Namespaces
Send Feedback

Namespaces

Namespace | Description
Autodesk.Revit.ApplicationServices |
Autodesk.Revit.Attributes |
Autodesk.Revit.Collections |
Autodesk.Revit.Creation |
Autodesk.Revit.DB |
Autodesk.Revit.DB.Analysis |
Autodesk.Revit.DB.Architecture |
Autodesk.Revit.DB.Electrical |
Autodesk.Revit.DB.Events |
Autodesk.Revit.DB.ExtensibleStorage |
Autodesk.Revit.DB.ExternalService |
Autodesk.Revit.DB.IFC |
Autodesk.Revit.DB.Lighting |
Autodesk.Revit.DB.Mechanical |
Autodesk.Revit.DB.Plumbing |
Autodesk.Revit.DB.PointClouds |
Autodesk.Revit.DB.Structure |
Autodesk.Revit.Exceptions |
Autodesk.Revit.UI |
Autodesk.Revit.UI.Events |
Autodesk.Revit.UI.Macros |
Autodesk.Revit.UI.Selection |
Autodesk.Revit.Utility |
February 2, 2012

Send comments on this topic to Autodesk


Autodesk.Revit.ApplicationServices Namespace

[image]

Revit 2013 API
Autodesk.Revit.ApplicationServices Namespace
Send Feedback

Classes

 | Class | Description
Public class | Application | Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class | ControlledApplication | Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Enumerations

 | Enumeration | Description
Public enumeration | LanguageType | An enumerated type containing the supported Revit product languages.
Public enumeration | ProductType | An enumerated type containing the possible Revit product types.


Application Class

[image]

Revit 2013 API
Application Class
Members Example See Also Send Feedback
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Application : IDisposable
Visual Basic
Public Class Application _
    Implements IDisposable
Visual C++
public ref class Application : IDisposable

Examples

CopyC#
string versionInfo = application.VersionBuild + "\n"
                    + application.VersionName + "\n"
                    + application.VersionNumber;
CopyVB.NET
Dim versionInfo As String = application.VersionBuild + vbLf + application.VersionName + vbLf + application.VersionNumber

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.ApplicationServices..::..Application

See Also

Application Members
Autodesk.Revit.ApplicationServices Namespace


Application Members

[image] [image]

Revit 2013 API
Application Members
Application Class Constructors Methods Properties Events See Also Send Feedback

The Application type exposes the following members.

Constructors

 | Name | Description
Public method | Application | Initializes a new instance of the Application class

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose | Releases all resources used by the Application
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenBuildingComponentDocument | Opens a Building Component document from disk.
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk.
Public method | OpenIFCDocument | Opens an IFC document from disk.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | Language | The language used in the current session of Revit.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Gets the vertex tolerance.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Constructor

[image]

Revit 2013 API
Application Constructor
Application Class See Also Send Feedback
Initializes a new instance of the Application class

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Application()
Visual Basic
Public Sub New
Visual C++
public:
Application()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Methods

[image] [image]

Revit 2013 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | CopyModel | Copies an existing model to a new file. Overwriting a file of the same name is allowed.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractPartAtomFromFamilyFile | Writes a PartAtom XML from the contents of a family file.
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetRevitServerNetworkHosts |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksharingCentralGUID | Gets the worksharing central GUID of the given server-based model.
Public method | NewFamilyDocument | New family document, including family, titleblock, and annotation symbol
Public method | NewProjectDocument | New project document
Public method | NewProjectTemplateDocument | New project template document
Public method | OpenBuildingComponentDocument | Opens a Building Component document from disk.
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk.
Public method | OpenIFCDocument | Opens an IFC document from disk.
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
Public method | PurgeReleasedAPIObjects | Explicitly purges all API objects that have been released but are still awaiting to be finalized
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CopyModel Method

[image]

Revit 2013 API
Application..::..CopyModel Method
Application Class See Also Send Feedback
Copies an existing model to a new file. Overwriting a file of the same name is allowed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void CopyModel(
    ModelPath sourceModelPath,
    string destFilePath,
    bool overwrite
)
Visual Basic
Public Sub CopyModel ( _
    sourceModelPath As ModelPath, _
    destFilePath As String, _
    overwrite As Boolean _
)
Visual C++
public:
void CopyModel(
    ModelPath^ sourceModelPath,
    String^ destFilePath,
    bool overwrite
)

Parameters

sourceModelPath
Type: Autodesk.Revit.DB..::..ModelPath
The path of the file-based or server-based source model.
destFilePath
Type: System..::..String
The path of the destination file.
overwrite
Type: System..::..Boolean
True if the destination file can be overwritten; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory of destination file doesn't exist.
Autodesk.Revit.Exceptions..::..FileArgumentAlreadyExistsException | The destination file exists and can't be overwritten. -or- destFilePath is the path of an existing folder, and cannot be overwritten with a copied file.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The Revit model specified by sourceModelPath doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The destination file name includes one or more invalid characters.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Thrown when there is any network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Thrown when there is any server internal error.
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException | Thrown when the server-based source model is being accessed by other users.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Dispose Method

[image]

Revit 2013 API
Application..::..Dispose Method
Application Class See Also Send Feedback
Releases all resources used by the Application

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ExtractPartAtomFromFamilyFile Method

[image]

Revit 2013 API
Application..::..ExtractPartAtomFromFamilyFile Method
Application Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ExtractPartAtomFromFamilyFile(
    string familyFilePath,
    string xmlFilePath
)
Visual Basic
Public Sub ExtractPartAtomFromFamilyFile ( _
    familyFilePath As String, _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtomFromFamilyFile(
    String^ familyFilePath,
    String^ xmlFilePath
)

Parameters

familyFilePath
Type: System..::..String
The family file to be processed.
xmlFilePath
Type: System..::..String
The xml file to be saved.

Remarks

If there is a TXT type catalog next to the family file (a TXT file with the same name as the RFA file), the function will read it as well and process its contents into PartAtom. To extract a PartAtom XML from a family loaded into a document in session, use Family.ExtractPartAtom().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'familyFilePath' or 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string or if the family file doesn't exist on disk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2013 API
Application..::..GetFailureDefinitionRegistry Method
Application Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetLibraryPaths Method

[image]

Revit 2013 API
Application..::..GetLibraryPaths Method
Application Class Example See Also Send Feedback
Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<string, string> GetLibraryPaths()
Visual Basic
Public Function GetLibraryPaths As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetLibraryPaths()

Return Value

The map of library paths.

Remarks

The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.LibraryPaths
    strLibPaths += path + vbLf
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetRevitServerNetworkHosts Method

[image]

Revit 2013 API
Application..::..GetRevitServerNetworkHosts Method
Application Class See Also Send Feedback

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<string> GetRevitServerNetworkHosts()
Visual Basic
Public Function GetRevitServerNetworkHosts As IList(Of String)
Visual C++
public:
IList<String^>^ GetRevitServerNetworkHosts()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


GetWorksharingCentralGUID Method

[image]

Revit 2013 API
Application..::..GetWorksharingCentralGUID Method
Application Class See Also Send Feedback
Gets the worksharing central GUID of the given server-based model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid GetWorksharingCentralGUID(
    ServerPath serverModelPath
)
Visual Basic
Public Function GetWorksharingCentralGUID ( _
    serverModelPath As ServerPath _
) As Guid
Visual C++
public:
Guid GetWorksharingCentralGUID(
    ServerPath^ serverModelPath
)

Parameters

serverModelPath
Type: Autodesk.Revit.DB..::..ServerPath
The server-based model path.

Return Value

The worksharing central GUID.

Remarks

The given server-based model saved in a release prior to Revit 2013 did not have this GUID. Only the given server-based model saved in Revit 2013 or later will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the given model is not created in Revit 2013 or later release.
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | Thrown when there is any network communication error.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | Thrown when there is any server internal error.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewFamilyDocument Method

[image]

Revit 2013 API
Application..::..NewFamilyDocument Method
Application Class Example See Also Send Feedback
New family document, including family, titleblock, and annotation symbol

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document NewFamilyDocument(
    string templateFileName
)
Visual Basic
Public Overridable Function NewFamilyDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewFamilyDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::..String
The template file name.

Remarks

This command corresponds to File->New->Family.../TitleBlock.../Annotation Symbol....

Examples

CopyC#
// create a new family document using Generic Model.rft template
string templateFileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft";
Document familyDocument = application.NewFamilyDocument(templateFileName);
if (null == familyDocument)
{
    throw new Exception("Cannot open family document");
}
CopyVB.NET
' create a new family document using Generic Model.rft template
Dim templateFileName As String = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Templates\Generic Model.rft"
Dim familyDocument As Document = application.NewFamilyDocument(templateFileName)
If familyDocument Is Nothing Then
    Throw New Exception("Cannot open family document")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the new family document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewProjectDocument Method

[image]

Revit 2013 API
Application..::..NewProjectDocument Method
Application Class See Also Send Feedback
New project document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document NewProjectDocument(
    string templateFileName
)
Visual Basic
Public Overridable Function NewProjectDocument ( _
    templateFileName As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectDocument(
    String^ templateFileName
)

Parameters

templateFileName
Type: System..::..String
The template file name.

Remarks

This command corresponds to New->Project command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the new project document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


NewProjectTemplateDocument Method

[image]

Revit 2013 API
Application..::..NewProjectTemplateDocument Method
Application Class See Also Send Feedback
New project template document

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document NewProjectTemplateDocument(
    string templateFilename
)
Visual Basic
Public Overridable Function NewProjectTemplateDocument ( _
    templateFilename As String _
) As Document
Visual C++
public:
virtual Document^ NewProjectTemplateDocument(
    String^ templateFilename
)

Parameters

templateFilename
Type: System..::..String
The template file name.

Remarks

This command corresponds to New->Project->Project Template command in the user-interface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'templateFileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the project template document cannot be created.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenBuildingComponentDocument Method

[image]

Revit 2013 API
Application..::..OpenBuildingComponentDocument Method
Application Class See Also Send Feedback
Opens a Building Component document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document OpenBuildingComponentDocument(
    string fileName
)
Visual Basic
Public Overridable Function OpenBuildingComponentDocument ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenBuildingComponentDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The Building Component file to be opened.

Remarks

The opened document is a family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName'.
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string or it is not an Autodesk Exchange file name.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the Building Component file cannot be opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method

[image] [image]

Revit 2013 API
Application..::..OpenDocumentFile Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenDocumentFile(String) | Opens a document from disk.
Public method | OpenDocumentFile(ModelPath, OpenOptions) | Opens a document from disk.

See Also

Application Class
Application Members
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method (String)

[image]

Revit 2013 API
Application..::..OpenDocumentFile Method (String)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document OpenDocumentFile(
    string fileName
)
Visual Basic
Public Overridable Function OpenDocumentFile ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The file to be opened.

Remarks

This method opens the document into memory but does not make it visible to the user in any way.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.
Autodesk.Revit.Exceptions..::..ApplicationException | If the file cannot be opened.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


OpenDocumentFile Method (ModelPath, OpenOptions)

[image]

Revit 2013 API
Application..::..OpenDocumentFile Method (ModelPath, OpenOptions)
Application Class See Also Send Feedback
Opens a document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual Document OpenDocumentFile(
    ModelPath modelPath,
    OpenOptions openOptions
)
Visual Basic
Public Overridable Function OpenDocumentFile ( _
    modelPath As ModelPath, _
    openOptions As OpenOptions _
) As Document
Visual C++
public:
virtual Document^ OpenDocumentFile(
    ModelPath^ modelPath,
    OpenOptions^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
The file to be opened.
openOptions
Type: Autodesk.Revit.DB..::..OpenOptions

Remarks

This method opens the document into memory but does not make it visible to the user in any way.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If 'modelPath' is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentNullException | If 'options' is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | If the modelPath is not a FilePath
Autodesk.Revit.Exceptions..::..ApplicationException | If the file cannot be opened.

See Also

Application Class
OpenDocumentFile Overload
Autodesk.Revit.ApplicationServices Namespace


OpenIFCDocument Method

[image]

Revit 2013 API
Application..::..OpenIFCDocument Method
Application Class See Also Send Feedback
Opens an IFC document from disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Document OpenIFCDocument(
    string fileName
)
Visual Basic
Public Overridable Function OpenIFCDocument ( _
    fileName As String _
) As Document
Visual C++
public:
virtual Document^ OpenIFCDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
The IFC file to be opened.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName'.
Autodesk.Revit.Exceptions..::..ArgumentException | If 'fileName' is an empty string.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | If the file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If Revit is missing document templates or if the file cannot be opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


OpenSharedParameterFile Method

[image]

Revit 2013 API
Application..::..OpenSharedParameterFile Method
Application Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file that exists on disk. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the file does not exist.

Remarks

This function is used to return an object that represents a Revit shared parameters file Revit can use only one shared parameters file at one time. The filename for the shared parameters file can be set in the Application.SharedParametersFilename property.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


PurgeReleasedAPIObjects Method

[image]

Revit 2013 API
Application..::..PurgeReleasedAPIObjects Method
Application Class See Also Send Feedback
Explicitly purges all API objects that have been released but are still awaiting to be finalized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void PurgeReleasedAPIObjects()
Visual Basic
Public Sub PurgeReleasedAPIObjects
Visual C++
public:
void PurgeReleasedAPIObjects()

Remarks

Revit purges API objects automatically every time when command control returns from an API application (an external command, event handler, etc.) back to Revit. This is necessary because Revit does not allow API objects to be finalized when the finalization is invoked from an outside thread (from the garbage collector, specifically). This automatic purging is adequate in most scenarios. When an application uses a lot of API objects during one single command though, it may be necessary or beneficial to invoke an additional purge explicitly to free the deleted API objects from memory.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


RegisterFailuresProcessor Method

[image]

Revit 2013 API
Application..::..RegisterFailuresProcessor Method
Application Class See Also Send Feedback
Registers Revit application-wide instance of Failures Processor.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::..IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear. If you want to handle only specific failures but not all types of failures in your application, subscribe to the FailuresProcessing event instead, or use FailuresPreprocessor interface for the specific transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SetLibraryPaths Method

[image]

Revit 2013 API
Application..::..SetLibraryPaths Method
Application Class See Also Send Feedback
Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Visual Basic
Public Sub SetLibraryPaths ( _
    paths As IDictionary(Of String, String) _
)
Visual C++
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of library paths.

Remarks

The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2013 API
Application..::..WriteJournalComment Method
Application Class See Also Send Feedback
Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::..String
Text for journal comment.
timeStamp
Type: System..::..Boolean
If a time stamp should be included in the journal comment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Properties

[image] [image]

Revit 2013 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Assets |
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | CurrentRevitServerAccelerator | Current Revit Server accelerator.
Public property | DefaultProjectTemplate | Full path to the default template file for new project documents.
Public property | DefaultViewDiscipline | The view discipline that will be applied to new views by default.
Public property | Documents | Returns a set of documents within Revit.
Public property | FamilyTemplatePath | Default path for family template files.
Public property | IsArchitectureEnabled | Checks whether or not the architecture discipline is enabled, and enable or disable it.
Public property | IsElectricalAnalysisEnabled | Checks whether or not electrical analysis is enabled, and enable or disable it.
Public property | IsElectricalEnabled | Checks whether or not the electrical discipline is enabled, and enable or disable it.
Public property | IsEnergyAnalysisEnabled | Checks whether or not energy analysis is enabled, and enable or disable it.
Public property | IsMassingEnabled | Checks whether or not the massing and site tools are enabled, and enable or disable them.
Public property | IsMechanicalAnalysisEnabled | Checks whether or not mechanical analysis is enabled, and enable or disable it.
Public property | IsMechanicalEnabled | Checks whether or not the mechanical discipline is enabled, and enable or disable it.
Public property | IsPipingAnalysisEnabled | Checks whether or not piping analysis is enabled, and enable or disable it.
Public property | IsPipingEnabled | Checks whether or not the piping discipline is enabled, and enable or disable it.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | IsStructuralAnalysisEnabled | Checks whether or not the structural analysis is enabled, and enable or disable it.
Public property | IsStructureEnabled | Checks whether or not the structure discipline is enabled, and enable or disable it.
Public property | IsSystemsEnabled | Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.
Public property | Language | The language used in the current session of Revit.
Public property | ObjectFactory | Provides an object that can be used to create other instances of Autodesk Revit API objects.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | ShowGraphicalWarningCableTrayConduitDisconnects | Whether or not to show the graphical warnings for CTC disconnects.
Public property | ShowGraphicalWarningDuctDisconnects | Whether or not to show the graphical warnings for duct disconnects.
Public property | ShowGraphicalWarningElectricalDisconnects | Whether or not to show the graphical warnings for Electrical disconnects.
Public property | ShowGraphicalWarningPipeDisconnects | Whether or not to show the graphical warnings for Pipe disconnects.
Public property | Username | Gets the user name for the current Revit session.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.
Public property | VertexTolerance | Gets the vertex tolerance.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ActiveAddInId Property

[image]

Revit 2013 API
Application..::..ActiveAddInId Property
Application Class See Also Send Feedback
Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

Remarks

The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return nullNothingnullptra null reference (Nothing in Visual Basic). If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Assets Property

[image]

Revit 2013 API
Application..::..Assets Property
Application Class See Also Send Feedback

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetSet this[
    AssetType
] { get; }
Visual Basic
Public ReadOnly Property Assets ( _
     As AssetType _
) As AssetSet
    Get
Visual C++
public:
property AssetSet^ Assets[AssetType ] {
    AssetSet^ get (AssetType );
}

Parameters

Type: Autodesk.Revit.Utility..::..AssetType

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2013 API
Application..::..Cities Property
Application Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic
Public ReadOnly Property Cities As CitySet
    Get
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2013 API
Application..::..Create Property
Application Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic
Public ReadOnly Property Create As Application
    Get
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


CurrentRevitServerAccelerator Property

[image]

Revit 2013 API
Application..::..CurrentRevitServerAccelerator Property
Application Class See Also Send Feedback
Current Revit Server accelerator.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string CurrentRevitServerAccelerator { get; set; }
Visual Basic
Public Property CurrentRevitServerAccelerator As String
    Get
    Set
Visual C++
public:
property String^ CurrentRevitServerAccelerator {
    String^ get ();
    void set (String^ value);
}

Remarks

Revit connects with Revit Server hosts via current Revit Server accelerator. If current Revit Server accelerator is not set, this will be an empty string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The server name can not be used to construct a well formed Uri string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: When setting the value, Revit failed to write current Revit Server accelerator to the user environment.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DefaultProjectTemplate Property

[image]

Revit 2013 API
Application..::..DefaultProjectTemplate Property
Application Class See Also Send Feedback
Full path to the default template file for new project documents.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string DefaultProjectTemplate { get; }
Visual Basic
Public ReadOnly Property DefaultProjectTemplate As String
    Get
Visual C++
public:
property String^ DefaultProjectTemplate {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DefaultViewDiscipline Property

[image]

Revit 2013 API
Application..::..DefaultViewDiscipline Property
Application Class See Also Send Feedback
The view discipline that will be applied to new views by default.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewDiscipline DefaultViewDiscipline { get; set; }
Visual Basic
Public Property DefaultViewDiscipline As ViewDiscipline
    Get
    Set
Visual C++
public:
property ViewDiscipline DefaultViewDiscipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}

Remarks

This view discipline may be overridden by a view template when a view template is also applied to new views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This functionality is not available in Revit LT.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Documents Property

[image]

Revit 2013 API
Application..::..Documents Property
Application Class See Also Send Feedback
Returns a set of documents within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DocumentSet Documents { get; }
Visual Basic
Public Overridable ReadOnly Property Documents As DocumentSet
    Get
Visual C++
public:
virtual property DocumentSet^ Documents {
    DocumentSet^ get ();
}

Remarks

This property can be used for the user to find all the document inside Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FamilyTemplatePath Property

[image]

Revit 2013 API
Application..::..FamilyTemplatePath Property
Application Class See Also Send Feedback
Default path for family template files.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string FamilyTemplatePath { get; }
Visual Basic
Public ReadOnly Property FamilyTemplatePath As String
    Get
Visual C++
public:
property String^ FamilyTemplatePath {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsArchitectureEnabled Property

[image]

Revit 2013 API
Application..::..IsArchitectureEnabled Property
Application Class See Also Send Feedback
Checks whether or not the architecture discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsArchitectureEnabled { get; set; }
Visual Basic
Public Property IsArchitectureEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsArchitectureEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsElectricalAnalysisEnabled Property

[image]

Revit 2013 API
Application..::..IsElectricalAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not electrical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsElectricalAnalysisEnabled { get; set; }
Visual Basic
Public Property IsElectricalAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsElectricalAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling electrical analysis will not take effect unless the electrical discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsElectricalEnabled Property

[image]

Revit 2013 API
Application..::..IsElectricalEnabled Property
Application Class See Also Send Feedback
Checks whether or not the electrical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsElectricalEnabled { get; set; }
Visual Basic
Public Property IsElectricalEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsElectricalEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsEnergyAnalysisEnabled Property

[image]

Revit 2013 API
Application..::..IsEnergyAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not energy analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsEnergyAnalysisEnabled { get; set; }
Visual Basic
Public Property IsEnergyAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnergyAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMassingEnabled Property

[image]

Revit 2013 API
Application..::..IsMassingEnabled Property
Application Class See Also Send Feedback
Checks whether or not the massing and site tools are enabled, and enable or disable them.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMassingEnabled { get; set; }
Visual Basic
Public Property IsMassingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMassingEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMechanicalAnalysisEnabled Property

[image]

Revit 2013 API
Application..::..IsMechanicalAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not mechanical analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMechanicalAnalysisEnabled { get; set; }
Visual Basic
Public Property IsMechanicalAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMechanicalAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling mechanical analysis will not take effect unless the mechanical discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsMechanicalEnabled Property

[image]

Revit 2013 API
Application..::..IsMechanicalEnabled Property
Application Class See Also Send Feedback
Checks whether or not the mechanical discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMechanicalEnabled { get; set; }
Visual Basic
Public Property IsMechanicalEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsMechanicalEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsPipingAnalysisEnabled Property

[image]

Revit 2013 API
Application..::..IsPipingAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not piping analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPipingAnalysisEnabled { get; set; }
Visual Basic
Public Property IsPipingAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPipingAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

Enabling piping analysis will not take effect unless the piping discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsPipingEnabled Property

[image]

Revit 2013 API
Application..::..IsPipingEnabled Property
Application Class See Also Send Feedback
Checks whether or not the piping discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPipingEnabled { get; set; }
Visual Basic
Public Property IsPipingEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsPipingEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsQuiescent Property

[image]

Revit 2013 API
Application..::..IsQuiescent Property
Application Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic
Public ReadOnly Property IsQuiescent As Boolean
    Get
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in the current application is in editing mode or an In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsStructuralAnalysisEnabled Property

[image]

Revit 2013 API
Application..::..IsStructuralAnalysisEnabled Property
Application Class See Also Send Feedback
Checks whether or not the structural analysis is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsStructuralAnalysisEnabled { get; set; }
Visual Basic
Public Property IsStructuralAnalysisEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsStructuralAnalysisEnabled {
    bool get ();
    void set (bool value);
}

Remarks

When structural analysis is disabled the structural analytical model will not be updated automatically by Revit. Enabling structural analysis will not take effect unless the structure discipline is also enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsStructureEnabled Property

[image]

Revit 2013 API
Application..::..IsStructureEnabled Property
Application Class See Also Send Feedback
Checks whether or not the structure discipline is enabled, and enable or disable it.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsStructureEnabled { get; set; }
Visual Basic
Public Property IsStructureEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsStructureEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property:

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


IsSystemsEnabled Property

[image]

Revit 2013 API
Application..::..IsSystemsEnabled Property
Application Class See Also Send Feedback
Checks whether or not any systems disciplines (mechanical, electrical, or piping) are enabled.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSystemsEnabled { get; }
Visual Basic
Public ReadOnly Property IsSystemsEnabled As Boolean
    Get
Visual C++
public:
property bool IsSystemsEnabled {
    bool get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2013 API
Application..::..Language Property
Application Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic
Public ReadOnly Property Language As LanguageType
    Get
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ObjectFactory Property

[image]

Revit 2013 API
Application..::..ObjectFactory Property
Application Class See Also Send Feedback
Provides an object that can be used to create other instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ObjectFactory ObjectFactory { get; }
Visual Basic
Public ReadOnly Property ObjectFactory As ObjectFactory
    Get
Visual C++
public:
property ObjectFactory^ ObjectFactory {
    ObjectFactory^ get ();
}

Remarks

Returns an object factory object that can create other objects. This property is available for advanced use cases only. For general purpose creation of Autodesk Revit API objects use the Application.Create object.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2013 API
Application..::..Product Property
Application Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2013 API
Application..::..RecordingJournalFilename Property
Application Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic
Public ReadOnly Property RecordingJournalFilename As String
    Get
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


SharedParametersFilename Property

[image]

Revit 2013 API
Application..::..SharedParametersFilename Property
Application Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic
Public Property SharedParametersFilename As String
    Get
    Set
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningCableTrayConduitDisconnects Property

[image]

Revit 2013 API
Application..::..ShowGraphicalWarningCableTrayConduitDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for CTC disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningCableTrayConduitDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningCableTrayConduitDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningCableTrayConduitDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningDuctDisconnects Property

[image]

Revit 2013 API
Application..::..ShowGraphicalWarningDuctDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for duct disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningDuctDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningDuctDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningDuctDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningElectricalDisconnects Property

[image]

Revit 2013 API
Application..::..ShowGraphicalWarningElectricalDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for Electrical disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningElectricalDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningElectricalDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningElectricalDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ShowGraphicalWarningPipeDisconnects Property

[image]

Revit 2013 API
Application..::..ShowGraphicalWarningPipeDisconnects Property
Application Class See Also Send Feedback
Whether or not to show the graphical warnings for Pipe disconnects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ShowGraphicalWarningPipeDisconnects { get; set; }
Visual Basic
Public Property ShowGraphicalWarningPipeDisconnects As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGraphicalWarningPipeDisconnects {
    bool get ();
    void set (bool value);
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Username Property

[image]

Revit 2013 API
Application..::..Username Property
Application Class See Also Send Feedback
Gets the user name for the current Revit session.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get
Visual C++
public:
property String^ Username {
    String^ get ();
}

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2013 API
Application..::..VersionBuild Property
Application Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic
Public ReadOnly Property VersionBuild As String
    Get
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2013 API
Application..::..VersionName Property
Application Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic
Public ReadOnly Property VersionName As String
    Get
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2013 API
Application..::..VersionNumber Property
Application Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic
Public ReadOnly Property VersionNumber As String
    Get
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


VertexTolerance Property

[image]

Revit 2013 API
Application..::..VertexTolerance Property
Application Class See Also Send Feedback
Gets the vertex tolerance.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double VertexTolerance { get; }
Visual Basic
Public ReadOnly Property VertexTolerance As Double
    Get
Visual C++
public:
property double VertexTolerance {
    double get ();
}

Remarks

Two points within this distance are considered coincident.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


Application Events

[image] [image]

Revit 2013 API
Application Events
Application Class See Also Send Feedback

The Application type exposes the following members.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ApplicationInitialized Event

[image]

Revit 2013 API
Application..::..ApplicationInitialized Event
Application Class See Also Send Feedback
Subscribe to this event to get notified after the Revit application has been initialized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<ApplicationInitializedEventArgs> ApplicationInitialized
Visual Basic
Public Event ApplicationInitialized As EventHandler(Of ApplicationInitializedEventArgs)
Visual C++
public:
 event EventHandler<ApplicationInitializedEventArgs^>^ ApplicationInitialized {
    void add (EventHandler<ApplicationInitializedEventArgs^>^ value);
    void remove (EventHandler<ApplicationInitializedEventArgs^>^ value);
}

Remarks

The event is raised after Revit was launched as fully initialized, including initialization of external applications.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentChanged Event

[image]

Revit 2013 API
Application..::..DocumentChanged Event
Application Class See Also Send Feedback
Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Visual Basic
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
Visual C++
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}

Remarks

This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosed Event

[image]

Revit 2013 API
Application..::..DocumentClosed Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosing Event

[image]

Revit 2013 API
Application..::..DocumentClosing Event
Application Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

An DocumentClosed event will be raised immediately after document is closed.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2013 API
Application..::..DocumentCreated Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2013 API
Application..::..DocumentCreating Event
Application Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2013 API
Application..::..DocumentOpened Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        Transaction transaction = new Transaction(doc, "Edit Address");
        if (transaction.Start() == TransactionStatus.Started)
        {
            doc.ProjectInformation.Address =
                "United States - Massachusetts - Waltham - 1560 Trapelo Road";
            transaction.Commit();
        }
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Dim transaction As New Transaction(doc, "Edit Address")
        If transaction.Start() = TransactionStatus.Started Then
            doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
            transaction.Commit()
        End If
    End Sub

    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpening Event

[image]

Revit 2013 API
Application..::..DocumentOpening Event
Application Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2013 API
Application..::..DocumentPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        Application app = sender as Application;
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (0 == args.GetFailedViewElementIds().Count || 0 == args.GetPrintedViewElementIds().Count)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", ref info);
        }
        //
        // FailedViews
        if (0 == args.GetFailedViewElementIds().Count)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " + args.Status.ToString())
        info.AppendLine("    Event Cancellable : " + args.Cancellable)
        '
        ' PrintedViews
        If args.FailedViews Is Nothing OrElse 0 = args.PrintedViews.Size Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(args.PrintedViews, "      ", info)
        End If
        '
        ' FailedViews
        If args.FailedViews Is Nothing OrElse 0 = args.FailedViews.Size Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(args.FailedViews, "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2013 API
Application..::..DocumentPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        Application app = sender as Application;
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
            DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " + args.Cancellable)
        info.AppendLine("    Views to be printed : ")
        ' Views
        DumpViewsInfo(args.Views, "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2013 API
Application..::..DocumentSaved Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2013 API
Application..::..DocumentSavedAs Event
Application Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2013 API
Application..::..DocumentSaving Event
Application Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavingAs Event

[image]

Revit 2013 API
Application..::..DocumentSavingAs Event
Application Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel();
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(ByVal sender As [Object], ByVal args As Autodesk.Revit.DB.Events.DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel = True
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2013 API
Application..::..DocumentSynchronizedWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2013 API
Application..::..DocumentSynchronizingWithCentral Event
Application Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2013 API
Application..::..FailuresProcessing Event
Application Class Example See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using provided restricted failures accessor interface.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)]

public class NoUnenclosedRoomWarnings : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

    public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication uiControlledApplication)
    {
        //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
        return Result.Succeeded;
    }

    public Autodesk.Revit.UI.Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
    {
        FailuresAccessor fa = e.GetFailuresAccessor();
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                fa.DeleteWarning(failure);
            }
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)> _
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(ByVal uiControlledApplication As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += New EventHandler < FailuresProcessingEventArgs > (CheckWarnings)
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(ByVal sender As Object, ByVal e As Autodesk.Revit.DB.Events.FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2013 API
Application..::..FileExported Event
Application Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileExporting Event

[image]

Revit 2013 API
Application..::..FileExporting Event
Application Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileImported Event

[image]

Revit 2013 API
Application..::..FileImported Event
Application Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2013 API
Application..::..FileImporting Event
Application Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ProgressChanged Event

[image]

Revit 2013 API
Application..::..ProgressChanged Event
Application Class See Also Send Feedback
Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<ProgressChangedEventArgs> ProgressChanged
Visual Basic
Public Event ProgressChanged As EventHandler(Of ProgressChangedEventArgs)
Visual C++
public:
 event EventHandler<ProgressChangedEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProgressChangedEventArgs^>^ value);
    void remove (EventHandler<ProgressChangedEventArgs^>^ value);
}

Remarks

Handlers of this event may use the Cancel()()()() method to cancel the operation tracked by the progress bar. Users may not change the document in the handler for this event. Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2013 API
Application..::..ViewPrinted Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " + args.Status)
        info.AppendLine("    TotalViews          : " + args.TotalViews)
        info.AppendLine("    View Index          : " + args.Index)
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2013 API
Application..::..ViewPrinting Event
Application Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & args.Cancellable.ToString())
        info.AppendLine("    TotalViews          : " & args.TotalViews.ToString())
        info.AppendLine("    View Index          : " & args.Index.ToString())
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

Application Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Class

[image]

Revit 2013 API
ControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ControlledApplication
Visual Basic
Public Class ControlledApplication
Visual C++
public ref class ControlledApplication

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.ApplicationServices..::..ControlledApplication

See Also

ControlledApplication Members
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Members

[image] [image]

Revit 2013 API
ControlledApplication Members
ControlledApplication Class Methods Properties Events See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Methods

[image] [image]

Revit 2013 API
ControlledApplication Methods
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFailureDefinitionRegistry | Returns the instance of FailureDefinitionRegistry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLibraryPaths | Returns path information identifying where Revit searches for content.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenSharedParameterFile | Enables access to shared parameter groups and definitions that are maintained on disk.
 | RegisterFailuresProcessor | Registers Revit application-wide instance of Failures Processor.
Public method | SetLibraryPaths | Sets path information identifying where Revit searches for content.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteJournalComment | Writes a comment to the Revit journal file.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


GetFailureDefinitionRegistry Method

[image]

Revit 2013 API
ControlledApplication..::..GetFailureDefinitionRegistry Method
ControlledApplication Class See Also Send Feedback
Returns the instance of FailureDefinitionRegistry.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinitionRegistry GetFailureDefinitionRegistry()
Visual Basic
Public Shared Function GetFailureDefinitionRegistry As FailureDefinitionRegistry
Visual C++
public:
static FailureDefinitionRegistry^ GetFailureDefinitionRegistry()

Return Value

The instance of FailureDefinitionRegistry.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


GetLibraryPaths Method

[image]

Revit 2013 API
ControlledApplication..::..GetLibraryPaths Method
ControlledApplication Class Example See Also Send Feedback
Returns path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<string, string> GetLibraryPaths()
Visual Basic
Public Function GetLibraryPaths As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetLibraryPaths()

Return Value

The map of library paths.

Remarks

The map that is returned contains a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path that is used for that search path.

Examples

CopyC#
string strLibPaths = "";
foreach (String path in application.GetLibraryPaths().Values)
{
    strLibPaths += path + "\n";
}
CopyVB.NET
Dim strLibPaths As String = ""
For Each path As [String] In application.LibraryPaths
    strLibPaths += path + vbLf
Next

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


OpenSharedParameterFile Method

[image]

Revit 2013 API
ControlledApplication..::..OpenSharedParameterFile Method
ControlledApplication Class See Also Send Feedback
Enables access to shared parameter groups and definitions that are maintained on disk.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionFile OpenSharedParameterFile()
Visual Basic
Public Function OpenSharedParameterFile As DefinitionFile
Visual C++
public:
DefinitionFile^ OpenSharedParameterFile()

Return Value

An object that represents a shared parameters file that exists on disk. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the file does not exist.

Remarks

This function is used to return an object that represents a Revit shared parameters file Revit can use only one shared parameters file at one time. The filename for the shared parameters file can be set in the Application.SharedParametersFilename property.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RegisterFailuresProcessor Method

[image]

Revit 2013 API
ControlledApplication..::..RegisterFailuresProcessor Method
ControlledApplication Class See Also Send Feedback
Registers Revit application-wide instance of Failures Processor.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void RegisterFailuresProcessor(
    IFailuresProcessor processor
)
Visual Basic
Public Shared Sub RegisterFailuresProcessor ( _
    processor As IFailuresProcessor _
)
Visual C++
public:
static void RegisterFailuresProcessor(
    IFailuresProcessor^ processor
)

Parameters

processor
Type: Autodesk.Revit.DB..::..IFailuresProcessor
Instance of Failures Processor to be used by the Revit Application.

Remarks

If there is previously registered Failures Processor, it gets discarded. If you opt to register a FailuresProcessor for Revit, your processor will become the default error handler for all Revit errors for the session. The standard Revit error dialog will not appear. If you want to handle only specific failures but not all types of failures in your application, subscribe to the FailuresProcessing event instead, or use FailuresPreprocessor interface for the specific transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SetLibraryPaths Method

[image]

Revit 2013 API
ControlledApplication..::..SetLibraryPaths Method
ControlledApplication Class See Also Send Feedback
Sets path information identifying where Revit searches for content.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetLibraryPaths(
    IDictionary<string, string> paths
)
Visual Basic
Public Sub SetLibraryPaths ( _
    paths As IDictionary(Of String, String) _
)
Visual C++
public:
void SetLibraryPaths(
    IDictionary<String^, String^>^ paths
)

Parameters

paths
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of library paths.

Remarks

The map that is returned should contain a key that is purpose of the path, such as Material Libraries and the value in the map is the fully qualified path to be used for that search path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


WriteJournalComment Method

[image]

Revit 2013 API
ControlledApplication..::..WriteJournalComment Method
ControlledApplication Class See Also Send Feedback
Writes a comment to the Revit journal file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void WriteJournalComment(
    string comment,
    bool timeStamp
)
Visual Basic
Public Sub WriteJournalComment ( _
    comment As String, _
    timeStamp As Boolean _
)
Visual C++
public:
void WriteJournalComment(
    String^ comment,
    bool timeStamp
)

Parameters

comment
Type: System..::..String
Text for journal comment.
timeStamp
Type: System..::..Boolean
If a time stamp should be included in the journal comment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Properties

[image] [image]

Revit 2013 API
ControlledApplication Properties
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Retrieves the Id of the currently running external application.
Public property | Cities | Returns a set of all the known city locations within Revit.
Public property | Create | Provides an object that can be used to create new instances of Autodesk Revit API objects.
Public property | IsQuiescent | Returns if the current application is quiescent.
Public property | Language | The language used in the current session of Revit.
Public property | Product | The product type for the current session of Revit.
Public property | RecordingJournalFilename | Retrieve the name of the journal file the Revit is currently recording to.
Public property | SharedParametersFilename | Contains the fully qualified path to a shared parameters file.
Public property | VersionBuild | Returns the internal build number of the Autodesk Revit application.
Public property | VersionName | Returns the name of the Revit application.
Public property | VersionNumber | Return the primary version of the Revit application.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ActiveAddInId Property

[image]

Revit 2013 API
ControlledApplication..::..ActiveAddInId Property
ControlledApplication Class See Also Send Feedback
Retrieves the Id of the currently running external application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

Remarks

The application can be either a UI application, DB application, or an external command. If no addin is active, this property will return nullNothingnullptra null reference (Nothing in Visual Basic). If an event handler is currently being executed, the returned value will be the Id of the application or command in which the event handler was registered.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Cities Property

[image]

Revit 2013 API
ControlledApplication..::..Cities Property
ControlledApplication Class Example See Also Send Feedback
Returns a set of all the known city locations within Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CitySet Cities { get; }
Visual Basic
Public ReadOnly Property Cities As CitySet
    Get
Visual C++
public:
property CitySet^ Cities {
    CitySet^ get ();
}

Remarks

Each city has information about longitude, latitude etc.

Examples

CopyC#
// Get all Revit support cities
Autodesk.Revit.DB.CitySet cities = application.Cities;

// Set all Revit support cities into an ArrayList
System.Collections.ArrayList cityList = new System.Collections.ArrayList();
foreach (Autodesk.Revit.DB.City city in cities)
{
    cityList.Add(city);
}
CopyVB.NET
' Get all Revit support cities
Dim cities As Autodesk.Revit.DB.CitySet = application.Cities

' Set all Revit support cities into an ArrayList
Dim cityList As New System.Collections.ArrayList()
For Each city As Autodesk.Revit.DB.City In cities
    cityList.Add(city)
Next

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Create Property

[image]

Revit 2013 API
ControlledApplication..::..Create Property
ControlledApplication Class See Also Send Feedback
Provides an object that can be used to create new instances of Autodesk Revit API objects.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Application Create { get; }
Visual Basic
Public ReadOnly Property Create As Application
    Get
Visual C++
public:
property Application^ Create {
    Application^ get ();
}

Remarks

The Create property returns an object that is used to create application wide utility and geometric objects within the Autodesk Revit API, such as arrays, sets, lines. This object should be used when you wish to create an object within the Autodesk Revit application memory, rather than your own application's memory. If you are performing your own memory management techniques then it is advisable to create any utility objects via the Create object. For example: Instead of Dim set As New Autodesk_Revit_ElementSet do Set set = application.Create.NewElementSet()

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


IsQuiescent Property

[image]

Revit 2013 API
ControlledApplication..::..IsQuiescent Property
ControlledApplication Class See Also Send Feedback
Returns if the current application is quiescent.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsQuiescent { get; }
Visual Basic
Public ReadOnly Property IsQuiescent As Boolean
    Get
Visual C++
public:
property bool IsQuiescent {
    bool get ();
}

Remarks

This property can be used check if the current application is quiescent. If any document in the current application is in editing mode or an In-place family is being edited, it returns false. Otherwise, true will be returned.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Language Property

[image]

Revit 2013 API
ControlledApplication..::..Language Property
ControlledApplication Class See Also Send Feedback
The language used in the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LanguageType Language { get; }
Visual Basic
Public ReadOnly Property Language As LanguageType
    Get
Visual C++
public:
property LanguageType Language {
    LanguageType get ();
}

Remarks

Use this property to determine the language used by Revit; this can allow your application to load the appropriate resources.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


Product Property

[image]

Revit 2013 API
ControlledApplication..::..Product Property
ControlledApplication Class See Also Send Feedback
The product type for the current session of Revit.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProductType Product { get; }
Visual Basic
Public ReadOnly Property Product As ProductType
    Get
Visual C++
public:
property ProductType Product {
    ProductType get ();
}

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


RecordingJournalFilename Property

[image]

Revit 2013 API
ControlledApplication..::..RecordingJournalFilename Property
ControlledApplication Class See Also Send Feedback
Retrieve the name of the journal file the Revit is currently recording to.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string RecordingJournalFilename { get; }
Visual Basic
Public ReadOnly Property RecordingJournalFilename As String
    Get
Visual C++
public:
property String^ RecordingJournalFilename {
    String^ get ();
}

Remarks

As Revit operates it keeps a log of operations that the user performs within a file, known as a journal file. These files provide information about the actions performed in a session and the state of Revit when a problem occurs. These files are included during error reporting to Autodesk.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


SharedParametersFilename Property

[image]

Revit 2013 API
ControlledApplication..::..SharedParametersFilename Property
ControlledApplication Class See Also Send Feedback
Contains the fully qualified path to a shared parameters file.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string SharedParametersFilename { get; set; }
Visual Basic
Public Property SharedParametersFilename As String
    Get
    Set
Visual C++
public:
property String^ SharedParametersFilename {
    String^ get ();
    void set (String^ value);
}

Remarks

This path can be read and set via this property. By default Autodesk Revit does not have a shared parameters file so this property must be set before access is made to the shared parameters file object otherwise an exception will be thrown.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionBuild Property

[image]

Revit 2013 API
ControlledApplication..::..VersionBuild Property
ControlledApplication Class See Also Send Feedback
Returns the internal build number of the Autodesk Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionBuild { get; }
Visual Basic
Public ReadOnly Property VersionBuild As String
    Get
Visual C++
public:
property String^ VersionBuild {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Autodesk Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Autodesk Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionName Property

[image]

Revit 2013 API
ControlledApplication..::..VersionName Property
ControlledApplication Class See Also Send Feedback
Returns the name of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionName { get; }
Visual Basic
Public ReadOnly Property VersionName As String
    Get
Visual C++
public:
property String^ VersionName {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


VersionNumber Property

[image]

Revit 2013 API
ControlledApplication..::..VersionNumber Property
ControlledApplication Class See Also Send Feedback
Return the primary version of the Revit application.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string VersionNumber { get; }
Visual Basic
Public ReadOnly Property VersionNumber As String
    Get
Visual C++
public:
property String^ VersionNumber {
    String^ get ();
}

Remarks

This property can be used by your application to find the version of Revit against which your application is running. Based on this information your application can report if it is able to work correctly with that version of Revit.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ControlledApplication Events

[image] [image]

Revit 2013 API
ControlledApplication Events
ControlledApplication Class See Also Send Feedback

The ControlledApplication type exposes the following members.

Events

 | Name | Description
Public event | ApplicationInitialized | Subscribe to this event to get notified after the Revit application has been initialized
Public event | DocumentChanged | Subscribe to the DocumentChanged event to be notified when Revit document has changed.
Public event | DocumentClosed | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentCreated | Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.
Public event | DocumentCreating | Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.
Public event | DocumentOpened | Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.
Public event | DocumentOpening | Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | DocumentSynchronizedWithCentral | Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.
Public event | DocumentSynchronizingWithCentral | Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.
Public event | FailuresProcessing | Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.
Public event | FileExported | Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.
Public event | FileExporting | Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.
Public event | FileImported | Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.
Public event | FileImporting | Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.
Public event | ProgressChanged | Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ApplicationInitialized Event

[image]

Revit 2013 API
ControlledApplication..::..ApplicationInitialized Event
ControlledApplication Class See Also Send Feedback
Subscribe to this event to get notified after the Revit application has been initialized

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<ApplicationInitializedEventArgs> ApplicationInitialized
Visual Basic
Public Event ApplicationInitialized As EventHandler(Of ApplicationInitializedEventArgs)
Visual C++
public:
 event EventHandler<ApplicationInitializedEventArgs^>^ ApplicationInitialized {
    void add (EventHandler<ApplicationInitializedEventArgs^>^ value);
    void remove (EventHandler<ApplicationInitializedEventArgs^>^ value);
}

Remarks

The event is raised after Revit was launched as fully initialized, including initialization of external applications.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentChanged Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentChanged Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentChanged event to be notified when Revit document has changed.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<DocumentChangedEventArgs> DocumentChanged
Visual Basic
Public Event DocumentChanged As EventHandler(Of DocumentChangedEventArgs)
Visual C++
public:
 event EventHandler<DocumentChangedEventArgs^>^ DocumentChanged {
    void add (EventHandler<DocumentChangedEventArgs^>^ value);
    void remove (EventHandler<DocumentChangedEventArgs^>^ value);
}

Remarks

This event is raised whenever a Revit transaction is either committed, undone or redone. This is a readonly event, designed to allow you to keep external data in synch with the state of the Revit database. To update the Revit database in response to changes in elements, use the IUpdater framework.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosed Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentClosed Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosedEventArgs> DocumentClosed
Visual Basic
Public Event DocumentClosed As EventHandler(Of DocumentClosedEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosedEventArgs^>^ DocumentClosed {
    void add (EventHandler<DocumentClosedEventArgs^>^ value);
    void remove (EventHandler<DocumentClosedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentClosing Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentClosing Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

An DocumentClosed event will be raised immediately after document is closed.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreated Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentCreated Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreated event to be notified immediately after Revit has finished creating a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatedEventArgs> DocumentCreated
Visual Basic
Public Event DocumentCreated As EventHandler(Of DocumentCreatedEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatedEventArgs^>^ DocumentCreated {
    void add (EventHandler<DocumentCreatedEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished creating a new document. It is raised even when document creation failed or was cancelled (during DocumentCreating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. This event is not cancellable, for the process of document creation has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentCreating Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentCreating Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentCreating event to be notified when Revit is just about to create a new document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentCreatingEventArgs> DocumentCreating
Visual Basic
Public Event DocumentCreating As EventHandler(Of DocumentCreatingEventArgs)
Visual C++
public:
 event EventHandler<DocumentCreatingEventArgs^>^ DocumentCreating {
    void add (EventHandler<DocumentCreatingEventArgs^>^ value);
    void remove (EventHandler<DocumentCreatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to create a new document.

Event is cancellable. To cancel it, call the 'Cancel()' method of event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not created yet at the time of the event.

The following API functions are not available for the current document during this event:

  • NewProjectDocument(String)
  • NewFamilyDocument(String)
  • NewProjectTemplateDocument(String)
  • OpenDocumentFile(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentCreated event will be raised immediately after document creation is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpened Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentOpened Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentOpened event to be notified immediately after Revit has finished opening a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpenedEventArgs> DocumentOpened
Visual Basic
Public Event DocumentOpened As EventHandler(Of DocumentOpenedEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpenedEventArgs^>^ DocumentOpened {
    void add (EventHandler<DocumentOpenedEventArgs^>^ value);
    void remove (EventHandler<DocumentOpenedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished opening a document. It is raised even when document opening failed or was cancelled (during DocumentOpening event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of opening document has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentOpened : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement this method to subscribe to event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        try
        {
            // Register event.
           application.ControlledApplication.DocumentOpened += new EventHandler
                <Autodesk.Revit.DB.Events.DocumentOpenedEventArgs>(application_DocumentOpened);
        }
        catch (Exception)
        {
            return Result.Failed;
        }

        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // remove the event.
       application.ControlledApplication.DocumentOpened -= application_DocumentOpened;
        return Result.Succeeded;
    }

    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentOpened class description
    /// </TrivialCode>

    /// <description>
    /// This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    /// </description>
    /// <summary>
    /// This is the event handler. We modify the model.
    /// </summary>
    /// <param name="sender">Event sender.</param>
    /// <param name="args"></param>
    public void application_DocumentOpened(object sender, DocumentOpenedEventArgs args)
    {
        // get document from event args.
        Document doc = args.Document;

        // Following code snippet demonstrates support of DocumentOpened event to modify the model.
        // Because DocumentOpened supports model changes, it allows user to update document data.
        // Here, this sample assigns a specified value to ProjectInformation.Address property.
        // User can change other properties of document or create(delete) something as he likes.
        //
        // Please note that ProjectInformation property is empty for family document.
        // So please don't run this sample on family document.
        Transaction transaction = new Transaction(doc, "Edit Address");
        if (transaction.Start() == TransactionStatus.Started)
        {
            doc.ProjectInformation.Address =
                "United States - Massachusetts - Waltham - 1560 Trapelo Road";
            transaction.Commit();
        }
    }

    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentOpened
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement this method to subscribe to event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        Try
            ' Register event.
            AddHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Catch generatedExceptionName As Exception
            Return Result.Failed
        End Try

        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' remove the event.
        RemoveHandler application.ControlledApplication.DocumentOpened, AddressOf application_DocumentOpened
        Return Result.Succeeded
    End Function

    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentOpened class description
    ' </TrivialCode>

    ' <description>
    ' This sample demonstrates how to subscribe to the DocumentOpened event and modify the model in the event handler method.
    ' </description>
    ' <summary>
    ' This is the event handler. We modify the model.
    ' </summary>
    ' <param name="sender">Event sender.</param>
    ' <param name="args"></param>
    Public Sub application_DocumentOpened(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentOpenedEventArgs)
        ' get document from event args.
        Dim doc As Document = args.Document

        ' Following code snippet demonstrates support of DocumentOpened event to modify the model.
        ' Because DocumentOpened supports model changes, it allows user to update document data.
        ' Here, this sample assigns a specified value to ProjectInformation.Address property.
        ' User can change other properties of document or create(delete) something as he likes.
        '
        ' Please note that ProjectInformation property is empty for family document.
        ' So please don't run this sample on family document.
        Dim transaction As New Transaction(doc, "Edit Address")
        If transaction.Start() = TransactionStatus.Started Then
            doc.ProjectInformation.Address = "United States - Massachusetts - Waltham - 1560 Trapelo Road"
            transaction.Commit()
        End If
    End Sub

    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentOpening Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentOpening Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentOpening event to be notified when Revit is just about to open a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentOpeningEventArgs> DocumentOpening
Visual Basic
Public Event DocumentOpening As EventHandler(Of DocumentOpeningEventArgs)
Visual C++
public:
 event EventHandler<DocumentOpeningEventArgs^>^ DocumentOpening {
    void add (EventHandler<DocumentOpeningEventArgs^>^ value);
    void remove (EventHandler<DocumentOpeningEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to open a document.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document cannot be modified, for it is not opened yet at the time of the event.

Another DocumentOpened event will be raised immediately after document is opened.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinted Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DocumentPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinted += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinted -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintedEventArgs>(AppDocumentPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinted event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinted(object sender, Autodesk.Revit.DB.Events.DocumentPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        Application app = sender as Application;
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status      : " + args.Status.ToString());
        info.AppendLine("    Event Cancellable : " + args.Cancellable);
        //
        // PrintedViews
        if (0 == args.GetFailedViewElementIds().Count || 0 == args.GetPrintedViewElementIds().Count)
        {
            info.AppendLine("    Views been printed: <null>");
        }
        else
        {
            info.AppendLine("    Views been printed: ");
            DumpViewsInfo(app, args.GetPrintedViewElementIds(), "      ", ref info);
        }
        //
        // FailedViews
        if (0 == args.GetFailedViewElementIds().Count)
        {
            info.AppendLine("    Views failed: <null>");
        }
        else
        {
            info.AppendLine("    Views Failed : ");
            DumpViewsInfo(app, args.GetFailedViewElementIds(), "      ", ref info);
        }

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
                DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinted, AddressOf AppDocumentPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinted event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status      : " + args.Status.ToString())
        info.AppendLine("    Event Cancellable : " + args.Cancellable)
        '
        ' PrintedViews
        If args.FailedViews Is Nothing OrElse 0 = args.PrintedViews.Size Then
            info.AppendLine("    Views been printed: <null>")
        Else
            info.AppendLine("    Views been printed: ")
            DumpViewsInfo(args.PrintedViews, "      ", info)
        End If
        '
        ' FailedViews
        If args.FailedViews Is Nothing OrElse 0 = args.FailedViews.Size Then
            info.AppendLine("    Views failed: <null>")
        Else
            info.AppendLine("    Views Failed : ")
            DumpViewsInfo(args.FailedViews, "      ", info)
        End If

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentPrinting Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed, ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

Examples

CopyC#
public class Application_DocumentPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.DocumentPrinting += new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.DocumentPrinting -= new EventHandler<Autodesk.Revit.DB.Events.DocumentPrintingEventArgs>(AppDocumentPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For DocumentPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for DocumentPrinting event, it will display some event arguments.
    /// </summary>
    public void AppDocumentPrinting(object sender, Autodesk.Revit.DB.Events.DocumentPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>");

        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    Views to be printed : "); // Views
        Application app = sender as Application;
        DumpViewsInfo(app, args.GetViewElementIds(), "    ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of views: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="views">Views to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewsInfo(Application app, System.Collections.Generic.IList<ElementId> viewIds, String prefix, ref StringBuilder info)
    {
        int index = 0;
        UIApplication uiApp = new UIApplication(app);
        foreach (ElementId curViewId in viewIds)
        {
            Autodesk.Revit.DB.View curView = uiApp.ActiveUIDocument.Document.GetElement(curViewId) as Autodesk.Revit.DB.View;
            DumpViewInfo(curView, String.Format("{0}#{1}", prefix, index++), ref info);
        }
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line sent to message box.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_DocumentPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.DocumentPrinting, AddressOf AppDocumentPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For DocumentPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for DocumentPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppDocumentPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.DocumentPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("DocumentPrintingEventArgs Parameters ------>")

        info.AppendLine("    Event Cancellable   : " + args.Cancellable)
        info.AppendLine("    Views to be printed : ")
        ' Views
        DumpViewsInfo(args.Views, "    ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of views: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="views">Views to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewsInfo(ByVal views As ViewSet, ByVal prefix As [String], ByRef info As StringBuilder)
        Dim index As Integer = 0
        Dim vsi As ViewSetIterator = views.ForwardIterator()
        vsi.Reset()
        While vsi.MoveNext()
            Dim curView As Autodesk.Revit.DB.View = TryCast(vsi.Current, Autodesk.Revit.DB.View)
            If curView IsNot Nothing Then
                DumpViewInfo(curView, [String].Format("{0}#{1}", prefix, System.Math.Max(System.Threading.Interlocked.Increment(index), index - 1)), info)
            End If
        End While
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line sent to message box.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaved Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSaved Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavedAs Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSavedAs Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSaving Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSaving Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSavingAs Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSavingAs Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

Examples

CopyC#
public class DocumentSavingAs : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// This method subscribes to DocumentSavingAs event.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
       application.ControlledApplication.DocumentSavingAs += new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister subscribed event
       application.ControlledApplication.DocumentSavingAs -= new EventHandler<DocumentSavingAsEventArgs>(CheckProjectStatusInitial);
        return Result.Succeeded;
    }

    /// <summary>
    /// Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    /// if it is null or empty string cancel the save as process.
    /// </summary>
    /// <param name="sender">The source of the event.</param>
    /// <param name="args">Event arguments that contains the event data.</param>
    private void CheckProjectStatusInitial(Object sender, DocumentSavingAsEventArgs args)
    {
        Document doc = args.Document;
        ProjectInfo proInfo = doc.ProjectInformation;

        // Project information is only available for project document.
        if (null != proInfo)
        {
            if (string.IsNullOrEmpty(proInfo.Status))
            {
                // cancel the save as process.
                args.Cancel();
                TaskDialog.Show("Revit","Status project parameter is not set.  Save is aborted.");
            }
        }
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class DocumentSavingAs
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' This method subscribes to DocumentSavingAs event.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        AddHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement OnShutdown method of IExternalApplication interface to unregister subscribed event
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister subscribed event
        RemoveHandler application.ControlledApplication.DocumentSavingAs, AddressOf CheckProjectStatusInitial
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Event handler method for DocumentSavingAs event. This method will check the "Project Status" value,
    ' if it is null or empty string cancel the save as process.
    ' </summary>
    ' <param name="sender">The source of the event.</param>
    ' <param name="args">Event arguments that contains the event data.</param>
    Private Sub CheckProjectStatusInitial(ByVal sender As [Object], ByVal args As Autodesk.Revit.DB.Events.DocumentSavingAsEventArgs)
        Dim doc As Document = args.Document
        Dim proInfo As ProjectInfo = doc.ProjectInformation

        ' Project information is only available for project document.
        If proInfo IsNot Nothing Then
            If String.IsNullOrEmpty(proInfo.Status) Then
                ' cancel the save as process.
                args.Cancel = True
                TaskDialog.Show("Revit", "Status project parameter is not set.  Save is aborted.")
            End If
        End If
    End Sub
    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizedWithCentral Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSynchronizedWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizedWithCentral event to be notified immediately after Revit has finished synchronizing a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizedWithCentralEventArgs> DocumentSynchronizedWithCentral
Visual Basic
Public Event DocumentSynchronizedWithCentral As EventHandler(Of DocumentSynchronizedWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ DocumentSynchronizedWithCentral {
    void add (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizedWithCentralEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished synchronizing a document with central model. It is raised even when document synchronizing with central model failed or was cancelled (during DocumentSynchronizingWithCentral event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of synchronizing a document with central model has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


DocumentSynchronizingWithCentral Event

[image]

Revit 2013 API
ControlledApplication..::..DocumentSynchronizingWithCentral Event
ControlledApplication Class See Also Send Feedback
Subscribe to the DocumentSynchronizingWithCentral event to be notified when Revit is just about to synchronize a document with central model.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSynchronizingWithCentralEventArgs> DocumentSynchronizingWithCentral
Visual Basic
Public Event DocumentSynchronizingWithCentral As EventHandler(Of DocumentSynchronizingWithCentralEventArgs)
Visual C++
public:
 event EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ DocumentSynchronizingWithCentral {
    void add (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
    void remove (EventHandler<DocumentSynchronizingWithCentralEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to synchronize a document with central model.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another DocumentSynchronizedWithCentral event will be raised immediately after document synchronizing with central model is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FailuresProcessing Event

[image]

Revit 2013 API
ControlledApplication..::..FailuresProcessing Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the FailuresProcessing event to be notified when failures are being processed at the end of transaction.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public event EventHandler<FailuresProcessingEventArgs> FailuresProcessing
Visual Basic
Public Event FailuresProcessing As EventHandler(Of FailuresProcessingEventArgs)
Visual C++
public:
 event EventHandler<FailuresProcessingEventArgs^>^ FailuresProcessing {
    void add (EventHandler<FailuresProcessingEventArgs^>^ value);
    void remove (EventHandler<FailuresProcessingEventArgs^>^ value);
}

Remarks

This event is raised when failures are being processed during transaction commit or rollback operations. Handlers of this event have a limited ability to modify the document and/or failures in it, using provided restricted failures accessor interface.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)]

public class NoUnenclosedRoomWarnings : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("EB296268-8364-4d25-96E6-F664C608503C"));

    public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication uiControlledApplication)
    {
        //Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += new EventHandler<FailuresProcessingEventArgs>(CheckWarnings);
        return Result.Succeeded;
    }

    public Autodesk.Revit.UI.Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    private void CheckWarnings(object sender, FailuresProcessingEventArgs e)
    {
        FailuresAccessor fa = e.GetFailuresAccessor();
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        failList = fa.GetFailureMessages(); // Inside event handler, get all warnings
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                fa.DeleteWarning(failure);
            }
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)> _
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class NoUnenclosedRoomWarnings
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("EB296268-8364-4d25-96E6-F664C608503C"))

    Public Function OnStartup(ByVal uiControlledApplication As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        'Create an API application that subscribes to FailuresProcessing event for the lifetime of the session.
        uiControlledApplication.ControlledApplication.FailuresProcessing += New EventHandler < FailuresProcessingEventArgs > (CheckWarnings)
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Private Sub CheckWarnings(ByVal sender As Object, ByVal e As Autodesk.Revit.DB.Events.FailuresProcessingEventArgs)
        Dim fa As FailuresAccessor = e.GetFailuresAccessor()
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        failList = fa.GetFailureMessages()
        ' Inside event handler, get all warnings
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                fa.DeleteWarning(failure)
            End If
        Next
    End Sub
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExported Event

[image]

Revit 2013 API
ControlledApplication..::..FileExported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExported event to be notified immediately after Revit has finished exporting files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileExportedEventArgs> FileExported
Visual Basic
Public Event FileExported As EventHandler(Of FileExportedEventArgs)
Visual C++
public:
 event EventHandler<FileExportedEventArgs^>^ FileExported {
    void add (EventHandler<FileExportedEventArgs^>^ value);
    void remove (EventHandler<FileExportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished exporting files of formats supported by the API. It is raised even when file exporting failed or was cancelled (during FileExporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not. If export is a part of ‘Publish to Buzzsaw’ command which consists of two parts – export of a document followed by publishing it to a BuzzSaw server, the event status only reflects the result of the Export action. The publishing part of the command could still be cancelled or could fail after FileExported event is raised.

This event is not cancellable, for the process of exporting file has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileExporting Event

[image]

Revit 2013 API
ControlledApplication..::..FileExporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileExporting event to be notified when Revit is just about to export files of formats supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileExportingEventArgs> FileExporting
Visual Basic
Public Event FileExporting As EventHandler(Of FileExportingEventArgs)
Visual C++
public:
 event EventHandler<FileExportingEventArgs^>^ FileExporting {
    void add (EventHandler<FileExportingEventArgs^>^ value);
    void remove (EventHandler<FileExportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to export files of formats supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileExported event will be raised immediately after file exporting is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImported Event

[image]

Revit 2013 API
ControlledApplication..::..FileImported Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImported event to be notified immediately after Revit has finished importing a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileImportedEventArgs> FileImported
Visual Basic
Public Event FileImported As EventHandler(Of FileImportedEventArgs)
Visual C++
public:
 event EventHandler<FileImportedEventArgs^>^ FileImported {
    void add (EventHandler<FileImportedEventArgs^>^ value);
    void remove (EventHandler<FileImportedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished importing a file of format supported by the API. It is raised even when file importing failed or was cancelled (during FileImporting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


FileImporting Event

[image]

Revit 2013 API
ControlledApplication..::..FileImporting Event
ControlledApplication Class See Also Send Feedback
Subscribe to the FileImporting event to be notified when Revit is just about to import a file of format supported by the API.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<FileImportingEventArgs> FileImporting
Visual Basic
Public Event FileImporting As EventHandler(Of FileImportingEventArgs)
Visual C++
public:
 event EventHandler<FileImportingEventArgs^>^ FileImporting {
    void add (EventHandler<FileImportingEventArgs^>^ value);
    void remove (EventHandler<FileImportingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to import a file of format supported by the API.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Import()
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FileImported event will be raised immediately after file importing is finished.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ProgressChanged Event

[image]

Revit 2013 API
ControlledApplication..::..ProgressChanged Event
ControlledApplication Class See Also Send Feedback
Subscribe to the ProgressChanged event to be notified when an operation in Revit has progress bar data available.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<ProgressChangedEventArgs> ProgressChanged
Visual Basic
Public Event ProgressChanged As EventHandler(Of ProgressChangedEventArgs)
Visual C++
public:
 event EventHandler<ProgressChangedEventArgs^>^ ProgressChanged {
    void add (EventHandler<ProgressChangedEventArgs^>^ value);
    void remove (EventHandler<ProgressChangedEventArgs^>^ value);
}

Remarks

Handlers of this event may use the Cancel()()()() method to cancel the operation tracked by the progress bar. Users may not change the document in the handler for this event. Exception ModificationForbiddenException will be thrown if any document-modifying method is called during this event's handler.

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinted Event

[image]

Revit 2013 API
ControlledApplication..::..ViewPrinted Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_ViewPrinted : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.ControlledApplication.ViewPrinted += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinted -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintedEventArgs>(AppViewPrinted);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinted class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will dump some event arguments.
    /// </summary>
    public void AppViewPrinted(object sender, Autodesk.Revit.DB.Events.ViewPrintedEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintedEventArgs Parameters ------>");
        info.AppendLine("    Event Status        : " + args.Status);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :");
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinted
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinted, AddressOf AppViewPrinted
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinted class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will dump some event arguments.
    ' </summary>
    Public Sub AppViewPrinted(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintedEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintedEventArgs Parameters ------>")
        info.AppendLine("    Event Status        : " + args.Status)
        info.AppendLine("    TotalViews          : " + args.TotalViews)
        info.AppendLine("    View Index          : " + args.Index)
        info.AppendLine("    View Information    :")
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


ViewPrinting Event

[image]

Revit 2013 API
ControlledApplication..::..ViewPrinting Event
ControlledApplication Class Example See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

Examples

CopyC#
public class Application_ViewPrinting : IExternalApplication
{
    /// <ExampleMethod>
    /// <summary>
    /// Implement the OnStartup method to register events when Revit starts.
    /// </summary>
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
       application.ControlledApplication.ViewPrinting += new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }

    /// <summary>
    /// Implement this method to unregister the subscribed events when Revit exits.
    /// </summary>
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
       application.ControlledApplication.ViewPrinting -= new EventHandler<Autodesk.Revit.DB.Events.ViewPrintingEventArgs>(AppViewPrinting);
        return Result.Succeeded;
    }
    /// <TrivialCode>
    /// Code ID: 501
    /// For ViewPrinting class description
    /// </TrivialCode>

    /// <summary>
    /// Handler method for ViewPrinting event, it will display some event arguments.
    /// </summary>
    public void AppViewPrinting(object sender, Autodesk.Revit.DB.Events.ViewPrintingEventArgs args)
    {
        StringBuilder info = new StringBuilder();
        info.AppendLine("ViewPrintingEventArgs Parameters ------>");
        info.AppendLine("    Event Cancellable   : " + args.Cancellable);
        info.AppendLine("    TotalViews          : " + args.TotalViews);
        info.AppendLine("    View Index          : " + args.Index);
        info.AppendLine("    View Information    :"); // View
        DumpViewInfo(args.View, "      ", ref info);

        TaskDialog.Show("Revit",info.ToString());
    }

    /// <summary>
    /// Dump information of single view: ViewType, Id and ViewName.
    /// </summary>
    /// <param name="view">View element to be displayed in message box.</param>
    /// <param name="prefix">Prefix mark for each line added to message box string.</param>
    /// <param name="info">String where data is stored for display</param>
    private static void DumpViewInfo(Autodesk.Revit.DB.View view, String prefix, ref StringBuilder info)
    {
        info.AppendLine(String.Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}",
            prefix, view.Id.IntegerValue, view.ViewName, view.ViewType));
    }
    /// </ExampleMethod>
}
CopyVB.NET
Public Class Application_ViewPrinting
    Implements IExternalApplication
    ' <ExampleMethod>
    ' <summary>
    ' Implement the OnStartup method to register events when Revit starts.
    ' </summary>
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function

    ' <summary>
    ' Implement this method to unregister the subscribed events when Revit exits.
    ' </summary>
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.ControlledApplication.ViewPrinting, AddressOf AppViewPrinting
        Return Result.Succeeded
    End Function
    ' <TrivialCode>
    ' Code ID: 501
    ' For ViewPrinting class description
    ' </TrivialCode>

    ' <summary>
    ' Handler method for ViewPrinting event, it will display some event arguments.
    ' </summary>
    Public Sub AppViewPrinting(ByVal sender As Object, ByVal args As Autodesk.Revit.DB.Events.ViewPrintingEventArgs)
        Dim info As New StringBuilder()
        info.AppendLine("ViewPrintingEventArgs Parameters ------>")
        info.AppendLine("    Event Cancellable   : " & args.Cancellable.ToString())
        info.AppendLine("    TotalViews          : " & args.TotalViews.ToString())
        info.AppendLine("    View Index          : " & args.Index.ToString())
        info.AppendLine("    View Information    :")
        ' View
        DumpViewInfo(args.View, "      ", info)

        TaskDialog.Show("Revit", info.ToString())
    End Sub

    ' <summary>
    ' Dump information of single view: ViewType, Id and ViewName.
    ' </summary>
    ' <param name="view">View element to be displayed in message box.</param>
    ' <param name="prefix">Prefix mark for each line added to message box string.</param>
    ' <param name="info">String where data is stored for display</param>
    Private Shared Sub DumpViewInfo(ByVal view As Autodesk.Revit.DB.View, ByVal prefix As [String], ByRef info As StringBuilder)
        info.AppendLine([String].Format("{0} Id: {1}, ViewName: {2}, ViewType: {3}", prefix, view.Id.IntegerValue, view.ViewName, view.ViewType))
    End Sub
    ' </ExampleMethod>
End Class

See Also

ControlledApplication Class
Autodesk.Revit.ApplicationServices Namespace


LanguageType Enumeration

[image]

Revit 2013 API
LanguageType Enumeration
See Also Send Feedback
An enumerated type containing the supported Revit product languages.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LanguageType
Visual Basic
Public Enumeration LanguageType
Visual C++
public enum class LanguageType

Members

Member name | Description
Unknown | Unknown.
English_USA | English USA.
German | German.
Spanish | Spanish.
French | French.
Italian | Italian.
Dutch | Dutch.
Chinese_Simplified | Chinese simplified.
Chinese_Traditional | Chinese traditional.
Japanese | Japanese.
Korean | Korean.
Russian | Russian.
Czech | Czech.
Polish | Polish.
Hungarian | Hungarian.
Brazilian_Portuguese | Brazilian Portuguese.

See Also

Autodesk.Revit.ApplicationServices Namespace


ProductType Enumeration

[image]

Revit 2013 API
ProductType Enumeration
See Also Send Feedback
An enumerated type containing the possible Revit product types.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ProductType
Visual Basic
Public Enumeration ProductType
Visual C++
public enum class ProductType

Members

Member name | Description
Architecture | Architecture.
Structure | Structure.
MEP | MEP.
Revit | Revit.
LT | LT.
Unknown | Unknown.

See Also

Autodesk.Revit.ApplicationServices Namespace


Autodesk.Revit.Attributes Namespace

[image]

Revit 2013 API
Autodesk.Revit.Attributes Namespace
Send Feedback

Classes

 | Class | Description
Public class | JournalingAttribute | The custom journaling attribute to control the journaling behavior of the external command.
Public class | RegenerationAttribute | The custom regeneration attribute to control the regeneration behavior of the external command or external application.
Public class | TransactionAttribute | The custom transaction attribute to control the transaction behavior of the external command.

Enumerations

 | Enumeration | Description
Public enumeration | JournalingMode | All journaling modes supported by Revit external commands.
Public enumeration | RegenerationOption | All regeneration options supported by Revit external commands and external applications.
Public enumeration | TransactionMode | All transaction modes supported by Revit external commands.


JournalingAttribute Class

[image]

Revit 2013 API
JournalingAttribute Class
Members See Also Send Feedback
The custom journaling attribute to control the journaling behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class JournalingAttribute : Attribute
Visual Basic
Public Class JournalingAttribute _
    Inherits Attribute
Visual C++
public ref class JournalingAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.Attributes..::..JournalingAttribute

See Also

JournalingAttribute Members
Autodesk.Revit.Attributes Namespace


JournalingAttribute Members

[image] [image]

Revit 2013 API
JournalingAttribute Members
JournalingAttribute Class Constructors Methods Properties See Also Send Feedback

The JournalingAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | JournalingAttribute | Constructs a new JournalingAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Mode | Journaling mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Constructor

[image]

Revit 2013 API
JournalingAttribute Constructor
JournalingAttribute Class See Also Send Feedback
Constructs a new JournalingAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public JournalingAttribute(
    JournalingMode mode
)
Visual Basic
Public Sub New ( _
    mode As JournalingMode _
)
Visual C++
public:
JournalingAttribute(
    JournalingMode mode
)

Parameters

mode
Type: Autodesk.Revit.Attributes..::..JournalingMode

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Methods

[image] [image]

Revit 2013 API
JournalingAttribute Methods
JournalingAttribute Class See Also Send Feedback

The JournalingAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingAttribute Properties

[image] [image]

Revit 2013 API
JournalingAttribute Properties
JournalingAttribute Class See Also Send Feedback

The JournalingAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Mode | Journaling mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


Mode Property

[image]

Revit 2013 API
JournalingAttribute..::..Mode Property
JournalingAttribute Class See Also Send Feedback
Journaling mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public JournalingMode Mode { get; }
Visual Basic
Public ReadOnly Property Mode As JournalingMode
    Get
Visual C++
public:
property JournalingMode Mode {
    JournalingMode get ();
}

See Also

JournalingAttribute Class
Autodesk.Revit.Attributes Namespace


JournalingMode Enumeration

[image]

Revit 2013 API
JournalingMode Enumeration
See Also Send Feedback
All journaling modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum JournalingMode
Visual Basic
Public Enumeration JournalingMode
Visual C++
public enum class JournalingMode

Members

Member name | Description
UsingCommandData | Uses the “StringStringMap” supplied in the command data. Hides all Revit journal entries in between the external command invocation and the StringStringMap entry. Commands which invoke the Revit UI for selection or for responses to task dialogs may not replay correctly.
NoCommandData | Does not write contents of the ExternalCommandData.Data map to the Revit journal. But does allow Revit API calls to write to the journal as needed. This option should allow commands which invoke the Revit UI for selection or for responses to task dialogs to replay correctly.

See Also

Autodesk.Revit.Attributes Namespace


RegenerationAttribute Class

[image]

Revit 2013 API
RegenerationAttribute Class
Members See Also Send Feedback
The custom regeneration attribute to control the regeneration behavior of the external command or external application.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RegenerationAttribute : Attribute
Visual Basic
Public Class RegenerationAttribute _
    Inherits Attribute
Visual C++
public ref class RegenerationAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.Attributes..::..RegenerationAttribute

See Also

RegenerationAttribute Members
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Members

[image] [image]

Revit 2013 API
RegenerationAttribute Members
RegenerationAttribute Class Constructors Methods Properties See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | RegenerationAttribute | Constructs a new RegenerationAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Constructor

[image]

Revit 2013 API
RegenerationAttribute Constructor
RegenerationAttribute Class See Also Send Feedback
Constructs a new RegenerationAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public RegenerationAttribute(
    RegenerationOption option
)
Visual Basic
Public Sub New ( _
    option As RegenerationOption _
)
Visual C++
public:
RegenerationAttribute(
    RegenerationOption option
)

Parameters

option
Type: Autodesk.Revit.Attributes..::..RegenerationOption

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Methods

[image] [image]

Revit 2013 API
RegenerationAttribute Methods
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationAttribute Properties

[image] [image]

Revit 2013 API
RegenerationAttribute Properties
RegenerationAttribute Class See Also Send Feedback

The RegenerationAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Option | Regeneration option.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


Option Property

[image]

Revit 2013 API
RegenerationAttribute..::..Option Property
RegenerationAttribute Class See Also Send Feedback
Regeneration option.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public RegenerationOption Option { get; }
Visual Basic
Public ReadOnly Property Option As RegenerationOption
    Get
Visual C++
public:
property RegenerationOption Option {
    RegenerationOption get ();
}

See Also

RegenerationAttribute Class
Autodesk.Revit.Attributes Namespace


RegenerationOption Enumeration

[image]

Revit 2013 API
RegenerationOption Enumeration
See Also Send Feedback
All regeneration options supported by Revit external commands and external applications.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum RegenerationOption
Visual Basic
Public Enumeration RegenerationOption
Visual C++
public enum class RegenerationOption

Members

Member name | Description
Manual | The API framework will not regenerate after every model level change. Instead, you may use the regeneration APIs to force update of the document after a group of changes. SuspendUpdating blocks are unnecessary and should not be used. Performance of multiple modifications of the Revit document should be faster than RegenerationOption.Automatic. Because this mode suspends all updates to the document, your application should not read data from the document after it has been modified until the document has been regenerated, or it runs the risk of accessing stale data. This mode will be only option in a future release.

See Also

Autodesk.Revit.Attributes Namespace


TransactionAttribute Class

[image]

Revit 2013 API
TransactionAttribute Class
Members See Also Send Feedback
The custom transaction attribute to control the transaction behavior of the external command.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TransactionAttribute : Attribute
Visual Basic
Public Class TransactionAttribute _
    Inherits Attribute
Visual C++
public ref class TransactionAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.Attributes..::..TransactionAttribute

See Also

TransactionAttribute Members
Autodesk.Revit.Attributes Namespace


TransactionAttribute Members

[image] [image]

Revit 2013 API
TransactionAttribute Members
TransactionAttribute Class Constructors Methods Properties See Also Send Feedback

The TransactionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionAttribute | Constructs a new TransactionAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Constructor

[image]

Revit 2013 API
TransactionAttribute Constructor
TransactionAttribute Class See Also Send Feedback
Constructs a new TransactionAttribute.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionAttribute(
    TransactionMode mode
)
Visual Basic
Public Sub New ( _
    mode As TransactionMode _
)
Visual C++
public:
TransactionAttribute(
    TransactionMode mode
)

Parameters

mode
Type: Autodesk.Revit.Attributes..::..TransactionMode

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Methods

[image] [image]

Revit 2013 API
TransactionAttribute Methods
TransactionAttribute Class See Also Send Feedback

The TransactionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionAttribute Properties

[image] [image]

Revit 2013 API
TransactionAttribute Properties
TransactionAttribute Class See Also Send Feedback

The TransactionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | Mode | Transaction mode.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


Mode Property

[image]

Revit 2013 API
TransactionAttribute..::..Mode Property
TransactionAttribute Class See Also Send Feedback
Transaction mode.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionMode Mode { get; }
Visual Basic
Public ReadOnly Property Mode As TransactionMode
    Get
Visual C++
public:
property TransactionMode Mode {
    TransactionMode get ();
}

See Also

TransactionAttribute Class
Autodesk.Revit.Attributes Namespace


TransactionMode Enumeration

[image]

Revit 2013 API
TransactionMode Enumeration
See Also Send Feedback
All transaction modes supported by Revit external commands.

Namespace: Autodesk.Revit.Attributes
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TransactionMode
Visual Basic
Public Enumeration TransactionMode
Visual C++
public enum class TransactionMode

Members

Member name | Description
Automatic | The API framework will create a transaction on the active document before the external command is executed and the transaction will be committed or rolled back after the command is completed (based upon the return value of the ExternalCommand callback).
Manual | The API framework will not create a transaction (but will create an outer group to roll back all changes if the external command returns a failure status). Instead, you may use combinations of transactions, sub-transactions, and groups. You will have to follow all rules regarding use of transactions and related classes. You will have to give your transactions names, which will then appear in the undo menu. Revit will check that all transactions (also groups and sub-transaction) are properly closed upon return from an external command. If not, it will discard all changes to the model.
ReadOnly | No transaction (nor group) will be created, and no transaction may be created for the lifetime of the command. The External command may use methods that only read from the model, but not methods that write anything to it. Exceptions will be thrown if the command either tries to start a transaction (or group) or attempts to write to the model.

See Also

Autodesk.Revit.Attributes Namespace


Autodesk.Revit.Collections Namespace

[image]

Revit 2013 API
Autodesk.Revit.Collections Namespace
Send Feedback

Classes

 | Class | Description
Public class | StringStringMap | A map that can contain a mapping of a string to another string.
Public class | StringStringMapIterator | An iterator to a string to string map.


StringStringMap Class

[image]

Revit 2013 API
StringStringMap Class
Members See Also Send Feedback
A map that can contain a mapping of a string to another string.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class StringStringMap : APIObject,
    IEnumerable
Visual Basic
Public Class StringStringMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class StringStringMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Collections..::..StringStringMap

See Also

StringStringMap Members
Autodesk.Revit.Collections Namespace


StringStringMap Members

[image] [image]

Revit 2013 API
StringStringMap Members
StringStringMap Class Constructors Methods Properties See Also Send Feedback

The StringStringMap type exposes the following members.

Constructors

 | Name | Description
Public method | StringStringMap | Initializes a new instance of the StringStringMap class

Methods

 | Name | Description
Public method | Clear | Removes every string from the map, rendering it empty.
Public method | Contains | Tests for the existence of a string key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes an item with the specified string key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a string item at a specified string key within the map.
Public property | Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Constructor

[image]

Revit 2013 API
StringStringMap Constructor
StringStringMap Class See Also Send Feedback
Initializes a new instance of the StringStringMap class

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StringStringMap()
Visual Basic
Public Sub New
Visual C++
public:
StringStringMap()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Methods

[image] [image]

Revit 2013 API
StringStringMap Methods
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every string from the map, rendering it empty.
Public method | Contains | Tests for the existence of a string key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes an item with the specified string key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Clear Method

[image]

Revit 2013 API
StringStringMap..::..Clear Method
StringStringMap Class See Also Send Feedback
Removes every string from the map, rendering it empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Contains Method

[image]

Revit 2013 API
StringStringMap..::..Contains Method
StringStringMap Class See Also Send Feedback
Tests for the existence of a string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The key to be searched for.

Return Value

The Contains method returns True if the string key is within the map, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Erase Method

[image]

Revit 2013 API
StringStringMap..::..Erase Method
StringStringMap Class See Also Send Feedback
Removes an item with the specified string key from the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::..String
The string key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ForwardIterator Method

[image]

Revit 2013 API
StringStringMap..::..ForwardIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual StringStringMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


GetEnumerator Method

[image]

Revit 2013 API
StringStringMap..::..GetEnumerator Method
StringStringMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Insert Method

[image]

Revit 2013 API
StringStringMap..::..Insert Method
StringStringMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    string item
)
Visual Basic
Public Overridable Function Insert ( _
    key As String, _
    item As String _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    String^ item
)

Parameters

key
Type: System..::..String
The key to be used for inserting the item into the map.
item
Type: System..::..String
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


ReverseIterator Method

[image]

Revit 2013 API
StringStringMap..::..ReverseIterator Method
StringStringMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual StringStringMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As StringStringMapIterator
Visual C++
public:
virtual StringStringMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMap Properties

[image] [image]

Revit 2013 API
StringStringMap Properties
StringStringMap Class See Also Send Feedback

The StringStringMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a string item at a specified string key within the map.
Public property | Size | Returns the number of strings that are in the map.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


IsEmpty Property

[image]

Revit 2013 API
StringStringMap..::..IsEmpty Property
StringStringMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Item Property

[image]

Revit 2013 API
StringStringMap..::..Item Property
StringStringMap Class See Also Send Feedback
Gets or sets a string item at a specified string key within the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As String
    Get
    Set
Visual C++
public:
virtual property String^ Item[String^ key] {
    String^ get (String^ key);
    void set (String^ key, String^ value);
}

Parameters

key
Type: System..::..String
The string key of the string item to be set or retrieved.

Return Value

Returns the string item at the specified string key.

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


Size Property

[image]

Revit 2013 API
StringStringMap..::..Size Property
StringStringMap Class See Also Send Feedback
Returns the number of strings that are in the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

StringStringMap Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Class

[image]

Revit 2013 API
StringStringMapIterator Class
Members See Also Send Feedback
An iterator to a string to string map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class StringStringMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class StringStringMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class StringStringMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Collections..::..StringStringMapIterator

See Also

StringStringMapIterator Members
Autodesk.Revit.Collections Namespace


StringStringMapIterator Members

[image] [image]

Revit 2013 API
StringStringMapIterator Members
StringStringMapIterator Class Constructors Methods Properties See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | StringStringMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the string item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Constructor

[image]

Revit 2013 API
StringStringMapIterator Constructor
StringStringMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StringStringMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
StringStringMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Methods

[image] [image]

Revit 2013 API
StringStringMapIterator Methods
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


MoveNext Method

[image]

Revit 2013 API
StringStringMapIterator..::..MoveNext Method
StringStringMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Reset Method

[image]

Revit 2013 API
StringStringMapIterator..::..Reset Method
StringStringMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


StringStringMapIterator Properties

[image] [image]

Revit 2013 API
StringStringMapIterator Properties
StringStringMapIterator Class See Also Send Feedback

The StringStringMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the string item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the string key that is the current focus of the iterator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Current Property

[image]

Revit 2013 API
StringStringMapIterator..::..Current Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Key Property

[image]

Revit 2013 API
StringStringMapIterator..::..Key Property
StringStringMapIterator Class See Also Send Feedback
Retrieves the string key that is the current focus of the iterator.

Namespace: Autodesk.Revit.Collections
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

StringStringMapIterator Class
Autodesk.Revit.Collections Namespace


Autodesk.Revit.Creation Namespace

[image]

Revit 2013 API
Autodesk.Revit.Creation Namespace
Send Feedback

Classes

 | Class | Description
Public class | Application | The Application Creation object is used to create new instances of utility objects.
Public class | AreaCreationData | A class which wraps the arguments of Area for batch creation
Public class | Document | The Document Creation object is used to create new instances of elements within the Autodesk Revit project.
Public class | FamilyInstanceCreationData | A class which wraps the arguments of FamilyInstance for batch creation.
Public class | FamilyItemFactory | The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.
Public class | ItemFactoryBase | The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.
Public class | ProfiledWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RectangularWallCreationData | A class which wraps the arguments of Wall for batch creation
Public class | RoomCreationData | Obsolete. A class which wraps the arguments of Room for batch creation.
Public class | TextNoteCreationData | A class which wraps the arguments of TextNote for batch creation

Enumerations

 | Enumeration | Description
Public enumeration | eRefFace | Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.


Application Class

[image]

Revit 2013 API
Application Class
Members See Also Send Feedback
The Application Creation object is used to create new instances of utility objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Application : APIObject
Visual Basic
Public Class Application _
    Inherits APIObject
Visual C++
public ref class Application : public APIObject

Remarks

General purpose objects can be generated by this creation object. Creating objects via this object ensures that they will be correctly constructed and will reside in the Autodesk Revit memory space.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..Application

See Also

Application Members
Autodesk.Revit.Creation Namespace


Application Members

[image] [image]

Revit 2013 API
Application Members
Application Class Methods Properties See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Public method | NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Public method | NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewBoundingBoxUV()()()() | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewBuildingSiteExportOptions | Creates Building Site Export options.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCombinableElementArray | Returns an array that can hold combinable element objects.
Public method | NewCurveArrArray | Creates an empty array that can store geometric curve loops.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWFExportOptions | Creates DWF Export options.
Public method | NewDWFXExportOptions | Creates DWFX Export options.
Public method | NewElementArray | Obsolete. Returns an array that can hold element objects.
Public method | NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewGBXMLExportOptions | Creates Green-Building XML Export options.
Public method | NewGBXMLImportOptions | Creates Green-Building XML Import options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean, XYZ, XYZ) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | NewImageImportOptions | Creates Image Import options.
Public method | NewInstanceBinding()()()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Public method | NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMaterialSet | Obsolete. Create a new instance of MaterialSet.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), DoubleArray, DoubleArray, Int32, Boolean, Boolean) | Creates a new geometric nurbSpline object.
Public method | NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
Public method | NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
Public method | NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.
Public method | NewPoint | Creates a new geometric point object.
Public method | NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method | NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method | NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method | NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method | NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method | NewPointRelativeToPoint | Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method | NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
Public method | NewSATExportOptions | Creates SAT Export options.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTypeBinding()()()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Public method | NewUV()()()() | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Public method | NewVertexIndexPair | Creates a new VertexIndexPair object.
Public method | NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewVolumeCalculationOptions | Creates options related to room volume and area computations.
Public method | NewXYZ()()()() | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


Application Methods

[image] [image]

Revit 2013 API
Application Methods
Application Class See Also Send Feedback

The Application type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Public method | NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Public method | NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.
Public method | NewAreaCreationData | Creates an object which wraps the arguments of Area for batch creation.
Public method | NewBoundingBoxUV()()()() | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.
Public method | NewBoundingBoxXYZ | Creates a three-dimensional rectangular box.
Public method | NewBuildingSiteExportOptions | Creates Building Site Export options.
Public method | NewCategorySet | Creates a new instance of a set specifically for holding category objects.
Public method | NewColor | Returns a new color object.
Public method | NewCombinableElementArray | Returns an array that can hold combinable element objects.
Public method | NewCurveArrArray | Creates an empty array that can store geometric curve loops.
Public method | NewCurveArray | Creates an empty array that can store geometric curves.
Public method | NewCurveLoopsProfile | Creates a new CurveLoopsProfile object.
Public method | NewDoubleArray | Creates a new instance of a double array.
Public method | NewDWFExportOptions | Creates DWF Export options.
Public method | NewDWFXExportOptions | Creates DWFX Export options.
Public method | NewElementArray | Obsolete. Returns an array that can hold element objects.
Public method | NewElementId | Creates a new Autodesk::Revit::DB::ElementId^ object.
Public method | NewElementSet | Creates a new instance of a set specifically for holding elements.
Public method | NewEllipse | Creates a new geometric ellipse object.
Public method | NewFaceArray | Creates a new instance of a face array.
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilySymbolProfile | Creates a new FamilySymbolProfile object.
Public method | NewFBXExportOptions | Creates 3D-Studio Max (FBX) Export options.
Public method | NewGBXMLExportOptions | Creates Green-Building XML Export options.
Public method | NewGBXMLImportOptions | Creates Green-Building XML Import options.
Public method | NewGeometryOptions | Creates an object to specify user preferences in parsing of geometry.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean, XYZ, XYZ) | Creates a Hermite spline with specified tangency at its endpoints.
Public method | NewImageImportOptions | Creates Image Import options.
Public method | NewInstanceBinding()()()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.
Public method | NewIntersectionResultArray | Creates a new instance of an IntersectionResult array.
Public method | NewLine | Creates a new bound or unbounded geometric line object.
Public method | NewLineBound | Creates a new bounded geometric line object.
Public method | NewLineUnbound | Creates a new unbounded geometric line object.
Public method | NewLoadCaseArray | Creates a new instance of a LoadCase array.
Public method | NewLoadCombinationArray | Creates a new instance of a LoadCombination array.
Public method | NewLoadUsageArray | Creates a new instance of a LoadUsage array.
Public method | NewMaterialSet | Obsolete. Create a new instance of MaterialSet.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), DoubleArray, DoubleArray, Int32, Boolean, Boolean) | Creates a new geometric nurbSpline object.
Public method | NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
Public method | NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
Public method | NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.
Public method | NewPoint | Creates a new geometric point object.
Public method | NewPointOnEdge | Create a PointOnEdge object which is used to define the placement of a ReferencePoint.
Public method | NewPointOnEdgeEdgeIntersection | Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.
Public method | NewPointOnEdgeFaceIntersection | Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.
Public method | NewPointOnFace | Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.
Public method | NewPointOnPlane | Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.
Public method | NewPointRelativeToPoint | Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.
Public method | NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProjectPosition | Creates a new project position object.
Public method | NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewReferenceArray | Creates a new instance of a reference array.
Public method | NewReferencePointArray | Creates an empty array that can store ReferencePoint objects.
Public method | NewRoomCreationData | Creates an object which wraps the arguments of NewRoom() for batch creation.
Public method | NewSATExportOptions | Creates SAT Export options.
Public method | NewSpaceSet | Creates a new instance of a space set.
Public method | NewStringStringMap | Creates a new map that maps one string to another string.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTypeBinding()()()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.
Public method | NewUV()()()() | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.
Public method | NewVertexIndexPair | Creates a new VertexIndexPair object.
Public method | NewVertexIndexPairArray | Returns an array that can hold VertexIndexPair objects.
Public method | NewViewSet | Creates a new instance of a View set.
Public method | NewVolumeCalculationOptions | Creates options related to room volume and area computations.
Public method | NewXYZ()()()() | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewArc Method

[image] [image]

Revit 2013 API
Application..::..NewArc Method
Application Class See Also Send Feedback
Creates a new geometric arc object.

Overload List

 | Name | Description
Public method | NewArc(XYZ, XYZ, XYZ) | Creates a new geometric arc object based on three points.
Public method | NewArc(Plane, Double, Double, Double) | Creates a new geometric arc object based on plane, radius, and angles.
Public method | NewArc(XYZ, Double, Double, Double, XYZ, XYZ) | Creates a new geometric arc object based on center, radius, unit vectors, and angles.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, XYZ, XYZ)

[image]

Revit 2013 API
Application..::..NewArc Method (XYZ, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on three points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ end0,
    XYZ end1,
    XYZ pointOnCurve
)
Visual Basic
Public Function NewArc ( _
    end0 As XYZ, _
    end1 As XYZ, _
    pointOnCurve As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ end0,
    XYZ^ end1,
    XYZ^ pointOnCurve
)

Parameters

end0
Type: Autodesk.Revit.DB..::..XYZ
The start point of the arc.
end1
Type: Autodesk.Revit.DB..::..XYZ
The end point of the arc.
pointOnCurve
Type: Autodesk.Revit.DB..::..XYZ
A point on the arc.

Remarks

Examples

CopyC#
// Create a new arc using two ends and a point on the curve
XYZ end0 = new XYZ(1, 0, 0);    // start point of the arc
XYZ end1 = new XYZ(10, 10, 10); // end point of the arc
XYZ pointOnCurve = new XYZ(10, 0, 0);   // point along arc

Arc arc = application.Create.NewArc(end0, end1, pointOnCurve);
CopyVB.NET
' Create a new arc using two ends and a point on the curve
Dim end0 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' start point of the arc
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 10, 10)
' end point of the arc
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(10, 0, 0)
' point along arc
Dim arc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (Plane, Double, Double, Double)

[image]

Revit 2013 API
Application..::..NewArc Method (Plane, Double, Double, Double)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on plane, radius, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    Plane plane,
    double radius,
    double startAngle,
    double endAngle
)
Visual Basic
Public Function NewArc ( _
    plane As Plane, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double _
) As Arc
Visual C++
public:
Arc^ NewArc(
    Plane^ plane,
    double radius,
    double startAngle,
    double endAngle
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane which the arc resides in. The plane's origin is the center of the arc.
radius
Type: System..::..Double
startAngle
Type: System..::..Double
The start angle of the arc (in radians).
endAngle
Type: System..::..Double
The end angle of the arc (in radians).

Remarks

Examples

CopyC#
Arc CreateArcByGivingPlane(Autodesk.Revit.ApplicationServices.Application application, Plane plane)
{
    // Create an arc which is placed on the plane and whose center is the plane's origin
    double radius = 10;
    double startAngle = 0;      // The unit is radian
    double endAngle = 2 * Math.PI;        // this arc will be a circle
    return application.Create.NewArc(plane, radius, startAngle, endAngle);
}
CopyVB.NET
Function CreateArcByGivingPlane(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal plane As Plane) As Arc
    ' Create an arc which is placed on the plane and whose center is the plane's origin
    Dim radius As Double = 10
    Dim startAngle As Double = 0
    ' The unit is radian
    Dim endAngle As Double = 2 * Math.PI
    ' this arc will be a circle
    Return application.Create.NewArc(plane, radius, startAngle, endAngle)
End Function

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)

[image]

Revit 2013 API
Application..::..NewArc Method (XYZ, Double, Double, Double, XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric arc object based on center, radius, unit vectors, and angles.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Arc NewArc(
    XYZ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ xAxis,
    XYZ yAxis
)
Visual Basic
Public Function NewArc ( _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    endAngle As Double, _
    xAxis As XYZ, _
    yAxis As XYZ _
) As Arc
Visual C++
public:
Arc^ NewArc(
    XYZ^ center,
    double radius,
    double startAngle,
    double endAngle,
    XYZ^ xAxis,
    XYZ^ yAxis
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center of the arc.
radius
Type: System..::..Double
The radius of the arc.
startAngle
Type: System..::..Double
The start angle of the arc (in radians).
endAngle
Type: System..::..Double
The end angle of the arc (in radians).
xAxis
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the arc plane. Must be normalized.
yAxis
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the arc plane. Must be normalized.

Remarks

Examples

CopyC#
// Create a new arc defined by its center, radios, angles and 2 axes
double radius = 10;
double startAngle = 0;      // In radian
double endAngle = Math.PI;        // In radian
XYZ center = new XYZ(5, 0, 0);
XYZ xAxis = new XYZ(1, 0, 0);   // The x axis to define the arc plane. Must be normalized
XYZ yAxis = new XYZ(0, 1, 0);   // The y axis to define the arc plane. Must be normalized

Arc arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis);
CopyVB.NET
' Create a new arc defined by its center, radios, angles and 2 axes
Dim radius As Double = 10
Dim startAngle As Double = 0
' In radian
Dim endAngle As Double = Math.PI
' In radian
Dim center As New Autodesk.Revit.DB.XYZ(5, 0, 0)
Dim xAxis As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' The x axis to define the arc plane. Must be normalized
Dim yAxis As New Autodesk.Revit.DB.XYZ(0, 1, 0)
' The y axis to define the arc plane. Must be normalized
Dim arc As Arc = application.Create.NewArc(center, radius, startAngle, endAngle, xAxis, yAxis)

See Also

Application Class
NewArc Overload
Autodesk.Revit.Creation Namespace


NewAreaCreationData Method

[image]

Revit 2013 API
Application..::..NewAreaCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of Area for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaCreationData NewAreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic
Public Function NewAreaCreationData ( _
    areaView As ViewPlan, _
    point As UV _
) As AreaCreationData
Visual C++
public:
AreaCreationData^ NewAreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::..UV
A point which lies in an enclosed region of area boundary where the new area will reside.

Return Value

The object containing the data needed for area creation.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image] [image]

Revit 2013 API
Application..::..NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates a two-dimensional rectangle.

Overload List

 | Name | Description
Public method | NewBoundingBoxUV()()()() | Creates an empty two-dimensional rectangle.
Public method | NewBoundingBoxUV(Double, Double, Double, Double) | Creates a two-dimensional rectangle with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method

[image]

Revit 2013 API
Application..::..NewBoundingBoxUV Method
Application Class See Also Send Feedback
Creates an empty two-dimensional rectangle.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV()
Visual Basic
Public Function NewBoundingBoxUV As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV()

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxUV Method (Double, Double, Double, Double)

[image]

Revit 2013 API
Application..::..NewBoundingBoxUV Method (Double, Double, Double, Double)
Application Class See Also Send Feedback
Creates a two-dimensional rectangle with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic
Public Function NewBoundingBoxUV ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ NewBoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::..Double
The first coordinate of min.
min_v
Type: System..::..Double
The second coordinate of min.
max_u
Type: System..::..Double
The first coordinate of max.
max_v
Type: System..::..Double
The second coordinate of max.

See Also

Application Class
NewBoundingBoxUV Overload
Autodesk.Revit.Creation Namespace


NewBoundingBoxXYZ Method

[image]

Revit 2013 API
Application..::..NewBoundingBoxXYZ Method
Application Class See Also Send Feedback
Creates a three-dimensional rectangular box.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ NewBoundingBoxXYZ()
Visual Basic
Public Function NewBoundingBoxXYZ As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ NewBoundingBoxXYZ()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewBuildingSiteExportOptions Method

[image]

Revit 2013 API
Application..::..NewBuildingSiteExportOptions Method
Application Class See Also Send Feedback
Creates Building Site Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BuildingSiteExportOptions NewBuildingSiteExportOptions()
Visual Basic
Public Function NewBuildingSiteExportOptions As BuildingSiteExportOptions
Visual C++
public:
BuildingSiteExportOptions^ NewBuildingSiteExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCategorySet Method

[image]

Revit 2013 API
Application..::..NewCategorySet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding category objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategorySet NewCategorySet()
Visual Basic
Public Function NewCategorySet As CategorySet
Visual C++
public:
CategorySet^ NewCategorySet()

Return Value

A new instance of a Category Set.

Remarks

This type of set is used during the creation of instance and type bindings.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewColor Method

[image]

Revit 2013 API
Application..::..NewColor Method
Application Class Example See Also Send Feedback
Returns a new color object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color NewColor()
Visual Basic
Public Function NewColor As Color
Visual C++
public:
Color^ NewColor()

Return Value

The new color object.

Examples

CopyC#
Color NewColorInfo(Autodesk.Revit.Creation.Application appCreation)
{
    // Create a new color
    Autodesk.Revit.DB.Color color = appCreation.NewColor();

    // Set its RGB values
    color.Red = (byte)127;
    color.Green = (byte)64;
    color.Blue = (byte)32;

    // Display the color info
    StringBuilder info = new StringBuilder();
    info.AppendLine("Red:\t" + color.Red.ToString());
    info.AppendLine("Green:\t" + color.Green.ToString());
    info.AppendLine("Blue:\t" + color.Blue.ToString());

    TaskDialog.Show("Revit",info.ToString());

    return color;
}
CopyVB.NET
Function NewColorInfo(ByVal appCreation As Autodesk.Revit.Creation.Application) As Color
    ' Create a new color
    Dim color As Autodesk.Revit.DB.Color = appCreation.NewColor()

    ' Set its RGB values
    color.Red = CByte(127)
    color.Green = CByte(64)
    color.Blue = CByte(32)

    ' Display the color info
    Dim info As New StringBuilder()
    info.AppendLine("Red:" & vbTab + color.Red.ToString())
    info.AppendLine("Green:" & vbTab + color.Green.ToString())
    info.AppendLine("Blue:" & vbTab + color.Blue.ToString())

    TaskDialog.Show("Revit", info.ToString())

    Return color
End Function

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCombinableElementArray Method

[image]

Revit 2013 API
Application..::..NewCombinableElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold combinable element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CombinableElementArray NewCombinableElementArray()
Visual Basic
Public Function NewCombinableElementArray As CombinableElementArray
Visual C++
public:
CombinableElementArray^ NewCombinableElementArray()

Return Value

An empty array that can contain any CombinableElement derived objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArrArray Method

[image]

Revit 2013 API
Application..::..NewCurveArrArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curve loops.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray NewCurveArrArray()
Visual Basic
Public Function NewCurveArrArray As CurveArrArray
Visual C++
public:
CurveArrArray^ NewCurveArrArray()

Return Value

The empty array of curve loops.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveArray Method

[image]

Revit 2013 API
Application..::..NewCurveArray Method
Application Class See Also Send Feedback
Creates an empty array that can store geometric curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray NewCurveArray()
Visual Basic
Public Function NewCurveArray As CurveArray
Visual C++
public:
CurveArray^ NewCurveArray()

Return Value

An empty array that can hold geometric curves.

Remarks

This method can be used to create an array that can hold any curve type object. This array can be then passed to methods, such as NewAreaLoad, to represent the geometry for the boundary of the load.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewCurveLoopsProfile Method

[image]

Revit 2013 API
Application..::..NewCurveLoopsProfile Method
Application Class See Also Send Feedback
Creates a new CurveLoopsProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveLoopsProfile NewCurveLoopsProfile(
    CurveArrArray curveLoops
)
Visual Basic
Public Function NewCurveLoopsProfile ( _
    curveLoops As CurveArrArray _
) As CurveLoopsProfile
Visual C++
public:
CurveLoopsProfile^ NewCurveLoopsProfile(
    CurveArrArray^ curveLoops
)

Parameters

curveLoops
Type: Autodesk.Revit.DB..::..CurveArrArray
The curve loops of the Profile.

Return Value

The new CurveLoopsProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDoubleArray Method

[image]

Revit 2013 API
Application..::..NewDoubleArray Method
Application Class See Also Send Feedback
Creates a new instance of a double array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray NewDoubleArray()
Visual Basic
Public Function NewDoubleArray As DoubleArray
Visual C++
public:
DoubleArray^ NewDoubleArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFExportOptions Method

[image]

Revit 2013 API
Application..::..NewDWFExportOptions Method
Application Class See Also Send Feedback
Creates DWF Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFExportOptions NewDWFExportOptions()
Visual Basic
Public Function NewDWFExportOptions As DWFExportOptions
Visual C++
public:
DWFExportOptions^ NewDWFExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewDWFXExportOptions Method

[image]

Revit 2013 API
Application..::..NewDWFXExportOptions Method
Application Class See Also Send Feedback
Creates DWFX Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFXExportOptions NewDWFXExportOptions()
Visual Basic
Public Function NewDWFXExportOptions As DWFXExportOptions
Visual C++
public:
DWFXExportOptions^ NewDWFXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementArray Method

[image]

Revit 2013 API
Application..::..NewElementArray Method
Application Class See Also Send Feedback
Returns an array that can hold element objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013.  Use .NET generic collection classes instead.")]
public ElementArray NewElementArray()
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013.  Use .NET generic collection classes instead.")> _
Public Function NewElementArray As ElementArray
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013.  Use .NET generic collection classes instead.")]
public:
ElementArray^ NewElementArray()

Return Value

An empty array that can contain any Autodesk Revit element derived objects.

Remarks

The array returned by this method can be used as a general purpose tool for holding ordered lists of any type of element.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementId Method

[image]

Revit 2013 API
Application..::..NewElementId Method
Application Class See Also Send Feedback
Creates a new Autodesk::Revit::DB::ElementId^ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId NewElementId()
Visual Basic
Public Function NewElementId As ElementId
Visual C++
public:
ElementId^ NewElementId()

Return Value

The new Autodesk::Revit::DB::ElementId^ object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewElementSet Method

[image]

Revit 2013 API
Application..::..NewElementSet Method
Application Class See Also Send Feedback
Creates a new instance of a set specifically for holding elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet NewElementSet()
Visual Basic
Public Function NewElementSet As ElementSet
Visual C++
public:
ElementSet^ NewElementSet()

Return Value

A new Element Set.

Remarks

This is a general purpose set for passing elements to and from methods.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewEllipse Method

[image]

Revit 2013 API
Application..::..NewEllipse Method
Application Class See Also Send Feedback
Creates a new geometric ellipse object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Ellipse NewEllipse(
    XYZ center,
    double radX,
    double radY,
    XYZ xVec,
    XYZ yVec,
    double param0,
    double param1
)
Visual Basic
Public Function NewEllipse ( _
    center As XYZ, _
    radX As Double, _
    radY As Double, _
    xVec As XYZ, _
    yVec As XYZ, _
    param0 As Double, _
    param1 As Double _
) As Ellipse
Visual C++
public:
Ellipse^ NewEllipse(
    XYZ^ center,
    double radX,
    double radY,
    XYZ^ xVec,
    XYZ^ yVec,
    double param0,
    double param1
)

Parameters

center
Type: Autodesk.Revit.DB..::..XYZ
The center of the ellipse.
radX
Type: System..::..Double
The x vector radius of the ellipse. Should be > 0.
radY
Type: System..::..Double
The y vector radius of the ellipse. Should be > 0.
xVec
Type: Autodesk.Revit.DB..::..XYZ
The x axis to define the ellipse plane.
yVec
Type: Autodesk.Revit.DB..::..XYZ
The y axis to define the ellipse plane. xVec must be orthogonal with yVec.
param0
Type: System..::..Double
The raw parameter value at the start of the ellipse. Should be greater than or equal to -2PI and less than Param1.
param1
Type: System..::..Double
The raw parameter value at the end of the ellipse. Should be greater than Param0 and less than or equal to 2*PI.

Remarks

PI represents the value used in Revit internal code: 3.14159265358979.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFaceArray Method

[image]

Revit 2013 API
Application..::..NewFaceArray Method
Application Class See Also Send Feedback
Creates a new instance of a face array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FaceArray NewFaceArray()
Visual Basic
Public Function NewFaceArray As FaceArray
Visual C++
public:
FaceArray^ NewFaceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method

[image] [image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Overload List

 | Name | Description
Public method | NewFamilyInstanceCreationData(Face, Line, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Public method | NewFamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (Face, Line, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
Specify if the family instance is structural.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (Curve, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (Face, XYZ, XYZ, FamilySymbol)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2013 API
Application..::..NewFamilyInstanceCreationData Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData NewFamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstanceCreationData ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstanceCreationData
Visual C++
public:
FamilyInstanceCreationData^ NewFamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the family instance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

Application Class
NewFamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


NewFamilySymbolProfile Method

[image]

Revit 2013 API
Application..::..NewFamilySymbolProfile Method
Application Class See Also Send Feedback
Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolProfile NewFamilySymbolProfile(
    FamilySymbol familySymbol
)
Visual Basic
Public Function NewFamilySymbolProfile ( _
    familySymbol As FamilySymbol _
) As FamilySymbolProfile
Visual C++
public:
FamilySymbolProfile^ NewFamilySymbolProfile(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol of the Profile.

Return Value

The new FamilySymbolProfile object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument familySymbol is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewFBXExportOptions Method

[image]

Revit 2013 API
Application..::..NewFBXExportOptions Method
Application Class See Also Send Feedback
Creates 3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FBXExportOptions NewFBXExportOptions()
Visual Basic
Public Function NewFBXExportOptions As FBXExportOptions
Visual C++
public:
FBXExportOptions^ NewFBXExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLExportOptions Method

[image]

Revit 2013 API
Application..::..NewGBXMLExportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GBXMLExportOptions NewGBXMLExportOptions()
Visual Basic
Public Function NewGBXMLExportOptions As GBXMLExportOptions
Visual C++
public:
GBXMLExportOptions^ NewGBXMLExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGBXMLImportOptions Method

[image]

Revit 2013 API
Application..::..NewGBXMLImportOptions Method
Application Class See Also Send Feedback
Creates Green-Building XML Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GBXMLImportOptions NewGBXMLImportOptions()
Visual Basic
Public Function NewGBXMLImportOptions As GBXMLImportOptions
Visual C++
public:
GBXMLImportOptions^ NewGBXMLImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewGeometryOptions Method

[image]

Revit 2013 API
Application..::..NewGeometryOptions Method
Application Class Example See Also Send Feedback
Creates an object to specify user preferences in parsing of geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Options NewGeometryOptions()
Visual Basic
Public Function NewGeometryOptions As Options
Visual C++
public:
Options^ NewGeometryOptions()

Return Value

Examples

CopyC#
Autodesk.Revit.DB.Options geomOption = application.Create.NewGeometryOptions();
if (null != geomOption)
{
    geomOption.ComputeReferences = true;
    geomOption.DetailLevel = Autodesk.Revit.DB.ViewDetailLevel.Fine;

    // Either the DetailLevel or the View can be set, but not both
    //geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.");
}
CopyVB.NET
Dim geomOption As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
If geomOption IsNot Nothing Then
    geomOption.ComputeReferences = True
    geomOption.DetailLevel = Autodesk.Revit.DB.DetailLevels.Fine

    ' Either the DetailLevel or the View can be set, but not both
    'geomOption.View = commandData.Application.Application.ActiveDocument.ActiveView;

    TaskDialog.Show("Revit", "Geometry Option created successfully.")
End If

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewHermiteSpline Method

[image] [image]

Revit 2013 API
Application..::..NewHermiteSpline Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean) | Creates a Hermite spline with default tangency at its endpoints.
Public method | NewHermiteSpline(IList<(Of <<'(XYZ>)>>), Boolean, XYZ, XYZ) | Creates a Hermite spline with specified tangency at its endpoints.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewHermiteSpline Method (IList(XYZ), Boolean)

[image]

Revit 2013 API
Application..::..NewHermiteSpline Method (IList<(Of <(<'XYZ>)>)>, Boolean)
Application Class See Also Send Feedback
Creates a Hermite spline with default tangency at its endpoints.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    IList<XYZ> ctrlPoints,
    bool bPeriodic
)
Visual Basic
Public Function NewHermiteSpline ( _
    ctrlPoints As IList(Of XYZ), _
    bPeriodic As Boolean _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    IList<XYZ^>^ ctrlPoints,
    bool bPeriodic
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the Hermite spline.
bPeriodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic.

Remarks

The tangents at the ends of the spline are computed from the control points.

See Also

Application Class
NewHermiteSpline Overload
Autodesk.Revit.Creation Namespace


NewHermiteSpline Method (IList(XYZ), Boolean, XYZ, XYZ)

[image]

Revit 2013 API
Application..::..NewHermiteSpline Method (IList<(Of <(<'XYZ>)>)>, Boolean, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a Hermite spline with specified tangency at its endpoints.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HermiteSpline NewHermiteSpline(
    IList<XYZ> ctrlPoints,
    bool bPeriodic,
    XYZ startTangent,
    XYZ endTangent
)
Visual Basic
Public Function NewHermiteSpline ( _
    ctrlPoints As IList(Of XYZ), _
    bPeriodic As Boolean, _
    startTangent As XYZ, _
    endTangent As XYZ _
) As HermiteSpline
Visual C++
public:
HermiteSpline^ NewHermiteSpline(
    IList<XYZ^>^ ctrlPoints,
    bool bPeriodic,
    XYZ^ startTangent,
    XYZ^ endTangent
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the Hermite spline.
bPeriodic
Type: System..::..Boolean
True if the Hermite spline is to be periodic.
startTangent
Type: Autodesk.Revit.DB..::..XYZ
Tangent vector at the start of the spline. Can be null, in which case the tangent is computed from the control points.
endTangent
Type: Autodesk.Revit.DB..::..XYZ
Tangent vector at the end of the spline. Can be null, in which case the tangent is computed from the control points.

Remarks

See Also

Application Class
NewHermiteSpline Overload
Autodesk.Revit.Creation Namespace


NewImageImportOptions Method

[image]

Revit 2013 API
Application..::..NewImageImportOptions Method
Application Class See Also Send Feedback
Creates Image Import options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageImportOptions NewImageImportOptions()
Visual Basic
Public Function NewImageImportOptions As ImageImportOptions
Visual C++
public:
ImageImportOptions^ NewImageImportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image] [image]

Revit 2013 API
Application..::..NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new instance binding object.

Overload List

 | Name | Description
Public method | NewInstanceBinding()()()() | Creates a new empty instance binding object.
Public method | NewInstanceBinding(CategorySet) | Creates a new instance binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method

[image]

Revit 2013 API
Application..::..NewInstanceBinding Method
Application Class See Also Send Feedback
Creates a new empty instance binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding()
Visual Basic
Public Function NewInstanceBinding As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding()

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewInstanceBinding Method (CategorySet)

[image]

Revit 2013 API
Application..::..NewInstanceBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new instance binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceBinding NewInstanceBinding(
    CategorySet categorySet
)
Visual Basic
Public Function NewInstanceBinding ( _
    categorySet As CategorySet _
) As InstanceBinding
Visual C++
public:
InstanceBinding^ NewInstanceBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::..CategorySet
A set of categories that will be added to the binding.

Return Value

A new instance binding object.

Remarks

Instance binding objects are used for attaching shared parameter definitions to all instances of an element within a category.

See Also

Application Class
NewInstanceBinding Overload
Autodesk.Revit.Creation Namespace


NewIntersectionResultArray Method

[image]

Revit 2013 API
Application..::..NewIntersectionResultArray Method
Application Class See Also Send Feedback
Creates a new instance of an IntersectionResult array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResultArray NewIntersectionResultArray()
Visual Basic
Public Function NewIntersectionResultArray As IntersectionResultArray
Visual C++
public:
IntersectionResultArray^ NewIntersectionResultArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLine Method

[image]

Revit 2013 API
Application..::..NewLine Method
Application Class Example See Also Send Feedback
Creates a new bound or unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLine(
    XYZ point,
    XYZ endOrDirection,
    bool bound
)
Visual Basic
Public Function NewLine ( _
    point As XYZ, _
    endOrDirection As XYZ, _
    bound As Boolean _
) As Line
Visual C++
public:
Line^ NewLine(
    XYZ^ point,
    XYZ^ endOrDirection,
    bool bound
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
A start point or a point through which the line will pass.
endOrDirection
Type: Autodesk.Revit.DB..::..XYZ
An end point of a vector for the direction of the line.
bound
Type: System..::..Boolean
Set to True if you wish the line to be bound or False is the line is to be infinite.

Return Value

A new bounded or unbounded line object.

Remarks

If the bound parameter is False then the point parameter is considered to be a point on the line and the endOrDirection parameter is considered to be a directional vector. If the bound parameter is True then the point parameter is considered to be the start of the line and the endOrDirection parameter is considered to be the end of the line.

Examples

CopyC#
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// Create unbound line
Line line1 = application.Create.NewLine(startPoint, endPoint, false);

// Create bound line
Line line2 = application.Create.NewLine(startPoint, endPoint, true);
CopyVB.NET
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' Create unbound line
Dim line1 As Line = application.Create.NewLine(startPoint, endPoint, False)

' Create bound line
Dim line2 As Line = application.Create.NewLine(startPoint, endPoint, True)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineBound Method

[image]

Revit 2013 API
Application..::..NewLineBound Method
Application Class Example See Also Send Feedback
Creates a new bounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLineBound(
    XYZ start,
    XYZ end
)
Visual Basic
Public Function NewLineBound ( _
    start As XYZ, _
    end As XYZ _
) As Line
Visual C++
public:
Line^ NewLineBound(
    XYZ^ start,
    XYZ^ end
)

Parameters

start
Type: Autodesk.Revit.DB..::..XYZ
A start point for the line.
end
Type: Autodesk.Revit.DB..::..XYZ
An end point for the line.

Return Value

A new bounded line object.

Remarks

The new line is bounded and has the start parameter as the start point and the end parameter as the end point.

Examples

CopyC#
// define start and end for bound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineBound(startPoint, endPoint);
CopyVB.NET
' define start and end for bound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineBound(startPoint, endPoint)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLineUnbound Method

[image]

Revit 2013 API
Application..::..NewLineUnbound Method
Application Class Example See Also Send Feedback
Creates a new unbounded geometric line object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line NewLineUnbound(
    XYZ point,
    XYZ direction
)
Visual Basic
Public Function NewLineUnbound ( _
    point As XYZ, _
    direction As XYZ _
) As Line
Visual C++
public:
Line^ NewLineUnbound(
    XYZ^ point,
    XYZ^ direction
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
A point through which the line will pass.
direction
Type: Autodesk.Revit.DB..::..XYZ
A vector for the direction of the line.

Return Value

A new unbounded line object.

Remarks

The line returned will be infinite in length and pass through the point provided in the specified direction. This method is useful for generating an axis around which an element can be rotated.

Examples

CopyC#
// define start point and direction for unbound line
XYZ startPoint = new XYZ(0, 0, 0);
XYZ directionPt = new XYZ(10, 10, 10);

// create line
Line line = application.Create.NewLineUnbound(startPoint, directionPt);
CopyVB.NET
' define start point and direction for unbound line
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim directionPt As New Autodesk.Revit.DB.XYZ(10, 10, 10)

' create line
Dim line As Line = application.Create.NewLineUnbound(startPoint, directionPt)

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCaseArray Method

[image]

Revit 2013 API
Application..::..NewLoadCaseArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCase array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCaseArray NewLoadCaseArray()
Visual Basic
Public Function NewLoadCaseArray As LoadCaseArray
Visual C++
public:
LoadCaseArray^ NewLoadCaseArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadCombinationArray Method

[image]

Revit 2013 API
Application..::..NewLoadCombinationArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadCombination array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCombinationArray NewLoadCombinationArray()
Visual Basic
Public Function NewLoadCombinationArray As LoadCombinationArray
Visual C++
public:
LoadCombinationArray^ NewLoadCombinationArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewLoadUsageArray Method

[image]

Revit 2013 API
Application..::..NewLoadUsageArray Method
Application Class See Also Send Feedback
Creates a new instance of a LoadUsage array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadUsageArray NewLoadUsageArray()
Visual Basic
Public Function NewLoadUsageArray As LoadUsageArray
Visual C++
public:
LoadUsageArray^ NewLoadUsageArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewMaterialSet Method

[image]

Revit 2013 API
Application..::..NewMaterialSet Method
Application Class See Also Send Feedback
Create a new instance of MaterialSet.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Use Material.Create to create materials instead.")]
public MaterialSet NewMaterialSet()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Use Material.Create to create materials instead.")> _
Public Function NewMaterialSet As MaterialSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Use Material.Create to create materials instead.")]
public:
MaterialSet^ NewMaterialSet()

Return Value

The newly created MaterialSet instance.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewNurbSpline Method

[image] [image]

Revit 2013 API
Application..::..NewNurbSpline Method
Application Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(Double>)>>)) | Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.
Public method | NewNurbSpline(IList<(Of <<'(XYZ>)>>), DoubleArray, DoubleArray, Int32, Boolean, Boolean) | Creates a new geometric nurbSpline object.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewNurbSpline Method (IList(XYZ), IList(Double))

[image]

Revit 2013 API
Application..::..NewNurbSpline Method (IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'Double>)>)>)
Application Class See Also Send Feedback
Creates a new geometric NurbSpline object using the same calculations that Revit uses when sketching splines in the user interface.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    IList<XYZ> ctrlPoints,
    IList<double> weights
)
Visual Basic
Public Function NewNurbSpline ( _
    ctrlPoints As IList(Of XYZ), _
    weights As IList(Of Double) _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    IList<XYZ^>^ ctrlPoints,
    IList<double>^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the nurbSpline.
weights
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The weights of the nurbSpline.

Remarks

Knots and degree of the spline are computed from the control points and weights.

See Also

Application Class
NewNurbSpline Overload
Autodesk.Revit.Creation Namespace


NewNurbSpline Method (IList(XYZ), DoubleArray, DoubleArray, Int32, Boolean, Boolean)

[image]

Revit 2013 API
Application..::..NewNurbSpline Method (IList<(Of <(<'XYZ>)>)>, DoubleArray, DoubleArray, Int32, Boolean, Boolean)
Application Class See Also Send Feedback
Creates a new geometric nurbSpline object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public NurbSpline NewNurbSpline(
    IList<XYZ> ctrlPoints,
    DoubleArray weights,
    DoubleArray knots,
    int nDegree,
    bool bClosed,
    bool bRational
)
Visual Basic
Public Function NewNurbSpline ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray, _
    knots As DoubleArray, _
    nDegree As Integer, _
    bClosed As Boolean, _
    bRational As Boolean _
) As NurbSpline
Visual C++
public:
NurbSpline^ NewNurbSpline(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights,
    DoubleArray^ knots,
    int nDegree,
    bool bClosed,
    bool bRational
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The control points of the nurbSpline.
weights
Type: Autodesk.Revit.DB..::..DoubleArray
The weights of the nurbSpline.
knots
Type: Autodesk.Revit.DB..::..DoubleArray
The knots of the nurbSpline.
nDegree
Type: System..::..Int32
The degree of the nurbSpline.
bClosed
Type: System..::..Boolean
The nurbSpline is closed or not.
bRational
Type: System..::..Boolean
The nurbSpline is rational or not rational.

Remarks

The size of knots must equal the sum of nDegree, ctrlPoints.size and 1, and the first nDegree+1 elements in the knots always are zero.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If bRational is true, the size of ctrlPoints and weights must be equal.

See Also

Application Class
NewNurbSpline Overload
Autodesk.Revit.Creation Namespace


NewPlane Method

[image] [image]

Revit 2013 API
Application..::..NewPlane Method
Application Class See Also Send Feedback
Creates a new geometric plane object.

Overload List

 | Name | Description
Public method | NewPlane(CurveArray) | Creates a new geometric plane from a loop of planar curves.
Public method | NewPlane(XYZ, XYZ) | Creates a new geometric plane object based on a normal vector and an origin.
Public method | NewPlane(XYZ, XYZ, XYZ) | Creates a new geometric plane object based on two coordinate vectors and an origin.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewPlane Method (CurveArray)

[image]

Revit 2013 API
Application..::..NewPlane Method (CurveArray)
Application Class See Also Send Feedback
Creates a new geometric plane from a loop of planar curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane NewPlane(
    CurveArray curveloop
)
Visual Basic
Public Function NewPlane ( _
    curveloop As CurveArray _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    CurveArray^ curveloop
)

Parameters

curveloop
Type: Autodesk.Revit.DB..::..CurveArray
The closed loop of planar curves to locate plane.

Return Value

If successful a new geometric plane will be returned. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input curve loop is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input curve loop does not lie in a plane.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input curve loop is not closed.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ)

[image]

Revit 2013 API
Application..::..NewPlane Method (XYZ, XYZ)
Application Class Example See Also Send Feedback
Creates a new geometric plane object based on a normal vector and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ norm,
    XYZ origin
)
Visual Basic
Public Function NewPlane ( _
    norm As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.DB..::..XYZ
Z vector of the plane coordinate system.
origin
Type: Autodesk.Revit.DB..::..XYZ
Origin of the plane coordinate system.

Return Value

A new plane object.

Examples

CopyC#
 // Create a geometry plane in Revit application
XYZ normal = XYZ.BasisZ;    // use basis of the z-axis (0,0,1) for normal vector
XYZ origin = XYZ.Zero;  // origin is (0,0,0)
 Plane geomPlane = application.Create.NewPlane(normal, origin);
CopyVB.NET
' Create a geometry plane in Revit application
Dim normal As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.BasisZ
' use basis of the z-axis (0,0,1) for normal vector
Dim origin As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
' origin is (0,0,0)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPlane Method (XYZ, XYZ, XYZ)

[image]

Revit 2013 API
Application..::..NewPlane Method (XYZ, XYZ, XYZ)
Application Class See Also Send Feedback
Creates a new geometric plane object based on two coordinate vectors and an origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane NewPlane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic
Public Function NewPlane ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
) As Plane
Visual C++
public:
Plane^ NewPlane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.DB..::..XYZ
X vector of the plane coordinate system.
yVec
Type: Autodesk.Revit.DB..::..XYZ
Y vector of the plane coordinate system.
origin
Type: Autodesk.Revit.DB..::..XYZ
Origin of the plane coordinate system.

Return Value

A new plane object.

See Also

Application Class
NewPlane Overload
Autodesk.Revit.Creation Namespace


NewPoint Method

[image]

Revit 2013 API
Application..::..NewPoint Method
Application Class See Also Send Feedback
Creates a new geometric point object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Point NewPoint(
    XYZ coord
)
Visual Basic
Public Function NewPoint ( _
    coord As XYZ _
) As Point
Visual C++
public:
Point^ NewPoint(
    XYZ^ coord
)

Parameters

coord
Type: Autodesk.Revit.DB..::..XYZ
The coordinates of the point.

Remarks

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdge Method

[image]

Revit 2013 API
Application..::..NewPointOnEdge Method
Application Class See Also Send Feedback
Create a PointOnEdge object which is used to define the placement of a ReferencePoint.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnEdge NewPointOnEdge(
    Reference edgeReference,
    PointLocationOnCurve locationOnCurve
)
Visual Basic
Public Function NewPointOnEdge ( _
    edgeReference As Reference, _
    locationOnCurve As PointLocationOnCurve _
) As PointOnEdge
Visual C++
public:
PointOnEdge^ NewPointOnEdge(
    Reference^ edgeReference,
    PointLocationOnCurve^ locationOnCurve
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference whose edge the object will be created on.
locationOnCurve
Type: Autodesk.Revit.DB..::..PointLocationOnCurve
The location on the edge.

Return Value

If creation was successful then a new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference or locationOnCurve is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeEdgeIntersection Method

[image]

Revit 2013 API
Application..::..NewPointOnEdgeEdgeIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeEdgeIntersection object which is used to define the placement of a ReferencePoint given two references to edge.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnEdgeEdgeIntersection NewPointOnEdgeEdgeIntersection(
    Reference edgeReference1,
    Reference edgeReference2
)
Visual Basic
Public Function NewPointOnEdgeEdgeIntersection ( _
    edgeReference1 As Reference, _
    edgeReference2 As Reference _
) As PointOnEdgeEdgeIntersection
Visual C++
public:
PointOnEdgeEdgeIntersection^ NewPointOnEdgeEdgeIntersection(
    Reference^ edgeReference1,
    Reference^ edgeReference2
)

Parameters

edgeReference1
Type: Autodesk.Revit.DB..::..Reference
The first edge reference.
edgeReference2
Type: Autodesk.Revit.DB..::..Reference
The second edge reference.

Return Value

A new PointOnEdgeEdgeIntersection object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference1 or edgeReference2 is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnEdgeFaceIntersection Method

[image]

Revit 2013 API
Application..::..NewPointOnEdgeFaceIntersection Method
Application Class See Also Send Feedback
Construct a PointOnEdgeFaceIntersection object which is used to define the placement of a ReferencePoint given a references to edge and a reference to face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnEdgeFaceIntersection NewPointOnEdgeFaceIntersection(
    Reference edgeReference,
    Reference faceReference,
    bool orientWithEdge
)
Visual Basic
Public Function NewPointOnEdgeFaceIntersection ( _
    edgeReference As Reference, _
    faceReference As Reference, _
    orientWithEdge As Boolean _
) As PointOnEdgeFaceIntersection
Visual C++
public:
PointOnEdgeFaceIntersection^ NewPointOnEdgeFaceIntersection(
    Reference^ edgeReference,
    Reference^ faceReference,
    bool orientWithEdge
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The edge reference.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The face reference.
orientWithEdge
Type: System..::..Boolean

Return Value

A new PointOnEdgeFaceIntersection object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument edgeReference or faceReference is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnFace Method

[image]

Revit 2013 API
Application..::..NewPointOnFace Method
Application Class See Also Send Feedback
Construct a PointOnFace object which is used to define the placement of a ReferencePoint given a reference and a location on the face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnFace NewPointOnFace(
    Reference faceReference,
    UV uv
)
Visual Basic
Public Function NewPointOnFace ( _
    faceReference As Reference, _
    uv As UV _
) As PointOnFace
Visual C++
public:
PointOnFace^ NewPointOnFace(
    Reference^ faceReference,
    UV^ uv
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference whose face the object will be created on.
uv
Type: Autodesk.Revit.DB..::..UV
A 2-dimensional position.

Return Value

A new PointOnFace object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument faceReference or uv is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointOnPlane Method

[image]

Revit 2013 API
Application..::..NewPointOnPlane Method
Application Class See Also Send Feedback
Construct a PointOnPlane object which is used to define the placement of a ReferencePoint from its property values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointOnPlane NewPointOnPlane(
    Reference planeReference,
    UV position,
    UV xvec,
    double offset
)
Visual Basic
Public Function NewPointOnPlane ( _
    planeReference As Reference, _
    position As UV, _
    xvec As UV, _
    offset As Double _
) As PointOnPlane
Visual C++
public:
PointOnPlane^ NewPointOnPlane(
    Reference^ planeReference,
    UV^ position,
    UV^ xvec,
    double offset
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::..Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)
position
Type: Autodesk.Revit.DB..::..UV
Coordinates of the point's projection onto the plane; see the Position property.
xvec
Type: Autodesk.Revit.DB..::..UV
The direction of the point's X-coordinate vector in the plane's coordinates; see the XVec property. Optional; default value is (1, 0).
offset
Type: System..::..Double
Signed offset from the plane; see the Offset property.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument planeReference or position or xvec is nullNothingnullptra null reference (Nothing in Visual Basic) or offset is not a valid double value.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewPointRelativeToPoint Method

[image]

Revit 2013 API
Application..::..NewPointRelativeToPoint Method
Application Class See Also Send Feedback
Create a PointRelativeToPoint object, which is used to define the placement of a ReferencePoint relative to a host point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PointRelativeToPoint NewPointRelativeToPoint(
    Reference hostPointReference
)
Visual Basic
Public Function NewPointRelativeToPoint ( _
    hostPointReference As Reference _
) As PointRelativeToPoint
Visual C++
public:
PointRelativeToPoint^ NewPointRelativeToPoint(
    Reference^ hostPointReference
)

Parameters

hostPointReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the host point.

Return Value

If creation is successful then a new PointRelativeToPoint object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument hostPointReference is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method

[image] [image]

Revit 2013 API
Application..::..NewProfiledWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

 | Name | Description
Public method | NewProfiledWallCreationData(CurveArray, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, Boolean)

[image]

Revit 2013 API
Application..::..NewProfiledWallCreationData Method (CurveArray, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2013 API
Application..::..NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2013 API
Application..::..NewProfiledWallCreationData Method (CurveArray, WallType, Level, Boolean, XYZ)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData NewProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
Public Function NewProfiledWallCreationData ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As ProfiledWallCreationData
Visual C++
public:
ProfiledWallCreationData^ NewProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

Application Class
NewProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewProjectPosition Method

[image]

Revit 2013 API
Application..::..NewProjectPosition Method
Application Class See Also Send Feedback
Creates a new project position object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectPosition NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic
Public Function NewProjectPosition ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
) As ProjectPosition
Visual C++
public:
ProjectPosition^ NewProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::..Double
East to West offset in feet.
ns
Type: System..::..Double
North to South offset in feet.
elevation
Type: System..::..Double
Elevation above sea level in feet.
angle
Type: System..::..Double
Rotation angle away from true north in the range of -PI to +PI.

Remarks

This object contains offset information and is used by the project location object for setting the project location relative to the site location. Measurements are in feet and radians.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method

[image] [image]

Revit 2013 API
Application..::..NewRectangularWallCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation.

Overload List

 | Name | Description
Public method | NewRectangularWallCreationData(Curve, Level, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation
Public method | NewRectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Creates an object which wraps the arguments of NewWall() for batch creation

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, Level, Boolean)

[image]

Revit 2013 API
Application..::..NewRectangularWallCreationData Method (Curve, Level, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2013 API
Application..::..NewRectangularWallCreationData Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewWall() for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularWallCreationData NewRectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
Public Function NewRectangularWallCreationData ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As RectangularWallCreationData
Visual C++
public:
RectangularWallCreationData^ NewRectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall.
offset
Type: System..::..Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

Application Class
NewRectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


NewReferenceArray Method

[image]

Revit 2013 API
Application..::..NewReferenceArray Method
Application Class See Also Send Feedback
Creates a new instance of a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray NewReferenceArray()
Visual Basic
Public Function NewReferenceArray As ReferenceArray
Visual C++
public:
ReferenceArray^ NewReferenceArray()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewReferencePointArray Method

[image]

Revit 2013 API
Application..::..NewReferencePointArray Method
Application Class See Also Send Feedback
Creates an empty array that can store ReferencePoint objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePointArray NewReferencePointArray()
Visual Basic
Public Function NewReferencePointArray As ReferencePointArray
Visual C++
public:
ReferencePointArray^ NewReferencePointArray()

Return Value

An empty array that can hold ReferencePoint objects.

Remarks

This method can be used to create an array that can hold ReferencePoint objects. This array can be then passed to methods, such as NewCurveByPoints, to represent two or more PointElements.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewRoomCreationData Method

[image]

Revit 2013 API
Application..::..NewRoomCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewRoom() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomCreationData NewRoomCreationData(
    Level level,
    UV point
)
Visual Basic
Public Function NewRoomCreationData ( _
    level As Level, _
    point As UV _
) As RoomCreationData
Visual C++
public:
RoomCreationData^ NewRoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point the dictates the location on that specified level.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSATExportOptions Method

[image]

Revit 2013 API
Application..::..NewSATExportOptions Method
Application Class See Also Send Feedback
Creates SAT Export options.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SATExportOptions NewSATExportOptions()
Visual Basic
Public Function NewSATExportOptions As SATExportOptions
Visual C++
public:
SATExportOptions^ NewSATExportOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewSpaceSet Method

[image]

Revit 2013 API
Application..::..NewSpaceSet Method
Application Class See Also Send Feedback
Creates a new instance of a space set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceSet NewSpaceSet()
Visual Basic
Public Function NewSpaceSet As SpaceSet
Visual C++
public:
SpaceSet^ NewSpaceSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewStringStringMap Method

[image]

Revit 2013 API
Application..::..NewStringStringMap Method
Application Class See Also Send Feedback
Creates a new map that maps one string to another string.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StringStringMap NewStringStringMap()
Visual Basic
Public Function NewStringStringMap As StringStringMap
Visual C++
public:
StringStringMap^ NewStringStringMap()

Return Value

A map that maps one string to another.

Remarks

This is a general purpose string to string mapping which can be used for generating Autodesk Revit library paths.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method

[image] [image]

Revit 2013 API
Application..::..NewTextNoteCreationData Method
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Overload List

 | Name | Description
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.
Public method | NewTextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates an object which wraps the arguments of NewTextNote() for batch creation.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2013 API
Application..::..NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2013 API
Application..::..NewTextNoteCreationData Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
Application Class See Also Send Feedback
Creates an object which wraps the arguments of NewTextNote() for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteCreationData NewTextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic
Public Function NewTextNoteCreationData ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNoteCreationData
Visual C++
public:
TextNoteCreationData^ NewTextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::..TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.DB..::..XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::..XYZ
The elbow point for the leader.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

Application Class
NewTextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image] [image]

Revit 2013 API
Application..::..NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new type binding object.

Overload List

 | Name | Description
Public method | NewTypeBinding()()()() | Creates a new empty type binding object.
Public method | NewTypeBinding(CategorySet) | Creates a new type binding object containing the categories passed as a parameter.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewTypeBinding Method

[image]

Revit 2013 API
Application..::..NewTypeBinding Method
Application Class See Also Send Feedback
Creates a new empty type binding object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding()
Visual Basic
Public Function NewTypeBinding As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding()

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category. Categories can be added to the instance binding via the Categories property of the InstanceBinding object

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewTypeBinding Method (CategorySet)

[image]

Revit 2013 API
Application..::..NewTypeBinding Method (CategorySet)
Application Class See Also Send Feedback
Creates a new type binding object containing the categories passed as a parameter.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TypeBinding NewTypeBinding(
    CategorySet categorySet
)
Visual Basic
Public Function NewTypeBinding ( _
    categorySet As CategorySet _
) As TypeBinding
Visual C++
public:
TypeBinding^ NewTypeBinding(
    CategorySet^ categorySet
)

Parameters

categorySet
Type: Autodesk.Revit.DB..::..CategorySet
A set of categories that will be added to the binding.

Return Value

A new type binding object.

Remarks

Type binding objects are used for attaching shared parameter definitions to a type within a category.

See Also

Application Class
NewTypeBinding Overload
Autodesk.Revit.Creation Namespace


NewUV Method

[image] [image]

Revit 2013 API
Application..::..NewUV Method
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space.

Overload List

 | Name | Description
Public method | NewUV()()()() | Creates a UV object at the origin.
Public method | NewUV(UV) | Creates a UV object by copying the supplied UV object.
Public method | NewUV(Double, Double) | Creates a UV object representing coordinates in 2-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewUV Method

[image]

Revit 2013 API
Application..::..NewUV Method
Application Class See Also Send Feedback
Creates a UV object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV NewUV()
Visual Basic
Public Function NewUV As UV
Visual C++
public:
UV^ NewUV()

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (UV)

[image]

Revit 2013 API
Application..::..NewUV Method (UV)
Application Class See Also Send Feedback
Creates a UV object by copying the supplied UV object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV NewUV(
    UV uv
)
Visual Basic
Public Function NewUV ( _
    uv As UV _
) As UV
Visual C++
public:
UV^ NewUV(
    UV^ uv
)

Parameters

uv
Type: Autodesk.Revit.DB..::..UV
The supplied UV object

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewUV Method (Double, Double)

[image]

Revit 2013 API
Application..::..NewUV Method (Double, Double)
Application Class See Also Send Feedback
Creates a UV object representing coordinates in 2-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV NewUV(
    double u,
    double v
)
Visual Basic
Public Function NewUV ( _
    u As Double, _
    v As Double _
) As UV
Visual C++
public:
UV^ NewUV(
    double u,
    double v
)

Parameters

u
Type: System..::..Double
The first coordinate.
v
Type: System..::..Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

Application Class
NewUV Overload
Autodesk.Revit.Creation Namespace


NewVertexIndexPair Method

[image]

Revit 2013 API
Application..::..NewVertexIndexPair Method
Application Class See Also Send Feedback
Creates a new VertexIndexPair object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPair NewVertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic
Public Function NewVertexIndexPair ( _
    iTop As Integer, _
    iBottom As Integer _
) As VertexIndexPair
Visual C++
public:
VertexIndexPair^ NewVertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::..Int32
The index of the vertex pair from the top profile of a blend.
iBottom
Type: System..::..Int32
The index of the vertex pair from the bottom profile of a blend.

Return Value

The new VertexIndexPair object.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVertexIndexPairArray Method

[image]

Revit 2013 API
Application..::..NewVertexIndexPairArray Method
Application Class See Also Send Feedback
Returns an array that can hold VertexIndexPair objects.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPairArray NewVertexIndexPairArray()
Visual Basic
Public Function NewVertexIndexPairArray As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ NewVertexIndexPairArray()

Return Value

The new VertexIndexPairArray objects.

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewViewSet Method

[image]

Revit 2013 API
Application..::..NewViewSet Method
Application Class See Also Send Feedback
Creates a new instance of a View set.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSet NewViewSet()
Visual Basic
Public Function NewViewSet As ViewSet
Visual C++
public:
ViewSet^ NewViewSet()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewVolumeCalculationOptions Method

[image]

Revit 2013 API
Application..::..NewVolumeCalculationOptions Method
Application Class See Also Send Feedback
Creates options related to room volume and area computations.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VolumeCalculationOptions NewVolumeCalculationOptions()
Visual Basic
Public Function NewVolumeCalculationOptions As VolumeCalculationOptions
Visual C++
public:
VolumeCalculationOptions^ NewVolumeCalculationOptions()

See Also

Application Class
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image] [image]

Revit 2013 API
Application..::..NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space.

Overload List

 | Name | Description
Public method | NewXYZ()()()() | Creates a XYZ object at the origin.
Public method | NewXYZ(XYZ) | Creates a XYZ object by copying the supplied XYZ object.
Public method | NewXYZ(Double, Double, Double) | Creates a XYZ object representing coordinates in 3-space with supplied values.

See Also

Application Class
Application Members
Autodesk.Revit.Creation Namespace


NewXYZ Method

[image]

Revit 2013 API
Application..::..NewXYZ Method
Application Class See Also Send Feedback
Creates a XYZ object at the origin.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ NewXYZ()
Visual Basic
Public Function NewXYZ As XYZ
Visual C++
public:
XYZ^ NewXYZ()

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (XYZ)

[image]

Revit 2013 API
Application..::..NewXYZ Method (XYZ)
Application Class See Also Send Feedback
Creates a XYZ object by copying the supplied XYZ object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ NewXYZ(
    XYZ xyz
)
Visual Basic
Public Function NewXYZ ( _
    xyz As XYZ _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    XYZ^ xyz
)

Parameters

xyz
Type: Autodesk.Revit.DB..::..XYZ
The supplied XYZ object

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


NewXYZ Method (Double, Double, Double)

[image]

Revit 2013 API
Application..::..NewXYZ Method (Double, Double, Double)
Application Class See Also Send Feedback
Creates a XYZ object representing coordinates in 3-space with supplied values.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ NewXYZ(
    double x,
    double y,
    double z
)
Visual Basic
Public Function NewXYZ ( _
    x As Double, _
    y As Double, _
    z As Double _
) As XYZ
Visual C++
public:
XYZ^ NewXYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double
The first coordinate.
y
Type: System..::..Double
The second coordinate.
z
Type: System..::..Double
The third coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

Application Class
NewXYZ Overload
Autodesk.Revit.Creation Namespace


Application Properties

[image] [image]

Revit 2013 API
Application Properties
Application Class See Also Send Feedback

The Application type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Application Class
Autodesk.Revit.Creation Namespace


AreaCreationData Class

[image]

Revit 2013 API
AreaCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Area for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaCreationData
Visual Basic
Public Class AreaCreationData
Visual C++
public ref class AreaCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..AreaCreationData

See Also

AreaCreationData Members
Autodesk.Revit.Creation Namespace


AreaCreationData Members

[image] [image]

Revit 2013 API
AreaCreationData Members
AreaCreationData Class Constructors Methods Properties See Also Send Feedback

The AreaCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | AreaCreationData | The data needed to create a new area

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Constructor

[image]

Revit 2013 API
AreaCreationData Constructor
AreaCreationData Class See Also Send Feedback
The data needed to create a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaCreationData(
    ViewPlan areaView,
    UV point
)
Visual Basic
Public Sub New ( _
    areaView As ViewPlan, _
    point As UV _
)
Visual C++
public:
AreaCreationData(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::..UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Methods

[image] [image]

Revit 2013 API
AreaCreationData Methods
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


AreaCreationData Properties

[image] [image]

Revit 2013 API
AreaCreationData Properties
AreaCreationData Class See Also Send Feedback

The AreaCreationData type exposes the following members.

Properties

 | Name | Description
Public property | TagPoint | Specify the location of the area tag.

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2013 API
AreaCreationData..::..TagPoint Property
AreaCreationData Class See Also Send Feedback
Specify the location of the area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic
Public Property TagPoint As UV
    Get
    Set
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

AreaCreationData Class
Autodesk.Revit.Creation Namespace


Document Class

[image]

Revit 2013 API
Document Class
Members See Also Send Feedback
The Document Creation object is used to create new instances of elements within the Autodesk Revit project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Document : ItemFactoryBase
Visual Basic
Public Class Document _
    Inherits ItemFactoryBase
Visual C++
public ref class Document : public ItemFactoryBase

Remarks

The Document Creation object is a utility object that is used to create new instances of elements within the Autodesk Revit project. This object, available from the Document.Create property should be used to create elements instead of using New. This object ensures that the elements created are added to the document correctly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..Document

See Also

Document Members
Autodesk.Revit.Creation Namespace


Document Members

[image] [image]

Revit 2013 API
Document Members
Document Class Methods Properties See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
Public method | NewAreaLoad(IList<(Of <<'(XYZ>)>>), XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <<'(XYZ>)>>), Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Obsolete. Creates a new view for the new area.
Public method | NewBeamSystem(CurveArray, Level) | Creates a new 2D BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem(ReferenceArray, CurtainSystemType) | Obsolete. Creates a new CurtainSystem element from a set of face references.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.
Public method | NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
Public method | NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
Public method | NewElectricalSystem(ICollection<(Of <<'(ElementId>)>>), ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewElectricalSystem(ElementSet, ElectricalSystemType) | Obsolete. Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid(Arc) | Creates a new radial grid line.
Public method | NewGrid(Line) | Creates a new linear grid line.
Public method | NewGrids | Creates new grid lines.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Public method | NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Public method | NewLineLoad(Element, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
Public method | NewLineLoad(Reference, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
Public method | NewLineLoad(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.
Public method | NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewMechanicalSystem | Creates a new MEP mechanical system element.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.
Public method | NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
Public method | NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.
Public method | NewPipingSystem | Creates a new MEP piping system element.
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
Public method | NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.
Public method | NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms(Level) | Obsolete. Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms(List<(Of <<'(RoomCreationData>)>>)) | Obsolete. Creates new rooms using the specified placement data.
Public method | NewRooms(Level, Phase) | Obsolete. Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms(Phase, Int32) | Obsolete. Creates new unplaced rooms in the given phase.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces(Phase, Int32) | Obsolete. Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces(Level, Phase, View) | Obsolete. Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
Public method | NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewTruss | Creates a New Truss.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewView3D | Obsolete. Creates a new 3D view. (Inherited from ItemFactoryBase.)
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
Public method | NewViewSection | Obsolete. Creates a new section view. (Inherited from ItemFactoryBase.)
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall(CurveArray, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the default wall type.
Public method | NewWall(Curve, Level, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | NewWalls(List<(Of <<'(ProfiledWallCreationData>)>>)) | Obsolete. Creates profile walls within the project.
Public method | NewWalls(List<(Of <<'(RectangularWallCreationData>)>>)) | Obsolete. Creates rectangular walls within the project.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Methods

[image] [image]

Revit 2013 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewArea | Creates a new area
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.
Public method | NewAreaBoundaryLine | Creates a new boundary line as an Area border.
Public method | NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
Public method | NewAreaLoad(IList<(Of <<'(XYZ>)>>), XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <<'(XYZ>)>>), Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaReinforcement | Creates a new instance of an Area Reinforcement element within the project
Public method | NewAreas | Creates new areas
Public method | NewAreaTag | Creates a new area tag.
Public method | NewAreaViewPlan | Obsolete. Creates a new view for the new area.
Public method | NewBeamSystem(CurveArray, Level) | Creates a new 2D BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewCrossFitting | Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.
Public method | NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem(ReferenceArray, CurtainSystemType) | Obsolete. Creates a new CurtainSystem element from a set of face references.
Public method | NewCurtainSystem2 | Creates a new CurtainSystem element from a set of face references.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.
Public method | NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
Public method | NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.
Public method | NewElbowFitting | Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.
Public method | NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
Public method | NewElectricalSystem(ICollection<(Of <<'(ElementId>)>>), ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewElectricalSystem(ElementSet, ElectricalSystemType) | Obsolete. Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewExtrusionRoof | Creates a new Extrusion Roof.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.
Public method | NewFootPrintRoof | Creates a new FootPrintRoof element.
Public method | NewFoundationSlab | Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFoundationWall | Creates a new continuous footing object.
Public method | NewGrid(Arc) | Creates a new radial grid line.
Public method | NewGrid(Line) | Creates a new linear grid line.
Public method | NewGrids | Creates new grid lines.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.
Public method | NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.
Public method | NewLineLoad(Element, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
Public method | NewLineLoad(Reference, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
Public method | NewLineLoad(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.
Public method | NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.
Public method | NewLoadCase | Creates a new instance of a LoadCase element within the project.
Public method | NewLoadCombination | Creates a new instance of a LoadCombination element within the project.
Public method | NewLoadNature | Creates a new instance of a LoadNature element within the project.
Public method | NewLoadUsage | Creates a new instance of a LoadUsage element within the project.
Public method | NewMechanicalSystem | Creates a new MEP mechanical system element.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.
Public method | NewPathReinforcement | Creates a new instance of a Path Reinforcement element within the project
Public method | NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.
Public method | NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
Public method | NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.
Public method | NewPipingSystem | Creates a new MEP piping system element.
Public method | NewPointBoundaryConditions | Creates a new Point BoundaryConditions Element.
Public method | NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
Public method | NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.
Public method | NewRebarBarType | Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.
Public method | NewRoomBoundaryLines | Creates a new boundary line as an Room border.
Public method | NewRooms(Level) | Obsolete. Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms(List<(Of <<'(RoomCreationData>)>>)) | Obsolete. Creates new rooms using the specified placement data.
Public method | NewRooms(Level, Phase) | Obsolete. Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms(Phase, Int32) | Obsolete. Creates new unplaced rooms in the given phase.
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.
Public method | NewRoomTag | Creates a new RoomTag.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)
Public method | NewSlab | Creates a slab within the project with the given horizontal profile using the default floor style.
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.
Public method | NewSpaceBoundaryLines | Creates a new boundary line as an Space border.
Public method | NewSpaces(Phase, Int32) | Obsolete. Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces(Level, Phase, View) | Obsolete. Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.
Public method | NewSpaceTag | Creates a new SpaceTag.
Public method | NewSpotCoordinate | Generate a new spot coordinate object within the project.
Public method | NewSpotElevation | Generate a new spot elevation object within the project.
Public method | NewTag | Creates a new IndependentTag Element.
Public method | NewTakeoffFitting | Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.
Public method | NewTeeFitting | Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
Public method | NewTopographySurface | Creates a new TopographySurface element in the document, and initializes it with a set of points.
Public method | NewTransitionFitting | Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.
Public method | NewTruss | Creates a New Truss.
Public method | NewUnionFitting | Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.
Public method | NewView3D | Obsolete. Creates a new 3D view. (Inherited from ItemFactoryBase.)
Public method | NewViewDrafting | Creates a new drafting view.
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
Public method | NewViewSection | Obsolete. Creates a new section view. (Inherited from ItemFactoryBase.)
Public method | NewViewSheet | Creates a new sheet view.
Public method | NewWall(CurveArray, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the default wall type.
Public method | NewWall(Curve, Level, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | NewWalls(List<(Of <<'(ProfiledWallCreationData>)>>)) | Obsolete. Creates profile walls within the project.
Public method | NewWalls(List<(Of <<'(RectangularWallCreationData>)>>)) | Obsolete. Creates rectangular walls within the project.
Public method | NewWire | Creates a new wire element.
Public method | NewZone | Creates a new Zone element.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewArea Method

[image]

Revit 2013 API
Document..::..NewArea Method
Document Class See Also Send Feedback
Creates a new area

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Area NewArea(
    ViewPlan areaView,
    UV point
)
Visual Basic
Public Function NewArea ( _
    areaView As ViewPlan, _
    point As UV _
) As Area
Visual C++
public:
Area^ NewArea(
    ViewPlan^ areaView,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The view of area element.
point
Type: Autodesk.Revit.DB..::..UV
The point which lies in the enclosed region of AreaBoundaryLines to put the new created Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method

[image] [image]

Revit 2013 API
Document..::..NewAreaBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Area BoundaryConditions element.

Overload List

 | Name | Description
Public method | NewAreaBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a host element.
Public method | NewAreaBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Area BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2013 API
Document..::..NewAreaBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic
Public Function NewAreaBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::..Element
A Wall, Slab or Slab Foundation to host the boundary conditions.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateAreaConditionWithElement(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    BoundaryConditions condition = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0,
                                                                               TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateAreaConditionWithElement(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Create Area Boundary Conditions using a given Wall and defaulting to fixed in all directions
    Dim condition As BoundaryConditions = docCreation.NewAreaBoundaryConditions(wall, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2013 API
Document..::..NewAreaBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Area BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryConditions NewAreaBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)
Visual Basic
Public Function NewAreaBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewAreaBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The Geometry reference obtained from a Wall, Slab or Slab Foundation.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".

Return Value

If successful, NewAreaBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 2 - "Area". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
 bool CreateAreaConditionWithReference(Wall wall, Autodesk.Revit.Creation.Document docCreation)
 {
     // Get the Geometry reference to the wall
     Reference profileReference = null;
     AnalyticalModel analytical = wall.GetAnalyticalModel() as AnalyticalModel;
     if (null == analytical)
     {
         return false; // the profile reference can't be retrieved.
     }

     // loop through the curves of the wall and get the first one as a reference
     foreach (Curve curve in analytical.GetCurves(AnalyticalCurveType.ActiveCurves))
     {
         profileReference = curve.Reference;
         if (null != profileReference)
         {
             break;
         }
     }

     BoundaryConditions condition = null;
     // Create the Area Boundary Conditions if we have a profileReference
     if (null != profileReference)
     {
         // Create Area Boundary Conditions with profile reference.
         condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0,
                                                                             TranslationRotationValue.Fixed, 0);
     }
     return (null != condition);
}
CopyVB.NET
Function CreateAreaConditionWithReference(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    ' Get the Geometry reference to the wall
    Dim profileReference As Reference = Nothing
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(wall.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    If analytical Is Nothing Then
        ' the profile reference can't be retrieved.
        Return False
    End If

    ' loop through the curves of the wall and get the first one as a reference
    For Each curve As Curve In analytical.GetCurves(Autodesk.Revit.DB.Structure.AnalyticalCurveType.ActiveCurves)
        profileReference = curve.Reference
        If profileReference IsNot Nothing Then
            Exit For
        End If
    Next

    Dim condition As BoundaryConditions = Nothing
    ' Create the Area Boundary Conditions if we have a profileReference
    If profileReference IsNot Nothing Then
        ' Create Area Boundary Conditions with profile reference.
        condition = docCreation.NewAreaBoundaryConditions(profileReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
         0)
    End If
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewAreaBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewAreaBoundaryLine Method

[image]

Revit 2013 API
Document..::..NewAreaBoundaryLine Method
Document Class See Also Send Feedback
Creates a new boundary line as an Area border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurve NewAreaBoundaryLine(
    SketchPlane sketchPlane,
    Curve geometryCurve,
    ViewPlan areaView
)
Visual Basic
Public Function NewAreaBoundaryLine ( _
    sketchPlane As SketchPlane, _
    geometryCurve As Curve, _
    areaView As ViewPlan _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewAreaBoundaryLine(
    SketchPlane^ sketchPlane,
    Curve^ geometryCurve,
    ViewPlan^ areaView
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane.
geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The geometry curve on which the boundary line are
areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The View for the new Area

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaLoad Method

[image] [image]

Revit 2013 API
Document..::..NewAreaLoad Method
Document Class See Also Send Feedback
Creates a new area load in the project.

Overload List

 | Name | Description
Public method | NewAreaLoad(Element, XYZ, Boolean, AreaLoadType) | Creates a new uniform hosted area load with polygonal shape within the project.
Public method | NewAreaLoad(IList<(Of <<'(XYZ>)>>), XYZ, Boolean, AreaLoadType) | Creates a new uniform unhosted area load with polygonal shape within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <<'(XYZ>)>>), Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.
Public method | NewAreaLoad(CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], XYZ, XYZ, XYZ, Boolean, AreaLoadType) | Creates a new unhosted area load with variable forces at the vertices within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)

[image]

Revit 2013 API
Document..::..NewAreaLoad Method (Element, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform hosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    Element host,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    host As Element, _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    Element^ host,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The host element (Floor or Wall) of the AreaLoad application.
force
Type: Autodesk.Revit.DB..::..XYZ
The 3d area force applied to the first reference point.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (IList(XYZ), XYZ, Boolean, AreaLoadType)

[image]

Revit 2013 API
Document..::..NewAreaLoad Method (IList<(Of <(<'XYZ>)>)>, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new uniform unhosted area load with polygonal shape within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    IList<XYZ> points,
    XYZ force,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    points As IList(Of XYZ), _
    force As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    IList<XYZ^>^ points,
    XYZ^ force,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Vertexes of AreaLoad shape polygon.
force
Type: Autodesk.Revit.DB..::..XYZ
The applied 3d area force.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], IList(XYZ), Boolean, AreaLoadType)

[image]

Revit 2013 API
Document..::..NewAreaLoad Method (CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], IList<(Of <(<'XYZ>)>)>, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    IList<XYZ> forces,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    forces As IList(Of XYZ), _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    IList<XYZ^>^ forces,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves that define the shape of the area load curves.
refPntIdxs
Type: array<System..::..Int32>[]()[][]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array<System..::..Int32>[]()[][]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The 3d area forces applied to each of the reference points in the refPntIdxs array.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

The size of the refPntIdxs, ends, and forces arrays must be the same, and a maximum of 3 values is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaLoad Method (CurveArray, Int32[], Int32[], XYZ, XYZ, XYZ, Boolean, AreaLoadType)

[image]

Revit 2013 API
Document..::..NewAreaLoad Method (CurveArray, array<Int32>[]()[][], array<Int32>[]()[][], XYZ, XYZ, XYZ, Boolean, AreaLoadType)
Document Class See Also Send Feedback
Creates a new unhosted area load with variable forces at the vertices within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoad NewAreaLoad(
    CurveArray curvesArr,
    int[] refPntIdxs,
    int[] ends,
    XYZ force0,
    XYZ force1,
    XYZ force2,
    bool isReaction,
    AreaLoadType symbol
)
Visual Basic
Public Function NewAreaLoad ( _
    curvesArr As CurveArray, _
    refPntIdxs As Integer(), _
    ends As Integer(), _
    force0 As XYZ, _
    force1 As XYZ, _
    force2 As XYZ, _
    isReaction As Boolean, _
    symbol As AreaLoadType _
) As AreaLoad
Visual C++
public:
AreaLoad^ NewAreaLoad(
    CurveArray^ curvesArr,
    array<int>^ refPntIdxs,
    array<int>^ ends,
    XYZ^ force0,
    XYZ^ force1,
    XYZ^ force2,
    bool isReaction,
    AreaLoadType^ symbol
)

Parameters

curvesArr
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves that define the shape of the area load.
refPntIdxs
Type: array<System..::..Int32>[]()[][]
The indices of the curves in curvesArr that will be used to define the reference points for the load.
ends
Type: array<System..::..Int32>[]()[][]
Identifies which of the curve end points should be used for the reference points, for each member of refPntIdxs. The value should be 0 for the start point or 1 for the end point of the curve.
force0
Type: Autodesk.Revit.DB..::..XYZ
The 3d area force applied to the first reference point.
force1
Type: Autodesk.Revit.DB..::..XYZ
The 3d area force applied to the second reference point. Ignored if only one or two reference points are supplied.
force2
Type: Autodesk.Revit.DB..::..XYZ
The 3d area force applied to the third reference point. Ignored if only one or two reference points are supplied.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The symbol of the AreaLoad.

Return Value

If successful, NewAreaLoad returns an object for the newly created AreaLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

The size of the refPntIdxs and ends arrays must be the same, and a maximum of 3 values is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewAreaLoad Overload
Autodesk.Revit.Creation Namespace


NewAreaReinforcement Method

[image]

Revit 2013 API
Document..::..NewAreaReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of an Area Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaReinforcement NewAreaReinforcement(
    Element host,
    CurveArray curves,
    XYZ direction
)
Visual Basic
Public Function NewAreaReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    direction As XYZ _
) As AreaReinforcement
Visual C++
public:
AreaReinforcement^ NewAreaReinforcement(
    Element^ host,
    CurveArray^ curves,
    XYZ^ direction
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The element to which the Area Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves that define the boundary of the area. They must belong to the top face of the floor or the exterior face of the wall.
direction
Type: Autodesk.Revit.DB..::..XYZ

Return Value

If successful, NewAreaReinforcement returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
AreaReinforcement CreateAreaReinforcementInWall(Wall wall, Autodesk.Revit.Creation.Document docCreation)
{
    // Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    AnalyticalModel analytical = wall.GetAnalyticalModel() as AnalyticalModel;
    if (null == analytical)
    {
        throw new Exception("Can't get AnalyticalModel from the selected wall");
    }

    CurveArray curves = analytical.GetCurves(AnalyticalCurveType.ActiveCurves) as CurveArray;

    //define the Major Direction of AreaReinforcement,
    //we get direction of first Line on the Wall as the Major Direction
    Line firstLine = (Line)(curves.get_Item(0));
    XYZ majorDirection = new XYZ(
        firstLine.get_EndPoint(1).X - firstLine.get_EndPoint(0).X,
        firstLine.get_EndPoint(1).Y - firstLine.get_EndPoint(0).Y,
        firstLine.get_EndPoint(1).Z - firstLine.get_EndPoint(0).Z);

    // Create the area reinforcement
    AreaReinforcement rein = docCreation.NewAreaReinforcement(wall, curves, majorDirection);

    return rein;
}
CopyVB.NET
Function CreateAreaReinforcementInWall(ByVal wall As Wall, ByVal docCreation As Autodesk.Revit.Creation.Document) As Autodesk.Revit.DB.Structure.AreaReinforcement
    ' Get the wall analytical profile whose curves will define the boundary of the the area reinforcement
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(wall.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    If analytical Is Nothing Then
        Throw New Exception("Can't get AnalyticalModel from the selected wall")
    End If

    Dim curves As CurveArray = TryCast(analytical.GetCurves(Autodesk.Revit.DB.Structure.AnalyticalCurveType.ActiveCurves), CurveArray)

    'define the Major Direction of AreaReinforcement,
    'we get direction of first Line on the Wall as the Major Direction
    Dim firstLine As Line = DirectCast((curves.Item(0)), Line)
    Dim majorDirection As New Autodesk.Revit.DB.XYZ(firstLine.EndPoint(1).X - firstLine.EndPoint(0).X, firstLine.EndPoint(1).Y - firstLine.EndPoint(0).Y, firstLine.EndPoint(1).Z - firstLine.EndPoint(0).Z)

    ' Create the area reinforcement
    Dim rein As Autodesk.Revit.DB.Structure.AreaReinforcement = docCreation.NewAreaReinforcement(wall, curves, majorDirection)

    Return rein
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreas Method

[image]

Revit 2013 API
Document..::..NewAreas Method
Document Class See Also Send Feedback
Creates new areas

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet NewAreas(
    List<AreaCreationData> dataList
)
Visual Basic
Public Function NewAreas ( _
    dataList As List(Of AreaCreationData) _
) As ElementSet
Visual C++
public:
ElementSet^ NewAreas(
    List<AreaCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'AreaCreationData>)>)>
A list of AreaCreationData which wraps the creation arguments of the areas to be created.

Return Value

If successful an Element Set which contains the areas should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If AreaCreationData's areaPoint is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the area cannot be created successfully or the phase is invalid or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaTag Method

[image]

Revit 2013 API
Document..::..NewAreaTag Method
Document Class See Also Send Feedback
Creates a new area tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaTag NewAreaTag(
    ViewPlan areaView,
    Area room,
    UV point
)
Visual Basic
Public Function NewAreaTag ( _
    areaView As ViewPlan, _
    room As Area, _
    point As UV _
) As AreaTag
Visual C++
public:
AreaTag^ NewAreaTag(
    ViewPlan^ areaView,
    Area^ room,
    UV^ point
)

Parameters

areaView
Type: Autodesk.Revit.DB..::..ViewPlan
The area view
room
Type: Autodesk.Revit.DB..::..Area
point
Type: Autodesk.Revit.DB..::..UV
The position of the area tag

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewAreaViewPlan Method

[image]

Revit 2013 API
Document..::..NewAreaViewPlan Method
Document Class See Also Send Feedback
Creates a new view for the new area.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")]
public ViewPlan NewAreaViewPlan(
    string pViewName,
    Level pLevel,
    AreaElemType areaElemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")> _
Public Function NewAreaViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    areaElemType As AreaElemType _
) As ViewPlan
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call ViewPlan.CreateAreaPlan()  instead.")]
public:
ViewPlan^ NewAreaViewPlan(
    String^ pViewName,
    Level^ pLevel,
    AreaElemType areaElemType
)

Parameters

pViewName
Type: System..::..String
The name of new created view
pLevel
Type: Autodesk.Revit.DB..::..Level
areaElemType
Type: Autodesk.Revit.DB..::..AreaElemType
The type of area element

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewBeamSystem Method

[image] [image]

Revit 2013 API
Document..::..NewBeamSystem Method
Document Class See Also Send Feedback
Creates a new 2D Beam System.

Overload List

 | Name | Description
Public method | NewBeamSystem(CurveArray, Level) | Creates a new 2D BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, Level, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.
Public method | NewBeamSystem(CurveArray, SketchPlane, XYZ, Boolean) | Creates a new BeamSystem with specified profile curves.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, Level)

[image]

Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, Level)
Document Class Example See Also Send Feedback
Creates a new 2D BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    Level level
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    level As Level _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    Level^ level
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the level.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work plane of the BeamSystem will be the ketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as elevation, direction, etc.

Examples

CopyC#
// Build a profile for the beam system creation
XYZ first = new XYZ(0, 0, 0);
XYZ second = new XYZ(40, 0, 0);
XYZ third = new XYZ(40, 25, 0);
XYZ fourth = new XYZ(0, 25, 0);
CurveArray profile = new CurveArray();
profile.Append(Line.get_Bound(first, second));
profile.Append(Line.get_Bound(second, third));
profile.Append(Line.get_Bound(third, fourth));
profile.Append(Line.get_Bound(fourth, first));

// Create a beam system
BeamSystem beamSystem = document.Create.NewBeamSystem(profile, level);
if (null != beamSystem)
{
    // Change some properties, such as elevation
    Parameter elevationPara = beamSystem.get_Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM);
    if (null != elevationPara)
    {
        elevationPara.Set(10.0);
    }
}
CopyVB.NET
' Build a profile for the beam system creation
Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim second As New Autodesk.Revit.DB.XYZ(40, 0, 0)
Dim third As New Autodesk.Revit.DB.XYZ(40, 25, 0)
Dim fourth As New Autodesk.Revit.DB.XYZ(0, 25, 0)
Dim profile As New CurveArray()
profile.Append(Line.Bound(first, second))
profile.Append(Line.Bound(second, third))
profile.Append(Line.Bound(third, fourth))
profile.Append(Line.Bound(fourth, first))

' Create a beam system
Dim beamSystem As BeamSystem = document.Create.NewBeamSystem(profile)
If beamSystem IsNot Nothing Then
    ' Change some properties, such as elevation
    Dim elevationPara As Parameter = beamSystem.Parameter(BuiltInParameter.INSTANCE_ELEVATION_PARAM)
    If elevationPara IsNot Nothing Then
        elevationPara.[Set](10)
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or level is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile or level is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, SketchPlane)

[image]

Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, SketchPlane)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile is the profile of the BeamSystem.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work plane of the BeamSystem.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or sketchPlane is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, Level, XYZ, Boolean)

[image]

Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, Level, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    Level level,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    level As Level, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    Level^ level,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the level.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the BeamSystem is to be created. The work plane of the BeamSystem will be the ketch plane associated with the Level. If there is no current sketch plane associated with the level yet, we will create a default one.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem. This argument is optional – may be null.
is3d
Type: System..::..Boolean
Whether the BeamSystem is 3D or not

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile or level is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile or level is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)

[image]

Revit 2013 API
Document..::..NewBeamSystem Method (CurveArray, SketchPlane, XYZ, Boolean)
Document Class See Also Send Feedback
Creates a new BeamSystem with specified profile curves.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystem NewBeamSystem(
    CurveArray profile,
    SketchPlane sketchPlane,
    XYZ direction,
    bool is3d
)
Visual Basic
Public Function NewBeamSystem ( _
    profile As CurveArray, _
    sketchPlane As SketchPlane, _
    direction As XYZ, _
    is3d As Boolean _
) As BeamSystem
Visual C++
public:
BeamSystem^ NewBeamSystem(
    CurveArray^ profile,
    SketchPlane^ sketchPlane,
    XYZ^ direction,
    bool is3d
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the BeamSystem. The profile must be a closed curve loop in the sketch plane.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The work plane of the BeamSystem.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction is the direction of the BeamSystem.
is3d
Type: System..::..Boolean
If the BeamSystem is 3D, the sketchPlane must be a level, or an exception will be thrown.

Return Value

If successful a new BeamSystem object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

Other properties are set to default value and can be set later. Such as level, elevation, direction, etc.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input profile, sketchPlane, or direction is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when profile is not suitable for creating beam system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if calling this function when the document is not modifiable. Thrown if the BeamSystem is 3D, but the sketchPlane is not a level.

See Also

Document Class
NewBeamSystem Overload
Autodesk.Revit.Creation Namespace


NewCrossFitting Method

[image]

Revit 2013 API
Document..::..NewCrossFitting Method
Document Class See Also Send Feedback
Add a new family instance of a cross fitting into the Autodesk Revit document, using four connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewCrossFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic
Public Function NewCrossFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewCrossFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the cross.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the cross.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third connector to be connected to the cross.
connector4
Type: Autodesk.Revit.DB..::..Connector
The fourth connector to be connected to the cross.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1, connector2, connector3, or connector4 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for cross creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when cross fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method

[image] [image]

Revit 2013 API
Document..::..NewCurtainSystem Method
Document Class See Also Send Feedback
Creates a new CurtainSystem element.

Overload List

 | Name | Description
Public method | NewCurtainSystem(FaceArray, CurtainSystemType) | Creates a new CurtainSystem element from a set of faces.
Public method | NewCurtainSystem(ReferenceArray, CurtainSystemType) | Obsolete. Creates a new CurtainSystem element from a set of face references.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (FaceArray, CurtainSystemType)

[image]

Revit 2013 API
Document..::..NewCurtainSystem Method (FaceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of faces.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystem NewCurtainSystem(
    FaceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem ( _
    faces As FaceArray, _
    curtainSystemType As CurtainSystemType _
) As CurtainSystem
Visual C++
public:
CurtainSystem^ NewCurtainSystem(
    FaceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..FaceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

The CurtainSystem created will be returned when the operation succeeds.

Remarks

The input faces will be copied during the operations so that they can be any faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewCurtainSystem Method (ReferenceArray, CurtainSystemType)

[image]

Revit 2013 API
Document..::..NewCurtainSystem Method (ReferenceArray, CurtainSystemType)
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewCurtainSystem2(Autodesk.Revit.DB.ReferenceArray faces, Autodesk.Revit.DB.CurtainSystemType curtainSystemType) instead.")]
public ElementSet NewCurtainSystem(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewCurtainSystem2(Autodesk.Revit.DB.ReferenceArray faces, Autodesk.Revit.DB.CurtainSystemType curtainSystemType) instead.")> _
Public Function NewCurtainSystem ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewCurtainSystem2(Autodesk.Revit.DB.ReferenceArray faces, Autodesk.Revit.DB.CurtainSystemType curtainSystemType) instead.")]
public:
ElementSet^ NewCurtainSystem(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
NewCurtainSystem Overload
Autodesk.Revit.Creation Namespace


NewCurtainSystem2 Method

[image]

Revit 2013 API
Document..::..NewCurtainSystem2 Method
Document Class See Also Send Feedback
Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewCurtainSystem2(
    ReferenceArray faces,
    CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem2 ( _
    faces As ReferenceArray, _
    curtainSystemType As CurtainSystemType _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewCurtainSystem2(
    ReferenceArray^ faces,
    CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DB..::..ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DB..::..CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of ElementIds of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown in following cases: The input argument faces or curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2013 API
Document..::..NewDimension Method
Document Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method

[image] [image]

Revit 2013 API
Document..::..NewDuct Method
Document Class See Also Send Feedback
Adds a new duct into the document.

Overload List

 | Name | Description
Public method | NewDuct(Connector, Connector, DuctType) | Adds a new duct into the document, using two connectors and duct type.
Public method | NewDuct(XYZ, Connector, DuctType) | Adds a new duct into the document, using a point, connector and duct type.
Public method | NewDuct(XYZ, XYZ, DuctType) | Adds a new duct into the document, using two points and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewDuct Method (Connector, Connector, DuctType)

[image]

Revit 2013 API
Document..::..NewDuct Method (Connector, Connector, DuctType)
Document Class Example See Also Send Feedback
Adds a new duct into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Duct NewDuct(
    Connector connector1,
    Connector connector2,
    DuctType ductType
)
Visual Basic
Public Function NewDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    Connector^ connector1,
    Connector^ connector2,
    DuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the duct, but no connection will be established.

Examples

CopyC#
public Duct CreateDuctBetweenConnectors(UIDocument uiDocument)
{
    // prior to running this example
    // select some mechanical equipment with a supply air connector
    // and an elbow duct fitting with a connector in line with that connector
    Connector connector1 = null, connector2 = null;
    ConnectorSetIterator csi = null;
    ElementSet selection = uiDocument.Selection.Elements;
    // First find the selected equipment and get the correct connector
    foreach (Element e in selection)
    {
        if (e is FamilyInstance)
        {
            FamilyInstance fi = e as FamilyInstance;
            Family family = fi.Symbol.Family;
            if (family.FamilyCategory.Name == "Mechanical Equipment")
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    Connector conn = csi.Current as Connector;
                    if (conn.Direction == FlowDirectionType.Out &&
                        conn.DuctSystemType == DuctSystemType.SupplyAir)
                    {
                        connector1 = conn;
                        break;
                    }
                }
            }
        }
    }
    // next find the second selected item to connect to
    foreach(Element e in selection)
    {
        if (e is FamilyInstance)
        {
            FamilyInstance fi = e as FamilyInstance;
            Family family = fi.Symbol.Family;
            if (family.FamilyCategory.Name != "Mechanical Equipment")
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    if (null == connector2)
                    {
                        Connector conn = csi.Current as Connector;

                        // make sure to choose the connector in line with the first connector
                        if (Math.Abs(conn.Origin.Y - connector1.Origin.Y) < 0.001)
                        {
                            connector2 = conn;
                            break;
                        }
                    }
                }
            }
        }
    }

    Duct duct = null;
    if (null != connector1 && null != connector2)
    {
        // find a duct type
        FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
        collector.OfClass(typeof(DuctType));

        // Use Linq query to make sure it is one of the rectangular duct types
        var query = from element in collector
                    where element.Name.Contains("Mitered Elbows") == true
                    select element;

        // use extension methods to get first duct type
        DuctType ductType = collector.Cast<DuctType>().First<DuctType>();

        if (null != ductType)
        {
            duct = uiDocument.Document.Create.NewDuct(connector1, connector2, ductType);
        }
    }

    return duct;
}
CopyVB.NET
Public Function CreateDuctBetweenConnectors(ByVal uiDocument As UIDocument) As Duct
    ' prior to running this example
    ' select some mechanical equipment with a supply air connector
    ' and an elbow duct fitting with a connector in line with that connector
    Dim connector1 As Connector = Nothing, connector2 As Connector = Nothing
    Dim csi As ConnectorSetIterator = Nothing
    Dim selection As ElementSet = uiDocument.Selection.Elements
    ' First find the selected equipment and get the correct connector
    For Each e As Element In selection
        If TypeOf e Is FamilyInstance Then
            Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
            Dim family As Family = fi.Symbol.Family
            If family.FamilyCategory.Name = "Mechanical Equipment" Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    Dim conn As Connector = TryCast(csi.Current, Connector)
                    If conn.Direction = FlowDirectionType.Out AndAlso conn.DuctSystemType = DuctSystemType.SupplyAir Then
                        connector1 = conn
                        Exit While
                    End If
                End While
            End If
        End If
    Next
    ' next find the second selected item to connect to
    For Each e As Element In selection
        If TypeOf e Is FamilyInstance Then
            Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
            Dim family As Family = fi.Symbol.Family
            If family.FamilyCategory.Name <> "Mechanical Equipment" Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    If connector2 Is Nothing Then
                        Dim conn As Connector = TryCast(csi.Current, Connector)

                        ' make sure to choose the connector in line with the first connector
                        If Math.Abs(conn.Origin.Y - connector1.Origin.Y) < 0.001 Then
                            connector2 = conn
                            Exit While
                        End If
                    End If
                End While
            End If
        End If
    Next

    Dim duct As Duct = Nothing
    If connector1 IsNot Nothing AndAlso connector2 IsNot Nothing Then
        ' find a duct type
        Dim collector As New FilteredElementCollector(uiDocument.Document)
        collector.OfClass(GetType(DuctType))

        ' Use Linq query to make sure it is one of the rectangular duct types
        Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
        query = From element In collector _
         Where element.Name.Contains("Mitered Elbows") = True _
         Select element

        ' use extension methods to get first duct type
        Dim ductType As DuctType = collector.Cast(Of DuctType)().First()

        If ductType IsNot Nothing Then
            duct = uiDocument.Document.Create.NewDuct(connector1, connector2, ductType)
        End If
    End If

    Return duct
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, Connector, DuctType)

[image]

Revit 2013 API
Document..::..NewDuct Method (XYZ, Connector, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using a point, connector and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point,
    Connector connector,
    DuctType ductType
)
Visual Basic
Public Function NewDuct ( _
    point As XYZ, _
    connector As Connector, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point,
    Connector^ connector,
    DuctType^ ductType
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The first point of the duct.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the duct, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument point or connector is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewDuct Method (XYZ, XYZ, DuctType)

[image]

Revit 2013 API
Document..::..NewDuct Method (XYZ, XYZ, DuctType)
Document Class See Also Send Feedback
Adds a new duct into the document, using two points and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Duct NewDuct(
    XYZ point1,
    XYZ point2,
    DuctType ductType
)
Visual Basic
Public Function NewDuct ( _
    point1 As XYZ, _
    point2 As XYZ, _
    ductType As DuctType _
) As Duct
Visual C++
public:
Duct^ NewDuct(
    XYZ^ point1,
    XYZ^ point2,
    DuctType^ ductType
)

Parameters

point1
Type: Autodesk.Revit.DB..::..XYZ
The first point of the duct.
point2
Type: Autodesk.Revit.DB..::..XYZ
The second point of the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..DuctType
The type of the duct.

Return Value

If creation was successful then a new duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument point1 or point2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the duct cannot be created or regenerate fails.

See Also

Document Class
NewDuct Overload
Autodesk.Revit.Creation Namespace


NewElbowFitting Method

[image]

Revit 2013 API
Document..::..NewElbowFitting Method
Document Class See Also Send Feedback
Add a new family instance of an elbow fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewElbowFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewElbowFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewElbowFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the elbow.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the elbow.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for the elbow creation. For example, they cannot be from the same element, they must be of the same domain, and the angle between them must fall within the valid range (typically 2 to 95 degrees).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when an elbow fitting cannot be created because the angle between the two connectors is too large or too small, the connectors are not close enough together, or the connectors are placed at positions with too high of a tolerance.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method

[image] [image]

Revit 2013 API
Document..::..NewElectricalSystem Method
Document Class See Also Send Feedback
Creates a new MEP Electrical System element.

Overload List

 | Name | Description
Public method | NewElectricalSystem(Connector, ElectricalSystemType) | Creates a new MEP Electrical System element from an unused Connector.
Public method | NewElectricalSystem(ICollection<(Of <<'(ElementId>)>>), ElectricalSystemType) | Creates a new MEP Electrical System element from a set of electrical components.
Public method | NewElectricalSystem(ElementSet, ElectricalSystemType) | Obsolete. Creates a new MEP Electrical System element from a set of electrical components.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (Connector, ElectricalSystemType)

[image]

Revit 2013 API
Document..::..NewElectricalSystem Method (Connector, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from an unused Connector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    Connector connector,
    ElectricalSystemType elecSysType
)
Visual Basic
Public Function NewElectricalSystem ( _
    connector As Connector, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    Connector^ connector,
    ElectricalSystemType elecSysType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The Connector to create this Electrical System.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the electrical system cannot be created by these input connector.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (ICollection(ElementId), ElectricalSystemType)

[image]

Revit 2013 API
Document..::..NewElectricalSystem Method (ICollection<(Of <(<'ElementId>)>)>, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystem NewElectricalSystem(
    ICollection<ElementId> electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic
Public Function NewElectricalSystem ( _
    electComponents As ICollection(Of ElementId), _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ NewElectricalSystem(
    ICollection<ElementId^>^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewElectricalSystem Method (ElementSet, ElectricalSystemType)

[image]

Revit 2013 API
Document..::..NewElectricalSystem Method (ElementSet, ElectricalSystemType)
Document Class See Also Send Feedback
Creates a new MEP Electrical System element from a set of electrical components.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewElectricalSystem(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> electComponents, Autodesk.Revit.DB.Electrical.ElectricalSystemType elecSysType) instead.")]
public ElectricalSystem NewElectricalSystem(
    ElementSet electComponents,
    ElectricalSystemType elecSysType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewElectricalSystem(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> electComponents, Autodesk.Revit.DB.Electrical.ElectricalSystemType elecSysType) instead.")> _
Public Function NewElectricalSystem ( _
    electComponents As ElementSet, _
    elecSysType As ElectricalSystemType _
) As ElectricalSystem
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewElectricalSystem(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> electComponents, Autodesk.Revit.DB.Electrical.ElectricalSystemType elecSysType) instead.")]
public:
ElectricalSystem^ NewElectricalSystem(
    ElementSet^ electComponents,
    ElectricalSystemType elecSysType
)

Parameters

electComponents
Type: Autodesk.Revit.DB..::..ElementSet
The electrical components in this system.
elecSysType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The System Type of electrical system.

Return Value

If successful a new MEP Electrical System element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the elecSysType parameter Value is out of the range of ElectricalSystemType.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the electrical system cannot be created by these input electrical components.

See Also

Document Class
NewElectricalSystem Overload
Autodesk.Revit.Creation Namespace


NewExtrusionRoof Method

[image]

Revit 2013 API
Document..::..NewExtrusionRoof Method
Document Class See Also Send Feedback
Creates a new Extrusion Roof.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ExtrusionRoof NewExtrusionRoof(
    CurveArray profile,
    ReferencePlane refPlane,
    Level level,
    RoofType roofType,
    double extrusionStart,
    double extrusionEnd
)
Visual Basic
Public Function NewExtrusionRoof ( _
    profile As CurveArray, _
    refPlane As ReferencePlane, _
    level As Level, _
    roofType As RoofType, _
    extrusionStart As Double, _
    extrusionEnd As Double _
) As ExtrusionRoof
Visual C++
public:
ExtrusionRoof^ NewExtrusionRoof(
    CurveArray^ profile,
    ReferencePlane^ refPlane,
    Level^ level,
    RoofType^ roofType,
    double extrusionStart,
    double extrusionEnd
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the extrusion roof.
refPlane
Type: Autodesk.Revit.DB..::..ReferencePlane
The work plane for the extrusion roof.
level
Type: Autodesk.Revit.DB..::..Level
The level of the extrusion roof.
roofType
Type: Autodesk.Revit.DB..::..RoofType
Type of the extrusion roof.
extrusionStart
Type: System..::..Double
Start the extrusion.
extrusionEnd
Type: System..::..Double
End the extrusion.

Remarks

This method will regenerate the document even in manual regeneration mode.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2013 API
Document..::..NewFamilyInstance Method
Document Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Curve, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
Document..::..NewFamilyInstance Method (Curve, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a curve, type/symbol and reference level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element along the geometry of a curve. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail. All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
// get the active view's level for beam creation
 Level level = document.ActiveView.Level;

 // load a family symbol from file
 FamilySymbol gotSymbol = null;
 String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa";
 String name = "W10X54";

 FamilyInstance instance = null;

 if (document.LoadFamilySymbol(fileName, name, out gotSymbol))
 {
     // look for a model line in the list of selected elements
     UIDocument uidoc = new UIDocument(document);
     ElementSet sel = uidoc.Selection.Elements;
     ModelLine modelLine = null;
     foreach (Autodesk.Revit.DB.Element elem in sel)
     {
         if (elem is ModelLine)
         {
             modelLine = elem as ModelLine;
             break;
         }
     }
     if (null != modelLine)
     {
         // create a new beam
         instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol,
                                                       level, StructuralType.Beam);
     }
     else
     {
         throw new Exception("Please select a model line before invoking this command");
     }

 }
 else
 {
     throw new Exception("Couldn't load " + fileName);
 }
CopyVB.NET
' get the active view's level for beam creation
Dim level As Level = document.ActiveView.Level

' load a family symbol from file
Dim gotSymbol As FamilySymbol = Nothing
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Structural\Framing\Steel\W-Wide Flange.rfa"
Dim name As [String] = "W10X54"

Dim instance As Autodesk.Revit.DB.FamilyInstance = Nothing

If document.LoadFamilySymbol(fileName, name, gotSymbol) Then
    ' look for a model line in the list of selected elements
    Dim uidoc As New UIDocument(document)
    Dim sel As ElementSet = uidoc.Selection.Elements
    Dim modelLine As ModelLine = Nothing
    For Each elem As Autodesk.Revit.DB.Element In sel
        If TypeOf elem Is ModelLine Then
            modelLine = TryCast(elem, ModelLine)
            Exit For
        End If
    Next
    If modelLine IsNot Nothing Then
        ' create a new beam
        instance = document.Create.NewFamilyInstance(modelLine.GeometryCurve, gotSymbol, level, Autodesk.Revit.DB.Structure.StructuralType.Beam)
    Else
        Throw New Exception("Please select a model line before invoking this command")

    End If
Else
    Throw New Exception("Couldn't load " + fileName)
End If

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
Document..::..NewFamilyInstance Method (XYZ, FamilySymbol, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to add a family instance that doesn't require a host element, but that can be associated to a level. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
FamilyInstance CreateColumn(Autodesk.Revit.DB.Document document, Level level)
{
    // Get a Column type from Revit
    FamilySymbol columnType = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        columnType = e as FamilySymbol;
        if (null != columnType && null != columnType.Category)
        {
            if ("Structural Columns" == columnType.Category.Name)
            {
                break;
            }
        }
    }

    FamilyInstance instance;
    if (null != columnType)
    {
        // Create a column at the origin
        XYZ origin = new XYZ(0, 0, 0);

        instance = document.Create.NewFamilyInstance(origin, columnType, level,
                                                      StructuralType.Column);
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return instance;
}
CopyVB.NET
Function CreateColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Autodesk.Revit.DB.FamilyInstance
    ' Get a Column type from Revit
    Dim columnType As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        columnType = TryCast(e, FamilySymbol)
        If columnType IsNot Nothing AndAlso columnType.Category IsNot Nothing Then
            If "Structural Columns" = columnType.Category.Name Then
                Exit For
            End If
        End If
    Next

    Dim instance As Autodesk.Revit.DB.FamilyInstance
    If columnType IsNot Nothing Then
        ' Create a column at the origin
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)

        instance = document.Create.NewFamilyInstance(origin, columnType, level, Autodesk.Revit.DB.Structure.StructuralType.Column)
    Else
        Throw New Exception("No column types found.")
    End If

    Return instance
End Function

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2013 API
Document..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, Level, StructuralType)
Document Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a base level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed on the specified level.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
A host object into which the instance will be embedded
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

All levels within the document can be found by iterating over the entire document and searching for objects of type Autodesk.Revit.Elements.Level.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
void CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa";

    Family family = null;
    if (!document.LoadFamily(fileName, out family))
    {
        throw new Exception("Unable to load " + fileName);
    }

    // get the active view's level for beam creation
    Level level = document.ActiveView.Level;

    FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
    double x = 0, y = 0, z = 0;
    while (symbolItor.MoveNext())
    {
        FamilySymbol symbol = symbolItor.Current as FamilySymbol;
        XYZ location = new XYZ(x, y, z);
        FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
        x += 10;
        y += 10;
        z += 1.5;
    }
}
CopyVB.NET
Sub CreateDoorsInWall(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2011\Imperial Library\Doors\Single-Decorative 2.rfa"

    Dim family As Family = Nothing
    If Not document.LoadFamily(fileName, family) Then
        Throw New Exception("Unable to load " + fileName)
    End If

    ' get the active view's level for beam creation
    Dim level As Level = document.ActiveView.Level

    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Double = 0, y As Double = 0, z As Double = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New Autodesk.Revit.DB.XYZ(x, y, z)
        Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
        x += 10
        y += 10
        z += 1.5
    End While
End Sub

See Also

Document Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFascia Method

[image] [image]

Revit 2013 API
Document..::..NewFascia Method
Document Class See Also Send Feedback
Creates a fascia.

Overload List

 | Name | Description
Public method | NewFascia(FasciaType, Reference) | Creates a fascia along a reference.
Public method | NewFascia(FasciaType, ReferenceArray) | Creates a fascia along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, Reference)

[image]

Revit 2013 API
Document..::..NewFascia Method (FasciaType, Reference)
Document Class See Also Send Feedback
Creates a fascia along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    Reference reference
)
Visual Basic
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    reference As Reference _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    Reference^ reference
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
reference
Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFascia Method (FasciaType, ReferenceArray)

[image]

Revit 2013 API
Document..::..NewFascia Method (FasciaType, ReferenceArray)
Document Class See Also Send Feedback
Creates a fascia along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Fascia NewFascia(
    FasciaType FasciaType,
    ReferenceArray references
)
Visual Basic
Public Function NewFascia ( _
    FasciaType As FasciaType, _
    references As ReferenceArray _
) As Fascia
Visual C++
public:
Fascia^ NewFascia(
    FasciaType^ FasciaType,
    ReferenceArray^ references
)

Parameters

FasciaType
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The type of the fascia to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the fascia.

Return Value

If successful a new fascia object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFascia Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method

[image] [image]

Revit 2013 API
Document..::..NewFlexDuct Method
Document Class See Also Send Feedback
Adds a new flexible duct into the document.

Overload List

 | Name | Description
Public method | NewFlexDuct(IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a point array and duct type.
Public method | NewFlexDuct(Connector, Connector, FlexDuctType) | Adds a new flexible duct into the document, using two connector, and duct type.
Public method | NewFlexDuct(Connector, IList<(Of <<'(XYZ>)>>), FlexDuctType) | Adds a new flexible duct into the document, using a connector, point array and duct type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (IList(XYZ), FlexDuctType)

[image]

Revit 2013 API
Document..::..NewFlexDuct Method (IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The point array indicating the path of the flexible duct, including the end points.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, Connector, FlexDuctType)

[image]

Revit 2013 API
Document..::..NewFlexDuct Method (Connector, Connector, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using two connector, and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector1,
    Connector connector2,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector1 As Connector, _
    connector2 As Connector, _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector1,
    Connector^ connector2,
    FlexDuctType^ ductType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the duct.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexDuct Method (Connector, IList(XYZ), FlexDuctType)

[image]

Revit 2013 API
Document..::..NewFlexDuct Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexDuctType)
Document Class See Also Send Feedback
Adds a new flexible duct into the document, using a connector, point array and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexDuct NewFlexDuct(
    Connector connector,
    IList<XYZ> points,
    FlexDuctType ductType
)
Visual Basic
Public Function NewFlexDuct ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    ductType As FlexDuctType _
) As FlexDuct
Visual C++
public:
FlexDuct^ NewFlexDuct(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexDuctType^ ductType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the duct, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The point array indicating the path of the flexible duct.
ductType
Type: Autodesk.Revit.DB.Mechanical..::..FlexDuctType
The type of the flexible duct.

Return Value

If creation was successful then a new flexible duct is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flexible duct to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible duct cannot be created or regenerate fails.

See Also

Document Class
NewFlexDuct Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method

[image] [image]

Revit 2013 API
Document..::..NewFlexPipe Method
Document Class See Also Send Feedback
Adds a new flexible pipe into the document.

Overload List

 | Name | Description
Public method | NewFlexPipe(IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a point array and pipe type.
Public method | NewFlexPipe(Connector, Connector, FlexPipeType) | Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Public method | NewFlexPipe(Connector, IList<(Of <<'(XYZ>)>>), FlexPipeType) | Adds a new flexible pipe into the document, using a connector, point array and pipe type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (IList(XYZ), FlexPipeType)

[image]

Revit 2013 API
Document..::..NewFlexPipe Method (IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The point array indicating the path of the flexible pipe, including the end points.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, Connector, FlexPipeType)

[image]

Revit 2013 API
Document..::..NewFlexPipe Method (Connector, Connector, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using two connector, and flexible pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector1,
    Connector connector2,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector1,
    Connector^ connector2,
    FlexPipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFlexPipe Method (Connector, IList(XYZ), FlexPipeType)

[image]

Revit 2013 API
Document..::..NewFlexPipe Method (Connector, IList<(Of <(<'XYZ>)>)>, FlexPipeType)
Document Class See Also Send Feedback
Adds a new flexible pipe into the document, using a connector, point array and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexPipe NewFlexPipe(
    Connector connector,
    IList<XYZ> points,
    FlexPipeType pipeType
)
Visual Basic
Public Function NewFlexPipe ( _
    connector As Connector, _
    points As IList(Of XYZ), _
    pipeType As FlexPipeType _
) As FlexPipe
Visual C++
public:
FlexPipe^ NewFlexPipe(
    Connector^ connector,
    IList<XYZ^>^ points,
    FlexPipeType^ pipeType
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the flexible pipe, including the end points.
points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The point array indicating the path of the flexible pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..FlexPipeType
The type of the flexible pipe.

Return Value

If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connector, no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector or points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails.

See Also

Document Class
NewFlexPipe Overload
Autodesk.Revit.Creation Namespace


NewFloor Method

[image] [image]

Revit 2013 API
Document..::..NewFloor Method
Document Class See Also Send Feedback
Creates a floor within the project.

Overload List

 | Name | Description
Public method | NewFloor(CurveArray, Boolean) | Creates a floor within the project with the given horizontal profile using the default floor style.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean) | Creates a floor within the project with the given horizontal profile and floor style on the specified level.
Public method | NewFloor(CurveArray, FloorType, Level, Boolean, XYZ) | Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, Boolean)

[image]

Revit 2013 API
Document..::..NewFloor Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    bool structural
)
Visual Basic
Public Function NewFloor ( _
    profile As CurveArray, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean)

[image]

Revit 2013 API
Document..::..NewFloor Method (CurveArray, FloorType, Level, Boolean)
Document Class See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural
)
Visual Basic
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::..FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the floor is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.

Return Value

if successful, a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)

[image]

Revit 2013 API
Document..::..NewFloor Method (CurveArray, FloorType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a floor within the project with the given horizontal profile and floor style on the specified level with the specified normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFloor(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
Public Function NewFloor ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFloor(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::..FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the floor is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

Examples

CopyC#
Floor CreateFloor(UIApplication application, Level level)
{
    // Get the Revit document
    Autodesk.Revit.DB.Document document = application.ActiveUIDocument.Document;

    // Get the application creation object
    Autodesk.Revit.Creation.Application appCreation = application.Application.Create;

    // Get a floor type for floor creation
    FloorType floorType = null;
    FloorTypeSet floorTypes = document.FloorTypes;
    FloorTypeSetIterator iter = floorTypes.ForwardIterator();
    iter.Reset();
    while (iter.MoveNext())
    {
        floorType = iter.Current as FloorType;
        if (null != floorType)
        {
            break;
        }
    }

    // Build a floor profile for the floor creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 15, 0);
    XYZ fourth = new XYZ(0, 15, 0);
    CurveArray profile = new CurveArray();
    profile.Append(appCreation.NewLineBound(first, second));
    profile.Append(appCreation.NewLineBound(second, third));
    profile.Append(appCreation.NewLineBound(third, fourth));
    profile.Append(appCreation.NewLineBound(fourth, first));

    // The normal vector (0,0,1) that must be perpendicular to the profile.
    XYZ normal = XYZ.BasisZ;

    return document.Create.NewFloor(profile, floorType, level, true, normal);
}
CopyVB.NET
Function CreateFloor(ByVal application As UIApplication, ByVal level As Level) As Autodesk.Revit.DB.Floor
    ' Get the Revit document
    Dim document As Autodesk.Revit.DB.Document = application.ActiveUIDocument.Document

    ' Get the application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = application.Application.Create

    ' Get a floor type for floor creation
    Dim floorType As FloorType = Nothing
    Dim floorTypes As FloorTypeSet = document.FloorTypes
    Dim iter As FloorTypeSetIterator = floorTypes.ForwardIterator()
    iter.Reset()
    While iter.MoveNext()
        floorType = TryCast(iter.Current, FloorType)
        If floorType IsNot Nothing Then
            Exit While
        End If
    End While

    ' Build a floor profile for the floor creation
    Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.DB.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.DB.XYZ(20, 15, 0)
    Dim fourth As New Autodesk.Revit.DB.XYZ(0, 15, 0)
    Dim profile As New CurveArray()
    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    ' The normal vector (0,0,1) that must be perpendicular to the profile.
    Dim normal As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.BasisZ

    Return document.Create.NewFloor(profile, floorType, level, True, normal)
End Function

See Also

Document Class
NewFloor Overload
Autodesk.Revit.Creation Namespace


NewFootPrintRoof Method

[image]

Revit 2013 API
Document..::..NewFootPrintRoof Method
Document Class Example See Also Send Feedback
Creates a new FootPrintRoof element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FootPrintRoof NewFootPrintRoof(
    CurveArray footPrint,
    Level level,
    RoofType roofType,
    out ModelCurveArray footPrintToModelCurvesMapping
)
Visual Basic
Public Function NewFootPrintRoof ( _
    footPrint As CurveArray, _
    level As Level, _
    roofType As RoofType, _
    <OutAttribute> ByRef footPrintToModelCurvesMapping As ModelCurveArray _
) As FootPrintRoof
Visual C++
public:
FootPrintRoof^ NewFootPrintRoof(
    CurveArray^ footPrint,
    Level^ level,
    RoofType^ roofType,
    [OutAttribute] ModelCurveArray^% footPrintToModelCurvesMapping
)

Parameters

footPrint
Type: Autodesk.Revit.DB..::..CurveArray
The footprint of the FootPrintRoof.
level
Type: Autodesk.Revit.DB..::..Level
The level of the FootPrintRoof.
roofType
Type: Autodesk.Revit.DB..::..RoofType
Type of the FootPrintRoof.
footPrintToModelCurvesMapping
Type: Autodesk.Revit.DB..::..ModelCurveArray%
An array of Model Curves corresponding to the set of Curves input in the footPrint. By knowing which Model Curve was created by each footPrint curve, you can set properties like SlopeAngle for each curve.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
// Before invoking this sample, select some walls to add a roof over.
// Make sure there is a level named "Roof" in the document.

// find the Roof level
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(new ElementClassFilter(typeof(Level)));
var elements = from element in collector where element.Name == "Roof" select element;
Level level = elements.Cast<Level>().ElementAt<Level>(0);

RoofType rooftype = null;
// select the first rooftype
foreach (RoofType rt in document.RoofTypes)
{
    rooftype = rt;
    break;
}

// Get the handle of the application
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Define the footprint for the roof based on user selection
CurveArray footprint = application.Create.NewCurveArray();
UIDocument uidoc = new UIDocument(document);
if (uidoc.Selection.Elements.Size != 0)
{
    foreach (Autodesk.Revit.DB.Element element in uidoc.Selection.Elements)
    {
        Wall wall = element as Wall;
        if (wall != null)
        {
            LocationCurve wallCurve = wall.Location as LocationCurve;
            footprint.Append(wallCurve.Curve);
            continue;
        }

        ModelCurve modelCurve = element as ModelCurve;
        if (modelCurve != null)
        {
            footprint.Append(modelCurve.GeometryCurve);
        }
    }

}
else
{
    throw new Exception("You should select a curve loop, or a wall loop, or loops combination \nof walls and curves to create a footprint roof.");
}

ModelCurveArray footPrintToModelCurveMapping = new ModelCurveArray();
FootPrintRoof footprintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, out footPrintToModelCurveMapping);
ModelCurveArrayIterator iterator = footPrintToModelCurveMapping.ForwardIterator();
iterator.Reset();
while (iterator.MoveNext())
{
    ModelCurve modelCurve = iterator.Current as ModelCurve;
    footprintRoof.set_DefinesSlope(modelCurve, true);
    footprintRoof.set_SlopeAngle(modelCurve, 0.5);
}
CopyVB.NET
' Before invoking this sample, select some walls to add a roof over.
' Make sure there is a level named "Roof" in the document.

' find the Roof level
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(New ElementClassFilter(GetType(Autodesk.Revit.DB.Level)))
Dim elements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
elements = From element In collector _
            Where element.Name = "Roof" _
            Select element
Dim level As Level = elements.Cast(Of Autodesk.Revit.DB.Level)().ElementAt(0)

Dim rooftype As RoofType = Nothing
' select the first rooftype
For Each rt As RoofType In document.RoofTypes
    rooftype = rt
    Exit For
Next

' Get the handle of the application
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Define the footprint for the roof based on user selection
Dim footprint As CurveArray = application.Create.NewCurveArray()
Dim uidoc As New UIDocument(document)
If uidoc.Selection.Elements.Size <> 0 Then
    For Each element As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
        Dim wall As Wall = TryCast(element, Wall)
        If wall IsNot Nothing Then
            Dim wallCurve As LocationCurve = TryCast(wall.Location, LocationCurve)
            footprint.Append(wallCurve.Curve)
            Continue For
        End If

        Dim modelCurve As ModelCurve = TryCast(element, ModelCurve)
        If modelCurve IsNot Nothing Then
            footprint.Append(modelCurve.GeometryCurve)
        End If

    Next
Else
    Throw New Exception("You should select a curve loop, or a wall loop, or loops combination " & vbLf & "of walls and curves to create a footprint roof.")
End If

Dim footPrintToModelCurveMapping As New ModelCurveArray()
Dim footprintRoof As FootPrintRoof = document.Create.NewFootPrintRoof(footprint, level, rooftype, footPrintToModelCurveMapping)
Dim iterator As ModelCurveArrayIterator = footPrintToModelCurveMapping.ForwardIterator()
iterator.Reset()
While iterator.MoveNext()
    Dim modelCurve As ModelCurve = TryCast(iterator.Current, ModelCurve)
    footprintRoof.DefinesSlope(modelCurve) = True
    footprintRoof.SlopeAngle(modelCurve) = 0.5
End While

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationSlab Method

[image]

Revit 2013 API
Document..::..NewFoundationSlab Method
Document Class See Also Send Feedback
Creates a foundation slab within the project with the given horizontal profile and floor style on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewFoundationSlab(
    CurveArray profile,
    FloorType floorType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
Public Function NewFoundationSlab ( _
    profile As CurveArray, _
    floorType As FloorType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Floor
Visual C++
public:
Floor^ NewFoundationSlab(
    CurveArray^ profile,
    FloorType^ floorType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the floor.
floorType
Type: Autodesk.Revit.DB..::..FloorType
A floor type to be used by the new floor instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the floor is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the floor is considered to be upper and down.

Return Value

if successful, a new foundation slab object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The Face formed by profile should be suitable to create floor, otherwise an exception thrown.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewFoundationWall Method

[image]

Revit 2013 API
Document..::..NewFoundationWall Method
Document Class See Also Send Feedback
Creates a new continuous footing object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFooting NewFoundationWall(
    ContFootingType contFootingType,
    Wall wall
)
Visual Basic
Public Function NewFoundationWall ( _
    contFootingType As ContFootingType, _
    wall As Wall _
) As ContFooting
Visual C++
public:
ContFooting^ NewFoundationWall(
    ContFootingType^ contFootingType,
    Wall^ wall
)

Parameters

contFootingType
Type: Autodesk.Revit.DB..::..ContFootingType
The ContFooting type.
wall
Type: Autodesk.Revit.DB..::..Wall
The Wall to append a ContFooting.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGrid Method

[image] [image]

Revit 2013 API
Document..::..NewGrid Method
Document Class See Also Send Feedback
Creates a new grid line.

Overload List

 | Name | Description
Public method | NewGrid(Arc) | Creates a new radial grid line.
Public method | NewGrid(Line) | Creates a new linear grid line.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGrid Method (Arc)

[image]

Revit 2013 API
Document..::..NewGrid Method (Arc)
Document Class Example See Also Send Feedback
Creates a new radial grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Grid NewGrid(
    Arc arc
)
Visual Basic
Public Function NewGrid ( _
    arc As Arc _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Arc^ arc
)

Parameters

arc
Type: Autodesk.Revit.DB..::..Arc
An arc object that represents the location of the new grid line.

Return Value

The newly created grid line.

Remarks

The arc should be on a horizontal plane.

Examples

CopyC#
// Create the geometry arc which the grid locates
XYZ end0 = new XYZ(0, 0, 0);
XYZ end1 = new XYZ(10, 40, 0);
XYZ pointOnCurve = new XYZ(5, 7, 0);
Arc geomArc = document.Application.Create.NewArc(end0, end1, pointOnCurve);

// Create a grid using the geometry arc
Grid arcGrid = document.Create.NewGrid(geomArc);

if (null == arcGrid)
{
    throw new Exception("Create a new curved grid failed.");
}

// Modify the name of the created grid
arcGrid.Name = "New Name2";
CopyVB.NET
' Create the geometry arc which the grid locates
Dim end0 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 40, 0)
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(5, 7, 0)
Dim geomArc As Arc = document.Application.Create.NewArc(end0, end1, pointOnCurve)

' Create a grid using the geometry arc
Dim arcGrid As Grid = document.Create.NewGrid(geomArc)

If arcGrid Is Nothing Then
    Throw New Exception("Create a new curved grid failed.")
End If

' Modify the name of the created grid
arcGrid.Name = "New Name2"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrid Method (Line)

[image]

Revit 2013 API
Document..::..NewGrid Method (Line)
Document Class Example See Also Send Feedback
Creates a new linear grid line.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Grid NewGrid(
    Line line
)
Visual Basic
Public Function NewGrid ( _
    line As Line _
) As Grid
Visual C++
public:
Grid^ NewGrid(
    Line^ line
)

Parameters

line
Type: Autodesk.Revit.DB..::..Line
A line object which represents the location of the grid line.

Return Value

The newly created grid line.

Remarks

The line should be on a horizontal plane.

Examples

CopyC#
// Create the geometry line which the grid locates
XYZ start = new XYZ(0, 0, 0);
XYZ end = new XYZ(30, 30, 0);
Line geomLine = Line.get_Bound(start, end);

// Create a grid using the geometry line
Grid lineGrid = document.Create.NewGrid(geomLine);

if (null == lineGrid)
{
    throw new Exception("Create a new straight grid failed.");
}

// Modify the name of the created grid
lineGrid.Name = "New Name1";
CopyVB.NET
' Create the geometry line which the grid locates
Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim [end] As New Autodesk.Revit.DB.XYZ(30, 30, 0)
Dim geomLine As Line = Line.Bound(start, [end])

' Create a grid using the geometry line
Dim lineGrid As Grid = document.Create.NewGrid(geomLine)

If lineGrid Is Nothing Then
    Throw New Exception("Create a new straight grid failed.")
End If

' Modify the name of the created grid
lineGrid.Name = "New Name1"

See Also

Document Class
NewGrid Overload
Autodesk.Revit.Creation Namespace


NewGrids Method

[image]

Revit 2013 API
Document..::..NewGrids Method
Document Class See Also Send Feedback
Creates new grid lines.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet NewGrids(
    CurveArray curves
)
Visual Basic
Public Function NewGrids ( _
    curves As CurveArray _
) As ElementSet
Visual C++
public:
ElementSet^ NewGrids(
    CurveArray^ curves
)

Parameters

curves
Type: Autodesk.Revit.DB..::..CurveArray
The curves which represent the new grid lines. These curves must be lines or bounded arcs.

Return Value

An Element set that contains the Grids.

Remarks

All input curves should lie on horizontal planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If the curve is an unbounded arc (a circle).
Autodesk.Revit.Exceptions..::..ArgumentNullException | If any curve supplied in the input is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If any grid line is not created successfully or regeneration fails at the end of the batch creation.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image] [image]

Revit 2013 API
Document..::..NewGroup Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method

[image] [image]

Revit 2013 API
Document..::..NewGutter Method
Document Class See Also Send Feedback
Creates a gutter.

Overload List

 | Name | Description
Public method | NewGutter(GutterType, Reference) | Creates a gutter along a reference.
Public method | NewGutter(GutterType, ReferenceArray) | Creates a gutter along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, Reference)

[image]

Revit 2013 API
Document..::..NewGutter Method (GutterType, Reference)
Document Class See Also Send Feedback
Creates a gutter along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    Reference reference
)
Visual Basic
Public Function NewGutter ( _
    GutterType As GutterType, _
    reference As Reference _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    Reference^ reference
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The type of the gutter to create
reference
Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewGutter Method (GutterType, ReferenceArray)

[image]

Revit 2013 API
Document..::..NewGutter Method (GutterType, ReferenceArray)
Document Class See Also Send Feedback
Creates a gutter along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Gutter NewGutter(
    GutterType GutterType,
    ReferenceArray references
)
Visual Basic
Public Function NewGutter ( _
    GutterType As GutterType, _
    references As ReferenceArray _
) As Gutter
Visual C++
public:
Gutter^ NewGutter(
    GutterType^ GutterType,
    ReferenceArray^ references
)

Parameters

GutterType
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The type of the gutter to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the gutter.

Return Value

If successful a new gutter object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewGutter Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method

[image] [image]

Revit 2013 API
Document..::..NewLineBoundaryConditions Method
Document Class See Also Send Feedback
Creates a new Line BoundaryConditions element.

Overload List

 | Name | Description
Public method | NewLineBoundaryConditions(Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a host element.
Public method | NewLineBoundaryConditions(Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double) | Creates a new Line BoundaryConditions element on a reference.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2013 API
Document..::..NewLineBoundaryConditions Method (Element, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Element hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic
Public Function NewLineBoundaryConditions ( _
    hostElement As Element, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Element^ hostElement,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::..Element
A Beam.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionsWithElement(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only works for columns.");
    }

    // Create the new line boundary conditions
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateLineConditionsWithElement(ByVal column As Autodesk.Revit.DB.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.DB.Structure.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only works for columns.")
    End If

    ' Create the new line boundary conditions
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(column, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)

[image]

Revit 2013 API
Document..::..NewLineBoundaryConditions Method (Reference, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double, TranslationRotationValue, Double)
Document Class Example See Also Send Feedback
Creates a new Line BoundaryConditions element on a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryConditions NewLineBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)
Visual Basic
Public Function NewLineBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewLineBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The Geometry reference to a Beam's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical line.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring"

Return Value

If successful, NewLineBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 1 - "Line". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreateLineConditionWithReference(FamilyInstance column, Autodesk.Revit.Creation.Document docCreation)
{
    if (StructuralType.Column != column.StructuralType)
    {
        throw new Exception("This sample only work for columns.");
    }

    // Get the line reference for the column analytical model
    Reference lineReference = null;
    AnalyticalModel analytical = column.GetAnalyticalModel() as AnalyticalModel;
    lineReference = analytical.GetCurve().Reference;
    if (null == lineReference)
    {
        throw new Exception("Unable to get reference line for selected column.");
    }

    // Create line Boundary Conditions for the column
    BoundaryConditions condition = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0,
                                                                                TranslationRotationValue.Fixed, 0);
    return (null != condition);
}
CopyVB.NET
Function CreateLineConditionWithReference(ByVal column As Autodesk.Revit.DB.FamilyInstance, ByVal docCreation As Autodesk.Revit.Creation.Document) As Boolean
    If Autodesk.Revit.DB.Structure.StructuralType.Column <> column.StructuralType Then
        Throw New Exception("This sample only work for columns.")
    End If

    ' Get the line reference for the column analytical model
    Dim lineReference As Reference = Nothing
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    lineReference = analytical.GetCurve().Reference
    If lineReference Is Nothing Then
        Throw New Exception("Unable to get reference line for selected column.")
    End If

    ' Create line Boundary Conditions for the column
    Dim condition As BoundaryConditions = docCreation.NewLineBoundaryConditions(lineReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0)
    Return (condition IsNot Nothing)
End Function

See Also

Document Class
NewLineBoundaryConditions Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method

[image] [image]

Revit 2013 API
Document..::..NewLineLoad Method
Document Class See Also Send Feedback
Creates a new line load within the project.

Overload List

 | Name | Description
Public method | NewLineLoad(Element, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at two points.
Public method | NewLineLoad(Reference, IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new hosted line load within the project using data at an array of points.
Public method | NewLineLoad(IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), IList<(Of <<'(XYZ>)>>), Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at an array of points.
Public method | NewLineLoad(XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane) | Creates a new unhosted line load within the project using data at two points.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Element, IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewLineLoad Method (Element, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Element host,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewLineLoad ( _
    host As Element, _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Element^ host,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The host element (Beam, Brace or Column) of the LineLoad application.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear moments in the end points.
uniform
Type: System..::..Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::..Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (Reference, IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewLineLoad Method (Reference, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    Reference reference,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewLineLoad ( _
    reference As Reference, _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    Reference^ reference,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The Geometry reference to Beam's, Brace's, Column's, Wall's, Wall Foundation's, Slab's or Slab Foundation's analytical lines.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear moments in the end points.
uniform
Type: System..::..Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::..Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (IList(XYZ), IList(XYZ), IList(XYZ), Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewLineLoad Method (IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, IList<(Of <(<'XYZ>)>)>, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at an array of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    IList<XYZ> points,
    IList<XYZ> forces,
    IList<XYZ> moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewLineLoad ( _
    points As IList(Of XYZ), _
    forces As IList(Of XYZ), _
    moments As IList(Of XYZ), _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    IList<XYZ^>^ points,
    IList<XYZ^>^ forces,
    IList<XYZ^>^ moments,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The end points of the LineLoad application.
forces
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear forces in the end points.
moments
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The applied 3d linear moments in the end points.
uniform
Type: System..::..Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::..Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns an object for the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewLineLoad Method (XYZ, XYZ, XYZ, XYZ, XYZ, XYZ, Boolean, Boolean, Boolean, LineLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new unhosted line load within the project using data at two points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoad NewLineLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    XYZ point1,
    XYZ force1,
    XYZ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewLineLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    point1 As XYZ, _
    force1 As XYZ, _
    moment1 As XYZ, _
    uniform As Boolean, _
    projected As Boolean, _
    isReaction As Boolean, _
    symbol As LineLoadType, _
    plane As SketchPlane _
) As LineLoad
Visual C++
public:
LineLoad^ NewLineLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    XYZ^ point1,
    XYZ^ force1,
    XYZ^ moment1,
    bool uniform,
    bool projected,
    bool isReaction,
    LineLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The first point of the LineLoad application.
force
Type: Autodesk.Revit.DB..::..XYZ
The applied 3d linear force in the first point.
moment
Type: Autodesk.Revit.DB..::..XYZ
The applied 3d linear moment in the first point.
point1
Type: Autodesk.Revit.DB..::..XYZ
The second point of the LineLoad application.
force1
Type: Autodesk.Revit.DB..::..XYZ
The applied 3d linear force in the second point.
moment1
Type: Autodesk.Revit.DB..::..XYZ
The applied 3d linear moment in the second point.
uniform
Type: System..::..Boolean
Set to True if you wish to create the uniform load.
projected
Type: System..::..Boolean
Set to True if you wish to create the projected load.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The symbol of the LineLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the LineLoad.

Return Value

If successful, NewLineLoad returns the newly created LineLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewLineLoad Overload
Autodesk.Revit.Creation Namespace


NewLoadCase Method

[image]

Revit 2013 API
Document..::..NewLoadCase Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCase element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCase NewLoadCase(
    string name,
    LoadNature nature,
    Category category
)
Visual Basic
Public Function NewLoadCase ( _
    name As String, _
    nature As LoadNature, _
    category As Category _
) As LoadCase
Visual C++
public:
LoadCase^ NewLoadCase(
    String^ name,
    LoadNature^ nature,
    Category^ category
)

Parameters

name
Type: System..::..String
The not empty name for the Load Case Element to create.
nature
Type: Autodesk.Revit.DB.Structure..::..LoadNature
The Load Case nature.
category
Type: Autodesk.Revit.DB..::..Category
The Load Case category.

Return Value

If successful, NewLoadCase and there isn't the Load Case Element with the same name returns an object for the newly created LoadCase. If such element exist and match desired one (has the same nature and number), returns existing element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Examples

CopyC#
LoadCase CreateLoadCase(Autodesk.Revit.DB.Document document, Category category, LoadNature nature)
{
    // Create a load case
    // Category should be of type OST_LoadCases
    LoadCase loadCase = document.Create.NewLoadCase("new case", nature, category);
    if (null == loadCase)
    {
        throw new Exception("Create a new load case failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Successfully created a load case.");

    return loadCase;
}
CopyVB.NET
Function CreateLoadCase(ByVal document As Autodesk.Revit.DB.Document, ByVal category As Category, ByVal nature As LoadNature) As LoadCase
    ' Create a load case
    ' Category should be of type OST_LoadCases
    Dim loadCase As LoadCase = document.Create.NewLoadCase("new case", nature, category)
    If loadCase Is Nothing Then
        Throw New Exception("Create a new load case failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Successfully created a load case.")

    Return loadCase
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadCombination Method

[image]

Revit 2013 API
Document..::..NewLoadCombination Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadCombination element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCombination NewLoadCombination(
    string name,
    int typeInd,
    int stateInd,
    double[] factors,
    LoadCaseArray cases,
    LoadCombinationArray combinations,
    LoadUsageArray usages
)
Visual Basic
Public Function NewLoadCombination ( _
    name As String, _
    typeInd As Integer, _
    stateInd As Integer, _
    factors As Double(), _
    cases As LoadCaseArray, _
    combinations As LoadCombinationArray, _
    usages As LoadUsageArray _
) As LoadCombination
Visual C++
public:
LoadCombination^ NewLoadCombination(
    String^ name,
    int typeInd,
    int stateInd,
    array<double>^ factors,
    LoadCaseArray^ cases,
    LoadCombinationArray^ combinations,
    LoadUsageArray^ usages
)

Parameters

name
Type: System..::..String
The not empty name for the Load Combination Element to create.
typeInd
Type: System..::..Int32
LoadCombination Type Index: 0-Combination, 1-Envelope.
stateInd
Type: System..::..Int32
LoadCombination State Index: 0-Servicebility, 1-Ultimate.
factors
Type: array<System..::..Double>[]()[][]
Factors array for Load Combination formula.
cases
Type: Autodesk.Revit.DB.Structure..::..LoadCaseArray
Load Cases array for Load Combination formula.
combinations
Type: Autodesk.Revit.DB.Structure..::..LoadCombinationArray
Load Combinations array for Load Combination formula.
usages
Type: Autodesk.Revit.DB.Structure..::..LoadUsageArray
Load Usages array.

Return Value

If successful, NewLoadCombination and there isn't the Load Combination Element with the same name returns an object for the newly created LoadCombination. If such element exist and match desired one (has the same formula and the same usages set), returns existing element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Remarks

Factors and Load Combinations arrays have the same dimension (n). The Load Combination formula is equal to: factors[0]*cases[0]*factors[1]*cases[1]*. . . factors[n]*cases[n].

Examples

CopyC#
LoadCombination CreateLoadCombination(Autodesk.Revit.DB.Document document, LoadCaseArray loadCases, LoadUsageArray loadUsages)
{
    // Create the factor array for load combination creation
    double[] factorArray = new double[loadCases.Size];
    for (int ii = 0; ii < loadCases.Size; ii++)
    {
        factorArray[ii] = ii + 1;
    }

    // Create a new load combination
    int typeInd = 0;    // Combination
    int stateInd = 0;   // Servicebility
    LoadCombinationArray combinations = new LoadCombinationArray();

    LoadCombination loadCombination = document.Create.NewLoadCombination("New combination",
                                                        typeInd, stateInd, factorArray, loadCases,
                                                        combinations, loadUsages);
    if (null == loadCombination)
    {
        throw new Exception("Create a load combination failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Load combination created successfully.");

    return loadCombination;
}
CopyVB.NET
Function CreateLoadCombination(ByVal document As Autodesk.Revit.DB.Document, ByVal loadCases As LoadCaseArray, ByVal loadUsages As LoadUsageArray) As LoadCombination
    ' Create the factor array for load combination creation
    Dim factorArray As Double() = New Double(loadCases.Size) {}
    Dim ii As Integer = 0
    While ii < loadCases.Size
        factorArray(ii) = ii + 1
        System.Math.Max(System.Threading.Interlocked.Increment(ii), ii - 1)
    End While

    ' Create a new load combination
    Dim typeInd As Integer = 0
    ' Combination
    Dim stateInd As Integer = 0
    ' Servicebility
    Dim combinations As New LoadCombinationArray()

    Dim loadCombination As LoadCombination = document.Create.NewLoadCombination("New combination", typeInd, stateInd, factorArray, loadCases, combinations, _
     loadUsages)
    If loadCombination Is Nothing Then
        Throw New Exception("Create a load combination failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Load combination created successfully.")

    Return loadCombination
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadNature Method

[image]

Revit 2013 API
Document..::..NewLoadNature Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadNature element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadNature NewLoadNature(
    string name
)
Visual Basic
Public Function NewLoadNature ( _
    name As String _
) As LoadNature
Visual C++
public:
LoadNature^ NewLoadNature(
    String^ name
)

Parameters

name
Type: System..::..String
The name for the Load Nature Element to create.

Return Value

If successful and there isn't the Load Nature Element with the same name NewLoadNature returns an object for the newly created LoadNature. If such element exist it returns existing element. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
// Create a new load nature.
LoadNature nature = document.Create.NewLoadNature("New Nature");
if (null == nature)
{
    throw new Exception("Create a new load nature failed.");
}
CopyVB.NET
' Create a new load nature.
Dim nature As LoadNature = document.Create.NewLoadNature("New Nature")
If nature Is Nothing Then
    Throw New Exception("Create a new load nature failed.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewLoadUsage Method

[image]

Revit 2013 API
Document..::..NewLoadUsage Method
Document Class Example See Also Send Feedback
Creates a new instance of a LoadUsage element within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadUsage NewLoadUsage(
    string name
)
Visual Basic
Public Function NewLoadUsage ( _
    name As String _
) As LoadUsage
Visual C++
public:
LoadUsage^ NewLoadUsage(
    String^ name
)

Parameters

name
Type: System..::..String
The not empty name for the Load Usage Element to create.

Return Value

If successful and there isn't the Load Usage Element with the same name NewLoadUsage returns an object for the newly created LoadUsage. If such element exist it returns existing element. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
// Create some Load usages and add them into an array
LoadUsage usage1 = document.Create.NewLoadUsage("Usage one");
LoadUsage usage2 = document.Create.NewLoadUsage("Usage two");

if (null == usage1 || null == usage2)
{
    throw new Exception("Create new load usage failed.");
}

LoadUsageArray loadUsages = new LoadUsageArray();
loadUsages.Append(usage1);
loadUsages.Append(usage2);
CopyVB.NET
' Create some Load usages and add them into an array
Dim usage1 As LoadUsage = document.Create.NewLoadUsage("Usage one")
Dim usage2 As LoadUsage = document.Create.NewLoadUsage("Usage two")

If usage1 Is Nothing OrElse usage2 Is Nothing Then
    Throw New Exception("Create new load usage failed.")
End If

Dim loadUsages As New LoadUsageArray()
loadUsages.Append(usage1)
loadUsages.Append(usage2)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewMechanicalSystem Method

[image]

Revit 2013 API
Document..::..NewMechanicalSystem Method
Document Class Example See Also Send Feedback
Creates a new MEP mechanical system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MechanicalSystem NewMechanicalSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    DuctSystemType ductSystemType
)
Visual Basic
Public Function NewMechanicalSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    ductSystemType As DuctSystemType _
) As MechanicalSystem
Visual C++
public:
MechanicalSystem^ NewMechanicalSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    DuctSystemType ductSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.DB..::..Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be nullNothingnullptra null reference (Nothing in Visual Basic). The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.DB..::..ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
ductSystemType
Type: Autodesk.Revit.DB.Mechanical..::..DuctSystemType
The system type.

Return Value

If creation was successful then an instance of mechanical system is returned, otherwise an exception with information will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
// create a connector set for new mechanical system
ConnectorSet connectorSet = new ConnectorSet();
// Base equipment connector
Connector baseConnector = null;

// Select a Parallel Fan Powered VAV and some Supply Diffusers
// prior to running this example
ConnectorSetIterator csi = null;
ElementSet selection = uiDocument.Selection.Elements;
foreach (Element e in selection)
{
    if (e is FamilyInstance)
    {
        FamilyInstance fi = e as FamilyInstance;
        Family family = fi.Symbol.Family;
        // Assume the selected Mechanical Equipment is the base equipment for new system
        if (family.FamilyCategory.Name == "Mechanical Equipment")
        {
            //Find the "Out" and "SupplyAir" connector on the base equipment
            if (null != fi.MEPModel)
            {
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
                while (csi.MoveNext())
                {
                    Connector conn = csi.Current as Connector;
                    if (conn.Direction == FlowDirectionType.Out && conn.DuctSystemType == DuctSystemType.SupplyAir)
                    {
                        baseConnector = conn;
                        break;
                    }
                }
            }
        }
        else if (family.FamilyCategory.Name == "Air Terminals")
        {
            // add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator();
            csi.MoveNext();
            connectorSet.Insert(csi.Current as Connector);
        }
    }
}

MechanicalSystem mechanicalSys = null;
if (null != baseConnector && connectorSet.Size > 0)
{
    // create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir);
}
CopyVB.NET
' create a connector set for new mechanical system
Dim connectorSet As New ConnectorSet()
' Base equipment connector
Dim baseConnector As Connector = Nothing

' Select a Parallel Fan Powered VAV and some Supply Diffusers
' prior to running this example
Dim csi As ConnectorSetIterator = Nothing
Dim selection As ElementSet = uiDocument.Selection.Elements
For Each e As Element In selection
    If TypeOf e Is FamilyInstance Then
        Dim fi As FamilyInstance = TryCast(e, FamilyInstance)
        Dim family As Family = fi.Symbol.Family
        ' Assume the selected Mechanical Equipment is the base equipment for new system
        If family.FamilyCategory.Name = "Mechanical Equipment" Then
            'Find the "Out" and "SupplyAir" connector on the base equipment
            If fi.MEPModel IsNot Nothing Then
                csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
                While csi.MoveNext()
                    Dim conn As Connector = TryCast(csi.Current, Connector)
                    If conn.Direction = FlowDirectionType.Out AndAlso conn.DuctSystemType = DuctSystemType.SupplyAir Then
                        baseConnector = conn
                        Exit While
                    End If
                End While
            End If
        ElseIf family.FamilyCategory.Name = "Air Terminals" Then
            ' add selected Air Terminals to connector set for new mechanical system
            csi = fi.MEPModel.ConnectorManager.Connectors.ForwardIterator()
            csi.MoveNext()
            connectorSet.Insert(TryCast(csi.Current, Connector))
        End If
    End If
Next

Dim mechanicalSys As MechanicalSystem = Nothing
If baseConnector IsNot Nothing AndAlso connectorSet.Size > 0 Then
    ' create a new SupplyAir mechanical system
    mechanicalSys = uiDocument.Document.Create.NewMechanicalSystem(baseConnector, connectorSet, DuctSystemType.SupplyAir)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input connectors parameter value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the ductSystemType parameter is out of permitted scope.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system. The owner of BaseConnector should be a mechanical equipment, and the owner of other connectors should be a mechanical equipment or air terminal.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the mechanical system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image] [image]

Revit 2013 API
Document..::..NewOpening Method
Document Class See Also Send Feedback
Creates a new opening.

Overload List

 | Name | Description
Public method | NewOpening(Element, CurveArray, eRefFace) | Creates a new opening in a beam, brace and column.
Public method | NewOpening(Element, CurveArray, Boolean) | Creates a new opening in a roof, floor and ceiling.
Public method | NewOpening(Level, Level, CurveArray) | Creates a new shaft opening between a set of levels.
Public method | NewOpening(Wall, XYZ, XYZ) | Creates a rectangular opening on a wall.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, eRefFace)

[image]

Revit 2013 API
Document..::..NewOpening Method (Element, CurveArray, eRefFace)
Document Class See Also Send Feedback
Creates a new opening in a beam, brace and column.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Opening NewOpening(
    Element famInstElement,
    CurveArray profile,
    eRefFace iFace
)
Visual Basic
Public Function NewOpening ( _
    famInstElement As Element, _
    profile As CurveArray, _
    iFace As eRefFace _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ famInstElement,
    CurveArray^ profile,
    eRefFace iFace
)

Parameters

famInstElement
Type: Autodesk.Revit.DB..::..Element
host element of the opening, can be a beam, brace and column.
profile
Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.
iFace
Type: Autodesk.Revit.Creation..::..eRefFace
face on which opening is based on.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms opening on a beam, brace and column.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Element, CurveArray, Boolean)

[image]

Revit 2013 API
Document..::..NewOpening Method (Element, CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Opening NewOpening(
    Element hostElement,
    CurveArray profile,
    bool bPerpendicularFace
)
Visual Basic
Public Function NewOpening ( _
    hostElement As Element, _
    profile As CurveArray, _
    bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ hostElement,
    CurveArray^ profile,
    bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit.DB..::..Element
Host element of the opening. Can be a roof, floor, or ceiling.
profile
Type: Autodesk.Revit.DB..::..CurveArray
Profile of the opening.
bPerpendicularFace
Type: System..::..Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Level, Level, CurveArray)

[image]

Revit 2013 API
Document..::..NewOpening Method (Level, Level, CurveArray)
Document Class See Also Send Feedback
Creates a new shaft opening between a set of levels.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Opening NewOpening(
    Level bottomLevel,
    Level topLevel,
    CurveArray profile
)
Visual Basic
Public Function NewOpening ( _
    bottomLevel As Level, _
    topLevel As Level, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Level^ bottomLevel,
    Level^ topLevel,
    CurveArray^ profile
)

Parameters

bottomLevel
Type: Autodesk.Revit.DB..::..Level
bottom level
topLevel
Type: Autodesk.Revit.DB..::..Level
top level
profile
Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.

Return Value

If successful, an Opening object is returned.

Remarks

This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewOpening Method (Wall, XYZ, XYZ)

[image]

Revit 2013 API
Document..::..NewOpening Method (Wall, XYZ, XYZ)
Document Class See Also Send Feedback
Creates a rectangular opening on a wall.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Opening NewOpening(
    Wall wall,
    XYZ pntStart,
    XYZ pntEnd
)
Visual Basic
Public Function NewOpening ( _
    wall As Wall, _
    pntStart As XYZ, _
    pntEnd As XYZ _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Wall^ wall,
    XYZ^ pntStart,
    XYZ^ pntEnd
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
Host element of the opening.
pntStart
Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
pntEnd
Type: Autodesk.Revit.DB..::..XYZ
The opposite corner of the rectangle.

Return Value

If successful, an Opening object is returned.

See Also

Document Class
NewOpening Overload
Autodesk.Revit.Creation Namespace


NewPathReinforcement Method

[image]

Revit 2013 API
Document..::..NewPathReinforcement Method
Document Class Example See Also Send Feedback
Creates a new instance of a Path Reinforcement element within the project

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PathReinforcement NewPathReinforcement(
    Element host,
    CurveArray curves,
    bool flip
)
Visual Basic
Public Function NewPathReinforcement ( _
    host As Element, _
    curves As CurveArray, _
    flip As Boolean _
) As PathReinforcement
Visual C++
public:
PathReinforcement^ NewPathReinforcement(
    Element^ host,
    CurveArray^ curves,
    bool flip
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
The element to which the Path Reinforcement belongs. The element must be a structural floor or wall.
curves
Type: Autodesk.Revit.DB..::..CurveArray
An array of curves forming a chain. Bars will be placed orthogonal to the chain with their hook ends near the chain, offset by the side cover setting. The curves must belong to the top face of the floor or the exterior face of the wall.
flip
Type: System..::..Boolean
A flag controlling the bars relative to the curves. If the curves are given in order and with consistent orientation, the bars will lie to the right of the chain if flip=false, to the left if flip=true, when viewed from above the floor or outside the wall.

Return Value

If successful, NewPathReinforcement returns an object for the newly created Rebar. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
PathReinforcement CreatePathReinforcement(Autodesk.Revit.DB.Document document, Wall wall)
{
    // Create a geometry line in the selected wall as the path
    CurveArray curves = new CurveArray();
    LocationCurve location = wall.Location as LocationCurve;
    XYZ start = location.Curve.get_EndPoint(0);
    XYZ end = location.Curve.get_EndPoint(1);
    curves.Append(document.Application.Create.NewLineBound(start, end));

    // Begin to create the path reinforcement
    PathReinforcement rein = document.Create.NewPathReinforcement(wall, curves, true);
    if (null == rein)
    {
        throw new Exception("Create path reinforcement failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Create path reinforcement succeed.");

    return rein;
}
CopyVB.NET
Function CreatePathReinforcement(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall) As Autodesk.Revit.DB.Structure.PathReinforcement
    ' Create a geometry line in the selected wall as the path
    Dim curves As New CurveArray()
    Dim location As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim start As Autodesk.Revit.DB.XYZ = location.Curve.EndPoint(0)
    Dim [end] As Autodesk.Revit.DB.XYZ = location.Curve.EndPoint(1)
    curves.Append(document.Application.Create.NewLineBound(start, [end]))

    ' Begin to create the path reinforcement
    Dim rein As Autodesk.Revit.DB.Structure.PathReinforcement = document.Create.NewPathReinforcement(wall, curves, True)
    If rein Is Nothing Then
        Throw New Exception("Create path reinforcement failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Create path reinforcement succeed.")

    Return rein
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPipe Method

[image] [image]

Revit 2013 API
Document..::..NewPipe Method
Document Class See Also Send Feedback
Adds a new pipe into the document.

Overload List

 | Name | Description
Public method | NewPipe(Connector, Connector, PipeType) | Adds a new pipe into the document, using two connectors and duct type.
Public method | NewPipe(XYZ, Connector, PipeType) | Adds a new pipe into the document, using a point, connector and pipe type.
Public method | NewPipe(XYZ, XYZ, PipeType) | Adds a new pipe into the document, using two points and pipe type.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPipe Method (Connector, Connector, PipeType)

[image]

Revit 2013 API
Document..::..NewPipe Method (Connector, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using two connectors and duct type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Pipe NewPipe(
    Connector connector1,
    Connector connector2,
    PipeType pipeType
)
Visual Basic
Public Function NewPipe ( _
    connector1 As Connector, _
    connector2 As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    Connector^ connector1,
    Connector^ connector2,
    PipeType^ pipeType
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the pipe.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connectors are fitting or equipment connectors of the correct domain, and if the connectors’ direction match the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connectors will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, Connector, PipeType)

[image]

Revit 2013 API
Document..::..NewPipe Method (XYZ, Connector, PipeType)
Document Class See Also Send Feedback
Adds a new pipe into the document, using a point, connector and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point,
    Connector connector,
    PipeType pipeType
)
Visual Basic
Public Function NewPipe ( _
    point As XYZ, _
    connector As Connector, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point,
    Connector^ connector,
    PipeType^ pipeType
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The first point of the pipe.
connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Remarks

If the connector is a fitting or equipment connector of the correct domain, and if the connector’s direction matches the direction of the pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector if necessary. If the connector's type, domain, or direction does not match the direction of the duct to be created, the position of the input connector will govern the endpoints of the pipe, but no connection will be established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument point or connector is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipe Method (XYZ, XYZ, PipeType)

[image]

Revit 2013 API
Document..::..NewPipe Method (XYZ, XYZ, PipeType)
Document Class Example See Also Send Feedback
Adds a new pipe into the document, using two points and pipe type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Pipe NewPipe(
    XYZ point1,
    XYZ point2,
    PipeType pipeType
)
Visual Basic
Public Function NewPipe ( _
    point1 As XYZ, _
    point2 As XYZ, _
    pipeType As PipeType _
) As Pipe
Visual C++
public:
Pipe^ NewPipe(
    XYZ^ point1,
    XYZ^ point2,
    PipeType^ pipeType
)

Parameters

point1
Type: Autodesk.Revit.DB..::..XYZ
The first point of the pipe.
point2
Type: Autodesk.Revit.DB..::..XYZ
The second point of the pipe.
pipeType
Type: Autodesk.Revit.DB.Plumbing..::..PipeType
The type of the pipe.

Return Value

If creation was successful then a new pipe is returned, otherwise an exception with failure information will be thrown.

Examples

CopyC#
public Pipe CreateNewPipe(Document document)
{
    // find a pipe type

    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.OfClass(typeof(PipeType));
    PipeType pipeType = collector.FirstElement() as PipeType;

    Pipe pipe = null;
    if (null != pipeType)
    {
        // create pipe between 2 points
        XYZ p1 = new XYZ(0, 0, 0);
        XYZ p2 = new XYZ(10, 0, 0);

        pipe = document.Create.NewPipe(p1, p2, pipeType);
    }

    return pipe;
}
CopyVB.NET
Public Function CreateNewPipe(ByVal document As Document) As Pipe
    ' find a pipe type

    Dim collector As New FilteredElementCollector(document)
    collector.OfClass(GetType(PipeType))
    Dim pipeType As PipeType = TryCast(collector.FirstElement(), PipeType)

    Dim pipe As Pipe = Nothing
    If pipeType IsNot Nothing Then
        ' create pipe between 2 points
        Dim p1 As New XYZ(0, 0, 0)
        Dim p2 As New XYZ(10, 0, 0)

        pipe = document.Create.NewPipe(p1, p2, pipeType)
    End If

    Return pipe
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument point1 or point2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the pipe cannot be created or regenerate fails.

See Also

Document Class
NewPipe Overload
Autodesk.Revit.Creation Namespace


NewPipingSystem Method

[image]

Revit 2013 API
Document..::..NewPipingSystem Method
Document Class See Also Send Feedback
Creates a new MEP piping system element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipingSystem NewPipingSystem(
    Connector baseEquipmentConnector,
    ConnectorSet connectors,
    PipeSystemType pipingSystemType
)
Visual Basic
Public Function NewPipingSystem ( _
    baseEquipmentConnector As Connector, _
    connectors As ConnectorSet, _
    pipingSystemType As PipeSystemType _
) As PipingSystem
Visual C++
public:
PipingSystem^ NewPipingSystem(
    Connector^ baseEquipmentConnector,
    ConnectorSet^ connectors,
    PipeSystemType pipingSystemType
)

Parameters

baseEquipmentConnector
Type: Autodesk.Revit.DB..::..Connector
One connector within base equipment which is used to connect with the system. The base equipment is optional for the system, so this argument may be nullNothingnullptra null reference (Nothing in Visual Basic). The baseEquipmentConnector should not be included in the connectors.
connectors
Type: Autodesk.Revit.DB..::..ConnectorSet
Connectors that will connect to the system. The owner elements of these connectors will be added into system as its elements.
pipingSystemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The System type.

Return Value

If creation was successful then an instance of piping system is returned, otherwise an exception with information will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when calling this function outside of the Autodesk Revit MEP product.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the connectors parameter value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the pipingSystemType parameter value is out of permitted scope.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some connectors can't be used to create the mechanical system. All the input connectors and base equipment connector should match system type and domain with the system, and they should not have been used in another system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the piping system creation failed.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointBoundaryConditions Method

[image]

Revit 2013 API
Document..::..NewPointBoundaryConditions Method
Document Class Example See Also Send Feedback
Creates a new Point BoundaryConditions Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryConditions NewPointBoundaryConditions(
    Reference reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)
Visual Basic
Public Function NewPointBoundaryConditions ( _
    reference As Reference, _
    X_Translation As TranslationRotationValue, _
    X_TranslationSpringModulus As Double, _
    Y_Translation As TranslationRotationValue, _
    Y_TranslationSpringModulus As Double, _
    Z_Translation As TranslationRotationValue, _
    Z_TranslationSpringModulus As Double, _
    X_Rotation As TranslationRotationValue, _
    X_RotationSpringModulus As Double, _
    Y_Rotation As TranslationRotationValue, _
    Y_RotationSpringModulus As Double, _
    Z_Rotation As TranslationRotationValue, _
    Z_RotationSpringModulus As Double _
) As BoundaryConditions
Visual C++
public:
BoundaryConditions^ NewPointBoundaryConditions(
    Reference^ reference,
    TranslationRotationValue X_Translation,
    double X_TranslationSpringModulus,
    TranslationRotationValue Y_Translation,
    double Y_TranslationSpringModulus,
    TranslationRotationValue Z_Translation,
    double Z_TranslationSpringModulus,
    TranslationRotationValue X_Rotation,
    double X_RotationSpringModulus,
    TranslationRotationValue Y_Rotation,
    double Y_RotationSpringModulus,
    TranslationRotationValue Z_Rotation,
    double Z_RotationSpringModulus
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A Geometry reference to a Beam's, Brace's or Column's analytical line end.
X_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the X axis translation option.
X_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for X axis. Ignored if X_Translation is not "Spring".
Y_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Y axis translation option.
Y_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Y axis. Ignored if Y_Translation is not "Spring".
Z_Translation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the Z axis translation option.
Z_TranslationSpringModulus
Type: System..::..Double
Translation Spring Modulus for Z axis. Ignored if Z_Translation is not "Spring".
X_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the X axis.
X_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for X axis. Ignored if X_Rotation is not "Spring".
Y_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the Y axis.
Y_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for Y axis. Ignored if Y_Rotation is not "Spring".
Z_Rotation
Type: Autodesk.Revit.DB.Structure..::..TranslationRotationValue
A value indicating the option for rotation about the Z axis.
Z_RotationSpringModulus
Type: System..::..Double
Rotation Spring Modulus for Z axis. Ignored if Y_Rotation is not "Spring".

Return Value

If successful, NewPointBoundaryConditions returns an object for the newly created BoundaryConditions with the BoundaryType = 0 - "Point". nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Remarks

This method will only function with the Autodesk Revit Structure application.

Examples

CopyC#
bool CreatePointBoundaryCondition(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // Get the start point reference of the column
    Reference startReference = null;
    AnalyticalModel analyticalModel = column.GetAnalyticalModel() as AnalyticalModel;

    if (null != analyticalModel)
    {
        startReference = analyticalModel.GetCurve().get_EndPointReference(0);
    }
    else
    {
        throw new Exception("Cannot get end point for selected column");
    }

    // Get the Revit creation document
    Autodesk.Revit.Creation.Document docCreation = document.Create;

    // Create the Point Boundary Conditions for the start point
    BoundaryConditions condition = docCreation.NewPointBoundaryConditions(startReference,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0,
                                                                          TranslationRotationValue.Fixed, 0);
    if (null == condition)
    {
        throw new Exception("Can't create the point boundary condition for selected column start point.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Point boundary condition created successfully.");

    return (null != condition);
}
CopyVB.NET
Function CreatePointBoundaryCondition(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance) As Boolean
    ' Get the start point reference of the column
    Dim startReference As Reference = Nothing
    Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)

    If analyticalModel IsNot Nothing Then
        startReference = analyticalModel.GetCurve().EndPointReference(0)
    Else
        Throw New Exception("Cannot get end point for selected column")
    End If

    ' Get the Revit creation document
    Dim docCreation As Autodesk.Revit.Creation.Document = document.Create

    ' Create the Point Boundary Conditions for the start point
    Dim condition As BoundaryConditions = docCreation.NewPointBoundaryConditions(startReference, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, 0, TranslationRotationValue.Fixed, _
     0)
    If condition Is Nothing Then
        Throw New Exception("Can't create the point boundary condition for selected column start point.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Point boundary condition created successfully.")

    Return (condition IsNot Nothing)
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewPointLoad Method

[image] [image]

Revit 2013 API
Document..::..NewPointLoad Method
Document Class See Also Send Feedback
Creates a new point load within the project.

Overload List

 | Name | Description
Public method | NewPointLoad(Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new hosted point load within the project.
Public method | NewPointLoad(XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane) | Creates a new unhosted point load within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewPointLoad Method (Reference, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class See Also Send Feedback
Creates a new hosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    Reference reference,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewPointLoad ( _
    reference As Reference, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    Reference^ reference,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The Geometry reference to Beam's, Brace's, Column's, analytical line's end.
force
Type: Autodesk.Revit.DB..::..XYZ
The 3d force.
moment
Type: Autodesk.Revit.DB..::..XYZ
The 3d moment.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)

[image]

Revit 2013 API
Document..::..NewPointLoad Method (XYZ, XYZ, XYZ, Boolean, PointLoadType, SketchPlane)
Document Class Example See Also Send Feedback
Creates a new unhosted point load within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointLoad NewPointLoad(
    XYZ point,
    XYZ force,
    XYZ moment,
    bool isReaction,
    PointLoadType symbol,
    SketchPlane plane
)
Visual Basic
Public Function NewPointLoad ( _
    point As XYZ, _
    force As XYZ, _
    moment As XYZ, _
    isReaction As Boolean, _
    symbol As PointLoadType, _
    plane As SketchPlane _
) As PointLoad
Visual C++
public:
PointLoad^ NewPointLoad(
    XYZ^ point,
    XYZ^ force,
    XYZ^ moment,
    bool isReaction,
    PointLoadType^ symbol,
    SketchPlane^ plane
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point of the PointLoad application.
force
Type: Autodesk.Revit.DB..::..XYZ
The 3d force.
moment
Type: Autodesk.Revit.DB..::..XYZ
The 3d moment.
isReaction
Type: System..::..Boolean
Specifies if the load is a reaction load. The load cannot be modified if isReaction=True.
symbol
Type: Autodesk.Revit.DB.Structure..::..PointLoadType
The symbol of the PointLoad.
plane
Type: Autodesk.Revit.DB..::..SketchPlane
Indicate the work plane of the PointLoad.

Return Value

If successful, NewPointLoad returns an object for the newly created PointLoad. nullNothingnullptra null reference (Nothing in Visual Basic) is returned if the operation fails.

Examples

CopyC#
//Define the location at which the PointLoad is applied.
 XYZ point = new XYZ(0, 0, 4);
 //Define the 3d force.
 XYZ force = new XYZ(0, 0, -1);
 //Define the 3d moment.
 XYZ moment = new XYZ(0, 0, 0);
 //Set to True if you wish to create the reaction
 System.Boolean isReaction = true;

 PointLoad pointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, null, null);
CopyVB.NET
'Define the location at which the PointLoad is applied.
Dim point As New Autodesk.Revit.DB.XYZ(0, 0, 4)
'Define the 3d force.
Dim force As New Autodesk.Revit.DB.XYZ(0, 0, -1)
'Define the 3d moment.
Dim moment As New Autodesk.Revit.DB.XYZ(0, 0, 0)
'Set to True if you wish to create the reaction
Dim isReaction As System.Boolean = True

Dim pointLoad As Autodesk.Revit.DB.Structure.PointLoad = document.Create.NewPointLoad(point, force, moment, isReaction, Nothing, Nothing)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
NewPointLoad Overload
Autodesk.Revit.Creation Namespace


NewRebarBarType Method

[image]

Revit 2013 API
Document..::..NewRebarBarType Method
Document Class See Also Send Feedback
Creates a new instance of Rebar Bar Type, which defines the bar diameter, bar bend diameter and bar material of the rebar.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarBarType NewRebarBarType()
Visual Basic
Public Function NewRebarBarType As RebarBarType
Visual C++
public:
RebarBarType^ NewRebarBarType()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the product is not Revit Structure.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRoom Method

[image] [image]

Revit 2013 API
Document..::..NewRoom Method
Document Class See Also Send Feedback
Creates a new room.

Overload List

 | Name | Description
Public method | NewRoom(Phase) | Creates a new unplaced room and with an assigned phase.
Public method | NewRoom(Level, UV) | Creates a new room on a level at a specified point.
Public method | NewRoom(Room, PlanCircuit) | Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRoom Method (Phase)

[image]

Revit 2013 API
Document..::..NewRoom Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced room and with an assigned phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room NewRoom(
    Phase phase
)
Visual Basic
Public Function NewRoom ( _
    phase As Phase _
) As Room
Visual C++
public:
Room^ NewRoom(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the room is to exist.

Return Value

If successful the new room , otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Level, UV)

[image]

Revit 2013 API
Document..::..NewRoom Method (Level, UV)
Document Class Example See Also Send Feedback
Creates a new room on a level at a specified point.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room NewRoom(
    Level level,
    UV point
)
Visual Basic
Public Function NewRoom ( _
    level As Level, _
    point As UV _
) As Room
Visual C++
public:
Room^ NewRoom(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location of the room on that specified level.

Return Value

If successful the new room will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room CreateRoom(Autodesk.Revit.DB.Document document, Level level)
{
    // Create a UV structure which determines the room location
   UV roomLocation = new UV(0, 0);

    // Create a new room
    Room room = document.Create.NewRoom(level, roomLocation);
    if (null == room)
    {
        throw new Exception("Create a new room failed.");
    }

    return room;
}
CopyVB.NET
Function CreateRoom(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Room
    ' Create a UV structure which determines the room location
    Dim roomLocation As New Autodesk.Revit.DB.UV(0, 0)

    ' Create a new room
    Dim room As Room = document.Create.NewRoom(level, roomLocation)
    If room Is Nothing Then
        Throw New Exception("Create a new room failed.")
    End If

    Return room
End Function

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoom Method (Room, PlanCircuit)

[image]

Revit 2013 API
Document..::..NewRoom Method (Room, PlanCircuit)
Document Class Example See Also Send Feedback
Creates a new room within the confines of a plan circuit, or places an unplaced room within the confines of the plan circuit.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room NewRoom(
    Room room,
    PlanCircuit circuit
)
Visual Basic
Public Function NewRoom ( _
    room As Room, _
    circuit As PlanCircuit _
) As Room
Visual C++
public:
Room^ NewRoom(
    Room^ room,
    PlanCircuit^ circuit
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::..Room
The room which you want to locate in the circuit. Pass nullNothingnullptra null reference (Nothing in Visual Basic) to create a new room.
circuit
Type: Autodesk.Revit.DB..::..PlanCircuit
The circuit in which you want to locate a room.

Return Value

If successful the room is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
Room InsertNewRoomInPlanCircuit(Autodesk.Revit.DB.Document document, Level level, Phase newConstructionPhase)
{
    // create room using Phase
    Room newScheduleRoom = document.Create.NewRoom(newConstructionPhase);

    // set the Room Number and Name
    string newRoomNumber = "101";
    string newRoomName = "Class Room 1";
    newScheduleRoom.Name = newRoomName;
    newScheduleRoom.Number = newRoomNumber;

    // Get a PlanCircuit
    PlanCircuit planCircuit = null;
    // first get the plan topology for given level
    PlanTopology planTopology = document.get_PlanTopology(level);

    // Iterate circuits in this plan topology
    foreach (PlanCircuit circuit in planTopology.Circuits)
    {
        // get the first circuit we find
        if (null != circuit)
        {
            planCircuit = circuit;
            break;
        }
    }

    Room newRoom2 = null;
    if (null != planCircuit)
    {
        Transaction transaction = new Transaction(document, "Create Room");
        if (transaction.Start() == TransactionStatus.Started)
        {
            // The input room must exist only in the room schedule,
            // meaning that it does not display in any plan view.
            newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit);
            // a model room with the same name and number is created in the
            // view where the PlanCircuit is located
            if (null != newRoom2)
            {
                // Give the user some information
                TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.");
            }
            transaction.Commit();
        }
    }

    return newRoom2;
}
CopyVB.NET
Function InsertNewRoomInPlanCircuit(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal newConstructionPhase As Phase) As Room
    ' create room using Phase
    Dim newScheduleRoom As Room = document.Create.NewRoom(newConstructionPhase)

    ' set the Room Number and Name
    Dim newRoomNumber As String = "101"
    Dim newRoomName As String = "Class Room 1"
    newScheduleRoom.Name = newRoomName
    newScheduleRoom.Number = newRoomNumber

    ' Get a PlanCircuit
    Dim planCircuit As PlanCircuit = Nothing
    ' first get the plan topology for given level
    Dim planTopology As PlanTopology = document.PlanTopology(level)

    ' Iterate circuits in this plan topology
    For Each circuit As PlanCircuit In planTopology.Circuits
        ' get the first circuit we find
        If circuit IsNot Nothing Then
            planCircuit = circuit
            Exit For
        End If
    Next

    Dim newRoom2 As Room = Nothing
    If planCircuit IsNot Nothing Then
        Dim transaction As New Transaction(document, "Create Room")
        If transaction.Start() = TransactionStatus.Started Then
            ' The input room must exist only in the room schedule,
            ' meaning that it does not display in any plan view.
            newRoom2 = document.Create.NewRoom(newScheduleRoom, planCircuit)
            ' a model room with the same name and number is created in the
            ' view where the PlanCircuit is located
            If newRoom2 IsNot Nothing Then
                ' Give the user some information
                TaskDialog.Show("Revit", "Room placed in Plan Circuit successfully.")
            End If
            transaction.Commit()
        End If
    End If

    Return newRoom2
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the existing room is already placed.

See Also

Document Class
NewRoom Overload
Autodesk.Revit.Creation Namespace


NewRoomBoundaryLines Method

[image]

Revit 2013 API
Document..::..NewRoomBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Room border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray NewRoomBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic
Public Function NewRoomBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewRoomBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::..CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::..View
The View for the new Room

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewRooms Method

[image] [image]

Revit 2013 API
Document..::..NewRooms Method
Document Class See Also Send Feedback
Creates one or more rooms.

Overload List

 | Name | Description
Public method | NewRooms(Level) | Obsolete. Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms(List<(Of <<'(RoomCreationData>)>>)) | Obsolete. Creates new rooms using the specified placement data.
Public method | NewRooms(Level, Phase) | Obsolete. Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms(Phase, Int32) | Obsolete. Creates new unplaced rooms in the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRooms Method (Level)

[image]

Revit 2013 API
Document..::..NewRooms Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level) instead.")]
public ElementSet NewRooms(
    Level level
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level) instead.")> _
Public Function NewRooms ( _
    level As Level _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level) instead.")]
public:
ElementSet^ NewRooms(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.

Return Value

If successful an Element set which contain the rooms created should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (List(RoomCreationData))

[image]

Revit 2013 API
Document..::..NewRooms Method (List<(Of <(<'RoomCreationData>)>)>)
Document Class See Also Send Feedback
Creates new rooms using the specified placement data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewRooms(
    List<RoomCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewRooms ( _
    dataList As List(Of RoomCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRoom(Autodesk.Revit.DB.Level, Autodesk.Revit.DB.UV) instead.   Create each room in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewRooms(
    List<RoomCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'RoomCreationData>)>)>
A list of RoomCreationData which wraps the creation arguments of the rooms to be created.

Return Value

If successful an ElementSet contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more of the RoomCreationData's level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The relevant room tag is not created successfully, or regeneration fails at the end of the batch creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Level, Phase)

[image]

Revit 2013 API
Document..::..NewRooms Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")]
public ElementSet NewRooms(
    Level level,
    Phase phase
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")> _
Public Function NewRooms ( _
    level As Level, _
    phase As Phase _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Level level, Autodesk.Revit.DB.Phase phase) instead.")]
public:
ElementSet^ NewRooms(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the room is to exist.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms Method (Phase, Int32)

[image]

Revit 2013 API
Document..::..NewRooms Method (Phase, Int32)
Document Class See Also Send Feedback
Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")]
public ElementSet NewRooms(
    Phase phase,
    int count
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")> _
Public Function NewRooms ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewRooms2(Autodesk.Revit.DB.Phase phase, int count) instead.")]
public:
ElementSet^ NewRooms(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the rooms are to exist.
count
Type: System..::..Int32
The number of the rooms to be created.

Return Value

If successful an Element set which contain the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms Overload
Autodesk.Revit.Creation Namespace


NewRooms2 Method

[image] [image]

Revit 2013 API
Document..::..NewRooms2 Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewRooms2(Level) | Creates new rooms in each plan circuit found in the given level in the last phase.
Public method | NewRooms2(Level, Phase) | Creates new rooms in each plan circuit found in the given level in the given phase.
Public method | NewRooms2(Phase, Int32) | Creates new unplaced rooms in the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewRooms2 Method (Level)

[image]

Revit 2013 API
Document..::..NewRooms2 Method (Level)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the last phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewRooms2(
    Level level
)
Visual Basic
Public Function NewRooms2 ( _
    level As Level _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.

Return Value

If successful, a set of ElementIds which contains the rooms created should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


NewRooms2 Method (Level, Phase)

[image]

Revit 2013 API
Document..::..NewRooms2 Method (Level, Phase)
Document Class See Also Send Feedback
Creates new rooms in each plan circuit found in the given level in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewRooms2(
    Level level,
    Phase phase
)
Visual Basic
Public Function NewRooms2 ( _
    level As Level, _
    phase As Phase _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewRooms2(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level from which the circuits are found.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the room is to exist.

Return Value

If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | If the view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid, or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


NewRooms2 Method (Phase, Int32)

[image]

Revit 2013 API
Document..::..NewRooms2 Method (Phase, Int32)
Document Class See Also Send Feedback
Creates new unplaced rooms in the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewRooms2(
    Phase phase,
    int count
)
Visual Basic
Public Function NewRooms2 ( _
    phase As Phase, _
    count As Integer _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewRooms2(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase on which the rooms are to exist.
count
Type: System..::..Int32
The number of the rooms to be created.

Return Value

If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the room can not be created successfully or regeneration fails at the end of the creation.

See Also

Document Class
NewRooms2 Overload
Autodesk.Revit.Creation Namespace


NewRoomTag Method

[image]

Revit 2013 API
Document..::..NewRoomTag Method
Document Class Example See Also Send Feedback
Creates a new RoomTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTag NewRoomTag(
    Room room,
    UV point,
    View view
)
Visual Basic
Public Function NewRoomTag ( _
    room As Room, _
    point As UV, _
    view As View _
) As RoomTag
Visual C++
public:
RoomTag^ NewRoomTag(
    Room^ room,
    UV^ point,
    View^ view
)

Parameters

room
Type: Autodesk.Revit.DB.Architecture..::..Room
The Room which the tag refers.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on the level of the room.
view
Type: Autodesk.Revit.DB..::..View
The view where the tag will lie.

Return Value

If successful a RoomTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

Remarks

This method will regenerate the document even in manual regeneration mode.

Examples

CopyC#
RoomTag CreateRoomTag(Autodesk.Revit.DB.Document document, Room room)
{
    // Create a UV structure which determine the room tag location
   UV roomTagLocation = new UV(0, 0);

    // Create a new room tag in the created room
    RoomTag roomTag = document.Create.NewRoomTag(room, roomTagLocation, null);
    if (null == roomTag)
    {
        throw new Exception("Create a new room tag failed.");
    }

    // Give the user some information
    TaskDialog.Show("Revit","Room tag created successfully.");

    return roomTag;
}
CopyVB.NET
Function CreateRoomTag(ByVal document As Autodesk.Revit.DB.Document, ByVal room As Room) As Autodesk.Revit.DB.Architecture.RoomTag
    ' Create a UV structure which determine the room tag location
    Dim roomTagLocation As New Autodesk.Revit.DB.UV(0, 0)

    ' Create a new room tag in the created room
    Dim roomTag As Autodesk.Revit.DB.Architecture.RoomTag = document.Create.NewRoomTag(room, roomTagLocation, Nothing)
    If roomTag Is Nothing Then
        Throw New Exception("Create a new room tag failed.")
    End If

    ' Give the user some information
    TaskDialog.Show("Revit", "Room tag created successfully.")

    Return roomTag
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2013 API
Document..::..NewSketchPlane Method
Document Class See Also Send Feedback
Creates a new sketch plane.

Overload List

 | Name | Description
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlab Method

[image]

Revit 2013 API
Document..::..NewSlab Method
Document Class See Also Send Feedback
Creates a slab within the project with the given horizontal profile using the default floor style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Floor NewSlab(
    CurveArray profile,
    Level level,
    Line slopedArrow,
    double slope,
    bool isStructural
)
Visual Basic
Public Function NewSlab ( _
    profile As CurveArray, _
    level As Level, _
    slopedArrow As Line, _
    slope As Double, _
    isStructural As Boolean _
) As Floor
Visual C++
public:
Floor^ NewSlab(
    CurveArray^ profile,
    Level^ level,
    Line^ slopedArrow,
    double slope,
    bool isStructural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the horizontal profile of the slab.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the slab is to be placed.
slopedArrow
Type: Autodesk.Revit.DB..::..Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
slope
Type: System..::..Double
The slope.
isStructural
Type: System..::..Boolean
If set, specifies that the floor is structural in nature.

Return Value

If successful a new floor object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSlabEdge Method

[image] [image]

Revit 2013 API
Document..::..NewSlabEdge Method
Document Class See Also Send Feedback
Creates a slab edge.

Overload List

 | Name | Description
Public method | NewSlabEdge(SlabEdgeType, Reference) | Creates a slab edge along a reference.
Public method | NewSlabEdge(SlabEdgeType, ReferenceArray) | Creates a slab edge along a reference array.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, Reference)

[image]

Revit 2013 API
Document..::..NewSlabEdge Method (SlabEdgeType, Reference)
Document Class See Also Send Feedback
Creates a slab edge along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    Reference reference
)
Visual Basic
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    reference As Reference _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    Reference^ reference
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.DB..::..SlabEdgeType
The type of the slab edge to create
reference
Type: Autodesk.Revit.DB..::..Reference
A planar line or arc that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSlabEdge Method (SlabEdgeType, ReferenceArray)

[image]

Revit 2013 API
Document..::..NewSlabEdge Method (SlabEdgeType, ReferenceArray)
Document Class See Also Send Feedback
Creates a slab edge along a reference array.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdge NewSlabEdge(
    SlabEdgeType SlabEdgeType,
    ReferenceArray references
)
Visual Basic
Public Function NewSlabEdge ( _
    SlabEdgeType As SlabEdgeType, _
    references As ReferenceArray _
) As SlabEdge
Visual C++
public:
SlabEdge^ NewSlabEdge(
    SlabEdgeType^ SlabEdgeType,
    ReferenceArray^ references
)

Parameters

SlabEdgeType
Type: Autodesk.Revit.DB..::..SlabEdgeType
The type of the slab edge to create
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of planar lines and arcs that represents the place where you want to place the slab edge.

Return Value

If successful a new slab edge object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSlabEdge Overload
Autodesk.Revit.Creation Namespace


NewSpace Method

[image] [image]

Revit 2013 API
Document..::..NewSpace Method
Document Class See Also Send Feedback
Creates a new space.

Overload List

 | Name | Description
Public method | NewSpace(Phase) | Creates a new unplaced space on a given phase.
Public method | NewSpace(Level, UV) | Creates a new space element on the given level at the given location.
Public method | NewSpace(Level, Phase, UV) | Creates a new space element on the given level, at the given location, and assigned to the given phase.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpace Method (Phase)

[image]

Revit 2013 API
Document..::..NewSpace Method (Phase)
Document Class See Also Send Feedback
Creates a new unplaced space on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space NewSpace(
    Phase phase
)
Visual Basic
Public Function NewSpace ( _
    phase As Phase _
) As Space
Visual C++
public:
Space^ NewSpace(
    Phase^ phase
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the space is to exist.

Return Value

If successful the new space should be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, UV)

[image]

Revit 2013 API
Document..::..NewSpace Method (Level, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level at the given location.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    UV point
)
Visual Basic
Public Function NewSpace ( _
    level As Level, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the space is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on that specified level.

Return Value

If successful the new space element is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when level or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpace Method (Level, Phase, UV)

[image]

Revit 2013 API
Document..::..NewSpace Method (Level, Phase, UV)
Document Class See Also Send Feedback
Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space NewSpace(
    Level level,
    Phase phase,
    UV point
)
Visual Basic
Public Function NewSpace ( _
    level As Level, _
    phase As Phase, _
    point As UV _
) As Space
Visual C++
public:
Space^ NewSpace(
    Level^ level,
    Phase^ phase,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the room is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the room is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on that specified level.

Return Value

If successful a new Space element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when level, phase or point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the space cannot be created.

See Also

Document Class
NewSpace Overload
Autodesk.Revit.Creation Namespace


NewSpaceBoundaryLines Method

[image]

Revit 2013 API
Document..::..NewSpaceBoundaryLines Method
Document Class See Also Send Feedback
Creates a new boundary line as an Space border.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray NewSpaceBoundaryLines(
    SketchPlane sketchPlane,
    CurveArray curves,
    View view
)
Visual Basic
Public Function NewSpaceBoundaryLines ( _
    sketchPlane As SketchPlane, _
    curves As CurveArray, _
    view As View _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewSpaceBoundaryLines(
    SketchPlane^ sketchPlane,
    CurveArray^ curves,
    View^ view
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plan
curves
Type: Autodesk.Revit.DB..::..CurveArray
The geometry curves on which the boundary lines are
view
Type: Autodesk.Revit.DB..::..View
The View for the new Space

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpaces Method

[image] [image]

Revit 2013 API
Document..::..NewSpaces Method
Document Class See Also Send Feedback
Creates one or more spaces.

Overload List

 | Name | Description
Public method | NewSpaces(Phase, Int32) | Obsolete. Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces(Level, Phase, View) | Obsolete. Creates new spaces on the available plan circuits of a the given level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces Method (Phase, Int32)

[image]

Revit 2013 API
Document..::..NewSpaces Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")]
public ElementSet NewSpaces(
    Phase phase,
    int count
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")> _
Public Function NewSpaces ( _
    phase As Phase, _
    count As Integer _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Phase phase, int count ) instead.")]
public:
ElementSet^ NewSpaces(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces are to exist.
count
Type: System..::..Int32

Return Value

If successful, a set if new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaces Method (Level, Phase, View)

[image]

Revit 2013 API
Document..::..NewSpaces Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")]
public ElementSet NewSpaces(
    Level level,
    Phase phase,
    View view
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")> _
Public Function NewSpaces ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2012.  Call NewSpaces2( Autodesk.Revit.DB.Level level, Autodesk.Revit.DBPhase phase, AutodeskRevitDBView view ) instead.")]
public:
ElementSet^ NewSpaces(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.DB..::..View
The view on which the space tags for the spaces are to display.

Return Value

If successful an Element set which contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces Overload
Autodesk.Revit.Creation Namespace


NewSpaces2 Method

[image] [image]

Revit 2013 API
Document..::..NewSpaces2 Method
Document Class See Also Send Feedback
Creates one or more spaces.

Overload List

 | Name | Description
Public method | NewSpaces2(Phase, Int32) | Creates a set of new unplaced spaces on a given phase.
Public method | NewSpaces2(Level, Phase, View) | Creates new spaces on the available plan circuits of a the given level.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewSpaces2 Method (Phase, Int32)

[image]

Revit 2013 API
Document..::..NewSpaces2 Method (Phase, Int32)
Document Class See Also Send Feedback
Creates a set of new unplaced spaces on a given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewSpaces2(
    Phase phase,
    int count
)
Visual Basic
Public Function NewSpaces2 ( _
    phase As Phase, _
    count As Integer _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
    Phase^ phase,
    int count
)

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces are to exist.
count
Type: System..::..Int32

Return Value

If successful, a set of ElementIds of new unplaced spaces are be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


NewSpaces2 Method (Level, Phase, View)

[image]

Revit 2013 API
Document..::..NewSpaces2 Method (Level, Phase, View)
Document Class See Also Send Feedback
Creates new spaces on the available plan circuits of a the given level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewSpaces2(
    Level level,
    Phase phase,
    View view
)
Visual Basic
Public Function NewSpaces2 ( _
    level As Level, _
    phase As Phase, _
    view As View _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewSpaces2(
    Level^ level,
    Phase^ phase,
    View^ view
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the spaces is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase in which the spaces is to exist.
view
Type: Autodesk.Revit.DB..::..View
The view on which the space tags for the spaces are to display.

Return Value

If successful, a set of ElementIds which contains the rooms should be returned, otherwise the exception will be thrown.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The view of the relevant level can not be retrieved.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The phase is invalid or regeneration fails at the end of the creation.

See Also

Document Class
NewSpaces2 Overload
Autodesk.Revit.Creation Namespace


NewSpaceTag Method

[image]

Revit 2013 API
Document..::..NewSpaceTag Method
Document Class See Also Send Feedback
Creates a new SpaceTag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTag NewSpaceTag(
    Space space,
    UV point,
    View view
)
Visual Basic
Public Function NewSpaceTag ( _
    space As Space, _
    point As UV, _
    view As View _
) As SpaceTag
Visual C++
public:
SpaceTag^ NewSpaceTag(
    Space^ space,
    UV^ point,
    View^ view
)

Parameters

space
Type: Autodesk.Revit.DB.Mechanical..::..Space
The Space which the tag refers.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point that dictates the location on the level of the space.
view
Type: Autodesk.Revit.DB..::..View
The view where the tag will lie.

Return Value

If successful a SpaceTag object will be returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic). Suitable exceptions will be fired if the parameters are invalid.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotCoordinate Method

[image]

Revit 2013 API
Document..::..NewSpotCoordinate Method
Document Class See Also Send Feedback
Generate a new spot coordinate object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimension NewSpotCoordinate(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic
Public Function NewSpotCoordinate ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotCoordinate(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the spot coordinate is to be visible.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference to which the spot coordinate is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point which the spot coordinate evaluate.
bend
Type: Autodesk.Revit.DB..::..XYZ
The bend point for the spot coordinate.
end
Type: Autodesk.Revit.DB..::..XYZ
The end point for the spot coordinate.
refPt
Type: Autodesk.Revit.DB..::..XYZ
The actual point on the reference which the spot coordinate evaluate.
hasLeader
Type: System..::..Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewSpotElevation Method

[image]

Revit 2013 API
Document..::..NewSpotElevation Method
Document Class See Also Send Feedback
Generate a new spot elevation object within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimension NewSpotElevation(
    View view,
    Reference reference,
    XYZ origin,
    XYZ bend,
    XYZ end,
    XYZ refPt,
    bool hasLeader
)
Visual Basic
Public Function NewSpotElevation ( _
    view As View, _
    reference As Reference, _
    origin As XYZ, _
    bend As XYZ, _
    end As XYZ, _
    refPt As XYZ, _
    hasLeader As Boolean _
) As SpotDimension
Visual C++
public:
SpotDimension^ NewSpotElevation(
    View^ view,
    Reference^ reference,
    XYZ^ origin,
    XYZ^ bend,
    XYZ^ end,
    XYZ^ refPt,
    bool hasLeader
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the spot elevation is to be visible.
reference
Type: Autodesk.Revit.DB..::..Reference
The reference to which the spot elevation is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point which the spot elevation evaluate.
bend
Type: Autodesk.Revit.DB..::..XYZ
The bend point for the spot elevation.
end
Type: Autodesk.Revit.DB..::..XYZ
The end point for the spot elevation.
refPt
Type: Autodesk.Revit.DB..::..XYZ
The actual point on the reference which the spot elevation evaluate.
hasLeader
Type: System..::..Boolean
Indicate if it has leader or not.

Return Value

If successful a new spot dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTag Method

[image]

Revit 2013 API
Document..::..NewTag Method
Document Class Example See Also Send Feedback
Creates a new IndependentTag Element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IndependentTag NewTag(
    View dbview,
    Element elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ pnt
)
Visual Basic
Public Function NewTag ( _
    dbview As View, _
    elemToTag As Element, _
    addLeader As Boolean, _
    tagMode As TagMode, _
    tagOrientation As TagOrientation, _
    pnt As XYZ _
) As IndependentTag
Visual C++
public:
IndependentTag^ NewTag(
    View^ dbview,
    Element^ elemToTag,
    bool addLeader,
    TagMode tagMode,
    TagOrientation tagOrientation,
    XYZ^ pnt
)

Parameters

dbview
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
elemToTag
Type: Autodesk.Revit.DB..::..Element
The host object of tag.
addLeader
Type: System..::..Boolean
Whether there will be a leader.
tagMode
Type: Autodesk.Revit.DB..::..TagMode
The mode of the tag. Add by Category, add by Multi-Category, or add by material.
tagOrientation
Type: Autodesk.Revit.DB..::..TagOrientation
The orientation of the tag.
pnt
Type: Autodesk.Revit.DB..::..XYZ
The position of the tag.

Return Value

If successful, an IndependentTag object is returned.

Remarks

This method forms a tag relationship to the host object.

Examples

CopyC#
private IndependentTag CreateIndependentTag(Autodesk.Revit.DB.Document document, Wall wall)
{
    // make sure active view is not a 3D view
    Autodesk.Revit.DB.View view = document.ActiveView;

    // define tag mode and tag orientation for new tag
    TagMode tagMode = TagMode.TM_ADDBY_CATEGORY;
    TagOrientation tagorn = TagOrientation.Horizontal;

    // Add the tag to the middle of the wall
    LocationCurve wallLoc = wall.Location as LocationCurve;
    XYZ wallStart = wallLoc.Curve.get_EndPoint(0);
    XYZ wallEnd = wallLoc.Curve.get_EndPoint(1);
    XYZ wallMid = wallLoc.Curve.Evaluate(0.5, true);

    IndependentTag newTag = document.Create.NewTag(view, wall, true, tagMode, tagorn, wallMid);
    if (null == newTag)
    {
        throw new Exception("Create IndependentTag Failed.");
    }

    // newTag.TagText is read-only, so we change the Type Mark type parameter to
    // set the tag text.  The label parameter for the tag family determines
    // what type parameter is used for the tag text.

    WallType type = wall.WallType;

    Parameter foundParameter = type.get_Parameter("Type Mark");
    bool result = foundParameter.Set("Hello");

    // set leader mode free
    // otherwise leader end point move with elbow point

    newTag.LeaderEndCondition = LeaderEndCondition.Free;
    XYZ elbowPnt = wallMid + new XYZ(5.0, 5.0, 0.0);
    newTag.LeaderElbow = elbowPnt;
    XYZ headerPnt = wallMid + new XYZ(10.0, 10.0, 0.0);
    newTag.TagHeadPosition = headerPnt;

    return newTag;
}
CopyVB.NET
Private Function CreateIndependentTag(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall) As IndependentTag
    ' make sure active view is not a 3D view
    Dim view As Autodesk.Revit.DB.View = document.ActiveView

    ' define tag mode and tag orientation for new tag
    Dim tagMode As TagMode = tagMode.TM_ADDBY_CATEGORY
    Dim tagorn As TagOrientation = TagOrientation.TAG_HORIZONTAL

    ' Add the tag to the middle of the wall
    Dim wallLoc As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim wallStart As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(0)
    Dim wallEnd As Autodesk.Revit.DB.XYZ = wallLoc.Curve.EndPoint(1)
    Dim wallMid As Autodesk.Revit.DB.XYZ = wallLoc.Curve.Evaluate(0.5, True)

    Dim newTag As IndependentTag = document.Create.NewTag(view, wall, True, tagMode, tagorn, wallMid)
    If newTag Is Nothing Then
        Throw New Exception("Create IndependentTag Failed.")
    End If

    ' newTag.TagText is read-only, so we change the Type Mark type parameter to
    ' set the tag text.  The label parameter for the tag family determines
    ' what type parameter is used for the tag text.

    Dim type As WallType = wall.WallType

    Dim foundParameter As Parameter = type.Parameter("Type Mark")
    Dim result As Boolean = foundParameter.[Set]("Hello")

    ' set leader mode free
    ' otherwise leader end point move with elbow point

    newTag.LeaderMode = LeaderEndCondition.LEC_FREE
    Dim elbowPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(5, 5, 0)
    newTag.LeaderElbow = elbowPnt
    Dim headerPnt As Autodesk.Revit.DB.XYZ = wallMid + New Autodesk.Revit.DB.XYZ(10, 10, 0)
    newTag.TagHeadPosition = headerPnt

    Return newTag
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the view is a perspective view.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTakeoffFitting Method

[image]

Revit 2013 API
Document..::..NewTakeoffFitting Method
Document Class See Also Send Feedback
Add a new family instance of an takeoff fitting into the Autodesk Revit document, using one connector and one MEP curve.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewTakeoffFitting(
    Connector connector,
    MEPCurve curve
)
Visual Basic
Public Function NewTakeoffFitting ( _
    connector As Connector, _
    curve As MEPCurve _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTakeoffFitting(
    Connector^ connector,
    MEPCurve^ curve
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
The connector to be connected to the takeoff.
curve
Type: Autodesk.Revit.DB..::..MEPCurve
The duct or pipe which is the trunk for the takeoff.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connector and the curve cannot be used for takeoff creation. For example, they must be of the same domain, the curve must be a duct or pipe, and the owner of the connector should be (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when takeoff fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTeeFitting Method

[image]

Revit 2013 API
Document..::..NewTeeFitting Method
Document Class See Also Send Feedback
Add a new family instance of a tee fitting into the Autodesk Revit document, using three connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewTeeFitting(
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic
Public Function NewTeeFitting ( _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTeeFitting(
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the tee.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the tee.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third connector to be connected to the tee. This should be connected to the branch of the tee.

Return Value

If creation was successful then an family instance to the new object is returned, and the transition fitting will be added at the connectors’ end if necessary, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1, connector2 or connector3 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for the tee creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of the connectors should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when tee fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2013 API
Document..::..NewTextNote Method
Document Class See Also Send Feedback
Creates a new TextNote object.

Overload List

 | Name | Description
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewTopographySurface Method

[image]

Revit 2013 API
Document..::..NewTopographySurface Method
Document Class See Also Send Feedback
Creates a new TopographySurface element in the document, and initializes it with a set of points.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TopographySurface NewTopographySurface(
    IList<XYZ> points
)
Visual Basic
Public Function NewTopographySurface ( _
    points As IList(Of XYZ) _
) As TopographySurface
Visual C++
public:
TopographySurface^ NewTopographySurface(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
An array of initial points for the surface.

Return Value

The TopographySurface element.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when input argument 'points' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when points.Size is less than 3, to create a TopographySurface needs at least 3 points.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTransitionFitting Method

[image]

Revit 2013 API
Document..::..NewTransitionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an transition fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewTransitionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewTransitionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewTransitionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the transition.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the transition.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for transition creation. For example, they cannot be from the same element, they must be of the same domain, and the owner of connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when transition fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewTruss Method

[image]

Revit 2013 API
Document..::..NewTruss Method
Document Class Example See Also Send Feedback
Creates a New Truss.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Truss NewTruss(
    TrussType trussType,
    SketchPlane sketchPlane,
    Curve baseCurve
)
Visual Basic
Public Function NewTruss ( _
    trussType As TrussType, _
    sketchPlane As SketchPlane, _
    baseCurve As Curve _
) As Truss
Visual C++
public:
Truss^ NewTruss(
    TrussType^ trussType,
    SketchPlane^ sketchPlane,
    Curve^ baseCurve
)

Parameters

trussType
Type: Autodesk.Revit.DB.Structure..::..TrussType
The type for truss.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane where the truss is going to reside. It could be nullNothingnullptra null reference (Nothing in Visual Basic).
baseCurve
Type: Autodesk.Revit.DB..::..Curve
The curve that represents truss's base curve. It must be a line, must not be a vertical line, and must be within the sketch plane if sketchPlane is valid.

Examples

CopyC#
Truss CreateTruss(Autodesk.Revit.DB.Document document,
    FamilyInstance column1, FamilyInstance column2)
{
    Truss truss = null;
    Transaction transaction = new Transaction(document, "Add Truss");
    if (transaction.Start() == TransactionStatus.Started)
    {
        //sketchPlane
        XYZ origin = new XYZ(0, 0, 0);
        XYZ xDirection = new XYZ(1, 0, 0);
        XYZ yDirection = new XYZ(0, 1, 0);
        Plane plane = document.Application.Create.NewPlane(xDirection, yDirection, origin);
        SketchPlane sketchPlane = document.Create.NewSketchPlane(plane);

        //new base Line - use line that spans two selected columns
        AnalyticalModel frame1 = column1.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint1 = (frame1.GetCurve() as Line).get_EndPoint(0);

        AnalyticalModel frame2 = column2.GetAnalyticalModel() as AnalyticalModel;
        XYZ centerPoint2 = (frame2.GetCurve() as Line).get_EndPoint(0);

        XYZ startPoint = new XYZ(centerPoint1.X, centerPoint1.Y, 0);
        XYZ endPoint = new XYZ(centerPoint2.X, centerPoint2.Y, 0);
        Autodesk.Revit.DB.Line baseLine = null;

        try
        {
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint);
        }
        catch (System.ArgumentException)
        {
            throw new Exception("Selected columns are too close to create truss.");
        }

        // use the active view for where the truss's tag will be placed; View used in
        // NewTruss should be plan or elevation view parallel to the truss's base line
        Autodesk.Revit.DB.View view = document.ActiveView;

        // Get a truss type for the truss
        TrussType trussType = null;
        foreach (TrussType currentType in document.TrussTypes)
        {
            if (null != currentType)
            {
                trussType = currentType;
                break;
            }
        }

        if (null != trussType)
        {
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine);
            transaction.Commit();
        }
        else
        {
            transaction.RollBack();
            throw new Exception("No truss types found in document.");
        }
    }

    return truss;
}
CopyVB.NET
Function CreateTruss(ByVal document As Autodesk.Revit.DB.Document, ByVal column1 As Autodesk.Revit.DB.FamilyInstance, ByVal column2 As Autodesk.Revit.DB.FamilyInstance) As Truss
    Dim truss As Truss = Nothing
    Dim transaction As New Transaction(document, "Add Truss")
    If transaction.Start() = TransactionStatus.Started Then
        'sketchPlane
        Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim xDirection As New Autodesk.Revit.DB.XYZ(1, 0, 0)
        Dim yDirection As New Autodesk.Revit.DB.XYZ(0, 1, 0)
        Dim plane As Plane = document.Application.Create.NewPlane(xDirection, yDirection, origin)
        Dim sketchPlane As SketchPlane = document.Create.NewSketchPlane(plane)

        'new base Line - use line that spans two selected columns
        Dim frame1 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column1.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint1 As Autodesk.Revit.DB.XYZ = (TryCast(frame1.GetCurve(), Line)).EndPoint(0)

        Dim frame2 As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column2.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
        Dim centerPoint2 As Autodesk.Revit.DB.XYZ = (TryCast(frame2.GetCurve(), Line)).EndPoint(0)

        Dim startPoint As New Autodesk.Revit.DB.XYZ(centerPoint1.X, centerPoint1.Y, 0)
        Dim endPoint As New Autodesk.Revit.DB.XYZ(centerPoint2.X, centerPoint2.Y, 0)
        Dim baseLine As Autodesk.Revit.DB.Line = Nothing

        Try
            baseLine = document.Application.Create.NewLineBound(startPoint, endPoint)
        Catch generatedExceptionName As System.ArgumentException
            Throw New Exception("Selected columns are too close to create truss.")
        End Try

        ' use the active view for where the truss's tag will be placed; View used in
        ' NewTruss should be plan or elevation view parallel to the truss's base line
        Dim view As Autodesk.Revit.DB.View = document.ActiveView

        ' Get a truss type for the truss
        Dim trussType As TrussType = Nothing
        For Each currentType As TrussType In document.TrussTypes
            If currentType IsNot Nothing Then
                trussType = currentType
                Exit For
            End If
        Next

        If trussType IsNot Nothing Then
            truss = document.Create.NewTruss(trussType, sketchPlane, baseLine, view)
            transaction.Commit()
        Else
            transaction.RollBack()
            Throw New Exception("No truss types found in document.")
        End If
    End If

    Return truss
End Function

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewUnionFitting Method

[image]

Revit 2013 API
Document..::..NewUnionFitting Method
Document Class See Also Send Feedback
Add a new family instance of an union fitting into the Autodesk Revit document, using two connectors.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewUnionFitting(
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Function NewUnionFitting ( _
    connector1 As Connector, _
    connector2 As Connector _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewUnionFitting(
    Connector^ connector1,
    Connector^ connector2
)

Parameters

connector1
Type: Autodesk.Revit.DB..::..Connector
The first connector to be connected to the union.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second connector to be connected to the union.

Return Value

If creation was successful then an family instance to the new object is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connector1 or connector2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the connectors cannot be used for union creation. For example, they cannot be from the same element, they must be of the same domain and shape, and the owner of the connector1 should be a (flex) duct or pipe.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when union fitting cannot be created.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewDrafting Method

[image]

Revit 2013 API
Document..::..NewViewDrafting Method
Document Class Example See Also Send Feedback
Creates a new drafting view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewDrafting NewViewDrafting()
Visual Basic
Public Function NewViewDrafting As ViewDrafting
Visual C++
public:
ViewDrafting^ NewViewDrafting()

Return Value

The newly created drafting view.

Examples

CopyC#
// Create a new ViewDrafting instance
ViewDrafting view = document.Create.NewViewDrafting();
view.ViewName = "MyViewDrafting";

// Set the CropBox
BoundingBoxXYZ boundingBox = new BoundingBoxXYZ();
boundingBox.Max = new XYZ(100, 100, 50);
boundingBox.Min = new XYZ(-100, -100, -50);
view.CropBox = boundingBox;

// Use current view as template
view.ApplyTemplate(document.ActiveView);
CopyVB.NET
' Create a new ViewDrafting instance
Dim view As ViewDrafting = document.Create.NewViewDrafting()
view.ViewName = "MyViewDrafting"

' Set the CropBox
Dim boundingBox As New BoundingBoxXYZ()
boundingBox.Max = New Autodesk.Revit.DB.XYZ(100, 100, 50)
boundingBox.Min = New Autodesk.Revit.DB.XYZ(-100, -100, -50)
view.CropBox = boundingBox

' Use current view as template
view.ApplyTemplate(document.ActiveView)

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewViewSheet Method

[image]

Revit 2013 API
Document..::..NewViewSheet Method
Document Class Example See Also Send Feedback
Creates a new sheet view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSheet NewViewSheet(
    FamilySymbol titleBlock
)
Visual Basic
Public Function NewViewSheet ( _
    titleBlock As FamilySymbol _
) As ViewSheet
Visual C++
public:
ViewSheet^ NewViewSheet(
    FamilySymbol^ titleBlock
)

Parameters

titleBlock
Type: Autodesk.Revit.DB..::..FamilySymbol
The titleblock family symbol to apply to this sheet.

Return Value

The newly created sheet view.

Remarks

Use the TitleBlocks property of Document to choose a titleblock.

Examples

CopyC#
private void CreateSheetView(Autodesk.Revit.DB.Document document, View3D view3D)
{

    // Get an available title block from document
    FamilySymbolSet fsSet = document.TitleBlocks;
    if (fsSet.Size == 0)
    {
        throw new Exception("No title blocks");
    }

    FamilySymbol fs = null;
    foreach (FamilySymbol f in fsSet)
    {
        if (null != f)
        {
            fs = f;
            break;
        }
    }

    // Create a sheet view
    ViewSheet viewSheet = document.Create.NewViewSheet(fs);
    if (null == viewSheet)
    {
        throw new Exception("Failed to create new ViewSheet.");
    }

    // Add passed in view onto the center of the sheet
    UV location = new UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2,
                         (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2);

    viewSheet.AddView(view3D, location);

    // Print the sheet out
    if (viewSheet.CanBePrinted)
    {
       TaskDialog taskDialog = new TaskDialog("Revit");
       taskDialog.MainContent = "Print the sheet?";
       TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes | TaskDialogCommonButtons.No;
       taskDialog.CommonButtons = buttons;
       TaskDialogResult result = taskDialog.Show();

        if (result == TaskDialogResult.Yes)
        {
            viewSheet.Print();
        }
    }
}
CopyVB.NET
Private Sub CreateSheetView(ByVal document As Autodesk.Revit.DB.Document, ByVal view3D As View3D)

    ' Get an available title block from document
    Dim fsSet As FamilySymbolSet = document.TitleBlocks
    If fsSet.Size = 0 Then
        Throw New Exception("No title blocks")
    End If

    Dim fs As FamilySymbol = Nothing
    For Each f As FamilySymbol In fsSet
        If f IsNot Nothing Then
            fs = f
            Exit For
        End If
    Next

    ' Create a sheet view
    Dim viewSheet As ViewSheet = document.Create.NewViewSheet(fs)
    If viewSheet Is Nothing Then
        Throw New Exception("Failed to create new ViewSheet.")
    End If

    ' Add passed in view onto the center of the sheet
    Dim location As New Autodesk.Revit.DB.UV((viewSheet.Outline.Max.U - viewSheet.Outline.Min.U) / 2, (viewSheet.Outline.Max.V - viewSheet.Outline.Min.V) / 2)

    viewSheet.AddView(view3D, location)

    ' Print the sheet out
    If viewSheet.CanBePrinted Then
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = "Print the sheet?"
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()

        If result = TaskDialogResult.Yes Then
            viewSheet.Print()
        End If
    End If
End Sub

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewWall Method

[image] [image]

Revit 2013 API
Document..::..NewWall Method
Document Class See Also Send Feedback
Creates a new wall within the project.

Overload List

 | Name | Description
Public method | NewWall(CurveArray, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the default wall type.
Public method | NewWall(Curve, Level, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the default wall style.
Public method | NewWall(CurveArray, WallType, Level, Boolean) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type.
Public method | NewWall(CurveArray, WallType, Level, Boolean, XYZ) | Obsolete. Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Public method | NewWall(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Obsolete. Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, Boolean)

[image]

Revit 2013 API
Document..::..NewWall Method (CurveArray, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    CurveArray profile,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    profile As CurveArray, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, Level, Boolean)

[image]

Revit 2013 API
Document..::..NewWall Method (Curve, Level, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve1(Autodesk.Revit.DB.Document document, Level level)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Create a wall using the location line
    return Wall.Create(document, geomLine, level.Id, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve1(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Create a wall using the location line
    Return document.Create.NewWall(geomLine, level, True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean)

[image]

Revit 2013 API
Document..::..NewWall Method (CurveArray, WallType, Level, Boolean)
Document Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2013 API
Document..::..NewWall Method (CurveArray, WallType, Level, Boolean, XYZ)
Document Class Example See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingProfile(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a wall profile for the wall creation
    XYZ first = new XYZ(0, 0, 0);
    XYZ second = new XYZ(20, 0, 0);
    XYZ third = new XYZ(20, 0, 15);
    XYZ fourth = new XYZ(0, 0, 15);
    IList<Curve> profile = new List<Curve>();

    // Get application creation object
    Autodesk.Revit.Creation.Application appCreation = document.Application.Create;

    profile.Add(appCreation.NewLineBound(first, second));
    profile.Add(appCreation.NewLineBound(second, third));
    profile.Add(appCreation.NewLineBound(third, fourth));
    profile.Add(appCreation.NewLineBound(fourth, first));

    XYZ normal = new XYZ(0, 1, 0);

    // Create a wall
    return Wall.Create(document, profile, wallType.Id, level.Id, true, normal);
}
CopyVB.NET
Public Function CreateWallUsingProfile(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal wallType As WallType) As Wall
    ' Build a wall profile for the wall creation
    Dim first As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim second As New Autodesk.Revit.DB.XYZ(20, 0, 0)
    Dim third As New Autodesk.Revit.DB.XYZ(20, 0, 15)
    Dim fourth As New Autodesk.Revit.DB.XYZ(0, 0, 15)
    Dim profile As New CurveArray()

    ' Get application creation object
    Dim appCreation As Autodesk.Revit.Creation.Application = document.Application.Create

    profile.Append(appCreation.NewLineBound(first, second))
    profile.Append(appCreation.NewLineBound(second, third))
    profile.Append(appCreation.NewLineBound(third, fourth))
    profile.Append(appCreation.NewLineBound(fourth, first))

    Dim normal As New Autodesk.Revit.DB.XYZ(0, 1, 0)

    ' Create a wall
    Return document.Create.NewWall(profile, wallType, level, True, normal)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2013 API
Document..::..NewWall Method (Curve, WallType, Level, Double, Double, Boolean, Boolean)
Document Class Example See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public Wall NewWall(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")> _
Public Function NewWall ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Please call a static creation method of Wall class instead.")]
public:
Wall^ NewWall(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall other than the default height.
offset
Type: System..::..Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
public Wall CreateWallUsingCurve2(Autodesk.Revit.DB.Document document, Level level, WallType wallType)
{
    // Build a location line for the wall creation
    XYZ start = new XYZ(0, 0, 0);
    XYZ end = new XYZ(10, 10, 0);
    Line geomLine = document.Application.Create.NewLineBound(start, end);

    // Determine the other parameters
    double height = 15;
    double offset = 3;

    // Create a wall using the location line and wall type
    return Wall.Create(document, geomLine, wallType.Id, level.Id, height, offset, true, true);
}
CopyVB.NET
Public Function CreateWallUsingCurve2(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level, ByVal wallType As WallType) As Wall
    ' Build a location line for the wall creation
    Dim start As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim [end] As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim geomLine As Line = document.Application.Create.NewLineBound(start, [end])

    ' Determine the other parameters
    Dim height As Double = 15
    Dim offset As Double = 3

    ' Create a wall using the location line and wall type
    Return document.Create.NewWall(geomLine, wallType, level, height, offset, True, _
     True)
End Function

See Also

Document Class
NewWall Overload
Autodesk.Revit.Creation Namespace


NewWalls Method

[image] [image]

Revit 2013 API
Document..::..NewWalls Method
Document Class See Also Send Feedback
Creates walls within the project.

Overload List

 | Name | Description
Public method | NewWalls(List<(Of <<'(ProfiledWallCreationData>)>>)) | Obsolete. Creates profile walls within the project.
Public method | NewWalls(List<(Of <<'(RectangularWallCreationData>)>>)) | Obsolete. Creates rectangular walls within the project.

See Also

Document Class
Document Members
Autodesk.Revit.Creation Namespace


NewWalls Method (List(ProfiledWallCreationData))

[image]

Revit 2013 API
Document..::..NewWalls Method (List<(Of <(<'ProfiledWallCreationData>)>)>)
Document Class See Also Send Feedback
Creates profile walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewWalls(
    List<ProfiledWallCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewWalls ( _
    dataList As List(Of ProfiledWallCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewWalls(
    List<ProfiledWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'ProfiledWallCreationData>)>)>
A list of ProfiledWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If ProfiledWallCreationData's profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWalls Method (List(RectangularWallCreationData))

[image]

Revit 2013 API
Document..::..NewWalls Method (List<(Of <(<'RectangularWallCreationData>)>)>)
Document Class See Also Send Feedback
Creates rectangular walls within the project.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewWalls(
    List<RectangularWallCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewWalls ( _
    dataList As List(Of RectangularWallCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call a static creation method of Wall class instead.  Create each wall in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewWalls(
    List<RectangularWallCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'RectangularWallCreationData>)>)>
A list of RectangularWallCreationData which wraps the creation arguments of the walls to be created.

Return Value

If the creation is successful an ElementSet which contains the walls should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Either of 'curve', 'wallType', 'level' or 'height' is less than 0, or the 'curve' is not horizontal, or the neither of the curve's type is CURVE_TYPE_LINE or CURVE_TYPE_ARC.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

Document Class
NewWalls Overload
Autodesk.Revit.Creation Namespace


NewWire Method

[image]

Revit 2013 API
Document..::..NewWire Method
Document Class See Also Send Feedback
Creates a new wire element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Wire NewWire(
    Curve curve,
    View view,
    Connector startConnector,
    Connector endConnector,
    WireType wireType,
    WiringType wiringType
)
Visual Basic
Public Function NewWire ( _
    curve As Curve, _
    view As View, _
    startConnector As Connector, _
    endConnector As Connector, _
    wireType As WireType, _
    wiringType As WiringType _
) As Wire
Visual C++
public:
Wire^ NewWire(
    Curve^ curve,
    View^ view,
    Connector^ startConnector,
    Connector^ endConnector,
    WireType^ wireType,
    WiringType wiringType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The base line of the wire.
view
Type: Autodesk.Revit.DB..::..View
The view in which the wire is to be visible.
startConnector
Type: Autodesk.Revit.DB..::..Connector
The connector which connects with the start point connector of wire, if it is nullNothingnullptra null reference (Nothing in Visual Basic), the start point connects with nothing.
endConnector
Type: Autodesk.Revit.DB..::..Connector
The connector which connects with the end point connector of wire, if it is nullNothingnullptra null reference (Nothing in Visual Basic), the end point connects with nothing.
wireType
Type: Autodesk.Revit.DB.Electrical..::..WireType
Specify wire type of new created wire.
wiringType
Type: Autodesk.Revit.DB.Electrical..::..WiringType
Specify wiring type(Arc or chamfer) of new created wire.

Return Value

If successful a new wire element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | An InvalidOperationException will to be thrown when Revit MEP product is unavailable.

See Also

Document Class
Autodesk.Revit.Creation Namespace


NewZone Method

[image]

Revit 2013 API
Document..::..NewZone Method
Document Class See Also Send Feedback
Creates a new Zone element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Zone NewZone(
    Level level,
    Phase phase
)
Visual Basic
Public Function NewZone ( _
    level As Level, _
    phase As Phase _
) As Zone
Visual C++
public:
Zone^ NewZone(
    Level^ level,
    Phase^ phase
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level on which the Zone is to exist.
phase
Type: Autodesk.Revit.DB..::..Phase
The associative phase on which the Zone is to exist.

Return Value

If successful a new Zone element within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the electrical system cannot be created by these input phase and level.

See Also

Document Class
Autodesk.Revit.Creation Namespace


Document Properties

[image] [image]

Revit 2013 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Document Class
Autodesk.Revit.Creation Namespace


eRefFace Enumeration

[image]

Revit 2013 API
eRefFace Enumeration
See Also Send Feedback
Indicates the reference face. The Opening will be created at the direction perpendicular to the reference face.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum eRefFace
Visual Basic
Public Enumeration eRefFace
Visual C++
public enum class eRefFace

Members

Member name | Description
CenterX | The reference face is at the middle of the element in the direction of x-axis and its normal is parallel to x-axis.
CenterY | The reference face is at the middle of the element in the direction of y-axis and its normal is parallel to y-axis.
CenterZ | The reference face is at the middle of the element in the direction of z-axis and its normal is parallel to z-axis.

Remarks

Direction of the opening.

See Also

Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Class

[image]

Revit 2013 API
FamilyInstanceCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of FamilyInstance for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyInstanceCreationData
Visual Basic
Public Class FamilyInstanceCreationData
Visual C++
public ref class FamilyInstanceCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..FamilyInstanceCreationData

See Also

FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Members

[image] [image]

Revit 2013 API
FamilyInstanceCreationData Members
FamilyInstanceCreationData Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor

[image] [image]

Revit 2013 API
FamilyInstanceCreationData Constructor
FamilyInstanceCreationData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FamilyInstanceCreationData(Face, Line, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Curve, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(Face, XYZ, XYZ, FamilySymbol) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, Element, Level, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class
Public method | FamilyInstanceCreationData(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Initializes a new instance of the FamilyInstanceCreationData class

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Members
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (Face, Line, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Sub New ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
Specify if the family instance is structural.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (Curve, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Curve curve,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    Curve^ curve,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve where the instance is based.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (Face, XYZ, XYZ, FamilySymbol)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Sub New ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
)
Visual C++
public:
FamilyInstanceCreationData(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, Element, Level, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    Level level,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    level As Level, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    Level^ level,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
level
Type: Autodesk.Revit.DB..::..Level
A Level object that is used as the base level for the object.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2013 API
FamilyInstanceCreationData Constructor (XYZ, FamilySymbol, XYZ, Element, StructuralType)
FamilyInstanceCreationData Class See Also Send Feedback
Initializes a new instance of the FamilyInstanceCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstanceCreationData(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
)
Visual C++
public:
FamilyInstanceCreationData(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

See Also

FamilyInstanceCreationData Class
FamilyInstanceCreationData Overload
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Methods

[image] [image]

Revit 2013 API
FamilyInstanceCreationData Methods
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyInstanceCreationData Properties

[image] [image]

Revit 2013 API
FamilyInstanceCreationData Properties
FamilyInstanceCreationData Class See Also Send Feedback

The FamilyInstanceCreationData type exposes the following members.

Properties

 | Name | Description
Public property | Axis | Get or set the axis of the FamilyInstance
Public property | RotateAngle | Get or set the rotate angle of the FamilyInstance

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


Axis Property

[image]

Revit 2013 API
FamilyInstanceCreationData..::..Axis Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the axis of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Line Axis { get; set; }
Visual Basic
Public Property Axis As Line
    Get
    Set
Visual C++
public:
property Line^ Axis {
    Line^ get ();
    void set (Line^ value);
}

Remarks

The element property will be the axis while performing the rotation.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


RotateAngle Property

[image]

Revit 2013 API
FamilyInstanceCreationData..::..RotateAngle Property
FamilyInstanceCreationData Class See Also Send Feedback
Get or set the rotate angle of the FamilyInstance

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double RotateAngle { get; set; }
Visual Basic
Public Property RotateAngle As Double
    Get
    Set
Visual C++
public:
property double RotateAngle {
    double get ();
    void set (double value);
}

Remarks

The FamilyInstance will rotate this angle when the instance is created.

See Also

FamilyInstanceCreationData Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Class

[image]

Revit 2013 API
FamilyItemFactory Class
Members See Also Send Feedback
The Family Item Factory object is used to create new instances of elements within the Autodesk Revit Family.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyItemFactory : ItemFactoryBase
Visual Basic
Public Class FamilyItemFactory _
    Inherits ItemFactoryBase
Visual C++
public ref class FamilyItemFactory : public ItemFactoryBase

Remarks

The Family Item Factory object is a utility object that is used to create new instances of elements within the Autodesk Revit Family Document. This object should be used to create elements instead of using New. This object ensures that the elements created are added to the family document correctly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..FamilyItemFactory

See Also

FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Members

[image] [image]

Revit 2013 API
FamilyItemFactory Members
FamilyItemFactory Class Methods Properties See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDividedSurface | Create a DividedSurface element on one surface of another element.
Public method | NewDuctConnector | Obsolete. Add a new duct connector into the Autodesk Revit family document.
Public method | NewElectricalConnector | Obsolete. Add a new Electrical connector into the Autodesk Revit family document.
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewPipeConnector | Obsolete. Add a new pipe connector into the Autodesk Revit family document.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
Public method | NewView3D | Obsolete. Creates a new 3D view. (Inherited from ItemFactoryBase.)
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
Public method | NewViewSection | Obsolete. Creates a new section view. (Inherited from ItemFactoryBase.)
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


FamilyItemFactory Methods

[image] [image]

Revit 2013 API
FamilyItemFactory Methods
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document. (Inherited from ItemFactoryBase.)
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.
Public method | NewBlend | Add a new Blend instance into the Autodesk Revit family document.
Public method | NewControl | Add a new control into the Autodesk Revit family document.
Public method | NewCurveByPoints | Create a 3d curve through two or more points in an Autodesk Revit family document.
Public method | NewDetailCurve | Creates a new detail curve element. (Inherited from ItemFactoryBase.)
Public method | NewDetailCurveArray | Creates an array of new detail curve elements. (Inherited from ItemFactoryBase.)
Public method | NewDiameterDimension | Creates a new diameter dimension object using the default dimension type.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDividedSurface | Create a DividedSurface element on one surface of another element.
Public method | NewDuctConnector | Obsolete. Add a new duct connector into the Autodesk Revit family document.
Public method | NewElectricalConnector | Obsolete. Add a new Electrical connector into the Autodesk Revit family document.
Public method | NewExtrusion | Add a new Extrusion instance into the Autodesk Revit family document.
Public method | NewExtrusionForm | Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstances2 | Creates Family instances within the document. (Inherited from ItemFactoryBase.)
Public method | NewFormByCap | Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.
Public method | NewFormByThickenSingleSurface | Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewLevel | Creates a new level. (Inherited from ItemFactoryBase.)
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.
Public method | NewLoftForm | Create new Form element by Loft operation, and add it into the Autodesk Revit family document.
Public method | NewModelCurve | Creates a new model line element. (Inherited from ItemFactoryBase.)
Public method | NewModelCurveArray | Creates an array of new model line elements. (Inherited from ItemFactoryBase.)
Public method | NewModelText | Create a model text in the Autodesk Revit family document.
Public method | NewOpening | Create an opening to cut the wall or ceiling.
Public method | NewPipeConnector | Obsolete. Add a new pipe connector into the Autodesk Revit family document.
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane. (Inherited from ItemFactoryBase.)
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.
Public method | NewRevolution | Add a new Revolution instance into the Autodesk Revit family document.
Public method | NewRevolveForms | Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.
Public method | NewSweptBlendForm | Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.
Public method | NewSymbolicCurve | Create a symbolic curve in an Autodesk Revit family document.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data. (Inherited from ItemFactoryBase.)
Public method | NewView3D | Obsolete. Creates a new 3D view. (Inherited from ItemFactoryBase.)
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level. (Inherited from ItemFactoryBase.)
Public method | NewViewSection | Obsolete. Creates a new section view. (Inherited from ItemFactoryBase.)
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type. (Inherited from ItemFactoryBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewAngularDimension Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewAngularDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object.

Overload List

 | Name | Description
Public method | NewAngularDimension(View, Arc, Reference, Reference) | Creates a new angular dimension object using the default dimension type.
Public method | NewAngularDimension(View, Arc, Reference, Reference, DimensionType) | Creates a new angular dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference)

[image]

Revit 2013 API
FamilyItemFactory..::..NewAngularDimension Method (View, Arc, Reference, Reference)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef
)
Visual Basic
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)

[image]

Revit 2013 API
FamilyItemFactory..::..NewAngularDimension Method (View, Arc, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new angular dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewAngularDimension(
    View view,
    Arc arc,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic
Public Function NewAngularDimension ( _
    view As View, _
    arc As Arc, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewAngularDimension(
    View^ view,
    Arc^ arc,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. The reference must be perpendicular to the extension arc.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new angular dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument firstRef/secondRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewAngularDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewArcLengthDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object.

Overload List

 | Name | Description
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference) | Creates a new arc length dimension object using the default dimension type.
Public method | NewArcLengthDimension(View, Arc, Reference, Reference, Reference, DimensionType) | Creates a new arc length dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)

[image]

Revit 2013 API
FamilyItemFactory..::..NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference)
FamilyItemFactory Class Example See Also Send Feedback
Creates a new arc length dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef
)
Visual Basic
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateArcDimension(Document document, SketchPlane sketchPlane)
{
    Autodesk.Revit.Creation.Application appCreate = document.Application.Create;
    Line gLine1 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 2, 0), true);
    Line gLine2 = appCreate.NewLine(new XYZ(0, 2, 0), new XYZ(2, 4, 0), true);
    Arc arctoDim = appCreate.NewArc(new XYZ(1, 2, 0), new XYZ(-1, 2, 0), new XYZ(0, 3, 0));
    Arc arcofDim = appCreate.NewArc(new XYZ(0, 3, 0), new XYZ(1, 2, 0), new XYZ(0.8, 2.8, 0));

    Autodesk.Revit.Creation.FamilyItemFactory creationFamily = document.FamilyCreate;
    ModelCurve modelCurve1 = creationFamily.NewModelCurve(gLine1, sketchPlane);
    ModelCurve modelCurve2 = creationFamily.NewModelCurve(gLine2, sketchPlane);
    ModelCurve modelCurve3 = creationFamily.NewModelCurve(arctoDim, sketchPlane);
    //get their reference
    Reference ref1 = modelCurve1.GeometryCurve.Reference;
    Reference ref2 = modelCurve2.GeometryCurve.Reference;
    Reference arcRef = modelCurve3.GeometryCurve.Reference;

    Dimension newArcDim = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2);
    if (newArcDim == null)
    {
        throw new Exception("Failed to create new arc length dimension.");
    }

    return newArcDim;
}
CopyVB.NET
Public Function CreateArcDimension(ByVal document As Document, ByVal sketchPlane As SketchPlane) As Dimension
    Dim appCreate As Autodesk.Revit.Creation.Application = document.Application.Create
    Dim gLine1 As Line = appCreate.NewLine(New Autodesk.Revit.DB.XYZ(0, 2, 0), New Autodesk.Revit.DB.XYZ(2, 2, 0), True)
    Dim gLine2 As Line = appCreate.NewLine(New Autodesk.Revit.DB.XYZ(0, 2, 0), New Autodesk.Revit.DB.XYZ(2, 4, 0), True)
    Dim arctoDim As Arc = appCreate.NewArc(New Autodesk.Revit.DB.XYZ(1, 2, 0), New Autodesk.Revit.DB.XYZ(-1, 2, 0), New Autodesk.Revit.DB.XYZ(0, 3, 0))
    Dim arcofDim As Arc = appCreate.NewArc(New Autodesk.Revit.DB.XYZ(0, 3, 0), New Autodesk.Revit.DB.XYZ(1, 2, 0), New Autodesk.Revit.DB.XYZ(0.8, 2.8, 0))

    Dim creationFamily As Autodesk.Revit.Creation.FamilyItemFactory = document.FamilyCreate
    Dim modelCurve1 As ModelCurve = creationFamily.NewModelCurve(gLine1, sketchPlane)
    Dim modelCurve2 As ModelCurve = creationFamily.NewModelCurve(gLine2, sketchPlane)
    Dim modelCurve3 As ModelCurve = creationFamily.NewModelCurve(arctoDim, sketchPlane)
    'get their reference
    Dim ref1 As Reference = modelCurve1.GeometryCurve.Reference
    Dim ref2 As Reference = modelCurve2.GeometryCurve.Reference
    Dim arcRef As Reference = modelCurve3.GeometryCurve.Reference

    Dim newArcDim As Dimension = creationFamily.NewArcLengthDimension(document.ActiveView, arcofDim, arcRef, ref1, ref2)
    If newArcDim Is Nothing Then
        Throw New Exception("Failed to create new arc length dimension.")
    End If

    Return newArcDim
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/ref1/ref2 is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)

[image]

Revit 2013 API
FamilyItemFactory..::..NewArcLengthDimension Method (View, Arc, Reference, Reference, Reference, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new arc length dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewArcLengthDimension(
    View view,
    Arc arc,
    Reference arcRef,
    Reference firstRef,
    Reference secondRef,
    DimensionType dimensionType
)
Visual Basic
Public Function NewArcLengthDimension ( _
    view As View, _
    arc As Arc, _
    arcRef As Reference, _
    firstRef As Reference, _
    secondRef As Reference, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewArcLengthDimension(
    View^ view,
    Arc^ arc,
    Reference^ arcRef,
    Reference^ firstRef,
    Reference^ secondRef,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arc
Type: Autodesk.Revit.DB..::..Arc
The extension arc of the dimension.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound. This reference must be parallel to the extension arc.
firstRef
Type: Autodesk.Revit.DB..::..Reference
The first geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
secondRef
Type: Autodesk.Revit.DB..::..Reference
The second geometric reference to which the dimension is to be bound. This reference must intersect the arcRef reference.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/ref1/ref2/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewArcLengthDimension Overload
Autodesk.Revit.Creation Namespace


NewBlend Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewBlend Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Blend instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Blend NewBlend(
    bool isSolid,
    CurveArray topProfile,
    CurveArray baseProfile,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewBlend ( _
    isSolid As Boolean, _
    topProfile As CurveArray, _
    baseProfile As CurveArray, _
    sketchPlane As SketchPlane _
) As Blend
Visual C++
public:
Blend^ NewBlend(
    bool isSolid,
    CurveArray^ topProfile,
    CurveArray^ baseProfile,
    SketchPlane^ sketchPlane
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Blend is Solid or Void.
topProfile
Type: Autodesk.Revit.DB..::..CurveArray
The top blend section. It should consist of only one curve loop. The input profile must be in one plane.
baseProfile
Type: Autodesk.Revit.DB..::..CurveArray
The base blend section. It should consist of only one curve loop. The input profile must be in one plane.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the base profile. Use this to associate the base of the blend to geometry from another element. Optional, it can be nullNothingnullptra null reference (Nothing in Visual Basic) if you want Revit to derive a new sketch plane from the geometry of the base profile.

Return Value

If creation was successful the new blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a blend in a family document. The blend will be extended between the two independent pieces of geometry. Revit will determine an appropriate default mapping for the vertices of the two profiles. The two input profiles must be parallel. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the blend.

Examples

CopyC#
private Blend CreateBlend(UIApplication application, SketchPlane sketchPlane)
{
    Blend blend = null;

    // make sure we have a family document
    Document familyDocument = application.ActiveUIDocument.Document;
    if (true == familyDocument.IsFamilyDocument)
    {
        // Define top and base profiles for the blend
        CurveArray topProfile = new CurveArray();
        CurveArray baseProfile = new CurveArray();

        // create rectangular base profile
        XYZ p00 = XYZ.Zero;
        XYZ p01 = new XYZ(10, 0, 0);
        XYZ p02 = new XYZ(10, 10, 0);
        XYZ p03 = new XYZ(0, 10, 0);
        Line line01 = application.Application.Create.NewLineBound(p00, p01);
        Line line02 = application.Application.Create.NewLineBound(p01, p02);
        Line line03 = application.Application.Create.NewLineBound(p02, p03);
        Line line04 = application.Application.Create.NewLineBound(p03, p00);

        baseProfile.Append(line01);
        baseProfile.Append(line02);
        baseProfile.Append(line03);
        baseProfile.Append(line04);

        // create rectangular top profile
        XYZ p10 = new XYZ(5, 2, 10);
        XYZ p11 = new XYZ(8, 5, 10);
        XYZ p12 = new XYZ(5, 8, 10);
        XYZ p13 = new XYZ(2, 5, 10);
        Line line11 = application.Application.Create.NewLineBound(p10, p11);
        Line line12 = application.Application.Create.NewLineBound(p11, p12);
        Line line13 = application.Application.Create.NewLineBound(p12, p13);
        Line line14 = application.Application.Create.NewLineBound(p13, p10);

        topProfile.Append(line11);
        topProfile.Append(line12);
        topProfile.Append(line13);
        topProfile.Append(line14);

        // now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(true, topProfile, baseProfile, sketchPlane);

        if (null != blend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 11, 0);
            ElementTransformUtils.MoveElement(familyDocument, blend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Blend failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return blend;
}
CopyVB.NET
Private Function CreateBlend(ByVal application As UIApplication, ByVal sketchPlane As SketchPlane) As Blend
    Dim blend As Blend = Nothing

    ' make sure we have a family document
    Dim familyDocument As Document = application.ActiveUIDocument.Document
    If True = familyDocument.IsFamilyDocument Then
        ' Define top and base profiles for the blend
        Dim topProfile As New CurveArray()
        Dim baseProfile As New CurveArray()

        ' create rectangular base profile
        Dim p00 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p01 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p02 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p03 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line01 As Line = application.Application.Create.NewLineBound(p00, p01)
        Dim line02 As Line = application.Application.Create.NewLineBound(p01, p02)
        Dim line03 As Line = application.Application.Create.NewLineBound(p02, p03)
        Dim line04 As Line = application.Application.Create.NewLineBound(p03, p00)

        baseProfile.Append(line01)
        baseProfile.Append(line02)
        baseProfile.Append(line03)
        baseProfile.Append(line04)

        ' create rectangular top profile
        Dim p10 As New Autodesk.Revit.DB.XYZ(5, 2, 10)
        Dim p11 As New Autodesk.Revit.DB.XYZ(8, 5, 10)
        Dim p12 As New Autodesk.Revit.DB.XYZ(5, 8, 10)
        Dim p13 As New Autodesk.Revit.DB.XYZ(2, 5, 10)
        Dim line11 As Line = application.Application.Create.NewLineBound(p10, p11)
        Dim line12 As Line = application.Application.Create.NewLineBound(p11, p12)
        Dim line13 As Line = application.Application.Create.NewLineBound(p12, p13)
        Dim line14 As Line = application.Application.Create.NewLineBound(p13, p10)

        topProfile.Append(line11)
        topProfile.Append(line12)
        topProfile.Append(line13)
        topProfile.Append(line14)

        ' now create solid rectangular blend
        blend = familyDocument.FamilyCreate.NewBlend(True, topProfile, baseProfile, sketchPlane)

        If blend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(0, 11, 0)
            familyDocument.Move(blend, transPoint1)
        Else
            Throw New Exception("Create new Blend failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return blend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where blends cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewControl Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewControl Method
FamilyItemFactory Class See Also Send Feedback
Add a new control into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Control NewControl(
    ControlShape controlShape,
    View view,
    XYZ origin
)
Visual Basic
Public Function NewControl ( _
    controlShape As ControlShape, _
    view As View, _
    origin As XYZ _
) As Control
Visual C++
public:
Control^ NewControl(
    ControlShape controlShape,
    View^ view,
    XYZ^ origin
)

Parameters

controlShape
Type: Autodesk.Revit.DB..::..ControlShape
The shape of the control.
view
Type: Autodesk.Revit.DB..::..View
The view in which the control is to be visible. It must be a FloorPlan view or a CeilingPlan view.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the control.

Return Value

If successful, the newly created control is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"view" or "position"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"view"-is invalid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"controlType"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when control creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewCurveByPoints Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewCurveByPoints Method
FamilyItemFactory Class Example See Also Send Feedback
Create a 3d curve through two or more points in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveByPoints NewCurveByPoints(
    ReferencePointArray points
)
Visual Basic
Public Function NewCurveByPoints ( _
    points As ReferencePointArray _
) As CurveByPoints
Visual C++
public:
CurveByPoints^ NewCurveByPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::..ReferencePointArray
Two or more PointElements. The curve will interpolate these points.

Return Value

The newly created curve.

Examples

CopyC#
ReferencePointArray rpa = new ReferencePointArray();

XYZ xyz = document.Application.Create.NewXYZ(0, 0, 0);
ReferencePoint rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 30, 10);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 60, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 100, 30);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

xyz = document.Application.Create.NewXYZ(0, 150, 0);
rp = document.FamilyCreate.NewReferencePoint(xyz);
rpa.Append(rp);

curve = document.FamilyCreate.NewCurveByPoints(rpa);
CopyVB.NET
Dim rpa As New ReferencePointArray()

Dim xyz As Autodesk.Revit.DB.XYZ = document.Application.Create.NewXYZ(0, 0, 0)
Dim rp As ReferencePoint = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 30, 10)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 60, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 100, 30)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

xyz = document.Application.Create.NewXYZ(0, 150, 0)
rp = document.FamilyCreate.NewReferencePoint(xyz)
rpa.Append(rp)

curve = document.FamilyCreate.NewCurveByPoints(rpa)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when points is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when points does not contain at least two PointElements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDiameterDimension Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewDiameterDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new diameter dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewDiameterDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic
Public Function NewDiameterDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewDiameterDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the diameter dimension will lie.

Return Value

If creation was successful the new diameter dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style. (Inherited from ItemFactoryBase.)
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewDividedSurface Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewDividedSurface Method
FamilyItemFactory Class Example See Also Send Feedback
Create a DividedSurface element on one surface of another element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurface NewDividedSurface(
    Reference hostReference
)
Visual Basic
Public Function NewDividedSurface ( _
    hostReference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ NewDividedSurface(
    Reference^ hostReference
)

Parameters

hostReference
Type: Autodesk.Revit.DB..::..Reference
Reference to a surface on an existing element. The element must be one of the following: Form, GeomCombination, FamilyInstance, or ImportInstance.

Return Value

The newly created DividedSurface element.

Examples

CopyC#
public void DivideSurface(Document document, Form form)
{
    Autodesk.Revit.ApplicationServices.Application application = document.Application;
    Options opt = application.Create.NewGeometryOptions();
    opt.ComputeReferences = true;

    Autodesk.Revit.DB.GeometryElement geomElem = form.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid solid = geomObj as Solid;
        foreach (Face face in solid.Faces)
        {
            if (face.Reference != null)
            {
                DividedSurface ds = document.FamilyCreate.NewDividedSurface(face.Reference);
                // create a divided surface with fixed number of U and V grid lines
                SpacingRule srU = ds.USpacingRule;
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0);

                SpacingRule srV = ds.VSpacingRule;
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0);

                break;  // just divide one face of form
            }
        }
    }
}
CopyVB.NET
Public Sub DivideSurface(ByVal document As Document, ByVal form As Form)
    Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application
    Dim opt As Autodesk.Revit.DB.Options = application.Create.NewGeometryOptions()
    opt.ComputeReferences = True

    Dim geomElem As Autodesk.Revit.DB.GeometryElement = form.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim solid As Solid = TryCast(geomObj, Solid)
        For Each face As Autodesk.Revit.DB.Face In solid.Faces
            If face.Reference IsNot Nothing Then
                Dim ds As DividedSurface = document.FamilyCreate.NewDividedSurface(face.Reference)
                ' create a divided surface with fixed number of U and V grid lines
                Dim srU As SpacingRule = ds.USpacingRule
                srU.SetLayoutFixedNumber(16, SpacingRuleJustification.Center, 0, 0)

                Dim srV As SpacingRule = ds.VSpacingRule
                srV.SetLayoutFixedNumber(24, SpacingRuleJustification.Center, 0, 0)

                ' just divide one face of form
                Exit For
            End If
        Next
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when surface is not a reference to a surface, or when the referenced element does not support divided surfaces.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewDuctConnector Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewDuctConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new duct connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateDuctConnector() instead")]
public DuctConnector NewDuctConnector(
    Reference planarFaceReference,
    DuctSystemType systemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateDuctConnector() instead")> _
Public Function NewDuctConnector ( _
    planarFaceReference As Reference, _
    systemType As DuctSystemType _
) As DuctConnector
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateDuctConnector() instead")]
public:
DuctConnector^ NewDuctConnector(
    Reference^ planarFaceReference,
    DuctSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Mechanical..::..DuctSystemType
Indicates the system type of this new duct connector.

Return Value

If creation was successful the new Duct Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a duct connector in a family document. The duct connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewElectricalConnector Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewElectricalConnector Method
FamilyItemFactory Class See Also Send Feedback
Add a new Electrical connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateElectricalConnector() instead")]
public ElectricalConnector NewElectricalConnector(
    Reference planarFaceReference,
    ElectricalSystemType systemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateElectricalConnector() instead")> _
Public Function NewElectricalConnector ( _
    planarFaceReference As Reference, _
    systemType As ElectricalSystemType _
) As ElectricalConnector
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call ConnectorElement::CreateElectricalConnector() instead")]
public:
ElectricalConnector^ NewElectricalConnector(
    Reference^ planarFaceReference,
    ElectricalSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
Indicates the system type of this new Electrical connector.

Return Value

If creation was successful the new Electrical Connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Electrical Connector in a family document. The electrical connector will be placed at the centroid of the planar face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusion Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewExtrusion Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Extrusion instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Extrusion NewExtrusion(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    double end
)
Visual Basic
Public Function NewExtrusion ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    end As Double _
) As Extrusion
Visual C++
public:
Extrusion^ NewExtrusion(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    double end
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Extrusion is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..CurveArrArray
The profile of the newly created Extrusion. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. All input curves must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the extrusion. The direction of extrusion is determined by the normal for the sketch plane. To extrude in the other direction set the end value to negative.
end
Type: System..::..Double
The length of the extrusion.

Return Value

If creation was successful the new Extrusion is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an extrusion in a family document. The extrusion will be extended perpendicular to the sketch plane of the extrusion profile.

Examples

CopyC#
private Extrusion CreateExtrusion(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Extrusion rectExtrusion = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // define the profile for the extrusion
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray1 = new CurveArray();
        CurveArray curveArray2 = new CurveArray();
        CurveArray curveArray3 = new CurveArray();

        // create a rectangular profile
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);
        curveArray1.Append(line1);
        curveArray1.Append(line2);
        curveArray1.Append(line3);
        curveArray1.Append(line4);

        curveArrArray.Append(curveArray1);

        // create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(true, curveArrArray, sketchPlane, 10);

        if (null != rectExtrusion)
        {
            // move extrusion to proper place
            XYZ transPoint1 = new XYZ(-16, 0, 0);
            ElementTransformUtils.MoveElement(document, rectExtrusion.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create new Extrusion failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return rectExtrusion;
}
CopyVB.NET
Private Function CreateExtrusion(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Extrusion
    Dim rectExtrusion As Extrusion = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' define the profile for the extrusion
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray1 As New CurveArray()
        Dim curveArray2 As New CurveArray()
        Dim curveArray3 As New CurveArray()

        ' create a rectangular profile
        Dim p0 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p1 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)
        curveArray1.Append(line1)
        curveArray1.Append(line2)
        curveArray1.Append(line3)
        curveArray1.Append(line4)

        curveArrArray.Append(curveArray1)

        ' create solid rectangular extrusion
        rectExtrusion = document.FamilyCreate.NewExtrusion(True, curveArrArray, sketchPlane, 10)

        If rectExtrusion IsNot Nothing Then
            ' move extrusion to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(-16, 0, 0)
            document.Move(rectExtrusion, transPoint1)
        Else
            Throw New Exception("Create new Extrusion failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return rectExtrusion
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty array.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-sketchPlane-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewExtrusionForm Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewExtrusionForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Extrude operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Form NewExtrusionForm(
    bool isSolid,
    ReferenceArray profile,
    XYZ direction
)
Visual Basic
Public Function NewExtrusionForm ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    direction As XYZ _
) As Form
Visual C++
public:
Form^ NewExtrusionForm(
    bool isSolid,
    ReferenceArray^ profile,
    XYZ^ direction
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of extrusion. It should consist of only one curve loop. The input profile must be in one plane.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of extrusion, with its length the length of the extrusion. The direction must be perpendicular to the plane determined by profile. The length of vector must be non-zero.

Return Value

If creation was successful new form is returned.

Examples

CopyC#
private Form CreateExtrusionForm(Autodesk.Revit.DB.Document document)
{
    Form extrusionForm = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(10, 10, 0);
    XYZ ptB = new XYZ(90, 10, 0);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(90, 10, 0);
    ptB = new XYZ(10, 90, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(10, 90, 0);
    ptB = new XYZ(10, 10, 0);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // The extrusion form direction
    XYZ direction = new XYZ(0, 0, 50);

    extrusionForm = document.FamilyCreate.NewExtrusionForm(true, ref_ar, direction);

    int profileCount = extrusionForm.ProfileCount;

    return extrusionForm;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = app.Create.NewLine(ptA, ptB, true);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = app.Create.NewPlane(norm, ptB);
    SketchPlane skplane = doc.FamilyCreate.NewSketchPlane(plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateExtrusionForm(ByVal document As Autodesk.Revit.DB.Document) As Form
    Dim extrusionForm As Form = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New Autodesk.Revit.DB.XYZ(10, 10, 0)
    Dim ptB As New Autodesk.Revit.DB.XYZ(90, 10, 0)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(90, 10, 0)
    ptB = New Autodesk.Revit.DB.XYZ(10, 90, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(10, 90, 0)
    ptB = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' The extrusion form direction
    Dim direction As New Autodesk.Revit.DB.XYZ(0, 0, 50)

    extrusionForm = document.FamilyCreate.NewExtrusionForm(True, ref_ar, direction)

    Dim profileCount As Integer = extrusionForm.ProfileCount

    Return extrusionForm
End Function

Public Function MakeLine(ByVal doc As Document, ByVal ptA As Autodesk.Revit.DB.XYZ, ByVal ptB As Autodesk.Revit.DB.XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line As Line = app.Create.NewLine(ptA, ptB, True)
    Dim norm As Autodesk.Revit.DB.XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = Autodesk.Revit.DB.XYZ.BasisZ
    End If
    Dim plane As Plane = app.Create.NewPlane(norm, ptB)
    Dim skplane As SketchPlane = doc.FamilyCreate.NewSketchPlane(plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line, skplane)
    Return modelcurve
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where extrusions cannot be created.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewFamilyInstance Method
FamilyItemFactory Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element. (Inherited from ItemFactoryBase.)
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewFormByCap Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewFormByCap Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by cap operation (to create a single-surface form), and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Form NewFormByCap(
    bool isSolid,
    ReferenceArray profile
)
Visual Basic
Public Function NewFormByCap ( _
    isSolid As Boolean, _
    profile As ReferenceArray _
) As Form
Visual C++
public:
Form^ NewFormByCap(
    bool isSolid,
    ReferenceArray^ profile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of the newly created cap. It should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewFormByThickenSingleSurface Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewFormByThickenSingleSurface Method
FamilyItemFactory Class See Also Send Feedback
Create a new Form element by thickening a single-surface form, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Form NewFormByThickenSingleSurface(
    bool isSolid,
    Form singleSurfaceForm,
    XYZ thickenDir
)
Visual Basic
Public Function NewFormByThickenSingleSurface ( _
    isSolid As Boolean, _
    singleSurfaceForm As Form, _
    thickenDir As XYZ _
) As Form
Visual C++
public:
Form^ NewFormByThickenSingleSurface(
    bool isSolid,
    Form^ singleSurfaceForm,
    XYZ^ thickenDir
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
singleSurfaceForm
Type: Autodesk.Revit.DB..::..Form
The single-surface form element. It can have one top/bottom face or one side face.
thickenDir
Type: Autodesk.Revit.DB..::..XYZ
The offset of capped solid.

Return Value

This function will modify the input singleSurfaceForm and return the same element.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewGroup Method
FamilyItemFactory Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group. (Inherited from ItemFactoryBase.)
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewLinearDimension Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewLinearDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewLinearDimension(View, Line, ReferenceArray) | Generate a new linear dimension object using the default dimension type.
Public method | NewLinearDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray)

[image]

Revit 2013 API
FamilyItemFactory..::..NewLinearDimension Method (View, Line, ReferenceArray)
FamilyItemFactory Class Example See Also Send Feedback
Generate a new linear dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::..Line
The extension line of the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
public Dimension CreateLinearDimension(Document document)
{
    // first create two lines
    XYZ pt1 = new XYZ(5, 5, 0);
    XYZ pt2 = new XYZ(5, 10, 0);
    Line line = document.Application.Create.NewLine(pt1, pt2, true);
    Plane plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2);
    SketchPlane skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve1 = document.FamilyCreate.NewModelCurve(line, skplane);

    pt1 = new XYZ(10, 5, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);
    plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2);
    skplane = document.FamilyCreate.NewSketchPlane(plane);
    ModelCurve modelcurve2 = document.FamilyCreate.NewModelCurve(line, skplane);

    // now create a linear dimension between them
    ReferenceArray ra = new ReferenceArray();
    ra.Append(modelcurve1.GeometryCurve.Reference);
    ra.Append(modelcurve2.GeometryCurve.Reference);

    pt1 = new XYZ(5, 10, 0);
    pt2 = new XYZ(10, 10, 0);
    line = document.Application.Create.NewLine(pt1, pt2, true);

    Dimension dim = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra);

    // create a label for the dimension called "width"
    FamilyParameter param = document.FamilyManager.AddParameter("width",
        BuiltInParameterGroup.PG_CONSTRAINTS,
        ParameterType.Length, false);

    dim.Label = param;

    return dim;
}
CopyVB.NET
Public Function CreateLinearDimension(ByVal document As Document) As Dimension
    ' first create two lines
    Dim pt1 As New Autodesk.Revit.DB.XYZ(5, 5, 0)
    Dim pt2 As New Autodesk.Revit.DB.XYZ(5, 10, 0)
    Dim line As Line = document.Application.Create.NewLine(pt1, pt2, True)
    Dim plane As Plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2)
    Dim skplane As SketchPlane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve1 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    pt1 = New Autodesk.Revit.DB.XYZ(10, 5, 0)
    pt2 = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)
    plane = document.Application.Create.NewPlane(pt1.CrossProduct(pt2), pt2)
    skplane = document.FamilyCreate.NewSketchPlane(plane)
    Dim modelcurve2 As ModelCurve = document.FamilyCreate.NewModelCurve(line, skplane)

    ' now create a linear dimension between them
    Dim ra As New ReferenceArray()
    ra.Append(modelcurve1.GeometryCurve.Reference)
    ra.Append(modelcurve2.GeometryCurve.Reference)

    pt1 = New Autodesk.Revit.DB.XYZ(5, 10, 0)
    pt2 = New Autodesk.Revit.DB.XYZ(10, 10, 0)
    line = document.Application.Create.NewLine(pt1, pt2, True)

    Dim [dim] As Dimension = document.FamilyCreate.NewLinearDimension(document.ActiveView, line, ra)

    ' create a label for the dimension called "width"
    Dim param As FamilyParameter = document.FamilyManager.AddParameter("width", BuiltInParameterGroup.PG_CONSTRAINTS, ParameterType.Length, False)

    [dim].Label = param

    Return [dim]
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument "references" is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2013 API
FamilyItemFactory..::..NewLinearDimension Method (View, Line, ReferenceArray, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewLinearDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic
Public Function NewLinearDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewLinearDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::..Line
The extension line of the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound. You must supply at least two references, and all references supplied must be parallel to each other and perpendicular to the extension line.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new linear dimension is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewLinearDimension Overload
Autodesk.Revit.Creation Namespace


NewLoftForm Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewLoftForm Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Form NewLoftForm(
    bool isSolid,
    ReferenceArrayArray profiles
)
Visual Basic
Public Function NewLoftForm ( _
    isSolid As Boolean, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewLoftForm(
    bool isSolid,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profiles
Type: Autodesk.Revit.DB..::..ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful form is are returned.

Examples

CopyC#
private Form CreateLoftForm(Autodesk.Revit.DB.Document document)
{
    Form loftForm = null;

    ReferencePointArray rpa = new ReferencePointArray();
    ReferenceArrayArray ref_ar_ar = new ReferenceArrayArray();
    ReferenceArray ref_ar = new ReferenceArray();
    ReferencePoint rp = null;
    XYZ xyz = null;

    // make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 50, 10);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(0, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    CurveByPoints cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 50, 30);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(50, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);
    rpa.Clear();
    ref_ar = new ReferenceArray();

    // make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 50, 5);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    xyz = document.Application.Create.NewXYZ(75, 100, 0);
    rp = document.FamilyCreate.NewReferencePoint(xyz);
    rpa.Append(rp);

    cbp = document.FamilyCreate.NewCurveByPoints(rpa);
    ref_ar.Append(cbp.GeometryCurve.Reference);
    ref_ar_ar.Append(ref_ar);

    loftForm = document.FamilyCreate.NewLoftForm(true, ref_ar_ar);

    return loftForm;
}
CopyVB.NET
Private Function CreateLoftForm(ByVal document As Autodesk.Revit.DB.Document) As Form
    Dim loftForm As Form = Nothing

    Dim rpa As New ReferencePointArray()
    Dim ref_ar_ar As New ReferenceArrayArray()
    Dim ref_ar As New ReferenceArray()
    Dim rp As ReferencePoint = Nothing
    Dim xyz As Autodesk.Revit.DB.XYZ = Nothing

    ' make first profile curve for loft
    xyz = document.Application.Create.NewXYZ(0, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 50, 10)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(0, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    Dim cbp As CurveByPoints = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make second profile curve for loft
    xyz = document.Application.Create.NewXYZ(50, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 50, 30)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(50, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)
    rpa.Clear()
    ref_ar = New ReferenceArray()

    ' make third profile curve for loft
    xyz = document.Application.Create.NewXYZ(75, 0, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 50, 5)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    xyz = document.Application.Create.NewXYZ(75, 100, 0)
    rp = document.FamilyCreate.NewReferencePoint(xyz)
    rpa.Append(rp)

    cbp = document.FamilyCreate.NewCurveByPoints(rpa)
    ref_ar.Append(cbp.GeometryCurve.Reference)
    ref_ar_ar.Append(ref_ar)

    loftForm = document.FamilyCreate.NewLoftForm(True, ref_ar_ar)

    Return loftForm
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewModelText Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewModelText Method
FamilyItemFactory Class See Also Send Feedback
Create a model text in the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelText NewModelText(
    string text,
    ModelTextType modelTextType,
    SketchPlane sketchPlane,
    XYZ position,
    HorizontalAlign horizontalAlign,
    double depth
)
Visual Basic
Public Function NewModelText ( _
    text As String, _
    modelTextType As ModelTextType, _
    sketchPlane As SketchPlane, _
    position As XYZ, _
    horizontalAlign As HorizontalAlign, _
    depth As Double _
) As ModelText
Visual C++
public:
ModelText^ NewModelText(
    String^ text,
    ModelTextType^ modelTextType,
    SketchPlane^ sketchPlane,
    XYZ^ position,
    HorizontalAlign horizontalAlign,
    double depth
)

Parameters

text
Type: System..::..String
The text to be displayed.
modelTextType
Type: Autodesk.Revit.DB..::..ModelTextType
The type of model text. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), the default type will be used.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane of the model text. The direction of model text is determined by the normal of the sketch plane. To extrude in the other direction set the depth value to negative.
position
Type: Autodesk.Revit.DB..::..XYZ
The position of the model text. The position must lie in the sketch plane.
horizontalAlign
Type: Autodesk.Revit.DB..::..HorizontalAlign
The horizontal alignment.
depth
Type: System..::..Double
The depth of the model text.

Return Value

If successful, the newly created model text is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument text, sketchPlane or XYZ is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when input argument text is an empty string. Thrown when input argument horizontalAlign or depth is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when model text creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewOpening Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewOpening Method
FamilyItemFactory Class See Also Send Feedback
Create an opening to cut the wall or ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Opening NewOpening(
    Element host,
    CurveArray profile
)
Visual Basic
Public Function NewOpening ( _
    host As Element, _
    profile As CurveArray _
) As Opening
Visual C++
public:
Opening^ NewOpening(
    Element^ host,
    CurveArray^ profile
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
Host elements that new opening would lie in. The host can only be a wall or a ceiling.
profile
Type: Autodesk.Revit.DB..::..CurveArray
The profile of the newly created opening. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops may not intersect. The profiles will be projected into the host plane.

Return Value

If successful, the newly created opening is returned, otherwise an exception with error information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument host or profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when host isn't a wall or a ceiling. Thrown when profile doesn't contain any loops.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when opening creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewPipeConnector Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewPipeConnector Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new pipe connector into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")]
public PipeConnector NewPipeConnector(
    Reference planarFaceReference,
    PipeSystemType systemType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")> _
Public Function NewPipeConnector ( _
    planarFaceReference As Reference, _
    systemType As PipeSystemType _
) As PipeConnector
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Please call ConnectorElement::CreatePipeConnector() instead")]
public:
PipeConnector^ NewPipeConnector(
    Reference^ planarFaceReference,
    PipeSystemType systemType
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
A reference to a planar face where the connector will be placed.
systemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
Indicates the system type of this new Pipe connector.

Return Value

If creation was successful the new pipe connector is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a Pipe Connector in a family document. The pipe connector will be placed at the centroid of the planar face.

Examples

CopyC#
public void CreatePipeConnectors(UIDocument uiDocument, Extrusion extrusion)
{
    // get the faces of the extrusion
    Options geoOptions = uiDocument.Document.Application.Create.NewGeometryOptions();
    geoOptions.View = uiDocument.Document.ActiveView;
    geoOptions.ComputeReferences = true;

    List<PlanarFace> planarFaces = new List<PlanarFace>();
    Autodesk.Revit.DB.GeometryElement geoElement = extrusion.get_Geometry(geoOptions);
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        Solid geoSolid = geoObject as Solid;
        if (null != geoSolid)
        {
            foreach (Face geoFace in geoSolid.Faces)
            {
                if (geoFace is PlanarFace)
                {
                    planarFaces.Add(geoFace as PlanarFace);
                }
            }
        }
    }

    if (planarFaces.Count > 1)
    {
        // Create the Supply Hydronic pipe connector
        PipeConnector connSupply =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[0].Reference,
                                                   PipeSystemType.SupplyHydronic);
        Parameter param = connSupply.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(1.0); // 1' radius
        param = connSupply.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(2);

        // Create the Return Hydronic pipe connector
        PipeConnector connReturn =
            uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces[1].Reference,
                                                   PipeSystemType.ReturnHydronic);

        param = connReturn.get_Parameter(BuiltInParameter.CONNECTOR_RADIUS);
        param.Set(0.5); // 6" radius
        param = connReturn.get_Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM);
        param.Set(1);
    }
}
CopyVB.NET
Public Sub CreatePipeConnectors(ByVal uiDocument As UIDocument, ByVal extrusion As Extrusion)
    ' get the faces of the extrusion
    Dim geoOptions As Options = uiDocument.Document.Application.Create.NewGeometryOptions()
    geoOptions.View = uiDocument.Document.ActiveView
    geoOptions.ComputeReferences = True

    Dim planarFaces As New List(Of PlanarFace)()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = extrusion.Geometry(geoOptions)
    For Each geoObject As GeometryObject In geoElement.Objects
        Dim geoSolid As Solid = TryCast(geoObject, Solid)
        If geoSolid IsNot Nothing Then
            For Each geoFace As Face In geoSolid.Faces
                If TypeOf geoFace Is PlanarFace Then
                    planarFaces.Add(TryCast(geoFace, PlanarFace))
                End If
            Next
        End If
    Next

    If planarFaces.Count > 1 Then
        ' Create the Supply Hydronic pipe connector
        Dim connSupply As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(0).Reference, PipeSystemType.SupplyHydronic)
        Dim param As Parameter = connSupply.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](1)
        ' 1' radius
        param = connSupply.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](2)

        ' Create the Return Hydronic pipe connector
        Dim connReturn As PipeConnector = uiDocument.Document.FamilyCreate.NewPipeConnector(planarFaces(1).Reference, PipeSystemType.ReturnHydronic)

        param = connReturn.Parameter(BuiltInParameter.CONNECTOR_RADIUS)
        param.[Set](0.5)
        ' 6" radius
        param = connReturn.Parameter(BuiltInParameter.RBS_PIPE_FLOW_DIRECTION_PARAM)
        param.[Set](1)
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument planarFaceReference is invalid.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRadialDimension Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewRadialDimension Method
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object.

Overload List

 | Name | Description
Public method | NewRadialDimension(View, Reference, XYZ) | Creates a new radial dimension object using the default dimension type.
Public method | NewRadialDimension(View, Reference, XYZ, DimensionType) | Generate a new radial dimension object using a specified dimension type.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ)

[image]

Revit 2013 API
FamilyItemFactory..::..NewRadialDimension Method (View, Reference, XYZ)
FamilyItemFactory Class See Also Send Feedback
Creates a new radial dimension object using the default dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin
)
Visual Basic
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the radial dimension will lie.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The currently user set default style is used for the created dimension.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewRadialDimension Method (View, Reference, XYZ, DimensionType)

[image]

Revit 2013 API
FamilyItemFactory..::..NewRadialDimension Method (View, Reference, XYZ, DimensionType)
FamilyItemFactory Class See Also Send Feedback
Generate a new radial dimension object using a specified dimension type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewRadialDimension(
    View view,
    Reference arcRef,
    XYZ origin,
    DimensionType dimensionType
)
Visual Basic
Public Function NewRadialDimension ( _
    view As View, _
    arcRef As Reference, _
    origin As XYZ, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewRadialDimension(
    View^ view,
    Reference^ arcRef,
    XYZ^ origin,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
arcRef
Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
origin
Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the radial dimension will lie.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If creation was successful the new arc length dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

The dimension will be created on default place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef/dimensionType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewRadialDimension Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method
FamilyItemFactory Class See Also Send Feedback
Creates a reference point.

Overload List

 | Name | Description
Public method | NewReferencePoint(PointElementReference) | Create a reference point on an existing reference in an Autodesk Revit family document.
Public method | NewReferencePoint(Transform) | Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.
Public method | NewReferencePoint(XYZ) | Create a reference point at a given location in an Autodesk Revit family document.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (PointElementReference)

[image]

Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method (PointElementReference)
FamilyItemFactory Class See Also Send Feedback
Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    PointElementReference
)
Visual Basic
Public Function NewReferencePoint ( _
     As PointElementReference _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    PointElementReference^
)

Parameters

Type: Autodesk.Revit.DB..::..PointElementReference

Return Value

The newly created ReferencePoint.

Remarks

The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (Transform)

[image]

Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method (Transform)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location and with a given coordinate system in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    Transform
)
Visual Basic
Public Function NewReferencePoint ( _
     As Transform _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    Transform^
)

Parameters

Type: Autodesk.Revit.DB..::..Transform

Return Value

The newly created ReferencePoint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewReferencePoint Method (XYZ)

[image]

Revit 2013 API
FamilyItemFactory..::..NewReferencePoint Method (XYZ)
FamilyItemFactory Class See Also Send Feedback
Create a reference point at a given location in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePoint NewReferencePoint(
    XYZ
)
Visual Basic
Public Function NewReferencePoint ( _
     As XYZ _
) As ReferencePoint
Visual C++
public:
ReferencePoint^ NewReferencePoint(
    XYZ^
)

Parameters

Type: Autodesk.Revit.DB..::..XYZ

Return Value

The newly created ReferencePoint.

Remarks

The ReferencePoint will have a default coordinate system corresponding to the global coordinate system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family.

See Also

FamilyItemFactory Class
NewReferencePoint Overload
Autodesk.Revit.Creation Namespace


NewRevolution Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewRevolution Method
FamilyItemFactory Class Example See Also Send Feedback
Add a new Revolution instance into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Revolution NewRevolution(
    bool isSolid,
    CurveArrArray profile,
    SketchPlane sketchPlane,
    Line axis,
    double startAngle,
    double endAngle
)
Visual Basic
Public Function NewRevolution ( _
    isSolid As Boolean, _
    profile As CurveArrArray, _
    sketchPlane As SketchPlane, _
    axis As Line, _
    startAngle As Double, _
    endAngle As Double _
) As Revolution
Visual C++
public:
Revolution^ NewRevolution(
    bool isSolid,
    CurveArrArray^ profile,
    SketchPlane^ sketchPlane,
    Line^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Revolution is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..CurveArrArray
The profile of the newly created revolution. This may contain more than one curve loop. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the revolution. The direction of revolution is determined by the normal for the sketch plane.
axis
Type: Autodesk.Revit.DB..::..Line
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::..Double
The start angle of Revolution in radians.
endAngle
Type: System..::..Double
The end angle of Revolution in radians.

Return Value

If creation was successful the new revolution is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates an Revolution in a family document. The Revolution will be rotated the plane of the Revolution profile about the Axis.

Examples

CopyC#
private Revolution CreateRevolution(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Revolution revolution = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the revolution
        CurveArrArray curveArrArray = new CurveArrArray();
        CurveArray curveArray = new CurveArray();

        // create a rectangular profile for the revolution
        XYZ p0 = XYZ.Zero;
        XYZ p1 = new XYZ(10, 0, 0);
        XYZ p2 = new XYZ(10, 10, 0);
        XYZ p3 = new XYZ(0, 10, 0);
        Line line1 = document.Application.Create.NewLineBound(p0, p1);
        Line line2 = document.Application.Create.NewLineBound(p1, p2);
        Line line3 = document.Application.Create.NewLineBound(p2, p3);
        Line line4 = document.Application.Create.NewLineBound(p3, p0);

        XYZ pp = new XYZ(1, -1, 0);
        Line axis1 = document.Application.Create.NewLineBound(XYZ.Zero, pp);
        curveArray.Append(line1);
        curveArray.Append(line2);
        curveArray.Append(line3);
        curveArray.Append(line4);

        curveArrArray.Append(curveArray);

        // create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(true, curveArrArray, sketchPlane, axis1, -Math.PI, 0);

        if (null != revolution)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(0, 32, 0);
            ElementTransformUtils.MoveElement(document, revolution.Id, transPoint1);
        }
        else
        {
            throw new Exception("Create a new Revolution failed.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return revolution;
}
CopyVB.NET
Private Function CreateRevolution(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Revolution
    Dim revolution As Revolution = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the revolution
        Dim curveArrArray As New CurveArrArray()
        Dim curveArray As New CurveArray()

        ' create a rectangular profile for the revolution
        Dim p0 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
        Dim p1 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim p2 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
        Dim p3 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim line1 As Line = document.Application.Create.NewLineBound(p0, p1)
        Dim line2 As Line = document.Application.Create.NewLineBound(p1, p2)
        Dim line3 As Line = document.Application.Create.NewLineBound(p2, p3)
        Dim line4 As Line = document.Application.Create.NewLineBound(p3, p0)

        Dim pp As New Autodesk.Revit.DB.XYZ(1, -1, 0)
        Dim axis1 As Line = document.Application.Create.NewLineBound(XYZ.Zero, pp)
        curveArray.Append(line1)
        curveArray.Append(line2)
        curveArray.Append(line3)
        curveArray.Append(line4)

        curveArrArray.Append(curveArray)

        ' create solid rectangular revolution
        revolution = document.FamilyCreate.NewRevolution(True, curveArrArray, sketchPlane, axis1, -Math.PI, 0)

        If revolution IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(0, 32, 0)
            document.Move(revolution, transPoint1)
        Else
            Throw New Exception("Create a new Revolution failed.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return revolution
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty array.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-sketchPlane-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-sketchPlane-is an invalid sketch plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-axis-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where revolutions cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewRevolveForms Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewRevolveForms Method
FamilyItemFactory Class Example See Also Send Feedback
Create new Form elements by revolve operation, and add them into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FormArray NewRevolveForms(
    bool isSolid,
    ReferenceArray profile,
    Reference axis,
    double startAngle,
    double endAngle
)
Visual Basic
Public Function NewRevolveForms ( _
    isSolid As Boolean, _
    profile As ReferenceArray, _
    axis As Reference, _
    startAngle As Double, _
    endAngle As Double _
) As FormArray
Visual C++
public:
FormArray^ NewRevolveForms(
    bool isSolid,
    ReferenceArray^ profile,
    Reference^ axis,
    double startAngle,
    double endAngle
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
profile
Type: Autodesk.Revit.DB..::..ReferenceArray
The profile of the newly created revolution. It should consist of only one curve loop. The input profile must be in one plane.
axis
Type: Autodesk.Revit.DB..::..Reference
The axis of revolution. This axis must lie in the same plane as the curve loops.
startAngle
Type: System..::..Double
The start angle of Revolution in radians.
endAngle
Type: System..::..Double
The end angle of Revolution in radians.

Return Value

If creation was successful new forms are returned.

Remarks

Typically this operation produces only a single form, but some combinations of arguments will create multiple forms from a single profile.

Examples

CopyC#
private FormArray CreateRevolveForm(Document document)
{
    FormArray revolveForms = null;

    // Create one profile
    ReferenceArray ref_ar = new ReferenceArray();

    XYZ ptA = new XYZ(0, 0, 10);
    XYZ ptB = new XYZ(100, 0, 10);
    Line line = document.Application.Create.NewLine(ptA, ptB, true);
    ModelCurve modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 0, 10);
    ptB = new XYZ(100, 100, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    ptA = new XYZ(100, 100, 10);
    ptB = new XYZ(0, 0, 10);
    modelcurve = MakeLine(document, ptA, ptB);
    ref_ar.Append(modelcurve.GeometryCurve.Reference);

    // Create axis for revolve form
    ptA = new XYZ(-5, 0, 10);
    ptB = new XYZ(-5, 10, 10);
    ModelCurve axis = MakeLine(document, ptA, ptB);

    // make axis a Reference Line
    axis.ChangeToReferenceLine();

    // Typically this operation produces only a single form,
    // but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(true, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4);

    return revolveForms;
}

public ModelCurve MakeLine(Document doc, XYZ ptA, XYZ ptB)
{
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    // Create plane by the points
    Line line = app.Create.NewLine(ptA, ptB, true);
    XYZ norm = ptA.CrossProduct(ptB);
    if (norm.IsZeroLength()) norm = XYZ.BasisZ;
    Plane plane = app.Create.NewPlane(norm, ptB);
    SketchPlane skplane = doc.FamilyCreate.NewSketchPlane(plane);
    // Create line here
    ModelCurve modelcurve = doc.FamilyCreate.NewModelCurve(line, skplane);
    return modelcurve;
}
CopyVB.NET
Private Function CreateRevolveForm(ByVal document As Document) As FormArray
    Dim revolveForms As FormArray = Nothing

    ' Create one profile
    Dim ref_ar As New ReferenceArray()

    Dim ptA As New Autodesk.Revit.DB.XYZ(0, 0, 10)
    Dim ptB As New Autodesk.Revit.DB.XYZ(100, 0, 10)
    Dim line As Line = document.Application.Create.NewLine(ptA, ptB, True)
    Dim modelcurve As ModelCurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(100, 0, 10)
    ptB = New Autodesk.Revit.DB.XYZ(100, 100, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ptA = New Autodesk.Revit.DB.XYZ(100, 100, 10)
    ptB = New Autodesk.Revit.DB.XYZ(0, 0, 10)
    modelcurve = MakeLine(document, ptA, ptB)
    ref_ar.Append(modelcurve.GeometryCurve.Reference)

    ' Create axis for revolve form
    ptA = New Autodesk.Revit.DB.XYZ(-5, 0, 10)
    ptB = New Autodesk.Revit.DB.XYZ(-5, 10, 10)
    Dim axis As ModelCurve = MakeLine(document, ptA, ptB)

    ' make axis a Reference Line
    axis.ChangeToReferenceLine()

    ' Typically this operation produces only a single form,
    ' but some combinations of arguments will create multiple froms from a single profile.
    revolveForms = document.FamilyCreate.NewRevolveForms(True, ref_ar, axis.GeometryCurve.Reference, 0, Math.PI / 4)

    Return revolveForms
End Function

Public Function MakeLine(ByVal doc As Document, ByVal ptA As Autodesk.Revit.DB.XYZ, ByVal ptB As Autodesk.Revit.DB.XYZ) As ModelCurve
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    ' Create plane by the points
    Dim line As Line = app.Create.NewLine(ptA, ptB, True)
    Dim norm As Autodesk.Revit.DB.XYZ = ptA.CrossProduct(ptB)
    If norm.IsZeroLength() Then
        norm = Autodesk.Revit.DB.XYZ.BasisZ
    End If
    Dim plane As Plane = app.Create.NewPlane(norm, ptB)
    Dim skplane As SketchPlane = doc.FamilyCreate.NewSketchPlane(plane)
    ' Create line here
    Dim modelcurve As ModelCurve = doc.FamilyCreate.NewModelCurve(line, skplane)
    Return modelcurve
End Function

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewSketchPlane Method
FamilyItemFactory Class See Also Send Feedback
Creates a new sketch plane.

Overload List

 | Name | Description
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane. (Inherited from ItemFactoryBase.)
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewSweep Method
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form to the family document.

Overload List

 | Name | Description
Public method | NewSweep(Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form into the family document, using an array of selected references as a 3D path.
Public method | NewSweep(Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation) | Adds a new sweep form to the family document, using a path of curve elements.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2013 API
FamilyItemFactory..::..NewSweep Method (Boolean, ReferenceArray, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class See Also Send Feedback
Adds a new sweep form into the family document, using an array of selected references as a 3D path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    ReferenceArray path,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    ReferenceArray^ path,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::..ReferenceArray
The path of the sweep. The path should be reference of curve or edge obtained from existing geometry.
profile
Type: Autodesk.Revit.DB..::..SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::..Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::..ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)

[image]

Revit 2013 API
FamilyItemFactory..::..NewSweep Method (Boolean, CurveArray, SketchPlane, SweepProfile, Int32, ProfilePlaneLocation)
FamilyItemFactory Class Example See Also Send Feedback
Adds a new sweep form to the family document, using a path of curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sweep NewSweep(
    bool isSolid,
    CurveArray path,
    SketchPlane pathPlane,
    SweepProfile profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)
Visual Basic
Public Function NewSweep ( _
    isSolid As Boolean, _
    path As CurveArray, _
    pathPlane As SketchPlane, _
    profile As SweepProfile, _
    profileLocationCurveIndex As Integer, _
    profilePlaneLocation As ProfilePlaneLocation _
) As Sweep
Visual C++
public:
Sweep^ NewSweep(
    bool isSolid,
    CurveArray^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ profile,
    int profileLocationCurveIndex,
    ProfilePlaneLocation profilePlaneLocation
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Sweep is Solid or Void.
path
Type: Autodesk.Revit.DB..::..CurveArray
The path of the sweep. The path should be 2D, where all input curves lie in one plane, and the curves are not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for 3D paths or for 2D paths where the path should not reference an existing face.
profile
Type: Autodesk.Revit.DB..::..SweepProfile
The profile of the newly created Sweep. This may contain more than one curve loop or a profile family. Each loop must be a fully closed curve loop and the loops must not intersect. All loops must lie in the same plane. The loop can be a unbound circle or ellipse, but its geometry will be split in two in order to satisfy requirements for sketches used in extrusions.
profileLocationCurveIndex
Type: System..::..Int32
The index of the path curves. The curve upon which the profile plane will be determined.
profilePlaneLocation
Type: Autodesk.Revit.DB..::..ProfilePlaneLocation
The location on the profileLocationCurve where the profile plane will be determined.

Return Value

If creation was successful the new Sweep is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a sweep in a family document. The sweep will trace the profile along the path.

Examples

CopyC#
private Sweep CreateSweep(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    Sweep sweep = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Define a profile for the sweep
        CurveArrArray arrarr = new CurveArrArray();
        CurveArray arr = new CurveArray();

        // Create an ovoid profile
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(2, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        arr.Append(document.Application.Create.NewArc(pnt2, 1.0d, 0.0d, 180.0d, XYZ.BasisX, XYZ.BasisY));
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2));
        arrarr.Append(arr);
        SweepProfile profile = document.Application.Create.NewCurveLoopsProfile(arrarr);

        // Create a path for the sweep
        XYZ pnt4 = new XYZ(10, 0, 0);
        XYZ pnt5 = new XYZ(0, 10, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt4, pnt5);

        CurveArray curves = new CurveArray();
        curves.Append(curve);

        // create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(true, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start);

        if (null != sweep)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 0, 0);
            ElementTransformUtils.MoveElement(document, sweep.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create a new Sweep.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }

    return sweep;
}
CopyVB.NET
Private Function CreateSweep(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As Sweep
    Dim sweep As Sweep = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Define a profile for the sweep
        Dim arrarr As New CurveArrArray()
        Dim arr As New CurveArray()

        ' Create an ovoid profile
        Dim pnt1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.DB.XYZ(2, 0, 0)
        Dim pnt3 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
        arr.Append(document.Application.Create.NewArc(pnt2, 1, 0, 180, Autodesk.Revit.DB.XYZ.BasisX, Autodesk.Revit.DB.XYZ.BasisY))
        arr.Append(document.Application.Create.NewArc(pnt1, pnt3, pnt2))
        arrarr.Append(arr)
        Dim profile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr)

        ' Create a path for the sweep
        Dim pnt4 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
        Dim pnt5 As New Autodesk.Revit.DB.XYZ(0, 10, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt4, pnt5)

        Dim curves As New CurveArray()
        curves.Append(curve)

        ' create a solid ovoid sweep
        sweep = document.FamilyCreate.NewSweep(True, curves, sketchPlane, profile, 0, ProfilePlaneLocation.Start)

        If sweep IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(11, 0, 0)
            document.Move(sweep, transPoint1)
        Else
            Throw New Exception("Failed to create a new Sweep.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If

    Return sweep
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-path-is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-profile-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profileLocationCurveIndex-is out of index bounds.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-profilePlaneLocation-does not exist in the ProfilePlaneLocation enumeration.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where sweeps cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweep Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewSweptBlend Method
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document.

Overload List

 | Name | Description
Public method | NewSweptBlend(Boolean, Reference, SweepProfile, SweepProfile) | Adds a new swept blend into the family document, using a selected reference as the path.
Public method | NewSweptBlend(Boolean, Curve, SketchPlane, SweepProfile, SweepProfile) | Add a new swept blend into the family document, using a curve as the path.

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)

[image]

Revit 2013 API
FamilyItemFactory..::..NewSweptBlend Method (Boolean, Reference, SweepProfile, SweepProfile)
FamilyItemFactory Class See Also Send Feedback
Adds a new swept blend into the family document, using a selected reference as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Reference path,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Reference, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Reference^ path,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::..Reference
The path of the swept blend. The path might be a reference of single curve or edge obtained from existing geometry. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
bottomProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)

[image]

Revit 2013 API
FamilyItemFactory..::..NewSweptBlend Method (Boolean, Curve, SketchPlane, SweepProfile, SweepProfile)
FamilyItemFactory Class Example See Also Send Feedback
Add a new swept blend into the family document, using a curve as the path.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SweptBlend NewSweptBlend(
    bool isSolid,
    Curve path,
    SketchPlane pathPlane,
    SweepProfile bottomProfile,
    SweepProfile topProfile
)
Visual Basic
Public Function NewSweptBlend ( _
    isSolid As Boolean, _
    path As Curve, _
    pathPlane As SketchPlane, _
    bottomProfile As SweepProfile, _
    topProfile As SweepProfile _
) As SweptBlend
Visual C++
public:
SweptBlend^ NewSweptBlend(
    bool isSolid,
    Curve^ path,
    SketchPlane^ pathPlane,
    SweepProfile^ bottomProfile,
    SweepProfile^ topProfile
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the swept blend is Solid or Void.
path
Type: Autodesk.Revit.DB..::..Curve
The path of the swept blend. The path should be a single curve. Or the path can be a single sketched curve, and the curve is not required to reference existing geometry.
pathPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the path. Use this when you want to create a 2D path that resides on an existing planar face. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic) for a path curve obtained from geometry or for 2D paths where the path should not reference an existing edge.
bottomProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The bottom profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.
topProfile
Type: Autodesk.Revit.DB..::..SweepProfile
The top profile of the newly created Swept blend. It should consist of only one curve loop. the input profile must be in one plane.

Return Value

If creation was successful the new Swept blend is returned, otherwise an exception with failure information will be thrown.

Remarks

This method creates a swept blend in a family document. The swept blend will trace from bottom profile to the top along the path. Revit will determine an appropriate default mapping for the vertices of the two profiles. If the input profile is to be a cyclic profile (curve or ellipse) it must be split into at least two segments, so that Revit can find vertices to use for mapping the swept blend.

Examples

CopyC#
private SweptBlend CreateSweptBlend(Autodesk.Revit.DB.Document document, SketchPlane sketchPlane)
{
    SweptBlend newSweptBlend = null;

    // make sure we have a family document
    if (true == document.IsFamilyDocument)
    {
        // Create top and bottom profiles and path curve
        XYZ pnt1 = new XYZ(0, 0, 0);
        XYZ pnt2 = new XYZ(1, 0, 0);
        XYZ pnt3 = new XYZ(1, 1, 0);
        XYZ pnt4 = new XYZ(0, 1, 0);
        XYZ pnt5 = new XYZ(0, 0, 1);

        CurveArrArray arrarr1 = new CurveArrArray();
        CurveArray arr1 = new CurveArray();
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2));
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3));
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4));
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1));
        arrarr1.Append(arr1);

        XYZ pnt6 = new XYZ(0.5, 0, 0);
        XYZ pnt7 = new XYZ(1, 0.5, 0);
        XYZ pnt8 = new XYZ(0.5, 1, 0);
        XYZ pnt9 = new XYZ(0, 0.5, 0);
        CurveArrArray arrarr2 = new CurveArrArray();
        CurveArray arr2 = new CurveArray();
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7));
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8));
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9));
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6));
        arrarr2.Append(arr2);

        SweepProfile bottomProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1);
        SweepProfile topProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2);

        XYZ pnt10 = new XYZ(5, 0, 0);
        XYZ pnt11 = new XYZ(0, 20, 0);
        Curve curve = document.Application.Create.NewLineBound(pnt10, pnt11);

        // here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(true, curve, sketchPlane, bottomProfile, topProfile);
        if (null != newSweptBlend)
        {
            // move to proper place
            XYZ transPoint1 = new XYZ(11, 32, 0);
            ElementTransformUtils.MoveElement(document, newSweptBlend.Id, transPoint1);
        }
        else
        {
            throw new Exception("Failed to create new SweptBlend.");
        }
    }
    else
    {
        throw new Exception("Please open a Family document before invoking this command.");
    }
    return newSweptBlend;
}
CopyVB.NET
Private Function CreateSweptBlend(ByVal document As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane) As SweptBlend
    Dim newSweptBlend As SweptBlend = Nothing

    ' make sure we have a family document
    If True = document.IsFamilyDocument Then
        ' Create top and bottom profiles and path curve
        Dim pnt1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
        Dim pnt2 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
        Dim pnt3 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
        Dim pnt4 As New Autodesk.Revit.DB.XYZ(0, 1, 0)
        Dim pnt5 As New Autodesk.Revit.DB.XYZ(0, 0, 1)

        Dim arrarr1 As New CurveArrArray()
        Dim arr1 As New CurveArray()
        arr1.Append(document.Application.Create.NewLineBound(pnt1, pnt2))
        arr1.Append(document.Application.Create.NewLineBound(pnt2, pnt3))
        arr1.Append(document.Application.Create.NewLineBound(pnt3, pnt4))
        arr1.Append(document.Application.Create.NewLineBound(pnt4, pnt1))
        arrarr1.Append(arr1)

        Dim pnt6 As New Autodesk.Revit.DB.XYZ(0.5, 0, 0)
        Dim pnt7 As New Autodesk.Revit.DB.XYZ(1, 0.5, 0)
        Dim pnt8 As New Autodesk.Revit.DB.XYZ(0.5, 1, 0)
        Dim pnt9 As New Autodesk.Revit.DB.XYZ(0, 0.5, 0)
        Dim arrarr2 As New CurveArrArray()
        Dim arr2 As New CurveArray()
        arr2.Append(document.Application.Create.NewLineBound(pnt6, pnt7))
        arr2.Append(document.Application.Create.NewLineBound(pnt7, pnt8))
        arr2.Append(document.Application.Create.NewLineBound(pnt8, pnt9))
        arr2.Append(document.Application.Create.NewLineBound(pnt9, pnt6))
        arrarr2.Append(arr2)

        Dim bottomProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr1)
        Dim topProfile As SweepProfile = document.Application.Create.NewCurveLoopsProfile(arrarr2)

        Dim pnt10 As New Autodesk.Revit.DB.XYZ(5, 0, 0)
        Dim pnt11 As New Autodesk.Revit.DB.XYZ(0, 20, 0)
        Dim curve As Curve = document.Application.Create.NewLineBound(pnt10, pnt11)

        ' here create rectangular swept blend
        newSweptBlend = document.FamilyCreate.NewSweptBlend(True, curve, sketchPlane, bottomProfile, topProfile)
        If newSweptBlend IsNot Nothing Then
            ' move to proper place
            Dim transPoint1 As New Autodesk.Revit.DB.XYZ(11, 32, 0)
            document.Move(newSweptBlend, transPoint1)
        Else
            Throw New Exception("Failed to create new SweptBlend.")
        End If
    Else
        Throw New Exception("Please open a Family document before invoking this command.")
    End If
    Return newSweptBlend
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input arguments-path/bottomProfile/topProfile-are nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a curve based profile and the profile contains nullNothingnullptra null reference (Nothing in Visual Basic) or more than one curve loops.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-bottomProfile/topProfile-is a family symbol based profile and the family symbol profile is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation is attempted in Conceptual Mass, 2D, or other family where swept blends cannot be created.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed.

See Also

FamilyItemFactory Class
NewSweptBlend Overload
Autodesk.Revit.Creation Namespace


NewSweptBlendForm Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewSweptBlendForm Method
FamilyItemFactory Class See Also Send Feedback
Create new Form element by swept blend operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Form NewSweptBlendForm(
    bool isSolid,
    ReferenceArray path,
    ReferenceArrayArray profiles
)
Visual Basic
Public Function NewSweptBlendForm ( _
    isSolid As Boolean, _
    path As ReferenceArray, _
    profiles As ReferenceArrayArray _
) As Form
Visual C++
public:
Form^ NewSweptBlendForm(
    bool isSolid,
    ReferenceArray^ path,
    ReferenceArrayArray^ profiles
)

Parameters

isSolid
Type: System..::..Boolean
Indicates if the Form is Solid or Void.
path
Type: Autodesk.Revit.DB..::..ReferenceArray
The path of the swept blend. The path should be 2D, where all input curves lie in one plane. If there’s more than one profile, the path should be a single curve. It’s required to reference existing geometry.
profiles
Type: Autodesk.Revit.DB..::..ReferenceArrayArray
The profile set of the newly created swept blend. Each profile should consist of only one curve loop. The input profile must be in one plane.

Return Value

If creation was successful new form is returned.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewSymbolicCurve Method

[image]

Revit 2013 API
FamilyItemFactory..::..NewSymbolicCurve Method
FamilyItemFactory Class See Also Send Feedback
Create a symbolic curve in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SymbolicCurve NewSymbolicCurve(
    Curve curve,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewSymbolicCurve ( _
    curve As Curve, _
    sketchPlane As SketchPlane _
) As SymbolicCurve
Visual C++
public:
SymbolicCurve^ NewSymbolicCurve(
    Curve^ curve,
    SketchPlane^ sketchPlane
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The geometry curve of the newly created symbolic curve.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane for the symbolic curve.

Return Value

The newly created symbolic curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when symbolic curve creation failed.

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2013 API
FamilyItemFactory..::..NewTextNote Method
FamilyItemFactory Class See Also Send Feedback
Creates a new TextNote object.

Overload List

 | Name | Description
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader. (Inherited from ItemFactoryBase.)
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader. (Inherited from ItemFactoryBase.)

See Also

FamilyItemFactory Class
FamilyItemFactory Members
Autodesk.Revit.Creation Namespace


FamilyItemFactory Properties

[image] [image]

Revit 2013 API
FamilyItemFactory Properties
FamilyItemFactory Class See Also Send Feedback

The FamilyItemFactory type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyItemFactory Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Class

[image]

Revit 2013 API
ItemFactoryBase Class
Members See Also Send Feedback
The ItemFactoryBase object is used to create new instances of elements within the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ItemFactoryBase : APIObject
Visual Basic
Public Class ItemFactoryBase _
    Inherits APIObject
Visual C++
public ref class ItemFactoryBase : public APIObject

Remarks

The ItemFactoryBase object is a utility object that is used to create new instances of elements within the Autodesk Revit document. This class holds common methods used in both project documents and family documents.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.Creation..::..Document
Autodesk.Revit.Creation..::..FamilyItemFactory

See Also

ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


ItemFactoryBase Members

[image] [image]

Revit 2013 API
ItemFactoryBase Members
ItemFactoryBase Class Methods Properties See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document.
Public method | NewFamilyInstances2 | Creates Family instances within the document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group.
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group.
Public method | NewLevel | Creates a new level.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data.
Public method | NewView3D | Obsolete. Creates a new 3D view.
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level.
Public method | NewViewSection | Obsolete. Creates a new section view.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Methods

[image] [image]

Revit 2013 API
ItemFactoryBase Methods
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewAlignment | Add a new locked alignment into the Autodesk Revit document.
Public method | NewAnnotationSymbol | Obsolete. Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewDetailCurve | Creates a new detail curve element.
Public method | NewDetailCurveArray | Creates an array of new detail curve elements.
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.
Public method | NewFamilyInstances | Obsolete. Creates Family instances within the document.
Public method | NewFamilyInstances2 | Creates Family instances within the document.
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group.
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group.
Public method | NewLevel | Creates a new level.
Public method | NewModelCurve | Creates a new model line element.
Public method | NewModelCurveArray | Creates an array of new model line elements.
Public method | NewReferencePlane | Creates a new instance of ReferencePlane.
Public method | NewReferencePlane2 | Creates a new instance of ReferencePlane.
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.
Public method | NewTextNotes | Obsolete. Creates TextNotes with the specified data.
Public method | NewView3D | Obsolete. Creates a new 3D view.
Public method | NewViewPlan | Obsolete. Creates a plan view based on the specified level.
Public method | NewViewSection | Obsolete. Creates a new section view.
Public method | PlaceGroup | Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAlignment Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewAlignment Method
ItemFactoryBase Class See Also Send Feedback
Add a new locked alignment into the Autodesk Revit document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewAlignment(
    View view,
    Reference reference1,
    Reference reference2
)
Visual Basic
Public Function NewAlignment ( _
    view As View, _
    reference1 As Reference, _
    reference2 As Reference _
) As Dimension
Visual C++
public:
Dimension^ NewAlignment(
    View^ view,
    Reference^ reference1,
    Reference^ reference2
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view that determines the orientation of the alignment.
reference1
Type: Autodesk.Revit.DB..::..Reference
The first reference.
reference2
Type: Autodesk.Revit.DB..::..Reference
The second reference.

Return Value

If creation was successful the new locked alignment dimension is returned, otherwise an exception with failure information will be thrown.

Remarks

These two references must be one of the following combinations:
  • 2 planar faces
  • 2 lines
  • line and point
  • line and reference plane
  • 2 arcs
  • 2 cylindrical faces
These references must be already geometrically aligned (this function will not force them to become aligned).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"view" or "headerReference" or "otherReference"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"headerReference" or "otherReference"-is invalid.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewAnnotationSymbol Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewAnnotationSymbol Method
ItemFactoryBase Class See Also Send Feedback
Add a new instance of an Annotation Symbol into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")]
public AnnotationSymbol NewAnnotationSymbol(
    XYZ origin,
    AnnotationSymbolType annotationSymbolType,
    View specView
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")> _
Public Function NewAnnotationSymbol ( _
    origin As XYZ, _
    annotationSymbolType As AnnotationSymbolType, _
    specView As View _
) As AnnotationSymbol
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2013.  Use NewFamilyInstance(XYZ, FamilySymbol, View)  to place any view-based family instance including annotation symbols.")]
public:
AnnotationSymbol^ NewAnnotationSymbol(
    XYZ^ origin,
    AnnotationSymbolType^ annotationSymbolType,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the annotation symbol. If created on ViewPlan, the origin will be projected onto the ViewPlan.
annotationSymbolType
Type: Autodesk.Revit.DB..::..AnnotationSymbolType
An annotation symbol type that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
A 2D view in which to display the annotation symbol.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods. The location may be different from its origin on ViewPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | The input view was not 2D.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurve Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewDetailCurve Method
ItemFactoryBase Class See Also Send Feedback
Creates a new detail curve element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DetailCurve NewDetailCurve(
    View view,
    Curve geometryCurve
)
Visual Basic
Public Function NewDetailCurve ( _
    view As View, _
    geometryCurve As Curve _
) As DetailCurve
Visual C++
public:
DetailCurve^ NewDetailCurve(
    View^ view,
    Curve^ geometryCurve
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the detail curve is to be visible.
geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The internal geometry curve for detail curve. It should be a bound curve.

Return Value

If successful a new detail curve element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of detail curve element will be returned according to the type of geometry curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in plane of the view

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDetailCurveArray Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewDetailCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DetailCurveArray NewDetailCurveArray(
    View view,
    CurveArray geometryCurveArray
)
Visual Basic
Public Function NewDetailCurveArray ( _
    view As View, _
    geometryCurveArray As CurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ NewDetailCurveArray(
    View^ view,
    CurveArray^ geometryCurveArray
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the detail curves are to be visible.
geometryCurveArray
Type: Autodesk.Revit.DB..::..CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

If successful an array of new detail curve elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in plane of the view

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewDimension Method

[image] [image]

Revit 2013 API
ItemFactoryBase..::..NewDimension Method
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object.

Overload List

 | Name | Description
Public method | NewDimension(View, Line, ReferenceArray) | Creates a new linear dimension object using the default dimension style.
Public method | NewDimension(View, Line, ReferenceArray, DimensionType) | Creates a new linear dimension object using the specified dimension style.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray)

[image]

Revit 2013 API
ItemFactoryBase..::..NewDimension Method (View, Line, ReferenceArray)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new linear dimension object using the default dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references
)
Visual Basic
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::..Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The currently user set default style is used for the created dimension.

Examples

CopyC#
Dimension CreateNewDimensionAlongLine(Autodesk.Revit.DB.Document document, Line line)
{
    // Use the Start and End points of our line as the references
    // Line must come from something in Revit, such as a beam
    ReferenceArray references = new ReferenceArray();
    references.Append(line.get_EndPointReference(0));
    references.Append(line.get_EndPointReference(1));

    // create the new dimension
    Dimension dimension = document.Create.NewDimension(document.ActiveView,
                                                        line, references);
    return dimension;
}
CopyVB.NET
Function CreateNewDimensionAlongLine(ByVal document As Autodesk.Revit.DB.Document, ByVal line As Line) As Dimension
    ' Use the Start and End points of our line as the references
    ' Line must come from something in Revit, such as a beam
    Dim references As New ReferenceArray()
    references.Append(line.EndPointReference(0))
    references.Append(line.EndPointReference(1))

    ' create the new dimension
    Dim dimension As Dimension = document.Create.NewDimension(document.ActiveView, line, references)
    Return dimension
End Function

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewDimension Method (View, Line, ReferenceArray, DimensionType)

[image]

Revit 2013 API
ItemFactoryBase..::..NewDimension Method (View, Line, ReferenceArray, DimensionType)
ItemFactoryBase Class See Also Send Feedback
Creates a new linear dimension object using the specified dimension style.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Dimension NewDimension(
    View view,
    Line line,
    ReferenceArray references,
    DimensionType dimensionType
)
Visual Basic
Public Function NewDimension ( _
    view As View, _
    line As Line, _
    references As ReferenceArray, _
    dimensionType As DimensionType _
) As Dimension
Visual C++
public:
Dimension^ NewDimension(
    View^ view,
    Line^ line,
    ReferenceArray^ references,
    DimensionType^ dimensionType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
line
Type: Autodesk.Revit.DB..::..Line
The line drawn for the dimension.
references
Type: Autodesk.Revit.DB..::..ReferenceArray
An array of geometric references to which the dimension is to be bound.
dimensionType
Type: Autodesk.Revit.DB..::..DimensionType
The dimension style to be used for the dimension.

Return Value

If successful a new dimension object, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ItemFactoryBase Class
NewDimension Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method

[image] [image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document.

Overload List

 | Name | Description
Public method | NewFamilyInstance(Face, Line, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(Line, FamilySymbol, View) | Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.
Public method | NewFamilyInstance(Reference, Line, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, StructuralType) | Inserts a new instance of a family into the document, using a location and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, View) | Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.
Public method | NewFamilyInstance(Face, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(Reference, XYZ, XYZ, FamilySymbol) | Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.
Public method | NewFamilyInstance(XYZ, FamilySymbol, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.
Public method | NewFamilyInstance(XYZ, FamilySymbol, XYZ, Element, StructuralType) | Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, Line, FamilySymbol)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Face, Line, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    face As Face, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the Reference from the face, or, Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Line, FamilySymbol, View)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Line, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a line based detail family instance into the Autodesk Revit document, using an line and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Line line,
    FamilySymbol symbol,
    View specView
)
Visual Basic
Public Function NewFamilyInstance ( _
    line As Line, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Line^ line,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

line
Type: Autodesk.Revit.DB..::..Line
The line location of family instance. The line must in the plane of the view.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
A 2D view in which to display the family instance.

Remarks

This overload applies only to 2D family line based detail symbols. The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when input argument line or symbol or specView is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when input argument line or symbol or specView is invalid, or cannot make such type in the specView, or the line is not in the plane of specView.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to create the instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Reference, Line, FamilySymbol)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Reference, Line, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face referenced by the input Reference instance, using a line on that face for its position, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Reference reference,
    Line position,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    reference As Reference, _
    position As Line, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    Line^ position,
    FamilySymbol^ symbol
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A reference to a face.
position
Type: Autodesk.Revit.DB..::..Line
A line on the face defining where the symbol is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased or CurveBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a line on the face to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instance fails to be created an exception may be thrown.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get a face from the reference, or, when the family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased or CurveBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the family cannot be placed on this line as it does not coincide with the input face.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert a family instance that does not require a host element or level.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa";

 // try to load family
 Family family = null;
 if (!document.LoadFamily(fileName, out family))
 {
     throw new Exception("Unable to load " + fileName);
 }

 // Loop through table symbols and add a new table for each
 FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
 double x = 0.0, y = 0.0;
 while (symbolItor.MoveNext())
 {
     FamilySymbol symbol = symbolItor.Current as FamilySymbol;
     XYZ location = new XYZ(x, y, 10.0);
     // Do not use the overloaded NewFamilyInstance() method that contains
     // the Level argument, otherwise Revit cannot show the instances
     // correctly in 3D View, for the table is not level-based component.
     FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, StructuralType.NonStructural);
     x += 10.0;
 }
CopyVB.NET
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Table-Dining Round w Chairs.rfa"

' try to load family
Dim family As Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Unable to load " + fileName)
End If

' Loop through table symbols and add a new table for each
Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
Dim x As Double = 0, y As Double = 0
While symbolItor.MoveNext()
    Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
    Dim location As New Autodesk.Revit.DB.XYZ(x, y, 10)
    ' Do not use the overloaded NewFamilyInstance() method that contains
    ' the Level argument, otherwise Revit cannot show the instances
    ' correctly in 3D View, for the table is not level-based component.
    Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
    x += 10
End While

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, View)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, View)
ItemFactoryBase Class See Also Send Feedback
Add a new family instance into the Autodesk Revit document, using an origin and a view where the instance should be placed.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ origin,
    FamilySymbol symbol,
    View specView
)
Visual Basic
Public Function NewFamilyInstance ( _
    origin As XYZ, _
    symbol As FamilySymbol, _
    specView As View _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ origin,
    FamilySymbol^ symbol,
    View^ specView
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of family instance. If created on a ViewPlan, the origin will be projected onto the ViewPlan.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A family symbol object that represents the type of the instance that is to be inserted.
specView
Type: Autodesk.Revit.DB..::..View
The 2D view in which to place the family instance.

Return Value

If creation was successful then an instance to the new object is returned.

Remarks

This overload applies only to 2D family symbols (detail components, annotation symbols, titleblocks, etc.). The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more required arguments was nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | The input family PlacementType was not ViewBased, the input view was not 2D, or the input family is not permitted in this view.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Face, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face of an existing element, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Face face,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    face As Face, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Face^ face,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the Reference from the face, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (Reference, XYZ, XYZ, FamilySymbol)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (Reference, XYZ, XYZ, FamilySymbol)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family onto a face referenced by the input Reference instance, using a location, reference direction, and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    Reference reference,
    XYZ location,
    XYZ referenceDirection,
    FamilySymbol symbol
)
Visual Basic
Public Function NewFamilyInstance ( _
    reference As Reference, _
    location As XYZ, _
    referenceDirection As XYZ, _
    symbol As FamilySymbol _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    Reference^ reference,
    XYZ^ location,
    XYZ^ referenceDirection,
    FamilySymbol^ symbol
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A reference to a face.
location
Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance. Note that this direction defines the rotation of the instance on the face, and thus cannot be parallel to the face normal.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted. Note that this symbol must represent a family whose FamilyPlacementType is WorkPlaneBased.

Return Value

An instance of the new object if creation was successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Use this method to insert one family instance on a face of another element, using a point on the face and a vector to define the position and direction of the new symbol.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must support insertion of instances, otherwise this method will fail. If the instances fails to be created an exception may be thrown.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted, these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when a non-optional argument was null.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the function cannot get the face from the reference, or, when the Family cannot be placed as line-based on an input face reference, because its FamilyPlacementType is not WorkPlaneBased
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when reference direction is parallel to face normal at insertion point.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Revit is unable to place the family instance.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, Element, StructuralType)
ItemFactoryBase Class See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, and the host element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
host
Type: Autodesk.Revit.DB..::..Element
The object into which the FamilyInstance is to be inserted, often known as the host.
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to insert one family instance into another element, such as inserting a window into a wall. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

The host object must be one that supports insertion of instances otherwise this method will fail.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstance Method (XYZ, FamilySymbol, XYZ, Element, StructuralType)
ItemFactoryBase Class Example See Also Send Feedback
Inserts a new instance of a family into the document, using a location, type/symbol, the host element and a reference direction.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance NewFamilyInstance(
    XYZ location,
    FamilySymbol symbol,
    XYZ referenceDirection,
    Element host,
    StructuralType structuralType
)
Visual Basic
Public Function NewFamilyInstance ( _
    location As XYZ, _
    symbol As FamilySymbol, _
    referenceDirection As XYZ, _
    host As Element, _
    structuralType As StructuralType _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ NewFamilyInstance(
    XYZ^ location,
    FamilySymbol^ symbol,
    XYZ^ referenceDirection,
    Element^ host,
    StructuralType structuralType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the instance is to be placed.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
referenceDirection
Type: Autodesk.Revit.DB..::..XYZ
A vector that dictates the direction of certain family instances.
host
Type: Autodesk.Revit.DB..::..Element
A host object into which the instance will be embedded
structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
If structural then specify the type of the component.

Return Value

If creation was successful then an instance to the new object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method allows you to create FamilyInstance objects that require both a location and direction. If the instance fails to be created an exception may be thrown.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
String fileName = @"C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa";

 Autodesk.Revit.DB.Family family = null;
 if (!document.LoadFamily(fileName, out family))
 {
     throw new Exception("Couldn't load " + fileName);
 }

 FilteredElementCollector collector = new FilteredElementCollector(document);
 Floor floor = collector.OfClass(typeof(Floor)).FirstElement() as Floor;
 if (floor != null)
 {
     FamilySymbolSetIterator symbolItor = family.Symbols.ForwardIterator();
     int x = 0, y = 0;
     int i = 0;
     while (symbolItor.MoveNext())
     {
         FamilySymbol symbol = symbolItor.Current as FamilySymbol;
         XYZ location = new XYZ(x, y, 0);
         XYZ direction = new XYZ();
         switch (i % 3)
         {
             case 0:
                 direction = new XYZ(1, 1, 0);
                 break;
             case 1:
                 direction = new XYZ(0, 1, 1);
                 break;
             case 2:
                 direction = new XYZ(1, 0, 1);
                 break;
         }
         FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, direction, floor, StructuralType.NonStructural);
         x += 10;
         i++;
     }
 }
 else
 {
     throw new Exception("Please open a model with at least one floor element before invoking this command.");
 }
CopyVB.NET
Dim fileName As [String] = "C:\Documents and Settings\All Users\Application Data\Autodesk\RST 2010\Imperial Library\Furniture\Bed-Box.rfa"

Dim family As Autodesk.Revit.DB.Family = Nothing
If Not document.LoadFamily(fileName, family) Then
    Throw New Exception("Couldn't load " + fileName)
End If

Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim floor As Autodesk.Revit.DB.Floor = TryCast(collector.OfClass(GetType(Floor)).FirstElement(), Autodesk.Revit.DB.Floor)
If floor IsNot Nothing Then
    Dim symbolItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
    Dim x As Integer = 0, y As Integer = 0
    Dim i As Integer = 0
    While symbolItor.MoveNext()
        Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
        Dim location As New Autodesk.Revit.DB.XYZ(x, y, 0)
        Dim direction As New Autodesk.Revit.DB.XYZ()
        Select Case i Mod 3
            Case 0
                direction = New Autodesk.Revit.DB.XYZ(1, 1, 0)
                Exit Select
            Case 1
                direction = New Autodesk.Revit.DB.XYZ(0, 1, 1)
                Exit Select
            Case 2
                direction = New Autodesk.Revit.DB.XYZ(1, 0, 1)
                Exit Select
        End Select
        Dim instance As Autodesk.Revit.DB.FamilyInstance = document.Create.NewFamilyInstance(location, symbol, direction, floor, Autodesk.Revit.DB.Structure.StructuralType.NonStructural)
        x += 10
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
Else
    Throw New Exception("Please open a model with at least one floor element before invoking this command.")
End If

See Also

ItemFactoryBase Class
NewFamilyInstance Overload
Autodesk.Revit.Creation Namespace


NewFamilyInstances Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstances Method
ItemFactoryBase Class Example See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")]
public ElementSet NewFamilyInstances(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")> _
Public Function NewFamilyInstances ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call NewFamilyInstances2(List<FamilyInstanceCreationData> dataList) instead.")]
public:
ElementSet^ NewFamilyInstances(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'FamilyInstanceCreationData>)>)>
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful an ElementSet which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Examples

CopyC#
ElementSet BatchCreateColumns(Autodesk.Revit.DB.Document document, Level level)
{
    List<FamilyInstanceCreationData> fiCreationDatas = new List<FamilyInstanceCreationData>();

    ElementSet elementSet = null;

    //Try to get a FamilySymbol
    FamilySymbol familySymbol = null;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol)).ToElements();
    foreach (Element e in collection)
    {
        familySymbol = e as FamilySymbol;
        if (null != familySymbol.Category)
        {
            if ("Structural Columns" == familySymbol.Category.Name)
            {
                break;
            }
        }
    }

    if (null != familySymbol)
    {
        //Create 10 FamilyInstanceCreationData items for batch creation
        for (int i = 1; i < 11; i++)
        {
            XYZ location = new XYZ(i * 10, 100, 0);
            FamilyInstanceCreationData fiCreationData =
                new FamilyInstanceCreationData(location, familySymbol, level,  StructuralType.Column);

            if (null != fiCreationData)
            {
                fiCreationDatas.Add(fiCreationData);
            }
        }

        if (fiCreationDatas.Count > 0)
        {
            // Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas);
        }
        else
        {
            throw new Exception("Batch creation failed.");
        }
    }
    else
    {
        throw new Exception("No column types found.");
    }

    return elementSet;
}
CopyVB.NET
Function BatchCreateColumns(ByVal document As Autodesk.Revit.DB.Document, ByVal level As Level) As ElementSet
    Dim fiCreationDatas As New List(Of FamilyInstanceCreationData)()

    Dim elementSet As ElementSet = Nothing

    'Try to get a FamilySymbol
    Dim familySymbol As FamilySymbol = Nothing
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        familySymbol = TryCast(e, FamilySymbol)
        If familySymbol.Category IsNot Nothing Then
            If "Structural Columns" = familySymbol.Category.Name Then
                Exit For
            End If
        End If
    Next

    If familySymbol IsNot Nothing Then
        'Create 10 FamilyInstanceCreationData items for batch creation
        Dim i As Integer = 1
        While i < 11
            Dim location As New Autodesk.Revit.DB.XYZ(i * 10, 100, 0)
            Dim fiCreationData As New FamilyInstanceCreationData(location, familySymbol, level, Autodesk.Revit.DB.Structure.StructuralType.Column)

            If fiCreationData IsNot Nothing Then
                fiCreationDatas.Add(fiCreationData)
            End If
            System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
        End While

        If fiCreationDatas.Count > 0 Then
            ' Create Columns
            elementSet = document.Create.NewFamilyInstances(fiCreationDatas)
        Else
            Throw New Exception("Batch creation failed.")
        End If
    Else
        Throw New Exception("No column types found.")
    End If

    Return elementSet
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewFamilyInstances2 Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewFamilyInstances2 Method
ItemFactoryBase Class See Also Send Feedback
Creates Family instances within the document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> NewFamilyInstances2(
    List<FamilyInstanceCreationData> dataList
)
Visual Basic
Public Function NewFamilyInstances2 ( _
    dataList As List(Of FamilyInstanceCreationData) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewFamilyInstances2(
    List<FamilyInstanceCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'FamilyInstanceCreationData>)>)>
A list of FamilyInstanceCreationData which wraps the creation arguments of the families to be created.

Return Value

If the creation is successful, a set of ElementIds which contains the Family instances should be returned, otherwise the exception will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call. This happens regardless of the setting for RegenerationMode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If FamilyInstanceCreationData's 'curve' or 'symbol' member is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | If regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewGroup Method

[image] [image]

Revit 2013 API
ItemFactoryBase..::..NewGroup Method
ItemFactoryBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | NewGroup(ICollection<(Of <<'(ElementId>)>>)) | Creates a new type of group.
Public method | NewGroup(ElementSet) | Obsolete. Creates a new type of group.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewGroup Method (ICollection(ElementId))

[image]

Revit 2013 API
ItemFactoryBase..::..NewGroup Method (ICollection<(Of <(<'ElementId>)>)>)
ItemFactoryBase Class See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Group NewGroup(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function NewGroup ( _
    elementIds As ICollection(Of ElementId) _
) As Group
Visual C++
public:
Group^ NewGroup(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.

See Also

ItemFactoryBase Class
NewGroup Overload
Autodesk.Revit.Creation Namespace


NewGroup Method (ElementSet)

[image]

Revit 2013 API
ItemFactoryBase..::..NewGroup Method (ElementSet)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new type of group.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public Group NewGroup(
    ElementSet elements
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")> _
Public Function NewGroup ( _
    elements As ElementSet _
) As Group
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call NewGroup(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public:
Group^ NewGroup(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements which will be made into the new group.

Return Value

A new instance of a group containing the elements specified.

Remarks

  • The new group may contain more members than just the set input to this method. Elements which are closely connected with the inputs (such as sketch and sketch plane) will also be added to the group.
  • Initially the group will have a generic name, such as Group 1. This can be changed by changing the name of the group type as follows: newGroup.GroupType.Name = newName.
  • If a newly-created element is being added to a group, calling document.Regenerate() may be needed to avoid a warning visible in the UI that the group has changed outside group edit mode.

Examples

CopyC#
Group group = null;
UIDocument uidoc = new UIDocument(document);
ElementSet selection = uidoc.Selection.Elements;
if (selection.Size > 0)
{
    // Group all selected elements
    group = document.Create.NewGroup(selection);

}
CopyVB.NET
Dim group As Group = Nothing
Dim uidoc As New UIDocument(document)
Dim selection As ElementSet = uidoc.Selection.Elements
If selection.Size > 0 Then
    ' Group all selected elements

    group = document.Create.NewGroup(selection)
Else

See Also

ItemFactoryBase Class
NewGroup Overload
Autodesk.Revit.Creation Namespace


NewLevel Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewLevel Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level NewLevel(
    double elevation
)
Visual Basic
Public Function NewLevel ( _
    elevation As Double _
) As Level
Visual C++
public:
Level^ NewLevel(
    double elevation
)

Parameters

elevation
Type: System..::..Double
The elevation to apply to the new level.

Return Value

The newly created level.

Remarks

Default level attributes will apply to this new model.

Examples

CopyC#
Level CreateLevel(Autodesk.Revit.DB.Document document)
{
    // The elevation to apply to the new level
    double elevation = 20.0;

    // Begin to create a level
    Level level = document.Create.NewLevel(elevation);
    if (null == level)
    {
        throw new Exception("Create a new level failed.");
    }

    // Change the level name
    level.Name = "New level";

    return level;
}
CopyVB.NET
Function CreateLevel(ByVal document As Autodesk.Revit.DB.Document) As Level
    ' The elevation to apply to the new level
    Dim elevation As Double = 20

    ' Begin to create a level
    Dim level As Level = document.Create.NewLevel(elevation)
    If level Is Nothing Then
        Throw New Exception("Create a new level failed.")
    End If

    ' Change the level name
    level.Name = "New level"

    Return level
End Function

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurve Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewModelCurve Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurve NewModelCurve(
    Curve geometryCurve,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewModelCurve ( _
    geometryCurve As Curve, _
    sketchPlane As SketchPlane _
) As ModelCurve
Visual C++
public:
ModelCurve^ NewModelCurve(
    Curve^ geometryCurve,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurve
Type: Autodesk.Revit.DB..::..Curve
The internal geometry curve for model line.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane this new model line resides in.

Return Value

If successful a new model line element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Different type of model curve element will be returned according to the type of geometry curve.

Examples

CopyC#
// get handle to application from document
Autodesk.Revit.ApplicationServices.Application application = document.Application;

// Create a geometry line in Revit application
XYZ startPoint = new XYZ(0, 0, 0);
XYZ endPoint = new XYZ(10, 10, 0);
Line geomLine = application.Create.NewLine(startPoint, endPoint, true);

// Create a geometry arc in Revit application
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc geomArc = application.Create.NewArc(end0, end1, pointOnCurve);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(1, 1, 0);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// Create a sketch plane in current document
SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

// Create a ModelLine element using the created geometry line and sketch plane
ModelLine line = document.Create.NewModelCurve(geomLine, sketch) as ModelLine;

// Create a ModelArc element using the created geometry arc and sketch plane
ModelArc arc = document.Create.NewModelCurve(geomArc, sketch) as ModelArc;
CopyVB.NET
' get handle to application from document
Dim application As Autodesk.Revit.ApplicationServices.Application = document.Application

' Create a geometry line in Revit application
Dim startPoint As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim endPoint As New Autodesk.Revit.DB.XYZ(10, 10, 0)
Dim geomLine As Line = application.Create.NewLine(startPoint, endPoint, True)

' Create a geometry arc in Revit application
Dim end0 As New Autodesk.Revit.DB.XYZ(1, 0, 0)
Dim end1 As New Autodesk.Revit.DB.XYZ(10, 10, 10)
Dim pointOnCurve As New Autodesk.Revit.DB.XYZ(10, 0, 0)
Dim geomArc As Arc = application.Create.NewArc(end0, end1, pointOnCurve)

' Create a geometry plane in Revit application
Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.DB.XYZ(1, 1, 0)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

' Create a sketch plane in current document
Dim sketch As SketchPlane = document.Create.NewSketchPlane(geomPlane)

' Create a ModelLine element using the created geometry line and sketch plane
Dim line As ModelLine = TryCast(document.Create.NewModelCurve(geomLine, sketch), ModelLine)

' Create a ModelArc element using the created geometry arc and sketch plane
Dim arc As ModelArc = TryCast(document.Create.NewModelCurve(geomArc, sketch), ModelArc)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewModelCurveArray Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewModelCurveArray Method
ItemFactoryBase Class See Also Send Feedback
Creates an array of new model line elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray NewModelCurveArray(
    CurveArray geometryCurveArray,
    SketchPlane sketchPlane
)
Visual Basic
Public Function NewModelCurveArray ( _
    geometryCurveArray As CurveArray, _
    sketchPlane As SketchPlane _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ NewModelCurveArray(
    CurveArray^ geometryCurveArray,
    SketchPlane^ sketchPlane
)

Parameters

geometryCurveArray
Type: Autodesk.Revit.DB..::..CurveArray
An array containing the internal geometry curves for model lines.
sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane

Return Value

If successful an array of new model line elements. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in the plane

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewReferencePlane Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ cutVec,
    View pView
)
Visual Basic
Public Function NewReferencePlane ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    cutVec As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ cutVec,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::..XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::..XYZ
The free end applied to reference plane.
cutVec
Type: Autodesk.Revit.DB..::..XYZ
The cut vector apply to reference plane, should perpendicular to the vector (bubbleEnd-freeEnd).
pView
Type: Autodesk.Revit.DB..::..View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Define data for reference plane creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Cut vector should be perpendicular to bubbleEnd-freeEnd vector
XYZ cutVec = new XYZ(0, 0, 1);  // cut vector applied to reference plane

// Create the reference plane, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView);
CopyVB.NET
' Define data for reference plane creation
Dim bubbleEnd As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.DB.XYZ(-5, 0, 0)
' free end applied to reference plane
' Cut vector should be perpendicular to bubbleEnd-freeEnd vector
Dim cutVec As New Autodesk.Revit.DB.XYZ(0, 0, 1)
' cut vector applied to reference plane
' Create the reference plane, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane(bubbleEnd, freeEnd, cutVec, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewReferencePlane2 Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewReferencePlane2 Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new instance of ReferencePlane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePlane NewReferencePlane2(
    XYZ bubbleEnd,
    XYZ freeEnd,
    XYZ thirdPnt,
    View pView
)
Visual Basic
Public Function NewReferencePlane2 ( _
    bubbleEnd As XYZ, _
    freeEnd As XYZ, _
    thirdPnt As XYZ, _
    pView As View _
) As ReferencePlane
Visual C++
public:
ReferencePlane^ NewReferencePlane2(
    XYZ^ bubbleEnd,
    XYZ^ freeEnd,
    XYZ^ thirdPnt,
    View^ pView
)

Parameters

bubbleEnd
Type: Autodesk.Revit.DB..::..XYZ
The bubble end applied to reference plane.
freeEnd
Type: Autodesk.Revit.DB..::..XYZ
The free end applied to reference plane.
thirdPnt
Type: Autodesk.Revit.DB..::..XYZ
A third point needed to define the reference plane.
pView
Type: Autodesk.Revit.DB..::..View
The specific view apply to the Reference plane.

Return Value

The newly created reference plane.

Examples

CopyC#
// Build now data before creation
XYZ bubbleEnd = new XYZ(1, 0, 0);   // bubble end applied to reference plane
XYZ freeEnd = new XYZ(-5, 0, 0);    // free end applied to reference plane
// Third point should not be on the bubbleEnd-freeEnd line
XYZ thirdPnt = new XYZ(0, 15, 0);   // 3rd point to define reference plane

// Create the reference plane in X-Y, applying the active view
ReferencePlane refPlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView);
CopyVB.NET
' Build now data before creation
Dim bubbleEnd As New Autodesk.Revit.DB.XYZ(1, 0, 0)
' bubble end applied to reference plane
Dim freeEnd As New Autodesk.Revit.DB.XYZ(-5, 0, 0)
' free end applied to reference plane
' Third point should not be on the bubbleEnd-freeEnd line
Dim thirdPnt As New Autodesk.Revit.DB.XYZ(0, 15, 0)
' 3rd point to define reference plane
' Create the reference plane in X-Y, applying the active view
Dim refPlane As ReferencePlane = document.Create.NewReferencePlane2(bubbleEnd, freeEnd, thirdPnt, document.ActiveView)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewSketchPlane Method

[image] [image]

Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane.

Overload List

 | Name | Description
Public method | NewSketchPlane(PlanarFace) | Creates a new sketch plane on a planar face of existing geometry.
Public method | NewSketchPlane(Plane) | Creates a new sketch plane from an arbitrary geometric plane.
Public method | NewSketchPlane(Reference) | Creates a new sketch plane on a reference to existing planar geometry.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (PlanarFace)

[image]

Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method (PlanarFace)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a planar face of existing geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    PlanarFace planarFace
)
Visual Basic
Public Function NewSketchPlane ( _
    planarFace As PlanarFace _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    PlanarFace^ planarFace
)

Parameters

planarFace
Type: Autodesk.Revit.DB..::..PlanarFace
The geometry planar face to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is nullNothingnullptra null reference (Nothing in Visual Basic), or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (Plane)

[image]

Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method (Plane)
ItemFactoryBase Class Example See Also Send Feedback
Creates a new sketch plane from an arbitrary geometric plane.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Plane geometryPlane
)
Visual Basic
Public Function NewSketchPlane ( _
    geometryPlane As Plane _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Plane^ geometryPlane
)

Parameters

geometryPlane
Type: Autodesk.Revit.DB..::..Plane
The geometry plane to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Examples

CopyC#
public static SketchPlane CreateSketchPlane(Autodesk.Revit.DB.Document document, Plane plane)
{
    SketchPlane sketchPlane = null;

    // create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane);

    // throw exception if creation failed
    if (null == sketchPlane)
    {
        throw new Exception("Create the sketch plane failed.");
    }

    return sketchPlane;
}
CopyVB.NET
Public Shared Function CreateSketchPlane(ByVal document As Autodesk.Revit.DB.Document, ByVal plane As Plane) As SketchPlane
    Dim sketchPlane As SketchPlane = Nothing

    ' create a sketch plane using Geometry.Plane
    sketchPlane = document.FamilyCreate.NewSketchPlane(plane)

    ' throw exception if creation failed
    If sketchPlane Is Nothing Then
        Throw New Exception("Create the sketch plane failed.")
    End If

    Return sketchPlane
End Function

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewSketchPlane Method (Reference)

[image]

Revit 2013 API
ItemFactoryBase..::..NewSketchPlane Method (Reference)
ItemFactoryBase Class See Also Send Feedback
Creates a new sketch plane on a reference to existing planar geometry.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane NewSketchPlane(
    Reference planarFaceReference
)
Visual Basic
Public Function NewSketchPlane ( _
    planarFaceReference As Reference _
) As SketchPlane
Visual C++
public:
SketchPlane^ NewSketchPlane(
    Reference^ planarFaceReference
)

Parameters

planarFaceReference
Type: Autodesk.Revit.DB..::..Reference
The planar face reference to locate sketch plane.

Return Value

If successful a new sketch plane will be returned. Otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is an invalid object, or reference of the argument is nullNothingnullptra null reference (Nothing in Visual Basic), or the host of this face is invalid.

See Also

ItemFactoryBase Class
NewSketchPlane Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method

[image] [image]

Revit 2013 API
ItemFactoryBase..::..NewTextNote Method
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object.

Overload List

 | Name | Description
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Creates a new TextNote object without a leader.
Public method | NewTextNote(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Creates a new text note with a single leader.

See Also

ItemFactoryBase Class
ItemFactoryBase Members
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2013 API
ItemFactoryBase..::..NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new TextNote object without a leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any one of pView, origin, baseVec, upVec, strText is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input lineWidth is not a finite number.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input textAlign is not a valid TextAlignFlags or it is not a valid bitwise OR of the align flags.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2013 API
ItemFactoryBase..::..NewTextNote Method (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
ItemFactoryBase Class See Also Send Feedback
Creates a new text note with a single leader.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNote NewTextNote(
    View pView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic
Public Function NewTextNote ( _
    pView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
) As TextNote
Visual C++
public:
TextNote^ NewTextNote(
    View^ pView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::..TextNoteLeaderStyles
The style of the leader for the note.
leaderEnd
Type: Autodesk.Revit.DB..::..XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::..XYZ
The elbow point for the leader.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

Return Value

If successful, a TextNote object is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when (1) Any one of pView, origin, baseVec, upVec, strText is nullNothingnullptra null reference (Nothing in Visual Basic). (2)leaderEnd is nullNothingnullptra null reference (Nothing in Visual Basic) when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE. (3)leaderElbow is nullNothingnullptra null reference (Nothing in Visual Basic) when leaderStyle == Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when lineWidth is not a finite number.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when (1) textAlign is not a valid TextAlignFlags or it is not a valid bitwise OR of TextAlignFlags. (2) leaderStyle is not a valid TextNoteLeaderTypes or leaderType is not a valid TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the regeneration fails when creating the text note.

See Also

ItemFactoryBase Class
NewTextNote Overload
Autodesk.Revit.Creation Namespace


NewTextNotes Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewTextNotes Method
ItemFactoryBase Class See Also Send Feedback
Creates TextNotes with the specified data.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public ElementSet NewTextNotes(
    List<TextNoteCreationData> dataList
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")> _
Public Function NewTextNotes ( _
    dataList As List(Of TextNoteCreationData) _
) As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call NewTextNote() instead.  Create each TextNote in a loop and call Document.Regenerate() or Transaction.Commit() after the loop exits.")]
public:
ElementSet^ NewTextNotes(
    List<TextNoteCreationData^>^ dataList
)

Parameters

dataList
Type: System.Collections.Generic..::..List<(Of <(<'TextNoteCreationData>)>)>
A list of TextNoteCreationData which wraps the creation arguments of the TextNotes to be created.

Return Value

If the creation is successful an ElementSet which contains the TextNotes should be returned, otherwise Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

Remarks

This batch creation method is not supported in VSTA for Revit 2010.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when (1) Any one of theView, origin, baseVec, upVec, strText in TextNoteCreationData is nullNothingnullptra null reference (Nothing in Visual Basic). (2) Any one of leaderEnd is nullNothingnullptra null reference (Nothing in Visual Basic) in TextNoteCreationData when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE . (3) Any one of leaderElbow is nullNothingnullptra null reference (Nothing in Visual Basic) TextNoteCreationData when leaderStyle == Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_TWO_SEG_LINE.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when one lineWidth in textNoteCreationData is not a finite number.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when (1) Any one textAlign in TextNoteCreationData is not a valid TextAlignFlags or it is not a valid bitwise OR of TextAlignFlags. (2) Any one leaderStyle in TextNoteCreationData is not a valid TextNoteLeaderTypes or any one leaderType in TextNoteCreationData is not a valid TextNoteLeaderTypes when leaderStyle != Autodesk::Revit::DB::TextNoteLeaderStyles::LCS_NONE
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the phase is invalid or regeneration fails at the end of the batch creation.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewView3D Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewView3D Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new 3D view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")]
public View3D NewView3D(
    XYZ viewDirection
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")> _
Public Function NewView3D ( _
    viewDirection As XYZ _
) As View3D
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call View3D.CreateIsometric() instead.")]
public:
View3D^ NewView3D(
    XYZ^ viewDirection
)

Parameters

viewDirection
Type: Autodesk.Revit.DB..::..XYZ
The view direction - the vector pointing from the eye towards the model.

Return Value

The newly created 3D view.

Examples

CopyC#
// Create a new View3D
XYZ direction = new XYZ(1, 1, 1);
View3D view3D = document.Create.NewView3D(direction);
if (null == view3D)
{
    throw new Exception("Failed to create new View3D");
}
CopyVB.NET
' Create a new View3D
Dim direction As New Autodesk.Revit.DB.XYZ(1, 1, 1)
Dim view3D As View3D = document.Create.NewView3D(direction)
If view3D Is Nothing Then
    Throw New Exception("Failed to create new View3D")
End If

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewPlan Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewViewPlan Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a plan view based on the specified level.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")]
public ViewPlan NewViewPlan(
    string pViewName,
    Level pLevel,
    ViewPlanType viewType
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")> _
Public Function NewViewPlan ( _
    pViewName As String, _
    pLevel As Level, _
    viewType As ViewPlanType _
) As ViewPlan
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call ViewPlan.Create() instead.")]
public:
ViewPlan^ NewViewPlan(
    String^ pViewName,
    Level^ pLevel,
    ViewPlanType viewType
)

Parameters

pViewName
Type: System..::..String
The name for the new plan view, must be unique or nullNothingnullptra null reference (Nothing in Visual Basic).
pLevel
Type: Autodesk.Revit.DB..::..Level
The level on which the plan view is to be associated.
viewType
Type: Autodesk.Revit.DB..::..ViewPlanType
The type of plan view to be created.

Return Value

if successful, a new plan view object within the project, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

if pViewName is nullNothingnullptra null reference (Nothing in Visual Basic), the pLevel's name will be used as the new plan view's name.

Examples

CopyC#
// Create a Level and a Floor Plan based on it
 double elevation = 10.0;
 Level level1 = document.Create.NewLevel(elevation);
 ViewPlan floorView = document.Create.NewViewPlan(null, level1, ViewPlanType.FloorPlan);

 // Create another Level and a Ceiling Plan based on it
 elevation += 10.0;
 Level level2 = document.Create.NewLevel(elevation);
 ViewPlan ceilingView = document.Create.NewViewPlan(null, level2, ViewPlanType.CeilingPlan);
CopyVB.NET
' Create a Level and a Floor Plan based on it
Dim elevation As Double = 10
Dim level1 As Level = document.Create.NewLevel(elevation)
Dim floorView As ViewPlan = document.Create.NewViewPlan(Nothing, level1, ViewPlanType.FloorPlan)

' Create another Level and a Ceiling Plan based on it
elevation += 10
Dim level2 As Level = document.Create.NewLevel(elevation)
Dim ceilingView As ViewPlan = document.Create.NewViewPlan(Nothing, level2, ViewPlanType.CeilingPlan)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the name is not unique

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


NewViewSection Method

[image]

Revit 2013 API
ItemFactoryBase..::..NewViewSection Method
ItemFactoryBase Class Example See Also Send Feedback
Creates a new section view.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")]
public ViewSection NewViewSection(
    BoundingBoxXYZ box
)
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")> _
Public Function NewViewSection ( _
    box As BoundingBoxXYZ _
) As ViewSection
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call ViewSection.CreateDetail() instead.")]
public:
ViewSection^ NewViewSection(
    BoundingBoxXYZ^ box
)

Parameters

box
Type: Autodesk.Revit.DB..::..BoundingBoxXYZ
The view volume of the section will correspond geometrically to the specified bounding box.

Return Value

The newly created section view.

Remarks

The view's forward direction will correspond to the Z direction of the box, and the view's up direction will correspond to the Y direction of the box. The right hand direction of the view will be computed so that (right, up, forward) will form a left-handed coordinate system. The resulting view will be cropped, and far clipping will be active.

Examples

CopyC#
// Get a BoundingBoxXYZ instance from Revit
BoundingBoxXYZ box = document.ActiveView.CropBox;
if (null == box)
{
    throw new Exception("No BoundingBoxXYZ instance found.");
}

// Create a new view section.
ViewSection viewSection = document.Create.NewViewSection(box);
CopyVB.NET
' Get a BoundingBoxXYZ instance from Revit
Dim box As BoundingBoxXYZ = document.ActiveView.CropBox
If box Is Nothing Then
    Throw New Exception("No BoundingBoxXYZ instance found.")
End If

' Create a new view section.
Dim viewSection As ViewSection = document.Create.NewViewSection(box)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


PlaceGroup Method

[image]

Revit 2013 API
ItemFactoryBase..::..PlaceGroup Method
ItemFactoryBase Class See Also Send Feedback
Place an instance of a Model Group into the Autodesk Revit document, using a location and a group type.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Group PlaceGroup(
    XYZ location,
    GroupType groupType
)
Visual Basic
Public Function PlaceGroup ( _
    location As XYZ, _
    groupType As GroupType _
) As Group
Visual C++
public:
Group^ PlaceGroup(
    XYZ^ location,
    GroupType^ groupType
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The physical location where the group is to be placed.
groupType
Type: Autodesk.Revit.DB..::..GroupType
A GroupType object that represents the type of group that is to be placed.

Return Value

If creation was successful then an instance to the new group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method is used to place a new instance of an existing group type within the document. The group's origin will placed at the point specified by the location. All group types within the document can be found by iterating over the document and looking for elements of type Autodesk.Revit.Symbols.GroupType.

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ItemFactoryBase Properties

[image] [image]

Revit 2013 API
ItemFactoryBase Properties
ItemFactoryBase Class See Also Send Feedback

The ItemFactoryBase type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ItemFactoryBase Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Class

[image]

Revit 2013 API
ProfiledWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProfiledWallCreationData
Visual Basic
Public Class ProfiledWallCreationData
Visual C++
public ref class ProfiledWallCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..ProfiledWallCreationData

See Also

ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Members

[image] [image]

Revit 2013 API
ProfiledWallCreationData Members
ProfiledWallCreationData Class Constructors Methods See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | ProfiledWallCreationData(CurveArray, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
Public method | ProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
Public method | ProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Initializes a new instance of the ProfiledWallCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor

[image] [image]

Revit 2013 API
ProfiledWallCreationData Constructor
ProfiledWallCreationData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ProfiledWallCreationData(CurveArray, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
Public method | ProfiledWallCreationData(CurveArray, WallType, Level, Boolean) | Initializes a new instance of the ProfiledWallCreationData class
Public method | ProfiledWallCreationData(CurveArray, WallType, Level, Boolean, XYZ) | Initializes a new instance of the ProfiledWallCreationData class

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Members
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, Boolean)

[image]

Revit 2013 API
ProfiledWallCreationData Constructor (CurveArray, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    bool structural
)
Visual Basic
Public Sub New ( _
    profile As CurveArray, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)

[image]

Revit 2013 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural
)
Visual Basic
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)

[image]

Revit 2013 API
ProfiledWallCreationData Constructor (CurveArray, WallType, Level, Boolean, XYZ)
ProfiledWallCreationData Class See Also Send Feedback
Initializes a new instance of the ProfiledWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProfiledWallCreationData(
    CurveArray profile,
    WallType wallType,
    Level level,
    bool structural,
    XYZ normal
)
Visual Basic
Public Sub New ( _
    profile As CurveArray, _
    wallType As WallType, _
    level As Level, _
    structural As Boolean, _
    normal As XYZ _
)
Visual C++
public:
ProfiledWallCreationData(
    CurveArray^ profile,
    WallType^ wallType,
    Level^ level,
    bool structural,
    XYZ^ normal
)

Parameters

profile
Type: Autodesk.Revit.DB..::..CurveArray
An array of planar lines and arcs that represent the vertical profile of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered.

See Also

ProfiledWallCreationData Class
ProfiledWallCreationData Overload
Autodesk.Revit.Creation Namespace


ProfiledWallCreationData Methods

[image] [image]

Revit 2013 API
ProfiledWallCreationData Methods
ProfiledWallCreationData Class See Also Send Feedback

The ProfiledWallCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProfiledWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Class

[image]

Revit 2013 API
RectangularWallCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Wall for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RectangularWallCreationData
Visual Basic
Public Class RectangularWallCreationData
Visual C++
public ref class RectangularWallCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..RectangularWallCreationData

See Also

RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Members

[image] [image]

Revit 2013 API
RectangularWallCreationData Members
RectangularWallCreationData Class Constructors Methods See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | RectangularWallCreationData(Curve, Level, Boolean) | Initializes a new instance of the RectangularWallCreationData class
Public method | RectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Initializes a new instance of the RectangularWallCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor

[image] [image]

Revit 2013 API
RectangularWallCreationData Constructor
RectangularWallCreationData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangularWallCreationData(Curve, Level, Boolean) | Initializes a new instance of the RectangularWallCreationData class
Public method | RectangularWallCreationData(Curve, WallType, Level, Double, Double, Boolean, Boolean) | Initializes a new instance of the RectangularWallCreationData class

See Also

RectangularWallCreationData Class
RectangularWallCreationData Members
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, Level, Boolean)

[image]

Revit 2013 API
RectangularWallCreationData Constructor (Curve, Level, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    Level level,
    bool structural
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    level As Level, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    Level^ level,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)

[image]

Revit 2013 API
RectangularWallCreationData Constructor (Curve, WallType, Level, Double, Double, Boolean, Boolean)
RectangularWallCreationData Class See Also Send Feedback
Initializes a new instance of the RectangularWallCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularWallCreationData(
    Curve curve,
    WallType wallType,
    Level level,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    wallType As WallType, _
    level As Level, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
)
Visual C++
public:
RectangularWallCreationData(
    Curve^ curve,
    WallType^ wallType,
    Level^ level,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallType
Type: Autodesk.Revit.DB..::..WallType
A wall type to be used by the new wall instead of the default type.
level
Type: Autodesk.Revit.DB..::..Level
The level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall.
offset
Type: System..::..Double
An offset distance, in feet from the specified baseline. The wall will be placed that distance from the baseline.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

See Also

RectangularWallCreationData Class
RectangularWallCreationData Overload
Autodesk.Revit.Creation Namespace


RectangularWallCreationData Methods

[image] [image]

Revit 2013 API
RectangularWallCreationData Methods
RectangularWallCreationData Class See Also Send Feedback

The RectangularWallCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangularWallCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Class

[image]

Revit 2013 API
RoomCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of Room for batch creation.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013.")]
public class RoomCreationData
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013.")> _
Public Class RoomCreationData
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013.")]
public ref class RoomCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..RoomCreationData

See Also

RoomCreationData Members
Autodesk.Revit.Creation Namespace


RoomCreationData Members

[image] [image]

Revit 2013 API
RoomCreationData Members
RoomCreationData Class Constructors Methods Properties See Also Send Feedback

The RoomCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | RoomCreationData | Initializes a new instance of the RoomCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Constructor

[image]

Revit 2013 API
RoomCreationData Constructor
RoomCreationData Class See Also Send Feedback
Initializes a new instance of the RoomCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomCreationData(
    Level level,
    UV point
)
Visual Basic
Public Sub New ( _
    level As Level, _
    point As UV _
)
Visual C++
public:
RoomCreationData(
    Level^ level,
    UV^ point
)

Parameters

level
Type: Autodesk.Revit.DB..::..Level
- The level on which the room is to exist.
point
Type: Autodesk.Revit.DB..::..UV
A 2D point the dictates the location on that specified level.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Methods

[image] [image]

Revit 2013 API
RoomCreationData Methods
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


RoomCreationData Properties

[image] [image]

Revit 2013 API
RoomCreationData Properties
RoomCreationData Class See Also Send Feedback

The RoomCreationData type exposes the following members.

Properties

 | Name | Description
Public property | TagPoint | Get or set the location of room tag.

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TagPoint Property

[image]

Revit 2013 API
RoomCreationData..::..TagPoint Property
RoomCreationData Class See Also Send Feedback
Get or set the location of room tag.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV TagPoint { get; set; }
Visual Basic
Public Property TagPoint As UV
    Get
    Set
Visual C++
public:
property UV^ TagPoint {
    UV^ get ();
    void set (UV^ value);
}

See Also

RoomCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Class

[image]

Revit 2013 API
TextNoteCreationData Class
Members See Also Send Feedback
A class which wraps the arguments of TextNote for batch creation

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextNoteCreationData
Visual Basic
Public Class TextNoteCreationData
Visual C++
public ref class TextNoteCreationData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Creation..::..TextNoteCreationData

See Also

TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Members

[image] [image]

Revit 2013 API
TextNoteCreationData Members
TextNoteCreationData Class Constructors Methods See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Initializes a new instance of the TextNoteCreationData class
Public method | TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Initializes a new instance of the TextNoteCreationData class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor

[image] [image]

Revit 2013 API
TextNoteCreationData Constructor
TextNoteCreationData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String) | Initializes a new instance of the TextNoteCreationData class
Public method | TextNoteCreationData(View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String) | Initializes a new instance of the TextNoteCreationData class

See Also

TextNoteCreationData Class
TextNoteCreationData Members
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)

[image]

Revit 2013 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    string strText
)
Visual Basic
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)

[image]

Revit 2013 API
TextNoteCreationData Constructor (View, XYZ, XYZ, XYZ, Double, TextAlignFlags, TextNoteLeaderTypes, TextNoteLeaderStyles, XYZ, XYZ, String)
TextNoteCreationData Class See Also Send Feedback
Initializes a new instance of the TextNoteCreationData class

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteCreationData(
    View theView,
    XYZ origin,
    XYZ baseVec,
    XYZ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ leaderEnd,
    XYZ leaderElbow,
    string strText
)
Visual Basic
Public Sub New ( _
    theView As View, _
    origin As XYZ, _
    baseVec As XYZ, _
    upVec As XYZ, _
    lineWidth As Double, _
    textAlign As TextAlignFlags, _
    leaderType As TextNoteLeaderTypes, _
    leaderStyle As TextNoteLeaderStyles, _
    leaderEnd As XYZ, _
    leaderElbow As XYZ, _
    strText As String _
)
Visual C++
public:
TextNoteCreationData(
    View^ theView,
    XYZ^ origin,
    XYZ^ baseVec,
    XYZ^ upVec,
    double lineWidth,
    TextAlignFlags textAlign,
    TextNoteLeaderTypes leaderType,
    TextNoteLeaderStyles leaderStyle,
    XYZ^ leaderEnd,
    XYZ^ leaderElbow,
    String^ strText
)

Parameters

theView
Type: Autodesk.Revit.DB..::..View
The view where the text note object will be visible.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the text note.
baseVec
Type: Autodesk.Revit.DB..::..XYZ
The horizontal direction for text in the text note.
upVec
Type: Autodesk.Revit.DB..::..XYZ
The vertical direction for text in the text note.
lineWidth
Type: System..::..Double
The width of the rectangle bounding the note text.
textAlign
Type: Autodesk.Revit.DB..::..TextAlignFlags
Flags indicating the alignment of the note. This should be a bitwise OR including one of TEF_ALIGN_TOP, TEF_ALIGN_MIDDLE and TEF_ALIGN_BOTTOM and one of TEF_ALIGN_LEFT, TEF_ALIGN_CENTER and TEF_ALIGN_RIGHT. The defaults for this flag are TEF_ALIGN_TOP | TEF_ALIGN_LEFT.
leaderType
Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes
The type and alignment of the leader for the note.
leaderStyle
Type: Autodesk.Revit.DB..::..TextNoteLeaderStyles
The style for the leader.
leaderEnd
Type: Autodesk.Revit.DB..::..XYZ
The end point for the leader.
leaderElbow
Type: Autodesk.Revit.DB..::..XYZ
The elbow point for the leader.
strText
Type: System..::..String
Text to display in the text note. Include new line characters to force a multiple line note to be created. Notes may also wrap automatically based on the width of the note rectangle.

See Also

TextNoteCreationData Class
TextNoteCreationData Overload
Autodesk.Revit.Creation Namespace


TextNoteCreationData Methods

[image] [image]

Revit 2013 API
TextNoteCreationData Methods
TextNoteCreationData Class See Also Send Feedback

The TextNoteCreationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteCreationData Class
Autodesk.Revit.Creation Namespace


Autodesk.Revit.DB Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB Namespace
Send Feedback

Classes

Class | Description
Public class ACADExportOptions
The base class for options used to export DWG and DXF format files.
Public class AdaptiveComponentFamilyUtils
An interface for Adaptive Component Instances.
Public class AdaptiveComponentInstanceUtils
An interface for Adaptive Component Instances.
Public class AddInId
Identifies an AddIn registered with Revit
Public class AnnotationSymbol
This object represents a symbol of the Generic Annotation.
Public class AnnotationSymbolType
An object that represents an annotation style.
Public class AnnotationSymbolTypeSet
A set that contains AnnotationSymbol types.
Public class AnnotationSymbolTypeSetIterator
An iterator to a AnnotationSymbol type set.
Public class APIObject
Supports all objects in the Autodesk Revit API hierarchy.
Public class Arc
A circular arc.
Public class Area
Provides access to the area topology in Autodesk Revit.
Public class AreaFilter
A filter used to match areas.
Public class AreaScheme
The area scheme associated with a particular area plan.
Public class AreaTag
Provides access to the area topology in Autodesk Revit.
Public class AreaTagFilter
A filter used to match area tags.
Public class AreaTagType
An object that represents an Area Tag style.
Public class AreaTagTypeSet
A set that contains areatag types.
Public class AreaTagTypeSetIterator
An iterator to a areatag type set.
Public class AssemblyDifference
Class that describes difference between two assemblies.
Public class AssemblyDifferenceConfiguration
The two assemblies being compared have different spatial configuration
Public class AssemblyDifferenceMemberCount
The two assemblies being compared have different number of members
Public class AssemblyDifferenceMemberDifference
The two assemblies being compared have different members
Public class AssemblyDifferenceNamingCategory
The two assemblies being compared have different naming categories
Public class AssemblyDifferenceNone
The two assemblies being compared are identical
Public class AssemblyInstance
Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.
Public class AssemblyMemberDifference
Class that describes difference between two assembly members
Public class AssemblyMemberDifferentCategory
The two assembly members being compared have different category
Public class AssemblyMemberDifferentGeometry
The two assembly members being compared have different geometry
Public class AssemblyMemberDifferentParameters
The two assembly members being compared have different parameters
Public class AssemblyMemberDifferentType
The two assembly members being compared have different type
Public class AssemblyType
Type for construction assembly elements.
Public class | AssemblyViewUtils
Public class BackgroundSettings
Represents the rendering background settings.
Public class BaseArray
An abstract base class that represents an array within the Revit project.
Public class BaseExportOptions
The base class for options used to export DWG, DXF and DGN format files.
Public class | BaseImportOptions
Public class BasePoint
Represents kinds of BasePoints.
Public class BasicFileInfo
Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
Public class BeamSystem
An object that represents a BeamSystem within the Autodesk Revit project.
Public class BeamSystemType
An object that specifies the type of a beam system in Autodesk Revit.
Public class | BeamSystemTypeSet
Public class | BeamSystemTypeSetIterator
Public class Binding
Binding objects are used to take a parameter definition and bind it to one or more categories.
Public class BindingMap
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.
Public class Blend
A blend solid or void form.
Public class BooleanOperationsUtils
These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.
Public class BoundaryConditions
An object that represents a force applied across an area.
Public class BoundarySegment
An object that represents a segment of an area boundary.
Public class BoundarySegmentArray
An array that contains boundary segments.
Public class BoundarySegmentArrayArray
An array that contains boundary segment arrays.
Public class BoundarySegmentArrayArrayIterator
An iterator to a array of boundary segment arrays.
Public class BoundarySegmentArrayIterator
An iterator to a boundary segment array.
Public class BoundingBoxContainsPointFilter
A filter used to match elements with a bounding box that contains the given point.
Public class BoundingBoxIntersectsFilter
A filter used to match elements with a bounding box that intersects the given Outline.
Public class BoundingBoxIsInsideFilter
A filter used to match elements with a bounding box that is contained by the given Outline.
Public class BoundingBoxUV
A two-dimensional rectangle, parallel to the coordinate axes.
Public class BoundingBoxXYZ
A three-dimensional rectangular box.
Public class BuildingPadType
Represents a specific type of Building Pad.
Public class BuildingSiteExportOptions
Building Site Export options.
Public class BuiltInFailures
Provides a container of all Revit built-in FailureDefinitionId instances.
Public class BuiltInFailures..::..AnalyticalModelFailures
Failures about AnalyticalModel.
Public class BuiltInFailures..::..ArrayFailures
Failures about Arrays.
Public class | BuiltInFailures..::..AssemblyFailures
Public class BuiltInFailures..::..AutoJoinFailures
Failures about AutoJoin.
Public class BuiltInFailures..::..AutoRouteFailures
Failures about AutoRoute.
Public class BuiltInFailures..::..BeamFailures
Failures about Beams.
Public class BuiltInFailures..::..BeamSystemFailures
Failures about BeamSystem.
Public class BuiltInFailures..::..BendFailures
Failures about Bends.
Public class BuiltInFailures..::..BlendFailures
Failures about Blend.
Public class BuiltInFailures..::..ColorFillFailures
Failures about ColorFill.
Public class BuiltInFailures..::..ColumnFailures
Failures about Columns.
Public class BuiltInFailures..::..ColumnInsideWallFailures
Failures description ColumnInsideWall
Public class | BuiltInFailures..::..ComponentRepeaterFailures
Public class | BuiltInFailures..::..ComponentRepeaterSlotFailures
Public class BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures
Failures about ConceptualEnergyAnalysisDB.
Public class BuiltInFailures..::..ConnectorFailures
Failures about Connector.
Public class BuiltInFailures..::..ConstraintFailures
Failures about Constraint.
Public class BuiltInFailures..::..ConversionFailures
Failures about conversion of data to a different format.
Public class BuiltInFailures..::..CopyMonitorFailures
Failures about CopyWatch.
Public class BuiltInFailures..::..CopyPasteFailures
Failures about CopyPasteFailures.
Public class BuiltInFailures..::..CreationFailures
Failures about CreationFailures.
Public class BuiltInFailures..::..CurtainGridFamilyFailures
Failures about CurtainGrid Family.
Public class BuiltInFailures..::..CurtainWallFailures
Failures about CurtainWall.
Public class BuiltInFailures..::..CurveByPointFailures
Failures about Curve By Point Element
Public class BuiltInFailures..::..CurveFailures
Failures about Curves and Curve-Driven Elements.
Public class BuiltInFailures..::..CutFailures
Failures about Cut.
Public class BuiltInFailures..::..CutterFailures
Failures about Cutter.
Public class BuiltInFailures..::..CuttingFailures
Failures about Cutting.
Public class BuiltInFailures..::..DatumPlaneFailures
Failures about DatumPlane.
Public class BuiltInFailures..::..DebugTabBindingFailures
Failures related to binding framework demo panel on Ribbon Debug Tab.
Public class BuiltInFailures..::..DecalFailures
Failures about Decal.
Public class BuiltInFailures..::..DesignOptionFailures
Failures about DesignOptionFailures.
Public class BuiltInFailures..::..DetailFailures
Failures about Detail.
Public class BuiltInFailures..::..DimensionFailures
Failures about DimensionFailures.
Public class | BuiltInFailures..::..DividedPathFailures
Public class BuiltInFailures..::..DividedSurfaceFailures
Failures about DividedSurface.
Public class BuiltInFailures..::..DocumentFailures
Failures about DocumentFailures.
Public class | BuiltInFailures..::..DPartFailures
Public class BuiltInFailures..::..DuctFailures
Failures about Duct.
Public class BuiltInFailures..::..EditingFailures
Failures about EditingFailures.
Public class BuiltInFailures..::..ElectricalFailures
Failures about Electricity.
Public class | BuiltInFailures..::..ElectricityFailures
Public class BuiltInFailures..::..ElementFailures
Failures about Elements.
Public class BuiltInFailures..::..ElementTypeFailures
Failures about ElementTypeFailures.
Public class BuiltInFailures..::..ElevationFailures
Failures about Elevation.
Public class BuiltInFailures..::..EnergyAnalysisFailures
Failures about EnergyAnalysis.
Public class BuiltInFailures..::..ExportFailures
Failures about ExportFailures.
Public class BuiltInFailures..::..ExtrusionFailures
Failures about Extrusions.
Public class | BuiltInFailures..::..FabricAreaFailures
Public class BuiltInFailures..::..FabricFailures
Failures about Fabric.
Public class BuiltInFailures..::..FaceSplitterFailures
Failures about FaceSplitter.
Public class BuiltInFailures..::..FamilyFailures
Failures about FamilyFailures.
Public class BuiltInFailures..::..FilledRegionFailures
Failures about FilledRegion.
Public class | BuiltInFailures..::..FloorFailures
Public class BuiltInFailures..::..FluidFailures
Failures about Fluid.
Public class BuiltInFailures..::..FormFailures
Failures about Form.
Public class BuiltInFailures..::..GeneralFailures
Failures about GeneralFailures.
Public class BuiltInFailures..::..GenericFailures
Generic failures that may apply to any Revit Element
Public class BuiltInFailures..::..GenericMEPFailures
Failures applicable to different mechanical, electrical and piping Elements.
Public class BuiltInFailures..::..GeometryFailures
Failures about GeometryFailures.
Public class BuiltInFailures..::..GridChainSketchFailures
Failures related to the GridChain sketch.
Public class BuiltInFailures..::..GridFailures
Failures about Grid.
Public class BuiltInFailures..::..GroupFailures
Failures related to groups and their behavior.
Public class BuiltInFailures..::..HostFinishFailures
Failures about HostFinish.
Public class BuiltInFailures..::..HostObjFailures
Failures about HostObj.
Public class | BuiltInFailures..::..HvacFailures
Public class BuiltInFailures..::..IlluminationFailures
Failures about Illumination.
Public class BuiltInFailures..::..ImageFailures
Failures about Image.
Public class BuiltInFailures..::..ImportFailures
Failures about ImportFailures.
Public class BuiltInFailures..::..InaccurateFailures
Failures about Inaccurate.
Public class BuiltInFailures..::..InfillFailures
Failures about Infill.
Public class BuiltInFailures..::..InterferenceFailures
Failures about Interference.
Public class BuiltInFailures..::..JoinElementsFailures
Failures about JoinElements.
Public class BuiltInFailures..::..KeynoteFailures
Failures about KeynoteFailures.
Public class | BuiltInFailures..::..KeynoteTagFailures
Public class BuiltInFailures..::..LegendFailures
Failures about Legend.
Public class BuiltInFailures..::..LevelFailures
Failures about Level.
Public class BuiltInFailures..::..LinkFailures
Failures about LinkFailures.
Public class BuiltInFailures..::..LoadFailures
Failures about Load.
Public class BuiltInFailures..::..LooseDimensionFailures
Failures about LooseDimension.
Public class BuiltInFailures..::..MassFailures
Failures about Mass.
Public class BuiltInFailures..::..MatchlineFailures
Failures about Matchline.
Public class BuiltInFailures..::..MechanicalFailures
Failures about HVAC.
Public class BuiltInFailures..::..MirrorFailures
Failures about Mirror.
Public class | BuiltInFailures..::..OffsetFacesCellLegacyFailures
Public class BuiltInFailures..::..OpeningFailures
Failures about Opening.
Public class | BuiltInFailures..::..OverlapFailure
Public class BuiltInFailures..::..OverlapFailures
Failures detected by overlap check.
Public class | BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures
Public class | BuiltInFailures..::..PartMakerMethodForMergePartFailures
Public class | BuiltInFailures..::..PartMakerMethodForWallFailures
Public class BuiltInFailures..::..PathFailures
Failures about Path.
Public class | BuiltInFailures..::..PerformanceFailures
Public class BuiltInFailures..::..PipingFailures
Failures about Pipes.
Public class BuiltInFailures..::..PlanRegionFailures
Failures about PlanRegion.
Public class BuiltInFailures..::..PointFailures
Failures about Point Element.
Public class BuiltInFailures..::..ProfileFailures
Failures about Profile.
Public class | BuiltInFailures..::..PropertySetElementFailures
Public class BuiltInFailures..::..RebarFailures
Failures about Rebar.
Public class BuiltInFailures..::..RebarShapeFailures
Failures about RebarShape.
Public class BuiltInFailures..::..RebarSystemFailures
Failures about RebarSystem.
Public class BuiltInFailures..::..RefPlaneFailures
Failures about RefPlane.
Public class BuiltInFailures..::..RegenFailures
Failures about RegenFailures.
Public class BuiltInFailures..::..RenderFailures
Failures about Render.
Public class BuiltInFailures..::..RevisionCloudFailures
Failures about RevisionCloud.
Public class BuiltInFailures..::..RevolutionFailures
Failures about Revolution.
Public class BuiltInFailures..::..RoofFailures
Failures about Roof.
Public class BuiltInFailures..::..RoomFailures
Failures about Room.
Public class BuiltInFailures..::..ScheduleViewFailures
Failures about Schedule.
Public class BuiltInFailures..::..SculptingFailures
Failures about Sculpting.
Public class BuiltInFailures..::..SectionViewFailures
Failures about Section.
Public class BuiltInFailures..::..SelectionFailures
Failures about Selections.
Public class BuiltInFailures..::..SheetFailures
Failures about Sheet.
Public class BuiltInFailures..::..SiteFailures
Failures about Site.
Public class BuiltInFailures..::..SiteImportFailures
Failures about SiteImport.
Public class BuiltInFailures..::..SketchFailures
Failures about Sketch.
Public class BuiltInFailures..::..SkylightFailures
Failures about Skylight.
Public class BuiltInFailures..::..SlabFailures
Failures about Slab.
Public class BuiltInFailures..::..SlabShapeFailures
Failures about SlabShape.
Public class BuiltInFailures..::..SlantedColumnFailures
Failures about SlantedColumn.
Public class BuiltInFailures..::..SpanDirectionSymbolFailures
Failures about SpanDirectionSymbol.
Public class BuiltInFailures..::..SplineFailures
Failures about Spline.
Public class BuiltInFailures..::..StairRampFailures
Failures about StairRamp.
Public class | BuiltInFailures..::..StructuralAssetFailure
Public class BuiltInFailures..::..SweepFailures
Failures about Sweep.
Public class BuiltInFailures..::..SweptBlendFailures
Failures about SweptBlend.
Public class | BuiltInFailures..::..SystemNavigatorFailures
Public class BuiltInFailures..::..SystemsFailures
Failures about System.
Public class BuiltInFailures..::..TagFailures
Failures about Tag.
Public class BuiltInFailures..::..TextFailures
Failures about Text.
Public class BuiltInFailures..::..TrussFailures
Failures about Truss.
Public class BuiltInFailures..::..ViewFailures
Failures about ViewFailures.
Public class BuiltInFailures..::..WallFailures
Failures about Wall.
Public class BuiltInFailures..::..WallJoinRoofFailures
Failures about WallJoinRoof.
Public class BuiltInFailures..::..WorksharingFailures
Failures about WorksharingFailures.
Public class CADExportOptions
Generic CAD Export options.
Public class CADLinkType
CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.
Public class Categories
The Categories object is a map that contains all the top-level Category objects within the Document.
Public class Category
Represents the category or subcategory to which an element belongs.
Public class CategoryNameMap
A map that contains a mapping of category name to its category object.
Public class CategoryNameMapIterator
An iterator to a category name map.
Public class CategorySet
A set that can contains Category objects.
Public class CategorySetIterator
An iterator to a category set.
Public class Ceiling
Represents a ceiling in Autodesk Revit.
Public class CeilingAndFloor
A base class that provides support for all ceiling and floor objects.
Public class CeilingType
Represents a ceiling type in Autodesk Revit.
Public class | ChangeType
Public class City
An object that contains geographical location information for a known city.
Public class CitySet
An set that contains cities.
Public class CitySetIterator
An iterator to a city set.
Public class Color
Represents a color in Autodesk Revit.
Public class ColorBackgroundSettings
Represents the rendering color background settings.
Public class ColumnAttachment
An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.
Public class CombinableElement
An element that can be added to a geometry combination.
Public class CombinableElementArray
An array that contains CombinableElement objects.
Public class CombinableElementArrayIterator
An iterator to an CombinableElement array.
Public class CompoundStructure
Describes the internal structure of a wall, floor, roof or ceiling.
Public class CompoundStructureLayer
Describes a single layer in a CompoundStructure.
Public class ConicalFace
A cone face of a 3d solid.
Public class Connector
A connector in an Autodesk Revit MEP project document.
Public class ConnectorElement
A base class that provides support for all connector elements occurring in families.
Public class ConnectorManager
Provides access to the Connector Manager
Public class ConnectorSet
A set that can contain any type of object.
Public class ConnectorSetIterator
An iterator to a set.
Public class Construction
Construction definition for Project Information.
Public class ContFooting
An object that represents a Continuous Footing within Autodesk Revit.
Public class ContFootingType
An object that specifies the type of a continuous footing in Autodesk Revit.
Public class ContFootingTypeSet
A set that contains ContFooting types.
Public class ContFootingTypeSetIterator
An iterator to a ContFooting type set.
Public class Control
A control in Autodesk Revit family document.
Public class CurtainCell
Represents a CurtainCell within Autodesk Revit.
Public class CurtainCellSet
A set that can contain any type of object.
Public class CurtainCellSetIterator Obsolete.
An iterator to a set.
Public class CurtainGrid
Represents a curtain grid element within Autodesk Revit.
Public class CurtainGridLine
Represents a CurtainGridLine within Autodesk Revit.
Public class CurtainGridSet
A set that can contain any type of object.
Public class CurtainGridSetIterator
An iterator to a set.
Public class CurtainSystem
Provides access to the CurtainSystem object in Autodesk Revit.
Public class CurtainSystemBase
Provides access to the CurtainSystemBase object in Autodesk Revit.
Public class CurtainSystemType
An object that represents CurtainSystem type.
Public class CurtainSystemTypeSet
A set that contains CurtainSystem types.
Public class CurtainSystemTypeSetIterator
An iterator to a CurtainSystem type set.
Public class Curve
A parametric curve.
Public class CurveArrArray
An array that can contain any type of object.
Public class CurveArrArrayIterator
An iterator to a array.
Public class CurveArray
An array that can contain curves.
Public class CurveArrayIterator
An iterator to a curve array.
Public class CurveByPoints
A curve interpolating two or more points.
Public class | CurveByPointsArray
Public class | CurveByPointsArrayIterator
Public class CurveByPointsUtils
A static class that contains methods for processing curves driven by points.
Public class | CurveElement
Public class | CurveElementFilter
Public class | CurveLoop
Public class CurveLoopIterator
An iterator to a curve loop.
Public class CurveLoopsProfile
Represents a curve loop based profile for sweep or swept blend elements.
Public class CylindricalFace
A cylinder face of a 3d solid.
Public class CylindricalHelix
A cylindrical helix.
Public class Definition
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.
Public class DefinitionBindingMap
A map that contains mappings of parameter definitions to parameter bindings.
Public class DefinitionBindingMapIterator
An iterator to a parameter definition to parameter bindings map.
Public class DefinitionFile
The DefinitionFile object represents a shared parameters file on disk.
Public class DefinitionGroup
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.
Public class DefinitionGroups
A specialized set of definition groups that allows creation of new groups.
Public class Definitions
A base class that supports the addition of new parameter definitions.
Public class DeleteElements
Deletes element(s) related to the failure.
Public class DesignOption
An element that represents a design alternative.
Public class DetailArc
Represents a DetailArc within Autodesk Revit.
Public class DetailCurve
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.
Public class DetailCurveArray
An array that can contain any type of object.
Public class DetailCurveArrayIterator
An iterator to a array.
Public class DetailElementOrderUtils
A utility class that arranges the draw order of the detail objects.
Public class DetailEllipse
Represents a DetailEllipse within Autodesk Revit.
Public class DetailLine
Represents a DetailLine within Autodesk Revit.
Public class DetailNurbSpline
Represents a DetailNurbSpline within Autodesk Revit.
Public class DGNExportOptions
The export options used by exporting DGN format file.
Public class DGNImportOptions
The import options used to import DGN format files.
Public class Dimension
An object that represents a dimension within the Revit project.
Public class DimensionSegment
A segment of a dimension within the Autodesk Revit project.
Public class DimensionSegmentArray
An array that can contain any number of DimensionSegment objects.
Public class DimensionSegmentArrayIterator
An iterator to an array of DimensionSegment objects..
Public class DimensionType
An object that represents a dimension style.
Public class DimensionTypeSet
A set that contains dimension types.
Public class DimensionTypeSetIterator
An iterator to a dimension type set.
Public class DividedPath
An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.
Public class DividedSurface
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.
Public class DividedSurfaceData
An interface to the divided surfaces on an element.
Public class Document
An object that represents an open Autodesk Revit project.
Public class DocumentPreviewSettings
Contains the settings related to the saving of preview images for a given document.
Public class DocumentSet
A set that can contain any documents.
Public class DocumentSetIterator
An iterator to a set of documents.
Public class DoubleArray
An array that contains doubles.
Public class DoubleArrayIterator
An iterator to an array of doubles.
Public class DWFExportOptions
DWF Export options.
Public class DWFXExportOptions
DWFX Export options.
Public class DWGExportOptions
The export options used by exporting DWG format file.
Public class DWGImportOptions
The import options used by importing DWG or DXF format file.
Public class DXFExportOptions
The export options used by exporting DXF format file.
Public class Edge
An edge of a 3d solid.
Public class EdgeArray
An array that contains edges.
Public class EdgeArrayArray
An array of edge arrays.
Public class EdgeArrayArrayIterator
An iterator to an array or edge arrays.
Public class EdgeArrayIterator
An iterator to an edge array.
Public class Element
Base class for most persistent data within a Revit document.
Public class ElementArray
An array that contains element objects.
Public class ElementArrayIterator
An iterator to an element array.
Public class ElementBinding
A base class for all types of binding that attach to an element.
Public class ElementCategoryFilter
A filter used to match elements by their category.
Public class ElementClassFilter
A filter used to match elements by their class.
Public class ElementDesignOptionFilter
A filter used to find elements contained within a particular design option.
Public class ElementFilter
A base class for a type of filter that accepts or rejects elements based upon criteria.
Public class ElementId
The ElementId object is used as a unique identification for an element within a single project.
Public class ElementIntersectsElementFilter
A filter to find elements that intersect the solid geometry of a given element.
Public class ElementIntersectsFilter
A base class for filters used to match elements which intersect with geometry.
Public class ElementIntersectsSolidFilter
A filter to find elements that intersect the given solid geometry.
Public class ElementIsCurveDrivenFilter
A filter used to match elements which are curve driven.
Public class ElementIsElementTypeFilter
A filter used to match elements which are ElementTypes.
Public class ElementLevelFilter
A filter used to match elements by their associated level.
Public class ElementLogicalFilter
A filter used to logically combine two or more filters.
Public class ElementMulticategoryFilter
A filter used to find elements whose category matches any of a given set of categories.
Public class | ElementMulticlassFilter
Public class ElementOwnerViewFilter
A filter used to match elements which are owned by a particular view.
Public class ElementParameterFilter
A filter used to match elements by one or more parameter filter rules.
Public class ElementPhaseStatusFilter
A filter used to match elements that have a given phase status on a given phase.
Public class ElementQuickFilter
A base class for a type of filter that operates on element records.
Public class ElementRecord
A record in the Revit database representing an element.
Public class ElementSet
A set that contains element objects.
Public class ElementSetIterator
An iterator to an element set.
Public class ElementSlowFilter
A base class for a type of filter that operates on expanded elements.
Public class ElementStructuralTypeFilter
A filter used to find elements matching a structural type.
Public class | ElementTransformUtils
Public class ElementType
Base class for all Types within Autodesk Revit.
Public class ElementWorksetFilter
A filter used to match elements which reside in a given workset.
Public class ElevationMarker
ElevationMarkers either host elevation ViewSection views or view references.
Public class Ellipse
A whole or partial ellipse.
Public class ExclusionFilter
A filter used to exclude a set of elements automatically.
Public class ExportDGNSettings
This element contains DGN export settings which are saved in a Revit document.
Public class ExportDWGSettings
This element contains DWG/DXF export settings which are saved in a Revit document.
Public class ExportUtils
This class provides utilities related to document export.
Public class ExternalDefinition
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.
Public class ExternalDefinitions
Supports the creation of new shared parameters definitions.
Public class | ExternalFileReference
Public class ExternalFileUtils
A utility class containing functions related to external file references. Elements which are external file references refer to files outside of the base .rvt file. Examples include Revit links, CAD links, the element which stores the location of the keynote file, and rendering decals.
Public class Extrusion
A extrusion solid or void form.
Public class ExtrusionAnalyzer
This geometry utility allows you to attempt to “fit” a given piece of geometry into the shape of an extrusion.
Public class ExtrusionRoof
Represents some kinds of Extrusion Roofs.
Public class Face
A face of a 3d solid.
Public class FaceArray
An array that contains faces.
Public class FaceArrayIterator
An iterator to a face array.
Public class FaceSplitter
Represents an element that splits a face.
Public class FacetingUtils
This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Public class FaceWall
A wall attached to a non-vertical massing face.
Public class FailureDefinition
Defines persistent information about a failure.
Public class | FailureDefinitionAccessor
Public class FailureDefinitionId
The unique identifier of a FailureDefinition.
Public class FailureDefinitionRegistry
The global registry for all FailureDefinitions in the Revit session.
Public class FailureHandlingOptions
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.
Public class FailureMessage
Represents a message describing a failure of an operation in Revit.
Public class FailureMessageAccessor
Restricted accessor for FailureMessage.
Public class FailureMessageKey
A unique key assigned to each posted failure message
Public class FailureResolution
Defines a resolution for a failure.
Public class FailuresAccessor
An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Public class Family
The Family object defines an entire family.
Public class FamilyBase
A base class for all Family objects.
Public class FamilyElementVisibility
Provides access to the visibility parameters of family elements in family document.
Public class FamilyInstance
This object represents a single instance of a family type, such as a single I beam.
Public class FamilyInstanceFilter
A filter used to find elements that are family instances of the given family symbol.
Public class FamilyManager
The family manager object to manage the family types and parameters in family document.
Public class FamilyParameter
The family parameter object.
Public class FamilyParameterSet
A set that contains FamilyParameter objects.
Public class FamilyParameterSetIterator
An iterator to a FamilyParameter set.
Public class FamilyPointLocation
This object represents a data corresponding to the point locations in a certain types Family Symbols (see examples listed below).
Public class FamilyPointPlacementReference
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).
Public class FamilySymbol
Represents a single Type within a Family.
Public class FamilySymbolFilter
A filter used to find all family symbols of the given family.
Public class FamilySymbolProfile
Represents a family symbol based profile for sweep or swept blend elements.
Public class FamilySymbolSet
A set that can contain family symbols.
Public class FamilySymbolSetIterator
An iterator to a family symbol set.
Public class FamilyThermalProperties
A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Public class FamilyType
The family type object provides read access to the values of family parameters for this type.
Public class FamilyTypeSet
A set that contains FamilyType objects.
Public class FamilyTypeSetIterator
An iterator to a FamilyType set.
Public class | FamilyUtils
Public class FBXExportOptions
3D-Studio Max (FBX) Export options.
Public class FilePath
This class represents a path on a disk or network location, but not a path to a Revit server location.
Public class FilledRegion
A filled region element.
Public class FilledRegionType
A filled region attributes element.
Public class FillGrid
Represents a grid line in a fill pattern.
Public class FillPattern
Represents a fill pattern object.
Public class FillPatternElement
An element that represents a fill pattern.
Public class FilterableValueProvider
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.
Public class FilterDoubleRule
A filter rule that operates on double-precision numeric values in a Revit project.
Public class FilteredElementCollector
This class is used to search, filter and iterate through a set of elements.
Public class FilteredElementIdIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Public class FilteredElementIterator
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.
Public class FilteredWorksetCollector
This class is used to search, filter and iterate through a set of worksets.
Public class FilteredWorksetIdIterator
An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.
Public class FilteredWorksetIterator
An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Public class | FilterElement
Public class FilterElementIdRule
A filter rule that operates on ElementId values in a Revit project.
Public class FilterIntegerRule
A filter rule that operates on integer values in a Revit project.
Public class FilterInverseRule
A filter rule that inverts the boolean values returned by the rule it contains.
Public class FilterNumericEquals
Tests whether numeric values from the document are equal to a certain value
Public class FilterNumericGreater
Tests whether numeric values from the document are greater than a certain value
Public class FilterNumericGreaterOrEqual
Tests whether numeric values from the document are greater than or equal to a certain value
Public class FilterNumericLess
Tests whether numeric values from the document are less than a certain value
Public class FilterNumericLessOrEqual
Tests whether numeric values from the document are less than or equal to a certain value
Public class FilterNumericRuleEvaluator
Base for all classes that compare numeric values from Revit to a user-supplied filter value.
Public class FilterNumericValueRule
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons
Public class FilterRule
Defines a boolean operation that can be used to cull elements from a document.
Public class FilterStringBeginsWith
Tests whether string values from the document begin with a certain string.
Public class FilterStringContains
Tests whether string values from the document contain a certain string.
Public class FilterStringEndsWith
Tests whether string values from the document end with a certain string.
Public class FilterStringEquals
Tests whether string values from the document match a certain string.
Public class FilterStringGreater
Tests whether string values from the document would sort after a certain string.
Public class FilterStringGreaterOrEqual
Tests whether string values from the document would sort after or match a certain string.
Public class FilterStringLess
Tests whether string values from the document would sort before a certain string.
Public class FilterStringLessOrEqual
Tests whether string values from the document would sort before or match a certain string.
Public class FilterStringRule
A filter rule that operates on string values in a Revit project.
Public class FilterStringRuleEvaluator
Base for all classes that compare string values from Revit to a user-supplied filter value
Public class FilterValueRule
A rule that filters on a particular value of an element.
Public class Floor
An object that represents a Floor within the Autodesk Revit project.
Public class FloorType
An object that specifies the type of a floor in Autodesk Revit.
Public class FloorTypeSet
A set that contains floor types.
Public class FloorTypeSetIterator
An iterator to a floor type set.
Public class FootPrintRoof
Represents kinds of FootPrintRoofs.
Public class Form
An object that represents a Form within the Autodesk Revit Massing Family.
Public class FormArray
An array that contains form objects.
Public class FormArrayIterator
An iterator to a form array.
Public class FormatOptions
Contains the Unit information of current user selection of Unit within the project.
Public class FormatUtils
A utility class capable of applying formats to values based on properties such as units.
Public class FormUtils
Define Form utility functions
Public class Frame
Represents a coordinate frame of reference.
Public class GBXMLExportOptions
Green-Building XML Export options.
Public class GBXMLImportOptions
Import options for Green-Building XML format.
Public class GenericForm
Provides access to the Generic Form model in Autodesk Revit.
Public class GenericFormSet
A set that can contain any type of object.
Public class GenericFormSetIterator
An iterator to a set.
Public class GenericImportOptions
Generic Import options.
Public class GeomCombination
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.
Public class GeomCombinationSet
A set that contains GeomCombination objects.
Public class GeomCombinationSetIterator
An iterator to a GeomCombination set.
Public class GeometryCreationUtilities
A utility that allows construction of basic solid shapes.
Public class GeometryElement
Geometric representation of an element.
Public class GeometryInstance
An instance of another element (symbol), specially positioned by this element.
Public class GeometryObject
The common base class for all geometric primitives.
Public class GeometryObjectArray
An array that contains geometry objects.
Public class GeometryObjectArrayIterator
An iterator to a geometry object array.
Public class GraphicsStyle
The graphics style instance in Autodesk Revit document.
Public class Grid
Represents a single grid line within Autodesk Revit.
Public class GridType
An object that represents a grid type.
Public class GridTypeSet
A set that contains grid types.
Public class GridTypeSetIterator
An iterator to a grid type set.
Public class Group
This object represents a group of elements within the project.
Public class GroupSet
An set that contains groups.
Public class GroupSetIterator
An iterator to a group set.
Public class GroupType
Represents a type of a user defined group.
Public class GuidEnum
Base class of all GUID-based enum classes.
Public class HermiteFace
A cubic hermite spline face of a 3d solid.
Public class HermiteSpline
A Hermite spline.
Public class HostedSweep
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.
Public class HostedSweepType
An object that represents the attributes for sweep host objects in Autodesk Revit.
Public class HostObjAttributes
An object that represents characteristics of several kinds of type.
Public class HostObject
A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.
Public class HostObjectUtils
These are generic host object utilities.
Public class IFCExportOptions
IFC Export options.
Public class ImageBackgroundSettings
Represents the rendering image background settings.
Public class ImageExportOptions
This class defines options for exporting views and sheets as an image.
Public class ImageImportOptions
Import options specific image (bitmap) formats.
Public class ImageView
Class for ImageView views
Public class ImportInstance
An element created during either import or link operation in Autodesk Revit.
Public class IndependentTag
Represents an IndependentTag within Autodesk Revit.
Public class InsertableObject
A base class you all types that are insertable.
Public class InSessionPrintSetting
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class InSessionViewSheetSet
Represents the in-session ViewSheetSet.
Public class Instance
The base class for all instance objects.
Public class InstanceArray
An array that contains instances.
Public class InstanceArrayIterator
An iterator to an instance array.
Public class InstanceBinding
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.
Public class InstanceVoidCutUtils
Utilities for cutting elements by unattached voids in family instances.
Public class InsulationLiningBase
Acts as the base class for duct insulation, pipe insulation and duct lining elements.
Public class InternalDefinition
This object represents a parameter definition in Autodesk Revit.
Public class InternalDefinitions
This object blocks attempts to create new internal definitions as they are not permitted.
Public class IntersectionResult
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.
Public class IntersectionResultArray
An array that can contain any type of object.
Public class IntersectionResultArrayIterator
An iterator to a array.
Public class LabelUtils
Used to obtain user-visible name for certain enums.
Public class LayoutRule
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.
Public class LayoutRuleClearSpacing
This class indicate the layout rule of a Beam System is Clear-Spacing.
Public class LayoutRuleFixedDistance
This class indicate the layout rule of a Beam System is Fixed-Distance.
Public class LayoutRuleFixedNumber
This class indicate the layout rule of a Beam System is Fixed-Number.
Public class LayoutRuleMaximumSpacing
This class indicate the layout rule of a Beam System is Max-Spacing.
Public class Leader
An object that represents a Leader within the Autodesk Revit project.
Public class LeaderArray
An array that can contain any number of leaders.
Public class LeaderArrayIterator
An iterator to an array of leaders.
Public class Level
Represents a Level line within Autodesk Revit.
Public class LevelType
An object that represents a Level type.
Public class LevelTypeSet
A set that contains level types.
Public class LevelTypeSetIterator
An iterator to a level type set.
Public class Line
A line in space.
Public class LineAndTextAttrSymbol
An object that represents a dimension style.
Public class LinearArray
An object that represents an Array created linearly within the Revit project.
Public class LinePattern
Represents a line pattern definition.
Public class LinePatternElement
An element that represents a line pattern.
Public class LinePatternSegment
Represents a segment in a line pattern.
Public class LinkElementId
LinkElementId represents an element in a linked document.
Public class Location
Provides location functionality for all elements.
Public class LocationCurve
Provides location functionality for all elements that are based upon a curve.
Public class LocationPoint
Provides location functionality for all elements that have a single insertion point.
Public class LogicalAndFilter
A filter that contains a set of filters. The filter passes when all filters in the set pass.
Public class LogicalOrFilter
A filter that contains a set of filters. The filter passes when any filter in the set passes.
Public class MassInstanceUtils
A static class that contains methods for processing curves driven by points.
Public class Material
Represents a material element within an Autodesk Revit project.
Public class MaterialSet
An set that contains materials.
Public class MaterialSetIterator Obsolete.
An iterator to a material set.
Public class MEPCurve
A curve object for duct or pipe blend elements.
Public class | MEPCurveType
Public class MEPModel
Supports all MEP models that are persistent within the Autodesk Revit project
Public class MEPSize
Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.
Public class MEPSystem
A system in the Autodesk Revit MEP product. Default constructor Default destructor
Public class MEPSystemType
A system type in the Autodesk Revit MEP product.
Public class Mesh
A triangular mesh.
Public class MeshArray
An array that contains meshes.
Public class MeshArrayIterator
An iterator to a mesh array.
Public class MeshTriangle
One triangle of a mesh.
Public class ModelArc
Represents a ModelArc within Autodesk Revit.
Public class ModelCurve
A model element that exists in 3D space and is visible in all views of a Revit project.
Public class ModelCurveArrArray
An array that can contain any type of object.
Public class ModelCurveArrArrayIterator
An iterator to a array.
Public class ModelCurveArray
An array that contains model curves.
Public class ModelCurveArrayIterator
An iterator to a model curve array.
Public class ModelEllipse
Represents a ModelEllipse within Autodesk Revit.
Public class ModelHermiteSpline
Represents a ModelHermiteSpline within Autodesk Revit.
Public class ModelLine
Represents a ModelLine within Autodesk Revit.
Public class ModelNurbSpline
Represents a ModelNurbSpline within Autodesk Revit.
Public class ModelPath
A path to a file stored on a disk or on a server.
Public class ModelPathUtils
Utility functions using ModelPaths
Public class ModelText
A model text element in an Autodesk Revit family document.
Public class ModelTextType
A model text type symbol in the Autodesk Revit Family document.
Public class Mullion
Represents a CurtainGrid within Autodesk Revit.
Public class MullionType
An object that represents a mullion type.
Public class MullionTypeSet
A set that contains mullion types.
Public class MullionTypeSetIterator
An iterator to a mullion type set.
Public class MultiSegmentGrid
This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.
Public class NumberSystem
An annotation that consists of a series of numeric tags attached to and describing a host element.
Public class NurbSpline
A nurb spline.
Public class ObjectFactory
For Internal Use Only.
Public class Opening
An opening in an Autodesk Revit project or family document.
Public class OpenOptions
This class contains options available for opening a document from disk.
Public class | OptionalFunctionalityUtils
Public class Options
User preferences for parsing of geometry.
Public class Outline
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.
Public class Panel
This object represents a curtain panel.
Public class PanelType
An object that represents a curtain panel type.
Public class PanelTypeSet
A set that contains panel types.
Public class PanelTypeSetIterator
An iterator to a panel type set.
Public class PaperSize
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.
Public class PaperSizeSet
A set that can contain any number of paper size objects.
Public class PaperSizeSetIterator
An iterator to a set of paper size objects.
Public class PaperSource
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.
Public class PaperSourceSet
A set that can contain any number of paper source objects.
Public class PaperSourceSetIterator
An iterator to a set of paper source objects.
Public class Parameter
The parameter object contains the value data assigned to that parameter.
Public class ParameterFilterElement
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.
Public class ParameterFilterRuleFactory
Contains functions that create appropriate FilterRule objects based on the parameters given.
Public class ParameterFilterUtilities
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.
Public class ParameterMap
A map that can contain a mapping of a parameter name (a String) to a parameter.
Public class ParameterMapIterator
An iterator to a map relating a parameter name (the key, a String) to a parameter.
Public class ParameterSet
A set that contains parameters.
Public class ParameterSetIterator
An iterator to a parameter set.
Public class ParameterValueProvider
Gets the value of a parameter from any element passed to getStringValue, getDoubleValue, getIntegerValue, or getElementIdValue.
Public class Part
This element represents a part of another element.
Public class PartMaker
This element manages the strategy to make Part elements for one or more original elements. accessors to PartMakerMethod methods ------------------------------------------------ TWEAK_DIVIDED_VOLUME Depending from the use case scenarios, it can be beneficial to unite getAdjacentDPartIds() and getOtherComponentsDPartIds() in a single function. To run them sequentially would be rather inefficient ---------------------------------------------------------------------------------
Public class PartMakerMethodToDivideVolumes
By-References dividing strategy used by PartMaker element.
Public class PartUtils
General Part utility methods
Public class Path3d
Provides access to the Generic 3D path object in Autodesk Revit.
Public class PerformanceAdviser
The tool to report performance problems in a given document.
Public class PerformanceAdviserRuleId
The unique identifier of a PerformanceAdviserRule
Public class PerformanceAdviserRules
Provides a container of all Revit built-in instances.
Public class Phase
Represents a phase in the life of a building.
Public class PhaseArray
An array that contains phase objects.
Public class PhaseArrayIterator
An iterator to a phase array.
Public class PhaseFilter
Represents an phase filter within Autodesk Revit.
Public class PlanarFace
A planar face of a 3d solid.
Public class PlanCircuit
An object that represents an enclosed area in a plan view within the Autodesk Revit project.
Public class PlanCircuitSet
A set that can contain any number of plan circuit objects.
Public class PlanCircuitSetIterator
An iterator to a set of plan circuit objects.
Public class Plane
Provides access to the geometry plane object.
Public class PlanTopology
An object that represents a Plan Topology within the Autodesk Revit project.
Public class PlanTopologySet
A set that can contain any number of plan topology objects.
Public class PlanTopologySetIterator
An iterator to a set of plan topology objects.
Public class PlanViewRange
This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.
Public class Point
A 3D point.
Public class PointCloudInstance
Represents a single instance of a point cloud in the Revit document.
Public class PointCloudType
Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).
Public class PointElementReference
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.
Public class PointLocationOnCurve
Defines the measurement parameters necessary to create a point at a specific location on a curve.
Public class PointOnEdge
Define a ReferencePoint relative to a referenceable edge or curve on another element.
Public class PointOnEdgeEdgeIntersection
Define a ReferencePoint at the intersection of two referenceable lines.
Public class PointOnEdgeFaceIntersection
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.
Public class PointOnFace
Define a ReferencePoint relative to a Face.
Public class PointOnPlane
Define a ReferencePoint relative to a planar reference.
Public class PointRelativeToPoint
Represents a point placed relative to another point.
Public class PolyLine
A polyline.
Public class PrimaryDesignOptionMemberFilter
A filter used to find elements contained in any primary design option of any design option set.
Public class PrimarySizeCriterion
This class contains a size criterion for a RoutingPreferenceRule.
Public class PrintManager
The PrintManager object is used to configure the global print settings.
Public class PrintParameters
An object that contains settings used for printing the document.
Public class PrintSetting
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class PrintSetup
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public class Profile
A geometric profile consisting of a loop of curves.
Public class ProjectInfo
An object that represents a Project Information within the Autodesk Revit project.
Public class ProjectLocation
An object that represents a named location in a project.
Public class ProjectLocationSet
An set that contains project locations.
Public class ProjectLocationSetIterator
An iterator to a project location set.
Public class ProjectPosition
An object that is used to represent a geographical offset and rotation.
Public class ProjectUnit
Provides access to the Project Unit... in Autodesk Revit.
Public class PropertyLine
Represents kinds of PropertyLines.
Public class PropertySetElement
An element that groups together a set of related parameters.
Public class PropertySetLibrary Obsolete.
A named collection of property sets.
Public class RadialArray
An object that represents an Array created along a circle arc within the Revit project.
Public class Rectangle
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.
Public class Reference
A stable reference to a geometric object in a Revit model.
Public class | ReferenceArray
Public class ReferenceArrayArray
An array that contains ReferenceArray objects.
Public class ReferenceArrayArrayIterator
An iterator to a ReferenceArray array.
Public class ReferenceArrayIterator
An iterator to a reference array.
Public class ReferenceIntersector
A class used to intersect and return elements based on an origin point and direction.
Public class ReferencePlane
Represents a reference plane of Autodesk Revit.
Public class ReferencePoint
A reference point in an Autodesk Revit family.
Public class | ReferencePointArray
Public class | ReferencePointArrayIterator
Public class ReferenceWithContext
An object including a reference to a geometric object and related context, as instance transform etc.
Public class RenderingImageExposureSettings
Represents the exposure settings of rendering.
Public class RenderingQualitySettings
Represents the quality settings of rendering.
Public class RenderingSettings
Represents the rendering settings for a 3d view.
Public class RevitLinkInstance
Represents an instance of a RevitLinkType.
Public class RevitLinkLoadResult
This class stores the results of trying to load a single linked model.
Public class RevitLinkOptions
This class contains the options in use when creating or loading a Revit link.
Public class RevitLinkType
This class represents another Revit Document ("link") brought into the current one ("host").
Public class Revolution
A revolution solid or void form.
Public class RevolvedFace
A revolved face of a 3d solid.
Public class RoofBase
Represents all kinds of Roofs.
Public class RoofType
Represents a specific type of roof.
Public class RoofTypeSet
A set that contains roof types.
Public class RoofTypeSetIterator
An iterator to a roof type set.
Public class RoutingCondition
RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met. inhouse RoutingCondition is a data container that includes the routing information such as size, profile shape, connection type, and etc. Default destructor
Public class RoutingConditions
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met. inhouse RoutingConditions is a collection of RoutingCondition data, each of them typically represents routing information on one connector. inhouse The class is passed into the routing preference manager in order to retrieve an appropriate part. inhouse For example: inhouse RoutingConditions myConditions; inhouse myConditions.appendCondition( RoutingCondition(dDiameter) ); // The array must have a primary condition inhouse myConditions.appendCondition( RoutingCondition(dDiameter2) ); // The array may have more conditions inhouse ElementId myPart = pRPM->getMEPPartId(myGroupType, myConditions); Default destructor
Public class RoutingCriterionBase
RoutingCriteriaBase is the base class for all routing criteria.
Public class RoutingPreferenceManager
Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType Default constructor. Default destructor
Public class RoutingPreferenceRule
Default destructor
Public class RuledFace
A ruled face of a 3d solid.
Public class SATExportOptions
Export options specific to AutoCAD file formats.
Public class SaveAsOptions
This class contains options available for saving a document to disk with a new filename.
Public class SaveOptions
This class contains options available for saving a document to disk.
Public class SchedulableField
A non-calculated field eligible to be included in a schedule.
Public class ScheduleDefinition
Settings that define the contents of a schedule.
Public class ScheduleField
A field in a schedule.
Public class ScheduleFieldId
The ScheduleFieldId object is used as a unique identification for a field in a schedule.
Public class ScheduleFilter
A filter in a schedule.
Public class | ScheduleSheetInstance
Public class ScheduleSortGroupField
A field that is used for sorting and/or grouping in a schedule.
Public class Segment
Base class for pipe, duct, cable tray and conduit segment. Default constructor Default destructor
Public class SelectionFilterElement
A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.
Public class ServerPath
This class represents a path to a Revit server location, rather than a location on disk or a network drive.
Public class Settings
The settings object provides access to general components of the Autodesk Revit application, such as Categories.
Public class SharedParameterApplicableRule
Tests whether an element supports a shared parameter.
Public class SiteLocation
Contains the geographical location information for the project's site.
Public class Sketch
Provides access to the Sketch in Autodesk Revit.
Public class SketchBase
Provides access to the SketchBase in Autodesk Revit.
Public class SketchPlane
Represents a sketch plane or work plane within Autodesk Revit.
Public class SkyBackgroundSettings
Represents the rendering sky background settings.
Public class SlabEdge
An object that represents a slab edge within the Autodesk Revit project.
Public class SlabEdgeType
An object that represents the slab edge type in Autodesk Revit.
Public class SlabEdgeTypeSet
A set that contains slab edge types.
Public class SlabEdgeTypeSetIterator
An iterator to a slab edge type set.
Public class SlabShapeCrease
A crease used in Slab Shape Editing.
Public class SlabShapeCreaseArray
An array that can contain any number of creases used in Slab Shape Editing.
Public class SlabShapeCreaseArrayIterator
An iterator to an array of creases used for Slab Shape Editing.
Public class SlabShapeEditor
An object used for Slab Shape Editing.
Public class SlabShapeVertex
A vertex used in Slab Shape Editing.
Public class SlabShapeVertexArray
An array that can contain any number of vertices used in Slab Shape Editing.
Public class SlabShapeVertexArrayIterator
An iterator to an array of vertices used for Slab Shape Editing.
Public class Solid
A 3d solid.
Public class SolidArray
An array that contains solids.
Public class SolidArrayIterator
An iterator to a solids array.
Public class SolidOrShellTessellationControls
Controls various aspects of the triangulation produced by SolutUtils::tessellateSolidOrShell.
Public class SolidSolidCutUtils
Exposes utilities which can cause one solid to cut another.
Public class SolidUtils
Contains utility functions for solid operations.
Public class SpacingRule
A rule for specifying a set of equidistant, parallel gridlines within a region.
Public class SpatialElement
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.
Public class | SpatialElementBoundaryOptions
Public class SpatialElementBoundarySubface
SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Public class SpatialElementCalculationPoint
A Spatial Element Calculation Point is used as a search point for room and space relations for all instances of this family.
Public class SpatialElementGeometryCalculator
Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.
Public class SpatialElementGeometryResults
The results of spatial element geometry calculation.
Public class SpatialElementTag
A tag attached to an SpatialElement (room, space or area) in Autodesk Revit.
Public class SpotDimension
An object that represents a spot dimension within the Revit project.
Public class SpotDimensionType
An object that specifies the type of a spot dimension in Autodesk Revit.
Public class SpotDimensionTypeSet
A set that contains spotdimension types.
Public class SpotDimensionTypeSetIterator
An iterator to a spotdimension type set.
Public class StairsEditScope
StairsEditScope allows user to maintain a stairs-editing session.
Public class StartingViewSettings
The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents. This element is unique and should be created only by upgrade.
Public class StructuralAsset
Represents the properties of a material pertinent to structural analysis.
Public class SubTransaction
Sub-transactions are objects that provide control over a subset of changes in a document.
Public class SunAndShadowSettings
The SunAndShadowSettings class represents the sun control.
Public class Sweep
A sweep solid or void form.
Public class SweepProfile
Represents a profile for sweep or swept blend elements.
Public class SweptBlend
A swept blend solid or void form.
Public class SymbolicCurve
A curve that provides information but is not intended to represent actual geometry in an element.
Public class SymbolicCurveArray
An array that contains model curves.
Public class SymbolicCurveArrayIterator
An iterator to a model curve array.
Public class TableCellCalculatedValueData
The TableCellCalculatedValueData stores the data for calculated value
Public class TableCellCombinedParameterData
The TableCellCombinedParameterData stores the data for combined parameters
Public class TableCellStyle
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.
Public class TableData
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.
Public class TableMergedCell
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.
Public class TableSectionData
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.
Public class TableView
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.
Public class TextElement
Represents the TextElement.
Public class TextElementType
An object that represents a text style.
Public class TextNote
Provides access to the TextNote object in Autodesk Revit.
Public class TextNoteType
An object that represents a text note style.
Public class TextNoteTypeSet
A set that contains textnote types.
Public class TextNoteTypeSetIterator
An iterator to a textnote type set.
Public class ThermalAsset
Represents the properties of a material pertinent to energy analysis.
Public class ThermalProperties
Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.
Public class TilePattern
An object representing a tile pattern that may be applied to a DividedSurface.
Public class TilePatterns
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.
Public class TopographySurface
An object that is used to represent a topography surface.
Public class Transaction
Transactions are context-like objects that guard any changes made to a Revit model
Public class TransactionGroup
Transaction groups aggregate a number of transactions.
Public class Transform
A transformation of the affine 3-space.
Public class TransmissionData
A class representing information on all external file references in a document.
Public class TriangleInShellComponent
This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent’s array of vertices.
Public class TriangulatedShellComponent
This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Public class | TriangulatedSolidOrShell
Public class TriangulationInterface
This abstract class provides an interface for querying a triangulation structure (vertices and triangles).
Public class TriangulationInterfaceForTriangulatedShellComponent
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.
Public class TriangulationInterfaceForTriangulatedSolidOrShell
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.
Public class TriOrQuadFacet
This class represents a triangle or quadrilateral in a faceted structure.
Public class TypeBinding
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.
Public class UpdaterData
Service class that is passed to an Updater to prove access to update execution context
Public class UpdaterId
A unique identifier of an Updater
Public class UpdaterInfo
Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Public class UpdaterRegistry
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.
Public class UV
Object representing coordinates in 2-dimensional space.
Public class ValueAtPointBase
Base class for classes containing values for point. Stores a set of flags corresponding to a measurement: flag values combine bitwise flags defined in class ValueAtPointFlags
Public class VertexIndexPair
Represents a connection between vertices in the top and bottom profile of a blend.
Public class VertexIndexPairArray
An array that contains VertexIndex pairs.
Public class VertexIndexPairArrayIterator
An iterator to an array of VertexIndex pairs.
Public class VertexPair
Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
Public class View
Base class for all types of views in Autodesk Revit.
Public class View3D
Class for 3D views
Public class ViewDrafting
Class for drafting views
Public class | ViewFamilyType
Public class ViewOrientation3D
Container for the point and vectors which define View3D's orientation.
Public class ViewPlan
Class for plan views
Public class Viewport
An element that establishes the placement of a view on a sheet.
Public class ViewSchedule
A schedule view.
Public class ViewScheduleExportOptions
The export options used to export schedule views.
Public class ViewSection
ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.
Public class ViewSet
A set that contains views.
Public class ViewSetIterator
An iterator to a view set.
Public class ViewSheet
Class for ViewSheet
Public class ViewSheetSet
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.
Public class ViewSheetSets
A set that can contain any type of object.
Public class ViewSheetSetsIterator
An iterator to a set.
Public class ViewSheetSetting
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Public class VolumeCalculationOptions
This class provides access to options related to room volume and area computations.
Public class VolumeCalculationSetting
This class provides access to settings related to room volume and area computations.
Public class Wall
Represents a wall in Autodesk Revit.
Public class WallSweep
Represents a wall sweep or reveal.
Public class WallSweepInfo
Represents a wall sweep or reveal of a vertically compound structure.
Public class WallType
Represents a specific type of wall, such as 'Generic -8" '.
Public class WallTypeSet
A set that contains wall types.
Public class WallTypeSetIterator
An iterator to a wall type set.
Public class WallUtils
General Wall utility methods
Public class Workset
Represents a workset in the document.
Public class WorksetDefaultVisibilitySettings
An object that manages default visibility of worksets in a document.
Public class WorksetFilter
A base class for a type of filter that accepts or rejects worksets based upon criteria.
Public class WorksetId
WorksetId identifies a workset within a single document.
Public class WorksetKindFilter
A filter used to match worksets of the given WorksetKind.
Public class WorksetTable
A table containing references to all the worksets contained in a document.
Public class WorksharingDisplayGraphicSettings
Represents the graphical settings that can be assigned to elements in the worksharing display modes.
Public class WorksharingDisplaySettings
WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.
Public class WorksharingTooltipInfo
Worksharing information about a single element suitable for display in an in-canvas tooltip.
Public class WorksharingUtils
A static class that contains utility functions related to worksharing.
Public class XYZ
Object representing coordinates in 3-dimensional space.

Structures

 | Structure | Description
Public structure | GridNode |

Interfaces

 | Interface | Description
Public interface | IConnector | An interface which provides access to connector in Autodesk Revit MEP document.
Public interface | IExtension | An interface that supports the additional operation for Extension Status
Public interface | IExternalDBApplication | An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.
Public interface | IFailuresPreprocessor | An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.
Public interface | IFailuresProcessor | To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.
Public interface | IFamilyLoadOptions | An interface class which provide the callback for family load options.
Public interface | IPerformanceAdviserRule | Base class to derive specific performance adviser rules from.
Public interface | IPrintSetting | An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.
Public interface | ITransactionFinalizer | An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.
Public interface | IUpdater | The interface used to create an updater capable of reacting to changes in the Revit model.
Public interface | IViewSheetSet | This interface represents a selected set of views/sheets which will be used for printing.

Enumerations

 | Enumeration | Description
Public enumeration | ACADVersion | An enumerated type listing available AutoCAD versions, into which a file may be exported.
Public enumeration | ACAObjectPreference | An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.
Public enumeration | AdaptivePointConstraintType | An enumerated type containing possible constraint types for Adaptive Points.
Public enumeration | AdaptivePointOrientationType | An enumerated type containing possible orientation types for Adaptive Points.
Public enumeration | AdaptivePointType | An enumerated type containing possible types for Adaptive Points.
Public enumeration | AnalyzesAsType | This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.
Public enumeration | AreaElemType | An enumerated type to store type of AreaElement.
Public enumeration | ArrayAnchorMember | Represents the possible choices for how the translation or rotation is used to place each member of the array.
Public enumeration | AssemblyDetailViewOrientation | Orientation of the Assembly Detail View.
Public enumeration | AttachmentType | Enum determining whether a link is an attachment or an overlay
Public enumeration | AutomaticConnectionBehaviorType | Defines behavior of connector with respect to automatic creation of connections
Public enumeration | BackgroundImageFit | Indicates the background image fit type in rendering settings.
Public enumeration | BackgroundStyle | Indicates the background style in rendering settings.
Public enumeration | BaseLoadOn | An enumerated type listing all the possible power load use types for a space object.
Public enumeration | BeamSystemJustifyType | Describes the justify method of beamsystem.
Public enumeration | BooleanOperationsType | An enumerated type listing boolean types that are supported for boolean operation.
Public enumeration | BorderTile | Options for controlling tiles that overlap the face boundary. See DividedSurface.
Public enumeration | BoxPlacement | An enumerated type listing possible placement of a box (an object of rectangular shape).
Public enumeration | BuildingType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | BuiltInCategory | A list of all the built in categories within Revit.
Public enumeration | BuiltInParameter | An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.
Public enumeration | BuiltInParameterGroup | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | CellType | Declares the cell data type.
Public enumeration | ChangePriority | Enum used to specify the priority of an Updater during execution.
Public enumeration | CheckoutStatus | Indicates the ownership status of an element
Public enumeration | ColorDepthType | An enumerated type listing all Color Depth types of Print Setting.
Public enumeration | ColumnAttachmentCutStyle | Control the handling of columns that intersect their targets.
Public enumeration | ColumnAttachmentJustification | Control the column extent in cases where the target is not a uniform height.
Public enumeration | ComponentRotation | ComponentRotation property of DividedSurface. See DividedSurface.
Public enumeration | CompoundStructureDeckUsage | Describes how the deck relates to the surrounding layers.
Public enumeration | CompoundStructureError | When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.
Public enumeration | CompoundStructureLayerFunction | Describes the purpose of the layer within a compound structure, such as a wall or floor.
Public enumeration | ConnectorDomainType | Type of connector domain.
Public enumeration | ConnectorGenderType | Connector gender type enum
Public enumeration | ConnectorJointType | Connector joint type enum
Public enumeration | ConnectorProfileType | An enumerated type listing all connector profile types
Public enumeration | ConnectorType | An enumerated type listing all connector types for a connection
Public enumeration | ControlShape | An enumerated type listing four shapes of control that Autodesk Revit supports.
Public enumeration | CoordinatePlaneVisibility | Visibility settings for ReferencePoint element's coordinate reference planes.
Public enumeration | CurtainGridAlignType | An enumerated to list CurtainGrid patterns.
Public enumeration | CurveElementType |
Public enumeration | CurveProjectionType | This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.
Public enumeration | CutFailureReason | The reason why a solid-solid cut cannot be created.
Public enumeration | DecimalSymbolType | An enumerated type listing two types of the Decimal Symbol types that Autodesk Revit supports.
Public enumeration | DetachFromCentralOption | Options for workset detachment behavior.
Public enumeration | DGNFileFormat | An enumerated type listing available Microstation versions into which a file may be exported.
Public enumeration | DigitGroupingAmount | An enumerated type listing the types of the Digit Grouping Amount that Autodesk Revit supports.
Public enumeration | DigitGroupingSymbolType | An enumerated type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.
Public enumeration | DimensionShape | An enumerated type to list dimension type.
Public enumeration | DimensionStyleType | An enumerated type containing possible style types of dimensions.
Public enumeration | DisplayStyle | Display type of the view
Public enumeration | DisplayUnit | Describes the type of Revit display unit, metric or imperial.
Public enumeration | DisplayUnitType |
Public enumeration | DistanceMeasuredFrom | Indicates if the distance is measured from the top or bottom of the wall.
Public enumeration | DividedPathMeasurementType | DividedPath measurement type.
Public enumeration | DocumentType | Types of Revit documents.
Public enumeration | Domain | Type of connector domain.
Public enumeration | DuplicateTypeAction | The Enum defines how the paste operation should handle duplicate types (inexact matches).
Public enumeration | DWFImageFormat | An enumerated type listing possible image format for DWF Export.
Public enumeration | DWFImageQuality | An enumerated type listing possible image quality for DWF Export.
Public enumeration | EaveCutterType | An enumerated type to store type of EaveCutter.
Public enumeration | ElementOnPhaseStatus | The statuses that an element can have with respect to a given phase.
Public enumeration | ElementReferenceType | Element reference types.
Public enumeration | EndCapCondition | Used by CompoundStructure to describe which shell layers participate in end wrapping.
Public enumeration | ExportColorMode | An enumerated type listing export color mode.
Public enumeration | ExportColumnHeaders | Options for exporting column headers in schedule view export.
Public enumeration | ExportPaperFormat | Paper formats supported by DWF export
Public enumeration | ExportRange | This enum is used to define what view, part of the view, or list of views will be exported.
Public enumeration | ExportSheetType | An enumerated type listing possible Sheet type.
Public enumeration | ExportTextQualifier | Options for the text qualifier character in schedule view export.
Public enumeration | ExportUnit | An enumerated type listing possible target units for CAD Export.
Public enumeration | ExternalDBApplicationResult | Informs Autodesk Revit of the status of your external db application after execution.
Public enumeration | ExternalFileReferenceType | Enum class indicating kinds of external file references
Public enumeration | ExtrusionAnalyzerFaceAlignment | Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.
Public enumeration | FailureProcessingResult | Enum represents result of failure processing by FailuresPreprocessor, handler of FailuresProcessing event or by FailuresProcessor.
Public enumeration | FailureResolutionType | Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.
Public enumeration | FailureSeverity | Enum represents severity of a failure.
Public enumeration | FamilyElementVisibilityType | Indicates the Visibility type of generic forms.
Public enumeration | FamilyHostingBehavior | Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!
Public enumeration | FamilyPlacementType | The type of placement required for a given family.
Public enumeration | FamilySource | Describes which version of the family to be loaded.
Public enumeration | FilledRegionBackground | The filled region background types.
Public enumeration | FillPatternHostOrientation | The types of orientations for fill patterns.
Public enumeration | FillPatternTarget | The type of the fill pattern.
Public enumeration | FindReferenceTarget | The type of reference to find
Public enumeration | FitDirectionType | This enum is used to define the direction to fit the number of pixels defined by PixelSize.
Public enumeration | FloorFace | An enumerated type listing floor face types (top or bottom)
Public enumeration | FlowDirectionType | An enumerated type listing direction types for a connector.
Public enumeration | GraphicsStyleType | Describes the type of graphics style.
Public enumeration | GridNodeLocation | Location of a grid node relative to the face boundary. See DividedSurface.
Public enumeration | GridSegmentDirection | Specify one of the four adjacent segments to a GridNode. See DividedSurface.
Public enumeration | HiddenLineViewsType | An enumerated type listing all Hidden Line Views types of Print Setting.
Public enumeration | HorizontalAlign | Horizontal alignment of model text.
Public enumeration | HorizontalAlignmentStyle | Declares the horizontal alignment style of font.
Public enumeration | IFCVersion | An enumerated type listing available IFC file versions into which a file may be exported.
Public enumeration | ImageFileType | This enum is used to define exported file type.
Public enumeration | ImageResolution | This enum is used to define image resolution in order to calculate the image size.
Public enumeration | ImportColorMode | An enumerated type listing how colors are handled in an import process.
Public enumeration | ImportExportFileFormat | Describes formats supported by import / export.
Public enumeration | ImportPlacement | An enumerated type listing possible placement modes for imported drawings.
Public enumeration | ImportUnit | An enumerated type listing possible target units for CAD Import.
Public enumeration | JoinType | The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.
Public enumeration | JunctionType | An enumerated type listing all the junction types for MEP curve types.
Public enumeration | LeaderEndCondition | An enumerated type listing Leader end conditions that are supported for IndependentTags.
Public enumeration | LightingSource | Indicates the lighting scheme type in rendering settings.
Public enumeration | LinePatternSegmentType | Represents the type of a line pattern segment.
Public enumeration | LineScaling | An enumerated type listing possible LineType scaling modes.
Public enumeration | LinkedFileStatus | Enum displaying the loaded status of a linked file
Public enumeration | MarginType | An enumerated type listing all Margin types of Print Setting.
Public enumeration | MassDisplayTemporaryOverrideType | This enum identifies the mass display overrides.
Public enumeration | MaterialAspect | A list of all material aspects that a material can store PropertySetElements for.
Public enumeration | MaterialFunctionAssignment | Used in class CompoundStructure to specify the function of a layer.
Public enumeration | MaterialPropertyPathType | Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.
Public enumeration | MEPSystemClassification | This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type
Public enumeration | ModelUpdatesStatus | Indicates whether an element in the current model has additional user changes in the central model.
Public enumeration | NumberSystemDisplayRule | The available options for display of numeric values in the number system.
Public enumeration | NumberSystemJustifyOption | The available options for justification of the numbers in a number system.
Public enumeration | OpeningWrappingCondition | Used by CompoundStructure to describe which shell layers participate in wrapping at openings.
Public enumeration | PageOrientationType | An enumerated type listing all Page Orientation types of Print Setting.
Public enumeration | PaperPlacementType | An enumerated type listing all Paper Placement types of Print Setting.
Public enumeration | ParameterType | An enumerated type listing all of the data type interpretation that Autodesk Revit supports.
Public enumeration | PartEdgeConditionOrientation | Relative orientation of the right/lower and left/upper edge condition profiles.
Public enumeration | PartsVisibility | Indicates the visibility of parts for the view.
Public enumeration | PartType | An enumerated type listing all MEP family part types
Public enumeration | PathType | Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.
Public enumeration | PhaseStatusPresentation | An enumerated type listing the options for element display in a phase filter.
Public enumeration | PlanViewDirection | This enumerated type represents the possible directions for a plan view.
Public enumeration | PlanViewPlane | Locations where view range offsets can be specified.
Public enumeration | PlanViewRangeError | Describes errors in the location of planes in a PlanViewRange object.
Public enumeration | PlanViewRangeLevel |
Public enumeration | PointCloudFoundStatus |
Public enumeration | PointOnCurveMeasureFrom | Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.
Public enumeration | PointOnCurveMeasurementType | Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.
Public enumeration | PreferredJunctionType |
Public enumeration | PrinterResolution | Controls the resolution level in rendering settings.
Public enumeration | PrintRange | An enumerated type listing all Print Range types of Print.
Public enumeration | ProfilePlaneLocation | Indicates the location of Sweep profile plane on the path curve.
Public enumeration | PropOverrideMode | An enumerated type listing ways how overridden object styles get exported.
Public enumeration | RasterQualityType |
Public enumeration | RectangularGridSegmentOrientation | The orientation type of rectangular grid segment.
Public enumeration | ReferenceType | Reference types of curve element.
Public enumeration | RenderingQuality | Indicates the rendering quality in rendering settings.
Public enumeration | ResolutionTarget | Indicates the resolution target(Screen or Printer) used for rendering settings.
Public enumeration | RevitLinkLoadResultType | Enum listing the possible results after loading a linked model.
Public enumeration | RoutingPreferenceErrorLevel |
Public enumeration | RoutingPreferenceRuleGroupType | Add more rule group type here.
Public enumeration | ScheduleFieldType | The type of data displayed in a schedule field.
Public enumeration | ScheduleFilterType | Type of schedule filter.
Public enumeration | ScheduleHeadingOrientation | Orientation of schedule heading.
Public enumeration | ScheduleHorizontalAlignment | Horizontal alignment of data in a schedule.
Public enumeration | ScheduleSortOrder | Options for sort order of rows in a schedule.
Public enumeration | SectionType | Declares the section data type.
Public enumeration | SelectionFilterAction | An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.
Public enumeration | ServiceType | An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.
Public enumeration | SetComparisonResult | An enumerated type listing all the relationship types between two sets of arbitrary nature.
Public enumeration | ShellLayerType | Used to distinguish exterior and interior shell layers.
Public enumeration | SlabShapeCreaseType | An enumerated type listing all Crease types of Slab Shape Edit.
Public enumeration | SlabShapeVertexType | An enumerated type listing all Vertex types of Slab Shape Edit.
Public enumeration | SlantedOrVerticalColumnType | This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.
Public enumeration | SolidGeometry | An enumerated type listing possible ways of exporting solids in 3D views.
Public enumeration | SpacingRuleJustification | Justification property of spacing rule
Public enumeration | SpacingRuleLayout | Rules for laying out a series of equidistant points or parallel lines
Public enumeration | SpatialElementBoundaryLocation | An enumerated type listing boundary options of spatial element geometry calculation.
Public enumeration | StickSymbolLocation | Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.
Public enumeration | StorageType | An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Public enumeration | StructDeckEmbeddingType | Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.
Public enumeration | StructuralAssetClass | Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.
Public enumeration | StructuralBehavior | Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.
Public enumeration | StructuralReleaseType | Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.
Public enumeration | SubfaceType | Meaning of a subface's type.
Public enumeration | SunAndShadowType | Sun study type enum of SunAndShadowSettings.
Public enumeration | SunStudyTimeInterval | Time interval enum for a single or multi-day sun study.
Public enumeration | TagMode | An enumerated type listing tag mode that are supported for IndependentTags.
Public enumeration | TagOrientation | An enumerated type listing tag orientation options that are supported by IndependentTags.
Public enumeration | TemporaryViewMode | Enumeration to represent the various temporary view modes a view can be in.
Public enumeration | TextAlignFlags | An enumerated type listing all the Text align flags.
Public enumeration | TextAlignMask | An enumerated type listing all the Text align mask.
Public enumeration | TextElementBackground | An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.
Public enumeration | TextNoteLeaderStyles | An enumerated type listing all the Leader styles.
Public enumeration | TextNoteLeaderTypes | An enumerated type listing all the Leader types.
Public enumeration | TextTreatment | An enumerated type listing possible text treatment modes.
Public enumeration | ThermalMaterialType | Represents the thermal material type.
Public enumeration | TilePatternsBuiltIn | Revit's built-in tile patterns. See TilePattern.
Public enumeration | TransactionStatus |
Public enumeration | TransmittedModelOptions | Enum giving desired behavior when opening or saving a transmitted workshared model.
Public enumeration | UnitGroup | An enumerated type listing Discipline of the Unit types that Autodesk Revit supports.
Public enumeration | UnitSymbolType | An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.
Public enumeration | UnitType |
Public enumeration | ValueAtPointFlags |
Public enumeration | VerticalAlignmentStyle | Declares the vertical alignment style of font.
Public enumeration | ViewDetailLevel | Detail level of the view
Public enumeration | ViewDiscipline | Discipline of the view
Public enumeration | ViewDuplicateOption | Options for duplicating views
Public enumeration | ViewFamily | An enumerated type that corresponds to the type of a Revit view.
Public enumeration | ViewPlanType | An enumerated type listing plan view types.
Public enumeration | ViewportRotation | Rotation of the viewport
Public enumeration | ViewTemplateApplicationOption | Options for applying view templates
Public enumeration | ViewType | An enumerated type listing available view types.
Public enumeration | VirtualPrinterType | An enumerated to list Virtual Printer Types in Revit.
Public enumeration | Visibility | Describes the visibility of a particular geometry object.
Public enumeration | WallFunction | Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.
Public enumeration | WallKind | Describes the fundamental type of wall, such as curtain wall or stacked wall.
Public enumeration | WallLocationLine | This enumerated type represents the options for alignment of a wall's location line.
Public enumeration | WallSide | Represents the possible sides of a wall where a sweep or reveal may be attached.
Public enumeration | WallSweepType | Represents the possible types for methods affecting wall sweeps or reveals.
Public enumeration | WorksetKind | Indicates one of the standard kinds of workset (as available in the UI).
Public enumeration | WorksetVisibility | Indicates the visibility settings of a workset in a particular view.
Public enumeration | WorksharingDisplayMode | Indicates which worksharing display mode a view is in.
Public enumeration | ZoomFitType | This enum is used to define type of zoom.
Public enumeration | ZoomType | An enumerated type listing all Zoom types of Print Setting.


ACADExportOptions Class

[image]

Revit 2013 API
ACADExportOptions Class
Members See Also Send Feedback
The base class for options used to export DWG and DXF format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ACADExportOptions : BaseExportOptions
Visual Basic
Public Class ACADExportOptions _
    Inherits BaseExportOptions
Visual C++
public ref class ACADExportOptions : public BaseExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DWGExportOptions
Autodesk.Revit.DB..::..DXFExportOptions

See Also

ACADExportOptions Members
Autodesk.Revit.DB Namespace


ACADExportOptions Members

[image] [image]

Revit 2013 API
ACADExportOptions Members
ACADExportOptions Class Methods Properties See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false.
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty.
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default.
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact.

See Also

ACADExportOptions Class


ACADExportOptions Methods

[image] [image]

Revit 2013 API
ACADExportOptions Methods
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ACADExportOptions Class


ACADExportOptions Properties

[image] [image]

Revit 2013 API
ACADExportOptions Properties
ACADExportOptions Class See Also Send Feedback

The ACADExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false.
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale.
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty.
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default.
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact.

See Also

ACADExportOptions Class


ACAPreference Property

[image]

Revit 2013 API
ACADExportOptions..::..ACAPreference Property
ACADExportOptions Class See Also Send Feedback
The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ACAObjectPreference ACAPreference { get; set; }
Visual Basic
Public Property ACAPreference As ACAObjectPreference
    Get
    Set
Visual C++
public:
property ACAObjectPreference ACAPreference {
    ACAObjectPreference get ();
    void set (ACAObjectPreference value);
}

See Also

ACADExportOptions Class


ExportingAreas Property

[image]

Revit 2013 API
ACADExportOptions..::..ExportingAreas Property
ACADExportOptions Class See Also Send Feedback
True to export area and room geometry, false otherwise. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic
Public Property ExportingAreas As Boolean
    Get
    Set
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


ExportOfSolids Property

[image]

Revit 2013 API
ACADExportOptions..::..ExportOfSolids Property
ACADExportOptions Class See Also Send Feedback
The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SolidGeometry ExportOfSolids { get; set; }
Visual Basic
Public Property ExportOfSolids As SolidGeometry
    Get
    Set
Visual C++
public:
property SolidGeometry ExportOfSolids {
    SolidGeometry get ();
    void set (SolidGeometry value);
}

See Also

ACADExportOptions Class


FileVersion Property

[image]

Revit 2013 API
ACADExportOptions..::..FileVersion Property
ACADExportOptions Class See Also Send Feedback
ACADVersion::Default Default value is ACADVersion.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ACADVersion FileVersion { get; set; }
Visual Basic
Public Property FileVersion As ACADVersion
    Get
    Set
Visual C++
public:
property ACADVersion FileVersion {
    ACADVersion get ();
    void set (ACADVersion value);
}

See Also

ACADExportOptions Class


LineScaling Property

[image]

Revit 2013 API
ACADExportOptions..::..LineScaling Property
ACADExportOptions Class See Also Send Feedback
The scaling mode for the line type. Default value is LineScaling.ViewScale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineScaling LineScaling { get; set; }
Visual Basic
Public Property LineScaling As LineScaling
    Get
    Set
Visual C++
public:
property LineScaling LineScaling {
    LineScaling get ();
    void set (LineScaling value);
}

See Also

ACADExportOptions Class


LinetypesFileName Property

[image]

Revit 2013 API
ACADExportOptions..::..LinetypesFileName Property
ACADExportOptions Class See Also Send Feedback
The custom linetype file name (*.lin). Default value is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LinetypesFileName { get; set; }
Visual Basic
Public Property LinetypesFileName As String
    Get
    Set
Visual C++
public:
property String^ LinetypesFileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ACADExportOptions Class


MarkNonplotLayers Property

[image]

Revit 2013 API
ACADExportOptions..::..MarkNonplotLayers Property
ACADExportOptions Class See Also Send Feedback
If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool MarkNonplotLayers { get; set; }
Visual Basic
Public Property MarkNonplotLayers As Boolean
    Get
    Set
Visual C++
public:
property bool MarkNonplotLayers {
    bool get ();
    void set (bool value);
}

Remarks

A typical use would be to mark as non-plot all layers containing -NPLT. Default value is false

See Also

ACADExportOptions Class


NonplotSuffix Property

[image]

Revit 2013 API
ACADExportOptions..::..NonplotSuffix Property
ACADExportOptions Class See Also Send Feedback
If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string NonplotSuffix { get; set; }
Visual Basic
Public Property NonplotSuffix As String
    Get
    Set
Visual C++
public:
property String^ NonplotSuffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ACADExportOptions Class


SharedCoords Property

[image]

Revit 2013 API
ACADExportOptions..::..SharedCoords Property
ACADExportOptions Class See Also Send Feedback
True to use the shared coordinate system's origin, false to use the project origin. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SharedCoords { get; set; }
Visual Basic
Public Property SharedCoords As Boolean
    Get
    Set
Visual C++
public:
property bool SharedCoords {
    bool get ();
    void set (bool value);
}

See Also

ACADExportOptions Class


TargetUnit Property

[image]

Revit 2013 API
ACADExportOptions..::..TargetUnit Property
ACADExportOptions Class See Also Send Feedback
The target unit type. Default value is ExportUnit.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ExportUnit TargetUnit { get; set; }
Visual Basic
Public Property TargetUnit As ExportUnit
    Get
    Set
Visual C++
public:
property ExportUnit TargetUnit {
    ExportUnit get ();
    void set (ExportUnit value);
}

See Also

ACADExportOptions Class


TextTreatment Property

[image]

Revit 2013 API
ACADExportOptions..::..TextTreatment Property
ACADExportOptions Class See Also Send Feedback
The text treatment. Deault value is TextTreatment.Exact.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextTreatment TextTreatment { get; set; }
Visual Basic
Public Property TextTreatment As TextTreatment
    Get
    Set
Visual C++
public:
property TextTreatment TextTreatment {
    TextTreatment get ();
    void set (TextTreatment value);
}

See Also

ACADExportOptions Class


ACADVersion Enumeration

[image]

Revit 2013 API
ACADVersion Enumeration
See Also Send Feedback
An enumerated type listing available AutoCAD versions, into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ACADVersion
Visual Basic
Public Enumeration ACADVersion
Visual C++
public enum class ACADVersion

Members

Member name | Description
R2000 | AutoCAD 2000 file format.
R2004 | AutoCAD 2004 file format.
R2007 | AutoCAD 2007 file format.
R2010 | AutoCAD 2010 file format.
Default | The Autodesk Revit application's default export format.
R2013 | AutoCAD 2013 file format.

See Also


ACAObjectPreference Enumeration

[image]

Revit 2013 API
ACAObjectPreference Enumeration
See Also Send Feedback
An enumerated type listing possible ways to generate geometry of an ACA object Revit object parameters used to generate geometry of the exported ACA object. Revit object geometry is used to generate geometry of the exported ACA object. That may produce better geometric fidelity in some cases.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ACAObjectPreference
Visual Basic
Public Enumeration ACAObjectPreference
Visual C++
public enum class ACAObjectPreference

Members

Member name | Description
Object |
Geometry |

See Also


AdaptiveComponentFamilyUtils Class

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AdaptiveComponentFamilyUtils : IDisposable
Visual Basic
Public Class AdaptiveComponentFamilyUtils _
    Implements IDisposable
Visual C++
public ref class AdaptiveComponentFamilyUtils : IDisposable

Examples

CopyC#
private void CreateAdaptiveComponentFamily(Document document)
{
    // check if this family is an Adaptive Component family
    if (!(AdaptiveComponentFamilyUtils.IsAdaptiveComponentFamily(document.OwnerFamily))) return;
    Transaction transaction = new Transaction(document); ;
    int placementCtr = 1;
    ReferencePointArray refPointArray = new ReferencePointArray();
    for (int i = 0; i < 10; i++)
    {
        transaction.SetName("Point" + i);
        transaction.Start();
        ReferencePoint referencePoint = document.FamilyCreate.NewReferencePoint(new XYZ(i, 0, 0));
        if (i % 2 == 0)
        // Even-numbered reference points will be Placement Points
        {
            AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.PlacementPoint);
            transaction.Commit();
            AdaptiveComponentFamilyUtils.SetPlacementNumber(document, referencePoint.Id, placementCtr);
            placementCtr++;
        }
        else
        // Odd-numbered points will be Shape Handle Points
        {
            AdaptiveComponentFamilyUtils.MakeAdaptivePoint(document, referencePoint.Id, AdaptivePointType.ShapeHandlePoint);
            transaction.Commit();
        }
        refPointArray.Append(referencePoint);
    }
    // Create a curve running through all Reference Points
    transaction.SetName("Curve");
    transaction.Start();
    CurveByPoints curve = document.FamilyCreate.NewCurveByPoints(refPointArray);
    transaction.Commit();
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentFamilyUtils

See Also

AdaptiveComponentFamilyUtils Members


AdaptiveComponentFamilyUtils Members

[image] [image]

Revit 2013 API
AdaptiveComponentFamilyUtils Members
AdaptiveComponentFamilyUtils Class Methods See Also Send Feedback

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AdaptiveComponentFamilyUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
 | GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
 | GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
 | GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
 | GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
 | GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
 | IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
 | IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
 | IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
 | MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
 | SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
 | SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
 | SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentFamilyUtils Class


AdaptiveComponentFamilyUtils Methods

[image] [image]

Revit 2013 API
AdaptiveComponentFamilyUtils Methods
AdaptiveComponentFamilyUtils Class See Also Send Feedback

The AdaptiveComponentFamilyUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNumberOfAdaptivePoints | Gets number of Adaptive Point Elements in Adaptive Component Family.
 | GetNumberOfPlacementPoints | Gets number of Placement Point Elements in Adaptive Component Family.
 | GetNumberOfShapeHandlePoints | Gets number of Shape Handle Point Elements in Adaptive Component Family.
 | GetPlacementNumber | Gets Placement number of an Adaptive Placement Point.
 | GetPointConstraintType | Gets constrain type of an Adaptive Shape Handle Point.
 | GetPointOrientationType | Gets orientation type of an Adaptive Placement Point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAdaptiveComponentFamily | Verifies if the Family is an Adaptive Component Family.
 | IsAdaptivePlacementPoint | Verifies if the Reference Point is an Adaptive Placement Point.
 | IsAdaptivePoint | Verifies if the Reference Point is an Adaptive Point.
 | IsAdaptiveShapeHandlePoint | Verifies if the Reference Point is an Adaptive Shape Handle Point.
 | MakeAdaptivePoint | Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.
 | SetPlacementNumber | Sets Placement Number of an Adaptive Placement Point.
 | SetPointConstraintType | Sets constrain type of an Adaptive Shape Handle Point.
 | SetPointOrientationType | Sets orientation type of an Adaptive Placement Point.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentFamilyUtils Class


Dispose Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..Dispose Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Releases all resources used by the AdaptiveComponentFamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AdaptiveComponentFamilyUtils Class


GetNumberOfAdaptivePoints Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetNumberOfAdaptivePoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Adaptive Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static int GetNumberOfAdaptivePoints(
    FamilyBase famBase
)
Visual Basic
Public Shared Function GetNumberOfAdaptivePoints ( _
    famBase As FamilyBase _
) As Integer
Visual C++
public:
static int GetNumberOfAdaptivePoints(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

Number of Adaptive Point Element References in Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family famBase is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


GetNumberOfPlacementPoints Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetNumberOfPlacementPoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Placement Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static int GetNumberOfPlacementPoints(
    FamilyBase famBase
)
Visual Basic
Public Shared Function GetNumberOfPlacementPoints ( _
    famBase As FamilyBase _
) As Integer
Visual C++
public:
static int GetNumberOfPlacementPoints(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

Number of Adaptive Placement Point Element References in Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family famBase is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


GetNumberOfShapeHandlePoints Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetNumberOfShapeHandlePoints Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets number of Shape Handle Point Elements in Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static int GetNumberOfShapeHandlePoints(
    FamilyBase famBase
)
Visual Basic
Public Shared Function GetNumberOfShapeHandlePoints ( _
    famBase As FamilyBase _
) As Integer
Visual C++
public:
static int GetNumberOfShapeHandlePoints(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

Number of Adaptive Shape Handle Point Element References in the Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Family famBase is not an Adaptive Component Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


GetPlacementNumber Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetPlacementNumber Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets Placement number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static int GetPlacementNumber(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPlacementNumber ( _
    doc As Document, _
    refPointId As ElementId _
) As Integer
Visual C++
public:
static int GetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Placement number of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


GetPointConstraintType Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AdaptivePointConstraintType GetPointConstraintType(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId _
) As AdaptivePointConstraintType
Visual C++
public:
static AdaptivePointConstraintType GetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


GetPointOrientationType Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..GetPointOrientationType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Gets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AdaptivePointOrientationType GetPointOrientationType(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function GetPointOrientationType ( _
    doc As Document, _
    refPointId As ElementId _
) As AdaptivePointOrientationType
Visual C++
public:
static AdaptivePointOrientationType GetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

Orientation type of Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptiveComponentFamily Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..IsAdaptiveComponentFamily Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Family is an Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptiveComponentFamily(
    FamilyBase famBase
)
Visual Basic
Public Shared Function IsAdaptiveComponentFamily ( _
    famBase As FamilyBase _
) As Boolean
Visual C++
public:
static bool IsAdaptiveComponentFamily(
    FamilyBase^ famBase
)

Parameters

famBase
Type: Autodesk.Revit.DB..::..FamilyBase
The Family

Return Value

True if the Family is an Adaptive Component Family.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptivePlacementPoint Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..IsAdaptivePlacementPoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptivePlacementPoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptivePlacementPoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptivePlacementPoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptivePoint Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..IsAdaptivePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptivePoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptivePoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Point (Placement Point or Shape Handle Point).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


IsAdaptiveShapeHandlePoint Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..IsAdaptiveShapeHandlePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Verifies if the Reference Point is an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptiveShapeHandlePoint(
    Document doc,
    ElementId refPointId
)
Visual Basic
Public Shared Function IsAdaptiveShapeHandlePoint ( _
    doc As Document, _
    refPointId As ElementId _
) As Boolean
Visual C++
public:
static bool IsAdaptiveShapeHandlePoint(
    Document^ doc,
    ElementId^ refPointId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id

Return Value

True if the Point is an Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentFamilyUtils Class


MakeAdaptivePoint Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..MakeAdaptivePoint Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MakeAdaptivePoint(
    Document doc,
    ElementId refPointId,
    AdaptivePointType type
)
Visual Basic
Public Shared Sub MakeAdaptivePoint ( _
    doc As Document, _
    refPointId As ElementId, _
    type As AdaptivePointType _
)
Visual C++
public:
static void MakeAdaptivePoint(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointType type
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
type
Type: Autodesk.Revit.DB..::..AdaptivePointType
The Adaptive Point Type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPlacementNumber Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..SetPlacementNumber Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets Placement Number of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetPlacementNumber(
    Document doc,
    ElementId refPointId,
    int placementNumber
)
Visual Basic
Public Shared Sub SetPlacementNumber ( _
    doc As Document, _
    refPointId As ElementId, _
    placementNumber As Integer _
)
Visual C++
public:
static void SetPlacementNumber(
    Document^ doc,
    ElementId^ refPointId,
    int placementNumber
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
placementNumber
Type: System..::..Int32
Placement number of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. -or- The number placementNumber is out of range.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPointConstraintType Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..SetPointConstraintType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets constrain type of an Adaptive Shape Handle Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetPointConstraintType(
    Document doc,
    ElementId refPointId,
    AdaptivePointConstraintType constraintType
)
Visual Basic
Public Shared Sub SetPointConstraintType ( _
    doc As Document, _
    refPointId As ElementId, _
    constraintType As AdaptivePointConstraintType _
)
Visual C++
public:
static void SetPointConstraintType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointConstraintType constraintType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
constraintType
Type: Autodesk.Revit.DB..::..AdaptivePointConstraintType
Constraint type of the Adaptive Shape Handle Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to a Shape Handle Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


SetPointOrientationType Method

[image]

Revit 2013 API
AdaptiveComponentFamilyUtils..::..SetPointOrientationType Method
AdaptiveComponentFamilyUtils Class See Also Send Feedback
Sets orientation type of an Adaptive Placement Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetPointOrientationType(
    Document doc,
    ElementId refPointId,
    AdaptivePointOrientationType orientationType
)
Visual Basic
Public Shared Sub SetPointOrientationType ( _
    doc As Document, _
    refPointId As ElementId, _
    orientationType As AdaptivePointOrientationType _
)
Visual C++
public:
static void SetPointOrientationType(
    Document^ doc,
    ElementId^ refPointId,
    AdaptivePointOrientationType orientationType
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
refPointId
Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
orientationType
Type: Autodesk.Revit.DB..::..AdaptivePointOrientationType
Orientation type of the Adaptive Placement Point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentFamilyUtils Class


AdaptiveComponentInstanceUtils Class

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils Class
Members Example See Also Send Feedback
An interface for Adaptive Component Instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AdaptiveComponentInstanceUtils : IDisposable
Visual Basic
Public Class AdaptiveComponentInstanceUtils _
    Implements IDisposable
Visual C++
public ref class AdaptiveComponentInstanceUtils : IDisposable

Examples

CopyC#
private void CreateAdaptiveComponentInstance(Document document, FamilySymbol symbol)
{
    // Create a new instance of an adaptive component family
    FamilyInstance instance = AdaptiveComponentInstanceUtils.CreateAdaptiveComponentInstance(document, symbol);

    // Get the placement points of this instance
    IList<ElementId> placePointIds = new List<ElementId>();
    placePointIds = AdaptiveComponentInstanceUtils.GetInstancePlacementPointElementRefIds(instance);
    double x = 0;

    // Set the position of each placement point
    foreach (ElementId id in placePointIds)
    {
        ReferencePoint point = document.GetElement(id) as ReferencePoint;
        point.Position = new Autodesk.Revit.DB.XYZ(10*x, 10*Math.Cos(x), 0);
        x += Math.PI/6;
    }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AdaptiveComponentInstanceUtils

See Also

AdaptiveComponentInstanceUtils Members


AdaptiveComponentInstanceUtils Members

[image] [image]

Revit 2013 API
AdaptiveComponentInstanceUtils Members
AdaptiveComponentInstanceUtils Class Methods See Also Send Feedback

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
Public method | Dispose | Releases all resources used by the AdaptiveComponentInstanceUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
 | IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
 | IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
 | IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
 | MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
 | SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentInstanceUtils Class


AdaptiveComponentInstanceUtils Methods

[image] [image]

Revit 2013 API
AdaptiveComponentInstanceUtils Methods
AdaptiveComponentInstanceUtils Class See Also Send Feedback

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | CreateAdaptiveComponentInstance | Creates a FamilyInstance of Adaptive Component Family.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstancePlacementPointElementRefIds | Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstancePointElementRefIds | Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
 | GetInstanceShapeHandlePointElementRefIds | Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasAdaptiveFamilySymbol | Verifies if a FamilyInstance has an Adaptive Family Symbol.
 | IsAdaptiveComponentInstance | Verifies if a FamilyInstance is an Adaptive Component Instance.
 | IsAdaptiveFamilySymbol | Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
 | IsInstanceFlipped | Gets the value of the flip parameter on the adaptive instance.
 | MoveAdaptiveComponentInstance | Moves Adaptive Component Instance by the specified transformation.
 | SetInstanceFlipped | Sets the value of the flip parameter on the adaptive instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdaptiveComponentInstanceUtils Class


CreateAdaptiveComponentInstance Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..CreateAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Creates a FamilyInstance of Adaptive Component Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static FamilyInstance CreateAdaptiveComponentInstance(
    Document doc,
    FamilySymbol famSymb
)
Visual Basic
Public Shared Function CreateAdaptiveComponentInstance ( _
    doc As Document, _
    famSymb As FamilySymbol _
) As FamilyInstance
Visual C++
public:
static FamilyInstance^ CreateAdaptiveComponentInstance(
    Document^ doc,
    FamilySymbol^ famSymb
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The Document
famSymb
Type: Autodesk.Revit.DB..::..FamilySymbol
The FamilySymbol

Return Value

The Family Instance

Remarks

This method creates an Adaptive FamilyInstance and its PointElement references. The references can be accessed by methods like GetInstancePointElementRefIds(). The PointElement references can be moved, rehosted or manipulated just like any other PointElements. The FamilyInstance would then 'adapt' to these references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document doc does not contain the element famSymb -or- The Symbol famSymb is not an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create adaptive component instance.

See Also

AdaptiveComponentInstanceUtils Class


Dispose Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..Dispose Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Releases all resources used by the AdaptiveComponentInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AdaptiveComponentInstanceUtils Class


GetInstancePlacementPointElementRefIds Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..GetInstancePlacementPointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstancePlacementPointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePlacementPointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePlacementPointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The Placement Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains placement point ref ids. The element ids are sorted in by the placement numbers (increasing order).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


GetInstancePointElementRefIds Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..GetInstancePointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstancePointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstancePointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstancePointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains both placement point ref ids and the shape handles point ref ids. The order corresponds to the same order as that of the Adaptive Points in the Family (which may not be ordered as per their placement number). Will return an empty array if there are no placement points and shape handles. To manipulate such an instance the following methods can be useful: 1) RehostAdaptiveComponentInstanceWithNoPlacementPoints() 2) MoveAdaptiveComponentInstance()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


GetInstanceShapeHandlePointElementRefIds Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..GetInstanceShapeHandlePointElementRefIds Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function GetInstanceShapeHandlePointElementRefIds ( _
    famInst As FamilyInstance _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInstanceShapeHandlePointElementRefIds(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

The Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Remarks

The output contains shape handle point ref ids. If there are no shape handle points defined in the Family then the output is empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


HasAdaptiveFamilySymbol Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..HasAdaptiveFamilySymbol Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilyInstance has an Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool HasAdaptiveFamilySymbol(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function HasAdaptiveFamilySymbol ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool HasAdaptiveFamilySymbol(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the FamilyInstance has an Adaptive Family Symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentInstanceUtils Class


IsAdaptiveComponentInstance Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..IsAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilyInstance is an Adaptive Component Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptiveComponentInstance(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function IsAdaptiveComponentInstance ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsAdaptiveComponentInstance(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the FamilyInstance has an Adaptive Component Instances.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentInstanceUtils Class


IsAdaptiveFamilySymbol Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..IsAdaptiveFamilySymbol Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Verifies if a FamilySymbol is a valid Adaptive Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsAdaptiveFamilySymbol(
    FamilySymbol famSymb
)
Visual Basic
Public Shared Function IsAdaptiveFamilySymbol ( _
    famSymb As FamilySymbol _
) As Boolean
Visual C++
public:
static bool IsAdaptiveFamilySymbol(
    FamilySymbol^ famSymb
)

Parameters

famSymb
Type: Autodesk.Revit.DB..::..FamilySymbol
The FamilySymbol

Return Value

True if the FamilySymbol is a valid Adaptive Family Symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentInstanceUtils Class


IsInstanceFlipped Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..IsInstanceFlipped Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Gets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsInstanceFlipped(
    FamilyInstance famInst
)
Visual Basic
Public Shared Function IsInstanceFlipped ( _
    famInst As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsInstanceFlipped(
    FamilyInstance^ famInst
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance

Return Value

True if the instance is flipped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdaptiveComponentInstanceUtils Class


MoveAdaptiveComponentInstance Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..MoveAdaptiveComponentInstance Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Moves Adaptive Component Instance by the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MoveAdaptiveComponentInstance(
    FamilyInstance famInst,
    Transform trf,
    bool unHost
)
Visual Basic
Public Shared Sub MoveAdaptiveComponentInstance ( _
    famInst As FamilyInstance, _
    trf As Transform, _
    unHost As Boolean _
)
Visual C++
public:
static void MoveAdaptiveComponentInstance(
    FamilyInstance^ famInst,
    Transform^ trf,
    bool unHost
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance
trf
Type: Autodesk.Revit.DB..::..Transform
The Transformation
unHost
Type: System..::..Boolean
True if the move should disassociate the Point Element Refs from their hosts. False if the Point Element Refs remain hosted.

Remarks

This method will attempt a rigid body motion of all the individual references and hence the instance itself. However if unHost parameter is 'false' and any of the instance's references are hosted to any geometry, then those references will move within the constraints. The instance then adapts to where its references are moved to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | trf is not a rigid body transformation.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to move the adaptive component instance.

See Also

AdaptiveComponentInstanceUtils Class


SetInstanceFlipped Method

[image]

Revit 2013 API
AdaptiveComponentInstanceUtils..::..SetInstanceFlipped Method
AdaptiveComponentInstanceUtils Class See Also Send Feedback
Sets the value of the flip parameter on the adaptive instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetInstanceFlipped(
    FamilyInstance famInst,
    bool flip
)
Visual Basic
Public Shared Sub SetInstanceFlipped ( _
    famInst As FamilyInstance, _
    flip As Boolean _
)
Visual C++
public:
static void SetInstanceFlipped(
    FamilyInstance^ famInst,
    bool flip
)

Parameters

famInst
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance
flip
Type: System..::..Boolean
The flip flag

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. -or- The FamilyInstance famInst cannot be flipped or unflipped.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

AdaptiveComponentInstanceUtils Class


AdaptivePointConstraintType Enumeration

[image]

Revit 2013 API
AdaptivePointConstraintType Enumeration
See Also Send Feedback
An enumerated type containing possible constraint types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum AdaptivePointConstraintType
Visual Basic
Public Enumeration AdaptivePointConstraintType
Visual C++
public enum class AdaptivePointConstraintType

Members

Member name | Description
None | Not constrained.
Plane_YZ | Constrained to the YZ Plane (x=0).
Plane_ZX | Constrained to the ZX Plane (y=0).
Plane_XY | Constrained to the XY Plane (z=0).
Axis_X | Constrained to the X Axis (y=0, z=0).
Axis_Y | Constrained to the Y Axis (x=0, z=0).
Axis_Z | Constrained to the Z Axis (x=0, y=0).

See Also


AdaptivePointOrientationType Enumeration

[image]

Revit 2013 API
AdaptivePointOrientationType Enumeration
See Also Send Feedback
An enumerated type containing possible orientation types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum AdaptivePointOrientationType
Visual Basic
Public Enumeration AdaptivePointOrientationType
Visual C++
public enum class AdaptivePointOrientationType

Members

Member name | Description
HostReferenceStrictly | Strictly follows the orientation of the host reference point on placement.
HostReferenceAutoFlip | Follows the orientation of the host reference point on placement but calculates and aligns its flip sense with FamilyInstace's coordinate system.
PlacementVertical | Point is oriented vertically on placement.
PlacementOrthogonal | Point is oriented orthogonally on placement.
FamilyVertical | Point is oriented vertically on placement in the FamilyInstace's coordinate system.
FamilyOrthogonal | Point is oriented orthogonally on placement in the FamilyInstace's coordinate system. This value is optimal for performance of families.

See Also


AdaptivePointType Enumeration

[image]

Revit 2013 API
AdaptivePointType Enumeration
See Also Send Feedback
An enumerated type containing possible types for Adaptive Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum AdaptivePointType
Visual Basic
Public Enumeration AdaptivePointType
Visual C++
public enum class AdaptivePointType

Members

Member name | Description
ReferencePoint | Reference Point.
PlacementPoint | Placement Point.
ShapeHandlePoint | Shape Handle Point.

See Also


AddInId Class

[image]

Revit 2013 API
AddInId Class
Members See Also Send Feedback
Identifies an AddIn registered with Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AddInId : IDisposable
Visual Basic
Public Class AddInId _
    Implements IDisposable
Visual C++
public ref class AddInId : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AddInId

See Also

AddInId Members


AddInId Members

[image] [image]

Revit 2013 API
AddInId Members
AddInId Class Constructors Methods See Also Send Feedback

The AddInId type exposes the following members.

Constructors

 | Name | Description
Public method | AddInId | creates an AddInId object with a given GUID

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AddInId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class


AddInId Constructor

[image]

Revit 2013 API
AddInId Constructor
AddInId Class See Also Send Feedback
creates an AddInId object with a given GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AddInId(
    Guid val
)
Visual Basic
Public Sub New ( _
    val As Guid _
)
Visual C++
public:
AddInId(
    Guid val
)

Parameters

val
Type: System..::..Guid
GUID value

See Also

AddInId Class


AddInId Methods

[image] [image]

Revit 2013 API
AddInId Methods
AddInId Class See Also Send Feedback

The AddInId type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInName | name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public method | GetAddInNameFromDocument | name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public method | GetGUID | value of the AddInId as a GUID
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInId Class


Dispose Method

[image]

Revit 2013 API
AddInId..::..Dispose Method
AddInId Class See Also Send Feedback
Releases all resources used by the AddInId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AddInId Class


GetAddInName Method

[image]

Revit 2013 API
AddInId..::..GetAddInName Method
AddInId Class See Also Send Feedback
name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetAddInName()
Visual Basic
Public Function GetAddInName As String
Visual C++
public:
String^ GetAddInName()

Return Value

name of addin

See Also

AddInId Class


GetAddInNameFromDocument Method

[image]

Revit 2013 API
AddInId..::..GetAddInNameFromDocument Method
AddInId Class See Also Send Feedback
name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetAddInNameFromDocument(
    Document aDoc
)
Visual Basic
Public Function GetAddInNameFromDocument ( _
    aDoc As Document _
) As String
Visual C++
public:
String^ GetAddInNameFromDocument(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
target document

Return Value

name of application

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AddInId Class


GetGUID Method

[image]

Revit 2013 API
AddInId..::..GetGUID Method
AddInId Class See Also Send Feedback
value of the AddInId as a GUID

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Guid GetGUID()
Visual Basic
Public Function GetGUID As Guid
Visual C++
public:
Guid GetGUID()

Return Value

GUID value of the AddInId

See Also

AddInId Class


AnalyzesAsType Enumeration

[image]

Revit 2013 API
AnalyzesAsType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter STRUCTURAL_ANALYZES_AS.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyzesAsType
Visual Basic
Public Enumeration AnalyzesAsType
Visual C++
public enum class AnalyzesAsType

Members

Member name | Description
AA_Hanger |
AA_Gravity |
AA_Lateral |
AA_SlabOneWay |
AA_Mat |
AA_SlabOnGrade |
AA_Not_For_Analysis |
AA_SlabTwoWay |
AA_GravityLateral |

See Also


AnnotationSymbol Class

[image]

Revit 2013 API
AnnotationSymbol Class
Members See Also Send Feedback
This object represents a symbol of the Generic Annotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AnnotationSymbol : FamilyInstance
Visual Basic
Public Class AnnotationSymbol _
    Inherits FamilyInstance
Visual C++
public ref class AnnotationSymbol : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..AnnotationSymbol

See Also

AnnotationSymbol Members


AnnotationSymbol Members

[image] [image]

Revit 2013 API
AnnotationSymbol Members
AnnotationSymbol Class Methods Properties See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | addLeader | add a leader to this annotation symbol.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Leaders | Get all the leaders of this annotation symbol.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbol Class


AnnotationSymbol Methods

[image] [image]

Revit 2013 API
AnnotationSymbol Methods
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | addLeader | add a leader to this annotation symbol.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | duplicate | Duplicate this annotation symbol.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | removeLeader | remove a leader of this annotation symbol.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbol Class


addLeader Method

[image]

Revit 2013 API
AnnotationSymbol..::..addLeader Method
AnnotationSymbol Class See Also Send Feedback
add a leader to this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void addLeader()
Visual Basic
Public Sub addLeader
Visual C++
public:
void addLeader()

See Also

AnnotationSymbol Class


duplicate Method

[image]

Revit 2013 API
AnnotationSymbol..::..duplicate Method
AnnotationSymbol Class See Also Send Feedback
Duplicate this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AnnotationSymbol duplicate()
Visual Basic
Public Function duplicate As AnnotationSymbol
Visual C++
public:
AnnotationSymbol^ duplicate()

Return Value

Pointer to the new annotation symbol.

See Also

AnnotationSymbol Class


removeLeader Method

[image]

Revit 2013 API
AnnotationSymbol..::..removeLeader Method
AnnotationSymbol Class See Also Send Feedback
remove a leader of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void removeLeader()
Visual Basic
Public Sub removeLeader
Visual C++
public:
void removeLeader()

See Also

AnnotationSymbol Class


AnnotationSymbol Properties

[image] [image]

Revit 2013 API
AnnotationSymbol Properties
AnnotationSymbol Class See Also Send Feedback

The AnnotationSymbol type exposes the following members.

Properties

 | Name | Description
Public property | AnnotationSymbolType | The AnnotationSymbol style of this AnnotationSymbol.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Leaders | Get all the leaders of this annotation symbol.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbol Class


AnnotationSymbolType Property

[image]

Revit 2013 API
AnnotationSymbol..::..AnnotationSymbolType Property
AnnotationSymbol Class See Also Send Feedback
The AnnotationSymbol style of this AnnotationSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AnnotationSymbolType AnnotationSymbolType { get; set; }
Visual Basic
Public Property AnnotationSymbolType As AnnotationSymbolType
    Get
    Set
Visual C++
public:
property AnnotationSymbolType^ AnnotationSymbolType {
    AnnotationSymbolType^ get ();
    void set (AnnotationSymbolType^ value);
}

Remarks

The AnnotationSymbolType property can be used to retrieve the kind of the wall. This property can also be used to change the type of an annotation by setting it to a different type. All the annotation symbol types in the project can be found using the Document.AnnotationSymbolTypes property.

See Also

AnnotationSymbol Class


FromRoom Property

[image] [image]

Revit 2013 API
AnnotationSymbol..::..FromRoom Property
AnnotationSymbol Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Leaders Property

[image]

Revit 2013 API
AnnotationSymbol..::..Leaders Property
AnnotationSymbol Class See Also Send Feedback
Get all the leaders of this annotation symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic
Public ReadOnly Property Leaders As LeaderArray
    Get
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Return Value

The Leaders property returns a leader array that contains all the leaders of this annotation symbol.

See Also

AnnotationSymbol Class


Parameter Property

[image] [image]

Revit 2013 API
AnnotationSymbol..::..Parameter Property
AnnotationSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Room Property

[image] [image]

Revit 2013 API
AnnotationSymbol..::..Room Property
AnnotationSymbol Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


Space Property

[image] [image]

Revit 2013 API
AnnotationSymbol..::..Space Property
AnnotationSymbol Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


ToRoom Property

[image] [image]

Revit 2013 API
AnnotationSymbol..::..ToRoom Property
AnnotationSymbol Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

AnnotationSymbol Class
AnnotationSymbol Members


AnnotationSymbolType Class

[image]

Revit 2013 API
AnnotationSymbolType Class
Members See Also Send Feedback
An object that represents an annotation style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AnnotationSymbolType : FamilySymbol
Visual Basic
Public Class AnnotationSymbolType _
    Inherits FamilySymbol
Visual C++
public ref class AnnotationSymbolType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AnnotationSymbolType

See Also

AnnotationSymbolType Members


AnnotationSymbolType Members

[image] [image]

Revit 2013 API
AnnotationSymbolType Members
AnnotationSymbolType Class Methods Properties See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbolType Class


AnnotationSymbolType Methods

[image] [image]

Revit 2013 API
AnnotationSymbolType Methods
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolType Class


AnnotationSymbolType Properties

[image] [image]

Revit 2013 API
AnnotationSymbolType Properties
AnnotationSymbolType Class See Also Send Feedback

The AnnotationSymbolType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnnotationSymbolType Class


Parameter Property

[image] [image]

Revit 2013 API
AnnotationSymbolType..::..Parameter Property
AnnotationSymbolType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnnotationSymbolType Class
AnnotationSymbolType Members


AnnotationSymbolTypeSet Class

[image]

Revit 2013 API
AnnotationSymbolTypeSet Class
Members See Also Send Feedback
A set that contains AnnotationSymbol types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AnnotationSymbolTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class AnnotationSymbolTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AnnotationSymbolTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..AnnotationSymbolTypeSet

See Also

AnnotationSymbolTypeSet Members


AnnotationSymbolTypeSet Members

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSet Members
AnnotationSymbolTypeSet Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSet | Initializes a new instance of the AnnotationSymbolTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Constructor

[image]

Revit 2013 API
AnnotationSymbolTypeSet Constructor
AnnotationSymbolTypeSet Class See Also Send Feedback
Initializes a new instance of the AnnotationSymbolTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSet()

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Methods

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSet Methods
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every AnnotationSymbol type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a AnnotationSymbol type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified AnnotationSymbol type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified AnnotationSymbol type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSet Class


Clear Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..Clear Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes every AnnotationSymbol type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AnnotationSymbolTypeSet Class


Contains Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..Contains Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Tests for the existence of a AnnotationSymbol type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    AnnotationSymbolType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AnnotationSymbolType
The AnnotationSymbol type to be searched for.

Return Value

The Contains method returns True if the AnnotationSymbol type is within the set, otherwise False.

See Also

AnnotationSymbolTypeSet Class


Erase Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..Erase Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Removes a specified AnnotationSymbol type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    AnnotationSymbolType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As AnnotationSymbolType _
) As Integer
Visual C++
public:
virtual int Erase(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AnnotationSymbolType
The AnnotationSymbol type to be erased.

Return Value

The number of AnnotationSymbol types that were erased from the set.

See Also

AnnotationSymbolTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..ForwardIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..GetEnumerator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

AnnotationSymbolTypeSet Class


Insert Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..Insert Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Insert the specified AnnotationSymbol type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    AnnotationSymbolType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As AnnotationSymbolType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AnnotationSymbolType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AnnotationSymbolType
The AnnotationSymbol type to be inserted into the set.

Return Value

Returns whether the AnnotationSymbol type was inserted into the set.

See Also

AnnotationSymbolTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..ReverseIterator Method
AnnotationSymbolTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AnnotationSymbolTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As AnnotationSymbolTypeSetIterator
Visual C++
public:
virtual AnnotationSymbolTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSet Properties

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSet Properties
AnnotationSymbolTypeSet Class See Also Send Feedback

The AnnotationSymbolTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of AnnotationSymbol types that are in the set.

See Also

AnnotationSymbolTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..IsEmpty Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AnnotationSymbolTypeSet Class


Size Property

[image]

Revit 2013 API
AnnotationSymbolTypeSet..::..Size Property
AnnotationSymbolTypeSet Class See Also Send Feedback
Returns the number of AnnotationSymbol types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AnnotationSymbolTypeSet Class


AnnotationSymbolTypeSetIterator Class

[image]

Revit 2013 API
AnnotationSymbolTypeSetIterator Class
Members See Also Send Feedback
An iterator to a AnnotationSymbol type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class AnnotationSymbolTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class AnnotationSymbolTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AnnotationSymbolTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..AnnotationSymbolTypeSetIterator

See Also

AnnotationSymbolTypeSetIterator Members


AnnotationSymbolTypeSetIterator Members

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSetIterator Members
AnnotationSymbolTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | AnnotationSymbolTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Constructor

[image]

Revit 2013 API
AnnotationSymbolTypeSetIterator Constructor
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AnnotationSymbolTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
AnnotationSymbolTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Methods

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSetIterator Methods
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnnotationSymbolTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
AnnotationSymbolTypeSetIterator..::..MoveNext Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
AnnotationSymbolTypeSetIterator..::..Reset Method
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AnnotationSymbolTypeSetIterator Class


AnnotationSymbolTypeSetIterator Properties

[image] [image]

Revit 2013 API
AnnotationSymbolTypeSetIterator Properties
AnnotationSymbolTypeSetIterator Class See Also Send Feedback

The AnnotationSymbolTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AnnotationSymbolTypeSetIterator Class


Current Property

[image]

Revit 2013 API
AnnotationSymbolTypeSetIterator..::..Current Property
AnnotationSymbolTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AnnotationSymbolTypeSetIterator Class


APIObject Class

[image]

Revit 2013 API
APIObject Class
Members See Also Send Feedback
Supports all objects in the Autodesk Revit API hierarchy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class APIObject : IDisposable
Visual Basic
Public Class APIObject _
    Implements IDisposable
Visual C++
public ref class APIObject : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Collections..::..StringStringMap
Autodesk.Revit.Collections..::..StringStringMapIterator
Autodesk.Revit.Creation..::..Application
Autodesk.Revit.Creation..::..ItemFactoryBase
Autodesk.Revit.DB..::..AnnotationSymbolTypeSet
Autodesk.Revit.DB..::..AnnotationSymbolTypeSetIterator
Autodesk.Revit.DB.Architecture..::..BoundarySegment
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArray
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayArray
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayIterator
Autodesk.Revit.DB.Architecture..::..FasciaTypeSet
Autodesk.Revit.DB.Architecture..::..FasciaTypeSetIterator
Autodesk.Revit.DB.Architecture..::..GutterTypeSet
Autodesk.Revit.DB.Architecture..::..GutterTypeSetIterator
Autodesk.Revit.DB.Architecture..::..RoomTagTypeSet
Autodesk.Revit.DB.Architecture..::..RoomTagTypeSetIterator
Autodesk.Revit.DB..::..AreaTagTypeSet
Autodesk.Revit.DB..::..AreaTagTypeSetIterator
Autodesk.Revit.DB..::..BeamSystemTypeSet
Autodesk.Revit.DB..::..BeamSystemTypeSetIterator
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..BoundarySegment
Autodesk.Revit.DB..::..BoundarySegmentArray
Autodesk.Revit.DB..::..BoundarySegmentArrayArray
Autodesk.Revit.DB..::..BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB..::..BoundarySegmentArrayIterator
Autodesk.Revit.DB..::..BoundingBoxXYZ
Autodesk.Revit.DB..::..Category
Autodesk.Revit.DB..::..CategoryNameMap
Autodesk.Revit.DB..::..CategoryNameMapIterator
Autodesk.Revit.DB..::..CategorySet
Autodesk.Revit.DB..::..CategorySetIterator
Autodesk.Revit.DB..::..City
Autodesk.Revit.DB..::..CitySet
Autodesk.Revit.DB..::..CitySetIterator
Autodesk.Revit.DB..::..Color
Autodesk.Revit.DB..::..CombinableElementArray
Autodesk.Revit.DB..::..CombinableElementArrayIterator
Autodesk.Revit.DB..::..ConnectorSet
Autodesk.Revit.DB..::..ConnectorSetIterator
Autodesk.Revit.DB..::..ContFootingTypeSet
Autodesk.Revit.DB..::..ContFootingTypeSetIterator
Autodesk.Revit.DB..::..CurtainCell
Autodesk.Revit.DB..::..CurtainCellSet
Autodesk.Revit.DB..::..CurtainCellSetIterator
Autodesk.Revit.DB..::..CurtainGrid
Autodesk.Revit.DB..::..CurtainGridSet
Autodesk.Revit.DB..::..CurtainGridSetIterator
Autodesk.Revit.DB..::..CurtainSystemTypeSet
Autodesk.Revit.DB..::..CurtainSystemTypeSetIterator
Autodesk.Revit.DB..::..CurveArrArray
Autodesk.Revit.DB..::..CurveArrArrayIterator
Autodesk.Revit.DB..::..CurveArray
Autodesk.Revit.DB..::..CurveArrayIterator
Autodesk.Revit.DB..::..CurveByPointsArray
Autodesk.Revit.DB..::..CurveByPointsArrayIterator
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..DefinitionBindingMapIterator
Autodesk.Revit.DB..::..DefinitionFile
Autodesk.Revit.DB..::..DefinitionGroup
Autodesk.Revit.DB..::..DetailCurveArray
Autodesk.Revit.DB..::..DetailCurveArrayIterator
Autodesk.Revit.DB..::..DimensionSegment
Autodesk.Revit.DB..::..DimensionSegmentArray
Autodesk.Revit.DB..::..DimensionSegmentArrayIterator
Autodesk.Revit.DB..::..DimensionTypeSet
Autodesk.Revit.DB..::..DimensionTypeSetIterator
Autodesk.Revit.DB..::..DividedSurfaceData
Autodesk.Revit.DB..::..DocumentSet
Autodesk.Revit.DB..::..DocumentSetIterator
Autodesk.Revit.DB..::..DoubleArray
Autodesk.Revit.DB..::..DoubleArrayIterator
Autodesk.Revit.DB..::..EdgeArray
Autodesk.Revit.DB..::..EdgeArrayArray
Autodesk.Revit.DB..::..EdgeArrayArrayIterator
Autodesk.Revit.DB..::..EdgeArrayIterator
Autodesk.Revit.DB.Electrical..::..CorrectionFactor
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSet
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSetIterator
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSet
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSetIterator
Autodesk.Revit.DB.Electrical..::..ElectricalSetting
Autodesk.Revit.DB.Electrical..::..ElectricalSystemSet
Autodesk.Revit.DB.Electrical..::..ElectricalSystemSetIterator
Autodesk.Revit.DB.Electrical..::..GroundConductorSize
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSet
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSetIterator
Autodesk.Revit.DB.Electrical..::..InsulationTypeSet
Autodesk.Revit.DB.Electrical..::..InsulationTypeSetIterator
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSet
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSetIterator
Autodesk.Revit.DB.Electrical..::..VoltageTypeSet
Autodesk.Revit.DB.Electrical..::..VoltageTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireConduitType
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSet
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSet
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSetIterator
Autodesk.Revit.DB.Electrical..::..WireSet
Autodesk.Revit.DB.Electrical..::..WireSetIterator
Autodesk.Revit.DB.Electrical..::..WireSize
Autodesk.Revit.DB.Electrical..::..WireSizeSet
Autodesk.Revit.DB.Electrical..::..WireSizeSetIterator
Autodesk.Revit.DB.Electrical..::..WireTypeSet
Autodesk.Revit.DB.Electrical..::..WireTypeSetIterator
Autodesk.Revit.DB..::..ElementArray
Autodesk.Revit.DB..::..ElementArrayIterator
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.DB..::..ElementSetIterator
Autodesk.Revit.DB..::..FaceArray
Autodesk.Revit.DB..::..FaceArrayIterator
Autodesk.Revit.DB..::..FamilyElementVisibility
Autodesk.Revit.DB..::..FamilyManager
Autodesk.Revit.DB..::..FamilyParameter
Autodesk.Revit.DB..::..FamilyParameterSet
Autodesk.Revit.DB..::..FamilyParameterSetIterator
Autodesk.Revit.DB..::..FamilyPointLocation
Autodesk.Revit.DB..::..FamilyPointPlacementReference
Autodesk.Revit.DB..::..FamilySymbolSet
Autodesk.Revit.DB..::..FamilySymbolSetIterator
Autodesk.Revit.DB..::..FamilyType
Autodesk.Revit.DB..::..FamilyTypeSet
Autodesk.Revit.DB..::..FamilyTypeSetIterator
Autodesk.Revit.DB..::..FloorTypeSet
Autodesk.Revit.DB..::..FloorTypeSetIterator
Autodesk.Revit.DB..::..FormArray
Autodesk.Revit.DB..::..FormArrayIterator
Autodesk.Revit.DB..::..FormatOptions
Autodesk.Revit.DB..::..GenericFormSet
Autodesk.Revit.DB..::..GenericFormSetIterator
Autodesk.Revit.DB..::..GeomCombinationSet
Autodesk.Revit.DB..::..GeomCombinationSetIterator
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryObjectArray
Autodesk.Revit.DB..::..GeometryObjectArrayIterator
Autodesk.Revit.DB..::..GridTypeSet
Autodesk.Revit.DB..::..GridTypeSetIterator
Autodesk.Revit.DB..::..GroupSet
Autodesk.Revit.DB..::..GroupSetIterator
Autodesk.Revit.DB..::..InstanceArray
Autodesk.Revit.DB..::..InstanceArrayIterator
Autodesk.Revit.DB..::..IntersectionResult
Autodesk.Revit.DB..::..IntersectionResultArray
Autodesk.Revit.DB..::..IntersectionResultArrayIterator
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..Leader
Autodesk.Revit.DB..::..LeaderArray
Autodesk.Revit.DB..::..LeaderArrayIterator
Autodesk.Revit.DB..::..LevelTypeSet
Autodesk.Revit.DB..::..LevelTypeSetIterator
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..MaterialSet
Autodesk.Revit.DB..::..MaterialSetIterator
Autodesk.Revit.DB.Mechanical..::..BoundarySegment
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArray
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayArray
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayArrayIterator
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayIterator
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSet
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSetIterator
Autodesk.Revit.DB.Mechanical..::..SpaceSet
Autodesk.Revit.DB.Mechanical..::..SpaceSetIterator
Autodesk.Revit.DB.Mechanical..::..SpaceTagTypeSet
Autodesk.Revit.DB.Mechanical..::..SpaceTagTypeSetIterator
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB..::..MeshArray
Autodesk.Revit.DB..::..MeshArrayIterator
Autodesk.Revit.DB..::..MeshTriangle
Autodesk.Revit.DB..::..ModelCurveArrArray
Autodesk.Revit.DB..::..ModelCurveArrArrayIterator
Autodesk.Revit.DB..::..ModelCurveArray
Autodesk.Revit.DB..::..ModelCurveArrayIterator
Autodesk.Revit.DB..::..MullionTypeSet
Autodesk.Revit.DB..::..MullionTypeSetIterator
Autodesk.Revit.DB..::..Options
Autodesk.Revit.DB..::..PanelTypeSet
Autodesk.Revit.DB..::..PanelTypeSetIterator
Autodesk.Revit.DB..::..PaperSize
Autodesk.Revit.DB..::..PaperSizeSet
Autodesk.Revit.DB..::..PaperSizeSetIterator
Autodesk.Revit.DB..::..PaperSource
Autodesk.Revit.DB..::..PaperSourceSet
Autodesk.Revit.DB..::..PaperSourceSetIterator
Autodesk.Revit.DB..::..Parameter
Autodesk.Revit.DB..::..ParameterMap
Autodesk.Revit.DB..::..ParameterMapIterator
Autodesk.Revit.DB..::..ParameterSet
Autodesk.Revit.DB..::..ParameterSetIterator
Autodesk.Revit.DB..::..PhaseArray
Autodesk.Revit.DB..::..PhaseArrayIterator
Autodesk.Revit.DB..::..PlanCircuit
Autodesk.Revit.DB..::..PlanCircuitSet
Autodesk.Revit.DB..::..PlanCircuitSetIterator
Autodesk.Revit.DB..::..Plane
Autodesk.Revit.DB..::..PlanTopology
Autodesk.Revit.DB..::..PlanTopologySet
Autodesk.Revit.DB..::..PlanTopologySetIterator
Autodesk.Revit.DB..::..PrintManager
Autodesk.Revit.DB..::..PrintParameters
Autodesk.Revit.DB..::..PrintSetup
Autodesk.Revit.DB..::..ProjectLocationSet
Autodesk.Revit.DB..::..ProjectLocationSetIterator
Autodesk.Revit.DB..::..ProjectPosition
Autodesk.Revit.DB..::..Reference
Autodesk.Revit.DB..::..ReferenceArray
Autodesk.Revit.DB..::..ReferenceArrayArray
Autodesk.Revit.DB..::..ReferenceArrayArrayIterator
Autodesk.Revit.DB..::..ReferenceArrayIterator
Autodesk.Revit.DB..::..ReferencePointArray
Autodesk.Revit.DB..::..ReferencePointArrayIterator
Autodesk.Revit.DB..::..RoofTypeSet
Autodesk.Revit.DB..::..RoofTypeSetIterator
Autodesk.Revit.DB..::..Settings
Autodesk.Revit.DB..::..SlabEdgeTypeSet
Autodesk.Revit.DB..::..SlabEdgeTypeSetIterator
Autodesk.Revit.DB..::..SlabShapeCreaseArray
Autodesk.Revit.DB..::..SlabShapeCreaseArrayIterator
Autodesk.Revit.DB..::..SlabShapeVertexArray
Autodesk.Revit.DB..::..SlabShapeVertexArrayIterator
Autodesk.Revit.DB..::..SolidArray
Autodesk.Revit.DB..::..SolidArrayIterator
Autodesk.Revit.DB..::..SpacingRule
Autodesk.Revit.DB..::..SpotDimensionTypeSet
Autodesk.Revit.DB..::..SpotDimensionTypeSetIterator
Autodesk.Revit.DB.Structure..::..AreaLoadTypeSet
Autodesk.Revit.DB.Structure..::..AreaLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::..LineLoadTypeSet
Autodesk.Revit.DB.Structure..::..LineLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::..LoadCaseArray
Autodesk.Revit.DB.Structure..::..LoadCaseArrayIterator
Autodesk.Revit.DB.Structure..::..LoadCaseSet
Autodesk.Revit.DB.Structure..::..LoadCaseSetIterator
Autodesk.Revit.DB.Structure..::..LoadCombinationArray
Autodesk.Revit.DB.Structure..::..LoadCombinationArrayIterator
Autodesk.Revit.DB.Structure..::..LoadTypeBaseSet
Autodesk.Revit.DB.Structure..::..LoadTypeBaseSetIterator
Autodesk.Revit.DB.Structure..::..LoadUsageArray
Autodesk.Revit.DB.Structure..::..LoadUsageArrayIterator
Autodesk.Revit.DB.Structure..::..PointLoadTypeSet
Autodesk.Revit.DB.Structure..::..PointLoadTypeSetIterator
Autodesk.Revit.DB.Structure..::..RebarBarTypeSet
Autodesk.Revit.DB.Structure..::..RebarBarTypeSetIterator
Autodesk.Revit.DB.Structure..::..RebarCoverTypeSet
Autodesk.Revit.DB.Structure..::..RebarCoverTypeSetIterator
Autodesk.Revit.DB.Structure..::..RebarHookTypeSet
Autodesk.Revit.DB.Structure..::..RebarHookTypeSetIterator
Autodesk.Revit.DB.Structure..::..RebarShapeSet
Autodesk.Revit.DB.Structure..::..RebarShapeSetIterator
Autodesk.Revit.DB.Structure..::..TrussTypeSet
Autodesk.Revit.DB.Structure..::..TrussTypeSetIterator
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..SymbolicCurveArray
Autodesk.Revit.DB..::..SymbolicCurveArrayIterator
Autodesk.Revit.DB..::..TextNoteTypeSet
Autodesk.Revit.DB..::..TextNoteTypeSetIterator
Autodesk.Revit.DB..::..ThermalProperties
Autodesk.Revit.DB..::..TilePatterns
Autodesk.Revit.DB..::..Transform
Autodesk.Revit.DB..::..VertexIndexPairArray
Autodesk.Revit.DB..::..VertexIndexPairArrayIterator
Autodesk.Revit.DB..::..ViewSet
Autodesk.Revit.DB..::..ViewSetIterator
Autodesk.Revit.DB..::..ViewSheetSets
Autodesk.Revit.DB..::..ViewSheetSetsIterator
Autodesk.Revit.DB..::..ViewSheetSetting
Autodesk.Revit.DB..::..WallTypeSet
Autodesk.Revit.DB..::..WallTypeSetIterator
Autodesk.Revit.UI.Events..::..DialogBoxData
Autodesk.Revit.UI..::..ExternalApplicationArray
Autodesk.Revit.UI..::..ExternalApplicationArrayIterator
Autodesk.Revit.UI..::..ExternalCommandData
Autodesk.Revit.UI.Selection..::..Selection
Autodesk.Revit.UI..::..TaskDialog
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetSet
Autodesk.Revit.Utility..::..AssetSetIterator

See Also

APIObject Members


APIObject Members

[image] [image]

Revit 2013 API
APIObject Members
APIObject Class Methods Properties See Also Send Feedback

The APIObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


APIObject Methods

[image] [image]

Revit 2013 API
APIObject Methods
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

APIObject Class


Dispose Method

[image]

Revit 2013 API
APIObject..::..Dispose Method
APIObject Class See Also Send Feedback
Causes the object to release immediately any resources it may be utilizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

Remarks

This method is usually called implicitly by the programming language when the object is destroyed. After calling this method the object will no longer work correctly.

See Also

APIObject Class


APIObject Properties

[image] [image]

Revit 2013 API
APIObject Properties
APIObject Class See Also Send Feedback

The APIObject type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable.

See Also

APIObject Class


IsReadOnly Property

[image]

Revit 2013 API
APIObject..::..IsReadOnly Property
APIObject Class Example See Also Send Feedback
Identifies if the object is read-only or modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsReadOnly { get; }
Visual Basic
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get ();
}

Field Value

If true, the object may not be modified. If false, the object's contents may be modified.

Examples

CopyC#
Document project = uiApplication.ActiveUIDocument.Document;
Settings settings = project.Settings;
TaskDialog.Show("Revit","Categories: " + settings.Categories.IsReadOnly.ToString());
CopyVB.NET
Dim project As Document = uiApplication.ActiveUIDocument.Document
Dim settings As Settings = project.Settings
TaskDialog.Show("Revit", "Categories: " + settings.Categories.IsReadOnly.ToString())

See Also

APIObject Class


Arc Class

[image]

Revit 2013 API
Arc Class
Members See Also Send Feedback
A circular arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Arc : Curve
Visual Basic
Public Class Arc _
    Inherits Curve
Visual C++
public ref class Arc : public Curve

Remarks

The arc lies in the plane defined by center and normal.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Arc

See Also

Arc Members


Arc Members

[image] [image]

Revit 2013 API
Arc Members
Arc Class Methods Properties See Also Send Feedback

The Arc type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.

See Also

Arc Class


Arc Methods

[image] [image]

Revit 2013 API
Arc Methods
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Arc Class


Intersect Method

[image] [image]

Revit 2013 API
Arc..::..Intersect Method
Arc Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Arc Class
Arc Members


IsInside Method

[image] [image]

Revit 2013 API
Arc..::..IsInside Method
Arc Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Arc Class
Arc Members


Arc Properties

[image] [image]

Revit 2013 API
Arc Properties
Arc Class See Also Send Feedback

The Arc type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the arc.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the arc is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Radius | Returns the radius of the arc.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | Returns the X direction.
Public property | YDirection | Returns the Y direction.

See Also

Arc Class


Center Property

[image]

Revit 2013 API
Arc..::..Center Property
Arc Class See Also Send Feedback
Returns the center of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic
Public ReadOnly Property Center As XYZ
    Get
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Arc Class


Normal Property

[image]

Revit 2013 API
Arc..::..Normal Property
Arc Class See Also Send Feedback
Returns the normal to the plane in which the arc is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Arc Class


Radius Property

[image]

Revit 2013 API
Arc..::..Radius Property
Arc Class See Also Send Feedback
Returns the radius of the arc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Double
    Get
Visual C++
public:
property double Radius {
    double get ();
}

See Also

Arc Class


XDirection Property

[image]

Revit 2013 API
Arc..::..XDirection Property
Arc Class See Also Send Feedback
Returns the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ XDirection { get; }
Visual Basic
Public ReadOnly Property XDirection As XYZ
    Get
Visual C++
public:
property XYZ^ XDirection {
    XYZ^ get ();
}

See Also

Arc Class


YDirection Property

[image]

Revit 2013 API
Arc..::..YDirection Property
Arc Class See Also Send Feedback
Returns the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ YDirection { get; }
Visual Basic
Public ReadOnly Property YDirection As XYZ
    Get
Visual C++
public:
property XYZ^ YDirection {
    XYZ^ get ();
}

See Also

Arc Class


Area Class

[image]

Revit 2013 API
Area Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Area : SpatialElement
Visual Basic
Public Class Area _
    Inherits SpatialElement
Visual C++
public ref class Area : public SpatialElement

Remarks

The area object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB..::..Area

See Also

Area Members


Area Members

[image] [image]

Revit 2013 API
Area Members
Area Class Methods Properties See Also Send Feedback

The Area type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Area Class


Area Methods

[image] [image]

Revit 2013 API
Area Methods
Area Class See Also Send Feedback

The Area type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Area Class


Area Properties

[image] [image]

Revit 2013 API
Area Properties
Area Class See Also Send Feedback

The Area type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossInterior | The boolean value that indicates whether the area is gross interior.
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Area Class


AreaScheme Property

[image]

Revit 2013 API
Area..::..AreaScheme Property
Area Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic
Public ReadOnly Property AreaScheme As AreaScheme
    Get
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

See Also

Area Class


IsGrossInterior Property

[image]

Revit 2013 API
Area..::..IsGrossInterior Property
Area Class See Also Send Feedback
The boolean value that indicates whether the area is gross interior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsGrossInterior { get; }
Visual Basic
Public ReadOnly Property IsGrossInterior As Boolean
    Get
Visual C++
public:
property bool IsGrossInterior {
    bool get ();
}

See Also

Area Class


Parameter Property

[image] [image]

Revit 2013 API
Area..::..Parameter Property
Area Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Area Class
Area Members


AreaElemType Enumeration

[image]

Revit 2013 API
AreaElemType Enumeration
See Also Send Feedback
An enumerated type to store type of AreaElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AreaElemType
Visual Basic
Public Enumeration AreaElemType
Visual C++
public enum class AreaElemType

Members

Member name | Description
GrossArea | Gross Area Scheme - only 2 types of spaces (internal and external).
BOMAArea | Office Area Scheme - uses BOMA rules for space classification.

See Also


AreaFilter Class

[image]

Revit 2013 API
AreaFilter Class
Members Example See Also Send Feedback
A filter used to match areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaFilter : ElementSlowFilter
Visual Basic
Public Class AreaFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
// supported by those methods.
AreaFilter filter = new AreaFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> areas = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Use a AreaFilter to find all area elements in the document. It is necessary to use the AreaFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the area class is not
' supported by those methods.
Dim filter As New AreaFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim areas As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaFilter

See Also

AreaFilter Members


AreaFilter Members

[image] [image]

Revit 2013 API
AreaFilter Members
AreaFilter Class Constructors Methods Properties See Also Send Feedback

The AreaFilter type exposes the following members.

Constructors

 | Name | Description
Public method | AreaFilter | Constructs a filter which matches only areas.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaFilter Constructor

[image]

Revit 2013 API
AreaFilter Constructor
AreaFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaFilter()
Visual Basic
Public Sub New
Visual C++
public:
AreaFilter()

See Also

AreaFilter Class


AreaFilter Methods

[image] [image]

Revit 2013 API
AreaFilter Methods
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
AreaFilter..::..PassesFilter Method
AreaFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

AreaFilter Class
AreaFilter Members


AreaFilter Properties

[image] [image]

Revit 2013 API
AreaFilter Properties
AreaFilter Class See Also Send Feedback

The AreaFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaFilter Class


AreaScheme Class

[image]

Revit 2013 API
AreaScheme Class
Members See Also Send Feedback
The area scheme associated with a particular area plan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaScheme : Element
Visual Basic
Public Class AreaScheme _
    Inherits Element
Visual C++
public ref class AreaScheme : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AreaScheme

See Also

AreaScheme Members


AreaScheme Members

[image] [image]

Revit 2013 API
AreaScheme Members
AreaScheme Class Methods Properties See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaScheme Class


AreaScheme Methods

[image] [image]

Revit 2013 API
AreaScheme Methods
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaScheme Class


AreaScheme Properties

[image] [image]

Revit 2013 API
AreaScheme Properties
AreaScheme Class See Also Send Feedback

The AreaScheme type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsGrossBuildingArea | Indicates if the area scheme is a Gross Building Area scheme.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaScheme Class


IsGrossBuildingArea Property

[image]

Revit 2013 API
AreaScheme..::..IsGrossBuildingArea Property
AreaScheme Class See Also Send Feedback
Indicates if the area scheme is a Gross Building Area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsGrossBuildingArea { get; }
Visual Basic
Public ReadOnly Property IsGrossBuildingArea As Boolean
    Get
Visual C++
public:
property bool IsGrossBuildingArea {
    bool get ();
}

See Also

AreaScheme Class


Parameter Property

[image] [image]

Revit 2013 API
AreaScheme..::..Parameter Property
AreaScheme Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaScheme Class
AreaScheme Members


AreaTag Class

[image]

Revit 2013 API
AreaTag Class
Members See Also Send Feedback
Provides access to the area topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaTag : SpatialElementTag
Visual Basic
Public Class AreaTag _
    Inherits SpatialElementTag
Visual C++
public ref class AreaTag : public SpatialElementTag

Remarks

The areaTag object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB..::..AreaTag

See Also

AreaTag Members


AreaTag Members

[image] [image]

Revit 2013 API
AreaTag Members
AreaTag Class Methods Properties See Also Send Feedback

The AreaTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTag Class


AreaTag Methods

[image] [image]

Revit 2013 API
AreaTag Methods
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTag Class


AreaTag Properties

[image] [image]

Revit 2013 API
AreaTag Properties
AreaTag Class See Also Send Feedback

The AreaTag type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area that the tag is associated with.
Public property | AreaTagType | The tag type.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTag Class


Area Property

[image]

Revit 2013 API
AreaTag..::..Area Property
AreaTag Class See Also Send Feedback
The area that the tag is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Area Area { get; }
Visual Basic
Public ReadOnly Property Area As Area
    Get
Visual C++
public:
property Area^ Area {
    Area^ get ();
}

Remarks

In rare cases, the tag may not be associated to an area. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

AreaTag Class


AreaTagType Property

[image]

Revit 2013 API
AreaTag..::..AreaTagType Property
AreaTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaTagType AreaTagType { get; set; }
Visual Basic
Public Property AreaTagType As AreaTagType
    Get
    Set
Visual C++
public:
property AreaTagType^ AreaTagType {
    AreaTagType^ get ();
    void set (AreaTagType^ value);
}

See Also

AreaTag Class


Parameter Property

[image] [image]

Revit 2013 API
AreaTag..::..Parameter Property
AreaTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaTag Class
AreaTag Members


AreaTagFilter Class

[image]

Revit 2013 API
AreaTagFilter Class
Members See Also Send Feedback
A filter used to match area tags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaTagFilter : ElementSlowFilter
Visual Basic
Public Class AreaTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class AreaTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..AreaTagFilter

See Also

AreaTagFilter Members


AreaTagFilter Members

[image] [image]

Revit 2013 API
AreaTagFilter Members
AreaTagFilter Class Constructors Methods Properties See Also Send Feedback

The AreaTagFilter type exposes the following members.

Constructors

 | Name | Description
Public method | AreaTagFilter | Constructs a filter which matches only areas.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagFilter Constructor

[image]

Revit 2013 API
AreaTagFilter Constructor
AreaTagFilter Class See Also Send Feedback
Constructs a filter which matches only areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaTagFilter()
Visual Basic
Public Sub New
Visual C++
public:
AreaTagFilter()

See Also

AreaTagFilter Class


AreaTagFilter Methods

[image] [image]

Revit 2013 API
AreaTagFilter Methods
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
AreaTagFilter..::..PassesFilter Method
AreaTagFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class
AreaTagFilter Members


AreaTagFilter Properties

[image] [image]

Revit 2013 API
AreaTagFilter Properties
AreaTagFilter Class See Also Send Feedback

The AreaTagFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

AreaTagFilter Class


AreaTagType Class

[image]

Revit 2013 API
AreaTagType Class
Members See Also Send Feedback
An object that represents an Area Tag style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaTagType : FamilySymbol
Visual Basic
Public Class AreaTagType _
    Inherits FamilySymbol
Visual C++
public ref class AreaTagType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AreaTagType

See Also

AreaTagType Members


AreaTagType Members

[image] [image]

Revit 2013 API
AreaTagType Members
AreaTagType Class Methods Properties See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTagType Class


AreaTagType Methods

[image] [image]

Revit 2013 API
AreaTagType Methods
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagType Class


AreaTagType Properties

[image] [image]

Revit 2013 API
AreaTagType Properties
AreaTagType Class See Also Send Feedback

The AreaTagType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaTagType Class


Parameter Property

[image] [image]

Revit 2013 API
AreaTagType..::..Parameter Property
AreaTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaTagType Class
AreaTagType Members


AreaTagTypeSet Class

[image]

Revit 2013 API
AreaTagTypeSet Class
Members See Also Send Feedback
A set that contains areatag types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaTagTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class AreaTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..AreaTagTypeSet

See Also

AreaTagTypeSet Members


AreaTagTypeSet Members

[image] [image]

Revit 2013 API
AreaTagTypeSet Members
AreaTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | AreaTagTypeSet | Initializes a new instance of the AreaTagTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class


AreaTagTypeSet Constructor

[image]

Revit 2013 API
AreaTagTypeSet Constructor
AreaTagTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaTagTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaTagTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
AreaTagTypeSet()

See Also

AreaTagTypeSet Class


AreaTagTypeSet Methods

[image] [image]

Revit 2013 API
AreaTagTypeSet Methods
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every areatag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areatag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areatag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areatag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSet Class


Clear Method

[image]

Revit 2013 API
AreaTagTypeSet..::..Clear Method
AreaTagTypeSet Class See Also Send Feedback
Removes every areatag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaTagTypeSet Class


Contains Method

[image]

Revit 2013 API
AreaTagTypeSet..::..Contains Method
AreaTagTypeSet Class See Also Send Feedback
Tests for the existence of a areatag type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaTagType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AreaTagType
The areatag type to be searched for.

Return Value

The Contains method returns True if the areatag type is within the set, otherwise False.

See Also

AreaTagTypeSet Class


Erase Method

[image]

Revit 2013 API
AreaTagTypeSet..::..Erase Method
AreaTagTypeSet Class See Also Send Feedback
Removes a specified areatag type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    AreaTagType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As AreaTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AreaTagType
The areatag type to be erased.

Return Value

The number of areatag types that were erased from the set.

See Also

AreaTagTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
AreaTagTypeSet..::..ForwardIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaTagTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
AreaTagTypeSet..::..GetEnumerator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

AreaTagTypeSet Class


Insert Method

[image]

Revit 2013 API
AreaTagTypeSet..::..Insert Method
AreaTagTypeSet Class See Also Send Feedback
Insert the specified areatag type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaTagType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As AreaTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..AreaTagType
The areatag type to be inserted into the set.

Return Value

Returns whether the areatag type was inserted into the set.

See Also

AreaTagTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
AreaTagTypeSet..::..ReverseIterator Method
AreaTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AreaTagTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As AreaTagTypeSetIterator
Visual C++
public:
virtual AreaTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaTagTypeSet Class


AreaTagTypeSet Properties

[image] [image]

Revit 2013 API
AreaTagTypeSet Properties
AreaTagTypeSet Class See Also Send Feedback

The AreaTagTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areatag types that are in the set.

See Also

AreaTagTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
AreaTagTypeSet..::..IsEmpty Property
AreaTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaTagTypeSet Class


Size Property

[image]

Revit 2013 API
AreaTagTypeSet..::..Size Property
AreaTagTypeSet Class See Also Send Feedback
Returns the number of areatag types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaTagTypeSet Class


AreaTagTypeSetIterator Class

[image]

Revit 2013 API
AreaTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areatag type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class AreaTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class AreaTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..AreaTagTypeSetIterator

See Also

AreaTagTypeSetIterator Members


AreaTagTypeSetIterator Members

[image] [image]

Revit 2013 API
AreaTagTypeSetIterator Members
AreaTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | AreaTagTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Constructor

[image]

Revit 2013 API
AreaTagTypeSetIterator Constructor
AreaTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaTagTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
AreaTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Methods

[image] [image]

Revit 2013 API
AreaTagTypeSetIterator Methods
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaTagTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
AreaTagTypeSetIterator..::..MoveNext Method
AreaTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
AreaTagTypeSetIterator..::..Reset Method
AreaTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaTagTypeSetIterator Class


AreaTagTypeSetIterator Properties

[image] [image]

Revit 2013 API
AreaTagTypeSetIterator Properties
AreaTagTypeSetIterator Class See Also Send Feedback

The AreaTagTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaTagTypeSetIterator Class


Current Property

[image]

Revit 2013 API
AreaTagTypeSetIterator..::..Current Property
AreaTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaTagTypeSetIterator Class


ArrayAnchorMember Enumeration

[image]

Revit 2013 API
ArrayAnchorMember Enumeration
See Also Send Feedback
Represents the possible choices for how the translation or rotation is used to place each member of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ArrayAnchorMember
Visual Basic
Public Enumeration ArrayAnchorMember
Visual C++
public enum class ArrayAnchorMember

Members

Member name | Description
Second | The translation or rotation value specifies the location of the second member of the array.
Last | The translation or rotation value specifies the location of the last member of the array.

See Also


AssemblyDetailViewOrientation Enumeration

[image]

Revit 2013 API
AssemblyDetailViewOrientation Enumeration
See Also Send Feedback
Orientation of the Assembly Detail View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum AssemblyDetailViewOrientation
Visual Basic
Public Enumeration AssemblyDetailViewOrientation
Visual C++
public enum class AssemblyDetailViewOrientation

Members

Member name | Description
HorizontalDetail | The Detail View will be oriented horizontally, looking down.
DetailSectionA | The Detail View will be oriented vertically, looking north.
DetailSectionB | The Detail View will be oriented vertically, looking west.
ElevationTop | The Detail View will be oriented horizontally, with its cut plane along the top face of the assembly's bounding box, looking down into the bounding box.
ElevationBottom | The Detail View will be oriented horizontally, with its cut plane along the bottom face of the assembly's bounding box, looking up into the bounding box.
ElevationLeft | The Detail View will be oriented vertically, with its cut plane along the left face of the assembly's bounding box, looking into the bounding box.
ElevationRight | The Detail View will be oriented vertically, with its cut plane along the right face of the assembly's bounding box, looking into the bounding box.
ElevationFront | The Detail View will be oriented vertically, with its cut plane along the front face of the assembly's bounding box, looking into the bounding box.
ElevationBack | The Detail View will be oriented vertically, with its cut plane along the back face of the assembly's bounding box, looking into the bounding box.

Remarks

The orientation can be specified during creation but not modified for existing views.

See Also


AssemblyDifference Class

[image]

Revit 2013 API
AssemblyDifference Class
Members See Also Send Feedback
Class that describes difference between two assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifference : IDisposable
Visual Basic
Public Class AssemblyDifference _
    Implements IDisposable
Visual C++
public ref class AssemblyDifference : IDisposable

Remarks

The assembly comparison function returns a sub-class of this class. Different sub-classes represent different kinds of differences and contain additional data for each particular kind of difference.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceConfiguration
Autodesk.Revit.DB..::..AssemblyDifferenceMemberCount
Autodesk.Revit.DB..::..AssemblyDifferenceMemberDifference
Autodesk.Revit.DB..::..AssemblyDifferenceNamingCategory
Autodesk.Revit.DB..::..AssemblyDifferenceNone

See Also

AssemblyDifference Members


AssemblyDifference Members

[image] [image]

Revit 2013 API
AssemblyDifference Members
AssemblyDifference Class Methods See Also Send Feedback

The AssemblyDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AssemblyDifference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifference Class


AssemblyDifference Methods

[image] [image]

Revit 2013 API
AssemblyDifference Methods
AssemblyDifference Class See Also Send Feedback

The AssemblyDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifference Class


Dispose Method

[image]

Revit 2013 API
AssemblyDifference..::..Dispose Method
AssemblyDifference Class See Also Send Feedback
Releases all resources used by the AssemblyDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AssemblyDifference Class


AssemblyDifferenceConfiguration Class

[image]

Revit 2013 API
AssemblyDifferenceConfiguration Class
Members See Also Send Feedback
The two assemblies being compared have different spatial configuration

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifferenceConfiguration : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceConfiguration _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceConfiguration : public AssemblyDifference

Remarks

Assemblies resulting in this difference might be made up of identical elements, but the elements are not arranged in space relative to each other in the same way.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceConfiguration

See Also

AssemblyDifferenceConfiguration Members


AssemblyDifferenceConfiguration Members

[image] [image]

Revit 2013 API
AssemblyDifferenceConfiguration Members
AssemblyDifferenceConfiguration Class Methods See Also Send Feedback

The AssemblyDifferenceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceConfiguration Class


AssemblyDifferenceConfiguration Methods

[image] [image]

Revit 2013 API
AssemblyDifferenceConfiguration Methods
AssemblyDifferenceConfiguration Class See Also Send Feedback

The AssemblyDifferenceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceConfiguration Class


AssemblyDifferenceMemberCount Class

[image]

Revit 2013 API
AssemblyDifferenceMemberCount Class
Members See Also Send Feedback
The two assemblies being compared have different number of members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifferenceMemberCount : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceMemberCount _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceMemberCount : public AssemblyDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceMemberCount

See Also

AssemblyDifferenceMemberCount Members


AssemblyDifferenceMemberCount Members

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberCount Members
AssemblyDifferenceMemberCount Class Methods Properties See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount Methods

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberCount Methods
AssemblyDifferenceMemberCount Class See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberCount Properties

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberCount Properties
AssemblyDifferenceMemberCount Class See Also Send Feedback

The AssemblyDifferenceMemberCount type exposes the following members.

Properties

 | Name | Description
Public property | Count1 | Number of members in the first assembly
Public property | Count2 | Number of members in the second assembly

See Also

AssemblyDifferenceMemberCount Class


Count1 Property

[image]

Revit 2013 API
AssemblyDifferenceMemberCount..::..Count1 Property
AssemblyDifferenceMemberCount Class See Also Send Feedback
Number of members in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Count1 { get; }
Visual Basic
Public ReadOnly Property Count1 As Integer
    Get
Visual C++
public:
property int Count1 {
    int get ();
}

See Also

AssemblyDifferenceMemberCount Class


Count2 Property

[image]

Revit 2013 API
AssemblyDifferenceMemberCount..::..Count2 Property
AssemblyDifferenceMemberCount Class See Also Send Feedback
Number of members in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Count2 { get; }
Visual Basic
Public ReadOnly Property Count2 As Integer
    Get
Visual C++
public:
property int Count2 {
    int get ();
}

See Also

AssemblyDifferenceMemberCount Class


AssemblyDifferenceMemberDifference Class

[image]

Revit 2013 API
AssemblyDifferenceMemberDifference Class
Members See Also Send Feedback
The two assemblies being compared have different members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifferenceMemberDifference : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceMemberDifference _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceMemberDifference : public AssemblyDifference

Remarks

This difference means that there is a member of the first assembly which is different from the corresponding member of the second assembly. Details about the difference are in memberDifference.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceMemberDifference

See Also

AssemblyDifferenceMemberDifference Members


AssemblyDifferenceMemberDifference Members

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberDifference Members
AssemblyDifferenceMemberDifference Class Methods Properties See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference Methods

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberDifference Methods
AssemblyDifferenceMemberDifference Class See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceMemberDifference Properties

[image] [image]

Revit 2013 API
AssemblyDifferenceMemberDifference Properties
AssemblyDifferenceMemberDifference Class See Also Send Feedback

The AssemblyDifferenceMemberDifference type exposes the following members.

Properties

 | Name | Description
Public property | MemberDifference | Difference between the assembly members
Public property | MemberId1 | Id of the member in the first assembly
Public property | MemberId2 | Id of the member in the second assembly

See Also

AssemblyDifferenceMemberDifference Class


MemberDifference Property

[image]

Revit 2013 API
AssemblyDifferenceMemberDifference..::..MemberDifference Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Difference between the assembly members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AssemblyMemberDifference MemberDifference { get; }
Visual Basic
Public ReadOnly Property MemberDifference As AssemblyMemberDifference
    Get
Visual C++
public:
property AssemblyMemberDifference^ MemberDifference {
    AssemblyMemberDifference^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


MemberId1 Property

[image]

Revit 2013 API
AssemblyDifferenceMemberDifference..::..MemberId1 Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Id of the member in the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MemberId1 { get; }
Visual Basic
Public ReadOnly Property MemberId1 As ElementId
    Get
Visual C++
public:
property ElementId^ MemberId1 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


MemberId2 Property

[image]

Revit 2013 API
AssemblyDifferenceMemberDifference..::..MemberId2 Property
AssemblyDifferenceMemberDifference Class See Also Send Feedback
Id of the member in the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MemberId2 { get; }
Visual Basic
Public ReadOnly Property MemberId2 As ElementId
    Get
Visual C++
public:
property ElementId^ MemberId2 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceMemberDifference Class


AssemblyDifferenceNamingCategory Class

[image]

Revit 2013 API
AssemblyDifferenceNamingCategory Class
Members See Also Send Feedback
The two assemblies being compared have different naming categories

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifferenceNamingCategory : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceNamingCategory _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceNamingCategory : public AssemblyDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceNamingCategory

See Also

AssemblyDifferenceNamingCategory Members


AssemblyDifferenceNamingCategory Members

[image] [image]

Revit 2013 API
AssemblyDifferenceNamingCategory Members
AssemblyDifferenceNamingCategory Class Methods Properties See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory Methods

[image] [image]

Revit 2013 API
AssemblyDifferenceNamingCategory Methods
AssemblyDifferenceNamingCategory Class See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNamingCategory Properties

[image] [image]

Revit 2013 API
AssemblyDifferenceNamingCategory Properties
AssemblyDifferenceNamingCategory Class See Also Send Feedback

The AssemblyDifferenceNamingCategory type exposes the following members.

Properties

 | Name | Description
Public property | NamingCategoryId1 | Naming category id of the first assembly
Public property | NamingCategoryId2 | Naming category id of the second assembly

See Also

AssemblyDifferenceNamingCategory Class


NamingCategoryId1 Property

[image]

Revit 2013 API
AssemblyDifferenceNamingCategory..::..NamingCategoryId1 Property
AssemblyDifferenceNamingCategory Class See Also Send Feedback
Naming category id of the first assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId NamingCategoryId1 { get; }
Visual Basic
Public ReadOnly Property NamingCategoryId1 As ElementId
    Get
Visual C++
public:
property ElementId^ NamingCategoryId1 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceNamingCategory Class


NamingCategoryId2 Property

[image]

Revit 2013 API
AssemblyDifferenceNamingCategory..::..NamingCategoryId2 Property
AssemblyDifferenceNamingCategory Class See Also Send Feedback
Naming category id of the second assembly

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId NamingCategoryId2 { get; }
Visual Basic
Public ReadOnly Property NamingCategoryId2 As ElementId
    Get
Visual C++
public:
property ElementId^ NamingCategoryId2 {
    ElementId^ get ();
}

See Also

AssemblyDifferenceNamingCategory Class


AssemblyDifferenceNone Class

[image]

Revit 2013 API
AssemblyDifferenceNone Class
Members See Also Send Feedback
The two assemblies being compared are identical

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyDifferenceNone : AssemblyDifference
Visual Basic
Public Class AssemblyDifferenceNone _
    Inherits AssemblyDifference
Visual C++
public ref class AssemblyDifferenceNone : public AssemblyDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyDifference
Autodesk.Revit.DB..::..AssemblyDifferenceNone

See Also

AssemblyDifferenceNone Members


AssemblyDifferenceNone Members

[image] [image]

Revit 2013 API
AssemblyDifferenceNone Members
AssemblyDifferenceNone Class Methods See Also Send Feedback

The AssemblyDifferenceNone type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceNone Class


AssemblyDifferenceNone Methods

[image] [image]

Revit 2013 API
AssemblyDifferenceNone Methods
AssemblyDifferenceNone Class See Also Send Feedback

The AssemblyDifferenceNone type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyDifferenceNone Class


AssemblyInstance Class

[image]

Revit 2013 API
AssemblyInstance Class
Members Example See Also Send Feedback
Combines multiple elements for tagging, filtering, scheduling and creating isolated assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyInstance : Element
Visual Basic
Public Class AssemblyInstance _
    Inherits Element
Visual C++
public ref class AssemblyInstance : public Element

Examples

CopyC#
// Create assembly instance, name the assembly, and create views of the assembly
void CreateAssemblyAndViews(Autodesk.Revit.DB.Document doc, ICollection<ElementId> elementIds)
{
    Transaction transaction = new Transaction(doc);
    ElementId categoryId = doc.GetElement(elementIds.First()).Category.Id; // use category of one of the assembly elements
    if (AssemblyInstance.IsValidNamingCategory(doc, categoryId, elementIds))
    {
        transaction.Start("Create Assembly Instance");
        AssemblyInstance assemblyInstance = AssemblyInstance.Create(doc, elementIds, categoryId);
        transaction.Commit(); // commit the transaction that creates the assembly instance before modifying the instance's name

        transaction.Start("Set Assembly Name");
        assemblyInstance.AssemblyTypeName = "My Assembly Name";
        transaction.Commit();

        if (assemblyInstance.AllowsAssemblyViewCreation()) // create assembly views for this assembly instance
        {
            transaction.Start("View Creation");
            View3D view3d = AssemblyViewUtils.Create3DOrthographic(doc, assemblyInstance.Id);
            View partList = AssemblyViewUtils.CreatePartList(doc, assemblyInstance.Id);
            transaction.Commit();
        }
    }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..AssemblyInstance

See Also

AssemblyInstance Members


AssemblyInstance Members

[image] [image]

Revit 2013 API
AssemblyInstance Members
AssemblyInstance Class Methods Properties See Also Send Feedback

The AssemblyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTransform | Gets the origin of the assembly instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyInstance Class


AssemblyInstance Methods

[image] [image]

Revit 2013 API
AssemblyInstance Methods
AssemblyInstance Class See Also Send Feedback

The AssemblyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddMemberIds | Adds member element ids for the assembly instance.
Public method | AllowsAssemblyViewCreation | Returns true if assembly views can be created for this Assembly Instance.
 | AreElementsValidForAssembly | Identifies if provided assembly members are valid.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
 | CanRemoveElementsFromAssembly | Identifies if provided assembly members can be removed from the assembly instance.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CompareAssemblyInstances | Compares two assembly instances and returns a result with details about the differences
 | Create | Creates a new assembly instance.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disassemble | Removes the assembly instance and releases the member elements.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCenter | Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMemberIds | Gets member element ids for the assembly instance.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTransform | Gets the origin of the assembly instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidNamingCategory | Identifies if the naming category is valid for an assembly instance.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | PlaceInstance | Places an assembly instance of a given assembly type at the specified location.
Public method | RemoveMemberIds | Removes member element ids from the assembly instance.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMemberIds | Sets member element ids for the assembly instance. All existing members are cleared.
Public method | SetTransform | Sets the origin of the assembly instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyInstance Class


AddMemberIds Method

[image]

Revit 2013 API
AssemblyInstance..::..AddMemberIds Method
AssemblyInstance Class See Also Send Feedback
Adds member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub AddMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void AddMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be added to the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


AllowsAssemblyViewCreation Method

[image]

Revit 2013 API
AssemblyInstance..::..AllowsAssemblyViewCreation Method
AssemblyInstance Class See Also Send Feedback
Returns true if assembly views can be created for this Assembly Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool AllowsAssemblyViewCreation()
Visual Basic
Public Function AllowsAssemblyViewCreation As Boolean
Visual C++
public:
bool AllowsAssemblyViewCreation()

Remarks

Assembly views are allowed when there are no assembly views for any instance of this type, or when the only existing assembly views belong to this instance

See Also

AssemblyInstance Class


AreElementsValidForAssembly Method

[image]

Revit 2013 API
AssemblyInstance..::..AreElementsValidForAssembly Method
AssemblyInstance Class See Also Send Feedback
Identifies if provided assembly members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool AreElementsValidForAssembly(
    Document document,
    ICollection<ElementId> assemblyMemberIds,
    ElementId assemblyId
)
Visual Basic
Public Shared Function AreElementsValidForAssembly ( _
    document As Document, _
    assemblyMemberIds As ICollection(Of ElementId), _
    assemblyId As ElementId _
) As Boolean
Visual C++
public:
static bool AreElementsValidForAssembly(
    Document^ document,
    ICollection<ElementId^>^ assemblyMemberIds,
    ElementId^ assemblyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for membership of an assembly instance.
assemblyId
Type: Autodesk.Revit.DB..::..ElementId
Id of the existing assembly to add components to. If invalid, the method return whether the components can be added to a new assembly

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


CanRemoveElementsFromAssembly Method

[image]

Revit 2013 API
AssemblyInstance..::..CanRemoveElementsFromAssembly Method
AssemblyInstance Class See Also Send Feedback
Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanRemoveElementsFromAssembly(
    AssemblyInstance assemblyInstance,
    ICollection<ElementId> memberIds
)
Visual Basic
Public Shared Function CanRemoveElementsFromAssembly ( _
    assemblyInstance As AssemblyInstance, _
    memberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanRemoveElementsFromAssembly(
    AssemblyInstance^ assemblyInstance,
    ICollection<ElementId^>^ memberIds
)

Parameters

assemblyInstance
Type: Autodesk.Revit.DB..::..AssemblyInstance
The assembly instance to remove elements from.
memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity to remove from the assembly instance.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


CompareAssemblyInstances Method

[image]

Revit 2013 API
AssemblyInstance..::..CompareAssemblyInstances Method
AssemblyInstance Class Example See Also Send Feedback
Compares two assembly instances and returns a result with details about the differences

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AssemblyDifference CompareAssemblyInstances(
    AssemblyInstance instance1,
    AssemblyInstance instance2
)
Visual Basic
Public Shared Function CompareAssemblyInstances ( _
    instance1 As AssemblyInstance, _
    instance2 As AssemblyInstance _
) As AssemblyDifference
Visual C++
public:
static AssemblyDifference^ CompareAssemblyInstances(
    AssemblyInstance^ instance1,
    AssemblyInstance^ instance2
)

Parameters

instance1
Type: Autodesk.Revit.DB..::..AssemblyInstance
The first assembly instance to compare
instance2
Type: Autodesk.Revit.DB..::..AssemblyInstance
the second assembly instance to compare

Return Value

An object describing the difference between the two instances

Remarks

Only the first found difference is returned. If the instances are identical, AssemblyDifferenceNone will be returned.

Examples

CopyC#
// Identify the difference, if any, between two assembly instances
void FindAssemblyDifferences(AssemblyInstance instance1, AssemblyInstance instance2)
{
    Autodesk.Revit.DB.Document doc = instance1.Document;
        AssemblyDifference difference = AssemblyInstance.CompareAssemblyInstances(instance1, instance2);

        AssemblyDifferenceNone diffNone = difference as AssemblyDifferenceNone;
        if (diffNone != null)
        {
            TaskDialog.Show("Revit", "Assemblies are identical");
            return;
        }

        AssemblyDifferenceConfiguration diffConfig = difference as AssemblyDifferenceConfiguration;
        if (diffConfig != null)
        {
            TaskDialog.Show("Revit", "Elements are not arranged in space relative to each other in the same way");
            return;
        }

        AssemblyDifferenceMemberCount diffMemberCount = difference as AssemblyDifferenceMemberCount;
        if (diffMemberCount != null)
        {
            TaskDialog.Show("Revit", "Elements counts differ: " + diffMemberCount.Count1 + " & " + diffMemberCount.Count2);
            return;
        }

        AssemblyDifferenceNamingCategory diffNameCat = difference as AssemblyDifferenceNamingCategory;
        if (diffNameCat != null)
        {
            int catInt1 = diffNameCat.NamingCategoryId1.IntegerValue;
            int catInt2 = diffNameCat.NamingCategoryId2.IntegerValue;
            TaskDialog.Show("Revit", "Naming categories differ: " +
                doc.Settings.Categories.get_Item((BuiltInCategory)catInt1).Name + " & " +
                doc.Settings.Categories.get_Item((BuiltInCategory)catInt2).Name);
            return;
        }

        AssemblyDifferenceMemberDifference memberDifference = difference as AssemblyDifferenceMemberDifference;
        if (memberDifference != null)
        {
            AssemblyMemberDifference assemblyMemberDifference = memberDifference.MemberDifference as AssemblyMemberDifference;

            AssemblyMemberDifferentCategory differentCategory = assemblyMemberDifference as AssemblyMemberDifferentCategory;
            if (differentCategory != null)
            {
                int int1 = differentCategory.CategoryId1.IntegerValue;
                int int2 = differentCategory.CategoryId2.IntegerValue;
                TaskDialog.Show("Revit", "Element categories differ: " +
                    doc.Settings.Categories.get_Item((BuiltInCategory)int1).Name + " & " +
                    doc.Settings.Categories.get_Item((BuiltInCategory)int2).Name);
                return;
            }
            AssemblyMemberDifferentGeometry differentGeometry = assemblyMemberDifference as AssemblyMemberDifferentGeometry;
            if (differentGeometry != null)
            {
                TaskDialog.Show("Revit", "Member geometry differs");
                return;
            }
            AssemblyMemberDifferentParameters differentParameters = assemblyMemberDifference as AssemblyMemberDifferentParameters;
            if (differentParameters != null)
            {
                TaskDialog.Show("Revit", "Member parameters differs");
                return;
            }
            AssemblyMemberDifferentType differentType = assemblyMemberDifference as AssemblyMemberDifferentType;
            if (differentType != null)
            {
                TaskDialog.Show("Revit", "Element types differ: " + doc.GetElement(differentType.TypeId1).Name + " & " + doc.GetElement(differentType.TypeId2).Name);
                return;
            }
        }
        return;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


Create Method

[image]

Revit 2013 API
AssemblyInstance..::..Create Method
AssemblyInstance Class See Also Send Feedback
Creates a new assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AssemblyInstance Create(
    Document document,
    ICollection<ElementId> assemblyMemberIds,
    ElementId namingCategoryId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    assemblyMemberIds As ICollection(Of ElementId), _
    namingCategoryId As ElementId _
) As AssemblyInstance
Visual C++
public:
static AssemblyInstance^ Create(
    Document^ document,
    ICollection<ElementId^>^ assemblyMemberIds,
    ElementId^ namingCategoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that comprise the assembly.
namingCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The naming category for the assembly instance.

Return Value

The newly created assembly instance.

Remarks

Transaction must be committed after calling this method before performing any action on the newly created instance. Assembly type is assigned after the transaction for creating assembly instance is complete.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyInstance Class


Disassemble Method

[image]

Revit 2013 API
AssemblyInstance..::..Disassemble Method
AssemblyInstance Class See Also Send Feedback
Removes the assembly instance and releases the member elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> Disassemble()
Visual Basic
Public Function Disassemble As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Disassemble()

Return Value

ids of elements previously under the assembly instance.

See Also

AssemblyInstance Class


GetCenter Method

[image]

Revit 2013 API
AssemblyInstance..::..GetCenter Method
AssemblyInstance Class See Also Send Feedback
Returns the center of the bounding box for the assembly instance. This is the default position for placed assembly instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ GetCenter()
Visual Basic
Public Function GetCenter As XYZ
Visual C++
public:
XYZ^ GetCenter()

Return Value

The position for the center of the assembly instance.

See Also

AssemblyInstance Class


GetMemberIds Method

[image]

Revit 2013 API
AssemblyInstance..::..GetMemberIds Method
AssemblyInstance Class See Also Send Feedback
Gets member element ids for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetMemberIds()
Visual Basic
Public Function GetMemberIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMemberIds()

Return Value

Element ids for the members of the assembly instance.

See Also

AssemblyInstance Class


GetTransform Method

[image]

Revit 2013 API
AssemblyInstance..::..GetTransform Method
AssemblyInstance Class See Also Send Feedback
Gets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

Return Value

The origin of the assembly instance.

See Also

AssemblyInstance Class


IsValidNamingCategory Method

[image]

Revit 2013 API
AssemblyInstance..::..IsValidNamingCategory Method
AssemblyInstance Class See Also Send Feedback
Identifies if the naming category is valid for an assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidNamingCategory(
    Document document,
    ElementId namingCategoryId,
    ICollection<ElementId> assemblyMemberIds
)
Visual Basic
Public Shared Function IsValidNamingCategory ( _
    document As Document, _
    namingCategoryId As ElementId, _
    assemblyMemberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool IsValidNamingCategory(
    Document^ document,
    ElementId^ namingCategoryId,
    ICollection<ElementId^>^ assemblyMemberIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the assembly instance.
namingCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The id of the naming category for the assembly instance.
assemblyMemberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Member ids to check validity of naming category

Return Value

True if the naming category is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


PlaceInstance Method

[image]

Revit 2013 API
AssemblyInstance..::..PlaceInstance Method
AssemblyInstance Class See Also Send Feedback
Places an assembly instance of a given assembly type at the specified location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AssemblyInstance PlaceInstance(
    Document document,
    ElementId assemblyTypeId,
    XYZ location
)
Visual Basic
Public Shared Function PlaceInstance ( _
    document As Document, _
    assemblyTypeId As ElementId, _
    location As XYZ _
) As AssemblyInstance
Visual C++
public:
static AssemblyInstance^ PlaceInstance(
    Document^ document,
    ElementId^ assemblyTypeId,
    XYZ^ location
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for the new assembly instance.
assemblyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the assembly type to be used for the instance.
location
Type: Autodesk.Revit.DB..::..XYZ
The placement location for the instance in project coordinates.

Return Value

The newly created assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


RemoveMemberIds Method

[image]

Revit 2013 API
AssemblyInstance..::..RemoveMemberIds Method
AssemblyInstance Class See Also Send Feedback
Removes member element ids from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RemoveMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub RemoveMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void RemoveMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be removed from the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be removed from the assembly instance. Provided set should not be empty and all elements should be a member of the assembly instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyInstance Class


SetMemberIds Method

[image]

Revit 2013 API
AssemblyInstance..::..SetMemberIds Method
AssemblyInstance Class See Also Send Feedback
Sets member element ids for the assembly instance. All existing members are cleared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetMemberIds(
    ICollection<ElementId> memberIds
)
Visual Basic
Public Sub SetMemberIds ( _
    memberIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetMemberIds(
    ICollection<ElementId^>^ memberIds
)

Parameters

memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to set for the assembly instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.

See Also

AssemblyInstance Class


SetTransform Method

[image]

Revit 2013 API
AssemblyInstance..::..SetTransform Method
AssemblyInstance Class See Also Send Feedback
Sets the origin of the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetTransform(
    Transform trf
)
Visual Basic
Public Sub SetTransform ( _
    trf As Transform _
)
Visual C++
public:
void SetTransform(
    Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
Transform to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | trf is not a rigid body transformation.

See Also

AssemblyInstance Class


AssemblyInstance Properties

[image] [image]

Revit 2013 API
AssemblyInstance Properties
AssemblyInstance Class See Also Send Feedback

The AssemblyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssemblyTypeName | The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of the assembly instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NamingCategoryId | Id of the category that drives the default naming scheme for the assembly instance.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyInstance Class


AssemblyTypeName Property

[image]

Revit 2013 API
AssemblyInstance..::..AssemblyTypeName Property
AssemblyInstance Class See Also Send Feedback
The name for the assembly type. All matching assembly instances share this name. Unique assembly instances are named automatically based on their naming category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string AssemblyTypeName { get; set; }
Visual Basic
Public Property AssemblyTypeName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyTypeName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This assembly type name is not valid for this assembly instance. An assembly type name should be non-empty, should contain valid characters, and should be unique for its naming category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AssemblyInstance Class


Location Property

[image]

Revit 2013 API
AssemblyInstance..::..Location Property
AssemblyInstance Class See Also Send Feedback
This property is used to find the physical location of the assembly instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Assembly instances return a point location object positioned at the center of the assembly instance.

See Also

AssemblyInstance Class


NamingCategoryId Property

[image]

Revit 2013 API
AssemblyInstance..::..NamingCategoryId Property
AssemblyInstance Class See Also Send Feedback
Id of the category that drives the default naming scheme for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId NamingCategoryId { get; set; }
Visual Basic
Public Property NamingCategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ NamingCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AssemblyInstance Class


Parameter Property

[image] [image]

Revit 2013 API
AssemblyInstance..::..Parameter Property
AssemblyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AssemblyInstance Class
AssemblyInstance Members


AssemblyMemberDifference Class

[image]

Revit 2013 API
AssemblyMemberDifference Class
Members See Also Send Feedback
Class that describes difference between two assembly members

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyMemberDifference : IDisposable
Visual Basic
Public Class AssemblyMemberDifference _
    Implements IDisposable
Visual C++
public ref class AssemblyMemberDifference : IDisposable

Remarks

Different sub-classes of this class represent different kinds of differences between assembly members and contain additional data for each particular kind of difference.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentCategory
Autodesk.Revit.DB..::..AssemblyMemberDifferentGeometry
Autodesk.Revit.DB..::..AssemblyMemberDifferentParameters
Autodesk.Revit.DB..::..AssemblyMemberDifferentType

See Also

AssemblyMemberDifference Members


AssemblyMemberDifference Members

[image] [image]

Revit 2013 API
AssemblyMemberDifference Members
AssemblyMemberDifference Class Methods See Also Send Feedback

The AssemblyMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AssemblyMemberDifference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifference Class


AssemblyMemberDifference Methods

[image] [image]

Revit 2013 API
AssemblyMemberDifference Methods
AssemblyMemberDifference Class See Also Send Feedback

The AssemblyMemberDifference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifference Class


Dispose Method

[image]

Revit 2013 API
AssemblyMemberDifference..::..Dispose Method
AssemblyMemberDifference Class See Also Send Feedback
Releases all resources used by the AssemblyMemberDifference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AssemblyMemberDifference Class


AssemblyMemberDifferentCategory Class

[image]

Revit 2013 API
AssemblyMemberDifferentCategory Class
Members See Also Send Feedback
The two assembly members being compared have different category

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentCategory : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentCategory _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentCategory : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentCategory

See Also

AssemblyMemberDifferentCategory Members


AssemblyMemberDifferentCategory Members

[image] [image]

Revit 2013 API
AssemblyMemberDifferentCategory Members
AssemblyMemberDifferentCategory Class Methods Properties See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory Methods

[image] [image]

Revit 2013 API
AssemblyMemberDifferentCategory Methods
AssemblyMemberDifferentCategory Class See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentCategory Properties

[image] [image]

Revit 2013 API
AssemblyMemberDifferentCategory Properties
AssemblyMemberDifferentCategory Class See Also Send Feedback

The AssemblyMemberDifferentCategory type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId1 | Category id of the first assembly member
Public property | CategoryId2 | Category id of the second assembly member

See Also

AssemblyMemberDifferentCategory Class


CategoryId1 Property

[image]

Revit 2013 API
AssemblyMemberDifferentCategory..::..CategoryId1 Property
AssemblyMemberDifferentCategory Class See Also Send Feedback
Category id of the first assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId CategoryId1 { get; }
Visual Basic
Public ReadOnly Property CategoryId1 As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId1 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentCategory Class


CategoryId2 Property

[image]

Revit 2013 API
AssemblyMemberDifferentCategory..::..CategoryId2 Property
AssemblyMemberDifferentCategory Class See Also Send Feedback
Category id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId CategoryId2 { get; }
Visual Basic
Public ReadOnly Property CategoryId2 As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId2 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentCategory Class


AssemblyMemberDifferentGeometry Class

[image]

Revit 2013 API
AssemblyMemberDifferentGeometry Class
Members See Also Send Feedback
The two assembly members being compared have different geometry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentGeometry : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentGeometry _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentGeometry : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentGeometry

See Also

AssemblyMemberDifferentGeometry Members


AssemblyMemberDifferentGeometry Members

[image] [image]

Revit 2013 API
AssemblyMemberDifferentGeometry Members
AssemblyMemberDifferentGeometry Class Methods See Also Send Feedback

The AssemblyMemberDifferentGeometry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentGeometry Methods

[image] [image]

Revit 2013 API
AssemblyMemberDifferentGeometry Methods
AssemblyMemberDifferentGeometry Class See Also Send Feedback

The AssemblyMemberDifferentGeometry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentGeometry Class


AssemblyMemberDifferentParameters Class

[image]

Revit 2013 API
AssemblyMemberDifferentParameters Class
Members See Also Send Feedback
The two assembly members being compared have different parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentParameters : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentParameters _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentParameters : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentParameters

See Also

AssemblyMemberDifferentParameters Members


AssemblyMemberDifferentParameters Members

[image] [image]

Revit 2013 API
AssemblyMemberDifferentParameters Members
AssemblyMemberDifferentParameters Class Methods See Also Send Feedback

The AssemblyMemberDifferentParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentParameters Methods

[image] [image]

Revit 2013 API
AssemblyMemberDifferentParameters Methods
AssemblyMemberDifferentParameters Class See Also Send Feedback

The AssemblyMemberDifferentParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentParameters Class


AssemblyMemberDifferentType Class

[image]

Revit 2013 API
AssemblyMemberDifferentType Class
Members See Also Send Feedback
The two assembly members being compared have different type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyMemberDifferentType : AssemblyMemberDifference
Visual Basic
Public Class AssemblyMemberDifferentType _
    Inherits AssemblyMemberDifference
Visual C++
public ref class AssemblyMemberDifferentType : public AssemblyMemberDifference

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyMemberDifference
Autodesk.Revit.DB..::..AssemblyMemberDifferentType

See Also

AssemblyMemberDifferentType Members


AssemblyMemberDifferentType Members

[image] [image]

Revit 2013 API
AssemblyMemberDifferentType Members
AssemblyMemberDifferentType Class Methods Properties See Also Send Feedback

The AssemblyMemberDifferentType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId1 | Type id of the first assembly member
Public property | TypeId2 | Type id of the second assembly member

See Also

AssemblyMemberDifferentType Class


AssemblyMemberDifferentType Methods

[image] [image]

Revit 2013 API
AssemblyMemberDifferentType Methods
AssemblyMemberDifferentType Class See Also Send Feedback

The AssemblyMemberDifferentType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from AssemblyMemberDifference.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyMemberDifferentType Class


AssemblyMemberDifferentType Properties

[image] [image]

Revit 2013 API
AssemblyMemberDifferentType Properties
AssemblyMemberDifferentType Class See Also Send Feedback

The AssemblyMemberDifferentType type exposes the following members.

Properties

 | Name | Description
Public property | TypeId1 | Type id of the first assembly member
Public property | TypeId2 | Type id of the second assembly member

See Also

AssemblyMemberDifferentType Class


TypeId1 Property

[image]

Revit 2013 API
AssemblyMemberDifferentType..::..TypeId1 Property
AssemblyMemberDifferentType Class See Also Send Feedback
Type id of the first assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId TypeId1 { get; }
Visual Basic
Public ReadOnly Property TypeId1 As ElementId
    Get
Visual C++
public:
property ElementId^ TypeId1 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentType Class


TypeId2 Property

[image]

Revit 2013 API
AssemblyMemberDifferentType..::..TypeId2 Property
AssemblyMemberDifferentType Class See Also Send Feedback
Type id of the second assembly member

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId TypeId2 { get; }
Visual Basic
Public ReadOnly Property TypeId2 As ElementId
    Get
Visual C++
public:
property ElementId^ TypeId2 {
    ElementId^ get ();
}

See Also

AssemblyMemberDifferentType Class


AssemblyType Class

[image]

Revit 2013 API
AssemblyType Class
Members See Also Send Feedback
Type for construction assembly elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyType : ElementType
Visual Basic
Public Class AssemblyType _
    Inherits ElementType
Visual C++
public ref class AssemblyType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..AssemblyType

See Also

AssemblyType Members


AssemblyType Members

[image] [image]

Revit 2013 API
AssemblyType Members
AssemblyType Class Methods Properties See Also Send Feedback

The AssemblyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyType Class


AssemblyType Methods

[image] [image]

Revit 2013 API
AssemblyType Methods
AssemblyType Class See Also Send Feedback

The AssemblyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyType Class


AssemblyType Properties

[image] [image]

Revit 2013 API
AssemblyType Properties
AssemblyType Class See Also Send Feedback

The AssemblyType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AssemblyType Class


Parameter Property

[image] [image]

Revit 2013 API
AssemblyType..::..Parameter Property
AssemblyType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AssemblyType Class
AssemblyType Members


AssemblyViewUtils Class

[image]

Revit 2013 API
AssemblyViewUtils Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AssemblyViewUtils : IDisposable
Visual Basic
Public Class AssemblyViewUtils _
    Implements IDisposable
Visual C++
public ref class AssemblyViewUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..AssemblyViewUtils

See Also

AssemblyViewUtils Members


AssemblyViewUtils Members

[image] [image]

Revit 2013 API
AssemblyViewUtils Members
AssemblyViewUtils Class Methods See Also Send Feedback

The AssemblyViewUtils type exposes the following members.

Methods

 | Name | Description
 | AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
 | Create3DOrthographic | Creates a new orthographic 3D assembly view for the assembly instance.
 | CreateDetailSection | Creates a new detail section assembly view for the assembly instance.
 | CreateMaterialTakeoff | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
 | CreatePartList | Creates a new part list multicategory schedule assembly view for the assembly instance.
 | CreateSheet | Creates a new sheet assembly view for the assembly instance.
Public method | Dispose | Releases all resources used by the AssemblyViewUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyViewUtils Class


AssemblyViewUtils Methods

[image] [image]

Revit 2013 API
AssemblyViewUtils Methods
AssemblyViewUtils Class See Also Send Feedback

The AssemblyViewUtils type exposes the following members.

Methods

 | Name | Description
 | AcquireAssemblyViews | Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
 | Create3DOrthographic | Creates a new orthographic 3D assembly view for the assembly instance.
 | CreateDetailSection | Creates a new detail section assembly view for the assembly instance.
 | CreateMaterialTakeoff | Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
 | CreatePartList | Creates a new part list multicategory schedule assembly view for the assembly instance.
 | CreateSheet | Creates a new sheet assembly view for the assembly instance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssemblyViewUtils Class


AcquireAssemblyViews Method

[image]

Revit 2013 API
AssemblyViewUtils..::..AcquireAssemblyViews Method
AssemblyViewUtils Class See Also Send Feedback
Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AcquireAssemblyViews(
    Document document,
    ElementId sourceAssemblyInstanceId,
    ElementId targetAssemblyInstanceId
)
Visual Basic
Public Shared Sub AcquireAssemblyViews ( _
    document As Document, _
    sourceAssemblyInstanceId As ElementId, _
    targetAssemblyInstanceId As ElementId _
)
Visual C++
public:
static void AcquireAssemblyViews(
    Document^ document,
    ElementId^ sourceAssemblyInstanceId,
    ElementId^ targetAssemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the assembly instances live.
sourceAssemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that currently owns the assembly views.
targetAssemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance which will become the new owner of the assembly views.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | sourceAssemblyInstanceId is not an AssemblyInstance with assembly views. -or- targetAssemblyInstanceId is not an AssemblyInstance. -or- sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

AssemblyViewUtils Class


Create3DOrthographic Method

[image]

Revit 2013 API
AssemblyViewUtils..::..Create3DOrthographic Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new orthographic 3D assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static View3D Create3DOrthographic(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function Create3DOrthographic ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As View3D
Visual C++
public:
static View3D^ Create3DOrthographic(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new orthographic 3D assembly view.

Remarks

The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class


CreateDetailSection Method

[image]

Revit 2013 API
AssemblyViewUtils..::..CreateDetailSection Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSection CreateDetailSection(
    Document document,
    ElementId assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)
Visual Basic
Public Shared Function CreateDetailSection ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    direction As AssemblyDetailViewOrientation _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetailSection(
    Document^ document,
    ElementId^ assemblyInstanceId,
    AssemblyDetailViewOrientation direction
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
direction
Type: Autodesk.Revit.DB..::..AssemblyDetailViewOrientation
The direction for the new view.

Return Value

A new detail section assembly view.

Remarks

The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class


CreateMaterialTakeoff Method

[image]

Revit 2013 API
AssemblyViewUtils..::..CreateMaterialTakeoff Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new material takeoff multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function CreateMaterialTakeoff ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new material takeoff multicategory schedule assembly view.

Remarks

The material takeoff schedule will be preloaded with fields “Material: Name” and “Material: Volume”. The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class


CreatePartList Method

[image]

Revit 2013 API
AssemblyViewUtils..::..CreatePartList Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new part list multicategory schedule assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSchedule CreatePartList(
    Document document,
    ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function CreatePartList ( _
    document As Document, _
    assemblyInstanceId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreatePartList(
    Document^ document,
    ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.

Return Value

A new part list multicategory schedule assembly view.

Remarks

The new part list schedule will be preloaded with fields “Family and Type” and “Count”. The document must be regenerated before using the schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class


CreateSheet Method

[image]

Revit 2013 API
AssemblyViewUtils..::..CreateSheet Method
AssemblyViewUtils Class See Also Send Feedback
Creates a new sheet assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ViewSheet CreateSheet(
    Document document,
    ElementId assemblyInstanceId,
    ElementId titleBlockId
)
Visual Basic
Public Shared Function CreateSheet ( _
    document As Document, _
    assemblyInstanceId As ElementId, _
    titleBlockId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreateSheet(
    Document^ document,
    ElementId^ assemblyInstanceId,
    ElementId^ titleBlockId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
titleBlockId
Type: Autodesk.Revit.DB..::..ElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.

Return Value

A new sheet assembly view.

Remarks

The document must be regenerated before using the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AssemblyViewUtils Class


Dispose Method

[image]

Revit 2013 API
AssemblyViewUtils..::..Dispose Method
AssemblyViewUtils Class See Also Send Feedback
Releases all resources used by the AssemblyViewUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AssemblyViewUtils Class


AttachmentType Enumeration

[image]

Revit 2013 API
AttachmentType Enumeration
See Also Send Feedback
Enum determining whether a link is an attachment or an overlay

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AttachmentType
Visual Basic
Public Enumeration AttachmentType
Visual C++
public enum class AttachmentType

Members

Member name | Description
Attachment | The link is an attachment. If the host file is linked into another file, the link will also be brought along.
Overlay | The link is an overlay, only meant to be seen in this file. If the host is linked into another file, the link will not be brought along.

See Also


AutomaticConnectionBehaviorType Enumeration

[image]

Revit 2013 API
AutomaticConnectionBehaviorType Enumeration
See Also Send Feedback
Defines behavior of connector with respect to automatic creation of connections
Enumeration of automatic connection behavior types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AutomaticConnectionBehaviorType
Visual Basic
Public Enumeration AutomaticConnectionBehaviorType
Visual C++
public enum class AutomaticConnectionBehaviorType

Members

Member name | Description
Exclude | Connector does not participate in automatic connection
Active | Connector is actively looking to be connected
Forced | Connector must establish a connection
Accepting | Connector accepts more automatic connections if needed, but
Full | Connector may participate in automatic connection, but at the moment it is fully connected

See Also


BackgroundImageFit Enumeration

[image]

Revit 2013 API
BackgroundImageFit Enumeration
See Also Send Feedback
Indicates the background image fit type in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum BackgroundImageFit
Visual Basic
Public Enumeration BackgroundImageFit
Visual C++
public enum class BackgroundImageFit

Members

Member name | Description
None | No scale applied to the image; it will keep its original size.
Vertical | The image is proportionally resized so its height matches the view's height.
Horizontal | The image is proportionally resized so its width matches the view's width.
Stretch | The image is stretched in both directions so it matches the view's size.

See Also


BackgroundSettings Class

[image]

Revit 2013 API
BackgroundSettings Class
Members See Also Send Feedback
Represents the rendering background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class BackgroundSettings : IDisposable
Visual Basic
Public Class BackgroundSettings _
    Implements IDisposable
Visual C++
public ref class BackgroundSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BackgroundSettings
Autodesk.Revit.DB..::..ColorBackgroundSettings
Autodesk.Revit.DB..::..ImageBackgroundSettings
Autodesk.Revit.DB..::..SkyBackgroundSettings

See Also

BackgroundSettings Members


BackgroundSettings Members

[image] [image]

Revit 2013 API
BackgroundSettings Members
BackgroundSettings Class Methods See Also Send Feedback

The BackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BackgroundSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackgroundSettings Class


BackgroundSettings Methods

[image] [image]

Revit 2013 API
BackgroundSettings Methods
BackgroundSettings Class See Also Send Feedback

The BackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BackgroundSettings Class


Dispose Method

[image]

Revit 2013 API
BackgroundSettings..::..Dispose Method
BackgroundSettings Class See Also Send Feedback
Releases all resources used by the BackgroundSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BackgroundSettings Class


BackgroundStyle Enumeration

[image]

Revit 2013 API
BackgroundStyle Enumeration
See Also Send Feedback
Indicates the background style in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum BackgroundStyle
Visual Basic
Public Enumeration BackgroundStyle
Visual C++
public enum class BackgroundStyle

Members

Member name | Description
SkyNoClouds | Sky background without clouds.
SkyVeryFewClouds | Sky background with very few clouds.
SkyFewClouds | Sky background with few clouds.
SkyCloudy | Cloudy sky background.
SkyVeryCloudy | Very cloudy sky background.
Color | Color background.
Image | Image background.

See Also


BaseArray Class

[image]

Revit 2013 API
BaseArray Class
Members See Also Send Feedback
An abstract base class that represents an array within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BaseArray : Element
Visual Basic
Public MustInherit Class BaseArray _
    Inherits Element
Visual C++
public ref class BaseArray abstract : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..LinearArray
Autodesk.Revit.DB..::..RadialArray

See Also

BaseArray Members


BaseArray Members

[image] [image]

Revit 2013 API
BaseArray Members
BaseArray Class Methods Properties See Also Send Feedback

The BaseArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BaseArray Class


BaseArray Methods

[image] [image]

Revit 2013 API
BaseArray Methods
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseArray Class


GetCopiedMemberIds Method

[image]

Revit 2013 API
BaseArray..::..GetCopiedMemberIds Method
BaseArray Class See Also Send Feedback
Retrieves the copied member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public abstract ICollection<ElementId> GetCopiedMemberIds()
Visual Basic
Public MustOverride Function GetCopiedMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() abstract

Return Value

The copied member Ids of the Array

See Also

BaseArray Class


GetOriginalMemberIds Method

[image]

Revit 2013 API
BaseArray..::..GetOriginalMemberIds Method
BaseArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public abstract ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public MustOverride Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() abstract

Return Value

The original member Ids of the Array

See Also

BaseArray Class


BaseArray Properties

[image] [image]

Revit 2013 API
BaseArray Properties
BaseArray Class See Also Send Feedback

The BaseArray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members.
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BaseArray Class


CopyMembers Property

[image]

Revit 2013 API
BaseArray..::..CopyMembers Property
BaseArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public abstract ElementArray CopyMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")> _
Public MustOverride ReadOnly Property CopyMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class


Label Property

[image]

Revit 2013 API
BaseArray..::..Label Property
BaseArray Class See Also Send Feedback
The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic
Public Property Label As FamilyParameter
    Get
    Set
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the family parameter's ParameterType is not ParameterType.Integer.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to label the BaseArray out of family document.

See Also

BaseArray Class


Name Property

[image]

Revit 2013 API
BaseArray..::..Name Property
BaseArray Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for BaseArray object, an InvalidOperationException will be thrown.

See Also

BaseArray Class


NumMembers Property

[image]

Revit 2013 API
BaseArray..::..NumMembers Property
BaseArray Class See Also Send Feedback
Retrieves or changes the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract int NumMembers { get; set; }
Visual Basic
Public MustOverride Property NumMembers As Integer
    Get
    Set
Visual C++
public:
virtual property int NumMembers {
    int get () abstract;
    void set (int value) abstract;
}

See Also

BaseArray Class


OrigMembers Property

[image]

Revit 2013 API
BaseArray..::..OrigMembers Property
BaseArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public abstract ElementArray OrigMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")> _
Public MustOverride ReadOnly Property OrigMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () abstract;
}

See Also

BaseArray Class


Parameter Property

[image] [image]

Revit 2013 API
BaseArray..::..Parameter Property
BaseArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BaseArray Class
BaseArray Members


BaseExportOptions Class

[image]

Revit 2013 API
BaseExportOptions Class
Members See Also Send Feedback
The base class for options used to export DWG, DXF and DGN format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class BaseExportOptions : IDisposable
Visual Basic
Public Class BaseExportOptions _
    Implements IDisposable
Visual C++
public ref class BaseExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DGNExportOptions

See Also

BaseExportOptions Members


BaseExportOptions Members

[image] [image]

Revit 2013 API
BaseExportOptions Members
BaseExportOptions Class Methods Properties See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class


BaseExportOptions Methods

[image] [image]

Revit 2013 API
BaseExportOptions Methods
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedSetupNames | Returns a list of names of predefined setups of export options.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseExportOptions Class


Dispose Method

[image]

Revit 2013 API
BaseExportOptions..::..Dispose Method
BaseExportOptions Class See Also Send Feedback
Releases all resources used by the BaseExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BaseExportOptions Class


GetPredefinedSetupNames Method

[image]

Revit 2013 API
BaseExportOptions..::..GetPredefinedSetupNames Method
BaseExportOptions Class See Also Send Feedback
Returns a list of names of predefined setups of export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<string> GetPredefinedSetupNames(
    Document document
)
Visual Basic
Public Shared Function GetPredefinedSetupNames ( _
    document As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ GetPredefinedSetupNames(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Remarks

The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BaseExportOptions Class


BaseExportOptions Properties

[image] [image]

Revit 2013 API
BaseExportOptions Properties
BaseExportOptions Class See Also Send Feedback

The BaseExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name.
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false.
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false.
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false.
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

See Also

BaseExportOptions Class


Colors Property

[image]

Revit 2013 API
BaseExportOptions..::..Colors Property
BaseExportOptions Class See Also Send Feedback
Export color mode. Default value is ExportColorMode.IndexColors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExportColorMode Colors { get; set; }
Visual Basic
Public Property Colors As ExportColorMode
    Get
    Set
Visual C++
public:
property ExportColorMode Colors {
    ExportColorMode get ();
    void set (ExportColorMode value);
}

See Also

BaseExportOptions Class


HatchPatternsFileName Property

[image]

Revit 2013 API
BaseExportOptions..::..HatchPatternsFileName Property
BaseExportOptions Class See Also Send Feedback
Custom hatch patterns (pat) file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string HatchPatternsFileName { get; set; }
Visual Basic
Public Property HatchPatternsFileName As String
    Get
    Set
Visual C++
public:
property String^ HatchPatternsFileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

BaseExportOptions Class


HideReferencePlane Property

[image]

Revit 2013 API
BaseExportOptions..::..HideReferencePlane Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide reference planes. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HideReferencePlane { get; set; }
Visual Basic
Public Property HideReferencePlane As Boolean
    Get
    Set
Visual C++
public:
property bool HideReferencePlane {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


HideScopeBox Property

[image]

Revit 2013 API
BaseExportOptions..::..HideScopeBox Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide the scope box. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HideScopeBox { get; set; }
Visual Basic
Public Property HideScopeBox As Boolean
    Get
    Set
Visual C++
public:
property bool HideScopeBox {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


HideUnreferenceViewTags Property

[image]

Revit 2013 API
BaseExportOptions..::..HideUnreferenceViewTags Property
BaseExportOptions Class See Also Send Feedback
Whether or not to hide unreference view tags. Default value is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HideUnreferenceViewTags { get; set; }
Visual Basic
Public Property HideUnreferenceViewTags As Boolean
    Get
    Set
Visual C++
public:
property bool HideUnreferenceViewTags {
    bool get ();
    void set (bool value);
}

See Also

BaseExportOptions Class


LayerMapping Property

[image]

Revit 2013 API
BaseExportOptions..::..LayerMapping Property
BaseExportOptions Class See Also Send Feedback
Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string LayerMapping { get; set; }
Visual Basic
Public Property LayerMapping As String
    Get
    Set
Visual C++
public:
property String^ LayerMapping {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

BaseExportOptions Class


PropOverrides Property

[image]

Revit 2013 API
BaseExportOptions..::..PropOverrides Property
BaseExportOptions Class See Also Send Feedback
How to export overridden object styles. Default value is PropOverrideMode.ByEntity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PropOverrideMode PropOverrides { get; set; }
Visual Basic
Public Property PropOverrides As PropOverrideMode
    Get
    Set
Visual C++
public:
property PropOverrideMode PropOverrides {
    PropOverrideMode get ();
    void set (PropOverrideMode value);
}

See Also

BaseExportOptions Class


BaseImportOptions Class

[image]

Revit 2013 API
BaseImportOptions Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class BaseImportOptions : IDisposable
Visual Basic
Public Class BaseImportOptions _
    Implements IDisposable
Visual C++
public ref class BaseImportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..DGNImportOptions
Autodesk.Revit.DB..::..DWGImportOptions

See Also

BaseImportOptions Members


BaseImportOptions Members

[image] [image]

Revit 2013 API
BaseImportOptions Members
BaseImportOptions Class Methods Properties See Also Send Feedback

The BaseImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BaseImportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetRefPoint |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | SetRefPoint |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.

See Also

BaseImportOptions Class


BaseImportOptions Methods

[image] [image]

Revit 2013 API
BaseImportOptions Methods
BaseImportOptions Class See Also Send Feedback

The BaseImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit.
Public method | GetRefPoint |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit.
Public method | SetRefPoint |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseImportOptions Class


Dispose Method

[image]

Revit 2013 API
BaseImportOptions..::..Dispose Method
BaseImportOptions Class See Also Send Feedback
Releases all resources used by the BaseImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BaseImportOptions Class


GetLayerSelection Method

[image]

Revit 2013 API
BaseImportOptions..::..GetLayerSelection Method
BaseImportOptions Class See Also Send Feedback
Get all set layers name which user want to import into Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<string> GetLayerSelection()
Visual Basic
Public Function GetLayerSelection As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ GetLayerSelection()

Return Value

The layers' name.

See Also

BaseImportOptions Class


GetRefPoint Method

[image]

Revit 2013 API
BaseImportOptions..::..GetRefPoint Method
BaseImportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ GetRefPoint()
Visual Basic
Public Function GetRefPoint As XYZ
Visual C++
public:
XYZ^ GetRefPoint()

See Also

BaseImportOptions Class


SetLayerSelection Method

[image]

Revit 2013 API
BaseImportOptions..::..SetLayerSelection Method
BaseImportOptions Class See Also Send Feedback
Set the layers name which user want to import into Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLayerSelection(
    ICollection<string> layerSelection
)
Visual Basic
Public Sub SetLayerSelection ( _
    layerSelection As ICollection(Of String) _
)
Visual C++
public:
void SetLayerSelection(
    ICollection<String^>^ layerSelection
)

Parameters

layerSelection
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The layers imported into Revit.

Remarks

If user don't set any layer selection, all layers would be imported into Revit for dgn. But for dwg|dxf, all layers (or visible layers, it is up to visibleLayersOnly was set or not) would be imported into Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BaseImportOptions Class


SetRefPoint Method

[image]

Revit 2013 API
BaseImportOptions..::..SetRefPoint Method
BaseImportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetRefPoint(
    XYZ point
)
Visual Basic
Public Sub SetRefPoint ( _
    point As XYZ _
)
Visual C++
public:
void SetRefPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BaseImportOptions Class


BaseImportOptions Properties

[image] [image]

Revit 2013 API
BaseImportOptions Properties
BaseImportOptions Class See Also Send Feedback

The BaseImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views.
Public property | Unit | The unit of measure for imported geometry.
Public property | VisibleLayersOnly | Only import the visible layers.

See Also

BaseImportOptions Class


AutoCorrectAlmostVHLines Property

[image]

Revit 2013 API
BaseImportOptions..::..AutoCorrectAlmostVHLines Property
BaseImportOptions Class See Also Send Feedback
Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AutoCorrectAlmostVHLines { get; set; }
Visual Basic
Public Property AutoCorrectAlmostVHLines As Boolean
    Get
    Set
Visual C++
public:
property bool AutoCorrectAlmostVHLines {
    bool get ();
    void set (bool value);
}

See Also

BaseImportOptions Class


ColorMode Property

[image]

Revit 2013 API
BaseImportOptions..::..ColorMode Property
BaseImportOptions Class See Also Send Feedback
Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ImportColorMode ColorMode { get; set; }
Visual Basic
Public Property ColorMode As ImportColorMode
    Get
    Set
Visual C++
public:
property ImportColorMode ColorMode {
    ImportColorMode get ();
    void set (ImportColorMode value);
}

See Also

BaseImportOptions Class


CustomScale Property

[image]

Revit 2013 API
BaseImportOptions..::..CustomScale Property
BaseImportOptions Class See Also Send Feedback
Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CustomScale { get; set; }
Visual Basic
Public Property CustomScale As Double
    Get
    Set
Visual C++
public:
property double CustomScale {
    double get ();
    void set (double value);
}

See Also

BaseImportOptions Class


OrientToView Property

[image]

Revit 2013 API
BaseImportOptions..::..OrientToView Property
BaseImportOptions Class See Also Send Feedback
Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool OrientToView { get; set; }
Visual Basic
Public Property OrientToView As Boolean
    Get
    Set
Visual C++
public:
property bool OrientToView {
    bool get ();
    void set (bool value);
}

See Also

BaseImportOptions Class


Placement Property

[image]

Revit 2013 API
BaseImportOptions..::..Placement Property
BaseImportOptions Class See Also Send Feedback
Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ImportPlacement Placement { get; set; }
Visual Basic
Public Property Placement As ImportPlacement
    Get
    Set
Visual C++
public:
property ImportPlacement Placement {
    ImportPlacement get ();
    void set (ImportPlacement value);
}

See Also

BaseImportOptions Class


ThisViewOnly Property

[image]

Revit 2013 API
BaseImportOptions..::..ThisViewOnly Property
BaseImportOptions Class See Also Send Feedback
Imports drawings into the view that was passed into the import method. This option is not available in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ThisViewOnly { get; set; }
Visual Basic
Public Property ThisViewOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ThisViewOnly {
    bool get ();
    void set (bool value);
}

See Also

BaseImportOptions Class


Unit Property

[image]

Revit 2013 API
BaseImportOptions..::..Unit Property
BaseImportOptions Class See Also Send Feedback
The unit of measure for imported geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ImportUnit Unit { get; set; }
Visual Basic
Public Property Unit As ImportUnit
    Get
    Set
Visual C++
public:
property ImportUnit Unit {
    ImportUnit get ();
    void set (ImportUnit value);
}

Remarks

Units are used to calculate the import scale unless scale is defined explicitly using CustomScale, in which case Units will be ignored. Feet, inches, meters, centimeters, decimeters, millimeters are all supported. If Default unit is set, Revit will read and use the units from the file. If units are not available or accessible there, Revit will default to inches.

See Also

BaseImportOptions Class


VisibleLayersOnly Property

[image]

Revit 2013 API
BaseImportOptions..::..VisibleLayersOnly Property
BaseImportOptions Class See Also Send Feedback
Only import the visible layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool VisibleLayersOnly { get; set; }
Visual Basic
Public Property VisibleLayersOnly As Boolean
    Get
    Set
Visual C++
public:
property bool VisibleLayersOnly {
    bool get ();
    void set (bool value);
}

Remarks

If this option is set to true, only visible layers are imported. For dgn import, this option is unsupported.

See Also

BaseImportOptions Class


BaseLoadOn Enumeration

[image]

Revit 2013 API
BaseLoadOn Enumeration
See Also Send Feedback
An enumerated type listing all the possible power load use types for a space object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BaseLoadOn
Visual Basic
Public Enumeration BaseLoadOn
Visual C++
public enum class BaseLoadOn

Members

Member name | Description
kUseDefaultLoad | Return BaseLoadOn is UseDefaultLoad.
kUseEnteredLoad | Return BaseLoadOn is UseEnteredLoad.
kUseCalculatedLoad | Return BaseLoadOn is UseCalculatedLoad.
kUseActualLoad | Return BaseLoadOn is UseActualLoad.
kNoOfBaseLoadOnMethods | Return BaseLoadOn is NoOfBaseLoadOnMethods.

See Also


BasePoint Class

[image]

Revit 2013 API
BasePoint Class
Members See Also Send Feedback
Represents kinds of BasePoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BasePoint : Element
Visual Basic
Public Class BasePoint _
    Inherits Element
Visual C++
public ref class BasePoint : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BasePoint

See Also

BasePoint Members


BasePoint Members

[image] [image]

Revit 2013 API
BasePoint Members
BasePoint Class Methods Properties See Also Send Feedback

The BasePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsShared | Indicates whether the base point is shared.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BasePoint Class


BasePoint Methods

[image] [image]

Revit 2013 API
BasePoint Methods
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePoint Class


BasePoint Properties

[image] [image]

Revit 2013 API
BasePoint Properties
BasePoint Class See Also Send Feedback

The BasePoint type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsShared | Indicates whether the base point is shared.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BasePoint Class


IsShared Property

[image]

Revit 2013 API
BasePoint..::..IsShared Property
BasePoint Class See Also Send Feedback
Indicates whether the base point is shared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

BasePoint Class


Parameter Property

[image] [image]

Revit 2013 API
BasePoint..::..Parameter Property
BasePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BasePoint Class
BasePoint Members


BasicFileInfo Class

[image]

Revit 2013 API
BasicFileInfo Class
Members See Also Send Feedback
Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class BasicFileInfo : IDisposable
Visual Basic
Public Class BasicFileInfo _
    Implements IDisposable
Visual C++
public ref class BasicFileInfo : IDisposable

Remarks

This gives fast access to said information without fully opening the file.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BasicFileInfo

See Also

BasicFileInfo Members


BasicFileInfo Members

[image] [image]

Revit 2013 API
BasicFileInfo Members
BasicFileInfo Class Methods Properties See Also Send Feedback

The BasicFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BasicFileInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extract | Retrieves basic file data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralPath | Returns the central model path.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is created local.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | SavedInVersion | Returns the version in which file is saved.
Public property | Username | Returns the username.

See Also

BasicFileInfo Class


BasicFileInfo Methods

[image] [image]

Revit 2013 API
BasicFileInfo Methods
BasicFileInfo Class See Also Send Feedback

The BasicFileInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Extract | Retrieves basic file data.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasicFileInfo Class


Dispose Method

[image]

Revit 2013 API
BasicFileInfo..::..Dispose Method
BasicFileInfo Class See Also Send Feedback
Releases all resources used by the BasicFileInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BasicFileInfo Class


Extract Method

[image]

Revit 2013 API
BasicFileInfo..::..Extract Method
BasicFileInfo Class See Also Send Feedback
Retrieves basic file data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static BasicFileInfo Extract(
    string file
)
Visual Basic
Public Shared Function Extract ( _
    file As String _
) As BasicFileInfo
Visual C++
public:
static BasicFileInfo^ Extract(
    String^ file
)

Parameters

file
Type: System..::..String
The full path to the file to be queried.

Return Value

If successful, basic file data.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file doesn't exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | A file is saved in very old version of Revit without basic file data.

See Also

BasicFileInfo Class


BasicFileInfo Properties

[image] [image]

Revit 2013 API
BasicFileInfo Properties
BasicFileInfo Class See Also Send Feedback

The BasicFileInfo type exposes the following members.

Properties

 | Name | Description
Public property | CentralPath | Returns the central model path.
Public property | IsCentral | Checks if the file is workshared and Central.
Public property | IsCreatedLocal | Checks if the file is created local.
Public property | IsInProgress | Checks if the file is workshared and is in process of becoming Central.
Public property | IsLocal | Checks if the file is workshared and Local.
Public property | IsSavedInCurrentVersion | Checks if the file is saved in the current version.
Public property | IsWorkshared | Checks if the file is workshared.
Public property | LanguageWhenSaved | Return the language active for the last save
Public property | SavedInVersion | Returns the version in which file is saved.
Public property | Username | Returns the username.

See Also

BasicFileInfo Class


CentralPath Property

[image]

Revit 2013 API
BasicFileInfo..::..CentralPath Property
BasicFileInfo Class See Also Send Feedback
Returns the central model path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string CentralPath { get; }
Visual Basic
Public ReadOnly Property CentralPath As String
    Get
Visual C++
public:
property String^ CentralPath {
    String^ get ();
}

See Also

BasicFileInfo Class


IsCentral Property

[image]

Revit 2013 API
BasicFileInfo..::..IsCentral Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared and Central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCentral { get; }
Visual Basic
Public ReadOnly Property IsCentral As Boolean
    Get
Visual C++
public:
property bool IsCentral {
    bool get ();
}

Field Value

True if the file is workshared and Central, false if not.

See Also

BasicFileInfo Class


IsCreatedLocal Property

[image]

Revit 2013 API
BasicFileInfo..::..IsCreatedLocal Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is created local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCreatedLocal { get; }
Visual Basic
Public ReadOnly Property IsCreatedLocal As Boolean
    Get
Visual C++
public:
property bool IsCreatedLocal {
    bool get ();
}

Field Value

True if the file is created local, false if not.

See Also

BasicFileInfo Class


IsInProgress Property

[image]

Revit 2013 API
BasicFileInfo..::..IsInProgress Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared and is in process of becoming Central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsInProgress { get; }
Visual Basic
Public ReadOnly Property IsInProgress As Boolean
    Get
Visual C++
public:
property bool IsInProgress {
    bool get ();
}

Field Value

True if the file is workshared and is in process of becoming Central, false if not.

See Also

BasicFileInfo Class


IsLocal Property

[image]

Revit 2013 API
BasicFileInfo..::..IsLocal Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared and Local.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsLocal { get; }
Visual Basic
Public ReadOnly Property IsLocal As Boolean
    Get
Visual C++
public:
property bool IsLocal {
    bool get ();
}

Field Value

True if the file is workshared and Local, false if not.

See Also

BasicFileInfo Class


IsSavedInCurrentVersion Property

[image]

Revit 2013 API
BasicFileInfo..::..IsSavedInCurrentVersion Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is saved in the current version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSavedInCurrentVersion { get; }
Visual Basic
Public ReadOnly Property IsSavedInCurrentVersion As Boolean
    Get
Visual C++
public:
property bool IsSavedInCurrentVersion {
    bool get ();
}

Field Value

True if the file is saved in the current version, false if not.

See Also

BasicFileInfo Class


IsWorkshared Property

[image]

Revit 2013 API
BasicFileInfo..::..IsWorkshared Property
BasicFileInfo Class See Also Send Feedback
Checks if the file is workshared.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic
Public ReadOnly Property IsWorkshared As Boolean
    Get
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

Field Value

True if the file is workshared, false if not.

See Also

BasicFileInfo Class


LanguageWhenSaved Property

[image]

Revit 2013 API
BasicFileInfo..::..LanguageWhenSaved Property
BasicFileInfo Class See Also Send Feedback
Return the language active for the last save

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LanguageType LanguageWhenSaved { get; }
Visual Basic
Public ReadOnly Property LanguageWhenSaved As LanguageType
    Get
Visual C++
public:
property LanguageType LanguageWhenSaved {
    LanguageType get ();
}

See Also

BasicFileInfo Class


SavedInVersion Property

[image]

Revit 2013 API
BasicFileInfo..::..SavedInVersion Property
BasicFileInfo Class See Also Send Feedback
Returns the version in which file is saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string SavedInVersion { get; }
Visual Basic
Public ReadOnly Property SavedInVersion As String
    Get
Visual C++
public:
property String^ SavedInVersion {
    String^ get ();
}

See Also

BasicFileInfo Class


Username Property

[image]

Revit 2013 API
BasicFileInfo..::..Username Property
BasicFileInfo Class See Also Send Feedback
Returns the username.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Username { get; }
Visual Basic
Public ReadOnly Property Username As String
    Get
Visual C++
public:
property String^ Username {
    String^ get ();
}

See Also

BasicFileInfo Class


BeamSystem Class

[image]

Revit 2013 API
BeamSystem Class
Members Example See Also Send Feedback
An object that represents a BeamSystem within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BeamSystem : Element
Visual Basic
Public Class BeamSystem _
    Inherits Element
Visual C++
public ref class BeamSystem : public Element

Remarks

This object derived from the Element base object. It can be used access the properties of a BeamSystem, such as elevation, level etc. All the beams belongs to a BeamSystem can be got and there is a static method to find out the BeamSystem to which the beam belongs.

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " + beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " + beamSystem.BeamSystemType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BeamSystem

See Also

BeamSystem Members


BeamSystem Members

[image] [image]

Revit 2013 API
BeamSystem Members
BeamSystem Class Methods Properties See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllBeams | Obsolete. Get all the beams of the BeamSystem.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieves or changes the Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystem Class


BeamSystem Methods

[image] [image]

Revit 2013 API
BeamSystem Methods
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | BeamBelongsTo | Find out the BeamSystem to which the beam belongs.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
 | DropBeamSystem | Drop beam system, it will disassociate all members from the beam system and delete the beam system.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllBeams | Obsolete. Get all the beams of the BeamSystem.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBeamIds | Gets all the beams of the BeamSystem.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystem Class


BeamBelongsTo Method

[image]

Revit 2013 API
BeamSystem..::..BeamBelongsTo Method
BeamSystem Class See Also Send Feedback
Find out the BeamSystem to which the beam belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static BeamSystem BeamBelongsTo(
    FamilyInstance beam
)
Visual Basic
Public Shared Function BeamBelongsTo ( _
    beam As FamilyInstance _
) As BeamSystem
Visual C++
public:
static BeamSystem^ BeamBelongsTo(
    FamilyInstance^ beam
)

Parameters

beam
Type: Autodesk.Revit.DB..::..FamilyInstance
The beam want to ask.

Return Value

The BeamSystem.

See Also

BeamSystem Class


DropBeamSystem Method

[image]

Revit 2013 API
BeamSystem..::..DropBeamSystem Method
BeamSystem Class See Also Send Feedback
Drop beam system, it will disassociate all members from the beam system and delete the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void DropBeamSystem(
    BeamSystem beamSystem
)
Visual Basic
Public Shared Sub DropBeamSystem ( _
    beamSystem As BeamSystem _
)
Visual C++
public:
static void DropBeamSystem(
    BeamSystem^ beamSystem
)

Parameters

beamSystem
Type: Autodesk.Revit.DB..::..BeamSystem
The beam system to be deleted.

See Also

BeamSystem Class


GetAllBeams Method

[image]

Revit 2013 API
BeamSystem..::..GetAllBeams Method
BeamSystem Class See Also Send Feedback
Get all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")]
public ElementSet GetAllBeams()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")> _
Public Function GetAllBeams As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call GetBeamIds() instead.")]
public:
ElementSet^ GetAllBeams()

Return Value

The beams.

See Also

BeamSystem Class


GetBeamIds Method

[image]

Revit 2013 API
BeamSystem..::..GetBeamIds Method
BeamSystem Class See Also Send Feedback
Gets all the beams of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetBeamIds()
Visual Basic
Public Function GetBeamIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetBeamIds()

Return Value

The beam Ids.

See Also

BeamSystem Class


BeamSystem Properties

[image] [image]

Revit 2013 API
BeamSystem Properties
BeamSystem Class See Also Send Feedback

The BeamSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeamSystemType | Retrieves or changes the type of the BeamSystem.
Public property | BeamType | Retrieves or changes the Beam Type of the BeamSystem.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieves or changes the Direction of the BeamSystem.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the Elevation of the BeamSystem.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LayoutRule | Retrieves or changes the LayoutRule of the BeamSystem.
Public property | Level | Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Retrieve or set the profile of the BeamSystem.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystem Class


BeamSystemType Property

[image]

Revit 2013 API
BeamSystem..::..BeamSystemType Property
BeamSystem Class Example See Also Send Feedback
Retrieves or changes the type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemType BeamSystemType { get; set; }
Visual Basic
Public Property BeamSystemType As BeamSystemType
    Get
    Set
Visual C++
public:
property BeamSystemType^ BeamSystemType {
    BeamSystemType^ get ();
    void set (BeamSystemType^ value);
}

Examples

CopyC#
public void GetInfo_BeamSystemType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeamSystem type name : " + beamSystem.BeamSystemType.Name;

    // Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName";
    // Get BeamSystem type name
    message += "\nBeamSystem type name after set: " + beamSystem.BeamSystemType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamSystemType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name : " + beamSystem.BeamSystemType.Name

    ' Rename the BeamSystem type used by this BeamSystem
    beamSystem.BeamSystemType.Name = "TestBeamSystemTypeName"
    ' Get BeamSystem type name
    message += vbLf & "BeamSystem type name after set: " + beamSystem.BeamSystemType.Name

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class


BeamType Property

[image]

Revit 2013 API
BeamSystem..::..BeamType Property
BeamSystem Class Example See Also Send Feedback
Retrieves or changes the Beam Type of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol BeamType { get; set; }
Visual Basic
Public Property BeamType As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ BeamType {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Examples

CopyC#
public void GetInfo_BeamType(BeamSystem beamSystem)
{
    string message = "BeamSystem : ";
    // Get BeamSystem type name
    message += "\nBeam type name : " + beamSystem.BeamType.Name;
    // Get BeamSystem type material
    foreach (Material material in beamSystem.BeamType.Materials)
    {
       message += "\nBeam type material : " + material.Name;
    }
    // Get BeamSystem family name
    message += "\nBeam family name : " + beamSystem.BeamType.Family.Name;

    // Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName";
    // Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName";

    // Get BeamSystem type name
    message += "\nBeam type name after set : " + beamSystem.BeamType.Name;
    // Get BeamSystem family name
    message += "\nBeam family name after set : " + beamSystem.BeamType.Family.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BeamType(ByVal beamSystem As BeamSystem)
    Dim message As String = "BeamSystem : "
    ' Get BeamSystem type name
    message += vbLf & "Beam type name : " + beamSystem.BeamType.Name
    ' Get BeamSystem type material
    For Each material As Autodesk.Revit.DB.Material In beamSystem.BeamType.Materials
        message += vbLf & "Beam type material : " + material.Name
    Next
    ' Get BeamSystem family name
    message += vbLf & "Beam family name : " + beamSystem.BeamType.Family.Name

    ' Rename BeamType used by this BeamSystem
    beamSystem.BeamType.Name = "TestBeamTypeName"
    ' Rename the Family used by the BeamType that is used by this BeamSystem
    beamSystem.BeamType.Family.Name = "TestBeamTypeFamilyName"

    ' Get BeamSystem type name
    message += vbLf & "Beam type name after set : " + beamSystem.BeamType.Name
    ' Get BeamSystem family name
    message += vbLf & "Beam family name after set : " + beamSystem.BeamType.Family.Name

    TaskDialog.Show("Revit", message)
End Sub

See Also

BeamSystem Class


Direction Property

[image]

Revit 2013 API
BeamSystem..::..Direction Property
BeamSystem Class See Also Send Feedback
Retrieves or changes the Direction of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

BeamSystem Class


Elevation Property

[image]

Revit 2013 API
BeamSystem..::..Elevation Property
BeamSystem Class See Also Send Feedback
Retrieves or changes the Elevation of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

See Also

BeamSystem Class


LayoutRule Property

[image]

Revit 2013 API
BeamSystem..::..LayoutRule Property
BeamSystem Class See Also Send Feedback
Retrieves or changes the LayoutRule of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LayoutRule LayoutRule { get; set; }
Visual Basic
Public Property LayoutRule As LayoutRule
    Get
    Set
Visual C++
public:
property LayoutRule^ LayoutRule {
    LayoutRule^ get ();
    void set (LayoutRule^ value);
}

See Also

BeamSystem Class


Level Property

[image]

Revit 2013 API
BeamSystem..::..Level Property
BeamSystem Class See Also Send Feedback
Get or change the level of the BeamSystem. When the level is changed, the elevation is changed to make the the BeamSystem remain the location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level Level { get; set; }
Visual Basic
Public Property Level As Level
    Get
    Set
Visual C++
public:
property Level^ Level {
    Level^ get ();
    void set (Level^ value);
}

See Also

BeamSystem Class


Parameter Property

[image] [image]

Revit 2013 API
BeamSystem..::..Parameter Property
BeamSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BeamSystem Class
BeamSystem Members


Profile Property

[image]

Revit 2013 API
BeamSystem..::..Profile Property
BeamSystem Class See Also Send Feedback
Retrieve or set the profile of the BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray Profile { get; set; }
Visual Basic
Public Property Profile As CurveArray
    Get
    Set
Visual C++
public:
property CurveArray^ Profile {
    CurveArray^ get ();
    void set (CurveArray^ value);
}

See Also

BeamSystem Class


BeamSystemJustifyType Enumeration

[image]

Revit 2013 API
BeamSystemJustifyType Enumeration
See Also Send Feedback
Describes the justify method of beamsystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BeamSystemJustifyType
Visual Basic
Public Enumeration BeamSystemJustifyType
Visual C++
public enum class BeamSystemJustifyType

Members

Member name | Description
Center | Center.
End | End.
Beginning | Beginning.
DirectionLine | DirectionLine.

See Also


BeamSystemType Class

[image]

Revit 2013 API
BeamSystemType Class
Members See Also Send Feedback
An object that specifies the type of a beam system in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BeamSystemType : ElementType
Visual Basic
Public Class BeamSystemType _
    Inherits ElementType
Visual C++
public ref class BeamSystemType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..BeamSystemType

See Also

BeamSystemType Members


BeamSystemType Members

[image] [image]

Revit 2013 API
BeamSystemType Members
BeamSystemType Class Methods Properties See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystemType Class


BeamSystemType Methods

[image] [image]

Revit 2013 API
BeamSystemType Methods
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemType Class


BeamSystemType Properties

[image] [image]

Revit 2013 API
BeamSystemType Properties
BeamSystemType Class See Also Send Feedback

The BeamSystemType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BeamSystemType Class


Parameter Property

[image] [image]

Revit 2013 API
BeamSystemType..::..Parameter Property
BeamSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BeamSystemType Class
BeamSystemType Members


BeamSystemTypeSet Class

[image]

Revit 2013 API
BeamSystemTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BeamSystemTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class BeamSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BeamSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BeamSystemTypeSet

See Also

BeamSystemTypeSet Members


BeamSystemTypeSet Members

[image] [image]

Revit 2013 API
BeamSystemTypeSet Members
BeamSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | BeamSystemTypeSet | Initializes a new instance of the BeamSystemTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Constructor

[image]

Revit 2013 API
BeamSystemTypeSet Constructor
BeamSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the BeamSystemTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
BeamSystemTypeSet()

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Methods

[image] [image]

Revit 2013 API
BeamSystemTypeSet Methods
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSet Class


Clear Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..Clear Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BeamSystemTypeSet Class


Contains Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..Contains Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    BeamSystemType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..BeamSystemType

See Also

BeamSystemTypeSet Class


Erase Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..Erase Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    BeamSystemType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As BeamSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..BeamSystemType

See Also

BeamSystemTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..ForwardIterator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ForwardIterator()

See Also

BeamSystemTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..GetEnumerator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BeamSystemTypeSet Class


Insert Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..Insert Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    BeamSystemType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As BeamSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    BeamSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..BeamSystemType

See Also

BeamSystemTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
BeamSystemTypeSet..::..ReverseIterator Method
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BeamSystemTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BeamSystemTypeSetIterator
Visual C++
public:
virtual BeamSystemTypeSetIterator^ ReverseIterator()

See Also

BeamSystemTypeSet Class


BeamSystemTypeSet Properties

[image] [image]

Revit 2013 API
BeamSystemTypeSet Properties
BeamSystemTypeSet Class See Also Send Feedback

The BeamSystemTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

BeamSystemTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
BeamSystemTypeSet..::..IsEmpty Property
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

BeamSystemTypeSet Class


Size Property

[image]

Revit 2013 API
BeamSystemTypeSet..::..Size Property
BeamSystemTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BeamSystemTypeSet Class


BeamSystemTypeSetIterator Class

[image]

Revit 2013 API
BeamSystemTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BeamSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BeamSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BeamSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BeamSystemTypeSetIterator

See Also

BeamSystemTypeSetIterator Members


BeamSystemTypeSetIterator Members

[image] [image]

Revit 2013 API
BeamSystemTypeSetIterator Members
BeamSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BeamSystemTypeSetIterator | Initializes a new instance of the BeamSystemTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Constructor

[image]

Revit 2013 API
BeamSystemTypeSetIterator Constructor
BeamSystemTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the BeamSystemTypeSetIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
BeamSystemTypeSetIterator()

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Methods

[image] [image]

Revit 2013 API
BeamSystemTypeSetIterator Methods
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BeamSystemTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
BeamSystemTypeSetIterator..::..MoveNext Method
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

BeamSystemTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
BeamSystemTypeSetIterator..::..Reset Method
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

BeamSystemTypeSetIterator Class


BeamSystemTypeSetIterator Properties

[image] [image]

Revit 2013 API
BeamSystemTypeSetIterator Properties
BeamSystemTypeSetIterator Class See Also Send Feedback

The BeamSystemTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BeamSystemTypeSetIterator Class


Current Property

[image]

Revit 2013 API
BeamSystemTypeSetIterator..::..Current Property
BeamSystemTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

BeamSystemTypeSetIterator Class


Binding Class

[image]

Revit 2013 API
Binding Class
Members See Also Send Feedback
Binding objects are used to take a parameter definition and bind it to one or more categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class Binding : APIObject
Visual Basic
Public MustInherit Class Binding _
    Inherits APIObject
Visual C++
public ref class Binding abstract : public APIObject

Remarks

This class is a base class for all types of parameter binding within Autodesk Revit. Once the binding objects are created and added to the document parameters will be added to elements in those categories specified in the binding. There are currently two types of binding available, Instance binding and Type binding. The key difference between the two is that the instance bound parameters appear on all instances of the elements in those categories. Changing the parameter on one does not affect the other instances of the parameter. The Type bound parameters appear only on the type object and is shared by all the instances that use that type. Changing the type bound parameter affects all instances of the elements that use that type. Note, a definition can only be bound to an instance or a type and not both.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding

See Also

Binding Members


Binding Members

[image] [image]

Revit 2013 API
Binding Members
Binding Class Methods Properties See Also Send Feedback

The Binding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class


Binding Methods

[image] [image]

Revit 2013 API
Binding Methods
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Binding Class


Binding Properties

[image] [image]

Revit 2013 API
Binding Properties
Binding Class See Also Send Feedback

The Binding type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Binding Class


BindingMap Class

[image]

Revit 2013 API
BindingMap Class
Members See Also Send Feedback
The parameters BindingMap contains all the parameter bindings that exist in the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BindingMap : DefinitionBindingMap
Visual Basic
Public Class BindingMap _
    Inherits DefinitionBindingMap
Visual C++
public ref class BindingMap : public DefinitionBindingMap

Remarks

The ParameterBindingsMap is available from the Document.ParameterBindings property. A parameter binding is the way that a parameter definition is bound to elements within one or more categories. This map can be used to interrogate existing bindings, but it can also be used to generate new parameter bindings by using the Insert method.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..BindingMap

See Also

BindingMap Members


BindingMap Members

[image] [image]

Revit 2013 API
BindingMap Members
BindingMap Class Methods Properties See Also Send Feedback

The BindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::..Clear()()()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::..Contains(Definition).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::..Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::..Item[([( Definition])]) .)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


BindingMap Methods

[image] [image]

Revit 2013 API
BindingMap Methods
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | This method is used to remove all the items in the map. (Overrides DefinitionBindingMap..::..Clear()()()().)
Public method | Contains | The Contains method is used to check if the parameter binding exists for one definition. (Overrides DefinitionBindingMap..::..Contains(Definition).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | This method is used to erase one item in the map. (Overrides DefinitionBindingMap..::..Erase(Definition).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Creates a new parameter binding between a parameter and a set of categories in a specified group.
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.
Public method | Remove | The Remove method is used to remove a parameter binding.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map. (Inherited from DefinitionBindingMap.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindingMap Class


Clear Method

[image]

Revit 2013 API
BindingMap..::..Clear Method
BindingMap Class See Also Send Feedback
This method is used to remove all the items in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

The method Clear inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

BindingMap Class


Contains Method

[image]

Revit 2013 API
BindingMap..::..Contains Method
BindingMap Class See Also Send Feedback
The Contains method is used to check if the parameter binding exists for one definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Contains(
    Definition key
)
Visual Basic
Public Overrides Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


Erase Method

[image]

Revit 2013 API
BindingMap..::..Erase Method
BindingMap Class See Also Send Feedback
This method is used to erase one item in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int Erase(
    Definition key
)
Visual Basic
Public Overrides Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
) override

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

Remarks

The method Erase inherited from base class is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Use Remove() instead to remove the binding from the Revit session and from the map.

See Also

BindingMap Class


Insert Method

[image] [image]

Revit 2013 API
BindingMap..::..Insert Method
BindingMap Class See Also Send Feedback
Creates a new parameter binding.

Overload List

 | Name | Description
Public method | Insert(Definition, Binding) | Creates a new parameter binding between a parameter and a set of categories. (Overrides DefinitionBindingMap..::..Insert(Definition, Binding).)
Public method | Insert(Definition, Binding, BuiltInParameterGroup) | Creates a new parameter binding between a parameter and a set of categories in a specified group.

See Also

BindingMap Class
BindingMap Members


Insert Method (Definition, Binding)

[image]

Revit 2013 API
BindingMap..::..Insert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Insert(
    Definition key,
    Binding item
)
Visual Basic
Public Overrides Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
) override

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.

See Also

BindingMap Class
Insert Overload


Insert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2013 API
BindingMap..::..Insert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Creates a new parameter binding between a parameter and a set of categories in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the Parameter binding already exists, post an error and return false

See Also

BindingMap Class
Insert Overload


ReInsert Method

[image] [image]

Revit 2013 API
BindingMap..::..ReInsert Method
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Overload List

 | Name | Description
Public method | ReInsert(Definition, Binding) | Removes an existing parameter and creates a new binding for a given parameter.
Public method | ReInsert(Definition, Binding, BuiltInParameterGroup) | Removes an existing parameter and creates a new binding for a given parameter in a specified group.

See Also

BindingMap Class
BindingMap Members


ReInsert Method (Definition, Binding)

[image]

Revit 2013 API
BindingMap..::..ReInsert Method (Definition, Binding)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item
)
Visual Basic
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding.

See Also

BindingMap Class
ReInsert Overload


ReInsert Method (Definition, Binding, BuiltInParameterGroup)

[image]

Revit 2013 API
BindingMap..::..ReInsert Method (Definition, Binding, BuiltInParameterGroup)
BindingMap Class See Also Send Feedback
Removes an existing parameter and creates a new binding for a given parameter in a specified group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool ReInsert(
    Definition key,
    Binding item,
    BuiltInParameterGroup parameterGroup
)
Visual Basic
Public Overridable Function ReInsert ( _
    key As Definition, _
    item As Binding, _
    parameterGroup As BuiltInParameterGroup _
) As Boolean
Visual C++
public:
virtual bool ReInsert(
    Definition^ key,
    Binding^ item,
    BuiltInParameterGroup parameterGroup
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.
item
Type: Autodesk.Revit.DB..::..Binding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The GroupID of the parameter definition.

Remarks

Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, remove the binding, create a new parameter binding. If the parameter binding related to the input key doesn't exist in the database, ReInsert will fail and false will be returned. In this case, Insert should be called.

See Also

BindingMap Class
ReInsert Overload


Remove Method

[image]

Revit 2013 API
BindingMap..::..Remove Method
BindingMap Class See Also Send Feedback
The Remove method is used to remove a parameter binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Remove(
    Definition key
)
Visual Basic
Public Overridable Function Remove ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Remove(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

See Also

BindingMap Class


BindingMap Properties

[image] [image]

Revit 2013 API
BindingMap Properties
BindingMap Class See Also Send Feedback

The BindingMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty. (Inherited from DefinitionBindingMap.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | The get_Item method will get the binding item related to the input key. (Overrides DefinitionBindingMap..::..Item[([( Definition])]) .)
Public property | Size | Returns the number of bindings that are in the map. (Inherited from DefinitionBindingMap.)

See Also

BindingMap Class


Item Property

[image]

Revit 2013 API
BindingMap..::..Item Property
BindingMap Class See Also Send Feedback
The get_Item method will get the binding item related to the input key.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Binding this[
    Definition key
] { get; set; }
Visual Basic
Public Overrides Property Item ( _
    key As Definition _
) As Binding
    Get
    Set
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key) override;
    void set (Definition^ key, Binding^ value) override;
}

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
A parameter definition which can be an existing definition or one from a shared parameters file.

Field Value

The returned value of get_Item is an InstanceBinding or TypeBinding object that contains the set of categories to which the parameter is bound. The input item is an InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.

Remarks

set_Item is not permitted for this class. A Autodesk::Revit::Exceptions::InvalidOperationException will be thrown. Instead use Insert, Remove and ReInsert to modify the bindings in the document.

See Also

BindingMap Class


Blend Class

[image]

Revit 2013 API
Blend Class
Members See Also Send Feedback
A blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Blend : GenericForm
Visual Basic
Public Class Blend _
    Inherits GenericForm
Visual C++
public ref class Blend : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Blend

See Also

Blend Members


Blend Members

[image] [image]

Revit 2013 API
Blend Members
Blend Class Methods Properties See Also Send Feedback

The Blend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Blend Class


Blend Methods

[image] [image]

Revit 2013 API
Blend Methods
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blend Class


GetVertexConnectionMap Method

[image]

Revit 2013 API
Blend..::..GetVertexConnectionMap Method
Blend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

Blend Class


SetVertexConnectionMap Method

[image]

Revit 2013 API
Blend..::..SetVertexConnectionMap Method
Blend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::..VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the document failed to regenerate.

See Also

Blend Class


Blend Properties

[image] [image]

Revit 2013 API
Blend Properties
Blend Class See Also Send Feedback

The Blend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomOffset | The offset of the bottom end of the blend relative to the sketch plane.
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomSketch | Returns the Bottom Sketch of the Blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | The offset of the top end of the blend relative to the sketch plane.
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopSketch | Returns the Top Sketch of the Blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Blend Class


BottomOffset Property

[image]

Revit 2013 API
Blend..::..BottomOffset Property
Blend Class See Also Send Feedback
The offset of the bottom end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BottomOffset { get; set; }
Visual Basic
Public Property BottomOffset As Double
    Get
    Set
Visual C++
public:
property double BottomOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


BottomProfile Property

[image]

Revit 2013 API
Blend..::..BottomProfile Property
Blend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


BottomSketch Property

[image]

Revit 2013 API
Blend..::..BottomSketch Property
Blend Class See Also Send Feedback
Returns the Bottom Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic
Public ReadOnly Property BottomSketch As Sketch
    Get
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Bottom Sketch of the Blend.

See Also

Blend Class


Parameter Property

[image] [image]

Revit 2013 API
Blend..::..Parameter Property
Blend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Blend Class
Blend Members


TopOffset Property

[image]

Revit 2013 API
Blend..::..TopOffset Property
Blend Class See Also Send Feedback
The offset of the top end of the blend relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic
Public Property TopOffset As Double
    Get
    Set
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

See Also

Blend Class


TopProfile Property

[image]

Revit 2013 API
Blend..::..TopProfile Property
Blend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic
Public ReadOnly Property TopProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

Blend Class


TopSketch Property

[image]

Revit 2013 API
Blend..::..TopSketch Property
Blend Class See Also Send Feedback
Returns the Top Sketch of the Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic
Public ReadOnly Property TopSketch As Sketch
    Get
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Top Sketch of the Blend.

See Also

Blend Class


BooleanOperationsType Enumeration

[image]

Revit 2013 API
BooleanOperationsType Enumeration
See Also Send Feedback
An enumerated type listing boolean types that are supported for boolean operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum BooleanOperationsType
Visual Basic
Public Enumeration BooleanOperationsType
Visual C++
public enum class BooleanOperationsType

Members

Member name | Description
Union | Union.
Difference | Difference.
Intersect | Intersect.

See Also


BooleanOperationsUtils Class

[image]

Revit 2013 API
BooleanOperationsUtils Class
Members See Also Send Feedback
These utilities are applicable for the geometry created by GeometryCreationUtilities and the geometry of Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class BooleanOperationsUtils : IDisposable
Visual Basic
Public Class BooleanOperationsUtils _
    Implements IDisposable
Visual C++
public ref class BooleanOperationsUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BooleanOperationsUtils

See Also

BooleanOperationsUtils Members


BooleanOperationsUtils Members

[image] [image]

Revit 2013 API
BooleanOperationsUtils Members
BooleanOperationsUtils Class Methods See Also Send Feedback

The BooleanOperationsUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BooleanOperationsUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
 | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanOperationsUtils Class


BooleanOperationsUtils Methods

[image] [image]

Revit 2013 API
BooleanOperationsUtils Methods
BooleanOperationsUtils Class See Also Send Feedback

The BooleanOperationsUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteBooleanOperation | Perform a boolean geometric operation between two solids, and return a new solid to represent the result.
 | ExecuteBooleanOperationModifyingOriginalSolid | Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BooleanOperationsUtils Class


Dispose Method

[image]

Revit 2013 API
BooleanOperationsUtils..::..Dispose Method
BooleanOperationsUtils Class See Also Send Feedback
Releases all resources used by the BooleanOperationsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BooleanOperationsUtils Class


ExecuteBooleanOperation Method

[image]

Revit 2013 API
BooleanOperationsUtils..::..ExecuteBooleanOperation Method
BooleanOperationsUtils Class Example See Also Send Feedback
Perform a boolean geometric operation between two solids, and return a new solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid ExecuteBooleanOperation(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Visual Basic
Public Shared Function ExecuteBooleanOperation ( _
    solid0 As Solid, _
    solid1 As Solid, _
    booleanType As BooleanOperationsType _
) As Solid
Visual C++
public:
static Solid^ ExecuteBooleanOperation(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)

Parameters

solid0
Type: Autodesk.Revit.DB..::..Solid
The first solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
solid1
Type: Autodesk.Revit.DB..::..Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType
Type: Autodesk.Revit.DB..::..BooleanOperationsType
boolean operation type.

Return Value

The result geometry.

Examples

CopyC#
private void ComputeIntersectionVolume(Solid solidA, Solid solidB)
{
    Solid intersection = BooleanOperationsUtils.ExecuteBooleanOperation(solidA, solidB, BooleanOperationsType.Intersect);
    double volumeOfIntersection = intersection.Volume;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to perform the boolean operation for the two solids.

See Also

BooleanOperationsUtils Class


ExecuteBooleanOperationModifyingOriginalSolid Method

[image]

Revit 2013 API
BooleanOperationsUtils..::..ExecuteBooleanOperationModifyingOriginalSolid Method
BooleanOperationsUtils Class See Also Send Feedback
Perform a boolean geometric operation between two solids, and modify the original solid to represent the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid solid0,
    Solid solid1,
    BooleanOperationsType booleanType
)
Visual Basic
Public Shared Sub ExecuteBooleanOperationModifyingOriginalSolid ( _
    solid0 As Solid, _
    solid1 As Solid, _
    booleanType As BooleanOperationsType _
)
Visual C++
public:
static void ExecuteBooleanOperationModifyingOriginalSolid(
    Solid^ solid0,
    Solid^ solid1,
    BooleanOperationsType booleanType
)

Parameters

solid0
Type: Autodesk.Revit.DB..::..Solid
The original solid object. This object cannot be obtained directly from a Revit element. This means that IsElementGeometry cannot be true.
solid1
Type: Autodesk.Revit.DB..::..Solid
The second solid object. A copy will be taken of the input object, so any solid whether obtained from a Revit element or not would be accepted.
booleanType
Type: Autodesk.Revit.DB..::..BooleanOperationsType
boolean operation type.

Remarks

This operation modifies the original input Geometry objects.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the original solid object is the geometry of Revit model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to perform the boolean operation for the two solids.

See Also

BooleanOperationsUtils Class


BorderTile Enumeration

[image]

Revit 2013 API
BorderTile Enumeration
See Also Send Feedback
Options for controlling tiles that overlap the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BorderTile
Visual Basic
Public Enumeration BorderTile
Visual C++
public enum class BorderTile

Members

Member name | Description
Empty |
Partial |
Overhanging |

See Also


BoundaryConditions Class

[image]

Revit 2013 API
BoundaryConditions Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundaryConditions : Element
Visual Basic
Public Class BoundaryConditions _
    Inherits Element
Visual C++
public ref class BoundaryConditions : public Element

Examples

CopyC#
public void GetInfo_BoundaryConditions(BoundaryConditions boundaryConditions)
{
    string message = "BoundaryConditions : ";

    Parameter param = boundaryConditions.get_Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE);
    switch (param.AsInteger())
    {
        case 0:
          XYZ point = boundaryConditions.Point;
            message += "\nThis BoundaryConditions is a Point Boundary Conditions.";
            message += "\nLocation point: (" + point.X + ", "
                        + point.Y + ", " + point.Z + ")";
            break;
        case 1:
            message += "\nThis BoundaryConditions is a Line Boundary Conditions.";
            Curve curve = boundaryConditions.get_Curve(0);
            // Get curve start point
            message += "\nLocation Line: start point: (" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += ";  end point:(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
            break;
        case 2:
            message += "\nThis BoundaryConditions is an Area Boundary Conditions.";
            for (int i = 0; i < boundaryConditions.NumCurves; i++)
            {
                Autodesk.Revit.DB.Curve areaCurve = boundaryConditions.get_Curve(i);
                // Get curve start point
                message += "\nCurve start point:(" + areaCurve.get_EndPoint(0).X + ", "
                     + areaCurve.get_EndPoint(0).Y + ", " + areaCurve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + areaCurve.get_EndPoint(1).X + ", "
                     + areaCurve.get_EndPoint(1).Y + ", " + areaCurve.get_EndPoint(1).Z + ")";
            }
            break;
        default:
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_BoundaryConditions(ByVal boundaryConditions As Autodesk.Revit.DB.BoundaryConditions)
    Dim message As String = "BoundaryConditions : "

    Dim param As Parameter = boundaryConditions.Parameter(BuiltInParameter.BOUNDARY_CONDITIONS_TYPE)
    Select Case param.AsInteger()
        Case 0
            Dim point As Autodesk.Revit.DB.XYZ = boundaryConditions.Point
            message += vbLf & "This BoundaryConditions is a Point Boundary Conditions."
            message += vbLf & "Location point: (" + point.X + ", " + point.Y + ", " + point.Z + ")"
            Exit Select
        Case 1
            message += vbLf & "This BoundaryConditions is a Line Boundary Conditions."
            Dim curve As Curve = boundaryConditions.Curve(0)
            ' Get curve start point
            message += vbLf & "Location Line: start point: (" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += ";  end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            Exit Select
        Case 2
            message += vbLf & "This BoundaryConditions is an Area Boundary Conditions."
            Dim i As Integer = 0
            While i < boundaryConditions.NumCurves
                Dim areaCurve As Autodesk.Revit.DB.Curve = boundaryConditions.Curve(i)
                ' Get curve start point
                message += vbLf & "Curve start point:(" + areaCurve.EndPoint(0).X + ", " + areaCurve.EndPoint(0).Y + ", " + areaCurve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + areaCurve.EndPoint(1).X + ", " + areaCurve.EndPoint(1).Y + ", " + areaCurve.EndPoint(1).Z + ")"
                System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
            End While
            Exit Select
        Case Else
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BoundaryConditions

See Also

BoundaryConditions Members


BoundaryConditions Members

[image] [image]

Revit 2013 API
BoundaryConditions Members
BoundaryConditions Class Methods Properties See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | associateWithLoad | Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedLoad | Retrieve the AssociatedLoad.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | Retrieve the HostElementId.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | If successful, returns the point represents Boundary Conditions.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BoundaryConditions Class


BoundaryConditions Methods

[image] [image]

Revit 2013 API
BoundaryConditions Methods
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | associateWithLoad | Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundaryConditions Class


associateWithLoad Method

[image]

Revit 2013 API
BoundaryConditions..::..associateWithLoad Method
BoundaryConditions Class See Also Send Feedback
Sets the Autodesk::Revit::DB::ElementId^ of Load to associate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool associateWithLoad(
    ElementId elementToAssociateId
)
Visual Basic
Public Function associateWithLoad ( _
    elementToAssociateId As ElementId _
) As Boolean
Visual C++
public:
bool associateWithLoad(
    ElementId^ elementToAssociateId
)

Parameters

elementToAssociateId
Type: Autodesk.Revit.DB..::..ElementId
The Autodesk::Revit::DB::ElementId^ of Load to associate.

Return Value

If the Autodesk::Revit::DB::ElementId^ was set returns true. Otherwise returns false.

Remarks

Autodesk::Revit::DB::ElementId^ may be set if the internal Load with the elementToAssociateId exist and it's type fit the BoundaryConditions type only.

See Also

BoundaryConditions Class


BoundaryConditions Properties

[image] [image]

Revit 2013 API
BoundaryConditions Properties
BoundaryConditions Class See Also Send Feedback

The BoundaryConditions type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedLoad | Retrieve the AssociatedLoad.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | Retrieve the HostElementId.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves represent the Boundary Conditions Element.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | If successful, returns the point represents Boundary Conditions.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BoundaryConditions Class


AssociatedLoad Property

[image]

Revit 2013 API
BoundaryConditions..::..AssociatedLoad Property
BoundaryConditions Class See Also Send Feedback
Retrieve the AssociatedLoad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element AssociatedLoad { get; }
Visual Basic
Public ReadOnly Property AssociatedLoad As Element
    Get
Visual C++
public:
property Element^ AssociatedLoad {
    Element^ get ();
}

See Also

BoundaryConditions Class


Curve Property

[image]

Revit 2013 API
BoundaryConditions..::..Curve Property
BoundaryConditions Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    int curveIndex
] { get; }
Visual Basic
Public ReadOnly Property Curve ( _
    curveIndex As Integer _
) As Curve
    Get
Visual C++
public:
property Curve^ Curve[int curveIndex] {
    Curve^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::..Int32
The index curve in the BoundaryConditions.

Return Value

If successful, returns the curve pointer. Otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The curve index should be between 0 and NumCurves-1.

See Also

BoundaryConditions Class


HostElement Property

[image]

Revit 2013 API
BoundaryConditions..::..HostElement Property
BoundaryConditions Class See Also Send Feedback
Retrieve the HostElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic
Public ReadOnly Property HostElement As Element
    Get
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

See Also

BoundaryConditions Class


NumCurves Property

[image]

Revit 2013 API
BoundaryConditions..::..NumCurves Property
BoundaryConditions Class See Also Send Feedback
Returns the number of curves represent the Boundary Conditions Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumCurves { get; }
Visual Basic
Public ReadOnly Property NumCurves As Integer
    Get
Visual C++
public:
property int NumCurves {
    int get ();
}

Remarks

For Point Boundary Conditions returns 0, for Line Boundary Conditions returns 1, for Area Boundary Conditions returns value > 0.

See Also

BoundaryConditions Class


Parameter Property

[image] [image]

Revit 2013 API
BoundaryConditions..::..Parameter Property
BoundaryConditions Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BoundaryConditions Class
BoundaryConditions Members


Point Property

[image]

Revit 2013 API
BoundaryConditions..::..Point Property
BoundaryConditions Class See Also Send Feedback
If successful, returns the point represents Boundary Conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic
Public ReadOnly Property Point As XYZ
    Get
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

Returns the point if the BoundaryConditionsType == 0 - point. Otherwise returns default XYZ().

See Also

BoundaryConditions Class


BoundarySegment Class

[image]

Revit 2013 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundarySegment

See Also

BoundarySegment Members


BoundarySegment Members

[image] [image]

Revit 2013 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class


BoundarySegment Methods

[image] [image]

Revit 2013 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class


BoundarySegment Properties

[image] [image]

Revit 2013 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class


Curve Property

[image]

Revit 2013 API
BoundarySegment..::..Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class


Document Property

[image]

Revit 2013 API
BoundarySegment..::..Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class


Element Property

[image]

Revit 2013 API
BoundarySegment..::..Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class


BoundarySegmentArray Class

[image]

Revit 2013 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundarySegmentArray

See Also

BoundarySegmentArray Members


BoundarySegmentArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class


BoundarySegmentArray Constructor

[image]

Revit 2013 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class


BoundarySegmentArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class


Append Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class


Clear Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArray Class


Insert Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::..Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class


BoundarySegmentArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArray..::..IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class


Item Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegment this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
    Get
    Set
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class


Size Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class


BoundarySegmentArrayArray Class

[image]

Revit 2013 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members


BoundarySegmentArrayArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class


Append Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class


Clear Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArrayArray Class


Insert Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::..Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class


Item Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
    Get
    Set
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class


Size Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class


BoundarySegmentArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class


BoundingBoxContainsPointFilter Class

[image]

Revit 2013 API
BoundingBoxContainsPointFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxContainsPointFilter : ElementQuickFilter
Visual Basic
Public Class BoundingBoxContainsPointFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxContainsPointFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
// given point in the document.

// Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
XYZ basePnt = new XYZ(0, 0, 0);
BoundingBoxContainsPointFilter filter = new BoundingBoxContainsPointFilter(basePnt);

// Apply the filter to the elements in the active document
// This filter will excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls that do not contain the given point: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxContainsPointFilter notContainFilter =
    new BoundingBoxContainsPointFilter(basePnt, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notContainFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notContainFilter).ToElements();
CopyVB.NET
' Use BoundingBoxContainsPoint filter to find elements with a bounding box that contains the
' given point in the document.

' Create a BoundingBoxContainsPoint filter for base point of (0, 0, 0)
Dim basePnt As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim filter As New BoundingBoxContainsPointFilter(basePnt)

' Apply the filter to the elements in the active document
' This filter will excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find walls that do not contain the given point: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim notContainFilter As New BoundingBoxContainsPointFilter(basePnt, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notContainFounds As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(notContainFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxContainsPointFilter

See Also

BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Members

[image] [image]

Revit 2013 API
BoundingBoxContainsPointFilter Members
BoundingBoxContainsPointFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxContainsPointFilter Constructor

[image] [image]

Revit 2013 API
BoundingBoxContainsPointFilter Constructor
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxContainsPointFilter(XYZ) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point.
Public method | BoundingBoxContainsPointFilter(XYZ, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Constructor (XYZ)

[image]

Revit 2013 API
BoundingBoxContainsPointFilter Constructor (XYZ)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point
)
Visual Basic
Public Sub New ( _
    point As XYZ _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box that contains it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)

[image]

Revit 2013 API
BoundingBoxContainsPointFilter Constructor (XYZ, Boolean)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    bool inverted
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box containing it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Double)

[image]

Revit 2013 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box that contains it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)

[image]

Revit 2013 API
BoundingBoxContainsPointFilter Constructor (XYZ, Double, Boolean)
BoundingBoxContainsPointFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that contains the given point, with the option to invert the filter and match all elements with a bounding box that do not contain the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxContainsPointFilter(
    XYZ point,
    double tolerance,
    bool inverted
)
Visual Basic
Public Sub New ( _
    point As XYZ, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxContainsPointFilter(
    XYZ^ point,
    double tolerance,
    bool inverted
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point used to find elements with a bounding box containing it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that do not contain the given point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Overload


BoundingBoxContainsPointFilter Methods

[image] [image]

Revit 2013 API
BoundingBoxContainsPointFilter Methods
BoundingBoxContainsPointFilter Class See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxContainsPointFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
BoundingBoxContainsPointFilter..::..PassesFilter Method
BoundingBoxContainsPointFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxContainsPointFilter Class
BoundingBoxContainsPointFilter Members


BoundingBoxContainsPointFilter Properties

[image] [image]

Revit 2013 API
BoundingBoxContainsPointFilter Properties
BoundingBoxContainsPointFilter Class See Also Send Feedback

The BoundingBoxContainsPointFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Point | The XYZ point to use when matching element bounding boxes.
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxContainsPointFilter Class


Point Property

[image]

Revit 2013 API
BoundingBoxContainsPointFilter..::..Point Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
The XYZ point to use when matching element bounding boxes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

BoundingBoxContainsPointFilter Class


Tolerance Property

[image]

Revit 2013 API
BoundingBoxContainsPointFilter..::..Tolerance Property
BoundingBoxContainsPointFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the point may lie up to the tolerance amount outside the outline to be matched. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline to be matched.

See Also

BoundingBoxContainsPointFilter Class


BoundingBoxIntersectsFilter Class

[image]

Revit 2013 API
BoundingBoxIntersectsFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxIntersectsFilter : ElementQuickFilter
Visual Basic
Public Class BoundingBoxIntersectsFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxIntersectsFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
// given Outline in the document.

// Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIntersects filter with this Outline
BoundingBoxIntersectsFilter filter = new BoundingBoxIntersectsFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIntersectsFilter invertFilter = new BoundingBoxIntersectsFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> notIntersectWalls =
    collector.OfClass(typeof(Wall)).WherePasses(invertFilter).ToElements();
CopyVB.NET
' Use BoundingBoxIntersects filter to find elements with a bounding box that intersects the
' given Outline in the document.

' Create a Outline, uses a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New Autodesk.Revit.DB.XYZ(0, 0, 0), New Autodesk.Revit.DB.XYZ(100, 100, 100))

' Create a BoundingBoxIntersects filter with this Outline
Dim filter As New BoundingBoxIntersectsFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find all walls which don't intersect with BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim invertFilter As New BoundingBoxIntersectsFilter(myOutLn, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notIntersectWalls As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(invertFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxIntersectsFilter

See Also

BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Members

[image] [image]

Revit 2013 API
BoundingBoxIntersectsFilter Members
BoundingBoxIntersectsFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIntersectsFilter Constructor

[image] [image]

Revit 2013 API
BoundingBoxIntersectsFilter Constructor
BoundingBoxIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxIntersectsFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.
Public method | BoundingBoxIntersectsFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Constructor (Outline)

[image]

Revit 2013 API
BoundingBoxIntersectsFilter Constructor (Outline)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Boolean)

[image]

Revit 2013 API
BoundingBoxIntersectsFilter Constructor (Outline, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double)

[image]

Revit 2013 API
BoundingBoxIntersectsFilter Constructor (Outline, Double)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)

[image]

Revit 2013 API
BoundingBoxIntersectsFilter Constructor (Outline, Double, Boolean)
BoundingBoxIntersectsFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that intersects the given Outline, with the option to invert the filter and match all elements with a bounding box that are not intersecting the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIntersectsFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIntersectsFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that intersect it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not intersecting the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Overload


BoundingBoxIntersectsFilter Methods

[image] [image]

Revit 2013 API
BoundingBoxIntersectsFilter Methods
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxIntersectsFilter Class


GetBoundingBox Method

[image]

Revit 2013 API
BoundingBoxIntersectsFilter..::..GetBoundingBox Method
BoundingBoxIntersectsFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIntersectsFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
BoundingBoxIntersectsFilter..::..PassesFilter Method
BoundingBoxIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxIntersectsFilter Class
BoundingBoxIntersectsFilter Members


BoundingBoxIntersectsFilter Properties

[image] [image]

Revit 2013 API
BoundingBoxIntersectsFilter Properties
BoundingBoxIntersectsFilter Class See Also Send Feedback

The BoundingBoxIntersectsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIntersectsFilter Class


Tolerance Property

[image]

Revit 2013 API
BoundingBoxIntersectsFilter..::..Tolerance Property
BoundingBoxIntersectsFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

See Also

BoundingBoxIntersectsFilter Class


BoundingBoxIsInsideFilter Class

[image]

Revit 2013 API
BoundingBoxIsInsideFilter Class
Members Example See Also Send Feedback
A filter used to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class BoundingBoxIsInsideFilter : ElementQuickFilter
Visual Basic
Public Class BoundingBoxIsInsideFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class BoundingBoxIsInsideFilter : public ElementQuickFilter

Remarks

This filter excludes all objects derived from View and objects derived from ElementType. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
// by the given Outline in the document.

// Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Outline myOutLn = new Outline(new XYZ(0, 0, 0), new XYZ(100, 100, 100));

// Create a BoundingBoxIsInside filter for Outline
BoundingBoxIsInsideFilter filter = new BoundingBoxIsInsideFilter(myOutLn);

// Apply the filter to the elements in the active document
// This filter excludes all objects derived from View and objects derived from ElementType
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> elements = collector.WherePasses(filter).ToElements();

// Find walls outside BoundingBox: use an inverted filter to match elements
// Use shortcut command OfClass() to find walls only
BoundingBoxIsInsideFilter outsideFilter = new BoundingBoxIsInsideFilter(myOutLn, true); // inverted filter
collector = new FilteredElementCollector(document);
IList<Element> outsideFounds = collector.OfClass(typeof(Wall)).WherePasses(outsideFilter).ToElements();
CopyVB.NET
' Use BoundingBoxIsInside filter to find elements with a bounding box that is contained(inside completely)
' by the given Outline in the document.

' Create a Outline, use a minimum and maximum XYZ point to initialize the outline.
Dim myOutLn As New Outline(New Autodesk.Revit.DB.XYZ(0, 0, 0), New Autodesk.Revit.DB.XYZ(100, 100, 100))

' Create a BoundingBoxIsInside filter for Outline
Dim filter As New BoundingBoxIsInsideFilter(myOutLn)

' Apply the filter to the elements in the active document
' This filter excludes all objects derived from View and objects derived from ElementType
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim elements As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find walls outside BoundingBox: use an inverted filter to match elements
' Use shortcut command OfClass() to find walls only
Dim outsideFilter As New BoundingBoxIsInsideFilter(myOutLn, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim outsideFounds As IList(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(outsideFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxIsInsideFilter

See Also

BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Members

[image] [image]

Revit 2013 API
BoundingBoxIsInsideFilter Members
BoundingBoxIsInsideFilter Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxIsInsideFilter Constructor

[image] [image]

Revit 2013 API
BoundingBoxIsInsideFilter Constructor
BoundingBoxIsInsideFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxIsInsideFilter(Outline) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double) | Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.
Public method | BoundingBoxIsInsideFilter(Outline, Double, Boolean) | Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Constructor (Outline)

[image]

Revit 2013 API
BoundingBoxIsInsideFilter Constructor (Outline)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline
)
Visual Basic
Public Sub New ( _
    outline As Outline _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Boolean)

[image]

Revit 2013 API
BoundingBoxIsInsideFilter Constructor (Outline, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Double)

[image]

Revit 2013 API
BoundingBoxIsInsideFilter Constructor (Outline, Double)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box that is contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Constructor (Outline, Double, Boolean)

[image]

Revit 2013 API
BoundingBoxIsInsideFilter Constructor (Outline, Double, Boolean)
BoundingBoxIsInsideFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements with a bounding box is contained by the given Outline, with the option to invert the filter and match all elements with a bounding box that are not contained by the given Outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxIsInsideFilter(
    Outline outline,
    double tolerance,
    bool inverted
)
Visual Basic
Public Sub New ( _
    outline As Outline, _
    tolerance As Double, _
    inverted As Boolean _
)
Visual C++
public:
BoundingBoxIsInsideFilter(
    Outline^ outline,
    double tolerance,
    bool inverted
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The Outline used to find elements with a bounding box that are contained by it.
tolerance
Type: System..::..Double
The tolerance value to use instead of zero. See the tolerance property for details.
inverted
Type: System..::..Boolean
True if the filter should be inverted and match all elements with a bounding box that are not contained by the given Outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | outline is an empty Outline. -or- The given value for tolerance is not finite -or- The given value for tolerance is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Overload


BoundingBoxIsInsideFilter Methods

[image] [image]

Revit 2013 API
BoundingBoxIsInsideFilter Methods
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the outline being used for this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxIsInsideFilter Class


GetBoundingBox Method

[image]

Revit 2013 API
BoundingBoxIsInsideFilter..::..GetBoundingBox Method
BoundingBoxIsInsideFilter Class See Also Send Feedback
Gets the outline being used for this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The outline being used for this filter.

See Also

BoundingBoxIsInsideFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
BoundingBoxIsInsideFilter..::..PassesFilter Method
BoundingBoxIsInsideFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

BoundingBoxIsInsideFilter Class
BoundingBoxIsInsideFilter Members


BoundingBoxIsInsideFilter Properties

[image] [image]

Revit 2013 API
BoundingBoxIsInsideFilter Properties
BoundingBoxIsInsideFilter Class See Also Send Feedback

The BoundingBoxIsInsideFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | Tolerance | Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

See Also

BoundingBoxIsInsideFilter Class


Tolerance Property

[image]

Revit 2013 API
BoundingBoxIsInsideFilter..::..Tolerance Property
BoundingBoxIsInsideFilter Class See Also Send Feedback
Allows control over the match criteria by using a tolerance in the geometry comparison. It is suggested to use this in cases where trivial differences should be considered when matching elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Tolerance { get; set; }
Visual Basic
Public Property Tolerance As Double
    Get
    Set
Visual C++
public:
property double Tolerance {
    double get ();
    void set (double value);
}

Remarks

By default this is set to zero, but depending on your units of measure and how close objects may be, it is advised to set this to something more realistic. If the tolerance is positive, the iterated element's Outline may extend the tolerance distance outside of the given Outline in each coordinate to be a match. If the tolerance is negative, the iterated element's Outline must lie at least the tolerance distance inside the given Outline in each coordinate to be a match.

See Also

BoundingBoxIsInsideFilter Class


BoundingBoxUV Class

[image]

Revit 2013 API
BoundingBoxUV Class
Members Example See Also Send Feedback
A two-dimensional rectangle, parallel to the coordinate axes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundingBoxUV : IDisposable
Visual Basic
Public Class BoundingBoxUV _
    Implements IDisposable
Visual C++
public ref class BoundingBoxUV : IDisposable

Examples

CopyC#
Document doc = application.ActiveUIDocument.Document;
FilteredElementCollector collector = new FilteredElementCollector(doc);
ICollection<Element> collection = collector.OfClass(typeof(Autodesk.Revit.DB.View)).ToElements();
foreach (Element element in collection)

{
    Autodesk.Revit.DB.View view = element as Autodesk.Revit.DB.View;
    if (null != view)
    {
        string messageInfo = "BoundingBoxUV : ";
        messageInfo += "\nView name : " + view.Name;
        BoundingBoxUV boundingBox = view.Outline;
        // Get max bounding box
        UV max = boundingBox.Max;
        messageInfo += "\nMax boundingbox : (" + max.U + "," + max.V + ")";
        // Get min bounding box
        UV min = boundingBox.Min;
        messageInfo += "\nMin boundingbox : (" + min.U + "," + min.V + ")";
        // Get bounds,
        // Use 0 for Min and 1 for Max
        UV bound = boundingBox.get_Bounds(0);
        messageInfo += "\nBoundingbox bounds : (" + bound.U + "," + bound.V + ")";
        TaskDialog.Show("Revit",messageInfo);
    }
}
CopyVB.NET
Dim doc As Document = application.ActiveUIDocument.Document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Autodesk.Revit.DB.View)).ToElements()
For Each element As Autodesk.Revit.DB.Element In collection

    Dim view As Autodesk.Revit.DB.View = TryCast(element, Autodesk.Revit.DB.View)
    If view IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxUV : "
        messageInfo += vbLf & "View name : " + view.Name
        Dim boundingBox As BoundingBoxUV = view.Outline
        ' Get max bounding box
        Dim max As Autodesk.Revit.DB.UV = boundingBox.Max
        messageInfo += vbLf & "Max boundingbox : (" + max.U + "," + max.V + ")"
        ' Get min bounding box
        Dim min As Autodesk.Revit.DB.UV = boundingBox.Min
        messageInfo += vbLf & "Min boundingbox : (" + min.U + "," + min.V + ")"
        ' Get bounds,
        ' Use 0 for Min and 1 for Max
        Dim bound As Autodesk.Revit.DB.UV = boundingBox.Bounds(0)
        messageInfo += vbLf & "Boundingbox bounds : (" + bound.U + "," + bound.V + ")"
        TaskDialog.Show("Revit", messageInfo)
    End If
Next

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BoundingBoxUV

See Also

BoundingBoxUV Members


BoundingBoxUV Members

[image] [image]

Revit 2013 API
BoundingBoxUV Members
BoundingBoxUV Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxUV()()()() | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BoundingBoxUV
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


BoundingBoxUV Constructor

[image] [image]

Revit 2013 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BoundingBoxUV()()()() | default constructor
Public method | BoundingBoxUV(Double, Double, Double, Double) | Creates object with supplied values.

See Also

BoundingBoxUV Class
BoundingBoxUV Members


BoundingBoxUV Constructor

[image]

Revit 2013 API
BoundingBoxUV Constructor
BoundingBoxUV Class See Also Send Feedback
default constructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV()
Visual Basic
Public Sub New
Visual C++
public:
BoundingBoxUV()

See Also

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Constructor (Double, Double, Double, Double)

[image]

Revit 2013 API
BoundingBoxUV Constructor (Double, Double, Double, Double)
BoundingBoxUV Class See Also Send Feedback
Creates object with supplied values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)
Visual Basic
Public Sub New ( _
    min_u As Double, _
    min_v As Double, _
    max_u As Double, _
    max_v As Double _
)
Visual C++
public:
BoundingBoxUV(
    double min_u,
    double min_v,
    double max_u,
    double max_v
)

Parameters

min_u
Type: System..::..Double
The first coordinate of min.
min_v
Type: System..::..Double
The second coordinate of min.
max_u
Type: System..::..Double
The first coordinate of max.
max_v
Type: System..::..Double
The second coordinate of max.

See Also

BoundingBoxUV Class
BoundingBoxUV Overload


BoundingBoxUV Methods

[image] [image]

Revit 2013 API
BoundingBoxUV Methods
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxUV Class


Dispose Method

[image]

Revit 2013 API
BoundingBoxUV..::..Dispose Method
BoundingBoxUV Class See Also Send Feedback
Releases all resources used by the BoundingBoxUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BoundingBoxUV Class


BoundingBoxUV Properties

[image] [image]

Revit 2013 API
BoundingBoxUV Properties
BoundingBoxUV Class See Also Send Feedback

The BoundingBoxUV type exposes the following members.

Properties

 | Name | Description
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Max | Maximum coordinates (upper-right corner of the box).
Public property | Min | Minimum coordinates (lower-left corner of the box).

See Also

BoundingBoxUV Class


Bounds Property

[image]

Revit 2013 API
BoundingBoxUV..::..Bounds Property
BoundingBoxUV Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Bounds ( _
    idx As Integer _
) As UV
    Get
Visual C++
public:
property UV^ Bounds[int idx] {
    UV^ get (int idx);
}

Parameters

idx
Type: System..::..Int32

See Also

BoundingBoxUV Class


Max Property

[image]

Revit 2013 API
BoundingBoxUV..::..Max Property
BoundingBoxUV Class See Also Send Feedback
Maximum coordinates (upper-right corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Max { get; set; }
Visual Basic
Public Property Max As UV
    Get
    Set
Visual C++
public:
property UV^ Max {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


Min Property

[image]

Revit 2013 API
BoundingBoxUV..::..Min Property
BoundingBoxUV Class See Also Send Feedback
Minimum coordinates (lower-left corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Min { get; set; }
Visual Basic
Public Property Min As UV
    Get
    Set
Visual C++
public:
property UV^ Min {
    UV^ get ();
    void set (UV^ value);
}

See Also

BoundingBoxUV Class


BoundingBoxXYZ Class

[image]

Revit 2013 API
BoundingBoxXYZ Class
Members Example See Also Send Feedback
A three-dimensional rectangular box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundingBoxXYZ : APIObject
Visual Basic
Public Class BoundingBoxXYZ _
    Inherits APIObject
Visual C++
public ref class BoundingBoxXYZ : public APIObject

Remarks

The box is defined as follows. A Transform specifies the coordinate system in which the box is defined. The minimum and maximum values for each coordinate in that system are specified. An alternative way to construct the box is: for each basis vector of the transform, there are two planes that are orthogonal to the vector and have their origins given by Transform.Origin + BasisVector * Bound. The entire box and each face may be turned on or off.

Examples

CopyC#
Document doc = uiApplication.ActiveUIDocument.Document;
View3D view3D = null;
FilteredElementCollector collector = new FilteredElementCollector(doc);
ICollection<Element> collection = collector.OfClass(typeof(View3D)).ToElements();
foreach (Element element in collection)
 {
    view3D = element as View3D;
    if (null != view3D)
    {
        string messageInfo = "BoundingBoxXYZ : ";
        messageInfo += "\nView name : " + view3D.Name;
        BoundingBoxXYZ boundingBox = view3D.SectionBox;
        if (!boundingBox.Enabled)
        {
            boundingBox.Enabled = true;
        }
        if (boundingBox.Enabled)
        {
            // Get max boundingbox
           XYZ max = boundingBox.Max;
            messageInfo += "\nMax boundingbox : (" + max.X + ","
                + max.Y + "," + max.Z + ")";
            // Get min boundingbox
            XYZ min = boundingBox.Min;
            messageInfo += "\nMin boundingbox : (" + min.X + ","
                + min.Y + "," + min.Z + ")";
            // Get if max boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMaxEnabledX = boundingBox.get_MaxEnabled(0);
            // Get if min boundingbox enabled,
            // use 0 for X, 1 for Y and 2 for Z
            bool bMinEnabledX = boundingBox.get_MinEnabled(0);
            // Get if bound boundingbox enabled
            // For bound, use 0 for Min and 1 for Max.
            // For dimension, use 0 for X, 1 for Y and 2 for Z
            bool bBoundEnabled = boundingBox.get_BoundEnabled(0, 0);
            // Get minimum bound of boundingbox
            XYZ minBound = boundingBox.get_Bounds(0);
            // Get maximum bound of boundingbox
            XYZ maxBound = boundingBox.get_Bounds(1);
        }
        TaskDialog.Show("Revit",messageInfo);
    }
}
CopyVB.NET
Dim doc As Document = uiApplication.ActiveUIDocument.Document
Dim view3D As View3D = Nothing
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(View3D)).ToElements()
For Each element As Autodesk.Revit.DB.Element In collection
    view3D = TryCast(element, View3D)
    If view3D IsNot Nothing Then
        Dim messageInfo As String = "BoundingBoxXYZ : "
        messageInfo += vbLf & "View name : " + view3D.Name
        Dim boundingBox As BoundingBoxXYZ = view3D.SectionBox
        If Not boundingBox.Enabled Then
            boundingBox.Enabled = True
        End If
        If boundingBox.Enabled Then
            ' Get max boundingbox
            Dim max As Autodesk.Revit.DB.XYZ = boundingBox.Max
            messageInfo += vbLf & "Max boundingbox : (" + max.X + "," + max.Y + "," + max.Z + ")"
            ' Get min boundingbox
            Dim min As Autodesk.Revit.DB.XYZ = boundingBox.Min
            messageInfo += vbLf & "Min boundingbox : (" + min.X + "," + min.Y + "," + min.Z + ")"
            ' Get if max boundingbox enabled,
            ' use 0 for X, 1 for Y and 2 for Z
            Dim bMaxEnabledX As Boolean = boundingBox.MaxEnabled(0)
            ' Get if min boundingbox enabled,
            ' use 0 for X, 1 for Y and 2 for Z
            Dim bMinEnabledX As Boolean = boundingBox.MinEnabled(0)
            ' Get if bound boundingbox enabled
            ' For bound, use 0 for Min and 1 for Max.
            ' For dimension, use 0 for X, 1 for Y and 2 for Z
            Dim bBoundEnabled As Boolean = boundingBox.BoundEnabled(0, 0)
            ' Get minimum bound of boundingbox
            Dim minBound As Autodesk.Revit.DB.XYZ = boundingBox.Bounds(0)
            ' Get maximum bound of boundingbox
            Dim maxBound As Autodesk.Revit.DB.XYZ = boundingBox.Bounds(1)
        End If
        TaskDialog.Show("Revit", messageInfo)
    End If
Next

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..BoundingBoxXYZ

See Also

BoundingBoxXYZ Members


BoundingBoxXYZ Members

[image] [image]

Revit 2013 API
BoundingBoxXYZ Members
BoundingBoxXYZ Class Constructors Methods Properties See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Constructors

 | Name | Description
Public method | BoundingBoxXYZ | Initializes a new instance of the BoundingBoxXYZ class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Constructor

[image]

Revit 2013 API
BoundingBoxXYZ Constructor
BoundingBoxXYZ Class See Also Send Feedback
Initializes a new instance of the BoundingBoxXYZ class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ()
Visual Basic
Public Sub New
Visual C++
public:
BoundingBoxXYZ()

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Methods

[image] [image]

Revit 2013 API
BoundingBoxXYZ Methods
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundingBoxXYZ Class


BoundingBoxXYZ Properties

[image] [image]

Revit 2013 API
BoundingBoxXYZ Properties
BoundingBoxXYZ Class See Also Send Feedback

The BoundingBoxXYZ type exposes the following members.

Properties

 | Name | Description
Public property | BoundEnabled | Indexed access for loops.
Public property | Bounds | Indexed access for loops. Use 0 for Min and 1 for Max.
Public property | Enabled | Defines whether bounding box is turned on.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Max | Maximum coordinates (upper-right-front corner of the box).
Public property | MaxEnabled | Defines whether the maximum bound is active for given dimension.
Public property | Min | Minimum coordinates (lower-left-rear corner of the box).
Public property | MinEnabled | Defines whether the minimum bound is active for given dimension.
Public property | Transform | The transform FROM the coordinate space of the box TO the model space.

See Also

BoundingBoxXYZ Class


BoundEnabled Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..BoundEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    int bound,
    int dim
] { get; set; }
Visual Basic
Public Property BoundEnabled ( _
    bound As Integer, _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool BoundEnabled[int bound, int dim] {
    bool get (int bound, int dim);
    void set (int bound, int dim, bool value);
}

Parameters

bound
Type: System..::..Int32
dim
Type: System..::..Int32

Remarks

For bound, use 0 for Min and 1 for Max. For dimension, use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds.

See Also

BoundingBoxXYZ Class


Bounds Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..Bounds Property
BoundingBoxXYZ Class See Also Send Feedback
Indexed access for loops. Use 0 for Min and 1 for Max.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int bound
] { get; set; }
Visual Basic
Public Property Bounds ( _
    bound As Integer _
) As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Bounds[int bound] {
    XYZ^ get (int bound);
    void set (int bound, XYZ^ value);
}

Parameters

bound
Type: System..::..Int32

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


Enabled Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..Enabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether bounding box is turned on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

BoundingBoxXYZ Class


Max Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..Max Property
BoundingBoxXYZ Class See Also Send Feedback
Maximum coordinates (upper-right-front corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Max { get; set; }
Visual Basic
Public Property Max As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


MaxEnabled Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..MaxEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the maximum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    int dim
] { get; set; }
Visual Basic
Public Property MaxEnabled ( _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool MaxEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::..Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds.

See Also

BoundingBoxXYZ Class


Min Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..Min Property
BoundingBoxXYZ Class See Also Send Feedback
Minimum coordinates (lower-left-rear corner of the box).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Min { get; set; }
Visual Basic
Public Property Min As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The bounds are defined in the coordinate space of the box.

See Also

BoundingBoxXYZ Class


MinEnabled Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..MinEnabled Property
BoundingBoxXYZ Class See Also Send Feedback
Defines whether the minimum bound is active for given dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    int dim
] { get; set; }
Visual Basic
Public Property MinEnabled ( _
    dim As Integer _
) As Boolean
    Get
    Set
Visual C++
public:
property bool MinEnabled[int dim] {
    bool get (int dim);
    void set (int dim, bool value);
}

Parameters

dim
Type: System..::..Int32

Remarks

Use 0 for X, 1 for Y and 2 for Z. The entire box must be enabled to enable individual bounds.

See Also

BoundingBoxXYZ Class


Transform Property

[image]

Revit 2013 API
BoundingBoxXYZ..::..Transform Property
BoundingBoxXYZ Class Example See Also Send Feedback
The transform FROM the coordinate space of the box TO the model space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Transform { get; set; }
Visual Basic
Public Property Transform As Transform
    Get
    Set
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
    void set (Transform^ value);
}

Remarks

The transform must always be right-handed and orthonormal.

Examples

CopyC#
private void RotateBoundingBox(View3D view3d)
{
    BoundingBoxXYZ box = view3d.SectionBox;
    if (false == box.Enabled)
    {
        TaskDialog.Show("Revit","The section box for View3D isn't Enable.");
        return;
    }
    // Create a rotation transform,
    XYZ origin = new XYZ(0, 0, 0);
    XYZ axis = new XYZ(0, 0, 1);
    Transform rotate = Transform.get_Rotation(origin, axis, 2);
    // Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate);
    view3d.SectionBox = box;
}
CopyVB.NET
Private Sub RotateBoundingBox(ByVal view3d As View3D)
    Dim box As BoundingBoxXYZ = view3d.SectionBox
    If False = box.Enabled Then
        TaskDialog.Show("Revit", "The section box for View3D isn't Enable.")
        Return
    End If
    ' Create a rotation transform,
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim axis As New Autodesk.Revit.DB.XYZ(0, 0, 1)
    Dim rotate As Transform = Transform.Rotation(origin, axis, 2)
    ' Transform the View3D's SectionBox with the rotation transfrom
    box.Transform = box.Transform.Multiply(rotate)
    view3d.SectionBox = box
End Sub

See Also

BoundingBoxXYZ Class


BoxPlacement Enumeration

[image]

Revit 2013 API
BoxPlacement Enumeration
See Also Send Feedback
An enumerated type listing possible placement of a box (an object of rectangular shape).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BoxPlacement
Visual Basic
Public Enumeration BoxPlacement
Visual C++
public enum class BoxPlacement

Members

Member name | Description
Center | Placement of a box by its center point.
TopLeft | Placement of a box by its top left corner.
TopRight | Placement of a box by its top right corner.
BottomRight | Placement of a box by its bottom right corner.
BottomLeft | Placement of a box by its bottom left corner.

See Also


BuildingPadType Class

[image]

Revit 2013 API
BuildingPadType Class
Members See Also Send Feedback
Represents a specific type of Building Pad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BuildingPadType : HostObjAttributes
Visual Basic
Public Class BuildingPadType _
    Inherits HostObjAttributes
Visual C++
public ref class BuildingPadType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..BuildingPadType

See Also

BuildingPadType Members


BuildingPadType Members

[image] [image]

Revit 2013 API
BuildingPadType Members
BuildingPadType Class Methods Properties See Also Send Feedback

The BuildingPadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the BuildingPadType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BuildingPadType Class


BuildingPadType Methods

[image] [image]

Revit 2013 API
BuildingPadType Methods
BuildingPadType Class See Also Send Feedback

The BuildingPadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildingPadType Class


BuildingPadType Properties

[image] [image]

Revit 2013 API
BuildingPadType Properties
BuildingPadType Class See Also Send Feedback

The BuildingPadType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the BuildingPadType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

BuildingPadType Class


Parameter Property

[image] [image]

Revit 2013 API
BuildingPadType..::..Parameter Property
BuildingPadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

BuildingPadType Class
BuildingPadType Members


ThermalProperties Property

[image]

Revit 2013 API
BuildingPadType..::..ThermalProperties Property
BuildingPadType Class See Also Send Feedback
The calculated and settable thermal properties of the BuildingPadType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | the building pad does not have thermal properties.

See Also

BuildingPadType Class


BuildingSiteExportOptions Class

[image]

Revit 2013 API
BuildingSiteExportOptions Class
Members See Also Send Feedback
Building Site Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BuildingSiteExportOptions
Visual Basic
Public Class BuildingSiteExportOptions
Visual C++
public ref class BuildingSiteExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuildingSiteExportOptions

See Also

BuildingSiteExportOptions Members


BuildingSiteExportOptions Members

[image] [image]

Revit 2013 API
BuildingSiteExportOptions Members
BuildingSiteExportOptions Class Constructors Methods Properties See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | BuildingSiteExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaPerPerson | Custom value for Area Per Person value.
Public property | PropertyLine | Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | PropertyLineOffset | Property Line Offset. Default is 0.0.
Public property | TotalGrossArea | Custom value for the total area.
Public property | TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Constructor

[image]

Revit 2013 API
BuildingSiteExportOptions Constructor
BuildingSiteExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BuildingSiteExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
BuildingSiteExportOptions()

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Methods

[image] [image]

Revit 2013 API
BuildingSiteExportOptions Methods
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BuildingSiteExportOptions Class


BuildingSiteExportOptions Properties

[image] [image]

Revit 2013 API
BuildingSiteExportOptions Properties
BuildingSiteExportOptions Class See Also Send Feedback

The BuildingSiteExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AreaPerPerson | Custom value for Area Per Person value.
Public property | PropertyLine | Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | PropertyLineOffset | Property Line Offset. Default is 0.0.
Public property | TotalGrossArea | Custom value for the total area.
Public property | TotalOccupancy | Custom value for the total occupancy.

See Also

BuildingSiteExportOptions Class


AreaPerPerson Property

[image]

Revit 2013 API
BuildingSiteExportOptions..::..AreaPerPerson Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for Area Per Person value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AreaPerPerson { get; set; }
Visual Basic
Public Property AreaPerPerson As Double
    Get
    Set
Visual C++
public:
property double AreaPerPerson {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


PropertyLine Property

[image]

Revit 2013 API
BuildingSiteExportOptions..::..PropertyLine Property
BuildingSiteExportOptions Class See Also Send Feedback
Optional property Line to export; it may be nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PropertyLine PropertyLine { get; set; }
Visual Basic
Public Property PropertyLine As PropertyLine
    Get
    Set
Visual C++
public:
property PropertyLine^ PropertyLine {
    PropertyLine^ get ();
    void set (PropertyLine^ value);
}

See Also

BuildingSiteExportOptions Class


PropertyLineOffset Property

[image]

Revit 2013 API
BuildingSiteExportOptions..::..PropertyLineOffset Property
BuildingSiteExportOptions Class See Also Send Feedback
Property Line Offset. Default is 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double PropertyLineOffset { get; set; }
Visual Basic
Public Property PropertyLineOffset As Double
    Get
    Set
Visual C++
public:
property double PropertyLineOffset {
    double get ();
    void set (double value);
}

Remarks

Is only used if property line is also specified.

See Also

BuildingSiteExportOptions Class


TotalGrossArea Property

[image]

Revit 2013 API
BuildingSiteExportOptions..::..TotalGrossArea Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TotalGrossArea { get; set; }
Visual Basic
Public Property TotalGrossArea As Double
    Get
    Set
Visual C++
public:
property double TotalGrossArea {
    double get ();
    void set (double value);
}

Remarks

If specified value > 0.0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


TotalOccupancy Property

[image]

Revit 2013 API
BuildingSiteExportOptions..::..TotalOccupancy Property
BuildingSiteExportOptions Class See Also Send Feedback
Custom value for the total occupancy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int TotalOccupancy { get; set; }
Visual Basic
Public Property TotalOccupancy As Integer
    Get
    Set
Visual C++
public:
property int TotalOccupancy {
    int get ();
    void set (int value);
}

Remarks

If specified value > 0, the value will be used instead of the default value calculated internally.

See Also

BuildingSiteExportOptions Class


BuildingType Enumeration

[image]

Revit 2013 API
BuildingType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BuildingType
Visual Basic
Public Enumeration BuildingType
Visual C++
public enum class BuildingType

Members

Member name | Description
kNoOfBuildingTypes | Building Type is NoOfBuildingTypes.
kAutomotiveFacility | Building Type is AutomotiveFacility.
kConventionCenter | Building Type is ConventionCenter.
kCourthouse | Building Type is Courthouse.
kDiningBarLoungeOrLeisure | Building Type is DiningBarLoungeOrLeisure.
kDiningCafeteriaFastFood | Building Type is DiningCafeteriaFastFood.
kDiningFamily | Building Type is DiningFamily.
kDormitory | Building Type is Dormitory.
kExerciseCenter | Building Type is ExerciseCenter.
kFireStation | Building Type is FireStation.
kGymnasium | Building Type is Gymnasium.
kHospitalOrHealthcare | Building Type is HospitalOrHealthcare.
kHotel | Building Type is Hotel.
kLibrary | Building Type is Library.
kManufacturing | Building Type is Manufacturing.
kMotel | Building Type is Motel.
kMotionPictureTheatre | Building Type is MotionPictureTheatre.
kMultiFamily | Building Type is MultiFamily.
kMuseum | Building Type is Museum.
kOffice | Building Type is Office.
kParkingGarage | Building Type is ParkingGarage.
kPenitentiary | Building Type is Penitentiary.
kPerformingArtsTheater | Building Type is PerformingArtsTheater.
kPoliceStation | Building Type is PoliceStation.
kPostOffice | Building Type is PostOffice.
kReligiousBuilding | Building Type is ReligiousBuilding.
kRetail | Building Type is Retail.
kSchoolOrUniversity | Building Type is SchoolOrUniversity.
kSportsArena | Building Type is SportsArena.
kTownHall | Building Type is TownHall.
kTransportation | Building Type is Transportation.
kWarehouse | Building Type is Warehouse.
kWorkshop | Building Type is Workshop.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also


BuiltInCategory Enumeration

[image]

Revit 2013 API
BuiltInCategory Enumeration
See Also Send Feedback
A list of all the built in categories within Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BuiltInCategory
Visual Basic
Public Enumeration BuiltInCategory
Visual C++
public enum class BuiltInCategory

Members

Member name | Description
OST_StackedWalls_Obsolete_IdInWrongRange |
OST_MassTags_Obsolete_IdInWrongRange |
OST_MassSurface_Obsolete_IdInWrongRange |
OST_MassFloor_Obsolete_IdInWrongRange |
OST_Mass_Obsolete_IdInWrongRange |
OST_WallRefPlanes_Obsolete_IdInWrongRange |
OST_StickSymbols_Obsolete_IdInWrongRange |
OST_RemovedGridSeg_Obsolete_IdInWrongRange |
OST_PointClouds |
OST_AssemblyOrigin_Lines |
OST_AssemblyOrigin_Planes |
OST_AssemblyOrigin_Points |
OST_AssemblyOrigin |
OST_LinksAnalytical |
OST_FoundationSlabAnalyticalTags |
OST_WallFoundationAnalyticalTags |
OST_IsolatedFoundationAnalyticalTags |
OST_WallAnalyticalTags |
OST_FloorAnalyticalTags |
OST_ColumnAnalyticalTags |
OST_BraceAnalyticalTags |
OST_BeamAnalyticalTags |
OST_AnalyticalNodes_Lines |
OST_AnalyticalNodes_Planes |
OST_AnalyticalNodes_Points |
OST_AnalyticalNodes |
OST_RigidLinksAnalytical |
OST_FoundationSlabAnalytical |
OST_WallFoundationAnalytical |
OST_IsolatedFoundationAnalytical |
OST_WallAnalytical |
OST_FloorAnalytical |
OST_ColumnEndSegment |
OST_ColumnStartSegment |
OST_ColumnAnalytical |
OST_BraceEndSegment |
OST_BraceStartSegment |
OST_BraceAnalytical |
OST_BeamEndSegment |
OST_BeamStartSegment |
OST_BeamAnalytical |
OST_CompassSecondaryMonth |
OST_CompassPrimaryMonth |
OST_CompassSectionFilled |
OST_LightLine |
OST_MultiSurface |
OST_SunSurface |
OST_Analemma |
OST_SunsetText |
OST_CompassSection |
OST_CompassOuter |
OST_SunriseText |
OST_CompassInner |
OST_SunPath2 |
OST_SunPath1 |
OST_Sun |
OST_SunStudy |
OST_StructuralTrussStickSymbols |
OST_StructuralTrussHiddenLines |
OST_TrussChord |
OST_TrussWeb |
OST_TrussBottomChordCurve |
OST_TrussTopChordCurve |
OST_TrussVertWebCurve |
OST_TrussDiagWebCurve |
OST_Truss |
OST_RailingSystemTransitionHiddenLines_Deprecated |
OST_RailingSystemTerminationHiddenLines_Deprecated |
OST_RailingSystemRailHiddenLines_Deprecated |
OST_RailingSystemTopRailHiddenLines_Deprecated |
OST_RailingSystemHandRailBracketHiddenLines_Deprecated |
OST_RailingSystemHandRailHiddenLines_Deprecated |
OST_RailingSystemPanelBracketHiddenLines_Deprecated |
OST_RailingSystemPanelHiddenLines_Deprecated |
OST_RailingSystemBalusterHiddenLines_Deprecated |
OST_RailingSystemPostHiddenLines_Deprecated |
OST_RailingSystemSegmentHiddenLines_Deprecated |
OST_RailingSystemHiddenLines_Deprecated |
OST_StairStringer2012HiddenLines_Deprecated |
OST_StairTread2012HiddenLines_Deprecated |
OST_StairLanding2012HiddenLines_Deprecated |
OST_StairRun2012HiddenLines_Deprecated |
OST_Stairs2012HiddenLines_Deprecated |
OST_MassHiddenLines |
OST_CurtaSystemHiddenLines |
OST_OBSOLETE_ElemArrayHiddenLines |
OST_EntourageHiddenLines |
OST_PlantingHiddenLines |
OST_SpecialityEquipmentHiddenLines |
OST_TopographyHiddenLines |
OST_StructuralFramingSystemHiddenLines_Obsolete |
OST_SiteHiddenLines |
OST_RoadsHiddenLines |
OST_ParkingHiddenLines |
OST_PlumbingFixturesHiddenLines |
OST_MechanicalEquipmentHiddenLines |
OST_LightingFixturesHiddenLines |
OST_FurnitureSystemsHiddenLines |
OST_ElectricalFixturesHiddenLines |
OST_ElectricalEquipmentHiddenLines |
OST_CaseworkHiddenLines |
OST_DetailComponentsHiddenLines |
OST_ShaftOpeningHiddenLines |
OST_GenericModelHiddenLines |
OST_CurtainWallMullionsHiddenLines |
OST_CurtainWallPanelsHiddenLines |
OST_RampsHiddenLines |
OST_StairsRailingHiddenLines |
OST_StairsHiddenLines |
OST_ColumnsHiddenLines |
OST_FurnitureHiddenLines |
OST_LinesHiddenLines |
OST_CeilingsHiddenLines |
OST_RoofsHiddenLines |
OST_DoorsHiddenLines |
OST_WindowsHiddenLines |
OST_StructConnectionTags |
OST_StructWeldLines |
OST_StructConnections |
OST_FabricAreaBoundary |
OST_FabricReinSpanSymbol |
OST_FabricReinforcementWire |
OST_FabricReinforcementBoundary |
OST_RebarSetToggle |
OST_FabricAreaTags |
OST_FabricReinforcementTags |
OST_AreaReinTags |
OST_RebarTags |
OST_FabricAreaSketchSheetsLines |
OST_FabricAreaSketchEnvelopeLines |
OST_FabricAreas |
OST_FabricReinforcement |
OST_RebarCover |
OST_CoverType |
OST_RebarShape |
OST_PathReinBoundary |
OST_PathReinTags |
OST_PathReinSpanSymbol |
OST_PathRein |
OST_Cage |
OST_AreaReinXVisibility |
OST_AreaReinBoundary |
OST_AreaReinSpanSymbol |
OST_AreaReinSketchOverride |
OST_AreaRein |
OST_RebarLines |
OST_RebarSketchLines |
OST_Rebar |
OST_AnalyticSpaces |
OST_gbXML_OpeningAir |
OST_gbXML_NonSlidingDoor |
OST_gbXML_SlidingDoor |
OST_gbXML_OperableSkylight |
OST_gbXML_FixedSkylight |
OST_gbXML_OperableWindow |
OST_gbXML_FixedWindow |
OST_gbXML_UndergroundCeiling |
OST_gbXML_UndergroundSlab |
OST_gbXML_UndergroundWall |
OST_gbXML_SurfaceAir |
OST_gbXML_Ceiling |
OST_gbXML_InteriorFloor |
OST_gbXML_InteriorWall |
OST_gbXML_SlabOnGrade |
OST_gbXML_RaisedFloor |
OST_gbXML_Roof |
OST_gbXML_ExteriorWall |
OST_DivisionProfile |
OST_SplitterProfile |
OST_PipeSegments |
OST_GraphicalWarning_OpenConnector |
OST_PlaceHolderPipes |
OST_PlaceHolderDucts |
OST_PipingSystem_Reference_Visibility |
OST_PipingSystem_Reference |
OST_DuctSystem_Reference_Visibility |
OST_DuctSystem_Reference |
OST_PipeInsulationsTags |
OST_DuctLiningsTags |
OST_DuctInsulationsTags |
OST_ElectricalInternalCircuits |
OST_PanelScheduleGraphics |
OST_CableTrayRun |
OST_ConduitRun |
OST_ParamElemElectricalLoadClassification |
OST_DataPanelScheduleTemplates |
OST_SwitchboardScheduleTemplates |
OST_BranchPanelScheduleTemplates |
OST_ConduitStandards |
OST_ElectricalLoadClassifications |
OST_ElectricalDemandFactorDefinitions |
OST_ConduitFittingCenterLine |
OST_CableTrayFittingCenterLine |
OST_ConduitCenterLine |
OST_ConduitDrop |
OST_ConduitRiseDrop |
OST_CableTrayCenterLine |
OST_CableTrayDrop |
OST_CableTrayRiseDrop |
OST_ConduitTags |
OST_Conduit |
OST_CableTrayTags |
OST_CableTray |
OST_ConduitFittingTags |
OST_ConduitFitting |
OST_CableTrayFittingTags |
OST_CableTrayFitting |
OST_DuctLinings |
OST_DuctInsulations |
OST_PipeInsulations |
OST_HVAC_Load_Schedules |
OST_HVAC_Load_Building_Types |
OST_HVAC_Load_Space_Types |
OST_HVAC_Zones_Reference_Visibility |
OST_HVAC_Zones_InteriorFill_Visibility |
OST_HVAC_Zones_ColorFill |
OST_ZoneTags |
OST_LayoutPath_Bases |
OST_WireTemperatureRatings |
OST_WireInsulations |
OST_WireMaterials |
OST_HVAC_Zones_Reference |
OST_HVAC_Zones_InteriorFill |
OST_HVAC_Zones_Boundary |
OST_HVAC_Zones |
OST_Fluids |
OST_PipeSchedules |
OST_PipeMaterials |
OST_PipeConnections |
OST_EAConstructions |
OST_SwitchSystem |
OST_SprinklerTags |
OST_Sprinklers |
OST_RouteCurveBranch |
OST_RouteCurveMain |
OST_RouteCurve |
OST_GbXML_Opening |
OST_GbXML_SType_Underground |
OST_GbXML_SType_Shade |
OST_GbXML_SType_Exterior |
OST_GbXML_SType_Interior |
OST_GbXMLFaces |
OST_WireHomeRunArrows |
OST_LightingDeviceTags |
OST_LightingDevices |
OST_FireAlarmDeviceTags |
OST_FireAlarmDevices |
OST_DataDeviceTags |
OST_DataDevices |
OST_CommunicationDeviceTags |
OST_CommunicationDevices |
OST_SecurityDeviceTags |
OST_SecurityDevices |
OST_NurseCallDeviceTags |
OST_NurseCallDevices |
OST_TelephoneDeviceTags |
OST_TelephoneDevices |
OST_WireTickMarks |
OST_PipeFittingInsulation |
OST_PipeFittingCenterLine |
OST_FlexPipeCurvesInsulation |
OST_PipeCurvesInsulation |
OST_PipeCurvesDrop |
OST_DuctFittingLining |
OST_DuctFittingInsulation |
OST_DuctFittingCenterLine |
OST_FlexDuctCurvesInsulation |
OST_DuctCurvesLining |
OST_DuctCurvesInsulation |
OST_DuctCurvesDrop |
OST_DuctFittingTags |
OST_PipeFittingTags |
OST_PipeColorFills |
OST_PipeColorFillLegends |
OST_WireTags |
OST_PipeAccessoryTags |
OST_PipeAccessory |
OST_PipeCurvesRiseDrop |
OST_FlexPipeCurvesPattern |
OST_FlexPipeCurvesContour |
OST_FlexPipeCurvesCenterLine |
OST_FlexPipeCurves |
OST_PipeFitting |
OST_FlexPipeTags |
OST_PipeTags |
OST_PipeCurvesContour |
OST_PipeCurvesCenterLine |
OST_PipeCurves |
OST_PipingSystem |
OST_ElectricalDemandFactor |
OST_ElecDistributionSys |
OST_ElectricalVoltage |
OST_Wire |
OST_ElectricalCircuitTags |
OST_ElectricalCircuit |
OST_DuctCurvesRiseDrop |
OST_FlexDuctCurvesPattern |
OST_FlexDuctCurvesContour |
OST_FlexDuctCurvesCenterLine |
OST_FlexDuctCurves |
OST_DuctAccessoryTags |
OST_DuctAccessory |
OST_DuctSystem |
OST_DuctTerminalTags |
OST_DuctTerminal |
OST_DuctFitting |
OST_DuctColorFills |
OST_FlexDuctTags |
OST_DuctTags |
OST_DuctCurvesContour |
OST_DuctCurvesCenterLine |
OST_DuctCurves |
OST_DuctColorFillLegends |
OST_ConnectorElemZAxis |
OST_ConnectorElemYAxis |
OST_ConnectorElemXAxis |
OST_ConnectorElem |
OST_DesignOptions |
OST_DesignOptionSets |
OST_StructuralBracePlanReps |
OST_StructConnectionSymbols |
OST_StructuralAnnotations |
OST_RevisionCloudTags |
OST_Revisions |
OST_RevisionClouds |
OST_EditCutProfile |
OST_ElevationMarks |
OST_GridHeads |
OST_LevelHeads |
OST_DecalType |
OST_DecalElement |
OST_VolumeOfInterest |
OST_BoundaryConditions |
OST_InternalAreaLoadTags |
OST_InternalLineLoadTags |
OST_InternalPointLoadTags |
OST_AreaLoadTags |
OST_LineLoadTags |
OST_PointLoadTags |
OST_LoadCasesSeismic |
OST_LoadCasesTemperature |
OST_LoadCasesAccidental |
OST_LoadCasesRoofLive |
OST_LoadCasesSnow |
OST_LoadCasesWind |
OST_LoadCasesLive |
OST_LoadCasesDead |
OST_LoadCases |
OST_InternalAreaLoads |
OST_InternalLineLoads |
OST_InternalPointLoads |
OST_InternalLoads |
OST_AreaLoads |
OST_LineLoads |
OST_PointLoads |
OST_Loads |
OST_BeamSystemTags |
OST_FootingSpanDirectionSymbol |
OST_SpanDirectionSymbol |
OST_SpotSlopesSymbols |
OST_SpotCoordinateSymbols |
OST_SpotElevSymbols |
OST_TrussTags |
OST_KeynoteTags |
OST_DetailComponentTags |
OST_MaterialTags |
OST_FloorTags |
OST_CurtaSystemTags |
OST_HostFinTags |
OST_StairsTags |
OST_MultiCategoryTags |
OST_PlantingTags |
OST_AreaTags |
OST_StructuralFoundationTags |
OST_StructuralColumnTags |
OST_ParkingTags |
OST_SiteTags |
OST_StructuralFramingTags |
OST_SpecialityEquipmentTags |
OST_GenericModelTags |
OST_CurtainWallPanelTags |
OST_WallTags |
OST_PlumbingFixtureTags |
OST_MechanicalEquipmentTags |
OST_LightingFixtureTags |
OST_FurnitureSystemTags |
OST_FurnitureTags |
OST_ElectricalFixtureTags |
OST_ElectricalEquipmentTags |
OST_CeilingTags |
OST_CaseworkTags |
OST_Tags |
OST_MEPSpaceColorFill |
OST_MEPSpaceReference |
OST_MEPSpaceInteriorFill |
OST_MEPSpaceReferenceVisibility |
OST_MEPSpaceInteriorFillVisibility |
OST_MEPSpaces |
OST_StackedWalls |
OST_MassGlazingAll |
OST_MassFloorsAll |
OST_MassWallsAll |
OST_MassExteriorWallUnderground |
OST_MassSlab |
OST_MassShade |
OST_MassOpening |
OST_MassSkylights |
OST_MassWindow |
OST_MassRoof |
OST_MassExteriorWall |
OST_MassInteriorWall |
OST_MassZone |
OST_MassAreaFaceTags |
OST_HostTemplate |
OST_MassFaceSplitter |
OST_MassCutter |
OST_ZoningEnvelope |
OST_MassTags |
OST_MassForm |
OST_MassFloor |
OST_Mass |
OST_DividedSurface_DiscardedDivisionLines |
OST_DividedSurfaceBelt |
OST_TilePatterns |
OST_AlwaysExcludedInAllViews |
OST_DividedSurface_TransparentFace |
OST_DividedSurface_PreDividedSurface |
OST_DividedSurface_PatternFill |
OST_DividedSurface_PatternLines |
OST_DividedSurface_Gridlines |
OST_DividedSurface_Nodes |
OST_DividedSurface |
OST_RepeatingDetailLines |
OST_RampsDownArrow |
OST_RampsUpArrow |
OST_RampsDownText |
OST_RampsUpText |
OST_RampsStringerAboveCut |
OST_RampsStringer |
OST_RampsAboveCut |
OST_RampsIncomplete |
OST_TrussDummy |
OST_ZoneSchemes |
OST_AreaSchemes |
OST_Areas |
OST_ProjectInformation |
OST_Sheets |
OST_ProfileFamilies |
OST_DetailComponents |
OST_RoofSoffit |
OST_EdgeSlab |
OST_Gutter |
OST_Fascia |
OST_Entourage |
OST_Planting |
OST_StructuralStiffenerTags |
OST_StructuralStiffener |
OST_FootingAnalyticalGeometry |
OST_RvtLinks |
OST_Automatic |
OST_SpecialityEquipment |
OST_ColumnAnalyticalRigidLinks |
OST_SecondaryTopographyContours |
OST_TopographyContours |
OST_TopographySurface |
OST_Topography |
OST_StructuralTruss |
OST_StructuralColumnStickSymbols |
OST_HiddenStructuralColumnLines |
OST_AnalyticalRigidLinks |
OST_ColumnAnalyticalGeometry |
OST_FramingAnalyticalGeometry |
OST_StructuralColumns |
OST_HiddenStructuralFramingLines |
OST_KickerBracing |
OST_StructuralFramingSystem |
OST_VerticalBracing |
OST_HorizontalBracing |
OST_Purlin |
OST_Joist |
OST_Girder |
OST_StructuralFramingOther |
OST_StructuralFraming |
OST_HiddenStructuralFoundationLines |
OST_StructuralFoundation |
OST_BasePointAxisZ |
OST_BasePointAxisY |
OST_BasePointAxisX |
OST_SharedBasePoint |
OST_ProjectBasePoint |
OST_SiteRegion |
OST_SitePropertyLineSegmentTags |
OST_SitePropertyLineSegment |
OST_SitePropertyTags |
OST_SitePointBoundary |
OST_SiteProperty |
OST_BuildingPad |
OST_SitePoint |
OST_SiteSurface |
OST_Site |
OST_HiddenBuildingUnitLines |
OST_BuildingUnits |
OST_Sewer |
OST_Roads |
OST_Property |
OST_Parking |
OST_PlumbingFixtures |
OST_MechanicalEquipment |
OST_LightingFixtureSource |
OST_LightingFixtures |
OST_FurnitureSystems |
OST_ElectricalFixtures |
OST_ElectricalEquipment |
OST_Casework |
OST_ArcWallRectOpening |
OST_DormerOpeningIncomplete |
OST_SWallRectOpening |
OST_ShaftOpening |
OST_StructuralFramingOpening |
OST_ColumnOpening |
OST_RailingRailPathExtensionLines |
OST_RailingRailPathLines |
OST_StairsSupports |
OST_RailingHandRailAboveCut |
OST_RailingTopRailAboveCut |
OST_RailingTermination |
OST_RailingSupport |
OST_RailingHandRail |
OST_RailingTopRail |
OST_StairsSketchPathLines |
OST_StairsTriserNumbers |
OST_StairsTriserTags |
OST_StairsSupportTags |
OST_StairsLandingTags |
OST_StairsRunTags |
OST_StairsPathsAboveCut |
OST_StairsPaths |
OST_StairsRiserLinesAboveCut |
OST_StairsRiserLines |
OST_StairsOutlinesAboveCut |
OST_StairsOutlines |
OST_StairsNosingLinesAboveCut |
OST_StairsNosingLines |
OST_StairsCutMarksAboveCut |
OST_StairsCutMarks |
OST_ComponentRepeaterSlot |
OST_ComponentRepeater |
OST_DividedPath |
OST_IOSRoomCalculationPoint |
OST_PropertySet |
OST_AppearanceAsset |
OST_StairStringer2012_Deprecated |
OST_StairsTrisers |
OST_StairsLandings |
OST_StairsRuns |
OST_Stair2012_Deprecated |
OST_RailingSystemTags |
OST_RailingSystemTransition |
OST_RailingSystemTermination |
OST_RailingSystemRail |
OST_RailingSystemTopRail |
OST_RailingSystemHandRailBracket |
OST_RailingSystemHandRail |
OST_RailingSystemHardware |
OST_RailingSystemPanel |
OST_RailingSystemBaluster |
OST_RailingSystemPost |
OST_RailingSystemSegment |
OST_RailingSystem |
OST_AdaptivePoints_HiddenLines |
OST_AdaptivePoints_Lines |
OST_AdaptivePoints_Planes |
OST_AdaptivePoints_Points |
OST_AdaptivePoints |
OST_CeilingOpening |
OST_FloorOpening |
OST_RoofOpening |
OST_WallRefPlanes |
OST_DimLockControlLeader |
OST_MEPSpaceSeparationLines |
OST_AreaPolylines |
OST_RoomPolylines |
OST_InstanceDrivenLineStyle |
OST_RemovedGridSeg |
OST_IOSOpening |
OST_IOSTilePatternGrid |
OST_ControlLocal |
OST_ControlAxisZ |
OST_ControlAxisY |
OST_ControlAxisX |
OST_XRayConstrainedProfileEdge |
OST_XRayImplicitPathCurve |
OST_XRayPathPoint |
OST_XRayPathCurve |
OST_XRaySideEdge |
OST_XRayProfileEdge |
OST_ReferencePoints_HiddenLines |
OST_ReferencePoints_Lines |
OST_ReferencePoints_Planes |
OST_ReferencePoints_Points |
OST_ReferencePoints |
OST_Materials |
OST_CeilingsCutPattern |
OST_CeilingsDefault |
OST_CeilingsFinish2 |
OST_CeilingsFinish1 |
OST_CeilingsSubstrate |
OST_CeilingsInsulation |
OST_CeilingsStructure |
OST_CeilingsMembrane |
OST_FloorsInteriorEdges |
OST_FloorsCutPattern |
OST_HiddenFloorLines |
OST_FloorsDefault |
OST_FloorsFinish2 |
OST_FloorsFinish1 |
OST_FloorsSubstrate |
OST_FloorsInsulation |
OST_FloorsStructure |
OST_FloorsMembrane |
OST_RoofsInteriorEdges |
OST_RoofsCutPattern |
OST_RoofsDefault |
OST_RoofsFinish2 |
OST_RoofsFinish1 |
OST_RoofsSubstrate |
OST_RoofsInsulation |
OST_RoofsStructure |
OST_RoofsMembrane |
OST_WallsCutPattern |
OST_HiddenWallLines |
OST_WallsDefault |
OST_WallsFinish2 |
OST_WallsFinish1 |
OST_WallsSubstrate |
OST_WallsInsulation |
OST_WallsStructure |
OST_WallsMembrane |
OST_PreviewLegendComponents |
OST_LegendComponents |
OST_ScheduleGraphics |
OST_RasterImages |
OST_ColorFillSchema |
OST_RoomColorFill |
OST_ColorFillLegends |
OST_AnnotationCropSpecial |
OST_CropBoundarySpecial |
OST_AnnotationCrop |
OST_FloorsAnalyticalGeometry |
OST_WallsAnalyticalGeometry |
OST_CalloutLeaderLine |
OST_CeilingsSurfacePattern |
OST_RoofsSurfacePattern |
OST_FloorsSurfacePattern |
OST_WallsSurfacePattern |
OST_CalloutBoundary |
OST_CalloutHeads |
OST_Callouts |
OST_CropBoundary |
OST_Elev |
OST_AxisZ |
OST_AxisY |
OST_AxisX |
OST_CLines |
OST_Lights |
OST_ViewportLabel |
OST_Viewports |
OST_Camera_Lines |
OST_Cameras |
OST_MEPSpaceTags |
OST_RoomTags |
OST_DoorTags |
OST_WindowTags |
OST_SectionHeadWideLines |
OST_SectionHeadMediumLines |
OST_SectionHeadThinLines |
OST_SectionHeads |
OST_ContourLabels |
OST_CurtaSystemFaceManager |
OST_CurtaSystem |
OST_AreaReport_Arc_Minus |
OST_AreaReport_Arc_Plus |
OST_AreaReport_Boundary |
OST_AreaReport_Triangle |
OST_CurtainGridsCurtaSystem |
OST_CurtainGridsSystem |
OST_CurtainGridsWall |
OST_CurtainGridsRoof |
OST_DetailArray |
OST_ModelArray |
OST_HostFinHF |
OST_HostFinWall |
OST_HostFinCeiling |
OST_HostFinRoof |
OST_HostFinFloor |
OST_HostFin |
OST_AnalysisDisplayStyle |
OST_AnalysisResults |
OST_RenderRegions |
OST_SectionBox |
OST_TextNotes |
OST_Divisions |
OST_Catalogs |
OST_DirectionEdgeLines |
OST_CenterLines |
OST_LinesBeyond |
OST_HiddenLines |
OST_DemolishedLines |
OST_OverheadLines |
OST_TitleBlockWideLines |
OST_TitleBlockMediumLines |
OST_TitleBlockThinLines |
OST_TitleBlocks |
OST_Views |
OST_Viewers |
OST_PartHiddenLines |
OST_PartTags |
OST_Parts |
OST_AssemblyTags |
OST_Assemblies |
OST_RoofTags |
OST_SpotSlopes |
OST_SpotCoordinates |
OST_SpotElevations |
OST_Constraints |
OST_WeakDims |
OST_Dimensions |
OST_DatumLevels |
OST_Levels |
OST_GridChains |
OST_Grids |
OST_BrokenSectionLine |
OST_SectionLine |
OST_Sections |
OST_ReferenceViewer |
OST_ReferenceViewerSymbol |
OST_ImportObjectStyles |
OST_ModelText |
OST_MaskingRegion |
OST_Matchline |
OST_FaceSplitter |
OST_PlanRegion |
OST_FilledRegion |
OST_MassingProjectionOutlines |
OST_MassingCutOutlines |
OST_Massing |
OST_Reveals |
OST_Cornices |
OST_Ramps |
OST_RailingBalusterRailCut |
OST_RailingBalusterRail |
OST_Railings |
OST_CurtainGrids |
OST_CurtainWallMullionsCut |
OST_CurtainWallMullions |
OST_CurtainWallPanels |
OST_AreaReference |
OST_AreaInteriorFill |
OST_RoomReference |
OST_RoomInteriorFill |
OST_AreaColorFill |
OST_AreaReferenceVisibility |
OST_AreaInteriorFillVisibility |
OST_RoomReferenceVisibility |
OST_RoomInteriorFillVisibility |
OST_Rooms |
OST_GenericModel |
OST_GenericAnnotation |
OST_Fixtures |
OST_StairsRailingTags |
OST_StairsRailingAboveCut |
OST_StairsDownArrows |
OST_StairsUpArrows |
OST_StairsDownText |
OST_StairsRailingRail |
OST_StairsRailingBaluster |
OST_StairsRailing |
OST_StairsUpText |
OST_StairsSupportsAboveCut |
OST_StairsStringerCarriage |
OST_StairsAboveCut_ToBeDeprecated |
OST_StairsIncomplete_Deprecated |
OST_Stairs |
OST_IOSNavWheelPivotBall |
OST_IOSRoomComputationHeight |
OST_IOSRoomUpperLowerLines |
OST_IOSDragBoxInverted |
OST_IOSDragBox |
OST_Phases |
OST_IOS_GeoSite |
OST_IOS_GeoLocations |
OST_IOSFabricReinSpanSymbolCtrl |
OST_GuideGrid |
OST_EPS_Future |
OST_EPS_Temporary |
OST_EPS_New |
OST_EPS_Demolished |
OST_EPS_Existing |
OST_IOSMeasureLineScreenSize |
OST_Columns |
OST_IOSRebarSystemSpanSymbolCtrl |
OST_IOSRoomTagToRoomLines |
OST_IOSAttachedDetailGroups |
OST_IOSDetailGroups |
OST_IOSModelGroups |
OST_IOSSuspendedSketch |
OST_IOSWallCoreBoundary |
OST_IOSMeasureLine |
OST_IOSArrays |
OST_Curtain_Systems |
OST_IOSBBoxScreenSize |
OST_IOSSlabShapeEditorPointInterior |
OST_IOSSlabShapeEditorPointBoundary |
OST_IOSSlabShapeEditorBoundary |
OST_IOSSlabShapeEditorAutoCrease |
OST_IOSSlabShapeEditorExplitCrease |
OST_ReferenceLines |
OST_IOSNotSilhouette |
OST_FillPatterns |
OST_Furniture |
OST_AreaSchemeLines |
OST_GenericLines |
OST_InsulationLines |
OST_CloudLines |
OST_IOSRoomPerimeterLines |
OST_IOSCuttingGeometry |
OST_IOSCrashGraphics |
OST_IOSGroups |
OST_IOSGhost |
OST_StairsSketchLandingCenterLines |
OST_StairsSketchRunLines |
OST_StairsSketchRiserLines |
OST_StairsSketchBoundaryLines |
OST_AreaSeparationLines |
OST_AxisOfRotation |
OST_InvisibleLines |
OST_IOSThinPixel_DashDot |
OST_IOSThinPixel_Dash |
OST_IOSThinPixel_Dot |
OST_Extrusions |
OST_IOS |
OST_CutOutlines |
OST_IOSThinPixel |
OST_IOSFlipControl |
OST_IOSSketchGrid |
OST_IOSSuspendedSketch_obsolete |
OST_IOSFreeSnapLine |
OST_IOSDatumPlane |
OST_Lines |
OST_IOSConstructionLine |
OST_IOSAlignmentGraphics |
OST_IOSAligningLine |
OST_IOSBackedUpElements |
OST_IOSRegeneratedElements |
OST_SketchLines |
OST_CurvesWideLines |
OST_CurvesMediumLines |
OST_CurvesThinLines |
OST_Curves |
OST_CeilingsProjection |
OST_CeilingsCut |
OST_Ceilings |
OST_RoofsProjection |
OST_RoofsCut |
OST_Roofs |
OST_FloorsProjection |
OST_FloorsCut |
OST_Floors |
OST_DoorsGlassProjection |
OST_DoorsGlassCut |
OST_DoorsFrameMullionProjection |
OST_DoorsFrameMullionCut |
OST_DoorsOpeningProjection |
OST_DoorsOpeningCut |
OST_DoorsPanelProjection |
OST_DoorsPanelCut |
OST_Doors |
OST_WindowsOpeningProjection |
OST_WindowsOpeningCut |
OST_WindowsSillHeadProjection |
OST_WindowsSillHeadCut |
OST_WindowsFrameMullionProjection |
OST_WindowsFrameMullionCut |
OST_WindowsGlassProjection |
OST_WindowsGlassCut |
OST_Windows |
OST_WallsProjectionOutlines |
OST_WallsCutOutlines |
OST_Walls |
OST_IOSRegenerationFailure |
OST_MatchSiteComponent |
OST_MatchProfile |
OST_MatchDetail |
OST_MatchAnnotation |
OST_MatchModel |
OST_MatchAll |
INVALID |

See Also


BuiltInFailures Class

[image]

Revit 2013 API
BuiltInFailures Class
See Also Send Feedback
Provides a container of all Revit built-in FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class BuiltInFailures
Visual Basic
Public NotInheritable Class BuiltInFailures
Visual C++
public ref class BuiltInFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures

See Also


BuiltInFailures.AnalyticalModelFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AnalyticalModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class AnalyticalModelFailures
Visual Basic
Public NotInheritable Class AnalyticalModelFailures
Visual C++
public ref class AnalyticalModelFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AnalyticalModelFailures

See Also

BuiltInFailures..::..AnalyticalModelFailures Members


BuiltInFailures.AnalyticalModelFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures Members
BuiltInFailures..::..AnalyticalModelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AdjustCurveTooShort | AdjustCurve is too short.
AdjustEdgeTooShort | AdjustEdge is too short.
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalLinkNotConnected | Analytical Link has lost one or more references.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
BoundaryLinesIntersect | Boundary lines intersect.
CannotCreateAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Cannot construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
ProjectionPlaneInvalidWall | Projection plane becomes invalid for this wall.
ProjectionPlanesNotIntersect | Can't project Analytical Model. Planes do not intersect each other.
ProjectionPlanesParallel | Can't project Analytical Model. Two or more projection planes are parallel.
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


BuiltInFailures.AnalyticalModelFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures Properties
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback

The BuiltInFailures..::..AnalyticalModelFailures type exposes the following members.

Properties

Name | Description
AdjustCurveTooShort | AdjustCurve is too short.
AdjustEdgeTooShort | AdjustEdge is too short.
AnalyticalBeamSlabWarning | Beam and Slab Analytical Models do not have the same Analytical Projection Plane.
AnalyticalDiscrepancyWarning | Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]
AnalyticalGapWarning | Detected physical connection between Structural Elements, but did not detect Analytical intersection.
AnalyticalLinkNotConnected | Analytical Link has lost one or more references.
AnalyticalMemberInstability | Possible Member Instability, based on Release Conditions
AnalyticalModelInstability | Possible Model Instability
AnalyticalPhysicalCheckDone | Analytical / Physical Model Consistency check is complete.
AnalyticalSupportCycleWarning | Circular support chain detected
AnalyticalTopBottomPlanesReversed | Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.
AutoDetectIgnoreLeaderWarning | Analytical Model for Structural Element has reset to its default location.
BoundaryLinesIntersect | Boundary lines intersect.
CannotCreateAnalyticalGeometry | Cannot construct Analytical Geometry.
CannotKeepAnalyticalAdjustment | Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.
CannotMakeAnalyticalGeometry | Cannot construct Analytical Geometry.
LoadsMayBeNotUpToDate | Some of reactions may be not up-to-date
ProjectionPlaneInvalidWall | Projection plane becomes invalid for this wall.
ProjectionPlanesNotIntersect | Can't project Analytical Model. Planes do not intersect each other.
ProjectionPlanesParallel | Can't project Analytical Model. Two or more projection planes are parallel.
StructAnalyticalErrorProjection | Can't project Analytical Model to Analytical Projection Surface
StructuralElementMayNotBeSupported | Structural Element may not be supported -- verify support for Element.
StructWallAnalyticalErrorAlign | Can't align Analytical Model with joined Walls.
StructWallAnalyticalErrorConversion | Can't convert Edges to Analytical Model curves.
SupportCheckDone | Member support check is complete. No unsupported elements detected.

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AdjustCurveTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AdjustCurveTooShort Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
AdjustCurve is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AdjustCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AdjustCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AdjustEdgeTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AdjustEdgeTooShort Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
AdjustEdge is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AdjustEdgeTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AdjustEdgeTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustEdgeTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalBeamSlabWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalBeamSlabWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Beam and Slab Analytical Models do not have the same Analytical Projection Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalBeamSlabWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalBeamSlabWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalBeamSlabWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalDiscrepancyWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalDiscrepancyWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Distance between Analytical and Physical Models of Structural Element is beyond tolerance of [Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalDiscrepancyWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalDiscrepancyWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalDiscrepancyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalGapWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalGapWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Detected physical connection between Structural Elements, but did not detect Analytical intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalGapWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalGapWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalGapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalLinkNotConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalLinkNotConnected Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Link has lost one or more references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalLinkNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalLinkNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalLinkNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalMemberInstability Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalMemberInstability Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Possible Member Instability, based on Release Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalMemberInstability { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalMemberInstability As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalMemberInstability {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalModelInstability Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalModelInstability Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Possible Model Instability

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalModelInstability { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalModelInstability As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalModelInstability {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalPhysicalCheckDone Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalPhysicalCheckDone Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical / Physical Model Consistency check is complete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalPhysicalCheckDone { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalPhysicalCheckDone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalPhysicalCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalSupportCycleWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalSupportCycleWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Circular support chain detected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalSupportCycleWarning { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalSupportCycleWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalSupportCycleWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AnalyticalTopBottomPlanesReversed Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AnalyticalTopBottomPlanesReversed Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Top Projection Plane is partially or completely below Analytical Bottom Projection Plane. Please reset top and/or bottom planes to valid values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AnalyticalTopBottomPlanesReversed { get; }
Visual Basic
Public Shared ReadOnly Property AnalyticalTopBottomPlanesReversed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AnalyticalTopBottomPlanesReversed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


AutoDetectIgnoreLeaderWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..AutoDetectIgnoreLeaderWarning Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical Model for Structural Element has reset to its default location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AutoDetectIgnoreLeaderWarning { get; }
Visual Basic
Public Shared ReadOnly Property AutoDetectIgnoreLeaderWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutoDetectIgnoreLeaderWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


BoundaryLinesIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..BoundaryLinesIntersect Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Boundary lines intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BoundaryLinesIntersect { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryLinesIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BoundaryLinesIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotCreateAnalyticalGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotCreateAnalyticalGeometry Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateAnalyticalGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateAnalyticalGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateAnalyticalGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotKeepAnalyticalAdjustment Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotKeepAnalyticalAdjustment Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Analytical model Adjustment distance exceeds current Adjustment Snapping Distance. To adjust snap settings, go to the Structural Settings Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepAnalyticalAdjustment { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepAnalyticalAdjustment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepAnalyticalAdjustment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


CannotMakeAnalyticalGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..CannotMakeAnalyticalGeometry Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Cannot construct Analytical Geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeAnalyticalGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeAnalyticalGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeAnalyticalGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


LoadsMayBeNotUpToDate Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..LoadsMayBeNotUpToDate Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Some of reactions may be not up-to-date

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoadsMayBeNotUpToDate { get; }
Visual Basic
Public Shared ReadOnly Property LoadsMayBeNotUpToDate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoadsMayBeNotUpToDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ProjectionPlaneInvalidWall Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..ProjectionPlaneInvalidWall Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Projection plane becomes invalid for this wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProjectionPlaneInvalidWall { get; }
Visual Basic
Public Shared ReadOnly Property ProjectionPlaneInvalidWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProjectionPlaneInvalidWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ProjectionPlanesNotIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..ProjectionPlanesNotIntersect Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model. Planes do not intersect each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProjectionPlanesNotIntersect { get; }
Visual Basic
Public Shared ReadOnly Property ProjectionPlanesNotIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProjectionPlanesNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


ProjectionPlanesParallel Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..ProjectionPlanesParallel Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model. Two or more projection planes are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProjectionPlanesParallel { get; }
Visual Basic
Public Shared ReadOnly Property ProjectionPlanesParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProjectionPlanesParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructAnalyticalErrorProjection Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructAnalyticalErrorProjection Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't project Analytical Model to Analytical Projection Surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructAnalyticalErrorProjection { get; }
Visual Basic
Public Shared ReadOnly Property StructAnalyticalErrorProjection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructAnalyticalErrorProjection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructuralElementMayNotBeSupported Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructuralElementMayNotBeSupported Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Structural Element may not be supported -- verify support for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructuralElementMayNotBeSupported { get; }
Visual Basic
Public Shared ReadOnly Property StructuralElementMayNotBeSupported As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralElementMayNotBeSupported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructWallAnalyticalErrorAlign Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructWallAnalyticalErrorAlign Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't align Analytical Model with joined Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructWallAnalyticalErrorAlign { get; }
Visual Basic
Public Shared ReadOnly Property StructWallAnalyticalErrorAlign As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorAlign {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


StructWallAnalyticalErrorConversion Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..StructWallAnalyticalErrorConversion Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Can't convert Edges to Analytical Model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructWallAnalyticalErrorConversion { get; }
Visual Basic
Public Shared ReadOnly Property StructWallAnalyticalErrorConversion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructWallAnalyticalErrorConversion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


SupportCheckDone Property

[image]

Revit 2013 API
BuiltInFailures..::..AnalyticalModelFailures..::..SupportCheckDone Property
BuiltInFailures..::..AnalyticalModelFailures Class See Also Send Feedback
Member support check is complete. No unsupported elements detected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SupportCheckDone { get; }
Visual Basic
Public Shared ReadOnly Property SupportCheckDone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SupportCheckDone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AnalyticalModelFailures Class


BuiltInFailures.ArrayFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ArrayFailures
Visual Basic
Public NotInheritable Class ArrayFailures
Visual C++
public ref class ArrayFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ArrayFailures

See Also

BuiltInFailures..::..ArrayFailures Members


BuiltInFailures.ArrayFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures Members
BuiltInFailures..::..ArrayFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
InvalidPath3dIsAssignedToArray | Invalid Path3d is assigned to the Array.
OnlyGroupsAndInstancesShouldBePlaced | Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::..ArrayFailures Class


BuiltInFailures.ArrayFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures Properties
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback

The BuiltInFailures..::..ArrayFailures type exposes the following members.

Properties

Name | Description
ArrayingNotSupportedForElements | Arraying is not currently supported for the selected elements.
ArrayMixedModAndViewSpecElemsCorruption | Unable to array this mixture of modeling and view specific elements.
ArrayMixedModAndViewSpecElemsWarning | You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.
CannotCreateArraySelectionIsGrouped | Can't create an array because the selection cannot be grouped.
ConstraintsNotSatisfied | Constraints are not satisfied
CouldntFindNewHostsForElements | Couldn't find new hosts for elements in array.
IdenticalGeometryCopiesInArray | This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.
InvalidPath3dIsAssignedToArray | Invalid Path3d is assigned to the Array.
OnlyGroupsAndInstancesShouldBePlaced | Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.
RadiusTooSmall | Radius is too small.

See Also

BuiltInFailures..::..ArrayFailures Class


ArrayingNotSupportedForElements Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..ArrayingNotSupportedForElements Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Arraying is not currently supported for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayingNotSupportedForElements { get; }
Visual Basic
Public Shared ReadOnly Property ArrayingNotSupportedForElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArrayingNotSupportedForElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


ArrayMixedModAndViewSpecElemsCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..ArrayMixedModAndViewSpecElemsCorruption Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Unable to array this mixture of modeling and view specific elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsCorruption { get; }
Visual Basic
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


ArrayMixedModAndViewSpecElemsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..ArrayMixedModAndViewSpecElemsWarning Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
You have selected a mixture of modeling and view specific elements to array in an associative manner. Only the model elements will remain grouped and associative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArrayMixedModAndViewSpecElemsWarning { get; }
Visual Basic
Public Shared ReadOnly Property ArrayMixedModAndViewSpecElemsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArrayMixedModAndViewSpecElemsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


CannotCreateArraySelectionIsGrouped Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..CannotCreateArraySelectionIsGrouped Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Can't create an array because the selection cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateArraySelectionIsGrouped { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateArraySelectionIsGrouped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateArraySelectionIsGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


ConstraintsNotSatisfied Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..ConstraintsNotSatisfied Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConstraintsNotSatisfied { get; }
Visual Basic
Public Shared ReadOnly Property ConstraintsNotSatisfied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstraintsNotSatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


CouldntFindNewHostsForElements Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..CouldntFindNewHostsForElements Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Couldn't find new hosts for elements in array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldntFindNewHostsForElements { get; }
Visual Basic
Public Shared ReadOnly Property CouldntFindNewHostsForElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldntFindNewHostsForElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


IdenticalGeometryCopiesInArray Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..IdenticalGeometryCopiesInArray Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
This array contains multiple copies of some identical geometry. Performance might be improved by using a nested family and arraying copies of its instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IdenticalGeometryCopiesInArray { get; }
Visual Basic
Public Shared ReadOnly Property IdenticalGeometryCopiesInArray As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IdenticalGeometryCopiesInArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


InvalidPath3dIsAssignedToArray Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..InvalidPath3dIsAssignedToArray Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Invalid Path3d is assigned to the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPath3dIsAssignedToArray { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPath3dIsAssignedToArray As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPath3dIsAssignedToArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


OnlyGroupsAndInstancesShouldBePlaced Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..OnlyGroupsAndInstancesShouldBePlaced Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Only Groups and certain Instances should be placed with Arrays. The Arrays will not place anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyGroupsAndInstancesShouldBePlaced { get; }
Visual Basic
Public Shared ReadOnly Property OnlyGroupsAndInstancesShouldBePlaced As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyGroupsAndInstancesShouldBePlaced {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


RadiusTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..ArrayFailures..::..RadiusTooSmall Property
BuiltInFailures..::..ArrayFailures Class See Also Send Feedback
Radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RadiusTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RadiusTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ArrayFailures Class


BuiltInFailures.AssemblyFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class AssemblyFailures
Visual Basic
Public NotInheritable Class AssemblyFailures
Visual C++
public ref class AssemblyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AssemblyFailures

See Also

BuiltInFailures..::..AssemblyFailures Members


BuiltInFailures.AssemblyFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures Members
BuiltInFailures..::..AssemblyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..AssemblyFailures type exposes the following members.

Properties

Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
NoValidElementsSelected | No valid elements selected in the assembly edit mode.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

See Also

BuiltInFailures..::..AssemblyFailures Class


BuiltInFailures.AssemblyFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures Properties
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback

The BuiltInFailures..::..AssemblyFailures type exposes the following members.

Properties

Name | Description
AddedElementsNotSamePhaseAsAssembly | Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.
AssemblyDeleteTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyDidNotMatchRequestedTypeWarn | Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.
AssemblyDisassembleInstanceWarn | Edits to these assemblies changed the naming category and name of these assemblies.
AssemblyInheritTypeWarn | Edits to these assemblies do not match existing types, new type will be created.
AssemblyInvalidMember | Some elements became ineligible to be included in an assembly and were removed.
AssemblyNewTypeWarn | Edits to these assemblies match existing type and will inherit that name.
AssemblyRenameTypeWarn | Edits to these assemblies changed the naming category and name of these assemblies.
CouldNotAcquireAssemblyViews | The assembly instance could not acquire the assembly views.
CouldNotChangeTypeOfAssembly | Assembly cannot be changed to selected type.
DeleteAssemblyInstWithViewsWarn | Deleting this assembly will remove the assembly from the project and any views associated with that assembly.
DeleteShopDrawingsWarn | The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!
ElementsNotAllowedAreNotAddedToAssembly | Elements not allowed in Assembly were not added to it, but only in the document
IneligibleElementsInAssembly | Ineligible elements in assembly.
MixedPhasesInAssembly | Assembly cannot be created. All elements must have the same phases to be included in an assembly.
NoElementsAddedtoNewAssembly | No elements were added to the assembly. No assembly will be created.
NoElementsLeftInExistingAssembly | There are no elements left in the assembly. It will be disassembled.
NoEligibleElementsInAssembly | No eligible elements in assembly.
NoValidElementsSelected | No valid elements selected in the assembly edit mode.
SomeElementsPreventAssemblyTypeChange | Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

See Also

BuiltInFailures..::..AssemblyFailures Class


AddedElementsNotSamePhaseAsAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AddedElementsNotSamePhaseAsAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Selected Element(s) cannot be added to the assembly. Elements must have the same phases as the assembly to be included in the assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AddedElementsNotSamePhaseAsAssembly { get; }
Visual Basic
Public Shared ReadOnly Property AddedElementsNotSamePhaseAsAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddedElementsNotSamePhaseAsAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDeleteTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDeleteTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyDeleteTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDeleteTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDeleteTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDidNotMatchRequestedTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDidNotMatchRequestedTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly was changed to a new type, but did not match the type. Geometry could have been changed due to a join condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyDidNotMatchRequestedTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDidNotMatchRequestedTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDidNotMatchRequestedTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyDisassembleInstanceWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyDisassembleInstanceWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyDisassembleInstanceWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyDisassembleInstanceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyDisassembleInstanceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyInheritTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyInheritTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies do not match existing types, new type will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyInheritTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyInheritTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyInheritTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyInvalidMember Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyInvalidMember Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Some elements became ineligible to be included in an assembly and were removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyInvalidMember { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyInvalidMember As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyInvalidMember {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyNewTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyNewTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies match existing type and will inherit that name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyNewTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyNewTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyNewTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


AssemblyRenameTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..AssemblyRenameTypeWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Edits to these assemblies changed the naming category and name of these assemblies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssemblyRenameTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property AssemblyRenameTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssemblyRenameTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


CouldNotAcquireAssemblyViews Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..CouldNotAcquireAssemblyViews Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
The assembly instance could not acquire the assembly views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotAcquireAssemblyViews { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotAcquireAssemblyViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotAcquireAssemblyViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


CouldNotChangeTypeOfAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..CouldNotChangeTypeOfAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly cannot be changed to selected type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotChangeTypeOfAssembly { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotChangeTypeOfAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotChangeTypeOfAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


DeleteAssemblyInstWithViewsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..DeleteAssemblyInstWithViewsWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Deleting this assembly will remove the assembly from the project and any views associated with that assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteAssemblyInstWithViewsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteAssemblyInstWithViewsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteAssemblyInstWithViewsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


DeleteShopDrawingsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..DeleteShopDrawingsWarn Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
The assembly instance has associated views and cannot be merged with assembly type '%1!s!'. Delete the views to continue.\n\nViews:%2!s!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteShopDrawingsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteShopDrawingsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteShopDrawingsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


ElementsNotAllowedAreNotAddedToAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..ElementsNotAllowedAreNotAddedToAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Elements not allowed in Assembly were not added to it, but only in the document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNotAllowedAreNotAddedToAssembly { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNotAllowedAreNotAddedToAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNotAllowedAreNotAddedToAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


IneligibleElementsInAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..IneligibleElementsInAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Ineligible elements in assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IneligibleElementsInAssembly { get; }
Visual Basic
Public Shared ReadOnly Property IneligibleElementsInAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IneligibleElementsInAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


MixedPhasesInAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..MixedPhasesInAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly cannot be created. All elements must have the same phases to be included in an assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MixedPhasesInAssembly { get; }
Visual Basic
Public Shared ReadOnly Property MixedPhasesInAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MixedPhasesInAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


NoElementsAddedtoNewAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..NoElementsAddedtoNewAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
No elements were added to the assembly. No assembly will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoElementsAddedtoNewAssembly { get; }
Visual Basic
Public Shared ReadOnly Property NoElementsAddedtoNewAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoElementsAddedtoNewAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


NoElementsLeftInExistingAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..NoElementsLeftInExistingAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
There are no elements left in the assembly. It will be disassembled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoElementsLeftInExistingAssembly { get; }
Visual Basic
Public Shared ReadOnly Property NoElementsLeftInExistingAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoElementsLeftInExistingAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


NoEligibleElementsInAssembly Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..NoEligibleElementsInAssembly Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
No eligible elements in assembly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoEligibleElementsInAssembly { get; }
Visual Basic
Public Shared ReadOnly Property NoEligibleElementsInAssembly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoEligibleElementsInAssembly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


NoValidElementsSelected Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..NoValidElementsSelected Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
No valid elements selected in the assembly edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoValidElementsSelected { get; }
Visual Basic
Public Shared ReadOnly Property NoValidElementsSelected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoValidElementsSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


SomeElementsPreventAssemblyTypeChange Property

[image]

Revit 2013 API
BuiltInFailures..::..AssemblyFailures..::..SomeElementsPreventAssemblyTypeChange Property
BuiltInFailures..::..AssemblyFailures Class See Also Send Feedback
Assembly cannot be changed to selected type. Some elements in the target assembly prevent the type change from occurring. These tend to be parts and nested elements such as mullion, curtain panels, and members of trusses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeElementsPreventAssemblyTypeChange { get; }
Visual Basic
Public Shared ReadOnly Property SomeElementsPreventAssemblyTypeChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeElementsPreventAssemblyTypeChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AssemblyFailures Class


BuiltInFailures.AutoJoinFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoJoin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class AutoJoinFailures
Visual Basic
Public NotInheritable Class AutoJoinFailures
Visual C++
public ref class AutoJoinFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AutoJoinFailures

See Also

BuiltInFailures..::..AutoJoinFailures Members


BuiltInFailures.AutoJoinFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures Members
BuiltInFailures..::..AutoJoinFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..AutoJoinFailures type exposes the following members.

Properties

Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.

See Also

BuiltInFailures..::..AutoJoinFailures Class


BuiltInFailures.AutoJoinFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures Properties
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback

The BuiltInFailures..::..AutoJoinFailures type exposes the following members.

Properties

Name | Description
DesignOptionAndWorksetViolation | Can't make the expected join because of editability and design option restrictions.
DesignOptionCannotReference | Design Option ' [Name] ' cannot reference Design Option ' [Name] '.
OtherNonEditJoinFailure | Two elements were not automatically joined because other elements at join are not editable.
UnexpectedJoinFailure | Join failure caused by editability or design option related problem.
Unknown | Unknown
WorksetJoinWarn | Two elements were not automatically joined because one or both is not editable.

See Also

BuiltInFailures..::..AutoJoinFailures Class


DesignOptionAndWorksetViolation Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..DesignOptionAndWorksetViolation Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Can't make the expected join because of editability and design option restrictions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionAndWorksetViolation { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionAndWorksetViolation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionAndWorksetViolation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


DesignOptionCannotReference Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..DesignOptionCannotReference Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Design Option ' [Name] ' cannot reference Design Option ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionCannotReference { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionCannotReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionCannotReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


OtherNonEditJoinFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..OtherNonEditJoinFailure Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because other elements at join are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OtherNonEditJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property OtherNonEditJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OtherNonEditJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


UnexpectedJoinFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..UnexpectedJoinFailure Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Join failure caused by editability or design option related problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


Unknown Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..Unknown Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Unknown

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId Unknown { get; }
Visual Basic
Public Shared ReadOnly Property Unknown As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Unknown {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


WorksetJoinWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoJoinFailures..::..WorksetJoinWarn Property
BuiltInFailures..::..AutoJoinFailures Class See Also Send Feedback
Two elements were not automatically joined because one or both is not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetJoinWarn { get; }
Visual Basic
Public Shared ReadOnly Property WorksetJoinWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetJoinWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoJoinFailures Class


BuiltInFailures.AutoRouteFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about AutoRoute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class AutoRouteFailures
Visual Basic
Public NotInheritable Class AutoRouteFailures
Visual C++
public ref class AutoRouteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..AutoRouteFailures

See Also

BuiltInFailures..::..AutoRouteFailures Members


BuiltInFailures.AutoRouteFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures Members
BuiltInFailures..::..AutoRouteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToComnnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToComnnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::..AutoRouteFailures Class


BuiltInFailures.AutoRouteFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures Properties
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback

The BuiltInFailures..::..AutoRouteFailures type exposes the following members.

Properties

Name | Description
AttemptToComnnectNonSlopingElementToSlopedPipeError | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
AttemptToComnnectNonSlopingElementToSlopedPipeWarning | You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.
DesignOptionConflictError | The solution is failing to do the elements are not in the same Design Option.
DesignOptionConflictWarning | The solution is failing to do the elements are not in the same Design Option.
DistributionTypeInvalid | Selected distribution system type is invalid!
ElementHasFlowCalculation | This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.
ElementHasOpenConnection | This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.
FailedDowngradeCrossToElbow | Failed to downgrade tee type to elbow type.
FailedDowngradeCrossToTee | Failed to downgrade cross type to tee type.
FailedDowngradeTeeToCross | Failed to upgrade tee type to cross type.
FailToDoCompatiblePhaseError | The solution is failing to do the elements Phases are compatible.
FailToDoCompatiblePhaseWarning | The solution is failing to do the elements Phases are compatible.
FailToIntersectParallelSegmentsError | The solution is failing to do segments which are parallel and should intersect.
FailToIntersectParallelSegmentsWarning | The solution is failing to do segments which are parallel and should intersect.
FittingParamsCauseGeometryToFailError | The one of parameters for the fitting is causing the geometry to fail.
FittingParamsCauseGeometryToFailWarning | The one of parameters for the fitting is causing the geometry to fail.
HighlightedElementDisconnected | The highlighted element has been disconnected.
InappropriateSlopeForPipe | The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.
MismatchedSystemClassificationHasSystemWarning | The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.
MismatchedSystemClassificationNoSystemWarning | The selected fixture is assigned to a system with different classification.
MismatchedSystemTypeWarning | The selected fixture is part of a different system. You may want to edit the system type and merge two systems.
NoAutoRouteSolutionFoundError | No auto-route solution was found.
NoAutoRouteSolutionFoundWarning | No auto-route solution was found.
NoFittingInProjectError | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInProjectWarning | The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.
NoFittingInRoutingError | The fitting that is converted to was not defined. Please assign one in the routing preference.
NoFittingLoadedInProjectError | The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.
NoSolutionInView | There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.
NotEnoughRoomForFittingsError | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NotEnoughRoomForFittingsWarning | There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.
NoValidSolutionAtSelectedPoint | No valid auto-route solution at selected point.
SegmentDrawnFromWrongSideError | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentDrawnFromWrongSideWarning | The segment is being drawn from the wrong side to connect to the location you indicated.
SegmentsAngleTooGreatError | The resulting angle between the segments is too great.
SegmentsAngleTooGreatWarning | The resulting angle between the segments is too great.
SolutionIsOppositeToConnectionError | The solution is in the opposite direction of the connection direction.
SolutionIsOppositeToConnectionWarning | The solution is in the opposite direction of the connection direction.
UnableToMakeConnectionInDirection | The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.
UtilizationCoefficientOutOfRange | The value for Coefficient of Utilization must be between 0 and 1.
ZeroLengthSegmentError | The solution is failing to do segments which are zero length.
ZeroLengthSegmentWarning | The solution is failing to do segments which are zero length.

See Also

BuiltInFailures..::..AutoRouteFailures Class


AttemptToComnnectNonSlopingElementToSlopedPipeError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..AttemptToComnnectNonSlopingElementToSlopedPipeError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToComnnectNonSlopingElementToSlopedPipeError { get; }
Visual Basic
Public Shared ReadOnly Property AttemptToComnnectNonSlopingElementToSlopedPipeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttemptToComnnectNonSlopingElementToSlopedPipeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


AttemptToComnnectNonSlopingElementToSlopedPipeWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..AttemptToComnnectNonSlopingElementToSlopedPipeWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
You have specified that sloped pipe be drawn, but are trying to connect to an element that doesn't support sloping connections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToComnnectNonSlopingElementToSlopedPipeWarning { get; }
Visual Basic
Public Shared ReadOnly Property AttemptToComnnectNonSlopingElementToSlopedPipeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttemptToComnnectNonSlopingElementToSlopedPipeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DesignOptionConflictError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..DesignOptionConflictError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionConflictError { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionConflictError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DesignOptionConflictWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..DesignOptionConflictWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements are not in the same Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DesignOptionConflictWarning { get; }
Visual Basic
Public Shared ReadOnly Property DesignOptionConflictWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DesignOptionConflictWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


DistributionTypeInvalid Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..DistributionTypeInvalid Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Selected distribution system type is invalid!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DistributionTypeInvalid { get; }
Visual Basic
Public Shared ReadOnly Property DistributionTypeInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DistributionTypeInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ElementHasFlowCalculation Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..ElementHasFlowCalculation Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but for flow calculations to work correctly all connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementHasFlowCalculation { get; }
Visual Basic
Public Shared ReadOnly Property ElementHasFlowCalculation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementHasFlowCalculation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ElementHasOpenConnection Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..ElementHasOpenConnection Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
This element has an open connection. This may not be an error, but all open connections should be sealed with an end cap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementHasOpenConnection { get; }
Visual Basic
Public Shared ReadOnly Property ElementHasOpenConnection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementHasOpenConnection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailedDowngradeCrossToElbow Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailedDowngradeCrossToElbow Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Failed to downgrade tee type to elbow type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeCrossToElbow { get; }
Visual Basic
Public Shared ReadOnly Property FailedDowngradeCrossToElbow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeCrossToElbow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailedDowngradeCrossToTee Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailedDowngradeCrossToTee Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Failed to downgrade cross type to tee type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeCrossToTee { get; }
Visual Basic
Public Shared ReadOnly Property FailedDowngradeCrossToTee As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeCrossToTee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailedDowngradeTeeToCross Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailedDowngradeTeeToCross Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
Failed to upgrade tee type to cross type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedDowngradeTeeToCross { get; }
Visual Basic
Public Shared ReadOnly Property FailedDowngradeTeeToCross As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedDowngradeTeeToCross {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToDoCompatiblePhaseError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailToDoCompatiblePhaseError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseError { get; }
Visual Basic
Public Shared ReadOnly Property FailToDoCompatiblePhaseError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToDoCompatiblePhaseWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailToDoCompatiblePhaseWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do the elements Phases are compatible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailToDoCompatiblePhaseWarning { get; }
Visual Basic
Public Shared ReadOnly Property FailToDoCompatiblePhaseWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToDoCompatiblePhaseWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToIntersectParallelSegmentsError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailToIntersectParallelSegmentsError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsError { get; }
Visual Basic
Public Shared ReadOnly Property FailToIntersectParallelSegmentsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FailToIntersectParallelSegmentsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FailToIntersectParallelSegmentsWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are parallel and should intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailToIntersectParallelSegmentsWarning { get; }
Visual Basic
Public Shared ReadOnly Property FailToIntersectParallelSegmentsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToIntersectParallelSegmentsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FittingParamsCauseGeometryToFailError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FittingParamsCauseGeometryToFailError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingParamsCauseGeometryToFailError { get; }
Visual Basic
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


FittingParamsCauseGeometryToFailWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..FittingParamsCauseGeometryToFailWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The one of parameters for the fitting is causing the geometry to fail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingParamsCauseGeometryToFailWarning { get; }
Visual Basic
Public Shared ReadOnly Property FittingParamsCauseGeometryToFailWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingParamsCauseGeometryToFailWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


HighlightedElementDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..HighlightedElementDisconnected Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The highlighted element has been disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property HighlightedElementDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


InappropriateSlopeForPipe Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..InappropriateSlopeForPipe Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The slope that you specified could not be applied to this pipe. Please check the items that it is connected to and make sure that they aren't constraining the slope of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InappropriateSlopeForPipe { get; }
Visual Basic
Public Shared ReadOnly Property InappropriateSlopeForPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InappropriateSlopeForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


MismatchedSystemClassificationHasSystemWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..MismatchedSystemClassificationHasSystemWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The selected fixture is part of a system with different classification. System calculations (e.g. flow analysis) are not possible between systems with different classifications.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchedSystemClassificationHasSystemWarning { get; }
Visual Basic
Public Shared ReadOnly Property MismatchedSystemClassificationHasSystemWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchedSystemClassificationHasSystemWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


MismatchedSystemClassificationNoSystemWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..MismatchedSystemClassificationNoSystemWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The selected fixture is assigned to a system with different classification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchedSystemClassificationNoSystemWarning { get; }
Visual Basic
Public Shared ReadOnly Property MismatchedSystemClassificationNoSystemWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchedSystemClassificationNoSystemWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


MismatchedSystemTypeWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..MismatchedSystemTypeWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The selected fixture is part of a different system. You may want to edit the system type and merge two systems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchedSystemTypeWarning { get; }
Visual Basic
Public Shared ReadOnly Property MismatchedSystemTypeWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchedSystemTypeWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoAutoRouteSolutionFoundError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoAutoRouteSolutionFoundError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoAutoRouteSolutionFoundError { get; }
Visual Basic
Public Shared ReadOnly Property NoAutoRouteSolutionFoundError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoAutoRouteSolutionFoundWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoAutoRouteSolutionFoundWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
No auto-route solution was found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoAutoRouteSolutionFoundWarning { get; }
Visual Basic
Public Shared ReadOnly Property NoAutoRouteSolutionFoundWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAutoRouteSolutionFoundWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInProjectError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInProjectError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingInProjectError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInProjectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInProjectWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInProjectWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The routing solution failed because there is no default fitting type specified or the fitting cannot be found in the project. Ensure the fitting is loaded in the project and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingInProjectWarning { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInProjectWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInProjectWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingInRoutingError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingInRoutingError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The fitting that is converted to was not defined. Please assign one in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingInRoutingError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingInRoutingError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingInRoutingError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoFittingLoadedInProjectError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoFittingLoadedInProjectError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The fitting that is converted to was not defined. Please load one fitting family and assign it in the routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFittingLoadedInProjectError { get; }
Visual Basic
Public Shared ReadOnly Property NoFittingLoadedInProjectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFittingLoadedInProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoSolutionInView Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoSolutionInView Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
There is no solution for this view. All the elements have been filtered for this view, select another view, and select solutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSolutionInView { get; }
Visual Basic
Public Shared ReadOnly Property NoSolutionInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSolutionInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NotEnoughRoomForFittingsError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NotEnoughRoomForFittingsError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsError { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForFittingsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NotEnoughRoomForFittingsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NotEnoughRoomForFittingsWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
There was not enough room to place the required fittings. Consider increasing the length of the segments, or moving them farther apart to generate a solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForFittingsWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForFittingsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForFittingsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


NoValidSolutionAtSelectedPoint Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..NoValidSolutionAtSelectedPoint Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
No valid auto-route solution at selected point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoValidSolutionAtSelectedPoint { get; }
Visual Basic
Public Shared ReadOnly Property NoValidSolutionAtSelectedPoint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoValidSolutionAtSelectedPoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentDrawnFromWrongSideError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentDrawnFromWrongSideError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentDrawnFromWrongSideError { get; }
Visual Basic
Public Shared ReadOnly Property SegmentDrawnFromWrongSideError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentDrawnFromWrongSideWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentDrawnFromWrongSideWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The segment is being drawn from the wrong side to connect to the location you indicated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentDrawnFromWrongSideWarning { get; }
Visual Basic
Public Shared ReadOnly Property SegmentDrawnFromWrongSideWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentDrawnFromWrongSideWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentsAngleTooGreatError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentsAngleTooGreatError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatError { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsAngleTooGreatError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SegmentsAngleTooGreatWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SegmentsAngleTooGreatWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The resulting angle between the segments is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsAngleTooGreatWarning { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsAngleTooGreatWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsAngleTooGreatWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SolutionIsOppositeToConnectionError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SolutionIsOppositeToConnectionError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionError { get; }
Visual Basic
Public Shared ReadOnly Property SolutionIsOppositeToConnectionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


SolutionIsOppositeToConnectionWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..SolutionIsOppositeToConnectionWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is in the opposite direction of the connection direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SolutionIsOppositeToConnectionWarning { get; }
Visual Basic
Public Shared ReadOnly Property SolutionIsOppositeToConnectionWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SolutionIsOppositeToConnectionWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


UnableToMakeConnectionInDirection Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..UnableToMakeConnectionInDirection Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The application is unable to make a connection in that direction. If the connectors are pointing up, make sure that the elevations of the segments (ducts and pipes) are above them. If the connectors are pointing down, make sure that the elevations of the segments (ducts and pipes) are below them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMakeConnectionInDirection { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMakeConnectionInDirection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeConnectionInDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


UtilizationCoefficientOutOfRange Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..UtilizationCoefficientOutOfRange Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The value for Coefficient of Utilization must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UtilizationCoefficientOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property UtilizationCoefficientOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UtilizationCoefficientOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ZeroLengthSegmentError Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..ZeroLengthSegmentError Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentError { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthSegmentError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


ZeroLengthSegmentWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..AutoRouteFailures..::..ZeroLengthSegmentWarning Property
BuiltInFailures..::..AutoRouteFailures Class See Also Send Feedback
The solution is failing to do segments which are zero length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthSegmentWarning { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthSegmentWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthSegmentWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..AutoRouteFailures Class


BuiltInFailures.BeamFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..BeamFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class BeamFailures
Visual Basic
Public NotInheritable Class BeamFailures
Visual C++
public ref class BeamFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BeamFailures

See Also

BuiltInFailures..::..BeamFailures Members


BuiltInFailures.BeamFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..BeamFailures Members
BuiltInFailures..::..BeamFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::..BeamFailures Class


BuiltInFailures.BeamFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..BeamFailures Properties
BuiltInFailures..::..BeamFailures Class See Also Send Feedback

The BuiltInFailures..::..BeamFailures type exposes the following members.

Properties

Name | Description
CannotBendBeamType | Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

See Also

BuiltInFailures..::..BeamFailures Class


CannotBendBeamType Property

[image]

Revit 2013 API
BuiltInFailures..::..BeamFailures..::..CannotBendBeamType Property
BuiltInFailures..::..BeamFailures Class See Also Send Feedback
Can't bend beam type "[Type Name]" along its location line. The beam is either too large or its curve is too sharp. You may be able to resolve the problem by reducing the beam's width in the bending direction, or by reducing acute angles in the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotBendBeamType { get; }
Visual Basic
Public Shared ReadOnly Property CannotBendBeamType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotBendBeamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamFailures Class


BuiltInFailures.BeamSystemFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about BeamSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class BeamSystemFailures
Visual Basic
Public NotInheritable Class BeamSystemFailures
Visual C++
public ref class BeamSystemFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BeamSystemFailures

See Also

BuiltInFailures..::..BeamSystemFailures Members


BuiltInFailures.BeamSystemFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures Members
BuiltInFailures..::..BeamSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BeamSystemFailures type exposes the following members.

Properties

Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.

See Also

BuiltInFailures..::..BeamSystemFailures Class


BuiltInFailures.BeamSystemFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures Properties
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback

The BuiltInFailures..::..BeamSystemFailures type exposes the following members.

Properties

Name | Description
BeamSystemEdgeBeamTooWide | Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.
BeamSystemHasTooManyBeams | A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.
BeamSystemTagBadView | Beam System Tags can only be placed in plan , elevation and 3D views.

See Also

BuiltInFailures..::..BeamSystemFailures Class


BeamSystemEdgeBeamTooWide Property

[image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemEdgeBeamTooWide Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
Beam of user-defined type does not fit into beam system with clear spacing layout rule. Beam type is reset to default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemEdgeBeamTooWide { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemEdgeBeamTooWide As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemEdgeBeamTooWide {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BeamSystemHasTooManyBeams Property

[image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemHasTooManyBeams Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
A beam system is trying to create more than 500 beams. Please use multiple beam systems if more than 500 beams are desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemHasTooManyBeams { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemHasTooManyBeams As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemHasTooManyBeams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BeamSystemTagBadView Property

[image]

Revit 2013 API
BuiltInFailures..::..BeamSystemFailures..::..BeamSystemTagBadView Property
BuiltInFailures..::..BeamSystemFailures Class See Also Send Feedback
Beam System Tags can only be placed in plan , elevation and 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BeamSystemTagBadView { get; }
Visual Basic
Public Shared ReadOnly Property BeamSystemTagBadView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamSystemTagBadView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BeamSystemFailures Class


BuiltInFailures.BendFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Bends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class BendFailures
Visual Basic
Public NotInheritable Class BendFailures
Visual C++
public ref class BendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BendFailures

See Also

BuiltInFailures..::..BendFailures Members


BuiltInFailures.BendFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..BendFailures Members
BuiltInFailures..::..BendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::..BendFailures Class


BuiltInFailures.BendFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..BendFailures Properties
BuiltInFailures..::..BendFailures Class See Also Send Feedback

The BuiltInFailures..::..BendFailures type exposes the following members.

Properties

Name | Description
BendAngleIsUnacceptable | The angle of the bend/elbow is unacceptable
DeleteMiddleBendNotAllowed | Delete a middle bend in a bank is not allowed
DeleteSegmentInBankNotAllowed | Delete a segment in a bank is not allowed
NotBentControl | While making curved beam type "[Type Name]" some Control elements were not created
NotBentDetailComponent | While making curved beam type "[Type Name]" 2D Detail Component elements were not created
NotBentFilledRegion | While making curved beam type "[Type Name]" Filled Region elements were not created
NotBentImage | While making curved beam type "[Type Name]" Image elements were not created
NotBentImport | While making curved beam type "[Type Name]" CAD File elements were not created
NotBentMaskingRegion | While making curved beam type "[Type Name]" Masking Region elements were not created
NotBentModelLine | While making curved beam type "[Type Name]" some Model Line elements were not created
NotBentOpening | While making curved beam type "[Type Name]" Opening elements were not created
NotBentRefLine | While making curved beam type "[Type Name]" some Reference Line elements were not created
NotBentRefPlane | While making curved beam type "[Type Name]" some Reference Plane elements were not created
NotBentSharedFamily | While making curved beam type "[Type Name]" Shared Family Instances were not created
NotBentSymbol | While making curved beam type "[Type Name]" Symbol elements were not created
NotBentSymbolicLine | While making curved beam type "[Type Name]" some Symbolic Line elements were not created

See Also

BuiltInFailures..::..BendFailures Class


BendAngleIsUnacceptable Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..BendAngleIsUnacceptable Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
The angle of the bend/elbow is unacceptable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BendAngleIsUnacceptable { get; }
Visual Basic
Public Shared ReadOnly Property BendAngleIsUnacceptable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendAngleIsUnacceptable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


DeleteMiddleBendNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..DeleteMiddleBendNotAllowed Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
Delete a middle bend in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteMiddleBendNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property DeleteMiddleBendNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteMiddleBendNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


DeleteSegmentInBankNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..DeleteSegmentInBankNotAllowed Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
Delete a segment in a bank is not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteSegmentInBankNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property DeleteSegmentInBankNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteSegmentInBankNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentControl Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentControl Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Control elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentControl { get; }
Visual Basic
Public Shared ReadOnly Property NotBentControl As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentControl {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentDetailComponent Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentDetailComponent Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" 2D Detail Component elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentDetailComponent { get; }
Visual Basic
Public Shared ReadOnly Property NotBentDetailComponent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentDetailComponent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentFilledRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentFilledRegion Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Filled Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentFilledRegion { get; }
Visual Basic
Public Shared ReadOnly Property NotBentFilledRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentFilledRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentImage Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentImage Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Image elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentImage { get; }
Visual Basic
Public Shared ReadOnly Property NotBentImage As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentImage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentImport Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentImport Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" CAD File elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentImport { get; }
Visual Basic
Public Shared ReadOnly Property NotBentImport As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentImport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentMaskingRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentMaskingRegion Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Masking Region elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentMaskingRegion { get; }
Visual Basic
Public Shared ReadOnly Property NotBentMaskingRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentMaskingRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentModelLine Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentModelLine Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Model Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentModelLine { get; }
Visual Basic
Public Shared ReadOnly Property NotBentModelLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentModelLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentOpening Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentOpening Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Opening elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentOpening { get; }
Visual Basic
Public Shared ReadOnly Property NotBentOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentRefLine Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentRefLine Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Reference Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentRefLine { get; }
Visual Basic
Public Shared ReadOnly Property NotBentRefLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentRefLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentRefPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentRefPlane Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Reference Plane elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentRefPlane { get; }
Visual Basic
Public Shared ReadOnly Property NotBentRefPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSharedFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentSharedFamily Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Shared Family Instances were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSharedFamily { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSharedFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSharedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSymbol Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentSymbol Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" Symbol elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSymbol { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


NotBentSymbolicLine Property

[image]

Revit 2013 API
BuiltInFailures..::..BendFailures..::..NotBentSymbolicLine Property
BuiltInFailures..::..BendFailures Class See Also Send Feedback
While making curved beam type "[Type Name]" some Symbolic Line elements were not created

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotBentSymbolicLine { get; }
Visual Basic
Public Shared ReadOnly Property NotBentSymbolicLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotBentSymbolicLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BendFailures Class


BuiltInFailures.BlendFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..BlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class BlendFailures
Visual Basic
Public NotInheritable Class BlendFailures
Visual C++
public ref class BlendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..BlendFailures

See Also

BuiltInFailures..::..BlendFailures Members


BuiltInFailures.BlendFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..BlendFailures Members
BuiltInFailures..::..BlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..BlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawBlend | Can't create blend.

See Also

BuiltInFailures..::..BlendFailures Class


BuiltInFailures.BlendFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..BlendFailures Properties
BuiltInFailures..::..BlendFailures Class See Also Send Feedback

The BuiltInFailures..::..BlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawBlend | Can't create blend.

See Also

BuiltInFailures..::..BlendFailures Class


CannotDrawBlend Property

[image]

Revit 2013 API
BuiltInFailures..::..BlendFailures..::..CannotDrawBlend Property
BuiltInFailures..::..BlendFailures Class See Also Send Feedback
Can't create blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawBlend { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawBlend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawBlend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..BlendFailures Class


BuiltInFailures.ColorFillFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ColorFillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ColorFill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ColorFillFailures
Visual Basic
Public NotInheritable Class ColorFillFailures
Visual C++
public ref class ColorFillFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ColorFillFailures

See Also

BuiltInFailures..::..ColorFillFailures Members


BuiltInFailures.ColorFillFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColorFillFailures Members
BuiltInFailures..::..ColorFillFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..ColorFillFailures Class


BuiltInFailures.ColorFillFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColorFillFailures Properties
BuiltInFailures..::..ColorFillFailures Class See Also Send Feedback

The BuiltInFailures..::..ColorFillFailures type exposes the following members.

Properties

Name | Description
OnlyOneColorFillNonPlan | A Color Fill Legend can only be placed in a Floor Plan View or a Section View.
SymtemColorFillLegendNotAllowed | [Category name] Color Fill Legend can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..ColorFillFailures Class


OnlyOneColorFillNonPlan Property

[image]

Revit 2013 API
BuiltInFailures..::..ColorFillFailures..::..OnlyOneColorFillNonPlan Property
BuiltInFailures..::..ColorFillFailures Class See Also Send Feedback
A Color Fill Legend can only be placed in a Floor Plan View or a Section View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyOneColorFillNonPlan { get; }
Visual Basic
Public Shared ReadOnly Property OnlyOneColorFillNonPlan As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyOneColorFillNonPlan {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColorFillFailures Class


SymtemColorFillLegendNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..ColorFillFailures..::..SymtemColorFillLegendNotAllowed Property
BuiltInFailures..::..ColorFillFailures Class See Also Send Feedback
[Category name] Color Fill Legend can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SymtemColorFillLegendNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property SymtemColorFillLegendNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SymtemColorFillLegendNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColorFillFailures Class


BuiltInFailures.ColumnFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ColumnFailures
Visual Basic
Public NotInheritable Class ColumnFailures
Visual C++
public ref class ColumnFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ColumnFailures

See Also

BuiltInFailures..::..ColumnFailures Members


BuiltInFailures.ColumnFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures Members
BuiltInFailures..::..ColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColumnFailures type exposes the following members.

Properties

Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height

See Also

BuiltInFailures..::..ColumnFailures Class


BuiltInFailures.ColumnFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures Properties
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback

The BuiltInFailures..::..ColumnFailures type exposes the following members.

Properties

Name | Description
ColumnAndTargetAreConcrete | Column and target are both concrete. Geometries have been joined.
ColumnBaseAboveTopError | The column base can't be moved above its top.
ColumnBaseAboveTopFailure | The column base can't be moved above its top.
ColumnJoinNonhitFailure | The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
ColumnTopBelowBaseError | The column top can't be moved below its base.
ColumnTopBelowBaseFailure | The column top can't be moved below its base.
ColumnZeroHeightError | The column can't have zero height
ColumnZeroHeightFailure | The column can't have zero height

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnAndTargetAreConcrete Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnAndTargetAreConcrete Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
Column and target are both concrete. Geometries have been joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAreConcrete { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAndTargetAreConcrete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAreConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnBaseAboveTopError Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnBaseAboveTopError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAboveTopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnBaseAboveTopFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnBaseAboveTopFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column base can't be moved above its top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnBaseAboveTopFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnBaseAboveTopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnBaseAboveTopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnJoinNonhitFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnJoinNonhitFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnJoinNonhitFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnJoinNonhitFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnJoinNonhitFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnTopBelowBaseError Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnTopBelowBaseError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopBelowBaseError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnTopBelowBaseFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnTopBelowBaseFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column top can't be moved below its base.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTopBelowBaseFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTopBelowBaseFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTopBelowBaseFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnZeroHeightError Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnZeroHeightError Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightError { get; }
Visual Basic
Public Shared ReadOnly Property ColumnZeroHeightError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


ColumnZeroHeightFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnFailures..::..ColumnZeroHeightFailure Property
BuiltInFailures..::..ColumnFailures Class See Also Send Feedback
The column can't have zero height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnZeroHeightFailure { get; }
Visual Basic
Public Shared ReadOnly Property ColumnZeroHeightFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnZeroHeightFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnFailures Class


BuiltInFailures.ColumnInsideWallFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures description ColumnInsideWall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ColumnInsideWallFailures
Visual Basic
Public NotInheritable Class ColumnInsideWallFailures
Visual C++
public ref class ColumnInsideWallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ColumnInsideWallFailures

See Also

BuiltInFailures..::..ColumnInsideWallFailures Members


BuiltInFailures.ColumnInsideWallFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures Members
BuiltInFailures..::..ColumnInsideWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ColumnInsideWallFailures type exposes the following members.

Properties

Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StairJoinGeometryWarning | Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


BuiltInFailures.ColumnInsideWallFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures Properties
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback

The BuiltInFailures..::..ColumnInsideWallFailures type exposes the following members.

Properties

Name | Description
ColumnInsideWall | One element is completely inside another.
CopingWarningExtension | Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.
CopingWarningIgnored | Cuts on concrete members are ignored.
CopingWarningMedium | Coping applied, but only in Medium Detail Level.
CopingWarningOffset | Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.
StairJoinGeometryWarning | Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.
StartCutShadowJoin | Two joined walls are in a position to allow automatic insert copying.
StopCutShadowJoin | Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


ColumnInsideWall Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..ColumnInsideWall Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
One element is completely inside another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnInsideWall { get; }
Visual Basic
Public Shared ReadOnly Property ColumnInsideWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnInsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningExtension Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningExtension Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but no cut was made. Adjust Coping Distance or Extension parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningExtension { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningExtension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningExtension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningIgnored Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningIgnored Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Cuts on concrete members are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningIgnored { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningIgnored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningMedium Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningMedium Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but only in Medium Detail Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningMedium { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningMedium As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningMedium {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


CopingWarningOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..CopingWarningOffset Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Coping applied, but no cut was made. Adjust Coping Distance or Offset parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopingWarningOffset { get; }
Visual Basic
Public Shared ReadOnly Property CopingWarningOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingWarningOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


StairJoinGeometryWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..StairJoinGeometryWarning Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Join Geometry of Stairs would clean only aligned edges in Sections views. Geometry will not be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairJoinGeometryWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairJoinGeometryWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairJoinGeometryWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


StartCutShadowJoin Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..StartCutShadowJoin Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are in a position to allow automatic insert copying.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StartCutShadowJoin { get; }
Visual Basic
Public Shared ReadOnly Property StartCutShadowJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StartCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


StopCutShadowJoin Property

[image]

Revit 2013 API
BuiltInFailures..::..ColumnInsideWallFailures..::..StopCutShadowJoin Property
BuiltInFailures..::..ColumnInsideWallFailures Class See Also Send Feedback
Two joined walls are no longer in a position to allow automatic insert copying. They are either non-parallel or non-overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StopCutShadowJoin { get; }
Visual Basic
Public Shared ReadOnly Property StopCutShadowJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StopCutShadowJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ColumnInsideWallFailures Class


BuiltInFailures.ComponentRepeaterFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ComponentRepeaterFailures
Visual Basic
Public NotInheritable Class ComponentRepeaterFailures
Visual C++
public ref class ComponentRepeaterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ComponentRepeaterFailures

See Also

BuiltInFailures..::..ComponentRepeaterFailures Members


BuiltInFailures.ComponentRepeaterFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterFailures Members
BuiltInFailures..::..ComponentRepeaterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ComponentRepeaterFailures type exposes the following members.

Properties

Name | Description
ComponentRepeater_InvalidFamilyOnReload | Reloaded family not appropriate for repeater.
ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater | There is only one component in this repeater.

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterFailures Properties
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback

The BuiltInFailures..::..ComponentRepeaterFailures type exposes the following members.

Properties

Name | Description
ComponentRepeater_InvalidFamilyOnReload | Reloaded family not appropriate for repeater.
ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater | There is only one component in this repeater.

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


ComponentRepeater_InvalidFamilyOnReload Property

[image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterFailures..::..ComponentRepeater_InvalidFamilyOnReload Property
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback
Reloaded family not appropriate for repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ComponentRepeater_InvalidFamilyOnReload { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeater_InvalidFamilyOnReload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeater_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property

[image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterFailures..::..ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater Property
BuiltInFailures..::..ComponentRepeaterFailures Class See Also Send Feedback
There is only one component in this repeater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeater_ThereIsOnlyOneInstanceInThisRepeater {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterFailures Class


BuiltInFailures.ComponentRepeaterSlotFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterSlotFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ComponentRepeaterSlotFailures
Visual Basic
Public NotInheritable Class ComponentRepeaterSlotFailures
Visual C++
public ref class ComponentRepeaterSlotFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ComponentRepeaterSlotFailures

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Members


BuiltInFailures.ComponentRepeaterSlotFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterSlotFailures Members
BuiltInFailures..::..ComponentRepeaterSlotFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ComponentRepeaterSlotFailures type exposes the following members.

Properties

Name | Description
ComponentRepeaterSlot_InvalidFamilyOnReload | Reloaded family not appropriate for repeated component.

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Class


BuiltInFailures.ComponentRepeaterSlotFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterSlotFailures Properties
BuiltInFailures..::..ComponentRepeaterSlotFailures Class See Also Send Feedback

The BuiltInFailures..::..ComponentRepeaterSlotFailures type exposes the following members.

Properties

Name | Description
ComponentRepeaterSlot_InvalidFamilyOnReload | Reloaded family not appropriate for repeated component.

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Class


ComponentRepeaterSlot_InvalidFamilyOnReload Property

[image]

Revit 2013 API
BuiltInFailures..::..ComponentRepeaterSlotFailures..::..ComponentRepeaterSlot_InvalidFamilyOnReload Property
BuiltInFailures..::..ComponentRepeaterSlotFailures Class See Also Send Feedback
Reloaded family not appropriate for repeated component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ComponentRepeaterSlot_InvalidFamilyOnReload { get; }
Visual Basic
Public Shared ReadOnly Property ComponentRepeaterSlot_InvalidFamilyOnReload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComponentRepeaterSlot_InvalidFamilyOnReload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ComponentRepeaterSlotFailures Class


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ConceptualEnergyAnalysisDB.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ConceptualEnergyAnalysisDBFailures
Visual Basic
Public NotInheritable Class ConceptualEnergyAnalysisDBFailures
Visual C++
public ref class ConceptualEnergyAnalysisDBFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures

See Also

BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Members


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Members
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures type exposes the following members.

Properties

Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

See Also

BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class


BuiltInFailures.ConceptualEnergyAnalysisDBFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Properties
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class See Also Send Feedback

The BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures type exposes the following members.

Properties

Name | Description
AimErrEmptyName | MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

See Also

BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class


AimErrEmptyName Property

[image]

Revit 2013 API
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures..::..AimErrEmptyName Property
BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class See Also Send Feedback
MassZone '%1' has empty name and id values which cannot be used as gbXML identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AimErrEmptyName { get; }
Visual Basic
Public Shared ReadOnly Property AimErrEmptyName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AimErrEmptyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConceptualEnergyAnalysisDBFailures Class


BuiltInFailures.ConnectorFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ConnectorFailures
Visual Basic
Public NotInheritable Class ConnectorFailures
Visual C++
public ref class ConnectorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConnectorFailures

See Also

BuiltInFailures..::..ConnectorFailures Members


BuiltInFailures.ConnectorFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures Members
BuiltInFailures..::..ConnectorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConnectorFailures type exposes the following members.

Properties

Name | Description
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
AlwaysVertical | [Family Name] - 'Always vertical' should be checked:\n [Description]
DisconnectedElements | Elements are disconnected!
DuctPipeOpositDirection | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ElementsNotAlignment | [Family Name] - The following Elements don't align at (0,0,0) :\n [Description]
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidIESParamValue | [Family Name] - The value of IES parameter is invalid:\n [Description]
InvalidPartType | [Family Name] - The part type is invalid:\n [Description]
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoShapeHandle | [Family Name] - RME family should not have shape handle:\n [Description]
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
NotWellConnected | [Element Name] is not "Well Connected".
OpenConnector | The element has an open connector
OverConstrainParams | [Family Name] - Change following parameters will cause over constrain :\n [Description]
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation is none. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
TransitionDoesNotFitOrConnectorsMismatch | Can not place transition. The transition does not fit or the connectors mismatch.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
UnLockedDimensions | [Family Name] - Dimensions should be locked or labeled:\n [Description]
WrongConnector | [Family Name] - Connector is wrong:\n [Description]
WrongConnectorDomain | [Family Name] - Connector Domain is wrong:\n [Description]
WrongConnectorLink | [Family Name] - Connector link is wrong:\n [Description]
WrongConnectorMappingParam | [Family Name] - connector mapping parameter is wrong:\n [Description]
WrongConnectorNumber | [Family Name] - The number of connector is wrong:\n [Description]
WrongConnectorParamValue | [Family Name] - connector parameter value is wrong:\n [Description]
WrongFamilyName | [Family Name] - Family name is wrong:\n [Description]
WrongPrimaryConnector | [Family Name] - Primary connector is wrong:\n [Description]
WrongPrimaryConnectorSystemType | [Family Name] - System Type of primary connector is wrong:\n [Description]

See Also

BuiltInFailures..::..ConnectorFailures Class


BuiltInFailures.ConnectorFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures Properties
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback

The BuiltInFailures..::..ConnectorFailures type exposes the following members.

Properties

Name | Description
AllElementsRemovedFromCircuitGroup | [System] is empty and will be deleted.
AlwaysVertical | [Family Name] - 'Always vertical' should be checked:\n [Description]
DisconnectedElements | Elements are disconnected!
DuctPipeOpositDirection | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
ElementAssignedToDefaultSystem | At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.
ElementsAreDisconnected | Elements need to be disconnected.
ElementsConnectedToParent | You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.
ElementsNeedToBeDisconnected | Elements need to be disconnected.
ElementsNotAlignment | [Family Name] - The following Elements don't align at (0,0,0) :\n [Description]
ExistsForSelectedElement | Connections already exists for selected element.
FittingMustBeOnDuct | The [Tap] must be attached to duct.
FittingMustBeOnDuctWarn | The [Tap] must be attached to duct.
FittingMustBeOnPipe | The [Tap] must be attached to pipe.
FittingMustBeOnPipeWarn | The [Tap] must be attached to pipe.
InvalidConnectionRef | The selected fitting has invalid connections and must be deleted to continue.
InvalidConnector | The connector is invalid, the size cannot be determined from the connector.
InvalidIESParamValue | [Family Name] - The value of IES parameter is invalid:\n [Description]
InvalidPartType | [Family Name] - The part type is invalid:\n [Description]
InvalidPowerFactorValue | The value for Power Factor must be between 0 and 1.
JointGenderMismatch | The element has a connector with a fitting joint gender mismatch
JointShapeMismatch | The element has a connector with a fitting joint shape mismatch
JointSizeMismatch | The element has a connector with a fitting joint size mismatch
JointTypeMismatch | The element has a connector with a fitting joint type mismatch
LayoutConnector | [Unassigned System Type] on Connector [Index Number].
MismatchNoAvailableConnector | Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.
NetworkValidityError | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NetworkValidityErrorWasDisconnected | The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?
NoLossDefined | No Loss Defined
NoShapeHandle | [Family Name] - RME family should not have shape handle:\n [Description]
NotAllowedToModifyGroupElementsError | Connection to a group failed. Modification of elements within a group is not allowed.
NotAllowedToModifyGroupElementsWarning | Connection to a group failed. Modification of elements within a group is not allowed.
NotWellConnected | [Element Name] is not "Well Connected".
OpenConnector | The element has an open connector
OverConstrainParams | [Family Name] - Change following parameters will cause over constrain :\n [Description]
RbsNetworkValidityError | The family is connected in a network and can no longer keep the connectivity.
RemoveConnectorLinksWarn | The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.
RemoveConnectorLinkWarn | The link between connector [Index] and connector [Index] is removed.
ShapesNotMatch | Shapes do not match. A connection could not be made.
SizingCalculationFlowOnlyWarn | Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.
SizingCalculationNoneWarn | Some elements are not sized because the system calculation is none. You may change the system calculation level to size them again.
SizingFailed | Sizing failed.
TransitionDoesNotFitOrConnectorsMismatch | Can not place transition. The transition does not fit or the connectors mismatch.
UnconnectedCircuit | The element has an unconnected circuit on its connector
UnconnectedDevice | Device has an unconnected [Type Name] connector (index = [Index Number]).
UndefinedConnector | Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]
UnLockedDimensions | [Family Name] - Dimensions should be locked or labeled:\n [Description]
WrongConnector | [Family Name] - Connector is wrong:\n [Description]
WrongConnectorDomain | [Family Name] - Connector Domain is wrong:\n [Description]
WrongConnectorLink | [Family Name] - Connector link is wrong:\n [Description]
WrongConnectorMappingParam | [Family Name] - connector mapping parameter is wrong:\n [Description]
WrongConnectorNumber | [Family Name] - The number of connector is wrong:\n [Description]
WrongConnectorParamValue | [Family Name] - connector parameter value is wrong:\n [Description]
WrongFamilyName | [Family Name] - Family name is wrong:\n [Description]
WrongPrimaryConnector | [Family Name] - Primary connector is wrong:\n [Description]
WrongPrimaryConnectorSystemType | [Family Name] - System Type of primary connector is wrong:\n [Description]

See Also

BuiltInFailures..::..ConnectorFailures Class


AllElementsRemovedFromCircuitGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..AllElementsRemovedFromCircuitGroup Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[System] is empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllElementsRemovedFromCircuitGroup { get; }
Visual Basic
Public Shared ReadOnly Property AllElementsRemovedFromCircuitGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllElementsRemovedFromCircuitGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


AlwaysVertical Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..AlwaysVertical Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - 'Always vertical' should be checked:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AlwaysVertical { get; }
Visual Basic
Public Shared ReadOnly Property AlwaysVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlwaysVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


DisconnectedElements Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..DisconnectedElements Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements are disconnected!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DisconnectedElements { get; }
Visual Basic
Public Shared ReadOnly Property DisconnectedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DisconnectedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


DuctPipeOpositDirection Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..DuctPipeOpositDirection Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuctPipeOpositDirection { get; }
Visual Basic
Public Shared ReadOnly Property DuctPipeOpositDirection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctPipeOpositDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementAssignedToDefaultSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ElementAssignedToDefaultSystem Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
At least one connector on the highlighted element is currently assigned to the [Element Name]. In general items shouldn't be assigned to the Default Systems, but should be assigned as equipments or elements of a non-default system. Click the More Info button below for additional information on System Creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementAssignedToDefaultSystem { get; }
Visual Basic
Public Shared ReadOnly Property ElementAssignedToDefaultSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementAssignedToDefaultSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsAreDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ElementsAreDisconnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsAreDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property ElementsAreDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsAreDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsConnectedToParent Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ElementsConnectedToParent Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
You have selected elements that are connected to a parent object in a System. These elements cannot be removed from the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsConnectedToParent { get; }
Visual Basic
Public Shared ReadOnly Property ElementsConnectedToParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsConnectedToParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsNeedToBeDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ElementsNeedToBeDisconnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Elements need to be disconnected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNeedToBeDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNeedToBeDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNeedToBeDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ElementsNotAlignment Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ElementsNotAlignment Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - The following Elements don't align at (0,0,0) :\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNotAlignment { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNotAlignment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNotAlignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ExistsForSelectedElement Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ExistsForSelectedElement Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Connections already exists for selected element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExistsForSelectedElement { get; }
Visual Basic
Public Shared ReadOnly Property ExistsForSelectedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExistsForSelectedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnDuct Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnDuct Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnDuct { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnDuct As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnDuctWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnDuctWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnDuctWarn { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnDuctWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnDuctWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnPipe Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnPipe Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnPipe { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


FittingMustBeOnPipeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..FittingMustBeOnPipeWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The [Tap] must be attached to pipe.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FittingMustBeOnPipeWarn { get; }
Visual Basic
Public Shared ReadOnly Property FittingMustBeOnPipeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FittingMustBeOnPipeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidConnectionRef Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..InvalidConnectionRef Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The selected fitting has invalid connections and must be deleted to continue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidConnectionRef { get; }
Visual Basic
Public Shared ReadOnly Property InvalidConnectionRef As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidConnectionRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..InvalidConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The connector is invalid, the size cannot be determined from the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidConnector { get; }
Visual Basic
Public Shared ReadOnly Property InvalidConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidIESParamValue Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..InvalidIESParamValue Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - The value of IES parameter is invalid:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidIESParamValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidIESParamValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidIESParamValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidPartType Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..InvalidPartType Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - The part type is invalid:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPartType { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPartType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPartType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


InvalidPowerFactorValue Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..InvalidPowerFactorValue Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The value for Power Factor must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPowerFactorValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPowerFactorValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPowerFactorValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointGenderMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..JointGenderMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint gender mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JointGenderMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointGenderMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointGenderMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointShapeMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..JointShapeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint shape mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JointShapeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointShapeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointShapeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointSizeMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..JointSizeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint size mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JointSizeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointSizeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointSizeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


JointTypeMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..JointTypeMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has a connector with a fitting joint type mismatch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JointTypeMismatch { get; }
Visual Basic
Public Shared ReadOnly Property JointTypeMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JointTypeMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


LayoutConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..LayoutConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Unassigned System Type] on Connector [Index Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LayoutConnector { get; }
Visual Basic
Public Shared ReadOnly Property LayoutConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LayoutConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


MismatchNoAvailableConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..MismatchNoAvailableConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Cannot add [Element] to System. There is no available connector matching the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNoAvailableConnector { get; }
Visual Basic
Public Shared ReadOnly Property MismatchNoAvailableConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchNoAvailableConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NetworkValidityError Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NetworkValidityError Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NetworkValidityError { get; }
Visual Basic
Public Shared ReadOnly Property NetworkValidityError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NetworkValidityErrorWasDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NetworkValidityErrorWasDisconnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity. Disconnect the family from the network?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NetworkValidityErrorWasDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property NetworkValidityErrorWasDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NetworkValidityErrorWasDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NoLossDefined Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NoLossDefined Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
No Loss Defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLossDefined { get; }
Visual Basic
Public Shared ReadOnly Property NoLossDefined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLossDefined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NoShapeHandle Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NoShapeHandle Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - RME family should not have shape handle:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoShapeHandle { get; }
Visual Basic
Public Shared ReadOnly Property NoShapeHandle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoShapeHandle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NotAllowedToModifyGroupElementsError Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NotAllowedToModifyGroupElementsError Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToModifyGroupElementsError { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NotAllowedToModifyGroupElementsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NotAllowedToModifyGroupElementsWarning Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Connection to a group failed. Modification of elements within a group is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToModifyGroupElementsWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedToModifyGroupElementsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToModifyGroupElementsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


NotWellConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..NotWellConnected Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Element Name] is not "Well Connected".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotWellConnected { get; }
Visual Basic
Public Shared ReadOnly Property NotWellConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotWellConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


OpenConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..OpenConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has an open connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenConnector { get; }
Visual Basic
Public Shared ReadOnly Property OpenConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


OverConstrainParams Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..OverConstrainParams Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Change following parameters will cause over constrain :\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OverConstrainParams { get; }
Visual Basic
Public Shared ReadOnly Property OverConstrainParams As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverConstrainParams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RbsNetworkValidityError Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..RbsNetworkValidityError Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The family is connected in a network and can no longer keep the connectivity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RbsNetworkValidityError { get; }
Visual Basic
Public Shared ReadOnly Property RbsNetworkValidityError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RbsNetworkValidityError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RemoveConnectorLinksWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..RemoveConnectorLinksWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The links between connector [Index] and connector [Index], connector [Index] and connector [Index] are removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinksWarn { get; }
Visual Basic
Public Shared ReadOnly Property RemoveConnectorLinksWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinksWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


RemoveConnectorLinkWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..RemoveConnectorLinkWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The link between connector [Index] and connector [Index] is removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveConnectorLinkWarn { get; }
Visual Basic
Public Shared ReadOnly Property RemoveConnectorLinkWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveConnectorLinkWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


ShapesNotMatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..ShapesNotMatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Shapes do not match. A connection could not be made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShapesNotMatch { get; }
Visual Basic
Public Shared ReadOnly Property ShapesNotMatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShapesNotMatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingCalculationFlowOnlyWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..SizingCalculationFlowOnlyWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Some elements are not sized because the system calculation is flow only. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SizingCalculationFlowOnlyWarn { get; }
Visual Basic
Public Shared ReadOnly Property SizingCalculationFlowOnlyWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingCalculationFlowOnlyWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingCalculationNoneWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..SizingCalculationNoneWarn Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Some elements are not sized because the system calculation is none. You may change the system calculation level to size them again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SizingCalculationNoneWarn { get; }
Visual Basic
Public Shared ReadOnly Property SizingCalculationNoneWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingCalculationNoneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


SizingFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..SizingFailed Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SizingFailed { get; }
Visual Basic
Public Shared ReadOnly Property SizingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


TransitionDoesNotFitOrConnectorsMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..TransitionDoesNotFitOrConnectorsMismatch Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Can not place transition. The transition does not fit or the connectors mismatch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TransitionDoesNotFitOrConnectorsMismatch { get; }
Visual Basic
Public Shared ReadOnly Property TransitionDoesNotFitOrConnectorsMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TransitionDoesNotFitOrConnectorsMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


UnconnectedCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..UnconnectedCircuit Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
The element has an unconnected circuit on its connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnconnectedCircuit { get; }
Visual Basic
Public Shared ReadOnly Property UnconnectedCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnconnectedCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


UnconnectedDevice Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..UnconnectedDevice Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Device has an unconnected [Type Name] connector (index = [Index Number]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnconnectedDevice { get; }
Visual Basic
Public Shared ReadOnly Property UnconnectedDevice As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnconnectedDevice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


UndefinedConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..UndefinedConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
Revit does not support Undefined connectors. The following have been replaced by the default connector: [Connector Element]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedConnector { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


UnLockedDimensions Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..UnLockedDimensions Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Dimensions should be locked or labeled:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnLockedDimensions { get; }
Visual Basic
Public Shared ReadOnly Property UnLockedDimensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnLockedDimensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnector { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnectorDomain Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnectorDomain Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector Domain is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorDomain { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnectorDomain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorDomain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnectorLink Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnectorLink Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Connector link is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorLink { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnectorLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnectorMappingParam Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnectorMappingParam Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - connector mapping parameter is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorMappingParam { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnectorMappingParam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorMappingParam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnectorNumber Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnectorNumber Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - The number of connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorNumber { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnectorNumber As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongConnectorParamValue Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongConnectorParamValue Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - connector parameter value is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConnectorParamValue { get; }
Visual Basic
Public Shared ReadOnly Property WrongConnectorParamValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConnectorParamValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongFamilyName Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongFamilyName Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Family name is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFamilyName { get; }
Visual Basic
Public Shared ReadOnly Property WrongFamilyName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFamilyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongPrimaryConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongPrimaryConnector Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - Primary connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongPrimaryConnector { get; }
Visual Basic
Public Shared ReadOnly Property WrongPrimaryConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongPrimaryConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


WrongPrimaryConnectorSystemType Property

[image]

Revit 2013 API
BuiltInFailures..::..ConnectorFailures..::..WrongPrimaryConnectorSystemType Property
BuiltInFailures..::..ConnectorFailures Class See Also Send Feedback
[Family Name] - System Type of primary connector is wrong:\n [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongPrimaryConnectorSystemType { get; }
Visual Basic
Public Shared ReadOnly Property WrongPrimaryConnectorSystemType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongPrimaryConnectorSystemType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConnectorFailures Class


BuiltInFailures.ConstraintFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ConstraintFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Constraint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ConstraintFailures
Visual Basic
Public NotInheritable Class ConstraintFailures
Visual C++
public ref class ConstraintFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConstraintFailures

See Also

BuiltInFailures..::..ConstraintFailures Members


BuiltInFailures.ConstraintFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConstraintFailures Members
BuiltInFailures..::..ConstraintFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

See Also

BuiltInFailures..::..ConstraintFailures Class


BuiltInFailures.ConstraintFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConstraintFailures Properties
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback

The BuiltInFailures..::..ConstraintFailures type exposes the following members.

Properties

Name | Description
UndeletedConstraints | A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

See Also

BuiltInFailures..::..ConstraintFailures Class


UndeletedConstraints Property

[image]

Revit 2013 API
BuiltInFailures..::..ConstraintFailures..::..UndeletedConstraints Property
BuiltInFailures..::..ConstraintFailures Class See Also Send Feedback
A Dimension with Lock and/or EQ Constraints is being deleted, but the elements will still be constrained. Push Unconstrain to remove the Constraints or OK to leave elements constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndeletedConstraints { get; }
Visual Basic
Public Shared ReadOnly Property UndeletedConstraints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndeletedConstraints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConstraintFailures Class


BuiltInFailures.ConversionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about conversion of data to a different format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ConversionFailures
Visual Basic
Public NotInheritable Class ConversionFailures
Visual C++
public ref class ConversionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ConversionFailures

See Also

BuiltInFailures..::..ConversionFailures Members


BuiltInFailures.ConversionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures Members
BuiltInFailures..::..ConversionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ConversionFailures type exposes the following members.

Properties

Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'

See Also

BuiltInFailures..::..ConversionFailures Class


BuiltInFailures.ConversionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures Properties
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback

The BuiltInFailures..::..ConversionFailures type exposes the following members.

Properties

Name | Description
CannotConvertPercentToDouble | Cannot convert concentration percent ' [Percentage Value] ' to double value
CannotConvertTempToDouble | Cannot convert temperature '[Temperate Value]' to double value
CannotConvertToDouble | Cannot convert '[Text] ' to double value
UndefinedFluidUnit | Undefined fluid unit: '[Fluid Unit Type Name]'
UndefinedTemperatureUnit | Undefined temperature unit: '[Temperature Unit Type Name]'

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertPercentToDouble Property

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertPercentToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert concentration percent ' [Percentage Value] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertPercentToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertPercentToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertPercentToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertTempToDouble Property

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertTempToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert temperature '[Temperate Value]' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertTempToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertTempToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertTempToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


CannotConvertToDouble Property

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures..::..CannotConvertToDouble Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Cannot convert '[Text] ' to double value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertToDouble { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertToDouble As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertToDouble {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


UndefinedFluidUnit Property

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures..::..UndefinedFluidUnit Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Undefined fluid unit: '[Fluid Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidUnit { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


UndefinedTemperatureUnit Property

[image]

Revit 2013 API
BuiltInFailures..::..ConversionFailures..::..UndefinedTemperatureUnit Property
BuiltInFailures..::..ConversionFailures Class See Also Send Feedback
Undefined temperature unit: '[Temperature Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedTemperatureUnit { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedTemperatureUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedTemperatureUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ConversionFailures Class


BuiltInFailures.CopyMonitorFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CopyWatch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CopyMonitorFailures
Visual Basic
Public NotInheritable Class CopyMonitorFailures
Visual C++
public ref class CopyMonitorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CopyMonitorFailures

See Also

BuiltInFailures..::..CopyMonitorFailures Members


BuiltInFailures.CopyMonitorFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures Members
BuiltInFailures..::..CopyMonitorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::..CopyMonitorFailures Class


BuiltInFailures.CopyMonitorFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures Properties
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback

The BuiltInFailures..::..CopyMonitorFailures type exposes the following members.

Properties

Name | Description
AlreadyCopiedAndStopWatch | Element has already been copied. Stop existing monitoring to copy again.
AlreadyWatched | Elements already monitored.
CannotCopyCuttingInsert | Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.
CannotMoveHostedFixtureViaCopyMonitor | The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.
CopyWatchAlert | Coordination Monitor alert : [Description]
GridDeletedSameName | Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.
LevelDeletedSameName | Level cannot be copied because level with desired name '[Name]' already exist in a target document.

See Also

BuiltInFailures..::..CopyMonitorFailures Class


AlreadyCopiedAndStopWatch Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..AlreadyCopiedAndStopWatch Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Element has already been copied. Stop existing monitoring to copy again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyCopiedAndStopWatch { get; }
Visual Basic
Public Shared ReadOnly Property AlreadyCopiedAndStopWatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlreadyCopiedAndStopWatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


AlreadyWatched Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..AlreadyWatched Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Elements already monitored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyWatched { get; }
Visual Basic
Public Shared ReadOnly Property AlreadyWatched As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlreadyWatched {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


CannotCopyCuttingInsert Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..CannotCopyCuttingInsert Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Copy/Monitor does not support cutting inserts in floors. Some openings were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyCuttingInsert { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyCuttingInsert As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyCuttingInsert {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


CannotMoveHostedFixtureViaCopyMonitor Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..CannotMoveHostedFixtureViaCopyMonitor Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
The fixture is hosted and cannot be moved. Use the Move command to relocate the fixture in the host file as required.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveHostedFixtureViaCopyMonitor { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveHostedFixtureViaCopyMonitor As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveHostedFixtureViaCopyMonitor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


CopyWatchAlert Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..CopyWatchAlert Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Coordination Monitor alert : [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopyWatchAlert { get; }
Visual Basic
Public Shared ReadOnly Property CopyWatchAlert As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyWatchAlert {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


GridDeletedSameName Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..GridDeletedSameName Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Grid cannot be copied because grid with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridDeletedSameName { get; }
Visual Basic
Public Shared ReadOnly Property GridDeletedSameName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridDeletedSameName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


LevelDeletedSameName Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyMonitorFailures..::..LevelDeletedSameName Property
BuiltInFailures..::..CopyMonitorFailures Class See Also Send Feedback
Level cannot be copied because level with desired name '[Name]' already exist in a target document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LevelDeletedSameName { get; }
Visual Basic
Public Shared ReadOnly Property LevelDeletedSameName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LevelDeletedSameName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyMonitorFailures Class


BuiltInFailures.CopyPasteFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CopyPasteFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CopyPasteFailures
Visual Basic
Public NotInheritable Class CopyPasteFailures
Visual C++
public ref class CopyPasteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CopyPasteFailures

See Also

BuiltInFailures..::..CopyPasteFailures Members


BuiltInFailures.CopyPasteFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures Members
BuiltInFailures..::..CopyPasteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDependentViewWarn | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFaceHostedMonitoringElements | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFaceHostedMonitoringElementsWarn | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotCopyHostedLoadWarn | Can't copy Load based on the Host Element.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueViewport | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueViewportWarn | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyProfile | Can't copy Profile.
CannotCopyProfileWarn | Can't copy Profile.
CannotCopyReferencePlane | Can't copy reference plane.
CannotCopyReferencePlaneWarn | Can't copy reference plane.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteInViewError | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
PasteInvisibleInViewWarn | The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]

See Also

BuiltInFailures..::..CopyPasteFailures Class


BuiltInFailures.CopyPasteFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures Properties
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback

The BuiltInFailures..::..CopyPasteFailures type exposes the following members.

Properties

Name | Description
CannotCopyAttachedType | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyAttachedTypeWarn | Cannot copy attached detail group type without copying the model group type it refers to.
CannotCopyBetweenFamilyAndProjectCorruption | Can't copy between Family and Project.
CannotCopyBetweenFamilyAndProjectError | Can't copy between Family and Project.
CannotCopyCurtainWallGridLines | Curtain wall grid lines currently cannot be copied.
CannotCopyDependentView | Dependent views cannot be copied.
CannotCopyDependentViewWarn | Dependent views cannot be copied.
CannotCopyDetails | Can't copy some or all of the detailing with the view.
CannotCopyDuplicates | Can't paste duplicate types. Only non duplicate types will be pasted.
CannotCopyElevationArrow | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyElevationArrowWarn | To duplicate Elevations, copy the elevation symbol in a plan view.
CannotCopyFaceHostedMonitoringElements | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFaceHostedMonitoringElementsWarn | This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.
CannotCopyFamilyName | Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.
CannotCopyFromProjectAndLink | Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.
CannotCopyGridLines | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyGridLinesWarn | Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.
CannotCopyHostedLoad | Can't copy Load based on the Host Element.
CannotCopyHostedLoadWarn | Can't copy Load based on the Host Element.
CannotCopyImportInstancesAcrossProjects | Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.
CannotCopyIncompleteElement | Can't copy part of element
CannotCopyIncompleteElementWarn | Can't copy part of element
CannotCopyJoinedGeometry | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyJoinedGeometryWarn | Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.
CannotCopyLocked | Can't copy pinned element.
CannotCopyLockedWarn | Can't copy pinned element.
CannotCopyMassing | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMassingWarn | A massing cannot be copied. Copy the elements within the massing instead.
CannotCopyMullions | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsError | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMullionsWarn | Mullions and panels cannot be copied without copying the entire curtain wall.
CannotCopyMultipleSketchParents | Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.
CannotCopyMustBeUnique | Element must be unique.
CannotCopyMustBeUniqueViewport | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueViewportWarn | Multiple instances of the same view in sheets not supported.
CannotCopyMustBeUniqueWarn | Element must be unique.
CannotCopyNestedLinks | To copy a nested link, use Copy to Clipboard or Move Copy.
CannotCopyNoAttachedParent | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoAttachedParentWarn | Attached Detail Group can’t be copied without its Model Group
CannotCopyNoParents | Can't Copy to Clipboard because of relationships between Elements
CannotCopyNoReferences | Elements can't be copied because they will lose their References.
CannotCopyProfile | Can't copy Profile.
CannotCopyProfileWarn | Can't copy Profile.
CannotCopyReferencePlane | Can't copy reference plane.
CannotCopyReferencePlaneWarn | Can't copy reference plane.
CannotCopyRevolveAxis | The axis cannot be copied.
CannotCopyRevolveAxisWarn | The axis cannot be copied.
CannotCopySelectedPick | The element being dragged can't be copied.
CannotCopySelection | Cannot copy selection.[Description]
CannotCopySketchGrid | Work Planes cannot be copied.
CannotCopySketchGridWarn | Work Planes cannot be copied.
CannotCopySunAndShadowSettings | SunAndShadowSettings cannot be copied.
CannotCopySunAndShadowSettingsWarn | SunAndShadowSettings cannot be copied.
CannotCopyWallPanels | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyWallPanelsWarn | Cannot copy wall panels unless their parent wall is also being copied.
CannotCopyZone | A Zone cannot be copied.
CannotCopyZoneWarn | A Zone cannot be copied.
CannotDuplicate | Elements can't be duplicated
CannotDuplicateDesignOption | Can't duplicate Design Option.
CannotDuplicateInOption | Elements can't be duplicated in a secondary Option
CannotDuplicateInOptionWarn | Elements can't be duplicated in a secondary Option
CannotDuplicateType | Cannot Duplicate Type.
CannotDuplicateWarn | Elements can't be duplicated
CannotFinalizeClusterInconsistency | Can't finalize because dependent element failed to finalize.
CannotFinalizeOrphanSerf | Can't finalize Group member without finalizing the entire Group.
CannotPasteAlignedAny | Can't Paste Aligned.
CannotPasteAlignedCorruption | Can't Paste Aligned these elements in this view.
CannotPasteAlignedError | Can't Paste Align these elements in this view.
CannotPasteAlignedSomeLevels | Can't Paste Aligned to some views.
CannotPasteCircularLinks | The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.
CannotPasteCurtainGridLine | Can't paste Curtain Grid Line.
CannotPasteDifferentViewSpecificElements | Cannot paste view-specific elements from different views.
CannotPasteInSketch | Can't paste elements into sketch.
CannotPasteInView | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteInViewError | Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.
CannotPasteModelPlusViewSpecificElementsIntoView | Cannot paste view-specific model plus into view.
CannotPasteNoLevelAbove | Can't paste these elements at this height because there is no Level above to Reference.
CannotPasteNoLevelBelow | Can't paste these elements at this height because there is no Level below to reference.
CannotPasteNoWorkplane | Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.
CannotPasteToSheet | Elements copied to Sheets can only be copied from other Sheets.
CannotPasteViewSpecElemsFromDiffViews | Cannot paste view-specific elements from different views.
CannotTransferProjectStandards | These Project Standards cannot be transferred.[Description]
CantCopyBetweenModelAndAnnotFam | Can't copy element(s) between Model and Annotation families.
CantCopyElemsToInplaceFam | Can't copy element(s) to In Place family.
CantCopyFrom2dTo3dFam | Can't copy 2D element(s) into a 3D family.
CantCopyFrom3dTo2dFam | Can't copy 3D element(s) into a 2D family.
CantCopyFromDetailToProfileFam | Can't copy Detail element(s) into a Profile family.
CantCopyLevelsOrRefPlanesToNonMassFamily | Can't copy levels or reference planes to families that are not Mass families.
CopingColumnBeamFailure | The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.
CopyImposterContentError | Cannot copy Render Appearance.
CopyImposterContentWarn | Cannot copy Render Appearance.
CopyImposterLightError | Light source cannot be copied!
CopyImposterLightWarn | Light source cannot be copied!
ElementRenamedOnPaste | The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.
FinalizedElementsWillBeDeleted | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeDeletedWarn | Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModified | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
FinalizedElementsWillBeModifiedWarn | Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.
LostReference | A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].
NoSketchPlane | Can't paste because no Work Plane is defined in the View.
PasteInvisibleInView | Selection is invisible in this view.
PasteInvisibleInViewWarn | The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)
SomeElementsNotCopiedWarn | Some elements were not copied.[Description]

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyAttachedType Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyAttachedType Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedType { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyAttachedType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyAttachedTypeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyAttachedTypeWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy attached detail group type without copying the model group type it refers to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyAttachedTypeWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyAttachedTypeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyAttachedTypeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyBetweenFamilyAndProjectCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyBetweenFamilyAndProjectCorruption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyBetweenFamilyAndProjectError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyBetweenFamilyAndProjectError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy between Family and Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyBetweenFamilyAndProjectError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyBetweenFamilyAndProjectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyBetweenFamilyAndProjectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyCurtainWallGridLines Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyCurtainWallGridLines Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Curtain wall grid lines currently cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyCurtainWallGridLines { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyCurtainWallGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyCurtainWallGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDependentView Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDependentView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDependentView { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDependentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDependentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDependentViewWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDependentViewWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Dependent views cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDependentViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDependentViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDependentViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDetails Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDetails Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy some or all of the detailing with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDetails { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDetails As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDetails {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyDuplicates Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyDuplicates Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste duplicate types. Only non duplicate types will be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyDuplicates { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyDuplicates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyElevationArrow Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyElevationArrow Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrow { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyElevationArrow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyElevationArrowWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyElevationArrowWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
To duplicate Elevations, copy the elevation symbol in a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyElevationArrowWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyElevationArrowWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyElevationArrowWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFaceHostedMonitoringElements Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFaceHostedMonitoringElements Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFaceHostedMonitoringElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFaceHostedMonitoringElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFaceHostedMonitoringElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFaceHostedMonitoringElementsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFaceHostedMonitoringElementsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
This instance is face-hosted and being managed by copy/monitor, so it cannot be copy/pasted. Use create similar to place a new instance instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFaceHostedMonitoringElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFaceHostedMonitoringElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFaceHostedMonitoringElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFamilyName Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFamilyName Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't [Action] because Family '[Family Name]' is different in the two documents. Update the documents to contain the same version of the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFamilyName { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFamilyName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFamilyName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyFromProjectAndLink Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyFromProjectAndLink Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Copy to Clipboard elements from the project and a link instance at the same time. Only elements from the project will be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFromProjectAndLink { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFromProjectAndLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromProjectAndLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyGridLines Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyGridLines Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGridLines { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyGridLinesWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyGridLinesWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Curtain grid lines cannot be copied. If you are trying to copy the curtain wall, try using tab to select entire wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGridLinesWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyGridLinesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGridLinesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyHostedLoad Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyHostedLoad Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyHostedLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyHostedLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyHostedLoadWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyHostedLoadWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyHostedLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyHostedLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyHostedLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyImportInstancesAcrossProjects Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyImportInstancesAcrossProjects Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Linked Imported Files cannot be copied across projects. All non-RVT linked files will be pasted as imports instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyImportInstancesAcrossProjects { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyImportInstancesAcrossProjects As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyImportInstancesAcrossProjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyIncompleteElement Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyIncompleteElement Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyIncompleteElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyIncompleteElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyIncompleteElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyIncompleteElementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyIncompleteElementWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy part of element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyIncompleteElementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyIncompleteElementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyIncompleteElementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyJoinedGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyJoinedGeometry Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyJoinedGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyJoinedGeometryWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyJoinedGeometryWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Joined solid geometry cannot be copied as a whole. Instead, select the individual extrusions, etc., using Pick box or Ctrl-select and copy them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyJoinedGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyJoinedGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyJoinedGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyLocked Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyLocked Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyLockedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyLockedWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLockedWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyLockedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLockedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMassing Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMassing { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMassingWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMassingWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A massing cannot be copied. Copy the elements within the massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMassingWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMassingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMassingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullions Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullions Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullionsError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullionsError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullionsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMullionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMullionsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Mullions and panels cannot be copied without copying the entire curtain wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMullionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMullionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMullionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMultipleSketchParents Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMultipleSketchParents Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Copying elements from unrelated Workplanes together is not supported in families. Try copying elements separately.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMultipleSketchParents { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMultipleSketchParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMultipleSketchParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMustBeUnique Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMustBeUnique Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUnique { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMustBeUnique As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMustBeUniqueViewport Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMustBeUniqueViewport Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Multiple instances of the same view in sheets not supported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueViewport { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMustBeUniqueViewport As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueViewport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMustBeUniqueViewportWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMustBeUniqueViewportWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Multiple instances of the same view in sheets not supported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueViewportWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMustBeUniqueViewportWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueViewportWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyMustBeUniqueWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyMustBeUniqueWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Element must be unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyMustBeUniqueWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyMustBeUniqueWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyMustBeUniqueWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNestedLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNestedLinks Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
To copy a nested link, use Copy to Clipboard or Move Copy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNestedLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNestedLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNestedLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoAttachedParent Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoAttachedParent Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can’t be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParent { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoAttachedParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoAttachedParentWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoAttachedParentWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Attached Detail Group can’t be copied without its Model Group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoAttachedParentWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoAttachedParentWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoAttachedParentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoParents Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoParents Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Copy to Clipboard because of relationships between Elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoParents { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyNoReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyNoReferences Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be copied because they will lose their References.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyNoReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyNoReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyNoReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyProfile Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyProfile { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyProfileWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyProfileWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyProfileWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyProfileWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyProfileWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyReferencePlane Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyReferencePlane Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyReferencePlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyReferencePlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyReferencePlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyReferencePlaneWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyReferencePlaneWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyReferencePlaneWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyReferencePlaneWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyReferencePlaneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyRevolveAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyRevolveAxis Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxis { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyRevolveAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyRevolveAxisWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyRevolveAxisWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The axis cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyRevolveAxisWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyRevolveAxisWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyRevolveAxisWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySelectedPick Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySelectedPick Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The element being dragged can't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySelectedPick { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySelectedPick As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySelectedPick {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySelection Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySelection Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy selection.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySelection { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySelection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySketchGrid Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySketchGrid Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySketchGrid { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySketchGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySketchGridWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySketchGridWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Work Planes cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySketchGridWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySketchGridWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySketchGridWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySunAndShadowSettings Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySunAndShadowSettings Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySunAndShadowSettings { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySunAndShadowSettings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopySunAndShadowSettingsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopySunAndShadowSettingsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
SunAndShadowSettings cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopySunAndShadowSettingsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopySunAndShadowSettingsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopySunAndShadowSettingsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyWallPanels Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyWallPanels Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanels { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyWallPanels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyWallPanelsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyWallPanelsWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy wall panels unless their parent wall is also being copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyWallPanelsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyWallPanelsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyWallPanelsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyZone Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyZone Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyZone { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyZone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotCopyZoneWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotCopyZoneWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A Zone cannot be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyZoneWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyZoneWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyZoneWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicate Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicate Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicate { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateDesignOption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't duplicate Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateInOption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateInOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateInOptionWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated in a secondary Option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateInOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateInOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateType Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateType Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot Duplicate Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotDuplicateWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotDuplicateWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements can't be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotFinalizeClusterInconsistency Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotFinalizeClusterInconsistency Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't finalize because dependent element failed to finalize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinalizeClusterInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinalizeClusterInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeClusterInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotFinalizeOrphanSerf Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotFinalizeOrphanSerf Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't finalize Group member without finalizing the entire Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinalizeOrphanSerf { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinalizeOrphanSerf As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinalizeOrphanSerf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedAny Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedAny Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedAny { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedAny As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedAny {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedCorruption Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Align these elements in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedError { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteAlignedSomeLevels Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteAlignedSomeLevels Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't Paste Aligned to some views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteAlignedSomeLevels { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteAlignedSomeLevels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteAlignedSomeLevels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteCircularLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteCircularLinks Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The pasted selection includes a linked instance of this file '[Name]'. A file cannot link itself, so the link was not pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteCircularLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteCircularLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCircularLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteCurtainGridLine Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteCurtainGridLine Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste Curtain Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteCurtainGridLine { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteCurtainGridLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteCurtainGridLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteDifferentViewSpecificElements Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteDifferentViewSpecificElements Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteDifferentViewSpecificElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteDifferentViewSpecificElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteDifferentViewSpecificElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteInSketch Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste elements into sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInSketch { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteInView Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteInView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteInViewError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteInViewError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste current clipboard contents in [View Type] View. Switch to appropriate view to paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteModelPlusViewSpecificElementsIntoView Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteModelPlusViewSpecificElementsIntoView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific model plus into view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteModelPlusViewSpecificElementsIntoView { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteModelPlusViewSpecificElementsIntoView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteModelPlusViewSpecificElementsIntoView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteNoLevelAbove Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteNoLevelAbove Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste these elements at this height because there is no Level above to Reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoLevelAbove { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteNoLevelAbove As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoLevelAbove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteNoLevelBelow Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteNoLevelBelow Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste these elements at this height because there is no Level below to reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoLevelBelow { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteNoLevelBelow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoLevelBelow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteNoWorkplane Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteNoWorkplane Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste because there is no corresponding Work Plane. Set workplane or switch to view with appropriate workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteNoWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteNoWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteNoWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteToSheet Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteToSheet Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Elements copied to Sheets can only be copied from other Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteToSheet { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteToSheet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteToSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotPasteViewSpecElemsFromDiffViews Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotPasteViewSpecElemsFromDiffViews Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot paste view-specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteViewSpecElemsFromDiffViews { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteViewSpecElemsFromDiffViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteViewSpecElemsFromDiffViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CannotTransferProjectStandards Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CannotTransferProjectStandards Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
These Project Standards cannot be transferred.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotTransferProjectStandards { get; }
Visual Basic
Public Shared ReadOnly Property CannotTransferProjectStandards As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotTransferProjectStandards {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyBetweenModelAndAnnotFam Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyBetweenModelAndAnnotFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy element(s) between Model and Annotation families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyBetweenModelAndAnnotFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyBetweenModelAndAnnotFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyBetweenModelAndAnnotFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyElemsToInplaceFam Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyElemsToInplaceFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy element(s) to In Place family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyElemsToInplaceFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyElemsToInplaceFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyElemsToInplaceFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFrom2dTo3dFam Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFrom2dTo3dFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy 2D element(s) into a 3D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFrom2dTo3dFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFrom2dTo3dFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom2dTo3dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFrom3dTo2dFam Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFrom3dTo2dFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy 3D element(s) into a 2D family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFrom3dTo2dFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFrom3dTo2dFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFrom3dTo2dFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyFromDetailToProfileFam Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyFromDetailToProfileFam Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy Detail element(s) into a Profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyFromDetailToProfileFam { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyFromDetailToProfileFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyFromDetailToProfileFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CantCopyLevelsOrRefPlanesToNonMassFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CantCopyLevelsOrRefPlanesToNonMassFamily Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't copy levels or reference planes to families that are not Mass families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopyLevelsOrRefPlanesToNonMassFamily { get; }
Visual Basic
Public Shared ReadOnly Property CantCopyLevelsOrRefPlanesToNonMassFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopyLevelsOrRefPlanesToNonMassFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopingColumnBeamFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CopingColumnBeamFailure Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The support order for a beam/column connection has been changed. When a beam is supported by a column that same beam cannot be coped by the column. The existing coping has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopingColumnBeamFailure { get; }
Visual Basic
Public Shared ReadOnly Property CopingColumnBeamFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopingColumnBeamFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterContentError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterContentError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterContentError { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterContentError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterContentWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterContentWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Cannot copy Render Appearance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterContentWarn { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterContentWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterContentWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterLightError Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterLightError Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Light source cannot be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterLightError { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterLightError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterLightError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


CopyImposterLightWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..CopyImposterLightWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Light source cannot be copied!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CopyImposterLightWarn { get; }
Visual Basic
Public Shared ReadOnly Property CopyImposterLightWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CopyImposterLightWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


ElementRenamedOnPaste Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..ElementRenamedOnPaste Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The loaded type "[Name]" has been renamed to "[New Name]" to avoid conflicts with the existing type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementRenamedOnPaste { get; }
Visual Basic
Public Shared ReadOnly Property ElementRenamedOnPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementRenamedOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeDeleted Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeDeletedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeDeletedWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find new hosts for this Element.\nIt will be deleted on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeDeletedWarn { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeDeletedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeDeletedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeModified Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeModified Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeModified { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


FinalizedElementsWillBeModifiedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..FinalizedElementsWillBeModifiedWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't find some new hosts for this Element.\nIt will lose references on Finish Paste unless repositioned or rehosted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FinalizedElementsWillBeModifiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property FinalizedElementsWillBeModifiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FinalizedElementsWillBeModifiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


LostReference Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..LostReference Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
A relationship between Elements in [Option Name] and [Reference Option Name] has been deleted. There is no corresponding relationship in the Primary [New Primary Option Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LostReference { get; }
Visual Basic
Public Shared ReadOnly Property LostReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LostReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


NoSketchPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..NoSketchPlane Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Can't paste because no Work Plane is defined in the View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSketchPlane { get; }
Visual Basic
Public Shared ReadOnly Property NoSketchPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


PasteInvisibleInView Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..PasteInvisibleInView Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Selection is invisible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PasteInvisibleInView { get; }
Visual Basic
Public Shared ReadOnly Property PasteInvisibleInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PasteInvisibleInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


PasteInvisibleInViewWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..PasteInvisibleInViewWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
The selection can’t be pasted because it is not visible in this view. Common causes and solutions The category is not visible in this view (make category visible) An annotation element falls outside this view’s annotation crop (temporarily disable annotation cropping) The element tagged by an annotation is not visible (check view extents and depth)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PasteInvisibleInViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property PasteInvisibleInViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PasteInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


SomeElementsNotCopiedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CopyPasteFailures..::..SomeElementsNotCopiedWarn Property
BuiltInFailures..::..CopyPasteFailures Class See Also Send Feedback
Some elements were not copied.[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeElementsNotCopiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property SomeElementsNotCopiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeElementsNotCopiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CopyPasteFailures Class


BuiltInFailures.CreationFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CreationFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CreationFailures
Visual Basic
Public NotInheritable Class CreationFailures
Visual C++
public ref class CreationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CreationFailures

See Also

BuiltInFailures..::..CreationFailures Members


BuiltInFailures.CreationFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CreationFailures Members
BuiltInFailures..::..CreationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CreationFailures type exposes the following members.

Properties

Name | Description
CannotCreateCornerFinish | Could not create Corner Finish.
CannotCreateCornerFinishError | Could not create Corner Finish.
CannotCreateCornerFinishWarn | Could not create Corner Finish.
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateHostFinish | Can't create Host Finish.
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Cannot create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeWall | Can't make Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

See Also

BuiltInFailures..::..CreationFailures Class


BuiltInFailures.CreationFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CreationFailures Properties
BuiltInFailures..::..CreationFailures Class See Also Send Feedback

The BuiltInFailures..::..CreationFailures type exposes the following members.

Properties

Name | Description
CannotCreateCornerFinish | Could not create Corner Finish.
CannotCreateCornerFinishError | Could not create Corner Finish.
CannotCreateCornerFinishWarn | Could not create Corner Finish.
CannotCreateCornice | Could not create Wall Sweep. [Description]
CannotCreateCorniceError | Could not create Wall Sweep. [Description]
CannotCreateCorniceIntegral | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralError | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceIntegralWarn | Could not create integral wall sweep for wall instance. [Description]
CannotCreateCorniceWarn | Could not create Wall Sweep. [Description]
CannotCreateCurtainGrid | Can't create Curtain Wall Grid Line.
CannotCreateCutout | Can't make cut-out.
CannotCreateCutoutError | Can't make cut-out.
CannotCreateCutoutWarn | Can't make cut-out.
CannotCreateElementInFamily | Can't create element in this family.
CannotCreateElementInView | Can't create this kind of element in this view in the current mode.
CannotCreateExplicitCrease | Cannot create a new split line based on the picked support.
CannotCreateFascia | Could not create Fascia. [Description]
CannotCreateFasciaError | Could not create Fascia. [Description]
CannotCreateFasciaWarn | Could not create Fascia. [Description]
CannotCreateGutter | Could not create Gutter. [Description]
CannotCreateGutterError | Could not create Gutter. [Description]
CannotCreateGutterWarn | Could not create Gutter. [Description]
CannotCreateHostFinish | Can't create Host Finish.
CannotCreateMullion | Can't create Mullion.
CannotCreateMullionError | Can't create Mullion.
CannotCreateMullionReference | Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.
CannotCreateMullionReferenceNoGeometry | Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.
CannotCreateNewDesignOption | Cannot create a new empty design option
CannotCreateOldCornerMullion | Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.
CannotCreateOpening | Cannot create opening.
CannotCreateOpeningCutOut | Can't create Opening cut.
CannotCreateOpeningRectangularArcWall | Creation of a Rectangular Arc Wall Opening failed.
CannotCreateReveal | Could not create Reveal. [Description]
CannotCreateRevealError | Could not create Reveal. [Description]
CannotCreateRevealIntegral | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralError | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealIntegralWarn | Could not create integral reveal for wall instance. [Description]
CannotCreateRevealWarn | Could not create Reveal. [Description]
CannotCreateSlabEdge | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeError | Could not create Slab Edge. [Description]
CannotCreateSlabEdgeWarn | Could not create Slab Edge. [Description]
CannotCreateSystemPanel | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateThis | Can't create [Element].
CannotDrawProfileRoof | Can't make footprint roof.
CannotDrawRoof | Can't make roof.
CannotDrawRoofError | Can't make roof.
CannotDrawRoofWall | Can't make roof.
CannotDrawWalls | Can't make Wall.
CannotDrawWallsError | Can't make Wall.
CannotMakeRoofFromVerticalFace | Can't make roof from vertical face.
CannotMakeRoofFromVerticalFaceError | Can't make roof from vertical face.
CannotMakeSurface | Can't construct surface.
CannotMakeSurfaceError | Can't construct surface.
CannotMakeSurfaceWarn | Can't construct surface.
CannotMakeWall | Can't make Wall.
SwitchFromLegendBeforeCreateSimilar | To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCornerFinish Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCornerFinish Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinish { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerFinish As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinish {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCornerFinishError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCornerFinishError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinishError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerFinishError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinishError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCornerFinishWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCornerFinishWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Corner Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerFinishWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerFinishWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerFinishWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCornice Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCornice Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornice { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornice As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegral Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegral Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegral { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegral As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegralError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegralError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceIntegralWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceIntegralWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral wall sweep for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceIntegralWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceIntegralWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCorniceWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCorniceWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Wall Sweep. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCorniceWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCorniceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCorniceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCurtainGrid Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCurtainGrid Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainGrid { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCutout Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCutout Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutout { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCutout As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutout {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCutoutError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCutoutError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutoutError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCutoutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutoutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateCutoutWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateCutoutWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCutoutWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCutoutWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCutoutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateElementInFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateElementInFamily Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create element in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateElementInFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateElementInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateElementInView Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateElementInView Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create this kind of element in this view in the current mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateElementInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateElementInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateElementInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateExplicitCrease Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateExplicitCrease Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create a new split line based on the picked support.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateExplicitCrease { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateExplicitCrease As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateExplicitCrease {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFascia Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFascia Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFascia { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFascia As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFascia {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFasciaError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFasciaError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFasciaError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateFasciaWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateFasciaWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Fascia. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateFasciaWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateFasciaWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateFasciaWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateGutter Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateGutter Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutter { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGutter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateGutterError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateGutterError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutterError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGutterError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutterError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateGutterWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateGutterWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Gutter. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGutterWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGutterWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGutterWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateHostFinish Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateHostFinish Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Host Finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateHostFinish { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateHostFinish As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateHostFinish {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullion Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullion Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullionError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullionError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullionReference Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullionReference Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Curtain Wall Mullion. The grid segment for the Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReference { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullionReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateMullionReferenceNoGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateMullionReferenceNoGeometry Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can’t create Curtain Wall Mullion. The portion of the curtain grid it was placed on no longer exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMullionReferenceNoGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMullionReferenceNoGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMullionReferenceNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateNewDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateNewDesignOption Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create a new empty design option

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateNewDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateNewDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNewDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOldCornerMullion Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOldCornerMullion Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot change the type of a mullion created prior to release 4.0 to a corner mullion type. Try deleting the existing mullion and placing a new one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOldCornerMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOldCornerMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOldCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOpening Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOpening Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Cannot create opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpening { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOpeningCutOut Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOpeningCutOut Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Opening cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpeningCutOut { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpeningCutOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpeningCutOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateOpeningRectangularArcWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateOpeningRectangularArcWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Creation of a Rectangular Arc Wall Opening failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpeningRectangularArcWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpeningRectangularArcWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpeningRectangularArcWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateReveal Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateReveal Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateReveal { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateReveal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateReveal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegral Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegral Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegral { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegral As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegral {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegralError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegralError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealIntegralWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealIntegralWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create integral reveal for wall instance. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealIntegralWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealIntegralWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealIntegralWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateRevealWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateRevealWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Reveal. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRevealWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRevealWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRevealWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlabEdge Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlabEdge Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdge { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlabEdge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlabEdgeError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlabEdgeError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlabEdgeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSlabEdgeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSlabEdgeWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Could not create Slab Edge. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSlabEdgeWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSlabEdgeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSlabEdgeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateSystemPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateSystemPanel Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSystemPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSystemPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSystemPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotCreateThis Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotCreateThis Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't create [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateThis { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateThis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateThis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawProfileRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawProfileRoof Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoof Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoofError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoofError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawRoofWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawRoofWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRoofWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRoofWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRoofWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawWalls Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawWalls Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawWalls { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawWalls As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotDrawWallsError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotDrawWallsError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawWallsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawWallsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawWallsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeRoofFromVerticalFace Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeRoofFromVerticalFace Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFace { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeRoofFromVerticalFaceError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeRoofFromVerticalFaceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make roof from vertical face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoofFromVerticalFaceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoofFromVerticalFaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoofFromVerticalFaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurface Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurface Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurfaceError Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurfaceError Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurfaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeSurfaceWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeSurfaceWarn Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurfaceWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurfaceWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurfaceWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


CannotMakeWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..CannotMakeWall Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
Can't make Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


SwitchFromLegendBeforeCreateSimilar Property

[image]

Revit 2013 API
BuiltInFailures..::..CreationFailures..::..SwitchFromLegendBeforeCreateSimilar Property
BuiltInFailures..::..CreationFailures Class See Also Send Feedback
To Create Similar from a Legend View, first select the element, then activate the target view, then invoke Create Similar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SwitchFromLegendBeforeCreateSimilar { get; }
Visual Basic
Public Shared ReadOnly Property SwitchFromLegendBeforeCreateSimilar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SwitchFromLegendBeforeCreateSimilar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CreationFailures Class


BuiltInFailures.CurtainGridFamilyFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainGrid Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CurtainGridFamilyFailures
Visual Basic
Public NotInheritable Class CurtainGridFamilyFailures
Visual C++
public ref class CurtainGridFamilyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurtainGridFamilyFailures

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Members


BuiltInFailures.CurtainGridFamilyFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures Members
BuiltInFailures..::..CurtainGridFamilyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
EnterValueBetween | Please enter a value between [Value] and [Value].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


BuiltInFailures.CurtainGridFamilyFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures Properties
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

The BuiltInFailures..::..CurtainGridFamilyFailures type exposes the following members.

Properties

Name | Description
AllMullionsAreTooShort | The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.
CannotCreateCornerMullionDueAngle | Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.
CannotCreateCurtainPanelCorruption | Can't create Curtain Panel. A Panel or a Mullion is probably too small.
CannotCreateCurtainPanelError |
CannotCreateCurtainPanelInOpeningCorruption | Can't create Curtain Panel in opening. The opening is probably too small.
CannotCreateCurtainPanelInOpeningWarning |
CannotGenerateAllNecessaryElements | Unable to regenerate all necessary elements.
CannotPlaceSystemMullionFamilyOnCurtainWall | Can't place System Mullion Family on this Curtain Wall.
CannotPlaceSystemPanelsInOldArcedCurtainWalls | Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.
CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion | Corner Mullion overlaps Mullion placed on neighboring Curtain region.
CornerMullionsNeighborsMustBeTangent | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainPanelNotBelongsToElement | Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.
CurtainPanelsParamDefinedTypeDefinedCirculary | Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.
CurtainSystemCouldnotReacquireFaces | Curtain System could not reacquire [Number] faces out of [Number].
EnterValueBetween | Please enter a value between [Value] and [Value].
InvalidCurtainPanelInModel | There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.
MullionProfileContainsMoreThanOneOrOpenLoop | The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.
NonSystemPanelFamiliesCannotBeUsed | Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.
PanelsSlightlyMalformedCorruption | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
PanelsSlightlyMalformedWarning | Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).
SomeMullionsAreTooShort | Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


AllMullionsAreTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..AllMullionsAreTooShort Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
The mullion(s) you are trying to place is too short for his type, and was not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllMullionsAreTooShort { get; }
Visual Basic
Public Shared ReadOnly Property AllMullionsAreTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCornerMullionDueAngle Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCornerMullionDueAngle Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Corner Mullion due to the angle between the neighboring panels. Try changing the Parameters in the Curtain Wall Mullion Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerMullionDueAngle { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerMullionDueAngle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerMullionDueAngle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelCorruption Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel. A Panel or a Mullion is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelError Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelError Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelInOpeningCorruption Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't create Curtain Panel in opening. The opening is probably too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotCreateCurtainPanelInOpeningWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotCreateCurtainPanelInOpeningWarning Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCurtainPanelInOpeningWarning { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCurtainPanelInOpeningWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCurtainPanelInOpeningWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotGenerateAllNecessaryElements Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotGenerateAllNecessaryElements Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Unable to regenerate all necessary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateAllNecessaryElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateAllNecessaryElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateAllNecessaryElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotPlaceSystemMullionFamilyOnCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotPlaceSystemMullionFamilyOnCurtainWall Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Mullion Family on this Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemMullionFamilyOnCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSystemMullionFamilyOnCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemMullionFamilyOnCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CannotPlaceSystemPanelsInOldArcedCurtainWalls Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CannotPlaceSystemPanelsInOldArcedCurtainWalls Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Can't place System Panels in arced Curtain Walls created prior to 3.0, nor in straight Curtain Walls created prior to version 2.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSystemPanelsInOldArcedCurtainWalls { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSystemPanelsInOldArcedCurtainWalls As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSystemPanelsInOldArcedCurtainWalls {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullion overlaps Mullion placed on neighboring Curtain region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion { get; }
Visual Basic
Public Shared ReadOnly Property CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CornerMullionOverlapsOtherOnePlacedOnNeighboringRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CornerMullionsNeighborsMustBeTangent Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CornerMullionsNeighborsMustBeTangent Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CornerMullionsNeighborsMustBeTangent { get; }
Visual Basic
Public Shared ReadOnly Property CornerMullionsNeighborsMustBeTangent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CornerMullionsNeighborsMustBeTangent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CurtainPanelNotBelongsToElement Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CurtainPanelNotBelongsToElement Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Curtain element Panel doesn't belong to Curtain element. In merging, you must select the version of a Curtain element that has had Panels added to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainPanelNotBelongsToElement { get; }
Visual Basic
Public Shared ReadOnly Property CurtainPanelNotBelongsToElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelNotBelongsToElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CurtainPanelsParamDefinedTypeDefinedCirculary Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CurtainPanelsParamDefinedTypeDefinedCirculary Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and default panel type will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainPanelsParamDefinedTypeDefinedCirculary { get; }
Visual Basic
Public Shared ReadOnly Property CurtainPanelsParamDefinedTypeDefinedCirculary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainPanelsParamDefinedTypeDefinedCirculary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


CurtainSystemCouldnotReacquireFaces Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..CurtainSystemCouldnotReacquireFaces Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Curtain System could not reacquire [Number] faces out of [Number].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainSystemCouldnotReacquireFaces { get; }
Visual Basic
Public Shared ReadOnly Property CurtainSystemCouldnotReacquireFaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainSystemCouldnotReacquireFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


EnterValueBetween Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..EnterValueBetween Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueBetween { get; }
Visual Basic
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


InvalidCurtainPanelInModel Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..InvalidCurtainPanelInModel Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
There is an invalid Curtain Panel in the model. This is probably caused by two Grid Lines almost meeting at a border of the Curtain Wall or Sloped Glazing, but not exactly at a point. The Curtain Panel can't be displayed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCurtainPanelInModel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCurtainPanelInModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCurtainPanelInModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


MullionProfileContainsMoreThanOneOrOpenLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..MullionProfileContainsMoreThanOneOrOpenLoop Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
The selected mullion profile either contains more than one profile loop or an open profile loop and cannot be used. Valid profiles can only have a single continuous closed profile loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MullionProfileContainsMoreThanOneOrOpenLoop { get; }
Visual Basic
Public Shared ReadOnly Property MullionProfileContainsMoreThanOneOrOpenLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MullionProfileContainsMoreThanOneOrOpenLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


NonSystemPanelFamiliesCannotBeUsed Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..NonSystemPanelFamiliesCannotBeUsed Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Non-system panel families cannot be used for non-rectangular panels. If your panel is simple, create an appropriate panel type derived from the system panel family. If not, try making the panel in the wall or roof rectangular, and then using a panel family of the desired (non-rectangular) shape. The wall will then conform to the non-rectangular shape of the panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonSystemPanelFamiliesCannotBeUsed { get; }
Visual Basic
Public Shared ReadOnly Property NonSystemPanelFamiliesCannotBeUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonSystemPanelFamiliesCannotBeUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


PanelsSlightlyMalformedCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..PanelsSlightlyMalformedCorruption Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelsSlightlyMalformedCorruption { get; }
Visual Basic
Public Shared ReadOnly Property PanelsSlightlyMalformedCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


PanelsSlightlyMalformedWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..PanelsSlightlyMalformedWarning Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Some panels in this curtain system are slightly malformed. The problem is most likely ignorable. This problem usually occurs when a panel or parts of a panel have been divided so that they are very narrow. To better see the malformed panels, temporarily hide the mullion category and set display of lines to ""thin lines"" (using the command on the view menu).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelsSlightlyMalformedWarning { get; }
Visual Basic
Public Shared ReadOnly Property PanelsSlightlyMalformedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelsSlightlyMalformedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


SomeMullionsAreTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainGridFamilyFailures..::..SomeMullionsAreTooShort Property
BuiltInFailures..::..CurtainGridFamilyFailures Class See Also Send Feedback
Some of the mullions you are trying to place are too short for its types, and were not placed on the grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeMullionsAreTooShort { get; }
Visual Basic
Public Shared ReadOnly Property SomeMullionsAreTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeMullionsAreTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainGridFamilyFailures Class


BuiltInFailures.CurtainWallFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about CurtainWall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CurtainWallFailures
Visual Basic
Public NotInheritable Class CurtainWallFailures
Visual C++
public ref class CurtainWallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurtainWallFailures

See Also

BuiltInFailures..::..CurtainWallFailures Members


BuiltInFailures.CurtainWallFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures Members
BuiltInFailures..::..CurtainWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::..CurtainWallFailures Class


BuiltInFailures.CurtainWallFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures Properties
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback

The BuiltInFailures..::..CurtainWallFailures type exposes the following members.

Properties

Name | Description
AdjustEndCurtainWallParameterNoCorners | Can't put Corner Mullion at end joined to non-Curtain Wall.
AllGridSegmentsRemoved | Curtain grid lines must have at least one segment.
CannotApplyGridSpecification | It is not possible to apply the host family's grid specification to this instance.
CannotDivideCurtainGrid | Can't divide Curtain Grid by Grid Line.
CannotGroupCurtainGridHost | Curtain grid based elements cannot be grouped.
CannotHaveIndependentOverlappingGrids | Overlapping independent type associated gridlines are not allowed.
CannotPlaceSplitMullions | Could not determine how to place the highlighted mullions after the wall was split.
CannotSplitOldMullions | Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.
CannotSwitchToCurtainWall | Can't switch type to Curtain Wall after Edit Elevation Profile.
CannotUseCornerMullion | Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.
CurtainGridFaceCannotBeReparamForGridRotation | Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.
CurtainGridOffHost | Curtain grid has left its host.
CurtainSystemHostInvisible | Element defining the Curtain System is invisible in the current view.
DanglingCurtainWallCorner | A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.
DeletingCurtainSystemFaceGridLines | Deleting Grid Lines residing on faces that no longer are part of a Curtain System.
DependentGridlineMayBeDeleted | Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.
ExceedMaxDrivenGridlines | Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.
ExessiveBeltDistance | The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.
GridlinesOutOfBounds | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutOfBoundsWarn | Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.
GridlinesOutsideWillBeRedependent | Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.
GridlinesOverlap | Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.
GridlinesWerePushed | Panels and mullions created by a curtain grid were created with slight inaccuracies.
GridOutOfOrder | Curtain wall grid lines have changed order.
GridOutOfOrderError | Curtain wall grid lines have changed order.
GridOutsideWall | Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.
InvalidSkipSegments | A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.
MullionLostRefReorder | Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.
MullionsWillBeDeleted | The Mullions between the Panels being joined will be deleted.
MultipleDominatingMullions | Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.
MultipleIdsInCurtainSystem | A Curtain System cannot be based on faces from multiple elements.
MustReplacePanels | Missing Curtain Panels will be replaced with System Panels to complete command.
NegativeBeltDistance | Measurement Line Offset cannot be negative.
NonSupportedCurtainWall | Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.
NoPanelsLoaded | No Curtain Panel Families loaded. Can't make arced Curtain Wall.
RequestOrphanMullionDeletion | Due to the changes in parameters of their hosts some mullions became non-type driven.
RuledCurtainElementLostCurves | Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.
TypePanelsFronNonRectCellsUnlocked | Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

See Also

BuiltInFailures..::..CurtainWallFailures Class


AdjustEndCurtainWallParameterNoCorners Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..AdjustEndCurtainWallParameterNoCorners Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Can't put Corner Mullion at end joined to non-Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AdjustEndCurtainWallParameterNoCorners { get; }
Visual Basic
Public Shared ReadOnly Property AdjustEndCurtainWallParameterNoCorners As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdjustEndCurtainWallParameterNoCorners {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


AllGridSegmentsRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..AllGridSegmentsRemoved Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grid lines must have at least one segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllGridSegmentsRemoved { get; }
Visual Basic
Public Shared ReadOnly Property AllGridSegmentsRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllGridSegmentsRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotApplyGridSpecification Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotApplyGridSpecification Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
It is not possible to apply the host family's grid specification to this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotApplyGridSpecification { get; }
Visual Basic
Public Shared ReadOnly Property CannotApplyGridSpecification As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotApplyGridSpecification {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotDivideCurtainGrid Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotDivideCurtainGrid Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Can't divide Curtain Grid by Grid Line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDivideCurtainGrid { get; }
Visual Basic
Public Shared ReadOnly Property CannotDivideCurtainGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDivideCurtainGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotGroupCurtainGridHost Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotGroupCurtainGridHost Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grid based elements cannot be grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGroupCurtainGridHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotGroupCurtainGridHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGroupCurtainGridHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotHaveIndependentOverlappingGrids Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotHaveIndependentOverlappingGrids Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Overlapping independent type associated gridlines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveIndependentOverlappingGrids { get; }
Visual Basic
Public Shared ReadOnly Property CannotHaveIndependentOverlappingGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotHaveIndependentOverlappingGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotPlaceSplitMullions Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotPlaceSplitMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Could not determine how to place the highlighted mullions after the wall was split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceSplitMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceSplitMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceSplitMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotSplitOldMullions Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotSplitOldMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Split does not work on curtain walls containing mullions created in Revit prior to version 4.0. You may delete the mullions, place them again, and then proceed with splitting the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitOldMullions { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitOldMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitOldMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotSwitchToCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotSwitchToCurtainWall Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Can't switch type to Curtain Wall after Edit Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSwitchToCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotSwitchToCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSwitchToCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CannotUseCornerMullion Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CannotUseCornerMullion Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Corner Mullions must be placed at a location that can have neighboring Panels that are not tangent. With the exception of Wall Join locations, Corner Mullions are not currently supported on the external boundaries of Curtain elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUseCornerMullion { get; }
Visual Basic
Public Shared ReadOnly Property CannotUseCornerMullion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUseCornerMullion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CurtainGridFaceCannotBeReparamForGridRotation Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CurtainGridFaceCannotBeReparamForGridRotation Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grids cannot be rotated exactly as requested. Push "Adjust Grids" to get the nearest valid rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainGridFaceCannotBeReparamForGridRotation { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridFaceCannotBeReparamForGridRotation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainGridFaceCannotBeReparamForGridRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CurtainGridOffHost Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CurtainGridOffHost Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain grid has left its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainGridOffHost { get; }
Visual Basic
Public Shared ReadOnly Property CurtainGridOffHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainGridOffHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


CurtainSystemHostInvisible Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..CurtainSystemHostInvisible Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Element defining the Curtain System is invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurtainSystemHostInvisible { get; }
Visual Basic
Public Shared ReadOnly Property CurtainSystemHostInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurtainSystemHostInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


DanglingCurtainWallCorner Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..DanglingCurtainWallCorner Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
A Corner Mullion has been placed at the end of a Curtain Wall that is not joined to another Curtain Wall. The angle of the Corner Mullion will default to 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DanglingCurtainWallCorner { get; }
Visual Basic
Public Shared ReadOnly Property DanglingCurtainWallCorner As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DanglingCurtainWallCorner {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


DeletingCurtainSystemFaceGridLines Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..DeletingCurtainSystemFaceGridLines Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Deleting Grid Lines residing on faces that no longer are part of a Curtain System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingCurtainSystemFaceGridLines { get; }
Visual Basic
Public Shared ReadOnly Property DeletingCurtainSystemFaceGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingCurtainSystemFaceGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


DependentGridlineMayBeDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..DependentGridlineMayBeDeleted Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Type generated gridlines will become non-associated due to changes in the type. Press delete if you wish to remove them instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DependentGridlineMayBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property DependentGridlineMayBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DependentGridlineMayBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


ExceedMaxDrivenGridlines Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..ExceedMaxDrivenGridlines Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Changes have been made that cause a curtain wall with type driven grid lines to exceed the maximum allowed number of type driven lines (200 in direction (1) and 200 in direction (2)). If you really need this many type driven grid lines, please split the affected wall before proceeding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExceedMaxDrivenGridlines { get; }
Visual Basic
Public Shared ReadOnly Property ExceedMaxDrivenGridlines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExceedMaxDrivenGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


ExessiveBeltDistance Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..ExessiveBeltDistance Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
The requested Measurement Line Offset would place the put the Measurement Line of the face boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExessiveBeltDistance { get; }
Visual Basic
Public Shared ReadOnly Property ExessiveBeltDistance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExessiveBeltDistance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOutOfBounds Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOutOfBounds Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBounds { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOutOfBounds As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBounds {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOutOfBoundsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOutOfBoundsWarn Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Manually placed curtain grid lines are on the wall edges or outside the wall boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutOfBoundsWarn { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOutOfBoundsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutOfBoundsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOutsideWillBeRedependent Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOutsideWillBeRedependent Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Type associated curtain grid lines outside of the edited wall boundaries will be made dependent again in order that they remain on the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOutsideWillBeRedependent { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOutsideWillBeRedependent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOutsideWillBeRedependent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesOverlap Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Overlapping gridlines should be avoided, unless there are only two and one is host type dependent and the other is not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridlinesWerePushed Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridlinesWerePushed Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Panels and mullions created by a curtain grid were created with slight inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlinesWerePushed { get; }
Visual Basic
Public Shared ReadOnly Property GridlinesWerePushed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlinesWerePushed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutOfOrder Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutOfOrder Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutOfOrder { get; }
Visual Basic
Public Shared ReadOnly Property GridOutOfOrder As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutOfOrderError Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutOfOrderError Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines have changed order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutOfOrderError { get; }
Visual Basic
Public Shared ReadOnly Property GridOutOfOrderError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutOfOrderError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


GridOutsideWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..GridOutsideWall Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Curtain wall grid lines are outside wall. If you are trying to shorten the wall, please remove grid lines, including mullions on top of them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridOutsideWall { get; }
Visual Basic
Public Shared ReadOnly Property GridOutsideWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridOutsideWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


InvalidSkipSegments Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..InvalidSkipSegments Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
A curtain grid line had invalid removed segment data. When correcting data, Revit may have split curtain panels that should be combined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSkipSegments { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSkipSegments As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSkipSegments {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MullionLostRefReorder Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..MullionLostRefReorder Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Mullions have lost references as a result of gridlines changing order. These mullions must be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MullionLostRefReorder { get; }
Visual Basic
Public Shared ReadOnly Property MullionLostRefReorder As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MullionLostRefReorder {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MullionsWillBeDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..MullionsWillBeDeleted Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
The Mullions between the Panels being joined will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MullionsWillBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property MullionsWillBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MullionsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MultipleDominatingMullions Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..MultipleDominatingMullions Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Multiple dominating mullions on a grid face may cause ambiguous automatic adjustment of margins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleDominatingMullions { get; }
Visual Basic
Public Shared ReadOnly Property MultipleDominatingMullions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleDominatingMullions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MultipleIdsInCurtainSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..MultipleIdsInCurtainSystem Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
A Curtain System cannot be based on faces from multiple elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleIdsInCurtainSystem { get; }
Visual Basic
Public Shared ReadOnly Property MultipleIdsInCurtainSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleIdsInCurtainSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


MustReplacePanels Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..MustReplacePanels Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Missing Curtain Panels will be replaced with System Panels to complete command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MustReplacePanels { get; }
Visual Basic
Public Shared ReadOnly Property MustReplacePanels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustReplacePanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


NegativeBeltDistance Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..NegativeBeltDistance Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Measurement Line Offset cannot be negative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NegativeBeltDistance { get; }
Visual Basic
Public Shared ReadOnly Property NegativeBeltDistance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NegativeBeltDistance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


NonSupportedCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..NonSupportedCurtainWall Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Currently, only straight Walls with straight or arc edges are supported for non-rectangular Curtain Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonSupportedCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property NonSupportedCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonSupportedCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


NoPanelsLoaded Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..NoPanelsLoaded Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
No Curtain Panel Families loaded. Can't make arced Curtain Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoPanelsLoaded { get; }
Visual Basic
Public Shared ReadOnly Property NoPanelsLoaded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPanelsLoaded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


RequestOrphanMullionDeletion Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..RequestOrphanMullionDeletion Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Due to the changes in parameters of their hosts some mullions became non-type driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RequestOrphanMullionDeletion { get; }
Visual Basic
Public Shared ReadOnly Property RequestOrphanMullionDeletion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RequestOrphanMullionDeletion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


RuledCurtainElementLostCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..RuledCurtainElementLostCurves Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Ruled Curtain System cannot be built. The Lines or Edges used to create it cannot be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RuledCurtainElementLostCurves { get; }
Visual Basic
Public Shared ReadOnly Property RuledCurtainElementLostCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RuledCurtainElementLostCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


TypePanelsFronNonRectCellsUnlocked Property

[image]

Revit 2013 API
BuiltInFailures..::..CurtainWallFailures..::..TypePanelsFronNonRectCellsUnlocked Property
BuiltInFailures..::..CurtainWallFailures Class See Also Send Feedback
Loaded family curtain panels cannot be used in non-rectangular cells of the curtain host. Type-driven panels from non-rectangular cells were unlocked and left unchanged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TypePanelsFronNonRectCellsUnlocked { get; }
Visual Basic
Public Shared ReadOnly Property TypePanelsFronNonRectCellsUnlocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TypePanelsFronNonRectCellsUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurtainWallFailures Class


BuiltInFailures.CurveByPointFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CurveByPointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Curve By Point Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CurveByPointFailures
Visual Basic
Public NotInheritable Class CurveByPointFailures
Visual C++
public ref class CurveByPointFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurveByPointFailures

See Also

BuiltInFailures..::..CurveByPointFailures Members


BuiltInFailures.CurveByPointFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurveByPointFailures Members
BuiltInFailures..::..CurveByPointFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurveByPointFailures type exposes the following members.

Properties

Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

See Also

BuiltInFailures..::..CurveByPointFailures Class


BuiltInFailures.CurveByPointFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurveByPointFailures Properties
BuiltInFailures..::..CurveByPointFailures Class See Also Send Feedback

The BuiltInFailures..::..CurveByPointFailures type exposes the following members.

Properties

Name | Description
UnableToGenerateCurve | Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

See Also

BuiltInFailures..::..CurveByPointFailures Class


UnableToGenerateCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveByPointFailures..::..UnableToGenerateCurve Property
BuiltInFailures..::..CurveByPointFailures Class See Also Send Feedback
Unable to generate valid curve geometry from the driving points. The line by points will be dissolved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToGenerateCurve { get; }
Visual Basic
Public Shared ReadOnly Property UnableToGenerateCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToGenerateCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveByPointFailures Class


BuiltInFailures.CurveFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Curves and Curve-Driven Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CurveFailures
Visual Basic
Public NotInheritable Class CurveFailures
Visual C++
public ref class CurveFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CurveFailures

See Also

BuiltInFailures..::..CurveFailures Members


BuiltInFailures.CurveFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurveFailures Members
BuiltInFailures..::..CurveFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.

See Also

BuiltInFailures..::..CurveFailures Class


BuiltInFailures.CurveFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CurveFailures Properties
BuiltInFailures..::..CurveFailures Class See Also Send Feedback

The BuiltInFailures..::..CurveFailures type exposes the following members.

Properties

Name | Description
CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary.
CurveNotEditable | Lines created by massing or picking 3d path are not editable.
CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable.
InvalidCurveForElement | End positions are invalid.
LineTooShortError | Line is too short.
LineTooShortWarning | Line is too short.
PeriodicCurveBadParams | End positions are invalid.
SelfIntersectingSpline | Self intersecting splines are not allowed in sketches.
TooShort | Line is too short.

See Also

BuiltInFailures..::..CurveFailures Class


CannotFindAreaScheme Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..CannotFindAreaScheme Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Can't find new Area Scheme for Area Boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindAreaScheme { get; }
Visual Basic
Public Shared ReadOnly Property CannotFindAreaScheme As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFindAreaScheme {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


CurveNotEditable Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..CurveNotEditable Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveNotEditable { get; }
Visual Basic
Public Shared ReadOnly Property CurveNotEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


CurveNotEditableWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..CurveNotEditableWarn Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Lines created by massing or picking 3d path are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveNotEditableWarn { get; }
Visual Basic
Public Shared ReadOnly Property CurveNotEditableWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveNotEditableWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


InvalidCurveForElement Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..InvalidCurveForElement Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCurveForElement { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCurveForElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCurveForElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


LineTooShortError Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..LineTooShortError Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LineTooShortError { get; }
Visual Basic
Public Shared ReadOnly Property LineTooShortError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineTooShortError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


LineTooShortWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..LineTooShortWarning Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LineTooShortWarning { get; }
Visual Basic
Public Shared ReadOnly Property LineTooShortWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineTooShortWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


PeriodicCurveBadParams Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..PeriodicCurveBadParams Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
End positions are invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PeriodicCurveBadParams { get; }
Visual Basic
Public Shared ReadOnly Property PeriodicCurveBadParams As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PeriodicCurveBadParams {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


SelfIntersectingSpline Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..SelfIntersectingSpline Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Self intersecting splines are not allowed in sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SelfIntersectingSpline { get; }
Visual Basic
Public Shared ReadOnly Property SelfIntersectingSpline As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelfIntersectingSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


TooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..CurveFailures..::..TooShort Property
BuiltInFailures..::..CurveFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooShort { get; }
Visual Basic
Public Shared ReadOnly Property TooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CurveFailures Class


BuiltInFailures.CutFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CutFailures
Visual Basic
Public NotInheritable Class CutFailures
Visual C++
public ref class CutFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CutFailures

See Also

BuiltInFailures..::..CutFailures Members


BuiltInFailures.CutFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CutFailures Members
BuiltInFailures..::..CutFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CutFailures type exposes the following members.

Properties

Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutHostFinishOut | Cannot cut Host Finish out.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.

See Also

BuiltInFailures..::..CutFailures Class


BuiltInFailures.CutFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CutFailures Properties
BuiltInFailures..::..CutFailures Class See Also Send Feedback

The BuiltInFailures..::..CutFailures type exposes the following members.

Properties

Name | Description
CannotCutGeometry | Elements do not intersect.
CannotCutGeometryWarn | Elements do not intersect.
CannotCutHostFinishOut | Cannot cut Host Finish out.
CannotCutInstanceOut | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutError | Can't cut instance of [Symbol] out of Wall.
CannotCutInstanceOutGen | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenError | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutGenWarn | Can't cut instance(s) of [Symbol] out of its host.
CannotCutInstanceOutWarn | Can't cut instance of [Symbol] out of Wall.
CannotCutJoinedElement | Can't cut joined element.
CannotCutRoof | The roof couldn't be cut.
CannotCutRoofError | The roof couldn't be cut.
CantCutHostWithInstance | Can't cut host with instance.
CutExactlyHalf | Can't cut in half. Move plane towards either end.
CutoutNotCuttingAnything | Opening not cutting anything.
CutoutNotCuttingAnythingDeleteOpening | Opening not cutting anything.
DormerCutProblem | Dormer Opening Cut is not fully defined. Cut was not performed.
DormerCutProblemWarn | Dormer Opening Cut is not fully defined. Cut was not performed.
HostCutoutForInsertionFailure | Can't cut host for inserted objects
InstanceNotCuttingAnything | Instance(s) of [Symbol] not cutting anything.

See Also

BuiltInFailures..::..CutFailures Class


CannotCutGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutGeometry Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutGeometryWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutGeometryWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Elements do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutHostFinishOut Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutHostFinishOut Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Cannot cut Host Finish out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutHostFinishOut { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutHostFinishOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutHostFinishOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOut Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOut Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOut { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutError Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGen Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGen Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGen { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGen As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGenError Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGenError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGenError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutGenWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutGenWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance(s) of [Symbol] out of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutGenWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutGenWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutGenWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutInstanceOutWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutInstanceOutWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut instance of [Symbol] out of Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutInstanceOutWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutInstanceOutWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutInstanceOutWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutJoinedElement Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutJoinedElement Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutJoinedElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutJoinedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutRoof Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CannotCutRoofError Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CannotCutRoofError Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
The roof couldn't be cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CantCutHostWithInstance Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CantCutHostWithInstance Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut host with instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCutHostWithInstance { get; }
Visual Basic
Public Shared ReadOnly Property CantCutHostWithInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCutHostWithInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutExactlyHalf Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CutExactlyHalf Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut in half. Move plane towards either end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CutExactlyHalf { get; }
Visual Basic
Public Shared ReadOnly Property CutExactlyHalf As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutExactlyHalf {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutoutNotCuttingAnything Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CutoutNotCuttingAnything Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnything { get; }
Visual Basic
Public Shared ReadOnly Property CutoutNotCuttingAnything As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


CutoutNotCuttingAnythingDeleteOpening Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..CutoutNotCuttingAnythingDeleteOpening Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Opening not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CutoutNotCuttingAnythingDeleteOpening { get; }
Visual Basic
Public Shared ReadOnly Property CutoutNotCuttingAnythingDeleteOpening As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CutoutNotCuttingAnythingDeleteOpening {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


DormerCutProblem Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..DormerCutProblem Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DormerCutProblem { get; }
Visual Basic
Public Shared ReadOnly Property DormerCutProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


DormerCutProblemWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..DormerCutProblemWarn Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Dormer Opening Cut is not fully defined. Cut was not performed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DormerCutProblemWarn { get; }
Visual Basic
Public Shared ReadOnly Property DormerCutProblemWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DormerCutProblemWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


HostCutoutForInsertionFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..HostCutoutForInsertionFailure Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Can't cut host for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostCutoutForInsertionFailure { get; }
Visual Basic
Public Shared ReadOnly Property HostCutoutForInsertionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


InstanceNotCuttingAnything Property

[image]

Revit 2013 API
BuiltInFailures..::..CutFailures..::..InstanceNotCuttingAnything Property
BuiltInFailures..::..CutFailures Class See Also Send Feedback
Instance(s) of [Symbol] not cutting anything.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InstanceNotCuttingAnything { get; }
Visual Basic
Public Shared ReadOnly Property InstanceNotCuttingAnything As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstanceNotCuttingAnything {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutFailures Class


BuiltInFailures.CutterFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CutterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CutterFailures
Visual Basic
Public NotInheritable Class CutterFailures
Visual C++
public ref class CutterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CutterFailures

See Also

BuiltInFailures..::..CutterFailures Members


BuiltInFailures.CutterFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CutterFailures Members
BuiltInFailures..::..CutterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::..CutterFailures Class


BuiltInFailures.CutterFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CutterFailures Properties
BuiltInFailures..::..CutterFailures Class See Also Send Feedback

The BuiltInFailures..::..CutterFailures type exposes the following members.

Properties

Name | Description
MakeCutterForPlanRegionsGStepFailed | Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.
MakeCutterForSectionGStepFailed | Attempt to create or manipulate a segmented section has failed.

See Also

BuiltInFailures..::..CutterFailures Class


MakeCutterForPlanRegionsGStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..CutterFailures..::..MakeCutterForPlanRegionsGStepFailed Property
BuiltInFailures..::..CutterFailures Class See Also Send Feedback
Failed to make cutter for plan view with plan regions. Try deleting one or more plan regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MakeCutterForPlanRegionsGStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property MakeCutterForPlanRegionsGStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForPlanRegionsGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutterFailures Class


MakeCutterForSectionGStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..CutterFailures..::..MakeCutterForSectionGStepFailed Property
BuiltInFailures..::..CutterFailures Class See Also Send Feedback
Attempt to create or manipulate a segmented section has failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MakeCutterForSectionGStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property MakeCutterForSectionGStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MakeCutterForSectionGStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CutterFailures Class


BuiltInFailures.CuttingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Cutting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class CuttingFailures
Visual Basic
Public NotInheritable Class CuttingFailures
Visual C++
public ref class CuttingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..CuttingFailures

See Also

BuiltInFailures..::..CuttingFailures Members


BuiltInFailures.CuttingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures Members
BuiltInFailures..::..CuttingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::..CuttingFailures Class


BuiltInFailures.CuttingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures Properties
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback

The BuiltInFailures..::..CuttingFailures type exposes the following members.

Properties

Name | Description
CannotCopyFromMultipleLinks | Elements cannot be copied from multiple links at the same time.
ElementsWithNotCopiedParentsDeleted | Some elements were deleted because elements that they require for references were not copied.
NoFileSaved | No file has been saved.
NoSupported2DElementsToCopyFromView | None of the elements in the view you have selected are supported for the insert 2D operation.
UnableToCopyElementsFromFile | Unable to copy elements from file.
UnableToPasteToFile | Unable to paste current clipboard contents to file.
UnableToReplaceWithLink | Selected elements were copied to new file but Revit was unable to replace them with link to that file.

See Also

BuiltInFailures..::..CuttingFailures Class


CannotCopyFromMultipleLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..CannotCopyFromMultipleLinks Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Elements cannot be copied from multiple links at the same time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyFromMultipleLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyFromMultipleLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyFromMultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


ElementsWithNotCopiedParentsDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..ElementsWithNotCopiedParentsDeleted Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Some elements were deleted because elements that they require for references were not copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWithNotCopiedParentsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsWithNotCopiedParentsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsWithNotCopiedParentsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


NoFileSaved Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..NoFileSaved Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
No file has been saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFileSaved { get; }
Visual Basic
Public Shared ReadOnly Property NoFileSaved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFileSaved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


NoSupported2DElementsToCopyFromView Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..NoSupported2DElementsToCopyFromView Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
None of the elements in the view you have selected are supported for the insert 2D operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSupported2DElementsToCopyFromView { get; }
Visual Basic
Public Shared ReadOnly Property NoSupported2DElementsToCopyFromView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSupported2DElementsToCopyFromView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


UnableToCopyElementsFromFile Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..UnableToCopyElementsFromFile Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Unable to copy elements from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCopyElementsFromFile { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCopyElementsFromFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCopyElementsFromFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


UnableToPasteToFile Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..UnableToPasteToFile Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Unable to paste current clipboard contents to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToPasteToFile { get; }
Visual Basic
Public Shared ReadOnly Property UnableToPasteToFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToPasteToFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


UnableToReplaceWithLink Property

[image]

Revit 2013 API
BuiltInFailures..::..CuttingFailures..::..UnableToReplaceWithLink Property
BuiltInFailures..::..CuttingFailures Class See Also Send Feedback
Selected elements were copied to new file but Revit was unable to replace them with link to that file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToReplaceWithLink { get; }
Visual Basic
Public Shared ReadOnly Property UnableToReplaceWithLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToReplaceWithLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..CuttingFailures Class


BuiltInFailures.DatumPlaneFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DatumPlaneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DatumPlane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DatumPlaneFailures
Visual Basic
Public NotInheritable Class DatumPlaneFailures
Visual C++
public ref class DatumPlaneFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DatumPlaneFailures

See Also

BuiltInFailures..::..DatumPlaneFailures Members


BuiltInFailures.DatumPlaneFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DatumPlaneFailures Members
BuiltInFailures..::..DatumPlaneFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DatumPlaneFailures type exposes the following members.

Properties

Name | Description
ScopeBoxWrongPosition | The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

See Also

BuiltInFailures..::..DatumPlaneFailures Class


BuiltInFailures.DatumPlaneFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DatumPlaneFailures Properties
BuiltInFailures..::..DatumPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::..DatumPlaneFailures type exposes the following members.

Properties

Name | Description
ScopeBoxWrongPosition | The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

See Also

BuiltInFailures..::..DatumPlaneFailures Class


ScopeBoxWrongPosition Property

[image]

Revit 2013 API
BuiltInFailures..::..DatumPlaneFailures..::..ScopeBoxWrongPosition Property
BuiltInFailures..::..DatumPlaneFailures Class See Also Send Feedback
The Highlighted Datum cannot be associated with the specified Scope Box because the Datum plane does not intersect the Scope Box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ScopeBoxWrongPosition { get; }
Visual Basic
Public Shared ReadOnly Property ScopeBoxWrongPosition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ScopeBoxWrongPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DatumPlaneFailures Class


BuiltInFailures.DebugTabBindingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DebugTabBindingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to binding framework demo panel on Ribbon Debug Tab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DebugTabBindingFailures
Visual Basic
Public NotInheritable Class DebugTabBindingFailures
Visual C++
public ref class DebugTabBindingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DebugTabBindingFailures

See Also

BuiltInFailures..::..DebugTabBindingFailures Members


BuiltInFailures.DebugTabBindingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DebugTabBindingFailures Members
BuiltInFailures..::..DebugTabBindingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DebugTabBindingFailures type exposes the following members.

Properties

Name | Description
OptionValueOutOfRange | Value out of range for Options enum.

See Also

BuiltInFailures..::..DebugTabBindingFailures Class


BuiltInFailures.DebugTabBindingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DebugTabBindingFailures Properties
BuiltInFailures..::..DebugTabBindingFailures Class See Also Send Feedback

The BuiltInFailures..::..DebugTabBindingFailures type exposes the following members.

Properties

Name | Description
OptionValueOutOfRange | Value out of range for Options enum.

See Also

BuiltInFailures..::..DebugTabBindingFailures Class


OptionValueOutOfRange Property

[image]

Revit 2013 API
BuiltInFailures..::..DebugTabBindingFailures..::..OptionValueOutOfRange Property
BuiltInFailures..::..DebugTabBindingFailures Class See Also Send Feedback
Value out of range for Options enum.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionValueOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property OptionValueOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DebugTabBindingFailures Class


BuiltInFailures.DecalFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DecalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Decal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DecalFailures
Visual Basic
Public NotInheritable Class DecalFailures
Visual C++
public ref class DecalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DecalFailures

See Also

BuiltInFailures..::..DecalFailures Members


BuiltInFailures.DecalFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DecalFailures Members
BuiltInFailures..::..DecalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::..DecalFailures Class


BuiltInFailures.DecalFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DecalFailures Properties
BuiltInFailures..::..DecalFailures Class See Also Send Feedback

The BuiltInFailures..::..DecalFailures type exposes the following members.

Properties

Name | Description
CannotPaste | Can't place Decal at new position.
LongerThanPossible | Decal element is longer than the circumference of the surface.
OutsideHost | Decal does not lie on host.

See Also

BuiltInFailures..::..DecalFailures Class


CannotPaste Property

[image]

Revit 2013 API
BuiltInFailures..::..DecalFailures..::..CannotPaste Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Can't place Decal at new position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPaste { get; }
Visual Basic
Public Shared ReadOnly Property CannotPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


LongerThanPossible Property

[image]

Revit 2013 API
BuiltInFailures..::..DecalFailures..::..LongerThanPossible Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Decal element is longer than the circumference of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LongerThanPossible { get; }
Visual Basic
Public Shared ReadOnly Property LongerThanPossible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LongerThanPossible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


OutsideHost Property

[image]

Revit 2013 API
BuiltInFailures..::..DecalFailures..::..OutsideHost Property
BuiltInFailures..::..DecalFailures Class See Also Send Feedback
Decal does not lie on host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OutsideHost { get; }
Visual Basic
Public Shared ReadOnly Property OutsideHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutsideHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DecalFailures Class


BuiltInFailures.DesignOptionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DesignOptionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DesignOptionFailures
Visual Basic
Public NotInheritable Class DesignOptionFailures
Visual C++
public ref class DesignOptionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DesignOptionFailures

See Also

BuiltInFailures..::..DesignOptionFailures Members


BuiltInFailures.DesignOptionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures Members
BuiltInFailures..::..DesignOptionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutLinkedRoomInOption | Linked Rooms must be in the Main Model
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::..DesignOptionFailures Class


BuiltInFailures.DesignOptionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures Properties
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback

The BuiltInFailures..::..DesignOptionFailures type exposes the following members.

Properties

Name | Description
AreaTagLineCannotBeInDesignOption | Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.
BadReferenceBetweenOptions | An element may not reference an element in another Option of the same Option Set.
BadReferenceBetweenOptionsWarn | An element may not reference an element in another Option of the same Option Set.
BadReferenceToSecondary | No element in a secondary Option can be referenced by an element outside that Option.
BadReferenceToSecondaryWarn | No element in a secondary Option can be referenced by an element outside that Option.
CannotAddToOptions | Elements can't be added to Option Set
CannotAddToOptionsWarn | Elements can't be added to Option Set
CannotPutLinkedRoomInOption | Linked Rooms must be in the Main Model
CannotPutSpaceInOption | MEP space must be in the Main Model
CannotPutZoneInOption | HVAC Zones must be in the Main Model.
ConfusingHostByElementsInAnotherDesignOption | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInAnotherDesignOptionWarn | An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOption | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInDesignOptionWarn | An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModel | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingHostByElementsInMainModelWarn | An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOption | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInAnotherDesignOptionWarn | A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOption | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInDesignOptionWarn | A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModel | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingPadByElementsInMainModelWarn | A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOption | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInAnotherDesignOptionWarn | A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOption | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInDesignOptionWarn | A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModel | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
ConfusingSweepByElementsInMainModelWarn | A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].
DebugLevelsInOptionsError | This is an internal diagnostic message.
DebugLevelsInOptionsWarn | This is an internal diagnostic message.
ElementsWillBeDeletedNoOption | Elements will be deleted
KingNeverInOption | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
KingNeverInOptionWarn | A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.
MustAddKing | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustAddKingWarn | In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set
MustBeInMainModel | Element must be in Main Model
NeverInOption | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NeverInOptionWarn | Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.
NoSelectedInOption | None of the selected elements can be added to this Option Set. The following warnings provide additional information.
OptionElementsDeleted | Elements in [option] were deleted
SelectionIncludesOptionItems | Elements that were already in a Design Option were selected. These will not be added to the Option Set.

See Also

BuiltInFailures..::..DesignOptionFailures Class


AreaTagLineCannotBeInDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..AreaTagLineCannotBeInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Areas and Area Boundaries are not allowed in Design Options. Make an Area Scheme and an Area Plan for this Option then draw all Areas and Area Boundaries in that view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaTagLineCannotBeInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property AreaTagLineCannotBeInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaTagLineCannotBeInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceBetweenOptions Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceBetweenOptions Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceBetweenOptions { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceBetweenOptions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceBetweenOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceBetweenOptionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceBetweenOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An element may not reference an element in another Option of the same Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceBetweenOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceBetweenOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceBetweenOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceToSecondary Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceToSecondary Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondary { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceToSecondary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BadReferenceToSecondaryWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..BadReferenceToSecondaryWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
No element in a secondary Option can be referenced by an element outside that Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadReferenceToSecondaryWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadReferenceToSecondaryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadReferenceToSecondaryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotAddToOptions Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..CannotAddToOptions Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToOptions { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToOptions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotAddToOptionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..CannotAddToOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements can't be added to Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutLinkedRoomInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutLinkedRoomInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Linked Rooms must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutLinkedRoomInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutLinkedRoomInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutLinkedRoomInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutSpaceInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutSpaceInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
MEP space must be in the Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutSpaceInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutSpaceInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutSpaceInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


CannotPutZoneInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..CannotPutZoneInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
HVAC Zones must be in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPutZoneInOption { get; }
Visual Basic
Public Shared ReadOnly Property CannotPutZoneInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPutZoneInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInMainModel Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingHostByElementsInMainModelWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingHostByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
An insert in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingHostByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingHostByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingHostByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a Design Option cannot be hosted by a topography in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in the main model cannot be hosted by topography in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInMainModel Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingPadByElementsInMainModelWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingPadByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A pad in a design option cannot be hosted by topography in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingPadByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingPadByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingPadByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInAnotherDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInAnotherDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInAnotherDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a Design Option cannot be hosted by an element in another Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInAnotherDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInAnotherDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInAnotherDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInDesignOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInDesignOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOption { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInDesignOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInDesignOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in the main model cannot be hosted by an element in a Design Option [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInDesignOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInDesignOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInDesignOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInMainModel Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ConfusingSweepByElementsInMainModelWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ConfusingSweepByElementsInMainModelWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A sweep in a design option cannot be hosted by an element in the Main Model [--if you continue it will not be added to the design option set].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConfusingSweepByElementsInMainModelWarn { get; }
Visual Basic
Public Shared ReadOnly Property ConfusingSweepByElementsInMainModelWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConfusingSweepByElementsInMainModelWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


DebugLevelsInOptionsError Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..DebugLevelsInOptionsError Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
This is an internal diagnostic message.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DebugLevelsInOptionsError { get; }
Visual Basic
Public Shared ReadOnly Property DebugLevelsInOptionsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DebugLevelsInOptionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


DebugLevelsInOptionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..DebugLevelsInOptionsWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
This is an internal diagnostic message.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DebugLevelsInOptionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DebugLevelsInOptionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DebugLevelsInOptionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


ElementsWillBeDeletedNoOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..ElementsWillBeDeletedNoOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWillBeDeletedNoOption { get; }
Visual Basic
Public Shared ReadOnly Property ElementsWillBeDeletedNoOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsWillBeDeletedNoOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


KingNeverInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..KingNeverInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId KingNeverInOption { get; }
Visual Basic
Public Shared ReadOnly Property KingNeverInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ KingNeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


KingNeverInOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..KingNeverInOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
A selected "[Serf]" belongs to a "[King]" which cannot be added to an Option--it was not added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId KingNeverInOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property KingNeverInOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ KingNeverInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustAddKing Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..MustAddKing Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MustAddKing { get; }
Visual Basic
Public Shared ReadOnly Property MustAddKing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustAddKing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustAddKingWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..MustAddKingWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
In order to add this '[Serf]' to the Option Set, you must also add its '[King]'--if you continue it will not be added to the Option Set

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MustAddKingWarn { get; }
Visual Basic
Public Shared ReadOnly Property MustAddKingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustAddKingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


MustBeInMainModel Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..MustBeInMainModel Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Element must be in Main Model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MustBeInMainModel { get; }
Visual Basic
Public Shared ReadOnly Property MustBeInMainModel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MustBeInMainModel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


NeverInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..NeverInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NeverInOption { get; }
Visual Basic
Public Shared ReadOnly Property NeverInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeverInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


NeverInOptionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..NeverInOptionWarn Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Some types of elements can't belong to an Option. Elements of these types were not added to this Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NeverInOptionWarn { get; }
Visual Basic
Public Shared ReadOnly Property NeverInOptionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeverInOptionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


NoSelectedInOption Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..NoSelectedInOption Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
None of the selected elements can be added to this Option Set. The following warnings provide additional information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSelectedInOption { get; }
Visual Basic
Public Shared ReadOnly Property NoSelectedInOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSelectedInOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


OptionElementsDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..OptionElementsDeleted Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements in [option] were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property OptionElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


SelectionIncludesOptionItems Property

[image]

Revit 2013 API
BuiltInFailures..::..DesignOptionFailures..::..SelectionIncludesOptionItems Property
BuiltInFailures..::..DesignOptionFailures Class See Also Send Feedback
Elements that were already in a Design Option were selected. These will not be added to the Option Set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SelectionIncludesOptionItems { get; }
Visual Basic
Public Shared ReadOnly Property SelectionIncludesOptionItems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelectionIncludesOptionItems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DesignOptionFailures Class


BuiltInFailures.DetailFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DetailFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DetailFailures
Visual Basic
Public NotInheritable Class DetailFailures
Visual C++
public ref class DetailFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DetailFailures

See Also

BuiltInFailures..::..DetailFailures Members


BuiltInFailures.DetailFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DetailFailures Members
BuiltInFailures..::..DetailFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::..DetailFailures Class


BuiltInFailures.DetailFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DetailFailures Properties
BuiltInFailures..::..DetailFailures Class See Also Send Feedback

The BuiltInFailures..::..DetailFailures type exposes the following members.

Properties

Name | Description
EavesAreAligned | All eaves are already aligned.
NeedsTwoToAlignEaves | At least two Slope Defining Lines are needed to perform Align Eaves.
RepeatingDetailSpacingZeroError | Spacing must be greater than 0

See Also

BuiltInFailures..::..DetailFailures Class


EavesAreAligned Property

[image]

Revit 2013 API
BuiltInFailures..::..DetailFailures..::..EavesAreAligned Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
All eaves are already aligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EavesAreAligned { get; }
Visual Basic
Public Shared ReadOnly Property EavesAreAligned As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EavesAreAligned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


NeedsTwoToAlignEaves Property

[image]

Revit 2013 API
BuiltInFailures..::..DetailFailures..::..NeedsTwoToAlignEaves Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
At least two Slope Defining Lines are needed to perform Align Eaves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NeedsTwoToAlignEaves { get; }
Visual Basic
Public Shared ReadOnly Property NeedsTwoToAlignEaves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeedsTwoToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


RepeatingDetailSpacingZeroError Property

[image]

Revit 2013 API
BuiltInFailures..::..DetailFailures..::..RepeatingDetailSpacingZeroError Property
BuiltInFailures..::..DetailFailures Class See Also Send Feedback
Spacing must be greater than 0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RepeatingDetailSpacingZeroError { get; }
Visual Basic
Public Shared ReadOnly Property RepeatingDetailSpacingZeroError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RepeatingDetailSpacingZeroError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DetailFailures Class


BuiltInFailures.DimensionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DimensionFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DimensionFailures
Visual Basic
Public NotInheritable Class DimensionFailures
Visual C++
public ref class DimensionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DimensionFailures

See Also

BuiltInFailures..::..DimensionFailures Members


BuiltInFailures.DimensionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures Members
BuiltInFailures..::..DimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::..DimensionFailures Class


BuiltInFailures.DimensionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures Properties
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback

The BuiltInFailures..::..DimensionFailures type exposes the following members.

Properties

Name | Description
AngularDimensionRegenFailed | Can't form Angular Dimension.
ArcAlignmentRegenFailed | Can't form arc alignment.
ArcLengthDimensionNoReferencesOnArc | None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.
ArcLengthDimensionReferencesNotIntersect | One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.
AssocpropNeedJog | Need to add jog in order to satisfy constraints
CannotConstrainBasePointAlignments | Alignments to base points cannot be constrained.
CannotConstrainBasePointDimensions | Dimensions to base points cannot be constrained.
CannotCreateDimensionNotParallel | Can't create dimension. Highlighted references are not parallel to first selection.
CannotDragWitnessLine | Moving the Witness Line conflicts with other Constraints in the Sketch.
CannotLockThisDimension | Can't lock this Dimension because it breaks formulas
CannotToggleDimensionEquality | Toggling the dimension's equality constraint would overconstrain the sketch.
ChangeDimensionSegmentFailed | Can't change dimension segment to this value.
ChangeSpotElevationFailed | Can't change Spot Elevation to the desired value.
DimensionOverconstrained | The Dimension would overconstrain the Sketch.
DimensionOverconstrainedError | The Dimension would overconstrain the Sketch.
DimensionOverrideNearByIsLost | The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]
DimensionPerpendicularToView | The Dimension is perpendicular to the current view, and no longer valid.
DimensionReferencesInvalid | One or more dimension references are or have become invalid.
DimensionUnequaled | Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.
DimensionUnlocked | Dimension had to be un-EQed in order to remove sketch over-constraining.
DimensionUnlockedAndUnequaled | Dimension had to be unlocked in order to remove sketch over-constraining.
EqualityConstraintsUnsatisfied | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
EqualityConstraintsUnsatisfiedWarn | Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.
ForbiddenGroupConstraint | You may not create sketch or family constraints between group members and elements which are not members of the same group.
LabelOverconstrained | Labeling this dimension would overconstrain the sketch.
LinearConstraintBadDirection | Bad direction vector in dimension element.
LinearConstraintNotParallel | The References of the highlighted Dimension are no longer parallel.
LinearDimensionReferenceNotOrthogonalToView | The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.
LockOverconstrained | Locking this dimension would overconstrain the sketch.
LockOverconstrainedAlignment | Locking this alignment would overconstrain the sketch.
LooseLabeledDimensionRegenFailure | Failed to Regenerate Family
NoConstraintsInProperSketch | You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.
NoConstraintsToLinks | Constraints may not be created to linked instances using Shared Locations.
RadialDimensionCannotProjectToArc | Cannot form radial dimension.
RadialDimensionChangeRadiusFailed | Can't change radius.
RegenConstraintUnsatisfied | Constraints are not satisfied
RegenConstraintUnsatisfiedWarn | Constraints are not satisfied
SomeDimensionsLostOnPaste | Some Dimensions were not copied because some References were lost.
SomeDimensionsLostWitnessLines | Some Dimensions lost some of their References on paste.
SomeSpotDimensionsLostOnPaste | Some Spot Dimensions were not copied because some References were lost.
SpotDimensionFloatingPointError | Some spot dimensions contain invalid floating-point values.
SpotDimensionFormerSetMoribundCall | One or more Spot Dimension references are no longer valid.
SpotDimensionReferencesNoLongerHorizontal | One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.
SpotElevationLostEdgeReferences | Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.
SpotElevationMissesReference | Spot Dimension does not lie on its reference.
SpotSlopeReferenceIsVertical | The highlighted Spot Slope references an element that is vertical.
SpotSlopeReferencePointIsSingular | The highlighted Spot Slope references an element point that is singular.
WrongConstraintInGridChainSketch | Curve in a GridChain sketch cannot be constrained to a sub-grid
WrongConstraintInJoistSystemSketch | Structural Beam System sketch can't be constrained to its beam.
WrongConstraintInSkeletonSketch | Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.
WrongConstraintInTrussSketch | Structural Truss sketch can't be constrained to its members.

See Also

BuiltInFailures..::..DimensionFailures Class


AngularDimensionRegenFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..AngularDimensionRegenFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't form Angular Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AngularDimensionRegenFailed { get; }
Visual Basic
Public Shared ReadOnly Property AngularDimensionRegenFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AngularDimensionRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ArcAlignmentRegenFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ArcAlignmentRegenFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't form arc alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArcAlignmentRegenFailed { get; }
Visual Basic
Public Shared ReadOnly Property ArcAlignmentRegenFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcAlignmentRegenFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ArcLengthDimensionNoReferencesOnArc Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ArcLengthDimensionNoReferencesOnArc Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
None of the segment references of this Arc Length Dimension intersects the bounded arc of the arc reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArcLengthDimensionNoReferencesOnArc { get; }
Visual Basic
Public Shared ReadOnly Property ArcLengthDimensionNoReferencesOnArc As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcLengthDimensionNoReferencesOnArc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ArcLengthDimensionReferencesNotIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ArcLengthDimensionReferencesNotIntersect Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more dimension references of this Arc Length dimension no longer intersect the circle needed for arc length computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArcLengthDimensionReferencesNotIntersect { get; }
Visual Basic
Public Shared ReadOnly Property ArcLengthDimensionReferencesNotIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcLengthDimensionReferencesNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


AssocpropNeedJog Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..AssocpropNeedJog Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Need to add jog in order to satisfy constraints

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AssocpropNeedJog { get; }
Visual Basic
Public Shared ReadOnly Property AssocpropNeedJog As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AssocpropNeedJog {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotConstrainBasePointAlignments Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotConstrainBasePointAlignments Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Alignments to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointAlignments { get; }
Visual Basic
Public Shared ReadOnly Property CannotConstrainBasePointAlignments As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointAlignments {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotConstrainBasePointDimensions Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotConstrainBasePointDimensions Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimensions to base points cannot be constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConstrainBasePointDimensions { get; }
Visual Basic
Public Shared ReadOnly Property CannotConstrainBasePointDimensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConstrainBasePointDimensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotCreateDimensionNotParallel Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotCreateDimensionNotParallel Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't create dimension. Highlighted references are not parallel to first selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateDimensionNotParallel { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateDimensionNotParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateDimensionNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotDragWitnessLine Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotDragWitnessLine Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Moving the Witness Line conflicts with other Constraints in the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDragWitnessLine { get; }
Visual Basic
Public Shared ReadOnly Property CannotDragWitnessLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDragWitnessLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotLockThisDimension Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotLockThisDimension Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't lock this Dimension because it breaks formulas

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLockThisDimension { get; }
Visual Basic
Public Shared ReadOnly Property CannotLockThisDimension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLockThisDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


CannotToggleDimensionEquality Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..CannotToggleDimensionEquality Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Toggling the dimension's equality constraint would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotToggleDimensionEquality { get; }
Visual Basic
Public Shared ReadOnly Property CannotToggleDimensionEquality As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotToggleDimensionEquality {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ChangeDimensionSegmentFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ChangeDimensionSegmentFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change dimension segment to this value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ChangeDimensionSegmentFailed { get; }
Visual Basic
Public Shared ReadOnly Property ChangeDimensionSegmentFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangeDimensionSegmentFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ChangeSpotElevationFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ChangeSpotElevationFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change Spot Elevation to the desired value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ChangeSpotElevationFailed { get; }
Visual Basic
Public Shared ReadOnly Property ChangeSpotElevationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangeSpotElevationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionOverconstrained Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The Dimension would overconstrain the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property DimensionOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionOverconstrainedError Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionOverconstrainedError Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The Dimension would overconstrain the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverconstrainedError { get; }
Visual Basic
Public Shared ReadOnly Property DimensionOverconstrainedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionOverconstrainedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionOverrideNearByIsLost Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionOverrideNearByIsLost Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The dimension segment containing the override(s) shown below has been removed. The override text will no longer appear. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionOverrideNearByIsLost { get; }
Visual Basic
Public Shared ReadOnly Property DimensionOverrideNearByIsLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionOverrideNearByIsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionPerpendicularToView Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionPerpendicularToView Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The Dimension is perpendicular to the current view, and no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionPerpendicularToView { get; }
Visual Basic
Public Shared ReadOnly Property DimensionPerpendicularToView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionPerpendicularToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionReferencesInvalid Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionReferencesInvalid Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more dimension references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionReferencesInvalid { get; }
Visual Basic
Public Shared ReadOnly Property DimensionReferencesInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionReferencesInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionUnequaled Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionUnequaled Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimension had to be unlocked and un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnequaled { get; }
Visual Basic
Public Shared ReadOnly Property DimensionUnequaled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionUnequaled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionUnlocked Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionUnlocked Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimension had to be un-EQed in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnlocked { get; }
Visual Basic
Public Shared ReadOnly Property DimensionUnlocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionUnlocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


DimensionUnlockedAndUnequaled Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..DimensionUnlockedAndUnequaled Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Dimension had to be unlocked in order to remove sketch over-constraining.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionUnlockedAndUnequaled { get; }
Visual Basic
Public Shared ReadOnly Property DimensionUnlockedAndUnequaled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionUnlockedAndUnequaled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


EqualityConstraintsUnsatisfied Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..EqualityConstraintsUnsatisfied Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfied { get; }
Visual Basic
Public Shared ReadOnly Property EqualityConstraintsUnsatisfied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


EqualityConstraintsUnsatisfiedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..EqualityConstraintsUnsatisfiedWarn Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Equality constraints are not satisfied. The action either violates a locked constraint or tries to modify a sketch based object outside of the sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EqualityConstraintsUnsatisfiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property EqualityConstraintsUnsatisfiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EqualityConstraintsUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


ForbiddenGroupConstraint Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..ForbiddenGroupConstraint Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
You may not create sketch or family constraints between group members and elements which are not members of the same group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ForbiddenGroupConstraint { get; }
Visual Basic
Public Shared ReadOnly Property ForbiddenGroupConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForbiddenGroupConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LabelOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LabelOverconstrained Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Labeling this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LabelOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property LabelOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LabelOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LinearConstraintBadDirection Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LinearConstraintBadDirection Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Bad direction vector in dimension element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinearConstraintBadDirection { get; }
Visual Basic
Public Shared ReadOnly Property LinearConstraintBadDirection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinearConstraintBadDirection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LinearConstraintNotParallel Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LinearConstraintNotParallel Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The References of the highlighted Dimension are no longer parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinearConstraintNotParallel { get; }
Visual Basic
Public Shared ReadOnly Property LinearConstraintNotParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinearConstraintNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LinearDimensionReferenceNotOrthogonalToView Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LinearDimensionReferenceNotOrthogonalToView Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The planes of one or more references are not exactly orthogonal to this view. The dimension to these reference cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinearDimensionReferenceNotOrthogonalToView { get; }
Visual Basic
Public Shared ReadOnly Property LinearDimensionReferenceNotOrthogonalToView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinearDimensionReferenceNotOrthogonalToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LockOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LockOverconstrained Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Locking this dimension would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property LockOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LockOverconstrainedAlignment Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LockOverconstrainedAlignment Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Locking this alignment would overconstrain the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockOverconstrainedAlignment { get; }
Visual Basic
Public Shared ReadOnly Property LockOverconstrainedAlignment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockOverconstrainedAlignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


LooseLabeledDimensionRegenFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..LooseLabeledDimensionRegenFailure Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Failed to Regenerate Family

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseLabeledDimensionRegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property LooseLabeledDimensionRegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseLabeledDimensionRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


NoConstraintsInProperSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..NoConstraintsInProperSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
You are creating a constraint inside the sketch of a property line. Constraints inside a sketch can only drive elements within the sketch. Usually you do not want property lines driven by other elements. If you would like to constrain other elements to the property lines, you should add the constraints outside of sketch mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsInProperSketch { get; }
Visual Basic
Public Shared ReadOnly Property NoConstraintsInProperSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsInProperSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


NoConstraintsToLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..NoConstraintsToLinks Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints may not be created to linked instances using Shared Locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsToLinks { get; }
Visual Basic
Public Shared ReadOnly Property NoConstraintsToLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsToLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RadialDimensionCannotProjectToArc Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..RadialDimensionCannotProjectToArc Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Cannot form radial dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RadialDimensionCannotProjectToArc { get; }
Visual Basic
Public Shared ReadOnly Property RadialDimensionCannotProjectToArc As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RadialDimensionCannotProjectToArc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RadialDimensionChangeRadiusFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..RadialDimensionChangeRadiusFailed Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Can't change radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RadialDimensionChangeRadiusFailed { get; }
Visual Basic
Public Shared ReadOnly Property RadialDimensionChangeRadiusFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RadialDimensionChangeRadiusFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RegenConstraintUnsatisfied Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..RegenConstraintUnsatisfied Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfied { get; }
Visual Basic
Public Shared ReadOnly Property RegenConstraintUnsatisfied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


RegenConstraintUnsatisfiedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..RegenConstraintUnsatisfiedWarn Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Constraints are not satisfied

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegenConstraintUnsatisfiedWarn { get; }
Visual Basic
Public Shared ReadOnly Property RegenConstraintUnsatisfiedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenConstraintUnsatisfiedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeDimensionsLostOnPaste Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SomeDimensionsLostOnPaste Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostOnPaste { get; }
Visual Basic
Public Shared ReadOnly Property SomeDimensionsLostOnPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeDimensionsLostWitnessLines Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SomeDimensionsLostWitnessLines Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Dimensions lost some of their References on paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeDimensionsLostWitnessLines { get; }
Visual Basic
Public Shared ReadOnly Property SomeDimensionsLostWitnessLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeDimensionsLostWitnessLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SomeSpotDimensionsLostOnPaste Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SomeSpotDimensionsLostOnPaste Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Spot Dimensions were not copied because some References were lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeSpotDimensionsLostOnPaste { get; }
Visual Basic
Public Shared ReadOnly Property SomeSpotDimensionsLostOnPaste As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeSpotDimensionsLostOnPaste {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionFloatingPointError Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionFloatingPointError Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some spot dimensions contain invalid floating-point values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotDimensionFloatingPointError { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionFloatingPointError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionFloatingPointError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionFormerSetMoribundCall Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionFormerSetMoribundCall Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more Spot Dimension references are no longer valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotDimensionFormerSetMoribundCall { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionFormerSetMoribundCall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionFormerSetMoribundCall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotDimensionReferencesNoLongerHorizontal Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotDimensionReferencesNoLongerHorizontal Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
One or more Spot Dimension references are no longer valid. Spot Dimensions can generally reference only those references which have valid coordinates in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotDimensionReferencesNoLongerHorizontal { get; }
Visual Basic
Public Shared ReadOnly Property SpotDimensionReferencesNoLongerHorizontal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotDimensionReferencesNoLongerHorizontal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotElevationLostEdgeReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotElevationLostEdgeReferences Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Some Spot Dimensions lost their References. Those Spot Dimensions will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotElevationLostEdgeReferences { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevationLostEdgeReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotElevationLostEdgeReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotElevationMissesReference Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotElevationMissesReference Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Spot Dimension does not lie on its reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotElevationMissesReference { get; }
Visual Basic
Public Shared ReadOnly Property SpotElevationMissesReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotElevationMissesReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotSlopeReferenceIsVertical Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotSlopeReferenceIsVertical Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element that is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotSlopeReferenceIsVertical { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeReferenceIsVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferenceIsVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


SpotSlopeReferencePointIsSingular Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..SpotSlopeReferencePointIsSingular Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
The highlighted Spot Slope references an element point that is singular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpotSlopeReferencePointIsSingular { get; }
Visual Basic
Public Shared ReadOnly Property SpotSlopeReferencePointIsSingular As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpotSlopeReferencePointIsSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInGridChainSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInGridChainSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Curve in a GridChain sketch cannot be constrained to a sub-grid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInGridChainSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInGridChainSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInGridChainSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInJoistSystemSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInJoistSystemSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Structural Beam System sketch can't be constrained to its beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInJoistSystemSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInJoistSystemSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInJoistSystemSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInSkeletonSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInSkeletonSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Reference Lines can only be constrained to Reference Planes, Levels, Family Host, and other Reference Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInSkeletonSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInSkeletonSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInSkeletonSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


WrongConstraintInTrussSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..DimensionFailures..::..WrongConstraintInTrussSketch Property
BuiltInFailures..::..DimensionFailures Class See Also Send Feedback
Structural Truss sketch can't be constrained to its members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongConstraintInTrussSketch { get; }
Visual Basic
Public Shared ReadOnly Property WrongConstraintInTrussSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongConstraintInTrussSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DimensionFailures Class


BuiltInFailures.DividedPathFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DividedPathFailures
Visual Basic
Public NotInheritable Class DividedPathFailures
Visual C++
public ref class DividedPathFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DividedPathFailures

See Also

BuiltInFailures..::..DividedPathFailures Members


BuiltInFailures.DividedPathFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures Members
BuiltInFailures..::..DividedPathFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DividedPathFailures type exposes the following members.

Properties

Name | Description
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.

See Also

BuiltInFailures..::..DividedPathFailures Class


BuiltInFailures.DividedPathFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures Properties
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback

The BuiltInFailures..::..DividedPathFailures type exposes the following members.

Properties

Name | Description
DividedPathCannotBeMirroredWithoutItsCurves | Divided path cannot be mirrored without its curves.
DividedPathDistanceTooSmall | Distance is too small.
DividedPathIndentsOverlap | Beginning indent and end indent overlap.
DividedPathIntersectionPolycurveParamsStepFailed | Intersection failed.
DividedPathInvalidNumberOfPoints | End indent is too large.
DividedPathLayoutStepFailed | Layout algorithm failed.
DividedPathUpdateMergedPointKeysStepFailed | Merging failed.

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathCannotBeMirroredWithoutItsCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathCannotBeMirroredWithoutItsCurves Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Divided path cannot be mirrored without its curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathCannotBeMirroredWithoutItsCurves { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathCannotBeMirroredWithoutItsCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathCannotBeMirroredWithoutItsCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathDistanceTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathDistanceTooSmall Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Distance is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathDistanceTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathDistanceTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathDistanceTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathIndentsOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathIndentsOverlap Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Beginning indent and end indent overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathIndentsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathIndentsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathIndentsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathIntersectionPolycurveParamsStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathIntersectionPolycurveParamsStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Intersection failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathIntersectionPolycurveParamsStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathIntersectionPolycurveParamsStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathIntersectionPolycurveParamsStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathInvalidNumberOfPoints Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathInvalidNumberOfPoints Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
End indent is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathInvalidNumberOfPoints { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathInvalidNumberOfPoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathInvalidNumberOfPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathLayoutStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathLayoutStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Layout algorithm failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathLayoutStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathLayoutStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathLayoutStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


DividedPathUpdateMergedPointKeysStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedPathFailures..::..DividedPathUpdateMergedPointKeysStepFailed Property
BuiltInFailures..::..DividedPathFailures Class See Also Send Feedback
Merging failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedPathUpdateMergedPointKeysStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividedPathUpdateMergedPointKeysStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedPathUpdateMergedPointKeysStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedPathFailures Class


BuiltInFailures.DividedSurfaceFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DividedSurfaceFailures
Visual Basic
Public NotInheritable Class DividedSurfaceFailures
Visual C++
public ref class DividedSurfaceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DividedSurfaceFailures

See Also

BuiltInFailures..::..DividedSurfaceFailures Members


BuiltInFailures.DividedSurfaceFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures Members
BuiltInFailures..::..DividedSurfaceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
AttemptToCreateMultipleDividedSurfacesOnTheSameFace | Creation of a Divided Surface on a face already hosting another one was requested.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


BuiltInFailures.DividedSurfaceFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures Properties
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback

The BuiltInFailures..::..DividedSurfaceFailures type exposes the following members.

Properties

Name | Description
AttemptToCreateMultipleDividedSurfacesOnTheSameFace | Creation of a Divided Surface on a face already hosting another one was requested.
DividedSurfaceCoincidingSplittingWorkplanes | Coinciding splitting workplanes are encountered
DividedSurfaceCurveChainBelongsToMultipleBeltIntervals | A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
DividedSurfaceCurveChainBothUandV | A chain formed by these curve elements is trying to be both U- and V- splitter
DividedSurfaceCurveChainDoesNotEngageUorV | A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
DividedSurfaceCurveChainGeneralProblem | The chain formed by these curve elements cannot be processed and will be ignored.
DividedSurfaceCurveChainIntersection | A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
DividedSurfaceCurveChainIsTooClosedToGridlines | A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
DividedSurfaceCurveChainMultipleSeqIntersWithDivLine | The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
DividedSurfaceCurveChainNonSeqIntersWithDivLines | The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
DividedSurfaceCurveChainUnsortableBucket | The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
DividedSurfaceCurveFromChainMultipleIntersWithDivLine | A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
DividedSurfaceCurveLoopChainIntersectedByExtensions | Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
DividedSurfaceCuttingSurfaceDoesNotCutMeshFace | The surface-based splitter does not intersect a face to be divided and will be ignored
DividedSurfaceCuttingSurfaceGeneralProblem | Cannot process a surface-based splitter
DividedSurfaceCuttingSurfaceMakesMultipleCuts | The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
DividedSurfaceDidNotRegenerateProperly | Divided Surface gridlines could not be generated.
DividedSurfaceDiscardedSplittersWarning | Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
DividedSurfaceIgnoresSplitters | Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
DividedSurfaceInvalidSpacing | Constraints not satisfied, cannot generate gridlines.
DividedSurfaceLoopsOfSplittingCurves | Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids | There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
DividedSurfaceSelfIntersectingCurveLoopChain | Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveLoopsAsSplitters | Curve elements forming a single curve loop cannot be used as splitters and are ignored.
DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids | There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
DividedSurfaceSplitManagerProblem1dNonWPCurve | Divided Surface cannot be split by a one dimensional curve without workplane
DividedSurfaceSplitManagerProblemClosedArcOrEllipse | Divided Surface cannot be split by a closed arc or ellipse.
DividedSurfaceSplitRefInvisible | Some of the splitting references of this Divided Surface are invisible in the current view.
DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors | Curve elements which form chains connecting points shared by more than two curve elements are ignored.
DividedSurfaceSplittingCurvesWithMultipleNeighbors | A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
DividedSurfaceZeroLengthSplittingCurve | Curve element with zero length cannot be used as a splitter and ignored.
MeshTopologicalSortFailed | Splitters and grids do not define a consistent rectangular mesh on the face.

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


AttemptToCreateMultipleDividedSurfacesOnTheSameFace Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..AttemptToCreateMultipleDividedSurfacesOnTheSameFace Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Creation of a Divided Surface on a face already hosting another one was requested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AttemptToCreateMultipleDividedSurfacesOnTheSameFace { get; }
Visual Basic
Public Shared ReadOnly Property AttemptToCreateMultipleDividedSurfacesOnTheSameFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttemptToCreateMultipleDividedSurfacesOnTheSameFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCoincidingSplittingWorkplanes Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCoincidingSplittingWorkplanes Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Coinciding splitting workplanes are encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCoincidingSplittingWorkplanes { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCoincidingSplittingWorkplanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCoincidingSplittingWorkplanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainBelongsToMultipleBeltIntervals Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainBelongsToMultipleBeltIntervals { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainBelongsToMultipleBeltIntervals As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBelongsToMultipleBeltIntervals {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainBothUandV Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainBothUandV Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements is trying to be both U- and V- splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainBothUandV { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainBothUandV As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainBothUandV {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainDoesNotEngageUorV Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainDoesNotEngageUorV Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainDoesNotEngageUorV { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainDoesNotEngageUorV As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainDoesNotEngageUorV {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainGeneralProblem Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainGeneralProblem Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements cannot be processed and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainGeneralProblem { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainGeneralProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainIntersection Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainIntersection Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIntersection { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainIsTooClosedToGridlines Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainIsTooClosedToGridlines Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainIsTooClosedToGridlines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainIsTooClosedToGridlines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainIsTooClosedToGridlines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainMultipleSeqIntersWithDivLine Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainMultipleSeqIntersWithDivLine { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainMultipleSeqIntersWithDivLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainMultipleSeqIntersWithDivLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainNonSeqIntersWithDivLines Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainNonSeqIntersWithDivLines Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainNonSeqIntersWithDivLines { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainNonSeqIntersWithDivLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainNonSeqIntersWithDivLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveChainUnsortableBucket Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveChainUnsortableBucket Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveChainUnsortableBucket { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveChainUnsortableBucket As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveChainUnsortableBucket {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveFromChainMultipleIntersWithDivLine Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveFromChainMultipleIntersWithDivLine Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveFromChainMultipleIntersWithDivLine { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveFromChainMultipleIntersWithDivLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveFromChainMultipleIntersWithDivLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCurveLoopChainIntersectedByExtensions Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCurveLoopChainIntersectedByExtensions Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCurveLoopChainIntersectedByExtensions { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCurveLoopChainIntersectedByExtensions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCurveLoopChainIntersectedByExtensions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCuttingSurfaceDoesNotCutMeshFace Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The surface-based splitter does not intersect a face to be divided and will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceDoesNotCutMeshFace { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceDoesNotCutMeshFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceDoesNotCutMeshFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceGeneralProblem Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCuttingSurfaceGeneralProblem Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Cannot process a surface-based splitter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceGeneralProblem { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceGeneralProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceGeneralProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceCuttingSurfaceMakesMultipleCuts Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceCuttingSurfaceMakesMultipleCuts Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceCuttingSurfaceMakesMultipleCuts { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceCuttingSurfaceMakesMultipleCuts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceCuttingSurfaceMakesMultipleCuts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceDidNotRegenerateProperly Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceDidNotRegenerateProperly Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Divided Surface gridlines could not be generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceDidNotRegenerateProperly { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDidNotRegenerateProperly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceDidNotRegenerateProperly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceDiscardedSplittersWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceDiscardedSplittersWarning Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceDiscardedSplittersWarning { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceDiscardedSplittersWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceDiscardedSplittersWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceIgnoresSplitters Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceIgnoresSplitters Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceIgnoresSplitters { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceIgnoresSplitters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceIgnoresSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceInvalidSpacing Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceInvalidSpacing Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Constraints not satisfied, cannot generate gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceInvalidSpacing { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceInvalidSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceInvalidSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceLoopsOfSplittingCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceLoopsOfSplittingCurves Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a closed loop currently cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceLoopsOfSplittingCurves { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceLoopsOfSplittingCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceLoopsOfSplittingCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSelfIntersectingCurveLoopChain Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSelfIntersectingCurveLoopChain Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSelfIntersectingCurveLoopChain { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSelfIntersectingCurveLoopChain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSelfIntersectingCurveLoopChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSingleCurveLoopsAsSplitters Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSingleCurveLoopsAsSplitters Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements forming a single curve loop cannot be used as splitters and are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveLoopsAsSplitters { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSingleCurveLoopsAsSplitters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveLoopsAsSplitters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplitManagerProblem1dNonWPCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplitManagerProblem1dNonWPCurve Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Divided Surface cannot be split by a one dimensional curve without workplane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitManagerProblem1dNonWPCurve { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblem1dNonWPCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblem1dNonWPCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplitManagerProblemClosedArcOrEllipse Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Divided Surface cannot be split by a closed arc or ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitManagerProblemClosedArcOrEllipse { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplitManagerProblemClosedArcOrEllipse As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitManagerProblemClosedArcOrEllipse {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplitRefInvisible Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplitRefInvisible Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Some of the splitting references of this Divided Surface are invisible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplitRefInvisible { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplitRefInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplitRefInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve elements which form chains connecting points shared by more than two curve elements are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceSplittingCurvesWithMultipleNeighbors Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceSplittingCurvesWithMultipleNeighbors Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceSplittingCurvesWithMultipleNeighbors { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceSplittingCurvesWithMultipleNeighbors As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceSplittingCurvesWithMultipleNeighbors {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


DividedSurfaceZeroLengthSplittingCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..DividedSurfaceZeroLengthSplittingCurve Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Curve element with zero length cannot be used as a splitter and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividedSurfaceZeroLengthSplittingCurve { get; }
Visual Basic
Public Shared ReadOnly Property DividedSurfaceZeroLengthSplittingCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividedSurfaceZeroLengthSplittingCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


MeshTopologicalSortFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DividedSurfaceFailures..::..MeshTopologicalSortFailed Property
BuiltInFailures..::..DividedSurfaceFailures Class See Also Send Feedback
Splitters and grids do not define a consistent rectangular mesh on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MeshTopologicalSortFailed { get; }
Visual Basic
Public Shared ReadOnly Property MeshTopologicalSortFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MeshTopologicalSortFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DividedSurfaceFailures Class


BuiltInFailures.DocumentFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about DocumentFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DocumentFailures
Visual Basic
Public NotInheritable Class DocumentFailures
Visual C++
public ref class DocumentFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DocumentFailures

See Also

BuiltInFailures..::..DocumentFailures Members


BuiltInFailures.DocumentFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures Members
BuiltInFailures..::..DocumentFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DocumentFailures type exposes the following members.

Properties

Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.

See Also

BuiltInFailures..::..DocumentFailures Class


BuiltInFailures.DocumentFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures Properties
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback

The BuiltInFailures..::..DocumentFailures type exposes the following members.

Properties

Name | Description
ApiDelayedUpdateFailed | Delayed Updating Failed. Please contact the 3rd Party Application vendor.
CannotAutoUpdate | Coordination Monitor can't update element
CannotLoadLink | Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.
DUExcessiveRegeneration | Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.
DUMisbehavingUpdater | Third party updater '[Name]' has experienced a problem and its action had to be canceled.

See Also

BuiltInFailures..::..DocumentFailures Class


ApiDelayedUpdateFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures..::..ApiDelayedUpdateFailed Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Delayed Updating Failed. Please contact the 3rd Party Application vendor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ApiDelayedUpdateFailed { get; }
Visual Basic
Public Shared ReadOnly Property ApiDelayedUpdateFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ApiDelayedUpdateFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


CannotAutoUpdate Property

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures..::..CannotAutoUpdate Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Coordination Monitor can't update element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAutoUpdate { get; }
Visual Basic
Public Shared ReadOnly Property CannotAutoUpdate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAutoUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


CannotLoadLink Property

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures..::..CannotLoadLink Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Can't load Linked File [Name] due to errors. Open it separately to investigate the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadLink { get; }
Visual Basic
Public Shared ReadOnly Property CannotLoadLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLoadLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


DUExcessiveRegeneration Property

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures..::..DUExcessiveRegeneration Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Third party updater '[Name]' has caused an infinite loop and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DUExcessiveRegeneration { get; }
Visual Basic
Public Shared ReadOnly Property DUExcessiveRegeneration As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DUExcessiveRegeneration {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


DUMisbehavingUpdater Property

[image]

Revit 2013 API
BuiltInFailures..::..DocumentFailures..::..DUMisbehavingUpdater Property
BuiltInFailures..::..DocumentFailures Class See Also Send Feedback
Third party updater '[Name]' has experienced a problem and its action had to be canceled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DUMisbehavingUpdater { get; }
Visual Basic
Public Shared ReadOnly Property DUMisbehavingUpdater As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DUMisbehavingUpdater {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DocumentFailures Class


BuiltInFailures.DPartFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DPartFailures
Visual Basic
Public NotInheritable Class DPartFailures
Visual C++
public ref class DPartFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DPartFailures

See Also

BuiltInFailures..::..DPartFailures Members


BuiltInFailures.DPartFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DPartFailures Members
BuiltInFailures..::..DPartFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DPartFailures type exposes the following members.

Properties

Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts

See Also

BuiltInFailures..::..DPartFailures Class


BuiltInFailures.DPartFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DPartFailures Properties
BuiltInFailures..::..DPartFailures Class See Also Send Feedback

The BuiltInFailures..::..DPartFailures type exposes the following members.

Properties

Name | Description
BindLinkWillDeleteAllPartsWarning | Bind Link will delete its associated Parts.
DeletingDPartWillDeleteAllPartsWarning | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingDPartWillDeleteMorePartsError | Deleting a Part will delete all associated Parts and the original Element will be made visible.
DeletingOriginalWillDeleteParts | Deletion of this element will delete its associated Parts.
DivideVolumesProfilesEdgeMatchForWidthAll | Division family cannot be used with the selected edge condition for all widths of hosts
DivideVolumesProfilesEdgeMatchForWidthSome | Division family cannot be used with the selected edge condition for some widths of hosts
DivideVolumesProfilesForWidthAll | Division family cannot be used for all widths of hosts
DivideVolumesProfilesForWidthSome | Division family cannot be used for some widths of hosts
DivideVolumesProfilesGapForWidthAll | Division family cannot be used with the selected division gap for all widths of hosts
DivideVolumesProfilesGapForWidthSome | Division family cannot be used with the selected division gap for some widths of hosts
DivideVolumesProfilesNonSlabSources | Some sources of a volume divider are non-slab like.
DivisionContainsNoParts | The division contains no parts.
DivisionContainsNoReferences | The division contains no dividing references.
ElementsAlreadyHaveParts | Some elements already have parts
IneligibleElementsForParts | Creating parts from ineligible elements
NoPartMakerCreatedInEditMode | Nothing will be divided.
PartPhaseParametersConflictWithOriginal | The creation and demolition phases of a part must lie between the corresponding phases of the original.
RemovingInvalidDPartParents | Can't make Parts out of these Elements.
RemovingUndividedDPartParents | These parts are not intersected by any dividing references. They will be removed from the division.
SourceInUnloadedLink | Some elements already have parts

See Also

BuiltInFailures..::..DPartFailures Class


BindLinkWillDeleteAllPartsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..BindLinkWillDeleteAllPartsWarning Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Bind Link will delete its associated Parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BindLinkWillDeleteAllPartsWarning { get; }
Visual Basic
Public Shared ReadOnly Property BindLinkWillDeleteAllPartsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BindLinkWillDeleteAllPartsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DeletingDPartWillDeleteAllPartsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DeletingDPartWillDeleteAllPartsWarning Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingDPartWillDeleteAllPartsWarning { get; }
Visual Basic
Public Shared ReadOnly Property DeletingDPartWillDeleteAllPartsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteAllPartsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DeletingDPartWillDeleteMorePartsError Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DeletingDPartWillDeleteMorePartsError Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Deleting a Part will delete all associated Parts and the original Element will be made visible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingDPartWillDeleteMorePartsError { get; }
Visual Basic
Public Shared ReadOnly Property DeletingDPartWillDeleteMorePartsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingDPartWillDeleteMorePartsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DeletingOriginalWillDeleteParts Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DeletingOriginalWillDeleteParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Deletion of this element will delete its associated Parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingOriginalWillDeleteParts { get; }
Visual Basic
Public Shared ReadOnly Property DeletingOriginalWillDeleteParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingOriginalWillDeleteParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesEdgeMatchForWidthAll Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesEdgeMatchForWidthAll Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected edge condition for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthAll { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesEdgeMatchForWidthSome Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesEdgeMatchForWidthSome Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected edge condition for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesEdgeMatchForWidthSome { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesEdgeMatchForWidthSome As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesEdgeMatchForWidthSome {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesForWidthAll Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesForWidthAll Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesForWidthAll { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesForWidthAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesForWidthAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesForWidthSome Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesForWidthSome Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesForWidthSome { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesForWidthSome As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesForWidthSome {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesGapForWidthAll Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesGapForWidthAll Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected division gap for all widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesGapForWidthAll { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesGapForWidthAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesGapForWidthAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesGapForWidthSome Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesGapForWidthSome Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Division family cannot be used with the selected division gap for some widths of hosts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesGapForWidthSome { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesGapForWidthSome As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesGapForWidthSome {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivideVolumesProfilesNonSlabSources Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivideVolumesProfilesNonSlabSources Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Some sources of a volume divider are non-slab like.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivideVolumesProfilesNonSlabSources { get; }
Visual Basic
Public Shared ReadOnly Property DivideVolumesProfilesNonSlabSources As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivideVolumesProfilesNonSlabSources {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivisionContainsNoParts Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivisionContainsNoParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
The division contains no parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivisionContainsNoParts { get; }
Visual Basic
Public Shared ReadOnly Property DivisionContainsNoParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivisionContainsNoParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


DivisionContainsNoReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..DivisionContainsNoReferences Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
The division contains no dividing references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivisionContainsNoReferences { get; }
Visual Basic
Public Shared ReadOnly Property DivisionContainsNoReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivisionContainsNoReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


ElementsAlreadyHaveParts Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..ElementsAlreadyHaveParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Some elements already have parts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsAlreadyHaveParts { get; }
Visual Basic
Public Shared ReadOnly Property ElementsAlreadyHaveParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsAlreadyHaveParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


IneligibleElementsForParts Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..IneligibleElementsForParts Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Creating parts from ineligible elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IneligibleElementsForParts { get; }
Visual Basic
Public Shared ReadOnly Property IneligibleElementsForParts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IneligibleElementsForParts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


NoPartMakerCreatedInEditMode Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..NoPartMakerCreatedInEditMode Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Nothing will be divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoPartMakerCreatedInEditMode { get; }
Visual Basic
Public Shared ReadOnly Property NoPartMakerCreatedInEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPartMakerCreatedInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


PartPhaseParametersConflictWithOriginal Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..PartPhaseParametersConflictWithOriginal Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
The creation and demolition phases of a part must lie between the corresponding phases of the original.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartPhaseParametersConflictWithOriginal { get; }
Visual Basic
Public Shared ReadOnly Property PartPhaseParametersConflictWithOriginal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartPhaseParametersConflictWithOriginal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


RemovingInvalidDPartParents Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..RemovingInvalidDPartParents Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Can't make Parts out of these Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingInvalidDPartParents { get; }
Visual Basic
Public Shared ReadOnly Property RemovingInvalidDPartParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingInvalidDPartParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


RemovingUndividedDPartParents Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..RemovingUndividedDPartParents Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
These parts are not intersected by any dividing references. They will be removed from the division.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingUndividedDPartParents { get; }
Visual Basic
Public Shared ReadOnly Property RemovingUndividedDPartParents As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingUndividedDPartParents {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


SourceInUnloadedLink Property

[image]

Revit 2013 API
BuiltInFailures..::..DPartFailures..::..SourceInUnloadedLink Property
BuiltInFailures..::..DPartFailures Class See Also Send Feedback
Some elements already have parts

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SourceInUnloadedLink { get; }
Visual Basic
Public Shared ReadOnly Property SourceInUnloadedLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SourceInUnloadedLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DPartFailures Class


BuiltInFailures.DuctFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Duct.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class DuctFailures
Visual Basic
Public NotInheritable Class DuctFailures
Visual C++
public ref class DuctFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..DuctFailures

See Also

BuiltInFailures..::..DuctFailures Members


BuiltInFailures.DuctFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..DuctFailures Members
BuiltInFailures..::..DuctFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
InvalidDuctFittingKfactorDatabase | Invalid Duct Fitting K-Factor Database
NoAshraeTableFoundForLossMethod | No loss defined because no ASHRAE table could be found.
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.

See Also

BuiltInFailures..::..DuctFailures Class


BuiltInFailures.DuctFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..DuctFailures Properties
BuiltInFailures..::..DuctFailures Class See Also Send Feedback

The BuiltInFailures..::..DuctFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForDuct | Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.
FlexDuctLengthOutOfLimits | The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]
InvalidDuctFittingKfactorDatabase | Invalid Duct Fitting K-Factor Database
NoAshraeTableFoundForLossMethod | No loss defined because no ASHRAE table could be found.
NoDuctFittingsInProject | There are no duct fittings defined in project. The default duct type for fittings will be set to none.

See Also

BuiltInFailures..::..DuctFailures Class


CannotCreateGeometryForDuct Property

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures..::..CannotCreateGeometryForDuct Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
Cannot create geometry for flex duct. The flex duct is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForDuct { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGeometryForDuct As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForDuct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


FlexDuctLengthOutOfLimits Property

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures..::..FlexDuctLengthOutOfLimits Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
The flex duct length of [Length Value] exceeds the maximum specified length of [Maximum Flex Duct Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FlexDuctLengthOutOfLimits { get; }
Visual Basic
Public Shared ReadOnly Property FlexDuctLengthOutOfLimits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlexDuctLengthOutOfLimits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


InvalidDuctFittingKfactorDatabase Property

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures..::..InvalidDuctFittingKfactorDatabase Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
Invalid Duct Fitting K-Factor Database

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidDuctFittingKfactorDatabase { get; }
Visual Basic
Public Shared ReadOnly Property InvalidDuctFittingKfactorDatabase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidDuctFittingKfactorDatabase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


NoAshraeTableFoundForLossMethod Property

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures..::..NoAshraeTableFoundForLossMethod Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
No loss defined because no ASHRAE table could be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoAshraeTableFoundForLossMethod { get; }
Visual Basic
Public Shared ReadOnly Property NoAshraeTableFoundForLossMethod As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAshraeTableFoundForLossMethod {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


NoDuctFittingsInProject Property

[image]

Revit 2013 API
BuiltInFailures..::..DuctFailures..::..NoDuctFittingsInProject Property
BuiltInFailures..::..DuctFailures Class See Also Send Feedback
There are no duct fittings defined in project. The default duct type for fittings will be set to none.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoDuctFittingsInProject { get; }
Visual Basic
Public Shared ReadOnly Property NoDuctFittingsInProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoDuctFittingsInProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..DuctFailures Class


BuiltInFailures.EditingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EditingFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class EditingFailures
Visual Basic
Public NotInheritable Class EditingFailures
Visual C++
public ref class EditingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..EditingFailures

See Also

BuiltInFailures..::..EditingFailures Members


BuiltInFailures.EditingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..EditingFailures Members
BuiltInFailures..::..EditingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central Model is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central Model.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | No work plane while editing unconstrained element in 3d view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletedRequestedWarn | You have deleted elements that other users requested.
DeleteElementsError | [Description]
DeleteElementsWarn | [Description]
DeletePreventedByElemArray | Elements managed by Element Arrays can be deleted only if explicitly unlocked.
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherCrash | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherWarn | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedByElementArray | Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.
LockedByGroup | Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.
LockedByMassing | To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.
WorksetNoneditableCozAdvanced | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::..EditingFailures Class


BuiltInFailures.EditingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..EditingFailures Properties
BuiltInFailures..::..EditingFailures Class See Also Send Feedback

The BuiltInFailures..::..EditingFailures type exposes the following members.

Properties

Name | Description
AllInvisibleInPlanViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
AllInvisibleInViewWarn | None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
BorrowElementsAtRisk | Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
CannotBorrowBusyContention | Can't obtain permission to edit the element. The Central Model is busy.
CannotCheckoutWorksets | Can't make workset editable. User '[Borrowers]' has already checked it out.
CannotDeleteEditedElement | Can't delete element that is being edited.
CannotDeleteEditedElementError | Can't delete element that is being edited.
CannotDeletePredefinedFamilyElement | Element is a built-in part of the family definition and cannot be deleted or added to groups.
CannotDrawInCurrentView | Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
CannotDuplicateType | Cannot Duplicate Type
CannotEditDeletedElements | Can't edit the element. It was deleted in the Central Model.
CannotEditDeletedWorkset | This action has caused deletion of non-editable Workset ' [Name] '.
CannotEditEditingElements | Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
CannotEditElements | Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
CannotEditRenamedWorkset | Can't edit workset ' [Name] '.
CannotMirrorInView | Must specify Work Plane to mirror in a 3d View.
CannotMoveElement | Can't move element.
CannotMoveElementWarn | Can't move element.
CannotMoveElementWithoutWorkplane | No work plane while editing unconstrained element in 3d view.
CannotMoveInView | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveInViewError | Can't move element because the move plane is seen at a very sharp angle in this View
CannotMoveLocked | Can't move pinned element.
CannotMoveTogether | Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
CannotRotateLocked | Can't rotate pinned element.
CannotScaleInView | Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
DeletedRequestedWarn | You have deleted elements that other users requested.
DeleteElementsError | [Description]
DeleteElementsWarn | [Description]
DeletePreventedByElemArray | Elements managed by Element Arrays can be deleted only if explicitly unlocked.
DeletePreventedByGroup | Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
ElementNotEditable | One or more elements are not editable.
ElementReversed | Element is reversed.
ElementsDeleted | Elements were deleted.
ElementsDeletedPastedToKeep | Elements were deleted. Use Edit Pasted Elements to keep them.
ElementsNotInPlane | Elements don't lie on the same plane.
ElementsWillBeDeleted | Elements in [Design Option] will be deleted
ExtendToOtherCrash | Can't keep [Type Name] extended to [Type Name].
ExtendToOtherWarn | Can't keep [Type Name] extended to [Type Name].
GeneratedByMassing | Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
HaveNoPermissionToEdit | You do not have permission to edit the element.
HiddenBeamsEditingWarning | The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
InvalidArrayObject | Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
InvalidElemsInSelection | Can't scale elements together.
LockedByElementArray | Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.
LockedByGroup | Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.
LockedByMassing | To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n
LockedDeleted | Pinned objects deleted.
LockedDeletedWarn | Pinned objects deleted.
MirrorProjectSuccess | [Action] command has successfully processed [Number] elements
NElementsDeleted | [Number] elements were deleted
NElementsWrongPosition | Review [Number] elements for correct position and shape
NoRotateMirrorZ | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
NoRotateMirrorZError | Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
OutOfDateElements | Workset is editable, but you must Reload Latest before editing the element.
OwnedByOther | Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
OwnElementsOutOfDate | You now own the element, but your file is out of date. You must Reload Latest before editing the element.
PressShowToSee | Press Show to see the element(s); then Ignore or Cancel
ReloadBeforeMakeEditable | You must Reload Latest before editing the element.
ReloadNoGood | You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
SourceInEditMode | Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TargetInEditMode | Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
TemporaryChangesOutOfDate | You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
TemporaryChangesTransparentPermissions | Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
UnableFilletSpecifiedRadius | Unable to create Fillet with the specified radius.
UnableToMakeSourceWorksetEditable | Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
UnableToTransformElement | Attempted an invalid element rotate, mirror, or move.
UnableToTransformElementError | Attempted an invalid element rotate, mirror, or move.
WorksetHasChangedInCentralFile | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.
WorksetNoneditableCozAdvanced | This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

See Also

BuiltInFailures..::..EditingFailures Class


AllInvisibleInPlanViewWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..AllInvisibleInPlanViewWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllInvisibleInPlanViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property AllInvisibleInPlanViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInPlanViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


AllInvisibleInViewWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..AllInvisibleInViewWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllInvisibleInViewWarn { get; }
Visual Basic
Public Shared ReadOnly Property AllInvisibleInViewWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllInvisibleInViewWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


BorrowElementsAtRisk Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..BorrowElementsAtRisk Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BorrowElementsAtRisk { get; }
Visual Basic
Public Shared ReadOnly Property BorrowElementsAtRisk As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BorrowElementsAtRisk {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotBorrowBusyContention Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotBorrowBusyContention Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element. The Central Model is busy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotBorrowBusyContention { get; }
Visual Basic
Public Shared ReadOnly Property CannotBorrowBusyContention As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotBorrowBusyContention {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotCheckoutWorksets Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotCheckoutWorksets Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't make workset editable. User '[Borrowers]' has already checked it out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCheckoutWorksets { get; }
Visual Basic
Public Shared ReadOnly Property CannotCheckoutWorksets As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCheckoutWorksets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeleteEditedElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotDeleteEditedElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteEditedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeleteEditedElementError Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotDeleteEditedElementError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't delete element that is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteEditedElementError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteEditedElementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteEditedElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDeletePredefinedFamilyElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotDeletePredefinedFamilyElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element is a built-in part of the family definition and cannot be deleted or added to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeletePredefinedFamilyElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeletePredefinedFamilyElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeletePredefinedFamilyElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDrawInCurrentView Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotDrawInCurrentView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawInCurrentView { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawInCurrentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotDuplicateType Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotDuplicateType Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Cannot Duplicate Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDuplicateType { get; }
Visual Basic
Public Shared ReadOnly Property CannotDuplicateType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDuplicateType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditDeletedElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotEditDeletedElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't edit the element. It was deleted in the Central Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditDeletedElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditDeletedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditDeletedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditDeletedWorkset Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotEditDeletedWorkset Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
This action has caused deletion of non-editable Workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditDeletedWorkset { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditDeletedWorkset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditDeletedWorkset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditEditingElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotEditEditingElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditEditingElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditEditingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditEditingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotEditElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotEditRenamedWorkset Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotEditRenamedWorkset Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't edit workset ' [Name] '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEditRenamedWorkset { get; }
Visual Basic
Public Shared ReadOnly Property CannotEditRenamedWorkset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEditRenamedWorkset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMirrorInView Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMirrorInView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Must specify Work Plane to mirror in a 3d View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElementWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveElementWithoutWorkplane Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveElementWithoutWorkplane Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
No work plane while editing unconstrained element in 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveElementWithoutWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveElementWithoutWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveElementWithoutWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveInView Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveInView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveInViewError Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveInViewError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move element because the move plane is seen at a very sharp angle in this View

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveInViewError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveInViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveInViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveLocked Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveLocked Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotMoveTogether Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotMoveTogether Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveTogether { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveTogether As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveTogether {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotRotateLocked Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotRotateLocked Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't rotate pinned element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateLocked { get; }
Visual Basic
Public Shared ReadOnly Property CannotRotateLocked As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLocked {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


CannotScaleInView Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..CannotScaleInView Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotScaleInView { get; }
Visual Basic
Public Shared ReadOnly Property CannotScaleInView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotScaleInView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeletedRequestedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..DeletedRequestedWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You have deleted elements that other users requested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletedRequestedWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeletedRequestedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletedRequestedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeleteElementsError Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..DeleteElementsError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteElementsError { get; }
Visual Basic
Public Shared ReadOnly Property DeleteElementsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeleteElementsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..DeleteElementsWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property DeleteElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeletePreventedByElemArray Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..DeletePreventedByElemArray Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements managed by Element Arrays can be deleted only if explicitly unlocked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletePreventedByElemArray { get; }
Visual Basic
Public Shared ReadOnly Property DeletePreventedByElemArray As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletePreventedByElemArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


DeletePreventedByGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..DeletePreventedByGroup Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletePreventedByGroup { get; }
Visual Basic
Public Shared ReadOnly Property DeletePreventedByGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletePreventedByGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementNotEditable Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementNotEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
One or more elements are not editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementNotEditable { get; }
Visual Basic
Public Shared ReadOnly Property ElementNotEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementNotEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementReversed Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementReversed Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementReversed { get; }
Visual Basic
Public Shared ReadOnly Property ElementReversed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementReversed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementsDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsDeletedPastedToKeep Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementsDeletedPastedToKeep Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements were deleted. Use Edit Pasted Elements to keep them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsDeletedPastedToKeep { get; }
Visual Basic
Public Shared ReadOnly Property ElementsDeletedPastedToKeep As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsDeletedPastedToKeep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsNotInPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementsNotInPlane Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements don't lie on the same plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsNotInPlane { get; }
Visual Basic
Public Shared ReadOnly Property ElementsNotInPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsNotInPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ElementsWillBeDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ElementsWillBeDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements in [Design Option] will be deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsWillBeDeleted { get; }
Visual Basic
Public Shared ReadOnly Property ElementsWillBeDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsWillBeDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ExtendToOtherCrash Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ExtendToOtherCrash Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendToOtherCrash { get; }
Visual Basic
Public Shared ReadOnly Property ExtendToOtherCrash As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendToOtherCrash {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ExtendToOtherWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ExtendToOtherWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't keep [Type Name] extended to [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendToOtherWarn { get; }
Visual Basic
Public Shared ReadOnly Property ExtendToOtherWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendToOtherWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


GeneratedByMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..GeneratedByMassing Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GeneratedByMassing { get; }
Visual Basic
Public Shared ReadOnly Property GeneratedByMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeneratedByMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


HaveNoPermissionToEdit Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..HaveNoPermissionToEdit Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You do not have permission to edit the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HaveNoPermissionToEdit { get; }
Visual Basic
Public Shared ReadOnly Property HaveNoPermissionToEdit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HaveNoPermissionToEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


HiddenBeamsEditingWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..HiddenBeamsEditingWarning Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HiddenBeamsEditingWarning { get; }
Visual Basic
Public Shared ReadOnly Property HiddenBeamsEditingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HiddenBeamsEditingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


InvalidArrayObject Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..InvalidArrayObject Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidArrayObject { get; }
Visual Basic
Public Shared ReadOnly Property InvalidArrayObject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidArrayObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


InvalidElemsInSelection Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..InvalidElemsInSelection Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't scale elements together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElemsInSelection { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElemsInSelection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidElemsInSelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedByElementArray Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..LockedByElementArray Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Elements managed by Element Arrays are locked by default so that they cannot be moved or deleted inadvertently. To change or delete a managed element unlock it first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByElementArray { get; }
Visual Basic
Public Shared ReadOnly Property LockedByElementArray As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedByElementArray {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedByGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..LockedByGroup Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Grouped elements are locked so that they cannot be changed inadvertently. To change a group member select the group and then click the Edit Group button on the toolbar, then make the change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByGroup { get; }
Visual Basic
Public Shared ReadOnly Property LockedByGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedByGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedByMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..LockedByMassing Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
To unlock a shell element produced from the massing, change its "Constrain to Massing" property.\nTo unlock all shell elements produced from the massing, tab to the massing and delete it.\n

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockedByMassing { get; }
Visual Basic
Public Shared ReadOnly Property LockedByMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedByMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..LockedDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockedDeleted { get; }
Visual Basic
Public Shared ReadOnly Property LockedDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


LockedDeletedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..LockedDeletedWarn Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Pinned objects deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LockedDeletedWarn { get; }
Visual Basic
Public Shared ReadOnly Property LockedDeletedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LockedDeletedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


MirrorProjectSuccess Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..MirrorProjectSuccess Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Action] command has successfully processed [Number] elements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MirrorProjectSuccess { get; }
Visual Basic
Public Shared ReadOnly Property MirrorProjectSuccess As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MirrorProjectSuccess {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NElementsDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..NElementsDeleted Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
[Number] elements were deleted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NElementsDeleted { get; }
Visual Basic
Public Shared ReadOnly Property NElementsDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NElementsDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NElementsWrongPosition Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..NElementsWrongPosition Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Review [Number] elements for correct position and shape

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NElementsWrongPosition { get; }
Visual Basic
Public Shared ReadOnly Property NElementsWrongPosition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NElementsWrongPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NoRotateMirrorZ Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..NoRotateMirrorZ Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZ { get; }
Visual Basic
Public Shared ReadOnly Property NoRotateMirrorZ As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZ {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


NoRotateMirrorZError Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..NoRotateMirrorZError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRotateMirrorZError { get; }
Visual Basic
Public Shared ReadOnly Property NoRotateMirrorZError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRotateMirrorZError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


OutOfDateElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..OutOfDateElements Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Workset is editable, but you must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OutOfDateElements { get; }
Visual Basic
Public Shared ReadOnly Property OutOfDateElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutOfDateElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


OwnedByOther Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..OwnedByOther Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OwnedByOther { get; }
Visual Basic
Public Shared ReadOnly Property OwnedByOther As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OwnedByOther {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


OwnElementsOutOfDate Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..OwnElementsOutOfDate Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You now own the element, but your file is out of date. You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OwnElementsOutOfDate { get; }
Visual Basic
Public Shared ReadOnly Property OwnElementsOutOfDate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OwnElementsOutOfDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


PressShowToSee Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..PressShowToSee Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Press Show to see the element(s); then Ignore or Cancel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PressShowToSee { get; }
Visual Basic
Public Shared ReadOnly Property PressShowToSee As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PressShowToSee {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ReloadBeforeMakeEditable Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ReloadBeforeMakeEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadBeforeMakeEditable { get; }
Visual Basic
Public Shared ReadOnly Property ReloadBeforeMakeEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReloadBeforeMakeEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


ReloadNoGood Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..ReloadNoGood Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadNoGood { get; }
Visual Basic
Public Shared ReadOnly Property ReloadNoGood As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReloadNoGood {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


SourceInEditMode Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..SourceInEditMode Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SourceInEditMode { get; }
Visual Basic
Public Shared ReadOnly Property SourceInEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SourceInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TargetInEditMode Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..TargetInEditMode Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TargetInEditMode { get; }
Visual Basic
Public Shared ReadOnly Property TargetInEditMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TargetInEditMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TemporaryChangesOutOfDate Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..TemporaryChangesOutOfDate Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TemporaryChangesOutOfDate { get; }
Visual Basic
Public Shared ReadOnly Property TemporaryChangesOutOfDate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TemporaryChangesOutOfDate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


TemporaryChangesTransparentPermissions Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..TemporaryChangesTransparentPermissions Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TemporaryChangesTransparentPermissions { get; }
Visual Basic
Public Shared ReadOnly Property TemporaryChangesTransparentPermissions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TemporaryChangesTransparentPermissions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableFilletSpecifiedRadius Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..UnableFilletSpecifiedRadius Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Unable to create Fillet with the specified radius.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableFilletSpecifiedRadius { get; }
Visual Basic
Public Shared ReadOnly Property UnableFilletSpecifiedRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableFilletSpecifiedRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToMakeSourceWorksetEditable Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..UnableToMakeSourceWorksetEditable Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMakeSourceWorksetEditable { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMakeSourceWorksetEditable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMakeSourceWorksetEditable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToTransformElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..UnableToTransformElement Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransformElement { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransformElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


UnableToTransformElementError Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..UnableToTransformElementError Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
Attempted an invalid element rotate, mirror, or move.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransformElementError { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransformElementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransformElementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


WorksetHasChangedInCentralFile Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..WorksetHasChangedInCentralFile Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetHasChangedInCentralFile { get; }
Visual Basic
Public Shared ReadOnly Property WorksetHasChangedInCentralFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetHasChangedInCentralFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


WorksetNoneditableCozAdvanced Property

[image]

Revit 2013 API
BuiltInFailures..::..EditingFailures..::..WorksetNoneditableCozAdvanced Property
BuiltInFailures..::..EditingFailures Class See Also Send Feedback
This workset has changed in the Central Model. Please Reload Latest before making this workset editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetNoneditableCozAdvanced { get; }
Visual Basic
Public Shared ReadOnly Property WorksetNoneditableCozAdvanced As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetNoneditableCozAdvanced {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EditingFailures Class


BuiltInFailures.ElectricalFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Electricity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ElectricalFailures
Visual Basic
Public NotInheritable Class ElectricalFailures
Visual C++
public ref class ElectricalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElectricalFailures

See Also

BuiltInFailures..::..ElectricalFailures Members


BuiltInFailures.ElectricalFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures Members
BuiltInFailures..::..ElectricalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElectricalFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToCircuit | You have selected elements that are connected to other elements. These elements will also be added to the Circuit.
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsOnPanel | There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

See Also

BuiltInFailures..::..ElectricalFailures Class


BuiltInFailures.ElectricalFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures Properties
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback

The BuiltInFailures..::..ElectricalFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToCircuit | You have selected elements that are connected to other elements. These elements will also be added to the Circuit.
AllSlotsOnPanelOccupied | All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.
BankDistanceSmallerThanDiameter | The distance value is smaller than the conduit diameter, please enter a larger value
CableTrayModified | The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.
CannotAssignSecondaryDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].
CannotConnectDifferentDesignOptsObjects | Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.
CannotRemoveMembersInCircuitHavingParent | You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.
CircuitOverload | Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).
ConduitModified | The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.
ElementsBelongToOtherCircuit | You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.
FamilyMismatchCircuit | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?
InvalidNumwiresSinglephase | Invalid number of wires for single phase, only 2 and 3 are valid.
InvalidPathOfParallelConduits | Invalid path of parallel conduits
MismatchConnectorDistSysToCircuit | Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.
MismatchNmbAssignedDistSysToCircuit | Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].
MismatchNmbOfPolesToCircuit | Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.
MismatchPoleBrakesSlotsNumbers | The number of pole breakers may not be less than the number of occupied slots.
MismatchVoltageLineToLine | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).
MismatchVoltageToCircuit | Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.
MissingOrInvalidWireSizeTable | Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.
NoAvailableMatchingConnector | Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.
NotAllowedCableTrayConduitRotation | Don't allow to rotate a horizontal cable tray/conduit like this
NotEnoughAvailSlotsOnPanel | There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.
NotEnoughRoomForParallelConduits | Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.
NotEnoughRoomForParallelPipes | Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.
NotPositiveBendRadius | The value you entered for the bend radius is zero or a negative value. Enter a positive value.
NotSupportConcentricBend | Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.
ObjsDemolished | Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.
PanelMismatchCircuitType | Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.
SelectedElementsArePartOfOtherCircuit | You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.
SmallBendRadius | The value you entered for the bend radius for conduit is too small. Enter a larger value.
UnsignedCircuit | Circuit is not assigned to a panel
VoltageIsOutOfRange | Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

See Also

BuiltInFailures..::..ElectricalFailures Class


AddingOtherConnectedMembersToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..AddingOtherConnectedMembersToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are connected to other elements. These elements will also be added to the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AddingOtherConnectedMembersToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property AddingOtherConnectedMembersToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


AllSlotsOnPanelOccupied Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..AllSlotsOnPanelOccupied Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
All slots on panel: [Panel Name] are occupied. Some circuits will be disconnected from this panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllSlotsOnPanelOccupied { get; }
Visual Basic
Public Shared ReadOnly Property AllSlotsOnPanelOccupied As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllSlotsOnPanelOccupied {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


BankDistanceSmallerThanDiameter Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..BankDistanceSmallerThanDiameter Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The distance value is smaller than the conduit diameter, please enter a larger value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BankDistanceSmallerThanDiameter { get; }
Visual Basic
Public Shared ReadOnly Property BankDistanceSmallerThanDiameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BankDistanceSmallerThanDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CableTrayModified Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..CableTrayModified Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The cable tray has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CableTrayModified { get; }
Visual Basic
Public Shared ReadOnly Property CableTrayModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CableTrayModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotAssignSecondaryDistSysToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..CannotAssignSecondaryDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned secondary distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAssignSecondaryDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property CannotAssignSecondaryDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAssignSecondaryDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotConnectDifferentDesignOptsObjects Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..CannotConnectDifferentDesignOptsObjects Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add or assign [Element] to circuit. Electrical objects belonging to different design options cannot be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConnectDifferentDesignOptsObjects { get; }
Visual Basic
Public Shared ReadOnly Property CannotConnectDifferentDesignOptsObjects As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConnectDifferentDesignOptsObjects {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CannotRemoveMembersInCircuitHavingParent Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..CannotRemoveMembersInCircuitHavingParent Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are connected to a Panel object in a Circuit. These elements cannot be removed from the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveMembersInCircuitHavingParent { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveMembersInCircuitHavingParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveMembersInCircuitHavingParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


CircuitOverload Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..CircuitOverload Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Total connected load for Circuit [Name] is exceeding 80% of the defined rating ([Rating Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircuitOverload { get; }
Visual Basic
Public Shared ReadOnly Property CircuitOverload As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircuitOverload {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ConduitModified Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..ConduitModified Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The conduit has been modified to be in the opposite direction or insufficient space to create the required fittings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConduitModified { get; }
Visual Basic
Public Shared ReadOnly Property ConduitModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConduitModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ElementsBelongToOtherCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..ElementsBelongToOtherCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are already part of other Circuits that have assigned Panels. The elements you selected cannot be added to this Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsBelongToOtherCircuit { get; }
Visual Basic
Public Shared ReadOnly Property ElementsBelongToOtherCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsBelongToOtherCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


FamilyMismatchCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..FamilyMismatchCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuit { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMismatchCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidNumwiresSinglephase Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..InvalidNumwiresSinglephase Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Invalid number of wires for single phase, only 2 and 3 are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidNumwiresSinglephase { get; }
Visual Basic
Public Shared ReadOnly Property InvalidNumwiresSinglephase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidNumwiresSinglephase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


InvalidPathOfParallelConduits Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..InvalidPathOfParallelConduits Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Invalid path of parallel conduits

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPathOfParallelConduits { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPathOfParallelConduits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPathOfParallelConduits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchConnectorDistSysToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchConnectorDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Type for the available connector does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchConnectorDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchConnectorDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchConnectorDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchNmbAssignedDistSysToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchNmbAssignedDistSysToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. There is no assigned distribution system for [Element].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNmbAssignedDistSysToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchNmbAssignedDistSysToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbAssignedDistSysToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchNmbOfPolesToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchNmbOfPolesToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Number of Poles for [Element] does not match the Number of Poles ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchNmbOfPolesToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchNmbOfPolesToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchNmbOfPolesToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchPoleBrakesSlotsNumbers Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchPoleBrakesSlotsNumbers Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The number of pole breakers may not be less than the number of occupied slots.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchPoleBrakesSlotsNumbers { get; }
Visual Basic
Public Shared ReadOnly Property MismatchPoleBrakesSlotsNumbers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchPoleBrakesSlotsNumbers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchVoltageLineToLine Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchVoltageLineToLine Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Line Voltage for [Element] (The Line to Line Voltage is specified in the assigned Distribution System).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchVoltageLineToLine { get; }
Visual Basic
Public Shared ReadOnly Property MismatchVoltageLineToLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchVoltageLineToLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MismatchVoltageToCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MismatchVoltageToCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. The Voltage for [Element] is out of range for the Voltage ([Voltage Value]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchVoltageToCircuit { get; }
Visual Basic
Public Shared ReadOnly Property MismatchVoltageToCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchVoltageToCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


MissingOrInvalidWireSizeTable Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..MissingOrInvalidWireSizeTable Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Wire Size Table "[Fail Name]" is missing or invalid. Use Electrical Settings to select a valid Wire Size Table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissingOrInvalidWireSizeTable { get; }
Visual Basic
Public Shared ReadOnly Property MissingOrInvalidWireSizeTable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingOrInvalidWireSizeTable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NoAvailableMatchingConnector Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NoAvailableMatchingConnector Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot add [Element] to Circuit. There is no available connector matching the Type ([Type Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoAvailableMatchingConnector { get; }
Visual Basic
Public Shared ReadOnly Property NoAvailableMatchingConnector As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAvailableMatchingConnector {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotAllowedCableTrayConduitRotation Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotAllowedCableTrayConduitRotation Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Don't allow to rotate a horizontal cable tray/conduit like this

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedCableTrayConduitRotation { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedCableTrayConduitRotation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedCableTrayConduitRotation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughAvailSlotsOnPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughAvailSlotsOnPanel Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
There are not enough slots available on panel: [Panel Name] for a circuit to be added. Please increase the maximum number of single pole breakers to be greater than [Number] or set it to 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughAvailSlotsOnPanel { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughAvailSlotsOnPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughAvailSlotsOnPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughRoomForParallelConduits Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughRoomForParallelConduits Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Due to changes in elevation, there is not enough room to generate all of the parallel conduits. As a result, some conduit segments have not been generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForParallelConduits { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForParallelConduits As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForParallelConduits {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotEnoughRoomForParallelPipes Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotEnoughRoomForParallelPipes Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Due to changes in elevation, there is not enough room to generate all of the parallel pipes. As a result, some pipe segments have not been generated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRoomForParallelPipes { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRoomForParallelPipes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRoomForParallelPipes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotPositiveBendRadius Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotPositiveBendRadius Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The value you entered for the bend radius is zero or a negative value. Enter a positive value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotPositiveBendRadius { get; }
Visual Basic
Public Shared ReadOnly Property NotPositiveBendRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotPositiveBendRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


NotSupportConcentricBend Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..NotSupportConcentricBend Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Conduit with Fittings do not support Concentric Bend Radius, the bend radius of the conduit fittings will be same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotSupportConcentricBend { get; }
Visual Basic
Public Shared ReadOnly Property NotSupportConcentricBend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotSupportConcentricBend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


ObjsDemolished Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..ObjsDemolished Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to circuit. Objects that are demolished cannot be added to a circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ObjsDemolished { get; }
Visual Basic
Public Shared ReadOnly Property ObjsDemolished As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ObjsDemolished {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


PanelMismatchCircuitType Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..PanelMismatchCircuitType Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign [Element] to Circuit. The Type for the panel does not match the Type ([Name]) for the Circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelMismatchCircuitType { get; }
Visual Basic
Public Shared ReadOnly Property PanelMismatchCircuitType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelMismatchCircuitType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


SelectedElementsArePartOfOtherCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..SelectedElementsArePartOfOtherCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
You have selected elements that are already part of other Circuits. They will be removed from the original Circuits and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherCircuit { get; }
Visual Basic
Public Shared ReadOnly Property SelectedElementsArePartOfOtherCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


SmallBendRadius Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..SmallBendRadius Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
The value you entered for the bend radius for conduit is too small. Enter a larger value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SmallBendRadius { get; }
Visual Basic
Public Shared ReadOnly Property SmallBendRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SmallBendRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


UnsignedCircuit Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..UnsignedCircuit Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Circuit is not assigned to a panel

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnsignedCircuit { get; }
Visual Basic
Public Shared ReadOnly Property UnsignedCircuit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsignedCircuit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


VoltageIsOutOfRange Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricalFailures..::..VoltageIsOutOfRange Property
BuiltInFailures..::..ElectricalFailures Class See Also Send Feedback
Cannot assign or add [Element] to Circuit. The Voltage ([Voltage Value]) for the Circuit is out of range for the Line to Ground Voltage for [Element] (The Line to Ground Voltage is specified in the assigned Distribution System)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VoltageIsOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property VoltageIsOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VoltageIsOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricalFailures Class


BuiltInFailures.ElectricityFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ElectricityFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ElectricityFailures
Visual Basic
Public NotInheritable Class ElectricityFailures
Visual C++
public ref class ElectricityFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElectricityFailures

See Also

BuiltInFailures..::..ElectricityFailures Members


BuiltInFailures.ElectricityFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElectricityFailures Members
BuiltInFailures..::..ElectricityFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElectricityFailures type exposes the following members.

Properties

Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

See Also

BuiltInFailures..::..ElectricityFailures Class


BuiltInFailures.ElectricityFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElectricityFailures Properties
BuiltInFailures..::..ElectricityFailures Class See Also Send Feedback

The BuiltInFailures..::..ElectricityFailures type exposes the following members.

Properties

Name | Description
FamilyMismatchCircuitDisconnected | The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

See Also

BuiltInFailures..::..ElectricityFailures Class


FamilyMismatchCircuitDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..ElectricityFailures..::..FamilyMismatchCircuitDisconnected Property
BuiltInFailures..::..ElectricityFailures Class See Also Send Feedback
The family no longer matches the properties for the Circuit. Disconnect the family from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyMismatchCircuitDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMismatchCircuitDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMismatchCircuitDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElectricityFailures Class


BuiltInFailures.ElementFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ElementFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ElementFailures
Visual Basic
Public NotInheritable Class ElementFailures
Visual C++
public ref class ElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElementFailures

See Also

BuiltInFailures..::..ElementFailures Members


BuiltInFailures.ElementFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElementFailures Members
BuiltInFailures..::..ElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElementFailures type exposes the following members.

Properties

Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.

See Also

BuiltInFailures..::..ElementFailures Class


BuiltInFailures.ElementFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElementFailures Properties
BuiltInFailures..::..ElementFailures Class See Also Send Feedback

The BuiltInFailures..::..ElementFailures type exposes the following members.

Properties

Name | Description
FailedToRemoveElement | Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.
NotAllowedToRemoveAllElements | You cannot removed all the elements from current solution. At least there should be two elements in the solution.
SplitElementHasTagsWithoutLeaders | The split element has one or more Tags without Leaders enabled and needs to be checked.

See Also

BuiltInFailures..::..ElementFailures Class


FailedToRemoveElement Property

[image]

Revit 2013 API
BuiltInFailures..::..ElementFailures..::..FailedToRemoveElement Property
BuiltInFailures..::..ElementFailures Class See Also Send Feedback
Element cannot be removed from the solution. The solution is required to have at least two elements to be valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToRemoveElement { get; }
Visual Basic
Public Shared ReadOnly Property FailedToRemoveElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToRemoveElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementFailures Class


NotAllowedToRemoveAllElements Property

[image]

Revit 2013 API
BuiltInFailures..::..ElementFailures..::..NotAllowedToRemoveAllElements Property
BuiltInFailures..::..ElementFailures Class See Also Send Feedback
You cannot removed all the elements from current solution. At least there should be two elements in the solution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllowedToRemoveAllElements { get; }
Visual Basic
Public Shared ReadOnly Property NotAllowedToRemoveAllElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllowedToRemoveAllElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementFailures Class


SplitElementHasTagsWithoutLeaders Property

[image]

Revit 2013 API
BuiltInFailures..::..ElementFailures..::..SplitElementHasTagsWithoutLeaders Property
BuiltInFailures..::..ElementFailures Class See Also Send Feedback
The split element has one or more Tags without Leaders enabled and needs to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SplitElementHasTagsWithoutLeaders { get; }
Visual Basic
Public Shared ReadOnly Property SplitElementHasTagsWithoutLeaders As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitElementHasTagsWithoutLeaders {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementFailures Class


BuiltInFailures.ElementTypeFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ElementTypeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ElementTypeFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ElementTypeFailures
Visual Basic
Public NotInheritable Class ElementTypeFailures
Visual C++
public ref class ElementTypeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElementTypeFailures

See Also

BuiltInFailures..::..ElementTypeFailures Members


BuiltInFailures.ElementTypeFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElementTypeFailures Members
BuiltInFailures..::..ElementTypeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::..ElementTypeFailures Class


BuiltInFailures.ElementTypeFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElementTypeFailures Properties
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback

The BuiltInFailures..::..ElementTypeFailures type exposes the following members.

Properties

Name | Description
NoDefaultType | As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.
WarnLastType1 | Last type in system family '[Name]' cannot be deleted.

See Also

BuiltInFailures..::..ElementTypeFailures Class


NoDefaultType Property

[image]

Revit 2013 API
BuiltInFailures..::..ElementTypeFailures..::..NoDefaultType Property
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no types of [User Name] left. Create a new type by duplicating an existing [User Name] type in the Project Browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoDefaultType { get; }
Visual Basic
Public Shared ReadOnly Property NoDefaultType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoDefaultType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementTypeFailures Class


WarnLastType1 Property

[image]

Revit 2013 API
BuiltInFailures..::..ElementTypeFailures..::..WarnLastType1 Property
BuiltInFailures..::..ElementTypeFailures Class See Also Send Feedback
Last type in system family '[Name]' cannot be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WarnLastType1 { get; }
Visual Basic
Public Shared ReadOnly Property WarnLastType1 As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WarnLastType1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElementTypeFailures Class


BuiltInFailures.ElevationFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ElevationFailures
Visual Basic
Public NotInheritable Class ElevationFailures
Visual C++
public ref class ElevationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ElevationFailures

See Also

BuiltInFailures..::..ElevationFailures Members


BuiltInFailures.ElevationFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures Members
BuiltInFailures..::..ElevationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ElevationFailures type exposes the following members.

Properties

Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

See Also

BuiltInFailures..::..ElevationFailures Class


BuiltInFailures.ElevationFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures Properties
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback

The BuiltInFailures..::..ElevationFailures type exposes the following members.

Properties

Name | Description
ElevationDetach | An Elevation arrow can't keep its Crop Region extents attached.
IncompatibleElevationTagFamily | Attempt to change elevation tag families to one with incompatible view directions.
WarnElevSheet | An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

See Also

BuiltInFailures..::..ElevationFailures Class


ElevationDetach Property

[image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures..::..ElevationDetach Property
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback
An Elevation arrow can't keep its Crop Region extents attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElevationDetach { get; }
Visual Basic
Public Shared ReadOnly Property ElevationDetach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElevationDetach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElevationFailures Class


IncompatibleElevationTagFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures..::..IncompatibleElevationTagFamily Property
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback
Attempt to change elevation tag families to one with incompatible view directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IncompatibleElevationTagFamily { get; }
Visual Basic
Public Shared ReadOnly Property IncompatibleElevationTagFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IncompatibleElevationTagFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElevationFailures Class


WarnElevSheet Property

[image]

Revit 2013 API
BuiltInFailures..::..ElevationFailures..::..WarnElevSheet Property
BuiltInFailures..::..ElevationFailures Class See Also Send Feedback
An elevation symbol references views on more than one sheet. It will show a blank sheet reference. To show the correct references, use a separate elevation symbol for the views on each sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WarnElevSheet { get; }
Visual Basic
Public Shared ReadOnly Property WarnElevSheet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WarnElevSheet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ElevationFailures Class


BuiltInFailures.EnergyAnalysisFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about EnergyAnalysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class EnergyAnalysisFailures
Visual Basic
Public NotInheritable Class EnergyAnalysisFailures
Visual C++
public ref class EnergyAnalysisFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..EnergyAnalysisFailures

See Also

BuiltInFailures..::..EnergyAnalysisFailures Members


BuiltInFailures.EnergyAnalysisFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures Members
BuiltInFailures..::..EnergyAnalysisFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..EnergyAnalysisFailures type exposes the following members.

Properties

Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNegativeWarn | [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


BuiltInFailures.EnergyAnalysisFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures Properties
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback

The BuiltInFailures..::..EnergyAnalysisFailures type exposes the following members.

Properties

Name | Description
ComputeRoomVolumeNotCheckedWarn | The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes
ModelWithNoConditionedSpacesWarn | The model has no conditioned spaces.
ModelWithNoOccupiedSpacesWarn | The model has no occupiable spaces.
NoRoofsRoomBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.
NoRoofsSpacesBoundingWarn | The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.
NoRoomBoundingElements | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.
NoRoomsWarn | Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.
NoSpaceBoundingElements | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpaceBoundingElementsWarn | Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.
NoSpacesWarn | Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.
PlenumWithNoCeilingWarn | [Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.
ProblemWithLightingLoadWarn | [Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPeopleLoadWarn | [Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
ProblemWithPowerLoadWarn | [Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.
RoomGeometryCannotFindFreeFacesBoundingElement | An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.
RoomGeometryCannotOverlapBoundingElement | An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].
RoomGeometryCannotTrimBoundingElement | An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].
RoomNotPlacedWarn | [Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.
RoomNotUpperBoundedByElement | [Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.
RoomVolumeNegativeWarn | [Room] has a negative volume? [Room] will be ignored in the energy analysis model.
RoomVolumeNotComputedWarn | [Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.
UndefinedRooms | There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.
UndefinedSpaces | There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.
ZoneWithoutSpacesWarn | This zone has no spaces.

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ComputeRoomVolumeNotCheckedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ComputeRoomVolumeNotCheckedWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The setting for calculation of Volume Computations is not on. The analysis model produced will be approximate without the computation of Areas and Volumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ComputeRoomVolumeNotCheckedWarn { get; }
Visual Basic
Public Shared ReadOnly Property ComputeRoomVolumeNotCheckedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComputeRoomVolumeNotCheckedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ModelWithNoConditionedSpacesWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ModelWithNoConditionedSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The model has no conditioned spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModelWithNoConditionedSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property ModelWithNoConditionedSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModelWithNoConditionedSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ModelWithNoOccupiedSpacesWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ModelWithNoOccupiedSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The model has no occupiable spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModelWithNoOccupiedSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property ModelWithNoOccupiedSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModelWithNoOccupiedSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoofsRoomBoundingWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoofsRoomBoundingWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are room bounding, and make sure that the room offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoofsRoomBoundingWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoofsRoomBoundingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoofsRoomBoundingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoofsSpacesBoundingWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoofsSpacesBoundingWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
The energy analysis model does not contain any roof surfaces! If there are roofs in your model, please verify that they are space bounding, and make sure that the space offsets are high enough to include the roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoofsSpacesBoundingWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoofsSpacesBoundingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoofsSpacesBoundingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoomBoundingElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoomBoundingElements Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomBoundingElements { get; }
Visual Basic
Public Shared ReadOnly Property NoRoomBoundingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoomBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoomBoundingElementsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoomBoundingElementsWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Room bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomBoundingElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoomBoundingElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoomBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoRoomsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoRoomsWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any rooms. If you are sure that rooms have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which rooms have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRoomsWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoRoomsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRoomsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpaceBoundingElements Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpaceBoundingElements Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElements { get; }
Visual Basic
Public Shared ReadOnly Property NoSpaceBoundingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpaceBoundingElementsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpaceBoundingElementsWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Can't create any energy analysis surfaces. There are no Space bounding elements defined in the current phase. Please check the Project Information settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpaceBoundingElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoSpaceBoundingElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpaceBoundingElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


NoSpacesWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..NoSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
Revit was unable to identify any spaces. If you are sure that spaces have been created in the project, please check the Project Phase setting to verify that the Project Phase matches the phase in which spaces have been defined in your project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


PlenumWithNoCeilingWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..PlenumWithNoCeilingWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room] has Space Type set to Plenum but has no ceiling surface. A plenum must be separated from the space it serves by a ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PlenumWithNoCeilingWarn { get; }
Visual Basic
Public Shared ReadOnly Property PlenumWithNoCeilingWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlenumWithNoCeilingWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithLightingLoadWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithLightingLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s lighting load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithLightingLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithLightingLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithLightingLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithPeopleLoadWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithPeopleLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s number of people or people load (sensible or latent) is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithPeopleLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithPeopleLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPeopleLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ProblemWithPowerLoadWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ProblemWithPowerLoadWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room]'s power load is too high. This may be caused by an incorrect density value and must be corrected before this space can be included in the load calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemWithPowerLoadWarn { get; }
Visual Basic
Public Shared ReadOnly Property ProblemWithPowerLoadWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemWithPowerLoadWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomGeometryCannotFindFreeFacesBoundingElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomGeometryCannotFindFreeFacesBoundingElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trying to find the free part of a face of the bounding geometry for [Room] when processing the room-bounding element [Name]. The free part of the face is found by subtracting the portions of the face that overlap various room-bounding element faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotFindFreeFacesBoundingElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomGeometryCannotFindFreeFacesBoundingElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotFindFreeFacesBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomGeometryCannotOverlapBoundingElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomGeometryCannotOverlapBoundingElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trying to find the region where a face of the bounding geometry for [Room] overlaps a face of a room-bounding element [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotOverlapBoundingElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomGeometryCannotOverlapBoundingElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotOverlapBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomGeometryCannotTrimBoundingElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomGeometryCannotTrimBoundingElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
An error occurred while trimming the vertical shadow of a room-bounding element [Name] of the bounding geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomGeometryCannotTrimBoundingElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomGeometryCannotTrimBoundingElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomGeometryCannotTrimBoundingElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomNotPlacedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomNotPlacedWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Family] is not placed. Physical properties such as area will display as "Not Placed" in schedules. You can place the [Family] using the option bar in the [Family] tool, or you can delete the [Family] in a schedule. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotPlacedWarn { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotPlacedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotPlacedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomNotUpperBoundedByElement Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomNotUpperBoundedByElement Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Family] is not upper bounded by a roof, ceiling or floor element. This can result in incorrect adjacencies and voids in the analytical model. Please ensure that Upper Limit and Limit Offset for [Room] is set correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotUpperBoundedByElement { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotUpperBoundedByElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotUpperBoundedByElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomVolumeNegativeWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomVolumeNegativeWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Room] has a negative volume? [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomVolumeNegativeWarn { get; }
Visual Basic
Public Shared ReadOnly Property RoomVolumeNegativeWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomVolumeNegativeWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


RoomVolumeNotComputedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..RoomVolumeNotComputedWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
[Family] volume can't be computed. The bounding geometry (in 3D) can't be found for [Room]. [Room] will be ignored in the energy analysis model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomVolumeNotComputedWarn { get; }
Visual Basic
Public Shared ReadOnly Property RoomVolumeNotComputedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomVolumeNotComputedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


UndefinedRooms Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..UndefinedRooms Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Rooms in the model! Recommend creating a Room schedule and checking the Area parameter of each Room for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedRooms { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


UndefinedSpaces Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..UndefinedSpaces Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
There are undefined Spaces in the model! Recommend creating a Space schedule and checking the Area parameter of each Space for warnings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedSpaces { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


ZoneWithoutSpacesWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..EnergyAnalysisFailures..::..ZoneWithoutSpacesWarn Property
BuiltInFailures..::..EnergyAnalysisFailures Class See Also Send Feedback
This zone has no spaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ZoneWithoutSpacesWarn { get; }
Visual Basic
Public Shared ReadOnly Property ZoneWithoutSpacesWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZoneWithoutSpacesWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..EnergyAnalysisFailures Class


BuiltInFailures.ExportFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ExportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ExportFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ExportFailures
Visual Basic
Public NotInheritable Class ExportFailures
Visual C++
public ref class ExportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ExportFailures

See Also

BuiltInFailures..::..ExportFailures Members


BuiltInFailures.ExportFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ExportFailures Members
BuiltInFailures..::..ExportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ExportFailures type exposes the following members.

Properties

Name | Description
IFCFatalExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCFatalToolkitExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCGenericExportWarning | Unexpected errors occurred while exporting these elements to the IFC file.

See Also

BuiltInFailures..::..ExportFailures Class


BuiltInFailures.ExportFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ExportFailures Properties
BuiltInFailures..::..ExportFailures Class See Also Send Feedback

The BuiltInFailures..::..ExportFailures type exposes the following members.

Properties

Name | Description
IFCFatalExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCFatalToolkitExportError | There has been an unrecoverable error during export. Export will now be aborted.
IFCGenericExportWarning | Unexpected errors occurred while exporting these elements to the IFC file.

See Also

BuiltInFailures..::..ExportFailures Class


IFCFatalExportError Property

[image]

Revit 2013 API
BuiltInFailures..::..ExportFailures..::..IFCFatalExportError Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IFCFatalExportError { get; }
Visual Basic
Public Shared ReadOnly Property IFCFatalExportError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCFatalExportError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


IFCFatalToolkitExportError Property

[image]

Revit 2013 API
BuiltInFailures..::..ExportFailures..::..IFCFatalToolkitExportError Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
There has been an unrecoverable error during export. Export will now be aborted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IFCFatalToolkitExportError { get; }
Visual Basic
Public Shared ReadOnly Property IFCFatalToolkitExportError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCFatalToolkitExportError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


IFCGenericExportWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ExportFailures..::..IFCGenericExportWarning Property
BuiltInFailures..::..ExportFailures Class See Also Send Feedback
Unexpected errors occurred while exporting these elements to the IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IFCGenericExportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericExportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericExportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExportFailures Class


BuiltInFailures.ExtrusionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Extrusions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ExtrusionFailures
Visual Basic
Public NotInheritable Class ExtrusionFailures
Visual C++
public ref class ExtrusionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ExtrusionFailures

See Also

BuiltInFailures..::..ExtrusionFailures Members


BuiltInFailures.ExtrusionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures Members
BuiltInFailures..::..ExtrusionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::..ExtrusionFailures Class


BuiltInFailures.ExtrusionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures Properties
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback

The BuiltInFailures..::..ExtrusionFailures type exposes the following members.

Properties

Name | Description
CannotDrawExtrusions | Can't make Extrusion.
CannotDrawExtrusionsError | Can't make Extrusion.
InvalidExtrusionCurveloop | Base sketch for extrusion is invalid.
InvalidExtrusionCurveloopError | Base sketch for extrusion is invalid.

See Also

BuiltInFailures..::..ExtrusionFailures Class


CannotDrawExtrusions Property

[image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures..::..CannotDrawExtrusions Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusions { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawExtrusions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


CannotDrawExtrusionsError Property

[image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures..::..CannotDrawExtrusionsError Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Can't make Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusionsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawExtrusionsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusionsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


InvalidExtrusionCurveloop Property

[image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures..::..InvalidExtrusionCurveloop Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloop { get; }
Visual Basic
Public Shared ReadOnly Property InvalidExtrusionCurveloop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


InvalidExtrusionCurveloopError Property

[image]

Revit 2013 API
BuiltInFailures..::..ExtrusionFailures..::..InvalidExtrusionCurveloopError Property
BuiltInFailures..::..ExtrusionFailures Class See Also Send Feedback
Base sketch for extrusion is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidExtrusionCurveloopError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidExtrusionCurveloopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidExtrusionCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ExtrusionFailures Class


BuiltInFailures.FabricAreaFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FabricAreaFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FabricAreaFailures
Visual Basic
Public NotInheritable Class FabricAreaFailures
Visual C++
public ref class FabricAreaFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FabricAreaFailures

See Also

BuiltInFailures..::..FabricAreaFailures Members


BuiltInFailures.FabricAreaFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FabricAreaFailures Members
BuiltInFailures..::..FabricAreaFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FabricAreaFailures type exposes the following members.

Properties

Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.

See Also

BuiltInFailures..::..FabricAreaFailures Class


BuiltInFailures.FabricAreaFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FabricAreaFailures Properties
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricAreaFailures type exposes the following members.

Properties

Name | Description
FabricAreaLapSplicesIncorrect | Fabric Area lap splice is incorrect.
FabricAreaOutSideOfHost | Fabric Area is sketched completely outside of its host.

See Also

BuiltInFailures..::..FabricAreaFailures Class


FabricAreaLapSplicesIncorrect Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricAreaFailures..::..FabricAreaLapSplicesIncorrect Property
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback
Fabric Area lap splice is incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FabricAreaLapSplicesIncorrect { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaLapSplicesIncorrect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaLapSplicesIncorrect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricAreaFailures Class


FabricAreaOutSideOfHost Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricAreaFailures..::..FabricAreaOutSideOfHost Property
BuiltInFailures..::..FabricAreaFailures Class See Also Send Feedback
Fabric Area is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FabricAreaOutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaOutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaOutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricAreaFailures Class


BuiltInFailures.FabricFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fabric.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FabricFailures
Visual Basic
Public NotInheritable Class FabricFailures
Visual C++
public ref class FabricFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FabricFailures

See Also

BuiltInFailures..::..FabricFailures Members


BuiltInFailures.FabricFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FabricFailures Members
BuiltInFailures..::..FabricFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FabricFailures type exposes the following members.

Properties

Name | Description
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CoverOffsetTooLong | Cover offset is greater than host thickness.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.

See Also

BuiltInFailures..::..FabricFailures Class


BuiltInFailures.FabricFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FabricFailures Properties
BuiltInFailures..::..FabricFailures Class See Also Send Feedback

The BuiltInFailures..::..FabricFailures type exposes the following members.

Properties

Name | Description
CannotPlaceFabricArea | Can't find a host for Fabric Area.
CannotPlaceFabricAreaWarn | Can't find a host for Fabric Area.
CoverOffsetTooLong | Cover offset is greater than host thickness.
FabricAreaWrongHost | Fabric Area can be placed only in Structural Floors and straight Structural Walls.
FabricAreaWrongLapSplice | Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
FabricAreaWrongSheetAlignment | Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
MajorLapSpliceFailure | The lap splice in the major direction is greater than the half of the overall length.
MajorOverhangFailure | At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
MajorSpacingFailure | The spacing in the major direction is lower than diameter of the wire in the minor direction.
MinorLapSpliceFailure | The lap splice in the minor direction is greater than the half of the overall width.
MinorOverhangFailure | At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
MinorSpacingFailure | The spacing in the minor direction is lower than diameter of the wire in the major direction.
NoSurfPatternOnWire | Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
NoWireMaterialDensity | Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
WireDiameterTooLarge | Fabric Wire Diameter is too large.
WrongFabricSheetEndOverhang | Wrong Start Overhang of the Fabric Sheet Type.
WrongFabricSheetLayoutPattern | The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
WrongFabricSheetNumberOfWires | Wrong Number of Wires of the Fabric Sheet Type.
WrongFabricSheetOverallLength | Wrong Overall Length/Width of the Fabric Sheet Type.
WrongFabricSheetSpacing | Wrong Spacing of the Fabric Sheet Type.
WrongFabricSheetStartOverhang | Wrong Start Overhang of the Fabric Sheet Type.

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricArea Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricArea Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricArea { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricArea As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CannotPlaceFabricAreaWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..CannotPlaceFabricAreaWarn Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Can't find a host for Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceFabricAreaWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceFabricAreaWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceFabricAreaWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


CoverOffsetTooLong Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..CoverOffsetTooLong Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Cover offset is greater than host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CoverOffsetTooLong { get; }
Visual Basic
Public Shared ReadOnly Property CoverOffsetTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoverOffsetTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricAreaWrongHost Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..FabricAreaWrongHost Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Area can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FabricAreaWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricAreaWrongLapSplice Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..FabricAreaWrongLapSplice Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FabricAreaWrongLapSplice { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaWrongLapSplice As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaWrongLapSplice {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


FabricAreaWrongSheetAlignment Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..FabricAreaWrongSheetAlignment Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FabricAreaWrongSheetAlignment { get; }
Visual Basic
Public Shared ReadOnly Property FabricAreaWrongSheetAlignment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FabricAreaWrongSheetAlignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MajorLapSpliceFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MajorLapSpliceFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The lap splice in the major direction is greater than the half of the overall length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MajorLapSpliceFailure { get; }
Visual Basic
Public Shared ReadOnly Property MajorLapSpliceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MajorLapSpliceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MajorOverhangFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MajorOverhangFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MajorOverhangFailure { get; }
Visual Basic
Public Shared ReadOnly Property MajorOverhangFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MajorOverhangFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MajorSpacingFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MajorSpacingFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The spacing in the major direction is lower than diameter of the wire in the minor direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MajorSpacingFailure { get; }
Visual Basic
Public Shared ReadOnly Property MajorSpacingFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MajorSpacingFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorLapSpliceFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MinorLapSpliceFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The lap splice in the minor direction is greater than the half of the overall width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinorLapSpliceFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorLapSpliceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorLapSpliceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorOverhangFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MinorOverhangFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinorOverhangFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorOverhangFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorOverhangFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


MinorSpacingFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..MinorSpacingFailure Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The spacing in the minor direction is lower than diameter of the wire in the major direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinorSpacingFailure { get; }
Visual Basic
Public Shared ReadOnly Property MinorSpacingFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinorSpacingFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


NoSurfPatternOnWire Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..NoSurfPatternOnWire Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnWire { get; }
Visual Basic
Public Shared ReadOnly Property NoSurfPatternOnWire As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnWire {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


NoWireMaterialDensity Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..NoWireMaterialDensity Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoWireMaterialDensity { get; }
Visual Basic
Public Shared ReadOnly Property NoWireMaterialDensity As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoWireMaterialDensity {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WireDiameterTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WireDiameterTooLarge Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Fabric Wire Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WireDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property WireDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WireDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetEndOverhang Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetEndOverhang Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Start Overhang of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetEndOverhang { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetEndOverhang As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetEndOverhang {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetLayoutPattern Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetLayoutPattern Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetLayoutPattern { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetLayoutPattern As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetLayoutPattern {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetNumberOfWires Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetNumberOfWires Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Number of Wires of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetNumberOfWires { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetNumberOfWires As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetNumberOfWires {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetOverallLength Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetOverallLength Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Overall Length/Width of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetOverallLength { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetOverallLength As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetOverallLength {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetSpacing Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetSpacing Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Spacing of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetSpacing { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


WrongFabricSheetStartOverhang Property

[image]

Revit 2013 API
BuiltInFailures..::..FabricFailures..::..WrongFabricSheetStartOverhang Property
BuiltInFailures..::..FabricFailures Class See Also Send Feedback
Wrong Start Overhang of the Fabric Sheet Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFabricSheetStartOverhang { get; }
Visual Basic
Public Shared ReadOnly Property WrongFabricSheetStartOverhang As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFabricSheetStartOverhang {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FabricFailures Class


BuiltInFailures.FaceSplitterFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FaceSplitter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FaceSplitterFailures
Visual Basic
Public NotInheritable Class FaceSplitterFailures
Visual C++
public ref class FaceSplitterFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FaceSplitterFailures

See Also

BuiltInFailures..::..FaceSplitterFailures Members


BuiltInFailures.FaceSplitterFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures Members
BuiltInFailures..::..FaceSplitterFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::..FaceSplitterFailures Class


BuiltInFailures.FaceSplitterFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures Properties
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback

The BuiltInFailures..::..FaceSplitterFailures type exposes the following members.

Properties

Name | Description
CannotUseCurvesForFaceSplit | The sketch cannot split the face of the highlighted element.
EndsNotOnEdgeError | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
InvalidClosedLoopsForFaceSplit | The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
InvalidOpenLoopsForFaceSplit | The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
LoopsDoNotSubdivideFace | Sketched loops must sub-divide the face into two or more completely enclosed regions.
LoopsOutsideFaceSplitError | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
NoFaceForSplit | The highlighted element no longer contains a face that has been split by highlighted sketch.

See Also

BuiltInFailures..::..FaceSplitterFailures Class


CannotUseCurvesForFaceSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..CannotUseCurvesForFaceSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The sketch cannot split the face of the highlighted element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUseCurvesForFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property CannotUseCurvesForFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUseCurvesForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


EndsNotOnEdgeError Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..EndsNotOnEdgeError Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnEdgeError { get; }
Visual Basic
Public Shared ReadOnly Property EndsNotOnEdgeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdgeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


InvalidClosedLoopsForFaceSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..InvalidClosedLoopsForFaceSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidClosedLoopsForFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property InvalidClosedLoopsForFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidClosedLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


InvalidOpenLoopsForFaceSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..InvalidOpenLoopsForFaceSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidOpenLoopsForFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property InvalidOpenLoopsForFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidOpenLoopsForFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


LoopsDoNotSubdivideFace Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..LoopsDoNotSubdivideFace Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Sketched loops must sub-divide the face into two or more completely enclosed regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsDoNotSubdivideFace { get; }
Visual Basic
Public Shared ReadOnly Property LoopsDoNotSubdivideFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsDoNotSubdivideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


LoopsOutsideFaceSplitError Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..LoopsOutsideFaceSplitError Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitError { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplitError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


NoFaceForSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..FaceSplitterFailures..::..NoFaceForSplit Property
BuiltInFailures..::..FaceSplitterFailures Class See Also Send Feedback
The highlighted element no longer contains a face that has been split by highlighted sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFaceForSplit { get; }
Visual Basic
Public Shared ReadOnly Property NoFaceForSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFaceForSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FaceSplitterFailures Class


BuiltInFailures.FamilyFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FamilyFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FamilyFailures
Visual Basic
Public NotInheritable Class FamilyFailures
Visual C++
public ref class FamilyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FamilyFailures

See Also

BuiltInFailures..::..FamilyFailures Members


BuiltInFailures.FamilyFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures Members
BuiltInFailures..::..FamilyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FamilyFailures type exposes the following members.

Properties

Name | Description
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersCorruption | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]

See Also

BuiltInFailures..::..FamilyFailures Class


BuiltInFailures.FamilyFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures Properties
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback

The BuiltInFailures..::..FamilyFailures type exposes the following members.

Properties

Name | Description
CannotChangeCategory | Can't change category of Family Instance
CannotChangeInstFam | Can't change Instance's Family. Try changing Instance's Host to a Level first.
CannotConvertInstHostToWorkPlane | Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.
CannotConvertInstWorkPlaneToHost | Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.
CannotCopyByPatternFamilies | Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.
CannotCopyInplaceFamily | In-place family groups cannot be copied between in-place families of the same project.
CannotCutRefPlane | Can't cut reference plane.
CannotFindHost | Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.
CannotLoadImperialFamilyToMetricProject | Can't load an imperial Family into a metric Project.
CannotLoadMetricFamilyToImperialProject | Can't load a metric Family into an imperial Project.
CannotMakeType |
CannotMakeTypeCB | Can't make type "[Family Name]".
CannotMakeTypeFamilySaved | Can't make type "[Family Name]". Failing family has been saved to "[File Name]"
CannotPasteLabelsAcrossFamilies | Can't paste Labels across Families of different Categories.
CannotPasteObject | Can't paste some or all of the selected objects.
CannotRotateElement | Can't rotate element into this position.
CannotSetFamilyTypeToNone | Cannot set Family Type to 'None';.
CannotUnlockFamilyTemplate | Can't unlock alignments from Family Template.
CantCopySelectionToNonStory | Can't copy this selection to a non-story Level.
CantEditWhileGrouped | You may not edit this parameter while the element is grouped.
CantMirrorInstWoHost | Can't mirror an instance without its host.
CantMoveFrozenInstance | A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.
CantPasteSelection | Can't paste selection.
CantPlaceInsertsError | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInsertsWarning | Can't place inserts outside of hosts. These elements won't be copied.
CantPlaceInstanceError | Can't place instance of [Symbol]
CantPlaceInstanceWarning | Can't place instance of [Symbol]
CantSetSlantedColumnEndPlane | Unable to determine slanted column end cut plane.
CantSolve | Can't find solution for formulas for Type '[Type Name]'.
ColumnAlreadyAttachedWillBeReattached | The column is already attached. It will be detached and attached to the new target.
ColumnAndTargetAlreadyJoined | The column and target are joined, remove that join before attaching them.
ColumnHeightZeroBecauseOfInvalidOffset | Change Offset Value so that Column height is not 0.0.
ColumnTooLong | This column is too long. Maximum length is 30,000 ft.
ContainsSharedSameNameFamily | Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!
CouldNotGenerateReferencesForFamilyInstance | Could not generate references for Family Instance.
CouldNotPlaceAdaptiveFamInst | Could not place Adaptive Family Instance.
CustomFittingCreated | Custom fitting was created.
DeletingBadFamType | Can't make type "[Family Name]". It will be deleted.
DeletingBadFamTypeDumped | Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"
DummyHostMustBePerpendicularToXY | Dummy host must be perpendicular to Z or Y axis.
DuplicateFamilyParameterNameWithSharedParameter | Parameter '[Parameter]' has the same name with an existing shared parameter.
DuplicateParamName | Family parameters have duplicate names.
DuplicateTypeName | "Ignoring attempt to add family type '%1!s!' for a second time."
ElementTypeParameterized | The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.
FailedToBecomeNonParametric | Family failed to become non-parametric!
FailedToSetParameters | Failed to apply family parameters.
FailedWhenLoadingFamily | Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.
FamilyBadUnattachedVoids | Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.
FamilyConnectorDeletedWarning | The family Connector has been modified so the connection is invalid.
FamilyDoesntMatchSystemPropertiesDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyMembersReferToOutsideFamily | Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.
FamilyNoExternalParametersCorruption | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersError | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNoExternalParametersWarning | Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.
FamilyNotFitHostShape | The host shape has changed and the family is no longer appropriate.
FamilyOverconstraint | Dimension overconstrains the Family. Cannot set Family Type to <None>.
FamilyOverconstraintCB | Dimension overconstrains the Family.
FamilyParameterNoExist | The parameter [Name] doesn't exist in the Family. It will be ignored.
FamilyValidationResult | Family Validation Warning(s): [Description]
FormulaBasedParameterCannotBeChanged | Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'
FormulasFailedForType | "Can't satisfy formulas for type [Family Symbol].
FrozenBecauseFaceGone | This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.
FrozenBecauseMonitorRelationshipGone | The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.
HighlightedElementFamRefsInvalidError | One or more references of the highlighted element have become invalid.
HighlightedElementFamRefsInvalidWarning | One or more references of the highlighted element have become invalid.
InstMayCutMoreOrFewerHosts | Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.
InstOutsideFaceBoundary | Instance origin does not lie on host face. Instance will lose association to host.
InvalidContextForAdaptivePlacement | The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.
InvalidParameterValue | Parameter [Caption] has an invalid value.
InvalidSlantedColumnOffsets | The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
NoInstparamFormulas | Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]
NonGenericAnnotationsOutsideLegend | Only Generic Annotations may be copied between Legends and other Views
NotFamilyFile | The selected file is not a Family File.
ProfileContainsNoLoops | Profile type '[Family Symbol]' contains no loops.
ReferencePlanesOverconstrained | Reference Planes are overconstrained.
SetbackTooLarge | Setback computations are too large for this element.
SharedParameterReplacedByBuiltInOne | Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!
SketchCannotBeAutomaticallyDimensioned | Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.
SlantedColumnEndCutPlaneIsParallelToGeometry | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnEndPlanesHaveFlipped | Position of end cut planes has resulted in a slanted column without any geometry.
StructuralColumnAttachedToNonStructuralTarget | The structural column is attached to a non-structural target.
TitleblockBadViewType | Titleblocks can only be placed on sheets.
TryingToAttachWhenJoined | The column and target are joined. The attachment has been removed.
TypeRecursiveElementIdParameter | Type's parameter cannot recursively point to the type itself.
UnableGenerateTrussByFamilyAndOrientation | Revit is unable to generate a truss using the current Layout Family and Truss orientation.
UnexpectedFamilyChangeResultsError | Changing the family for a MEP fitting might cause unexpected results.
UnexpectedFamilyChangeResultsWarning | Changing the family for a MEP fitting might cause unexpected results.
ValueOutOfRange | The value must be from 0.0 to 1.0
WhileLoadingFamily | While loading family '[Family Name]': [Description]
WhileLoadingFamilyShared | While loading shared family '[Family Name]' from family '[Family Name]': [Description]
WhileScanningParametersForType | While loading Type '[Name]', parameter '[Name]': [Description]

See Also

BuiltInFailures..::..FamilyFailures Class


CannotChangeCategory Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotChangeCategory Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't change category of Family Instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeCategory { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeCategory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotChangeInstFam Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotChangeInstFam Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't change Instance's Family. Try changing Instance's Host to a Level first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeInstFam { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeInstFam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeInstFam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotConvertInstHostToWorkPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotConvertInstHostToWorkPlane Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't convert Instance's Host to Work Plane. Try resetting Host to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertInstHostToWorkPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertInstHostToWorkPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstHostToWorkPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotConvertInstWorkPlaneToHost Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotConvertInstWorkPlaneToHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't convert Instance's Work Plane to Host. Try resetting Work Plane to a Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertInstWorkPlaneToHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertInstWorkPlaneToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertInstWorkPlaneToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCopyByPatternFamilies Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotCopyByPatternFamilies Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't copy between Mass or Curtain Panel by Pattern families, and other families or Revit projects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyByPatternFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyByPatternFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyByPatternFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCopyInplaceFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotCopyInplaceFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
In-place family groups cannot be copied between in-place families of the same project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyInplaceFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyInplaceFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyInplaceFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotCutRefPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotCutRefPlane Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't cut reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutRefPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutRefPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotFindHost Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotFindHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Couldn't find an appropriate Host. Try selecting a different Host Face or switch Placement Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindHost { get; }
Visual Basic
Public Shared ReadOnly Property CannotFindHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFindHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotLoadImperialFamilyToMetricProject Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotLoadImperialFamilyToMetricProject Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't load an imperial Family into a metric Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadImperialFamilyToMetricProject { get; }
Visual Basic
Public Shared ReadOnly Property CannotLoadImperialFamilyToMetricProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLoadImperialFamilyToMetricProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotLoadMetricFamilyToImperialProject Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotLoadMetricFamilyToImperialProject Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't load a metric Family into an imperial Project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLoadMetricFamilyToImperialProject { get; }
Visual Basic
Public Shared ReadOnly Property CannotLoadMetricFamilyToImperialProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLoadMetricFamilyToImperialProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotMakeType Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotMakeType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeType { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotMakeTypeCB Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotMakeTypeCB Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeTypeCB { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeTypeCB As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeTypeCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotMakeTypeFamilySaved Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotMakeTypeFamilySaved Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeTypeFamilySaved { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeTypeFamilySaved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeTypeFamilySaved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotPasteLabelsAcrossFamilies Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotPasteLabelsAcrossFamilies Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste Labels across Families of different Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteLabelsAcrossFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteLabelsAcrossFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteLabelsAcrossFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotPasteObject Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotPasteObject Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste some or all of the selected objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteObject { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteObject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteObject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotRotateElement Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotRotateElement Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't rotate element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotRotateElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRotateElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotSetFamilyTypeToNone Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotSetFamilyTypeToNone Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Cannot set Family Type to 'None';.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSetFamilyTypeToNone { get; }
Visual Basic
Public Shared ReadOnly Property CannotSetFamilyTypeToNone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSetFamilyTypeToNone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CannotUnlockFamilyTemplate Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CannotUnlockFamilyTemplate Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't unlock alignments from Family Template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUnlockFamilyTemplate { get; }
Visual Basic
Public Shared ReadOnly Property CannotUnlockFamilyTemplate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUnlockFamilyTemplate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantCopySelectionToNonStory Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantCopySelectionToNonStory Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't copy this selection to a non-story Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantCopySelectionToNonStory { get; }
Visual Basic
Public Shared ReadOnly Property CantCopySelectionToNonStory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantCopySelectionToNonStory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantEditWhileGrouped Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantEditWhileGrouped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
You may not edit this parameter while the element is grouped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantEditWhileGrouped { get; }
Visual Basic
Public Shared ReadOnly Property CantEditWhileGrouped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantEditWhileGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantMirrorInstWoHost Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantMirrorInstWoHost Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't mirror an instance without its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantMirrorInstWoHost { get; }
Visual Basic
Public Shared ReadOnly Property CantMirrorInstWoHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantMirrorInstWoHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantMoveFrozenInstance Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantMoveFrozenInstance Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
A family instance placed on a curved surface of a linked file can't be moved while the link is unloaded. To move the instance, reload the link or rehost the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantMoveFrozenInstance { get; }
Visual Basic
Public Shared ReadOnly Property CantMoveFrozenInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantMoveFrozenInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPasteSelection Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantPasteSelection Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't paste selection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantPasteSelection { get; }
Visual Basic
Public Shared ReadOnly Property CantPasteSelection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPasteSelection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInsertsError Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInsertsError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInsertsError { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInsertsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInsertsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInsertsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInsertsWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place inserts outside of hosts. These elements won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInsertsWarning { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInsertsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInsertsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInstanceError Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInstanceError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInstanceError { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInstanceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInstanceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantPlaceInstanceWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantPlaceInstanceWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't place instance of [Symbol]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantPlaceInstanceWarning { get; }
Visual Basic
Public Shared ReadOnly Property CantPlaceInstanceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantPlaceInstanceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantSetSlantedColumnEndPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantSetSlantedColumnEndPlane Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Unable to determine slanted column end cut plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantSetSlantedColumnEndPlane { get; }
Visual Basic
Public Shared ReadOnly Property CantSetSlantedColumnEndPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantSetSlantedColumnEndPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CantSolve Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CantSolve Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't find solution for formulas for Type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantSolve { get; }
Visual Basic
Public Shared ReadOnly Property CantSolve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantSolve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnAlreadyAttachedWillBeReattached Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ColumnAlreadyAttachedWillBeReattached Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column is already attached. It will be detached and attached to the new target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAlreadyAttachedWillBeReattached { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAlreadyAttachedWillBeReattached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAlreadyAttachedWillBeReattached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnAndTargetAlreadyJoined Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ColumnAndTargetAlreadyJoined Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column and target are joined, remove that join before attaching them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnAndTargetAlreadyJoined { get; }
Visual Basic
Public Shared ReadOnly Property ColumnAndTargetAlreadyJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnAndTargetAlreadyJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnHeightZeroBecauseOfInvalidOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ColumnHeightZeroBecauseOfInvalidOffset Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Change Offset Value so that Column height is not 0.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnHeightZeroBecauseOfInvalidOffset { get; }
Visual Basic
Public Shared ReadOnly Property ColumnHeightZeroBecauseOfInvalidOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnHeightZeroBecauseOfInvalidOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ColumnTooLong Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ColumnTooLong Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
This column is too long. Maximum length is 30,000 ft.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnTooLong { get; }
Visual Basic
Public Shared ReadOnly Property ColumnTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ContainsSharedSameNameFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ContainsSharedSameNameFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family '[Family Name]' contains a shared family of the same name. Please rename one of the two families before loading!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContainsSharedSameNameFamily { get; }
Visual Basic
Public Shared ReadOnly Property ContainsSharedSameNameFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContainsSharedSameNameFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CouldNotGenerateReferencesForFamilyInstance Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CouldNotGenerateReferencesForFamilyInstance Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Could not generate references for Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotGenerateReferencesForFamilyInstance { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotGenerateReferencesForFamilyInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotGenerateReferencesForFamilyInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CouldNotPlaceAdaptiveFamInst Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CouldNotPlaceAdaptiveFamInst Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Could not place Adaptive Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotPlaceAdaptiveFamInst { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotPlaceAdaptiveFamInst As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotPlaceAdaptiveFamInst {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


CustomFittingCreated Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..CustomFittingCreated Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Custom fitting was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CustomFittingCreated { get; }
Visual Basic
Public Shared ReadOnly Property CustomFittingCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CustomFittingCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DeletingBadFamType Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DeletingBadFamType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingBadFamType { get; }
Visual Basic
Public Shared ReadOnly Property DeletingBadFamType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DeletingBadFamTypeDumped Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DeletingBadFamTypeDumped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Can't make type "[Family Name]". It will be deleted. Failing family has been saved to "[File Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletingBadFamTypeDumped { get; }
Visual Basic
Public Shared ReadOnly Property DeletingBadFamTypeDumped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletingBadFamTypeDumped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DummyHostMustBePerpendicularToXY Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DummyHostMustBePerpendicularToXY Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Dummy host must be perpendicular to Z or Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DummyHostMustBePerpendicularToXY { get; }
Visual Basic
Public Shared ReadOnly Property DummyHostMustBePerpendicularToXY As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DummyHostMustBePerpendicularToXY {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DuplicateFamilyParameterNameWithSharedParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DuplicateFamilyParameterNameWithSharedParameter Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter '[Parameter]' has the same name with an existing shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateFamilyParameterNameWithSharedParameter { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateFamilyParameterNameWithSharedParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateFamilyParameterNameWithSharedParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DuplicateParamName Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DuplicateParamName Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family parameters have duplicate names.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateParamName { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateParamName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateParamName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


DuplicateTypeName Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..DuplicateTypeName Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
"Ignoring attempt to add family type '%1!s!' for a second time."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateTypeName { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateTypeName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateTypeName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ElementTypeParameterized Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ElementTypeParameterized Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The type(s) of the selected element(s) are driven by family parameter(s). Changing the type directly will break the association.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementTypeParameterized { get; }
Visual Basic
Public Shared ReadOnly Property ElementTypeParameterized As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementTypeParameterized {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FailedToBecomeNonParametric Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FailedToBecomeNonParametric Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family failed to become non-parametric!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToBecomeNonParametric { get; }
Visual Basic
Public Shared ReadOnly Property FailedToBecomeNonParametric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToBecomeNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FailedToSetParameters Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FailedToSetParameters Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Failed to apply family parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetParameters { get; }
Visual Basic
Public Shared ReadOnly Property FailedToSetParameters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToSetParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FailedWhenLoadingFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FailedWhenLoadingFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Some unlocked labeled dimensions prevent family from loading. Please try to lock unlocked labeled dimensions and load again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedWhenLoadingFamily { get; }
Visual Basic
Public Shared ReadOnly Property FailedWhenLoadingFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedWhenLoadingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyBadUnattachedVoids Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyBadUnattachedVoids Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family '[Family Name]' contains unattached voids that can't be combined for cutting. Try fixing the voids or unset the Cut with Voids parameter in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyBadUnattachedVoids { get; }
Visual Basic
Public Shared ReadOnly Property FamilyBadUnattachedVoids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyBadUnattachedVoids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyConnectorDeletedWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyConnectorDeletedWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The family Connector has been modified so the connection is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyConnectorDeletedWarning { get; }
Visual Basic
Public Shared ReadOnly Property FamilyConnectorDeletedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyConnectorDeletedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyDoesntMatchSystemPropertiesDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyDoesntMatchSystemPropertiesDisconnected Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyMembersReferToOutsideFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyMembersReferToOutsideFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Memebrs of Family '[Name]' or a nested family thereof illegally refer to Elements outside the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyMembersReferToOutsideFamily { get; }
Visual Basic
Public Shared ReadOnly Property FamilyMembersReferToOutsideFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyMembersReferToOutsideFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNoExternalParametersCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyNoExternalParametersCorruption Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersCorruption { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNoExternalParametersCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNoExternalParametersError Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyNoExternalParametersError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersError { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNoExternalParametersError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNoExternalParametersWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyNoExternalParametersWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family's Category can't be changed because the Family contains Shared Parameters which are not permitted in the new Category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNoExternalParametersWarning { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNoExternalParametersWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNoExternalParametersWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyNotFitHostShape Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyNotFitHostShape Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The host shape has changed and the family is no longer appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyNotFitHostShape { get; }
Visual Basic
Public Shared ReadOnly Property FamilyNotFitHostShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyNotFitHostShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyOverconstraint Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyOverconstraint Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family. Cannot set Family Type to <None>.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyOverconstraint { get; }
Visual Basic
Public Shared ReadOnly Property FamilyOverconstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyOverconstraintCB Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyOverconstraintCB Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Dimension overconstrains the Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyOverconstraintCB { get; }
Visual Basic
Public Shared ReadOnly Property FamilyOverconstraintCB As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyOverconstraintCB {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyParameterNoExist Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyParameterNoExist Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The parameter [Name] doesn't exist in the Family. It will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyParameterNoExist { get; }
Visual Basic
Public Shared ReadOnly Property FamilyParameterNoExist As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyParameterNoExist {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FamilyValidationResult Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FamilyValidationResult Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Family Validation Warning(s): [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyValidationResult { get; }
Visual Basic
Public Shared ReadOnly Property FamilyValidationResult As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyValidationResult {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FormulaBasedParameterCannotBeChanged Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FormulaBasedParameterCannotBeChanged Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter '[Caption]' cannot be changed because it is defined by formula '[Formula]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormulaBasedParameterCannotBeChanged { get; }
Visual Basic
Public Shared ReadOnly Property FormulaBasedParameterCannotBeChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormulaBasedParameterCannotBeChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FormulasFailedForType Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FormulasFailedForType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
"Can't satisfy formulas for type [Family Symbol].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormulasFailedForType { get; }
Visual Basic
Public Shared ReadOnly Property FormulasFailedForType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormulasFailedForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FrozenBecauseFaceGone Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FrozenBecauseFaceGone Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
This family instance was hosted by a curved face that is no longer present in the linked file. To move the family instance, rehost it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FrozenBecauseFaceGone { get; }
Visual Basic
Public Shared ReadOnly Property FrozenBecauseFaceGone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseFaceGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


FrozenBecauseMonitorRelationshipGone Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..FrozenBecauseMonitorRelationshipGone Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The position of this element was determined by copy/monitor but the monitor relationship has been removed. To move this instance, use pick new host to select a valid host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FrozenBecauseMonitorRelationshipGone { get; }
Visual Basic
Public Shared ReadOnly Property FrozenBecauseMonitorRelationshipGone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FrozenBecauseMonitorRelationshipGone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


HighlightedElementFamRefsInvalidError Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..HighlightedElementFamRefsInvalidError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidError { get; }
Visual Basic
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


HighlightedElementFamRefsInvalidWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..HighlightedElementFamRefsInvalidWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
One or more references of the highlighted element have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HighlightedElementFamRefsInvalidWarning { get; }
Visual Basic
Public Shared ReadOnly Property HighlightedElementFamRefsInvalidWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HighlightedElementFamRefsInvalidWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InstMayCutMoreOrFewerHosts Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..InstMayCutMoreOrFewerHosts Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Insert may be cutting fewer or more hosts than needed. The problem may be solved by forcing regeneration, e.g. by moving the insert out and back by a tiny distance in any direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InstMayCutMoreOrFewerHosts { get; }
Visual Basic
Public Shared ReadOnly Property InstMayCutMoreOrFewerHosts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstMayCutMoreOrFewerHosts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InstOutsideFaceBoundary Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..InstOutsideFaceBoundary Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Instance origin does not lie on host face. Instance will lose association to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InstOutsideFaceBoundary { get; }
Visual Basic
Public Shared ReadOnly Property InstOutsideFaceBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InstOutsideFaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidContextForAdaptivePlacement Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..InvalidContextForAdaptivePlacement Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The component '%1!s!' cannot be directly placed in the project environment. Place it in either an In-Place Mass, a Conceptual Mass Family, a Curtain Panel by Pattern Family, or an Adaptive Component.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidContextForAdaptivePlacement { get; }
Visual Basic
Public Shared ReadOnly Property InvalidContextForAdaptivePlacement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidContextForAdaptivePlacement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidParameterValue Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..InvalidParameterValue Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Parameter [Caption] has an invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidParameterValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidParameterValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidParameterValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


InvalidSlantedColumnOffsets Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..InvalidSlantedColumnOffsets Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column’s base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSlantedColumnOffsets { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSlantedColumnOffsets As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSlantedColumnOffsets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


NoInstparamFormulas Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..NoInstparamFormulas Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Instance Parameters can't be used in Type Parameter formulas.\n\n[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoInstparamFormulas { get; }
Visual Basic
Public Shared ReadOnly Property NoInstparamFormulas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoInstparamFormulas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


NonGenericAnnotationsOutsideLegend Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..NonGenericAnnotationsOutsideLegend Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Only Generic Annotations may be copied between Legends and other Views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonGenericAnnotationsOutsideLegend { get; }
Visual Basic
Public Shared ReadOnly Property NonGenericAnnotationsOutsideLegend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonGenericAnnotationsOutsideLegend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


NotFamilyFile Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..NotFamilyFile Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The selected file is not a Family File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotFamilyFile { get; }
Visual Basic
Public Shared ReadOnly Property NotFamilyFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotFamilyFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ProfileContainsNoLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ProfileContainsNoLoops Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Profile type '[Family Symbol]' contains no loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileContainsNoLoops { get; }
Visual Basic
Public Shared ReadOnly Property ProfileContainsNoLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileContainsNoLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ReferencePlanesOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ReferencePlanesOverconstrained Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Reference Planes are overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencePlanesOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property ReferencePlanesOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReferencePlanesOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SetbackTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..SetbackTooLarge Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Setback computations are too large for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SetbackTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property SetbackTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SetbackTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SharedParameterReplacedByBuiltInOne Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..SharedParameterReplacedByBuiltInOne Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Shared parameter [Name] will be replaced by a built-in parameter with the same name. This may affect scheduling!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SharedParameterReplacedByBuiltInOne { get; }
Visual Basic
Public Shared ReadOnly Property SharedParameterReplacedByBuiltInOne As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SharedParameterReplacedByBuiltInOne {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SketchCannotBeAutomaticallyDimensioned Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..SketchCannotBeAutomaticallyDimensioned Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Sketch can't be Automatically Dimensioned - this is a prerequisite for Labeled Dimensions to work properly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchCannotBeAutomaticallyDimensioned { get; }
Visual Basic
Public Shared ReadOnly Property SketchCannotBeAutomaticallyDimensioned As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchCannotBeAutomaticallyDimensioned {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SlantedColumnEndCutPlaneIsParallelToGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..SlantedColumnEndCutPlaneIsParallelToGeometry Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnEndCutPlaneIsParallelToGeometry { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnEndCutPlaneIsParallelToGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndCutPlaneIsParallelToGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


SlantedColumnEndPlanesHaveFlipped Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..SlantedColumnEndPlanesHaveFlipped Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Position of end cut planes has resulted in a slanted column without any geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnEndPlanesHaveFlipped { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnEndPlanesHaveFlipped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnEndPlanesHaveFlipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


StructuralColumnAttachedToNonStructuralTarget Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..StructuralColumnAttachedToNonStructuralTarget Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The structural column is attached to a non-structural target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructuralColumnAttachedToNonStructuralTarget { get; }
Visual Basic
Public Shared ReadOnly Property StructuralColumnAttachedToNonStructuralTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralColumnAttachedToNonStructuralTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


TitleblockBadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..TitleblockBadViewType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Titleblocks can only be placed on sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TitleblockBadViewType { get; }
Visual Basic
Public Shared ReadOnly Property TitleblockBadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TitleblockBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


TryingToAttachWhenJoined Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..TryingToAttachWhenJoined Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The column and target are joined. The attachment has been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TryingToAttachWhenJoined { get; }
Visual Basic
Public Shared ReadOnly Property TryingToAttachWhenJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TryingToAttachWhenJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


TypeRecursiveElementIdParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..TypeRecursiveElementIdParameter Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Type's parameter cannot recursively point to the type itself.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TypeRecursiveElementIdParameter { get; }
Visual Basic
Public Shared ReadOnly Property TypeRecursiveElementIdParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TypeRecursiveElementIdParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnableGenerateTrussByFamilyAndOrientation Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..UnableGenerateTrussByFamilyAndOrientation Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Revit is unable to generate a truss using the current Layout Family and Truss orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableGenerateTrussByFamilyAndOrientation { get; }
Visual Basic
Public Shared ReadOnly Property UnableGenerateTrussByFamilyAndOrientation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableGenerateTrussByFamilyAndOrientation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnexpectedFamilyChangeResultsError Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..UnexpectedFamilyChangeResultsError Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsError { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


UnexpectedFamilyChangeResultsWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..UnexpectedFamilyChangeResultsWarning Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
Changing the family for a MEP fitting might cause unexpected results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedFamilyChangeResultsWarning { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedFamilyChangeResultsWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedFamilyChangeResultsWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


ValueOutOfRange Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..ValueOutOfRange Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
The value must be from 0.0 to 1.0

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ValueOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileLoadingFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..WhileLoadingFamily Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WhileLoadingFamily { get; }
Visual Basic
Public Shared ReadOnly Property WhileLoadingFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileLoadingFamilyShared Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..WhileLoadingFamilyShared Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading shared family '[Family Name]' from family '[Family Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WhileLoadingFamilyShared { get; }
Visual Basic
Public Shared ReadOnly Property WhileLoadingFamilyShared As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileLoadingFamilyShared {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


WhileScanningParametersForType Property

[image]

Revit 2013 API
BuiltInFailures..::..FamilyFailures..::..WhileScanningParametersForType Property
BuiltInFailures..::..FamilyFailures Class See Also Send Feedback
While loading Type '[Name]', parameter '[Name]': [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WhileScanningParametersForType { get; }
Visual Basic
Public Shared ReadOnly Property WhileScanningParametersForType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WhileScanningParametersForType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FamilyFailures Class


BuiltInFailures.FilledRegionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about FilledRegion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FilledRegionFailures
Visual Basic
Public NotInheritable Class FilledRegionFailures
Visual C++
public ref class FilledRegionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FilledRegionFailures

See Also

BuiltInFailures..::..FilledRegionFailures Members


BuiltInFailures.FilledRegionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures Members
BuiltInFailures..::..FilledRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::..FilledRegionFailures Class


BuiltInFailures.FilledRegionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures Properties
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback

The BuiltInFailures..::..FilledRegionFailures type exposes the following members.

Properties

Name | Description
BadViewType | [Filled Region Name] can't be placed in 3D Views.
CannotDrawFilledRegion | Can't draw [Filled Region Name].
CannotDrawFilledRegionError | Can't draw [Filled Region Name].

See Also

BuiltInFailures..::..FilledRegionFailures Class


BadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures..::..BadViewType Property
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback
[Filled Region Name] can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FilledRegionFailures Class


CannotDrawFilledRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures..::..CannotDrawFilledRegion Property
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegion { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawFilledRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FilledRegionFailures Class


CannotDrawFilledRegionError Property

[image]

Revit 2013 API
BuiltInFailures..::..FilledRegionFailures..::..CannotDrawFilledRegionError Property
BuiltInFailures..::..FilledRegionFailures Class See Also Send Feedback
Can't draw [Filled Region Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawFilledRegionError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawFilledRegionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawFilledRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FilledRegionFailures Class


BuiltInFailures.FloorFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FloorFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FloorFailures
Visual Basic
Public NotInheritable Class FloorFailures
Visual C++
public ref class FloorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FloorFailures

See Also

BuiltInFailures..::..FloorFailures Members


BuiltInFailures.FloorFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FloorFailures Members
BuiltInFailures..::..FloorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..FloorFailures Class


BuiltInFailures.FloorFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FloorFailures Properties
BuiltInFailures..::..FloorFailures Class See Also Send Feedback

The BuiltInFailures..::..FloorFailures type exposes the following members.

Properties

Name | Description
FloorSlopeExceedsThreshold | Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

See Also

BuiltInFailures..::..FloorFailures Class


FloorSlopeExceedsThreshold Property

[image]

Revit 2013 API
BuiltInFailures..::..FloorFailures..::..FloorSlopeExceedsThreshold Property
BuiltInFailures..::..FloorFailures Class See Also Send Feedback
Thickness of this Floor may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorSlopeExceedsThreshold { get; }
Visual Basic
Public Shared ReadOnly Property FloorSlopeExceedsThreshold As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FloorFailures Class


BuiltInFailures.FluidFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FluidFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Fluid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FluidFailures
Visual Basic
Public NotInheritable Class FluidFailures
Visual C++
public ref class FluidFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FluidFailures

See Also

BuiltInFailures..::..FluidFailures Members


BuiltInFailures.FluidFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FluidFailures Members
BuiltInFailures..::..FluidFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FluidFailures type exposes the following members.

Properties

Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
UndefinedFluidUnit | Undefined fluid unit: '[Unit Type Name]'

See Also

BuiltInFailures..::..FluidFailures Class


BuiltInFailures.FluidFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FluidFailures Properties
BuiltInFailures..::..FluidFailures Class See Also Send Feedback

The BuiltInFailures..::..FluidFailures type exposes the following members.

Properties

Name | Description
UndefinedFluidType | The fluid type '[Type Name]' is not defined
UndefinedFluidUnit | Undefined fluid unit: '[Unit Type Name]'

See Also

BuiltInFailures..::..FluidFailures Class


UndefinedFluidType Property

[image]

Revit 2013 API
BuiltInFailures..::..FluidFailures..::..UndefinedFluidType Property
BuiltInFailures..::..FluidFailures Class See Also Send Feedback
The fluid type '[Type Name]' is not defined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidType { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedFluidType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FluidFailures Class


UndefinedFluidUnit Property

[image]

Revit 2013 API
BuiltInFailures..::..FluidFailures..::..UndefinedFluidUnit Property
BuiltInFailures..::..FluidFailures Class See Also Send Feedback
Undefined fluid unit: '[Unit Type Name]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UndefinedFluidUnit { get; }
Visual Basic
Public Shared ReadOnly Property UndefinedFluidUnit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UndefinedFluidUnit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FluidFailures Class


BuiltInFailures.FormFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class FormFailures
Visual Basic
Public NotInheritable Class FormFailures
Visual C++
public ref class FormFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..FormFailures

See Also

BuiltInFailures..::..FormFailures Members


BuiltInFailures.FormFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..FormFailures Members
BuiltInFailures..::..FormFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
NoSoludGeometryForVoidFormsInMass | This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::..FormFailures Class


BuiltInFailures.FormFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..FormFailures Properties
BuiltInFailures..::..FormFailures Class See Also Send Feedback

The BuiltInFailures..::..FormFailures type exposes the following members.

Properties

Name | Description
AddProfileFailure | Failed to Add Profile
DissolveNoValidInputs | No form elements selected to dissolve.
DissolveUnableToDissolveForm | Unable to dissolve form element.
FormCreationInvalidGeomCombination | Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.
FormElemRegenFailure | Unable to create form element
FormElemRegenFailureError | Unable to create form element
FormElemRegenSelfIntersection | Unable to create form element: self-intersecting or singular geometry would result.
FormElemRegenSelfIntersectionReorderProfiles | This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.
FormElemRegenSelfIntersectionResetConnections | This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.
NoSoludGeometryForVoidFormsInMass | This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.
OpenProfileMultiSegmentSweepsNotSupported | An open profile cannot be swept along a multi-segment path.
VoidFormsNotUsed | Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

See Also

BuiltInFailures..::..FormFailures Class


AddProfileFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..AddProfileFailure Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Failed to Add Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AddProfileFailure { get; }
Visual Basic
Public Shared ReadOnly Property AddProfileFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddProfileFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


DissolveNoValidInputs Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..DissolveNoValidInputs Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
No form elements selected to dissolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DissolveNoValidInputs { get; }
Visual Basic
Public Shared ReadOnly Property DissolveNoValidInputs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DissolveNoValidInputs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


DissolveUnableToDissolveForm Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..DissolveUnableToDissolveForm Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to dissolve form element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DissolveUnableToDissolveForm { get; }
Visual Basic
Public Shared ReadOnly Property DissolveUnableToDissolveForm As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DissolveUnableToDissolveForm {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormCreationInvalidGeomCombination Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormCreationInvalidGeomCombination Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Cannot remake form that is currently cut or joined to other geometry. Please uncut or unjoin first.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormCreationInvalidGeomCombination { get; }
Visual Basic
Public Shared ReadOnly Property FormCreationInvalidGeomCombination As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormCreationInvalidGeomCombination {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormElemRegenFailure Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenFailureError Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormElemRegenFailureError Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenFailureError { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenFailureError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenSelfIntersection Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormElemRegenSelfIntersection Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Unable to create form element: self-intersecting or singular geometry would result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersection { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenSelfIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenSelfIntersectionReorderProfiles Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormElemRegenSelfIntersectionReorderProfiles Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
This form cannot be created due to self-intersecting geometry. Clicking the Reorder Profiles button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersectionReorderProfiles { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenSelfIntersectionReorderProfiles As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionReorderProfiles {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


FormElemRegenSelfIntersectionResetConnections Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..FormElemRegenSelfIntersectionResetConnections Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
This form cannot be created due to self-intersecting geometry. Clicking the Reset Connections button will attempt to solve this problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormElemRegenSelfIntersectionResetConnections { get; }
Visual Basic
Public Shared ReadOnly Property FormElemRegenSelfIntersectionResetConnections As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormElemRegenSelfIntersectionResetConnections {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


NoSoludGeometryForVoidFormsInMass Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..NoSoludGeometryForVoidFormsInMass Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
This Mass has no solid geometry for its Void Forms to cut. They must be deleted, or solid geometry added and cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSoludGeometryForVoidFormsInMass { get; }
Visual Basic
Public Shared ReadOnly Property NoSoludGeometryForVoidFormsInMass As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSoludGeometryForVoidFormsInMass {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


OpenProfileMultiSegmentSweepsNotSupported Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..OpenProfileMultiSegmentSweepsNotSupported Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
An open profile cannot be swept along a multi-segment path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenProfileMultiSegmentSweepsNotSupported { get; }
Visual Basic
Public Shared ReadOnly Property OpenProfileMultiSegmentSweepsNotSupported As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenProfileMultiSegmentSweepsNotSupported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


VoidFormsNotUsed Property

[image]

Revit 2013 API
BuiltInFailures..::..FormFailures..::..VoidFormsNotUsed Property
BuiltInFailures..::..FormFailures Class See Also Send Feedback
Some Void Forms of this family do not cut anything and will be deleted. To make a Void Form cut something else use the Cut Geometry tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VoidFormsNotUsed { get; }
Visual Basic
Public Shared ReadOnly Property VoidFormsNotUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VoidFormsNotUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..FormFailures Class


BuiltInFailures.GeneralFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about GeneralFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GeneralFailures
Visual Basic
Public NotInheritable Class GeneralFailures
Visual C++
public ref class GeneralFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GeneralFailures

See Also

BuiltInFailures..::..GeneralFailures Members


BuiltInFailures.GeneralFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures Members
BuiltInFailures..::..GeneralFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GeneralFailures type exposes the following members.

Properties

Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
DuplicateValue | Elements have duplicate '[Value]' values.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].

See Also

BuiltInFailures..::..GeneralFailures Class


BuiltInFailures.GeneralFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures Properties
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback

The BuiltInFailures..::..GeneralFailures type exposes the following members.

Properties

Name | Description
CannotFixProblem | Failed to fix problem. Action has to be cancelled.
CannotSetParameter | Cant set parameter
CharactersNotAllowed | Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
ConvertingOldAxisToNormal | This operation will convert the existing axis of revolution to a normal line.
DuplicateValue | Elements have duplicate '[Value]' values.
EnterValidRealGreaterThan | Enter a number greater than [Value].
EnterValueBetween | Please enter a value between [Value] and [Value].
ErrorResolved | Error "[Text]" was automatically resolved by "[Resolution]"
FailedToOpenFile | Failed to open file.
FailedToReadLine | Failed to read line.
GenericCorruption | A generic error has occurred.
GenericError | Error.
GenericErrorNone | None.
GenericFatalError | A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
GenericNonFatalError | A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
GenericWarning | A generic error has occurred.
InaccuracyDetected | A geometric inaccuracy was found in the element.
InternalProblemsParameter | Parameter cannot be changed due to internal problems.
InvalidInput | Invalid Input
InvalidInputWarn | Invalid Input
InvalidValue | Invalid value.
NameInUse | The name "[Name]" is already in use.
NameIsEmpty | Name is empty
NameNotUnique | The name entered is already in use. Enter a unique name.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoRelatedWarnings | Document doesn't contain any warnings related to these elements.
ParameterValueNotInRange | The value for [Parameter Name] must be between [Value] and [Value].
SeriousElementReferenceCorruption | Element references are seriously corrupt.
TransactionFailed | [Description]
TransactionFailedWarn | [Description]
UnspecifiedError | Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
ValueOutOfRange | Value is out of range ! Please enter a number between [Value] and [Value].

See Also

BuiltInFailures..::..GeneralFailures Class


CannotFixProblem Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..CannotFixProblem Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Failed to fix problem. Action has to be cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFixProblem { get; }
Visual Basic
Public Shared ReadOnly Property CannotFixProblem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFixProblem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


CannotSetParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..CannotSetParameter Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Cant set parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSetParameter { get; }
Visual Basic
Public Shared ReadOnly Property CannotSetParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSetParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


CharactersNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..CharactersNotAllowed Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CharactersNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property CharactersNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CharactersNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ConvertingOldAxisToNormal Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..ConvertingOldAxisToNormal Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
This operation will convert the existing axis of revolution to a normal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertingOldAxisToNormal { get; }
Visual Basic
Public Shared ReadOnly Property ConvertingOldAxisToNormal As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertingOldAxisToNormal {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


DuplicateValue Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..DuplicateValue Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Elements have duplicate '[Value]' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateValue { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


EnterValidRealGreaterThan Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..EnterValidRealGreaterThan Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Enter a number greater than [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValidRealGreaterThan { get; }
Visual Basic
Public Shared ReadOnly Property EnterValidRealGreaterThan As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValidRealGreaterThan {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


EnterValueBetween Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..EnterValueBetween Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Please enter a value between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueBetween { get; }
Visual Basic
Public Shared ReadOnly Property EnterValueBetween As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValueBetween {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ErrorResolved Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..ErrorResolved Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Error "[Text]" was automatically resolved by "[Resolution]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ErrorResolved { get; }
Visual Basic
Public Shared ReadOnly Property ErrorResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ErrorResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


FailedToOpenFile Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..FailedToOpenFile Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Failed to open file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToOpenFile { get; }
Visual Basic
Public Shared ReadOnly Property FailedToOpenFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToOpenFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


FailedToReadLine Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..FailedToReadLine Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Failed to read line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToReadLine { get; }
Visual Basic
Public Shared ReadOnly Property FailedToReadLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToReadLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericCorruption Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericCorruption { get; }
Visual Basic
Public Shared ReadOnly Property GenericCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericError Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericError { get; }
Visual Basic
Public Shared ReadOnly Property GenericError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericErrorNone Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericErrorNone Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericErrorNone { get; }
Visual Basic
Public Shared ReadOnly Property GenericErrorNone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericErrorNone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericFatalError Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericFatalError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericFatalError { get; }
Visual Basic
Public Shared ReadOnly Property GenericFatalError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericNonFatalError Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericNonFatalError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericNonFatalError { get; }
Visual Basic
Public Shared ReadOnly Property GenericNonFatalError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericNonFatalError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


GenericWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..GenericWarning Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A generic error has occurred.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GenericWarning { get; }
Visual Basic
Public Shared ReadOnly Property GenericWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GenericWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InaccuracyDetected Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..InaccuracyDetected Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
A geometric inaccuracy was found in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccuracyDetected { get; }
Visual Basic
Public Shared ReadOnly Property InaccuracyDetected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccuracyDetected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InternalProblemsParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..InternalProblemsParameter Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Parameter cannot be changed due to internal problems.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InternalProblemsParameter { get; }
Visual Basic
Public Shared ReadOnly Property InternalProblemsParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InternalProblemsParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidInput Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..InvalidInput Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidInput { get; }
Visual Basic
Public Shared ReadOnly Property InvalidInput As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidInput {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidInputWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..InvalidInputWarn Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid Input

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidInputWarn { get; }
Visual Basic
Public Shared ReadOnly Property InvalidInputWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidInputWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


InvalidValue Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..InvalidValue Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidValue { get; }
Visual Basic
Public Shared ReadOnly Property InvalidValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NameInUse Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..NameInUse Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The name "[Name]" is already in use.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NameInUse { get; }
Visual Basic
Public Shared ReadOnly Property NameInUse As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NameInUse {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NameIsEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..NameIsEmpty Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Name is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NameIsEmpty { get; }
Visual Basic
Public Shared ReadOnly Property NameIsEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NameIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NameNotUnique Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..NameNotUnique Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The name entered is already in use. Enter a unique name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NameNotUnique { get; }
Visual Basic
Public Shared ReadOnly Property NameNotUnique As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NameNotUnique {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NewElementInvisibleInCurrentView Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..NewElementInvisibleInCurrentView Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The newly created object is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NewElementInvisibleInCurrentView { get; }
Visual Basic
Public Shared ReadOnly Property NewElementInvisibleInCurrentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NewElementInvisibleInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


NoRelatedWarnings Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..NoRelatedWarnings Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Document doesn't contain any warnings related to these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRelatedWarnings { get; }
Visual Basic
Public Shared ReadOnly Property NoRelatedWarnings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRelatedWarnings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ParameterValueNotInRange Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..ParameterValueNotInRange Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
The value for [Parameter Name] must be between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ParameterValueNotInRange { get; }
Visual Basic
Public Shared ReadOnly Property ParameterValueNotInRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ParameterValueNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


SeriousElementReferenceCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..SeriousElementReferenceCorruption Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Visual Basic
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


TransactionFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..TransactionFailed Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TransactionFailed { get; }
Visual Basic
Public Shared ReadOnly Property TransactionFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TransactionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


TransactionFailedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..TransactionFailedWarn Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TransactionFailedWarn { get; }
Visual Basic
Public Shared ReadOnly Property TransactionFailedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TransactionFailedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


UnspecifiedError Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..UnspecifiedError Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnspecifiedError { get; }
Visual Basic
Public Shared ReadOnly Property UnspecifiedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnspecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


ValueOutOfRange Property

[image]

Revit 2013 API
BuiltInFailures..::..GeneralFailures..::..ValueOutOfRange Property
BuiltInFailures..::..GeneralFailures Class See Also Send Feedback
Value is out of range ! Please enter a number between [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ValueOutOfRange { get; }
Visual Basic
Public Shared ReadOnly Property ValueOutOfRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ValueOutOfRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeneralFailures Class


BuiltInFailures.GenericFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GenericFailures Class
BuiltInFailures Class Members See Also Send Feedback
Generic failures that may apply to any Revit Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GenericFailures
Visual Basic
Public NotInheritable Class GenericFailures
Visual C++
public ref class GenericFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GenericFailures

See Also

BuiltInFailures..::..GenericFailures Members


BuiltInFailures.GenericFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GenericFailures Members
BuiltInFailures..::..GenericFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GenericFailures type exposes the following members.

Properties

Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

See Also

BuiltInFailures..::..GenericFailures Class


BuiltInFailures.GenericFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GenericFailures Properties
BuiltInFailures..::..GenericFailures Class See Also Send Feedback

The BuiltInFailures..::..GenericFailures type exposes the following members.

Properties

Name | Description
ElementsInInvalidContext | There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

See Also

BuiltInFailures..::..GenericFailures Class


ElementsInInvalidContext Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericFailures..::..ElementsInInvalidContext Property
BuiltInFailures..::..GenericFailures Class See Also Send Feedback
There are elements in the document that exist in a context they should not. These elements must be deleted to continue using this project or family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsInInvalidContext { get; }
Visual Basic
Public Shared ReadOnly Property ElementsInInvalidContext As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsInInvalidContext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericFailures Class


BuiltInFailures.GenericMEPFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures applicable to different mechanical, electrical and piping Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GenericMEPFailures
Visual Basic
Public NotInheritable Class GenericMEPFailures
Visual C++
public ref class GenericMEPFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GenericMEPFailures

See Also

BuiltInFailures..::..GenericMEPFailures Members


BuiltInFailures.GenericMEPFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures Members
BuiltInFailures..::..GenericMEPFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class


BuiltInFailures.GenericMEPFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures Properties
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback

The BuiltInFailures..::..GenericMEPFailures type exposes the following members.

Properties

Name | Description
FlowConfigMismatch | [Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.
FlowDirectionMismatch | [Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.
MaxWidthAndHeightReached | Maximum width and height reached during sizing
SegmentIsTooShort | The segment is too short.
SizingFailedZeroFlow | Sizing failed. Flow for section is 0.
ValidatePHSegmentConnWarning | The placeholder curve will not be able to connect to the required fittings for placeholder convert
ValidatePHSegmentLengthWarning | The placeholder curve is not long enough to support the required fittings for placeholder convert

See Also

BuiltInFailures..::..GenericMEPFailures Class


FlowConfigMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..FlowConfigMismatch Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since all the components in this system have the flow configuration set to Preset or System. At least one component is required to have the flow configuration set to Calculated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FlowConfigMismatch { get; }
Visual Basic
Public Shared ReadOnly Property FlowConfigMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlowConfigMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


FlowDirectionMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..FlowDirectionMismatch Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
[Element Name]: It is not possible to calculate the flow since the flow direction mismatch. Please check flow direction on all equipment in this system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FlowDirectionMismatch { get; }
Visual Basic
Public Shared ReadOnly Property FlowDirectionMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FlowDirectionMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


MaxWidthAndHeightReached Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..MaxWidthAndHeightReached Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
Maximum width and height reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MaxWidthAndHeightReached { get; }
Visual Basic
Public Shared ReadOnly Property MaxWidthAndHeightReached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxWidthAndHeightReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


SegmentIsTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..SegmentIsTooShort Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
The segment is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentIsTooShort { get; }
Visual Basic
Public Shared ReadOnly Property SegmentIsTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentIsTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


SizingFailedZeroFlow Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..SizingFailedZeroFlow Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
Sizing failed. Flow for section is 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SizingFailedZeroFlow { get; }
Visual Basic
Public Shared ReadOnly Property SizingFailedZeroFlow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SizingFailedZeroFlow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


ValidatePHSegmentConnWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..ValidatePHSegmentConnWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
The placeholder curve will not be able to connect to the required fittings for placeholder convert

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ValidatePHSegmentConnWarning { get; }
Visual Basic
Public Shared ReadOnly Property ValidatePHSegmentConnWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ValidatePHSegmentConnWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


ValidatePHSegmentLengthWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..GenericMEPFailures..::..ValidatePHSegmentLengthWarning Property
BuiltInFailures..::..GenericMEPFailures Class See Also Send Feedback
The placeholder curve is not long enough to support the required fittings for placeholder convert

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ValidatePHSegmentLengthWarning { get; }
Visual Basic
Public Shared ReadOnly Property ValidatePHSegmentLengthWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ValidatePHSegmentLengthWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GenericMEPFailures Class


BuiltInFailures.GeometryFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about GeometryFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GeometryFailures
Visual Basic
Public NotInheritable Class GeometryFailures
Visual C++
public ref class GeometryFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GeometryFailures

See Also

BuiltInFailures..::..GeometryFailures Members


BuiltInFailures.GeometryFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures Members
BuiltInFailures..::..GeometryFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CreateCoreGeometryFailed | Failed to create core geometries.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::..GeometryFailures Class


BuiltInFailures.GeometryFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures Properties
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback

The BuiltInFailures..::..GeometryFailures type exposes the following members.

Properties

Name | Description
CannotFindClosest | Cannot find closest points within lines.
ConvertFaceRegionsToFacesCrashed | Failed to replace an instance face with its face regions.
ConvertFaceRegionsToFacesFailed | Failed to replace an instance face with its face regions.
CreateCoreGeometryFailed | Failed to create core geometries.
CurveAndSurfaceDoNotIntersect | Curve and Surface do not intersect.
CurveDriverError | Element's internal join data is corrupt.
CurveProjectTooShort | The projection of the line in this view is too short to create a new Line
ElementIsTooThin | [Element] is too thin.
ElementTooSmall | Element is too small on screen
FailedReplaceCurveElemCurveDriver | Failed to replace curve elem curve driver.
FailedUpdateCurveChain | Failed to update curve chain.
FailToConvertLine | Unable to convert lines
LineArcTangentFailure | Can't keep arc element and straight line element tangent.
OffsetFaceFailed | Failed to offset the face.
PolygonSegmentTooShort | Polygon segment too short
SuccessToConvertLine | Success to convert lines
SymbolicLineInvalidPlane | Symbolic Element refers to a Work Plane with unacceptable normal.
TooManyFacesEdges | This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

See Also

BuiltInFailures..::..GeometryFailures Class


CannotFindClosest Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..CannotFindClosest Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Cannot find closest points within lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFindClosest { get; }
Visual Basic
Public Shared ReadOnly Property CannotFindClosest As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFindClosest {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ConvertFaceRegionsToFacesCrashed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..ConvertFaceRegionsToFacesCrashed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesCrashed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertFaceRegionsToFacesCrashed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ConvertFaceRegionsToFacesFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..ConvertFaceRegionsToFacesFailed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace an instance face with its face regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertFaceRegionsToFacesFailed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertFaceRegionsToFacesFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertFaceRegionsToFacesFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CreateCoreGeometryFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..CreateCoreGeometryFailed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Visual Basic
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveAndSurfaceDoNotIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..CurveAndSurfaceDoNotIntersect Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Curve and Surface do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveAndSurfaceDoNotIntersect { get; }
Visual Basic
Public Shared ReadOnly Property CurveAndSurfaceDoNotIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveAndSurfaceDoNotIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveDriverError Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..CurveDriverError Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Element's internal join data is corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveDriverError { get; }
Visual Basic
Public Shared ReadOnly Property CurveDriverError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveDriverError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


CurveProjectTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..CurveProjectTooShort Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
The projection of the line in this view is too short to create a new Line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveProjectTooShort { get; }
Visual Basic
Public Shared ReadOnly Property CurveProjectTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveProjectTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ElementIsTooThin Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..ElementIsTooThin Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
[Element] is too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementIsTooThin { get; }
Visual Basic
Public Shared ReadOnly Property ElementIsTooThin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementIsTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


ElementTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..ElementTooSmall Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Element is too small on screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property ElementTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


FailedReplaceCurveElemCurveDriver Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..FailedReplaceCurveElemCurveDriver Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to replace curve elem curve driver.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedReplaceCurveElemCurveDriver { get; }
Visual Basic
Public Shared ReadOnly Property FailedReplaceCurveElemCurveDriver As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedReplaceCurveElemCurveDriver {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


FailedUpdateCurveChain Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..FailedUpdateCurveChain Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to update curve chain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedUpdateCurveChain { get; }
Visual Basic
Public Shared ReadOnly Property FailedUpdateCurveChain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedUpdateCurveChain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


FailToConvertLine Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..FailToConvertLine Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Unable to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailToConvertLine { get; }
Visual Basic
Public Shared ReadOnly Property FailToConvertLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailToConvertLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


LineArcTangentFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..LineArcTangentFailure Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Can't keep arc element and straight line element tangent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LineArcTangentFailure { get; }
Visual Basic
Public Shared ReadOnly Property LineArcTangentFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineArcTangentFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


OffsetFaceFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..OffsetFaceFailed Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Failed to offset the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OffsetFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


PolygonSegmentTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..PolygonSegmentTooShort Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Polygon segment too short

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PolygonSegmentTooShort { get; }
Visual Basic
Public Shared ReadOnly Property PolygonSegmentTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PolygonSegmentTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


SuccessToConvertLine Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..SuccessToConvertLine Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Success to convert lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SuccessToConvertLine { get; }
Visual Basic
Public Shared ReadOnly Property SuccessToConvertLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuccessToConvertLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


SymbolicLineInvalidPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..SymbolicLineInvalidPlane Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
Symbolic Element refers to a Work Plane with unacceptable normal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SymbolicLineInvalidPlane { get; }
Visual Basic
Public Shared ReadOnly Property SymbolicLineInvalidPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SymbolicLineInvalidPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


TooManyFacesEdges Property

[image]

Revit 2013 API
BuiltInFailures..::..GeometryFailures..::..TooManyFacesEdges Property
BuiltInFailures..::..GeometryFailures Class See Also Send Feedback
This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyFacesEdges { get; }
Visual Basic
Public Shared ReadOnly Property TooManyFacesEdges As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyFacesEdges {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GeometryFailures Class


BuiltInFailures.GridChainSketchFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to the GridChain sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GridChainSketchFailures
Visual Basic
Public NotInheritable Class GridChainSketchFailures
Visual C++
public ref class GridChainSketchFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GridChainSketchFailures

See Also

BuiltInFailures..::..GridChainSketchFailures Members


BuiltInFailures.GridChainSketchFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures Members
BuiltInFailures..::..GridChainSketchFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GridChainSketchFailures type exposes the following members.

Properties

Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.

See Also

BuiltInFailures..::..GridChainSketchFailures Class


BuiltInFailures.GridChainSketchFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures Properties
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback

The BuiltInFailures..::..GridChainSketchFailures type exposes the following members.

Properties

Name | Description
ClosedLoop | GridChain sketch contains a closed loop.
InvalidSketch | Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.
MoreThanOneLoop | GridChain sketch contains more than one loop.
OverlappingLines | GridChain sketch contains lines which overlap.

See Also

BuiltInFailures..::..GridChainSketchFailures Class


ClosedLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures..::..ClosedLoop Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
GridChain sketch contains a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property ClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


InvalidSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures..::..InvalidSketch Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
Sketch is invalid. Grid sketch must consist of a single open loop with no intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


MoreThanOneLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures..::..MoreThanOneLoop Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
GridChain sketch contains more than one loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MoreThanOneLoop { get; }
Visual Basic
Public Shared ReadOnly Property MoreThanOneLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


OverlappingLines Property

[image]

Revit 2013 API
BuiltInFailures..::..GridChainSketchFailures..::..OverlappingLines Property
BuiltInFailures..::..GridChainSketchFailures Class See Also Send Feedback
GridChain sketch contains lines which overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OverlappingLines { get; }
Visual Basic
Public Shared ReadOnly Property OverlappingLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverlappingLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridChainSketchFailures Class


BuiltInFailures.GridFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GridFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GridFailures
Visual Basic
Public NotInheritable Class GridFailures
Visual C++
public ref class GridFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GridFailures

See Also

BuiltInFailures..::..GridFailures Members


BuiltInFailures.GridFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GridFailures Members
BuiltInFailures..::..GridFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::..GridFailures Class


BuiltInFailures.GridFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GridFailures Properties
BuiltInFailures..::..GridFailures Class See Also Send Feedback

The BuiltInFailures..::..GridFailures type exposes the following members.

Properties

Name | Description
GridEndSegmentsLengthTooShort | The end segment length for a grid must be at least [Length Value]
GridInGridChainCannotMirror | A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.
GridlineAxisTooClose | Axis of gridlines should not change order or be closer than [Value] to each other.
GridlineAxisTooFar | Axis of gridlines should not be further than [Value] to each other.

See Also

BuiltInFailures..::..GridFailures Class


GridEndSegmentsLengthTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..GridFailures..::..GridEndSegmentsLengthTooShort Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
The end segment length for a grid must be at least [Length Value]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridEndSegmentsLengthTooShort { get; }
Visual Basic
Public Shared ReadOnly Property GridEndSegmentsLengthTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridEndSegmentsLengthTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


GridInGridChainCannotMirror Property

[image]

Revit 2013 API
BuiltInFailures..::..GridFailures..::..GridInGridChainCannotMirror Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
A grid that is a sub-grid of a multi-segment grid can only be mirrored if the entire multi-segment grid is being mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridInGridChainCannotMirror { get; }
Visual Basic
Public Shared ReadOnly Property GridInGridChainCannotMirror As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridInGridChainCannotMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


GridlineAxisTooClose Property

[image]

Revit 2013 API
BuiltInFailures..::..GridFailures..::..GridlineAxisTooClose Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
Axis of gridlines should not change order or be closer than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlineAxisTooClose { get; }
Visual Basic
Public Shared ReadOnly Property GridlineAxisTooClose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


GridlineAxisTooFar Property

[image]

Revit 2013 API
BuiltInFailures..::..GridFailures..::..GridlineAxisTooFar Property
BuiltInFailures..::..GridFailures Class See Also Send Feedback
Axis of gridlines should not be further than [Value] to each other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GridlineAxisTooFar { get; }
Visual Basic
Public Shared ReadOnly Property GridlineAxisTooFar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GridlineAxisTooFar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GridFailures Class


BuiltInFailures.GroupFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures related to groups and their behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class GroupFailures
Visual Basic
Public NotInheritable Class GroupFailures
Visual C++
public ref class GroupFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..GroupFailures

See Also

BuiltInFailures..::..GroupFailures Members


BuiltInFailures.GroupFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..GroupFailures Members
BuiltInFailures..::..GroupFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetMasterGroupId | Unable to set master id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::..GroupFailures Class


BuiltInFailures.GroupFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..GroupFailures Properties
BuiltInFailures..::..GroupFailures Class See Also Send Feedback

The BuiltInFailures..::..GroupFailures type exposes the following members.

Properties

Name | Description
AdditionalElementsRequired | Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
AdditionalElementsRequiredRemove | To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
AllElementsRemovedFromGroup | Group "[Type Name]" is now empty and will be deleted.
AtomTouchedNotAllowed | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomTouchedNotAllowedDelete | Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
AtomViolationWhenMultiPlacedInstances | Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
AtomViolationWhenOnePlaceInstance | A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
AttachedGroupNoMirror | Attached detail groups cannot be mirrored without also mirroring their parent group.
AttachedGroupNoPasteToView | An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
BadProblemWithGroup | The operation performed affects groups in an unacceptable manner.
BadViewForAttachedGroup | Attached groups can only be created for view specific elements belonging to non-3d model views.
BadViewForAttachedGroupWarn | Attached groups can only be created for view specific elements belonging to non-3d model views.
CannotAddAlreadyMemberToDiffGroup | Elements that are already members of one group cannot be added to another group.
CannotAddToGroupFormat | [Element] cannot be added to the instance of [Group]
CannotAddToGroupFormatWarn | [Element] cannot be added to the instance of [Group]
CannotCopyGroup | Unable to copy the selected group.
CannotCreateGroup | Cannot create group of these elements.
CannotCreateGroupWithInvalidReferences | The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
CannotFinishGroupInSketchMode | Can't Finish Group while in Sketch Mode.
CannotLinkAnnotationsForSomeViews | Annotations for some views cannot be displayed from linked file.
CannotPlaceGroup | Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
CannotReloadWithFile | Group [Type Name] cannot be reloaded from file [File Name].
CannotRemoveGroupMemberConstraint | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveGroupMemberConstraintWarn | Constraints between group members cannot be removed or excluded from the group.
CannotRemoveSubordFromGroup | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotRemoveSubordFromGroupWarn | Element can't be removed or excluded from the Group because it is required by another Group element.
CannotSaveGroup | Can't save Group.
CannotSwapNestedGroups | Can't replace because one Group is contained in the other.
ChildrenDeletedOnGroupSwap | Some dependent elements were deleted by changing group type and cannot be retained.
ChildrenLostOnGroupSwap | Some elements could not find new hosts after changing group type and will be deleted.
DetailsOfNestedGroupsLost | Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
DimensionsOrTagsReferecedRemoved | Dimensions or Tags that reference non-group members have been removed from group [Name].
DimRefsGroupMemberSketch | A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
DontEditNestedGroup | Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
ElementChangedMoreThanAllowed | The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
ExcludedElementsRestoredInLink | Excluded elements restored in the link.
FailedToChangeGroupLevelRef | Unable to change group level ref.
FailedToSetMasterGroupId | Unable to set master id of group type.
FailedToTransformAttachedGroup | Attached group could not be properly relocated.
GroupAmongstLoadedRenamed | A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
GroupCannotMixBackAndForegroundDetail | This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
GroupCannotSave | The group cannot be saved at this time because one of its instances is being edited.
GroupCannotSaveWarn | The group cannot be saved at this time because one of its instances is being edited.
GroupChangeNoPlaceElements | Elements cannot be placed as a result of changes to groups.
GroupEditModeNoDuplicates | Can't create duplicates in Edit Group mode.
GroupedModelElemHasViewSpecificSubordinates | Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
GroupHadFailedElementsWhileUpdating | Group members failed while updating group.
GroupPropagationFailedSketch | Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
GroupPropagationFailedUngroup | Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
GroupPropagationUserCancelled | Changes to Group "[Type Name]" have been cancelled.
GroupsHasCycle | Can't create Group because it contains multiple copies of same Group.
GroupsHaveDifferentMembers | Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
GroupsNotCompatibleForTypeChange | Some of the selected groups are not compatible with the new group type that was chosen.
GroupViewSpecificDiffViews | You may not create a detail group with view specific elements from different views.
InvalidGroup | This group is invalid.
LastCopyOfGroupDeleted | Last copy of Group "[Name]" deleted. Group type removed from project.
LastGroupMemberExcluded | Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
LinkVisibilityLost | Link visibility overrides will be lost.
LoadOfGroupAbortedByUser | You have aborted loading file '[File Name]' as a group.
MembersExcluded | Group members have been excluded from this group instance.
MembersExcludedWarn | Group members have been excluded from this group instance.
MembersMovedToProjectToMakeConsistent | Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
ModifyingMultiGroups | Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
MoveElemFailed | Unable to move element.
NoAppropriateGroup | There is no Group that can be placed in the current view.
NoDetailGroups | There are no Detail Groups in this Project or Family.
NoModelGroups | There are no Model Groups in this Project or Family.
NoneOfSelElemsGroupable | None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
NoSwapGroupBeingEdited | You may not change the type of the group that is currently being edited.
NotAGroupFile | This is not a Group File.
NotAllGroupsFullyRestored | Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
PlaceGroupFailed | Unable to place group instances.
ProblemRegeneratingInGroupUpdate | Unable to regenerate while updating groups at end of transaction.
ReferencesOutsideGroupAreNotAllowed | The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
RemoveGroupSketchConstraintParent | You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
RemovingElemCannotBeGrouped | Elements that cannot be grouped were removed from groups of type '[Type Name]'.
RemovingReferencesFromGroupedCurve | References to elements outside the group were removed from a grouped curve element.
RevitUnableToUpadateGroups | Unable to update groups for changes.
SomeGroupInstsBecameEmpty | Group instances have had all their group members deleted and will also be deleted.
SomeMembersNotRestored | Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
UnableToBindLink | Unable to bind the selected links.
UnableToBindLinkInstances | Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
UnableToConvertGroupsToLinks | Unable to convert the selected groups to links.
UnableToCreateAttachedGroup | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToDetachGroup | Unable to detach the selected attached detail group(s).
UnableToExcludeElems | Unable to exclude the selected group members.
UnableToGroupElems | Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
UnableToLoadAttachedGroup | Unable to load attached detail group '[Type Name]'.
UnableToLoadDetailGroup | Unable to load detail group '[Type Name]'.
UnableToLoadGroup | Unable to load file '[File Name]' as a group.
UnableToMaintainExclusions | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMaintainExclusionsWarn | Unable to maintain exclusion of some group members. Some excluded members have been restored.
UnableToMoveElemsToProject | Revit is unable to move the selected group members to the project.
UnableToRemapDetails | Unable to create attached detail group in view '[View Name]' for the selected elements.
UnableToReplaceSelectedGroups | Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
UnableToRestoreAllMembersOfGroups | Revit is unable to restore the members of the selected groups.
UnableToSaveGroupType | Unable to save group type.
UnableToTransferAttachedGroup | Unable to load attached group [Type Name] of model group [Type Name].

See Also

BuiltInFailures..::..GroupFailures Class


AdditionalElementsRequired Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AdditionalElementsRequired Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequired { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalElementsRequired As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequired {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AdditionalElementsRequiredRemove Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AdditionalElementsRequiredRemove Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AdditionalElementsRequiredRemove { get; }
Visual Basic
Public Shared ReadOnly Property AdditionalElementsRequiredRemove As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AdditionalElementsRequiredRemove {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AllElementsRemovedFromGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AllElementsRemovedFromGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group "[Type Name]" is now empty and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AllElementsRemovedFromGroup { get; }
Visual Basic
Public Shared ReadOnly Property AllElementsRemovedFromGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AllElementsRemovedFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomTouchedNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AtomTouchedNotAllowed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property AtomTouchedNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomTouchedNotAllowedDelete Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AtomTouchedNotAllowedDelete Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AtomTouchedNotAllowedDelete { get; }
Visual Basic
Public Shared ReadOnly Property AtomTouchedNotAllowedDelete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomTouchedNotAllowedDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomViolationWhenMultiPlacedInstances Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AtomViolationWhenMultiPlacedInstances Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AtomViolationWhenMultiPlacedInstances { get; }
Visual Basic
Public Shared ReadOnly Property AtomViolationWhenMultiPlacedInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomViolationWhenMultiPlacedInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AtomViolationWhenOnePlaceInstance Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AtomViolationWhenOnePlaceInstance Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AtomViolationWhenOnePlaceInstance { get; }
Visual Basic
Public Shared ReadOnly Property AtomViolationWhenOnePlaceInstance As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AtomViolationWhenOnePlaceInstance {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AttachedGroupNoMirror Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AttachedGroupNoMirror Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached detail groups cannot be mirrored without also mirroring their parent group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AttachedGroupNoMirror { get; }
Visual Basic
Public Shared ReadOnly Property AttachedGroupNoMirror As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttachedGroupNoMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


AttachedGroupNoPasteToView Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..AttachedGroupNoPasteToView Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AttachedGroupNoPasteToView { get; }
Visual Basic
Public Shared ReadOnly Property AttachedGroupNoPasteToView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AttachedGroupNoPasteToView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadProblemWithGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..BadProblemWithGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The operation performed affects groups in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadProblemWithGroup { get; }
Visual Basic
Public Shared ReadOnly Property BadProblemWithGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadProblemWithGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadViewForAttachedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..BadViewForAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property BadViewForAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BadViewForAttachedGroupWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..BadViewForAttachedGroupWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached groups can only be created for view specific elements belonging to non-3d model views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewForAttachedGroupWarn { get; }
Visual Basic
Public Shared ReadOnly Property BadViewForAttachedGroupWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewForAttachedGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddAlreadyMemberToDiffGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotAddAlreadyMemberToDiffGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements that are already members of one group cannot be added to another group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddAlreadyMemberToDiffGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddAlreadyMemberToDiffGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddAlreadyMemberToDiffGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddToGroupFormat Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotAddToGroupFormat Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormat { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToGroupFormat As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormat {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotAddToGroupFormatWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotAddToGroupFormatWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
[Element] cannot be added to the instance of [Group]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAddToGroupFormatWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotAddToGroupFormatWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAddToGroupFormatWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCopyGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotCopyGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to copy the selected group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCreateGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotCreateGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Cannot create group of these elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotCreateGroupWithInvalidReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotCreateGroupWithInvalidReferences Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGroupWithInvalidReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGroupWithInvalidReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGroupWithInvalidReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotFinishGroupInSketchMode Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotFinishGroupInSketchMode Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't Finish Group while in Sketch Mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotFinishGroupInSketchMode { get; }
Visual Basic
Public Shared ReadOnly Property CannotFinishGroupInSketchMode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotFinishGroupInSketchMode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotLinkAnnotationsForSomeViews Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotLinkAnnotationsForSomeViews Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Annotations for some views cannot be displayed from linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotLinkAnnotationsForSomeViews { get; }
Visual Basic
Public Shared ReadOnly Property CannotLinkAnnotationsForSomeViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotLinkAnnotationsForSomeViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotPlaceGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotPlaceGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't place Group from browser. Try copy/pasting existing copy of the Group instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotReloadWithFile Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotReloadWithFile Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group [Type Name] cannot be reloaded from file [File Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotReloadWithFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotReloadWithFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotReloadWithFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveGroupMemberConstraint Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveGroupMemberConstraint Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveGroupMemberConstraint { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveGroupMemberConstraintWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveGroupMemberConstraintWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Constraints between group members cannot be removed or excluded from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveGroupMemberConstraintWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveGroupMemberConstraintWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveGroupMemberConstraintWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveSubordFromGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveSubordFromGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveSubordFromGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotRemoveSubordFromGroupWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotRemoveSubordFromGroupWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Element can't be removed or excluded from the Group because it is required by another Group element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRemoveSubordFromGroupWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotRemoveSubordFromGroupWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRemoveSubordFromGroupWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotSaveGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotSaveGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't save Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSaveGroup { get; }
Visual Basic
Public Shared ReadOnly Property CannotSaveGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSaveGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


CannotSwapNestedGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..CannotSwapNestedGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't replace because one Group is contained in the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSwapNestedGroups { get; }
Visual Basic
Public Shared ReadOnly Property CannotSwapNestedGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSwapNestedGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ChildrenDeletedOnGroupSwap Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ChildrenDeletedOnGroupSwap Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some dependent elements were deleted by changing group type and cannot be retained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ChildrenDeletedOnGroupSwap { get; }
Visual Basic
Public Shared ReadOnly Property ChildrenDeletedOnGroupSwap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChildrenDeletedOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ChildrenLostOnGroupSwap Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ChildrenLostOnGroupSwap Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some elements could not find new hosts after changing group type and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ChildrenLostOnGroupSwap { get; }
Visual Basic
Public Shared ReadOnly Property ChildrenLostOnGroupSwap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChildrenLostOnGroupSwap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DetailsOfNestedGroupsLost Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..DetailsOfNestedGroupsLost Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Details will be deleted if they reference group members being ungrouped in other instances of this containing group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DetailsOfNestedGroupsLost { get; }
Visual Basic
Public Shared ReadOnly Property DetailsOfNestedGroupsLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailsOfNestedGroupsLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DimensionsOrTagsReferecedRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..DimensionsOrTagsReferecedRemoved Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Dimensions or Tags that reference non-group members have been removed from group [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionsOrTagsReferecedRemoved { get; }
Visual Basic
Public Shared ReadOnly Property DimensionsOrTagsReferecedRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionsOrTagsReferecedRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DimRefsGroupMemberSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..DimRefsGroupMemberSketch Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimRefsGroupMemberSketch { get; }
Visual Basic
Public Shared ReadOnly Property DimRefsGroupMemberSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimRefsGroupMemberSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


DontEditNestedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..DontEditNestedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DontEditNestedGroup { get; }
Visual Basic
Public Shared ReadOnly Property DontEditNestedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DontEditNestedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ElementChangedMoreThanAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ElementChangedMoreThanAllowed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementChangedMoreThanAllowed { get; }
Visual Basic
Public Shared ReadOnly Property ElementChangedMoreThanAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementChangedMoreThanAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ExcludedElementsRestoredInLink Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ExcludedElementsRestoredInLink Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Excluded elements restored in the link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExcludedElementsRestoredInLink { get; }
Visual Basic
Public Shared ReadOnly Property ExcludedElementsRestoredInLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExcludedElementsRestoredInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


FailedToChangeGroupLevelRef Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..FailedToChangeGroupLevelRef Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to change group level ref.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToChangeGroupLevelRef { get; }
Visual Basic
Public Shared ReadOnly Property FailedToChangeGroupLevelRef As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeGroupLevelRef {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


FailedToSetMasterGroupId Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..FailedToSetMasterGroupId Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to set master id of group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetMasterGroupId { get; }
Visual Basic
Public Shared ReadOnly Property FailedToSetMasterGroupId As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToSetMasterGroupId {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


FailedToTransformAttachedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..FailedToTransformAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Attached group could not be properly relocated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToTransformAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property FailedToTransformAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToTransformAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupAmongstLoadedRenamed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupAmongstLoadedRenamed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupAmongstLoadedRenamed { get; }
Visual Basic
Public Shared ReadOnly Property GroupAmongstLoadedRenamed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupAmongstLoadedRenamed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotMixBackAndForegroundDetail Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupCannotMixBackAndForegroundDetail Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotMixBackAndForegroundDetail { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotMixBackAndForegroundDetail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotMixBackAndForegroundDetail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotSave Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupCannotSave Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotSave { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotSave As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSave {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupCannotSaveWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupCannotSaveWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The group cannot be saved at this time because one of its instances is being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupCannotSaveWarn { get; }
Visual Basic
Public Shared ReadOnly Property GroupCannotSaveWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupCannotSaveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupChangeNoPlaceElements Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupChangeNoPlaceElements Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements cannot be placed as a result of changes to groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupChangeNoPlaceElements { get; }
Visual Basic
Public Shared ReadOnly Property GroupChangeNoPlaceElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupChangeNoPlaceElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupEditModeNoDuplicates Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupEditModeNoDuplicates Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't create duplicates in Edit Group mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupEditModeNoDuplicates { get; }
Visual Basic
Public Shared ReadOnly Property GroupEditModeNoDuplicates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupEditModeNoDuplicates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupedModelElemHasViewSpecificSubordinates Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupedModelElemHasViewSpecificSubordinates Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupedModelElemHasViewSpecificSubordinates { get; }
Visual Basic
Public Shared ReadOnly Property GroupedModelElemHasViewSpecificSubordinates As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupedModelElemHasViewSpecificSubordinates {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupHadFailedElementsWhileUpdating Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupHadFailedElementsWhileUpdating Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members failed while updating group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupHadFailedElementsWhileUpdating { get; }
Visual Basic
Public Shared ReadOnly Property GroupHadFailedElementsWhileUpdating As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupHadFailedElementsWhileUpdating {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupPropagationFailedSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupPropagationFailedSketch Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationFailedSketch { get; }
Visual Basic
Public Shared ReadOnly Property GroupPropagationFailedSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationFailedSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupPropagationFailedUngroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupPropagationFailedUngroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationFailedUngroup { get; }
Visual Basic
Public Shared ReadOnly Property GroupPropagationFailedUngroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationFailedUngroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupPropagationUserCancelled Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupPropagationUserCancelled Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Changes to Group "[Type Name]" have been cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupPropagationUserCancelled { get; }
Visual Basic
Public Shared ReadOnly Property GroupPropagationUserCancelled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupPropagationUserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsHasCycle Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupsHasCycle Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Can't create Group because it contains multiple copies of same Group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsHasCycle { get; }
Visual Basic
Public Shared ReadOnly Property GroupsHasCycle As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsHasCycle {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsHaveDifferentMembers Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupsHaveDifferentMembers Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsHaveDifferentMembers { get; }
Visual Basic
Public Shared ReadOnly Property GroupsHaveDifferentMembers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsHaveDifferentMembers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupsNotCompatibleForTypeChange Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupsNotCompatibleForTypeChange Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Some of the selected groups are not compatible with the new group type that was chosen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupsNotCompatibleForTypeChange { get; }
Visual Basic
Public Shared ReadOnly Property GroupsNotCompatibleForTypeChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupsNotCompatibleForTypeChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


GroupViewSpecificDiffViews Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..GroupViewSpecificDiffViews Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You may not create a detail group with view specific elements from different views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GroupViewSpecificDiffViews { get; }
Visual Basic
Public Shared ReadOnly Property GroupViewSpecificDiffViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GroupViewSpecificDiffViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


InvalidGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..InvalidGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
This group is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidGroup { get; }
Visual Basic
Public Shared ReadOnly Property InvalidGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LastCopyOfGroupDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..LastCopyOfGroupDeleted Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Last copy of Group "[Name]" deleted. Group type removed from project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LastCopyOfGroupDeleted { get; }
Visual Basic
Public Shared ReadOnly Property LastCopyOfGroupDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LastCopyOfGroupDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LastGroupMemberExcluded Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..LastGroupMemberExcluded Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LastGroupMemberExcluded { get; }
Visual Basic
Public Shared ReadOnly Property LastGroupMemberExcluded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LastGroupMemberExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LinkVisibilityLost Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..LinkVisibilityLost Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Link visibility overrides will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinkVisibilityLost { get; }
Visual Basic
Public Shared ReadOnly Property LinkVisibilityLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinkVisibilityLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


LoadOfGroupAbortedByUser Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..LoadOfGroupAbortedByUser Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You have aborted loading file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoadOfGroupAbortedByUser { get; }
Visual Basic
Public Shared ReadOnly Property LoadOfGroupAbortedByUser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoadOfGroupAbortedByUser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersExcluded Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..MembersExcluded Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MembersExcluded { get; }
Visual Basic
Public Shared ReadOnly Property MembersExcluded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersExcludedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..MembersExcludedWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members have been excluded from this group instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MembersExcludedWarn { get; }
Visual Basic
Public Shared ReadOnly Property MembersExcludedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersExcludedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MembersMovedToProjectToMakeConsistent Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..MembersMovedToProjectToMakeConsistent Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MembersMovedToProjectToMakeConsistent { get; }
Visual Basic
Public Shared ReadOnly Property MembersMovedToProjectToMakeConsistent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MembersMovedToProjectToMakeConsistent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ModifyingMultiGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ModifyingMultiGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingMultiGroups { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingMultiGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingMultiGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


MoveElemFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..MoveElemFailed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to move element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MoveElemFailed { get; }
Visual Basic
Public Shared ReadOnly Property MoveElemFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoveElemFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoAppropriateGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NoAppropriateGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
There is no Group that can be placed in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoAppropriateGroup { get; }
Visual Basic
Public Shared ReadOnly Property NoAppropriateGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoAppropriateGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoDetailGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NoDetailGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
There are no Detail Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoDetailGroups { get; }
Visual Basic
Public Shared ReadOnly Property NoDetailGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoDetailGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoModelGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NoModelGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
There are no Model Groups in this Project or Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoModelGroups { get; }
Visual Basic
Public Shared ReadOnly Property NoModelGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoModelGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoneOfSelElemsGroupable Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NoneOfSelElemsGroupable Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoneOfSelElemsGroupable { get; }
Visual Basic
Public Shared ReadOnly Property NoneOfSelElemsGroupable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoneOfSelElemsGroupable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NoSwapGroupBeingEdited Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NoSwapGroupBeingEdited Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You may not change the type of the group that is currently being edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSwapGroupBeingEdited { get; }
Visual Basic
Public Shared ReadOnly Property NoSwapGroupBeingEdited As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSwapGroupBeingEdited {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NotAGroupFile Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NotAGroupFile Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
This is not a Group File.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAGroupFile { get; }
Visual Basic
Public Shared ReadOnly Property NotAGroupFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAGroupFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


NotAllGroupsFullyRestored Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..NotAllGroupsFullyRestored Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAllGroupsFullyRestored { get; }
Visual Basic
Public Shared ReadOnly Property NotAllGroupsFullyRestored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAllGroupsFullyRestored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


PlaceGroupFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..PlaceGroupFailed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to place group instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PlaceGroupFailed { get; }
Visual Basic
Public Shared ReadOnly Property PlaceGroupFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlaceGroupFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ProblemRegeneratingInGroupUpdate Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ProblemRegeneratingInGroupUpdate Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to regenerate while updating groups at end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProblemRegeneratingInGroupUpdate { get; }
Visual Basic
Public Shared ReadOnly Property ProblemRegeneratingInGroupUpdate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProblemRegeneratingInGroupUpdate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


ReferencesOutsideGroupAreNotAllowed Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..ReferencesOutsideGroupAreNotAllowed Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencesOutsideGroupAreNotAllowed { get; }
Visual Basic
Public Shared ReadOnly Property ReferencesOutsideGroupAreNotAllowed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReferencesOutsideGroupAreNotAllowed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemoveGroupSketchConstraintParent Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..RemoveGroupSketchConstraintParent Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveGroupSketchConstraintParent { get; }
Visual Basic
Public Shared ReadOnly Property RemoveGroupSketchConstraintParent As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveGroupSketchConstraintParent {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemovingElemCannotBeGrouped Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..RemovingElemCannotBeGrouped Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Elements that cannot be grouped were removed from groups of type '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingElemCannotBeGrouped { get; }
Visual Basic
Public Shared ReadOnly Property RemovingElemCannotBeGrouped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingElemCannotBeGrouped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RemovingReferencesFromGroupedCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..RemovingReferencesFromGroupedCurve Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
References to elements outside the group were removed from a grouped curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemovingReferencesFromGroupedCurve { get; }
Visual Basic
Public Shared ReadOnly Property RemovingReferencesFromGroupedCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemovingReferencesFromGroupedCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


RevitUnableToUpadateGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..RevitUnableToUpadateGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to update groups for changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RevitUnableToUpadateGroups { get; }
Visual Basic
Public Shared ReadOnly Property RevitUnableToUpadateGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RevitUnableToUpadateGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


SomeGroupInstsBecameEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..SomeGroupInstsBecameEmpty Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Group instances have had all their group members deleted and will also be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeGroupInstsBecameEmpty { get; }
Visual Basic
Public Shared ReadOnly Property SomeGroupInstsBecameEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeGroupInstsBecameEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


SomeMembersNotRestored Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..SomeMembersNotRestored Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeMembersNotRestored { get; }
Visual Basic
Public Shared ReadOnly Property SomeMembersNotRestored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeMembersNotRestored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToBindLink Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToBindLink Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to bind the selected links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToBindLink { get; }
Visual Basic
Public Shared ReadOnly Property UnableToBindLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToBindLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToBindLinkInstances Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToBindLinkInstances Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToBindLinkInstances { get; }
Visual Basic
Public Shared ReadOnly Property UnableToBindLinkInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToBindLinkInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToConvertGroupsToLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToConvertGroupsToLinks Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to convert the selected groups to links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToConvertGroupsToLinks { get; }
Visual Basic
Public Shared ReadOnly Property UnableToConvertGroupsToLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToConvertGroupsToLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToCreateAttachedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToCreateAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCreateAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCreateAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToDetachGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToDetachGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to detach the selected attached detail group(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToDetachGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToDetachGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToDetachGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToExcludeElems Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToExcludeElems Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to exclude the selected group members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToExcludeElems { get; }
Visual Basic
Public Shared ReadOnly Property UnableToExcludeElems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToExcludeElems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToGroupElems Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToGroupElems Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToGroupElems { get; }
Visual Basic
Public Shared ReadOnly Property UnableToGroupElems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToGroupElems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToLoadAttachedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToLoadAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load attached detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToLoadDetailGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToLoadDetailGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load detail group '[Type Name]'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadDetailGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadDetailGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadDetailGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToLoadGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToLoadGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load file '[File Name]' as a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToLoadGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToLoadGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToLoadGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToMaintainExclusions Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToMaintainExclusions Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusions { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMaintainExclusions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToMaintainExclusionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToMaintainExclusionsWarn Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to maintain exclusion of some group members. Some excluded members have been restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMaintainExclusionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMaintainExclusionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMaintainExclusionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToMoveElemsToProject Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToMoveElemsToProject Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit is unable to move the selected group members to the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToMoveElemsToProject { get; }
Visual Basic
Public Shared ReadOnly Property UnableToMoveElemsToProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToMoveElemsToProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToRemapDetails Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToRemapDetails Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to create attached detail group in view '[View Name]' for the selected elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToRemapDetails { get; }
Visual Basic
Public Shared ReadOnly Property UnableToRemapDetails As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToRemapDetails {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToReplaceSelectedGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToReplaceSelectedGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToReplaceSelectedGroups { get; }
Visual Basic
Public Shared ReadOnly Property UnableToReplaceSelectedGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToReplaceSelectedGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToRestoreAllMembersOfGroups Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToRestoreAllMembersOfGroups Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Revit is unable to restore the members of the selected groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToRestoreAllMembersOfGroups { get; }
Visual Basic
Public Shared ReadOnly Property UnableToRestoreAllMembersOfGroups As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToRestoreAllMembersOfGroups {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToSaveGroupType Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToSaveGroupType Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to save group type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToSaveGroupType { get; }
Visual Basic
Public Shared ReadOnly Property UnableToSaveGroupType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToSaveGroupType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


UnableToTransferAttachedGroup Property

[image]

Revit 2013 API
BuiltInFailures..::..GroupFailures..::..UnableToTransferAttachedGroup Property
BuiltInFailures..::..GroupFailures Class See Also Send Feedback
Unable to load attached group [Type Name] of model group [Type Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToTransferAttachedGroup { get; }
Visual Basic
Public Shared ReadOnly Property UnableToTransferAttachedGroup As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToTransferAttachedGroup {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..GroupFailures Class


BuiltInFailures.HostFinishFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HostFinish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class HostFinishFailures
Visual Basic
Public NotInheritable Class HostFinishFailures
Visual C++
public ref class HostFinishFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..HostFinishFailures

See Also

BuiltInFailures..::..HostFinishFailures Members


BuiltInFailures.HostFinishFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures Members
BuiltInFailures..::..HostFinishFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..HostFinishFailures type exposes the following members.

Properties

Name | Description
HostFinishFailedBoolean | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanError | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanWarn | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedFaceActive | Host Finish does not have any volume
HostFinishFailedFaceActiveError | Host Finish does not have any volume
HostFinishFailedFaceActiveWarn | Host Finish does not have any volume
HostFinishFailedHostHow | Host Finish cannot be hosted by such host
HostFinishFailedHostHowError | Host Finish cannot be hosted by such host
HostFinishFailedHostHowWarn | Host Finish cannot be hosted by such host
HostFinishFailedNotSet | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetError | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetWarn | Host Finish is not set properly and cannot be created.
HostFinishFailedOffsetRadius | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusError | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusWarn | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedSketch | Hast Finish cannot be based on this sketch
HostFinishFailedSketchError | Hast Finish cannot be based on this sketch
HostFinishFailedSketchWarn | Hast Finish cannot be based on this sketch
HostFinishTooThin | Host Finish too thin.

See Also

BuiltInFailures..::..HostFinishFailures Class


BuiltInFailures.HostFinishFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures Properties
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback

The BuiltInFailures..::..HostFinishFailures type exposes the following members.

Properties

Name | Description
HostFinishFailedBoolean | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanError | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedBooleanWarn | Boolean operation(s) with Host Finish geometry failed
HostFinishFailedFaceActive | Host Finish does not have any volume
HostFinishFailedFaceActiveError | Host Finish does not have any volume
HostFinishFailedFaceActiveWarn | Host Finish does not have any volume
HostFinishFailedHostHow | Host Finish cannot be hosted by such host
HostFinishFailedHostHowError | Host Finish cannot be hosted by such host
HostFinishFailedHostHowWarn | Host Finish cannot be hosted by such host
HostFinishFailedNotSet | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetError | Host Finish is not set properly and cannot be created.
HostFinishFailedNotSetWarn | Host Finish is not set properly and cannot be created.
HostFinishFailedOffsetRadius | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusError | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedOffsetRadiusWarn | Offset of the Host Finish is incompatible with radius of its host
HostFinishFailedSketch | Hast Finish cannot be based on this sketch
HostFinishFailedSketchError | Hast Finish cannot be based on this sketch
HostFinishFailedSketchWarn | Hast Finish cannot be based on this sketch
HostFinishTooThin | Host Finish too thin.

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedBoolean Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedBoolean Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBoolean { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedBoolean As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBoolean {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedBooleanError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedBooleanError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBooleanError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedBooleanError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBooleanError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedBooleanWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedBooleanWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Boolean operation(s) with Host Finish geometry failed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedBooleanWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedBooleanWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedBooleanWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedFaceActive Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedFaceActive Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActive { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedFaceActive As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActive {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedFaceActiveError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedFaceActiveError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActiveError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedFaceActiveError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActiveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedFaceActiveWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedFaceActiveWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish does not have any volume

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedFaceActiveWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedFaceActiveWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedFaceActiveWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedHostHow Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedHostHow Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHow { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedHostHow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedHostHowError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedHostHowError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHowError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedHostHowError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHowError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedHostHowWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedHostHowWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish cannot be hosted by such host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedHostHowWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedHostHowWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedHostHowWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedNotSet Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedNotSet Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSet { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedNotSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedNotSetError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedNotSetError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSetError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedNotSetError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSetError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedNotSetWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedNotSetWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish is not set properly and cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedNotSetWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedNotSetWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedNotSetWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedOffsetRadius Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedOffsetRadius Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadius { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedOffsetRadius As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadius {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedOffsetRadiusError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedOffsetRadiusError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadiusError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedOffsetRadiusError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadiusError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedOffsetRadiusWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedOffsetRadiusWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Offset of the Host Finish is incompatible with radius of its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedOffsetRadiusWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedOffsetRadiusWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedOffsetRadiusWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedSketch Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketch { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedSketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedSketchError Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketchError { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishFailedSketchWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishFailedSketchWarn Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Hast Finish cannot be based on this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishFailedSketchWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishFailedSketchWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishFailedSketchWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


HostFinishTooThin Property

[image]

Revit 2013 API
BuiltInFailures..::..HostFinishFailures..::..HostFinishTooThin Property
BuiltInFailures..::..HostFinishFailures Class See Also Send Feedback
Host Finish too thin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishTooThin { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishTooThin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostFinishFailures Class


BuiltInFailures.HostObjFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..HostObjFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HostObj.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class HostObjFailures
Visual Basic
Public NotInheritable Class HostObjFailures
Visual C++
public ref class HostObjFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..HostObjFailures

See Also

BuiltInFailures..::..HostObjFailures Members


BuiltInFailures.HostObjFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..HostObjFailures Members
BuiltInFailures..::..HostObjFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::..HostObjFailures Class


BuiltInFailures.HostObjFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..HostObjFailures Properties
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback

The BuiltInFailures..::..HostObjFailures type exposes the following members.

Properties

Name | Description
HostMismatch | Can't use this type in this host.
ReferencesNulled | One or more references are or have become invalid.

See Also

BuiltInFailures..::..HostObjFailures Class


HostMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..HostObjFailures..::..HostMismatch Property
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback
Can't use this type in this host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostMismatch { get; }
Visual Basic
Public Shared ReadOnly Property HostMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostObjFailures Class


ReferencesNulled Property

[image]

Revit 2013 API
BuiltInFailures..::..HostObjFailures..::..ReferencesNulled Property
BuiltInFailures..::..HostObjFailures Class See Also Send Feedback
One or more references are or have become invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReferencesNulled { get; }
Visual Basic
Public Shared ReadOnly Property ReferencesNulled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReferencesNulled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HostObjFailures Class


BuiltInFailures.HvacFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..HvacFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class HvacFailures
Visual Basic
Public NotInheritable Class HvacFailures
Visual C++
public ref class HvacFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..HvacFailures

See Also

BuiltInFailures..::..HvacFailures Members


BuiltInFailures.HvacFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..HvacFailures Members
BuiltInFailures..::..HvacFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::..HvacFailures Class


BuiltInFailures.HvacFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..HvacFailures Properties
BuiltInFailures..::..HvacFailures Class See Also Send Feedback

The BuiltInFailures..::..HvacFailures type exposes the following members.

Properties

Name | Description
PanelDoesntMatchCircuitPropertiesDisconnected | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

See Also

BuiltInFailures..::..HvacFailures Class


PanelDoesntMatchCircuitPropertiesDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..HvacFailures..::..PanelDoesntMatchCircuitPropertiesDisconnected Property
BuiltInFailures..::..HvacFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitPropertiesDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property PanelDoesntMatchCircuitPropertiesDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitPropertiesDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..HvacFailures Class


BuiltInFailures.IlluminationFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Illumination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class IlluminationFailures
Visual Basic
Public NotInheritable Class IlluminationFailures
Visual C++
public ref class IlluminationFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..IlluminationFailures

See Also

BuiltInFailures..::..IlluminationFailures Members


BuiltInFailures.IlluminationFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures Members
BuiltInFailures..::..IlluminationFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::..IlluminationFailures Class


BuiltInFailures.IlluminationFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures Properties
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback

The BuiltInFailures..::..IlluminationFailures type exposes the following members.

Properties

Name | Description
IESFileNotFoundWarning | Estimated Illumination failed. IES file not found for lighting fixture.
LightingFixtureLumensWarning | Estimated Illumination failed. Lumens not set for lighting fixture.
RoomCoefficientUtilizationWarning | Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.
RoomLightLossFactorWarning | Estimated Illumination failed. Light Loss factor not set for lighting fixture.

See Also

BuiltInFailures..::..IlluminationFailures Class


IESFileNotFoundWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures..::..IESFileNotFoundWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. IES file not found for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IESFileNotFoundWarning { get; }
Visual Basic
Public Shared ReadOnly Property IESFileNotFoundWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IESFileNotFoundWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


LightingFixtureLumensWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures..::..LightingFixtureLumensWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Lumens not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LightingFixtureLumensWarning { get; }
Visual Basic
Public Shared ReadOnly Property LightingFixtureLumensWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LightingFixtureLumensWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


RoomCoefficientUtilizationWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures..::..RoomCoefficientUtilizationWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Coefficient of utilization not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomCoefficientUtilizationWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomCoefficientUtilizationWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomCoefficientUtilizationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


RoomLightLossFactorWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..IlluminationFailures..::..RoomLightLossFactorWarning Property
BuiltInFailures..::..IlluminationFailures Class See Also Send Feedback
Estimated Illumination failed. Light Loss factor not set for lighting fixture.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomLightLossFactorWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomLightLossFactorWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomLightLossFactorWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..IlluminationFailures Class


BuiltInFailures.ImageFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ImageFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ImageFailures
Visual Basic
Public NotInheritable Class ImageFailures
Visual C++
public ref class ImageFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ImageFailures

See Also

BuiltInFailures..::..ImageFailures Members


BuiltInFailures.ImageFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ImageFailures Members
BuiltInFailures..::..ImageFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.

See Also

BuiltInFailures..::..ImageFailures Class


BuiltInFailures.ImageFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ImageFailures Properties
BuiltInFailures..::..ImageFailures Class See Also Send Feedback

The BuiltInFailures..::..ImageFailures type exposes the following members.

Properties

Name | Description
BadViewType | Image Instances can't be placed in 3D Views.

See Also

BuiltInFailures..::..ImageFailures Class


BadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..ImageFailures..::..BadViewType Property
BuiltInFailures..::..ImageFailures Class See Also Send Feedback
Image Instances can't be placed in 3D Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImageFailures Class


BuiltInFailures.ImportFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ImportFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ImportFailures
Visual Basic
Public NotInheritable Class ImportFailures
Visual C++
public ref class ImportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ImportFailures

See Also

BuiltInFailures..::..ImportFailures Members


BuiltInFailures.ImportFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ImportFailures Members
BuiltInFailures..::..ImportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ImportFailures type exposes the following members.

Properties

Name | Description
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
CannotRelinkWrapper | [Description]
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained 3D data or points which can't be exploded. Only 2D data was exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]

See Also

BuiltInFailures..::..ImportFailures Class


BuiltInFailures.ImportFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ImportFailures Properties
BuiltInFailures..::..ImportFailures Class See Also Send Feedback

The BuiltInFailures..::..ImportFailures type exposes the following members.

Properties

Name | Description
BadFaceFoundInDwg | One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.
CannotChangeImportSymbol | Can't change an imported or linked element's symbol type.
CannotExplodeElement | Can't explode the imported object.
CannotImportFile | Can't import file.
CannotRelinkWrapper | [Description]
FailedToSetWorkplane | Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.
IFCGenericImportWarning | The following problems were encountered in the IFC file: [Description]
IFCGenericRevitImportWarning | Revit had the following problems importing the IFC file: [Description]
ImportTooFarAway | Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.
ImportTooManyElmentsToExplode | Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.
LostAcisObjectsOnImport | Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.
SomeObjectsNotExploded | Import contained 3D data or points which can't be exploded. Only 2D data was exploded.
TextNotImported | Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.
TooManyPickFaces | Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.
WorksetCreatedForLinkWarning | Newly created link types and instances were placed in new workset [workset name]

See Also

BuiltInFailures..::..ImportFailures Class


BadFaceFoundInDwg Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..BadFaceFoundInDwg Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
One or more hatch regions were found in the imported file with unconnected boundaries. These hatch regions will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadFaceFoundInDwg { get; }
Visual Basic
Public Shared ReadOnly Property BadFaceFoundInDwg As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadFaceFoundInDwg {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotChangeImportSymbol Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..CannotChangeImportSymbol Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't change an imported or linked element's symbol type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeImportSymbol { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeImportSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeImportSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotExplodeElement Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..CannotExplodeElement Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't explode the imported object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotExplodeElement { get; }
Visual Basic
Public Shared ReadOnly Property CannotExplodeElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotExplodeElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotImportFile Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..CannotImportFile Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Can't import file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotImportFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotImportFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotImportFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


CannotRelinkWrapper Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..CannotRelinkWrapper Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
[Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRelinkWrapper { get; }
Visual Basic
Public Shared ReadOnly Property CannotRelinkWrapper As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRelinkWrapper {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


FailedToSetWorkplane Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..FailedToSetWorkplane Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Could not set Work Plane of [Import].\n\nPlease use the Work Plane tool to set a Work Plane for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToSetWorkplane { get; }
Visual Basic
Public Shared ReadOnly Property FailedToSetWorkplane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToSetWorkplane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCGenericImportWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..IFCGenericImportWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
The following problems were encountered in the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IFCGenericImportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericImportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


IFCGenericRevitImportWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..IFCGenericRevitImportWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Revit had the following problems importing the IFC file: [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IFCGenericRevitImportWarning { get; }
Visual Basic
Public Shared ReadOnly Property IFCGenericRevitImportWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IFCGenericRevitImportWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportTooFarAway Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..ImportTooFarAway Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Imported objects located a large distance from the model might not display properly. The 'Center-to-Center' option will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ImportTooFarAway { get; }
Visual Basic
Public Shared ReadOnly Property ImportTooFarAway As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportTooFarAway {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


ImportTooManyElmentsToExplode Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..ImportTooManyElmentsToExplode Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Import Instance has [Number] elements. Imports with more than 10,000 elements cannot be exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ImportTooManyElmentsToExplode { get; }
Visual Basic
Public Shared ReadOnly Property ImportTooManyElmentsToExplode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ImportTooManyElmentsToExplode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


LostAcisObjectsOnImport Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..LostAcisObjectsOnImport Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Some ACIS objects could not be imported. To import them, use AutoCAD to convert them into polymesh objects and reimport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LostAcisObjectsOnImport { get; }
Visual Basic
Public Shared ReadOnly Property LostAcisObjectsOnImport As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LostAcisObjectsOnImport {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


SomeObjectsNotExploded Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..SomeObjectsNotExploded Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Import contained 3D data or points which can't be exploded. Only 2D data was exploded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SomeObjectsNotExploded { get; }
Visual Basic
Public Shared ReadOnly Property SomeObjectsNotExploded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SomeObjectsNotExploded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


TextNotImported Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..TextNotImported Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Text is only imported if the "Current View Only" option is selected. To see the text in the original file, import again with this check box selected in the Import Dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TextNotImported { get; }
Visual Basic
Public Shared ReadOnly Property TextNotImported As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TextNotImported {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


TooManyPickFaces Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..TooManyPickFaces Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Too many faces were created from imported meshes. Host by Face tools may not select the imported meshes correctly. Decrease the complexity of the file or try importing only selected layers to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyPickFaces { get; }
Visual Basic
Public Shared ReadOnly Property TooManyPickFaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyPickFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


WorksetCreatedForLinkWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ImportFailures..::..WorksetCreatedForLinkWarning Property
BuiltInFailures..::..ImportFailures Class See Also Send Feedback
Newly created link types and instances were placed in new workset [workset name]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WorksetCreatedForLinkWarning { get; }
Visual Basic
Public Shared ReadOnly Property WorksetCreatedForLinkWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorksetCreatedForLinkWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ImportFailures Class


BuiltInFailures.InaccurateFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class InaccurateFailures
Visual Basic
Public NotInheritable Class InaccurateFailures
Visual C++
public ref class InaccurateFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..InaccurateFailures

See Also

BuiltInFailures..::..InaccurateFailures Members


BuiltInFailures.InaccurateFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures Members
BuiltInFailures..::..InaccurateFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::..InaccurateFailures Class


BuiltInFailures.InaccurateFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures Properties
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback

The BuiltInFailures..::..InaccurateFailures type exposes the following members.

Properties

Name | Description
InaccurateAreaLine | Area separation line is slightly off axis and may cause inaccuracies.
InaccurateBeamOrBrace | Beam or Brace is slightly off axis and may cause inaccuracies.
InaccurateCurveBasedFamily | Curve-Based Family is slightly off axis and may cause inaccuracies.
InaccurateDriveCurve | Element is slightly off axis and may cause inaccuracies.
InaccurateGrid | Grid is slightly off axis and may cause inaccuracies.
InaccurateLevel | Level is slightly off axis and may cause inaccuracies.
InaccurateLine | Line is slightly off axis and may cause inaccuracies.
InaccurateMassingSketchLine | Line in Massing Sketch is slightly off axis and may cause inaccuracies.
InaccurateRefPlane | Ref Plane is slightly off axis and may cause inaccuracies.
InaccurateRoomSeparation | Room separation line is slightly off axis and may cause inaccuracies.
InaccurateSketchLine | Line in Sketch is slightly off axis and may cause inaccuracies.
InaccurateSpaceSeparation | Space separation line is slightly off axis and may cause inaccuracies.
InaccurateWall | Wall is slightly off axis and may cause inaccuracies.

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateAreaLine Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateAreaLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Area separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateAreaLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateAreaLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateAreaLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateBeamOrBrace Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateBeamOrBrace Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Beam or Brace is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateBeamOrBrace { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateBeamOrBrace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateBeamOrBrace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateCurveBasedFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateCurveBasedFamily Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Curve-Based Family is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateCurveBasedFamily { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateCurveBasedFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateCurveBasedFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateDriveCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateDriveCurve Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Element is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateDriveCurve { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateDriveCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateDriveCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateGrid Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateGrid Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Grid is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateGrid { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateLevel Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Level is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateLevel { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateLine Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateMassingSketchLine Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateMassingSketchLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Line in Massing Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateMassingSketchLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateMassingSketchLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateMassingSketchLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateRefPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateRefPlane Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Ref Plane is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateRefPlane { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateRefPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateRefPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateRoomSeparation Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateRoomSeparation Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Room separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateRoomSeparation { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateRoomSeparation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateRoomSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateSketchLine Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateSketchLine Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Line in Sketch is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateSketchLine { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateSketchLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateSketchLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateSpaceSeparation Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateSpaceSeparation Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Space separation line is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateSpaceSeparation { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateSpaceSeparation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateSpaceSeparation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


InaccurateWall Property

[image]

Revit 2013 API
BuiltInFailures..::..InaccurateFailures..::..InaccurateWall Property
BuiltInFailures..::..InaccurateFailures Class See Also Send Feedback
Wall is slightly off axis and may cause inaccuracies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InaccurateWall { get; }
Visual Basic
Public Shared ReadOnly Property InaccurateWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InaccurateWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InaccurateFailures Class


BuiltInFailures.InfillFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Infill.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class InfillFailures
Visual Basic
Public NotInheritable Class InfillFailures
Visual C++
public ref class InfillFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..InfillFailures

See Also

BuiltInFailures..::..InfillFailures Members


BuiltInFailures.InfillFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..InfillFailures Members
BuiltInFailures..::..InfillFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..InfillFailures type exposes the following members.

Properties

Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.

See Also

BuiltInFailures..::..InfillFailures Class


BuiltInFailures.InfillFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..InfillFailures Properties
BuiltInFailures..::..InfillFailures Class See Also Send Feedback

The BuiltInFailures..::..InfillFailures type exposes the following members.

Properties

Name | Description
CannotDeleteInfill | Can't delete infilling element without deleting its insert or host.
FamilyInstanceIsNotCuttingHost | Instance is not cutting host.
InfillCannotChangeType | Infilling element replaced by a later phase insert must be the same type as the insert's host.
InfillCannotHaveDiffThickness | This infilling element must have the same thickness as its host.
InfillDifferentPhase | Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.
InfillLost | Standalone infilling Wall is separated from its insert.
InfillNoSlopeGlazing | Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.
InfillNoThicknessCeiling | Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.
InfillNoThicknessMultiface | Highlighted infilling element could not have thickness different from its host because it spans multiple faces.
InPlaceFamilyNotCuttingHost | Instance of in-place family is not cutting host.
InsertJoinedWall | Insert conflicts with joined Wall.
InsertOverlapsOrOut | Highlighted inserts overlap with other inserts or completely miss their hosts.
MovedInfillToHost | Infilling element was automatically moved to keep it aligned to host.

See Also

BuiltInFailures..::..InfillFailures Class


CannotDeleteInfill Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..CannotDeleteInfill Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Can't delete infilling element without deleting its insert or host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDeleteInfill { get; }
Visual Basic
Public Shared ReadOnly Property CannotDeleteInfill As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDeleteInfill {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


FamilyInstanceIsNotCuttingHost Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..FamilyInstanceIsNotCuttingHost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Instance is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyInstanceIsNotCuttingHost { get; }
Visual Basic
Public Shared ReadOnly Property FamilyInstanceIsNotCuttingHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyInstanceIsNotCuttingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillCannotChangeType Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillCannotChangeType Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Infilling element replaced by a later phase insert must be the same type as the insert's host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillCannotChangeType { get; }
Visual Basic
Public Shared ReadOnly Property InfillCannotChangeType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillCannotChangeType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillCannotHaveDiffThickness Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillCannotHaveDiffThickness Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
This infilling element must have the same thickness as its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillCannotHaveDiffThickness { get; }
Visual Basic
Public Shared ReadOnly Property InfillCannotHaveDiffThickness As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillCannotHaveDiffThickness {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillDifferentPhase Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillDifferentPhase Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Wall and instance have different phasing settings. Automatic creation of the infilling wall fails.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillDifferentPhase { get; }
Visual Basic
Public Shared ReadOnly Property InfillDifferentPhase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillDifferentPhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillLost Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillLost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Standalone infilling Wall is separated from its insert.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillLost { get; }
Visual Basic
Public Shared ReadOnly Property InfillLost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillLost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillNoSlopeGlazing Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillNoSlopeGlazing Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Could not change type due to highlighted infilling element. 'Sloped glazing' infills are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoSlopeGlazing { get; }
Visual Basic
Public Shared ReadOnly Property InfillNoSlopeGlazing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillNoSlopeGlazing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillNoThicknessCeiling Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillNoThicknessCeiling Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Could not change type due to highlighted infilling element. 'Basic Ceiling' infills are only compatible with 'Basic Ceiling' hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoThicknessCeiling { get; }
Visual Basic
Public Shared ReadOnly Property InfillNoThicknessCeiling As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillNoThicknessCeiling {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InfillNoThicknessMultiface Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InfillNoThicknessMultiface Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Highlighted infilling element could not have thickness different from its host because it spans multiple faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InfillNoThicknessMultiface { get; }
Visual Basic
Public Shared ReadOnly Property InfillNoThicknessMultiface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InfillNoThicknessMultiface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InPlaceFamilyNotCuttingHost Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InPlaceFamilyNotCuttingHost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Instance of in-place family is not cutting host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InPlaceFamilyNotCuttingHost { get; }
Visual Basic
Public Shared ReadOnly Property InPlaceFamilyNotCuttingHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InPlaceFamilyNotCuttingHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InsertJoinedWall Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InsertJoinedWall Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Insert conflicts with joined Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertJoinedWall { get; }
Visual Basic
Public Shared ReadOnly Property InsertJoinedWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertJoinedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


InsertOverlapsOrOut Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..InsertOverlapsOrOut Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Highlighted inserts overlap with other inserts or completely miss their hosts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertOverlapsOrOut { get; }
Visual Basic
Public Shared ReadOnly Property InsertOverlapsOrOut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertOverlapsOrOut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


MovedInfillToHost Property

[image]

Revit 2013 API
BuiltInFailures..::..InfillFailures..::..MovedInfillToHost Property
BuiltInFailures..::..InfillFailures Class See Also Send Feedback
Infilling element was automatically moved to keep it aligned to host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MovedInfillToHost { get; }
Visual Basic
Public Shared ReadOnly Property MovedInfillToHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MovedInfillToHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InfillFailures Class


BuiltInFailures.InterferenceFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..InterferenceFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Interference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class InterferenceFailures
Visual Basic
Public NotInheritable Class InterferenceFailures
Visual C++
public ref class InterferenceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..InterferenceFailures

See Also

BuiltInFailures..::..InterferenceFailures Members


BuiltInFailures.InterferenceFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..InterferenceFailures Members
BuiltInFailures..::..InterferenceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::..InterferenceFailures Class


BuiltInFailures.InterferenceFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..InterferenceFailures Properties
BuiltInFailures..::..InterferenceFailures Class See Also Send Feedback

The BuiltInFailures..::..InterferenceFailures type exposes the following members.

Properties

Name | Description
GeometryWarning | A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

See Also

BuiltInFailures..::..InterferenceFailures Class


GeometryWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..InterferenceFailures..::..GeometryWarning Property
BuiltInFailures..::..InterferenceFailures Class See Also Send Feedback
A geometrical error has occurred while checking for Interference. Reported interference may not be accurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GeometryWarning { get; }
Visual Basic
Public Shared ReadOnly Property GeometryWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeometryWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..InterferenceFailures Class


BuiltInFailures.JoinElementsFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about JoinElements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class JoinElementsFailures
Visual Basic
Public NotInheritable Class JoinElementsFailures
Visual C++
public ref class JoinElementsFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..JoinElementsFailures

See Also

BuiltInFailures..::..JoinElementsFailures Members


BuiltInFailures.JoinElementsFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures Members
BuiltInFailures..::..JoinElementsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.

See Also

BuiltInFailures..::..JoinElementsFailures Class


BuiltInFailures.JoinElementsFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures Properties
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback

The BuiltInFailures..::..JoinElementsFailures type exposes the following members.

Properties

Name | Description
CannotCope | Can't apply Coping.
CannotCutJoinedGeometry | Element could not be cut by joined element.
CannotJoinDesignOptions | An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.
CannotJoinElements | Can't keep elements joined.
CannotJoinElementsError | Can't keep elements joined.
CannotJoinElementsMultiPlaneError | Can't keep elements joined.
CannotJoinElementsStructural | Can't keep elements joined.
CannotJoinElementsStructuralError | Can't keep elements joined.
CannotJoinElementsWarn | Can't keep elements joined.
CannotJoinRoof | The roof cannot be joined.
CannotJoinRoofError | The roof cannot be joined.
CannotKeepJoined | Can't keep elements joined.
CannotKeepTrussJoined | Can't keep the highlighted [Element]s joined.
CannotKeepWallJoinToRoof | Can't keep wall and [target] joined
CannotKeepWallJoinToRoofError | Can't keep wall and [target] joined
ElementWillBeDetachedFromPlane | Element will be detached from its associated plane
FootingWillMoveToBottom | An attached Structural Foundation will be moved to the bottom of the Column.
JoiningDisjoint | Highlighted elements are joined but do not intersect.
JoiningDisjointWarn | Highlighted elements are joined but do not intersect.
StructGroupMemberWillDetachFromGrid | A structural element will be detached from grid(s) due to inconsistent group membership.

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotCope Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotCope Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't apply Coping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCope { get; }
Visual Basic
Public Shared ReadOnly Property CannotCope As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCope {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotCutJoinedGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotCutJoinedGeometry Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Element could not be cut by joined element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutJoinedGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutJoinedGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutJoinedGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinDesignOptions Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinDesignOptions Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
An element cannot join to an element in a secondary Design Option unless it is in the same secondary Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinDesignOptions { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinDesignOptions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinDesignOptions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElements Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElements Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElements { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsError Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsMultiPlaneError Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsMultiPlaneError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsMultiPlaneError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsMultiPlaneError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsMultiPlaneError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsStructural Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsStructural Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructural { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsStructural As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsStructuralError Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsStructuralError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsStructuralError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsStructuralError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsStructuralError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinElementsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinElementsWarn Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinElementsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinElementsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinElementsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinRoof Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotJoinRoofError Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotJoinRoofError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
The roof cannot be joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotJoinRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotJoinRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotJoinRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepJoined Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepJoined Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepJoined { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepTrussJoined Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepTrussJoined Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep the highlighted [Element]s joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepTrussJoined { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepTrussJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepTrussJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepWallJoinToRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepWallJoinToRoof Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepWallJoinToRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


CannotKeepWallJoinToRoofError Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..CannotKeepWallJoinToRoofError Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Can't keep wall and [target] joined

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotKeepWallJoinToRoofError { get; }
Visual Basic
Public Shared ReadOnly Property CannotKeepWallJoinToRoofError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotKeepWallJoinToRoofError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


ElementWillBeDetachedFromPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..ElementWillBeDetachedFromPlane Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Element will be detached from its associated plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementWillBeDetachedFromPlane { get; }
Visual Basic
Public Shared ReadOnly Property ElementWillBeDetachedFromPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementWillBeDetachedFromPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


FootingWillMoveToBottom Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..FootingWillMoveToBottom Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
An attached Structural Foundation will be moved to the bottom of the Column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FootingWillMoveToBottom { get; }
Visual Basic
Public Shared ReadOnly Property FootingWillMoveToBottom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FootingWillMoveToBottom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


JoiningDisjoint Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..JoiningDisjoint Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JoiningDisjoint { get; }
Visual Basic
Public Shared ReadOnly Property JoiningDisjoint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjoint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


JoiningDisjointWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..JoiningDisjointWarn Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
Highlighted elements are joined but do not intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JoiningDisjointWarn { get; }
Visual Basic
Public Shared ReadOnly Property JoiningDisjointWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoiningDisjointWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


StructGroupMemberWillDetachFromGrid Property

[image]

Revit 2013 API
BuiltInFailures..::..JoinElementsFailures..::..StructGroupMemberWillDetachFromGrid Property
BuiltInFailures..::..JoinElementsFailures Class See Also Send Feedback
A structural element will be detached from grid(s) due to inconsistent group membership.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructGroupMemberWillDetachFromGrid { get; }
Visual Basic
Public Shared ReadOnly Property StructGroupMemberWillDetachFromGrid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructGroupMemberWillDetachFromGrid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..JoinElementsFailures Class


BuiltInFailures.KeynoteFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about KeynoteFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class KeynoteFailures
Visual Basic
Public NotInheritable Class KeynoteFailures
Visual C++
public ref class KeynoteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..KeynoteFailures

See Also

BuiltInFailures..::..KeynoteFailures Members


BuiltInFailures.KeynoteFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures Members
BuiltInFailures..::..KeynoteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..KeynoteFailures type exposes the following members.

Properties

Name | Description
CyclicalKeynote | A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'
DuplicateKeynote | Duplicate key value '[Value]', text: '[Text]'
MissingKeynote | No parent keynote '[Value]' for '[Value]'
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
WrongKeynote | Cannot understand keynote line '[Number]'

See Also

BuiltInFailures..::..KeynoteFailures Class


BuiltInFailures.KeynoteFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures Properties
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback

The BuiltInFailures..::..KeynoteFailures type exposes the following members.

Properties

Name | Description
CyclicalKeynote | A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'
DuplicateKeynote | Duplicate key value '[Value]', text: '[Text]'
MissingKeynote | No parent keynote '[Value]' for '[Value]'
MissKeynoteParameter | No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.
MissKeynotingSystem | No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.
NotAssociatedKeynoteParameter | Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.
WrongKeynote | Cannot understand keynote line '[Number]'

See Also

BuiltInFailures..::..KeynoteFailures Class


CyclicalKeynote Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..CyclicalKeynote Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
A sub-keynote '[Value]' specified as parent for its current ancestor '[Value]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CyclicalKeynote { get; }
Visual Basic
Public Shared ReadOnly Property CyclicalKeynote As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CyclicalKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


DuplicateKeynote Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..DuplicateKeynote Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
Duplicate key value '[Value]', text: '[Text]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateKeynote { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateKeynote As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


MissingKeynote Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..MissingKeynote Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
No parent keynote '[Value]' for '[Value]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissingKeynote { get; }
Visual Basic
Public Shared ReadOnly Property MissingKeynote As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


MissKeynoteParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..MissKeynoteParameter Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
No Keynote Parameter.\nTo resolve, select key value parameter in keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissKeynoteParameter { get; }
Visual Basic
Public Shared ReadOnly Property MissKeynoteParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


MissKeynotingSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..MissKeynotingSystem Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
No Keynoting System associated with Tag Family.\nTo resolve, select keynoting system for the tag family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissKeynotingSystem { get; }
Visual Basic
Public Shared ReadOnly Property MissKeynotingSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissKeynotingSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


NotAssociatedKeynoteParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..NotAssociatedKeynoteParameter Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
Current tag keynoting system uses key value parameter that is not associated with this element category.\nTo resolve, associate parameter with category or change keynoting system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotAssociatedKeynoteParameter { get; }
Visual Basic
Public Shared ReadOnly Property NotAssociatedKeynoteParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotAssociatedKeynoteParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


WrongKeynote Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteFailures..::..WrongKeynote Property
BuiltInFailures..::..KeynoteFailures Class See Also Send Feedback
Cannot understand keynote line '[Number]'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongKeynote { get; }
Visual Basic
Public Shared ReadOnly Property WrongKeynote As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongKeynote {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteFailures Class


BuiltInFailures.KeynoteTagFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteTagFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class KeynoteTagFailures
Visual Basic
Public NotInheritable Class KeynoteTagFailures
Visual C++
public ref class KeynoteTagFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..KeynoteTagFailures

See Also

BuiltInFailures..::..KeynoteTagFailures Members


BuiltInFailures.KeynoteTagFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..KeynoteTagFailures Members
BuiltInFailures..::..KeynoteTagFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..KeynoteTagFailures type exposes the following members.

Properties

Name | Description
KeynoteOnLinkWithDifferentKeynoteFile | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
NoKeynoteAssignedToLinkedElement | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

See Also

BuiltInFailures..::..KeynoteTagFailures Class


BuiltInFailures.KeynoteTagFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..KeynoteTagFailures Properties
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback

The BuiltInFailures..::..KeynoteTagFailures type exposes the following members.

Properties

Name | Description
KeynoteOnLinkWithDifferentKeynoteFile | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.
NoKeynoteAssignedToLinkedElement | The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

See Also

BuiltInFailures..::..KeynoteTagFailures Class


KeynoteOnLinkWithDifferentKeynoteFile Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteTagFailures..::..KeynoteOnLinkWithDifferentKeynoteFile Property
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback
The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId KeynoteOnLinkWithDifferentKeynoteFile { get; }
Visual Basic
Public Shared ReadOnly Property KeynoteOnLinkWithDifferentKeynoteFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ KeynoteOnLinkWithDifferentKeynoteFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteTagFailures Class


NoKeynoteAssignedToLinkedElement Property

[image]

Revit 2013 API
BuiltInFailures..::..KeynoteTagFailures..::..NoKeynoteAssignedToLinkedElement Property
BuiltInFailures..::..KeynoteTagFailures Class See Also Send Feedback
The parameters of the keynote tag are empty because the keynoted linked element uses a different keynote file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoKeynoteAssignedToLinkedElement { get; }
Visual Basic
Public Shared ReadOnly Property NoKeynoteAssignedToLinkedElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoKeynoteAssignedToLinkedElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..KeynoteTagFailures Class


BuiltInFailures.LegendFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..LegendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class LegendFailures
Visual Basic
Public NotInheritable Class LegendFailures
Visual C++
public ref class LegendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LegendFailures

See Also

BuiltInFailures..::..LegendFailures Members


BuiltInFailures.LegendFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..LegendFailures Members
BuiltInFailures..::..LegendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::..LegendFailures Class


BuiltInFailures.LegendFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..LegendFailures Properties
BuiltInFailures..::..LegendFailures Class See Also Send Feedback

The BuiltInFailures..::..LegendFailures type exposes the following members.

Properties

Name | Description
LegendComponentBadViewType | Legend Components may only be placed in Legends
LegendComponentNotVisible | The component you have selected is not visible in the selected view.

See Also

BuiltInFailures..::..LegendFailures Class


LegendComponentBadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..LegendFailures..::..LegendComponentBadViewType Property
BuiltInFailures..::..LegendFailures Class See Also Send Feedback
Legend Components may only be placed in Legends

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LegendComponentBadViewType { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentBadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LegendComponentBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LegendFailures Class


LegendComponentNotVisible Property

[image]

Revit 2013 API
BuiltInFailures..::..LegendFailures..::..LegendComponentNotVisible Property
BuiltInFailures..::..LegendFailures Class See Also Send Feedback
The component you have selected is not visible in the selected view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LegendComponentNotVisible { get; }
Visual Basic
Public Shared ReadOnly Property LegendComponentNotVisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LegendComponentNotVisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LegendFailures Class


BuiltInFailures.LevelFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class LevelFailures
Visual Basic
Public NotInheritable Class LevelFailures
Visual C++
public ref class LevelFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LevelFailures

See Also

BuiltInFailures..::..LevelFailures Members


BuiltInFailures.LevelFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..LevelFailures Members
BuiltInFailures..::..LevelFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

See Also

BuiltInFailures..::..LevelFailures Class


BuiltInFailures.LevelFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..LevelFailures Properties
BuiltInFailures..::..LevelFailures Class See Also Send Feedback

The BuiltInFailures..::..LevelFailures type exposes the following members.

Properties

Name | Description
NoLevelsLeft | There are no levels or plan views remaining in the project.
NoLevelsLeftReloading | As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.
StoryAboveDeleted | The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.
StoryAboveMoved | The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.
StoryAboveNonStoryLevel | The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

See Also

BuiltInFailures..::..LevelFailures Class


NoLevelsLeft Property

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures..::..NoLevelsLeft Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
There are no levels or plan views remaining in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLevelsLeft { get; }
Visual Basic
Public Shared ReadOnly Property NoLevelsLeft As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeft {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


NoLevelsLeftReloading Property

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures..::..NoLevelsLeftReloading Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
As a result of Reloading Latest, there are no Levels left. Create a new Level, and then Reload Latest again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLevelsLeftReloading { get; }
Visual Basic
Public Shared ReadOnly Property NoLevelsLeftReloading As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLevelsLeftReloading {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures..::..StoryAboveDeleted Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels is being deleted. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StoryAboveDeleted { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveMoved Property

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures..::..StoryAboveMoved Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels has moved below these levels. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StoryAboveMoved { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveMoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveMoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


StoryAboveNonStoryLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..LevelFailures..::..StoryAboveNonStoryLevel Property
BuiltInFailures..::..LevelFailures Class See Also Send Feedback
The level set as the Story Above for these levels is no longer a story level. This change will cause these levels to revert to the default Story Above.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StoryAboveNonStoryLevel { get; }
Visual Basic
Public Shared ReadOnly Property StoryAboveNonStoryLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StoryAboveNonStoryLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LevelFailures Class


BuiltInFailures.LinkFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LinkFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class LinkFailures
Visual Basic
Public NotInheritable Class LinkFailures
Visual C++
public ref class LinkFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LinkFailures

See Also

BuiltInFailures..::..LinkFailures Members


BuiltInFailures.LinkFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..LinkFailures Members
BuiltInFailures..::..LinkFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LinkFailures type exposes the following members.

Properties

Name | Description
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::..LinkFailures Class


BuiltInFailures.LinkFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..LinkFailures Properties
BuiltInFailures..::..LinkFailures Class See Also Send Feedback

The BuiltInFailures..::..LinkFailures type exposes the following members.

Properties

Name | Description
CannotPublishSharedCoordinatesToMirroredNonRevitLinks | Shared coordinates cannot be published to mirrored, non Revit, links.
CannotReloadFile | Can't reload file.
CannotUnlinkFile | Can't unlink file.
DataDictionaryDifferentInLink | Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.
DeleteLinkSymbolPrompt | All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.
LinkedFileOpenInOtherDoc | Linked file cannot be reloaded because it is loaded into another open document.
LinkInstanceNeedsReconcile | Instance of linked .rvt file needs Coordination Review
ModifyingLinkedFile | Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.
MultipleLinks | Can't complete operation. Linked Files have the same name.
NoConstraintsToLinks1 | Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.
SourceFileDrivenByOtherTarget | Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.
WatchedLinkMoved | Monitored Link moved.

See Also

BuiltInFailures..::..LinkFailures Class


CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..CannotPublishSharedCoordinatesToMirroredNonRevitLinks Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Shared coordinates cannot be published to mirrored, non Revit, links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPublishSharedCoordinatesToMirroredNonRevitLinks { get; }
Visual Basic
Public Shared ReadOnly Property CannotPublishSharedCoordinatesToMirroredNonRevitLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPublishSharedCoordinatesToMirroredNonRevitLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotReloadFile Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..CannotReloadFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't reload file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotReloadFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotReloadFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotReloadFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


CannotUnlinkFile Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..CannotUnlinkFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't unlink file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUnlinkFile { get; }
Visual Basic
Public Shared ReadOnly Property CannotUnlinkFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUnlinkFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


DataDictionaryDifferentInLink Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..DataDictionaryDifferentInLink Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Linked file [Name] was last saved in a previous version of Revit. Changes to it cannot be saved until it is upgraded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DataDictionaryDifferentInLink { get; }
Visual Basic
Public Shared ReadOnly Property DataDictionaryDifferentInLink As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DataDictionaryDifferentInLink {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


DeleteLinkSymbolPrompt Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..DeleteLinkSymbolPrompt Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
All instances of Linked Model '[Name]' have been deleted, but the file itself is still loaded. Remove the Linked File using Manage Links dialog to save memory unless you are going to reuse it in this project. Removing the Link cannot be undone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeleteLinkSymbolPrompt { get; }
Visual Basic
Public Shared ReadOnly Property DeleteLinkSymbolPrompt As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeleteLinkSymbolPrompt {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


LinkedFileOpenInOtherDoc Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..LinkedFileOpenInOtherDoc Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Linked file cannot be reloaded because it is loaded into another open document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinkedFileOpenInOtherDoc { get; }
Visual Basic
Public Shared ReadOnly Property LinkedFileOpenInOtherDoc As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinkedFileOpenInOtherDoc {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


LinkInstanceNeedsReconcile Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..LinkInstanceNeedsReconcile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Instance of linked .rvt file needs Coordination Review

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinkInstanceNeedsReconcile { get; }
Visual Basic
Public Shared ReadOnly Property LinkInstanceNeedsReconcile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinkInstanceNeedsReconcile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


ModifyingLinkedFile Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..ModifyingLinkedFile Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Shared Locations in the Linked Model '[Name]' have been modified, but not saved back to the Linked File. Upon reopening, instances of the Linked Model will return to their last Saved Positions. You can Save the Linked Model later via the Manage Links dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingLinkedFile { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingLinkedFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingLinkedFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


MultipleLinks Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..MultipleLinks Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Can't complete operation. Linked Files have the same name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleLinks { get; }
Visual Basic
Public Shared ReadOnly Property MultipleLinks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleLinks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


NoConstraintsToLinks1 Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..NoConstraintsToLinks1 Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Constraints may not be created to linked instances using Shared Locations. Constraints will be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoConstraintsToLinks1 { get; }
Visual Basic
Public Shared ReadOnly Property NoConstraintsToLinks1 As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoConstraintsToLinks1 {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


SourceFileDrivenByOtherTarget Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..SourceFileDrivenByOtherTarget Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Linked Model's Shared Coordinates have been modified via another host model in this session. In order to be able to change the Linked File via the active host model, Save and open it again in a new session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SourceFileDrivenByOtherTarget { get; }
Visual Basic
Public Shared ReadOnly Property SourceFileDrivenByOtherTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SourceFileDrivenByOtherTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


WatchedLinkMoved Property

[image]

Revit 2013 API
BuiltInFailures..::..LinkFailures..::..WatchedLinkMoved Property
BuiltInFailures..::..LinkFailures Class See Also Send Feedback
Monitored Link moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WatchedLinkMoved { get; }
Visual Basic
Public Shared ReadOnly Property WatchedLinkMoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WatchedLinkMoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LinkFailures Class


BuiltInFailures.LoadFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Load.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class LoadFailures
Visual Basic
Public NotInheritable Class LoadFailures
Visual C++
public ref class LoadFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LoadFailures

See Also

BuiltInFailures..::..LoadFailures Members


BuiltInFailures.LoadFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..LoadFailures Members
BuiltInFailures..::..LoadFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotPlaceBoundaryConditions | Can't find a host for Boundary Conditions
CannotPlaceBoundaryConditionsWarn | Can't find a host for Boundary Conditions
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.

See Also

BuiltInFailures..::..LoadFailures Class


BuiltInFailures.LoadFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..LoadFailures Properties
BuiltInFailures..::..LoadFailures Class See Also Send Feedback

The BuiltInFailures..::..LoadFailures type exposes the following members.

Properties

Name | Description
CannotMirrorBoundaryCondition | Can't mirror Boundary Conditions
CannotMirrorHostedLoad | Can't mirror Load based on the Host Element.
CannotMirrorLoad | Can't mirror Load because mirror plane is not perpendicular to sketch plane.
CannotPlaceBoundaryConditions | Can't find a host for Boundary Conditions
CannotPlaceBoundaryConditionsWarn | Can't find a host for Boundary Conditions
CannotRotateLoad | Can't rotate Load because rotation axis is not perpendicular to sketch plane.
HostChangeDisallowsLoadOrBoundaryConditions | Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.
LineLoadAllZero | Line Load can't have all force components and moment components to be zero.
PointLoadAllZero | Point Load can't have all force components and moment components to be zero.

See Also

BuiltInFailures..::..LoadFailures Class


CannotMirrorBoundaryCondition Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotMirrorBoundaryCondition Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't mirror Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorBoundaryCondition { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorBoundaryCondition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorBoundaryCondition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotMirrorHostedLoad Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotMirrorHostedLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't mirror Load based on the Host Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorHostedLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorHostedLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorHostedLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotMirrorLoad Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotMirrorLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't mirror Load because mirror plane is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotPlaceBoundaryConditions Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotPlaceBoundaryConditions Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't find a host for Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBoundaryConditions { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBoundaryConditions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotPlaceBoundaryConditionsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotPlaceBoundaryConditionsWarn Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't find a host for Boundary Conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBoundaryConditionsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBoundaryConditionsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBoundaryConditionsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


CannotRotateLoad Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..CannotRotateLoad Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Can't rotate Load because rotation axis is not perpendicular to sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRotateLoad { get; }
Visual Basic
Public Shared ReadOnly Property CannotRotateLoad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRotateLoad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


HostChangeDisallowsLoadOrBoundaryConditions Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..HostChangeDisallowsLoadOrBoundaryConditions Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Some Hosted Loads or BoundaryConditions lost their References. They will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostChangeDisallowsLoadOrBoundaryConditions { get; }
Visual Basic
Public Shared ReadOnly Property HostChangeDisallowsLoadOrBoundaryConditions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostChangeDisallowsLoadOrBoundaryConditions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


LineLoadAllZero Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..LineLoadAllZero Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Line Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LineLoadAllZero { get; }
Visual Basic
Public Shared ReadOnly Property LineLoadAllZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LineLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


PointLoadAllZero Property

[image]

Revit 2013 API
BuiltInFailures..::..LoadFailures..::..PointLoadAllZero Property
BuiltInFailures..::..LoadFailures Class See Also Send Feedback
Point Load can't have all force components and moment components to be zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PointLoadAllZero { get; }
Visual Basic
Public Shared ReadOnly Property PointLoadAllZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointLoadAllZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LoadFailures Class


BuiltInFailures.LooseDimensionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about LooseDimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class LooseDimensionFailures
Visual Basic
Public NotInheritable Class LooseDimensionFailures
Visual C++
public ref class LooseDimensionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..LooseDimensionFailures

See Also

BuiltInFailures..::..LooseDimensionFailures Members


BuiltInFailures.LooseDimensionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures Members
BuiltInFailures..::..LooseDimensionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::..LooseDimensionFailures Class


BuiltInFailures.LooseDimensionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures Properties
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback

The BuiltInFailures..::..LooseDimensionFailures type exposes the following members.

Properties

Name | Description
LooseCurtainWallData | Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.
LooseDimensionsForCurtainWall | Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.
LooseFaceSplitsForCurtainWall | Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.
LooseInsertsForCurtainWall | Switching element type to Curtain element. All inserts in the element will be deleted.
LooseWallsweepsForCurtainWall | Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseCurtainWallData Property

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseCurtainWallData Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to a non-Curtain element Family type. All data about Mullions, Grid Lines, and design units for the Curtain element will be lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseCurtainWallData { get; }
Visual Basic
Public Shared ReadOnly Property LooseCurtainWallData As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseCurtainWallData {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseDimensionsForCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseDimensionsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching wall type to Family Curtain Wall. All Dimension References to the side faces of the Wall will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseDimensionsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseDimensionsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseDimensionsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseFaceSplitsForCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseFaceSplitsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain Family. All Split Face Regions in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseFaceSplitsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseFaceSplitsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseFaceSplitsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseInsertsForCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseInsertsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain element. All inserts in the element will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseInsertsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseInsertsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseInsertsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


LooseWallsweepsForCurtainWall Property

[image]

Revit 2013 API
BuiltInFailures..::..LooseDimensionFailures..::..LooseWallsweepsForCurtainWall Property
BuiltInFailures..::..LooseDimensionFailures Class See Also Send Feedback
Switching element type to Curtain Family. All Wall Sweeps or Reveals hosted by this instance will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LooseWallsweepsForCurtainWall { get; }
Visual Basic
Public Shared ReadOnly Property LooseWallsweepsForCurtainWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LooseWallsweepsForCurtainWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..LooseDimensionFailures Class


BuiltInFailures.MassFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Mass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class MassFailures
Visual Basic
Public NotInheritable Class MassFailures
Visual C++
public ref class MassFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MassFailures

See Also

BuiltInFailures..::..MassFailures Members


BuiltInFailures.MassFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..MassFailures Members
BuiltInFailures..::..MassFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MassFailures type exposes the following members.

Properties

Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

See Also

BuiltInFailures..::..MassFailures Class


BuiltInFailures.MassFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..MassFailures Properties
BuiltInFailures..::..MassFailures Class See Also Send Feedback

The BuiltInFailures..::..MassFailures type exposes the following members.

Properties

Name | Description
AutoGlazingFailed | Failure in Auto-Glazing region computation.
AutoGlazingFailedError | Failure in Auto-Glazing region computation.
BooleanUnionFailed | Failed to merge overlapping solids
CannotIntegrate | In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.
CannotMergeGeometry | The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.
CannotMoveMassing | Can't move whole Massing. Move the elements within the Massing instead.
CreateCoreGeometryFailed | Failed to create core geometries.
DividePerimeterZoneFailed | Failed to divide perimeter zone.
FaceRegionCreationFailed | Failure in face region creation.
FaceSplitFailed | A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.
FloorAreaFaceFailed | Failed to create a Mass Floor.
FloorMightLookWrong | Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.
MultipleMassing | Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.
NoCurtainRoofsInMassing | Massing cannot be created with a curtain roof. Please change the default roof type and try again.
NonOccupiableMassZone | For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.
NoSolidInMass | Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.
OpenAndSolidGeometry | Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.
OpenGeometryOnly | Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.
OverlappingSolids | Found volumetric overlap between solids. They will be merged into one
SketchCurveNotModelable | This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.
SplitFacesByGroundPlaneCrashed | Failed to split face by ground plane.
SplitFacesByGroundPlaneFailed | Failed to split face by ground plane.
SplitOverlappingFacesFailed | Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.
TooManyGeometries | The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.
UpgradedMassingWarning | Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

See Also

BuiltInFailures..::..MassFailures Class


AutoGlazingFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..AutoGlazingFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AutoGlazingFailed { get; }
Visual Basic
Public Shared ReadOnly Property AutoGlazingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


AutoGlazingFailedError Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..AutoGlazingFailedError Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in Auto-Glazing region computation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AutoGlazingFailedError { get; }
Visual Basic
Public Shared ReadOnly Property AutoGlazingFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutoGlazingFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


BooleanUnionFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..BooleanUnionFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to merge overlapping solids

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BooleanUnionFailed { get; }
Visual Basic
Public Shared ReadOnly Property BooleanUnionFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BooleanUnionFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotIntegrate Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..CannotIntegrate Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
In order to restore an element's 'Constrain to Massing' property to 'Dependent', it must be in the main model with the massing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotIntegrate { get; }
Visual Basic
Public Shared ReadOnly Property CannotIntegrate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotIntegrate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotMergeGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..CannotMergeGeometry Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The Mass contains geometry that cannot be combined. Mass Floors, volume, and surface area, won’t be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMergeGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMergeGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMergeGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CannotMoveMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..CannotMoveMassing Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Can't move whole Massing. Move the elements within the Massing instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMoveMassing { get; }
Visual Basic
Public Shared ReadOnly Property CannotMoveMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMoveMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


CreateCoreGeometryFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..CreateCoreGeometryFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to create core geometries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CreateCoreGeometryFailed { get; }
Visual Basic
Public Shared ReadOnly Property CreateCoreGeometryFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreateCoreGeometryFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


DividePerimeterZoneFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..DividePerimeterZoneFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to divide perimeter zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DividePerimeterZoneFailed { get; }
Visual Basic
Public Shared ReadOnly Property DividePerimeterZoneFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DividePerimeterZoneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FaceRegionCreationFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..FaceRegionCreationFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failure in face region creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceRegionCreationFailed { get; }
Visual Basic
Public Shared ReadOnly Property FaceRegionCreationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceRegionCreationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FaceSplitFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..FaceSplitFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
A face of a joined (i.e. one cuts another) mass could not be split into interior and exterior faces. Remove the cut to resolve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSplitFailed { get; }
Visual Basic
Public Shared ReadOnly Property FaceSplitFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceSplitFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FloorAreaFaceFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..FloorAreaFaceFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to create a Mass Floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorAreaFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property FloorAreaFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorAreaFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


FloorMightLookWrong Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..FloorMightLookWrong Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass Floors may appear incorrect since the Mass contains mesh and solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorMightLookWrong { get; }
Visual Basic
Public Shared ReadOnly Property FloorMightLookWrong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorMightLookWrong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


MinSkylightWidthImperial Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..MinSkylightWidthImperial Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..MinSkylightWidthMetric Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


MultipleMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..MultipleMassing Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Can't complete operation. Massing can only exist in one Workset. Change Workset of Massing to match in Local and Central Models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleMassing { get; }
Visual Basic
Public Shared ReadOnly Property MultipleMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


NoCurtainRoofsInMassing Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..NoCurtainRoofsInMassing Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Massing cannot be created with a curtain roof. Please change the default roof type and try again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoCurtainRoofsInMassing { get; }
Visual Basic
Public Shared ReadOnly Property NoCurtainRoofsInMassing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoCurtainRoofsInMassing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


NonOccupiableMassZone Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..NonOccupiableMassZone Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
For mass zone, if the bottom level ref does not intersect, then this zone is going to be "not occupiable" and a warning is posted for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonOccupiableMassZone { get; }
Visual Basic
Public Shared ReadOnly Property NonOccupiableMassZone As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonOccupiableMassZone {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


NoSolidInMass Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..NoSolidInMass Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass contains no solid geometry. Mass Floors, volume, and surface area, won’t be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSolidInMass { get; }
Visual Basic
Public Shared ReadOnly Property NoSolidInMass As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSolidInMass {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OpenAndSolidGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..OpenAndSolidGeometry Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass contains both solid and mesh geometry. Mass Floors, volume, and surface area, may appear incorrect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAndSolidGeometry { get; }
Visual Basic
Public Shared ReadOnly Property OpenAndSolidGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAndSolidGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OpenGeometryOnly Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..OpenGeometryOnly Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Mass contains only mesh geometry, which can’t be used to compute Mass Floors, volume, or surface area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenGeometryOnly { get; }
Visual Basic
Public Shared ReadOnly Property OpenGeometryOnly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenGeometryOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


OverlappingSolids Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..OverlappingSolids Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Found volumetric overlap between solids. They will be merged into one

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OverlappingSolids { get; }
Visual Basic
Public Shared ReadOnly Property OverlappingSolids As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverlappingSolids {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SketchCurveNotModelable Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..SketchCurveNotModelable Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
This action cannot be completed. An element created by massing has a sketch line that cannot be modeled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchCurveNotModelable { get; }
Visual Basic
Public Shared ReadOnly Property SketchCurveNotModelable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchCurveNotModelable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SplitFacesByGroundPlaneCrashed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..SplitFacesByGroundPlaneCrashed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneCrashed { get; }
Visual Basic
Public Shared ReadOnly Property SplitFacesByGroundPlaneCrashed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneCrashed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SplitFacesByGroundPlaneFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..SplitFacesByGroundPlaneFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to split face by ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SplitFacesByGroundPlaneFailed { get; }
Visual Basic
Public Shared ReadOnly Property SplitFacesByGroundPlaneFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitFacesByGroundPlaneFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


SplitOverlappingFacesFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..SplitOverlappingFacesFailed Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Failed to resolve all overlaps between faces of the same Mass Energy Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SplitOverlappingFacesFailed { get; }
Visual Basic
Public Shared ReadOnly Property SplitOverlappingFacesFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SplitOverlappingFacesFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


TooManyGeometries Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..TooManyGeometries Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
The geometry in this Mass instance is too complex to take advantage of the capabilities a Mass provides. Please break it down into multiple Mass and family instances that are less complex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyGeometries { get; }
Visual Basic
Public Shared ReadOnly Property TooManyGeometries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyGeometries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


UpgradedMassingWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..MassFailures..::..UpgradedMassingWarning Property
BuiltInFailures..::..MassFailures Class See Also Send Feedback
Your document contained a Massing element which has been upgraded to a Mass instance. Please review the documentation on the new enhanced Mass capabilities to understand the implications of this change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UpgradedMassingWarning { get; }
Visual Basic
Public Shared ReadOnly Property UpgradedMassingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UpgradedMassingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MassFailures Class


BuiltInFailures.MatchlineFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..MatchlineFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Matchline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class MatchlineFailures
Visual Basic
Public NotInheritable Class MatchlineFailures
Visual C++
public ref class MatchlineFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MatchlineFailures

See Also

BuiltInFailures..::..MatchlineFailures Members


BuiltInFailures.MatchlineFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..MatchlineFailures Members
BuiltInFailures..::..MatchlineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::..MatchlineFailures Class


BuiltInFailures.MatchlineFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..MatchlineFailures Properties
BuiltInFailures..::..MatchlineFailures Class See Also Send Feedback

The BuiltInFailures..::..MatchlineFailures type exposes the following members.

Properties

Name | Description
CreationFailed | Matchline top extent should be higher than its bottom.

See Also

BuiltInFailures..::..MatchlineFailures Class


CreationFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MatchlineFailures..::..CreationFailed Property
BuiltInFailures..::..MatchlineFailures Class See Also Send Feedback
Matchline top extent should be higher than its bottom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CreationFailed { get; }
Visual Basic
Public Shared ReadOnly Property CreationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CreationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MatchlineFailures Class


BuiltInFailures.MechanicalFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about HVAC.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class MechanicalFailures
Visual Basic
Public NotInheritable Class MechanicalFailures
Visual C++
public ref class MechanicalFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MechanicalFailures

See Also

BuiltInFailures..::..MechanicalFailures Members


BuiltInFailures.MechanicalFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures Members
BuiltInFailures..::..MechanicalFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MechanicalFailures type exposes the following members.

Properties

Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.

See Also

BuiltInFailures..::..MechanicalFailures Class


BuiltInFailures.MechanicalFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures Properties
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback

The BuiltInFailures..::..MechanicalFailures type exposes the following members.

Properties

Name | Description
InitialEqualFrictionSizingFailed | Initial Equal Friction Sizing failed.
LiningThicknessIsLargeForDiameter | Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).
LiningThicknessIsLargeForHeight | Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).
LiningThicknessIsLargeForWidth | Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).
PanelDoesntMatchCircuitProperties | The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?
TwoPointsSelectedBeforeEdit | Two points have to be selected before existing the edit mode.

See Also

BuiltInFailures..::..MechanicalFailures Class


InitialEqualFrictionSizingFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..InitialEqualFrictionSizingFailed Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Initial Equal Friction Sizing failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InitialEqualFrictionSizingFailed { get; }
Visual Basic
Public Shared ReadOnly Property InitialEqualFrictionSizingFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InitialEqualFrictionSizingFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


LiningThicknessIsLargeForDiameter Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..LiningThicknessIsLargeForDiameter Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Diameter ([Diameter Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForDiameter { get; }
Visual Basic
Public Shared ReadOnly Property LiningThicknessIsLargeForDiameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForDiameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


LiningThicknessIsLargeForHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..LiningThicknessIsLargeForHeight Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Height ([Height Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForHeight { get; }
Visual Basic
Public Shared ReadOnly Property LiningThicknessIsLargeForHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


LiningThicknessIsLargeForWidth Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..LiningThicknessIsLargeForWidth Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Lining Thickness ([Lining Thickness Value]) is too large for current Width ([Width Value]).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LiningThicknessIsLargeForWidth { get; }
Visual Basic
Public Shared ReadOnly Property LiningThicknessIsLargeForWidth As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LiningThicknessIsLargeForWidth {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


PanelDoesntMatchCircuitProperties Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..PanelDoesntMatchCircuitProperties Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
The panel no longer matches the properties for the Circuit. Disconnect the panel from the Circuit?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelDoesntMatchCircuitProperties { get; }
Visual Basic
Public Shared ReadOnly Property PanelDoesntMatchCircuitProperties As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelDoesntMatchCircuitProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


TwoPointsSelectedBeforeEdit Property

[image]

Revit 2013 API
BuiltInFailures..::..MechanicalFailures..::..TwoPointsSelectedBeforeEdit Property
BuiltInFailures..::..MechanicalFailures Class See Also Send Feedback
Two points have to be selected before existing the edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TwoPointsSelectedBeforeEdit { get; }
Visual Basic
Public Shared ReadOnly Property TwoPointsSelectedBeforeEdit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TwoPointsSelectedBeforeEdit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MechanicalFailures Class


BuiltInFailures.MirrorFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..MirrorFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Mirror.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class MirrorFailures
Visual Basic
Public NotInheritable Class MirrorFailures
Visual C++
public ref class MirrorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..MirrorFailures

See Also

BuiltInFailures..::..MirrorFailures Members


BuiltInFailures.MirrorFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..MirrorFailures Members
BuiltInFailures..::..MirrorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.

See Also

BuiltInFailures..::..MirrorFailures Class


BuiltInFailures.MirrorFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..MirrorFailures Properties
BuiltInFailures..::..MirrorFailures Class See Also Send Feedback

The BuiltInFailures..::..MirrorFailures type exposes the following members.

Properties

Name | Description
BadMirror | Can't mirror element into this position.

See Also

BuiltInFailures..::..MirrorFailures Class


BadMirror Property

[image]

Revit 2013 API
BuiltInFailures..::..MirrorFailures..::..BadMirror Property
BuiltInFailures..::..MirrorFailures Class See Also Send Feedback
Can't mirror element into this position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadMirror { get; }
Visual Basic
Public Shared ReadOnly Property BadMirror As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..MirrorFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class OffsetFacesCellLegacyFailures
Visual Basic
Public NotInheritable Class OffsetFacesCellLegacyFailures
Visual C++
public ref class OffsetFacesCellLegacyFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OffsetFacesCellLegacyFailures

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Members


BuiltInFailures.OffsetFacesCellLegacyFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Members
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OffsetFacesCellLegacyFailures type exposes the following members.

Properties

Name | Description
OffsetFaceFailed |

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


BuiltInFailures.OffsetFacesCellLegacyFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures Properties
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class See Also Send Feedback

The BuiltInFailures..::..OffsetFacesCellLegacyFailures type exposes the following members.

Properties

Name | Description
OffsetFaceFailed |

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


OffsetFaceFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..OffsetFacesCellLegacyFailures..::..OffsetFaceFailed Property
BuiltInFailures..::..OffsetFacesCellLegacyFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OffsetFaceFailed { get; }
Visual Basic
Public Shared ReadOnly Property OffsetFaceFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OffsetFaceFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OffsetFacesCellLegacyFailures Class


BuiltInFailures.OpeningFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class OpeningFailures
Visual Basic
Public NotInheritable Class OpeningFailures
Visual C++
public ref class OpeningFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OpeningFailures

See Also

BuiltInFailures..::..OpeningFailures Members


BuiltInFailures.OpeningFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures Members
BuiltInFailures..::..OpeningFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OpeningFailures type exposes the following members.

Properties

Name | Description
CannotMakeCutoutCorruption | Can't make cut-out.
CannotMakeCutoutError | Can't make cut-out.
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::..OpeningFailures Class


BuiltInFailures.OpeningFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures Properties
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback

The BuiltInFailures..::..OpeningFailures type exposes the following members.

Properties

Name | Description
CannotMakeCutoutCorruption | Can't make cut-out.
CannotMakeCutoutError | Can't make cut-out.
HostForCutHasNoGeometry | Host can't be cut because it has no geometry.
HostForCutHasNoGeometryWarn | Host can't be cut because it has no geometry.
InvalidComplexCut | The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
OpeningCutAll | Opening completely removes its host
OpeningDoesnotCutHost | Opening does not cut its host.
OpeningDoesnotCutHostDelete | Opening does not cut its host.
OpeningNegativeHeight | The top of the Opening is lower than the bottom of the Opening or coincident with it.
OpeningPartiallyCutsHost | Opening partially cuts its host.
OpeningRectDoesnotCutHost | Rectangular opening doesn't cut its host.
OpeningRemovesHost | Opening completely removes its host.
OpenStringerConflictNosing | Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
PropertyNotClosed | Property lines do not form a closed loop. Area will not be computed.

See Also

BuiltInFailures..::..OpeningFailures Class


CannotMakeCutoutCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..CannotMakeCutoutCorruption Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeCutoutCorruption { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeCutoutCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeCutoutCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


CannotMakeCutoutError Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..CannotMakeCutoutError Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Can't make cut-out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeCutoutError { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeCutoutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeCutoutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


HostForCutHasNoGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..HostForCutHasNoGeometry Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometry { get; }
Visual Basic
Public Shared ReadOnly Property HostForCutHasNoGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


HostForCutHasNoGeometryWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..HostForCutHasNoGeometryWarn Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Host can't be cut because it has no geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostForCutHasNoGeometryWarn { get; }
Visual Basic
Public Shared ReadOnly Property HostForCutHasNoGeometryWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostForCutHasNoGeometryWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


InvalidComplexCut Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..InvalidComplexCut Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidComplexCut { get; }
Visual Basic
Public Shared ReadOnly Property InvalidComplexCut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidComplexCut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningCutAll Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningCutAll Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening completely removes its host

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningCutAll { get; }
Visual Basic
Public Shared ReadOnly Property OpeningCutAll As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningCutAll {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningDoesnotCutHost Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningDoesnotCutHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningDoesnotCutHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningDoesnotCutHostDelete Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningDoesnotCutHostDelete Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening does not cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningDoesnotCutHostDelete { get; }
Visual Basic
Public Shared ReadOnly Property OpeningDoesnotCutHostDelete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningDoesnotCutHostDelete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningNegativeHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningNegativeHeight Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
The top of the Opening is lower than the bottom of the Opening or coincident with it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningNegativeHeight { get; }
Visual Basic
Public Shared ReadOnly Property OpeningNegativeHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningPartiallyCutsHost Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningPartiallyCutsHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening partially cuts its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningPartiallyCutsHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningPartiallyCutsHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningPartiallyCutsHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningRectDoesnotCutHost Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningRectDoesnotCutHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Rectangular opening doesn't cut its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningRectDoesnotCutHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningRectDoesnotCutHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningRectDoesnotCutHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpeningRemovesHost Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpeningRemovesHost Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Opening completely removes its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpeningRemovesHost { get; }
Visual Basic
Public Shared ReadOnly Property OpeningRemovesHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpeningRemovesHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


OpenStringerConflictNosing Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..OpenStringerConflictNosing Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenStringerConflictNosing { get; }
Visual Basic
Public Shared ReadOnly Property OpenStringerConflictNosing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenStringerConflictNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


PropertyNotClosed Property

[image]

Revit 2013 API
BuiltInFailures..::..OpeningFailures..::..PropertyNotClosed Property
BuiltInFailures..::..OpeningFailures Class See Also Send Feedback
Property lines do not form a closed loop. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PropertyNotClosed { get; }
Visual Basic
Public Shared ReadOnly Property PropertyNotClosed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PropertyNotClosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OpeningFailures Class


BuiltInFailures.OverlapFailure Class

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailure Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class OverlapFailure
Visual Basic
Public NotInheritable Class OverlapFailure
Visual C++
public ref class OverlapFailure abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OverlapFailure

See Also

BuiltInFailures..::..OverlapFailure Members


BuiltInFailures.OverlapFailure Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..OverlapFailure Members
BuiltInFailures..::..OverlapFailure Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OverlapFailure type exposes the following members.

Properties

Name | Description
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

See Also

BuiltInFailures..::..OverlapFailure Class


BuiltInFailures.OverlapFailure Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..OverlapFailure Properties
BuiltInFailures..::..OverlapFailure Class See Also Send Feedback

The BuiltInFailures..::..OverlapFailure type exposes the following members.

Properties

Name | Description
OverlappingElementsTest | There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

See Also

BuiltInFailures..::..OverlapFailure Class


OverlappingElementsTest Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailure..::..OverlappingElementsTest Property
BuiltInFailures..::..OverlapFailure Class See Also Send Feedback
There are overlapping structural framing elements of the same type in the project found by Dynamic Update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OverlappingElementsTest { get; }
Visual Basic
Public Shared ReadOnly Property OverlappingElementsTest As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OverlappingElementsTest {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailure Class


BuiltInFailures.OverlapFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures detected by overlap check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class OverlapFailures
Visual Basic
Public NotInheritable Class OverlapFailures
Visual C++
public ref class OverlapFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..OverlapFailures

See Also

BuiltInFailures..::..OverlapFailures Members


BuiltInFailures.OverlapFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures Members
BuiltInFailures..::..OverlapFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
LevelsOverlap | Highlighted levels overlap.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::..OverlapFailures Class


BuiltInFailures.OverlapFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures Properties
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback

The BuiltInFailures..::..OverlapFailures type exposes the following members.

Properties

Name | Description
AreaBoundaryLinesOverlap | Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.
CurvesOverlap | Highlighted lines overlap. Lines may not form closed loops.
DivisionSketchOverlap | Curves in the sketch of the Division overlap.
DuplicateInstances | There are identical instances in the same place. This will result in double counting in schedules.
DuplicatePoints | There are identical points in the same place. Lines created from points may not work as expected.
DuplicateRebar | There are identical rebar in the same place. This will result in double counting in schedules.
LevelsOverlap | Highlighted levels overlap.
RoomSeparationLinesOverlap | Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.
SpaceSeparationLinesOverlap | Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.
WallAreaBoundaryOverlap | Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.
WallRoomSeparationOverlap | A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.
WallsOverlap | Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.
WallSpaceSeparationOverlap | A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

See Also

BuiltInFailures..::..OverlapFailures Class


AreaBoundaryLinesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..AreaBoundaryLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted area boundary lines overlap. Color fills, area tags, and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaBoundaryLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property AreaBoundaryLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaBoundaryLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


CurvesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..CurvesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted lines overlap. Lines may not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property CurvesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurvesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DivisionSketchOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..DivisionSketchOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Curves in the sketch of the Division overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DivisionSketchOverlap { get; }
Visual Basic
Public Shared ReadOnly Property DivisionSketchOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DivisionSketchOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicateInstances Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..DuplicateInstances Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical instances in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateInstances { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicatePoints Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..DuplicatePoints Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical points in the same place. Lines created from points may not work as expected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicatePoints { get; }
Visual Basic
Public Shared ReadOnly Property DuplicatePoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicatePoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


DuplicateRebar Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..DuplicateRebar Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
There are identical rebar in the same place. This will result in double counting in schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateRebar { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


LevelsOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..LevelsOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted levels overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LevelsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property LevelsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LevelsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


RoomSeparationLinesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..RoomSeparationLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted room separation lines overlap. One of them may be ignored when Revit finds room boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomSeparationLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property RoomSeparationLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


SpaceSeparationLinesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..SpaceSeparationLinesOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted space separation lines overlap. One of them may be ignored when Revit finds space boundaries. Delete one of the lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpaceSeparationLinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property SpaceSeparationLinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpaceSeparationLinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallAreaBoundaryOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..WallAreaBoundaryOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Wall and area boundary line overlap. Color fills, area tags and areas may not behave correctly.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallAreaBoundaryOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallAreaBoundaryOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallAreaBoundaryOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallRoomSeparationOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..WallRoomSeparationOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
A wall and a room separation line overlap. One of them may be ignored when Revit finds room boundaries. Shorten or delete the room separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallRoomSeparationOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallRoomSeparationOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallRoomSeparationOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallsOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..WallsOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
Highlighted walls overlap. One of them may be ignored when Revit finds room boundaries. Use Cut Geometry to embed one wall within the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


WallSpaceSeparationOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..OverlapFailures..::..WallSpaceSeparationOverlap Property
BuiltInFailures..::..OverlapFailures Class See Also Send Feedback
A wall and a space separation line overlap. One of them may be ignored when Revit finds space boundaries. Shorten or delete the space separation line to remove the overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallSpaceSeparationOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallSpaceSeparationOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallSpaceSeparationOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..OverlapFailures Class


BuiltInFailures.PartMakerMethodForFamilyInstanceFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PartMakerMethodForFamilyInstanceFailures
Visual Basic
Public NotInheritable Class PartMakerMethodForFamilyInstanceFailures
Visual C++
public ref class PartMakerMethodForFamilyInstanceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures

See Also

BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Members


BuiltInFailures.PartMakerMethodForFamilyInstanceFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Members
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures type exposes the following members.

Properties

Name | Description
PartsCannotBeCreatedFromInvalidFamInstGeom | Post failure when attempts to create parts from family instance that has invalid geometry.

See Also

BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class


BuiltInFailures.PartMakerMethodForFamilyInstanceFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Properties
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures type exposes the following members.

Properties

Name | Description
PartsCannotBeCreatedFromInvalidFamInstGeom | Post failure when attempts to create parts from family instance that has invalid geometry.

See Also

BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class


PartsCannotBeCreatedFromInvalidFamInstGeom Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures..::..PartsCannotBeCreatedFromInvalidFamInstGeom Property
BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class See Also Send Feedback
Post failure when attempts to create parts from family instance that has invalid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartsCannotBeCreatedFromInvalidFamInstGeom { get; }
Visual Basic
Public Shared ReadOnly Property PartsCannotBeCreatedFromInvalidFamInstGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartsCannotBeCreatedFromInvalidFamInstGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForFamilyInstanceFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PartMakerMethodForMergePartFailures
Visual Basic
Public NotInheritable Class PartMakerMethodForMergePartFailures
Visual C++
public ref class PartMakerMethodForMergePartFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PartMakerMethodForMergePartFailures

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Members


BuiltInFailures.PartMakerMethodForMergePartFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Members
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PartMakerMethodForMergePartFailures type exposes the following members.

Properties

Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForMergePartFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures Properties
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForMergePartFailures type exposes the following members.

Properties

Name | Description
MergedPartHasDisConnectedGeometries | A merged part geometry has dis-connected components.
NeedTwoPartsToMerge | Attempt to merge fewer than two parts. There must be at least two. No part will be produced.
PartNotIncludedInMerge | This part is not geometrically coincident with another part of the same material. No merge possible.
PartsCannotBeMerged | This PartMaker refers to parts which cannot be merged.
UnableToIncludePartInMerge | Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


MergedPartHasDisConnectedGeometries Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..MergedPartHasDisConnectedGeometries Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
A merged part geometry has dis-connected components.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MergedPartHasDisConnectedGeometries { get; }
Visual Basic
Public Shared ReadOnly Property MergedPartHasDisConnectedGeometries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MergedPartHasDisConnectedGeometries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


NeedTwoPartsToMerge Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..NeedTwoPartsToMerge Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
Attempt to merge fewer than two parts. There must be at least two. No part will be produced.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NeedTwoPartsToMerge { get; }
Visual Basic
Public Shared ReadOnly Property NeedTwoPartsToMerge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NeedTwoPartsToMerge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


PartNotIncludedInMerge Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..PartNotIncludedInMerge Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
This part is not geometrically coincident with another part of the same material. No merge possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartNotIncludedInMerge { get; }
Visual Basic
Public Shared ReadOnly Property PartNotIncludedInMerge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotIncludedInMerge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


PartsCannotBeMerged Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..PartsCannotBeMerged Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
This PartMaker refers to parts which cannot be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartsCannotBeMerged { get; }
Visual Basic
Public Shared ReadOnly Property PartsCannotBeMerged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartsCannotBeMerged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


UnableToIncludePartInMerge Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForMergePartFailures..::..UnableToIncludePartInMerge Property
BuiltInFailures..::..PartMakerMethodForMergePartFailures Class See Also Send Feedback
Attempt to merge this Part results in failure of boolean operation. Cannot compute combined geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToIncludePartInMerge { get; }
Visual Basic
Public Shared ReadOnly Property UnableToIncludePartInMerge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToIncludePartInMerge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForMergePartFailures Class


BuiltInFailures.PartMakerMethodForWallFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForWallFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PartMakerMethodForWallFailures
Visual Basic
Public NotInheritable Class PartMakerMethodForWallFailures
Visual C++
public ref class PartMakerMethodForWallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PartMakerMethodForWallFailures

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Members


BuiltInFailures.PartMakerMethodForWallFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForWallFailures Members
BuiltInFailures..::..PartMakerMethodForWallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PartMakerMethodForWallFailures type exposes the following members.

Properties

Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


BuiltInFailures.PartMakerMethodForWallFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForWallFailures Properties
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback

The BuiltInFailures..::..PartMakerMethodForWallFailures type exposes the following members.

Properties

Name | Description
CouldNotAdjustWallPartsAtJoin | Failed to extend or trim some layer at an end join
CouldNotCreateWallPart | Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


CouldNotAdjustWallPartsAtJoin Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForWallFailures..::..CouldNotAdjustWallPartsAtJoin Property
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback
Failed to extend or trim some layer at an end join

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotAdjustWallPartsAtJoin { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotAdjustWallPartsAtJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotAdjustWallPartsAtJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


CouldNotCreateWallPart Property

[image]

Revit 2013 API
BuiltInFailures..::..PartMakerMethodForWallFailures..::..CouldNotCreateWallPart Property
BuiltInFailures..::..PartMakerMethodForWallFailures Class See Also Send Feedback
Failed to create basic layer geometry. Probably a failure either to create the cutter or to intersect the cutter with the wall geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CouldNotCreateWallPart { get; }
Visual Basic
Public Shared ReadOnly Property CouldNotCreateWallPart As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CouldNotCreateWallPart {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PartMakerMethodForWallFailures Class


BuiltInFailures.PathFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PathFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PathFailures
Visual Basic
Public NotInheritable Class PathFailures
Visual C++
public ref class PathFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PathFailures

See Also

BuiltInFailures..::..PathFailures Members


BuiltInFailures.PathFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PathFailures Members
BuiltInFailures..::..PathFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::..PathFailures Class


BuiltInFailures.PathFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PathFailures Properties
BuiltInFailures..::..PathFailures Class See Also Send Feedback

The BuiltInFailures..::..PathFailures type exposes the following members.

Properties

Name | Description
Path3dRegenError | Picked Path could not be regenerated.

See Also

BuiltInFailures..::..PathFailures Class


Path3dRegenError Property

[image]

Revit 2013 API
BuiltInFailures..::..PathFailures..::..Path3dRegenError Property
BuiltInFailures..::..PathFailures Class See Also Send Feedback
Picked Path could not be regenerated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId Path3dRegenError { get; }
Visual Basic
Public Shared ReadOnly Property Path3dRegenError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Path3dRegenError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PathFailures Class


BuiltInFailures.PerformanceFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PerformanceFailures
Visual Basic
Public NotInheritable Class PerformanceFailures
Visual C++
public ref class PerformanceFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PerformanceFailures

See Also

BuiltInFailures..::..PerformanceFailures Members


BuiltInFailures.PerformanceFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures Members
BuiltInFailures..::..PerformanceFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PerformanceFailures type exposes the following members.

Properties

Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

See Also

BuiltInFailures..::..PerformanceFailures Class


BuiltInFailures.PerformanceFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures Properties
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback

The BuiltInFailures..::..PerformanceFailures type exposes the following members.

Properties

Name | Description
ClippingIsDisabled | View has clipping disabled. It causes view to draw too many elements.
DisjoinedSolidsInInPlaceFamily | In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
DuplicateInstances | There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
FamilyContainsViewSpecificImports | Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
HostHasTooManyInserts | Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
InteriorCategoriesEnabledInLargeView | Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
LargeFamilyFile | Family occupies XXX kilobytes of memory. Consider simplification of the family.
ManyElementInFamily | Family definition contains too many elements. Consider simplification of the family.
ManyUnusedNestedFamilies | Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
MultipleLoopsInSketch | Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
TooLargeSketch | Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
TooManyAreaBoundaryLinesFound | There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
TooManyElementsInSketch | Sketch of <element> contains too many objects - it may take long time to solve.
UnjoinedRoomSeparationLinesFound | Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
UnusedTypesInTheProject | Project contains unused families and/or types. Consider purging them out.
ViewDetailLevelIsHighInLargeView | A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
WallsOverlap | Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

See Also

BuiltInFailures..::..PerformanceFailures Class


ClippingIsDisabled Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..ClippingIsDisabled Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
View has clipping disabled. It causes view to draw too many elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ClippingIsDisabled { get; }
Visual Basic
Public Shared ReadOnly Property ClippingIsDisabled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClippingIsDisabled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


DisjoinedSolidsInInPlaceFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..DisjoinedSolidsInInPlaceFamily Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
In-place family contains multiple disjoined solids. Consider splitting in several in-place families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DisjoinedSolidsInInPlaceFamily { get; }
Visual Basic
Public Shared ReadOnly Property DisjoinedSolidsInInPlaceFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DisjoinedSolidsInInPlaceFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


DuplicateInstances Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..DuplicateInstances Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateInstances { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateInstances As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateInstances {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


FamilyContainsViewSpecificImports Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..FamilyContainsViewSpecificImports Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyContainsViewSpecificImports { get; }
Visual Basic
Public Shared ReadOnly Property FamilyContainsViewSpecificImports As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyContainsViewSpecificImports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


HostHasTooManyInserts Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..HostHasTooManyInserts Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostHasTooManyInserts { get; }
Visual Basic
Public Shared ReadOnly Property HostHasTooManyInserts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostHasTooManyInserts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


InteriorCategoriesEnabledInLargeView Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..InteriorCategoriesEnabledInLargeView Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InteriorCategoriesEnabledInLargeView { get; }
Visual Basic
Public Shared ReadOnly Property InteriorCategoriesEnabledInLargeView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InteriorCategoriesEnabledInLargeView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


LargeFamilyFile Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..LargeFamilyFile Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Family occupies XXX kilobytes of memory. Consider simplification of the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LargeFamilyFile { get; }
Visual Basic
Public Shared ReadOnly Property LargeFamilyFile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LargeFamilyFile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


ManyElementInFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..ManyElementInFamily Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Family definition contains too many elements. Consider simplification of the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyElementInFamily { get; }
Visual Basic
Public Shared ReadOnly Property ManyElementInFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyElementInFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


ManyUnusedNestedFamilies Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..ManyUnusedNestedFamilies Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Family contains other families loaded into it but not used. Consider purging family document from unused families and types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyUnusedNestedFamilies { get; }
Visual Basic
Public Shared ReadOnly Property ManyUnusedNestedFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyUnusedNestedFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


MultipleLoopsInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..MultipleLoopsInSketch Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleLoopsInSketch { get; }
Visual Basic
Public Shared ReadOnly Property MultipleLoopsInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleLoopsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


TooLargeSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..TooLargeSketch Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooLargeSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooLargeSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooLargeSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


TooManyAreaBoundaryLinesFound Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..TooManyAreaBoundaryLinesFound Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyAreaBoundaryLinesFound { get; }
Visual Basic
Public Shared ReadOnly Property TooManyAreaBoundaryLinesFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyAreaBoundaryLinesFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


TooManyElementsInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..TooManyElementsInSketch Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Sketch of <element> contains too many objects - it may take long time to solve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyElementsInSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


UnjoinedRoomSeparationLinesFound Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..UnjoinedRoomSeparationLinesFound Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnjoinedRoomSeparationLinesFound { get; }
Visual Basic
Public Shared ReadOnly Property UnjoinedRoomSeparationLinesFound As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnjoinedRoomSeparationLinesFound {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


UnusedTypesInTheProject Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..UnusedTypesInTheProject Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Project contains unused families and/or types. Consider purging them out.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnusedTypesInTheProject { get; }
Visual Basic
Public Shared ReadOnly Property UnusedTypesInTheProject As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedTypesInTheProject {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


ViewDetailLevelIsHighInLargeView Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..ViewDetailLevelIsHighInLargeView Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ViewDetailLevelIsHighInLargeView { get; }
Visual Basic
Public Shared ReadOnly Property ViewDetailLevelIsHighInLargeView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewDetailLevelIsHighInLargeView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


WallsOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..PerformanceFailures..::..WallsOverlap Property
BuiltInFailures..::..PerformanceFailures Class See Also Send Feedback
Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallsOverlap { get; }
Visual Basic
Public Shared ReadOnly Property WallsOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallsOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PerformanceFailures Class


BuiltInFailures.PipingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Pipes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PipingFailures
Visual Basic
Public NotInheritable Class PipingFailures
Visual C++
public ref class PipingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PipingFailures

See Also

BuiltInFailures..::..PipingFailures Members


BuiltInFailures.PipingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PipingFailures Members
BuiltInFailures..::..PipingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
InvalidPipeFittingKfactorDatabase | Invalid Pipe Fitting K-Factor Database
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."

See Also

BuiltInFailures..::..PipingFailures Class


BuiltInFailures.PipingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PipingFailures Properties
BuiltInFailures..::..PipingFailures Class See Also Send Feedback

The BuiltInFailures..::..PipingFailures type exposes the following members.

Properties

Name | Description
CannotCreateGeometryForPipe | Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.
CircularLoopInPipeSizing | Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.
DuctPipeModified | The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.
InvalidPipeFittingKfactorDatabase | Invalid Pipe Fitting K-Factor Database
InvalidPipeSize | Pipe Size Table "[File Name]" is missing or invalid.
MaxPipeSizeReached | Maximum pipe size diameter reached during sizing
PartNotFoundInRoutingPreferenceError | "%1s is not found. Please review the routing preference of %2s."
PartNotFoundInRoutingPreferenceWarning | "%1s is not found. Please review the routing preference of %2s."

See Also

BuiltInFailures..::..PipingFailures Class


CannotCreateGeometryForPipe Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..CannotCreateGeometryForPipe Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Cannot create geometry for flex pipe. The flex pipe is intersecting itself or the start and end are too close together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateGeometryForPipe { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateGeometryForPipe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateGeometryForPipe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


CircularLoopInPipeSizing Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..CircularLoopInPipeSizing Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Circular loop detected during pipe sizing. The loop may be avoided by modifying segment settings in the pipe routing preference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularLoopInPipeSizing { get; }
Visual Basic
Public Shared ReadOnly Property CircularLoopInPipeSizing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularLoopInPipeSizing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


DuctPipeModified Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..DuctPipeModified Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
The duct/pipe has been modified to be in the opposite direction causing the connections to be invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuctPipeModified { get; }
Visual Basic
Public Shared ReadOnly Property DuctPipeModified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuctPipeModified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


InvalidPipeFittingKfactorDatabase Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..InvalidPipeFittingKfactorDatabase Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Invalid Pipe Fitting K-Factor Database

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPipeFittingKfactorDatabase { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPipeFittingKfactorDatabase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPipeFittingKfactorDatabase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


InvalidPipeSize Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..InvalidPipeSize Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Pipe Size Table "[File Name]" is missing or invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPipeSize { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPipeSize As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPipeSize {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


MaxPipeSizeReached Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..MaxPipeSizeReached Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
Maximum pipe size diameter reached during sizing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MaxPipeSizeReached { get; }
Visual Basic
Public Shared ReadOnly Property MaxPipeSizeReached As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxPipeSizeReached {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


PartNotFoundInRoutingPreferenceError Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..PartNotFoundInRoutingPreferenceError Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
"%1s is not found. Please review the routing preference of %2s."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartNotFoundInRoutingPreferenceError { get; }
Visual Basic
Public Shared ReadOnly Property PartNotFoundInRoutingPreferenceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotFoundInRoutingPreferenceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


PartNotFoundInRoutingPreferenceWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..PipingFailures..::..PartNotFoundInRoutingPreferenceWarning Property
BuiltInFailures..::..PipingFailures Class See Also Send Feedback
"%1s is not found. Please review the routing preference of %2s."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartNotFoundInRoutingPreferenceWarning { get; }
Visual Basic
Public Shared ReadOnly Property PartNotFoundInRoutingPreferenceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartNotFoundInRoutingPreferenceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PipingFailures Class


BuiltInFailures.PlanRegionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about PlanRegion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PlanRegionFailures
Visual Basic
Public NotInheritable Class PlanRegionFailures
Visual C++
public ref class PlanRegionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PlanRegionFailures

See Also

BuiltInFailures..::..PlanRegionFailures Members


BuiltInFailures.PlanRegionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures Members
BuiltInFailures..::..PlanRegionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PlanRegionFailures type exposes the following members.

Properties

Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.

See Also

BuiltInFailures..::..PlanRegionFailures Class


BuiltInFailures.PlanRegionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures Properties
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback

The BuiltInFailures..::..PlanRegionFailures type exposes the following members.

Properties

Name | Description
DeletedViewRangeLevel | Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?
Intersecting | The boundaries of the highlighted Plan Regions overlap.
InvalidPlanRegion | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
InvalidPlanRegionError | Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.
Nested | Cannot have nested Plan Regions.

See Also

BuiltInFailures..::..PlanRegionFailures Class


DeletedViewRangeLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures..::..DeletedViewRangeLevel Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Deleted level was used to define plan region's view range.\r\nReplace deleted level by level of parent view and adjust offset?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DeletedViewRangeLevel { get; }
Visual Basic
Public Shared ReadOnly Property DeletedViewRangeLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DeletedViewRangeLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


Intersecting Property

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures..::..Intersecting Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
The boundaries of the highlighted Plan Regions overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId Intersecting { get; }
Visual Basic
Public Shared ReadOnly Property Intersecting As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Intersecting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


InvalidPlanRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures..::..InvalidPlanRegion Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPlanRegion { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPlanRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPlanRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


InvalidPlanRegionError Property

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures..::..InvalidPlanRegionError Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Plan region is invalid. The sketch of a plan region may not contain intersecting, overlapping or nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidPlanRegionError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidPlanRegionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidPlanRegionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


Nested Property

[image]

Revit 2013 API
BuiltInFailures..::..PlanRegionFailures..::..Nested Property
BuiltInFailures..::..PlanRegionFailures Class See Also Send Feedback
Cannot have nested Plan Regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId Nested { get; }
Visual Basic
Public Shared ReadOnly Property Nested As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Nested {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PlanRegionFailures Class


BuiltInFailures.PointFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Point Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PointFailures
Visual Basic
Public NotInheritable Class PointFailures
Visual C++
public ref class PointFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PointFailures

See Also

BuiltInFailures..::..PointFailures Members


BuiltInFailures.PointFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PointFailures Members
BuiltInFailures..::..PointFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::..PointFailures Class


BuiltInFailures.PointFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PointFailures Properties
BuiltInFailures..::..PointFailures Class See Also Send Feedback

The BuiltInFailures..::..PointFailures type exposes the following members.

Properties

Name | Description
CannotMakePointHostedByIntersection | Cannot make point hosted by intersection.
CantChangeParamFlip | Can't flip Element.
CantChangeParamMirror | Can't mirror Element.
CantChangeParamRotate | Can't rotate Element.
EdgeHostedPointToBeUnhosted | A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.
HostMeasurementError | Invalid host curve measurement type or value or justification
HostParameterRangeError | Hosted Parameter must be between 0 and 1
RegenFailure | Regeneration Failure.

See Also

BuiltInFailures..::..PointFailures Class


CannotMakePointHostedByIntersection Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..CannotMakePointHostedByIntersection Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Cannot make point hosted by intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakePointHostedByIntersection { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakePointHostedByIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakePointHostedByIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


CantChangeParamFlip Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..CantChangeParamFlip Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Can't flip Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamFlip { get; }
Visual Basic
Public Shared ReadOnly Property CantChangeParamFlip As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamFlip {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


CantChangeParamMirror Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..CantChangeParamMirror Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Can't mirror Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamMirror { get; }
Visual Basic
Public Shared ReadOnly Property CantChangeParamMirror As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamMirror {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


CantChangeParamRotate Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..CantChangeParamRotate Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Can't rotate Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantChangeParamRotate { get; }
Visual Basic
Public Shared ReadOnly Property CantChangeParamRotate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantChangeParamRotate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


EdgeHostedPointToBeUnhosted Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..EdgeHostedPointToBeUnhosted Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
A point element in a family was hosted on an edge outside its family and the edge no longer exists. The point will remain placed but with no host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EdgeHostedPointToBeUnhosted { get; }
Visual Basic
Public Shared ReadOnly Property EdgeHostedPointToBeUnhosted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EdgeHostedPointToBeUnhosted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


HostMeasurementError Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..HostMeasurementError Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Invalid host curve measurement type or value or justification

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostMeasurementError { get; }
Visual Basic
Public Shared ReadOnly Property HostMeasurementError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostMeasurementError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


HostParameterRangeError Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..HostParameterRangeError Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Hosted Parameter must be between 0 and 1

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostParameterRangeError { get; }
Visual Basic
Public Shared ReadOnly Property HostParameterRangeError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostParameterRangeError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


RegenFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..PointFailures..::..RegenFailure Property
BuiltInFailures..::..PointFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PointFailures Class


BuiltInFailures.ProfileFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ProfileFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ProfileFailures
Visual Basic
Public NotInheritable Class ProfileFailures
Visual C++
public ref class ProfileFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ProfileFailures

See Also

BuiltInFailures..::..ProfileFailures Members


BuiltInFailures.ProfileFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ProfileFailures Members
BuiltInFailures..::..ProfileFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::..ProfileFailures Class


BuiltInFailures.ProfileFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ProfileFailures Properties
BuiltInFailures..::..ProfileFailures Class See Also Send Feedback

The BuiltInFailures..::..ProfileFailures type exposes the following members.

Properties

Name | Description
SketchNotEmpty | Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

See Also

BuiltInFailures..::..ProfileFailures Class


SketchNotEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..ProfileFailures..::..SketchNotEmpty Property
BuiltInFailures..::..ProfileFailures Class See Also Send Feedback
Can't move the Profile Plane because the Profile Sketch is not empty. This operation is not supported at this time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchNotEmpty { get; }
Visual Basic
Public Shared ReadOnly Property SketchNotEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchNotEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ProfileFailures Class


BuiltInFailures.PropertySetElementFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PropertySetElementFailures
Visual Basic
Public NotInheritable Class PropertySetElementFailures
Visual C++
public ref class PropertySetElementFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..PropertySetElementFailures

See Also

BuiltInFailures..::..PropertySetElementFailures Members


BuiltInFailures.PropertySetElementFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures Members
BuiltInFailures..::..PropertySetElementFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..PropertySetElementFailures type exposes the following members.

Properties

Name | Description
EmptyPropertySetName |
NonStringParameterValue |
NonUniquePropertySetName |

See Also

BuiltInFailures..::..PropertySetElementFailures Class


BuiltInFailures.PropertySetElementFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures Properties
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback

The BuiltInFailures..::..PropertySetElementFailures type exposes the following members.

Properties

Name | Description
EmptyPropertySetName |
NonStringParameterValue |
NonUniquePropertySetName |

See Also

BuiltInFailures..::..PropertySetElementFailures Class


EmptyPropertySetName Property

[image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures..::..EmptyPropertySetName Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EmptyPropertySetName { get; }
Visual Basic
Public Shared ReadOnly Property EmptyPropertySetName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EmptyPropertySetName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


NonStringParameterValue Property

[image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures..::..NonStringParameterValue Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonStringParameterValue { get; }
Visual Basic
Public Shared ReadOnly Property NonStringParameterValue As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonStringParameterValue {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


NonUniquePropertySetName Property

[image]

Revit 2013 API
BuiltInFailures..::..PropertySetElementFailures..::..NonUniquePropertySetName Property
BuiltInFailures..::..PropertySetElementFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonUniquePropertySetName { get; }
Visual Basic
Public Shared ReadOnly Property NonUniquePropertySetName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonUniquePropertySetName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..PropertySetElementFailures Class


BuiltInFailures.RebarFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RebarFailures
Visual Basic
Public NotInheritable Class RebarFailures
Visual C++
public ref class RebarFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RebarFailures

See Also

BuiltInFailures..::..RebarFailures Members


BuiltInFailures.RebarFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarFailures Members
BuiltInFailures..::..RebarFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::..RebarFailures Class


BuiltInFailures.RebarFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarFailures Properties
BuiltInFailures..::..RebarFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarFailures type exposes the following members.

Properties

Name | Description
BarDiameterTooLarge | Rebar Bar Diameter is too large.
BarTypeDoesNotAllowHooksOfCurrentShape | You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).
BendDiameterTooLarge | Rebar Bend Diameter is too large.
BendDiameterTooSmall | Rebar Bend Diameter is too small.
CannotPlaceRebar | Can't find a host for Rebar.
CannotPlaceRebarWarn | Can't find a host for Rebar.
CoverTooLong | Rebar Cover length is too large for host thickness.
HideAllBarsInRebarSet | All Bars in Rebar Set have been hidden.
HostTopologyChange | A reinforced host has undergone a major change. The reinforcement must be removed.
IncompleteShape | Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.
InvalidRebarHost | Rebar can be placed only in Concrete Structural elements.
InvalidRebarHostFamilyCanHostRebarParam | Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].
InvalidRebarHostNonConcrete | Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].
InvalidRebarHostNonStructural | Rebar can't be placed in a non-structural element.
InvalidRebarHostWrongCategory | Rebar can't be placed in a family of category [Name].
Inverted3dShape | The Rebar Shape XX cannot be inverted.
MaxHookExtensionMultiplierWarn | The maximum Hook Extension Multiplier value permitted is 99.
NoSurfPatternOnRebar | Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.
OutOfPlaneBendDiameterTooSmall | The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.
OutSideOfHost | Rebar is placed completely outside of its host.
RebarArrayTooShort | Rebar Set can't have coincident Bars.
RebarBendRadiusTooBig | Rebar Bend Radius is too big. Ignoring bend.
RebarBendRadiusTooBigWarn | Rebar Bend Radius is too big. Ignoring bend.
RebarConstraintWarning | Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.
RebarHooksDontMatchShape | The Rebar's hooks do not match its Rebar Shape.
RebarIllegalBarType | There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.
RebarNoMatchingHooks | The Rebar Shape '[Family Name]' has no matching hooks.
RebarShapeFailure | Can't solve Rebar Shape.
RebarSpacingTooSmall | Bar Spacing is too small.
RebarTooShortImperial | The minimum length of rebar shape is 1 inch.
RebarTooShortMetric | The minimum length of rebar shape is 25 mm.
SketchDimensionsRemoved | The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.
StandardHookBendDiameterTooLarge | Rebar Standard Hook Bend Diameter is too large.
StandardHookBendDiameterTooSmall | Rebar Standard Hook Bend Diameter is too small.
TooLargeNumberOfBars | Rebar Set must contain at most 1002 bar locations.
TooSmallNumberOfBars | Rebar Set must contain at least two bar locations.
TrySmallerBarType | Rebar Bend Diameter is too large. Try a smaller Bar Type.

See Also

BuiltInFailures..::..RebarFailures Class


BarDiameterTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..BarDiameterTooLarge Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bar Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BarDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property BarDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


BarTypeDoesNotAllowHooksOfCurrentShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..BarTypeDoesNotAllowHooksOfCurrentShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
You have selected a Bar Type which does not allow the Hooks used by the current shape. Please select a different Shape / Bar Type combination, or change the Hook permissions for the desired Bar Type (see Hook Lengths under Rebar Bar properties).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BarTypeDoesNotAllowHooksOfCurrentShape { get; }
Visual Basic
Public Shared ReadOnly Property BarTypeDoesNotAllowHooksOfCurrentShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarTypeDoesNotAllowHooksOfCurrentShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


BendDiameterTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..BendDiameterTooLarge Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BendDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property BendDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


BendDiameterTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..BendDiameterTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BendDiameterTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property BendDiameterTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotPlaceRebar Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..CannotPlaceRebar Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceRebar { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CannotPlaceRebarWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..CannotPlaceRebarWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't find a host for Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceRebarWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceRebarWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceRebarWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


CoverTooLong Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..CoverTooLong Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Cover length is too large for host thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CoverTooLong { get; }
Visual Basic
Public Shared ReadOnly Property CoverTooLong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CoverTooLong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


HideAllBarsInRebarSet Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..HideAllBarsInRebarSet Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
All Bars in Rebar Set have been hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HideAllBarsInRebarSet { get; }
Visual Basic
Public Shared ReadOnly Property HideAllBarsInRebarSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HideAllBarsInRebarSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


HostTopologyChange Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..HostTopologyChange Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
A reinforced host has undergone a major change. The reinforcement must be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostTopologyChange { get; }
Visual Basic
Public Shared ReadOnly Property HostTopologyChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostTopologyChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


IncompleteShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..IncompleteShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Shape [Family Name] is not fully defined and cannot be loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IncompleteShape { get; }
Visual Basic
Public Shared ReadOnly Property IncompleteShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IncompleteShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHost Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHost Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can be placed only in Concrete Structural elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHost { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostFamilyCanHostRebarParam Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostFamilyCanHostRebarParam Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in this Generic Model element because rebar hosting is disabled in the family [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostFamilyCanHostRebarParam { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostFamilyCanHostRebarParam As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostFamilyCanHostRebarParam {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostNonConcrete Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostNonConcrete Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a structural family unless its [Material Type] is [Concrete].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonConcrete { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostNonConcrete As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonConcrete {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostNonStructural Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostNonStructural Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a non-structural element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostNonStructural { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostNonStructural As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostNonStructural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


InvalidRebarHostWrongCategory Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..InvalidRebarHostWrongCategory Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar can't be placed in a family of category [Name].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRebarHostWrongCategory { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRebarHostWrongCategory As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRebarHostWrongCategory {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


Inverted3dShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..Inverted3dShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Rebar Shape XX cannot be inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId Inverted3dShape { get; }
Visual Basic
Public Shared ReadOnly Property Inverted3dShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ Inverted3dShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


MaxHookExtensionMultiplierWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..MaxHookExtensionMultiplierWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The maximum Hook Extension Multiplier value permitted is 99.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MaxHookExtensionMultiplierWarn { get; }
Visual Basic
Public Shared ReadOnly Property MaxHookExtensionMultiplierWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MaxHookExtensionMultiplierWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


NoSurfPatternOnRebar Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..NoSurfPatternOnRebar Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Rebar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnRebar { get; }
Visual Basic
Public Shared ReadOnly Property NoSurfPatternOnRebar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnRebar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


OutOfPlaneBendDiameterTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..OutOfPlaneBendDiameterTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Out of Plane Bend Diameter for Rebar Shape XX is too small for Rebar Bar Type YY.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OutOfPlaneBendDiameterTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property OutOfPlaneBendDiameterTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutOfPlaneBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


OutSideOfHost Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..OutSideOfHost Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar is placed completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property OutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarArrayTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarArrayTooShort Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set can't have coincident Bars.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarArrayTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RebarArrayTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarArrayTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarBendRadiusTooBig Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarBendRadiusTooBig Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarBendRadiusTooBig { get; }
Visual Basic
Public Shared ReadOnly Property RebarBendRadiusTooBig As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarBendRadiusTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarBendRadiusTooBigWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarBendRadiusTooBigWarn Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Radius is too big. Ignoring bend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarBendRadiusTooBigWarn { get; }
Visual Basic
Public Shared ReadOnly Property RebarBendRadiusTooBigWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarBendRadiusTooBigWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarConstraintWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarConstraintWarning Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Structural rebar have automatic constraints that may conflict with dimensional constraints. Using dimensional constraints with structural rebar is not recommended and should be avoided.\nGrouped structural rebar is the only exception to this recommendation, since the automatic constraints are removed on grouped rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarConstraintWarning { get; }
Visual Basic
Public Shared ReadOnly Property RebarConstraintWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarConstraintWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarHooksDontMatchShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarHooksDontMatchShape Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Rebar's hooks do not match its Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarHooksDontMatchShape { get; }
Visual Basic
Public Shared ReadOnly Property RebarHooksDontMatchShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarHooksDontMatchShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarIllegalBarType Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarIllegalBarType Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
There is Structural Rebar present in the project that no longer meet the criteria defined in Allowable Rebar Bar types parameter. Please review all existing Structural Rebar created with this Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarIllegalBarType { get; }
Visual Basic
Public Shared ReadOnly Property RebarIllegalBarType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarIllegalBarType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarNoMatchingHooks Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarNoMatchingHooks Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The Rebar Shape '[Family Name]' has no matching hooks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarNoMatchingHooks { get; }
Visual Basic
Public Shared ReadOnly Property RebarNoMatchingHooks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarNoMatchingHooks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarShapeFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarShapeFailure Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Can't solve Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarShapeFailure { get; }
Visual Basic
Public Shared ReadOnly Property RebarShapeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarSpacingTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarSpacingTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Bar Spacing is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSpacingTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RebarSpacingTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSpacingTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarTooShortImperial Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarTooShortImperial Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 1 inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarTooShortImperial { get; }
Visual Basic
Public Shared ReadOnly Property RebarTooShortImperial As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


RebarTooShortMetric Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..RebarTooShortMetric Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The minimum length of rebar shape is 25 mm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarTooShortMetric { get; }
Visual Basic
Public Shared ReadOnly Property RebarTooShortMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarTooShortMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


SketchDimensionsRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..SketchDimensionsRemoved Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
The sketch dimensions, that were used to create the sketch, have been removed from the completed rebar shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchDimensionsRemoved { get; }
Visual Basic
Public Shared ReadOnly Property SketchDimensionsRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchDimensionsRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


StandardHookBendDiameterTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..StandardHookBendDiameterTooLarge Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property StandardHookBendDiameterTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


StandardHookBendDiameterTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..StandardHookBendDiameterTooSmall Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Standard Hook Bend Diameter is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StandardHookBendDiameterTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property StandardHookBendDiameterTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StandardHookBendDiameterTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TooLargeNumberOfBars Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..TooLargeNumberOfBars Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set must contain at most 1002 bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooLargeNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property TooLargeNumberOfBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooLargeNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TooSmallNumberOfBars Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..TooSmallNumberOfBars Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Set must contain at least two bar locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooSmallNumberOfBars { get; }
Visual Basic
Public Shared ReadOnly Property TooSmallNumberOfBars As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooSmallNumberOfBars {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


TrySmallerBarType Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarFailures..::..TrySmallerBarType Property
BuiltInFailures..::..RebarFailures Class See Also Send Feedback
Rebar Bend Diameter is too large. Try a smaller Bar Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrySmallerBarType { get; }
Visual Basic
Public Shared ReadOnly Property TrySmallerBarType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrySmallerBarType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarFailures Class


BuiltInFailures.RebarShapeFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RebarShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RebarShapeFailures
Visual Basic
Public NotInheritable Class RebarShapeFailures
Visual C++
public ref class RebarShapeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RebarShapeFailures

See Also

BuiltInFailures..::..RebarShapeFailures Members


BuiltInFailures.RebarShapeFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures Members
BuiltInFailures..::..RebarShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarShapeFailures type exposes the following members.

Properties

Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.

See Also

BuiltInFailures..::..RebarShapeFailures Class


BuiltInFailures.RebarShapeFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures Properties
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarShapeFailures type exposes the following members.

Properties

Name | Description
CircleMultiPlanarShape | A circle can't be converted to multiplanar shape.
CircleUnbounded | An unbounded circle can only be used to construct a spiral shape.
CurveOverconstrained | Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.
CurvesCollinear | Collinear segments are not allowed in a Rebar Shape definition.
CurvesUnlooped | Segments defining the Rebar Shape must be in a continuous loop.
CurveUnderconstrained | Segment is underconstrained. It requires additional parameterized dimensions.
DepthDimensionNotExisted | Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.
DimensionLoose | This dimension cannot be used to parameterize the Rebar Shape.
DimensionWithoutParameter | Dimension has no parameter assigned to it.
FormulaDrivenDimension | Dimension can't be driven by a formula parameter.
MultiPlanarDepth | Multi-planar depth of Rebar Shape can't be too small.
MultipleArcsMustOverlap | Multiple arcs are supported only if they are concentric and form a circle with an overlap.
PlanarMultiPlanarShape | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
ShapeFailure | The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.
WrongDepthDimensionLabel | Multi-planar depth dimension label is already used for one of the planar shape parameters.

See Also

BuiltInFailures..::..RebarShapeFailures Class


CircleMultiPlanarShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CircleMultiPlanarShape Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
A circle can't be converted to multiplanar shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircleMultiPlanarShape { get; }
Visual Basic
Public Shared ReadOnly Property CircleMultiPlanarShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircleMultiPlanarShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CircleUnbounded Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CircleUnbounded Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
An unbounded circle can only be used to construct a spiral shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircleUnbounded { get; }
Visual Basic
Public Shared ReadOnly Property CircleUnbounded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircleUnbounded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CurveOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CurveOverconstrained Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Segment is overconstrained. It has at least one parameterized dimension that conflicts with another dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property CurveOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CurvesCollinear Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CurvesCollinear Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Collinear segments are not allowed in a Rebar Shape definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesCollinear { get; }
Visual Basic
Public Shared ReadOnly Property CurvesCollinear As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurvesCollinear {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CurvesUnlooped Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CurvesUnlooped Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Segments defining the Rebar Shape must be in a continuous loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurvesUnlooped { get; }
Visual Basic
Public Shared ReadOnly Property CurvesUnlooped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurvesUnlooped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


CurveUnderconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..CurveUnderconstrained Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Segment is underconstrained. It requires additional parameterized dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveUnderconstrained { get; }
Visual Basic
Public Shared ReadOnly Property CurveUnderconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveUnderconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DepthDimensionNotExisted Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..DepthDimensionNotExisted Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multi-planar shape's depth dimension has been deleted. Please assign a new one to multi-planar depth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DepthDimensionNotExisted { get; }
Visual Basic
Public Shared ReadOnly Property DepthDimensionNotExisted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DepthDimensionNotExisted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DimensionLoose Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..DimensionLoose Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
This dimension cannot be used to parameterize the Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionLoose { get; }
Visual Basic
Public Shared ReadOnly Property DimensionLoose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionLoose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


DimensionWithoutParameter Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..DimensionWithoutParameter Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Dimension has no parameter assigned to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DimensionWithoutParameter { get; }
Visual Basic
Public Shared ReadOnly Property DimensionWithoutParameter As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DimensionWithoutParameter {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


FormulaDrivenDimension Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..FormulaDrivenDimension Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Dimension can't be driven by a formula parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FormulaDrivenDimension { get; }
Visual Basic
Public Shared ReadOnly Property FormulaDrivenDimension As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FormulaDrivenDimension {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


MultiPlanarDepth Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..MultiPlanarDepth Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multi-planar depth of Rebar Shape can't be too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultiPlanarDepth { get; }
Visual Basic
Public Shared ReadOnly Property MultiPlanarDepth As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultiPlanarDepth {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


MultipleArcsMustOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..MultipleArcsMustOverlap Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multiple arcs are supported only if they are concentric and form a circle with an overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleArcsMustOverlap { get; }
Visual Basic
Public Shared ReadOnly Property MultipleArcsMustOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleArcsMustOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


PlanarMultiPlanarShape Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..PlanarMultiPlanarShape Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PlanarMultiPlanarShape { get; }
Visual Basic
Public Shared ReadOnly Property PlanarMultiPlanarShape As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlanarMultiPlanarShape {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


ShapeFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..ShapeFailure Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
The displayed Rebar Shape is created using a 'Rebar Bar for Preview'. This bar defines the bend radius displayed in the family. Using this preview bar the drawn shape cannot be completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShapeFailure { get; }
Visual Basic
Public Shared ReadOnly Property ShapeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShapeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


WrongDepthDimensionLabel Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarShapeFailures..::..WrongDepthDimensionLabel Property
BuiltInFailures..::..RebarShapeFailures Class See Also Send Feedback
Multi-planar depth dimension label is already used for one of the planar shape parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongDepthDimensionLabel { get; }
Visual Basic
Public Shared ReadOnly Property WrongDepthDimensionLabel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongDepthDimensionLabel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarShapeFailures Class


BuiltInFailures.RebarSystemFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RebarSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RebarSystemFailures
Visual Basic
Public NotInheritable Class RebarSystemFailures
Visual C++
public ref class RebarSystemFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RebarSystemFailures

See Also

BuiltInFailures..::..RebarSystemFailures Members


BuiltInFailures.RebarSystemFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures Members
BuiltInFailures..::..RebarSystemFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::..RebarSystemFailures Class


BuiltInFailures.RebarSystemFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures Properties
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

The BuiltInFailures..::..RebarSystemFailures type exposes the following members.

Properties

Name | Description
AreaReinforcementOutSideOfHost | Area Reinforcement is sketched completely outside of its host.
AreaReinforcementRegenFail | Can't regenerate Area Reinforcement.
AreaReinforcementsCollision | Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.
AreaReinforcementWrongHost | Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.
BarsTooCloseNumber | Bars are too close together. Decrease the Number Of Lines parameter.
BarsTooCloseSpacing | Bars are too close together. Increase the Maximum Spacing parameter.
BarsTooSparseSpacing | Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.
CannotPlaceAreaReinforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReinforcementWarn | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcement | Can't find a host for Area Reinforcement.
CannotPlaceAreaReininforcementWarn | Can't find a host for Area Reinforcement.
CannotPlacePathReinforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReinforcementWarn | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcement | Can't find a host for Path Reinforcement.
CannotPlacePathReininforcementWarn | Can't find a host for Path Reinforcement.
HostFlagAreaOff |
HostFlagAreaOn | The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.
HostFlagPathOff |
HostFlagPathOn |
PathReinforcementWrongHost | Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.
RebarSystemOffset | Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.
ThinHostFloor | Rebar Cover Top and Bottom are too large for host.
ThinHostFloorError | Rebar Cover Top and Bottom are too large for host.
ThinHostWall | Rebar Cover Interior and Exterior are too large for host.
ThinHostWallError | Rebar Cover Interior and Exterior are too large for host.

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementOutSideOfHost Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementOutSideOfHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Area Reinforcement is sketched completely outside of its host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementOutSideOfHost { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementOutSideOfHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementOutSideOfHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementRegenFail Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementRegenFail Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't regenerate Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementRegenFail { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementRegenFail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementRegenFail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementsCollision Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementsCollision Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Area Reinforcements are colliding. Aligning the Major Directions, or changing the Additional Offsets, can prevent collision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementsCollision { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementsCollision As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementsCollision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


AreaReinforcementWrongHost Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..AreaReinforcementWrongHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Area Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaReinforcementWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property AreaReinforcementWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BarsTooCloseNumber Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..BarsTooCloseNumber Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Bars are too close together. Decrease the Number Of Lines parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooCloseNumber { get; }
Visual Basic
Public Shared ReadOnly Property BarsTooCloseNumber As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarsTooCloseNumber {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BarsTooCloseSpacing Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..BarsTooCloseSpacing Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Bars are too close together. Increase the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooCloseSpacing { get; }
Visual Basic
Public Shared ReadOnly Property BarsTooCloseSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarsTooCloseSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BarsTooSparseSpacing Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..BarsTooSparseSpacing Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Bar spacing is greater than the size of the reinforced region. Decrease the Maximum Spacing parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BarsTooSparseSpacing { get; }
Visual Basic
Public Shared ReadOnly Property BarsTooSparseSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BarsTooSparseSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReinforcement Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReinforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReinforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReinforcementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReinforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReinforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReinforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReinforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReininforcement Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReininforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReininforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReininforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlaceAreaReininforcementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlaceAreaReininforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Area Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceAreaReininforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceAreaReininforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceAreaReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReinforcement Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReinforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReinforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReinforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReinforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReinforcementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReinforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReinforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReinforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReinforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReininforcement Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReininforcement Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcement { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReininforcement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


CannotPlacePathReininforcementWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..CannotPlacePathReininforcementWarn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Can't find a host for Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlacePathReininforcementWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlacePathReininforcementWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlacePathReininforcementWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagAreaOff Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagAreaOff Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFlagAreaOff { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagAreaOff As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagAreaOff {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagAreaOn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagAreaOn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
The Area Reinforcement element was created in a document with the Host Structural Rebar setting on, and cannot be transferred into this document, which has the setting off.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFlagAreaOn { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagAreaOn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagAreaOn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagPathOff Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagPathOff Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFlagPathOff { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagPathOff As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagPathOff {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


HostFlagPathOn Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..HostFlagPathOn Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFlagPathOn { get; }
Visual Basic
Public Shared ReadOnly Property HostFlagPathOn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFlagPathOn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


PathReinforcementWrongHost Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..PathReinforcementWrongHost Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Path Reinforcement can be placed only in Structural Floors and straight Structural Walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementWrongHost { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementWrongHost As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementWrongHost {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


RebarSystemOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..RebarSystemOffset Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Side/Edge is too large for sketch. Bar placement may be inaccurate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemOffset { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostFloor Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostFloor Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostFloor { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostFloor As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostFloorError Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostFloorError Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Top and Bottom are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostFloorError { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostFloorError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostFloorError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostWall Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostWall Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostWall { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


ThinHostWallError Property

[image]

Revit 2013 API
BuiltInFailures..::..RebarSystemFailures..::..ThinHostWallError Property
BuiltInFailures..::..RebarSystemFailures Class See Also Send Feedback
Rebar Cover Interior and Exterior are too large for host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ThinHostWallError { get; }
Visual Basic
Public Shared ReadOnly Property ThinHostWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ThinHostWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RebarSystemFailures Class


BuiltInFailures.RefPlaneFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RefPlaneFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RefPlane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RefPlaneFailures
Visual Basic
Public NotInheritable Class RefPlaneFailures
Visual C++
public ref class RefPlaneFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RefPlaneFailures

See Also

BuiltInFailures..::..RefPlaneFailures Members


BuiltInFailures.RefPlaneFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RefPlaneFailures Members
BuiltInFailures..::..RefPlaneFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RefPlaneFailures type exposes the following members.

Properties

Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.

See Also

BuiltInFailures..::..RefPlaneFailures Class


BuiltInFailures.RefPlaneFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RefPlaneFailures Properties
BuiltInFailures..::..RefPlaneFailures Class See Also Send Feedback

The BuiltInFailures..::..RefPlaneFailures type exposes the following members.

Properties

Name | Description
AlreadyHaveTwoClosurePlanes | No more than two closure planes are allowed.

See Also

BuiltInFailures..::..RefPlaneFailures Class


AlreadyHaveTwoClosurePlanes Property

[image]

Revit 2013 API
BuiltInFailures..::..RefPlaneFailures..::..AlreadyHaveTwoClosurePlanes Property
BuiltInFailures..::..RefPlaneFailures Class See Also Send Feedback
No more than two closure planes are allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AlreadyHaveTwoClosurePlanes { get; }
Visual Basic
Public Shared ReadOnly Property AlreadyHaveTwoClosurePlanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AlreadyHaveTwoClosurePlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RefPlaneFailures Class


BuiltInFailures.RegenFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RegenFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RegenFailures
Visual Basic
Public NotInheritable Class RegenFailures
Visual C++
public ref class RegenFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RegenFailures

See Also

BuiltInFailures..::..RegenFailures Members


BuiltInFailures.RegenFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RegenFailures Members
BuiltInFailures..::..RegenFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::..RegenFailures Class


BuiltInFailures.RegenFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RegenFailures Properties
BuiltInFailures..::..RegenFailures Class See Also Send Feedback

The BuiltInFailures..::..RegenFailures type exposes the following members.

Properties

Name | Description
CannotRegenFamily | Can't regenerate Family [Family Name]. Edit Family to modify it.
CircularDependency | There is a circular chain of references among the highlighted elements.
CircularDependencyAssocProp | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyAssocPropError | There is a circular dependency between a Line created with Pick Support and the supporting member.
CircularDependencyConstraint | Highlighted constraints cause a circular chain of references.
CircularDependencyConstraintError | Highlighted constraints cause a circular chain of references.
CircularDependencyError | There is a circular chain of references among the highlighted elements.
CircularDependencyResolved | There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.
CircularDependencySketch | Constraints in sketches of highlighted elements cause a circular chain of references.
CircularDependencySketchError | There is a circular chain of references among the highlighted elements.
CircularDependencyUncut | There is a circular chain of references among the highlighted elements.
CircularDependencyUncutError | There is a circular chain of references among the highlighted elements.
CircularDependencyWall | There is a circular chain of references among the highlighted elements.
CircularDependencyWallError | There is a circular chain of references among the highlighted elements.
ForceRegenSketch | Regen Sketch
GeomStepFailed | Can't rebuild geometry.
GeomStepFailedError | Can't rebuild geometry.
RegenElements | Regenerating elements.
RegeneratedElements | Elements regenerated in pass [Regen Index]
RegenFailure | Regeneration Failure.
UserCancelled | Operation is cancelled by the user.
UserCancelledError | Operation is cancelled by the user.

See Also

BuiltInFailures..::..RegenFailures Class


CannotRegenFamily Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CannotRegenFamily Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Can't regenerate Family [Family Name]. Edit Family to modify it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRegenFamily { get; }
Visual Basic
Public Shared ReadOnly Property CannotRegenFamily As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRegenFamily {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependency Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependency Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependency { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyAssocProp Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyAssocProp Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyAssocPropError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyAssocPropError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular dependency between a Line created with Pick Support and the supporting member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyAssocPropError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyAssocPropError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyAssocPropError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyConstraint Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyConstraint Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraint { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyConstraint As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraint {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyConstraintError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyConstraintError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Highlighted constraints cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyConstraintError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyConstraintError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyConstraintError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyResolved Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyResolved Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There was a circular chain of references among the highlighted elements that was attempted to resolve. User-visible text will depend on original error returned by offending element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyResolved { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyResolved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyResolved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencySketch Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencySketch Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Constraints in sketches of highlighted elements cause a circular chain of references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencySketch { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencySketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencySketchError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencySketchError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencySketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyUncut Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyUncut Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyUncut { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyUncut As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncut {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyUncutError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyUncutError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyUncutError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyUncutError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyUncutError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyWall Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyWall Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyWall { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


CircularDependencyWallError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..CircularDependencyWallError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
There is a circular chain of references among the highlighted elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircularDependencyWallError { get; }
Visual Basic
Public Shared ReadOnly Property CircularDependencyWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircularDependencyWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


ForceRegenSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..ForceRegenSketch Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Regen Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ForceRegenSketch { get; }
Visual Basic
Public Shared ReadOnly Property ForceRegenSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ForceRegenSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


GeomStepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..GeomStepFailed Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GeomStepFailed { get; }
Visual Basic
Public Shared ReadOnly Property GeomStepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeomStepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


GeomStepFailedError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..GeomStepFailedError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Can't rebuild geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GeomStepFailedError { get; }
Visual Basic
Public Shared ReadOnly Property GeomStepFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GeomStepFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


RegenElements Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..RegenElements Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Regenerating elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegenElements { get; }
Visual Basic
Public Shared ReadOnly Property RegenElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


RegeneratedElements Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..RegeneratedElements Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Elements regenerated in pass [Regen Index]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegeneratedElements { get; }
Visual Basic
Public Shared ReadOnly Property RegeneratedElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegeneratedElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


RegenFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..RegenFailure Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Regeneration Failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegenFailure { get; }
Visual Basic
Public Shared ReadOnly Property RegenFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegenFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


UserCancelled Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..UserCancelled Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelled { get; }
Visual Basic
Public Shared ReadOnly Property UserCancelled As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UserCancelled {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


UserCancelledError Property

[image]

Revit 2013 API
BuiltInFailures..::..RegenFailures..::..UserCancelledError Property
BuiltInFailures..::..RegenFailures Class See Also Send Feedback
Operation is cancelled by the user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelledError { get; }
Visual Basic
Public Shared ReadOnly Property UserCancelledError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UserCancelledError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RegenFailures Class


BuiltInFailures.RenderFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RenderFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Render.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RenderFailures
Visual Basic
Public NotInheritable Class RenderFailures
Visual C++
public ref class RenderFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RenderFailures

See Also

BuiltInFailures..::..RenderFailures Members


BuiltInFailures.RenderFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RenderFailures Members
BuiltInFailures..::..RenderFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::..RenderFailures Class


BuiltInFailures.RenderFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RenderFailures Properties
BuiltInFailures..::..RenderFailures Class See Also Send Feedback

The BuiltInFailures..::..RenderFailures type exposes the following members.

Properties

Name | Description
LightParametersNotInRange | The value should be in range of [Value] and [Value].
LightSourceInsideGeometry | Light source is inside solid geometry. No light will be emitted during rendering.
ProhibitDeletionLightSource | The light source cannot be deleted with UI.
RenderLibNotInstalledWarn | Rendering library has not been installed, so the third party geometry cannot be created.

See Also

BuiltInFailures..::..RenderFailures Class


LightParametersNotInRange Property

[image]

Revit 2013 API
BuiltInFailures..::..RenderFailures..::..LightParametersNotInRange Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
The value should be in range of [Value] and [Value].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LightParametersNotInRange { get; }
Visual Basic
Public Shared ReadOnly Property LightParametersNotInRange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LightParametersNotInRange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


LightSourceInsideGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..RenderFailures..::..LightSourceInsideGeometry Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
Light source is inside solid geometry. No light will be emitted during rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LightSourceInsideGeometry { get; }
Visual Basic
Public Shared ReadOnly Property LightSourceInsideGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LightSourceInsideGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


ProhibitDeletionLightSource Property

[image]

Revit 2013 API
BuiltInFailures..::..RenderFailures..::..ProhibitDeletionLightSource Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
The light source cannot be deleted with UI.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitDeletionLightSource { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitDeletionLightSource As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitDeletionLightSource {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


RenderLibNotInstalledWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RenderFailures..::..RenderLibNotInstalledWarn Property
BuiltInFailures..::..RenderFailures Class See Also Send Feedback
Rendering library has not been installed, so the third party geometry cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RenderLibNotInstalledWarn { get; }
Visual Basic
Public Shared ReadOnly Property RenderLibNotInstalledWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RenderLibNotInstalledWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RenderFailures Class


BuiltInFailures.RevisionCloudFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about RevisionCloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RevisionCloudFailures
Visual Basic
Public NotInheritable Class RevisionCloudFailures
Visual C++
public ref class RevisionCloudFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RevisionCloudFailures

See Also

BuiltInFailures..::..RevisionCloudFailures Members


BuiltInFailures.RevisionCloudFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures Members
BuiltInFailures..::..RevisionCloudFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitDeletionInIssued | The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::..RevisionCloudFailures Class


BuiltInFailures.RevisionCloudFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures Properties
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback

The BuiltInFailures..::..RevisionCloudFailures type exposes the following members.

Properties

Name | Description
ModifyingIssuedRevisionCloudOnUpgrade | During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.
ProhibitCreationInIssued | The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.
ProhibitDeletionInIssued | The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.
ProhibitModificationOfIssuedRevisionCloud | Issued Revision Clouds can't be modified.
ProhibitSwitchFromIssuedRevision | Can't remove cloud from an Issued Revision.
ProhibitSwitchToIssuedRevision | Can't add cloud to an Issued Revision.

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ModifyingIssuedRevisionCloudOnUpgrade Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ModifyingIssuedRevisionCloudOnUpgrade Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
During upgrade, an issued revision cloud was moved. Please double check the revision cloud to ensure it is located in the correct place.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModifyingIssuedRevisionCloudOnUpgrade { get; }
Visual Basic
Public Shared ReadOnly Property ModifyingIssuedRevisionCloudOnUpgrade As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModifyingIssuedRevisionCloudOnUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitCreationInIssued Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitCreationInIssued Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
The most current project revision has been issued. No new revision clouds can be created in it. Please add a new revision to the global revision table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitCreationInIssued { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitCreationInIssued As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitCreationInIssued {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitDeletionInIssued Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitDeletionInIssued Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
The Revision of this Revision Cloud has been issued. Deletion of this Revision Cloud is prohibited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitDeletionInIssued { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitDeletionInIssued As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitDeletionInIssued {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitModificationOfIssuedRevisionCloud Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitModificationOfIssuedRevisionCloud Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
Issued Revision Clouds can't be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitModificationOfIssuedRevisionCloud { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitModificationOfIssuedRevisionCloud As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitModificationOfIssuedRevisionCloud {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitSwitchFromIssuedRevision Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitSwitchFromIssuedRevision Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
Can't remove cloud from an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitSwitchFromIssuedRevision { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitSwitchFromIssuedRevision As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitSwitchFromIssuedRevision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


ProhibitSwitchToIssuedRevision Property

[image]

Revit 2013 API
BuiltInFailures..::..RevisionCloudFailures..::..ProhibitSwitchToIssuedRevision Property
BuiltInFailures..::..RevisionCloudFailures Class See Also Send Feedback
Can't add cloud to an Issued Revision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProhibitSwitchToIssuedRevision { get; }
Visual Basic
Public Shared ReadOnly Property ProhibitSwitchToIssuedRevision As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProhibitSwitchToIssuedRevision {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevisionCloudFailures Class


BuiltInFailures.RevolutionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RevolutionFailures
Visual Basic
Public NotInheritable Class RevolutionFailures
Visual C++
public ref class RevolutionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RevolutionFailures

See Also

BuiltInFailures..::..RevolutionFailures Members


BuiltInFailures.RevolutionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures Members
BuiltInFailures..::..RevolutionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::..RevolutionFailures Class


BuiltInFailures.RevolutionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures Properties
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback

The BuiltInFailures..::..RevolutionFailures type exposes the following members.

Properties

Name | Description
CannotDrawRevolution | Can't create surface of revolution.
ProfileCrossesRevolutionAxis | The profile must not cross the axis of revolution.
ProfileNotPlanar | The Profile must lie in a plane.

See Also

BuiltInFailures..::..RevolutionFailures Class


CannotDrawRevolution Property

[image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures..::..CannotDrawRevolution Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
Can't create surface of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawRevolution { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawRevolution As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawRevolution {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


ProfileCrossesRevolutionAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures..::..ProfileCrossesRevolutionAxis Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
The profile must not cross the axis of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileCrossesRevolutionAxis { get; }
Visual Basic
Public Shared ReadOnly Property ProfileCrossesRevolutionAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileCrossesRevolutionAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


ProfileNotPlanar Property

[image]

Revit 2013 API
BuiltInFailures..::..RevolutionFailures..::..ProfileNotPlanar Property
BuiltInFailures..::..RevolutionFailures Class See Also Send Feedback
The Profile must lie in a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileNotPlanar { get; }
Visual Basic
Public Shared ReadOnly Property ProfileNotPlanar As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileNotPlanar {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RevolutionFailures Class


BuiltInFailures.RoofFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RoofFailures
Visual Basic
Public NotInheritable Class RoofFailures
Visual C++
public ref class RoofFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RoofFailures

See Also

BuiltInFailures..::..RoofFailures Members


BuiltInFailures.RoofFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RoofFailures Members
BuiltInFailures..::..RoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
HoleInRoofFailedError | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::..RoofFailures Class


BuiltInFailures.RoofFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RoofFailures Properties
BuiltInFailures..::..RoofFailures Class See Also Send Feedback

The BuiltInFailures..::..RoofFailures type exposes the following members.

Properties

Name | Description
CurveRoofSkippedLoops | Some loops were skipped
CurveRoofSkippedLoopsError | Some loops were skipped
CurveRoofSkippedLoopsWarn | Some loops were skipped
ExtrudedRoofCutBySketch | Entire extruded Roof is cut by cut Sketch.
HadToAlignEaves | Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.
HoleInRoofFailed | Hole(s) could not be cut in roof.
HoleInRoofFailedError | Hole(s) could not be cut in roof.
InvalidArcSegmentation | A segmented slope-defining arc has too few segments.
JoinedRoofMissesTarget | Part of the roof to be joined misses the target face.
JoinedRoofMissesTargetError | Part of the roof to be joined misses the target face.
NoFlatCurtainRoofs | A Sloped Glazing with no slope is not allowed.
OnlyOneSlopeCurtainRoof | Only one slope in curtain roof.
OnlyUpwardFacesUsed | The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.
RoofCutoffRemoved | The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.
RoofExceedsMaxHeight | Roof exceeds user-specified maximum height
RoofMeetsRoofTangentially | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofMeetsRoofTangentiallyError | The roofs cannot be joined because the roof being joined meets the target roof tangentially.
RoofSlopeExceedsThreshold | Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
RoofToRefPlanes | Roof cannot be joined to more than one reference plane.
RoofToRefPlanesError | Roof cannot be joined to more than one reference plane.
UnusedSlopeArrow | The tails of all slope arrows must lie on the roof boundary.
UptoHeightTooLow | Cutoff Level cannot be below bottom of roof.
UserCancelledRoof | Cancelled.
WorkplaneShouldBeLevel | Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoops Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoops { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoopsError Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoopsError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


CurveRoofSkippedLoopsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..CurveRoofSkippedLoopsWarn Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Some loops were skipped

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveRoofSkippedLoopsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CurveRoofSkippedLoopsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveRoofSkippedLoopsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


ExtrudedRoofCutBySketch Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..ExtrudedRoofCutBySketch Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Entire extruded Roof is cut by cut Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtrudedRoofCutBySketch { get; }
Visual Basic
Public Shared ReadOnly Property ExtrudedRoofCutBySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtrudedRoofCutBySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


HadToAlignEaves Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..HadToAlignEaves Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Adjacent slope-defining lines must have identical eave heights. Eaves were aligned to higher location automatically to avoid failure. Use the Align Eaves tool to specify desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HadToAlignEaves { get; }
Visual Basic
Public Shared ReadOnly Property HadToAlignEaves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HadToAlignEaves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


HoleInRoofFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..HoleInRoofFailed Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HoleInRoofFailed { get; }
Visual Basic
Public Shared ReadOnly Property HoleInRoofFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HoleInRoofFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


HoleInRoofFailedError Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..HoleInRoofFailedError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Hole(s) could not be cut in roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HoleInRoofFailedError { get; }
Visual Basic
Public Shared ReadOnly Property HoleInRoofFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HoleInRoofFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


InvalidArcSegmentation Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..InvalidArcSegmentation Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
A segmented slope-defining arc has too few segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidArcSegmentation { get; }
Visual Basic
Public Shared ReadOnly Property InvalidArcSegmentation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidArcSegmentation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


JoinedRoofMissesTarget Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..JoinedRoofMissesTarget Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JoinedRoofMissesTarget { get; }
Visual Basic
Public Shared ReadOnly Property JoinedRoofMissesTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoinedRoofMissesTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


JoinedRoofMissesTargetError Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..JoinedRoofMissesTargetError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Part of the roof to be joined misses the target face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId JoinedRoofMissesTargetError { get; }
Visual Basic
Public Shared ReadOnly Property JoinedRoofMissesTargetError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ JoinedRoofMissesTargetError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


NoFlatCurtainRoofs Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..NoFlatCurtainRoofs Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
A Sloped Glazing with no slope is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFlatCurtainRoofs { get; }
Visual Basic
Public Shared ReadOnly Property NoFlatCurtainRoofs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFlatCurtainRoofs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


OnlyOneSlopeCurtainRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..OnlyOneSlopeCurtainRoof Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Only one slope in curtain roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyOneSlopeCurtainRoof { get; }
Visual Basic
Public Shared ReadOnly Property OnlyOneSlopeCurtainRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyOneSlopeCurtainRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


OnlyUpwardFacesUsed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..OnlyUpwardFacesUsed Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The selected faces contain both upward and downward pointing faces. Only the upward pointing faces were used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyUpwardFacesUsed { get; }
Visual Basic
Public Shared ReadOnly Property OnlyUpwardFacesUsed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyUpwardFacesUsed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofCutoffRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofCutoffRemoved Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roof's cutoff failed and was removed; make sure the cutoff height is not below the roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofCutoffRemoved { get; }
Visual Basic
Public Shared ReadOnly Property RoofCutoffRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofCutoffRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofExceedsMaxHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofExceedsMaxHeight Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Roof exceeds user-specified maximum height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofExceedsMaxHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoofExceedsMaxHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofExceedsMaxHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofMeetsRoofTangentially Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofMeetsRoofTangentially Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentially { get; }
Visual Basic
Public Shared ReadOnly Property RoofMeetsRoofTangentially As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofMeetsRoofTangentiallyError Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofMeetsRoofTangentiallyError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The roofs cannot be joined because the roof being joined meets the target roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofMeetsRoofTangentiallyError { get; }
Visual Basic
Public Shared ReadOnly Property RoofMeetsRoofTangentiallyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofMeetsRoofTangentiallyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofSlopeExceedsThreshold Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofSlopeExceedsThreshold Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Thickness of this Roof may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofSlopeExceedsThreshold { get; }
Visual Basic
Public Shared ReadOnly Property RoofSlopeExceedsThreshold As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofSlopeExceedsThreshold {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofToRefPlanes Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofToRefPlanes Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofToRefPlanes { get; }
Visual Basic
Public Shared ReadOnly Property RoofToRefPlanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofToRefPlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


RoofToRefPlanesError Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..RoofToRefPlanesError Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Roof cannot be joined to more than one reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoofToRefPlanesError { get; }
Visual Basic
Public Shared ReadOnly Property RoofToRefPlanesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoofToRefPlanesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UnusedSlopeArrow Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..UnusedSlopeArrow Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
The tails of all slope arrows must lie on the roof boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnusedSlopeArrow { get; }
Visual Basic
Public Shared ReadOnly Property UnusedSlopeArrow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedSlopeArrow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UptoHeightTooLow Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..UptoHeightTooLow Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Cutoff Level cannot be below bottom of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UptoHeightTooLow { get; }
Visual Basic
Public Shared ReadOnly Property UptoHeightTooLow As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UptoHeightTooLow {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


UserCancelledRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..UserCancelledRoof Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Cancelled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UserCancelledRoof { get; }
Visual Basic
Public Shared ReadOnly Property UserCancelledRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UserCancelledRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


WorkplaneShouldBeLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..RoofFailures..::..WorkplaneShouldBeLevel Property
BuiltInFailures..::..RoofFailures Class See Also Send Feedback
Can't use Workplane that is not a Level. Set the desired Level as current Workplane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WorkplaneShouldBeLevel { get; }
Visual Basic
Public Shared ReadOnly Property WorkplaneShouldBeLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WorkplaneShouldBeLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoofFailures Class


BuiltInFailures.RoomFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class RoomFailures
Visual Basic
Public NotInheritable Class RoomFailures
Visual C++
public ref class RoomFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..RoomFailures

See Also

BuiltInFailures..::..RoomFailures Members


BuiltInFailures.RoomFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..RoomFailures Members
BuiltInFailures..::..RoomFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotCopyLinkedRooms | Linked Rooms may not be pasted
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictInLinkBoundariesVaryMainAddToOptionSet | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkBoundariesVaryMainSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkBoundariesVaryOptionSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkRoomOverlapMain | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link’s option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkRoomOverlapOption | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link’s option '[Option #1 Name in Link]' overlaps a room in the Revit link’s option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] Volumes Overlap, adjust Upper Limit and Upper Offset.
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::..RoomFailures Class


BuiltInFailures.RoomFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..RoomFailures Properties
BuiltInFailures..::..RoomFailures Class See Also Send Feedback

The BuiltInFailures..::..RoomFailures type exposes the following members.

Properties

Name | Description
AreaTagBadViewType | Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.
AreaUnplaceWarning | An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.
CannotCopyLinkedRooms | Linked Rooms may not be pasted
CannotMakeRoomsGeometry | Could not create geometry for [Room].
ExtensionsOverlapWarning | Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.
InvalidReflectivityPercentage | The value for Reflectivity must be between 0 and 1.
InvisibleRoomBoundElemement | [Room] Bounding element is invisible in current view.
OptionConflictBoundariesVaryMainAddToOptionSet | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictBoundariesVaryMainSeparate | Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictBoundariesVaryOptionSeparate | Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.
OptionConflictInLinkBoundariesVaryMainAddToOptionSet | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkBoundariesVaryMainSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkBoundariesVaryOptionSeparate | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.
OptionConflictInLinkRoomOverlapMain | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link’s option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.
OptionConflictInLinkRoomOverlapOption | Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link’s option '[Option #1 Name in Link]' overlaps a room in the Revit link’s option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.
OptionConflictRoomOverlapMain | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.
OptionConflictRoomOverlapOption | Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.
RoomBaseAboveComputationHeight | [RoomBase]'s lower offset is above the Computation Height
RoomBelowCompHeight | [Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.
RoomBoundaryMisalignment | [Room] bounding element might be misaligned.
RoomHeightNegative | [Room] must have a height greater than 0.
RoomLevelElevs | A [Room]s Upper Limit must be above its Base Level.
RoomNotEnclosed | [Room] is not in a properly enclosed region
RoomNotEnclosedAreas | [Room] is not in a properly enclosed region
RoomNotEnclosedRooms | [Room] is not in a properly enclosed region
RoomNotEnclosedSpaces | [Room] is not in a properly enclosed region
RoomsCreatedAutomatically | [Room] [Room] created automatically.
RoomsFailed | [Room] computations only succeeded without considering the following elements.
RoomsInSameRegion | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionAreas | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionRooms | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsInSameRegionSpaces | Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.
RoomsOverlapInHeight | [Room] Volumes Overlap, adjust Upper Limit and Upper Offset.
RoomsReallyFailed | [Room] computations failed. Try to modify the following elements.
RoomTagBadViewType | [Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.
RoomTagDeleted | A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.
RoomTagNotInRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToArea | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToRoom | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagNotInRoomToSpace | [Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].
RoomTagVolumeNotComputed | [Room] Tag is displaying volume that can't be computed.
RoomTooShort | [Room] is very short. If this is not intended, change its Upper Limit and Offset.
RoomUnplaceWarning | A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.
ShowRoomBoundingElements | [Room] Bounding elements are highlighted.
SpaceUnplaceWarning | A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

See Also

BuiltInFailures..::..RoomFailures Class


AreaTagBadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..AreaTagBadViewType Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Can't Copy Area Tags. The target view doesn't have the same Area Scheme as the original view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaTagBadViewType { get; }
Visual Basic
Public Shared ReadOnly Property AreaTagBadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaTagBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


AreaUnplaceWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..AreaUnplaceWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
An Area was deleted from all model views but still remains in this project. \n The area can be removed from any schedule or placed back in the model using the Area command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaUnplaceWarning { get; }
Visual Basic
Public Shared ReadOnly Property AreaUnplaceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


CannotCopyLinkedRooms Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..CannotCopyLinkedRooms Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Linked Rooms may not be pasted

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyLinkedRooms { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyLinkedRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyLinkedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


CannotMakeRoomsGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..CannotMakeRoomsGeometry Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Could not create geometry for [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeRoomsGeometry { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeRoomsGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeRoomsGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


ExtensionsOverlapWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..ExtensionsOverlapWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Vertical Extensions on these Walls overlap. This can cause undesirable Joins. Try starting with no overlap and extend the Walls toward one another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtensionsOverlapWarning { get; }
Visual Basic
Public Shared ReadOnly Property ExtensionsOverlapWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtensionsOverlapWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


InvalidReflectivityPercentage Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..InvalidReflectivityPercentage Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
The value for Reflectivity must be between 0 and 1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidReflectivityPercentage { get; }
Visual Basic
Public Shared ReadOnly Property InvalidReflectivityPercentage As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidReflectivityPercentage {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


InvisibleRoomBoundElemement Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..InvisibleRoomBoundElemement Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Bounding element is invisible in current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvisibleRoomBoundElemement { get; }
Visual Basic
Public Shared ReadOnly Property InvisibleRoomBoundElemement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvisibleRoomBoundElemement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictBoundariesVaryMainAddToOptionSet Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictBoundariesVaryMainAddToOptionSet Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryMainAddToOptionSet { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainAddToOptionSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictBoundariesVaryMainSeparate Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictBoundariesVaryMainSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary in the Main Model differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryMainSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictBoundariesVaryMainSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryMainSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictBoundariesVaryOptionSeparate Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictBoundariesVaryOptionSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom boundary differs from the apparent boundary in view '[View Name]'.\nTo resolve, divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictBoundariesVaryOptionSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkBoundariesVaryMainAddToOptionSet Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkBoundariesVaryMainAddToOptionSet Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryMainAddToOptionSet { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryMainAddToOptionSet As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryMainAddToOptionSet {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkBoundariesVaryMainSeparate Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkBoundariesVaryMainSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary in the main model of the Revit link differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryMainSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryMainSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryMainSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkBoundariesVaryOptionSeparate Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkBoundariesVaryOptionSeparate Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room boundary differs from the apparent boundary in the linked view '[View Name from Link]'.\nTo resolve the issue, open the Revit link file for editing, and use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkBoundariesVaryOptionSeparate { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkBoundariesVaryOptionSeparate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkBoundariesVaryOptionSeparate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkRoomOverlapMain Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkRoomOverlapMain Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nThe room in the Revit link’s option '[Option Name in Link]' overlaps a room in the main model.\nTo resolve the issue, open the Revit link file for editing, select the main model room, and use the Add to Design Option Set tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkRoomOverlapMain { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapMain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapMain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictInLinkRoomOverlapOption Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictInLinkRoomOverlapOption Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option conflict between rooms in the Revit link '[Link Instance Name]'.\nA room in the Revit link’s option '[Option #1 Name in Link]' overlaps a room in the Revit link’s option '[Option #2 Name in Link]'.\nTo resolve the issue, open the Revit link file for editing, and delete the duplicate room or use room separation lines to divide the space in the main model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictInLinkRoomOverlapOption { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictInLinkRoomOverlapOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictInLinkRoomOverlapOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictRoomOverlapMain Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictRoomOverlapMain Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in the Main Model.\nTo resolve, select the Main Model Room and use the Add to Design Option Set command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapMain { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictRoomOverlapMain As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapMain {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


OptionConflictRoomOverlapOption Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..OptionConflictRoomOverlapOption Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Option Conflict between Rooms.\nRoom in Option '[Option Name]' overlaps Room in Option '[Option Name]'.\nTo resolve, delete the duplicate Room or divide space with Room Separation Lines in the Main Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OptionConflictRoomOverlapOption { get; }
Visual Basic
Public Shared ReadOnly Property OptionConflictRoomOverlapOption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OptionConflictRoomOverlapOption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomBaseAboveComputationHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomBaseAboveComputationHeight Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[RoomBase]'s lower offset is above the Computation Height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBaseAboveComputationHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomBaseAboveComputationHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomBaseAboveComputationHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomBelowCompHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomBelowCompHeight Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Volume is being calculated above the Upper Limit of this [Room]. Change the Upper Limit and Offset or change the height of volume calculations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBelowCompHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomBelowCompHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomBelowCompHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomBoundaryMisalignment Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomBoundaryMisalignment Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] bounding element might be misaligned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomBoundaryMisalignment { get; }
Visual Basic
Public Shared ReadOnly Property RoomBoundaryMisalignment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomBoundaryMisalignment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomHeightNegative Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomHeightNegative Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] must have a height greater than 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomHeightNegative { get; }
Visual Basic
Public Shared ReadOnly Property RoomHeightNegative As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomHeightNegative {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomLevelElevs Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomLevelElevs Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A [Room]s Upper Limit must be above its Base Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomLevelElevs { get; }
Visual Basic
Public Shared ReadOnly Property RoomLevelElevs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomLevelElevs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosed { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedAreas Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedAreas Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedAreas { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedAreas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedRooms Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedRooms Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedRooms { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomNotEnclosedSpaces Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomNotEnclosedSpaces Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is not in a properly enclosed region

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomNotEnclosedSpaces { get; }
Visual Basic
Public Shared ReadOnly Property RoomNotEnclosedSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomNotEnclosedSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsCreatedAutomatically Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsCreatedAutomatically Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] [Room] created automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsCreatedAutomatically { get; }
Visual Basic
Public Shared ReadOnly Property RoomsCreatedAutomatically As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsCreatedAutomatically {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsFailed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] computations only succeeded without considering the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsFailed { get; }
Visual Basic
Public Shared ReadOnly Property RoomsFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegion Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegion { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionAreas Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionAreas Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionAreas { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionAreas As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionAreas {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionRooms Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionRooms Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionRooms { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionRooms As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionRooms {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsInSameRegionSpaces Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsInSameRegionSpaces Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
Multiple [Room] are in the same enclosed region. The correct area and perimeter will be assigned to one [Room] and the others will display "Redundant [Room]." You should separate the regions, delete the extra [Room], or move them into different regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsInSameRegionSpaces { get; }
Visual Basic
Public Shared ReadOnly Property RoomsInSameRegionSpaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsInSameRegionSpaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsOverlapInHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsOverlapInHeight Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Volumes Overlap, adjust Upper Limit and Upper Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsOverlapInHeight { get; }
Visual Basic
Public Shared ReadOnly Property RoomsOverlapInHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsOverlapInHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomsReallyFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomsReallyFailed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] computations failed. Try to modify the following elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomsReallyFailed { get; }
Visual Basic
Public Shared ReadOnly Property RoomsReallyFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomsReallyFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagBadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagBadViewType Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tags can only be placed in Floor Plan, Reflected Ceiling Plan and Section Views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagBadViewType { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagBadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagBadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagDeleted Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A [Room] Tag was deleted, but the corresponding [Room] still exists. You can place another tag for the [Room] using the [Room] Tag tool or select the [Room] and delete it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagDeleted { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoom Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoom Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoom { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToArea Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToArea Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToArea { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToArea As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToRoom Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToRoom Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToRoom { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToRoom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToRoom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagNotInRoomToSpace Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagNotInRoomToSpace Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is outside of its [Room]. Enable Leader or move [Room] Tag within its [Room].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagNotInRoomToSpace { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagNotInRoomToSpace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagNotInRoomToSpace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTagVolumeNotComputed Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTagVolumeNotComputed Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Tag is displaying volume that can't be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTagVolumeNotComputed { get; }
Visual Basic
Public Shared ReadOnly Property RoomTagVolumeNotComputed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTagVolumeNotComputed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomTooShort Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] is very short. If this is not intended, change its Upper Limit and Offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RoomTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


RoomUnplaceWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..RoomUnplaceWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A Room was deleted from all model views but still remains in this project. \n The room can be removed from any schedule or placed back in the model using the Room command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RoomUnplaceWarning { get; }
Visual Basic
Public Shared ReadOnly Property RoomUnplaceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RoomUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


ShowRoomBoundingElements Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..ShowRoomBoundingElements Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
[Room] Bounding elements are highlighted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShowRoomBoundingElements { get; }
Visual Basic
Public Shared ReadOnly Property ShowRoomBoundingElements As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShowRoomBoundingElements {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


SpaceUnplaceWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..RoomFailures..::..SpaceUnplaceWarning Property
BuiltInFailures..::..RoomFailures Class See Also Send Feedback
A Space was deleted from all model views but still remains in this project. \n The Space can be removed from any schedule or placed back in the model using the Space command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpaceUnplaceWarning { get; }
Visual Basic
Public Shared ReadOnly Property SpaceUnplaceWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpaceUnplaceWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..RoomFailures Class


BuiltInFailures.ScheduleViewFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ScheduleViewFailures
Visual Basic
Public NotInheritable Class ScheduleViewFailures
Visual C++
public ref class ScheduleViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ScheduleViewFailures

See Also

BuiltInFailures..::..ScheduleViewFailures Members


BuiltInFailures.ScheduleViewFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures Members
BuiltInFailures..::..ScheduleViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::..ScheduleViewFailures Class


BuiltInFailures.ScheduleViewFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures Properties
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ScheduleViewFailures type exposes the following members.

Properties

Name | Description
BadViewType | Schedules can only be placed on Sheets.
CannotResizeColumn | Can't resize column.
ColumnsExceedSegment | Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.
ColumnsExcluded | Some columns in the project are excluded from the graphical column schedule view.
DuplicateFieldRemovedFromKeySchedule | Duplicate fields across key schedules will be removed after paste.
NoColumnsJoinedToGridLines | No columns are joined to grid lines, or view parameters exclude all columns.
NotGridName | '[Text]' is not a Grid line name
PanelScheduleLoadClassInconsistency | You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.
PanelScheduleSlotInconsistency | The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.
SchedulesCanBePlacedOnSheetsOnly | Schedules can only be placed on Sheets.
SegmentsStartIsGreaterThanSegmentsEnd | Change values so Segments End is greater than or equal to Segments Start.

See Also

BuiltInFailures..::..ScheduleViewFailures Class


BadViewType Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..BadViewType Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewType { get; }
Visual Basic
Public Shared ReadOnly Property BadViewType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


CannotResizeColumn Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..CannotResizeColumn Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Can't resize column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotResizeColumn { get; }
Visual Basic
Public Shared ReadOnly Property CannotResizeColumn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotResizeColumn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


ColumnsExceedSegment Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..ColumnsExceedSegment Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Some columns in Graphical Column Schedule exceed the segment's upper/lower bounds. You can add levels or adjust the view parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnsExceedSegment { get; }
Visual Basic
Public Shared ReadOnly Property ColumnsExceedSegment As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnsExceedSegment {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


ColumnsExcluded Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..ColumnsExcluded Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Some columns in the project are excluded from the graphical column schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ColumnsExcluded { get; }
Visual Basic
Public Shared ReadOnly Property ColumnsExcluded As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ColumnsExcluded {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


DuplicateFieldRemovedFromKeySchedule Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..DuplicateFieldRemovedFromKeySchedule Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Duplicate fields across key schedules will be removed after paste.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateFieldRemovedFromKeySchedule { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateFieldRemovedFromKeySchedule As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateFieldRemovedFromKeySchedule {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


NoColumnsJoinedToGridLines Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..NoColumnsJoinedToGridLines Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
No columns are joined to grid lines, or view parameters exclude all columns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoColumnsJoinedToGridLines { get; }
Visual Basic
Public Shared ReadOnly Property NoColumnsJoinedToGridLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoColumnsJoinedToGridLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


NotGridName Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..NotGridName Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
'[Text]' is not a Grid line name

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotGridName { get; }
Visual Basic
Public Shared ReadOnly Property NotGridName As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotGridName {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


PanelScheduleLoadClassInconsistency Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..PanelScheduleLoadClassInconsistency Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
You have one or more loads connected to this panel that are not displayed in the panel schedule. Add the load classification(s) to the associated template to report this information in the Loads Summary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelScheduleLoadClassInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleLoadClassInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleLoadClassInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


PanelScheduleSlotInconsistency Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..PanelScheduleSlotInconsistency Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
The template applied to this panel schedule is set to display fewer slots than what is needed to display the maximum number of 1-pole breakers set on the equipment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PanelScheduleSlotInconsistency { get; }
Visual Basic
Public Shared ReadOnly Property PanelScheduleSlotInconsistency As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PanelScheduleSlotInconsistency {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


SchedulesCanBePlacedOnSheetsOnly Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..SchedulesCanBePlacedOnSheetsOnly Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Schedules can only be placed on Sheets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SchedulesCanBePlacedOnSheetsOnly { get; }
Visual Basic
Public Shared ReadOnly Property SchedulesCanBePlacedOnSheetsOnly As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SchedulesCanBePlacedOnSheetsOnly {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


SegmentsStartIsGreaterThanSegmentsEnd Property

[image]

Revit 2013 API
BuiltInFailures..::..ScheduleViewFailures..::..SegmentsStartIsGreaterThanSegmentsEnd Property
BuiltInFailures..::..ScheduleViewFailures Class See Also Send Feedback
Change values so Segments End is greater than or equal to Segments Start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SegmentsStartIsGreaterThanSegmentsEnd { get; }
Visual Basic
Public Shared ReadOnly Property SegmentsStartIsGreaterThanSegmentsEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SegmentsStartIsGreaterThanSegmentsEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ScheduleViewFailures Class


BuiltInFailures.SculptingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SculptingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sculpting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SculptingFailures
Visual Basic
Public NotInheritable Class SculptingFailures
Visual C++
public ref class SculptingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SculptingFailures

See Also

BuiltInFailures..::..SculptingFailures Members


BuiltInFailures.SculptingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SculptingFailures Members
BuiltInFailures..::..SculptingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::..SculptingFailures Class


BuiltInFailures.SculptingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SculptingFailures Properties
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback

The BuiltInFailures..::..SculptingFailures type exposes the following members.

Properties

Name | Description
FaceSculptEditFailed | Face Sculpt Edit failed.
FaceSculptingFaceLoss | The original sculpted face is lost.

See Also

BuiltInFailures..::..SculptingFailures Class


FaceSculptEditFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SculptingFailures..::..FaceSculptEditFailed Property
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback
Face Sculpt Edit failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSculptEditFailed { get; }
Visual Basic
Public Shared ReadOnly Property FaceSculptEditFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceSculptEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SculptingFailures Class


FaceSculptingFaceLoss Property

[image]

Revit 2013 API
BuiltInFailures..::..SculptingFailures..::..FaceSculptingFaceLoss Property
BuiltInFailures..::..SculptingFailures Class See Also Send Feedback
The original sculpted face is lost.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceSculptingFaceLoss { get; }
Visual Basic
Public Shared ReadOnly Property FaceSculptingFaceLoss As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceSculptingFaceLoss {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SculptingFailures Class


BuiltInFailures.SectionViewFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SectionViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SectionViewFailures
Visual Basic
Public NotInheritable Class SectionViewFailures
Visual C++
public ref class SectionViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SectionViewFailures

See Also

BuiltInFailures..::..SectionViewFailures Members


BuiltInFailures.SectionViewFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SectionViewFailures Members
BuiltInFailures..::..SectionViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
SectionAndScopeBoxNotOrtho | Section must be parallel to one side of the associated scope box.

See Also

BuiltInFailures..::..SectionViewFailures Class


BuiltInFailures.SectionViewFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SectionViewFailures Properties
BuiltInFailures..::..SectionViewFailures Class See Also Send Feedback

The BuiltInFailures..::..SectionViewFailures type exposes the following members.

Properties

Name | Description
ScopeBoxBehindSection | Section may not be associated to a scope box which lies behind it.
SectionAndScopeBoxNotOrtho | Section must be parallel to one side of the associated scope box.

See Also

BuiltInFailures..::..SectionViewFailures Class


ScopeBoxBehindSection Property

[image]

Revit 2013 API
BuiltInFailures..::..SectionViewFailures..::..ScopeBoxBehindSection Property
BuiltInFailures..::..SectionViewFailures Class See Also Send Feedback
Section may not be associated to a scope box which lies behind it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ScopeBoxBehindSection { get; }
Visual Basic
Public Shared ReadOnly Property ScopeBoxBehindSection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ScopeBoxBehindSection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SectionViewFailures Class


SectionAndScopeBoxNotOrtho Property

[image]

Revit 2013 API
BuiltInFailures..::..SectionViewFailures..::..SectionAndScopeBoxNotOrtho Property
BuiltInFailures..::..SectionViewFailures Class See Also Send Feedback
Section must be parallel to one side of the associated scope box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SectionAndScopeBoxNotOrtho { get; }
Visual Basic
Public Shared ReadOnly Property SectionAndScopeBoxNotOrtho As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SectionAndScopeBoxNotOrtho {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SectionViewFailures Class


BuiltInFailures.SelectionFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SelectionFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Selections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SelectionFailures
Visual Basic
Public NotInheritable Class SelectionFailures
Visual C++
public ref class SelectionFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SelectionFailures

See Also

BuiltInFailures..::..SelectionFailures Members


BuiltInFailures.SelectionFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SelectionFailures Members
BuiltInFailures..::..SelectionFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::..SelectionFailures Class


BuiltInFailures.SelectionFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SelectionFailures Properties
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback

The BuiltInFailures..::..SelectionFailures type exposes the following members.

Properties

Name | Description
NoElementSelected | No element selected.
NoValidElementSelected | No valid element selected.

See Also

BuiltInFailures..::..SelectionFailures Class


NoElementSelected Property

[image]

Revit 2013 API
BuiltInFailures..::..SelectionFailures..::..NoElementSelected Property
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback
No element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoElementSelected { get; }
Visual Basic
Public Shared ReadOnly Property NoElementSelected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SelectionFailures Class


NoValidElementSelected Property

[image]

Revit 2013 API
BuiltInFailures..::..SelectionFailures..::..NoValidElementSelected Property
BuiltInFailures..::..SelectionFailures Class See Also Send Feedback
No valid element selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoValidElementSelected { get; }
Visual Basic
Public Shared ReadOnly Property NoValidElementSelected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoValidElementSelected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SelectionFailures Class


BuiltInFailures.SheetFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SheetFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SheetFailures
Visual Basic
Public NotInheritable Class SheetFailures
Visual C++
public ref class SheetFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SheetFailures

See Also

BuiltInFailures..::..SheetFailures Members


BuiltInFailures.SheetFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SheetFailures Members
BuiltInFailures..::..SheetFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::..SheetFailures Class


BuiltInFailures.SheetFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SheetFailures Properties
BuiltInFailures..::..SheetFailures Class See Also Send Feedback

The BuiltInFailures..::..SheetFailures type exposes the following members.

Properties

Name | Description
SheetNumberDuplicated | Sheet Number is already in use. Enter a unique number.
SheetNumberEmpty | Sheet Number is empty

See Also

BuiltInFailures..::..SheetFailures Class


SheetNumberDuplicated Property

[image]

Revit 2013 API
BuiltInFailures..::..SheetFailures..::..SheetNumberDuplicated Property
BuiltInFailures..::..SheetFailures Class See Also Send Feedback
Sheet Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SheetNumberDuplicated { get; }
Visual Basic
Public Shared ReadOnly Property SheetNumberDuplicated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SheetNumberDuplicated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SheetFailures Class


SheetNumberEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..SheetFailures..::..SheetNumberEmpty Property
BuiltInFailures..::..SheetFailures Class See Also Send Feedback
Sheet Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SheetNumberEmpty { get; }
Visual Basic
Public Shared ReadOnly Property SheetNumberEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SheetNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SheetFailures Class


BuiltInFailures.SiteFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SiteFailures
Visual Basic
Public NotInheritable Class SiteFailures
Visual C++
public ref class SiteFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SiteFailures

See Also

BuiltInFailures..::..SiteFailures Members


BuiltInFailures.SiteFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SiteFailures Members
BuiltInFailures..::..SiteFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForRegion | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoHostForRegionWarn | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoSurfPatternOnSite | Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.

See Also

BuiltInFailures..::..SiteFailures Class


BuiltInFailures.SiteFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SiteFailures Properties
BuiltInFailures..::..SiteFailures Class See Also Send Feedback

The BuiltInFailures..::..SiteFailures type exposes the following members.

Properties

Name | Description
BuildingPadNotConnected | Can't create a single Pad with several connected regions.
BuildingPadOverlap | Pads can't overlap (but can share edges).
CannotComputeProperArea | Property Lines must close. Area will not be computed.
CannotIntersectSiteRegions | Subregions cannot intersect.
CannotMakeSurface | Can't construct surface.
ContourLabelEmpty | Contour Label doesn't intersect any contours.
EnterValueOrFormula | Enter a value or a formula starting with '='.
GradingInSamePhase | The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
NoHostForRegion | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoHostForRegionWarn | Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.
NoSurfPatternOnSite | Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.
NotEnoughPointsInSurface | The surface must have at least three distinct Points.
PointNotInSurface | A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
PointRelativeOutside | In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
PropertyIntersect | Property lines intersect. Area calculations will not be precise.
RegionPhaseMismatch | Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
ResetToposurfacePhaseCreated | The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
SiteEditPointsClipped | Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
SiteEditPointsInvisible | In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.
SiteMergeDisconnected | The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
SitePhasesDontOverlap | The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
SiteRegionOptionConflict | Subregions must be in the same Design Option as their Toposurface.
SurfaceSelfIntersection | The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
SurfaceSplit | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitError | The splitting boundary must split the Surface into exactly two pieces.
SurfaceSplitNoIntersection | The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
SurfaceTriangulationFailed | The Site Surface failed to triangulate.

See Also

BuiltInFailures..::..SiteFailures Class


BuildingPadNotConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..BuildingPadNotConnected Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Can't create a single Pad with several connected regions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


BuildingPadOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..BuildingPadOverlap Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Pads can't overlap (but can share edges).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadOverlap { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


CannotComputeProperArea Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..CannotComputeProperArea Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Property Lines must close. Area will not be computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeProperArea { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeProperArea As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeProperArea {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


CannotIntersectSiteRegions Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..CannotIntersectSiteRegions Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregions cannot intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotIntersectSiteRegions { get; }
Visual Basic
Public Shared ReadOnly Property CannotIntersectSiteRegions As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotIntersectSiteRegions {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


CannotMakeSurface Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..CannotMakeSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Can't construct surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeSurface { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


ContourLabelEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..ContourLabelEmpty Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Contour Label doesn't intersect any contours.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContourLabelEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ContourLabelEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContourLabelEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


EnterValueOrFormula Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..EnterValueOrFormula Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Enter a value or a formula starting with '='.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EnterValueOrFormula { get; }
Visual Basic
Public Shared ReadOnly Property EnterValueOrFormula As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EnterValueOrFormula {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


GradingInSamePhase Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..GradingInSamePhase Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId GradingInSamePhase { get; }
Visual Basic
Public Shared ReadOnly Property GradingInSamePhase As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ GradingInSamePhase {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NoHostForRegion Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..NoHostForRegion Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoHostForRegion { get; }
Visual Basic
Public Shared ReadOnly Property NoHostForRegion As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoHostForRegion {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NoHostForRegionWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..NoHostForRegionWarn Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregion does not appear to overlap a Toposurface with an appropriate Phase and Design Option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoHostForRegionWarn { get; }
Visual Basic
Public Shared ReadOnly Property NoHostForRegionWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoHostForRegionWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NoSurfPatternOnSite Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..NoSurfPatternOnSite Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Topographical surfaces do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoSurfPatternOnSite { get; }
Visual Basic
Public Shared ReadOnly Property NoSurfPatternOnSite As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoSurfPatternOnSite {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


NotEnoughPointsInSurface Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..NotEnoughPointsInSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The surface must have at least three distinct Points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughPointsInSurface { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughPointsInSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughPointsInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PointNotInSurface Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..PointNotInSurface Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PointNotInSurface { get; }
Visual Basic
Public Shared ReadOnly Property PointNotInSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointNotInSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PointRelativeOutside Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..PointRelativeOutside Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PointRelativeOutside { get; }
Visual Basic
Public Shared ReadOnly Property PointRelativeOutside As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PointRelativeOutside {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


PropertyIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..PropertyIntersect Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Property lines intersect. Area calculations will not be precise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PropertyIntersect { get; }
Visual Basic
Public Shared ReadOnly Property PropertyIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PropertyIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


RegionPhaseMismatch Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..RegionPhaseMismatch Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RegionPhaseMismatch { get; }
Visual Basic
Public Shared ReadOnly Property RegionPhaseMismatch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RegionPhaseMismatch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


ResetToposurfacePhaseCreated Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..ResetToposurfacePhaseCreated Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ResetToposurfacePhaseCreated { get; }
Visual Basic
Public Shared ReadOnly Property ResetToposurfacePhaseCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ResetToposurfacePhaseCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteEditPointsClipped Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SiteEditPointsClipped Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SiteEditPointsClipped { get; }
Visual Basic
Public Shared ReadOnly Property SiteEditPointsClipped As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsClipped {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteEditPointsInvisible Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SiteEditPointsInvisible Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
In your currently active view, topographic elements are not visible. You can change the visibility settings from the View menu, but it is recommended that you edit topography in either a Site view or a 3D view, as undesired clipping can occur in other views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SiteEditPointsInvisible { get; }
Visual Basic
Public Shared ReadOnly Property SiteEditPointsInvisible As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteEditPointsInvisible {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteMergeDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SiteMergeDisconnected Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SiteMergeDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property SiteMergeDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteMergeDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SitePhasesDontOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SitePhasesDontOverlap Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SitePhasesDontOverlap { get; }
Visual Basic
Public Shared ReadOnly Property SitePhasesDontOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SitePhasesDontOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SiteRegionOptionConflict Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SiteRegionOptionConflict Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
Subregions must be in the same Design Option as their Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SiteRegionOptionConflict { get; }
Visual Basic
Public Shared ReadOnly Property SiteRegionOptionConflict As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteRegionOptionConflict {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSelfIntersection Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SurfaceSelfIntersection Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSelfIntersection { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSelfIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSelfIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplit Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplitError Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplitError Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must split the Surface into exactly two pieces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplitError { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplitError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceSplitNoIntersection Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SurfaceSplitNoIntersection Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceSplitNoIntersection { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceSplitNoIntersection As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceSplitNoIntersection {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


SurfaceTriangulationFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteFailures..::..SurfaceTriangulationFailed Property
BuiltInFailures..::..SiteFailures Class See Also Send Feedback
The Site Surface failed to triangulate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceTriangulationFailed { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceTriangulationFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceTriangulationFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteFailures Class


BuiltInFailures.SiteImportFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SiteImport.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SiteImportFailures
Visual Basic
Public NotInheritable Class SiteImportFailures
Visual C++
public ref class SiteImportFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SiteImportFailures

See Also

BuiltInFailures..::..SiteImportFailures Members


BuiltInFailures.SiteImportFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures Members
BuiltInFailures..::..SiteImportFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooLarge | There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::..SiteImportFailures Class


BuiltInFailures.SiteImportFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures Properties
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback

The BuiltInFailures..::..SiteImportFailures type exposes the following members.

Properties

Name | Description
BoundaryDetectError | A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.
ContoursNoncontours | The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.
DifferentEntityTypes | Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.
NoPoints | No points were found in the file.
NoViewSpecificSiteImports | Can't make Toposurface from View Specific Imports.
SurfaceExists | You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.
TooFarAway | Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.
TooLarge | There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface
TooManyMeshes | The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.
UnusedPoints | Some rows from the file could not be used.

See Also

BuiltInFailures..::..SiteImportFailures Class


BoundaryDetectError Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..BoundaryDetectError Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
A boundary on this surface could not be autodetected. Revit will impose one, but it may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BoundaryDetectError { get; }
Visual Basic
Public Shared ReadOnly Property BoundaryDetectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BoundaryDetectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


ContoursNoncontours Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..ContoursNoncontours Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
The layers you have selected contain both contour lines and non-contour lines (lines of non-constant elevation). You may want to go back and select fewer layers, or you can continue, but the boundary of the site may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContoursNoncontours { get; }
Visual Basic
Public Shared ReadOnly Property ContoursNoncontours As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContoursNoncontours {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


DifferentEntityTypes Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..DifferentEntityTypes Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Can’t auto-detect boundary. The layers selected contain data that may make the Toposurface look incorrect. For better results, try selecting only those layers that contain relevant 3D info.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DifferentEntityTypes { get; }
Visual Basic
Public Shared ReadOnly Property DifferentEntityTypes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DifferentEntityTypes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


NoPoints Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..NoPoints Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
No points were found in the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoPoints { get; }
Visual Basic
Public Shared ReadOnly Property NoPoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


NoViewSpecificSiteImports Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..NoViewSpecificSiteImports Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Can't make Toposurface from View Specific Imports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoViewSpecificSiteImports { get; }
Visual Basic
Public Shared ReadOnly Property NoViewSpecificSiteImports As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoViewSpecificSiteImports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


SurfaceExists Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..SurfaceExists Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
You are importing data into a surface that already contains points. You may want to go back, create a new surface, and import the data into that instead. You can continue, and Revit will sew the meshes together, but the boundary may be larger than you want.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SurfaceExists { get; }
Visual Basic
Public Shared ReadOnly Property SurfaceExists As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SurfaceExists {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooFarAway Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..TooFarAway Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Imported Toposurface Points are located a large distance from the model and might not display properly. Points will be centered on the model instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooFarAway { get; }
Visual Basic
Public Shared ReadOnly Property TooFarAway As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooFarAway {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..TooLarge Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
There are too many points on the selected layers of this dataset to place into the toposurface. Try selecting fewer layers to create the surface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooLarge { get; }
Visual Basic
Public Shared ReadOnly Property TooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


TooManyMeshes Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..TooManyMeshes Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
The layers you have selected contain more than one mesh. You may want to go back and import the meshes separately. If you continue, the meshes will be combined and a new boundary will be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyMeshes { get; }
Visual Basic
Public Shared ReadOnly Property TooManyMeshes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyMeshes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


UnusedPoints Property

[image]

Revit 2013 API
BuiltInFailures..::..SiteImportFailures..::..UnusedPoints Property
BuiltInFailures..::..SiteImportFailures Class See Also Send Feedback
Some rows from the file could not be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnusedPoints { get; }
Visual Basic
Public Shared ReadOnly Property UnusedPoints As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnusedPoints {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SiteImportFailures Class


BuiltInFailures.SketchFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SketchFailures
Visual Basic
Public NotInheritable Class SketchFailures
Visual C++
public ref class SketchFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SketchFailures

See Also

BuiltInFailures..::..SketchFailures Members


BuiltInFailures.SketchFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SketchFailures Members
BuiltInFailures..::..SketchFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
CircleMultiPlanarShapeInSketch | A circle can't be converted to multiplanar shape.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
HostFinishOverlapOld | Host Finish overlapped.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LandingNotEnoughBoundaryCurves | Sketch landing require boundaries
LandingTwoManyLoops | Sketch landing can only have one closed loop
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MoreThanOneAxis | More than one axes of revolution.
MutipleStairsPathInOneRunFailure | Each stairs run can only have one stairs path.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path cannot be a closed loop.
PathCannotBeClosedLoopPath3d | Path cannot be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PlanarMultiPlanarShapeInSketch | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
RunInvalidSketch | Invalid sketch, can't create run by this sketch
RunNotEnoughBoundaryCurves | Sketch run require boundaries (chains of one or more Boundary Lines)
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchedRunInvalidPath | Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairOnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairRiserDoesntIntersectBoundaryError | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::..SketchFailures Class


BuiltInFailures.SketchFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SketchFailures Properties
BuiltInFailures..::..SketchFailures Class See Also Send Feedback

The BuiltInFailures..::..SketchFailures type exposes the following members.

Properties

Name | Description
AreaLoadNoForce | Area Load can't have all force components equal to zero.
AxisNotSpecified | Axis of revolution not specified.
BadNosingProfile | Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.
BadRailingsProfile | Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.
BeamDirectionNotSpecified | Beam direction not specified.
BeamDirectionNotSpecifiedError | Beam direction not specified.
BuildingPadNoSurface | A Pad can't extend beyond the edge of a Toposurface.
BuildingPadNoSurfaceError | A Pad can't extend beyond the edge of a Toposurface.
CannotChangeUserSketchPlane | Can't change plane of [Element Name] Sketch.
CannotChangeUserSketchPlaneError | Can't change plane of [Element Name] Sketch.
CannotChangeWorkplaneVisibility | Can't change Work Plane Visibility.
CannotComputeRailingsElevation | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationError | Can't compute Railings Elevation Profile.
CannotComputeRailingsElevationWarn | Can't compute Railings Elevation Profile
CannotConvertSketch | Can't convert Sketch to Rebar Shape.
CannotDrawExtrusionRoof | Can't make extruded roof.
CannotDrawProfileRoof | Can't make footprint roof.
CannotGetSketchReferences | Cannot find references to dimension sketch.
CannotHaveArcs | Sorry, we can't use arcs here.
CannotHaveArcsPath3d | Sorry, we can't use arcs here.
CircleMultiPlanarShapeInSketch | A circle can't be converted to multiplanar shape.
ClosedProfileRoof | Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.
ConstantHeightNotParallel | Constant-height-defining lines must be parallel.
ConstantHeightNotParallelError | Constant-height-defining lines must be parallel.
ContainedInOtherLoops | When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.
ConvertSplineToLineFailed | Failed to convert spline to straight line
CurveFromPickedFailed | Can't create boundary from pick.
CurveIntersectsCutFace | The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.
CurveIntersectsSplitFace | The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.
CurveTooShort | Line is too short.
DifferentOffsets | Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.
ElementsSketchTooLarge | The sketch defining the highlighted element is too large.
EndsNotOnCutFace | Ends of the sketched loop do not lie on the boundary of the face being modified.
EndsNotOnEdge | Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
FloorCannotAddDirectionCurve | Cannot add the direction curve in the floor sketch.
FloorCannotAddDirectionCurveError | Cannot add the direction curve in the floor sketch.
FloorDirectionNotSpecified | Structural floor span direction not specified.
FloorManyDirectionCurves | More than one span direction curve specified.
HostFinishOverlapOld | Host Finish overlapped.
InvalidAreaLoadSketch | Area Load has invalid Sketch.
InvalidAreaLoadSketchError | Area Load has invalid Sketch.
InvalidElevationSketch | Elevation Profile sketch is invalid.
InvalidElevationSketchError | Elevation Profile sketch is invalid.
InvalidProfile | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidProfileError | One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.
InvalidRoofCurveloop | Base sketch for roof is invalid.
InvalidRoofCurveloopError | Base sketch for roof is invalid
InvalidRoofCurveloopFailure | Base sketch for roof is invalid
InvalidSketch | Sketch is invalid.
InvalidSketchError | Sketch is invalid.
InvalidSketchForBuildingpad | Pad sketch is invalid.
InvalidSketchForCeiling | Ceiling sketch is invalid.
InvalidSketchForFloor | Floor sketch is invalid.
InvalidSketchForRoofsoffit | Roof Soffit sketch is invalid.
InvalidSketchPath3d | Sketch is invalid.
LandingNotEnoughBoundaryCurves | Sketch landing require boundaries
LandingTwoManyLoops | Sketch landing can only have one closed loop
LinesOverlap | Cannot have overlapping lines.
LinesOverlapError | Cannot have overlapping lines.
LinesOverlapPath3d | Cannot have overlapping lines.
LoopIntersect | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectError | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopIntersectPath3d | Lines cannot intersect each other. The highlighted lines currently intersect.
LoopsOutsideFaceSplit | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
LoopsOutsideFaceSplitterTooShort | Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
ManyCCWLoops | Area defined by sketch must be connected.
ManyCCWLoopsError | Area defined by sketch must be connected.
ManyDirectionCurves | More than one direction curve specified.
ManyDirectionCurvesError | More than one direction curve specified.
MoreThanOneAxis | More than one axes of revolution.
MutipleStairsPathInOneRunFailure | Each stairs run can only have one stairs path.
NestedLoops | Cannot have nested loops.
NoLoops | Sketch is empty.
NoLoopsError | Sketch is empty.
NoLoopsPath3d | Sketch is empty.
NonMonotoneRoof | All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.
NoPlane | Highlighted geometry no longer determines a plane
NotOneCCWLoop | This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.
NotOneCurve | More than one curve not allowed.
NotOneCurveError | More than one curve not allowed.
NotOneCurvePath3d | More than one curve not allowed.
NotOneLoop | More than one loop not allowed.
NotOneLoopPath3d | More than one loop not allowed.
OpenAreaLoadLoop | Area Load Sketch can't contain open loops.
OpenAreaLoadLoopError | Area Load Sketch can't contain open loops.
OpenLoop | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopError | Lines must be in closed loops. The highlighted lines are open on one end.
OpenLoopPath3d | Lines must be in closed loops. The highlighted lines are open on one end.
PathCannotBeClosedLoop | Path cannot be a closed loop.
PathCannotBeClosedLoopPath3d | Path cannot be a closed loop.
PathReinforcementClosedLoop | Sketch contains a closed loop. Can't create Path Reinforcement.
PathReinforcementEmptySketch | Sketch is empty. Can't create Path Reinforcement.
PathReinforcementManyLoops | Sketch contains more than one chain. Can't create Path Reinforcement.
PlanarMultiPlanarShapeInSketch | The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingDoublyConnectedError | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailingNotConnectedError | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RebarEmptySketch | Rebar Sketch is empty. Can't create Rebar.
RebarEmptySketchError | Rebar Sketch is empty. Can't create Rebar.
RebarManyLoops | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarManyLoopsError | Rebar Sketch contains more than one loop. Can't create Rebar.
RebarSystemDirectionNotSpecified | Major direction not specified.
RebarSystemDirectionNotSpecifiedError | Major direction not specified.
RunInvalidSketch | Invalid sketch, can't create run by this sketch
RunNotEnoughBoundaryCurves | Sketch run require boundaries (chains of one or more Boundary Lines)
SculptingCurvesCannotFormClosedLoop | Curves cannot form a closed loop.
SculptingCurvesCrossAxis | The highlighted curves cross the axis.
SculptingCurvesTouchAxis | The highlighted curves touch the axis.
SculptingLoopsOnBothSidesOfAxis | All curves must be on the same side of the axis.
SculptingSingleLineLoopLiesOnAxis | The highlighted lines lie on the axis.
ShortCurveInSketch | The sketch contains an extremely short line.
ShortCurveInSketchRoof | The sketch contains an extremely short line.
SiteCannotDrawSurfaceBoundary | Cannot make surface with specified boundary.
SketchedRunInvalidPath | Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.
SketchFailurePlanes | Sketch is no longer parallel to its defining plane
SketchingInTheWrongView | Detail sketch is only editable in [View Type].
SketchingInWrongView | Detail sketch is not editable in this view.
SketchOverconstrained | Sketch is overconstrained.
SketchOverconstrainedError | Sketch is overconstrained.
SketchOverconstrainedWarn | Sketch is overconstrained.
SketchTooLarge | Sketch is too large.
SketchWasDeleted | Sketch was deleted.
StairClosedBoundaries | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairClosedBoundariesError | Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.
StairNotEnoughBoundaryCurves | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughBoundaryCurvesError | Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.
StairNotEnoughRiserCurves | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairNotEnoughRiserCurvesError | Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.
StairOnlyOneConnectedBoundary | Stairs require no less than two boundaries (chains of one or more Boundary Lines)."
StairOnlyOneConnectedBoundaryError | Stairs require no less than two boundaries (chains of one or more Boundary Lines).
StairRiserDoesntIntersectBoundary | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairRiserDoesntIntersectBoundaryError | The line representing the top of a riser does not intersect one or both of the boundary lines.
StairTooManyConnectedBoundaries | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
StairTooManyConnectedBoundariesError | Stairs require no more than two boundaries (chains of one or more Boundary Lines).
SuggestMakingFamilyNonParametric | Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.
SuspendedSketchWarn | Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem
TooFewParamsForSketch | The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.
TooManyElementsInSketch | This sketch is large. Performance will improve if constructed as several independent sketches.
TooManySlopes | There is more than one slope defined.
TooManySlopesError | There is more than one slope defined.
TrussClosedReference | Truss references (chains of one or more reference lines) should not form closed loops."
TrussCrossingReferences | Truss top and bottom references cannot cross.
TrussMissingReference | Trusses require both a top and a bottom chord reference (chain of one or more reference lines).
TrussOverlappingReference | Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.
TrussSegmentedReference | Truss reference must form a continuous chain of one or more sketch lines.
TrussShiftedReferences | Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.
TrussSwappedReferences | Truss top reference must be above the bottom reference.
UnsatisfiedSupportAssocProp | Constraint between a Line created with Pick Support and the Support is not satisfied.
UnsatisfiedWallAssocProp | Constraint between a Line created with Pick Wall and the Wall is not satisfied.
VarSketchFailure | Constraints defined by highlighted Lines and Dimensions can't be satisfied.
VarSketchInElementFailure | The constraints of the sketch defining the highlighted element cannot be satisfied.
WrongCutBoundaryLoops | Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.
WrongFaceSplitterLoopTypesNum | Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

See Also

BuiltInFailures..::..SketchFailures Class


AreaLoadNoForce Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..AreaLoadNoForce Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load can't have all force components equal to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AreaLoadNoForce { get; }
Visual Basic
Public Shared ReadOnly Property AreaLoadNoForce As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AreaLoadNoForce {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


AxisNotSpecified Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..AxisNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Axis of revolution not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AxisNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property AxisNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AxisNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BadNosingProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BadNosingProfile Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs nosing profile must have one loop. Wrong profile will not be shown in profiles list in Stairs Type properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadNosingProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadNosingProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadNosingProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BadRailingsProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BadRailingsProfile Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rail profile must have one closed loop. Wrong profile will not be shown in profiles list for rail definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailingsProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadRailingsProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailingsProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BeamDirectionNotSpecified Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BeamDirectionNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BeamDirectionNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property BeamDirectionNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BeamDirectionNotSpecifiedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BeamDirectionNotSpecifiedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Beam direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BeamDirectionNotSpecifiedError { get; }
Visual Basic
Public Shared ReadOnly Property BeamDirectionNotSpecifiedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BeamDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuildingPadNoSurface Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BuildingPadNoSurface Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurface { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNoSurface As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurface {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuildingPadNoSurfaceError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..BuildingPadNoSurfaceError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A Pad can't extend beyond the edge of a Toposurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BuildingPadNoSurfaceError { get; }
Visual Basic
Public Shared ReadOnly Property BuildingPadNoSurfaceError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BuildingPadNoSurfaceError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeUserSketchPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotChangeUserSketchPlane Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlane { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeUserSketchPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeUserSketchPlaneError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotChangeUserSketchPlaneError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change plane of [Element Name] Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeUserSketchPlaneError { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeUserSketchPlaneError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeUserSketchPlaneError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotChangeWorkplaneVisibility Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotChangeWorkplaneVisibility Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't change Work Plane Visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeWorkplaneVisibility { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeWorkplaneVisibility As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeWorkplaneVisibility {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotComputeRailingsElevation Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotComputeRailingsElevation Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevation { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailingsElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotComputeRailingsElevationError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotComputeRailingsElevationError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationError { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailingsElevationError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotComputeRailingsElevationWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotComputeRailingsElevationWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't compute Railings Elevation Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailingsElevationWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailingsElevationWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailingsElevationWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotConvertSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotConvertSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't convert Sketch to Rebar Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotConvertSketch { get; }
Visual Basic
Public Shared ReadOnly Property CannotConvertSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotConvertSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotDrawExtrusionRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotDrawExtrusionRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't make extruded roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawExtrusionRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawExtrusionRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawExtrusionRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotDrawProfileRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotDrawProfileRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't make footprint roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawProfileRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawProfileRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotGetSketchReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotGetSketchReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot find references to dimension sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGetSketchReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotGetSketchReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGetSketchReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotHaveArcs Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotHaveArcs Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveArcs { get; }
Visual Basic
Public Shared ReadOnly Property CannotHaveArcs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotHaveArcs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CannotHaveArcsPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CannotHaveArcsPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sorry, we can't use arcs here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotHaveArcsPath3d { get; }
Visual Basic
Public Shared ReadOnly Property CannotHaveArcsPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotHaveArcsPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CircleMultiPlanarShapeInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CircleMultiPlanarShapeInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
A circle can't be converted to multiplanar shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CircleMultiPlanarShapeInSketch { get; }
Visual Basic
Public Shared ReadOnly Property CircleMultiPlanarShapeInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CircleMultiPlanarShapeInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ClosedProfileRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ClosedProfileRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Extrusion roof sketch must be open. The roof's thickness and material composition are defined in its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedProfileRoof { get; }
Visual Basic
Public Shared ReadOnly Property ClosedProfileRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClosedProfileRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ConstantHeightNotParallel Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ConstantHeightNotParallel Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConstantHeightNotParallel { get; }
Visual Basic
Public Shared ReadOnly Property ConstantHeightNotParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstantHeightNotParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ConstantHeightNotParallelError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ConstantHeightNotParallelError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constant-height-defining lines must be parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConstantHeightNotParallelError { get; }
Visual Basic
Public Shared ReadOnly Property ConstantHeightNotParallelError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstantHeightNotParallelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ContainedInOtherLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ContainedInOtherLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
When creating an opening, you cannot sketch loops within other loops. The highlighted loop(s) are contained within another loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContainedInOtherLoops { get; }
Visual Basic
Public Shared ReadOnly Property ContainedInOtherLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContainedInOtherLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ConvertSplineToLineFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ConvertSplineToLineFailed Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Failed to convert spline to straight line

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConvertSplineToLineFailed { get; }
Visual Basic
Public Shared ReadOnly Property ConvertSplineToLineFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConvertSplineToLineFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveFromPickedFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CurveFromPickedFailed Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Can't create boundary from pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveFromPickedFailed { get; }
Visual Basic
Public Shared ReadOnly Property CurveFromPickedFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveFromPickedFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveIntersectsCutFace Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CurveIntersectsCutFace Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being modified. To modify a cut face, use open loops that end on the existing boundary without intersecting or overlapping existing edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveIntersectsCutFace { get; }
Visual Basic
Public Shared ReadOnly Property CurveIntersectsCutFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsCutFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveIntersectsSplitFace Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CurveIntersectsSplitFace Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted line intersects the boundary of the face being split. To split a face at its border, use an open loop that ends on the boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveIntersectsSplitFace { get; }
Visual Basic
Public Shared ReadOnly Property CurveIntersectsSplitFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveIntersectsSplitFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


CurveTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..CurveTooShort Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Line is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property CurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


DifferentOffsets Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..DifferentOffsets Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Adjacent slope-defining lines must have identical eave heights; the highlighted lines do not. You can use the Align Eaves tool to have the eaves aligned for you.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DifferentOffsets { get; }
Visual Basic
Public Shared ReadOnly Property DifferentOffsets As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DifferentOffsets {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ElementsSketchTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ElementsSketchTooLarge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch defining the highlighted element is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsSketchTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property ElementsSketchTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsSketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


EndsNotOnCutFace Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..EndsNotOnCutFace Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Ends of the sketched loop do not lie on the boundary of the face being modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnCutFace { get; }
Visual Basic
Public Shared ReadOnly Property EndsNotOnCutFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnCutFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


EndsNotOnEdge Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..EndsNotOnEdge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EndsNotOnEdge { get; }
Visual Basic
Public Shared ReadOnly Property EndsNotOnEdge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EndsNotOnEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorCannotAddDirectionCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..FloorCannotAddDirectionCurve Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurve { get; }
Visual Basic
Public Shared ReadOnly Property FloorCannotAddDirectionCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorCannotAddDirectionCurveError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..FloorCannotAddDirectionCurveError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot add the direction curve in the floor sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorCannotAddDirectionCurveError { get; }
Visual Basic
Public Shared ReadOnly Property FloorCannotAddDirectionCurveError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorCannotAddDirectionCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorDirectionNotSpecified Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..FloorDirectionNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Structural floor span direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorDirectionNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property FloorDirectionNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


FloorManyDirectionCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..FloorManyDirectionCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one span direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FloorManyDirectionCurves { get; }
Visual Basic
Public Shared ReadOnly Property FloorManyDirectionCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FloorManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


HostFinishOverlapOld Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..HostFinishOverlapOld Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Host Finish overlapped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HostFinishOverlapOld { get; }
Visual Basic
Public Shared ReadOnly Property HostFinishOverlapOld As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HostFinishOverlapOld {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidAreaLoadSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidAreaLoadSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidAreaLoadSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidAreaLoadSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidAreaLoadSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidAreaLoadSketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidAreaLoadSketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load has invalid Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidAreaLoadSketchError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidAreaLoadSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidAreaLoadSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidElevationSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidElevationSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElevationSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElevationSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidElevationSketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidElevationSketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Elevation Profile sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidElevationSketchError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElevationSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidElevationSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidProfile Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidProfile { get; }
Visual Basic
Public Shared ReadOnly Property InvalidProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidProfileError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidProfileError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
One or more profiles are invalid. Make sure that every used profile is a closed loop of non-intersecting lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidProfileError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidProfileError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidProfileError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidRoofCurveloop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidRoofCurveloop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloop { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRoofCurveloop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidRoofCurveloopError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidRoofCurveloopError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRoofCurveloopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidRoofCurveloopFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidRoofCurveloopFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Base sketch for roof is invalid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRoofCurveloopFailure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRoofCurveloopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRoofCurveloopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketch { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForBuildingpad Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForBuildingpad Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Pad sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForBuildingpad { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForBuildingpad As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForBuildingpad {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForCeiling Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForCeiling Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Ceiling sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForCeiling { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForCeiling As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForCeiling {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForFloor Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForFloor Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Floor sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForFloor { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForFloor As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForFloor {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchForRoofsoffit Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchForRoofsoffit Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Roof Soffit sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchForRoofsoffit { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchForRoofsoffit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchForRoofsoffit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


InvalidSketchPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..InvalidSketchPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidSketchPath3d { get; }
Visual Basic
Public Shared ReadOnly Property InvalidSketchPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidSketchPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LandingNotEnoughBoundaryCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LandingNotEnoughBoundaryCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch landing require boundaries

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LandingNotEnoughBoundaryCurves { get; }
Visual Basic
Public Shared ReadOnly Property LandingNotEnoughBoundaryCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LandingTwoManyLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LandingTwoManyLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch landing can only have one closed loop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LandingTwoManyLoops { get; }
Visual Basic
Public Shared ReadOnly Property LandingTwoManyLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingTwoManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlap Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LinesOverlap Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlap { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlap As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlap {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlapError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LinesOverlapError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlapError { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlapError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LinesOverlapPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LinesOverlapPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have overlapping lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LinesOverlapPath3d { get; }
Visual Basic
Public Shared ReadOnly Property LinesOverlapPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LinesOverlapPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersect Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LoopIntersect Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersect { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersect As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersect {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersectError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LoopIntersectError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersectError { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersectError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopIntersectPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LoopIntersectPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines cannot intersect each other. The highlighted lines currently intersect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopIntersectPath3d { get; }
Visual Basic
Public Shared ReadOnly Property LoopIntersectPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopIntersectPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopsOutsideFaceSplit Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LoopsOutsideFaceSplit Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplit { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplit As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplit {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


LoopsOutsideFaceSplitterTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..LoopsOutsideFaceSplitterTooShort Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LoopsOutsideFaceSplitterTooShort { get; }
Visual Basic
Public Shared ReadOnly Property LoopsOutsideFaceSplitterTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LoopsOutsideFaceSplitterTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyCCWLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ManyCCWLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyCCWLoops { get; }
Visual Basic
Public Shared ReadOnly Property ManyCCWLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyCCWLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyCCWLoopsError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ManyCCWLoopsError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area defined by sketch must be connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyCCWLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property ManyCCWLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyCCWLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyDirectionCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ManyDirectionCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyDirectionCurves { get; }
Visual Basic
Public Shared ReadOnly Property ManyDirectionCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ManyDirectionCurvesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ManyDirectionCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one direction curve specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ManyDirectionCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property ManyDirectionCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ManyDirectionCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


MoreThanOneAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..MoreThanOneAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one axes of revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MoreThanOneAxis { get; }
Visual Basic
Public Shared ReadOnly Property MoreThanOneAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MoreThanOneAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


MutipleStairsPathInOneRunFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..MutipleStairsPathInOneRunFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Each stairs run can only have one stairs path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MutipleStairsPathInOneRunFailure { get; }
Visual Basic
Public Shared ReadOnly Property MutipleStairsPathInOneRunFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MutipleStairsPathInOneRunFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NestedLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NestedLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot have nested loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NestedLoops { get; }
Visual Basic
Public Shared ReadOnly Property NestedLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NestedLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NoLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NoLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoops { get; }
Visual Basic
Public Shared ReadOnly Property NoLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NoLoopsError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NoLoopsError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property NoLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NoLoopsPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NoLoopsPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoLoopsPath3d { get; }
Visual Basic
Public Shared ReadOnly Property NoLoopsPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoLoopsPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NonMonotoneRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NonMonotoneRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
All parts of an extruded roof must face upward. Make sure that no part of the sketch lies below any other part of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonMonotoneRoof { get; }
Visual Basic
Public Shared ReadOnly Property NonMonotoneRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonMonotoneRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NoPlane Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NoPlane Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Highlighted geometry no longer determines a plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoPlane { get; }
Visual Basic
Public Shared ReadOnly Property NoPlane As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoPlane {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCCWLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneCCWLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
This sketch defines more than one footprint. Make sure the sketch contains only one outermost loop and that there are no loops inside inner loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCCWLoop { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCCWLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCCWLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneCurve Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurve { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCurveError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneCurveError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurveError { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCurveError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCurveError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneCurvePath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneCurvePath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one curve not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneCurvePath3d { get; }
Visual Basic
Public Shared ReadOnly Property NotOneCurvePath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneCurvePath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneLoop { get; }
Visual Basic
Public Shared ReadOnly Property NotOneLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


NotOneLoopPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..NotOneLoopPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
More than one loop not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotOneLoopPath3d { get; }
Visual Basic
Public Shared ReadOnly Property NotOneLoopPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotOneLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenAreaLoadLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..OpenAreaLoadLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoop { get; }
Visual Basic
Public Shared ReadOnly Property OpenAreaLoadLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenAreaLoadLoopError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..OpenAreaLoadLoopError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Area Load Sketch can't contain open loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenAreaLoadLoopError { get; }
Visual Basic
Public Shared ReadOnly Property OpenAreaLoadLoopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenAreaLoadLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..OpenLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoop { get; }
Visual Basic
Public Shared ReadOnly Property OpenLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenLoopError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..OpenLoopError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoopError { get; }
Visual Basic
Public Shared ReadOnly Property OpenLoopError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenLoopError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


OpenLoopPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..OpenLoopPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Lines must be in closed loops. The highlighted lines are open on one end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OpenLoopPath3d { get; }
Visual Basic
Public Shared ReadOnly Property OpenLoopPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OpenLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathCannotBeClosedLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PathCannotBeClosedLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property PathCannotBeClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathCannotBeClosedLoopPath3d Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PathCannotBeClosedLoopPath3d Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Path cannot be a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathCannotBeClosedLoopPath3d { get; }
Visual Basic
Public Shared ReadOnly Property PathCannotBeClosedLoopPath3d As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathCannotBeClosedLoopPath3d {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathReinforcementClosedLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PathReinforcementClosedLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch contains a closed loop. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathReinforcementEmptySketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PathReinforcementEmptySketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is empty. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementEmptySketch { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementEmptySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PathReinforcementManyLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PathReinforcementManyLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch contains more than one chain. Can't create Path Reinforcement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathReinforcementManyLoops { get; }
Visual Basic
Public Shared ReadOnly Property PathReinforcementManyLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathReinforcementManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


PlanarMultiPlanarShapeInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..PlanarMultiPlanarShapeInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The current shape is only bent in a single plane. A multi-planar definition is not required. Please redefine the shape on the top plane only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PlanarMultiPlanarShapeInSketch { get; }
Visual Basic
Public Shared ReadOnly Property PlanarMultiPlanarShapeInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PlanarMultiPlanarShapeInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingDoublyConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RailingDoublyConnected Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingDoublyConnectedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RailingDoublyConnectedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingNotConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RailingNotConnected Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RailingNotConnectedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RailingNotConnectedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnectedError { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnectedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnectedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarEmptySketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarEmptySketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarEmptySketch { get; }
Visual Basic
Public Shared ReadOnly Property RebarEmptySketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarEmptySketchError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarEmptySketchError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch is empty. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarEmptySketchError { get; }
Visual Basic
Public Shared ReadOnly Property RebarEmptySketchError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarEmptySketchError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarManyLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarManyLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarManyLoops { get; }
Visual Basic
Public Shared ReadOnly Property RebarManyLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarManyLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarManyLoopsError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarManyLoopsError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Rebar Sketch contains more than one loop. Can't create Rebar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarManyLoopsError { get; }
Visual Basic
Public Shared ReadOnly Property RebarManyLoopsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarManyLoopsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarSystemDirectionNotSpecified Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarSystemDirectionNotSpecified Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecified { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemDirectionNotSpecified As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecified {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RebarSystemDirectionNotSpecifiedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RebarSystemDirectionNotSpecifiedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Major direction not specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RebarSystemDirectionNotSpecifiedError { get; }
Visual Basic
Public Shared ReadOnly Property RebarSystemDirectionNotSpecifiedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RebarSystemDirectionNotSpecifiedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RunInvalidSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RunInvalidSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Invalid sketch, can't create run by this sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunInvalidSketch { get; }
Visual Basic
Public Shared ReadOnly Property RunInvalidSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunInvalidSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


RunNotEnoughBoundaryCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..RunNotEnoughBoundaryCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch run require boundaries (chains of one or more Boundary Lines)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunNotEnoughBoundaryCurves { get; }
Visual Basic
Public Shared ReadOnly Property RunNotEnoughBoundaryCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesCannotFormClosedLoop Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesCannotFormClosedLoop Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Curves cannot form a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesCannotFormClosedLoop { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesCannotFormClosedLoop As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCannotFormClosedLoop {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesCrossAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesCrossAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted curves cross the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesCrossAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesCrossAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesCrossAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingCurvesTouchAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SculptingCurvesTouchAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted curves touch the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingCurvesTouchAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingCurvesTouchAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingCurvesTouchAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingLoopsOnBothSidesOfAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SculptingLoopsOnBothSidesOfAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
All curves must be on the same side of the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingLoopsOnBothSidesOfAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingLoopsOnBothSidesOfAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingLoopsOnBothSidesOfAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SculptingSingleLineLoopLiesOnAxis Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SculptingSingleLineLoopLiesOnAxis Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The highlighted lines lie on the axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SculptingSingleLineLoopLiesOnAxis { get; }
Visual Basic
Public Shared ReadOnly Property SculptingSingleLineLoopLiesOnAxis As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SculptingSingleLineLoopLiesOnAxis {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ShortCurveInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ShortCurveInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShortCurveInSketch { get; }
Visual Basic
Public Shared ReadOnly Property ShortCurveInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


ShortCurveInSketchRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..ShortCurveInSketchRoof Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketch contains an extremely short line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShortCurveInSketchRoof { get; }
Visual Basic
Public Shared ReadOnly Property ShortCurveInSketchRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShortCurveInSketchRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SiteCannotDrawSurfaceBoundary Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SiteCannotDrawSurfaceBoundary Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Cannot make surface with specified boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SiteCannotDrawSurfaceBoundary { get; }
Visual Basic
Public Shared ReadOnly Property SiteCannotDrawSurfaceBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SiteCannotDrawSurfaceBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchedRunInvalidPath Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchedRunInvalidPath Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Invalid stair path. Stair path should connect both start and end riser, and cross all other risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchedRunInvalidPath { get; }
Visual Basic
Public Shared ReadOnly Property SketchedRunInvalidPath As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchedRunInvalidPath {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchFailurePlanes Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchFailurePlanes Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is no longer parallel to its defining plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchFailurePlanes { get; }
Visual Basic
Public Shared ReadOnly Property SketchFailurePlanes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchFailurePlanes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchingInTheWrongView Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchingInTheWrongView Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Detail sketch is only editable in [View Type].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchingInTheWrongView { get; }
Visual Basic
Public Shared ReadOnly Property SketchingInTheWrongView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchingInTheWrongView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchingInWrongView Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchingInWrongView Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Detail sketch is not editable in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchingInWrongView { get; }
Visual Basic
Public Shared ReadOnly Property SketchingInWrongView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchingInWrongView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchOverconstrained Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchOverconstrained Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrained { get; }
Visual Basic
Public Shared ReadOnly Property SketchOverconstrained As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrained {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchOverconstrainedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchOverconstrainedError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrainedError { get; }
Visual Basic
Public Shared ReadOnly Property SketchOverconstrainedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrainedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchOverconstrainedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchOverconstrainedWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is overconstrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchOverconstrainedWarn { get; }
Visual Basic
Public Shared ReadOnly Property SketchOverconstrainedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchOverconstrainedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchTooLarge Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchTooLarge Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchTooLarge { get; }
Visual Basic
Public Shared ReadOnly Property SketchTooLarge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchTooLarge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SketchWasDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SketchWasDeleted Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch was deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SketchWasDeleted { get; }
Visual Basic
Public Shared ReadOnly Property SketchWasDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SketchWasDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairClosedBoundaries Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairClosedBoundaries Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairClosedBoundaries { get; }
Visual Basic
Public Shared ReadOnly Property StairClosedBoundaries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairClosedBoundariesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairClosedBoundariesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs Boundaries (chains of one or more Boundary Lines) should not form closed loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairClosedBoundariesError { get; }
Visual Basic
Public Shared ReadOnly Property StairClosedBoundariesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairClosedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughBoundaryCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughBoundaryCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurves { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughBoundaryCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughBoundaryCurvesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughBoundaryCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require boundaries (chains of one or more Boundary Lines) on each side of the Stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughBoundaryCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughBoundaryCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughBoundaryCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughRiserCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughRiserCurves Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurves { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughRiserCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairNotEnoughRiserCurvesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairNotEnoughRiserCurvesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Boundaries (chains of one or more Boundary Lines) must be connected by at least two Riser Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairNotEnoughRiserCurvesError { get; }
Visual Basic
Public Shared ReadOnly Property StairNotEnoughRiserCurvesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairNotEnoughRiserCurvesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairOnlyOneConnectedBoundary Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairOnlyOneConnectedBoundary Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no less than two boundaries (chains of one or more Boundary Lines)."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairOnlyOneConnectedBoundary { get; }
Visual Basic
Public Shared ReadOnly Property StairOnlyOneConnectedBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairOnlyOneConnectedBoundaryError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairOnlyOneConnectedBoundaryError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no less than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairOnlyOneConnectedBoundaryError { get; }
Visual Basic
Public Shared ReadOnly Property StairOnlyOneConnectedBoundaryError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairOnlyOneConnectedBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairRiserDoesntIntersectBoundary Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairRiserDoesntIntersectBoundary Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairRiserDoesntIntersectBoundary { get; }
Visual Basic
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairRiserDoesntIntersectBoundaryError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairRiserDoesntIntersectBoundaryError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The line representing the top of a riser does not intersect one or both of the boundary lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairRiserDoesntIntersectBoundaryError { get; }
Visual Basic
Public Shared ReadOnly Property StairRiserDoesntIntersectBoundaryError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairRiserDoesntIntersectBoundaryError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairTooManyConnectedBoundaries Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairTooManyConnectedBoundaries Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundaries { get; }
Visual Basic
Public Shared ReadOnly Property StairTooManyConnectedBoundaries As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundaries {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


StairTooManyConnectedBoundariesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..StairTooManyConnectedBoundariesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Stairs require no more than two boundaries (chains of one or more Boundary Lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairTooManyConnectedBoundariesError { get; }
Visual Basic
Public Shared ReadOnly Property StairTooManyConnectedBoundariesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairTooManyConnectedBoundariesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SuggestMakingFamilyNonParametric Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SuggestMakingFamilyNonParametric Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Performance Warning: This family now contains both labeled dimensions and sketches with many segments. This may hurt performance. To improve performance, create elements that require complex sketches as nested families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SuggestMakingFamilyNonParametric { get; }
Visual Basic
Public Shared ReadOnly Property SuggestMakingFamilyNonParametric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuggestMakingFamilyNonParametric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


SuspendedSketchWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..SuspendedSketchWarn Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Highlighted element's sketch could not regenerate and has been suspended. Select the element and edit its sketch to fix the problem. The element will display in magenta until you fix the problem

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SuspendedSketchWarn { get; }
Visual Basic
Public Shared ReadOnly Property SuspendedSketchWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SuspendedSketchWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooFewParamsForSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TooFewParamsForSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The sketched Structural Rebar element has too many segments to be properly parameterized. Please reduce the number of segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooFewParamsForSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooFewParamsForSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooFewParamsForSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManyElementsInSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TooManyElementsInSketch Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
This sketch is large. Performance will improve if constructed as several independent sketches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManyElementsInSketch { get; }
Visual Basic
Public Shared ReadOnly Property TooManyElementsInSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManyElementsInSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManySlopes Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TooManySlopes Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManySlopes { get; }
Visual Basic
Public Shared ReadOnly Property TooManySlopes As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManySlopes {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TooManySlopesError Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TooManySlopesError Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
There is more than one slope defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooManySlopesError { get; }
Visual Basic
Public Shared ReadOnly Property TooManySlopesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooManySlopesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussClosedReference Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussClosedReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) should not form closed loops."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussClosedReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussClosedReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussClosedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussCrossingReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussCrossingReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top and bottom references cannot cross.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussCrossingReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussCrossingReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussCrossingReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussMissingReference Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussMissingReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Trusses require both a top and a bottom chord reference (chain of one or more reference lines).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussMissingReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussMissingReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussMissingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussOverlappingReference Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussOverlappingReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss references (chains of one or more reference lines) cannot overlap themselves in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussOverlappingReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussOverlappingReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussOverlappingReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussSegmentedReference Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussSegmentedReference Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss reference must form a continuous chain of one or more sketch lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussSegmentedReference { get; }
Visual Basic
Public Shared ReadOnly Property TrussSegmentedReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussSegmentedReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussShiftedReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussShiftedReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top and bottom references (chains of one or more reference lines) must overlap at least partially in the vertical direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussShiftedReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussShiftedReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussShiftedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


TrussSwappedReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..TrussSwappedReferences Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Truss top reference must be above the bottom reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussSwappedReferences { get; }
Visual Basic
Public Shared ReadOnly Property TrussSwappedReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussSwappedReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


UnsatisfiedSupportAssocProp Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..UnsatisfiedSupportAssocProp Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Support and the Support is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnsatisfiedSupportAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property UnsatisfiedSupportAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedSupportAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


UnsatisfiedWallAssocProp Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..UnsatisfiedWallAssocProp Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraint between a Line created with Pick Wall and the Wall is not satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnsatisfiedWallAssocProp { get; }
Visual Basic
Public Shared ReadOnly Property UnsatisfiedWallAssocProp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnsatisfiedWallAssocProp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


VarSketchFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..VarSketchFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Constraints defined by highlighted Lines and Dimensions can't be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VarSketchFailure { get; }
Visual Basic
Public Shared ReadOnly Property VarSketchFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VarSketchFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


VarSketchInElementFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..VarSketchInElementFailure Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
The constraints of the sketch defining the highlighted element cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VarSketchInElementFailure { get; }
Visual Basic
Public Shared ReadOnly Property VarSketchInElementFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VarSketchInElementFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


WrongCutBoundaryLoops Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..WrongCutBoundaryLoops Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Only open loops can be used for Edit Cut Profile. All open ends must lie on the boundary of the cut profile, and the loop may not touch the boundary anywhere except at its ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongCutBoundaryLoops { get; }
Visual Basic
Public Shared ReadOnly Property WrongCutBoundaryLoops As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongCutBoundaryLoops {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


WrongFaceSplitterLoopTypesNum Property

[image]

Revit 2013 API
BuiltInFailures..::..SketchFailures..::..WrongFaceSplitterLoopTypesNum Property
BuiltInFailures..::..SketchFailures Class See Also Send Feedback
Sketch for splitting the face is invalid. Faces may be split either by a single closed loop that is contained within the face or by one or more open loops whose ends lie on the boundary of the face. None of the lines in the sketch are allowed to overlap or intersect the boundaries of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WrongFaceSplitterLoopTypesNum { get; }
Visual Basic
Public Shared ReadOnly Property WrongFaceSplitterLoopTypesNum As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WrongFaceSplitterLoopTypesNum {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SketchFailures Class


BuiltInFailures.SkylightFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SkylightFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Skylight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SkylightFailures
Visual Basic
Public NotInheritable Class SkylightFailures
Visual C++
public ref class SkylightFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SkylightFailures

See Also

BuiltInFailures..::..SkylightFailures Members


BuiltInFailures.SkylightFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SkylightFailures Members
BuiltInFailures..::..SkylightFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::..SkylightFailures Class


BuiltInFailures.SkylightFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SkylightFailures Properties
BuiltInFailures..::..SkylightFailures Class See Also Send Feedback

The BuiltInFailures..::..SkylightFailures type exposes the following members.

Properties

Name | Description
MinSkylightWidthImperial | The minimum skylight width is 8 inches.
MinSkylightWidthMetric | The minimum skylight width is 203.2 millimeters.

See Also

BuiltInFailures..::..SkylightFailures Class


MinSkylightWidthImperial Property

[image]

Revit 2013 API
BuiltInFailures..::..SkylightFailures..::..MinSkylightWidthImperial Property
BuiltInFailures..::..SkylightFailures Class See Also Send Feedback
The minimum skylight width is 8 inches.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthImperial { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthImperial As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthImperial {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SkylightFailures Class


MinSkylightWidthMetric Property

[image]

Revit 2013 API
BuiltInFailures..::..SkylightFailures..::..MinSkylightWidthMetric Property
BuiltInFailures..::..SkylightFailures Class See Also Send Feedback
The minimum skylight width is 203.2 millimeters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MinSkylightWidthMetric { get; }
Visual Basic
Public Shared ReadOnly Property MinSkylightWidthMetric As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MinSkylightWidthMetric {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SkylightFailures Class


BuiltInFailures.SlabFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SlabFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SlabFailures
Visual Basic
Public NotInheritable Class SlabFailures
Visual C++
public ref class SlabFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlabFailures

See Also

BuiltInFailures..::..SlabFailures Members


BuiltInFailures.SlabFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlabFailures Members
BuiltInFailures..::..SlabFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::..SlabFailures Class


BuiltInFailures.SlabFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlabFailures Properties
BuiltInFailures..::..SlabFailures Class See Also Send Feedback

The BuiltInFailures..::..SlabFailures type exposes the following members.

Properties

Name | Description
CantileverValueTooBig | Cantilever value is too big.

See Also

BuiltInFailures..::..SlabFailures Class


CantileverValueTooBig Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabFailures..::..CantileverValueTooBig Property
BuiltInFailures..::..SlabFailures Class See Also Send Feedback
Cantilever value is too big.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CantileverValueTooBig { get; }
Visual Basic
Public Shared ReadOnly Property CantileverValueTooBig As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CantileverValueTooBig {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabFailures Class


BuiltInFailures.SlabShapeFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlabShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SlabShapeFailures
Visual Basic
Public NotInheritable Class SlabShapeFailures
Visual C++
public ref class SlabShapeFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlabShapeFailures

See Also

BuiltInFailures..::..SlabShapeFailures Members


BuiltInFailures.SlabShapeFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures Members
BuiltInFailures..::..SlabShapeFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlabShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Roof or Floor is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Roof or Floor may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof is too thin for its given type.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::..SlabShapeFailures Class


BuiltInFailures.SlabShapeFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures Properties
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback

The BuiltInFailures..::..SlabShapeFailures type exposes the following members.

Properties

Name | Description
SlabShapeEditFailed | Slab Shape Edit failed. [Description]
SlabShapeEditFailedError | Slab Shape Edit failed. [Description]
SlabShapeFailedNotHorz | The Roof or Floor is no longer horizontal.
SlabShapeFailedNotOnlyLines | The Roof or Floor may only contain straight lines.
SlabShapeFailedTooThin | The Floor or Roof is too thin for its given type.
SlabShapeWarnVerticesDeleted | Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.
SlopedInnerEdge | Inner loops of a footprint sketch may not have slope-defining lines.
SlopeTailInsideSlopeLine | The tails of slope arrows must not lie in interior of slope defining lines.
SlopeZero | Adjusting this Line's Overhang will not affect its height because its slope is zero.

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeEditFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeEditFailed Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailed { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeEditFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeEditFailedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeEditFailedError Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Slab Shape Edit failed. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeEditFailedError { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeEditFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeEditFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedNotHorz Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedNotHorz Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Roof or Floor is no longer horizontal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotHorz { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedNotHorz As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotHorz {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedNotOnlyLines Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedNotOnlyLines Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Roof or Floor may only contain straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedNotOnlyLines { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedNotOnlyLines As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedNotOnlyLines {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeFailedTooThin Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeFailedTooThin Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The Floor or Roof is too thin for its given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeFailedTooThin { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeFailedTooThin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeFailedTooThin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlabShapeWarnVerticesDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlabShapeWarnVerticesDeleted Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Some slab shape edit vertices were deleted because the Floor or Roof has changed its shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlabShapeWarnVerticesDeleted { get; }
Visual Basic
Public Shared ReadOnly Property SlabShapeWarnVerticesDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlabShapeWarnVerticesDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopedInnerEdge Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlopedInnerEdge Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Inner loops of a footprint sketch may not have slope-defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlopedInnerEdge { get; }
Visual Basic
Public Shared ReadOnly Property SlopedInnerEdge As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopedInnerEdge {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopeTailInsideSlopeLine Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlopeTailInsideSlopeLine Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
The tails of slope arrows must not lie in interior of slope defining lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlopeTailInsideSlopeLine { get; }
Visual Basic
Public Shared ReadOnly Property SlopeTailInsideSlopeLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopeTailInsideSlopeLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


SlopeZero Property

[image]

Revit 2013 API
BuiltInFailures..::..SlabShapeFailures..::..SlopeZero Property
BuiltInFailures..::..SlabShapeFailures Class See Also Send Feedback
Adjusting this Line's Overhang will not affect its height because its slope is zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlopeZero { get; }
Visual Basic
Public Shared ReadOnly Property SlopeZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlopeZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlabShapeFailures Class


BuiltInFailures.SlantedColumnFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SlantedColumn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SlantedColumnFailures
Visual Basic
Public NotInheritable Class SlantedColumnFailures
Visual C++
public ref class SlantedColumnFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SlantedColumnFailures

See Also

BuiltInFailures..::..SlantedColumnFailures Members


BuiltInFailures.SlantedColumnFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures Members
BuiltInFailures..::..SlantedColumnFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::..SlantedColumnFailures Class


BuiltInFailures.SlantedColumnFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures Properties
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback

The BuiltInFailures..::..SlantedColumnFailures type exposes the following members.

Properties

Name | Description
CannotCutParallelToLocationCurve | Cut plane of slanted column end is parallel to the location curve.
SlantedColumnCannotCutEnd | Unable to trim slanted column end geometry to desired condition.
SlantedColumnCannotCutEndWarn | Unable to trim slanted column end geometry to desired condition.

See Also

BuiltInFailures..::..SlantedColumnFailures Class


CannotCutParallelToLocationCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures..::..CannotCutParallelToLocationCurve Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Cut plane of slanted column end is parallel to the location curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCutParallelToLocationCurve { get; }
Visual Basic
Public Shared ReadOnly Property CannotCutParallelToLocationCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCutParallelToLocationCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


SlantedColumnCannotCutEnd Property

[image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures..::..SlantedColumnCannotCutEnd Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEnd { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnCannotCutEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


SlantedColumnCannotCutEndWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..SlantedColumnFailures..::..SlantedColumnCannotCutEndWarn Property
BuiltInFailures..::..SlantedColumnFailures Class See Also Send Feedback
Unable to trim slanted column end geometry to desired condition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SlantedColumnCannotCutEndWarn { get; }
Visual Basic
Public Shared ReadOnly Property SlantedColumnCannotCutEndWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SlantedColumnCannotCutEndWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SlantedColumnFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SpanDirectionSymbolFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SpanDirectionSymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SpanDirectionSymbolFailures
Visual Basic
Public NotInheritable Class SpanDirectionSymbolFailures
Visual C++
public ref class SpanDirectionSymbolFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SpanDirectionSymbolFailures

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Members


BuiltInFailures.SpanDirectionSymbolFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SpanDirectionSymbolFailures Members
BuiltInFailures..::..SpanDirectionSymbolFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SpanDirectionSymbolFailures type exposes the following members.

Properties

Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Class


BuiltInFailures.SpanDirectionSymbolFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SpanDirectionSymbolFailures Properties
BuiltInFailures..::..SpanDirectionSymbolFailures Class See Also Send Feedback

The BuiltInFailures..::..SpanDirectionSymbolFailures type exposes the following members.

Properties

Name | Description
NonPlanView | Span Direction Symbol can only be placed in a Floor Plan View.

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Class


NonPlanView Property

[image]

Revit 2013 API
BuiltInFailures..::..SpanDirectionSymbolFailures..::..NonPlanView Property
BuiltInFailures..::..SpanDirectionSymbolFailures Class See Also Send Feedback
Span Direction Symbol can only be placed in a Floor Plan View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NonPlanView { get; }
Visual Basic
Public Shared ReadOnly Property NonPlanView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NonPlanView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SpanDirectionSymbolFailures Class


BuiltInFailures.SplineFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SplineFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SplineFailures
Visual Basic
Public NotInheritable Class SplineFailures
Visual C++
public ref class SplineFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SplineFailures

See Also

BuiltInFailures..::..SplineFailures Members


BuiltInFailures.SplineFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SplineFailures Members
BuiltInFailures..::..SplineFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::..SplineFailures Class


BuiltInFailures.SplineFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SplineFailures Properties
BuiltInFailures..::..SplineFailures Class See Also Send Feedback

The BuiltInFailures..::..SplineFailures type exposes the following members.

Properties

Name | Description
CannotCreateSpline | Can't make Spline.
ClosedSpline | Closed or self-intersecting splines are not allowed.

See Also

BuiltInFailures..::..SplineFailures Class


CannotCreateSpline Property

[image]

Revit 2013 API
BuiltInFailures..::..SplineFailures..::..CannotCreateSpline Property
BuiltInFailures..::..SplineFailures Class See Also Send Feedback
Can't make Spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSpline { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSpline As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplineFailures Class


ClosedSpline Property

[image]

Revit 2013 API
BuiltInFailures..::..SplineFailures..::..ClosedSpline Property
BuiltInFailures..::..SplineFailures Class See Also Send Feedback
Closed or self-intersecting splines are not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ClosedSpline { get; }
Visual Basic
Public Shared ReadOnly Property ClosedSpline As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ClosedSpline {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SplineFailures Class


BuiltInFailures.StairRampFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about StairRamp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class StairRampFailures
Visual Basic
Public NotInheritable Class StairRampFailures
Visual C++
public ref class StairRampFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..StairRampFailures

See Also

BuiltInFailures..::..StairRampFailures Members


BuiltInFailures.StairRampFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures Members
BuiltInFailures..::..StairRampFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarning | You may lose some rail customizations when changing rail type. Click OK if you want to continue with the type change.
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Place holder and will be replaced with detail failure types.
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.

See Also

BuiltInFailures..::..StairRampFailures Class


BuiltInFailures.StairRampFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures Properties
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback

The BuiltInFailures..::..StairRampFailures type exposes the following members.

Properties

Name | Description
ActualRiserHeightChanged | The actual riser height for one or more stairs violates the maximum set in the type.
AntiparallelRampRisers | Riser lines are parallel but not collinear. Can't build Run between these Risers.
AntiparallelRampRisersError | Riser lines are parallel but not collinear. Can't build Run between these Risers.
ArcRunRadiusTooSmall | Can't create Run. Run radius is too small.
ArcRunWidthTooLongFailure | Arc run width is too long.
AutomaticLandingConvertedToSketchedLandingWarning | Some run(s) are deleted, so automatic landing is converted to sketched landing.
BadBalustersPerTread | Number of Balusters per Tread must be an integer greater than zero.
BadFillingSpacing | Spacing for Excess Length Fill is too small.
BadRailings | Can't create Railings.
BadRailingsError | Can't create Railings.
BadRailProfile | One or more Profile Loops are invalid, probably because of self-intersection.
BadTreadRiserProfile | Tread/Riser profile is invalid.
BalustersTooClose | Baluster Separation must be equal to or greater than the Baluster widths.
BalustersTooCloseAbsolute | Baluster Separation is too small.
BalusterUpsideDown | Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.
CannotAlignSupportOnPosts | Cannot align the support on the posts.
CannotComputeRailElevation | Can't compute elevation profile for one or more Rails
CannotCreateBaluster | Can't create Balusters for given Width and Height.
CannotCreateBalusterPatterns | Can't create Baluster Patterns for Railings
CannotCreateCornerBalusters | Can't create corner Baluster
CannotCreateLandingStringer | Can't create stringer at landing.
CannotCreateMiddleStringer | Can't create one or more Middle Stringers.
CannotCreateMonolithicStairs | Can't make monolithic Stairs.
CannotCreateNosing | Can't create nosing on one or more treads.
CannotCreateOneOrMoreBaluster | Can't create one or more Balusters
CannotCreateOneOrMoreTreads | Can't create geometry for one or more treads.
CannotCreateOpenMiddleStringers | Can't cut open/middle stringers geometry.
CannotCreateRail | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRailGeom | Can't create geometry for one or more Rails
CannotCreateRailWarn | Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.
CannotCreateRiser | Can't create geometry for one or more risers.
CannotCreateSideStringer | Can't create one or more Side Stringers.
CannotCreateStringers | Can't create stringers geometry.
CannotDrawStairs | Can't make stairs
CannotDrawStairsError | Can't make stairs
CannotEndWithZeroRiser | Can't end Stairs with Riser because Riser Thickness is too small.
CannotGenerateFaces | Couldn't generate surfaces for stairs.
CannotGenerateFacesError | Couldn't generate surfaces for stairs.
CannotGenerateRamp | Couldn't generate surfaces for ramp.
CannotGenerateRampError | Couldn't generate surfaces for ramp.
CannotMakeLanding | Can't make landing.
CannotOffsetBoundary | Can't create Boundary as an offset of Run Curve
CannotOffsetRail | Can't create one or more Rails with desired offset
CannotPlaceBalusterOffset | Can't place Balusters and/or Rails with desired offset
CannotPlaceBalusterPatterns | Can't place Baluster Patterns
ContinuousRailFilletCreationError | Cannot create specified fillet at rail path corner.
ContinuousRailFilletCreationParallel | Cannot create specified fillet at rail path corner because of the curves are already smoothed.
ContinuousRailFilletCreationWarning | Cannot create specified fillet at rail path corner.
ContinuousRailGometryCreationFailure | Cannot create the continuous rail geometry.
ContinuousRailNotContinuous | The rail is non-continuous.
ContinuousRailSupportPlacementFailure | Cannot place the supports along the rail path.
ContinuousRailTransitionFailure | Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.
ExtendBelowBaseGreaterThanLandingBaseElevation | Extend Below Base needs to be less than Landing Base Elevation.
ExtendBelowBaseGreaterThanRunTopElevation | Extend Below Base needs to be less than Run Top Elevation.
HeightOfRunIsTooSmall | Height of run is too small.
IntermediateLandingHigherThanTopRunFailure | Run is reversed.
InvalidBalustersPattern | Invalid Balusters Pattern
InvalidParameters | Stairs run or landing has invalid parameter(s).
InvalidRailProfile | Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.
InvalidStairsPathFailure | Invalid stairs path provided.
InvalidStartLevel | The start level and end level for this staircase must be at different elevations.
InvalidStartLevelRamp | The start level and end level for this ramp must be at different elevations.
LandingHeightUnderStairsBottom | Cannot make landing because height of landing is equal or less than to bottom height of the stair.
MayUnjoinRailAndSupports | Fillet may cause the supports unjoin with the rail.
MultistoryLevelBelowTopbottomLevel | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryLevelBelowTopbottomLevelError | Multistory top level must be above the stair/ramp top and bottom levels.
MultistoryStairDoesntReach | The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.
MultusegmentRampRiser | Ramp can't have multisegment Riser.
MultusegmentRampRiserError | Ramp can't have multisegment Riser.
NoCurvesInRailing | Railing Sketch has no Lines.
NoProfileForRail | Must specify Profiles for every Rail.
NoRailingsStringer | Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.
NoRisersInPureMonolithicStairs | Monolithic Stairs with zero tread thickness can't have risers
NoRunsRamp | Ramp has no Runs. Can't create Ramp.
NoRunsRampError | Ramp has no Runs. Can't create Ramp.
NotALineRiserRamp | Riser line must be a straight line for Ramps.
NotALineRiserRampError | Riser line must be a straight line for Ramps.
NotchThicknessIsLargerThanLandingWarning | The notch thickness is larger than landing.
NotEnoughRisers | Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.
OnlyMonolithicStairs | Tread thickness can't be zero for non-monolithic stairs
PartOfRiserLiesOnBoundaryFailure | Part of the riser lies on the boundary is not allowed.
PathDoesntJoinToBorderRisersFailure | Path doesn't join to border risers is not allowed.
RailCurveTooShort | Curve in rail sketch is too short for rail creation and ignored.
RailingBadOffset | An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.
RailingCurvesNotSplitRamp | The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingCurvesNotSplitStairs | The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.
RailingDoublyConnected | Railings hosted on Stairs must form a single, open, connected line.
RailingNotConnected | The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.
RailPathCloseLoopForExtensionWarning | The rail path is closed at the start and end path point for extension creation.
RailProfileLowerThanFilletFailure | Fillet cannot be created between rail segment since the radius is lower than the profile size.
RailProfileOpen | Open Profile Loop can't be used as a Rail Profile
RailTypeChangeInconsistancyWarning | You may lose some rail customizations when changing rail type. Click OK if you want to continue with the type change.
RailTypeChangeInconsistancyWarningWithResetBtn | Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.
RampDoesntReach | The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.
RampDoesntReachOffset | The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.
RampLandingNotCreated | Beginning of run coincide with the end of previous run. Landing is not created between runs.
RampRunTooComplex | Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.
RampStartHigherThanEnd | The ramp's base (base level + base offset) must be below its top (top level + top offset).
RiserCurveTooShort | Riser curve is too short to create nosing on it.
RiserHeightIsTooSmall | Riser height is too small.
RiserIntWithBoundaryMoreThanOnceFailure | Riser intersects with boundary more than once.
RisersAtSameLocation | The highlighted risers have the same location along the boundary line. Please move one of the two risers.
RiserThicknesssResetToZero | Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.
RunBottomHigherThanTopFailure | The base elevation for the run is higher than the top elevation for the run.
RunBottomUnderStairsBottomFailure | Run bottom elevation should not be below the stairs bottom elevation.
RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning | Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.
RunTopLowerThanBottomFailure | The top elevation for the run is lower than the base elevation for the run.
SpiralRunRadiusTooSmallFailure | The radius value for the run is too small.
StairIncompleteFailure | Stair element is incomplete, not all components are logic connected.
StairsActualRiserHeightGreaterThanMaximumFailure | Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.
StairsActualRunWidthLessThanMinimumFailure | Actual run width is less than minimum run width defined in stairs type.
StairsActualTreadDepthLessThanMinimumFailure | Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.
StairsAutomaticLandingLayoutFailure | Fail to generate the automatic landing layout
StairsBottomEndExceedsOrNotReachWarning | Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.
StairsCommonRunGenerateLayoutFailure | Fail to get base line thus fail to generate run layout
StairsComponentJoinFailure | Can't keep elements joined.
StairsCrossingRisersDisallowedFailure | Crossing risers are not allowed
StairsGenericFailure | Place holder and will be replaced with detail failure types.
StairsGenericTransformFailure | Cannot change base elevation of Stairs
StairsIllegalDesiredNumRisers | Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.
StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure | Only single boundary case may have riser with its both ends on boundary.
StairsOtherThan2IntsByRiserAndBoundaryFailure | More than 2 intersection points between riser segment and boundary encountered
StairsPathPositionResetWarning | The stairs path doesn't intersect with riser lines.
StairsRunRunJoinNotAllowedFailure | Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.
StairsStartHigherThanEnd | The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).
StairsStringerCannotBeCreated | The stairs stringer cannot be created.
StairsSubElementsNotConnectedWarning | Stair sub-elements are not connected
StairsSupportOverlapFailure | Some supports overlap with others
StairsSupportTooShort | A short support is being created.
StairsTopEndExceedsOrNotReachWarning | Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.
StairsTopLowerThanBaseFailure | The top of the Stair is lower than the base of the Stair
StairStringerCantOffset | Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.
StairsWinderGenLayoutFailure | Fail to generate run layout and then cannot make winder run
StairsWinderInvalidParamsFailure | Cannot create the winder run because some values for the instance properties cannot be satisfied.
StairsZeroDesiredRisers | The number of desired risers for a staircase cannot be 0.
StringerCurvesNotSplitStairs | The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.
StringerCurveTooShort | A piece of boundary is too short to create stringer on it.
TooShortCurveDowngradeGeometry | Curve is too short and may downgrade the geometry.
TreadDepthBelowMin | The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.
TreadDepthFailsEq | The actual tread depth and riser height for one or more stairs of this type violates the stair equation.
TreadDepthTooBigFailure | The tread depth is too large for the spiral run.
TreadFrontProfileInvalid | This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.
UnexpectedCurveIntersectionFailure | Computing curve intersection and find the invalid result.
WinderFilletRadiusTooLargeFailure | The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.
WinderFirstLegTooShortOrRunWidthTooGreatFailure | The first leg of winder run is too short or the runwidth is too great.
WinderGenericError | Cannot make winder.
WinderLegIsTooShortFailure | A winder leg is too short.
WinderLegsAngleTooGreatOrRunWidthTooSmallFailure | The angle between two consecutive legs are too great or the runwidth is too small.
WinderLegTooShortOrRunWidthTooGreatFailure | One leg of the winder run is too small or the runwidth is too great.
WinderMinWidthTooLargeFailure | The value for Minimum Width on Inside Boundary is too large.
WinderMinWidthTooLargeForParallelTreadsFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderParallelLegsFailure | Two consecutive legs are parallel.
WinderParallelTreadsNumberFailure | Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties
WinderRunCreationFailure | The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.
WinderRunInsideMinTreadDepthFailure | Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).
WinderRunInsideWalklineOffsetFailure | Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).
WinderRunWidthLessThan2TimesMinWidthFailure | The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.
WinderRunWidthLessThanWalkLineOffsetFailure | The value for Run Width is less than two times of value of the inside walkline offset.
WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure | The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.
WinderRunWidthOrMinWidthOrTooShortFailure | The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.
WinderSecondLegTooShortOrRunwidthTooGreatFailure | The second leg of winder run is too short or the runwidth is too great.
WinderStraightStepsNumberFailure | The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.
WinderThirdLegTooShortOrRunWidthTooGreatFailure | The third leg of winder run is too short or the runwidth is too great.
WinderTooManyEndParallelTreadsOrRunWidthFailure | The number of parallel treads at end is too great or the run width is too great.
WinderTooManyParallelTreadsAtEndFailure | The number of parallel treads at end is too great.
WinderTooManyParallelTreadsAtHeadFailure | The number of parallel treads at start is too great.
WinderTooManyStartParallelTreadsOrRunWidthFailure | The number of parallel treads at start is too great or the run width is too great.

See Also

BuiltInFailures..::..StairRampFailures Class


ActualRiserHeightChanged Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ActualRiserHeightChanged Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The actual riser height for one or more stairs violates the maximum set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ActualRiserHeightChanged { get; }
Visual Basic
Public Shared ReadOnly Property ActualRiserHeightChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ActualRiserHeightChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AntiparallelRampRisers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..AntiparallelRampRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisers { get; }
Visual Basic
Public Shared ReadOnly Property AntiparallelRampRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AntiparallelRampRisersError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..AntiparallelRampRisersError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser lines are parallel but not collinear. Can't build Run between these Risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AntiparallelRampRisersError { get; }
Visual Basic
Public Shared ReadOnly Property AntiparallelRampRisersError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AntiparallelRampRisersError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ArcRunRadiusTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ArcRunRadiusTooSmall Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Run. Run radius is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArcRunRadiusTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property ArcRunRadiusTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcRunRadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ArcRunWidthTooLongFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ArcRunWidthTooLongFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Arc run width is too long.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ArcRunWidthTooLongFailure { get; }
Visual Basic
Public Shared ReadOnly Property ArcRunWidthTooLongFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ArcRunWidthTooLongFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


AutomaticLandingConvertedToSketchedLandingWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..AutomaticLandingConvertedToSketchedLandingWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some run(s) are deleted, so automatic landing is converted to sketched landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AutomaticLandingConvertedToSketchedLandingWarning { get; }
Visual Basic
Public Shared ReadOnly Property AutomaticLandingConvertedToSketchedLandingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AutomaticLandingConvertedToSketchedLandingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadBalustersPerTread Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadBalustersPerTread Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Number of Balusters per Tread must be an integer greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadBalustersPerTread { get; }
Visual Basic
Public Shared ReadOnly Property BadBalustersPerTread As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadBalustersPerTread {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadFillingSpacing Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadFillingSpacing Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Spacing for Excess Length Fill is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadFillingSpacing { get; }
Visual Basic
Public Shared ReadOnly Property BadFillingSpacing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadFillingSpacing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadRailings Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadRailings Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailings { get; }
Visual Basic
Public Shared ReadOnly Property BadRailings As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailings {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadRailingsError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadRailingsError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailingsError { get; }
Visual Basic
Public Shared ReadOnly Property BadRailingsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailingsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadRailProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadRailProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One or more Profile Loops are invalid, probably because of self-intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadRailProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadRailProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BadTreadRiserProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BadTreadRiserProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Tread/Riser profile is invalid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadTreadRiserProfile { get; }
Visual Basic
Public Shared ReadOnly Property BadTreadRiserProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadTreadRiserProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BalustersTooClose Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BalustersTooClose Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Baluster Separation must be equal to or greater than the Baluster widths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BalustersTooClose { get; }
Visual Basic
Public Shared ReadOnly Property BalustersTooClose As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BalustersTooClose {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BalustersTooCloseAbsolute Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BalustersTooCloseAbsolute Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Baluster Separation is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BalustersTooCloseAbsolute { get; }
Visual Basic
Public Shared ReadOnly Property BalustersTooCloseAbsolute As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BalustersTooCloseAbsolute {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BalusterUpsideDown Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..BalusterUpsideDown Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Top reference is below Bottom reference for one or more Balusters. These Balusters are not created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BalusterUpsideDown { get; }
Visual Basic
Public Shared ReadOnly Property BalusterUpsideDown As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BalusterUpsideDown {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotAlignSupportOnPosts Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotAlignSupportOnPosts Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot align the support on the posts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotAlignSupportOnPosts { get; }
Visual Basic
Public Shared ReadOnly Property CannotAlignSupportOnPosts As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotAlignSupportOnPosts {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotComputeRailElevation Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotComputeRailElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't compute elevation profile for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotComputeRailElevation { get; }
Visual Basic
Public Shared ReadOnly Property CannotComputeRailElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotComputeRailElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateBaluster Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateBaluster Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Balusters for given Width and Height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateBaluster { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateBaluster As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBaluster {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateBalusterPatterns Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateBalusterPatterns Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Baluster Patterns for Railings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateBalusterPatterns { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateBalusterPatterns As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateCornerBalusters Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateCornerBalusters Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create corner Baluster

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateCornerBalusters { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateCornerBalusters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateCornerBalusters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateLandingStringer Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateLandingStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create stringer at landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateLandingStringer { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateLandingStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateLandingStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateMiddleStringer Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateMiddleStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Middle Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMiddleStringer { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMiddleStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMiddleStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateMonolithicStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't make monolithic Stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateNosing Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateNosing Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create nosing on one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateNosing { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateNosing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateNosing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateOneOrMoreBaluster Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateOneOrMoreBaluster Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Balusters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOneOrMoreBaluster { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOneOrMoreBaluster As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreBaluster {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateOneOrMoreTreads Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateOneOrMoreTreads Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more treads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOneOrMoreTreads { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOneOrMoreTreads As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOneOrMoreTreads {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateOpenMiddleStringers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateOpenMiddleStringers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't cut open/middle stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateOpenMiddleStringers { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateOpenMiddleStringers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateOpenMiddleStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRail Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRail { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRailGeom Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRailGeom Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more Rails

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRailGeom { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRailGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRailWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRailWarn Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Railing. Thickness of Rail or Balusters might be too small. If you don't want Balusters, specify "None" for Baluster Shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRailWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRailWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRailWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateRiser Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create geometry for one or more risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateRiser { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateSideStringer Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateSideStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Side Stringers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateSideStringer { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateSideStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateSideStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotCreateStringers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotCreateStringers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create stringers geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateStringers { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateStringers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateStringers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotDrawStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotDrawStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawStairs { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotDrawStairsError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotDrawStairsError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't make stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawStairsError { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawStairsError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawStairsError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotEndWithZeroRiser Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotEndWithZeroRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't end Stairs with Riser because Riser Thickness is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotEndWithZeroRiser { get; }
Visual Basic
Public Shared ReadOnly Property CannotEndWithZeroRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotEndWithZeroRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateFaces Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateFaces Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateFaces { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateFaces As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateFaces {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateFacesError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateFacesError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateFacesError { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateFacesError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateFacesError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateRamp Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateRamp { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotGenerateRampError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotGenerateRampError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Couldn't generate surfaces for ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotGenerateRampError { get; }
Visual Basic
Public Shared ReadOnly Property CannotGenerateRampError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotGenerateRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotMakeLanding Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotMakeLanding Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't make landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMakeLanding { get; }
Visual Basic
Public Shared ReadOnly Property CannotMakeLanding As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMakeLanding {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotOffsetBoundary Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotOffsetBoundary Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create Boundary as an offset of Run Curve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotOffsetBoundary { get; }
Visual Basic
Public Shared ReadOnly Property CannotOffsetBoundary As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotOffsetBoundary {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotOffsetRail Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotOffsetRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't create one or more Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotOffsetRail { get; }
Visual Basic
Public Shared ReadOnly Property CannotOffsetRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotOffsetRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotPlaceBalusterOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotPlaceBalusterOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't place Balusters and/or Rails with desired offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterOffset { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBalusterOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


CannotPlaceBalusterPatterns Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..CannotPlaceBalusterPatterns Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't place Baluster Patterns

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPlaceBalusterPatterns { get; }
Visual Basic
Public Shared ReadOnly Property CannotPlaceBalusterPatterns As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPlaceBalusterPatterns {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailFilletCreationError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailFilletCreationError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified fillet at rail path corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailFilletCreationError { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailFilletCreationError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailFilletCreationParallel Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailFilletCreationParallel Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified fillet at rail path corner because of the curves are already smoothed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailFilletCreationParallel { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailFilletCreationParallel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationParallel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailFilletCreationWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailFilletCreationWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified fillet at rail path corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailFilletCreationWarning { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailFilletCreationWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailFilletCreationWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailGometryCreationFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailGometryCreationFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create the continuous rail geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailGometryCreationFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailGometryCreationFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailGometryCreationFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailNotContinuous Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailNotContinuous Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The rail is non-continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailNotContinuous { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailNotContinuous As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailNotContinuous {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailSupportPlacementFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailSupportPlacementFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot place the supports along the rail path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailSupportPlacementFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailSupportPlacementFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailSupportPlacementFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ContinuousRailTransitionFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ContinuousRailTransitionFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create specified transition at rail path turn, hand Rail/Top Rail cannot maintain continuous.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContinuousRailTransitionFailure { get; }
Visual Basic
Public Shared ReadOnly Property ContinuousRailTransitionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContinuousRailTransitionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ExtendBelowBaseGreaterThanLandingBaseElevation Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ExtendBelowBaseGreaterThanLandingBaseElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Extend Below Base needs to be less than Landing Base Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendBelowBaseGreaterThanLandingBaseElevation { get; }
Visual Basic
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanLandingBaseElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanLandingBaseElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


ExtendBelowBaseGreaterThanRunTopElevation Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..ExtendBelowBaseGreaterThanRunTopElevation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Extend Below Base needs to be less than Run Top Elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ExtendBelowBaseGreaterThanRunTopElevation { get; }
Visual Basic
Public Shared ReadOnly Property ExtendBelowBaseGreaterThanRunTopElevation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ExtendBelowBaseGreaterThanRunTopElevation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


HeightOfRunIsTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..HeightOfRunIsTooSmall Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Height of run is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId HeightOfRunIsTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property HeightOfRunIsTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ HeightOfRunIsTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


IntermediateLandingHigherThanTopRunFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..IntermediateLandingHigherThanTopRunFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run is reversed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IntermediateLandingHigherThanTopRunFailure { get; }
Visual Basic
Public Shared ReadOnly Property IntermediateLandingHigherThanTopRunFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IntermediateLandingHigherThanTopRunFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidBalustersPattern Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidBalustersPattern Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Invalid Balusters Pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidBalustersPattern { get; }
Visual Basic
Public Shared ReadOnly Property InvalidBalustersPattern As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidBalustersPattern {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidParameters Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidParameters Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stairs run or landing has invalid parameter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidParameters { get; }
Visual Basic
Public Shared ReadOnly Property InvalidParameters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidRailProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidRailProfile Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Profiles for one or more of the Rails are invalid. Make sure that every used Profile is a closed series of non-intersecting Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidRailProfile { get; }
Visual Basic
Public Shared ReadOnly Property InvalidRailProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidRailProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStairsPathFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidStairsPathFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Invalid stairs path provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidStairsPathFailure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStairsPathFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStairsPathFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStartLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidStartLevel Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The start level and end level for this staircase must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidStartLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStartLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


InvalidStartLevelRamp Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..InvalidStartLevelRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The start level and end level for this ramp must be at different elevations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidStartLevelRamp { get; }
Visual Basic
Public Shared ReadOnly Property InvalidStartLevelRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidStartLevelRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


LandingHeightUnderStairsBottom Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..LandingHeightUnderStairsBottom Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot make landing because height of landing is equal or less than to bottom height of the stair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LandingHeightUnderStairsBottom { get; }
Visual Basic
Public Shared ReadOnly Property LandingHeightUnderStairsBottom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LandingHeightUnderStairsBottom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MayUnjoinRailAndSupports Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MayUnjoinRailAndSupports Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fillet may cause the supports unjoin with the rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MayUnjoinRailAndSupports { get; }
Visual Basic
Public Shared ReadOnly Property MayUnjoinRailAndSupports As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MayUnjoinRailAndSupports {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryLevelBelowTopbottomLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MultistoryLevelBelowTopbottomLevel Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevel { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryLevelBelowTopbottomLevelError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MultistoryLevelBelowTopbottomLevelError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Multistory top level must be above the stair/ramp top and bottom levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultistoryLevelBelowTopbottomLevelError { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryLevelBelowTopbottomLevelError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryLevelBelowTopbottomLevelError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultistoryStairDoesntReach Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MultistoryStairDoesntReach Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The multistory stair/ramp could not reach its top level with integral number of flights. Maximum number of flights below the top level is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultistoryStairDoesntReach { get; }
Visual Basic
Public Shared ReadOnly Property MultistoryStairDoesntReach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultistoryStairDoesntReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultusegmentRampRiser Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MultusegmentRampRiser Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiser { get; }
Visual Basic
Public Shared ReadOnly Property MultusegmentRampRiser As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiser {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


MultusegmentRampRiserError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..MultusegmentRampRiserError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp can't have multisegment Riser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultusegmentRampRiserError { get; }
Visual Basic
Public Shared ReadOnly Property MultusegmentRampRiserError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultusegmentRampRiserError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoCurvesInRailing Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoCurvesInRailing Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railing Sketch has no Lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoCurvesInRailing { get; }
Visual Basic
Public Shared ReadOnly Property NoCurvesInRailing As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoCurvesInRailing {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoProfileForRail Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoProfileForRail Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Must specify Profiles for every Rail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoProfileForRail { get; }
Visual Basic
Public Shared ReadOnly Property NoProfileForRail As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoProfileForRail {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRailingsStringer Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoRailingsStringer Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railings and Stringers will not be automatically generated due to bad Runs. This message may be incorrect if you have Edited the Sketch and modified some dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRailingsStringer { get; }
Visual Basic
Public Shared ReadOnly Property NoRailingsStringer As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRailingsStringer {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRisersInPureMonolithicStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoRisersInPureMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Monolithic Stairs with zero tread thickness can't have risers

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRisersInPureMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property NoRisersInPureMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRisersInPureMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRunsRamp Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoRunsRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRunsRamp { get; }
Visual Basic
Public Shared ReadOnly Property NoRunsRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRunsRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NoRunsRampError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NoRunsRampError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp has no Runs. Can't create Ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoRunsRampError { get; }
Visual Basic
Public Shared ReadOnly Property NoRunsRampError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoRunsRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotALineRiserRamp Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NotALineRiserRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotALineRiserRamp { get; }
Visual Basic
Public Shared ReadOnly Property NotALineRiserRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotALineRiserRampError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NotALineRiserRampError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser line must be a straight line for Ramps.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotALineRiserRampError { get; }
Visual Basic
Public Shared ReadOnly Property NotALineRiserRampError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotALineRiserRampError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotchThicknessIsLargerThanLandingWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NotchThicknessIsLargerThanLandingWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The notch thickness is larger than landing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotchThicknessIsLargerThanLandingWarning { get; }
Visual Basic
Public Shared ReadOnly Property NotchThicknessIsLargerThanLandingWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotchThicknessIsLargerThanLandingWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


NotEnoughRisers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..NotEnoughRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Actual Number of Risers is different from Desired Number of Risers. Add/remove Risers or change Desired Number of Risers in Stairs Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotEnoughRisers { get; }
Visual Basic
Public Shared ReadOnly Property NotEnoughRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotEnoughRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


OnlyMonolithicStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..OnlyMonolithicStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Tread thickness can't be zero for non-monolithic stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId OnlyMonolithicStairs { get; }
Visual Basic
Public Shared ReadOnly Property OnlyMonolithicStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ OnlyMonolithicStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


PartOfRiserLiesOnBoundaryFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..PartOfRiserLiesOnBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Part of the riser lies on the boundary is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PartOfRiserLiesOnBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property PartOfRiserLiesOnBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PartOfRiserLiesOnBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


PathDoesntJoinToBorderRisersFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..PathDoesntJoinToBorderRisersFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Path doesn't join to border risers is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId PathDoesntJoinToBorderRisersFailure { get; }
Visual Basic
Public Shared ReadOnly Property PathDoesntJoinToBorderRisersFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ PathDoesntJoinToBorderRisersFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailCurveTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailCurveTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Curve in rail sketch is too short for rail creation and ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RailCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingBadOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailingBadOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
An arc in the railing sketch has a radius that conflicts with the current rail widths and offsets. Please either increase the radius or modify rail profiles and offsets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingBadOffset { get; }
Visual Basic
Public Shared ReadOnly Property RailingBadOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingBadOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingCurvesNotSplitRamp Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailingCurvesNotSplitRamp Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The slope of this railing will not parallel the ramp at landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitRamp { get; }
Visual Basic
Public Shared ReadOnly Property RailingCurvesNotSplitRamp As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitRamp {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingCurvesNotSplitStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailingCurvesNotSplitStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The slope of this railing may not parallel the stairs at runs and landings. To get a parallel railing, split the railing sketch at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingCurvesNotSplitStairs { get; }
Visual Basic
Public Shared ReadOnly Property RailingCurvesNotSplitStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingDoublyConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailingDoublyConnected Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Railings hosted on Stairs must form a single, open, connected line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingDoublyConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingDoublyConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingDoublyConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailingNotConnected Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailingNotConnected Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The Railing line must be a single connected Sketch. If you want separate pieces of Railing, create two or more separate Railings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailingNotConnected { get; }
Visual Basic
Public Shared ReadOnly Property RailingNotConnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailingNotConnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailPathCloseLoopForExtensionWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailPathCloseLoopForExtensionWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The rail path is closed at the start and end path point for extension creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailPathCloseLoopForExtensionWarning { get; }
Visual Basic
Public Shared ReadOnly Property RailPathCloseLoopForExtensionWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailPathCloseLoopForExtensionWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailProfileLowerThanFilletFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailProfileLowerThanFilletFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fillet cannot be created between rail segment since the radius is lower than the profile size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailProfileLowerThanFilletFailure { get; }
Visual Basic
Public Shared ReadOnly Property RailProfileLowerThanFilletFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailProfileLowerThanFilletFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailProfileOpen Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailProfileOpen Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Open Profile Loop can't be used as a Rail Profile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailProfileOpen { get; }
Visual Basic
Public Shared ReadOnly Property RailProfileOpen As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailProfileOpen {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailTypeChangeInconsistancyWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailTypeChangeInconsistancyWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
You may lose some rail customizations when changing rail type. Click OK if you want to continue with the type change.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailTypeChangeInconsistancyWarning { get; }
Visual Basic
Public Shared ReadOnly Property RailTypeChangeInconsistancyWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailTypeChangeInconsistancyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RailTypeChangeInconsistancyWarningWithResetBtn Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RailTypeChangeInconsistancyWarningWithResetBtn Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some rail type changes are not consistent with your rail instances customization in this project, you can reset them to make them corresponding with your changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RailTypeChangeInconsistancyWarningWithResetBtn { get; }
Visual Basic
Public Shared ReadOnly Property RailTypeChangeInconsistancyWarningWithResetBtn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RailTypeChangeInconsistancyWarningWithResetBtn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampDoesntReach Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RampDoesntReach Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RampDoesntReach { get; }
Visual Basic
Public Shared ReadOnly Property RampDoesntReach As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReach {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampDoesntReachOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RampDoesntReachOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The ramp is not long enough to reach the top constraint plus top offset. Change the slope or increase the length of the ramp.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RampDoesntReachOffset { get; }
Visual Basic
Public Shared ReadOnly Property RampDoesntReachOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampDoesntReachOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampLandingNotCreated Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RampLandingNotCreated Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Beginning of run coincide with the end of previous run. Landing is not created between runs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RampLandingNotCreated { get; }
Visual Basic
Public Shared ReadOnly Property RampLandingNotCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampLandingNotCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampRunTooComplex Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RampRunTooComplex Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Ramp Run has complex boundary and may produce unreasonable geometry. Split it into few Runs by inserting Riser Lines at the end of each Run and at the beginning of the next one. If you want to create Ramp with arc an straight section you can do it using a Run tool.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RampRunTooComplex { get; }
Visual Basic
Public Shared ReadOnly Property RampRunTooComplex As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampRunTooComplex {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RampStartHigherThanEnd Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RampStartHigherThanEnd Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The ramp's base (base level + base offset) must be below its top (top level + top offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RampStartHigherThanEnd { get; }
Visual Basic
Public Shared ReadOnly Property RampStartHigherThanEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RampStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserCurveTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RiserCurveTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser curve is too short to create nosing on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RiserCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property RiserCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserHeightIsTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RiserHeightIsTooSmall Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser height is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RiserHeightIsTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property RiserHeightIsTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserHeightIsTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserIntWithBoundaryMoreThanOnceFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RiserIntWithBoundaryMoreThanOnceFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Riser intersects with boundary more than once.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RiserIntWithBoundaryMoreThanOnceFailure { get; }
Visual Basic
Public Shared ReadOnly Property RiserIntWithBoundaryMoreThanOnceFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserIntWithBoundaryMoreThanOnceFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RisersAtSameLocation Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RisersAtSameLocation Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The highlighted risers have the same location along the boundary line. Please move one of the two risers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RisersAtSameLocation { get; }
Visual Basic
Public Shared ReadOnly Property RisersAtSameLocation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RisersAtSameLocation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RiserThicknesssResetToZero Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RiserThicknesssResetToZero Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Monolithic Stairs without Treads can't have Risers. Riser Thickness for Stairs Type was automatically set to zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RiserThicknesssResetToZero { get; }
Visual Basic
Public Shared ReadOnly Property RiserThicknesssResetToZero As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RiserThicknesssResetToZero {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunBottomHigherThanTopFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RunBottomHigherThanTopFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The base elevation for the run is higher than the top elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunBottomHigherThanTopFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunBottomHigherThanTopFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunBottomHigherThanTopFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunBottomUnderStairsBottomFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RunBottomUnderStairsBottomFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run bottom elevation should not be below the stairs bottom elevation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunBottomUnderStairsBottomFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunBottomUnderStairsBottomFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunBottomUnderStairsBottomFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run is joining landing with riser, so notch configuration does not take effect. Try to set run as begin/end with tread to make a notch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning { get; }
Visual Basic
Public Shared ReadOnly Property RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunIsJoiningLandingWithRiserSoNotchDoesNotWorkWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


RunTopLowerThanBottomFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..RunTopLowerThanBottomFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The top elevation for the run is lower than the base elevation for the run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RunTopLowerThanBottomFailure { get; }
Visual Basic
Public Shared ReadOnly Property RunTopLowerThanBottomFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RunTopLowerThanBottomFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


SpiralRunRadiusTooSmallFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..SpiralRunRadiusTooSmallFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The radius value for the run is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SpiralRunRadiusTooSmallFailure { get; }
Visual Basic
Public Shared ReadOnly Property SpiralRunRadiusTooSmallFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SpiralRunRadiusTooSmallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairIncompleteFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairIncompleteFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair element is incomplete, not all components are logic connected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairIncompleteFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairIncompleteFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairIncompleteFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsActualRiserHeightGreaterThanMaximumFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsActualRiserHeightGreaterThanMaximumFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Computed actual riser height of stairs is greater than maximum riser height defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsActualRiserHeightGreaterThanMaximumFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualRiserHeightGreaterThanMaximumFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsActualRiserHeightGreaterThanMaximumFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsActualRunWidthLessThanMinimumFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsActualRunWidthLessThanMinimumFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Actual run width is less than minimum run width defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsActualRunWidthLessThanMinimumFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualRunWidthLessThanMinimumFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsActualRunWidthLessThanMinimumFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsActualTreadDepthLessThanMinimumFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsActualTreadDepthLessThanMinimumFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Computed actual tread depth of stairs is less than minimum tread depth defined in stairs type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsActualTreadDepthLessThanMinimumFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsActualTreadDepthLessThanMinimumFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsActualTreadDepthLessThanMinimumFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsAutomaticLandingLayoutFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsAutomaticLandingLayoutFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to generate the automatic landing layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsAutomaticLandingLayoutFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsAutomaticLandingLayoutFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsAutomaticLandingLayoutFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsBottomEndExceedsOrNotReachWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsBottomEndExceedsOrNotReachWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair bottom end exceeds or cannot reach the base elevation of the stair. Add/remove risers at the bottom end or change base elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsBottomEndExceedsOrNotReachWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsBottomEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsBottomEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsCommonRunGenerateLayoutFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsCommonRunGenerateLayoutFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to get base line thus fail to generate run layout

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsCommonRunGenerateLayoutFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsCommonRunGenerateLayoutFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsCommonRunGenerateLayoutFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsComponentJoinFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsComponentJoinFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Can't keep elements joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsComponentJoinFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsComponentJoinFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsComponentJoinFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsCrossingRisersDisallowedFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsCrossingRisersDisallowedFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Crossing risers are not allowed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsCrossingRisersDisallowedFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsCrossingRisersDisallowedFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsCrossingRisersDisallowedFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsGenericFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsGenericFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Place holder and will be replaced with detail failure types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsGenericFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsGenericFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsGenericFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsGenericTransformFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsGenericTransformFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot change base elevation of Stairs

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsGenericTransformFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsGenericTransformFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsGenericTransformFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsIllegalDesiredNumRisers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsIllegalDesiredNumRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Desired Number of Risers is too small. Computed Actual Riser Height is greater than Maximum Riser Height allowed by type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsIllegalDesiredNumRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsIllegalDesiredNumRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsIllegalDesiredNumRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Only single boundary case may have riser with its both ends on boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsOnlySingleBoundaryHasRiserWithBothEndsOnBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsOtherThan2IntsByRiserAndBoundaryFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsOtherThan2IntsByRiserAndBoundaryFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
More than 2 intersection points between riser segment and boundary encountered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsOtherThan2IntsByRiserAndBoundaryFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsOtherThan2IntsByRiserAndBoundaryFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsOtherThan2IntsByRiserAndBoundaryFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsPathPositionResetWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsPathPositionResetWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The stairs path doesn't intersect with riser lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsPathPositionResetWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsPathPositionResetWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsPathPositionResetWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsRunRunJoinNotAllowedFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsRunRunJoinNotAllowedFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Run-Run join is not allowed of they have same "Start With Riser"/"End With Riser" configuration at the joined end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsRunRunJoinNotAllowedFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsRunRunJoinNotAllowedFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsRunRunJoinNotAllowedFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsStartHigherThanEnd Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsStartHigherThanEnd Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The stairs' base (Base Level + Base Offset) must be below its top (Top Level + Top Offset).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsStartHigherThanEnd { get; }
Visual Basic
Public Shared ReadOnly Property StairsStartHigherThanEnd As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsStartHigherThanEnd {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsStringerCannotBeCreated Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsStringerCannotBeCreated Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The stairs stringer cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsStringerCannotBeCreated { get; }
Visual Basic
Public Shared ReadOnly Property StairsStringerCannotBeCreated As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsStringerCannotBeCreated {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsSubElementsNotConnectedWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsSubElementsNotConnectedWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair sub-elements are not connected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsSubElementsNotConnectedWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsSubElementsNotConnectedWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsSubElementsNotConnectedWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsSupportOverlapFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsSupportOverlapFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Some supports overlap with others

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsSupportOverlapFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportOverlapFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsSupportOverlapFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsSupportTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsSupportTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
A short support is being created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsSupportTooShort { get; }
Visual Basic
Public Shared ReadOnly Property StairsSupportTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsSupportTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsTopEndExceedsOrNotReachWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsTopEndExceedsOrNotReachWarning Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Stair top end exceeds or cannot reach the top elevation of the stair. Add/remove risers at the top end or change top elevation settings in Stair Properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsTopEndExceedsOrNotReachWarning { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopEndExceedsOrNotReachWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsTopEndExceedsOrNotReachWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsTopLowerThanBaseFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsTopLowerThanBaseFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The top of the Stair is lower than the base of the Stair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsTopLowerThanBaseFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsTopLowerThanBaseFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsTopLowerThanBaseFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairStringerCantOffset Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairStringerCantOffset Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Inside stringer could not be created because of insufficient space. Please disable the inside stringer or decrease its width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairStringerCantOffset { get; }
Visual Basic
Public Shared ReadOnly Property StairStringerCantOffset As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairStringerCantOffset {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsWinderGenLayoutFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsWinderGenLayoutFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Fail to generate run layout and then cannot make winder run

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsWinderGenLayoutFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderGenLayoutFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsWinderGenLayoutFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsWinderInvalidParamsFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsWinderInvalidParamsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot create the winder run because some values for the instance properties cannot be satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsWinderInvalidParamsFailure { get; }
Visual Basic
Public Shared ReadOnly Property StairsWinderInvalidParamsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsWinderInvalidParamsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StairsZeroDesiredRisers Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StairsZeroDesiredRisers Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of desired risers for a staircase cannot be 0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StairsZeroDesiredRisers { get; }
Visual Basic
Public Shared ReadOnly Property StairsZeroDesiredRisers As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StairsZeroDesiredRisers {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StringerCurvesNotSplitStairs Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StringerCurvesNotSplitStairs Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The slope of stringer may not parallel runs and landings. To get a parallel stringer, split boundary lines at the ends of landings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StringerCurvesNotSplitStairs { get; }
Visual Basic
Public Shared ReadOnly Property StringerCurvesNotSplitStairs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StringerCurvesNotSplitStairs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


StringerCurveTooShort Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..StringerCurveTooShort Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
A piece of boundary is too short to create stringer on it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StringerCurveTooShort { get; }
Visual Basic
Public Shared ReadOnly Property StringerCurveTooShort As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StringerCurveTooShort {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TooShortCurveDowngradeGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..TooShortCurveDowngradeGeometry Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Curve is too short and may downgrade the geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooShortCurveDowngradeGeometry { get; }
Visual Basic
Public Shared ReadOnly Property TooShortCurveDowngradeGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShortCurveDowngradeGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadDepthBelowMin Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..TreadDepthBelowMin Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The Actual Tread Depth for one or more Stairs violates the Minimum Depth set in the type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TreadDepthBelowMin { get; }
Visual Basic
Public Shared ReadOnly Property TreadDepthBelowMin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadDepthBelowMin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadDepthFailsEq Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..TreadDepthFailsEq Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The actual tread depth and riser height for one or more stairs of this type violates the stair equation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TreadDepthFailsEq { get; }
Visual Basic
Public Shared ReadOnly Property TreadDepthFailsEq As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadDepthFailsEq {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadDepthTooBigFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..TreadDepthTooBigFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The tread depth is too large for the spiral run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TreadDepthTooBigFailure { get; }
Visual Basic
Public Shared ReadOnly Property TreadDepthTooBigFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadDepthTooBigFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


TreadFrontProfileInvalid Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..TreadFrontProfileInvalid Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
This profile cannot be used for the front of treads. Please choose a profile composed of a closed loop of lines with exactly one lines coincident with the y-axis. This lines will define the connection of this profile to the tread.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TreadFrontProfileInvalid { get; }
Visual Basic
Public Shared ReadOnly Property TreadFrontProfileInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TreadFrontProfileInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


UnexpectedCurveIntersectionFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..UnexpectedCurveIntersectionFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Computing curve intersection and find the invalid result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnexpectedCurveIntersectionFailure { get; }
Visual Basic
Public Shared ReadOnly Property UnexpectedCurveIntersectionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnexpectedCurveIntersectionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderFilletRadiusTooLargeFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderFilletRadiusTooLargeFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Fillet Radius is too large to satisfy the Minimum Inside Width value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderFilletRadiusTooLargeFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderFilletRadiusTooLargeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderFilletRadiusTooLargeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderFirstLegTooShortOrRunWidthTooGreatFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderFirstLegTooShortOrRunWidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The first leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderFirstLegTooShortOrRunWidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderFirstLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderFirstLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderGenericError Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderGenericError Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot make winder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderGenericError { get; }
Visual Basic
Public Shared ReadOnly Property WinderGenericError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderGenericError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegIsTooShortFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderLegIsTooShortFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
A winder leg is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderLegIsTooShortFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegIsTooShortFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegIsTooShortFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderLegsAngleTooGreatOrRunWidthTooSmallFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The angle between two consecutive legs are too great or the runwidth is too small.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderLegsAngleTooGreatOrRunWidthTooSmallFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegsAngleTooGreatOrRunWidthTooSmallFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegsAngleTooGreatOrRunWidthTooSmallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderLegTooShortOrRunWidthTooGreatFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderLegTooShortOrRunWidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
One leg of the winder run is too small or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderLegTooShortOrRunWidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderMinWidthTooLargeFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderMinWidthTooLargeFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Minimum Width on Inside Boundary is too large.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderMinWidthTooLargeFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderMinWidthTooLargeFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderMinWidthTooLargeForParallelTreadsFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderMinWidthTooLargeForParallelTreadsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderMinWidthTooLargeForParallelTreadsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderMinWidthTooLargeForParallelTreadsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderMinWidthTooLargeForParallelTreadsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderParallelLegsFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderParallelLegsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Two consecutive legs are parallel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderParallelLegsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderParallelLegsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderParallelLegsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderParallelTreadsNumberFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderParallelTreadsNumberFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Cannot satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderParallelTreadsNumberFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderParallelTreadsNumberFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderParallelTreadsNumberFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunCreationFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunCreationFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The relationship between the current values of Actual Run Width, Minimum Width at Inside Boundary, and Parallel Treads at Start or End does not support the creation of the winder run.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunCreationFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunCreationFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunCreationFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunInsideMinTreadDepthFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunInsideMinTreadDepthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Please enter a positive value less than Actual Tread Depth on Stair Path (%Actual Tread Depth%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunInsideMinTreadDepthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunInsideMinTreadDepthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunInsideMinTreadDepthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunInsideWalklineOffsetFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunInsideWalklineOffsetFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
Please enter a value between 0 and half of Actual Run Width (%1/2 Actual Run Width%).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunInsideWalklineOffsetFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunInsideWalklineOffsetFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunInsideWalklineOffsetFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthLessThan2TimesMinWidthFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthLessThan2TimesMinWidthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Minimum Width on Inside Boundary is too large to satisfy the number of Parallel Treads at the Start or End as specified in the Run Instance properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunWidthLessThan2TimesMinWidthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthLessThan2TimesMinWidthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthLessThan2TimesMinWidthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthLessThanWalkLineOffsetFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthLessThanWalkLineOffsetFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The value for Run Width is less than two times of value of the inside walkline offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunWidthLessThanWalkLineOffsetFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthLessThanWalkLineOffsetFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthLessThanWalkLineOffsetFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The parameter runwidth is great or the parameter min width at inside boundary is too great, or number of parallel treads at both ends is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooGreatParallelTreadsFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderRunWidthOrMinWidthOrTooShortFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderRunWidthOrMinWidthOrTooShortFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The parameter runwidth is too great or the parameter min width at inside boundary is too great, or one leg of winder run is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderRunWidthOrMinWidthOrTooShortFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderRunWidthOrMinWidthOrTooShortFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderRunWidthOrMinWidthOrTooShortFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderSecondLegTooShortOrRunwidthTooGreatFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderSecondLegTooShortOrRunwidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The second leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderSecondLegTooShortOrRunwidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderSecondLegTooShortOrRunwidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderSecondLegTooShortOrRunwidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderStraightStepsNumberFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderStraightStepsNumberFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The current layout cannot allow the specified number of treads. Increase the length of the run leg in the model or reduce the value for Parallel Treads at Start or Parallel Treads at End.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderStraightStepsNumberFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderStraightStepsNumberFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderStraightStepsNumberFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderThirdLegTooShortOrRunWidthTooGreatFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderThirdLegTooShortOrRunWidthTooGreatFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The third leg of winder run is too short or the runwidth is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderThirdLegTooShortOrRunWidthTooGreatFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderThirdLegTooShortOrRunWidthTooGreatFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderThirdLegTooShortOrRunWidthTooGreatFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyEndParallelTreadsOrRunWidthFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyEndParallelTreadsOrRunWidthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at end is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderTooManyEndParallelTreadsOrRunWidthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyEndParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyEndParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyParallelTreadsAtEndFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyParallelTreadsAtEndFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at end is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderTooManyParallelTreadsAtEndFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtEndFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtEndFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyParallelTreadsAtHeadFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyParallelTreadsAtHeadFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at start is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderTooManyParallelTreadsAtHeadFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyParallelTreadsAtHeadFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyParallelTreadsAtHeadFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


WinderTooManyStartParallelTreadsOrRunWidthFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..StairRampFailures..::..WinderTooManyStartParallelTreadsOrRunWidthFailure Property
BuiltInFailures..::..StairRampFailures Class See Also Send Feedback
The number of parallel treads at start is too great or the run width is too great.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WinderTooManyStartParallelTreadsOrRunWidthFailure { get; }
Visual Basic
Public Shared ReadOnly Property WinderTooManyStartParallelTreadsOrRunWidthFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WinderTooManyStartParallelTreadsOrRunWidthFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StairRampFailures Class


BuiltInFailures.StructuralAssetFailure Class

[image]

Revit 2013 API
BuiltInFailures..::..StructuralAssetFailure Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class StructuralAssetFailure
Visual Basic
Public NotInheritable Class StructuralAssetFailure
Visual C++
public ref class StructuralAssetFailure abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..StructuralAssetFailure

See Also

BuiltInFailures..::..StructuralAssetFailure Members


BuiltInFailures.StructuralAssetFailure Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..StructuralAssetFailure Members
BuiltInFailures..::..StructuralAssetFailure Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..StructuralAssetFailure type exposes the following members.

Properties

Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

See Also

BuiltInFailures..::..StructuralAssetFailure Class


BuiltInFailures.StructuralAssetFailure Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..StructuralAssetFailure Properties
BuiltInFailures..::..StructuralAssetFailure Class See Also Send Feedback

The BuiltInFailures..::..StructuralAssetFailure type exposes the following members.

Properties

Name | Description
StructuralMaterialAssetInvalid | Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

See Also

BuiltInFailures..::..StructuralAssetFailure Class


StructuralMaterialAssetInvalid Property

[image]

Revit 2013 API
BuiltInFailures..::..StructuralAssetFailure..::..StructuralMaterialAssetInvalid Property
BuiltInFailures..::..StructuralAssetFailure Class See Also Send Feedback
Material assigned to the Analytical Element does not contain Structure parameters - verify material content.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StructuralMaterialAssetInvalid { get; }
Visual Basic
Public Shared ReadOnly Property StructuralMaterialAssetInvalid As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StructuralMaterialAssetInvalid {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..StructuralAssetFailure Class


BuiltInFailures.SweepFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SweepFailures
Visual Basic
Public NotInheritable Class SweepFailures
Visual C++
public ref class SweepFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SweepFailures

See Also

BuiltInFailures..::..SweepFailures Members


BuiltInFailures.SweepFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SweepFailures Members
BuiltInFailures..::..SweepFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.

See Also

BuiltInFailures..::..SweepFailures Class


BuiltInFailures.SweepFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SweepFailures Properties
BuiltInFailures..::..SweepFailures Class See Also Send Feedback

The BuiltInFailures..::..SweepFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweep | Can't create sweep.
ComplexPathWithComplexProfile | Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.
ProfileLoopEmpty | Profile sketch is empty!
SweepFailed | Proper sweep geometry creation failed.
SweepFailedError | Proper sweep geometry creation failed.

See Also

BuiltInFailures..::..SweepFailures Class


CannotDrawSweep Property

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures..::..CannotDrawSweep Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Can't create sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawSweep { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawSweep As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSweep {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


ComplexPathWithComplexProfile Property

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures..::..ComplexPathWithComplexProfile Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Sweep cannot have a path with ellipse or spline segments and a profile with non-straight lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ComplexPathWithComplexProfile { get; }
Visual Basic
Public Shared ReadOnly Property ComplexPathWithComplexProfile As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ComplexPathWithComplexProfile {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


ProfileLoopEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures..::..ProfileLoopEmpty Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Profile sketch is empty!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ProfileLoopEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ProfileLoopEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ProfileLoopEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


SweepFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures..::..SweepFailed Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SweepFailed { get; }
Visual Basic
Public Shared ReadOnly Property SweepFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SweepFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


SweepFailedError Property

[image]

Revit 2013 API
BuiltInFailures..::..SweepFailures..::..SweepFailedError Property
BuiltInFailures..::..SweepFailures Class See Also Send Feedback
Proper sweep geometry creation failed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SweepFailedError { get; }
Visual Basic
Public Shared ReadOnly Property SweepFailedError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SweepFailedError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweepFailures Class


BuiltInFailures.SweptBlendFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SweptBlendFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about SweptBlend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SweptBlendFailures
Visual Basic
Public NotInheritable Class SweptBlendFailures
Visual C++
public ref class SweptBlendFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SweptBlendFailures

See Also

BuiltInFailures..::..SweptBlendFailures Members


BuiltInFailures.SweptBlendFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SweptBlendFailures Members
BuiltInFailures..::..SweptBlendFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::..SweptBlendFailures Class


BuiltInFailures.SweptBlendFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SweptBlendFailures Properties
BuiltInFailures..::..SweptBlendFailures Class See Also Send Feedback

The BuiltInFailures..::..SweptBlendFailures type exposes the following members.

Properties

Name | Description
CannotDrawSweptblend | Can't create swept blend.

See Also

BuiltInFailures..::..SweptBlendFailures Class


CannotDrawSweptblend Property

[image]

Revit 2013 API
BuiltInFailures..::..SweptBlendFailures..::..CannotDrawSweptblend Property
BuiltInFailures..::..SweptBlendFailures Class See Also Send Feedback
Can't create swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotDrawSweptblend { get; }
Visual Basic
Public Shared ReadOnly Property CannotDrawSweptblend As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotDrawSweptblend {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SweptBlendFailures Class


BuiltInFailures.SystemNavigatorFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SystemNavigatorFailures Class
BuiltInFailures Class Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SystemNavigatorFailures
Visual Basic
Public NotInheritable Class SystemNavigatorFailures
Visual C++
public ref class SystemNavigatorFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SystemNavigatorFailures

See Also

BuiltInFailures..::..SystemNavigatorFailures Members


BuiltInFailures.SystemNavigatorFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SystemNavigatorFailures Members
BuiltInFailures..::..SystemNavigatorFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SystemNavigatorFailures type exposes the following members.

Properties

Name | Description
CannottFindCorrectTreeNode |
MultipleSelectNumberIsWrong |

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


BuiltInFailures.SystemNavigatorFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SystemNavigatorFailures Properties
BuiltInFailures..::..SystemNavigatorFailures Class See Also Send Feedback

The BuiltInFailures..::..SystemNavigatorFailures type exposes the following members.

Properties

Name | Description
CannottFindCorrectTreeNode |
MultipleSelectNumberIsWrong |

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


CannottFindCorrectTreeNode Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemNavigatorFailures..::..CannottFindCorrectTreeNode Property
BuiltInFailures..::..SystemNavigatorFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannottFindCorrectTreeNode { get; }
Visual Basic
Public Shared ReadOnly Property CannottFindCorrectTreeNode As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannottFindCorrectTreeNode {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


MultipleSelectNumberIsWrong Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemNavigatorFailures..::..MultipleSelectNumberIsWrong Property
BuiltInFailures..::..SystemNavigatorFailures Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultipleSelectNumberIsWrong { get; }
Visual Basic
Public Shared ReadOnly Property MultipleSelectNumberIsWrong As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultipleSelectNumberIsWrong {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemNavigatorFailures Class


BuiltInFailures.SystemsFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class SystemsFailures
Visual Basic
Public NotInheritable Class SystemsFailures
Visual C++
public ref class SystemsFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..SystemsFailures

See Also

BuiltInFailures..::..SystemsFailures Members


BuiltInFailures.SystemsFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures Members
BuiltInFailures..::..SystemsFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::..SystemsFailures Class


BuiltInFailures.SystemsFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures Properties
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback

The BuiltInFailures..::..SystemsFailures type exposes the following members.

Properties

Name | Description
AddingOtherConnectedMembersToSystem | "You have selected elements that are connected to other elements. These elements will also be added to the System."
DefaultSystemOver50Elems | The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.
ElementsBelongToOtherSystem | You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.
FamilyDoesntMatchSystemProperties | The family no longer matches the properties for the System. Disconnect the family from the System?
FamilyDoesntMatchSystemPropertiesWasDisconnected | The family no longer matches the properties for the System. Disconnect the family from the System?
MismatchSystemType | Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.
SelectedElementsArePartOfOtherSystem | You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

See Also

BuiltInFailures..::..SystemsFailures Class


AddingOtherConnectedMembersToSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..AddingOtherConnectedMembersToSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
"You have selected elements that are connected to other elements. These elements will also be added to the System."

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId AddingOtherConnectedMembersToSystem { get; }
Visual Basic
Public Shared ReadOnly Property AddingOtherConnectedMembersToSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ AddingOtherConnectedMembersToSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


DefaultSystemOver50Elems Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..DefaultSystemOver50Elems Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The default system "[Element Name]" is now over 50 elements. To improve performance, Revit is no longer calculating the critical path pressure drop and the more complex duct sizing has been disabled. If you want to use these features, you must define logical systems in the model instead of using the default system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DefaultSystemOver50Elems { get; }
Visual Basic
Public Shared ReadOnly Property DefaultSystemOver50Elems As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DefaultSystemOver50Elems {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


ElementsBelongToOtherSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..ElementsBelongToOtherSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
You have selected elements that are already part of other Systems that have assigned Equipment. The elements you selected cannot be added to this System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementsBelongToOtherSystem { get; }
Visual Basic
Public Shared ReadOnly Property ElementsBelongToOtherSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementsBelongToOtherSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


FamilyDoesntMatchSystemProperties Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..FamilyDoesntMatchSystemProperties Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemProperties { get; }
Visual Basic
Public Shared ReadOnly Property FamilyDoesntMatchSystemProperties As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemProperties {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


FamilyDoesntMatchSystemPropertiesWasDisconnected Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..FamilyDoesntMatchSystemPropertiesWasDisconnected Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
The family no longer matches the properties for the System. Disconnect the family from the System?

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FamilyDoesntMatchSystemPropertiesWasDisconnected { get; }
Visual Basic
Public Shared ReadOnly Property FamilyDoesntMatchSystemPropertiesWasDisconnected As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FamilyDoesntMatchSystemPropertiesWasDisconnected {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


MismatchSystemType Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..MismatchSystemType Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
Cannot add [Element] to System. The System Type for the available connector does not match the System Type ([Type Name]) for the System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MismatchSystemType { get; }
Visual Basic
Public Shared ReadOnly Property MismatchSystemType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MismatchSystemType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


SelectedElementsArePartOfOtherSystem Property

[image]

Revit 2013 API
BuiltInFailures..::..SystemsFailures..::..SelectedElementsArePartOfOtherSystem Property
BuiltInFailures..::..SystemsFailures Class See Also Send Feedback
You have selected elements that are already part of other System. They will be removed from the original Systems and added to this one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SelectedElementsArePartOfOtherSystem { get; }
Visual Basic
Public Shared ReadOnly Property SelectedElementsArePartOfOtherSystem As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SelectedElementsArePartOfOtherSystem {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..SystemsFailures Class


BuiltInFailures.TagFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class TagFailures
Visual Basic
Public NotInheritable Class TagFailures
Visual C++
public ref class TagFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TagFailures

See Also

BuiltInFailures..::..TagFailures Members


BuiltInFailures.TagFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..TagFailures Members
BuiltInFailures..::..TagFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.

See Also

BuiltInFailures..::..TagFailures Class


BuiltInFailures.TagFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..TagFailures Properties
BuiltInFailures..::..TagFailures Class See Also Send Feedback

The BuiltInFailures..::..TagFailures type exposes the following members.

Properties

Name | Description
CannotCopyTag | A tag cannot be arrayed without copying the associated element.
CannotCopyTagWarn | A tag cannot be arrayed without copying the associated element.
CannotPasteOrphanTags | Orphaned tags cannot be pasted.
CannotPasteOrphanTagsWarn | Orphaned tags cannot be pasted.
CannotPasteTag | Can't find new element to tag. Tag won't be copied.
ElementCategoryChangeInvalidatesTag | Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.
ElementCategoryChangeInvalidatesTagUpgrade | During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.
MultiCategoryTagFilterParamNotFoundInElement | The filter specified by Multi-Category Tag can't be used with the tagged object.
TagsCannotBePlacedInUnlocked3dViews | Tags can't be pasted into Unlocked 3D views.

See Also

BuiltInFailures..::..TagFailures Class


CannotCopyTag Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..CannotCopyTag Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyTag { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyTag As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotCopyTagWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..CannotCopyTagWarn Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
A tag cannot be arrayed without copying the associated element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCopyTagWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotCopyTagWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCopyTagWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteOrphanTags Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..CannotPasteOrphanTags Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTags { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteOrphanTags As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTags {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteOrphanTagsWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..CannotPasteOrphanTagsWarn Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Orphaned tags cannot be pasted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteOrphanTagsWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteOrphanTagsWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteOrphanTagsWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


CannotPasteTag Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..CannotPasteTag Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Can't find new element to tag. Tag won't be copied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteTag { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteTag As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


ElementCategoryChangeInvalidatesTag Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..ElementCategoryChangeInvalidatesTag Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Elements have changed category. Tags for these elements are now of the wrong category and will be deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesTag { get; }
Visual Basic
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTag As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTag {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


ElementCategoryChangeInvalidatesTagUpgrade Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..ElementCategoryChangeInvalidatesTagUpgrade Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
During upgrade, Revit discovered that the highlighted elements were marked with tags of the wrong category. These tags were deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ElementCategoryChangeInvalidatesTagUpgrade { get; }
Visual Basic
Public Shared ReadOnly Property ElementCategoryChangeInvalidatesTagUpgrade As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ElementCategoryChangeInvalidatesTagUpgrade {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


MultiCategoryTagFilterParamNotFoundInElement Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..MultiCategoryTagFilterParamNotFoundInElement Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
The filter specified by Multi-Category Tag can't be used with the tagged object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MultiCategoryTagFilterParamNotFoundInElement { get; }
Visual Basic
Public Shared ReadOnly Property MultiCategoryTagFilterParamNotFoundInElement As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MultiCategoryTagFilterParamNotFoundInElement {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


TagsCannotBePlacedInUnlocked3dViews Property

[image]

Revit 2013 API
BuiltInFailures..::..TagFailures..::..TagsCannotBePlacedInUnlocked3dViews Property
BuiltInFailures..::..TagFailures Class See Also Send Feedback
Tags can't be pasted into Unlocked 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TagsCannotBePlacedInUnlocked3dViews { get; }
Visual Basic
Public Shared ReadOnly Property TagsCannotBePlacedInUnlocked3dViews As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TagsCannotBePlacedInUnlocked3dViews {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TagFailures Class


BuiltInFailures.TextFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..TextFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class TextFailures
Visual Basic
Public NotInheritable Class TextFailures
Visual C++
public ref class TextFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TextFailures

See Also

BuiltInFailures..::..TextFailures Members


BuiltInFailures.TextFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..TextFailures Members
BuiltInFailures..::..TextFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..TextFailures type exposes the following members.

Properties

Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.

See Also

BuiltInFailures..::..TextFailures Class


BuiltInFailures.TextFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..TextFailures Properties
BuiltInFailures..::..TextFailures Class See Also Send Feedback

The BuiltInFailures..::..TextFailures type exposes the following members.

Properties

Name | Description
CannotCreateModeltext | Can't create Model Text.
ModeltextIsEmpty | Model Text deleted because it consists entirely of spaces and/or carriage returns.

See Also

BuiltInFailures..::..TextFailures Class


CannotCreateModeltext Property

[image]

Revit 2013 API
BuiltInFailures..::..TextFailures..::..CannotCreateModeltext Property
BuiltInFailures..::..TextFailures Class See Also Send Feedback
Can't create Model Text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotCreateModeltext { get; }
Visual Basic
Public Shared ReadOnly Property CannotCreateModeltext As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotCreateModeltext {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TextFailures Class


ModeltextIsEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..TextFailures..::..ModeltextIsEmpty Property
BuiltInFailures..::..TextFailures Class See Also Send Feedback
Model Text deleted because it consists entirely of spaces and/or carriage returns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ModeltextIsEmpty { get; }
Visual Basic
Public Shared ReadOnly Property ModeltextIsEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ModeltextIsEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TextFailures Class


BuiltInFailures.TrussFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class TrussFailures
Visual Basic
Public NotInheritable Class TrussFailures
Visual C++
public ref class TrussFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..TrussFailures

See Also

BuiltInFailures..::..TrussFailures Members


BuiltInFailures.TrussFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..TrussFailures Members
BuiltInFailures..::..TrussFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::..TrussFailures Class


BuiltInFailures.TrussFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..TrussFailures Properties
BuiltInFailures..::..TrussFailures Class See Also Send Feedback

The BuiltInFailures..::..TrussFailures type exposes the following members.

Properties

Name | Description
IncorrectWallUsageWithAttachedStruct | A structural framing element is attached to a wall whose Structural Usage is set to [Usage].
InvalidWorkplaneForStructuralFraming | Workplane not valid for Structural Framing component "[Family Name]"
RemoveTrussSketch | Remove Sketch
TrussBadTransformation | Revit cannot transform the truss Layout Family to the Truss as oriented in the project.
TrussChordUntransformable | Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.
TrussDuplicateEngineeringType | Elements have duplicate 'Engineering Type' values.
TrussInvalidSymbolGeom | Truss is unable to generate any members due to layout family error.
TrussIsAttachedTo | Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.
TrussLayoutNonSympleTopChord | This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.
TrussLayoutOverlapedCurves | The current transformation of this specific truss layout will some sub members to overlap.
TrussNotJoinedWebs | The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.
TrussUserDefinedMemberDeleted | A user-defined structural member was deleted due to missing or deleted references.
TrussUserDefinedMemberNotJoined | Both start and end of web must intersect the truss.

See Also

BuiltInFailures..::..TrussFailures Class


IncorrectWallUsageWithAttachedStruct Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..IncorrectWallUsageWithAttachedStruct Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
A structural framing element is attached to a wall whose Structural Usage is set to [Usage].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId IncorrectWallUsageWithAttachedStruct { get; }
Visual Basic
Public Shared ReadOnly Property IncorrectWallUsageWithAttachedStruct As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ IncorrectWallUsageWithAttachedStruct {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


InvalidWorkplaneForStructuralFraming Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..InvalidWorkplaneForStructuralFraming Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Workplane not valid for Structural Framing component "[Family Name]"

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidWorkplaneForStructuralFraming { get; }
Visual Basic
Public Shared ReadOnly Property InvalidWorkplaneForStructuralFraming As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidWorkplaneForStructuralFraming {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


RemoveTrussSketch Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..RemoveTrussSketch Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Remove Sketch

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemoveTrussSketch { get; }
Visual Basic
Public Shared ReadOnly Property RemoveTrussSketch As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemoveTrussSketch {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussBadTransformation Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussBadTransformation Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Revit cannot transform the truss Layout Family to the Truss as oriented in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussBadTransformation { get; }
Visual Basic
Public Shared ReadOnly Property TrussBadTransformation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussBadTransformation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussChordUntransformable Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussChordUntransformable Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Unable to maintain user changes to unpinned Chord. Restoring Truss-defined shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussChordUntransformable { get; }
Visual Basic
Public Shared ReadOnly Property TrussChordUntransformable As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussChordUntransformable {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussDuplicateEngineeringType Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussDuplicateEngineeringType Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Elements have duplicate 'Engineering Type' values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussDuplicateEngineeringType { get; }
Visual Basic
Public Shared ReadOnly Property TrussDuplicateEngineeringType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussDuplicateEngineeringType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussInvalidSymbolGeom Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussInvalidSymbolGeom Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Truss is unable to generate any members due to layout family error.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussInvalidSymbolGeom { get; }
Visual Basic
Public Shared ReadOnly Property TrussInvalidSymbolGeom As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussInvalidSymbolGeom {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussIsAttachedTo Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussIsAttachedTo Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Revit cannot attach to the chosen Roof/Slab. The truss cannot project to a surface or the attachment creates an invalid profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussIsAttachedTo { get; }
Visual Basic
Public Shared ReadOnly Property TrussIsAttachedTo As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussIsAttachedTo {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussLayoutNonSympleTopChord Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussLayoutNonSympleTopChord Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
This truss layout family defines an offset or non horizontal top chord. This may conflict with attachment or profile editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussLayoutNonSympleTopChord { get; }
Visual Basic
Public Shared ReadOnly Property TrussLayoutNonSympleTopChord As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussLayoutNonSympleTopChord {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussLayoutOverlapedCurves Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussLayoutOverlapedCurves Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
The current transformation of this specific truss layout will some sub members to overlap.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussLayoutOverlapedCurves { get; }
Visual Basic
Public Shared ReadOnly Property TrussLayoutOverlapedCurves As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussLayoutOverlapedCurves {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussNotJoinedWebs Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussNotJoinedWebs Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
The current edits are causing some webs to disjoin. The truss layout family requires additional constraints to maintain these joins.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussNotJoinedWebs { get; }
Visual Basic
Public Shared ReadOnly Property TrussNotJoinedWebs As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussNotJoinedWebs {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussUserDefinedMemberDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussUserDefinedMemberDeleted Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
A user-defined structural member was deleted due to missing or deleted references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberDeleted { get; }
Visual Basic
Public Shared ReadOnly Property TrussUserDefinedMemberDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


TrussUserDefinedMemberNotJoined Property

[image]

Revit 2013 API
BuiltInFailures..::..TrussFailures..::..TrussUserDefinedMemberNotJoined Property
BuiltInFailures..::..TrussFailures Class See Also Send Feedback
Both start and end of web must intersect the truss.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TrussUserDefinedMemberNotJoined { get; }
Visual Basic
Public Shared ReadOnly Property TrussUserDefinedMemberNotJoined As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TrussUserDefinedMemberNotJoined {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..TrussFailures Class


BuiltInFailures.ViewFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about ViewFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ViewFailures
Visual Basic
Public NotInheritable Class ViewFailures
Visual C++
public ref class ViewFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..ViewFailures

See Also

BuiltInFailures..::..ViewFailures Members


BuiltInFailures.ViewFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..ViewFailures Members
BuiltInFailures..::..ViewFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | Can't construct View Clipping and Cropping from Scope Box.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::..ViewFailures Class


BuiltInFailures.ViewFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..ViewFailures Properties
BuiltInFailures..::..ViewFailures Class See Also Send Feedback

The BuiltInFailures..::..ViewFailures type exposes the following members.

Properties

Name | Description
BadViewDirectionSetting | Plan view DBViewType has invalid view direction parameter.
CanNotDeleteLastOpenView | Deleting of all open views in a project is not allowed.
CannotPasteViewReferences | Cannot paste view references into the view they reference or into unrelated views
DetailNumberDuplicate | Detail Number is already in use. Enter a unique number.
DetailNumberEmpty | Detail Number is empty
InitialViewDeleted | The starting view for the project has been deleted.
InsertColumnViewError | Column cannot be placed in Elevation or Section view
InsertColumnViewFailure | Column cannot be placed in Elevation or Section view
InsertComponentViewError | This type of Component cannot be placed in Elevation or Section view
InsertComponentViewFailure | This type of Component cannot be placed in Elevation or Section view
InvalidDBviewScopeBox | Can't construct View Clipping and Cropping from Scope Box.
NewElementInvisibleInCurrentView | The newly created object is not visible in the current view.
NoTargetsForDependentViewPropagation | There are no valid views. Only views without dependents can be used.
NothingToApplyError | Start and end elevations are the same, nothing to Apply.
NothingToApplyWarning | Start and end elevations are the same, nothing to Apply.
ReloadLatestDeletedLastOpenView | The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.
TurnCropRegionOffRemovesViewBreaks | Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.
ViewPublishFailed | The following views could not be published.
ZeroLengthViewBreaksRemoved | Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.
ZeroLengthViewRegionsRemoved | Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

See Also

BuiltInFailures..::..ViewFailures Class


BadViewDirectionSetting Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..BadViewDirectionSetting Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Plan view DBViewType has invalid view direction parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId BadViewDirectionSetting { get; }
Visual Basic
Public Shared ReadOnly Property BadViewDirectionSetting As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ BadViewDirectionSetting {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


CanNotDeleteLastOpenView Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..CanNotDeleteLastOpenView Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Deleting of all open views in a project is not allowed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CanNotDeleteLastOpenView { get; }
Visual Basic
Public Shared ReadOnly Property CanNotDeleteLastOpenView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CanNotDeleteLastOpenView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


CannotPasteViewReferences Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..CannotPasteViewReferences Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Cannot paste view references into the view they reference or into unrelated views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotPasteViewReferences { get; }
Visual Basic
Public Shared ReadOnly Property CannotPasteViewReferences As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotPasteViewReferences {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


DetailNumberDuplicate Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..DetailNumberDuplicate Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Detail Number is already in use. Enter a unique number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DetailNumberDuplicate { get; }
Visual Basic
Public Shared ReadOnly Property DetailNumberDuplicate As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailNumberDuplicate {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


DetailNumberEmpty Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..DetailNumberEmpty Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Detail Number is empty

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DetailNumberEmpty { get; }
Visual Basic
Public Shared ReadOnly Property DetailNumberEmpty As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DetailNumberEmpty {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InitialViewDeleted Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InitialViewDeleted Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The starting view for the project has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InitialViewDeleted { get; }
Visual Basic
Public Shared ReadOnly Property InitialViewDeleted As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InitialViewDeleted {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertColumnViewError Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InsertColumnViewError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertColumnViewError { get; }
Visual Basic
Public Shared ReadOnly Property InsertColumnViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertColumnViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertColumnViewFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InsertColumnViewFailure Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Column cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertColumnViewFailure { get; }
Visual Basic
Public Shared ReadOnly Property InsertColumnViewFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertColumnViewFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertComponentViewError Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InsertComponentViewError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertComponentViewError { get; }
Visual Basic
Public Shared ReadOnly Property InsertComponentViewError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertComponentViewError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InsertComponentViewFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InsertComponentViewFailure Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
This type of Component cannot be placed in Elevation or Section view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InsertComponentViewFailure { get; }
Visual Basic
Public Shared ReadOnly Property InsertComponentViewFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InsertComponentViewFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


InvalidDBviewScopeBox Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..InvalidDBviewScopeBox Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Can't construct View Clipping and Cropping from Scope Box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidDBviewScopeBox { get; }
Visual Basic
Public Shared ReadOnly Property InvalidDBviewScopeBox As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidDBviewScopeBox {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NewElementInvisibleInCurrentView Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..NewElementInvisibleInCurrentView Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The newly created object is not visible in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NewElementInvisibleInCurrentView { get; }
Visual Basic
Public Shared ReadOnly Property NewElementInvisibleInCurrentView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NewElementInvisibleInCurrentView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NoTargetsForDependentViewPropagation Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..NoTargetsForDependentViewPropagation Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
There are no valid views. Only views without dependents can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoTargetsForDependentViewPropagation { get; }
Visual Basic
Public Shared ReadOnly Property NoTargetsForDependentViewPropagation As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoTargetsForDependentViewPropagation {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NothingToApplyError Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..NothingToApplyError Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NothingToApplyError { get; }
Visual Basic
Public Shared ReadOnly Property NothingToApplyError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


NothingToApplyWarning Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..NothingToApplyWarning Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Start and end elevations are the same, nothing to Apply.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NothingToApplyWarning { get; }
Visual Basic
Public Shared ReadOnly Property NothingToApplyWarning As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NothingToApplyWarning {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ReloadLatestDeletedLastOpenView Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..ReloadLatestDeletedLastOpenView Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The only open view has been deleted because of changes from the Central Model. Open another view and Reload Latest or Synchronize with Central again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ReloadLatestDeletedLastOpenView { get; }
Visual Basic
Public Shared ReadOnly Property ReloadLatestDeletedLastOpenView As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ReloadLatestDeletedLastOpenView {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


TurnCropRegionOffRemovesViewBreaks Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..TurnCropRegionOffRemovesViewBreaks Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Turning off the Crop Region of the view will remove all View Breaks. If the Crop Region is turned on at a later time, any desired View Breaks must be created again.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TurnCropRegionOffRemovesViewBreaks { get; }
Visual Basic
Public Shared ReadOnly Property TurnCropRegionOffRemovesViewBreaks As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TurnCropRegionOffRemovesViewBreaks {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ViewPublishFailed Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..ViewPublishFailed Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
The following views could not be published.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ViewPublishFailed { get; }
Visual Basic
Public Shared ReadOnly Property ViewPublishFailed As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ViewPublishFailed {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ZeroLengthViewBreaksRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..ZeroLengthViewBreaksRemoved Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Some View Regions were consolidated. When the size of a View Break between View Regions becomes zero, the View Break is removed and the adjacent View Regions are joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthViewBreaksRemoved { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthViewBreaksRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthViewBreaksRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


ZeroLengthViewRegionsRemoved Property

[image]

Revit 2013 API
BuiltInFailures..::..ViewFailures..::..ZeroLengthViewRegionsRemoved Property
BuiltInFailures..::..ViewFailures Class See Also Send Feedback
Some View Regions were removed. When the size of a View Region becomes zero, it is removed from the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ZeroLengthViewRegionsRemoved { get; }
Visual Basic
Public Shared ReadOnly Property ZeroLengthViewRegionsRemoved As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ZeroLengthViewRegionsRemoved {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..ViewFailures Class


BuiltInFailures.WallFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class WallFailures
Visual Basic
Public NotInheritable Class WallFailures
Visual C++
public ref class WallFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WallFailures

See Also

BuiltInFailures..::..WallFailures Members


BuiltInFailures.WallFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..WallFailures Members
BuiltInFailures..::..WallFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

See Also

BuiltInFailures..::..WallFailures Class


BuiltInFailures.WallFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..WallFailures Properties
BuiltInFailures..::..WallFailures Class See Also Send Feedback

The BuiltInFailures..::..WallFailures type exposes the following members.

Properties

Name | Description
CannotChangeSubwall | Changing the type of a subwall is not allowed. Edit the stacked wall type instead.
CannotChangeTypeOfOldCurtainPanel | Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.
CannotMaintainKeyReference | Can't maintain the position of the Location Line in this Wall.
CannotMirrorWallPanel | Cannot mirror wall panels.
CannotRedoFaceBased | Faces defining this Element cannot be reacquired.
CannotRedoFaceBasedWarn | Faces defining this Element cannot be reacquired.
CannotRedoFaceRoof | "Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.
CannotSplitJoinHostsInplaceFamilies | Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.
CannotSplitVerticallyCompoundWall | Can't divide Wall's face to assign different materials to a vertically compound Wall.
CannotToSplitWallPanels | Unable to split wall panel(s).
CannotUpdateWallPanel | Unable to update wall panel.
ChangingWallsweepType | This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.
ConstrainedToWall | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ConstrainedToWallError | Sketch Lines created with Pick Wall must remain parallel to the Wall.
ContFootingCannotJoin | Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.
ContFootingRadiusTooSmall | Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.
EmbeddedButShouldNotBe | Conditions for wall embedding are no longer satisfied.
FaceBecameVertical | Face defining this non-vertical Wall is vertical.
FaceIsNoGoodForWall | Defining face is not suitable for walls.
FaceIsNoLongerVertical | Face defining this vertical Wall is no longer vertical.
FaceWallBadType | Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.
FaceWallComplexType | Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.
FaceWallFailedToMake | Can't make Face Wall shape.
FaceWallMissingFace | No picked face found.
FailedConvertWallToPanel | Unable to convert wall to panel.
FailedToChangeInstSymbol | Failed to change symbol of instance.
FailedToStoreSideFace | Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.
InvalidBaseConstraintForLevel | Base Constraint is invalid for the Level.
InvalidCompoundStructure | Invalid compound structure.
InvalidTargetPosition | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTargetPositionError | Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.
InvalidTopConstraintForLevel | Top Constraint is invalid for the Level.
LostEditsJoinsRedoFaceBased | Previous edits and /or wall joins will not be preserved on this operation.
ParameterChangeNotAffectingGeometry | Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.
RecursionParameterIgnored | Parameter-defined type of curtain panels defined in a circular way and will be ignored.
RemapConstrainLocationLine | Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.
ShorterThanMinWall | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallError | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShorterThanMinWallFailure | Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].
ShouldAdjustWallParameters | The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.
StackedWallNeedsUnjoin | A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.
TooShortStackedWall | Stacked wall instance is too short.
UnableToCreateWallForPanel | Unable to create wall for curtain wall panel.
UnableToDeleteWallForPanel | Unable to delete curtain panel wall.
UnjoinOnEditWallChange | Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]
VerticalLayerExtensionFailure | Cannot extend layer(s) of the highlighted vertically compound wall.
VerticalLayerExtensionFailureError | Cannot extend layer(s) of the highlighted vertically compound wall.
WallCutoutForInsertionFailure | Can't cut wall for inserted objects
WallLacksCurve | Wall does not have both a curve driver and a curve!!!!
WallNegativeHeight | The top of the Wall is lower than the base of the Wall.
WallSettingsChanged | Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

See Also

BuiltInFailures..::..WallFailures Class


CannotChangeSubwall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotChangeSubwall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Changing the type of a subwall is not allowed. Edit the stacked wall type instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeSubwall { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeSubwall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeSubwall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotChangeTypeOfOldCurtainPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotChangeTypeOfOldCurtainPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot change the type of curtain panels in walls created with early versions of Revit. To change the panels of this curtain wall, wall must be recreated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotChangeTypeOfOldCurtainPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotChangeTypeOfOldCurtainPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotChangeTypeOfOldCurtainPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotMaintainKeyReference Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotMaintainKeyReference Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't maintain the position of the Location Line in this Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMaintainKeyReference { get; }
Visual Basic
Public Shared ReadOnly Property CannotMaintainKeyReference As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMaintainKeyReference {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotMirrorWallPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotMirrorWallPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot mirror wall panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotMirrorWallPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotMirrorWallPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotMirrorWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotRedoFaceBased Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotRedoFaceBased Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceBased { get; }
Visual Basic
Public Shared ReadOnly Property CannotRedoFaceBased As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceBased {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotRedoFaceBasedWarn Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotRedoFaceBasedWarn Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Faces defining this Element cannot be reacquired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceBasedWarn { get; }
Visual Basic
Public Shared ReadOnly Property CannotRedoFaceBasedWarn As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceBasedWarn {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotRedoFaceRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotRedoFaceRoof Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
"Faces defining this Roof cannot be reacquired. Either delete the Roof or leave as it is.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotRedoFaceRoof { get; }
Visual Basic
Public Shared ReadOnly Property CannotRedoFaceRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotRedoFaceRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotSplitJoinHostsInplaceFamilies Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotSplitJoinHostsInplaceFamilies Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't split/join this host because there are instances of In-place Families that cut openings into it. Edit or delete instances first so they don't cut into the host to be split or joined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitJoinHostsInplaceFamilies { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitJoinHostsInplaceFamilies As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitJoinHostsInplaceFamilies {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotSplitVerticallyCompoundWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotSplitVerticallyCompoundWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't divide Wall's face to assign different materials to a vertically compound Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotSplitVerticallyCompoundWall { get; }
Visual Basic
Public Shared ReadOnly Property CannotSplitVerticallyCompoundWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotSplitVerticallyCompoundWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotToSplitWallPanels Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotToSplitWallPanels Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to split wall panel(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotToSplitWallPanels { get; }
Visual Basic
Public Shared ReadOnly Property CannotToSplitWallPanels As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotToSplitWallPanels {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


CannotUpdateWallPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..CannotUpdateWallPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to update wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId CannotUpdateWallPanel { get; }
Visual Basic
Public Shared ReadOnly Property CannotUpdateWallPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ CannotUpdateWallPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ChangingWallsweepType Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ChangingWallsweepType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
This wall sweep instance has different profile or material than its type. You may delete the sweep, or if you ignore this warning, it will be regenerated according to its type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ChangingWallsweepType { get; }
Visual Basic
Public Shared ReadOnly Property ChangingWallsweepType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ChangingWallsweepType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ConstrainedToWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ConstrainedToWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConstrainedToWall { get; }
Visual Basic
Public Shared ReadOnly Property ConstrainedToWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ConstrainedToWallError Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ConstrainedToWallError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Sketch Lines created with Pick Wall must remain parallel to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ConstrainedToWallError { get; }
Visual Basic
Public Shared ReadOnly Property ConstrainedToWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ConstrainedToWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ContFootingCannotJoin Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ContFootingCannotJoin Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Miter plane for Wall Foundation join is too far away; Bisecting plane will be used instead.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContFootingCannotJoin { get; }
Visual Basic
Public Shared ReadOnly Property ContFootingCannotJoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContFootingCannotJoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ContFootingRadiusTooSmall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ContFootingRadiusTooSmall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't display the Wall Foundation, because the Wall's radius is too small. Please increase the radius to display the Wall Foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ContFootingRadiusTooSmall { get; }
Visual Basic
Public Shared ReadOnly Property ContFootingRadiusTooSmall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ContFootingRadiusTooSmall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


EmbeddedButShouldNotBe Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..EmbeddedButShouldNotBe Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Conditions for wall embedding are no longer satisfied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId EmbeddedButShouldNotBe { get; }
Visual Basic
Public Shared ReadOnly Property EmbeddedButShouldNotBe As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ EmbeddedButShouldNotBe {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceBecameVertical Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceBecameVertical Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Face defining this non-vertical Wall is vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceBecameVertical { get; }
Visual Basic
Public Shared ReadOnly Property FaceBecameVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceBecameVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceIsNoGoodForWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceIsNoGoodForWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Defining face is not suitable for walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceIsNoGoodForWall { get; }
Visual Basic
Public Shared ReadOnly Property FaceIsNoGoodForWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoGoodForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceIsNoLongerVertical Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceIsNoLongerVertical Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Face defining this vertical Wall is no longer vertical.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceIsNoLongerVertical { get; }
Visual Basic
Public Shared ReadOnly Property FaceIsNoLongerVertical As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceIsNoLongerVertical {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallBadType Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceWallBadType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall type '[Type Name]' is incompatible with picked face. Only basic wall types are accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallBadType { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallBadType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallBadType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallComplexType Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceWallComplexType Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Vertically compound wall type features sweeps, reveals, or split layers are not supported on non-vertical face. Consider using a simplified type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallComplexType { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallComplexType As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallComplexType {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallFailedToMake Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceWallFailedToMake Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't make Face Wall shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallFailedToMake { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallFailedToMake As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallFailedToMake {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FaceWallMissingFace Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FaceWallMissingFace Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
No picked face found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FaceWallMissingFace { get; }
Visual Basic
Public Shared ReadOnly Property FaceWallMissingFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FaceWallMissingFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedConvertWallToPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FailedConvertWallToPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to convert wall to panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedConvertWallToPanel { get; }
Visual Basic
Public Shared ReadOnly Property FailedConvertWallToPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedConvertWallToPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedToChangeInstSymbol Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FailedToChangeInstSymbol Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Failed to change symbol of instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToChangeInstSymbol { get; }
Visual Basic
Public Shared ReadOnly Property FailedToChangeInstSymbol As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToChangeInstSymbol {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


FailedToStoreSideFace Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..FailedToStoreSideFace Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Failed to store wall side face. Wall sweeps on this wall will fail to regenerate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId FailedToStoreSideFace { get; }
Visual Basic
Public Shared ReadOnly Property FailedToStoreSideFace As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ FailedToStoreSideFace {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidBaseConstraintForLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..InvalidBaseConstraintForLevel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Base Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidBaseConstraintForLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidBaseConstraintForLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidBaseConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidCompoundStructure Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..InvalidCompoundStructure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Invalid compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidCompoundStructure { get; }
Visual Basic
Public Shared ReadOnly Property InvalidCompoundStructure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidCompoundStructure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidTargetPosition Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..InvalidTargetPosition Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTargetPosition { get; }
Visual Basic
Public Shared ReadOnly Property InvalidTargetPosition As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidTargetPosition {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidTargetPositionError Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..InvalidTargetPositionError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Joining the highlighted wall to the highlighted element moves the wall's top below its bottom or its bottom above its top, or interferes with wall joins or holes in the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTargetPositionError { get; }
Visual Basic
Public Shared ReadOnly Property InvalidTargetPositionError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidTargetPositionError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


InvalidTopConstraintForLevel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..InvalidTopConstraintForLevel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Top Constraint is invalid for the Level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId InvalidTopConstraintForLevel { get; }
Visual Basic
Public Shared ReadOnly Property InvalidTopConstraintForLevel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ InvalidTopConstraintForLevel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


LostEditsJoinsRedoFaceBased Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..LostEditsJoinsRedoFaceBased Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Previous edits and /or wall joins will not be preserved on this operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId LostEditsJoinsRedoFaceBased { get; }
Visual Basic
Public Shared ReadOnly Property LostEditsJoinsRedoFaceBased As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ LostEditsJoinsRedoFaceBased {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ParameterChangeNotAffectingGeometry Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ParameterChangeNotAffectingGeometry Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Changing this element's parameter has no effect on its current position or geometry. Check to see if the element is constrained either in the project view or in the element's sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ParameterChangeNotAffectingGeometry { get; }
Visual Basic
Public Shared ReadOnly Property ParameterChangeNotAffectingGeometry As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ParameterChangeNotAffectingGeometry {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


RecursionParameterIgnored Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..RecursionParameterIgnored Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Parameter-defined type of curtain panels defined in a circular way and will be ignored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RecursionParameterIgnored { get; }
Visual Basic
Public Shared ReadOnly Property RecursionParameterIgnored As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RecursionParameterIgnored {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


RemapConstrainLocationLine Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..RemapConstrainLocationLine Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Existing locked constraints to the Location Line will be transferred to the new Location Line position. Press "Unconstrain" to remove the constraint rather than transferring it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId RemapConstrainLocationLine { get; }
Visual Basic
Public Shared ReadOnly Property RemapConstrainLocationLine As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ RemapConstrainLocationLine {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWall { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWallError Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWallError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallError { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWallError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShorterThanMinWallFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ShorterThanMinWallFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall is shorter than minimum height allowed by its type.\nIt is [Length] and must be at least [Length].

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShorterThanMinWallFailure { get; }
Visual Basic
Public Shared ReadOnly Property ShorterThanMinWallFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShorterThanMinWallFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


ShouldAdjustWallParameters Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..ShouldAdjustWallParameters Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
The best way to control top and base of the Wall is to modify the Constraints and Offset Parameters in Properties dialog.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId ShouldAdjustWallParameters { get; }
Visual Basic
Public Shared ReadOnly Property ShouldAdjustWallParameters As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ ShouldAdjustWallParameters {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


StackedWallNeedsUnjoin Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..StackedWallNeedsUnjoin Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
A subwall of this stacked wall is unjoined from its neighbors because it was pulled too far.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId StackedWallNeedsUnjoin { get; }
Visual Basic
Public Shared ReadOnly Property StackedWallNeedsUnjoin As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ StackedWallNeedsUnjoin {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


TooShortStackedWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..TooShortStackedWall Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Stacked wall instance is too short.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId TooShortStackedWall { get; }
Visual Basic
Public Shared ReadOnly Property TooShortStackedWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ TooShortStackedWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


UnableToCreateWallForPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..UnableToCreateWallForPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to create wall for curtain wall panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToCreateWallForPanel { get; }
Visual Basic
Public Shared ReadOnly Property UnableToCreateWallForPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToCreateWallForPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


UnableToDeleteWallForPanel Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..UnableToDeleteWallForPanel Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Unable to delete curtain panel wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnableToDeleteWallForPanel { get; }
Visual Basic
Public Shared ReadOnly Property UnableToDeleteWallForPanel As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnableToDeleteWallForPanel {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


UnjoinOnEditWallChange Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..UnjoinOnEditWallChange Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Line associated with a joined face has been moved. This action will cause the other walls to become disjoined from this face. [Description]

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId UnjoinOnEditWallChange { get; }
Visual Basic
Public Shared ReadOnly Property UnjoinOnEditWallChange As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ UnjoinOnEditWallChange {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


VerticalLayerExtensionFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..VerticalLayerExtensionFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VerticalLayerExtensionFailure { get; }
Visual Basic
Public Shared ReadOnly Property VerticalLayerExtensionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


VerticalLayerExtensionFailureError Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..VerticalLayerExtensionFailureError Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Cannot extend layer(s) of the highlighted vertically compound wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId VerticalLayerExtensionFailureError { get; }
Visual Basic
Public Shared ReadOnly Property VerticalLayerExtensionFailureError As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ VerticalLayerExtensionFailureError {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallCutoutForInsertionFailure Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..WallCutoutForInsertionFailure Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Can't cut wall for inserted objects

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallCutoutForInsertionFailure { get; }
Visual Basic
Public Shared ReadOnly Property WallCutoutForInsertionFailure As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallCutoutForInsertionFailure {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallLacksCurve Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..WallLacksCurve Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Wall does not have both a curve driver and a curve!!!!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallLacksCurve { get; }
Visual Basic
Public Shared ReadOnly Property WallLacksCurve As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallLacksCurve {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallNegativeHeight Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..WallNegativeHeight Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
The top of the Wall is lower than the base of the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallNegativeHeight { get; }
Visual Basic
Public Shared ReadOnly Property WallNegativeHeight As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallNegativeHeight {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


WallSettingsChanged Property

[image]

Revit 2013 API
BuiltInFailures..::..WallFailures..::..WallSettingsChanged Property
BuiltInFailures..::..WallFailures Class See Also Send Feedback
Default wall settings will be changed (Base Constraint: [Base Level], Base Offset: [Base Offset], Top Constraint: [Top Level], Top Offset: [Top Offset])

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallSettingsChanged { get; }
Visual Basic
Public Shared ReadOnly Property WallSettingsChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallSettingsChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallFailures Class


BuiltInFailures.WallJoinRoofFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WallJoinRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class WallJoinRoofFailures
Visual Basic
Public NotInheritable Class WallJoinRoofFailures
Visual C++
public ref class WallJoinRoofFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WallJoinRoofFailures

See Also

BuiltInFailures..::..WallJoinRoofFailures Members


BuiltInFailures.WallJoinRoofFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures Members
BuiltInFailures..::..WallJoinRoofFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


BuiltInFailures.WallJoinRoofFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures Properties
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback

The BuiltInFailures..::..WallJoinRoofFailures type exposes the following members.

Properties

Name | Description
NoFromRoofForWall | Highlighted wall is set to be "From roof", however there is no roof below it that can be used.
NotCoveredAtAllByTarget | Highlighted walls are attached to, but miss, the highlighted targets.
NoUptoRoofForWall | Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.
WallMeetsRoofTangentially | The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.
WallNotCoveredByRoof | The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


NoFromRoofForWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures..::..NoFromRoofForWall Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "From roof", however there is no roof below it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoFromRoofForWall { get; }
Visual Basic
Public Shared ReadOnly Property NoFromRoofForWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoFromRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


NotCoveredAtAllByTarget Property

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures..::..NotCoveredAtAllByTarget Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
Highlighted walls are attached to, but miss, the highlighted targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NotCoveredAtAllByTarget { get; }
Visual Basic
Public Shared ReadOnly Property NotCoveredAtAllByTarget As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NotCoveredAtAllByTarget {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


NoUptoRoofForWall Property

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures..::..NoUptoRoofForWall Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
Highlighted wall is set to be "Up to roof", however there is no roof above it that can be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId NoUptoRoofForWall { get; }
Visual Basic
Public Shared ReadOnly Property NoUptoRoofForWall As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ NoUptoRoofForWall {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


WallMeetsRoofTangentially Property

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures..::..WallMeetsRoofTangentially Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall cannot be joined to the highlighted roof because the wall meets the roof tangentially.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallMeetsRoofTangentially { get; }
Visual Basic
Public Shared ReadOnly Property WallMeetsRoofTangentially As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallMeetsRoofTangentially {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


WallNotCoveredByRoof Property

[image]

Revit 2013 API
BuiltInFailures..::..WallJoinRoofFailures..::..WallNotCoveredByRoof Property
BuiltInFailures..::..WallJoinRoofFailures Class See Also Send Feedback
The highlighted wall(s) cannot be joined to the highlighted roof because the roof does not entirely cover the wall(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId WallNotCoveredByRoof { get; }
Visual Basic
Public Shared ReadOnly Property WallNotCoveredByRoof As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ WallNotCoveredByRoof {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WallJoinRoofFailures Class


BuiltInFailures.WorksharingFailures Class

[image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures Class
BuiltInFailures Class Members See Also Send Feedback
Failures about WorksharingFailures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class WorksharingFailures
Visual Basic
Public NotInheritable Class WorksharingFailures
Visual C++
public ref class WorksharingFailures abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BuiltInFailures..::..WorksharingFailures

See Also

BuiltInFailures..::..WorksharingFailures Members


BuiltInFailures.WorksharingFailures Members

[image] [image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures Members
BuiltInFailures..::..WorksharingFailures Class Properties See Also Send Feedback

Provides a container of all Revit built-in FailureDefinitionId instances.

The BuiltInFailures..::..WorksharingFailures type exposes the following members.

Properties

Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.

See Also

BuiltInFailures..::..WorksharingFailures Class


BuiltInFailures.WorksharingFailures Properties

[image] [image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures Properties
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback

The BuiltInFailures..::..WorksharingFailures type exposes the following members.

Properties

Name | Description
DuplicateNamesChanged | These elements' names were automatically changed to eliminate duplicates.
MissingUpdaterLatestOrCentralPlural | The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.
MissingUpdaterLatestOrCentralSingular | The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.
SeriousElementReferenceCorruption | Element references are seriously corrupt.

See Also

BuiltInFailures..::..WorksharingFailures Class


DuplicateNamesChanged Property

[image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures..::..DuplicateNamesChanged Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
These elements' names were automatically changed to eliminate duplicates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId DuplicateNamesChanged { get; }
Visual Basic
Public Shared ReadOnly Property DuplicateNamesChanged As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ DuplicateNamesChanged {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


MissingUpdaterLatestOrCentralPlural Property

[image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures..::..MissingUpdaterLatestOrCentralPlural Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
The file [File Name] you are trying to synchronize was modified by the third-party updaters [Updater Name(s)] which are not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by these updaters will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] are present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissingUpdaterLatestOrCentralPlural { get; }
Visual Basic
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralPlural As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralPlural {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


MissingUpdaterLatestOrCentralSingular Property

[image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures..::..MissingUpdaterLatestOrCentralSingular Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
The file [File Name] you are trying to synchronize was modified by the third-party updater [Updater Name(s)] which is not currently installed. \n\r \n\r If you continue to Synchronize with Central or Reload Latest, data maintained by this updater will not be updated properly. This may create problems when [File Name] is later opened when [Updater Name(s)] is present.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId MissingUpdaterLatestOrCentralSingular { get; }
Visual Basic
Public Shared ReadOnly Property MissingUpdaterLatestOrCentralSingular As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ MissingUpdaterLatestOrCentralSingular {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


SeriousElementReferenceCorruption Property

[image]

Revit 2013 API
BuiltInFailures..::..WorksharingFailures..::..SeriousElementReferenceCorruption Property
BuiltInFailures..::..WorksharingFailures Class See Also Send Feedback
Element references are seriously corrupt.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static FailureDefinitionId SeriousElementReferenceCorruption { get; }
Visual Basic
Public Shared ReadOnly Property SeriousElementReferenceCorruption As FailureDefinitionId
    Get
Visual C++
public:
static property FailureDefinitionId^ SeriousElementReferenceCorruption {
    FailureDefinitionId^ get ();
}

See Also

BuiltInFailures..::..WorksharingFailures Class


BuiltInParameter Enumeration

Collapse All Expand All Code: All Code: Multiple Code: C# Code: Visual Basic Code: Visual C++

C#
Visual Basic
Visual C++

Revit 2013 API

BuiltInParameter Enumeration

See Also Send Feedback

An enumerated type listing all of the built-in parameter IDs supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Syntax

C#
public enum BuiltInParameter
Visual Basic
Public Enumeration BuiltInParameter
Visual C++
public enum class BuiltInParameter
Members

Member name

Description

ANALYTICAL_MODEL_MANUALLY_ADJUSTED

"Manually Adjusted"

PROPERTY_SET_KEYWORDS

"Keywords"

MATERIAL_ASSET_PARAM_SOURCE_URL

"Source URL"

MATERIAL_ASSET_PARAM_SOURCE

"Source"

MATERIAL_ASSET_PARAM_EXTERNAL_MATERIAL_ID

"External Material ID"

MATERIAL_ASSET_PARAM_COMMON_SHARED_ASSET

"Sharing"

MATERIAL_ASSET_PARAM_ASSET_LIB_ID

"Asset library id"

DPART_BASE_LEVEL_BY_ORIGINAL

"Base Level By Original"

DPART_BASE_LEVEL

"Base Level"

POINT_ADAPTIVE_NUM_PARAM

"Number"

POINT_ADAPTIVE_SHOW_NUMBER

"Show Placement Number"

POINT_ADAPTIVE_CONSTRAINED

"Constrained"

POINT_ADAPTIVE_ORIENTATION_TYPE

"Orientation"

THERMAL_MATERIAL_PARAM_ELECTRICAL_RESISTIVITY

"Electrical Resistivity"

THERMAL_MATERIAL_PARAM_REFLECTIVITY

"Reflectivity"

THERMAL_MATERIAL_PARAM_POROSITY

"Porosity"

THERMAL_MATERIAL_PARAM_PERMEABILITY

"Permeability"

THERMAL_MATERIAL_PARAM_TRANSMITS_LIGHT

"Transmits Light"

THERMAL_MATERIAL_PARAM_VAPOR_PRESSURE

"Vapor Pressure"

THERMAL_MATERIAL_PARAM_SPECIFIC_HEAT_OF_VAPORIZATION

"Specific Heat of Vaporization"

THERMAL_MATERIAL_PARAM_LIQUID_VISCOSITY

"Liquid Viscosity"

THERMAL_MATERIAL_PARAM_COMPRESSIBILITY

"Compressibility"

THERMAL_MATERIAL_PARAM_GAS_VISCOSITY

"Gas Viscosity"

THERMAL_MATERIAL_PARAM_EMISSIVITY

"Emissivity"

PHY_MATERIAL_PARAM_WOOD_CONSTRUCTION

"Construction"

PHY_MATERIAL_PARAM_FIVEPERCENT_MODULUS_OF_ELACTICITY

"5% Modulus of Elacticity"

PHY_MATERIAL_PARAM_AVERAGE_MODULUS

"Average Modulus"

PHY_MATERIAL_PARAM_TENSION_PERPENDICULAR

"Tension Perpendicular to Grain"

PHY_MATERIAL_PARAM_TENSION_PARALLEL

"Tension Parallel to Grain"

PHY_MATERIAL_PARAM_STRUCTURAL_THERMAL_TREATED

"Thermally Treated"

PHY_MATERIAL_PARAM_STRUCTURAL_DENSITY

"Density"

PHY_MATERIAL_PARAM_STRUCTURAL_SPECIFIC_HEAT

"Specific Heat"

PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_Z

"Thermal Conductivity Z"

PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_Y

"Thermal Conductivity Y"

PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY_X

"Thermal Conductivity X"

PHY_MATERIAL_PARAM_THERMAL_CONDUCTIVITY

"Thermal Conductivity"

PHY_MATERIAL_PARAM_EXP_COEFF_2

"Thermal Expansion Coefficient 2"

PHY_MATERIAL_PARAM_EXP_COEFF_1

"Thermal Expansion Coefficient 1"

PHY_MATERIAL_PARAM_SHEAR_MOD_12

"Shear Modulus 12"

PHY_MATERIAL_PARAM_POISSON_MOD_23

"Poisson Ratio 23"

PHY_MATERIAL_PARAM_POISSON_MOD_12

"Poisson Ratio 12"

PHY_MATERIAL_PARAM_YOUNG_MOD_2

"Young's Modulus 2"

PHY_MATERIAL_PARAM_YOUNG_MOD_1

"Young's Modulus 1"

STAIRS_RAILING_PLACEMENT_OFFSET

"Tread/Stringer Offset"

STAIRS_TRISERTYPE_RISER_IS_SLANTED

"Slanted"

STAIRS_TRISERTYPE_RISER

"Riser"

STAIRS_TRISERTYPE_NOSING_PLACEMENT

"Apply Nosing Profile"

STAIRS_TRISERTYPE_RISER_PROFILE

"Riser Profile"

TERMINATION_EXTENSION_LENGTH

"Extension Length"

SUPPORT_HEIGHT

"Height"

SUPPORT_HAND_CLEARANCE

"Hand Clearance"

STAIRS_TRISERTYPE_TREAD_PROFILE

"Tread Profile"

STAIRS_TRISERTYPE_RISER_MATERIAL

"Riser Material"

STAIRS_TRISERTYPE_TREAD_MATERIAL

"Tread Material"

STAIRS_TRISERTYPE_RISER_TREAD_CONNECTION

"Riser To Tread Connection"

STAIRS_TRISERTYPE_RISER_THICKNESS

"Riser Thickness"

STAIRS_TRISERTYPE_RISER_STYLE

"Riser Type"

STAIRS_TRISERTYPE_BACK_NOSING

"Back Nosing"

STAIRS_TRISERTYPE_LEFT_NOSING

"Left Nosing"

STAIRS_TRISERTYPE_RIGHT_NOSING

"Right Nosing"

STAIRS_TRISERTYPE_FRONT_NOSING

"Front Nosing"

STAIRS_TRISERTYPE_NOSING_LENGTH

"Nosing Length"

STAIRS_TRISERTYPE_NOSING_PROFILE

"Nosing Profile"

STAIRS_TRISERTYPE_TREAD_THICKNESS

"Tread Thickness"

STAIRS_TRISERTYPE_TREAD

"Tread"

STAIRS_TRISER_RISER_MARK

"Riser Mark"

STAIRS_TRISER_TREAD_MARK

"Tread Mark"

STAIRS_TRISER_RISER_NUMBER

"Riser Number": Count the sequential number of riser in the stair.

STAIRS_TRISER_TREAD_NUMBER

"Tread Number": Count the sequential number of tread in the stair.

STAIRS_TRISER_IS_TYPE_OVERRIDDEN

"Overridden": Indicate whether selected individual step is governed by default type setting.

STAIRS_WINDERPATTERN_NUMBER_OF_STRAIGHT_STEPS_AT_END

"Parallel Treads at End": Number of straight steps at the begin of winder

STAIRS_WINDERPATTERN_NUMBER_OF_STRAIGHT_STEPS_AT_BEGIN

"Parallel Treads at Start": Number of straight steps at the begin of winder

STAIRS_WINDERPATTERN_RADIUS_INTERIOR

"Fillet Radius": The fillet corner radius on the interior boundary

STAIRS_WINDERPATTERN_FILLET_INSIDE_CORNER

"Fillet on Corner": Fillet on inside corner

STAIRS_WINDERPATTERN_STAIR_PATH_OFFSET

"Inside Walk Line Offset": The offset from inside walk line to interior boundary

STAIRS_WINDERPATTERN_MINIMUM_WIDTH_INSIDE_WALKLINE

"Minimum Width on Inside Walk Line": Minimum width on inside walkline

STAIRS_WINDERPATTERN_MINIMUM_WIDTH_CORNER

"Minimum Width on Inside Boundary": Minimum Width on Inside Boundary

STAIRS_WINDERPATTERN_WINDER_STYLE

"Winder Style": Winder Style

STAIRS_SUPPORTTYPE_FLIP_SECTION_PROFILE

"Flip Section Profile": Flip Section Profile

STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH_ON_LANDING

"Structural Depth On Landing": Structural Depth

STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH_ON_RUN

"Structural Depth On Run": Structural Depth

STAIRS_SUPPORTTYPE_MATERIAL

"Material": Material

STAIRS_SUPPORTTYPE_WIDTH

"Width": Width

STAIRS_SUPPORTTYPE_TOTAL_DEPTH

"Total Depth": Total Depth

STAIRS_SUPPORTTYPE_STRUCTURAL_DEPTH

"Structural Depth": Structural Depth

STAIRS_SUPPORTTYPE_UNDERSIDE_SURFACE

"Underside Surface": Underside Surface

STAIRS_SUPPORTTYPE_TOPSIDE_SURFACE

"Topside Surface": Topside Surface

STAIRS_SUPPORTTYPE_SECTION_PROFILE

"Section Profile": Section Profile

STAIRS_SUPPORT_LANDINGSUPPORT_TYPE

"Landing Support Type": Landing Support Type

STAIRS_SUPPORT_OVERRIDDEN

"Overridden": Overridden

STAIRS_SUPPORT_TRIM_SUPPORT_UPPER

"Trim Support at Upper": Trim Support at Upper

STAIRS_SUPPORT_UPPER_END_CUT

"Upper End Cut": Upper End Cut

STAIRS_SUPPORT_LOWER_END_CUT

"Lower End Cut": Lower End Cut

STAIRS_SUPPORT_VERTICAL_OFFSET

"Vertical Offset": Distance of top plane of edge stringer relative to the plane connecting tread nosing

STAIRS_SUPPORT_HORIZONTAL_OFFSET

"Lateral Offset": Distance from center or edge of boundary

STAIRS_LANDINGTYPE_LANDING_MATERIAL

"Monolithic Material": Landing Material

STAIRS_LANDINGTYPE_TREADRISER_TYPE

"Type": Tread/Riser Type

STAIRS_LANDINGTYPE_USE_SAME_TRISER_AS_RUN

"Same as Run": Same as Run

STAIRS_LANDINGTYPE_THICKNESS

"Monolithic Thickness": Default thickness

STAIRS_LANDINGTYPE_STRUCTURE

"Structure": Structure

STAIRS_LANDINGTYPE_HAS_MONOLITHIC_SUPPORT

"Monolithic Support": Monolithic Support

STAIRS_LANDING_OVERRIDDEN

"Overridden": Overridden

STAIRS_LANDING_THICKNESS

"Total Thickness": Thickness

STAIRS_LANDING_STRUCTURAL

"Structural": Structural

STAIRS_LANDING_BASE_ELEVATION

"Relative Height": Height

STAIRS_RUNTYPE_RUN_MATERIAL

"Monolithic Material": Material

STAIRS_RUNTYPE_TOTAL_DEPTH

"Total Depth": Total Depth

STAIRS_RUNTYPE_STRUCTURAL_DEPTH

"Structural Depth": Structural Depth

STAIRS_RUNTYPE_STRUCTURE

"Structure": Structure

STAIRS_RUNTYPE_UNDERSIDE_SURFACE_TYPE

"Underside Surface": Underside Surface

STAIRS_RUNTYPE_HAS_MONOLITHIC_SUPPORT

"Monolithic Support": Monolithic Support

STAIRS_RUN_CCW

"CCW": Revert the run preview

STAIRS_RUN_CREATE_AUTO_LANDING

"With Automatic Landing": Create automatic landing

STAIRS_RUN_WINDER_END_WITH_STRAIGHT

"End with Straight Run": Winder end with straight run

STAIRS_RUN_WINDER_BEGIN_WITH_STRAIGHT

"Begin with Straight Run": Winder begin with straight run

STAIRS_RUN_LOCATIONPATH_JUSTFICATION

"Location Line": Location Line

STAIRS_RUN_END_WITH_RISER

"End with Riser": End with Riser

STAIRS_RUN_BEGIN_WITH_RISER

"Begin with Riser": Begin with Riser

STAIRS_RUN_OVERRIDDEN

"Overridden": Overridden

STAIRS_RUN_STRUCTURAL

"Structural": Structural

STAIRS_RUN_CENTER_MARK_VISIBLE

"Center Mark Visible": Center Mark Visible

STAIRS_RUN_ACTUAL_RUN_WIDTH

"Actual Run Width": Actual Run Width

STAIRS_RUN_ACTUAL_TREAD_DEPTH

"Actual Tread Depth": Actual Tread Depth

STAIRS_RUN_ACTUAL_RISER_HEIGHT

"Actual Riser Height": Actual Riser Height

STAIRS_RUN_ACTUAL_NUMBER_OF_TREADS

"Actual Number of Treads": Actual Number of Treads

STAIRS_RUN_ACTUAL_NUMBER_OF_RISERS

"Actual Number of Risers": Actual Number of Risers

STAIRS_RUN_EXTEND_BELOW_BASE

"Extend Below Base": Extend Below Base

STAIRS_RUN_HEIGHT

"Run Height": Run Height

STAIRS_RUN_TOP_ELEVATION

"Relative Top Height": Top height of run

STAIRS_RUN_BOTTOM_ELEVATION

"Relative Base Height": Relative height to stairs bottom elevation

STAIRSTYPE_HAS_INTERMEDIATE_SUPPORT

"Middle Support": Whether stairs is assembled

STAIRSTYPE_LEFT_SUPPORT_LATERAL_OFFSET

"Left Lateral Offset":

STAIRSTYPE_RIGHT_SUPPORT_LATERAL_OFFSET

"Right Lateral Offset":

STAIRSTYPE_CUTMARK_TYPE

"Cut Mark Type": Cut Mark Type

STAIRSTYPE_CONSTRUCTION_METHOD

"Construction Method":

STAIRSTYPE_HAS_RIGHT_SUPPORT

"Right Support":

STAIRSTYPE_HAS_LEFT_SUPPORT

"Left Support":

STAIRSTYPE_NOTCH_WIDTH

"Notch Width":

STAIRSTYPE_NOTCH_VERTICAL_GAP

"Vertical Gap Distance":

STAIRSTYPE_NOTCH_HORIZONTAL_GAP

"Horizontal Gap Distance":

STAIRSTYPE_NOTCH_CUSTOM_WIDTH

"Custom":

STAIRSTYPE_NOTCH_THICKNESS

"Notch Thickness":

STAIRSTYPE_NOTCH_EXTENSION

"Notch Extension":

STAIRSTYPE_GEOMUNJOINED_END_CUT_STYLE

"Connection Method": Cut Style for Geometrically Unjoined End

STAIRSTYPE_CALC_RULE_TARGET_RESULT

"Target Result": Calculation Rule Target Result

STAIRSTYPE_CALC_RULE_MIN_RESULT

"Min. Result": Calculation Rule Min Result

STAIRSTYPE_CALC_RULE_MAX_RESULT

"Max. Result": Calculation Rule Max Result

STAIRSTYPE_CALC_RULE_TREAD_MULTIPLIER

"Tread Multiplier": Calculation Rule Tread Multiplier

STAIRSTYPE_CALC_RULE_RISER_MULTIPLIER

"Riser Multiplier": Calculation Rule Riser Multiplier

STAIRSTYPE_IS_ASSEMBLED_STAIRS

"Assembled Stair": Whether stairs is assembled

STAIRSTYPE_NUMBER_OF_INTERMEDIATE_SUPPORTS

"Middle Support Number": Number of intermediate supports

STAIRSTYPE_MINIMUM_RUN_WIDTH

"Minimum Run Width": Minimum Run Width

STAIRSTYPE_WINDER_STEP_FRONT_MEASUREMENT

"Winder Algorithm": Winder Algorithm

STAIRSTYPE_SHOW_UPDOWN

"Show Up/Down in Plan": Show Up/Down in Plan

STAIRSTYPE_SHOW_STAIR_PATH

"Show Stair Path in Plan": Show Stair Path in Plan

STAIRSTYPE_SHOW_CUTLINE

"Show Cut Line in Plan": Show Cut Line in Plan

STAIRSTYPE_INTERMEDIATE_SUPPORT_TYPE

"Middle Support Type": Intermediate Support Type

STAIRSTYPE_LEFT_SIDE_SUPPORT_TYPE

"Left Support Type": Left Side Support Type

STAIRSTYPE_RIGHT_SIDE_SUPPORT_TYPE

"Right Support Type": Right Side Support Type

STAIRSTYPE_LANDING_TYPE

"Landing Type": Landing Type

STAIRSTYPE_RUN_TYPE

"Run Type": Run Type

STAIRSTYPE_CALCULATION_RULES

"Calculation Rules": Calculation Rules

STAIRSTYPE_MINIMUM_TREAD_WIDTH_INSIDE_BOUNDARY

"Min. Tread Depth on Winder Inner Boundary": Minimum Tread Width on Inside Boundary

STAIRSTYPE_MINIMUM_TREAD_DEPTH

"Min. Tread Depth": Minimum Tread Depth

STAIRSTYPE_MAXIMUM_RISER_HEIGHT

"Max. Riser Height": Maximum Riser Height

STAIRSTYPE_STAIRS_PATH_TO_INSIDE_BOUNDARY

"Stairs Path to Inside Boundary": Stair Path to Inside Boundary

STAIRSTYPE_STAIRS_PATH_LOCATION

"Stairs Path Location": Stair Path Location

STAIRS_TRISER_NUMBER_BASE_INDEX

"Tread/Riser Start Number":

STAIRS_DBG_SHOW_ANNOTATION_CUT_MARK

"Cut by Cut Plane"

STAIRS_DBG_SHOW_MONOLITHIC_SUPPORT_CORSE_GEOM

"Show Monolithic Support Corse Geometry"

STAIRS_DBG_SHOW_TRISER_CORSE_GEOM

"Show Triser Corse Geometry"

STAIRS_DBG_SHOW_RUN_CORSE_GEOM

"Show Run Corse Geometry"

STAIRS_DBG_SHOW_MONOLITHIC_SUPPORT_GEOM

"Show Monolithic Support Geometry"

STAIRS_DBG_SHOW_TRISER_GEOM

"Show Triser Geometry"

STAIRS_DBG_SHOW_RUN_GEOM

"Show Run Geometry"

STAIRS_DBG_SHOW_SUPPORT_PATH

"Show Support Path"

STAIRS_DBG_SHOW_BOUNDARY_3D

"Show Stairs' Boundary 3D"

STAIRS_DBG_SHOW_BOUNDARY_2D

"Show Stairs' Boundary 2D"

STAIRS_DBG_SHOW_LANDING_PATH

"Show Landing Path"

STAIRS_DBG_SHOW_LANDING_BOUNDARY

"Show Landing Boundary"

STAIRS_DBG_SHOW_RUN_OUTLINE_FOR_PLAN

"Show Run Outline For Plan"

STAIRS_DBG_SHOW_RUN_NOSING

"Show Run's Nosings"

STAIRS_DBG_SHOW_RUN_RISER

"Show Run's Risers"

STAIRS_DBG_SHOW_RUN_PATH_3D

"Show Run's Path 3D"

STAIRS_DBG_SHOW_RUN_PATH_2D

"Show Run's Path 2D"

STAIRS_DBG_SHOW_RIGHT_RUN_BOUNDARY_3D

"Show Run's Right Boundary 3D"

STAIRS_DBG_SHOW_LEFT_RUN_BOUNDARY_3D

"Show Run's Left Boundary 3D"

STAIRS_DBG_SHOW_RIGHT_RUN_BOUNDARY_2D

"Show Run's Right Boundary 2D"

STAIRS_DBG_SHOW_LEFT_RUN_BOUNDARY_2D

"Show Run's Left Boundary 2D"

STAIRS_DBG_SHOW_LANDING_FACES

"Show Landing Faces"

STAIRS_DBG_SHOW_TREAD_FACES

"Show Run's Tread Faces"

STAIRS_ENABLE_CALCULATION_RULE_CHECKING

"Enable Calculator Rules Check": Enable calculation rule checking

STAIRS_MIN_AUTOMATIC_LANDING_DEPTH

"Minimum Automatic Landing Depth": The minimum depth of automatic landing

STAIRS_RUN_WIDTH_MEASUREMENT

"Run Width Measurement": Run Width Measurement

STAIRS_TOTAL_NUMBER_OF_TREADS

"Total Number of Treads": Total number of treads

STAIRS_TOTAL_NUMBER_OF_RISERS

"Total Number of Risers": Total number of risers

STAIRS_ACTUAL_NUMBER_OF_RISERS

"Actual Number of Risers": The total number of actually created risers in model

STAIRS_DESIRED_NUMBER_OF_RISERS

"Desired Number of Risers": The number of risers is calculated based on stairs height

STAIRS_MULTISTORY_UP_TO_LEVEL

"Multistory Top Level": The top level of multi-story stairs

STAIRS_STAIRS_HEIGHT

"Desired Stair Height": Stairs unconnected height

STAIRS_TOP_LEVEL

"Top Level": The top level of stairs

STAIRS_BASE_LEVEL

"Base Level": The base level of stairs

PART_MAKER_DIVISION_PROFILE_OFFSET

"Profile Offset"

DIVISION_PROFILE_WIDTH

"Width": Width

PART_MAKER_SPLITTER_PROFILE_EDGE_MATCH

"Edge Match"

PART_MAKER_SPLITTER_PROFILE_CHAMFER_OR_GROOVE

"Chamfer or Groove"

PART_MAKER_SPLITTER_PROFILE_GAP

"Gap"

PART_MAKER_SPLITTER_PROFILE_CHAMFER_WIDTH

"Chamfer Width"

PART_MAKER_SPLITTER_PROFILE_CHAMFER_DEPTH

"Chamfer Depth"

PART_MAKER_SPLITTER_PROFILE_TAPER_DEPTH_1

"Taper Depth 1"

PART_MAKER_SPLITTER_PROFILE_TAPER_DEPTH_0

"Taper Depth 0"

PART_MAKER_SPLITTER_PROFILE_TAPER_DEPTH

"Taper Depth"

PART_MAKER_SPLITTER_PROFILE_TAPER_WIDTH_1

"Taper Width 1"

PART_MAKER_SPLITTER_PROFILE_TAPER_WIDTH_0

"Taper Width 0"

PART_MAKER_SPLITTER_PROFILE_WIDTH_1

"Width 1"

PART_MAKER_SPLITTER_PROFILE_WIDTH_0

"Width 0"

PART_MAKER_SPLITTER_PROFILE_NOTCH_DEPTH

"Notch Depth"

PART_MAKER_SPLITTER_PROFILE_BASE_DEPTH_1

"Base Depth 1"

PART_MAKER_SPLITTER_PROFILE_BASE_DEPTH_0

"Base Depth 0"

PART_MAKER_SPLITTER_PROFILE_BASE_DEPTH

"Base Depth"

PART_MAKER_SPLITTER_PROFILE_FLIP_ALONG

"Profile Along Flip"

PART_MAKER_SPLITTER_PROFILE_FLIP_ACROSS

"Profile Across Flip"

PART_MAKER_SPLITTER_PROFILE

"Split Profile Type"

FAMILY_KEYWORD_PROTECTED

"Content protection enabled"

PARTMAKER_PARAM_OFFSET

"Divider gap"

POINTCLOUDINSTANCE_NAME

"Name": The name of the instance as it will show in the Property Palette

ANALYTICAL_MODEL_ROTATION

"Cross-Section Rotation": The rotation of Analytical Model

POINTCLOUDTYPE_SCALE

"Scale": The scale for this instance

PROPERTY_SET_DESCRIPTION

"Description"

PROPERTY_SET_MATERIAL_ASPECT

"Material aspect"

RBS_DUCT_PIPE_SYSTEM_ABBREVIATION_PARAM

"System Abbreviation"

PHY_MATERIAL_PROPERTIES

"Properties"

PROPERTY_SET_NAME

"Property Set Name"

PHY_MATERIAL_PARAM_SUBCLASS

"Subclass"

PHY_MATERIAL_PARAM_CLASS

"Class"

ANALYTICAL_MODEL_PERIMETER

"Perimeter": The Perimeter of Analytical Model

ANALYTICAL_MODEL_AREA

"Area": The Area of Analytical Model

ANALYTICAL_MODEL_LENGTH

"Length": The length of Analytical Model

SHEET_ASSEMBLY_KEYNOTE

"Assembly: Keynote"

SHEET_ASSEMBLY_ASSEMBLY_DESCRIPTION

"Assembly: Assembly Description"

SHEET_ASSEMBLY_COST

"Assembly: Cost"

SHEET_ASSEMBLY_TYPE_MARK

"Assembly: Type Mark"

SHEET_ASSEMBLY_ASSEMBLY_CODE

"Assembly: Assembly Code"

SHEET_ASSEMBLY_DESCRIPTION

"Assembly: Description"

SHEET_ASSEMBLY_URL

"Assembly: URL"

SHEET_ASSEMBLY_TYPE_COMMENTS

"Assembly: Type Comments"

SHEET_ASSEMBLY_MANUFACTURER

"Assembly: Manufacturer"

SHEET_ASSEMBLY_MODEL

"Assembly: Model"

SHEET_ASSEMBLY_NAME

"Assembly: Name"

RBS_REFERENCE_FREESIZE

"Free Size"

RBS_REFERENCE_OVERALLSIZE

"Overall Size"

RBS_REFERENCE_LINING_THICKNESS

"Lining Thickness"

RBS_REFERENCE_LINING_TYPE

"Lining Type"

RBS_REFERENCE_INSULATION_THICKNESS

"Insulation Thickness"

RBS_REFERENCE_INSULATION_TYPE

"Insulation Type"

RBS_PIPE_CALCULATED_SIZE

"Pipe Size"

RBS_DUCT_CALCULATED_SIZE

"Duct Size"

RBS_INSULATION_LINING_VOLUME

"Volume"

ASSEMBLY_NAME

"Assembly Name"

RBS_SYSTEM_RISEDROP_PARAM

"Rise / Drop Symbol"

RBS_SYSTEM_RISEDROP_2LINEDROPSYMBOL_PARAM

"Two Line Drop Symbol"

RBS_SYSTEM_RISEDROP_2LINERISESYMBOL_PARAM

"Two Line Rise Symbol"

RBS_SYSTEM_RISEDROP_1LINEDROPSYMBOL_PARAM

"Single Line Drop Symbol"

RBS_SYSTEM_RISEDROP_1LINERISESYMBOL_PARAM

"Single Line Rise Symbol"

RBS_SYSTEM_RISEDROP_1LINETEEUPSYMBOL_PARAM

"Single Line Tee Up Symbol"

RBS_SYSTEM_RISEDROP_1LINETEEDOWNSYMBOL_PARAM

"Single Line Tee Down Symbol"

ASSEMBLY_NAMING_CATEGORY

"Naming Category"

CONTINUOUSRAIL_JOIN_TYPE_PARAM

"Rail Path Join"

CONTINUOUSRAIL_PLUS_TREAD_DEPTH_PARAM

"Plus Tread Depth"

CONTINUOUSRAIL_LENGTH_PARAM

"Length"

HANDRAIL_SUPPORTS_JUSTIFICATION_PARAM

"Justification"

HANDRAIL_SUPPORTS_NUMBER_PARAM

"Number"

HANDRAIL_SUPPORTS_SPACING_PARAM

"Spacing"

HANDRAIL_SUPPORTS_LAYOUT_PARAM

"Layout"

HANDRAIL_SUPPORTS_TYPE_PARAM

"Family"

CONTINUOUSRAIL_END_EXTENSION_LENGTH_PARAM

"Length"

CONTINUOUSRAIL_END_TERMINATION_ATTACHMENT_PARAM

"Extension Style"

CONTINUOUSRAIL_EXTENSION_LENGTH_PARAM

"Length"

CONTINUOUSRAIL_BEGINNING_TERMINATION_ATTACHMENT_PARAM

"Extension Style"

CONTINUOUSRAIL_END_TERMINATION_TYPE_PARAM

"End/Top Termination"

CONTINUOUSRAIL_BEGINNING_TERMINATION_TYPE_PARAM

"Beginning/Bottom Termination"

CONTINUOUSRAIL_MATERIALS_PARAM

"Material"

CONTINUOUSRAIL_TRANSITION_TYPE_PARAM

"Transitions"

HANDRAIL_HAND_CLEARANCE_PARAM

"Hand Clearance"

HANDRAIL_PROJECTION_PARAM

"Projection"

HANDRAIL_HEIGHT_PARAM

"Height"

CONTINUOUSRAIL_PROFILE_TYPE_PARAM

"Profile"

CONTINUOUSRAIL_FILLET_RADIUS_PARAM

"Fillet Radius"

CONTINUOUSRAIL_DEFAULT_JOIN_TYPE_PARAM

"Default Join"

RAILING_SYSTEM_SECONDARY_HANDRAILS_LATTERAL_OFFSET

"Lateral Offset"

RAILING_SYSTEM_SECONDARY_HANDRAILS_HEIGHT_PARAM

"Height"

RAILING_SYSTEM_SECONDARY_HANDRAILS_POSITION_PARAM

"Position"

RAILING_SYSTEM_SECONDARY_HANDRAILS_TYPES_PARAM

"Type"

RAILING_SYSTEM_HANDRAILS_LATTERAL_OFFSET

"Lateral Offset"

RAILING_SYSTEM_HANDRAILS_HEIGHT_PARAM

"Height"

RAILING_SYSTEM_HANDRAILS_POSITION_PARAM

"Position"

RAILING_SYSTEM_HANDRAILS_TYPES_PARAM

"Type"

RAILING_SYSTEM_TOP_RAIL_HEIGHT_PARAM

"Height"

RAILING_SYSTEM_TOP_RAIL_TYPES_PARAM

"Type"

POINT_ELEMENT_ROTATION_ANGLE

"Rotation Angle"

FLEXIBLE_INSTANCE_FLIP

"Flip"

POINT_FLEXIBLE_ORIENTATION_TYPE

"Orientation"

DEFAULT_CONSTRUCTION_MASS_FLOOR

"Mass Floor"

DEFAULT_CONSTRUCTION_MASS_OPENING

"Mass Opening"

DEFAULT_CONSTRUCTION_MASS_SKYLIGHT

"Mass Skylight"

DEFAULT_CONSTRUCTION_MASS_GLAZING

"Mass Glazing"

DEFAULT_CONSTRUCTION_EXT_WALL_UNDERGROUND

"Mass Exterior Wall - Underground"

DEFAULT_CONSTRUCTION_MASS_SLAB

"Mass Slab"

DEFAULT_CONSTRUCTION_MASS_SHADE

"Mass Shade"

DEFAULT_CONSTRUCTION_MASS_ROOF

"Mass Roof"

DEFAULT_CONSTRUCTION_MASS_INTERIOR_WALL

"Mass Interior Wall"

DEFAULT_CONSTRUCTION_MASS_EXTERIOR_WALL

"Mass Exterior Wall"

LEADER_RIGHT_ATTACHMENT

"Right Attachment"

LEADER_LEFT_ATTACHMENT

"Left Attachment"

POINT_ELEMENT_MEASURE_FROM

"Measure From"

POINT_ELEMENT_ANGLE

"Angle"

POINT_ELEMENT_CHORD_LENGTH

"Chord Length"

POINT_ELEMENT_NORMALIZED_SEGMENT_LENGTH

"Normalized Segment Length"

POINT_ELEMENT_SEGMENT_LENGTH

"Segment Length"

POINT_ELEMENT_NORMALIZED_CURVE_PARAMATER

"Normalized Curve Parameter"

POINT_ELEMENT_NON_NORMALIZED_CURVE_PARAMATER

"Non-Normalized Curve Parameter"

POINT_ELEMENT_MEASUREMENT_TYPE

"Measurement Type"

STRUCTURAL_BEAM_END_ATTACHMENT_REFCOLUMN_END

"End of Referenced Column"

STRUCTURAL_BEAM_START_ATTACHMENT_REFCOLUMN_END

"End of Referenced Column"

STRUCTURAL_BEAM_END_ATTACHMENT_DISTANCE

"End Attachment Distance"

STRUCTURAL_BEAM_START_ATTACHMENT_DISTANCE

"Start Attachment Distance"

STRUCTURAL_BEAM_END_ATTACHMENT_TYPE

"End Attachment Type"

STRUCTURAL_BEAM_START_ATTACHMENT_TYPE

"Start Attachment Type"

TEXT_BOX_VISIBILITY

"Show Border"

CURVE_BY_POINTS_PROJECTION_TYPE

"Projection Type"

FOLLOW_SURFACE

"Follow Surface"

RBS_ENERGY_ANALYSIS_INCLUDE_THERMAL_PROPERTIES

"Include Thermal Properties"

POINT_FLEXIBLE_NUM_PARAM

"Number"

FRAMING_LENGTH_ROUNDOFF

"Structural Framing Length Roundoff"

SLANTED_COLUMN_BASE_EXTENSION

"Base Extension"

SLANTED_COLUMN_TOP_EXTENSION

"Top Extension"

SLANTED_COLUMN_BASE_CUT_STYLE

"Base Cut Style"

SLANTED_COLUMN_TOP_CUT_STYLE

"Top Cut Style"

RBS_BUILDING_USELOADCREDITS

"Use Load Credits"

TILE_PATTERN_FAMREF_COMPONENT_EXTENTS

"Component Extents"

TILE_PATTERN_GRID_CELLS_Y

"Number of vertical cells"

TILE_PATTERN_GRID_CELLS_X

"Number of horizontal cells"

TILE_PATTERN_GRID_UNIT_Y

"Vertical spacing"

TILE_PATTERN_GRID_UNIT_X

"Horizontal spacing"

POINT_ELEMENT_SHOW_NORMAL_PLANE_ONLY

"Show Normal Reference Plane Only"

LEVEL_IS_GROUND_PLANE

"Is ground plane"

BASEPOINT_ANGLETON_PARAM

"Angle to True North"

BASEPOINT_ELEVATION_PARAM

"Elev"

BASEPOINT_EASTWEST_PARAM

"E/W"

BASEPOINT_NORTHSOUTH_PARAM

"N/S"

SLANTED_COLUMN_GEOMETRY_TREATMENT_BASE

"Base Geometry Alignment"

SLANTED_COLUMN_GEOMETRY_TREATMENT_TOP

"Top Geometry Alignment"

ROOM_PLENUM_LIGHTING_PARAM

"Plenum Lighting Contribution"

STRUCTURAL_ATTACHMENT_TOP_REFERENCEDEND

"Top Attachment Referenced End"

STRUCTURAL_ATTACHMENT_TOP_RATIO

"Top Attachment Ratio"

STRUCTURAL_ATTACHMENT_TOP_DISTANCE

"Top Attachment Distance"

STRUCTURAL_ATTACHMENT_TOP_TYPE

"Top Attachment Type"

STRUCTURAL_ATTACHMENT_BASE_REFERENCEDEND

"Base Attachment Referenced End"

STRUCTURAL_ATTACHMENT_BASE_RATIO

"Base Attachment Ratio"

STRUCTURAL_ATTACHMENT_BASE_DISTANCE

"Base Attachment Distance"

STRUCTURAL_ATTACHMENT_BASE_TYPE

"Base Attachment Type"

INSTANCE_MOVE_BASE_WITH_GRIDS

"Move Base With Grids"

INSTANCE_MOVE_TOP_WITH_GRIDS

"Move Top With Grids"

SLANTED_COLUMN_TYPE_PARAM

"Column Style"

VIEW_SLANTED_COLUMN_SYMBOL_OFFSET

"Column Symbolic Offset"

POINT_ELEMENT_MIRRORED

"Mirrored"

POINT_ELEMENT_ZFLIPPED

"Flipped"

POINT_ELEMENT_HOSTED_ON_FACE_V_PARAM

"Hosted V Parameter"

POINT_ELEMENT_HOSTED_ON_FACE_U_PARAM

"Hosted U Parameter"

LOCKED_END_OFFSET

"Positive Offset"

LOCKED_START_OFFSET

"Negative Offset"

LOCKED_BASE_OFFSET

"Negative Offset"

LOCKED_TOP_OFFSET

"Positive Offset"

RBS_PROJECT_REPORTTYPE_PARAM

"Report Type"

RBS_BUILDING_CONSTRUCTIONCLASS

"Building Infiltration Class"

CONNECTOR_UTILITY_PARAM

"Utility"

POINT_FLEXIBLE_SHOW_NUMBER

"Show Placement Number"

POINT_FLEXIBLE_CONSTRAINED

"Constrained"

POINT_NAME_PARAM

"Name"

POINT_ADAPTIVE_TYPE_PARAM

"Point"

SPOT_DIM_STYLE_SLOPE_UNITS

"Units Format"

POINT_ELEMENT_DRIVING

"Driving Curve(s)"

SPOT_SLOPE_LEADER_LENGTH

"Leader Line Length"

SPOT_SLOPE_SUFFIX

"Suffix"

SPOT_SLOPE_PREFIX

"Prefix"

POINT_VISIBILITY_PARAM

"Visibility/Graphics Overrides"

POINT_ELEMENT_SHOW_PLANES

"Show Reference Planes"

CURVE_IS_REFERENCE_LINE

"Is Reference Line"

POINT_ELEMENT_HOSTED_PARAM

"Hosted Parameter"

POINT_ELEMENT_DRIVEN

"Driven by Host"

POINT_ELEMENT_OFFSET

"Offset"

FBX_LIGHT_PHOTOMETRIC_FILE_CACHE

"None"

FBX_LIGHT_PHOTOMETRICS_FAM

"Light Source Definition (family)"

FAMILY_CURVE_ATTACHMENT_PROPORTION

"Attachment Point"

FBX_LIGHT_LOSS_FACTOR_CTRL

"Light Loss Factor"

FBX_LIGHT_INITIAL_COLOR_CTRL

"Initial Color"

FBX_LIGHT_LOSS_FACTOR_METHOD

"Light Loss Input Method"

FBX_LIGHT_INITIAL_COLOR_NAME

"Temperature Color"

FBX_LIGHT_AT_A_DISTANCE

"At a distance"

FBX_LIGHT_INITIAL_INTENSITY_INPUT_METHOD

"Initial Light Intensity Input Method"

FBX_LIGHT_SOURCE_LENGTH

"Light Source Symbol Length"

FBX_LIGHT_SOURCE_DIAMETER

"Light Source Symbol Size"

FBX_LIGHT_EMIT_CIRCLE_DIAMETER

"Emit from Circle Diameter"

FBX_LIGHT_EMIT_RECTANGLE_LENGTH

"Emit from Rectangle Length"

FBX_LIGHT_EMIT_RECTANGLE_WIDTH

"Emit from Rectangle Width"

FBX_LIGHT_EMIT_LINE_LENGTH

"Emit from Line Length"

FBX_LIGHT_EMIT_SHAPE_VISIBLE

"Emit Shape Visible in Rendering"

FBX_LIGHT_DIMMING_LIGHT_COLOR

"Dimming Lamp Color Temperature Shift"

FBX_LIGHT_LUMENAIRE_DIRT

"Luminaire Dirt Depreciation"

FBX_LIGHT_LAMP_LUMEN_DEPR

"Lamp Lumen Depreciation"

FBX_LIGHT_SURFACE_LOSS

"Surface Depreciation Loss"

FBX_LIGHT_LAMP_TILT_LOSS

"Lamp Tilt Loss"

FBX_LIGHT_VOLTAGE_LOSS

"Voltage Loss"

FBX_LIGHT_TEMPERATURE_LOSS

"Temperature Loss"

FBX_LIGHT_COLOR_FILTER

"Color Filter"

FBX_LIGHT_INITIAL_COLOR_TEMPERATURE

"Initial Color Temperature"

FBX_LIGHT_ILLUMINANCE

"Illuminance"

FBX_LIGHT_LIMUNOUS_INTENSITY

"Luminous Intensity"

FBX_LIGHT_EFFICACY

"Efficacy"

FBX_LIGHT_WATTAGE

"Wattage"

FBX_LIGHT_INITIAL_INTENSITY

"Initial Intensity"

FBX_LIGHT_PHOTOMETRICS

"Light Source Definition"

FBX_ASSET_TYPE

"Light Source"

DIVIDED_SURFACE_GRID_OPTION_PARAM_2

"Option 2"

DIVIDED_SURFACE_GRID_OPTION_PARAM_1

"Option 1"

DIVIDED_SURFACE_DISPLAY_DISCARDEDDIVISIONLINES

"Discarded Division Lines"

DIVIDED_SURFACE_COMPONENT_TRIM_TYPE

"Component Trim"

DIVIDED_SURFACE_PATTERN_MIRROR

"Component Mirror"

DIVIDED_SURFACE_RULE_2_SUSPENSION

"Is grid 2 suspended?"

DIVIDED_SURFACE_RULE_1_SUSPENSION

"Is grid 1 suspended?"

DIVIDED_SURFACE_DISPLAY_COMPONENTS

"Components"

DIVIDED_SURFACE_PATTERN_FILL_MATERIAL

"Pattern Fill Material"

DIVIDED_SURFACE_DISPLAY_PATTERN_FILL

"Pattern Fill"

DIVIDED_SURFACE_PATTERN_LINES_STYLE

"Pattern Lines Style"

DIVIDED_SURFACE_DISPLAY_PATTERN_LINES

"Pattern Lines"

DIVIDED_SURFACE_GRIDLINES_STYLE

"Gridlines Style"

DIVIDED_SURFACE_DISPLAY_GRIDLINES

"Gridlines"

DIVIDED_SURFACE_DISPLAY_NODES

"Nodes"

DIVIDED_SURFACE_ORIGINAL_SURFACE_MATERIAL

"Surface Material"

DIVIDED_SURFACE_DISPLAY_ORIGINAL_SURFACE

"Surface"

DIVIDED_SURFACE_DISPLAY_SURFACE_OPTION

"Display Surface Option"

DIVIDED_SURFACE_ALL_GRID_ROTATION

"All Grid Rotation"

DIVIDED_SURFACE_TILE_BORDER

"Border Tile"

DIVIDED_SURFACE_ALL_POINTS

"Show all points"

DIVIDED_SURFACE_PATTERN

"Tile Pattern"

DIVIDED_SURFACE_PATTERN_FLIP

"Component Flip"

DIVIDED_SURFACE_PATTERN_ROTATION_ANGLE

"Component Rotation"

DIVIDED_SURFACE_PATTERN_INDENT_2

"Indent 2"

DIVIDED_SURFACE_PATTERN_INDENT_1

"Indent 1"

DIVIDED_SURFACE_COVER_FACE_COMPLETELY

"Cover face completely"

DIVIDED_SURFACE_OFFSET_FROM_SURFACE

"Offset from surface"

DIVIDED_SURFACE_TOTAL_EDGE_LENGTH

"Total edge length"

DIVIDED_SURFACE_EDGE_NUMBER

"Edge number"

DIVIDED_SURFACE_POINT_NUMBER

"Point number"

DIVIDED_SURFACE_FACET_NUMBER

"Facet number"

DIVIDED_SURFACE_SURFACE_AREA

"Divided Surface Area"

RBS_ELEC_ROOM_LIGHTING_CALC_LUMINAIREPLANE

"Lighting Calculation Luminaire Plane"

REFERENCE_VIEWER_UI_TARGET_VIEW

"Target view": This is used by the UI to allow selection of target view. It allows the UI to set a filter that is incompatible with the current target view (REFERENCE_VIEWER_TARGET_VIEW).

REFERENCE_VIEWER_UI_TARGET_FILTER

"Filter": This is used by the UI to filter the list of target views.

TRUSS_FAMILY_BOTTOM_CHORD_STRUCTURAL_TYPES_PARAM

"Structural Framing Type"

TRUSS_FAMILY_BOTTOM_CHORD_ANGLE_PARAM

"Angle"

TRUSS_FAMILY_BOTTOM_CHORD_VERTICAL_PROJECTION_PARAM

"Analytical Vertical Projection"

TRUSS_FAMILY_BOTTOM_CHORD_START_RELEASE_TYPE

"Start Release"

TRUSS_FAMILY_BOTTOM_CHORD_END_RELEASE_TYPE

"End Release"

JOIST_SYSTEM_ELEM_TAG_NEW_MEMBERS_VIEW

"Tag new members in view"

REFERENCE_VIEWER_ATTR_TAG

"View Reference Tag"

REFERENCE_VIEWER_TARGET_VIEW

"Target view"

MATCHLINE_BOTTOM_PLANE

"Bottom Constraint"

MATCHLINE_TOP_PLANE

"Top Constraint"

MATCHLINE_BOTTOM_OFFSET

"Bottom Offset"

MATCHLINE_TOP_OFFSET

"Top Offset"

TRUSS_FAMILY_TOP_CHORD_STRUCTURAL_TYPES_PARAM

"Structural Framing Type"

TRUSS_FAMILY_TOP_CHORD_ANGLE_PARAM

"Angle"

TRUSS_FAMILY_TOP_CHORD_VERTICAL_PROJECTION_PARAM

"Analytical Vertical Projection"

TRUSS_FAMILY_TOP_CHORD_START_RELEASE_TYPE

"Start Release"

TRUSS_FAMILY_TOP_CHORD_END_RELEASE_TYPE

"End Release"

TRUSS_FAMILY_DIAG_WEB_STRUCTURAL_TYPES_PARAM

"Structural Framing Type"

TRUSS_FAMILY_DIAG_WEB_ANGLE_PARAM

"Angle"

TRUSS_FAMILY_DIAG_WEB_START_RELEASE_TYPE

"Start Release"

TRUSS_FAMILY_DIAG_WEB_END_RELEASE_TYPE

"End Release"

TRUSS_FAMILY_VERT_WEB_STRUCTURAL_TYPES_PARAM

"Structural Framing Type"

TRUSS_FAMILY_VERT_WEB_ANGLE_PARAM

"Angle"

TRUSS_FAMILY_VERT_WEB_START_RELEASE_TYPE

"Start Release"

TRUSS_FAMILY_VERT_WEB_END_RELEASE_TYPE

"End Release"

TRUSS_ELEMENT_TAG_NEW_MEMBERS_VIEW

"Tag new members in view"

TRUSS_NON_BEARING_OFFSET_PARAM

"Non Bearing Offset"

TRUSS_BEARING_CHORD_TOP_BOTTOM_PARAM

"Bearing Chord"

TRUSS_ELEMENT_SPAN_PARAM

"Span"

TRUSS_ELEMENT_STICK_JUST_PARAM

"Stick Symbol Location"

TRUSS_FAMILY_WEBS_HAVE_SYMBOLIC_CUTBACK_PARAM

"Webs have symbolic cutback"

TRUSS_HEIGHT

"Truss Height"

TRUSS_FAMILY_TRANSFORMATION_PARAM

"Web Orientation"

TRUSS_ELEMENT_REFERENCE_LEVEL_PARAM

"Reference Level"

TRUSS_ELEMENT_END1_ELEVATION

"End Level Offset"

TRUSS_ELEMENT_END0_ELEVATION

"Start Level Offset"

TRUSS_ELEMENT_BEARING_JUST_PARAM

"Bearing Vertical Justification"

TRUSS_ELEMENT_CREATE_BOTTOM_PARAM

"Create Bottom Chord"

TRUSS_ELEMENT_CREATE_TOP_PARAM

"Create Top Chord"

TRUSS_ELEMENT_ANGLE_PARAM

"Rotation Angle"

TRUSS_ELEMENT_CLASS_PARAM

"Engineering Type"

TRUSS_LENGTH

"Truss Length"

BOUNDARY_PARAM_PRESET_AREA

"State"

BOUNDARY_PARAM_PRESET_LINEAR

"State"

BOUNDARY_PARAM_PRESET

"State"

BOUNDARY_Z_TRANSLATION_SPRING

"Z Translation - Spring"

BOUNDARY_Z_TRANSLATION_FIXED

"Z Translation - Fixed"

BOUNDARY_Z_ROTATION_SPRING

"Z Rotation - Spring"

BOUNDARY_Z_ROTATION_FIXED

"Z Rotation - Fixed"

BOUNDARY_Y_TRANSLATION_SPRING

"Y Translation - Spring"

BOUNDARY_Y_TRANSLATION_FIXED

"Y Translation - Fixed"

BOUNDARY_Y_ROTATION_SPRING

"Y Rotation - Spring"

BOUNDARY_Y_ROTATION_FIXED

"Y Rotation - Fixed"

BOUNDARY_X_TRANSLATION_SPRING

"X Translation - Spring"

BOUNDARY_X_TRANSLATION_FIXED

"X Translation - Fixed"

BOUNDARY_X_ROTATION_SPRING

"X Rotation - Spring"

BOUNDARY_X_ROTATION_FIXED

"X Rotation - Fixed"

BOUNDARY_AREA_RESTRAINT_Z

"Z Spring Modulus"

BOUNDARY_AREA_RESTRAINT_Y

"Y Spring Modulus"

BOUNDARY_AREA_RESTRAINT_X

"X Spring Modulus"

BOUNDARY_LINEAR_RESTRAINT_ROT_X

"X Spring Modulus"

BOUNDARY_LINEAR_RESTRAINT_Z

"Z Spring Modulus"

BOUNDARY_LINEAR_RESTRAINT_Y

"Y Spring Modulus"

BOUNDARY_LINEAR_RESTRAINT_X

"X Spring Modulus"

BOUNDARY_RESTRAINT_ROT_Z

"Z Spring Modulus"

BOUNDARY_RESTRAINT_ROT_Y

"Y Spring Modulus"

BOUNDARY_RESTRAINT_ROT_X

"X Spring Modulus"

BOUNDARY_RESTRAINT_Z

"Z Spring Modulus"

BOUNDARY_RESTRAINT_Y

"Y Spring Modulus"

BOUNDARY_RESTRAINT_X

"X Spring Modulus"

BOUNDARY_DIRECTION_ROT_Z

"Z Rotation"

BOUNDARY_DIRECTION_ROT_Y

"Y Rotation"

BOUNDARY_DIRECTION_ROT_X

"X Rotation"

BOUNDARY_DIRECTION_Z

"Z Translation"

BOUNDARY_DIRECTION_Y

"Y Translation"

BOUNDARY_DIRECTION_X

"X Translation"

BOUNDARY_CONDITIONS_IS_EXT

"Is Boundary Conditions External?"

BOUNDARY_CONDITIONS_TYPE

"Boundary Conditions Type"

KEY_SOURCE_PARAM

"Key Source"

KEYNOTE_PARAM

"Keynote"

KEYNOTE_NUMBER

"Key Value"

SHEET_KEY_NUMBER

"Sheet Key Number"

KEYNOTE_TEXT

"Keynote Text"

KEY_VALUE

"Key Value"

PHY_MATERIAL_PARAM_GRADE

"Grade"

PHY_MATERIAL_PARAM_SPECIES

"Species"

PHY_MATERIAL_PARAM_EXP_COEFF

"Thermal expansion coefficient"

PHY_MATERIAL_PARAM_BENDING

"Bending"

PHY_MATERIAL_PARAM_SHEAR_MOD

"Shear modulus"

PHY_MATERIAL_PARAM_POISSON_MOD

"Poisson ratio"

PHY_MATERIAL_PARAM_SHEAR_PERPENDICULAR

"Tension perpendicular to grain"

PHY_MATERIAL_PARAM_SHEAR_PARALLEL

"Shear parallel to grain"

PHY_MATERIAL_PARAM_COMPRESSION_PERPENDICULAR

"Compression perpendicular to grain"

PHY_MATERIAL_PARAM_COMPRESSION_PARALLEL

"Compression parallel to grain"

PHY_MATERIAL_PARAM_YOUNG_MOD

"Young modulus"

PHY_MATERIAL_PARAM_TYPE

"Material Type"

ELEM_CATEGORY_PARAM_MT

"Category"

ELEM_CATEGORY_PARAM

"Category"

MATERIAL_VOLUME

"Volume"

MATERIAL_AREA

"Area"

MATERIAL_ASPAINT

"As Paint"

MATERIAL_NAME

"Name"

RBS_DUCT_SYSTEM_CALCULATION_PARAM

"Calculations"

RBS_PIPE_SYSTEM_CALCULATION_PARAM

"Calculations"

RBS_PIPING_SYSTEM_TYPE_PARAM

"System Type"

RBS_DUCT_SYSTEM_TYPE_PARAM

"System Type"

RBS_SYSTEM_ABBREVIATION_PARAM

"Abbreviation"

RBS_SYSTEM_OVERRIDE_GRAPHICS_PARAM

"Graphic Overrides"

RBS_PIPE_SLOPE_DEF_PARAM

"Pipe Slope Definitions"

CONNECTOR_ENGAGEMENT_LENGTH

"Engagement Length"

RBS_SYSTEM_FLOW_CONVERSION_METHOD_PARAM

"Flow Conversion Method"

RBS_SYSTEM_NUM_ELEMENTS_PARAM

"Number of Elements"

RBS_SYSTEM_BASE_ELEMENT_PARAM

"System Equipment"

RBS_SYSTEM_CLASSIFICATION_PARAM

"System Classification"

RBS_SYSTEM_NAME_PARAM

"System Name"

PHY_MATERIAL_PARAM_LIGHT_WEIGHT

"Lightweight"

PHY_MATERIAL_PARAM_BEHAVIOR

"Behavior"

PHY_MATERIAL_PARAM_RESISTANCE_CALC_STRENGTH

"Resistance calculation strength"

PHY_MATERIAL_PARAM_REDUCTION_FACTOR

"Reduction factor for shear"

PHY_MATERIAL_PARAM_MINIMUM_TENSILE_STRENGTH

"Minimum tensile strength"

PHY_MATERIAL_PARAM_MINIMUM_YIELD_STRESS

"Minimum yield stress"

PHY_MATERIAL_PARAM_SHEAR_STRENGTH_REDUCTION

"Shear strength modification"

PHY_MATERIAL_PARAM_SHEAR_REINFORCEMENT

"Shear reinforcement yield stress"

PHY_MATERIAL_PARAM_BENDING_REINFORCEMENT

"Bending reinforcement"

PHY_MATERIAL_PARAM_CONCRETE_COMPRESSION

"Concrete compression"

PHY_MATERIAL_PARAM_DAMPING_RATIO

"Damping ratio"

PHY_MATERIAL_PARAM_EXP_COEFF3

"Thermal expansion coefficient Z"

PHY_MATERIAL_PARAM_EXP_COEFF2

"Thermal expansion coefficient Y"

PHY_MATERIAL_PARAM_EXP_COEFF1

"Thermal expansion coefficient X"

PHY_MATERIAL_PARAM_UNIT_WEIGHT

"Unit weight"

PHY_MATERIAL_PARAM_SHEAR_MOD3

"Shear modulus Z"

PHY_MATERIAL_PARAM_SHEAR_MOD2

"Shear modulus Y"

PHY_MATERIAL_PARAM_SHEAR_MOD1

"Shear modulus X"

PHY_MATERIAL_PARAM_POISSON_MOD3

"Poisson ratio Z"

PHY_MATERIAL_PARAM_POISSON_MOD2

"Poisson ratio Y"

PHY_MATERIAL_PARAM_POISSON_MOD1

"Poisson ratio X"

PHY_MATERIAL_PARAM_YOUNG_MOD3

"Young modulus Z"

PHY_MATERIAL_PARAM_YOUNG_MOD2

"Young modulus Y"

PHY_MATERIAL_PARAM_YOUNG_MOD1

"Young modulus X"

RBS_DUCT_ROUTING_PREFERENCE_PARAM

"Routing Preferences"

RBS_SEGMENT_DESCRIPTION_PARAM

"Segment Description"

RBS_PIPE_JOINTTYPE_PARAM

"Connection Type"

RBS_PIPE_SEGMENT_PARAM

"Pipe Segment"

RBS_ROUTING_PREFERENCE_PARAM

"Routing Preferences"

RBS_PARALLELPIPES_VERTICAL_OFFSET_VALUE

"Vertical Offset value for parallel pipes"

RBS_PARALLELPIPES_HORIZONTAL_OFFSET_VALUE

"Horizontal Offset value for parallel pipes"

RBS_PARALLELPIPES_VERTICAL_NUMBER

"Vertical Number for parallel pipes"

RBS_PARALLELPIPES_HORIZONTAL_NUMBER

"Horizontal Number for parallel pipes"

RBS_PARALLELCONDUITS_VERTICAL_OFFSET_VALUE

"Vertical Offset value for parallel conduits"

RBS_PARALLELCONDUITS_HORIZONTAL_OFFSET_VALUE

"Horizontal Offset value for parallel conduits"

RBS_PARALLELCONDUITS_VERTICAL_NUMBER

"Vertical Number for parallel conduits"

RBS_PARALLELCONDUITS_HORIZONTAL_NUMBER

"Horizontal Number for parallel conduits"

RBS_FP_SPRINKLER_ORIFICE_SIZE_PARAM

"Orifice Size"

RBS_FP_SPRINKLER_TEMPERATURE_RATING_PARAM

"Temperature Rating"

RBS_FP_SPRINKLER_K_FACTOR_PARAM

"K-Factor"

RBS_FP_SPRINKLER_PRESSURE_CLASS_PARAM

"Pressure Class"

RBS_FP_SPRINKLER_ORIFICE_PARAM

"Orifice"

RBS_FP_SPRINKLER_COVERAGE_PARAM

"Coverage"

RBS_FP_SPRINKLER_RESPONSE_PARAM

"Response"

RBS_SHOW_PROFILE_TYPE

"Show Round"

RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM

"Fixture Units"

RBS_PIPE_SLOPE

"Slope"

RBS_DUCT_SLOPE

"Slope"

RBS_CURVE_UTSLOPE

"Slope"

RBS_PIPE_VOLUME_PARAM

"Volume"

RBS_PIPE_WFU_PARAM

"WFU"

RBS_PIPE_HWFU_PARAM

"HWFU"

RBS_PIPE_CWFU_PARAM

"CWFU"

RBS_PIPE_FLOW_CONFIGURATION_PARAM

"Flow Configuration"

RBS_PIPE_FLOW_DIRECTION_PARAM

"Flow Direction"

RBS_PIPE_FIXTURE_UNITS_PARAM

"Fixture Units"

RBS_PIPE_STATIC_PRESSURE

"Static Pressure"

RBS_PIPE_INSULATION_THICKNESS

"Insulation Thickness"

RBS_DUCT_BOTTOM_ELEVATION

"Bottom Elevation"

RBS_DUCT_TOP_ELEVATION

"Top Elevation"

RBS_PIPE_OUTER_DIAMETER

"Outer Diameter"

RBS_PIPE_INVERT_ELEVATION

"Invert Elevation"

RBS_PIPE_TYPE_FITTING_LOSS_METHOD_PARAM

"Loss Method"

RBS_PIPE_TYPE_FITTING_LOSS_TABLE_PARAM

"K Coefficient Table"

RBS_PIPE_TYPE_FITTING_LOSS_KFACTOR_PARAM

"K Coefficient"

RBS_PIPE_TYPE_VALVE_LOSS_CVFACTOR_PARAM

"Cv Coefficient"

RBS_PIPE_FITTING_LOSS_METHOD_PARAM

"Loss Method"

RBS_PIPE_FITTING_LOSS_TABLE_PARAM

"K Coefficient Table"

RBS_PIPE_FITTING_LOSS_KFACTOR_PARAM

"K Coefficient"

RBS_PIPE_VALVE_LOSS_CVFACTOR_PARAM

"Cv Coefficient"

RBS_PIPE_ADDITIONAL_FLOW_PARAM

"Additional Flow"

RBS_PIPE_DIAMETER_PARAM

"Diameter"

RBS_CURVE_SLOPE

"Slope Percentage (%)"

RBS_ADJUSTABLE_CONNECTOR

"Allow Slope Adjustments"

RBS_FLOW_FACTOR_PARAM

"Flow Factor"

RBS_DUCT_FLOW_CONFIGURATION_PARAM

"Flow Configuration"

RBS_DUCT_FLOW_DIRECTION_PARAM

"Flow Direction"

RBS_PIPE_FLUID_TYPE_PARAM

"Fluid Type"

RBS_PIPE_FLUID_TEMPERATURE_PARAM

"Fluid Temperature"

RBS_PIPE_FLUID_VISCOSITY_PARAM

"Fluid Viscosity"

RBS_PIPE_FLUID_DENSITY_PARAM

"Fluid Density"

RBS_PIPE_FLOW_PARAM

"Flow"

RBS_PIPE_INNER_DIAM_PARAM

"Inner Diameter"

RBS_PIPE_REYNOLDS_NUMBER_PARAM

"Reynolds Number"

RBS_PIPE_RELATIVE_ROUGHNESS_PARAM

"Relative Roughness"

RBS_PIPE_FLOW_STATE_PARAM

"Flow State"

RBS_PIPE_FRICTION_FACTOR_PARAM

"Friction Factor"

RBS_PIPE_VELOCITY_PARAM

"Velocity"

RBS_PIPE_FRICTION_PARAM

"Friction"

RBS_PIPE_PRESSUREDROP_PARAM

"Pressure Drop"

RBS_PIPE_ROUGHNESS_PARAM

"Roughness"

RBS_PIPE_MATERIAL_PARAM

"Material"

RBS_PIPE_CONNECTIONTYPE_PARAM

"Connection Type"

RBS_PIPE_CLASS_PARAM

"Schedule/Type"

RBS_ELEC_CIRCUIT_START_SLOT

"Start Slot"

CONNECTOR_GENDER_TYPE

"Connector Gender Type"

CONNECTOR_JOINT_TYPE

"Connector Joint Type"

RBS_ELEC_PANEL_CONFIGURATION_PARAM

"Panel Configuration"

RBS_ELEC_PANEL_LOCATION_PARAM

"Location"

PANEL_SCHEDULE_NAME

"Panel Schedule Name"

TEMPLATE_NAME

"Template"

RBS_ELEC_PANEL_CURRENT_PHASEC_PARAM

"Current Phase C"

RBS_ELEC_PANEL_CURRENT_PHASEB_PARAM

"Current Phase B"

RBS_ELEC_PANEL_CURRENT_PHASEA_PARAM

"Current Phase A"

RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_RULE_PARAM

"Description"

RBS_ELEC_LOADSUMMARY_DEMAND_CURRENT_PARAM

"Estimated Demand Current"

RBS_ELEC_LOADSUMMARY_CONNECTED_CURRENT_PARAM

"Connected Current"

RBS_ELEC_LOADSUMMARY_DEMAND_LOAD_PARAM

"Estimated Demand (VA)"

RBS_ELEC_LOADSUMMARY_DEMAND_FACTOR_PARAM

"Demand Factor"

RBS_ELEC_LOADSUMMARY_CONNECTED_LOAD_PARAM

"Connected Load (VA)"

RBS_ELEC_LOADSUMMARY_LOADCLASSIFICATION_PARAM

"Load Classification"

RBS_ELEC_CIRCUIT_NOTES_PARAM

"Schedule Circuit Notes"

RBS_ELEC_CIRCUIT_NUMBER_OF_ELEMENTS_PARAM

"Number of Elements"

RBS_ELEC_CIRCUIT_FRAME_PARAM

"Frame"

RBS_ELEC_PANEL_TOTAL_DEMAND_CURRENT_PARAM

"Total Estimated Demand Current"

RBS_ELEC_PANEL_TOTAL_CONNECTED_CURRENT_PARAM

"Total Connected Current"

RBS_ELEC_PANEL_TOTAL_DEMAND_FACTOR_PARAM

"Total Demand Factor"

RBS_ELEC_PANEL_SCHEDULE_FOOTER_NOTES_PARAM

"Schedule Footer Notes"

RBS_ELEC_PANEL_SCHEDULE_HEADER_NOTES_PARAM

"Schedule Header Notes"

RBS_ELEC_PANEL_NUMWIRES_PARAM

"Number of Wires"

RBS_ELEC_PANEL_NUMPHASES_PARAM

"Number of Phases"

RBS_ELEC_PANEL_NEUTRAL_RATING_PARAM

"Neutral Rating"

RBS_ELEC_PANEL_NEUTRAL_BUS_PARAM

"Neutral Bus"

RBS_ELEC_PANEL_GROUND_BUS_PARAM

"Ground Bus"

RBS_ELEC_PANEL_BUSSING_PARAM

"Bussing"

RBS_ELEC_PANEL_SUBFEED_LUGS_PARAM

"SubFeed Lugs"

RBS_ELEC_PANEL_SUPPLY_FROM_PARAM

"Supply From"

RBS_ELEC_PANEL_MCB_RATING_PARAM

"MCB Rating"

RBS_ELEC_PANEL_MAINSTYPE_PARAM

"Mains Type"

RBS_ELEC_PANEL_FEED_PARAM

"Feed"

RBS_CONDUITRUN_OUTER_DIAM_PARAM

"Outer Diameter"

RBS_CONDUITRUN_INNER_DIAM_PARAM

"Inner Diameter"

RBS_CONDUITRUN_DIAMETER_PARAM

"Diameter(Trade Size)"

RBS_CABLETRAYRUN_WIDTH_PARAM

"Width"

RBS_CABLETRAYRUN_HEIGHT_PARAM

"Height"

RBS_CABLETRAYCONDUITRUN_LENGTH_PARAM

"Length"

RBS_LOAD_SUB_CLASSIFICATION_MOTOR

"Load Sub-Classification Motor"

RBS_CABLETRAY_SHAPETYPE

"Shape"

RBS_CABLETRAYCONDUIT_BENDORFITTING

"Bend or Fitting"

RBS_CTC_SERVICE_TYPE

"Service Type"

RBS_CONDUIT_OUTER_DIAM_PARAM

"Outer Diameter"

RBS_CONDUIT_INNER_DIAM_PARAM

"Inner Diameter"

RBS_CTC_BOTTOM_ELEVATION

"Bottom Elevation"

RBS_CTC_TOP_ELEVATION

"Top Elevation"

RBS_CONDUIT_DIAMETER_PARAM

"Diameter(Trade Size)"

RBS_CABLETRAY_WIDTH_PARAM

"Width"

RBS_CABLETRAY_HEIGHT_PARAM

"Height"

CIRCUIT_LOAD_CLASSIFICATION_PARAM

"Load Classification"

CABLETRAY_MINBENDMULTIPLIER_PARAM

"Bend Radius Multiplier"

CONDUIT_STANDARD_TYPE_PARAM

"Standard"

RBS_CONDUIT_TRADESIZE

"Conduit Size Lookup"

RBS_CONDUIT_BENDRADIUS

"Bend Radius"

RBS_CABLETRAY_BENDRADIUS

"Bend Radius"

RBS_CABLETRAY_RUNGHEIGHT

"Rung Height"

RBS_CABLETRAY_RUNGWIDTH

"Rung Width"

RBS_CABLETRAY_RUNGSPACE

"Rung Space"

RBS_CABLETRAY_THICKNESS

"Thickness"

RBS_ELEC_SWITCH_ID_PARAM

"Switch ID"

RBS_WIRE_CIRCUIT_DESCRIPTION

"Circuit Description"

RBS_WIRE_CIRCUIT_LOAD_NAME

"Circuit Load Name"

RBS_WIRE_NUM_CONDUCTORS_PARAM

"Number of Conductors"

RBS_ELEC_WIRE_TICKMARK_STATE

"Tick Marks"

RBS_ELEC_CIRCUIT_PANEL_PARAM

"Panel"

RBS_ELEC_CIRCUIT_NUMBER

"Circuit Number"

RBS_ELEC_WIRE_CIRCUITS

"Circuits"

RBS_ELEC_CIRCUIT_WIRE_NUM_RUNS_PARAM

"# of Runs"

RBS_ELEC_CIRCUIT_WIRE_NUM_HOTS_PARAM

"# of Hot Conductors"

RBS_ELEC_CIRCUIT_WIRE_NUM_NEUTRALS_PARAM

"# of Neutral Conductors"

RBS_ELEC_CIRCUIT_WIRE_NUM_GROUNDS_PARAM

"# of Ground Conductors"

RBS_ELEC_WIRE_TYPE

"Type"

RBS_ELEC_WIRE_ELEVATION

"Elevation"

RBS_ELEC_WIRE_HOT_ADJUSTMENT

"Hot Conductors"

RBS_ELEC_WIRE_NEUTRAL_ADJUSTMENT

"Neutral Conductors"

RBS_ELEC_WIRE_GROUND_ADJUSTMENT

"Ground Conductors"

RBS_ELEC_WIRE_SHARE_NEUTRAL

"Share Neutral Conductor"

RBS_ELEC_WIRE_SHARE_GROUND

"Share Ground Conductor"

RBS_ELEC_CIRCUIT_NAME

"Load Name"

RBS_FAMILY_CONTENT_SECONDARY_DISTRIBSYS

"Secondary Distribution System"

RBS_ELEC_CIRCUIT_NAMING

"Circuit Naming"

RBS_ELEC_CIRCUIT_PREFIX_SEPARATOR

"Circuit Prefix Separator"

RBS_ELEC_CIRCUIT_PREFIX

"Circuit Prefix"

RBS_ELEC_MODIFICATIONS

"Modifications"

RBS_ELEC_ENCLOSURE

"Enclosure"

RBS_ELEC_MAINS

"Mains"

RBS_ELEC_MOUNTING

"Mounting"

RBS_ELEC_SHORT_CIRCUIT_RATING

"Short Circuit Rating"

RBS_ELEC_MAX_POLE_BREAKERS

"Max #1 Pole Breakers"

RBS_ELEC_PANEL_NAME

"Panel Name"

RBS_ELEC_PANEL_TOTALESTLOAD_HVAC_PARAM

"HVAC Total Estimated Demand"

RBS_ELEC_PANEL_TOTALLOAD_HVAC_PARAM

"HVAC Total Connected"

RBS_ELEC_PANEL_TOTALESTLOAD_LIGHT_PARAM

"Lighting Total Estimated Demand"

RBS_ELEC_PANEL_TOTALLOAD_LIGHT_PARAM

"Lighting Total Connected"

RBS_ELEC_PANEL_TOTALESTLOAD_POWER_PARAM

"Power Total Estimated Demand"

RBS_ELEC_PANEL_TOTALLOAD_POWER_PARAM

"Power Total Connected"

RBS_ELEC_PANEL_TOTALESTLOAD_OTHER_PARAM

"Other Total Estimated Demand"

RBS_ELEC_PANEL_TOTALLOAD_OTHER_PARAM

"Other Total Connected"

RBS_ELEC_PANEL_TOTALESTLOAD_PARAM

"Total Estimated Demand"

RBS_ELEC_PANEL_TOTALLOAD_PARAM

"Total Connected"

RBS_ELEC_DEMANDFACTOR_LOADCLASSIFICATION_PARAM

"Load Classification"

RBS_ELEC_DEMANDFACTOR_LOAD_PARAM

"Connected Load"

RBS_ELEC_DEMANDFACTOR_DEMANDLOAD_PARAM

"Estimated Demand Load"

RBS_FAMILY_CONTENT_DISTRIBUTION_SYSTEM

"Distribution System"

RBS_DISTRIBUTIONSYS_VLL_PARAM

"Line to Line Voltage"

RBS_DISTRIBUTIONSYS_VLG_PARAM

"Line to Ground Voltage"

RBS_DISTRIBUTIONSYS_PHASE_PARAM

"Phase"

RBS_DISTRIBUTIONSYS_CONFIG_PARAM

"Configuration"

RBS_DISTRIBUTIONSYS_NUMWIRES_PARAM

"Wires"

RBS_VOLTAGETYPE_VOLTAGE_PARAM

"Actual Voltage"

RBS_VOLTAGETYPE_MINVOLTAGE_PARAM

"Minimum Voltage"

RBS_VOLTAGETYPE_MAXVOLTAGE_PARAM

"Maximum Voltage"

RBS_ELEC_APPARENT_LOAD_PHASEC

"Apparent Load Phase C"

RBS_ELEC_APPARENT_LOAD_PHASEB

"Apparent Load Phase B"

RBS_ELEC_APPARENT_LOAD_PHASEA

"Apparent Load Phase A"

RBS_ELEC_TRUE_LOAD_PHASEC

"True Load Phase C"

RBS_ELEC_TRUE_LOAD_PHASEB

"True Load Phase B"

RBS_ELEC_TRUE_LOAD_PHASEA

"True Load Phase A"

RBS_ELEC_TRUE_CURRENT_PARAM

"True Current"

RBS_ELEC_TRUE_CURRENT_PHASEA_PARAM

"True Current Phase A"

RBS_ELEC_TRUE_CURRENT_PHASEB_PARAM

"True Current Phase B"

RBS_ELEC_TRUE_CURRENT_PHASEC_PARAM

"True Current Phase C"

RBS_ELEC_APPARENT_CURRENT_PARAM

"Apparent Current"

RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM

"Apparent Current Phase A"

RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM

"Apparent Current Phase B"

RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM

"Apparent Current Phase C"

RBS_ELEC_VOLTAGE_DROP_PARAM

"Voltage Drop"

RBS_ELEC_CALC_COEFFICIENT_UTILIZATION

"Calculate Coefficient of Utilization"

RBS_ELEC_CIRCUIT_LENGTH_PARAM

"Length"

RBS_ELEC_CIRCUIT_RATING_PARAM

"Rating"

RBS_ELEC_CIRCUIT_WIRE_SIZE_PARAM

"Wire Size"

RBS_ELEC_CIRCUIT_WIRE_TYPE_PARAM

"Wire Type"

RBS_ELEC_ROOM_CAVITY_RATIO

"Room Cavity Ratio"

FBX_LIGHT_PHOTOMETRIC_FILE

"Photometric Web File"

RBS_ELEC_ROOM_AVERAGE_ILLUMINATION

"Average Estimated Illumination"

RBS_ELEC_ROOM_REFLECTIVITY_FLOOR

"Floor Reflectance"

RBS_ELEC_ROOM_REFLECTIVITY_WALLS

"Wall Reflectance"

RBS_ELEC_ROOM_REFLECTIVITY_CEILING

"Ceiling Reflectance"

RBS_ELEC_ROOM_LIGHTING_CALC_WORKPLANE

"Lighting Calculation Workplane"

RBS_WIRE_MATERIAL_PARAM

"Material"

RBS_WIRE_TEMPERATURE_RATING_PARAM

"Temperature Rating"

RBS_WIRE_INSULATION_PARAM

"Insulation"

RBS_WIRE_MAX_CONDUCTOR_SIZE_PARAM

"Max Size"

RBS_WIRE_NEUTRAL_MULTIPLIER_PARAM

"Neutral Multiplier"

RBS_WIRE_NEUTRAL_INCLUDED_IN_BALANCED_LOAD_PARAM

"Neutral Included in Balanced Load"

RBS_WIRE_NEUTRAL_MODE_PARAM

"Neutral Size"

RBS_WIRE_CONDUIT_TYPE_PARAM

"Conduit Type"

RBS_ELEC_AMBIENT_TEMPERATURE

"Ambient Temperature"

RBS_ELEC_CIRCUIT_TYPE

"System Type"

RBS_ELEC_LOAD_CLASSIFICATION

"Load Classification"

RBS_ELEC_TRUE_LOAD_PHASE3

"True Load Phase 3"

RBS_ELEC_TRUE_LOAD_PHASE2

"True Load Phase 2"

RBS_ELEC_TRUE_LOAD_PHASE1

"True Load Phase 1"

RBS_ELEC_TRUE_LOAD

"True Load"

RBS_ELEC_POWER_FACTOR_STATE

"Power Factor State"

RBS_ELEC_POWER_FACTOR

"Power Factor"

RBS_ELEC_APPARENT_LOAD_PHASE3

"Apparent Load Phase 3"

RBS_ELEC_APPARENT_LOAD_PHASE2

"Apparent Load Phase 2"

RBS_ELEC_APPARENT_LOAD_PHASE1

"Apparent Load Phase 1"

RBS_ELEC_APPARENT_LOAD

"Apparent Load"

RBS_ELEC_BALANCED_LOAD

"Balanced Load"

RBS_ELEC_VOLTAGE

"Voltage"

RBS_ELEC_NUMBER_OF_POLES

"Number of Poles"

RBS_CONNECTOR_DESCRIPTION

"Connector Description"

VIEW_FAMILY_SCHEDULES

"Family"

VIEW_FAMILY_AND_TYPE_SCHEDULES

"Family and Type"

VIEW_TYPE_SCHEDULES

"Type"

MARKUPS_PRIVATE

"Private"

MARKUPS_NOTES

"Notes"

MARKUPS_HISTORY

"History"

MARKUPS_STATUS

"Status"

MARKUPS_LABEL

"Label"

MARKUPS_CREATOR

"Creator"

MARKUPS_CREATED

"Created"

MARKUPS_MODIFIED

"Modified"

VIEW_SCHEMA_SETTING_FOR_SYSTEM_TEMPLATE

"System Color Schemes"

LEGEND_COMPONENT_DETAIL_LEVEL

"Detail Level"

LEGEND_COMPONENT_LENGTH

"Host Length"

LEGEND_COMPONENT_VIEW

"View Direction"

LEGEND_COMPONENT

"Component Type"

OPTION_SET_ID

"Design Option Set Id"

OPTION_NAME

"Name"

PRIMARY_OPTION_ID

"Primary Option Id"

OPTION_SET_NAME

"Name"

GROUP_ATTACHED_PARENT_NAME

"Attached to"

GROUP_ALLOWED_VIEW_TYPES

"Allowed View Types"

GROUP_OFFSET_FROM_LEVEL

"Origin Level Offset"

GROUP_LEVEL

"Reference Level"

RBS_CABLETRAYCONDUIT_CONNECTORELEM_TYPE

"Connector Type"

RBS_CABLETRAYCONDUIT_SYSTEM_TYPE

"System Type"

RBS_CONNECTOR_ISPRIMARY

"Primary Connector"

CONNECTOR_REFERENCE_INDEX

"Link Connector Index"

RBS_PIPE_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM

"System Classification"

CONNECTOR_ANGLE

"Angle"

RBS_DUCT_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM

"System Classification"

CONNECTOR_INDEX

"Index"

CONNECTOR_VISIBLE_SIZE

"Size on screen"

CONNECTOR_HEIGHT

"Height"

CONNECTOR_WIDTH

"Width"

CONNECTOR_RADIUS

"Radius"

CONNECTOR_PROFILE_TYPE

"Shape"

RBS_PART_TYPE

"Part Type"

PIPE_FITTING_ANGLE

"Angle"

PIPE_FITTING_LAYING_LENGTH

"Laying Length"

PIPE_THICKNESS

"Thickness"

PIPE_FITTING_OVERALL_LENGTH

"Overall Length"

PIPE_CONNECTION_BODY_LENGTH

"Connection Body Length"

PIPE_FITTING_BODY_OUTSIDE_DIAMETER

"Body Outside Diameter"

PIPE_CONNECTION_ENGAGEMENT_LENGTH

"Connection Engagement Length"

PIPE_NOMINAL_DIAMETER

"Nominal Diameter"

PIPE_INSIDE_DIAMETER

"Inside Diameter"

PIPE_OUTSIDE_DIAMETER

"Outside Diameter"

RBS_GBXML_OPENING_TYPE

"Opening Type"

ROOM_CALCULATION_POINT

"Room Calculation Point"

GRID_BANK_COL_WIDTH

"Column Distance"

GRID_BANK_ROW_HEIGHT

"Row Distance"

GRID_BANK_COL_NUM

"Column"

GRID_BANK_ROW_NUM

"Row"

RBS_CURVETYPE_DEFAULT_BEND_PARAM

"Bend"

RBS_CURVETYPE_DEFAULT_HORIZONTAL_BEND_PARAM

"Horizontal Bend"

RBS_CURVETYPE_MULTISHAPE_TRANSITION_OVALROUND_PARAM

"Multi Shape Transition Oval to Round"

RBS_CURVETYPE_MULTISHAPE_TRANSITION_RECTOVAL_PARAM

"Multi Shape Transition Rect to Oval"

RBS_CURVETYPE_DEFAULT_TEEDOWN_PARAM

"Tee Down"

RBS_CURVETYPE_DEFAULT_TEEUP_PARAM

"Tee Up"

RBS_CURVETYPE_DEFAULT_ELBOWDOWN_PARAM

"Vertical Outside Bend"

RBS_CURVETYPE_DEFAULT_ELBOWUP_PARAM

"Vertical Inside Bend"

RBS_ENERGY_ANALYSIS_EXPORT_CATEGORY_PARAM

"Export Category"

RBS_ENERGY_ANALYSIS_EXPORT_COMPLEXITY_PARAM

"Export Complexity"

SPACE_ZONE_NAME

"Zone"

RBS_ENERGY_ANALYSIS_EXPORT_GBXML_DEFAULTS_PARAM

"Export Default Values"

RBS_HVACLOAD_PLENUM_COOLING_LOAD_PARAM

"Plenum Cooling Load"

RBS_HVACLOAD_SKYLIGHT_COOLING_LOAD_PARAM

"Skylight Cooling Load"

RBS_HVACLOAD_PARTITION_COOLING_LOAD_PARAM

"Partition Cooling Load"

RBS_HVACLOAD_DOOR_COOLING_LOAD_PARAM

"Door Cooling Load"

RBS_HVACLOAD_WINDOW_COOLING_LOAD_PARAM

"Window Cooling Load"

RBS_HVACLOAD_WALL_COOLING_LOAD_PARAM

"Wall Cooling Load"

RBS_HVACLOAD_ROOF_COOLING_LOAD_PARAM

"Roof Cooling Load"

RBS_HVACLOAD_SKYLIGHT_AREA_PARAM

"Skylight Area"

RBS_HVACLOAD_PARTITION_AREA_PARAM

"Partition Area"

RBS_HVACLOAD_FLOOR_AREA_PARAM

"Floor Area"

RBS_HVACLOAD_DOOR_AREA_PARAM

"Door Area"

RBS_HVACLOAD_WINDOW_AREA_PARAM

"Window Area"

RBS_HVACLOAD_WALL_AREA_PARAM

"Wall Area"

RBS_HVACLOAD_ROOF_AREA_PARAM

"Roof Area"

RBS_ENERGY_ANALYSIS_VIEW_COORD_AXIS_MODE

"Show a Coordinate System Symbol for each Surface"

RBS_ENERGY_ANALYSIS_VIEW_RBE_MODE

"Show Room Bounding Elements Dimmed and Underlay"

RBS_ENERGY_ANALYSIS_VIEW_SHADING_SURFACES_MODE

"Show Shading Surfaces"

RBS_ENERGY_ANALYSIS_VIEW_TRANSPARENT_MODE

"Show Surfaces Transparent"

RBS_ENERGY_ANALYSIS_VIEW_SURFACES_MODE

"Show Surfaces"

RBS_ENERGY_ANALYSIS_VIEW_INNER_SHELL_MODE

"Show Inner Space Shells"

RBS_ENERGY_ANALYSIS_VIEW_OUTER_SHELL_MODE

"Show Analytical Space Shells"

RBS_ENERGY_ANALYSIS_VIEW_BUILDING_SHELL_MODE

"Show Analytical Building Shell"

RBS_LINING_THICKNESS_FOR_DUCT

"Lining Thickness"

RBS_INSULATION_THICKNESS_FOR_PIPE

"Insulation Thickness"

RBS_INSULATION_THICKNESS_FOR_DUCT

"Insulation Thickness"

BUILDING_UNOCCUPIED_COOLING_SET_POINT_PARAM

"Unoccupied Cooling Set Point"

BUILDING_CLOSING_TIME_PARAM

"Closing Time"

BUILDING_OPENING_TIME_PARAM

"Opening Time"

SPACE_PEOPLE_ACTIVITY_LEVEL_PARAM

"People Activity Level"

SPACE_ELEC_EQUIPMENT_RADIANT_PERCENTAGE_PARAM

"Electrical Equipment Radiant"

SPACE_POWER_SCHEDULE_PARAM

"Power Schedule"

SPACE_LIGHTING_SCHEDULE_PARAM

"Lighting Schedule"

SPACE_OCCUPANCY_SCHEDULE_PARAM

"Occupancy Schedule"

SPACE_INFILTRATION_PARAM

"Infiltration"

SPACE_CARPETING_PARAM

"Carpeting"

ZONE_AIR_VOLUME_CALCULATION_TYPE_PARAM

"Air Volume Calculation Type"

ZONE_COIL_BYPASS_PERCENTAGE_PARAM

"Coil Bypass"

ZONE_CALCULATED_AREA_PER_COOLING_LOAD_PARAM

"Calculated Area per Cooling Load"

ZONE_CALCULATED_AREA_PER_HEATING_LOAD_PARAM

"Calculated Area per Heating Load"

ZONE_USE_AIR_CHANGES_PER_HOUR_PARAM

"Use Air Changes Per Hour"

ZONE_USE_OUTSIDE_AIR_PER_AREA_PARAM

"Use Outside Air Per Area"

ZONE_USE_OUTSIDE_AIR_PER_PERSON_PARAM

"Use Outside Air Per Person"

ZONE_USE_DEHUMIDIFICATION_SETPOINT_PARAM

"Use Dehumidification Set Point"

ZONE_USE_HUMIDIFICATION_SETPOINT_PARAM

"Use Humidification Set Point"

ZONE_OUTDOOR_AIR_INFORMATION_PARAM

"Outdoor Air Information"

ZONE_COOLING_INFORMATION_PARAM

"Cooling Information"

ZONE_HEATING_INFORMATION_PARAM

"Heating Information"

RBS_ENERGY_ANALYSIS_SLIVER_SPACE_TOLERANCE

"Sliver Space Tolerance"

ZONE_AREA_GROSS

"Gross Area"

ZONE_VOLUME_GROSS

"Gross Volume"

SPACE_IS_PLENUM

"Plenum"

SPACE_IS_OCCUPIABLE

"Occupiable"

SPACE_ASSOC_ROOM_NUMBER

"Room Number"

SPACE_ASSOC_ROOM_NAME

"Room Name"

ZONE_PHASE

"Phase"

ZONE_PHASE_ID

"Phase Id"

RBS_ENERGY_ANALYSIS_PROJECT_PHASE_PARAM

"Project Phase"

ROOM_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM

"Calculated Supply Airflow per area"

ROOM_CALCULATED_COOLING_LOAD_PER_AREA_PARAM

"Calculated Cooling Load per area"

ROOM_CALCULATED_HEATING_LOAD_PER_AREA_PARAM

"Calculated Heating Load per area"

ZONE_CALCULATED_SUPPLY_AIRFLOW_PER_AREA_PARAM

"Calculated Supply Airflow per area"

ZONE_CALCULATED_COOLING_LOAD_PER_AREA_PARAM

"Calculated Cooling Load per area"

ZONE_CALCULATED_HEATING_LOAD_PER_AREA_PARAM

"Calculated Heating Load per area"

ZONE_LEVEL_ID

"Level"

ZONE_OA_RATE_PER_ACH_PARAM

"Outdoor Air Rate / Air Changes per Hour"

ZONE_OUTSIDE_AIR_PER_AREA_PARAM

"Outdoor Air per Area"

ZONE_OUTSIDE_AIR_PER_PERSON_PARAM

"Outdoor Air per Person"

ZONE_DEHUMIDIFICATION_SET_POINT_PARAM

"Dehumidification Set Point"

ZONE_HUMIDIFICATION_SET_POINT_PARAM

"Humidification Set Point"

ZONE_COOLING_AIR_TEMPERATURE_PARAM

"Cooling Air Temperature"

ZONE_HEATING_AIR_TEMPERATURE_PARAM

"Heating Air Temperature"

ZONE_COOLING_SET_POINT_PARAM

"Cooling Set Point"

ZONE_HEATING_SET_POINT_PARAM

"Heating Set Point"

ZONE_CALCULATED_SUPPLY_AIRFLOW_PARAM

"Calculated Supply Airflow"

ZONE_CALCULATED_COOLING_LOAD_PARAM

"Calculated Cooling Load"

ZONE_CALCULATED_HEATING_LOAD_PARAM

"Calculated Heating Load"

ZONE_SERVICE_TYPE_PARAM

"Service Type"

ZONE_VOLUME

"Occupied Volume"

ZONE_PERIMETER

"Perimeter"

ZONE_AREA

"Occupied Area"

ZONE_NAME

"Name"

RBS_ENERGY_ANALYSIS_VIEW_UPDATE_SURFACES

"Update Surfaces"

RBS_PROJECT_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM

"Internal Shading Factor"

RBS_CONSTRUCTION_TYPE_SHADINGFACTOR_PARAM

"Internal Shading Factor"

RBS_ENERGY_ANALYSIS_GROUND_PLANE_PARAM

"Ground Plane"

RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Z

"Origin (Z)"

RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_Y

"Origin (Y)"

RBS_ENERGY_ANALYSIS_SURFACE_ORIGIN_X

"Origin (X)"

RBS_ENERGY_ANALYSIS_SURFACE_AZIMUTH

"Azimuth"

RBS_ENERGY_ANALYSIS_SURFACE_TILT

"Tilt"

RBS_ENERGY_ANALYSIS_SURFACE_CADOBJECTID

"CADObjectID"

RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID2

"Adjacent Space Id (2)"

RBS_ENERGY_ANALYSIS_SURFACE_ADJACENT_SPACE_ID1

"Adjacent Space Id (1)"

ROOM_EDIT_ELECTRICAL_LOADS_PARAM

"Electrical Loads"

ROOM_EDIT_PEOPLE_LOADS_PARAM

"People"

RBS_PROJECT_LOCATION_PARAM

"Location"

ROOM_ACTUAL_LIGHTING_LOAD_PER_AREA_PARAM

"Actual Lighting Load per area"

ROOM_ACTUAL_POWER_LOAD_PER_AREA_PARAM

"Actual Power Load per area"

ROOM_BASE_HEAT_LOAD_ON_PARAM

"Heat Load Values"

ROOM_LIGHTING_LOAD_UNITS_PARAM

"Lighting Load Units"

ROOM_POWER_LOAD_UNITS_PARAM

"Power Load Units"

ROOM_DESIGN_COOLING_LOAD_PARAM

"Design Cooling Load"

ROOM_CALCULATED_COOLING_LOAD_PARAM

"Calculated Cooling Load"

ROOM_DESIGN_HEATING_LOAD_PARAM

"Design Heating Load"

ROOM_CALCULATED_HEATING_LOAD_PARAM

"Calculated Heating Load"

ROOM_BASE_RETURN_AIRFLOW_ON_PARAM

"Return Airflow"

ROOM_CONSTRUCTION_SET_PARAM

"Construction Type"

RBS_CONSTRUCTION_SET_PARAM

"Building Construction"

RBS_SERVICE_TYPE_PARAM

"Building Service"

RBS_GBXML_SURFACE_AREA

"Area"

RBS_GBXML_SURFACE_TYPE

"Surface Type"

RBS_GBXML_SURFACE_NAME

"Surface Name"

FAMILY_ELECTRICAL_MAINTAIN_ANNOTATION_ORIENTATION

"Maintain Annotation Orientation"

RBS_FAMILY_CONTENT_ANNOTATION_DISPLAY

"Use Annotation Scale"

RBS_ELECTRICAL_DATA

"Electrical Data"

RBS_CALCULATED_SIZE

"Size"

ROOM_PEOPLE_SENSIBLE_HEAT_GAIN_PER_PERSON_PARAM

"Sensible Heat Gain per person"

RBS_IS_CUSTOM_FITTING

"IsCustom"

RBS_CONNECTOR_OFFSET_OBSOLETE

"Connector Offset"

RBS_LOOKUP_TABLE_NAME

"Lookup Table Name"

ROOM_DESIGN_LIGHTING_LOAD_PARAM

"Specified Lighting Load"

ROOM_DESIGN_POWER_LOAD_PARAM

"Specified Power Load"

ROOM_ACTUAL_LIGHTING_LOAD_PARAM

"Actual Lighting Load"

ROOM_ACTUAL_POWER_LOAD_PARAM

"Actual Power Load"

ROOM_BASE_LIGHTING_LOAD_ON_PARAM

"Base Lighting Load on"

ROOM_BASE_POWER_LOAD_ON_PARAM

"Base Power Load on"

ROOM_DESIGN_OTHER_LOAD_PER_AREA_PARAM

"Design Other Load per area"

ROOM_DESIGN_MECHANICAL_LOAD_PER_AREA_PARAM

"Design HVAC Load per area"

ROOM_DESIGN_LIGHTING_LOAD_PER_AREA_PARAM

"Specified Lighting Load per area"

ROOM_DESIGN_POWER_LOAD_PER_AREA_PARAM

"Specified Power Load per area"

FBX_LIGHT_BALLAST_LOSS

"Ballast Loss"

FBX_LIGHT_TOTAL_LIGHT_LOSS

"Total Light Loss Factor"

RBS_ROOM_COEFFICIENT_UTILIZATION

"Coefficient of Utilization"

RBS_FAMILY_CONTENT_TAKEOFF_FIXED_LENGTH

"Takeoff Fixed Length"

RBS_FAMILY_CONTENT_TAKEOFF_PROJLENGTH

"Takeoff Length Projection"

RBS_FAMILY_CONTENT_TAKEOFF_LENGTH

"Takeoff Length"

RBS_FAMILY_CONTENT_OFFSET_HEIGHT

"OffsetHeight"

RBS_FAMILY_CONTENT_OFFSET_WIDTH

"OffsetWidth"

FAMILY_CONTENT_PART_TYPE

"Part Type"

GBXML_EDIT_DATA_PARAM

"Energy Settings"

ROOM_ACTUAL_EXHAUST_AIRFLOW_PARAM

"Actual Exhaust Airflow"

ROOM_ACTUAL_RETURN_AIRFLOW_PARAM

"Actual Return Airflow"

ROOM_ACTUAL_SUPPLY_AIRFLOW_PARAM

"Actual Supply Airflow"

ROOM_PEOPLE_LATENT_HEAT_GAIN_PER_PERSON_PARAM

"Latent Heat Gain per person"

ROOM_PEOPLE_TOTAL_HEAT_GAIN_PER_PERSON_PARAM

"Total Heat Gain per person"

ROOM_CALCULATED_SUPPLY_AIRFLOW_PARAM

"Calculated Supply Airflow"

ROOM_DESIGN_EXHAUST_AIRFLOW_PARAM

"Specified Exhaust Airflow"

ROOM_DESIGN_RETURN_AIRFLOW_PARAM

"Specified Return Airflow"

ROOM_DESIGN_SUPPLY_AIRFLOW_PARAM

"Specified Supply Airflow"

ROOM_AREA_PER_PERSON_PARAM

"Area per Person"

ROOM_NUMBER_OF_PEOPLE_PARAM

"Number of People"

ROOM_OCCUPANCY_UNIT_PARAM

"Occupancy Unit"

ROOM_SPACE_TYPE_PARAM

"Space Type"

ROOM_CONDITION_TYPE_PARAM

"Condition Type"

PROJECT_POSTAL_CODE

"Postal Code"

PROJECT_BUILDING_TYPE

"Building Type"

RBS_SIZE_LOCK

"Size Lock"

RBS_ADDITIONAL_FLOW

"Additional Flow"

RBS_CURVETYPE_MAX_WIDTH_PARAM

"Max Width"

RBS_CURVETYPE_DEFAULT_MECHJOINT_PARAM

"Flange"

RBS_PIPE_SIZE_FORMATTED_PARAM

"Size"

RBS_DUCT_SIZE_FORMATTED_PARAM

"Size"

RBS_DUCT_STATIC_PRESSURE

"Static Pressure"

RBS_FLEX_PIPE_TYPE_PARAM

"Flex Pipe"

RBS_PIPE_TYPE_PARAM

"Pipe Type"

RBS_FLEX_DUCT_TYPE_PARAM

"Flex Duct Type"

RBS_DUCT_TYPE_PARAM

"Duct Type"

RBS_DUCT_FITTING_LOSS_TABLE_PARAM

"ASHRAE Table"

RBS_DUCT_FITTING_LOSS_METHOD_PARAM

"Loss Method"

RBS_FLEXDUCT_ROUNDTYPE_PARAM

"Flex Duct Type"

RBS_CURVETYPE_PREFERRED_BRANCH_PARAM

"Preferred Junction Type"

RBS_CURVETYPE_DEFAULT_TAKEOFF_PARAM

"Tap"

RBS_OFFSET_PARAM

"Offset"

RBS_CURVETYPE_DEFAULT_UNION_PARAM

"Union"

RBS_HYDRAULIC_DIAMETER_PARAM

"Hydraulic Diameter"

RBS_REYNOLDSNUMBER_PARAM

"Reynolds number"

RBS_EQ_DIAMETER_PARAM

"Equivalent Diameter"

RBS_CURVETYPE_MULTISHAPE_TRANSITION_PARAM

"Multi Shape Transition Rect to Round"

RBS_SECTION

"Section"

RBS_LOSS_COEFFICIENT

"Loss Coefficient"

RBS_MAX_FLOW

"Max Flow"

RBS_MIN_FLOW

"Min Flow"

RBS_VELOCITY_PRESSURE

"Velocity Pressure"

RBS_CURVE_SURFACE_AREA

"Area"

RBS_CURVETYPE_MAX_HEIGHT_PARAM

"Max Height"

RBS_LINING_THICKNESS

"Lining Thickness"

RBS_INSULATION_THICKNESS

"Insulation Thickness"

RBS_FRICTION

"Friction"

RBS_CURVETYPE_ROUGHNESS_PARAM

"Roughness"

RBS_CURVETYPE_DEFAULT_TRANSITION_PARAM

"Transition"

RBS_CURVETYPE_DEFAULT_CROSS_PARAM

"Cross"

RBS_CURVETYPE_DEFAULT_TEE_PARAM

"Tee"

RBS_CURVETYPE_DEFAULT_ELBOW_PARAM

"Elbow"

RBS_PRESSURE_DROP

"Pressure Drop"

RBS_VELOCITY

"Velocity"

RBS_CURVE_VERT_OFFSET_PARAM

"Vertical Justification"

RBS_CURVE_HOR_OFFSET_PARAM

"Horizontal Justification"

RBS_FLOW_OBSOLETE

"Flow"

RBS_CURVE_DIAMETER_PARAM

"Diameter"

RBS_CURVE_HEIGHT_PARAM

"Height"

RBS_CURVE_WIDTH_PARAM

"Width"

RBS_FLEX_PATTERN_PARAM

"Flex Pattern"

RBS_END_OFFSET_PARAM

"End Offset"

RBS_START_OFFSET_PARAM

"Start Offset"

RBS_END_LEVEL_PARAM

"End Level"

RBS_START_LEVEL_PARAM

"Reference Level"

DIVIDEDPATH_TOTAL_PATH_LENGTH

"Path Length"

DIVIDEDPATH_DISPLAY_NODE_NUMBERS

"Show Node Numbers"

DIVIDEDPATH_MERGED_POINT_NUM

"Total Number of Nodes"

DIVIDEDPATH_DISPLAY_NODES

"Display Nodes"

DIVIDEDPATH_DISPLAY_REFERENCE_CURVES

"Display Path"

DIVIDEDPATH_JUSTIFICATION

"Justification"

DIVIDEDPATH_LAYOUT_FIXED_NUM_POINT

"Number"

DIVIDEDPATH_FLIP_DIRECTION

"Flip Direction"

DIVIDEDPATH_MEASUREMENT_TYPE

"Measurement Type"

DIVIDEDPATH_MAX_DISTANCE

"Maximum Distance"

DIVIDEDPATH_MIN_DISTANCE

"Mininimum Distance"

DIVIDEDPATH_END_INDENT

"End Indent"

DIVIDEDPATH_BEGINNING_INDENT

"Beginning Indent"

DIVIDEDPATH_DISTANCE

"Distance"

DIVIDEDPATH_LAYOUT

"Layout"

PROJECT_ORGANIZATION_NAME

"Organization Name"

PROJECT_ORGANIZATION_DESCRIPTION

"Organization Description"

PROJECT_BUILDING_NAME

"Building Name"

PROJECT_AUTHOR

"Author"

IFC_SITE_GUID

"IfcSite GUID"

IFC_BUILDING_GUID

"IfcBuilding GUID"

IFC_PROJECT_GUID

"IfcProject GUID"

IFC_TYPE_GUID

"IfcGUID"

IFC_GUID

"IfcGUID"

STRUCT_CONNECTION_TYPE_NAME

"Name"

STRUCT_CONNECTION_CUTBACK

"Automatic Cutback for Beams and Braces"

STRUCT_CONNECTION_COLUMN_BASE

"Base Connection"

STRUCT_CONNECTION_COLUMN_TOP

"Top Connection"

STRUCT_CONNECTION_BEAM_END

"End Connection"

STRUCT_CONNECTION_BEAM_START

"Start Connection"

STRUCT_CONNECTION_APPLY_TO

"Apply to"

REINFORCEMENT_VOLUME

"Reinforcement Volume"

REIN_EST_BAR_VOLUME

"Estimated Reinforcement Volume"

REIN_EST_BAR_LENGTH

"Estimated Total Bar Length"

REIN_EST_NUMBER_OF_BARS

"Estimated Number of Bars"

PATH_REIN_SHAPE_2

"Alternating Bar - Shape"

PATH_REIN_SHAPE_1

"Primary Bar - Shape"

PATH_REIN_SPANLENGTH_ALT_OFFSET

"Offset"

PATH_REIN_SPANLENGTH_BARLENGTH_ALT

"Length (Alternating Bar)"

PATH_REIN_SPANLENGTH_BARLENGTH_PRIM

"Length (Primary Bar)"

PATH_REIN_SPANLENGTH_TOP_ALT

"Top (Alternating Bar)"

PATH_REIN_END_SPANHOOK_ALT

"End Hook Angle Alternating"

PATH_REIN_END_SPANHOOK_PRIM

"End Hook Angle Primary"

PATH_REIN_SUMMARY

"Summary"

PATH_REIN_SPANLENGTH_BOTTOM_ALT

"Bottom (Alternating Bar)"

PATH_REIN_SPANLENGTH_BOTTOM_PRIM

"Bottom (Primary Bar)"

PATH_REIN_SPANHOOK_ALT

"Start Hook Angle Alternating"

PATH_REIN_SPANHOOK_PRIM

"Start Hook Angle Primary"

PATH_REIN_ADDL_OFFSET

"Additional Offset"

PATH_REIN_ALT_OFFSET

"Alternating Bar - Offset"

PATH_REIN_END_HOOK_ORIENT_2_WALL

"INTERNAL: Alternating Bar - End Hook Orientation"

PATH_REIN_END_HOOK_ORIENT_1_WALL

"INTERNAL: Primary Bar - End Hook Orientation"

PATH_REIN_END_HOOK_ORIENT_2_SLAB

"INTERNAL: Alternating Bar - End Hook Orientation"

PATH_REIN_END_HOOK_ORIENT_1_SLAB

"INTERNAL: Primary Bar - End Hook Orientation"

PATH_REIN_END_HOOK_TYPE_2

"Alternating Bar - End Hook Type"

PATH_REIN_END_HOOK_TYPE_1

"Primary Bar - End Hook Type"

PATH_REIN_HOOK_ORIENT_2_WALL

"Alternating Bar - Hook Orientation"

PATH_REIN_HOOK_ORIENT_1_WALL

"Primary Bar - Hook Orientation"

PATH_REIN_HOOK_ORIENT_2_SLAB

"Alternating Bar - Hook Orientation"

PATH_REIN_HOOK_ORIENT_1_SLAB

"Primary Bar - Hook Orientation"

PATH_REIN_HOOK_TYPE_2

"Alternating Bar - Start Hook Type"

PATH_REIN_HOOK_TYPE_1

"Primary Bar - Start Hook Type"

PATH_REIN_LENGTH_2

"Alternating Bar - Length"

PATH_REIN_LENGTH_1

"Primary Bar - Length"

PATH_REIN_TYPE_2

"Alternating Bar - Type"

PATH_REIN_TYPE_1

"Primary Bar - Type"

PATH_REIN_ALTERNATING

"Alternating Bars"

PATH_REIN_NUMBER_OF_BARS

"Number Of Bars"

PATH_REIN_SPACING

"Bar Spacing"

PATH_REIN_FACE_WALL

"Face"

PATH_REIN_FACE_SLAB

"Face"

REBAR_SYSTEM_SPACING_BOTTOM_DIR_2_GENERIC

"Bottom/Interior Minor Spacing"

REBAR_SYSTEM_SPACING_BOTTOM_DIR_1_GENERIC

"Bottom/Interior Major Spacing"

REBAR_SYSTEM_SPACING_TOP_DIR_2_GENERIC

"Top/Exterior Minor Spacing"

REBAR_SYSTEM_SPACING_TOP_DIR_1_GENERIC

"Top/Exterior Major Spacing"

REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2_GENERIC

"Bottom/Interior Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1_GENERIC

"Bottom/Interior Major Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2_GENERIC

"Top/Exterior Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1_GENERIC

"Top/Exterior Major Number Of Lines"

REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2_GENERIC

"Bottom/Interior Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1_GENERIC

"Bottom/Interior Major Bar Type"

REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2_GENERIC

"Top/Exterior Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1_GENERIC

"Top/Exterior Major Bar Type"

REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2_GENERIC

"Bottom/Interior Minor Direction"

REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1_GENERIC

"Bottom/Interior Major Direction"

REBAR_SYSTEM_ACTIVE_TOP_DIR_2_GENERIC

"Top/Exterior Minor Direction"

REBAR_SYSTEM_ACTIVE_TOP_DIR_1_GENERIC

"Top/Exterior Major Direction"

REBAR_SYSTEM_SPACING_BACK_DIR_2

"Interior Minor Spacing"

REBAR_SYSTEM_SPACING_BACK_DIR_1

"Interior Major Spacing"

REBAR_SYSTEM_SPACING_FRONT_DIR_2

"Exterior Minor Spacing"

REBAR_SYSTEM_SPACING_FRONT_DIR_1

"Exterior Major Spacing"

REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_2

"Interior Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_BACK_DIR_1

"Interior Major Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_2

"Exterior Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_FRONT_DIR_1

"Exterior Major Number Of Lines"

REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_2

"Interior Minor Hook Type"

REBAR_SYSTEM_HOOK_TYPE_BACK_DIR_1

"Interior Major Hook Type"

REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_2

"Exterior Minor Hook Type"

REBAR_SYSTEM_HOOK_TYPE_FRONT_DIR_1

"Exterior Major Hook Type"

REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_2

"Interior Minor Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_BACK_DIR_1

"Interior Major Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_2

"Exterior Minor Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_FRONT_DIR_1

"Exterior Major Hook Orientation"

REBAR_SYSTEM_BAR_TYPE_BACK_DIR_2

"Interior Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_BACK_DIR_1

"Interior Major Bar Type"

REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_2

"Exterior Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_FRONT_DIR_1

"Exterior Major Bar Type"

REBAR_SYSTEM_ACTIVE_BACK_DIR_2

"Interior Minor Direction"

REBAR_SYSTEM_ACTIVE_BACK_DIR_1

"Interior Major Direction"

REBAR_SYSTEM_ACTIVE_FRONT_DIR_2

"Exterior Minor Direction"

REBAR_SYSTEM_ACTIVE_FRONT_DIR_1

"Exterior Major Direction"

REBAR_SYSTEM_SPACING_BOTTOM_DIR_2

"Bottom Minor Spacing"

REBAR_SYSTEM_SPACING_BOTTOM_DIR_1

"Bottom Major Spacing"

REBAR_SYSTEM_SPACING_TOP_DIR_2

"Top Minor Spacing"

REBAR_SYSTEM_SPACING_TOP_DIR_1

"Top Major Spacing"

REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_2

"Bottom Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_BOTTOM_DIR_1

"Bottom Major Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_2

"Top Minor Number Of Lines"

REBAR_SYSTEM_NUMBER_OF_LINES_TOP_DIR_1

"Top Major Number Of Lines"

REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_2

"Bottom Minor Hook Type"

REBAR_SYSTEM_HOOK_TYPE_BOTTOM_DIR_1

"Bottom Major Hook Type"

REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_2

"Top Minor Hook Type"

REBAR_SYSTEM_HOOK_TYPE_TOP_DIR_1

"Top Major Hook Type"

REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_2

"Bottom Minor Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_BOTTOM_DIR_1

"Bottom Major Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_2

"Top Minor Hook Orientation"

REBAR_SYSTEM_HOOK_ORIENT_TOP_DIR_1

"Top Major Hook Orientation"

REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_2

"Bottom Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_BOTTOM_DIR_1

"Bottom Major Bar Type"

REBAR_SYSTEM_BAR_TYPE_TOP_DIR_2

"Top Minor Bar Type"

REBAR_SYSTEM_BAR_TYPE_TOP_DIR_1

"Top Major Bar Type"

REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_2

"Bottom Minor Direction"

REBAR_SYSTEM_ACTIVE_BOTTOM_DIR_1

"Bottom Major Direction"

REBAR_SYSTEM_ACTIVE_TOP_DIR_2

"Top Minor Direction"

REBAR_SYSTEM_ACTIVE_TOP_DIR_1

"Top Major Direction"

REBAR_SYSTEM_SPANHOOK_TOP_DIR_2

"Hook Angle Top"

REBAR_SYSTEM_SPANHOOK_BOTTOM_DIR_2

"Hook Angle Bottom"

REBAR_SYSTEM_SPANHOOK_RIGHT_DIR_1

"Hook Angle Right"

REBAR_SYSTEM_SPANHOOK_LEFT_DIR_1

"Hook Angle Left"

REBAR_SYSTEM_SPANACTIVE_DIR_2

"Bars In Minor Direction"

REBAR_SYSTEM_SPANACTIVE_DIR_1

"Bars In Major Direction"

REBAR_SYSTEM_ADDL_INTERIOR_OFFSET

"Additional Interior Cover Offset"

REBAR_SYSTEM_ADDL_EXTERIOR_OFFSET

"Additional Exterior Cover Offset"

REBAR_SYSTEM_ADDL_BOTTOM_OFFSET

"Additional Bottom Cover Offset"

REBAR_SYSTEM_ADDL_TOP_OFFSET

"Additional Top Cover Offset"

REBAR_SYSTEM_TOP_MINOR_MATCHES_BOTTOM_MINOR

"Top and Bottom Minor Layers Match"

REBAR_SYSTEM_TOP_MAJOR_MATCHES_BOTTOM_MAJOR

"Top and Bottom Major Layers Match"

REBAR_SYSTEM_BOTTOM_MAJOR_MATCHES_BOTTOM_MINOR

"Bottom Major and Minor Layers Match"

REBAR_SYSTEM_TOP_MAJOR_MATCHES_TOP_MINOR

"Top Major and Minor Layers Match"

REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_NO_SPACING

"Minor, Both Faces (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_DIR_2_WITH_SPACING

"Minor, Both Faces"

REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_NO_SPACING

"Major, Both Faces (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_DIR_1_WITH_SPACING

"Major, Both Faces"

REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_NO_SPACING

"Bottom/Interior Minor (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_2_WITH_SPACING

"Bottom/Interior Minor"

REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_NO_SPACING

"Bottom/Interior Major (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_BOTTOM_DIR_1_WITH_SPACING

"Bottom/Interior Major"

REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_NO_SPACING

"Top/Exterior Minor (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_2_WITH_SPACING

"Top/Exterior Minor"

REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_NO_SPACING

"Top/Exterior Major (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_TOP_DIR_1_WITH_SPACING

"Top/Exterior Major"

REBAR_SYSTEM_COVER_BOTTOM

"Rebar Cover Bottom/Interior"

REBAR_SYSTEM_COVER_TOP

"Rebar Cover Top/Exterior"

REBAR_SYSTEM_OVERRIDE

"Override Area Reinforcement Settings"

REBAR_SYSTEM_LAYER_SUMMARY_NO_SPACING

"Layer Summary (Brief)"

REBAR_SYSTEM_LAYER_SUMMARY_WITH_SPACING

"Layer Summary"

REBAR_SYSTEM_LAYOUT_RULE

"Layout Rule"

REBAR_SYSTEM_COVER_SIDE

"Rebar Cover Side/Edge"

FABRIC_PARAM_SPAN_TAG_COMPONENT_REFERENCE

"Tag Component Reference"

FABRIC_PARAM_SPAN_SYM_D_RIGHT

"D_Right"

FABRIC_PARAM_SPAN_SYM_D_LEFT

"D_Left"

FABRIC_PARAM_SPAN_SYM_D_BOTTOM

"D_Bottom"

FABRIC_PARAM_SPAN_SYM_D_TOP

"D_Top"

FABRIC_PARAM_SPAN_SYM_RIGHT

"Right"

FABRIC_PARAM_SPAN_SYM_LEFT

"Left"

FABRIC_PARAM_SPAN_SYM_BOTTOM

"Bottom"

FABRIC_PARAM_SPAN_SYM_TOP

"Top"

FABRIC_PARAM_TAG_VIEW

"Tag new members in view": List of all Plan Views and None.

FABRIC_PARAM_CUT_SHEET_MASS

"Cut Sheet Mass": Calculated cut sheet mass [Sheet Mass per Unit Area * (Cut Overall Length * Cut Overall Width)]

FABRIC_PARAM_TOTAL_SHEET_MASS

"Total Sheet Mass": Calculated all sheet mass: Volume of Wire * Unit Weight.

FABRIC_PARAM_CUT_OVERALL_WIDTH

"Cut Overall Width": Provides a real sheet Width after definition

FABRIC_PARAM_CUT_OVERALL_LENGTH

"Cut Overall Length": Provides a real sheet Length after definition

FABRIC_PARAM_COVER_OFFSET

"Additional Cover Offset": Additional cover offset of the fabric distribution.

FABRIC_PARAM_MINOR_LAPSPLICE_LENGTH

"Minor Lap Splice Length": Fabric lap splice length in minor direction in the fabric distribution.

FABRIC_PARAM_MAJOR_LAPSPLICE_LENGTH

"Major Lap Splice Length": Fabric lap splice length in major direction in the fabric distribution.

FABRIC_PARAM_LOCATION_GENERIC

"Location": Fabric location in the host.

FABRIC_PARAM_LAPSPLICE_POSITION

"Lap Splice Position": Fabric lap splice position in the fabric distribution

FABRIC_PARAM_LOCATION_WALL

"Location": Fabric location in the wall

FABRIC_PARAM_LOCATION_SLAB

"Location": Fabric location in the slab

FABRIC_PARAM_SHEET_TYPE

"Fabric Sheet": List all Fabric Sheet types

FABRIC_SHEET_MASSUNIT

"Sheet Mass per Unit Area": Structural Sheet Mass per Unit Area [Sheet Mass / (Overall Length * Overall Width)]

FABRIC_SHEET_MINOR_REINFORCEMENT_AREA

"Minor Reinforcement Area": Minor Reinforcement Area

FABRIC_SHEET_MAJOR_REINFORCEMENT_AREA

"Major Reinforcement Area": Major Reinforcement Area

FABRIC_SHEET_MASS

"Sheet Mass": Sheet Mass

FABRIC_SHEET_MINOR_SPACING

"Minor Spacing": Minor Spacing

FABRIC_SHEET_MINOR_NUMBER_OF_WIRES

"Minor Number of Wires": Minor Number of Wires

FABRIC_SHEET_MINOR_LAYOUT_PATTERN

"Minor Layout Pattern": Minor Layout Pattern

FABRIC_SHEET_MINOR_END_OVERHANG

"Minor End Overhang": Minor End Overhang

FABRIC_SHEET_MINOR_START_OVERHANG

"Minor Start Overhang": Minor Start Overhang

FABRIC_SHEET_WIDTH

"Width": Width

FABRIC_SHEET_OVERALL_WIDTH

"Overall Width": Overall Width

FABRIC_SHEET_MAJOR_SPACING

"Major Spacing": Major Spacing

FABRIC_SHEET_MAJOR_NUMBER_OF_WIRES

"Major Number of Wires": Major Number of Wires

FABRIC_SHEET_MAJOR_LAYOUT_PATTERN

"Major Layout Pattern": Major Layout Pattern

FABRIC_SHEET_MAJOR_END_OVERHANG

"Major End Overhang": Major End Overhang

FABRIC_SHEET_MAJOR_START_OVERHANG

"Major Start Overhang": Major Start Overhang

FABRIC_SHEET_LENGTH

"Length": Length

FABRIC_SHEET_OVERALL_LENGTH

"Overall Length": Overall Length

FABRIC_SHEET_DEFAULT_MINOR_LAPSPLICE_LENGTH

"Default Minor Lap Splice Length": Default Minor Lap Splice Length

FABRIC_SHEET_DEFAULT_MAJOR_LAPSPLICE_LENGTH

"Default Major Lap Splice Length": Default Major Lap Splice Length

FABRIC_SHEET_MINOR_DIRECTION_WIRE_TYPE

"Minor Direction Wire Type": Minor Direction Wire Type

FABRIC_SHEET_MAJOR_DIRECTION_WIRE_TYPE

"Major Direction Wire Type": Major Direction Wire Type

FABRIC_SHEET_PHYSICAL_MATERIAL_ASSET

"Physical Material Asset": Physical Material Asset

FABRIC_WIRE_DIAMETER

"Nominal Diameter": Nominal Diameter of Fabric Wire.

REBAR_INTERNAL_MULTIPLANAR_END_CONNECTOR

"INTERNAL: Multiplanar End Connector"

REBAR_INTERNAL_MULTIPLANAR_START_CONNECTOR

"INTERNAL: Multiplanar Start Connector"

REBAR_INTERNAL_MULTIPLANAR_DUPLICATE

"INTERNAL: Multiplanar Duplicate"

REBAR_INTERNAL_MULTIPLANAR

"INTERNAL: Multiplanar"

REBAR_SHAPE_OUT_OF_PLANE_BEND_DIAMETER

"Out of Plane Bend Diameter"

REBAR_INSTANCE_STIRRUP_TIE_ATTACHMENT

"Stirrup/Tie Attachment"

REBAR_SHAPE_STIRRUP_TIE_ATTACHMENT

"Stirrup/Tie Attachment"

REBAR_SHAPE_SPIRAL_BASE_FINISHING_TURNS

"Base Finishing Turns"

REBAR_SHAPE_SPIRAL_TOP_FINISHING_TURNS

"Top Finishing Turns"

REBAR_SHAPE_SPIRAL_HEIGHT

"Height"

REBAR_SHAPE_SPIRAL_PITCH

"Pitch"

REBAR_STANDARD_HOOK_BEND_DIAMETER

"Standard Hook Bend Diameter"

REBAR_INCLUDE_LAST_BAR

"Include Last Bar"

REBAR_INCLUDE_FIRST_BAR

"Include First Bar"

REBAR_INSTANCE_BEND_DIAMETER

"Bend Diameter"

REBAR_INSTANCE_BAR_DIAMETER

"Bar Diameter"

REBAR_SHAPE_END_HOOK_OFFSET

"End Hook Offset Length"

REBAR_SHAPE_END_HOOK_LENGTH

"End Hook Length"

REBAR_SHAPE_START_HOOK_OFFSET

"Start Hook Offset Length"

REBAR_SHAPE_START_HOOK_LENGTH

"Start Hook Length"

REBAR_ELEM_SCHEDULE_MARK

"Schedule Mark"

REBAR_ELEM_HOOK_STYLE

"Style"

REBAR_SHAPE_HOOK_END_TYPE

"Hook At End"

REBAR_SHAPE_HOOK_START_TYPE

"Hook At Start"

REBAR_SHAPE_HOOK_STYLE

"Style"

REBAR_BAR_ALLOWED_BAR_TYPES

"Allowable Rebar Bar Types"

REBAR_SHAPE_ALLOWED_BAR_TYPES

"Allowable Rebar Bar Types"

REBAR_BAR_MAXIMUM_BEND_RADIUS

"Maximum Bend Radius"

REBAR_BAR_STIRRUP_BEND_DIAMETER

"Stirrup/Tie Bend Diameter"

REBAR_BAR_HOOK_LENGTHS

"Hook Lengths"

REBAR_HOOK_STYLE

"Style"

REBAR_ELEM_LENGTH

"Bar Length"

REBAR_SHAPE

"Shape"

REBAR_ELEMENT_VISIBILITY

"View Visibility States"

REBAR_ELEM_BAR_SPACING

"Spacing"

REBAR_ELEM_QUANTITY_OF_BARS

"Quantity"

REBAR_ELEM_LAYOUT_RULE

"Layout Rule"

REBAR_STANDARD_BEND_DIAMETER

"Standard Bend Diameter"

REBAR_ELEM_HOOK_END_ORIENT

"Hook Orientation At End"

REBAR_ELEM_HOOK_END_TYPE

"Hook At End"

REBAR_ELEM_HOOK_START_ORIENT

"Hook Orientation At Start"

REBAR_ELEM_HOOK_START_TYPE

"Hook At Start"

REBAR_ELEM_TOTAL_LENGTH

"Total Bar Length"

REBAR_HOOK_LINE_LEN_FACTOR

"Extension Multiplier"

REBAR_HOOK_ANGLE

"Hook Angle"

REBAR_BAR_STYLE

"Subcategory"

REBAR_BAR_DIAMETER

"Bar Diameter"

CWP_COPY_ROOF_INSERTS

"Copy openings"

CWP_COPY_FLOOR_INSERTS

"Copy openings/inserts"

CWP_COPY_WALL_INSERTS

"Copy windows/doors/openings"

CWP_LINKED_ROOM_PARAMS

"Parameters"

CWP_LINKED_ROOM_PHASES

"Phases"

CWP_REUSE_GRIDS_SAME_NAME

"Reuse Grids with the same name"

CWP_REUSE_LEVELS_SAME_NAME

"Reuse Levels with the same name"

CWP_SPLIT_COLUMNS_AT_LEVELS

"Split Columns by Levels"

CWP_REUSE_EXISTING_GRIDS

"Reuse matching Grids"

CWP_REUSE_EXISTING_LEVELS

"Reuse matching Levels"

CWP_LEVEL_OFFSET

"Offset Level"

CWP_ADD_LEVEL_SUFFIX

"Add suffix to Level Name"

CWP_ADD_LEVEL_PREFIX

"Add prefix to Level Name"

CWP_ADD_GRID_SUFFIX

"Add suffix to Grid Name"

CWP_ADD_GRID_PREFIX

"Add prefix to Grid Name"

LOAD_USAGE_NAME

"Name"

LOAD_COMBINATION_FACTOR

"Factor"

LOAD_COMBINATION_NAME

"Name"

LOAD_NATURE_NAME

"Name"

LOAD_CASE_CATEGORY

"Category"

LOAD_CASE_NATURE

"Nature"

LOAD_CASE_NUMBER

"Case Number"

LOAD_CASE_NAME

"Name"

LOAD_ATTR_AREA_FORCE_SCALE_FACTOR

"Area force scale"

LOAD_ATTR_LINEAR_FORCE_SCALE_FACTOR

"Linear force scale"

LOAD_ARROW_SEPARATION

"Distance between arrows"

LOAD_ATTR_MOMENT_SCALE_FACTOR

"Moment scale"

LOAD_ATTR_MOMENT_ARROW_LINE

"Moment arrowhead (alternate)"

LOAD_ATTR_MOMENT_ARROW_ARC

"Moment arrowhead"

LOAD_ATTR_FORCE_SCALE_FACTOR

"Force scale"

LOAD_ATTR_FORCE_ARROW_TYPE

"Force arrowhead"

LOAD_DESCRIPTION

"Description"

LOAD_COMMENTS

"Comments"

LOAD_CASE_NATURE_TEXT

"Nature"

LOAD_ALL_NON_0_LOADS

"All non 0 loads"

LOAD_AREA_AREA

"Area"

LOAD_AREA_FORCE_FZ3

"Fz 3"

LOAD_AREA_FORCE_FY3

"Fy 3"

LOAD_AREA_FORCE_FX3

"Fx 3"

LOAD_AREA_FORCE_FZ2

"Fz 2"

LOAD_AREA_FORCE_FY2

"Fy 2"

LOAD_AREA_FORCE_FX2

"Fx 2"

LOAD_AREA_FORCE_FZ1

"Fz 1"

LOAD_AREA_FORCE_FY1

"Fy 1"

LOAD_AREA_FORCE_FX1

"Fx 1"

LOAD_LINEAR_LENGTH

"Length"

LOAD_IS_PROJECTED

"Projected Load"

LOAD_MOMENT_MZ2

"Mz 2"

LOAD_MOMENT_MY2

"My 2"

LOAD_MOMENT_MX2

"Mx 2"

LOAD_MOMENT_MZ1

"Mz 1"

LOAD_MOMENT_MY1

"My 1"

LOAD_MOMENT_MX1

"Mx 1"

LOAD_LINEAR_FORCE_FZ2

"Fz 2"

LOAD_LINEAR_FORCE_FY2

"Fy 2"

LOAD_LINEAR_FORCE_FX2

"Fx 2"

LOAD_LINEAR_FORCE_FZ1

"Fz 1"

LOAD_LINEAR_FORCE_FY1

"Fy 1"

LOAD_LINEAR_FORCE_FX1

"Fx 1"

LOAD_MOMENT_MZ

"Mz"

LOAD_MOMENT_MY

"My"

LOAD_MOMENT_MX

"Mx"

LOAD_FORCE_FZ

"Fz"

LOAD_FORCE_FY

"Fy"

LOAD_FORCE_FX

"Fx"

LOAD_IS_REACTION

"Is Reaction"

LOAD_IS_CREATED_BY_API

"Is created by API"

LOAD_IS_UNIFORM

"Uniform Load"

LOAD_USE_LOCAL_COORDINATE_SYSTEM

"Orient to"

LOAD_CASE_ID

"Load Case"

SPAN_DIR_SYM_PARAM_RIGHT

"Right"

SPAN_DIR_SYM_PARAM_LEFT

"Left"

SPAN_DIR_SYM_PARAM_BOTTOM

"Bottom"

SPAN_DIR_SYM_PARAM_TOP

"Top"

SPAN_DIR_INST_PARAM_ANGLE

"Span Direction"

STRUCTURAL_ASSET_PARAM

"Physical Material Asset"

ANALYTICAL_MODEL_NODES_MARK

"Node Number": Used for nodes

ANALYTICAL_MODEL_FOUNDATIONS_MARK

"Foundation Number": Used for isolated, wall foundations

ANALYTICAL_MODEL_SURFACE_ELEMENTS_MARK

"Surface Number": Used for floors, slabs, walls

ANALYTICAL_MODEL_STICK_ELEMENTS_MARK

"Member Number": Used for beams, braces, columns

FAMILY_ENABLE_CUTTING_IN_VIEWS

"Enable cutting in views"

FAMILY_CAN_HOST_REBAR

"Can host rebar"

CLEAR_COVER

"Rebar Cover"

CLEAR_COVER_BOTTOM

"Rebar Cover - Bottom Face"

CLEAR_COVER_TOP

"Rebar Cover - Top Face"

CLEAR_COVER_OTHER

"Rebar Cover - Other Faces"

CLEAR_COVER_INTERIOR

"Rebar Cover - Interior Face"

CLEAR_COVER_EXTERIOR

"Rebar Cover - Exterior Face"

COVER_TYPE_LENGTH

"Length"

COVER_TYPE_NAME

"Name"

JOIST_SYSTEM_CLEAR_SPACING_PARAM

"Clear Spacing"

JOIST_SYSTEM_FIXED_SPACING_PARAM

"Fixed Spacing"

JOIST_SYSTEM_MAXIMUM_SPACING_PARAM

"Maximum Spacing"

CURVE_EDGE_OFFSET

"Wall offset"

BEAM_SYSTEM_3D_PARAM

"3D"

JOIST_SYSTEM_NEW_BEAM_TYPE_NO_FAM_NAME_PARAM

"Beam Type (No Family Name)"

BEAM_SYSTEM_TAG_INST_PARAM_ANGLE

"Beam System Tag Direction"

BEAM_SYSTEM_TAG_PARAM_RIGHT

"Right"

BEAM_SYSTEM_TAG_PARAM_LEFT

"Left"

JOIST_SYSTEM_NUM_BEAMS_SAME_TYPE

"Num. of Beams With Same Type"

BEAM_H_JUSTIFICATION

"Lateral Justification"

BEAM_V_JUSTIFICATION

"z-Direction Justification"

CURVE_SUPPORT_OFFSET

"Wall offset"

JOIST_SYSTEM_NEW_BEAM_TYPE_PARAM

"Beam Type"

JOIST_SYSTEM_LAYOUT_RULE_PARAM

"Layout Rule"

JOIST_SYSTEM_JUSTIFICATION_PARAM

"Justification"

JOIST_SYSTEM_SPACING_PARAM

"Centerline Spacing"

JOIST_SYSTEM_NUMBER_OF_LINES_PARAM

"Number of Lines"

RBS_DUCT_FLOW_PARAM

"Flow"

CURTAINGRID_BELT_RATIO_V

"Belt Measurement"

CURTAINGRID_BELT_RATIO_U

"Belt Measurement"

CURTAINGRID_USE_CURVE_DIST_V

"Use Curve Distance"

CURTAINGRID_USE_CURVE_DIST_U

"Use Curve Distance"

CURTAINGRID_ADJUST_BORDER_V

"Adjust for Mullion Size"

CURTAINGRID_ADJUST_BORDER_U

"Adjust for Mullion Size"

CURTAINGRID_BELT_V

"Belt Measurement"

CURTAINGRID_BELT_U

"Belt Measurement"

CURTAINGRID_ORIGIN_V

"Offset"

CURTAINGRID_ORIGIN_U

"Offset"

CURTAINGRID_ANGLE_V

"Grid Rotation"

CURTAINGRID_ANGLE_U

"Grid Rotation"

SPACING_NUM_DIVISIONS_V

"Number"

SPACING_NUM_DIVISIONS_U

"Number"

SPACING_JUSTIFICATION_V

"Justification"

SPACING_JUSTIFICATION_U

"Justification"

SPACING_LENGTH_V

"Distance"

SPACING_LENGTH_U

"Distance"

SPACING_LAYOUT_V

"Layout"

SPACING_LAYOUT_U

"Layout"

CURTAINGRID_BELT_RATIO_2

"Measurement Line"

CURTAINGRID_BELT_RATIO_1

"Measurement Line"

CURTAIN_VERSION_PARAM

"Curtain version"

PADDING_LENGTH

"Padding"

ELEM_ARRAY_ALWAYS_VERTICAL

"Always vertical"

ELEM_ARRAY_ANCHORS_VISIBLE

"Anchor Points Visible"

CURTAINGRID_USE_CURVE_DIST

"Use Curve Distance"

SPACING_JUSTIFICATION

"Justification"

SPACING_NUM_DIVISIONS

"Number"

SPACING_LENGTH

"Spacing"

SPACING_LAYOUT

"Layout"

CURTAINGRID_USE_CURVE_DIST_2

"Use Curve Distance"

CURTAINGRID_USE_CURVE_DIST_1

"Use Curve Distance"

CURTAINGRID_ADJUST_BORDER_2

"Adjust for Mullion Size"

CURTAINGRID_ADJUST_BORDER_1

"Adjust for Mullion Size"

CURTAINGRID_BELT_2

"Measurement Line"

CURTAINGRID_BELT_1

"Measurement Line"

CURTAINGRID_ORIGIN_2

"Offset"

CURTAINGRID_ORIGIN_1

"Offset"

CURTAINGRID_ANGLE_2

"Angle"

CURTAINGRID_ANGLE_1

"Angle"

SPACING_NUM_DIVISIONS_2

"Number"

SPACING_NUM_DIVISIONS_1

"Number"

SPACING_JUSTIFICATION_2

"Justification"

SPACING_JUSTIFICATION_1

"Justification"

SPACING_LENGTH_2

"Spacing"

SPACING_LENGTH_1

"Spacing"

SPACING_LAYOUT_2

"Layout"

SPACING_LAYOUT_1

"Layout"

CURTAINGRID_USE_CURVE_DIST_HORIZ

"Use Curve Distance"

CURTAINGRID_USE_CURVE_DIST_VERT

"Use Curve Distance"

CURTAINGRID_ADJUST_BORDER_HORIZ

"Adjust for Mullion Size"

CURTAINGRID_ADJUST_BORDER_VERT

"Adjust for Mullion Size"

CURTAINGRID_BELT_HORIZ

"Measurement Line"

CURTAINGRID_BELT_VERT

"Measurement Line"

CURTAINGRID_ORIGIN_HORIZ

"Offset"

CURTAINGRID_ORIGIN_VERT

"Offset"

CURTAINGRID_ANGLE_HORIZ

"Angle"

CURTAINGRID_ANGLE_VERT

"Angle"

GRIDLINE_SPEC_STATUS

"Type Association"

SPACING_NUM_DIVISIONS_HORIZ

"Number"

SPACING_NUM_DIVISIONS_VERT

"Number"

SPACING_JUSTIFICATION_HORIZ

"Justification"

SPACING_JUSTIFICATION_VERT

"Justification"

SPACING_LENGTH_HORIZ

"Spacing"

SPACING_LENGTH_VERT

"Spacing"

SPACING_LAYOUT_HORIZ

"Layout"

SPACING_LAYOUT_VERT

"Layout"

DESIGN_OPTION_ID

"Design Option"

DESIGN_OPTION_PARAM

"Design Option"

PLAN_REGION_VIEW_RANGE

"View Range"

GUIDE_GRID_NAME_PARAM

"Name"

GUIDE_GRID_SPACING_PARAM

"Guide Spacing"

SKETCH_GRID_SPACING_PARAM

"Work Plane Grid Spacing"

HOSTFIN_PARAM_VOLUME_COMPUTED

"Volume"

HOSTFIN_PARAM_AREA_COMPUTED

"Area"

HOSTFIN_PARAM_MATERIAL

"Material"

HOSTFIN_PARAM_THICKNESS

"Thickness"

HOSTFIN_PARAM_OFFSET

"Offset"

JOIN_STRENGTH_ORDER

"Abstract Join Strength Order"

FAMILY_HOSTING_BEHAVIOR

"Host"

FAMILY_IS_ELEVATION_MARK_BODY

"Elevation Mark Use"

FAMILY_USE_PRECUT_SHAPE

"Show family pre-cut in plan views"

WALL_SWEEP_DEFAULT_SETBACK_PARAM

"Default Setback"

WALL_SWEEP_CUTS_WALL_PARAM

"Cuts Wall"

WALL_SWEEP_CUT_BY_INSERTS_PARAM

"Cut by Inserts"

SLAB_EDGE_PROFILE_PARAM

"Profile"

GUTTER_PROFILE_PARAM

"Profile"

REVEAL_PROFILE_PARAM

"Profile"

FAMILY_SHARED

"Shared"

FAMILY_WORK_PLANE_BASED

"Work Plane-Based"

FAMILY_AUTOJOIN

"Automatically joins geometry to walls"

FAMILY_IS_PARAMETRIC

"Is parametric"

FAMILY_KEEP_TEXT_READABLE

"Keep text readable"

WALL_BOTTOM_EXTENSION_DIST_PARAM

"Base Extension Distance"

WALL_TOP_EXTENSION_DIST_PARAM

"Top Extension Distance"

SWEEP_BASE_VERT_OFFSET

"Vertical Profile Offset"

SWEEP_BASE_OFFSET

"Horizontal Profile Offset"

SLAB_EDGE_MATERIAL_PARAM

"Material"

GUTTER_MATERIAL_PARAM

"Material"

FASCIA_MATERIAL_PARAM

"Material"

SWEEP_BASE_FLOOR_SUBCATEGORY_ID

"Subcategory of Floors"

SWEEP_BASE_ROOF_SUBCATEGORY_ID

"Subcategory of Roofs"

FASCIA_PROFILE_PARAM

"Profile"

DECAL_SUBCATEGORY_ID

"Subcategory"

DECAL_HEIGHT

"Height"

DECAL_WIDTH

"Width"

DECAL_LOCK_PROPORTIONS

"Lock Proportions"

DECAL_ATTRIBUTES

"Decal Attributes"

FAMILY_ALLOW_CUT_WITH_VOIDS

"Cut with Voids When Loaded"

FAMILY_KEY_EXT_PARAM

"Filter Parameter"

WALL_SWEEP_WALL_SUBCATEGORY_ID

"Subcategory of Walls"

FAMILY_ALWAYS_VERTICAL

"Always vertical"

FAMILY_ROTATE_WITH_COMPONENT

"Rotate with component"

HOST_VOLUME_COMPUTED

"Volume"

HOST_AREA_COMPUTED

"Area"

WALL_SWEEP_WALL_OFFSET_PARAM

"Offset From Wall"

WALL_SWEEP_OFFSET_PARAM

"Offset From Level"

WALL_SWEEP_LEVEL_PARAM

"Level"

WALL_SWEEP_PROFILE_PARAM

"Profile"

AREA_SCHEME_NAME

"Name"

AREA_SCHEME_ID

"Area Scheme Id"

AREA_TYPE_TEXT

"Area Type"

AREA_TYPE

"Area Type"

CONTOUR_LABELS_RELATIVE_BASE

"Relative Base"

CONTOUR_LABELS_ELEV_BASE_TYPE

"Elevation Base"

PROPERTY_SEGMENT_SUBCATEGORY_ID

"Subcategory"

PROPERTY_SEGMENT_L_R

"L/R"

PROPERTY_SEGMENT_RADIUS

"Radius"

PROPERTY_SEGMENT_E_W

"E/W"

PROPERTY_SEGMENT_BEARING

"Bearing"

PROPERTY_SEGMENT_N_S

"N/S"

PROPERTY_SEGMENT_DISTANCE

"Distance"

PROPERTY_LENGTH_UNITS

"Units Format"

PROPERTY_AREA_UNITS

"Area Units, Format"

VOLUME_NET

"Net cut/fill"

PROJECTED_SURFACE_AREA

"Projected Area"

CONTOUR_LABELS_LINEAR_UNITS

"Units Format"

CONTOUR_LABELS_PRIMARY_ONLY

"Label primary contours only"

PROPERTY_SUBCATEGORY_ID

"Subcategory"

PROPERTY_AREA_OPEN

"Area"

VOLUME_FILL

"Fill"

VOLUME_CUT

"Cut"

SURFACE_PERIMETER

"Perimeter"

SURFACE_AREA

"Surface Area"

PROPERTY_AREA

"Area"

BUILDINGPAD_HEIGHTABOVELEVEL_PARAM

"Height Offset From Level"

BUILDINGPAD_THICKNESS

"Thickness"

BOUNDARY_RADIUS

"Radius"

CONTOUR_SUBCATEGORY_ID

"Subcategory"

BOUNDARY_BEARING

"Bearing"

BOUNDARY_DISTANCE

"Distance"

CONTOUR_ELEVATION_STEP

"Increment"

CONTOUR_ELEVATION

"Elevation"

POINT_ELEVATION

"Elevation"

VOLUME_OF_INTEREST_NAME

"Name"

VOLUME_OF_INTEREST_VIEWS_VISIBLE

"Views Visible"

VIEWER_VOLUME_OF_INTEREST_CROP

"Scope Box"

DATUM_VOLUME_OF_INTEREST

"Scope Box"

ORIENT_BY_VIEW

"Rotate With Section"

ROOM_PHASE

"Phase"

ROOM_PHASE_ID

"Phase Id"

PHASE_SEQUENCE_NUMBER

"Sequence Number"

PHASE_NAME

"Name"

VIEW_FAMILY

"Family"

VIEW_TYPE

"Family and Type"

VIEW_PHASE_FILTER

"Phase Filter"

VIEW_PHASE

"Phase"

PHASE_DEMOLISHED

"Phase Demolished"

PHASE_CREATED

"Phase Created"

MASS_DATA_SLAB

"Slab"

ENERGY_ANALYSIS_HVAC_SYSTEM

"HVAC System"

ENERGY_ANALYSIS_OUTDOOR_AIR_INFORMATION_PARAM

"Outdoor Air Information"

ENERGY_ANALYSIS_MASSZONE_USEENERGYDATASETTINGS

"Use Energy Data"

ENERGY_ANALYSIS_MASSZONE_DIVIDEPERIMETER

"Divide Perimeter Zones"

ENERGY_ANALYSIS_MASSZONE_COREOFFSET

"Core Offset"

ENERGY_ANALYSIS_SHADE_DEPTH

"Shade Depth"

ENERGY_ANALYSIS_CONCEPTUAL_CONSTRUCTION

"Conceptual Constructions"

ENERGY_ANALYSIS_SKYLIGHT_WIDTH

"Skylight Width & Depth"

ENERGY_ANALYSIS_PERCENTAGE_SKYLIGHTS

"Target Percentage Skylights"

ENERGY_ANALYSIS_GLAZING_IS_SHADED

"Glazing is Shaded"

ENERGY_ANALYSIS_SILL_HEIGHT

"Target Sill Height"

ENERGY_ANALYSIS_PERCENTAGE_GLAZING

"Target Percentage Glazing"

ENERGY_ANALYSIS_MASS_ZONING

"Mass Zoning"

ENERGY_ANALYSIS_BUILDING_OPERATING_SCHEDULE

"Building Operating Schedule"

ENERGY_ANALYSIS_CREATE_ANALYTICAL_MODEL

"Create Energy Model"

MASS_DATA_SURFACE_DATA_SOURCE

"Values"

MASS_DATA_SKYLIGHT_WIDTH

"Skylight Width & Depth"

MASS_DATA_PERCENTAGE_SKYLIGHTS

"Target Percentage Skylights"

MASS_DATA_SILL_HEIGHT

"Target Sill Height"

MASS_DATA_SHADE_DEPTH

"Shade Depth"

MASS_DATA_GLAZING_IS_SHADED

"Glazing is Shaded"

MASS_DATA_PERCENTAGE_GLAZING

"Target Percentage Glazing"

MASS_DATA_UNDERGROUND

"Underground"

MASS_DATA_MASS_OPENING_AREA

"Mass Opening Area"

MASS_DATA_MASS_SKYLIGHT_AREA

"Mass Skylight Area"

MASS_DATA_MASS_WINDOW_AREA

"Mass Window Area"

MASS_DATA_MASS_ROOF_AREA

"Mass Roof Area"

MASS_DATA_MASS_INTERIOR_WALL_AREA

"Mass Interior Wall Area"

MASS_DATA_MASS_EXTERIOR_WALL_AREA

"Mass Exterior Wall Area"

MASS_DATA_SUBCATEGORY

"Subcategory"

MASS_DATA_CONCEPTUAL_CONSTRUCTION

"Conceptual Constructions"

MASS_ZONE_CONDITION_TYPE_PARAM

"Condition Type"

MASS_ZONE_SPACE_TYPE_PARAM

"Space Type"

MASS_ZONE_FLOOR_AREA

"Mass Floor Area"

CONCEPTUAL_CONSTRUCTION_MATERIAL

"Graphical Appearance"

MASS_SURFACEDATA_MATERIAL

"Graphical Appearance"

MASS_ZONE_MATERIAL

"Graphical Appearance"

MASS_ZONE_VOLUME

"Mass Zone Volume"

LEVEL_DATA_MASS_TYPE_DESCRIPTION

"Mass: Description"

LEVEL_DATA_MASS_INSTANCE_COMMENTS

"Mass: Comments"

LEVEL_DATA_MASS_TYPE_COMMENTS

"Mass: Type Comments"

LEVEL_DATA_MASS_FAMILY_AND_TYPE_PARAM

"Mass: Family and Type"

LEVEL_DATA_MASS_FAMILY_PARAM

"Mass: Family"

LEVEL_DATA_SPACE_USAGE

"Usage"

LEVEL_DATA_OWNING_LEVEL

"Level"

LEVEL_DATA_MASS_TYPE_PARAM

"Mass: Type"

LEVEL_DATA_VOLUME

"Floor Volume"

LEVEL_DATA_SURFACE_AREA

"Exterior Surface Area"

LEVEL_DATA_FLOOR_AREA

"Floor Area"

LEVEL_DATA_FLOOR_PERIMETER

"Floor Perimeter"

MASS_GROSS_VOLUME

"Gross Volume"

MASS_GROSS_SURFACE_AREA

"Gross Surface Area"

MASS_FLOOR_AREA_LEVELS

"Mass Floors"

MASS_GROSS_AREA

"Gross Floor Area"

MASSING_INTEGRATION_LEVEL

"Constrain to Massing"

PROJECT_REVISION_REVISION_ISSUED

"Issued"

PROJECT_REVISION_ENUMERATION

"Numbering"

PROJECT_REVISION_REVISION_ISSUED_BY

"Issued by"

PROJECT_REVISION_REVISION_ISSUED_TO

"Issued to"

PROJECT_REVISION_REVISION_DATE

"Revision Date"

PROJECT_REVISION_REVISION_DESCRIPTION

"Revision Description"

PROJECT_REVISION_REVISION_NUM

"Revision Number"

PROJECT_REVISION_SEQUENCE_NUM

"Revision Sequence"

REVISION_CLOUD_REVISION_ISSUED_BY

"Issued by"

REVISION_CLOUD_REVISION_ISSUED_TO

"Issued to"

REVISION_CLOUD_REVISION_DATE

"Revision Date"

REVISION_CLOUD_REVISION_DESCRIPTION

"Revision Description"

REVISION_CLOUD_REVISION_NUM

"Revision Number"

REVISION_CLOUD_REVISION

"Revision"

HELIX_PITCH

"Pitch"

HELIX_LENGTH

"Helix Total Length"

REPEATING_DETAIL_ROTATION

"Detail Rotation"

REPEATING_DETAIL_INSIDE

"Inside"

REPEATING_DETAIL_ELEMENT

"Detail"

REPEATING_DETAIL_LAYOUT

"Layout"

REPEATING_DETAIL_SPACING

"Spacing"

REPEATING_DETAIL_NUMBER

"Number"

INSULATION_SCALE

"Insulation Bulge to Width Ratio (1/x)"

INSULATION_WIDTH

"Insulation Width"

VIEW_PARTS_VISIBILITY

"Parts Visibility"

VIEW_DETAIL_LEVEL

"Detail Level"

PLUMBING_FIXTURES_VENT_CONNECTION

"Vent Connection"

PLUMBING_FIXTURES_WASTE_CONNECTION

"Waste Connection"

PLUMBING_FIXTURES_CW_CONNECTION

"CW Connection"

PLUMBING_FIXTURES_HW_CONNECTION

"HW Connection"

PLUMBING_FIXTURES_TRAP

"Trap"

PLUMBING_FIXTURES_DRAIN

"Drain"

PLUMBING_FIXTURES_SUPPLY_PIPE

"Supply Pipe"

PLUMBING_FIXTURES_SUPPLY_FITTING

"Supply Fitting"

LIGHTING_FIXTURE_LIGHT_EMITTER

"Light Emitter"

FBX_LIGHT_SPOT_FIELD_ANGLE

"Spot Field Angle"

FBX_LIGHT_SPOT_BEAM_ANGLE

"Spot Beam Angle"

FBX_LIGHT_SPOT_TILT_ANGLE

"Tilt Angle"

FBX_LIGHT_LIMUNOUS_FLUX

"Luminous Flux"

LIGHTING_FIXTURE_LAMP

"Lamp"

LIGHTING_FIXTURE_WATTAGE

"Wattage Comments"

ELECTICAL_EQUIP_VOLTAGE

"Voltage"

ELECTICAL_EQUIP_WATTAGE

"Wattage"

CURTAIN_WALL_SYSPANEL_THICKNESS

"Thickness"

CURTAIN_WALL_PANEL_HOST_ID

"Host Id"

CURTAIN_WALL_SYSPANEL_OFFSET

"Offset"

CURTAIN_WALL_PANELS_WIDTH

"Width"

CURTAIN_WALL_PANELS_HEIGHT

"Height"

ALL_MODEL_MODEL

"Model"

ALL_MODEL_MANUFACTURER

"Manufacturer"

ALL_MODEL_INSTANCE_COMMENTS

"Comments"

ALL_MODEL_TYPE_COMMENTS

"Type Comments"

ALL_MODEL_URL

"URL"

ALL_MODEL_DESCRIPTION

"Description"

RGB_B_PARAM

"Blue value for RGB color spec. (for Use with XAML Data Template example)"

RGB_G_PARAM

"Green value for RGB color spec. (for Use with XAML Data Template example)"

RGB_R_PARAM

"Red value for RGB color spec. (for Use with XAML Data Template example)"

ELLIPSE_Y_PARAM

"Y-Radius Value for Ellipse (for Use with XAML Data Template example)"

ELLIPSE_X_PARAM

"X-Radius Value for Ellipse (for Use with XAML Data Template example)"

GROUPNAME_PARAM

"Group Name for Ribbon Combo Items (for Use with XAML)"

ICON_INDEX_PARAM

"Index Into Image File Name Array (for Use with XAML)"

SHOW_ICON_PARAM

"Flag to display icon in Ribbon Combo Item"

DEBUGTAB_DATABOUNDCONTROLSDEMO_DOUBLE

"Double"

DEBUGTAB_DATABOUNDCONTROLSDEMO_INTEGER

"Integer"

DEBUGTAB_DATABOUNDCONTROLSDEMO_BOOLEAN

"Boolean"

DEBUGTAB_DATABOUNDCONTROLSDEMO_ENUM

"Options"

CASEWORK_DEPTH

"Depth"

GENERIC_DEPTH

"Depth"

ANALYTICAL_LINK_RELEASE_ROTATION_Z

"Z Rotation"

ANALYTICAL_LINK_RELEASE_ROTATION_Y

"Y Rotation"

ANALYTICAL_LINK_RELEASE_ROTATION_X

"X Rotation"

ANALYTICAL_LINK_RELEASE_TRANSLATION_Z

"Z Translation"

ANALYTICAL_LINK_RELEASE_TRANSLATION_Y

"Y Translation"

ANALYTICAL_LINK_RELEASE_TRANSLATION_X

"X Translation"

ANALYTICAL_MODEL_PHYSICAL_TYPE

"Family Type": the Family Type of the physical element associated with the Analytical Model

ANALYTICAL_MODEL_SKETCH_PROJECTION

"In-Plane Projection"

ANALYTICAL_MODEL_SKETCH_ALIGNMENT_METHOD

"Alignment Method"

ANALYTICAL_MODEL_WALL_BASE_PROJECTION

"Base In-Plane Projection"

ANALYTICAL_MODEL_WALL_TOP_PROJECTION

"Top In-Plane Projection"

ANALYTICAL_MODEL_WALL_PROJECTION

"Projection"

ANALYTICAL_MODEL_WALL_ALIGNMENT_METHOD

"Alignment Method"

ANALYTICAL_MODEL_FLOOR_PROJECTION

"Projection"

ANALYTICAL_MODEL_FLOOR_ALIGNMENT_METHOD

"Alignment Method"

ANALYTICAL_MODEL_BASE_EXTENSION

"Base z-Direction Projection"

ANALYTICAL_MODEL_BASE_EXTENSION_METHOD

"Base Extension Method"

ANALYTICAL_MODEL_TOP_EXTENSION

"Top z-Direction Projection"

ANALYTICAL_MODEL_TOP_EXTENSION_METHOD

"Top Extension Method"

ANALYTICAL_MODEL_TOP_Y_PROJECTION

"Top y-Direction Projection"

ANALYTICAL_MODEL_TOP_X_PROJECTION

"Top x-Direction Projection"

ANALYTICAL_MODEL_TOP_ALIGNMENT_METHOD

"Top Alignment Method"

ANALYTICAL_MODEL_BASE_Y_PROJECTION

"Base y-Direction Projection"

ANALYTICAL_MODEL_BASE_X_PROJECTION

"Base x-Direction Projection"

ANALYTICAL_MODEL_BASE_ALIGNMENT_METHOD

"Base Alignment Method"

ANALYTICAL_MODEL_END_Z_PROJECTION

"End z-Direction Projection"

ANALYTICAL_MODEL_END_Y_PROJECTION

"End y-Direction Projection"

ANALYTICAL_MODEL_END_ALIGNMENT_METHOD

"End Alignment Method"

ANALYTICAL_MODEL_START_Z_PROJECTION

"Start z-Direction Projection"

ANALYTICAL_MODEL_START_Y_PROJECTION

"Start y-Direction Projection"

ANALYTICAL_MODEL_START_ALIGNMENT_METHOD

"Start Alignment Method"

ELEMENT_LOCKED_PARAM

"Locked"

STAIRS_RAILING_BALUSTER_IS_POST

"Post"

STAIRS_RAILING_CONNECTION

"Rail Connections"

STAIRS_RAILING_ANGLED_CONNECTION

"Angled Joins"

STAIRS_RAILING_TANGENT_CONNECTION

"Tangent Joins"

STAIRS_RAILING_HEIGHT_SHIFT_VAL

"Landing Height Adjustment"

STAIRS_RAILING_HEIGHT_SHIFT_TYPE

"Use Landing Height Adjustment"

STAIRS_RAILING_RAIL_NAME

"Name"

STAIRS_RAILING_BALUSTER_PLACEMENT

"Baluster Placement"

STAIRS_RAILING_BALUSTER_SLOPE_ANGLE

"Slope Angle"

STAIRS_RAILING_BALUSTER_BOTTOM_ANGLE

"Bottom Cut Angle"

STAIRS_RAILING_BALUSTER_TOP_ANGLE

"Top Cut Angle"

STAIRS_RAILING_BALUSTER_HEIGHT

"Baluster Height"

STAIRS_RAILING_HEIGHT_OFFSET

"Base Offset"

STAIRS_RAILING_BASE_LEVEL_PARAM

"Base Level"

STAIRS_RAILING_BALUSTER_OFFSET

"Baluster Offset"

STAIRS_RAILING_BALUSTER_FAMILY

"Baluster Family"

STAIRS_RAILING_RAIL_OFFSET

"Rail Offset"

STAIRS_RAILING_RAIL_HEIGHT

"Rail Height"

STAIRS_RAILING_RAIL_STRUCTURE

"Rail Structure (Non-Continuous)"

STAIRS_RAILING_SHAPE

"Rail Shape"

STAIRS_RAILING_BALUSTER_LENGTH

"Baluster Length"

STAIRS_RAILING_BALUSTER_WIDTH

"Baluster Width"

STAIRS_RAILING_BALUSTERS_PER_TREAD

"Balusters Per Tread (Stair Railing Only)"

STAIRS_RAILING_BALUSTER_SPACING

"Baluster Separation"

STAIRS_RAILING_BALUSTER_SPACING_TYPE

"Baluster Spacing Type (Stair Railing Only)"

STAIRS_RAILING_BALUSTER_SHAPE

"Baluster Shape"

STAIRS_RAILING_THICKNESS

"Railing Thickness"

STAIRS_RAILING_WIDTH

"Railing Width"

STAIRS_RAILING_HEIGHT

"Railing Height"

RAMP_ATTR_TEXT_SIZE

"Text Size"

RAMP_ATTR_TEXT_FONT

"Text Font"

RAMP_ATTR_MATERIAL

"Ramp Material"

RAMP_ATTR_RIGHT_BALUSTER_ATTACH_PT

"Right Baluster Location"

RAMP_ATTR_LEFT_BALUSTER_ATTACH_PT

"Left Baluster Location"

RAMP_ATTR_SHAPE

"Shape"

RAMP_ATTR_THICKNESS

"Thickness"

RAMP_MAX_RUN_LENGTH

"Maximum Incline Length"

RAMP_ATTR_MIN_INV_SLOPE

"Ramp Max Slope (1/x)"

ASSIGN_TEMPLATE_ON_VIEW_CREATION

"New views are dependent on template"

DEFAULT_VIEW_TEMPLATE

"View Template applied to new views"

PLAN_VIEW_VIEW_DIR

"View Direction"

POCHE_MAT_ID

"Coarse Poche Material"

ELEVATN_TAG

"Elevation Tag"

CALLOUT_TAG

"Callout Tag"

SECTION_TAG

"Section Tag"

CALLOUT_SYNCRONIZE_BOUND_OFFSET_FAR

"Far Clip Settings"

CALLOUT_CORNER_SHEET_RADIUS

"Corner Radius"

CALLOUT_ATTR_HEAD_TAG

"Callout Head"

GRID_BUBBLE_END_2

"Plan View Symbols End 2 (Default)"

GRID_BUBBLE_END_1

"Plan View Symbols End 1 (Default)"

DATUM_BUBBLE_LOCATION_IN_ELEV

"Non-Plan View Symbols (Default)"

DATUM_BUBBLE_END_1

"Symbol at End 1 Default"

DATUM_BUBBLE_END_2

"Symbol at End 2 Default"

DATUM_TEXT

"Name"

ELLIPSE_FOCUS_MRK_VISIBLE

"Focus Marks Visible"

ARC_CURVE_CNTR_MRK_VISIBLE

"Center Mark Visible"

ARC_WALL_CNTR_MRK_VISIBLE

"Center Mark Visible"

REF_TABLE_PARAM_NAME

"Parameter Name"

REF_TABLE_ELEM_NAME

"Key Name"

RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_INST_PARAM

"Appearance"

RBS_PANEL_SCHEDULE_SHEET_APPEARANCE_PARAM

"Appearance On Sheet"

SCHEDULE_EMBEDDED_PARAM

"Embedded Schedule"

SCHEDULE_SHEET_APPEARANCE_PARAM

"Appearance"

SCHEDULE_FORMAT_PARAM

"Formatting"

SCHEDULE_GROUP_PARAM

"Sorting/Grouping"

SCHEDULE_FILTER_PARAM

"Filter"

SCHEDULE_FIELDS_PARAM

"Fields"

RASTER_HORIZONTAL_SCALE

"Horizontal Scale"

RASTER_VERTICAL_SCALE

"Vertical Scale"

RASTER_SYMBOL_HEIGHT

"Height"

RASTER_SYMBOL_WIDTH

"Width"

RASTER_SYMBOL_RESOLUTION

"Resolution (dpi)"

RASTER_SYMBOL_FILENAME

"Loaded from file"

RASTER_SYMBOL_VIEWNAME

"View Name"

RASTER_SYMBOL_PIXELHEIGHT

"Height (pixels)"

RASTER_SYMBOL_PIXELWIDTH

"Width (pixels)"

RASTER_MAINTAIN_ASPECT_RATIO

"Lock Proportions"

RASTER_SHEETHEIGHT

"Height"

RASTER_SHEETWIDTH

"Width"

IMPORT_ADT_ENTITY_ROLL

"Roll"

IMPORT_ADT_ENTITY_THICKNESS

"Thickness"

IMPORT_ADT_ENTITY_LENGTH

"Length"

IMPORT_ADT_ENTITY_WIDTH

"Width"

IMPORT_ADT_ENTITY_HEIGHT

"Height"

IMPORT_ADT_COMPONENTS_DESC

"Component Description"

IMPORT_ADT_ENTITY_STYLE

"Style Name"

IMPORT_ADT_ENTITY_STRUCT_TYPE

"Structural Type Name"

IMPORT_ADT_ENTITY_TYPE

"Type Name"

RVT_LINK_PHASE_MAP

"Phase Mapping"

RVT_LINK_REFERENCE_TYPE

"Reference Type"

RVT_LINK_FILE_NAME_WITHOUT_EXT

"File Name"

RVT_LEVEL_OFFSET

"Map Levels..."

RVT_HOST_LEVEL

"Map Levels..."

RVT_SOURCE_LEVEL

"Map Levels..."

RVT_LINK_INSTANCE_NAME

"Name"

GEO_LOCATION

"Shared Site"

IMPORT_INSTANCE_SCALE

"Instance Scale"

IMPORT_BACKGROUND

"Draw Layer"

IMPORT_DISPLAY_UNITS

"Import Units"

IMPORT_BASE_LEVEL_OFFSET

"Base Offset"

IMPORT_BASE_LEVEL

"Base Level"

IMPORT_SCALE

"Scale Factor"

IMPORT_SYMBOL_NAME

"Name"

ELEV_SYMBOL_ID

"Elevation Mark"

ELEV_REFERENCE_LABEL_POS

"Reference Label Position"

ELEV_ASSOC_DATUM

"Associated Datum"

ELEV_VIEW_NAME_POS

"View Name Position"

ELEV_SHOW_VIEW_NAME

"Show View Name"

ELEV_TEXT_POS

"Text Position"

ELEV_ARROW_FILLED

"Filled"

ELEV_ARROW_ANGLE

"Arrow Angle"

ELEV_SHAPE

"Shape"

ELEV_WIDTH

"Width"

COLOR_FILL_SWATCH_HEIGHT_PARAM

"Swatch Height"

COLOR_FILL_SWATCH_WIDTH_PARAM

"Swatch Width"

COLOR_FILL_FILTERED_PARAM

"Values Displayed"

DETAIL_ARRAY_GROUP_ELEMENT_INST

"Component to Array"

DETAIL_ARRAY_GROUP_ELEMENT

"Component to Array"

SPACING_ORIENTATION_STEP_ALL

"Component Facing"

SPACING_INITIAL_ROTATION

"Initial Rotation"

SPACING_ORIENTATION_STEP2

"Complex Path Rule"

SPACING_ORIENTATION_STEP1_INST

"Component Facing"

SHEET_GUIDE_GRID

"Guide Grid"

SHEET_CURRENT_REVISION_ISSUED

"Current Revision Issued"

SHEET_CURRENT_REVISION_ISSUED_BY

"Current Revision Issued By"

SHEET_CURRENT_REVISION_ISSUED_TO

"Current Revision Issued To"

SHEET_CURRENT_REVISION_DATE

"Current Revision Date"

SHEET_CURRENT_REVISION_DESCRIPTION

"Current Revision Description"

SHEET_REVISIONS_ON_SHEET

"Revisions on Sheet"

SHEET_CURRENT_REVISION

"Current Revision"

SHEET_HEIGHT

"Sheet Height"

SHEET_WIDTH

"Sheet Width"

SHEET_FILE_PATH

"File Path"

SHEET_APPROVED_BY

"Approved By"

SHEET_DESIGNED_BY

"Designed By"

SHEET_SCHEDULED

"Appears In Sheet List"

SHEET_CHECKED_BY

"Checked By"

SHEET_DRAWN_BY

"Drawn By"

SHEET_DATE

"Date/Time Stamp"

SHEET_SCALE

"Scale"

SHEET_NUMBER

"Sheet Number"

SHEET_NAME

"Sheet Name"

MODEL_ARRAY_GROUP_ELEMENT_INST

"Component to Array"

SPACING_APPEND

"Append Position"

SPACING_ORIENTATION_STEP1

"Component Facing"

MODEL_ARRAY_GROUP_ELEMENT

"Component to Array"

AUTO_JOIN_CONDITION_WALL

"Join Condition"

AUTO_MULLION_BORDER2_HORIZ

"Border 2 Type"

AUTO_MULLION_BORDER1_HORIZ

"Border 1 Type"

AUTO_MULLION_BORDER2_VERT

"Border 2 Type"

AUTO_MULLION_BORDER1_VERT

"Border 1 Type"

AUTO_MULLION_INTERIOR_HORIZ

"Interior Type"

AUTO_MULLION_INTERIOR_VERT

"Interior Type"

AUTO_PANEL_WALL

"Curtain Panel"

AUTO_JOIN_CONDITION

"Join Condition"

AUTO_PANEL

"Curtain Panel"

AUTO_MULLION_BORDER2_GRID2

"Border 2 Type"

AUTO_MULLION_BORDER1_GRID2

"Border 1 Type"

AUTO_MULLION_BORDER2_GRID1

"Border 2 Type"

AUTO_MULLION_BORDER1_GRID1

"Border 1 Type"

AUTO_MULLION_INTERIOR_GRID2

"Interior Type"

AUTO_MULLION_INTERIOR_GRID1

"Interior Type"

CURTAIN_GRID_BASE_ORIENTATION

"Grid Base Orientation"

MULLION_ANGLE

"Angle"

MULLION_POSITION

"Position"

MULLION_PROFILE

"Profile"

TRAP_MULL_WIDTH

"Center Width"

MULLION_DEPTH2

"Depth 2"

MULLION_DEPTH1

"Depth 1"

MULLION_DEPTH

"Depth"

LV_MULLION_LEG2

"Leg 2"

LV_MULLION_LEG1

"Leg 1"

MULLION_CORNER_TYPE

"Corner Mullion"

MULLION_FAM_TYPE

"Mullion Family General Shape"

MULLION_OFFSET

"Offset"

CIRC_MULLION_RADIUS

"Radius"

CUST_MULLION_THICK

"Thickness"

CUST_MULLION_WIDTH2

"Width on side 2"

CUST_MULLION_WIDTH1

"Width on side 1"

RECT_MULLION_THICK

"Thickness"

RECT_MULLION_WIDTH2

"Width on side 2"

RECT_MULLION_WIDTH1

"Width on side 1"

STAIRS_INST_ALWAYS_UP

"Show Up arrow in all views"

STAIRS_ATTR_TRIM_TOP

"Trim Stringers at Top"

STAIRS_INST_DOWN_ARROW_ON

"Down arrow"

STAIRS_INST_DOWN_LABEL_TEXT

"Down text"

STAIRS_INST_DOWN_LABEL_ON

"Down label"

STAIRS_INST_UP_ARROW_ON

"Up arrow"

STAIRS_INST_UP_LABEL_TEXT

"Up text"

STAIRS_INST_UP_LABEL_ON

"Up label"

STAIRS_ATTR_TEXT_SIZE

"Text Size"

STAIRS_ATTR_TEXT_FONT

"Text Font"

STAIRS_ATTR_BODY_MATERIAL

"Monolithic Material"

STAIRS_ATTR_LANDING_CARRIAGE

"Landing Carriage Height"

STAIRS_ATTR_LANDINGS_OVERLAPPING

"Landing Overlap"

STAIRS_ATTR_RIGHT_SIDE_STRINGER

"Right Stringer"

STAIRS_ATTR_LEFT_SIDE_STRINGER

"Left Stringer"

STAIRS_ATTR_NOSING_PLACEMENT

"Apply Nosing Profile"

STAIRS_ATTR_RISER_TREAD_CONNECT

"Riser to Tread Connection"

STAIRS_ATTR_RISER_THICKNESS

"Riser Thickness"

STAIRS_ATTR_NUM_MID_STRINGERS

"Middle Stringers"

STAIRS_ATTR_STAIRS_CUT_OFFSET

"Extend Below Base"

STAIRS_ATTR_LAST_RISER

"End with Riser"

STAIRS_ATTR_FIRST_RISER

"Begin with Riser"

STAIRS_ATTR_STAIRS_BOTTOM

"Underside of Winder"

STAIRS_ATTR_MONOLITHIC_STAIRS

"Monolithic Stairs"

STAIRS_ATTR_CALC_ENABLED

"Calculation Rules"

STAIRS_ATTR_CALC_MAX

"Calculation Rules"

STAIRS_ATTR_CALC_MIN

"Calculation Rules"

STAIRS_ATTR_EQ_RESULT

"Calculation Rules"

STAIRS_ACTUAL_TREAD_DEPTH

"Actual Tread Depth"

STAIRS_ATTR_TREAD_MULT

"Tread Multiplier"

STAIRS_ATTR_RISER_MULT

"Riser Multiplier"

STAIRS_ATTR_STAIR_CALCULATOR

"Calculation Rules"

STAIRS_ACTUAL_NUM_RISERS

"Actual Number of Risers"

STAIRS_ATTR_BREAK_SYM_IN_CUTLINE

"Break Symbol in Plan"

STAIRS_ATTR_RISER_MATERIAL

"Riser Material"

STAIRS_ATTR_RISER_TYPE

"Riser Type"

STAIRS_ATTR_TREAD_MATERIAL

"Tread Material"

STAIRS_ATTR_NOSING_LENGTH

"Nosing Length"

STAIRS_ATTR_TREAD_FRONT_PROFILE

"Nosing Profile"

STAIRS_ATTR_STRINGER_MATERIAL

"Stringer Material"

STAIRS_ATTR_STRINGER_OFFSET

"Open Stringer Offset"

STAIRS_ATTR_STRINGER_CARRIAGE

"Stringer Carriage Height"

STAIRS_ATTR_SIDE_STRINGER_TYPE_PARAM

"Type of Side Stringers"

STAIRS_MULTISTORY_TOP_LEVEL_PARAM

"Multistory Top Level"

STAIRS_STRINGERS_PRESENT

"Stringer Position"

STAIRS_TOP_OFFSET

"Top Offset"

STAIRS_BASE_OFFSET

"Base Offset"

STAIRS_ATTR_RISER_ANGLE

"Riser Angle"

STAIRS_ATTR_TREAD_THICKNESS

"Tread Thickness"

STAIRS_ATTR_STRINGER_THICKNESS

"Stringer Thickness"

STAIRS_ATTR_STRINGER_HEIGHT

"Stringer Height"

STAIRS_ATTR_RISERS_PRESENT

"Risers Present"

STAIRS_ACTUAL_RISER_HEIGHT

"Actual Riser Height"

STAIRS_DESIRED_NUM_RISERS

"Desired Number of Risers"

STAIRS_ATTR_TREAD_WIDTH

"Width"

STAIRS_ATTR_MINIMUM_TREAD_DEPTH

"Minimum Tread Depth"

STAIRS_ATTR_MAX_RISER_HEIGHT

"Maximum Riser Height"

STAIRS_TOP_LEVEL_PARAM

"Top Level"

STAIRS_BASE_LEVEL_PARAM

"Base Level"

LEVEL_IS_STRUCTURAL

"Structural"

LEVEL_IS_BUILDING_STORY

"Building Story"

LEVEL_UP_TO_LEVEL

"Story Above"

LEVEL_RELATIVE_BASE_TYPE

"Elevation Base"

LEVEL_ELEV

"Elevation"

LEVEL_NAME

"Level"

LEVEL_HEAD_TAG

"Symbol"

TAG_NO_BREAK_PARAM_STRINGS

"Wrap between parameters only"

ROOM_TAG_ORIENTATION_PARAM

"Orientation"

TAG_ORIENTATION_PARAM

"Orientation"

TAG_SAMPLE_TEXT

"Sample Text"

TAG_TAG

"Label"

DIAMETER_SYMBOL_TEXT

"Diameter Symbol Text"

DIAMETER_SYMBOL_LOCATION

"Diameter Symbol Location"

RADIUS_SYMBOL_TEXT

"Radius Symbol Text"

VIS_GRAPHICS_WORKSETS

"V/G Overrides Worksets"

VIS_GRAPHICS_ANALYTICAL_MODEL

"V/G Overrides Analytical Model"

VIS_GRAPHICS_DESIGNOPTIONS

"V/G Overrides Design Options"

VIS_GRAPHICS_RVT_LINKS

"V/G Overrides RVT Links"

VIS_GRAPHICS_FILTERS

"V/G Overrides Filters"

VIS_GRAPHICS_IMPORT

"V/G Overrides Import"

VIS_GRAPHICS_ANNOTATION

"V/G Overrides Annotation"

VIS_GRAPHICS_MODEL

"V/G Overrides Model"

LEVEL_ATTR_ROOM_COMPUTATION_AUTOMATIC

"Automatic Room Computation Height"

LEVEL_ATTR_ROOM_COMPUTATION_HEIGHT

"Computation Height"

LEVEL_ROOM_COMPUTATION_HEIGHT

"Computation Height"

ROOM_COMPUTATION_HEIGHT

"Computation Height"

ALWAYS_ZERO_LENGTH

"Base Offset"

ROOM_COMPUTATION_METHOD

"Computation"

ROOM_LOWER_OFFSET

"Base Offset"

ROOM_UPPER_OFFSET

"Limit Offset"

ROOM_UPPER_LEVEL

"Upper Limit"

ROOM_VOLUME

"Volume"

ROOM_HEIGHT

"Unbounded Height"

ROOM_PERIMETER

"Perimeter"

ROOM_LEVEL_ID

"Level"

ROOM_OCCUPANCY

"Occupancy"

ROOM_DEPARTMENT

"Department"

ROOM_FINISH_BASE

"Base Finish"

ROOM_FINISH_CEILING

"Ceiling Finish"

ROOM_FINISH_WALL

"Wall Finish"

ROOM_FINISH_FLOOR

"Floor Finish"

ROOM_AREA

"Area"

ROOM_NUMBER

"Number"

ROOM_NAME

"Name"

SPATIAL_FIELD_MGR_LEGEND_HOR_ORIGIN_GAP

"Legend Horizontal Origin Gap"

SPATIAL_FIELD_MGR_LEGEND_VERT_ORIGIN_GAP

"Legend Vertical Origin Gap"

SPATIAL_FIELD_MGR_LEGEND_WIDTH

"Legend Width"

SPATIAL_FIELD_MGR_LEGEND_HEIGHT

"Legend Height"

VIEW_ANALYSIS_RESULTS_VISIBILITY

"Analysis Display Settings"

SPATIAL_FIELD_MGR_LEGEND_TEXT_TYPE

"Overall Legend Text"

SPATIAL_FIELD_MGR_RESULTS_VISIBILITY

"Results Visibility"

SPATIAL_FIELD_MGR_LEGEND_SHOW_DESCRIPTION

"Show Description"

SPATIAL_FIELD_MGR_LEGEND_SHOW_CONFIG_NAME

"Show Configuration Name"

SPATIAL_FIELD_MGR_DESCRIPTION

"Description"

SPATIAL_FIELD_MGR_CURRENT_NAME

"Analysis Configuration"

SPATIAL_FIELD_MGR_RANGE

"Data Range"

FILLED_REGION_BACKGROUND

"Background"

GRID_END_SEGMENTS_LENGTH

"End Segments Length"

GRID_END_SEGMENT_PATTERN

"End Segment Pattern"

GRID_END_SEGMENT_COLOR

"End Segment Color"

GRID_END_SEGMENT_WEIGHT

"End Segment Weight"

GRID_CENTER_SEGMENT_PATTERN

"Center Segment Pattern"

GRID_CENTER_SEGMENT_COLOR

"Center Segment Color"

GRID_CENTER_SEGMENT_WEIGHT

"Center Segment Weight"

GRID_CENTER_SEGMENT_STYLE

"Center Segment"

GRID_BUBBLE_LINE_PEN

"Bubble Weight Number\n"

GRID_HEAD_TAG

"Symbol"

STAIRS_PATH_FULL_STEP_ARROW

"Full Step Arrow"

STAIRS_PATH_START_EXTENSION

"Start Extension"

NUMBER_SYSTEM_TEXT_SIZE

"Number Size"

NUMBER_SYSTEM_TAG_TYPE

"Tag Type"

NUMBER_SYSTEM_DISPLAY_RULE

"Display Rule"

NUMBER_SYSTEM_REFERENCE

"Reference"

NUMBER_SYSTEM_JUSTIFY

"Justify"

NUMBER_SYSTEM_ORIENTATION

"Orientation"

NUMBER_SYSTEM_REFERENCE_OFFSET

"Offset from Reference"

NUMBER_SYSTEM_JUSTIFY_OFFSET

"Justify Offset"

STAIRS_TEXT_ORIENTATION

"Orientation"

STAIRS_TEXT_TYPE

"Text Type"

STAIRS_DOWN_TEXT

"Down Text"

STAIRS_SHOW_DOWN_TEXT

"Show Down Text"

STAIRS_UP_TEXT

"Up Text"

STAIRS_SHOW_UP_TEXT

"Show Up Text"

SHOW_ARROWHEAD_TO_CUT_MARK

"Show Arrowhead to Cut Mark"

DRAW_FOR_EACH_RUN

"Draw for Each Run"

ARROWHEAD_END_AT_RISER

"End at Riser"

STAIRS_PATH_START_FROM_RISER

"Start from Riser"

DISTANCE_TO_CUT_MARK

"Distance to Cut Mark"

LINE_SHAPE_AT_CORNER

"Line Shape at Landing Corner"

ARROWHEAD_TYPE

"Arrowhead Type"

START_SYMBOL_TYPE

"Start Symbol Type"

CUT_MARK_SYMBOL_SIZE

"Cut Mark Symbol Size"

CUT_LINE_TYPE

"Cut Line Type"

CUT_LINE_ANGLE

"Cut Line Angle"

CUT_LINE_EXTENSION

"Cut Line Extension"

CUT_LINE_DISTANCE

"Cut Line Distance"

CUT_MARK_SYMBOL

"Cut Mark Symbol"

SECTION_BROKEN_DISPLAY_STYLE

"Broken Section Display Style"

SECTION_COARSER_SCALE_PULLDOWN_IMPERIAL

"Hide at scales coarser than"

SECTION_COARSER_SCALE_PULLDOWN_METRIC

"Hide at scales coarser than"

SECTION_PARENT_VIEW_NAME

"Parent View"

SECTION_SHOW_IN_ONE_VIEW_ONLY

"Show in"

SECTION_ATTR_TAIL_TAG

"Section Tail"

SECTION_ATTR_TAIL_WIDTH

"Tail width"

SECTION_ATTR_TAIL_LENGTH

"Tail length"

VIEWER_DETAIL_NUMBER

"Detail Number"

VIEWER_SHEET_NUMBER

"Sheet Number"

SECTION_ATTR_HEAD_TAG

"Section Head"

EQUALITY_WITNESS_DISPLAY

"Equality Witness Display"

DIM_STYLE_SUPPRESS_SPACES

"Suppress Spaces"

EQUALITY_FORMULA

"Equality Formula"

DIM_STYLE_LEADER_TICK_MARK

"Leader Tick Mark"

EQUALITY_TEXT_FOR_ANGULAR_DIM

"Equality Text"

EQUALITY_TEXT_FOR_CONTINUOUS_LINEAR_DIM

"Equality Text"

DIM_TEXT_LOCATION_FOR_LEADER

"Text Location"

DIM_LEADER_DISPLAY_CONDITION

"Show Leader When Text Moves"

DIM_LEADER_SHOULDER_LENGTH

"Shoulder Length"

DIM_LEADER_TYPE

"Leader Type"

DIM_TO_INTERSECTING_GRIDS

"Dimension To Intersecting Grids"

DIM_TO_INTERSECTING_WALLS

"Dimension To Intersecting Walls"

DIM_TO_INSERT_TYPE

"Dimension To Opening Type"

FIXED_ROTATION

"Fixed Rotation"

KEEP_READABLE

"Keep Readable"

LEADER_LINE

"Leader Line"

LEADER_OFFSET_SHEET

"Leader/Border Offset"

DIM_TO_INSERTS

"Dimension To Openings"

SPOT_SLOPE_OFFSET_FROM_REFERENCE

"Offset from Reference"

SPOT_SLOPE_SLOPE_REPRESENTATION

"Slope Representation"

SPOT_SLOPE_SLOPE_DIRECTION

"Slope Direction"

SPOT_ELEV_LOWER_VALUE

"Lower Value"

SPOT_ELEV_SINGLE_OR_UPPER_VALUE

"Single/Upper Value"

SPOT_ELEV_IND_TYPE_ELEVATION

"Elevation Indicator as Prefix/Suffix"

SPOT_COORDINATE_INCLUDE_ELEVATION

"Include Elevation"

SPOT_COORDINATE_ELEVATION_SUFFIX

"Elevation Value Suffix"

SPOT_COORDINATE_ELEVATION_PREFIX

"Elevation Value Prefix"

SPOT_COORDINATE_BOTTOM_SUFFIX

"Bottom Value Suffix"

SPOT_COORDINATE_BOTTOM_PREFIX

"Bottom Value Prefix"

SPOT_COORDINATE_TOP_SUFFIX

"Top Value Suffix"

SPOT_COORDINATE_TOP_PREFIX

"Top Value Prefix"

SPOT_ELEV_LOWER_SUFFIX

"Lower Value Suffix"

SPOT_ELEV_LOWER_PREFIX

"Lower Value Prefix"

SPOT_ELEV_SINGLE_OR_UPPER_SUFFIX

"Single/Upper Value Suffix"

SPOT_ELEV_SINGLE_OR_UPPER_PREFIX

"Single/Upper Value Prefix"

BASELINE_DIM_OFFSET

"Baseline Offset\nBaseline Offset"

SPOT_ELEV_BEND_LEADER

"Leader Shoulder"

SPOT_ELEV_IND_TYPE_BOTTOM

"Bottom Indicator as Prefix/Suffix"

SPOT_ELEV_IND_TYPE_TOP

"Top Indicator as Prefix/Suffix"

SPOT_ELEV_IND_BOTTOM

"Bottom Indicator"

SPOT_ELEV_IND_TOP

"Top Indicator"

SPOT_ELEV_TEXT_LOCATION

"Text Location"

SPOT_ELEV_ROTATE_WITH_COMPONENT

"Rotate with Component"

SPOT_ELEV_DISPLAY_ELEVATIONS

"Display Elevations"

ORDINATE_DIM_SETTING

"Ordinate Dimension Settings"

LINEAR_DIM_TYPE

"Dimension String Type"

SPOT_DIM_LEADER

"Leader"

DIM_STYLE_FLIPPED_DIM_LINE_EXTENSION

"Flipped Dimension Line Extension"

DIM_STYLE_INTERIOR_TICK_MARK

"Interior Tick Mark"

SPOT_TEXT_FROM_LEADER

"Text Offset from Leader"

SPOT_COORDINATE_BASE

"Coordinate Origin"

SPOT_ELEV_IND_TYPE

"Indicator as Prefix / Suffix"

SPOT_ELEV_BOT_VALUE

"Bottom Value"

SPOT_ELEV_TOP_VALUE

"Top Value"

SPOT_ELEV_TEXT_ORIENTATION

"Text Orientation"

SPOT_ELEV_IND_ELEVATION

"Elevation Indicator"

SPOT_ELEV_IND_EW

"East / West Indicator"

SPOT_ELEV_IND_NS

"North / South Indicator"

ARROW_CLOSED

"Arrow Closed"

DIM_STYLE_READ_CONVENTION

"Read Convention"

HEAVY_END_PEN

"Heavy End Pen Weight"

DIM_STYLE_DIM_LINE_SNAP_DIST

"Dimension Line Snap Distance"

DIM_STYLE_CENTERLINE_TICK_MARK

"Centerline Tick Mark"

SPOT_ELEV_LINE_PEN

"Leader Line Weight"

SPOT_ELEV_TICK_MARK_PEN

"Leader Arrowhead Line Weight"

SPOT_ELEV_LEADER_ARROWHEAD

"Leader Arrowhead"

SPOT_ELEV_RELATIVE_BASE

"Relative Base"

SPOT_ELEV_FLIP_TEXT_VERT

"Auto Mirror"

SPOT_ELEV_TEXT_HORIZ_OFFSET

"Text Offset from Symbol"

SPOT_ELEV_BASE

"Elevation Origin"

SPOT_ELEV_SYMBOL

"Symbol"

DIM_STYLE_SHOW_OPENING_HT

"Show Opening Height"

DIM_STYLE_CENTERLINE_PATTERN

"Centerline Pattern"

DIM_WITNS_LINE_EXTENSION_BELOW

"Witness Line Length"

DIM_WITNS_LINE_CNTRL

"Witness Line Control"

DIM_LINE_EXTENSION

"Dimension Line Extension"

DIM_STYLE_CENTERLINE_SYMBOL

"Centerline Symbol"

DIM_TEXT_BACKGROUND

"Text Background"

DIM_STYLE_ANGULAR_UNITS

"Units Format"

DIM_STYLE_LINEAR_UNITS

"Units Format"

LEADER_ARROW_WIDTH

"Arrow Width Angle"

ARROW_FILLED

"Fill Tick"

HEAVY_TICK_MARK_PEN

"Heavy End Pen Weight"

ARROW_SIZE

"Tick Size"

ARROW_TYPE

"Arrow Style"

TICK_MARK_PEN

"Tick Mark Line Weight"

TEXT_POSITION

"Text Position"

RADIUS_SYMBOL_LOCATION

"Radius Symbol Location"

CENTER_MARK_SIZE

"Center Mark Size"

ARC_CENTER_MARK

"Center Marks"

WITNS_LINE_GAP_TO_ELT

"Witness Line Gap to Element"

WITNS_LINE_EXTENSION

"Witness Line Extension"

TEXT_DIST_TO_LINE

"Text Offset"

TEXT_ALIGNMENT

"Text Alignment"

MODEL_TEXT_SIZE

"Text Size"

TEXT_STYLE_SIZE

"Size"

TEXT_STYLE_FONT

"Font"

SHOW_TITLE

"Show Title"

TITLE_STYLE_UNDERLINE

"Underline"

TITLE_STYLE_ITALIC

"Italic"

TITLE_STYLE_BOLD

"Bold"

TITLE_SIZE

"Size"

TITLE_FONT

"Font"

TEXT_WIDTH_SCALE

"Width Factor"

TEXT_TAB_SIZE

"Tab Size"

ARC_LEADER_PARAM

"Arc Leaders"

DIM_LEADER_ARROWHEAD

"Tick Mark"

SHEET_ISSUE_DATE

"Sheet Issue Date"

PROJECT_ISSUE_DATE

"Project Issue Date"

PROJECT_STATUS

"Project Status"

CLIENT_NAME

"Client Name"

PROJECT_ADDRESS

"Project Address"

PROJECT_NAME

"Project Name"

PROJECT_NUMBER

"Project Number"

LEADER_ARROWHEAD

"Leader Arrowhead"

TEXT_BACKGROUND

"Background"

TEXT_STYLE_UNDERLINE

"Underline"

TEXT_STYLE_ITALIC

"Italic"

TEXT_STYLE_BOLD

"Bold"

CURVE_IS_FILLED

"Filled"

TEXT_ALIGN_VERT

"Vertical Align"

TEXT_ALIGN_HORZ

"Horizontal Align"

TEXT_TEXT

"Text"

LINE_PATTERN

"Line Pattern"

LINE_COLOR

"Color"

LINE_PEN

"Line Weight"

TEXT_COLOR

"Color"

TEXT_SIZE

"Text Size"

TEXT_FONT

"Text Font"

EDGE_LINEWORK

"Line Style"

BUILDING_CURVE_GSTYLE_PLUS_INVISIBLE

"Subcategory"

BUILDING_CURVE_GSTYLE

"Line Style"

FAMILY_CURVE_GSTYLE_FOR_2010_MASS

"Subcategory"

HEAD_ON_PLACEMENT_METHOD

"Draw in Foreground"

IS_VISIBLE_PARAM

"Visible"

FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM_MINUS_ANALYTICAL

"Subcategory"

FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_MINUS_ANALYTICAL

"Subcategory"

FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE_PLUS_STICK_SYM

"Subcategory"

FAMILY_CURVE_GSTYLE_PLUS_INVISIBLE

"Subcategory"

FAMILY_ELEM_SUBCATEGORY

"Subcategory"

STAIRS_CURVE_TYPE

"Stairs Line Type"

ROOF_SLOPE

"Slope"

CURVE_PARAM_STEEL_CANTILEVER

"Steel Cantilever"

CURVE_PARAM_CONCRETE_CANTILEVER

"Concrete Cantilever"

CURVE_NUMBER_OF_SEGMENTS

"Number of Full Segments"

SPECIFY_SLOPE_OR_OFFSET

"Specify "

SLOPE_ARROW_LEVEL_END

"Level at Head"

SLOPE_ARROW_LEVEL_START

"Level at Tail"

CURVE_LEVEL

"Level"

CURVE_HEIGHT_OFFSET

"Offset From Base"

CURVE_IS_SLOPE_DEFINING

"Defines Slope"

DEFINES_CONSTANT_HEIGHT

"Defines Constant Height"

ROOF_CURVE_HEIGHT_AT_WALL

"Plate Offset From Base"

ROOF_CURVE_HEIGHT_OFFSET

"Offset From Roof Base"

ROOF_CURVE_IS_SLOPE_DEFINING

"Defines Roof Slope"

STRUCTURAL_MATERIAL_PARAM

"Structural Material"

ANALYTIC_CONSTRUCTION_GBXML_TYPEID

"Construction Type Id"

ANALYTIC_CONSTRUCTION_LOOKUP_TABLE

"Analytic Construction"

ANALYTICAL_ROUGHNESS

"Roughness"

ANALYTICAL_ABSORPTANCE

"Absorptance"

ANALYTICAL_THERMAL_MASS

"Thermal mass"

ANALYTICAL_VISUAL_LIGHT_TRANSMITTANCE

"Visual Light Transmittance"

ANALYTICAL_SOLAR_HEAT_GAIN_COEFFICIENT

"Solar Heat Gain Coefficient"

ANALYTICAL_THERMAL_RESISTANCE

"Thermal Resistance (R)"

ANALYTICAL_HEAT_TRANSFER_COEFFICIENT

"Heat Transfer Coefficient (U)"

VIEW_DESIGN_OPTIONS_CONFIG

"Design Option Configuration"

VIEW_GRAPH_SUN_PATH_SIZE

"Sun path size (%)"

VIEW_GRAPH_SUN_PATH

"Sun Path"

VIEW_ANALYSIS_DISPLAY_STYLE

"Default Analysis Display Style"

VIEW_GRAPH_SCHED_LEVEL_RELATIVE_BASE_TYPE

"Elevation Base for Levels"

VIEW_GRAPH_SCHED_HIDDEN_LEVELS

"Hidden Levels"

VIEW_GRAPH_SCHED_TOTAL_ROWS

"Total Segments"

VIEW_GRAPH_SCHED_ROWS_COUNT

"Segments in Viewport"

VIEW_GRAPH_SCHED_GRID_APPEARANCE

"Grid Appearance"

VIEW_GRAPH_SCHED_TEXT_APPEARANCE

"Text Appearance"

VIEW_GRAPH_SCHED_TITLE

"Title"

VIEW_GRAPH_SCHED_ROWS_FROM

"Segment Start in Viewport"

VIEW_GRAPH_SCHED_GROUP_SIMILAR

"Group Similar Locations"

VIEW_GRAPH_SCHED_MATERIAL_TYPES

"Material Types"

VIEW_GRAPH_SCHED_LOCATIONS_HIGH

"Column Locations End"

VIEW_GRAPH_SCHED_LOCATIONS_LOW

"Column Locations Start"

VIEW_GRAPH_SCHED_BOTTOM_LEVEL

"Bottom Level"

VIEW_GRAPH_SCHED_TOP_LEVEL

"Top Level"

VIEWPORT_ATTR_ORIENTATION_ON_SHEET

"Rotation on Sheet"

VIEWPORT_ATTR_SHOW_BOX

"Show Box"

VIEWPORT_ATTR_SHOW_EXTENSION_LINE

"Show Extension Line"

VIEWPORT_ATTR_SHOW_LABEL

"Show Title"

VIEWPORT_ATTR_LABEL_TAG

"Title"

VIEW_SCALE_HAVENAME

"Display Name"

VIEW_SCALE_CUSTOMNAME

"Display Name"

VIEW_GRAPH_SCHED_OFF_GRID

"Include Off-Grid Columns"

VIEW_GRAPH_SCHED_UNITS_FORMAT

"Off-Grid Units Format"

VIEWPORT_SHEET_NAME

"Sheet Name"

VIEWPORT_SHEET_NUMBER

"Sheet Number"

VIEWPORT_SCALE

"View Scale"

VIEWPORT_VIEW_NAME

"View Name"

VIEWPORT_DETAIL_NUMBER

"Detail Number"

VIEW_TEMPLATE_FOR_SCHEDULE

"View Template"

RENDER_RPC_PROPERTIES

"Render Appearance Properties"

FAMILY_SYMBOLIC_REP

"Symbolic Representation"

FAMILY_RENDERING_TYPE

"Render Appearance Source"

RENDER_RPC_FILENAME

"Render Appearance"

RENDER_PLANT_TRIM_HEIGHT

"Plant Trim Height"

RENDER_PLANT_HEIGHT

"Height"

RENDER_PLANT_NAME

"Plant Name"

VIEW_CAMERA_ORIENTATION

"Locked Orientation"

COLOR_SCHEME_LOCATION

"Color Scheme Location"

VIEW_DEPENDENCY

"Dependency"

VIEW_BACK_CLIPPING

"Depth Clipping"

VIEW_SHOP_DRAWING_ASSEMBLY_INSTANCE_ID

"None"

VIEW_GRAPH_SCHED_TOTAL_COLUMNS

"Total Column Locations"

VIEW_UNDERLAY_ORIENTATION

"Underlay Orientation"

VIEW_TEMPLATE

"View Template"

VIEW_GRAPH_SCHED_NUMBER_COLUMNS

"Column Locations per Segment"

GRAPHIC_DISPLAY_OPTIONS

"Graphic Display Options"

MODEL_GRAPHICS_STYLE_ANON_DRAFT

"Visual Style"

VIEW_REFERENCING_DETAIL

"Referencing Detail"

VIEW_REFERENCING_SHEET

"Referencing Sheet"

VIEW_CAMERA_POSITION

"Camera Position"

PLAN_VIEW_NORTH

"Orientation"

WALKTHROUGH_FRAMES_COUNT

"Walkthrough Frames"

PLAN_VIEW_LEVEL

"Associated Level"

MODEL_GRAPHICS_STYLE

"Visual Style"

VIEW_VISIBLE_CATEGORIES

"Visibility/Graphics Overrides"

VIEW_DISCIPLINE

"Discipline"

PLAN_VIEW_RANGE

"View Range"

VIEW_MODEL_DISPLAY_MODE

"Display Model"

VIEW_SHOW_MASSING

"Show Mass"

PLAN_VIEW_TOP_CLIP_HEIGHT

"Top Clip Height"

VIEW_CLEAN_JOINS

"Wall Join Display"

VIEW_SHEET_VIEWPORT_INFO

"Viewport"

PLAN_VIEW_CUT_PLANE_HEIGHT

"Cut Plane Height"

VIEW_DEPTH

"View Depth"

VIEW_UNDERLAY_ID

"Underlay"

VIEW_SCALE_PULLDOWN_IMPERIAL

"View Scale"

VIEW_SCALE_PULLDOWN_METRIC

"View Scale"

VIEW_SCALE

"Scale Value 1:"

VIEW_SCHEMA_SETTING_FOR_SYSTEM

"System Color Schemes"

VIEW_SCHEMA_SETTING_FOR_BUILDING

"Color Scheme"

VIEW_FIXED_SKETCH_PLANE

"None"

GRAPHIC_DISPLAY_OPTIONS_PHOTO_EXPOSURE

"Photographic Exposure"

GRAPHIC_DISPLAY_OPTIONS_FOG

"Fog"

GRAPHIC_DISPLAY_OPTIONS_BACKGROUND

"Background"

GRAPHIC_DISPLAY_OPTIONS_SS_INTENSITY

"Sun and Shadow Intensity"

GRAPHIC_DISPLAY_OPTIONS_LIGHTING

"Lighting"

GRAPHIC_DISPLAY_OPTIONS_SHADOWS

"Shadows"

GRAPHIC_DISPLAY_OPTIONS_MODEL

"Model Display"

VIEWER3D_RENDER_SETTINGS

"Rendering Settings"

VIEWER_BOUND_FAR_CLIPPING

"Far Clipping"

VIEWER_REFERENCE_LABEL_TEXT

"Reference Label"

VIEWER_IS_REFERENCE

"Is a Reference"

VIEWER_REFERENCE_LABEL

"Reference Label"

VIEW_DESCRIPTION

"Title on Sheet"

VIEWER_MODEL_CLIP_BOX_ACTIVE

"Section Box"

VIEW_NAME

"View Name"

VIEWER_BOUND_ACTIVE_NEAR

"Near Clip Active"

VIEWER_BOUND_ACTIVE_FAR

"Far Clip Active"

VIEWER_BOUND_ACTIVE_BOTTOM

"Bottom Clip Active"

VIEWER_BOUND_ACTIVE_TOP

"Top Clip Active"

VIEWER_BOUND_ACTIVE_LEFT

"Left Clip Active"

VIEWER_BOUND_ACTIVE_RIGHT

"Right Clip Active"

VIEWER_BOUND_OFFSET_NEAR

"Near Clip Offset"

VIEWER_BOUND_OFFSET_FAR

"Far Clip Offset"

VIEWER_BOUND_OFFSET_BOTTOM

"Bottom Clip Offset"

VIEWER_BOUND_OFFSET_TOP

"Top Clip Offset"

VIEWER_BOUND_OFFSET_LEFT

"Left Clip Offset"

VIEWER_BOUND_OFFSET_RIGHT

"Right Clip Offset"

VIEWER_ANNOTATION_CROP_ACTIVE

"Annotation Crop"

VIEWER_SHOW_UNCROPPED

"Show uncropped"

VIEWER_CROP_REGION_DISABLED

"Crop View"

VIEWER_CROP_REGION_VISIBLE

"Crop Region Visible"

VIEWER_CROP_REGION

"Crop View"

VIEWER_PERSPECTIVE_DISABLED

"Perspective"

VIEWER_PERSPECTIVE

"Perspective"

VIEWER_TARGET_ELEVATION

"Target Elevation"

VIEWER_OPTION_VISIBILITY

"Visible In Option"

VIEWER_EYE_ELEVATION

"Eye Elevation"

DIM_LEADER

"Leader"

DIM_DISPLAY_EQ

"Equality Display"

DIM_NOT_MODIFIABLE

"Non-modifiable"

DIM_LABEL

"Label"

DIM_VALUE_ANGLE

"Value"

DIM_VALUE_LENGTH

"Value"

ELEM_REFERENCE_NAME_2D_XZ

"Is Reference"

CURVE_ELEM_DEFINES_SLOPE

"Defines Beam System Slope"

RADIAL_ARRAY_ARC_RADIUS

"Radius"

CURVE_DETERMINES_ORIENTATION

"Determines Orientation"

DATUM_PLANE_DEFINES_WALL_CLOSURE

"Wall Closure"

CURVE_IS_DETAIL

"Detail Line"

CURVE_ELEM_ARC_RADIUS

"Radius"

CURVE_ELEM_ARC_RANGE

"Range"

CURVE_ELEM_ARC_END_ANGLE

"Angle 2"

CURVE_ELEM_ARC_START_ANGLE

"Angle 1"

CURVE_ELEM_LINE_ANGLE

"Angle"

CURVE_ELEM_LENGTH

"Length"

ELEM_DELETABLE_IN_FAMILY

"Deletable"

ELEM_REFERENCE_NAME

"Is Reference"

DATUM_PLANE_DEFINES_ORIGIN

"Defines Origin"

ELEM_IS_REFERENCE

"Reference"

COLUMN_LOCATION_MARK

"Column Location Mark"

COLUMN_TOP_ATTACH_CUT_PARAM

"Top Attachment Cut"

COLUMN_BASE_ATTACH_CUT_PARAM

"Base Attachment Cut"

COLUMN_BASE_ATTACHED_PARAM

"Base is Attached"

COLUMN_TOP_ATTACHED_PARAM

"Top is Attached"

COLUMN_BASE_ATTACHMENT_OFFSET_PARAM

"Offset From Attachment At Base"

COLUMN_TOP_ATTACHMENT_OFFSET_PARAM

"Offset From Attachment At Top"

COLUMN_BASE_ATTACH_JUSTIFICATION_PARAM

"Attachment Justification At Base"

COLUMN_TOP_ATTACH_JUSTIFICATION_PARAM

"Attachment Justification At Top"

MATERIAL_PARAM_SHININESS

"Shininess"

MATERIAL_PARAM_SMOOTHNESS

"Smoothness"

MATERIAL_PARAM_GLOW

"Glow"

MATERIAL_PARAM_TRANSPARENCY

"Transparency"

MATERIAL_PARAM_COLOR

"Color"

SEEK_ITEM_ID

"Seek Item ID"

OMNICLASS_DESCRIPTION

"OmniClass Title"

OMNICLASS_CODE

"OmniClass Number"

UNIFORMAT_DESCRIPTION

"Assembly Description"

UNIFORMAT_CODE

"Assembly Code"

SLOPE_END_HEIGHT

"Height Offset at Head"

SLOPE_START_HEIGHT

"Height Offset at Tail"

CEILING_HAS_THICKNESS_PARAM

"Has Thickness"

CEILING_THICKNESS_PARAM

"Thickness"

CEILING_HEIGHTABOVELEVEL_PARAM

"Height Offset From Level"

CEILING_THICKNESS

"Thickness"

CEILING_ATTR_SYSTEMNAME_PARAM

"System"

CEILING_ATTR_SPACING2_PARAM

"Spacing Axis 2"

CEILING_ATTR_SPACING1_PARAM

"Spacing Axis 1"

CEILING_ATTR_PATTERN_PARAM

"Pattern"

CEILING_ATTR_DEFAULT_HEIGHT_PARAM

"Default Height above level"

BUILIDING_PAD_STRUCTURE_ID_PARAM

"Structure"

CEILING_STRUCTURE_ID_PARAM

"Structure"

ROOF_STRUCTURE_ID_PARAM

"Structure"

FLOOR_STRUCTURE_ID_PARAM

"Structure"

ANY_PATTERN_ID_PARAM_NO_NO

"Fill Pattern"

FILL_PATTERN_ID_PARAM_NO_NO

"Cut fill pattern"

OBJECT_STYLE_MATERIAL_ID_PARAM

"Object Style Material"

WRAPPING_AT_INSERTS_PARAM

"Wrapping at Inserts"

WRAPPING_AT_ENDS_PARAM

"Wrapping at Ends"

COARSE_SCALE_FILL_PATTERN_COLOR

"Coarse Scale Fill Color"

MODEL_CATEGORY_ID_PARAM

"Subcategory"

HOST_ID_PARAM

"Host Id"

MATERIAL_ID_PARAM

"Material"

COARSE_SCALE_FILL_PATTERN_ID_PARAM

"Coarse Scale Fill Pattern"

ANY_PATTERN_ID_PARAM

"Fill Pattern"

WALL_STRUCTURE_ID_PARAM

"Structure"

SURFACE_PATTERN_ID_PARAM

"Surface fill pattern"

FILL_PATTERN_ID_PARAM

"Cut fill pattern"

ID_PARAM

"Id"

EDITED_BY

"Edited by"

SCHEDULE_TOP_LEVEL_OFFSET_PARAM

"Top Offset"

SCHEDULE_BASE_LEVEL_OFFSET_PARAM

"Base Offset"

SCHEDULE_TOP_LEVEL_PARAM

"Top Level"

SCHEDULE_BASE_LEVEL_PARAM

"Base Level"

SCHEDULE_LEVEL_PARAM

"Level"

ELEM_ROOM_ID

"Room Id"

ELEM_ROOM_NAME

"Room Name"

ELEM_ROOM_NUMBER

"Room Number"

ELEM_PARTITION_PARAM

"Workset"

ELEM_FAMILY_AND_TYPE_PARAM

"Family and Type"

ELEM_FAMILY_PARAM

"Family"

ELEM_TYPE_PARAM

"Type"

ELEM_TYPE_LABEL

"Label"

BR_ORG_FILTER

"Filter"

BR_ORG_FOLDERS

"Folders"

SYMBOL_FAMILY_AND_TYPE_NAMES_PARAM

"Family and Type"

ALL_MODEL_FAMILY_NAME

"Family Name"

SYMBOL_FAMILY_NAME_PARAM

"Family Name"

ALL_MODEL_TYPE_NAME

"Type Name"

SYMBOL_NAME_PARAM

"Type Name"

SYMBOL_ID_PARAM

"Type Id"

STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS

"Display in Hidden Views"

FLOOR_PARAM_SPAN_DIRECTION

"Span Direction"

FLOOR_PARAM_IS_STRUCTURAL

"Structural"

HOST_PERIMETER_COMPUTED

"Perimeter"

LEVEL_PARAM

"Level"

FLOOR_HEIGHTABOVELEVEL_PARAM

"Height Offset From Level"

FLOOR_ATTR_DEFAULT_HEIGHT_PARAM

"Default Height above level"

FLOOR_ATTR_DEFAULT_THICKNESS_PARAM

"Default Thickness"

FLOOR_ATTR_THICKNESS_PARAM

"Thickness"

PROFILE_PARAM_ALONG_PATH

"Parameter along path"

PROFILE_FAM_TYPE_PLUS_NONE

"Profile"

PROFILE2_ANGLE

"Angle"

PROFILE2_FAM_TYPE

"Profile"

PROFILE2_FLIPPED_HOR

"Profile Is Flipped"

PROFILE2_OFFSET_Y

"Vertical Profile Offset"

PROFILE2_OFFSET_X

"Horizontal Profile Offset"

PROFILE1_ANGLE

"Angle"

PROFILE1_FAM_TYPE

"Profile"

PROFILE1_FLIPPED_HOR

"Profile Is Flipped"

PROFILE1_OFFSET_Y

"Vertical Profile Offset"

PROFILE1_OFFSET_X

"Horizontal Profile Offset"

FAM_PROFILE_USAGE

"Profile Usage"

SWEEP_TRAJ_SEGMENTED

"Trajectory Segmentation"

SWEEP_MAX_SEG_ANGLE

"Maximum Segment Angle"

MODEL_OR_SYMBOLIC

"Model or Symbolic"

PROFILE_ANGLE

"Angle"

PROFILE_FAM_TYPE

"Profile"

PROFILE_FLIPPED_HOR

"Profile Is Flipped"

PROFILE_OFFSET_Y

"Vertical Profile Offset"

PROFILE_OFFSET_X

"Horizontal Profile Offset"

EXTRUSION_LENGTH

"Depth"

CURVE_VISIBILITY_PARAM

"Visibility/Graphics Overrides"

GEOM_VISIBILITY_PARAM

"Visibility/Graphics Overrides"

ELEMENT_IS_CUTTING

"Solid/Void"

EXTRUSION_AUTO_PARAMS

"Auto ends"

BLEND_END_PARAM

"Second End"

BLEND_START_PARAM

"First End"

REVOLUTION_END_ANGLE

"End Angle"

REVOLUTION_START_ANGLE

"Start Angle"

EXTRUSION_END_PARAM

"Extrusion End"

EXTRUSION_START_PARAM

"Extrusion Start"

FACEROOF_OFFSET_PARAM

"Level Offset"

FACEROOF_LEVEL_PARAM

"Reference Level"

ROOF_FACES_LOCATION

"Picked Faces Location"

RELATED_TO_MASS

"Related to Mass"

ROOF_RAFTER_OR_TRUSS_TEXT_PARAM

"Rafter or Truss"

FASCIA_DEPTH_PARAM

"Fascia Depth"

ROOF_EAVE_CUT_PARAM

"Rafter Cut"

ROOF_RAFTER_OR_TRUSS_PARAM

"Rafter or Truss"

ROOF_BASE_LEVEL_PARAM

"Base Level"

CURVE_WALL_OFFSET_ROOFS

"Overhang"

CURVE_WALL_OFFSET

"Wall offset"

ACTUAL_MAX_RIDGE_HEIGHT_PARAM

"Maximum Ridge Height"

ROOF_UPTO_LEVEL_OFFSET_PARAM

"Cutoff Offset"

ROOF_UPTO_LEVEL_PARAM

"Cutoff Level"

ROOF_LEVEL_OFFSET_PARAM

"Base Offset From Level"

ROOF_CONSTRAINT_OFFSET_PARAM

"Level Offset"

ROOF_CONSTRAINT_LEVEL_PARAM

"Reference Level"

HOST_SSE_CURVED_EDGE_CONDITION_PARAM

"Curved Edge Condition"

ROOF_ATTR_THICKNESS_PARAM

"Thickness"

ROOF_ATTR_DEFAULT_THICKNESS_PARAM

"Default Thickness"

NODE_CONNECTION_STATUS

"Connection Status"

WALL_STRUCTURAL_SIGNIFICANT

"Structural"

STRUCTURAL_ANALYTICAL_BEAM_RIGID_LINK

"Analytical Links"

STRUCTURAL_ANALYTICAL_COLUMN_HORIZONTAL_PROJECTION_PLANE

"Horizontal Projection"

STRUCTURAL_ANALYTICAL_BEAM_HORIZONTAL_PROJECTION_PLANE

"Horizontal Projection"

CONTINUOUS_FOOTING_BREAK_AT_INSERTS_DISABLE

"Do Not Break At Inserts"

CONTINUOUS_FOOTING_DEFAULT_END_EXTENSION_LENGTH

"Default End Extension Length"

STRUCTURAL_ANALYTICAL_TESSELLATE

"Approximate curve"

STRUCTURAL_ANALYTICAL_TESS_DEVIATION

"Maximum discretized offset"

STRUCTURAL_ANALYTICAL_HARD_POINTS

"Use hard-points"

STRUCTURAL_BEND_DIR_ANGLE

"Cross-Section Rotation"

STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_COLUMN

"Display in Hidden Views"

STRUCTURAL_DISPLAY_IN_HIDDEN_VIEWS_FRAMING

"Display in Hidden Views"

STRUCTURAL_FLOOR_ANALYZES_AS

"Analyze As"

STRUCTURAL_ANALYZES_AS

"Analyze As"

STRUCTURAL_BEAM_CUTBACK_FOR_COLUMN

"Beam cutback in plan"

BEAM_V_JUSTIFICATION_OTHER_VALUE

"z-Direction Offset Value"

STRUCTURAL_BEAM_ORIENTATION

"Orientation"

STRUCTURAL_BEAM_END1_ELEVATION

"End Level Offset"

STRUCTURAL_BEAM_END0_ELEVATION

"Start Level Offset"

FAMILY_EXPORT_AS_GEOMETRY

"Always export as geometry"

STRUCTURAL_FOUNDATION_LENGTH

"Length"

STRUCTURAL_FOUNDATION_WIDTH

"Width"

CONTINUOUS_FOOTING_LENGTH

"Length"

CONTINUOUS_FOOTING_ECCENTRICITY

"Eccentricity"

CONTINUOUS_FOOTING_STRUCTURAL_USAGE

"Structural Usage"

CONTINUOUS_FOOTING_BEARING_WIDTH

"Width"

STRUCTURAL_FOOTING_BOTTOM_ELEVATION

"Elevation at Bottom"

FAMILY_STRUCT_FOOTING_USE_CAP_TOP

"Cap"

STRUCTURAL_COPING_DISTANCE

"Coping Distance"

CONTINUOUS_FOOTING_WIDTH

"Width"

CONTINUOUS_FOOTING_THICKNESS

"Foundation Thickness"

CONTINUOUS_FOOTING_BOTTOM_HEEL

"Bottom Heel Length"

CONTINUOUS_FOOTING_TOP_HEEL

"Heel Length"

CONTINUOUS_FOOTING_BOTTOM_TOE

"Bottom Toe Length"

CONTINUOUS_FOOTING_TOP_TOE

"Toe Length"

STRUCTURAL_ANALYTICAL_MODEL

"Enable Analytical Model"

STRUCTURAL_ANALYTICAL_COLUMN_RIGID_LINK

"Analytical Links"

FAMILY_STRUCT_MATERIAL_TYPE

"Material for Model Behavior"

STRUCTURAL_BOTTOM_RELEASE_MZ

"Bottom Mz"

STRUCTURAL_BOTTOM_RELEASE_MY

"Bottom My"

STRUCTURAL_BOTTOM_RELEASE_MX

"Bottom Mx"

STRUCTURAL_BOTTOM_RELEASE_FZ

"Bottom Fz"

STRUCTURAL_BOTTOM_RELEASE_FY

"Bottom Fy"

STRUCTURAL_BOTTOM_RELEASE_FX

"Bottom Fx"

STRUCTURAL_TOP_RELEASE_MZ

"Top Mz"

STRUCTURAL_TOP_RELEASE_MY

"Top My"

STRUCTURAL_TOP_RELEASE_MX

"Top Mx"

STRUCTURAL_TOP_RELEASE_FZ

"Top Fz"

STRUCTURAL_TOP_RELEASE_FY

"Top Fy"

STRUCTURAL_TOP_RELEASE_FX

"Top Fx"

STRUCTURAL_BOTTOM_RELEASE_TYPE

"Bottom Release"

STRUCTURAL_TOP_RELEASE_TYPE

"Top Release"

STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_BOTTOM

"Bottom Vertical Projection"

STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE_COLUMN_TOP

"Top Vertical Projection"

STRUCTURAL_MATERIAL_TYPE

"Structural Material Type"

STRUCTURAL_CAMBER

"Camber Size"

STRUCTURAL_NUMBER_OF_STUDS

"Number of studs"

STRUCTURAL_END_RELEASE_MZ

"End Mz"

STRUCTURAL_END_RELEASE_MY

"End My"

STRUCTURAL_END_RELEASE_MX

"End Mx"

STRUCTURAL_END_RELEASE_FZ

"End Fz"

STRUCTURAL_END_RELEASE_FY

"End Fy"

STRUCTURAL_END_RELEASE_FX

"End Fx"

STRUCTURAL_START_RELEASE_MZ

"Start Mz"

STRUCTURAL_START_RELEASE_MY

"Start My"

STRUCTURAL_START_RELEASE_MX

"Start Mx"

STRUCTURAL_START_RELEASE_FZ

"Start Fz"

STRUCTURAL_START_RELEASE_FY

"Start Fy"

STRUCTURAL_START_RELEASE_FX

"Start Fx"

STRUCTURAL_END_RELEASE_TYPE

"End Release"

STRUCTURAL_START_RELEASE_TYPE

"Start Release"

STRUCTURAL_WALL_BOTTOM_PROJECTION_PLANE

"Bottom Vertical Projection"

STRUCTURAL_WALL_TOP_PROJECTION_PLANE

"Top Vertical Projection"

STRUCTURAL_WALL_PROJECTION_SURFACE

"Horizontal Projection"

STRUCTURAL_ANALYTICAL_PROJECT_FLOOR_PLANE

"Vertical Projection"

STRUCTURAL_ANALYTICAL_PROJECT_MEMBER_PLANE

"Vertical Projection"

STRUCTURAL_BRACE_REPRESENTATION

"Representation Type"

STRUCTURAL_STICK_SYMBOL_LOCATION

"Stick Symbol Location"

STRUCTURAL_BEAM_END_SUPPORT

"Beam End Pocket Seat"

STRUCTURAL_BEAM_START_SUPPORT

"Beam Start Pocket Seat"

ALL_MODEL_TYPE_MARK

"Type Mark"

WINDOW_TYPE_ID

"Type Mark"

STRUCTURAL_ATTACHMENT_END_VALUE_ELEVATION

"End Attachment Elevation"

STRUCTURAL_ATTACHMENT_START_VALUE_ELEVATION

"Start Attachment Elevation"

STRUCTURAL_ATTACHMENT_END_LEVEL_REFERENCE

"End Attachment Level Reference"

STRUCTURAL_ATTACHMENT_START_LEVEL_REFERENCE

"Start Attachment Level Reference"

STRUCTURAL_ATTACHMENT_END_VALUE_RATIO

"End attachment ratio"

STRUCTURAL_ATTACHMENT_START_VALUE_RATIO

"Start Attachment Ratio"

STRUCTURAL_ATTACHMENT_END_REFELEMENT_END

"End of Referenced Element"

TYPE_WALL_CLOSURE

"Wall Closure"

STRUCTURAL_ATTACHMENT_START_REFELEMENT_END

"End of Referenced Element"

STRUCTURAL_ATTACHMENT_END_VALUE_DISTANCE

"End Attachment Distance"

STRUCTURAL_ATTACHMENT_START_VALUE_DISTANCE

"Start Attachment Distance"

STRUCTURAL_ATTACHMENT_END_TYPE

"End Attachment Type"

STRUCTURAL_ATTACHMENT_START_TYPE

"Start Attachment Type"

STRUCTURAL_FRAME_CUT_LENGTH

"Cut Length"

INSTANCE_REFERENCE_LEVEL_PARAM

"Reference Level"

INSTANCE_STRUCT_USAGE_TEXT_PARAM

"Structural Usage"

INSTANCE_STRUCT_USAGE_PARAM

"Structural Usage"

SKETCH_PLANE_PARAM

"Work Plane"

INSTANCE_LENGTH_PARAM

"Length"

INSTANCE_MOVES_WITH_GRID_PARAM

"Moves With Grids"

INSTANCE_OFFSET_POS_PARAM

"Moves With Nearby Elements"

INSTANCE_SCHEDULE_ONLY_LEVEL_PARAM

"Schedule Level"

INSTANCE_FREE_HOST_OFFSET_PARAM

"Offset"

INSTANCE_FREE_HOST_PARAM

"Host"

INSTANCE_HEAD_HEIGHT_PARAM

"Head Height"

INSTANCE_SILL_HEIGHT_PARAM

"Sill Height"

INSTANCE_ELEVATION_PARAM

"Elevation"

FAMILY_TOP_LEVEL_OFFSET_PARAM

"Top Offset"

FAMILY_BASE_LEVEL_OFFSET_PARAM

"Base Offset"

FAMILY_LEVEL_PARAM

"Level"

FAMILY_TOP_LEVEL_PARAM

"Top Level"

FAMILY_BASE_LEVEL_PARAM

"Base Level"

FAMILY_RFA_PATH_PSEUDO_PARAM

"File Path"

FAMILY_CATEGORY_PSEUDO_PARAM

"Category"

FAMILY_NAME_PSEUDO_PARAM

"Family"

FAMILY_USAGE_PSEUDO_PARAM

"Usage"

FAMILY_WPB_DEFAULT_ELEVATION

"Default Elevation"

FAMILY_LINE_LENGTH_PARAM

"Length"

FAMILY_ROUGH_WIDTH_PARAM

"Rough Width"

FAMILY_ROUGH_HEIGHT_PARAM

"Rough Height"

WINDOW_INSET

"Inset"

FAMILY_WINDOW_INSET_PARAM

"Inset"

WINDOW_THICKNESS

"Thickness"

GENERIC_THICKNESS

"Thickness"

FURNITURE_THICKNESS

"Thickness"

DOOR_THICKNESS

"Thickness"

FAMILY_THICKNESS_PARAM

"Thickness"

WINDOW_WIDTH

"Width"

GENERIC_WIDTH

"Width"

FURNITURE_WIDTH

"Width"

DOOR_WIDTH

"Width"

CASEWORK_WIDTH

"Width"

FAMILY_WIDTH_PARAM

"Width"

GENERIC_HEIGHT

"Height"

FURNITURE_HEIGHT

"Height"

DOOR_HEIGHT

"Height"

CASEWORK_HEIGHT

"Height"

FAMILY_HEIGHT_PARAM

"Height"

WINDOW_HEIGHT

"Height"

WINDOW_OPERATION_TYPE

"Operation"

DOOR_OPERATION_TYPE

"Operation"

DOOR_FRAME_MATERIAL

"Frame Material"

DOOR_FRAME_TYPE

"Frame Type"

GENERIC_FINISH

"Finish"

CURTAIN_WALL_PANELS_FINISH

"Finish"

CASEWORK_FINISH

"Finish"

DOOR_FINISH

"Finish"

WINDOW_CONSTRUCTION_TYPE

"Construction Type"

GENERIC_CONSTRUCTION_TYPE

"Construction Type"

CURTAIN_WALL_PANELS_CONSTRUCTION_TYPE

"Construction Type"

CASEWORK_CONSTRUCTION_TYPE

"Construction Type"

DOOR_CONSTRUCTION_TYPE

"Construction Type"

DOOR_FIRE_RATING

"Fire Rating"

ALL_MODEL_COST

"Cost"

DOOR_COST

"Cost"

ALL_MODEL_MARK

"Mark"

DOOR_NUMBER

"Mark"

DPART_ORIGINAL_CATEGORY_ID

"Original Category"

DPART_LAYER_CONSTRUCTION

"Construction"

DPART_PHASE_DEMOLISHED_BY_ORIGINAL

"Phase Demolished By Original"

DPART_PHASE_CREATED_BY_ORIGINAL

"Phase Created By Original"

DPART_LENGTH_COMPUTED

"Length"

DPART_HEIGHT_COMPUTED

"Height"

DPART_LAYER_WIDTH

"Thickness"

DPART_AREA_COMPUTED

"Area"

DPART_ORIGINAL_TYPE

"Original Type"

DPART_SHOW_SHAPE_HANDLES

"Show Shape Handles"

DPART_LAYER_FUNCTION

"Layer Function"

DPART_VOLUME_COMPUTED

"Volume"

DPART_MATERIAL_BY_ORIGINAL

"Material By Original"

DPART_MATERIAL_ID_PARAM

"Material"

DPART_ORIGINAL_FAMILY

"Original Family"

DPART_ORIGINAL_CATEGORY

"Original Category"

HOST_PANEL_SCHEDULE_AS_PANEL_PARAM

"Categorize as"

WALL_LOCATION_LINE_OFFSET_PARAM

"Location Line Offset"

WALL_KEY_REF_PARAM

"Location Line"

WALL_STRUCTURAL_USAGE_TEXT_PARAM

"Structural Usage"

MEASURE_FROM_STRUCTURE

"Extend into wall (to core)"

WALL_STRUCTURAL_USAGE_PARAM

"Structural Usage"

WALL_BOTTOM_IS_ATTACHED

"Base is Attached"

WALL_TOP_IS_ATTACHED

"Top is Attached"

WALL_TOP_OFFSET

"Top Offset"

WALL_BASE_OFFSET

"Base Offset"

WALL_BASE_CONSTRAINT

"Base Constraint"

WALL_USER_HEIGHT_PARAM

"Unconnected Height"

WALL_HEIGHT_TYPE

"Top Constraint"

WALL_BASE_HEIGHT_PARAM

"Base height"

ALLOW_AUTO_EMBED

"Automatically Embed"

WALL_ATTR_ROOM_BOUNDING

"Room Bounding"

FUNCTION_PARAM

"Function"

WALL_ATTR_DEFHEIGHT_PARAM

"Default height"

WALL_ATTR_HEIGHT_PARAM

"Height"

WALL_ATTR_WIDTH_PARAM

"Width"

INVALID

Remarks

The ID of the parameter can be used to retrieve property values from an Element by using the Element.Parameter property. The documentation for each ID includes the parameter name, as found in the Element Properties dialog in the English version of Autodesk Revit. Note that multiple distinct parameter ids may map to the same English name; in those case you must examine the parameters associated with a specific element to determine which parameter id to use.

See Also


BuiltInParameterGroup Enumeration

[image]

Revit 2013 API
BuiltInParameterGroup Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BuiltInParameterGroup
Visual Basic
Public Enumeration BuiltInParameterGroup
Visual C++
public enum class BuiltInParameterGroup

Members

Member name | Description
PG_SEGMENTS_FITTINGS |
PG_CONTINUOUSRAIL_END_TOP_EXTENSION |
PG_CONTINUOUSRAIL_BEGIN_BOTTOM_EXTENSION |
PG_STAIRS_WINDERS |
PG_STAIRS_SUPPORTS |
PG_STAIRS_OPEN_END_CONNECTION |
PG_RAILING_SYSTEM_SECONDARY_FAMILY_HANDRAILS |
PG_TERMINTATION |
PG_STAIRS_TREADS_RISERS |
PG_STAIRS_CALCULATOR_RULES |
PG_SPLIT_PROFILE_DIMENSIONS |
PG_LENGTH |
PG_NODES |
PG_ANALYTICAL_PROPERTIES |
PG_ANALYTICAL_ALIGNMENT |
PG_SYSTEMTYPE_RISEDROP |
PG_LINING |
PG_INSULATION |
PG_OVERALL_LEGEND |
PG_VISIBILITY |
PG_SUPPORT |
PG_RAILING_SYSTEM_SEGMENT_V_GRID |
PG_RAILING_SYSTEM_SEGMENT_U_GRID |
PG_RAILING_SYSTEM_SEGMENT_POSTS |
PG_RAILING_SYSTEM_SEGMENT_PATTERN_REMAINDER |
PG_RAILING_SYSTEM_SEGMENT_PATTERN_REPEAT |
PG_RAILING_SYSTEM_FAMILY_SEGMENT_PATTERN |
PG_RAILING_SYSTEM_FAMILY_HANDRAILS |
PG_RAILING_SYSTEM_FAMILY_TOP_RAIL |
PG_CONCEPTUAL_ENERGY_DATA_BUILDING_SERVICES |
PG_DATA |
PG_ELECTRICAL_CIRCUITING |
PG_GENERAL |
PG_FLEXIBLE |
PG_ENERGY_ANALYSIS_CONCEPTUAL_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_MODEL |
PG_ENERGY_ANALYSIS_DETAILED_AND_CONCEPTUAL_MODELS |
PG_FITTING |
PG_CONCEPTUAL_ENERGY_DATA |
PG_AREA |
PG_ADSK_MODEL_PROPERTIES |
PG_PATTERN_GRID_V |
PG_PATTERN_GRID_U |
PG_DISPLAY |
PG_ANALYSIS_RESULTS |
PG_SLAB_SHAPE_EDIT |
PG_LIGHT_PHOTOMETRICS |
PG_PATTERN_APPLICATION |
PG_GREEN_BUILDING |
PG_PROFILE_2 |
PG_PROFILE_1 |
PG_PROFILE |
PG_TRUSS_FAMILY_BOTTOM_CHORD |
PG_TRUSS_FAMILY_TOP_CHORD |
PG_TRUSS_FAMILY_DIAG_WEB |
PG_TRUSS_FAMILY_VERT_WEB |
PG_TITLE |
PG_FIRE_PROTECTION |
PG_ROTATION_ABOUT |
PG_TRANSLATION_IN |
PG_ANALYTICAL_MODEL |
PG_REBAR_ARRAY |
PG_REBAR_SYSTEM_LAYERS |
PG_ORIENTATION |
PG_PATTERN_GRID |
PG_PATTERN_MULLION_2 |
PG_PATTERN_MULLION_HORIZ |
PG_PATTERN_MULLION_1 |
PG_PATTERN_MULLION_VERT |
PG_PATTERN_GRID_2 |
PG_PATTERN_GRID_HORIZ |
PG_PATTERN_GRID_1 |
PG_PATTERN_GRID_VERT |
PG_IFC |
PG_AELECTRICAL |
PG_ENERGY_ANALYSIS |
PG_STRUCTURAL_ANALYSIS |
PG_MECHANICAL_AIRFLOW |
PG_MECHANICAL_LOADS |
PG_ELECTRICAL_LOADS |
PG_ELECTRICAL_LIGHTING |
PG_TEXT |
PG_VIEW_CAMERA |
PG_VIEW_EXTENTS |
PG_PATTERN |
PG_CONSTRAINTS |
PG_PHASING |
PG_MECHANICAL |
PG_STRUCTURAL |
PG_PLUMBING |
PG_ELECTRICAL |
PG_STAIR_STRINGERS |
PG_STAIR_RISERS |
PG_STAIR_TREADS |
PG_MATERIALS |
PG_GRAPHICS |
PG_CONSTRUCTION |
PG_GEOMETRY |
PG_IDENTITY_DATA |
INVALID |

Remarks

Parameter groups are used to sort parameters within the Element Properties dialog.

See Also


CADExportOptions Class

[image]

Revit 2013 API
CADExportOptions Class
Members See Also Send Feedback
Generic CAD Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CADExportOptions
Visual Basic
Public MustInherit Class CADExportOptions
Visual C++
public ref class CADExportOptions abstract

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..DWFExportOptions
Autodesk.Revit.DB..::..SATExportOptions

See Also

CADExportOptions Members


CADExportOptions Members

[image] [image]

Revit 2013 API
CADExportOptions Members
CADExportOptions Class Methods See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class


CADExportOptions Methods

[image] [image]

Revit 2013 API
CADExportOptions Methods
CADExportOptions Class See Also Send Feedback

The CADExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADExportOptions Class


CADLinkType Class

[image]

Revit 2013 API
CADLinkType Class
Members See Also Send Feedback
CADLinkType represents both CAD links and CAD imports. The function IsLink can be used to distinguish between the two. CAD imports are not ExternalFileReferences; they are brought completely into the document and maintain no connection to their original file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CADLinkType : ElementType
Visual Basic
Public Class CADLinkType _
    Inherits ElementType
Visual C++
public ref class CADLinkType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..CADLinkType

See Also

CADLinkType Members


CADLinkType Members

[image] [image]

Revit 2013 API
CADLinkType Members
CADLinkType Class Methods Properties See Also Send Feedback

The CADLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CADLinkType Class


CADLinkType Methods

[image] [image]

Revit 2013 API
CADLinkType Methods
CADLinkType Class See Also Send Feedback

The CADLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CADLinkType Class


CADLinkType Properties

[image] [image]

Revit 2013 API
CADLinkType Properties
CADLinkType Class See Also Send Feedback

The CADLinkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CADLinkType Class


Parameter Property

[image] [image]

Revit 2013 API
CADLinkType..::..Parameter Property
CADLinkType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CADLinkType Class
CADLinkType Members


Categories Class

[image]

Revit 2013 API
Categories Class
Members Example See Also Send Feedback
The Categories object is a map that contains all the top-level Category objects within the Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Categories : CategoryNameMap
Visual Basic
Public Class Categories _
    Inherits CategoryNameMap
Visual C++
public ref class Categories : public CategoryNameMap

Remarks

Use this object to retrieve categories by name or by BuiltInCategory id.

Examples

CopyC#
// Get settings of current document
Settings documentSettings = document.Settings;

// Get all categories of current document
Categories groups = documentSettings.Categories;

// Show the number of all the categories to the user
String prompt = "Number of all categories in current Revit document:" + groups.Size;

// get Floor category according to OST_Floors and show its name
Category floorCategory = groups.get_Item(BuiltInCategory.OST_Floors);
prompt += floorCategory.Name;

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get settings of current document
Dim documentSettings As Settings = document.Settings

' Get all categories of current document
Dim groups As Categories = documentSettings.Categories

' Show the number of all the categories to the user
Dim prompt As [String] = "Number of all categories in current Revit document:" + groups.Size

' get Floor category according to OST_Floors and show its name
Dim floorCategory As Category = groups.Item(BuiltInCategory.OST_Floors)
prompt += floorCategory.Name

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategoryNameMap
Autodesk.Revit.DB..::..Categories

See Also

Categories Members


Categories Members

[image] [image]

Revit 2013 API
Categories Members
Categories Class Methods Properties See Also Send Feedback

The Categories type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::..Contains(String).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..ForwardIterator()()()().)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..GetEnumerator()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::..Insert(String, Category).)
Public method | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::..ReverseIterator()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::..IsEmpty.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::..Size.)

See Also

Categories Class


Categories Methods

[image] [image]

Revit 2013 API
Categories Methods
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty. (Inherited from CategoryNameMap.)
Public method | Contains | Identifies if a category which has the specified name is in the list of top-level categories. (Overrides CategoryNameMap..::..Contains(String).)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map. (Inherited from CategoryNameMap.)
Public method | ForwardIterator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..ForwardIterator()()()().)
Public method | GetEnumerator | Retrieves a forward moving iterator to the map. (Overrides CategoryNameMap..::..GetEnumerator()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Inserts the specified category with the specified name into the map. (Overrides CategoryNameMap..::..Insert(String, Category).)
Public method | NewSubcategory | Add a new subcategory into the Autodesk Revit document.
Public method | ReverseIterator | Retrieves a backward moving iterator to the map. (Overrides CategoryNameMap..::..ReverseIterator()()()().)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Categories Class


Contains Method

[image]

Revit 2013 API
Categories..::..Contains Method
Categories Class See Also Send Feedback
Identifies if a category which has the specified name is in the list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Contains(
    string name
)
Visual Basic
Public Overrides Function Contains ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ name
) override

Parameters

name
Type: System..::..String
The name of the category to be retrieved.

Field Value

Whether the category exists in the list of top-level categories.

See Also

Categories Class


ForwardIterator Method

[image]

Revit 2013 API
Categories..::..ForwardIterator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override CategoryNameMapIterator ForwardIterator()
Visual Basic
Public Overrides Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator() override

Return Value

A forward moving iterator to the map.

See Also

Categories Class


GetEnumerator Method

[image]

Revit 2013 API
Categories..::..GetEnumerator Method
Categories Class See Also Send Feedback
Retrieves a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override IEnumerator GetEnumerator()
Visual Basic
Public Overrides Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() override

Return Value

A forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

Categories Class


Insert Method

[image]

Revit 2013 API
Categories..::..Insert Method
Categories Class See Also Send Feedback
Inserts the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Insert(
    string key,
    Category item
)
Visual Basic
Public Overrides Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
) override

Parameters

key
Type: System..::..String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::..Category
The category to be inserted into the map.

Return Value

Whether or not the category was inserted into the map.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Always thrown; this list is read only.

See Also

Categories Class


NewSubcategory Method

[image]

Revit 2013 API
Categories..::..NewSubcategory Method
Categories Class Example See Also Send Feedback
Add a new subcategory into the Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category NewSubcategory(
    Category parentCategory,
    string name
)
Visual Basic
Public Function NewSubcategory ( _
    parentCategory As Category, _
    name As String _
) As Category
Visual C++
public:
Category^ NewSubcategory(
    Category^ parentCategory,
    String^ name
)

Parameters

parentCategory
Type: Autodesk.Revit.DB..::..Category
The parent category.
name
Type: System..::..String
The new category name.

Return Value

If successful, the newly created subcategory.

Examples

CopyC#
public void AssignSubCategory(Document document, GenericForm extrusion)
{
    // create a new subcategory
    Category cat = document.OwnerFamily.FamilyCategory;
    Category subCat = document.Settings.Categories.NewSubcategory(cat, "NewSubCat");

    // create a new material and assign it to the subcategory
    ElementId materialId = Material.Create(document, "Wood Material");
    subCat.Material = document.GetElement(materialId) as Material;

    // assign the subcategory to the element
    extrusion.Subcategory = subCat;
}
CopyVB.NET
Public Sub AssignSubCategory(ByVal document As Document, ByVal extrusion As GenericForm)
    ' create a new subcategory
    Dim cat As Category = document.OwnerFamily.FamilyCategory
    Dim subCat As Category = document.Settings.Categories.NewSubcategory(cat, "NewSubCat")

    ' create a new material and assign it to the subcategory
    Dim woodMaterial As Material = Material.Create(document, "Wood Material")

    ' assign the subcategory to the element
    extrusion.Subcategory = subCat
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parentCategory" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parentCategory"-cannot add subcategory. Thrown when the input argument-"name"-is an illegal name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when subcategory creation failed.

See Also

Categories Class


ReverseIterator Method

[image]

Revit 2013 API
Categories..::..ReverseIterator Method
Categories Class See Also Send Feedback
Retrieves a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override CategoryNameMapIterator ReverseIterator()
Visual Basic
Public Overrides Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator() override

Return Value

A backward moving iterator to the map.

See Also

Categories Class


Categories Properties

[image] [image]

Revit 2013 API
Categories Properties
Categories Class See Also Send Feedback

The Categories type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Whether or not the list of top-level categories is empty. (Overrides CategoryNameMap..::..IsEmpty.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.
Public property | Size | The total number of top-level categories in the document. (Overrides CategoryNameMap..::..Size.)

See Also

Categories Class


IsEmpty Property

[image]

Revit 2013 API
Categories..::..IsEmpty Property
Categories Class See Also Send Feedback
Whether or not the list of top-level categories is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool IsEmpty { get; }
Visual Basic
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get () override;
}

See Also

Categories Class


Item Property

[image] [image]

Revit 2013 API
Categories..::..Item Property
Categories Class See Also Send Feedback
Retrieves a category object matching an identifier.

Overload List

 | Name | Description
Public property | Item[([( String])]) | Gets a category which has the specified name from this list of top-level categories. (Overrides CategoryNameMap..::..Item[([( String])]) .)
Public property | Item[([( BuiltInCategory])]) | Retrieves a category object corresponding to a BuiltInCategory id.

See Also

Categories Class
Categories Members


Item Property (String)

[image]

Revit 2013 API
Categories..::..Item Property (String)
Categories Class See Also Send Feedback
Gets a category which has the specified name from this list of top-level categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Category this[
    string name
] { get; set; }
Visual Basic
Public Overrides Property Item ( _
    name As String _
) As Category
    Get
    Set
Visual C++
public:
virtual property Category^ Item[String^ name] {
    Category^ get (String^ name) override;
    void set (String^ name, Category^ value) override;
}

Parameters

name
Type: System..::..String
The name of the category to be retrieved.

Field Value

The category with the specified name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the category list does not contain the category with this name. Thrown when trying to set an item to this list of categories; this list is read only.

See Also

Categories Class
Item Overload


Item Property (BuiltInCategory)

[image]

Revit 2013 API
Categories..::..Item Property (BuiltInCategory)
Categories Class See Also Send Feedback
Retrieves a category object corresponding to a BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Category this[
    BuiltInCategory categoryId
] { get; }
Visual Basic
Public Overridable ReadOnly Property Item ( _
    categoryId As BuiltInCategory _
) As Category
    Get
Visual C++
public:
virtual property Category^ Item[BuiltInCategory categoryId] {
    Category^ get (BuiltInCategory categoryId);
}

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory

Remarks

Unlike the method that obtains categories by name, this routine will obtain the handle even of built-in subcategories.

See Also

Categories Class
Item Overload


Size Property

[image]

Revit 2013 API
Categories..::..Size Property
Categories Class See Also Send Feedback
The total number of top-level categories in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int Size { get; }
Visual Basic
Public Overrides ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get () override;
}

See Also

Categories Class


Category Class

[image]

Revit 2013 API
Category Class
Members Example See Also Send Feedback
Represents the category or subcategory to which an element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Category : APIObject
Visual Basic
Public Class Category _
    Inherits APIObject
Visual C++
public ref class Category : public APIObject

Remarks

Categories are an import tool within Revit for identifying the inferred type of an element, such as anything in the Walls category should be considered as a wall. The API exposes access to the built in categories within Revit via the Document.Settings.Categories property.

Examples

CopyC#
Element selectedElement = null;
foreach (Element e in uidoc.Selection.Elements)
{
    selectedElement = e;
    break;  // just get one selected element
}

// Get the category instance from the Category property
Category category = selectedElement.Category;

BuiltInCategory enumCategory = (BuiltInCategory)category.Id.IntegerValue;

// Format the prompt string, which contains the category information
String prompt = "The category information of the selected element is: ";
prompt += "\n\tName:\t" + category.Name;   // Name information

prompt += "\n\tId:\t" + enumCategory.ToString();    // Id information
prompt += "\n\tParent:\t";
if (null == category.Parent)
{
    prompt += "No Parent Category";   // Parent information, it may be null
}
else
{
    prompt += category.Parent.Name;
}

prompt += "\n\tSubCategories:"; // SubCategories information,
CategoryNameMap subCategories = category.SubCategories;
if (null == subCategories || 0 == subCategories.Size) // It may be null or has no item in it
{
    prompt += "No SubCategories;";
}
else
{
    foreach (Category ii in subCategories)
    {
        prompt += "\n\t\t" + ii.Name;
    }
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
Dim selectedElement As Autodesk.Revit.DB.Element = Nothing
For Each e As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
    selectedElement = e
    ' just get one selected element
    Exit For
Next

' Get the category instance from the Category property
Dim category As Category = selectedElement.Category

Dim enumCategory As BuiltInCategory = DirectCast(category.Id.IntegerValue, BuiltInCategory)

' Format the prompt string, which contains the category information
Dim prompt As [String] = "The category information of the selected element is: "
prompt += vbLf & vbTab & "Name:" & vbTab + category.Name
' Name information
prompt += vbLf & vbTab & "Id:" & vbTab + enumCategory.ToString()
' Id information
prompt += vbLf & vbTab & "Parent:" & vbTab
If category.Parent Is Nothing Then
    ' Parent information, it may be null
    prompt += "No Parent Category"
Else
    prompt += category.Parent.Name
End If

prompt += vbLf & vbTab & "SubCategories:"
' SubCategories information,
Dim subCategories As CategoryNameMap = category.SubCategories
If subCategories Is Nothing OrElse 0 = subCategories.Size Then
    ' It may be null or has no item in it
    prompt += "No SubCategories;"
Else
    For Each ii As Category In subCategories
        prompt += vbLf & vbTab & vbTab + ii.Name
    Next
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Category

See Also

Category Members


Category Members

[image] [image]

Revit 2013 API
Category Members
Category Class Methods Properties See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.

See Also

Category Class


Category Methods

[image] [image]

Revit 2013 API
Category Methods
Category Class See Also Send Feedback

The Category type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGraphicsStyle | Gets the graphics style associated with this category for the given graphics style type.
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetLineWeight | Retrieves the line weight assigned to the category for the given graphics style type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLineWeight | Sets the line weight for the given graphics style type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Category Class


GetGraphicsStyle Method

[image]

Revit 2013 API
Category..::..GetGraphicsStyle Method
Category Class See Also Send Feedback
Gets the graphics style associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GraphicsStyle GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Function GetGraphicsStyle ( _
    graphicsStyleType As GraphicsStyleType _
) As GraphicsStyle
Visual C++
public:
GraphicsStyle^ GetGraphicsStyle(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


GetHashCode Method

[image]

Revit 2013 API
Category..::..GetHashCode Method
Category Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

Category Class


GetLineWeight Method

[image]

Revit 2013 API
Category..::..GetLineWeight Method
Category Class See Also Send Feedback
Retrieves the line weight assigned to the category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Function GetLineWeight ( _
    graphicsStyleType As GraphicsStyleType _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> GetLineWeight(
    GraphicsStyleType graphicsStyleType
)

Parameters

graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"graphicsStyleType"-is out of range.

See Also

Category Class


SetLineWeight Method

[image]

Revit 2013 API
Category..::..SetLineWeight Method
Category Class See Also Send Feedback
Sets the line weight for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Sub SetLineWeight ( _
    lineWeight As Integer, _
    graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLineWeight(
    int lineWeight,
    GraphicsStyleType graphicsStyleType
)

Parameters

lineWeight
Type: System..::..Int32
graphicsStyleType
Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"lineWeight" or "graphicsStyleType"-is out of range.

See Also

Category Class


Category Properties

[image] [image]

Revit 2013 API
Category Properties
Category Class See Also Send Feedback

The Category type exposes the following members.

Properties

 | Name | Description
Public property | AllowsBoundParameters | To check if the category can have project parameters.
Public property | AllowsVisibilityControl | Whether the visibility can be controlled by the user for this category in this view.
Public property | CanAddSubcategory | Indicates if subcategories can be assigned to the category.
Public property | HasMaterialQuantities | Identifies if elements of the category are able to report what materials they contain in what quantities.
Public property | Id | Returns the category id associated with the category object.
Public property | IsCuttable | Indicates if the category is cuttable or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | LineColor | The color of lines shown for elements of this category.
Public property | Material | Retrieves or changes the material of the category.
Public property | Name | The category name.
Public property | Parent | Returns the parent category of this category.
Public property | SubCategories | Returns a map containing all of the subcategories of this category.
Public property | Visible | Retrieves or changes the visibility of the category in the active view.

See Also

Category Class


AllowsBoundParameters Property

[image]

Revit 2013 API
Category..::..AllowsBoundParameters Property
Category Class See Also Send Feedback
To check if the category can have project parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AllowsBoundParameters { get; }
Visual Basic
Public ReadOnly Property AllowsBoundParameters As Boolean
    Get
Visual C++
public:
property bool AllowsBoundParameters {
    bool get ();
}

See Also

Category Class


AllowsVisibilityControl Property

[image]

Revit 2013 API
Category..::..AllowsVisibilityControl Property
Category Class See Also Send Feedback
Whether the visibility can be controlled by the user for this category in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    View view
] { get; }
Visual Basic
Public ReadOnly Property AllowsVisibilityControl ( _
    view As View _
) As Boolean
    Get
Visual C++
public:
property bool AllowsVisibilityControl[View^ view] {
    bool get (View^ view);
}

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where visibility control might be allowed.

Remarks

There are some categories in Revit that are hidden to users in the Object Styles and Visibility dialog. Their visibility cannot be controlled for a particular view. This property identifies if the category allows visibility control (and thus allows the Visible property to be set).

See Also

Category Class


CanAddSubcategory Property

[image]

Revit 2013 API
Category..::..CanAddSubcategory Property
Category Class See Also Send Feedback
Indicates if subcategories can be assigned to the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanAddSubcategory { get; }
Visual Basic
Public ReadOnly Property CanAddSubcategory As Boolean
    Get
Visual C++
public:
property bool CanAddSubcategory {
    bool get ();
}

See Also

Category Class


HasMaterialQuantities Property

[image]

Revit 2013 API
Category..::..HasMaterialQuantities Property
Category Class See Also Send Feedback
Identifies if elements of the category are able to report what materials they contain in what quantities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasMaterialQuantities { get; }
Visual Basic
Public ReadOnly Property HasMaterialQuantities As Boolean
    Get
Visual C++
public:
property bool HasMaterialQuantities {
    bool get ();
}

Remarks

Get materials via the Element' property Materials; Get quantities via methods GetMaterialArea and GetMaterialVolume.

See Also

Category Class


Id Property

[image]

Revit 2013 API
Category..::..Id Property
Category Class See Also Send Feedback
Returns the category id associated with the category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Category Class


IsCuttable Property

[image]

Revit 2013 API
Category..::..IsCuttable Property
Category Class See Also Send Feedback
Indicates if the category is cuttable or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCuttable { get; }
Visual Basic
Public ReadOnly Property IsCuttable As Boolean
    Get
Visual C++
public:
property bool IsCuttable {
    bool get ();
}

See Also

Category Class


LineColor Property

[image]

Revit 2013 API
Category..::..LineColor Property
Category Class See Also Send Feedback
The color of lines shown for elements of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color LineColor { get; set; }
Visual Basic
Public Property LineColor As Color
    Get
    Set
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

See Also

Category Class


Material Property

[image]

Revit 2013 API
Category..::..Material Property
Category Class See Also Send Feedback
Retrieves or changes the material of the category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Material Material { get; set; }
Visual Basic
Public Property Material As Material
    Get
    Set
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category does not have a material.

See Also

Category Class


Name Property

[image]

Revit 2013 API
Category..::..Name Property
Category Class See Also Send Feedback
The category name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

Category Class


Parent Property

[image]

Revit 2013 API
Category..::..Parent Property
Category Class See Also Send Feedback
Returns the parent category of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category Parent { get; }
Visual Basic
Public ReadOnly Property Parent As Category
    Get
Visual C++
public:
property Category^ Parent {
    Category^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if this category a not a subcategory

See Also

Category Class


SubCategories Property

[image]

Revit 2013 API
Category..::..SubCategories Property
Category Class See Also Send Feedback
Returns a map containing all of the subcategories of this category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategoryNameMap SubCategories { get; }
Visual Basic
Public ReadOnly Property SubCategories As CategoryNameMap
    Get
Visual C++
public:
property CategoryNameMap^ SubCategories {
    CategoryNameMap^ get ();
}

Return Value

An empty map if the category has no subcategories.

See Also

Category Class


Visible Property

[image]

Revit 2013 API
Category..::..Visible Property
Category Class See Also Send Feedback
Retrieves or changes the visibility of the category in the active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    View view
] { get; set; }
Visual Basic
Public Property Visible ( _
    view As View _
) As Boolean
    Get
    Set
Visual C++
public:
property bool Visible[View^ view] {
    bool get (View^ view);
    void set (View^ view, bool value);
}

Parameters

view
Type: Autodesk.Revit.DB..::..View
Check if the category is visible in this view.

See Also

Category Class


CategoryNameMap Class

[image]

Revit 2013 API
CategoryNameMap Class
Members See Also Send Feedback
A map that contains a mapping of category name to its category object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CategoryNameMap : APIObject,
    IEnumerable
Visual Basic
Public Class CategoryNameMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategoryNameMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategoryNameMap
Autodesk.Revit.DB..::..Categories

See Also

CategoryNameMap Members


CategoryNameMap Members

[image] [image]

Revit 2013 API
CategoryNameMap Members
CategoryNameMap Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMap type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryNameMap | Initializes a new instance of the CategoryNameMap class

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


CategoryNameMap Constructor

[image]

Revit 2013 API
CategoryNameMap Constructor
CategoryNameMap Class See Also Send Feedback
Initializes a new instance of the CategoryNameMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategoryNameMap()
Visual Basic
Public Sub New
Visual C++
public:
CategoryNameMap()

See Also

CategoryNameMap Class


CategoryNameMap Methods

[image] [image]

Revit 2013 API
CategoryNameMap Methods
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every category from the map, rendering it empty.
Public method | Contains | Tests for the existence of a category with that name within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a category with the specified name from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category with the specified name into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMap Class


Clear Method

[image]

Revit 2013 API
CategoryNameMap..::..Clear Method
CategoryNameMap Class See Also Send Feedback
Removes every category from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategoryNameMap Class


Contains Method

[image]

Revit 2013 API
CategoryNameMap..::..Contains Method
CategoryNameMap Class See Also Send Feedback
Tests for the existence of a category with that name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The category name to be searched for.

Return Value

The Contains method returns True if the name is within the map, otherwise False.

See Also

CategoryNameMap Class


Erase Method

[image]

Revit 2013 API
CategoryNameMap..::..Erase Method
CategoryNameMap Class See Also Send Feedback
Removes a category with the specified name from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::..String
The name of the category to be erased.

Return Value

The number of categories that were erased from the map.

See Also

CategoryNameMap Class


ForwardIterator Method

[image]

Revit 2013 API
CategoryNameMap..::..ForwardIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

CategoryNameMap Class


GetEnumerator Method

[image]

Revit 2013 API
CategoryNameMap..::..GetEnumerator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CategoryNameMap Class


Insert Method

[image]

Revit 2013 API
CategoryNameMap..::..Insert Method
CategoryNameMap Class See Also Send Feedback
Insert the specified category with the specified name into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Category item
)
Visual Basic
Public Overridable Function Insert ( _
    key As String, _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Category^ item
)

Parameters

key
Type: System..::..String
The name to be used for inserting the category into the map.
item
Type: Autodesk.Revit.DB..::..Category
The category to be inserted into the map.

Return Value

Returns whether the category was inserted into the map.

See Also

CategoryNameMap Class


ReverseIterator Method

[image]

Revit 2013 API
CategoryNameMap..::..ReverseIterator Method
CategoryNameMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CategoryNameMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CategoryNameMapIterator
Visual C++
public:
virtual CategoryNameMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

CategoryNameMap Class


CategoryNameMap Properties

[image] [image]

Revit 2013 API
CategoryNameMap Properties
CategoryNameMap Class See Also Send Feedback

The CategoryNameMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a category at a specified name within the map.
Public property | Size | Returns the number of categories that are in the map.

See Also

CategoryNameMap Class


IsEmpty Property

[image]

Revit 2013 API
CategoryNameMap..::..IsEmpty Property
CategoryNameMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

CategoryNameMap Class


Item Property

[image]

Revit 2013 API
CategoryNameMap..::..Item Property
CategoryNameMap Class See Also Send Feedback
Gets or sets a category at a specified name within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Category this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As Category
    Get
    Set
Visual C++
public:
virtual property Category^ Item[String^ key] {
    Category^ get (String^ key);
    void set (String^ key, Category^ value);
}

Parameters

key
Type: System..::..String
The name of the category to be set or retrieved.

Return Value

Returns the category at the specified name.

See Also

CategoryNameMap Class


Size Property

[image]

Revit 2013 API
CategoryNameMap..::..Size Property
CategoryNameMap Class See Also Send Feedback
Returns the number of categories that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategoryNameMap Class


CategoryNameMapIterator Class

[image]

Revit 2013 API
CategoryNameMapIterator Class
Members See Also Send Feedback
An iterator to a category name map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CategoryNameMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CategoryNameMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategoryNameMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategoryNameMapIterator

See Also

CategoryNameMapIterator Members


CategoryNameMapIterator Members

[image] [image]

Revit 2013 API
CategoryNameMapIterator Members
CategoryNameMapIterator Class Constructors Methods Properties See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CategoryNameMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Constructor

[image]

Revit 2013 API
CategoryNameMapIterator Constructor
CategoryNameMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategoryNameMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
CategoryNameMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Methods

[image] [image]

Revit 2013 API
CategoryNameMapIterator Methods
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategoryNameMapIterator Class


MoveNext Method

[image]

Revit 2013 API
CategoryNameMapIterator..::..MoveNext Method
CategoryNameMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


Reset Method

[image]

Revit 2013 API
CategoryNameMapIterator..::..Reset Method
CategoryNameMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategoryNameMapIterator Class


CategoryNameMapIterator Properties

[image] [image]

Revit 2013 API
CategoryNameMapIterator Properties
CategoryNameMapIterator Class See Also Send Feedback

The CategoryNameMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the category that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the category name that is the current focus of the iterator.

See Also

CategoryNameMapIterator Class


Current Property

[image]

Revit 2013 API
CategoryNameMapIterator..::..Current Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


Key Property

[image]

Revit 2013 API
CategoryNameMapIterator..::..Key Property
CategoryNameMapIterator Class See Also Send Feedback
Retrieves the category name that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

CategoryNameMapIterator Class


CategorySet Class

[image]

Revit 2013 API
CategorySet Class
Members See Also Send Feedback
A set that can contains Category objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CategorySet : APIObject,
    IEnumerable
Visual Basic
Public Class CategorySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CategorySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategorySet

See Also

CategorySet Members


CategorySet Members

[image] [image]

Revit 2013 API
CategorySet Members
CategorySet Class Constructors Methods Properties See Also Send Feedback

The CategorySet type exposes the following members.

Constructors

 | Name | Description
Public method | CategorySet | Initializes a new instance of the CategorySet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


CategorySet Constructor

[image]

Revit 2013 API
CategorySet Constructor
CategorySet Class See Also Send Feedback
Initializes a new instance of the CategorySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategorySet()
Visual Basic
Public Sub New
Visual C++
public:
CategorySet()

See Also

CategorySet Class


CategorySet Methods

[image] [image]

Revit 2013 API
CategorySet Methods
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of a category within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified category from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified category into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySet Class


Clear Method

[image]

Revit 2013 API
CategorySet..::..Clear Method
CategorySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CategorySet Class


Contains Method

[image]

Revit 2013 API
CategorySet..::..Contains Method
CategorySet Class See Also Send Feedback
Tests for the existence of a category within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Category item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The category to be searched for.

Return Value

The Contains method returns True if the category is within the set, otherwise False.

See Also

CategorySet Class


Erase Method

[image]

Revit 2013 API
CategorySet..::..Erase Method
CategorySet Class See Also Send Feedback
Removes a specified category from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Category item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Category _
) As Integer
Visual C++
public:
virtual int Erase(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The category to be erased.

Return Value

The number of items that were erased from the set.

See Also

CategorySet Class


ForwardIterator Method

[image]

Revit 2013 API
CategorySet..::..ForwardIterator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CategorySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CategorySet Class


GetEnumerator Method

[image]

Revit 2013 API
CategorySet..::..GetEnumerator Method
CategorySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CategorySet Class


Insert Method

[image]

Revit 2013 API
CategorySet..::..Insert Method
CategorySet Class See Also Send Feedback
Insert the specified category into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Category item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Category _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Category^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Category
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

CategorySet Class


ReverseIterator Method

[image]

Revit 2013 API
CategorySet..::..ReverseIterator Method
CategorySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CategorySetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CategorySetIterator
Visual C++
public:
virtual CategorySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CategorySet Class


CategorySet Properties

[image] [image]

Revit 2013 API
CategorySet Properties
CategorySet Class See Also Send Feedback

The CategorySet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of categories that are in the set.

See Also

CategorySet Class


IsEmpty Property

[image]

Revit 2013 API
CategorySet..::..IsEmpty Property
CategorySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CategorySet Class


Size Property

[image]

Revit 2013 API
CategorySet..::..Size Property
CategorySet Class See Also Send Feedback
Returns the number of categories that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CategorySet Class


CategorySetIterator Class

[image]

Revit 2013 API
CategorySetIterator Class
Members See Also Send Feedback
An iterator to a category set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CategorySetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CategorySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CategorySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CategorySetIterator

See Also

CategorySetIterator Members


CategorySetIterator Members

[image] [image]

Revit 2013 API
CategorySetIterator Members
CategorySetIterator Class Constructors Methods Properties See Also Send Feedback

The CategorySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CategorySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


CategorySetIterator Constructor

[image]

Revit 2013 API
CategorySetIterator Constructor
CategorySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategorySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CategorySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CategorySetIterator Class


CategorySetIterator Methods

[image] [image]

Revit 2013 API
CategorySetIterator Methods
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CategorySetIterator Class


MoveNext Method

[image]

Revit 2013 API
CategorySetIterator..::..MoveNext Method
CategorySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CategorySetIterator Class


Reset Method

[image]

Revit 2013 API
CategorySetIterator..::..Reset Method
CategorySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CategorySetIterator Class


CategorySetIterator Properties

[image] [image]

Revit 2013 API
CategorySetIterator Properties
CategorySetIterator Class See Also Send Feedback

The CategorySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CategorySetIterator Class


Current Property

[image]

Revit 2013 API
CategorySetIterator..::..Current Property
CategorySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CategorySetIterator Class


Ceiling Class

[image]

Revit 2013 API
Ceiling Class
Members See Also Send Feedback
Represents a ceiling in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Ceiling : CeilingAndFloor
Visual Basic
Public Class Ceiling _
    Inherits CeilingAndFloor
Visual C++
public ref class Ceiling : public CeilingAndFloor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Ceiling

See Also

Ceiling Members


Ceiling Members

[image] [image]

Revit 2013 API
Ceiling Members
Ceiling Class Methods Properties See Also Send Feedback

The Ceiling type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Ceiling Class


Ceiling Methods

[image] [image]

Revit 2013 API
Ceiling Methods
Ceiling Class See Also Send Feedback

The Ceiling type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ceiling Class


Ceiling Properties

[image] [image]

Revit 2013 API
Ceiling Properties
Ceiling Class See Also Send Feedback

The Ceiling type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Ceiling Class


Parameter Property

[image] [image]

Revit 2013 API
Ceiling..::..Parameter Property
Ceiling Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Ceiling Class
Ceiling Members


CeilingAndFloor Class

[image]

Revit 2013 API
CeilingAndFloor Class
Members See Also Send Feedback
A base class that provides support for all ceiling and floor objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CeilingAndFloor : HostObject
Visual Basic
Public Class CeilingAndFloor _
    Inherits HostObject
Visual C++
public ref class CeilingAndFloor : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Ceiling
Autodesk.Revit.DB..::..Floor

See Also

CeilingAndFloor Members


CeilingAndFloor Members

[image] [image]

Revit 2013 API
CeilingAndFloor Members
CeilingAndFloor Class Methods Properties See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingAndFloor Class


CeilingAndFloor Methods

[image] [image]

Revit 2013 API
CeilingAndFloor Methods
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CeilingAndFloor Class


CeilingAndFloor Properties

[image] [image]

Revit 2013 API
CeilingAndFloor Properties
CeilingAndFloor Class See Also Send Feedback

The CeilingAndFloor type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingAndFloor Class


Parameter Property

[image] [image]

Revit 2013 API
CeilingAndFloor..::..Parameter Property
CeilingAndFloor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CeilingAndFloor Class
CeilingAndFloor Members


CeilingType Class

[image]

Revit 2013 API
CeilingType Class
Members See Also Send Feedback
Represents a ceiling type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CeilingType : HostObjAttributes
Visual Basic
Public Class CeilingType _
    Inherits HostObjAttributes
Visual C++
public ref class CeilingType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..CeilingType

See Also

CeilingType Members


CeilingType Members

[image] [image]

Revit 2013 API
CeilingType Members
CeilingType Class Methods Properties See Also Send Feedback

The CeilingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the CeilingType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingType Class


CeilingType Methods

[image] [image]

Revit 2013 API
CeilingType Methods
CeilingType Class See Also Send Feedback

The CeilingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CeilingType Class


CeilingType Properties

[image] [image]

Revit 2013 API
CeilingType Properties
CeilingType Class See Also Send Feedback

The CeilingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the CeilingType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CeilingType Class


Parameter Property

[image] [image]

Revit 2013 API
CeilingType..::..Parameter Property
CeilingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CeilingType Class
CeilingType Members


ThermalProperties Property

[image]

Revit 2013 API
CeilingType..::..ThermalProperties Property
CeilingType Class See Also Send Feedback
The calculated and settable thermal properties of the CeilingType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The ceiling does not have thermal properties.

See Also

CeilingType Class


CellType Enumeration

[image]

Revit 2013 API
CellType Enumeration
See Also Send Feedback
Declares the cell data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum CellType
Visual Basic
Public Enumeration CellType
Visual C++
public enum class CellType

Members

Member name | Description
Text | Simple text
Graphic | Embedded graphic
Parameter | Data bound parameter
Inherited | the type is inherited from the column or section if appropriate
CombinedParameter | the type is combined parameter
CalculatedValue | the type is a calculated value

See Also


ChangePriority Enumeration

[image]

Revit 2013 API
ChangePriority Enumeration
See Also Send Feedback
Enum used to specify the priority of an Updater during execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ChangePriority
Visual Basic
Public Enumeration ChangePriority
Visual C++
public enum class ChangePriority

Members

Member name | Description
GridsLevelsReferencePlanes | Updater will modify core datums and major reference planes
Masses | Updater will modify masses
FloorsRoofsStructuralWalls | Updater will modify exterior shell of the building or floor slabs
Structure | Updater will modify structural elements like beams, braces, columns and trusses
InteriorWalls | Updater will modify interior/partition walls
DoorsOpeningsWindows | Updater will modify family instances that cut their hosts like doors and windows
MEPFixtures | Updater will modify MEP fixtures such as lights, sinks, equipment, etc.
RoomsSpacesZones | Updater will modify Rooms, MEP spaces or zones
MEPCalculations | Updater will update MEP calculated values
FreeStandingComponents | Updater will modify standalone components
Connections | Updater will modify connections
Rebar | Updater will modify rebar
MEPAccessoriesFittingsSegmentsWires | Updater will modify MEP elements such as segments, fittings and wires
MEPSystems | Updater will modify MEP systems or circuits
Views | Updater will modify views
DetailComponents | Updater will modify detail components and symbolic lines
Annotations | Updater will modify annotations

Remarks

The enumeration values are ordered in the order in which updaters associated to each priority will be run. For example, updaters associated to priority GridsLevelsReferencePlanes will run first, while updaters associated to priority Annotations will run last.

See Also


ChangeType Class

[image]

Revit 2013 API
ChangeType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ChangeType : IDisposable
Visual Basic
Public Class ChangeType _
    Implements IDisposable
Visual C++
public ref class ChangeType : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ChangeType

See Also

ChangeType Members


ChangeType Members

[image] [image]

Revit 2013 API
ChangeType Members
ChangeType Class Methods See Also Send Feedback

The ChangeType type exposes the following members.

Methods

 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose | Releases all resources used by the ChangeType
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeType Class


ChangeType Methods

[image] [image]

Revit 2013 API
ChangeType Methods
ChangeType Class See Also Send Feedback

The ChangeType type exposes the following members.

Methods

 | Name | Description
 | ConcatenateChangeTypes | Creates a ChangeType that is a union of the two input ChangeTypes
Public method | Contains | Checks whether this ChangeType contains the input ChangeType
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsIdentical | Compares if two ChangeTypes are identical
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChangeType Class


ConcatenateChangeTypes Method

[image]

Revit 2013 API
ChangeType..::..ConcatenateChangeTypes Method
ChangeType Class See Also Send Feedback
Creates a ChangeType that is a union of the two input ChangeTypes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ChangeType ConcatenateChangeTypes(
    ChangeType changeType1,
    ChangeType changeType2
)
Visual Basic
Public Shared Function ConcatenateChangeTypes ( _
    changeType1 As ChangeType, _
    changeType2 As ChangeType _
) As ChangeType
Visual C++
public:
static ChangeType^ ConcatenateChangeTypes(
    ChangeType^ changeType1,
    ChangeType^ changeType2
)

Parameters

changeType1
Type: Autodesk.Revit.DB..::..ChangeType
First input ChangeType to be concatenated
changeType2
Type: Autodesk.Revit.DB..::..ChangeType
Second input ChangeType to be concatenated

Return Value

A new ChangeType that is a concatenation/union of the input change types

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


Contains Method

[image]

Revit 2013 API
ChangeType..::..Contains Method
ChangeType Class See Also Send Feedback
Checks whether this ChangeType contains the input ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Contains(
    ChangeType changeType
)
Visual Basic
Public Function Contains ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool Contains(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::..ChangeType

Return Value

True if input changeType is contained by this ChangeType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


Dispose Method

[image]

Revit 2013 API
ChangeType..::..Dispose Method
ChangeType Class See Also Send Feedback
Releases all resources used by the ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ChangeType Class


IsIdentical Method

[image]

Revit 2013 API
ChangeType..::..IsIdentical Method
ChangeType Class See Also Send Feedback
Compares if two ChangeTypes are identical

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsIdentical(
    ChangeType changeType
)
Visual Basic
Public Function IsIdentical ( _
    changeType As ChangeType _
) As Boolean
Visual C++
public:
bool IsIdentical(
    ChangeType^ changeType
)

Parameters

changeType
Type: Autodesk.Revit.DB..::..ChangeType
Input ChangeType to be compared

Return Value

True if the this ChangeType and input ChangeType are identical

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ChangeType Class


CheckoutStatus Enumeration

[image]

Revit 2013 API
CheckoutStatus Enumeration
See Also Send Feedback
Indicates the ownership status of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum CheckoutStatus
Visual Basic
Public Enumeration CheckoutStatus
Visual C++
public enum class CheckoutStatus

Members

Member name | Description
OwnedByCurrentUser | The element is owned by the current user.
OwnedByOtherUser | The element is owned by some user other than the current user.
NotOwned | The element is not owned by any user.

See Also


City Class

[image]

Revit 2013 API
City Class
Members Example See Also Send Feedback
An object that contains geographical location information for a known city.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class City : APIObject
Visual Basic
Public Class City _
    Inherits APIObject
Visual C++
public ref class City : public APIObject

Remarks

This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.

Examples

CopyC#
double angleRatio = Math.PI / 180;   // ratio of Angle

// Get the Latitude information
double latiude = city.Latitude / angleRatio;
String latiudeInfo = "Latitude:      " + latiude.ToString();

// Get the Longitude information
double longitude = city.Longitude / angleRatio;
String longitudeInfo = "Longitude:   " + longitude.ToString();

// Get the TimeZone information
String timeZoneInfo = "TimeZone:   " + city.TimeZone.ToString();

// Set the information text box.
string cityInfo = latiudeInfo + "\n" + longitudeInfo
                            + "\n" + timeZoneInfo;
CopyVB.NET
Dim angleRatio As Double = Math.PI / 180
' ratio of Angle
' Get the Latitude information
Dim latiude As Double = city.Latitude / angleRatio
Dim latiudeInfo As [String] = "Latitude:      " + latiude.ToString()

' Get the Longitude information
Dim longitude As Double = city.Longitude / angleRatio
Dim longitudeInfo As [String] = "Longitude:   " + longitude.ToString()

' Get the TimeZone information
Dim timeZoneInfo As [String] = "TimeZone:   " + city.TimeZone.ToString()

' Set the information text box.
Dim cityInfo As String = latiudeInfo + vbLf + longitudeInfo + vbLf + timeZoneInfo

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..City

See Also

City Members


City Members

[image] [image]

Revit 2013 API
City Members
City Class Methods Properties See Also Send Feedback

The City type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station

See Also

City Class


City Methods

[image] [image]

Revit 2013 API
City Methods
City Class See Also Send Feedback

The City type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

City Class


City Properties

[image] [image]

Revit 2013 API
City Properties
City Class See Also Send Feedback

The City type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Latitude | Latitude of the city
Public property | Longitude | Longitude of the city
Public property | Name | The name of the city
Public property | TimeZone | Time-zone in which the city resides
Public property | WeatherStation | An identifier for the nearest weather station

See Also

City Class


Latitude Property

[image]

Revit 2013 API
City..::..Latitude Property
City Class See Also Send Feedback
Latitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Latitude { get; }
Visual Basic
Public ReadOnly Property Latitude As Double
    Get
Visual C++
public:
property double Latitude {
    double get ();
}

Remarks

A read only property that contains the latitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class


Longitude Property

[image]

Revit 2013 API
City..::..Longitude Property
City Class See Also Send Feedback
Longitude of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Longitude { get; }
Visual Basic
Public ReadOnly Property Longitude As Double
    Get
Visual C++
public:
property double Longitude {
    double get ();
}

Remarks

A read only property that contains the longitude of the city. The value returned is in radians, ranging from -PI to +PI.

See Also

City Class


Name Property

[image]

Revit 2013 API
City..::..Name Property
City Class See Also Send Feedback
The name of the city

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

A read only string property that contains the name of the city, such as Boston.

See Also

City Class


TimeZone Property

[image]

Revit 2013 API
City..::..TimeZone Property
City Class See Also Send Feedback
Time-zone in which the city resides

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TimeZone { get; }
Visual Basic
Public ReadOnly Property TimeZone As Double
    Get
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

A read only property that returns the time zone in which the city resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

City Class


WeatherStation Property

[image]

Revit 2013 API
City..::..WeatherStation Property
City Class See Also Send Feedback
An identifier for the nearest weather station

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string WeatherStation { get; }
Visual Basic
Public ReadOnly Property WeatherStation As String
    Get
Visual C++
public:
property String^ WeatherStation {
    String^ get ();
}

Remarks

A read only string property that contains an identifier of the nearest weather station.

See Also

City Class


CitySet Class

[image]

Revit 2013 API
CitySet Class
Members See Also Send Feedback
An set that contains cities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CitySet : APIObject, IEnumerable
Visual Basic
Public Class CitySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CitySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CitySet

See Also

CitySet Members


CitySet Members

[image] [image]

Revit 2013 API
CitySet Members
CitySet Class Constructors Methods Properties See Also Send Feedback

The CitySet type exposes the following members.

Constructors

 | Name | Description
Public method | CitySet | Initializes a new instance of the CitySet class

Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet Class


CitySet Constructor

[image]

Revit 2013 API
CitySet Constructor
CitySet Class See Also Send Feedback
Initializes a new instance of the CitySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CitySet()
Visual Basic
Public Sub New
Visual C++
public:
CitySet()

See Also

CitySet Class


CitySet Methods

[image] [image]

Revit 2013 API
CitySet Methods
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every city from the set, rendering it empty.
Public method | Contains | Tests for the existence of a city within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified city from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified city into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySet Class


Clear Method

[image]

Revit 2013 API
CitySet..::..Clear Method
CitySet Class See Also Send Feedback
Removes every city from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CitySet Class


Contains Method

[image]

Revit 2013 API
CitySet..::..Contains Method
CitySet Class See Also Send Feedback
Tests for the existence of a city within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    City item
)
Visual Basic
Public Overridable Function Contains ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Contains(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..City
The city to be searched for.

Return Value

The Contains method returns True if the city is within the set, otherwise False.

See Also

CitySet Class


Erase Method

[image]

Revit 2013 API
CitySet..::..Erase Method
CitySet Class See Also Send Feedback
Removes a specified city from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    City item
)
Visual Basic
Public Overridable Function Erase ( _
    item As City _
) As Integer
Visual C++
public:
virtual int Erase(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..City
The city to be erased.

Return Value

The number of cities that were erased from the set.

See Also

CitySet Class


ForwardIterator Method

[image]

Revit 2013 API
CitySet..::..ForwardIterator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CitySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CitySet Class


GetEnumerator Method

[image]

Revit 2013 API
CitySet..::..GetEnumerator Method
CitySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CitySet Class


Insert Method

[image]

Revit 2013 API
CitySet..::..Insert Method
CitySet Class See Also Send Feedback
Insert the specified city into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    City item
)
Visual Basic
Public Overridable Function Insert ( _
    item As City _
) As Boolean
Visual C++
public:
virtual bool Insert(
    City^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..City
The city to be inserted into the set.

Return Value

Returns whether the city was inserted into the set.

See Also

CitySet Class


ReverseIterator Method

[image]

Revit 2013 API
CitySet..::..ReverseIterator Method
CitySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CitySetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CitySetIterator
Visual C++
public:
virtual CitySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CitySet Class


CitySet Properties

[image] [image]

Revit 2013 API
CitySet Properties
CitySet Class See Also Send Feedback

The CitySet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of cities that are in the set.

See Also

CitySet Class


IsEmpty Property

[image]

Revit 2013 API
CitySet..::..IsEmpty Property
CitySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CitySet Class


Size Property

[image]

Revit 2013 API
CitySet..::..Size Property
CitySet Class See Also Send Feedback
Returns the number of cities that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CitySet Class


CitySetIterator Class

[image]

Revit 2013 API
CitySetIterator Class
Members See Also Send Feedback
An iterator to a city set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CitySetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CitySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CitySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CitySetIterator

See Also

CitySetIterator Members


CitySetIterator Members

[image] [image]

Revit 2013 API
CitySetIterator Members
CitySetIterator Class Constructors Methods Properties See Also Send Feedback

The CitySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CitySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


CitySetIterator Constructor

[image]

Revit 2013 API
CitySetIterator Constructor
CitySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CitySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CitySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CitySetIterator Class


CitySetIterator Methods

[image] [image]

Revit 2013 API
CitySetIterator Methods
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CitySetIterator Class


MoveNext Method

[image]

Revit 2013 API
CitySetIterator..::..MoveNext Method
CitySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CitySetIterator Class


Reset Method

[image]

Revit 2013 API
CitySetIterator..::..Reset Method
CitySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CitySetIterator Class


CitySetIterator Properties

[image] [image]

Revit 2013 API
CitySetIterator Properties
CitySetIterator Class See Also Send Feedback

The CitySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CitySetIterator Class


Current Property

[image]

Revit 2013 API
CitySetIterator..::..Current Property
CitySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CitySetIterator Class


Color Class

[image]

Revit 2013 API
Color Class
Members See Also Send Feedback
Represents a color in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Color : APIObject
Visual Basic
Public Class Color _
    Inherits APIObject
Visual C++
public ref class Color : public APIObject

Remarks

Colors obtained from some API methods may represent an uninitialized/invalid color. You can identify these using the IsValid property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Color

See Also

Color Members


Color Members

[image] [image]

Revit 2013 API
Color Members
Color Class Constructors Methods Properties See Also Send Feedback

The Color type exposes the following members.

Constructors

 | Name | Description
Public method | Color | Constructor that takes the red, green and blue channels of the color.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Blue | Get or set the blue channel of the color.
Public property | Green | Get or set the green channel of the color.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get or set the red channel of the color.

See Also

Color Class


Color Constructor

[image]

Revit 2013 API
Color Constructor
Color Class See Also Send Feedback
Constructor that takes the red, green and blue channels of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color(
    byte red,
    byte green,
    byte blue
)
Visual Basic
Public Sub New ( _
    red As Byte, _
    green As Byte, _
    blue As Byte _
)
Visual C++
public:
Color(
    unsigned char red,
    unsigned char green,
    unsigned char blue
)

Parameters

red
Type: System..::..Byte
The red channel of the color that ranges from 0 to 255.
green
Type: System..::..Byte
The green channel of the color that ranges from 0 to 255.
blue
Type: System..::..Byte
The blue channel of the color that ranges from 0 to 255.

See Also

Color Class


Color Methods

[image] [image]

Revit 2013 API
Color Methods
Color Class See Also Send Feedback

The Color type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Color Class


Color Properties

[image] [image]

Revit 2013 API
Color Properties
Color Class See Also Send Feedback

The Color type exposes the following members.

Properties

 | Name | Description
Public property | Blue | Get or set the blue channel of the color.
Public property | Green | Get or set the green channel of the color.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsValid | Identifies if the color represents a valid color, or an uninitialized/invalid value.
Public property | Red | Get or set the red channel of the color.

See Also

Color Class


Blue Property

[image]

Revit 2013 API
Color..::..Blue Property
Color Class See Also Send Feedback
Get or set the blue channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public byte Blue { get; set; }
Visual Basic
Public Property Blue As Byte
    Get
    Set
Visual C++
public:
property unsigned char Blue {
    unsigned char get ();
    void set (unsigned char value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When getting the value: the color is invalid or uninitialized. When setting the value: the color is read-only.

See Also

Color Class


Green Property

[image]

Revit 2013 API
Color..::..Green Property
Color Class See Also Send Feedback
Get or set the green channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public byte Green { get; set; }
Visual Basic
Public Property Green As Byte
    Get
    Set
Visual C++
public:
property unsigned char Green {
    unsigned char get ();
    void set (unsigned char value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When getting the value: the color is invalid or uninitialized. When setting the value: the color is read-only.

See Also

Color Class


IsValid Property

[image]

Revit 2013 API
Color..::..IsValid Property
Color Class See Also Send Feedback
Identifies if the color represents a valid color, or an uninitialized/invalid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

Color Class


Red Property

[image]

Revit 2013 API
Color..::..Red Property
Color Class See Also Send Feedback
Get or set the red channel of the color.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public byte Red { get; set; }
Visual Basic
Public Property Red As Byte
    Get
    Set
Visual C++
public:
property unsigned char Red {
    unsigned char get ();
    void set (unsigned char value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When getting the value: the color is invalid or uninitialized. When setting the value: the color is read-only.

See Also

Color Class


ColorBackgroundSettings Class

[image]

Revit 2013 API
ColorBackgroundSettings Class
Members See Also Send Feedback
Represents the rendering color background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ColorBackgroundSettings : BackgroundSettings
Visual Basic
Public Class ColorBackgroundSettings _
    Inherits BackgroundSettings
Visual C++
public ref class ColorBackgroundSettings : public BackgroundSettings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BackgroundSettings
Autodesk.Revit.DB..::..ColorBackgroundSettings

See Also

ColorBackgroundSettings Members


ColorBackgroundSettings Members

[image] [image]

Revit 2013 API
ColorBackgroundSettings Members
ColorBackgroundSettings Class Methods Properties See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | The color of the rendering background.

See Also

ColorBackgroundSettings Class


ColorBackgroundSettings Methods

[image] [image]

Revit 2013 API
ColorBackgroundSettings Methods
ColorBackgroundSettings Class See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorBackgroundSettings Class


ColorBackgroundSettings Properties

[image] [image]

Revit 2013 API
ColorBackgroundSettings Properties
ColorBackgroundSettings Class See Also Send Feedback

The ColorBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | Color | The color of the rendering background.

See Also

ColorBackgroundSettings Class


Color Property

[image]

Revit 2013 API
ColorBackgroundSettings..::..Color Property
ColorBackgroundSettings Class See Also Send Feedback
The color of the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ColorBackgroundSettings Class


ColorDepthType Enumeration

[image]

Revit 2013 API
ColorDepthType Enumeration
See Also Send Feedback
An enumerated type listing all Color Depth types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ColorDepthType
Visual Basic
Public Enumeration ColorDepthType
Visual C++
public enum class ColorDepthType

Members

Member name | Description
BlackLine | The type of Color Depth is Black Line.
GrayScale | The type of Color Depth is Gray Scale.
Color | The type of Color Depth is Color.

See Also


ColumnAttachment Class

[image]

Revit 2013 API
ColumnAttachment Class
Members See Also Send Feedback
An object representing the attachment of the top or bottom of a column to some target: a floor, roof, ceiling, beam, or brace.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ColumnAttachment : IDisposable
Visual Basic
Public Class ColumnAttachment _
    Implements IDisposable
Visual C++
public ref class ColumnAttachment : IDisposable

Remarks

Call IsValidColumn() and IsValidTarget() to verify that specific elements support column attachments. A column has at most one top attachment and one bottom attachment.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ColumnAttachment

See Also

ColumnAttachment Members


ColumnAttachment Members

[image] [image]

Revit 2013 API
ColumnAttachment Members
ColumnAttachment Class Methods Properties See Also Send Feedback

The ColumnAttachment type exposes the following members.

Methods

 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose | Releases all resources used by the ColumnAttachment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttachOffset |
Public property | BaseOrTop |
Public property | CutStyle |
Public property | Justification |
Public property | TargetId |

See Also

ColumnAttachment Class


ColumnAttachment Methods

[image] [image]

Revit 2013 API
ColumnAttachment Methods
ColumnAttachment Class See Also Send Feedback

The ColumnAttachment type exposes the following members.

Methods

 | Name | Description
 | AddColumnAttachment | Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
 | GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidColumn | Says whether a FamilyInstance supports column attachments.
 | IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
 | IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.
 | RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
 | RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.
Public method | SetJustification |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnAttachment Class


AddColumnAttachment Method

[image]

Revit 2013 API
ColumnAttachment..::..AddColumnAttachment Method
ColumnAttachment Class See Also Send Feedback
Attaches the column to the target. If an attachment already exists with the same "baseOrTop" value, no attachment is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void AddColumnAttachment(
    Document doc,
    FamilyInstance column,
    Element target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)
Visual Basic
Public Shared Sub AddColumnAttachment ( _
    doc As Document, _
    column As FamilyInstance, _
    target As Element, _
    baseOrTop As Integer, _
    cutColumnStyle As ColumnAttachmentCutStyle, _
    justification As ColumnAttachmentJustification, _
    attachOffset As Double _
)
Visual C++
public:
static void AddColumnAttachment(
    Document^ doc,
    FamilyInstance^ column,
    Element^ target,
    int baseOrTop,
    ColumnAttachmentCutStyle cutColumnStyle,
    ColumnAttachmentJustification justification,
    double attachOffset
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing column and target.
column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
target
Type: Autodesk.Revit.DB..::..Element
A target element.
baseOrTop
Type: System..::..Int32
0 to attach the column base, 1 to attach the column top.
cutColumnStyle
Type: Autodesk.Revit.DB..::..ColumnAttachmentCutStyle
Control the handling of columns that intersect their targets.
justification
Type: Autodesk.Revit.DB..::..ColumnAttachmentJustification
Control the column extent in cases where the target is not a uniform height.
attachOffset
Type: System..::..Double
An additional offset for the bottom. If positive, the column base or top will be higher than the attachment point; if negative, lower.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | column is not a column that supports ColumnAttachments. -or- target is not a valid target for ColumnAttachments. -or- column already has an attachment at its base or top as specified by baseOrTop. -or- column already has an attachment to target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1. -or- The given value for attachOffset must be no more than 30000 feet in absolute value.

See Also

ColumnAttachment Class


Dispose Method

[image]

Revit 2013 API
ColumnAttachment..::..Dispose Method
ColumnAttachment Class See Also Send Feedback
Releases all resources used by the ColumnAttachment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ColumnAttachment Class


GetColumnAttachment Method

[image] [image]

Revit 2013 API
ColumnAttachment..::..GetColumnAttachment Method
ColumnAttachment Class See Also Send Feedback

Overload List

Name | Description
GetColumnAttachment(FamilyInstance, ElementId) | Look up a column attachment by specifying the target id.
GetColumnAttachment(FamilyInstance, Int32) | Look up a column attachment. There is at most one attachment on the base and one on the top.

See Also

ColumnAttachment Class
ColumnAttachment Members


GetColumnAttachment Method (FamilyInstance, ElementId)

[image]

Revit 2013 API
ColumnAttachment..::..GetColumnAttachment Method (FamilyInstance, ElementId)
ColumnAttachment Class See Also Send Feedback
Look up a column attachment by specifying the target id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Visual Basic
Public Shared Function GetColumnAttachment ( _
    column As FamilyInstance, _
    targetId As ElementId _
) As ColumnAttachment
Visual C++
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
targetId
Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.

Return Value

The column attachment attaching the column to the target, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no such attachment.

Remarks

May return either a top or base attachment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
GetColumnAttachment Overload


GetColumnAttachment Method (FamilyInstance, Int32)

[image]

Revit 2013 API
ColumnAttachment..::..GetColumnAttachment Method (FamilyInstance, Int32)
ColumnAttachment Class See Also Send Feedback
Look up a column attachment. There is at most one attachment on the base and one on the top.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ColumnAttachment GetColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Visual Basic
Public Shared Function GetColumnAttachment ( _
    column As FamilyInstance, _
    baseOrTop As Integer _
) As ColumnAttachment
Visual C++
public:
static ColumnAttachment^ GetColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
baseOrTop
Type: System..::..Int32
0 for base, 1 for top.

Return Value

The column attachment for the base or top of the column, or nullNothingnullptra null reference (Nothing in Visual Basic) if that end of the column is unattached.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.

See Also

ColumnAttachment Class
GetColumnAttachment Overload


IsValidColumn Method

[image]

Revit 2013 API
ColumnAttachment..::..IsValidColumn Method
ColumnAttachment Class See Also Send Feedback
Says whether a FamilyInstance supports column attachments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidColumn(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function IsValidColumn ( _
    familyInstance As FamilyInstance _
) As Boolean
Visual C++
public:
static bool IsValidColumn(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.

Remarks

In-place columns do not support attachments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class


IsValidTarget Method

[image] [image]

Revit 2013 API
ColumnAttachment..::..IsValidTarget Method
ColumnAttachment Class See Also Send Feedback

Overload List

Name | Description
IsValidTarget(Boolean, Element) | Says whether the element can be used as a target for a new attachment.
IsValidTarget(FamilyInstance, Element) | Says whether the element can be used as a target for a new attachment.

See Also

ColumnAttachment Class
ColumnAttachment Members


IsValidTarget Method (Boolean, Element)

[image]

Revit 2013 API
ColumnAttachment..::..IsValidTarget Method (Boolean, Element)
ColumnAttachment Class See Also Send Feedback
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidTarget(
    bool forSlantedColumn,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    forSlantedColumn As Boolean, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    bool forSlantedColumn,
    Element^ target
)

Parameters

forSlantedColumn
Type: System..::..Boolean
If true, check whether the target is valid for a slanted column; if false, check whether the target is valid for a vertical column.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, ceilings, levels. Beams and braces are valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
IsValidTarget Overload


IsValidTarget Method (FamilyInstance, Element)

[image]

Revit 2013 API
ColumnAttachment..::..IsValidTarget Method (FamilyInstance, Element)
ColumnAttachment Class See Also Send Feedback
Says whether the element can be used as a target for a new attachment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidTarget(
    FamilyInstance column,
    Element target
)
Visual Basic
Public Shared Function IsValidTarget ( _
    column As FamilyInstance, _
    target As Element _
) As Boolean
Visual C++
public:
static bool IsValidTarget(
    FamilyInstance^ column,
    Element^ target
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
The column to attach. If the target is a beam or brace, the column will be checked to see if it is slanted. Otherwise, this argument is not used and may be omitted.
target
Type: Autodesk.Revit.DB..::..Element
A proposed target element for a column attachment.

Remarks

Valid targets are roofs, floors, and ceilings. Beams and braces are also valid targets, except for slanted columns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
IsValidTarget Overload


RemoveColumnAttachment Method

[image] [image]

Revit 2013 API
ColumnAttachment..::..RemoveColumnAttachment Method
ColumnAttachment Class See Also Send Feedback

Overload List

Name | Description
RemoveColumnAttachment(FamilyInstance, ElementId) | Removes any attachment of the column to the specified target.
RemoveColumnAttachment(FamilyInstance, Int32) | Removes an attachment at the top or base of a column, if there is one.

See Also

ColumnAttachment Class
ColumnAttachment Members


RemoveColumnAttachment Method (FamilyInstance, ElementId)

[image]

Revit 2013 API
ColumnAttachment..::..RemoveColumnAttachment Method (FamilyInstance, ElementId)
ColumnAttachment Class See Also Send Feedback
Removes any attachment of the column to the specified target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void RemoveColumnAttachment(
    FamilyInstance column,
    ElementId targetId
)
Visual Basic
Public Shared Sub RemoveColumnAttachment ( _
    column As FamilyInstance, _
    targetId As ElementId _
)
Visual C++
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    ElementId^ targetId
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
targetId
Type: Autodesk.Revit.DB..::..ElementId
Id of a target element.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ColumnAttachment Class
RemoveColumnAttachment Overload


RemoveColumnAttachment Method (FamilyInstance, Int32)

[image]

Revit 2013 API
ColumnAttachment..::..RemoveColumnAttachment Method (FamilyInstance, Int32)
ColumnAttachment Class See Also Send Feedback
Removes an attachment at the top or base of a column, if there is one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void RemoveColumnAttachment(
    FamilyInstance column,
    int baseOrTop
)
Visual Basic
Public Shared Sub RemoveColumnAttachment ( _
    column As FamilyInstance, _
    baseOrTop As Integer _
)
Visual C++
public:
static void RemoveColumnAttachment(
    FamilyInstance^ column,
    int baseOrTop
)

Parameters

column
Type: Autodesk.Revit.DB..::..FamilyInstance
A column.
baseOrTop
Type: System..::..Int32
0 for base, 1 for top.

Remarks

This method modifies both column and target elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | baseOrTop must be either 0 or 1.

See Also

ColumnAttachment Class
RemoveColumnAttachment Overload


SetJustification Method

[image]

Revit 2013 API
ColumnAttachment..::..SetJustification Method
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetJustification(
    ColumnAttachmentJustification justification
)
Visual Basic
Public Sub SetJustification ( _
    justification As ColumnAttachmentJustification _
)
Visual C++
public:
void SetJustification(
    ColumnAttachmentJustification justification
)

Parameters

justification
Type: Autodesk.Revit.DB..::..ColumnAttachmentJustification

See Also

ColumnAttachment Class


ColumnAttachment Properties

[image] [image]

Revit 2013 API
ColumnAttachment Properties
ColumnAttachment Class See Also Send Feedback

The ColumnAttachment type exposes the following members.

Properties

 | Name | Description
Public property | AttachOffset |
Public property | BaseOrTop |
Public property | CutStyle |
Public property | Justification |
Public property | TargetId |

See Also

ColumnAttachment Class


AttachOffset Property

[image]

Revit 2013 API
ColumnAttachment..::..AttachOffset Property
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AttachOffset { get; set; }
Visual Basic
Public Property AttachOffset As Double
    Get
    Set
Visual C++
public:
property double AttachOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for attachOffset must be no more than 30000 feet in absolute value.

See Also

ColumnAttachment Class


BaseOrTop Property

[image]

Revit 2013 API
ColumnAttachment..::..BaseOrTop Property
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int BaseOrTop { get; }
Visual Basic
Public ReadOnly Property BaseOrTop As Integer
    Get
Visual C++
public:
property int BaseOrTop {
    int get ();
}

See Also

ColumnAttachment Class


CutStyle Property

[image]

Revit 2013 API
ColumnAttachment..::..CutStyle Property
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ColumnAttachmentCutStyle CutStyle { get; }
Visual Basic
Public ReadOnly Property CutStyle As ColumnAttachmentCutStyle
    Get
Visual C++
public:
property ColumnAttachmentCutStyle CutStyle {
    ColumnAttachmentCutStyle get ();
}

See Also

ColumnAttachment Class


Justification Property

[image]

Revit 2013 API
ColumnAttachment..::..Justification Property
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ColumnAttachmentJustification Justification { get; }
Visual Basic
Public ReadOnly Property Justification As ColumnAttachmentJustification
    Get
Visual C++
public:
property ColumnAttachmentJustification Justification {
    ColumnAttachmentJustification get ();
}

See Also

ColumnAttachment Class


TargetId Property

[image]

Revit 2013 API
ColumnAttachment..::..TargetId Property
ColumnAttachment Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId TargetId { get; }
Visual Basic
Public ReadOnly Property TargetId As ElementId
    Get
Visual C++
public:
property ElementId^ TargetId {
    ElementId^ get ();
}

See Also

ColumnAttachment Class


ColumnAttachmentCutStyle Enumeration

[image]

Revit 2013 API
ColumnAttachmentCutStyle Enumeration
See Also Send Feedback
Control the handling of columns that intersect their targets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ColumnAttachmentCutStyle
Visual Basic
Public Enumeration ColumnAttachmentCutStyle
Visual C++
public enum class ColumnAttachmentCutStyle

Members

Member name | Description
CutColumn |
CutTarget |
None |

See Also


ColumnAttachmentJustification Enumeration

[image]

Revit 2013 API
ColumnAttachmentJustification Enumeration
See Also Send Feedback
Control the column extent in cases where the target is not a uniform height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ColumnAttachmentJustification
Visual Basic
Public Enumeration ColumnAttachmentJustification
Visual C++
public enum class ColumnAttachmentJustification

Members

Member name | Description
Minimum | Minimize the column extent, so that it comes in contact with the target but does not intersect.
Midpoint | Extend the column until its midpoint contacts the target.
Maximum | Extend the column until it is completely covered by the target, intersecting it if necessary.
Tangent | For slanted columns only. Extend the column until its driving curve contacts the target, then cut the column with a plane tangent to the target at that contact point.

See Also


CombinableElement Class

[image]

Revit 2013 API
CombinableElement Class
Members See Also Send Feedback
An element that can be added to a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CombinableElement : Element
Visual Basic
Public Class CombinableElement _
    Inherits Element
Visual C++
public ref class CombinableElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..GeomCombination

See Also

CombinableElement Members


CombinableElement Members

[image] [image]

Revit 2013 API
CombinableElement Members
CombinableElement Class Methods Properties See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CombinableElement Class


CombinableElement Methods

[image] [image]

Revit 2013 API
CombinableElement Methods
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElement Class


CombinableElement Properties

[image] [image]

Revit 2013 API
CombinableElement Properties
CombinableElement Class See Also Send Feedback

The CombinableElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CombinableElement Class


Combinations Property

[image]

Revit 2013 API
CombinableElement..::..Combinations Property
CombinableElement Class See Also Send Feedback
The geometry combinations that this element belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeomCombinationSet Combinations { get; }
Visual Basic
Public ReadOnly Property Combinations As GeomCombinationSet
    Get
Visual C++
public:
property GeomCombinationSet^ Combinations {
    GeomCombinationSet^ get ();
}

Remarks

If this combinable element does not belong to any geometry combination, this value is an empty collection. A solid combinable element may belong to at most one combination, while a void combinable element may belong to multiple combinations.

See Also

CombinableElement Class


Parameter Property

[image] [image]

Revit 2013 API
CombinableElement..::..Parameter Property
CombinableElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CombinableElement Class
CombinableElement Members


CombinableElementArray Class

[image]

Revit 2013 API
CombinableElementArray Class
Members See Also Send Feedback
An array that contains CombinableElement objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CombinableElementArray : APIObject,
    IEnumerable
Visual Basic
Public Class CombinableElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CombinableElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CombinableElementArray

See Also

CombinableElementArray Members


CombinableElementArray Members

[image] [image]

Revit 2013 API
CombinableElementArray Members
CombinableElementArray Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArray | Initializes a new instance of the CombinableElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class


CombinableElementArray Constructor

[image]

Revit 2013 API
CombinableElementArray Constructor
CombinableElementArray Class See Also Send Feedback
Initializes a new instance of the CombinableElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CombinableElementArray()
Visual Basic
Public Sub New
Visual C++
public:
CombinableElementArray()

See Also

CombinableElementArray Class


CombinableElementArray Methods

[image] [image]

Revit 2013 API
CombinableElementArray Methods
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every CombinableElement from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArray Class


Append Method

[image]

Revit 2013 API
CombinableElementArray..::..Append Method
CombinableElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    CombinableElement item
)
Visual Basic
Public Overridable Sub Append ( _
    item As CombinableElement _
)
Visual C++
public:
virtual void Append(
    CombinableElement^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CombinableElement
The CombinableElement to be added.

See Also

CombinableElementArray Class


Clear Method

[image]

Revit 2013 API
CombinableElementArray..::..Clear Method
CombinableElementArray Class See Also Send Feedback
Removes every CombinableElement from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CombinableElementArray Class


ForwardIterator Method

[image]

Revit 2013 API
CombinableElementArray..::..ForwardIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CombinableElementArray Class


GetEnumerator Method

[image]

Revit 2013 API
CombinableElementArray..::..GetEnumerator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CombinableElementArray Class


Insert Method

[image]

Revit 2013 API
CombinableElementArray..::..Insert Method
CombinableElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    CombinableElement item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As CombinableElement, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CombinableElement^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..CombinableElement
The CombinableElement to be inserted into the array.
index
Type: System..::..Int32
The CombinableElement will be inserted before this index.

Return Value

Returns whether the CombinableElement was inserted into the array.

See Also

CombinableElementArray Class


ReverseIterator Method

[image]

Revit 2013 API
CombinableElementArray..::..ReverseIterator Method
CombinableElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CombinableElementArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CombinableElementArrayIterator
Visual C++
public:
virtual CombinableElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CombinableElementArray Class


CombinableElementArray Properties

[image] [image]

Revit 2013 API
CombinableElementArray Properties
CombinableElementArray Class See Also Send Feedback

The CombinableElementArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a CombinableElement at a specified index within the array.
Public property | Size | Returns the number of CombinableElements that are in the array.

See Also

CombinableElementArray Class


IsEmpty Property

[image]

Revit 2013 API
CombinableElementArray..::..IsEmpty Property
CombinableElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CombinableElementArray Class


Item Property

[image]

Revit 2013 API
CombinableElementArray..::..Item Property
CombinableElementArray Class See Also Send Feedback
Gets or sets a CombinableElement at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CombinableElement this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CombinableElement
    Get
    Set
Visual C++
public:
virtual property CombinableElement^ Item[int index] {
    CombinableElement^ get (int index);
    void set (int index, CombinableElement^ value);
}

Parameters

index
Type: System..::..Int32
The index of the CombinableElement to be set or retrieved.

Return Value

Returns the CombinableElement at the specified index.

See Also

CombinableElementArray Class


Size Property

[image]

Revit 2013 API
CombinableElementArray..::..Size Property
CombinableElementArray Class See Also Send Feedback
Returns the number of CombinableElements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CombinableElementArray Class


CombinableElementArrayIterator Class

[image]

Revit 2013 API
CombinableElementArrayIterator Class
Members See Also Send Feedback
An iterator to an CombinableElement array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CombinableElementArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CombinableElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CombinableElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CombinableElementArrayIterator

See Also

CombinableElementArrayIterator Members


CombinableElementArrayIterator Members

[image] [image]

Revit 2013 API
CombinableElementArrayIterator Members
CombinableElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CombinableElementArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Constructor

[image]

Revit 2013 API
CombinableElementArrayIterator Constructor
CombinableElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CombinableElementArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CombinableElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Methods

[image] [image]

Revit 2013 API
CombinableElementArrayIterator Methods
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CombinableElementArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
CombinableElementArrayIterator..::..MoveNext Method
CombinableElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


Reset Method

[image]

Revit 2013 API
CombinableElementArrayIterator..::..Reset Method
CombinableElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CombinableElementArrayIterator Class


CombinableElementArrayIterator Properties

[image] [image]

Revit 2013 API
CombinableElementArrayIterator Properties
CombinableElementArrayIterator Class See Also Send Feedback

The CombinableElementArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CombinableElementArrayIterator Class


Current Property

[image]

Revit 2013 API
CombinableElementArrayIterator..::..Current Property
CombinableElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CombinableElementArrayIterator Class


ComponentRotation Enumeration

[image]

Revit 2013 API
ComponentRotation Enumeration
See Also Send Feedback
ComponentRotation property of DividedSurface. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ComponentRotation
Visual Basic
Public Enumeration ComponentRotation
Visual C++
public enum class ComponentRotation

Members

Member name | Description
Angle0 |
Angle90 |
Angle180 |
Angle270 |

See Also


CompoundStructure Class

[image]

Revit 2013 API
CompoundStructure Class
Members See Also Send Feedback
Describes the internal structure of a wall, floor, roof or ceiling.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CompoundStructure : IDisposable
Visual Basic
Public Class CompoundStructure _
    Implements IDisposable
Visual C++
public ref class CompoundStructure : IDisposable

Remarks

If IsVerticallyCompound is false, then it describes a series of parallel layers, each with specified width, function, material etc. If IsVerticallyCompound is true (which should apply only for CompoundStructures assigned to walls) then horizontal sections at different elevations may have different layered structures. In this case, the structure describes a vertical section via a rectangle which is divided into polygonal regions whose sides are all vertical or horizontal segments. A map associates each of these regions with the index of a layer in the CompoundStructure which determines the properties of that region.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CompoundStructure

See Also

CompoundStructure Members


CompoundStructure Members

[image] [image]

Revit 2013 API
CompoundStructure Members
CompoundStructure Class Methods Properties See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associate a region with a layer.
Public method | CanLayerWidthBeNonZero | Changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure with one layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose | Releases all resources used by the CompoundStructure
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Take a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Check if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Set a layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Set the characteristics of the layers for this CompoundStructure.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Check if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers represented by this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.

See Also

CompoundStructure Class


CompoundStructure Methods

[image] [image]

Revit 2013 API
CompoundStructure Methods
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Methods

 | Name | Description
Public method | AddWallSweep | Adds a new wall sweep or reveal to the compound structure.
Public method | AssociateRegionWithLayer | Associate a region with a layer.
Public method | CanLayerWidthBeNonZero | Changing the width of an existing layer from zero to a positive value will create a rectangular region.
Public method | ChangeRegionWidth | Adjust the width of an existing simple region.
Public method | ClearWallSweeps | Removes all sweeps or reveals.
 | CreateSimpleCompoundStructure | Creates a non-vertically compound structure comprised of parallel layers.
 | CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure with one layer.
 | CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.
Public method | DeleteLayer | Deletes the specified layer from this CompoundStructure.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindEnclosingRegionAndSegments | Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Public method | GetAdjacentRegions | Gets the ids of region bound to a specified segment.
Public method | GetCoreBoundaryLayerIndex | Returns the index of the layer just below the core boundary.
Public method | GetDeckEmbeddingType | Retrieves the deck embedding type used for the specified structural deck.
Public method | GetDeckProfileId | Retrieves the profile loop used for the specified structural deck.
Public method | GetExtendableRegionIds | Gets the extendable region ids for the compound structure.
Public method | GetFirstCoreLayerIndex | Gets the index of the first core layer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastCoreLayerIndex | Gets the index of the last core layer.
Public method | GetLayerAssociatedToRegion | Gets the layer associated to a particular region.
Public method | GetLayerFunction | Retrieves the function of the specified layer.
Public method | GetLayers | A copy of the layers which define this compound structure.
Public method | GetLayerWidth | Retrieves the width of a specified layer.
Public method | GetMaterialId | Retrieves the material element id of a specified layer.
 | GetMinimumLayerThickness | Get the minimum allowable layer thickness.
Public method | GetNumberOfShellLayers | Retrieves the number of interior or exterior shell layers.
Public method | GetOffsetForLocationLine | Returns the offset from the center of the compound structure to the given location line value.
Public method | GetPreviousNonZeroLayerIndex | Returns the index of the nearest non-zero width layer before this layer.
Public method | GetRegionEnvelope | Gets the envelope that a specified region spans.
Public method | GetRegionIds | Gets region ids of this compound structure.
Public method | GetRegionsAlongLevel | Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.
Public method | GetRegionsAssociatedToLayer | Gets the set of region ids associated to a particular layer.
Public method | GetSegmentCoordinate | Gets the coordinate of a segment.
Public method | GetSegmentEndPoints | Gets the end points of a segment.
Public method | GetSegmentIds | Gets segment ids of this compound structure.
Public method | GetSegmentOrientation | Gets the orientation of a segment.
Public method | GetSimpleCompoundStructure | Take a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWallSweepsInfo | Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.
Public method | IsCoreLayer | Check if the specified layer is a core layer.
Public method | IsEqual | Checks whether this CompoundStructure is the same as another CompoundStructure.
Public method | IsLayerValid | Verifies that the data in this layer is internally consistent.
Public method | IsRectangularRegion | Determines whether the specified region is rectangular.
Public method | IsSimpleRegion | Determines whether the region is a simple region in this CompoundStructure.
Public method | IsStructuralDeck | Determines whether a specified layer is a structural deck.
Public method | IsValid | Checks for errors or inconsistencies in the data in this CompoundStructure.
Public method | IsValidRegionId | Determines whether the specified integer is actually the id of a region in this CompoundStructure.
Public method | IsValidSegmentId | Determines whether the specified integer is actually the id of a segment in this CompoundStructure.
Public method | IsVerticallyHomogeneous | Indicates whether this CompoundStructure represents a single set of parallel layers.
Public method | MergeRegionsAdjacentToSegment | Merges the two regions which share the specified segment.
Public method | ParticipatesInWrapping | Identifies if a layer is included in wrapping at inserts and ends.
Public method | RemoveWallSweep | Removes a single sweep or reveal from the compound structure.
Public method | SetDeckEmbeddingType | Sets the deck embedding type to use for the specified structural deck.
Public method | SetDeckProfileId | Sets the profile loop to use for the specified structural deck.
Public method | SetExtendableRegionIds | Sets the extendable region ids for the compound structure.
Public method | SetLayer | Set a layer for this CompoundStructure.
Public method | SetLayerFunction | Sets the function of the specified layer.
Public method | SetLayers | Set the characteristics of the layers for this CompoundStructure.
Public method | SetLayerWidth | Sets the width of a specified layer.
Public method | SetMaterialId | Sets a material element for a specified layer.
Public method | SetNumberOfShellLayers | Sets the number of interior or exterior shell layers.
Public method | SetParticipatesInWrapping | Assigns if a layer is included in wrapping at inserts and ends.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructure Class


AddWallSweep Method

[image]

Revit 2013 API
CompoundStructure..::..AddWallSweep Method
CompoundStructure Class See Also Send Feedback
Adds a new wall sweep or reveal to the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddWallSweep(
    WallSweepInfo wallSweepInfo
)
Visual Basic
Public Sub AddWallSweep ( _
    wallSweepInfo As WallSweepInfo _
)
Visual C++
public:
void AddWallSweep(
    WallSweepInfo^ wallSweepInfo
)

Parameters

wallSweepInfo
Type: Autodesk.Revit.DB..::..WallSweepInfo
The wall sweep info to create a wall sweep.

Remarks

A wall sweep is an object that is created by sweeping a closed 2d profile along a horizontal line that is positioned on one side (exterior or interior) of the hosting wall. A reveal is a special wall sweep with a void shape that is subtracted from the hosting wall.

The id field of the WallSweepInfo must be populated with a non-negative integer value. If there already is a sweep defined for this id, its parameters will be changed. A new sweep will be created if no existing one has matching id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wall sweep info does not represent a fixed wall sweep. Only fixed wall sweeps may be assigned to vertical compound structures. -or- The WallSweepInfo has an invalid id for a fixed wall sweep.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


AssociateRegionWithLayer Method

[image]

Revit 2013 API
CompoundStructure..::..AssociateRegionWithLayer Method
CompoundStructure Class See Also Send Feedback
Associate a region with a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)
Visual Basic
Public Sub AssociateRegionWithLayer ( _
    regionId As Integer, _
    layerIdx As Integer _
)
Visual C++
public:
void AssociateRegionWithLayer(
    int regionId,
    int layerIdx
)

Parameters

regionId
Type: System..::..Int32
The id of a region.
layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


CanLayerWidthBeNonZero Method

[image]

Revit 2013 API
CompoundStructure..::..CanLayerWidthBeNonZero Method
CompoundStructure Class See Also Send Feedback
Changing the width of an existing layer from zero to a positive value will create a rectangular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanLayerWidthBeNonZero(
    int layerIdx
)
Visual Basic
Public Function CanLayerWidthBeNonZero ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool CanLayerWidthBeNonZero(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a CompoundStructureLayer.

Remarks

This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx, and all regions to the right are assigned to layers with index > layerIdx.

See Also

CompoundStructure Class


ChangeRegionWidth Method

[image]

Revit 2013 API
CompoundStructure..::..ChangeRegionWidth Method
CompoundStructure Class See Also Send Feedback
Adjust the width of an existing simple region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ChangeRegionWidth(
    int regionId,
    double newWidth
)
Visual Basic
Public Function ChangeRegionWidth ( _
    regionId As Integer, _
    newWidth As Double _
) As Boolean
Visual C++
public:
bool ChangeRegionWidth(
    int regionId,
    double newWidth
)

Parameters

regionId
Type: System..::..Int32
The id of a region.
newWidth
Type: System..::..Double
The desired width of the specified region.

Return Value

True if newWidth is zero and the region was deleted.

Remarks

If width is changed to zero, the effect is to delete the region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id. -or- It is not a simple region.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


ClearWallSweeps Method

[image]

Revit 2013 API
CompoundStructure..::..ClearWallSweeps Method
CompoundStructure Class See Also Send Feedback
Removes all sweeps or reveals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ClearWallSweeps(
    WallSweepType wallSweepType
)
Visual Basic
Public Sub ClearWallSweeps ( _
    wallSweepType As WallSweepType _
)
Visual C++
public:
void ClearWallSweeps(
    WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


CreateSimpleCompoundStructure Method

[image]

Revit 2013 API
CompoundStructure..::..CreateSimpleCompoundStructure Method
CompoundStructure Class See Also Send Feedback
Creates a non-vertically compound structure comprised of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static CompoundStructure CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer> layers
)
Visual Basic
Public Shared Function CreateSimpleCompoundStructure ( _
    layers As IList(Of CompoundStructureLayer) _
) As CompoundStructure
Visual C++
public:
static CompoundStructure^ CreateSimpleCompoundStructure(
    IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic..::..IList<(Of <(<'CompoundStructureLayer>)>)>
An array which describes the parallel layers of this compound structure.

Return Value

A newly created compound structure.

Remarks

All layers are in the core, i.e. there are no shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more layers is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class


CreateSingleLayerCompoundStructure Method

[image] [image]

Revit 2013 API
CompoundStructure..::..CreateSingleLayerCompoundStructure Method
CompoundStructure Class See Also Send Feedback

Overload List

Name | Description
CreateSingleLayerCompoundStructure(MaterialFunctionAssignment, Double, ElementId) | Creates a CompoundStructure with one layer.
CreateSingleLayerCompoundStructure(Double, MaterialFunctionAssignment, Double, ElementId) | Creates a vertically compound CompoundStructure with one layer.

See Also

CompoundStructure Class
CompoundStructure Members


CreateSingleLayerCompoundStructure Method (MaterialFunctionAssignment, Double, ElementId)

[image]

Revit 2013 API
CompoundStructure..::..CreateSingleLayerCompoundStructure Method (MaterialFunctionAssignment, Double, ElementId)
CompoundStructure Class See Also Send Feedback
Creates a CompoundStructure with one layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static CompoundStructure CreateSingleLayerCompoundStructure(
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId materialId
)
Visual Basic
Public Shared Function CreateSingleLayerCompoundStructure ( _
    layerFunction As MaterialFunctionAssignment, _
    width As Double, _
    materialId As ElementId _
) As CompoundStructure
Visual C++
public:
static CompoundStructure^ CreateSingleLayerCompoundStructure(
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId^ materialId
)

Parameters

layerFunction
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the single layer.
width
Type: System..::..Double
The width of the single layer.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the material for the single layer.

Return Value

The newly created compound structure.

Remarks

It is not verified that materialId corresponds to a valid Material element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for width must be greater than 0 and no more than 30000 feet.

See Also

CompoundStructure Class
CreateSingleLayerCompoundStructure Overload


CreateSingleLayerCompoundStructure Method (Double, MaterialFunctionAssignment, Double, ElementId)

[image]

Revit 2013 API
CompoundStructure..::..CreateSingleLayerCompoundStructure Method (Double, MaterialFunctionAssignment, Double, ElementId)
CompoundStructure Class See Also Send Feedback
Creates a vertically compound CompoundStructure with one layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static CompoundStructure CreateSingleLayerCompoundStructure(
    double sampleHeight,
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId materialId
)
Visual Basic
Public Shared Function CreateSingleLayerCompoundStructure ( _
    sampleHeight As Double, _
    layerFunction As MaterialFunctionAssignment, _
    width As Double, _
    materialId As ElementId _
) As CompoundStructure
Visual C++
public:
static CompoundStructure^ CreateSingleLayerCompoundStructure(
    double sampleHeight,
    MaterialFunctionAssignment layerFunction,
    double width,
    ElementId^ materialId
)

Parameters

sampleHeight
Type: System..::..Double
The sample height of this vertically compound structure.
layerFunction
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the single layer.
width
Type: System..::..Double
The width of the single layer.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the material for the single layer.

Remarks

It is not verified that materialId corresponds to a valid MaterialElem.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for sampleHeight must be greater than 0 and no more than 30000 feet. -or- The given value for width must be greater than 0 and no more than 30000 feet.

See Also

CompoundStructure Class
CreateSingleLayerCompoundStructure Overload


DeleteLayer Method

[image]

Revit 2013 API
CompoundStructure..::..DeleteLayer Method
CompoundStructure Class See Also Send Feedback
Deletes the specified layer from this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool DeleteLayer(
    int layerIdx
)
Visual Basic
Public Function DeleteLayer ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool DeleteLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

True if the layer was successfully deleted, and false otherwise.

Remarks

For a vertically compound structure, a layer may only be deleted if it is not associated to a region, or else it is associated to exactly one simple region, which will also be deleted. Regions associated to layers with index greater than layerIdx will have their associated layer indices decremented by one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer cannot be deleted.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


Dispose Method

[image]

Revit 2013 API
CompoundStructure..::..Dispose Method
CompoundStructure Class See Also Send Feedback
Releases all resources used by the CompoundStructure

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CompoundStructure Class


FindEnclosingRegionAndSegments Method

[image]

Revit 2013 API
CompoundStructure..::..FindEnclosingRegionAndSegments Method
CompoundStructure Class See Also Send Feedback
Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int FindEnclosingRegionAndSegments(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int segmentId1,
    out int segmentId2
)
Visual Basic
Public Function FindEnclosingRegionAndSegments ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation, _
    <OutAttribute> ByRef segmentId1 As Integer, _
    <OutAttribute> ByRef segmentId2 As Integer _
) As Integer
Visual C++
public:
int FindEnclosingRegionAndSegments(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% segmentId1,
    [OutAttribute] int% segmentId2
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.
segmentId1
Type: System..::..Int32%
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
segmentId2
Type: System..::..Int32%
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.

Return Value

Returns the id of the enclosing region, and -1 if no region encloses the point.

Remarks

Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetAdjacentRegions Method

[image]

Revit 2013 API
CompoundStructure..::..GetAdjacentRegions Method
CompoundStructure Class See Also Send Feedback
Gets the ids of region bound to a specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetAdjacentRegions(
    int segmentId
)
Visual Basic
Public Function GetAdjacentRegions ( _
    segmentId As Integer _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetAdjacentRegions(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The ids of the regions that are bounded by the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids. The segments which define the outer boundary of the structure are adjacent to one region, other segments will be adjacent to two regions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetCoreBoundaryLayerIndex Method

[image]

Revit 2013 API
CompoundStructure..::..GetCoreBoundaryLayerIndex Method
CompoundStructure Class See Also Send Feedback
Returns the index of the layer just below the core boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetCoreBoundaryLayerIndex ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetCoreBoundaryLayerIndex(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
The type of the shell layer.

Return Value

The index of the layer.

Remarks

-1 returned if there is no such a layer.

See Also

CompoundStructure Class


GetDeckEmbeddingType Method

[image]

Revit 2013 API
CompoundStructure..::..GetDeckEmbeddingType Method
CompoundStructure Class See Also Send Feedback
Retrieves the deck embedding type used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)
Visual Basic
Public Function GetDeckEmbeddingType ( _
    layerIdx As Integer _
) As StructDeckEmbeddingType
Visual C++
public:
StructDeckEmbeddingType GetDeckEmbeddingType(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetDeckProfileId Method

[image]

Revit 2013 API
CompoundStructure..::..GetDeckProfileId Method
CompoundStructure Class See Also Send Feedback
Retrieves the profile loop used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetDeckProfileId(
    int layerIdx
)
Visual Basic
Public Function GetDeckProfileId ( _
    layerIdx As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetDeckProfileId(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The element id of a FamilySymbol which contains a profile loop used by a structural deck associated to the specified layer, or invalidElementId if isStructuralDeck(layerIdx) is false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetExtendableRegionIds Method

[image]

Revit 2013 API
CompoundStructure..::..GetExtendableRegionIds Method
CompoundStructure Class See Also Send Feedback
Gets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetExtendableRegionIds(
    bool top
)
Visual Basic
Public Function GetExtendableRegionIds ( _
    top As Boolean _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetExtendableRegionIds(
    bool top
)

Parameters

top
Type: System..::..Boolean
If true, retrieve ids of regions which are extendable at the top, otherwise retrieve the ids of regions which are extendable at the bottom.

Return Value

An array of region ids which are marked extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetFirstCoreLayerIndex Method

[image]

Revit 2013 API
CompoundStructure..::..GetFirstCoreLayerIndex Method
CompoundStructure Class See Also Send Feedback
Gets the index of the first core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetFirstCoreLayerIndex()
Visual Basic
Public Function GetFirstCoreLayerIndex As Integer
Visual C++
public:
int GetFirstCoreLayerIndex()

Return Value

The index of the first core layer.

See Also

CompoundStructure Class


GetLastCoreLayerIndex Method

[image]

Revit 2013 API
CompoundStructure..::..GetLastCoreLayerIndex Method
CompoundStructure Class See Also Send Feedback
Gets the index of the last core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetLastCoreLayerIndex()
Visual Basic
Public Function GetLastCoreLayerIndex As Integer
Visual C++
public:
int GetLastCoreLayerIndex()

Return Value

The index of the last core layer.

See Also

CompoundStructure Class


GetLayerAssociatedToRegion Method

[image]

Revit 2013 API
CompoundStructure..::..GetLayerAssociatedToRegion Method
CompoundStructure Class See Also Send Feedback
Gets the layer associated to a particular region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetLayerAssociatedToRegion(
    int regionId
)
Visual Basic
Public Function GetLayerAssociatedToRegion ( _
    regionId As Integer _
) As Integer
Visual C++
public:
int GetLayerAssociatedToRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region.

Return Value

The index of a layer in this CompoundStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | For a non-vertically compound structure, implicitly each layer is associated to its corresponding simple region.

See Also

CompoundStructure Class


GetLayerFunction Method

[image]

Revit 2013 API
CompoundStructure..::..GetLayerFunction Method
CompoundStructure Class See Also Send Feedback
Retrieves the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)
Visual Basic
Public Function GetLayerFunction ( _
    layerIdx As Integer _
) As MaterialFunctionAssignment
Visual C++
public:
MaterialFunctionAssignment GetLayerFunction(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The function of the layer.

Remarks

The function determines how this layer interacts with the layers of other elements to which it is joined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetLayers Method

[image]

Revit 2013 API
CompoundStructure..::..GetLayers Method
CompoundStructure Class See Also Send Feedback
A copy of the layers which define this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<CompoundStructureLayer> GetLayers()
Visual Basic
Public Function GetLayers As IList(Of CompoundStructureLayer)
Visual C++
public:
IList<CompoundStructureLayer^>^ GetLayers()

Return Value

An array of CompoundStructureLayer.

See Also

CompoundStructure Class


GetLayerWidth Method

[image]

Revit 2013 API
CompoundStructure..::..GetLayerWidth Method
CompoundStructure Class See Also Send Feedback
Retrieves the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetLayerWidth(
    int layerIdx
)
Visual Basic
Public Function GetLayerWidth ( _
    layerIdx As Integer _
) As Double
Visual C++
public:
double GetLayerWidth(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The width of the specified layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetMaterialId Method

[image]

Revit 2013 API
CompoundStructure..::..GetMaterialId Method
CompoundStructure Class See Also Send Feedback
Retrieves the material element id of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetMaterialId(
    int layerIdx
)
Visual Basic
Public Function GetMaterialId ( _
    layerIdx As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetMaterialId(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

The material element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetMinimumLayerThickness Method

[image]

Revit 2013 API
CompoundStructure..::..GetMinimumLayerThickness Method
CompoundStructure Class See Also Send Feedback
Get the minimum allowable layer thickness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static double GetMinimumLayerThickness()
Visual Basic
Public Shared Function GetMinimumLayerThickness As Double
Visual C++
public:
static double GetMinimumLayerThickness()

Return Value

The minimum allowable width of a layer in feet.

See Also

CompoundStructure Class


GetNumberOfShellLayers Method

[image]

Revit 2013 API
CompoundStructure..::..GetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Retrieves the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)
Visual Basic
Public Function GetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType _
) As Integer
Visual C++
public:
int GetNumberOfShellLayers(
    ShellLayerType shellLayerType
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType::Exterior gets the number of exterior shell layers, otherwise gets the number of interior shell layers.

Return Value

The number of shell layers in the interior or exterior shell, as specified by shellLayerType.

Remarks

There must be at least one core layer, i.e. one layer which is not a shell layer.

See Also

CompoundStructure Class


GetOffsetForLocationLine Method

[image]

Revit 2013 API
CompoundStructure..::..GetOffsetForLocationLine Method
CompoundStructure Class See Also Send Feedback
Returns the offset from the center of the compound structure to the given location line value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)
Visual Basic
Public Function GetOffsetForLocationLine ( _
    wallLocationLine As WallLocationLine _
) As Double
Visual C++
public:
double GetOffsetForLocationLine(
    WallLocationLine wallLocationLine
)

Parameters

wallLocationLine
Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment type of the wall's location line.

Return Value

The offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically homogeneous compound structures.

See Also

CompoundStructure Class


GetPreviousNonZeroLayerIndex Method

[image]

Revit 2013 API
CompoundStructure..::..GetPreviousNonZeroLayerIndex Method
CompoundStructure Class See Also Send Feedback
Returns the index of the nearest non-zero width layer before this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetPreviousNonZeroLayerIndex(
    int thisIdx
)
Visual Basic
Public Function GetPreviousNonZeroLayerIndex ( _
    thisIdx As Integer _
) As Integer
Visual C++
public:
int GetPreviousNonZeroLayerIndex(
    int thisIdx
)

Parameters

thisIdx
Type: System..::..Int32
The layer from which to look for a non-zero width layer.

Return Value

The index of the layer found.

Remarks

If this layer is non-zero width, it will be returned. If there are non-zero width layers found, returns -1.

See Also

CompoundStructure Class


GetRegionEnvelope Method

[image]

Revit 2013 API
CompoundStructure..::..GetRegionEnvelope Method
CompoundStructure Class See Also Send Feedback
Gets the envelope that a specified region spans.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV GetRegionEnvelope(
    int regionId
)
Visual Basic
Public Function GetRegionEnvelope ( _
    regionId As Integer _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetRegionEnvelope(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of the region.

Return Value

The envelope of the region.

Remarks

This envelope indicates the external boundary of the region. The coordinate system it defines is used in the results of GetSegmentCoordinate().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetRegionIds Method

[image]

Revit 2013 API
CompoundStructure..::..GetRegionIds Method
CompoundStructure Class See Also Send Feedback
Gets region ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetRegionIds()
Visual Basic
Public Function GetRegionIds As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionIds()

Return Value

The ids of the regions defining this CompoundStructure.

Remarks

A vertically compound structure consists of regions with polygonal boundaries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetRegionsAlongLevel Method

[image]

Revit 2013 API
CompoundStructure..::..GetRegionsAlongLevel Method
CompoundStructure Class See Also Send Feedback
Returns the ids of the regions encountered as the vertically compound structure is traversed at a constant height above the bottom a wall to which this structure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetRegionsAlongLevel(
    double height
)
Visual Basic
Public Function GetRegionsAlongLevel ( _
    height As Double _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionsAlongLevel(
    double height
)

Parameters

height
Type: System..::..Double
Distance from the bottom of the wall.

Return Value

The ids of the regions intersected by the specified line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The height is outside valid range. It should be in the range of [0, SampleHeight].

See Also

CompoundStructure Class


GetRegionsAssociatedToLayer Method

[image]

Revit 2013 API
CompoundStructure..::..GetRegionsAssociatedToLayer Method
CompoundStructure Class See Also Send Feedback
Gets the set of region ids associated to a particular layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetRegionsAssociatedToLayer(
    int layerIdx
)
Visual Basic
Public Function GetRegionsAssociatedToLayer ( _
    layerIdx As Integer _
) As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegionsAssociatedToLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Return Value

An array of region ids which are associated to the specified layer.

Remarks

Regions are associated to layers. In a vertically compound structure, more than one region may be associated to a single layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


GetSegmentCoordinate Method

[image]

Revit 2013 API
CompoundStructure..::..GetSegmentCoordinate Method
CompoundStructure Class See Also Send Feedback
Gets the coordinate of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetSegmentCoordinate(
    int segmentId
)
Visual Basic
Public Function GetSegmentCoordinate ( _
    segmentId As Integer _
) As Double
Visual C++
public:
double GetSegmentCoordinate(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The local coordinates of the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments. If the segment orientation is horizontal, then its coordinate will lie in the range [0.0, SampleHeight]. If the segment orientation is vertical, then its coordinate will lie in the range of u values obtained from GetRegionEnvelope().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetSegmentEndPoints Method

[image]

Revit 2013 API
CompoundStructure..::..GetSegmentEndPoints Method
CompoundStructure Class See Also Send Feedback
Gets the end points of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    out UV end1,
    out UV end2
)
Visual Basic
Public Sub GetSegmentEndPoints ( _
    segmentId As Integer, _
    regionId As Integer, _
    <OutAttribute> ByRef end1 As UV, _
    <OutAttribute> ByRef end2 As UV _
)
Visual C++
public:
void GetSegmentEndPoints(
    int segmentId,
    int regionId,
    [OutAttribute] UV^% end1,
    [OutAttribute] UV^% end2
)

Parameters

segmentId
Type: System..::..Int32
The segment id.
regionId
Type: System..::..Int32
The region id.
end1
Type: Autodesk.Revit.DB..::..UV%
One end point.
end2
Type: Autodesk.Revit.DB..::..UV%
The other end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetSegmentIds Method

[image]

Revit 2013 API
CompoundStructure..::..GetSegmentIds Method
CompoundStructure Class See Also Send Feedback
Gets segment ids of this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<int> GetSegmentIds()
Visual Basic
Public Function GetSegmentIds As IList(Of Integer)
Visual C++
public:
IList<int>^ GetSegmentIds()

Return Value

The ids of the segments which form the boundary of the regions of this CompoundStructure.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments with unique ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetSegmentOrientation Method

[image]

Revit 2013 API
CompoundStructure..::..GetSegmentOrientation Method
CompoundStructure Class See Also Send Feedback
Gets the orientation of a segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)
Visual Basic
Public Function GetSegmentOrientation ( _
    segmentId As Integer _
) As RectangularGridSegmentOrientation
Visual C++
public:
RectangularGridSegmentOrientation GetSegmentOrientation(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

The orientation of the specified segment.

Remarks

The boundaries of the regions of a vertically compound structure consist of vertical horizontal segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The segment id is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


GetSimpleCompoundStructure Method

[image]

Revit 2013 API
CompoundStructure..::..GetSimpleCompoundStructure Method
CompoundStructure Class See Also Send Feedback
Take a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructure GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)
Visual Basic
Public Function GetSimpleCompoundStructure ( _
    wallHeight As Double, _
    distAboveBase As Double _
) As CompoundStructure
Visual C++
public:
CompoundStructure^ GetSimpleCompoundStructure(
    double wallHeight,
    double distAboveBase
)

Parameters

wallHeight
Type: System..::..Double
The height of the wall.
distAboveBase
Type: System..::..Double
The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.

Return Value

A simple CompoundStructure representing a series of parallel layers.

Remarks

If IsVerticallyCompound returns false, the output is a copy of this CompoundStructure.

See Also

CompoundStructure Class


GetWallSweepsInfo Method

[image]

Revit 2013 API
CompoundStructure..::..GetWallSweepsInfo Method
CompoundStructure Class See Also Send Feedback
Obtains a list of the intrinsic wall sweeps or reveals in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<WallSweepInfo> GetWallSweepsInfo(
    WallSweepType wallSweepType
)
Visual Basic
Public Function GetWallSweepsInfo ( _
    wallSweepType As WallSweepType _
) As IList(Of WallSweepInfo)
Visual C++
public:
IList<WallSweepInfo^>^ GetWallSweepsInfo(
    WallSweepType wallSweepType
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
Whether to obtain wall sweeps or reveals.

Return Value

An array which describes the intrinsic wall sweeps or reveals.

See Also

CompoundStructure Class


GetWidth Method

[image] [image]

Revit 2013 API
CompoundStructure..::..GetWidth Method
CompoundStructure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWidth()()()() | The width implied by this compound structure.
Public method | GetWidth(Int32) | Computes the width of the envelope (2d bounding box) of the specified region.

See Also

CompoundStructure Class
CompoundStructure Members


GetWidth Method

[image]

Revit 2013 API
CompoundStructure..::..GetWidth Method
CompoundStructure Class See Also Send Feedback
The width implied by this compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetWidth()
Visual Basic
Public Function GetWidth As Double
Visual C++
public:
double GetWidth()

Return Value

The width of a host object with this compound structure.

Remarks

If the structure is not vertically compound, then this is simply the sum of all layers' widths. If the structure is vertically compound, this is the width of the rectangular grid stored in the vertically compound structure. The presence of a layer with variable width has no effect on the value returned by this method. The value returned assumes that all layers have their specified width.

See Also

CompoundStructure Class
GetWidth Overload


GetWidth Method (Int32)

[image]

Revit 2013 API
CompoundStructure..::..GetWidth Method (Int32)
CompoundStructure Class See Also Send Feedback
Computes the width of the envelope (2d bounding box) of the specified region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetWidth(
    int regionId
)
Visual Basic
Public Function GetWidth ( _
    regionId As Integer _
) As Double
Visual C++
public:
double GetWidth(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

The width of the envelope (2d bounding box) of the region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class
GetWidth Overload


IsCoreLayer Method

[image]

Revit 2013 API
CompoundStructure..::..IsCoreLayer Method
CompoundStructure Class See Also Send Feedback
Check if the specified layer is a core layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCoreLayer(
    int layerIdx
)
Visual Basic
Public Function IsCoreLayer ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool IsCoreLayer(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer in this CompoundStructure.

Return Value

Returns true if the number of exterior layers <= layerIdx <= LayerCount - the number of interior layers - 1, and returns false otherwise.

See Also

CompoundStructure Class


IsEqual Method

[image]

Revit 2013 API
CompoundStructure..::..IsEqual Method
CompoundStructure Class See Also Send Feedback
Checks whether this CompoundStructure is the same as another CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEqual(
    CompoundStructure otherStructure
)
Visual Basic
Public Function IsEqual ( _
    otherStructure As CompoundStructure _
) As Boolean
Visual C++
public:
bool IsEqual(
    CompoundStructure^ otherStructure
)

Parameters

otherStructure
Type: Autodesk.Revit.DB..::..CompoundStructure
A CompoundStructure.

Return Value

True if the two CompoundStructures are the same, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class


IsLayerValid Method

[image]

Revit 2013 API
CompoundStructure..::..IsLayerValid Method
CompoundStructure Class See Also Send Feedback
Verifies that the data in this layer is internally consistent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer layer
)
Visual Basic
Public Function IsLayerValid ( _
    layerIdx As Integer, _
    layer As CompoundStructureLayer _
) As Boolean
Visual C++
public:
bool IsLayerValid(
    int layerIdx,
    CompoundStructureLayer^ layer
)

Parameters

layerIdx
Type: System..::..Int32
The index of the layer in the compound structure to be set.
layer
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The layer to be set.

Return Value

True if the layer is internally consistent, false if the layer is not internally consistent.

Remarks

If the layer function is not Membrane or StructuralDeck, the width must be greater than zero. If the layer function is not StructuralDeck, then the deck embedding type must be Invalid, and the deck profile id must be invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class


IsRectangularRegion Method

[image]

Revit 2013 API
CompoundStructure..::..IsRectangularRegion Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified region is rectangular.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRectangularRegion(
    int regionId
)
Visual Basic
Public Function IsRectangularRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsRectangularRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region.

Return Value

True if the specified region is a rectangle, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


IsSimpleRegion Method

[image]

Revit 2013 API
CompoundStructure..::..IsSimpleRegion Method
CompoundStructure Class See Also Send Feedback
Determines whether the region is a simple region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSimpleRegion(
    int regionId
)
Visual Basic
Public Function IsSimpleRegion ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsSimpleRegion(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is simple, false otherwise.

Remarks

A region is simple if it rectangular and spans the height of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a valid region id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


IsStructuralDeck Method

[image]

Revit 2013 API
CompoundStructure..::..IsStructuralDeck Method
CompoundStructure Class See Also Send Feedback
Determines whether a specified layer is a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsStructuralDeck(
    int layerIdx
)
Visual Basic
Public Function IsStructuralDeck ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool IsStructuralDeck(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.

Return Value

True if specified layer is a structural deck, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


IsValid Method

[image]

Revit 2013 API
CompoundStructure..::..IsValid Method
CompoundStructure Class See Also Send Feedback
Checks for errors or inconsistencies in the data in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValid(
    Document doc,
    out IDictionary<int, CompoundStructureError> errMap,
    out IDictionary<int, int> twoLayerErrorsMap
)
Visual Basic
Public Function IsValid ( _
    doc As Document, _
    <OutAttribute> ByRef errMap As IDictionary(Of Integer, CompoundStructureError), _
    <OutAttribute> ByRef twoLayerErrorsMap As IDictionary(Of Integer, Integer) _
) As Boolean
Visual C++
public:
bool IsValid(
    Document^ doc,
    [OutAttribute] IDictionary<int, CompoundStructureError>^% errMap,
    [OutAttribute] IDictionary<int, int>^% twoLayerErrorsMap
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Access to the document in which the CompoundStructure will be used.
errMap
Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, CompoundStructureError>)>)>%
This map will associate each problematic layer index to a value in CompoundStructureError. General structure errors are reported as associated to layer index -1.
twoLayerErrorsMap
Type: System.Collections.Generic..::..IDictionary<(Of <(<'Int32, Int32>)>)>%
The map is associated to a check run only for vertically Compound Structures. Essentially the Compound Structure is sliced at representative heights. It looks at the region from exterior to interior, and requires that the assigned layer indices do not decrease. If they do, an entry is generated for this map. The first entry is the last valid layer index encountered. The second entry is a region id whose assigned layer index is too small: it should be at least as large as the first entry.

Return Value

True if the compound structure is valid for the document, false otherwise.

Remarks

This check is run before the CompoundStructure may be assigned to a particular ElementType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class


IsValidRegionId Method

[image]

Revit 2013 API
CompoundStructure..::..IsValidRegionId Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified integer is actually the id of a region in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidRegionId(
    int regionId
)
Visual Basic
Public Function IsValidRegionId ( _
    regionId As Integer _
) As Boolean
Visual C++
public:
bool IsValidRegionId(
    int regionId
)

Parameters

regionId
Type: System..::..Int32
The id of a region in this vertically compound structure.

Return Value

True if the region is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


IsValidSegmentId Method

[image]

Revit 2013 API
CompoundStructure..::..IsValidSegmentId Method
CompoundStructure Class See Also Send Feedback
Determines whether the specified integer is actually the id of a segment in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidSegmentId(
    int segmentId
)
Visual Basic
Public Function IsValidSegmentId ( _
    segmentId As Integer _
) As Boolean
Visual C++
public:
bool IsValidSegmentId(
    int segmentId
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in this CompoundStructure.

Return Value

True if the specified segment is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


IsVerticallyHomogeneous Method

[image]

Revit 2013 API
CompoundStructure..::..IsVerticallyHomogeneous Method
CompoundStructure Class See Also Send Feedback
Indicates whether this CompoundStructure represents a single set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsVerticallyHomogeneous()
Visual Basic
Public Function IsVerticallyHomogeneous As Boolean
Visual C++
public:
bool IsVerticallyHomogeneous()

Return Value

True if this CompoundStructure represents a series of parallel layers that stretch from bottom to top, false otherwise.

Remarks

Differs from IsVerticallyCompound as a vertically compound structure might happen not to have any horizontal breaks. For that situation, both IsVerticallyCompound and this method will return true.

See Also

CompoundStructure Class


MergeRegionsAdjacentToSegment Method

[image]

Revit 2013 API
CompoundStructure..::..MergeRegionsAdjacentToSegment Method
CompoundStructure Class See Also Send Feedback
Merges the two regions which share the specified segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int MergeRegionsAdjacentToSegment(
    int segmentId,
    int layerIdxForMergedRegion
)
Visual Basic
Public Function MergeRegionsAdjacentToSegment ( _
    segmentId As Integer, _
    layerIdxForMergedRegion As Integer _
) As Integer
Visual C++
public:
int MergeRegionsAdjacentToSegment(
    int segmentId,
    int layerIdxForMergedRegion
)

Parameters

segmentId
Type: System..::..Int32
The id of a segment in the underlying grid.
layerIdxForMergedRegion
Type: System..::..Int32
The index of the layer to which the resulting region will be associated.

Return Value

The id of the resulting region. If -1 is returned, then the operation would have produced an invalid region and was not performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures. -or- The segment is not shared by adjacent regions.

See Also

CompoundStructure Class


ParticipatesInWrapping Method

[image]

Revit 2013 API
CompoundStructure..::..ParticipatesInWrapping Method
CompoundStructure Class See Also Send Feedback
Identifies if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ParticipatesInWrapping(
    int layerIdx
)
Visual Basic
Public Function ParticipatesInWrapping ( _
    layerIdx As Integer _
) As Boolean
Visual C++
public:
bool ParticipatesInWrapping(
    int layerIdx
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer.

Return Value

If true, then the layer participates in wrapping at inserts and openings. If false, the layer will not participate in wrapping.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


RemoveWallSweep Method

[image]

Revit 2013 API
CompoundStructure..::..RemoveWallSweep Method
CompoundStructure Class See Also Send Feedback
Removes a single sweep or reveal from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)
Visual Basic
Public Sub RemoveWallSweep ( _
    wallSweepType As WallSweepType, _
    id As Integer _
)
Visual C++
public:
void RemoveWallSweep(
    WallSweepType wallSweepType,
    int id
)

Parameters

wallSweepType
Type: Autodesk.Revit.DB..::..WallSweepType
The type of a wall sweep.
id
Type: System..::..Int32
The id of the sweep or reveal to remove.

Remarks

No validation of input arguments is performed. If no reveal or sweep has the specified id, no action is performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


SetDeckEmbeddingType Method

[image]

Revit 2013 API
CompoundStructure..::..SetDeckEmbeddingType Method
CompoundStructure Class See Also Send Feedback
Sets the deck embedding type to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)
Visual Basic
Public Sub SetDeckEmbeddingType ( _
    layerIdx As Integer, _
    embedType As StructDeckEmbeddingType _
)
Visual C++
public:
void SetDeckEmbeddingType(
    int layerIdx,
    StructDeckEmbeddingType embedType
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
embedType
Type: Autodesk.Revit.DB..::..StructDeckEmbeddingType
The embedding type to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetDeckProfileId Method

[image]

Revit 2013 API
CompoundStructure..::..SetDeckProfileId Method
CompoundStructure Class See Also Send Feedback
Sets the profile loop to use for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetDeckProfileId(
    int layerIdx,
    ElementId profileId
)
Visual Basic
Public Sub SetDeckProfileId ( _
    layerIdx As Integer, _
    profileId As ElementId _
)
Visual C++
public:
void SetDeckProfileId(
    int layerIdx,
    ElementId^ profileId
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
profileId
Type: Autodesk.Revit.DB..::..ElementId
The element id of a FamilySymbol which contains a profile loop to be used by the specified layer if it is a structural deck.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not a structural deck.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetExtendableRegionIds Method

[image]

Revit 2013 API
CompoundStructure..::..SetExtendableRegionIds Method
CompoundStructure Class See Also Send Feedback
Sets the extendable region ids for the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetExtendableRegionIds(
    bool top,
    IList<int> regionIds
)
Visual Basic
Public Sub SetExtendableRegionIds ( _
    top As Boolean, _
    regionIds As IList(Of Integer) _
)
Visual C++
public:
void SetExtendableRegionIds(
    bool top,
    IList<int>^ regionIds
)

Parameters

top
Type: System..::..Boolean
If true, set ids of regions which are extendable at the top, otherwise set the ids of regions which are extendable at the bottom.
regionIds
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
The ids of regions which will be extendable.

Remarks

Regions along the top or bottom of the wall may be set to be extendable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The region ids are not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


SetLayer Method

[image]

Revit 2013 API
CompoundStructure..::..SetLayer Method
CompoundStructure Class See Also Send Feedback
Set a layer for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayer(
    int layerIdx,
    CompoundStructureLayer layer
)
Visual Basic
Public Sub SetLayer ( _
    layerIdx As Integer, _
    layer As CompoundStructureLayer _
)
Visual C++
public:
void SetLayer(
    int layerIdx,
    CompoundStructureLayer^ layer
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer. This should range from 0 to the number of layers - 1.
layer
Type: Autodesk.Revit.DB..::..CompoundStructureLayer
The layer to be set.

Remarks

This function does not support addition of new layers, use SetLayers() to change the number of layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The layer is not valid for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetLayerFunction Method

[image]

Revit 2013 API
CompoundStructure..::..SetLayerFunction Method
CompoundStructure Class See Also Send Feedback
Sets the function of the specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)
Visual Basic
Public Sub SetLayerFunction ( _
    layerIdx As Integer, _
    function As MaterialFunctionAssignment _
)
Visual C++
public:
void SetLayerFunction(
    int layerIdx,
    MaterialFunctionAssignment function
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetLayers Method

[image]

Revit 2013 API
CompoundStructure..::..SetLayers Method
CompoundStructure Class See Also Send Feedback
Set the characteristics of the layers for this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayers(
    IList<CompoundStructureLayer> layers
)
Visual Basic
Public Sub SetLayers ( _
    layers As IList(Of CompoundStructureLayer) _
)
Visual C++
public:
void SetLayers(
    IList<CompoundStructureLayer^>^ layers
)

Parameters

layers
Type: System.Collections.Generic..::..IList<(Of <(<'CompoundStructureLayer>)>)>
The layers to be set.

Remarks

This function will replace all existing layers with the contents of the input. Properties such as VariableLayerIndex may need to be reset after setting a new set of layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructure Class


SetLayerWidth Method

[image]

Revit 2013 API
CompoundStructure..::..SetLayerWidth Method
CompoundStructure Class See Also Send Feedback
Sets the width of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayerWidth(
    int layerIdx,
    double width
)
Visual Basic
Public Sub SetLayerWidth ( _
    layerIdx As Integer, _
    width As Double _
)
Visual C++
public:
void SetLayerWidth(
    int layerIdx,
    double width
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
width
Type: System..::..Double
The new width of the specified layer.

Remarks

If the structure is vertically compound, and the layer is associated to a single simple region, the width of that region is adjusted. If layerIdx is 0 or LayerCount-1, and there is no associated region in the VerticalRegionsStructure, one will be created and associated to the layer. If the specified layer index is associated to a simple region, and the width is set to 0.0, that region will be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The width of the layer is not valid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the region of the layer is not a simple region.

See Also

CompoundStructure Class


SetMaterialId Method

[image]

Revit 2013 API
CompoundStructure..::..SetMaterialId Method
CompoundStructure Class See Also Send Feedback
Sets a material element for a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetMaterialId(
    int layerIdx,
    ElementId materialId
)
Visual Basic
Public Sub SetMaterialId ( _
    layerIdx As Integer, _
    materialId As ElementId _
)
Visual C++
public:
void SetMaterialId(
    int layerIdx,
    ElementId^ materialId
)

Parameters

layerIdx
Type: System..::..Int32
Index of a layer in the CompoundStructure.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of a Material element.

Remarks

It is not verified that materialId corresponds to a valid Material element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SetNumberOfShellLayers Method

[image]

Revit 2013 API
CompoundStructure..::..SetNumberOfShellLayers Method
CompoundStructure Class See Also Send Feedback
Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)
Visual Basic
Public Sub SetNumberOfShellLayers ( _
    shellLayerType As ShellLayerType, _
    numLayers As Integer _
)
Visual C++
public:
void SetNumberOfShellLayers(
    ShellLayerType shellLayerType,
    int numLayers
)

Parameters

shellLayerType
Type: Autodesk.Revit.DB..::..ShellLayerType
If ShellLayerType::Exterior sets the number of exterior shell layers, otherwise sets the number of interior shell layers.
numLayers
Type: System..::..Int32
Number of layers in the specified shell.

Remarks

There must be at least one core layer, i.e. one layer which is not a shell layer.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Number of shell layers is negative.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Too many shell layers: there must be at least one core layer.

See Also

CompoundStructure Class


SetParticipatesInWrapping Method

[image]

Revit 2013 API
CompoundStructure..::..SetParticipatesInWrapping Method
CompoundStructure Class See Also Send Feedback
Assigns if a layer is included in wrapping at inserts and ends.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)
Visual Basic
Public Sub SetParticipatesInWrapping ( _
    layerIdx As Integer, _
    participatesInWrapping As Boolean _
)
Visual C++
public:
void SetParticipatesInWrapping(
    int layerIdx,
    bool participatesInWrapping
)

Parameters

layerIdx
Type: System..::..Int32
The index of a layer.
participatesInWrapping
Type: System..::..Boolean
True if the specified layer will participate in wrapping at inserts and ends, false otherwise.

Remarks

This method applies only to interior and exterior shell layers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wrapping of the layer is not valid.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range.

See Also

CompoundStructure Class


SplitRegion Method

[image] [image]

Revit 2013 API
CompoundStructure..::..SplitRegion Method
CompoundStructure Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SplitRegion(UV, RectangularGridSegmentOrientation) | Splits the region which contains the specified grid point by a line with the specified direction.
Public method | SplitRegion(UV, RectangularGridSegmentOrientation, Int32%) | Splits the region which contains the specified grid point by a line with the specified direction.

See Also

CompoundStructure Class
CompoundStructure Members


SplitRegion Method (UV, RectangularGridSegmentOrientation)

[image]

Revit 2013 API
CompoundStructure..::..SplitRegion Method (UV, RectangularGridSegmentOrientation)
CompoundStructure Class See Also Send Feedback
Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection
)
Visual Basic
Public Function SplitRegion ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation _
) As Integer
Visual C++
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.

Return Value

The id of the region created by this operation.

Remarks

This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(). Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class
SplitRegion Overload


SplitRegion Method (UV, RectangularGridSegmentOrientation, Int32)

[image]

Revit 2013 API
CompoundStructure..::..SplitRegion Method (UV, RectangularGridSegmentOrientation, Int32%)
CompoundStructure Class See Also Send Feedback
Splits the region which contains the specified grid point by a line with the specified direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int SplitRegion(
    UV gridUV,
    RectangularGridSegmentOrientation splitDirection,
    out int newSegmentId
)
Visual Basic
Public Function SplitRegion ( _
    gridUV As UV, _
    splitDirection As RectangularGridSegmentOrientation, _
    <OutAttribute> ByRef newSegmentId As Integer _
) As Integer
Visual C++
public:
int SplitRegion(
    UV^ gridUV,
    RectangularGridSegmentOrientation splitDirection,
    [OutAttribute] int% newSegmentId
)

Parameters

gridUV
Type: Autodesk.Revit.DB..::..UV
Coordinates of a point in the rectangular grid of this compound structure.
splitDirection
Type: Autodesk.Revit.DB..::..RectangularGridSegmentOrientation
Specifies the direction of the split.
newSegmentId
Type: System..::..Int32%
The id of segment that bounds both the original region and the new region.

Return Value

The id of the region created by this operation.

Remarks

This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(). Grid coordinates correspond to uv coordinates of faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class
SplitRegion Overload


CompoundStructure Properties

[image] [image]

Revit 2013 API
CompoundStructure Properties
CompoundStructure Class See Also Send Feedback

The CompoundStructure type exposes the following members.

Properties

 | Name | Description
Public property | CutoffHeight | Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.
Public property | EndCap | Indicates the end cap condition defining which shell layers will participate in end wrapping.
Public property | HasStructuralDeck | Check if the compound structure has a structural deck.
Public property | IsEmpty | Checks whether this CompoundStructure is empty.
Public property | IsVerticallyCompound | Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.
Public property | LayerCount | Returns the number of layers represented by this CompoundStructure.
Public property | MinimumSampleHeight | The minimum sample height determined by the current sample height and the horizontal segments.
Public property | OpeningWrapping | Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.
Public property | SampleHeight | The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.
Public property | StructuralMaterialIndex | Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.
Public property | VariableLayerIndex | Indicates the index of the layer which is designated as variable.

See Also

CompoundStructure Class


CutoffHeight Property

[image]

Revit 2013 API
CompoundStructure..::..CutoffHeight Property
CompoundStructure Class See Also Send Feedback
Horizontal segments below or at the cutoff height have their distance to the wall bottom fixed, those above have their distance to the wall top fixed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CutoffHeight { get; set; }
Visual Basic
Public Property CutoffHeight As Double
    Get
    Set
Visual C++
public:
property double CutoffHeight {
    double get ();
    void set (double value);
}

Field Value

The cutoff height of this CompoundStructure.

Remarks

This allows layers with one horizontal segment above and one below this line to be of variable height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


EndCap Property

[image]

Revit 2013 API
CompoundStructure..::..EndCap Property
CompoundStructure Class See Also Send Feedback
Indicates the end cap condition defining which shell layers will participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EndCapCondition EndCap { get; set; }
Visual Basic
Public Property EndCap As EndCapCondition
    Get
    Set
Visual C++
public:
property EndCapCondition EndCap {
    EndCapCondition get ();
    void set (EndCapCondition value);
}

See Also

CompoundStructure Class


HasStructuralDeck Property

[image]

Revit 2013 API
CompoundStructure..::..HasStructuralDeck Property
CompoundStructure Class See Also Send Feedback
Check if the compound structure has a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasStructuralDeck { get; }
Visual Basic
Public ReadOnly Property HasStructuralDeck As Boolean
    Get
Visual C++
public:
property bool HasStructuralDeck {
    bool get ();
}

Field Value

True if IsStructuralDeck returns true for any one of the available layers.

See Also

CompoundStructure Class


IsEmpty Property

[image]

Revit 2013 API
CompoundStructure..::..IsEmpty Property
CompoundStructure Class See Also Send Feedback
Checks whether this CompoundStructure is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Field Value

True if there are no layers in the structure, false otherwise.

See Also

CompoundStructure Class


IsVerticallyCompound Property

[image]

Revit 2013 API
CompoundStructure..::..IsVerticallyCompound Property
CompoundStructure Class See Also Send Feedback
Identifies if this CompoundStructure represents a layout that is more complicated than a simple set of parallel layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsVerticallyCompound { get; }
Visual Basic
Public ReadOnly Property IsVerticallyCompound As Boolean
    Get
Visual C++
public:
property bool IsVerticallyCompound {
    bool get ();
}

Field Value

If true, then the layers of this CompoundStructure may be arranged into a grid pattern in two-dimension; otherwise it is a simple compound structure with a single set of parallel layers.

Remarks

Vertically compound structures should be assigned only to walls.

See Also

CompoundStructure Class


LayerCount Property

[image]

Revit 2013 API
CompoundStructure..::..LayerCount Property
CompoundStructure Class See Also Send Feedback
Returns the number of layers represented by this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int LayerCount { get; }
Visual Basic
Public ReadOnly Property LayerCount As Integer
    Get
Visual C++
public:
property int LayerCount {
    int get ();
}

Remarks

Establishes the valid range of indices passed to various access functions: 0 ... this value - 1

See Also

CompoundStructure Class


MinimumSampleHeight Property

[image]

Revit 2013 API
CompoundStructure..::..MinimumSampleHeight Property
CompoundStructure Class See Also Send Feedback
The minimum sample height determined by the current sample height and the horizontal segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double MinimumSampleHeight { get; }
Visual Basic
Public ReadOnly Property MinimumSampleHeight As Double
    Get
Visual C++
public:
property double MinimumSampleHeight {
    double get ();
}

Field Value

The smallest sample height that may be used for this compound structure.

Remarks

All horizontal segments dimensioned to the top must remain strictly above all horizontal segments dimensioned to the bottom.

See Also

CompoundStructure Class


OpeningWrapping Property

[image]

Revit 2013 API
CompoundStructure..::..OpeningWrapping Property
CompoundStructure Class See Also Send Feedback
Indicates the opening wrapping condition defining which shell layers of a wall, in plan view, wrap at inserts and openings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public OpeningWrappingCondition OpeningWrapping { get; set; }
Visual Basic
Public Property OpeningWrapping As OpeningWrappingCondition
    Get
    Set
Visual C++
public:
property OpeningWrappingCondition OpeningWrapping {
    OpeningWrappingCondition get ();
    void set (OpeningWrappingCondition value);
}

See Also

CompoundStructure Class


SampleHeight Property

[image]

Revit 2013 API
CompoundStructure..::..SampleHeight Property
CompoundStructure Class See Also Send Feedback
The sample height is the presumed height of the wall to which the data in this CompoundStructure is applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SampleHeight { get; set; }
Visual Basic
Public Property SampleHeight As Double
    Get
    Set
Visual C++
public:
property double SampleHeight {
    double get ();
    void set (double value);
}

Field Value

The height of the wall used to define the vertically compound structure.

Remarks

This value has meaning only for vertically compound structures. In order to apply this CompoundStructure to a wall whose height differs from the sample height, the underlying grid will be rescaled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation is valid only vertically compound structures.

See Also

CompoundStructure Class


StructuralMaterialIndex Property

[image]

Revit 2013 API
CompoundStructure..::..StructuralMaterialIndex Property
CompoundStructure Class See Also Send Feedback
Indicates the layer whose material defines the structural properties of the type for the purposes of analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int StructuralMaterialIndex { get; set; }
Visual Basic
Public Property StructuralMaterialIndex As Integer
    Get
    Set
Visual C++
public:
property int StructuralMaterialIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the layer containing the structural material properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The specified layer cannot define the structural material properties of the type.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The layer index is invalid.

See Also

CompoundStructure Class


VariableLayerIndex Property

[image]

Revit 2013 API
CompoundStructure..::..VariableLayerIndex Property
CompoundStructure Class See Also Send Feedback
Indicates the index of the layer which is designated as variable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int VariableLayerIndex { get; set; }
Visual Basic
Public Property VariableLayerIndex As Integer
    Get
    Set
Visual C++
public:
property int VariableLayerIndex {
    int get ();
    void set (int value);
}

Field Value

The index of the layer specified as variable. If there is no variable layer, this value is -1.

Remarks

If the host object to which it is applied has an actual width that exceeds the total width of all layers, then all layers except the variable layer will be created with their specified width, and the variable layer will expand to take up the slack. Generally this is applicable for floors and roofs with shape edits applied. There can be only one variable layer. In the wall compound structure UI, when a layer is labeled 'variable' in the thickness column, that means it is assigned either to a non-rectangular region, or it means the layer is assigned to two different layers. Neither of those situations is what this method refers to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The specified layer cannot be set to a variable layer.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The layer index is invalid.

See Also

CompoundStructure Class


CompoundStructureDeckUsage Enumeration

[image]

Revit 2013 API
CompoundStructureDeckUsage Enumeration
See Also Send Feedback
Describes how the deck relates to the surrounding layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum CompoundStructureDeckUsage
Visual Basic
Public Enumeration CompoundStructureDeckUsage
Visual C++
public enum class CompoundStructureDeckUsage

Members

Member name | Description
Invalid | Invalid.
MergeWithLayerAbove | Deck is merged with the layer above.
Standalone | Deck is independent of other layers.
MergeWithLayerBelow | Deck is merged with the layer below.

See Also


CompoundStructureError Enumeration

[image]

Revit 2013 API
CompoundStructureError Enumeration
See Also Send Feedback
When CompoundStructure::isValid() returns false, it uses these values to indicate precise nature of defect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum CompoundStructureError
Visual Basic
Public Enumeration CompoundStructureError
Visual C++
public enum class CompoundStructureError

Members

Member name | Description
BadShellOrder | Layer Function Priorities ascend from the Core Boundary to the Finish Face.
CoreTooThin | Core contain a membrane layer or thickness of core is zero.
LayerTooThin | Layers with non-zero thickness is less than a minimum thickness.
MembraneTooThick | Thickness of membrane layer is more than zero.
NonmembraneTooThin | Thickness of non-membrane layer is too thin.
BadShellsStructure | The number of shell layers is larger than the total number of layers.
ThinOuterLayer | Thickness of face layer is too thin.
VerticalUnusedLayer | A layer is not membrane layer and the Thickness of layer is zero.
VerticalWrongOrderLayer | Layers assigned to the same Row are not on the same side of the Core Boundary.
VerticalWrongOrderCoreExterior | Exterior core boundary have more than one face at any height.
VerticalWrongOrderCoreInterior | Interior core boundary have more than one face at any height.
VerticalWrongOrderMembrane | Membrane Layer have more than one face at any height.
DeckCantBoundAbove | There is no layer above Structural deck or it is too thin.
DeckCantBoundBelow | There is no layer below Structural deck or it is too thin.
VarThickLayerCantBeZero | Variable thickness layer have zero thickness.
InvalidMaterialId | Element id used as material id does not correspond to an actual MaterialElem.
ExtensibleRegionsNotContiguousAlongTop | Extension Layers at the top of the wall must be adjacent.
ExtensibleRegionsNotContiguousAlongBottom | Extension Layers at the bottom of the wall must be adjacent.
InvalidProfileId | Element id used as profile id does not correspond to a valid deck profile.

See Also


CompoundStructureLayer Class

[image]

Revit 2013 API
CompoundStructureLayer Class
Members See Also Send Feedback
Describes a single layer in a CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CompoundStructureLayer : IDisposable
Visual Basic
Public Class CompoundStructureLayer _
    Implements IDisposable
Visual C++
public ref class CompoundStructureLayer : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CompoundStructureLayer

See Also

CompoundStructureLayer Members


CompoundStructureLayer Members

[image] [image]

Revit 2013 API
CompoundStructureLayer Members
CompoundStructureLayer Class Constructors Methods Properties See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Constructors

 | Name | Description
Public method | CompoundStructureLayer()()()() | Creates a default compound structure layer.
Public method | CompoundStructureLayer(CompoundStructureLayer) | Creates a copy of compound structure layer.
Public method | CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) | Creates a default compound structure layer based on the given width, function and material element id.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CompoundStructureLayer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | LayerCapFlag | Identifies if the layer participates in the cap work.
Public property | LayerId | The id of the layer - may be different from the index in the array of layers in a CompoundStructure.
Public property | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.

See Also

CompoundStructureLayer Class


CompoundStructureLayer Constructor

[image] [image]

Revit 2013 API
CompoundStructureLayer Constructor
CompoundStructureLayer Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CompoundStructureLayer()()()() | Creates a default compound structure layer.
Public method | CompoundStructureLayer(CompoundStructureLayer) | Creates a copy of compound structure layer.
Public method | CompoundStructureLayer(Double, MaterialFunctionAssignment, ElementId) | Creates a default compound structure layer based on the given width, function and material element id.

See Also

CompoundStructureLayer Class
CompoundStructureLayer Members


CompoundStructureLayer Constructor

[image]

Revit 2013 API
CompoundStructureLayer Constructor
CompoundStructureLayer Class See Also Send Feedback
Creates a default compound structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructureLayer()
Visual Basic
Public Sub New
Visual C++
public:
CompoundStructureLayer()

Remarks

Sets Width to 0. Sets Function to None. Sets DeckEmbeddingType to Invalid. Sets MaterialId to invalidElementId. Sets DeckProfileId to invalidElementId. Sets LayerCapFlag to true. Note that the combination of these default values does not create a completely valid CompoundStructureLayer. You should change the necessary values before adding to a CompoundStructure.

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Constructor (CompoundStructureLayer)

[image]

Revit 2013 API
CompoundStructureLayer Constructor (CompoundStructureLayer)
CompoundStructureLayer Class See Also Send Feedback
Creates a copy of compound structure layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructureLayer(
    CompoundStructureLayer cs
)
Visual Basic
Public Sub New ( _
    cs As CompoundStructureLayer _
)
Visual C++
public:
CompoundStructureLayer(
    CompoundStructureLayer^ cs
)

Parameters

cs
Type: Autodesk.Revit.DB..::..CompoundStructureLayer

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)

[image]

Revit 2013 API
CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)
CompoundStructureLayer Class See Also Send Feedback
Creates a default compound structure layer based on the given width, function and material element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId materialId
)
Visual Basic
Public Sub New ( _
    width As Double, _
    function As MaterialFunctionAssignment, _
    materialId As ElementId _
)
Visual C++
public:
CompoundStructureLayer(
    double width,
    MaterialFunctionAssignment function,
    ElementId^ materialId
)

Parameters

width
Type: System..::..Double
The width of the layer.
function
Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.
materialId
Type: Autodesk.Revit.DB..::..ElementId
The material element id of the layer.

Remarks

Sets LayerCapFlag to true. Sets DeckEmbeddingType to Invalid. Sets DeckProfileId to invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CompoundStructureLayer Class
CompoundStructureLayer Overload


CompoundStructureLayer Methods

[image] [image]

Revit 2013 API
CompoundStructureLayer Methods
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CompoundStructureLayer Class


Dispose Method

[image]

Revit 2013 API
CompoundStructureLayer..::..Dispose Method
CompoundStructureLayer Class See Also Send Feedback
Releases all resources used by the CompoundStructureLayer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CompoundStructureLayer Class


CompoundStructureLayer Properties

[image] [image]

Revit 2013 API
CompoundStructureLayer Properties
CompoundStructureLayer Class See Also Send Feedback

The CompoundStructureLayer type exposes the following members.

Properties

 | Name | Description
Public property | DeckEmbeddingType | Embedding type for structural deck - only for a layer whose function is StructuralDeck.
Public property | DeckProfileId | The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.
Public property | Function | The function of the layer.
Public property | LayerCapFlag | Identifies if the layer participates in the cap work.
Public property | LayerId | The id of the layer - may be different from the index in the array of layers in a CompoundStructure.
Public property | MaterialId | Id of the material assigned to this layer.
Public property | Width | Width of the layer.

See Also

CompoundStructureLayer Class


DeckEmbeddingType Property

[image]

Revit 2013 API
CompoundStructureLayer..::..DeckEmbeddingType Property
CompoundStructureLayer Class See Also Send Feedback
Embedding type for structural deck - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructDeckEmbeddingType DeckEmbeddingType { get; set; }
Visual Basic
Public Property DeckEmbeddingType As StructDeckEmbeddingType
    Get
    Set
Visual C++
public:
property StructDeckEmbeddingType DeckEmbeddingType {
    StructDeckEmbeddingType get ();
    void set (StructDeckEmbeddingType value);
}

See Also

CompoundStructureLayer Class


DeckProfileId Property

[image]

Revit 2013 API
CompoundStructureLayer..::..DeckProfileId Property
CompoundStructureLayer Class See Also Send Feedback
The ElementId of the structural deck profile - only for a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId DeckProfileId { get; set; }
Visual Basic
Public Property DeckProfileId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DeckProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

CompoundStructureLayer Class


Function Property

[image]

Revit 2013 API
CompoundStructureLayer..::..Function Property
CompoundStructureLayer Class See Also Send Feedback
The function of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MaterialFunctionAssignment Function { get; set; }
Visual Basic
Public Property Function As MaterialFunctionAssignment
    Get
    Set
Visual C++
public:
property MaterialFunctionAssignment Function {
    MaterialFunctionAssignment get ();
    void set (MaterialFunctionAssignment value);
}

See Also

CompoundStructureLayer Class


LayerCapFlag Property

[image]

Revit 2013 API
CompoundStructureLayer..::..LayerCapFlag Property
CompoundStructureLayer Class See Also Send Feedback
Identifies if the layer participates in the cap work.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool LayerCapFlag { get; set; }
Visual Basic
Public Property LayerCapFlag As Boolean
    Get
    Set
Visual C++
public:
property bool LayerCapFlag {
    bool get ();
    void set (bool value);
}

Remarks

It is meaningful only for shell layers; The default value is "true".

See Also

CompoundStructureLayer Class


LayerId Property

[image]

Revit 2013 API
CompoundStructureLayer..::..LayerId Property
CompoundStructureLayer Class See Also Send Feedback
The id of the layer - may be different from the index in the array of layers in a CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int LayerId { get; }
Visual Basic
Public ReadOnly Property LayerId As Integer
    Get
Visual C++
public:
property int LayerId {
    int get ();
}

See Also

CompoundStructureLayer Class


MaterialId Property

[image]

Revit 2013 API
CompoundStructureLayer..::..MaterialId Property
CompoundStructureLayer Class Example See Also Send Feedback
Id of the material assigned to this layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Examples

CopyC#
public void GetWallLayerMaterial(Autodesk.Revit.DB.Document document, Wall wall)
{
    // get WallType of wall
    WallType aWallType = wall.WallType;
    // Only Basic Wall has compoundStructure
    if (WallKind.Basic == aWallType.Kind)
    {
        // Get CompoundStructure
        CompoundStructure comStruct = aWallType.GetCompoundStructure();
        Categories allCategories = document.Settings.Categories;

        // Get the category OST_Walls default Material;
        // use if that layer's default Material is <By Category>
        Category wallCategory = allCategories.get_Item(BuiltInCategory.OST_Walls);
        Autodesk.Revit.DB.Material wallMaterial = wallCategory.Material;

        foreach (CompoundStructureLayer structLayer in comStruct.GetLayers())
        {
            Autodesk.Revit.DB.Material layerMaterial = document.GetElement(structLayer.MaterialId) as Material;

            // If CompoundStructureLayer's Material is specified, use default
            // Material of its Category
            if (null == layerMaterial)
            {
                switch (structLayer.Function)
                {
                    case MaterialFunctionAssignment.Finish1:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish1).Material;
                        break;
                    case MaterialFunctionAssignment.Finish2:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsFinish2).Material;
                        break;
                    case MaterialFunctionAssignment.Membrane:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsMembrane).Material;
                        break;
                    case MaterialFunctionAssignment.Structure:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsStructure).Material;
                        break;
                    case MaterialFunctionAssignment.Substrate:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsSubstrate).Material;
                        break;
                    case MaterialFunctionAssignment.Insulation:
                        layerMaterial =
                            allCategories.get_Item(BuiltInCategory.OST_WallsInsulation).Material;
                        break;
                    default:
                        // It is impossible to reach here
                        break;
                }
                if (null == layerMaterial)
                {
                    // CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial;
                }
            }
            TaskDialog.Show("Revit","Layer Material: " + layerMaterial);
        }
    }
}
CopyVB.NET
Public Sub GetWallLayerMaterial(ByVal document As Autodesk.Revit.DB.Document, ByVal wall As Wall)
    ' get WallType of wall
    Dim aWallType As Autodesk.Revit.DB.WallType = wall.WallType
    ' Only Basic Wall has compoundStructure
    If WallKind.Basic = aWallType.Kind Then
        ' Get CompoundStructure
        Dim comStruct As Autodesk.Revit.DB.CompoundStructure = aWallType.CompoundStructure
        Dim allCategories As Categories = document.Settings.Categories

        ' Get the category OST_Walls default Material;
        ' use if that layer's default Material is <By Category>
        Dim wallCategory As Autodesk.Revit.DB.Category = allCategories.Item(BuiltInCategory.OST_Walls)
        Dim wallMaterial As Autodesk.Revit.DB.Material = wallCategory.Material

        For Each structLayer As Autodesk.Revit.DB.CompoundStructureLayer In comStruct.Layers
            Dim layerMaterial As Autodesk.Revit.DB.Material = structLayer.Material
            ' If CompoundStructureLayer's Material is specified, use default
            ' Material of its Category
            If layerMaterial Is Nothing Then
                Select Case structLayer.[Function]
                    Case CompoundStructureLayerFunction.Finish1
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish1).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Finish2
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsFinish2).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.MembraneLayer
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsMembrane).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.[Structure]
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsStructure).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.Substrate
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsSubstrate).Material
                        Exit Select
                    Case CompoundStructureLayerFunction.ThermalOrAir
                        layerMaterial = allCategories.Item(BuiltInCategory.OST_WallsInsulation).Material
                        Exit Select
                    Case Else
                        ' It is impossible to reach here
                        Exit Select
                End Select
                If layerMaterial Is Nothing Then
                    ' CompoundStructureLayer's default Material is its SubCategory
                    layerMaterial = wallMaterial
                End If
            End If
            TaskDialog.Show("Revit", "Layer Material: " & layerMaterial.ToString())
        Next
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

CompoundStructureLayer Class


Width Property

[image]

Revit 2013 API
CompoundStructureLayer..::..Width Property
CompoundStructureLayer Class See Also Send Feedback
Width of the layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

Can be 0.0 if this is a membrane layer.

See Also

CompoundStructureLayer Class


CompoundStructureLayerFunction Enumeration

[image]

Revit 2013 API
CompoundStructureLayerFunction Enumeration
See Also Send Feedback
Describes the purpose of the layer within a compound structure, such as a wall or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum CompoundStructureLayerFunction
Visual Basic
Public Enumeration CompoundStructureLayerFunction
Visual C++
public enum class CompoundStructureLayerFunction

Members

Member name | Description
Structure | A structural layer.
Substrate | A substrate layer.
ThermalOrAir | A thermal or air insulating layer.
Finish1 | A finish layer.
Finish2 | A finish layer.
MembraneLayer | A membrane layer.
StructuralDeck | A special layer considered to be structural decking.

See Also


ConicalFace Class

[image]

Revit 2013 API
ConicalFace Class
Members Example See Also Send Feedback
A cone face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConicalFace : Face
Visual Basic
Public Class ConicalFace _
    Inherits Face
Visual C++
public ref class ConicalFace : public Face

Remarks

Cone faces are defined by cone surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + v*[sin(HalfAngle)*(cos(u)*Radius[0] + sin(u)*Radius[1]) + cos(HalfAngle)*Axis]

Examples

CopyC#
private void GetConicalFaceInfo(Face face)
{
    ConicalFace conicalFace = face as ConicalFace;
    if (null != conicalFace)
    {
       XYZ axis = conicalFace.Axis;
       XYZ origin = conicalFace.Origin;
        double halfAngle = conicalFace.HalfAngle;
        XYZ radius = conicalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetConicalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim conicalFace As ConicalFace = TryCast(face, ConicalFace)
    If conicalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = conicalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = conicalFace.Origin
        Dim halfAngle As Double = conicalFace.HalfAngle
        Dim radius As Autodesk.Revit.DB.XYZ = conicalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..ConicalFace

See Also

ConicalFace Members


ConicalFace Members

[image] [image]

Revit 2013 API
ConicalFace Members
ConicalFace Class Methods Properties See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


ConicalFace Methods

[image] [image]

Revit 2013 API
ConicalFace Methods
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

ConicalFace Class


Intersect Method

[image] [image]

Revit 2013 API
ConicalFace..::..Intersect Method
ConicalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


IsInside Method

[image] [image]

Revit 2013 API
ConicalFace..::..IsInside Method
ConicalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


Triangulate Method

[image] [image]

Revit 2013 API
ConicalFace..::..Triangulate Method
ConicalFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

ConicalFace Class
ConicalFace Members


ConicalFace Properties

[image] [image]

Revit 2013 API
ConicalFace Properties
ConicalFace Class See Also Send Feedback

The ConicalFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HalfAngle | Half angle of the surface.
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

ConicalFace Class


Axis Property

[image]

Revit 2013 API
ConicalFace..::..Axis Property
ConicalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

ConicalFace Class


HalfAngle Property

[image]

Revit 2013 API
ConicalFace..::..HalfAngle Property
ConicalFace Class See Also Send Feedback
Half angle of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HalfAngle { get; }
Visual Basic
Public ReadOnly Property HalfAngle As Double
    Get
Visual C++
public:
property double HalfAngle {
    double get ();
}

See Also

ConicalFace Class


Origin Property

[image]

Revit 2013 API
ConicalFace..::..Origin Property
ConicalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

ConicalFace Class


Radius Property

[image]

Revit 2013 API
ConicalFace..::..Radius Property
ConicalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

ConicalFace Class


Connector Class

[image]

Revit 2013 API
Connector Class
Members Example See Also Send Feedback
A connector in an Autodesk Revit MEP project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Connector : IConnector, IDisposable
Visual Basic
Public Class Connector _
    Implements IConnector, IDisposable
Visual C++
public ref class Connector : IConnector,
    IDisposable

Remarks

This connector is an item that is a part of another element (duct, pipe, fitting, or equipment etc.). This connector does not represent the connector element that can be created inside a family; for that element, refer to DuctConnector, PipeConnector and ElectricalConnector.

Examples

CopyC#
public void GetElementAtConnector(Autodesk.Revit.DB.Connector connector)
{
    MEPSystem mepSystem = connector.MEPSystem;
    if (null != mepSystem)
    {
        string message = "Connector is owned by: " + connector.Owner.Name;

        if (connector.IsConnected == true)
        {
            ConnectorSet connectorSet = connector.AllRefs;
            ConnectorSetIterator csi = connectorSet.ForwardIterator();
            while (csi.MoveNext())
            {
                Connector connected = csi.Current as Connector;
                if (null != connected)
                {
                    // look for physical connections
                    if (connected.ConnectorType == ConnectorType.End ||
                        connected.ConnectorType == ConnectorType.Curve ||
                        connected.ConnectorType == ConnectorType.Physical)
                    {
                        message += "\nConnector is connected to: " + connected.Owner.Name;
                        message += "\nConnection type is: " + connected.ConnectorType;
                    }
                }
            }
        }
        else
        {
            message += "\nConnector is not connected to anything.";
        }

        TaskDialog.Show("Revit", message);
    }
}
CopyVB.NET
Public Sub GetElementAtConnector(ByVal connector As Autodesk.Revit.DB.Connector)
    Dim mepSystem As MEPSystem = connector.MEPSystem
    If mepSystem IsNot Nothing Then
        Dim message As String = "Connector is owned by: " + connector.Owner.Name

        If connector.IsConnected = True Then
            Dim connectorSet As ConnectorSet = connector.AllRefs
            Dim csi As ConnectorSetIterator = connectorSet.ForwardIterator()
            While csi.MoveNext()
                Dim connected As Connector = TryCast(csi.Current, Connector)
                If connected IsNot Nothing Then
                    ' look for physical connections
                    If connected.ConnectorType = ConnectorType.EndConn OrElse connected.ConnectorType = ConnectorType.CurveConn OrElse connected.ConnectorType = ConnectorType.PhysicalConn Then
                        message += vbLf & "Connector is connected to: " + connected.Owner.Name
                        message += vbLf & "Connection type is: " + connected.ConnectorType
                    End If
                End If
            End While
        Else
            message += vbLf & "Connector is not connected to anything."
        End If

        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Connector

See Also

Connector Members


Connector Members

[image] [image]

Revit 2013 API
Connector Members
Connector Class Methods Properties See Also Send Feedback

The Connector type exposes the following members.

Methods

 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose | Releases all resources used by the Connector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length
Public property | Flow | The flow of the connector.
Public property | GenderType | Connector gender type
Public property | Height | The height of the connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | JointType | Connector joint type
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.

See Also

Connector Class


Connector Methods

[image] [image]

Revit 2013 API
Connector Methods
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Methods

 | Name | Description
Public method | ConnectTo | Make connection between two connectors.
Public method | DisconnectFrom | Remove connection between two connectors.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsConnectedTo | Identifies if the connector is connected to the specified connector.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Connector Class


ConnectTo Method

[image]

Revit 2013 API
Connector..::..ConnectTo Method
Connector Class See Also Send Feedback
Make connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ConnectTo(
    Connector connector
)
Visual Basic
Public Sub ConnectTo ( _
    connector As Connector _
)
Visual C++
public:
void ConnectTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
Indicate the connector will be connected to.

Remarks

Connection success may create a new Fitting between two connectors, if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when two connectors with different domain types. Thrown when these two connectors fail to connect each other. Thrown when connection already exists.

See Also

Connector Class


DisconnectFrom Method

[image]

Revit 2013 API
Connector..::..DisconnectFrom Method
Connector Class See Also Send Feedback
Remove connection between two connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DisconnectFrom(
    Connector connector
)
Visual Basic
Public Sub DisconnectFrom ( _
    connector As Connector _
)
Visual C++
public:
void DisconnectFrom(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector
Indicate the connector, connection will be removed from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no connection between these two connector. Thrown on failure to remove the connection between these two connectors.

See Also

Connector Class


Dispose Method

[image]

Revit 2013 API
Connector..::..Dispose Method
Connector Class See Also Send Feedback
Releases all resources used by the Connector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Connector Class


IsConnectedTo Method

[image]

Revit 2013 API
Connector..::..IsConnectedTo Method
Connector Class See Also Send Feedback
Identifies if the connector is connected to the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsConnectedTo(
    Connector connector
)
Visual Basic
Public Function IsConnectedTo ( _
    connector As Connector _
) As Boolean
Visual C++
public:
bool IsConnectedTo(
    Connector^ connector
)

Parameters

connector
Type: Autodesk.Revit.DB..::..Connector

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Connector Class


Connector Properties

[image] [image]

Revit 2013 API
Connector Properties
Connector Class See Also Send Feedback

The Connector type exposes the following members.

Properties

 | Name | Description
Public property | AllRefs | All references of the connector.
Public property | Angle | The angle of the Connector.
Public property | AssignedDuctFlowConfiguration | The assigned duct flow configuration of the connector.
Public property | AssignedDuctLossMethod | The duct loss method of the connector.
Public property | AssignedFixtureUnits | The assigned fixture units of the connector.
Public property | AssignedFlow | The assigned flow of the connector.
Public property | AssignedFlowDirection | The assigned flow direction of the connector.
Public property | AssignedFlowFactor | The assigned flow factor of this connector.
Public property | AssignedKCoefficient | The assigned kCoefficient of the connector.
Public property | AssignedLossCoefficient | The assigned loss coefficient of the connector.
Public property | AssignedPipeFlowConfiguration | The pipe flow configuration type of the connector.
Public property | AssignedPipeLossMethod | The pipe loss method of the connector.
Public property | AssignedPressureDrop | The assigned pressure drop of the connector.
Public property | Coefficient | The coefficient of the connector.
Public property | ConnectorManager | The connector manager of the connector.
Public property | ConnectorType | The connector type of the connector.
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Demand | The demand of the connector.
Public property | Direction | The direction of the connector.
Public property | Domain | The domain of the connector.
Public property | DuctSystemType | The duct system type of the connector.
Public property | ElectricalSystemType | The electrical system type of the connector.
Public property | EngagementLength | Connector engagement length
Public property | Flow | The flow of the connector.
Public property | GenderType | Connector gender type
Public property | Height | The height of the connector.
Public property | IsConnected | Identifies if the connector is physically connected to a connector on another element.
Public property | IsMovable | whether the connector can be moved.
Public property | JointType | Connector joint type
Public property | MEPSystem | The system of the connector belong to.
Public property | Origin | The location of the connector.
Public property | Owner | The host of the connector.
Public property | PipeSystemType | The pipe system type of the connector.
Public property | PressureDrop | The pressure drop of the connector.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | VelocityPressure | The velocity pressure of the connector.
Public property | Width | The width of the connector.

See Also

Connector Class


AllRefs Property

[image]

Revit 2013 API
Connector..::..AllRefs Property
Connector Class See Also Send Feedback
All references of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorSet AllRefs { get; }
Visual Basic
Public ReadOnly Property AllRefs As ConnectorSet
    Get
Visual C++
public:
property ConnectorSet^ AllRefs {
    ConnectorSet^ get ();
}

Remarks

A set of connectors that the connectors is connected to, including both physical connection and logical connection.

See Also

Connector Class


Angle Property

[image]

Revit 2013 API
Connector..::..Angle Property
Connector Class See Also Send Feedback
The angle of the Connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

Angle may be assigned for connectors of some family instances, for more information, refer to PipeConnector or DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition. For a connector obtained from a non-family instance (for example not a fitting, but instead a pipe, duct, or cable tray), the value will always be zero. Non-zero angles are only valid for family instance fitting connectors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac, DomainPiping, or DomainCableTrayConduit. Thrown when set value for the connector not in family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set angle.

See Also

Connector Class


AssignedDuctFlowConfiguration Property

[image]

Revit 2013 API
Connector..::..AssignedDuctFlowConfiguration Property
Connector Class See Also Send Feedback
The assigned duct flow configuration of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctFlowConfigurationType AssignedDuctFlowConfiguration { get; }
Visual Basic
Public ReadOnly Property AssignedDuctFlowConfiguration As DuctFlowConfigurationType
    Get
Visual C++
public:
property DuctFlowConfigurationType AssignedDuctFlowConfiguration {
    DuctFlowConfigurationType get ();
}

Remarks

Assigned duct flow configuration may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct flow configuration.

See Also

Connector Class


AssignedDuctLossMethod Property

[image]

Revit 2013 API
Connector..::..AssignedDuctLossMethod Property
Connector Class See Also Send Feedback
The duct loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctLossMethodType AssignedDuctLossMethod { get; }
Visual Basic
Public ReadOnly Property AssignedDuctLossMethod As DuctLossMethodType
    Get
Visual C++
public:
property DuctLossMethodType AssignedDuctLossMethod {
    DuctLossMethodType get ();
}

Remarks

Assigned duct loss method may be assigned for connectors of some family instances, for more information, refer to DuctConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct loss method.

See Also

Connector Class


AssignedFixtureUnits Property

[image]

Revit 2013 API
Connector..::..AssignedFixtureUnits Property
Connector Class See Also Send Feedback
The assigned fixture units of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedFixtureUnits { get; set; }
Visual Basic
Public Property AssignedFixtureUnits As Double
    Get
    Set
Visual C++
public:
property double AssignedFixtureUnits {
    double get ();
    void set (double value);
}

Remarks

Assigned fixture units may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned fixture units.

See Also

Connector Class


AssignedFlow Property

[image]

Revit 2013 API
Connector..::..AssignedFlow Property
Connector Class See Also Send Feedback
The assigned flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedFlow { get; set; }
Visual Basic
Public Property AssignedFlow As Double
    Get
    Set
Visual C++
public:
property double AssignedFlow {
    double get ();
    void set (double value);
}

Remarks

Assigned flow may be assigned for connectors of some family instances, for more information, refer to PipeConnector, DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned flow.

See Also

Connector Class


AssignedFlowDirection Property

[image]

Revit 2013 API
Connector..::..AssignedFlowDirection Property
Connector Class See Also Send Feedback
The assigned flow direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlowDirectionType AssignedFlowDirection { get; }
Visual Basic
Public ReadOnly Property AssignedFlowDirection As FlowDirectionType
    Get
Visual C++
public:
property FlowDirectionType AssignedFlowDirection {
    FlowDirectionType get ();
}

Remarks

Flow direction may be assigned for connectors of some family instances. For more information, seeDuctConnector, PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get assigned flow direction.

See Also

Connector Class


AssignedFlowFactor Property

[image]

Revit 2013 API
Connector..::..AssignedFlowFactor Property
Connector Class See Also Send Feedback
The assigned flow factor of this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedFlowFactor { get; set; }
Visual Basic
Public Property AssignedFlowFactor As Double
    Get
    Set
Visual C++
public:
property double AssignedFlowFactor {
    double get ();
    void set (double value);
}

Remarks

Assigned flow factor may be assigned for connectors of some family instances, for more information, refer to DuctConnector, PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..ArgumentException | Throw when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned flow factor.

See Also

Connector Class


AssignedKCoefficient Property

[image]

Revit 2013 API
Connector..::..AssignedKCoefficient Property
Connector Class See Also Send Feedback
The assigned kCoefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedKCoefficient { get; set; }
Visual Basic
Public Property AssignedKCoefficient As Double
    Get
    Set
Visual C++
public:
property double AssignedKCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned kCoefficient may be assigned for connectors of some family instances, for more information, refer to PipeConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set kCoefficient.

See Also

Connector Class


AssignedLossCoefficient Property

[image]

Revit 2013 API
Connector..::..AssignedLossCoefficient Property
Connector Class See Also Send Feedback
The assigned loss coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedLossCoefficient { get; set; }
Visual Basic
Public Property AssignedLossCoefficient As Double
    Get
    Set
Visual C++
public:
property double AssignedLossCoefficient {
    double get ();
    void set (double value);
}

Remarks

Assigned loss coefficient may be assigned for connectors of some family instances, for more information, refer to DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned loss coefficient.

See Also

Connector Class


AssignedPipeFlowConfiguration Property

[image]

Revit 2013 API
Connector..::..AssignedPipeFlowConfiguration Property
Connector Class See Also Send Feedback
The pipe flow configuration type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeFlowConfigurationType AssignedPipeFlowConfiguration { get; }
Visual Basic
Public ReadOnly Property AssignedPipeFlowConfiguration As PipeFlowConfigurationType
    Get
Visual C++
public:
property PipeFlowConfigurationType AssignedPipeFlowConfiguration {
    PipeFlowConfigurationType get ();
}

Remarks

Assigned pipe flow configuration may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe flow configuration.

See Also

Connector Class


AssignedPipeLossMethod Property

[image]

Revit 2013 API
Connector..::..AssignedPipeLossMethod Property
Connector Class See Also Send Feedback
The pipe loss method of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeLossMethodType AssignedPipeLossMethod { get; }
Visual Basic
Public ReadOnly Property AssignedPipeLossMethod As PipeLossMethodType
    Get
Visual C++
public:
property PipeLossMethodType AssignedPipeLossMethod {
    PipeLossMethodType get ();
}

Remarks

Assigned duct pipe loss method may be assigned for connectors of some family instances, for more information, refer to PipeConnector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping. Thrown when the connector is not in a family instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe loss method.

See Also

Connector Class


AssignedPressureDrop Property

[image]

Revit 2013 API
Connector..::..AssignedPressureDrop Property
Connector Class See Also Send Feedback
The assigned pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AssignedPressureDrop { get; set; }
Visual Basic
Public Property AssignedPressureDrop As Double
    Get
    Set
Visual C++
public:
property double AssignedPressureDrop {
    double get ();
    void set (double value);
}

Remarks

Assigned pressure drop may be assigned for connectors of some family instances, for more information, refer to PipeConnector, DuctConnector. In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector is not in a family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when set an invalid value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get or set assigned pressure drop.

See Also

Connector Class


Coefficient Property

[image]

Revit 2013 API
Connector..::..Coefficient Property
Connector Class See Also Send Feedback
The coefficient of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Coefficient { get; }
Visual Basic
Public ReadOnly Property Coefficient As Double
    Get
Visual C++
public:
property double Coefficient {
    double get ();
}

Remarks

Instantaneous coefficient of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


ConnectorManager Property

[image]

Revit 2013 API
Connector..::..ConnectorManager Property
Connector Class See Also Send Feedback
The connector manager of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get connector manager.

See Also

Connector Class


ConnectorType Property

[image]

Revit 2013 API
Connector..::..ConnectorType Property
Connector Class See Also Send Feedback
The connector type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorType ConnectorType { get; }
Visual Basic
Public ReadOnly Property ConnectorType As ConnectorType
    Get
Visual C++
public:
property ConnectorType ConnectorType {
    ConnectorType get ();
}

See Also

Connector Class


CoordinateSystem Property

[image]

Revit 2013 API
Connector..::..CoordinateSystem Property
Connector Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic
Public Overridable ReadOnly Property CoordinateSystem As Transform
    Get
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::..CoordinateSystem

Remarks

The coordinate system's origin is the location of the connector and the Z-axis is normal to the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector is of logical type.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get coordinate system.

See Also

Connector Class


Demand Property

[image]

Revit 2013 API
Connector..::..Demand Property
Connector Class See Also Send Feedback
The demand of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Demand { get; }
Visual Basic
Public ReadOnly Property Demand As Double
    Get
Visual C++
public:
property double Demand {
    double get ();
}

Remarks

Instantaneous demand at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get demand.

See Also

Connector Class


Direction Property

[image]

Revit 2013 API
Connector..::..Direction Property
Connector Class See Also Send Feedback
The direction of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlowDirectionType Direction { get; }
Visual Basic
Public ReadOnly Property Direction As FlowDirectionType
    Get
Visual C++
public:
property FlowDirectionType Direction {
    FlowDirectionType get ();
}

Remarks

Instantaneous direction of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get direction.

See Also

Connector Class


Domain Property

[image]

Revit 2013 API
Connector..::..Domain Property
Connector Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic
Public Overridable ReadOnly Property Domain As Domain
    Get
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::..Domain

See Also

Connector Class


DuctSystemType Property

[image]

Revit 2013 API
Connector..::..DuctSystemType Property
Connector Class See Also Send Feedback
The duct system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSystemType DuctSystemType { get; }
Visual Basic
Public ReadOnly Property DuctSystemType As DuctSystemType
    Get
Visual C++
public:
property DuctSystemType DuctSystemType {
    DuctSystemType get ();
}

Remarks

This is the instantaneous system type at this connector, calculated according to system. For unconnected connectors, the system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get duct system type.

See Also

Connector Class


ElectricalSystemType Property

[image]

Revit 2013 API
Connector..::..ElectricalSystemType Property
Connector Class See Also Send Feedback
The electrical system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemType ElectricalSystemType { get; }
Visual Basic
Public ReadOnly Property ElectricalSystemType As ElectricalSystemType
    Get
Visual C++
public:
property ElectricalSystemType ElectricalSystemType {
    ElectricalSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not of DomainElectrical.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get electrical system type.

See Also

Connector Class


EngagementLength Property

[image]

Revit 2013 API
Connector..::..EngagementLength Property
Connector Class See Also Send Feedback
Connector engagement length

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double EngagementLength { get; }
Visual Basic
Public ReadOnly Property EngagementLength As Double
    Get
Visual C++
public:
property double EngagementLength {
    double get ();
}

See Also

Connector Class


Flow Property

[image]

Revit 2013 API
Connector..::..Flow Property
Connector Class See Also Send Feedback
The flow of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Flow { get; }
Visual Basic
Public ReadOnly Property Flow As Double
    Get
Visual C++
public:
property double Flow {
    double get ();
}

Remarks

Instantaneous flow at this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping or DomainHvac.

See Also

Connector Class


GenderType Property

[image]

Revit 2013 API
Connector..::..GenderType Property
Connector Class See Also Send Feedback
Connector gender type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorGenderType GenderType { get; }
Visual Basic
Public ReadOnly Property GenderType As ConnectorGenderType
    Get
Visual C++
public:
property ConnectorGenderType GenderType {
    ConnectorGenderType get ();
}

See Also

Connector Class


Height Property

[image]

Revit 2013 API
Connector..::..Height Property
Connector Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Height { get; set; }
Visual Basic
Public Overridable Property Height As Double
    Get
    Set
Visual C++
public:
virtual property double Height {
    double get ();
    void set (double value);
}

Implements

IConnector..::..Height

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set height.

See Also

Connector Class


IsConnected Property

[image]

Revit 2013 API
Connector..::..IsConnected Property
Connector Class See Also Send Feedback
Identifies if the connector is physically connected to a connector on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsConnected { get; }
Visual Basic
Public ReadOnly Property IsConnected As Boolean
    Get
Visual C++
public:
property bool IsConnected {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's type is LogicalConn.

See Also

Connector Class


IsMovable Property

[image]

Revit 2013 API
Connector..::..IsMovable Property
Connector Class See Also Send Feedback
whether the connector can be moved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsMovable { get; }
Visual Basic
Public ReadOnly Property IsMovable As Boolean
    Get
Visual C++
public:
property bool IsMovable {
    bool get ();
}

Remarks

Only connectors of type EndConn can be moved.

See Also

Connector Class


JointType Property

[image]

Revit 2013 API
Connector..::..JointType Property
Connector Class See Also Send Feedback
Connector joint type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorJointType JointType { get; }
Visual Basic
Public ReadOnly Property JointType As ConnectorJointType
    Get
Visual C++
public:
property ConnectorJointType JointType {
    ConnectorJointType get ();
}

See Also

Connector Class


MEPSystem Property

[image]

Revit 2013 API
Connector..::..MEPSystem Property
Connector Class See Also Send Feedback
The system of the connector belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic
Public ReadOnly Property MEPSystem As MEPSystem
    Get
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get system.

See Also

Connector Class


Origin Property

[image]

Revit 2013 API
Connector..::..Origin Property
Connector Class See Also Send Feedback
The location of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual XYZ Origin { get; set; }
Visual Basic
Public Overridable Property Origin As XYZ
    Get
    Set
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Implements

IConnector..::..Origin

Remarks

Changing the location of the connector may lead to changes of location and geometry for the connector's host element and the hosts for other elements the element is connected to.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when connector's type is NonEndConn. Thrown when the connector is a part of a family instance.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the assigned origin is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set origin.

See Also

Connector Class


Owner Property

[image]

Revit 2013 API
Connector..::..Owner Property
Connector Class See Also Send Feedback
The host of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Element
    Get
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

Remarks

The element that contains this connector. It may also contain other connectors.

See Also

Connector Class


PipeSystemType Property

[image]

Revit 2013 API
Connector..::..PipeSystemType Property
Connector Class See Also Send Feedback
The pipe system type of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeSystemType PipeSystemType { get; }
Visual Basic
Public ReadOnly Property PipeSystemType As PipeSystemType
    Get
Visual C++
public:
property PipeSystemType PipeSystemType {
    PipeSystemType get ();
}

Remarks

Instantaneous system type at this connector, calculated according to system. For unconnected connectors, system type is undefined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainPiping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to get pipe system type.

See Also

Connector Class


PressureDrop Property

[image]

Revit 2013 API
Connector..::..PressureDrop Property
Connector Class See Also Send Feedback
The pressure drop of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double PressureDrop { get; }
Visual Basic
Public ReadOnly Property PressureDrop As Double
    Get
Visual C++
public:
property double PressureDrop {
    double get ();
}

Remarks

Instantaneous pressure drop of this connector, calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


Radius Property

[image]

Revit 2013 API
Connector..::..Radius Property
Connector Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Radius { get; set; }
Visual Basic
Public Overridable Property Radius As Double
    Get
    Set
Visual C++
public:
virtual property double Radius {
    double get ();
    void set (double value);
}

Implements

IConnector..::..Radius

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not round.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set radius.

See Also

Connector Class


Shape Property

[image]

Revit 2013 API
Connector..::..Shape Property
Connector Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic
Public Overridable ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::..Shape

See Also

Connector Class


VelocityPressure Property

[image]

Revit 2013 API
Connector..::..VelocityPressure Property
Connector Class See Also Send Feedback
The velocity pressure of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double VelocityPressure { get; }
Visual Basic
Public ReadOnly Property VelocityPressure As Double
    Get
Visual C++
public:
property double VelocityPressure {
    double get ();
}

Remarks

Instantaneous velocity pressure of this connector,calculated according to system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's domain is not DomainHvac or DomainPiping.

See Also

Connector Class


Width Property

[image]

Revit 2013 API
Connector..::..Width Property
Connector Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Width { get; set; }
Visual Basic
Public Overridable Property Width As Double
    Get
    Set
Visual C++
public:
virtual property double Width {
    double get ();
    void set (double value);
}

Implements

IConnector..::..Width

Remarks

In order to set this property, it must be mapped to a writable instance parameter in the family definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown on failure to set width.

See Also

Connector Class


ConnectorDomainType Enumeration

[image]

Revit 2013 API
ConnectorDomainType Enumeration
See Also Send Feedback
Type of connector domain.
Enumeration of connector domain types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorDomainType
Visual Basic
Public Enumeration ConnectorDomainType
Visual C++
public enum class ConnectorDomainType

Members

Member name | Description
Undefined | Domain is undefined
Hvac | HVAC (duct) connector
Electrical | Electrical connector
Piping | Piping connector
CableTrayConduit | Connector of cable trays or conduits
StructuralAnalytical | Connector of Structural Analytical Model

See Also


ConnectorElement Class

[image]

Revit 2013 API
ConnectorElement Class
Members See Also Send Feedback
A base class that provides support for all connector elements occurring in families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConnectorElement : Element,
    IConnector
Visual Basic
Public Class ConnectorElement _
    Inherits Element _
    Implements IConnector
Visual C++
public ref class ConnectorElement : public Element,
    IConnector

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Electrical..::..ElectricalConnector
Autodesk.Revit.DB.Mechanical..::..DuctConnector
Autodesk.Revit.DB.Plumbing..::..PipeConnector

See Also

ConnectorElement Members


ConnectorElement Members

[image] [image]

Revit 2013 API
ConnectorElement Members
ConnectorElement Class Methods Properties See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateCableTrayConnector | Create a new cable tray ConnectorElement.
 | CreateConduitConnector | Create a new conduit ConnectorElement.
 | CreateDuctConnector | Create a new duct ConnectorElement.
 | CreateElectricalConnector | Create a new electrical ConnectorElement.
 | CreatePipeConnector | Create a new pipe ConnectorElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConnectorElement Class


ConnectorElement Methods

[image] [image]

Revit 2013 API
ConnectorElement Methods
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateCableTrayConnector | Create a new cable tray ConnectorElement.
 | CreateConduitConnector | Create a new conduit ConnectorElement.
 | CreateDuctConnector | Create a new duct ConnectorElement.
 | CreateElectricalConnector | Create a new electrical ConnectorElement.
 | CreatePipeConnector | Create a new pipe ConnectorElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorElement Class


AssignAsPrimary Method

[image]

Revit 2013 API
ConnectorElement..::..AssignAsPrimary Method
ConnectorElement Class See Also Send Feedback
Assign a connector as a primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AssignAsPrimary()
Visual Basic
Public Sub AssignAsPrimary
Visual C++
public:
void AssignAsPrimary()

Remarks

This method is used to promote this connector as primary, and the rest of connectors in this system will be assigned as secondary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when fail to assign this connector as primary.

See Also

ConnectorElement Class


CreateCableTrayConnector Method

[image]

Revit 2013 API
ConnectorElement..::..CreateCableTrayConnector Method
ConnectorElement Class See Also Send Feedback
Create a new cable tray ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreateCableTrayConnector(
    Document document,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateCableTrayConnector ( _
    document As Document, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateCableTrayConnector(
    Document^ document,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The cable tray ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class


CreateConduitConnector Method

[image]

Revit 2013 API
ConnectorElement..::..CreateConduitConnector Method
ConnectorElement Class See Also Send Feedback
Create a new conduit ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreateConduitConnector(
    Document document,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateConduitConnector ( _
    document As Document, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateConduitConnector(
    Document^ document,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The conduit ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class


CreateDuctConnector Method

[image]

Revit 2013 API
ConnectorElement..::..CreateDuctConnector Method
ConnectorElement Class See Also Send Feedback
Create a new duct ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreateDuctConnector(
    Document document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateDuctConnector ( _
    document As Document, _
    ductSystemType As DuctSystemType, _
    profileShape As ConnectorProfileType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateDuctConnector(
    Document^ document,
    DuctSystemType ductSystemType,
    ConnectorProfileType profileShape,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
ductSystemType
Type: Autodesk.Revit.DB.Mechanical..::..DuctSystemType
The DuctSystemType of the connector.
profileShape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of the duct.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The duct ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class


CreateElectricalConnector Method

[image]

Revit 2013 API
ConnectorElement..::..CreateElectricalConnector Method
ConnectorElement Class See Also Send Feedback
Create a new electrical ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreateElectricalConnector(
    Document document,
    ElectricalSystemType electricalSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreateElectricalConnector ( _
    document As Document, _
    electricalSystemType As ElectricalSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreateElectricalConnector(
    Document^ document,
    ElectricalSystemType electricalSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
electricalSystemType
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystemType
The ElectricalSystemTYpe of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The electrical ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class


CreatePipeConnector Method

[image]

Revit 2013 API
ConnectorElement..::..CreatePipeConnector Method
ConnectorElement Class See Also Send Feedback
Create a new pipe ConnectorElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ConnectorElement CreatePipeConnector(
    Document document,
    PipeSystemType pipeSystemType,
    Reference planarFace
)
Visual Basic
Public Shared Function CreatePipeConnector ( _
    document As Document, _
    pipeSystemType As PipeSystemType, _
    planarFace As Reference _
) As ConnectorElement
Visual C++
public:
static ConnectorElement^ CreatePipeConnector(
    Document^ document,
    PipeSystemType pipeSystemType,
    Reference^ planarFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to add the connector to.
pipeSystemType
Type: Autodesk.Revit.DB.Plumbing..::..PipeSystemType
The PipeSystemType of the connector.
planarFace
Type: Autodesk.Revit.DB..::..Reference
The planar face to place the connector on.

Return Value

The pipe ConnectorElement.

Remarks

Regenerates the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The reference is not a planar face. -or- document is not a family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Connector creation is not allowed in this family.

See Also

ConnectorElement Class


GetLinkedConnectorElement Method

[image]

Revit 2013 API
ConnectorElement..::..GetLinkedConnectorElement Method
ConnectorElement Class See Also Send Feedback
Get the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ConnectorElement GetLinkedConnectorElement()
Visual Basic
Public Function GetLinkedConnectorElement As ConnectorElement
Visual C++
public:
ConnectorElement^ GetLinkedConnectorElement()

Return Value

The linked connector element. If nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link.

See Also

ConnectorElement Class


SetLinkedConnectorElement Method

[image]

Revit 2013 API
ConnectorElement..::..SetLinkedConnectorElement Method
ConnectorElement Class See Also Send Feedback
Set the linked connector element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLinkedConnectorElement(
    ConnectorElement otherConnector
)
Visual Basic
Public Sub SetLinkedConnectorElement ( _
    otherConnector As ConnectorElement _
)
Visual C++
public:
void SetLinkedConnectorElement(
    ConnectorElement^ otherConnector
)

Parameters

otherConnector
Type: Autodesk.Revit.DB..::..ConnectorElement
The connector to link to.

Remarks

Set the linked connector to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The connector being linked to is a different domain than that of the calling connector. -or- The connector being linked to is the same as the calling connector.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This connector type does not support linked connectors.

See Also

ConnectorElement Class


ConnectorElement Properties

[image] [image]

Revit 2013 API
ConnectorElement Properties
ConnectorElement Class See Also Send Feedback

The ConnectorElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConnectorElement Class


CoordinateSystem Property

[image]

Revit 2013 API
ConnectorElement..::..CoordinateSystem Property
ConnectorElement Class See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Transform CoordinateSystem { get; }
Visual Basic
Public Overridable ReadOnly Property CoordinateSystem As Transform
    Get
Visual C++
public:
virtual property Transform^ CoordinateSystem {
    Transform^ get ();
}

Implements

IConnector..::..CoordinateSystem

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

ConnectorElement Class


Domain Property

[image]

Revit 2013 API
ConnectorElement..::..Domain Property
ConnectorElement Class See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Domain Domain { get; }
Visual Basic
Public Overridable ReadOnly Property Domain As Domain
    Get
Visual C++
public:
virtual property Domain Domain {
    Domain get ();
}

Implements

IConnector..::..Domain

Remarks

This property is used to retrieve the domain of the connector.

See Also

ConnectorElement Class


Height Property

[image]

Revit 2013 API
ConnectorElement..::..Height Property
ConnectorElement Class See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Height { get; }
Visual Basic
Public Overridable ReadOnly Property Height As Double
    Get
Visual C++
public:
virtual property double Height {
    double get ();
}

Implements

IConnector..::..Height

Remarks

-1 if the connector is round.

See Also

ConnectorElement Class


IsPrimary Property

[image]

Revit 2013 API
ConnectorElement..::..IsPrimary Property
ConnectorElement Class See Also Send Feedback
Identifies if this is the primary connector in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic
Public ReadOnly Property IsPrimary As Boolean
    Get
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

ConnectorElement Class


Origin Property

[image]

Revit 2013 API
ConnectorElement..::..Origin Property
ConnectorElement Class See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual XYZ Origin { get; }
Visual Basic
Public Overridable ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
virtual property XYZ^ Origin {
    XYZ^ get ();
}

Implements

IConnector..::..Origin

See Also

ConnectorElement Class


Parameter Property

[image] [image]

Revit 2013 API
ConnectorElement..::..Parameter Property
ConnectorElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ConnectorElement Class
ConnectorElement Members


Radius Property

[image]

Revit 2013 API
ConnectorElement..::..Radius Property
ConnectorElement Class See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Radius { get; }
Visual Basic
Public Overridable ReadOnly Property Radius As Double
    Get
Visual C++
public:
virtual property double Radius {
    double get ();
}

Implements

IConnector..::..Radius

Remarks

-1 if the connector is not round.

See Also

ConnectorElement Class


Shape Property

[image]

Revit 2013 API
ConnectorElement..::..Shape Property
ConnectorElement Class See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ConnectorProfileType Shape { get; }
Visual Basic
Public Overridable ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
public:
virtual property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Implements

IConnector..::..Shape

Remarks

ConnectorProfileType::Invalid if the connector is electrical or undefined.

See Also

ConnectorElement Class


Width Property

[image]

Revit 2013 API
ConnectorElement..::..Width Property
ConnectorElement Class See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double Width { get; }
Visual Basic
Public Overridable ReadOnly Property Width As Double
    Get
Visual C++
public:
virtual property double Width {
    double get ();
}

Implements

IConnector..::..Width

Remarks

-1 if the connector is round.

See Also

ConnectorElement Class


ConnectorGenderType Enumeration

[image]

Revit 2013 API
ConnectorGenderType Enumeration
See Also Send Feedback
Connector gender type enum
Enum of connector gender type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorGenderType
Visual Basic
Public Enumeration ConnectorGenderType
Visual C++
public enum class ConnectorGenderType

Members

Member name | Description
Undefined | Undefined connector gender type
Male | Male connector gender type
Female | Female connector gender type

See Also


ConnectorJointType Enumeration

[image]

Revit 2013 API
ConnectorJointType Enumeration
See Also Send Feedback
Connector joint type enum
Enum of connector joint type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorJointType
Visual Basic
Public Enumeration ConnectorJointType
Visual C++
public enum class ConnectorJointType

Members

Member name | Description
Undefined | Undefined connector joint type
Flanged | Flanged connector joint type
Welded | Welded connector joint type
Threaded | Threaded connector joint type
Grooved | Grooved connector joint type
Glued | Glued connector joint type
Soldered | Soldered connector joint type

See Also


ConnectorManager Class

[image]

Revit 2013 API
ConnectorManager Class
Members See Also Send Feedback
Provides access to the Connector Manager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConnectorManager : IDisposable
Visual Basic
Public Class ConnectorManager _
    Implements IDisposable
Visual C++
public ref class ConnectorManager : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ConnectorManager

See Also

ConnectorManager Members


ConnectorManager Members

[image] [image]

Revit 2013 API
ConnectorManager Members
ConnectorManager Class Methods Properties See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConnectorManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


ConnectorManager Methods

[image] [image]

Revit 2013 API
ConnectorManager Methods
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorManager Class


Dispose Method

[image]

Revit 2013 API
ConnectorManager..::..Dispose Method
ConnectorManager Class See Also Send Feedback
Releases all resources used by the ConnectorManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ConnectorManager Class


ConnectorManager Properties

[image] [image]

Revit 2013 API
ConnectorManager Properties
ConnectorManager Class See Also Send Feedback

The ConnectorManager type exposes the following members.

Properties

 | Name | Description
Public property | Connectors | Return all the Connectors of the Connector Manager.
Public property | Owner | This property is used to retrieve the owner of the Connector Manager.
Public property | UnusedConnectors | Return all the unused Connectors of the Connector Manager.

See Also

ConnectorManager Class


Connectors Property

[image]

Revit 2013 API
ConnectorManager..::..Connectors Property
ConnectorManager Class See Also Send Feedback
Return all the Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorSet Connectors { get; }
Visual Basic
Public ReadOnly Property Connectors As ConnectorSet
    Get
Visual C++
public:
property ConnectorSet^ Connectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the Connectors from the Connector Manager.

See Also

ConnectorManager Class


Owner Property

[image]

Revit 2013 API
ConnectorManager..::..Owner Property
ConnectorManager Class See Also Send Feedback
This property is used to retrieve the owner of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Owner { get; }
Visual Basic
Public ReadOnly Property Owner As Element
    Get
Visual C++
public:
property Element^ Owner {
    Element^ get ();
}

See Also

ConnectorManager Class


UnusedConnectors Property

[image]

Revit 2013 API
ConnectorManager..::..UnusedConnectors Property
ConnectorManager Class See Also Send Feedback
Return all the unused Connectors of the Connector Manager.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorSet UnusedConnectors { get; }
Visual Basic
Public ReadOnly Property UnusedConnectors As ConnectorSet
    Get
Visual C++
public:
property ConnectorSet^ UnusedConnectors {
    ConnectorSet^ get ();
}

Remarks

This property is used to retrieve the unused Connectors from the Connector Manager.

See Also

ConnectorManager Class


ConnectorProfileType Enumeration

[image]

Revit 2013 API
ConnectorProfileType Enumeration
See Also Send Feedback
An enumerated type listing all connector profile types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorProfileType
Visual Basic
Public Enumeration ConnectorProfileType
Visual C++
public enum class ConnectorProfileType

Members

Member name | Description
Invalid | Invalid connector profile
Round | Round connector profile
Rectangular | Rectangular connector profile
Oval | Oval connector profile

See Also


ConnectorSet Class

[image]

Revit 2013 API
ConnectorSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConnectorSet : APIObject,
    IEnumerable
Visual Basic
Public Class ConnectorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ConnectorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ConnectorSet

See Also

ConnectorSet Members


ConnectorSet Members

[image] [image]

Revit 2013 API
ConnectorSet Members
ConnectorSet Class Constructors Methods Properties See Also Send Feedback

The ConnectorSet type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectorSet | Initializes a new instance of the ConnectorSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


ConnectorSet Constructor

[image]

Revit 2013 API
ConnectorSet Constructor
ConnectorSet Class See Also Send Feedback
Initializes a new instance of the ConnectorSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorSet()
Visual Basic
Public Sub New
Visual C++
public:
ConnectorSet()

See Also

ConnectorSet Class


ConnectorSet Methods

[image] [image]

Revit 2013 API
ConnectorSet Methods
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSet Class


Clear Method

[image]

Revit 2013 API
ConnectorSet..::..Clear Method
ConnectorSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ConnectorSet Class


Contains Method

[image]

Revit 2013 API
ConnectorSet..::..Contains Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Connector item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Connector

See Also

ConnectorSet Class


Erase Method

[image]

Revit 2013 API
ConnectorSet..::..Erase Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Connector item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Connector _
) As Integer
Visual C++
public:
virtual int Erase(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Connector

See Also

ConnectorSet Class


ForwardIterator Method

[image]

Revit 2013 API
ConnectorSet..::..ForwardIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ConnectorSet Class


GetEnumerator Method

[image]

Revit 2013 API
ConnectorSet..::..GetEnumerator Method
ConnectorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ConnectorSet Class


Insert Method

[image]

Revit 2013 API
ConnectorSet..::..Insert Method
ConnectorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Connector item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Connector _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Connector^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Connector

See Also

ConnectorSet Class


ReverseIterator Method

[image]

Revit 2013 API
ConnectorSet..::..ReverseIterator Method
ConnectorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ConnectorSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ConnectorSetIterator
Visual C++
public:
virtual ConnectorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ConnectorSet Class


ConnectorSet Properties

[image] [image]

Revit 2013 API
ConnectorSet Properties
ConnectorSet Class See Also Send Feedback

The ConnectorSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ConnectorSet Class


IsEmpty Property

[image]

Revit 2013 API
ConnectorSet..::..IsEmpty Property
ConnectorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ConnectorSet Class


Size Property

[image]

Revit 2013 API
ConnectorSet..::..Size Property
ConnectorSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ConnectorSet Class


ConnectorSetIterator Class

[image]

Revit 2013 API
ConnectorSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ConnectorSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ConnectorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ConnectorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ConnectorSetIterator

See Also

ConnectorSetIterator Members


ConnectorSetIterator Members

[image] [image]

Revit 2013 API
ConnectorSetIterator Members
ConnectorSetIterator Class Constructors Methods Properties See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectorSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


ConnectorSetIterator Constructor

[image]

Revit 2013 API
ConnectorSetIterator Constructor
ConnectorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ConnectorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ConnectorSetIterator Class


ConnectorSetIterator Methods

[image] [image]

Revit 2013 API
ConnectorSetIterator Methods
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectorSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ConnectorSetIterator..::..MoveNext Method
ConnectorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


Reset Method

[image]

Revit 2013 API
ConnectorSetIterator..::..Reset Method
ConnectorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ConnectorSetIterator Class


ConnectorSetIterator Properties

[image] [image]

Revit 2013 API
ConnectorSetIterator Properties
ConnectorSetIterator Class See Also Send Feedback

The ConnectorSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ConnectorSetIterator Class


Current Property

[image]

Revit 2013 API
ConnectorSetIterator..::..Current Property
ConnectorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ConnectorSetIterator Class


ConnectorType Enumeration

[image]

Revit 2013 API
ConnectorType Enumeration
See Also Send Feedback
An enumerated type listing all connector types for a connection

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConnectorType
Visual Basic
Public Enumeration ConnectorType
Visual C++
public enum class ConnectorType

Members

Member name | Description
Invalid | Invalid connection type
End | End connection type
Curve | Curve connection type
Logical | Logical connection type
Reference | Reference connection type
Surface | Surface connection type
EndSurface | End or Surface connection type
Physical | Physical connection type
NonEnd | Not end connection type
MasterSurface | Master surface connection type
Family | Family connection type
AllModes | All connection modes

See Also


Construction Class

[image]

Revit 2013 API
Construction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Construction
Visual Basic
Public Class Construction
Visual C++
public ref class Construction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Construction

See Also

Construction Members


Construction Members

[image] [image]

Revit 2013 API
Construction Members
Construction Class Methods Properties See Also Send Feedback

The Construction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction Class


Construction Methods

[image] [image]

Revit 2013 API
Construction Methods
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Construction Class


Construction Properties

[image] [image]

Revit 2013 API
Construction Properties
Construction Class See Also Send Feedback

The Construction type exposes the following members.

Properties

 | Name | Description
Public property | Id | Get the id of the Construction.
Public property | Name | Get the name of the Construction.

See Also

Construction Class


Id Property

[image]

Revit 2013 API
Construction..::..Id Property
Construction Class See Also Send Feedback
Get the id of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This property is used to get the id of the Construction.

See Also

Construction Class


Name Property

[image]

Revit 2013 API
Construction..::..Name Property
Construction Class See Also Send Feedback
Get the name of the Construction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

This property is used to get the name of the Construction.

See Also

Construction Class


ContFooting Class

[image]

Revit 2013 API
ContFooting Class
Members Example See Also Send Feedback
An object that represents a Continuous Footing within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ContFooting : HostObject
Visual Basic
Public Class ContFooting _
    Inherits HostObject
Visual C++
public ref class ContFooting : public HostObject

Examples

CopyC#
public void GetInfo_ContFooting(ContFooting contFooting)
{
    string message = "Wall Foundation : ";

    // Get Analytical model
    if (null != contFooting.GetAnalyticalModel())
    {
        message += "\nAnalytical model : " + contFooting.GetAnalyticalModel();
    }

    // Get Footing type name
    message += "\nFooting type name is : " + contFooting.FootingType.Name;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_ContFooting(ByVal contFooting As Autodesk.Revit.DB.ContFooting)
    Dim message As String = "Wall Foundation : "

    ' Get Analytical model
    If contFooting.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "Analytical model : " & contFooting.GetAnalyticalModel().ToString()
    End If

    ' Get Footing type name
    message += vbLf & "Footing type name is : " + contFooting.FootingType.Name

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..ContFooting

See Also

ContFooting Members


ContFooting Members

[image] [image]

Revit 2013 API
ContFooting Members
ContFooting Class Methods Properties See Also Send Feedback

The ContFooting type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FootingType | Retrieves an object that represents the type of the footing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContFooting Class


ContFooting Methods

[image] [image]

Revit 2013 API
ContFooting Methods
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFooting Class


ContFooting Properties

[image] [image]

Revit 2013 API
ContFooting Properties
ContFooting Class See Also Send Feedback

The ContFooting type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FootingType | Retrieves an object that represents the type of the footing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContFooting Class


FootingType Property

[image]

Revit 2013 API
ContFooting..::..FootingType Property
ContFooting Class See Also Send Feedback
Retrieves an object that represents the type of the footing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFootingType FootingType { get; set; }
Visual Basic
Public Property FootingType As ContFootingType
    Get
    Set
Visual C++
public:
property ContFootingType^ FootingType {
    ContFootingType^ get ();
    void set (ContFootingType^ value);
}

Remarks

The footing type can be used to access the multi layered structure of a footing.

See Also

ContFooting Class


Parameter Property

[image] [image]

Revit 2013 API
ContFooting..::..Parameter Property
ContFooting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ContFooting Class
ContFooting Members


ContFootingType Class

[image]

Revit 2013 API
ContFootingType Class
Members See Also Send Feedback
An object that specifies the type of a continuous footing in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ContFootingType : HostObjAttributes
Visual Basic
Public Class ContFootingType _
    Inherits HostObjAttributes
Visual C++
public ref class ContFootingType : public HostObjAttributes

Remarks

The structural layers of the continuous footing can be accessed via this object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..ContFootingType

See Also

ContFootingType Members


ContFootingType Members

[image] [image]

Revit 2013 API
ContFootingType Members
ContFootingType Class Methods Properties See Also Send Feedback

The ContFootingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContFootingType Class


ContFootingType Methods

[image] [image]

Revit 2013 API
ContFootingType Methods
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingType Class


ContFootingType Properties

[image] [image]

Revit 2013 API
ContFootingType Properties
ContFootingType Class See Also Send Feedback

The ContFootingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContFootingType Class


Parameter Property

[image] [image]

Revit 2013 API
ContFootingType..::..Parameter Property
ContFootingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ContFootingType Class
ContFootingType Members


ContFootingTypeSet Class

[image]

Revit 2013 API
ContFootingTypeSet Class
Members See Also Send Feedback
A set that contains ContFooting types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ContFootingTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class ContFootingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ContFootingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ContFootingTypeSet

See Also

ContFootingTypeSet Members


ContFootingTypeSet Members

[image] [image]

Revit 2013 API
ContFootingTypeSet Members
ContFootingTypeSet Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | ContFootingTypeSet | Initializes a new instance of the ContFootingTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every ContFooting type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a ContFooting type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified ContFooting type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified ContFooting type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class


ContFootingTypeSet Constructor

[image]

Revit 2013 API
ContFootingTypeSet Constructor
ContFootingTypeSet Class See Also Send Feedback
Initializes a new instance of the ContFootingTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFootingTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
ContFootingTypeSet()

See Also

ContFootingTypeSet Class


ContFootingTypeSet Methods

[image] [image]

Revit 2013 API
ContFootingTypeSet Methods
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every ContFooting type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a ContFooting type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified ContFooting type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified ContFooting type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSet Class


Clear Method

[image]

Revit 2013 API
ContFootingTypeSet..::..Clear Method
ContFootingTypeSet Class See Also Send Feedback
Removes every ContFooting type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ContFootingTypeSet Class


Contains Method

[image]

Revit 2013 API
ContFootingTypeSet..::..Contains Method
ContFootingTypeSet Class See Also Send Feedback
Tests for the existence of a ContFooting type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    ContFootingType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContFootingType
The ContFooting type to be searched for.

Return Value

The Contains method returns True if the ContFooting type is within the set, otherwise False.

See Also

ContFootingTypeSet Class


Erase Method

[image]

Revit 2013 API
ContFootingTypeSet..::..Erase Method
ContFootingTypeSet Class See Also Send Feedback
Removes a specified ContFooting type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    ContFootingType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As ContFootingType _
) As Integer
Visual C++
public:
virtual int Erase(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContFootingType
The ContFooting type to be erased.

Return Value

The number of ContFooting types that were erased from the set.

See Also

ContFootingTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
ContFootingTypeSet..::..ForwardIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ContFootingTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
ContFootingTypeSet..::..GetEnumerator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ContFootingTypeSet Class


Insert Method

[image]

Revit 2013 API
ContFootingTypeSet..::..Insert Method
ContFootingTypeSet Class See Also Send Feedback
Insert the specified ContFooting type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    ContFootingType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As ContFootingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ContFootingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ContFootingType
The ContFooting type to be inserted into the set.

Return Value

Returns whether the ContFooting type was inserted into the set.

See Also

ContFootingTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
ContFootingTypeSet..::..ReverseIterator Method
ContFootingTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ContFootingTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ContFootingTypeSetIterator
Visual C++
public:
virtual ContFootingTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ContFootingTypeSet Class


ContFootingTypeSet Properties

[image] [image]

Revit 2013 API
ContFootingTypeSet Properties
ContFootingTypeSet Class See Also Send Feedback

The ContFootingTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of ContFooting types that are in the set.

See Also

ContFootingTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
ContFootingTypeSet..::..IsEmpty Property
ContFootingTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ContFootingTypeSet Class


Size Property

[image]

Revit 2013 API
ContFootingTypeSet..::..Size Property
ContFootingTypeSet Class See Also Send Feedback
Returns the number of ContFooting types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ContFootingTypeSet Class


ContFootingTypeSetIterator Class

[image]

Revit 2013 API
ContFootingTypeSetIterator Class
Members See Also Send Feedback
An iterator to a ContFooting type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ContFootingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ContFootingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ContFootingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ContFootingTypeSetIterator

See Also

ContFootingTypeSetIterator Members


ContFootingTypeSetIterator Members

[image] [image]

Revit 2013 API
ContFootingTypeSetIterator Members
ContFootingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ContFootingTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Constructor

[image]

Revit 2013 API
ContFootingTypeSetIterator Constructor
ContFootingTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFootingTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ContFootingTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Methods

[image] [image]

Revit 2013 API
ContFootingTypeSetIterator Methods
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContFootingTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ContFootingTypeSetIterator..::..MoveNext Method
ContFootingTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
ContFootingTypeSetIterator..::..Reset Method
ContFootingTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ContFootingTypeSetIterator Class


ContFootingTypeSetIterator Properties

[image] [image]

Revit 2013 API
ContFootingTypeSetIterator Properties
ContFootingTypeSetIterator Class See Also Send Feedback

The ContFootingTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ContFootingTypeSetIterator Class


Current Property

[image]

Revit 2013 API
ContFootingTypeSetIterator..::..Current Property
ContFootingTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ContFootingTypeSetIterator Class


Control Class

[image]

Revit 2013 API
Control Class
Members See Also Send Feedback
A control in Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Control : Element
Visual Basic
Public Class Control _
    Inherits Element
Visual C++
public ref class Control : public Element

Remarks

The object represents a variety of different shapes of controls in family document. The different shapes of controls can handle the family instance in different ways.
  • A vertical/horizontal arrow control rotates the instance by 180 degrees.
  • A double vertical arrow control mirrors the instance geometry vertically.
  • A double horizontal arrow control mirrors the instance geometry horizontally.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Control

See Also

Control Members


Control Members

[image] [image]

Revit 2013 API
Control Members
Control Class Methods Properties See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The control origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Shape | The control shape.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Control Class


Control Methods

[image] [image]

Revit 2013 API
Control Methods
Control Class See Also Send Feedback

The Control type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Control Class


Control Properties

[image] [image]

Revit 2013 API
Control Properties
Control Class See Also Send Feedback

The Control type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The control origin.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Shape | The control shape.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Control Class


Origin Property

[image]

Revit 2013 API
Control..::..Origin Property
Control Class See Also Send Feedback
The control origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Control Class


Parameter Property

[image] [image]

Revit 2013 API
Control..::..Parameter Property
Control Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Control Class
Control Members


Shape Property

[image]

Revit 2013 API
Control..::..Shape Property
Control Class See Also Send Feedback
The control shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ControlShape Shape { get; }
Visual Basic
Public ReadOnly Property Shape As ControlShape
    Get
Visual C++
public:
property ControlShape Shape {
    ControlShape get ();
}

See Also

Control Class


View Property

[image]

Revit 2013 API
Control..::..View Property
Control Class See Also Send Feedback
The view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Control Class


ControlShape Enumeration

[image]

Revit 2013 API
ControlShape Enumeration
See Also Send Feedback
An enumerated type listing four shapes of control that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ControlShape
Visual Basic
Public Enumeration ControlShape
Visual C++
public enum class ControlShape

Members

Member name | Description
VerticalArrow | Vertical arrow.
HorizontalArrow | Horizontal arrow.
DoubleVerticalArrow | Double vertical arrow.
DoubleHorizontalArrow | Double horizontal arrow.

See Also


CoordinatePlaneVisibility Enumeration

[image]

Revit 2013 API
CoordinatePlaneVisibility Enumeration
See Also Send Feedback
Visibility settings for ReferencePoint element's coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum CoordinatePlaneVisibility
Visual Basic
Public Enumeration CoordinatePlaneVisibility
Visual C++
public enum class CoordinatePlaneVisibility

Members

Member name | Description
Never | Never visible.
WhenSelected | Visible when selected.
Always | Always Visible.

See Also


CurtainCell Class

[image]

Revit 2013 API
CurtainCell Class
Members See Also Send Feedback
Represents a CurtainCell within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainCell : APIObject
Visual Basic
Public Class CurtainCell _
    Inherits APIObject
Visual C++
public ref class CurtainCell : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainCell

See Also

CurtainCell Members


CurtainCell Members

[image] [image]

Revit 2013 API
CurtainCell Members
CurtainCell Class Methods Properties See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


CurtainCell Methods

[image] [image]

Revit 2013 API
CurtainCell Methods
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCell Class


CurtainCell Properties

[image] [image]

Revit 2013 API
CurtainCell Properties
CurtainCell Class See Also Send Feedback

The CurtainCell type exposes the following members.

Properties

 | Name | Description
Public property | CurveLoops | The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PlanarizedCurveLoops | The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

See Also

CurtainCell Class


CurveLoops Property

[image]

Revit 2013 API
CurtainCell..::..CurveLoops Property
CurtainCell Class See Also Send Feedback
The cell boundaries on the reference face. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray CurveLoops { get; }
Visual Basic
Public ReadOnly Property CurveLoops As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ CurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class


PlanarizedCurveLoops Property

[image]

Revit 2013 API
CurtainCell..::..PlanarizedCurveLoops Property
CurtainCell Class See Also Send Feedback
The planarized curve loops for cell boundaries. The boundaries can have more than one CurveLoop. Each item in the returned array represents a CurveLoop containing 3 or more than 3 edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray PlanarizedCurveLoops { get; }
Visual Basic
Public ReadOnly Property PlanarizedCurveLoops As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ PlanarizedCurveLoops {
    CurveArrArray^ get ();
}

See Also

CurtainCell Class


CurtainCellSet Class

[image]

Revit 2013 API
CurtainCellSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainCellSet : APIObject,
    IEnumerable
Visual Basic
Public Class CurtainCellSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainCellSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainCellSet

See Also

CurtainCellSet Members


CurtainCellSet Members

[image] [image]

Revit 2013 API
CurtainCellSet Members
CurtainCellSet Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSet type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainCellSet | Initializes a new instance of the CurtainCellSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

CurtainCellSet Class


CurtainCellSet Constructor

[image]

Revit 2013 API
CurtainCellSet Constructor
CurtainCellSet Class See Also Send Feedback
Initializes a new instance of the CurtainCellSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainCellSet()
Visual Basic
Public Sub New
Visual C++
public:
CurtainCellSet()

See Also

CurtainCellSet Class


CurtainCellSet Methods

[image] [image]

Revit 2013 API
CurtainCellSet Methods
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSet Class


Clear Method

[image]

Revit 2013 API
CurtainCellSet..::..Clear Method
CurtainCellSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainCellSet Class


Contains Method

[image]

Revit 2013 API
CurtainCellSet..::..Contains Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainCell item
)
Visual Basic
Public Overridable Function Contains ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainCell

See Also

CurtainCellSet Class


Erase Method

[image]

Revit 2013 API
CurtainCellSet..::..Erase Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainCell item
)
Visual Basic
Public Overridable Function Erase ( _
    item As CurtainCell _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainCell

See Also

CurtainCellSet Class


ForwardIterator Method

[image]

Revit 2013 API
CurtainCellSet..::..ForwardIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainCellSet Class


GetEnumerator Method

[image]

Revit 2013 API
CurtainCellSet..::..GetEnumerator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurtainCellSet Class


Insert Method

[image]

Revit 2013 API
CurtainCellSet..::..Insert Method
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainCell item
)
Visual Basic
Public Overridable Function Insert ( _
    item As CurtainCell _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainCell^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainCell

See Also

CurtainCellSet Class


ReverseIterator Method

[image]

Revit 2013 API
CurtainCellSet..::..ReverseIterator Method
CurtainCellSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainCellSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurtainCellSetIterator
Visual C++
public:
virtual CurtainCellSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainCellSet Class


CurtainCellSet Properties

[image] [image]

Revit 2013 API
CurtainCellSet Properties
CurtainCellSet Class See Also Send Feedback

The CurtainCellSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

CurtainCellSet Class


IsEmpty Property

[image]

Revit 2013 API
CurtainCellSet..::..IsEmpty Property
CurtainCellSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainCellSet Class


Size Property

[image]

Revit 2013 API
CurtainCellSet..::..Size Property
CurtainCellSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainCellSet Class


CurtainCellSetIterator Class

[image]

Revit 2013 API
CurtainCellSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013.  Use generic .NET collection classes instead.")]
public abstract class CurtainCellSetIterator : APIObject,
    IEnumerator
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013.  Use generic .NET collection classes instead.")> _
Public MustInherit Class CurtainCellSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013.  Use generic .NET collection classes instead.")]
public ref class CurtainCellSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainCellSetIterator

See Also

CurtainCellSetIterator Members


CurtainCellSetIterator Members

[image] [image]

Revit 2013 API
CurtainCellSetIterator Members
CurtainCellSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainCellSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Constructor

[image]

Revit 2013 API
CurtainCellSetIterator Constructor
CurtainCellSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainCellSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurtainCellSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Methods

[image] [image]

Revit 2013 API
CurtainCellSetIterator Methods
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainCellSetIterator Class


MoveNext Method

[image]

Revit 2013 API
CurtainCellSetIterator..::..MoveNext Method
CurtainCellSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class


Reset Method

[image]

Revit 2013 API
CurtainCellSetIterator..::..Reset Method
CurtainCellSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainCellSetIterator Class


CurtainCellSetIterator Properties

[image] [image]

Revit 2013 API
CurtainCellSetIterator Properties
CurtainCellSetIterator Class See Also Send Feedback

The CurtainCellSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainCellSetIterator Class


Current Property

[image]

Revit 2013 API
CurtainCellSetIterator..::..Current Property
CurtainCellSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainCellSetIterator Class


CurtainGrid Class

[image]

Revit 2013 API
CurtainGrid Class
Members See Also Send Feedback
Represents a curtain grid element within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainGrid : APIObject
Visual Basic
Public Class CurtainGrid _
    Inherits APIObject
Visual C++
public ref class CurtainGrid : public APIObject

Remarks

This element is obtained from a curtain wall, curtain system, or curtain roof. A curtain wall has only one curtain grid, while a curtain system or curtain roof may have several curtain grids.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGrid Members


CurtainGrid Members

[image] [image]

Revit 2013 API
CurtainGrid Members
CurtainGrid Class Methods Properties See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cells | Obsolete. Get all the cells owned by this curtain grid.
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Mullions | Obsolete. Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Public property | Panels | Obsolete. All the panels of the curtain grid.
Public property | UGridLines | Obsolete. All grid lines in the U direction.
Public property | UnlockedMullions | Obsolete. Get all the unlocked mullions of the curtain grid.
Public property | UnlockedPanels | Obsolete. Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Obsolete. All grid lines in the V direction.

See Also

CurtainGrid Class


CurtainGrid Methods

[image] [image]

Revit 2013 API
CurtainGrid Methods
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Methods

 | Name | Description
Public method | AddGridLine | Add a grid line to the curtain grid.
Public method | ChangePanelType | Change the type of a curtain panel.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCell | Get the specified cell located by the intersection of the grid lines.
Public method | GetCurtainCells | Gets the CurtainCells owned by this curtain grid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMullionIds | Gets all ElementIds of the mullions of the curtain grid.
Public method | GetPanel | Get the specified panel located by the intersection of the grid lines.
Public method | GetPanelIds | Gets all ElementIds of the panels of the curtain grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUGridLineIds | Gets all ElementIds of grid lines in the U direction.
Public method | GetUnlockedMullionIds | Gets all ElementIds of the unlocked mullions of the curtain grid.
Public method | GetUnlockedPanelIds | Gets all ElementIds of the unlocked panels of the curtain grid.
Public method | GetVGridLineIds | Gets all ElementIds of grid lines in the V direction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGrid Class


AddGridLine Method

[image]

Revit 2013 API
CurtainGrid..::..AddGridLine Method
CurtainGrid Class See Also Send Feedback
Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridLine AddGridLine(
    bool isUGridLine,
    XYZ position,
    bool oneSegmentOnly
)
Visual Basic
Public Function AddGridLine ( _
    isUGridLine As Boolean, _
    position As XYZ, _
    oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
    bool isUGridLine,
    XYZ^ position,
    bool oneSegmentOnly
)

Parameters

isUGridLine
Type: System..::..Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.DB..::..XYZ
The position of the grid line.
oneSegmentOnly
Type: System..::..Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the position for the grid line is out of range.

See Also

CurtainGrid Class


ChangePanelType Method

[image]

Revit 2013 API
CurtainGrid..::..ChangePanelType Method
CurtainGrid Class See Also Send Feedback
Change the type of a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element ChangePanelType(
    Element panel,
    ElementType newSymbol
)
Visual Basic
Public Function ChangePanelType ( _
    panel As Element, _
    newSymbol As ElementType _
) As Element
Visual C++
public:
Element^ ChangePanelType(
    Element^ panel,
    ElementType^ newSymbol
)

Parameters

panel
Type: Autodesk.Revit.DB..::..Element
The panel to be changed, it can be a type of Panel or Wall.
newSymbol
Type: Autodesk.Revit.DB..::..ElementType
The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall. The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.

Return Value

If operation succeeds, the modified panel element is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input symbol can't be used for the panel.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the type change failed.

See Also

CurtainGrid Class


GetCell Method

[image]

Revit 2013 API
CurtainGrid..::..GetCell Method
CurtainGrid Class See Also Send Feedback
Get the specified cell located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainCell GetCell(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Visual Basic
Public Function GetCell ( _
    uGridLineId As ElementId, _
    vGridLineId As ElementId _
) As CurtainCell
Visual C++
public:
CurtainCell^ GetCell(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the U-direction used to locate the cell.
vGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the V-direction used to locate the cell.

Return Value

The cell.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the grid line ids are not part of this curtain grid.

See Also

CurtainGrid Class


GetCurtainCells Method

[image]

Revit 2013 API
CurtainGrid..::..GetCurtainCells Method
CurtainGrid Class See Also Send Feedback
Gets the CurtainCells owned by this curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<CurtainCell> GetCurtainCells()
Visual Basic
Public Function GetCurtainCells As ICollection(Of CurtainCell)
Visual C++
public:
ICollection<CurtainCell^>^ GetCurtainCells()

Return Value

The CurtainCells owned by this curtain grid.

See Also

CurtainGrid Class


GetMullionIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetMullionIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetMullionIds()
Visual Basic
Public Function GetMullionIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMullionIds()

Return Value

The mullion ElementIds

Remarks

ElementIds are of Mullion Elements.

See Also

CurtainGrid Class


GetPanel Method

[image]

Revit 2013 API
CurtainGrid..::..GetPanel Method
CurtainGrid Class See Also Send Feedback
Get the specified panel located by the intersection of the grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Panel GetPanel(
    ElementId uGridLineId,
    ElementId vGridLineId
)
Visual Basic
Public Function GetPanel ( _
    uGridLineId As ElementId, _
    vGridLineId As ElementId _
) As Panel
Visual C++
public:
Panel^ GetPanel(
    ElementId^ uGridLineId,
    ElementId^ vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the U-direction used to locate the panel.
vGridLineId
Type: Autodesk.Revit.DB..::..ElementId
The id of a grid line in the V-direction used to locate the panel.

Return Value

The panel, or nullNothingnullptra null reference (Nothing in Visual Basic) if the panel cannot be found at this intersection.

See Also

CurtainGrid Class


GetPanelIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetPanelIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetPanelIds()
Visual Basic
Public Function GetPanelIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetPanelIds()

Return Value

The panel ElementIds

Remarks

For curtain walls, the ElementIds in this set are of either Panel or Wall Elements. For curtain systems, ElementIds are of Panel Elements.

See Also

CurtainGrid Class


GetUGridLineIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetUGridLineIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetUGridLineIds()
Visual Basic
Public Function GetUGridLineIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUGridLineIds()

Return Value

The U grid line ElementIds

See Also

CurtainGrid Class


GetUnlockedMullionIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetUnlockedMullionIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the unlocked mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetUnlockedMullionIds()
Visual Basic
Public Function GetUnlockedMullionIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUnlockedMullionIds()

Return Value

The unlocked mullion ElementIds

Remarks

ElementIds are of Mullion Elements.

See Also

CurtainGrid Class


GetUnlockedPanelIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetUnlockedPanelIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetUnlockedPanelIds()
Visual Basic
Public Function GetUnlockedPanelIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetUnlockedPanelIds()

Return Value

The unlocked panel ElementIds

Remarks

For curtain walls, the ElementIds in this set are of either Panel or Wall Elements. For curtain systems, ElementIds are of Panel Elements.

See Also

CurtainGrid Class


GetVGridLineIds Method

[image]

Revit 2013 API
CurtainGrid..::..GetVGridLineIds Method
CurtainGrid Class See Also Send Feedback
Gets all ElementIds of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetVGridLineIds()
Visual Basic
Public Function GetVGridLineIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetVGridLineIds()

Return Value

The V grid line ElementIds

See Also

CurtainGrid Class


CurtainGrid Properties

[image] [image]

Revit 2013 API
CurtainGrid Properties
CurtainGrid Class See Also Send Feedback

The CurtainGrid type exposes the following members.

Properties

 | Name | Description
Public property | Cells | Obsolete. Get all the cells owned by this curtain grid.
Public property | Grid1Angle | The angle for the U grid line pattern of the curtain grid.
Public property | Grid1Justification | The justification for the U grid line pattern of the curtain grid.
Public property | Grid1Offset | The offset for the U grid line pattern of the curtain grid.
Public property | Grid2Angle | The angle for V grid line pattern of the curtain grid.
Public property | Grid2Justification | The justification for the V grid line pattern of the curtain grid.
Public property | Grid2Offset | The offset for V grid line pattern of the curtain grid.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Mullions | Obsolete. Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.
Public property | NumPanels | The number of panels.
Public property | NumULines | Get the number of grid lines in the U direction.
Public property | NumVLines | Get the number of grid lines in the V direction.
Public property | Panels | Obsolete. All the panels of the curtain grid.
Public property | UGridLines | Obsolete. All grid lines in the U direction.
Public property | UnlockedMullions | Obsolete. Get all the unlocked mullions of the curtain grid.
Public property | UnlockedPanels | Obsolete. Get all the unlocked panels of the curtain grid.
Public property | VGridLines | Obsolete. All grid lines in the V direction.

See Also

CurtainGrid Class


Cells Property

[image]

Revit 2013 API
CurtainGrid..::..Cells Property
CurtainGrid Class See Also Send Feedback
Get all the cells owned by this curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetCurtainCells() instead.")]
public CurtainCellSet Cells { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetCurtainCells() instead.")> _
Public ReadOnly Property Cells As CurtainCellSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetCurtainCells() instead.")]
public:
property CurtainCellSet^ Cells {
    CurtainCellSet^ get ();
}

See Also

CurtainGrid Class


Grid1Angle Property

[image]

Revit 2013 API
CurtainGrid..::..Grid1Angle Property
CurtainGrid Class See Also Send Feedback
The angle for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Grid1Angle { get; set; }
Visual Basic
Public Property Grid1Angle As Double
    Get
    Set
Visual C++
public:
property double Grid1Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid1Justification Property

[image]

Revit 2013 API
CurtainGrid..::..Grid1Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridAlignType Grid1Justification { get; set; }
Visual Basic
Public Property Grid1Justification As CurtainGridAlignType
    Get
    Set
Visual C++
public:
property CurtainGridAlignType Grid1Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid1Offset Property

[image]

Revit 2013 API
CurtainGrid..::..Grid1Offset Property
CurtainGrid Class See Also Send Feedback
The offset for the U grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Grid1Offset { get; set; }
Visual Basic
Public Property Grid1Offset As Double
    Get
    Set
Visual C++
public:
property double Grid1Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Angle Property

[image]

Revit 2013 API
CurtainGrid..::..Grid2Angle Property
CurtainGrid Class See Also Send Feedback
The angle for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Grid2Angle { get; set; }
Visual Basic
Public Property Grid2Angle As Double
    Get
    Set
Visual C++
public:
property double Grid2Angle {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Grid2Justification Property

[image]

Revit 2013 API
CurtainGrid..::..Grid2Justification Property
CurtainGrid Class See Also Send Feedback
The justification for the V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridAlignType Grid2Justification { get; set; }
Visual Basic
Public Property Grid2Justification As CurtainGridAlignType
    Get
    Set
Visual C++
public:
property CurtainGridAlignType Grid2Justification {
    CurtainGridAlignType get ();
    void set (CurtainGridAlignType value);
}

See Also

CurtainGrid Class


Grid2Offset Property

[image]

Revit 2013 API
CurtainGrid..::..Grid2Offset Property
CurtainGrid Class See Also Send Feedback
The offset for V grid line pattern of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Grid2Offset { get; set; }
Visual Basic
Public Property Grid2Offset As Double
    Get
    Set
Visual C++
public:
property double Grid2Offset {
    double get ();
    void set (double value);
}

See Also

CurtainGrid Class


Mullions Property

[image]

Revit 2013 API
CurtainGrid..::..Mullions Property
CurtainGrid Class See Also Send Feedback
Get all the mullions of the curtain grid. The elements in this set are instances of Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetMullionIds() instead.")]
public ElementSet Mullions { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetMullionIds() instead.")> _
Public ReadOnly Property Mullions As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetMullionIds() instead.")]
public:
property ElementSet^ Mullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


NumPanels Property

[image]

Revit 2013 API
CurtainGrid..::..NumPanels Property
CurtainGrid Class See Also Send Feedback
The number of panels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumPanels { get; }
Visual Basic
Public ReadOnly Property NumPanels As Integer
    Get
Visual C++
public:
property int NumPanels {
    int get ();
}

See Also

CurtainGrid Class


NumULines Property

[image]

Revit 2013 API
CurtainGrid..::..NumULines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumULines { get; }
Visual Basic
Public ReadOnly Property NumULines As Integer
    Get
Visual C++
public:
property int NumULines {
    int get ();
}

See Also

CurtainGrid Class


NumVLines Property

[image]

Revit 2013 API
CurtainGrid..::..NumVLines Property
CurtainGrid Class See Also Send Feedback
Get the number of grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumVLines { get; }
Visual Basic
Public ReadOnly Property NumVLines As Integer
    Get
Visual C++
public:
property int NumVLines {
    int get ();
}

See Also

CurtainGrid Class


Panels Property

[image]

Revit 2013 API
CurtainGrid..::..Panels Property
CurtainGrid Class See Also Send Feedback
All the panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")]
public ElementSet Panels { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")> _
Public ReadOnly Property Panels As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetPanelIds() instead.")]
public:
property ElementSet^ Panels {
    ElementSet^ get ();
}

Remarks

For curtain walls, the element in this set is either an instance of Panel or Wall. For curtain systems, the set contains only instances of Panel.

See Also

CurtainGrid Class


UGridLines Property

[image]

Revit 2013 API
CurtainGrid..::..UGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the U direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUGridLineIds() instead.")]
public ElementSet UGridLines { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUGridLineIds() instead.")> _
Public ReadOnly Property UGridLines As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetUGridLineIds() instead.")]
public:
property ElementSet^ UGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


UnlockedMullions Property

[image]

Revit 2013 API
CurtainGrid..::..UnlockedMullions Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked mullions of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUnlockedMullionIds() instead.")]
public ElementSet UnlockedMullions { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUnlockedMullionIds() instead.")> _
Public ReadOnly Property UnlockedMullions As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetUnlockedMullionIds() instead.")]
public:
property ElementSet^ UnlockedMullions {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


UnlockedPanels Property

[image]

Revit 2013 API
CurtainGrid..::..UnlockedPanels Property
CurtainGrid Class See Also Send Feedback
Get all the unlocked panels of the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUnlockedPanelIds() instead.")]
public ElementSet UnlockedPanels { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetUnlockedPanelIds() instead.")> _
Public ReadOnly Property UnlockedPanels As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetUnlockedPanelIds() instead.")]
public:
property ElementSet^ UnlockedPanels {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


VGridLines Property

[image]

Revit 2013 API
CurtainGrid..::..VGridLines Property
CurtainGrid Class See Also Send Feedback
All grid lines in the V direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetVGridLineIds() instead.")]
public ElementSet VGridLines { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetVGridLineIds() instead.")> _
Public ReadOnly Property VGridLines As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetVGridLineIds() instead.")]
public:
property ElementSet^ VGridLines {
    ElementSet^ get ();
}

See Also

CurtainGrid Class


CurtainGridAlignType Enumeration

[image]

Revit 2013 API
CurtainGridAlignType Enumeration
See Also Send Feedback
An enumerated to list CurtainGrid patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum CurtainGridAlignType
Visual Basic
Public Enumeration CurtainGridAlignType
Visual C++
public enum class CurtainGridAlignType

Members

Member name | Description
NoJustify | NoJustify.
Beginning | Beginning pattern of CurtainGrid.
Center | Center pattern of CurtainGrid.
End | End pattern of CurtainGrid.

See Also


CurtainGridLine Class

[image]

Revit 2013 API
CurtainGridLine Class
Members See Also Send Feedback
Represents a CurtainGridLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainGridLine : HostObject
Visual Basic
Public Class CurtainGridLine _
    Inherits HostObject
Visual C++
public ref class CurtainGridLine : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CurtainGridLine

See Also

CurtainGridLine Members


CurtainGridLine Members

[image] [image]

Revit 2013 API
CurtainGridLine Members
CurtainGridLine Class Methods Properties See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainGridLine Class


CurtainGridLine Methods

[image] [image]

Revit 2013 API
CurtainGridLine Methods
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Methods

 | Name | Description
Public method | AddAllSegments | All the segments on this grid line will be added.
Public method | AddMullions | Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.
Public method | AddSegment | Add a segment based on the specified segment curve of the gridline.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Move | It is used to move unlocked type-driven grid lines or user defined grid lines.
Public method | RemoveSegment | Remove the segment specified by the input curve.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridLine Class


AddAllSegments Method

[image]

Revit 2013 API
CurtainGridLine..::..AddAllSegments Method
CurtainGridLine Class See Also Send Feedback
All the segments on this grid line will be added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddAllSegments()
Visual Basic
Public Sub AddAllSegments
Visual C++
public:
void AddAllSegments()

See Also

CurtainGridLine Class


AddMullions Method

[image]

Revit 2013 API
CurtainGridLine..::..AddMullions Method
CurtainGridLine Class See Also Send Feedback
Add mullions on the specified segments of a grid. If a segment already had mullion, just keep it and do nothing to that segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet AddMullions(
    Curve segment,
    MullionType mullionType,
    bool oneSegmentOnly
)
Visual Basic
Public Function AddMullions ( _
    segment As Curve, _
    mullionType As MullionType, _
    oneSegmentOnly As Boolean _
) As ElementSet
Visual C++
public:
ElementSet^ AddMullions(
    Curve^ segment,
    MullionType^ mullionType,
    bool oneSegmentOnly
)

Parameters

segment
Type: Autodesk.Revit.DB..::..Curve
Curve of the segment.
mullionType
Type: Autodesk.Revit.DB..::..MullionType
The type of the mullion.
oneSegmentOnly
Type: System..::..Boolean
If it is true, we only add one mullion to the specified segment, otherwise we add mullions to all the segments of the grid line.

Return Value

If operation succeeds, the created mullion will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If one of the segments are not the tagged edge of the host element, this exception will be thrown.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation fails to create one or several mullions as required or regeneration fails.

See Also

CurtainGridLine Class


AddSegment Method

[image]

Revit 2013 API
CurtainGridLine..::..AddSegment Method
CurtainGridLine Class See Also Send Feedback
Add a segment based on the specified segment curve of the gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddSegment(
    Curve curve
)
Visual Basic
Public Sub AddSegment ( _
    curve As Curve _
)
Visual C++
public:
void AddSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve used to locate the segment to be removed.

See Also

CurtainGridLine Class


Move Method

[image]

Revit 2013 API
CurtainGridLine..::..Move Method
CurtainGridLine Class See Also Send Feedback
It is used to move unlocked type-driven grid lines or user defined grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Move(
    XYZ moveVec
)
Visual Basic
Public Function Move ( _
    moveVec As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ moveVec
)

Parameters

moveVec
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return true, otherwise false.

Remarks

Grid line can only move within its surface and U line can only be moved along V direction. So the move distance on grid surface will be calculated from moveVec.

See Also

CurtainGridLine Class


RemoveSegment Method

[image]

Revit 2013 API
CurtainGridLine..::..RemoveSegment Method
CurtainGridLine Class See Also Send Feedback
Remove the segment specified by the input curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveSegment(
    Curve curve
)
Visual Basic
Public Sub RemoveSegment ( _
    curve As Curve _
)
Visual C++
public:
void RemoveSegment(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve used to locate the segment to be removed.

Remarks

When a segment is removed, the neighboring two panels will be merged into one panel.

See Also

CurtainGridLine Class


CurtainGridLine Properties

[image] [image]

Revit 2013 API
CurtainGridLine Properties
CurtainGridLine Class See Also Send Feedback

The CurtainGridLine type exposes the following members.

Properties

 | Name | Description
Public property | AllSegmentCurves | Retrieve the curves of all segments.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExistingSegmentCurves | Retrieve all the existing segment curves of the grid line.
Public property | FullCurve | Retrieve the geometry curve of the curtain grid line.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsUGridLine | Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Lock | Retrieves or changes the lock state of the curtain grid line.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SkippedSegmentCurves | Retrieve all the removed segment curves of the grid line.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainGridLine Class


AllSegmentCurves Property

[image]

Revit 2013 API
CurtainGridLine..::..AllSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve the curves of all segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray AllSegmentCurves { get; }
Visual Basic
Public ReadOnly Property AllSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ AllSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() or RemoveSegment() to add/remove specified segments. If the specified segment is already added/removed, nothing will happen.

See Also

CurtainGridLine Class


ExistingSegmentCurves Property

[image]

Revit 2013 API
CurtainGridLine..::..ExistingSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the existing segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray ExistingSegmentCurves { get; }
Visual Basic
Public ReadOnly Property ExistingSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ ExistingSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and call RemoveSegment() to remove the segments to the gridline or call AddMullions() to add mullions to these segments.

See Also

CurtainGridLine Class


FullCurve Property

[image]

Revit 2013 API
CurtainGridLine..::..FullCurve Property
CurtainGridLine Class See Also Send Feedback
Retrieve the geometry curve of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve FullCurve { get; }
Visual Basic
Public ReadOnly Property FullCurve As Curve
    Get
Visual C++
public:
property Curve^ FullCurve {
    Curve^ get ();
}

See Also

CurtainGridLine Class


IsUGridLine Property

[image]

Revit 2013 API
CurtainGridLine..::..IsUGridLine Property
CurtainGridLine Class See Also Send Feedback
Retrieve the direction of a grid line.If it is true,we say it is a UGridLine,otherwise it is VGridLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsUGridLine { get; }
Visual Basic
Public ReadOnly Property IsUGridLine As Boolean
    Get
Visual C++
public:
property bool IsUGridLine {
    bool get ();
}

See Also

CurtainGridLine Class


Lock Property

[image]

Revit 2013 API
CurtainGridLine..::..Lock Property
CurtainGridLine Class See Also Send Feedback
Retrieves or changes the lock state of the curtain grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic
Public Property Lock As Boolean
    Get
    Set
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

CurtainGridLine Class


Parameter Property

[image] [image]

Revit 2013 API
CurtainGridLine..::..Parameter Property
CurtainGridLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainGridLine Class
CurtainGridLine Members


SkippedSegmentCurves Property

[image]

Revit 2013 API
CurtainGridLine..::..SkippedSegmentCurves Property
CurtainGridLine Class See Also Send Feedback
Retrieve all the removed segment curves of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray SkippedSegmentCurves { get; }
Visual Basic
Public ReadOnly Property SkippedSegmentCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ SkippedSegmentCurves {
    CurveArray^ get ();
}

Remarks

User can get these curves and then call the method AddSegment() to add the segments to the grid line.

See Also

CurtainGridLine Class


CurtainGridSet Class

[image]

Revit 2013 API
CurtainGridSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainGridSet : APIObject,
    IEnumerable
Visual Basic
Public Class CurtainGridSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainGridSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGridSet

See Also

CurtainGridSet Members


CurtainGridSet Members

[image] [image]

Revit 2013 API
CurtainGridSet Members
CurtainGridSet Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSet type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainGridSet | Initializes a new instance of the CurtainGridSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


CurtainGridSet Constructor

[image]

Revit 2013 API
CurtainGridSet Constructor
CurtainGridSet Class See Also Send Feedback
Initializes a new instance of the CurtainGridSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridSet()
Visual Basic
Public Sub New
Visual C++
public:
CurtainGridSet()

See Also

CurtainGridSet Class


CurtainGridSet Methods

[image] [image]

Revit 2013 API
CurtainGridSet Methods
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSet Class


Clear Method

[image]

Revit 2013 API
CurtainGridSet..::..Clear Method
CurtainGridSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainGridSet Class


Contains Method

[image]

Revit 2013 API
CurtainGridSet..::..Contains Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainGrid item
)
Visual Basic
Public Overridable Function Contains ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGridSet Class


Erase Method

[image]

Revit 2013 API
CurtainGridSet..::..Erase Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainGrid item
)
Visual Basic
Public Overridable Function Erase ( _
    item As CurtainGrid _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGridSet Class


ForwardIterator Method

[image]

Revit 2013 API
CurtainGridSet..::..ForwardIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainGridSet Class


GetEnumerator Method

[image]

Revit 2013 API
CurtainGridSet..::..GetEnumerator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurtainGridSet Class


Insert Method

[image]

Revit 2013 API
CurtainGridSet..::..Insert Method
CurtainGridSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainGrid item
)
Visual Basic
Public Overridable Function Insert ( _
    item As CurtainGrid _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainGrid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainGrid

See Also

CurtainGridSet Class


ReverseIterator Method

[image]

Revit 2013 API
CurtainGridSet..::..ReverseIterator Method
CurtainGridSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainGridSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurtainGridSetIterator
Visual C++
public:
virtual CurtainGridSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainGridSet Class


CurtainGridSet Properties

[image] [image]

Revit 2013 API
CurtainGridSet Properties
CurtainGridSet Class See Also Send Feedback

The CurtainGridSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

CurtainGridSet Class


IsEmpty Property

[image]

Revit 2013 API
CurtainGridSet..::..IsEmpty Property
CurtainGridSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainGridSet Class


Size Property

[image]

Revit 2013 API
CurtainGridSet..::..Size Property
CurtainGridSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainGridSet Class


CurtainGridSetIterator Class

[image]

Revit 2013 API
CurtainGridSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CurtainGridSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurtainGridSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainGridSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainGridSetIterator

See Also

CurtainGridSetIterator Members


CurtainGridSetIterator Members

[image] [image]

Revit 2013 API
CurtainGridSetIterator Members
CurtainGridSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainGridSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Constructor

[image]

Revit 2013 API
CurtainGridSetIterator Constructor
CurtainGridSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurtainGridSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Methods

[image] [image]

Revit 2013 API
CurtainGridSetIterator Methods
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainGridSetIterator Class


MoveNext Method

[image]

Revit 2013 API
CurtainGridSetIterator..::..MoveNext Method
CurtainGridSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


Reset Method

[image]

Revit 2013 API
CurtainGridSetIterator..::..Reset Method
CurtainGridSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainGridSetIterator Class


CurtainGridSetIterator Properties

[image] [image]

Revit 2013 API
CurtainGridSetIterator Properties
CurtainGridSetIterator Class See Also Send Feedback

The CurtainGridSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainGridSetIterator Class


Current Property

[image]

Revit 2013 API
CurtainGridSetIterator..::..Current Property
CurtainGridSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainGridSetIterator Class


CurtainSystem Class

[image]

Revit 2013 API
CurtainSystem Class
Members See Also Send Feedback
Provides access to the CurtainSystem object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainSystem : CurtainSystemBase
Visual Basic
Public Class CurtainSystem _
    Inherits CurtainSystemBase
Visual C++
public ref class CurtainSystem : public CurtainSystemBase

Remarks

The user can create CurtainSystem object and change the internal properties.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB..::..CurtainSystem

See Also

CurtainSystem Members


CurtainSystem Members

[image] [image]

Revit 2013 API
CurtainSystem Members
CurtainSystem Class Methods Properties See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainSystem Methods

[image] [image]

Revit 2013 API
CurtainSystem Methods
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Methods

 | Name | Description
Public method | AddCurtainGrid | Add CurtainGrid on the specified face for the CurtainSystem.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCurtainGrid | Remove CurtainGrid from the specified face for the CurtainSystem.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystem Class


AddCurtainGrid Method

[image]

Revit 2013 API
CurtainSystem..::..AddCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Add CurtainGrid on the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddCurtainGrid(
    Reference face
)
Visual Basic
Public Sub AddCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void AddCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference
The face new CurtainGrid will be created on.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creating CurtainGrid on the specified face fails or regenerate fails.

See Also

CurtainSystem Class


RemoveCurtainGrid Method

[image]

Revit 2013 API
CurtainSystem..::..RemoveCurtainGrid Method
CurtainSystem Class See Also Send Feedback
Remove CurtainGrid from the specified face for the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveCurtainGrid(
    Reference face
)
Visual Basic
Public Sub RemoveCurtainGrid ( _
    face As Reference _
)
Visual C++
public:
void RemoveCurtainGrid(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference
The face CurtainGrid will be removed from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input parameter face is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the CurtainGrid cannot be removed from the specified face or regenerate fails.

See Also

CurtainSystem Class


CurtainSystem Properties

[image] [image]

Revit 2013 API
CurtainSystem Properties
CurtainSystem Class See Also Send Feedback

The CurtainSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.
Public property | CurtainSystemType | get or set the type of the CurtainSystem.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystem Class


CurtainGrids Property

[image]

Revit 2013 API
CurtainSystem..::..CurtainGrids Property
CurtainSystem Class See Also Send Feedback
Get all the CurtainGrid object of this CurtainSystem. Each CurtainGrid corresponds to one face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Return Value

A CurtainGrid set will be returned if the operation succeeds. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the CurtainSystem doesn't include any CurtainGrid.

See Also

CurtainSystem Class


CurtainSystemType Property

[image]

Revit 2013 API
CurtainSystem..::..CurtainSystemType Property
CurtainSystem Class See Also Send Feedback
get or set the type of the CurtainSystem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystemType CurtainSystemType { get; set; }
Visual Basic
Public Property CurtainSystemType As CurtainSystemType
    Get
    Set
Visual C++
public:
property CurtainSystemType^ CurtainSystemType {
    CurtainSystemType^ get ();
    void set (CurtainSystemType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter curtainSystemType is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the type of the CurtainSystem cannot be changed to the specified one.

See Also

CurtainSystem Class


Parameter Property

[image] [image]

Revit 2013 API
CurtainSystem..::..Parameter Property
CurtainSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainSystem Class
CurtainSystem Members


CurtainSystemBase Class

[image]

Revit 2013 API
CurtainSystemBase Class
Members See Also Send Feedback
Provides access to the CurtainSystemBase object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainSystemBase : HostObject
Visual Basic
Public Class CurtainSystemBase _
    Inherits HostObject
Visual C++
public ref class CurtainSystemBase : public HostObject

Remarks

This is the base class of CurtainSystem.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB..::..CurtainSystem

See Also

CurtainSystemBase Members


CurtainSystemBase Members

[image] [image]

Revit 2013 API
CurtainSystemBase Members
CurtainSystemBase Class Methods Properties See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemBase Class


CurtainSystemBase Methods

[image] [image]

Revit 2013 API
CurtainSystemBase Methods
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemBase Class


CurtainSystemBase Properties

[image] [image]

Revit 2013 API
CurtainSystemBase Properties
CurtainSystemBase Class See Also Send Feedback

The CurtainSystemBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemBase Class


Parameter Property

[image] [image]

Revit 2013 API
CurtainSystemBase..::..Parameter Property
CurtainSystemBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainSystemBase Class
CurtainSystemBase Members


CurtainSystemType Class

[image]

Revit 2013 API
CurtainSystemType Class
Members See Also Send Feedback
An object that represents CurtainSystem type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainSystemType : HostObjAttributes
Visual Basic
Public Class CurtainSystemType _
    Inherits HostObjAttributes
Visual C++
public ref class CurtainSystemType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..CurtainSystemType

See Also

CurtainSystemType Members


CurtainSystemType Members

[image] [image]

Revit 2013 API
CurtainSystemType Members
CurtainSystemType Class Methods Properties See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemType Class


CurtainSystemType Methods

[image] [image]

Revit 2013 API
CurtainSystemType Methods
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemType Class


CurtainSystemType Properties

[image] [image]

Revit 2013 API
CurtainSystemType Properties
CurtainSystemType Class See Also Send Feedback

The CurtainSystemType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurtainSystemType Class


Parameter Property

[image] [image]

Revit 2013 API
CurtainSystemType..::..Parameter Property
CurtainSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurtainSystemType Class
CurtainSystemType Members


CurtainSystemTypeSet Class

[image]

Revit 2013 API
CurtainSystemTypeSet Class
Members See Also Send Feedback
A set that contains CurtainSystem types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurtainSystemTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class CurtainSystemTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurtainSystemTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainSystemTypeSet

See Also

CurtainSystemTypeSet Members


CurtainSystemTypeSet Members

[image] [image]

Revit 2013 API
CurtainSystemTypeSet Members
CurtainSystemTypeSet Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainSystemTypeSet | Initializes a new instance of the CurtainSystemTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every CurtainSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a CurtainSystem type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified CurtainSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified CurtainSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Constructor

[image]

Revit 2013 API
CurtainSystemTypeSet Constructor
CurtainSystemTypeSet Class See Also Send Feedback
Initializes a new instance of the CurtainSystemTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystemTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
CurtainSystemTypeSet()

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Methods

[image] [image]

Revit 2013 API
CurtainSystemTypeSet Methods
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every CurtainSystem type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a CurtainSystem type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified CurtainSystem type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified CurtainSystem type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSet Class


Clear Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..Clear Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes every CurtainSystem type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurtainSystemTypeSet Class


Contains Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..Contains Method
CurtainSystemTypeSet Class See Also Send Feedback
Tests for the existence of a CurtainSystem type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    CurtainSystemType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainSystemType
The CurtainSystem type to be searched for.

Return Value

The Contains method returns True if the CurtainSystem type is within the set, otherwise False.

See Also

CurtainSystemTypeSet Class


Erase Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..Erase Method
CurtainSystemTypeSet Class See Also Send Feedback
Removes a specified CurtainSystem type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    CurtainSystemType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As CurtainSystemType _
) As Integer
Visual C++
public:
virtual int Erase(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainSystemType
The CurtainSystem type to be erased.

Return Value

The number of CurtainSystem types that were erased from the set.

See Also

CurtainSystemTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..ForwardIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CurtainSystemTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..GetEnumerator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurtainSystemTypeSet Class


Insert Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..Insert Method
CurtainSystemTypeSet Class See Also Send Feedback
Insert the specified CurtainSystem type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    CurtainSystemType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As CurtainSystemType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CurtainSystemType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurtainSystemType
The CurtainSystem type to be inserted into the set.

Return Value

Returns whether the CurtainSystem type was inserted into the set.

See Also

CurtainSystemTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
CurtainSystemTypeSet..::..ReverseIterator Method
CurtainSystemTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurtainSystemTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurtainSystemTypeSetIterator
Visual C++
public:
virtual CurtainSystemTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSet Properties

[image] [image]

Revit 2013 API
CurtainSystemTypeSet Properties
CurtainSystemTypeSet Class See Also Send Feedback

The CurtainSystemTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of CurtainSystem types that are in the set.

See Also

CurtainSystemTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
CurtainSystemTypeSet..::..IsEmpty Property
CurtainSystemTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CurtainSystemTypeSet Class


Size Property

[image]

Revit 2013 API
CurtainSystemTypeSet..::..Size Property
CurtainSystemTypeSet Class See Also Send Feedback
Returns the number of CurtainSystem types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurtainSystemTypeSet Class


CurtainSystemTypeSetIterator Class

[image]

Revit 2013 API
CurtainSystemTypeSetIterator Class
Members See Also Send Feedback
An iterator to a CurtainSystem type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CurtainSystemTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurtainSystemTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurtainSystemTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurtainSystemTypeSetIterator

See Also

CurtainSystemTypeSetIterator Members


CurtainSystemTypeSetIterator Members

[image] [image]

Revit 2013 API
CurtainSystemTypeSetIterator Members
CurtainSystemTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurtainSystemTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Constructor

[image]

Revit 2013 API
CurtainSystemTypeSetIterator Constructor
CurtainSystemTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystemTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurtainSystemTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Methods

[image] [image]

Revit 2013 API
CurtainSystemTypeSetIterator Methods
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurtainSystemTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
CurtainSystemTypeSetIterator..::..MoveNext Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
CurtainSystemTypeSetIterator..::..Reset Method
CurtainSystemTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurtainSystemTypeSetIterator Class


CurtainSystemTypeSetIterator Properties

[image] [image]

Revit 2013 API
CurtainSystemTypeSetIterator Properties
CurtainSystemTypeSetIterator Class See Also Send Feedback

The CurtainSystemTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurtainSystemTypeSetIterator Class


Current Property

[image]

Revit 2013 API
CurtainSystemTypeSetIterator..::..Current Property
CurtainSystemTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurtainSystemTypeSetIterator Class


Curve Class

[image]

Revit 2013 API
Curve Class
Members See Also Send Feedback
A parametric curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Curve : GeometryObject
Visual Basic
Public Class Curve _
    Inherits GeometryObject
Visual C++
public ref class Curve : public GeometryObject

Remarks

The concrete curves are defined by parametric equations. If the curve is bound, it is only defined for an interval in parameterization. Otherwise, it is defined for all values of the parameter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Arc
Autodesk.Revit.DB..::..CylindricalHelix
Autodesk.Revit.DB..::..Ellipse
Autodesk.Revit.DB..::..HermiteSpline
Autodesk.Revit.DB..::..Line
Autodesk.Revit.DB..::..NurbSpline

See Also

Curve Members


Curve Members

[image] [image]

Revit 2013 API
Curve Members
Curve Class Methods Properties See Also Send Feedback

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


Curve Methods

[image] [image]

Revit 2013 API
Curve Methods
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve.
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter.
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter.
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
Public method | MakeBound | Changes the bounds of this curve to the specified values.
Public method | MakeUnbound | Makes this curve unbound.
Public method | Project | Projects the specified point on this curve.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Curve Class


Clone Method

[image]

Revit 2013 API
Curve..::..Clone Method
Curve Class See Also Send Feedback
Returns a copy of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Clone()
Visual Basic
Public Function Clone As Curve
Visual C++
public:
Curve^ Clone()

See Also

Curve Class


ComputeDerivatives Method

[image]

Revit 2013 API
Curve..::..ComputeDerivatives Method
Curve Class See Also Send Feedback
Returns the vectors describing the curve at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter,
    bool normalized
)
Visual Basic
Public Function ComputeDerivatives ( _
    parameter As Double, _
    normalized As Boolean _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter,
    bool normalized
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.
normalized
Type: System..::..Boolean
Indicates that the specified parameter is normalized.

Return Value

The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.

Remarks

The following is the meaning of the transformation members: Origin is the point on the curve (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the second derivative; BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the curve is straight at the point. None of the vectors are normalized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified parameter is infinite.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when normalized is true and this curve is unbound or the parameter is not within [0, 1] interval.

See Also

Curve Class


ComputeNormalizedParameter Method

[image]

Revit 2013 API
Curve..::..ComputeNormalizedParameter Method
Curve Class See Also Send Feedback
Computes the normalized curve parameter from the raw parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ComputeNormalizedParameter(
    double rawParameter
)
Visual Basic
Public Function ComputeNormalizedParameter ( _
    rawParameter As Double _
) As Double
Visual C++
public:
double ComputeNormalizedParameter(
    double rawParameter
)

Parameters

rawParameter
Type: System..::..Double
The raw parameter.

Return Value

The real number equal to the normalized curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when rawParameter is infinite.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class


ComputeRawParameter Method

[image]

Revit 2013 API
Curve..::..ComputeRawParameter Method
Curve Class See Also Send Feedback
Computes the raw parameter from the normalized parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ComputeRawParameter(
    double normalizedParameter
)
Visual Basic
Public Function ComputeRawParameter ( _
    normalizedParameter As Double _
) As Double
Visual C++
public:
double ComputeRawParameter(
    double normalizedParameter
)

Parameters

normalizedParameter
Type: System..::..Double
The normalized parameter.

Return Value

The real number equal to the raw curve parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when normalizedParameter is infinite.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound.

See Also

Curve Class


Distance Method

[image]

Revit 2013 API
Curve..::..Distance Method
Curve Class See Also Send Feedback
Returns the shortest distance from the specified point to this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Distance(
    XYZ point
)
Visual Basic
Public Function Distance ( _
    point As XYZ _
) As Double
Visual C++
public:
double Distance(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The specified point.

Return Value

The real number equal to the shortest distance.

Remarks

Returns the distance from the closest point on the curve to the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class


Evaluate Method

[image]

Revit 2013 API
Curve..::..Evaluate Method
Curve Class See Also Send Feedback
Evaluates a parameter on the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param,
    bool normalized
)
Visual Basic
Public Function Evaluate ( _
    param As Double, _
    normalized As Boolean _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param,
    bool normalized
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated.
normalized
Type: System..::..Boolean
If false, param is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.

See Also

Curve Class


Intersect Method

[image] [image]

Revit 2013 API
Curve..::..Intersect Method
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results.

See Also

Curve Class
Curve Members


Intersect Method (Curve)

[image]

Revit 2013 API
Curve..::..Intersect Method (Curve)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this curve.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2013 API
Curve..::..Intersect Method (Curve, IntersectionResultArray%)
Curve Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray resultArray
)
Visual Basic
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef resultArray As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% resultArray
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this curve.
resultArray
Type: Autodesk.Revit.DB..::..IntersectionResultArray%
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the details.
  • SetComparisonResult.Subset - The inputs are parallel lines with only one common intersection point, or the curve used to invoke the intersection check is a line entirely within the unbound line passed as argument curve. If the former, the output argument has the details of the intersection point.
  • SetComparisonResult.Superset - The input curve is entirely within the unbound line used to invoke the intersection check.
  • SetComparisonResult.Disjoint - There is no intersection found between the two curves.
  • SetComparisonResult.Equal - The two curves are identical.

Remarks

The array of the intersection results contains one entry for each point where curves intersect. The following is the meaning of IntersectionResult members:
  • XYZPoint is the evaluated intersection point
  • UVPoint.U is the unnormalized parameter on this curve (use ComputeNormalizedParameter to compute the normalized value).
  • UVPoint.V is the unnormalized parameter on the specified curve (use ComputeNormalizedParameter to compute the normalized value).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to calculate the intersection.

See Also

Curve Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2013 API
Curve..::..IsInside Method
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds.
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

See Also

Curve Class
Curve Members


IsInside Method (Double)

[image]

Revit 2013 API
Curve..::..IsInside Method (Double)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInside(
    double parameter
)
Visual Basic
Public Function IsInside ( _
    parameter As Double _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter
)

Parameters

parameter
Type: System..::..Double
The raw curve parameter to be evaluated.

Return Value

True if the parameter is within the bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified parameter is infinite.

See Also

Curve Class
IsInside Overload


IsInside Method (Double, Int32)

[image]

Revit 2013 API
Curve..::..IsInside Method (Double, Int32%)
Curve Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInside(
    double parameter,
    out int end
)
Visual Basic
Public Function IsInside ( _
    parameter As Double, _
    <OutAttribute> ByRef end As Integer _
) As Boolean
Visual C++
public:
bool IsInside(
    double parameter,
    [OutAttribute] int% end
)

Parameters

parameter
Type: System..::..Double
The raw curve parameter to be evaluated.
end
Type: System..::..Int32%
The end index is equal to 0 for the start point, 1 for the end point, or -1 if the parameter is not at the end.

Return Value

True if the parameter is within the curve's bounds, otherwise false.

Remarks

Always returns true if this curve is unbound.

See Also

Curve Class
IsInside Overload


MakeBound Method

[image]

Revit 2013 API
Curve..::..MakeBound Method
Curve Class See Also Send Feedback
Changes the bounds of this curve to the specified values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeBound(
    double startParameter,
    double endParameter
)
Visual Basic
Public Sub MakeBound ( _
    startParameter As Double, _
    endParameter As Double _
)
Visual C++
public:
void MakeBound(
    double startParameter,
    double endParameter
)

Parameters

startParameter
Type: System..::..Double
The new parameter of the start point.
endParameter
Type: System..::..Double
The new parameter of the end point.

Remarks

This method changes this curve to bound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified values are infinite.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when endParameter is smaller than startParameter, or the object is internally marked as read-only.

See Also

Curve Class


MakeUnbound Method

[image]

Revit 2013 API
Curve..::..MakeUnbound Method
Curve Class See Also Send Feedback
Makes this curve unbound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeUnbound()
Visual Basic
Public Sub MakeUnbound
Visual C++
public:
void MakeUnbound()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only.

See Also

Curve Class


Project Method

[image]

Revit 2013 API
Curve..::..Project Method
Curve Class See Also Send Feedback
Projects the specified point on this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to be projected.

Return Value

Geometric information if projection is successful.

Remarks

The following is the meaning of every IntersectionResult's members:
  • XYZPoint is the nearest point on the curve;
  • Parameter is the unnormalized parameter on the curve (use ComputeNormalizedParameter to compute the normalized value)
  • Distance is the distance from the point to the curve (equivalent to Distance).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to find the closest point on the curve.

See Also

Curve Class


Tessellate Method

[image]

Revit 2013 API
Curve..::..Tessellate Method
Curve Class See Also Send Feedback
Valid only if the curve is bound. Returns a polyline approximation to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Tessellate()
Visual Basic
Public Function Tessellate As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Curve Class


Curve Properties

[image] [image]

Revit 2013 API
Curve Properties
Curve Class See Also Send Feedback

The Curve type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve.
Public property | EndParameter | The parameter of the start or the end point of the curve.
Public property | EndPoint | The start or the end point of this curve.
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve.
Public property | Period | The period of this curve.
Public property | Reference | Returns a stable reference to the curve.
Public property | Transformed | Applies the specified transformation to this curve and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Curve Class


ApproximateLength Property

[image]

Revit 2013 API
Curve..::..ApproximateLength Property
Curve Class See Also Send Feedback
The approximate length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic
Public ReadOnly Property ApproximateLength As Double
    Get
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Quickly estimates the length of the curve, may deviate by a factor of 2 in some cases. The computation is exact for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


EndParameter Property

[image]

Revit 2013 API
Curve..::..EndParameter Property
Curve Class See Also Send Feedback
The parameter of the start or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int index
] { get; set; }
Visual Basic
Public Property EndParameter ( _
    index As Integer _
) As Double
    Get
    Set
Visual C++
public:
property double EndParameter[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1 both in the getter and setter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the specified parameter is not within curve bounds in the setter, or the object is internally marked as read-only in the setter, or the curve is unbound both in the getter and setter.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value of parameter is infinite in the setter.

See Also

Curve Class


EndPoint Property

[image]

Revit 2013 API
Curve..::..EndPoint Property
Curve Class See Also Send Feedback
The start or the end point of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property EndPoint ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ EndPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this curve is unbound.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.

See Also

Curve Class


EndPointReference Property

[image]

Revit 2013 API
Curve..::..EndPointReference Property
Curve Class See Also Send Feedback
Returns a stable reference to the start point or the end point of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
    Get
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound.

See Also

Curve Class


IsBound Property

[image]

Revit 2013 API
Curve..::..IsBound Property
Curve Class See Also Send Feedback
Describes whether the parameter of the curve is restricted to a particular interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsBound { get; }
Visual Basic
Public ReadOnly Property IsBound As Boolean
    Get
Visual C++
public:
property bool IsBound {
    bool get ();
}

See Also

Curve Class


IsCyclic Property

[image]

Revit 2013 API
Curve..::..IsCyclic Property
Curve Class See Also Send Feedback
The boolean value that indicates whether this curve is cyclic.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCyclic { get; }
Visual Basic
Public ReadOnly Property IsCyclic As Boolean
    Get
Visual C++
public:
property bool IsCyclic {
    bool get ();
}

Return Value

True if this curve is cyclic; otherwise, false.

See Also

Curve Class


Length Property

[image]

Revit 2013 API
Curve..::..Length Property
Curve Class See Also Send Feedback
The exact length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

Remarks

Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is unbound and not periodic.

See Also

Curve Class


Period Property

[image]

Revit 2013 API
Curve..::..Period Property
Curve Class See Also Send Feedback
The period of this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Period { get; }
Visual Basic
Public ReadOnly Property Period As Double
    Get
Visual C++
public:
property double Period {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the curve is not cyclic.

See Also

Curve Class


Reference Property

[image]

Revit 2013 API
Curve..::..Reference Property
Curve Class See Also Send Feedback
Returns a stable reference to the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Curve Class


Transformed Property

[image]

Revit 2013 API
Curve..::..Transformed Property
Curve Class Example See Also Send Feedback
Applies the specified transformation to this curve and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Curve
    Get
Visual C++
public:
property Curve^ Transformed[Transform^ transform] {
    Curve^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to be applied.

Return Value

The transformed curve.

Examples

CopyC#
public void GetAndTransformCurve(Autodesk.Revit.ApplicationServices.Application app,
    Autodesk.Revit.DB.Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
       Autodesk.Revit.DB.GeometryInstance instance =
           geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject o in instance.SymbolGeometry.Objects)
            {
                // Get curve
                Curve curve = o as Curve;
                if (curve != null)
                {
                    // transfrom the curve to make it in the instance's coordinate space
                    curve = curve.get_Transformed(instance.Transform);
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetAndTransformCurve(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each o As GeometryObject In instance.SymbolGeometry.Objects
                ' Get curve
                Dim curve As Curve = TryCast(o, Curve)
                If curve IsNot Nothing Then
                    ' transfrom the curve to make it in the instance's coordinate space
                    curve = curve.Transformed(instance.Transform)
                End If
            Next
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transformation is not valid or the transformation application fails.

See Also

Curve Class


CurveArrArray Class

[image]

Revit 2013 API
CurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveArrArray : APIObject,
    IEnumerable
Visual Basic
Public Class CurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArrArray

See Also

CurveArrArray Members


CurveArrArray Members

[image] [image]

Revit 2013 API
CurveArrArray Members
CurveArrArray Class Constructors Methods Properties See Also Send Feedback

The CurveArrArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArrArray | Initializes a new instance of the CurveArrArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class


CurveArrArray Constructor

[image]

Revit 2013 API
CurveArrArray Constructor
CurveArrArray Class See Also Send Feedback
Initializes a new instance of the CurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrArray()

See Also

CurveArrArray Class


CurveArrArray Methods

[image] [image]

Revit 2013 API
CurveArrArray Methods
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArray Class


Append Method

[image]

Revit 2013 API
CurveArrArray..::..Append Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    CurveArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As CurveArray _
)
Visual C++
public:
virtual void Append(
    CurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveArray

See Also

CurveArrArray Class


Clear Method

[image]

Revit 2013 API
CurveArrArray..::..Clear Method
CurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArrArray Class


ForwardIterator Method

[image]

Revit 2013 API
CurveArrArray..::..ForwardIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArrArray Class


GetEnumerator Method

[image]

Revit 2013 API
CurveArrArray..::..GetEnumerator Method
CurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveArrArray Class


Insert Method

[image]

Revit 2013 API
CurveArrArray..::..Insert Method
CurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    CurveArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As CurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveArray
index
Type: System..::..Int32

See Also

CurveArrArray Class


ReverseIterator Method

[image]

Revit 2013 API
CurveArrArray..::..ReverseIterator Method
CurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveArrArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurveArrArrayIterator
Visual C++
public:
virtual CurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArrArray Class


CurveArrArray Properties

[image] [image]

Revit 2013 API
CurveArrArray Properties
CurveArrArray Class See Also Send Feedback

The CurveArrArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

CurveArrArray Class


IsEmpty Property

[image]

Revit 2013 API
CurveArrArray..::..IsEmpty Property
CurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArrArray Class


Item Property

[image]

Revit 2013 API
CurveArrArray..::..Item Property
CurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CurveArray
    Get
    Set
Visual C++
public:
virtual property CurveArray^ Item[int index] {
    CurveArray^ get (int index);
    void set (int index, CurveArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

CurveArrArray Class


Size Property

[image]

Revit 2013 API
CurveArrArray..::..Size Property
CurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArrArray Class


CurveArrArrayIterator Class

[image]

Revit 2013 API
CurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArrArrayIterator

See Also

CurveArrArrayIterator Members


CurveArrArrayIterator Members

[image] [image]

Revit 2013 API
CurveArrArrayIterator Members
CurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArrArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Constructor

[image]

Revit 2013 API
CurveArrArrayIterator Constructor
CurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Methods

[image] [image]

Revit 2013 API
CurveArrArrayIterator Methods
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
CurveArrArrayIterator..::..MoveNext Method
CurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


Reset Method

[image]

Revit 2013 API
CurveArrArrayIterator..::..Reset Method
CurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrArrayIterator Class


CurveArrArrayIterator Properties

[image] [image]

Revit 2013 API
CurveArrArrayIterator Properties
CurveArrArrayIterator Class See Also Send Feedback

The CurveArrArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrArrayIterator Class


Current Property

[image]

Revit 2013 API
CurveArrArrayIterator..::..Current Property
CurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrArrayIterator Class


CurveArray Class

[image]

Revit 2013 API
CurveArray Class
Members See Also Send Feedback
An array that can contain curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveArray : APIObject, IEnumerable
Visual Basic
Public Class CurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArray

See Also

CurveArray Members


CurveArray Members

[image] [image]

Revit 2013 API
CurveArray Members
CurveArray Class Constructors Methods Properties See Also Send Feedback

The CurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArray | Initializes a new instance of the CurveArray class

Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


CurveArray Constructor

[image]

Revit 2013 API
CurveArray Constructor
CurveArray Class See Also Send Feedback
Initializes a new instance of the CurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveArray()

See Also

CurveArray Class


CurveArray Methods

[image] [image]

Revit 2013 API
CurveArray Methods
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the curve to the end of the array.
Public method | Clear | Removes every curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArray Class


Append Method

[image]

Revit 2013 API
CurveArray..::..Append Method
CurveArray Class See Also Send Feedback
Add the curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Curve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Curve _
)
Visual C++
public:
virtual void Append(
    Curve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Curve
The curve to be added.

See Also

CurveArray Class


Clear Method

[image]

Revit 2013 API
CurveArray..::..Clear Method
CurveArray Class See Also Send Feedback
Removes every curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveArray Class


ForwardIterator Method

[image]

Revit 2013 API
CurveArray..::..ForwardIterator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

CurveArray Class


GetEnumerator Method

[image]

Revit 2013 API
CurveArray..::..GetEnumerator Method
CurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveArray Class


Insert Method

[image]

Revit 2013 API
CurveArray..::..Insert Method
CurveArray Class See Also Send Feedback
Insert the specified curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Curve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Curve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Curve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Curve
The curve to be inserted into the array.
index
Type: System..::..Int32
The curve will be inserted before this index.

Return Value

Returns whether the curve was inserted into the array.

See Also

CurveArray Class


ReverseIterator Method

[image]

Revit 2013 API
CurveArray..::..ReverseIterator Method
CurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurveArrayIterator
Visual C++
public:
virtual CurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

CurveArray Class


CurveArray Properties

[image] [image]

Revit 2013 API
CurveArray Properties
CurveArray Class See Also Send Feedback

The CurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a curve at a specified index within the array.
Public property | Size | Returns the number of curves that are in the array.

See Also

CurveArray Class


IsEmpty Property

[image]

Revit 2013 API
CurveArray..::..IsEmpty Property
CurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

CurveArray Class


Item Property

[image]

Revit 2013 API
CurveArray..::..Item Property
CurveArray Class See Also Send Feedback
Gets or sets a curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Curve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Curve
    Get
    Set
Visual C++
public:
virtual property Curve^ Item[int index] {
    Curve^ get (int index);
    void set (int index, Curve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the curve to be set or retrieved.

Return Value

Returns the curve at the specified index.

See Also

CurveArray Class


Size Property

[image]

Revit 2013 API
CurveArray..::..Size Property
CurveArray Class See Also Send Feedback
Returns the number of curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveArray Class


CurveArrayIterator Class

[image]

Revit 2013 API
CurveArrayIterator Class
Members See Also Send Feedback
An iterator to a curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveArrayIterator

See Also

CurveArrayIterator Members


CurveArrayIterator Members

[image] [image]

Revit 2013 API
CurveArrayIterator Members
CurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class


CurveArrayIterator Constructor

[image]

Revit 2013 API
CurveArrayIterator Constructor
CurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CurveArrayIterator Class


CurveArrayIterator Methods

[image] [image]

Revit 2013 API
CurveArrayIterator Methods
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
CurveArrayIterator..::..MoveNext Method
CurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


Reset Method

[image]

Revit 2013 API
CurveArrayIterator..::..Reset Method
CurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CurveArrayIterator Class


CurveArrayIterator Properties

[image] [image]

Revit 2013 API
CurveArrayIterator Properties
CurveArrayIterator Class See Also Send Feedback

The CurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveArrayIterator Class


Current Property

[image]

Revit 2013 API
CurveArrayIterator..::..Current Property
CurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CurveArrayIterator Class


CurveByPoints Class

[image]

Revit 2013 API
CurveByPoints Class
Members See Also Send Feedback
A curve interpolating two or more points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveByPoints : CurveElement
Visual Basic
Public Class CurveByPoints _
    Inherits CurveElement
Visual C++
public ref class CurveByPoints : public CurveElement

Remarks

The points to be interpolated are represented as ReferencePoints, which must already exist in the document. In terms of appearance and graphics control, CurveByPoints behaves similarly to ModelCurve. The main difference being that a ModelCurve refers to a SketchPlane, while a CurveByPoints does not. For more methods capable of accessing data from CurveByPoints elements, see the static class CurveByPointsUtils.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..CurveByPoints

See Also

CurveByPoints Members


CurveByPoints Members

[image] [image]

Revit 2013 API
CurveByPoints Members
CurveByPoints Class Methods Properties See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine |
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::..SketchPlane.)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveByPoints Class


CurveByPoints Methods

[image] [image]

Revit 2013 API
CurveByPoints Methods
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoints | Get the sequence of points interpolated by this curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPoints | Change the sequence of points interpolated by this curve.
Public method | SetVisibility | Sets the visibility.
 | SortPoints | Order a set of ReferencePoints in the same way Revit does when creating a curve from points.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPoints Class


GetPoints Method

[image]

Revit 2013 API
CurveByPoints..::..GetPoints Method
CurveByPoints Class See Also Send Feedback
Get the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePointArray GetPoints()
Visual Basic
Public Function GetPoints As ReferencePointArray
Visual C++
public:
ReferencePointArray^ GetPoints()

See Also

CurveByPoints Class


GetVisibility Method

[image]

Revit 2013 API
CurveByPoints..::..GetVisibility Method
CurveByPoints Class See Also Send Feedback
Gets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the curve.

See Also

CurveByPoints Class


SetPoints Method

[image]

Revit 2013 API
CurveByPoints..::..SetPoints Method
CurveByPoints Class See Also Send Feedback
Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetPoints(
    ReferencePointArray points
)
Visual Basic
Public Sub SetPoints ( _
    points As ReferencePointArray _
)
Visual C++
public:
void SetPoints(
    ReferencePointArray^ points
)

Parameters

points
Type: Autodesk.Revit.DB..::..ReferencePointArray
An array of 2 or more ReferencePoints.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.

See Also

CurveByPoints Class


SetVisibility Method

[image]

Revit 2013 API
CurveByPoints..::..SetVisibility Method
CurveByPoints Class See Also Send Feedback
Sets the visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the CurveByPoints can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SortPoints Method

[image]

Revit 2013 API
CurveByPoints..::..SortPoints Method
CurveByPoints Class See Also Send Feedback
Order a set of ReferencePoints in the same way Revit does when creating a curve from points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool SortPoints(
    ReferencePointArray arr
)
Visual Basic
Public Shared Function SortPoints ( _
    arr As ReferencePointArray _
) As Boolean
Visual C++
public:
static bool SortPoints(
    ReferencePointArray^ arr
)

Parameters

arr
Type: Autodesk.Revit.DB..::..ReferencePointArray
An array of ReferencePoints. The array is reordered if sortPoints returns true, and is unchanged if sortPoints returns false.

Return Value

False if the least-squares method is unable to find a solution; true otherwise.

Remarks

Finds a best-fit line to the points by the least squares method, and orders the points by their projection onto the line.

See Also

CurveByPoints Class


CurveByPoints Properties

[image] [image]

Revit 2013 API
CurveByPoints Properties
CurveByPoints Class See Also Send Feedback

The CurveByPoints type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine |
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | Override the SketchPlane property of CurveElement. (Overrides CurveElement..::..SketchPlane.)
Public property | Subcategory | The subcategory, or graphics style, of the CurveByPoints.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveByPoints Class


IsReferenceLine Property

[image]

Revit 2013 API
CurveByPoints..::..IsReferenceLine Property
CurveByPoints Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReferenceLine { get; set; }
Visual Basic
Public Property IsReferenceLine As Boolean
    Get
    Set
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class


Parameter Property

[image] [image]

Revit 2013 API
CurveByPoints..::..Parameter Property
CurveByPoints Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurveByPoints Class
CurveByPoints Members


ReferenceType Property

[image]

Revit 2013 API
CurveByPoints..::..ReferenceType Property
CurveByPoints Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic
Public Property ReferenceType As ReferenceType
    Get
    Set
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

CurveByPoints Class


SketchPlane Property

[image]

Revit 2013 API
CurveByPoints..::..SketchPlane Property
CurveByPoints Class See Also Send Feedback
Override the SketchPlane property of CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override SketchPlane SketchPlane { get; set; }
Visual Basic
Public Overrides Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get () override;
    void set (SketchPlane^ value) override;
}

Remarks

CurveByPoints has no associated SketchPlane. Getting this property returns nullNothingnullptra null reference (Nothing in Visual Basic). Setting it causes an InvalidOperationException.

See Also

CurveByPoints Class


Subcategory Property

[image]

Revit 2013 API
CurveByPoints..::..Subcategory Property
CurveByPoints Class See Also Send Feedback
The subcategory, or graphics style, of the CurveByPoints.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic
Public Property Subcategory As GraphicsStyle
    Get
    Set
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

CurveByPoints Class


Visible Property

[image]

Revit 2013 API
CurveByPoints..::..Visible Property
CurveByPoints Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

CurveByPoints Class


CurveByPointsArray Class

[image]

Revit 2013 API
CurveByPointsArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveByPointsArray : APIObject,
    IEnumerable
Visual Basic
Public Class CurveByPointsArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CurveByPointsArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveByPointsArray

See Also

CurveByPointsArray Members


CurveByPointsArray Members

[image] [image]

Revit 2013 API
CurveByPointsArray Members
CurveByPointsArray Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Constructors

 | Name | Description
Public method | CurveByPointsArray | Initializes a new instance of the CurveByPointsArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size |

See Also

CurveByPointsArray Class


CurveByPointsArray Constructor

[image]

Revit 2013 API
CurveByPointsArray Constructor
CurveByPointsArray Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveByPointsArray()
Visual Basic
Public Sub New
Visual C++
public:
CurveByPointsArray()

See Also

CurveByPointsArray Class


CurveByPointsArray Methods

[image] [image]

Revit 2013 API
CurveByPointsArray Methods
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArray Class


Append Method

[image]

Revit 2013 API
CurveByPointsArray..::..Append Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    CurveByPoints item
)
Visual Basic
Public Overridable Sub Append ( _
    item As CurveByPoints _
)
Visual C++
public:
virtual void Append(
    CurveByPoints^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveByPoints

See Also

CurveByPointsArray Class


Clear Method

[image]

Revit 2013 API
CurveByPointsArray..::..Clear Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CurveByPointsArray Class


ForwardIterator Method

[image]

Revit 2013 API
CurveByPointsArray..::..ForwardIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ForwardIterator()

See Also

CurveByPointsArray Class


GetEnumerator Method

[image]

Revit 2013 API
CurveByPointsArray..::..GetEnumerator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveByPointsArray Class


Insert Method

[image]

Revit 2013 API
CurveByPointsArray..::..Insert Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    CurveByPoints item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As CurveByPoints, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    CurveByPoints^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..CurveByPoints
index
Type: System..::..Int32

See Also

CurveByPointsArray Class


ReverseIterator Method

[image]

Revit 2013 API
CurveByPointsArray..::..ReverseIterator Method
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveByPointsArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CurveByPointsArrayIterator
Visual C++
public:
virtual CurveByPointsArrayIterator^ ReverseIterator()

See Also

CurveByPointsArray Class


CurveByPointsArray Properties

[image] [image]

Revit 2013 API
CurveByPointsArray Properties
CurveByPointsArray Class See Also Send Feedback

The CurveByPointsArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size |

See Also

CurveByPointsArray Class


IsEmpty Property

[image]

Revit 2013 API
CurveByPointsArray..::..IsEmpty Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

CurveByPointsArray Class


Item Property

[image]

Revit 2013 API
CurveByPointsArray..::..Item Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CurveByPoints this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As CurveByPoints
    Get
    Set
Visual C++
public:
virtual property CurveByPoints^ Item[int index] {
    CurveByPoints^ get (int index);
    void set (int index, CurveByPoints^ value);
}

Parameters

index
Type: System..::..Int32

See Also

CurveByPointsArray Class


Size Property

[image]

Revit 2013 API
CurveByPointsArray..::..Size Property
CurveByPointsArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CurveByPointsArray Class


CurveByPointsArrayIterator Class

[image]

Revit 2013 API
CurveByPointsArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CurveByPointsArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CurveByPointsArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CurveByPointsArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..CurveByPointsArrayIterator

See Also

CurveByPointsArrayIterator Members


CurveByPointsArrayIterator Members

[image] [image]

Revit 2013 API
CurveByPointsArrayIterator Members
CurveByPointsArrayIterator Class Constructors Methods Properties See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CurveByPointsArrayIterator | Initializes a new instance of the CurveByPointsArrayIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Constructor

[image]

Revit 2013 API
CurveByPointsArrayIterator Constructor
CurveByPointsArrayIterator Class See Also Send Feedback
Initializes a new instance of the CurveByPointsArrayIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveByPointsArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
CurveByPointsArrayIterator()

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Methods

[image] [image]

Revit 2013 API
CurveByPointsArrayIterator Methods
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveByPointsArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
CurveByPointsArrayIterator..::..MoveNext Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

CurveByPointsArrayIterator Class


Reset Method

[image]

Revit 2013 API
CurveByPointsArrayIterator..::..Reset Method
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

CurveByPointsArrayIterator Class


CurveByPointsArrayIterator Properties

[image] [image]

Revit 2013 API
CurveByPointsArrayIterator Properties
CurveByPointsArrayIterator Class See Also Send Feedback

The CurveByPointsArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CurveByPointsArrayIterator Class


Current Property

[image]

Revit 2013 API
CurveByPointsArrayIterator..::..Current Property
CurveByPointsArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

CurveByPointsArrayIterator Class


CurveByPointsUtils Class

[image]

Revit 2013 API
CurveByPointsUtils Class
Members See Also Send Feedback
A static class that contains methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class CurveByPointsUtils : IDisposable
Visual Basic
Public Class CurveByPointsUtils _
    Implements IDisposable
Visual C++
public ref class CurveByPointsUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveByPointsUtils

See Also

CurveByPointsUtils Members


CurveByPointsUtils Members

[image] [image]

Revit 2013 API
CurveByPointsUtils Members
CurveByPointsUtils Class Methods See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Methods

 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose | Releases all resources used by the CurveByPointsUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFaceRegions | Gets the FaceRegions in the existing face.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class


CurveByPointsUtils Methods

[image] [image]

Revit 2013 API
CurveByPointsUtils Methods
CurveByPointsUtils Class See Also Send Feedback

The CurveByPointsUtils type exposes the following members.

Methods

 | Name | Description
 | AddCurvesToFaceRegion | Adds The CurveElements to one or more FaceRegions.
 | CreateRectangle | Creates rectangle on face or sketchplane for two given diagonal points.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFaceRegions | Gets the FaceRegions in the existing face.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetHostFace | Gets the host face to which the CurveElement is added.
 | GetProjectionType | Gets the projection type of the CurveElement.
 | GetSketchOnSurface | Gets the relationship between the CurveElement and face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | SetProjectionType | Sets the projection type of the CurveElement.
 | SetSketchOnSurface | Sets the relationship between the CurveElement and face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateCurveElementIdArrayForFaceRegions | Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

See Also

CurveByPointsUtils Class


AddCurvesToFaceRegion Method

[image]

Revit 2013 API
CurveByPointsUtils..::..AddCurvesToFaceRegion Method
CurveByPointsUtils Class See Also Send Feedback
Adds The CurveElements to one or more FaceRegions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void AddCurvesToFaceRegion(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic
Public Shared Sub AddCurvesToFaceRegion ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
)
Visual C++
public:
static void AddCurvesToFaceRegion(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
curveElemIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ElementIds of CurveElements which are to define the FaceRegion.

Remarks

The CurveElements that are input may produce an arbitrary number of regions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to add curves to FaceRegion.

See Also

CurveByPointsUtils Class


CreateRectangle Method

[image]

Revit 2013 API
CurveByPointsUtils..::..CreateRectangle Method
CurveByPointsUtils Class See Also Send Feedback
Creates rectangle on face or sketchplane for two given diagonal points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateRectangle(
    Document document,
    ReferencePoint startPoint,
    ReferencePoint endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    out IList<ElementId> createdCurvesIds,
    out IList<ElementId> createdCornersIds
)
Visual Basic
Public Shared Sub CreateRectangle ( _
    document As Document, _
    startPoint As ReferencePoint, _
    endPoint As ReferencePoint, _
    projectionType As CurveProjectionType, _
    boundaryReferenceLines As Boolean, _
    boundaryCurvesFollowSurface As Boolean, _
    <OutAttribute> ByRef createdCurvesIds As IList(Of ElementId), _
    <OutAttribute> ByRef createdCornersIds As IList(Of ElementId) _
)
Visual C++
public:
static void CreateRectangle(
    Document^ document,
    ReferencePoint^ startPoint,
    ReferencePoint^ endPoint,
    CurveProjectionType projectionType,
    bool boundaryReferenceLines,
    bool boundaryCurvesFollowSurface,
    [OutAttribute] IList<ElementId^>^% createdCurvesIds,
    [OutAttribute] IList<ElementId^>^% createdCornersIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
startPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
First diagonal point of rectangle.
endPoint
Type: Autodesk.Revit.DB..::..ReferencePoint
Second diagonal point of rectangle.
projectionType
Type: Autodesk.Revit.DB..::..CurveProjectionType
Projection type of rectangle's boundary curves. If the rectangle input points are Face hosted, and CurveProjectionType::ParallelToLevel is requested, and the Face normal at the location of the start point is at a less than 45 degree angle with the level planes, then the projectionType will be set to FromTopDown, even if ParallelToLevel was requested.
boundaryReferenceLines
Type: System..::..Boolean
True if rectangle's boundary curves should be reference lines, false otherwise.
boundaryCurvesFollowSurface
Type: System..::..Boolean
True if rectangle's boundary curves should follow surface, false otherwise.
createdCurvesIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>%
Created rectangle's boundary curves ids.
createdCornersIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>%
Ids of two newly created corner points.

Remarks

This array contains the ElementIds of the two additional corner points that are created to complete the rectangle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Unexpected projection type.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create rectangle.

See Also

CurveByPointsUtils Class


Dispose Method

[image]

Revit 2013 API
CurveByPointsUtils..::..Dispose Method
CurveByPointsUtils Class See Also Send Feedback
Releases all resources used by the CurveByPointsUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveByPointsUtils Class


GetFaceRegions Method

[image]

Revit 2013 API
CurveByPointsUtils..::..GetFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Gets the FaceRegions in the existing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetFaceRegions(
    Document cda,
    Reference referenceOfFace
)
Visual Basic
Public Shared Function GetFaceRegions ( _
    cda As Document, _
    referenceOfFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetFaceRegions(
    Document^ cda,
    Reference^ referenceOfFace
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The Document.
referenceOfFace
Type: Autodesk.Revit.DB..::..Reference
The Reference of the existing face.

Return Value

The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face Reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetHostFace Method

[image]

Revit 2013 API
CurveByPointsUtils..::..GetHostFace Method
CurveByPointsUtils Class See Also Send Feedback
Gets the host face to which the CurveElement is added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Reference GetHostFace(
    CurveElement curveElem
)
Visual Basic
Public Shared Function GetHostFace ( _
    curveElem As CurveElement _
) As Reference
Visual C++
public:
static Reference^ GetHostFace(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.

Return Value

The host face to which the CurveElement is added, or an empty Reference if the host is not a face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetProjectionType Method

[image]

Revit 2013 API
CurveByPointsUtils..::..GetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Gets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CurveProjectionType GetProjectionType(
    CurveElement curveElem
)
Visual Basic
Public Shared Function GetProjectionType ( _
    curveElem As CurveElement _
) As CurveProjectionType
Visual C++
public:
static CurveProjectionType GetProjectionType(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.

Return Value

The projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


GetSketchOnSurface Method

[image]

Revit 2013 API
CurveByPointsUtils..::..GetSketchOnSurface Method
CurveByPointsUtils Class See Also Send Feedback
Gets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool GetSketchOnSurface(
    CurveElement curveElem
)
Visual Basic
Public Shared Function GetSketchOnSurface ( _
    curveElem As CurveElement _
) As Boolean
Visual C++
public:
static bool GetSketchOnSurface(
    CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.

Return Value

Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


SetProjectionType Method

[image]

Revit 2013 API
CurveByPointsUtils..::..SetProjectionType Method
CurveByPointsUtils Class See Also Send Feedback
Sets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetProjectionType(
    CurveElement curveElem,
    CurveProjectionType value
)
Visual Basic
Public Shared Sub SetProjectionType ( _
    curveElem As CurveElement, _
    value As CurveProjectionType _
)
Visual C++
public:
static void SetProjectionType(
    CurveElement^ curveElem,
    CurveProjectionType value
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
value
Type: Autodesk.Revit.DB..::..CurveProjectionType
The input projection type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


SetSketchOnSurface Method

[image]

Revit 2013 API
CurveByPointsUtils..::..SetSketchOnSurface Method
CurveByPointsUtils Class See Also Send Feedback
Sets the relationship between the CurveElement and face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void SetSketchOnSurface(
    CurveElement curveElem,
    bool sketchOnSurface
)
Visual Basic
Public Shared Sub SetSketchOnSurface ( _
    curveElem As CurveElement, _
    sketchOnSurface As Boolean _
)
Visual C++
public:
static void SetSketchOnSurface(
    CurveElement^ curveElem,
    bool sketchOnSurface
)

Parameters

curveElem
Type: Autodesk.Revit.DB..::..CurveElement
The CurveElement.
sketchOnSurface
Type: System..::..Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input CurveElement is not a CurveByPoints.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


ValidateCurveElementIdArrayForFaceRegions Method

[image]

Revit 2013 API
CurveByPointsUtils..::..ValidateCurveElementIdArrayForFaceRegions Method
CurveByPointsUtils Class See Also Send Feedback
Validates that the input CurveElements can define FaceRegions. The CurveElements must be CurveByPoints. Each curve must be entirely hosted by a single Face or hosts related to a common Face (for example, Edges of a common Face, other CurveElements hosted by a common Face). To be added to the FaceRegion definition, a CurveElement must have the SketchOnSurface attribute set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ValidateCurveElementIdArrayForFaceRegions(
    Document document,
    IList<ElementId> curveElemIds
)
Visual Basic
Public Shared Function ValidateCurveElementIdArrayForFaceRegions ( _
    document As Document, _
    curveElemIds As IList(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ValidateCurveElementIdArrayForFaceRegions(
    Document^ document,
    IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
curveElemIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The CurveElements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveByPointsUtils Class


CurveElement Class

[image]

Revit 2013 API
CurveElement Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveElement : Element
Visual Basic
Public Class CurveElement _
    Inherits Element
Visual C++
public ref class CurveElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..CurveByPoints
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB.Structure..::..AreaReinforcementCurve
Autodesk.Revit.DB..::..SymbolicCurve

See Also

CurveElement Members


CurveElement Members

[image] [image]

Revit 2013 API
CurveElement Members
CurveElement Class Methods Properties See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element.
Public property | LineStyles | Obsolete. All available line styles.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveElement Class


CurveElement Methods

[image] [image]

Revit 2013 API
CurveElement Methods
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveElement Class


GetLineStyleIds Method

[image]

Revit 2013 API
CurveElement..::..GetLineStyleIds Method
CurveElement Class See Also Send Feedback
Retrieves the set of available line style Element Ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetLineStyleIds()
Visual Basic
Public Function GetLineStyleIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetLineStyleIds()

Return Value

A collection of ElementIds of line styles. The members will be the ids of GraphicsStyle elements. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

See Also

CurveElement Class


CurveElement Properties

[image] [image]

Revit 2013 API
CurveElement Properties
CurveElement Class See Also Send Feedback

The CurveElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element.
Public property | LineStyles | Obsolete. All available line styles.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CurveElement Class


CenterPointReference Property

[image]

Revit 2013 API
CurveElement..::..CenterPointReference Property
CurveElement Class See Also Send Feedback
Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference CenterPointReference { get; }
Visual Basic
Public ReadOnly Property CenterPointReference As Reference
    Get
Visual C++
public:
property Reference^ CenterPointReference {
    Reference^ get ();
}

Remarks

Use this reference property when using the API to dimension between centerpoints of curves.

See Also

CurveElement Class


CurveElementType Property

[image]

Revit 2013 API
CurveElement..::..CurveElementType Property
CurveElement Class See Also Send Feedback
The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic
Public ReadOnly Property CurveElementType As CurveElementType
    Get
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElement Class


GeometryCurve Property

[image]

Revit 2013 API
CurveElement..::..GeometryCurve Property
CurveElement Class See Also Send Feedback
Geometry curve of the curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve GeometryCurve { get; set; }
Visual Basic
Public Property GeometryCurve As Curve
    Get
    Set
Visual C++
public:
property Curve^ GeometryCurve {
    Curve^ get ();
    void set (Curve^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when try to set a curve of different type.

See Also

CurveElement Class


LineStyle Property

[image]

Revit 2013 API
CurveElement..::..LineStyle Property
CurveElement Class See Also Send Feedback
The line style of this curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element LineStyle { get; set; }
Visual Basic
Public Property LineStyle As Element
    Get
    Set
Visual C++
public:
property Element^ LineStyle {
    Element^ get ();
    void set (Element^ value);
}

Remarks

The return of this property will be a GraphicsStyle element. These graphics styles should be associated to subcategories of the BuiltInCategory OST_Lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when fail to get line style.

See Also

CurveElement Class


LineStyles Property

[image]

Revit 2013 API
CurveElement..::..LineStyles Property
CurveElement Class See Also Send Feedback
All available line styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetLineStyleIds() instead.")]
public ElementArray LineStyles { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetLineStyleIds() instead.")> _
Public ReadOnly Property LineStyles As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetLineStyleIds() instead.")]
public:
property ElementArray^ LineStyles {
    ElementArray^ get ();
}

See Also

CurveElement Class


Parameter Property

[image] [image]

Revit 2013 API
CurveElement..::..Parameter Property
CurveElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CurveElement Class
CurveElement Members


SketchPlane Property

[image]

Revit 2013 API
CurveElement..::..SketchPlane Property
CurveElement Class See Also Send Feedback
The sketch plane the curve element lies in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SketchPlane SketchPlane { get; set; }
Visual Basic
Public Overridable Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
virtual property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Remarks

The new sketch plane must be parallel to the existing sketch plane. Setting this property is not permitted for detail curves because they must be placed only on view-specific planes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the modification failed, when the sketch plane is not parallel to the existing plane, or when this property is set on a DetailCurve.

See Also

CurveElement Class


CurveElementFilter Class

[image]

Revit 2013 API
CurveElementFilter Class
Members Example See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class CurveElementFilter : ElementSlowFilter
Visual Basic
Public Class CurveElementFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class CurveElementFilter : public ElementSlowFilter

Examples

CopyC#
// Create a CurveElement filter to find CurveByPoints elements.
// It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
// method OfClass() because subclasses of CurveElement are not supported by those methods.
CurveElementFilter filter = new CurveElementFilter(CurveElementType.CurveByPoints);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> founds = collector.WherePasses(filter).ToElements();

// Find all curve elements: use inverted filter with invalid CurveElementType to match elements
CurveElementFilter notCurveByPntFilter = new CurveElementFilter(CurveElementType.Invalid, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveByPntFounds = collector.WherePasses(notCurveByPntFilter).ToElements();
CopyVB.NET
' Create a CurveElement filter to find CurveByPoints elements.
' It is necessary to use the CurveElementFilter, and not an ElementClassFilter or  the shortcut
' method OfClass() because subclasses of CurveElement are not supported by those methods.
Dim filter As New CurveElementFilter(CurveElementType.CurveByPoints)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim founds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find all curve elements: use inverted filter with invalid CurveElementType to match elements
Dim notCurveByPntFilter As New CurveElementFilter(CurveElementType.Invalid, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notCurveByPntFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notCurveByPntFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..CurveElementFilter

See Also

CurveElementFilter Members


CurveElementFilter Members

[image] [image]

Revit 2013 API
CurveElementFilter Members
CurveElementFilter Class Constructors Methods Properties See Also Send Feedback

The CurveElementFilter type exposes the following members.

Constructors

 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveElementType | The curve element type.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class


CurveElementFilter Constructor

[image] [image]

Revit 2013 API
CurveElementFilter Constructor
CurveElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CurveElementFilter(CurveElementType) | Constructs a new instance of a filter to match specific types of curve elements.
Public method | CurveElementFilter(CurveElementType, Boolean) | Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Members


CurveElementFilter Constructor (CurveElementType)

[image]

Revit 2013 API
CurveElementFilter Constructor (CurveElementType)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Constructor (CurveElementType, Boolean)

[image]

Revit 2013 API
CurveElementFilter Constructor (CurveElementType, Boolean)
CurveElementFilter Class See Also Send Feedback
Constructs a new instance of a filter to match specific types of curve elements, with the option to match all curves which are not of the given curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    curveElementType As CurveElementType, _
    inverted As Boolean _
)
Visual C++
public:
CurveElementFilter(
    CurveElementType curveElementType,
    bool inverted
)

Parameters

curveElementType
Type: Autodesk.Revit.DB..::..CurveElementType
The curve element type to match.
inverted
Type: System..::..Boolean
True if the filter should match all curves which are not of the given curve type.

See Also

CurveElementFilter Class
CurveElementFilter Overload


CurveElementFilter Methods

[image] [image]

Revit 2013 API
CurveElementFilter Methods
CurveElementFilter Class See Also Send Feedback

The CurveElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveElementFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
CurveElementFilter..::..PassesFilter Method
CurveElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class
CurveElementFilter Members


CurveElementFilter Properties

[image] [image]

Revit 2013 API
CurveElementFilter Properties
CurveElementFilter Class See Also Send Feedback

The CurveElementFilter type exposes the following members.

Properties

 | Name | Description
Public property | CurveElementType | The curve element type.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

CurveElementFilter Class


CurveElementType Property

[image]

Revit 2013 API
CurveElementFilter..::..CurveElementType Property
CurveElementFilter Class See Also Send Feedback
The curve element type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public CurveElementType CurveElementType { get; }
Visual Basic
Public ReadOnly Property CurveElementType As CurveElementType
    Get
Visual C++
public:
property CurveElementType CurveElementType {
    CurveElementType get ();
}

See Also

CurveElementFilter Class


CurveElementType Enumeration

[image]

Revit 2013 API
CurveElementType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum CurveElementType
Visual Basic
Public Enumeration CurveElementType
Visual C++
public enum class CurveElementType

Members

Member name | Description
Invalid | An invalid curve element type.
ModelCurve | A model curve.
DetailCurve | A detail curve.
SymbolicCurve | A symbolic curve.
ReferenceLine | A reference line.
SpaceSeparation | A space separation curve.
RoomSeparation | An room separation curve.
AreaSeparation | An area separation curve.
CurveByPoints | A curve created by connecting a set of points.
RepeatingDetail | The profile of a repeating detail set.
Insulation | A detail curve representing insulation.
Cloud | A portion of a revision cloud.

See Also


CurveLoop Class

[image]

Revit 2013 API
CurveLoop Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveLoop : IEnumerable<Curve>,
    IDisposable
Visual Basic
Public Class CurveLoop _
    Implements IEnumerable(Of Curve), IDisposable
Visual C++
public ref class CurveLoop : IEnumerable<Curve^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveLoop

See Also

CurveLoop Members


CurveLoop Members

[image] [image]

Revit 2013 API
CurveLoop Members
CurveLoop Class Constructors Methods See Also Send Feedback

The CurveLoop type exposes the following members.

Constructors

 | Name | Description
Public method | CurveLoop | Constructs a new empty curve loop.

Methods

 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaThicken | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
Public method | Dispose | Releases all resources used by the CurveLoop
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through the curve loop.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoop Class


CurveLoop Constructor

[image]

Revit 2013 API
CurveLoop Constructor
CurveLoop Class See Also Send Feedback
Constructs a new empty curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public CurveLoop()
Visual Basic
Public Sub New
Visual C++
public:
CurveLoop()

See Also

CurveLoop Class


CurveLoop Methods

[image] [image]

Revit 2013 API
CurveLoop Methods
CurveLoop Class See Also Send Feedback

The CurveLoop type exposes the following members.

Methods

 | Name | Description
Public method | Append | Append the curve to this loop.
 | Create | Creates a new curve loop.
 | CreateViaCopy | Creates a new curve loop as a copy of the input.
 | CreateViaThicken | Creates a new closed curve loop by thickening the input curve with respect to a given plane.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Reverses the orientation of the curve loop.
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetCurveLoopIterator | Returns a curve that iterates through the curve loop.
Public method | GetEnumerator | Returns an enumerator that iterates through the curve loop.
Public method | GetExactLength | Returns the sum of exact lengths of all curves in the loop.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlane | Gets the plane of the curve loop, if it is planar.
Public method | GetRectangularHeight | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetRectangularWidth | Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasPlane | Identifies if the CurveLoop is planar.
Public method | IsCounterclockwise | Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.
Public method | IsOpen | Returns whether the curve loop is open or closed, as determined by an internal flag.
Public method | IsRectangular | Identifies if the curve loop is rectangular with respect to a given projection plane.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoop Class


Append Method

[image]

Revit 2013 API
CurveLoop..::..Append Method
CurveLoop Class See Also Send Feedback
Append the curve to this loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Append(
    Curve curve
)
Visual Basic
Public Sub Append ( _
    curve As Curve _
)
Visual C++
public:
void Append(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Throws if the input curve makes the loop not contiguous.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveLoop Class


Create Method

[image]

Revit 2013 API
CurveLoop..::..Create Method
CurveLoop Class See Also Send Feedback
Creates a new curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CurveLoop Create(
    IList<Curve> curves
)
Visual Basic
Public Shared Function Create ( _
    curves As IList(Of Curve) _
) As CurveLoop
Visual C++
public:
static CurveLoop^ Create(
    IList<Curve^>^ curves
)

Parameters

curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The curves.

Return Value

The curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curves contains at least one helical curve and is not supported for this operation. -or- Throws if the input curves are not contiguous.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveLoop Class


CreateViaCopy Method

[image]

Revit 2013 API
CurveLoop..::..CreateViaCopy Method
CurveLoop Class See Also Send Feedback
Creates a new curve loop as a copy of the input.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CurveLoop CreateViaCopy(
    CurveLoop original
)
Visual Basic
Public Shared Function CreateViaCopy ( _
    original As CurveLoop _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaCopy(
    CurveLoop^ original
)

Parameters

original
Type: Autodesk.Revit.DB..::..CurveLoop
The original curve loop.

Return Value

The copied curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveLoop Class


CreateViaThicken Method

[image]

Revit 2013 API
CurveLoop..::..CreateViaThicken Method
CurveLoop Class See Also Send Feedback
Creates a new closed curve loop by thickening the input curve with respect to a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CurveLoop CreateViaThicken(
    Curve pCurve,
    double thickness,
    XYZ normal
)
Visual Basic
Public Shared Function CreateViaThicken ( _
    pCurve As Curve, _
    thickness As Double, _
    normal As XYZ _
) As CurveLoop
Visual C++
public:
static CurveLoop^ CreateViaThicken(
    Curve^ pCurve,
    double thickness,
    XYZ^ normal
)

Parameters

pCurve
Type: Autodesk.Revit.DB..::..Curve
The input curve.
thickness
Type: System..::..Double
The distance between the offset curves created on either side of the input curve.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for thickening.

Return Value

The new curve loop.

Remarks

The new loop will be created via offsets of the input curve (in the plane of the normal vector) with the endpoints connected with lines.The original curve will be at the center of the new loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pCurve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for thickness must be greater than 0 and no more than 30000 feet.

See Also

CurveLoop Class


Dispose Method

[image]

Revit 2013 API
CurveLoop..::..Dispose Method
CurveLoop Class See Also Send Feedback
Releases all resources used by the CurveLoop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

CurveLoop Class


Flip Method

[image]

Revit 2013 API
CurveLoop..::..Flip Method
CurveLoop Class See Also Send Feedback
Reverses the orientation of the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

CurveLoop Class


GetBasicIEnumerator Method

[image]

Revit 2013 API
CurveLoop..::..GetBasicIEnumerator Method
CurveLoop Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CurveLoop Class


GetCurveLoopIterator Method

[image]

Revit 2013 API
CurveLoop..::..GetCurveLoopIterator Method
CurveLoop Class See Also Send Feedback
Returns a curve that iterates through the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CurveLoopIterator GetCurveLoopIterator()
Visual Basic
Public Function GetCurveLoopIterator As CurveLoopIterator
Visual C++
public:
CurveLoopIterator^ GetCurveLoopIterator()

Return Value

A curve loop iterator object that can be used to iterate through key-value pairs in the collection.

See Also

CurveLoop Class


GetEnumerator Method

[image]

Revit 2013 API
CurveLoop..::..GetEnumerator Method
CurveLoop Class See Also Send Feedback
Returns an enumerator that iterates through the curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual IEnumerator<Curve> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Curve)
Visual C++
public:
virtual IEnumerator<Curve^>^ GetEnumerator()

Return Value

An IEnumerator(Curve) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CurveLoop Class


GetExactLength Method

[image]

Revit 2013 API
CurveLoop..::..GetExactLength Method
CurveLoop Class See Also Send Feedback
Returns the sum of exact lengths of all curves in the loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetExactLength()
Visual Basic
Public Function GetExactLength As Double
Visual C++
public:
double GetExactLength()

Return Value

The total length of the curves in the loop.

See Also

CurveLoop Class


GetPlane Method

[image]

Revit 2013 API
CurveLoop..::..GetPlane Method
CurveLoop Class See Also Send Feedback
Gets the plane of the curve loop, if it is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Plane GetPlane()
Visual Basic
Public Function GetPlane As Plane
Visual C++
public:
Plane^ GetPlane()

Return Value

The plane of the curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop does not lie in a single plane.

See Also

CurveLoop Class


GetRectangularHeight Method

[image]

Revit 2013 API
CurveLoop..::..GetRectangularHeight Method
CurveLoop Class See Also Send Feedback
Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetRectangularHeight(
    Plane plane
)
Visual Basic
Public Function GetRectangularHeight ( _
    plane As Plane _
) As Double
Visual C++
public:
double GetRectangularHeight(
    Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to which the curves will be projected.

Return Value

The height.

Remarks

The height is determined by the V extents of the UV curve created by from the curve loop plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop is not rectangular when projected to the input plane.

See Also

CurveLoop Class


GetRectangularWidth Method

[image]

Revit 2013 API
CurveLoop..::..GetRectangularWidth Method
CurveLoop Class See Also Send Feedback
Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetRectangularWidth(
    Plane plane
)
Visual Basic
Public Function GetRectangularWidth ( _
    plane As Plane _
) As Double
Visual C++
public:
double GetRectangularWidth(
    Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to which the curves will be projected.

Return Value

The width.

Remarks

The width is determined by the U extents of the UV curve created by from the curve loop plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop is not rectangular when projected to the input plane.

See Also

CurveLoop Class


HasPlane Method

[image]

Revit 2013 API
CurveLoop..::..HasPlane Method
CurveLoop Class See Also Send Feedback
Identifies if the CurveLoop is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasPlane()
Visual Basic
Public Function HasPlane As Boolean
Visual C++
public:
bool HasPlane()

Return Value

True if the curve loop is planar, false otherwise.

See Also

CurveLoop Class


IsCounterclockwise Method

[image]

Revit 2013 API
CurveLoop..::..IsCounterclockwise Method
CurveLoop Class See Also Send Feedback
Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with respect to the specified 3D direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsCounterclockwise(
    XYZ normal
)
Visual Basic
Public Function IsCounterclockwise ( _
    normal As XYZ _
) As Boolean
Visual C++
public:
bool IsCounterclockwise(
    XYZ^ normal
)

Parameters

normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for this determination.

Return Value

True if the curve loop is oriented counter-clockwise with respect to the specified 3D direction, false if the loop is oriented clockwise.

Remarks

CCW means that the projection of the CurveLoop onto a plane having "normal" as its oriented normal is CCW. This method should only be called if the loop is closed and has a non-singular projection onto the plane (i.e., the projection should have no self-intersections and should not be degenerate or even nearly degenerate). The return value in other cases is indeterminate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop is open or consists of a single unbound curve; counterclockwise determination has no meaning.

See Also

CurveLoop Class


IsOpen Method

[image]

Revit 2013 API
CurveLoop..::..IsOpen Method
CurveLoop Class See Also Send Feedback
Returns whether the curve loop is open or closed, as determined by an internal flag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsOpen()
Visual Basic
Public Function IsOpen As Boolean
Visual C++
public:
bool IsOpen()

Return Value

True if the CurveLoop is marked open, false if marked closed.

Remarks

Some routines in Revit may set the CurveLoop to be marked "open" or "closed" in spite of the actual geometry of the curves. In these special cases, the CurveLoop class does not require that the CurveLoop is correctly marked.

See Also

CurveLoop Class


IsRectangular Method

[image]

Revit 2013 API
CurveLoop..::..IsRectangular Method
CurveLoop Class See Also Send Feedback
Identifies if the curve loop is rectangular with respect to a given projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsRectangular(
    Plane plane
)
Visual Basic
Public Function IsRectangular ( _
    plane As Plane _
) As Boolean
Visual C++
public:
bool IsRectangular(
    Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to which the curves will be projected to determine if they represent a rectangle.

Return Value

True if the curve loop is rectangular, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CurveLoop Class


CurveLoopIterator Class

[image]

Revit 2013 API
CurveLoopIterator Class
Members See Also Send Feedback
An iterator to a curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CurveLoopIterator : IEnumerator<Curve>
Visual Basic
Public Class CurveLoopIterator _
    Implements IEnumerator(Of Curve)
Visual C++
public ref class CurveLoopIterator : IEnumerator<Curve^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CurveLoopIterator

See Also

CurveLoopIterator Members


CurveLoopIterator Members

[image] [image]

Revit 2013 API
CurveLoopIterator Members
CurveLoopIterator Class Methods Properties See Also Send Feedback

The CurveLoopIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the CurveLoopIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

CurveLoopIterator Class


CurveLoopIterator Methods

[image] [image]

Revit 2013 API
CurveLoopIterator Methods
CurveLoopIterator Class See Also Send Feedback

The CurveLoopIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoopIterator Class


Dispose Method

[image]

Revit 2013 API
CurveLoopIterator..::..Dispose Method
CurveLoopIterator Class See Also Send Feedback
Releases all resources used by the CurveLoopIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

CurveLoopIterator Class


MoveNext Method

[image]

Revit 2013 API
CurveLoopIterator..::..MoveNext Method
CurveLoopIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

Remarks

After an enumerator is created or after the Reset method is called, an enumerator is positioned before the first element of the collection, and the first call to the MoveNext method moves the enumerator over the first element of the collection.

See Also

CurveLoopIterator Class


Reset Method

[image]

Revit 2013 API
CurveLoopIterator..::..Reset Method
CurveLoopIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

CurveLoopIterator Class


CurveLoopIterator Properties

[image] [image]

Revit 2013 API
CurveLoopIterator Properties
CurveLoopIterator Class See Also Send Feedback

The CurveLoopIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

CurveLoopIterator Class


Current Property

[image]

Revit 2013 API
CurveLoopIterator..::..Current Property
CurveLoopIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual Curve Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Curve
    Get
Visual C++
public:
virtual property Curve^ Current {
    Curve^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

CurveLoopIterator Class


CurrentObject Property

[image]

Revit 2013 API
CurveLoopIterator..::..CurrentObject Property
CurveLoopIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

CurveLoopIterator Class


CurveLoopsProfile Class

[image]

Revit 2013 API
CurveLoopsProfile Class
Members See Also Send Feedback
Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic
Public Class CurveLoopsProfile _
    Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..CurveLoopsProfile

See Also

CurveLoopsProfile Members


CurveLoopsProfile Members

[image] [image]

Revit 2013 API
CurveLoopsProfile Members
CurveLoopsProfile Class Methods Properties See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


CurveLoopsProfile Methods

[image] [image]

Revit 2013 API
CurveLoopsProfile Methods
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CurveLoopsProfile Class


CurveLoopsProfile Properties

[image] [image]

Revit 2013 API
CurveLoopsProfile Properties
CurveLoopsProfile Class See Also Send Feedback

The CurveLoopsProfile type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the curve loops of the profile.

See Also

CurveLoopsProfile Class


Profile Property

[image]

Revit 2013 API
CurveLoopsProfile..::..Profile Property
CurveLoopsProfile Class See Also Send Feedback
Returns the curve loops of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray Profile { get; set; }
Visual Basic
Public Property Profile As CurveArrArray
    Get
    Set
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
    void set (CurveArrArray^ value);
}

Remarks

This property is used to retrieve the curve loops of profile.

See Also

CurveLoopsProfile Class


CurveProjectionType Enumeration

[image]

Revit 2013 API
CurveProjectionType Enumeration
See Also Send Feedback
This attribute indicates how the curve will be projected to the surface if the curve is sketched on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum CurveProjectionType
Visual Basic
Public Enumeration CurveProjectionType
Visual C++
public enum class CurveProjectionType

Members

Member name | Description
FromTopDown | Projects curve in a direction parallel to the height of the project or family (projects in an upwardly or downwardly direction). For example, would be used to project curves to a surface that represented a roof or site, where the goal was for the curves to look from above as they were sketched, even though they are being mapped to the surface.
ParallelToLevel | The curves are projected to their target surface in a projection direction that is parallel to level. The exact vector of projection also considers the endpoints of the curve being projected or endpoints in a loop of curves it belongs to (if any). But the vector is always parallel to the level. This is used to create curves on the building that retain a particular sketched shape based on elevation perspective, regardless of target surface contours. Sketching windows is an example where this is useful.
FollowSurfaceUV | The curve is generated on to lie on the surface based on its endpoints/control points on the surface, its curve type, and depending on the surface type, either projecting to the surface based on projecting tessellation points of the curve to the target surface, or by interpreting the equation produced by the curve type and user defined control points in the surface uv. In some ways, this is the most robust way to generate the curve on the surface, but for some surface shapes, it can make it difficult to obtain the desired appearance from a particular perspective in the model.

See Also


CutFailureReason Enumeration

[image]

Revit 2013 API
CutFailureReason Enumeration
See Also Send Feedback
The reason why a solid-solid cut cannot be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum CutFailureReason
Visual Basic
Public Enumeration CutFailureReason
Visual C++
public enum class CutFailureReason

Members

Member name | Description
CutAllowed | Yes, the cutting element can add a cut to the target element.
CutAlreadyExists | The cutting element has already cut the target element.
OppositeCutExists | The target element has already cut the cutting element.
CutNotAppropriateForElements | The cut is not appropriate for the two elements.

See Also


CylindricalFace Class

[image]

Revit 2013 API
CylindricalFace Class
Members Example See Also Send Feedback
A cylinder face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CylindricalFace : Face
Visual Basic
Public Class CylindricalFace _
    Inherits Face
Visual C++
public ref class CylindricalFace : public Face

Remarks

Cylinder faces are defined by cylinder surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + cos(u)*Radius[0] + sin(u)*Radius[1] + v*Axis

Examples

CopyC#
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetCylindricalFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim cylindricalFace As CylindricalFace = TryCast(face, CylindricalFace)
    If cylindricalFace IsNot Nothing Then
        Dim axis As Autodesk.Revit.DB.XYZ = cylindricalFace.Axis
        Dim origin As Autodesk.Revit.DB.XYZ = cylindricalFace.Origin
        Dim radius As Autodesk.Revit.DB.XYZ = cylindricalFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..CylindricalFace

See Also

CylindricalFace Members


CylindricalFace Members

[image] [image]

Revit 2013 API
CylindricalFace Members
CylindricalFace Class Methods Properties See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class


CylindricalFace Methods

[image] [image]

Revit 2013 API
CylindricalFace Methods
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class


Intersect Method

[image] [image]

Revit 2013 API
CylindricalFace..::..Intersect Method
CylindricalFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


IsInside Method

[image] [image]

Revit 2013 API
CylindricalFace..::..IsInside Method
CylindricalFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


Triangulate Method

[image] [image]

Revit 2013 API
CylindricalFace..::..Triangulate Method
CylindricalFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

CylindricalFace Class
CylindricalFace Members


CylindricalFace Properties

[image] [image]

Revit 2013 API
CylindricalFace Properties
CylindricalFace Class See Also Send Feedback

The CylindricalFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radii of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

CylindricalFace Class


Axis Property

[image]

Revit 2013 API
CylindricalFace..::..Axis Property
CylindricalFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Origin Property

[image]

Revit 2013 API
CylindricalFace..::..Origin Property
CylindricalFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

CylindricalFace Class


Radius Property

[image]

Revit 2013 API
CylindricalFace..::..Radius Property
CylindricalFace Class See Also Send Feedback
Radii of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

CylindricalFace Class


CylindricalHelix Class

[image]

Revit 2013 API
CylindricalHelix Class
Members See Also Send Feedback
A cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CylindricalHelix : Curve
Visual Basic
Public Class CylindricalHelix _
    Inherits Curve
Visual C++
public ref class CylindricalHelix : public Curve

Remarks

The helix winds around a cylinder making constant angle with the axis of the cylinder. In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..CylindricalHelix

See Also

CylindricalHelix Members


CylindricalHelix Members

[image] [image]

Revit 2013 API
CylindricalHelix Members
CylindricalHelix Class Methods Properties See Also Send Feedback

The CylindricalHelix type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create | Create a cylindrical helix.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | Height | Height of the cylindrical helix.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class


CylindricalHelix Methods

[image] [image]

Revit 2013 API
CylindricalHelix Methods
CylindricalHelix Class See Also Send Feedback

The CylindricalHelix type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
 | Create | Create a cylindrical helix.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CylindricalHelix Class


Create Method

[image]

Revit 2013 API
CylindricalHelix..::..Create Method
CylindricalHelix Class See Also Send Feedback
Create a cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static CylindricalHelix Create(
    XYZ basePoint,
    double radius,
    XYZ xVector,
    XYZ zVector,
    double pitch,
    double startAngle,
    double endAngle
)
Visual Basic
Public Shared Function Create ( _
    basePoint As XYZ, _
    radius As Double, _
    xVector As XYZ, _
    zVector As XYZ, _
    pitch As Double, _
    startAngle As Double, _
    endAngle As Double _
) As CylindricalHelix
Visual C++
public:
static CylindricalHelix^ Create(
    XYZ^ basePoint,
    double radius,
    XYZ^ xVector,
    XYZ^ zVector,
    double pitch,
    double startAngle,
    double endAngle
)

Parameters

basePoint
Type: Autodesk.Revit.DB..::..XYZ
Base point of the axis. It can be any point in 3d.
radius
Type: System..::..Double
Radius. It should be a positive number.
xVector
Type: Autodesk.Revit.DB..::..XYZ
X vector. Should be Non-zero vector.
zVector
Type: Autodesk.Revit.DB..::..XYZ
Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
pitch
Type: System..::..Double
Pitch. It should be non-zero number, can be positive or negative. Positive means right handed and negative means left handed.
startAngle
Type: System..::..Double
Start angle. It specifies the start point of the Helix.
endAngle
Type: System..::..Double
End angle. It specifies the end point of the Helix. End angle should not be equal to start angle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The radius is negative -or- the pitch is zero -or- the xVector or zVector is zero length -or- zVector is not orthogonal to xVector -or- endAngle is equal to startAngle.

See Also

CylindricalHelix Class


Intersect Method

[image] [image]

Revit 2013 API
CylindricalHelix..::..Intersect Method
CylindricalHelix Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

CylindricalHelix Class
CylindricalHelix Members


IsInside Method

[image] [image]

Revit 2013 API
CylindricalHelix..::..IsInside Method
CylindricalHelix Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

CylindricalHelix Class
CylindricalHelix Members


CylindricalHelix Properties

[image] [image]

Revit 2013 API
CylindricalHelix Properties
CylindricalHelix Class See Also Send Feedback

The CylindricalHelix type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | BasePoint | The base point of the axis of the cylindrical helix.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | Height | Height of the cylindrical helix.
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRightHanded | True if the helix is right handed, false if the helix is left handed.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Pitch | The pitch of the cylindrical helix.
Public property | Radius | The radius of the cylindrical helix.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XVector | The X direction vector.
Public property | YVector | The Y direction vector.
Public property | ZVector | The Z direction vector, which is same as the axis direction vector.

See Also

CylindricalHelix Class


BasePoint Property

[image]

Revit 2013 API
CylindricalHelix..::..BasePoint Property
CylindricalHelix Class See Also Send Feedback
The base point of the axis of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ BasePoint { get; }
Visual Basic
Public ReadOnly Property BasePoint As XYZ
    Get
Visual C++
public:
property XYZ^ BasePoint {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


Height Property

[image]

Revit 2013 API
CylindricalHelix..::..Height Property
CylindricalHelix Class See Also Send Feedback
Height of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

It is the length of the span of the helix along the axis direction. The height is defined only if the helix is bounded. That is, its start and end angles (parameters) are specified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Height is not defined for unbounded helix.

See Also

CylindricalHelix Class


IsRightHanded Property

[image]

Revit 2013 API
CylindricalHelix..::..IsRightHanded Property
CylindricalHelix Class See Also Send Feedback
True if the helix is right handed, false if the helix is left handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRightHanded { get; }
Visual Basic
Public ReadOnly Property IsRightHanded As Boolean
    Get
Visual C++
public:
property bool IsRightHanded {
    bool get ();
}

See Also

CylindricalHelix Class


Pitch Property

[image]

Revit 2013 API
CylindricalHelix..::..Pitch Property
CylindricalHelix Class See Also Send Feedback
The pitch of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Pitch { get; }
Visual Basic
Public ReadOnly Property Pitch As Double
    Get
Visual C++
public:
property double Pitch {
    double get ();
}

Remarks

It is the distance moved along the axis direction when a point makes one rotation about the axis. Pitch can be positive or negative.

See Also

CylindricalHelix Class


Radius Property

[image]

Revit 2013 API
CylindricalHelix..::..Radius Property
CylindricalHelix Class See Also Send Feedback
The radius of the cylindrical helix.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Radius { get; }
Visual Basic
Public ReadOnly Property Radius As Double
    Get
Visual C++
public:
property double Radius {
    double get ();
}

See Also

CylindricalHelix Class


XVector Property

[image]

Revit 2013 API
CylindricalHelix..::..XVector Property
CylindricalHelix Class See Also Send Feedback
The X direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ XVector { get; }
Visual Basic
Public ReadOnly Property XVector As XYZ
    Get
Visual C++
public:
property XYZ^ XVector {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


YVector Property

[image]

Revit 2013 API
CylindricalHelix..::..YVector Property
CylindricalHelix Class See Also Send Feedback
The Y direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ YVector { get; }
Visual Basic
Public ReadOnly Property YVector As XYZ
    Get
Visual C++
public:
property XYZ^ YVector {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


ZVector Property

[image]

Revit 2013 API
CylindricalHelix..::..ZVector Property
CylindricalHelix Class See Also Send Feedback
The Z direction vector, which is same as the axis direction vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ ZVector { get; }
Visual Basic
Public ReadOnly Property ZVector As XYZ
    Get
Visual C++
public:
property XYZ^ ZVector {
    XYZ^ get ();
}

See Also

CylindricalHelix Class


DecimalSymbolType Enumeration

[image]

Revit 2013 API
DecimalSymbolType Enumeration
See Also Send Feedback
An enumerated type listing two types of the Decimal Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DecimalSymbolType
Visual Basic
Public Enumeration DecimalSymbolType
Visual C++
public enum class DecimalSymbolType

Members

Member name | Description
DST_DOT |
DST_COMMA |

See Also


Definition Class

[image]

Revit 2013 API
Definition Class
Members See Also Send Feedback
The Definition object is a base object for all type of parameter definitions within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class Definition : APIObject
Visual Basic
Public MustInherit Class Definition _
    Inherits APIObject
Visual C++
public ref class Definition abstract : public APIObject

Remarks

This object supports properties and methods that report the name and type of a particular parameter. There are two kinds of definition object derived from this: InternalDefinition which represents all kinds of definitions existing entirely within the Autodesk Revit database. ExternalDefinitions represent definitions stored on disk in a shared parameters file. Most of the time code should be written to utilize this Definition base class as then the code will be applicable to both internal and external parameter definitions.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..ExternalDefinition
Autodesk.Revit.DB..::..InternalDefinition

See Also

Definition Members


Definition Members

[image] [image]

Revit 2013 API
Definition Members
Definition Class Methods Properties See Also Send Feedback

The Definition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class


Definition Methods

[image] [image]

Revit 2013 API
Definition Methods
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definition Class


Definition Properties

[image] [image]

Revit 2013 API
Definition Properties
Definition Class See Also Send Feedback

The Definition type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter.
Public property | ParameterGroup | Returns the group ID of the parameter definition.
Public property | ParameterType | Returns the user visible interpretation of the parameter data.

See Also

Definition Class


Name Property

[image]

Revit 2013 API
Definition..::..Name Property
Definition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () abstract;
}

See Also

Definition Class


ParameterGroup Property

[image]

Revit 2013 API
Definition..::..ParameterGroup Property
Definition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract BuiltInParameterGroup ParameterGroup { get; }
Visual Basic
Public MustOverride ReadOnly Property ParameterGroup As BuiltInParameterGroup
    Get
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () abstract;
}

See Also

Definition Class


ParameterType Property

[image]

Revit 2013 API
Definition..::..ParameterType Property
Definition Class Example See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract ParameterType ParameterType { get; }
Visual Basic
Public MustOverride ReadOnly Property ParameterType As ParameterType
    Get
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () abstract;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

Examples

CopyC#
//Find parameter using the Parameter's definition type.
public Parameter FindParameter(Element element)
{
    Parameter foundParameter = null;
    // This will find the first parameter that measures length
    foreach (Parameter parameter in element.Parameters)
    {
        if (parameter.Definition.ParameterType == ParameterType.Length)
        {
            foundParameter = parameter;
            break;
        }
    }
    return foundParameter;
}
CopyVB.NET
'Find parameter using the Parameter's definition type.
Public Function FindParameter(ByVal element As Autodesk.Revit.DB.Element) As Parameter
    Dim foundParameter As Parameter = Nothing
    ' This will find the first parameter that measures length
    For Each parameter As Parameter In element.Parameters
        If parameter.Definition.ParameterType = ParameterType.Length Then
            foundParameter = parameter
            Exit For
        End If
    Next
    Return foundParameter
End Function

See Also

Definition Class


DefinitionBindingMap Class

[image]

Revit 2013 API
DefinitionBindingMap Class
Members See Also Send Feedback
A map that contains mappings of parameter definitions to parameter bindings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DefinitionBindingMap : APIObject,
    IEnumerable
Visual Basic
Public Class DefinitionBindingMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DefinitionBindingMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMap
Autodesk.Revit.DB..::..BindingMap

See Also

DefinitionBindingMap Members


DefinitionBindingMap Members

[image] [image]

Revit 2013 API
DefinitionBindingMap Members
DefinitionBindingMap Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMap | Initializes a new instance of the DefinitionBindingMap class

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Constructor

[image]

Revit 2013 API
DefinitionBindingMap Constructor
DefinitionBindingMap Class See Also Send Feedback
Initializes a new instance of the DefinitionBindingMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionBindingMap()
Visual Basic
Public Sub New
Visual C++
public:
DefinitionBindingMap()

See Also

DefinitionBindingMap Class


DefinitionBindingMap Methods

[image] [image]

Revit 2013 API
DefinitionBindingMap Methods
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every binding from the map, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMap Class


Clear Method

[image]

Revit 2013 API
DefinitionBindingMap..::..Clear Method
DefinitionBindingMap Class See Also Send Feedback
Removes every binding from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DefinitionBindingMap Class


Contains Method

[image]

Revit 2013 API
DefinitionBindingMap..::..Contains Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Definition key
)
Visual Basic
Public Overridable Function Contains ( _
    key As Definition _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

See Also

DefinitionBindingMap Class


Erase Method

[image]

Revit 2013 API
DefinitionBindingMap..::..Erase Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Definition key
)
Visual Basic
Public Overridable Function Erase ( _
    key As Definition _
) As Integer
Visual C++
public:
virtual int Erase(
    Definition^ key
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

See Also

DefinitionBindingMap Class


ForwardIterator Method

[image]

Revit 2013 API
DefinitionBindingMap..::..ForwardIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

DefinitionBindingMap Class


GetEnumerator Method

[image]

Revit 2013 API
DefinitionBindingMap..::..GetEnumerator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DefinitionBindingMap Class


Insert Method

[image]

Revit 2013 API
DefinitionBindingMap..::..Insert Method
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Definition key,
    Binding item
)
Visual Basic
Public Overridable Function Insert ( _
    key As Definition, _
    item As Binding _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Definition^ key,
    Binding^ item
)

Parameters

key
Type: Autodesk.Revit.DB..::..Definition
item
Type: Autodesk.Revit.DB..::..Binding

See Also

DefinitionBindingMap Class


ReverseIterator Method

[image]

Revit 2013 API
DefinitionBindingMap..::..ReverseIterator Method
DefinitionBindingMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DefinitionBindingMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DefinitionBindingMapIterator
Visual C++
public:
virtual DefinitionBindingMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

DefinitionBindingMap Class


DefinitionBindingMap Properties

[image] [image]

Revit 2013 API
DefinitionBindingMap Properties
DefinitionBindingMap Class See Also Send Feedback

The DefinitionBindingMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size | Returns the number of bindings that are in the map.

See Also

DefinitionBindingMap Class


IsEmpty Property

[image]

Revit 2013 API
DefinitionBindingMap..::..IsEmpty Property
DefinitionBindingMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

DefinitionBindingMap Class


Item Property

[image]

Revit 2013 API
DefinitionBindingMap..::..Item Property
DefinitionBindingMap Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Binding this[
    Definition key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As Definition _
) As Binding
    Get
    Set
Visual C++
public:
virtual property Binding^ Item[Definition^ key] {
    Binding^ get (Definition^ key);
    void set (Definition^ key, Binding^ value);
}

Parameters

key
Type: Autodesk.Revit.DB..::..Definition

See Also

DefinitionBindingMap Class


Size Property

[image]

Revit 2013 API
DefinitionBindingMap..::..Size Property
DefinitionBindingMap Class See Also Send Feedback
Returns the number of bindings that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DefinitionBindingMap Class


DefinitionBindingMapIterator Class

[image]

Revit 2013 API
DefinitionBindingMapIterator Class
Members See Also Send Feedback
An iterator to a parameter definition to parameter bindings map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DefinitionBindingMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DefinitionBindingMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DefinitionBindingMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionBindingMapIterator

See Also

DefinitionBindingMapIterator Members


DefinitionBindingMapIterator Members

[image] [image]

Revit 2013 API
DefinitionBindingMapIterator Members
DefinitionBindingMapIterator Class Constructors Methods Properties See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DefinitionBindingMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Constructor

[image]

Revit 2013 API
DefinitionBindingMapIterator Constructor
DefinitionBindingMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionBindingMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
DefinitionBindingMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Methods

[image] [image]

Revit 2013 API
DefinitionBindingMapIterator Methods
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionBindingMapIterator Class


MoveNext Method

[image]

Revit 2013 API
DefinitionBindingMapIterator..::..MoveNext Method
DefinitionBindingMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


Reset Method

[image]

Revit 2013 API
DefinitionBindingMapIterator..::..Reset Method
DefinitionBindingMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DefinitionBindingMapIterator Class


DefinitionBindingMapIterator Properties

[image] [image]

Revit 2013 API
DefinitionBindingMapIterator Properties
DefinitionBindingMapIterator Class See Also Send Feedback

The DefinitionBindingMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the binding that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the definition that is the current focus of the iterator.

See Also

DefinitionBindingMapIterator Class


Current Property

[image]

Revit 2013 API
DefinitionBindingMapIterator..::..Current Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the binding that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


Key Property

[image]

Revit 2013 API
DefinitionBindingMapIterator..::..Key Property
DefinitionBindingMapIterator Class See Also Send Feedback
Retrieves the definition that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Definition Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As Definition
    Get
Visual C++
public:
virtual property Definition^ Key {
    Definition^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

DefinitionBindingMapIterator Class


DefinitionFile Class

[image]

Revit 2013 API
DefinitionFile Class
Members Example See Also Send Feedback
The DefinitionFile object represents a shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DefinitionFile : APIObject
Visual Basic
Public Class DefinitionFile _
    Inherits APIObject
Visual C++
public ref class DefinitionFile : public APIObject

Remarks

Shared Parameters are parameter definitions that are stored in a text file external to the Autodesk Revit project. These definitions can be used in multiple projects and are identifiable by a unique identifier generated when they are created. API access to shared parameters consist of a number of objects, the first of which is an object that represents the shared parameters file on disk. That object then contains a number of Group objects. Shared parameters are grouped for easier management. These groups then contain the shared parameter definitions. The groups support the ability to create new shared parameter definitions. The DefinitionFile object can be retrieved by the Application.OpenSharedParameterFile method.

Examples

CopyC#
private void ShowDefinitionFileInfo(DefinitionFile myDefinitionFile)
{
    StringBuilder fileInformation = new StringBuilder(500);

    // get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename);

    // iterate the Definition groups of this file
    foreach (DefinitionGroup myGroup in myDefinitionFile.Groups)
    {
        // get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name);

        // iterate the difinitions
        foreach (Definition definition in myGroup.Definitions)
        {
            // get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name);
        }
    }
    TaskDialog.Show("Revit",fileInformation.ToString());
}
CopyVB.NET
Private Sub ShowDefinitionFileInfo(ByVal myDefinitionFile As DefinitionFile)
    Dim fileInformation As New StringBuilder(500)

    ' get the file name
    fileInformation.AppendLine("File Name: " + myDefinitionFile.Filename)

    ' iterate the Definition groups of this file
    For Each myGroup As DefinitionGroup In myDefinitionFile.Groups
        ' get the group name
        fileInformation.AppendLine("Group Name: " + myGroup.Name)

        ' iterate the difinitions
        For Each definition As Definition In myGroup.Definitions
            ' get definition name
            fileInformation.AppendLine("Definition Name: " + definition.Name)
        Next
    Next
    TaskDialog.Show("Revit", fileInformation.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionFile

See Also

DefinitionFile Members


DefinitionFile Members

[image] [image]

Revit 2013 API
DefinitionFile Members
DefinitionFile Class Methods Properties See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class


DefinitionFile Methods

[image] [image]

Revit 2013 API
DefinitionFile Methods
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionFile Class


DefinitionFile Properties

[image] [image]

Revit 2013 API
DefinitionFile Properties
DefinitionFile Class See Also Send Feedback

The DefinitionFile type exposes the following members.

Properties

 | Name | Description
Public property | Filename | This property returns the physical filename of the shared parameters file on disk.
Public property | Groups | Return a map of shared parameter definition groups contained within the file.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DefinitionFile Class


Filename Property

[image]

Revit 2013 API
DefinitionFile..::..Filename Property
DefinitionFile Class See Also Send Feedback
This property returns the physical filename of the shared parameters file on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Filename { get; }
Visual Basic
Public ReadOnly Property Filename As String
    Get
Visual C++
public:
property String^ Filename {
    String^ get ();
}

See Also

DefinitionFile Class


Groups Property

[image]

Revit 2013 API
DefinitionFile..::..Groups Property
DefinitionFile Class See Also Send Feedback
Return a map of shared parameter definition groups contained within the file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionGroups Groups { get; }
Visual Basic
Public ReadOnly Property Groups As DefinitionGroups
    Get
Visual C++
public:
property DefinitionGroups^ Groups {
    DefinitionGroups^ get ();
}

Remarks

A particular group can be found by Name, using the Item property on the DefinitionGroups object. A new group can be created by using the Create method on the DefinitionGroups Object. The Create method takes the name of the new group, as a string, as its input parameter, returning a reference to a new definition group object as its result.

See Also

DefinitionFile Class


DefinitionGroup Class

[image]

Revit 2013 API
DefinitionGroup Class
Members See Also Send Feedback
The DefinitionGroup is a container that is used to hold shared parameter definitions on disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DefinitionGroup : APIObject
Visual Basic
Public Class DefinitionGroup _
    Inherits APIObject
Visual C++
public ref class DefinitionGroup : public APIObject

Remarks

Groups are used for logical arrangement of the shared parameters into meaningful sets. Through the DefinitionGroup object new shared parameter definitions can be made.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DefinitionGroup

See Also

DefinitionGroup Members


DefinitionGroup Members

[image] [image]

Revit 2013 API
DefinitionGroup Members
DefinitionGroup Class Methods Properties See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


DefinitionGroup Methods

[image] [image]

Revit 2013 API
DefinitionGroup Methods
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroup Class


DefinitionGroup Properties

[image] [image]

Revit 2013 API
DefinitionGroup Properties
DefinitionGroup Class See Also Send Feedback

The DefinitionGroup type exposes the following members.

Properties

 | Name | Description
Public property | Definitions | The Definitions property returns an object that contains all the shared parameter definitions within the group.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Returns the name of the parameter group.

See Also

DefinitionGroup Class


Definitions Property

[image]

Revit 2013 API
DefinitionGroup..::..Definitions Property
DefinitionGroup Class See Also Send Feedback
The Definitions property returns an object that contains all the shared parameter definitions within the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definitions Definitions { get; }
Visual Basic
Public ReadOnly Property Definitions As Definitions
    Get
Visual C++
public:
property Definitions^ Definitions {
    Definitions^ get ();
}

Remarks

A known definition can be retrieved, by name, using the Item property on the Definitions object. A new definition can be created by using the Create method. The Create method takes two parameters, a string for name and a type. If the creation of the definition was successful then an object representing the definition is returned by the Create method.

See Also

DefinitionGroup Class


Name Property

[image]

Revit 2013 API
DefinitionGroup..::..Name Property
DefinitionGroup Class See Also Send Feedback
Returns the name of the parameter group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

DefinitionGroup Class


DefinitionGroups Class

[image]

Revit 2013 API
DefinitionGroups Class
Members See Also Send Feedback
A specialized set of definition groups that allows creation of new groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DefinitionGroups : IEnumerable<DefinitionGroup>,
    IDisposable
Visual Basic
Public Class DefinitionGroups _
    Implements IEnumerable(Of DefinitionGroup), IDisposable
Visual C++
public ref class DefinitionGroups : IEnumerable<DefinitionGroup^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DefinitionGroups

See Also

DefinitionGroups Members


DefinitionGroups Members

[image] [image]

Revit 2013 API
DefinitionGroups Members
DefinitionGroups Class Methods Properties See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose | Releases all resources used by the DefinitionGroups
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class


DefinitionGroups Methods

[image] [image]

Revit 2013 API
DefinitionGroups Methods
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition group within the collection.
Public method | Create | Create a new parameter definition group using the name provided.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DefinitionGroups Class


Contains Method

[image]

Revit 2013 API
DefinitionGroups..::..Contains Method
DefinitionGroups Class See Also Send Feedback
Tests for the existence of a definition group within the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Contains(
    DefinitionGroup definitionGroup
)
Visual Basic
Public Function Contains ( _
    definitionGroup As DefinitionGroup _
) As Boolean
Visual C++
public:
bool Contains(
    DefinitionGroup^ definitionGroup
)

Parameters

definitionGroup
Type: Autodesk.Revit.DB..::..DefinitionGroup
The definition group to look for.

Return Value

True if the definition group was found, false otherwise.

See Also

DefinitionGroups Class


Create Method

[image]

Revit 2013 API
DefinitionGroups..::..Create Method
DefinitionGroups Class See Also Send Feedback
Create a new parameter definition group using the name provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionGroup Create(
    string name
)
Visual Basic
Public Function Create ( _
    name As String _
) As DefinitionGroup
Visual C++
public:
DefinitionGroup^ Create(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the group to be created.

Return Value

If successful a reference to the new parameter group is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If a group with the same name already exists then an exception will be thrown.

See Also

DefinitionGroups Class


Dispose Method

[image]

Revit 2013 API
DefinitionGroups..::..Dispose Method
DefinitionGroups Class See Also Send Feedback
Releases all resources used by the DefinitionGroups

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DefinitionGroups Class


GetBasicIEnumerator Method

[image]

Revit 2013 API
DefinitionGroups..::..GetBasicIEnumerator Method
DefinitionGroups Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DefinitionGroups Class


GetEnumerator Method

[image]

Revit 2013 API
DefinitionGroups..::..GetEnumerator Method
DefinitionGroups Class See Also Send Feedback
Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<DefinitionGroup> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of DefinitionGroup)
Visual C++
public:
virtual IEnumerator<DefinitionGroup^>^ GetEnumerator()

Return Value

The enumerator.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

DefinitionGroups Class


DefinitionGroups Properties

[image] [image]

Revit 2013 API
DefinitionGroups Properties
DefinitionGroups Class See Also Send Feedback

The DefinitionGroups type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definition groups collection is empty.
Public property | Item | Retrieve a definition group by name.
Public property | Size | The number of definition groups in the collection.

See Also

DefinitionGroups Class


IsEmpty Property

[image]

Revit 2013 API
DefinitionGroups..::..IsEmpty Property
DefinitionGroups Class See Also Send Feedback
Identifies if the definition groups collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

DefinitionGroups Class


Item Property

[image]

Revit 2013 API
DefinitionGroups..::..Item Property
DefinitionGroups Class See Also Send Feedback
Retrieve a definition group by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DefinitionGroup this[
    string groupName
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    groupName As String _
) As DefinitionGroup
    Get
Visual C++
public:
property DefinitionGroup^ Item[String^ groupName] {
    DefinitionGroup^ get (String^ groupName);
}

Parameters

groupName
Type: System..::..String
The name of the group for which to search.

Remarks

If the group is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

DefinitionGroups Class


Size Property

[image]

Revit 2013 API
DefinitionGroups..::..Size Property
DefinitionGroups Class See Also Send Feedback
The number of definition groups in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

DefinitionGroups Class


Definitions Class

[image]

Revit 2013 API
Definitions Class
Members See Also Send Feedback
A base class that supports the addition of new parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Definitions : IEnumerable<Definition>,
    IDisposable
Visual Basic
Public Class Definitions _
    Implements IEnumerable(Of Definition), IDisposable
Visual C++
public ref class Definitions : IEnumerable<Definition^>,
    IDisposable

Remarks

There are two derivations of this class, one of which handles external parameters and another which handles internal parameters.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..ExternalDefinitions
Autodesk.Revit.DB..::..InternalDefinitions

See Also

Definitions Members


Definitions Members

[image] [image]

Revit 2013 API
Definitions Members
Definitions Class Constructors Methods Properties See Also Send Feedback

The Definitions type exposes the following members.

Constructors

 | Name | Description
Public method | Definitions | Constructs an empty set of parameter definitions.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type.
Public method | Dispose | Releases all resources used by the Definitions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.

See Also

Definitions Class


Definitions Constructor

[image]

Revit 2013 API
Definitions Constructor
Definitions Class See Also Send Feedback
Constructs an empty set of parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definitions()
Visual Basic
Public Sub New
Visual C++
public:
Definitions()

See Also

Definitions Class


Definitions Methods

[image] [image]

Revit 2013 API
Definitions Methods
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set.
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Retrieves an enumerator to the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Definitions Class


Contains Method

[image]

Revit 2013 API
Definitions..::..Contains Method
Definitions Class See Also Send Feedback
Tests for the existence of a definition within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Contains(
    Definition definition
)
Visual Basic
Public Function Contains ( _
    definition As Definition _
) As Boolean
Visual C++
public:
bool Contains(
    Definition^ definition
)

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition
The definition to look for.

Return Value

True if the definition was found, false otherwise.

See Also

Definitions Class


Create Method

[image] [image]

Revit 2013 API
Definitions..::..Create Method
Definitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility.
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type.

See Also

Definitions Class
Definitions Members


Create Method (String, ParameterType)

[image]

Revit 2013 API
Definitions..::..Create Method (String, ParameterType)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name, type and visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type
)
Visual Basic
Public Function Create ( _
    name As String, _
    type As ParameterType _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type
)

Parameters

name
Type: System..::..String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB..::..ParameterType
The name of the parameter type for the new definition.

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be created.

See Also

Definitions Class
Create Overload


Create Method (String, ParameterType, Boolean)

[image]

Revit 2013 API
Definitions..::..Create Method (String, ParameterType, Boolean)
Definitions Class See Also Send Feedback
Creates a new parameter definition using name and type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition Create(
    string name,
    ParameterType type,
    bool visible
)
Visual Basic
Public Function Create ( _
    name As String, _
    type As ParameterType, _
    visible As Boolean _
) As Definition
Visual C++
public:
Definition^ Create(
    String^ name,
    ParameterType type,
    bool visible
)

Parameters

name
Type: System..::..String
The name of the parameter definition to be created.
type
Type: Autodesk.Revit.DB..::..ParameterType
The name of the parameter type for the new definition.
visible
Type: System..::..Boolean

Return Value

If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

If an attempt is made to create a new internal definition an exception will be thrown. Only external (shared) parameter definitions can be made.

See Also

Definitions Class
Create Overload


Dispose Method

[image]

Revit 2013 API
Definitions..::..Dispose Method
Definitions Class See Also Send Feedback
Releases all resources used by the Definitions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Definitions Class


GetBasicIEnumerator Method

[image]

Revit 2013 API
Definitions..::..GetBasicIEnumerator Method
Definitions Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

Definitions Class


GetEnumerator Method

[image]

Revit 2013 API
Definitions..::..GetEnumerator Method
Definitions Class See Also Send Feedback
Retrieves an enumerator to the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<Definition> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Definition)
Visual C++
public:
virtual IEnumerator<Definition^>^ GetEnumerator()

Return Value

The enumerator.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

Definitions Class


Definitions Properties

[image] [image]

Revit 2013 API
Definitions Properties
Definitions Class See Also Send Feedback

The Definitions type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty.
Public property | Item | Retrieves a definition by a given name.
Public property | Size | The number of definitions in the collection.

See Also

Definitions Class


IsEmpty Property

[image]

Revit 2013 API
Definitions..::..IsEmpty Property
Definitions Class See Also Send Feedback
Identifies if the definitions collection is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Definitions Class


Item Property

[image]

Revit 2013 API
Definitions..::..Item Property
Definitions Class See Also Send Feedback
Retrieves a definition by a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition this[
    string name
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    name As String _
) As Definition
    Get
Visual C++
public:
property Definition^ Item[String^ name] {
    Definition^ get (String^ name);
}

Parameters

name
Type: System..::..String
The name of the parameter definition for which to search.

Remarks

If the definition is not found then nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

See Also

Definitions Class


Size Property

[image]

Revit 2013 API
Definitions..::..Size Property
Definitions Class See Also Send Feedback
The number of definitions in the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

Definitions Class


DeleteElements Class

[image]

Revit 2013 API
DeleteElements Class
Members See Also Send Feedback
Deletes element(s) related to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class DeleteElements : FailureResolution
Visual Basic
Public Class DeleteElements _
    Inherits FailureResolution
Visual C++
public ref class DeleteElements : public FailureResolution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureResolution
Autodesk.Revit.DB..::..DeleteElements

See Also

DeleteElements Members


DeleteElements Members

[image] [image]

Revit 2013 API
DeleteElements Members
DeleteElements Class Methods See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteElements Class


DeleteElements Methods

[image] [image]

Revit 2013 API
DeleteElements Methods
DeleteElements Class See Also Send Feedback

The DeleteElements type exposes the following members.

Methods

 | Name | Description
 | Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
 | Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.
Public method | Dispose | (Inherited from FailureResolution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteElements Class


Create Method

[image] [image]

Revit 2013 API
DeleteElements..::..Create Method
DeleteElements Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates an instance of the DeleteElements resolution.
Create(Document, IList<(Of <<'(ElementId>)>>)) | Creates an instance of the DeleteElements resolution.

See Also

DeleteElements Class
DeleteElements Members


Create Method (Document, ElementId)

[image]

Revit 2013 API
DeleteElements..::..Create Method (Document, ElementId)
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    ElementId id
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    id As ElementId _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which owns the element to delete.
id
Type: Autodesk.Revit.DB..::..ElementId
The id of the element that will be deleted when this resolution is chosen.

Return Value

The instance of the DeletedElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input id is not valid for deletion.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DeleteElements Class
Create Overload


Create Method (Document, IList(ElementId))

[image]

Revit 2013 API
DeleteElements..::..Create Method (Document, IList<(Of <(<'ElementId>)>)>)
DeleteElements Class See Also Send Feedback
Creates an instance of the DeleteElements resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureResolution Create(
    Document document,
    IList<ElementId> ids
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ids As IList(Of ElementId) _
) As FailureResolution
Visual C++
public:
static FailureResolution^ Create(
    Document^ document,
    IList<ElementId^>^ ids
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which owns the elements to delete.
ids
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ids of the elements that will be deleted when this resolution is chosen.

Return Value

The instance of the DeleteElements resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input ids is empty or contains an invalid element id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DeleteElements Class
Create Overload


DesignOption Class

[image]

Revit 2013 API
DesignOption Class
Members See Also Send Feedback
An element that represents a design alternative.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DesignOption : Element
Visual Basic
Public Class DesignOption _
    Inherits Element
Visual C++
public ref class DesignOption : public Element

Remarks

Design options enable the user to add alternative designs within the same project. Each element can either be in a design option or not at all, in which case it is considered to be part of the main model and have no design alternatives.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DesignOption

See Also

DesignOption Members


DesignOption Members

[image] [image]

Revit 2013 API
DesignOption Members
DesignOption Class Methods Properties See Also Send Feedback

The DesignOption type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Determines whether this is a primary design option.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DesignOption Class


DesignOption Methods

[image] [image]

Revit 2013 API
DesignOption Methods
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetActiveDesignOptionId | Gets the active design option id for the current design option set.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DesignOption Class


GetActiveDesignOptionId Method

[image]

Revit 2013 API
DesignOption..::..GetActiveDesignOptionId Method
DesignOption Class See Also Send Feedback
Gets the active design option id for the current design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetActiveDesignOptionId(
    Document document
)
Visual Basic
Public Shared Function GetActiveDesignOptionId ( _
    document As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetActiveDesignOptionId(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The active design option id. It can be invalid id if there is no active design option in the model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DesignOption Class


DesignOption Properties

[image] [image]

Revit 2013 API
DesignOption Properties
DesignOption Class See Also Send Feedback

The DesignOption type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Determines whether this is a primary design option.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DesignOption Class


IsPrimary Property

[image]

Revit 2013 API
DesignOption..::..IsPrimary Property
DesignOption Class See Also Send Feedback
Determines whether this is a primary design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPrimary { get; }
Visual Basic
Public ReadOnly Property IsPrimary As Boolean
    Get
Visual C++
public:
property bool IsPrimary {
    bool get ();
}

See Also

DesignOption Class


Parameter Property

[image] [image]

Revit 2013 API
DesignOption..::..Parameter Property
DesignOption Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DesignOption Class
DesignOption Members


DetachFromCentralOption Enumeration

[image]

Revit 2013 API
DetachFromCentralOption Enumeration
See Also Send Feedback
Options for workset detachment behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum DetachFromCentralOption
Visual Basic
Public Enumeration DetachFromCentralOption
Visual C++
public enum class DetachFromCentralOption

Members

Member name | Description
DoNotDetach | Do not detach the file being opened from its central file.
DetachAndPreserveWorksets | Detach the file being opened from its central file.

See Also


DetailArc Class

[image]

Revit 2013 API
DetailArc Class
Members See Also Send Feedback
Represents a DetailArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailArc : DetailCurve
Visual Basic
Public Class DetailArc _
    Inherits DetailCurve
Visual C++
public ref class DetailArc : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailArc

See Also

DetailArc Members


DetailArc Members

[image] [image]

Revit 2013 API
DetailArc Members
DetailArc Class Methods Properties See Also Send Feedback

The DetailArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailArc Class


DetailArc Methods

[image] [image]

Revit 2013 API
DetailArc Methods
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailArc Class


DetailArc Properties

[image] [image]

Revit 2013 API
DetailArc Properties
DetailArc Class See Also Send Feedback

The DetailArc type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailArc Class


Parameter Property

[image] [image]

Revit 2013 API
DetailArc..::..Parameter Property
DetailArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailArc Class
DetailArc Members


DetailCurve Class

[image]

Revit 2013 API
DetailCurve Class
Members See Also Send Feedback
A curve that is used to create a detail drawing. A detail curve is visible only in the view in which it is drawn.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailCurve : CurveElement
Visual Basic
Public Class DetailCurve _
    Inherits CurveElement
Visual C++
public ref class DetailCurve : public CurveElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailArc
Autodesk.Revit.DB..::..DetailEllipse
Autodesk.Revit.DB..::..DetailLine
Autodesk.Revit.DB..::..DetailNurbSpline

See Also

DetailCurve Members


DetailCurve Members

[image] [image]

Revit 2013 API
DetailCurve Members
DetailCurve Class Methods Properties See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailCurve Class


DetailCurve Methods

[image] [image]

Revit 2013 API
DetailCurve Methods
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurve Class


DetailCurve Properties

[image] [image]

Revit 2013 API
DetailCurve Properties
DetailCurve Class See Also Send Feedback

The DetailCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailCurve Class


Parameter Property

[image] [image]

Revit 2013 API
DetailCurve..::..Parameter Property
DetailCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailCurve Class
DetailCurve Members


DetailCurveArray Class

[image]

Revit 2013 API
DetailCurveArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailCurveArray : APIObject,
    IEnumerable
Visual Basic
Public Class DetailCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DetailCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DetailCurveArray

See Also

DetailCurveArray Members


DetailCurveArray Members

[image] [image]

Revit 2013 API
DetailCurveArray Members
DetailCurveArray Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | DetailCurveArray | Initializes a new instance of the DetailCurveArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


DetailCurveArray Constructor

[image]

Revit 2013 API
DetailCurveArray Constructor
DetailCurveArray Class See Also Send Feedback
Initializes a new instance of the DetailCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DetailCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
DetailCurveArray()

See Also

DetailCurveArray Class


DetailCurveArray Methods

[image] [image]

Revit 2013 API
DetailCurveArray Methods
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArray Class


Append Method

[image]

Revit 2013 API
DetailCurveArray..::..Append Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    DetailCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As DetailCurve _
)
Visual C++
public:
virtual void Append(
    DetailCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DetailCurve

See Also

DetailCurveArray Class


Clear Method

[image]

Revit 2013 API
DetailCurveArray..::..Clear Method
DetailCurveArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DetailCurveArray Class


ForwardIterator Method

[image]

Revit 2013 API
DetailCurveArray..::..ForwardIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DetailCurveArray Class


GetEnumerator Method

[image]

Revit 2013 API
DetailCurveArray..::..GetEnumerator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DetailCurveArray Class


Insert Method

[image]

Revit 2013 API
DetailCurveArray..::..Insert Method
DetailCurveArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    DetailCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As DetailCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DetailCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..DetailCurve
index
Type: System..::..Int32

See Also

DetailCurveArray Class


ReverseIterator Method

[image]

Revit 2013 API
DetailCurveArray..::..ReverseIterator Method
DetailCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DetailCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DetailCurveArrayIterator
Visual C++
public:
virtual DetailCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DetailCurveArray Class


DetailCurveArray Properties

[image] [image]

Revit 2013 API
DetailCurveArray Properties
DetailCurveArray Class See Also Send Feedback

The DetailCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DetailCurveArray Class


IsEmpty Property

[image]

Revit 2013 API
DetailCurveArray..::..IsEmpty Property
DetailCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DetailCurveArray Class


Item Property

[image]

Revit 2013 API
DetailCurveArray..::..Item Property
DetailCurveArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DetailCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As DetailCurve
    Get
    Set
Visual C++
public:
virtual property DetailCurve^ Item[int index] {
    DetailCurve^ get (int index);
    void set (int index, DetailCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DetailCurveArray Class


Size Property

[image]

Revit 2013 API
DetailCurveArray..::..Size Property
DetailCurveArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DetailCurveArray Class


DetailCurveArrayIterator Class

[image]

Revit 2013 API
DetailCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DetailCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DetailCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DetailCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DetailCurveArrayIterator

See Also

DetailCurveArrayIterator Members


DetailCurveArrayIterator Members

[image] [image]

Revit 2013 API
DetailCurveArrayIterator Members
DetailCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DetailCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Constructor

[image]

Revit 2013 API
DetailCurveArrayIterator Constructor
DetailCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DetailCurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
DetailCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Methods

[image] [image]

Revit 2013 API
DetailCurveArrayIterator Methods
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailCurveArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
DetailCurveArrayIterator..::..MoveNext Method
DetailCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


Reset Method

[image]

Revit 2013 API
DetailCurveArrayIterator..::..Reset Method
DetailCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DetailCurveArrayIterator Class


DetailCurveArrayIterator Properties

[image] [image]

Revit 2013 API
DetailCurveArrayIterator Properties
DetailCurveArrayIterator Class See Also Send Feedback

The DetailCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DetailCurveArrayIterator Class


Current Property

[image]

Revit 2013 API
DetailCurveArrayIterator..::..Current Property
DetailCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DetailCurveArrayIterator Class


DetailElementOrderUtils Class

[image]

Revit 2013 API
DetailElementOrderUtils Class
Members See Also Send Feedback
A utility class that arranges the draw order of the detail objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DetailElementOrderUtils : IDisposable
Visual Basic
Public Class DetailElementOrderUtils _
    Implements IDisposable
Visual C++
public ref class DetailElementOrderUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DetailElementOrderUtils

See Also

DetailElementOrderUtils Members


DetailElementOrderUtils Members

[image] [image]

Revit 2013 API
DetailElementOrderUtils Members
DetailElementOrderUtils Class Methods See Also Send Feedback

The DetailElementOrderUtils type exposes the following members.

Methods

 | Name | Description
 | BringForward | Moves the given detail instance one step closer to the front of all other detail instances in the view.
 | BringToFront | Places the given detail instance in the front of all other detail instances in the view.
Public method | Dispose | Releases all resources used by the DetailElementOrderUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDetailElement | Indicates if the given element is a detail element.
 | SendBackward | Moves the given detail instance one step closer to the back of all other detail instances in the view.
 | SendToBack | Places the given detail instance behind all detail instances in the view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailElementOrderUtils Class


DetailElementOrderUtils Methods

[image] [image]

Revit 2013 API
DetailElementOrderUtils Methods
DetailElementOrderUtils Class See Also Send Feedback

The DetailElementOrderUtils type exposes the following members.

Methods

 | Name | Description
 | BringForward | Moves the given detail instance one step closer to the front of all other detail instances in the view.
 | BringToFront | Places the given detail instance in the front of all other detail instances in the view.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDetailElement | Indicates if the given element is a detail element.
 | SendBackward | Moves the given detail instance one step closer to the back of all other detail instances in the view.
 | SendToBack | Places the given detail instance behind all detail instances in the view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailElementOrderUtils Class


BringForward Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..BringForward Method
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instance one step closer to the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void BringForward(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub BringForward ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void BringForward(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element detailElementId is not a detail element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class


BringToFront Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..BringToFront Method
DetailElementOrderUtils Class See Also Send Feedback
Places the given detail instance in the front of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void BringToFront(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub BringToFront ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void BringToFront(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element detailElementId is not a detail element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class


Dispose Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..Dispose Method
DetailElementOrderUtils Class See Also Send Feedback
Releases all resources used by the DetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DetailElementOrderUtils Class


IsDetailElement Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..IsDetailElement Method
DetailElementOrderUtils Class See Also Send Feedback
Indicates if the given element is a detail element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsDetailElement(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Function IsDetailElement ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsDetailElement(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Return Value

True if it is a detail element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class


SendBackward Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..SendBackward Method
DetailElementOrderUtils Class See Also Send Feedback
Moves the given detail instance one step closer to the back of all other detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SendBackward(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub SendBackward ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void SendBackward(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element detailElementId is not a detail element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class


SendToBack Method

[image]

Revit 2013 API
DetailElementOrderUtils..::..SendToBack Method
DetailElementOrderUtils Class See Also Send Feedback
Places the given detail instance behind all detail instances in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SendToBack(
    Document pDocument,
    View pDBView,
    ElementId detailElementId
)
Visual Basic
Public Shared Sub SendToBack ( _
    pDocument As Document, _
    pDBView As View, _
    detailElementId As ElementId _
)
Visual C++
public:
static void SendToBack(
    Document^ pDocument,
    View^ pDBView,
    ElementId^ detailElementId
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document
The document.
pDBView
Type: Autodesk.Revit.DB..::..View
The view.
detailElementId
Type: Autodesk.Revit.DB..::..ElementId
The detail elementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element detailElementId is not a detail element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DetailElementOrderUtils Class


DetailEllipse Class

[image]

Revit 2013 API
DetailEllipse Class
Members See Also Send Feedback
Represents a DetailEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailEllipse : DetailCurve
Visual Basic
Public Class DetailEllipse _
    Inherits DetailCurve
Visual C++
public ref class DetailEllipse : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailEllipse

See Also

DetailEllipse Members


DetailEllipse Members

[image] [image]

Revit 2013 API
DetailEllipse Members
DetailEllipse Class Methods Properties See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailEllipse Class


DetailEllipse Methods

[image] [image]

Revit 2013 API
DetailEllipse Methods
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailEllipse Class


DetailEllipse Properties

[image] [image]

Revit 2013 API
DetailEllipse Properties
DetailEllipse Class See Also Send Feedback

The DetailEllipse type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailEllipse Class


Parameter Property

[image] [image]

Revit 2013 API
DetailEllipse..::..Parameter Property
DetailEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailEllipse Class
DetailEllipse Members


DetailLine Class

[image]

Revit 2013 API
DetailLine Class
Members See Also Send Feedback
Represents a DetailLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailLine : DetailCurve
Visual Basic
Public Class DetailLine _
    Inherits DetailCurve
Visual C++
public ref class DetailLine : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailLine

See Also

DetailLine Members


DetailLine Members

[image] [image]

Revit 2013 API
DetailLine Members
DetailLine Class Methods Properties See Also Send Feedback

The DetailLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailLine Class


DetailLine Methods

[image] [image]

Revit 2013 API
DetailLine Methods
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailLine Class


DetailLine Properties

[image] [image]

Revit 2013 API
DetailLine Properties
DetailLine Class See Also Send Feedback

The DetailLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailLine Class


Parameter Property

[image] [image]

Revit 2013 API
DetailLine..::..Parameter Property
DetailLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailLine Class
DetailLine Members


DetailNurbSpline Class

[image]

Revit 2013 API
DetailNurbSpline Class
Members See Also Send Feedback
Represents a DetailNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DetailNurbSpline : DetailCurve
Visual Basic
Public Class DetailNurbSpline _
    Inherits DetailCurve
Visual C++
public ref class DetailNurbSpline : public DetailCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from DetailCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DetailCurve
Autodesk.Revit.DB..::..DetailNurbSpline

See Also

DetailNurbSpline Members


DetailNurbSpline Members

[image] [image]

Revit 2013 API
DetailNurbSpline Members
DetailNurbSpline Class Methods Properties See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailNurbSpline Class


DetailNurbSpline Methods

[image] [image]

Revit 2013 API
DetailNurbSpline Methods
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DetailNurbSpline Class


DetailNurbSpline Properties

[image] [image]

Revit 2013 API
DetailNurbSpline Properties
DetailNurbSpline Class See Also Send Feedback

The DetailNurbSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DetailNurbSpline Class


Parameter Property

[image] [image]

Revit 2013 API
DetailNurbSpline..::..Parameter Property
DetailNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DetailNurbSpline Class
DetailNurbSpline Members


DGNExportOptions Class

[image]

Revit 2013 API
DGNExportOptions Class
Members See Also Send Feedback
The export options used by exporting DGN format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DGNExportOptions : BaseExportOptions
Visual Basic
Public Class DGNExportOptions _
    Inherits BaseExportOptions
Visual C++
public ref class DGNExportOptions : public BaseExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..DGNExportOptions

See Also

DGNExportOptions Members


DGNExportOptions Members

[image] [image]

Revit 2013 API
DGNExportOptions Members
DGNExportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | MasterUnits | The master units. Default value of masterUnits is true.
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.

See Also

DGNExportOptions Class


DGNExportOptions Constructor

[image] [image]

Revit 2013 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DGNExportOptions()()()() | Constructs a new instance of DGNExportOptions with default values of all properties.
Public method | DGNExportOptions(DGNExportOptions) | Constructs a new instance of DGNExportOptions as a copy of the export options.

See Also

DGNExportOptions Class
DGNExportOptions Members


DGNExportOptions Constructor

[image]

Revit 2013 API
DGNExportOptions Constructor
DGNExportOptions Class See Also Send Feedback
Constructs a new instance of DGNExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DGNExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DGNExportOptions()

See Also

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions Constructor (DGNExportOptions)

[image]

Revit 2013 API
DGNExportOptions Constructor (DGNExportOptions)
DGNExportOptions Class See Also Send Feedback
Constructs a new instance of DGNExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DGNExportOptions(
    DGNExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DGNExportOptions _
)
Visual C++
public:
DGNExportOptions(
    DGNExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DGNExportOptions Class
DGNExportOptions Overload


DGNExportOptions Methods

[image] [image]

Revit 2013 API
DGNExportOptions Methods
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DGNExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DGNExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2013 API
DGNExportOptions..::..GetPredefinedOptions Method
DGNExportOptions Class See Also Send Feedback
Returns an instance DGNExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static DGNExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DGNExportOptions
Visual C++
public:
static DGNExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DGNExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DGNExportOptions Class


DGNExportOptions Properties

[image] [image]

Revit 2013 API
DGNExportOptions Properties
DGNExportOptions Class See Also Send Feedback

The DGNExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | FileVersion | The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | MasterUnits | The master units. Default value of masterUnits is true.
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SeedName | The name of the DGN seed. Default value of seedName is empty.

See Also

DGNExportOptions Class


FileVersion Property

[image]

Revit 2013 API
DGNExportOptions..::..FileVersion Property
DGNExportOptions Class See Also Send Feedback
The DGN file version. Default value of fileVersion is DGNFileFormat.Default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DGNFileFormat FileVersion { get; set; }
Visual Basic
Public Property FileVersion As DGNFileFormat
    Get
    Set
Visual C++
public:
property DGNFileFormat FileVersion {
    DGNFileFormat get ();
    void set (DGNFileFormat value);
}

See Also

DGNExportOptions Class


MasterUnits Property

[image]

Revit 2013 API
DGNExportOptions..::..MasterUnits Property
DGNExportOptions Class See Also Send Feedback
The master units. Default value of masterUnits is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool MasterUnits { get; set; }
Visual Basic
Public Property MasterUnits As Boolean
    Get
    Set
Visual C++
public:
property bool MasterUnits {
    bool get ();
    void set (bool value);
}

See Also

DGNExportOptions Class


MergedViews Property

[image]

Revit 2013 API
DGNExportOptions..::..MergedViews Property
DGNExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DGNExportOptions Class


SeedName Property

[image]

Revit 2013 API
DGNExportOptions..::..SeedName Property
DGNExportOptions Class See Also Send Feedback
The name of the DGN seed. Default value of seedName is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string SeedName { get; set; }
Visual Basic
Public Property SeedName As String
    Get
    Set
Visual C++
public:
property String^ SeedName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

DGNExportOptions Class


DGNFileFormat Enumeration

[image]

Revit 2013 API
DGNFileFormat Enumeration
See Also Send Feedback
An enumerated type listing available Microstation versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum DGNFileFormat
Visual Basic
Public Enumeration DGNFileFormat
Visual C++
public enum class DGNFileFormat

Members

Member name | Description
DGNVersion7 | Micorstation V7 file format.
Default | The Autodesk Revit application's default file format.
DGNVersion8 | Micorstation V8 file format.

See Also


DGNImportOptions Class

[image]

Revit 2013 API
DGNImportOptions Class
Members See Also Send Feedback
The import options used to import DGN format files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DGNImportOptions : BaseImportOptions
Visual Basic
Public Class DGNImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class DGNImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..DGNImportOptions

See Also

DGNImportOptions Members


DGNImportOptions Members

[image] [image]

Revit 2013 API
DGNImportOptions Members
DGNImportOptions Class Constructors Methods Properties See Also Send Feedback

The DGNImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DGNImportOptions()()()() | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetRefPoint | (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetRefPoint | (Inherited from BaseImportOptions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DGNImportOptions Class


DGNImportOptions Constructor

[image] [image]

Revit 2013 API
DGNImportOptions Constructor
DGNImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DGNImportOptions()()()() | Constructs a new instance of DGNImportOptions with default values of all properties.
Public method | DGNImportOptions(DGNImportOptions) | Constructs a new instance of DGNImportOptions as a copy of the import options.

See Also

DGNImportOptions Class
DGNImportOptions Members


DGNImportOptions Constructor

[image]

Revit 2013 API
DGNImportOptions Constructor
DGNImportOptions Class See Also Send Feedback
Constructs a new instance of DGNImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DGNImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DGNImportOptions()

See Also

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions Constructor (DGNImportOptions)

[image]

Revit 2013 API
DGNImportOptions Constructor (DGNImportOptions)
DGNImportOptions Class See Also Send Feedback
Constructs a new instance of DGNImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DGNImportOptions(
    DGNImportOptions option
)
Visual Basic
Public Sub New ( _
    option As DGNImportOptions _
)
Visual C++
public:
DGNImportOptions(
    DGNImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DGNImportOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DGNImportOptions Class
DGNImportOptions Overload


DGNImportOptions Methods

[image] [image]

Revit 2013 API
DGNImportOptions Methods
DGNImportOptions Class See Also Send Feedback

The DGNImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetRefPoint | (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetRefPoint | (Inherited from BaseImportOptions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DGNImportOptions Class


DGNImportOptions Properties

[image] [image]

Revit 2013 API
DGNImportOptions Properties
DGNImportOptions Class See Also Send Feedback

The DGNImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | DGNModelViewName | The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit
Public property | IgnoreUnsupportedElementWarning | If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DGNImportOptions Class


DGNModelViewName Property

[image]

Revit 2013 API
DGNImportOptions..::..DGNModelViewName Property
DGNImportOptions Class See Also Send Feedback
The model view name to be imported. Need user give a model view name to specify which model view need to be imported into Revit

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string DGNModelViewName { get; set; }
Visual Basic
Public Property DGNModelViewName As String
    Get
    Set
Visual C++
public:
property String^ DGNModelViewName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

DGNImportOptions Class


IgnoreUnsupportedElementWarning Property

[image]

Revit 2013 API
DGNImportOptions..::..IgnoreUnsupportedElementWarning Property
DGNImportOptions Class See Also Send Feedback
If true, ignore warning messages about unsupported elements in the DGN file. If false, the import process is aborted if imported dgn files have unsupported elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IgnoreUnsupportedElementWarning { get; set; }
Visual Basic
Public Property IgnoreUnsupportedElementWarning As Boolean
    Get
    Set
Visual C++
public:
property bool IgnoreUnsupportedElementWarning {
    bool get ();
    void set (bool value);
}

See Also

DGNImportOptions Class


DigitGroupingAmount Enumeration

[image]

Revit 2013 API
DigitGroupingAmount Enumeration
See Also Send Feedback
An enumerated type listing the types of the Digit Grouping Amount that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DigitGroupingAmount
Visual Basic
Public Enumeration DigitGroupingAmount
Visual C++
public enum class DigitGroupingAmount

Members

Member name | Description
DGA_TWO |
DGA_THREE |

See Also


DigitGroupingSymbolType Enumeration

[image]

Revit 2013 API
DigitGroupingSymbolType Enumeration
See Also Send Feedback
An enumerated type listing the types of the Digit Grouping Symbol types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DigitGroupingSymbolType
Visual Basic
Public Enumeration DigitGroupingSymbolType
Visual C++
public enum class DigitGroupingSymbolType

Members

Member name | Description
DGST_DOT |
DGST_COMMA |
DGST_SPACE |
DGST_TICK |

See Also


Dimension Class

[image]

Revit 2013 API
Dimension Class
Members Example See Also Send Feedback
An object that represents a dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Dimension : Element
Visual Basic
Public Class Dimension _
    Inherits Element
Visual C++
public ref class Dimension : public Element

Examples

CopyC#
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
             + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
             + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.ViewName;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if ((int)BuiltInCategory.OST_Dimensions == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if ((int)BuiltInCategory.OST_Constraints == dimension.Category.Id.IntegerValue)
    {
        message += "\nDimension is a constraint element.";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Dimension(ByVal dimension As Autodesk.Revit.DB.Dimension)
    Dim message As String = "Dimension : "
    ' Get Dimension name
    message += vbLf & "Dimension name is : " + dimension.Name

    ' Get Dimension Curve
    Dim curve As Autodesk.Revit.DB.Curve = dimension.Curve
    If curve IsNot Nothing AndAlso curve.IsBound Then
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    End If

    ' Get Dimension type name
    message += vbLf & "Dimension type name is : " + dimension.DimensionType.Name

    ' Get Dimension view name
    message += vbLf & "Dimension view name is : " + dimension.View.ViewName

    ' Get Dimension reference count
    message += vbLf & "Dimension references count is " + dimension.References.Size

    If DirectCast(BuiltInCategory.OST_Dimensions, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a permanent dimension."
    ElseIf DirectCast(BuiltInCategory.OST_Constraints, Integer) = dimension.Category.Id.IntegerValue Then
        message += vbLf & "Dimension is a constraint element."
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..SpotDimension

See Also

Dimension Members


Dimension Members

[image] [image]

Revit 2013 API
Dimension Members
Dimension Class Methods Properties See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked.
Public property | Label | The family parameter label of the dimension.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Dimension Class


Dimension Methods

[image] [image]

Revit 2013 API
Dimension Methods
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Dimension Class


Dimension Properties

[image] [image]

Revit 2013 API
Dimension Properties
Dimension Class See Also Send Feedback

The Dimension type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension.
Public property | DimensionType | The dimension style of this dimension.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked.
Public property | Label | The family parameter label of the dimension.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension.
Public property | NumberOfSegments | The number of segments for the dimension.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value.
Public property | References | Returns an array of geometric references to which the dimension is attached.
Public property | Segments | The segments in the dimension.
Public property | Suffix | The text shown after the segment's value.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The dimension value as a user visible string.
Public property | View | Supplies the view that contains the dimension if the dimension is view specific.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Dimension Class


Above Property

[image]

Revit 2013 API
Dimension..::..Above Property
Dimension Class See Also Send Feedback
The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Above { get; set; }
Visual Basic
Public Property Above As String
    Get
    Set
Visual C++
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


AreSegmentsEqual Property

[image]

Revit 2013 API
Dimension..::..AreSegmentsEqual Property
Dimension Class See Also Send Feedback
Indicates if all segments are forced to be equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AreSegmentsEqual { get; set; }
Visual Basic
Public Property AreSegmentsEqual As Boolean
    Get
    Set
Visual C++
public:
property bool AreSegmentsEqual {
    bool get ();
    void set (bool value);
}

Remarks

This property is usable only for linear dimensions with more than one segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the dimension is non-linear or has only one segment.

See Also

Dimension Class


Below Property

[image]

Revit 2013 API
Dimension..::..Below Property
Dimension Class See Also Send Feedback
The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Below { get; set; }
Visual Basic
Public Property Below As String
    Get
    Set
Visual C++
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


Curve Property

[image]

Revit 2013 API
Dimension..::..Curve Property
Dimension Class See Also Send Feedback
A curve that represents the dimension line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

Dimension Class


DimensionShape Property

[image]

Revit 2013 API
Dimension..::..DimensionShape Property
Dimension Class See Also Send Feedback
The shape of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionShape DimensionShape { get; }
Visual Basic
Public ReadOnly Property DimensionShape As DimensionShape
    Get
Visual C++
public:
property DimensionShape DimensionShape {
    DimensionShape get ();
}

See Also

Dimension Class


DimensionType Property

[image]

Revit 2013 API
Dimension..::..DimensionType Property
Dimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionType DimensionType { get; set; }
Visual Basic
Public Property DimensionType As DimensionType
    Get
    Set
Visual C++
public:
property DimensionType^ DimensionType {
    DimensionType^ get ();
    void set (DimensionType^ value);
}

See Also

Dimension Class


IsLocked Property

[image]

Revit 2013 API
Dimension..::..IsLocked Property
Dimension Class See Also Send Feedback
Indicates if this dimension is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the dimension has been labeled, or if the dimension shape is radial or spot, or if the dimension is linear with more than one segment.

See Also

Dimension Class


Label Property

[image]

Revit 2013 API
Dimension..::..Label Property
Dimension Class See Also Send Feedback
The family parameter label of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic
Public Property Label As FamilyParameter
    Get
    Set
Visual C++
public:
property FamilyParameter^ Label {
    FamilyParameter^ get ();
    void set (FamilyParameter^ value);
}

Remarks

A dimension only can be labeled in a family document. Multi-segmented linear dimensions cannot be labeled. To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when dimension can not be labeled.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL.

See Also

Dimension Class


Name Property

[image]

Revit 2013 API
Dimension..::..Name Property
Dimension Class See Also Send Feedback
Retrieves or changes the name associated with the Dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The property inherited from element is hidden, a System.InvalidOperationException is thrown.

See Also

Dimension Class


NumberOfSegments Property

[image]

Revit 2013 API
Dimension..::..NumberOfSegments Property
Dimension Class See Also Send Feedback
The number of segments for the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic
Public ReadOnly Property NumberOfSegments As Integer
    Get
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

Dimension Class


Parameter Property

[image] [image]

Revit 2013 API
Dimension..::..Parameter Property
Dimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Dimension Class
Dimension Members


Prefix Property

[image]

Revit 2013 API
Dimension..::..Prefix Property
Dimension Class See Also Send Feedback
The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


References Property

[image]

Revit 2013 API
Dimension..::..References Property
Dimension Class See Also Send Feedback
Returns an array of geometric references to which the dimension is attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray References { get; }
Visual Basic
Public ReadOnly Property References As ReferenceArray
    Get
Visual C++
public:
property ReferenceArray^ References {
    ReferenceArray^ get ();
}

See Also

Dimension Class


Segments Property

[image]

Revit 2013 API
Dimension..::..Segments Property
Dimension Class See Also Send Feedback
The segments in the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionSegmentArray Segments { get; }
Visual Basic
Public ReadOnly Property Segments As DimensionSegmentArray
    Get
Visual C++
public:
property DimensionSegmentArray^ Segments {
    DimensionSegmentArray^ get ();
}

Remarks

Returns a read only array of segments in the dimension. The references of the dimension can be mapped to segments in order. The first segment here wrapped by first and second references; the nth segment is wrapped by nth and n+1st references.

See Also

Dimension Class


Suffix Property

[image]

Revit 2013 API
Dimension..::..Suffix Property
Dimension Class See Also Send Feedback
The text shown after the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


Value Property

[image]

Revit 2013 API
Dimension..::..Value Property
Dimension Class See Also Send Feedback
The value of the dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic
Public ReadOnly Property Value As Nullable(Of Double)
    Get
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

Remarks

This nullable property will not have a value for spot dimensions or for linear dimensions with more than one segment.

See Also

Dimension Class


ValueOverride Property

[image]

Revit 2013 API
Dimension..::..ValueOverride Property
Dimension Class See Also Send Feedback
The text that replaces the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ValueOverride { get; set; }
Visual Basic
Public Property ValueOverride As String
    Get
    Set
Visual C++
public:
property String^ ValueOverride {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is for use with single-segmment dimensions only. For multi-segment dimensions use the corresponding properties of the DimensionSegment class.

See Also

Dimension Class


ValueString Property

[image]

Revit 2013 API
Dimension..::..ValueString Property
Dimension Class See Also Send Feedback
The dimension value as a user visible string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic
Public ReadOnly Property ValueString As String
    Get
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

Remarks

This property always return nullNothingnullptra null reference (Nothing in Visual Basic) if this is a spot dimension, or it is a linear dimension with more than one segments.

See Also

Dimension Class


View Property

[image]

Revit 2013 API
Dimension..::..View Property
Dimension Class See Also Send Feedback
Supplies the view that contains the dimension if the dimension is view specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

Dimension Class


DimensionSegment Class

[image]

Revit 2013 API
DimensionSegment Class
Members See Also Send Feedback
A segment of a dimension within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DimensionSegment : APIObject
Visual Basic
Public Class DimensionSegment _
    Inherits APIObject
Visual C++
public ref class DimensionSegment : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionSegment

See Also

DimensionSegment Members


DimensionSegment Members

[image] [image]

Revit 2013 API
DimensionSegment Members
DimensionSegment Class Methods Properties See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


DimensionSegment Methods

[image] [image]

Revit 2013 API
DimensionSegment Methods
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegment Class


DimensionSegment Properties

[image] [image]

Revit 2013 API
DimensionSegment Properties
DimensionSegment Class See Also Send Feedback

The DimensionSegment type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value.
Public property | Below | The text shown below the segment's value.
Public property | IsLocked | Indicates if this segment is locked.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Origin | The segment origin.
Public property | Prefix | The text shown before the segment's value.
Public property | Suffix | The text shown after the segment's value.
Public property | Value | The length of the segment.
Public property | ValueOverride | The text that replaces the segment's value.
Public property | ValueString | The displayed value shown for the dimension segment.

See Also

DimensionSegment Class


Above Property

[image]

Revit 2013 API
DimensionSegment..::..Above Property
DimensionSegment Class See Also Send Feedback
The text shown above the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Above { get; set; }
Visual Basic
Public Property Above As String
    Get
    Set
Visual C++
public:
property String^ Above {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


Below Property

[image]

Revit 2013 API
DimensionSegment..::..Below Property
DimensionSegment Class See Also Send Feedback
The text shown below the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Below { get; set; }
Visual Basic
Public Property Below As String
    Get
    Set
Visual C++
public:
property String^ Below {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


IsLocked Property

[image]

Revit 2013 API
DimensionSegment..::..IsLocked Property
DimensionSegment Class See Also Send Feedback
Indicates if this segment is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsLocked { get; set; }
Visual Basic
Public Property IsLocked As Boolean
    Get
    Set
Visual C++
public:
property bool IsLocked {
    bool get ();
    void set (bool value);
}

Remarks

This property always returns false if the dimension is a radial or spot dimension. This property cannot be set if the segment has been labeled, or the dimension shape is a radial or spot dimension.

See Also

DimensionSegment Class


Origin Property

[image]

Revit 2013 API
DimensionSegment..::..Origin Property
DimensionSegment Class See Also Send Feedback
The segment origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

The origin will be the midpoint of the line that makes up the segment.

See Also

DimensionSegment Class


Prefix Property

[image]

Revit 2013 API
DimensionSegment..::..Prefix Property
DimensionSegment Class See Also Send Feedback
The text shown before the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


Suffix Property

[image]

Revit 2013 API
DimensionSegment..::..Suffix Property
DimensionSegment Class See Also Send Feedback
The text shown after the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


Value Property

[image]

Revit 2013 API
DimensionSegment..::..Value Property
DimensionSegment Class See Also Send Feedback
The length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Nullable<double> Value { get; }
Visual Basic
Public ReadOnly Property Value As Nullable(Of Double)
    Get
Visual C++
public:
property Nullable<double> Value {
    Nullable<double> get ();
}

See Also

DimensionSegment Class


ValueOverride Property

[image]

Revit 2013 API
DimensionSegment..::..ValueOverride Property
DimensionSegment Class See Also Send Feedback
The text that replaces the segment's value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ValueOverride { get; set; }
Visual Basic
Public Property ValueOverride As String
    Get
    Set
Visual C++
public:
property String^ ValueOverride {
    String^ get ();
    void set (String^ value);
}

See Also

DimensionSegment Class


ValueString Property

[image]

Revit 2013 API
DimensionSegment..::..ValueString Property
DimensionSegment Class See Also Send Feedback
The displayed value shown for the dimension segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ValueString { get; }
Visual Basic
Public ReadOnly Property ValueString As String
    Get
Visual C++
public:
property String^ ValueString {
    String^ get ();
}

See Also

DimensionSegment Class


DimensionSegmentArray Class

[image]

Revit 2013 API
DimensionSegmentArray Class
Members See Also Send Feedback
An array that can contain any number of DimensionSegment objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DimensionSegmentArray : APIObject,
    IEnumerable
Visual Basic
Public Class DimensionSegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionSegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionSegmentArray

See Also

DimensionSegmentArray Members


DimensionSegmentArray Members

[image] [image]

Revit 2013 API
DimensionSegmentArray Members
DimensionSegmentArray Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionSegmentArray | Initializes a new instance of the DimensionSegmentArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class


DimensionSegmentArray Constructor

[image]

Revit 2013 API
DimensionSegmentArray Constructor
DimensionSegmentArray Class See Also Send Feedback
Initializes a new instance of the DimensionSegmentArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionSegmentArray()
Visual Basic
Public Sub New
Visual C++
public:
DimensionSegmentArray()

See Also

DimensionSegmentArray Class


DimensionSegmentArray Methods

[image] [image]

Revit 2013 API
DimensionSegmentArray Methods
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArray Class


Append Method

[image]

Revit 2013 API
DimensionSegmentArray..::..Append Method
DimensionSegmentArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    DimensionSegment item
)
Visual Basic
Public Overridable Sub Append ( _
    item As DimensionSegment _
)
Visual C++
public:
virtual void Append(
    DimensionSegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionSegment
The item to be added.

See Also

DimensionSegmentArray Class


Clear Method

[image]

Revit 2013 API
DimensionSegmentArray..::..Clear Method
DimensionSegmentArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionSegmentArray Class


ForwardIterator Method

[image]

Revit 2013 API
DimensionSegmentArray..::..ForwardIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DimensionSegmentArray Class


GetEnumerator Method

[image]

Revit 2013 API
DimensionSegmentArray..::..GetEnumerator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DimensionSegmentArray Class


Insert Method

[image]

Revit 2013 API
DimensionSegmentArray..::..Insert Method
DimensionSegmentArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    DimensionSegment item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As DimensionSegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    DimensionSegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionSegment
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

DimensionSegmentArray Class


ReverseIterator Method

[image]

Revit 2013 API
DimensionSegmentArray..::..ReverseIterator Method
DimensionSegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DimensionSegmentArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DimensionSegmentArrayIterator
Visual C++
public:
virtual DimensionSegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DimensionSegmentArray Class


DimensionSegmentArray Properties

[image] [image]

Revit 2013 API
DimensionSegmentArray Properties
DimensionSegmentArray Class See Also Send Feedback

The DimensionSegmentArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

DimensionSegmentArray Class


IsEmpty Property

[image]

Revit 2013 API
DimensionSegmentArray..::..IsEmpty Property
DimensionSegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DimensionSegmentArray Class


Item Property

[image]

Revit 2013 API
DimensionSegmentArray..::..Item Property
DimensionSegmentArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DimensionSegment this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As DimensionSegment
    Get
    Set
Visual C++
public:
virtual property DimensionSegment^ Item[int index] {
    DimensionSegment^ get (int index);
    void set (int index, DimensionSegment^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

DimensionSegmentArray Class


Size Property

[image]

Revit 2013 API
DimensionSegmentArray..::..Size Property
DimensionSegmentArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionSegmentArray Class


DimensionSegmentArrayIterator Class

[image]

Revit 2013 API
DimensionSegmentArrayIterator Class
Members See Also Send Feedback
An iterator to an array of DimensionSegment objects..

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DimensionSegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DimensionSegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionSegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionSegmentArrayIterator

See Also

DimensionSegmentArrayIterator Members


DimensionSegmentArrayIterator Members

[image] [image]

Revit 2013 API
DimensionSegmentArrayIterator Members
DimensionSegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionSegmentArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Constructor

[image]

Revit 2013 API
DimensionSegmentArrayIterator Constructor
DimensionSegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionSegmentArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
DimensionSegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Methods

[image] [image]

Revit 2013 API
DimensionSegmentArrayIterator Methods
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionSegmentArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
DimensionSegmentArrayIterator..::..MoveNext Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


Reset Method

[image]

Revit 2013 API
DimensionSegmentArrayIterator..::..Reset Method
DimensionSegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionSegmentArrayIterator Class


DimensionSegmentArrayIterator Properties

[image] [image]

Revit 2013 API
DimensionSegmentArrayIterator Properties
DimensionSegmentArrayIterator Class See Also Send Feedback

The DimensionSegmentArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionSegmentArrayIterator Class


Current Property

[image]

Revit 2013 API
DimensionSegmentArrayIterator..::..Current Property
DimensionSegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionSegmentArrayIterator Class


DimensionShape Enumeration

[image]

Revit 2013 API
DimensionShape Enumeration
See Also Send Feedback
An enumerated type to list dimension type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DimensionShape
Visual Basic
Public Enumeration DimensionShape
Visual C++
public enum class DimensionShape

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
Spot | Spot dimension.
Diameter | Diameter dimension.
Unknown | Unknown type dimension.

See Also


DimensionStyleType Enumeration

[image]

Revit 2013 API
DimensionStyleType Enumeration
See Also Send Feedback
An enumerated type containing possible style types of dimensions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DimensionStyleType
Visual Basic
Public Enumeration DimensionStyleType
Visual C++
public enum class DimensionStyleType

Members

Member name | Description
Linear | Linear dimension.
Angular | Angular dimension.
Radial | Radial dimension.
ArcLength | ArcLength dimension.
SpotElevation | SpotElevation
SpotCoordinate | SpotCoordinate
LinearFixed | LinearFixed dimension, which is linear dimension whose direction is parallel to X or Y.
SpotSlope | SpotSlope
Diameter | Diameter dimension.

See Also


DimensionType Class

[image]

Revit 2013 API
DimensionType Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DimensionType : ElementType
Visual Basic
Public Class DimensionType _
    Inherits ElementType
Visual C++
public ref class DimensionType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB..::..SpotDimensionType

See Also

DimensionType Members


DimensionType Members

[image] [image]

Revit 2013 API
DimensionType Members
DimensionType Class Methods Properties See Also Send Feedback

The DimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StyleType | The dimension style type of this DimensionType.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DimensionType Class


DimensionType Methods

[image] [image]

Revit 2013 API
DimensionType Methods
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionType Class


DimensionType Properties

[image] [image]

Revit 2013 API
DimensionType Properties
DimensionType Class See Also Send Feedback

The DimensionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StyleType | The dimension style type of this DimensionType.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DimensionType Class


Parameter Property

[image] [image]

Revit 2013 API
DimensionType..::..Parameter Property
DimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DimensionType Class
DimensionType Members


StyleType Property

[image]

Revit 2013 API
DimensionType..::..StyleType Property
DimensionType Class See Also Send Feedback
The dimension style type of this DimensionType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DimensionStyleType StyleType { get; }
Visual Basic
Public ReadOnly Property StyleType As DimensionStyleType
    Get
Visual C++
public:
property DimensionStyleType StyleType {
    DimensionStyleType get ();
}

See Also

DimensionType Class


DimensionTypeSet Class

[image]

Revit 2013 API
DimensionTypeSet Class
Members See Also Send Feedback
A set that contains dimension types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DimensionTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class DimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionTypeSet

See Also

DimensionTypeSet Members


DimensionTypeSet Members

[image] [image]

Revit 2013 API
DimensionTypeSet Members
DimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionTypeSet | Initializes a new instance of the DimensionTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every dimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a dimension type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified dimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified dimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class


DimensionTypeSet Constructor

[image]

Revit 2013 API
DimensionTypeSet Constructor
DimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the DimensionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
DimensionTypeSet()

See Also

DimensionTypeSet Class


DimensionTypeSet Methods

[image] [image]

Revit 2013 API
DimensionTypeSet Methods
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every dimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a dimension type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified dimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified dimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSet Class


Clear Method

[image]

Revit 2013 API
DimensionTypeSet..::..Clear Method
DimensionTypeSet Class See Also Send Feedback
Removes every dimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DimensionTypeSet Class


Contains Method

[image]

Revit 2013 API
DimensionTypeSet..::..Contains Method
DimensionTypeSet Class See Also Send Feedback
Tests for the existence of a dimension type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    DimensionType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionType
The dimension type to be searched for.

Return Value

The Contains method returns True if the dimension type is within the set, otherwise False.

See Also

DimensionTypeSet Class


Erase Method

[image]

Revit 2013 API
DimensionTypeSet..::..Erase Method
DimensionTypeSet Class See Also Send Feedback
Removes a specified dimension type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    DimensionType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As DimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionType
The dimension type to be erased.

Return Value

The number of dimension types that were erased from the set.

See Also

DimensionTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
DimensionTypeSet..::..ForwardIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DimensionTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
DimensionTypeSet..::..GetEnumerator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DimensionTypeSet Class


Insert Method

[image]

Revit 2013 API
DimensionTypeSet..::..Insert Method
DimensionTypeSet Class See Also Send Feedback
Insert the specified dimension type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    DimensionType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As DimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..DimensionType
The dimension type to be inserted into the set.

Return Value

Returns whether the dimension type was inserted into the set.

See Also

DimensionTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
DimensionTypeSet..::..ReverseIterator Method
DimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DimensionTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DimensionTypeSetIterator
Visual C++
public:
virtual DimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DimensionTypeSet Class


DimensionTypeSet Properties

[image] [image]

Revit 2013 API
DimensionTypeSet Properties
DimensionTypeSet Class See Also Send Feedback

The DimensionTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of dimension types that are in the set.

See Also

DimensionTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
DimensionTypeSet..::..IsEmpty Property
DimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DimensionTypeSet Class


Size Property

[image]

Revit 2013 API
DimensionTypeSet..::..Size Property
DimensionTypeSet Class See Also Send Feedback
Returns the number of dimension types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DimensionTypeSet Class


DimensionTypeSetIterator Class

[image]

Revit 2013 API
DimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a dimension type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DimensionTypeSetIterator

See Also

DimensionTypeSetIterator Members


DimensionTypeSetIterator Members

[image] [image]

Revit 2013 API
DimensionTypeSetIterator Members
DimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DimensionTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Constructor

[image]

Revit 2013 API
DimensionTypeSetIterator Constructor
DimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
DimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Methods

[image] [image]

Revit 2013 API
DimensionTypeSetIterator Methods
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DimensionTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
DimensionTypeSetIterator..::..MoveNext Method
DimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
DimensionTypeSetIterator..::..Reset Method
DimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DimensionTypeSetIterator Class


DimensionTypeSetIterator Properties

[image] [image]

Revit 2013 API
DimensionTypeSetIterator Properties
DimensionTypeSetIterator Class See Also Send Feedback

The DimensionTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DimensionTypeSetIterator Class


Current Property

[image]

Revit 2013 API
DimensionTypeSetIterator..::..Current Property
DimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DimensionTypeSetIterator Class


DisplayStyle Enumeration

[image]

Revit 2013 API
DisplayStyle Enumeration
See Also Send Feedback
Display type of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum DisplayStyle
Visual Basic
Public Enumeration DisplayStyle
Visual C++
public enum class DisplayStyle

Members

Member name | Description
Undefined | View does not use Render Type
Wireframe | Wireframe
HLR | Hidden Line Removal
Shading | Shading
ShadingWithEdges | Shading With Edges
Rendering | Rendering
Realistic | Realistic
FlatColors | Flat Colors
RealisticWithEdges | Realistic With Edges
Raytrace | Raytrace. Because setting a view's display style to raytrace enters a special restricted mode with limited capabilities, it is not permitted to directly assign the display style to this value.

See Also


DisplayUnit Enumeration

[image]

Revit 2013 API
DisplayUnit Enumeration
See Also Send Feedback
Describes the type of Revit display unit, metric or imperial.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DisplayUnit
Visual Basic
Public Enumeration DisplayUnit
Visual C++
public enum class DisplayUnit

Members

Member name | Description
METRIC |
IMPERIAL |

See Also


DisplayUnitType Enumeration

[image]

Revit 2013 API
DisplayUnitType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DisplayUnitType
Visual Basic
Public Enumeration DisplayUnitType
Visual C++
public enum class DisplayUnitType

Members

Member name | Description
DUT_UNDEFINED |
DUT_CUSTOM |
DUT_METERS |
DUT_CENTIMETERS |
DUT_MILLIMETERS |
DUT_DECIMAL_FEET |
DUT_FEET_FRACTIONAL_INCHES |
DUT_FRACTIONAL_INCHES |
DUT_DECIMAL_INCHES |
DUT_ACRES |
DUT_HECTARES |
DUT_METERS_CENTIMETERS |
DUT_CUBIC_YARDS |
DUT_SQUARE_FEET |
DUT_SQUARE_METERS |
DUT_CUBIC_FEET |
DUT_CUBIC_METERS |
DUT_DECIMAL_DEGREES |
DUT_DEGREES_AND_MINUTES |
DUT_GENERAL |
DUT_FIXED |
DUT_PERCENTAGE |
DUT_SQUARE_INCHES |
DUT_SQUARE_CENTIMETERS |
DUT_SQUARE_MILLIMETERS |
DUT_CUBIC_INCHES |
DUT_CUBIC_CENTIMETERS |
DUT_CUBIC_MILLIMETERS |
DUT_LITERS | liter (L)
DUT_GALLONS_US | gallon (U.S.) (gal)
DUT_KILOGRAMS_PER_CUBIC_METER | kilogram per cubic meter (kg/m³)
DUT_POUNDS_MASS_PER_CUBIC_FOOT | pound per cubic foot (lb/ft³)
DUT_POUNDS_MASS_PER_CUBIC_INCH | pound per cubic inch (lb/in³)
DUT_BRITISH_THERMAL_UNITS | British thermal unit[IT] (Btu[IT])
DUT_CALORIES | calorie[IT] (cal[IT])
DUT_KILOCALORIES | kilocalorie[IT] (kcal[IT])
DUT_JOULES | joule (J)
DUT_KILOWATT_HOURS | kilowatt hour (kW · h)
DUT_THERMS | therm (EC)
DUT_INCHES_OF_WATER_PER_100FT | Inches of water per 100 feet
DUT_PASCALS_PER_METER | pascal per meter (N/m)
DUT_WATTS | watt (W)
DUT_KILOWATTS | kilowatt (kW)
DUT_BRITISH_THERMAL_UNITS_PER_SECOND | British thermal unit[IT] per second (Btu[IT]/s)
DUT_BRITISH_THERMAL_UNITS_PER_HOUR | British thermal unit[IT] per hour (Btu[IT]/h)
DUT_CALORIES_PER_SECOND | calorie[IT] per second (cal[IT]/s)
DUT_KILOCALORIES_PER_SECOND | kilocalorie[IT] per second (kcal[IT]/s)
DUT_WATTS_PER_SQUARE_FOOT | watt per square foot (W/ft²)
DUT_WATTS_PER_SQUARE_METER | watt per square meter (W/m²)
DUT_INCHES_OF_WATER | inch of water (60.8°F)
DUT_PASCALS | pascal (Pa)
DUT_KILOPASCALS | kilopascal (kPa)
DUT_MEGAPASCALS | megapascal (MPa)
DUT_POUNDS_FORCE_PER_SQUARE_INCH | pound-force per square inch (psi) (lbf/in2)
DUT_INCHES_OF_MERCURY | inch of mercury conventional (inHg)
DUT_MILLIMETERS_OF_MERCURY | millimeter of mercury conventional (mmHg)
DUT_ATMOSPHERES | atmosphere standard (atm)
DUT_BARS | bar (bar)
DUT_FAHRENHEIT | degree Fahrenheit (ºF)
DUT_CELSIUS | degree Celsius (ºC)
DUT_KELVIN | kelvin (K)
DUT_RANKINE | degree Rankine (ºR)
DUT_FEET_PER_MINUTE | foot per minute (ft/min)
DUT_METERS_PER_SECOND | meter per second (m/s)
DUT_CENTIMETERS_PER_MINUTE | centimeter per minute (cm/min)
DUT_CUBIC_FEET_PER_MINUTE | cubic foot per minute (ft³/min)
DUT_LITERS_PER_SECOND | liter per second (L/s)
DUT_CUBIC_METERS_PER_SECOND | cubic meter per second (m³/s)
DUT_CUBIC_METERS_PER_HOUR | cubic meters per hour (m³/h)
DUT_GALLONS_US_PER_MINUTE | gallon (U.S.) per minute (gpm) (gal/min)
DUT_GALLONS_US_PER_HOUR | gallon (U.S.) per hour (gph) (gal/h)
DUT_AMPERES | ampere (A)
DUT_KILOAMPERES | kiloampere (kA)
DUT_MILLIAMPERES | milliampere (mA)
DUT_VOLTS | volt (V)
DUT_KILOVOLTS | kilovolt (kV)
DUT_MILLIVOLTS | millivolt (mV)
DUT_HERTZ | hertz (Hz)
DUT_CYCLES_PER_SECOND |
DUT_LUX | lux (lx)
DUT_FOOTCANDLES | footcandle
DUT_FOOTLAMBERTS | footlambert
DUT_CANDELAS_PER_SQUARE_METER | candela per square meter (cd/m²)
DUT_CANDELAS | candela (cd)
DUT_CANDLEPOWER | obsolete
DUT_LUMENS | lumen (lm)
DUT_VOLT_AMPERES |
DUT_KILOVOLT_AMPERES |
DUT_HORSEPOWER | horsepower (550 ft · lbf/s)
DUT_NEWTONS |
DUT_DECANEWTONS |
DUT_KILONEWTONS |
DUT_MEGANEWTONS |
DUT_KIPS |
DUT_KILOGRAMS_FORCE |
DUT_TONNES_FORCE |
DUT_POUNDS_FORCE |
DUT_NEWTONS_PER_METER |
DUT_DECANEWTONS_PER_METER |
DUT_KILONEWTONS_PER_METER |
DUT_MEGANEWTONS_PER_METER |
DUT_KIPS_PER_FOOT |
DUT_KILOGRAMS_FORCE_PER_METER |
DUT_TONNES_FORCE_PER_METER |
DUT_POUNDS_FORCE_PER_FOOT |
DUT_NEWTONS_PER_SQUARE_METER |
DUT_DECANEWTONS_PER_SQUARE_METER |
DUT_KILONEWTONS_PER_SQUARE_METER |
DUT_MEGANEWTONS_PER_SQUARE_METER |
DUT_KIPS_PER_SQUARE_FOOT |
DUT_KILOGRAMS_FORCE_PER_SQUARE_METER |
DUT_TONNES_FORCE_PER_SQUARE_METER |
DUT_POUNDS_FORCE_PER_SQUARE_FOOT |
DUT_NEWTON_METERS |
DUT_DECANEWTON_METERS |
DUT_KILONEWTON_METERS |
DUT_MEGANEWTON_METERS |
DUT_KIP_FEET |
DUT_KILOGRAM_FORCE_METERS |
DUT_TONNE_FORCE_METERS |
DUT_POUND_FORCE_FEET |
DUT_METERS_PER_KILONEWTON |
DUT_FEET_PER_KIP |
DUT_SQUARE_METERS_PER_KILONEWTON |
DUT_SQUARE_FEET_PER_KIP |
DUT_CUBIC_METERS_PER_KILONEWTON |
DUT_CUBIC_FEET_PER_KIP |
DUT_INV_KILONEWTONS |
DUT_INV_KIPS |
DUT_FEET_OF_WATER_PER_100FT | foot of water conventional (ftH2O) per 100 ft
DUT_FEET_OF_WATER | foot of water conventional (ftH2O)
DUT_PASCAL_SECONDS | pascal second (Pa · s)
DUT_POUNDS_MASS_PER_FOOT_SECOND | pound per foot second (lb/(ft · s))
DUT_CENTIPOISES | centipoise (cP)
DUT_FEET_PER_SECOND | foot per second (ft/s)
DUT_KIPS_PER_SQUARE_INCH |
DUT_KILONEWTONS_PER_CUBIC_METER | kilnewtons per cubic meter (kN/m³)
DUT_POUNDS_FORCE_PER_CUBIC_FOOT | pound per cubic foot (kip/ft³)
DUT_KIPS_PER_CUBIC_INCH | pound per cubic foot (kip/in³)
DUT_INV_FAHRENHEIT |
DUT_INV_CELSIUS |
DUT_NEWTON_METERS_PER_METER |
DUT_DECANEWTON_METERS_PER_METER |
DUT_KILONEWTON_METERS_PER_METER |
DUT_MEGANEWTON_METERS_PER_METER |
DUT_KIP_FEET_PER_FOOT |
DUT_KILOGRAM_FORCE_METERS_PER_METER |
DUT_TONNE_FORCE_METERS_PER_METER |
DUT_POUND_FORCE_FEET_PER_FOOT |
DUT_POUNDS_MASS_PER_FOOT_HOUR | pound per foot hour (lb/(ft · h))
DUT_KIPS_PER_INCH |
DUT_KIPS_PER_CUBIC_FOOT | pound per cubic foot (kip/ft³)
DUT_KIP_FEET_PER_DEGREE |
DUT_KILONEWTON_METERS_PER_DEGREE |
DUT_KIP_FEET_PER_DEGREE_PER_FOOT |
DUT_KILONEWTON_METERS_PER_DEGREE_PER_METER |
DUT_WATTS_PER_SQUARE_METER_KELVIN | watt per square meter kelvin (W/(m² · K))
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT_FAHRENHEIT | British thermal unit[IT] per hour square foot degree Fahrenheit (Btu[IT]/(h · ft² · ºF)
DUT_CUBIC_FEET_PER_MINUTE_SQUARE_FOOT | cubic foot per minute square foot
DUT_LITERS_PER_SECOND_SQUARE_METER | liter per second square meter
DUT_RATIO_10 |
DUT_RATIO_12 |
DUT_SLOPE_DEGREES |
DUT_RISE_OVER_INCHES |
DUT_RISE_OVER_FOOT |
DUT_RISE_OVER_MMS |
DUT_WATTS_PER_CUBIC_FOOT | watt per cubic foot (W/m³)
DUT_WATTS_PER_CUBIC_METER | watt per cubic meter (W/m³)
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_SQUARE_FOOT | British thermal unit[IT] per hour square foot (Btu[IT]/(h · ft²)
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_CUBIC_FOOT | British thermal unit[IT] per hour cubic foot (Btu[IT]/(h · ft³)
DUT_TON_OF_REFRIGERATION | Ton of refrigeration (12 000 Btu[IT]/h)
DUT_CUBIC_FEET_PER_MINUTE_CUBIC_FOOT | cubic foot per minute cubic foot
DUT_LITERS_PER_SECOND_CUBIC_METER | liter per second cubic meter
DUT_CUBIC_FEET_PER_MINUTE_TON_OF_REFRIGERATION | cubic foot per minute ton of refrigeration
DUT_LITERS_PER_SECOND_KILOWATTS | liter per second kilowatt
DUT_SQUARE_FEET_PER_TON_OF_REFRIGERATION | square foot per ton of refrigeration
DUT_SQUARE_METERS_PER_KILOWATTS | square meter per kilowatt
DUT_CURRENCY |
DUT_LUMENS_PER_WATT |
DUT_SQUARE_FEET_PER_THOUSAND_BRITISH_THERMAL_UNITS_PER_HOUR | square foot per thousand British thermal unit[IT] per hour
DUT_KILONEWTONS_PER_SQUARE_CENTIMETER |
DUT_NEWTONS_PER_SQUARE_MILLIMETER |
DUT_KILONEWTONS_PER_SQUARE_MILLIMETER |
DUT_RISE_OVER_120_INCHES |
DUT_1_RATIO |
DUT_RISE_OVER_10_FEET |
DUT_HOUR_SQUARE_FOOT_FAHRENHEIT_PER_BRITISH_THERMAL_UNIT |
DUT_SQUARE_METER_KELVIN_PER_WATT |
DUT_BRITISH_THERMAL_UNIT_PER_FAHRENHEIT |
DUT_JOULES_PER_KELVIN |
DUT_KILOJOULES_PER_KELVIN |
DUT_KILOGRAMS_MASS | kilograms (kg)
DUT_TONNES_MASS | pounds (lb)
DUT_POUNDS_MASS | tonnes (t)
DUT_METERS_PER_SECOND_SQUARED | meters per second squared (m/s²)
DUT_KILOMETERS_PER_SECOND_SQUARED | kilometers per second squared (km/s²)
DUT_INCHES_PER_SECOND_SQUARED | inches per second squared (in/s²)
DUT_FEET_PER_SECOND_SQUARED | feet per second squared (ft/s²)
DUT_MILES_PER_SECOND_SQUARED | miles per second squared (mi/s²)
DUT_FEET_TO_THE_FOURTH_POWER | feet to the fourth power (ft^4)
DUT_INCHES_TO_THE_FOURTH_POWER | inches to the fourth power (in^4)
DUT_MILLIMETERS_TO_THE_FOURTH_POWER | millimeters to the fourth power (mm^4)
DUT_CENTIMETERS_TO_THE_FOURTH_POWER | centimeters to the fourth power (cm^4)
DUT_METERS_TO_THE_FOURTH_POWER | Meters to the fourth power (m^4)
DUT_FEET_TO_THE_SIXTH_POWER | feet to the sixth power (ft^6)
DUT_INCHES_TO_THE_SIXTH_POWER | inches to the sixth power (in^6)
DUT_MILLIMETERS_TO_THE_SIXTH_POWER | millimeters to the sixth power (mm^6)
DUT_CENTIMETERS_TO_THE_SIXTH_POWER | centimeters to the sixth power (cm^6)
DUT_METERS_TO_THE_SIXTH_POWER | meters to the sixth power (m^6)
DUT_SQUARE_FEET_PER_FOOT | square feet per foot (ft²/ft)
DUT_SQUARE_INCHES_PER_FOOT | square inches per foot (in²/ft)
DUT_SQUARE_MILLIMETERS_PER_METER | square millimeters per meter (mm²/m)
DUT_SQUARE_CENTIMETERS_PER_METER | square centimeters per meter (cm²/m)
DUT_SQUARE_METERS_PER_METER | square meters per meter (m²/m)
DUT_KILOGRAMS_MASS_PER_METER | kilograms per meter (kg/m)
DUT_POUNDS_MASS_PER_FOOT | pounds per foot (lb/ft)
DUT_RADIANS | radians
DUT_GRADS | grads
DUT_RADIANS_PER_SECOND | radians per second
DUT_MILISECONDS | millisecond
DUT_SECONDS | second
DUT_MINUTES | minutes
DUT_HOURS | hours
DUT_KILOMETERS_PER_HOUR | kilometers per hour
DUT_MILES_PER_HOUR | miles per hour
DUT_KILOJOULES | kilojoules
DUT_KILOGRAMS_MASS_PER_SQUARE_METER | kilograms per square meter (kg/m²)
DUT_POUNDS_MASS_PER_SQUARE_FOOT | pounds per square foot (lb/ft²)
DUT_WATTS_PER_METER_KELVIN | Watts per meter kelvin (W/(m·K))
DUT_JOULES_PER_GRAM_CELSIUS | Joules per gram Celsius (J/(g·°C))
DUT_JOULES_PER_GRAM | Joules per gram (J/g)
DUT_NANOGRAMS_PER_PASCAL_SECOND_SQUARE_METER | Nanograms per pascal second spuare meter (ng/(Pa·s·m²))
DUT_OHM_METERS | Ohm meters
DUT_BRITISH_THERMAL_UNITS_PER_HOUR_FOOT_FAHRENHEIT | BTU per hour foot Fahrenheit (BTU/(h·ft·°F))
DUT_BRITISH_THERMAL_UNITS_PER_POUND_FAHRENHEIT | BTU per pound Fahrenheit (BTU/(lb·°F))
DUT_BRITISH_THERMAL_UNITS_PER_POUND | BTU per pound (BTU/lb)
DUT_GRAINS_PER_HOUR_SQUARE_FOOT_INCH_MERCURY | Grains per hour square foot inch mercury (gr/(h·ft²·inHg))
DUT_PER_MILLE | Per mille or per thousand(‰)
DUT_DECIMETERS | Decimeters
DUT_JOULES_PER_KILOGRAM_CELSIUS | Joules per kilogram Celsius (J/(kg·°C))
DUT_MICROMETERS_PER_METER_CELSIUS | Micrometers per meter Celsius (um/(m·°C))
DUT_MICROINCHES_PER_INCH_FAHRENHEIT | Microinches per inch Fahrenheit (uin/(in·°F))

See Also


DistanceMeasuredFrom Enumeration

[image]

Revit 2013 API
DistanceMeasuredFrom Enumeration
See Also Send Feedback
Indicates if the distance is measured from the top or bottom of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum DistanceMeasuredFrom
Visual Basic
Public Enumeration DistanceMeasuredFrom
Visual C++
public enum class DistanceMeasuredFrom

Members

Member name | Description
Base | From bottom.
Top | From top.

See Also


DividedPath Class

[image]

Revit 2013 API
DividedPath Class
Members See Also Send Feedback
An element that consists of a set of points distributed along a path which consists of a connected set of curves and edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DividedPath : Element
Visual Basic
Public Class DividedPath _
    Inherits Element
Visual C++
public ref class DividedPath : public Element

Remarks

The points can be the result of a uniform distribution along the path. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the path, the layout, and layout specific settings. In addition, points can also be the result of intersecting the path with other elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DividedPath

See Also

DividedPath Members


DividedPath Members

[image] [image]

Revit 2013 API
DividedPath Members
DividedPath Class Methods Properties See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Toggle the flipped value
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints |
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedPath Class


DividedPath Methods

[image] [image]

Revit 2013 API
DividedPath Methods
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Methods

 | Name | Description
 | AreCurveReferencesConnected | This checks if the references represent a connected set of curves as required by the divided path.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
 | Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Toggle the flipped value
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntersectingElements | Get the elements whose intersection with path produces points.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsCurveReferenceValid | This returns true if the reference represents a curve or edge that can be used to create a divided path.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsIntersectorValidForCreation | This returns true if the intersector is an element that can be used to intersect with a newly created divided path.
Public method | IsIntersectorValidForDividedPath | This returns true if the intersector is an element that can be used to intersect with the divided path.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidBeginningIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
Public method | IsValidEndIndent | Checks that the indent value does not cause the beginningIndent and endIndent to overlop
 | IsValidFixedNumberOfPoints |
Public method | IsValidMeasurementType | Checks that the measurement type enumeration value is valid
Public method | IsValidSpacingRuleJustification | Checks that the justification enumeration value is valid
Public method | IsValidSpacingRuleLayout | Checks that the spacing rule layout enumeration value is valid
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | SeparateReferencesIntoConnectedReferences | This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetIntersectingElements | Set the elements whose intersection with path produces points.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedPath Class


AreCurveReferencesConnected Method

[image]

Revit 2013 API
DividedPath..::..AreCurveReferencesConnected Method
DividedPath Class See Also Send Feedback
This checks if the references represent a connected set of curves as required by the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool AreCurveReferencesConnected(
    Document document,
    IList<Reference> curveReferences
)
Visual Basic
Public Shared Function AreCurveReferencesConnected ( _
    document As Document, _
    curveReferences As IList(Of Reference) _
) As Boolean
Visual C++
public:
static bool AreCurveReferencesConnected(
    Document^ document,
    IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
The references.

Return Value

True if the arguments passed the checks, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedPath Class


Create Method

[image] [image]

Revit 2013 API
DividedPath..::..Create Method
DividedPath Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(Reference>)>>)) | Creates a new instance of a divided path with a default layout.
Create(Document, IList<(Of <<'(Reference>)>>), ICollection<(Of <<'(ElementId>)>>)) | Creates a new instance of a divided path whose points are determined by the intersecting elements.

See Also

DividedPath Class
DividedPath Members


Create Method (Document, IList(Reference))

[image]

Revit 2013 API
DividedPath..::..Create Method (Document, IList<(Of <(<'Reference>)>)>)
DividedPath Class See Also Send Feedback
Creates a new instance of a divided path with a default layout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveReferences As IList(Of Reference) _
) As DividedPath
Visual C++
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
References that represent a connected set of curves or edges.

Return Value

The newly created divided path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DividedPath Class
Create Overload


Create Method (Document, IList(Reference), ICollection(ElementId))

[image]

Revit 2013 API
DividedPath..::..Create Method (Document, IList<(Of <(<'Reference>)>)>, ICollection<(Of <(<'ElementId>)>)>)
DividedPath Class See Also Send Feedback
Creates a new instance of a divided path whose points are determined by the intersecting elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static DividedPath Create(
    Document document,
    IList<Reference> curveReferences,
    ICollection<ElementId> intersectors
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curveReferences As IList(Of Reference), _
    intersectors As ICollection(Of ElementId) _
) As DividedPath
Visual C++
public:
static DividedPath^ Create(
    Document^ document,
    IList<Reference^>^ curveReferences,
    ICollection<ElementId^>^ intersectors
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
References that represent a connected set of curves or edges.
intersectors
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Elements whose intersection with the curve references result in additional divisions.

Return Value

The newly created divided path.

Remarks

Intersectors can be curve elements, datum planes, or other divided paths.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document does not allow creation of a divided path. -or- Not all curve references in curveReferences represent a curve or an edge -or- The references in curveReferences are not connected. -or- Not all intersecting elements in intersectors are valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DividedPath Class
Create Overload


Flip Method

[image]

Revit 2013 API
DividedPath..::..Flip Method
DividedPath Class See Also Send Feedback
Toggle the flipped value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

DividedPath Class


GetIntersectingElements Method

[image]

Revit 2013 API
DividedPath..::..GetIntersectingElements Method
DividedPath Class See Also Send Feedback
Get the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetIntersectingElements()
Visual Basic
Public Function GetIntersectingElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetIntersectingElements()

See Also

DividedPath Class


IsCurveReferenceValid Method

[image]

Revit 2013 API
DividedPath..::..IsCurveReferenceValid Method
DividedPath Class See Also Send Feedback
This returns true if the reference represents a curve or edge that can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsCurveReferenceValid(
    Document document,
    Reference curveReference
)
Visual Basic
Public Shared Function IsCurveReferenceValid ( _
    document As Document, _
    curveReference As Reference _
) As Boolean
Visual C++
public:
static bool IsCurveReferenceValid(
    Document^ document,
    Reference^ curveReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReference
Type: Autodesk.Revit.DB..::..Reference
The reference.

Return Value

True if the reference can be used to create a divided path, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedPath Class


IsIntersectorValidForCreation Method

[image]

Revit 2013 API
DividedPath..::..IsIntersectorValidForCreation Method
DividedPath Class See Also Send Feedback
This returns true if the intersector is an element that can be used to intersect with a newly created divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsIntersectorValidForCreation(
    Document document,
    ElementId intersector
)
Visual Basic
Public Shared Function IsIntersectorValidForCreation ( _
    document As Document, _
    intersector As ElementId _
) As Boolean
Visual C++
public:
static bool IsIntersectorValidForCreation(
    Document^ document,
    ElementId^ intersector
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
intersector
Type: Autodesk.Revit.DB..::..ElementId
The intersector.

Return Value

True if the reference can be used to create a divided path, false otherwise.

Remarks

Intersectors can be curve elements, datum planes, or divided paths. This function is should not be used to validate the input to SetIntersectors() because it does not check for self intersection of any other circular dependencies between intersectors. Use isIntersectorValidForDividedPath() instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedPath Class


IsIntersectorValidForDividedPath Method

[image]

Revit 2013 API
DividedPath..::..IsIntersectorValidForDividedPath Method
DividedPath Class See Also Send Feedback
This returns true if the intersector is an element that can be used to intersect with the divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsIntersectorValidForDividedPath(
    ElementId intersector
)
Visual Basic
Public Function IsIntersectorValidForDividedPath ( _
    intersector As ElementId _
) As Boolean
Visual C++
public:
bool IsIntersectorValidForDividedPath(
    ElementId^ intersector
)

Parameters

intersector
Type: Autodesk.Revit.DB..::..ElementId
The intersector.

Return Value

True if the reference can be used to create a divided path, false otherwise.

Remarks

Intersectors can be curve elements, datum planes, or other divided paths. Note that divided paths that have this divided path as an intersector (either directly, or recursively) are not valid. Also, if the nesting of divided path intersectors that have intersectors is more than 5 levels deep the divided path intersector is considered invalid as well.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedPath Class


IsValidBeginningIndent Method

[image]

Revit 2013 API
DividedPath..::..IsValidBeginningIndent Method
DividedPath Class See Also Send Feedback
Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidBeginningIndent(
    double beginningIndent
)
Visual Basic
Public Function IsValidBeginningIndent ( _
    beginningIndent As Double _
) As Boolean
Visual C++
public:
bool IsValidBeginningIndent(
    double beginningIndent
)

Parameters

beginningIndent
Type: System..::..Double

See Also

DividedPath Class


IsValidEndIndent Method

[image]

Revit 2013 API
DividedPath..::..IsValidEndIndent Method
DividedPath Class See Also Send Feedback
Checks that the indent value does not cause the beginningIndent and endIndent to overlop

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidEndIndent(
    double endIndent
)
Visual Basic
Public Function IsValidEndIndent ( _
    endIndent As Double _
) As Boolean
Visual C++
public:
bool IsValidEndIndent(
    double endIndent
)

Parameters

endIndent
Type: System..::..Double

See Also

DividedPath Class


IsValidFixedNumberOfPoints Method

[image]

Revit 2013 API
DividedPath..::..IsValidFixedNumberOfPoints Method
DividedPath Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)
Visual Basic
Public Shared Function IsValidFixedNumberOfPoints ( _
    fixedNumberOfPoints As Integer _
) As Boolean
Visual C++
public:
static bool IsValidFixedNumberOfPoints(
    int fixedNumberOfPoints
)

Parameters

fixedNumberOfPoints
Type: System..::..Int32

See Also

DividedPath Class


IsValidMeasurementType Method

[image]

Revit 2013 API
DividedPath..::..IsValidMeasurementType Method
DividedPath Class See Also Send Feedback
Checks that the measurement type enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)
Visual Basic
Public Function IsValidMeasurementType ( _
    measurementType As DividedPathMeasurementType _
) As Boolean
Visual C++
public:
bool IsValidMeasurementType(
    DividedPathMeasurementType measurementType
)

Parameters

measurementType
Type: Autodesk.Revit.DB..::..DividedPathMeasurementType

See Also

DividedPath Class


IsValidSpacingRuleJustification Method

[image]

Revit 2013 API
DividedPath..::..IsValidSpacingRuleJustification Method
DividedPath Class See Also Send Feedback
Checks that the justification enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)
Visual Basic
Public Function IsValidSpacingRuleJustification ( _
    justification As SpacingRuleJustification _
) As Boolean
Visual C++
public:
bool IsValidSpacingRuleJustification(
    SpacingRuleJustification justification
)

Parameters

justification
Type: Autodesk.Revit.DB..::..SpacingRuleJustification

See Also

DividedPath Class


IsValidSpacingRuleLayout Method

[image]

Revit 2013 API
DividedPath..::..IsValidSpacingRuleLayout Method
DividedPath Class See Also Send Feedback
Checks that the spacing rule layout enumeration value is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)
Visual Basic
Public Function IsValidSpacingRuleLayout ( _
    layout As SpacingRuleLayout _
) As Boolean
Visual C++
public:
bool IsValidSpacingRuleLayout(
    SpacingRuleLayout layout
)

Parameters

layout
Type: Autodesk.Revit.DB..::..SpacingRuleLayout

See Also

DividedPath Class


SeparateReferencesIntoConnectedReferences Method

[image]

Revit 2013 API
DividedPath..::..SeparateReferencesIntoConnectedReferences Method
DividedPath Class See Also Send Feedback
This function separates the input curve references into groups of connected curve references. Each group of connected curve references can be used to create a divided path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<IList<Reference>> SeparateReferencesIntoConnectedReferences(
    Document document,
    IList<Reference> curveReferences
)
Visual Basic
Public Shared Function SeparateReferencesIntoConnectedReferences ( _
    document As Document, _
    curveReferences As IList(Of Reference) _
) As IList(Of IList(Of Reference))
Visual C++
public:
static IList<IList<Reference^>^>^ SeparateReferencesIntoConnectedReferences(
    Document^ document,
    IList<Reference^>^ curveReferences
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
curveReferences
Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
The references.

Return Value

The grouped references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not all curve references in curveReferences represent a curve or an edge
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

DividedPath Class


SetIntersectingElements Method

[image]

Revit 2013 API
DividedPath..::..SetIntersectingElements Method
DividedPath Class See Also Send Feedback
Set the elements whose intersection with path produces points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetIntersectingElements(
    ICollection<ElementId> intersectors
)
Visual Basic
Public Sub SetIntersectingElements ( _
    intersectors As ICollection(Of ElementId) _
)
Visual C++
public:
void SetIntersectingElements(
    ICollection<ElementId^>^ intersectors
)

Parameters

intersectors
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not all intersecting elements in intersectors are valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedPath Class


DividedPath Properties

[image] [image]

Revit 2013 API
DividedPath Properties
DividedPath Class See Also Send Feedback

The DividedPath type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BeginningIndent | The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DisplayNodeNumbers | Controls whether the node numbers are shown when the divided path is selected
Public property | DisplayNodes | Controls whether the points of the divided path are visible
Public property | DisplayReferenceCurves | Controls whether the curves in the path are visible
Public property | Distance | The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndIndent | The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.
Public property | FixedNumberOfPoints | The number of points used when the layout is set to 'FixedNumber'.
Public property | Flipped | If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsClosedLoop | Whether or not the path forms a closed loop.
Public property | IsCyclical | True if the first and last point coincide False otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumDistance | The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.
Public property | MeasurementType | The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').
Public property | MinimumDistance | The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfPoints | The total number of points of the divided surface. This combines the layout points and the intersection points.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpacingRuleJustification | When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.
Public property | SpacingRuleLayout | The layout determines how points are distributed along the path.
Public property | TotalPathLength | The sum of the curve lengths.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedPath Class


BeginningIndent Property

[image]

Revit 2013 API
DividedPath..::..BeginningIndent Property
DividedPath Class See Also Send Feedback
The beginningIndent is an offset distance from the beginning of the first curve that determines the beginning of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double BeginningIndent { get; set; }
Visual Basic
Public Property BeginningIndent As Double
    Get
    Set
Visual C++
public:
property double BeginningIndent {
    double get ();
    void set (double value);
}

Remarks

BeginningIndent and endIndent are not allowed to overlap

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for beginningIndent must be between 0 and 30000 feet. -or- When setting this property: beginningIndent overlaps with endIndent

See Also

DividedPath Class


DisplayNodeNumbers Property

[image]

Revit 2013 API
DividedPath..::..DisplayNodeNumbers Property
DividedPath Class See Also Send Feedback
Controls whether the node numbers are shown when the divided path is selected

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DisplayNodeNumbers { get; set; }
Visual Basic
Public Property DisplayNodeNumbers As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayNodeNumbers {
    bool get ();
    void set (bool value);
}

Remarks

If true the divided path will show the number of each node when the divided path is selected. If false the node numbers are hidden.

See Also

DividedPath Class


DisplayNodes Property

[image]

Revit 2013 API
DividedPath..::..DisplayNodes Property
DividedPath Class See Also Send Feedback
Controls whether the points of the divided path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DisplayNodes { get; set; }
Visual Basic
Public Property DisplayNodes As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayNodes {
    bool get ();
    void set (bool value);
}

Remarks

If true the nodes of the divided path are visible. If false the nodes are hidden.

See Also

DividedPath Class


DisplayReferenceCurves Property

[image]

Revit 2013 API
DividedPath..::..DisplayReferenceCurves Property
DividedPath Class See Also Send Feedback
Controls whether the curves in the path are visible

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DisplayReferenceCurves { get; set; }
Visual Basic
Public Property DisplayReferenceCurves As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayReferenceCurves {
    bool get ();
    void set (bool value);
}

Remarks

If true the references that represent the curves will not be hidden. If false the references that represent the curves may be hidden Only references that are curve elements can be hidden If multiple divided paths reference a curve element then the curve element is not hidden unless all divided paths request that it be hidden.

See Also

DividedPath Class


Distance Property

[image]

Revit 2013 API
DividedPath..::..Distance Property
DividedPath Class See Also Send Feedback
The distance between points that are distributed along the path according to the selected layout. When the layout is set to 'FixedDistance' this value can be set to desired distance. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This does not take into account points obtained by intersections with other elements. When the layout is set to 'None' the distance is the value that would be used by the 'FixedDistance' layout.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The distance is too small.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The distance can only be set when the layout of this DividedPath is set to 'FixedDistance' or 'None'.

See Also

DividedPath Class


EndIndent Property

[image]

Revit 2013 API
DividedPath..::..EndIndent Property
DividedPath Class See Also Send Feedback
The endIndent is an offset distance from the end of the last curve that determines the end of the range over which the layout is applied. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EndIndent { get; set; }
Visual Basic
Public Property EndIndent As Double
    Get
    Set
Visual C++
public:
property double EndIndent {
    double get ();
    void set (double value);
}

Remarks

BeginningIndent and endIndent are not allowed to overlap

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for endIndent must be between 0 and 30000 feet. -or- When setting this property: endIndent overlaps with beginningIndent

See Also

DividedPath Class


FixedNumberOfPoints Property

[image]

Revit 2013 API
DividedPath..::..FixedNumberOfPoints Property
DividedPath Class See Also Send Feedback
The number of points used when the layout is set to 'FixedNumber'.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int FixedNumberOfPoints { get; set; }
Visual Basic
Public Property FixedNumberOfPoints As Integer
    Get
    Set
Visual C++
public:
property int FixedNumberOfPoints {
    int get ();
    void set (int value);
}

Remarks

To get the actual number of point use GetNumberOfPoints().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fixedNumberOfPoints must be at least 2 and at most 200.

See Also

DividedPath Class


Flipped Property

[image]

Revit 2013 API
DividedPath..::..Flipped Property
DividedPath Class See Also Send Feedback
If the divided path is flipped the nodes are numbered in the reverse order. It also switches the ends from which beginningIndent and endIndent are measured from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Flipped { get; }
Visual Basic
Public ReadOnly Property Flipped As Boolean
    Get
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

DividedPath Class


IsClosedLoop Property

[image]

Revit 2013 API
DividedPath..::..IsClosedLoop Property
DividedPath Class See Also Send Feedback
Whether or not the path forms a closed loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsClosedLoop { get; }
Visual Basic
Public ReadOnly Property IsClosedLoop As Boolean
    Get
Visual C++
public:
property bool IsClosedLoop {
    bool get ();
}

Remarks

True if the path form a closed loop. False otherwise.

See Also

DividedPath Class


IsCyclical Property

[image]

Revit 2013 API
DividedPath..::..IsCyclical Property
DividedPath Class See Also Send Feedback
True if the first and last point coincide False otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCyclical { get; }
Visual Basic
Public ReadOnly Property IsCyclical As Boolean
    Get
Visual C++
public:
property bool IsCyclical {
    bool get ();
}

See Also

DividedPath Class


MaximumDistance Property

[image]

Revit 2013 API
DividedPath..::..MaximumDistance Property
DividedPath Class See Also Send Feedback
The maximum distance is used when the layout is set to 'MaximumSpacing'. When that layout rule is used the distance between points will not exceed this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MaximumDistance { get; set; }
Visual Basic
Public Property MaximumDistance As Double
    Get
    Set
Visual C++
public:
property double MaximumDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximumDistance is too small.

See Also

DividedPath Class


MeasurementType Property

[image]

Revit 2013 API
DividedPath..::..MeasurementType Property
DividedPath Class See Also Send Feedback
The measurement type determines how distances are calculated. Either along a straight line between two points ('ChordLength') or along the segment of the path that connects them. ('SegmentLength').

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DividedPathMeasurementType MeasurementType { get; set; }
Visual Basic
Public Property MeasurementType As DividedPathMeasurementType
    Get
    Set
Visual C++
public:
property DividedPathMeasurementType MeasurementType {
    DividedPathMeasurementType get ();
    void set (DividedPathMeasurementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid measurementType

See Also

DividedPath Class


MinimumDistance Property

[image]

Revit 2013 API
DividedPath..::..MinimumDistance Property
DividedPath Class See Also Send Feedback
The minimum distance is used when the layout is set to 'MinimumSpacing'. When that layout rule is used the distance between points will not fall below this value. The measurement type determines how the distance is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinimumDistance { get; set; }
Visual Basic
Public Property MinimumDistance As Double
    Get
    Set
Visual C++
public:
property double MinimumDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The minimumDistance is too small.

See Also

DividedPath Class


NumberOfPoints Property

[image]

Revit 2013 API
DividedPath..::..NumberOfPoints Property
DividedPath Class See Also Send Feedback
The total number of points of the divided surface. This combines the layout points and the intersection points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfPoints { get; }
Visual Basic
Public ReadOnly Property NumberOfPoints As Integer
    Get
Visual C++
public:
property int NumberOfPoints {
    int get ();
}

See Also

DividedPath Class


Parameter Property

[image] [image]

Revit 2013 API
DividedPath..::..Parameter Property
DividedPath Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DividedPath Class
DividedPath Members


SpacingRuleJustification Property

[image]

Revit 2013 API
DividedPath..::..SpacingRuleJustification Property
DividedPath Class See Also Send Feedback
When the layout is set to 'FixedDistance' the points may not cover the entire range of the path. The justification determines whether the points are centered on the range, or shifted towards the start or end of the range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpacingRuleJustification SpacingRuleJustification { get; set; }
Visual Basic
Public Property SpacingRuleJustification As SpacingRuleJustification
    Get
    Set
Visual C++
public:
property SpacingRuleJustification SpacingRuleJustification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid justification

See Also

DividedPath Class


SpacingRuleLayout Property

[image]

Revit 2013 API
DividedPath..::..SpacingRuleLayout Property
DividedPath Class See Also Send Feedback
The layout determines how points are distributed along the path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpacingRuleLayout SpacingRuleLayout { get; set; }
Visual Basic
Public Property SpacingRuleLayout As SpacingRuleLayout
    Get
    Set
Visual C++
public:
property SpacingRuleLayout SpacingRuleLayout {
    SpacingRuleLayout get ();
    void set (SpacingRuleLayout value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: Invalid layout

See Also

DividedPath Class


TotalPathLength Property

[image]

Revit 2013 API
DividedPath..::..TotalPathLength Property
DividedPath Class See Also Send Feedback
The sum of the curve lengths.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalPathLength { get; }
Visual Basic
Public ReadOnly Property TotalPathLength As Double
    Get
Visual C++
public:
property double TotalPathLength {
    double get ();
}

See Also

DividedPath Class


DividedPathMeasurementType Enumeration

[image]

Revit 2013 API
DividedPathMeasurementType Enumeration
See Also Send Feedback
DividedPath measurement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum DividedPathMeasurementType
Visual Basic
Public Enumeration DividedPathMeasurementType
Visual C++
public enum class DividedPathMeasurementType

Members

Member name | Description
ChordLength | Distances between two points are measured along a straight line between the points.
SegmentLength | Distances between two points are measured along the path segment between the points.

See Also


DividedSurface Class

[image]

Revit 2013 API
DividedSurface Class
Members Example See Also Send Feedback
An element that represents a mesh on the surface of another element, a family instance, an import instance or a geometry combination, and a tile pattern built on that mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DividedSurface : Element
Visual Basic
Public Class DividedSurface _
    Inherits Element
Visual C++
public ref class DividedSurface : public Element

Remarks

The type of this element may be set to: a TilePattern element, a FamilySymbol element from a Curtain Panel family.

Examples

CopyC#
public void TileSurface(Document document, Form form)
{
    // cover surface with OctagonRotate tile pattern
    TilePatterns tilePatterns = document.Settings.TilePatterns;
    DividedSurfaceData dsData = form.GetDividedSurfaceData();
    if (dsData != null)
    {
        foreach (Reference r in dsData.GetReferencesWithDividedSurfaces())
        {
            DividedSurface ds = dsData.GetDividedSurfaceForReference(r);
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id);
        }
    }
}
CopyVB.NET
Public Sub TileSurface(ByVal document As Document, ByVal form As Form)
    ' cover surface with OctagonRotate tile pattern
    Dim tilePatterns As TilePatterns = document.Settings.TilePatterns
    Dim dsData As DividedSurfaceData = form.GetDividedSurfaceData()
    If dsData IsNot Nothing Then
        For Each r As Reference In dsData.GetReferencesWithDividedSurfaces()
            Dim ds As Autodesk.Revit.DB.DividedSurface = dsData.GetDividedSurfaceForReference(r)
            ds.ChangeTypeId(tilePatterns.GetTilePattern(TilePatternsBuiltIn.OctagonRotate).Id)
        Next
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..DividedSurface

See Also

DividedSurface Members


DividedSurface Members

[image] [image]

Revit 2013 API
DividedSurface Members
DividedSurface Class Methods Properties See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedSurface Class


DividedSurface Methods

[image] [image]

Revit 2013 API
DividedSurface Methods
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectionElement | Adds an intersection element to the divided surface.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanBeIntersectionElement | Checks if the element can be an intersection reference.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllIntersectionElements | Gets all intersection elements which produce division lines.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridNodeLocation | Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.
Public method | GetGridNodeReference | Get a reference to the geometric point associated with a grid node.
Public method | GetGridNodeUV | Get the position of a grid node in UV coordinates in the surface.
Public method | GetGridSegmentReference | Get a reference to a line segment connecting two adjacent grid nodes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTileFamilyInstance | Get a reference to a tile element associated with a given seed node.
Public method | GetTileReference | Get a reference to one of the tile surfaces associated with a given seed node.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSeedNode | Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveAllIntersectionElements | Removes all the intersection elements from a divided surface.
Public method | RemoveIntersectionElement | Removes an intersection element from a divided surface.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurface Class


AddIntersectionElement Method

[image]

Revit 2013 API
DividedSurface..::..AddIntersectionElement Method
DividedSurface Class See Also Send Feedback
Adds an intersection element to the divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddIntersectionElement(
    ElementId newIntersectionElemId
)
Visual Basic
Public Sub AddIntersectionElement ( _
    newIntersectionElemId As ElementId _
)
Visual C++
public:
void AddIntersectionElement(
    ElementId^ newIntersectionElemId
)

Parameters

newIntersectionElemId
Type: Autodesk.Revit.DB..::..ElementId
The intersection element to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element newIntersectionElemId is not a level, grid, reference plane, or a curve element whose category is lines and reference lines.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


CanBeIntersectionElement Method

[image]

Revit 2013 API
DividedSurface..::..CanBeIntersectionElement Method
DividedSurface Class See Also Send Feedback
Checks if the element can be an intersection reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanBeIntersectionElement(
    ElementId id
)
Visual Basic
Public Function CanBeIntersectionElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool CanBeIntersectionElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked.

Return Value

True if the element can be an intersection reference., false otherwise.

Remarks

The element must be a level, grid, reference plane, or a curve element whose category is lines and reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


GetAllIntersectionElements Method

[image]

Revit 2013 API
DividedSurface..::..GetAllIntersectionElements Method
DividedSurface Class See Also Send Feedback
Gets all intersection elements which produce division lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAllIntersectionElements()
Visual Basic
Public Function GetAllIntersectionElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllIntersectionElements()

Return Value

The intersection elements.

See Also

DividedSurface Class


GetGridNodeLocation Method

[image]

Revit 2013 API
DividedSurface..::..GetGridNodeLocation Method
DividedSurface Class See Also Send Feedback
Specify whether a particular grid node is interior to the surface, on the boundary, or outside the boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeLocation ( _
    gridNode As GridNode _
) As GridNodeLocation
Visual C++
public:
GridNodeLocation GetGridNodeLocation(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeReference Method

[image]

Revit 2013 API
DividedSurface..::..GetGridNodeReference Method
DividedSurface Class See Also Send Feedback
Get a reference to the geometric point associated with a grid node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetGridNodeReference(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeReference ( _
    gridNode As GridNode _
) As Reference
Visual C++
public:
Reference^ GetGridNodeReference(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridNodeUV Method

[image]

Revit 2013 API
DividedSurface..::..GetGridNodeUV Method
DividedSurface Class See Also Send Feedback
Get the position of a grid node in UV coordinates in the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV GetGridNodeUV(
    GridNode gridNode
)
Visual Basic
Public Function GetGridNodeUV ( _
    gridNode As GridNode _
) As UV
Visual C++
public:
UV^ GetGridNodeUV(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


GetGridSegmentReference Method

[image]

Revit 2013 API
DividedSurface..::..GetGridSegmentReference Method
DividedSurface Class See Also Send Feedback
Get a reference to a line segment connecting two adjacent grid nodes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)
Visual Basic
Public Function GetGridSegmentReference ( _
    gridNode As GridNode, _
    gridSegmentDirection As GridSegmentDirection _
) As Reference
Visual C++
public:
Reference^ GetGridSegmentReference(
    GridNode gridNode,
    GridSegmentDirection gridSegmentDirection
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
gridSegmentDirection
Type: Autodesk.Revit.DB..::..GridSegmentDirection

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ], or when the adjacent grid node specified by gridSegmentDirection is out of range.

See Also

DividedSurface Class


GetTileFamilyInstance Method

[image]

Revit 2013 API
DividedSurface..::..GetTileFamilyInstance Method
DividedSurface Class See Also Send Feedback
Get a reference to a tile element associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)
Visual Basic
Public Function GetTileFamilyInstance ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As FamilyInstance
Visual C++
public:
FamilyInstance^ GetTileFamilyInstance(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
tileIndex
Type: System..::..Int32

Return Value

A FamilyInstance object. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the ObjectType property is not a FamilySymbol. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


GetTileReference Method

[image]

Revit 2013 API
DividedSurface..::..GetTileReference Method
DividedSurface Class See Also Send Feedback
Get a reference to one of the tile surfaces associated with a given seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetTileReference(
    GridNode gridNode,
    int tileIndex
)
Visual Basic
Public Function GetTileReference ( _
    gridNode As GridNode, _
    tileIndex As Integer _
) As Reference
Visual C++
public:
Reference^ GetTileReference(
    GridNode gridNode,
    int tileIndex
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode
tileIndex
Type: System..::..Int32
An integer between 0 and T-1, where T is TilesPerSeedNode.

Return Value

A reference to a Face (surface). Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the grid node is not a "seed node", or if the tile is omitted due to boundary conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if the grid node is outside of the range specified by NumberOfUGridlines and NumberOfVGridlines, or if tileIndex is outside the range [0, TilesPerSeedNode-1].

See Also

DividedSurface Class


IsSeedNode Method

[image]

Revit 2013 API
DividedSurface..::..IsSeedNode Method
DividedSurface Class See Also Send Feedback
Reports whether a grid node is a "seed node," a node that is associated with one or more tiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSeedNode(
    GridNode gridNode
)
Visual Basic
Public Function IsSeedNode ( _
    gridNode As GridNode _
) As Boolean
Visual C++
public:
bool IsSeedNode(
    GridNode gridNode
)

Parameters

gridNode
Type: Autodesk.Revit.DB..::..GridNode

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the grid node indexes are outside the range [ 0, NumberOfUGridlines - 1 ], [ 0, NumberOfVGridlines - 1 ].

See Also

DividedSurface Class


RemoveAllIntersectionElements Method

[image]

Revit 2013 API
DividedSurface..::..RemoveAllIntersectionElements Method
DividedSurface Class See Also Send Feedback
Removes all the intersection elements from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void RemoveAllIntersectionElements()
Visual Basic
Public Sub RemoveAllIntersectionElements
Visual C++
public:
void RemoveAllIntersectionElements()

See Also

DividedSurface Class


RemoveIntersectionElement Method

[image]

Revit 2013 API
DividedSurface..::..RemoveIntersectionElement Method
DividedSurface Class See Also Send Feedback
Removes an intersection element from a divided surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void RemoveIntersectionElement(
    ElementId referenceElemIdToRemove
)
Visual Basic
Public Sub RemoveIntersectionElement ( _
    referenceElemIdToRemove As ElementId _
)
Visual C++
public:
void RemoveIntersectionElement(
    ElementId^ referenceElemIdToRemove
)

Parameters

referenceElemIdToRemove
Type: Autodesk.Revit.DB..::..ElementId
The intersection element to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DividedSurface Class


DividedSurface Properties

[image] [image]

Revit 2013 API
DividedSurface Properties
DividedSurface Class See Also Send Feedback

The DividedSurface type exposes the following members.

Properties

 | Name | Description
Public property | AllGridRotation | Angle of rotation applied to the U- and V- directions together.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BorderTile | Determines the handling of tiles that overlap the surface's boundary.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ComponentRotation | The rotation of the pattern by a multiple of 90 degrees.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Host | The element whose surface has been divided.
Public property | HostReference | A reference to the divided face on the host.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsComponentFlipped | Whether the pattern is flipped.
Public property | IsComponentMirrored | Whether the pattern is mirror-imaged.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfUGridlines | Get the number of U-gridlines used on the surface.
Public property | NumberOfVGridlines | Get the number of V-gridlines used on the surface.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the U-direction.
Public property | USpacingRule | Access to the rule for laying out the first series of equidistant parallel lines on the surface.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VPatternIndent | The offset applied to the pattern by an integral number of grid nodes in the V-direction.
Public property | VSpacingRule | Access to the rule for laying out the second series of equidistant parallel lines on the surface.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DividedSurface Class


AllGridRotation Property

[image]

Revit 2013 API
DividedSurface..::..AllGridRotation Property
DividedSurface Class See Also Send Feedback
Angle of rotation applied to the U- and V- directions together.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AllGridRotation { get; set; }
Visual Basic
Public Property AllGridRotation As Double
    Get
    Set
Visual C++
public:
property double AllGridRotation {
    double get ();
    void set (double value);
}

See Also

DividedSurface Class


BorderTile Property

[image]

Revit 2013 API
DividedSurface..::..BorderTile Property
DividedSurface Class See Also Send Feedback
Determines the handling of tiles that overlap the surface's boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BorderTile BorderTile { get; set; }
Visual Basic
Public Property BorderTile As BorderTile
    Get
    Set
Visual C++
public:
property BorderTile BorderTile {
    BorderTile get ();
    void set (BorderTile value);
}

See Also

DividedSurface Class


ComponentRotation Property

[image]

Revit 2013 API
DividedSurface..::..ComponentRotation Property
DividedSurface Class See Also Send Feedback
The rotation of the pattern by a multiple of 90 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ComponentRotation ComponentRotation { get; set; }
Visual Basic
Public Property ComponentRotation As ComponentRotation
    Get
    Set
Visual C++
public:
property ComponentRotation ComponentRotation {
    ComponentRotation get ();
    void set (ComponentRotation value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

DividedSurface Class


Host Property

[image]

Revit 2013 API
DividedSurface..::..Host Property
DividedSurface Class See Also Send Feedback
The element whose surface has been divided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic
Public ReadOnly Property Host As Element
    Get
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

DividedSurface Class


HostReference Property

[image]

Revit 2013 API
DividedSurface..::..HostReference Property
DividedSurface Class See Also Send Feedback
A reference to the divided face on the host.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference HostReference { get; }
Visual Basic
Public ReadOnly Property HostReference As Reference
    Get
Visual C++
public:
property Reference^ HostReference {
    Reference^ get ();
}

Remarks

This is the same as the hostReference argument to the NewDividedSurface method of FamilyItemFactory.

See Also

DividedSurface Class


IsComponentFlipped Property

[image]

Revit 2013 API
DividedSurface..::..IsComponentFlipped Property
DividedSurface Class See Also Send Feedback
Whether the pattern is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsComponentFlipped { get; set; }
Visual Basic
Public Property IsComponentFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsComponentFlipped {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)). Changing this flag effectively reflects the component through its XY-plane, which is equivalent to reflecting it through the original surface.

See Also

DividedSurface Class


IsComponentMirrored Property

[image]

Revit 2013 API
DividedSurface..::..IsComponentMirrored Property
DividedSurface Class See Also Send Feedback
Whether the pattern is mirror-imaged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsComponentMirrored { get; set; }
Visual Basic
Public Property IsComponentMirrored As Boolean
    Get
    Set
Visual C++
public:
property bool IsComponentMirrored {
    bool get ();
    void set (bool value);
}

Remarks

This property has no effect unless a pattern is selected (the ObjectType property is not nullNothingnullptra null reference (Nothing in Visual Basic)). Changing this flag effectively reflects the component through its YZ-plane.

See Also

DividedSurface Class


NumberOfUGridlines Property

[image]

Revit 2013 API
DividedSurface..::..NumberOfUGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of U-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfUGridlines { get; }
Visual Basic
Public ReadOnly Property NumberOfUGridlines As Integer
    Get
Visual C++
public:
property int NumberOfUGridlines {
    int get ();
}

See Also

DividedSurface Class


NumberOfVGridlines Property

[image]

Revit 2013 API
DividedSurface..::..NumberOfVGridlines Property
DividedSurface Class See Also Send Feedback
Get the number of V-gridlines used on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfVGridlines { get; }
Visual Basic
Public ReadOnly Property NumberOfVGridlines As Integer
    Get
Visual C++
public:
property int NumberOfVGridlines {
    int get ();
}

See Also

DividedSurface Class


Parameter Property

[image] [image]

Revit 2013 API
DividedSurface..::..Parameter Property
DividedSurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DividedSurface Class
DividedSurface Members


UPatternIndent Property

[image]

Revit 2013 API
DividedSurface..::..UPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the U-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int UPatternIndent { get; set; }
Visual Basic
Public Property UPatternIndent As Integer
    Get
    Set
Visual C++
public:
property int UPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


USpacingRule Property

[image]

Revit 2013 API
DividedSurface..::..USpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the first series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpacingRule USpacingRule { get; }
Visual Basic
Public ReadOnly Property USpacingRule As SpacingRule
    Get
Visual C++
public:
property SpacingRule^ USpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


VPatternIndent Property

[image]

Revit 2013 API
DividedSurface..::..VPatternIndent Property
DividedSurface Class See Also Send Feedback
The offset applied to the pattern by an integral number of grid nodes in the V-direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int VPatternIndent { get; set; }
Visual Basic
Public Property VPatternIndent As Integer
    Get
    Set
Visual C++
public:
property int VPatternIndent {
    int get ();
    void set (int value);
}

See Also

DividedSurface Class


VSpacingRule Property

[image]

Revit 2013 API
DividedSurface..::..VSpacingRule Property
DividedSurface Class See Also Send Feedback
Access to the rule for laying out the second series of equidistant parallel lines on the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpacingRule VSpacingRule { get; }
Visual Basic
Public ReadOnly Property VSpacingRule As SpacingRule
    Get
Visual C++
public:
property SpacingRule^ VSpacingRule {
    SpacingRule^ get ();
}

See Also

DividedSurface Class


DividedSurfaceData Class

[image]

Revit 2013 API
DividedSurfaceData Class
Members See Also Send Feedback
An interface to the divided surfaces on an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DividedSurfaceData : APIObject
Visual Basic
Public Class DividedSurfaceData _
    Inherits APIObject
Visual C++
public ref class DividedSurfaceData : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DividedSurfaceData

See Also

DividedSurfaceData Members


DividedSurfaceData Members

[image] [image]

Revit 2013 API
DividedSurfaceData Members
DividedSurfaceData Class Methods Properties See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class


DividedSurfaceData Methods

[image] [image]

Revit 2013 API
DividedSurfaceData Methods
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDividedSurfaceForReference | Find the DividedSurface element that is associated with a surface of this element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetReferencesWithDividedSurfaces | Find the set of references that have associated DividedSurface elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DividedSurfaceData Class


GetDividedSurfaceForReference Method

[image]

Revit 2013 API
DividedSurfaceData..::..GetDividedSurfaceForReference Method
DividedSurfaceData Class See Also Send Feedback
Find the DividedSurface element that is associated with a surface of this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurface GetDividedSurfaceForReference(
    Reference reference
)
Visual Basic
Public Function GetDividedSurfaceForReference ( _
    reference As Reference _
) As DividedSurface
Visual C++
public:
DividedSurface^ GetDividedSurfaceForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Return Value

A DividedSurface element, if there is one associated with this face; null if the reference is to a face without a DividedSurface.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when reference is not a face (surface) reference.

See Also

DividedSurfaceData Class


GetReferencesWithDividedSurfaces Method

[image]

Revit 2013 API
DividedSurfaceData..::..GetReferencesWithDividedSurfaces Method
DividedSurfaceData Class See Also Send Feedback
Find the set of references that have associated DividedSurface elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray GetReferencesWithDividedSurfaces()
Visual Basic
Public Function GetReferencesWithDividedSurfaces As ReferenceArray
Visual C++
public:
ReferenceArray^ GetReferencesWithDividedSurfaces()

See Also

DividedSurfaceData Class


DividedSurfaceData Properties

[image] [image]

Revit 2013 API
DividedSurfaceData Properties
DividedSurfaceData Class See Also Send Feedback

The DividedSurfaceData type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DividedSurfaceData Class


Document Class

[image]

Revit 2013 API
Document Class
Members See Also Send Feedback
An object that represents an open Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Document : IDisposable
Visual Basic
Public Class Document _
    Implements IDisposable
Visual C++
public ref class Document : IDisposable

Remarks

The Document object represents an Autodesk Revit project. Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the Application object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Document

See Also

Document Members


Document Members

[image] [image]

Revit 2013 API
Document Members
Document Class Methods Properties Events See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(Element) | Deletes an element from the document.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes several elements from the document given their ids.
Public method | Delete(ElementSet) | Obsolete. Deletes several elements from the document.
Public method | Dispose | Releases all resources used by the Document
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | FindReferencesWithContextByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
Public method | GetElement(String) | Gets the Element referenced by the input string name.
Public method | GetElement(ElementId) | Gets the Element referenced by the input string name.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | Import(String, ImageImportOptions, View, Element%) | Imports an image (a bitmap) into the document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file to the document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file to the document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file name.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | Application | Returns the Application in which the Document resides.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Public property | Element[([( String])]) | Obsolete. Retrieves an element from the document given a unique id string.
Public property | Element[([( ElementId])]) | Obsolete. Retrieves an element from the document given a Revit element id.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsModifiable | The document's state of modifiability.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Obsolete. Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | The document's title.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | Obsolete. The name and path of the central model for a workshared document.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


Document Methods

[image] [image]

Revit 2013 API
Document Methods
Document Class See Also Send Feedback

The Document type exposes the following members.

Methods

 | Name | Description
Public method | AutoJoinElements | Forces the elements in the Revit document to automatically join to their neighbors where appropriate.
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.
Public method | CombineElements | Combine a set of combinable elements into a geometry combination.
Public method | ConvertDetailToModelCurves | Converts a group of DetailCurves to equivalent ModelCurves.
Public method | ConvertModelToDetailCurves | Converts a group of ModelCurves to equivalent DetailCurves.
Public method | ConvertModelToSymbolicCurves | Converts a group of ModelCurves to equivalent SymbolicCurves.
Public method | ConvertSymbolicToModelCurves | Converts a group of SymbolicCurves to equivalent ModelCurves.
Public method | Delete(Element) | Deletes an element from the document.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes several elements from the document given their ids.
Public method | Delete(ElementSet) | Obsolete. Deletes several elements from the document.
Public method | Dispose |
Public method | EditFamily | Gets the document of a loaded family to edit.
Public method | Equals | Determines whether the specified Object equals to this Object. (Overrides Object..::..Equals(Object).)
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.
Public method | ExportImage | Exports a view or set of views into an image file.
Public method | FindReferencesWithContextByDirection | Finds the references that intersect a line extended in a certain direction from an origin point.
Public method | GetDocumentPreviewSettings | Returns the preview settings for the given document.
Public method | GetElement(String) | Gets the Element referenced by the input string name.
Public method | GetElement(ElementId) | Gets the Element referenced by the input string name.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.
Public method | GetHashCode | Gets the hash code of this document instance. (Overrides Object..::..GetHashCode()()()().)
Public method | GetPrintSettingIds | Retrieves all Print Settings of current project.
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetId | Get Id of the Workset which owns the element.
Public method | GetWorksetTable | Get the WorksetTable of this document.
Public method | GetWorksharingCentralModelPath | Gets the central model path of the worksharing model.
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | Import(String, ImageImportOptions, View, Element%) | Imports an image (a bitmap) into the document.
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file to the document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file to the document.
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | PostFailure | Posts a failure to be displayed to the user at the end of transaction.
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.
Public method | Regenerate | Updates the elements in the Revit document to reflect all changes.
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.
Public method | SaveAs(String) | Saves the document to a given file name.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.
Public method | SaveToProjectAsImage | Creates an image view from the currently active view.
Public method | SeparateElements | Separate a set of combinable elements out of combinations they currently belong to.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnpostFailure | Deletes the posted failure message associated with a given FailureMessageKey.

See Also

Document Class


AutoJoinElements Method

[image]

Revit 2013 API
Document..::..AutoJoinElements Method
Document Class See Also Send Feedback
Forces the elements in the Revit document to automatically join to their neighbors where appropriate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AutoJoinElements()
Visual Basic
Public Sub AutoJoinElements
Visual C++
public:
void AutoJoinElements()

Remarks

Use this method to force elements in the document to automatically join to their neighbors. Note that when a transaction is committed there is an automatic call to automatically join elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..AutoJoinFailedException | Thrown when the regeneration option is automatic or the operation fails.

See Also

Document Class


Close Method

[image] [image]

Revit 2013 API
Document..::..Close Method
Document Class See Also Send Feedback
Closes the document.

Overload List

 | Name | Description
Public method | Close()()()() | Closes the document, save the changes if there are.
Public method | Close(Boolean) | Closes the document with the option to save.

See Also

Document Class
Document Members


Close Method

[image]

Revit 2013 API
Document..::..Close Method
Document Class See Also Send Feedback
Closes the document, save the changes if there are.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Close()
Visual Basic
Public Function Close As Boolean
Visual C++
public:
bool Close()

Return Value

False if either closing procedure fails or if saving of a modified document failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

The currently active document may not be closed by this function. It can only be closed via Revit's UI.

The changes will saved automatically, the document will not be closed if failed to save changes. If the document was created in this current session and has not been saved to a file yet, it needs to call Revit::UI::UIDocument::SaveAndClose() method instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if the PathName is not set yet. Thrown if the saving target file is read only.

See Also

Document Class
Close Overload


Close Method (Boolean)

[image]

Revit 2013 API
Document..::..Close Method (Boolean)
Document Class See Also Send Feedback
Closes the document with the option to save.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Close(
    bool saveModified
)
Visual Basic
Public Function Close ( _
    saveModified As Boolean _
) As Boolean
Visual C++
public:
bool Close(
    bool saveModified
)

Parameters

saveModified
Type: System..::..Boolean
Indicates if the current document should be saved before close operation.

Return Value

False if closing procedure fails or if saving of a modified document was requested (saveModified = True) but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

The currently active document may not be closed by this function. It can only be closed via Revit's UI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if saveModified is 'true' and the PathName is not set yet. Thrown if saveModified is 'true' and the saving target file is read only.

See Also

Document Class
Close Overload


CombineElements Method

[image]

Revit 2013 API
Document..::..CombineElements Method
Document Class See Also Send Feedback
Combine a set of combinable elements into a geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeomCombination CombineElements(
    CombinableElementArray members
)
Visual Basic
Public Function CombineElements ( _
    members As CombinableElementArray _
) As GeomCombination
Visual C++
public:
GeomCombination^ CombineElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::..CombinableElementArray
A list of combinable elements to be combined.

Return Value

If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.

Remarks

If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when members contains less than two elements. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when creation of the combination failed.

See Also

Document Class


ConvertDetailToModelCurves Method

[image]

Revit 2013 API
Document..::..ConvertDetailToModelCurves Method
Document Class See Also Send Feedback
Converts a group of DetailCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray ConvertDetailToModelCurves(
    View view,
    DetailCurveArray detailCurves
)
Visual Basic
Public Function ConvertDetailToModelCurves ( _
    view As View, _
    detailCurves As DetailCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertDetailToModelCurves(
    View^ view,
    DetailCurveArray^ detailCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
detailCurves
Type: Autodesk.Revit.DB..::..DetailCurveArray
The detail curve array to be converted.

Remarks

This operation will create new ModelCurves with the same geometry of the original detail curves' geometry. The detail curves will be deleted from the document.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when the given detail lines are not visible in the given view. Thrown when the detail lines are not in the same view or not parallel to the given view.
System..::..InvalidOperationException | Thrown when one or more curves could not be successfully converted.

See Also

Document Class


ConvertModelToDetailCurves Method

[image]

Revit 2013 API
Document..::..ConvertModelToDetailCurves Method
Document Class See Also Send Feedback
Converts a group of ModelCurves to equivalent DetailCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DetailCurveArray ConvertModelToDetailCurves(
    View view,
    ModelCurveArray modelCurves
)
Visual Basic
Public Function ConvertModelToDetailCurves ( _
    view As View, _
    modelCurves As ModelCurveArray _
) As DetailCurveArray
Visual C++
public:
DetailCurveArray^ ConvertModelToDetailCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves
Type: Autodesk.Revit.DB..::..ModelCurveArray
The model curve array to be converted.

Remarks

This operation will create new DetailCurves with the same geometry of the original model curves' geometry. The model curves will be deleted from the document. If the model curves do not lie in a plane parallel to the view, their geometry will be projected to the view.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when view is invalid to create DetailCurves on it.
System..::..InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.

See Also

Document Class


ConvertModelToSymbolicCurves Method

[image]

Revit 2013 API
Document..::..ConvertModelToSymbolicCurves Method
Document Class See Also Send Feedback
Converts a group of ModelCurves to equivalent SymbolicCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SymbolicCurveArray ConvertModelToSymbolicCurves(
    View view,
    ModelCurveArray modelCurves
)
Visual Basic
Public Function ConvertModelToSymbolicCurves ( _
    view As View, _
    modelCurves As ModelCurveArray _
) As SymbolicCurveArray
Visual C++
public:
SymbolicCurveArray^ ConvertModelToSymbolicCurves(
    View^ view,
    ModelCurveArray^ modelCurves
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane. If the lines are not parallel to the view plane, lines are foreshortened and arcs are converted to ellipses. Splines are modified.
modelCurves
Type: Autodesk.Revit.DB..::..ModelCurveArray
The model curve array to be converted.

Remarks

This operation will create new SymbolicCurves with the modelCurves' geometry curves and delete the ModelCurve in the array. If modelCurves are not parallel to the workplane, they will be projected to the workplane and create new SymbolicCurves with the projected curves.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..ArgumentException | Thrown when view is invalid to create SymbolicCurves on it.
System..::..InvalidOperationException | Thrown when current document is a family. Thrown when one or more curves could not be successfully converted, perhaps because some of the input curves could not be projected onto the active workplane of the view.

See Also

Document Class


ConvertSymbolicToModelCurves Method

[image]

Revit 2013 API
Document..::..ConvertSymbolicToModelCurves Method
Document Class See Also Send Feedback
Converts a group of SymbolicCurves to equivalent ModelCurves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray ConvertSymbolicToModelCurves(
    View view,
    SymbolicCurveArray symbolicCurve
)
Visual Basic
Public Function ConvertSymbolicToModelCurves ( _
    view As View, _
    symbolicCurve As SymbolicCurveArray _
) As ModelCurveArray
Visual C++
public:
ModelCurveArray^ ConvertSymbolicToModelCurves(
    View^ view,
    SymbolicCurveArray^ symbolicCurve
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view where the new lines will be created. The lines are projected on the view workplane. The view workplane must be parallel to the view plane.
symbolicCurve
Type: Autodesk.Revit.DB..::..SymbolicCurveArray
The symbolic curve array to be converted.

Remarks

This operation will create new ModelCurves with the symbolicCurves' geometry curves and delete the SymbolicCurve in the array.

Exceptions

Exception | Condition
System..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
System..::..InvalidOperationException | Thrown when one or more curves could not be successfully converted.

See Also

Document Class


Delete Method

[image] [image]

Revit 2013 API
Document..::..Delete Method
Document Class See Also Send Feedback
Deletes one or more elements from the document.

Overload List

 | Name | Description
Public method | Delete(Element) | Deletes an element from the document.
Public method | Delete(ElementId) | Deletes an element from the document given the id of that element.
Public method | Delete(ICollection<(Of <<'(ElementId>)>>)) | Deletes several elements from the document given their ids.
Public method | Delete(ElementSet) | Obsolete. Deletes several elements from the document.

See Also

Document Class
Document Members


Delete Method (Element)

[image]

Revit 2013 API
Document..::..Delete Method (Element)
Document Class Example See Also Send Feedback
Deletes an element from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    Element element
)
Visual Basic
Public Function Delete ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element that is to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete a selected element.
   ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(element);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit",prompt);

}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Delete a selected element.
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(element)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)

End Sub

See Also

Document Class
Delete Overload


Delete Method (ElementId)

[image]

Revit 2013 API
Document..::..Delete Method (ElementId)
Document Class Example See Also Send Feedback
Deletes an element from the document given the id of that element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ElementId id
)
Visual Basic
Public Function Delete ( _
    id As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The Autodesk::Revit::DB::ElementId^ for the element that is to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the element and any elements that are totally dependent upon that element. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
private void DeleteElement(Autodesk.Revit.DB.Document document, Element element)
{
    // Delete an element via its id
    Autodesk.Revit.DB.ElementId elementId = element.Id;
    ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementId);

    if (0 == deletedIdSet.Count)
    {
        throw new Exception("Deleting the selected element in Revit failed.");
    }

    String prompt = "The selected element has been removed and ";
    prompt += deletedIdSet.Count - 1;
    prompt += " more dependent elements have also been removed.";

    // Give the user some information
    TaskDialog.Show("Revit", prompt);
}
CopyVB.NET
Private Sub DeleteElement(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Delete an element via its id
    Dim elementId As Autodesk.Revit.DB.ElementId = element.Id
    Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementId)

    If 0 = deletedIdSet.Count Then
        Throw New Exception("Deleting the selected element in Revit failed.")
    End If

    Dim prompt As [String] = "The selected element has been removed and "
    prompt += deletedIdSet.Count - 1
    prompt += " more dependent elements have also been removed."

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Document Class
Delete Overload


Delete Method (ICollection(ElementId))

[image]

Revit 2013 API
Document..::..Delete Method (ICollection<(Of <(<'ElementId>)>)>)
Document Class Example See Also Send Feedback
Deletes several elements from the document given their ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Delete(
    ICollection<ElementId> ids
)
Visual Basic
Public Function Delete ( _
    ids As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ Delete(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of element ids.
ICollection<Autodesk.Revit.DB.ElementId> idSelection = null ;
 UIDocument uidoc = new UIDocument(document);
 foreach (Autodesk.Revit.DB.Element elem in uidoc.Selection.Elements)
 {
     Autodesk.Revit.DB.ElementId id = elem.Id;
     idSelection.Add(id);
 }
 ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(idSelection);

 if (0 == deletedIdSet.Count)
 {
     throw new Exception("Deleting the selected elements in Revit failed.");
 }

 TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of element ids.
Dim idSelection As ICollection(Of Autodesk.Revit.DB.ElementId) = Nothing
Dim uidoc As New UIDocument(document)
For Each elem As Autodesk.Revit.DB.Element In uidoc.Selection.Elements
    Dim id As Autodesk.Revit.DB.ElementId = elem.Id
    idSelection.Add(id)
Next
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(idSelection)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload


Delete Method (ElementSet)

[image]

Revit 2013 API
Document..::..Delete Method (ElementSet)
Document Class Example See Also Send Feedback
Deletes several elements from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public ICollection<ElementId> Delete(
    ElementSet elements
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")> _
Public Function Delete ( _
    elements As ElementSet _
) As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call Delete(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId> elementIds) instead.")]
public:
ICollection<ElementId^>^ Delete(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements that are to be deleted.

Return Value

The deleted element id set if the deletion succeeds, or nullNothingnullptra null reference (Nothing in Visual Basic) if the deletion fails.

Remarks

This method will delete the elements and any other elements that are totally dependent upon those elements. Any references to the deleted elements will become invalid and hence cause an exception to be thrown if they are accessed.

Note: in a family document, the predefined elements (those elements inherited from its family template file) can't be deleted by this method.

Examples

CopyC#
// Delete all the selected elements via the set of elements
UIDocument uidoc = new UIDocument(document);
ElementSet elementSet = uidoc.Selection.Elements;
ICollection<Autodesk.Revit.DB.ElementId> deletedIdSet = document.Delete(elementSet);

if (0 == deletedIdSet.Count)
{
    throw new Exception("Deleting the selected elements in Revit failed.");
}

TaskDialog.Show("Revit","The selected element has been removed.");
CopyVB.NET
' Delete all the selected elements via the set of elements
Dim uidoc As New UIDocument(document)
Dim elementSet As ElementSet = uidoc.Selection.Elements
Dim deletedIdSet As ICollection(Of Autodesk.Revit.DB.ElementId) = document.Delete(elementSet)

If 0 = deletedIdSet.Count Then
    Throw New Exception("Deleting the selected elements in Revit failed.")
End If

TaskDialog.Show("Revit", "The selected element has been removed.")

See Also

Document Class
Delete Overload


Dispose Method

[image]

Revit 2013 API
Document..::..Dispose Method
Document Class See Also Send Feedback
Releases all resources used by the Document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Document Class


EditFamily Method

[image]

Revit 2013 API
Document..::..EditFamily Method
Document Class Example See Also Send Feedback
Gets the document of a loaded family to edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document EditFamily(
    Family loadedFamily
)
Visual Basic
Public Function EditFamily ( _
    loadedFamily As Family _
) As Document
Visual C++
public:
Document^ EditFamily(
    Family^ loadedFamily
)

Parameters

loadedFamily
Type: Autodesk.Revit.DB..::..Family
The loaded family in current document.

Return Value

Reference of the document of the family.

Remarks

This creates an independent copy of the family for editing. To apply the changes back to the family stored in the document, use the LoadFamily overload accepting IFamilyLoadOptions.

This method may not be called if the document is currently modifiable (has an open transaction) or is in a read-only state. The method may not be called during dynamic updates. To test the document's current status, check the values of IsModifiable and IsReadOnly properties.

Examples

CopyC#
public void GetLoadedSymbols(Autodesk.Revit.DB.Document document, FamilyInstance familyInstance)
{
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc && familyDoc.IsFamilyDocument == true)
        {
            String loadedFamilies = "FamilySymbols in " + family.Name + ":\n";
            FilteredElementCollector collector = new FilteredElementCollector(document);
            ICollection<Element> collection =
                collector.OfClass(typeof(FamilySymbol)).ToElements();
            foreach (Element e in collection)
            {
                FamilySymbol fs = e as FamilySymbol;
                loadedFamilies += "\t" + fs.Name + "\n";
            }

            TaskDialog.Show("Revit",loadedFamilies);
        }
    }
}
CopyVB.NET
Public Sub GetLoadedSymbols(ByVal document As Autodesk.Revit.DB.Document, ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing AndAlso familyDoc.IsFamilyDocument = True Then
            Dim loadedFamilies As [String] = "FamilySymbols in " + family.Name + ":" & vbLf
            Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
            Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilySymbol)).ToElements()
            For Each e As Autodesk.Revit.DB.Element In collection
                Dim fs As FamilySymbol = TryCast(e, FamilySymbol)
                loadedFamilies += vbTab + fs.Name + vbLf
            Next

            TaskDialog.Show("Revit", loadedFamilies)
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"loadedFamily"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"loadedFamily"-is an in-place family or a non-editable family. (This can be checked with the IsInPlace and IsEditable properties of the Family class.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is already being edited.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this method is called while the document is modifiable (i.e. it has an unfinished transaction.)
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this method is currently in a read-only state.

See Also

Document Class


Equals Method

[image]

Revit 2013 API
Document..::..Equals Method
Document Class See Also Send Feedback
Determines whether the specified Object equals to this Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

Remarks

Two document instances are considered equal if they represent the same document currently opened in the Revit session.

See Also

Document Class


Export Method

[image] [image]

Revit 2013 API
Document..::..Export Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Export(String, String, MassGBXMLExportOptions) | Exports a gbXML file from a mass model document.
Public method | Export(String, String, GBXMLExportOptions) | Exports the document in Green-Building XML format.
Public method | Export(String, String, IFCExportOptions) | Exports the document to the Industry Standard Classes (IFC) format.
Public method | Export(String, String, ViewSet, DWFExportOptions) | Exports the current view or a selection of views in DWF format.
Public method | Export(String, String, ViewSet, DWFXExportOptions) | Exports the current view or a selection of views in DWFX format.
Public method | Export(String, String, ViewSet, FBXExportOptions) | Exports the document in 3D-Studio Max (FBX) format.
Public method | Export(String, String, ViewSet, SATExportOptions) | Exports the current view or a selection of views in SAT format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DGNExportOptions) | Exports a selection of views in DGN format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DWGExportOptions) | Exports a selection of views in DWG format.
Public method | Export(String, String, ICollection<(Of <<'(ElementId>)>>), DXFExportOptions) | Exports a selection of views in DXF format.
Public method | Export(String, String, View3D, ViewPlan, BuildingSiteExportOptions) | Exports the document in the format of Civil Engineering design applications.

See Also

Document Class
Document Members


Export Method (String, String, MassGBXMLExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, MassGBXMLExportOptions)
Document Class See Also Send Feedback
Exports a gbXML file from a mass model document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Export(
    string folder,
    string name,
    MassGBXMLExportOptions options
)
Visual Basic
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As MassGBXMLExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    MassGBXMLExportOptions^ options
)

Parameters

folder
Type: System..::..String
Indicates the path of a folder where to export the gbXML file.
name
Type: System..::..String
Indicates the name of the gbXML file to export. If it doesn't end with ".xml", extension ".xml" will be added automatically. The name cannot contain any of the following characters: \/:*?"<>|. Empty name is not acceptable.
options
Type: Autodesk.Revit.DB.Analysis..::..MassGBXMLExportOptions
Options which control the contents of the export.

Remarks

This is only available for projects containing one or more instances of Conceptual Mass families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The path is not valid for exporting gbXML files. -or- The name is empty or not valid for exporting gbXML files. -or- options object is invalid: There should be at least one Id in MassZoneIds, the MassIds should be for masses without mass floors.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Exporting is not allowed in the current application mode. -or- The weather station name is not valid for exporting gbXML files. -or- Cannot export gbXML files, because the energy model setting is off. -or- Failed to export gbxml files due to internal errors.

See Also

Document Class
Export Overload


Export Method (String, String, GBXMLExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, GBXMLExportOptions)
Document Class See Also Send Feedback
Exports the document in Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    GBXMLExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As GBXMLExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    GBXMLExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::..GBXMLExportOptions
Options applicable to the gbXML format.

Return Value

True if successful, otherwise False.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

See Also

Document Class
Export Overload


Export Method (String, String, IFCExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, IFCExportOptions)
Document Class See Also Send Feedback
Exports the document to the Industry Standard Classes (IFC) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    IFCExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    options As IFCExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    IFCExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder into which the file will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
options
Type: Autodesk.Revit.DB..::..IFCExportOptions
Various options applicable to the IFC format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.

This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The IFCExportOptions FamilyMappingFile does not exist.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | This method may not be called during dynamic update.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. -or- This Document is not a project document.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWFExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ViewSet, DWFExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.
options
Type: Autodesk.Revit.DB..::..DWFExportOptions
Various options applicable to the DWF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic) Thrown when the input views is an empty ViewSet. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not modifiable.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, DWFXExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ViewSet, DWFXExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in DWFX format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    DWFXExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As DWFXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    DWFXExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.
options
Type: Autodesk.Revit.DB..::..DWFXExportOptions
Various options applicable to the DWFX format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input views is an empty ViewSet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not modifiable.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, FBXExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ViewSet, FBXExportOptions)
Document Class See Also Send Feedback
Exports the document in 3D-Studio Max (FBX) format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    FBXExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As FBXExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    FBXExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.Only 3D views are allowed.
options
Type: Autodesk.Revit.DB..::..FBXExportOptions
Options applicable to the FBX format.

Return Value

Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.

Remarks

Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input views is an empty ViewSet. Thrown if any view in the views is not a 3D view.

See Also

Document Class
Export Overload


Export Method (String, String, ViewSet, SATExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ViewSet, SATExportOptions)
Document Class See Also Send Feedback
Exports the current view or a selection of views in SAT format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Export(
    string folder,
    string name,
    ViewSet views,
    SATExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ViewSet, _
    options As SATExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ViewSet^ views,
    SATExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used.
views
Type: Autodesk.Revit.DB..::..ViewSet
Selection of views to be exported.
options
Type: Autodesk.Revit.DB..::..SATExportOptions
Various options applicable to the SAT format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic) Thrown when the input views is an empty ViewSet. It can be assured by checking the CanBePrinted property of each view.

See Also

Document Class
Export Overload


Export Method (String, String, ICollection(ElementId), DGNExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DGNExportOptions)
Document Class See Also Send Feedback
Exports a selection of views in DGN format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DGNExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DGNExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DGNExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters -or- non empty list of views must be provided -or- some of the views is not printable(exportable) -or- Thrown when the options in DGNExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, ICollection(ElementId), DWGExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DWGExportOptions)
Document Class See Also Send Feedback
Exports a selection of views in DWG format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DWGExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DWGExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DWGExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DWGExportOptions
Various options applicable to the DWG format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters -or- non empty list of views must be provided -or- some of the views is not printable(exportable) -or- Thrown when the options in DWGExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, ICollection(ElementId), DXFExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, ICollection<(Of <(<'ElementId>)>)>, DXFExportOptions)
Document Class See Also Send Feedback
Exports a selection of views in DXF format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    ICollection<ElementId> views,
    DXFExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    views As ICollection(Of ElementId), _
    options As DXFExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    ICollection<ElementId^>^ views,
    DXFExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
name
Type: System..::..String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
views
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
options
Type: Autodesk.Revit.DB..::..DXFExportOptions
Various options applicable to the DXF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters -or- non empty list of views must be provided -or- some of the views is not printable(exportable) -or- Thrown when the options in DWGExportOptions is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the directory does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DXF module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit.

See Also

Document Class
Export Overload


Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)

[image]

Revit 2013 API
Document..::..Export Method (String, String, View3D, ViewPlan, BuildingSiteExportOptions)
Document Class See Also Send Feedback
Exports the document in the format of Civil Engineering design applications.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Export(
    string folder,
    string name,
    View3D view,
    ViewPlan grossAreaPlan,
    BuildingSiteExportOptions options
)
Visual Basic
Public Function Export ( _
    folder As String, _
    name As String, _
    view As View3D, _
    grossAreaPlan As ViewPlan, _
    options As BuildingSiteExportOptions _
) As Boolean
Visual C++
public:
bool Export(
    String^ folder,
    String^ name,
    View3D^ view,
    ViewPlan^ grossAreaPlan,
    BuildingSiteExportOptions^ options
)

Parameters

folder
Type: System..::..String
Output folder, into which file will be exported. The folder must exist.
name
Type: System..::..String
The name for the exported civil file. If nullNothingnullptra null reference (Nothing in Visual Basic) or empty, automatic naming will be used."
view
Type: Autodesk.Revit.DB..::..View3D
3D View to be exported.
grossAreaPlan
Type: Autodesk.Revit.DB..::..ViewPlan
All the areas on the view plan will be exported, it must be 'Gross Building' area plan. It must not be nullNothingnullptra null reference (Nothing in Visual Basic). To check whether its area scheme is Gross Building, use IsGrossBuildingArea property of AreaScheme.
options
Type: Autodesk.Revit.DB..::..BuildingSiteExportOptions
Various options applicable to the format of Civil Engineering design applications. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input view or grossAreaPlan is nullNothingnullptra null reference (Nothing in Visual Basic)
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when folder is null or empty.Thrown when name is not valid.Thrown when grossAreaPlan is not a valid element.Thrown when grossAreaPlan is not a Gross Building Area Plan.
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException | Thrown when the folder does not exist

See Also

Document Class
Export Overload


ExportImage Method

[image]

Revit 2013 API
Document..::..ExportImage Method
Document Class See Also Send Feedback
Exports a view or set of views into an image file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ExportImage(
    ImageExportOptions options
)
Visual Basic
Public Sub ExportImage ( _
    options As ImageExportOptions _
)
Visual C++
public:
void ExportImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
The options which govern the image export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileAccessException | The path indicated could not be accessed.
Autodesk.Revit.Exceptions..::..FileNotFoundException | The path indicated could not be found.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Exporting is not allowed in the current application mode. -or- Failed to export image due to an error with the inputs. -or- Failed to export image due to an issue where the DirectX Device was lost.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The Graphics module is not available in the installed Revit.

See Also

Document Class


FindReferencesWithContextByDirection Method

[image]

Revit 2013 API
Document..::..FindReferencesWithContextByDirection Method
Document Class See Also Send Feedback
Finds the references that intersect a line extended in a certain direction from an origin point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ReferenceWithContext> FindReferencesWithContextByDirection(
    XYZ pOrigin,
    XYZ pDirection,
    View3D pView
)
Visual Basic
Public Function FindReferencesWithContextByDirection ( _
    pOrigin As XYZ, _
    pDirection As XYZ, _
    pView As View3D _
) As IList(Of ReferenceWithContext)
Visual C++
public:
IList<ReferenceWithContext^>^ FindReferencesWithContextByDirection(
    XYZ^ pOrigin,
    XYZ^ pDirection,
    View3D^ pView
)

Parameters

pOrigin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the line.
pDirection
Type: Autodesk.Revit.DB..::..XYZ
The direction.
pView
Type: Autodesk.Revit.DB..::..View3D
The 3D view used to determine the geometry for intersection. If the view has specific geometry (section cuts, visibility changes due to detail level or hidden categories) this will affect the results.

Return Value

An array of references for items the line intersects with the context information.

Remarks

This method finds both elements and geometric references which intersect the ray. Some element references returned will not have a corresponding geometric object which is also intersected (for example, rays passing through openings in walls will intersect the wall and the opening element). If you are interested only in true physical intersections you should discard all references whose GeometryObject is of type Element.

References will be found and returned from either the positive or negative direction along the line. Use the reference's ProximityParameter to sort the results or exclude references found in the opposite direction to the given direction.

This method will return intersections encountered only in the main document. Intersections in linked files will not be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when pOrigin, pDirection or pView is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class


GetDocumentPreviewSettings Method

[image]

Revit 2013 API
Document..::..GetDocumentPreviewSettings Method
Document Class See Also Send Feedback
Returns the preview settings for the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DocumentPreviewSettings GetDocumentPreviewSettings()
Visual Basic
Public Function GetDocumentPreviewSettings As DocumentPreviewSettings
Visual C++
public:
DocumentPreviewSettings^ GetDocumentPreviewSettings()

Return Value

The preview settings.

See Also

Document Class


GetElement Method

[image] [image]

Revit 2013 API
Document..::..GetElement Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetElement(String) | Gets the Element referenced by the input string name.
Public method | GetElement(ElementId) | Gets the Element referenced by the input string name.
Public method | GetElement(Reference) | Gets the Element referenced by the input reference.

See Also

Document Class
Document Members


GetElement Method (String)

[image]

Revit 2013 API
Document..::..GetElement Method (String)
Document Class See Also Send Feedback
Gets the Element referenced by the input string name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Element GetElement(
    string name
)
Visual Basic
Public Function GetElement ( _
    name As String _
) As Element
Visual C++
public:
Element^ GetElement(
    String^ name
)

Parameters

name
Type: System..::..String
The element name, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input string doesn't reference to a valid Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class
GetElement Overload


GetElement Method (ElementId)

[image]

Revit 2013 API
Document..::..GetElement Method (ElementId)
Document Class See Also Send Feedback
Gets the Element referenced by the input string name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Element GetElement(
    ElementId id
)
Visual Basic
Public Function GetElement ( _
    id As ElementId _
) As Element
Visual C++
public:
Element^ GetElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input ElementId doesn't reference to a valid Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class
GetElement Overload


GetElement Method (Reference)

[image]

Revit 2013 API
Document..::..GetElement Method (Reference)
Document Class See Also Send Feedback
Gets the Element referenced by the input reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Element GetElement(
    Reference reference
)
Visual Basic
Public Function GetElement ( _
    reference As Reference _
) As Element
Visual C++
public:
Element^ GetElement(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The reference, whose referenced Element will be retrieved from the model.

Return Value

The element referenced by the input argument.

Remarks

nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if the input reference doesn't reference to a valid Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class
GetElement Overload


GetHashCode Method

[image]

Revit 2013 API
Document..::..GetHashCode Method
Document Class See Also Send Feedback
Gets the hash code of this document instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Remarks

The hash code is the same for document instances that represent the same document currently opened in the Revit session. The hash code is generated when a Revit file is opened or created in session. If the same Revit file is opened later (in the same session or a different session) the hash code will not be the same.

See Also

Document Class


GetPrintSettingIds Method

[image]

Revit 2013 API
Document..::..GetPrintSettingIds Method
Document Class See Also Send Feedback
Retrieves all Print Settings of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetPrintSettingIds()
Visual Basic
Public Function GetPrintSettingIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetPrintSettingIds()

Return Value

The ElementIds of all print setting elements

See Also

Document Class


GetRoomAtPoint Method

[image] [image]

Revit 2013 API
Document..::..GetRoomAtPoint Method
Document Class See Also Send Feedback
Gets a room containing the point.

Overload List

 | Name | Description
Public method | GetRoomAtPoint(XYZ) | Gets a room containing the point.
Public method | GetRoomAtPoint(XYZ, Phase) | Gets a room containing the point.

See Also

Document Class
Document Members


GetRoomAtPoint Method (XYZ)

[image]

Revit 2013 API
Document..::..GetRoomAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point
)
Visual Basic
Public Function GetRoomAtPoint ( _
    point As XYZ _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Return Value

The room containing the point.

Remarks

Surveys only the rooms from the final phase of the project. The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetRoomAtPoint Method (XYZ, Phase)

[image]

Revit 2013 API
Document..::..GetRoomAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a room containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room GetRoomAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic
Public Function GetRoomAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Room
Visual C++
public:
Room^ GetRoomAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::..Phase
Phase in which the room exists.

Return Value

The room containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the room of the last phase.The first one found will be returned. If there is no room containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetRoomAtPoint Overload


GetSpaceAtPoint Method

[image] [image]

Revit 2013 API
Document..::..GetSpaceAtPoint Method
Document Class See Also Send Feedback
Gets a space containing the point.

Overload List

 | Name | Description
Public method | GetSpaceAtPoint(XYZ) | Gets a space containing the point.
Public method | GetSpaceAtPoint(XYZ, Phase) | Gets a space containing the point.

See Also

Document Class
Document Members


GetSpaceAtPoint Method (XYZ)

[image]

Revit 2013 API
Document..::..GetSpaceAtPoint Method (XYZ)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point
)
Visual Basic
Public Function GetSpaceAtPoint ( _
    point As XYZ _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Return Value

The space containing the point.

Remarks

Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


GetSpaceAtPoint Method (XYZ, Phase)

[image]

Revit 2013 API
Document..::..GetSpaceAtPoint Method (XYZ, Phase)
Document Class See Also Send Feedback
Gets a space containing the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space GetSpaceAtPoint(
    XYZ point,
    Phase phase
)
Visual Basic
Public Function GetSpaceAtPoint ( _
    point As XYZ, _
    phase As Phase _
) As Space
Visual C++
public:
Space^ GetSpaceAtPoint(
    XYZ^ point,
    Phase^ phase
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
phase
Type: Autodesk.Revit.DB..::..Phase
Phase in which the space exists.

Return Value

The space containing the point.

Remarks

If phase is nullNothingnullptra null reference (Nothing in Visual Basic), it will get the space of the last phase.The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue.

See Also

Document Class
GetSpaceAtPoint Overload


GetWorksetId Method

[image]

Revit 2013 API
Document..::..GetWorksetId Method
Document Class See Also Send Feedback
Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WorksetId GetWorksetId(
    ElementId id
)
Visual Basic
Public Function GetWorksetId ( _
    id As ElementId _
) As WorksetId
Visual C++
public:
WorksetId^ GetWorksetId(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
Id of the element.

Return Value

Id of the Workset which owns the element.

Remarks

Each element belongs to one and only one workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class


GetWorksetTable Method

[image]

Revit 2013 API
Document..::..GetWorksetTable Method
Document Class See Also Send Feedback
Get the WorksetTable of this document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WorksetTable GetWorksetTable()
Visual Basic
Public Function GetWorksetTable As WorksetTable
Visual C++
public:
WorksetTable^ GetWorksetTable()

Return Value

The WorksetTable of this document.

Remarks

There is one WorksetTable for each document. There will be at least one workset in the table, even if sharing has not yet been enabled for this document.

See Also

Document Class


GetWorksharingCentralModelPath Method

[image]

Revit 2013 API
Document..::..GetWorksharingCentralModelPath Method
Document Class See Also Send Feedback
Gets the central model path of the worksharing model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ModelPath GetWorksharingCentralModelPath()
Visual Basic
Public Function GetWorksharingCentralModelPath As ModelPath
Visual C++
public:
ModelPath^ GetWorksharingCentralModelPath()

Return Value

The central model path, or null if the document is not workshared.

See Also

Document Class


Import Method

[image] [image]

Revit 2013 API
Document..::..Import Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Import(String, GBXMLImportOptions) | Imports a Green-Building XML file into the document.
Public method | Import(String, DGNImportOptions, View, ElementId%) | Imports a DGN file to the document.
Public method | Import(String, DWGImportOptions, View, ElementId%) | Imports a DWG or DXF file to the document.
Public method | Import(String, ImageImportOptions, View, Element%) | Imports an image (a bitmap) into the document.

See Also

Document Class
Document Members


Import Method (String, GBXMLImportOptions)

[image]

Revit 2013 API
Document..::..Import Method (String, GBXMLImportOptions)
Document Class See Also Send Feedback
Imports a Green-Building XML file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Import(
    string file,
    GBXMLImportOptions options
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As GBXMLImportOptions _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    GBXMLImportOptions^ options
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::..GBXMLImportOptions
Various options applicable to GBXml import. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.

Return Value

True if successful, otherwise False.

Remarks

This method is available only in MEP. Though the 'options' argument is not currently used, an object still must be provided (may be nullNothingnullptra null reference (Nothing in Visual Basic)). The method will return False if not succeed. e.g when the input xml file does not contain any result elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when file argument is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..FileNotFoundException | Thrown when the file specified does not exist.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when no file is specified or if the file is not a valid gbXML file or does not contain any result elements.

See Also

Document Class
Import Overload


Import Method (String, DGNImportOptions, View, ElementId)

[image]

Revit 2013 API
Document..::..Import Method (String, DGNImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Imports a DGN file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Import(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As DGNImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid DGN file.
options
Type: Autodesk.Revit.DB..::..DGNImportOptions
Various options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
The view into which the file will be imported.
elementId
Type: Autodesk.Revit.DB..::..ElementId%
The id of imported instance after a successful import.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters -or- Visible layer only option must be set to false for DGN import
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, DWGImportOptions, View, ElementId)

[image]

Revit 2013 API
Document..::..Import Method (String, DWGImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Imports a DWG or DXF file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Import(
    string file,
    DWGImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As DWGImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    DWGImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist and must be a valid DWG or DXF file.
options
Type: Autodesk.Revit.DB..::..DWGImportOptions
Various options applicable to the DWG or DXF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
The view into which the file wil be imported.
elementId
Type: Autodesk.Revit.DB..::..ElementId%
The id of imported instance after a successful import.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view -or- One or more strings describing layer selection is invalid or empty. -or- The array of line weights is not valid; either it contains less than expected 255 values, or one or more values are out of range 1 to 16 -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.

See Also

Document Class
Import Overload


Import Method (String, ImageImportOptions, View, Element)

[image]

Revit 2013 API
Document..::..Import Method (String, ImageImportOptions, View, Element%)
Document Class See Also Send Feedback
Imports an image (a bitmap) into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Import(
    string file,
    ImageImportOptions options,
    View view,
    out Element element
)
Visual Basic
Public Function Import ( _
    file As String, _
    options As ImageImportOptions, _
    view As View, _
    <OutAttribute> ByRef element As Element _
) As Boolean
Visual C++
public:
bool Import(
    String^ file,
    ImageImportOptions^ options,
    View^ view,
    [OutAttribute] Element^% element
)

Parameters

file
Type: System..::..String
Full path of the file to import. File must exist.
options
Type: Autodesk.Revit.DB..::..ImageImportOptions
Various options applicable to an image. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
view
Type: Autodesk.Revit.DB..::..View
The view into which the image is going to be imported.
element
Type: Autodesk.Revit.DB..::..Element%
The imported instance after a successful import. It could be used for further manipulating of that instance.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if view is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
Import Overload


Link Method

[image] [image]

Revit 2013 API
Document..::..Link Method
Document Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Link(String, DGNImportOptions, View, ElementId%) | Links a DGN file to the document.
Public method | Link(String, DWGImportOptions, View, ElementId%) | Links a DWG or DXF file to the document.

See Also

Document Class
Document Members


Link Method (String, DGNImportOptions, View, ElementId)

[image]

Revit 2013 API
Document..::..Link Method (String, DGNImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Links a DGN file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Link(
    string file,
    DGNImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As DGNImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Link(
    String^ file,
    DGNImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid DGN file.
options
Type: Autodesk.Revit.DB..::..DGNImportOptions
Various import options applicable to the DGN format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
The view into which the file will be linked.
elementId
Type: Autodesk.Revit.DB..::..ElementId%
The id of linked instance after a successful link.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DGN import (.dgn files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view -or- One or more strings describing layer selection is invalid or empty. -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable. -or- Empty DGN model view name characters -or- Visible layer only option must be set to false for DGN import
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DGN Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


Link Method (String, DWGImportOptions, View, ElementId)

[image]

Revit 2013 API
Document..::..Link Method (String, DWGImportOptions, View, ElementId%)
Document Class See Also Send Feedback
Links a DWG or DXF file to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Link(
    string file,
    DWGImportOptions options,
    View pDBView,
    out ElementId elementId
)
Visual Basic
Public Function Link ( _
    file As String, _
    options As DWGImportOptions, _
    pDBView As View, _
    <OutAttribute> ByRef elementId As ElementId _
) As Boolean
Visual C++
public:
bool Link(
    String^ file,
    DWGImportOptions^ options,
    View^ pDBView,
    [OutAttribute] ElementId^% elementId
)

Parameters

file
Type: System..::..String
Full path of the file to link. File must exist and must be a valid DWG or DXF file.
options
Type: Autodesk.Revit.DB..::..DWGImportOptions
Various import options applicable to the DWG or DXF format. If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
pDBView
Type: Autodesk.Revit.DB..::..View
The view into which the file will be linked.
elementId
Type: Autodesk.Revit.DB..::..ElementId%
The id of linked instance after a successful link.

Return Value

True if successful, otherwise False.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view -or- One or more strings describing layer selection is invalid or empty. -or- The array of line weights is not valid; either it contains less than expected 255 values, or one or more values are out of range 1 to 16 -or- The scale is not valid as a CustomScale for use during import. -or- NullOrEmpty -or- The view is not printable.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Import is temporarily disabled.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException | The DWG Import/Link module is not available in the installed Revit.

See Also

Document Class
Link Overload


LoadFamily Method

[image] [image]

Revit 2013 API
Document..::..LoadFamily Method
Document Class See Also Send Feedback
Loads a family and all its types/symbols.

Overload List

 | Name | Description
Public method | LoadFamily(String) | Loads an entire family and all its types/symbols into the document.
Public method | LoadFamily(Document) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.
Public method | LoadFamily(Document, IFamilyLoadOptions) | Loads the contents of this family document into another document.
Public method | LoadFamily(String, IFamilyLoadOptions, Family%) | Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

See Also

Document Class
Document Members


LoadFamily Method (String)

[image]

Revit 2013 API
Document..::..LoadFamily Method (String)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename
)
Visual Basic
Public Function LoadFamily ( _
    filename As String _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (Document)

[image]

Revit 2013 API
Document..::..LoadFamily Method (Document)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument
)
Visual Basic
Public Function LoadFamily ( _
    targetDocument As Document _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::..Document
The target document where the family will be loaded.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, this method will always fail. This is because this method automatically suppresses the prompts Revit typically uses to deal with conflicts between families, and assumes that any such conflict should prevent the loading. If you want to be able to reload the same family into the source document, you should use the LoadFamily overload accepting IFamilyLoadOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"targetDocument"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not a family document, or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed), or when this family was found in the target document already and the conflict caused an automatic abort of the load operation, or when a shared family in this family was found in the target document already and the conflict caused an automatic abort of the load operation, or this document is currently in a read-only state.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, Family)

[image]

Revit 2013 API
Document..::..LoadFamily Method (String, Family%)
Document Class Example See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool LoadFamily(
    string filename,
    out Family family
)
Visual Basic
Public Function LoadFamily ( _
    filename As String, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
family
Type: Autodesk.Revit.DB..::..Family%
A reference to the family that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Examples

CopyC#
// Get the Revit library path as defined via the Options dialog - File Locations tab - Places button
string libraryPath = "";
application.Application.GetLibraryPaths().TryGetValue("Imperial Library", out libraryPath);

if (String.IsNullOrEmpty(libraryPath))
{
    libraryPath = "c:\\";   // If not have, use a default path.
}

// Allow the user to select a family file.
OpenFileDialog openFileDialog1 = new OpenFileDialog();
openFileDialog1.InitialDirectory = libraryPath;
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa";

// Load the family file using LoadFamily method and then give information.
if (DialogResult.OK == openFileDialog1.ShowDialog())
{
    Autodesk.Revit.DB.Family family = null;
    if (document.LoadFamily(openFileDialog1.FileName, out family))
    {
        String name = family.Name;
        TaskDialog.Show("Revit","Family file has been loaded. Its name is " + name);
    }
    else
    {
        TaskDialog.Show("Revit","Can't load the family file.");
    }
}
CopyVB.NET
' Get the Revit library path.
Dim libraryPath As [String] = application.Application.LibraryPaths.Item("Imperial Library")
If [String].IsNullOrEmpty(libraryPath) Then
    ' If not have, use a default path.
    libraryPath = "c:\"
End If

' Allow the user to select a family file.
Dim openFileDialog1 As New OpenFileDialog()
openFileDialog1.InitialDirectory = libraryPath
openFileDialog1.Filter = "Family Files (*.rfa)|*.rfa"

' Load the family file using LoadFamily method and then give information.
If DialogResult.OK = openFileDialog1.ShowDialog() Then
    Dim family As Autodesk.Revit.DB.Family = Nothing
    If document.LoadFamily(openFileDialog1.FileName, family) Then
        Dim name As [String] = family.Name
        TaskDialog.Show("Revit", "Family file has been loaded. Its name is " + name)
    Else
        TaskDialog.Show("Revit", "Can't load the family file.")
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (Document, IFamilyLoadOptions)

[image]

Revit 2013 API
Document..::..LoadFamily Method (Document, IFamilyLoadOptions)
Document Class See Also Send Feedback
Loads the contents of this family document into another document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Family LoadFamily(
    Document targetDocument,
    IFamilyLoadOptions familyLoadOptions
)
Visual Basic
Public Function LoadFamily ( _
    targetDocument As Document, _
    familyLoadOptions As IFamilyLoadOptions _
) As Family
Visual C++
public:
Family^ LoadFamily(
    Document^ targetDocument,
    IFamilyLoadOptions^ familyLoadOptions
)

Parameters

targetDocument
Type: Autodesk.Revit.DB..::..Document
The target document which the family will be loaded into.
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when responding to conflicts during the load operation.

Return Value

Reference of the family in the target document.

Remarks

If you are reloading an edited family back into the source document from which it was extracted, use this overload. This is because this overload allows you to respond to possible conflicts due to families already being present in the target document. The Revit API offers one automatic overload: RevitUIFamilyLoadOptions, which will show the same prompts to the user as seen during an interactive load.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"targetDocument" or "familyLoadOptions"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is not a family document, or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed), or the load was cancelled due to a conflict and a False return from one of the interface methods, or this document is currently in a read-only state.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
LoadFamily Overload


LoadFamily Method (String, IFamilyLoadOptions, Family)

[image]

Revit 2013 API
Document..::..LoadFamily Method (String, IFamilyLoadOptions, Family%)
Document Class See Also Send Feedback
Loads an entire family and all its types/symbols into the document and provides a reference to the loaded family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool LoadFamily(
    string filename,
    IFamilyLoadOptions familyLoadOptions,
    out Family family
)
Visual Basic
Public Function LoadFamily ( _
    filename As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef family As Family _
) As Boolean
Visual C++
public:
bool LoadFamily(
    String^ filename,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] Family^% family
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
family
Type: Autodesk.Revit.DB..::..Family%
A reference to the family that was loaded if successful, otherwise Nothing.

Return Value

True if the entire family was loaded successfully into the project, otherwise False.

Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use LoadFamilySymbol and only load those symbols that you need. The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument "familyLoadOptions" is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Document Class
LoadFamily Overload


LoadFamilySymbol Method

[image] [image]

Revit 2013 API
Document..::..LoadFamilySymbol Method
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Overload List

 | Name | Description
Public method | LoadFamilySymbol(String, String) | Loads only a specified family type/symbol from a family file into the document.
Public method | LoadFamilySymbol(String, String, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.
Public method | LoadFamilySymbol(String, String, IFamilyLoadOptions, FamilySymbol%) | Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

See Also

Document Class
Document Members


LoadFamilySymbol Method (String, String)

[image]

Revit 2013 API
Document..::..LoadFamilySymbol Method (String, String)
Document Class See Also Send Feedback
Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, FamilySymbol)

[image]

Revit 2013 API
Document..::..LoadFamilySymbol Method (String, String, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol%
A reference to the family symbol that was loaded if successful, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol)

[image]

Revit 2013 API
Document..::..LoadFamilySymbol Method (String, String, IFamilyLoadOptions, FamilySymbol%)
Document Class See Also Send Feedback
Loads only the specified family type/symbol from a family file into the document and provides a reference to the loaded family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool LoadFamilySymbol(
    string filename,
    string name,
    IFamilyLoadOptions familyLoadOptions,
    out FamilySymbol symbol
)
Visual Basic
Public Function LoadFamilySymbol ( _
    filename As String, _
    name As String, _
    familyLoadOptions As IFamilyLoadOptions, _
    <OutAttribute> ByRef symbol As FamilySymbol _
) As Boolean
Visual C++
public:
bool LoadFamilySymbol(
    String^ filename,
    String^ name,
    IFamilyLoadOptions^ familyLoadOptions,
    [OutAttribute] FamilySymbol^% symbol
)

Parameters

filename
Type: System..::..String
The fully qualified filename of the Family file, usually ending in .rfa.
name
Type: System..::..String
The name of the type/symbol to be loaded, such as "W11x14".
familyLoadOptions
Type: Autodesk.Revit.DB..::..IFamilyLoadOptions
The interface implementation to use when loading a family into the document.
symbol
Type: Autodesk.Revit.DB..::..FamilySymbol%
A reference to the family symbol that was loaded if successful, otherwise Nothing.

Return Value

True if the family type/symbol was loaded successfully into the project, otherwise False.

Remarks

The path to the installed Autodesk Revit family files can be found by using the Application.Options object and its methods. The name of the family type/symbol is the same name as returned by the Name property on the FamilySymbol object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when filename or name is nullNothingnullptra null reference (Nothing in Visual Basic) or empty.

See Also

Document Class
LoadFamilySymbol Overload


PostFailure Method

[image]

Revit 2013 API
Document..::..PostFailure Method
Document Class Example See Also Send Feedback
Posts a failure to be displayed to the user at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessageKey PostFailure(
    FailureMessage failure
)
Visual Basic
Public Function PostFailure ( _
    failure As FailureMessage _
) As FailureMessageKey
Visual C++
public:
FailureMessageKey^ PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
The failure to be posted.

Return Value

A unique key that identifies posted failure message in a document. If exactly the same error is posted more than once, and not removed between the postings, returned key will be the same every time.

Remarks

If code inside transaction detects a problem that needs to be communicated to the user, it should report these conditions via this method. Failures will be validated and possibly resolved at the end of transaction. Warnings posted via this method will not be stored in the document after they are resolved. A unique key returned by postFailure can be stored for the lifetime of transaction and used to remove failure message if it is no longer relevant.

Examples

CopyC#
// Execute function for an Updater triggered when new FamilyInstances are added
public void Execute(UpdaterData data)
{
    Document doc = data.GetDocument();
    Autodesk.Revit.ApplicationServices.Application app = doc.Application;
    foreach (ElementId id in data.GetModifiedElementIds())
    {
        FamilyInstance fi = doc.GetElement(id) as FamilyInstance;
        if (fi.StructuralType == StructuralType.Beam)
        {
            AnalyticalModel analyticalModel = fi.GetAnalyticalModel();
            if (analyticalModel.IsSingleCurve() == true)
            {
                Curve beamCurve = analyticalModel.GetCurve();
                // enforce beam length minimum of 12 inches
                if (beamCurve.Length < 12.0)
                {
                    FailureMessage failMessage =
                        new FailureMessage(BuiltInFailures.CurveFailures.TooShort);
                    failMessage.SetFailingElement(id);
                    doc.PostFailure(failMessage);
                }
            }
        }
    }
}
CopyVB.NET
' Execute function for an Updater triggered when new FamilyInstances are added
Public Sub Execute(ByVal data As UpdaterData) Implements IUpdater.Execute
    Dim doc As Document = data.GetDocument()
    Dim app As Autodesk.Revit.ApplicationServices.Application = doc.Application
    For Each id As ElementId In data.GetModifiedElementIds()
        Dim fi As Autodesk.Revit.DB.FamilyInstance = TryCast(doc.GetElement(id), Autodesk.Revit.DB.FamilyInstance)
        If fi.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Beam Then
            Dim analyticalModel As Autodesk.Revit.DB.Structure.AnalyticalModel = fi.GetAnalyticalModel()
            If analyticalModel.IsSingleCurve() = True Then
                Dim beamCurve As Curve = analyticalModel.GetCurve()
                ' enforce beam length minimum of 12 inches
                If beamCurve.Length < 12 Then
                    Dim failMessage As New FailureMessage(BuiltInFailures.CurveFailures.TooShort)
                    failMessage.SetFailingElement(id)
                    doc.PostFailure(failMessage)
                End If
            End If
        End If
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Print Method

[image] [image]

Revit 2013 API
Document..::..Print Method
Document Class See Also Send Feedback
Prints a set of views.

Overload List

 | Name | Description
Public method | Print(ViewSet) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View) | Prints a set of views with a specified view template and default print settings.
Public method | Print(ViewSet, Boolean) | Prints a set of views with default view template and default print settings.
Public method | Print(ViewSet, View, Boolean) | Prints a set of views with a specified view template and default print settings.

See Also

Document Class
Document Members


Print Method (ViewSet)

[image]

Revit 2013 API
Document..::..Print Method (ViewSet)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    ViewSet views
)
Visual Basic
Public Sub Print ( _
    views As ViewSet _
)
Visual C++
public:
void Print(
    ViewSet^ views
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, View)

[image]

Revit 2013 API
Document..::..Print Method (ViewSet, View)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate
)
Visual Basic
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the set of views.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, Boolean)

[image]

Revit 2013 API
Document..::..Print Method (ViewSet, Boolean)
Document Class See Also Send Feedback
Prints a set of views with default view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    views As ViewSet, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Print Method (ViewSet, View, Boolean)

[image]

Revit 2013 API
Document..::..Print Method (ViewSet, View, Boolean)
Document Class See Also Send Feedback
Prints a set of views with a specified view template and default print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    ViewSet views,
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    views As ViewSet, _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    ViewSet^ views,
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

views
Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the set of views.
useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the current print setting, otherwise with the print setting of the document of the view.

Remarks

If one view in the set can not be printed successfully then an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when at least one view from the view set could not be printed.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler.

See Also

Document Class
Print Overload


Regenerate Method

[image]

Revit 2013 API
Document..::..Regenerate Method
Document Class Example See Also Send Feedback
Updates the elements in the Revit document to reflect all changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Regenerate()
Visual Basic
Public Sub Regenerate
Visual C++
public:
void Regenerate()

Remarks

Use this method to force update to the document after a group of changes. Note that when a transaction is committed there is an automatic call to regenerate the document.

Examples

CopyC#
FamilyInstance instance = doc.Create.NewFamilyInstance(new XYZ(15, 20, 0), familySymbol, StructuralType.NonStructural);
FamilyInstance instance2 = doc.Create.NewFamilyInstance(new XYZ(25, 30, 0), familySymbol, StructuralType.NonStructural);
// faster to create multiple instances without calling Regenerate after each one

LocationPoint point = instance.Location as LocationPoint;
// this data is incorrect because the new geometry has not yet been regenerated

doc.Regenerate();
point = instance.Location as LocationPoint;
// now it is correct

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..RegenerationFailedException Thrown when the regeneration option is automatic or the operation fails.
  • If regeneration fails, there is posted error of severity DocumentCorruption that will be delivered to the end user at the end of transaction explaining what specifically has happened.
  • If regeneration has failed, document is corrupted and even reading from it is illegal.
  • Code that called regeneration and got this exception should not catch and ignore it - instead, it should do nothing but internal cleanup and return control to the owner of currently active transaction/subtransaction, which must be aborted.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Modification of the document is forbidden. Typically, this is because there is no open transaction; consult documentation for Document.IsModified for other possible causes.

See Also

Document Class


Save Method

[image] [image]

Revit 2013 API
Document..::..Save Method
Document Class See Also Send Feedback
Saves the document.

Overload List

 | Name | Description
Public method | Save()()()() | Saves the document.
Public method | Save(SaveOptions) | Saves the document.

See Also

Document Class
Document Members


Save Method

[image]

Revit 2013 API
Document..::..Save Method
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Save()
Visual Basic
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails. Also returns False if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, True is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

If the document was created in this current session and has not been saved to a file yet, it needs to be first saved using the SaveAs method instead.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if the PathName is not set yet. Thrown if the saving target file is read only.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Save Overload


Save Method (SaveOptions)

[image]

Revit 2013 API
Document..::..Save Method (SaveOptions)
Document Class See Also Send Feedback
Saves the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Save(
    SaveOptions options
)
Visual Basic
Public Function Save ( _
    options As SaveOptions _
) As Boolean
Visual C++
public:
bool Save(
    SaveOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..SaveOptions
Options which govern the save operation.

Return Value

False if save operation fails. Also returns False if saving is cancelled by an external application during 'DocumentSaving' event. When function succeeds, True is returned.

Remarks

The trial version of Revit doesn't support this function. If the user tries to call this function in a trial version, InvalidOperationException will be thrown.

If the document was created in this current session and has not been saved to a file yet, it needs to be first saved using the SaveAs method instead.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if the PathName is not set yet. Thrown if the saving target file is read only.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if options.PreviewViewId is invalid for generating a preview.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
Save Overload


SaveAs Method

[image] [image]

Revit 2013 API
Document..::..SaveAs Method
Document Class See Also Send Feedback
Saves the document to a new file name.

Overload List

 | Name | Description
Public method | SaveAs(String) | Saves the document to a given file name.
Public method | SaveAs(String, SaveAsOptions) | Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.

See Also

Document Class
Document Members


SaveAs Method (String)

[image]

Revit 2013 API
Document..::..SaveAs Method (String)
Document Class See Also Send Feedback
Saves the document to a given file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName
)
Visual Basic
Public Function SaveAs ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
File name to be saved as. Either a relative or absolute path can be provided.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

The document's title in the Revit's title bar will be updated automatically to reflect the file's new location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if there is an existing file with the same fileName.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the specified fileName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the specified fileName is an empty string. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters).
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload


SaveAs Method (String, SaveAsOptions)

[image]

Revit 2013 API
Document..::..SaveAs Method (String, SaveAsOptions)
Document Class Example See Also Send Feedback
Saves the document to a given file name with options to change the document's name in Revit and overwrite an existing file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string fileName,
    SaveAsOptions options
)
Visual Basic
Public Function SaveAs ( _
    fileName As String, _
    options As SaveAsOptions _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ fileName,
    SaveAsOptions^ options
)

Parameters

fileName
Type: System..::..String
File name and path to be saved as. Either a relative or absolute path can be provided.
options
Type: Autodesk.Revit.DB..::..SaveAsOptions
Options which govern the SaveAs operation.

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.Event handlers are not allowed to save document that are currently in modifiable state.

Examples

CopyC#
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate plan view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(ViewPlan));

Func<ViewPlan, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

ViewPlan viewForPreview = collector.OfType<ViewPlan>().First<ViewPlan>(isValidForPreview);

// Save the document
SaveAsOptions options = new SaveAsOptions();
options.PreviewViewId = viewForPreview.Id;

document.SaveAs(@"c:\renamed_family.rfa", options);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown if the specified fileName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the specified fileName is an empty string. Thrown if the specified fileName is invalid (for example, a string that contains the invalid characters). Thrown if options.PreviewViewId is invalid for generating a preview.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document. Thrown if overwriteExistingFile is 'false' but there is an existing file with the same fileName. Thrown if overwriteExistingFile is 'true' but the saving target file is read only.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Document Class
SaveAs Overload


SaveToProjectAsImage Method

[image]

Revit 2013 API
Document..::..SaveToProjectAsImage Method
Document Class See Also Send Feedback
Creates an image view from the currently active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId SaveToProjectAsImage(
    ImageExportOptions options
)
Visual Basic
Public Function SaveToProjectAsImage ( _
    options As ImageExportOptions _
) As ElementId
Visual C++
public:
ElementId^ SaveToProjectAsImage(
    ImageExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
The options which govern the image creation.

Return Value

Id of the newly created view if the operation succeeded, invalid element id otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | options object is invalid: the ExportRange is invalid, must be CurrentView or VisibleRegionOfCurrentView, or the ViewName is invalid, must be non-empty, unique and should not contain prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Document Class


SeparateElements Method

[image]

Revit 2013 API
Document..::..SeparateElements Method
Document Class See Also Send Feedback
Separate a set of combinable elements out of combinations they currently belong to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SeparateElements(
    CombinableElementArray members
)
Visual Basic
Public Sub SeparateElements ( _
    members As CombinableElementArray _
)
Visual C++
public:
void SeparateElements(
    CombinableElementArray^ members
)

Parameters

members
Type: Autodesk.Revit.DB..::..CombinableElementArray
A list of combinable elements to be separated.

Remarks

If geometry combination elements are passed as input, they will be completely separated and deleted. If generic forms that happen to belong to combination elements are passed, these forms will be removed from their geometry combination. The handles of geometry combinations completely removed by this operation are no longer valid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when members is empty. Thrown when members contains nullNothingnullptra null reference (Nothing in Visual Basic) elements.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when separation failed.

See Also

Document Class


UnpostFailure Method

[image]

Revit 2013 API
Document..::..UnpostFailure Method
Document Class See Also Send Feedback
Deletes the posted failure message associated with a given FailureMessageKey.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void UnpostFailure(
    FailureMessageKey messageKey
)
Visual Basic
Public Sub UnpostFailure ( _
    messageKey As FailureMessageKey _
)
Visual C++
public:
void UnpostFailure(
    FailureMessageKey^ messageKey
)

Parameters

messageKey
Type: Autodesk.Revit.DB..::..FailureMessageKey
The key of the FailureMessage to be deleted.

Remarks

If code that previously has posted a failure is executed again or otherwise detects that failure conditions do not exist anymore and the failure is not longer relevant, it should delete a failure message in order to let transaction to be committed. In order to delete the failure, it should invoke this method with a message key that was returned when the failure was posted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | messageKey is invalid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Document Class


Document Properties

[image] [image]

Revit 2013 API
Document Properties
Document Class See Also Send Feedback

The Document type exposes the following members.

Properties

 | Name | Description
Public property | ActiveProjectLocation | Retrieve the active project location.
Public property | ActiveView | The document's active view.
Public property | AnnotationSymbolTypes | Retrieves an object that contains all the annotation types that are currently loaded into the project.
Public property | Application | Returns the Application in which the Document resides.
Public property | BeamSystemTypes | Retrieves an object that contains all of beam system types that are currently loaded into the project.
Public property | ContFootingTypes | Retrieves an object that contains all of continuous footing types that are currently loaded into the project.
Public property | Create | An object that can be used to create new instances of Autodesk Revit API elements within a project.
Public property | CurtainSystemTypes | This property is used to retrieve all the CurtainSystem types in current system.
Public property | DeckProfiles | Returns an object that contains all of the available deck profiles currently loaded to this project.
Public property | DimensionTypes | Retrieves an object that contains all of dimension types that are currently loaded into the project.
Public property | DisplayUnitSystem | Provides access to display unit type with in the document.
Public property | ElectricalEquipmentTypes | Returns an object that contains all of the available electrical equipment types currently loaded to this project.
Public property | Element[([( String])]) | Obsolete. Retrieves an element from the document given a unique id string.
Public property | Element[([( ElementId])]) | Obsolete. Retrieves an element from the document given a Revit element id.
Public property | FamilyCreate | An object that can be used to create new instances of Autodesk Revit API elements within a family document.
Public property | FamilyManager | The family manager object provides access to family types and parameters.
Public property | FasciaTypes | Retrieves an object that contains all the Fascia types that are currently loaded into the project.
Public property | FloorTypes | Retrieves an object that contains all the floor types that are currently loaded into the project.
Public property | GridTypes | Retrieves an object that contains all of Grid types that are currently loaded into the project.
Public property | GutterTypes | Retrieves an object that contains all the Gutter types that are currently loaded into the project.
Public property | IsFamilyDocument | Identifies if the current document is a family document.
Public property | IsModifiable | The document's state of modifiability.
Public property | IsModified | The state of changes made to the document.
Public property | IsReadOnly | Identifies if the document is read-only or can possibly be modified.
Public property | IsReadOnlyFile | Signals whether the document was opened from a read-only file.
Public property | IsWorkshared | Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document.
Public property | LevelTypes | Retrieves an object that contains all the level types that are currently loaded into the project.
Public property | LightingDeviceTypes | Returns an object that contains all of the available lighting device types currently loaded to this project.
Public property | LightingFixtureTypes | Returns an object that contains all of the available lighting fixture types currently loaded to this project.
Public property | MassDisplayTemporaryOverride | This setting controls temporary display in views of objects with mass category or subcategories.
Public property | MechanicalEquipmentTypes | Returns an object that contains all of the available mechanical equipment types currently loaded to this project.
Public property | MullionTypes | This property is used to retrieve all the mullion types in current system.
Public property | OwnerFamily | Get the Family of this Family Document.
Public property | PanelTypes | Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.
Public property | ParameterBindings | Retrieves an object from which mappings between parameter definitions and categories can be found.
Public property | PathName | The fully qualified path of the document's disk file.
Public property | Phases | Retrieves all the object that represent phases within the project.
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.
Public property | PrintManager | Retrieve the PrintManager of current project.
Public property | PrintSettings | Obsolete. Retrieve all Print Settings of current project.
Public property | ProjectInformation | Return the Project Information of the current project.
Public property | ProjectLocations | Retrieve all the project locations associated with this project
Public property | ProjectUnit | Provides access to Project Unit Setting with in the document.
Public property | ReactionsAreUpToDate | Reports if the analytical model has regenerated in a document with reaction loads.
Public property | RebarBarTypes | Retrieves an object that contains all the rebar bar types that are currently loaded into the project.
Public property | RebarCoverTypes | Retrieves an object that contains all the rebar cover types that are currently loaded into the project.
Public property | RebarHookTypes | Retrieves an object that contains all the rebar hook types that are currently loaded into the project.
Public property | RebarShapes | Retrieves an object that contains all the rebar shape types that are currently loaded into the project.
Public property | RoofTypes | Retrieves an object that contains all the roof types that are currently loaded into the project.
Public property | RoomTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | Settings | Provides access to general application settings, such as Categories.
Public property | SiteLocation | Returns the site location information.
Public property | SlabEdgeTypes | Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.
Public property | SpaceTagTypes | Retrieves an object that contains all of RoomTag types that are currently loaded into the project.
Public property | SpotDimensionTypes | Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.
Public property | TextNoteTypes | Retrieves an object that contains all of TextNote types that are currently loaded into the project.
Public property | Title | The document's title.
Public property | TitleBlocks | Titleblocks currently loaded into the document.
Public property | TrussTypes | Retrieves an object that contains all the truss types that are currently loaded into the project.
Public property | TypeOfStorage | Get the storage type of the specified BuiltInParameter.
Public property | ViewSheetSets | The view sheet sets stored in the document.
Public property | WallTypes | Retrieves an object that contains all the wall types that are currently loaded into the project.
Public property | WorksharingCentralFilename | Obsolete. The name and path of the central model for a workshared document.
Public property | WorksharingCentralGUID | The central GUID of the server-based model.

See Also

Document Class


ActiveProjectLocation Property

[image]

Revit 2013 API
Document..::..ActiveProjectLocation Property
Document Class See Also Send Feedback
Retrieve the active project location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocation ActiveProjectLocation { get; set; }
Visual Basic
Public Property ActiveProjectLocation As ProjectLocation
    Get
    Set
Visual C++
public:
property ProjectLocation^ ActiveProjectLocation {
    ProjectLocation^ get ();
    void set (ProjectLocation^ value);
}

Remarks

Getting this property returns the currently active project location that the user is currently working with. Setting this property can be used to change the active project location.

See Also

Document Class


ActiveView Property

[image]

Revit 2013 API
Document..::..ActiveView Property
Document Class Example See Also Send Feedback
The document's active view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public View ActiveView { get; }
Visual Basic
Public ReadOnly Property ActiveView As View
    Get
Visual C++
public:
property View^ ActiveView {
    View^ get ();
}

Field Value

The active view is the view that last had focus in the UI. nullNothingnullptra null reference (Nothing in Visual Basic) if no view is considered active.

Examples

CopyC#
// Get the active view of the current document.
Autodesk.Revit.DB.View view = document.ActiveView;

// Get the class type of the active view, and format the prompt string
String prompt = "Revit is currently in ";
if (view is Autodesk.Revit.DB.View3D)
{
    prompt += "3D view.";
}
else if (view is Autodesk.Revit.DB.ViewSection)
{
    prompt += "section view.";
}
else if (view is Autodesk.Revit.DB.ViewSheet)
{
    prompt += "sheet view.";
}
else if (view is Autodesk.Revit.DB.ViewDrafting)
{
    prompt += "drafting view.";
}
else
{
    prompt += "normal view, the view name is " + view.Name;
}

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get the active view of the current document.
Dim view As Autodesk.Revit.DB.View = document.ActiveView

' Get the class type of the active view, and format the prompt string
Dim prompt As [String] = "Revit is currently in "
If TypeOf view Is Autodesk.Revit.DB.View3D Then
    prompt += "3D view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSection Then
    prompt += "section view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewSheet Then
    prompt += "sheet view."
ElseIf TypeOf view Is Autodesk.Revit.DB.ViewDrafting Then
    prompt += "drafting view."
Else
    prompt += "normal view, the view name is " + view.Name
End If

' Give the user some information
TaskDialog.Show("Revit", prompt)

See Also

Document Class


AnnotationSymbolTypes Property

[image]

Revit 2013 API
Document..::..AnnotationSymbolTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the annotation types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AnnotationSymbolTypeSet AnnotationSymbolTypes { get; }
Visual Basic
Public ReadOnly Property AnnotationSymbolTypes As AnnotationSymbolTypeSet
    Get
Visual C++
public:
property AnnotationSymbolTypeSet^ AnnotationSymbolTypes {
    AnnotationSymbolTypeSet^ get ();
}

Remarks

This property returns a set of AnnotationSymbol objects. These objects can be used change the type of an Annotation from one type to another.

See Also

Document Class


Application Property

[image]

Revit 2013 API
Document..::..Application Property
Document Class See Also Send Feedback
Returns the Application in which the Document resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic
Public ReadOnly Property Application As Application
    Get
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

Document Class


BeamSystemTypes Property

[image]

Revit 2013 API
Document..::..BeamSystemTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of beam system types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemTypeSet BeamSystemTypes { get; }
Visual Basic
Public ReadOnly Property BeamSystemTypes As BeamSystemTypeSet
    Get
Visual C++
public:
property BeamSystemTypeSet^ BeamSystemTypes {
    BeamSystemTypeSet^ get ();
}

Remarks

This property returns a set of BeamSystemType objects. These objects can be used change the type of a BeamSystem from one type to another.

See Also

Document Class


ContFootingTypes Property

[image]

Revit 2013 API
Document..::..ContFootingTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of continuous footing types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ContFootingTypeSet ContFootingTypes { get; }
Visual Basic
Public ReadOnly Property ContFootingTypes As ContFootingTypeSet
    Get
Visual C++
public:
property ContFootingTypeSet^ ContFootingTypes {
    ContFootingTypeSet^ get ();
}

Remarks

This property returns a set of ContFootingType objects. These objects can be used change the type of a ContFooting from one type to another.

See Also

Document Class


Create Property

[image]

Revit 2013 API
Document..::..Create Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Create { get; }
Visual Basic
Public ReadOnly Property Create As Document
    Get
Visual C++
public:
property Document^ Create {
    Document^ get ();
}

Field Value

This object is used to create new instances of project elements within the Autodesk Revit API, such as FamilyInstances or groups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is family document.

See Also

Document Class


CurtainSystemTypes Property

[image]

Revit 2013 API
Document..::..CurtainSystemTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the CurtainSystem types in current system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainSystemTypeSet CurtainSystemTypes { get; }
Visual Basic
Public ReadOnly Property CurtainSystemTypes As CurtainSystemTypeSet
    Get
Visual C++
public:
property CurtainSystemTypeSet^ CurtainSystemTypes {
    CurtainSystemTypeSet^ get ();
}

Remarks

This property returns a set of CurtainSystemType objects. These objects can be used change the type of a CurtainSystem from one type to another.

See Also

Document Class


DeckProfiles Property

[image]

Revit 2013 API
Document..::..DeckProfiles Property
Document Class See Also Send Feedback
Returns an object that contains all of the available deck profiles currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet DeckProfiles { get; }
Visual Basic
Public ReadOnly Property DeckProfiles As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ DeckProfiles {
    FamilySymbolSet^ get ();
}

Remarks

The DeckProfiles property returns an object that contains the deck profiles which can be used to change the profile of a layer within a compound structure object.

See Also

Document Class


DimensionTypes Property

[image]

Revit 2013 API
Document..::..DimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of dimension types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DimensionTypeSet DimensionTypes { get; }
Visual Basic
Public ReadOnly Property DimensionTypes As DimensionTypeSet
    Get
Visual C++
public:
property DimensionTypeSet^ DimensionTypes {
    DimensionTypeSet^ get ();
}

Remarks

This property returns a set of DimensionType objects. These objects can be used change the type of a Dimension from one type to another.

See Also

Document Class


DisplayUnitSystem Property

[image]

Revit 2013 API
Document..::..DisplayUnitSystem Property
Document Class See Also Send Feedback
Provides access to display unit type with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DisplayUnit DisplayUnitSystem { get; }
Visual Basic
Public ReadOnly Property DisplayUnitSystem As DisplayUnit
    Get
Visual C++
public:
property DisplayUnit DisplayUnitSystem {
    DisplayUnit get ();
}

Remarks

Return the display unit type, metric or imperial.

See Also

Document Class


ElectricalEquipmentTypes Property

[image]

Revit 2013 API
Document..::..ElectricalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available electrical equipment types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet ElectricalEquipmentTypes { get; }
Visual Basic
Public ReadOnly Property ElectricalEquipmentTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ ElectricalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The ElectricalEquipmentTypes property returns an object that contains the electrical equipment types which can be used to change the type of an electrical equipment from one type to another.

See Also

Document Class


Element Property

[image] [image]

Revit 2013 API
Document..::..Element Property
Document Class See Also Send Feedback
Retrieves an element from the document given an identifier.

Overload List

 | Name | Description
Public property | Element[([( String])]) | Obsolete. Retrieves an element from the document given a unique id string.
Public property | Element[([( ElementId])]) | Obsolete. Retrieves an element from the document given a Revit element id.

See Also

Document Class
Document Members


Element Property (String)

[image]

Revit 2013 API
Document..::..Element Property (String)
Document Class See Also Send Feedback
Retrieves an element from the document given a unique id string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")]
public Element this[
    string
] { get; }
Visual Basic
<ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")> _
Public ReadOnly Property Element ( _
     As String _
) As Element
    Get
Visual C++
[ObsoleteAttribute(L"This method has been obsoleted. Use GetElement() instead.")]
public:
property Element^ Element[String^ ] {
    Element^ get (String^ );
}

Parameters

Type: System..::..String

Remarks

Returns the element corresponding to the unique id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the uniqueId does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload


Element Property (ElementId)

[image]

Revit 2013 API
Document..::..Element Property (ElementId)
Document Class See Also Send Feedback
Retrieves an element from the document given a Revit element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")]
public Element this[
    ElementId id
] { get; }
Visual Basic
<ObsoleteAttribute("This method has been obsoleted. Use GetElement() instead.")> _
Public ReadOnly Property Element ( _
    id As ElementId _
) As Element
    Get
Visual C++
[ObsoleteAttribute(L"This method has been obsoleted. Use GetElement() instead.")]
public:
property Element^ Element[ElementId^ id] {
    Element^ get (ElementId^ id);
}

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The Autodesk::Revit::DB::ElementId^ of the element to be retrieved from the Document.

Remarks

Returns the element corresponding to the id that was passed. The Element property is used to retrieve a known Element from the Revit database within the Document. If the Element specified by the Autodesk::Revit::DB::ElementId^ does not exist then an empty reference will be returned.

See Also

Document Class
Element Overload


FamilyCreate Property

[image]

Revit 2013 API
Document..::..FamilyCreate Property
Document Class See Also Send Feedback
An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyItemFactory FamilyCreate { get; }
Visual Basic
Public ReadOnly Property FamilyCreate As FamilyItemFactory
    Get
Visual C++
public:
property FamilyItemFactory^ FamilyCreate {
    FamilyItemFactory^ get ();
}

Field Value

This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


FamilyManager Property

[image]

Revit 2013 API
Document..::..FamilyManager Property
Document Class See Also Send Feedback
The family manager object provides access to family types and parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyManager FamilyManager { get; }
Visual Basic
Public ReadOnly Property FamilyManager As FamilyManager
    Get
Visual C++
public:
property FamilyManager^ FamilyManager {
    FamilyManager^ get ();
}

Remarks

This property is available when the document is a family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is project document.

See Also

Document Class


FasciaTypes Property

[image]

Revit 2013 API
Document..::..FasciaTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Fascia types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FasciaTypeSet FasciaTypes { get; }
Visual Basic
Public ReadOnly Property FasciaTypes As FasciaTypeSet
    Get
Visual C++
public:
property FasciaTypeSet^ FasciaTypes {
    FasciaTypeSet^ get ();
}

Remarks

This property returns a set of FasciaType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


FloorTypes Property

[image]

Revit 2013 API
Document..::..FloorTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the floor types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FloorTypeSet FloorTypes { get; }
Visual Basic
Public ReadOnly Property FloorTypes As FloorTypeSet
    Get
Visual C++
public:
property FloorTypeSet^ FloorTypes {
    FloorTypeSet^ get ();
}

Remarks

This property returns a set of FloorType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


GridTypes Property

[image]

Revit 2013 API
Document..::..GridTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of Grid types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridTypeSet GridTypes { get; }
Visual Basic
Public ReadOnly Property GridTypes As GridTypeSet
    Get
Visual C++
public:
property GridTypeSet^ GridTypes {
    GridTypeSet^ get ();
}

Remarks

This property returns a set of Grid objects. These objects can be used change the type of a Grid from one type to another.

See Also

Document Class


GutterTypes Property

[image]

Revit 2013 API
Document..::..GutterTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the Gutter types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GutterTypeSet GutterTypes { get; }
Visual Basic
Public ReadOnly Property GutterTypes As GutterTypeSet
    Get
Visual C++
public:
property GutterTypeSet^ GutterTypes {
    GutterTypeSet^ get ();
}

Remarks

This property returns a set of GutterType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


IsFamilyDocument Property

[image]

Revit 2013 API
Document..::..IsFamilyDocument Property
Document Class See Also Send Feedback
Identifies if the current document is a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFamilyDocument { get; }
Visual Basic
Public ReadOnly Property IsFamilyDocument As Boolean
    Get
Visual C++
public:
property bool IsFamilyDocument {
    bool get ();
}

See Also

Document Class


IsModifiable Property

[image]

Revit 2013 API
Document..::..IsModifiable Property
Document Class See Also Send Feedback
The document's state of modifiability.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsModifiable { get; }
Visual Basic
Public ReadOnly Property IsModifiable As Boolean
    Get
Visual C++
public:
property bool IsModifiable {
    bool get ();
}

Field Value

True if the document is currently in a state of accepting modifications, False otherwise.

Remarks

This is not a permanent state such as, for example IsReadOnlyFile. Value of this property changes dynamically multiple times within the life-time of an open document. Regardless of the mode a document is opened with, the model can only be modified inside an open transaction. Furthermore, even with a transaction open, the model is not always modifiable. Though this is rather a rare situation, it can happen, most likely during model regeneration, failure processing, or some events. An attempt to modify a non-modifiable document will result in throwing a ModificationOutsideTransactionException. See also IsReadOnly

See Also

Document Class


IsModified Property

[image]

Revit 2013 API
Document..::..IsModified Property
Document Class See Also Send Feedback
The state of changes made to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsModified { get; }
Visual Basic
Public ReadOnly Property IsModified As Boolean
    Get
Visual C++
public:
property bool IsModified {
    bool get ();
}

Field Value

True if the document has been modified since it was opened or saved, False otherwise.

See Also

Document Class


IsReadOnly Property

[image]

Revit 2013 API
Document..::..IsReadOnly Property
Document Class See Also Send Feedback
Identifies if the document is read-only or can possibly be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic
Public ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
property bool IsReadOnly {
    bool get ();
}

Field Value

True when no modifications to the model, including new transactions, are currently allowed; False otherwise.

Remarks

Like the IsModifiable, IsReadOnly is also a dynamic property. It’s value can change depending on the state a document is currently in. There are various factors that may affect this property. The most probable reason for this property to return 'true' is when Revit is currently processing failures (recoverable or not). Another possibility is when an external command is executed in read-only mode. If a document is in a read-only state, then not only the model cannot be modified at the moment, but even a new transaction may not be started. Attempting to do so will raise an InvalidOperationException.

See Also

Document Class


IsReadOnlyFile Property

[image]

Revit 2013 API
Document..::..IsReadOnlyFile Property
Document Class See Also Send Feedback
Signals whether the document was opened from a read-only file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReadOnlyFile { get; }
Visual Basic
Public ReadOnly Property IsReadOnlyFile As Boolean
    Get
Visual C++
public:
property bool IsReadOnlyFile {
    bool get ();
}

Field Value

True if the document was opened in read-only mode, False otherwise.

Remarks

A document could be opened this way when, for example, at the time of opening the file was being used by another Revit user, or if the disk file has the read-only attribute set.

Although it will still be possible to modify the opened document, any changes made there will not be possible to save into the original file. If the changes are to be preserved, the document must be saved under a different name using the SaveAs() method.

See Also

Document Class


IsWorkshared Property

[image]

Revit 2013 API
Document..::..IsWorkshared Property
Document Class See Also Send Feedback
Identifies if worksharing (i.e. editing permissions and multiple worksets) have been enabled in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsWorkshared { get; }
Visual Basic
Public ReadOnly Property IsWorkshared As Boolean
    Get
Visual C++
public:
property bool IsWorkshared {
    bool get ();
}

Field Value

True if the document is workshared (as either central or local), False if it is not workshared.

See Also

Document Class


LevelTypes Property

[image]

Revit 2013 API
Document..::..LevelTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the level types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LevelTypeSet LevelTypes { get; }
Visual Basic
Public ReadOnly Property LevelTypes As LevelTypeSet
    Get
Visual C++
public:
property LevelTypeSet^ LevelTypes {
    LevelTypeSet^ get ();
}

Remarks

This property returns a set of level objects. These objects can be used change the type of a level from one type to another.

See Also

Document Class


LightingDeviceTypes Property

[image]

Revit 2013 API
Document..::..LightingDeviceTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting device types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet LightingDeviceTypes { get; }
Visual Basic
Public ReadOnly Property LightingDeviceTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ LightingDeviceTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingDeviceTypes property returns an object that contains the lighting device types which can be used to change the type of a lighting device from one type to another.

See Also

Document Class


LightingFixtureTypes Property

[image]

Revit 2013 API
Document..::..LightingFixtureTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available lighting fixture types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet LightingFixtureTypes { get; }
Visual Basic
Public ReadOnly Property LightingFixtureTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ LightingFixtureTypes {
    FamilySymbolSet^ get ();
}

Remarks

The LightingFixtureTypes property returns an object that contains the lighting fixture types which can be used to change the type of a lighting fixture from one type to another.

See Also

Document Class


MassDisplayTemporaryOverride Property

[image]

Revit 2013 API
Document..::..MassDisplayTemporaryOverride Property
Document Class See Also Send Feedback
This setting controls temporary display in views of objects with mass category or subcategories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride { get; set; }
Visual Basic
Public Property MassDisplayTemporaryOverride As MassDisplayTemporaryOverrideType
    Get
    Set
Visual C++
public:
property MassDisplayTemporaryOverrideType MassDisplayTemporaryOverride {
    MassDisplayTemporaryOverrideType get ();
    void set (MassDisplayTemporaryOverrideType value);
}

Field Value

The MassDisplayTemporaryOverrideType that is active.

Remarks

This setting is temporary and is not stored in the document. The mass display overrides allow mass category and certain mass subcategories to be displayed in all views, regardless of the visibility settings of that view. The settings that show certain mass subcategories will also force the other mass subcategories to be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The MassDisplayTemporaryOverrideType::Enum value is not in the proper range.

See Also

Document Class


MechanicalEquipmentTypes Property

[image]

Revit 2013 API
Document..::..MechanicalEquipmentTypes Property
Document Class See Also Send Feedback
Returns an object that contains all of the available mechanical equipment types currently loaded to this project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet MechanicalEquipmentTypes { get; }
Visual Basic
Public ReadOnly Property MechanicalEquipmentTypes As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ MechanicalEquipmentTypes {
    FamilySymbolSet^ get ();
}

Remarks

The MechanicalEquipmentTypes property returns an object that contains the mechanical equipment types which can be used to change the type of a mechanical equipment from one type to another.

See Also

Document Class


MullionTypes Property

[image]

Revit 2013 API
Document..::..MullionTypes Property
Document Class See Also Send Feedback
This property is used to retrieve all the mullion types in current system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MullionTypeSet MullionTypes { get; }
Visual Basic
Public ReadOnly Property MullionTypes As MullionTypeSet
    Get
Visual C++
public:
property MullionTypeSet^ MullionTypes {
    MullionTypeSet^ get ();
}

Remarks

This property returns a set of MullionType objects. These objects can be used change the type of a mullion from one type to another.

See Also

Document Class


OwnerFamily Property

[image]

Revit 2013 API
Document..::..OwnerFamily Property
Document Class Example See Also Send Feedback
Get the Family of this Family Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Family OwnerFamily { get; }
Visual Basic
Public ReadOnly Property OwnerFamily As Family
    Get
Visual C++
public:
property Family^ OwnerFamily {
    Family^ get ();
}

Remarks

Only available if the current document is family document.

Examples

CopyC#
string categoryName = familyDoc.OwnerFamily.FamilyCategory.Name;
CopyVB.NET
Dim categoryName As String = familyDoc.OwnerFamily.FamilyCategory.Name

See Also

Document Class


PanelTypes Property

[image]

Revit 2013 API
Document..::..PanelTypes Property
Document Class See Also Send Feedback
Retrieves a set of PanelType objects that contains all the panel types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelTypeSet PanelTypes { get; }
Visual Basic
Public ReadOnly Property PanelTypes As PanelTypeSet
    Get
Visual C++
public:
property PanelTypeSet^ PanelTypes {
    PanelTypeSet^ get ();
}

Remarks

This property returns a set of panelType objects. These objects can be used change the type of a panel from one type to another.

See Also

Document Class


ParameterBindings Property

[image]

Revit 2013 API
Document..::..ParameterBindings Property
Document Class See Also Send Feedback
Retrieves an object from which mappings between parameter definitions and categories can be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BindingMap ParameterBindings { get; }
Visual Basic
Public ReadOnly Property ParameterBindings As BindingMap
    Get
Visual C++
public:
property BindingMap^ ParameterBindings {
    BindingMap^ get ();
}

Remarks

Returns a mapping between parameter definitions and parameter bindings. New bindings can be added to the Revit Document by using this object.

See Also

Document Class


PathName Property

[image]

Revit 2013 API
Document..::..PathName Property
Document Class Example See Also Send Feedback
The fully qualified path of the document's disk file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get
Visual C++
public:
property String^ PathName {
    String^ get ();
}

Remarks

This string is empty if the project has not been saved or does not have a disk file associated with it yet.

Examples

CopyC#
string docPathName = document.PathName;
CopyVB.NET
Dim docPathName As String = document.PathName

See Also

Document Class


Phases Property

[image]

Revit 2013 API
Document..::..Phases Property
Document Class Example See Also Send Feedback
Retrieves all the object that represent phases within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PhaseArray Phases { get; }
Visual Basic
Public ReadOnly Property Phases As PhaseArray
    Get
Visual C++
public:
property PhaseArray^ Phases {
    PhaseArray^ get ();
}

Remarks

The phases returned are in order of earliest phase first, through to latest phase last.

Examples

CopyC#
void Getinfo_Phase(Document doc)
{
    // Get the phase array which contains all the phases.
    PhaseArray phases = doc.Phases;
    // Format the prompt string which identifies all supported phases in the current document.
    String prompt = null;
    if (0 != phases.Size)
    {
        prompt = "All the phases in current document list as follow:";
        foreach (Phase ii in phases)
        {
            prompt += "\n\t" + ii.Name;
        }
    }
    else
    {
        prompt = "There are no phases in current document.";
    }
    // Give the user the information.
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Sub Getinfo_Phase(ByVal doc As Document)
    ' Get the phase array which contains all the phases.
    Dim phases As PhaseArray = doc.Phases
    ' Format the prompt string which identifies all supported phases in the current document.
    Dim prompt As [String] = Nothing
    If 0 <> phases.Size Then
        prompt = "All the phases in current document list as follow:"
        For Each ii As Phase In phases
            prompt += vbLf & vbTab + ii.Name
        Next
    Else
        prompt = "There are no phases in current document."
    End If
    ' Give the user the information.
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Document Class


PlanTopologies Property

[image] [image]

Revit 2013 API
Document..::..PlanTopologies Property
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project.

Overload List

 | Name | Description
Public property | PlanTopologies | Get the PlanTopologies of the current project in the last phase.
Public property | PlanTopologies[([( Phase])]) | Gets the PlanTopologies of the current project in a given phase.

See Also

Document Class
Document Members


PlanTopologies Property

[image]

Revit 2013 API
Document..::..PlanTopologies Property
Document Class See Also Send Feedback
Get the PlanTopologies of the current project in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopologySet PlanTopologies { get; }
Visual Basic
Public ReadOnly Property PlanTopologies As PlanTopologySet
    Get
Visual C++
public:
property PlanTopologySet^ PlanTopologies {
    PlanTopologySet^ get ();
}

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopologies Property (Phase)

[image]

Revit 2013 API
Document..::..PlanTopologies Property (Phase)
Document Class See Also Send Feedback
Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopologySet this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property PlanTopologies ( _
    phase As Phase _
) As PlanTopologySet
    Get
Visual C++
public:
property PlanTopologySet^ PlanTopologies[Phase^ phase] {
    PlanTopologySet^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.

Remarks

Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopologies Overload


PlanTopology Property

[image] [image]

Revit 2013 API
Document..::..PlanTopology Property
Document Class See Also Send Feedback
Gets the PlanTopology of a given level.

Overload List

 | Name | Description
Public property | PlanTopology[([( Level])]) | Get the PlanTopology of a given level in the last phase.
Public property | PlanTopology[([( Level, Phase])]) | Get the PlanTopology of a given level in a given phase.

See Also

Document Class
Document Members


PlanTopology Property (Level)

[image]

Revit 2013 API
Document..::..PlanTopology Property (Level)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopology this[
    Level level
] { get; }
Visual Basic
Public ReadOnly Property PlanTopology ( _
    level As Level _
) As PlanTopology
    Get
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level] {
    PlanTopology^ get (Level^ level);
}

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level of the Plan Topology.

Remarks

Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopology Overload


PlanTopology Property (Level, Phase)

[image]

Revit 2013 API
Document..::..PlanTopology Property (Level, Phase)
Document Class See Also Send Feedback
Get the PlanTopology of a given level in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopology this[
    Level level,
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property PlanTopology ( _
    level As Level, _
    phase As Phase _
) As PlanTopology
    Get
Visual C++
public:
property PlanTopology^ PlanTopology[Level^ level, Phase^ phase] {
    PlanTopology^ get (Level^ level, Phase^ phase);
}

Parameters

level
Type: Autodesk.Revit.DB..::..Level
The level of the Plan Topology.
phase
Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.

Remarks

Accessing plan topology requires that document is modifiable as it will actually trigger calculating plan topology if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.

See Also

Document Class
PlanTopology Overload


PrintManager Property

[image]

Revit 2013 API
Document..::..PrintManager Property
Document Class See Also Send Feedback
Retrieve the PrintManager of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PrintManager PrintManager { get; }
Visual Basic
Public ReadOnly Property PrintManager As PrintManager
    Get
Visual C++
public:
property PrintManager^ PrintManager {
    PrintManager^ get ();
}

See Also

Document Class


PrintSettings Property

[image]

Revit 2013 API
Document..::..PrintSettings Property
Document Class See Also Send Feedback
Retrieve all Print Settings of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPrintSettingIds() instead.")]
public ElementSet PrintSettings { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetPrintSettingIds() instead.")> _
Public ReadOnly Property PrintSettings As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetPrintSettingIds() instead.")]
public:
property ElementSet^ PrintSettings {
    ElementSet^ get ();
}

See Also

Document Class


ProjectInformation Property

[image]

Revit 2013 API
Document..::..ProjectInformation Property
Document Class See Also Send Feedback
Return the Project Information of the current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectInfo ProjectInformation { get; }
Visual Basic
Public ReadOnly Property ProjectInformation As ProjectInfo
    Get
Visual C++
public:
property ProjectInfo^ ProjectInformation {
    ProjectInfo^ get ();
}

Return Value

Autodesk::Revit::DB::ProjectInfo

See Also

Document Class


ProjectLocations Property

[image]

Revit 2013 API
Document..::..ProjectLocations Property
Document Class See Also Send Feedback
Retrieve all the project locations associated with this project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocationSet ProjectLocations { get; }
Visual Basic
Public ReadOnly Property ProjectLocations As ProjectLocationSet
    Get
Visual C++
public:
property ProjectLocationSet^ ProjectLocations {
    ProjectLocationSet^ get ();
}

Remarks

This property returns all the locations of the project. A project can have one site location but many project locations within that site. Each project location object is an offset and rotation from the site location.

See Also

Document Class


ProjectUnit Property

[image]

Revit 2013 API
Document..::..ProjectUnit Property
Document Class See Also Send Feedback
Provides access to Project Unit Setting with in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectUnit ProjectUnit { get; }
Visual Basic
Public ReadOnly Property ProjectUnit As ProjectUnit
    Get
Visual C++
public:
property ProjectUnit^ ProjectUnit {
    ProjectUnit^ get ();
}

Remarks

Return the Project Unit Setting items.

See Also

Document Class


ReactionsAreUpToDate Property

[image]

Revit 2013 API
Document..::..ReactionsAreUpToDate Property
Document Class See Also Send Feedback
Reports if the analytical model has regenerated in a document with reaction loads.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ReactionsAreUpToDate { get; }
Visual Basic
Public ReadOnly Property ReactionsAreUpToDate As Boolean
    Get
Visual C++
public:
property bool ReactionsAreUpToDate {
    bool get ();
}

Remarks

Revit sets this property to False after regeneration of the analytical model if the document contains loads that have isReaction=True. This results in a user-visible warning that exists until there are no longer loads with isReaction=True.

See Also

Document Class


RebarBarTypes Property

[image]

Revit 2013 API
Document..::..RebarBarTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar bar types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarBarTypeSet RebarBarTypes { get; }
Visual Basic
Public ReadOnly Property RebarBarTypes As RebarBarTypeSet
    Get
Visual C++
public:
property RebarBarTypeSet^ RebarBarTypes {
    RebarBarTypeSet^ get ();
}

Remarks

This property returns a set of rebarbartype objects. These objects can be used change the type of a rebar from one type to another.

See Also

Document Class


RebarCoverTypes Property

[image]

Revit 2013 API
Document..::..RebarCoverTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar cover types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarCoverTypeSet RebarCoverTypes { get; }
Visual Basic
Public ReadOnly Property RebarCoverTypes As RebarCoverTypeSet
    Get
Visual C++
public:
property RebarCoverTypeSet^ RebarCoverTypes {
    RebarCoverTypeSet^ get ();
}

Remarks

This property returns a set of RebarCoverType objects.

See Also

Document Class


RebarHookTypes Property

[image]

Revit 2013 API
Document..::..RebarHookTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar hook types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarHookTypeSet RebarHookTypes { get; }
Visual Basic
Public ReadOnly Property RebarHookTypes As RebarHookTypeSet
    Get
Visual C++
public:
property RebarHookTypeSet^ RebarHookTypes {
    RebarHookTypeSet^ get ();
}

Remarks

This property returns a set of rebarhooktype objects.

See Also

Document Class


RebarShapes Property

[image]

Revit 2013 API
Document..::..RebarShapes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the rebar shape types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarShapeSet RebarShapes { get; }
Visual Basic
Public ReadOnly Property RebarShapes As RebarShapeSet
    Get
Visual C++
public:
property RebarShapeSet^ RebarShapes {
    RebarShapeSet^ get ();
}

Remarks

This property returns a set of RebarShape objects.

See Also

Document Class


RoofTypes Property

[image]

Revit 2013 API
Document..::..RoofTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the roof types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoofTypeSet RoofTypes { get; }
Visual Basic
Public ReadOnly Property RoofTypes As RoofTypeSet
    Get
Visual C++
public:
property RoofTypeSet^ RoofTypes {
    RoofTypeSet^ get ();
}

Remarks

This property returns a set of RoofType objects.

See Also

Document Class


RoomTagTypes Property

[image]

Revit 2013 API
Document..::..RoomTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTagTypeSet RoomTagTypes { get; }
Visual Basic
Public ReadOnly Property RoomTagTypes As RoomTagTypeSet
    Get
Visual C++
public:
property RoomTagTypeSet^ RoomTagTypes {
    RoomTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class


Settings Property

[image]

Revit 2013 API
Document..::..Settings Property
Document Class See Also Send Feedback
Provides access to general application settings, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Settings Settings { get; }
Visual Basic
Public ReadOnly Property Settings As Settings
    Get
Visual C++
public:
property Settings^ Settings {
    Settings^ get ();
}

Remarks

Returns an object that provides access to various settings within Autodesk Revit. The Settings property returns an object that provides access to the categories within the Autodesk Revit project.

See Also

Document Class


SiteLocation Property

[image]

Revit 2013 API
Document..::..SiteLocation Property
Document Class See Also Send Feedback
Returns the site location information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic
Public ReadOnly Property SiteLocation As SiteLocation
    Get
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The SiteLocation property returns an object that contains the site location for the entire project.

See Also

Document Class


SlabEdgeTypes Property

[image]

Revit 2013 API
Document..::..SlabEdgeTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the SlabEdge types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdgeTypeSet SlabEdgeTypes { get; }
Visual Basic
Public ReadOnly Property SlabEdgeTypes As SlabEdgeTypeSet
    Get
Visual C++
public:
property SlabEdgeTypeSet^ SlabEdgeTypes {
    SlabEdgeTypeSet^ get ();
}

Remarks

This property returns a set of SlabEdgeType objects. These objects can be used change the type of a floor from one type to another.

See Also

Document Class


SpaceTagTypes Property

[image]

Revit 2013 API
Document..::..SpaceTagTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of RoomTag types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTagTypeSet SpaceTagTypes { get; }
Visual Basic
Public ReadOnly Property SpaceTagTypes As SpaceTagTypeSet
    Get
Visual C++
public:
property SpaceTagTypeSet^ SpaceTagTypes {
    SpaceTagTypeSet^ get ();
}

Remarks

This property returns a set of RoomTag objects. These objects can be used change the type of a RoomTag from one type to another.

See Also

Document Class


SpotDimensionTypes Property

[image]

Revit 2013 API
Document..::..SpotDimensionTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of SpotDimension types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimensionTypeSet SpotDimensionTypes { get; }
Visual Basic
Public ReadOnly Property SpotDimensionTypes As SpotDimensionTypeSet
    Get
Visual C++
public:
property SpotDimensionTypeSet^ SpotDimensionTypes {
    SpotDimensionTypeSet^ get ();
}

Remarks

This property returns a set of SpotDimensionType objects. These objects can be used change the type of a SpotDimension from one type to another.

See Also

Document Class


TextNoteTypes Property

[image]

Revit 2013 API
Document..::..TextNoteTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all of TextNote types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteTypeSet TextNoteTypes { get; }
Visual Basic
Public ReadOnly Property TextNoteTypes As TextNoteTypeSet
    Get
Visual C++
public:
property TextNoteTypeSet^ TextNoteTypes {
    TextNoteTypeSet^ get ();
}

Remarks

This property returns a set of TextNote objects. These objects can be used change the type of a TextNote from one type to another.

See Also

Document Class


Title Property

[image]

Revit 2013 API
Document..::..Title Property
Document Class See Also Send Feedback
The document's title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

Remarks

A title is usually derived from the document's filename.

See Also

Document Class


TitleBlocks Property

[image]

Revit 2013 API
Document..::..TitleBlocks Property
Document Class See Also Send Feedback
Titleblocks currently loaded into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet TitleBlocks { get; }
Visual Basic
Public ReadOnly Property TitleBlocks As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ TitleBlocks {
    FamilySymbolSet^ get ();
}

Remarks

A titleblock is a symbol that defines the layout of a drafting sheet.

See Also

Document Class


TrussTypes Property

[image]

Revit 2013 API
Document..::..TrussTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the truss types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussTypeSet TrussTypes { get; }
Visual Basic
Public ReadOnly Property TrussTypes As TrussTypeSet
    Get
Visual C++
public:
property TrussTypeSet^ TrussTypes {
    TrussTypeSet^ get ();
}

Remarks

This property returns a set of TrussType objects.

See Also

Document Class


TypeOfStorage Property

[image]

Revit 2013 API
Document..::..TypeOfStorage Property
Document Class See Also Send Feedback
Get the storage type of the specified BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StorageType this[
    BuiltInParameter
] { get; }
Visual Basic
Public ReadOnly Property TypeOfStorage ( _
     As BuiltInParameter _
) As StorageType
    Get
Visual C++
public:
property StorageType TypeOfStorage[BuiltInParameter ] {
    StorageType get (BuiltInParameter );
}

Parameters

Type: Autodesk.Revit.DB..::..BuiltInParameter

See Also

Document Class


ViewSheetSets Property

[image]

Revit 2013 API
Document..::..ViewSheetSets Property
Document Class See Also Send Feedback
The view sheet sets stored in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSheetSets ViewSheetSets { get; }
Visual Basic
Public ReadOnly Property ViewSheetSets As ViewSheetSets
    Get
Visual C++
public:
property ViewSheetSets^ ViewSheetSets {
    ViewSheetSets^ get ();
}

Field Value

A group of the available view sheet sets.

See Also

Document Class


WallTypes Property

[image]

Revit 2013 API
Document..::..WallTypes Property
Document Class See Also Send Feedback
Retrieves an object that contains all the wall types that are currently loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallTypeSet WallTypes { get; }
Visual Basic
Public ReadOnly Property WallTypes As WallTypeSet
    Get
Visual C++
public:
property WallTypeSet^ WallTypes {
    WallTypeSet^ get ();
}

Remarks

This property returns a set of WallType objects. These objects can be used change the type of a wall from one type to another.

See Also

Document Class


WorksharingCentralFilename Property

[image]

Revit 2013 API
Document..::..WorksharingCentralFilename Property
Document Class See Also Send Feedback
The name and path of the central model for a workshared document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use method GetWorksharingCentralModelPath() instead.")]
public string WorksharingCentralFilename { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use method GetWorksharingCentralModelPath() instead.")> _
Public ReadOnly Property WorksharingCentralFilename As String
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use method GetWorksharingCentralModelPath() instead.")]
public:
property String^ WorksharingCentralFilename {
    String^ get ();
}

Field Value

The name and path of the central model, or an empty string if the file is not workshared.

See Also

Document Class


WorksharingCentralGUID Property

[image]

Revit 2013 API
Document..::..WorksharingCentralGUID Property
Document Class See Also Send Feedback
The central GUID of the server-based model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid WorksharingCentralGUID { get; }
Visual Basic
Public ReadOnly Property WorksharingCentralGUID As Guid
    Get
Visual C++
public:
property Guid WorksharingCentralGUID {
    Guid get ();
}

Field Value

The central GUID of the server-based model.

Remarks

The central model of this document that is file-based model or saved in a release prior to Revit 2013 did not have this GUID. Only the central model saved in Revit 2013 or later and stored on Revit Server will be able to provide this value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the central model of this document is not a server-based model that created in Revit 2013 or later release.

See Also

Document Class


Document Events

[image] [image]

Revit 2013 API
Document Events
Document Class See Also Send Feedback

The Document type exposes the following members.

Events

 | Name | Description
Public event | DocumentClosing | Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.
Public event | DocumentPrinted | Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.
Public event | DocumentPrinting | Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.
Public event | DocumentSaved | Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.
Public event | DocumentSavedAs | Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.
Public event | DocumentSaving | Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.
Public event | DocumentSavingAs | Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.
Public event | ViewPrinted | Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.
Public event | ViewPrinting | Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

See Also

Document Class


DocumentClosing Event

[image]

Revit 2013 API
Document..::..DocumentClosing Event
Document Class See Also Send Feedback
Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentClosingEventArgs> DocumentClosing
Visual Basic
Public Event DocumentClosing As EventHandler(Of DocumentClosingEventArgs)
Visual C++
public:
 event EventHandler<DocumentClosingEventArgs^>^ DocumentClosing {
    void add (EventHandler<DocumentClosingEventArgs^>^ value);
    void remove (EventHandler<DocumentClosingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to close a document.

This event is cancellable, except when it is raised as part of application closing. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to True to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may not be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another Autodesk::Revit::ApplicationServices::Application::DocumentClosed event will be raised immediately after document is closed.

See Also

Document Class


DocumentPrinted Event

[image]

Revit 2013 API
Document..::..DocumentPrinted Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinted event to be notified immediately after Revit has finished printing a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted
Visual Basic
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted {
    void add (EventHandler<DocumentPrintedEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentPrinting Event

[image]

Revit 2013 API
Document..::..DocumentPrinting Event
Document Class See Also Send Feedback
Subscribe to the DocumentPrinting event to be notified when Revit is just about to print a view or ViewSet of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentPrintingEventArgs> DocumentPrinting
Visual Basic
Public Event DocumentPrinting As EventHandler(Of DocumentPrintingEventArgs)
Visual C++
public:
 event EventHandler<DocumentPrintingEventArgs^>^ DocumentPrinting {
    void add (EventHandler<DocumentPrintingEventArgs^>^ value);
    void remove (EventHandler<DocumentPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view or ViewSet of the document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method of event’s argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk::Revit::DB::Document::Print
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

After this event, for each view being printed,ViewPrinting and ViewPrinted events will be raised. Another event DocumentPrinted will be raised immediately after document printing is finished.

See Also

Document Class


DocumentSaved Event

[image]

Revit 2013 API
Document..::..DocumentSaved Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaved event to be notified immediately after Revit has finished saving a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedEventArgs> DocumentSaved
Visual Basic
Public Event DocumentSaved As EventHandler(Of DocumentSavedEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedEventArgs^>^ DocumentSaved {
    void add (EventHandler<DocumentSavedEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving a document. Note that the first save of a newly created document will raise DocumentSavedAs rather than the DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSaving event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSavedAs Event

[image]

Revit 2013 API
Document..::..DocumentSavedAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavedAs event to be notified immediately after Revit has finished saving document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavedAsEventArgs> DocumentSavedAs
Visual Basic
Public Event DocumentSavedAs As EventHandler(Of DocumentSavedAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavedAsEventArgs^>^ DocumentSavedAs {
    void add (EventHandler<DocumentSavedAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavedAsEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished saving document with a new file name. Note that the first save of a newly created document will raise DocumentSavedAs rather than DocumentSaved event. It is raised even when document saving failed or was cancelled (during DocumentSavingAs event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' property in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of saving document has already been finished.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


DocumentSaving Event

[image]

Revit 2013 API
Document..::..DocumentSaving Event
Document Class See Also Send Feedback
Subscribe to the DocumentSaving event to be notified when Revit is just about to save a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingEventArgs> DocumentSaving
Visual Basic
Public Event DocumentSaving As EventHandler(Of DocumentSavingEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingEventArgs^>^ DocumentSaving {
    void add (EventHandler<DocumentSavingEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document. Note that the first save of a newly created document will raise DocumentSavingAs rather than the DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSaved will be raised immediately after the document has been saved.

See Also

Document Class


DocumentSavingAs Event

[image]

Revit 2013 API
Document..::..DocumentSavingAs Event
Document Class See Also Send Feedback
Subscribe to the DocumentSavingAs event to be notified when Revit is just about to save the document with a new file name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<DocumentSavingAsEventArgs> DocumentSavingAs
Visual Basic
Public Event DocumentSavingAs As EventHandler(Of DocumentSavingAsEventArgs)
Visual C++
public:
 event EventHandler<DocumentSavingAsEventArgs^>^ DocumentSavingAs {
    void add (EventHandler<DocumentSavingAsEventArgs^>^ value);
    void remove (EventHandler<DocumentSavingAsEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to save the document with a new file name. Note that the first save of a newly created document will raise DocumentSavingAs rather than DocumentSaving event.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

This event is cancellable, except when it is raised during close of the application. Check the 'Cancellable' property of event’s argument to see whether it is cancellable or not. When it is cancellable, call the 'Cancel()' method of event’s argument to cancel it. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event DocumentSavedAs will be raised immediately after the document has been saved with a new file name.

See Also

Document Class


ViewPrinted Event

[image]

Revit 2013 API
Document..::..ViewPrinted Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinted event to be notified immediately after Revit has finished printing a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintedEventArgs> ViewPrinted
Visual Basic
Public Event ViewPrinted As EventHandler(Of ViewPrintedEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintedEventArgs^>^ ViewPrinted {
    void add (EventHandler<ViewPrintedEventArgs^>^ value);
    void remove (EventHandler<ViewPrintedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished printing a view of the document. If multiple views are combined to a single file, this event will be raised only once. It is raised even when view printing failed.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event’s argument to see whether the action was successful or not.

This event is not cancellable, for the process of view printing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

Document Class


ViewPrinting Event

[image]

Revit 2013 API
Document..::..ViewPrinting Event
Document Class See Also Send Feedback
Subscribe to the ViewPrinting event to be notified when Revit is just about to print a view of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public event EventHandler<ViewPrintingEventArgs> ViewPrinting
Visual Basic
Public Event ViewPrinting As EventHandler(Of ViewPrintingEventArgs)
Visual C++
public:
 event EventHandler<ViewPrintingEventArgs^>^ ViewPrinting {
    void add (EventHandler<ViewPrintingEventArgs^>^ value);
    void remove (EventHandler<ViewPrintingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to print a view of the document. If multiple views are combined to a single file, this event will be raised only once.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

The following API functions are not available for the current document during this event:

  • All overloads of Autodesk.Revit.DB.Document.Export()
  • Autodesk.Revit.DB.Document.Print()
  • Print()()()() and similar overloads.
  • SubmitPrint()()()() and similar overloads.
  • Close()()()() and similar overloads.
  • Save()()()() .
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another event ViewPrinted will be raised immediately after view printing is finished.

See Also

Document Class


DocumentPreviewSettings Class

[image]

Revit 2013 API
DocumentPreviewSettings Class
Members Example See Also Send Feedback
Contains the settings related to the saving of preview images for a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DocumentPreviewSettings : IDisposable
Visual Basic
Public Class DocumentPreviewSettings _
    Implements IDisposable
Visual C++
public ref class DocumentPreviewSettings : IDisposable

Examples

CopyC#
// Get the document's preview settings
DocumentPreviewSettings settings = document.GetDocumentPreviewSettings();

// Find a candidate 3D view
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.OfClass(typeof(View3D));

Func<View3D, bool> isValidForPreview = v => settings.IsViewIdValidForPreview(v.Id);

View3D viewForPreview = collector.OfType<View3D>().First<View3D>(isValidForPreview);

// Set the preview settings
Transaction setTransaction = new Transaction(document, "Set preview view id");
setTransaction.Start();
settings.PreviewViewId = viewForPreview.Id;
setTransaction.Commit();

// Save the document
document.Save();

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..DocumentPreviewSettings

See Also

DocumentPreviewSettings Members


DocumentPreviewSettings Members

[image] [image]

Revit 2013 API
DocumentPreviewSettings Members
DocumentPreviewSettings Class Methods Properties See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DocumentPreviewSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Methods

[image] [image]

Revit 2013 API
DocumentPreviewSettings Methods
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForceViewUpdate | Sets Revit to update the preview view if necessary.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsViewIdValidForPreview | Identifies if the view id is valid as a preview view id.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPreviewSettings Class


Dispose Method

[image]

Revit 2013 API
DocumentPreviewSettings..::..Dispose Method
DocumentPreviewSettings Class See Also Send Feedback
Releases all resources used by the DocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DocumentPreviewSettings Class


ForceViewUpdate Method

[image]

Revit 2013 API
DocumentPreviewSettings..::..ForceViewUpdate Method
DocumentPreviewSettings Class See Also Send Feedback
Sets Revit to update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ForceViewUpdate(
    bool forceViewUpdate
)
Visual Basic
Public Sub ForceViewUpdate ( _
    forceViewUpdate As Boolean _
)
Visual C++
public:
void ForceViewUpdate(
    bool forceViewUpdate
)

Parameters

forceViewUpdate
Type: System..::..Boolean
True to force update of the preview view. False to skip update if necessary (the default).

Remarks

An update is necessary if the view has never been displayed, or if the model has been changed and the view has not been updated or accessed. If the preview view has not been updated, the preview may not be properly saved.

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class


IsViewIdValidForPreview Method

[image]

Revit 2013 API
DocumentPreviewSettings..::..IsViewIdValidForPreview Method
DocumentPreviewSettings Class See Also Send Feedback
Identifies if the view id is valid as a preview view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsViewIdValidForPreview(
    ElementId viewId
)
Visual Basic
Public Function IsViewIdValidForPreview ( _
    viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsViewIdValidForPreview(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Return Value

True if the view id is valid for preview, false otherwise.

Remarks

Only graphical views (3d or 2d) are valid for use as a preview view. Other views (such as view templates) will not pass this method. InvalidElementId is accepted by this method as this id means that no special view is set for the preview.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DocumentPreviewSettings Class


DocumentPreviewSettings Properties

[image] [image]

Revit 2013 API
DocumentPreviewSettings Properties
DocumentPreviewSettings Class See Also Send Feedback

The DocumentPreviewSettings type exposes the following members.

Properties

 | Name | Description
Public property | IsViewUpdateForced | Identifies if Revit will update the preview view if necessary.
Public property | PreviewViewId | The view id that will be used to generate the preview.

See Also

DocumentPreviewSettings Class


IsViewUpdateForced Property

[image]

Revit 2013 API
DocumentPreviewSettings..::..IsViewUpdateForced Property
DocumentPreviewSettings Class See Also Send Feedback
Identifies if Revit will update the preview view if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsViewUpdateForced { get; }
Visual Basic
Public ReadOnly Property IsViewUpdateForced As Boolean
    Get
Visual C++
public:
property bool IsViewUpdateForced {
    bool get ();
}

Field Value

True if the preview view will be updated during Save, if necessary. False if the view will not be updated.

Remarks

This setting applies only to a single Save operation and is reset to false after it is accessed.

See Also

DocumentPreviewSettings Class


PreviewViewId Property

[image]

Revit 2013 API
DocumentPreviewSettings..::..PreviewViewId Property
DocumentPreviewSettings Class See Also Send Feedback
The view id that will be used to generate the preview.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic
Public Property PreviewViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

InvalidElementId signals that there is no permanent preview view for the document. Where possible the document's active view will be used to generate the preview upon save; where there is no active view the document will not include a preview.

Remarks

This view will always be saved as the preview view for the document unless it is overridden by the value used in SaveOptions or SaveAsOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The view id is not valid to use as a preview view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

DocumentPreviewSettings Class


DocumentSet Class

[image]

Revit 2013 API
DocumentSet Class
Members See Also Send Feedback
A set that can contain any documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DocumentSet : APIObject,
    IEnumerable
Visual Basic
Public Class DocumentSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DocumentSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DocumentSet

See Also

DocumentSet Members


DocumentSet Members

[image] [image]

Revit 2013 API
DocumentSet Members
DocumentSet Class Constructors Methods Properties See Also Send Feedback

The DocumentSet type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSet | Initializes a new instance of the DocumentSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class


DocumentSet Constructor

[image]

Revit 2013 API
DocumentSet Constructor
DocumentSet Class See Also Send Feedback
Initializes a new instance of the DocumentSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DocumentSet()
Visual Basic
Public Sub New
Visual C++
public:
DocumentSet()

See Also

DocumentSet Class


DocumentSet Methods

[image] [image]

Revit 2013 API
DocumentSet Methods
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSet Class


Clear Method

[image]

Revit 2013 API
DocumentSet..::..Clear Method
DocumentSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DocumentSet Class


Contains Method

[image]

Revit 2013 API
DocumentSet..::..Contains Method
DocumentSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Document item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Document
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

DocumentSet Class


Erase Method

[image]

Revit 2013 API
DocumentSet..::..Erase Method
DocumentSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Document item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Document _
) As Integer
Visual C++
public:
virtual int Erase(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Document
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

DocumentSet Class


ForwardIterator Method

[image]

Revit 2013 API
DocumentSet..::..ForwardIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DocumentSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DocumentSet Class


GetEnumerator Method

[image]

Revit 2013 API
DocumentSet..::..GetEnumerator Method
DocumentSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DocumentSet Class


Insert Method

[image]

Revit 2013 API
DocumentSet..::..Insert Method
DocumentSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Document item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Document _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Document^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Document
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

DocumentSet Class


ReverseIterator Method

[image]

Revit 2013 API
DocumentSet..::..ReverseIterator Method
DocumentSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DocumentSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DocumentSetIterator
Visual C++
public:
virtual DocumentSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DocumentSet Class


DocumentSet Properties

[image] [image]

Revit 2013 API
DocumentSet Properties
DocumentSet Class See Also Send Feedback

The DocumentSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

DocumentSet Class


IsEmpty Property

[image]

Revit 2013 API
DocumentSet..::..IsEmpty Property
DocumentSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DocumentSet Class


Size Property

[image]

Revit 2013 API
DocumentSet..::..Size Property
DocumentSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DocumentSet Class


DocumentSetIterator Class

[image]

Revit 2013 API
DocumentSetIterator Class
Members See Also Send Feedback
An iterator to a set of documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DocumentSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DocumentSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DocumentSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DocumentSetIterator

See Also

DocumentSetIterator Members


DocumentSetIterator Members

[image] [image]

Revit 2013 API
DocumentSetIterator Members
DocumentSetIterator Class Constructors Methods Properties See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class


DocumentSetIterator Constructor

[image]

Revit 2013 API
DocumentSetIterator Constructor
DocumentSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DocumentSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
DocumentSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DocumentSetIterator Class


DocumentSetIterator Methods

[image] [image]

Revit 2013 API
DocumentSetIterator Methods
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSetIterator Class


MoveNext Method

[image]

Revit 2013 API
DocumentSetIterator..::..MoveNext Method
DocumentSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


Reset Method

[image]

Revit 2013 API
DocumentSetIterator..::..Reset Method
DocumentSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DocumentSetIterator Class


DocumentSetIterator Properties

[image] [image]

Revit 2013 API
DocumentSetIterator Properties
DocumentSetIterator Class See Also Send Feedback

The DocumentSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DocumentSetIterator Class


Current Property

[image]

Revit 2013 API
DocumentSetIterator..::..Current Property
DocumentSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DocumentSetIterator Class


DocumentType Enumeration

[image]

Revit 2013 API
DocumentType Enumeration
See Also Send Feedback
Types of Revit documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public enum DocumentType
Visual Basic
Public Enumeration DocumentType
Visual C++
public enum class DocumentType

Members

Member name | Description
Project | Project document.
Family | Family document.
Template | Template document.
IFC | IFC document.
BuildingComponent | Building Component document.
Other | Document of another type.

See Also


Domain Enumeration

[image]

Revit 2013 API
Domain Enumeration
See Also Send Feedback
Type of connector domain.
Enumeration of connector domain types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum Domain
Visual Basic
Public Enumeration Domain
Visual C++
public enum class Domain

Members

Member name | Description
DomainUndefined | Domain is undefined
DomainHvac | HVAC (duct) connector
DomainElectrical | Electrical connector
DomainPiping | Connector of cable trays or conduits
DomainCableTrayConduit | Connector of Structural Analytical Model

See Also


DoubleArray Class

[image]

Revit 2013 API
DoubleArray Class
Members See Also Send Feedback
An array that contains doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DoubleArray : APIObject,
    IEnumerable
Visual Basic
Public Class DoubleArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DoubleArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DoubleArray

See Also

DoubleArray Members


DoubleArray Members

[image] [image]

Revit 2013 API
DoubleArray Members
DoubleArray Class Constructors Methods Properties See Also Send Feedback

The DoubleArray type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleArray | Initializes a new instance of the DoubleArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


DoubleArray Constructor

[image]

Revit 2013 API
DoubleArray Constructor
DoubleArray Class See Also Send Feedback
Initializes a new instance of the DoubleArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray()
Visual Basic
Public Sub New
Visual C++
public:
DoubleArray()

See Also

DoubleArray Class


DoubleArray Methods

[image] [image]

Revit 2013 API
DoubleArray Methods
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every double from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArray Class


Append Method

[image]

Revit 2013 API
DoubleArray..::..Append Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    ref double item
)
Visual Basic
Public Overridable Sub Append ( _
    ByRef item As Double _
)
Visual C++
public:
virtual void Append(
    double% item
)

Parameters

item
Type: System..::..Double%

See Also

DoubleArray Class


Clear Method

[image]

Revit 2013 API
DoubleArray..::..Clear Method
DoubleArray Class See Also Send Feedback
Removes every double from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DoubleArray Class


ForwardIterator Method

[image]

Revit 2013 API
DoubleArray..::..ForwardIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

DoubleArray Class


GetEnumerator Method

[image]

Revit 2013 API
DoubleArray..::..GetEnumerator Method
DoubleArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DoubleArray Class


Insert Method

[image]

Revit 2013 API
DoubleArray..::..Insert Method
DoubleArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ref double item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    ByRef item As Double, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    double% item,
    int index
)

Parameters

item
Type: System..::..Double%
index
Type: System..::..Int32

See Also

DoubleArray Class


ReverseIterator Method

[image]

Revit 2013 API
DoubleArray..::..ReverseIterator Method
DoubleArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DoubleArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DoubleArrayIterator
Visual C++
public:
virtual DoubleArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

DoubleArray Class


DoubleArray Properties

[image] [image]

Revit 2013 API
DoubleArray Properties
DoubleArray Class See Also Send Feedback

The DoubleArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a double at a specified index within the array.
Public property | Size | Returns the number of doubles that are in the array.

See Also

DoubleArray Class


IsEmpty Property

[image]

Revit 2013 API
DoubleArray..::..IsEmpty Property
DoubleArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

DoubleArray Class


Item Property

[image]

Revit 2013 API
DoubleArray..::..Item Property
DoubleArray Class See Also Send Feedback
Gets or sets a double at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual double this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Double
    Get
    Set
Visual C++
public:
virtual property double Item[int index] {
    double get (int index);
    void set (int index, double value);
}

Parameters

index
Type: System..::..Int32
The index of the double to be set or retrieved.

Return Value

Returns the double at the specified index.

See Also

DoubleArray Class


Size Property

[image]

Revit 2013 API
DoubleArray..::..Size Property
DoubleArray Class See Also Send Feedback
Returns the number of doubles that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DoubleArray Class


DoubleArrayIterator Class

[image]

Revit 2013 API
DoubleArrayIterator Class
Members See Also Send Feedback
An iterator to an array of doubles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DoubleArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DoubleArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DoubleArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..DoubleArrayIterator

See Also

DoubleArrayIterator Members


DoubleArrayIterator Members

[image] [image]

Revit 2013 API
DoubleArrayIterator Members
DoubleArrayIterator Class Constructors Methods Properties See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DoubleArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class


DoubleArrayIterator Constructor

[image]

Revit 2013 API
DoubleArrayIterator Constructor
DoubleArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
DoubleArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Methods

[image] [image]

Revit 2013 API
DoubleArrayIterator Methods
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DoubleArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
DoubleArrayIterator..::..MoveNext Method
DoubleArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


Reset Method

[image]

Revit 2013 API
DoubleArrayIterator..::..Reset Method
DoubleArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DoubleArrayIterator Class


DoubleArrayIterator Properties

[image] [image]

Revit 2013 API
DoubleArrayIterator Properties
DoubleArrayIterator Class See Also Send Feedback

The DoubleArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DoubleArrayIterator Class


Current Property

[image]

Revit 2013 API
DoubleArrayIterator..::..Current Property
DoubleArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DoubleArrayIterator Class


DuplicateTypeAction Enumeration

[image]

Revit 2013 API
DuplicateTypeAction Enumeration
See Also Send Feedback
The Enum defines how the paste operation should handle duplicate types (inexact matches).
The Enum defined 3 different kinds of DuplicateType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum DuplicateTypeAction
Visual Basic
Public Enumeration DuplicateTypeAction
Visual C++
public enum class DuplicateTypeAction

Members

Member name | Description
Overwrite | Replace internals of existing types in the destination document with pasted types.
NewOnly | Discard inexact matches and only paste non-matches
Abort | Abort the operation

See Also


DWFExportOptions Class

[image]

Revit 2013 API
DWFExportOptions Class
Members See Also Send Feedback
DWF Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DWFExportOptions : CADExportOptions
Visual Basic
Public Class DWFExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class DWFExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..DWFExportOptions
Autodesk.Revit.DB..::..DWFXExportOptions

See Also

DWFExportOptions Members


DWFExportOptions Members

[image] [image]

Revit 2013 API
DWFExportOptions Members
DWFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWFExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


DWFExportOptions Constructor

[image]

Revit 2013 API
DWFExportOptions Constructor
DWFExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWFExportOptions()

See Also

DWFExportOptions Class


DWFExportOptions Methods

[image] [image]

Revit 2013 API
DWFExportOptions Methods
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFExportOptions Class


DWFExportOptions Properties

[image] [image]

Revit 2013 API
DWFExportOptions Properties
DWFExportOptions Class See Also Send Feedback

The DWFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportingAreas | Whether to also export areas and rooms' geometry.
Public property | ExportObjectData | Whether to include properties associated with elements.
Public property | ImageFormat | Controls the compression level of images embedded.
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used.
Public property | MergedViews | Whether to merge all views in one file.
Public property | PaperFormat | Standard paper format.
Public property | PortraitLayout | Paper orientation - Portrait/Landscape.
Public property | StopOnError | Whether export process should stop when a view fails to export.

See Also

DWFExportOptions Class


ExportingAreas Property

[image]

Revit 2013 API
DWFExportOptions..::..ExportingAreas Property
DWFExportOptions Class See Also Send Feedback
Whether to also export areas and rooms' geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ExportingAreas { get; set; }
Visual Basic
Public Property ExportingAreas As Boolean
    Get
    Set
Visual C++
public:
property bool ExportingAreas {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


ExportObjectData Property

[image]

Revit 2013 API
DWFExportOptions..::..ExportObjectData Property
DWFExportOptions Class See Also Send Feedback
Whether to include properties associated with elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ExportObjectData { get; set; }
Visual Basic
Public Property ExportObjectData As Boolean
    Get
    Set
Visual C++
public:
property bool ExportObjectData {
    bool get ();
    void set (bool value);
}

Remarks

ExportObjectData must be enabled (true) in order to also enable exporting rooms and areas (ExportingAreas). If ExportObjectData is disabled, the ExportingAreas property will be ignored.

See Also

DWFExportOptions Class


ImageFormat Property

[image]

Revit 2013 API
DWFExportOptions..::..ImageFormat Property
DWFExportOptions Class See Also Send Feedback
Controls the compression level of images embedded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFImageFormat ImageFormat { get; set; }
Visual Basic
Public Property ImageFormat As DWFImageFormat
    Get
    Set
Visual C++
public:
property DWFImageFormat ImageFormat {
    DWFImageFormat get ();
    void set (DWFImageFormat value);
}

Remarks

ImageQuality is ignored when ImageFormat is set to "PNG"-the standard format.

See Also

DWFExportOptions Class


ImageQuality Property

[image]

Revit 2013 API
DWFExportOptions..::..ImageQuality Property
DWFExportOptions Class See Also Send Feedback
Image quality level when compressed raster format(JPEG) is used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFImageQuality ImageQuality { get; set; }
Visual Basic
Public Property ImageQuality As DWFImageQuality
    Get
    Set
Visual C++
public:
property DWFImageQuality ImageQuality {
    DWFImageQuality get ();
    void set (DWFImageQuality value);
}

Remarks

The default value is Default.

See Also

DWFExportOptions Class


MergedViews Property

[image]

Revit 2013 API
DWFExportOptions..::..MergedViews Property
DWFExportOptions Class See Also Send Feedback
Whether to merge all views in one file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


PaperFormat Property

[image]

Revit 2013 API
DWFExportOptions..::..PaperFormat Property
DWFExportOptions Class See Also Send Feedback
Standard paper format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ExportPaperFormat PaperFormat { get; set; }
Visual Basic
Public Property PaperFormat As ExportPaperFormat
    Get
    Set
Visual C++
public:
property ExportPaperFormat PaperFormat {
    ExportPaperFormat get ();
    void set (ExportPaperFormat value);
}

See Also

DWFExportOptions Class


PortraitLayout Property

[image]

Revit 2013 API
DWFExportOptions..::..PortraitLayout Property
DWFExportOptions Class See Also Send Feedback
Paper orientation - Portrait/Landscape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool PortraitLayout { get; set; }
Visual Basic
Public Property PortraitLayout As Boolean
    Get
    Set
Visual C++
public:
property bool PortraitLayout {
    bool get ();
    void set (bool value);
}

See Also

DWFExportOptions Class


StopOnError Property

[image]

Revit 2013 API
DWFExportOptions..::..StopOnError Property
DWFExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

DWFExportOptions Class


DWFImageFormat Enumeration

[image]

Revit 2013 API
DWFImageFormat Enumeration
See Also Send Feedback
An enumerated type listing possible image format for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DWFImageFormat
Visual Basic
Public Enumeration DWFImageFormat
Visual C++
public enum class DWFImageFormat

Members

Member name | Description
Lossless |
Lossy |

See Also


DWFImageQuality Enumeration

[image]

Revit 2013 API
DWFImageQuality Enumeration
See Also Send Feedback
An enumerated type listing possible image quality for DWF Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DWFImageQuality
Visual Basic
Public Enumeration DWFImageQuality
Visual C++
public enum class DWFImageQuality

Members

Member name | Description
Default |
Low |
Medium |
High |

See Also


DWFXExportOptions Class

[image]

Revit 2013 API
DWFXExportOptions Class
Members See Also Send Feedback
DWFX Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DWFXExportOptions : DWFExportOptions
Visual Basic
Public Class DWFXExportOptions _
    Inherits DWFExportOptions
Visual C++
public ref class DWFXExportOptions : public DWFExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..DWFExportOptions
Autodesk.Revit.DB..::..DWFXExportOptions

See Also

DWFXExportOptions Members


DWFXExportOptions Members

[image] [image]

Revit 2013 API
DWFXExportOptions Members
DWFXExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWFXExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
Public property | ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
Public property | ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
Public property | MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
Public property | PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
Public property | PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
Public property | StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class


DWFXExportOptions Constructor

[image]

Revit 2013 API
DWFXExportOptions Constructor
DWFXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWFXExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWFXExportOptions()

See Also

DWFXExportOptions Class


DWFXExportOptions Methods

[image] [image]

Revit 2013 API
DWFXExportOptions Methods
DWFXExportOptions Class See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWFXExportOptions Class


DWFXExportOptions Properties

[image] [image]

Revit 2013 API
DWFXExportOptions Properties
DWFXExportOptions Class See Also Send Feedback

The DWFXExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportingAreas | Whether to also export areas and rooms' geometry. (Inherited from DWFExportOptions.)
Public property | ExportObjectData | Whether to include properties associated with elements. (Inherited from DWFExportOptions.)
Public property | ImageFormat | Controls the compression level of images embedded. (Inherited from DWFExportOptions.)
Public property | ImageQuality | Image quality level when compressed raster format(JPEG) is used. (Inherited from DWFExportOptions.)
Public property | MergedViews | Whether to merge all views in one file. (Inherited from DWFExportOptions.)
Public property | PaperFormat | Standard paper format. (Inherited from DWFExportOptions.)
Public property | PortraitLayout | Paper orientation - Portrait/Landscape. (Inherited from DWFExportOptions.)
Public property | StopOnError | Whether export process should stop when a view fails to export. (Inherited from DWFExportOptions.)

See Also

DWFXExportOptions Class


DWGExportOptions Class

[image]

Revit 2013 API
DWGExportOptions Class
Members See Also Send Feedback
The export options used by exporting DWG format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DWGExportOptions : ACADExportOptions
Visual Basic
Public Class DWGExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DWGExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DWGExportOptions

See Also

DWGExportOptions Members


DWGExportOptions Members

[image] [image]

Revit 2013 API
DWGExportOptions Members
DWGExportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWGExportOptions()()()() | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


DWGExportOptions Constructor

[image] [image]

Revit 2013 API
DWGExportOptions Constructor
DWGExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DWGExportOptions()()()() | Constructs a new instance of DWGExportOptions with default values of all properties.
Public method | DWGExportOptions(DWGExportOptions) | Constructs a new instance of DWGExportOptions as a copy of the export options.

See Also

DWGExportOptions Class
DWGExportOptions Members


DWGExportOptions Constructor

[image]

Revit 2013 API
DWGExportOptions Constructor
DWGExportOptions Class See Also Send Feedback
Constructs a new instance of DWGExportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWGExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWGExportOptions()

See Also

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions Constructor (DWGExportOptions)

[image]

Revit 2013 API
DWGExportOptions Constructor (DWGExportOptions)
DWGExportOptions Class See Also Send Feedback
Constructs a new instance of DWGExportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DWGExportOptions(
    DWGExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DWGExportOptions _
)
Visual C++
public:
DWGExportOptions(
    DWGExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DWGExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWGExportOptions Class
DWGExportOptions Overload


DWGExportOptions Methods

[image] [image]

Revit 2013 API
DWGExportOptions Methods
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2013 API
DWGExportOptions..::..GetPredefinedOptions Method
DWGExportOptions Class See Also Send Feedback
Returns an instance DWGExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static DWGExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DWGExportOptions
Visual C++
public:
static DWGExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DWGExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWGExportOptions Class


DWGExportOptions Properties

[image] [image]

Revit 2013 API
DWGExportOptions Properties
DWGExportOptions Class See Also Send Feedback

The DWGExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | MergedViews | Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)

See Also

DWGExportOptions Class


MergedViews Property

[image]

Revit 2013 API
DWGExportOptions..::..MergedViews Property
DWGExportOptions Class See Also Send Feedback
Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool MergedViews { get; set; }
Visual Basic
Public Property MergedViews As Boolean
    Get
    Set
Visual C++
public:
property bool MergedViews {
    bool get ();
    void set (bool value);
}

See Also

DWGExportOptions Class


DWGImportOptions Class

[image]

Revit 2013 API
DWGImportOptions Class
Members See Also Send Feedback
The import options used by importing DWG or DXF format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DWGImportOptions : BaseImportOptions
Visual Basic
Public Class DWGImportOptions _
    Inherits BaseImportOptions
Visual C++
public ref class DWGImportOptions : public BaseImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseImportOptions
Autodesk.Revit.DB..::..DWGImportOptions

See Also

DWGImportOptions Members


DWGImportOptions Members

[image] [image]

Revit 2013 API
DWGImportOptions Members
DWGImportOptions Class Constructors Methods Properties See Also Send Feedback

The DWGImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DWGImportOptions()()()() | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetLineWeights |
Public method | GetRefPoint | (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetLineWeights |
Public method | SetRefPoint | (Inherited from BaseImportOptions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DWGImportOptions Class


DWGImportOptions Constructor

[image] [image]

Revit 2013 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DWGImportOptions()()()() | Constructs a new instance of DWGImportOptions with default values of all properties.
Public method | DWGImportOptions(DWGImportOptions) | Constructs a new instance of DWGImportOptions as a copy of the import options.

See Also

DWGImportOptions Class
DWGImportOptions Members


DWGImportOptions Constructor

[image]

Revit 2013 API
DWGImportOptions Constructor
DWGImportOptions Class See Also Send Feedback
Constructs a new instance of DWGImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DWGImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DWGImportOptions()

See Also

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions Constructor (DWGImportOptions)

[image]

Revit 2013 API
DWGImportOptions Constructor (DWGImportOptions)
DWGImportOptions Class See Also Send Feedback
Constructs a new instance of DWGImportOptions as a copy of the import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DWGImportOptions(
    DWGImportOptions option
)
Visual Basic
Public Sub New ( _
    option As DWGImportOptions _
)
Visual C++
public:
DWGImportOptions(
    DWGImportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DWGImportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWGImportOptions Class
DWGImportOptions Overload


DWGImportOptions Methods

[image] [image]

Revit 2013 API
DWGImportOptions Methods
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseImportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLayerSelection | Get all set layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | GetLineWeights |
Public method | GetRefPoint | (Inherited from BaseImportOptions.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayerSelection | Set the layers name which user want to import into Revit. (Inherited from BaseImportOptions.)
Public method | SetLineWeights |
Public method | SetRefPoint | (Inherited from BaseImportOptions.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DWGImportOptions Class


GetLineWeights Method

[image]

Revit 2013 API
DWGImportOptions..::..GetLineWeights Method
DWGImportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<int> GetLineWeights()
Visual Basic
Public Function GetLineWeights As IList(Of Integer)
Visual C++
public:
IList<int>^ GetLineWeights()

See Also

DWGImportOptions Class


SetLineWeights Method

[image]

Revit 2013 API
DWGImportOptions..::..SetLineWeights Method
DWGImportOptions Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLineWeights(
    IList<int> lineWeight
)
Visual Basic
Public Sub SetLineWeights ( _
    lineWeight As IList(Of Integer) _
)
Visual C++
public:
void SetLineWeights(
    IList<int>^ lineWeight
)

Parameters

lineWeight
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DWGImportOptions Class


DWGImportOptions Properties

[image] [image]

Revit 2013 API
DWGImportOptions Properties
DWGImportOptions Class See Also Send Feedback

The DWGImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | AutoCorrectAlmostVHLines | Correct almost-vertical lines and almost-horizontal lines for import model if option is set to true, the almost-vertical lines would be vertical lines and almost-horizontal lines would be horizontal lines. (Inherited from BaseImportOptions.)
Public property | ColorMode | Color mode for the import. Three modes are supported. Black and White, Preserve Colors, and Invert Colors. (Inherited from BaseImportOptions.)
Public property | CustomScale | Scaling the import. If this is defined and a valid value (> 0.0), it takes preference over units. (Inherited from BaseImportOptions.)
Public property | OrientToView | Place the import at the same orientation as the view that was passed into the import method. This option can only be used when not importing into a single view.(i.e. ThisViewOnly is set to false); (Inherited from BaseImportOptions.)
Public property | Placement | Where to place the import. Set this option to place the view at the origin or the center, or a shared coordinates. (Inherited from BaseImportOptions.)
Public property | ThisViewOnly | Imports drawings into the view that was passed into the import method. This option is not available in 3D views. (Inherited from BaseImportOptions.)
Public property | Unit | The unit of measure for imported geometry. (Inherited from BaseImportOptions.)
Public property | VisibleLayersOnly | Only import the visible layers. (Inherited from BaseImportOptions.)

See Also

DWGImportOptions Class


DXFExportOptions Class

[image]

Revit 2013 API
DXFExportOptions Class
Members See Also Send Feedback
The export options used by exporting DXF format file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DXFExportOptions : ACADExportOptions
Visual Basic
Public Class DXFExportOptions _
    Inherits ACADExportOptions
Visual C++
public ref class DXFExportOptions : public ACADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BaseExportOptions
Autodesk.Revit.DB..::..ACADExportOptions
Autodesk.Revit.DB..::..DXFExportOptions

See Also

DXFExportOptions Members


DXFExportOptions Members

[image] [image]

Revit 2013 API
DXFExportOptions Members
DXFExportOptions Class Constructors Methods Properties See Also Send Feedback

The DXFExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | DXFExportOptions()()()() | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


DXFExportOptions Constructor

[image] [image]

Revit 2013 API
DXFExportOptions Constructor
DXFExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DXFExportOptions()()()() | Constructs a new instance of DXFImportOptions with default values of all properties.
Public method | DXFExportOptions(DXFExportOptions) | Constructs a new instance of DXFImportOptions as a copy of the export options.

See Also

DXFExportOptions Class
DXFExportOptions Members


DXFExportOptions Constructor

[image]

Revit 2013 API
DXFExportOptions Constructor
DXFExportOptions Class See Also Send Feedback
Constructs a new instance of DXFImportOptions with default values of all properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public DXFExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
DXFExportOptions()

See Also

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions Constructor (DXFExportOptions)

[image]

Revit 2013 API
DXFExportOptions Constructor (DXFExportOptions)
DXFExportOptions Class See Also Send Feedback
Constructs a new instance of DXFImportOptions as a copy of the export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public DXFExportOptions(
    DXFExportOptions option
)
Visual Basic
Public Sub New ( _
    option As DXFExportOptions _
)
Visual C++
public:
DXFExportOptions(
    DXFExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..DXFExportOptions
The options to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DXFExportOptions Class
DXFExportOptions Overload


DXFExportOptions Methods

[image] [image]

Revit 2013 API
DXFExportOptions Methods
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BaseExportOptions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPredefinedOptions | Returns an instance DXFExportOptions containing settings from a predefined export setup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DXFExportOptions Class


GetPredefinedOptions Method

[image]

Revit 2013 API
DXFExportOptions..::..GetPredefinedOptions Method
DXFExportOptions Class See Also Send Feedback
Returns an instance DXFExportOptions containing settings from a predefined export setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static DXFExportOptions GetPredefinedOptions(
    Document document,
    string setup
)
Visual Basic
Public Shared Function GetPredefinedOptions ( _
    document As Document, _
    setup As String _
) As DXFExportOptions
Visual C++
public:
static DXFExportOptions^ GetPredefinedOptions(
    Document^ document,
    String^ setup
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A Revit project document to retrieve the setup from.
setup
Type: System..::..String
The name of a predefined export setup from the specified document.

Return Value

An instance of predefined DXFExportOptions, or nullNothingnullptra null reference (Nothing in Visual Basic) if the name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DXFExportOptions Class


DXFExportOptions Properties

[image] [image]

Revit 2013 API
DXFExportOptions Properties
DXFExportOptions Class See Also Send Feedback

The DXFExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ACAPreference | The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object. (Inherited from ACADExportOptions.)
Public property | Colors | Export color mode. Default value is ExportColorMode.IndexColors. (Inherited from BaseExportOptions.)
Public property | ExportingAreas | True to export area and room geometry, false otherwise. Default value is false. (Inherited from ACADExportOptions.)
Public property | ExportOfSolids | The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh. (Inherited from ACADExportOptions.)
Public property | FileVersion | ACADVersion::Default Default value is ACADVersion.Default. (Inherited from ACADExportOptions.)
Public property | HatchPatternsFileName | Custom hatch patterns (pat) file name. (Inherited from BaseExportOptions.)
Public property | HideReferencePlane | Whether or not to hide reference planes. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideScopeBox | Whether or not to hide the scope box. Default value is false. (Inherited from BaseExportOptions.)
Public property | HideUnreferenceViewTags | Whether or not to hide unreference view tags. Default value is false. (Inherited from BaseExportOptions.)
Public property | LayerMapping | Name of a layer settings standard or filename (with custom layer settings). Valid standards are: AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization. (Inherited from BaseExportOptions.)
Public property | LineScaling | The scaling mode for the line type. Default value is LineScaling.ViewScale. (Inherited from ACADExportOptions.)
Public property | LinetypesFileName | The custom linetype file name (*.lin). Default value is empty. (Inherited from ACADExportOptions.)
Public property | MarkNonplotLayers | If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot. (Inherited from ACADExportOptions.)
Public property | NonplotSuffix | If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty. (Inherited from ACADExportOptions.)
Public property | PropOverrides | How to export overridden object styles. Default value is PropOverrideMode.ByEntity. (Inherited from BaseExportOptions.)
Public property | SharedCoords | True to use the shared coordinate system's origin, false to use the project origin. Default value is false. (Inherited from ACADExportOptions.)
Public property | TargetUnit | The target unit type. Default value is ExportUnit.Default. (Inherited from ACADExportOptions.)
Public property | TextTreatment | The text treatment. Deault value is TextTreatment.Exact. (Inherited from ACADExportOptions.)

See Also

DXFExportOptions Class


EaveCutterType Enumeration

[image]

Revit 2013 API
EaveCutterType Enumeration
See Also Send Feedback
An enumerated type to store type of EaveCutter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum EaveCutterType
Visual Basic
Public Enumeration EaveCutterType
Visual C++
public enum class EaveCutterType

Members

Member name | Description
PlumbCut | Plumb Cut type of Eave.
TwoCutSquare | Two Cut Square type of Eave.
TwoCutPlumb | Two Cut Plumb type of Eave.

See Also


Edge Class

[image]

Revit 2013 API
Edge Class
Members See Also Send Feedback
An edge of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Edge : GeometryObject
Visual Basic
Public Class Edge _
    Inherits GeometryObject
Visual C++
public ref class Edge : public GeometryObject

Remarks

Edges are defined by intersections of surfaces that form faces of the solid. They have arbitrary parameterization that is normalized to [0,1].

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Edge

See Also

Edge Members


Edge Members

[image] [image]

Revit 2013 API
Edge Members
Edge Class Methods Properties See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class


Edge Methods

[image] [image]

Revit 2013 API
Edge Methods
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Methods

 | Name | Description
Public method | AsCurve | Returns a curve that corresponds to the edge's parametric orientation.
Public method | AsCurveFollowingFace | Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Public method | ComputeDerivatives | Returns the vectors describing the edge at the specified parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the edge.
Public method | EvaluateOnFace | Evaluates a parameter on the edge to produce UV coordinates on the face.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Tessellate | Returns a polyline approximation to the edge.
Public method | TessellateOnFace | Returns a polyline approximation to the edge in UV parameters of the face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Edge Class


AsCurve Method

[image]

Revit 2013 API
Edge..::..AsCurve Method
Edge Class See Also Send Feedback
Returns a curve that corresponds to the edge's parametric orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve AsCurve()
Visual Basic
Public Function AsCurve As Curve
Visual C++
public:
Curve^ AsCurve()

Return Value

It can be an Arc, Line, or HermiteSpline.

See Also

Edge Class


AsCurveFollowingFace Method

[image]

Revit 2013 API
Edge..::..AsCurveFollowingFace Method
Edge Class See Also Send Feedback
Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve AsCurveFollowingFace(
    Face faceForDir
)
Visual Basic
Public Function AsCurveFollowingFace ( _
    faceForDir As Face _
) As Curve
Visual C++
public:
Curve^ AsCurveFollowingFace(
    Face^ faceForDir
)

Parameters

faceForDir
Type: Autodesk.Revit.DB..::..Face
Specifies the face, on which the curve will follow the topological direction of the edge.

Return Value

It can be an Arc, Line, or HermiteSpline.

Remarks

Evaluating the edge using EvaluateOnFace gives the same result as evaluating the curve returned by AsCurveFollowingFace with a normalized curve parameter. When a Hermite spline is returned, the two evaluated points will be approximately equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified faceForDir is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified faceForDir is not one of the faces for this edge.

See Also

Edge Class


ComputeDerivatives Method

[image]

Revit 2013 API
Edge..::..ComputeDerivatives Method
Edge Class See Also Send Feedback
Returns the vectors describing the edge at the specified parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    double parameter
)
Visual Basic
Public Function ComputeDerivatives ( _
    parameter As Double _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    double parameter
)

Parameters

parameter
Type: System..::..Double
The parameter to be evaluated.

Return Value

The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.

Remarks

The following is the meaning of the transformation members: Origin is the point on the edge (equivalent to Evaluate); BasisX is the tangent vector (the first derivative); BasisY is the second derivative; BasisZ is the bi-normal vector (tangent x normal). Normal and bi-normal are zero if the edge is straight at the point. None of the vectors are normalized.

See Also

Edge Class


Evaluate Method

[image]

Revit 2013 API
Edge..::..Evaluate Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated, in [0,1].

See Also

Edge Class


EvaluateOnFace Method

[image]

Revit 2013 API
Edge..::..EvaluateOnFace Method
Edge Class See Also Send Feedback
Evaluates a parameter on the edge to produce UV coordinates on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV EvaluateOnFace(
    double param,
    Face face
)
Visual Basic
Public Function EvaluateOnFace ( _
    param As Double, _
    face As Face _
) As UV
Visual C++
public:
UV^ EvaluateOnFace(
    double param,
    Face^ face
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated, in [0,1].
face
Type: Autodesk.Revit.DB..::..Face
The face on which to perform the evaluation. Must belong to the edge.

See Also

Edge Class


Tessellate Method

[image]

Revit 2013 API
Edge..::..Tessellate Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Tessellate()
Visual Basic
Public Function Tessellate As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ Tessellate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class


TessellateOnFace Method

[image]

Revit 2013 API
Edge..::..TessellateOnFace Method
Edge Class See Also Send Feedback
Returns a polyline approximation to the edge in UV parameters of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<UV> TessellateOnFace(
    Face face
)
Visual Basic
Public Function TessellateOnFace ( _
    face As Face _
) As IList(Of UV)
Visual C++
public:
IList<UV^>^ TessellateOnFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face on which to perform the tessellation. Must belong to the edge.

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

See Also

Edge Class


Edge Properties

[image] [image]

Revit 2013 API
Edge Properties
Edge Class See Also Send Feedback

The Edge type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | Returns the approximate length of the edge.
Public property | EndPointReference | Returns a stable reference to the start or the end point of the edge.
Public property | Face | Returns one of the two faces that meet at the edge.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the edge.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Edge Class


ApproximateLength Property

[image]

Revit 2013 API
Edge..::..ApproximateLength Property
Edge Class See Also Send Feedback
Returns the approximate length of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApproximateLength { get; }
Visual Basic
Public ReadOnly Property ApproximateLength As Double
    Get
Visual C++
public:
property double ApproximateLength {
    double get ();
}

Remarks

Estimates the length of the edge by adding together tessellated segments, Will underestimate when the surface is curved.

See Also

Edge Class


EndPointReference Property

[image]

Revit 2013 API
Edge..::..EndPointReference Property
Edge Class See Also Send Feedback
Returns a stable reference to the start or the end point of the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property EndPointReference ( _
    index As Integer _
) As Reference
    Get
Visual C++
public:
property Reference^ EndPointReference[int index] {
    Reference^ get (int index);
}

Parameters

index
Type: System..::..Int32
Use 0 for the start point; 1 for the end point.

Return Value

Reference to the point or nullNothingnullptra null reference (Nothing in Visual Basic) if reference cannot be obtained.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the object is internally marked as read-only in the setter.

See Also

Edge Class


Face Property

[image]

Revit 2013 API
Edge..::..Face Property
Edge Class See Also Send Feedback
Returns one of the two faces that meet at the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Face this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Face ( _
    idx As Integer _
) As Face
    Get
Visual C++
public:
property Face^ Face[int idx] {
    Face^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
The index of the face (0 or 1).

See Also

Edge Class


Reference Property

[image]

Revit 2013 API
Edge..::..Reference Property
Edge Class See Also Send Feedback
Returns a stable reference to the edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Edge Class


EdgeArray Class

[image]

Revit 2013 API
EdgeArray Class
Members See Also Send Feedback
An array that contains edges.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class EdgeArray : APIObject, IEnumerable
Visual Basic
Public Class EdgeArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArray

See Also

EdgeArray Members


EdgeArray Members

[image] [image]

Revit 2013 API
EdgeArray Members
EdgeArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArray type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArray | Initializes a new instance of the EdgeArray class

Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class


EdgeArray Constructor

[image]

Revit 2013 API
EdgeArray Constructor
EdgeArray Class See Also Send Feedback
Initializes a new instance of the EdgeArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArray()
Visual Basic
Public Sub New
Visual C++
public:
EdgeArray()

See Also

EdgeArray Class


EdgeArray Methods

[image] [image]

Revit 2013 API
EdgeArray Methods
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the edge to the end of the array.
Public method | Clear | Removes every edge from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArray Class


Append Method

[image]

Revit 2013 API
EdgeArray..::..Append Method
EdgeArray Class See Also Send Feedback
Add the edge to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Edge item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Edge _
)
Visual C++
public:
virtual void Append(
    Edge^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Edge
The edge to be added.

See Also

EdgeArray Class


Clear Method

[image]

Revit 2013 API
EdgeArray..::..Clear Method
EdgeArray Class See Also Send Feedback
Removes every edge from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArray Class


ForwardIterator Method

[image]

Revit 2013 API
EdgeArray..::..ForwardIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArray Class


GetEnumerator Method

[image]

Revit 2013 API
EdgeArray..::..GetEnumerator Method
EdgeArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

EdgeArray Class


Insert Method

[image]

Revit 2013 API
EdgeArray..::..Insert Method
EdgeArray Class See Also Send Feedback
Insert the specified edge into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Edge item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Edge, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Edge^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Edge
The edge to be inserted into the array.
index
Type: System..::..Int32
The edge will be inserted before this index.

Return Value

Returns whether the edge was inserted into the array.

See Also

EdgeArray Class


ReverseIterator Method

[image]

Revit 2013 API
EdgeArray..::..ReverseIterator Method
EdgeArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual EdgeArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As EdgeArrayIterator
Visual C++
public:
virtual EdgeArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArray Class


EdgeArray Properties

[image] [image]

Revit 2013 API
EdgeArray Properties
EdgeArray Class See Also Send Feedback

The EdgeArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge at a specified index within the array.
Public property | Size | Returns the number of edges that are in the array.

See Also

EdgeArray Class


IsEmpty Property

[image]

Revit 2013 API
EdgeArray..::..IsEmpty Property
EdgeArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArray Class


Item Property

[image]

Revit 2013 API
EdgeArray..::..Item Property
EdgeArray Class See Also Send Feedback
Gets or sets an edge at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Edge this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Edge
    Get
    Set
Visual C++
public:
virtual property Edge^ Item[int index] {
    Edge^ get (int index);
    void set (int index, Edge^ value);
}

Parameters

index
Type: System..::..Int32
The index of the edge to be set or retrieved.

Return Value

Returns the edge at the specified index.

See Also

EdgeArray Class


Size Property

[image]

Revit 2013 API
EdgeArray..::..Size Property
EdgeArray Class See Also Send Feedback
Returns the number of edges that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArray Class


EdgeArrayArray Class

[image]

Revit 2013 API
EdgeArrayArray Class
Members Example See Also Send Feedback
An array of edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class EdgeArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class EdgeArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class EdgeArrayArray : public APIObject,
    IEnumerable

Examples

CopyC#
public void GetEdgeArrayArray(Autodesk.Revit.ApplicationServices.Application app, Autodesk.Revit.DB.Element element)
{
    // Get geometry element of the selected element
    Options geoOptions = app.Create.NewGeometryOptions();
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);
    // Get geometry object
    foreach (GeometryObject o in geoElement.Objects)
    {
        Solid solid = o as Solid;
        if (null != solid)
        {
            foreach (Face face in solid.Faces)
            {
                if (face != null)
                {
                    EdgeArrayArray edgeArrays = face.EdgeLoops;
                    foreach (EdgeArray edges in edgeArrays)
                    {
                        foreach (Edge edge in edges)
                        {
                            // Get one test point
                            XYZ testPoint = edge.Evaluate(0.5);
                            string edgeInfo = string.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z);
                            TaskDialog.Show("Revit",edgeInfo);
                        }
                    }
                }
            }
        }
    }
}
CopyVB.NET
Public Sub GetEdgeArrayArray(ByVal app As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element)
    ' Get geometry element of the selected element
    Dim geoOptions As Autodesk.Revit.DB.Options = app.Create.NewGeometryOptions()
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)
    ' Get geometry object
    For Each o As GeometryObject In geoElement.Objects
        Dim solid As Solid = TryCast(o, Solid)
        If solid IsNot Nothing Then
            For Each face As Autodesk.Revit.DB.Face In solid.Faces
                If face IsNot Nothing Then
                    Dim edgeArrays As EdgeArrayArray = face.EdgeLoops
                    For Each edges As EdgeArray In edgeArrays
                        For Each edge As Autodesk.Revit.DB.Edge In edges
                            ' Get one test point
                            Dim testPoint As Autodesk.Revit.DB.XYZ = edge.Evaluate(0.5)
                            Dim edgeInfo As String = String.Format("Point on edge: ({0},{1},{2})", testPoint.X, testPoint.Y, testPoint.Z)
                            TaskDialog.Show("Revit", edgeInfo)
                        Next
                    Next
                End If
            Next
        End If
    Next
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayArray

See Also

EdgeArrayArray Members


EdgeArrayArray Members

[image] [image]

Revit 2013 API
EdgeArrayArray Members
EdgeArrayArray Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayArray | Initializes a new instance of the EdgeArrayArray class

Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


EdgeArrayArray Constructor

[image]

Revit 2013 API
EdgeArrayArray Constructor
EdgeArrayArray Class See Also Send Feedback
Initializes a new instance of the EdgeArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
EdgeArrayArray()

See Also

EdgeArrayArray Class


EdgeArrayArray Methods

[image] [image]

Revit 2013 API
EdgeArrayArray Methods
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the edge array to the end of the array.
Public method | Clear | Removes every edge array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified edge array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArray Class


Append Method

[image]

Revit 2013 API
EdgeArrayArray..::..Append Method
EdgeArrayArray Class See Also Send Feedback
Add the edge array to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    EdgeArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As EdgeArray _
)
Visual C++
public:
virtual void Append(
    EdgeArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..EdgeArray
The edge array to be added.

See Also

EdgeArrayArray Class


Clear Method

[image]

Revit 2013 API
EdgeArrayArray..::..Clear Method
EdgeArrayArray Class See Also Send Feedback
Removes every edge array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

EdgeArrayArray Class


ForwardIterator Method

[image]

Revit 2013 API
EdgeArrayArray..::..ForwardIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

EdgeArrayArray Class


GetEnumerator Method

[image]

Revit 2013 API
EdgeArrayArray..::..GetEnumerator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

EdgeArrayArray Class


Insert Method

[image]

Revit 2013 API
EdgeArrayArray..::..Insert Method
EdgeArrayArray Class See Also Send Feedback
Insert the specified edge array into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    EdgeArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As EdgeArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    EdgeArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..EdgeArray
The edge array to be inserted into the array.
index
Type: System..::..Int32
The edge array will be inserted before this index.

Return Value

Returns whether the edge array was inserted into the array.

See Also

EdgeArrayArray Class


ReverseIterator Method

[image]

Revit 2013 API
EdgeArrayArray..::..ReverseIterator Method
EdgeArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual EdgeArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As EdgeArrayArrayIterator
Visual C++
public:
virtual EdgeArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

EdgeArrayArray Class


EdgeArrayArray Properties

[image] [image]

Revit 2013 API
EdgeArrayArray Properties
EdgeArrayArray Class See Also Send Feedback

The EdgeArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an edge array at a specified index within the array.
Public property | Size | Returns the number of edge arrays that are in the array.

See Also

EdgeArrayArray Class


IsEmpty Property

[image]

Revit 2013 API
EdgeArrayArray..::..IsEmpty Property
EdgeArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

EdgeArrayArray Class


Item Property

[image]

Revit 2013 API
EdgeArrayArray..::..Item Property
EdgeArrayArray Class See Also Send Feedback
Gets or sets an edge array at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual EdgeArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As EdgeArray
    Get
    Set
Visual C++
public:
virtual property EdgeArray^ Item[int index] {
    EdgeArray^ get (int index);
    void set (int index, EdgeArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the edge array to be set or retrieved.

Return Value

Returns the edge array at the specified index.

See Also

EdgeArrayArray Class


Size Property

[image]

Revit 2013 API
EdgeArrayArray..::..Size Property
EdgeArrayArray Class See Also Send Feedback
Returns the number of edge arrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

EdgeArrayArray Class


EdgeArrayArrayIterator Class

[image]

Revit 2013 API
EdgeArrayArrayIterator Class
Members See Also Send Feedback
An iterator to an array or edge arrays.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class EdgeArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class EdgeArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayArrayIterator

See Also

EdgeArrayArrayIterator Members


EdgeArrayArrayIterator Members

[image] [image]

Revit 2013 API
EdgeArrayArrayIterator Members
EdgeArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Constructor

[image]

Revit 2013 API
EdgeArrayArrayIterator Constructor
EdgeArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
EdgeArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Methods

[image] [image]

Revit 2013 API
EdgeArrayArrayIterator Methods
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
EdgeArrayArrayIterator..::..MoveNext Method
EdgeArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class


Reset Method

[image]

Revit 2013 API
EdgeArrayArrayIterator..::..Reset Method
EdgeArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayArrayIterator Class


EdgeArrayArrayIterator Properties

[image] [image]

Revit 2013 API
EdgeArrayArrayIterator Properties
EdgeArrayArrayIterator Class See Also Send Feedback

The EdgeArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayArrayIterator Class


Current Property

[image]

Revit 2013 API
EdgeArrayArrayIterator..::..Current Property
EdgeArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayArrayIterator Class


EdgeArrayIterator Class

[image]

Revit 2013 API
EdgeArrayIterator Class
Members See Also Send Feedback
An iterator to an edge array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class EdgeArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class EdgeArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class EdgeArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..EdgeArrayIterator

See Also

EdgeArrayIterator Members


EdgeArrayIterator Members

[image] [image]

Revit 2013 API
EdgeArrayIterator Members
EdgeArrayIterator Class Constructors Methods Properties See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | EdgeArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class


EdgeArrayIterator Constructor

[image]

Revit 2013 API
EdgeArrayIterator Constructor
EdgeArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
EdgeArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

EdgeArrayIterator Class


EdgeArrayIterator Methods

[image] [image]

Revit 2013 API
EdgeArrayIterator Methods
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EdgeArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
EdgeArrayIterator..::..MoveNext Method
EdgeArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class


Reset Method

[image]

Revit 2013 API
EdgeArrayIterator..::..Reset Method
EdgeArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

EdgeArrayIterator Class


EdgeArrayIterator Properties

[image] [image]

Revit 2013 API
EdgeArrayIterator Properties
EdgeArrayIterator Class See Also Send Feedback

The EdgeArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

EdgeArrayIterator Class


Current Property

[image]

Revit 2013 API
EdgeArrayIterator..::..Current Property
EdgeArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

EdgeArrayIterator Class


Element Class

[image]

Revit 2013 API
Element Class
Members See Also Send Feedback
Base class for most persistent data within a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Element : IDisposable
Visual Basic
Public Class Element _
    Implements IDisposable
Visual C++
public ref class Element : IDisposable

Remarks

The data in a Revit document consists primarily of a collection of elements. An element usually corresponds to a single component of a building or drawing, such as a wall, door, or dimension, but it can also be something more abstract, like a wall type or a view. Every element in a document has a unique ID, represented by the ElementId class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegend
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayStyle
Autodesk.Revit.DB.Analysis..::..MassEnergyAnalyticalModel
Autodesk.Revit.DB.Analysis..::..MassLevelData
Autodesk.Revit.DB.Analysis..::..MassSurfaceData
Autodesk.Revit.DB.Analysis..::..MassZone
Autodesk.Revit.DB.Analysis..::..SpatialFieldManager
Autodesk.Revit.DB.Architecture..::..ContinuousRail
Autodesk.Revit.DB.Architecture..::..Railing
Autodesk.Revit.DB.Architecture..::..Stairs
Autodesk.Revit.DB.Architecture..::..StairsLanding
Autodesk.Revit.DB.Architecture..::..StairsPath
Autodesk.Revit.DB.Architecture..::..StairsRun
Autodesk.Revit.DB..::..AreaScheme
Autodesk.Revit.DB..::..AssemblyInstance
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..BasePoint
Autodesk.Revit.DB..::..BeamSystem
Autodesk.Revit.DB..::..BoundaryConditions
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB..::..Control
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..DesignOption
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..DividedPath
Autodesk.Revit.DB..::..DividedSurface
Autodesk.Revit.DB.Electrical..::..CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::..ElectricalDemandFactorDefinition
Autodesk.Revit.DB.Electrical..::..ElectricalLoadClassification
Autodesk.Revit.DB.Electrical..::..PanelScheduleSheetInstance
Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..ElevationMarker
Autodesk.Revit.DB..::..ExportDGNSettings
Autodesk.Revit.DB..::..ExportDWGSettings
Autodesk.Revit.DB.ExtensibleStorage..::..DataStorage
Autodesk.Revit.DB..::..FaceSplitter
Autodesk.Revit.DB..::..FamilyBase
Autodesk.Revit.DB..::..FilledRegion
Autodesk.Revit.DB..::..FillPatternElement
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..GraphicsStyle
Autodesk.Revit.DB..::..Grid
Autodesk.Revit.DB..::..Group
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..IndependentTag
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..Level
Autodesk.Revit.DB..::..LinePatternElement
Autodesk.Revit.DB..::..Material
Autodesk.Revit.DB.Mechanical..::..Zone
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB..::..ModelText
Autodesk.Revit.DB..::..MultiSegmentGrid
Autodesk.Revit.DB..::..NumberSystem
Autodesk.Revit.DB..::..Opening
Autodesk.Revit.DB..::..Part
Autodesk.Revit.DB..::..PartMaker
Autodesk.Revit.DB..::..Phase
Autodesk.Revit.DB..::..PhaseFilter
Autodesk.Revit.DB..::..PrintSetting
Autodesk.Revit.DB..::..ProjectInfo
Autodesk.Revit.DB..::..ProjectUnit
Autodesk.Revit.DB..::..PropertyLine
Autodesk.Revit.DB..::..PropertySetElement
Autodesk.Revit.DB..::..PropertySetLibrary
Autodesk.Revit.DB..::..ReferencePlane
Autodesk.Revit.DB..::..ReferencePoint
Autodesk.Revit.DB..::..ScheduleSheetInstance
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..SketchPlane
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB..::..SpatialElementCalculationPoint
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB.Structure..::..AnalyticalLink
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AreaReinforcement
Autodesk.Revit.DB.Structure..::..FabricArea
Autodesk.Revit.DB.Structure..::..FabricSheet
Autodesk.Revit.DB.Structure..::..Hub
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..LoadCase
Autodesk.Revit.DB.Structure..::..LoadCombination
Autodesk.Revit.DB.Structure..::..LoadNature
Autodesk.Revit.DB.Structure..::..LoadUsage
Autodesk.Revit.DB.Structure..::..PathReinforcement
Autodesk.Revit.DB.Structure..::..Rebar
Autodesk.Revit.DB.Structure..::..RebarInSystem
Autodesk.Revit.DB.Structure..::..Truss
Autodesk.Revit.DB..::..SunAndShadowSettings
Autodesk.Revit.DB..::..TextElement
Autodesk.Revit.DB..::..TopographySurface
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..Viewport
Autodesk.Revit.DB..::..ViewSheetSet
Autodesk.Revit.DB..::..WorksharingDisplaySettings

See Also

Element Members


Element Members

[image] [image]

Revit 2013 API
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | Dispose | Releases all resources used by the Element
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element.
Public method | GetMaterialVolume | Get the volume of the given material on this element.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | Level | If the element is level based then level to which the element is assigned is returned.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Materials | Get all materials present in the element.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created.
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class


Element Methods

[image] [image]

Revit 2013 API
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.
Public method | ChangeTypeId(ElementId) | Changes type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element.
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element.
 | GetChangeTypeAny | Returns ChangeType associated with any change in an element.
 | GetChangeTypeElementAddition | Returns ChangeType associated with element addition
 | GetChangeTypeElementDeletion | Returns ChangeType associated with element deletion.
 | GetChangeTypeGeometry | Returns ChangeType associated with a change in the geometry of an element
 | GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
 | GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object.
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element.
Public method | GetMaterialVolume | Get the volume of the given material on this element.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring.
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
Public method | IsExternalFileReference | Determines whether this Element represents an external file.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models.
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Element Class


ArePhasesModifiable Method

[image]

Revit 2013 API
Element..::..ArePhasesModifiable Method
Element Class See Also Send Feedback
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ArePhasesModifiable()
Visual Basic
Public Function ArePhasesModifiable As Boolean
Visual C++
public:
bool ArePhasesModifiable()

Return Value

True if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element, false otherwise.

Remarks

Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


CanBeHidden Method

[image]

Revit 2013 API
Element..::..CanBeHidden Method
Element Class See Also Send Feedback
Indicates if the element can be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanBeHidden(
    View pView
)
Visual Basic
Public Function CanBeHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool CanBeHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View

Return Value

If the element is not permitted to be hidden, false is returned.

Remarks

See discussion for some types of elements which may not be hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


CanHaveAnalyticalModel Method

[image]

Revit 2013 API
Element..::..CanHaveAnalyticalModel Method
Element Class See Also Send Feedback
Indicates whether the Element can have an Analytical Model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveAnalyticalModel()
Visual Basic
Public Function CanHaveAnalyticalModel As Boolean
Visual C++
public:
bool CanHaveAnalyticalModel()

Return Value

True if the Element can have an Analytical Model, false otherwise.

See Also

Element Class


CanHaveTypeAssigned Method

[image] [image]

Revit 2013 API
Element..::..CanHaveTypeAssigned Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned.
 | CanHaveTypeAssigned(Document, ICollection<(Of <<'(ElementId>)>>)) | Checks if all elements in the set can have a type assigned.

See Also

Element Class
Element Members


CanHaveTypeAssigned Method

[image]

Revit 2013 API
Element..::..CanHaveTypeAssigned Method
Element Class See Also Send Feedback
Identifies if the element can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveTypeAssigned()
Visual Basic
Public Function CanHaveTypeAssigned As Boolean
Visual C++
public:
bool CanHaveTypeAssigned()

Return Value

True if element can have a type assigned, false otherwise.

Remarks

Some elements cannot have type assigned, in which case invalid element id is considered to be their type id.

See Also

Element Class
CanHaveTypeAssigned Overload


CanHaveTypeAssigned Method (Document, ICollection(ElementId))

[image]

Revit 2013 API
Element..::..CanHaveTypeAssigned Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Checks if all elements in the set can have a type assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CanHaveTypeAssigned(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function CanHaveTypeAssigned ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanHaveTypeAssigned(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs.

Return Value

True if all elements in the set can have a type assigned, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
CanHaveTypeAssigned Overload


ChangeTypeId Method

[image] [image]

Revit 2013 API
Element..::..ChangeTypeId Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ChangeTypeId(ElementId) | Changes type of the element.
 | ChangeTypeId(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Changes the type of all elements in the given set.

See Also

Element Class
Element Members


ChangeTypeId Method (ElementId)

[image]

Revit 2013 API
Element..::..ChangeTypeId Method (ElementId)
Element Class See Also Send Feedback
Changes type of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ChangeTypeId(
    ElementId typeId
)
Visual Basic
Public Function ChangeTypeId ( _
    typeId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ ChangeTypeId(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this element.

Return Value

The new element id if new element is created, or invalid element id.

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. In this situation the new element id is returned. Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type typeId is not valid for this element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element cannot have type assigned.

See Also

Element Class
ChangeTypeId Overload


ChangeTypeId Method (Document, ICollection(ElementId), ElementId)

[image]

Revit 2013 API
Element..::..ChangeTypeId Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementId)
Element Class See Also Send Feedback
Changes the type of all elements in the given set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static IDictionary<ElementId, ElementId> ChangeTypeId(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic
Public Shared Function ChangeTypeId ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As IDictionary(Of ElementId, ElementId)
Visual C++
public:
static IDictionary<ElementId^, ElementId^>^ ChangeTypeId(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the type to assign to this element.

Return Value

The map of original element IDs to the new element IDs if some elements were replaced by new elements (the map is empty if no elements were replaced)

Remarks

In some cases, applying a change in type will result in a new element being created. The only active examples of this are when applying a normal wall type to a curtain panel, or converting such a wall back to a curtain panel. Then return map would have (original element id, new element id) pair(s). Note: this function needs an open transaction. Note: this function calls regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | At least one of the elements in elementIds does not exist in the document -or- Not all elements elementIds can have a type assigned. -or- The type typeId is not valid for at least one of the elements in elementIds.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | One or more elements in elementIds is a member of a loaded family. -or- One or more elements in elementIds is a member of a group type that is not being edited.

See Also

Element Class
ChangeTypeId Overload


DeleteEntity Method

[image]

Revit 2013 API
Element..::..DeleteEntity Method
Element Class See Also Send Feedback
Deletes the existing entity created by %schema% in the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool DeleteEntity(
    Schema schema
)
Visual Basic
Public Function DeleteEntity ( _
    schema As Schema _
) As Boolean
Visual C++
public:
bool DeleteEntity(
    Schema^ schema
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
Schema used for creation of the entity

Return Value

True if entity was deleted, false if entity didn't exist

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


Dispose Method

[image]

Revit 2013 API
Element..::..Dispose Method
Element Class See Also Send Feedback
Releases all resources used by the Element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Element Class


GetAnalyticalModel Method

[image]

Revit 2013 API
Element..::..GetAnalyticalModel Method
Element Class See Also Send Feedback
Retrieves writeable Analytical Model for Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModel GetAnalyticalModel()
Visual Basic
Public Function GetAnalyticalModel As AnalyticalModel
Visual C++
public:
AnalyticalModel^ GetAnalyticalModel()

Return Value

Writeable Analytical Model.

Remarks

If the Element does not have an Analytical Model, the returned value will be NULL. This may occur even if the Element can have an Analytical Model, but does not for some reason.

See Also

Element Class


GetAnalyticalModelId Method

[image]

Revit 2013 API
Element..::..GetAnalyticalModelId Method
Element Class See Also Send Feedback
Retrieves the Element Id of the Analytical Model Element for this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetAnalyticalModelId()
Visual Basic
Public Function GetAnalyticalModelId As ElementId
Visual C++
public:
ElementId^ GetAnalyticalModelId()

Return Value

Element Id.

Remarks

If the Element does not have an Analytical Model, the returned value will be invalidElementId. This may occur even if the Element can have an Analytical Model, but does not for some reason.

See Also

Element Class


GetChangeTypeAny Method

[image]

Revit 2013 API
Element..::..GetChangeTypeAny Method
Element Class See Also Send Feedback
Returns ChangeType associated with any change in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeAny()
Visual Basic
Public Shared Function GetChangeTypeAny As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeAny()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on any change in an element

Remarks

Use this change type to trigger an Updater when elements change in any way. For maximum efficiency, we recommend the use of ChangeTypeParameter and ChangeTypeGeometry, if applicable, instead. Caution: Changes to an element by an Updater using this trigger will result in re-triggering of the Updater. For example, Updater1 triggers on ChangeTypeAny on Element X. A Revit user modifies parameter A of X. Updater1 is triggered and modifies X's parameter B. The change in parameter B, triggers another call to Updater1::execute(). If Updater1 continues to modify X, it can run into an infinite loop. Infinite loops are detected by Revit and result in the Updater being disabled. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeElementAddition Method

[image]

Revit 2013 API
Element..::..GetChangeTypeElementAddition Method
Element Class See Also Send Feedback
Returns ChangeType associated with element addition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementAddition()
Visual Basic
Public Shared Function GetChangeTypeElementAddition As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementAddition()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element addition.

Remarks

Use this change type to trigger an Updater on the addition of elements to a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeElementDeletion Method

[image]

Revit 2013 API
Element..::..GetChangeTypeElementDeletion Method
Element Class See Also Send Feedback
Returns ChangeType associated with element deletion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeElementDeletion()
Visual Basic
Public Shared Function GetChangeTypeElementDeletion As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeElementDeletion()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on element deletion.

Remarks

ChangeType that can be used to define a trigger for an Updater, Use this change type to trigger an Updater on the deletion of elements from a document. Note: This change type will not trigger on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeGeometry Method

[image]

Revit 2013 API
Element..::..GetChangeTypeGeometry Method
Element Class See Also Send Feedback
Returns ChangeType associated with a change in the geometry of an element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeGeometry()
Visual Basic
Public Shared Function GetChangeTypeGeometry As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeGeometry()

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on a geometry change in an element

Remarks

Use this change type to trigger an Updater when the geometry of an element changes. Only physical changes to shape of the element(s) will trigger the updater. For example, changes like cutting a hole in a wall or adjusting its height are considered to be geometric changes. However, moving a wall to a different location without modifying its shape is not considered to be a change in geometry and will not trigger the Updater. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

See Also

Element Class


GetChangeTypeParameter Method

[image] [image]

Revit 2013 API
Element..::..GetChangeTypeParameter Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetChangeTypeParameter(ElementId) | Returns ChangeType associated with a change in a parameter's value
GetChangeTypeParameter(Parameter) | Returns ChangeType associated with a change in a parameter's value

See Also

Element Class
Element Members


GetChangeTypeParameter Method (ElementId)

[image]

Revit 2013 API
Element..::..GetChangeTypeParameter Method (ElementId)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    ElementId parameterId
)
Visual Basic
Public Shared Function GetChangeTypeParameter ( _
    parameterId As ElementId _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.

Remarks

remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetChangeTypeParameter Overload


GetChangeTypeParameter Method (Parameter)

[image]

Revit 2013 API
Element..::..GetChangeTypeParameter Method (Parameter)
Element Class See Also Send Feedback
Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ChangeType GetChangeTypeParameter(
    Parameter param
)
Visual Basic
Public Shared Function GetChangeTypeParameter ( _
    param As Parameter _
) As ChangeType
Visual C++
public:
static ChangeType^ GetChangeTypeParameter(
    Parameter^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::..Parameter
Parameter for the ChangeType to trigger on

Return Value

ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change

Remarks

Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

Element Class
GetChangeTypeParameter Overload


GetDividedSurfaceData Method

[image]

Revit 2013 API
Element..::..GetDividedSurfaceData Method
Element Class See Also Send Feedback
Get an interface to the divided surfaces on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DividedSurfaceData GetDividedSurfaceData()
Visual Basic
Public Function GetDividedSurfaceData As DividedSurfaceData
Visual C++
public:
DividedSurfaceData^ GetDividedSurfaceData()

Return Value

An object that can be used to find information about this element's divided surfaces. Divided surfaces are only supported in Conceptual Massing families; outside of that environment, this method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Divided surfaces are supported on the following element types: Form, GeomCombination, FamilyInstance, and ImportInstance.

See Also

Element Class


GetEntity Method

[image]

Revit 2013 API
Element..::..GetEntity Method
Element Class See Also Send Feedback
Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Entity GetEntity(
    Schema schema
)
Visual Basic
Public Function GetEntity ( _
    schema As Schema _
) As Entity
Visual C++
public:
Entity^ GetEntity(
    Schema^ schema
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
The Schema describing the Entity.

Return Value

The returned Entity.

Remarks

The Entity that is returned is a copy of the stored data (with copy-on-write optimization). Modifying it is allowed (even with restricted write), but to save your changes you must call SetEntity.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Reading of Entities of this Schema is not allowed to the current add-in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


GetExternalFileReference Method

[image]

Revit 2013 API
Element..::..GetExternalFileReference Method
Element Class See Also Send Feedback
Gets information pertaining to the external file referenced by the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReference GetExternalFileReference()
Visual Basic
Public Function GetExternalFileReference As ExternalFileReference
Visual C++
public:
ExternalFileReference^ GetExternalFileReference()

Return Value

An object containing path and type information for the external file referenced by the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Element does not represent an external file.

See Also

Element Class


GetGeneratingElementIds Method

[image]

Revit 2013 API
Element..::..GetGeneratingElementIds Method
Element Class Example See Also Send Feedback
Returns the ids of the element(s) that generated the input geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetGeneratingElementIds(
    GeometryObject geometryObject
)
Visual Basic
Public Function GetGeneratingElementIds ( _
    geometryObject As GeometryObject _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetGeneratingElementIds(
    GeometryObject^ geometryObject
)

Parameters

geometryObject
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object whose generating element is requested.

Return Value

The id(s) of the element(s) that generated (or may have generated) the given geometry object. Empty if no generating elements are found. If the set contains just one id, it is the id of the element that generated the geometry object.

Remarks

This function supports many different types of relationships among elements. Most of these relationships will return a single element, for example:
  • Window and door cutting walls
  • Openings cutting hosts
  • Face splitting faces
  • Wall sweep or reveal traversing wall
A few relationships have the potential for returning multiple elements, including:
  • Walls joining to other wall(s)
  • Elements extending to roof(s)
If more than one id is returned, one of them (unspecified) is the id of the element that generated the geometry object and the others are ids of related elements. For example, if a wall A is joined to two walls B and C in a way that creates two end faces, and if this function is called for one of the two end faces, it will return the ids of walls B and C.

Examples

CopyC#
// Find elements joined or attached to the end faces of a given wall (such as walls and roofs).
// Mid-joined walls (such as in a T configuration) are not found because they do not affect end face geometry.

ICollection<ElementId> joinedElements = new Collection<ElementId>(); // collection to store the walls joined to the selected wall

// find all faces of the selected wall
GeometryElement geometryElement = wall.get_Geometry(new Options());
foreach (GeometryObject geometryObject in geometryElement.Objects)
{
    if (geometryObject is Solid)
    {
        Solid solid = geometryObject as Solid;
        foreach (Face face in solid.Faces)
        {
            // for each face, find the other elements that generated the geometry of that face
            ICollection<ElementId> generatingElementIds = wall.GetGeneratingElementIds(face);

            generatingElementIds.Remove(wall.Id); // remove the originally selected wall, leaving only other elements joined to it
            foreach (ElementId id in generatingElementIds)
            {
                if (!(joinedElements.Contains(id)))
                    joinedElements.Add(id); // add each wall joined to this face to the overall collection
            }
        }
    }
}
foreach (ElementId id in joinedElements)
{
    uidocument.Selection.Elements.Add(document.GetElement(id)); // select all of the joined elements
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input geometryObject is invalid and so cannot be used to obtain the generating element ids.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


GetGeometryObjectFromReference Method

[image]

Revit 2013 API
Element..::..GetGeometryObjectFromReference Method
Element Class See Also Send Feedback
Retrieve one geometric primitive contained in the element given a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public GeometryObject GetGeometryObjectFromReference(
    Reference reference
)
Visual Basic
Public Function GetGeometryObjectFromReference ( _
    reference As Reference _
) As GeometryObject
Visual C++
public:
GeometryObject^ GetGeometryObjectFromReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
The geometric object referenced by this instance will be retrieved from the model.

Return Value

The geometric object referenced by the input reference.

Remarks

It will return the last geometric object in the path. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned if related geometric object could not be found in the model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id of this element is not same as that referenced by reference
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element id held by the input reference is not same as the id of this element. The geometric information could not be taken for this element.

See Also

Element Class


GetMaterialArea Method

[image]

Revit 2013 API
Element..::..GetMaterialArea Method
Element Class See Also Send Feedback
Get the area of the given material on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetMaterialArea(
    Material material
)
Visual Basic
Public Function GetMaterialArea ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialArea(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.DB..::..Material

Return Value

The area, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The input material was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | The material comes from a different document than this element.

See Also

Element Class


GetMaterialVolume Method

[image]

Revit 2013 API
Element..::..GetMaterialVolume Method
Element Class See Also Send Feedback
Get the volume of the given material on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetMaterialVolume(
    Material material
)
Visual Basic
Public Function GetMaterialVolume ( _
    material As Material _
) As Double
Visual C++
public:
double GetMaterialVolume(
    Material^ material
)

Parameters

material
Type: Autodesk.Revit.DB..::..Material

Return Value

The volume, or 0.0 if the input material is not a member of Materials.

Remarks

This value is calculated by Revit to show in material takeoff schedules. In some cases the value may be approximate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The input material was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | The material comes from a different document than this element.

See Also

Element Class


GetMonitoredLinkElementIds Method

[image]

Revit 2013 API
Element..::..GetMonitoredLinkElementIds Method
Element Class See Also Send Feedback
Provides the link instance IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLinkElementIds()
Visual Basic
Public Function GetMonitoredLinkElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLinkElementIds()

Return Value

The IDs of linked instances.

See Also

Element Class


GetMonitoredLocalElementIds Method

[image]

Revit 2013 API
Element..::..GetMonitoredLocalElementIds Method
Element Class See Also Send Feedback
Provides the local element IDs when the element is monitoring.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetMonitoredLocalElementIds()
Visual Basic
Public Function GetMonitoredLocalElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMonitoredLocalElementIds()

Return Value

The IDs of local element IDs being monitored by this element.

See Also

Element Class


GetPhaseStatus Method

[image]

Revit 2013 API
Element..::..GetPhaseStatus Method
Element Class See Also Send Feedback
Gets the status of a given element in the input phase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementOnPhaseStatus GetPhaseStatus(
    ElementId phaseId
)
Visual Basic
Public Function GetPhaseStatus ( _
    phaseId As ElementId _
) As ElementOnPhaseStatus
Visual C++
public:
ElementOnPhaseStatus GetPhaseStatus(
    ElementId^ phaseId
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.

Return Value

The status of the element in the phase.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id does not represent a valid phase.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


GetTypeId Method

[image]

Revit 2013 API
Element..::..GetTypeId Method
Element Class Example See Also Send Feedback
Returns the identifier of this element's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetTypeId()
Visual Basic
Public Function GetTypeId As ElementId
Visual C++
public:
ElementId^ GetTypeId()

Return Value

The id of the element's type, or invalid element id if the element cannot have type assigned.

Remarks

Some elements cannot have type assigned, in which case this method returns invalid element id.

Examples

CopyC#
void GetStairType(Autodesk.Revit.DB.Document document)
{
   FilteredElementCollector collector = new FilteredElementCollector(document);
   ICollection<Element> stairs = collector.OfClass(typeof(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements();
   foreach (Element stair in stairs)
    {
        if (null == stair.GetTypeId())
        {
            TaskDialog.Show("Revit","No symbol found in stair element: " + stair.Name);
        }
        else
        {
            Element elemType = document.GetElement(stair.GetTypeId());
            string info = "Stair type is: " + elemType.Name;
            TaskDialog.Show("Revit",info);
        }
    }
}
CopyVB.NET
Sub GetStairType(ByVal document As Autodesk.Revit.DB.Document)
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim stairs As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(FamilyInstance)).OfCategory(BuiltInCategory.OST_Stairs).ToElements()
    For Each stair As Autodesk.Revit.DB.Element In stairs
        If stair.GetTypeId() Is Nothing Then
            TaskDialog.Show("Revit", "No symbol found in stair element: " + stair.Name)
        Else
            Dim elemType As Autodesk.Revit.DB.Element = document.GetElement(stair.GetTypeId())
            Dim info As String = "Stair type is: " + elemType.Name
            TaskDialog.Show("Revit", info)
        End If
    Next
End Sub

See Also

Element Class


GetValidTypes Method

[image] [image]

Revit 2013 API
Element..::..GetValidTypes Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element.
 | GetValidTypes(Document, ICollection<(Of <<'(ElementId>)>>)) | Obtains a set of types that are valid for all given elements.

See Also

Element Class
Element Members


GetValidTypes Method

[image]

Revit 2013 API
Element..::..GetValidTypes Method
Element Class See Also Send Feedback
Obtains a set of types that are valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetValidTypes()
Visual Basic
Public Function GetValidTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidTypes()

Return Value

A set of element IDs of types that are valid for this element or an empty set if element cannot have type assigned.

See Also

Element Class
GetValidTypes Overload


GetValidTypes Method (Document, ICollection(ElementId))

[image]

Revit 2013 API
Element..::..GetValidTypes Method (Document, ICollection<(Of <(<'ElementId>)>)>)
Element Class See Also Send Feedback
Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetValidTypes(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function GetValidTypes ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidTypes(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs.

Return Value

A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
GetValidTypes Overload


HasPhases Method

[image]

Revit 2013 API
Element..::..HasPhases Method
Element Class See Also Send Feedback
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasPhases()
Visual Basic
Public Function HasPhases As Boolean
Visual C++
public:
bool HasPhases()

Return Value

True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.

Remarks

Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


IsExternalFileReference Method

[image]

Revit 2013 API
Element..::..IsExternalFileReference Method
Element Class See Also Send Feedback
Determines whether this Element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsExternalFileReference()
Visual Basic
Public Function IsExternalFileReference As Boolean
Visual C++
public:
bool IsExternalFileReference()

Return Value

True if this element contains information about some external file, false if it does not.

Remarks

Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.

See Also

Element Class


IsHidden Method

[image]

Revit 2013 API
Element..::..IsHidden Method
Element Class See Also Send Feedback
Identifies if the element has been permanently hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsHidden(
    View pView
)
Visual Basic
Public Function IsHidden ( _
    pView As View _
) As Boolean
Visual C++
public:
bool IsHidden(
    View^ pView
)

Parameters

pView
Type: Autodesk.Revit.DB..::..View

Remarks

This does not determine if the element is hidden as a result of temporary hide/isolate, view sectioning, view crop box, or other operations that can cause elements not to be visible. To hide or unhide an element, use the Hide() and Unhide() method of View.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Element Class


IsMonitoringLinkElement Method

[image]

Revit 2013 API
Element..::..IsMonitoringLinkElement Method
Element Class See Also Send Feedback
Indicate whether an element is monitoring any elements in any linked models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsMonitoringLinkElement()
Visual Basic
Public Function IsMonitoringLinkElement As Boolean
Visual C++
public:
bool IsMonitoringLinkElement()

Return Value

True if this element is monitoring elements in a linked models. Otherwise, false will be returned.

See Also

Element Class


IsMonitoringLocalElement Method

[image]

Revit 2013 API
Element..::..IsMonitoringLocalElement Method
Element Class See Also Send Feedback
Indicate whether an element is monitoring other local elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsMonitoringLocalElement()
Visual Basic
Public Function IsMonitoringLocalElement As Boolean
Visual C++
public:
bool IsMonitoringLocalElement()

Return Value

True if this element is monitoring other elements in same project. Otherwise, false will be returned.

See Also

Element Class


IsPhaseCreatedValid Method

[image]

Revit 2013 API
Element..::..IsPhaseCreatedValid Method
Element Class See Also Send Feedback
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPhaseCreatedValid(
    ElementId createdPhaseId
)
Visual Basic
Public Function IsPhaseCreatedValid ( _
    createdPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsPhaseCreatedValid(
    ElementId^ createdPhaseId
)

Parameters

createdPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The id of a Phase.

Return Value

True if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element, false otherwise.

Remarks

Acts as a validator for setting the property CreatedPhaseId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


IsPhaseDemolishedValid Method

[image]

Revit 2013 API
Element..::..IsPhaseDemolishedValid Method
Element Class See Also Send Feedback
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPhaseDemolishedValid(
    ElementId demolishedPhaseId
)
Visual Basic
Public Function IsPhaseDemolishedValid ( _
    demolishedPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsPhaseDemolishedValid(
    ElementId^ demolishedPhaseId
)

Parameters

demolishedPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The id of a Phase or invalidElementId.

Return Value

True if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element, false otherwise.

Remarks

Acts as a validator for setting the property DemolishedPhaseId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


IsValidType Method

[image] [image]

Revit 2013 API
Element..::..IsValidType Method
Element Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidType(ElementId) | Checks if given type is valid for this element.
 | IsValidType(Document, ICollection<(Of <<'(ElementId>)>>), ElementId) | Checks if given type is valid for the set of elements.

See Also

Element Class
Element Members


IsValidType Method (ElementId)

[image]

Revit 2013 API
Element..::..IsValidType Method (ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidType(
    ElementId typeId
)
Visual Basic
Public Function IsValidType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if element can have a type assigned and this type is valid for this element, false otherwise.

Remarks

A type is valid for an element if it can be assigned to the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
IsValidType Overload


IsValidType Method (Document, ICollection(ElementId), ElementId)

[image]

Revit 2013 API
Element..::..IsValidType Method (Document, ICollection<(Of <(<'ElementId>)>)>, ElementId)
Element Class See Also Send Feedback
Checks if given type is valid for the set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidType(
    Document document,
    ICollection<ElementId> elementIds,
    ElementId typeId
)
Visual Basic
Public Shared Function IsValidType ( _
    document As Document, _
    elementIds As ICollection(Of ElementId), _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidType(
    Document^ document,
    ICollection<ElementId^>^ elementIds,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs.
typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if all elements can have a type assigned and this type is valid for all elements, false otherwise.

Remarks

A type is valid for the set of elements if it is valid for each and every element in the set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when at least one of the elements does not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class
IsValidType Overload


SetEntity Method

[image]

Revit 2013 API
Element..::..SetEntity Method
Element Class See Also Send Feedback
Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetEntity(
    Entity entity
)
Visual Basic
Public Sub SetEntity ( _
    entity As Entity _
)
Visual C++
public:
void SetEntity(
    Entity^ entity
)

Parameters

entity
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Entity
The Entity to be stored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Writing of Entities of this Schema is not allowed to the current add-in.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Element Class


Element Properties

[image] [image]

Revit 2013 API
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished.
Public property | DesignOption | Returns the design option to which the element belongs.
Public property | Document | Returns the Document in which the Element resides.
Public property | Geometry | Retrieves the geometric representation of the element.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project.
Public property | Level | If the element is level based then level to which the element is assigned is returned.
Public property | Location | This property is used to find the physical location of an element within a project.
Public property | Materials | Get all materials present in the element.
Public property | Name | A human readable name for the Element.
Public property | OwnerViewId | The id of the view that owns the element.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element.
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created.
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished.
Public property | Pinned | Identifies if the element has been pinned to prevent changes.
Public property | UniqueId | A stable unique identifier for an element within the document.
Public property | ViewSpecific | Identifies if the element is owned by a view.
Public property | WorksetId | Get Id of the Workset which owns the element.

See Also

Element Class


AssemblyInstanceId Property

[image]

Revit 2013 API
Element..::..AssemblyInstanceId Property
Element Class See Also Send Feedback
The id of the assembly instance to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssemblyInstanceId {
    ElementId^ get ();
}

Field Value

Assembly instance id, or InvalidElementId if element is not a member of an assembly.

See Also

Element Class


BoundingBox Property

[image]

Revit 2013 API
Element..::..BoundingBox Property
Element Class Example See Also Send Feedback
Retrieves a box that circumscribes all geometry of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ this[
    View
] { get; }
Visual Basic
Public ReadOnly Property BoundingBox ( _
     As View _
) As BoundingBoxXYZ
    Get
Visual C++
public:
property BoundingBoxXYZ^ BoundingBox[View^ ] {
    BoundingBoxXYZ^ get (View^ );
}

Parameters

Type: Autodesk.Revit.DB..::..View

Remarks

Pass in a view to query view-specific (e.g., cut) geometry or nullNothingnullptra null reference (Nothing in Visual Basic) for model geometry. If view box is not known, will return model box; if model box is not known, will return nullNothingnullptra null reference (Nothing in Visual Basic). Also note that this bounding box value may include geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.

Examples

CopyC#
private void GetElementBoundingBox(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the BoundingBox instance for current view.
    BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
    if (null == box)
    {
        throw new Exception("Selected element doesn't contain a bounding box.");
    }

    string info = "Bounding box is enabled: " + box.Enabled.ToString();

    // Give the user some information.
    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Private Sub GetElementBoundingBox(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get the BoundingBox instance for current view.
    Dim box As BoundingBoxXYZ = element.BoundingBox(document.ActiveView)
    If box Is Nothing Then
        Throw New Exception("Selected element doesn't contain a bounding box.")
    End If

    Dim info As String = "Bounding box is enabled: " + box.Enabled.ToString()

    ' Give the user some information.
    TaskDialog.Show("Revit", info)
End Sub

See Also

Element Class


Category Property

[image]

Revit 2013 API
Element..::..Category Property
Element Class See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category Category { get; }
Visual Basic
Public ReadOnly Property Category As Category
    Get
Visual C++
public:
property Category^ Category {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

See Also

Element Class


CreatedPhaseId Property

[image]

Revit 2013 API
Element..::..CreatedPhaseId Property
Element Class See Also Send Feedback
Id of a Phase at which the Element was created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId CreatedPhaseId { get; set; }
Visual Basic
Public Property CreatedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CreatedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property CreatedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order, i.e. their index in the property Document.Phases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property CreatedPhaseId to the value of createdPhaseId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


DemolishedPhaseId Property

[image]

Revit 2013 API
Element..::..DemolishedPhaseId Property
Element Class See Also Send Feedback
Id of a Phase at which the Element was demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId DemolishedPhaseId { get; set; }
Visual Basic
Public Property DemolishedPhaseId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DemolishedPhaseId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

After setting the property DemolishedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order, i.e. their index in the property Document.Phases. Can be set to invalid element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The element does not allow setting the property DemolishedPhaseId to the value of demolishedPhaseId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also

Element Class


DesignOption Property

[image]

Revit 2013 API
Element..::..DesignOption Property
Element Class Example See Also Send Feedback
Returns the design option to which the element belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DesignOption DesignOption { get; }
Visual Basic
Public ReadOnly Property DesignOption As DesignOption
    Get
Visual C++
public:
property DesignOption^ DesignOption {
    DesignOption^ get ();
}

Remarks

If the element is not in a design option, i.e. in the main model, then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void Getinfo_DesignOption(Document document)
{
    // Get the selected Elements in the Active Document
    UIDocument uidoc = new UIDocument(document);
    ElementSet selection = uidoc.Selection.Elements;

    foreach (Autodesk.Revit.DB.Element element in selection)
    {
        //Use the DesignOption property of Element
        if (element.DesignOption != null)
        {
            TaskDialog.Show("Revit",element.DesignOption.Name.ToString());
        }
    }
}
CopyVB.NET
Sub Getinfo_DesignOption(ByVal document As Document)
    ' Get the selected Elements in the Active Document
    Dim uidoc As New UIDocument(document)
    Dim selection As ElementSet = uidoc.Selection.Elements

    For Each element As Autodesk.Revit.DB.Element In selection
        'Use the DesignOption property of Element
        If element.DesignOption IsNot Nothing Then
            TaskDialog.Show("Revit", element.DesignOption.Name.ToString())
        End If
    Next
End Sub

See Also

Element Class


Document Property

[image]

Revit 2013 API
Element..::..Document Property
Element Class See Also Send Feedback
Returns the Document in which the Element resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

Remarks

All elements are contained within a document. An element can be retrieved from this document by using the id that is returned by the element's id property.

See Also

Element Class


Geometry Property

[image]

Revit 2013 API
Element..::..Geometry Property
Element Class Example See Also Send Feedback
Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement this[
    Options options
] { get; }
Visual Basic
Public ReadOnly Property Geometry ( _
    options As Options _
) As GeometryElement
    Get
Visual C++
public:
property GeometryElement^ Geometry[Options^ options] {
    GeometryElement^ get (Options^ options);
}

Parameters

options
Type: Autodesk.Revit.DB..::..Options
User preferences for parsing of geometry.

Field Value

An element that provides access to the geometry of the element.

Remarks

This call will retrieve 3d representation of the element. nullNothingnullptra null reference (Nothing in Visual Basic) will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

Geometry objects provided from this method are obtained directly from the element. When the element is changed for any reason, the geometry will be recalculated by Revit and geometry objects obtained before the change are likely to no longer be valid. If you need to preserve geometry information obtained an element even after changes to that element, you should copy the geometry objects or save the properties independently.

If you require that the geometry items obtained contain valid Reference objects, be sure to set the CalculateReferences property of the options.

Examples

CopyC#
public void GetCurvesFromABeam(Autodesk.Revit.DB.FamilyInstance beam,
                               Autodesk.Revit.DB.Options options)
{
    Autodesk.Revit.DB.GeometryElement geomElem = beam.get_Geometry(options);

    Autodesk.Revit.DB.CurveArray curves = new CurveArray();
    Autodesk.Revit.DB.SolidArray solids = new SolidArray();

    //Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, ref curves, ref solids);
}

private void AddCurvesAndSolids(Autodesk.Revit.DB.GeometryElement geomElem,
                                ref Autodesk.Revit.DB.CurveArray curves,
                                ref Autodesk.Revit.DB.SolidArray solids)
{
    foreach (Autodesk.Revit.DB.GeometryObject geomObj in geomElem.Objects)
    {
        Autodesk.Revit.DB.Curve curve = geomObj as Autodesk.Revit.DB.Curve;
        if (null != curve)
        {
            curves.Append(curve);
            continue;
        }
        Autodesk.Revit.DB.Solid solid = geomObj as Autodesk.Revit.DB.Solid;
        if (null != solid)
        {
            solids.Append(solid);
            continue;
        }
        //If this GeometryObject is Instance, call AddCurvesAndSolids
        Autodesk.Revit.DB.GeometryInstance geomInst = geomObj as Autodesk.Revit.DB.GeometryInstance;
        if (null != geomInst)
        {
            Autodesk.Revit.DB.GeometryElement transformedGeomElem
              = geomInst.GetInstanceGeometry(geomInst.Transform);
            AddCurvesAndSolids(transformedGeomElem, ref curves, ref solids);
        }
    }
}
CopyVB.NET
Public Sub GetCurvesFromABeam(ByVal beam As Autodesk.Revit.DB.FamilyInstance, ByVal options As Autodesk.Revit.DB.Options)
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = beam.Geometry(options)

    Dim curves As Autodesk.Revit.DB.CurveArray = New CurveArray()
    Dim solids As Autodesk.Revit.DB.SolidArray = New SolidArray()

    'Find all solids and insert them into solid array
    AddCurvesAndSolids(geomElem, curves, solids)
End Sub

Private Sub AddCurvesAndSolids(ByVal geomElem As Autodesk.Revit.DB.GeometryElement, ByRef curves As Autodesk.Revit.DB.CurveArray, ByRef solids As Autodesk.Revit.DB.SolidArray)
    For Each geomObj As Autodesk.Revit.DB.GeometryObject In geomElem.Objects
        Dim curve As Autodesk.Revit.DB.Curve = TryCast(geomObj, Autodesk.Revit.DB.Curve)
        If curve IsNot Nothing Then
            curves.Append(curve)
            Continue For
        End If
        Dim solid As Autodesk.Revit.DB.Solid = TryCast(geomObj, Autodesk.Revit.DB.Solid)
        If solid IsNot Nothing Then
            solids.Append(solid)
            Continue For
        End If
        'If this GeometryObject is Instance, call AddCurvesAndSolids
        Dim geomInst As Autodesk.Revit.DB.GeometryInstance = TryCast(geomObj, Autodesk.Revit.DB.GeometryInstance)
        If geomInst IsNot Nothing Then
            Dim transformedGeomElem As Autodesk.Revit.DB.GeometryElement = geomInst.GetInstanceGeometry(geomInst.Transform)
            AddCurvesAndSolids(transformedGeomElem, curves, solids)
        End If
    Next
End Sub

See Also

Element Class


Group Property

[image]

Revit 2013 API
Element..::..Group Property
Element Class Example See Also Send Feedback
Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Group Group { get; }
Visual Basic
Public ReadOnly Property Group As Group
    Get
Visual C++
public:
property Group^ Group {
    Group^ get ();
}

Examples

CopyC#
private void ShowGroupInformation(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get group information for the selected element
    String prompt = null;
    Autodesk.Revit.DB.Group group = element.Group;
    if (null == group)
    {
        prompt = "The element isn't in any group.";
    }
    else
    {
        prompt = "The element " + element.Id.IntegerValue + " is in a group.";
        prompt += "\nThe group id is " + group.Id.IntegerValue;
        prompt += "\nThe group's category is " + group.Category.Name;
        prompt += "\nAll group contained element ids are:";
        Autodesk.Revit.DB.ElementArray groupMembers = group.Members;
        foreach (Autodesk.Revit.DB.Element e in groupMembers)
        {
           prompt += "\n\t" + e.Id.IntegerValue;
        }
    }

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub ShowGroupInformation(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get group information for the selected element
    Dim prompt As [String] = Nothing
    Dim group As Autodesk.Revit.DB.Group = element.Group
    If group Is Nothing Then
        prompt = "The element isn't in any group."
    Else
        prompt = "The element " + element.Id.IntegerValue + " is in a group."
        prompt += vbLf & "The group id is " + group.Id.IntegerValue
        prompt += vbLf & "The group's category is " + group.Category.Name
        prompt += vbLf & "All group contained element ids are:"
        Dim groupMembers As Autodesk.Revit.DB.ElementArray = group.Members
        For Each e As Autodesk.Revit.DB.Element In groupMembers
            prompt += vbLf & vbTab + e.Id.IntegerValue
        Next
    End If

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class


Id Property

[image]

Revit 2013 API
Element..::..Id Property
Element Class Example See Also Send Feedback
Provides a way of uniquely identifying an Element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

Remarks

Returns an object containing the project wide unique identifier for this Element. The identifier with this id is only unique for the project, it is not unique across separate Autodesk Revit projects.

Examples

CopyC#
private void CheckElementId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    // Get the id of the element
    Autodesk.Revit.DB.ElementId selectedId = element.Id;
    int idInteger = selectedId.IntegerValue;

    // create a new id and set the value
    Autodesk.Revit.DB.ElementId id = new Autodesk.Revit.DB.ElementId(idInteger);

    // Get the element
    Autodesk.Revit.DB.Element first = document.GetElement(id);

    // And get the element using the original Id (they should be the same)
    Autodesk.Revit.DB.Element second = document.GetElement(selectedId);

    String prompt = "Get an element twice. They should be the same element.";
    // Use the Equal method to check two elements. It is not a good way.
    bool isSame = first.Equals(second);
    prompt += "\nUsing Equal method on elements, the result is: " + isSame;
    isSame = first.Id.Equals(second.Id);
    prompt += "\nUsing Equal method on element's Id properties, the result is: " + isSame;

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Private Sub CheckElementId(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Get the id of the element
    Dim selectedId As Autodesk.Revit.DB.ElementId = element.Id
    Dim idInteger As Integer = selectedId.IntegerValue

    ' create a new id and set the value
    Dim id As New Autodesk.Revit.DB.ElementId(idInteger)

    ' Get the element
    Dim first As Autodesk.Revit.DB.Element = document.GetElement(id)

    ' And get the element using the original Id (they should be the same)
    Dim second As Autodesk.Revit.DB.Element = document.GetElement(selectedId)

    Dim prompt As [String] = "Get an element twice. They should be the same element."
    ' Use the Equal method to check two elements. It is not a good way.
    Dim isSame As Boolean = first.Equals(second)
    prompt += vbLf & "Using Equal method on elements, the result is: " + isSame
    isSame = first.Id.Equals(second.Id)
    prompt += vbLf & "Using Equal method on element's Id properties, the result is: " + isSame

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

Element Class


Level Property

[image]

Revit 2013 API
Element..::..Level Property
Element Class Example See Also Send Feedback
If the element is level based then level to which the element is assigned is returned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Level Level { get; }
Visual Basic
Public Overridable ReadOnly Property Level As Level
    Get
Visual C++
public:
virtual property Level^ Level {
    Level^ get ();
}

Remarks

A number of elements use a level as a base reference, such as a column.

Examples

CopyC#
private void GetLevelInformation(Autodesk.Revit.DB.Element element)
{
    // Get the level object to which the element is assigned.
    Level level = element.Level;
    if (null == level)
    {
        TaskDialog.Show("Revit","The element isn't based on a level.");
    }
    else
    {
        // Format the prompt information(Name and elevation)
        String prompt = "The element is based on a level.";
        prompt += "\nThe level name is:  " + level.Name;
        prompt += "\nThe level elevation is:  " + level.Elevation;

        // Show the information to the user.
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Private Sub GetLevelInformation(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the level object to which the element is assigned.
    Dim level As Level = element.Level
    If level Is Nothing Then
        TaskDialog.Show("Revit", "The element isn't based on a level.")
    Else
        ' Format the prompt information(Name and elevation)
        Dim prompt As [String] = "The element is based on a level."
        prompt += vbLf & "The level name is:  " + level.Name
        prompt += vbLf & "The level elevation is:  " + level.Elevation

        ' Show the information to the user.
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Location Property

[image]

Revit 2013 API
Element..::..Location Property
Element Class Example See Also Send Feedback
This property is used to find the physical location of an element within a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Location Location { get; }
Visual Basic
Public Overridable ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get ();
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. An object may have a point location, such as a table or may have a line location. A wall is an example of an element that has a line location.

Examples

CopyC#
void GetLocationInformation(Autodesk.Revit.DB.Element element)
{
    // Get the Location property and judge whether it exists
    Autodesk.Revit.DB.Location position = element.Location;

    String prompt = null;
    if (null == position)
    {
        prompt = "No location can be found in element.";
    }
    else
    {
        // If the location is a point location, give the user information
        Autodesk.Revit.DB.LocationPoint positionPoint = position as Autodesk.Revit.DB.LocationPoint;
        if (null != positionPoint)
        {
            prompt = "Element has a point location.";
        }
        else
        {

            // If the location is a curve location, give the user information
            Autodesk.Revit.DB.LocationCurve positionCurve = position as Autodesk.Revit.DB.LocationCurve;
            if (null != positionCurve)
            {
                prompt = "Element has a curve location.";
            }
        }
    }

    if (null != prompt)
    {
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub GetLocationInformation(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Location property and judge whether it exists
    Dim position As Autodesk.Revit.DB.Location = element.Location

    Dim prompt As [String] = Nothing
    If position Is Nothing Then
        prompt = "No location can be found in element."
    Else
        ' If the location is a point location, give the user information
        Dim positionPoint As Autodesk.Revit.DB.LocationPoint = TryCast(position, Autodesk.Revit.DB.LocationPoint)
        If positionPoint IsNot Nothing Then
            prompt = "Element has a point location."
        Else

            ' If the location is a curve location, give the user information
            Dim positionCurve As Autodesk.Revit.DB.LocationCurve = TryCast(position, Autodesk.Revit.DB.LocationCurve)
            If positionCurve IsNot Nothing Then
                prompt = "Element has a curve location."
            End If
        End If
    End If

    If prompt IsNot Nothing Then
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Materials Property

[image]

Revit 2013 API
Element..::..Materials Property
Element Class See Also Send Feedback
Get all materials present in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MaterialSet Materials { get; }
Visual Basic
Public ReadOnly Property Materials As MaterialSet
    Get
Visual C++
public:
property MaterialSet^ Materials {
    MaterialSet^ get ();
}

Remarks

The set will be empty for elements where the HasMaterialQuantities property of the element's Category is false. The set will also be empty for elements whose category supports material quantities (the HasMaterialQuantities property of the element's Category is true), but where the element has not been assigned materials.

See Also

Element Class


Name Property

[image]

Revit 2013 API
Element..::..Name Property
Element Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

Element Class


OwnerViewId Property

[image]

Revit 2013 API
Element..::..OwnerViewId Property
Element Class See Also Send Feedback
The id of the view that owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId OwnerViewId { get; }
Visual Basic
Public ReadOnly Property OwnerViewId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerViewId {
    ElementId^ get ();
}

Field Value

The owner view id, or InvalidElementId if there is no owner view.

See Also

Element Class


Parameter Property

[image] [image]

Revit 2013 API
Element..::..Parameter Property
Element Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter.
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name.
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id.
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition.

See Also

Element Class
Element Members


Parameter Property (Guid)

[image]

Revit 2013 API
Element..::..Parameter Property (Guid)
Element Class See Also Send Feedback
Retrieves a parameter from the element given a GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Parameter this[
    Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[Guid guid] {
    Parameter^ get (Guid guid);
}

Parameters

guid
Type: System..::..Guid
The unique id associated with the shared parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method is used to retrieve a parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

Element Class
Parameter Overload


Parameter Property (String)

[image]

Revit 2013 API
Element..::..Parameter Property (String)
Element Class See Also Send Feedback
Retrieves a parameter from the element given its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Parameter this[
    string paramName
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    paramName As String _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[String^ paramName] {
    Parameter^ get (String^ paramName);
}

Parameters

paramName
Type: System..::..String
The name of the parameter to be retrieved.

See Also

Element Class
Parameter Overload


Parameter Property (BuiltInParameter)

[image]

Revit 2013 API
Element..::..Parameter Property (BuiltInParameter)
Element Class Example See Also Send Feedback
Retrieves a parameter from the element given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Parameter this[
    BuiltInParameter parameterId
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[BuiltInParameter parameterId] {
    Parameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::..BuiltInParameter
The built in parameter id of the parameter to be retrieved.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. This method uses a built in parameter id to access the parameter. Autodesk Revit has a large number of built in parameters that are available via an enumerated type.

Examples

CopyC#
public Parameter FindWithBuiltinParameterID(Wall wall)
{
    //Use the WALL_BASE_OFFSET paramametId
    // to get the base offset parameter of the wall.
    BuiltInParameter paraIndex = BuiltInParameter.WALL_BASE_OFFSET;
    Parameter parameter = wall.get_Parameter(paraIndex);

    return parameter;
}
CopyVB.NET
Public Function FindWithBuiltinParameterID(ByVal wall As Wall) As Parameter
    'Use the WALL_BASE_OFFSET paramametId
    ' to get the base offset parameter of the wall.
    Dim paraIndex As BuiltInParameter = BuiltInParameter.WALL_BASE_OFFSET
    Dim parameter As Parameter = wall.Parameter(paraIndex)

    Return parameter
End Function

See Also

Element Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2013 API
Element..::..Parameter Property (Definition)
Element Class See Also Send Feedback
Retrieves a parameter from the element based on its definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Parameter this[
    Definition definition
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As Parameter
    Get
Visual C++
public:
property Parameter^ Parameter[Definition^ definition] {
    Parameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition
The internal or external definition of the parameter.

Remarks

Parameters are a generic form of data storage within elements. The parameters are visible through the Autodesk Revit user interface in the Element Properties dialog. An element can only have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.

See Also

Element Class
Parameter Overload


Parameters Property

[image]

Revit 2013 API
Element..::..Parameters Property
Element Class Example See Also Send Feedback
Retrieves a set containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterSet Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As ParameterSet
    Get
Visual C++
public:
property ParameterSet^ Parameters {
    ParameterSet^ get ();
}

Remarks

The Parameters property contains a set of all the parameters that the element supports. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this set.

Examples

CopyC#
void GetElementParameterInformation(Document document, Element element)
{
    // Format the prompt information string
    String prompt = "Show parameters in selected Element:";

    StringBuilder st = new StringBuilder();
    // iterate element's parameters
    foreach (Parameter para in element.Parameters)
    {
        st.AppendLine(GetParameterInformation(para, document));
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}

String GetParameterInformation(Parameter para, Document document)
{
    string defName = para.Definition.Name + @"\t";
    // Use different method to get parameter data according to the storage type
    switch (para.StorageType)
    {
        case StorageType.Double:
            //covert the number into Metric
            defName += " : " + para.AsValueString();
            break;
        case StorageType.ElementId:
            //find out the name of the element
            Autodesk.Revit.DB.ElementId id = para.AsElementId();
            if (id.IntegerValue >= 0)
            {
                defName += " : " + document.GetElement(id).Name;
            }
            else
            {
               defName += " : " + id.IntegerValue.ToString();
            }
            break;
        case StorageType.Integer:
            if (ParameterType.YesNo == para.Definition.ParameterType)
            {
                if (para.AsInteger() == 0)
                {
                    defName += " : " + "False";
                }
                else
                {
                    defName += " : " + "True";
                }
            }
            else
            {
                defName += " : " + para.AsInteger().ToString();
            }
            break;
        case StorageType.String:
            defName += " : " + para.AsString();
            break;
        default:
            defName = "Unexposed parameter.";
            break;
    }

    return defName;
}
CopyVB.NET
Sub GetElementParameterInformation(ByVal document As Document, ByVal element As Autodesk.Revit.DB.Element)
    ' Format the prompt information string
    Dim prompt As [String] = "Show parameters in selected Element:"

    Dim st As New StringBuilder()
    ' iterate element's parameters
    For Each para As Parameter In element.Parameters
        st.AppendLine(GetParameterInformation(para, document))
    Next

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Function GetParameterInformation(ByVal para As Parameter, ByVal document As Document) As [String]
    Dim defName As String = para.Definition.Name + "\t"
    ' Use different method to get parameter data according to the storage type
    Select Case para.StorageType
        Case StorageType.[Double]
            'covert the number into Metric
            defName += " : " + para.AsValueString()
            Exit Select
        Case StorageType.ElementId
            'find out the name of the element
            Dim id As Autodesk.Revit.DB.ElementId = para.AsElementId()
            If id.IntegerValue >= 0 Then
                defName += " : " + document.GetElement(id).Name
            Else
                defName += " : " + id.IntegerValue.ToString()
            End If
            Exit Select
        Case StorageType.[Integer]
            If ParameterType.YesNo = para.Definition.ParameterType Then
                If para.AsInteger() = 0 Then
                    defName += " : " + "False"
                Else
                    defName += " : " + "True"
                End If
            Else
                defName += " : " + para.AsInteger().ToString()
            End If
            Exit Select
        Case StorageType.[String]
            defName += " : " + para.AsString()
            Exit Select
        Case Else
            defName = "Unexposed parameter."
            Exit Select
    End Select

    Return defName
End Function

See Also

Element Class


ParametersMap Property

[image]

Revit 2013 API
Element..::..ParametersMap Property
Element Class See Also Send Feedback
Retrieves a map containing all of the parameters that are contained within the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterMap ParametersMap { get; }
Visual Basic
Public ReadOnly Property ParametersMap As ParameterMap
    Get
Visual C++
public:
property ParameterMap^ ParametersMap {
    ParameterMap^ get ();
}

Remarks

The Parameters can be rapidly accessed by parameter name as a key. These parameters are displayed in the Element properties dialog in the Autodesk Revit interface. These parameters can be retrieved and set via the parameter objects stored in this map.

See Also

Element Class


PhaseCreated Property

[image]

Revit 2013 API
Element..::..PhaseCreated Property
Element Class Example See Also Send Feedback
An object representing the phase when the element is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in 2013. Use CreatedPhaseId instead.")]
public Phase PhaseCreated { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in 2013. Use CreatedPhaseId instead.")> _
Public ReadOnly Property PhaseCreated As Phase
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in 2013. Use CreatedPhaseId instead.")]
public:
property Phase^ PhaseCreated {
    Phase^ get ();
}

Remarks

Elements always have a phase for when they are created.

Examples

CopyC#
void ShowPhaseCreatedName(Element element)
{
    // Get the Phase Create property, and assert it should not be null
    Autodesk.Revit.DB.Phase phaseCreated = element.PhaseCreated;
    if (null == phaseCreated)
    {
        throw new Exception("Elements always have a phase for when they are created.");
    }
    else
    {
        // Show the Phase Create name to the user.
        String prompt = "The phase created is: " + phaseCreated.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseCreatedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Create property, and assert it should not be null
    Dim phaseCreated As Autodesk.Revit.DB.Phase = element.PhaseCreated
    If phaseCreated Is Nothing Then
        Throw New Exception("Elements always have a phase for when they are created.")
    Else
        ' Show the Phase Create name to the user.
        Dim prompt As [String] = "The phase created is: " + phaseCreated.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


PhaseDemolished Property

[image]

Revit 2013 API
Element..::..PhaseDemolished Property
Element Class Example See Also Send Feedback
An object representing the phase for when the element is to be demolished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in 2013. Use DemolishedPhaseId instead.")]
public Phase PhaseDemolished { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in 2013. Use DemolishedPhaseId instead.")> _
Public ReadOnly Property PhaseDemolished As Phase
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in 2013. Use DemolishedPhaseId instead.")]
public:
property Phase^ PhaseDemolished {
    Phase^ get ();
}

Remarks

The element may not have a demolition phase. If it does not then this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
void ShowPhaseDemolishedName(Element element)
{
    // Get the Phase Demolished property, and check whether it be null
    Autodesk.Revit.DB.Phase phaseDemolished = element.PhaseDemolished;
    if (null == phaseDemolished)
    {
        TaskDialog.Show("Revit","This Element doesn't have Phase Demolished parameter.");
    }
    else
    {
        // Show the Phase Demolished name to the user.
        String prompt = "The phase demolished is: " + phaseDemolished.Name;
        TaskDialog.Show("Revit",prompt);
    }
}
CopyVB.NET
Sub ShowPhaseDemolishedName(ByVal element As Autodesk.Revit.DB.Element)
    ' Get the Phase Demolished property, and check whether it be null
    Dim phaseDemolished As Autodesk.Revit.DB.Phase = element.PhaseDemolished
    If phaseDemolished Is Nothing Then
        TaskDialog.Show("Revit", "This Element doesn't have Phase Demolished parameter.")
    Else
        ' Show the Phase Demolished name to the user.
        Dim prompt As [String] = "The phase demolished is: " + phaseDemolished.Name
        TaskDialog.Show("Revit", prompt)
    End If
End Sub

See Also

Element Class


Pinned Property

[image]

Revit 2013 API
Element..::..Pinned Property
Element Class See Also Send Feedback
Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Pinned { get; set; }
Visual Basic
Public Property Pinned As Boolean
    Get
    Set
Visual C++
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}

Remarks

An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.

See Also

Element Class


UniqueId Property

[image]

Revit 2013 API
Element..::..UniqueId Property
Element Class Example See Also Send Feedback
A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string UniqueId { get; }
Visual Basic
Public ReadOnly Property UniqueId As String
    Get
Visual C++
public:
property String^ UniqueId {
    String^ get ();
}

Remarks

The UniqueId can be used to store an identifier in an external database and to retrieve the same element in the future if it still exists. This id can be passed the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as Save To Central, while the Autodesk::Revit::DB::ElementId^ property may change.

Examples

CopyC#
private void CheckElementUniqueId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    String uniqueId = element.UniqueId;

    // Get the element using the UniqueId
    Autodesk.Revit.DB.Element elem = document.GetElement(uniqueId);

    String prompt = "UniqueId of element is: " + uniqueId;
    prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
CopyVB.NET
Private Sub CheckElementUniqueId(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element)
    Dim uniqueId As [String] = element.UniqueId

    ' Get the element using the UniqueId
    Dim elem As Autodesk.Revit.DB.Element = document.GetElement(uniqueId)

    Dim prompt As [String] = "UniqueId of element is: " + uniqueId
    prompt += vbLf & "UniqueID of elem is: " + elem.UniqueId
End Sub

See Also

Element Class


ViewSpecific Property

[image]

Revit 2013 API
Element..::..ViewSpecific Property
Element Class See Also Send Feedback
Identifies if the element is owned by a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ViewSpecific { get; }
Visual Basic
Public ReadOnly Property ViewSpecific As Boolean
    Get
Visual C++
public:
property bool ViewSpecific {
    bool get ();
}

Field Value

True if the element is owned by a view.

See Also

Element Class


WorksetId Property

[image]

Revit 2013 API
Element..::..WorksetId Property
Element Class See Also Send Feedback
Get Id of the Workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

Remarks

Each element belongs to one and only one workset.

See Also

Element Class


ElementArray Class

[image]

Revit 2013 API
ElementArray Class
Members See Also Send Feedback
An array that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementArray : APIObject,
    IEnumerable
Visual Basic
Public Class ElementArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementArray

See Also

ElementArray Members


ElementArray Members

[image] [image]

Revit 2013 API
ElementArray Members
ElementArray Class Constructors Methods Properties See Also Send Feedback

The ElementArray type exposes the following members.

Constructors

 | Name | Description
Public method | ElementArray | Initializes a new instance of the ElementArray class

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray Class


ElementArray Constructor

[image]

Revit 2013 API
ElementArray Constructor
ElementArray Class See Also Send Feedback
Initializes a new instance of the ElementArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementArray()
Visual Basic
Public Sub New
Visual C++
public:
ElementArray()

See Also

ElementArray Class


ElementArray Methods

[image] [image]

Revit 2013 API
ElementArray Methods
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the element to the end of the array.
Public method | Clear | Removes every element from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArray Class


Append Method

[image]

Revit 2013 API
ElementArray..::..Append Method
ElementArray Class See Also Send Feedback
Add the element to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Element item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Element _
)
Visual C++
public:
virtual void Append(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be added.

See Also

ElementArray Class


Clear Method

[image]

Revit 2013 API
ElementArray..::..Clear Method
ElementArray Class See Also Send Feedback
Removes every element from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementArray Class


ForwardIterator Method

[image]

Revit 2013 API
ElementArray..::..ForwardIterator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElementArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ElementArray Class


GetEnumerator Method

[image]

Revit 2013 API
ElementArray..::..GetEnumerator Method
ElementArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ElementArray Class


Insert Method

[image]

Revit 2013 API
ElementArray..::..Insert Method
ElementArray Class See Also Send Feedback
Insert the specified element into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Element item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Element, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Element^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be inserted into the array.
index
Type: System..::..Int32
The element will be inserted before this index.

Return Value

Returns whether the element was inserted into the array.

See Also

ElementArray Class


ReverseIterator Method

[image]

Revit 2013 API
ElementArray..::..ReverseIterator Method
ElementArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElementArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ElementArrayIterator
Visual C++
public:
virtual ElementArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ElementArray Class


ElementArray Properties

[image] [image]

Revit 2013 API
ElementArray Properties
ElementArray Class See Also Send Feedback

The ElementArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an element at a specified index within the array.
Public property | Size | Returns the number of elements that are in the array.

See Also

ElementArray Class


IsEmpty Property

[image]

Revit 2013 API
ElementArray..::..IsEmpty Property
ElementArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ElementArray Class


Item Property

[image]

Revit 2013 API
ElementArray..::..Item Property
ElementArray Class See Also Send Feedback
Gets or sets an element at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Element this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Element
    Get
    Set
Visual C++
public:
virtual property Element^ Item[int index] {
    Element^ get (int index);
    void set (int index, Element^ value);
}

Parameters

index
Type: System..::..Int32
The index of the element to be set or retrieved.

Return Value

Returns the element at the specified index.

See Also

ElementArray Class


Size Property

[image]

Revit 2013 API
ElementArray..::..Size Property
ElementArray Class See Also Send Feedback
Returns the number of elements that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementArray Class


ElementArrayIterator Class

[image]

Revit 2013 API
ElementArrayIterator Class
Members See Also Send Feedback
An iterator to an element array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ElementArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ElementArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementArrayIterator

See Also

ElementArrayIterator Members


ElementArrayIterator Members

[image] [image]

Revit 2013 API
ElementArrayIterator Members
ElementArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ElementArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class


ElementArrayIterator Constructor

[image]

Revit 2013 API
ElementArrayIterator Constructor
ElementArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ElementArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementArrayIterator Class


ElementArrayIterator Methods

[image] [image]

Revit 2013 API
ElementArrayIterator Methods
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ElementArrayIterator..::..MoveNext Method
ElementArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


Reset Method

[image]

Revit 2013 API
ElementArrayIterator..::..Reset Method
ElementArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementArrayIterator Class


ElementArrayIterator Properties

[image] [image]

Revit 2013 API
ElementArrayIterator Properties
ElementArrayIterator Class See Also Send Feedback

The ElementArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementArrayIterator Class


Current Property

[image]

Revit 2013 API
ElementArrayIterator..::..Current Property
ElementArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementArrayIterator Class


ElementBinding Class

[image]

Revit 2013 API
ElementBinding Class
Members See Also Send Feedback
A base class for all types of binding that attach to an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ElementBinding : Binding
Visual Basic
Public MustInherit Class ElementBinding _
    Inherits Binding
Visual C++
public ref class ElementBinding abstract : public Binding

Remarks

This base class provides methods that are common to all types of binding that work with elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding
Autodesk.Revit.DB..::..InstanceBinding
Autodesk.Revit.DB..::..TypeBinding

See Also

ElementBinding Members


ElementBinding Members

[image] [image]

Revit 2013 API
ElementBinding Members
ElementBinding Class Methods Properties See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


ElementBinding Methods

[image] [image]

Revit 2013 API
ElementBinding Methods
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementBinding Class


ElementBinding Properties

[image] [image]

Revit 2013 API
ElementBinding Properties
ElementBinding Class See Also Send Feedback

The ElementBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementBinding Class


Categories Property

[image]

Revit 2013 API
ElementBinding..::..Categories Property
ElementBinding Class See Also Send Feedback
Retrieve or set the categories to which a parameter definition will be bound.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CategorySet Categories { get; set; }
Visual Basic
Public Property Categories As CategorySet
    Get
    Set
Visual C++
public:
property CategorySet^ Categories {
    CategorySet^ get ();
    void set (CategorySet^ value);
}

Remarks

The Categories property is used to set the categories to which the definition will be bound when it is added to the document bindings. This property can also be read from existing bindings to interrogate to which categories a parameter has been bound.

See Also

ElementBinding Class


ElementCategoryFilter Class

[image]

Revit 2013 API
ElementCategoryFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementCategoryFilter : ElementQuickFilter
Visual Basic
Public Class ElementCategoryFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementCategoryFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Find all Wall instances in the document by using category filter
ElementCategoryFilter filter = new ElementCategoryFilter(BuiltInCategory.OST_Walls);

// Apply the filter to the elements in the active document,
// Use shortcut WhereElementIsNotElementType() to find wall instances only
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> walls = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements();
String prompt = "The walls in the current document are:\n";
foreach (Element e in walls)
{
    prompt += e.Name + "\n";
}
TaskDialog.Show("Revit", prompt);
CopyVB.NET
' Find all Wall instances in the document by using category filter
Dim filter As New ElementCategoryFilter(BuiltInCategory.OST_Walls)

' Apply the filter to the elements in the active document,
' Use shortcut WhereElementIsNotElementType() to find wall instances only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim walls As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).WhereElementIsNotElementType().ToElements()
Dim prompt As [String] = "The walls in the current document are:" & vbLf
For Each e As Autodesk.Revit.DB.Element In walls
    prompt += e.Name + vbLf
Next
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementCategoryFilter

See Also

ElementCategoryFilter Members


ElementCategoryFilter Members

[image] [image]

Revit 2013 API
ElementCategoryFilter Members
ElementCategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


ElementCategoryFilter Constructor

[image] [image]

Revit 2013 API
ElementCategoryFilter Constructor
ElementCategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementCategoryFilter(BuiltInCategory) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(ElementId) | Constructs a new instance of a filter to match elements by category.
Public method | ElementCategoryFilter(BuiltInCategory, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.
Public method | ElementCategoryFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Members


ElementCategoryFilter Constructor (BuiltInCategory)

[image]

Revit 2013 API
ElementCategoryFilter Constructor (BuiltInCategory)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category
)
Visual Basic
Public Sub New ( _
    category As BuiltInCategory _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId)

[image]

Revit 2013 API
ElementCategoryFilter Constructor (ElementId)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId
)
Visual Basic
Public Sub New ( _
    categoryId As ElementId _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (BuiltInCategory, Boolean)

[image]

Revit 2013 API
ElementCategoryFilter Constructor (BuiltInCategory, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)
Visual Basic
Public Sub New ( _
    category As BuiltInCategory, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    BuiltInCategory category,
    bool inverted
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Constructor (ElementId, Boolean)

[image]

Revit 2013 API
ElementCategoryFilter Constructor (ElementId, Boolean)
ElementCategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementCategoryFilter(
    ElementId categoryId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categoryId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementCategoryFilter(
    ElementId^ categoryId,
    bool inverted
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementCategoryFilter Class
ElementCategoryFilter Overload


ElementCategoryFilter Methods

[image] [image]

Revit 2013 API
ElementCategoryFilter Methods
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementCategoryFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementCategoryFilter..::..PassesFilter Method
ElementCategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class
ElementCategoryFilter Members


ElementCategoryFilter Properties

[image] [image]

Revit 2013 API
ElementCategoryFilter Properties
ElementCategoryFilter Class See Also Send Feedback

The ElementCategoryFilter type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | The category id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementCategoryFilter Class


CategoryId Property

[image]

Revit 2013 API
ElementCategoryFilter..::..CategoryId Property
ElementCategoryFilter Class See Also Send Feedback
The category id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

See Also

ElementCategoryFilter Class


ElementClassFilter Class

[image]

Revit 2013 API
ElementClassFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementClassFilter : ElementQuickFilter
Visual Basic
Public Class ElementClassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementClassFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

This filter will match elements whose class is an exact match to the input class, or elements whose class is derived from the input class.

There is a small subset of Element subclasses in the API which are not supported by this filter. These types exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subtype. The following types are affected by this restriction:

  • Subclasses of Autodesk.Revit.DB.Material
  • Subclasses of Autodesk.Revit.DB.CurveElement
  • Subclasses of Autodesk.Revit.DB.ConnectorElement
  • Subclasses of Autodesk.Revit.DB.HostedSweep
  • Autodesk.Revit.DB.Architecture.Room
  • Autodesk.Revit.DB.Mechanical.Space
  • Autodesk.Revit.DB.Area
  • Autodesk.Revit.DB.Architecture.RoomTag
  • Autodesk.Revit.DB.Mechanical.SpaceTag
  • Autodesk.Revit.DB.AreaTag
  • Autodesk.Revit.DB.CombinableElement
  • Autodesk.Revit.DB.Mullion
  • Autodesk.Revit.DB.Panel
  • Autodesk.Revit.DB.AnnotationSymbol
  • Autodesk.Revit.DB.Structure.AreaReinforcementType
  • Autodesk.Revit.DB.Structure.PathReinforcementType
  • Autodesk.Revit.DB.AnnotationSymbolType
  • Autodesk.Revit.DB.Architecture.RoomTagType
  • Autodesk.Revit.DB.Mechanical.SpaceTagType
  • Autodesk.Revit.DB.AreaTagType
  • Autodesk.Revit.DB.Structure.TrussType

Examples

CopyC#
// Use ElementClassFilter to find family instances whose name is 60" x 30" Student
ElementClassFilter filter = new ElementClassFilter(typeof(FamilyInstance));

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Use Linq query to find family instances whose name is 60" x 30" Student
var query = from element in collector
            where element.Name == "60\" x 30\" Student"
            select element;

// Cast found elements to family instances,
// this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
List<FamilyInstance> familyInstances = query.Cast<FamilyInstance>().ToList<FamilyInstance>();
CopyVB.NET
' Use ElementClassFilter to find family instances whose name is 60" x 30" Student
Dim filter As New ElementClassFilter(GetType(FamilyInstance))

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(filter)

' Use Linq query to find family instances whose name is 60" x 30" Student
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "60"" x 30"" Student" _
 Select element

' Cast found elements to family instances,
' this cast to FamilyInstance is safe because ElementClassFilter for FamilyInstance was used
Dim familyInstances As List(Of Autodesk.Revit.DB.FamilyInstance) = query.Cast(Of Autodesk.Revit.DB.FamilyInstance)().ToList()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementClassFilter

See Also

ElementClassFilter Members


ElementClassFilter Members

[image] [image]

Revit 2013 API
ElementClassFilter Members
ElementClassFilter Class Constructors Methods Properties See Also Send Feedback

The ElementClassFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementClass | The class for the filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class


ElementClassFilter Constructor

[image] [image]

Revit 2013 API
ElementClassFilter Constructor
ElementClassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementClassFilter(Type) | Constructs a new instance of a filter to match elements by class.
Public method | ElementClassFilter(Type, Boolean) | Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

See Also

ElementClassFilter Class
ElementClassFilter Members


ElementClassFilter Constructor (Type)

[image]

Revit 2013 API
ElementClassFilter Constructor (Type)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type
)
Visual Basic
Public Sub New ( _
    type As Type _
)
Visual C++
public:
ElementClassFilter(
    Type^ type
)

Parameters

type
Type: System..::..Type
The type to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Constructor (Type, Boolean)

[image]

Revit 2013 API
ElementClassFilter Constructor (Type, Boolean)
ElementClassFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by class, with the option to match all elements which are not of the given class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementClassFilter(
    Type type,
    bool inverted
)
Visual Basic
Public Sub New ( _
    type As Type, _
    inverted As Boolean _
)
Visual C++
public:
ElementClassFilter(
    Type^ type,
    bool inverted
)

Parameters

type
Type: System..::..Type
The type to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element class that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementClassFilter Class
ElementClassFilter Overload


ElementClassFilter Methods

[image] [image]

Revit 2013 API
ElementClassFilter Methods
ElementClassFilter Class See Also Send Feedback

The ElementClassFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementClass | The class for the filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementClassFilter Class


GetElementClass Method

[image]

Revit 2013 API
ElementClassFilter..::..GetElementClass Method
ElementClassFilter Class See Also Send Feedback
The class for the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Type GetElementClass()
Visual Basic
Public Function GetElementClass As Type
Visual C++
public:
Type^ GetElementClass()

Return Value

The class.

See Also

ElementClassFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementClassFilter..::..PassesFilter Method
ElementClassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class
ElementClassFilter Members


ElementClassFilter Properties

[image] [image]

Revit 2013 API
ElementClassFilter Properties
ElementClassFilter Class See Also Send Feedback

The ElementClassFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementClassFilter Class


ElementDesignOptionFilter Class

[image]

Revit 2013 API
ElementDesignOptionFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementDesignOptionFilter : ElementQuickFilter
Visual Basic
Public Class ElementDesignOptionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementDesignOptionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Create an ElementDesignOption filter to find all walls in the active design option.
// Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
// ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
ElementId activeOptId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document);

// Create an ElementDesignOption filter
ElementDesignOptionFilter filter = new ElementDesignOptionFilter(activeOptId);

// Apply the filter to the elements in the active document,
// use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfDesignOpt = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();

// Find all walls that are not contained within active design option: use inverted filter to match elements
ElementDesignOptionFilter notActiveOptFilter = new ElementDesignOptionFilter(activeOptId, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notActiveOptWalls =
    collector.WherePasses(notActiveOptFilter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Create an ElementDesignOption filter to find all walls in the active design option.
' Note that if no design option is being edited, GetActiveDesignOptionId() method will return ElementId.InvalidElementId,
' ElementDesignOptionFilter with invalid id will filter elements not associated to a design option
Dim activeOptId As ElementId = Autodesk.Revit.DB.DesignOption.GetActiveDesignOptionId(document)

' Create an ElementDesignOption filter
Dim filter As New ElementDesignOptionFilter(activeOptId)

' Apply the filter to the elements in the active document,
' use shortcut method OfClass() to find Walls only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim wallsOfDesignOpt As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

' Find all walls that are not contained within active design option: use inverted filter to match elements
Dim notActiveOptFilter As New ElementDesignOptionFilter(activeOptId, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notActiveOptWalls As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notActiveOptFilter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementDesignOptionFilter

See Also

ElementDesignOptionFilter Members


ElementDesignOptionFilter Members

[image] [image]

Revit 2013 API
ElementDesignOptionFilter Members
ElementDesignOptionFilter Class Constructors Methods Properties See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


ElementDesignOptionFilter Constructor

[image] [image]

Revit 2013 API
ElementDesignOptionFilter Constructor
ElementDesignOptionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementDesignOptionFilter(ElementId) | Constructs a new instance of a filter to match elements contained within a particular design option.
Public method | ElementDesignOptionFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Members


ElementDesignOptionFilter Constructor (ElementId)

[image]

Revit 2013 API
ElementDesignOptionFilter Constructor (ElementId)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId
)
Visual Basic
Public Sub New ( _
    designOptionId As ElementId _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Constructor (ElementId, Boolean)

[image]

Revit 2013 API
ElementDesignOptionFilter Constructor (ElementId, Boolean)
ElementDesignOptionFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained within a particular design option, with the option to invert the filter and find elements not contained within a particular design option.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementDesignOptionFilter(
    ElementId designOptionId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    designOptionId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementDesignOptionFilter(
    ElementId^ designOptionId,
    bool inverted
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not contained within a particular design option.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Overload


ElementDesignOptionFilter Methods

[image] [image]

Revit 2013 API
ElementDesignOptionFilter Methods
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementDesignOptionFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementDesignOptionFilter..::..PassesFilter Method
ElementDesignOptionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class
ElementDesignOptionFilter Members


ElementDesignOptionFilter Properties

[image] [image]

Revit 2013 API
ElementDesignOptionFilter Properties
ElementDesignOptionFilter Class See Also Send Feedback

The ElementDesignOptionFilter type exposes the following members.

Properties

 | Name | Description
Public property | DesignOptionId | The design option id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementDesignOptionFilter Class


DesignOptionId Property

[image]

Revit 2013 API
ElementDesignOptionFilter..::..DesignOptionId Property
ElementDesignOptionFilter Class See Also Send Feedback
The design option id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId DesignOptionId { get; }
Visual Basic
Public ReadOnly Property DesignOptionId As ElementId
    Get
Visual C++
public:
property ElementId^ DesignOptionId {
    ElementId^ get ();
}

See Also

ElementDesignOptionFilter Class


ElementFilter Class

[image]

Revit 2013 API
ElementFilter Class
Members See Also Send Feedback
A base class for a type of filter that accepts or rejects elements based upon criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementFilter : IDisposable
Visual Basic
Public Class ElementFilter _
    Implements IDisposable
Visual C++
public ref class ElementFilter : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementSlowFilter

See Also

ElementFilter Members


ElementFilter Members

[image] [image]

Revit 2013 API
ElementFilter Members
ElementFilter Class Methods Properties See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElementFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

See Also

ElementFilter Class


ElementFilter Methods

[image] [image]

Revit 2013 API
ElementFilter Methods
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementFilter Class


Dispose Method

[image]

Revit 2013 API
ElementFilter..::..Dispose Method
ElementFilter Class See Also Send Feedback
Releases all resources used by the ElementFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElementFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementFilter..::..PassesFilter Method
ElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element.
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element.

See Also

ElementFilter Class
ElementFilter Members


PassesFilter Method (Element)

[image]

Revit 2013 API
ElementFilter..::..PassesFilter Method (Element)
ElementFilter Class See Also Send Feedback
Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool PassesFilter(
    Element element
)
Visual Basic
Public Function PassesFilter ( _
    element As Element _
) As Boolean
Visual C++
public:
bool PassesFilter(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementFilter Class
PassesFilter Overload


PassesFilter Method (Document, ElementId)

[image]

Revit 2013 API
ElementFilter..::..PassesFilter Method (Document, ElementId)
ElementFilter Class See Also Send Feedback
Applies the filter to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool PassesFilter(
    Document document,
    ElementId id
)
Visual Basic
Public Function PassesFilter ( _
    document As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
bool PassesFilter(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the element is accepted by the filter. False if the element is rejected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementFilter Class
PassesFilter Overload


ElementFilter Properties

[image] [image]

Revit 2013 API
ElementFilter Properties
ElementFilter Class See Also Send Feedback

The ElementFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

See Also

ElementFilter Class


Inverted Property

[image]

Revit 2013 API
ElementFilter..::..Inverted Property
ElementFilter Class See Also Send Feedback
True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Inverted { get; }
Visual Basic
Public ReadOnly Property Inverted As Boolean
    Get
Visual C++
public:
property bool Inverted {
    bool get ();
}

See Also

ElementFilter Class


ElementId Class

[image]

Revit 2013 API
ElementId Class
Members See Also Send Feedback
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementId
Visual Basic
Public Class ElementId
Visual C++
public ref class ElementId

Remarks

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementId

See Also

ElementId Members


ElementId Members

[image] [image]

Revit 2013 API
ElementId Members
ElementId Class Constructors Methods Operators Properties See Also Send Feedback

The ElementId type exposes the following members.

Constructors

 | Name | Description
Public method | ElementId(Int32) | Create an ElementId handle with the given integer id.
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the element id as an integer.
 | InvalidElementId | Get the invalid ElementId whose IntegerValue is -1.

See Also

ElementId Class


ElementId Constructor

[image] [image]

Revit 2013 API
ElementId Constructor
ElementId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementId(Int32) | Create an ElementId handle with the given integer id.
Public method | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id.
Public method | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id.

See Also

ElementId Class
ElementId Members


ElementId Constructor (Int32)

[image]

Revit 2013 API
ElementId Constructor (Int32)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId(
    int id
)
Visual Basic
Public Sub New ( _
    id As Integer _
)
Visual C++
public:
ElementId(
    int id
)

Parameters

id
Type: System..::..Int32
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (BuiltInCategory)

[image]

Revit 2013 API
ElementId Constructor (BuiltInCategory)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given BuiltInCategory id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId(
    BuiltInCategory categoryId
)
Visual Basic
Public Sub New ( _
    categoryId As BuiltInCategory _
)
Visual C++
public:
ElementId(
    BuiltInCategory categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..BuiltInCategory
The id.

See Also

ElementId Class
ElementId Overload


ElementId Constructor (BuiltInParameter)

[image]

Revit 2013 API
ElementId Constructor (BuiltInParameter)
ElementId Class See Also Send Feedback
Create an ElementId handle with the given BuiltInParameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId(
    BuiltInParameter parameterId
)
Visual Basic
Public Sub New ( _
    parameterId As BuiltInParameter _
)
Visual C++
public:
ElementId(
    BuiltInParameter parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..BuiltInParameter
The id.

See Also

ElementId Class
ElementId Overload


ElementId Methods

[image] [image]

Revit 2013 API
ElementId Methods
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two element ids.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

See Also

ElementId Class


Compare Method

[image]

Revit 2013 API
ElementId..::..Compare Method
ElementId Class See Also Send Feedback
Compares two element ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Compare(
    ElementId id
)
Visual Basic
Public Function Compare ( _
    id As ElementId _
) As Integer
Visual C++
public:
int Compare(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be compared with this ElementId.

Return Value

-1 if this element id is less than id, 0 if equal, 1 if greater.

See Also

ElementId Class


Equals Method

[image]

Revit 2013 API
ElementId..::..Equals Method
ElementId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

ElementId Class


GetHashCode Method

[image]

Revit 2013 API
ElementId..::..GetHashCode Method
ElementId Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ElementId Class


ToString Method

[image]

Revit 2013 API
ElementId..::..ToString Method
ElementId Class See Also Send Feedback
Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ElementId Class


ElementId Operators

[image] [image]

Revit 2013 API
ElementId Operators
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Operators

Name | Description
Equality | Determines whether these two ElementIds are the same.
GreaterThan | Determines whether one element id is greater than another element id.
GreaterThanOrEqual | Determines whether one element id is not less than another element id.
Inequality | Determines whether these two ElementIds are different.
LessThan | Determines whether this element id is less than another element id.
LessThanOrEqual | Determines whether one element id is not greater than another element id.

See Also

ElementId Class


Equality Operator

[image]

Revit 2013 API
ElementId..::..Equality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    ElementId first,
    ElementId second
)
Visual Basic
Public Shared Operator = ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the ElementIds are the same; otherwise, false.

See Also

ElementId Class


GreaterThan Operator

[image]

Revit 2013 API
ElementId..::..GreaterThan Operator
ElementId Class See Also Send Feedback
Determines whether one element id is greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator >(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator > ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is greater than the second element id, otherwise, false.

See Also

ElementId Class


GreaterThanOrEqual Operator

[image]

Revit 2013 API
ElementId..::..GreaterThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator >=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator >= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator >=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is not less than the second element id, otherwise, false.

See Also

ElementId Class


Inequality Operator

[image]

Revit 2013 API
ElementId..::..Inequality Operator
ElementId Class See Also Send Feedback
Determines whether these two ElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    ElementId first,
    ElementId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ElementId, _
    second As ElementId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ElementId^ first,
    ElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
second
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the ElementIds are different; otherwise, false.

See Also

ElementId Class


LessThan Operator

[image]

Revit 2013 API
ElementId..::..LessThan Operator
ElementId Class See Also Send Feedback
Determines whether this element id is less than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator <(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator < ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is less than the second element id, otherwise, false.

See Also

ElementId Class


LessThanOrEqual Operator

[image]

Revit 2013 API
ElementId..::..LessThanOrEqual Operator
ElementId Class See Also Send Feedback
Determines whether one element id is not greater than another element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator <=(
    ElementId elementId1,
    ElementId elementId2
)
Visual Basic
Public Shared Operator <= ( _
    elementId1 As ElementId, _
    elementId2 As ElementId _
) As Boolean
Visual C++
public:
static bool operator <=(
    ElementId^ elementId1,
    ElementId^ elementId2
)

Parameters

elementId1
Type: Autodesk.Revit.DB..::..ElementId
The first ElementId.
elementId2
Type: Autodesk.Revit.DB..::..ElementId
The second ElementId.

Return Value

True if the first element id is not greater than the second element id, otherwise, false.

See Also

ElementId Class


ElementId Properties

[image] [image]

Revit 2013 API
ElementId Properties
ElementId Class See Also Send Feedback

The ElementId type exposes the following members.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the element id as an integer.
 | InvalidElementId | Get the invalid ElementId whose IntegerValue is -1.

See Also

ElementId Class


IntegerValue Property

[image]

Revit 2013 API
ElementId..::..IntegerValue Property
ElementId Class See Also Send Feedback
Provides the value of the element id as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int IntegerValue { get; }
Visual Basic
Public ReadOnly Property IntegerValue As Integer
    Get
Visual C++
public:
property int IntegerValue {
    int get ();
}

See Also

ElementId Class


InvalidElementId Property

[image]

Revit 2013 API
ElementId..::..InvalidElementId Property
ElementId Class See Also Send Feedback
Get the invalid ElementId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ElementId InvalidElementId { get; }
Visual Basic
Public Shared ReadOnly Property InvalidElementId As ElementId
    Get
Visual C++
public:
static property ElementId^ InvalidElementId {
    ElementId^ get ();
}

See Also

ElementId Class


ElementIntersectsElementFilter Class

[image]

Revit 2013 API
ElementIntersectsElementFilter Class
Members See Also Send Feedback
A filter to find elements that intersect the solid geometry of a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementIntersectsElementFilter : ElementIntersectsFilter
Visual Basic
Public Class ElementIntersectsElementFilter _
    Inherits ElementIntersectsFilter
Visual C++
public ref class ElementIntersectsElementFilter : public ElementIntersectsFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsElementFilter

See Also

ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Members

[image] [image]

Revit 2013 API
ElementIntersectsElementFilter Members
ElementIntersectsElementFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class


ElementIntersectsElementFilter Constructor

[image] [image]

Revit 2013 API
ElementIntersectsElementFilter Constructor
ElementIntersectsElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIntersectsElementFilter(Element) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsElementFilter(Element, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Constructor (Element)

[image]

Revit 2013 API
ElementIntersectsElementFilter Constructor (Element)
ElementIntersectsElementFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementIntersectsElementFilter(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
ElementIntersectsElementFilter(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to check for intersection.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload


ElementIntersectsElementFilter Constructor (Element, Boolean)

[image]

Revit 2013 API
ElementIntersectsElementFilter Constructor (Element, Boolean)
ElementIntersectsElementFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementIntersectsElementFilter(
    Element element,
    bool inverted
)
Visual Basic
Public Sub New ( _
    element As Element, _
    inverted As Boolean _
)
Visual C++
public:
ElementIntersectsElementFilter(
    Element^ element,
    bool inverted
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to check for intersection.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not intersect the given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Overload


ElementIntersectsElementFilter Methods

[image] [image]

Revit 2013 API
ElementIntersectsElementFilter Methods
ElementIntersectsElementFilter Class See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElement | Gets the target element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIntersectsElementFilter Class


GetElement Method

[image]

Revit 2013 API
ElementIntersectsElementFilter..::..GetElement Method
ElementIntersectsElementFilter Class See Also Send Feedback
Gets the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Element GetElement()
Visual Basic
Public Function GetElement As Element
Visual C++
public:
Element^ GetElement()

Return Value

The element.

See Also

ElementIntersectsElementFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementIntersectsElementFilter..::..PassesFilter Method
ElementIntersectsElementFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class
ElementIntersectsElementFilter Members


ElementIntersectsElementFilter Properties

[image] [image]

Revit 2013 API
ElementIntersectsElementFilter Properties
ElementIntersectsElementFilter Class See Also Send Feedback

The ElementIntersectsElementFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsElementFilter Class


ElementIntersectsFilter Class

[image]

Revit 2013 API
ElementIntersectsFilter Class
Members See Also Send Feedback
A base class for filters used to match elements which intersect with geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementIntersectsFilter : ElementSlowFilter
Visual Basic
Public Class ElementIntersectsFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementIntersectsFilter : public ElementSlowFilter

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsElementFilter
Autodesk.Revit.DB..::..ElementIntersectsSolidFilter

See Also

ElementIntersectsFilter Members


ElementIntersectsFilter Members

[image] [image]

Revit 2013 API
ElementIntersectsFilter Members
ElementIntersectsFilter Class Methods Properties See Also Send Feedback

The ElementIntersectsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsFilter Class


ElementIntersectsFilter Methods

[image] [image]

Revit 2013 API
ElementIntersectsFilter Methods
ElementIntersectsFilter Class See Also Send Feedback

The ElementIntersectsFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsCategorySupported | Identifies if the input element is of a category supported by element intersection filters.
 | IsElementSupported | Identifies if the input element is supported by element intersection filters.
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIntersectsFilter Class


IsCategorySupported Method

[image]

Revit 2013 API
ElementIntersectsFilter..::..IsCategorySupported Method
ElementIntersectsFilter Class See Also Send Feedback
Identifies if the input element is of a category supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsCategorySupported(
    Element element
)
Visual Basic
Public Shared Function IsCategorySupported ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsCategorySupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

True if the element category is supported, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsFilter Class


IsElementSupported Method

[image]

Revit 2013 API
ElementIntersectsFilter..::..IsElementSupported Method
ElementIntersectsFilter Class See Also Send Feedback
Identifies if the input element is supported by element intersection filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsElementSupported(
    Element element
)
Visual Basic
Public Shared Function IsElementSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsElementSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

True if the element is supported, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementIntersectsFilter..::..PassesFilter Method
ElementIntersectsFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIntersectsFilter Class
ElementIntersectsFilter Members


ElementIntersectsFilter Properties

[image] [image]

Revit 2013 API
ElementIntersectsFilter Properties
ElementIntersectsFilter Class See Also Send Feedback

The ElementIntersectsFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsFilter Class


ElementIntersectsSolidFilter Class

[image]

Revit 2013 API
ElementIntersectsSolidFilter Class
Members Example See Also Send Feedback
A filter to find elements that intersect the given solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementIntersectsSolidFilter : ElementIntersectsFilter
Visual Basic
Public Class ElementIntersectsSolidFilter _
    Inherits ElementIntersectsFilter
Visual C++
public ref class ElementIntersectsSolidFilter : public ElementIntersectsFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement.Objects)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id + ")");
CopyC#
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement.Objects)
{
    solid = geomObj as Solid;
    if (solid != null) break;
}

FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches

TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id + ")");

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementIntersectsSolidFilter

See Also

ElementIntersectsSolidFilter Members


ElementIntersectsSolidFilter Members

[image] [image]

Revit 2013 API
ElementIntersectsSolidFilter Members
ElementIntersectsSolidFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsSolidFilter Class


ElementIntersectsSolidFilter Constructor

[image] [image]

Revit 2013 API
ElementIntersectsSolidFilter Constructor
ElementIntersectsSolidFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIntersectsSolidFilter(Solid) | Constructs a filter to match elements which intersect the given element.
Public method | ElementIntersectsSolidFilter(Solid, Boolean) | Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

See Also

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Members


ElementIntersectsSolidFilter Constructor (Solid)

[image]

Revit 2013 API
ElementIntersectsSolidFilter Constructor (Solid)
ElementIntersectsSolidFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementIntersectsSolidFilter(
    Solid solid
)
Visual Basic
Public Sub New ( _
    solid As Solid _
)
Visual C++
public:
ElementIntersectsSolidFilter(
    Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The solid geometry to check for intersection.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Overload


ElementIntersectsSolidFilter Constructor (Solid, Boolean)

[image]

Revit 2013 API
ElementIntersectsSolidFilter Constructor (Solid, Boolean)
ElementIntersectsSolidFilter Class See Also Send Feedback
Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementIntersectsSolidFilter(
    Solid solid,
    bool inverted
)
Visual Basic
Public Sub New ( _
    solid As Solid, _
    inverted As Boolean _
)
Visual C++
public:
ElementIntersectsSolidFilter(
    Solid^ solid,
    bool inverted
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The solid geometry to check for intersection.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not intersect the given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Overload


ElementIntersectsSolidFilter Methods

[image] [image]

Revit 2013 API
ElementIntersectsSolidFilter Methods
ElementIntersectsSolidFilter Class See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSolid | Gets the target solid geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIntersectsSolidFilter Class


GetSolid Method

[image]

Revit 2013 API
ElementIntersectsSolidFilter..::..GetSolid Method
ElementIntersectsSolidFilter Class See Also Send Feedback
Gets the target solid geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Solid GetSolid()
Visual Basic
Public Function GetSolid As Solid
Visual C++
public:
Solid^ GetSolid()

Return Value

The solid geometry.

See Also

ElementIntersectsSolidFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementIntersectsSolidFilter..::..PassesFilter Method
ElementIntersectsSolidFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIntersectsSolidFilter Class
ElementIntersectsSolidFilter Members


ElementIntersectsSolidFilter Properties

[image] [image]

Revit 2013 API
ElementIntersectsSolidFilter Properties
ElementIntersectsSolidFilter Class See Also Send Feedback

The ElementIntersectsSolidFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIntersectsSolidFilter Class


ElementIsCurveDrivenFilter Class

[image]

Revit 2013 API
ElementIsCurveDrivenFilter Class
Members Example See Also Send Feedback
A filter used to match elements which are curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementIsCurveDrivenFilter : ElementQuickFilter
Visual Basic
Public Class ElementIsCurveDrivenFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsCurveDrivenFilter : public ElementQuickFilter

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements. This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
// The term "curve driven" indicates that the element's Location property is a LocationCurve
ElementIsCurveDrivenFilter filter = new ElementIsCurveDrivenFilter();

// Apply the filter to the elements in the active document,
// Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
// are placed at a single point).
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> slantColumns = collector
    .WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements();

// Find elements of not curve driven: use inverted filter to match elements
ElementIsCurveDrivenFilter notCurveDrivenFilter = new ElementIsCurveDrivenFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notCurveDrivenFounds = collector.WherePasses(notCurveDrivenFilter).ToElements();
CopyVB.NET
' Create an ElementIsCurveDriven filter to find slanted columns(which is curve-driven) in the document,
' The term "curve driven" indicates that the element's Location property is a LocationCurve
Dim filter As New ElementIsCurveDrivenFilter()

' Apply the filter to the elements in the active document,
' Use the ElementIsCurveDrivenFilter on columns to find only slanted columns (vertical columns
' are placed at a single point).
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim slantColumns As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfCategory(BuiltInCategory.OST_StructuralColumns).ToElements()

' Find elements of not curve driven: use inverted filter to match elements
Dim notCurveDrivenFilter As New ElementIsCurveDrivenFilter(True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notCurveDrivenFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notCurveDrivenFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementIsCurveDrivenFilter

See Also

ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Members

[image] [image]

Revit 2013 API
ElementIsCurveDrivenFilter Members
ElementIsCurveDrivenFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIsCurveDrivenFilter()()()() | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsCurveDrivenFilter Constructor

[image] [image]

Revit 2013 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIsCurveDrivenFilter()()()() | Constructs a new instance of a filter to match only curve driven elements.
Public method | ElementIsCurveDrivenFilter(Boolean) | Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Constructor

[image]

Revit 2013 API
ElementIsCurveDrivenFilter Constructor
ElementIsCurveDrivenFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter()
Visual Basic
Public Sub New
Visual C++
public:
ElementIsCurveDrivenFilter()

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter Constructor (Boolean)

[image]

Revit 2013 API
ElementIsCurveDrivenFilter Constructor (Boolean)
ElementIsCurveDrivenFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementIsCurveDrivenFilter(
    bool inverted
)
Visual Basic
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
ElementIsCurveDrivenFilter(
    bool inverted
)

Parameters

inverted
Type: System..::..Boolean
True if the filter should match all elements which are not curve driven elements.

Remarks

The term "curve driven" indicates that the element's Location property is a LocationCurve. Example elements found by this filter include walls, beams, and curve elements.

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Overload


ElementIsCurveDrivenFilter Methods

[image] [image]

Revit 2013 API
ElementIsCurveDrivenFilter Methods
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIsCurveDrivenFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementIsCurveDrivenFilter..::..PassesFilter Method
ElementIsCurveDrivenFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class
ElementIsCurveDrivenFilter Members


ElementIsCurveDrivenFilter Properties

[image] [image]

Revit 2013 API
ElementIsCurveDrivenFilter Properties
ElementIsCurveDrivenFilter Class See Also Send Feedback

The ElementIsCurveDrivenFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsCurveDrivenFilter Class


ElementIsElementTypeFilter Class

[image]

Revit 2013 API
ElementIsElementTypeFilter Class
Members See Also Send Feedback
A filter used to match elements which are ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementIsElementTypeFilter : ElementQuickFilter
Visual Basic
Public Class ElementIsElementTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementIsElementTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementIsElementTypeFilter

See Also

ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Members

[image] [image]

Revit 2013 API
ElementIsElementTypeFilter Members
ElementIsElementTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementIsElementTypeFilter()()()() | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class


ElementIsElementTypeFilter Constructor

[image] [image]

Revit 2013 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementIsElementTypeFilter()()()() | Constructs a new instance of a filter to match only ElementTypes.
Public method | ElementIsElementTypeFilter(Boolean) | Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Constructor

[image]

Revit 2013 API
ElementIsElementTypeFilter Constructor
ElementIsElementTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementIsElementTypeFilter()
Visual Basic
Public Sub New
Visual C++
public:
ElementIsElementTypeFilter()

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Constructor (Boolean)

[image]

Revit 2013 API
ElementIsElementTypeFilter Constructor (Boolean)
ElementIsElementTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match only ElementTypes, with the option to match all elements which are not ElementTypes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementIsElementTypeFilter(
    bool inverted
)
Visual Basic
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
ElementIsElementTypeFilter(
    bool inverted
)

Parameters

inverted
Type: System..::..Boolean
True if the filter should match all elements which are not ElementTypes.

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Overload


ElementIsElementTypeFilter Methods

[image] [image]

Revit 2013 API
ElementIsElementTypeFilter Methods
ElementIsElementTypeFilter Class See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementIsElementTypeFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementIsElementTypeFilter..::..PassesFilter Method
ElementIsElementTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class
ElementIsElementTypeFilter Members


ElementIsElementTypeFilter Properties

[image] [image]

Revit 2013 API
ElementIsElementTypeFilter Properties
ElementIsElementTypeFilter Class See Also Send Feedback

The ElementIsElementTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementIsElementTypeFilter Class


ElementLevelFilter Class

[image]

Revit 2013 API
ElementLevelFilter Class
Members Example See Also Send Feedback
A filter used to match elements by their associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementLevelFilter : ElementSlowFilter
Visual Basic
Public Class ElementLevelFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementLevelFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Use ElementLevel filter to find elements by their associated level in the document

// Find the level whose Name is "Level 1"
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
var query = from element in collector where element.Name == "Level 1" select element;// Linq query

// Get the level id which will be used to match elements
List<Element> level1 = query.ToList<Element>();
ElementId levelId = level1[0].Id;

// Find all walls on level one
ElementLevelFilter level1Filter = new ElementLevelFilter(levelId);
collector = new FilteredElementCollector(document);
ICollection<Element> allWallsOnLevel1 = collector.OfClass(typeof(Wall)).WherePasses(level1Filter).ToElements();

// Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
ElementLevelFilter notOnLevel1Filter = new ElementLevelFilter(levelId, true); // Inverted filter
collector = new FilteredElementCollector(document);
IList<Element> allRoomsNotOnLevel1 = collector.WherePasses(new RoomFilter()).WherePasses(notOnLevel1Filter).ToElements();
CopyVB.NET
' Use ElementLevel filter to find elements by their associated level in the document

' Find the level whose Name is "Level 1"
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim levels As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Level)).ToElements()
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "Level 1" _
 Select element
' Linq query
' Get the level id which will be used to match elements
Dim level1 As List(Of Autodesk.Revit.DB.Element) = query.ToList()
Dim levelId As ElementId = level1(0).Id

' Find all walls on level one
Dim level1Filter As New ElementLevelFilter(levelId)
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim allWallsOnLevel1 As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(level1Filter).ToElements()

' Find all rooms not on level one: use an inverted ElementLevelFilter to match all elements not on the target level
Dim notOnLevel1Filter As New ElementLevelFilter(levelId, True)
' Inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim allRoomsNotOnLevel1 As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(New Autodesk.Revit.DB.Architecture.RoomFilter()).WherePasses(notOnLevel1Filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementLevelFilter

See Also

ElementLevelFilter Members


ElementLevelFilter Members

[image] [image]

Revit 2013 API
ElementLevelFilter Members
ElementLevelFilter Class Constructors Methods Properties See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


ElementLevelFilter Constructor

[image] [image]

Revit 2013 API
ElementLevelFilter Constructor
ElementLevelFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementLevelFilter(ElementId) | Constructs a new instance of an ElementLevelFilter.
Public method | ElementLevelFilter(ElementId, Boolean) | Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

See Also

ElementLevelFilter Class
ElementLevelFilter Members


ElementLevelFilter Constructor (ElementId)

[image]

Revit 2013 API
ElementLevelFilter Constructor (ElementId)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId
)
Visual Basic
Public Sub New ( _
    levelId As ElementId _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the level that will be matched to elements' associated level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Constructor (ElementId, Boolean)

[image]

Revit 2013 API
ElementLevelFilter Constructor (ElementId, Boolean)
ElementLevelFilter Class See Also Send Feedback
Constructs a new instance of an ElementLevelFilter, with the option to match all elements not associated to the given level id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementLevelFilter(
    ElementId levelId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    levelId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementLevelFilter(
    ElementId^ levelId,
    bool inverted
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the level that will be matched to elements' associated level.
inverted
Type: System..::..Boolean
True if the filter should match all elements not associated to the given level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementLevelFilter Class
ElementLevelFilter Overload


ElementLevelFilter Methods

[image] [image]

Revit 2013 API
ElementLevelFilter Methods
ElementLevelFilter Class See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementLevelFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementLevelFilter..::..PassesFilter Method
ElementLevelFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementLevelFilter Class
ElementLevelFilter Members


ElementLevelFilter Properties

[image] [image]

Revit 2013 API
ElementLevelFilter Properties
ElementLevelFilter Class See Also Send Feedback

The ElementLevelFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | LevelId | The id of the level that will be matched to elements' associated level.

See Also

ElementLevelFilter Class


LevelId Property

[image]

Revit 2013 API
ElementLevelFilter..::..LevelId Property
ElementLevelFilter Class See Also Send Feedback
The id of the level that will be matched to elements' associated level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId LevelId { get; }
Visual Basic
Public ReadOnly Property LevelId As ElementId
    Get
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

ElementLevelFilter Class


ElementLogicalFilter Class

[image]

Revit 2013 API
ElementLogicalFilter Class
Members See Also Send Feedback
A filter used to logically combine two or more filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementLogicalFilter : ElementFilter
Visual Basic
Public Class ElementLogicalFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementLogicalFilter : public ElementFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalAndFilter
Autodesk.Revit.DB..::..LogicalOrFilter

See Also

ElementLogicalFilter Members


ElementLogicalFilter Members

[image] [image]

Revit 2013 API
ElementLogicalFilter Members
ElementLogicalFilter Class Methods Properties See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementLogicalFilter Methods

[image] [image]

Revit 2013 API
ElementLogicalFilter Methods
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementLogicalFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementLogicalFilter..::..PassesFilter Method
ElementLogicalFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class
ElementLogicalFilter Members


ElementLogicalFilter Properties

[image] [image]

Revit 2013 API
ElementLogicalFilter Properties
ElementLogicalFilter Class See Also Send Feedback

The ElementLogicalFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementLogicalFilter Class


ElementMulticategoryFilter Class

[image]

Revit 2013 API
ElementMulticategoryFilter Class
Members See Also Send Feedback
A filter used to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementMulticategoryFilter : ElementQuickFilter
Visual Basic
Public Class ElementMulticategoryFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementMulticategoryFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementMulticategoryFilter

See Also

ElementMulticategoryFilter Members


ElementMulticategoryFilter Members

[image] [image]

Revit 2013 API
ElementMulticategoryFilter Members
ElementMulticategoryFilter Class Constructors Methods Properties See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to match all elements which are of the given categories.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class


ElementMulticategoryFilter Constructor

[image] [image]

Revit 2013 API
ElementMulticategoryFilter Constructor
ElementMulticategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>)) | Constructs a new instance of a filter to match elements by built-in category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>)) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(BuiltInCategory>)>>), Boolean) | Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.
Public method | ElementMulticategoryFilter(ICollection<(Of <<'(ElementId>)>>), Boolean) | Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to match all elements which are of the given categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Members


ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory))

[image]

Revit 2013 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'BuiltInCategory>)>)>)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by built-in category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories
)
Visual Basic
Public Sub New ( _
    categories As ICollection(Of BuiltInCategory) _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'BuiltInCategory>)>)>
The built-in categories to match.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Constructor (ICollection(ElementId))

[image]

Revit 2013 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'ElementId>)>)>)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose category matches any of a given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds
)
Visual Basic
Public Sub New ( _
    categoryIds As ICollection(Of ElementId) _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The category ids to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more categories was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Constructor (ICollection(BuiltInCategory), Boolean)

[image]

Revit 2013 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'BuiltInCategory>)>)>, Boolean)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by built-in category, with the option to match all elements which are not of the given category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<BuiltInCategory> categories,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categories As ICollection(Of BuiltInCategory), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<BuiltInCategory>^ categories,
    bool inverted
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'BuiltInCategory>)>)>
The built-in categories to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given built-in categories.

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Constructor (ICollection(ElementId), Boolean)

[image]

Revit 2013 API
ElementMulticategoryFilter Constructor (ICollection<(Of <(<'ElementId>)>)>, Boolean)
ElementMulticategoryFilter Class See Also Send Feedback
Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to match all elements which are of the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementMulticategoryFilter(
    ICollection<ElementId> categoryIds,
    bool inverted
)
Visual Basic
Public Sub New ( _
    categoryIds As ICollection(Of ElementId), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticategoryFilter(
    ICollection<ElementId^>^ categoryIds,
    bool inverted
)

Parameters

categoryIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The category ids to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more categories was not valid for filtering.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Overload


ElementMulticategoryFilter Methods

[image] [image]

Revit 2013 API
ElementMulticategoryFilter Methods
ElementMulticategoryFilter Class See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCategoryIds | Gets the category ids assigned to this filter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementMulticategoryFilter Class


GetCategoryIds Method

[image]

Revit 2013 API
ElementMulticategoryFilter..::..GetCategoryIds Method
ElementMulticategoryFilter Class See Also Send Feedback
Gets the category ids assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetCategoryIds()
Visual Basic
Public Function GetCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategoryIds()

Return Value

The category ids.

See Also

ElementMulticategoryFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementMulticategoryFilter..::..PassesFilter Method
ElementMulticategoryFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class
ElementMulticategoryFilter Members


ElementMulticategoryFilter Properties

[image] [image]

Revit 2013 API
ElementMulticategoryFilter Properties
ElementMulticategoryFilter Class See Also Send Feedback

The ElementMulticategoryFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticategoryFilter Class


ElementMulticlassFilter Class

[image]

Revit 2013 API
ElementMulticlassFilter Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementMulticlassFilter : ElementQuickFilter
Visual Basic
Public Class ElementMulticlassFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementMulticlassFilter : public ElementQuickFilter

Remarks

Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementMulticlassFilter

See Also

ElementMulticlassFilter Members


ElementMulticlassFilter Members

[image] [image]

Revit 2013 API
ElementMulticlassFilter Members
ElementMulticlassFilter Class Constructors Methods Properties See Also Send Feedback

The ElementMulticlassFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>)) | Constructs a filter using multiple types
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>), Boolean) | Constructs a filter using multiple types

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class


ElementMulticlassFilter Constructor

[image] [image]

Revit 2013 API
ElementMulticlassFilter Constructor
ElementMulticlassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>)) | Constructs a filter using multiple types
Public method | ElementMulticlassFilter(IList<(Of <<'(Type>)>>), Boolean) | Constructs a filter using multiple types

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Members


ElementMulticlassFilter Constructor (IList(Type))

[image]

Revit 2013 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a filter using multiple types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type) _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of types to match

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not subclasses of Element. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


ElementMulticlassFilter Constructor (IList(Type), Boolean)

[image]

Revit 2013 API
ElementMulticlassFilter Constructor (IList<(Of <(<'Type>)>)>, Boolean)
ElementMulticlassFilter Class See Also Send Feedback
Constructs a filter using multiple types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementMulticlassFilter(
    IList<Type> typeList,
    bool inverted
)
Visual Basic
Public Sub New ( _
    typeList As IList(Of Type), _
    inverted As Boolean _
)
Visual C++
public:
ElementMulticlassFilter(
    IList<Type^>^ typeList,
    bool inverted
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'Type>)>)>
The list of types to match
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given class.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more input types are not subclasses of Element. -or- One or more of the types do not exist in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Overload


ElementMulticlassFilter Methods

[image] [image]

Revit 2013 API
ElementMulticlassFilter Methods
ElementMulticlassFilter Class See Also Send Feedback

The ElementMulticlassFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementMulticlassFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementMulticlassFilter..::..PassesFilter Method
ElementMulticlassFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class
ElementMulticlassFilter Members


ElementMulticlassFilter Properties

[image] [image]

Revit 2013 API
ElementMulticlassFilter Properties
ElementMulticlassFilter Class See Also Send Feedback

The ElementMulticlassFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementMulticlassFilter Class


ElementOnPhaseStatus Enumeration

[image]

Revit 2013 API
ElementOnPhaseStatus Enumeration
See Also Send Feedback
The statuses that an element can have with respect to a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ElementOnPhaseStatus
Visual Basic
Public Enumeration ElementOnPhaseStatus
Visual C++
public enum class ElementOnPhaseStatus

Members

Member name | Description
None | Phase status is undefined (e.g., for annotations)
Past | Created and demolished before the given phase
Existing | Created in a previous phase, existing through the end of the given phase
Demolished | Created before the given phase, to be demolished on the given phase
New | Created on this phase (and not demolished)
Temporary | Created and demolished during this phase
Future | Created after this phase

See Also


ElementOwnerViewFilter Class

[image]

Revit 2013 API
ElementOwnerViewFilter Class
Members Example See Also Send Feedback
A filter used to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementOwnerViewFilter : ElementQuickFilter
Visual Basic
Public Class ElementOwnerViewFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementOwnerViewFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use ElementOwnerView filter to find TextNotes in the active view

// Create an ElementOwnerView filter with id of active view
ElementOwnerViewFilter elementOwnerViewFilter = new ElementOwnerViewFilter(document.ActiveView.Id);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find TextNotes only
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> textNotesOfActiveView =
    collector.WherePasses(elementOwnerViewFilter).OfClass(typeof(TextNote)).ToElements();

// Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
ElementOwnerViewFilter notOwnedFilter = new ElementOwnerViewFilter(document.ActiveView.Id, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notOwnedByViewFounds =
    collector.WherePasses(notOwnedFilter).OfClass(typeof(TextNote)).ToElements();
CopyVB.NET
' Use ElementOwnerView filter to find TextNotes in the active view

' Create an ElementOwnerView filter with id of active view
Dim elementOwnerViewFilter As New ElementOwnerViewFilter(document.ActiveView.Id)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find TextNotes only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim textNotesOfActiveView As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(elementOwnerViewFilter).OfClass(GetType(TextNote)).ToElements()

' Find TextNotes which are not owned by active view: use an inverted filter to match TextNotes
Dim notOwnedFilter As New ElementOwnerViewFilter(document.ActiveView.Id, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notOwnedByViewFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notOwnedFilter).OfClass(GetType(TextNote)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementOwnerViewFilter

See Also

ElementOwnerViewFilter Members


ElementOwnerViewFilter Members

[image] [image]

Revit 2013 API
ElementOwnerViewFilter Members
ElementOwnerViewFilter Class Constructors Methods Properties See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ElementOwnerViewFilter Constructor

[image] [image]

Revit 2013 API
ElementOwnerViewFilter Constructor
ElementOwnerViewFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementOwnerViewFilter(ElementId) | Constructs a new instance of a filter to match elements which are owned by a particular view.
Public method | ElementOwnerViewFilter(ElementId, Boolean) | Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Members


ElementOwnerViewFilter Constructor (ElementId)

[image]

Revit 2013 API
ElementOwnerViewFilter Constructor (ElementId)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    viewId As ElementId _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Constructor (ElementId, Boolean)

[image]

Revit 2013 API
ElementOwnerViewFilter Constructor (ElementId, Boolean)
ElementOwnerViewFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements which are owned by a particular view, with the option to invert the filter and find elements not owned by the given view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementOwnerViewFilter(
    ElementId viewId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    viewId As ElementId, _
    inverted As Boolean _
)
Visual C++
public:
ElementOwnerViewFilter(
    ElementId^ viewId,
    bool inverted
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id to match. Pass invalid element id to create a filter that will pass non-view-specific elements.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not owned by the given view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Overload


ElementOwnerViewFilter Methods

[image] [image]

Revit 2013 API
ElementOwnerViewFilter Methods
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementOwnerViewFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementOwnerViewFilter..::..PassesFilter Method
ElementOwnerViewFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementOwnerViewFilter Class
ElementOwnerViewFilter Members


ElementOwnerViewFilter Properties

[image] [image]

Revit 2013 API
ElementOwnerViewFilter Properties
ElementOwnerViewFilter Class See Also Send Feedback

The ElementOwnerViewFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | ViewId | The view id.

See Also

ElementOwnerViewFilter Class


ViewId Property

[image]

Revit 2013 API
ElementOwnerViewFilter..::..ViewId Property
ElementOwnerViewFilter Class See Also Send Feedback
The view id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

See Also

ElementOwnerViewFilter Class


ElementParameterFilter Class

[image]

Revit 2013 API
ElementParameterFilter Class
Members Example See Also Send Feedback
A filter used to match elements by one or more parameter filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementParameterFilter : ElementSlowFilter
Visual Basic
Public Class ElementParameterFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementParameterFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates an ElementParameter filter to find rooms whose area is
// greater than specified value
// Create filter by provider and evaluator
// provider
ParameterValueProvider pvp = new ParameterValueProvider(new ElementId(BuiltInParameter.ROOM_AREA));
// evaluator
FilterNumericRuleEvaluator fnrv = new FilterNumericGreater();
// rule value
double ruleValue = 100.0f; // filter room whose area is greater than 100 SF
// rule
FilterRule fRule = new FilterDoubleRule(pvp, fnrv, ruleValue, 1E-6);

// Create an ElementParameter filter
ElementParameterFilter filter = new ElementParameterFilter(fRule);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();

// Find rooms whose area is less than or equal to 100:
// Use inverted filter to match elements
ElementParameterFilter lessOrEqualFilter = new ElementParameterFilter(fRule, true);
collector = new FilteredElementCollector(document);
IList<Element> lessOrEqualFounds = collector.WherePasses(lessOrEqualFilter).ToElements();
CopyVB.NET
' Creates an ElementParameter filter to find rooms whose area is
' greater than specified value
' Create filter by provider and evaluator
Dim areaParam As BuiltInParameter = BuiltInParameter.ROOM_AREA
' provider
Dim pvp As New ParameterValueProvider(New ElementId(DirectCast(areaParam, Integer)))
' evaluator
Dim fnrv As FilterNumericRuleEvaluator = New FilterNumericGreater()
' rule value
Dim ruleValue As Double = 100.0F
' filter room whose area is greater than 100 SF
' rule
Dim fRule As FilterRule = New FilterDoubleRule(pvp, fnrv, ruleValue, 0.000001)

' Create an ElementParameter filter
Dim filter As New ElementParameterFilter(fRule)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim rooms As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find rooms whose area is less than or equal to 100:
' Use inverted filter to match elements
Dim lessOrEqualFilter As New ElementParameterFilter(fRule, True)
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim lessOrEqualFounds As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(lessOrEqualFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementParameterFilter

See Also

ElementParameterFilter Members


ElementParameterFilter Members

[image] [image]

Revit 2013 API
ElementParameterFilter Members
ElementParameterFilter Class Constructors Methods Properties See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRules | Returns the set of rules contained in this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementParameterFilter Constructor

[image] [image]

Revit 2013 API
ElementParameterFilter Constructor
ElementParameterFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementParameterFilter(FilterRule) | Constructs a new instance of an ElementParameterFilter from a single rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>)) | Constructs a new instance of an ElementParameterFilter from a set of rules.
Public method | ElementParameterFilter(FilterRule, Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Public method | ElementParameterFilter(IList<(Of <<'(FilterRule>)>>), Boolean) | Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

See Also

ElementParameterFilter Class
ElementParameterFilter Members


ElementParameterFilter Constructor (FilterRule)

[image]

Revit 2013 API
ElementParameterFilter Constructor (FilterRule)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a single rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule
)
Visual Basic
Public Sub New ( _
    filterRule As FilterRule _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule))

[image]

Revit 2013 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter from a set of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule) _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules applied to test if the element passes this filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (FilterRule, Boolean)

[image]

Revit 2013 API
ElementParameterFilter Constructor (FilterRule, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    FilterRule filterRule,
    bool inverted
)
Visual Basic
Public Sub New ( _
    filterRule As FilterRule, _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    FilterRule^ filterRule,
    bool inverted
)

Parameters

filterRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Constructor (IList(FilterRule), Boolean)

[image]

Revit 2013 API
ElementParameterFilter Constructor (IList<(Of <(<'FilterRule>)>)>, Boolean)
ElementParameterFilter Class See Also Send Feedback
Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing the given filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementParameterFilter(
    IList<FilterRule> filterRules,
    bool inverted
)
Visual Basic
Public Sub New ( _
    filterRules As IList(Of FilterRule), _
    inverted As Boolean _
)
Visual C++
public:
ElementParameterFilter(
    IList<FilterRule^>^ filterRules,
    bool inverted
)

Parameters

filterRules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules applied to test if the element passes this filter.
inverted
Type: System..::..Boolean
True if the filter should match all elements which do not pass the filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filterRules array is empty or invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementParameterFilter Class
ElementParameterFilter Overload


ElementParameterFilter Methods

[image] [image]

Revit 2013 API
ElementParameterFilter Methods
ElementParameterFilter Class See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRules | Returns the set of rules contained in this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementParameterFilter Class


GetRules Method

[image]

Revit 2013 API
ElementParameterFilter..::..GetRules Method
ElementParameterFilter Class See Also Send Feedback
Returns the set of rules contained in this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FilterRule> GetRules()
Visual Basic
Public Function GetRules As IList(Of FilterRule)
Visual C++
public:
IList<FilterRule^>^ GetRules()

Return Value

A copy of the set of rules.

See Also

ElementParameterFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementParameterFilter..::..PassesFilter Method
ElementParameterFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class
ElementParameterFilter Members


ElementParameterFilter Properties

[image] [image]

Revit 2013 API
ElementParameterFilter Properties
ElementParameterFilter Class See Also Send Feedback

The ElementParameterFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementParameterFilter Class


ElementPhaseStatusFilter Class

[image]

Revit 2013 API
ElementPhaseStatusFilter Class
Members See Also Send Feedback
A filter used to match elements that have a given phase status on a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementPhaseStatusFilter : ElementSlowFilter
Visual Basic
Public Class ElementPhaseStatusFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class ElementPhaseStatusFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..ElementPhaseStatusFilter

See Also

ElementPhaseStatusFilter Members


ElementPhaseStatusFilter Members

[image] [image]

Revit 2013 API
ElementPhaseStatusFilter Members
ElementPhaseStatusFilter Class Constructors Methods Properties See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | PhaseId | The phase id.

See Also

ElementPhaseStatusFilter Class


ElementPhaseStatusFilter Constructor

[image] [image]

Revit 2013 API
ElementPhaseStatusFilter Constructor
ElementPhaseStatusFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus) | Constructs a new instance of a file to match elements that have a given phase status on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>)) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.
Public method | ElementPhaseStatusFilter(ElementId, ElementOnPhaseStatus, Boolean) | Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Public method | ElementPhaseStatusFilter(ElementId, ICollection<(Of <<'(ElementOnPhaseStatus>)>>), Boolean) | Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Members


ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)

[image]

Revit 2013 API
ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase status on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatus As ElementOnPhaseStatus _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatus
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus))

[image]

Revit 2013 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus) _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementOnPhaseStatus>)>)>
Target statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)

[image]

Revit 2013 API
ElementPhaseStatusFilter Constructor (ElementId, ElementOnPhaseStatus, Boolean)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatus As ElementOnPhaseStatus, _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ElementOnPhaseStatus phaseStatus,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatus
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
Target status.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus), Boolean)

[image]

Revit 2013 API
ElementPhaseStatusFilter Constructor (ElementId, ICollection<(Of <(<'ElementOnPhaseStatus>)>)>, Boolean)
ElementPhaseStatusFilter Class See Also Send Feedback
Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
    ElementId phaseId,
    ICollection<ElementOnPhaseStatus> phaseStatuses,
    bool inverted
)
Visual Basic
Public Sub New ( _
    phaseId As ElementId, _
    phaseStatuses As ICollection(Of ElementOnPhaseStatus), _
    inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
    ElementId^ phaseId,
    ICollection<ElementOnPhaseStatus>^ phaseStatuses,
    bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementOnPhaseStatus>)>)>
Target statuses.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Overload


ElementPhaseStatusFilter Methods

[image] [image]

Revit 2013 API
ElementPhaseStatusFilter Methods
ElementPhaseStatusFilter Class See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPhaseStatuses | Returns the phase statuses assigned to this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementPhaseStatusFilter Class


GetPhaseStatuses Method

[image]

Revit 2013 API
ElementPhaseStatusFilter..::..GetPhaseStatuses Method
ElementPhaseStatusFilter Class See Also Send Feedback
Returns the phase statuses assigned to this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementOnPhaseStatus> GetPhaseStatuses()
Visual Basic
Public Function GetPhaseStatuses As ICollection(Of ElementOnPhaseStatus)
Visual C++
public:
ICollection<ElementOnPhaseStatus>^ GetPhaseStatuses()

Return Value

The phase statuses.

See Also

ElementPhaseStatusFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementPhaseStatusFilter..::..PassesFilter Method
ElementPhaseStatusFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementPhaseStatusFilter Class
ElementPhaseStatusFilter Members


ElementPhaseStatusFilter Properties

[image] [image]

Revit 2013 API
ElementPhaseStatusFilter Properties
ElementPhaseStatusFilter Class See Also Send Feedback

The ElementPhaseStatusFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | PhaseId | The phase id.

See Also

ElementPhaseStatusFilter Class


PhaseId Property

[image]

Revit 2013 API
ElementPhaseStatusFilter..::..PhaseId Property
ElementPhaseStatusFilter Class See Also Send Feedback
The phase id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId PhaseId { get; }
Visual Basic
Public ReadOnly Property PhaseId As ElementId
    Get
Visual C++
public:
property ElementId^ PhaseId {
    ElementId^ get ();
}

See Also

ElementPhaseStatusFilter Class


ElementQuickFilter Class

[image]

Revit 2013 API
ElementQuickFilter Class
Members See Also Send Feedback
A base class for a type of filter that operates on element records.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementQuickFilter : ElementFilter
Visual Basic
Public Class ElementQuickFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementQuickFilter : public ElementFilter

Remarks

Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..BoundingBoxContainsPointFilter
Autodesk.Revit.DB..::..BoundingBoxIntersectsFilter
Autodesk.Revit.DB..::..BoundingBoxIsInsideFilter
Autodesk.Revit.DB..::..ElementCategoryFilter
Autodesk.Revit.DB..::..ElementClassFilter
Autodesk.Revit.DB..::..ElementDesignOptionFilter
Autodesk.Revit.DB..::..ElementIsCurveDrivenFilter
Autodesk.Revit.DB..::..ElementIsElementTypeFilter
Autodesk.Revit.DB..::..ElementMulticategoryFilter
Autodesk.Revit.DB..::..ElementMulticlassFilter
Autodesk.Revit.DB..::..ElementOwnerViewFilter
Autodesk.Revit.DB..::..ElementStructuralTypeFilter
Autodesk.Revit.DB..::..ElementWorksetFilter
Autodesk.Revit.DB..::..ExclusionFilter
Autodesk.Revit.DB..::..FamilySymbolFilter

See Also

ElementQuickFilter Members


ElementQuickFilter Members

[image] [image]

Revit 2013 API
ElementQuickFilter Members
ElementQuickFilter Class Methods Properties See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class


ElementQuickFilter Methods

[image] [image]

Revit 2013 API
ElementQuickFilter Methods
ElementQuickFilter Class See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementQuickFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementQuickFilter..::..PassesFilter Method
ElementQuickFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class
ElementQuickFilter Members


ElementQuickFilter Properties

[image] [image]

Revit 2013 API
ElementQuickFilter Properties
ElementQuickFilter Class See Also Send Feedback

The ElementQuickFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementQuickFilter Class


ElementRecord Class

[image]

Revit 2013 API
ElementRecord Class
Members See Also Send Feedback
A record in the Revit database representing an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementRecord : IDisposable
Visual Basic
Public Class ElementRecord _
    Implements IDisposable
Visual C++
public ref class ElementRecord : IDisposable

Remarks

The record is used to extract basic information about an element before the element is fully expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementRecord

See Also

ElementRecord Members


ElementRecord Members

[image] [image]

Revit 2013 API
ElementRecord Members
ElementRecord Class Methods Properties See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElementRecord
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | WorksetId | Get Id of the workset which owns the element.

See Also

ElementRecord Class


ElementRecord Methods

[image] [image]

Revit 2013 API
ElementRecord Methods
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingBox | Gets the bounding box of the element record.
Public method | GetCategoryId | Gets the category id of the element record.
Public method | GetDesignOptionId | Gets the design option id of the element record.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Gets the id of the element record.
Public method | GetOwnerViewId | Gets the element id of the owner view record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasBoundingBox | Determines whether this element record has a bounding box.
Public method | IsAnElementType | Identifies if the element record represents an ElementType.
Public method | IsCurveDriven | Identifies if the element is curve driven.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementRecord Class


Dispose Method

[image]

Revit 2013 API
ElementRecord..::..Dispose Method
ElementRecord Class See Also Send Feedback
Releases all resources used by the ElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElementRecord Class


GetBoundingBox Method

[image]

Revit 2013 API
ElementRecord..::..GetBoundingBox Method
ElementRecord Class See Also Send Feedback
Gets the bounding box of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Outline GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As Outline
Visual C++
public:
Outline^ GetBoundingBox()

Return Value

The bounding box outline. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no bounding box for this element.

See Also

ElementRecord Class


GetCategoryId Method

[image]

Revit 2013 API
ElementRecord..::..GetCategoryId Method
ElementRecord Class See Also Send Feedback
Gets the category id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCategoryId()
Visual Basic
Public Function GetCategoryId As ElementId
Visual C++
public:
ElementId^ GetCategoryId()

Return Value

The category id.

See Also

ElementRecord Class


GetDesignOptionId Method

[image]

Revit 2013 API
ElementRecord..::..GetDesignOptionId Method
ElementRecord Class See Also Send Feedback
Gets the design option id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetDesignOptionId()
Visual Basic
Public Function GetDesignOptionId As ElementId
Visual C++
public:
ElementId^ GetDesignOptionId()

Return Value

The design option id.

See Also

ElementRecord Class


GetId Method

[image]

Revit 2013 API
ElementRecord..::..GetId Method
ElementRecord Class See Also Send Feedback
Gets the id of the element record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetId()
Visual Basic
Public Function GetId As ElementId
Visual C++
public:
ElementId^ GetId()

Return Value

The element id.

See Also

ElementRecord Class


GetOwnerViewId Method

[image]

Revit 2013 API
ElementRecord..::..GetOwnerViewId Method
ElementRecord Class See Also Send Feedback
Gets the element id of the owner view record.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetOwnerViewId()
Visual Basic
Public Function GetOwnerViewId As ElementId
Visual C++
public:
ElementId^ GetOwnerViewId()

Return Value

The view record element id.

See Also

ElementRecord Class


HasBoundingBox Method

[image]

Revit 2013 API
ElementRecord..::..HasBoundingBox Method
ElementRecord Class See Also Send Feedback
Determines whether this element record has a bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasBoundingBox()
Visual Basic
Public Function HasBoundingBox As Boolean
Visual C++
public:
bool HasBoundingBox()

Return Value

True if the element record has a bounding box or false otherwise.

See Also

ElementRecord Class


IsAnElementType Method

[image]

Revit 2013 API
ElementRecord..::..IsAnElementType Method
ElementRecord Class See Also Send Feedback
Identifies if the element record represents an ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAnElementType()
Visual Basic
Public Function IsAnElementType As Boolean
Visual C++
public:
bool IsAnElementType()

Return Value

True if the element record represents an ElementType.

See Also

ElementRecord Class


IsCurveDriven Method

[image]

Revit 2013 API
ElementRecord..::..IsCurveDriven Method
ElementRecord Class See Also Send Feedback
Identifies if the element is curve driven.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsCurveDriven()
Visual Basic
Public Function IsCurveDriven As Boolean
Visual C++
public:
bool IsCurveDriven()

Return Value

True if the element is curve driven.

See Also

ElementRecord Class


ElementRecord Properties

[image] [image]

Revit 2013 API
ElementRecord Properties
ElementRecord Class See Also Send Feedback

The ElementRecord type exposes the following members.

Properties

 | Name | Description
Public property | WorksetId | Get Id of the workset which owns the element.

See Also

ElementRecord Class


WorksetId Property

[image]

Revit 2013 API
ElementRecord..::..WorksetId Property
ElementRecord Class See Also Send Feedback
Get Id of the workset which owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

Remarks

Each element belongs to one and only one workset.

See Also

ElementRecord Class


ElementReferenceType Enumeration

[image]

Revit 2013 API
ElementReferenceType Enumeration
See Also Send Feedback
Element reference types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ElementReferenceType
Visual Basic
Public Enumeration ElementReferenceType
Visual C++
public enum class ElementReferenceType

Members

Member name | Description
REFERENCE_TYPE_NONE | The reference is to an element.
REFERENCE_TYPE_LINEAR | The reference is to a curve or edge.
REFERENCE_TYPE_SURFACE | The reference is to a face or face region.
REFERENCE_TYPE_FOREIGN | The reference is to geometry or elements in linked Revit file.
REFERENCE_TYPE_INSTANCE | The reference is an instance of a symbol.
REFERENCE_TYPE_CUT_EDGE | The reference is to a face that was cut (where the original pick was made on the cut edge).
REFERENCE_TYPE_MESH | The reference is to a mesh.

See Also


ElementSet Class

[image]

Revit 2013 API
ElementSet Class
Members Example See Also Send Feedback
A set that contains element objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementSet : APIObject, IEnumerable
Visual Basic
Public Class ElementSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElementSet : public APIObject,
    IEnumerable

Examples

CopyC#
ElementSet elems = uidoc.Selection.Elements;

string info = "Selected elements:\n";
foreach (Autodesk.Revit.DB.Element elem in elems)
{
    info += elem.Name + "\n";
}

TaskDialog.Show("Revit",info);
CopyVB.NET
Dim elems As ElementSet = uidoc.Selection.Elements

Dim info As String = "Selected elements:" & vbLf
For Each elem As Autodesk.Revit.DB.Element In elems
    info += elem.Name + vbLf
Next

TaskDialog.Show("Revit", info)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.UI.Selection..::..SelElementSet

See Also

ElementSet Members


ElementSet Members

[image] [image]

Revit 2013 API
ElementSet Members
ElementSet Class Constructors Methods Properties See Also Send Feedback

The ElementSet type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSet | Initializes a new instance of the ElementSet class

Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet Class


ElementSet Constructor

[image]

Revit 2013 API
ElementSet Constructor
ElementSet Class See Also Send Feedback
Initializes a new instance of the ElementSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet()
Visual Basic
Public Sub New
Visual C++
public:
ElementSet()

See Also

ElementSet Class


ElementSet Methods

[image] [image]

Revit 2013 API
ElementSet Methods
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item element the set, rendering it empty.
Public method | Contains | Tests for the existence of an element within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified element from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSet Class


Clear Method

[image]

Revit 2013 API
ElementSet..::..Clear Method
ElementSet Class See Also Send Feedback
Removes every item element the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElementSet Class


Contains Method

[image]

Revit 2013 API
ElementSet..::..Contains Method
ElementSet Class See Also Send Feedback
Tests for the existence of an element within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Element item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be searched for.

Return Value

The Contains method returns True if the element is within the set, otherwise False.

See Also

ElementSet Class


Erase Method

[image]

Revit 2013 API
ElementSet..::..Erase Method
ElementSet Class See Also Send Feedback
Removes a specified element from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Element item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be erased.

Return Value

The number of elements that were erased from the set.

See Also

ElementSet Class


ForwardIterator Method

[image]

Revit 2013 API
ElementSet..::..ForwardIterator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElementSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElementSet Class


GetEnumerator Method

[image]

Revit 2013 API
ElementSet..::..GetEnumerator Method
ElementSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ElementSet Class


Insert Method

[image]

Revit 2013 API
ElementSet..::..Insert Method
ElementSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Element item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Element _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Element^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Element
The element to be inserted into the set.

Return Value

Returns whether the element was inserted into the set.

See Also

ElementSet Class


ReverseIterator Method

[image]

Revit 2013 API
ElementSet..::..ReverseIterator Method
ElementSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElementSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ElementSetIterator
Visual C++
public:
virtual ElementSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElementSet Class


ElementSet Properties

[image] [image]

Revit 2013 API
ElementSet Properties
ElementSet Class See Also Send Feedback

The ElementSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set.

See Also

ElementSet Class


IsEmpty Property

[image]

Revit 2013 API
ElementSet..::..IsEmpty Property
ElementSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElementSet Class


Size Property

[image]

Revit 2013 API
ElementSet..::..Size Property
ElementSet Class See Also Send Feedback
Returns the number of elements that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElementSet Class


ElementSetIterator Class

[image]

Revit 2013 API
ElementSetIterator Class
Members See Also Send Feedback
An iterator to an element set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ElementSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ElementSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElementSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSetIterator

See Also

ElementSetIterator Members


ElementSetIterator Members

[image] [image]

Revit 2013 API
ElementSetIterator Members
ElementSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElementSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ElementSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class


ElementSetIterator Constructor

[image]

Revit 2013 API
ElementSetIterator Constructor
ElementSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ElementSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElementSetIterator Class


ElementSetIterator Methods

[image] [image]

Revit 2013 API
ElementSetIterator Methods
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ElementSetIterator..::..MoveNext Method
ElementSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElementSetIterator Class


Reset Method

[image]

Revit 2013 API
ElementSetIterator..::..Reset Method
ElementSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElementSetIterator Class


ElementSetIterator Properties

[image] [image]

Revit 2013 API
ElementSetIterator Properties
ElementSetIterator Class See Also Send Feedback

The ElementSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElementSetIterator Class


Current Property

[image]

Revit 2013 API
ElementSetIterator..::..Current Property
ElementSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElementSetIterator Class


ElementSlowFilter Class

[image]

Revit 2013 API
ElementSlowFilter Class
Members See Also Send Feedback
A base class for a type of filter that operates on expanded elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementSlowFilter : ElementFilter
Visual Basic
Public Class ElementSlowFilter _
    Inherits ElementFilter
Visual C++
public ref class ElementSlowFilter : public ElementFilter

Remarks

Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple slow filters with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded in order to evaluate against the criteria set by this filter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Architecture..::..RoomFilter
Autodesk.Revit.DB.Architecture..::..RoomTagFilter
Autodesk.Revit.DB..::..AreaFilter
Autodesk.Revit.DB..::..AreaTagFilter
Autodesk.Revit.DB..::..CurveElementFilter
Autodesk.Revit.DB..::..ElementIntersectsFilter
Autodesk.Revit.DB..::..ElementLevelFilter
Autodesk.Revit.DB..::..ElementParameterFilter
Autodesk.Revit.DB..::..ElementPhaseStatusFilter
Autodesk.Revit.DB..::..FamilyInstanceFilter
Autodesk.Revit.DB.Mechanical..::..SpaceFilter
Autodesk.Revit.DB.Mechanical..::..SpaceTagFilter
Autodesk.Revit.DB..::..PrimaryDesignOptionMemberFilter
Autodesk.Revit.DB.Structure..::..FamilyStructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::..StructuralInstanceUsageFilter
Autodesk.Revit.DB.Structure..::..StructuralMaterialTypeFilter
Autodesk.Revit.DB.Structure..::..StructuralWallUsageFilter

See Also

ElementSlowFilter Members


ElementSlowFilter Members

[image] [image]

Revit 2013 API
ElementSlowFilter Members
ElementSlowFilter Class Methods Properties See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class


ElementSlowFilter Methods

[image] [image]

Revit 2013 API
ElementSlowFilter Methods
ElementSlowFilter Class See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementSlowFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementSlowFilter..::..PassesFilter Method
ElementSlowFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class
ElementSlowFilter Members


ElementSlowFilter Properties

[image] [image]

Revit 2013 API
ElementSlowFilter Properties
ElementSlowFilter Class See Also Send Feedback

The ElementSlowFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ElementSlowFilter Class


ElementStructuralTypeFilter Class

[image]

Revit 2013 API
ElementStructuralTypeFilter Class
Members See Also Send Feedback
A filter used to find elements matching a structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElementStructuralTypeFilter : ElementQuickFilter
Visual Basic
Public Class ElementStructuralTypeFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementStructuralTypeFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementStructuralTypeFilter

See Also

ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Members

[image] [image]

Revit 2013 API
ElementStructuralTypeFilter Members
ElementStructuralTypeFilter Class Constructors Methods Properties See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


ElementStructuralTypeFilter Constructor

[image] [image]

Revit 2013 API
ElementStructuralTypeFilter Constructor
ElementStructuralTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type.
Public method | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Constructor (StructuralType)

[image]

Revit 2013 API
ElementStructuralTypeFilter Constructor (StructuralType)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType
)
Visual Basic
Public Sub New ( _
    structuralType As StructuralType _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
The structural type to match.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Constructor (StructuralType, Boolean)

[image]

Revit 2013 API
ElementStructuralTypeFilter Constructor (StructuralType, Boolean)
ElementStructuralTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralType As StructuralType, _
    inverted As Boolean _
)
Visual C++
public:
ElementStructuralTypeFilter(
    StructuralType structuralType,
    bool inverted
)

Parameters

structuralType
Type: Autodesk.Revit.DB.Structure..::..StructuralType
The structural type to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not of the given structural type.

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Overload


ElementStructuralTypeFilter Methods

[image] [image]

Revit 2013 API
ElementStructuralTypeFilter Methods
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementStructuralTypeFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementStructuralTypeFilter..::..PassesFilter Method
ElementStructuralTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementStructuralTypeFilter Class
ElementStructuralTypeFilter Members


ElementStructuralTypeFilter Properties

[image] [image]

Revit 2013 API
ElementStructuralTypeFilter Properties
ElementStructuralTypeFilter Class See Also Send Feedback

The ElementStructuralTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralType | The structural type.

See Also

ElementStructuralTypeFilter Class


StructuralType Property

[image]

Revit 2013 API
ElementStructuralTypeFilter..::..StructuralType Property
ElementStructuralTypeFilter Class See Also Send Feedback
The structural type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic
Public ReadOnly Property StructuralType As StructuralType
    Get
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

See Also

ElementStructuralTypeFilter Class


ElementTransformUtils Class

[image]

Revit 2013 API
ElementTransformUtils Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementTransformUtils : IDisposable
Visual Basic
Public Class ElementTransformUtils _
    Implements IDisposable
Visual C++
public ref class ElementTransformUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementTransformUtils

See Also

ElementTransformUtils Members


ElementTransformUtils Members

[image] [image]

Revit 2013 API
ElementTransformUtils Members
ElementTransformUtils Class Methods See Also Send Feedback

The ElementTransformUtils type exposes the following members.

Methods

 | Name | Description
 | CanMirrorElement | Determines whether element can be mirrored.
 | CanMirrorElements | Determines whether elements can be mirrored.
 | CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
 | CopyElements | Copies a set of elements and places the copies at a location indicated by a given translation.
Public method | Dispose | Releases all resources used by the ElementTransformUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MirrorElement | Creates a mirrored copy of an element about a given plane.
 | MirrorElements | Creates a mirrored copy of a set of elements about a given plane.
 | MoveElement | Moves one element by a given transformation.
 | MoveElements | Moves a set of elements by a given transformation.
 | RotateElement | Rotates an element about the given axis and angle.
 | RotateElements | Rotates a set of elements about the given axis and angle.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementTransformUtils Class


ElementTransformUtils Methods

[image] [image]

Revit 2013 API
ElementTransformUtils Methods
ElementTransformUtils Class See Also Send Feedback

The ElementTransformUtils type exposes the following members.

Methods

 | Name | Description
 | CanMirrorElement | Determines whether element can be mirrored.
 | CanMirrorElements | Determines whether elements can be mirrored.
 | CopyElement | Copies an element and places the copy at a location indicated by a given transformation.
 | CopyElements | Copies a set of elements and places the copies at a location indicated by a given translation.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MirrorElement | Creates a mirrored copy of an element about a given plane.
 | MirrorElements | Creates a mirrored copy of a set of elements about a given plane.
 | MoveElement | Moves one element by a given transformation.
 | MoveElements | Moves a set of elements by a given transformation.
 | RotateElement | Rotates an element about the given axis and angle.
 | RotateElements | Rotates a set of elements about the given axis and angle.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementTransformUtils Class


CanMirrorElement Method

[image]

Revit 2013 API
ElementTransformUtils..::..CanMirrorElement Method
ElementTransformUtils Class See Also Send Feedback
Determines whether element can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanMirrorElement(
    Document ADoc,
    ElementId elemId
)
Visual Basic
Public Shared Function CanMirrorElement ( _
    ADoc As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool CanMirrorElement(
    Document^ ADoc,
    ElementId^ elemId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element reside.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element identified by id.

Return Value

True if the element can be mirrored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


CanMirrorElements Method

[image]

Revit 2013 API
ElementTransformUtils..::..CanMirrorElements Method
ElementTransformUtils Class See Also Send Feedback
Determines whether elements can be mirrored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanMirrorElements(
    Document ADoc,
    ICollection<ElementId> elemIds
)
Visual Basic
Public Shared Function CanMirrorElements ( _
    ADoc As Document, _
    elemIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanMirrorElements(
    Document^ ADoc,
    ICollection<ElementId^>^ elemIds
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the elements reside.
elemIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements identified by id.

Return Value

True if the elements can be mirrored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


CopyElement Method

[image]

Revit 2013 API
ElementTransformUtils..::..CopyElement Method
ElementTransformUtils Class See Also Send Feedback
Copies an element and places the copy at a location indicated by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> CopyElement(
    Document document,
    ElementId elementToCopy,
    XYZ translation
)
Visual Basic
Public Shared Function CopyElement ( _
    document As Document, _
    elementToCopy As ElementId, _
    translation As XYZ _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElement(
    Document^ document,
    ElementId^ elementToCopy,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the element.
elementToCopy
Type: Autodesk.Revit.DB..::..ElementId
The id of the element to copy.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the new element.

Return Value

The ids of the newly created copied elements. More than one element may be created due to dependencies.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementToCopy does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


CopyElements Method

[image]

Revit 2013 API
ElementTransformUtils..::..CopyElements Method
ElementTransformUtils Class See Also Send Feedback
Copies a set of elements and places the copies at a location indicated by a given translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> CopyElements(
    Document document,
    ICollection<ElementId> elementsToCopy,
    XYZ translation
)
Visual Basic
Public Shared Function CopyElements ( _
    document As Document, _
    elementsToCopy As ICollection(Of ElementId), _
    translation As XYZ _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ CopyElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToCopy,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToCopy
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to copy.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the new elements.

Return Value

The ids of the newly created copied elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elementsToCopy is empty. -or- One or more elements in elementsToCopy do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


Dispose Method

[image]

Revit 2013 API
ElementTransformUtils..::..Dispose Method
ElementTransformUtils Class See Also Send Feedback
Releases all resources used by the ElementTransformUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElementTransformUtils Class


MirrorElement Method

[image]

Revit 2013 API
ElementTransformUtils..::..MirrorElement Method
ElementTransformUtils Class Example See Also Send Feedback
Creates a mirrored copy of an element about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MirrorElement(
    Document document,
    ElementId elementToMirror,
    Plane plane
)
Visual Basic
Public Shared Sub MirrorElement ( _
    document As Document, _
    elementToMirror As ElementId, _
    plane As Plane _
)
Visual C++
public:
static void MirrorElement(
    Document^ document,
    ElementId^ elementToMirror,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the element.
elementToMirror
Type: Autodesk.Revit.DB..::..ElementId
The element to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.

Examples

CopyC#
public void MirrorWall(Autodesk.Revit.DB.Document document, Wall wall)
{
    Reference reference = HostObjectUtils.GetSideFaces(wall, ShellLayerType.Exterior).First();
    Face face = wall.GetGeometryObjectFromReference(reference) as Face; // get one of the wall's major side faces

    UV bboxMin = face.GetBoundingBox().Min;
    Plane plane = new Plane(face.ComputeNormal(bboxMin), face.Evaluate(bboxMin).Add(new XYZ(10, 10, 0)));
    // create a plane based on this side face with an offset of 10 in the X & Y directions

    ElementTransformUtils.MirrorElement(document, wall.Id, plane);
}
CopyVB.NET
Public Sub MirrorColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim uidoc As New UIDocument(document)
    Dim analytical As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(column.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
    Dim lineReference As Reference = analytical.GetCurve().Reference
    document.Mirror(column, lineReference)

    'The selected element is changed after the Mirror operation.
    For Each newColumn As Autodesk.Revit.DB.FamilyInstance In uidoc.Selection.Elements
        Dim isMirror As Boolean = newColumn.Mirrored

        TaskDialog.Show("Revit", "Column is mirrored: " + isMirror)

        'Offset the new column
        Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 30)
        newColumn.Location.Move(translationVec)
    Next
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementToMirror cannot be mirrored. -or- The element elementToMirror does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


MirrorElements Method

[image]

Revit 2013 API
ElementTransformUtils..::..MirrorElements Method
ElementTransformUtils Class See Also Send Feedback
Creates a mirrored copy of a set of elements about a given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MirrorElements(
    Document document,
    ICollection<ElementId> elementsToMirror,
    Plane plane
)
Visual Basic
Public Shared Sub MirrorElements ( _
    document As Document, _
    elementsToMirror As ICollection(Of ElementId), _
    plane As Plane _
)
Visual C++
public:
static void MirrorElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMirror,
    Plane^ plane
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToMirror
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to mirror.
plane
Type: Autodesk.Revit.DB..::..Plane
The mirror plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementsToMirror cannot be mirrored. -or- The elementsToMirror is empty. -or- One or more elements in elementsToMirror do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


MoveElement Method

[image]

Revit 2013 API
ElementTransformUtils..::..MoveElement Method
ElementTransformUtils Class Example See Also Send Feedback
Moves one element by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MoveElement(
    Document document,
    ElementId elementToMove,
    XYZ translation
)
Visual Basic
Public Shared Sub MoveElement ( _
    document As Document, _
    elementToMove As ElementId, _
    translation As XYZ _
)
Visual C++
public:
static void MoveElement(
    Document^ document,
    ElementId^ elementToMove,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementToMove
Type: Autodesk.Revit.DB..::..ElementId
The id of the element to move.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the elements.

Examples

CopyC#
public void MoveColumn(Autodesk.Revit.DB.Document document, FamilyInstance column)
{
    // get the column current location
    LocationPoint columnLocation = column.Location as LocationPoint;

    XYZ oldPlace = columnLocation.Point;

    // Move the column to new location.
    XYZ newPlace = new XYZ(10, 20, 30);
    ElementTransformUtils.MoveElement(document, column.Id, newPlace);

    // now get the column's new location
    columnLocation = column.Location as LocationPoint;
    XYZ newActual = columnLocation.Point;

    string info = "Original Z location: " + oldPlace.Z +
                  "\nNew Z location: " + newActual.Z;

    TaskDialog.Show("Revit",info);
}
CopyVB.NET
Public Sub MoveColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance)
    ' get the column current location
    Dim columnLocation As LocationPoint = TryCast(column.Location, LocationPoint)

    Dim oldPlace As Autodesk.Revit.DB.XYZ = columnLocation.Point

    ' Move the column to new location.
    Dim newPlace As New Autodesk.Revit.DB.XYZ(10, 20, 30)
    document.Move(column, newPlace)

    ' now get the column's new location
    columnLocation = TryCast(column.Location, LocationPoint)
    Dim newActual As Autodesk.Revit.DB.XYZ = columnLocation.Point

    Dim info As String = "Original Z location: " + oldPlace.Z + vbLf & "New Z location: " + newActual.Z

    TaskDialog.Show("Revit", info)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementToMove does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


MoveElements Method

[image]

Revit 2013 API
ElementTransformUtils..::..MoveElements Method
ElementTransformUtils Class See Also Send Feedback
Moves a set of elements by a given transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void MoveElements(
    Document document,
    ICollection<ElementId> elementsToMove,
    XYZ translation
)
Visual Basic
Public Shared Sub MoveElements ( _
    document As Document, _
    elementsToMove As ICollection(Of ElementId), _
    translation As XYZ _
)
Visual C++
public:
static void MoveElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToMove,
    XYZ^ translation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToMove
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to move.
translation
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elementsToMove is empty. -or- One or more elements in elementsToMove do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


RotateElement Method

[image]

Revit 2013 API
ElementTransformUtils..::..RotateElement Method
ElementTransformUtils Class Example See Also Send Feedback
Rotates an element about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RotateElement(
    Document document,
    ElementId elementToRotate,
    Line axis,
    double angle
)
Visual Basic
Public Shared Sub RotateElement ( _
    document As Document, _
    elementToRotate As ElementId, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
static void RotateElement(
    Document^ document,
    ElementId^ elementToRotate,
    Line^ axis,
    double angle
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementToRotate
Type: Autodesk.Revit.DB..::..ElementId
The element to rotate.
axis
Type: Autodesk.Revit.DB..::..Line
The axis of rotation.
angle
Type: System..::..Double
The angle of rotation in radians.

Examples

CopyC#
public void RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
    XYZ point1 = new XYZ(10, 20, 0);
    XYZ point2 = new XYZ(10, 20, 30);
    // The axis should be a bound line.
    Line axis = document.Application.Create.NewLineBound(point1, point2);
    ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0);
}
CopyVB.NET
Public Function RotateColumn(ByVal document As Autodesk.Revit.DB.Document, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim point1 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Dim point2 As New Autodesk.Revit.DB.XYZ(10, 20, 30)
    ' The axis should be a bound line.
    Dim axis As Line = document.Application.Create.NewLineBound(point1, point2)
    Dim successful As Boolean = document.Rotate(element, axis, Math.PI / 3)

    Return successful
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementToRotate does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


RotateElements Method

[image]

Revit 2013 API
ElementTransformUtils..::..RotateElements Method
ElementTransformUtils Class See Also Send Feedback
Rotates a set of elements about the given axis and angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RotateElements(
    Document document,
    ICollection<ElementId> elementsToRotate,
    Line axis,
    double angle
)
Visual Basic
Public Shared Sub RotateElements ( _
    document As Document, _
    elementsToRotate As ICollection(Of ElementId), _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
static void RotateElements(
    Document^ document,
    ICollection<ElementId^>^ elementsToRotate,
    Line^ axis,
    double angle
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements.
elementsToRotate
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to rotate.
axis
Type: Autodesk.Revit.DB..::..Line
The axis of rotation.
angle
Type: System..::..Double
The angle of rotation in radians.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elementsToRotate is empty. -or- One or more elements in elementsToRotate do not exist in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementTransformUtils Class


ElementType Class

[image]

Revit 2013 API
ElementType Class
Members See Also Send Feedback
Base class for all Types within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElementType : Element
Visual Basic
Public Class ElementType _
    Inherits Element
Visual C++
public ref class ElementType : public Element

Remarks

Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Analysis..::..ConceptualConstructionType
Autodesk.Revit.DB.Architecture..::..ContinuousRailType
Autodesk.Revit.DB.Architecture..::..CutMarkType
Autodesk.Revit.DB.Architecture..::..RailingType
Autodesk.Revit.DB.Architecture..::..StairsLandingType
Autodesk.Revit.DB.Architecture..::..StairsPathType
Autodesk.Revit.DB.Architecture..::..StairsRunType
Autodesk.Revit.DB.Architecture..::..StairsType
Autodesk.Revit.DB..::..AssemblyType
Autodesk.Revit.DB..::..BeamSystemType
Autodesk.Revit.DB..::..CADLinkType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB.Electrical..::..DistributionSysType
Autodesk.Revit.DB.Electrical..::..InsulationType
Autodesk.Revit.DB.Electrical..::..TemperatureRatingType
Autodesk.Revit.DB.Electrical..::..VoltageType
Autodesk.Revit.DB.Electrical..::..WireMaterialType
Autodesk.Revit.DB.Electrical..::..WireType
Autodesk.Revit.DB..::..GroupType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB.Mechanical..::..DuctInsulationType
Autodesk.Revit.DB.Mechanical..::..DuctLiningType
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB..::..ModelTextType
Autodesk.Revit.DB.Plumbing..::..FluidType
Autodesk.Revit.DB.Plumbing..::..PipeConnectionType
Autodesk.Revit.DB.Plumbing..::..PipeInsulationType
Autodesk.Revit.DB.Plumbing..::..PipeMaterialType
Autodesk.Revit.DB.Plumbing..::..PipeScheduleType
Autodesk.Revit.DB..::..PointCloudType
Autodesk.Revit.DB..::..RevitLinkType
Autodesk.Revit.DB..::..SiteLocation
Autodesk.Revit.DB.Structure..::..AnalyticalLinkType
Autodesk.Revit.DB.Structure..::..AreaReinforcementType
Autodesk.Revit.DB.Structure..::..FabricAreaType
Autodesk.Revit.DB.Structure..::..FabricSheetType
Autodesk.Revit.DB.Structure..::..FabricWireType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..PathReinforcementType
Autodesk.Revit.DB.Structure..::..RebarBarType
Autodesk.Revit.DB.Structure..::..RebarCoverType
Autodesk.Revit.DB.Structure..::..RebarHookType
Autodesk.Revit.DB.Structure..::..RebarShape
Autodesk.Revit.DB.Structure..::..StructuralConnectionType
Autodesk.Revit.DB..::..TilePattern
Autodesk.Revit.DB..::..ViewFamilyType

See Also

ElementType Members


ElementType Members

[image] [image]

Revit 2013 API
ElementType Members
ElementType Class Methods Properties See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElementType Class


ElementType Methods

[image] [image]

Revit 2013 API
ElementType Methods
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementType Class


Duplicate Method

[image]

Revit 2013 API
ElementType..::..Duplicate Method
ElementType Class See Also Send Feedback
Duplicate this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementType Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ElementType
Visual C++
public:
ElementType^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The new name that will be assigned to the duplicated object.

Return Value

If successful the duplicated object is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

This method attempts to duplicate the object and assign it the specified name. In some cases the name must be unique, i.e. not already exist in the project. If the name is required to be unique and the name is not unique, a System.ArgumentException will be thrown. If for some reason the object cannot be duplicated a ApplicationException will be thrown.

See Also

ElementType Class


GetPreviewImage Method

[image]

Revit 2013 API
ElementType..::..GetPreviewImage Method
ElementType Class See Also Send Feedback
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual Bitmap GetPreviewImage(
    Size size
)
Visual Basic
Public Overridable Function GetPreviewImage ( _
    size As Size _
) As Bitmap
Visual C++
public:
virtual Bitmap^ GetPreviewImage(
    Size size
)

Parameters

size
Type: System.Drawing..::..Size
The width and height of the preview image in pixels.

Return Value

System::Drawing::Bitmap represents the preview image. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no preview image.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The width or height of the size is equal or less than zero.

See Also

ElementType Class


GetSimilarTypes Method

[image]

Revit 2013 API
ElementType..::..GetSimilarTypes Method
ElementType Class See Also Send Feedback
Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetSimilarTypes()
Visual Basic
Public Function GetSimilarTypes As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSimilarTypes()

Return Value

A set of element IDs of types that are similar to this type.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

See Also

ElementType Class


IsSimilarType Method

[image]

Revit 2013 API
ElementType..::..IsSimilarType Method
ElementType Class See Also Send Feedback
Checks if given type is similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSimilarType(
    ElementId typeId
)
Visual Basic
Public Function IsSimilarType ( _
    typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsSimilarType(
    ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the type to check.

Return Value

True if given type is similar to this type, false otherwise.

Remarks

Two types are similar if elements that have one type could be assigned the other type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementType Class


ElementType Properties

[image] [image]

Revit 2013 API
ElementType Properties
ElementType Class See Also Send Feedback

The ElementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElementType Class


Name Property

[image]

Revit 2013 API
ElementType..::..Name Property
ElementType Class See Also Send Feedback
Set the name for the ElementType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This method will assign the element type a new name.

See Also

ElementType Class


Parameter Property

[image] [image]

Revit 2013 API
ElementType..::..Parameter Property
ElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElementType Class
ElementType Members


ElementWorksetFilter Class

[image]

Revit 2013 API
ElementWorksetFilter Class
Members Example See Also Send Feedback
A filter used to match elements which reside in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ElementWorksetFilter : ElementQuickFilter
Visual Basic
Public Class ElementWorksetFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ElementWorksetFilter : public ElementQuickFilter

Remarks

This filter is a quick filter.

Examples

CopyC#
public void WorksetElements(Document doc, Workset workset)
{
    // filter all elements that belong to the given workset
    FilteredElementCollector elementCollector = new FilteredElementCollector(doc);
    ElementWorksetFilter elementWorksetFilter = new ElementWorksetFilter(workset.Id, false);
    ICollection<Element> worksetElemsfounds = elementCollector.WherePasses(elementWorksetFilter).ToElements();

    // how many elements were found?
    int elementsCount = worksetElemsfounds.Count;
    String message = "Element count : " + elementsCount;

    // Get name and/or Id of the elements that pass the given filter and show a few of them
    int count = 5;  // show info for 5 elements only
    foreach (Element ele in worksetElemsfounds)
    {
        if (null != ele)
        {
           message += "\nElementId : " + ele.Id;
           message += ", Element Name : " + ele.Name;

          if (0 == --count)
              break;
        }
    }

    Autodesk.Revit.UI.TaskDialog.Show("ElementsOfWorkset", message);
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ElementWorksetFilter

See Also

ElementWorksetFilter Members


ElementWorksetFilter Members

[image] [image]

Revit 2013 API
ElementWorksetFilter Members
ElementWorksetFilter Class Constructors Methods Properties See Also Send Feedback

The ElementWorksetFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | WorksetId | The workset id.

See Also

ElementWorksetFilter Class


ElementWorksetFilter Constructor

[image] [image]

Revit 2013 API
ElementWorksetFilter Constructor
ElementWorksetFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElementWorksetFilter(WorksetId) | Constructs a new instance of a filter to match elements in a given workset.
Public method | ElementWorksetFilter(WorksetId, Boolean) | Constructs a new instance of a filter to match elements in a given workset.

See Also

ElementWorksetFilter Class
ElementWorksetFilter Members


ElementWorksetFilter Constructor (WorksetId)

[image]

Revit 2013 API
ElementWorksetFilter Constructor (WorksetId)
ElementWorksetFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementWorksetFilter(
    WorksetId worksetId
)
Visual Basic
Public Sub New ( _
    worksetId As WorksetId _
)
Visual C++
public:
ElementWorksetFilter(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id to match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter Constructor (WorksetId, Boolean)

[image]

Revit 2013 API
ElementWorksetFilter Constructor (WorksetId, Boolean)
ElementWorksetFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements in a given workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementWorksetFilter(
    WorksetId worksetId,
    bool inverted
)
Visual Basic
Public Sub New ( _
    worksetId As WorksetId, _
    inverted As Boolean _
)
Visual C++
public:
ElementWorksetFilter(
    WorksetId^ worksetId,
    bool inverted
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id to match.
inverted
Type: System..::..Boolean
True if the filter should match all elements which are not in the given workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElementWorksetFilter Class
ElementWorksetFilter Overload


ElementWorksetFilter Methods

[image] [image]

Revit 2013 API
ElementWorksetFilter Methods
ElementWorksetFilter Class See Also Send Feedback

The ElementWorksetFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementWorksetFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ElementWorksetFilter..::..PassesFilter Method
ElementWorksetFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ElementWorksetFilter Class
ElementWorksetFilter Members


ElementWorksetFilter Properties

[image] [image]

Revit 2013 API
ElementWorksetFilter Properties
ElementWorksetFilter Class See Also Send Feedback

The ElementWorksetFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | WorksetId | The workset id.

See Also

ElementWorksetFilter Class


WorksetId Property

[image]

Revit 2013 API
ElementWorksetFilter..::..WorksetId Property
ElementWorksetFilter Class See Also Send Feedback
The workset id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId WorksetId { get; }
Visual Basic
Public ReadOnly Property WorksetId As WorksetId
    Get
Visual C++
public:
property WorksetId^ WorksetId {
    WorksetId^ get ();
}

See Also

ElementWorksetFilter Class


ElevationMarker Class

[image]

Revit 2013 API
ElevationMarker Class
Members See Also Send Feedback
ElevationMarkers either host elevation ViewSection views or view references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ElevationMarker : Element
Visual Basic
Public Class ElevationMarker _
    Inherits Element
Visual C++
public ref class ElevationMarker : public Element

Remarks

ElevationMarkers store the ViewFamilyType which will be used by all elevations hosted on the ElevationMarker. The orientation of an ElevationMarker is determined by the orientation of the views it hosts. You can check the orientation of any view by getting View.ViewDirection. To reorient the ElevationMarker and all of the views it hosts, call ElementTransformUtils.RotateElement with the ElevationMarker as an argument.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElevationMarker

See Also

ElevationMarker Members


ElevationMarker Members

[image] [image]

Revit 2013 API
ElevationMarker Members
ElevationMarker Class Methods Properties See Also Send Feedback

The ElevationMarker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElevationMarker Class


ElevationMarker Methods

[image] [image]

Revit 2013 API
ElevationMarker Methods
ElevationMarker Class See Also Send Feedback

The ElevationMarker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CreateElevation | Creates a new elevation ViewSection on the ElevationMarker at the desired index.
 | CreateElevationMarker | Creates a new ElevationMarker.
Public method | CreateReferenceElevation | Creates a reference elevation on the ElevationMarker at the desired index.
 | CreateReferenceElevationMarker | Creates a new ElevationMarker.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewId | Returns the ViewSection id for the index of the ElevationMarker.
Public method | HasElevations | Returns true if the ElevationMarker has at least one elevation view, false otherwise.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAvailableIndex | Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElevationMarker Class


CreateElevation Method

[image]

Revit 2013 API
ElevationMarker..::..CreateElevation Method
ElevationMarker Class See Also Send Feedback
Creates a new elevation ViewSection on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewSection CreateElevation(
    Document document,
    ElementId viewPlanId,
    int index
)
Visual Basic
Public Function CreateElevation ( _
    document As Document, _
    viewPlanId As ElementId, _
    index As Integer _
) As ViewSection
Visual C++
public:
ViewSection^ CreateElevation(
    Document^ document,
    ElementId^ viewPlanId,
    int index
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new elevation ViewSection will be added.
viewPlanId
Type: Autodesk.Revit.DB..::..ElementId
The id of a ViewPlan in which the ElevationMarker is visible. The new elevation ViewSection will derive its extents and inherit settings from the ViewPlan.
index
Type: System..::..Int32
The index on the ElevationMarker where the new elevation ViewSection will be placed. The index on the ElevationMarker must be valid and unused. View direction is determined by the index.

Return Value

The new elevation ViewSection.

Remarks

The ViewFamilyType for the new elevation ViewSection is inherited from the ElevationMarker. The new elevation ViewSection will receive a unique view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ElevationMarker Class


CreateElevationMarker Method

[image]

Revit 2013 API
ElevationMarker..::..CreateElevationMarker Method
ElevationMarker Class See Also Send Feedback
Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ElevationMarker CreateElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    int initialViewScale
)
Visual Basic
Public Shared Function CreateElevationMarker ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    origin As XYZ, _
    initialViewScale As Integer _
) As ElevationMarker
Visual C++
public:
static ElevationMarker^ CreateElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    int initialViewScale
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin
Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
initialViewScale
Type: System..::..Int32
This view scale will be automatically applied to new elevations created on the ElevationMarker. The scale is the ratio of true model size to paper size.

Return Value

The new ElevationMarker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view family type is not appropriate for ElevationMarkers. -or- The denominator X of the view scale 1/X must be in the range 1 to 24,000. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElevationMarker Class


CreateReferenceElevation Method

[image]

Revit 2013 API
ElevationMarker..::..CreateReferenceElevation Method
ElevationMarker Class See Also Send Feedback
Creates a reference elevation on the ElevationMarker at the desired index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void CreateReferenceElevation(
    Document document,
    int index,
    ElementId viewIdToReference
)
Visual Basic
Public Sub CreateReferenceElevation ( _
    document As Document, _
    index As Integer, _
    viewIdToReference As ElementId _
)
Visual C++
public:
void CreateReferenceElevation(
    Document^ document,
    int index,
    ElementId^ viewIdToReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new reference elevation will be added.
index
Type: System..::..Int32
The index on the ElevationMarker where the reference elevation will be placed.
viewIdToReference
Type: Autodesk.Revit.DB..::..ElementId
The view which will be referenced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- This view cannot be referenced by elevations. -or- index is occupied or out of range. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Only reference elevations can be hosted on this ElevationMarker.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ElevationMarker Class


CreateReferenceElevationMarker Method

[image]

Revit 2013 API
ElevationMarker..::..CreateReferenceElevationMarker Method
ElevationMarker Class See Also Send Feedback
Creates a new ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ElevationMarker CreateReferenceElevationMarker(
    Document document,
    ElementId viewFamilyTypeId,
    XYZ origin,
    ElementId viewPlanId
)
Visual Basic
Public Shared Function CreateReferenceElevationMarker ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    origin As XYZ, _
    viewPlanId As ElementId _
) As ElevationMarker
Visual C++
public:
static ElevationMarker^ CreateReferenceElevationMarker(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    XYZ^ origin,
    ElementId^ viewPlanId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new ElevationMarker will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
This ViewFamilyType will be used by all elevations hosted on the new ElevationMarker.
origin
Type: Autodesk.Revit.DB..::..XYZ
The desired origin for the ElevationMarker.
viewPlanId
Type: Autodesk.Revit.DB..::..ElementId
The ViewPlan in which the reference ElevationMarker will appear. Reference ElevationMarkers only appear in one view.

Return Value

The new ElevationMarker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewPlanId does not correspond to a ViewPlan. -or- This view family type is not appropriate for ElevationMarkers. -or- Elevation view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElevationMarker Class


GetViewId Method

[image]

Revit 2013 API
ElevationMarker..::..GetViewId Method
ElevationMarker Class See Also Send Feedback
Returns the ViewSection id for the index of the ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetViewId(
    int index
)
Visual Basic
Public Function GetViewId ( _
    index As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetViewId(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the ElevationMarker for which a ViewSection id will be returned.

Return Value

ViewSection id of the view at the ElevationMarker index, invalid element id otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index index is out of range for this ElevationMarker.

See Also

ElevationMarker Class


HasElevations Method

[image]

Revit 2013 API
ElevationMarker..::..HasElevations Method
ElevationMarker Class See Also Send Feedback
Returns true if the ElevationMarker has at least one elevation view, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasElevations()
Visual Basic
Public Function HasElevations As Boolean
Visual C++
public:
bool HasElevations()

Return Value

True if the ElevationMarker has at least one elevation view, false otherwise.

See Also

ElevationMarker Class


IsAvailableIndex Method

[image]

Revit 2013 API
ElevationMarker..::..IsAvailableIndex Method
ElevationMarker Class See Also Send Feedback
Returns true if a new elevation ViewSection can be placed at %index%, returns false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsAvailableIndex(
    int index
)
Visual Basic
Public Function IsAvailableIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsAvailableIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the ElevationMarker which will be checked.

Return Value

True if an elevation can be created at %index%, false otherwise.

Remarks

False will be returned if the %index% is already occupied or if %index% is out of range for the ElevationMarker.

See Also

ElevationMarker Class


ElevationMarker Properties

[image] [image]

Revit 2013 API
ElevationMarker Properties
ElevationMarker Class See Also Send Feedback

The ElevationMarker type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentViewCount | The current number of views hosted by this ElevationMarker.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReference | Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumViewCount | The maximum number of views that can be hosted by this ElevationMarker.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElevationMarker Class


CurrentViewCount Property

[image]

Revit 2013 API
ElevationMarker..::..CurrentViewCount Property
ElevationMarker Class See Also Send Feedback
The current number of views hosted by this ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int CurrentViewCount { get; }
Visual Basic
Public ReadOnly Property CurrentViewCount As Integer
    Get
Visual C++
public:
property int CurrentViewCount {
    int get ();
}

See Also

ElevationMarker Class


IsReference Property

[image]

Revit 2013 API
ElevationMarker..::..IsReference Property
ElevationMarker Class See Also Send Feedback
Indicates if this is a reference ElevationMarker. Only reference elevations can be hosted by reference ElevationMarkers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsReference { get; }
Visual Basic
Public ReadOnly Property IsReference As Boolean
    Get
Visual C++
public:
property bool IsReference {
    bool get ();
}

See Also

ElevationMarker Class


MaximumViewCount Property

[image]

Revit 2013 API
ElevationMarker..::..MaximumViewCount Property
ElevationMarker Class See Also Send Feedback
The maximum number of views that can be hosted by this ElevationMarker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MaximumViewCount { get; }
Visual Basic
Public ReadOnly Property MaximumViewCount As Integer
    Get
Visual C++
public:
property int MaximumViewCount {
    int get ();
}

See Also

ElevationMarker Class


Parameter Property

[image] [image]

Revit 2013 API
ElevationMarker..::..Parameter Property
ElevationMarker Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElevationMarker Class
ElevationMarker Members


Ellipse Class

[image]

Revit 2013 API
Ellipse Class
Members See Also Send Feedback
A whole or partial ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Ellipse : Curve
Visual Basic
Public Class Ellipse _
    Inherits Curve
Visual C++
public ref class Ellipse : public Curve

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Ellipse

See Also

Ellipse Members


Ellipse Members

[image] [image]

Revit 2013 API
Ellipse Members
Ellipse Class Methods Properties See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class


Ellipse Methods

[image] [image]

Revit 2013 API
Ellipse Methods
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ellipse Class


Intersect Method

[image] [image]

Revit 2013 API
Ellipse..::..Intersect Method
Ellipse Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members


IsInside Method

[image] [image]

Revit 2013 API
Ellipse..::..IsInside Method
Ellipse Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Ellipse Class
Ellipse Members


Ellipse Properties

[image] [image]

Revit 2013 API
Ellipse Properties
Ellipse Class See Also Send Feedback

The Ellipse type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | Center | Returns the center of the ellipse.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Normal | Returns the normal to the plane in which the ellipse is defined.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | RadiusX | Returns the X vector radius of the ellipse.
Public property | RadiusY | Returns the Y vector radius of the ellipse.
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | XDirection | The X direction.
Public property | YDirection | The Y direction.

See Also

Ellipse Class


Center Property

[image]

Revit 2013 API
Ellipse..::..Center Property
Ellipse Class See Also Send Feedback
Returns the center of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Center { get; }
Visual Basic
Public ReadOnly Property Center As XYZ
    Get
Visual C++
public:
property XYZ^ Center {
    XYZ^ get ();
}

See Also

Ellipse Class


Normal Property

[image]

Revit 2013 API
Ellipse..::..Normal Property
Ellipse Class See Also Send Feedback
Returns the normal to the plane in which the ellipse is defined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Ellipse Class


RadiusX Property

[image]

Revit 2013 API
Ellipse..::..RadiusX Property
Ellipse Class See Also Send Feedback
Returns the X vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double RadiusX { get; }
Visual Basic
Public ReadOnly Property RadiusX As Double
    Get
Visual C++
public:
property double RadiusX {
    double get ();
}

See Also

Ellipse Class


RadiusY Property

[image]

Revit 2013 API
Ellipse..::..RadiusY Property
Ellipse Class See Also Send Feedback
Returns the Y vector radius of the ellipse.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double RadiusY { get; }
Visual Basic
Public ReadOnly Property RadiusY As Double
    Get
Visual C++
public:
property double RadiusY {
    double get ();
}

See Also

Ellipse Class


XDirection Property

[image]

Revit 2013 API
Ellipse..::..XDirection Property
Ellipse Class See Also Send Feedback
The X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ XDirection { get; }
Visual Basic
Public ReadOnly Property XDirection As XYZ
    Get
Visual C++
public:
property XYZ^ XDirection {
    XYZ^ get ();
}

See Also

Ellipse Class


YDirection Property

[image]

Revit 2013 API
Ellipse..::..YDirection Property
Ellipse Class See Also Send Feedback
The Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ YDirection { get; }
Visual Basic
Public ReadOnly Property YDirection As XYZ
    Get
Visual C++
public:
property XYZ^ YDirection {
    XYZ^ get ();
}

See Also

Ellipse Class


EndCapCondition Enumeration

[image]

Revit 2013 API
EndCapCondition Enumeration
See Also Send Feedback
Used by CompoundStructure to describe which shell layers participate in end wrapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum EndCapCondition
Visual Basic
Public Enumeration EndCapCondition
Visual C++
public enum class EndCapCondition

Members

Member name | Description
None | None of the shell layers participate in end wrapping.
Exterior | Only the exterior shell layers participate in end wrapping.
Interior | Only the interior shell layers participate in end wrapping.
NoEndCap | No end wrapping ability. Floors and roofs must use this enum value.

See Also


ExclusionFilter Class

[image]

Revit 2013 API
ExclusionFilter Class
Members Example See Also Send Feedback
A filter used to exclude a set of elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ExclusionFilter : ElementQuickFilter
Visual Basic
Public Class ExclusionFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class ExclusionFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Examples

CopyC#
// Use Exclusion filter to find exclude a set of elements in the document automatically

// Find all walls that are not currently selected,
// Get all element ids which are current selected by users, exclude these ids when filtering
ICollection<ElementId> excludes = new List<ElementId>();
ElementSetIterator elemIter = uiDocument.Selection.Elements.ForwardIterator();
elemIter.Reset();
while (elemIter.MoveNext())
{
    Element curElem = elemIter.Current as Element;
    excludes.Add(curElem.Id);
}

// Create filter to exclude all selected element ids
ExclusionFilter filter = new ExclusionFilter(excludes);

// Apply the filter to the elements in the active document,
// Use shortcut method OfClass() to find Walls only
FilteredElementCollector collector = new FilteredElementCollector(uiDocument.Document);
IList<Element> walls = collector.WherePasses(filter).OfClass(typeof(Wall)).ToElements();
CopyVB.NET
' Use Exclusion filter to find exclude a set of elements in the document automatically

' Find all walls that are not currently selected,
' Get all element ids which are current selected by users, exclude these ids when filtering
Dim excludes As ICollection(Of ElementId) = New List(Of ElementId)()
Dim elemIter As ElementSetIterator = uiDocument.Selection.Elements.ForwardIterator()
elemIter.Reset()
While elemIter.MoveNext()
    Dim curElem As Autodesk.Revit.DB.Element = TryCast(elemIter.Current, Autodesk.Revit.DB.Element)
    excludes.Add(curElem.Id)
End While

' Create filter to exclude all selected element ids
Dim filter As New ExclusionFilter(excludes)

' Apply the filter to the elements in the active document,
' Use shortcut method OfClass() to find Walls only
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(uiDocument.Document)
Dim walls As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).OfClass(GetType(Wall)).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..ExclusionFilter

See Also

ExclusionFilter Members


ExclusionFilter Members

[image] [image]

Revit 2013 API
ExclusionFilter Members
ExclusionFilter Class Constructors Methods Properties See Also Send Feedback

The ExclusionFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ExclusionFilter | Constructs a new instance of a filter to exclude elements automatically.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExclusionFilter Constructor

[image]

Revit 2013 API
ExclusionFilter Constructor
ExclusionFilter Class See Also Send Feedback
Constructs a new instance of a filter to exclude elements automatically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ExclusionFilter(
    ICollection<ElementId> idsToExclude
)
Visual Basic
Public Sub New ( _
    idsToExclude As ICollection(Of ElementId) _
)
Visual C++
public:
ExclusionFilter(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids to exclude from the results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExclusionFilter Class


ExclusionFilter Methods

[image] [image]

Revit 2013 API
ExclusionFilter Methods
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIdsToExclude | Returns the ids to be excluded by this filter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExclusionFilter Class


GetIdsToExclude Method

[image]

Revit 2013 API
ExclusionFilter..::..GetIdsToExclude Method
ExclusionFilter Class See Also Send Feedback
Returns the ids to be excluded by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetIdsToExclude()
Visual Basic
Public Function GetIdsToExclude As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetIdsToExclude()

Return Value

The collection of ids to exclude.

See Also

ExclusionFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
ExclusionFilter..::..PassesFilter Method
ExclusionFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class
ExclusionFilter Members


ExclusionFilter Properties

[image] [image]

Revit 2013 API
ExclusionFilter Properties
ExclusionFilter Class See Also Send Feedback

The ExclusionFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

ExclusionFilter Class


ExportColorMode Enumeration

[image]

Revit 2013 API
ExportColorMode Enumeration
See Also Send Feedback
An enumerated type listing export color mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExportColorMode
Visual Basic
Public Enumeration ExportColorMode
Visual C++
public enum class ExportColorMode

Members

Member name | Description
IndexColors | All colors from the Revit project will be set to the closest of the 255 AutoCAD Color Index colors.
TrueColor | All colors from the Revit project will be exported as 24-bit RGB values.

See Also


ExportColumnHeaders Enumeration

[image]

Revit 2013 API
ExportColumnHeaders Enumeration
See Also Send Feedback
Options for exporting column headers in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ExportColumnHeaders
Visual Basic
Public Enumeration ExportColumnHeaders
Visual C++
public enum class ExportColumnHeaders

Members

Member name | Description
None | Do not export column headers.
OneRow | Export column headers in one row.
MultipleRows | Export column headers using multiple rows.

See Also


ExportDGNSettings Class

[image]

Revit 2013 API
ExportDGNSettings Class
Members See Also Send Feedback
This element contains DGN export settings which are saved in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExportDGNSettings : Element
Visual Basic
Public Class ExportDGNSettings _
    Inherits Element
Visual C++
public ref class ExportDGNSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ExportDGNSettings

See Also

ExportDGNSettings Members


ExportDGNSettings Members

[image] [image]

Revit 2013 API
ExportDGNSettings Members
ExportDGNSettings Class Methods Properties See Also Send Feedback

The ExportDGNSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dgn export settings.
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDGNSettings Class


ExportDGNSettings Methods

[image] [image]

Revit 2013 API
ExportDGNSettings Methods
ExportDGNSettings Class See Also Send Feedback

The ExportDGNSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DGN export settings with default values.
 | Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDGNExportOptions | Gets the options stored in the these settings.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dgn export settings.
Public method | SetDGNExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportDGNSettings Class


Create Method

[image] [image]

Revit 2013 API
ExportDGNSettings..::..Create Method
ExportDGNSettings Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String) | Create a DGN export settings with default values.
Create(Document, String, DGNExportOptions) | Create DGN export settings with specified values in DGNExportOptions.

See Also

ExportDGNSettings Class
ExportDGNSettings Members


Create Method (Document, String)

[image]

Revit 2013 API
ExportDGNSettings..::..Create Method (Document, String)
ExportDGNSettings Class See Also Send Feedback
Create a DGN export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDGNSettings Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.

Return Value

The new DGN export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDGNSettings Class
Create Overload


Create Method (Document, String, DGNExportOptions)

[image]

Revit 2013 API
ExportDGNSettings..::..Create Method (Document, String, DGNExportOptions)
ExportDGNSettings Class See Also Send Feedback
Create DGN export settings with specified values in DGNExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDGNSettings Create(
    Document document,
    string name,
    DGNExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DGNExportOptions _
) As ExportDGNSettings
Visual C++
public:
static ExportDGNSettings^ Create(
    Document^ document,
    String^ name,
    DGNExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options which will be stored in these settings.

Return Value

The new DGN export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDGNSettings Class
Create Overload


GetDGNExportOptions Method

[image]

Revit 2013 API
ExportDGNSettings..::..GetDGNExportOptions Method
ExportDGNSettings Class See Also Send Feedback
Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DGNExportOptions GetDGNExportOptions()
Visual Basic
Public Function GetDGNExportOptions As DGNExportOptions
Visual C++
public:
DGNExportOptions^ GetDGNExportOptions()

Return Value

The options.

See Also

ExportDGNSettings Class


ListNames Method

[image]

Revit 2013 API
ExportDGNSettings..::..ListNames Method
ExportDGNSettings Class See Also Send Feedback
Returns a list of names of dgn export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<string> ListNames(
    Document aDoc
)
Visual Basic
Public Shared Function ListNames ( _
    aDoc As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from

Return Value

An array of strings representing names of predefined setups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDGNSettings Class


SetDGNExportOptions Method

[image]

Revit 2013 API
ExportDGNSettings..::..SetDGNExportOptions Method
ExportDGNSettings Class See Also Send Feedback
Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetDGNExportOptions(
    DGNExportOptions options
)
Visual Basic
Public Sub SetDGNExportOptions ( _
    options As DGNExportOptions _
)
Visual C++
public:
void SetDGNExportOptions(
    DGNExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DGNExportOptions
The options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDGNSettings Class


ExportDGNSettings Properties

[image] [image]

Revit 2013 API
ExportDGNSettings Properties
ExportDGNSettings Class See Also Send Feedback

The ExportDGNSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDGNSettings Class


Parameter Property

[image] [image]

Revit 2013 API
ExportDGNSettings..::..Parameter Property
ExportDGNSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExportDGNSettings Class
ExportDGNSettings Members


ExportDWGSettings Class

[image]

Revit 2013 API
ExportDWGSettings Class
Members See Also Send Feedback
This element contains DWG/DXF export settings which are saved in a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExportDWGSettings : Element
Visual Basic
Public Class ExportDWGSettings _
    Inherits Element
Visual C++
public ref class ExportDWGSettings : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ExportDWGSettings

See Also

ExportDWGSettings Members


ExportDWGSettings Members

[image] [image]

Revit 2013 API
ExportDWGSettings Members
ExportDWGSettings Class Methods Properties See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDWGSettings Class


ExportDWGSettings Methods

[image] [image]

Revit 2013 API
ExportDWGSettings Methods
ExportDWGSettings Class See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, String) | Create a DWG export settings with default values.
 | Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
 | Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetDWGExportOptions | Gets the options stored in the these settings.
Public method | GetDXFExportOptions | Gets the options stored in the these settings.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | ListNames | Returns a list of names of dwg/dxf export settings.
Public method | SetDWGExportOptions | Sets the options stored in these settings.
Public method | SetDXFExportOptions | Sets the options stored in these settings.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportDWGSettings Class


Create Method

[image] [image]

Revit 2013 API
ExportDWGSettings..::..Create Method
ExportDWGSettings Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String) | Create a DWG export settings with default values.
Create(Document, String, DWGExportOptions) | Create a DWG export settings with default values.
Create(Document, String, DXFExportOptions) | Create a DWG export settings with default values.

See Also

ExportDWGSettings Class
ExportDWGSettings Members


Create Method (Document, String)

[image]

Revit 2013 API
ExportDWGSettings..::..Create Method (Document, String)
ExportDWGSettings Class See Also Send Feedback
Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDWGSettings Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.

Return Value

The new DWG export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class
Create Overload


Create Method (Document, String, DWGExportOptions)

[image]

Revit 2013 API
ExportDWGSettings..::..Create Method (Document, String, DWGExportOptions)
ExportDWGSettings Class See Also Send Feedback
Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDWGSettings Create(
    Document document,
    string name,
    DWGExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DWGExportOptions _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DWGExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DWGExportOptions
Initialize settings by using values in DWGExportOptions.

Return Value

The new DWG export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class
Create Overload


Create Method (Document, String, DXFExportOptions)

[image]

Revit 2013 API
ExportDWGSettings..::..Create Method (Document, String, DXFExportOptions)
ExportDWGSettings Class See Also Send Feedback
Create a DWG export settings with default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExportDWGSettings Create(
    Document document,
    string name,
    DXFExportOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String, _
    options As DXFExportOptions _
) As ExportDWGSettings
Visual C++
public:
static ExportDWGSettings^ Create(
    Document^ document,
    String^ name,
    DXFExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document where created settings is saved.
name
Type: System..::..String
The name specified to this settings.
options
Type: Autodesk.Revit.DB..::..DXFExportOptions
Initialize settings by using values in DXFExportOptions.

Return Value

The new DWG export settings instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | ExistOrEmpty
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class
Create Overload


GetDWGExportOptions Method

[image]

Revit 2013 API
ExportDWGSettings..::..GetDWGExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DWGExportOptions GetDWGExportOptions()
Visual Basic
Public Function GetDWGExportOptions As DWGExportOptions
Visual C++
public:
DWGExportOptions^ GetDWGExportOptions()

Return Value

The options.

See Also

ExportDWGSettings Class


GetDXFExportOptions Method

[image]

Revit 2013 API
ExportDWGSettings..::..GetDXFExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Gets the options stored in the these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DXFExportOptions GetDXFExportOptions()
Visual Basic
Public Function GetDXFExportOptions As DXFExportOptions
Visual C++
public:
DXFExportOptions^ GetDXFExportOptions()

Return Value

The options

See Also

ExportDWGSettings Class


ListNames Method

[image]

Revit 2013 API
ExportDWGSettings..::..ListNames Method
ExportDWGSettings Class See Also Send Feedback
Returns a list of names of dwg/dxf export settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<string> ListNames(
    Document aDoc
)
Visual Basic
Public Shared Function ListNames ( _
    aDoc As Document _
) As IList(Of String)
Visual C++
public:
static IList<String^>^ ListNames(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit document to retrieve names from.

Return Value

An array of strings representing names of predefined setups.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class


SetDWGExportOptions Method

[image]

Revit 2013 API
ExportDWGSettings..::..SetDWGExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetDWGExportOptions(
    DWGExportOptions options
)
Visual Basic
Public Sub SetDWGExportOptions ( _
    options As DWGExportOptions _
)
Visual C++
public:
void SetDWGExportOptions(
    DWGExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DWGExportOptions
The options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class


SetDXFExportOptions Method

[image]

Revit 2013 API
ExportDWGSettings..::..SetDXFExportOptions Method
ExportDWGSettings Class See Also Send Feedback
Sets the options stored in these settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetDXFExportOptions(
    DXFExportOptions options
)
Visual Basic
Public Sub SetDXFExportOptions ( _
    options As DXFExportOptions _
)
Visual C++
public:
void SetDXFExportOptions(
    DXFExportOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..DXFExportOptions
The options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportDWGSettings Class


ExportDWGSettings Properties

[image] [image]

Revit 2013 API
ExportDWGSettings Properties
ExportDWGSettings Class See Also Send Feedback

The ExportDWGSettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExportDWGSettings Class


Parameter Property

[image] [image]

Revit 2013 API
ExportDWGSettings..::..Parameter Property
ExportDWGSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExportDWGSettings Class
ExportDWGSettings Members


ExportPaperFormat Enumeration

[image]

Revit 2013 API
ExportPaperFormat Enumeration
See Also Send Feedback
Paper formats supported by DWF export

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExportPaperFormat
Visual Basic
Public Enumeration ExportPaperFormat
Visual C++
public enum class ExportPaperFormat

Members

Member name | Description
Default | Default paper format.
ANSI_A | ANSI A, 8.5 x 11 in
ANSI_B | ANSI B, 11 x 17 in
ANSI_C | ANSI C, 17 x 22 in
ANSI_D | ANSI D, 22 x 34 in
ANSI_E | ANSI E, 34 x 44 in
ISO_A4 | ISO A4, 210 x 297 mm
ISO_A3 | ISO A3, 297 x 420 mm
ISO_A2 | ISO A2, 420 x 594 mm
ISO_A1 | ISO A1, 594 x 841 mm
ISO_A0 | ISO A0, 841 x 1189 mm
ISO_B4 | ISO B4, 250 x 353 mm
ISO_B3 | ISO B3, 353 x 500 mm
ISO_B2 | ISO B2, 500 x 707 mm
ISO_B1 | ISO B1, 707 x 1000 mm
ARCH_A | ARCH A, 9 x 12 in
ARCH_B | ARCH B, 12 x 18 in
ARCH_C | ARCH C, 18 x 24 in
ARCH_D | ARCH D, 24 x 36 in
ARCH_E | ARCH E, 36 x 48 in
ARCH_E1 | ARCH E1, 30 x 42 in
ARCH_E2 | ARCH E2, 26 x 38 in
ARCH_E3 | ARCH E3, 27 x 39 in

See Also


ExportRange Enumeration

[image]

Revit 2013 API
ExportRange Enumeration
See Also Send Feedback
This enum is used to define what view, part of the view, or list of views will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ExportRange
Visual Basic
Public Enumeration ExportRange
Visual C++
public enum class ExportRange

Members

Member name | Description
CurrentView | Export the current view only (zoom to fit of the current view).
VisibleRegionOfCurrentView | Export the visible region of the current view.
SetOfViews | Export a set of views (set in ViewsAndSheets).

See Also


ExportSheetType Enumeration

[image]

Revit 2013 API
ExportSheetType Enumeration
See Also Send Feedback
An enumerated type listing possible Sheet type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExportSheetType
Visual Basic
Public Enumeration ExportSheetType
Visual C++
public enum class ExportSheetType

Members

Member name | Description
ST_Current |
ST_Visible |
ST_Select |

See Also


ExportTextQualifier Enumeration

[image]

Revit 2013 API
ExportTextQualifier Enumeration
See Also Send Feedback
Options for the text qualifier character in schedule view export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ExportTextQualifier
Visual Basic
Public Enumeration ExportTextQualifier
Visual C++
public enum class ExportTextQualifier

Members

Member name | Description
None | No text qualifier.
Quote | The quote character - ' - is used to qualify text.
DoubleQuote | The quote character - " - is used to qualify text.

See Also


ExportUnit Enumeration

[image]

Revit 2013 API
ExportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExportUnit
Visual Basic
Public Enumeration ExportUnit
Visual C++
public enum class ExportUnit

Members

Member name | Description
Default | Default export unit. Depends on Revit's current units.
Inch | Inches in fractional notation.
Foot | Feet and Inches in fractional notation.
Millimeter | Millimeters as decimal values.
Centimeter | Centimeters as decimal values.
Meter | Meters as decimal values.

See Also


ExportUtils Class

[image]

Revit 2013 API
ExportUtils Class
Members See Also Send Feedback
This class provides utilities related to document export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ExportUtils : IDisposable
Visual Basic
Public Class ExportUtils _
    Implements IDisposable
Visual C++
public ref class ExportUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExportUtils

See Also

ExportUtils Members


ExportUtils Members

[image] [image]

Revit 2013 API
ExportUtils Members
ExportUtils Class Methods See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExportUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetExportId | Retrieves the GUID representing this element in DWF and IFC export.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportUtils Class


ExportUtils Methods

[image] [image]

Revit 2013 API
ExportUtils Methods
ExportUtils Class See Also Send Feedback

The ExportUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetExportId | Retrieves the GUID representing this element in DWF and IFC export.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExportUtils Class


Dispose Method

[image]

Revit 2013 API
ExportUtils..::..Dispose Method
ExportUtils Class See Also Send Feedback
Releases all resources used by the ExportUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExportUtils Class


GetExportId Method

[image]

Revit 2013 API
ExportUtils..::..GetExportId Method
ExportUtils Class See Also Send Feedback
Retrieves the GUID representing this element in DWF and IFC export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static Guid GetExportId(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetExportId ( _
    document As Document, _
    elementId As ElementId _
) As Guid
Visual C++
public:
static Guid GetExportId(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to get the element GUID from
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of element whose GUID to be retrieved

Return Value

GUID value of the element

Remarks

This id is used in the contents of DWF export and IFC export and it should be used only when cross-referencing to the contents of these export formats. When storing Ids that will need to be mapped back to elements in future sessions, UniqueId must be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elementId does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExportUtils Class


ExternalDBApplicationResult Enumeration

[image]

Revit 2013 API
ExternalDBApplicationResult Enumeration
See Also Send Feedback
Informs Autodesk Revit of the status of your external db application after execution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExternalDBApplicationResult
Visual Basic
Public Enumeration ExternalDBApplicationResult
Visual C++
public enum class ExternalDBApplicationResult

Members

Member name | Description
Failed | The external db application was unable to complete its task.
Succeeded | The external db application completed successfully. Autodesk Revit will keep this object during the entire Revit session.

See Also


ExternalDefinition Class

[image]

Revit 2013 API
ExternalDefinition Class
Members Example See Also Send Feedback
The ExternalDefinition object adds properties specific to Autodesk Revit shared parameter definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExternalDefinition : Definition
Visual Basic
Public Class ExternalDefinition _
    Inherits Definition
Visual C++
public ref class ExternalDefinition : public Definition

Remarks

The ExternalDefinition object can be created by a definition Group object from a shared parameters file. External parameter definition must belong to a Group which is nothing more than a collection of shared parameter definitions. The following process should be followed to add a parameter to an element: Open the shared parameters file, via the Application.OpenSharedParameterFile method. Access an existing or create a new group, via the DefinitionFile.Groups property. Access an existing or create a new external parameter definition, via the DefinitionGroup.Definitions property. Create a new Binding object with the categories to which the parameter will be bound using an InstanceBinding or a TypeBinding object. Finally add the binding and definition to the document using the Document.ParameterBindings object.

Examples

CopyC#
private void ReadEditExternalParam(DefinitionFile file)
{
    // get ExternalDefinition from shared parameter file
    DefinitionGroups myGroups = file.Groups;
    DefinitionGroup myGroup = myGroups.get_Item("MyGroup");
    if (null == myGroup)
        return;

    Definitions myDefinitions = myGroup.Definitions;
    ExternalDefinition myExtDef =
        myDefinitions.get_Item("MyParam") as ExternalDefinition;
    if (null == myExtDef)
        return;

    StringBuilder strBuilder = new StringBuilder();
    // iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString())
        .AppendLine("Name: " + myExtDef.Name)
        .AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name)
        .AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString())
        .AppendLine("Parameter Type" + myExtDef.ParameterType.ToString())
        .AppendLine("Is Visible: " + myExtDef.Visible.ToString());

    TaskDialog.Show("Revit",strBuilder.ToString());

    // change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.get_Item("AnotherGroup");
}
CopyVB.NET
Private Sub ReadEditExternalParam(ByVal file As DefinitionFile)
    ' get ExternalDefinition from shared parameter file
    Dim myGroups As DefinitionGroups = file.Groups
    Dim myGroup As DefinitionGroup = myGroups.Item("MyGroup")
    If myGroup Is Nothing Then
        Return
    End If

    Dim myDefinitions As Definitions = myGroup.Definitions
    Dim myExtDef As ExternalDefinition = TryCast(myDefinitions.Item("MyParam"), ExternalDefinition)
    If myExtDef Is Nothing Then
        Return
    End If

    Dim strBuilder As New StringBuilder()
    ' iterate every property of the ExternalDefinition
    strBuilder.AppendLine("GUID: " + myExtDef.GUID.ToString()).AppendLine("Name: " + myExtDef.Name).AppendLine("OwnerGroup: " + myExtDef.OwnerGroup.Name).AppendLine("Parameter Group" + myExtDef.ParameterGroup.ToString()).AppendLine("Parameter Type" + myExtDef.ParameterType.ToString()).AppendLine("Is Visible: " + myExtDef.Visible.ToString())

    TaskDialog.Show("Revit", strBuilder.ToString())

    ' change the OwnerGroup of the ExternalDefinition
    myExtDef.OwnerGroup = myGroups.Item("AnotherGroup")
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..ExternalDefinition

See Also

ExternalDefinition Members


ExternalDefinition Members

[image] [image]

Revit 2013 API
ExternalDefinition Members
ExternalDefinition Class Methods Properties See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class


ExternalDefinition Methods

[image] [image]

Revit 2013 API
ExternalDefinition Methods
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinition Class


ExternalDefinition Properties

[image] [image]

Revit 2013 API
ExternalDefinition Properties
ExternalDefinition Class See Also Send Feedback

The ExternalDefinition type exposes the following members.

Properties

 | Name | Description
Public property | GUID | Returns the GUID associated with the shared parameter definition.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user visible name for the parameter. (Overrides Definition..::..Name.)
Public property | OwnerGroup | Returns or change the group ID of the external parameter definition.
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

ExternalDefinition Class


GUID Property

[image]

Revit 2013 API
ExternalDefinition..::..GUID Property
ExternalDefinition Class See Also Send Feedback
Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Guid GUID { get; }
Visual Basic
Public Overridable ReadOnly Property GUID As Guid
    Get
Visual C++
public:
virtual property Guid GUID {
    Guid get ();
}

Remarks

Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.

See Also

ExternalDefinition Class


Name Property

[image]

Revit 2013 API
ExternalDefinition..::..Name Property
ExternalDefinition Class See Also Send Feedback
The user visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

ExternalDefinition Class


OwnerGroup Property

[image]

Revit 2013 API
ExternalDefinition..::..OwnerGroup Property
ExternalDefinition Class See Also Send Feedback
Returns or change the group ID of the external parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DefinitionGroup OwnerGroup { get; set; }
Visual Basic
Public Overridable Property OwnerGroup As DefinitionGroup
    Get
    Set
Visual C++
public:
virtual property DefinitionGroup^ OwnerGroup {
    DefinitionGroup^ get ();
    void set (DefinitionGroup^ value);
}

Remarks

If failed When set the group, an InvalidOperationException will be thrown.

See Also

ExternalDefinition Class


ParameterGroup Property

[image]

Revit 2013 API
ExternalDefinition..::..ParameterGroup Property
ExternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
    Get
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

ExternalDefinition Class


ParameterType Property

[image]

Revit 2013 API
ExternalDefinition..::..ParameterType Property
ExternalDefinition Class See Also Send Feedback
Returns the user visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterType As ParameterType
    Get
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored in a very simple manner as an integer, double, string or an element id, but to the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

ExternalDefinition Class


Visible Property

[image]

Revit 2013 API
ExternalDefinition..::..Visible Property
ExternalDefinition Class See Also Send Feedback
Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Visible { get; }
Visual Basic
Public Overridable ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

ExternalDefinition Class


ExternalDefinitions Class

[image]

Revit 2013 API
ExternalDefinitions Class
Members See Also Send Feedback
Supports the creation of new shared parameters definitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExternalDefinitions : Definitions
Visual Basic
Public Class ExternalDefinitions _
    Inherits Definitions
Visual C++
public ref class ExternalDefinitions : public Definitions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..ExternalDefinitions

See Also

ExternalDefinitions Members


ExternalDefinitions Members

[image] [image]

Revit 2013 API
ExternalDefinitions Members
ExternalDefinitions Class Methods Properties See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

ExternalDefinitions Class


ExternalDefinitions Methods

[image] [image]

Revit 2013 API
ExternalDefinitions Methods
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalDefinitions Class


Create Method

[image] [image]

Revit 2013 API
ExternalDefinitions..::..Create Method
ExternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)

See Also

ExternalDefinitions Class
ExternalDefinitions Members


ExternalDefinitions Properties

[image] [image]

Revit 2013 API
ExternalDefinitions Properties
ExternalDefinitions Class See Also Send Feedback

The ExternalDefinitions type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

ExternalDefinitions Class


ExternalFileReference Class

[image]

Revit 2013 API
ExternalFileReference Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExternalFileReference : IDisposable
Visual Basic
Public Class ExternalFileReference _
    Implements IDisposable
Visual C++
public ref class ExternalFileReference : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalFileReference

See Also

ExternalFileReference Members


ExternalFileReference Members

[image] [image]

Revit 2013 API
ExternalFileReference Members
ExternalFileReference Class Methods Properties See Also Send Feedback

The ExternalFileReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalFileReference
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | PathType | The path type of the link (relative, absolute, or server).

See Also

ExternalFileReference Class


ExternalFileReference Methods

[image] [image]

Revit 2013 API
ExternalFileReference Methods
ExternalFileReference Class See Also Send Feedback

The ExternalFileReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAbsolutePath | Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedFileStatus | Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.
Public method | GetPath | Gets the path of the link, relative or absolute according to the link's settings
Public method | GetReferencingId | Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalFileReference | Checks an ExternalFileReference to see if it is properly created.
Public method | IsValidPathTypeForExternalFileReference | Checks whether a PathType enum value will be valid to use with this ExternalFileReference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalFileReference Class


Dispose Method

[image]

Revit 2013 API
ExternalFileReference..::..Dispose Method
ExternalFileReference Class See Also Send Feedback
Releases all resources used by the ExternalFileReference

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalFileReference Class


GetAbsolutePath Method

[image]

Revit 2013 API
ExternalFileReference..::..GetAbsolutePath Method
ExternalFileReference Class See Also Send Feedback
Returns an absolute path to the referenced file, regardless of whether the PathType.Enum is relative or absolute.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ModelPath GetAbsolutePath()
Visual Basic
Public Function GetAbsolutePath As ModelPath
Visual C++
public:
ModelPath^ GetAbsolutePath()

Return Value

A full path to the linked model.

Remarks

ExternalFileReferences which are taken from a closed document will report their absolute path as of the last time the document was saved.

See Also

ExternalFileReference Class


GetLinkedFileStatus Method

[image]

Revit 2013 API
ExternalFileReference..::..GetLinkedFileStatus Method
ExternalFileReference Class See Also Send Feedback
Returns a LinkedFileStatus.Enum corresponding to the load status of the referenced file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinkedFileStatus GetLinkedFileStatus()
Visual Basic
Public Function GetLinkedFileStatus As LinkedFileStatus
Visual C++
public:
LinkedFileStatus GetLinkedFileStatus()

Remarks

Options are Invalid, Loaded, Unloaded, NotFound, or Imported.

See Also

ExternalFileReference Class


GetPath Method

[image]

Revit 2013 API
ExternalFileReference..::..GetPath Method
ExternalFileReference Class See Also Send Feedback
Gets the path of the link, relative or absolute according to the link's settings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ModelPath GetPath()
Visual Basic
Public Function GetPath As ModelPath
Visual C++
public:
ModelPath^ GetPath()

Return Value

The path of the link. This path will be relative for relatively-pathed links.

See Also

ExternalFileReference Class


GetReferencingId Method

[image]

Revit 2013 API
ExternalFileReference..::..GetReferencingId Method
ExternalFileReference Class See Also Send Feedback
Gets the ElementId corresponding to the element which this ExternalFileReference is associated with.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetReferencingId()
Visual Basic
Public Function GetReferencingId As ElementId
Visual C++
public:
ElementId^ GetReferencingId()

See Also

ExternalFileReference Class


IsValidExternalFileReference Method

[image]

Revit 2013 API
ExternalFileReference..::..IsValidExternalFileReference Method
ExternalFileReference Class See Also Send Feedback
Checks an ExternalFileReference to see if it is properly created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidExternalFileReference(
    ExternalFileReference data
)
Visual Basic
Public Shared Function IsValidExternalFileReference ( _
    data As ExternalFileReference _
) As Boolean
Visual C++
public:
static bool IsValidExternalFileReference(
    ExternalFileReference^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..ExternalFileReference
The ExternalFileReference to be checked

Remarks

The following restrictions exist:
  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable or ExternalFileReferenceType.Decal
  • Keynote tables and Decals (ExternalFileReferenceType.KeynoteTable and ExternalFileReferenceType.Decal) may only be LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileReference Class


IsValidPathTypeForExternalFileReference Method

[image]

Revit 2013 API
ExternalFileReference..::..IsValidPathTypeForExternalFileReference Method
ExternalFileReference Class See Also Send Feedback
Checks whether a PathType enum value will be valid to use with this ExternalFileReference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)
Visual Basic
Public Function IsValidPathTypeForExternalFileReference ( _
    pathType As PathType _
) As Boolean
Visual C++
public:
bool IsValidPathTypeForExternalFileReference(
    PathType pathType
)

Parameters

pathType
Type: Autodesk.Revit.DB..::..PathType

Remarks

  • PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
  • PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable and ExternalFileReferenceType.Decal

See Also

ExternalFileReference Class


ExternalFileReference Properties

[image] [image]

Revit 2013 API
ExternalFileReference Properties
ExternalFileReference Class See Also Send Feedback

The ExternalFileReference type exposes the following members.

Properties

 | Name | Description
Public property | ExternalFileReferenceType | The type of external file which this object references.
Public property | PathType | The path type of the link (relative, absolute, or server).

See Also

ExternalFileReference Class


ExternalFileReferenceType Property

[image]

Revit 2013 API
ExternalFileReference..::..ExternalFileReferenceType Property
ExternalFileReference Class See Also Send Feedback
The type of external file which this object references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReferenceType ExternalFileReferenceType { get; }
Visual Basic
Public ReadOnly Property ExternalFileReferenceType As ExternalFileReferenceType
    Get
Visual C++
public:
property ExternalFileReferenceType ExternalFileReferenceType {
    ExternalFileReferenceType get ();
}

Field Value

ExternalFileReferenceType.RevitLink for Revit links, ExternalFileReferenceType.CADLink for CAD link types. ExternalFileReferenceType.DWFMarkup for DWF markups. ExternalFileReferenceType.KeynoteTable for the keynote table element. ExternalFileReferenceType.Decal for rendering decals. ExternalFileReferenceType.Material for material files (not in this release).

See Also

ExternalFileReference Class


PathType Property

[image]

Revit 2013 API
ExternalFileReference..::..PathType Property
ExternalFileReference Class See Also Send Feedback
The path type of the link (relative, absolute, or server).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PathType PathType { get; }
Visual Basic
Public ReadOnly Property PathType As PathType
    Get
Visual C++
public:
property PathType PathType {
    PathType get ();
}

Field Value

See the PathType enum for a list of the options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: pathType is not a compatible path type for this ExternalFileReference.

See Also

ExternalFileReference Class


ExternalFileReferenceType Enumeration

[image]

Revit 2013 API
ExternalFileReferenceType Enumeration
See Also Send Feedback
Enum class indicating kinds of external file references

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ExternalFileReferenceType
Visual Basic
Public Enumeration ExternalFileReferenceType
Visual C++
public enum class ExternalFileReferenceType

Members

Member name | Description
None | Uninitialized value
RevitLink | Revit linked files
CADLink | Linked CAD files
DWFMarkup | DWF markup files
KeynoteTable | The keynote table (The file which contains keynote information.)
Decal | Decals (images which appear only during rendering)
Material | Materials are not included as ExternalFileReferences in the 2012 release

See Also


ExternalFileUtils Class

[image]

Revit 2013 API
ExternalFileUtils Class
Members See Also Send Feedback
A utility class containing functions related to external file references. Elements which are external file references refer to files outside of the base .rvt file. Examples include Revit links, CAD links, the element which stores the location of the keynote file, and rendering decals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExternalFileUtils : IDisposable
Visual Basic
Public Class ExternalFileUtils _
    Implements IDisposable
Visual C++
public ref class ExternalFileUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExternalFileUtils

See Also

ExternalFileUtils Members


ExternalFileUtils Members

[image] [image]

Revit 2013 API
ExternalFileUtils Members
ExternalFileUtils Class Methods See Also Send Feedback

The ExternalFileUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalFileUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllExternalFileReferences | Gets the ids of all elements which are external file references.
 | GetExternalFileReference | Gets the external file referencing data for the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsExternalFileReference | Determines whether the given element represents an external file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalFileUtils Class


ExternalFileUtils Methods

[image] [image]

Revit 2013 API
ExternalFileUtils Methods
ExternalFileUtils Class See Also Send Feedback

The ExternalFileUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllExternalFileReferences | Gets the ids of all elements which are external file references.
 | GetExternalFileReference | Gets the external file referencing data for the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsExternalFileReference | Determines whether the given element represents an external file.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalFileUtils Class


Dispose Method

[image]

Revit 2013 API
ExternalFileUtils..::..Dispose Method
ExternalFileUtils Class See Also Send Feedback
Releases all resources used by the ExternalFileUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalFileUtils Class


GetAllExternalFileReferences Method

[image]

Revit 2013 API
ExternalFileUtils..::..GetAllExternalFileReferences Method
ExternalFileUtils Class See Also Send Feedback
Gets the ids of all elements which are external file references.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAllExternalFileReferences(
    Document aDoc
)
Visual Basic
Public Shared Function GetAllExternalFileReferences ( _
    aDoc As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllExternalFileReferences(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.

Return Value

The ids of all elements which are external file references.

Remarks

This function will not return the ids of nested Revit links; it only returns top-level references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileUtils Class


GetExternalFileReference Method

[image]

Revit 2013 API
ExternalFileUtils..::..GetExternalFileReference Method
ExternalFileUtils Class See Also Send Feedback
Gets the external file referencing data for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ExternalFileReference GetExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Visual Basic
Public Shared Function GetExternalFileReference ( _
    aDoc As Document, _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
static ExternalFileReference^ GetExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element whose external file reference we want.

Return Value

An object containing path and type information for the given element's external file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elemId does not exist in the document -or- elemId does not represent an external file reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileUtils Class


IsExternalFileReference Method

[image]

Revit 2013 API
ExternalFileUtils..::..IsExternalFileReference Method
ExternalFileUtils Class See Also Send Feedback
Determines whether the given element represents an external file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsExternalFileReference(
    Document aDoc,
    ElementId elemId
)
Visual Basic
Public Shared Function IsExternalFileReference ( _
    aDoc As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool IsExternalFileReference(
    Document^ aDoc,
    ElementId^ elemId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
A Revit Document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for an external file reference.

Return Value

True if the given element represents an external file; false otherwise.

Remarks

Linked files are references to external files, but imported files are not, as their data is brought wholly into Revit.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element elemId does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalFileUtils Class


Extrusion Class

[image]

Revit 2013 API
Extrusion Class
Members See Also Send Feedback
A extrusion solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Extrusion : GenericForm
Visual Basic
Public Class Extrusion _
    Inherits GenericForm
Visual C++
public ref class Extrusion : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Extrusion

See Also

Extrusion Members


Extrusion Members

[image] [image]

Revit 2013 API
Extrusion Members
Extrusion Class Methods Properties See Also Send Feedback

The Extrusion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Extrusion Class


Extrusion Methods

[image] [image]

Revit 2013 API
Extrusion Methods
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Extrusion Class


Extrusion Properties

[image] [image]

Revit 2013 API
Extrusion Properties
Extrusion Class See Also Send Feedback

The Extrusion type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOffset | The offset of the end of the extrusion relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Extrusion.
Public property | StartOffset | The offset of the start of the extrusion relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Extrusion Class


EndOffset Property

[image]

Revit 2013 API
Extrusion..::..EndOffset Property
Extrusion Class See Also Send Feedback
The offset of the end of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double EndOffset { get; set; }
Visual Basic
Public Property EndOffset As Double
    Get
    Set
Visual C++
public:
property double EndOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class


Parameter Property

[image] [image]

Revit 2013 API
Extrusion..::..Parameter Property
Extrusion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Extrusion Class
Extrusion Members


Sketch Property

[image]

Revit 2013 API
Extrusion..::..Sketch Property
Extrusion Class See Also Send Feedback
Returns the Sketch of the Extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic
Public ReadOnly Property Sketch As Sketch
    Get
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketches of the Extrusion.

See Also

Extrusion Class


StartOffset Property

[image]

Revit 2013 API
Extrusion..::..StartOffset Property
Extrusion Class See Also Send Feedback
The offset of the start of the extrusion relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StartOffset { get; set; }
Visual Basic
Public Property StartOffset As Double
    Get
    Set
Visual C++
public:
property double StartOffset {
    double get ();
    void set (double value);
}

Remarks

The direction of the offset is based on the normal of the extrusion's sketch plane: a positive value is in the direction of the normal, a negative value is in the other direction.

See Also

Extrusion Class


ExtrusionAnalyzer Class

[image]

Revit 2013 API
ExtrusionAnalyzer Class
Members See Also Send Feedback
This geometry utility allows you to attempt to “fit” a given piece of geometry into the shape of an extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExtrusionAnalyzer : IDisposable
Visual Basic
Public Class ExtrusionAnalyzer _
    Implements IDisposable
Visual C++
public ref class ExtrusionAnalyzer : IDisposable

Remarks

An instance of this class is a single-time use class which should be supplied a solid geometry, a plane, and a direction. The utility will calculate a base boundary parallel to the input plane which is the outer boundary of the shadow cast by the solid onto the input plane and along the extrusion direction.

After the extrusion has been calculated, the class permits a second step analysis to identify all faces from the original geometry which do not align with the faces of the calculated extrusion.

This utility works best for geometry which are at least somewhat “extrusion-like”, for example, the geometry of a wall which may or may not be affected by end joins, floor joins, roof joins, openings cut by windows and doors, or other modifications.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ExtrusionAnalyzer

See Also

ExtrusionAnalyzer Members


ExtrusionAnalyzer Members

[image] [image]

Revit 2013 API
ExtrusionAnalyzer Members
ExtrusionAnalyzer Class Methods Properties See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose | Releases all resources used by the ExtrusionAnalyzer
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzer Methods

[image] [image]

Revit 2013 API
ExtrusionAnalyzer Methods
ExtrusionAnalyzer Class See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Methods

 | Name | Description
Public method | CalculateFaceAlignment | Calculates the alignment status of each face of the solid.
 | Create | Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetExtrusionBase | Obtains the face that represents the base contour of the extrusion analysis.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtrusionAnalyzer Class


CalculateFaceAlignment Method

[image]

Revit 2013 API
ExtrusionAnalyzer..::..CalculateFaceAlignment Method
ExtrusionAnalyzer Class See Also Send Feedback
Calculates the alignment status of each face of the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<Face, ExtrusionAnalyzerFaceAlignment> CalculateFaceAlignment()
Visual Basic
Public Function CalculateFaceAlignment As IDictionary(Of Face, ExtrusionAnalyzerFaceAlignment)
Visual C++
public:
IDictionary<Face^, ExtrusionAnalyzerFaceAlignment>^ CalculateFaceAlignment()

Return Value

Maps each face of the solid to its alignment status.

Remarks

You can obtain the element which produced the non-aligned face by passing the face to Element.GetGeneratingElementIds().

See Also

ExtrusionAnalyzer Class


Create Method

[image]

Revit 2013 API
ExtrusionAnalyzer..::..Create Method
ExtrusionAnalyzer Class See Also Send Feedback
Creates an ExtrusionAnalyzer and computes and stores the solid's shadow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ExtrusionAnalyzer Create(
    Solid solidGeometry,
    Plane plane,
    XYZ direction
)
Visual Basic
Public Shared Function Create ( _
    solidGeometry As Solid, _
    plane As Plane, _
    direction As XYZ _
) As ExtrusionAnalyzer
Visual C++
public:
static ExtrusionAnalyzer^ Create(
    Solid^ solidGeometry,
    Plane^ plane,
    XYZ^ direction
)

Parameters

solidGeometry
Type: Autodesk.Revit.DB..::..Solid
The geometry to analyze.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane to use for the base plane for the extrusion.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction to use for the calculation for the extrusion.

Return Value

The newly created ExtrusionAnalyzer object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input direction must be transverse to the input plane.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred in creating the ExtrusionAnalyzer or computing the solid's shadow.

See Also

ExtrusionAnalyzer Class


Dispose Method

[image]

Revit 2013 API
ExtrusionAnalyzer..::..Dispose Method
ExtrusionAnalyzer Class See Also Send Feedback
Releases all resources used by the ExtrusionAnalyzer

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExtrusionAnalyzer Class


GetExtrusionBase Method

[image]

Revit 2013 API
ExtrusionAnalyzer..::..GetExtrusionBase Method
ExtrusionAnalyzer Class See Also Send Feedback
Obtains the face that represents the base contour of the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Face GetExtrusionBase()
Visual Basic
Public Function GetExtrusionBase As Face
Visual C++
public:
Face^ GetExtrusionBase()

Return Value

The face that represents the base contour.

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzer Properties

[image] [image]

Revit 2013 API
ExtrusionAnalyzer Properties
ExtrusionAnalyzer Class See Also Send Feedback

The ExtrusionAnalyzer type exposes the following members.

Properties

 | Name | Description
Public property | EndParameter | The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.
Public property | ExtrusionDirection | The direction of extrusion specified for the extrusion analysis.
Public property | StartParameter | The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

See Also

ExtrusionAnalyzer Class


EndParameter Property

[image]

Revit 2013 API
ExtrusionAnalyzer..::..EndParameter Property
ExtrusionAnalyzer Class See Also Send Feedback
The end parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double EndParameter { get; }
Visual Basic
Public ReadOnly Property EndParameter As Double
    Get
Visual C++
public:
property double EndParameter {
    double get ();
}

See Also

ExtrusionAnalyzer Class


ExtrusionDirection Property

[image]

Revit 2013 API
ExtrusionAnalyzer..::..ExtrusionDirection Property
ExtrusionAnalyzer Class See Also Send Feedback
The direction of extrusion specified for the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ ExtrusionDirection { get; }
Visual Basic
Public ReadOnly Property ExtrusionDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ExtrusionDirection {
    XYZ^ get ();
}

See Also

ExtrusionAnalyzer Class


StartParameter Property

[image]

Revit 2013 API
ExtrusionAnalyzer..::..StartParameter Property
ExtrusionAnalyzer Class See Also Send Feedback
The start parameter (distance along the extrusion direction from the input plane) calculated by the extrusion analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double StartParameter { get; }
Visual Basic
Public ReadOnly Property StartParameter As Double
    Get
Visual C++
public:
property double StartParameter {
    double get ();
}

See Also

ExtrusionAnalyzer Class


ExtrusionAnalyzerFaceAlignment Enumeration

[image]

Revit 2013 API
ExtrusionAnalyzerFaceAlignment Enumeration
See Also Send Feedback
Indicates whether a face of the solid analyzed by ExtrusionAnalyzer is fully aligned, partially aligned, or unaligned with faces of the extrusion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ExtrusionAnalyzerFaceAlignment
Visual Basic
Public Enumeration ExtrusionAnalyzerFaceAlignment
Visual C++
public enum class ExtrusionAnalyzerFaceAlignment

Members

Member name | Description
FullyAligned | The face is fully aligned with faces of the extrusion.
PartiallyAligned | The face is only partially aligned with faces of the extrusion.
Unaligned | The face is not aligned with any faces of the extrusion.

See Also


ExtrusionRoof Class

[image]

Revit 2013 API
ExtrusionRoof Class
Members See Also Send Feedback
Represents some kinds of Extrusion Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExtrusionRoof : RoofBase
Visual Basic
Public Class ExtrusionRoof _
    Inherits RoofBase
Visual C++
public ref class ExtrusionRoof : public RoofBase

Remarks

The ExtrusionRoof object represents some kinds of extruded roofs in Revit.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..ExtrusionRoof

See Also

ExtrusionRoof Members


ExtrusionRoof Members

[image] [image]

Revit 2013 API
ExtrusionRoof Members
ExtrusionRoof Class Methods Properties See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExtrusionRoof Class


ExtrusionRoof Methods

[image] [image]

Revit 2013 API
ExtrusionRoof Methods
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfile | Retrieve the Profile of ExtrusionRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExtrusionRoof Class


GetProfile Method

[image]

Revit 2013 API
ExtrusionRoof..::..GetProfile Method
ExtrusionRoof Class See Also Send Feedback
Retrieve the Profile of ExtrusionRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray GetProfile()
Visual Basic
Public Function GetProfile As ModelCurveArray
Visual C++
public:
ModelCurveArray^ GetProfile()

See Also

ExtrusionRoof Class


ExtrusionRoof Properties

[image] [image]

Revit 2013 API
ExtrusionRoof Properties
ExtrusionRoof Class See Also Send Feedback

The ExtrusionRoof type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a curtain Roof.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ExtrusionRoof Class


CurtainGrids Property

[image]

Revit 2013 API
ExtrusionRoof..::..CurtainGrids Property
ExtrusionRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a curtain Roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only when the object is a CurtainRoof, this property makes sense.

See Also

ExtrusionRoof Class


Parameter Property

[image] [image]

Revit 2013 API
ExtrusionRoof..::..Parameter Property
ExtrusionRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ExtrusionRoof Class
ExtrusionRoof Members


Face Class

[image]

Revit 2013 API
Face Class
Members See Also Send Feedback
A face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Face : GeometryObject
Visual Basic
Public Class Face _
    Inherits GeometryObject
Visual C++
public ref class Face : public GeometryObject

Remarks

Faces are defined by surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..ConicalFace
Autodesk.Revit.DB..::..CylindricalFace
Autodesk.Revit.DB..::..HermiteFace
Autodesk.Revit.DB..::..PlanarFace
Autodesk.Revit.DB..::..RevolvedFace
Autodesk.Revit.DB..::..RuledFace

See Also

Face Members


Face Members

[image] [image]

Revit 2013 API
Face Members
Face Class Methods Properties See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.
Public method | Project | Projects the specified point on this face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElementId | Element ID of the material from which this face is composed.
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class


Face Methods

[image] [image]

Revit 2013 API
Face Methods
Face Class See Also Send Feedback

The Face type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point.
Public method | ComputeNormal | Returns the normal vector for the face at the given point.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face.
Public method | GetBoundingBox | Returns the UV bounding box of the face.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.
Public method | Project | Projects the specified point on this face.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class


ComputeDerivatives Method

[image]

Revit 2013 API
Face..::..ComputeDerivatives Method
Face Class See Also Send Feedback
Returns the vectors describing the face at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ComputeDerivatives(
    UV point
)
Visual Basic
Public Function ComputeDerivatives ( _
    point As UV _
) As Transform
Visual C++
public:
Transform^ ComputeDerivatives(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The transformation containing tangent vectors and a normal vector.

Remarks

The following is the meaning of the transformation members: Origin is the point on the face (equivalent to Evaluate);BasisX is the tangent vector along the U coordinate (partial derivative with respect to U).BasisY is the tangent vector along the V coordinate (partial derivative with respect to V).BasisZ is the "surface normal" vector. This is not necessarily the normal vector pointing out of the solid that contains the face, to get that value use ComputeNormal(UV). None of the vectors are normalized.

See Also

Face Class


ComputeNormal Method

[image]

Revit 2013 API
Face..::..ComputeNormal Method
Face Class See Also Send Feedback
Returns the normal vector for the face at the given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ ComputeNormal(
    UV point
)
Visual Basic
Public Function ComputeNormal ( _
    point As UV _
) As XYZ
Visual C++
public:
XYZ^ ComputeNormal(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

The normal vector. This vector will be normalized.

Remarks

Differs from the normal returned from ComputeDerivatives(UV) in that this vector is the "face normal" vector. It will always be oriented to point out of the solid that contains the face.

See Also

Face Class


Evaluate Method

[image]

Revit 2013 API
Face..::..Evaluate Method
Face Class See Also Send Feedback
Evaluates parameters on the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Evaluate(
    UV params
)
Visual Basic
Public Function Evaluate ( _
    params As UV _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    UV^ params
)

Parameters

params
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

See Also

Face Class


GetBoundingBox Method

[image]

Revit 2013 API
Face..::..GetBoundingBox Method
Face Class See Also Send Feedback
Returns the UV bounding box of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public BoundingBoxUV GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ GetBoundingBox()

Return Value

A BoundingBoxUV with the extents of the parameterization of the face.

See Also

Face Class


GetRegions Method

[image]

Revit 2013 API
Face..::..GetRegions Method
Face Class See Also Send Feedback
Face regions (created with the Split Face command) of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Face> GetRegions()
Visual Basic
Public Function GetRegions As IList(Of Face)
Visual C++
public:
IList<Face^>^ GetRegions()

Return Value

A list of faces, one for the main face of the object hosting the Split Face (such as wall of floor) and one face for each Split Face regions.

Remarks

Use the FaceSplitter Class to filter and find these faces by type.

See Also

Face Class


Intersect Method

[image] [image]

Revit 2013 API
Face..::..Intersect Method
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face.
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results.

See Also

Face Class
Face Members


Intersect Method (Curve)

[image]

Revit 2013 API
Face..::..Intersect Method (Curve)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve
)
Visual Basic
Public Function Intersect ( _
    curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


Intersect Method (Curve, IntersectionResultArray)

[image]

Revit 2013 API
Face..::..Intersect Method (Curve, IntersectionResultArray%)
Face Class See Also Send Feedback
Calculates the intersection of the specified curve with this face and returns the intersection results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SetComparisonResult Intersect(
    Curve curve,
    out IntersectionResultArray results
)
Visual Basic
Public Function Intersect ( _
    curve As Curve, _
    <OutAttribute> ByRef results As IntersectionResultArray _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
    Curve^ curve,
    [OutAttribute] IntersectionResultArray^% results
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this face.
results
Type: Autodesk.Revit.DB..::..IntersectionResultArray%
Provides more information about the intersection.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered. The output argument has the results.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Remarks

The array of the intersection results contains one entry for each point where this face and the curve intersect. The following is the meaning of IntersectionResult's members:
  • XYZPoint is the evaluated intersection point.
  • UVPoint is the intersection parameters on the face.
  • Parameter is the raw intersection parameter on the curve.
  • EdgeObject is the edge if the intersection happens to be near an edge of the face.
  • EdgeParameter is the parameter of the nearest point on the edge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails.

See Also

Face Class
Intersect Overload


IsInside Method

[image] [image]

Revit 2013 API
Face..::..IsInside Method
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face.
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results.

See Also

Face Class
Face Members


IsInside Method (UV)

[image]

Revit 2013 API
Face..::..IsInside Method (UV)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInside(
    UV point
)
Visual Basic
Public Function IsInside ( _
    point As UV _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.

Return Value

True if point is within this face, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload


IsInside Method (UV, IntersectionResult)

[image]

Revit 2013 API
Face..::..IsInside Method (UV, IntersectionResult%)
Face Class See Also Send Feedback
Indicates whether the specified point is within this face and outputs additional results.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInside(
    UV point,
    out IntersectionResult result
)
Visual Basic
Public Function IsInside ( _
    point As UV, _
    <OutAttribute> ByRef result As IntersectionResult _
) As Boolean
Visual C++
public:
bool IsInside(
    UV^ point,
    [OutAttribute] IntersectionResult^% result
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
The parameters to be evaluated, in natural parameterization of the face.
result
Type: Autodesk.Revit.DB..::..IntersectionResult%
Provides more information when the point is on the edge; otherwise, nullNothingnullptra null reference (Nothing in Visual Basic).

Return Value

True if within this face, otherwise False.

Remarks

The following is the meaning of the IntersectionResult members when the point is on the edge: EdgeObject is the edge that the point lies on; EdgeParameter is the parameter of the point on the edge nearest to the UV point; UV is the specified point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter evaluation fails.

See Also

Face Class
IsInside Overload


Project Method

[image]

Revit 2013 API
Face..::..Project Method
Face Class See Also Send Feedback
Projects the specified point on this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResult Project(
    XYZ point
)
Visual Basic
Public Function Project ( _
    point As XYZ _
) As IntersectionResult
Visual C++
public:
IntersectionResult^ Project(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to be projected.

Return Value

Geometric information if projection is successful; if projection fails or the nearest point is outside of this face, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The following is the meaning of IntersectionResult's members:
  • XYZPoint is the nearest point to the projected point on the face.
  • UVPoint is the UV coordinates of the nearest point on the face.
  • Distance is the distance from the point to the face.
  • EdgeObject is the edge if projected point is near an edge.
  • EdgeParameter is the parameter of the nearest point on the edge.

See Also

Face Class


Triangulate Method

[image] [image]

Revit 2013 API
Face..::..Triangulate Method
Face Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face.
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face.

See Also

Face Class
Face Members


Triangulate Method

[image]

Revit 2013 API
Face..::..Triangulate Method
Face Class Example See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Mesh Triangulate()
Visual Basic
Public Function Triangulate As Mesh
Visual C++
public:
Mesh^ Triangulate()

Remarks

Tolerance of approximation is defined internally by Revit to be adequate for display purposes.

Examples

CopyC#
private void TriangulateFace(Face face)
{
    // Get mesh
    Mesh mesh = face.Triangulate();
    for (int i = 0; i < mesh.NumTriangles; i++)
    {
        MeshTriangle triangle = mesh.get_Triangle(i);
        XYZ vertex1 = triangle.get_Vertex(0);
        XYZ vertex2 = triangle.get_Vertex(1);
        XYZ vertex3 = triangle.get_Vertex(2);
    }
}
CopyVB.NET
Private Sub TriangulateFace(ByVal face As Autodesk.Revit.DB.Face)
    ' Get mesh
    Dim mesh As Mesh = face.Triangulate()
    Dim i As Integer = 0
    While i < mesh.NumTriangles
        Dim triangle As MeshTriangle = mesh.Triangle(i)
        Dim vertex1 As Autodesk.Revit.DB.XYZ = triangle.Vertex(0)
        Dim vertex2 As Autodesk.Revit.DB.XYZ = triangle.Vertex(1)
        Dim vertex3 As Autodesk.Revit.DB.XYZ = triangle.Vertex(2)
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While
End Sub

See Also

Face Class
Triangulate Overload


Triangulate Method (Double)

[image]

Revit 2013 API
Face..::..Triangulate Method (Double)
Face Class See Also Send Feedback
Returns a triangular mesh approximation to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Mesh Triangulate(
    double levelOfDetail
)
Visual Basic
Public Function Triangulate ( _
    levelOfDetail As Double _
) As Mesh
Visual C++
public:
Mesh^ Triangulate(
    double levelOfDetail
)

Parameters

levelOfDetail
Type: System..::..Double
The level of detail. Its range is from 0 to 1. 0 is the lowest level of detail and 1 is the highest.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when level of detail is less than 0 or greater than 1.

See Also

Face Class
Triangulate Overload


Face Properties

[image] [image]

Revit 2013 API
Face Properties
Face Class See Also Send Feedback

The Face type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command.
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction.
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate)
Public property | MaterialElementId | Element ID of the material from which this face is composed.
Public property | Period | The period of this face in the specified parametric direction.
Public property | Reference | Returns a stable reference to the face.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Face Class


Area Property

[image]

Revit 2013 API
Face..::..Area Property
Face Class See Also Send Feedback
The area of this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

Remarks

Returns zero if fails to compute the area. Estimates the area of this face by integrating tessellated edges. Will slightly underestimate when the edges are curved.

See Also

Face Class


EdgeLoops Property

[image]

Revit 2013 API
Face..::..EdgeLoops Property
Face Class See Also Send Feedback
Each edge loop is a closed boundary of the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArrayArray EdgeLoops { get; }
Visual Basic
Public ReadOnly Property EdgeLoops As EdgeArrayArray
    Get
Visual C++
public:
property EdgeArrayArray^ EdgeLoops {
    EdgeArrayArray^ get ();
}

See Also

Face Class


HasRegions Property

[image]

Revit 2013 API
Face..::..HasRegions Property
Face Class See Also Send Feedback
Reports if the face contains regions created with the Split Face command.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasRegions { get; }
Visual Basic
Public ReadOnly Property HasRegions As Boolean
    Get
Visual C++
public:
property bool HasRegions {
    bool get ();
}

See Also

Face Class


IsCyclic Property

[image]

Revit 2013 API
Face..::..IsCyclic Property
Face Class See Also Send Feedback
The boolean value that indicates whether this face is periodic in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    int paramIdx
] { get; }
Visual Basic
Public ReadOnly Property IsCyclic ( _
    paramIdx As Integer _
) As Boolean
    Get
Visual C++
public:
property bool IsCyclic[int paramIdx] {
    bool get (int paramIdx);
}

Parameters

paramIdx
Type: System..::..Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

True if this face is cyclic; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.

See Also

Face Class


IsTwoSided Property

[image]

Revit 2013 API
Face..::..IsTwoSided Property
Face Class See Also Send Feedback
Determines if a face is two-sided (degenerate)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsTwoSided { get; }
Visual Basic
Public Overridable ReadOnly Property IsTwoSided As Boolean
    Get
Visual C++
public:
virtual property bool IsTwoSided {
    bool get ();
}

See Also

Face Class


MaterialElementId Property

[image]

Revit 2013 API
Face..::..MaterialElementId Property
Face Class See Also Send Feedback
Element ID of the material from which this face is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Face Class


Period Property

[image]

Revit 2013 API
Face..::..Period Property
Face Class See Also Send Feedback
The period of this face in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int paramIdx
] { get; }
Visual Basic
Public ReadOnly Property Period ( _
    paramIdx As Integer _
) As Double
    Get
Visual C++
public:
property double Period[int paramIdx] {
    double get (int paramIdx);
}

Parameters

paramIdx
Type: System..::..Int32
Use 0 for u coordinate and 1 for v coordinate.

Return Value

The real number equal to the period of this face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an attempt is made to access the flag with an index larger than dimension.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this face is not cyclic in the specified direction.

See Also

Face Class


Reference Property

[image]

Revit 2013 API
Face..::..Reference Property
Face Class See Also Send Feedback
Returns a stable reference to the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Face Class


FaceArray Class

[image]

Revit 2013 API
FaceArray Class
Members See Also Send Feedback
An array that contains faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FaceArray : APIObject, IEnumerable
Visual Basic
Public Class FaceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FaceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FaceArray

See Also

FaceArray Members


FaceArray Members

[image] [image]

Revit 2013 API
FaceArray Members
FaceArray Class Constructors Methods Properties See Also Send Feedback

The FaceArray type exposes the following members.

Constructors

 | Name | Description
Public method | FaceArray | Initializes a new instance of the FaceArray class

Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


FaceArray Constructor

[image]

Revit 2013 API
FaceArray Constructor
FaceArray Class See Also Send Feedback
Initializes a new instance of the FaceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FaceArray()
Visual Basic
Public Sub New
Visual C++
public:
FaceArray()

See Also

FaceArray Class


FaceArray Methods

[image] [image]

Revit 2013 API
FaceArray Methods
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the face to the end of the array.
Public method | Clear | Removes every face from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified face into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArray Class


Append Method

[image]

Revit 2013 API
FaceArray..::..Append Method
FaceArray Class See Also Send Feedback
Add the face to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Face item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Face _
)
Visual C++
public:
virtual void Append(
    Face^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Face
The face to be added.

See Also

FaceArray Class


Clear Method

[image]

Revit 2013 API
FaceArray..::..Clear Method
FaceArray Class See Also Send Feedback
Removes every face from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FaceArray Class


ForwardIterator Method

[image]

Revit 2013 API
FaceArray..::..ForwardIterator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FaceArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FaceArray Class


GetEnumerator Method

[image]

Revit 2013 API
FaceArray..::..GetEnumerator Method
FaceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FaceArray Class


Insert Method

[image]

Revit 2013 API
FaceArray..::..Insert Method
FaceArray Class See Also Send Feedback
Insert the specified face into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Face item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Face, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Face^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Face
The face to be inserted into the array.
index
Type: System..::..Int32
The face will be inserted before this index.

Return Value

Returns whether the face was inserted into the array.

See Also

FaceArray Class


ReverseIterator Method

[image]

Revit 2013 API
FaceArray..::..ReverseIterator Method
FaceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FaceArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FaceArrayIterator
Visual C++
public:
virtual FaceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FaceArray Class


FaceArray Properties

[image] [image]

Revit 2013 API
FaceArray Properties
FaceArray Class See Also Send Feedback

The FaceArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a face at a specified index within the array.
Public property | Size | Returns the number of faces that are in the array.

See Also

FaceArray Class


IsEmpty Property

[image]

Revit 2013 API
FaceArray..::..IsEmpty Property
FaceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FaceArray Class


Item Property

[image]

Revit 2013 API
FaceArray..::..Item Property
FaceArray Class See Also Send Feedback
Gets or sets a face at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Face this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Face
    Get
    Set
Visual C++
public:
virtual property Face^ Item[int index] {
    Face^ get (int index);
    void set (int index, Face^ value);
}

Parameters

index
Type: System..::..Int32
The index of the face to be set or retrieved.

Return Value

Returns the face at the specified index.

See Also

FaceArray Class


Size Property

[image]

Revit 2013 API
FaceArray..::..Size Property
FaceArray Class See Also Send Feedback
Returns the number of faces that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FaceArray Class


FaceArrayIterator Class

[image]

Revit 2013 API
FaceArrayIterator Class
Members See Also Send Feedback
An iterator to a face array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FaceArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FaceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FaceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FaceArrayIterator

See Also

FaceArrayIterator Members


FaceArrayIterator Members

[image] [image]

Revit 2013 API
FaceArrayIterator Members
FaceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FaceArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


FaceArrayIterator Constructor

[image]

Revit 2013 API
FaceArrayIterator Constructor
FaceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FaceArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
FaceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FaceArrayIterator Class


FaceArrayIterator Methods

[image] [image]

Revit 2013 API
FaceArrayIterator Methods
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
FaceArrayIterator..::..MoveNext Method
FaceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


Reset Method

[image]

Revit 2013 API
FaceArrayIterator..::..Reset Method
FaceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FaceArrayIterator Class


FaceArrayIterator Properties

[image] [image]

Revit 2013 API
FaceArrayIterator Properties
FaceArrayIterator Class See Also Send Feedback

The FaceArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FaceArrayIterator Class


Current Property

[image]

Revit 2013 API
FaceArrayIterator..::..Current Property
FaceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FaceArrayIterator Class


FaceSplitter Class

[image]

Revit 2013 API
FaceSplitter Class
Members See Also Send Feedback
Represents an element that splits a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FaceSplitter : Element
Visual Basic
Public Class FaceSplitter _
    Inherits Element
Visual C++
public ref class FaceSplitter : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FaceSplitter

See Also

FaceSplitter Members


FaceSplitter Members

[image] [image]

Revit 2013 API
FaceSplitter Members
FaceSplitter Class Methods Properties See Also Send Feedback

The FaceSplitter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SplitElementId | The id of the element whose face is split by this element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceSplitter Class


FaceSplitter Methods

[image] [image]

Revit 2013 API
FaceSplitter Methods
FaceSplitter Class See Also Send Feedback

The FaceSplitter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceSplitter Class


FaceSplitter Properties

[image] [image]

Revit 2013 API
FaceSplitter Properties
FaceSplitter Class See Also Send Feedback

The FaceSplitter type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SplitElementId | The id of the element whose face is split by this element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceSplitter Class


Parameter Property

[image] [image]

Revit 2013 API
FaceSplitter..::..Parameter Property
FaceSplitter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FaceSplitter Class
FaceSplitter Members


SplitElementId Property

[image]

Revit 2013 API
FaceSplitter..::..SplitElementId Property
FaceSplitter Class See Also Send Feedback
The id of the element whose face is split by this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId SplitElementId { get; }
Visual Basic
Public ReadOnly Property SplitElementId As ElementId
    Get
Visual C++
public:
property ElementId^ SplitElementId {
    ElementId^ get ();
}

See Also

FaceSplitter Class


FacetingUtils Class

[image]

Revit 2013 API
FacetingUtils Class
Members See Also Send Feedback
This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FacetingUtils : IDisposable
Visual Basic
Public Class FacetingUtils _
    Implements IDisposable
Visual C++
public ref class FacetingUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FacetingUtils

See Also

FacetingUtils Members


FacetingUtils Members

[image] [image]

Revit 2013 API
FacetingUtils Members
FacetingUtils Class Methods See Also Send Feedback

The FacetingUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertTrianglesToQuads | Replaces pairs of adjacent, coplanar triangles by quadrilaterals.
Public method | Dispose | Releases all resources used by the FacetingUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FacetingUtils Class


FacetingUtils Methods

[image] [image]

Revit 2013 API
FacetingUtils Methods
FacetingUtils Class See Also Send Feedback

The FacetingUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertTrianglesToQuads | Replaces pairs of adjacent, coplanar triangles by quadrilaterals.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FacetingUtils Class


ConvertTrianglesToQuads Method

[image]

Revit 2013 API
FacetingUtils..::..ConvertTrianglesToQuads Method
FacetingUtils Class See Also Send Feedback
Replaces pairs of adjacent, coplanar triangles by quadrilaterals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<TriOrQuadFacet> ConvertTrianglesToQuads(
    TriangulationInterface triangulation
)
Visual Basic
Public Shared Function ConvertTrianglesToQuads ( _
    triangulation As TriangulationInterface _
) As IList(Of TriOrQuadFacet)
Visual C++
public:
static IList<TriOrQuadFacet^>^ ConvertTrianglesToQuads(
    TriangulationInterface^ triangulation
)

Parameters

triangulation
Type: Autodesk.Revit.DB..::..TriangulationInterface
A triangulated face, shell, or solid.

Return Value

A collection of triangles and quadrilaterals representing the original triangulated object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

FacetingUtils Class


Dispose Method

[image]

Revit 2013 API
FacetingUtils..::..Dispose Method
FacetingUtils Class See Also Send Feedback
Releases all resources used by the FacetingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FacetingUtils Class


FaceWall Class

[image]

Revit 2013 API
FaceWall Class
Members See Also Send Feedback
A wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FaceWall : HostObject
Visual Basic
Public Class FaceWall _
    Inherits HostObject
Visual C++
public ref class FaceWall : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..FaceWall

See Also

FaceWall Members


FaceWall Members

[image] [image]

Revit 2013 API
FaceWall Members
FaceWall Class Methods Properties See Also Send Feedback

The FaceWall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceWall Class


FaceWall Methods

[image] [image]

Revit 2013 API
FaceWall Methods
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a wall attached to a non-vertical massing face.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFaceReferenceForFaceWall | Identifies if a reference may be used as the parent of a face wall.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsWallTypeValidForFaceWall | Identifies if a wall type may be applied to a face wall.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FaceWall Class


Create Method

[image]

Revit 2013 API
FaceWall..::..Create Method
FaceWall Class See Also Send Feedback
Creates a new instance of a wall attached to a non-vertical massing face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FaceWall Create(
    Document document,
    ElementId wallType,
    WallLocationLine locationLine,
    Reference faceReference
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    wallType As ElementId, _
    locationLine As WallLocationLine, _
    faceReference As Reference _
) As FaceWall
Visual C++
public:
static FaceWall^ Create(
    Document^ document,
    ElementId^ wallType,
    WallLocationLine locationLine,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
wallType
Type: Autodesk.Revit.DB..::..ElementId
The wall type. This must be a wall type accepted by IsWallTypeValidForFaceWall()
locationLine
Type: Autodesk.Revit.DB..::..WallLocationLine
The alignment of the wall location line.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference from the massing face. This must pass IsValidFaceReferenceForFaceWall()

Return Value

The newly created face wall.

Remarks

This method will regenerate the document.

Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the newly created face wall is going to be joined to surrounding structures.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element wallType does not exist in the document -or- The document does not allow creation of a face wall. -or- This wall type cannot be applied to a face wall. -or- This reference cannot be applied to a face wall.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

FaceWall Class


IsValidFaceReferenceForFaceWall Method

[image]

Revit 2013 API
FaceWall..::..IsValidFaceReferenceForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a reference may be used as the parent of a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidFaceReferenceForFaceWall(
    Document document,
    Reference faceReference
)
Visual Basic
Public Shared Function IsValidFaceReferenceForFaceWall ( _
    document As Document, _
    faceReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidFaceReferenceForFaceWall(
    Document^ document,
    Reference^ faceReference
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference.

Return Value

True if the reference is valid as a parent to a face wall, false otherwise.

Remarks

The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FaceWall Class


IsWallTypeValidForFaceWall Method

[image]

Revit 2013 API
FaceWall..::..IsWallTypeValidForFaceWall Method
FaceWall Class See Also Send Feedback
Identifies if a wall type may be applied to a face wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsWallTypeValidForFaceWall(
    Document document,
    ElementId wallType
)
Visual Basic
Public Shared Function IsWallTypeValidForFaceWall ( _
    document As Document, _
    wallType As ElementId _
) As Boolean
Visual C++
public:
static bool IsWallTypeValidForFaceWall(
    Document^ document,
    ElementId^ wallType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
wallType
Type: Autodesk.Revit.DB..::..ElementId
The wall type.

Return Value

True if the wall type is valid for face wall, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FaceWall Class


FaceWall Properties

[image] [image]

Revit 2013 API
FaceWall Properties
FaceWall Class See Also Send Feedback

The FaceWall type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FaceWall Class


Parameter Property

[image] [image]

Revit 2013 API
FaceWall..::..Parameter Property
FaceWall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FaceWall Class
FaceWall Members


FailureDefinition Class

[image]

Revit 2013 API
FailureDefinition Class
Members See Also Send Feedback
Defines persistent information about a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinition : IDisposable
Visual Basic
Public Class FailureDefinition _
    Implements IDisposable
Visual C++
public ref class FailureDefinition : IDisposable

Remarks

Each failure that can be potentially posted in Revit must be based on a FailureDefinition object that contains some persistent information about failure such as identity, severity, basic description text, types of resolution and default resolution. Each FailureMessage, which contains variable part of the information for a specific failure when it occurs, is created with a reference to a registered FailureDefinition. In order to be able to post a failure, one must define and register it via FailureDefinition object during Revit Application startup.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinition

See Also

FailureDefinition Members


FailureDefinition Members

[image] [image]

Revit 2013 API
FailureDefinition Members
FailureDefinition Class Methods Properties See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose | Releases all resources used by the FailureDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Severity | The severity of the failure.

See Also

FailureDefinition Class


FailureDefinition Methods

[image] [image]

Revit 2013 API
FailureDefinition Methods
FailureDefinition Class See Also Send Feedback

The FailureDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddResolutionType | Adds a type of possible resolution for the failure.
 | CreateFailureDefinition | Creates an instance of a FailureDefinition.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinition Class


AddResolutionType Method

[image]

Revit 2013 API
FailureDefinition..::..AddResolutionType Method
FailureDefinition Class See Also Send Feedback
Adds a type of possible resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition AddResolutionType(
    FailureResolutionType type,
    string caption,
    Type classOfResolution
)
Visual Basic
Public Function AddResolutionType ( _
    type As FailureResolutionType, _
    caption As String, _
    classOfResolution As Type _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ AddResolutionType(
    FailureResolutionType type,
    String^ caption,
    Type^ classOfResolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the resolution to add. The type of resolution can be used only once for the FailureDefinition.
caption
Type: System..::..String
A simple description of the resolution.
classOfResolution
Type: System..::..Type
The runtime class of the resolution. Used to ensure that the actual FailureResoution object added to the instance of FailureMessage belongs to an applicable class.

Return Value

The FailureDefinition.

Remarks

In order to inform Revit what failure resolutions can be possibly used with a given failure, a FailureDefinition must contain a full list of resolution types applicable to the failure, including user-visible caption and runtime class of the resolution. The number of resolutions is not limited. The first added resolution becomes the default resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type has already been added as a resolution to the FailureDefinition. -or- The input classOfResolution is not a subclass of FailureResolution.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class


CreateFailureDefinition Method

[image]

Revit 2013 API
FailureDefinition..::..CreateFailureDefinition Method
FailureDefinition Class Example See Also Send Feedback
Creates an instance of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FailureDefinition CreateFailureDefinition(
    FailureDefinitionId id,
    FailureSeverity severity,
    string messageString
)
Visual Basic
Public Shared Function CreateFailureDefinition ( _
    id As FailureDefinitionId, _
    severity As FailureSeverity, _
    messageString As String _
) As FailureDefinition
Visual C++
public:
static FailureDefinition^ CreateFailureDefinition(
    FailureDefinitionId^ id,
    FailureSeverity severity,
    String^ messageString
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
Unique identifier of the failure.
severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The severity of the failure. Cannot be FailureSeverity::None.
messageString
Type: System..::..String
A user-visible string describing the failure.

Return Value

The created FailureDefinition instance.

Remarks

The newly created FailureDefinition will be added to the FailureDefinitionRegistry. Because FailureDefinition could only be registered when Revit starting up, this function cannot be used after Revit has already started. Throws InvalidOperationException if invoked after Revit start-up is completed.

Examples

CopyC#
// define a new failure id for a warning about walls
FailureDefinitionId warnId =
    new FailureDefinitionId(new Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"));

// register the new warning using FailureDefinition
FailureDefinition failDef = FailureDefinition.CreateFailureDefinition(warnId,
    FailureSeverity.Warning,
    "Wall is too big (>100'). Performance problems may result.");
CopyVB.NET
' define a new failure id for a warning about walls
Dim warnId As New FailureDefinitionId(New Guid("FB4F5AF3-42BB-4371-B559-FB1648D5B4D1"))

' register the new warning using FailureDefinition
Dim failDef As FailureDefinition = FailureDefinition.CreateFailureDefinition(warnId, FailureSeverity.Warning, "Wall is too big (>100'). Performance problems may result.")

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id of failure definition is not valid. -or- The id of failure definition is already used to register another FailureDefinition. -or- The severity of failures cannot be FailureSeverity::None. -or- Message string is empty or contains invalid characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinition Class


Dispose Method

[image]

Revit 2013 API
FailureDefinition..::..Dispose Method
FailureDefinition Class See Also Send Feedback
Releases all resources used by the FailureDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinition Class


GetApplicableResolutionTypes Method

[image]

Revit 2013 API
FailureDefinition..::..GetApplicableResolutionTypes Method
FailureDefinition Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

See Also

FailureDefinition Class


GetDefaultResolutionType Method

[image]

Revit 2013 API
FailureDefinition..::..GetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The Default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


GetDescriptionText Method

[image]

Revit 2013 API
FailureDefinition..::..GetDescriptionText Method
FailureDefinition Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Remarks

Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"

See Also

FailureDefinition Class


GetResolutionCaption Method

[image]

Revit 2013 API
FailureDefinition..::..GetResolutionCaption Method
FailureDefinition Class See Also Send Feedback
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


HasResolutions Method

[image]

Revit 2013 API
FailureDefinition..::..HasResolutions Method
FailureDefinition Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

See Also

FailureDefinition Class


IsResolutionApplicable Method

[image]

Revit 2013 API
FailureDefinition..::..IsResolutionApplicable Method
FailureDefinition Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

See Also

FailureDefinition Class


SetDefaultResolutionType Method

[image]

Revit 2013 API
FailureDefinition..::..SetDefaultResolutionType Method
FailureDefinition Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinition SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Function SetDefaultResolutionType ( _
    type As FailureResolutionType _
) As FailureDefinition
Visual C++
public:
FailureDefinition^ SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Return Value

The FailureDefinition.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | FailureDefinition does not have any resolutions.

See Also

FailureDefinition Class


FailureDefinition Properties

[image] [image]

Revit 2013 API
FailureDefinition Properties
FailureDefinition Class See Also Send Feedback

The FailureDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Severity | The severity of the failure.

See Also

FailureDefinition Class


Severity Property

[image]

Revit 2013 API
FailureDefinition..::..Severity Property
FailureDefinition Class See Also Send Feedback
The severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity Severity { get; }
Visual Basic
Public ReadOnly Property Severity As FailureSeverity
    Get
Visual C++
public:
property FailureSeverity Severity {
    FailureSeverity get ();
}

See Also

FailureDefinition Class


FailureDefinitionAccessor Class

[image]

Revit 2013 API
FailureDefinitionAccessor Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionAccessor : IDisposable
Visual Basic
Public Class FailureDefinitionAccessor _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionAccessor : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinitionAccessor

See Also

FailureDefinitionAccessor Members


FailureDefinitionAccessor Members

[image] [image]

Revit 2013 API
FailureDefinitionAccessor Members
FailureDefinitionAccessor Class Methods See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class


FailureDefinitionAccessor Methods

[image] [image]

Revit 2013 API
FailureDefinitionAccessor Methods
FailureDefinitionAccessor Class See Also Send Feedback

The FailureDefinitionAccessor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetApplicableResolutionTypes | Retrieves a list of resolution types applicable to the failure.
Public method | GetDefaultResolutionType | Retrieves the default resolution type for the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetId | Retrieves the unique identifier of the FailureDefinition.
Public method | GetResolutionCaption | Retrieves the caption for a specific resolution type.
Public method | GetSeverity | Retrieves severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutions | Checks if the FailureDefinition has at least one resolution.
Public method | IsResolutionApplicable | Checks if the given resolution type is applicable to the failure.
Public method | SetDefaultResolutionType | Sets the default resolution type for the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionAccessor Class


Dispose Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..Dispose Method
FailureDefinitionAccessor Class See Also Send Feedback
Releases all resources used by the FailureDefinitionAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinitionAccessor Class


GetApplicableResolutionTypes Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetApplicableResolutionTypes Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves a list of resolution types applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetApplicableResolutionTypes()
Visual Basic
Public Function GetApplicableResolutionTypes As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetApplicableResolutionTypes()

Return Value

The list of resolution types applicable to the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetDefaultResolutionType Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetDefaultResolutionType()
Visual Basic
Public Function GetDefaultResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetDefaultResolutionType()

Return Value

The default resolution type for the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


GetDescriptionText Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetDescriptionText Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Remarks

Retrieved description text for built-in Revit failures is localized. The result may vary from the description text retrieved from the corresponding FailureMessage. A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings, that will be used to resolve them. A FailureMessage will contain "specific" strings. So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetId Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetId Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the unique identifier of the FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetId()
Visual Basic
Public Function GetId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetId()

Return Value

The unique identifier of the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


GetResolutionCaption Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetResolutionCaption Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves the caption for a specific resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetResolutionCaption(
    FailureResolutionType type
)
Visual Basic
Public Function GetResolutionCaption ( _
    type As FailureResolutionType _
) As String
Visual C++
public:
String^ GetResolutionCaption(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type.

Return Value

The caption of the resolution.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


GetSeverity Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..GetSeverity Method
FailureDefinitionAccessor Class See Also Send Feedback
Retrieves severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


HasResolutions Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..HasResolutions Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the FailureDefinition has at least one resolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if at least one resolution is defined in the FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


IsResolutionApplicable Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..IsResolutionApplicable Method
FailureDefinitionAccessor Class See Also Send Feedback
Checks if the given resolution type is applicable to the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsResolutionApplicable(
    FailureResolutionType type
)
Visual Basic
Public Function IsResolutionApplicable ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsResolutionApplicable(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The resolution type to check.

Return Value

True if the given resolution type is applicable to the failure, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized.

See Also

FailureDefinitionAccessor Class


SetDefaultResolutionType Method

[image]

Revit 2013 API
FailureDefinitionAccessor..::..SetDefaultResolutionType Method
FailureDefinitionAccessor Class See Also Send Feedback
Sets the default resolution type for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetDefaultResolutionType(
    FailureResolutionType type
)
Visual Basic
Public Sub SetDefaultResolutionType ( _
    type As FailureResolutionType _
)
Visual C++
public:
void SetDefaultResolutionType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution to be used as default.

Remarks

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the type is not applicable to the failure.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FailureDefinitionAccessor has not been properly initialized. -or- FailureDefinition does not have any resolutions.

See Also

FailureDefinitionAccessor Class


FailureDefinitionId Class

[image]

Revit 2013 API
FailureDefinitionId Class
Members See Also Send Feedback
The unique identifier of a FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionId : GuidEnum
Visual Basic
Public Class FailureDefinitionId _
    Inherits GuidEnum
Visual C++
public ref class FailureDefinitionId : public GuidEnum

Remarks

Each possible failure in Revit must be defined and registered during Revit application startup by creating a FailureDefinition object. Unique FailureDefinitionId must be used as a key to register FailureDefinition. Those unique FailureDefinitionId should be created using GUID generation tool. Later FailureDefinitionId can be used to lookup FailureDefinition in FailureDefinitionRegistry, and create and post FailureMessages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..FailureDefinitionId

See Also

FailureDefinitionId Members


FailureDefinitionId Members

[image] [image]

Revit 2013 API
FailureDefinitionId Members
FailureDefinitionId Class Constructors Methods Operators Properties See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Constructors

 | Name | Description
Public method | FailureDefinitionId | Creates a new FailureDefinitionId instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionId Constructor

[image]

Revit 2013 API
FailureDefinitionId Constructor
FailureDefinitionId Class See Also Send Feedback
Creates a new FailureDefinitionId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FailureDefinitionId(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
FailureDefinitionId(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the FailureDefinitionId.

See Also

FailureDefinitionId Class


FailureDefinitionId Methods

[image] [image]

Revit 2013 API
FailureDefinitionId Methods
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionId Class


FailureDefinitionId Operators

[image] [image]

Revit 2013 API
FailureDefinitionId Operators
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Operators

Name | Description
Equality | Compares two FailureDefinitionId instances.
Inequality | Compares two FailureDefinitionId instances.

See Also

FailureDefinitionId Class


Equality Operator

[image]

Revit 2013 API
FailureDefinitionId..::..Equality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic
Public Shared Operator = ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator ==(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are identical, false if they are different.

See Also

FailureDefinitionId Class


Inequality Operator

[image]

Revit 2013 API
FailureDefinitionId..::..Inequality Operator
FailureDefinitionId Class See Also Send Feedback
Compares two FailureDefinitionId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    FailureDefinitionId first,
    FailureDefinitionId second
)
Visual Basic
Public Shared Operator <> ( _
    first As FailureDefinitionId, _
    second As FailureDefinitionId _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureDefinitionId^ first,
    FailureDefinitionId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The first FailureDefinitionId.
second
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The second FailureDefinitionId.

Return Value

True if the inputs are different, false if they are identical.

See Also

FailureDefinitionId Class


FailureDefinitionId Properties

[image] [image]

Revit 2013 API
FailureDefinitionId Properties
FailureDefinitionId Class See Also Send Feedback

The FailureDefinitionId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

FailureDefinitionId Class


FailureDefinitionRegistry Class

[image]

Revit 2013 API
FailureDefinitionRegistry Class
Members See Also Send Feedback
The global registry for all FailureDefinitions in the Revit session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureDefinitionRegistry : IDisposable
Visual Basic
Public Class FailureDefinitionRegistry _
    Implements IDisposable
Visual C++
public ref class FailureDefinitionRegistry : IDisposable

Remarks

When a FailureDefinition is created, it will be registered in this registry automatically. Registration is allowed only during Revit Application startup - after that FailureDefinitionRegistry is locked and creation of new FailureDefinitions is not allowed. There is only one instance of FailureDefinitionRegistry in session. GetFailureDefinitionRegistry()()()()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureDefinitionRegistry

See Also

FailureDefinitionRegistry Members


FailureDefinitionRegistry Members

[image] [image]

Revit 2013 API
FailureDefinitionRegistry Members
FailureDefinitionRegistry Class Methods See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureDefinitionRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class


FailureDefinitionRegistry Methods

[image] [image]

Revit 2013 API
FailureDefinitionRegistry Methods
FailureDefinitionRegistry Class See Also Send Feedback

The FailureDefinitionRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindFailureDefinition | Finds a specific FailureDefinition by a given FailureDefinitionId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListAllFailureDefinitions | Retrieves all the registered FailureDefinitions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureDefinitionRegistry Class


Dispose Method

[image]

Revit 2013 API
FailureDefinitionRegistry..::..Dispose Method
FailureDefinitionRegistry Class See Also Send Feedback
Releases all resources used by the FailureDefinitionRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureDefinitionRegistry Class


FindFailureDefinition Method

[image]

Revit 2013 API
FailureDefinitionRegistry..::..FindFailureDefinition Method
FailureDefinitionRegistry Class See Also Send Feedback
Finds a specific FailureDefinition by a given FailureDefinitionId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionAccessor FindFailureDefinition(
    FailureDefinitionId id
)
Visual Basic
Public Function FindFailureDefinition ( _
    id As FailureDefinitionId _
) As FailureDefinitionAccessor
Visual C++
public:
FailureDefinitionAccessor^ FindFailureDefinition(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
The id of the FailureDefinition.

Return Value

The accessor of the found FailureDefinition, or null, if the FailureDefinition was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureDefinitionRegistry Class


ListAllFailureDefinitions Method

[image]

Revit 2013 API
FailureDefinitionRegistry..::..ListAllFailureDefinitions Method
FailureDefinitionRegistry Class See Also Send Feedback
Retrieves all the registered FailureDefinitions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureDefinitionAccessor> ListAllFailureDefinitions()
Visual Basic
Public Function ListAllFailureDefinitions As IList(Of FailureDefinitionAccessor)
Visual C++
public:
IList<FailureDefinitionAccessor^>^ ListAllFailureDefinitions()

Return Value

All the registered FailureDefinitions.

See Also

FailureDefinitionRegistry Class


FailureHandlingOptions Class

[image]

Revit 2013 API
FailureHandlingOptions Class
Members See Also Send Feedback
Options to control how failures (if any occurred during the transaction) should be handled at the time the transaction is being ended.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureHandlingOptions : IDisposable
Visual Basic
Public Class FailureHandlingOptions _
    Implements IDisposable
Visual C++
public ref class FailureHandlingOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureHandlingOptions

See Also

FailureHandlingOptions Members


FailureHandlingOptions Members

[image] [image]

Revit 2013 API
FailureHandlingOptions Members
FailureHandlingOptions Class Methods See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureHandlingOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetClearAfterRollback | Checks if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Checks if showing of mini-warning dialog should be delayed till the end of next transaction.
Public method | GetFailuresPreprocessor | Getting a callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Checks if error handling dialog at the end of transaction should be modal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransactionFinalizer | Getting a callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetClearAfterRollback | Set the flag to clear all posted failures silently if transaction is being rolled back intentionally and delivering failures to the user is not desired.
Public method | SetDelayedMiniWarnings | Set the flag to delay showing of mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) till the end of next transaction.
Public method | SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Setting a callback to be executed after transaction is completed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class


FailureHandlingOptions Methods

[image] [image]

Revit 2013 API
FailureHandlingOptions Methods
FailureHandlingOptions Class See Also Send Feedback

The FailureHandlingOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetClearAfterRollback | Checks if all posted failures should be removed silently when transaction is being rolled back.
Public method | GetDelayedMiniWarnings | Checks if showing of mini-warning dialog should be delayed till the end of next transaction.
Public method | GetFailuresPreprocessor | Getting a callback to be invoked in the beginning of failure processing.
Public method | GetForcedModalHandling | Checks if error handling dialog at the end of transaction should be modal.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTransactionFinalizer | Getting a callback to be executed after transaction is completed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetClearAfterRollback | Set the flag to clear all posted failures silently if transaction is being rolled back intentionally and delivering failures to the user is not desired.
Public method | SetDelayedMiniWarnings | Set the flag to delay showing of mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) till the end of next transaction.
Public method | SetFailuresPreprocessor | Setting a callback to be invoked in the beginning of failure processing.
Public method | SetForcedModalHandling | Set the flag whether it pops modal error dialog if the transaction failed to finish.
Public method | SetTransactionFinalizer | Setting a callback to be executed after transaction is completed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureHandlingOptions Class


Dispose Method

[image]

Revit 2013 API
FailureHandlingOptions..::..Dispose Method
FailureHandlingOptions Class See Also Send Feedback
Releases all resources used by the FailureHandlingOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureHandlingOptions Class


GetClearAfterRollback Method

[image]

Revit 2013 API
FailureHandlingOptions..::..GetClearAfterRollback Method
FailureHandlingOptions Class See Also Send Feedback
Checks if all posted failures should be removed silently when transaction is being rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool GetClearAfterRollback()
Visual Basic
Public Function GetClearAfterRollback As Boolean
Visual C++
public:
bool GetClearAfterRollback()

Return Value

True if all posted failures should be removed silently when transaction is being rolled back.

See Also

FailureHandlingOptions Class


GetDelayedMiniWarnings Method

[image]

Revit 2013 API
FailureHandlingOptions..::..GetDelayedMiniWarnings Method
FailureHandlingOptions Class See Also Send Feedback
Checks if showing of mini-warning dialog should be delayed till the end of next transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool GetDelayedMiniWarnings()
Visual Basic
Public Function GetDelayedMiniWarnings As Boolean
Visual C++
public:
bool GetDelayedMiniWarnings()

Return Value

True if showing of mini-warning dialog should be delayed till the end of next transaction.

See Also

FailureHandlingOptions Class


GetFailuresPreprocessor Method

[image]

Revit 2013 API
FailureHandlingOptions..::..GetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback
Getting a callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IFailuresPreprocessor GetFailuresPreprocessor()
Visual Basic
Public Function GetFailuresPreprocessor As IFailuresPreprocessor
Visual C++
public:
IFailuresPreprocessor^ GetFailuresPreprocessor()

Return Value

The callback to be invoked in the beginning of failure processing.

See Also

FailureHandlingOptions Class


GetForcedModalHandling Method

[image]

Revit 2013 API
FailureHandlingOptions..::..GetForcedModalHandling Method
FailureHandlingOptions Class See Also Send Feedback
Checks if error handling dialog at the end of transaction should be modal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool GetForcedModalHandling()
Visual Basic
Public Function GetForcedModalHandling As Boolean
Visual C++
public:
bool GetForcedModalHandling()

Return Value

True if error handling dialog at the end of transaction should be modal.

See Also

FailureHandlingOptions Class


GetTransactionFinalizer Method

[image]

Revit 2013 API
FailureHandlingOptions..::..GetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback
Getting a callback to be executed after transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ITransactionFinalizer GetTransactionFinalizer()
Visual Basic
Public Function GetTransactionFinalizer As ITransactionFinalizer
Visual C++
public:
ITransactionFinalizer^ GetTransactionFinalizer()

Return Value

The callback to be executed after transaction is completed.

See Also

FailureHandlingOptions Class


SetClearAfterRollback Method

[image]

Revit 2013 API
FailureHandlingOptions..::..SetClearAfterRollback Method
FailureHandlingOptions Class See Also Send Feedback
Set the flag to clear all posted failures silently if transaction is being rolled back intentionally and delivering failures to the user is not desired.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetClearAfterRollback(
    bool bFlag
)
Visual Basic
Public Function SetClearAfterRollback ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetClearAfterRollback(
    bool bFlag
)

Parameters

bFlag
Type: System..::..Boolean

See Also

FailureHandlingOptions Class


SetDelayedMiniWarnings Method

[image]

Revit 2013 API
FailureHandlingOptions..::..SetDelayedMiniWarnings Method
FailureHandlingOptions Class See Also Send Feedback
Set the flag to delay showing of mini-warning dialog (if one is to be shown as a result of warnings in the current transaction) till the end of next transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetDelayedMiniWarnings(
    bool bFlag
)
Visual Basic
Public Function SetDelayedMiniWarnings ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetDelayedMiniWarnings(
    bool bFlag
)

Parameters

bFlag
Type: System..::..Boolean

Remarks

This controls mini-warnings only; does not make sense in modal mode setting it to true will postpone clearing mini-warning dialogs until the next transaction is finished.

See Also

FailureHandlingOptions Class


SetFailuresPreprocessor Method

[image]

Revit 2013 API
FailureHandlingOptions..::..SetFailuresPreprocessor Method
FailureHandlingOptions Class See Also Send Feedback
Setting a callback to be invoked in the beginning of failure processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetFailuresPreprocessor(
    IFailuresPreprocessor preprocessor
)
Visual Basic
Public Function SetFailuresPreprocessor ( _
    preprocessor As IFailuresPreprocessor _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetFailuresPreprocessor(
    IFailuresPreprocessor^ preprocessor
)

Parameters

preprocessor
Type: Autodesk.Revit.DB..::..IFailuresPreprocessor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class


SetForcedModalHandling Method

[image]

Revit 2013 API
FailureHandlingOptions..::..SetForcedModalHandling Method
FailureHandlingOptions Class See Also Send Feedback
Set the flag whether it pops modal error dialog if the transaction failed to finish.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetForcedModalHandling(
    bool bFlag
)
Visual Basic
Public Function SetForcedModalHandling ( _
    bFlag As Boolean _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetForcedModalHandling(
    bool bFlag
)

Parameters

bFlag
Type: System..::..Boolean

See Also

FailureHandlingOptions Class


SetTransactionFinalizer Method

[image]

Revit 2013 API
FailureHandlingOptions..::..SetTransactionFinalizer Method
FailureHandlingOptions Class See Also Send Feedback
Setting a callback to be executed after transaction is completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions SetTransactionFinalizer(
    ITransactionFinalizer finalizer
)
Visual Basic
Public Function SetTransactionFinalizer ( _
    finalizer As ITransactionFinalizer _
) As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ SetTransactionFinalizer(
    ITransactionFinalizer^ finalizer
)

Parameters

finalizer
Type: Autodesk.Revit.DB..::..ITransactionFinalizer

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureHandlingOptions Class


FailureMessage Class

[image]

Revit 2013 API
FailureMessage Class
Members See Also Send Feedback
Represents a message describing a failure of an operation in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureMessage : IDisposable
Visual Basic
Public Class FailureMessage _
    Implements IDisposable
Visual C++
public ref class FailureMessage : IDisposable

Remarks

Failure messages are typically shown to the user in the Revit error dialog. This class contains the following information about the failures:
  1. The basic description of the failure (retrieved from the FailureDefinition)
  2. The available resolutions for the failure.
  3. The elements related to the failure.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureMessage

See Also

FailureMessage Members


FailureMessage Members

[image] [image]

Revit 2013 API
FailureMessage Members
FailureMessage Class Constructors Methods See Also Send Feedback

The FailureMessage type exposes the following members.

Constructors

 | Name | Description
Public method | FailureMessage | Creates a new FailureMessage related to a given FailureDefinition.

Methods

 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose | Releases all resources used by the FailureMessage
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessage Class


FailureMessage Constructor

[image]

Revit 2013 API
FailureMessage Constructor
FailureMessage Class See Also Send Feedback
Creates a new FailureMessage related to a given FailureDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage(
    FailureDefinitionId id
)
Visual Basic
Public Sub New ( _
    id As FailureDefinitionId _
)
Visual C++
public:
FailureMessage(
    FailureDefinitionId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..FailureDefinitionId
Id of FailureDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | id is valid or does not have corresponding failure definition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessage Class


FailureMessage Methods

[image] [image]

Revit 2013 API
FailureMessage Methods
FailureMessage Class See Also Send Feedback

The FailureMessage type exposes the following members.

Methods

 | Name | Description
Public method | AddResolution | Adds a resolution for the failure.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElements | Retrieves list of the additional reference elements for the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of the default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description text of the failure.
Public method | GetFailingElements | Retrieves list of the elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the id of the failure definition for the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetAdditionalElement | Sets the additional reference element for the failure.
Public method | SetAdditionalElements | Sets the additional reference elements for the failure.
Public method | SetFailingElement | Sets the element that has caused the failure.
Public method | SetFailingElements | Sets elements that have caused the failure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessage Class


AddResolution Method

[image]

Revit 2013 API
FailureMessage..::..AddResolution Method
FailureMessage Class See Also Send Feedback
Adds a resolution for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage AddResolution(
    FailureResolutionType type,
    FailureResolution resolution
)
Visual Basic
Public Function AddResolution ( _
    type As FailureResolutionType, _
    resolution As FailureResolution _
) As FailureMessage
Visual C++
public:
FailureMessage^ AddResolution(
    FailureResolutionType type,
    FailureResolution^ resolution
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of the resolution.
resolution
Type: Autodesk.Revit.DB..::..FailureResolution
The resolution.

Return Value

The FailureMessage.

Remarks

Each pair of FailureResolutionType and FailureResolution must have been defined in FailureDefinition, and could only be added once.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | type is not a valid resolution type for this FailureMessage. -or- resolution of type is not valid for this FailureMessage. -or- This FailureMessage already contains a resolution of type type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


Dispose Method

[image]

Revit 2013 API
FailureMessage..::..Dispose Method
FailureMessage Class See Also Send Feedback
Releases all resources used by the FailureMessage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessage Class


GetAdditionalElements Method

[image]

Revit 2013 API
FailureMessage..::..GetAdditionalElements Method
FailureMessage Class See Also Send Feedback
Retrieves list of the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElements()
Visual Basic
Public Function GetAdditionalElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElements()

Return Value

The additional elements.

See Also

FailureMessage Class


GetDefaultResolutionCaption Method

[image]

Revit 2013 API
FailureMessage..::..GetDefaultResolutionCaption Method
FailureMessage Class See Also Send Feedback
Retrieves the caption of the default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of the default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage does not have any resolutions.

See Also

FailureMessage Class


GetDescriptionText Method

[image]

Revit 2013 API
FailureMessage..::..GetDescriptionText Method
FailureMessage Class See Also Send Feedback
Retrieves the description text of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

See Also

FailureMessage Class


GetFailingElements Method

[image]

Revit 2013 API
FailureMessage..::..GetFailingElements Method
FailureMessage Class See Also Send Feedback
Retrieves list of the elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElements()
Visual Basic
Public Function GetFailingElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElements()

Return Value

The elements that have caused the failure.

See Also

FailureMessage Class


GetFailureDefinitionId Method

[image]

Revit 2013 API
FailureMessage..::..GetFailureDefinitionId Method
FailureMessage Class See Also Send Feedback
Retrieves the id of the failure definition for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The id of the FailureDefinition for the failure.

See Also

FailureMessage Class


GetSeverity Method

[image]

Revit 2013 API
FailureMessage..::..GetSeverity Method
FailureMessage Class See Also Send Feedback
Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

See Also

FailureMessage Class


HasResolutionOfType Method

[image]

Revit 2013 API
FailureMessage..::..HasResolutionOfType Method
FailureMessage Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution.

Return Value

True if the failure has a type of resolutions, else false.

See Also

FailureMessage Class


HasResolutions Method

[image]

Revit 2013 API
FailureMessage..::..HasResolutions Method
FailureMessage Class See Also Send Feedback
Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if the failure has any resolutions, false otherwise.

See Also

FailureMessage Class


SetAdditionalElement Method

[image]

Revit 2013 API
FailureMessage..::..SetAdditionalElement Method
FailureMessage Class See Also Send Feedback
Sets the additional reference element for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElement(
    ElementId additionalElement
)
Visual Basic
Public Function SetAdditionalElement ( _
    additionalElement As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElement(
    ElementId^ additionalElement
)

Parameters

additionalElement
Type: Autodesk.Revit.DB..::..ElementId
The additional element.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


SetAdditionalElements Method

[image]

Revit 2013 API
FailureMessage..::..SetAdditionalElements Method
FailureMessage Class See Also Send Feedback
Sets the additional reference elements for the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetAdditionalElements(
    ICollection<ElementId> additionalElements
)
Visual Basic
Public Function SetAdditionalElements ( _
    additionalElements As ICollection(Of ElementId) _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetAdditionalElements(
    ICollection<ElementId^>^ additionalElements
)

Parameters

additionalElements
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The additional elements.

Return Value

The FailureMessage.

Remarks

Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


SetFailingElement Method

[image]

Revit 2013 API
FailureMessage..::..SetFailingElement Method
FailureMessage Class See Also Send Feedback
Sets the element that has caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElement(
    ElementId id
)
Visual Basic
Public Function SetFailingElement ( _
    id As ElementId _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The element that has caused the failure.

Return Value

The FailureMessage.

Remarks

In Revit error dialog this element will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


SetFailingElements Method

[image]

Revit 2013 API
FailureMessage..::..SetFailingElements Method
FailureMessage Class See Also Send Feedback
Sets elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage SetFailingElements(
    ICollection<ElementId> idsToShow
)
Visual Basic
Public Function SetFailingElements ( _
    idsToShow As ICollection(Of ElementId) _
) As FailureMessage
Visual C++
public:
FailureMessage^ SetFailingElements(
    ICollection<ElementId^>^ idsToShow
)

Parameters

idsToShow
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that have caused the failure.

Return Value

The FailureMessage.

Remarks

In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessage is already posted to a document

See Also

FailureMessage Class


FailureMessageAccessor Class

[image]

Revit 2013 API
FailureMessageAccessor Class
Members See Also Send Feedback
Restricted accessor for FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureMessageAccessor : IDisposable
Visual Basic
Public Class FailureMessageAccessor _
    Implements IDisposable
Visual C++
public ref class FailureMessageAccessor : IDisposable

Remarks

Provides access to a FailureMessage stored in a Document. Reading of the information from the FailureMessage is allowed, changing of information is generally not allowed, except setting of the current resolution type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureMessageAccessor

See Also

FailureMessageAccessor Members


FailureMessageAccessor Members

[image] [image]

Revit 2013 API
FailureMessageAccessor Members
FailureMessageAccessor Class Methods See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose | Releases all resources used by the FailureMessageAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageAccessor Class


FailureMessageAccessor Methods

[image] [image]

Revit 2013 API
FailureMessageAccessor Methods
FailureMessageAccessor Class See Also Send Feedback

The FailureMessageAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CloneFailureMessage | Creates a copy of the FailureMessage.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdditionalElementIds | Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.
Public method | GetCurrentResolutionType | Retrieves the type of resolution to be used to resolve the failure.
Public method | GetDefaultResolutionCaption | Retrieves the caption of default resolution of the failure.
Public method | GetDescriptionText | Retrieves the description of the failure.
Public method | GetFailingElementIds | Retrieves Ids of Elements that have caused the failure.
Public method | GetFailureDefinitionId | Retrieves the Id of the FailureDefinition of the failure.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfResolutions | Retrieves number of resolutions that can be used to resolve failure.
Public method | GetSeverity | Retrieves the severity of the failure.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasResolutionOfType | Checks if failure has a resolution of a given type.
Public method | HasResolutions | Checks if the failure has any resolutions.
Public method | SetCurrentResolutionType | Sets the type of a resolution to be used to resolve the failure.
Public method | ShouldMergeWithMessage | Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageAccessor Class


CloneFailureMessage Method

[image]

Revit 2013 API
FailureMessageAccessor..::..CloneFailureMessage Method
FailureMessageAccessor Class See Also Send Feedback
Creates a copy of the FailureMessage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessage CloneFailureMessage()
Visual Basic
Public Function CloneFailureMessage As FailureMessage
Visual C++
public:
FailureMessage^ CloneFailureMessage()

Return Value

Copy of the FailureMesassge.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


Dispose Method

[image]

Revit 2013 API
FailureMessageAccessor..::..Dispose Method
FailureMessageAccessor Class See Also Send Feedback
Releases all resources used by the FailureMessageAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessageAccessor Class


GetAdditionalElementIds Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetAdditionalElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have not caused the failure but are related to it Checks if the failure has resolution of a given resolution type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAdditionalElementIds()
Visual Basic
Public Function GetAdditionalElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAdditionalElementIds()

Return Value

Ids of Elements related to the failure

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetCurrentResolutionType Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the type of resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureResolutionType GetCurrentResolutionType()
Visual Basic
Public Function GetCurrentResolutionType As FailureResolutionType
Visual C++
public:
FailureResolutionType GetCurrentResolutionType()

Return Value

The type of failure resolution to be used to resolve the failure.

Remarks

If the current resolution type was never set for the failure, FailureResolutionType::Default is returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


GetDefaultResolutionCaption Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetDefaultResolutionCaption Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the caption of default resolution of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDefaultResolutionCaption()
Visual Basic
Public Function GetDefaultResolutionCaption As String
Visual C++
public:
String^ GetDefaultResolutionCaption()

Return Value

The caption of default resolution of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetDescriptionText Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetDescriptionText Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the description of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetDescriptionText()
Visual Basic
Public Function GetDescriptionText As String
Visual C++
public:
String^ GetDescriptionText()

Return Value

The description text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetFailingElementIds Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetFailingElementIds Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves Ids of Elements that have caused the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetFailingElementIds()
Visual Basic
Public Function GetFailingElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetFailingElementIds()

Return Value

Ids of Elements that have caused the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetFailureDefinitionId Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetFailureDefinitionId Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the Id of the FailureDefinition of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureDefinitionId GetFailureDefinitionId()
Visual Basic
Public Function GetFailureDefinitionId As FailureDefinitionId
Visual C++
public:
FailureDefinitionId^ GetFailureDefinitionId()

Return Value

The Id of the FailureDefinition of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetNumberOfResolutions Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetNumberOfResolutions Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves number of resolutions that can be used to resolve failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int GetNumberOfResolutions()
Visual Basic
Public Function GetNumberOfResolutions As Integer
Visual C++
public:
int GetNumberOfResolutions()

Return Value

Number of resolutions that can be used to resolve failure

Remarks

If number of resolutions is zero, the failure cannot be resolved. If severity of the failure is Warning, it can be deleted. Otherwise, the only option is to cancel current operation and roll back the transaction

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


GetSeverity Method

[image]

Revit 2013 API
FailureMessageAccessor..::..GetSeverity Method
FailureMessageAccessor Class See Also Send Feedback
Retrieves the severity of the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The severity of the failure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


HasResolutionOfType Method

[image]

Revit 2013 API
FailureMessageAccessor..::..HasResolutionOfType Method
FailureMessageAccessor Class See Also Send Feedback
Checks if failure has a resolution of a given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutionOfType(
    FailureResolutionType type
)
Visual Basic
Public Function HasResolutionOfType ( _
    type As FailureResolutionType _
) As Boolean
Visual C++
public:
bool HasResolutionOfType(
    FailureResolutionType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of resolution.

Return Value

True if failure has a resolution of a given type, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


HasResolutions Method

[image]

Revit 2013 API
FailureMessageAccessor..::..HasResolutions Method
FailureMessageAccessor Class See Also Send Feedback
Checks if the failure has any resolutions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasResolutions()
Visual Basic
Public Function HasResolutions As Boolean
Visual C++
public:
bool HasResolutions()

Return Value

True if the failure has any resolutions, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


SetCurrentResolutionType Method

[image]

Revit 2013 API
FailureMessageAccessor..::..SetCurrentResolutionType Method
FailureMessageAccessor Class See Also Send Feedback
Sets the type of a resolution to be used to resolve the failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)
Visual Basic
Public Sub SetCurrentResolutionType ( _
    resolutionType As FailureResolutionType _
)
Visual C++
public:
void SetCurrentResolutionType(
    FailureResolutionType resolutionType
)

Parameters

resolutionType
Type: Autodesk.Revit.DB..::..FailureResolutionType
The type of failure resolution to be used to resolve the failure.

Remarks

When FailuresAccessor is used to resolve failures, it will execute resolutions based on current resolution type. If no current resolution type is set, the default resolution type will be used. Setting is performed on the FailureMessageAccessor object itself, so if there are several accessors issued for the same FailureMessage, setting of the resolution type performed on one of them does not impact the others.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This FailureMessageAccessor has no resolution of resolutionType.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized. -or- This FailureMessageAccessor does not have any resolutions.

See Also

FailureMessageAccessor Class


ShouldMergeWithMessage Method

[image]

Revit 2013 API
FailureMessageAccessor..::..ShouldMergeWithMessage Method
FailureMessageAccessor Class See Also Send Feedback
Checks if the FailureMessage should be merged with the other FailureMessage for better user experience.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShouldMergeWithMessage(
    FailureMessageAccessor messageToMergeWith
)
Visual Basic
Public Function ShouldMergeWithMessage ( _
    messageToMergeWith As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool ShouldMergeWithMessage(
    FailureMessageAccessor^ messageToMergeWith
)

Parameters

messageToMergeWith
Type: Autodesk.Revit.DB..::..FailureMessageAccessor

Return Value

True if messages should be merged

Remarks

Messages should be merged if all user-visible information except failing elements is the same, failure resolution types are the same and merging lists of failing elements keeps message text applicable to all of them equally. Method is used by the Revit UI to display multiple messages as one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | messageToMergeWith has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailureMessageAccessor has not been properly initialized.

See Also

FailureMessageAccessor Class


FailureMessageKey Class

[image]

Revit 2013 API
FailureMessageKey Class
Members See Also Send Feedback
A unique key assigned to each posted failure message

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureMessageKey : IDisposable
Visual Basic
Public Class FailureMessageKey _
    Implements IDisposable
Visual C++
public ref class FailureMessageKey : IDisposable

Remarks

When a failure message is posted, it gets a unique key assigned and returned to the caller. The key is guaranteed to be unique in the Revit session. The key can be used to unpost (delete) previously posted failure message if it is no longer valid.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureMessageKey

See Also

FailureMessageKey Members


FailureMessageKey Members

[image] [image]

Revit 2013 API
FailureMessageKey Members
FailureMessageKey Class Constructors Methods Operators See Also Send Feedback

The FailureMessageKey type exposes the following members.

Constructors

 | Name | Description
Public method | FailureMessageKey | Initializes a new instance of the FailureMessageKey class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureMessageKey
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class


FailureMessageKey Constructor

[image]

Revit 2013 API
FailureMessageKey Constructor
FailureMessageKey Class See Also Send Feedback
Initializes a new instance of the FailureMessageKey class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureMessageKey()
Visual Basic
Public Sub New
Visual C++
public:
FailureMessageKey()

See Also

FailureMessageKey Class


FailureMessageKey Methods

[image] [image]

Revit 2013 API
FailureMessageKey Methods
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks it this key is equal to the other.
Public method | IsValid | Checks if the failure message key is valid
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureMessageKey Class


Dispose Method

[image]

Revit 2013 API
FailureMessageKey..::..Dispose Method
FailureMessageKey Class See Also Send Feedback
Releases all resources used by the FailureMessageKey

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureMessageKey Class


Equals Method

[image]

Revit 2013 API
FailureMessageKey..::..Equals Method
FailureMessageKey Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

FailureMessageKey Class


GetHashCode Method

[image]

Revit 2013 API
FailureMessageKey..::..GetHashCode Method
FailureMessageKey Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

FailureMessageKey Class


IsEqual Method

[image]

Revit 2013 API
FailureMessageKey..::..IsEqual Method
FailureMessageKey Class See Also Send Feedback
Checks it this key is equal to the other.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    FailureMessageKey other
)
Visual Basic
Public Function IsEqual ( _
    other As FailureMessageKey _
) As Boolean
Visual C++
public:
bool IsEqual(
    FailureMessageKey^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FailureMessageKey
The key to compare with.

Return Value

True if keys are equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FailureMessageKey Class


IsValid Method

[image]

Revit 2013 API
FailureMessageKey..::..IsValid Method
FailureMessageKey Class See Also Send Feedback
Checks if the failure message key is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the failure message key is valid

See Also

FailureMessageKey Class


FailureMessageKey Operators

[image] [image]

Revit 2013 API
FailureMessageKey Operators
FailureMessageKey Class See Also Send Feedback

The FailureMessageKey type exposes the following members.

Operators

Name | Description
Equality | Determines whether two FailureMessageKeys are the same.
Inequality | Determines whether two FailureMessageKeys are different.

See Also

FailureMessageKey Class


Equality Operator

[image]

Revit 2013 API
FailureMessageKey..::..Equality Operator
FailureMessageKey Class See Also Send Feedback
Determines whether two FailureMessageKeys are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    FailureMessageKey first,
    FailureMessageKey second
)
Visual Basic
Public Shared Operator = ( _
    first As FailureMessageKey, _
    second As FailureMessageKey _
) As Boolean
Visual C++
public:
static bool operator ==(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureMessageKey
The first FailureMessageKey.
second
Type: Autodesk.Revit.DB..::..FailureMessageKey
The second FailureMessageKey.

Return Value

True if the FailureMessageKeys are the same; otherwise, false.

See Also

FailureMessageKey Class


Inequality Operator

[image]

Revit 2013 API
FailureMessageKey..::..Inequality Operator
FailureMessageKey Class See Also Send Feedback
Determines whether two FailureMessageKeys are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    FailureMessageKey first,
    FailureMessageKey second
)
Visual Basic
Public Shared Operator <> ( _
    first As FailureMessageKey, _
    second As FailureMessageKey _
) As Boolean
Visual C++
public:
static bool operator !=(
    FailureMessageKey^ first,
    FailureMessageKey^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..FailureMessageKey
The first FailureMessageKey.
second
Type: Autodesk.Revit.DB..::..FailureMessageKey
The second FailureMessageKey.

Return Value

True if the FailureMessageKeys are different; otherwise, false.

See Also

FailureMessageKey Class


FailureProcessingResult Enumeration

[image]

Revit 2013 API
FailureProcessingResult Enumeration
See Also Send Feedback
Enum represents result of failure processing by FailuresPreprocessor, handler of FailuresProcessing event or by FailuresProcessor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum FailureProcessingResult
Visual Basic
Public Enumeration FailureProcessingResult
Visual C++
public enum class FailureProcessingResult

Members

Member name | Description
Continue | Should be returned if no action was taken and/or caller should continue with default failure processing. If FailuresProcessor returns "Continue" with unresolved failures, Revit will instead act as if "ProceedWithRollBack" was returned.
ProceedWithCommit | Should be returned if some failures were resolved and instructs failure processing/transaction mechanism to try to repeat end of transaction checks and commit transaction again. There is no guarantee that such commit will succeed. "ProceedWithCommit" cannot be returned if transaction is already being rolled back, and will be treated as "ProceedWithRollBack" in this case.
ProceedWithRollBack | Should be returned if transaction was requested to be committed and failure (pre)processor requires it to be rolled back instead. If before ProceedWithRollBack is returned FailureHandlingOptions are set to clear errors after rollback, no further error processing will take place, all failures will be deleted and transaction is rolled back silently. Otherwise default failure processing will continue, failures may be delivered to the user, but transaction is guaranteed to be rolled back.
WaitForUserInput | Can be returned only by FailuresProcessor if it is waiting for external event (typically user input) to complete failures processing.

Remarks

The ability to return certain values may be restricted for certain methods or for certain contexts.

See Also


FailureResolution Class

[image]

Revit 2013 API
FailureResolution Class
Members See Also Send Feedback
Defines a resolution for a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailureResolution : IDisposable
Visual Basic
Public Class FailureResolution _
    Implements IDisposable
Visual C++
public ref class FailureResolution : IDisposable

Remarks

A failure could have several permitted resolutions. List of applicable resolution types for the specific failure is defined by the FailureDefinition, actual FailureResolutions are instantiated with the FailureMessage before it is posted. Multiple resolutions per failure are allowed, although Revit UI only uses default resolution.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailureResolution
Autodesk.Revit.DB..::..DeleteElements

See Also

FailureResolution Members


FailureResolution Members

[image] [image]

Revit 2013 API
FailureResolution Members
FailureResolution Class Methods See Also Send Feedback

The FailureResolution type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FailureResolution
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureResolution Class


FailureResolution Methods

[image] [image]

Revit 2013 API
FailureResolution Methods
FailureResolution Class See Also Send Feedback

The FailureResolution type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailureResolution Class


Dispose Method

[image]

Revit 2013 API
FailureResolution..::..Dispose Method
FailureResolution Class See Also Send Feedback
Releases all resources used by the FailureResolution

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailureResolution Class


FailureResolutionType Enumeration

[image]

Revit 2013 API
FailureResolutionType Enumeration
See Also Send Feedback
Enumeration to classify FailureResolutions by nature of operation they perform on failing Elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum FailureResolutionType
Visual Basic
Public Enumeration FailureResolutionType
Visual C++
public enum class FailureResolutionType

Members

Member name | Description
Invalid | Special (reserved) type. This should be non-initialized value of any variable of FailureResolutionType, end user should not see this value, API programmer could use this in initialization and comparison.
Default | Special (reserved) type. It cannot be used as a type when defining a resolution, but can be used as a key to query default resolution from FailureMessage or FailureDefinition.
CreateElements | Defines a resolution of a failure where Revit will add new Element(s) in place of missing one(s).
DeleteElements | Defines a resolution of a failure by deleting Element(s) that caused the failure.
SkipElements | Defines a resolution of a failure by skipping Element(s) for which operation has failed and proceeding with the rest of Elements.
MoveElements | Defines a resolution of a failure by moving Element(s) to an appropriate location.
FixElements | Defines a resolution of a failure by changing failing Element(s) - specific change may vary depending in type of failure and type of Element(s).
DetachElements | Defines a resolution of a failure by removing invalid relationships between elements such as joined walls and roofs, grouped elements, and associated curves.
QuitEditMode | Defines a resolution of a failure by quitting an Edit Mode instead of committing changes. Changes made in edit mode will be rolled back.
UnlockConstraints | Defines a resolution of a failure by unconstraining Element(s).
SetValue | Defines a resolution of a failure by setting an appropriate value in place of invalid value.
SaveDocument | Save the current document to avoid losing more if something serious occurs.
ShowElements | The standard "Show" may fail in some context, special resolution could be added in this condition to show failing element(s).
Others | Resolution type does not match any of the above.

See Also


FailuresAccessor Class

[image]

Revit 2013 API
FailuresAccessor Class
Members See Also Send Feedback
An interface class that provides access to failure information posted in a document and methods to resolve these failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailuresAccessor : IDisposable
Visual Basic
Public Class FailuresAccessor _
    Implements IDisposable
Visual C++
public ref class FailuresAccessor : IDisposable

Remarks

An instance of this class can be obtained only as an argument passed to interfaces used in the process of failure resolution and is the only available interface to fetch information about failures in a document. While reading from a document during failure processing is allowed, the only way to modify document during failure resolution is via methods provided by this class. After returning from failure processing, the instance of the class is deactivated and cannot be used any longer.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FailuresAccessor

See Also

FailuresAccessor Members


FailuresAccessor Members

[image] [image]

Revit 2013 API
FailuresAccessor Members
FailuresAccessor Class Methods See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose | Releases all resources used by the FailuresAccessor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresAccessor Class


FailuresAccessor Methods

[image] [image]

Revit 2013 API
FailuresAccessor Methods
FailuresAccessor Class See Also Send Feedback

The FailuresAccessor type exposes the following members.

Methods

 | Name | Description
Public method | CanCommitPendingTransaction | Checks if pending failure processing can be finished by committing a pending transaction.
Public method | CanRollBackPendingTransaction | Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method | CommitPendingTransaction | Finishes pending failures processing by committing the pending transaction.
Public method | DeleteAllWarnings | Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method | DeleteElements | Resolves failures by deletion of elements related to the failures.
Public method | DeleteWarning | Deletes one specific failure message of severity "Warning".
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAttemptedResolutionTypes | Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method | GetDocument | Provides access to a document for which failures are being processed or preprocessed.
Public method | GetFailureHandlingOptions | Provides access to the failure handling options for the transaction currently being finished.
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSeverity | Provides access to the current failure severity.
Public method | GetTransactionName | Retrieves the name of the transaction for which failures are being processed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsActive | Method allows to check if this instance of the accessor is currently active.
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.
Public method | IsPending | Checks if the failure processing is pending.
Public method | IsTransactionBeingCommitted | Checks if the transaction for which failures are processed is being committed or rolled back.
Public method | JournalFailures | Allows to record information about failures in the journal.
Public method | PostFailure | Posts an additional failure message to be processed for the current transaction.
Public method | ReplaceFailures | Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method | ResolveFailure | Resolves one failure using the failure resolution type last set for it.
Public method | ResolveFailures | Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method | RollBackPendingTransaction | Finishes pending failures processing by rolling back the pending transaction.
Public method | SetFailureHandlingOptions | Sets failure handling options for the transaction currently being finished.
Public method | SetTransactionName | Changes the name of the transaction for which failures are being processed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresAccessor Class


CanCommitPendingTransaction Method

[image]

Revit 2013 API
FailuresAccessor..::..CanCommitPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Checks if pending failure processing can be finished by committing a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanCommitPendingTransaction()
Visual Basic
Public Function CanCommitPendingTransaction As Boolean
Visual C++
public:
bool CanCommitPendingTransaction()

Return Value

True if there is a pending transaction and this transaction is allowed to be committed.

Remarks

Check makes sense only if the failure processing is pending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


CanRollBackPendingTransaction Method

[image]

Revit 2013 API
FailuresAccessor..::..CanRollBackPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Checks if pending failure processing can be finished by rolling back a pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanRollBackPendingTransaction()
Visual Basic
Public Function CanRollBackPendingTransaction As Boolean
Visual C++
public:
bool CanRollBackPendingTransaction()

Return Value

True if there is a pending transaction and this transaction is allowed to be rolled back

Remarks

Check makes sense only if the failure processing is pending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


CommitPendingTransaction Method

[image]

Revit 2013 API
FailuresAccessor..::..CommitPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Finishes pending failures processing by committing the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus CommitPendingTransaction()
Visual Basic
Public Function CommitPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus CommitPendingTransaction()

Return Value

Result of attempt to commit the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state. -or- There is no pending transaction or transaction is not allowed to be committed.

See Also

FailuresAccessor Class


DeleteAllWarnings Method

[image]

Revit 2013 API
FailuresAccessor..::..DeleteAllWarnings Method
FailuresAccessor Class See Also Send Feedback
Deletes all FailureMessages of severity "Warning" currently posted in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void DeleteAllWarnings()
Visual Basic
Public Sub DeleteAllWarnings
Visual C++
public:
void DeleteAllWarnings()

Remarks

Warnings are deleted immediately and will not be accessible by any further failures processing. Any accessors for these failure messages become invalid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteElements Method

[image]

Revit 2013 API
FailuresAccessor..::..DeleteElements Method
FailuresAccessor Class See Also Send Feedback
Resolves failures by deletion of elements related to the failures.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void DeleteElements(
    IList<ElementId> idsToDelete
)
Visual Basic
Public Sub DeleteElements ( _
    idsToDelete As IList(Of ElementId) _
)
Visual C++
public:
void DeleteElements(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of elements to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Resolution of the failures by deleting idsToDelete is not permitted
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


DeleteWarning Method

[image]

Revit 2013 API
FailuresAccessor..::..DeleteWarning Method
FailuresAccessor Class See Also Send Feedback
Deletes one specific failure message of severity "Warning".

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void DeleteWarning(
    FailureMessageAccessor failure
)
Visual Basic
Public Sub DeleteWarning ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void DeleteWarning(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The accessor to the warning to be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized. -or- Severity of failure is not FailureSeverity::Warning.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


Dispose Method

[image]

Revit 2013 API
FailuresAccessor..::..Dispose Method
FailuresAccessor Class See Also Send Feedback
Releases all resources used by the FailuresAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FailuresAccessor Class


GetAttemptedResolutionTypes Method

[image]

Revit 2013 API
FailuresAccessor..::..GetAttemptedResolutionTypes Method
FailuresAccessor Class See Also Send Feedback
Returns list of the failure resolution types attempted for the failure in the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureResolutionType> GetAttemptedResolutionTypes(
    FailureMessageAccessor failure
)
Visual Basic
Public Function GetAttemptedResolutionTypes ( _
    failure As FailureMessageAccessor _
) As IList(Of FailureResolutionType)
Visual C++
public:
IList<FailureResolutionType>^ GetAttemptedResolutionTypes(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The failure.

Return Value

The list of the types of failure resolutions attempted for the failure.

Remarks

In some cases attempt to resolve a failure has no impact or failure gets reposted during next round of the end of transaction checks after being resolved. Knowing if any failure resolutions were attempted for the failure allows failures processor to prevent infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetDocument Method

[image]

Revit 2013 API
FailuresAccessor..::..GetDocument Method
FailuresAccessor Class See Also Send Feedback
Provides access to a document for which failures are being processed or preprocessed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

The document for which failures preprocessing or processing is being performed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetFailureHandlingOptions Method

[image]

Revit 2013 API
FailuresAccessor..::..GetFailureHandlingOptions Method
FailuresAccessor Class See Also Send Feedback
Provides access to the failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureHandlingOptions GetFailureHandlingOptions()
Visual Basic
Public Function GetFailureHandlingOptions As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ GetFailureHandlingOptions()

Return Value

The failure handling options for transaction currently being finished.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetFailureMessages Method

[image] [image]

Revit 2013 API
FailuresAccessor..::..GetFailureMessages Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFailureMessages()()()() | Provides access to the individual failure messages currently posted in the document.
Public method | GetFailureMessages(FailureSeverity) | Provides access to the individual failure messages if a given severity currently posted in the document.

See Also

FailuresAccessor Class
FailuresAccessor Members


GetFailureMessages Method

[image]

Revit 2013 API
FailuresAccessor..::..GetFailureMessages Method
FailuresAccessor Class See Also Send Feedback
Provides access to the individual failure messages currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages()
Visual Basic
Public Function GetFailureMessages As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages()

Return Value

The accessors to the individual failure messages posted in the document.

Remarks

Returned set of messages will be ordered from more severe to less severe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload


GetFailureMessages Method (FailureSeverity)

[image]

Revit 2013 API
FailuresAccessor..::..GetFailureMessages Method (FailureSeverity)
FailuresAccessor Class See Also Send Feedback
Provides access to the individual failure messages if a given severity currently posted in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FailureMessageAccessor> GetFailureMessages(
    FailureSeverity severity
)
Visual Basic
Public Function GetFailureMessages ( _
    severity As FailureSeverity _
) As IList(Of FailureMessageAccessor)
Visual C++
public:
IList<FailureMessageAccessor^>^ GetFailureMessages(
    FailureSeverity severity
)

Parameters

severity
Type: Autodesk.Revit.DB..::..FailureSeverity
The failure severity for which failure messages are requested. If the requested severity is None, an empty collection is returned.

Return Value

Accessors to the individual failure messages of a given severity posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
GetFailureMessages Overload


GetSeverity Method

[image]

Revit 2013 API
FailuresAccessor..::..GetSeverity Method
FailuresAccessor Class See Also Send Feedback
Provides access to the current failure severity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureSeverity GetSeverity()
Visual Basic
Public Function GetSeverity As FailureSeverity
Visual C++
public:
FailureSeverity GetSeverity()

Return Value

The highest severity of a failure message currently posted in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


GetTransactionName Method

[image]

Revit 2013 API
FailuresAccessor..::..GetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Retrieves the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetTransactionName()
Visual Basic
Public Function GetTransactionName As String
Visual C++
public:
String^ GetTransactionName()

Return Value

The name of the transaction for which failures are being processed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsActive Method

[image]

Revit 2013 API
FailuresAccessor..::..IsActive Method
FailuresAccessor Class See Also Send Feedback
Method allows to check if this instance of the accessor is currently active.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsActive()
Visual Basic
Public Function IsActive As Boolean
Visual C++
public:
bool IsActive()

Return Value

True if this instance is currently active and can be used.

Remarks

Generally, this instance is active when it is passed to any of interfaces used in the process of failure resolution, and becomes inactive after returning control to Revit. The only special case is if failures processor returns WaitForUserInput, in which case document stays in the FailureMode and instance of failures accessor stays active till FailureMode is ended.

See Also

FailuresAccessor Class


IsElementsDeletionPermitted Method

[image] [image]

Revit 2013 API
FailuresAccessor..::..IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsElementsDeletionPermitted()()()() | Checks if resolution of the failures by deleting failure elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>)) | Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method | IsElementsDeletionPermitted(IList<(Of <<'(ElementId>)>>), String%) | Checks if resolution of the failures by deleting given collection of elements is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsElementsDeletionPermitted Method

[image]

Revit 2013 API
FailuresAccessor..::..IsElementsDeletionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting failure elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted()
Visual Basic
Public Function IsElementsDeletionPermitted As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted()

Return Value

True if resolution of the failures by deleting failure elements is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsElementsDeletionPermitted Method (IList(ElementId))

[image]

Revit 2013 API
FailuresAccessor..::..IsElementsDeletionPermitted Method (IList<(Of <(<'ElementId>)>)>)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete
)
Visual Basic
Public Function IsElementsDeletionPermitted ( _
    idsToDelete As IList(Of ElementId) _
) As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete
)

Parameters

idsToDelete
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The Ids of elements to be deleted.

Return Value

True if resolution of the failures by deleting given elements is permitted.

Remarks

Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements exist and can be deleted in the current state of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsElementsDeletionPermitted Method (IList(ElementId), String)

[image]

Revit 2013 API
FailuresAccessor..::..IsElementsDeletionPermitted Method (IList<(Of <(<'ElementId>)>)>, String%)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failures by deleting given collection of elements is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsElementsDeletionPermitted(
    IList<ElementId> idsToDelete,
    out string reason
)
Visual Basic
Public Function IsElementsDeletionPermitted ( _
    idsToDelete As IList(Of ElementId), _
    <OutAttribute> ByRef reason As String _
) As Boolean
Visual C++
public:
bool IsElementsDeletionPermitted(
    IList<ElementId^>^ idsToDelete,
    [OutAttribute] String^% reason
)

Parameters

idsToDelete
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The Ids of elements to be deleted.
reason
Type: System..::..String%
A localized string explaining reason why the elements cannot be deleted.

Return Value

True if resolution of the failures by deleting given elements is permitted

Remarks

Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements can be deleted in the current state of the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsElementsDeletionPermitted Overload


IsFailureResolutionPermitted Method

[image] [image]

Revit 2013 API
FailuresAccessor..::..IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsFailureResolutionPermitted()()()() | Checks if resolution of failures is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor) | Checks if default resolution of the failure is permitted.
Public method | IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) | Checks if resolution of the failure using given resolution type is permitted.

See Also

FailuresAccessor Class
FailuresAccessor Members


IsFailureResolutionPermitted Method

[image]

Revit 2013 API
FailuresAccessor..::..IsFailureResolutionPermitted Method
FailuresAccessor Class See Also Send Feedback
Checks if resolution of failures is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted()
Visual Basic
Public Function IsFailureResolutionPermitted As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted()

Return Value

True if resolutions of failures is permitted.

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor)

[image]

Revit 2013 API
FailuresAccessor..::..IsFailureResolutionPermitted Method (FailureMessageAccessor)
FailuresAccessor Class See Also Send Feedback
Checks if default resolution of the failure is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure
)
Visual Basic
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The accessor to the failure to be resolved.

Return Value

True if default resolution of the failure is permitted

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)

[image]

Revit 2013 API
FailuresAccessor..::..IsFailureResolutionPermitted Method (FailureMessageAccessor, FailureResolutionType)
FailuresAccessor Class See Also Send Feedback
Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsFailureResolutionPermitted(
    FailureMessageAccessor failure,
    FailureResolutionType resolutionType
)
Visual Basic
Public Function IsFailureResolutionPermitted ( _
    failure As FailureMessageAccessor, _
    resolutionType As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
    FailureMessageAccessor^ failure,
    FailureResolutionType resolutionType
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the failure resolution to be used.

Return Value

True if resolution of the failure using given resolution type is permitted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class
IsFailureResolutionPermitted Overload


IsPending Method

[image]

Revit 2013 API
FailuresAccessor..::..IsPending Method
FailuresAccessor Class See Also Send Feedback
Checks if the failure processing is pending.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsPending()
Visual Basic
Public Function IsPending As Boolean
Visual C++
public:
bool IsPending()

Return Value

True if the failures processing is in the pending state.

Remarks

The failure processing is pending after failures processor has returned WaitForUserInput and until pending state is finished by either committing or rolling back of the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


IsTransactionBeingCommitted Method

[image]

Revit 2013 API
FailuresAccessor..::..IsTransactionBeingCommitted Method
FailuresAccessor Class See Also Send Feedback
Checks if the transaction for which failures are processed is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsTransactionBeingCommitted()
Visual Basic
Public Function IsTransactionBeingCommitted As Boolean
Visual C++
public:
bool IsTransactionBeingCommitted()

Return Value

True if current transaction is being committed, false if the transaction is being rolled back.

Remarks

A transaction is considered as "being committed" if a caller has requested the transaction to be committed and no previous failure processing operation requested the transaction to be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


JournalFailures Method

[image]

Revit 2013 API
FailuresAccessor..::..JournalFailures Method
FailuresAccessor Class See Also Send Feedback
Allows to record information about failures in the journal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void JournalFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic
Public Sub JournalFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void JournalFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::..IList<(Of <(<'FailureMessageAccessor>)>)>
Accessors to the failures to journal.

Remarks

Records information about failure messages and elements involved in the failures. If this method not invoked, journal does not contain any information about failures resolved by (pre)processing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


PostFailure Method

[image]

Revit 2013 API
FailuresAccessor..::..PostFailure Method
FailuresAccessor Class See Also Send Feedback
Posts an additional failure message to be processed for the current transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void PostFailure(
    FailureMessage failure
)
Visual Basic
Public Sub PostFailure ( _
    failure As FailureMessage _
)
Visual C++
public:
void PostFailure(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
Failure message to post.

Remarks

Should be used during failures processing instead of a similar method in a document class. Using method of the document class with the same name during failures processing is prohibited.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


ReplaceFailures Method

[image]

Revit 2013 API
FailuresAccessor..::..ReplaceFailures Method
FailuresAccessor Class See Also Send Feedback
Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ReplaceFailures(
    FailureMessage failure
)
Visual Basic
Public Sub ReplaceFailures ( _
    failure As FailureMessage _
)
Visual C++
public:
void ReplaceFailures(
    FailureMessage^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessage
FailureMessage that should replace all currently posted messages. It must have severity DocumentCorruption.

Remarks

If analysis done by Failures Processing code concludes that in a given context delivering of the posted failures to the user makes no sense, this method can be used to discard all posted failures and substitute one "generic" one, that will be delivered to the user and then transaction forced to be aborted. After the call, (pre)processing of failures should return ProceedWithRollback.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Severity of failure must be FailureSeverity::DocumentCorruption.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


ResolveFailure Method

[image]

Revit 2013 API
FailuresAccessor..::..ResolveFailure Method
FailuresAccessor Class See Also Send Feedback
Resolves one failure using the failure resolution type last set for it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ResolveFailure(
    FailureMessageAccessor failure
)
Visual Basic
Public Sub ResolveFailure ( _
    failure As FailureMessageAccessor _
)
Visual C++
public:
void ResolveFailure(
    FailureMessageAccessor^ failure
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
The accessor to the failure to be resolved.

Remarks

If failure resolution type was not set, the default failure resolution type will be used. After execution of the failure resolution the failure will not be removed from the document automatically. To prevent the failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | failure has not been properly initialized. -or- failure does not have any resolutions. -or- Default resolution of failure is not permitted or not applicable. -or- The failure was already attempted to resolve twice with that resolution type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.

See Also

FailuresAccessor Class


ResolveFailures Method

[image]

Revit 2013 API
FailuresAccessor..::..ResolveFailures Method
FailuresAccessor Class See Also Send Feedback
Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ResolveFailures(
    IList<FailureMessageAccessor> failures
)
Visual Basic
Public Sub ResolveFailures ( _
    failures As IList(Of FailureMessageAccessor) _
)
Visual C++
public:
void ResolveFailures(
    IList<FailureMessageAccessor^>^ failures
)

Parameters

failures
Type: System.Collections.Generic..::..IList<(Of <(<'FailureMessageAccessor>)>)>
The accessors to the failures to be resolved.

Remarks

After execution of the failure resolutions the failures will not be removed from the document automatically. To prevent failure from being delivered to the user, failures (pre)processor should return ProceedWithCommit. It will cause failures to be regenerated and failure resolution process to be restarted. If attempt to resolve failure was not successful, and the same failure is present on repetitive calls of the failures (pre)processor, the preprocessor code should take care to attempt a different resolution the next time the failure appears, to avoid an infinite loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Default resolution of one of the failures is not permitted or not applicable. -or- One of the failures was already attempted to resolve twice with that resolution type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- Resolution of failures is not permitted in the current state of the document.

See Also

FailuresAccessor Class


RollBackPendingTransaction Method

[image]

Revit 2013 API
FailuresAccessor..::..RollBackPendingTransaction Method
FailuresAccessor Class See Also Send Feedback
Finishes pending failures processing by rolling back the pending transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBackPendingTransaction()
Visual Basic
Public Function RollBackPendingTransaction As TransactionStatus
Visual C++
public:
TransactionStatus RollBackPendingTransaction()

Return Value

Result of attempt to roll back the pending transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). -or- The processing of the failures is not in the pending state.

See Also

FailuresAccessor Class


SetFailureHandlingOptions Method

[image]

Revit 2013 API
FailuresAccessor..::..SetFailureHandlingOptions Method
FailuresAccessor Class See Also Send Feedback
Sets failure handling options for the transaction currently being finished.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
The failure handling options to be set for the transaction currently being finished.

Remarks

If used with returning ProceedWithRollback from (pre)processing, allows to dismiss errors and roll back transaction without any further failures processing and silently for the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


SetTransactionName Method

[image]

Revit 2013 API
FailuresAccessor..::..SetTransactionName Method
FailuresAccessor Class See Also Send Feedback
Changes the name of the transaction for which failures are being processed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetTransactionName(
    string transactionName
)
Visual Basic
Public Sub SetTransactionName ( _
    transactionName As String _
)
Visual C++
public:
void SetTransactionName(
    String^ transactionName
)

Parameters

transactionName
Type: System..::..String
The name of the transaction to set.

Remarks

If the transaction will be committed by or after failures processing it can change its name to reflect results of processing of the failures. For example, if the original transaction name was "review warnings" and some of the warnings were resolved by deleting of the relevant elements, failures processor may change the name of the transaction to "delete elements".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing).

See Also

FailuresAccessor Class


FailureSeverity Enumeration

[image]

Revit 2013 API
FailureSeverity Enumeration
See Also Send Feedback
Enum represents severity of a failure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum FailureSeverity
Visual Basic
Public Enumeration FailureSeverity
Visual C++
public enum class FailureSeverity

Members

Member name | Description
None | Represents a failure-free state of a document. This value cannot be used as an argument to construct FailureMesasage.
Warning | Failure that can be ignored by end-user. Failures of this severity do not prevent transactions from being committed.
Error | Failure that cannot be ignored. If FailureMeassage of this severity is posted, the current transaction cannot be committed unless failure is resolved via appropriate FailureResolution.
DocumentCorruption | Failure that forces Transaction to be rolled back as soon as possible due to known corruption to a document. When failure of this severity is posted, reading of information from a document is not allowed. The current transaction has to be rolled back first in order to work with the document.

See Also


Family Class

[image]

Revit 2013 API
Family Class
Members Example See Also Send Feedback
The Family object defines an entire family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Family : FamilyBase
Visual Basic
Public Class Family _
    Inherits FamilyBase
Visual C++
public ref class Family : public FamilyBase

Remarks

This object gets the family symbols that belong to the family so that instances can be swapped from one symbol to another. Families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of Families. The Family object represents the entire family such as an 'I Beam'. You can think of that object as representing the entire family file on disk. The Family object contains a number of FamilySymbols. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that Type (FamilySymbol) within the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project. Therefore: Each FamilyInstance has one FamilySymbol, e.g. an instance of a W14x32. Each FamilySymbol belongs to one Family, e.g. the W14x32 symbol belongs to an 'I Beam' family. Each Family will contain one or more FamilySymbols, e.g. the 'I Beam' family contains a W14x32 symbol, a W12x32 symbol etc.

Examples

CopyC#
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);

    if (family.Symbols.IsEmpty)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (FamilySymbol familySymbol in family.Symbols)
        {
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
           foreach (Material material in familySymbol.Materials)
           {
            message.AppendLine("\tMaterial: " + material.Name);
           }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Public Sub GetInfoForSymbols(ByVal family As Autodesk.Revit.DB.Family)
    Dim message As New StringBuilder("Selected element's family name is : " + family.Name)

    If family.Symbols.IsEmpty Then
        message.AppendLine("Contains no family symbols.")
    Else
        message.AppendLine("The family symbols contained in this family are : ")

        ' Get family symbols which is contained in this family
        For Each familySymbol As Autodesk.Revit.DB.FamilySymbol In family.Symbols
            ' Get family symbol name
            message.AppendLine(vbLf & "Name: " + familySymbol.Name)
            For Each material As Autodesk.Revit.DB.Material In familySymbol.Materials
                message.AppendLine(vbTab & "Material: " + material.Name)
            Next
        Next
    End If

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FamilyBase
Autodesk.Revit.DB..::..Family

See Also

Family Members


Family Members

[image] [image]

Revit 2013 API
Family Members
Family Class Methods Properties See Also Send Feedback

The Family type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | Indicates if this family supports editing.
Public property | IsInPlace | Indicates if this family is an in-place family or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralMaterialType | Gets the family's structural material type. (Inherited from FamilyBase.)
Public property | Symbols | A set of all symbols (types) that belong to a Family.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Family Class


Family Methods

[image] [image]

Revit 2013 API
Family Methods
Family Class See Also Send Feedback

The Family type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractPartAtom | Writes a PartAtom XML from the contents of a family object.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Family Class


ExtractPartAtom Method

[image]

Revit 2013 API
Family..::..ExtractPartAtom Method
Family Class See Also Send Feedback
Writes a PartAtom XML from the contents of a family object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ExtractPartAtom(
    string xmlFilePath
)
Visual Basic
Public Sub ExtractPartAtom ( _
    xmlFilePath As String _
)
Visual C++
public:
void ExtractPartAtom(
    String^ xmlFilePath
)

Parameters

xmlFilePath
Type: System..::..String
The xml file to be saved.

Remarks

This method is designed for a family loaded into a document in session. So it will skip the type catalog file. To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If 'xmlFilePath' is nullNothingnullptra null reference (Nothing in Visual Basic) or an empty string.

See Also

Family Class


Family Properties

[image] [image]

Revit 2013 API
Family Properties
Family Class See Also Send Feedback

The Family type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainPanelHorizontalSpacing | For Curtain Panel families, the horizontal spacing of the driving mesh.
Public property | CurtainPanelTilePattern | For Curtain Panel families, the choice of tile pattern.
Public property | CurtainPanelVerticalSpacing | For Curtain Panel families, the vertical spacing of the driving mesh.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside. (Inherited from FamilyBase.)
Public property | FamilyPlacementType | Identifies the type of placement required by a given family.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualMassFamily | Whether the Family is a Conceptual Mass family.
Public property | IsCurtainPanelFamily | Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public property | IsEditable | Indicates if this family supports editing.
Public property | IsInPlace | Indicates if this family is an in-place family or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowSpatialElementCalculationPoint | For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public property | StructuralMaterialType | Gets the family's structural material type. (Inherited from FamilyBase.)
Public property | Symbols | A set of all symbols (types) that belong to a Family.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Family Class


CurtainPanelHorizontalSpacing Property

[image]

Revit 2013 API
Family..::..CurtainPanelHorizontalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the horizontal spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CurtainPanelHorizontalSpacing { get; set; }
Visual Basic
Public Property CurtainPanelHorizontalSpacing As Double
    Get
    Set
Visual C++
public:
property double CurtainPanelHorizontalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


CurtainPanelTilePattern Property

[image]

Revit 2013 API
Family..::..CurtainPanelTilePattern Property
Family Class See Also Send Feedback
For Curtain Panel families, the choice of tile pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TilePatternsBuiltIn CurtainPanelTilePattern { get; }
Visual Basic
Public ReadOnly Property CurtainPanelTilePattern As TilePatternsBuiltIn
    Get
Visual C++
public:
property TilePatternsBuiltIn CurtainPanelTilePattern {
    TilePatternsBuiltIn get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


CurtainPanelVerticalSpacing Property

[image]

Revit 2013 API
Family..::..CurtainPanelVerticalSpacing Property
Family Class See Also Send Feedback
For Curtain Panel families, the vertical spacing of the driving mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CurtainPanelVerticalSpacing { get; set; }
Visual Basic
Public Property CurtainPanelVerticalSpacing As Double
    Get
    Set
Visual C++
public:
property double CurtainPanelVerticalSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Curtain Panel family.

See Also

Family Class


FamilyPlacementType Property

[image]

Revit 2013 API
Family..::..FamilyPlacementType Property
Family Class See Also Send Feedback
Identifies the type of placement required by a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FamilyPlacementType FamilyPlacementType { get; }
Visual Basic
Public ReadOnly Property FamilyPlacementType As FamilyPlacementType
    Get
Visual C++
public:
property FamilyPlacementType FamilyPlacementType {
    FamilyPlacementType get ();
}

See Also

Family Class


IsConceptualMassFamily Property

[image]

Revit 2013 API
Family..::..IsConceptualMassFamily Property
Family Class See Also Send Feedback
Whether the Family is a Conceptual Mass family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsConceptualMassFamily { get; }
Visual Basic
Public ReadOnly Property IsConceptualMassFamily As Boolean
    Get
Visual C++
public:
property bool IsConceptualMassFamily {
    bool get ();
}

See Also

Family Class


IsCurtainPanelFamily Property

[image]

Revit 2013 API
Family..::..IsCurtainPanelFamily Property
Family Class See Also Send Feedback
Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCurtainPanelFamily { get; }
Visual Basic
Public ReadOnly Property IsCurtainPanelFamily As Boolean
    Get
Visual C++
public:
property bool IsCurtainPanelFamily {
    bool get ();
}

See Also

Family Class


IsEditable Property

[image]

Revit 2013 API
Family..::..IsEditable Property
Family Class See Also Send Feedback
Indicates if this family supports editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get
Visual C++
public:
property bool IsEditable {
    bool get ();
}

See Also

Family Class


IsInPlace Property

[image]

Revit 2013 API
Family..::..IsInPlace Property
Family Class See Also Send Feedback
Indicates if this family is an in-place family or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInPlace { get; }
Visual Basic
Public ReadOnly Property IsInPlace As Boolean
    Get
Visual C++
public:
property bool IsInPlace {
    bool get ();
}

See Also

Family Class


Parameter Property

[image] [image]

Revit 2013 API
Family..::..Parameter Property
Family Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Family Class
Family Members


ShowSpatialElementCalculationPoint Property

[image]

Revit 2013 API
Family..::..ShowSpatialElementCalculationPoint Property
Family Class See Also Send Feedback
For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowSpatialElementCalculationPoint { get; set; }
Visual Basic
Public Property ShowSpatialElementCalculationPoint As Boolean
    Get
    Set
Visual C++
public:
property bool ShowSpatialElementCalculationPoint {
    bool get ();
    void set (bool value);
}

See Also

Family Class


Symbols Property

[image]

Revit 2013 API
Family..::..Symbols Property
Family Class See Also Send Feedback
A set of all symbols (types) that belong to a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet Symbols { get; }
Visual Basic
Public ReadOnly Property Symbols As FamilySymbolSet
    Get
Visual C++
public:
property FamilySymbolSet^ Symbols {
    FamilySymbolSet^ get ();
}

Remarks

Returns a read only set of all the symbols that belong to a particular family. The family symbol objects within this set can be used to swap an instance from one type to another.

See Also

Family Class


FamilyBase Class

[image]

Revit 2013 API
FamilyBase Class
Members See Also Send Feedback
A base class for all Family objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyBase : Element
Visual Basic
Public Class FamilyBase _
    Inherits Element
Visual C++
public ref class FamilyBase : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FamilyBase
Autodesk.Revit.DB..::..Family

See Also

FamilyBase Members


FamilyBase Members

[image] [image]

Revit 2013 API
FamilyBase Members
FamilyBase Class Methods Properties See Also Send Feedback

The FamilyBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | Gets the family's structural material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyBase Class


FamilyBase Methods

[image] [image]

Revit 2013 API
FamilyBase Methods
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyBase Class


FamilyBase Properties

[image] [image]

Revit 2013 API
FamilyBase Properties
FamilyBase Class See Also Send Feedback

The FamilyBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FamilyCategory | Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | Gets the family's structural material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyBase Class


FamilyCategory Property

[image]

Revit 2013 API
FamilyBase..::..FamilyCategory Property
FamilyBase Class Example See Also Send Feedback
Retrieves a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category FamilyCategory { get; }
Visual Basic
Public ReadOnly Property FamilyCategory As Category
    Get
Visual C++
public:
property Category^ FamilyCategory {
    Category^ get ();
}

Remarks

All category objects can be retrieved from the application by using the Categories property of the Application.Settings object.

Examples

CopyC#
public void GetBeamAndColumnSymbols(Document document)
{
    FamilySymbolSet columnTypes = new FamilySymbolSet();
    FamilySymbolSet framingTypes = new FamilySymbolSet();
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> elements = collector.OfClass(typeof(Family)).ToElements();

    foreach(Element element in elements)
    {
        Family tmpFamily = element as Family;
        Category category = tmpFamily.FamilyCategory;
        if (null != category)
        {
            if ((int)BuiltInCategory.OST_StructuralColumns == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    columnTypes.Insert(tmpSymbol);
                }
            }
            else if ((int)BuiltInCategory.OST_StructuralFraming == category.Id.IntegerValue)
            {
                foreach (FamilySymbol tmpSymbol in tmpFamily.Symbols)
                {
                    framingTypes.Insert(tmpSymbol);
                }
            }
        }
    }

    string message = "Column Types: ";
    FamilySymbolSetIterator fsItor = columnTypes.ForwardIterator();
    fsItor.Reset();
    while (fsItor.MoveNext())
    {
        FamilySymbol familySybmol = fsItor.Current as FamilySymbol;
        message += "\n" + familySybmol.Name;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetBeamAndColumnSymbols(ByVal document As Document)
    Dim columnTypes As New FamilySymbolSet()
    Dim framingTypes As New FamilySymbolSet()
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim elements As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Family)).ToElements()

    For Each element As Autodesk.Revit.DB.Element In elements
        Dim tmpFamily As Family = TryCast(element, Family)
        Dim category As Category = tmpFamily.FamilyCategory
        If category IsNot Nothing Then
            If DirectCast(BuiltInCategory.OST_StructuralColumns, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    columnTypes.Insert(tmpSymbol)
                Next
            ElseIf DirectCast(BuiltInCategory.OST_StructuralFraming, Integer) = category.Id.IntegerValue Then
                For Each tmpSymbol As FamilySymbol In tmpFamily.Symbols
                    framingTypes.Insert(tmpSymbol)
                Next
            End If
        End If
    Next

    Dim message As String = "Column Types: "
    Dim fsItor As FamilySymbolSetIterator = columnTypes.ForwardIterator()
    fsItor.Reset()
    While fsItor.MoveNext()
        Dim familySybmol As FamilySymbol = TryCast(fsItor.Current, FamilySymbol)
        message += vbLf + familySybmol.Name
    End While

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyBase Class


Parameter Property

[image] [image]

Revit 2013 API
FamilyBase..::..Parameter Property
FamilyBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FamilyBase Class
FamilyBase Members


StructuralMaterialType Property

[image]

Revit 2013 API
FamilyBase..::..StructuralMaterialType Property
FamilyBase Class See Also Send Feedback
Gets the family's structural material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

FamilyBase Class


FamilyElementVisibility Class

[image]

Revit 2013 API
FamilyElementVisibility Class
Members Example See Also Send Feedback
Provides access to the visibility parameters of family elements in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyElementVisibility : APIObject
Visual Basic
Public Class FamilyElementVisibility _
    Inherits APIObject
Visual C++
public ref class FamilyElementVisibility : public APIObject

Examples

CopyC#
public void CreateAndSetVisibility(Autodesk.Revit.DB.Document familyDocument, SketchPlane sketchPlane)
{
    // create a new ModelCurve in the family document
    XYZ p0 = new XYZ(1, 1, 0);
    XYZ p1 = new XYZ(5, 1, 0);
    Line line1 = familyDocument.Application.Create.NewLineBound(p0, p1);

    ModelCurve modelCurve1 = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane);

    // create a new ModelText along ModelCurve line
    ModelText text = familyDocument.FamilyCreate.NewModelText("Hello World", null, sketchPlane, p0, HorizontalAlign.Center, 0.1);

    // set visibility for text
    FamilyElementVisibility textVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    textVisibility.IsShownInTopBottom = false;
    text.SetVisibility(textVisibility);

    // set visibility for line
    FamilyElementVisibility curveVisibility = new FamilyElementVisibility(FamilyElementVisibilityType.Model);
    curveVisibility.IsShownInCoarse = false;
    modelCurve1.SetVisibility(curveVisibility);

}
CopyVB.NET
Public Sub CreateAndSetVisibility(ByVal familyDocument As Autodesk.Revit.DB.Document, ByVal sketchPlane As SketchPlane)
    ' create a new ModelCurve in the family document
    Dim p0 As New Autodesk.Revit.DB.XYZ(1, 1, 0)
    Dim p1 As New Autodesk.Revit.DB.XYZ(5, 1, 0)
    Dim line1 As Line = familyDocument.Application.Create.NewLineBound(p0, p1)

    Dim modelCurve1 As ModelCurve = familyDocument.FamilyCreate.NewModelCurve(line1, sketchPlane)

    ' create a new ModelText along ModelCurve line
    Dim text As ModelText = familyDocument.FamilyCreate.NewModelText("Hello World", Nothing, sketchPlane, p0, HorizontalAlign.Center, 0.1)

    ' set visibility for text
    Dim textVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    textVisibility.IsShownInTopBottom = False
    text.SetVisibility(textVisibility)

    ' set visibility for line
    Dim curveVisibility As New FamilyElementVisibility(FamilyElementVisibilityType.Model)
    curveVisibility.IsShownInCoarse = False
    modelCurve1.SetVisibility(curveVisibility)

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyElementVisibility

See Also

FamilyElementVisibility Members


FamilyElementVisibility Members

[image] [image]

Revit 2013 API
FamilyElementVisibility Members
FamilyElementVisibility Class Constructors Methods Properties See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyElementVisibility | Initializes a new instance of the FamilyElementVisibility class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


FamilyElementVisibility Constructor

[image]

Revit 2013 API
FamilyElementVisibility Constructor
FamilyElementVisibility Class See Also Send Feedback
Initializes a new instance of the FamilyElementVisibility class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)
Visual Basic
Public Sub New ( _
    visibilityType As FamilyElementVisibilityType _
)
Visual C++
public:
FamilyElementVisibility(
    FamilyElementVisibilityType visibilityType
)

Parameters

visibilityType
Type: Autodesk.Revit.DB..::..FamilyElementVisibilityType

See Also

FamilyElementVisibility Class


FamilyElementVisibility Methods

[image] [image]

Revit 2013 API
FamilyElementVisibility Methods
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyElementVisibility Class


FamilyElementVisibility Properties

[image] [image]

Revit 2013 API
FamilyElementVisibility Properties
FamilyElementVisibility Class See Also Send Feedback

The FamilyElementVisibility type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsShownInCoarse | Indicates if the instance is display with Coarse detail level in the view of project document.
Public property | IsShownInFine | Indicates if the instance is display with Fine detail level in the view of project document.
Public property | IsShownInFrontBack | Indicates if the instance is display in Front/Back view of project document.
Public property | IsShownInLeftRight | Indicates if the instance is display in Left/Right view of project document.
Public property | IsShownInMedium | Indicates if the instance is display with Medium detail level in the view of project document.
Public property | IsShownInPlanRCPCut | Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).
Public property | IsShownInTopBottom | Indicates if the instance is display in Plan/RCP view of project document.
Public property | IsShownOnlyWhenCut | Indicates if the instance is displayed only if it has been cut.
Public property | VisibilityType | Indicates if the instance is Model or View specific.

See Also

FamilyElementVisibility Class


IsShownInCoarse Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInCoarse Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Coarse detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInCoarse { get; set; }
Visual Basic
Public Property IsShownInCoarse As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInCoarse {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInFine Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInFine Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Fine detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInFine { get; set; }
Visual Basic
Public Property IsShownInFine As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInFine {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInFrontBack Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInFrontBack Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Front/Back view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInFrontBack { get; set; }
Visual Basic
Public Property IsShownInFrontBack As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInFrontBack {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownInLeftRight Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInLeftRight Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Left/Right view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInLeftRight { get; set; }
Visual Basic
Public Property IsShownInLeftRight As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInLeftRight {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownInMedium Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInMedium Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display with Medium detail level in the view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInMedium { get; set; }
Visual Basic
Public Property IsShownInMedium As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInMedium {
    bool get ();
    void set (bool value);
}

Remarks

This property cannot be set to false if the other two detail levels are also false.

See Also

FamilyElementVisibility Class


IsShownInPlanRCPCut Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInPlanRCPCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed when cut in Plan/RCP (if the category permits).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInPlanRCPCut { get; set; }
Visual Basic
Public Property IsShownInPlanRCPCut As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInPlanRCPCut {
    bool get ();
    void set (bool value);
}

Remarks

controls whether the Model Family Element is shown when a FamilyInstance of that Family is cut in a Plan/RCP view, i.e. the cut plane passes through the bounding box of the instance. It only has a meaning for categories that are "cut in the symbol". For non-cuttable categories it is always false and for ones that are "cuttable in the instance" it is the same as the IsShownInTopBottom.

See Also

FamilyElementVisibility Class


IsShownInTopBottom Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownInTopBottom Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is display in Plan/RCP view of project document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownInTopBottom { get; set; }
Visual Basic
Public Property IsShownInTopBottom As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownInTopBottom {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects whose visibility type is Model.

See Also

FamilyElementVisibility Class


IsShownOnlyWhenCut Property

[image]

Revit 2013 API
FamilyElementVisibility..::..IsShownOnlyWhenCut Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is displayed only if it has been cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsShownOnlyWhenCut { get; set; }
Visual Basic
Public Property IsShownOnlyWhenCut As Boolean
    Get
    Set
Visual C++
public:
property bool IsShownOnlyWhenCut {
    bool get ();
    void set (bool value);
}

Remarks

This property matters for objects which visibility type is ViewSpecific.

See Also

FamilyElementVisibility Class


VisibilityType Property

[image]

Revit 2013 API
FamilyElementVisibility..::..VisibilityType Property
FamilyElementVisibility Class See Also Send Feedback
Indicates if the instance is Model or View specific.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibilityType VisibilityType { get; }
Visual Basic
Public ReadOnly Property VisibilityType As FamilyElementVisibilityType
    Get
Visual C++
public:
property FamilyElementVisibilityType VisibilityType {
    FamilyElementVisibilityType get ();
}

See Also

FamilyElementVisibility Class


FamilyElementVisibilityType Enumeration

[image]

Revit 2013 API
FamilyElementVisibilityType Enumeration
See Also Send Feedback
Indicates the Visibility type of generic forms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FamilyElementVisibilityType
Visual Basic
Public Enumeration FamilyElementVisibilityType
Visual C++
public enum class FamilyElementVisibilityType

Members

Member name | Description
Model | The element will be displayed in 3D views and model other model views.
ViewSpecific | The element will be displayed only in the view where it is created. This applies to items like detail components, annotations, and view-specific imports.

Remarks

Use this enum to indicate the visibility type of new forms.

See Also


FamilyHostingBehavior Enumeration

[image]

Revit 2013 API
FamilyHostingBehavior Enumeration
See Also Send Feedback
Types of hosts into/onto which a family can be hosted. For informative purposes only. Does not affect anything in Revit!

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum FamilyHostingBehavior
Visual Basic
Public Enumeration FamilyHostingBehavior
Visual C++
public enum class FamilyHostingBehavior

Members

Member name | Description
None |
Wall |
Floor |
Ceiling |
Roof |
Face |

See Also


FamilyInstance Class

[image]

Revit 2013 API
FamilyInstance Class
Members Example See Also Send Feedback
This object represents a single instance of a family type, such as a single I beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyInstance : Instance
Visual Basic
Public Class FamilyInstance _
    Inherits Instance
Visual C++
public ref class FamilyInstance : public Instance

Remarks

Examples of FamilyInstance objects within Autodesk Revit are Beams, Columns, Braces and Desks. The FamilyInstance object provides more detailed properties that enable the type of the family instance to be changed, thus changing their appearance within the project.

Examples

CopyC#
public void GetInfo_FamilyInstance(FamilyInstance familyInstance)
{
    string message = "FamilyInstance : ";
    // Get FamilyInstance AnalyticalModel type
    if (null != familyInstance.GetAnalyticalModel())
    {
        message += "\nFamilyInstance AnalyticalModel is : " + familyInstance.GetAnalyticalModel();
    }

    // Get FamilyInstance host name
    if (familyInstance.Host != null)
    {
        message += "\nFamilyInstance host name is : " + familyInstance.Host.Name;
    }

    // Get FamilyInstance Material
    foreach (Material material in familyInstance.Materials)
    {
       message += "\nFamilyInstance Material is : " + material.Name;
    }
    // Get FamilyInstance room name
    if (familyInstance.Room != null)
    {
        message += "\nFamilyInstance room name is : " + familyInstance.Room.Name;
    }

    // Get FamilyInstance structural type
    message += "\nFamilyInstance structural type is : " + familyInstance.StructuralType;

    // Get FamilyInstance structural usage
    message += "\nFamilyInstance structural usage is : " + familyInstance.StructuralUsage;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = "FamilyInstance : "
    ' Get FamilyInstance AnalyticalModel type
    If familyInstance.GetAnalyticalModel() IsNot Nothing Then
        message += vbLf & "FamilyInstance AnalyticalModel is : " & familyInstance.GetAnalyticalModel().ToString()
    End If

    ' Get FamilyInstance host name
    If familyInstance.Host IsNot Nothing Then
        message += vbLf & "FamilyInstance host name is : " + familyInstance.Host.Name
    End If

    ' Get FamilyInstance Material
    For Each material As Autodesk.Revit.DB.Material In familyInstance.Materials
        message += vbLf & "FamilyInstance Material is : " + material.Name
    Next
    ' Get FamilyInstance room name
    If familyInstance.Room IsNot Nothing Then
        message += vbLf & "FamilyInstance room name is : " + familyInstance.Room.Name
    End If

    ' Get FamilyInstance structural type
    message += vbLf & "FamilyInstance structural type is : " + familyInstance.StructuralType

    ' Get FamilyInstance structural usage
    message += vbLf & "FamilyInstance structural usage is : " + familyInstance.StructuralUsage

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..AnnotationSymbol
Autodesk.Revit.DB..::..Mullion
Autodesk.Revit.DB..::..Panel

See Also

FamilyInstance Members


FamilyInstance Members

[image] [image]

Revit 2013 API
FamilyInstance Members
FamilyInstance Class Methods Properties See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance.
Public property | SuperComponent | Property to get the super component of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyInstance Class


FamilyInstance Methods

[image] [image]

Revit 2013 API
FamilyInstance Methods
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance.
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element.
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam.
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.
Public method | SetCopingIds | Specifies the set of coping cutters on this element.
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstance Class


AddCoping Method

[image]

Revit 2013 API
FamilyInstance..::..AddCoping Method
FamilyInstance Class See Also Send Feedback
Adds a coping (cut) to a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AddCoping(
    FamilyInstance cutter
)
Visual Basic
Public Function AddCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool AddCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This beam will be cut to fit another element, the cutter. The cut will include an offset determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings on this element. This function corresponds to Tools -> Coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


flipFacing Method

[image]

Revit 2013 API
FamilyInstance..::..flipFacing Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool flipFacing()
Visual Basic
Public Function flipFacing As Boolean
Visual C++
public:
bool flipFacing()

See Also

FamilyInstance Class


FlipFromToRoom Method

[image]

Revit 2013 API
FamilyInstance..::..FlipFromToRoom Method
FamilyInstance Class See Also Send Feedback
Flips the settings of "From Room" and "To Room" for the door or window instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void FlipFromToRoom()
Visual Basic
Public Sub FlipFromToRoom
Visual C++
public:
void FlipFromToRoom()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the FamilyInstance is neither a door nor a window.

See Also

FamilyInstance Class


flipHand Method

[image]

Revit 2013 API
FamilyInstance..::..flipHand Method
FamilyInstance Class See Also Send Feedback
The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool flipHand()
Visual Basic
Public Function flipHand As Boolean
Visual C++
public:
bool flipHand()

See Also

FamilyInstance Class


GetCopingIds Method

[image]

Revit 2013 API
FamilyInstance..::..GetCopingIds Method
FamilyInstance Class See Also Send Feedback
Lists the elements currently used as coping cutters for this element.
Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetCopingIds()
Visual Basic
Public Function GetCopingIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCopingIds()

Return Value

The coping ElementIds

See Also

FamilyInstance Class


GetCopings Method

[image]

Revit 2013 API
FamilyInstance..::..GetCopings Method
FamilyInstance Class See Also Send Feedback
Lists the elements currently used as coping cutters for this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetCopingIds() instead.")]
public ElementSet GetCopings()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetCopingIds() instead.")> _
Public Function GetCopings As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call GetCopingIds() instead.")]
public:
ElementSet^ GetCopings()

Return Value

The coping elements

See Also

FamilyInstance Class


GetFamilyPointPlacementReferences Method

[image]

Revit 2013 API
FamilyInstance..::..GetFamilyPointPlacementReferences Method
FamilyInstance Class See Also Send Feedback
Returns the Point Placement References for the Family Instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FamilyPointPlacementReference> GetFamilyPointPlacementReferences()
Visual Basic
Public Function GetFamilyPointPlacementReferences As IList(Of FamilyPointPlacementReference)
Visual C++
public:
IList<FamilyPointPlacementReference^>^ GetFamilyPointPlacementReferences()

Remarks

If a family instance has point placement references then they are returned by this method, otherwise an empty collection is returned. Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

See Also

FamilyInstance Class


GetOriginalGeometry Method

[image]

Revit 2013 API
FamilyInstance..::..GetOriginalGeometry Method
FamilyInstance Class See Also Send Feedback
Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetOriginalGeometry(
    Options options
)
Visual Basic
Public Function GetOriginalGeometry ( _
    options As Options _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetOriginalGeometry(
    Options^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..Options
The options used to obtain the geometry. Note that ComputeReferences may not be set to true.

Remarks

This method returns the original geometry of the instance. The instance's geometry will reflect the values of all instance level parameters (e.g. reference levels for columns) and of the placement conditions (so a beam placed along a 20' long line will be 20' long). It excludes all modifications made to the geometry due to operations like joining, cutting, openings, coping, or extensions.

The geometry will not include the GeometryInstance typically returned when you access the geometry of a FamilyInstance via Element.Geometry. But GeometryInstances may be encountered if there are nested family instances within the family.

The geometry is returned in the coordinates of the FamilySymbol, not the coordinates of the instance. If needed, you can transform the returned GeometryElement using the GetTransformed() method, passing the results from GetTransform(), or some other user-defined transformation.

The geometry returned is from Revit's internal computations and does not represent actual Revit geometry. Thus, you cannot use it as a reference for other geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the options are not valid for this operation (ComputeReferences == true)

See Also

FamilyInstance Class


GetSubComponentIds Method

[image]

Revit 2013 API
FamilyInstance..::..GetSubComponentIds Method
FamilyInstance Class See Also Send Feedback
Gets the sub component ElementIds of the current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetSubComponentIds()
Visual Basic
Public Function GetSubComponentIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSubComponentIds()

Return Value

The subcomponent ElementIDs

See Also

FamilyInstance Class


RemoveCoping Method

[image]

Revit 2013 API
FamilyInstance..::..RemoveCoping Method
FamilyInstance Class See Also Send Feedback
Removes a coping (cut) from a steel beam.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RemoveCoping(
    FamilyInstance cutter
)
Visual Basic
Public Function RemoveCoping ( _
    cutter As FamilyInstance _
) As Boolean
Visual C++
public:
bool RemoveCoping(
    FamilyInstance^ cutter
)

Parameters

cutter
Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column for which this beam currently has a coping cut. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.

Remarks

This function corresponds to Tools -> Remove coping in Revit Structure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


rotate Method

[image]

Revit 2013 API
FamilyInstance..::..rotate Method
FamilyInstance Class See Also Send Feedback
The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool rotate()
Visual Basic
Public Function rotate As Boolean
Visual C++
public:
bool rotate()

See Also

FamilyInstance Class


SetCopingIds Method

[image]

Revit 2013 API
FamilyInstance..::..SetCopingIds Method
FamilyInstance Class See Also Send Feedback
Specifies the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetCopingIds(
    ICollection<ElementId> cutters
)
Visual Basic
Public Function SetCopingIds ( _
    cutters As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool SetCopingIds(
    ICollection<ElementId^>^ cutters
)

Parameters

cutters
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of coping cutters (steel beams and steel columns).

Remarks

The set may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutters' contains this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails or if a cutter element is not a FamilyInstance.

See Also

FamilyInstance Class


SetCopings Method

[image]

Revit 2013 API
FamilyInstance..::..SetCopings Method
FamilyInstance Class See Also Send Feedback
Specify the set of coping cutters on this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")]
public bool SetCopings(
    ElementSet cutters
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")> _
Public Function SetCopings ( _
    cutters As ElementSet _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call SetCopingIds(System.Collections.Generic.ICollection<Autodesk.Revit.DB.ElementId>  cutters) instead.")]
public:
bool SetCopings(
    ElementSet^ cutters
)

Parameters

cutters
Type: Autodesk.Revit.DB..::..ElementSet
A set of coping cutters (steel beams and steel columns).

Remarks

The set must contain elements of FamilyInstance type only. The set may be nullNothingnullptra null reference (Nothing in Visual Basic) or empty, but may not contain the element being coped.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutters' contains this instance.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

FamilyInstance Class


FamilyInstance Properties

[image] [image]

Revit 2013 API
FamilyInstance Properties
FamilyInstance Class See Also Send Feedback

The FamilyInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped.
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped.
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane.
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation.
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped.
Public property | FacingOrientation | Property to get the orientation of family instance facing.
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped.
Public property | HandOrientation | Property to get the orientation of family instance hand.
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.
Public property | HostFace | Property to get the reference to the host face of family instance.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible.
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column.
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance.
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties.
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made.
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc.
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc.
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance.
Public property | SuperComponent | Property to get the super component of current family instance.
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance.
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilyInstance Class


CanFlipFacing Property

[image]

Revit 2013 API
FamilyInstance..::..CanFlipFacing Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanFlipFacing { get; }
Visual Basic
Public ReadOnly Property CanFlipFacing As Boolean
    Get
Visual C++
public:
property bool CanFlipFacing {
    bool get ();
}

See Also

FamilyInstance Class


CanFlipHand Property

[image]

Revit 2013 API
FamilyInstance..::..CanFlipHand Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand can be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanFlipHand { get; }
Visual Basic
Public ReadOnly Property CanFlipHand As Boolean
    Get
Visual C++
public:
property bool CanFlipHand {
    bool get ();
}

See Also

FamilyInstance Class


CanFlipWorkPlane Property

[image]

Revit 2013 API
FamilyInstance..::..CanFlipWorkPlane Property
FamilyInstance Class See Also Send Feedback
Identifies if the instance can flip its work plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanFlipWorkPlane { get; }
Visual Basic
Public ReadOnly Property CanFlipWorkPlane As Boolean
    Get
Visual C++
public:
property bool CanFlipWorkPlane {
    bool get ();
}

See Also

FamilyInstance Class


CanRotate Property

[image]

Revit 2013 API
FamilyInstance..::..CanRotate Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance can be rotated by 180 degrees.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanRotate { get; }
Visual Basic
Public ReadOnly Property CanRotate As Boolean
    Get
Visual C++
public:
property bool CanRotate {
    bool get ();
}

See Also

FamilyInstance Class


ExtensionUtility Property

[image]

Revit 2013 API
FamilyInstance..::..ExtensionUtility Property
FamilyInstance Class See Also Send Feedback
Property to check whether the instance can be extended and return the interface for extension operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IExtension ExtensionUtility { get; }
Visual Basic
Public ReadOnly Property ExtensionUtility As IExtension
    Get
Visual C++
public:
property IExtension^ ExtensionUtility {
    IExtension^ get ();
}

Remarks

If the family instance can not support extension operation, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


FacingFlipped Property

[image]

Revit 2013 API
FamilyInstance..::..FacingFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance facing is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool FacingFlipped { get; }
Visual Basic
Public ReadOnly Property FacingFlipped As Boolean
    Get
Visual C++
public:
property bool FacingFlipped {
    bool get ();
}

See Also

FamilyInstance Class


FacingOrientation Property

[image]

Revit 2013 API
FamilyInstance..::..FacingOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance facing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ FacingOrientation { get; }
Visual Basic
Public ReadOnly Property FacingOrientation As XYZ
    Get
Visual C++
public:
property XYZ^ FacingOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


FromRoom Property

[image] [image]

Revit 2013 API
FamilyInstance..::..FromRoom Property
FamilyInstance Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project.
Public property | FromRoom[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


FromRoom Property

[image]

Revit 2013 API
FamilyInstance..::..FromRoom Property
FamilyInstance Class See Also Send Feedback
The "From Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room FromRoom { get; }
Visual Basic
Public ReadOnly Property FromRoom As Room
    Get
Visual C++
public:
property Room^ FromRoom {
    Room^ get ();
}

Field Value

The "From Room" set for the door or window in the last phase of the project. nullNothingnullptra null reference (Nothing in Visual Basic) if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also nullNothingnullptra null reference (Nothing in Visual Basic) if there is no target room assigned to the last phase.

Remarks

Revit automatically calculates the "From Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "From Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom()()()() also can be used to swap the values.

See Also

FamilyInstance Class
FromRoom Overload


FromRoom Property (Phase)

[image]

Revit 2013 API
FamilyInstance..::..FromRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property FromRoom ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ FromRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
FromRoom Overload


HandFlipped Property

[image]

Revit 2013 API
FamilyInstance..::..HandFlipped Property
FamilyInstance Class See Also Send Feedback
Property to test whether the orientation of family instance hand is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HandFlipped { get; }
Visual Basic
Public ReadOnly Property HandFlipped As Boolean
    Get
Visual C++
public:
property bool HandFlipped {
    bool get ();
}

See Also

FamilyInstance Class


HandOrientation Property

[image]

Revit 2013 API
FamilyInstance..::..HandOrientation Property
FamilyInstance Class See Also Send Feedback
Property to get the orientation of family instance hand.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ HandOrientation { get; }
Visual Basic
Public ReadOnly Property HandOrientation As XYZ
    Get
Visual C++
public:
property XYZ^ HandOrientation {
    XYZ^ get ();
}

See Also

FamilyInstance Class


Host Property

[image]

Revit 2013 API
FamilyInstance..::..Host Property
FamilyInstance Class See Also Send Feedback
If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic
Public ReadOnly Property Host As Element
    Get
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

Remarks

An example of an instance that is contained is a window. In this case the host property would return the wall in which the window is contained. Another example is an instance that is hosted to a planar or curved face in a Mass element will return the Mass element.

See Also

FamilyInstance Class


HostFace Property

[image]

Revit 2013 API
FamilyInstance..::..HostFace Property
FamilyInstance Class See Also Send Feedback
Property to get the reference to the host face of family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference HostFace { get; }
Visual Basic
Public ReadOnly Property HostFace As Reference
    Get
Visual C++
public:
property Reference^ HostFace {
    Reference^ get ();
}

Field Value

If the instance is placed on a work plane, this property will return the reference to the geometry face underlying the work plane. If the work plane is not referencing other geometry, this property will return nullNothingnullptra null reference (Nothing in Visual Basic). If the instance is not hosted on a face or work plane, this property will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class


Invisible Property

[image]

Revit 2013 API
FamilyInstance..::..Invisible Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is invisible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Invisible { get; }
Visual Basic
Public ReadOnly Property Invisible As Boolean
    Get
Visual C++
public:
property bool Invisible {
    bool get ();
}

See Also

FamilyInstance Class


IsSlantedColumn Property

[image]

Revit 2013 API
FamilyInstance..::..IsSlantedColumn Property
FamilyInstance Class See Also Send Feedback
Indicates if the family instance is a slanted column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSlantedColumn { get; }
Visual Basic
Public ReadOnly Property IsSlantedColumn As Boolean
    Get
Visual C++
public:
property bool IsSlantedColumn {
    bool get ();
}

Remarks

If the family instance is a slanted column, it returns true, otherwise returns false.

See Also

FamilyInstance Class


IsWorkPlaneFlipped Property

[image]

Revit 2013 API
FamilyInstance..::..IsWorkPlaneFlipped Property
FamilyInstance Class See Also Send Feedback
Identifies if the instance's work plane is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsWorkPlaneFlipped { get; set; }
Visual Basic
Public Property IsWorkPlaneFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsWorkPlaneFlipped {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Work plane cannot be flipped for this instance.

See Also

FamilyInstance Class


Location Property

[image]

Revit 2013 API
FamilyInstance..::..Location Property
FamilyInstance Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an instance within the project. An instance may have a point location, such as a footing or may have a line location. A beam is an example of an instance that has a line location.

See Also

FamilyInstance Class


MEPModel Property

[image]

Revit 2013 API
FamilyInstance..::..MEPModel Property
FamilyInstance Class See Also Send Feedback
Retrieves the MEP model for the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPModel MEPModel { get; }
Visual Basic
Public ReadOnly Property MEPModel As MEPModel
    Get
Visual C++
public:
property MEPModel^ MEPModel {
    MEPModel^ get ();
}

Remarks

If the family instance has a MEP model it is returned by this method, otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned. Different types of MEP model will be returned based on the type of the instance, for example - if the instance is a lighting device then a lighting device model will be returned. This property will only function with the Autodesk Revit MEP product.

See Also

FamilyInstance Class


Mirrored Property

[image]

Revit 2013 API
FamilyInstance..::..Mirrored Property
FamilyInstance Class See Also Send Feedback
Property to test whether the family instance is mirrored. (only one axis is flipped)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Mirrored { get; }
Visual Basic
Public ReadOnly Property Mirrored As Boolean
    Get
Visual C++
public:
property bool Mirrored {
    bool get ();
}

See Also

FamilyInstance Class


Parameter Property

[image] [image]

Revit 2013 API
FamilyInstance..::..Parameter Property
FamilyInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image] [image]

Revit 2013 API
FamilyInstance..::..Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project).
Public property | Room[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Room Property

[image]

Revit 2013 API
FamilyInstance..::..Room Property
FamilyInstance Class See Also Send Feedback
The room in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic
Public ReadOnly Property Room As Room
    Get
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

This property will be the first room encountered that contains the instance. If more than one room includes this point in its volume only the first one is returned. If no room is found that contains the instance, this property is nullNothingnullptra null reference (Nothing in Visual Basic). This property should not be used for door or window instances, which are placed on the boundary or between rooms. Use the FromRoom and ToRoom properties instead.

See Also

FamilyInstance Class
Room Overload


Room Property (Phase)

[image]

Revit 2013 API
FamilyInstance..::..Room Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property Room ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ Room[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
Room Overload


Space Property

[image] [image]

Revit 2013 API
FamilyInstance..::..Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project).
Public property | Space[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


Space Property

[image]

Revit 2013 API
FamilyInstance..::..Space Property
FamilyInstance Class See Also Send Feedback
The space in which the instance is located (during the last phase of the project).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic
Public ReadOnly Property Space As Space
    Get
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

This property will be the first space encountered that contains the instance. If more than one space includes this point in its volume only the first one is returned. If no space is found that contains the instance, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyInstance Class
Space Overload


Space Property (Phase)

[image]

Revit 2013 API
FamilyInstance..::..Space Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property Space ( _
    phase As Phase _
) As Space
    Get
Visual C++
public:
property Space^ Space[Phase^ phase] {
    Space^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
Space Overload


StructuralMaterialId Property

[image]

Revit 2013 API
FamilyInstance..::..StructuralMaterialId Property
FamilyInstance Class See Also Send Feedback
Identifies the material that defines the instance's structural analysis properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId StructuralMaterialId { get; set; }
Visual Basic
Public Property StructuralMaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralMaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

FamilyInstance Class


StructuralMaterialType Property

[image]

Revit 2013 API
FamilyInstance..::..StructuralMaterialType Property
FamilyInstance Class See Also Send Feedback
This property returns the physical material from which the instance is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material. Different from Revit materials that geometry really consists of, this property is a family parameter defining family behavior and can not be set per instance. Its value is the same with the type of the instance's family. For example, the instances of different kind of column families(Steel, Concrete or Wood) have different material values and can't be changed int the UI or RevitAPI.

See Also

FamilyInstance Class


StructuralType Property

[image]

Revit 2013 API
FamilyInstance..::..StructuralType Property
FamilyInstance Class Example See Also Send Feedback
Provides the primary structural type of the instance, such as beam or column etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralType StructuralType { get; }
Visual Basic
Public ReadOnly Property StructuralType As StructuralType
    Get
Visual C++
public:
property StructuralType StructuralType {
    StructuralType get ();
}

Examples

CopyC#
public void GetStructuralType(FamilyInstance familyInstance)
{
    string message = "";
    switch (familyInstance.StructuralType)
    {
        case StructuralType.Beam:
            message = "FamilyInstance is a beam.";
            break;
        case StructuralType.Brace:
            message = "FamilyInstance is a brace.";
            break;
        case StructuralType.Column:
            message = "FamilyInstance is a column.";
            break;
        case StructuralType.Footing:
            message = "FamilyInstance is a footing.";
            break;
        default:
            message = "FamilyInstance is non-structural or unknown framing.";
            break;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetStructuralType(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = ""
    Select Case familyInstance.StructuralType
        Case Autodesk.Revit.DB.Structure.StructuralType.Beam
            message = "FamilyInstance is a beam."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Brace
            message = "FamilyInstance is a brace."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Column
            message = "FamilyInstance is a column."
            Exit Select
        Case Autodesk.Revit.DB.Structure.StructuralType.Footing
            message = "FamilyInstance is a footing."
            Exit Select
        Case Else
            message = "FamilyInstance is non-structural or unknown framing."
            Exit Select
    End Select

    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


StructuralUsage Property

[image]

Revit 2013 API
FamilyInstance..::..StructuralUsage Property
FamilyInstance Class See Also Send Feedback
Provides the primary structural usage of the instance, such as brace, girder etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As StructuralInstanceUsage
    Get
    Set
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
    void set (StructuralInstanceUsage value);
}

See Also

FamilyInstance Class


SubComponents Property

[image]

Revit 2013 API
FamilyInstance..::..SubComponents Property
FamilyInstance Class Example See Also Send Feedback
Property to get the sub components of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")]
public ElementSet SubComponents { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")> _
Public ReadOnly Property SubComponents As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetSubComponentIds() instead.")]
public:
property ElementSet^ SubComponents {
    ElementSet^ get ();
}

Remarks

When the FamilyInstance has no sub component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

Examples

CopyC#
public void GetSubAndSuperComponents(FamilyInstance familyInstance)
{
    ElementSet subElemSet = familyInstance.SubComponents;
    if (subElemSet != null)
    {
        string subElems = "";
        foreach (Autodesk.Revit.DB.Element ee in subElemSet)
        {
            FamilyInstance f = ee as FamilyInstance;
            subElems = subElems + f.Name + "\n";
        }
        TaskDialog.Show("Revit","Subcomponent count = " + subElemSet.Size + "\n" + subElems);
    }
    FamilyInstance super = familyInstance.SuperComponent as FamilyInstance;
    if (super != null)
    {
        TaskDialog.Show("Revit","SUPER component: " + super.Name);
    }
}
CopyVB.NET
Public Sub GetSubAndSuperComponents(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim subElemSet As ElementSet = familyInstance.SubComponents
    If subElemSet IsNot Nothing Then
        Dim subElems As String = ""
        For Each ee As Autodesk.Revit.DB.Element In subElemSet
            Dim f As Autodesk.Revit.DB.FamilyInstance = TryCast(ee, Autodesk.Revit.DB.FamilyInstance)
            subElems = subElems + f.Name + vbLf
        Next
        TaskDialog.Show("Revit", "Subcomponent count = " + subElemSet.Size + vbLf + subElems)
    End If
    Dim super As Autodesk.Revit.DB.FamilyInstance = TryCast(familyInstance.SuperComponent, Autodesk.Revit.DB.FamilyInstance)
    If super IsNot Nothing Then
        TaskDialog.Show("Revit", "SUPER component: " + super.Name)
    End If
End Sub

See Also

FamilyInstance Class


SuperComponent Property

[image]

Revit 2013 API
FamilyInstance..::..SuperComponent Property
FamilyInstance Class See Also Send Feedback
Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element SuperComponent { get; }
Visual Basic
Public ReadOnly Property SuperComponent As Element
    Get
Visual C++
public:
property Element^ SuperComponent {
    Element^ get ();
}

Remarks

When the FamilyInstance has no super component, it returns nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

FamilyInstance Class


Symbol Property

[image]

Revit 2013 API
FamilyInstance..::..Symbol Property
FamilyInstance Class Example See Also Send Feedback
Returns or changes the FamilySymbol object that represents the type of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Symbol { get; set; }
Visual Basic
Public Property Symbol As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Symbol {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

Setting this property will result in the type of the instance being changed. Related types can be found by examining the Family to which the symbol belongs.

Examples

CopyC#
public void GetInfo_FamilyInstance_Symbol(FamilyInstance familyInstance)
{
    string message = "FamilyInstance symbol: ";
    if (familyInstance.Symbol != null)
    {
        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name is : " + familyInstance.Symbol.Name;

        // Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName";

        // Get FamilyInstance structural symbol
        message += "\nFamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name;
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilyInstance_Symbol(ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    Dim message As String = "FamilyInstance symbol: "
    If familyInstance.Symbol IsNot Nothing Then
        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name is : " + familyInstance.Symbol.Name

        ' Rename the Symbol used by this FamilyInstance
        familyInstance.Symbol.Name = "TestFamilyInstanceSymbolName"

        ' Get FamilyInstance structural symbol
        message += vbLf & "FamilyInstance structural symbol name after set is : " + familyInstance.Symbol.Name
    End If
    TaskDialog.Show("Revit", message)
End Sub

See Also

FamilyInstance Class


ToRoom Property

[image] [image]

Revit 2013 API
FamilyInstance..::..ToRoom Property
FamilyInstance Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project.
Public property | ToRoom[([( Phase])]) |

See Also

FamilyInstance Class
FamilyInstance Members


ToRoom Property

[image]

Revit 2013 API
FamilyInstance..::..ToRoom Property
FamilyInstance Class See Also Send Feedback
The "To Room" set for the door or window in the last phase of the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room ToRoom { get; }
Visual Basic
Public ReadOnly Property ToRoom As Room
    Get
Visual C++
public:
property Room^ ToRoom {
    Room^ get ();
}

Field Value

The "To Room" set for the door or window in the last phase of the project. nullNothingnullptra null reference (Nothing in Visual Basic) if the FamilyInstance is neither a door nor a window, or if the door or window leads to a space where there is no room (an exterior space or interior space with no room defined). Also nullNothingnullptra null reference (Nothing in Visual Basic) if there is no target room assigned to the last phase.

Remarks

Revit automatically calculates the "To Room" for a given door or window. This is the default shown when creating a door or window schedule and adding the "To Room" properties. The user can opt to swap the "From Room" and "To Room" values via the schedule if they choose. The method FlipFromToRoom()()()() also can be used to swap the values.

See Also

FamilyInstance Class
ToRoom Overload


ToRoom Property (Phase)

[image]

Revit 2013 API
FamilyInstance..::..ToRoom Property (Phase)
FamilyInstance Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room this[
    Phase phase
] { get; }
Visual Basic
Public ReadOnly Property ToRoom ( _
    phase As Phase _
) As Room
    Get
Visual C++
public:
property Room^ ToRoom[Phase^ phase] {
    Room^ get (Phase^ phase);
}

Parameters

phase
Type: Autodesk.Revit.DB..::..Phase

See Also

FamilyInstance Class
ToRoom Overload


FamilyInstanceFilter Class

[image]

Revit 2013 API
FamilyInstanceFilter Class
Members Example See Also Send Feedback
A filter used to find elements that are family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FamilyInstanceFilter : ElementSlowFilter
Visual Basic
Public Class FamilyInstanceFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class FamilyInstanceFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

// Find all family symbols whose name is "W10X49"
FilteredElementCollector collector = new FilteredElementCollector(document);
collector = collector.OfClass(typeof(FamilySymbol));

// Get Element Id for family symbol which will be used to find family instances
var query = from element in collector where element.Name == "W10X49" select element;
List<Element> famSyms = query.ToList<Element>();
ElementId symbolId = famSyms[0].Id;

// Create a FamilyInstance filter with the FamilySymbol Id
FamilyInstanceFilter filter = new FamilyInstanceFilter(document, symbolId);

// Apply the filter to the elements in the active document
collector = new FilteredElementCollector(document);
ICollection<Element> familyInstances = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Creates a FamilyInstance filter for elements that are family instances of the given family symbol in the document

' Find all family symbols whose name is "W10X49"
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector = collector.OfClass(GetType(FamilySymbol))

' Get Element Id for family symbol which will be used to find family instances
Dim query As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
query = From element In collector _
 Where element.Name = "W10X49" _
 Select element
Dim famSyms As List(Of Autodesk.Revit.DB.Element) = query.ToList()
Dim symbolId As ElementId = famSyms(0).Id

' Create a FamilyInstance filter with the FamilySymbol Id
Dim filter As New FamilyInstanceFilter(document, symbolId)

' Apply the filter to the elements in the active document
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim familyInstances As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..FamilyInstanceFilter

See Also

FamilyInstanceFilter Members


FamilyInstanceFilter Members

[image] [image]

Revit 2013 API
FamilyInstanceFilter Members
FamilyInstanceFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyInstanceFilter | Constructs a new instance of a filter to match family instances of the given family symbol.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Constructor

[image]

Revit 2013 API
FamilyInstanceFilter Constructor
FamilyInstanceFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances of the given family symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilyInstanceFilter(
    Document document,
    ElementId familySymbolId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    familySymbolId As ElementId _
)
Visual C++
public:
FamilyInstanceFilter(
    Document^ document,
    ElementId^ familySymbolId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document. This requirement is unique to this filter and is needed to ensure the input family symbol id is valid for the provided document. This ensures the most stability and greatest performance for this filter.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The family symbol id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The familySymbolId does not represent a valid FamilySymbol record in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyInstanceFilter Class


FamilyInstanceFilter Methods

[image] [image]

Revit 2013 API
FamilyInstanceFilter Methods
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyInstanceFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
FamilyInstanceFilter..::..PassesFilter Method
FamilyInstanceFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class
FamilyInstanceFilter Members


FamilyInstanceFilter Properties

[image] [image]

Revit 2013 API
FamilyInstanceFilter Properties
FamilyInstanceFilter Class See Also Send Feedback

The FamilyInstanceFilter type exposes the following members.

Properties

 | Name | Description
Public property | FamilySymbolId | The family symbol id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilyInstanceFilter Class


FamilySymbolId Property

[image]

Revit 2013 API
FamilyInstanceFilter..::..FamilySymbolId Property
FamilyInstanceFilter Class See Also Send Feedback
The family symbol id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId FamilySymbolId { get; }
Visual Basic
Public ReadOnly Property FamilySymbolId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilySymbolId {
    ElementId^ get ();
}

See Also

FamilyInstanceFilter Class


FamilyManager Class

[image]

Revit 2013 API
FamilyManager Class
Members See Also Send Feedback
The family manager object to manage the family types and parameters in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyManager : APIObject
Visual Basic
Public Class FamilyManager _
    Inherits APIObject
Visual C++
public ref class FamilyManager : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyManager

See Also

FamilyManager Members


FamilyManager Members

[image] [image]

Revit 2013 API
FamilyManager Members
FamilyManager Class Methods Properties See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class


FamilyManager Methods

[image] [image]

Revit 2013 API
FamilyManager Methods
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Methods

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.
Public method | AssociateElementParameterToFamilyParameter | Associates or disassociates the element parameter to an existing family parameter.
Public method | CanElementParameterBeAssociated | Indicates if this element parameter can be associated with a family parameter.
Public method | DeleteCurrentType | Remove the current family type.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAssociatedFamilyParameter | Gets the associated family parameter of an element parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsParameterLockable | For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.
Public method | IsParameterLocked | For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.
Public method | MakeInstance | Set the family parameter as an instance parameter.
Public method | MakeNonReporting | Set the reporting family parameter as a regular/driving parameter.
Public method | MakeReporting | Set the family parameter as a reporting parameter.
Public method | MakeType | Set the family parameter as a type parameter.
Public method | NewType | Add a new family type with a given name and makes it be the current type.
Public method | RemoveParameter | Remove an existing family parameter from the family.
Public method | RenameCurrentType | Rename the current family type.
Public method | RenameParameter | Rename a family parameter.
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Replace a shared family parameter with a new non-shared family parameter.
Public method | Set(FamilyParameter, ElementId) | Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.
Public method | SetFormula | Set the formula of a family parameter.
Public method | SetParameterLocked | For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.
Public method | SetValueString | Set the string value of a family parameter of the current family type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyManager Class


AddParameter Method

[image] [image]

Revit 2013 API
FamilyManager..::..AddParameter Method
FamilyManager Class See Also Send Feedback
Add a new parameter to the family.

Overload List

 | Name | Description
Public method | AddParameter(ExternalDefinition, BuiltInParameterGroup, Boolean) | Add a new shared parameter to the family.
Public method | AddParameter(String, BuiltInParameterGroup, Category, Boolean) | Add a new family type parameter to control the type of a nested family within another family.
Public method | AddParameter(String, BuiltInParameterGroup, ParameterType, Boolean) | Add a new family parameter with a given name.

See Also

FamilyManager Class
FamilyManager Members


AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2013 API
FamilyManager..::..AddParameter Method (ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Add a new shared parameter to the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If creation was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the shared family parameter creation is not supported.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)

[image]

Revit 2013 API
FamilyManager..::..AddParameter Method (String, BuiltInParameterGroup, Category, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family type parameter to control the type of a nested family within another family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    Category familyCategory,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    familyCategory As Category, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    Category^ familyCategory,
    bool isInstance
)

Parameters

parameterName
Type: System..::..String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the family parameter belongs.
familyCategory
Type: Autodesk.Revit.DB..::..Category
The category to which the new family parameter binds.
isInstance
Type: System..::..Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input argument-"familyCategory"-is illegal to bind with parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed.

See Also

FamilyManager Class
AddParameter Overload


AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)

[image]

Revit 2013 API
FamilyManager..::..AddParameter Method (String, BuiltInParameterGroup, ParameterType, Boolean)
FamilyManager Class See Also Send Feedback
Add a new family parameter with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter AddParameter(
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)
Visual Basic
Public Function AddParameter ( _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    parameterType As ParameterType, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ AddParameter(
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    ParameterType parameterType,
    bool isInstance
)

Parameters

parameterName
Type: System..::..String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the family parameter belongs.
parameterType
Type: Autodesk.Revit.DB..::..ParameterType
The type of new family parameter.
isInstance
Type: System..::..Boolean
Indicates if the new family parameter is instance or type.

Return Value

If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"parameterName"-is already in use, or when the input argument -"parameterType" is an invalid type. Also thrown when "parameterType" is FamilyType; to add a parameter of this type use the AddParameter method that accepts a category instead.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter creation failed.

See Also

FamilyManager Class
AddParameter Overload


AssociateElementParameterToFamilyParameter Method

[image]

Revit 2013 API
FamilyManager..::..AssociateElementParameterToFamilyParameter Method
FamilyManager Class See Also Send Feedback
Associates or disassociates the element parameter to an existing family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AssociateElementParameterToFamilyParameter(
    Parameter elementParameter,
    FamilyParameter familyParameter
)
Visual Basic
Public Sub AssociateElementParameterToFamilyParameter ( _
    elementParameter As Parameter, _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void AssociateElementParameterToFamilyParameter(
    Parameter^ elementParameter,
    FamilyParameter^ familyParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::..Parameter
The parameter of an element in family.
familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The existing family parameter. If the input to this argument is nullNothingnullptra null reference (Nothing in Visual Basic), it will disassociate the element parameter from any family parameters.

Remarks

The parameter types of these two input parameter should be same, if not an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"elementParameter" or "familyParameter"-is an invalid parameter, or the input argument-"elementParameter"-cannot be associated.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter binding failed.

See Also

FamilyManager Class


CanElementParameterBeAssociated Method

[image]

Revit 2013 API
FamilyManager..::..CanElementParameterBeAssociated Method
FamilyManager Class See Also Send Feedback
Indicates if this element parameter can be associated with a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanElementParameterBeAssociated(
    Parameter elementParameter
)
Visual Basic
Public Function CanElementParameterBeAssociated ( _
    elementParameter As Parameter _
) As Boolean
Visual C++
public:
bool CanElementParameterBeAssociated(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::..Parameter

See Also

FamilyManager Class


DeleteCurrentType Method

[image]

Revit 2013 API
FamilyManager..::..DeleteCurrentType Method
FamilyManager Class See Also Send Feedback
Remove the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DeleteCurrentType()
Visual Basic
Public Sub DeleteCurrentType
Visual C++
public:
void DeleteCurrentType()

Remarks

If successfully removed, the first available type will become the current type, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is only one family type in current document.

See Also

FamilyManager Class


GetAssociatedFamilyParameter Method

[image]

Revit 2013 API
FamilyManager..::..GetAssociatedFamilyParameter Method
FamilyManager Class See Also Send Feedback
Gets the associated family parameter of an element parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter GetAssociatedFamilyParameter(
    Parameter elementParameter
)
Visual Basic
Public Function GetAssociatedFamilyParameter ( _
    elementParameter As Parameter _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ GetAssociatedFamilyParameter(
    Parameter^ elementParameter
)

Parameters

elementParameter
Type: Autodesk.Revit.DB..::..Parameter
The parameter of an element in family.

Return Value

The associated family parameter if there is an association between them, returns nullNothingnullptra null reference (Nothing in Visual Basic) if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"elementParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FamilyManager Class


IsParameterLockable Method

[image]

Revit 2013 API
FamilyManager..::..IsParameterLockable Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified parameter can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsParameterLockable(
    FamilyParameter familyParameter
)
Visual Basic
Public Function IsParameterLockable ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLockable(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

True if the family is a Conceptual Mass or Curtain Panel Family and the parameter drives one or more dimensions; false otherwise.

See Also

FamilyManager Class


IsParameterLocked Method

[image]

Revit 2013 API
FamilyManager..::..IsParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, indicate whether the specified dimension-driving parameter is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsParameterLocked(
    FamilyParameter familyParameter
)
Visual Basic
Public Function IsParameterLocked ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool IsParameterLocked(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

True if the parameter is lockable and is locked; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.

See Also

FamilyManager Class


MakeInstance Method

[image]

Revit 2013 API
FamilyManager..::..MakeInstance Method
FamilyManager Class See Also Send Feedback
Set the family parameter as an instance parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeInstance(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeInstance ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeInstance(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is Type family parameter driven by this parameter.

See Also

FamilyManager Class


MakeNonReporting Method

[image]

Revit 2013 API
FamilyManager..::..MakeNonReporting Method
FamilyManager Class See Also Send Feedback
Set the reporting family parameter as a regular/driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void MakeNonReporting(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeNonReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeNonReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to make a parameter which is labeled to an arc length dimension non-reporting.

See Also

FamilyManager Class


MakeReporting Method

[image]

Revit 2013 API
FamilyManager..::..MakeReporting Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void MakeReporting(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeReporting ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeReporting(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter can not be changed to a reporting parameter.

See Also

FamilyManager Class


MakeType Method

[image]

Revit 2013 API
FamilyManager..::..MakeType Method
FamilyManager Class See Also Send Feedback
Set the family parameter as a type parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MakeType(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub MakeType ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void MakeType(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also

FamilyManager Class


NewType Method

[image]

Revit 2013 API
FamilyManager..::..NewType Method
FamilyManager Class Example See Also Send Feedback
Add a new family type with a given name and makes it be the current type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyType NewType(
    string typeName
)
Visual Basic
Public Function NewType ( _
    typeName As String _
) As FamilyType
Visual C++
public:
FamilyType^ NewType(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The name of new family type.

Examples

CopyC#
public void EditFamilyTypes(Document document, FamilyInstance familyInstance)
{
    // example works best when familyInstance is a rectangular concrete element
    if (null != familyInstance.Symbol)
    {
        // Get family associated with this
        Family family = familyInstance.Symbol.Family;

        // Get Family document for family
        Document familyDoc = document.EditFamily(family);
        if (null != familyDoc)
        {
            FamilyManager familyManager = familyDoc.FamilyManager;

            // add a new type and edit its parameters
            FamilyType newFamilyType = familyManager.NewType("2X2");

            // look for 'b' and 'h' parameters and set them to 2 feet
            FamilyParameter familyParam = familyManager.get_Parameter("b");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }
            familyParam = familyManager.get_Parameter("h");
            if (null != familyParam)
            {
                familyManager.Set(familyParam, 2.0);
            }

            // now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document);
            // find the new type and assign it to FamilyInstance
            FamilySymbolSetIterator symbolsItor = family.Symbols.ForwardIterator();
            symbolsItor.Reset();
            while (symbolsItor.MoveNext())
            {
                FamilySymbol familySymbol = symbolsItor.Current as FamilySymbol;
                if (familySymbol.Name == "2X2")
                {
                    familyInstance.Symbol = familySymbol;
                    break;
                }
            }
        }
    }
}
CopyVB.NET
Public Sub EditFamilyTypes(ByVal document As Document, ByVal familyInstance As Autodesk.Revit.DB.FamilyInstance)
    ' example works best when familyInstance is a rectangular concrete element
    If familyInstance.Symbol IsNot Nothing Then
        ' Get family associated with this
        Dim family As Family = familyInstance.Symbol.Family

        ' Get Family document for family
        Dim familyDoc As Document = document.EditFamily(family)
        If familyDoc IsNot Nothing Then
            Dim familyManager As FamilyManager = familyDoc.FamilyManager

            ' add a new type and edit its parameters
            Dim newFamilyType As FamilyType = familyManager.NewType("2X2")

            ' look for 'b' and 'h' parameters and set them to 2 feet
            Dim familyParam As FamilyParameter = familyManager.Parameter("b")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2)
            End If
            familyParam = familyManager.Parameter("h")
            If familyParam IsNot Nothing Then
                familyManager.[Set](familyParam, 2)
            End If

            ' now update the Revit project with Family which has a new type
            family = familyDoc.LoadFamily(document)
            ' find the new type and assign it to FamilyInstance
            Dim symbolsItor As FamilySymbolSetIterator = family.Symbols.ForwardIterator()
            symbolsItor.Reset()
            While symbolsItor.MoveNext()
                Dim familySymbol As FamilySymbol = TryCast(symbolsItor.Current, FamilySymbol)
                If familySymbol.Name = "2X2" Then
                    familyInstance.Symbol = familySymbol
                    Exit While
                End If
            End While
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family type creation failed.

See Also

FamilyManager Class


RemoveParameter Method

[image]

Revit 2013 API
FamilyManager..::..RemoveParameter Method
FamilyManager Class See Also Send Feedback
Remove an existing family parameter from the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveParameter(
    FamilyParameter familyParameter
)
Visual Basic
Public Sub RemoveParameter ( _
    familyParameter As FamilyParameter _
)
Visual C++
public:
void RemoveParameter(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter.

Remarks

Only family and shared parameters may be removed, built-in parameters may not be removed. If the parameter is used in any formulas, those formulas will be automatically removed along with the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter deletion failed.

See Also

FamilyManager Class


RenameCurrentType Method

[image]

Revit 2013 API
FamilyManager..::..RenameCurrentType Method
FamilyManager Class See Also Send Feedback
Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RenameCurrentType(
    string typeName
)
Visual Basic
Public Sub RenameCurrentType ( _
    typeName As String _
)
Visual C++
public:
void RenameCurrentType(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The new name of the current family type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"typeName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family type rename failed.

See Also

FamilyManager Class


RenameParameter Method

[image]

Revit 2013 API
FamilyManager..::..RenameParameter Method
FamilyManager Class See Also Send Feedback
Rename a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RenameParameter(
    FamilyParameter familyParameter,
    string name
)
Visual Basic
Public Sub RenameParameter ( _
    familyParameter As FamilyParameter, _
    name As String _
)
Visual C++
public:
void RenameParameter(
    FamilyParameter^ familyParameter,
    String^ name
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter.
name
Type: System..::..String
The new name.

Remarks

This operation is valid only for Family Parameters, and is invalid for Shared Parameters and Built-in Parameters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to rename a built-in parameter or shared parameter.

See Also

FamilyManager Class


ReplaceParameter Method

[image] [image]

Revit 2013 API
FamilyManager..::..ReplaceParameter Method
FamilyManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReplaceParameter(FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean) | Replace a family parameter with a shared parameter.
Public method | ReplaceParameter(FamilyParameter, String, BuiltInParameterGroup, Boolean) | Replace a shared family parameter with a new non-shared family parameter.

See Also

FamilyManager Class
FamilyManager Members


ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)

[image]

Revit 2013 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, ExternalDefinition, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a family parameter with a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    ExternalDefinition familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    familyDefinition As ExternalDefinition, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    ExternalDefinition^ familyDefinition,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
familyDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
The definition of the loaded shared parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the new shared parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new shared parameter is returned, otherwise an exception with failure information will be thrown.

Remarks

This operation is invalid for Built-in Parameters. The formulas and labels which in reference to this parameter will be updated to the new parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter" or "name"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is invalid, or the input argument-"parameterGroup"-is illegal, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error.

See Also

FamilyManager Class
ReplaceParameter Overload


ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)

[image]

Revit 2013 API
FamilyManager..::..ReplaceParameter Method (FamilyParameter, String, BuiltInParameterGroup, Boolean)
FamilyManager Class See Also Send Feedback
Replace a shared family parameter with a new non-shared family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter ReplaceParameter(
    FamilyParameter currentParameter,
    string parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)
Visual Basic
Public Function ReplaceParameter ( _
    currentParameter As FamilyParameter, _
    parameterName As String, _
    parameterGroup As BuiltInParameterGroup, _
    isInstance As Boolean _
) As FamilyParameter
Visual C++
public:
FamilyParameter^ ReplaceParameter(
    FamilyParameter^ currentParameter,
    String^ parameterName,
    BuiltInParameterGroup parameterGroup,
    bool isInstance
)

Parameters

currentParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The current family parameter.
parameterName
Type: System..::..String
The name of the new family parameter.
parameterGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The group to which the new family parameter belongs.
isInstance
Type: System..::..Boolean
Indicates if the new parameter is instance or type.

Return Value

If replacement was successful the new family parameter is returned, otherwise an exception with failure information will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"currentParameter" or "parameterName"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"currentParameter"-is invalid, or the input argument-"parameterGroup"-is illegal, or the input name string contains illegal characters, or duplicated with existing parameter name.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to replace a built-in parameter or family parameter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when replacement failed, because the replacement would cause a formula error.

See Also

FamilyManager Class
ReplaceParameter Overload


Set Method

[image] [image]

Revit 2013 API
FamilyManager..::..Set Method
FamilyManager Class See Also Send Feedback
Set the value of a family parameter of the current family type.

Overload List

 | Name | Description
Public method | Set(FamilyParameter, ElementId) | Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Double) | Set the double value of a family parameter of the current family type.
Public method | Set(FamilyParameter, Int32) | Set the integer value of a family parameter of the current family type.
Public method | Set(FamilyParameter, String) | Set the string value of a family parameter of the current family type.

See Also

FamilyManager Class
FamilyManager Members


Set Method (FamilyParameter, ElementId)

[image]

Revit 2013 API
FamilyManager..::..Set Method (FamilyParameter, ElementId)
FamilyManager Class See Also Send Feedback
Set the Autodesk::Revit::DB::ElementId^ value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    ElementId value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As ElementId _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    ElementId^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: Autodesk.Revit.DB..::..ElementId
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, Double)

[image]

Revit 2013 API
FamilyManager..::..Set Method (FamilyParameter, Double)
FamilyManager Class See Also Send Feedback
Set the double value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    double value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Double _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    double value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..Double
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, Int32)

[image]

Revit 2013 API
FamilyManager..::..Set Method (FamilyParameter, Int32)
FamilyManager Class See Also Send Feedback
Set the integer value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    int value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As Integer _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    int value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..Int32
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


Set Method (FamilyParameter, String)

[image]

Revit 2013 API
FamilyManager..::..Set Method (FamilyParameter, String)
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Set(
    FamilyParameter familyParameter,
    string value
)
Visual Basic
Public Sub Set ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void Set(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..String
The new value for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid.

See Also

FamilyManager Class
Set Overload


SetFormula Method

[image]

Revit 2013 API
FamilyManager..::..SetFormula Method
FamilyManager Class See Also Send Feedback
Set the formula of a family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFormula(
    FamilyParameter familyParameter,
    string formula
)
Visual Basic
Public Sub SetFormula ( _
    familyParameter As FamilyParameter, _
    formula As String _
)
Visual C++
public:
void SetFormula(
    FamilyParameter^ familyParameter,
    String^ formula
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter.
formula
Type: System..::..String
The formula string, input nullNothingnullptra null reference (Nothing in Visual Basic) to clean the formula of the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is no valid family type, or the parameter cannot be assigned a formula, or the operation make a circular chain of references among the formulas.

See Also

FamilyManager Class


SetParameterLocked Method

[image]

Revit 2013 API
FamilyManager..::..SetParameterLocked Method
FamilyManager Class See Also Send Feedback
For Conceptual Mass and Curtain Panel families, lock or unlock a dimension-driving parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetParameterLocked(
    FamilyParameter familyParameter,
    bool locked
)
Visual Basic
Public Sub SetParameterLocked ( _
    familyParameter As FamilyParameter, _
    locked As Boolean _
)
Visual C++
public:
void SetParameterLocked(
    FamilyParameter^ familyParameter,
    bool locked
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
locked
Type: System..::..Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this family is not a Conceptual Mass or Curtain Panel family.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the parameter is not lockable.

See Also

FamilyManager Class


SetValueString Method

[image]

Revit 2013 API
FamilyManager..::..SetValueString Method
FamilyManager Class See Also Send Feedback
Set the string value of a family parameter of the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetValueString(
    FamilyParameter familyParameter,
    string value
)
Visual Basic
Public Sub SetValueString ( _
    familyParameter As FamilyParameter, _
    value As String _
)
Visual C++
public:
void SetValueString(
    FamilyParameter^ familyParameter,
    String^ value
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter
The family parameter of current type.
value
Type: System..::..String
The new value string for family parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter" or "value"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. or the input argument-"value"-is an illegal string.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or it is not a value type, or the current family type is invalid.

See Also

FamilyManager Class


FamilyManager Properties

[image] [image]

Revit 2013 API
FamilyManager Properties
FamilyManager Class See Also Send Feedback

The FamilyManager type exposes the following members.

Properties

 | Name | Description
Public property | CurrentType | The current family type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.
Public property | Parameters | All family parameters in this family.
Public property | Types | All family types in the family.

See Also

FamilyManager Class


CurrentType Property

[image]

Revit 2013 API
FamilyManager..::..CurrentType Property
FamilyManager Class See Also Send Feedback
The current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyType CurrentType { get; set; }
Visual Basic
Public Property CurrentType As FamilyType
    Get
    Set
Visual C++
public:
property FamilyType^ CurrentType {
    FamilyType^ get ();
    void set (FamilyType^ value);
}

Remarks

Only the current family type is editable using the methods in FamilyManager. If you want to modify the properties of any family type, it must be set to be the current type first. This value will be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no type in the family. In order to modify parameter values, you will need to create one using NewType(String).

See Also

FamilyManager Class


Parameter Property

[image] [image]

Revit 2013 API
FamilyManager..::..Parameter Property
FamilyManager Class See Also Send Feedback
Obtains a parameter based on an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Obtains the parameter of this type with a given GUID for a shared parameter.
Public property | Parameter[([( String])]) | Obtains the parameter of this type with a given name.
Public property | Parameter[([( BuiltInParameter])]) | Obtains the parameter of this type with a given parameter id.
Public property | Parameter[([( Definition])]) | Obtains the parameter of this type with a given definition.

See Also

FamilyManager Class
FamilyManager Members


Parameter Property (Guid)

[image]

Revit 2013 API
FamilyManager..::..Parameter Property (Guid)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given GUID for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter this[
    Guid guid
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    guid As Guid _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[Guid guid] {
    FamilyParameter^ get (Guid guid);
}

Parameters

guid
Type: System..::..Guid

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found. This method is used to retrieve a family parameter for a known shared parameter. When a shared parameter is created it is assigned a Guid which will not change. This guid can be used to retrieve the piece of data from the element at a later time.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (String)

[image]

Revit 2013 API
FamilyManager..::..Parameter Property (String)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter this[
    string parameterName
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterName As String _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[String^ parameterName] {
    FamilyParameter^ get (String^ parameterName);
}

Parameters

parameterName
Type: System..::..String

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (BuiltInParameter)

[image]

Revit 2013 API
FamilyManager..::..Parameter Property (BuiltInParameter)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter this[
    BuiltInParameter parameterId
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    parameterId As BuiltInParameter _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[BuiltInParameter parameterId] {
    FamilyParameter^ get (BuiltInParameter parameterId);
}

Parameters

parameterId
Type: Autodesk.Revit.DB..::..BuiltInParameter

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameter Property (Definition)

[image]

Revit 2013 API
FamilyManager..::..Parameter Property (Definition)
FamilyManager Class See Also Send Feedback
Obtains the parameter of this type with a given definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameter this[
    Definition definition
] { get; }
Visual Basic
Public ReadOnly Property Parameter ( _
    definition As Definition _
) As FamilyParameter
    Get
Visual C++
public:
property FamilyParameter^ Parameter[Definition^ definition] {
    FamilyParameter^ get (Definition^ definition);
}

Parameters

definition
Type: Autodesk.Revit.DB..::..Definition

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the parameter is not found.

See Also

FamilyManager Class
Parameter Overload


Parameters Property

[image]

Revit 2013 API
FamilyManager..::..Parameters Property
FamilyManager Class See Also Send Feedback
All family parameters in this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameterSet Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As FamilyParameterSet
    Get
Visual C++
public:
property FamilyParameterSet^ Parameters {
    FamilyParameterSet^ get ();
}

Remarks

These parameters will include the 'family parameter', 'shared parameter' and 'builtIn parameter' binding to the family types. Some parameters might be created as placeholders without a currently assigned value.

See Also

FamilyManager Class


Types Property

[image]

Revit 2013 API
FamilyManager..::..Types Property
FamilyManager Class Example See Also Send Feedback
All family types in the family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyTypeSet Types { get; }
Visual Basic
Public ReadOnly Property Types As FamilyTypeSet
    Get
Visual C++
public:
property FamilyTypeSet^ Types {
    FamilyTypeSet^ get ();
}

Examples

CopyC#
public void GetFamilyTypesInFamily(Document familyDoc)
{
    if (familyDoc.IsFamilyDocument == true)
    {
        FamilyManager familyManager = familyDoc.FamilyManager;

        // get types in family
        string types = "Family Types: ";
        FamilyTypeSet familyTypes = familyManager.Types;
        FamilyTypeSetIterator familyTypesItor = familyTypes.ForwardIterator();
        familyTypesItor.Reset();
        while (familyTypesItor.MoveNext())
        {
            FamilyType familyType = familyTypesItor.Current as FamilyType;
            types += "\n" + familyType.Name;
        }
        TaskDialog.Show("Revit",types);
    }
}
CopyVB.NET
Public Sub GetFamilyTypesInFamily(ByVal familyDoc As Document)
    If familyDoc.IsFamilyDocument = True Then
        Dim familyManager As FamilyManager = familyDoc.FamilyManager

        ' get types in family
        Dim types As String = "Family Types: "
        Dim familyTypes As FamilyTypeSet = familyManager.Types
        Dim familyTypesItor As FamilyTypeSetIterator = familyTypes.ForwardIterator()
        familyTypesItor.Reset()
        While familyTypesItor.MoveNext()
            Dim familyType As FamilyType = TryCast(familyTypesItor.Current, FamilyType)
            types += vbLf + familyType.Name
        End While
        TaskDialog.Show("Revit", types)
    End If
End Sub

See Also

FamilyManager Class


FamilyParameter Class

[image]

Revit 2013 API
FamilyParameter Class
Members See Also Send Feedback
The family parameter object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyParameter : APIObject
Visual Basic
Public Class FamilyParameter _
    Inherits APIObject
Visual C++
public ref class FamilyParameter : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameter Members


FamilyParameter Members

[image] [image]

Revit 2013 API
FamilyParameter Members
FamilyParameter Class Methods Properties See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | DisplayUnitType | The display unit type.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class


FamilyParameter Methods

[image] [image]

Revit 2013 API
FamilyParameter Methods
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameter Class


FamilyParameter Properties

[image] [image]

Revit 2013 API
FamilyParameter Properties
FamilyParameter Class See Also Send Feedback

The FamilyParameter type exposes the following members.

Properties

 | Name | Description
Public property | AssociatedParameters | The parameters from elements in the family which are associated to this parameter.
Public property | CanAssignFormula | Indicates if this parameter can be assigned a formula.
Public property | Definition | The definition.
Public property | DisplayUnitType | The display unit type.
Public property | Formula | The formula.
Public property | GUID | The globally unique identifier
Public property | Id | The id of the family parameter.
Public property | IsDeterminedByFormula | Indicates if the parameter is determined by formula.
Public property | IsInstance | Indicates if the parameter is instance or type.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsReporting | Indicates if the parameter is a reporting parameter.
Public property | StorageType | The storage type describes the type that is used internally within the parameter to store its value.

See Also

FamilyParameter Class


AssociatedParameters Property

[image]

Revit 2013 API
FamilyParameter..::..AssociatedParameters Property
FamilyParameter Class See Also Send Feedback
The parameters from elements in the family which are associated to this parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterSet AssociatedParameters { get; }
Visual Basic
Public ReadOnly Property AssociatedParameters As ParameterSet
    Get
Visual C++
public:
property ParameterSet^ AssociatedParameters {
    ParameterSet^ get ();
}

See Also

FamilyParameter Class


CanAssignFormula Property

[image]

Revit 2013 API
FamilyParameter..::..CanAssignFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if this parameter can be assigned a formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanAssignFormula { get; }
Visual Basic
Public ReadOnly Property CanAssignFormula As Boolean
    Get
Visual C++
public:
property bool CanAssignFormula {
    bool get ();
}

See Also

FamilyParameter Class


Definition Property

[image]

Revit 2013 API
FamilyParameter..::..Definition Property
FamilyParameter Class See Also Send Feedback
The definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As Definition
    Get
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

See Also

FamilyParameter Class


DisplayUnitType Property

[image]

Revit 2013 API
FamilyParameter..::..DisplayUnitType Property
FamilyParameter Class See Also Send Feedback
The display unit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic
Public ReadOnly Property DisplayUnitType As DisplayUnitType
    Get
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this parameter is not of value type.

See Also

FamilyParameter Class


Formula Property

[image]

Revit 2013 API
FamilyParameter..::..Formula Property
FamilyParameter Class See Also Send Feedback
The formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Formula { get; }
Visual Basic
Public ReadOnly Property Formula As String
    Get
Visual C++
public:
property String^ Formula {
    String^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no formula governing this parameter.

See Also

FamilyParameter Class


GUID Property

[image]

Revit 2013 API
FamilyParameter..::..GUID Property
FamilyParameter Class Example See Also Send Feedback
The globally unique identifier

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Examples

CopyC#
foreach (FamilyParameter familyParam in familyDoc.FamilyManager.Parameters)
{
    string familyParamName = familyParam.Definition.Name;
    try
    {
        Guid guid = familyParam.GUID;
        TaskDialog.Show("Revit",familyParamName + " is shared. Guid is " + guid);
    }
    catch (System.Exception)
    {
        TaskDialog.Show("Revit",familyParamName + " is NOT shared");
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

FamilyParameter Class


Id Property

[image]

Revit 2013 API
FamilyParameter..::..Id Property
FamilyParameter Class See Also Send Feedback
The id of the family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

FamilyParameter Class


IsDeterminedByFormula Property

[image]

Revit 2013 API
FamilyParameter..::..IsDeterminedByFormula Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is determined by formula.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDeterminedByFormula { get; }
Visual Basic
Public ReadOnly Property IsDeterminedByFormula As Boolean
    Get
Visual C++
public:
property bool IsDeterminedByFormula {
    bool get ();
}

Remarks

The parameter is read only if it is determined by formula.

See Also

FamilyParameter Class


IsInstance Property

[image]

Revit 2013 API
FamilyParameter..::..IsInstance Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is instance or type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInstance { get; }
Visual Basic
Public ReadOnly Property IsInstance As Boolean
    Get
Visual C++
public:
property bool IsInstance {
    bool get ();
}

See Also

FamilyParameter Class


IsReporting Property

[image]

Revit 2013 API
FamilyParameter..::..IsReporting Property
FamilyParameter Class See Also Send Feedback
Indicates if the parameter is a reporting parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsReporting { get; }
Visual Basic
Public ReadOnly Property IsReporting As Boolean
    Get
Visual C++
public:
property bool IsReporting {
    bool get ();
}

Remarks

If true, the parameter is a reporting parameter associated to a dimension value, and cannot be modified. If false, the parameter is a driving parameter and if associated to a dimension, can modify the dimension it labels.

See Also

FamilyParameter Class


StorageType Property

[image]

Revit 2013 API
FamilyParameter..::..StorageType Property
FamilyParameter Class See Also Send Feedback
The storage type describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

FamilyParameter Class


FamilyParameterSet Class

[image]

Revit 2013 API
FamilyParameterSet Class
Members See Also Send Feedback
A set that contains FamilyParameter objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyParameterSet : APIObject,
    IEnumerable
Visual Basic
Public Class FamilyParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyParameterSet

See Also

FamilyParameterSet Members


FamilyParameterSet Members

[image] [image]

Revit 2013 API
FamilyParameterSet Members
FamilyParameterSet Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyParameterSet | Initializes a new instance of the FamilyParameterSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Constructor

[image]

Revit 2013 API
FamilyParameterSet Constructor
FamilyParameterSet Class See Also Send Feedback
Initializes a new instance of the FamilyParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameterSet()
Visual Basic
Public Sub New
Visual C++
public:
FamilyParameterSet()

See Also

FamilyParameterSet Class


FamilyParameterSet Methods

[image] [image]

Revit 2013 API
FamilyParameterSet Methods
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSet Class


Clear Method

[image]

Revit 2013 API
FamilyParameterSet..::..Clear Method
FamilyParameterSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyParameterSet Class


Contains Method

[image]

Revit 2013 API
FamilyParameterSet..::..Contains Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyParameter item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameterSet Class


Erase Method

[image]

Revit 2013 API
FamilyParameterSet..::..Erase Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyParameter item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FamilyParameter _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameterSet Class


ForwardIterator Method

[image]

Revit 2013 API
FamilyParameterSet..::..ForwardIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyParameterSet Class


GetEnumerator Method

[image]

Revit 2013 API
FamilyParameterSet..::..GetEnumerator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FamilyParameterSet Class


Insert Method

[image]

Revit 2013 API
FamilyParameterSet..::..Insert Method
FamilyParameterSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyParameter item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FamilyParameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyParameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyParameter

See Also

FamilyParameterSet Class


ReverseIterator Method

[image]

Revit 2013 API
FamilyParameterSet..::..ReverseIterator Method
FamilyParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilyParameterSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FamilyParameterSetIterator
Visual C++
public:
virtual FamilyParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyParameterSet Class


FamilyParameterSet Properties

[image] [image]

Revit 2013 API
FamilyParameterSet Properties
FamilyParameterSet Class See Also Send Feedback

The FamilyParameterSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyParameterSet Class


IsEmpty Property

[image]

Revit 2013 API
FamilyParameterSet..::..IsEmpty Property
FamilyParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyParameterSet Class


Size Property

[image]

Revit 2013 API
FamilyParameterSet..::..Size Property
FamilyParameterSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyParameterSet Class


FamilyParameterSetIterator Class

[image]

Revit 2013 API
FamilyParameterSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyParameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FamilyParameterSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FamilyParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyParameterSetIterator

See Also

FamilyParameterSetIterator Members


FamilyParameterSetIterator Members

[image] [image]

Revit 2013 API
FamilyParameterSetIterator Members
FamilyParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyParameterSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Constructor

[image]

Revit 2013 API
FamilyParameterSetIterator Constructor
FamilyParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyParameterSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FamilyParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Methods

[image] [image]

Revit 2013 API
FamilyParameterSetIterator Methods
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyParameterSetIterator Class


MoveNext Method

[image]

Revit 2013 API
FamilyParameterSetIterator..::..MoveNext Method
FamilyParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class


Reset Method

[image]

Revit 2013 API
FamilyParameterSetIterator..::..Reset Method
FamilyParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyParameterSetIterator Class


FamilyParameterSetIterator Properties

[image] [image]

Revit 2013 API
FamilyParameterSetIterator Properties
FamilyParameterSetIterator Class See Also Send Feedback

The FamilyParameterSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyParameterSetIterator Class


Current Property

[image]

Revit 2013 API
FamilyParameterSetIterator..::..Current Property
FamilyParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyParameterSetIterator Class


FamilyPlacementType Enumeration

[image]

Revit 2013 API
FamilyPlacementType Enumeration
See Also Send Feedback
The type of placement required for a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum FamilyPlacementType
Visual Basic
Public Enumeration FamilyPlacementType
Visual C++
public enum class FamilyPlacementType

Members

Member name | Description
OneLevelBased | The family is placed referencing a single level.
OneLevelBasedHosted | The family is placed referencing a single level and host.
TwoLevelsBased | The family is placed referencing two levels (e.g. a column).
ViewBased | The family is view-specific (e.g. a detail annotation)
WorkPlaneBased | The family is placed on a work plane or face.
CurveBased | The family is based on a line and placed on a work plane.
CurveBasedDetail | The family is based on a line and place on a specific view (e.g. a detail component).
CurveDrivenStructural | The family is a structural curve driven member (beam, brace, or slanted column)
Adaptive | The family is an adaptive family.
Invalid | This signals an invalid value for the enum.

See Also


FamilyPointLocation Class

[image]

Revit 2013 API
FamilyPointLocation Class
Members See Also Send Feedback
This object represents a data corresponding to the point locations in a certain types Family Symbols (see examples listed below).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyPointLocation : APIObject
Visual Basic
Public Class FamilyPointLocation _
    Inherits APIObject
Visual C++
public ref class FamilyPointLocation : public APIObject

Remarks

Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyPointLocation

See Also

FamilyPointLocation Members


FamilyPointLocation Members

[image] [image]

Revit 2013 API
FamilyPointLocation Members
FamilyPointLocation Class Methods Properties See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.

See Also

FamilyPointLocation Class


FamilyPointLocation Methods

[image] [image]

Revit 2013 API
FamilyPointLocation Methods
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyPointLocation Class


FamilyPointLocation Properties

[image] [image]

Revit 2013 API
FamilyPointLocation Properties
FamilyPointLocation Class See Also Send Feedback

The FamilyPointLocation type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.

See Also

FamilyPointLocation Class


Location Property

[image]

Revit 2013 API
FamilyPointLocation..::..Location Property
FamilyPointLocation Class See Also Send Feedback
The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Location { get; }
Visual Basic
Public ReadOnly Property Location As Transform
    Get
Visual C++
public:
property Transform^ Location {
    Transform^ get ();
}

See Also

FamilyPointLocation Class


Name Property

[image]

Revit 2013 API
FamilyPointLocation..::..Name Property
FamilyPointLocation Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointLocation Class


FamilyPointPlacementReference Class

[image]

Revit 2013 API
FamilyPointPlacementReference Class
Members See Also Send Feedback
This object represents data corresponding to the placement references in a certain types of Family Instances (see examples listed below).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyPointPlacementReference : APIObject
Visual Basic
Public Class FamilyPointPlacementReference _
    Inherits APIObject
Visual C++
public ref class FamilyPointPlacementReference : public APIObject

Remarks

Examples of FamilyInstance objects that contain placement references are Panels and Flexible Components.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyPointPlacementReference

See Also

FamilyPointPlacementReference Members


FamilyPointPlacementReference Members

[image] [image]

Revit 2013 API
FamilyPointPlacementReference Members
FamilyPointPlacementReference Class Methods Properties See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.
Public property | PointReference | The reference on which the point depends on.

See Also

FamilyPointPlacementReference Class


FamilyPointPlacementReference Methods

[image] [image]

Revit 2013 API
FamilyPointPlacementReference Methods
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyPointPlacementReference Class


FamilyPointPlacementReference Properties

[image] [image]

Revit 2013 API
FamilyPointPlacementReference Properties
FamilyPointPlacementReference Class See Also Send Feedback

The FamilyPointPlacementReference type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Location | The location of the point.
Public property | Name | The name of the corresponding reference point in the Family document.
Public property | PointReference | The reference on which the point depends on.

See Also

FamilyPointPlacementReference Class


Location Property

[image]

Revit 2013 API
FamilyPointPlacementReference..::..Location Property
FamilyPointPlacementReference Class See Also Send Feedback
The location of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Location { get; }
Visual Basic
Public ReadOnly Property Location As Transform
    Get
Visual C++
public:
property Transform^ Location {
    Transform^ get ();
}

See Also

FamilyPointPlacementReference Class


Name Property

[image]

Revit 2013 API
FamilyPointPlacementReference..::..Name Property
FamilyPointPlacementReference Class See Also Send Feedback
The name of the corresponding reference point in the Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyPointPlacementReference Class


PointReference Property

[image]

Revit 2013 API
FamilyPointPlacementReference..::..PointReference Property
FamilyPointPlacementReference Class See Also Send Feedback
The reference on which the point depends on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PointReference { get; }
Visual Basic
Public ReadOnly Property PointReference As Reference
    Get
Visual C++
public:
property Reference^ PointReference {
    Reference^ get ();
}

See Also

FamilyPointPlacementReference Class


FamilySource Enumeration

[image]

Revit 2013 API
FamilySource Enumeration
See Also Send Feedback
Describes which version of the family to be loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FamilySource
Visual Basic
Public Enumeration FamilySource
Visual C++
public enum class FamilySource

Members

Member name | Description
Project | Loading the family from target project document.
Family | Loading the family from current family document.

See Also


FamilySymbol Class

[image]

Revit 2013 API
FamilySymbol Class
Members Example See Also Send Feedback
Represents a single Type within a Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilySymbol : InsertableObject
Visual Basic
Public Class FamilySymbol _
    Inherits InsertableObject
Visual C++
public ref class FamilySymbol : public InsertableObject

Remarks

The FamilySymbol object represents a Type within a Family. Each family can contain one or more family symbols.

Examples

CopyC#
public void GetInfo_FamilySymbol(FamilySymbol familySymbol)
{
    string message;
    // Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name;

    // Get FamilySymbol material
    message += "\nFamilySymbol materials are :";
    foreach (Material material in familySymbol.Materials)
    {
        message += "\n" + material.Name;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FamilySymbol(ByVal familySymbol As FamilySymbol)
    Dim message As String
    ' Get FamilySymbol family name
    message = "Family name is : " + familySymbol.Family.Name

    ' Get FamilySymbol material
    message += vbLf & "FamilySymbol material is : " & familySymbol.Materials.GetEnumerator().ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..AnnotationSymbolType
Autodesk.Revit.DB.Architecture..::..RoomTagType
Autodesk.Revit.DB..::..AreaTagType
Autodesk.Revit.DB.Mechanical..::..SpaceTagType
Autodesk.Revit.DB..::..MullionType
Autodesk.Revit.DB..::..PanelType
Autodesk.Revit.DB.Structure..::..TrussType

See Also

FamilySymbol Members


FamilySymbol Members

[image] [image]

Revit 2013 API
FamilySymbol Members
FamilySymbol Class Methods Properties See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilySymbol Class


FamilySymbol Methods

[image] [image]

Revit 2013 API
FamilySymbol Methods
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbol Class


GetFamilyPointLocations Method

[image]

Revit 2013 API
FamilySymbol..::..GetFamilyPointLocations Method
FamilySymbol Class See Also Send Feedback
Returns the Point Locations for the Family Symbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FamilyPointLocation> GetFamilyPointLocations()
Visual Basic
Public Function GetFamilyPointLocations As IList(Of FamilyPointLocation)
Visual C++
public:
IList<FamilyPointLocation^>^ GetFamilyPointLocations()

Remarks

If a family symbol has point references then their locations are returned by this method, otherwise an empty collection is returned. Examples of FamilySymbol objects that contain point location are Panels and Flexible Components.

See Also

FamilySymbol Class


GetThermalProperties Method

[image]

Revit 2013 API
FamilySymbol..::..GetThermalProperties Method
FamilySymbol Class See Also Send Feedback
Returns the thermal properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FamilyThermalProperties GetThermalProperties()
Visual Basic
Public Function GetThermalProperties As FamilyThermalProperties
Visual C++
public:
FamilyThermalProperties^ GetThermalProperties()

Return Value

The thermal properties. nullNothingnullptra null reference (Nothing in Visual Basic) if the family symbol does not contain thermal properties.

See Also

FamilySymbol Class


SetThermalProperties Method

[image]

Revit 2013 API
FamilySymbol..::..SetThermalProperties Method
FamilySymbol Class See Also Send Feedback
Set the thermal properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetThermalProperties(
    FamilyThermalProperties thermalProperties
)
Visual Basic
Public Sub SetThermalProperties ( _
    thermalProperties As FamilyThermalProperties _
)
Visual C++
public:
void SetThermalProperties(
    FamilyThermalProperties^ thermalProperties
)

Parameters

thermalProperties
Type: Autodesk.Revit.DB..::..FamilyThermalProperties

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"thermalProperties"-is invalid,

See Also

FamilySymbol Class


FamilySymbol Properties

[image] [image]

Revit 2013 API
FamilySymbol Properties
FamilySymbol Class See Also Send Feedback

The FamilySymbol type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FamilySymbol Class


Family Property

[image]

Revit 2013 API
FamilySymbol..::..Family Property
FamilySymbol Class See Also Send Feedback
Returns the Family object to which the symbol belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Family Family { get; }
Visual Basic
Public ReadOnly Property Family As Family
    Get
Visual C++
public:
property Family^ Family {
    Family^ get ();
}

See Also

FamilySymbol Class


Parameter Property

[image] [image]

Revit 2013 API
FamilySymbol..::..Parameter Property
FamilySymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FamilySymbol Class
FamilySymbol Members


StructuralMaterialType Property

[image]

Revit 2013 API
FamilySymbol..::..StructuralMaterialType Property
FamilySymbol Class See Also Send Feedback
This property returns the physical material from which the type is made.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

Remarks

Values of this property can be Steel, Concrete, Wood or some other material.

See Also

FamilySymbol Class


FamilySymbolFilter Class

[image]

Revit 2013 API
FamilySymbolFilter Class
Members See Also Send Feedback
A filter used to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FamilySymbolFilter : ElementQuickFilter
Visual Basic
Public Class FamilySymbolFilter _
    Inherits ElementQuickFilter
Visual C++
public ref class FamilySymbolFilter : public ElementQuickFilter

Remarks

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementQuickFilter
Autodesk.Revit.DB..::..FamilySymbolFilter

See Also

FamilySymbolFilter Members


FamilySymbolFilter Members

[image] [image]

Revit 2013 API
FamilySymbolFilter Members
FamilySymbolFilter Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySymbolFilter | Constructs a new instance of a filter to find all family symbols of the given family.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilySymbolFilter Constructor

[image]

Revit 2013 API
FamilySymbolFilter Constructor
FamilySymbolFilter Class See Also Send Feedback
Constructs a new instance of a filter to find all family symbols of the given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilySymbolFilter(
    ElementId familyId
)
Visual Basic
Public Sub New ( _
    familyId As ElementId _
)
Visual C++
public:
FamilySymbolFilter(
    ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB..::..ElementId
The family id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The familyId is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilySymbolFilter Class


FamilySymbolFilter Methods

[image] [image]

Revit 2013 API
FamilySymbolFilter Methods
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
FamilySymbolFilter..::..PassesFilter Method
FamilySymbolFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class
FamilySymbolFilter Members


FamilySymbolFilter Properties

[image] [image]

Revit 2013 API
FamilySymbolFilter Properties
FamilySymbolFilter Class See Also Send Feedback

The FamilySymbolFilter type exposes the following members.

Properties

 | Name | Description
Public property | FamilyId | The family id.
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

FamilySymbolFilter Class


FamilyId Property

[image]

Revit 2013 API
FamilySymbolFilter..::..FamilyId Property
FamilySymbolFilter Class See Also Send Feedback
The family id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic
Public ReadOnly Property FamilyId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

See Also

FamilySymbolFilter Class


FamilySymbolProfile Class

[image]

Revit 2013 API
FamilySymbolProfile Class
Members See Also Send Feedback
Represents a family symbol based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilySymbolProfile : SweepProfile
Visual Basic
Public Class FamilySymbolProfile _
    Inherits SweepProfile
Visual C++
public ref class FamilySymbolProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..FamilySymbolProfile

See Also

FamilySymbolProfile Members


FamilySymbolProfile Members

[image] [image]

Revit 2013 API
FamilySymbolProfile Members
FamilySymbolProfile Class Methods Properties See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class


FamilySymbolProfile Methods

[image] [image]

Revit 2013 API
FamilySymbolProfile Methods
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolProfile Class


FamilySymbolProfile Properties

[image] [image]

Revit 2013 API
FamilySymbolProfile Properties
FamilySymbolProfile Class See Also Send Feedback

The FamilySymbolProfile type exposes the following members.

Properties

 | Name | Description
Public property | Angle | The angle of the rotation of the profile in radians.
Public property | IsFlipped | Indicates if the symbol profile is flipped or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Profile | Returns the family symbol of the profile.
Public property | XOffset | The offset of the profile to the origin of the sketch plane in the X direction.
Public property | YOffset | The offset of the profile to the origin of the sketch plane in the Y direction.

See Also

FamilySymbolProfile Class


Angle Property

[image]

Revit 2013 API
FamilySymbolProfile..::..Angle Property
FamilySymbolProfile Class See Also Send Feedback
The angle of the rotation of the profile in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


IsFlipped Property

[image]

Revit 2013 API
FamilySymbolProfile..::..IsFlipped Property
FamilySymbolProfile Class See Also Send Feedback
Indicates if the symbol profile is flipped or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFlipped { get; set; }
Visual Basic
Public Property IsFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsFlipped {
    bool get ();
    void set (bool value);
}

See Also

FamilySymbolProfile Class


Profile Property

[image]

Revit 2013 API
FamilySymbolProfile..::..Profile Property
FamilySymbolProfile Class See Also Send Feedback
Returns the family symbol of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Profile { get; set; }
Visual Basic
Public Property Profile As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Profile {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

The symbol must of the category BuiltInCategory.OST_ProfileFamilies.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the category of argument is not BuiltInCategory.OST_ProfileFamilies.

See Also

FamilySymbolProfile Class


XOffset Property

[image]

Revit 2013 API
FamilySymbolProfile..::..XOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the X direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double XOffset { get; set; }
Visual Basic
Public Property XOffset As Double
    Get
    Set
Visual C++
public:
property double XOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


YOffset Property

[image]

Revit 2013 API
FamilySymbolProfile..::..YOffset Property
FamilySymbolProfile Class See Also Send Feedback
The offset of the profile to the origin of the sketch plane in the Y direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double YOffset { get; set; }
Visual Basic
Public Property YOffset As Double
    Get
    Set
Visual C++
public:
property double YOffset {
    double get ();
    void set (double value);
}

See Also

FamilySymbolProfile Class


FamilySymbolSet Class

[image]

Revit 2013 API
FamilySymbolSet Class
Members See Also Send Feedback
A set that can contain family symbols.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilySymbolSet : APIObject,
    IEnumerable
Visual Basic
Public Class FamilySymbolSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilySymbolSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilySymbolSet

See Also

FamilySymbolSet Members


FamilySymbolSet Members

[image] [image]

Revit 2013 API
FamilySymbolSet Members
FamilySymbolSet Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySymbolSet | Initializes a new instance of the FamilySymbolSet class

Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class


FamilySymbolSet Constructor

[image]

Revit 2013 API
FamilySymbolSet Constructor
FamilySymbolSet Class See Also Send Feedback
Initializes a new instance of the FamilySymbolSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSet()
Visual Basic
Public Sub New
Visual C++
public:
FamilySymbolSet()

See Also

FamilySymbolSet Class


FamilySymbolSet Methods

[image] [image]

Revit 2013 API
FamilySymbolSet Methods
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every symbol from the set, rendering it empty.
Public method | Contains | Tests for the existence of a family symbol within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified family symbol from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified family symbol into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSet Class


Clear Method

[image]

Revit 2013 API
FamilySymbolSet..::..Clear Method
FamilySymbolSet Class See Also Send Feedback
Removes every symbol from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilySymbolSet Class


Contains Method

[image]

Revit 2013 API
FamilySymbolSet..::..Contains Method
FamilySymbolSet Class See Also Send Feedback
Tests for the existence of a family symbol within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilySymbol item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilySymbol
The symbol to be searched for.

Return Value

The Contains method returns True if the symbol is within the set, otherwise False.

See Also

FamilySymbolSet Class


Erase Method

[image]

Revit 2013 API
FamilySymbolSet..::..Erase Method
FamilySymbolSet Class See Also Send Feedback
Removes a specified family symbol from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    FamilySymbol item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FamilySymbol _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilySymbol
The symbol to be erased.

Return Value

The number of symbols that were erased from the set.

See Also

FamilySymbolSet Class


ForwardIterator Method

[image]

Revit 2013 API
FamilySymbolSet..::..ForwardIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilySymbolSet Class


GetEnumerator Method

[image]

Revit 2013 API
FamilySymbolSet..::..GetEnumerator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FamilySymbolSet Class


Insert Method

[image]

Revit 2013 API
FamilySymbolSet..::..Insert Method
FamilySymbolSet Class See Also Send Feedback
Insert the specified family symbol into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilySymbol item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FamilySymbol _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilySymbol^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilySymbol
The symbol to be inserted into the set.

Return Value

Returns whether the symbol was inserted into the set.

See Also

FamilySymbolSet Class


ReverseIterator Method

[image]

Revit 2013 API
FamilySymbolSet..::..ReverseIterator Method
FamilySymbolSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilySymbolSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FamilySymbolSetIterator
Visual C++
public:
virtual FamilySymbolSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilySymbolSet Class


FamilySymbolSet Properties

[image] [image]

Revit 2013 API
FamilySymbolSet Properties
FamilySymbolSet Class See Also Send Feedback

The FamilySymbolSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of family symbols that are in the set.

See Also

FamilySymbolSet Class


IsEmpty Property

[image]

Revit 2013 API
FamilySymbolSet..::..IsEmpty Property
FamilySymbolSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilySymbolSet Class


Size Property

[image]

Revit 2013 API
FamilySymbolSet..::..Size Property
FamilySymbolSet Class See Also Send Feedback
Returns the number of family symbols that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilySymbolSet Class


FamilySymbolSetIterator Class

[image]

Revit 2013 API
FamilySymbolSetIterator Class
Members See Also Send Feedback
An iterator to a family symbol set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FamilySymbolSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FamilySymbolSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilySymbolSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilySymbolSetIterator

See Also

FamilySymbolSetIterator Members


FamilySymbolSetIterator Members

[image] [image]

Revit 2013 API
FamilySymbolSetIterator Members
FamilySymbolSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FamilySymbolSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Constructor

[image]

Revit 2013 API
FamilySymbolSetIterator Constructor
FamilySymbolSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FamilySymbolSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Methods

[image] [image]

Revit 2013 API
FamilySymbolSetIterator Methods
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilySymbolSetIterator Class


MoveNext Method

[image]

Revit 2013 API
FamilySymbolSetIterator..::..MoveNext Method
FamilySymbolSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class


Reset Method

[image]

Revit 2013 API
FamilySymbolSetIterator..::..Reset Method
FamilySymbolSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilySymbolSetIterator Class


FamilySymbolSetIterator Properties

[image] [image]

Revit 2013 API
FamilySymbolSetIterator Properties
FamilySymbolSetIterator Class See Also Send Feedback

The FamilySymbolSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilySymbolSetIterator Class


Current Property

[image]

Revit 2013 API
FamilySymbolSetIterator..::..Current Property
FamilySymbolSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilySymbolSetIterator Class


FamilyThermalProperties Class

[image]

Revit 2013 API
FamilyThermalProperties Class
Members See Also Send Feedback
A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FamilyThermalProperties : IDisposable
Visual Basic
Public Class FamilyThermalProperties _
    Implements IDisposable
Visual C++
public ref class FamilyThermalProperties : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilyThermalProperties

See Also

FamilyThermalProperties Members


FamilyThermalProperties Members

[image] [image]

Revit 2013 API
FamilyThermalProperties Members
FamilyThermalProperties Class Constructors Methods Properties See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyThermalProperties | Initializes a new instance of the FamilyThermalProperties class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FamilyThermalProperties
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Find | Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class


FamilyThermalProperties Constructor

[image]

Revit 2013 API
FamilyThermalProperties Constructor
FamilyThermalProperties Class See Also Send Feedback
Initializes a new instance of the FamilyThermalProperties class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FamilyThermalProperties()
Visual Basic
Public Sub New
Visual C++
public:
FamilyThermalProperties()

See Also

FamilyThermalProperties Class


FamilyThermalProperties Methods

[image] [image]

Revit 2013 API
FamilyThermalProperties Methods
FamilyThermalProperties Class See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Find | Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyThermalProperties Class


Dispose Method

[image]

Revit 2013 API
FamilyThermalProperties..::..Dispose Method
FamilyThermalProperties Class See Also Send Feedback
Releases all resources used by the FamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilyThermalProperties Class


Find Method

[image]

Revit 2013 API
FamilyThermalProperties..::..Find Method
FamilyThermalProperties Class See Also Send Feedback
Find the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FamilyThermalProperties Find(
    Document pADoc,
    string constructionId
)
Visual Basic
Public Shared Function Find ( _
    pADoc As Document, _
    constructionId As String _
) As FamilyThermalProperties
Visual C++
public:
static FamilyThermalProperties^ Find(
    Document^ pADoc,
    String^ constructionId
)

Parameters

pADoc
Type: Autodesk.Revit.DB..::..Document
The document
constructionId
Type: System..::..String
The 'id' property of a constructionType node in Constructions.xml

Return Value

Return the thermal properties found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyThermalProperties Class


FamilyThermalProperties Properties

[image] [image]

Revit 2013 API
FamilyThermalProperties Properties
FamilyThermalProperties Class See Also Send Feedback

The FamilyThermalProperties type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticConstructionName | The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public property | AnalyticConstructionTypeId | The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | SolarHeatGainCoefficient | The solar heat gain coefficient.
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).
Public property | VisualLightTransmittance | The visual light transmittance.

See Also

FamilyThermalProperties Class


AnalyticConstructionName Property

[image]

Revit 2013 API
FamilyThermalProperties..::..AnalyticConstructionName Property
FamilyThermalProperties Class See Also Send Feedback
The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string AnalyticConstructionName { get; }
Visual Basic
Public ReadOnly Property AnalyticConstructionName As String
    Get
Visual C++
public:
property String^ AnalyticConstructionName {
    String^ get ();
}

See Also

FamilyThermalProperties Class


AnalyticConstructionTypeId Property

[image]

Revit 2013 API
FamilyThermalProperties..::..AnalyticConstructionTypeId Property
FamilyThermalProperties Class See Also Send Feedback
The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string AnalyticConstructionTypeId { get; }
Visual Basic
Public ReadOnly Property AnalyticConstructionTypeId As String
    Get
Visual C++
public:
property String^ AnalyticConstructionTypeId {
    String^ get ();
}

See Also

FamilyThermalProperties Class


HeatTransferCoefficient Property

[image]

Revit 2013 API
FamilyThermalProperties..::..HeatTransferCoefficient Property
FamilyThermalProperties Class See Also Send Feedback
The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double HeatTransferCoefficient { get; }
Visual Basic
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
Visual C++
public:
property double HeatTransferCoefficient {
    double get ();
}

See Also

FamilyThermalProperties Class


SolarHeatGainCoefficient Property

[image]

Revit 2013 API
FamilyThermalProperties..::..SolarHeatGainCoefficient Property
FamilyThermalProperties Class See Also Send Feedback
The solar heat gain coefficient.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SolarHeatGainCoefficient { get; }
Visual Basic
Public ReadOnly Property SolarHeatGainCoefficient As Double
    Get
Visual C++
public:
property double SolarHeatGainCoefficient {
    double get ();
}

See Also

FamilyThermalProperties Class


ThermalResistance Property

[image]

Revit 2013 API
FamilyThermalProperties..::..ThermalResistance Property
FamilyThermalProperties Class See Also Send Feedback
The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ThermalResistance { get; }
Visual Basic
Public ReadOnly Property ThermalResistance As Double
    Get
Visual C++
public:
property double ThermalResistance {
    double get ();
}

See Also

FamilyThermalProperties Class


VisualLightTransmittance Property

[image]

Revit 2013 API
FamilyThermalProperties..::..VisualLightTransmittance Property
FamilyThermalProperties Class See Also Send Feedback
The visual light transmittance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double VisualLightTransmittance { get; }
Visual Basic
Public ReadOnly Property VisualLightTransmittance As Double
    Get
Visual C++
public:
property double VisualLightTransmittance {
    double get ();
}

See Also

FamilyThermalProperties Class


FamilyType Class

[image]

Revit 2013 API
FamilyType Class
Members See Also Send Feedback
The family type object provides read access to the values of family parameters for this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyType : APIObject
Visual Basic
Public Class FamilyType _
    Inherits APIObject
Visual C++
public ref class FamilyType : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyType

See Also

FamilyType Members


FamilyType Members

[image] [image]

Revit 2013 API
FamilyType Members
FamilyType Class Methods Properties See Also Send Feedback

The FamilyType type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The name of the family type.

See Also

FamilyType Class


FamilyType Methods

[image] [image]

Revit 2013 API
FamilyType Methods
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number of the given family parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Public method | AsInteger | Provides access to the integer number of the given family parameter.
Public method | AsString | Provides access to the string contents of the given family parameter.
Public method | AsValueString | Provides access to value as a string with unit in the given family parameter.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Indicates if this family parameter has an assigned value or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyType Class


AsDouble Method

[image]

Revit 2013 API
FamilyType..::..AsDouble Method
FamilyType Class See Also Send Feedback
Provides access to the double precision number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Nullable<double> AsDouble(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsDouble ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Double)
Visual C++
public:
Nullable<double> AsDouble(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The double value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not double type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsElementId Method

[image]

Revit 2013 API
FamilyType..::..AsElementId Method
FamilyType Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AsElementId(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsElementId ( _
    familyParameter As FamilyParameter _
) As ElementId
Visual C++
public:
ElementId^ AsElementId(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsInteger Method

[image]

Revit 2013 API
FamilyType..::..AsInteger Method
FamilyType Class See Also Send Feedback
Provides access to the integer number of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Nullable<int> AsInteger(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsInteger ( _
    familyParameter As FamilyParameter _
) As Nullable(Of Integer)
Visual C++
public:
Nullable<int> AsInteger(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The integer value contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not integer type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsString Method

[image]

Revit 2013 API
FamilyType..::..AsString Method
FamilyType Class See Also Send Feedback
Provides access to the string contents of the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string AsString(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The string contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid,

See Also

FamilyType Class


AsValueString Method

[image]

Revit 2013 API
FamilyType..::..AsValueString Method
FamilyType Class See Also Send Feedback
Provides access to value as a string with unit in the given family parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string AsValueString(
    FamilyParameter familyParameter
)
Visual Basic
Public Function AsValueString ( _
    familyParameter As FamilyParameter _
) As String
Visual C++
public:
String^ AsValueString(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Return Value

The string that represents the parameter value with unit.

Remarks

The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


HasValue Method

[image]

Revit 2013 API
FamilyType..::..HasValue Method
FamilyType Class See Also Send Feedback
Indicates if this family parameter has an assigned value or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasValue(
    FamilyParameter familyParameter
)
Visual Basic
Public Function HasValue ( _
    familyParameter As FamilyParameter _
) As Boolean
Visual C++
public:
bool HasValue(
    FamilyParameter^ familyParameter
)

Parameters

familyParameter
Type: Autodesk.Revit.DB..::..FamilyParameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid.

See Also

FamilyType Class


FamilyType Properties

[image] [image]

Revit 2013 API
FamilyType Properties
FamilyType Class See Also Send Feedback

The FamilyType type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The name of the family type.

See Also

FamilyType Class


Name Property

[image]

Revit 2013 API
FamilyType..::..Name Property
FamilyType Class See Also Send Feedback
The name of the family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

FamilyType Class


FamilyTypeSet Class

[image]

Revit 2013 API
FamilyTypeSet Class
Members See Also Send Feedback
A set that contains FamilyType objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class FamilyTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FamilyTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyTypeSet

See Also

FamilyTypeSet Members


FamilyTypeSet Members

[image] [image]

Revit 2013 API
FamilyTypeSet Members
FamilyTypeSet Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyTypeSet | Initializes a new instance of the FamilyTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class


FamilyTypeSet Constructor

[image]

Revit 2013 API
FamilyTypeSet Constructor
FamilyTypeSet Class See Also Send Feedback
Initializes a new instance of the FamilyTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
FamilyTypeSet()

See Also

FamilyTypeSet Class


FamilyTypeSet Methods

[image] [image]

Revit 2013 API
FamilyTypeSet Methods
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSet Class


Clear Method

[image]

Revit 2013 API
FamilyTypeSet..::..Clear Method
FamilyTypeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FamilyTypeSet Class


Contains Method

[image]

Revit 2013 API
FamilyTypeSet..::..Contains Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    FamilyType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


Erase Method

[image]

Revit 2013 API
FamilyTypeSet..::..Erase Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    FamilyType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FamilyType _
) As Integer
Visual C++
public:
virtual int Erase(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
FamilyTypeSet..::..ForwardIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FamilyTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
FamilyTypeSet..::..GetEnumerator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FamilyTypeSet Class


Insert Method

[image]

Revit 2013 API
FamilyTypeSet..::..Insert Method
FamilyTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    FamilyType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FamilyType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FamilyType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FamilyType

See Also

FamilyTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
FamilyTypeSet..::..ReverseIterator Method
FamilyTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FamilyTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FamilyTypeSetIterator
Visual C++
public:
virtual FamilyTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FamilyTypeSet Class


FamilyTypeSet Properties

[image] [image]

Revit 2013 API
FamilyTypeSet Properties
FamilyTypeSet Class See Also Send Feedback

The FamilyTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

FamilyTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
FamilyTypeSet..::..IsEmpty Property
FamilyTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FamilyTypeSet Class


Size Property

[image]

Revit 2013 API
FamilyTypeSet..::..Size Property
FamilyTypeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FamilyTypeSet Class


FamilyTypeSetIterator Class

[image]

Revit 2013 API
FamilyTypeSetIterator Class
Members See Also Send Feedback
An iterator to a FamilyType set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FamilyTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FamilyTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FamilyTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FamilyTypeSetIterator

See Also

FamilyTypeSetIterator Members


FamilyTypeSetIterator Members

[image] [image]

Revit 2013 API
FamilyTypeSetIterator Members
FamilyTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Constructor

[image]

Revit 2013 API
FamilyTypeSetIterator Constructor
FamilyTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FamilyTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Methods

[image] [image]

Revit 2013 API
FamilyTypeSetIterator Methods
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
FamilyTypeSetIterator..::..MoveNext Method
FamilyTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
FamilyTypeSetIterator..::..Reset Method
FamilyTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FamilyTypeSetIterator Class


FamilyTypeSetIterator Properties

[image] [image]

Revit 2013 API
FamilyTypeSetIterator Properties
FamilyTypeSetIterator Class See Also Send Feedback

The FamilyTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FamilyTypeSetIterator Class


Current Property

[image]

Revit 2013 API
FamilyTypeSetIterator..::..Current Property
FamilyTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FamilyTypeSetIterator Class


FamilyUtils Class

[image]

Revit 2013 API
FamilyUtils Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FamilyUtils : IDisposable
Visual Basic
Public Class FamilyUtils _
    Implements IDisposable
Visual C++
public ref class FamilyUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FamilyUtils

See Also

FamilyUtils Members


FamilyUtils Members

[image] [image]

Revit 2013 API
FamilyUtils Members
FamilyUtils Class Methods See Also Send Feedback

The FamilyUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertFamilyToFaceHostBased | Converts a family to be face host based.
Public method | Dispose | Releases all resources used by the FamilyUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyUtils Class


FamilyUtils Methods

[image] [image]

Revit 2013 API
FamilyUtils Methods
FamilyUtils Class See Also Send Feedback

The FamilyUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertFamilyToFaceHostBased | Converts a family to be face host based.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FamilyCanConvertToFaceHostBased | Indicates whether the family can be converted to face host based.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyUtils Class


ConvertFamilyToFaceHostBased Method

[image]

Revit 2013 API
FamilyUtils..::..ConvertFamilyToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Converts a family to be face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static void ConvertFamilyToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic
Public Shared Sub ConvertFamilyToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
)
Visual C++
public:
static void ConvertFamilyToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the family to be converted.
famId
Type: Autodesk.Revit.DB..::..ElementId
The family id.

Remarks

Converts a family hosted by some element other than a face to be hosted by a face. This is done by replacing the existing host (wall, roof, ceiling, floor) with a face. Conversion can succeed only if FamilyUtils.FamilyCanConvertToFaceHostBased() returns true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input famId cannot be converted to face host based.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The family is already unhosted. -or- Failed to convert the family to face host based.

See Also

FamilyUtils Class


Dispose Method

[image]

Revit 2013 API
FamilyUtils..::..Dispose Method
FamilyUtils Class See Also Send Feedback
Releases all resources used by the FamilyUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FamilyUtils Class


FamilyCanConvertToFaceHostBased Method

[image]

Revit 2013 API
FamilyUtils..::..FamilyCanConvertToFaceHostBased Method
FamilyUtils Class See Also Send Feedback
Indicates whether the family can be converted to face host based.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool FamilyCanConvertToFaceHostBased(
    Document aDoc,
    ElementId famId
)
Visual Basic
Public Shared Function FamilyCanConvertToFaceHostBased ( _
    aDoc As Document, _
    famId As ElementId _
) As Boolean
Visual C++
public:
static bool FamilyCanConvertToFaceHostBased(
    Document^ aDoc,
    ElementId^ famId
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
famId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if the family can be converted to face-based. Otherwise false, which will be returned if there any family instances exist in the project, the family is already face-based, or the family does not have a host. Also, false is returned if the family does not belong to one of the following categories:
  • OST_CommunicationDevices
  • OST_DataDevices
  • OST_DuctTerminal
  • OST_ElectricalEquipment
  • OST_ElectricalFixtures
  • OST_FireAlarmDevices
  • OST_LightingDevices
  • OST_LightingFixtures
  • OST_MechanicalEquipment
  • OST_NurseCallDevices
  • OST_PlumbingFixtures
  • OST_SecurityDevices
  • OST_Sprinklers
  • OST_TelephoneDevices

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FamilyUtils Class


FBXExportOptions Class

[image]

Revit 2013 API
FBXExportOptions Class
Members See Also Send Feedback
3D-Studio Max (FBX) Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FBXExportOptions
Visual Basic
Public Class FBXExportOptions
Visual C++
public ref class FBXExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FBXExportOptions

See Also

FBXExportOptions Members


FBXExportOptions Members

[image] [image]

Revit 2013 API
FBXExportOptions Members
FBXExportOptions Class Constructors Methods Properties See Also Send Feedback

The FBXExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | FBXExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.

See Also

FBXExportOptions Class


FBXExportOptions Constructor

[image]

Revit 2013 API
FBXExportOptions Constructor
FBXExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FBXExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
FBXExportOptions()

See Also

FBXExportOptions Class


FBXExportOptions Methods

[image] [image]

Revit 2013 API
FBXExportOptions Methods
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FBXExportOptions Class


FBXExportOptions Properties

[image] [image]

Revit 2013 API
FBXExportOptions Properties
FBXExportOptions Class See Also Send Feedback

The FBXExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | LevelsOfDetailValue | The value of the levels of detail.
Public property | StopOnError | Whether export process should stop when a view fails to export.
Public property | UseLevelsOfDetail | True to use levels of detail, false otherwise.
Public property | WithoutBoundaryEdges | True to export without boundary edges, false otherwise.

See Also

FBXExportOptions Class


LevelsOfDetailValue Property

[image]

Revit 2013 API
FBXExportOptions..::..LevelsOfDetailValue Property
FBXExportOptions Class See Also Send Feedback
The value of the levels of detail.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int LevelsOfDetailValue { get; set; }
Visual Basic
Public Property LevelsOfDetailValue As Integer
    Get
    Set
Visual C++
public:
property int LevelsOfDetailValue {
    int get ();
    void set (int value);
}

Field Value

To use this option, UseLevelsOfDetail should be set to true. And the value should be in the range [0, 15]. It will be calculated based on the settings of current view if it's not assigned a valid value.

See Also

FBXExportOptions Class


StopOnError Property

[image]

Revit 2013 API
FBXExportOptions..::..StopOnError Property
FBXExportOptions Class See Also Send Feedback
Whether export process should stop when a view fails to export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool StopOnError { get; set; }
Visual Basic
Public Property StopOnError As Boolean
    Get
    Set
Visual C++
public:
property bool StopOnError {
    bool get ();
    void set (bool value);
}

Remarks

If set to false, the export would continue until all views are processed. This option has an effect only when a set of more than one view is specified.

See Also

FBXExportOptions Class


UseLevelsOfDetail Property

[image]

Revit 2013 API
FBXExportOptions..::..UseLevelsOfDetail Property
FBXExportOptions Class See Also Send Feedback
True to use levels of detail, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool UseLevelsOfDetail { get; set; }
Visual Basic
Public Property UseLevelsOfDetail As Boolean
    Get
    Set
Visual C++
public:
property bool UseLevelsOfDetail {
    bool get ();
    void set (bool value);
}

Field Value

The default value is false.

See Also

FBXExportOptions Class


WithoutBoundaryEdges Property

[image]

Revit 2013 API
FBXExportOptions..::..WithoutBoundaryEdges Property
FBXExportOptions Class See Also Send Feedback
True to export without boundary edges, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool WithoutBoundaryEdges { get; set; }
Visual Basic
Public Property WithoutBoundaryEdges As Boolean
    Get
    Set
Visual C++
public:
property bool WithoutBoundaryEdges {
    bool get ();
    void set (bool value);
}

Field Value

The default value is false.

See Also

FBXExportOptions Class


FilePath Class

[image]

Revit 2013 API
FilePath Class
Members See Also Send Feedback
This class represents a path on a disk or network location, but not a path to a Revit server location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FilePath : ModelPath
Visual Basic
Public Class FilePath _
    Inherits ModelPath
Visual C++
public ref class FilePath : public ModelPath

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..FilePath

See Also

FilePath Members


FilePath Members

[image] [image]

Revit 2013 API
FilePath Members
FilePath Class Constructors Methods Properties See Also Send Feedback

The FilePath type exposes the following members.

Constructors

 | Name | Description
Public method | FilePath | Constructs a FilePath

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another; (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path or a file path; (Inherited from ModelPath.)

See Also

FilePath Class


FilePath Constructor

[image]

Revit 2013 API
FilePath Constructor
FilePath Class See Also Send Feedback
Constructs a FilePath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilePath(
    string path
)
Visual Basic
Public Sub New ( _
    path As String _
)
Visual C++
public:
FilePath(
    String^ path
)

Parameters

path
Type: System..::..String
The path to the file. This path does not have to be a full path; it can be relative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilePath Class


FilePath Methods

[image] [image]

Revit 2013 API
FilePath Methods
FilePath Class See Also Send Feedback

The FilePath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another; (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePath Class


FilePath Properties

[image] [image]

Revit 2013 API
FilePath Properties
FilePath Class See Also Send Feedback

The FilePath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path or a file path; (Inherited from ModelPath.)

See Also

FilePath Class


FilledRegion Class

[image]

Revit 2013 API
FilledRegion Class
Members See Also Send Feedback
A filled region element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FilledRegion : Element
Visual Basic
Public Class FilledRegion _
    Inherits Element
Visual C++
public ref class FilledRegion : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilledRegion

See Also

FilledRegion Members


FilledRegion Members

[image] [image]

Revit 2013 API
FilledRegion Members
FilledRegion Class Methods Properties See Also Send Feedback

The FilledRegion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a filled region from the given boundaries.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLineStyleId | Sets the line style Id for all boundaries.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMasking | Indicates whether the filled region is masking or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegion Class


FilledRegion Methods

[image] [image]

Revit 2013 API
FilledRegion Methods
FilledRegion Class See Also Send Feedback

The FilledRegion type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a filled region from the given boundaries.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundaries | Gets the boundaries.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidLineStyleIdsForFilledRegion | Gets the line style Ids which are permitted to be assigned to a filled region.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidFilledRegionTypeId | Indicates whether the given Id is a valid filled region type Id.
 | IsValidLineStyleIdForFilledRegion | Indicates whether the given Id is a valid line style Id.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLineStyleId | Sets the line style Id for all boundaries.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilledRegion Class


Create Method

[image]

Revit 2013 API
FilledRegion..::..Create Method
FilledRegion Class See Also Send Feedback
Creates a filled region from the given boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FilledRegion Create(
    Document document,
    ElementId typeId,
    ElementId viewId,
    IList<CurveLoop> boundaries
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    viewId As ElementId, _
    boundaries As IList(Of CurveLoop) _
) As FilledRegion
Visual C++
public:
static FilledRegion^ Create(
    Document^ document,
    ElementId^ typeId,
    ElementId^ viewId,
    IList<CurveLoop^>^ boundaries
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the filled region.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The filled region type Id.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view Id.
boundaries
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The boundaries.

Return Value

The newly created filled region.

Remarks

The line style of the boundaries will be set to thin lines by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Id typeId is invalid. -or- Thrown if the viewId or typeId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilledRegion Class


GetBoundaries Method

[image]

Revit 2013 API
FilledRegion..::..GetBoundaries Method
FilledRegion Class See Also Send Feedback
Gets the boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<CurveLoop> GetBoundaries()
Visual Basic
Public Function GetBoundaries As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetBoundaries()

Return Value

The filled region boundaries.

See Also

FilledRegion Class


GetValidLineStyleIdsForFilledRegion Method

[image]

Revit 2013 API
FilledRegion..::..GetValidLineStyleIdsForFilledRegion Method
FilledRegion Class See Also Send Feedback
Gets the line style Ids which are permitted to be assigned to a filled region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ElementId> GetValidLineStyleIdsForFilledRegion(
    Document document
)
Visual Basic
Public Shared Function GetValidLineStyleIdsForFilledRegion ( _
    document As Document _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetValidLineStyleIdsForFilledRegion(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The valid line style Ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilledRegion Class


IsValidFilledRegionTypeId Method

[image]

Revit 2013 API
FilledRegion..::..IsValidFilledRegionTypeId Method
FilledRegion Class See Also Send Feedback
Indicates whether the given Id is a valid filled region type Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidFilledRegionTypeId(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function IsValidFilledRegionTypeId ( _
    document As Document, _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidFilledRegionTypeId(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The filled region type Id.

Return Value

True if it is a valid filled region type Id, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilledRegion Class


IsValidLineStyleIdForFilledRegion Method

[image]

Revit 2013 API
FilledRegion..::..IsValidLineStyleIdForFilledRegion Method
FilledRegion Class See Also Send Feedback
Indicates whether the given Id is a valid line style Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidLineStyleIdForFilledRegion(
    Document document,
    ElementId lineStyleId
)
Visual Basic
Public Shared Function IsValidLineStyleIdForFilledRegion ( _
    document As Document, _
    lineStyleId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidLineStyleIdForFilledRegion(
    Document^ document,
    ElementId^ lineStyleId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
lineStyleId
Type: Autodesk.Revit.DB..::..ElementId
The line style Id.

Return Value

True if it is a valid line style Id, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilledRegion Class


SetLineStyleId Method

[image]

Revit 2013 API
FilledRegion..::..SetLineStyleId Method
FilledRegion Class See Also Send Feedback
Sets the line style Id for all boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLineStyleId(
    ElementId lineStyleId
)
Visual Basic
Public Sub SetLineStyleId ( _
    lineStyleId As ElementId _
)
Visual C++
public:
void SetLineStyleId(
    ElementId^ lineStyleId
)

Parameters

lineStyleId
Type: Autodesk.Revit.DB..::..ElementId
The line style Id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | lineStyleId is not a valid line style Id for a filled region.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilledRegion Class


FilledRegion Properties

[image] [image]

Revit 2013 API
FilledRegion Properties
FilledRegion Class See Also Send Feedback

The FilledRegion type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMasking | Indicates whether the filled region is masking or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegion Class


IsMasking Property

[image]

Revit 2013 API
FilledRegion..::..IsMasking Property
FilledRegion Class See Also Send Feedback
Indicates whether the filled region is masking or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsMasking { get; }
Visual Basic
Public ReadOnly Property IsMasking As Boolean
    Get
Visual C++
public:
property bool IsMasking {
    bool get ();
}

See Also

FilledRegion Class


Parameter Property

[image] [image]

Revit 2013 API
FilledRegion..::..Parameter Property
FilledRegion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FilledRegion Class
FilledRegion Members


FilledRegionBackground Enumeration

[image]

Revit 2013 API
FilledRegionBackground Enumeration
See Also Send Feedback
The filled region background types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum FilledRegionBackground
Visual Basic
Public Enumeration FilledRegionBackground
Visual C++
public enum class FilledRegionBackground

Members

Member name | Description
Opaque | Opaque background.
Transparent | Transparent background.

See Also


FilledRegionType Class

[image]

Revit 2013 API
FilledRegionType Class
Members See Also Send Feedback
A filled region attributes element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FilledRegionType : LineAndTextAttrSymbol
Visual Basic
Public Class FilledRegionType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class FilledRegionType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..FilledRegionType

See Also

FilledRegionType Members


FilledRegionType Members

[image] [image]

Revit 2013 API
FilledRegionType Members
FilledRegionType Class Methods Properties See Also Send Feedback

The FilledRegionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
 | IsValidLineWeight | Indicates whether the given line weight value is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Background | The background.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the fill pattern.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FillPatternId | The fill pattern Id.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWeight | The line weight of the fill pattern.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegionType Class


FilledRegionType Methods

[image] [image]

Revit 2013 API
FilledRegionType Methods
FilledRegionType Class See Also Send Feedback

The FilledRegionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
 | IsValidLineWeight | Indicates whether the given line weight value is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilledRegionType Class


IsValidLineWeight Method

[image]

Revit 2013 API
FilledRegionType..::..IsValidLineWeight Method
FilledRegionType Class See Also Send Feedback
Indicates whether the given line weight value is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidLineWeight(
    int lineWeight
)
Visual Basic
Public Shared Function IsValidLineWeight ( _
    lineWeight As Integer _
) As Boolean
Visual C++
public:
static bool IsValidLineWeight(
    int lineWeight
)

Parameters

lineWeight
Type: System..::..Int32
The line weight.

Return Value

True if it is a valid line weight value, false otherwise.

See Also

FilledRegionType Class


FilledRegionType Properties

[image] [image]

Revit 2013 API
FilledRegionType Properties
FilledRegionType Class See Also Send Feedback

The FilledRegionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Background | The background.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the fill pattern.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FillPatternId | The fill pattern Id.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWeight | The line weight of the fill pattern.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilledRegionType Class


Background Property

[image]

Revit 2013 API
FilledRegionType..::..Background Property
FilledRegionType Class See Also Send Feedback
The background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FilledRegionBackground Background { get; set; }
Visual Basic
Public Property Background As FilledRegionBackground
    Get
    Set
Visual C++
public:
property FilledRegionBackground Background {
    FilledRegionBackground get ();
    void set (FilledRegionBackground value);
}

See Also

FilledRegionType Class


Color Property

[image]

Revit 2013 API
FilledRegionType..::..Color Property
FilledRegionType Class See Also Send Feedback
The color of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FilledRegionType Class


FillPatternId Property

[image]

Revit 2013 API
FilledRegionType..::..FillPatternId Property
FilledRegionType Class See Also Send Feedback
The fill pattern Id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId FillPatternId { get; set; }
Visual Basic
Public Property FillPatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FillPatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FilledRegionType Class


LineWeight Property

[image]

Revit 2013 API
FilledRegionType..::..LineWeight Property
FilledRegionType Class See Also Send Feedback
The line weight of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int LineWeight { get; set; }
Visual Basic
Public Property LineWeight As Integer
    Get
    Set
Visual C++
public:
property int LineWeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: lineWeight is not a valid line weight value (it must be within the range of 1-16).

See Also

FilledRegionType Class


Parameter Property

[image] [image]

Revit 2013 API
FilledRegionType..::..Parameter Property
FilledRegionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FilledRegionType Class
FilledRegionType Members


FillGrid Class

[image]

Revit 2013 API
FillGrid Class
Members See Also Send Feedback
Represents a grid line in a fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FillGrid : IDisposable
Visual Basic
Public Class FillGrid _
    Implements IDisposable
Visual C++
public ref class FillGrid : IDisposable

Remarks

A grid line is described in the two dimensions of a face as follows: angle, origin, shift, offset, segments
  • Angle specifies the direction, in degrees, of the grid line relative to the x-axis.
  • Parallel lines are drawn as specified by Offset and Shift to fill the entire face. Offset defines the distance between parallel lines. Zero Offset is not allowed. Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.
  • The segments defines a repeating pattern of dashes and spaces for the grid line. If it is omitted, the line is solid. Positive numbers define dashes, negative numbers define spaces, and zero specifies a dot. If you begin a pattern with a space, do not alternate dashes and spaces, or do not end with a space, Revit will introduce tiny dashes or spaces to compensate. Revit expands dots and very short dashes into dashes of a minimum size.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FillGrid

See Also

FillGrid Members


FillGrid Members

[image] [image]

Revit 2013 API
FillGrid Members
FillGrid Class Constructors Methods Properties See Also Send Feedback

The FillGrid type exposes the following members.

Constructors

 | Name | Description
Public method | FillGrid()()()() | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Creates a copy of a fill grid.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and spacing.

Methods

 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose | Releases all resources used by the FillGrid
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.

See Also

FillGrid Class


FillGrid Constructor

[image] [image]

Revit 2013 API
FillGrid Constructor
FillGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillGrid()()()() | Creates a simple fill grid.
Public method | FillGrid(FillGrid) | Creates a copy of a fill grid.
Public method | FillGrid(Double, Double) | Creates a simple fill grid with given angle and spacing.

See Also

FillGrid Class
FillGrid Members


FillGrid Constructor

[image]

Revit 2013 API
FillGrid Constructor
FillGrid Class See Also Send Feedback
Creates a simple fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FillGrid()
Visual Basic
Public Sub New
Visual C++
public:
FillGrid()

See Also

FillGrid Class
FillGrid Overload


FillGrid Constructor (FillGrid)

[image]

Revit 2013 API
FillGrid Constructor (FillGrid)
FillGrid Class See Also Send Feedback
Creates a copy of a fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FillGrid(
    FillGrid sourceGrid
)
Visual Basic
Public Sub New ( _
    sourceGrid As FillGrid _
)
Visual C++
public:
FillGrid(
    FillGrid^ sourceGrid
)

Parameters

sourceGrid
Type: Autodesk.Revit.DB..::..FillGrid
The fill grid to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillGrid Class
FillGrid Overload


FillGrid Constructor (Double, Double)

[image]

Revit 2013 API
FillGrid Constructor (Double, Double)
FillGrid Class See Also Send Feedback
Creates a simple fill grid with given angle and spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FillGrid(
    double angle,
    double spacing
)
Visual Basic
Public Sub New ( _
    angle As Double, _
    spacing As Double _
)
Visual C++
public:
FillGrid(
    double angle,
    double spacing
)

Parameters

angle
Type: System..::..Double
The angle.
spacing
Type: System..::..Double
The spacing.

See Also

FillGrid Class
FillGrid Overload


FillGrid Methods

[image] [image]

Revit 2013 API
FillGrid Methods
FillGrid Class See Also Send Feedback

The FillGrid type exposes the following members.

Methods

 | Name | Description
Public method | CalculateLengthPerArea | Calculates length of the pattern per unit area.
Public method | CalculateLinesPerLength | Calculates the number of solid lines of the pattern per unit length.
Public method | CalculateStrokesPerArea | Calculates the number of the segments of the pattern per unit area.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHatchingDirection | Provides the hatching propagation. Hatching is inverted.
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.
Public method | GetSegmentDirection | Provides the segment direction.
Public method | GetSegments | Gets the segments of the fill grid.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if two fill grids are equal.
Public method | SetSegments | Sets the segments to the fill grid.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillGrid Class


CalculateLengthPerArea Method

[image]

Revit 2013 API
FillGrid..::..CalculateLengthPerArea Method
FillGrid Class See Also Send Feedback
Calculates length of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double CalculateLengthPerArea()
Visual Basic
Public Function CalculateLengthPerArea As Double
Visual C++
public:
double CalculateLengthPerArea()

Return Value

The length per area.

See Also

FillGrid Class


CalculateLinesPerLength Method

[image]

Revit 2013 API
FillGrid..::..CalculateLinesPerLength Method
FillGrid Class See Also Send Feedback
Calculates the number of solid lines of the pattern per unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double CalculateLinesPerLength()
Visual Basic
Public Function CalculateLinesPerLength As Double
Visual C++
public:
double CalculateLinesPerLength()

Return Value

The solid lines per length.

See Also

FillGrid Class


CalculateStrokesPerArea Method

[image]

Revit 2013 API
FillGrid..::..CalculateStrokesPerArea Method
FillGrid Class See Also Send Feedback
Calculates the number of the segments of the pattern per unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double CalculateStrokesPerArea()
Visual Basic
Public Function CalculateStrokesPerArea As Double
Visual C++
public:
double CalculateStrokesPerArea()

Return Value

The strokes per area.

See Also

FillGrid Class


Dispose Method

[image]

Revit 2013 API
FillGrid..::..Dispose Method
FillGrid Class See Also Send Feedback
Releases all resources used by the FillGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FillGrid Class


GetHatchingDirection Method

[image]

Revit 2013 API
FillGrid..::..GetHatchingDirection Method
FillGrid Class See Also Send Feedback
Provides the hatching propagation. Hatching is inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV GetHatchingDirection()
Visual Basic
Public Function GetHatchingDirection As UV
Visual C++
public:
UV^ GetHatchingDirection()

Return Value

The direction of hatching.

See Also

FillGrid Class


GetPointLineZone Method

[image] [image]

Revit 2013 API
FillGrid..::..GetPointLineZone Method
FillGrid Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPointLineZone(UV) | Gets the index of fill grid line closest to the input 2d point.
Public method | GetPointLineZone(UV, UV%) | Gets the index of fill grid line and the point on the grid line nearest to the input point.

See Also

FillGrid Class
FillGrid Members


GetPointLineZone Method (UV)

[image]

Revit 2013 API
FillGrid..::..GetPointLineZone Method (UV)
FillGrid Class See Also Send Feedback
Gets the index of fill grid line closest to the input 2d point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetPointLineZone(
    UV point
)
Visual Basic
Public Function GetPointLineZone ( _
    point As UV _
) As Integer
Visual C++
public:
int GetPointLineZone(
    UV^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
Input point.

Return Value

The index of fill grid line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillGrid Class
GetPointLineZone Overload


GetPointLineZone Method (UV, UV)

[image]

Revit 2013 API
FillGrid..::..GetPointLineZone Method (UV, UV%)
FillGrid Class See Also Send Feedback
Gets the index of fill grid line and the point on the grid line nearest to the input point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetPointLineZone(
    UV point,
    out UV nearestPoint
)
Visual Basic
Public Function GetPointLineZone ( _
    point As UV, _
    <OutAttribute> ByRef nearestPoint As UV _
) As Integer
Visual C++
public:
int GetPointLineZone(
    UV^ point,
    [OutAttribute] UV^% nearestPoint
)

Parameters

point
Type: Autodesk.Revit.DB..::..UV
Input point.
nearestPoint
Type: Autodesk.Revit.DB..::..UV%
The point on the grid line nearest to the input point.

Return Value

The index of fill grid line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillGrid Class
GetPointLineZone Overload


GetSegmentDirection Method

[image]

Revit 2013 API
FillGrid..::..GetSegmentDirection Method
FillGrid Class See Also Send Feedback
Provides the segment direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV GetSegmentDirection()
Visual Basic
Public Function GetSegmentDirection As UV
Visual C++
public:
UV^ GetSegmentDirection()

Return Value

The direction of segment.

See Also

FillGrid Class


GetSegments Method

[image]

Revit 2013 API
FillGrid..::..GetSegments Method
FillGrid Class See Also Send Feedback
Gets the segments of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<double> GetSegments()
Visual Basic
Public Function GetSegments As IList(Of Double)
Visual C++
public:
IList<double>^ GetSegments()

Return Value

The segments.

See Also

FillGrid Class


IsEqual Method

[image]

Revit 2013 API
FillGrid..::..IsEqual Method
FillGrid Class See Also Send Feedback
Check if two fill grids are equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEqual(
    FillGrid other
)
Visual Basic
Public Function IsEqual ( _
    other As FillGrid _
) As Boolean
Visual C++
public:
bool IsEqual(
    FillGrid^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FillGrid
The fill grid to be compared.

Return Value

True if the two fill grids are equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillGrid Class


SetSegments Method

[image]

Revit 2013 API
FillGrid..::..SetSegments Method
FillGrid Class See Also Send Feedback
Sets the segments to the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetSegments(
    IList<double> segArr
)
Visual Basic
Public Sub SetSegments ( _
    segArr As IList(Of Double) _
)
Visual C++
public:
void SetSegments(
    IList<double>^ segArr
)

Parameters

segArr
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The segments to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillGrid Class


FillGrid Properties

[image] [image]

Revit 2013 API
FillGrid Properties
FillGrid Class See Also Send Feedback

The FillGrid type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Gets and sets the angle of the fill grid.
Public property | Offset | Gets and sets the offset of the fill grid.
Public property | Origin | Gets and sets the origin of the fill grid.
Public property | Shift | Gets and sets the shift of the fill grid.

See Also

FillGrid Class


Angle Property

[image]

Revit 2013 API
FillGrid..::..Angle Property
FillGrid Class See Also Send Feedback
Gets and sets the angle of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

FillGrid Class


Offset Property

[image]

Revit 2013 API
FillGrid..::..Offset Property
FillGrid Class See Also Send Feedback
Gets and sets the offset of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Field Value

The offset of the fill grid.

Remarks

Offset defines the distance between parallel lines. A zero offset is not allowed.

See Also

FillGrid Class


Origin Property

[image]

Revit 2013 API
FillGrid..::..Origin Property
FillGrid Class See Also Send Feedback
Gets and sets the origin of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Origin { get; set; }
Visual Basic
Public Property Origin As UV
    Get
    Set
Visual C++
public:
property UV^ Origin {
    UV^ get ();
    void set (UV^ value);
}

Field Value

The origin of the fill grid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FillGrid Class


Shift Property

[image]

Revit 2013 API
FillGrid..::..Shift Property
FillGrid Class See Also Send Feedback
Gets and sets the shift of the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Shift { get; set; }
Visual Basic
Public Property Shift As Double
    Get
    Set
Visual C++
public:
property double Shift {
    double get ();
    void set (double value);
}

Field Value

The shift of the fill grid.

Remarks

Shift moves the pattern of dashes and spaces along the length of each new parallel line. Shift is ignored if the line is solid.

See Also

FillGrid Class


FillPattern Class

[image]

Revit 2013 API
FillPattern Class
Members See Also Send Feedback
Represents a fill pattern object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FillPattern : IDisposable
Visual Basic
Public Class FillPattern _
    Implements IDisposable
Visual C++
public ref class FillPattern : IDisposable

Remarks

Fill patterns control the appearance of surfaces that are cut or shown in projection. A simple fill pattern consists of a series of parallel or orthogonal lines. Note - Dots are coded as zero-length dashes in the fill pattern definition. When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything. So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FillPattern

See Also

FillPattern Members


FillPattern Members

[image] [image]

Revit 2013 API
FillPattern Members
FillPattern Class Constructors Methods Properties See Also Send Feedback

The FillPattern type exposes the following members.

Constructors

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Creates a copy of a fill pattern.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FillPattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if the contents in two fill patterns are equal.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class


FillPattern Constructor

[image] [image]

Revit 2013 API
FillPattern Constructor
FillPattern Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FillPattern()()()() | Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.
Public method | FillPattern(FillPattern) | Creates a copy of a fill pattern.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation) | Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double) | Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Public method | FillPattern(String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double) | Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

See Also

FillPattern Class
FillPattern Members


FillPattern Constructor

[image]

Revit 2013 API
FillPattern Constructor
FillPattern Class See Also Send Feedback
Creates a fill pattern with FillPatternHostOrientation::FPORIENTATION_TO_VIEW and FillPatternTarget::FPTARGET_NONE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern()
Visual Basic
Public Sub New
Visual C++
public:
FillPattern()

See Also

FillPattern Class
FillPattern Overload


FillPattern Constructor (FillPattern)

[image]

Revit 2013 API
FillPattern Constructor (FillPattern)
FillPattern Class See Also Send Feedback
Creates a copy of a fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    FillPattern from
)
Visual Basic
Public Sub New ( _
    from As FillPattern _
)
Visual C++
public:
FillPattern(
    FillPattern^ from
)

Parameters

from
Type: Autodesk.Revit.DB..::..FillPattern
The fill pattern to be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload


FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)

[image]

Revit 2013 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation)
FillPattern Class See Also Send Feedback
Creates a fill pattern based on the given name, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload


FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double)

[image]

Revit 2013 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double)
FillPattern Class See Also Send Feedback
Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation, _
    angle As Double, _
    spacing1 As Double _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.
angle
Type: System..::..Double
The angle.
spacing1
Type: System..::..Double
The spacing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload


FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double)

[image]

Revit 2013 API
FillPattern Constructor (String, FillPatternTarget, FillPatternHostOrientation, Double, Double, Double)
FillPattern Class See Also Send Feedback
Creates a simple crosshatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPattern(
    string name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)
Visual Basic
Public Sub New ( _
    name As String, _
    target As FillPatternTarget, _
    orientation As FillPatternHostOrientation, _
    angle As Double, _
    spacing1 As Double, _
    spacing2 As Double _
)
Visual C++
public:
FillPattern(
    String^ name,
    FillPatternTarget target,
    FillPatternHostOrientation orientation,
    double angle,
    double spacing1,
    double spacing2
)

Parameters

name
Type: System..::..String
The name.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
orientation
Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.
angle
Type: System..::..Double
The angle.
spacing1
Type: System..::..Double
The spacing.
spacing2
Type: System..::..Double
The spacing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class
FillPattern Overload


FillPattern Methods

[image] [image]

Revit 2013 API
FillPattern Methods
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExpandDots | Corrects pattern dots to make them be drawn properly for Revit.
Public method | GetFillGrid | Gets the specified fill grid.
Public method | GetFillGrids | Gets all fill grids in this fill pattern
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Check if the contents in two fill patterns are equal.
Public method | SetFillGrid | Sets the fill grid.
Public method | SetFillGrids | Set the fill grids in this fill pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPattern Class


Dispose Method

[image]

Revit 2013 API
FillPattern..::..Dispose Method
FillPattern Class See Also Send Feedback
Releases all resources used by the FillPattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FillPattern Class


ExpandDots Method

[image]

Revit 2013 API
FillPattern..::..ExpandDots Method
FillPattern Class See Also Send Feedback
Corrects pattern dots to make them be drawn properly for Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ExpandDots()
Visual Basic
Public Function ExpandDots As Boolean
Visual C++
public:
bool ExpandDots()

Return Value

Indicates whether any dots were in fact expanded.

See Also

FillPattern Class


GetFillGrid Method

[image]

Revit 2013 API
FillPattern..::..GetFillGrid Method
FillPattern Class See Also Send Feedback
Gets the specified fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillGrid GetFillGrid(
    int gridIdx
)
Visual Basic
Public Function GetFillGrid ( _
    gridIdx As Integer _
) As FillGrid
Visual C++
public:
FillGrid^ GetFillGrid(
    int gridIdx
)

Parameters

gridIdx
Type: System..::..Int32
The index of the fill grid.

Return Value

The fill grid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index of the FillGrid is not valid.

See Also

FillPattern Class


GetFillGrids Method

[image]

Revit 2013 API
FillPattern..::..GetFillGrids Method
FillPattern Class See Also Send Feedback
Gets all fill grids in this fill pattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<FillGrid> GetFillGrids()
Visual Basic
Public Function GetFillGrids As IList(Of FillGrid)
Visual C++
public:
IList<FillGrid^>^ GetFillGrids()

Return Value

The fill grids.

See Also

FillPattern Class


IsEqual Method

[image]

Revit 2013 API
FillPattern..::..IsEqual Method
FillPattern Class See Also Send Feedback
Check if the contents in two fill patterns are equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEqual(
    FillPattern other
)
Visual Basic
Public Function IsEqual ( _
    other As FillPattern _
) As Boolean
Visual C++
public:
bool IsEqual(
    FillPattern^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FillPattern
The fill pattern to be compared.

Return Value

True for equal, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class


SetFillGrid Method

[image]

Revit 2013 API
FillPattern..::..SetFillGrid Method
FillPattern Class See Also Send Feedback
Sets the fill grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFillGrid(
    int gridIdx,
    FillGrid fillGrid
)
Visual Basic
Public Sub SetFillGrid ( _
    gridIdx As Integer, _
    fillGrid As FillGrid _
)
Visual C++
public:
void SetFillGrid(
    int gridIdx,
    FillGrid^ fillGrid
)

Parameters

gridIdx
Type: System..::..Int32
The index of the fill grid.
fillGrid
Type: Autodesk.Revit.DB..::..FillGrid
The fill grid to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class


SetFillGrids Method

[image]

Revit 2013 API
FillPattern..::..SetFillGrids Method
FillPattern Class See Also Send Feedback
Set the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFillGrids(
    IList<FillGrid> fillGrids
)
Visual Basic
Public Sub SetFillGrids ( _
    fillGrids As IList(Of FillGrid) _
)
Visual C++
public:
void SetFillGrids(
    IList<FillGrid^>^ fillGrids
)

Parameters

fillGrids
Type: System.Collections.Generic..::..IList<(Of <(<'FillGrid>)>)>
The fill grids to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPattern Class


FillPattern Properties

[image] [image]

Revit 2013 API
FillPattern Properties
FillPattern Class See Also Send Feedback

The FillPattern type exposes the following members.

Properties

 | Name | Description
Public property | GridCount | Gets the count of the fill grids in this fill pattern.
Public property | HostOrientation | Orientation to host layer.
Public property | IsSolidFill | Check if the fill pattern is a solid fill pattern.
Public property | LengthPerArea | Gets length of all lines that placed on unit area.
Public property | LinesPerLength | Gets the number of solid lines that placed in unit length.
Public property | Name | The name of the fill pattern.
Public property | StrokesPerArea | Gets the number of strokes that placed on unit area.
Public property | Target | Target of this fill pattern applied to.

See Also

FillPattern Class


GridCount Property

[image]

Revit 2013 API
FillPattern..::..GridCount Property
FillPattern Class See Also Send Feedback
Gets the count of the fill grids in this fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GridCount { get; }
Visual Basic
Public ReadOnly Property GridCount As Integer
    Get
Visual C++
public:
property int GridCount {
    int get ();
}

Field Value

The count of the fill grids.

See Also

FillPattern Class


HostOrientation Property

[image]

Revit 2013 API
FillPattern..::..HostOrientation Property
FillPattern Class See Also Send Feedback
Orientation to host layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPatternHostOrientation HostOrientation { get; set; }
Visual Basic
Public Property HostOrientation As FillPatternHostOrientation
    Get
    Set
Visual C++
public:
property FillPatternHostOrientation HostOrientation {
    FillPatternHostOrientation get ();
    void set (FillPatternHostOrientation value);
}

See Also

FillPattern Class


IsSolidFill Property

[image]

Revit 2013 API
FillPattern..::..IsSolidFill Property
FillPattern Class See Also Send Feedback
Check if the fill pattern is a solid fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSolidFill { get; }
Visual Basic
Public ReadOnly Property IsSolidFill As Boolean
    Get
Visual C++
public:
property bool IsSolidFill {
    bool get ();
}

Field Value

Check if the fill pattern is a solid fill pattern.

See Also

FillPattern Class


LengthPerArea Property

[image]

Revit 2013 API
FillPattern..::..LengthPerArea Property
FillPattern Class See Also Send Feedback
Gets length of all lines that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LengthPerArea { get; }
Visual Basic
Public ReadOnly Property LengthPerArea As Double
    Get
Visual C++
public:
property double LengthPerArea {
    double get ();
}

Field Value

The length of all lines that placed on unit area.

See Also

FillPattern Class


LinesPerLength Property

[image]

Revit 2013 API
FillPattern..::..LinesPerLength Property
FillPattern Class See Also Send Feedback
Gets the number of solid lines that placed in unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LinesPerLength { get; }
Visual Basic
Public ReadOnly Property LinesPerLength As Double
    Get
Visual C++
public:
property double LinesPerLength {
    double get ();
}

Field Value

The number of solid lines that placed in unit length.

See Also

FillPattern Class


Name Property

[image]

Revit 2013 API
FillPattern..::..Name Property
FillPattern Class See Also Send Feedback
The name of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FillPattern Class


StrokesPerArea Property

[image]

Revit 2013 API
FillPattern..::..StrokesPerArea Property
FillPattern Class See Also Send Feedback
Gets the number of strokes that placed on unit area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StrokesPerArea { get; }
Visual Basic
Public ReadOnly Property StrokesPerArea As Double
    Get
Visual C++
public:
property double StrokesPerArea {
    double get ();
}

Field Value

The number of strokes that placed on unit area.

See Also

FillPattern Class


Target Property

[image]

Revit 2013 API
FillPattern..::..Target Property
FillPattern Class See Also Send Feedback
Target of this fill pattern applied to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPatternTarget Target { get; set; }
Visual Basic
Public Property Target As FillPatternTarget
    Get
    Set
Visual C++
public:
property FillPatternTarget Target {
    FillPatternTarget get ();
    void set (FillPatternTarget value);
}

See Also

FillPattern Class


FillPatternElement Class

[image]

Revit 2013 API
FillPatternElement Class
Members See Also Send Feedback
An element that represents a fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FillPatternElement : Element
Visual Basic
Public Class FillPatternElement _
    Inherits Element
Visual C++
public ref class FillPatternElement : public Element

Remarks

The FillPatternElement represents a fill pattern in a project. It enables the user to retrieve, modify or create a fill pattern in a project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FillPatternElement

See Also

FillPatternElement Members


FillPatternElement Members

[image] [image]

Revit 2013 API
FillPatternElement Members
FillPatternElement Class Methods Properties See Also Send Feedback

The FillPatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new FillPatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFillPattern | Gets the FillPattern associated to this element.
 | GetFillPatternElementByName | Retrieves the FillPatternElement by its name.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFillPattern | Sets the FillPattern associated to this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FillPatternElement Class


FillPatternElement Methods

[image] [image]

Revit 2013 API
FillPatternElement Methods
FillPatternElement Class See Also Send Feedback

The FillPatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new FillPatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFillPattern | Gets the FillPattern associated to this element.
 | GetFillPatternElementByName | Retrieves the FillPatternElement by its name.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFillPattern | Sets the FillPattern associated to this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillPatternElement Class


Create Method

[image]

Revit 2013 API
FillPatternElement..::..Create Method
FillPatternElement Class Example See Also Send Feedback
Creates a new FillPatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static FillPatternElement Create(
    Document document,
    FillPattern fillPattern
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    fillPattern As FillPattern _
) As FillPatternElement
Visual C++
public:
static FillPatternElement^ Create(
    Document^ document,
    FillPattern^ fillPattern
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the FillPatternElement.
fillPattern
Type: Autodesk.Revit.DB..::..FillPattern
The FillPattern associated to the newly created FillPatternElement.

Return Value

The newly created FillPatternElement.

Examples

CopyC#
// Create a complex fill pattern
public void CreateComplexFillPattern(Document doc)
{
    // Create the fill pattern
    FillPattern fillPattern = new FillPattern("API-created", FillPatternTarget.Model,
                                              FillPatternHostOrientation.ToHost);

    // Add grids
    List<FillGrid> grids = new List<FillGrid>();

    //Horizontal lines.
    // The arguments: origin, offset (vertical distance between lines),
    // angle, shift (delta between location of start point per line)
    // The last two arguments are the segments: e.g. 1.0 units on,
    // 0.1 units off (units are Revit units (ft))
    grids.Add(CreateGrid(new UV(0, 0.1), 0.5, 0, 0.55, 1.0, 0.1));
    grids.Add(CreateGrid(new UV(0, 0.5), 0.5, 0, 0.55, 1.0, 0.1));

    // Vertical lines.
    grids.Add(CreateGrid(new UV(0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));
    grids.Add(CreateGrid(new UV(1.0, 0.1), 0.55, Math.PI / 2, 0.5, 0.4, 0.6));

    fillPattern.SetFillGrids(grids);

    // Create the fill pattern element. Now document is modified; transaction is needed
    Transaction t = new Transaction(doc, "Create fill pattern");
    t.Start();
    FillPatternElement patternElement = FillPatternElement.Create(doc, fillPattern);
    t.Commit();
}

// Creates and returns a new fill grid
private FillGrid CreateGrid(UV origin, double offset, double angle,
                            double shift, params double[] segments)
{
    FillGrid fillGrid = new FillGrid();
    fillGrid.Origin = origin;
    fillGrid.Offset = offset;
    fillGrid.Angle = angle;
    fillGrid.Shift = shift;
    List<double> segmentsList = new List<double>();
    foreach (double d in segments)
    {
        segmentsList.Add(d);
    }
    fillGrid.SetSegments(segmentsList);

    return fillGrid;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPatternElement Class


GetFillPattern Method

[image]

Revit 2013 API
FillPatternElement..::..GetFillPattern Method
FillPatternElement Class See Also Send Feedback
Gets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FillPattern GetFillPattern()
Visual Basic
Public Function GetFillPattern As FillPattern
Visual C++
public:
FillPattern^ GetFillPattern()

Return Value

A copy of FillPattern object.

See Also

FillPatternElement Class


GetFillPatternElementByName Method

[image]

Revit 2013 API
FillPatternElement..::..GetFillPatternElementByName Method
FillPatternElement Class See Also Send Feedback
Retrieves the FillPatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static FillPatternElement GetFillPatternElementByName(
    Document document,
    FillPatternTarget target,
    string name
)
Visual Basic
Public Shared Function GetFillPatternElementByName ( _
    document As Document, _
    target As FillPatternTarget, _
    name As String _
) As FillPatternElement
Visual C++
public:
static FillPatternElement^ GetFillPatternElementByName(
    Document^ document,
    FillPatternTarget target,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the FillPatternElement.
target
Type: Autodesk.Revit.DB..::..FillPatternTarget
The FillPatternTarget of the FillPatternElement.
name
Type: System..::..String
The name of the FillPatternElement.

Return Value

The FillPatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPatternElement Class


SetFillPattern Method

[image]

Revit 2013 API
FillPatternElement..::..SetFillPattern Method
FillPatternElement Class See Also Send Feedback
Sets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFillPattern(
    FillPattern newFillPattern
)
Visual Basic
Public Sub SetFillPattern ( _
    newFillPattern As FillPattern _
)
Visual C++
public:
void SetFillPattern(
    FillPattern^ newFillPattern
)

Parameters

newFillPattern
Type: Autodesk.Revit.DB..::..FillPattern
The new FillPattern object.

Remarks

The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FillPatternElement Class


FillPatternElement Properties

[image] [image]

Revit 2013 API
FillPatternElement Properties
FillPatternElement Class See Also Send Feedback

The FillPatternElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FillPatternElement Class


Parameter Property

[image] [image]

Revit 2013 API
FillPatternElement..::..Parameter Property
FillPatternElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FillPatternElement Class
FillPatternElement Members


FillPatternHostOrientation Enumeration

[image]

Revit 2013 API
FillPatternHostOrientation Enumeration
See Also Send Feedback
The types of orientations for fill patterns.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum FillPatternHostOrientation
Visual Basic
Public Enumeration FillPatternHostOrientation
Visual C++
public enum class FillPatternHostOrientation

Members

Member name | Description
ToView | All patterns share the same orientation and origin with respect to view, so they perfectly align at element transitions.
AsText | Mimics the behavior of text. Patterns align with the host and share the same origin with respect to view.
ToHost | Patterns align with the host and compute a origin to fit the host.

See Also


FillPatternTarget Enumeration

[image]

Revit 2013 API
FillPatternTarget Enumeration
See Also Send Feedback
The type of the fill pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum FillPatternTarget
Visual Basic
Public Enumeration FillPatternTarget
Visual C++
public enum class FillPatternTarget

Members

Member name | Description
Drafting | Represents a material in symbolic form.
Model | Represents an actual element appearance on a building.
None |

See Also


FilterableValueProvider Class

[image]

Revit 2013 API
FilterableValueProvider Class
Members See Also Send Feedback
Defines the interface for classes that extract values from elements in a Revit project for testing against filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterableValueProvider : IDisposable
Visual Basic
Public Class FilterableValueProvider _
    Implements IDisposable
Visual C++
public ref class FilterableValueProvider : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider

See Also

FilterableValueProvider Members


FilterableValueProvider Members

[image] [image]

Revit 2013 API
FilterableValueProvider Members
FilterableValueProvider Class Methods See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterableValueProvider
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterableValueProvider Class


FilterableValueProvider Methods

[image] [image]

Revit 2013 API
FilterableValueProvider Methods
FilterableValueProvider Class See Also Send Feedback

The FilterableValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element.
Public method | GetElementIdValue | Gets an ElementId value from the given element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element.
Public method | GetStringValue | Gets a string value from the given element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element.
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element.
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element.
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterableValueProvider Class


Dispose Method

[image]

Revit 2013 API
FilterableValueProvider..::..Dispose Method
FilterableValueProvider Class See Also Send Feedback
Releases all resources used by the FilterableValueProvider

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterableValueProvider Class


GetDoubleValue Method

[image]

Revit 2013 API
FilterableValueProvider..::..GetDoubleValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a double-precision numeric value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GetDoubleValue(
    Element element
)
Visual Basic
Public Function GetDoubleValue ( _
    element As Element _
) As Double
Visual C++
public:
double GetDoubleValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The double-precision numeric value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetElementIdValue Method

[image]

Revit 2013 API
FilterableValueProvider..::..GetElementIdValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an ElementId value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetElementIdValue(
    Element element
)
Visual Basic
Public Function GetElementIdValue ( _
    element As Element _
) As ElementId
Visual C++
public:
ElementId^ GetElementIdValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The ElementId value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetIntegerValue Method

[image]

Revit 2013 API
FilterableValueProvider..::..GetIntegerValue Method
FilterableValueProvider Class See Also Send Feedback
Gets an integer value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int GetIntegerValue(
    Element element
)
Visual Basic
Public Function GetIntegerValue ( _
    element As Element _
) As Integer
Visual C++
public:
int GetIntegerValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The integer value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


GetStringValue Method

[image]

Revit 2013 API
FilterableValueProvider..::..GetStringValue Method
FilterableValueProvider Class See Also Send Feedback
Gets a string value from the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetStringValue(
    Element element
)
Visual Basic
Public Function GetStringValue ( _
    element As Element _
) As String
Visual C++
public:
String^ GetStringValue(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

The string value from the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsDoubleValueSupported Method

[image]

Revit 2013 API
FilterableValueProvider..::..IsDoubleValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a double-precision numeric value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsDoubleValueSupported(
    Element element
)
Visual Basic
Public Function IsDoubleValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsDoubleValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return a double-precision numeric value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsElementIdValueSupported Method

[image]

Revit 2013 API
FilterableValueProvider..::..IsElementIdValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an ElementId value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsElementIdValueSupported(
    Element element
)
Visual Basic
Public Function IsElementIdValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsElementIdValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return an ElementId value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsIntegerValueSupported Method

[image]

Revit 2013 API
FilterableValueProvider..::..IsIntegerValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide an integer value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsIntegerValueSupported(
    Element element
)
Visual Basic
Public Function IsIntegerValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsIntegerValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return an integer value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


IsStringValueSupported Method

[image]

Revit 2013 API
FilterableValueProvider..::..IsStringValueSupported Method
FilterableValueProvider Class See Also Send Feedback
Determines whether the provide can provide a string value for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsStringValueSupported(
    Element element
)
Visual Basic
Public Function IsStringValueSupported ( _
    element As Element _
) As Boolean
Visual C++
public:
bool IsStringValueSupported(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query.

Return Value

True if the provider can return a string value for the given element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterableValueProvider Class


FilterDoubleRule Class

[image]

Revit 2013 API
FilterDoubleRule Class
Members See Also Send Feedback
A filter rule that operates on double-precision numeric values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterDoubleRule : FilterNumericValueRule
Visual Basic
Public Class FilterDoubleRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterDoubleRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterDoubleRule

See Also

FilterDoubleRule Members


FilterDoubleRule Members

[image] [image]

Revit 2013 API
FilterDoubleRule Members
FilterDoubleRule Class Constructors Methods Properties See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterDoubleRule | Constructs an instance of FilterDoubleRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class


FilterDoubleRule Constructor

[image]

Revit 2013 API
FilterDoubleRule Constructor
FilterDoubleRule Class See Also Send Feedback
Constructs an instance of FilterDoubleRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterDoubleRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    double ruleValue,
    double epsilon
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Double, _
    epsilon As Double _
)
Visual C++
public:
FilterDoubleRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    double ruleValue,
    double epsilon
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::..Double
The user-supplied value against which values from a Revit document will be tested.
epsilon
Type: System..::..Double
The tolerance within which two floating-point values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for ruleValue is not finite -or- The given value for ruleValue is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterDoubleRule Class


FilterDoubleRule Methods

[image] [image]

Revit 2013 API
FilterDoubleRule Methods
FilterDoubleRule Class See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDoubleRule Class


FilterDoubleRule Properties

[image] [image]

Revit 2013 API
FilterDoubleRule Properties
FilterDoubleRule Class See Also Send Feedback

The FilterDoubleRule type exposes the following members.

Properties

 | Name | Description
Public property | Epsilon | The tolerance within which two floating-point values may be considered equal.
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterDoubleRule Class


Epsilon Property

[image]

Revit 2013 API
FilterDoubleRule..::..Epsilon Property
FilterDoubleRule Class See Also Send Feedback
The tolerance within which two floating-point values may be considered equal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Epsilon { get; set; }
Visual Basic
Public Property Epsilon As Double
    Get
    Set
Visual C++
public:
property double Epsilon {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for epsilon is not finite -or- When setting this property: The given value for epsilon is not a number

See Also

FilterDoubleRule Class


RuleValue Property

[image]

Revit 2013 API
FilterDoubleRule..::..RuleValue Property
FilterDoubleRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double RuleValue { get; set; }
Visual Basic
Public Property RuleValue As Double
    Get
    Set
Visual C++
public:
property double RuleValue {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for ruleValue is not finite -or- When setting this property: The given value for ruleValue is not a number

See Also

FilterDoubleRule Class


FilteredElementCollector Class

[image]

Revit 2013 API
FilteredElementCollector Class
Members See Also Send Feedback
This class is used to search, filter and iterate through a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementCollector : IEnumerable<Element>,
    IDisposable
Visual Basic
Public Class FilteredElementCollector _
    Implements IEnumerable(Of Element), IDisposable
Visual C++
public ref class FilteredElementCollector : IEnumerable<Element^>,
    IDisposable

Remarks

Developers can assign a variety of conditions to filter the elements that are returned. This class requires that at least one condition be set before making the attempt to access the elements.

Revit will attempt to organize the filters in order to minimize expansion of elements regardless of the order in which conditions and filters are applied.

There are three groups of methods that you can use on a given collector once you have applied filter(s) to it. One group provides collections of all passing elements, a second finds the first match of the given filter(s), and a third provides an iterator that is evaluated lazily (each element is tested by the filter only when the iterator reaches it). You should only use one of the methods from these group at a time; the collector will reset if you call another method to extract elements. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more elements if you call another method to extract elements.

In .NET, this class supports the IEnumerable interface for Elements. You can use this class with LINQ queries and operations to process lists of elements. Note that because the ElementFilters and the shortcut methods offered by this class process elements in native code before their managed wrappers are generated, better performance will be obtained by using as many native filters as possible on the collector before attempting to process the results using LINQ queries.

One special consideration when using this class in .NET: the debugger will attempt to traverse the members of the collector because of its implementation of IEnumerable. You may see strange results if you also attempt to extract the first element or all elements from the collector while the debugger is also looking at the contents of the collector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredElementCollector

See Also

FilteredElementCollector Members


FilteredElementCollector Members

[image] [image]

Revit 2013 API
FilteredElementCollector Members
FilteredElementCollector Class Constructors Methods See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public method | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollection<(Of <<'(ElementId>)>>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Methods

 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose | Releases all resources used by the FilteredElementCollector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Excluding | Applies an ExclusionFilter to the collector.
Public method | FirstElement | Returns the first element to pass the filter(s).
Public method | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
Public method | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
Public method | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
Public method | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class


FilteredElementCollector Constructor

[image] [image]

Revit 2013 API
FilteredElementCollector Constructor
FilteredElementCollector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FilteredElementCollector(Document) | Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.
Public method | FilteredElementCollector(Document, ElementId) | Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.
Public method | FilteredElementCollector(Document, ICollection<(Of <<'(ElementId>)>>)) | Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

See Also

FilteredElementCollector Class
FilteredElementCollector Members


FilteredElementCollector Constructor (Document)

[image]

Revit 2013 API
FilteredElementCollector Constructor (Document)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the set of elements in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ElementId)

[image]

Revit 2013 API
FilteredElementCollector Constructor (Document, ElementId)
FilteredElementCollector Class Example See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter the visible elements in a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    viewId As ElementId _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Remarks

Elements that will be passed by the collector have graphics that may be visible in the input view. Some elements may still be hidden because they are obscured by other elements. Accessing these visible elements may require Revit to rebuild the geometry of the view. The first time your code constructs a collector for a given view, or the first time your code constructs a collector for a view whose display settings have just been changed, you may experience a significant performance degradation.

Examples

CopyC#
private void CountElements(Autodesk.Revit.DB.Document document)
{
    StringBuilder message = new StringBuilder();
    FilteredElementCollector viewCollector =
        new FilteredElementCollector(document, document.ActiveView.Id);
    viewCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within active View: "
       + viewCollector.ToElementIds().Count);

    FilteredElementCollector docCollector = new FilteredElementCollector(document);
    docCollector.OfCategory(BuiltInCategory.OST_Walls);
    message.AppendLine("Wall category elements within document: "
       + docCollector.ToElementIds().Count);

    TaskDialog.Show("Revit", message.ToString());
}
CopyVB.NET
Private Sub CountElements(ByVal document As Autodesk.Revit.DB.Document)
    Dim message As New StringBuilder()
    Dim viewCollector As New Autodesk.Revit.DB.FilteredElementCollector(document, document.ActiveView.Id)
    viewCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within active View: " + viewCollector.ToElementIds().Count)

    Dim docCollector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    docCollector.OfCategory(BuiltInCategory.OST_Walls)
    message.AppendLine("Wall category elements within document: " + docCollector.ToElementIds().Count)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Constructor (Document, ICollection(ElementId))

[image]

Revit 2013 API
FilteredElementCollector Constructor (Document, ICollection<(Of <(<'ElementId>)>)>)
FilteredElementCollector Class See Also Send Feedback
Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub New ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
FilteredElementCollector(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the elements matching the element ids.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The input set of element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class
FilteredElementCollector Overload


FilteredElementCollector Methods

[image] [image]

Revit 2013 API
FilteredElementCollector Methods
FilteredElementCollector Class See Also Send Feedback

The FilteredElementCollector type exposes the following members.

Methods

 | Name | Description
Public method | ContainedInDesignOption | Applies an ElementDesignOptionFilter to the collector.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Excluding | Applies an ExclusionFilter to the collector.
Public method | FirstElement | Returns the first element to pass the filter(s).
Public method | FirstElementId | Returns the id of the first element to pass the filter(s).
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetElementIdIterator | Returns an element id iterator to the elements passing the filters.
Public method | GetElementIterator | Returns an element iterator to the elements passing the filters.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
 | IsViewValidForElementIteration | Identifies if the particular element is valid for iteration of drawn elements.
Public method | OfCategory | Applies an ElementCategoryFilter to the collector.
Public method | OfCategoryId | Applies an ElementCategoryFilter to the collector.
Public method | OfClass | Applies an ElementClassFilter to the collector.
Public method | OwnedByView | Applies an ElementOwnerViewFilter to the collector.
Public method | ToElementIds | Returns the complete set of element ids that pass the filter(s).
Public method | ToElements | Returns the complete set of elements that pass the filter(s).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnionWith | Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.
Public method | WhereElementIsCurveDriven | Applies an ElementIsCurveDrivenFilter to the collector.
Public method | WhereElementIsElementType | Applies an ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsNotElementType | Applies an inverted ElementIsElementTypeFilter to the collector.
Public method | WhereElementIsViewIndependent | Applies an ElementOwnerViewFilter to the collector.
Public method | WherePasses | Applies an element filter to the collector.

See Also

FilteredElementCollector Class


ContainedInDesignOption Method

[image]

Revit 2013 API
FilteredElementCollector..::..ContainedInDesignOption Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementDesignOptionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector ContainedInDesignOption(
    ElementId designOptionId
)
Visual Basic
Public Function ContainedInDesignOption ( _
    designOptionId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ ContainedInDesignOption(
    ElementId^ designOptionId
)

Parameters

designOptionId
Type: Autodesk.Revit.DB..::..ElementId
The design option id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are contained by this particular design option will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


Dispose Method

[image]

Revit 2013 API
FilteredElementCollector..::..Dispose Method
FilteredElementCollector Class See Also Send Feedback
Releases all resources used by the FilteredElementCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilteredElementCollector Class


Excluding Method

[image]

Revit 2013 API
FilteredElementCollector..::..Excluding Method
FilteredElementCollector Class See Also Send Feedback
Applies an ExclusionFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector Excluding(
    ICollection<ElementId> idsToExclude
)
Visual Basic
Public Function Excluding ( _
    idsToExclude As ICollection(Of ElementId) _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ Excluding(
    ICollection<ElementId^>^ idsToExclude
)

Parameters

idsToExclude
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The ids to exclude from the results.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Elements passed to this filter will be automatically excluded from the results. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


FirstElement Method

[image]

Revit 2013 API
FilteredElementCollector..::..FirstElement Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Element FirstElement()
Visual Basic
Public Function FirstElement As Element
Visual C++
public:
Element^ FirstElement()

Return Value

The first element.

Remarks

This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
    // Create a filter to find all columns
    StructuralInstanceUsageFilter columnFilter =
        new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);

    // Apply the filter to the elements in the active document
    FilteredElementCollector collector = new FilteredElementCollector(document);
    collector.WherePasses(columnFilter);

    // Get the first column from the filtered results
    // Element will be a FamilyInstance
    FamilyInstance column = collector.FirstElement() as FamilyInstance;

    return column;
}
CopyVB.NET
Public Function GetAColumn(ByVal document As Autodesk.Revit.DB.Document) As Autodesk.Revit.DB.FamilyInstance
    ' Create a filter to find all columns
    Dim columnFilter As New Autodesk.Revit.DB.Structure.StructuralInstanceUsageFilter(Autodesk.Revit.DB.Structure.StructuralInstanceUsage.Column)

    ' Apply the filter to the elements in the active document
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    collector.WherePasses(columnFilter)

    ' Get the first column from the filtered results
    ' Element will be a FamilyInstance
    Dim column As Autodesk.Revit.DB.FamilyInstance = TryCast(collector.FirstElement(), Autodesk.Revit.DB.FamilyInstance)

    Return column
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


FirstElementId Method

[image]

Revit 2013 API
FilteredElementCollector..::..FirstElementId Method
FilteredElementCollector Class Example See Also Send Feedback
Returns the id of the first element to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId FirstElementId()
Visual Basic
Public Function FirstElementId As ElementId
Visual C++
public:
ElementId^ FirstElementId()

Return Value

The first element id.

Remarks

This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Use shortcut OfClass to get View elements
collector.OfClass(typeof(View3D));

// Get the Id of the first view
ElementId viewId = collector.FirstElementId();

// Test if the view is valid for element filtering
if (FilteredElementCollector.IsViewValidForElementIteration(document, viewId))
{
    FilteredElementCollector viewCollector = new FilteredElementCollector(document, viewId);

    // Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(typeof(FamilyInstance));
    ICollection<ElementId> familyInstanceIds = viewCollector.ToElementIds();

    document.Delete(familyInstanceIds);
}
CopyVB.NET
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)

' Use shortcut OfClass to get View elements
collector.OfClass(GetType(View3D))

' Get the Id of the first view
Dim viewId As ElementId = collector.FirstElementId()

' Test if the view is valid for element filtering
If Autodesk.Revit.DB.FilteredElementCollector.IsViewValidForElementIteration(document, viewId) Then
    Dim viewCollector As New Autodesk.Revit.DB.FilteredElementCollector(document, viewId)

    ' Get all FamilyInstance items in the view and delete them
    viewCollector.OfClass(GetType(FamilyInstance))
    Dim familyInstanceIds As ICollection(Of ElementId) = viewCollector.ToElementIds()

    document.Delete(familyInstanceIds)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetBasicIEnumerator Method

[image]

Revit 2013 API
FilteredElementCollector..::..GetBasicIEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FilteredElementCollector Class


GetElementIdIterator Method

[image]

Revit 2013 API
FilteredElementCollector..::..GetElementIdIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element id iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementIdIterator GetElementIdIterator()
Visual Basic
Public Function GetElementIdIterator As FilteredElementIdIterator
Visual C++
public:
FilteredElementIdIterator^ GetElementIdIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
// Use a RoomFilter to find all room elements in the document.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(filter);

// Get results as ElementId iterator
FilteredElementIdIterator roomIdItr = collector.GetElementIdIterator();
roomIdItr.Reset();
while (roomIdItr.MoveNext())
{
    ElementId roomId = roomIdItr.Current;
    // Warn rooms smaller than 50 SF
    Room room = document.GetElement(roomId) as Room;
    if (room.Area < 50.0)
    {
        String prompt = "Room is too small: id = " + roomId.ToString();
        TaskDialog.Show("Revit", prompt);
        break;
    }
}
CopyVB.NET
' Use a RoomFilter to find all room elements in the document.
Dim filter As New Autodesk.Revit.DB.Architecture.RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
collector.WherePasses(filter)

' Get results as ElementId iterator
Dim roomIdItr As FilteredElementIdIterator = collector.GetElementIdIterator()
roomIdItr.Reset()
While roomIdItr.MoveNext()
    Dim roomId As ElementId = roomIdItr.Current
    ' Warn rooms smaller than 50 SF
    Dim room As Room = TryCast(document.GetElement(roomId), Room)
    If room.Area < 50 Then
        Dim prompt As [String] = "Room is too small: id = " + roomId.ToString()
        TaskDialog.Show("Revit", prompt)
        Exit While
    End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetElementIterator Method

[image]

Revit 2013 API
FilteredElementCollector..::..GetElementIterator Method
FilteredElementCollector Class Example See Also Send Feedback
Returns an element iterator to the elements passing the filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementIterator GetElementIterator()
Visual Basic
Public Function GetElementIterator As FilteredElementIterator
Visual C++
public:
FilteredElementIterator^ GetElementIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

Examples

CopyC#
FilteredElementCollector collector = new FilteredElementCollector(document);

// Apply a filter to get all pipes in the document
collector.OfClass(typeof(Autodesk.Revit.DB.Plumbing.Pipe));

// Get results as an element iterator and look for a pipe with
// a specific flow state
FilteredElementIterator elemItr = collector.GetElementIterator();
elemItr.Reset();
while (elemItr.MoveNext())
{
    Pipe pipe = elemItr.Current as Pipe;
    if (pipe.FlowState == PipeFlowState.LaminarState)
    {
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.");
        break;
    }
}
CopyVB.NET
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)

' Apply a filter to get all pipes in the document
collector.OfClass(GetType(Autodesk.Revit.DB.Plumbing.Pipe))

' Get results as an element iterator and look for a pipe with
' a specific flow state
Dim elemItr As FilteredElementIterator = collector.GetElementIterator()
elemItr.Reset()
While elemItr.MoveNext()
    Dim pipe As Pipe = TryCast(elemItr.Current, Pipe)
    If pipe.FlowState = PipeFlowState.LaminarState Then
        TaskDialog.Show("Revit", "Model has at least one pipe with Laminar flow state.")
        Exit While
    End If
End While

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


GetEnumerator Method

[image]

Revit 2013 API
FilteredElementCollector..::..GetEnumerator Method
FilteredElementCollector Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<Element> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Element)
Visual C++
public:
virtual IEnumerator<Element^>^ GetEnumerator()

Return Value

An IEnumerator(Autodesk.Revit.DB.Element) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FilteredElementCollector Class


IntersectWith Method

[image]

Revit 2013 API
FilteredElementCollector..::..IntersectWith Method
FilteredElementCollector Class See Also Send Feedback
Intersects the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector IntersectWith(
    FilteredElementCollector other
)
Visual Basic
Public Function IntersectWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ IntersectWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalAndFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


IsViewValidForElementIteration Method

[image]

Revit 2013 API
FilteredElementCollector..::..IsViewValidForElementIteration Method
FilteredElementCollector Class See Also Send Feedback
Identifies if the particular element is valid for iteration of drawn elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsViewValidForElementIteration(
    Document document,
    ElementId viewId
)
Visual Basic
Public Shared Function IsViewValidForElementIteration ( _
    document As Document, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewValidForElementIteration(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.

Return Value

True if the element is valid for iteration.

Remarks

Views that have no way of representing drawn elements, such as many view templates, fail this check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OfCategory Method

[image]

Revit 2013 API
FilteredElementCollector..::..OfCategory Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FilteredElementCollector OfCategory(
    BuiltInCategory category
)
Visual Basic
Public Function OfCategory ( _
    category As BuiltInCategory _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategory(
    BuiltInCategory category
)

Parameters

category
Type: Autodesk.Revit.DB..::..BuiltInCategory
The category.

Return Value

This collector.

Remarks

Only elements of this category id will pass the collector.

Examples

CopyC#
// Use OfCategory method to apply an ElementCategoryFilter and fine elements in the Doors category
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> doors = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements();
CopyVB.NET
' Use OfCategory method to apply an ElementCategoryFilter and find Levels in the document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim doors As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfCategory(BuiltInCategory.OST_Doors).ToElements()

See Also

FilteredElementCollector Class


OfCategoryId Method

[image]

Revit 2013 API
FilteredElementCollector..::..OfCategoryId Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementCategoryFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OfCategoryId(
    ElementId categoryId
)
Visual Basic
Public Function OfCategoryId ( _
    categoryId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfCategoryId(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements of this category id will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OfClass Method

[image]

Revit 2013 API
FilteredElementCollector..::..OfClass Method
FilteredElementCollector Class Example See Also Send Feedback
Applies an ElementClassFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OfClass(
    Type type
)
Visual Basic
Public Function OfClass ( _
    type As Type _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OfClass(
    Type^ type
)

Parameters

type
Type: System..::..Type
The element type.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements whose class is an exact match to the input class, or elements whose type is derived from the input class will pass the collector.

There is a small subset of Element subclasses in the API that are not supported by this filter. These classes exist in the API, but not in Revit's native object model, which means that this filter doesn't support them. In order to use a class filter to find elements of these types, it is necessary to use a higher level class and then process the results further to find elements matching only the subclass. For a list of subclasses affected by this restriction, consult the documentation for ElementClassFilter.

If you have an active iterator to this collector it will be stopped by this call.

Examples

CopyC#
// Use OfClass method to apply an ElementClassFilter and find Levels in the document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> levels = collector.OfClass(typeof(Level)).ToElements();
CopyVB.NET
' Use OfClass method to apply an ElementClassFilter and find Levels in the document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim levels As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Level)).ToElements()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input type is not a subclass of Element. -or- The input type is of an element type that exists in the API, but not in Revit's native object model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


OwnedByView Method

[image]

Revit 2013 API
FilteredElementCollector..::..OwnedByView Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector OwnedByView(
    ElementId viewId
)
Visual Basic
Public Function OwnedByView ( _
    viewId As ElementId _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ OwnedByView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id of the owner view.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are owned by this particular view will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


ToElementIds Method

[image]

Revit 2013 API
FilteredElementCollector..::..ToElementIds Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of element ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> ToElementIds()
Visual Basic
Public Function ToElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ ToElementIds()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


ToElements Method

[image]

Revit 2013 API
FilteredElementCollector..::..ToElements Method
FilteredElementCollector Class See Also Send Feedback
Returns the complete set of elements that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<Element> ToElements()
Visual Basic
Public Function ToElements As IList(Of Element)
Visual C++
public:
IList<Element^>^ ToElements()

Return Value

The complete set of element ids.

Remarks

This will reset the collector to the beginning and extract all elements that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


UnionWith Method

[image]

Revit 2013 API
FilteredElementCollector..::..UnionWith Method
FilteredElementCollector Class See Also Send Feedback
Unites the set of elements passing the filter in this collector with the set of elements passing the filter in another collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector UnionWith(
    FilteredElementCollector other
)
Visual Basic
Public Function UnionWith ( _
    other As FilteredElementCollector _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ UnionWith(
    FilteredElementCollector^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..FilteredElementCollector
The other collector

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The result will be the same as using a LogicalOrFilter to connect this filter with another. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter.

See Also

FilteredElementCollector Class


WhereElementIsCurveDriven Method

[image]

Revit 2013 API
FilteredElementCollector..::..WhereElementIsCurveDriven Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsCurveDrivenFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsCurveDriven()
Visual Basic
Public Function WhereElementIsCurveDriven As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsCurveDriven()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are curve driven will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsElementType Method

[image]

Revit 2013 API
FilteredElementCollector..::..WhereElementIsElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsElementType()
Visual Basic
Public Function WhereElementIsElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are ElementTypes will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsNotElementType Method

[image]

Revit 2013 API
FilteredElementCollector..::..WhereElementIsNotElementType Method
FilteredElementCollector Class See Also Send Feedback
Applies an inverted ElementIsElementTypeFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsNotElementType()
Visual Basic
Public Function WhereElementIsNotElementType As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsNotElementType()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are not element types will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WhereElementIsViewIndependent Method

[image]

Revit 2013 API
FilteredElementCollector..::..WhereElementIsViewIndependent Method
FilteredElementCollector Class See Also Send Feedback
Applies an ElementOwnerViewFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WhereElementIsViewIndependent()
Visual Basic
Public Function WhereElementIsViewIndependent As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WhereElementIsViewIndependent()

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only elements that are view independent will pass the collector. If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredElementCollector Class


WherePasses Method

[image]

Revit 2013 API
FilteredElementCollector..::..WherePasses Method
FilteredElementCollector Class See Also Send Feedback
Applies an element filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilteredElementCollector WherePasses(
    ElementFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As ElementFilter _
) As FilteredElementCollector
Visual C++
public:
FilteredElementCollector^ WherePasses(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The element filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered elements must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredElementCollector Class


FilteredElementIdIterator Class

[image]

Revit 2013 API
FilteredElementIdIterator Class
Members See Also Send Feedback
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementIdIterator : IEnumerator<ElementId>
Visual Basic
Public Class FilteredElementIdIterator _
    Implements IEnumerator(Of ElementId)
Visual C++
public ref class FilteredElementIdIterator : IEnumerator<ElementId^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredElementIdIterator

See Also

FilteredElementIdIterator Members


FilteredElementIdIterator Members

[image] [image]

Revit 2013 API
FilteredElementIdIterator Members
FilteredElementIdIterator Class Methods Properties See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIdIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredElementIdIterator Class


FilteredElementIdIterator Methods

[image] [image]

Revit 2013 API
FilteredElementIdIterator Methods
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredElementIdIterator Class


Dispose Method

[image]

Revit 2013 API
FilteredElementIdIterator..::..Dispose Method
FilteredElementIdIterator Class See Also Send Feedback
Releases all resources used by the FilteredElementIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIdIterator Class


GetCurrent Method

[image]

Revit 2013 API
FilteredElementIdIterator..::..GetCurrent Method
FilteredElementIdIterator Class See Also Send Feedback
The current element id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetCurrent()
Visual Basic
Public Function GetCurrent As ElementId
Visual C++
public:
ElementId^ GetCurrent()

Return Value

The element id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


IsDone Method

[image]

Revit 2013 API
FilteredElementIdIterator..::..IsDone Method
FilteredElementIdIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


MoveNext Method

[image]

Revit 2013 API
FilteredElementIdIterator..::..MoveNext Method
FilteredElementIdIterator Class See Also Send Feedback
Increments the iterator to the next element id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element id passing the filter in this iterator. False if the iterator has completed all available element ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


Reset Method

[image]

Revit 2013 API
FilteredElementIdIterator..::..Reset Method
FilteredElementIdIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIdIterator Class


FilteredElementIdIterator Properties

[image] [image]

Revit 2013 API
FilteredElementIdIterator Properties
FilteredElementIdIterator Class See Also Send Feedback

The FilteredElementIdIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredElementIdIterator Class


Current Property

[image]

Revit 2013 API
FilteredElementIdIterator..::..Current Property
FilteredElementIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElementId Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As ElementId
    Get
Visual C++
public:
virtual property ElementId^ Current {
    ElementId^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

FilteredElementIdIterator Class


CurrentObject Property

[image]

Revit 2013 API
FilteredElementIdIterator..::..CurrentObject Property
FilteredElementIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredElementIdIterator Class


FilteredElementIterator Class

[image]

Revit 2013 API
FilteredElementIterator Class
Members See Also Send Feedback
An iterator to a set of element ids filtered by the settings of a FilteredElementCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilteredElementIterator : IEnumerator<Element>
Visual Basic
Public Class FilteredElementIterator _
    Implements IEnumerator(Of Element)
Visual C++
public ref class FilteredElementIterator : IEnumerator<Element^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredElementIterator

See Also

FilteredElementIterator Members


FilteredElementIterator Members

[image] [image]

Revit 2013 API
FilteredElementIterator Members
FilteredElementIterator Class Methods Properties See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredElementIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredElementIterator Class


FilteredElementIterator Methods

[image] [image]

Revit 2013 API
FilteredElementIterator Methods
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current element found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next element passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredElementIterator Class


Dispose Method

[image]

Revit 2013 API
FilteredElementIterator..::..Dispose Method
FilteredElementIterator Class See Also Send Feedback
Releases all resources used by the FilteredElementIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredElementIterator Class


GetCurrent Method

[image]

Revit 2013 API
FilteredElementIterator..::..GetCurrent Method
FilteredElementIterator Class See Also Send Feedback
The current element found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Element GetCurrent()
Visual Basic
Public Function GetCurrent As Element
Visual C++
public:
Element^ GetCurrent()

Return Value

The element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more element ids in the iterator. -or- The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


IsDone Method

[image]

Revit 2013 API
FilteredElementIterator..::..IsDone Method
FilteredElementIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


MoveNext Method

[image]

Revit 2013 API
FilteredElementIterator..::..MoveNext Method
FilteredElementIterator Class See Also Send Feedback
Increments the iterator to the next element passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available element passing the filter in this iterator. False if the iterator has completed all available elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


Reset Method

[image]

Revit 2013 API
FilteredElementIterator..::..Reset Method
FilteredElementIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredElementIterator Class


FilteredElementIterator Properties

[image] [image]

Revit 2013 API
FilteredElementIterator Properties
FilteredElementIterator Class See Also Send Feedback

The FilteredElementIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredElementIterator Class


Current Property

[image]

Revit 2013 API
FilteredElementIterator..::..Current Property
FilteredElementIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Element Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Element
    Get
Visual C++
public:
virtual property Element^ Current {
    Element^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

FilteredElementIterator Class


CurrentObject Property

[image]

Revit 2013 API
FilteredElementIterator..::..CurrentObject Property
FilteredElementIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredElementIterator Class


FilteredWorksetCollector Class

[image]

Revit 2013 API
FilteredWorksetCollector Class
Members See Also Send Feedback
This class is used to search, filter and iterate through a set of worksets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FilteredWorksetCollector : IEnumerable<Workset>,
    IDisposable
Visual Basic
Public Class FilteredWorksetCollector _
    Implements IEnumerable(Of Workset), IDisposable
Visual C++
public ref class FilteredWorksetCollector : IEnumerable<Workset^>,
    IDisposable

Remarks

Developers can assign a condition to filter the worksets that are returned. If no condition is applied, it attempts to access all the worksets in the document.

The collector will reset if you call another method to extract worksets. Thus, if you have previously obtained an iterator, it will be stopped and traverse no more worksets if you call another method to extract worksets.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetCollector

See Also

FilteredWorksetCollector Members


FilteredWorksetCollector Members

[image] [image]

Revit 2013 API
FilteredWorksetCollector Members
FilteredWorksetCollector Class Constructors Methods See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Constructors

 | Name | Description
Public method | FilteredWorksetCollector | Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetCollector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

See Also

FilteredWorksetCollector Class


FilteredWorksetCollector Constructor

[image]

Revit 2013 API
FilteredWorksetCollector Constructor
FilteredWorksetCollector Class See Also Send Feedback
Constructs a new FilteredWorksetCollector that will search and filter the set of worksets in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetCollector(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
FilteredWorksetCollector(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredWorksetCollector Class


FilteredWorksetCollector Methods

[image] [image]

Revit 2013 API
FilteredWorksetCollector Methods
FilteredWorksetCollector Class See Also Send Feedback

The FilteredWorksetCollector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FirstWorkset | Returns the first workset to pass the filter(s).
Public method | FirstWorksetId | Returns the id of the first workset to pass the filter(s).
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorksetIdIterator | Returns a FilteredWorksetIdIterator to the worksets passing the current filter.
Public method | GetWorksetIterator | Returns a FilteredWorksetIterator to the worksets passing the current filter.
Public method | OfKind | Applies a WorksetKindFilter to the collector.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ToWorksetIds | Returns the complete set of workset ids that pass the filter(s).
Public method | ToWorksets | Returns the complete set of worksets that pass the filter(s).
Public method | WherePasses | Applies a workset filter to the collector.

See Also

FilteredWorksetCollector Class


Dispose Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..Dispose Method
FilteredWorksetCollector Class See Also Send Feedback
Releases all resources used by the FilteredWorksetCollector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilteredWorksetCollector Class


FirstWorkset Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..FirstWorkset Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the first workset to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Workset FirstWorkset()
Visual Basic
Public Function FirstWorkset As Workset
Visual C++
public:
Workset^ FirstWorkset()

Return Value

The first workset.

Remarks

This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


FirstWorksetId Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..FirstWorksetId Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the id of the first workset to pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId FirstWorksetId()
Visual Basic
Public Function FirstWorksetId As WorksetId
Visual C++
public:
WorksetId^ FirstWorksetId()

Return Value

The first workset id.

Remarks

This will reset the collector to the beginning and find the first workset that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


GetEnumerator Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..GetEnumerator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<Workset> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of Workset)
Visual C++
public:
virtual IEnumerator<Workset^>^ GetEnumerator()

Return Value

An IEnumerator(Autodesk.Revit.DB.Workset) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FilteredWorksetCollector Class


GetWorksetIdIterator Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..GetWorksetIdIterator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns a FilteredWorksetIdIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetIdIterator GetWorksetIdIterator()
Visual Basic
Public Function GetWorksetIdIterator As FilteredWorksetIdIterator
Visual C++
public:
FilteredWorksetIdIterator^ GetWorksetIdIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

See Also

FilteredWorksetCollector Class


GetWorksetIterator Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..GetWorksetIterator Method
FilteredWorksetCollector Class See Also Send Feedback
Returns a FilteredWorksetIterator to the worksets passing the current filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetIterator GetWorksetIterator()
Visual Basic
Public Function GetWorksetIterator As FilteredWorksetIterator
Visual C++
public:
FilteredWorksetIterator^ GetWorksetIterator()

Remarks

Calling this when you have an active iterator to this same collector will result in the first iterator being stopped by this call.

See Also

FilteredWorksetCollector Class


OfKind Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..OfKind Method
FilteredWorksetCollector Class See Also Send Feedback
Applies a WorksetKindFilter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetCollector OfKind(
    WorksetKind worksetKind
)
Visual Basic
Public Function OfKind ( _
    worksetKind As WorksetKind _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ OfKind(
    WorksetKind worksetKind
)

Parameters

worksetKind
Type: Autodesk.Revit.DB..::..WorksetKind
The WorksetKind of the workset.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

Only worksets whose WorksetKind is an exact match to the input WorksetKind will pass the collector.

If you have an active iterator to this collector it will be stopped by this call.

See Also

FilteredWorksetCollector Class


ToWorksetIds Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..ToWorksetIds Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the complete set of workset ids that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<WorksetId> ToWorksetIds()
Visual Basic
Public Function ToWorksetIds As ICollection(Of WorksetId)
Visual C++
public:
ICollection<WorksetId^>^ ToWorksetIds()

Return Value

The complete set of workset ids.

Remarks

This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


ToWorksets Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..ToWorksets Method
FilteredWorksetCollector Class See Also Send Feedback
Returns the complete set of worksets that pass the filter(s).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Workset> ToWorksets()
Visual Basic
Public Function ToWorksets As IList(Of Workset)
Visual C++
public:
IList<Workset^>^ ToWorksets()

Return Value

The complete array of worksets.

Remarks

This will reset the collector to the beginning and extract all worksets that pass the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.

See Also

FilteredWorksetCollector Class


WherePasses Method

[image]

Revit 2013 API
FilteredWorksetCollector..::..WherePasses Method
FilteredWorksetCollector Class See Also Send Feedback
Applies a workset filter to the collector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FilteredWorksetCollector WherePasses(
    WorksetFilter filter
)
Visual Basic
Public Function WherePasses ( _
    filter As WorksetFilter _
) As FilteredWorksetCollector
Visual C++
public:
FilteredWorksetCollector^ WherePasses(
    WorksetFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..WorksetFilter
The workset filter.

Return Value

A handle to this collector. This is the same collector that has just been modified, returned so you can chain multiple calls together in one line.

Remarks

The filter will be added as an additional condition that all filtered worksets must pass. If you have an active iterator to this collector it will be stopped by this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilteredWorksetCollector Class


FilteredWorksetIdIterator Class

[image]

Revit 2013 API
FilteredWorksetIdIterator Class
Members See Also Send Feedback
An iterator to a set of workset ids filtered by the settings of a FilteredWorksetCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FilteredWorksetIdIterator : IEnumerator<WorksetId>
Visual Basic
Public Class FilteredWorksetIdIterator _
    Implements IEnumerator(Of WorksetId)
Visual C++
public ref class FilteredWorksetIdIterator : IEnumerator<WorksetId^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetIdIterator

See Also

FilteredWorksetIdIterator Members


FilteredWorksetIdIterator Members

[image] [image]

Revit 2013 API
FilteredWorksetIdIterator Members
FilteredWorksetIdIterator Class Methods Properties See Also Send Feedback

The FilteredWorksetIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIdIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator Methods

[image] [image]

Revit 2013 API
FilteredWorksetIdIterator Methods
FilteredWorksetIdIterator Class See Also Send Feedback

The FilteredWorksetIdIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset id found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset id passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredWorksetIdIterator Class


Dispose Method

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..Dispose Method
FilteredWorksetIdIterator Class See Also Send Feedback
Releases all resources used by the FilteredWorksetIdIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredWorksetIdIterator Class


GetCurrent Method

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..GetCurrent Method
FilteredWorksetIdIterator Class See Also Send Feedback
The current workset id found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId GetCurrent()
Visual Basic
Public Function GetCurrent As WorksetId
Visual C++
public:
WorksetId^ GetCurrent()

Return Value

The workset id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more workset ids in the iterator. -or- The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


IsDone Method

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..IsDone Method
FilteredWorksetIdIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching worksets. False if there are more workset ids to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


MoveNext Method

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..MoveNext Method
FilteredWorksetIdIterator Class See Also Send Feedback
Increments the iterator to the next workset id passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available workset id passing the filter in this iterator. False if the iterator has completed all available workset ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


Reset Method

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..Reset Method
FilteredWorksetIdIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIdIterator Class


FilteredWorksetIdIterator Properties

[image] [image]

Revit 2013 API
FilteredWorksetIdIterator Properties
FilteredWorksetIdIterator Class See Also Send Feedback

The FilteredWorksetIdIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredWorksetIdIterator Class


Current Property

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..Current Property
FilteredWorksetIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WorksetId Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As WorksetId
    Get
Visual C++
public:
virtual property WorksetId^ Current {
    WorksetId^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

FilteredWorksetIdIterator Class


CurrentObject Property

[image]

Revit 2013 API
FilteredWorksetIdIterator..::..CurrentObject Property
FilteredWorksetIdIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredWorksetIdIterator Class


FilteredWorksetIterator Class

[image]

Revit 2013 API
FilteredWorksetIterator Class
Members See Also Send Feedback
An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FilteredWorksetIterator : IEnumerator<Workset>
Visual Basic
Public Class FilteredWorksetIterator _
    Implements IEnumerator(Of Workset)
Visual C++
public ref class FilteredWorksetIterator : IEnumerator<Workset^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilteredWorksetIterator

See Also

FilteredWorksetIterator Members


FilteredWorksetIterator Members

[image] [image]

Revit 2013 API
FilteredWorksetIterator Members
FilteredWorksetIterator Class Methods Properties See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilteredWorksetIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredWorksetIterator Class


FilteredWorksetIterator Methods

[image] [image]

Revit 2013 API
FilteredWorksetIterator Methods
FilteredWorksetIterator Class See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | The current workset found by the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next workset passing the filter.
Public method | Reset | Resets the iterator to the beginning.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilteredWorksetIterator Class


Dispose Method

[image]

Revit 2013 API
FilteredWorksetIterator..::..Dispose Method
FilteredWorksetIterator Class See Also Send Feedback
Releases all resources used by the FilteredWorksetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FilteredWorksetIterator Class


GetCurrent Method

[image]

Revit 2013 API
FilteredWorksetIterator..::..GetCurrent Method
FilteredWorksetIterator Class See Also Send Feedback
The current workset found by the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Workset GetCurrent()
Visual Basic
Public Function GetCurrent As Workset
Visual C++
public:
Workset^ GetCurrent()

Return Value

The workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There are no more worksets in the iterator. -or- The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


IsDone Method

[image]

Revit 2013 API
FilteredWorksetIterator..::..IsDone Method
FilteredWorksetIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching worksets. False if there are more worksets to be iterated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


MoveNext Method

[image]

Revit 2013 API
FilteredWorksetIterator..::..MoveNext Method
FilteredWorksetIterator Class See Also Send Feedback
Increments the iterator to the next workset passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available workset passing the filter in this iterator. False if the iterator has completed all available worksets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


Reset Method

[image]

Revit 2013 API
FilteredWorksetIterator..::..Reset Method
FilteredWorksetIterator Class See Also Send Feedback
Resets the iterator to the beginning.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also

FilteredWorksetIterator Class


FilteredWorksetIterator Properties

[image] [image]

Revit 2013 API
FilteredWorksetIterator Properties
FilteredWorksetIterator Class See Also Send Feedback

The FilteredWorksetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

FilteredWorksetIterator Class


Current Property

[image]

Revit 2013 API
FilteredWorksetIterator..::..Current Property
FilteredWorksetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Workset Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Workset
    Get
Visual C++
public:
virtual property Workset^ Current {
    Workset^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

FilteredWorksetIterator Class


CurrentObject Property

[image]

Revit 2013 API
FilteredWorksetIterator..::..CurrentObject Property
FilteredWorksetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FilteredWorksetIterator Class


FilterElement Class

[image]

Revit 2013 API
FilterElement Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterElement : Element
Visual Basic
Public Class FilterElement _
    Inherits Element
Visual C++
public ref class FilterElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..ParameterFilterElement
Autodesk.Revit.DB..::..SelectionFilterElement

See Also

FilterElement Members


FilterElement Members

[image] [image]

Revit 2013 API
FilterElement Members
FilterElement Class Methods Properties See Also Send Feedback

The FilterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilterElement Class


FilterElement Methods

[image] [image]

Revit 2013 API
FilterElement Methods
FilterElement Class See Also Send Feedback

The FilterElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterElement Class


IsNameUnique Method

[image]

Revit 2013 API
FilterElement..::..IsNameUnique Method
FilterElement Class See Also Send Feedback
Determines whether a potential filter element name is unique.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsNameUnique(
    string name
)
Visual Basic
Public Function IsNameUnique ( _
    name As String _
) As Boolean
Visual C++
public:
bool IsNameUnique(
    String^ name
)

Parameters

name
Type: System..::..String
The candidate name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterElement Class


FilterElement Properties

[image] [image]

Revit 2013 API
FilterElement Properties
FilterElement Class See Also Send Feedback

The FilterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FilterElement Class


Parameter Property

[image] [image]

Revit 2013 API
FilterElement..::..Parameter Property
FilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FilterElement Class
FilterElement Members


FilterElementIdRule Class

[image]

Revit 2013 API
FilterElementIdRule Class
Members See Also Send Feedback
A filter rule that operates on ElementId values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterElementIdRule : FilterNumericValueRule
Visual Basic
Public Class FilterElementIdRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterElementIdRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterElementIdRule

See Also

FilterElementIdRule Members


FilterElementIdRule Members

[image] [image]

Revit 2013 API
FilterElementIdRule Members
FilterElementIdRule Class Constructors Methods Properties See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterElementIdRule | Constructs an instance of FilterElementIdRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


FilterElementIdRule Constructor

[image]

Revit 2013 API
FilterElementIdRule Constructor
FilterElementIdRule Class See Also Send Feedback
Constructs an instance of FilterElementIdRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterElementIdRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    ElementId ruleValue
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As ElementId _
)
Visual C++
public:
FilterElementIdRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    ElementId^ ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterElementIdRule Class


FilterElementIdRule Methods

[image] [image]

Revit 2013 API
FilterElementIdRule Methods
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterElementIdRule Class


FilterElementIdRule Properties

[image] [image]

Revit 2013 API
FilterElementIdRule Properties
FilterElementIdRule Class See Also Send Feedback

The FilterElementIdRule type exposes the following members.

Properties

 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterElementIdRule Class


RuleValue Property

[image]

Revit 2013 API
FilterElementIdRule..::..RuleValue Property
FilterElementIdRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId RuleValue { get; set; }
Visual Basic
Public Property RuleValue As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RuleValue {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FilterElementIdRule Class


FilterIntegerRule Class

[image]

Revit 2013 API
FilterIntegerRule Class
Members See Also Send Feedback
A filter rule that operates on integer values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterIntegerRule : FilterNumericValueRule
Visual Basic
Public Class FilterIntegerRule _
    Inherits FilterNumericValueRule
Visual C++
public ref class FilterIntegerRule : public FilterNumericValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterIntegerRule

See Also

FilterIntegerRule Members


FilterIntegerRule Members

[image] [image]

Revit 2013 API
FilterIntegerRule Members
FilterIntegerRule Class Constructors Methods Properties See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterIntegerRule | Constructs an instance of FilterIntegerRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


FilterIntegerRule Constructor

[image]

Revit 2013 API
FilterIntegerRule Constructor
FilterIntegerRule Class See Also Send Feedback
Constructs an instance of FilterIntegerRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterIntegerRule(
    FilterableValueProvider valueProvider,
    FilterNumericRuleEvaluator evaluator,
    int ruleValue
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterNumericRuleEvaluator, _
    ruleValue As Integer _
)
Visual C++
public:
FilterIntegerRule(
    FilterableValueProvider^ valueProvider,
    FilterNumericRuleEvaluator^ evaluator,
    int ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: System..::..Int32
The user-supplied value against which values from a Revit document will be tested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterIntegerRule Class


FilterIntegerRule Methods

[image] [image]

Revit 2013 API
FilterIntegerRule Methods
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule. (Inherited from FilterNumericValueRule.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterIntegerRule Class


FilterIntegerRule Properties

[image] [image]

Revit 2013 API
FilterIntegerRule Properties
FilterIntegerRule Class See Also Send Feedback

The FilterIntegerRule type exposes the following members.

Properties

 | Name | Description
Public property | RuleValue | The user-supplied value against which values from a Revit document will be tested.

See Also

FilterIntegerRule Class


RuleValue Property

[image]

Revit 2013 API
FilterIntegerRule..::..RuleValue Property
FilterIntegerRule Class See Also Send Feedback
The user-supplied value against which values from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int RuleValue { get; set; }
Visual Basic
Public Property RuleValue As Integer
    Get
    Set
Visual C++
public:
property int RuleValue {
    int get ();
    void set (int value);
}

See Also

FilterIntegerRule Class


FilterInverseRule Class

[image]

Revit 2013 API
FilterInverseRule Class
Members See Also Send Feedback
A filter rule that inverts the boolean values returned by the rule it contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterInverseRule : FilterRule
Visual Basic
Public Class FilterInverseRule _
    Inherits FilterRule
Visual C++
public ref class FilterInverseRule : public FilterRule

Remarks

FilterInverse rule performs a logical "not" operation on its inner rule's "elementPasses()" method.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterInverseRule

See Also

FilterInverseRule Members


FilterInverseRule Members

[image] [image]

Revit 2013 API
FilterInverseRule Members
FilterInverseRule Class Constructors Methods See Also Send Feedback

The FilterInverseRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterInverseRule | Constructs a new instance of FilterInverseRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInnerRule | Gets the rule being inverted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInnerRule | Gets the rule being inverted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterInverseRule Class


FilterInverseRule Constructor

[image]

Revit 2013 API
FilterInverseRule Constructor
FilterInverseRule Class See Also Send Feedback
Constructs a new instance of FilterInverseRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterInverseRule(
    FilterRule innerRule
)
Visual Basic
Public Sub New ( _
    innerRule As FilterRule _
)
Visual C++
public:
FilterInverseRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterInverseRule Class


FilterInverseRule Methods

[image] [image]

Revit 2013 API
FilterInverseRule Methods
FilterInverseRule Class See Also Send Feedback

The FilterInverseRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInnerRule | Gets the rule being inverted.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInnerRule | Gets the rule being inverted.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterInverseRule Class


GetInnerRule Method

[image]

Revit 2013 API
FilterInverseRule..::..GetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterRule GetInnerRule()
Visual Basic
Public Function GetInnerRule As FilterRule
Visual C++
public:
FilterRule^ GetInnerRule()

See Also

FilterInverseRule Class


SetInnerRule Method

[image]

Revit 2013 API
FilterInverseRule..::..SetInnerRule Method
FilterInverseRule Class See Also Send Feedback
Gets the rule being inverted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetInnerRule(
    FilterRule innerRule
)
Visual Basic
Public Sub SetInnerRule ( _
    innerRule As FilterRule _
)
Visual C++
public:
void SetInnerRule(
    FilterRule^ innerRule
)

Parameters

innerRule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to invert.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterInverseRule Class


FilterNumericEquals Class

[image]

Revit 2013 API
FilterNumericEquals Class
Members See Also Send Feedback
Tests whether numeric values from the document are equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericEquals : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericEquals _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericEquals : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericEquals

See Also

FilterNumericEquals Members


FilterNumericEquals Members

[image] [image]

Revit 2013 API
FilterNumericEquals Members
FilterNumericEquals Class Constructors Methods See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericEquals | Constructs an instance of FilterNumericEquals.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericEquals Class


FilterNumericEquals Constructor

[image]

Revit 2013 API
FilterNumericEquals Constructor
FilterNumericEquals Class See Also Send Feedback
Constructs an instance of FilterNumericEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericEquals()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericEquals()

See Also

FilterNumericEquals Class


FilterNumericEquals Methods

[image] [image]

Revit 2013 API
FilterNumericEquals Methods
FilterNumericEquals Class See Also Send Feedback

The FilterNumericEquals type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericEquals Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericEquals..::..Evaluate Method
FilterNumericEquals Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericEquals Class
FilterNumericEquals Members


FilterNumericGreater Class

[image]

Revit 2013 API
FilterNumericGreater Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericGreater : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericGreater _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreater : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericGreater

See Also

FilterNumericGreater Members


FilterNumericGreater Members

[image] [image]

Revit 2013 API
FilterNumericGreater Members
FilterNumericGreater Class Constructors Methods See Also Send Feedback

The FilterNumericGreater type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericGreater | Constructs an instance of FilterNumericGreater.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreater Class


FilterNumericGreater Constructor

[image]

Revit 2013 API
FilterNumericGreater Constructor
FilterNumericGreater Class See Also Send Feedback
Constructs an instance of FilterNumericGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericGreater()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericGreater()

See Also

FilterNumericGreater Class


FilterNumericGreater Methods

[image] [image]

Revit 2013 API
FilterNumericGreater Methods
FilterNumericGreater Class See Also Send Feedback

The FilterNumericGreater type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreater Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericGreater..::..Evaluate Method
FilterNumericGreater Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreater Class
FilterNumericGreater Members


FilterNumericGreaterOrEqual Class

[image]

Revit 2013 API
FilterNumericGreaterOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are greater than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericGreaterOrEqual : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericGreaterOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericGreaterOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericGreaterOrEqual

See Also

FilterNumericGreaterOrEqual Members


FilterNumericGreaterOrEqual Members

[image] [image]

Revit 2013 API
FilterNumericGreaterOrEqual Members
FilterNumericGreaterOrEqual Class Constructors Methods See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericGreaterOrEqual | Constructs an instance of FilterNumericGreaterOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Constructor

[image]

Revit 2013 API
FilterNumericGreaterOrEqual Constructor
FilterNumericGreaterOrEqual Class See Also Send Feedback
Constructs an instance of FilterNumericGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericGreaterOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericGreaterOrEqual()

See Also

FilterNumericGreaterOrEqual Class


FilterNumericGreaterOrEqual Methods

[image] [image]

Revit 2013 API
FilterNumericGreaterOrEqual Methods
FilterNumericGreaterOrEqual Class See Also Send Feedback

The FilterNumericGreaterOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericGreaterOrEqual Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericGreaterOrEqual..::..Evaluate Method
FilterNumericGreaterOrEqual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericGreaterOrEqual Class
FilterNumericGreaterOrEqual Members


FilterNumericLess Class

[image]

Revit 2013 API
FilterNumericLess Class
Members See Also Send Feedback
Tests whether numeric values from the document are less than a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericLess : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericLess _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericLess : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericLess

See Also

FilterNumericLess Members


FilterNumericLess Members

[image] [image]

Revit 2013 API
FilterNumericLess Members
FilterNumericLess Class Constructors Methods See Also Send Feedback

The FilterNumericLess type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericLess | Constructs an instance of FilterNumericLess.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLess Class


FilterNumericLess Constructor

[image]

Revit 2013 API
FilterNumericLess Constructor
FilterNumericLess Class See Also Send Feedback
Constructs an instance of FilterNumericLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericLess()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericLess()

See Also

FilterNumericLess Class


FilterNumericLess Methods

[image] [image]

Revit 2013 API
FilterNumericLess Methods
FilterNumericLess Class See Also Send Feedback

The FilterNumericLess type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLess Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericLess..::..Evaluate Method
FilterNumericLess Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLess Class
FilterNumericLess Members


FilterNumericLessOrEqual Class

[image]

Revit 2013 API
FilterNumericLessOrEqual Class
Members See Also Send Feedback
Tests whether numeric values from the document are less than or equal to a certain value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericLessOrEqual : FilterNumericRuleEvaluator
Visual Basic
Public Class FilterNumericLessOrEqual _
    Inherits FilterNumericRuleEvaluator
Visual C++
public ref class FilterNumericLessOrEqual : public FilterNumericRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericLessOrEqual

See Also

FilterNumericLessOrEqual Members


FilterNumericLessOrEqual Members

[image] [image]

Revit 2013 API
FilterNumericLessOrEqual Members
FilterNumericLessOrEqual Class Constructors Methods See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterNumericLessOrEqual | Constructs an instance of FilterNumericLessOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Constructor

[image]

Revit 2013 API
FilterNumericLessOrEqual Constructor
FilterNumericLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterNumericLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericLessOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterNumericLessOrEqual()

See Also

FilterNumericLessOrEqual Class


FilterNumericLessOrEqual Methods

[image] [image]

Revit 2013 API
FilterNumericLessOrEqual Methods
FilterNumericLessOrEqual Class See Also Send Feedback

The FilterNumericLessOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterNumericRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericLessOrEqual Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericLessOrEqual..::..Evaluate Method
FilterNumericLessOrEqual Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test. (Inherited from FilterNumericRuleEvaluator.)
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not. (Inherited from FilterNumericRuleEvaluator.)

See Also

FilterNumericLessOrEqual Class
FilterNumericLessOrEqual Members


FilterNumericRuleEvaluator Class

[image]

Revit 2013 API
FilterNumericRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare numeric values from Revit to a user-supplied filter value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericRuleEvaluator : IDisposable
Visual Basic
Public Class FilterNumericRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterNumericRuleEvaluator : IDisposable

Remarks

A class derived from FilterNumericRuleEvaluator must handle both integer and double-precision types. For double-precision comparisons, an epsilon value is given. The evaluator class should use this value in a manner appropriate to the comparison being implemented.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
Autodesk.Revit.DB..::..FilterNumericEquals
Autodesk.Revit.DB..::..FilterNumericGreater
Autodesk.Revit.DB..::..FilterNumericGreaterOrEqual
Autodesk.Revit.DB..::..FilterNumericLess
Autodesk.Revit.DB..::..FilterNumericLessOrEqual

See Also

FilterNumericRuleEvaluator Members


FilterNumericRuleEvaluator Members

[image] [image]

Revit 2013 API
FilterNumericRuleEvaluator Members
FilterNumericRuleEvaluator Class Methods See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterNumericRuleEvaluator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericRuleEvaluator Class


FilterNumericRuleEvaluator Methods

[image] [image]

Revit 2013 API
FilterNumericRuleEvaluator Methods
FilterNumericRuleEvaluator Class See Also Send Feedback

The FilterNumericRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericRuleEvaluator Class


Dispose Method

[image]

Revit 2013 API
FilterNumericRuleEvaluator..::..Dispose Method
FilterNumericRuleEvaluator Class See Also Send Feedback
Releases all resources used by the FilterNumericRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterNumericRuleEvaluator Class


Evaluate Method

[image] [image]

Revit 2013 API
FilterNumericRuleEvaluator..::..Evaluate Method
FilterNumericRuleEvaluator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Evaluate(Int32, Int32) | Derived classes should override this method to implement the desired test.
Public method | Evaluate(Double, Double, Double) | Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

See Also

FilterNumericRuleEvaluator Class
FilterNumericRuleEvaluator Members


Evaluate Method (Int32, Int32)

[image]

Revit 2013 API
FilterNumericRuleEvaluator..::..Evaluate Method (Int32, Int32)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes should override this method to implement the desired test.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    int lhs,
    int rhs
)
Visual Basic
Public Function Evaluate ( _
    lhs As Integer, _
    rhs As Integer _
) As Boolean
Visual C++
public:
bool Evaluate(
    int lhs,
    int rhs
)

Parameters

lhs
Type: System..::..Int32
A value from an element in the document.
rhs
Type: System..::..Int32
The user-supplied value against which values from the document are tested.

Return Value

True if lhs, rhs satisfy the condition implemented by this evaluator.

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


Evaluate Method (Double, Double, Double)

[image]

Revit 2013 API
FilterNumericRuleEvaluator..::..Evaluate Method (Double, Double, Double)
FilterNumericRuleEvaluator Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the two given double-precision values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)
Visual Basic
Public Function Evaluate ( _
    lhs As Double, _
    rhs As Double, _
    epsilon As Double _
) As Boolean
Visual C++
public:
bool Evaluate(
    double lhs,
    double rhs,
    double epsilon
)

Parameters

lhs
Type: System..::..Double
A value from an element in the document.
rhs
Type: System..::..Double
The user-supplied value against which values from the document are tested.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Return Value

True if the given arguments satisfy the condition, otherwise false.

Remarks

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for lhs is not finite -or- The given value for lhs is not a number -or- The given value for rhs is not finite -or- The given value for rhs is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number

See Also

FilterNumericRuleEvaluator Class
Evaluate Overload


FilterNumericValueRule Class

[image]

Revit 2013 API
FilterNumericValueRule Class
Members See Also Send Feedback
Base for all classes that use a FilterNumericRuleEvaluator to perform their comparisons

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterNumericValueRule : FilterValueRule
Visual Basic
Public Class FilterNumericValueRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterNumericValueRule : public FilterValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterDoubleRule
Autodesk.Revit.DB..::..FilterElementIdRule
Autodesk.Revit.DB..::..FilterIntegerRule

See Also

FilterNumericValueRule Members


FilterNumericValueRule Members

[image] [image]

Revit 2013 API
FilterNumericValueRule Members
FilterNumericValueRule Class Methods See Also Send Feedback

The FilterNumericValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericValueRule Class


FilterNumericValueRule Methods

[image] [image]

Revit 2013 API
FilterNumericValueRule Methods
FilterNumericValueRule Class See Also Send Feedback

The FilterNumericValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterNumericValueRule Class


GetEvaluator Method

[image]

Revit 2013 API
FilterNumericValueRule..::..GetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterNumericRuleEvaluator GetEvaluator()
Visual Basic
Public Function GetEvaluator As FilterNumericRuleEvaluator
Visual C++
public:
FilterNumericRuleEvaluator^ GetEvaluator()

See Also

FilterNumericValueRule Class


SetEvaluator Method

[image]

Revit 2013 API
FilterNumericValueRule..::..SetEvaluator Method
FilterNumericValueRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterNumericRuleEvaluator evaluator
)
Visual Basic
Public Sub SetEvaluator ( _
    evaluator As FilterNumericRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterNumericRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterNumericValueRule Class


FilterRule Class

[image]

Revit 2013 API
FilterRule Class
Members See Also Send Feedback
Defines a boolean operation that can be used to cull elements from a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterRule : IDisposable
Visual Basic
Public Class FilterRule _
    Implements IDisposable
Visual C++
public ref class FilterRule : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterInverseRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..SharedParameterApplicableRule

See Also

FilterRule Members


FilterRule Members

[image] [image]

Revit 2013 API
FilterRule Members
FilterRule Class Methods See Also Send Feedback

The FilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterRule
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterRule Class


FilterRule Methods

[image] [image]

Revit 2013 API
FilterRule Methods
FilterRule Class See Also Send Feedback

The FilterRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterRule Class


Dispose Method

[image]

Revit 2013 API
FilterRule..::..Dispose Method
FilterRule Class See Also Send Feedback
Releases all resources used by the FilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterRule Class


ElementPasses Method

[image]

Revit 2013 API
FilterRule..::..ElementPasses Method
FilterRule Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the given element passes this rule or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ElementPasses(
    Element element
)
Visual Basic
Public Function ElementPasses ( _
    element As Element _
) As Boolean
Visual C++
public:
bool ElementPasses(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to test against the rule.

Return Value

True if the element satisfies the rule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterRule Class


FilterStringBeginsWith Class

[image]

Revit 2013 API
FilterStringBeginsWith Class
Members See Also Send Feedback
Tests whether string values from the document begin with a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringBeginsWith : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringBeginsWith _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringBeginsWith : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringBeginsWith

See Also

FilterStringBeginsWith Members


FilterStringBeginsWith Members

[image] [image]

Revit 2013 API
FilterStringBeginsWith Members
FilterStringBeginsWith Class Constructors Methods See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringBeginsWith | Constructs an instance of FilterStringBeginsWith.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Constructor

[image]

Revit 2013 API
FilterStringBeginsWith Constructor
FilterStringBeginsWith Class See Also Send Feedback
Constructs an instance of FilterStringBeginsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringBeginsWith()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringBeginsWith()

See Also

FilterStringBeginsWith Class


FilterStringBeginsWith Methods

[image] [image]

Revit 2013 API
FilterStringBeginsWith Methods
FilterStringBeginsWith Class See Also Send Feedback

The FilterStringBeginsWith type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringBeginsWith Class


FilterStringContains Class

[image]

Revit 2013 API
FilterStringContains Class
Members See Also Send Feedback
Tests whether string values from the document contain a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringContains : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringContains _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringContains : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringContains

See Also

FilterStringContains Members


FilterStringContains Members

[image] [image]

Revit 2013 API
FilterStringContains Members
FilterStringContains Class Constructors Methods See Also Send Feedback

The FilterStringContains type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringContains | Constructs an instance of FilterStringContains.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringContains Class


FilterStringContains Constructor

[image]

Revit 2013 API
FilterStringContains Constructor
FilterStringContains Class See Also Send Feedback
Constructs an instance of FilterStringContains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringContains()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringContains()

See Also

FilterStringContains Class


FilterStringContains Methods

[image] [image]

Revit 2013 API
FilterStringContains Methods
FilterStringContains Class See Also Send Feedback

The FilterStringContains type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringContains Class


FilterStringEndsWith Class

[image]

Revit 2013 API
FilterStringEndsWith Class
Members See Also Send Feedback
Tests whether string values from the document end with a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringEndsWith : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringEndsWith _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringEndsWith : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringEndsWith

See Also

FilterStringEndsWith Members


FilterStringEndsWith Members

[image] [image]

Revit 2013 API
FilterStringEndsWith Members
FilterStringEndsWith Class Constructors Methods See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringEndsWith | Constructs an instance of FilterStringEndsWith.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEndsWith Class


FilterStringEndsWith Constructor

[image]

Revit 2013 API
FilterStringEndsWith Constructor
FilterStringEndsWith Class See Also Send Feedback
Constructs an instance of FilterStringEndsWith.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringEndsWith()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringEndsWith()

See Also

FilterStringEndsWith Class


FilterStringEndsWith Methods

[image] [image]

Revit 2013 API
FilterStringEndsWith Methods
FilterStringEndsWith Class See Also Send Feedback

The FilterStringEndsWith type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEndsWith Class


FilterStringEquals Class

[image]

Revit 2013 API
FilterStringEquals Class
Members See Also Send Feedback
Tests whether string values from the document match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringEquals : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringEquals _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringEquals : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringEquals

See Also

FilterStringEquals Members


FilterStringEquals Members

[image] [image]

Revit 2013 API
FilterStringEquals Members
FilterStringEquals Class Constructors Methods See Also Send Feedback

The FilterStringEquals type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringEquals | Constructs an instance of FilterStringEquals.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEquals Class


FilterStringEquals Constructor

[image]

Revit 2013 API
FilterStringEquals Constructor
FilterStringEquals Class See Also Send Feedback
Constructs an instance of FilterStringEquals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringEquals()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringEquals()

See Also

FilterStringEquals Class


FilterStringEquals Methods

[image] [image]

Revit 2013 API
FilterStringEquals Methods
FilterStringEquals Class See Also Send Feedback

The FilterStringEquals type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringEquals Class


FilterStringGreater Class

[image]

Revit 2013 API
FilterStringGreater Class
Members See Also Send Feedback
Tests whether string values from the document would sort after a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringGreater : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringGreater _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreater : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringGreater

See Also

FilterStringGreater Members


FilterStringGreater Members

[image] [image]

Revit 2013 API
FilterStringGreater Members
FilterStringGreater Class Constructors Methods See Also Send Feedback

The FilterStringGreater type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringGreater | Constructs an instance of FilterStringGreater.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreater Class


FilterStringGreater Constructor

[image]

Revit 2013 API
FilterStringGreater Constructor
FilterStringGreater Class See Also Send Feedback
Constructs an instance of FilterStringGreater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringGreater()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringGreater()

See Also

FilterStringGreater Class


FilterStringGreater Methods

[image] [image]

Revit 2013 API
FilterStringGreater Methods
FilterStringGreater Class See Also Send Feedback

The FilterStringGreater type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreater Class


FilterStringGreaterOrEqual Class

[image]

Revit 2013 API
FilterStringGreaterOrEqual Class
Members See Also Send Feedback
Tests whether string values from the document would sort after or match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringGreaterOrEqual : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringGreaterOrEqual _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringGreaterOrEqual : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringGreaterOrEqual

See Also

FilterStringGreaterOrEqual Members


FilterStringGreaterOrEqual Members

[image] [image]

Revit 2013 API
FilterStringGreaterOrEqual Members
FilterStringGreaterOrEqual Class Constructors Methods See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringGreaterOrEqual | Constructs an instance of FilterStringGreaterOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Constructor

[image]

Revit 2013 API
FilterStringGreaterOrEqual Constructor
FilterStringGreaterOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringGreaterOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringGreaterOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringGreaterOrEqual()

See Also

FilterStringGreaterOrEqual Class


FilterStringGreaterOrEqual Methods

[image] [image]

Revit 2013 API
FilterStringGreaterOrEqual Methods
FilterStringGreaterOrEqual Class See Also Send Feedback

The FilterStringGreaterOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringGreaterOrEqual Class


FilterStringLess Class

[image]

Revit 2013 API
FilterStringLess Class
Members See Also Send Feedback
Tests whether string values from the document would sort before a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringLess : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringLess _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringLess : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringLess

See Also

FilterStringLess Members


FilterStringLess Members

[image] [image]

Revit 2013 API
FilterStringLess Members
FilterStringLess Class Constructors Methods See Also Send Feedback

The FilterStringLess type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringLess | Constructs an instance of FilterStringLess.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLess Class


FilterStringLess Constructor

[image]

Revit 2013 API
FilterStringLess Constructor
FilterStringLess Class See Also Send Feedback
Constructs an instance of FilterStringLess.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringLess()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringLess()

See Also

FilterStringLess Class


FilterStringLess Methods

[image] [image]

Revit 2013 API
FilterStringLess Methods
FilterStringLess Class See Also Send Feedback

The FilterStringLess type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLess Class


FilterStringLessOrEqual Class

[image]

Revit 2013 API
FilterStringLessOrEqual Class
Members See Also Send Feedback
Tests whether string values from the document would sort before or match a certain string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringLessOrEqual : FilterStringRuleEvaluator
Visual Basic
Public Class FilterStringLessOrEqual _
    Inherits FilterStringRuleEvaluator
Visual C++
public ref class FilterStringLessOrEqual : public FilterStringRuleEvaluator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringLessOrEqual

See Also

FilterStringLessOrEqual Members


FilterStringLessOrEqual Members

[image] [image]

Revit 2013 API
FilterStringLessOrEqual Members
FilterStringLessOrEqual Class Constructors Methods See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringLessOrEqual | Constructs an instance of FilterStringLessOrEqual.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Constructor

[image]

Revit 2013 API
FilterStringLessOrEqual Constructor
FilterStringLessOrEqual Class See Also Send Feedback
Constructs an instance of FilterStringLessOrEqual.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringLessOrEqual()
Visual Basic
Public Sub New
Visual C++
public:
FilterStringLessOrEqual()

See Also

FilterStringLessOrEqual Class


FilterStringLessOrEqual Methods

[image] [image]

Revit 2013 API
FilterStringLessOrEqual Methods
FilterStringLessOrEqual Class See Also Send Feedback

The FilterStringLessOrEqual type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterStringRuleEvaluator.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not. (Inherited from FilterStringRuleEvaluator.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringLessOrEqual Class


FilterStringRule Class

[image]

Revit 2013 API
FilterStringRule Class
Members See Also Send Feedback
A filter rule that operates on string values in a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringRule : FilterValueRule
Visual Basic
Public Class FilterStringRule _
    Inherits FilterValueRule
Visual C++
public ref class FilterStringRule : public FilterValueRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterStringRule

See Also

FilterStringRule Members


FilterStringRule Members

[image] [image]

Revit 2013 API
FilterStringRule Members
FilterStringRule Class Constructors Methods Properties See Also Send Feedback

The FilterStringRule type exposes the following members.

Constructors

 | Name | Description
Public method | FilterStringRule | Constructs an instance of FilterStringRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CaseSensitive | Obsolete. The boolean flag that determines whether or not the filter rule respects case when comparing strings.
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class


FilterStringRule Constructor

[image]

Revit 2013 API
FilterStringRule Constructor
FilterStringRule Class See Also Send Feedback
Constructs an instance of FilterStringRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringRule(
    FilterableValueProvider valueProvider,
    FilterStringRuleEvaluator evaluator,
    string ruleString,
    bool caseSensitive
)
Visual Basic
Public Sub New ( _
    valueProvider As FilterableValueProvider, _
    evaluator As FilterStringRuleEvaluator, _
    ruleString As String, _
    caseSensitive As Boolean _
)
Visual C++
public:
FilterStringRule(
    FilterableValueProvider^ valueProvider,
    FilterStringRuleEvaluator^ evaluator,
    String^ ruleString,
    bool caseSensitive
)

Parameters

valueProvider
Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DB..::..FilterStringRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests for strings such as begins-with, ends-with, contains, equal, etc.
ruleString
Type: System..::..String
The user-supplied string against which strings from a Revit document will be tested.
caseSensitive
Type: System..::..Boolean
If true, string comparisons will be done case-sensitively.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRule Class


FilterStringRule Methods

[image] [image]

Revit 2013 API
FilterStringRule Methods
FilterStringRule Class See Also Send Feedback

The FilterStringRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEvaluator | Gets the evaluator that implements the test for this rule.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEvaluator | Sets the evaluator that implements the test for this rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRule Class


GetEvaluator Method

[image]

Revit 2013 API
FilterStringRule..::..GetEvaluator Method
FilterStringRule Class See Also Send Feedback
Gets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FilterStringRuleEvaluator GetEvaluator()
Visual Basic
Public Function GetEvaluator As FilterStringRuleEvaluator
Visual C++
public:
FilterStringRuleEvaluator^ GetEvaluator()

See Also

FilterStringRule Class


SetEvaluator Method

[image]

Revit 2013 API
FilterStringRule..::..SetEvaluator Method
FilterStringRule Class See Also Send Feedback
Sets the evaluator that implements the test for this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetEvaluator(
    FilterStringRuleEvaluator evaluator
)
Visual Basic
Public Sub SetEvaluator ( _
    evaluator As FilterStringRuleEvaluator _
)
Visual C++
public:
void SetEvaluator(
    FilterStringRuleEvaluator^ evaluator
)

Parameters

evaluator
Type: Autodesk.Revit.DB..::..FilterStringRuleEvaluator

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRule Class


FilterStringRule Properties

[image] [image]

Revit 2013 API
FilterStringRule Properties
FilterStringRule Class See Also Send Feedback

The FilterStringRule type exposes the following members.

Properties

 | Name | Description
Public property | CaseSensitive | Obsolete. The boolean flag that determines whether or not the filter rule respects case when comparing strings.
Public property | RuleString | The user-supplied string against which strings from a Revit document will be tested.

See Also

FilterStringRule Class


CaseSensitive Property

[image]

Revit 2013 API
FilterStringRule..::..CaseSensitive Property
FilterStringRule Class See Also Send Feedback
The boolean flag that determines whether or not the filter rule respects case when comparing strings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")]
public bool CaseSensitive { get; set; }
Visual Basic
<ObsoleteAttribute("Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")> _
Public Property CaseSensitive As Boolean
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Case-sensitivity for filter rules is being phased out. In Revit 2013, case-sensitive filter rules will continue to use the old behavior. Case-insensitive filter rules will now use the same string matching algorithm used elsewhere in Revit.")]
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

FilterStringRule Class


RuleString Property

[image]

Revit 2013 API
FilterStringRule..::..RuleString Property
FilterStringRule Class See Also Send Feedback
The user-supplied string against which strings from a Revit document will be tested.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string RuleString { get; set; }
Visual Basic
Public Property RuleString As String
    Get
    Set
Visual C++
public:
property String^ RuleString {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

FilterStringRule Class


FilterStringRuleEvaluator Class

[image]

Revit 2013 API
FilterStringRuleEvaluator Class
Members See Also Send Feedback
Base for all classes that compare string values from Revit to a user-supplied filter value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterStringRuleEvaluator : IDisposable
Visual Basic
Public Class FilterStringRuleEvaluator _
    Implements IDisposable
Visual C++
public ref class FilterStringRuleEvaluator : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterStringRuleEvaluator
Autodesk.Revit.DB..::..FilterStringBeginsWith
Autodesk.Revit.DB..::..FilterStringContains
Autodesk.Revit.DB..::..FilterStringEndsWith
Autodesk.Revit.DB..::..FilterStringEquals
Autodesk.Revit.DB..::..FilterStringGreater
Autodesk.Revit.DB..::..FilterStringGreaterOrEqual
Autodesk.Revit.DB..::..FilterStringLess
Autodesk.Revit.DB..::..FilterStringLessOrEqual

See Also

FilterStringRuleEvaluator Members


FilterStringRuleEvaluator Members

[image] [image]

Revit 2013 API
FilterStringRuleEvaluator Members
FilterStringRuleEvaluator Class Methods See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FilterStringRuleEvaluator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRuleEvaluator Class


FilterStringRuleEvaluator Methods

[image] [image]

Revit 2013 API
FilterStringRuleEvaluator Methods
FilterStringRuleEvaluator Class See Also Send Feedback

The FilterStringRuleEvaluator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterStringRuleEvaluator Class


Dispose Method

[image]

Revit 2013 API
FilterStringRuleEvaluator..::..Dispose Method
FilterStringRuleEvaluator Class See Also Send Feedback
Releases all resources used by the FilterStringRuleEvaluator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FilterStringRuleEvaluator Class


Evaluate Method

[image]

Revit 2013 API
FilterStringRuleEvaluator..::..Evaluate Method
FilterStringRuleEvaluator Class See Also Send Feedback
Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Evaluate(
    string lhs,
    string rhs,
    bool caseSensitive
)
Visual Basic
Public Function Evaluate ( _
    lhs As String, _
    rhs As String, _
    caseSensitive As Boolean _
) As Boolean
Visual C++
public:
bool Evaluate(
    String^ lhs,
    String^ rhs,
    bool caseSensitive
)

Parameters

lhs
Type: System..::..String
A value from an element in the document.
rhs
Type: System..::..String
The user-supplied value against which values from the document are tested.
caseSensitive
Type: System..::..Boolean
If true, string comparisons are done case-sensitively.

Return Value

True if the given arguments satisfy the condition, otherwise false.

Remarks

The arguments may be thought of as the left and right operands of a binary expression; for example, "a < b", "x >= 100", etc. The left operand comes from an element in the Revit document (e.g., the value of a parameter.) The right operand is supplied by the user when creating the filter that contains the rule that uses this evaluator.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FilterStringRuleEvaluator Class


FilterValueRule Class

[image]

Revit 2013 API
FilterValueRule Class
Members See Also Send Feedback
A rule that filters on a particular value of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FilterValueRule : FilterRule
Visual Basic
Public Class FilterValueRule _
    Inherits FilterRule
Visual C++
public ref class FilterValueRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..FilterValueRule
Autodesk.Revit.DB..::..FilterNumericValueRule
Autodesk.Revit.DB..::..FilterStringRule

See Also

FilterValueRule Members


FilterValueRule Members

[image] [image]

Revit 2013 API
FilterValueRule Members
FilterValueRule Class Methods See Also Send Feedback

The FilterValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterValueRule Class


FilterValueRule Methods

[image] [image]

Revit 2013 API
FilterValueRule Methods
FilterValueRule Class See Also Send Feedback

The FilterValueRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterValueRule Class


FindReferenceTarget Enumeration

[image]

Revit 2013 API
FindReferenceTarget Enumeration
See Also Send Feedback
The type of reference to find
The type of reference to find

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum FindReferenceTarget
Visual Basic
Public Enumeration FindReferenceTarget
Visual C++
public enum class FindReferenceTarget

Members

Member name | Description
Element |
Mesh |
Edge |
Curve |
Face |
All |

See Also


FitDirectionType Enumeration

[image]

Revit 2013 API
FitDirectionType Enumeration
See Also Send Feedback
This enum is used to define the direction to fit the number of pixels defined by PixelSize.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum FitDirectionType
Visual Basic
Public Enumeration FitDirectionType
Visual C++
public enum class FitDirectionType

Members

Member name | Description
Horizontal | Fit a specific number of pixels in horizontal direction.
Vertical | Fit a specific number of pixels in vertical direction.

See Also


Floor Class

[image]

Revit 2013 API
Floor Class
Members Example See Also Send Feedback
An object that represents a Floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Floor : CeilingAndFloor
Visual Basic
Public Class Floor _
    Inherits CeilingAndFloor
Visual C++
public ref class Floor : public CeilingAndFloor

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
public void ShowFloorInfo(Floor floor)
{
    string message = "Floor : ";
    // Get Floor AnalyticalModel
    message += "\nFloor AnalyticalModel is : " + floor.GetAnalyticalModel();

    // Get Floor type name
    message += "\nFloor type name is : " + floor.FloorType.Name;
    try
    {
        // Get Floor span direction angle
        message += "\nFloor span direction angle is : " + floor.SpanDirectionAngle;
    }
    catch (Exception)
    {
        // an exception is thrown if floor is non-structural
        message += "\nFloor is non-structural.";
    }

    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Public Sub ShowFloorInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim message As String = "Floor : "
    ' Get Floor AnalyticalModel
    message += vbLf & "Floor AnalyticalModel is : " & floor.GetAnalyticalModel().ToString()

    ' Get Floor type name
    message += vbLf & "Floor type name is : " & floor.FloorType.Name.ToString()
    Try
        ' Get Floor span direction angle
        message += vbLf & "Floor span direction angle is : " + floor.SpanDirectionAngle
    Catch generatedExceptionName As Exception
        ' an exception is thrown if floor is non-structural
        message += vbLf & "Floor is non-structural."
    End Try

    TaskDialog.Show("Revit", message)

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..Floor

See Also

Floor Members


Floor Members

[image] [image]

Revit 2013 API
Floor Members
Floor Class Methods Properties See Also Send Feedback

The Floor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | Obsolete. An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Floor Class


Floor Methods

[image] [image]

Revit 2013 API
Floor Methods
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNormalAtVerticalProjectionPoint | Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSpanDirectionSymbolIds | Retrieves span direction symbol ElementIds.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVerticalProjectionPoint | Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Floor Class


GetNormalAtVerticalProjectionPoint Method

[image]

Revit 2013 API
Floor..::..GetNormalAtVerticalProjectionPoint Method
Floor Class See Also Send Feedback
Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ GetNormalAtVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Visual Basic
Public Function GetNormalAtVerticalProjectionPoint ( _
    modelLocation As XYZ, _
    floorFace As FloorFace _
) As XYZ
Visual C++
public:
XYZ^ GetNormalAtVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)

Parameters

modelLocation
Type: Autodesk.Revit.DB..::..XYZ
A point in project coordinates whose vertical projection will determine the location at which the normal will be taken.
floorFace
Type: Autodesk.Revit.DB..::..FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

Normal vector on the slab at the projection point.

Remarks

If the floor is shape edited, the floor location at which we attempt to take the normal must be within the boundaries of a face on the slab. Otherwise the method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


GetSpanDirectionSymbolIds Method

[image]

Revit 2013 API
Floor..::..GetSpanDirectionSymbolIds Method
Floor Class See Also Send Feedback
Retrieves span direction symbol ElementIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetSpanDirectionSymbolIds()
Visual Basic
Public Function GetSpanDirectionSymbolIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSpanDirectionSymbolIds()

Return Value

A collection of Element Ids of span direction symbol elements

Remarks

The element types of the Ids of these symbols determine if the floor has one way or two way span direction graphics.

See Also

Floor Class


GetVerticalProjectionPoint Method

[image]

Revit 2013 API
Floor..::..GetVerticalProjectionPoint Method
Floor Class See Also Send Feedback
Return a surface point on either the top or bottom face of a floor slab corresponding to the vertical projection of an arbitrary point in project space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ GetVerticalProjectionPoint(
    XYZ modelLocation,
    FloorFace floorFace
)
Visual Basic
Public Function GetVerticalProjectionPoint ( _
    modelLocation As XYZ, _
    floorFace As FloorFace _
) As XYZ
Visual C++
public:
XYZ^ GetVerticalProjectionPoint(
    XYZ^ modelLocation,
    FloorFace floorFace
)

Parameters

modelLocation
Type: Autodesk.Revit.DB..::..XYZ
A point in project coordinates that will be projected to the slab top or bottom face.
floorFace
Type: Autodesk.Revit.DB..::..FloorFace
A flag determining whether the top or bottom face of the floor should be used.

Return Value

Slab surface point for the vertically projected model point.

Remarks

If the floor is shape edited, the surface location must be within the boundaries of a face on the slab. Otherwise the method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


Floor Properties

[image] [image]

Revit 2013 API
Floor Properties
Floor Class See Also Send Feedback

The Floor type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorType | Retrieves/set an object that represents the type of the floor.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | SpanDirectionAngle | Retrieve the span direction angle of the floor
Public property | SpanDirectionSymbols | Obsolete. An array of span direction symbols associated with this floor.
Public property | StructuralUsage | The floors designated structural usage, such as bearing or non bearing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Floor Class


FloorType Property

[image]

Revit 2013 API
Floor..::..FloorType Property
Floor Class See Also Send Feedback
Retrieves/set an object that represents the type of the floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FloorType FloorType { get; set; }
Visual Basic
Public Property FloorType As FloorType
    Get
    Set
Visual C++
public:
property FloorType^ FloorType {
    FloorType^ get ();
    void set (FloorType^ value);
}

Remarks

The floor type can be used to access the multi layered structure of a floor.

See Also

Floor Class


Parameter Property

[image] [image]

Revit 2013 API
Floor..::..Parameter Property
Floor Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Floor Class
Floor Members


SlabShapeEditor Property

[image]

Revit 2013 API
Floor..::..SlabShapeEditor Property
Floor Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
    Get
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Only flat and horizontal floor is valid for slab shape edit. Otherwise, ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Floor Class


SpanDirectionAngle Property

[image]

Revit 2013 API
Floor..::..SpanDirectionAngle Property
Floor Class See Also Send Feedback
Retrieve the span direction angle of the floor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SpanDirectionAngle { get; set; }
Visual Basic
Public Property SpanDirectionAngle As Double
    Get
    Set
Visual C++
public:
property double SpanDirectionAngle {
    double get ();
    void set (double value);
}

Remarks

The angle returned is in radians. An exception will be thrown if the floor is non structural.

See Also

Floor Class


SpanDirectionSymbols Property

[image]

Revit 2013 API
Floor..::..SpanDirectionSymbols Property
Floor Class Example See Also Send Feedback
An array of span direction symbols associated with this floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")]
public ElementArray SpanDirectionSymbols { get; }
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")> _
Public ReadOnly Property SpanDirectionSymbols As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call GetSpanDirectionSymbolIds() instead.")]
public:
property ElementArray^ SpanDirectionSymbols {
    ElementArray^ get ();
}

Remarks

By using the ObjectType property of these span direction symbols it is possible to read if the floor has one way or two way span direction graphics.

Examples

CopyC#
public void SpanDirectionSymbolsInfo(Floor floor)
{
    string msg = "";
    if (0 == floor.SpanDirectionSymbols.Size)
    {
        msg = "No span direction symbol!";
    }
    foreach (Element element in floor.SpanDirectionSymbols)
    {
        msg += "Span direction symbol name is : " + element.Name;
    }

    // Give the user some information.
    TaskDialog.Show("Revit",msg);
}
CopyVB.NET
Public Sub SpanDirectionSymbolsInfo(ByVal floor As Autodesk.Revit.DB.Floor)
    Dim msg As String = ""
    If 0 = floor.SpanDirectionSymbols.Size Then
        msg = "No span direction symbol!"
    End If
    For Each element As Autodesk.Revit.DB.Element In floor.SpanDirectionSymbols
        msg += "Span direction symbol name is : " + element.Name
    Next

    ' Give the user some information.
    TaskDialog.Show("Revit", msg)
End Sub

See Also

Floor Class


StructuralUsage Property

[image]

Revit 2013 API
Floor..::..StructuralUsage Property
Floor Class See Also Send Feedback
The floors designated structural usage, such as bearing or non bearing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabFoundationType StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As SlabFoundationType
    Get
    Set
Visual C++
public:
property SlabFoundationType StructuralUsage {
    SlabFoundationType get ();
    void set (SlabFoundationType value);
}

Remarks

The StructuralUsage property is a read only property that returns the walls designated usage. Example values of this property are Non Bearing, Bearing, Shear, Combined etc.

See Also

Floor Class


FloorFace Enumeration

[image]

Revit 2013 API
FloorFace Enumeration
See Also Send Feedback
An enumerated type listing floor face types (top or bottom)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FloorFace
Visual Basic
Public Enumeration FloorFace
Visual C++
public enum class FloorFace

Members

Member name | Description
Top |
Bottom |

See Also


FloorType Class

[image]

Revit 2013 API
FloorType Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FloorType : HostObjAttributes
Visual Basic
Public Class FloorType _
    Inherits HostObjAttributes
Visual C++
public ref class FloorType : public HostObjAttributes

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_FloorType(FloorType floorType)
{
    string message;
    // Get whether FloorType is a foundation slab
    message = "If is foundation slab : " + floorType.IsFoundationSlab;
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_FloorType(ByVal floorType As FloorType)
    Dim message As String
    ' Get whether FloorType is a foundation slab
    message = "If is foundation slab : " & floorType.IsFoundationSlab.ToString()
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..FloorType

See Also

FloorType Members


FloorType Members

[image] [image]

Revit 2013 API
FloorType Members
FloorType Class Methods Properties See Also Send Feedback

The FloorType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FloorType Class


FloorType Methods

[image] [image]

Revit 2013 API
FloorType Methods
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorType Class


FloorType Properties

[image] [image]

Revit 2013 API
FloorType Properties
FloorType Class See Also Send Feedback

The FloorType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsFoundationSlab | Returns whether the element FloorAttributes type is FoundationSlab.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the FloorType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FloorType Class


IsFoundationSlab Property

[image]

Revit 2013 API
FloorType..::..IsFoundationSlab Property
FloorType Class See Also Send Feedback
Returns whether the element FloorAttributes type is FoundationSlab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFoundationSlab { get; }
Visual Basic
Public ReadOnly Property IsFoundationSlab As Boolean
    Get
Visual C++
public:
property bool IsFoundationSlab {
    bool get ();
}

See Also

FloorType Class


Parameter Property

[image] [image]

Revit 2013 API
FloorType..::..Parameter Property
FloorType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FloorType Class
FloorType Members


ThermalProperties Property

[image]

Revit 2013 API
FloorType..::..ThermalProperties Property
FloorType Class See Also Send Feedback
The calculated and settable thermal properties of the FloorType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | the floor does not have thermal properties.

See Also

FloorType Class


FloorTypeSet Class

[image]

Revit 2013 API
FloorTypeSet Class
Members See Also Send Feedback
A set that contains floor types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FloorTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class FloorTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FloorTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FloorTypeSet

See Also

FloorTypeSet Members


FloorTypeSet Members

[image] [image]

Revit 2013 API
FloorTypeSet Members
FloorTypeSet Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | FloorTypeSet | Initializes a new instance of the FloorTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every floor type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a floor type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified floor type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified floor type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class


FloorTypeSet Constructor

[image]

Revit 2013 API
FloorTypeSet Constructor
FloorTypeSet Class See Also Send Feedback
Initializes a new instance of the FloorTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FloorTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
FloorTypeSet()

See Also

FloorTypeSet Class


FloorTypeSet Methods

[image] [image]

Revit 2013 API
FloorTypeSet Methods
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every floor type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a floor type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified floor type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified floor type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSet Class


Clear Method

[image]

Revit 2013 API
FloorTypeSet..::..Clear Method
FloorTypeSet Class See Also Send Feedback
Removes every floor type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FloorTypeSet Class


Contains Method

[image]

Revit 2013 API
FloorTypeSet..::..Contains Method
FloorTypeSet Class See Also Send Feedback
Tests for the existence of a floor type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    FloorType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FloorType
The floor type to be searched for.

Return Value

The Contains method returns True if the floor type is within the set, otherwise False.

See Also

FloorTypeSet Class


Erase Method

[image]

Revit 2013 API
FloorTypeSet..::..Erase Method
FloorTypeSet Class See Also Send Feedback
Removes a specified floor type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    FloorType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FloorType _
) As Integer
Visual C++
public:
virtual int Erase(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FloorType
The floor type to be erased.

Return Value

The number of floor types that were erased from the set.

See Also

FloorTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
FloorTypeSet..::..ForwardIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FloorTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
FloorTypeSet..::..GetEnumerator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FloorTypeSet Class


Insert Method

[image]

Revit 2013 API
FloorTypeSet..::..Insert Method
FloorTypeSet Class See Also Send Feedback
Insert the specified floor type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    FloorType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FloorType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FloorType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..FloorType
The floor type to be inserted into the set.

Return Value

Returns whether the floor type was inserted into the set.

See Also

FloorTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
FloorTypeSet..::..ReverseIterator Method
FloorTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FloorTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FloorTypeSetIterator
Visual C++
public:
virtual FloorTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FloorTypeSet Class


FloorTypeSet Properties

[image] [image]

Revit 2013 API
FloorTypeSet Properties
FloorTypeSet Class See Also Send Feedback

The FloorTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of floor types that are in the set.

See Also

FloorTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
FloorTypeSet..::..IsEmpty Property
FloorTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FloorTypeSet Class


Size Property

[image]

Revit 2013 API
FloorTypeSet..::..Size Property
FloorTypeSet Class See Also Send Feedback
Returns the number of floor types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FloorTypeSet Class


FloorTypeSetIterator Class

[image]

Revit 2013 API
FloorTypeSetIterator Class
Members See Also Send Feedback
An iterator to a floor type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FloorTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FloorTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FloorTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FloorTypeSetIterator

See Also

FloorTypeSetIterator Members


FloorTypeSetIterator Members

[image] [image]

Revit 2013 API
FloorTypeSetIterator Members
FloorTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FloorTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Constructor

[image]

Revit 2013 API
FloorTypeSetIterator Constructor
FloorTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FloorTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FloorTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Methods

[image] [image]

Revit 2013 API
FloorTypeSetIterator Methods
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FloorTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
FloorTypeSetIterator..::..MoveNext Method
FloorTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
FloorTypeSetIterator..::..Reset Method
FloorTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FloorTypeSetIterator Class


FloorTypeSetIterator Properties

[image] [image]

Revit 2013 API
FloorTypeSetIterator Properties
FloorTypeSetIterator Class See Also Send Feedback

The FloorTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FloorTypeSetIterator Class


Current Property

[image]

Revit 2013 API
FloorTypeSetIterator..::..Current Property
FloorTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FloorTypeSetIterator Class


FlowDirectionType Enumeration

[image]

Revit 2013 API
FlowDirectionType Enumeration
See Also Send Feedback
An enumerated type listing direction types for a connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FlowDirectionType
Visual Basic
Public Enumeration FlowDirectionType
Visual C++
public enum class FlowDirectionType

Members

Member name | Description
Bidirectional | flow bidirectional
In | flow in
Out | flow out

See Also


FootPrintRoof Class

[image]

Revit 2013 API
FootPrintRoof Class
Members See Also Send Feedback
Represents kinds of FootPrintRoofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FootPrintRoof : RoofBase
Visual Basic
Public Class FootPrintRoof _
    Inherits RoofBase
Visual C++
public ref class FootPrintRoof : public RoofBase

Remarks

The FootPrintRoof object represents some kinds of FootPrintRoof in Revit. The RoofType property is used to distinguish the type of the roof.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..FootPrintRoof

See Also

FootPrintRoof Members


FootPrintRoof Members

[image] [image]

Revit 2013 API
FootPrintRoof Members
FootPrintRoof Class Methods Properties See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FootPrintRoof Class


FootPrintRoof Methods

[image] [image]

Revit 2013 API
FootPrintRoof Methods
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfiles | Retrieve all the curveLoops of FootPrintRoof.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FootPrintRoof Class


GetProfiles Method

[image]

Revit 2013 API
FootPrintRoof..::..GetProfiles Method
FootPrintRoof Class See Also Send Feedback
Retrieve all the curveLoops of FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArrArray GetProfiles()
Visual Basic
Public Function GetProfiles As ModelCurveArrArray
Visual C++
public:
ModelCurveArrArray^ GetProfiles()

See Also

FootPrintRoof Class


FootPrintRoof Properties

[image] [image]

Revit 2013 API
FootPrintRoof Properties
FootPrintRoof Class See Also Send Feedback

The FootPrintRoof type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrids | Retrieve all the CurtainGrid objects of a FootPrintRoof.
Public property | DefinesSlope | Retrieve or set the DefinesSlope of the curve.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType. (Inherited from RoofBase.)
Public property | ExtendIntoWall | Retrieve or set whether extend into wall the curve.
Public property | FasciaDepth | Retrieve or set the FasciaDepth. (Inherited from RoofBase.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Offset | Retrieve or set the Offset of the curve.
Public property | Overhang | Retrieve or set the Overhang of the curve.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type. (Inherited from RoofBase.)
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing. (Inherited from RoofBase.)
Public property | SlopeAngle | Retrieve or set the SlopeAngle of the curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FootPrintRoof Class


CurtainGrids Property

[image]

Revit 2013 API
FootPrintRoof..::..CurtainGrids Property
FootPrintRoof Class See Also Send Feedback
Retrieve all the CurtainGrid objects of a FootPrintRoof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGridSet CurtainGrids { get; }
Visual Basic
Public ReadOnly Property CurtainGrids As CurtainGridSet
    Get
Visual C++
public:
property CurtainGridSet^ CurtainGrids {
    CurtainGridSet^ get ();
}

Remarks

Only applicable when the object is a Curtain FootPrintRoof.

See Also

FootPrintRoof Class


DefinesSlope Property

[image]

Revit 2013 API
FootPrintRoof..::..DefinesSlope Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the DefinesSlope of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property DefinesSlope ( _
    pCurve As ModelCurve _
) As Boolean
    Get
    Set
Visual C++
public:
property bool DefinesSlope[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

See Also

FootPrintRoof Class


ExtendIntoWall Property

[image]

Revit 2013 API
FootPrintRoof..::..ExtendIntoWall Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set whether extend into wall the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property ExtendIntoWall ( _
    pCurve As ModelCurve _
) As Boolean
    Get
    Set
Visual C++
public:
property bool ExtendIntoWall[ModelCurve^ pCurve] {
    bool get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, bool value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

Only applicable when the FootPrintRoof is created with Pick Walls.

See Also

FootPrintRoof Class


Offset Property

[image]

Revit 2013 API
FootPrintRoof..::..Offset Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Offset of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property Offset ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double Offset[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

See Also

FootPrintRoof Class


Overhang Property

[image]

Revit 2013 API
FootPrintRoof..::..Overhang Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the Overhang of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property Overhang ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double Overhang[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

Only applicable when the FootPrintRoof is created with Pick Walls.

See Also

FootPrintRoof Class


Parameter Property

[image] [image]

Revit 2013 API
FootPrintRoof..::..Parameter Property
FootPrintRoof Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FootPrintRoof Class
FootPrintRoof Members


SlopeAngle Property

[image]

Revit 2013 API
FootPrintRoof..::..SlopeAngle Property
FootPrintRoof Class See Also Send Feedback
Retrieve or set the SlopeAngle of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    ModelCurve pCurve
] { get; set; }
Visual Basic
Public Property SlopeAngle ( _
    pCurve As ModelCurve _
) As Double
    Get
    Set
Visual C++
public:
property double SlopeAngle[ModelCurve^ pCurve] {
    double get (ModelCurve^ pCurve);
    void set (ModelCurve^ pCurve, double value);
}

Parameters

pCurve
Type: Autodesk.Revit.DB..::..ModelCurve

Remarks

The value is a "slope" measurement. For example, 0.5 is one unit of rise for each 2 units of run. This creates a slope of 26.57 degrees (the arctangent of 0.5).

See Also

FootPrintRoof Class


Form Class

[image]

Revit 2013 API
Form Class
Members See Also Send Feedback
An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Form : GenericForm
Visual Basic
Public Class Form _
    Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Form

See Also

Form Members


Form Members

[image] [image]

Revit 2013 API
Form Members
Form Class Methods Properties See Also Send Feedback

The Form type exposes the following members.

Methods

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
Public method | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Form Class


Form Methods

[image] [image]

Revit 2013 API
Form Methods
Form Class See Also Send Feedback

The Form type exposes the following members.

Methods

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.
Public method | AddProfile | Add a profile into the form, by a specified edge/param.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanManipulateProfile | Tell if a profile can be deleted/moved/rotated.
Public method | CanManipulateSubElement | Tell if a sub element can be deleted/moved/rotated/scaled.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConstrainProfiles | Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DeleteProfile | Delete a profile of the form.
Public method | DeleteSubElement | Delete a face/edge/curve/vertex of the form, specified by a reference.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetControlPoints | Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).
Public method | GetCurvesAndEdgesReference | Given a point, return all edges and curves that it is lying on.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPathCurveIndexByCurveReference | Given a reference to certain curve in the path, return its index.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetProfileAndCurveLoopIndexFromReference | Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoCreaseEdge | Tell if an edge is an auto-crease on a top/bottom cap face.
Public method | IsBeginningFace | Given a face, tell if it is a beginning cap face.
Public method | IsConnectingEdge | Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.
Public method | IsCurveReference | Tell if the pick is the reference to a curve of the form.
Public method | IsEdgeReference | Tell if the pick is the reference to an edge of the form.
Public method | IsEndFace | Given a face, tell if it is an end cap face.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFaceReference | Tell if the pick is the reference to a face of the form.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsProfileEdge | Tell if an edge or curve is generated from a profile.
Public method | IsReferenceOnlyProfile | Tell if the profile is made by referencing existing geometry in the Revit model.
Public method | IsSideFace | Given a face, tell if it is a side face.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsVertexReference | Tell if the pick is the reference to a vertex of the form.
Public method | MoveProfile | Move a profile of the form, specified by a reference, and an offset vector.
Public method | MoveSubElement | Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane
Public method | RotateProfile | Rotate a profile of the form, by a specified angle around a given axis.
Public method | RotateSubElement | Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.
Public method | ScaleProfile | Scale a profile of the form, by a specified origin and scale factor.
Public method | ScaleSubElement | Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Form Class


AddEdge Method

[image] [image]

Revit 2013 API
Form..::..AddEdge Method
Form Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddEdge(Reference, Reference) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.
Public method | AddEdge(Reference, XYZ) | Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.
Public method | AddEdge(Reference, Double, Reference, Double) | Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

See Also

Form Class
Form Members


AddEdge Method (Reference, Reference)

[image]

Revit 2013 API
Form..::..AddEdge Method (Reference, Reference)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddEdge(
    Reference startPointReference,
    Reference endPointReference
)
Visual Basic
Public Sub AddEdge ( _
    startPointReference As Reference, _
    endPointReference As Reference _
)
Visual C++
public:
void AddEdge(
    Reference^ startPointReference,
    Reference^ endPointReference
)

Parameters

startPointReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of start point
endPointReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of end point

See Also

Form Class
AddEdge Overload


AddEdge Method (Reference, XYZ)

[image]

Revit 2013 API
Form..::..AddEdge Method (Reference, XYZ)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on different profiles, by a specified face of the form and a point on face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddEdge(
    Reference faceReference,
    XYZ point
)
Visual Basic
Public Sub AddEdge ( _
    faceReference As Reference, _
    point As XYZ _
)
Visual C++
public:
void AddEdge(
    Reference^ faceReference,
    XYZ^ point
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face
point
Type: Autodesk.Revit.DB..::..XYZ
A point on the face, defining the position of edge to be created.

See Also

Form Class
AddEdge Overload


AddEdge Method (Reference, Double, Reference, Double)

[image]

Revit 2013 API
Form..::..AddEdge Method (Reference, Double, Reference, Double)
Form Class See Also Send Feedback
Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddEdge(
    Reference startEdgeReference,
    double startParam,
    Reference endEdgeReference,
    double endParam
)
Visual Basic
Public Sub AddEdge ( _
    startEdgeReference As Reference, _
    startParam As Double, _
    endEdgeReference As Reference, _
    endParam As Double _
)
Visual C++
public:
void AddEdge(
    Reference^ startEdgeReference,
    double startParam,
    Reference^ endEdgeReference,
    double endParam
)

Parameters

startEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of start edge
startParam
Type: System..::..Double
The param on start edge to specify the location.
endEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of end edge
endParam
Type: System..::..Double
The param on end edge to specify the location.

See Also

Form Class
AddEdge Overload


AddProfile Method

[image]

Revit 2013 API
Form..::..AddProfile Method
Form Class See Also Send Feedback
Add a profile into the form, by a specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int AddProfile(
    Reference edgeReference,
    double param
)
Visual Basic
Public Function AddProfile ( _
    edgeReference As Reference, _
    param As Double _
) As Integer
Visual C++
public:
int AddProfile(
    Reference^ edgeReference,
    double param
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of edge.
param
Type: System..::..Double
The param on edge to specify the location.

Return Value

Index of newly created profile.

See Also

Form Class


CanManipulateProfile Method

[image]

Revit 2013 API
Form..::..CanManipulateProfile Method
Form Class See Also Send Feedback
Tell if a profile can be deleted/moved/rotated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanManipulateProfile(
    int profileIndex
)
Visual Basic
Public Function CanManipulateProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool CanManipulateProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.

See Also

Form Class


CanManipulateSubElement Method

[image]

Revit 2013 API
Form..::..CanManipulateSubElement Method
Form Class See Also Send Feedback
Tell if a sub element can be deleted/moved/rotated/scaled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanManipulateSubElement(
    Reference subElementReference
)
Visual Basic
Public Function CanManipulateSubElement ( _
    subElementReference As Reference _
) As Boolean
Visual C++
public:
bool CanManipulateSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


ConstrainProfiles Method

[image]

Revit 2013 API
Form..::..ConstrainProfiles Method
Form Class See Also Send Feedback
Constrain form profiles using the specified profile as master. This is an advanced version of property "AreProfilesConstrained", allowing specify the master profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ConstrainProfiles(
    int masterProfileIndex
)
Visual Basic
Public Sub ConstrainProfiles ( _
    masterProfileIndex As Integer _
)
Visual C++
public:
void ConstrainProfiles(
    int masterProfileIndex
)

Parameters

masterProfileIndex
Type: System..::..Int32
Index to specify the profile used as master profile.

See Also

Form Class


DeleteProfile Method

[image]

Revit 2013 API
Form..::..DeleteProfile Method
Form Class See Also Send Feedback
Delete a profile of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DeleteProfile(
    int profileIndex
)
Visual Basic
Public Sub DeleteProfile ( _
    profileIndex As Integer _
)
Visual C++
public:
void DeleteProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.

See Also

Form Class


DeleteSubElement Method

[image]

Revit 2013 API
Form..::..DeleteSubElement Method
Form Class See Also Send Feedback
Delete a face/edge/curve/vertex of the form, specified by a reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DeleteSubElement(
    Reference subElementReference
)
Visual Basic
Public Sub DeleteSubElement ( _
    subElementReference As Reference _
)
Visual C++
public:
void DeleteSubElement(
    Reference^ subElementReference
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex

See Also

Form Class


GetControlPoints Method

[image]

Revit 2013 API
Form..::..GetControlPoints Method
Form Class See Also Send Feedback
Given an edge or a curve or a face, return all control points lying on it (in form of geometry references).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray GetControlPoints(
    Reference curveOrEdgeOrFaceReference
)
Visual Basic
Public Function GetControlPoints ( _
    curveOrEdgeOrFaceReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetControlPoints(
    Reference^ curveOrEdgeOrFaceReference
)

Parameters

curveOrEdgeOrFaceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of an edge or curve or face.

Return Value

Reference array containing all control points lying on it.

See Also

Form Class


GetCurvesAndEdgesReference Method

[image]

Revit 2013 API
Form..::..GetCurvesAndEdgesReference Method
Form Class See Also Send Feedback
Given a point, return all edges and curves that it is lying on.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray GetCurvesAndEdgesReference(
    Reference pointReference
)
Visual Basic
Public Function GetCurvesAndEdgesReference ( _
    pointReference As Reference _
) As ReferenceArray
Visual C++
public:
ReferenceArray^ GetCurvesAndEdgesReference(
    Reference^ pointReference
)

Parameters

pointReference
Type: Autodesk.Revit.DB..::..Reference
The reference of a point.

Return Value

Reference array containing all edges and curves that the point is lying on.

See Also

Form Class


GetPathCurveIndexByCurveReference Method

[image]

Revit 2013 API
Form..::..GetPathCurveIndexByCurveReference Method
Form Class See Also Send Feedback
Given a reference to certain curve in the path, return its index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetPathCurveIndexByCurveReference(
    Reference curveReference
)
Visual Basic
Public Function GetPathCurveIndexByCurveReference ( _
    curveReference As Reference _
) As Integer
Visual C++
public:
int GetPathCurveIndexByCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::..Reference
Reference to the curve in path

See Also

Form Class


GetProfileAndCurveLoopIndexFromReference Method

[image]

Revit 2013 API
Form..::..GetProfileAndCurveLoopIndexFromReference Method
Form Class See Also Send Feedback
Given a reference to certain curve or edge, get the index of its profile and curve loop respectively.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void GetProfileAndCurveLoopIndexFromReference(
    Reference curveOrEdgeReference,
    ref int profileIndex,
    ref int curveLoopIndex
)
Visual Basic
Public Sub GetProfileAndCurveLoopIndexFromReference ( _
    curveOrEdgeReference As Reference, _
    ByRef profileIndex As Integer, _
    ByRef curveLoopIndex As Integer _
)
Visual C++
public:
void GetProfileAndCurveLoopIndexFromReference(
    Reference^ curveOrEdgeReference,
    int% profileIndex,
    int% curveLoopIndex
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::..Reference
Reference to a curve/edge that is part of one profile
profileIndex
Type: System..::..Int32%
Profile index for output
curveLoopIndex
Type: System..::..Int32%
Curve loop index for output

See Also

Form Class


IsAutoCreaseEdge Method

[image]

Revit 2013 API
Form..::..IsAutoCreaseEdge Method
Form Class See Also Send Feedback
Tell if an edge is an auto-crease on a top/bottom cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAutoCreaseEdge(
    Reference edgeReference
)
Visual Basic
Public Function IsAutoCreaseEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsAutoCreaseEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge to be checked.

See Also

Form Class


IsBeginningFace Method

[image]

Revit 2013 API
Form..::..IsBeginningFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a beginning cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsBeginningFace(
    Reference faceReference
)
Visual Basic
Public Function IsBeginningFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsBeginningFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the face to be checked.

See Also

Form Class


IsConnectingEdge Method

[image]

Revit 2013 API
Form..::..IsConnectingEdge Method
Form Class See Also Send Feedback
Tell if an edge is a connecting edge on a side face. Connecting edges connect vertices on different profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsConnectingEdge(
    Reference edgeReference
)
Visual Basic
Public Function IsConnectingEdge ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsConnectingEdge(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge to be checked.

See Also

Form Class


IsCurveReference Method

[image]

Revit 2013 API
Form..::..IsCurveReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a curve of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCurveReference(
    Reference curveReference
)
Visual Basic
Public Function IsCurveReference ( _
    curveReference As Reference _
) As Boolean
Visual C++
public:
bool IsCurveReference(
    Reference^ curveReference
)

Parameters

curveReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


IsEdgeReference Method

[image]

Revit 2013 API
Form..::..IsEdgeReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to an edge of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEdgeReference(
    Reference edgeReference
)
Visual Basic
Public Function IsEdgeReference ( _
    edgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


IsEndFace Method

[image]

Revit 2013 API
Form..::..IsEndFace Method
Form Class See Also Send Feedback
Given a face, tell if it is an end cap face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEndFace(
    Reference faceReference
)
Visual Basic
Public Function IsEndFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsEndFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the face to be checked.

See Also

Form Class


IsFaceReference Method

[image]

Revit 2013 API
Form..::..IsFaceReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a face of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFaceReference(
    Reference faceReference
)
Visual Basic
Public Function IsFaceReference ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsFaceReference(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


IsProfileEdge Method

[image]

Revit 2013 API
Form..::..IsProfileEdge Method
Form Class See Also Send Feedback
Tell if an edge or curve is generated from a profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsProfileEdge(
    Reference curveOrEdgeReference
)
Visual Basic
Public Function IsProfileEdge ( _
    curveOrEdgeReference As Reference _
) As Boolean
Visual C++
public:
bool IsProfileEdge(
    Reference^ curveOrEdgeReference
)

Parameters

curveOrEdgeReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the edge or curve to be checked.

See Also

Form Class


IsReferenceOnlyProfile Method

[image]

Revit 2013 API
Form..::..IsReferenceOnlyProfile Method
Form Class See Also Send Feedback
Tell if the profile is made by referencing existing geometry in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReferenceOnlyProfile(
    int profileIndex
)
Visual Basic
Public Function IsReferenceOnlyProfile ( _
    profileIndex As Integer _
) As Boolean
Visual C++
public:
bool IsReferenceOnlyProfile(
    int profileIndex
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile to be checked.

See Also

Form Class


IsSideFace Method

[image]

Revit 2013 API
Form..::..IsSideFace Method
Form Class See Also Send Feedback
Given a face, tell if it is a side face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSideFace(
    Reference faceReference
)
Visual Basic
Public Function IsSideFace ( _
    faceReference As Reference _
) As Boolean
Visual C++
public:
bool IsSideFace(
    Reference^ faceReference
)

Parameters

faceReference
Type: Autodesk.Revit.DB..::..Reference
The reference of the face to be checked.

See Also

Form Class


IsVertexReference Method

[image]

Revit 2013 API
Form..::..IsVertexReference Method
Form Class See Also Send Feedback
Tell if the pick is the reference to a vertex of the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsVertexReference(
    Reference vertexReference
)
Visual Basic
Public Function IsVertexReference ( _
    vertexReference As Reference _
) As Boolean
Visual C++
public:
bool IsVertexReference(
    Reference^ vertexReference
)

Parameters

vertexReference
Type: Autodesk.Revit.DB..::..Reference
Reference to be checked.

See Also

Form Class


MoveProfile Method

[image]

Revit 2013 API
Form..::..MoveProfile Method
Form Class Example See Also Send Feedback
Move a profile of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MoveProfile(
    int profileIndex,
    XYZ offset
)
Visual Basic
Public Sub MoveProfile ( _
    profileIndex As Integer, _
    offset As XYZ _
)
Visual C++
public:
void MoveProfile(
    int profileIndex,
    XYZ^ offset
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
offset
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Examples

CopyC#
public void MoveForm(Form form)
{
    int profileCount = form.ProfileCount;
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // modify the first form only
        if (form.CanManipulateProfile(profileIndex))
        {
            XYZ offset = new XYZ(-25, 0, 0);
            form.MoveProfile(profileIndex, offset);
        }
    }
}
CopyVB.NET
Public Sub MoveForm(ByVal form As Form)
    Dim profileCount As Integer = form.ProfileCount
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' modify the first form only
        If form.CanManipulateProfile(profileIndex) Then
            Dim offset As New Autodesk.Revit.DB.XYZ(-25, 0, 0)
            form.MoveProfile(profileIndex, offset)
        End If
    End If
End Sub

See Also

Form Class


MoveSubElement Method

[image]

Revit 2013 API
Form..::..MoveSubElement Method
Form Class Example See Also Send Feedback
Move a face/edge/curve/vertex of the form, specified by a reference, and an offset vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MoveSubElement(
    Reference subElementReference,
    XYZ offset
)
Visual Basic
Public Sub MoveSubElement ( _
    subElementReference As Reference, _
    offset As XYZ _
)
Visual C++
public:
void MoveSubElement(
    Reference^ subElementReference,
    XYZ^ offset
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
offset
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Examples

CopyC#
public void MoveSubElement(Form form)
{
    if (form.ProfileCount > 0)
    {
        int profileIndex = 0;   // get first profile
        ReferenceArray ra = form.get_CurveLoopReferencesOnProfile(profileIndex, 0);
        foreach (Reference r in ra)
        {
            ReferenceArray ra2 = form.GetControlPoints(r);
            foreach (Reference r2 in ra2)
            {
                Point vertex = document.GetElement(r2).GetGeometryObjectFromReference(r2) as Point;

                XYZ offset = new XYZ(0, 15, 0);
                form.MoveSubElement(r2, offset);
                break;  // just move the first point
            }
        }
    }
}
CopyVB.NET
Public Sub MoveSubElement(ByVal form As Form)
    If form.ProfileCount > 0 Then
        Dim profileIndex As Integer = 0
        ' get first profile
        Dim ra As ReferenceArray = form.CurveLoopReferencesOnProfile(profileIndex, 0)
        For Each r As Reference In ra
            Dim ra2 As ReferenceArray = form.GetControlPoints(r)
            For Each r2 As Reference In ra2
                Dim vertex As Point = TryCast(r2.GeometryObject, Point)

                Dim offset As New Autodesk.Revit.DB.XYZ(0, 15, 0)
                form.MoveSubElement(r2, offset)
                ' just move the first point
                Exit For
            Next
        Next
    End If
End Sub

See Also

Form Class


Rehost Method

[image] [image]

Revit 2013 API
Form..::..Rehost Method
Form Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Rehost(Reference, XYZ) | Rehost Form to edge, face or curve.
Public method | Rehost(SketchPlane, XYZ) | Rehost Form to sketch plane

See Also

Form Class
Form Members


Rehost Method (Reference, XYZ)

[image]

Revit 2013 API
Form..::..Rehost Method (Reference, XYZ)
Form Class See Also Send Feedback
Rehost Form to edge, face or curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Rehost(
    Reference hostRef,
    XYZ location
)
Visual Basic
Public Sub Rehost ( _
    hostRef As Reference, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    Reference^ hostRef,
    XYZ^ location
)

Parameters

hostRef
Type: Autodesk.Revit.DB..::..Reference
The geometry reference on which to rehost the form.
location
Type: Autodesk.Revit.DB..::..XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the hostRef or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


Rehost Method (SketchPlane, XYZ)

[image]

Revit 2013 API
Form..::..Rehost Method (SketchPlane, XYZ)
Form Class See Also Send Feedback
Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Rehost(
    SketchPlane sketchPlane,
    XYZ location
)
Visual Basic
Public Sub Rehost ( _
    sketchPlane As SketchPlane, _
    location As XYZ _
)
Visual C++
public:
void Rehost(
    SketchPlane^ sketchPlane,
    XYZ^ location
)

Parameters

sketchPlane
Type: Autodesk.Revit.DB..::..SketchPlane
The sketch plane on which to rehost the form.
location
Type: Autodesk.Revit.DB..::..XYZ
The location to which to Rehost the form.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the sketchPlane or location is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when rehosting Form failed.

See Also

Form Class
Rehost Overload


RotateProfile Method

[image]

Revit 2013 API
Form..::..RotateProfile Method
Form Class See Also Send Feedback
Rotate a profile of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RotateProfile(
    int profileIndex,
    Line axis,
    double angle
)
Visual Basic
Public Sub RotateProfile ( _
    profileIndex As Integer, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateProfile(
    int profileIndex,
    Line^ axis,
    double angle
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
axis
Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class


RotateSubElement Method

[image]

Revit 2013 API
Form..::..RotateSubElement Method
Form Class See Also Send Feedback
Rotate a face/edge/curve/vertex of the form, by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RotateSubElement(
    Reference subElementReference,
    Line axis,
    double angle
)
Visual Basic
Public Sub RotateSubElement ( _
    subElementReference As Reference, _
    axis As Line, _
    angle As Double _
)
Visual C++
public:
void RotateSubElement(
    Reference^ subElementReference,
    Line^ axis,
    double angle
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
axis
Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.

See Also

Form Class


ScaleProfile Method

[image]

Revit 2013 API
Form..::..ScaleProfile Method
Form Class See Also Send Feedback
Scale a profile of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ origin
)
Visual Basic
Public Sub ScaleProfile ( _
    profileIndex As Integer, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleProfile(
    int profileIndex,
    double factor,
    XYZ^ origin
)

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile.
factor
Type: System..::..Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.

See Also

Form Class


ScaleSubElement Method

[image]

Revit 2013 API
Form..::..ScaleSubElement Method
Form Class See Also Send Feedback
Scale a face/edge/curve/vertex of the form, by a specified origin and scale factor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ScaleSubElement(
    Reference subElementReference,
    double factor,
    XYZ origin
)
Visual Basic
Public Sub ScaleSubElement ( _
    subElementReference As Reference, _
    factor As Double, _
    origin As XYZ _
)
Visual C++
public:
void ScaleSubElement(
    Reference^ subElementReference,
    double factor,
    XYZ^ origin
)

Parameters

subElementReference
Type: Autodesk.Revit.DB..::..Reference
The geometry reference of face/edge/curve/vertex
factor
Type: System..::..Double
The scale factor, it should be large than zero.
origin
Type: Autodesk.Revit.DB..::..XYZ
The origin where scale happens.

See Also

Form Class


Form Properties

[image] [image]

Revit 2013 API
Form Properties
Form Class See Also Send Feedback

The Form type exposes the following members.

Properties

 | Name | Description
Public property | AreProfilesConstrained | Get/set if the form's profiles are constrained.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Retrieve/set the base offset of the form object. It is only valid for locked form.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoopReferencesOnProfile | The curve references in certain curve loop, specified by profile index and curve loop index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasOneOrMoreReferenceProfiles | Tell if the form has any reference profile.
Public property | HasOpenGeometry | Tell if the form has an open geometry.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInXRayMode | Get/set if the form is in X-Ray mode.
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathCurveCount | The number of curves in the form path.
Public property | PathCurveReference | The curve reference in the path, specified by curve index.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileCount | The number of profiles in the form.
Public property | ProfileCurveLoopCount | The number of curve loops in certain profile, specified by profile index.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopOffset | Retrieve/set the top offset of the form object. It is only valid for locked form.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Form Class


AreProfilesConstrained Property

[image]

Revit 2013 API
Form..::..AreProfilesConstrained Property
Form Class See Also Send Feedback
Get/set if the form's profiles are constrained.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AreProfilesConstrained { get; set; }
Visual Basic
Public Property AreProfilesConstrained As Boolean
    Get
    Set
Visual C++
public:
property bool AreProfilesConstrained {
    bool get ();
    void set (bool value);
}

See Also

Form Class


BaseOffset Property

[image]

Revit 2013 API
Form..::..BaseOffset Property
Form Class See Also Send Feedback
Retrieve/set the base offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic
Public Property BaseOffset As Double
    Get
    Set
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when it fail to get/set BaseOffset.

See Also

Form Class


CurveLoopReferencesOnProfile Property

[image]

Revit 2013 API
Form..::..CurveLoopReferencesOnProfile Property
Form Class See Also Send Feedback
The curve references in certain curve loop, specified by profile index and curve loop index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray this[
    int profileIndex,
    int curveLoopIndex
] { get; }
Visual Basic
Public ReadOnly Property CurveLoopReferencesOnProfile ( _
    profileIndex As Integer, _
    curveLoopIndex As Integer _
) As ReferenceArray
    Get
Visual C++
public:
property ReferenceArray^ CurveLoopReferencesOnProfile[int profileIndex, int curveLoopIndex] {
    ReferenceArray^ get (int profileIndex, int curveLoopIndex);
}

Parameters

profileIndex
Type: System..::..Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).
curveLoopIndex
Type: System..::..Int32
Index to specify the curve loop, should be within 0 and (CurveLoopCount - 1).

See Also

Form Class


HasOneOrMoreReferenceProfiles Property

[image]

Revit 2013 API
Form..::..HasOneOrMoreReferenceProfiles Property
Form Class See Also Send Feedback
Tell if the form has any reference profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasOneOrMoreReferenceProfiles { get; }
Visual Basic
Public ReadOnly Property HasOneOrMoreReferenceProfiles As Boolean
    Get
Visual C++
public:
property bool HasOneOrMoreReferenceProfiles {
    bool get ();
}

See Also

Form Class


HasOpenGeometry Property

[image]

Revit 2013 API
Form..::..HasOpenGeometry Property
Form Class See Also Send Feedback
Tell if the form has an open geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasOpenGeometry { get; }
Visual Basic
Public ReadOnly Property HasOpenGeometry As Boolean
    Get
Visual C++
public:
property bool HasOpenGeometry {
    bool get ();
}

See Also

Form Class


IsInXRayMode Property

[image]

Revit 2013 API
Form..::..IsInXRayMode Property
Form Class See Also Send Feedback
Get/set if the form is in X-Ray mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInXRayMode { get; set; }
Visual Basic
Public Property IsInXRayMode As Boolean
    Get
    Set
Visual C++
public:
property bool IsInXRayMode {
    bool get ();
    void set (bool value);
}

See Also

Form Class


Parameter Property

[image] [image]

Revit 2013 API
Form..::..Parameter Property
Form Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Form Class
Form Members


PathCurveCount Property

[image]

Revit 2013 API
Form..::..PathCurveCount Property
Form Class See Also Send Feedback
The number of curves in the form path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int PathCurveCount { get; }
Visual Basic
Public ReadOnly Property PathCurveCount As Integer
    Get
Visual C++
public:
property int PathCurveCount {
    int get ();
}

See Also

Form Class


PathCurveReference Property

[image]

Revit 2013 API
Form..::..PathCurveReference Property
Form Class See Also Send Feedback
The curve reference in the path, specified by curve index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference this[
    int curveIndex
] { get; }
Visual Basic
Public ReadOnly Property PathCurveReference ( _
    curveIndex As Integer _
) As Reference
    Get
Visual C++
public:
property Reference^ PathCurveReference[int curveIndex] {
    Reference^ get (int curveIndex);
}

Parameters

curveIndex
Type: System..::..Int32
Index to specify the curve in path

See Also

Form Class


ProfileCount Property

[image]

Revit 2013 API
Form..::..ProfileCount Property
Form Class See Also Send Feedback
The number of profiles in the form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int ProfileCount { get; }
Visual Basic
Public ReadOnly Property ProfileCount As Integer
    Get
Visual C++
public:
property int ProfileCount {
    int get ();
}

See Also

Form Class


ProfileCurveLoopCount Property

[image]

Revit 2013 API
Form..::..ProfileCurveLoopCount Property
Form Class See Also Send Feedback
The number of curve loops in certain profile, specified by profile index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property ProfileCurveLoopCount ( _
    index As Integer _
) As Integer
    Get
Visual C++
public:
property int ProfileCurveLoopCount[int index] {
    int get (int index);
}

Parameters

index
Type: System..::..Int32
Index to specify the profile, should be within 0 and (ProfileCount - 1).

See Also

Form Class


TopOffset Property

[image]

Revit 2013 API
Form..::..TopOffset Property
Form Class See Also Send Feedback
Retrieve/set the top offset of the form object. It is only valid for locked form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TopOffset { get; set; }
Visual Basic
Public Property TopOffset As Double
    Get
    Set
Visual C++
public:
property double TopOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this is not a locked form.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the value is invalid.
Autodesk.Revit.Exceptions..::..ApplicationException | Thrown when it fail to get/set TopOffset.

See Also

Form Class


FormArray Class

[image]

Revit 2013 API
FormArray Class
Members See Also Send Feedback
An array that contains form objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FormArray : APIObject, IEnumerable
Visual Basic
Public Class FormArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FormArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FormArray

See Also

FormArray Members


FormArray Members

[image] [image]

Revit 2013 API
FormArray Members
FormArray Class Constructors Methods Properties See Also Send Feedback

The FormArray type exposes the following members.

Constructors

 | Name | Description
Public method | FormArray | Initializes a new instance of the FormArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.

See Also

FormArray Class


FormArray Constructor

[image]

Revit 2013 API
FormArray Constructor
FormArray Class See Also Send Feedback
Initializes a new instance of the FormArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FormArray()
Visual Basic
Public Sub New
Visual C++
public:
FormArray()

See Also

FormArray Class


FormArray Methods

[image] [image]

Revit 2013 API
FormArray Methods
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every form from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArray Class


Append Method

[image]

Revit 2013 API
FormArray..::..Append Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Form item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Form _
)
Visual C++
public:
virtual void Append(
    Form^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Form

See Also

FormArray Class


Clear Method

[image]

Revit 2013 API
FormArray..::..Clear Method
FormArray Class See Also Send Feedback
Removes every form from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FormArray Class


ForwardIterator Method

[image]

Revit 2013 API
FormArray..::..ForwardIterator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FormArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

FormArray Class


GetEnumerator Method

[image]

Revit 2013 API
FormArray..::..GetEnumerator Method
FormArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FormArray Class


Insert Method

[image]

Revit 2013 API
FormArray..::..Insert Method
FormArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Form item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Form, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Form^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Form
index
Type: System..::..Int32

See Also

FormArray Class


ReverseIterator Method

[image]

Revit 2013 API
FormArray..::..ReverseIterator Method
FormArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FormArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FormArrayIterator
Visual C++
public:
virtual FormArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

FormArray Class


FormArray Properties

[image] [image]

Revit 2013 API
FormArray Properties
FormArray Class See Also Send Feedback

The FormArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a form at a specified index within the array.
Public property | Size | Returns the number of forms that are in the array.

See Also

FormArray Class


IsEmpty Property

[image]

Revit 2013 API
FormArray..::..IsEmpty Property
FormArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

FormArray Class


Item Property

[image]

Revit 2013 API
FormArray..::..Item Property
FormArray Class See Also Send Feedback
Gets or sets a form at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Form this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Form
    Get
    Set
Visual C++
public:
virtual property Form^ Item[int index] {
    Form^ get (int index);
    void set (int index, Form^ value);
}

Parameters

index
Type: System..::..Int32
The index of the form to be set or retrieved.

Return Value

Returns the form at the specified index.

See Also

FormArray Class


Size Property

[image]

Revit 2013 API
FormArray..::..Size Property
FormArray Class See Also Send Feedback
Returns the number of forms that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FormArray Class


FormArrayIterator Class

[image]

Revit 2013 API
FormArrayIterator Class
Members See Also Send Feedback
An iterator to a form array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FormArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FormArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FormArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FormArrayIterator

See Also

FormArrayIterator Members


FormArrayIterator Members

[image] [image]

Revit 2013 API
FormArrayIterator Members
FormArrayIterator Class Constructors Methods Properties See Also Send Feedback

The FormArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FormArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class


FormArrayIterator Constructor

[image]

Revit 2013 API
FormArrayIterator Constructor
FormArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FormArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
FormArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FormArrayIterator Class


FormArrayIterator Methods

[image] [image]

Revit 2013 API
FormArrayIterator Methods
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
FormArrayIterator..::..MoveNext Method
FormArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FormArrayIterator Class


Reset Method

[image]

Revit 2013 API
FormArrayIterator..::..Reset Method
FormArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FormArrayIterator Class


FormArrayIterator Properties

[image] [image]

Revit 2013 API
FormArrayIterator Properties
FormArrayIterator Class See Also Send Feedback

The FormArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FormArrayIterator Class


Current Property

[image]

Revit 2013 API
FormArrayIterator..::..Current Property
FormArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FormArrayIterator Class


FormatOptions Class

[image]

Revit 2013 API
FormatOptions Class
Members See Also Send Feedback
Contains the Unit information of current user selection of Unit within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FormatOptions : APIObject
Visual Basic
Public Class FormatOptions _
    Inherits APIObject
Visual C++
public ref class FormatOptions : public APIObject

Remarks

The FormatOptions contains 5 item. Rounding and UnitSymbol properties depend on the Units property. All these three properties provided set function, but it is more rigid on input.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..FormatOptions

See Also

FormatOptions Members


FormatOptions Members

[image] [image]

Revit 2013 API
FormatOptions Members
FormatOptions Class Methods Properties See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Group | Retrieves the Group of Units Type that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieves the Name of Units Type that are currently selected.
Public property | Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Public property | Units | Retrieves the Units Type that are currently selected.
Public property | Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class


FormatOptions Methods

[image] [image]

Revit 2013 API
FormatOptions Methods
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatOptions Class


FormatOptions Properties

[image] [image]

Revit 2013 API
FormatOptions Properties
FormatOptions Class See Also Send Feedback

The FormatOptions type exposes the following members.

Properties

 | Name | Description
Public property | Group | Retrieves the Group of Units Type that are currently selected.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieves the Name of Units Type that are currently selected.
Public property | Rounding | Retrieves the Rounding/Accuracy of Units Type that are currently selected.
Public property | Units | Retrieves the Units Type that are currently selected.
Public property | Unitsymbol | Retrieves the Unit Symbol of Units Type that are currently selected.

See Also

FormatOptions Class


Group Property

[image]

Revit 2013 API
FormatOptions..::..Group Property
FormatOptions Class See Also Send Feedback
Retrieves the Group of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UnitGroup Group { get; }
Visual Basic
Public ReadOnly Property Group As UnitGroup
    Get
Visual C++
public:
property UnitGroup Group {
    UnitGroup get ();
}

Remarks

Common, Structural, etc.

See Also

FormatOptions Class


Name Property

[image]

Revit 2013 API
FormatOptions..::..Name Property
FormatOptions Class See Also Send Feedback
Retrieves the Name of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Get the Name of Units Type that are currently selected.

See Also

FormatOptions Class


Rounding Property

[image]

Revit 2013 API
FormatOptions..::..Rounding Property
FormatOptions Class See Also Send Feedback
Retrieves the Rounding/Accuracy of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Remarks

You can set a non-negative double value to Rounding property, if there is no this type in UI ComboBox, it will show us Custom value. and if you input a negative value, it will correct to 1.

See Also

FormatOptions Class


Units Property

[image]

Revit 2013 API
FormatOptions..::..Units Property
FormatOptions Class See Also Send Feedback
Retrieves the Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DisplayUnitType Units { get; set; }
Visual Basic
Public Property Units As DisplayUnitType
    Get
    Set
Visual C++
public:
property DisplayUnitType Units {
    DisplayUnitType get ();
    void set (DisplayUnitType value);
}

Remarks

The Units property returns the Units Type that were selected at the Format Options Dialog.

See Also

FormatOptions Class


Unitsymbol Property

[image]

Revit 2013 API
FormatOptions..::..Unitsymbol Property
FormatOptions Class See Also Send Feedback
Retrieves the Unit Symbol of Units Type that are currently selected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UnitSymbolType Unitsymbol { get; set; }
Visual Basic
Public Property Unitsymbol As UnitSymbolType
    Get
    Set
Visual C++
public:
property UnitSymbolType Unitsymbol {
    UnitSymbolType get ();
    void set (UnitSymbolType value);
}

Remarks

You can set or get Unit Symbol of Units Type that are currently selected. If current DisplayUnitType does NOT support Unit Symbol and you have inputted as well, it will throw an InvalidOperationException. If current DisplayUnitType support, and you set a unfit enum value, it will throw an ArgumentOutOfRangeException.

See Also

FormatOptions Class


FormatUtils Class

[image]

Revit 2013 API
FormatUtils Class
Members See Also Send Feedback
A utility class capable of applying formats to values based on properties such as units.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FormatUtils : IDisposable
Visual Basic
Public Class FormatUtils _
    Implements IDisposable
Visual C++
public ref class FormatUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FormatUtils

See Also

FormatUtils Members


FormatUtils Members

[image] [image]

Revit 2013 API
FormatUtils Members
FormatUtils Class Methods See Also Send Feedback

The FormatUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FormatUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Format | Formats a value into a user-visible string based on the default display units for a document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatUtils Class


FormatUtils Methods

[image] [image]

Revit 2013 API
FormatUtils Methods
FormatUtils Class See Also Send Feedback

The FormatUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Format | Formats a value into a user-visible string based on the default display units for a document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatUtils Class


Dispose Method

[image]

Revit 2013 API
FormatUtils..::..Dispose Method
FormatUtils Class See Also Send Feedback
Releases all resources used by the FormatUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FormatUtils Class


Format Method

[image]

Revit 2013 API
FormatUtils..::..Format Method
FormatUtils Class See Also Send Feedback
Formats a value into a user-visible string based on the default display units for a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string Format(
    Document document,
    UnitType unitType,
    double value
)
Visual Basic
Public Shared Function Format ( _
    document As Document, _
    unitType As UnitType, _
    value As Double _
) As String
Visual C++
public:
static String^ Format(
    Document^ document,
    UnitType unitType,
    double value
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
unitType
Type: Autodesk.Revit.DB..::..UnitType
The unit type for the input value.
value
Type: System..::..Double
The value to format.

Return Value

The formatted string.

Remarks

The default display units for the input unit type and document will be used. Default settings will also be used for rounding.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).

See Also

FormatUtils Class


FormUtils Class

[image]

Revit 2013 API
FormUtils Class
Members See Also Send Feedback
Define Form utility functions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FormUtils : IDisposable
Visual Basic
Public Class FormUtils _
    Implements IDisposable
Visual C++
public ref class FormUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FormUtils

See Also

FormUtils Members


FormUtils Members

[image] [image]

Revit 2013 API
FormUtils Members
FormUtils Class Methods See Also Send Feedback

The FormUtils type exposes the following members.

Methods

 | Name | Description
 | CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
Public method | Dispose | Releases all resources used by the FormUtils
 | DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
 | DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormUtils Class


FormUtils Methods

[image] [image]

Revit 2013 API
FormUtils Methods
FormUtils Class See Also Send Feedback

The FormUtils type exposes the following members.

Methods

 | Name | Description
 | CanBeDissolved | Validates that input contains one or more form elements or geom combinations containing form elements.
Public method | Dispose |
 | DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
 | DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormUtils Class


CanBeDissolved Method

[image]

Revit 2013 API
FormUtils..::..CanBeDissolved Method
FormUtils Class See Also Send Feedback
Validates that input contains one or more form elements or geom combinations containing form elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool CanBeDissolved(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic
Public Shared Function CanBeDissolved ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanBeDissolved(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document.
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of elements.

Return Value

True if inputs contain one or more form elements. Non-form element inputs are ignored. False if none of the inputs are form elements or do not contain form elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class


Dispose Method

[image]

Revit 2013 API
FormUtils..::..Dispose Method
FormUtils Class See Also Send Feedback
Releases all resources used by the FormUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FormUtils Class


DissolveForms Method

[image] [image]

Revit 2013 API
FormUtils..::..DissolveForms Method
FormUtils Class See Also Send Feedback

Overload List

Name | Description
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>)) | Dissolves a collection of form elements into their defining elements.
DissolveForms(Document, ICollection<(Of <<'(ElementId>)>>), ICollection<(Of <<'(ElementId>)>>)%) | Dissolves a collection of form elements into their defining elements.

See Also

FormUtils Class
FormUtils Members


DissolveForms Method (Document, ICollection(ElementId))

[image]

Revit 2013 API
FormUtils..::..DissolveForms Method (Document, ICollection<(Of <(<'ElementId>)>)>)
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements
)
Visual Basic
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class
DissolveForms Overload


DissolveForms Method (Document, ICollection(ElementId), ICollection(ElementId))

[image]

Revit 2013 API
FormUtils..::..DissolveForms Method (Document, ICollection<(Of <(<'ElementId>)>)>, ICollection<(Of <(<'ElementId>)>)>%)
FormUtils Class See Also Send Feedback
Dissolves a collection of form elements into their defining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> DissolveForms(
    Document ADoc,
    ICollection<ElementId> elements,
    out ICollection<ElementId> BondingPointSet
)
Visual Basic
Public Shared Function DissolveForms ( _
    ADoc As Document, _
    elements As ICollection(Of ElementId), _
    <OutAttribute> ByRef BondingPointSet As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ DissolveForms(
    Document^ ADoc,
    ICollection<ElementId^>^ elements,
    [OutAttribute] ICollection<ElementId^>^% BondingPointSet
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs of Forms and GeomCombinations that contain Forms that will be dissolved.
BondingPointSet
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%
A collection of the point element ids called "bonding points" (see below for description of "bonding points")

Return Value

A collection of curve element ids from the profiles and paths of the dissolved forms.

Remarks

Bonding points define the workplane of form profiles and paths and their curves. The bonding point represents a coordinate system with an origin (reference point) which can be manipulated to move the curves of a profile together as a unit after dissolve. Bonding points may themselves be constrained to other parts of the model or parts of the form, based on how the form was created/constructed. This is done through the reference point hosting mechanism.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The elements do not include Forms that can be dissolved.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FormUtils Class
DissolveForms Overload


Frame Class

[image]

Revit 2013 API
Frame Class
Members See Also Send Feedback
Represents a coordinate frame of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Frame : IDisposable
Visual Basic
Public Class Frame _
    Implements IDisposable
Visual C++
public ref class Frame : IDisposable

Remarks

A Frame consists of three vectors at a base point in 3D space. The vectors need not be orthogonal, have unit length, or even be linearly independent, although in practice Frames will usually have linearly independent vectors.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Frame

See Also

Frame Members


Frame Members

[image] [image]

Revit 2013 API
Frame Members
Frame Class Constructors Methods Properties See Also Send Feedback

The Frame type exposes the following members.

Constructors

 | Name | Description
Public method | Frame()()()() | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame’s base point and three basis vectors.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Frame
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Transform | Applies the input transform to this frame.

Properties

 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | Origin | The frame's base point.

See Also

Frame Class


Frame Constructor

[image] [image]

Revit 2013 API
Frame Constructor
Frame Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Frame()()()() | Default constructor. Uses global origin and standard basis vectors.
Public method | Frame(XYZ, XYZ, XYZ, XYZ) | Constructor that takes the frame’s base point and three basis vectors.

See Also

Frame Class
Frame Members


Frame Constructor

[image]

Revit 2013 API
Frame Constructor
Frame Class See Also Send Feedback
Default constructor. Uses global origin and standard basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Frame()
Visual Basic
Public Sub New
Visual C++
public:
Frame()

See Also

Frame Class
Frame Overload


Frame Constructor (XYZ, XYZ, XYZ, XYZ)

[image]

Revit 2013 API
Frame Constructor (XYZ, XYZ, XYZ, XYZ)
Frame Class See Also Send Feedback
Constructor that takes the frame’s base point and three basis vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Frame(
    XYZ origin,
    XYZ vec1,
    XYZ vec2,
    XYZ vec3
)
Visual Basic
Public Sub New ( _
    origin As XYZ, _
    vec1 As XYZ, _
    vec2 As XYZ, _
    vec3 As XYZ _
)
Visual C++
public:
Frame(
    XYZ^ origin,
    XYZ^ vec1,
    XYZ^ vec2,
    XYZ^ vec3
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The frame’s base point.
vec1
Type: Autodesk.Revit.DB..::..XYZ
The frame’s first basis vector.
vec2
Type: Autodesk.Revit.DB..::..XYZ
The frame’s second basis vector.
vec3
Type: Autodesk.Revit.DB..::..XYZ
The frame’s third basis vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Frame Class
Frame Overload


Frame Methods

[image] [image]

Revit 2013 API
Frame Methods
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsOrthogonal | Determines if this frame's basis vectors are orthogonal.
Public method | IsOrthonormal | Determines if this frame's basis vectors are orthonormal.
Public method | IsRightHanded | Determine if this frame's basis is right-handed.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Transform | Applies the input transform to this frame.

See Also

Frame Class


Dispose Method

[image]

Revit 2013 API
Frame..::..Dispose Method
Frame Class See Also Send Feedback
Releases all resources used by the Frame

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Frame Class


IsOrthogonal Method

[image]

Revit 2013 API
Frame..::..IsOrthogonal Method
Frame Class See Also Send Feedback
Determines if this frame's basis vectors are orthogonal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsOrthogonal()
Visual Basic
Public Function IsOrthogonal As Boolean
Visual C++
public:
bool IsOrthogonal()

Return Value

True if this frame's basis vectors are orthogonal, false if not.

See Also

Frame Class


IsOrthonormal Method

[image]

Revit 2013 API
Frame..::..IsOrthonormal Method
Frame Class See Also Send Feedback
Determines if this frame's basis vectors are orthonormal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsOrthonormal()
Visual Basic
Public Function IsOrthonormal As Boolean
Visual C++
public:
bool IsOrthonormal()

Return Value

True if this frame's basis vectors are orthonormal, false if not.

Remarks

"Orthonormal" means that the three vectors are orthogonal and each of them has unit length.

See Also

Frame Class


IsRightHanded Method

[image]

Revit 2013 API
Frame..::..IsRightHanded Method
Frame Class See Also Send Feedback
Determine if this frame's basis is right-handed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsRightHanded()
Visual Basic
Public Function IsRightHanded As Boolean
Visual C++
public:
bool IsRightHanded()

Return Value

True if this frame's basis is right-handed, false if not.

Remarks

The three basis vectors are "right-handed" if the triple vector product [vecX, vecY, vecZ] is positive, or equivalently if dot(vecX x vecY, vecZ) is positive, where “dot” represents the dot product.

See Also

Frame Class


Transform Method

[image]

Revit 2013 API
Frame..::..Transform Method
Frame Class See Also Send Feedback
Applies the input transform to this frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Transform(
    Transform trf
)
Visual Basic
Public Sub Transform ( _
    trf As Transform _
)
Visual C++
public:
void Transform(
    Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
The transform to apply to the frame.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | this operation failed.

See Also

Frame Class


Frame Properties

[image] [image]

Revit 2013 API
Frame Properties
Frame Class See Also Send Feedback

The Frame type exposes the following members.

Properties

 | Name | Description
Public property | BasisX | The first basis vector of the frame.
Public property | BasisY | The second basis vector of the frame.
Public property | BasisZ | The third basis vector of the frame.
Public property | Origin | The frame's base point.

See Also

Frame Class


BasisX Property

[image]

Revit 2013 API
Frame..::..BasisX Property
Frame Class See Also Send Feedback
The first basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic
Public Property BasisX As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Frame Class


BasisY Property

[image]

Revit 2013 API
Frame..::..BasisY Property
Frame Class See Also Send Feedback
The second basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic
Public Property BasisY As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Frame Class


BasisZ Property

[image]

Revit 2013 API
Frame..::..BasisZ Property
Frame Class See Also Send Feedback
The third basis vector of the frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ BasisZ { get; set; }
Visual Basic
Public Property BasisZ As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Frame Class


Origin Property

[image]

Revit 2013 API
Frame..::..Origin Property
Frame Class See Also Send Feedback
The frame's base point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Frame Class


GBXMLExportOptions Class

[image]

Revit 2013 API
GBXMLExportOptions Class
Members See Also Send Feedback
Green-Building XML Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GBXMLExportOptions
Visual Basic
Public Class GBXMLExportOptions
Visual C++
public ref class GBXMLExportOptions

Remarks

Not used currently. Reserved for future use

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GBXMLExportOptions

See Also

GBXMLExportOptions Members


GBXMLExportOptions Members

[image] [image]

Revit 2013 API
GBXMLExportOptions Members
GBXMLExportOptions Class Constructors Methods See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GBXMLExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class


GBXMLExportOptions Constructor

[image]

Revit 2013 API
GBXMLExportOptions Constructor
GBXMLExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GBXMLExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
GBXMLExportOptions()

See Also

GBXMLExportOptions Class


GBXMLExportOptions Methods

[image] [image]

Revit 2013 API
GBXMLExportOptions Methods
GBXMLExportOptions Class See Also Send Feedback

The GBXMLExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLExportOptions Class


GBXMLImportOptions Class

[image]

Revit 2013 API
GBXMLImportOptions Class
Members See Also Send Feedback
Import options for Green-Building XML format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GBXMLImportOptions
Visual Basic
Public Class GBXMLImportOptions
Visual C++
public ref class GBXMLImportOptions

Remarks

Not used currently. Reserved for future use.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GBXMLImportOptions

See Also

GBXMLImportOptions Members


GBXMLImportOptions Members

[image] [image]

Revit 2013 API
GBXMLImportOptions Members
GBXMLImportOptions Class Constructors Methods See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | GBXMLImportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GBXMLImportOptions Constructor

[image]

Revit 2013 API
GBXMLImportOptions Constructor
GBXMLImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GBXMLImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
GBXMLImportOptions()

See Also

GBXMLImportOptions Class


GBXMLImportOptions Methods

[image] [image]

Revit 2013 API
GBXMLImportOptions Methods
GBXMLImportOptions Class See Also Send Feedback

The GBXMLImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GBXMLImportOptions Class


GenericForm Class

[image]

Revit 2013 API
GenericForm Class
Members See Also Send Feedback
Provides access to the Generic Form model in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GenericForm : CombinableElement
Visual Basic
Public Class GenericForm _
    Inherits CombinableElement
Visual C++
public ref class GenericForm : public CombinableElement

Remarks

The Generic Form object can be queried for a generic form for use in family modeling and massing. It is the base class of Sweep, Blend, Extrusion, Revolution.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Blend
Autodesk.Revit.DB..::..Extrusion
Autodesk.Revit.DB..::..Form
Autodesk.Revit.DB..::..Revolution
Autodesk.Revit.DB..::..Sweep
Autodesk.Revit.DB..::..SweptBlend

See Also

GenericForm Members


GenericForm Members

[image] [image]

Revit 2013 API
GenericForm Members
GenericForm Class Methods Properties See Also Send Feedback

The GenericForm type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GenericForm Class


GenericForm Methods

[image] [image]

Revit 2013 API
GenericForm Methods
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericForm Class


GetVisibility Method

[image]

Revit 2013 API
GenericForm..::..GetVisibility Method
GenericForm Class See Also Send Feedback
Gets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the generic form.

See Also

GenericForm Class


SetVisibility Method

[image]

Revit 2013 API
GenericForm..::..SetVisibility Method
GenericForm Class See Also Send Feedback
Sets the visibility for the generic form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the generic form geometry can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

GenericForm Class


GenericForm Properties

[image] [image]

Revit 2013 API
GenericForm Properties
GenericForm Class See Also Send Feedback

The GenericForm type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GenericForm Class


IsSolid Property

[image]

Revit 2013 API
GenericForm..::..IsSolid Property
GenericForm Class See Also Send Feedback
Identifies if the GenericForm is a solid or a void element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSolid { get; }
Visual Basic
Public ReadOnly Property IsSolid As Boolean
    Get
Visual C++
public:
property bool IsSolid {
    bool get ();
}

Field Value

True if the form is a solid, false if the solid is a void element.

See Also

GenericForm Class


Name Property

[image]

Revit 2013 API
GenericForm..::..Name Property
GenericForm Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.

See Also

GenericForm Class


Parameter Property

[image] [image]

Revit 2013 API
GenericForm..::..Parameter Property
GenericForm Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GenericForm Class
GenericForm Members


Subcategory Property

[image]

Revit 2013 API
GenericForm..::..Subcategory Property
GenericForm Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic
Public Property Subcategory As Category
    Get
    Set
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

GenericForm Class


Visible Property

[image]

Revit 2013 API
GenericForm..::..Visible Property
GenericForm Class See Also Send Feedback
The visibility of the GenericForm.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Visible { get; }
Visual Basic
Public ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
property bool Visible {
    bool get ();
}

Field Value

True if the form is visible, false if it is hidden.

See Also

GenericForm Class


GenericFormSet Class

[image]

Revit 2013 API
GenericFormSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GenericFormSet : APIObject,
    IEnumerable
Visual Basic
Public Class GenericFormSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GenericFormSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GenericFormSet

See Also

GenericFormSet Members


GenericFormSet Members

[image] [image]

Revit 2013 API
GenericFormSet Members
GenericFormSet Class Constructors Methods Properties See Also Send Feedback

The GenericFormSet type exposes the following members.

Constructors

 | Name | Description
Public method | GenericFormSet | Initializes a new instance of the GenericFormSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class


GenericFormSet Constructor

[image]

Revit 2013 API
GenericFormSet Constructor
GenericFormSet Class See Also Send Feedback
Initializes a new instance of the GenericFormSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GenericFormSet()
Visual Basic
Public Sub New
Visual C++
public:
GenericFormSet()

See Also

GenericFormSet Class


GenericFormSet Methods

[image] [image]

Revit 2013 API
GenericFormSet Methods
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSet Class


Clear Method

[image]

Revit 2013 API
GenericFormSet..::..Clear Method
GenericFormSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GenericFormSet Class


Contains Method

[image]

Revit 2013 API
GenericFormSet..::..Contains Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    GenericForm item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GenericForm

See Also

GenericFormSet Class


Erase Method

[image]

Revit 2013 API
GenericFormSet..::..Erase Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    GenericForm item
)
Visual Basic
Public Overridable Function Erase ( _
    item As GenericForm _
) As Integer
Visual C++
public:
virtual int Erase(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GenericForm

See Also

GenericFormSet Class


ForwardIterator Method

[image]

Revit 2013 API
GenericFormSet..::..ForwardIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GenericFormSet Class


GetEnumerator Method

[image]

Revit 2013 API
GenericFormSet..::..GetEnumerator Method
GenericFormSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GenericFormSet Class


Insert Method

[image]

Revit 2013 API
GenericFormSet..::..Insert Method
GenericFormSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    GenericForm item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GenericForm _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GenericForm^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GenericForm

See Also

GenericFormSet Class


ReverseIterator Method

[image]

Revit 2013 API
GenericFormSet..::..ReverseIterator Method
GenericFormSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GenericFormSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GenericFormSetIterator
Visual C++
public:
virtual GenericFormSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GenericFormSet Class


GenericFormSet Properties

[image] [image]

Revit 2013 API
GenericFormSet Properties
GenericFormSet Class See Also Send Feedback

The GenericFormSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

GenericFormSet Class


IsEmpty Property

[image]

Revit 2013 API
GenericFormSet..::..IsEmpty Property
GenericFormSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GenericFormSet Class


Size Property

[image]

Revit 2013 API
GenericFormSet..::..Size Property
GenericFormSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GenericFormSet Class


GenericFormSetIterator Class

[image]

Revit 2013 API
GenericFormSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GenericFormSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GenericFormSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GenericFormSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GenericFormSetIterator

See Also

GenericFormSetIterator Members


GenericFormSetIterator Members

[image] [image]

Revit 2013 API
GenericFormSetIterator Members
GenericFormSetIterator Class Constructors Methods Properties See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GenericFormSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class


GenericFormSetIterator Constructor

[image]

Revit 2013 API
GenericFormSetIterator Constructor
GenericFormSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GenericFormSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GenericFormSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GenericFormSetIterator Class


GenericFormSetIterator Methods

[image] [image]

Revit 2013 API
GenericFormSetIterator Methods
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericFormSetIterator Class


MoveNext Method

[image]

Revit 2013 API
GenericFormSetIterator..::..MoveNext Method
GenericFormSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class


Reset Method

[image]

Revit 2013 API
GenericFormSetIterator..::..Reset Method
GenericFormSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GenericFormSetIterator Class


GenericFormSetIterator Properties

[image] [image]

Revit 2013 API
GenericFormSetIterator Properties
GenericFormSetIterator Class See Also Send Feedback

The GenericFormSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GenericFormSetIterator Class


Current Property

[image]

Revit 2013 API
GenericFormSetIterator..::..Current Property
GenericFormSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GenericFormSetIterator Class


GenericImportOptions Class

[image]

Revit 2013 API
GenericImportOptions Class
Members See Also Send Feedback
Generic Import options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GenericImportOptions
Visual Basic
Public MustInherit Class GenericImportOptions
Visual C++
public ref class GenericImportOptions abstract

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GenericImportOptions
Autodesk.Revit.DB..::..ImageImportOptions

See Also

GenericImportOptions Members


GenericImportOptions Members

[image] [image]

Revit 2013 API
GenericImportOptions Members
GenericImportOptions Class Methods Properties See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.

See Also

GenericImportOptions Class


GenericImportOptions Methods

[image] [image]

Revit 2013 API
GenericImportOptions Methods
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GenericImportOptions Class


GenericImportOptions Properties

[image] [image]

Revit 2013 API
GenericImportOptions Properties
GenericImportOptions Class See Also Send Feedback

The GenericImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted.

See Also

GenericImportOptions Class


RefPoint Property

[image]

Revit 2013 API
GenericImportOptions..::..RefPoint Property
GenericImportOptions Class See Also Send Feedback
Reference point (in Revit) to which the image is going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ RefPoint { get; set; }
Visual Basic
Public Property RefPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ RefPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

If nullNothingnullptra null reference (Nothing in Visual Basic), the image will be inserted to the Revit's origin.

See Also

GenericImportOptions Class


GeomCombination Class

[image]

Revit 2013 API
GeomCombination Class
Members See Also Send Feedback
An element created by Join and Cut operations applied to combinable elements in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeomCombination : CombinableElement
Visual Basic
Public Class GeomCombination _
    Inherits CombinableElement
Visual C++
public ref class GeomCombination : public CombinableElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GeomCombination

See Also

GeomCombination Members


GeomCombination Members

[image] [image]

Revit 2013 API
GeomCombination Members
GeomCombination Class Methods Properties See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GeomCombination Class


GeomCombination Methods

[image] [image]

Revit 2013 API
GeomCombination Methods
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombination Class


GeomCombination Properties

[image] [image]

Revit 2013 API
GeomCombination Properties
GeomCombination Class See Also Send Feedback

The GeomCombination type exposes the following members.

Properties

 | Name | Description
Public property | AllMembers | All elements that are joined in this geometry combination.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GeomCombination Class


AllMembers Property

[image]

Revit 2013 API
GeomCombination..::..AllMembers Property
GeomCombination Class See Also Send Feedback
All elements that are joined in this geometry combination.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CombinableElementArray AllMembers { get; }
Visual Basic
Public ReadOnly Property AllMembers As CombinableElementArray
    Get
Visual C++
public:
property CombinableElementArray^ AllMembers {
    CombinableElementArray^ get ();
}

Remarks

All members are generic forms, for more information, refer toGenericForm.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this geometry combination has already been deleted.

See Also

GeomCombination Class


Parameter Property

[image] [image]

Revit 2013 API
GeomCombination..::..Parameter Property
GeomCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GeomCombination Class
GeomCombination Members


GeomCombinationSet Class

[image]

Revit 2013 API
GeomCombinationSet Class
Members See Also Send Feedback
A set that contains GeomCombination objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeomCombinationSet : APIObject,
    IEnumerable
Visual Basic
Public Class GeomCombinationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeomCombinationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeomCombinationSet

See Also

GeomCombinationSet Members


GeomCombinationSet Members

[image] [image]

Revit 2013 API
GeomCombinationSet Members
GeomCombinationSet Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Constructors

 | Name | Description
Public method | GeomCombinationSet | Initializes a new instance of the GeomCombinationSet class

Methods

 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Constructor

[image]

Revit 2013 API
GeomCombinationSet Constructor
GeomCombinationSet Class See Also Send Feedback
Initializes a new instance of the GeomCombinationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeomCombinationSet()
Visual Basic
Public Sub New
Visual C++
public:
GeomCombinationSet()

See Also

GeomCombinationSet Class


GeomCombinationSet Methods

[image] [image]

Revit 2013 API
GeomCombinationSet Methods
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item GeomCombination the set, rendering it empty.
Public method | Contains | Tests for the existence of an GeomCombination within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GeomCombination from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSet Class


Clear Method

[image]

Revit 2013 API
GeomCombinationSet..::..Clear Method
GeomCombinationSet Class See Also Send Feedback
Removes every item GeomCombination the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeomCombinationSet Class


Contains Method

[image]

Revit 2013 API
GeomCombinationSet..::..Contains Method
GeomCombinationSet Class See Also Send Feedback
Tests for the existence of an GeomCombination within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    GeomCombination item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeomCombination
The element to be searched for.

Return Value

The Contains method returns True if the GeomCombination is within the set, otherwise False.

See Also

GeomCombinationSet Class


Erase Method

[image]

Revit 2013 API
GeomCombinationSet..::..Erase Method
GeomCombinationSet Class See Also Send Feedback
Removes a specified GeomCombination from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    GeomCombination item
)
Visual Basic
Public Overridable Function Erase ( _
    item As GeomCombination _
) As Integer
Visual C++
public:
virtual int Erase(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeomCombination
The GeomCombination to be erased.

Return Value

The number of GeomCombinations that were erased from the set.

See Also

GeomCombinationSet Class


ForwardIterator Method

[image]

Revit 2013 API
GeomCombinationSet..::..ForwardIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GeomCombinationSet Class


GetEnumerator Method

[image]

Revit 2013 API
GeomCombinationSet..::..GetEnumerator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GeomCombinationSet Class


Insert Method

[image]

Revit 2013 API
GeomCombinationSet..::..Insert Method
GeomCombinationSet Class See Also Send Feedback
Insert the specified element into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    GeomCombination item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GeomCombination _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GeomCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeomCombination
The GeomCombination to be inserted into the set.

Return Value

Returns whether the GeomCombination was inserted into the set.

See Also

GeomCombinationSet Class


ReverseIterator Method

[image]

Revit 2013 API
GeomCombinationSet..::..ReverseIterator Method
GeomCombinationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeomCombinationSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GeomCombinationSetIterator
Visual C++
public:
virtual GeomCombinationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GeomCombinationSet Class


GeomCombinationSet Properties

[image] [image]

Revit 2013 API
GeomCombinationSet Properties
GeomCombinationSet Class See Also Send Feedback

The GeomCombinationSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GeomCombinations that are in the set.

See Also

GeomCombinationSet Class


IsEmpty Property

[image]

Revit 2013 API
GeomCombinationSet..::..IsEmpty Property
GeomCombinationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GeomCombinationSet Class


Size Property

[image]

Revit 2013 API
GeomCombinationSet..::..Size Property
GeomCombinationSet Class See Also Send Feedback
Returns the number of GeomCombinations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeomCombinationSet Class


GeomCombinationSetIterator Class

[image]

Revit 2013 API
GeomCombinationSetIterator Class
Members See Also Send Feedback
An iterator to a GeomCombination set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GeomCombinationSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GeomCombinationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeomCombinationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeomCombinationSetIterator

See Also

GeomCombinationSetIterator Members


GeomCombinationSetIterator Members

[image] [image]

Revit 2013 API
GeomCombinationSetIterator Members
GeomCombinationSetIterator Class Constructors Methods Properties See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GeomCombinationSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Constructor

[image]

Revit 2013 API
GeomCombinationSetIterator Constructor
GeomCombinationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeomCombinationSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GeomCombinationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Methods

[image] [image]

Revit 2013 API
GeomCombinationSetIterator Methods
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeomCombinationSetIterator Class


MoveNext Method

[image]

Revit 2013 API
GeomCombinationSetIterator..::..MoveNext Method
GeomCombinationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


Reset Method

[image]

Revit 2013 API
GeomCombinationSetIterator..::..Reset Method
GeomCombinationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeomCombinationSetIterator Class


GeomCombinationSetIterator Properties

[image] [image]

Revit 2013 API
GeomCombinationSetIterator Properties
GeomCombinationSetIterator Class See Also Send Feedback

The GeomCombinationSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeomCombinationSetIterator Class


Current Property

[image]

Revit 2013 API
GeomCombinationSetIterator..::..Current Property
GeomCombinationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeomCombinationSetIterator Class


GeometryCreationUtilities Class

[image]

Revit 2013 API
GeometryCreationUtilities Class
Members See Also Send Feedback
A utility that allows construction of basic solid shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class GeometryCreationUtilities : IDisposable
Visual Basic
Public Class GeometryCreationUtilities _
    Implements IDisposable
Visual C++
public ref class GeometryCreationUtilities : IDisposable

Remarks

The shapes created by these utilities are not a part of any Revit document, but can be used in conjunction with other geometric utilities from within API applications.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GeometryCreationUtilities

See Also

GeometryCreationUtilities Members


GeometryCreationUtilities Members

[image] [image]

Revit 2013 API
GeometryCreationUtilities Members
GeometryCreationUtilities Class Methods See Also Send Feedback

The GeometryCreationUtilities type exposes the following members.

Methods

 | Name | Description
 | CreateBlendGeometry | Creates a solid by blending two closed curve loops lying in non-coincident planes.
 | CreateExtrusionGeometry | Creates a solid by linearly extruding one or more closed coplanar curve loops.
 | CreateRevolvedGeometry | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
 | CreateSweptBlendGeometry | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
 | CreateSweptGeometry | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Public method | Dispose | Releases all resources used by the GeometryCreationUtilities
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryCreationUtilities Class


GeometryCreationUtilities Methods

[image] [image]

Revit 2013 API
GeometryCreationUtilities Methods
GeometryCreationUtilities Class See Also Send Feedback

The GeometryCreationUtilities type exposes the following members.

Methods

 | Name | Description
 | CreateBlendGeometry | Creates a solid by blending two closed curve loops lying in non-coincident planes.
 | CreateExtrusionGeometry | Creates a solid by linearly extruding one or more closed coplanar curve loops.
 | CreateRevolvedGeometry | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.
 | CreateSweptBlendGeometry | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.
 | CreateSweptGeometry | Creates a solid by sweeping one or more closed coplanar curve loops along a path.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryCreationUtilities Class


CreateBlendGeometry Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..CreateBlendGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by blending two closed curve loops lying in non-coincident planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateBlendGeometry(
    CurveLoop firstLoop,
    CurveLoop secondLoop,
    ICollection<VertexPair> vertexPairs
)
Visual Basic
Public Shared Function CreateBlendGeometry ( _
    firstLoop As CurveLoop, _
    secondLoop As CurveLoop, _
    vertexPairs As ICollection(Of VertexPair) _
) As Solid
Visual C++
public:
static Solid^ CreateBlendGeometry(
    CurveLoop^ firstLoop,
    CurveLoop^ secondLoop,
    ICollection<VertexPair^>^ vertexPairs
)

Parameters

firstLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The first curve loop. The loop must be a closed planar loop without intersections or degeneracies. No orientation conditions are imposed.
secondLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The second curve loop, which also must be a closed planar loop without intersections or degeneracies. The planes of the first and second loops must not be coincident, but they need not be parallel.
vertexPairs
Type: System.Collections.Generic..::..ICollection<(Of <(<'VertexPair>)>)>
This input specifies how the two profile loops should be connected. If null, the function chooses vertex connections that will result in a geometrically reasonable blend.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The first profile CurveLoop do not satisfy the input requirements. -or- The second profile CurveLoop do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class


CreateExtrusionGeometry Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..CreateExtrusionGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by linearly extruding one or more closed coplanar curve loops.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateExtrusionGeometry(
    IList<CurveLoop> profileLoops,
    XYZ extrusionDir,
    double extrusionDist
)
Visual Basic
Public Shared Function CreateExtrusionGeometry ( _
    profileLoops As IList(Of CurveLoop), _
    extrusionDir As XYZ, _
    extrusionDist As Double _
) As Solid
Visual C++
public:
static Solid^ CreateExtrusionGeometry(
    IList<CurveLoop^>^ profileLoops,
    XYZ^ extrusionDir,
    double extrusionDist
)

Parameters

profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The profile loops to be extruded. The loops must be closed, coplanar, and without intersections, self-intersections, or degeneracies. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit’s orientation conventions.
extrusionDir
Type: Autodesk.Revit.DB..::..XYZ
The direction in which to extrude the profile loops. This vector must be non-zero and transverse (i.e., not parallel) to the plane of the profile loops. Its length is irrelevant; only its direction is used.
extrusionDist
Type: System..::..Double
The positive distance by which the loops are to be extruded in the direction of the input extrusionDir.

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The profile CurveLoops do not satisfy the input requirements. -or- The Input extrusionDir must be a non-zero vector. The normal of the loop plane should not be perpendicular to the given extrusionDir. -or- The input argument extrusionDist must be positive.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class


CreateRevolvedGeometry Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..CreateRevolvedGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateRevolvedGeometry(
    Frame coordinateFrame,
    IList<CurveLoop> profileLoops,
    double startAngle,
    double endAngle
)
Visual Basic
Public Shared Function CreateRevolvedGeometry ( _
    coordinateFrame As Frame, _
    profileLoops As IList(Of CurveLoop), _
    startAngle As Double, _
    endAngle As Double _
) As Solid
Visual C++
public:
static Solid^ CreateRevolvedGeometry(
    Frame^ coordinateFrame,
    IList<CurveLoop^>^ profileLoops,
    double startAngle,
    double endAngle
)

Parameters

coordinateFrame
Type: Autodesk.Revit.DB..::..Frame
A right-handed orthonormal frame of vectors. The frame’s z-vector is the axis of revolution. The start and end angle inputs refer to this frame.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The profile loops to be revolved. No conditions are imposed on the orientations of the loops. This function will use copies of the input loops that have been oriented as necessary to conform to Revit’s orientation conventions. Restrictions:
  • - The loops must lie in the xz coordinate plane of the input coordinate frame.
  • - The curve loop(s) must be closed and must define a single planar domain (one outer loop and, optionally, one or more inner loops).
  • - The curve loops must be without intersections, self-intersections, or degeneracies.
  • - The loops must lie on the "right" side of the z axis (where x >= 0).
startAngle
Type: System..::..Double
The start angle for the revolution, in radians, measured counter-clockwise from the coordinate frame’s x-axis as viewed looking down the frame’s z-axis.
endAngle
Type: System..::..Double
The end angle for the revolution, using the same conventions as the start angle. The end angle may be less than (but not equal to) the start angle. The total angle of revolution, equal to the absolute value of (endAngle – startAngle), must be at most 2*PI.

Return Value

The requested solid. Note that if less than a full revolution is used, planar end faces will be added as part of the solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument coordinateFrame should be a right-handed orthonormal frame of vectors. -or- The profile CurveLoops do not satisfy the input requirements. -or- The absolute value of %(endAngle – startAngle)%, must be at most 2*PI.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class


CreateSweptBlendGeometry Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..CreateSweptBlendGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateSweptBlendGeometry(
    Curve pathCurve,
    IList<double> pathParams,
    IList<CurveLoop> profileLoops,
    IList<ICollection<VertexPair>> vertexPairs
)
Visual Basic
Public Shared Function CreateSweptBlendGeometry ( _
    pathCurve As Curve, _
    pathParams As IList(Of Double), _
    profileLoops As IList(Of CurveLoop), _
    vertexPairs As IList(Of ICollection(Of VertexPair)) _
) As Solid
Visual C++
public:
static Solid^ CreateSweptBlendGeometry(
    Curve^ pathCurve,
    IList<double>^ pathParams,
    IList<CurveLoop^>^ profileLoops,
    IList<ICollection<VertexPair^>^>^ vertexPairs
)

Parameters

pathCurve
Type: Autodesk.Revit.DB..::..Curve
The sweep path, consisting of a single bounded, open curve.
pathParams
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
An increasing sequence of parameters along the path curve (lying within the curve’s bounds). These parameters specify the locations of the planes orthogonal to the path that contain the profile loops. This array must have the same size as the input array "profileLoops".
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
Closed, planar curve loops arrayed along the path. The solid will have these profiles as cross-sections at the points specified by the input pathParams. The solid will blend smoothly between the profiles. This array must have the same size as the input array “pathParams”, and each profile loop must lie in the plane orthogonal to the path at the point specified by the corresponding entry in the input array “pathParams”. Each profile loop must define a single planar domain and must be free of intersections and degeneracies. No orientation conditions on the loops are imposed.
vertexPairs
Type: System.Collections.Generic..::..IList<(Of <(<'ICollection<(Of <(<'VertexPair>)>)>>)>)>
This input specifies how adjacent profile loops should be connected. It must contain one less element than the "profileLoops" input, and entry vertexPairs[idx] specifies how profileLoops[idx] and profileLoops[idx+1] should be connected (indexing starts at 0).

Return Value

The requested solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input pathCurve is a helical curve and is not supported for this operation. -or- The input argument pathCurve should be bounded. The input argument pathCurve should be non-degenerate. -or- The input argument pathParams should be an increasing array. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class


CreateSweptGeometry Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..CreateSweptGeometry Method
GeometryCreationUtilities Class See Also Send Feedback
Creates a solid by sweeping one or more closed coplanar curve loops along a path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Solid CreateSweptGeometry(
    CurveLoop sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop> profileLoops
)
Visual Basic
Public Shared Function CreateSweptGeometry ( _
    sweepPath As CurveLoop, _
    pathAttachmentCrvIdx As Integer, _
    pathAttachmentParam As Double, _
    profileLoops As IList(Of CurveLoop) _
) As Solid
Visual C++
public:
static Solid^ CreateSweptGeometry(
    CurveLoop^ sweepPath,
    int pathAttachmentCrvIdx,
    double pathAttachmentParam,
    IList<CurveLoop^>^ profileLoops
)

Parameters

sweepPath
Type: Autodesk.Revit.DB..::..CurveLoop
The sweep path, consisting of a set of contiguous curves. The path may be open or closed, but should not otherwise have any self-intersections. The path may be planar or non-planar.
pathAttachmentCrvIdx
Type: System..::..Int32
The index of the curve in the sweep path where the profile loops are situated. Indexing starts at 0. Together with pathAttachmentParam, this specifies the profile’s attachment point.
pathAttachmentParam
Type: System..::..Double
Parameter of the path curve specified by pathAttachmentCrvIdx. The profile curves must lie in the plane orthogonal to the path at this attachment point.
profileLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The curve loops defining the planar domain to be swept along the path. No conditions are imposed on the orientations of the loops: this function will use copies of the input loops that have been oriented as necessary to conform to Revit’s orientation conventions. Restrictions:
  • - The loops must lie in the plane orthogonal to the path at the attachment point as defined above.
  • - The curve loop(s) must be closed and should define a single planar domain (one outer loop and, optionally, one or more inner loops)
  • - The curve loops must be without intersections, self-intersections, or degeneracies.

Return Value

The requested solid.

Remarks

The profile loops must lie in a plane orthogonal to the sweep path at some attachment point along the path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input argument sweepPath should at least contain one curve. -or- The input argument pathAttachmentCrvIdx is not valid. The given attachment point doesn't lie in the plane of the Curve Loop. -or- The profile CurveLoops do not satisfy the input requirements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

GeometryCreationUtilities Class


Dispose Method

[image]

Revit 2013 API
GeometryCreationUtilities..::..Dispose Method
GeometryCreationUtilities Class See Also Send Feedback
Releases all resources used by the GeometryCreationUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

GeometryCreationUtilities Class


GeometryElement Class

[image]

Revit 2013 API
GeometryElement Class
Members See Also Send Feedback
Geometric representation of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeometryElement : GeometryObject,
    IEnumerable<GeometryObject>
Visual Basic
Public Class GeometryElement _
    Inherits GeometryObject _
    Implements IEnumerable(Of GeometryObject)
Visual C++
public ref class GeometryElement : public GeometryObject,
    IEnumerable<GeometryObject^>

Remarks

This class contains geometric primitives that are generated from the parametric description of the element. The member geometric primitives can be obtained directly from this object using the capabilities of IEnumerable.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryElement

See Also

GeometryElement Members


GeometryElement Members

[image] [image]

Revit 2013 API
GeometryElement Members
GeometryElement Class Methods Properties See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Objects | Obsolete. All geometric primitives contained in the element.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


GeometryElement Methods

[image] [image]

Revit 2013 API
GeometryElement Methods
GeometryElement Class See Also Send Feedback

The GeometryElement type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetBoundingBox | Retrieves a box that encloses the geometry element.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Protected method | GetEnumeratorNG | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetTransformed | Returns a transformed copy of the geometry in this element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryElement Class


GetBoundingBox Method

[image]

Revit 2013 API
GeometryElement..::..GetBoundingBox Method
GeometryElement Class See Also Send Feedback
Retrieves a box that encloses the geometry element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BoundingBoxXYZ GetBoundingBox()
Visual Basic
Public Function GetBoundingBox As BoundingBoxXYZ
Visual C++
public:
BoundingBoxXYZ^ GetBoundingBox()

Return Value

The bounding box.

See Also

GeometryElement Class


GetEnumerator Method

[image]

Revit 2013 API
GeometryElement..::..GetEnumerator Method
GeometryElement Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<GeometryObject> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of GeometryObject)
Visual C++
public:
virtual IEnumerator<GeometryObject^>^ GetEnumerator()

Return Value

An IEnumerator(GeometryObject) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

GeometryElement Class


GetEnumeratorNG Method

[image]

Revit 2013 API
GeometryElement..::..GetEnumeratorNG Method
GeometryElement Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal IEnumerator GetEnumeratorNG()
Visual Basic
Friend Function GetEnumeratorNG As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetEnumeratorNG() sealed

Return Value

An IEnumerator(GeometryObject) object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GeometryElement Class


GetTransformed Method

[image]

Revit 2013 API
GeometryElement..::..GetTransformed Method
GeometryElement Class See Also Send Feedback
Returns a transformed copy of the geometry in this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetTransformed(
    Transform transform
)
Visual Basic
Public Function GetTransformed ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetTransformed(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal

See Also

GeometryElement Class


GeometryElement Properties

[image] [image]

Revit 2013 API
GeometryElement Properties
GeometryElement Class See Also Send Feedback

The GeometryElement type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElement | Element describing the material from which this element is composed.
Public property | Objects | Obsolete. All geometric primitives contained in the element.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryElement Class


MaterialElement Property

[image]

Revit 2013 API
GeometryElement..::..MaterialElement Property
GeometryElement Class See Also Send Feedback
Element describing the material from which this element is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Material MaterialElement { get; }
Visual Basic
Public ReadOnly Property MaterialElement As Material
    Get
Visual C++
public:
property Material^ MaterialElement {
    Material^ get ();
}

See Also

GeometryElement Class


Objects Property

[image]

Revit 2013 API
GeometryElement..::..Objects Property
GeometryElement Class See Also Send Feedback
All geometric primitives contained in the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property will be obsolete from 2013; Call GetEnumerator() instead.")]
public GeometryObjectArray Objects { get; }
Visual Basic
<ObsoleteAttribute("This property will be obsolete from 2013; Call GetEnumerator() instead.")> _
Public ReadOnly Property Objects As GeometryObjectArray
    Get
Visual C++
[ObsoleteAttribute(L"This property will be obsolete from 2013; Call GetEnumerator() instead.")]
public:
property GeometryObjectArray^ Objects {
    GeometryObjectArray^ get ();
}

Remarks

Branching on dynamic type of the objects is advised. Faces and edges are contained in solids and never directly in an element.

See Also

GeometryElement Class


GeometryInstance Class

[image]

Revit 2013 API
GeometryInstance Class
Members See Also Send Feedback
An instance of another element (symbol), specially positioned by this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeometryInstance : GeometryObject
Visual Basic
Public Class GeometryInstance _
    Inherits GeometryObject
Visual C++
public ref class GeometryInstance : public GeometryObject

Remarks

A GeometryInstance represents a set of geometry stored by Revit in a default configuration, and then transformed into the proper location as a result of the properties of the element. The most common situation where GeometryInstances are encountered is in Family instances. Revit uses GeometryInstances to allow it to store a single copy of the geometry for a given family and reuse it in multiple instances. Note that not all Family instances will include GeometryInstances. When Revit needs to make a unique copy of the family geometry for a given instance (because of the effect of local joins, intersections, and other factors related to the instance placement) no GeometryInstance will be encountered; instead the Solid geometry will be found at the top level of the hierarchy. A GeometryInstance offers the ability to read its geometry through the GetSymbolGeometry() and GetInstanceGeometry() methods. These methods return another Autodesk.Revit.DB.GeometryElement which can be parsed just like the first level return.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..GeometryInstance

See Also

GeometryInstance Members


GeometryInstance Members

[image] [image]

Revit 2013 API
GeometryInstance Members
GeometryInstance Class Methods Properties See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


GeometryInstance Methods

[image] [image]

Revit 2013 API
GeometryInstance Methods
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryInstance Class


GetInstanceGeometry Method

[image] [image]

Revit 2013 API
GeometryInstance..::..GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetInstanceGeometry()()()() | Computes the geometric representation of the instance.
Public method | GetInstanceGeometry(Transform) | Computes a transformation of the geometric representation of the instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetInstanceGeometry Method

[image]

Revit 2013 API
GeometryInstance..::..GetInstanceGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetInstanceGeometry()
Visual Basic
Public Function GetInstanceGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry()

Return Value

An element which contains the computed geometry for the instance.

Remarks

The geometry will be in the coordinate system of the model that owns this instance. The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.

See Also

GeometryInstance Class
GetInstanceGeometry Overload


GetInstanceGeometry Method (Transform)

[image]

Revit 2013 API
GeometryInstance..::..GetInstanceGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetInstanceGeometry(
    Transform transform
)
Visual Basic
Public Function GetInstanceGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetInstanceGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed instance.

Remarks

The context of the instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal

See Also

GeometryInstance Class
GetInstanceGeometry Overload


GetSymbolGeometry Method

[image] [image]

Revit 2013 API
GeometryInstance..::..GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetSymbolGeometry()()()() | Computes the geometric representation of the symbol which generates this instance.
Public method | GetSymbolGeometry(Transform) | Computes a transformation of the geometric representation of the symbol which generates this instance.

See Also

GeometryInstance Class
GeometryInstance Members


GetSymbolGeometry Method

[image]

Revit 2013 API
GeometryInstance..::..GetSymbolGeometry Method
GeometryInstance Class See Also Send Feedback
Computes the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetSymbolGeometry()
Visual Basic
Public Function GetSymbolGeometry As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry()

Return Value

An element which contains the computed geometry for the symbol.

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The results of the method and the value of the SymbolGeometry property are identical. This method returns the actual Revit geometry. Unlike other methods which extract transformed copies of the geometry, the return value of this method is suitable for creating new Revit elements referencing the original element (for example, dimensioning).

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GetSymbolGeometry Method (Transform)

[image]

Revit 2013 API
GeometryInstance..::..GetSymbolGeometry Method (Transform)
GeometryInstance Class See Also Send Feedback
Computes a transformation of the geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement GetSymbolGeometry(
    Transform transform
)
Visual Basic
Public Function GetSymbolGeometry ( _
    transform As Transform _
) As GeometryElement
Visual C++
public:
GeometryElement^ GetSymbolGeometry(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation to apply to the geometry.

Return Value

An element which contains the computed geometry for the transformed symbol.

Remarks

The context of this instance object (such as effective material) will be applied to the symbol. Note that this method involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. This method returns a copy of the Revit geometry. It is suitable for use in a tool which extracts geometry to another format or carries out a geometric analysis; however, because it returns a copy the references found in the geometry objects contained in this element are not suitable for creating new Revit elements referencing the original element (for example, dimensioning). Only the geometry returned by GetSymbolGeometry() with no transform can be used for that purpose.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Transform is not conformal

See Also

GeometryInstance Class
GetSymbolGeometry Overload


GeometryInstance Properties

[image] [image]

Revit 2013 API
GeometryInstance Properties
GeometryInstance Class See Also Send Feedback

The GeometryInstance type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Symbol | The symbol element that this object is referring to.
Public property | SymbolGeometry | The geometric representation of the symbol which generates this instance.
Public property | Transform | The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

GeometryInstance Class


Symbol Property

[image]

Revit 2013 API
GeometryInstance..::..Symbol Property
GeometryInstance Class See Also Send Feedback
The symbol element that this object is referring to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Symbol { get; }
Visual Basic
Public ReadOnly Property Symbol As Element
    Get
Visual C++
public:
property Element^ Symbol {
    Element^ get ();
}

See Also

GeometryInstance Class


SymbolGeometry Property

[image]

Revit 2013 API
GeometryInstance..::..SymbolGeometry Property
GeometryInstance Class See Also Send Feedback
The geometric representation of the symbol which generates this instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement SymbolGeometry { get; }
Visual Basic
Public ReadOnly Property SymbolGeometry As GeometryElement
    Get
Visual C++
public:
property GeometryElement^ SymbolGeometry {
    GeometryElement^ get ();
}

Remarks

The geometry will be in the local coordinate space of the symbol. The context of this instance object (such as effective material) will be applied to the symbol. Note that retrieving the value of this property involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical. Geometry will be parsed with the same options as those used when this object was retrieved. The value of this property and the results of the method GetSymbolGeometry(void) are identical.

See Also

GeometryInstance Class


Transform Property

[image]

Revit 2013 API
GeometryInstance..::..Transform Property
GeometryInstance Class See Also Send Feedback
The affine transformation from the local coordinate space of the symbol into the coordinate space of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic
Public ReadOnly Property Transform As Transform
    Get
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

See Also

GeometryInstance Class


GeometryObject Class

[image]

Revit 2013 API
GeometryObject Class
Members See Also Send Feedback
The common base class for all geometric primitives.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeometryObject : APIObject
Visual Basic
Public Class GeometryObject _
    Inherits APIObject
Visual C++
public ref class GeometryObject : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Edge
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..GeometryElement
Autodesk.Revit.DB..::..GeometryInstance
Autodesk.Revit.DB..::..Mesh
Autodesk.Revit.DB..::..Point
Autodesk.Revit.DB..::..PolyLine
Autodesk.Revit.DB..::..Profile
Autodesk.Revit.DB..::..Solid

See Also

GeometryObject Members


GeometryObject Members

[image] [image]

Revit 2013 API
GeometryObject Members
GeometryObject Class Methods Operators Properties See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two GeometryObjects are the same.
Inequality | Determines whether two GeometryObjects are different.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Visibility | The visibility.

See Also

GeometryObject Class


GeometryObject Methods

[image] [image]

Revit 2013 API
GeometryObject Methods
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObject Class


Equals Method

[image]

Revit 2013 API
GeometryObject..::..Equals Method
GeometryObject Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


GetHashCode Method

[image]

Revit 2013 API
GeometryObject..::..GetHashCode Method
GeometryObject Class See Also Send Feedback
Gets the integer value of the geometry object as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

GeometryObject Class


GeometryObject Operators

[image] [image]

Revit 2013 API
GeometryObject Operators
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Operators

Name | Description
Equality | Determines whether two GeometryObjects are the same.
Inequality | Determines whether two GeometryObjects are different.

See Also

GeometryObject Class


Equality Operator

[image]

Revit 2013 API
GeometryObject..::..Equality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator = ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator ==(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are the same; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


Inequality Operator

[image]

Revit 2013 API
GeometryObject..::..Inequality Operator
GeometryObject Class See Also Send Feedback
Determines whether two GeometryObjects are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    GeometryObject first,
    GeometryObject second
)
Visual Basic
Public Shared Operator <> ( _
    first As GeometryObject, _
    second As GeometryObject _
) As Boolean
Visual C++
public:
static bool operator !=(
    GeometryObject^ first,
    GeometryObject^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..GeometryObject
The first GeometryObject.
second
Type: Autodesk.Revit.DB..::..GeometryObject
The second GeometryObject.

Return Value

True if the GeometryObjects are different; otherwise, false.

Remarks

This compares the internal identifiers of the geometry, and doesn't compare them geometrically.

See Also

GeometryObject Class


GeometryObject Properties

[image] [image]

Revit 2013 API
GeometryObject Properties
GeometryObject Class See Also Send Feedback

The GeometryObject type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Visibility | The visibility.

See Also

GeometryObject Class


GraphicsStyleId Property

[image]

Revit 2013 API
GeometryObject..::..GraphicsStyleId Property
GeometryObject Class Example See Also Send Feedback
The ElementId of the GeometryObject's GraphicsStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GraphicsStyleId { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleId As ElementId
    Get
Visual C++
public:
property ElementId^ GraphicsStyleId {
    ElementId^ get ();
}

Remarks

This property provides the id of the GraphicsStyle assigned to the GeometryObject. This can be used to find the category of the object.

Examples

CopyC#
// find the name of the GraphicsSytleCategory for every geometric primitive in a family instance
        Options options = app.Create.NewGeometryOptions();
        GeometryElement geomElem = element.get_Geometry(options);
        foreach (GeometryObject geomObj in geomElem.Objects)
        {
            GeometryInstance geomInst = geomObj as GeometryInstance;
            if (geomInst != null)
            {
                foreach (Object obj in geomInst.SymbolGeometry.Objects)
                {
                    GeometryObject geomObject = obj as GeometryObject;
                    GraphicsStyle gStyle = doc.GetElement(geomObject.GraphicsStyleId) as GraphicsStyle;
                    if (gStyle != null)
                    {
                        string gstyleName = gStyle.GraphicsStyleCategory.Name;
                    }
                }
            }
        }

See Also

GeometryObject Class


IsElementGeometry Property

[image]

Revit 2013 API
GeometryObject..::..IsElementGeometry Property
GeometryObject Class See Also Send Feedback
Indicates whether this geometry is obtained directly from an Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsElementGeometry { get; }
Visual Basic
Public ReadOnly Property IsElementGeometry As Boolean
    Get
Visual C++
public:
property bool IsElementGeometry {
    bool get ();
}

See Also

GeometryObject Class


Visibility Property

[image]

Revit 2013 API
GeometryObject..::..Visibility Property
GeometryObject Class See Also Send Feedback
The visibility.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Visibility Visibility { get; }
Visual Basic
Public ReadOnly Property Visibility As Visibility
    Get
Visual C++
public:
property Visibility Visibility {
    Visibility get ();
}

Remarks

The visibility of this object has no effect on the visibility of objects contained within this object. For example, the visibility of a Solid may be Contextual but the faces within that solid may still be Visible.

See Also

GeometryObject Class


GeometryObjectArray Class

[image]

Revit 2013 API
GeometryObjectArray Class
Members See Also Send Feedback
An array that contains geometry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GeometryObjectArray : APIObject,
    IEnumerable
Visual Basic
Public Class GeometryObjectArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GeometryObjectArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObjectArray

See Also

GeometryObjectArray Members


GeometryObjectArray Members

[image] [image]

Revit 2013 API
GeometryObjectArray Members
GeometryObjectArray Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Constructors

 | Name | Description
Public method | GeometryObjectArray | Initializes a new instance of the GeometryObjectArray class

Methods

 | Name | Description
Public method | Append | Add the geometry object to the end of the array.
Public method | Clear | Removes every geometry object from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified geometry object into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a geometry object at a specified index within the array.
Public property | Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class


GeometryObjectArray Constructor

[image]

Revit 2013 API
GeometryObjectArray Constructor
GeometryObjectArray Class See Also Send Feedback
Initializes a new instance of the GeometryObjectArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryObjectArray()
Visual Basic
Public Sub New
Visual C++
public:
GeometryObjectArray()

See Also

GeometryObjectArray Class


GeometryObjectArray Methods

[image] [image]

Revit 2013 API
GeometryObjectArray Methods
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the geometry object to the end of the array.
Public method | Clear | Removes every geometry object from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified geometry object into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArray Class


Append Method

[image]

Revit 2013 API
GeometryObjectArray..::..Append Method
GeometryObjectArray Class See Also Send Feedback
Add the geometry object to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    GeometryObject item
)
Visual Basic
Public Overridable Sub Append ( _
    item As GeometryObject _
)
Visual C++
public:
virtual void Append(
    GeometryObject^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object to be added.

See Also

GeometryObjectArray Class


Clear Method

[image]

Revit 2013 API
GeometryObjectArray..::..Clear Method
GeometryObjectArray Class See Also Send Feedback
Removes every geometry object from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GeometryObjectArray Class


ForwardIterator Method

[image]

Revit 2013 API
GeometryObjectArray..::..ForwardIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

GeometryObjectArray Class


GetEnumerator Method

[image]

Revit 2013 API
GeometryObjectArray..::..GetEnumerator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GeometryObjectArray Class


Insert Method

[image]

Revit 2013 API
GeometryObjectArray..::..Insert Method
GeometryObjectArray Class See Also Send Feedback
Insert the specified geometry object into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryObject item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As GeometryObject, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryObject^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object to be inserted into the array.
index
Type: System..::..Int32
The geometry object will be inserted before this index.

Return Value

Returns whether the geometry object was inserted into the array.

See Also

GeometryObjectArray Class


ReverseIterator Method

[image]

Revit 2013 API
GeometryObjectArray..::..ReverseIterator Method
GeometryObjectArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeometryObjectArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GeometryObjectArrayIterator
Visual C++
public:
virtual GeometryObjectArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

GeometryObjectArray Class


GeometryObjectArray Properties

[image] [image]

Revit 2013 API
GeometryObjectArray Properties
GeometryObjectArray Class See Also Send Feedback

The GeometryObjectArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a geometry object at a specified index within the array.
Public property | Size | Returns the number of geometry objects that are in the array.

See Also

GeometryObjectArray Class


IsEmpty Property

[image]

Revit 2013 API
GeometryObjectArray..::..IsEmpty Property
GeometryObjectArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

GeometryObjectArray Class


Item Property

[image]

Revit 2013 API
GeometryObjectArray..::..Item Property
GeometryObjectArray Class See Also Send Feedback
Gets or sets a geometry object at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeometryObject this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As GeometryObject
    Get
    Set
Visual C++
public:
virtual property GeometryObject^ Item[int index] {
    GeometryObject^ get (int index);
    void set (int index, GeometryObject^ value);
}

Parameters

index
Type: System..::..Int32
The index of the geometry object to be set or retrieved.

Return Value

Returns the geometry object at the specified index.

See Also

GeometryObjectArray Class


Size Property

[image]

Revit 2013 API
GeometryObjectArray..::..Size Property
GeometryObjectArray Class See Also Send Feedback
Returns the number of geometry objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GeometryObjectArray Class


GeometryObjectArrayIterator Class

[image]

Revit 2013 API
GeometryObjectArrayIterator Class
Members See Also Send Feedback
An iterator to a geometry object array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GeometryObjectArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GeometryObjectArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GeometryObjectArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObjectArrayIterator

See Also

GeometryObjectArrayIterator Members


GeometryObjectArrayIterator Members

[image] [image]

Revit 2013 API
GeometryObjectArrayIterator Members
GeometryObjectArrayIterator Class Constructors Methods Properties See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GeometryObjectArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Constructor

[image]

Revit 2013 API
GeometryObjectArrayIterator Constructor
GeometryObjectArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryObjectArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
GeometryObjectArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Methods

[image] [image]

Revit 2013 API
GeometryObjectArrayIterator Methods
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GeometryObjectArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
GeometryObjectArrayIterator..::..MoveNext Method
GeometryObjectArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class


Reset Method

[image]

Revit 2013 API
GeometryObjectArrayIterator..::..Reset Method
GeometryObjectArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GeometryObjectArrayIterator Class


GeometryObjectArrayIterator Properties

[image] [image]

Revit 2013 API
GeometryObjectArrayIterator Properties
GeometryObjectArrayIterator Class See Also Send Feedback

The GeometryObjectArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GeometryObjectArrayIterator Class


Current Property

[image]

Revit 2013 API
GeometryObjectArrayIterator..::..Current Property
GeometryObjectArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GeometryObjectArrayIterator Class


GraphicsStyle Class

[image]

Revit 2013 API
GraphicsStyle Class
Members See Also Send Feedback
The graphics style instance in Autodesk Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GraphicsStyle : Element
Visual Basic
Public Class GraphicsStyle _
    Inherits Element
Visual C++
public ref class GraphicsStyle : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..GraphicsStyle

See Also

GraphicsStyle Members


GraphicsStyle Members

[image] [image]

Revit 2013 API
GraphicsStyle Members
GraphicsStyle Class Methods Properties See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyle Methods

[image] [image]

Revit 2013 API
GraphicsStyle Methods
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GraphicsStyle Class


GraphicsStyle Properties

[image] [image]

Revit 2013 API
GraphicsStyle Properties
GraphicsStyle Class See Also Send Feedback

The GraphicsStyle type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GraphicsStyleCategory | The graphics style category.
Public property | GraphicsStyleType | The graphics style type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GraphicsStyle Class


GraphicsStyleCategory Property

[image]

Revit 2013 API
GraphicsStyle..::..GraphicsStyleCategory Property
GraphicsStyle Class See Also Send Feedback
The graphics style category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category GraphicsStyleCategory { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleCategory As Category
    Get
Visual C++
public:
property Category^ GraphicsStyleCategory {
    Category^ get ();
}

See Also

GraphicsStyle Class


GraphicsStyleType Property

[image]

Revit 2013 API
GraphicsStyle..::..GraphicsStyleType Property
GraphicsStyle Class See Also Send Feedback
The graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GraphicsStyleType GraphicsStyleType { get; }
Visual Basic
Public ReadOnly Property GraphicsStyleType As GraphicsStyleType
    Get
Visual C++
public:
property GraphicsStyleType GraphicsStyleType {
    GraphicsStyleType get ();
}

See Also

GraphicsStyle Class


Parameter Property

[image] [image]

Revit 2013 API
GraphicsStyle..::..Parameter Property
GraphicsStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GraphicsStyle Class
GraphicsStyle Members


GraphicsStyleType Enumeration

[image]

Revit 2013 API
GraphicsStyleType Enumeration
See Also Send Feedback
Describes the type of graphics style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum GraphicsStyleType
Visual Basic
Public Enumeration GraphicsStyleType
Visual C++
public enum class GraphicsStyleType

Members

Member name | Description
Projection | Projection.
Cut | Cut.

See Also


Grid Class

[image]

Revit 2013 API
Grid Class
Members Example See Also Send Feedback
Represents a single grid line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Grid : Element
Visual Basic
Public Class Grid _
    Inherits Element
Visual C++
public ref class Grid : public Element

Remarks

Grid lines can either be curved or straight. The Name property can be used to retrieve the contents of the grid line's bubble.

Examples

CopyC#
public void GetInfo_Grid(Grid grid)
{
    string message = "Grid : ";

    // Show IsCurved property
    message += "\nIf grid is Arc : " + grid.IsCurved;

    // Show Curve information
    Autodesk.Revit.DB.Curve curve = grid.Curve;
    if (grid.IsCurved)
    {
        // if the curve is an arc, give center and radius information
        Autodesk.Revit.DB.Arc arc = curve as Autodesk.Revit.DB.Arc;
        message += "\nArc's radius: " + arc.Radius;
        message += "\nArc's center:  (" + XYZToString(arc.Center);
    }
    else
    {
        // if the curve is a line, give length information
        Autodesk.Revit.DB.Line line = curve as Autodesk.Revit.DB.Line;
        message += "\nLine's Length: " + line.Length;
    }
    // Get curve start point
    message += "\nStart point: " + XYZToString(curve.get_EndPoint(0));
    // Get curve end point
    message += "; End point: " + XYZToString(curve.get_EndPoint(0));

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub GetInfo_Grid(ByVal grid As Autodesk.Revit.DB.Grid)
    Dim message As String = "Grid : "

    ' Show IsCurved property
    message += vbLf & "If grid is Arc : " + grid.IsCurved

    ' Show Curve information
    Dim curve As Autodesk.Revit.DB.Curve = grid.Curve
    If grid.IsCurved Then
        ' if the curve is an arc, give center and radius information
        Dim arc As Autodesk.Revit.DB.Arc = TryCast(curve, Autodesk.Revit.DB.Arc)
        message += vbLf & "Arc's radius: " + arc.Radius
        message += vbLf & "Arc's center:  (" + XYZToString(arc.Center)
    Else
        ' if the curve is a line, give length information
        Dim line As Autodesk.Revit.DB.Line = TryCast(curve, Autodesk.Revit.DB.Line)
        message += vbLf & "Line's Length: " + line.Length
    End If
    ' Get curve start point
    message += vbLf & "Start point: " + XYZToString(curve.EndPoint(0))
    ' Get curve end point
    message += "; End point: " + XYZToString(curve.EndPoint(0))

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Grid

See Also

Grid Members


Grid Members

[image] [image]

Revit 2013 API
Grid Members
Grid Class Methods Properties See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtendToAllLevels | Adjust the grid to cut all levels.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GridType | Get and Set the type of the grid object.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Test to see if the grid line is curved or straight.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Grid Class


Grid Methods

[image] [image]

Revit 2013 API
Grid Methods
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtendToAllLevels | Adjust the grid to cut all levels.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExtents | Gets the extents of the grid in the model.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Grid Class


ExtendToAllLevels Method

[image]

Revit 2013 API
Grid..::..ExtendToAllLevels Method
Grid Class See Also Send Feedback
Adjust the grid to cut all levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ExtendToAllLevels()
Visual Basic
Public Sub ExtendToAllLevels
Visual C++
public:
void ExtendToAllLevels()

Remarks

Requires that at least one plan view exists in the document. If not, this will throw a Autodesk::Revit::Exceptions::InvalidOperationException.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no plan view in the document.

See Also

Grid Class


GetExtents Method

[image]

Revit 2013 API
Grid..::..GetExtents Method
Grid Class See Also Send Feedback
Gets the extents of the grid in the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Outline GetExtents()
Visual Basic
Public Function GetExtents As Outline
Visual C++
public:
Outline^ GetExtents()

Remarks

The extents are the 3D bounding box surrounding the grid. The Z coordinates of the box are used by Revit to determine if the grid should be displayed in a corresponding view plan (if the grid is linear). The extents are not used for arc grids.

See Also

Grid Class


Grid Properties

[image] [image]

Revit 2013 API
Grid Properties
Grid Class See Also Send Feedback

The Grid type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Retrieves an object that represents the geometry of the grid line.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GridType | Get and Set the type of the grid object.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsCurved | Test to see if the grid line is curved or straight.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Grid Class


Curve Property

[image]

Revit 2013 API
Grid..::..Curve Property
Grid Class See Also Send Feedback
Retrieves an object that represents the geometry of the grid line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

Remarks

The geometry can either be an arc or a curve. The IsCurved property can be used to determine this.

See Also

Grid Class


GridType Property

[image]

Revit 2013 API
Grid..::..GridType Property
Grid Class See Also Send Feedback
Get and Set the type of the grid object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridType GridType { get; set; }
Visual Basic
Public Property GridType As GridType
    Get
    Set
Visual C++
public:
property GridType^ GridType {
    GridType^ get ();
    void set (GridType^ value);
}

Remarks

When nullNothingnullptra null reference (Nothing in Visual Basic) is input for the method set, ArgumentNullException will be thrown.

See Also

Grid Class


IsCurved Property

[image]

Revit 2013 API
Grid..::..IsCurved Property
Grid Class See Also Send Feedback
Test to see if the grid line is curved or straight.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCurved { get; }
Visual Basic
Public ReadOnly Property IsCurved As Boolean
    Get
Visual C++
public:
property bool IsCurved {
    bool get ();
}

Remarks

A value of True is returned if the grid line is an arc or False if the grid line is straight. Use the Curve property to retrieve an object that represents the geometry of the grid line.

See Also

Grid Class


Parameter Property

[image] [image]

Revit 2013 API
Grid..::..Parameter Property
Grid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Grid Class
Grid Members


GridNode Structure

[image]

Revit 2013 API
GridNode Structure
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public struct GridNode
Visual Basic
Public Structure GridNode
Visual C++
public value class GridNode

See Also

GridNode Members


GridNode Members

[image] [image]

Revit 2013 API
GridNode Members
GridNode Structure Constructors Methods Properties See Also Send Feedback

The GridNode type exposes the following members.

Constructors

 | Name | Description
Public method | GridNode | Initializes a new instance of the GridNode class

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.

See Also

GridNode Structure


GridNode Constructor

[image]

Revit 2013 API
GridNode Constructor
GridNode Structure See Also Send Feedback
Initializes a new instance of the GridNode class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridNode(
    int uIndex,
    int vIndex
)
Visual Basic
Public Sub New ( _
    uIndex As Integer, _
    vIndex As Integer _
)
Visual C++
public:
GridNode(
    int uIndex,
    int vIndex
)

Parameters

uIndex
Type: System..::..Int32
vIndex
Type: System..::..Int32

See Also

GridNode Structure


GridNode Methods

[image] [image]

Revit 2013 API
GridNode Methods
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

GridNode Structure


GridNode Properties

[image] [image]

Revit 2013 API
GridNode Properties
GridNode Structure See Also Send Feedback

The GridNode type exposes the following members.

Properties

 | Name | Description
Public property | UIndex | The node's index along the U axis.
Public property | VIndex | The node's index along the V axis.

See Also

GridNode Structure


UIndex Property

[image]

Revit 2013 API
GridNode..::..UIndex Property
GridNode Structure See Also Send Feedback
The node's index along the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int UIndex { get; set; }
Visual Basic
Public Property UIndex As Integer
    Get
    Set
Visual C++
public:
property int UIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure


VIndex Property

[image]

Revit 2013 API
GridNode..::..VIndex Property
GridNode Structure See Also Send Feedback
The node's index along the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int VIndex { get; set; }
Visual Basic
Public Property VIndex As Integer
    Get
    Set
Visual C++
public:
property int VIndex {
    int get ();
    void set (int value);
}

See Also

GridNode Structure


GridNodeLocation Enumeration

[image]

Revit 2013 API
GridNodeLocation Enumeration
See Also Send Feedback
Location of a grid node relative to the face boundary. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum GridNodeLocation
Visual Basic
Public Enumeration GridNodeLocation
Visual C++
public enum class GridNodeLocation

Members

Member name | Description
Interior |
Boundary |
Exterior |

See Also


GridSegmentDirection Enumeration

[image]

Revit 2013 API
GridSegmentDirection Enumeration
See Also Send Feedback
Specify one of the four adjacent segments to a GridNode. See DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum GridSegmentDirection
Visual Basic
Public Enumeration GridSegmentDirection
Visual C++
public enum class GridSegmentDirection

Members

Member name | Description
PositiveU |
NegativeU |
PositiveV |
NegativeV |

See Also


GridType Class

[image]

Revit 2013 API
GridType Class
Members See Also Send Feedback
An object that represents a grid type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GridType : LineAndTextAttrSymbol
Visual Basic
Public Class GridType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class GridType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..GridType

See Also

GridType Members


GridType Members

[image] [image]

Revit 2013 API
GridType Members
GridType Class Methods Properties See Also Send Feedback

The GridType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GridType Class


GridType Methods

[image] [image]

Revit 2013 API
GridType Methods
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridType Class


GridType Properties

[image] [image]

Revit 2013 API
GridType Properties
GridType Class See Also Send Feedback

The GridType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GridType Class


Parameter Property

[image] [image]

Revit 2013 API
GridType..::..Parameter Property
GridType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GridType Class
GridType Members


GridTypeSet Class

[image]

Revit 2013 API
GridTypeSet Class
Members See Also Send Feedback
A set that contains grid types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GridTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class GridTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GridTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GridTypeSet

See Also

GridTypeSet Members


GridTypeSet Members

[image] [image]

Revit 2013 API
GridTypeSet Members
GridTypeSet Class Constructors Methods Properties See Also Send Feedback

The GridTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | GridTypeSet | Initializes a new instance of the GridTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class


GridTypeSet Constructor

[image]

Revit 2013 API
GridTypeSet Constructor
GridTypeSet Class See Also Send Feedback
Initializes a new instance of the GridTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
GridTypeSet()

See Also

GridTypeSet Class


GridTypeSet Methods

[image] [image]

Revit 2013 API
GridTypeSet Methods
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every grid type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a grid type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified grid type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified grid type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSet Class


Clear Method

[image]

Revit 2013 API
GridTypeSet..::..Clear Method
GridTypeSet Class See Also Send Feedback
Removes every grid type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GridTypeSet Class


Contains Method

[image]

Revit 2013 API
GridTypeSet..::..Contains Method
GridTypeSet Class See Also Send Feedback
Tests for the existence of a grid type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    GridType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GridType
The grid type to be searched for.

Return Value

The Contains method returns True if the grid type is within the set, otherwise False.

See Also

GridTypeSet Class


Erase Method

[image]

Revit 2013 API
GridTypeSet..::..Erase Method
GridTypeSet Class See Also Send Feedback
Removes a specified grid type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    GridType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As GridType _
) As Integer
Visual C++
public:
virtual int Erase(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GridType
The grid type to be erased.

Return Value

The number of grid types that were erased from the set.

See Also

GridTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
GridTypeSet..::..ForwardIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GridTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
GridTypeSet..::..GetEnumerator Method
GridTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GridTypeSet Class


Insert Method

[image]

Revit 2013 API
GridTypeSet..::..Insert Method
GridTypeSet Class See Also Send Feedback
Insert the specified grid type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    GridType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GridType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GridType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GridType
The grid type to be inserted into the set.

Return Value

Returns whether the grid type was inserted into the set.

See Also

GridTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
GridTypeSet..::..ReverseIterator Method
GridTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GridTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GridTypeSetIterator
Visual C++
public:
virtual GridTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GridTypeSet Class


GridTypeSet Properties

[image] [image]

Revit 2013 API
GridTypeSet Properties
GridTypeSet Class See Also Send Feedback

The GridTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of grid types that are in the set.

See Also

GridTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
GridTypeSet..::..IsEmpty Property
GridTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GridTypeSet Class


Size Property

[image]

Revit 2013 API
GridTypeSet..::..Size Property
GridTypeSet Class See Also Send Feedback
Returns the number of grid types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GridTypeSet Class


GridTypeSetIterator Class

[image]

Revit 2013 API
GridTypeSetIterator Class
Members See Also Send Feedback
An iterator to a grid type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GridTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GridTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GridTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GridTypeSetIterator

See Also

GridTypeSetIterator Members


GridTypeSetIterator Members

[image] [image]

Revit 2013 API
GridTypeSetIterator Members
GridTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GridTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class


GridTypeSetIterator Constructor

[image]

Revit 2013 API
GridTypeSetIterator Constructor
GridTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GridTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GridTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GridTypeSetIterator Class


GridTypeSetIterator Methods

[image] [image]

Revit 2013 API
GridTypeSetIterator Methods
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
GridTypeSetIterator..::..MoveNext Method
GridTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
GridTypeSetIterator..::..Reset Method
GridTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GridTypeSetIterator Class


GridTypeSetIterator Properties

[image] [image]

Revit 2013 API
GridTypeSetIterator Properties
GridTypeSetIterator Class See Also Send Feedback

The GridTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GridTypeSetIterator Class


Current Property

[image]

Revit 2013 API
GridTypeSetIterator..::..Current Property
GridTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GridTypeSetIterator Class


Group Class

[image]

Revit 2013 API
Group Class
Members Example See Also Send Feedback
This object represents a group of elements within the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Group : Element
Visual Basic
Public Class Group _
    Inherits Element
Visual C++
public ref class Group : public Element

Examples

CopyC#
// Change the default group name to a new name �MyGroup�
group.GroupType.Name = "MyGroup";
CopyC#
public void GetInfo_Group(Group group)
{
    string message = "Group : ";

    // Show the group type name
    message += "\nGroup type name is : " + group.GroupType.Name;

    // Show the name of the elements contained in the group
    message += "\nThe members contained in this group are:";
    foreach (Element member in group.Members)
    {
        message += "\n\tGroup member id : " + member.Id.IntegerValue;
    }

    message += "\nAll member will now be removed from group.";
    group.Ungroup();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
' Change the default group name to a new name "MyGroup"
group.GroupType.Name = "MyGroup"
CopyVB.NET
Public Sub GetInfo_Group(ByVal group As Group)
    Dim message As String = "Group : "

    ' Show the group type name
    message += vbLf & "Group type name is : " + group.GroupType.Name

    ' Show the name of the elements contained in the group
    message += vbLf & "The members contained in this group are:"
    For Each member As Autodesk.Revit.DB.Element In group.Members
        message += vbLf & vbTab & "Group member id : " + member.Id.IntegerValue
    Next

    message += vbLf & "All member will now be removed from group."
    group.Ungroup()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Group

See Also

Group Members


Group Members

[image] [image]

Revit 2013 API
Group Members
Group Class Methods Properties See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Ungroup | Obsolete. Ungroup the group.
Public method | UngroupMembers | Ungroups the group.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Members | Obsolete. Returns all the members of the group.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Group Class


Group Methods

[image] [image]

Revit 2013 API
Group Methods
Group Class See Also Send Feedback

The Group type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMemberIds | Retrieves all the member ElementIds of the group.
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Ungroup | Obsolete. Ungroup the group.
Public method | UngroupMembers | Ungroups the group.

See Also

Group Class


GetMemberIds Method

[image]

Revit 2013 API
Group..::..GetMemberIds Method
Group Class See Also Send Feedback
Retrieves all the member ElementIds of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetMemberIds()
Visual Basic
Public Function GetMemberIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMemberIds()

Return Value

An ordered list of the members within the group. The order of this list can be used to match members between other instances of the group.

See Also

Group Class


Ungroup Method

[image]

Revit 2013 API
Group..::..Ungroup Method
Group Class See Also Send Feedback
Ungroup the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call UngroupMembers() instead.")]
public ElementSet Ungroup()
Visual Basic
<ObsoleteAttribute("This method is Obsolete in Revit 2013.  Call UngroupMembers() instead.")> _
Public Function Ungroup As ElementSet
Visual C++
[ObsoleteAttribute(L"This method is Obsolete in Revit 2013.  Call UngroupMembers() instead.")]
public:
ElementSet^ Ungroup()

Return Value

If successful the removed group elements are returned in this set.

Remarks

Ungroup removed all the members from the group and then causes the group itself to be deleted. Note that the reference to this group object will become invalid once this method is called. If the group cannot be ungrouped a System.InvalidOperationException will be thrown.

See Also

Group Class


UngroupMembers Method

[image]

Revit 2013 API
Group..::..UngroupMembers Method
Group Class See Also Send Feedback
Ungroups the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> UngroupMembers()
Visual Basic
Public Function UngroupMembers As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ UngroupMembers()

Return Value

If successful, the ids of the members of group are returned.

Remarks

Removes all the members from the group and deletes the group. Note that the reference to this group object will become invalid once this method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the group cannot be ungrouped.

See Also

Group Class


Group Properties

[image] [image]

Revit 2013 API
Group Properties
Group Class See Also Send Feedback

The Group type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | GroupType | Get or set the type of the group.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of a group within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Members | Obsolete. Returns all the members of the group.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Group Class


GroupType Property

[image]

Revit 2013 API
Group..::..GroupType Property
Group Class See Also Send Feedback
Get or set the type of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GroupType GroupType { get; set; }
Visual Basic
Public Overridable Property GroupType As GroupType
    Get
    Set
Visual C++
public:
virtual property GroupType^ GroupType {
    GroupType^ get ();
    void set (GroupType^ value);
}

Remarks

By setting this property the group can be swapped to a different kind of group.

See Also

Group Class


Location Property

[image]

Revit 2013 API
Group..::..Location Property
Group Class See Also Send Feedback
This property is used to find the physical location of a group within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

The Location property returns an object that can be used to find the location of an object within the project. Groups return a point location object.

See Also

Group Class


Members Property

[image]

Revit 2013 API
Group..::..Members Property
Group Class See Also Send Feedback
Returns all the members of the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetMemberIds() instead.")]
public ElementArray Members { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetMemberIds() instead.")> _
Public ReadOnly Property Members As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetMemberIds() instead.")]
public:
property ElementArray^ Members {
    ElementArray^ get ();
}

Remarks

This property returns an ordered array of the members within the group. The order of this array can be used to match members between other instances of the group.

See Also

Group Class


Parameter Property

[image] [image]

Revit 2013 API
Group..::..Parameter Property
Group Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Group Class
Group Members


GroupSet Class

[image]

Revit 2013 API
GroupSet Class
Members See Also Send Feedback
An set that contains groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GroupSet : APIObject, IEnumerable
Visual Basic
Public Class GroupSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroupSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GroupSet

See Also

GroupSet Members


GroupSet Members

[image] [image]

Revit 2013 API
GroupSet Members
GroupSet Class Constructors Methods Properties See Also Send Feedback

The GroupSet type exposes the following members.

Constructors

 | Name | Description
Public method | GroupSet | Initializes a new instance of the GroupSet class

Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


GroupSet Constructor

[image]

Revit 2013 API
GroupSet Constructor
GroupSet Class See Also Send Feedback
Initializes a new instance of the GroupSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroupSet()
Visual Basic
Public Sub New
Visual C++
public:
GroupSet()

See Also

GroupSet Class


GroupSet Methods

[image] [image]

Revit 2013 API
GroupSet Methods
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every group from the set, rendering it empty.
Public method | Contains | Tests for the existence of a group within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified group from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified group into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSet Class


Clear Method

[image]

Revit 2013 API
GroupSet..::..Clear Method
GroupSet Class See Also Send Feedback
Removes every group from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroupSet Class


Contains Method

[image]

Revit 2013 API
GroupSet..::..Contains Method
GroupSet Class See Also Send Feedback
Tests for the existence of a group within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Group item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Group
The group to be searched for.

Return Value

The Contains method returns True if the group is within the set, otherwise False.

See Also

GroupSet Class


Erase Method

[image]

Revit 2013 API
GroupSet..::..Erase Method
GroupSet Class See Also Send Feedback
Removes a specified group from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Group item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Group _
) As Integer
Visual C++
public:
virtual int Erase(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Group
The group to be erased.

Return Value

The number of groups that were erased from the set.

See Also

GroupSet Class


ForwardIterator Method

[image]

Revit 2013 API
GroupSet..::..ForwardIterator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GroupSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroupSet Class


GetEnumerator Method

[image]

Revit 2013 API
GroupSet..::..GetEnumerator Method
GroupSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GroupSet Class


Insert Method

[image]

Revit 2013 API
GroupSet..::..Insert Method
GroupSet Class See Also Send Feedback
Insert the specified group into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Group item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Group _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Group^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Group
The group to be inserted into the set.

Return Value

Returns whether the group was inserted into the set.

See Also

GroupSet Class


ReverseIterator Method

[image]

Revit 2013 API
GroupSet..::..ReverseIterator Method
GroupSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GroupSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GroupSetIterator
Visual C++
public:
virtual GroupSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroupSet Class


GroupSet Properties

[image] [image]

Revit 2013 API
GroupSet Properties
GroupSet Class See Also Send Feedback

The GroupSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of groups that are in the set.

See Also

GroupSet Class


IsEmpty Property

[image]

Revit 2013 API
GroupSet..::..IsEmpty Property
GroupSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroupSet Class


Size Property

[image]

Revit 2013 API
GroupSet..::..Size Property
GroupSet Class See Also Send Feedback
Returns the number of groups that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroupSet Class


GroupSetIterator Class

[image]

Revit 2013 API
GroupSetIterator Class
Members See Also Send Feedback
An iterator to a group set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GroupSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GroupSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroupSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GroupSetIterator

See Also

GroupSetIterator Members


GroupSetIterator Members

[image] [image]

Revit 2013 API
GroupSetIterator Members
GroupSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroupSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GroupSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class


GroupSetIterator Constructor

[image]

Revit 2013 API
GroupSetIterator Constructor
GroupSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroupSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GroupSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroupSetIterator Class


GroupSetIterator Methods

[image] [image]

Revit 2013 API
GroupSetIterator Methods
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupSetIterator Class


MoveNext Method

[image]

Revit 2013 API
GroupSetIterator..::..MoveNext Method
GroupSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroupSetIterator Class


Reset Method

[image]

Revit 2013 API
GroupSetIterator..::..Reset Method
GroupSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroupSetIterator Class


GroupSetIterator Properties

[image] [image]

Revit 2013 API
GroupSetIterator Properties
GroupSetIterator Class See Also Send Feedback

The GroupSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroupSetIterator Class


Current Property

[image]

Revit 2013 API
GroupSetIterator..::..Current Property
GroupSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroupSetIterator Class


GroupType Class

[image]

Revit 2013 API
GroupType Class
Members Example See Also Send Feedback
Represents a type of a user defined group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GroupType : ElementType
Visual Basic
Public Class GroupType _
    Inherits ElementType
Visual C++
public ref class GroupType : public ElementType

Remarks

The GroupType object can be used to swap the type of an existing group or to place an new instance of a group.

Examples

CopyC#
public void GetInfo_GroupType(GroupType groupType)
{
    string message = "GroupType";
    //Retrieve a set of all the groups that have this type.
    foreach (Group group in groupType.Groups)
    {
        // Get GroupType group name
        message = "\nThe group type name is : " + groupType.Name;
        //Returns all the members of the group.
        message += "\nThe types and ids of the group members are : ";
        foreach (Element element in group.Members)
        {
            // Get GroupType group element id
            message += "\n\t" + element.GetType().Name + " : " + element.Id.IntegerValue;
        }
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_GroupType(ByVal groupType As GroupType)
    Dim message As String = "GroupType"
    'Retrieve a set of all the groups that have this type.
    For Each group As Group In groupType.Groups
        ' Get GroupType group name
        message = vbLf & "The group type name is : " & groupType.Name.ToString()
        'Returns all the members of the group.
        message += vbLf & "The types and ids of the group members are : "
        For Each element As Autodesk.Revit.DB.Element In group.Members
            ' Get GroupType group element id
            message += vbLf & vbTab + element.[GetType]().Name & " : " + element.Id.ToString()
        Next
    Next
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..GroupType

See Also

GroupType Members


GroupType Members

[image] [image]

Revit 2013 API
GroupType Members
GroupType Class Methods Properties See Also Send Feedback

The GroupType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Groups | Retrieve a set of all the groups that have this type.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GroupType Class


GroupType Methods

[image] [image]

Revit 2013 API
GroupType Methods
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupType Class


GroupType Properties

[image] [image]

Revit 2013 API
GroupType Properties
GroupType Class See Also Send Feedback

The GroupType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Groups | Retrieve a set of all the groups that have this type.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GroupType Class


Groups Property

[image]

Revit 2013 API
GroupType..::..Groups Property
GroupType Class See Also Send Feedback
Retrieve a set of all the groups that have this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroupSet Groups { get; }
Visual Basic
Public ReadOnly Property Groups As GroupSet
    Get
Visual C++
public:
property GroupSet^ Groups {
    GroupSet^ get ();
}

Return Value

A set of group objects that all share this group type.

Remarks

All groups returned by this property belong to this group type. A groups type can be changed by using the GroupType property on the group object, in which case it will no longer belong to this type but it will belong to the new type instead.

See Also

GroupType Class


Parameter Property

[image] [image]

Revit 2013 API
GroupType..::..Parameter Property
GroupType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GroupType Class
GroupType Members


GuidEnum Class

[image]

Revit 2013 API
GuidEnum Class
Members See Also Send Feedback
Base class of all GUID-based enum classes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GuidEnum
Visual Basic
Public Class GuidEnum
Visual C++
public ref class GuidEnum

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
Autodesk.Revit.DB..::..FailureDefinitionId
Autodesk.Revit.DB..::..PerformanceAdviserRuleId

See Also

GuidEnum Members


GuidEnum Members

[image] [image]

Revit 2013 API
GuidEnum Members
GuidEnum Class Constructors Methods Properties See Also Send Feedback

The GuidEnum type exposes the following members.

Constructors

 | Name | Description
Public method | GuidEnum | Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class


GuidEnum Constructor

[image]

Revit 2013 API
GuidEnum Constructor
GuidEnum Class See Also Send Feedback
Creates an Guid-based enum instance with the supplied name and GUID. GUID-based enum instance can be compared by this guid value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GuidEnum(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
GuidEnum(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The GUID of this GUID-based enum.

See Also

GuidEnum Class


GuidEnum Methods

[image] [image]

Revit 2013 API
GuidEnum Methods
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GuidEnum Class


GuidEnum Properties

[image] [image]

Revit 2013 API
GuidEnum Properties
GuidEnum Class See Also Send Feedback

The GuidEnum type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object.

See Also

GuidEnum Class


Guid Property

[image]

Revit 2013 API
GuidEnum..::..Guid Property
GuidEnum Class See Also Send Feedback
The Guid of GUID-based enum object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Guid Guid { get; }
Visual Basic
Public ReadOnly Property Guid As Guid
    Get
Visual C++
public:
property Guid Guid {
    Guid get ();
}

See Also

GuidEnum Class


HermiteFace Class

[image]

Revit 2013 API
HermiteFace Class
Members Example See Also Send Feedback
A cubic hermite spline face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HermiteFace : Face
Visual Basic
Public Class HermiteFace _
    Inherits Face
Visual C++
public ref class HermiteFace : public Face

Remarks

Hermite faces are defined by cubic hermite spline surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

CopyC#
private void GetHermiteFaceInfo(Face face)
{
    HermiteFace hermiteFace = face as HermiteFace;
    if (null != hermiteFace)
    {
        IList<XYZ> points = hermiteFace.Points;
        IList<XYZ> derivs = hermiteFace.MixedDerivs;
        DoubleArray faceParams = hermiteFace.get_Params(0);
        IList<XYZ> tangents = hermiteFace.get_Tangents(0);
    }
}
CopyVB.NET
Private Sub GetHermiteFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim hermiteFace As HermiteFace = TryCast(face, HermiteFace)
    If hermiteFace IsNot Nothing Then
        Dim points As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Points
        Dim derivs As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.MixedDerivs
        Dim faceParams As DoubleArray = hermiteFace.Params(0)
        Dim tangents As IList(Of Autodesk.Revit.DB.XYZ) = hermiteFace.Tangents(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..HermiteFace

See Also

HermiteFace Members


HermiteFace Members

[image] [image]

Revit 2013 API
HermiteFace Members
HermiteFace Class Methods Properties See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | Params | Parameters of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


HermiteFace Methods

[image] [image]

Revit 2013 API
HermiteFace Methods
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class


Intersect Method

[image] [image]

Revit 2013 API
HermiteFace..::..Intersect Method
HermiteFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


IsInside Method

[image] [image]

Revit 2013 API
HermiteFace..::..IsInside Method
HermiteFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


Triangulate Method

[image] [image]

Revit 2013 API
HermiteFace..::..Triangulate Method
HermiteFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

HermiteFace Class
HermiteFace Members


HermiteFace Properties

[image] [image]

Revit 2013 API
HermiteFace Properties
HermiteFace Class See Also Send Feedback

The HermiteFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | MixedDerivs | Mixed derivatives of the surface.
Public property | Params | Parameters of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Points | Interpolation points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Tangents | Tangents of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteFace Class


MixedDerivs Property

[image]

Revit 2013 API
HermiteFace..::..MixedDerivs Property
HermiteFace Class See Also Send Feedback
Mixed derivatives of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> MixedDerivs { get; }
Visual Basic
Public ReadOnly Property MixedDerivs As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ MixedDerivs {
    IList<XYZ^>^ get ();
}

See Also

HermiteFace Class


Params Property

[image]

Revit 2013 API
HermiteFace..::..Params Property
HermiteFace Class See Also Send Feedback
Parameters of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Params ( _
    index As Integer _
) As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Params[int index] {
    DoubleArray^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

HermiteFace Class


Points Property

[image]

Revit 2013 API
HermiteFace..::..Points Property
HermiteFace Class See Also Send Feedback
Interpolation points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Points { get; }
Visual Basic
Public ReadOnly Property Points As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
}

See Also

HermiteFace Class


Tangents Property

[image]

Revit 2013 API
HermiteFace..::..Tangents Property
HermiteFace Class See Also Send Feedback
Tangents of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Tangents ( _
    index As Integer _
) As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Tangents[int index] {
    IList<XYZ^>^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

HermiteFace Class


HermiteSpline Class

[image]

Revit 2013 API
HermiteSpline Class
Members See Also Send Feedback
A Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HermiteSpline : Curve
Visual Basic
Public Class HermiteSpline _
    Inherits Curve
Visual C++
public ref class HermiteSpline : public Curve

Remarks

The Hermite spline lies in the plane defined by control points.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..HermiteSpline

See Also

HermiteSpline Members


HermiteSpline Members

[image] [image]

Revit 2013 API
HermiteSpline Members
HermiteSpline Class Methods Properties See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | ControlPoints | The control points of the Hermite spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


HermiteSpline Methods

[image] [image]

Revit 2013 API
HermiteSpline Methods
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HermiteSpline Class


Intersect Method

[image] [image]

Revit 2013 API
HermiteSpline..::..Intersect Method
HermiteSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


IsInside Method

[image] [image]

Revit 2013 API
HermiteSpline..::..IsInside Method
HermiteSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

HermiteSpline Class
HermiteSpline Members


HermiteSpline Properties

[image] [image]

Revit 2013 API
HermiteSpline Properties
HermiteSpline Class See Also Send Feedback

The HermiteSpline type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | ControlPoints | The control points of the Hermite spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsPeriodic | Returns whether the Hermite spline is periodic or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Parameters | Returns the params of the Hermite spline.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Tangents | Returns the tangents of the Hermite spline.
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

HermiteSpline Class


ControlPoints Property

[image]

Revit 2013 API
HermiteSpline..::..ControlPoints Property
HermiteSpline Class See Also Send Feedback
The control points of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> ControlPoints { get; set; }
Visual Basic
Public Property ControlPoints As IList(Of XYZ)
    Get
    Set
Visual C++
public:
property IList<XYZ^>^ ControlPoints {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

See Also

HermiteSpline Class


IsPeriodic Property

[image]

Revit 2013 API
HermiteSpline..::..IsPeriodic Property
HermiteSpline Class See Also Send Feedback
Returns whether the Hermite spline is periodic or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPeriodic { get; }
Visual Basic
Public ReadOnly Property IsPeriodic As Boolean
    Get
Visual C++
public:
property bool IsPeriodic {
    bool get ();
}

See Also

HermiteSpline Class


Parameters Property

[image]

Revit 2013 API
HermiteSpline..::..Parameters Property
HermiteSpline Class See Also Send Feedback
Returns the params of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Parameters {
    DoubleArray^ get ();
}

See Also

HermiteSpline Class


Tangents Property

[image]

Revit 2013 API
HermiteSpline..::..Tangents Property
HermiteSpline Class See Also Send Feedback
Returns the tangents of the Hermite spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Tangents { get; }
Visual Basic
Public ReadOnly Property Tangents As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Tangents {
    IList<XYZ^>^ get ();
}

See Also

HermiteSpline Class


HiddenLineViewsType Enumeration

[image]

Revit 2013 API
HiddenLineViewsType Enumeration
See Also Send Feedback
An enumerated type listing all Hidden Line Views types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum HiddenLineViewsType
Visual Basic
Public Enumeration HiddenLineViewsType
Visual C++
public enum class HiddenLineViewsType

Members

Member name | Description
VectorProcessing | The type of Hidden Line Views is Vector Processing (fast).
RasterProcessing | The type of Hidden Line Views is Raster Processing.

See Also


HorizontalAlign Enumeration

[image]

Revit 2013 API
HorizontalAlign Enumeration
See Also Send Feedback
Horizontal alignment of model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum HorizontalAlign
Visual Basic
Public Enumeration HorizontalAlign
Visual C++
public enum class HorizontalAlign

Members

Member name | Description
Left |
Center |
Right |

See Also


HorizontalAlignmentStyle Enumeration

[image]

Revit 2013 API
HorizontalAlignmentStyle Enumeration
See Also Send Feedback
Declares the horizontal alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum HorizontalAlignmentStyle
Visual Basic
Public Enumeration HorizontalAlignmentStyle
Visual C++
public enum class HorizontalAlignmentStyle

Members

Member name | Description
Left | Alignment to left
Center | Alignment to center
Right | Alignment to right

See Also


HostedSweep Class

[image]

Revit 2013 API
HostedSweep Class
Members See Also Send Feedback
An object that represents an object hosted by an edge of a roof or floor within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class HostedSweep : HostObject
Visual Basic
Public MustInherit Class HostedSweep _
    Inherits HostObject
Visual C++
public ref class HostedSweep abstract : public HostObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB.Architecture..::..Fascia
Autodesk.Revit.DB.Architecture..::..Gutter
Autodesk.Revit.DB..::..SlabEdge

See Also

HostedSweep Members


HostedSweep Members

[image] [image]

Revit 2013 API
HostedSweep Members
HostedSweep Class Methods Properties See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweep Class


HostedSweep Methods

[image] [image]

Revit 2013 API
HostedSweep Methods
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the hosted sweep object.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object.
Public method | SetEndPointParameter | Set segment's start point or end point parameter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line.

See Also

HostedSweep Class


AddSegment Method

[image]

Revit 2013 API
HostedSweep..::..AddSegment Method
HostedSweep Class See Also Send Feedback
Add segments to the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract void AddSegment(
    Reference targetRef
)
Visual Basic
Public MustOverride Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) abstract

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference

See Also

HostedSweep Class


GetEndPointParameter Method

[image]

Revit 2013 API
HostedSweep..::..GetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Retrieve segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetEndPointParameter(
    Reference targetRef,
    int endIdx
)
Visual Basic
Public Function GetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer _
) As Double
Visual C++
public:
double GetEndPointParameter(
    Reference^ targetRef,
    int endIdx
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference whose parameter want to be get.
endIdx
Type: System..::..Int32
Start point (=0) or end point (=1).

Return Value

Start point or end point parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


HorizontalFlip Method

[image]

Revit 2013 API
HostedSweep..::..HorizontalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along horizontal line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void HorizontalFlip()
Visual Basic
Public Sub HorizontalFlip
Visual C++
public:
void HorizontalFlip()

See Also

HostedSweep Class


RemoveSegment Method

[image]

Revit 2013 API
HostedSweep..::..RemoveSegment Method
HostedSweep Class See Also Send Feedback
Remove segments from the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveSegment(
    Reference targetRef
)
Visual Basic
Public Sub RemoveSegment ( _
    targetRef As Reference _
)
Visual C++
public:
void RemoveSegment(
    Reference^ targetRef
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference which want to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


SetEndPointParameter Method

[image]

Revit 2013 API
HostedSweep..::..SetEndPointParameter Method
HostedSweep Class See Also Send Feedback
Set segment's start point or end point parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetEndPointParameter(
    Reference targetRef,
    int endIdx,
    double param
)
Visual Basic
Public Function SetEndPointParameter ( _
    targetRef As Reference, _
    endIdx As Integer, _
    param As Double _
) As Boolean
Visual C++
public:
bool SetEndPointParameter(
    Reference^ targetRef,
    int endIdx,
    double param
)

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference whose parameter want to be set.
endIdx
Type: System..::..Int32
Start point (=0) or end point (=1).
param
Type: System..::..Double
Value of parameter.

Return Value

true if operation success.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlip Method

[image]

Revit 2013 API
HostedSweep..::..VerticalFlip Method
HostedSweep Class See Also Send Feedback
Flip the hosted sweep object along vertical line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void VerticalFlip()
Visual Basic
Public Sub VerticalFlip
Visual C++
public:
void VerticalFlip()

See Also

HostedSweep Class


HostedSweep Properties

[image] [image]

Revit 2013 API
HostedSweep Properties
HostedSweep Class See Also Send Feedback

The HostedSweep type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object.
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object.
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweep Class


Angle Property

[image]

Revit 2013 API
HostedSweep..::..Angle Property
HostedSweep Class See Also Send Feedback
Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HorizontalFlipped Property

[image]

Revit 2013 API
HostedSweep..::..HorizontalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the horizontal flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HorizontalFlipped { get; }
Visual Basic
Public ReadOnly Property HorizontalFlipped As Boolean
    Get
Visual C++
public:
property bool HorizontalFlipped {
    bool get ();
}

See Also

HostedSweep Class


HorizontalOffset Property

[image]

Revit 2013 API
HostedSweep..::..HorizontalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the horizontal offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HorizontalOffset { get; set; }
Visual Basic
Public Property HorizontalOffset As Double
    Get
    Set
Visual C++
public:
property double HorizontalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


Length Property

[image]

Revit 2013 API
HostedSweep..::..Length Property
HostedSweep Class See Also Send Feedback
Retrieve the length of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

See Also

HostedSweep Class


Parameter Property

[image] [image]

Revit 2013 API
HostedSweep..::..Parameter Property
HostedSweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostedSweep Class
HostedSweep Members


ReferenceCurve Property

[image]

Revit 2013 API
HostedSweep..::..ReferenceCurve Property
HostedSweep Class See Also Send Feedback
The curve on which the hosted sweep segment is created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    Reference targetRef
] { get; }
Visual Basic
Public ReadOnly Property ReferenceCurve ( _
    targetRef As Reference _
) As Curve
    Get
Visual C++
public:
property Curve^ ReferenceCurve[Reference^ targetRef] {
    Curve^ get (Reference^ targetRef);
}

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Reference of the curve that hosts the object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails.

See Also

HostedSweep Class


VerticalFlipped Property

[image]

Revit 2013 API
HostedSweep..::..VerticalFlipped Property
HostedSweep Class See Also Send Feedback
Retrieve the vertical flip status of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool VerticalFlipped { get; }
Visual Basic
Public ReadOnly Property VerticalFlipped As Boolean
    Get
Visual C++
public:
property bool VerticalFlipped {
    bool get ();
}

See Also

HostedSweep Class


VerticalOffset Property

[image]

Revit 2013 API
HostedSweep..::..VerticalOffset Property
HostedSweep Class See Also Send Feedback
Retrieve/set the vertical offset of the hosted sweep object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double VerticalOffset { get; set; }
Visual Basic
Public Property VerticalOffset As Double
    Get
    Set
Visual C++
public:
property double VerticalOffset {
    double get ();
    void set (double value);
}

See Also

HostedSweep Class


HostedSweepType Class

[image]

Revit 2013 API
HostedSweepType Class
Members See Also Send Feedback
An object that represents the attributes for sweep host objects in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HostedSweepType : HostObjAttributes
Visual Basic
Public Class HostedSweepType _
    Inherits HostObjAttributes
Visual C++
public ref class HostedSweepType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB.Architecture..::..FasciaType
Autodesk.Revit.DB.Architecture..::..GutterType
Autodesk.Revit.DB..::..SlabEdgeType

See Also

HostedSweepType Members


HostedSweepType Members

[image] [image]

Revit 2013 API
HostedSweepType Members
HostedSweepType Class Methods Properties See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweepType Class


HostedSweepType Methods

[image] [image]

Revit 2013 API
HostedSweepType Methods
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostedSweepType Class


HostedSweepType Properties

[image] [image]

Revit 2013 API
HostedSweepType Properties
HostedSweepType Class See Also Send Feedback

The HostedSweepType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostedSweepType Class


Parameter Property

[image] [image]

Revit 2013 API
HostedSweepType..::..Parameter Property
HostedSweepType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostedSweepType Class
HostedSweepType Members


HostObjAttributes Class

[image]

Revit 2013 API
HostObjAttributes Class
Members See Also Send Feedback
An object that represents characteristics of several kinds of type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HostObjAttributes : ElementType
Visual Basic
Public Class HostObjAttributes _
    Inherits ElementType
Visual C++
public ref class HostObjAttributes : public ElementType

Remarks

This object provides access to structural layering components for any object derived from it, such as wall types and floor types.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..BuildingPadType
Autodesk.Revit.DB..::..CeilingType
Autodesk.Revit.DB..::..ContFootingType
Autodesk.Revit.DB..::..CurtainSystemType
Autodesk.Revit.DB..::..FloorType
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB..::..RoofType
Autodesk.Revit.DB..::..WallType

See Also

HostObjAttributes Members


HostObjAttributes Members

[image] [image]

Revit 2013 API
HostObjAttributes Members
HostObjAttributes Class Methods Properties See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObjAttributes Class


HostObjAttributes Methods

[image] [image]

Revit 2013 API
HostObjAttributes Methods
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObjAttributes Class


GetCompoundStructure Method

[image]

Revit 2013 API
HostObjAttributes..::..GetCompoundStructure Method
HostObjAttributes Class See Also Send Feedback
Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CompoundStructure GetCompoundStructure()
Visual Basic
Public Function GetCompoundStructure As CompoundStructure
Visual C++
public:
CompoundStructure^ GetCompoundStructure()

Remarks

A copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called. From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

HostObjAttributes Class


SetCompoundStructure Method

[image]

Revit 2013 API
HostObjAttributes..::..SetCompoundStructure Method
HostObjAttributes Class See Also Send Feedback
Sets the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCompoundStructure(
    CompoundStructure compoundStructure
)
Visual Basic
Public Sub SetCompoundStructure ( _
    compoundStructure As CompoundStructure _
)
Visual C++
public:
void SetCompoundStructure(
    CompoundStructure^ compoundStructure
)

Parameters

compoundStructure
Type: Autodesk.Revit.DB..::..CompoundStructure

See Also

HostObjAttributes Class


HostObjAttributes Properties

[image] [image]

Revit 2013 API
HostObjAttributes Properties
HostObjAttributes Class See Also Send Feedback

The HostObjAttributes type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObjAttributes Class


Parameter Property

[image] [image]

Revit 2013 API
HostObjAttributes..::..Parameter Property
HostObjAttributes Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostObjAttributes Class
HostObjAttributes Members


HostObject Class

[image]

Revit 2013 API
HostObject Class
Members See Also Send Feedback
A base class that provides support for all objects that can host other objects, such as walls roofs, and floors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class HostObject : Element
Visual Basic
Public Class HostObject _
    Inherits Element
Visual C++
public ref class HostObject : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..CeilingAndFloor
Autodesk.Revit.DB..::..ContFooting
Autodesk.Revit.DB..::..CurtainGridLine
Autodesk.Revit.DB..::..CurtainSystemBase
Autodesk.Revit.DB.Electrical..::..Wire
Autodesk.Revit.DB..::..FaceWall
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..Wall
Autodesk.Revit.DB..::..WallSweep

See Also

HostObject Members


HostObject Members

[image] [image]

Revit 2013 API
HostObject Members
HostObject Class Methods Properties See Also Send Feedback

The HostObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObject Class


HostObject Methods

[image] [image]

Revit 2013 API
HostObject Methods
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObject Class


FindInserts Method

[image]

Revit 2013 API
HostObject..::..FindInserts Method
HostObject Class See Also Send Feedback
Gets the ids of the instances inserted into this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)
Visual Basic
Public Function FindInserts ( _
    addRectOpenings As Boolean, _
    includeShadows As Boolean, _
    includeEmbeddedWalls As Boolean, _
    includeSharedEmbeddedInserts As Boolean _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ FindInserts(
    bool addRectOpenings,
    bool includeShadows,
    bool includeEmbeddedWalls,
    bool includeSharedEmbeddedInserts
)

Parameters

addRectOpenings
Type: System..::..Boolean
True if rectangular openings should be included in the return.
includeShadows
Type: System..::..Boolean
True if shadows should be included in the return.
includeEmbeddedWalls
Type: System..::..Boolean
True if embedded walls should be included in the return.
includeSharedEmbeddedInserts
Type: System..::..Boolean
True if shared embedded inserts should be included in the return.

Return Value

All the insertable instances' ids.

See Also

HostObject Class


HostObject Properties

[image] [image]

Revit 2013 API
HostObject Properties
HostObject Class See Also Send Feedback

The HostObject type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HostObject Class


Parameter Property

[image] [image]

Revit 2013 API
HostObject..::..Parameter Property
HostObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HostObject Class
HostObject Members


HostObjectUtils Class

[image]

Revit 2013 API
HostObjectUtils Class
Members See Also Send Feedback
These are generic host object utilities.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class HostObjectUtils : IDisposable
Visual Basic
Public Class HostObjectUtils _
    Implements IDisposable
Visual C++
public ref class HostObjectUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..HostObjectUtils

See Also

HostObjectUtils Members


HostObjectUtils Members

[image] [image]

Revit 2013 API
HostObjectUtils Members
HostObjectUtils Class Methods See Also Send Feedback

The HostObjectUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the HostObjectUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBottomFaces | Returns the bottom faces for this host object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSideFaces | Returns the major side faces for this host object.
 | GetTopFaces | Returns the top faces for this host object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObjectUtils Class


HostObjectUtils Methods

[image] [image]

Revit 2013 API
HostObjectUtils Methods
HostObjectUtils Class See Also Send Feedback

The HostObjectUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBottomFaces | Returns the bottom faces for this host object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSideFaces | Returns the major side faces for this host object.
 | GetTopFaces | Returns the top faces for this host object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HostObjectUtils Class


Dispose Method

[image]

Revit 2013 API
HostObjectUtils..::..Dispose Method
HostObjectUtils Class See Also Send Feedback
Releases all resources used by the HostObjectUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

HostObjectUtils Class


GetBottomFaces Method

[image]

Revit 2013 API
HostObjectUtils..::..GetBottomFaces Method
HostObjectUtils Class See Also Send Feedback
Returns the bottom faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetBottomFaces(
    HostObject hostObject
)
Visual Basic
Public Shared Function GetBottomFaces ( _
    hostObject As HostObject _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetBottomFaces(
    HostObject^ hostObject
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.

Return Value

An array of references to the faces which are at the bottom of this element.

Remarks

This utility supports host objects whose bottom faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to top or bottom faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HostObjectUtils Class


GetSideFaces Method

[image]

Revit 2013 API
HostObjectUtils..::..GetSideFaces Method
HostObjectUtils Class See Also Send Feedback
Returns the major side faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetSideFaces(
    HostObject hostObject,
    ShellLayerType side
)
Visual Basic
Public Shared Function GetSideFaces ( _
    hostObject As HostObject, _
    side As ShellLayerType _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetSideFaces(
    HostObject^ hostObject,
    ShellLayerType side
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.
side
Type: Autodesk.Revit.DB..::..ShellLayerType
The side of the host object.

Return Value

An array of references to the faces which are on the given side of this element.

Remarks

This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to side faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HostObjectUtils Class


GetTopFaces Method

[image]

Revit 2013 API
HostObjectUtils..::..GetTopFaces Method
HostObjectUtils Class See Also Send Feedback
Returns the top faces for this host object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetTopFaces(
    HostObject hostObject
)
Visual Basic
Public Shared Function GetTopFaces ( _
    hostObject As HostObject _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetTopFaces(
    HostObject^ hostObject
)

Parameters

hostObject
Type: Autodesk.Revit.DB..::..HostObject
The host object.

Return Value

An array of references to the faces which are at the top of this element.

Remarks

This utility supports host objects whose top faces represent one of the boundaries of CompoundStructure (such as roofs, floors or ceilings).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This host object does not support access to top or bottom faces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HostObjectUtils Class


IConnector Interface

[image]

Revit 2013 API
IConnector Interface
Members See Also Send Feedback
An interface which provides access to connector in Autodesk Revit MEP document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IConnector
Visual Basic
Public Interface IConnector
Visual C++
public interface class IConnector

Remarks

This interface is shared by Connector, DuctConnector,ElectricalConnector and PipeConnector.

See Also

IConnector Members


IConnector Members

[image] [image]

Revit 2013 API
IConnector Members
IConnector Interface Properties See Also Send Feedback

The IConnector type exposes the following members.

Properties

 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.

See Also

IConnector Interface


IConnector Properties

[image] [image]

Revit 2013 API
IConnector Properties
IConnector Interface See Also Send Feedback

The IConnector type exposes the following members.

Properties

 | Name | Description
Public property | CoordinateSystem | The coordinate system of the connector.
Public property | Domain | The domain of the connector.
Public property | Height | The height of the connector.
Public property | Origin | The location of the connector in family document.
Public property | Radius | The radius of the connector.
Public property | Shape | The shape of the connector.
Public property | Width | The width of the connector.

See Also

IConnector Interface


CoordinateSystem Property

[image]

Revit 2013 API
IConnector..::..CoordinateSystem Property
IConnector Interface See Also Send Feedback
The coordinate system of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
Transform CoordinateSystem { get; }
Visual Basic
ReadOnly Property CoordinateSystem As Transform
    Get
Visual C++
property Transform^ CoordinateSystem {
    Transform^ get ();
}

Remarks

The Z axis of the coordinate system is the normal to the plane of the connector.

See Also

IConnector Interface


Domain Property

[image]

Revit 2013 API
IConnector..::..Domain Property
IConnector Interface See Also Send Feedback
The domain of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
Domain Domain { get; }
Visual Basic
ReadOnly Property Domain As Domain
    Get
Visual C++
property Domain Domain {
    Domain get ();
}

Remarks

This property is used to retrieve the domain of the connector.

See Also

IConnector Interface


Height Property

[image]

Revit 2013 API
IConnector..::..Height Property
IConnector Interface See Also Send Feedback
The height of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
double Height { get; }
Visual Basic
ReadOnly Property Height As Double
    Get
Visual C++
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


Origin Property

[image]

Revit 2013 API
IConnector..::..Origin Property
IConnector Interface See Also Send Feedback
The location of the connector in family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
XYZ Origin { get; }
Visual Basic
ReadOnly Property Origin As XYZ
    Get
Visual C++
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to retrieve the origin of the connector.

See Also

IConnector Interface


Radius Property

[image]

Revit 2013 API
IConnector..::..Radius Property
IConnector Interface See Also Send Feedback
The radius of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
double Radius { get; }
Visual Basic
ReadOnly Property Radius As Double
    Get
Visual C++
property double Radius {
    double get ();
}

Remarks

This property is used to retrieve the radius of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not round.

See Also

IConnector Interface


Shape Property

[image]

Revit 2013 API
IConnector..::..Shape Property
IConnector Interface See Also Send Feedback
The shape of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
ConnectorProfileType Shape { get; }
Visual Basic
ReadOnly Property Shape As ConnectorProfileType
    Get
Visual C++
property ConnectorProfileType Shape {
    ConnectorProfileType get ();
}

Remarks

This property is used to retrieve the shape of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throw when this connector has no shape.

See Also

IConnector Interface


Width Property

[image]

Revit 2013 API
IConnector..::..Width Property
IConnector Interface See Also Send Feedback
The width of the connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
double Width { get; }
Visual Basic
ReadOnly Property Width As Double
    Get
Visual C++
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the connector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the connector's shape is not rectangular.

See Also

IConnector Interface


IExtension Interface

[image]

Revit 2013 API
IExtension Interface
Members See Also Send Feedback
An interface that supports the additional operation for Extension Status

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExtension
Visual Basic
Public Interface IExtension
Visual C++
public interface class IExtension

Remarks

See Also

IExtension Members


IExtension Members

[image] [image]

Revit 2013 API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface


IExtension Properties

[image] [image]

Revit 2013 API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

 | Name | Description
Public property | Extended | Retrieves or set the extension status at the end
Public property | HasMiter | Retrieves the miter status at the end
Public property | IsMiterLocked | Retrieves or set the miter locked status at the end.
Public property | SymbolicExtended | Retrieves or set the symbolic extension status at the end

See Also

IExtension Interface


Extended Property

[image]

Revit 2013 API
IExtension..::..Extended Property
IExtension Interface See Also Send Feedback
Retrieves or set the extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool this[
    int index
] { get; set; }
Visual Basic
Property Extended ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
property bool Extended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.

See Also

IExtension Interface


HasMiter Property

[image]

Revit 2013 API
IExtension..::..HasMiter Property
IExtension Interface See Also Send Feedback
Retrieves the miter status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool this[
    int index
] { get; }
Visual Basic
ReadOnly Property HasMiter ( _
    index As Integer _
) As Boolean
    Get
Visual C++
property bool HasMiter[int index] {
    bool get (int index);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, this can check whether the beam is mitered with other beams at the end

See Also

IExtension Interface


IsMiterLocked Property

[image]

Revit 2013 API
IExtension..::..IsMiterLocked Property
IExtension Interface See Also Send Feedback
Retrieves or set the miter locked status at the end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool this[
    int index
] { get; set; }
Visual Basic
Property IsMiterLocked ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
property bool IsMiterLocked[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, only if the beam is extended and is mitered with other beams at the end, it can be locked. Otherwise, the setting is invalid

See Also

IExtension Interface


SymbolicExtended Property

[image]

Revit 2013 API
IExtension..::..SymbolicExtended Property
IExtension Interface See Also Send Feedback
Retrieves or set the symbolic extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool this[
    int index
] { get; set; }
Visual Basic
Property SymbolicExtended ( _
    index As Integer _
) As Boolean
    Get
    Set
Visual C++
property bool SymbolicExtended[int index] {
    bool get (int index);
    void set (int index, bool value);
}

Parameters

index
Type: System..::..Int32

Remarks

Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, symbolic extension setting only works when the beam is extended, mitered, and miter locked at the end. Otherwise the setting is invalid

See Also

IExtension Interface


IExternalDBApplication Interface

[image]

Revit 2013 API
IExternalDBApplication Interface
Members See Also Send Feedback
An interface that supports addition of DB-level external applications to Revit, to subscribe to DB-level events and updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExternalDBApplication
Visual Basic
Public Interface IExternalDBApplication
Visual C++
public interface class IExternalDBApplication

Remarks

DB-level applications are permitted to add DB-level events and updaters to the session. They cannot create or modify UI.

See Also

IExternalDBApplication Members


IExternalDBApplication Members

[image] [image]

Revit 2013 API
IExternalDBApplication Members
IExternalDBApplication Interface Methods See Also Send Feedback

The IExternalDBApplication type exposes the following members.

Methods

 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.

See Also

IExternalDBApplication Interface


IExternalDBApplication Methods

[image] [image]

Revit 2013 API
IExternalDBApplication Methods
IExternalDBApplication Interface See Also Send Feedback

The IExternalDBApplication type exposes the following members.

Methods

 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.

See Also

IExternalDBApplication Interface


OnShutdown Method

[image]

Revit 2013 API
IExternalDBApplication..::..OnShutdown Method
IExternalDBApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit shuts down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
ExternalDBApplicationResult OnShutdown(
    ControlledApplication application
)
Visual Basic
Function OnShutdown ( _
    application As ControlledApplication _
) As ExternalDBApplicationResult
Visual C++
ExternalDBApplicationResult OnShutdown(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.ApplicationServices..::..ControlledApplication
Handle to the Revit Application object.

Return Value

Indicates if the external db application completes its work successfully.

See Also

IExternalDBApplication Interface


OnStartup Method

[image]

Revit 2013 API
IExternalDBApplication..::..OnStartup Method
IExternalDBApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit starts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
ExternalDBApplicationResult OnStartup(
    ControlledApplication application
)
Visual Basic
Function OnStartup ( _
    application As ControlledApplication _
) As ExternalDBApplicationResult
Visual C++
ExternalDBApplicationResult OnStartup(
    ControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.ApplicationServices..::..ControlledApplication
Handle to the Revit Application object.

Return Value

Indicates if the external db application completes its work successfully.

Remarks

Typically, event handlers and updaters are registered in this method.

See Also

IExternalDBApplication Interface


IFailuresPreprocessor Interface

[image]

Revit 2013 API
IFailuresPreprocessor Interface
Members Example See Also Send Feedback
An interface that may be used to perform a preprocessing step to either filter out anticipated transaction failures or to mark certain failures as non-continuable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public interface IFailuresPreprocessor
Visual Basic
Public Interface IFailuresPreprocessor
Visual C++
public interface class IFailuresPreprocessor

Remarks

This interface, if provided, is invoked when there are failures found at the end of a transaction. An instance of this interface can be set in the failure handling options of transaction object.

Examples

CopyC#
public class RoomWarningSwallower : IFailuresPreprocessor
{
    public FailureProcessingResult PreprocessFailures(FailuresAccessor failuresAccessor)
    {
        IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
        // Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages();
        foreach (FailureMessageAccessor failure in failList)
        {
            // check FailureDefinitionIds against ones that you want to dismiss,
            FailureDefinitionId failID = failure.GetFailureDefinitionId();
            // prevent Revit from showing Unenclosed room warnings
            if (failID == BuiltInFailures.RoomFailures.RoomNotEnclosed)
            {
                failuresAccessor.DeleteWarning(failure);
            }
        }

        return FailureProcessingResult.Continue;
    }
}
CopyVB.NET
Public Class RoomWarningSwallower
    Implements IFailuresPreprocessor
    Public Function PreprocessFailures(ByVal failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresPreprocessor.PreprocessFailures
        Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
        ' Inside event handler, get all warnings
        failList = failuresAccessor.GetFailureMessages()
        For Each failure As FailureMessageAccessor In failList
            ' check FailureDefinitionIds against ones that you want to dismiss,
            Dim failID As FailureDefinitionId = failure.GetFailureDefinitionId()
            ' prevent Revit from showing Unenclosed room warnings
            If failID = BuiltInFailures.RoomFailures.RoomNotEnclosed Then
                failuresAccessor.DeleteWarning(failure)
            End If
        Next

        Return FailureProcessingResult.[Continue]
    End Function
End Class

See Also

IFailuresPreprocessor Members


IFailuresPreprocessor Members

[image] [image]

Revit 2013 API
IFailuresPreprocessor Members
IFailuresPreprocessor Interface Methods See Also Send Feedback

The IFailuresPreprocessor type exposes the following members.

Methods

 | Name | Description
Public method | PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

See Also

IFailuresPreprocessor Interface


IFailuresPreprocessor Methods

[image] [image]

Revit 2013 API
IFailuresPreprocessor Methods
IFailuresPreprocessor Interface See Also Send Feedback

The IFailuresPreprocessor type exposes the following members.

Methods

 | Name | Description
Public method | PreprocessFailures | This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

See Also

IFailuresPreprocessor Interface


PreprocessFailures Method

[image]

Revit 2013 API
IFailuresPreprocessor..::..PreprocessFailures Method
IFailuresPreprocessor Interface See Also Send Feedback
This method is called when there have been failures found at the end of a transaction and Revit is about to start processing them.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
FailureProcessingResult PreprocessFailures(
    FailuresAccessor failuresAccessor
)
Visual Basic
Function PreprocessFailures ( _
    failuresAccessor As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult PreprocessFailures(
    FailuresAccessor^ failuresAccessor
)

Parameters

failuresAccessor
Type: Autodesk.Revit.DB..::..FailuresAccessor
The Interface class that provides access to the failure information.

Return Value

Notifies end of transaction code about further actions required. Return values are interpreted as follows:
  • Continue - the failure processing will continue. Failures will be shown to the user, even if they were addressed by this method.
  • ProceedWithCommit - end of transaction checks and failure processing will restart from the beginning. If some failures were resolved here, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - the failure processing will continue. Failures will be shown to the user, but user will have no option to resolve or ignore them - only cancel option will be available. If intent is to roll back transaction without showing failures to the user, it can be achieved by setting failure handling option to remove failures before returning ProceedWithRollBack.
Other return values are not allowed.

See Also

IFailuresPreprocessor Interface


IFailuresProcessor Interface

[image]

Revit 2013 API
IFailuresProcessor Interface
Members Example See Also Send Feedback
To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IFailuresProcessor
Visual Basic
Public Interface IFailuresProcessor
Visual C++
public interface class IFailuresProcessor

Remarks

To override Revit default Failures Processing UI, instantiate your own processor derived from this interface and register it in Revit application.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)]

public class MyFailuresUI : IExternalApplication
{
    static AddInId m_appId = new AddInId(new Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"));
    public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication uiControlledApplication)
    {
        IFailuresProcessor myFailUI = new FailUI();
        //Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        return Result.Succeeded;
    }

    public Autodesk.Revit.UI.Result OnShutdown(UIControlledApplication application)
    {
        return Result.Succeeded;
    }

    public class FailUI : IFailuresProcessor
    {
        public void Dismiss(Document document)
        {
            // This method is being called in case of exception or document destruction to
            // dismiss any possible pending failure UI that may have left on the screen
        }

        public FailureProcessingResult ProcessFailures(FailuresAccessor failuresAccessor)
        {
            IList<FailureResolutionType> resolutionTypeList = new List<FailureResolutionType>();
            IList<FailureMessageAccessor> failList = new List<FailureMessageAccessor>();
            // Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages();
            string errorString = "";
            bool hasFailures = false;
            foreach (FailureMessageAccessor failure in failList)
            {
                // check how many resolutions types were attempted to try to prevent
                // entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure);
                if (resolutionTypeList.Count >= 3)
                {
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.");
                    return FailureProcessingResult.ProceedWithRollBack;
                }

                errorString += "IDs ";
                foreach (ElementId id in failure.GetFailingElementIds())
                {
                    errorString += id + ", ";
                    hasFailures = true;
                }
                errorString += "\nWill be deleted because: " + failure.GetDescriptionText() + "\n";
                failuresAccessor.DeleteElements(failure.GetFailingElementIds() as IList<ElementId>);
            }
            if (hasFailures)
            {
                TaskDialog.Show("Error", errorString);
                return FailureProcessingResult.ProceedWithCommit;
            }

            return FailureProcessingResult.Continue;
        }
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(Autodesk.Revit.Attributes.TransactionMode.Automatic)> _
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class MyFailuresUI
    Implements IExternalApplication
    Shared m_appId As New AddInId(New Guid("9F179363-B349-4541-823F-A2DDB2B86AF3"))
    Public Function OnStartup(ByVal uiControlledApplication As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
        Dim myFailUI As IFailuresProcessor = New FailUI()
        'Autodesk.Revit.ApplicationServices.Application.RegisterFailuresProcessor(myFailUI);
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnShutdown
        Return Result.Succeeded
    End Function

    Public Class FailUI
        Implements IFailuresProcessor
        Public Sub Dismiss(ByVal document As Document) Implements IFailuresProcessor.Dismiss
            ' This method is being called in case of exception or document destruction to
            ' dismiss any possible pending failure UI that may have left on the screen
        End Sub

        Public Function ProcessFailures(ByVal failuresAccessor As FailuresAccessor) As FailureProcessingResult Implements IFailuresProcessor.ProcessFailures
            Dim resolutionTypeList As IList(Of FailureResolutionType) = New List(Of FailureResolutionType)()
            Dim failList As IList(Of FailureMessageAccessor) = New List(Of FailureMessageAccessor)()
            ' Inside event handler, get all warnings
            failList = failuresAccessor.GetFailureMessages()
            Dim errorString As String = ""
            Dim hasFailures As Boolean = False
            For Each failure As FailureMessageAccessor In failList
                ' check how many resolutions types were attempted to try to prevent
                ' entering infinite loop
                resolutionTypeList = failuresAccessor.GetAttemptedResolutionTypes(failure)
                If resolutionTypeList.Count >= 3 Then
                    TaskDialog.Show("Error", "Cannot resolve failures - transaction will be rolled back.")
                    Return FailureProcessingResult.ProceedWithRollBack
                End If

                errorString += "IDs "
                For Each id As ElementId In failure.GetFailingElementIds()
                    errorString += id.ToString() + ", "
                    hasFailures = True
                Next
                errorString += vbLf & "Will be deleted because: " + failure.GetDescriptionText() + vbLf
                failuresAccessor.DeleteElements(TryCast(failure.GetFailingElementIds(), IList(Of ElementId)))
            Next
            If hasFailures Then
                TaskDialog.Show("Error", errorString)
                Return FailureProcessingResult.ProceedWithCommit
            End If

            Return FailureProcessingResult.[Continue]
        End Function
    End Class
End Class

See Also

IFailuresProcessor Members


IFailuresProcessor Members

[image] [image]

Revit 2013 API
IFailuresProcessor Members
IFailuresProcessor Interface Methods See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


IFailuresProcessor Methods

[image] [image]

Revit 2013 API
IFailuresProcessor Methods
IFailuresProcessor Interface See Also Send Feedback

The IFailuresProcessor type exposes the following members.

Methods

 | Name | Description
Public method | Dismiss | This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method | ProcessFailures | Method that Revit will invoke to process failures at the end of transaction.

See Also

IFailuresProcessor Interface


Dismiss Method

[image]

Revit 2013 API
IFailuresProcessor..::..Dismiss Method
IFailuresProcessor Interface See Also Send Feedback
This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
void Dismiss(
    Document document
)
Visual Basic
Sub Dismiss ( _
    document As Document _
)
Visual C++
void Dismiss(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which pending failures processing UI should be dismissed

See Also

IFailuresProcessor Interface


ProcessFailures Method

[image]

Revit 2013 API
IFailuresProcessor..::..ProcessFailures Method
IFailuresProcessor Interface See Also Send Feedback
Method that Revit will invoke to process failures at the end of transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
FailureProcessingResult ProcessFailures(
    FailuresAccessor data
)
Visual Basic
Function ProcessFailures ( _
    data As FailuresAccessor _
) As FailureProcessingResult
Visual C++
FailureProcessingResult ProcessFailures(
    FailuresAccessor^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..FailuresAccessor
Provides all necessary data to perform the resolution of failures.

Return Value

The result of the failures processing.
  • Continue - Should be returned if there were no failures or highest failure severity was "Warning" and all warnings were deleted. If some failures are still present and "Continue" is returned, it will be treated as "ProceedWithRollback". Note: If this method has attempted to resolve failures, it should return "ProceedWithCommit" to repeat end of transaction checks and failures processing.
  • ProceedWithCommit - End of transaction checks and failure processing will restart from the beginning. If some failures were resolved, they will be removed and not delivered to the user. ProceedWithCommit cannot be returned if transaction is being rolled back.
  • ProceedWithRollBack - Transaction will be rolled back even if Commit was originally requested.
  • WaitForUserInput - Should be returned if method has activated modeless user interaction and is waiting for an external event (typically user input) to complete failures processing.

Remarks

This method is invoked after some failures may have been handled by any FailuresPreprocessor and/or FailureProcessing event subscribers.

See Also

IFailuresProcessor Interface


IFamilyLoadOptions Interface

[image]

Revit 2013 API
IFamilyLoadOptions Interface
Members See Also Send Feedback
An interface class which provide the callback for family load options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IFamilyLoadOptions
Visual Basic
Public Interface IFamilyLoadOptions
Visual C++
public interface class IFamilyLoadOptions

Remarks

Implement this interface and register an instance of the derived class with the UpdaterRegistry.

See Also

IFamilyLoadOptions Members


IFamilyLoadOptions Members

[image] [image]

Revit 2013 API
IFamilyLoadOptions Members
IFamilyLoadOptions Interface Methods See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

 | Name | Description
Public method | OnFamilyFound | This is the method called when the family was found in the target document already.
Public method | OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface


IFamilyLoadOptions Methods

[image] [image]

Revit 2013 API
IFamilyLoadOptions Methods
IFamilyLoadOptions Interface See Also Send Feedback

The IFamilyLoadOptions type exposes the following members.

Methods

 | Name | Description
Public method | OnFamilyFound | This is the method called when the family was found in the target document already.
Public method | OnSharedFamilyFound | This is the method called when the shared family was found in the target document already.

See Also

IFamilyLoadOptions Interface


OnFamilyFound Method

[image]

Revit 2013 API
IFamilyLoadOptions..::..OnFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the family was found in the target document already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool OnFamilyFound(
    bool familyInUse,
    out bool overwriteParameterValues
)
Visual Basic
Function OnFamilyFound ( _
    familyInUse As Boolean, _
    <OutAttribute> ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnFamilyFound(
    bool familyInUse,
    [OutAttribute] bool% overwriteParameterValues
)

Parameters

familyInUse
Type: System..::..Boolean
Indicates if at least one instance of the family is placed in the project or not.
overwriteParameterValues
Type: System..::..Boolean%
This is a boolean argument by reference which determines if overwrite the parameter values of existing types or not. The default value is false, and it can be overwritten if you want to change the behavior.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface


OnSharedFamilyFound Method

[image]

Revit 2013 API
IFamilyLoadOptions..::..OnSharedFamilyFound Method
IFamilyLoadOptions Interface See Also Send Feedback
This is the method called when the shared family was found in the target document already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
bool OnSharedFamilyFound(
    Family sharedFamily,
    bool familyInUse,
    out FamilySource source,
    out bool overwriteParameterValues
)
Visual Basic
Function OnSharedFamilyFound ( _
    sharedFamily As Family, _
    familyInUse As Boolean, _
    <OutAttribute> ByRef source As FamilySource, _
    <OutAttribute> ByRef overwriteParameterValues As Boolean _
) As Boolean
Visual C++
bool OnSharedFamilyFound(
    Family^ sharedFamily,
    bool familyInUse,
    [OutAttribute] FamilySource% source,
    [OutAttribute] bool% overwriteParameterValues
)

Parameters

sharedFamily
Type: Autodesk.Revit.DB..::..Family
The shared family in the current family document.
familyInUse
Type: System..::..Boolean
Indicates if at least one instance of the family is placed in the project or not.
source
Type: Autodesk.Revit.DB..::..FamilySource%
This is an output enum argument which indicates if the family will load from the project or the current family.
overwriteParameterValues
Type: System..::..Boolean%
This is an output boolean argument which indicates if overwrite the parameter values of existing types.

Return Value

Return true to continue loading the family, false to cancel.

See Also

IFamilyLoadOptions Interface


IFCExportOptions Class

[image]

Revit 2013 API
IFCExportOptions Class
Members See Also Send Feedback
IFC Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class IFCExportOptions : IDisposable
Visual Basic
Public Class IFCExportOptions _
    Implements IDisposable
Visual C++
public ref class IFCExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..IFCExportOptions

See Also

IFCExportOptions Members


IFCExportOptions Members

[image] [image]

Revit 2013 API
IFCExportOptions Members
IFCExportOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExportOptions()()()() | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.

Methods

 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose | Releases all resources used by the IFCExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


IFCExportOptions Constructor

[image] [image]

Revit 2013 API
IFCExportOptions Constructor
IFCExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IFCExportOptions()()()() | Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.
Public method | IFCExportOptions(IFCExportOptions) | Creates a copy of an IFCExportOptions.

See Also

IFCExportOptions Class
IFCExportOptions Members


IFCExportOptions Constructor

[image]

Revit 2013 API
IFCExportOptions Constructor
IFCExportOptions Class See Also Send Feedback
Default constructor. Initializes FileVersion to Default. WallAndColumnSplitting and ExportBaseQuantities are set to false. FamilyMappingFile is set to empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IFCExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
IFCExportOptions()

See Also

IFCExportOptions Class
IFCExportOptions Overload


IFCExportOptions Constructor (IFCExportOptions)

[image]

Revit 2013 API
IFCExportOptions Constructor (IFCExportOptions)
IFCExportOptions Class See Also Send Feedback
Creates a copy of an IFCExportOptions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IFCExportOptions(
    IFCExportOptions from
)
Visual Basic
Public Sub New ( _
    from As IFCExportOptions _
)
Visual C++
public:
IFCExportOptions(
    IFCExportOptions^ from
)

Parameters

from
Type: Autodesk.Revit.DB..::..IFCExportOptions

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExportOptions Class
IFCExportOptions Overload


IFCExportOptions Methods

[image] [image]

Revit 2013 API
IFCExportOptions Methods
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | AddOption | Adds a new named option to the options structure.
Public method | Assign | Assigns the values of the IFCExportOptions to this options object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExportOptions Class


AddOption Method

[image]

Revit 2013 API
IFCExportOptions..::..AddOption Method
IFCExportOptions Class See Also Send Feedback
Adds a new named option to the options structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddOption(
    string name,
    string value
)
Visual Basic
Public Sub AddOption ( _
    name As String, _
    value As String _
)
Visual C++
public:
void AddOption(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The option name.
value
Type: System..::..String
The option value.

Remarks

Named options can be used to set options not accessible through the standard IFC export user interface. It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExportOptions Class


Assign Method

[image]

Revit 2013 API
IFCExportOptions..::..Assign Method
IFCExportOptions Class See Also Send Feedback
Assigns the values of the IFCExportOptions to this options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Assign(
    IFCExportOptions sourceOptions
)
Visual Basic
Public Sub Assign ( _
    sourceOptions As IFCExportOptions _
)
Visual C++
public:
void Assign(
    IFCExportOptions^ sourceOptions
)

Parameters

sourceOptions
Type: Autodesk.Revit.DB..::..IFCExportOptions
The source IFCExportOptions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExportOptions Class


Dispose Method

[image]

Revit 2013 API
IFCExportOptions..::..Dispose Method
IFCExportOptions Class See Also Send Feedback
Releases all resources used by the IFCExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCExportOptions Class


IFCExportOptions Properties

[image] [image]

Revit 2013 API
IFCExportOptions Properties
IFCExportOptions Class See Also Send Feedback

The IFCExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportBaseQuantities | Option to export IFC standard quantities currently supported by Revit.
Public property | FamilyMappingFile | Path to a file containing family mapping.
Public property | FileVersion | IFC file version.
Public property | FilterViewId | Id of the view whose visibility settings will govern the contents in the exported IFC file.
Public property | SpaceBoundaryLevel | Level of space boundaries exported in IFC file.
Public property | WallAndColumnSplitting | Option to allow division of multi-level walls and columns by levels.

See Also

IFCExportOptions Class


ExportBaseQuantities Property

[image]

Revit 2013 API
IFCExportOptions..::..ExportBaseQuantities Property
IFCExportOptions Class See Also Send Feedback
Option to export IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ExportBaseQuantities { get; set; }
Visual Basic
Public Property ExportBaseQuantities As Boolean
    Get
    Set
Visual C++
public:
property bool ExportBaseQuantities {
    bool get ();
    void set (bool value);
}

Remarks

IFC has created a list of common quantities (e.g. length, area, volume, etc.) that can optionally be exported along with the 3D representation for many element types (e.g. walls, columns, doors). Setting this option to true will cause the export procedure to include the set of IFC quantities that Revit currently supports. Default is false.

See Also

IFCExportOptions Class


FamilyMappingFile Property

[image]

Revit 2013 API
IFCExportOptions..::..FamilyMappingFile Property
IFCExportOptions Class See Also Send Feedback
Path to a file containing family mapping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string FamilyMappingFile { get; set; }
Visual Basic
Public Property FamilyMappingFile As String
    Get
    Set
Visual C++
public:
property String^ FamilyMappingFile {
    String^ get ();
    void set (String^ value);
}

Remarks

The file, if specified, contains data describing how to map generic family instances to IFC containers (element types). This property may be empty, in which case the current mapping will be used. The default is an empty string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExportOptions Class


FileVersion Property

[image]

Revit 2013 API
IFCExportOptions..::..FileVersion Property
IFCExportOptions Class See Also Send Feedback
IFC file version.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IFCVersion FileVersion { get; set; }
Visual Basic
Public Property FileVersion As IFCVersion
    Get
    Set
Visual C++
public:
property IFCVersion FileVersion {
    IFCVersion get ();
    void set (IFCVersion value);
}

Remarks

Default is IFCVersion.Default.

See Also

IFCExportOptions Class


FilterViewId Property

[image]

Revit 2013 API
IFCExportOptions..::..FilterViewId Property
IFCExportOptions Class See Also Send Feedback
Id of the view whose visibility settings will govern the contents in the exported IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId FilterViewId { get; set; }
Visual Basic
Public Property FilterViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FilterViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

This should be set to the id of the view, or InvalidElementId if there is to be no special filtering applied (all model elements will be exported). Default is InvalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExportOptions Class


SpaceBoundaryLevel Property

[image]

Revit 2013 API
IFCExportOptions..::..SpaceBoundaryLevel Property
IFCExportOptions Class See Also Send Feedback
Level of space boundaries exported in IFC file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int SpaceBoundaryLevel { get; set; }
Visual Basic
Public Property SpaceBoundaryLevel As Integer
    Get
    Set
Visual C++
public:
property int SpaceBoundaryLevel {
    int get ();
    void set (int value);
}

Remarks

There are three valid values for this integer:
0 = export no space boundaries.  This can save space if the receiving application doesn't use them.
1 = export 1st level space boundaries.  This is the default.
2 = export 2nd level space boundaries.  This is primarily for use in energy analysis programs, and the GSA.
Default is 1.

See Also

IFCExportOptions Class


WallAndColumnSplitting Property

[image]

Revit 2013 API
IFCExportOptions..::..WallAndColumnSplitting Property
IFCExportOptions Class See Also Send Feedback
Option to allow division of multi-level walls and columns by levels.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool WallAndColumnSplitting { get; set; }
Visual Basic
Public Property WallAndColumnSplitting As Boolean
    Get
    Set
Visual C++
public:
property bool WallAndColumnSplitting {
    bool get ();
    void set (bool value);
}

Remarks

This option will always be considered true when FileVersion is IFC-BCA. For other File Versions, default is false.

See Also

IFCExportOptions Class


IFCVersion Enumeration

[image]

Revit 2013 API
IFCVersion Enumeration
See Also Send Feedback
An enumerated type listing available IFC file versions into which a file may be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum IFCVersion
Visual Basic
Public Enumeration IFCVersion
Visual C++
public enum class IFCVersion

Members

Member name | Description
Default | The Autodesk Revit application's default export format. Note that this may change as the defaults change in the Revit user interface.
IFCBCA | IFC BCA file format. This is a certified variant of IFC 2x2 used for submitting files to the Singapore BCA ePlan Check Server.
IFC2x2 | IFC 2x2 file format.
IFC2x3 | IFC 2x3 file format.
IFCCOBIE | IFC GSA COBIE 2010 file format. This is a variant of IFC 2x3 used for submitting files that are COBIE 2010-complaint.
IFC2x3CV2 | IFC 2x3 Coordination View 2.0 file format. This is a variant of IFC 2x3 used for exporting files using the Coordination View 2.0 model view.

See Also


ImageBackgroundSettings Class

[image]

Revit 2013 API
ImageBackgroundSettings Class
Members See Also Send Feedback
Represents the rendering image background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ImageBackgroundSettings : BackgroundSettings
Visual Basic
Public Class ImageBackgroundSettings _
    Inherits BackgroundSettings
Visual C++
public ref class ImageBackgroundSettings : public BackgroundSettings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BackgroundSettings
Autodesk.Revit.DB..::..ImageBackgroundSettings

See Also

ImageBackgroundSettings Members


ImageBackgroundSettings Members

[image] [image]

Revit 2013 API
ImageBackgroundSettings Members
ImageBackgroundSettings Class Methods Properties See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.

See Also

ImageBackgroundSettings Class


ImageBackgroundSettings Methods

[image] [image]

Revit 2013 API
ImageBackgroundSettings Methods
ImageBackgroundSettings Class See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageBackgroundSettings Class


ImageBackgroundSettings Properties

[image] [image]

Revit 2013 API
ImageBackgroundSettings Properties
ImageBackgroundSettings Class See Also Send Feedback

The ImageBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundImageFit | The background image fit type.
Public property | FilePath | File path of the image for the rendering background.
Public property | OffsetHeight | The vertical offset of the rendering image to the rendering region.
Public property | OffsetWidth | The horizontal offset of the rendering image to the rendering region.

See Also

ImageBackgroundSettings Class


BackgroundImageFit Property

[image]

Revit 2013 API
ImageBackgroundSettings..::..BackgroundImageFit Property
ImageBackgroundSettings Class See Also Send Feedback
The background image fit type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BackgroundImageFit BackgroundImageFit { get; set; }
Visual Basic
Public Property BackgroundImageFit As BackgroundImageFit
    Get
    Set
Visual C++
public:
property BackgroundImageFit BackgroundImageFit {
    BackgroundImageFit get ();
    void set (BackgroundImageFit value);
}

Remarks

This value indicates how scale should be applied to the image in order to fit it to a page or screen.

See Also

ImageBackgroundSettings Class


FilePath Property

[image]

Revit 2013 API
ImageBackgroundSettings..::..FilePath Property
ImageBackgroundSettings Class See Also Send Feedback
File path of the image for the rendering background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The file specified by path is not an image file. A valid image file should be in one of the following formats: bmp, jpg, jpeg, png, tif.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | When setting this property: The file specified by path doesn't exist.

See Also

ImageBackgroundSettings Class


OffsetHeight Property

[image]

Revit 2013 API
ImageBackgroundSettings..::..OffsetHeight Property
ImageBackgroundSettings Class See Also Send Feedback
The vertical offset of the rendering image to the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double OffsetHeight { get; set; }
Visual Basic
Public Property OffsetHeight As Double
    Get
    Set
Visual C++
public:
property double OffsetHeight {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be no more than 30000 feet in absolute value.

See Also

ImageBackgroundSettings Class


OffsetWidth Property

[image]

Revit 2013 API
ImageBackgroundSettings..::..OffsetWidth Property
ImageBackgroundSettings Class See Also Send Feedback
The horizontal offset of the rendering image to the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double OffsetWidth { get; set; }
Visual Basic
Public Property OffsetWidth As Double
    Get
    Set
Visual C++
public:
property double OffsetWidth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for width must be no more than 30000 feet in absolute value.

See Also

ImageBackgroundSettings Class


ImageExportOptions Class

[image]

Revit 2013 API
ImageExportOptions Class
Members See Also Send Feedback
This class defines options for exporting views and sheets as an image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ImageExportOptions : IDisposable
Visual Basic
Public Class ImageExportOptions _
    Implements IDisposable
Visual C++
public ref class ImageExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ImageExportOptions

See Also

ImageExportOptions Members


ImageExportOptions Members

[image] [image]

Revit 2013 API
ImageExportOptions Members
ImageExportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ImageExportOptions | Constructs a new instance of the options class used to produce images.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ImageExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ImageExportOptions Constructor

[image]

Revit 2013 API
ImageExportOptions Constructor
ImageExportOptions Class See Also Send Feedback
Constructs a new instance of the options class used to produce images.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
ImageExportOptions()

See Also

ImageExportOptions Class


ImageExportOptions Methods

[image] [image]

Revit 2013 API
ImageExportOptions Methods
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewsAndSheets | Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
 | IsValidFileName | Verify if File name is valid
 | IsValidForSaveToProjectAsImage | Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method | SetViewsAndSheets | Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageExportOptions Class


Dispose Method

[image]

Revit 2013 API
ImageExportOptions..::..Dispose Method
ImageExportOptions Class See Also Send Feedback
Releases all resources used by the ImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ImageExportOptions Class


GetViewsAndSheets Method

[image]

Revit 2013 API
ImageExportOptions..::..GetViewsAndSheets Method
ImageExportOptions Class See Also Send Feedback
Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetViewsAndSheets()
Visual Basic
Public Function GetViewsAndSheets As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetViewsAndSheets()

Return Value

The ids of the views and sheets.

See Also

ImageExportOptions Class


IsValidFileName Method

[image]

Revit 2013 API
ImageExportOptions..::..IsValidFileName Method
ImageExportOptions Class See Also Send Feedback
Verify if File name is valid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidFileName(
    string filePath
)
Visual Basic
Public Shared Function IsValidFileName ( _
    filePath As String _
) As Boolean
Visual C++
public:
static bool IsValidFileName(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
File path to be tested for valid file name

Return Value

True if File name is valid; false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ImageExportOptions Class


IsValidForSaveToProjectAsImage Method

[image]

Revit 2013 API
ImageExportOptions..::..IsValidForSaveToProjectAsImage Method
ImageExportOptions Class See Also Send Feedback
Verify if ImageExportOptions object is valid for calling saveToProjectAsImage

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions options,
    Document doc
)
Visual Basic
Public Shared Function IsValidForSaveToProjectAsImage ( _
    options As ImageExportOptions, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsValidForSaveToProjectAsImage(
    ImageExportOptions^ options,
    Document^ doc
)

Parameters

options
Type: Autodesk.Revit.DB..::..ImageExportOptions
ImageExportOptions object to be validated
doc
Type: Autodesk.Revit.DB..::..Document
Document for view name verification

Return Value

True if ImageExportOptions object is valid for calling saveToProjectAsImage; false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ImageExportOptions Class


SetViewsAndSheets Method

[image]

Revit 2013 API
ImageExportOptions..::..SetViewsAndSheets Method
ImageExportOptions Class See Also Send Feedback
Sets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetViewsAndSheets(
    IList<ElementId> viewsAndSheets
)
Visual Basic
Public Sub SetViewsAndSheets ( _
    viewsAndSheets As IList(Of ElementId) _
)
Visual C++
public:
void SetViewsAndSheets(
    IList<ElementId^>^ viewsAndSheets
)

Parameters

viewsAndSheets
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ids of the views and sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ImageExportOptions Class


ImageExportOptions Properties

[image] [image]

Revit 2013 API
ImageExportOptions Properties
ImageExportOptions Class See Also Send Feedback

The ImageExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportRange | The export range defining which view(s) will be exported.
Public property | FilePath | The file name and path for the exported file.
Public property | FitDirection | The fit direction. Used only if ZoomType is FitToPage.
Public property | HLRandWFViewsFileType | File type for exported HLR and wireframe views.
Public property | ImageResolution | The image resolution in dots per inch.
Public property | PixelSize | The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property | ShadowViewsFileType | The file type for exported shadow views.
Public property | ShouldCreateWebSite | Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property | ViewName | The name of the view to be created.
Public property | Zoom | The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property | ZoomType | The zoom type, which defines how the image size is determined.

See Also

ImageExportOptions Class


ExportRange Property

[image]

Revit 2013 API
ImageExportOptions..::..ExportRange Property
ImageExportOptions Class See Also Send Feedback
The export range defining which view(s) will be exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ExportRange ExportRange { get; set; }
Visual Basic
Public Property ExportRange As ExportRange
    Get
    Set
Visual C++
public:
property ExportRange ExportRange {
    ExportRange get ();
    void set (ExportRange value);
}

Remarks

Note that SetOfViews is not an acceptable value if these options are used to save an image to a project as a new view.

See Also

ImageExportOptions Class


FilePath Property

[image]

Revit 2013 API
ImageExportOptions..::..FilePath Property
ImageExportOptions Class See Also Send Feedback
The file name and path for the exported file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string FilePath { get; set; }
Visual Basic
Public Property FilePath As String
    Get
    Set
Visual C++
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Remarks

If ExportRange is SetOfViews, the name of each view or sheet will be appended to the name provided for each exported file. This field is ignored if used to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ImageExportOptions Class


FitDirection Property

[image]

Revit 2013 API
ImageExportOptions..::..FitDirection Property
ImageExportOptions Class See Also Send Feedback
The fit direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FitDirectionType FitDirection { get; set; }
Visual Basic
Public Property FitDirection As FitDirectionType
    Get
    Set
Visual C++
public:
property FitDirectionType FitDirection {
    FitDirectionType get ();
    void set (FitDirectionType value);
}

Remarks

The default is Horizontal.

See Also

ImageExportOptions Class


HLRandWFViewsFileType Property

[image]

Revit 2013 API
ImageExportOptions..::..HLRandWFViewsFileType Property
ImageExportOptions Class See Also Send Feedback
File type for exported HLR and wireframe views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageFileType HLRandWFViewsFileType { get; set; }
Visual Basic
Public Property HLRandWFViewsFileType As ImageFileType
    Get
    Set
Visual C++
public:
property ImageFileType HLRandWFViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ImageResolution Property

[image]

Revit 2013 API
ImageExportOptions..::..ImageResolution Property
ImageExportOptions Class See Also Send Feedback
The image resolution in dots per inch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageResolution ImageResolution { get; set; }
Visual Basic
Public Property ImageResolution As ImageResolution
    Get
    Set
Visual C++
public:
property ImageResolution ImageResolution {
    ImageResolution get ();
    void set (ImageResolution value);
}

Remarks

The default is DPI_72.

See Also

ImageExportOptions Class


PixelSize Property

[image]

Revit 2013 API
ImageExportOptions..::..PixelSize Property
ImageExportOptions Class See Also Send Feedback
The pixel size of an image in one direction. Used only if ZoomType is FitToPage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int PixelSize { get; set; }
Visual Basic
Public Property PixelSize As Integer
    Get
    Set
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

Remarks

The default is 512 pixels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The PixelSize value is outside the permitted range.

See Also

ImageExportOptions Class


ShadowViewsFileType Property

[image]

Revit 2013 API
ImageExportOptions..::..ShadowViewsFileType Property
ImageExportOptions Class See Also Send Feedback
The file type for exported shadow views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageFileType ShadowViewsFileType { get; set; }
Visual Basic
Public Property ShadowViewsFileType As ImageFileType
    Get
    Set
Visual C++
public:
property ImageFileType ShadowViewsFileType {
    ImageFileType get ();
    void set (ImageFileType value);
}

Remarks

The default is JPEGMedium. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ShouldCreateWebSite Property

[image]

Revit 2013 API
ImageExportOptions..::..ShouldCreateWebSite Property
ImageExportOptions Class See Also Send Feedback
Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShouldCreateWebSite { get; set; }
Visual Basic
Public Property ShouldCreateWebSite As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldCreateWebSite {
    bool get ();
    void set (bool value);
}

Remarks

The default is false. This field is ignored if used to save an image to a project as a new view.

See Also

ImageExportOptions Class


ViewName Property

[image]

Revit 2013 API
ImageExportOptions..::..ViewName Property
ImageExportOptions Class See Also Send Feedback
The name of the view to be created.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string ViewName { get; set; }
Visual Basic
Public Property ViewName As String
    Get
    Set
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Remarks

This field is used only to save an image to a project as a new view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ImageExportOptions Class


Zoom Property

[image]

Revit 2013 API
ImageExportOptions..::..Zoom Property
ImageExportOptions Class See Also Send Feedback
The value for Zoom (as a percentage). Used only when ZoomType is Zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Zoom { get; set; }
Visual Basic
Public Property Zoom As Integer
    Get
    Set
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Remarks

The default is 50.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The Zoom value is outside the permitted range.

See Also

ImageExportOptions Class


ZoomType Property

[image]

Revit 2013 API
ImageExportOptions..::..ZoomType Property
ImageExportOptions Class See Also Send Feedback
The zoom type, which defines how the image size is determined.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ZoomFitType ZoomType { get; set; }
Visual Basic
Public Property ZoomType As ZoomFitType
    Get
    Set
Visual C++
public:
property ZoomFitType ZoomType {
    ZoomFitType get ();
    void set (ZoomFitType value);
}

Remarks

The default is FitToPage.

See Also

ImageExportOptions Class


ImageFileType Enumeration

[image]

Revit 2013 API
ImageFileType Enumeration
See Also Send Feedback
This enum is used to define exported file type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ImageFileType
Visual Basic
Public Enumeration ImageFileType
Visual C++
public enum class ImageFileType

Members

Member name | Description
BMP | BMP
JPEGLossless | JPEG with high quality picture
JPEGMedium | JPEG with medium quality picture
JPEGSmallest | JPEG with lower quality picture and small file size
PNG | PNG
TARGA | TARGA
TIFF | TIFF

See Also


ImageImportOptions Class

[image]

Revit 2013 API
ImageImportOptions Class
Members See Also Send Feedback
Import options specific image (bitmap) formats.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ImageImportOptions : GenericImportOptions
Visual Basic
Public Class ImageImportOptions _
    Inherits GenericImportOptions
Visual C++
public ref class ImageImportOptions : public GenericImportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GenericImportOptions
Autodesk.Revit.DB..::..ImageImportOptions

See Also

ImageImportOptions Members


ImageImportOptions Members

[image] [image]

Revit 2013 API
ImageImportOptions Members
ImageImportOptions Class Constructors Methods Properties See Also Send Feedback

The ImageImportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ImageImportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Placement | Placement mode defines by which point is the image going to be inserted.
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public property | Resolution | Resolution [ppi] of the image to be imported.

See Also

ImageImportOptions Class


ImageImportOptions Constructor

[image]

Revit 2013 API
ImageImportOptions Constructor
ImageImportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageImportOptions()
Visual Basic
Public Sub New
Visual C++
public:
ImageImportOptions()

See Also

ImageImportOptions Class


ImageImportOptions Methods

[image] [image]

Revit 2013 API
ImageImportOptions Methods
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageImportOptions Class


ImageImportOptions Properties

[image] [image]

Revit 2013 API
ImageImportOptions Properties
ImageImportOptions Class See Also Send Feedback

The ImageImportOptions type exposes the following members.

Properties

 | Name | Description
Public property | Placement | Placement mode defines by which point is the image going to be inserted.
Public property | RefPoint | Reference point (in Revit) to which the image is going to be inserted. (Inherited from GenericImportOptions.)
Public property | Resolution | Resolution [ppi] of the image to be imported.

See Also

ImageImportOptions Class


Placement Property

[image]

Revit 2013 API
ImageImportOptions..::..Placement Property
ImageImportOptions Class See Also Send Feedback
Placement mode defines by which point is the image going to be inserted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoxPlacement Placement { get; set; }
Visual Basic
Public Property Placement As BoxPlacement
    Get
    Set
Visual C++
public:
property BoxPlacement Placement {
    BoxPlacement get ();
    void set (BoxPlacement value);
}

See Also

ImageImportOptions Class


Resolution Property

[image]

Revit 2013 API
ImageImportOptions..::..Resolution Property
ImageImportOptions Class See Also Send Feedback
Resolution [ppi] of the image to be imported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ushort Resolution { get; set; }
Visual Basic
Public Property Resolution As UShort
    Get
    Set
Visual C++
public:
property unsigned short Resolution {
    unsigned short get ();
    void set (unsigned short value);
}

See Also

ImageImportOptions Class


ImageResolution Enumeration

[image]

Revit 2013 API
ImageResolution Enumeration
See Also Send Feedback
This enum is used to define image resolution in order to calculate the image size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ImageResolution
Visual Basic
Public Enumeration ImageResolution
Visual C++
public enum class ImageResolution

Members

Member name | Description
DPI_72 | 72 dpi
DPI_150 | 150 dpi
DPI_300 | 300 dpi
DPI_600 | 600 dpi

Remarks

This is used only if the Zoom option for ZoomType is set.

See Also


ImageView Class

[image]

Revit 2013 API
ImageView Class
Members See Also Send Feedback
Class for ImageView views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ImageView : ViewDrafting
Visual Basic
Public Class ImageView _
    Inherits ViewDrafting
Visual C++
public ref class ImageView : public ViewDrafting

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewDrafting
Autodesk.Revit.DB..::..ImageView

See Also

ImageView Members


ImageView Members

[image] [image]

Revit 2013 API
ImageView Members
ImageView Class Methods Properties See Also Send Feedback

The ImageView type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | Create | Create an ImageView containing an image imported from disk.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | ImageInstanceId | Id of the image in the view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImageView Class


ImageView Methods

[image] [image]

Revit 2013 API
ImageView Methods
ImageView Class See Also Send Feedback

The ImageView type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | Create | Create an ImageView containing an image imported from disk.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ImageView Class


Create Method

[image]

Revit 2013 API
ImageView..::..Create Method
ImageView Class See Also Send Feedback
Create an ImageView containing an image imported from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ImageView Create(
    Document document,
    string imageFileName
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    imageFileName As String _
) As ImageView
Visual C++
public:
static ImageView^ Create(
    Document^ document,
    String^ imageFileName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the view.
imageFileName
Type: System..::..String
The full path to the image file.

Return Value

The newly created view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ImageView Class


Print Method

[image] [image]

Revit 2013 API
ImageView..::..Print Method
ImageView Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ImageView Class
ImageView Members


ImageView Properties

[image] [image]

Revit 2013 API
ImageView Properties
ImageView Class See Also Send Feedback

The ImageView type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | ImageInstanceId | Id of the image in the view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImageView Class


ImageInstanceId Property

[image]

Revit 2013 API
ImageView..::..ImageInstanceId Property
ImageView Class See Also Send Feedback
Id of the image in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId ImageInstanceId { get; }
Visual Basic
Public ReadOnly Property ImageInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ ImageInstanceId {
    ElementId^ get ();
}

See Also

ImageView Class


Parameter Property

[image] [image]

Revit 2013 API
ImageView..::..Parameter Property
ImageView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImageView Class
ImageView Members


ImportColorMode Enumeration

[image]

Revit 2013 API
ImportColorMode Enumeration
See Also Send Feedback
An enumerated type listing how colors are handled in an import process.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ImportColorMode
Visual Basic
Public Enumeration ImportColorMode
Visual C++
public enum class ImportColorMode

Members

Member name | Description
Preserved | Colors in the imported drawing are preserved.
Inverted | Colors in the imported drawing are inverted.
BlackAndWhite | Colors in the imported drawing are converted to Black and White.

See Also


ImportExportFileFormat Enumeration

[image]

Revit 2013 API
ImportExportFileFormat Enumeration
See Also Send Feedback
Describes formats supported by import / export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public enum ImportExportFileFormat
Visual Basic
Public Enumeration ImportExportFileFormat
Visual C++
public enum class ImportExportFileFormat

Members

Member name | Description
DWG | DWG format
DWF | DWF format
DWFX | DWFX format
GBXML | GBXML format
FBX | FBX format
Image | Image format
DGN | DGN format
Civil3D | Civel3D format
Inventor | Inventor format
DXF | DXF format
SAT | SAT format
IFC | IFC format

See Also


ImportInstance Class

[image]

Revit 2013 API
ImportInstance Class
Members See Also Send Feedback
An element created during either import or link operation in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ImportInstance : Instance
Visual Basic
Public Class ImportInstance _
    Inherits Instance
Visual C++
public ref class ImportInstance : public Instance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..ImportInstance

See Also

ImportInstance Members


ImportInstance Members

[image] [image]

Revit 2013 API
ImportInstance Members
ImportInstance Class Methods Properties See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImportInstance Class


ImportInstance Methods

[image] [image]

Revit 2013 API
ImportInstance Methods
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the import instance in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the import instance in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImportInstance Class


GetVisibility Method

[image]

Revit 2013 API
ImportInstance..::..GetVisibility Method
ImportInstance Class See Also Send Feedback
Gets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the import instance in a family document.

See Also

ImportInstance Class


SetVisibility Method

[image]

Revit 2013 API
ImportInstance..::..SetVisibility Method
ImportInstance Class See Also Send Feedback
Sets the visibility for the import instance in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the import instance geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed, or the import instance is in a project document.

See Also

ImportInstance Class


ImportInstance Properties

[image] [image]

Revit 2013 API
ImportInstance Properties
ImportInstance Class See Also Send Feedback

The ImportInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLinked | Identifies whether this instance is a linked object rather than imported one.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ImportInstance Class


IsLinked Property

[image]

Revit 2013 API
ImportInstance..::..IsLinked Property
ImportInstance Class See Also Send Feedback
Identifies whether this instance is a linked object rather than imported one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsLinked { get; }
Visual Basic
Public ReadOnly Property IsLinked As Boolean
    Get
Visual C++
public:
property bool IsLinked {
    bool get ();
}

Remarks

True if the instance was imported as a link to an external file. False if the instance was imported as a copy of data from an external file.

See Also

ImportInstance Class


Parameter Property

[image] [image]

Revit 2013 API
ImportInstance..::..Parameter Property
ImportInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ImportInstance Class
ImportInstance Members


ImportPlacement Enumeration

[image]

Revit 2013 API
ImportPlacement Enumeration
See Also Send Feedback
An enumerated type listing possible placement modes for imported drawings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ImportPlacement
Visual Basic
Public Enumeration ImportPlacement
Visual C++
public enum class ImportPlacement

Members

Member name | Description
Site | Placement at Base Point. There must be a reference point in order for this option to be valid.
Origin | Placement at the Origin. If reference point is provided, then the import is placed so the point is at the model's origin. If no point is provided, then the document's origin is matched with the model's origin.
Centered | Placement at the Center. If reference point is provided, then the import is placed so the point is at the model's center. If no point is provided, then the document's center is matched with the model's origin.
Shared | Placement with respect to the shared coordinates. Revit Building places the imported geometry according to its location with respect to the shared coordinates between the two files. There must be shared coordinates in a Revit document in order for this option to be valid.

See Also


ImportUnit Enumeration

[image]

Revit 2013 API
ImportUnit Enumeration
See Also Send Feedback
An enumerated type listing possible target units for CAD Import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ImportUnit
Visual Basic
Public Enumeration ImportUnit
Visual C++
public enum class ImportUnit

Members

Member name | Description
Default | Unit (if available) from the document that is getting imported.
Foot | Feet and Inches in fractional notation.
Inch | Inches in fractional notation.
Meter | Meters as decimal values.
Decimeter | Decimeters as decimal values.
Centimeter | Centimeters as decimal values.
Millimeter | Millimeters as decimal values.
Custom | Custom values as decimal values

See Also


IndependentTag Class

[image]

Revit 2013 API
IndependentTag Class
Members See Also Send Feedback
Represents an IndependentTag within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class IndependentTag : Element
Visual Basic
Public Class IndependentTag _
    Inherits Element
Visual C++
public ref class IndependentTag : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..IndependentTag
Autodesk.Revit.DB.Structure..::..FabricReinSpanSymbol

See Also

IndependentTag Members


IndependentTag Members

[image] [image]

Revit 2013 API
IndependentTag Members
IndependentTag Class Methods Properties See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be assigned.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTaggedLocalElement | Get the tagged local element if any.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Whether the tag has a leader or not.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | LeaderElbow | Returns the position of the elbow of leader.
Public property | LeaderEnd | Returns the position of the end of leader.
Public property | LeaderEndCondition | The leader end condition of the tag.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TaggedElementId | The LinkElementId of the tagged element.
Public property | TaggedLocalElementId | The id of the tagged local element if any.
Public property | TagHeadPosition | Returns the position of the head of tag.
Public property | TagOrientation | The tag orientation of the tag.
Public property | TagText | Returns the text of the Tag.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

IndependentTag Class


IndependentTag Methods

[image] [image]

Revit 2013 API
IndependentTag Methods
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be assigned.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTaggedLocalElement | Get the tagged local element if any.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IndependentTag Class


CanLeaderEndConditionBeAssigned Method

[image]

Revit 2013 API
IndependentTag..::..CanLeaderEndConditionBeAssigned Method
IndependentTag Class See Also Send Feedback
Checks whether the LeaderEndCondition can be assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)
Visual Basic
Public Function CanLeaderEndConditionBeAssigned ( _
    leaderEndCondition As LeaderEndCondition _
) As Boolean
Visual C++
public:
bool CanLeaderEndConditionBeAssigned(
    LeaderEndCondition leaderEndCondition
)

Parameters

leaderEndCondition
Type: Autodesk.Revit.DB..::..LeaderEndCondition
The leader end condition to check.

Return Value

True if the leader end condition of the tag can be assigned, or false otherwise.

See Also

IndependentTag Class


GetTaggedLocalElement Method

[image]

Revit 2013 API
IndependentTag..::..GetTaggedLocalElement Method
IndependentTag Class See Also Send Feedback
Get the tagged local element if any.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element GetTaggedLocalElement()
Visual Basic
Public Function GetTaggedLocalElement As Element
Visual C++
public:
Element^ GetTaggedLocalElement()

Return Value

The tagged local element, or nullNothingnullptra null reference (Nothing in Visual Basic) for orphan tags and tagged elements in links.

See Also

IndependentTag Class


IndependentTag Properties

[image] [image]

Revit 2013 API
IndependentTag Properties
IndependentTag Class See Also Send Feedback

The IndependentTag type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Whether the tag has a leader or not.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not.
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not.
Public property | IsOrphaned | Identifies if the tag is orphaned or not.
Public property | LeaderElbow | Returns the position of the elbow of leader.
Public property | LeaderEnd | Returns the position of the end of leader.
Public property | LeaderEndCondition | The leader end condition of the tag.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TaggedElementId | The LinkElementId of the tagged element.
Public property | TaggedLocalElementId | The id of the tagged local element if any.
Public property | TagHeadPosition | Returns the position of the head of tag.
Public property | TagOrientation | The tag orientation of the tag.
Public property | TagText | Returns the text of the Tag.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

IndependentTag Class


HasLeader Property

[image]

Revit 2013 API
IndependentTag..::..HasLeader Property
IndependentTag Class See Also Send Feedback
Whether the tag has a leader or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasLeader { get; set; }
Visual Basic
Public Property HasLeader As Boolean
    Get
    Set
Visual C++
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}

Field Value

True if the tag has a leader, or false otherwise.

See Also

IndependentTag Class


IsMaterialTag Property

[image]

Revit 2013 API
IndependentTag..::..IsMaterialTag Property
IndependentTag Class See Also Send Feedback
Identifies if it is a material tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsMaterialTag { get; }
Visual Basic
Public ReadOnly Property IsMaterialTag As Boolean
    Get
Visual C++
public:
property bool IsMaterialTag {
    bool get ();
}

See Also

IndependentTag Class


IsMulticategoryTag Property

[image]

Revit 2013 API
IndependentTag..::..IsMulticategoryTag Property
IndependentTag Class See Also Send Feedback
Identifies if it is a multi-category tag or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsMulticategoryTag { get; }
Visual Basic
Public ReadOnly Property IsMulticategoryTag As Boolean
    Get
Visual C++
public:
property bool IsMulticategoryTag {
    bool get ();
}

See Also

IndependentTag Class


IsOrphaned Property

[image]

Revit 2013 API
IndependentTag..::..IsOrphaned Property
IndependentTag Class See Also Send Feedback
Identifies if the tag is orphaned or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsOrphaned { get; }
Visual Basic
Public ReadOnly Property IsOrphaned As Boolean
    Get
Visual C++
public:
property bool IsOrphaned {
    bool get ();
}

Remarks

Orphans are those tags that are associated with an instance of a linked Revit file but have no host element. Tags become orphaned when the element they were tagging was deleted from the link.

See Also

IndependentTag Class


LeaderElbow Property

[image]

Revit 2013 API
IndependentTag..::..LeaderElbow Property
IndependentTag Class See Also Send Feedback
Returns the position of the elbow of leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ LeaderElbow { get; set; }
Visual Basic
Public Property LeaderElbow As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LeaderElbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Elbow of the Tag Leader.

Remarks

This property retrieves the elbow position of Tag Leader.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | If there is no leader for this tag or the leader is straight, the InvalidOperationException will be thrown.

See Also

IndependentTag Class


LeaderEnd Property

[image]

Revit 2013 API
IndependentTag..::..LeaderEnd Property
IndependentTag Class See Also Send Feedback
Returns the position of the end of leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ LeaderEnd { get; set; }
Visual Basic
Public Property LeaderEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LeaderEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the end of the Tag Leader.

Remarks

This property retrieves the end position of Tag Leader, which tie to the Host obj. And ONLY Material Tag support Set operation!

See Also

IndependentTag Class


LeaderEndCondition Property

[image]

Revit 2013 API
IndependentTag..::..LeaderEndCondition Property
IndependentTag Class See Also Send Feedback
The leader end condition of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LeaderEndCondition LeaderEndCondition { get; set; }
Visual Basic
Public Property LeaderEndCondition As LeaderEndCondition
    Get
    Set
Visual C++
public:
property LeaderEndCondition LeaderEndCondition {
    LeaderEndCondition get ();
    void set (LeaderEndCondition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: LeaderEndCondition cannot be assigned.

See Also

IndependentTag Class


Parameter Property

[image] [image]

Revit 2013 API
IndependentTag..::..Parameter Property
IndependentTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

IndependentTag Class
IndependentTag Members


TaggedElementId Property

[image]

Revit 2013 API
IndependentTag..::..TaggedElementId Property
IndependentTag Class See Also Send Feedback
The LinkElementId of the tagged element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinkElementId TaggedElementId { get; }
Visual Basic
Public ReadOnly Property TaggedElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ TaggedElementId {
    LinkElementId^ get ();
}

Remarks

If there is no tagged element because the tag is orphaned, LinkElementId.HostElementId, LinkElementId.LinkElementId and LinkElementId.LinkInstanceId will be InvalidElementId.

See Also

IndependentTag Class


TaggedLocalElementId Property

[image]

Revit 2013 API
IndependentTag..::..TaggedLocalElementId Property
IndependentTag Class See Also Send Feedback
The id of the tagged local element if any.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId TaggedLocalElementId { get; }
Visual Basic
Public ReadOnly Property TaggedLocalElementId As ElementId
    Get
Visual C++
public:
property ElementId^ TaggedLocalElementId {
    ElementId^ get ();
}

Field Value

The id of the tagged element in the local document. The value will be InvalidElementId when the tagged element is in a linked document or when there is no tagged element because the tag IsOrphaned.

See Also

IndependentTag Class


TagHeadPosition Property

[image]

Revit 2013 API
IndependentTag..::..TagHeadPosition Property
IndependentTag Class See Also Send Feedback
Returns the position of the head of tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ TagHeadPosition { get; set; }
Visual Basic
Public Property TagHeadPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ TagHeadPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Return Value

Return the Head Position of the Tag.

Remarks

This property retrieves the head position of tag head.

See Also

IndependentTag Class


TagOrientation Property

[image]

Revit 2013 API
IndependentTag..::..TagOrientation Property
IndependentTag Class See Also Send Feedback
The tag orientation of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TagOrientation TagOrientation { get; set; }
Visual Basic
Public Property TagOrientation As TagOrientation
    Get
    Set
Visual C++
public:
property TagOrientation TagOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

See Also

IndependentTag Class


TagText Property

[image]

Revit 2013 API
IndependentTag..::..TagText Property
IndependentTag Class See Also Send Feedback
Returns the text of the Tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string TagText { get; }
Visual Basic
Public ReadOnly Property TagText As String
    Get
Visual C++
public:
property String^ TagText {
    String^ get ();
}

Return Value

Return the text of the Tag.

Remarks

This property retrieves the text of the Tag.

See Also

IndependentTag Class


InsertableObject Class

[image]

Revit 2013 API
InsertableObject Class
Members See Also Send Feedback
A base class you all types that are insertable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InsertableObject : ElementType
Visual Basic
Public Class InsertableObject _
    Inherits ElementType
Visual C++
public ref class InsertableObject : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol

See Also

InsertableObject Members


InsertableObject Members

[image] [image]

Revit 2013 API
InsertableObject Members
InsertableObject Class Methods Properties See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsertableObject Class


InsertableObject Methods

[image] [image]

Revit 2013 API
InsertableObject Methods
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertableObject Class


InsertableObject Properties

[image] [image]

Revit 2013 API
InsertableObject Properties
InsertableObject Class See Also Send Feedback

The InsertableObject type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsertableObject Class


Parameter Property

[image] [image]

Revit 2013 API
InsertableObject..::..Parameter Property
InsertableObject Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

InsertableObject Class
InsertableObject Members


InSessionPrintSetting Class

[image]

Revit 2013 API
InSessionPrintSetting Class
Members See Also Send Feedback
Represents the in-session Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InSessionPrintSetting : IPrintSetting
Visual Basic
Public Class InSessionPrintSetting _
    Implements IPrintSetting
Visual C++
public ref class InSessionPrintSetting : IPrintSetting

Remarks

The in-session PrintSetting can't be stored in document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InSessionPrintSetting

See Also

InSessionPrintSetting Members


InSessionPrintSetting Members

[image] [image]

Revit 2013 API
InSessionPrintSetting Members
InSessionPrintSetting Class Methods Properties See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


InSessionPrintSetting Methods

[image] [image]

Revit 2013 API
InSessionPrintSetting Methods
InSessionPrintSetting Class See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InSessionPrintSetting Class


InSessionPrintSetting Properties

[image] [image]

Revit 2013 API
InSessionPrintSetting Properties
InSessionPrintSetting Class See Also Send Feedback

The InSessionPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

InSessionPrintSetting Class


PrintParameters Property

[image]

Revit 2013 API
InSessionPrintSetting..::..PrintParameters Property
InSessionPrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PrintParameters PrintParameters { get; }
Visual Basic
Public Overridable ReadOnly Property PrintParameters As PrintParameters
    Get
Visual C++
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Implements

IPrintSetting..::..PrintParameters

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

InSessionPrintSetting Class


InSessionViewSheetSet Class

[image]

Revit 2013 API
InSessionViewSheetSet Class
Members See Also Send Feedback
Represents the in-session ViewSheetSet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InSessionViewSheetSet : IViewSheetSet
Visual Basic
Public Class InSessionViewSheetSet _
    Implements IViewSheetSet
Visual C++
public ref class InSessionViewSheetSet : IViewSheetSet

Remarks

The in-session ViewSheetSet can't be stored in document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InSessionViewSheetSet

See Also

InSessionViewSheetSet Members


InSessionViewSheetSet Members

[image] [image]

Revit 2013 API
InSessionViewSheetSet Members
InSessionViewSheetSet Class Methods Properties See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Views | The views.

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Methods

[image] [image]

Revit 2013 API
InSessionViewSheetSet Methods
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InSessionViewSheetSet Class


InSessionViewSheetSet Properties

[image] [image]

Revit 2013 API
InSessionViewSheetSet Properties
InSessionViewSheetSet Class See Also Send Feedback

The InSessionViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | Views | The views.

See Also

InSessionViewSheetSet Class


Views Property

[image]

Revit 2013 API
InSessionViewSheetSet..::..Views Property
InSessionViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic
Public Overridable Property Views As ViewSet
    Get
    Set
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::..Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

InSessionViewSheetSet Class


Instance Class

[image]

Revit 2013 API
Instance Class
Members See Also Send Feedback
The base class for all instance objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Instance : Element
Visual Basic
Public Class Instance _
    Inherits Element
Visual C++
public ref class Instance : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..ImportInstance
Autodesk.Revit.DB..::..PointCloudInstance
Autodesk.Revit.DB..::..ProjectLocation
Autodesk.Revit.DB..::..RevitLinkInstance

See Also

Instance Members


Instance Members

[image] [image]

Revit 2013 API
Instance Members
Instance Class Methods Properties See Also Send Feedback

The Instance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Instance Class


Instance Methods

[image] [image]

Revit 2013 API
Instance Methods
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances.
Public method | GetTransform | Gets the transform of the instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Instance Class


GetTotalTransform Method

[image]

Revit 2013 API
Instance..::..GetTotalTransform Method
Instance Class See Also Send Feedback
Gets the total transform, which includes the true north transform for instances like import instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform GetTotalTransform()
Visual Basic
Public Function GetTotalTransform As Transform
Visual C++
public:
Transform^ GetTotalTransform()

Return Value

The calculated total transform.

Remarks

For most of other instances, it simply returns the inherent transform.

See Also

Instance Class


GetTransform Method

[image]

Revit 2013 API
Instance..::..GetTransform Method
Instance Class See Also Send Feedback
Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform GetTransform()
Visual Basic
Public Function GetTransform As Transform
Visual C++
public:
Transform^ GetTransform()

Return Value

The inherent transform.

See Also

Instance Class


Instance Properties

[image] [image]

Revit 2013 API
Instance Properties
Instance Class See Also Send Feedback

The Instance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Instance Class


Parameter Property

[image] [image]

Revit 2013 API
Instance..::..Parameter Property
Instance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Instance Class
Instance Members


InstanceArray Class

[image]

Revit 2013 API
InstanceArray Class
Members See Also Send Feedback
An array that contains instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InstanceArray : APIObject,
    IEnumerable
Visual Basic
Public Class InstanceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InstanceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..InstanceArray

See Also

InstanceArray Members


InstanceArray Members

[image] [image]

Revit 2013 API
InstanceArray Members
InstanceArray Class Constructors Methods Properties See Also Send Feedback

The InstanceArray type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceArray | Initializes a new instance of the InstanceArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every instance from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an instance at a specified index within the array.
Public property | Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class


InstanceArray Constructor

[image]

Revit 2013 API
InstanceArray Constructor
InstanceArray Class See Also Send Feedback
Initializes a new instance of the InstanceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceArray()
Visual Basic
Public Sub New
Visual C++
public:
InstanceArray()

See Also

InstanceArray Class


InstanceArray Methods

[image] [image]

Revit 2013 API
InstanceArray Methods
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every instance from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArray Class


Append Method

[image]

Revit 2013 API
InstanceArray..::..Append Method
InstanceArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    GeometryInstance item
)
Visual Basic
Public Overridable Sub Append ( _
    item As GeometryInstance _
)
Visual C++
public:
virtual void Append(
    GeometryInstance^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeometryInstance

See Also

InstanceArray Class


Clear Method

[image]

Revit 2013 API
InstanceArray..::..Clear Method
InstanceArray Class See Also Send Feedback
Removes every instance from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InstanceArray Class


ForwardIterator Method

[image]

Revit 2013 API
InstanceArray..::..ForwardIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

InstanceArray Class


GetEnumerator Method

[image]

Revit 2013 API
InstanceArray..::..GetEnumerator Method
InstanceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InstanceArray Class


Insert Method

[image]

Revit 2013 API
InstanceArray..::..Insert Method
InstanceArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    GeometryInstance item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As GeometryInstance, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    GeometryInstance^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..GeometryInstance
index
Type: System..::..Int32

See Also

InstanceArray Class


ReverseIterator Method

[image]

Revit 2013 API
InstanceArray..::..ReverseIterator Method
InstanceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual InstanceArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As InstanceArrayIterator
Visual C++
public:
virtual InstanceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

InstanceArray Class


InstanceArray Properties

[image] [image]

Revit 2013 API
InstanceArray Properties
InstanceArray Class See Also Send Feedback

The InstanceArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an instance at a specified index within the array.
Public property | Size | Returns the number of instances that are in the array.

See Also

InstanceArray Class


IsEmpty Property

[image]

Revit 2013 API
InstanceArray..::..IsEmpty Property
InstanceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

InstanceArray Class


Item Property

[image]

Revit 2013 API
InstanceArray..::..Item Property
InstanceArray Class See Also Send Feedback
Gets or sets an instance at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GeometryInstance this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As GeometryInstance
    Get
    Set
Visual C++
public:
virtual property GeometryInstance^ Item[int index] {
    GeometryInstance^ get (int index);
    void set (int index, GeometryInstance^ value);
}

Parameters

index
Type: System..::..Int32
The index of the instance to be set or retrieved.

Return Value

Returns the instance at the specified index.

See Also

InstanceArray Class


Size Property

[image]

Revit 2013 API
InstanceArray..::..Size Property
InstanceArray Class See Also Send Feedback
Returns the number of instances that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InstanceArray Class


InstanceArrayIterator Class

[image]

Revit 2013 API
InstanceArrayIterator Class
Members See Also Send Feedback
An iterator to an instance array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class InstanceArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class InstanceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InstanceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..InstanceArrayIterator

See Also

InstanceArrayIterator Members


InstanceArrayIterator Members

[image] [image]

Revit 2013 API
InstanceArrayIterator Members
InstanceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class


InstanceArrayIterator Constructor

[image]

Revit 2013 API
InstanceArrayIterator Constructor
InstanceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
InstanceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

InstanceArrayIterator Class


InstanceArrayIterator Methods

[image] [image]

Revit 2013 API
InstanceArrayIterator Methods
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
InstanceArrayIterator..::..MoveNext Method
InstanceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class


Reset Method

[image]

Revit 2013 API
InstanceArrayIterator..::..Reset Method
InstanceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

InstanceArrayIterator Class


InstanceArrayIterator Properties

[image] [image]

Revit 2013 API
InstanceArrayIterator Properties
InstanceArrayIterator Class See Also Send Feedback

The InstanceArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceArrayIterator Class


Current Property

[image]

Revit 2013 API
InstanceArrayIterator..::..Current Property
InstanceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

InstanceArrayIterator Class


InstanceBinding Class

[image]

Revit 2013 API
InstanceBinding Class
Members Example See Also Send Feedback
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InstanceBinding : ElementBinding
Visual Basic
Public Class InstanceBinding _
    Inherits ElementBinding
Visual C++
public ref class InstanceBinding : public ElementBinding

Remarks

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.

Examples

CopyC#
public bool SetNewParameterToInstanceWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters1");

    // create an instance definition in definition group MyParameters
    Definition myDefinition_ProductDate =
       myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text);

    // create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveUIDocument.Document.Settings.Categories.get_Item(
                                BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an instance of InstanceBinding
    InstanceBinding instanceBinding = app.Application.Create.NewInstanceBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool instanceBindOK = bindingMap.Insert(myDefinition_ProductDate,
                                    instanceBinding, BuiltInParameterGroup.PG_TEXT);
    return instanceBindOK;
}
CopyVB.NET
Public Function SetNewParameterToInsanceWall(ByVal app As UIApplication, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters1")

    ' create an instance definition in definition group MyParameters
    Dim myDefinition_ProductDate As Definition = myGroup.Definitions.Create("Instance_ProductDate", ParameterType.Text)

    ' create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
    ' use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.DB.Category = app.ActiveUIDocument.Document.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an instance of InstanceBinding
    Dim instanceBinding As InstanceBinding = app.Application.Create.NewInstanceBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

    ' Bind the definitions to the document
    Dim instanceBindOK As Boolean = bindingMap.Insert(myDefinition_ProductDate, instanceBinding, BuiltInParameterGroup.PG_TEXT)
    Return instanceBindOK
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding
Autodesk.Revit.DB..::..InstanceBinding

See Also

InstanceBinding Members


InstanceBinding Members

[image] [image]

Revit 2013 API
InstanceBinding Members
InstanceBinding Class Constructors Methods Properties See Also Send Feedback

The InstanceBinding type exposes the following members.

Constructors

 | Name | Description
Public method | InstanceBinding()()()() | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InstanceBinding Constructor

[image] [image]

Revit 2013 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InstanceBinding()()()() | Constructs an empty instance binding.
Public method | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed.

See Also

InstanceBinding Class
InstanceBinding Members


InstanceBinding Constructor

[image]

Revit 2013 API
InstanceBinding Constructor
InstanceBinding Class See Also Send Feedback
Constructs an empty instance binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceBinding()
Visual Basic
Public Sub New
Visual C++
public:
InstanceBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Constructor (CategorySet)

[image]

Revit 2013 API
InstanceBinding Constructor (CategorySet)
InstanceBinding Class See Also Send Feedback
Constructs an instance binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InstanceBinding(
    CategorySet categories
)
Visual Basic
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
InstanceBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit.DB..::..CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

InstanceBinding Class
InstanceBinding Overload


InstanceBinding Methods

[image] [image]

Revit 2013 API
InstanceBinding Methods
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceBinding Class


InstanceBinding Properties

[image] [image]

Revit 2013 API
InstanceBinding Properties
InstanceBinding Class See Also Send Feedback

The InstanceBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InstanceBinding Class


InstanceVoidCutUtils Class

[image]

Revit 2013 API
InstanceVoidCutUtils Class
Members See Also Send Feedback
Utilities for cutting elements by unattached voids in family instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class InstanceVoidCutUtils : IDisposable
Visual Basic
Public Class InstanceVoidCutUtils _
    Implements IDisposable
Visual C++
public ref class InstanceVoidCutUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..InstanceVoidCutUtils

See Also

InstanceVoidCutUtils Members


InstanceVoidCutUtils Members

[image] [image]

Revit 2013 API
InstanceVoidCutUtils Members
InstanceVoidCutUtils Class Methods See Also Send Feedback

The InstanceVoidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
 | CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
Public method | Dispose | Releases all resources used by the InstanceVoidCutUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
 | GetElementsBeingCut | Return ids of the elements being cut by the instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceVoidCutExists | Check whether the instance is cutting the element
 | IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
 | RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceVoidCutUtils Class


InstanceVoidCutUtils Methods

[image] [image]

Revit 2013 API
InstanceVoidCutUtils Methods
InstanceVoidCutUtils Class See Also Send Feedback

The InstanceVoidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddInstanceVoidCut | Add a cut to an element using the unattached voids inside a cutting instance.
 | CanBeCutWithVoid | Indicates if the element can be cut by an instance with unattached voids.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingVoidInstances | Return ids of the instances with unattached voids cutting the element.
 | GetElementsBeingCut | Return ids of the elements being cut by the instance
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceVoidCutExists | Check whether the instance is cutting the element
 | IsVoidInstanceCuttingElement | Indicates if the element is a family instance with unattached voids that can cut other elements.
 | RemoveInstanceVoidCut | Remove a cut applied to the element by a cutting instance with unattached voids.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InstanceVoidCutUtils Class


AddInstanceVoidCut Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..AddInstanceVoidCut Method
InstanceVoidCutUtils Class Example See Also Send Feedback
Add a cut to an element using the unattached voids inside a cutting instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Sub AddInstanceVoidCut ( _
    document As Document, _
    element As Element, _
    cuttingInstance As Element _
)
Visual C++
public:
static void AddInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
element
Type: Autodesk.Revit.DB..::..Element
The element to be cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Examples

CopyC#
// Cut a beam with 3 instances of a void-cutting family
// The Family Parameter "Cut with Voids When Loaded" must be true for the cutting family
void CutBeamWithFamilyVoid(Autodesk.Revit.DB.Document doc, FamilyInstance beam, FamilySymbol cuttingSymbol)
{
    LocationCurve lc = beam.Location as LocationCurve;
    Curve beamCurve = lc.Curve;

    for (int i = 1; i <= 3; i++)
    {
        XYZ beamLocation = beamCurve.Evaluate(i * 0.25, true); // position on the beam for this cutting instance
        beamLocation = beamLocation - XYZ.BasisZ; // adjust for top-aligned curve

        FamilyInstance cuttingInstance = doc.Create.NewFamilyInstance(beamLocation, cuttingSymbol, beam.Level, StructuralType.NonStructural);
        InstanceVoidCutUtils.AddInstanceVoidCut(doc, beam, cuttingInstance);
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element cannot be cut with a void instance. -or- The element is not a family instance with an unattached void that can cut.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to cut element with the instances

See Also

InstanceVoidCutUtils Class


CanBeCutWithVoid Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..CanBeCutWithVoid Method
InstanceVoidCutUtils Class See Also Send Feedback
Indicates if the element can be cut by an instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CanBeCutWithVoid(
    Element element
)
Visual Basic
Public Shared Function CanBeCutWithVoid ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool CanBeCutWithVoid(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to be cut

Return Value

Returns true if the element can be cut by an instance with unattached voids.

Remarks

Elements in a project can be cut if they are host elements or family instances with a category Generic Model or one of the structural categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InstanceVoidCutUtils Class


Dispose Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..Dispose Method
InstanceVoidCutUtils Class See Also Send Feedback
Releases all resources used by the InstanceVoidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InstanceVoidCutUtils Class


GetCuttingVoidInstances Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..GetCuttingVoidInstances Method
InstanceVoidCutUtils Class See Also Send Feedback
Return ids of the instances with unattached voids cutting the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetCuttingVoidInstances(
    Element element
)
Visual Basic
Public Shared Function GetCuttingVoidInstances ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetCuttingVoidInstances(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element being cut

Return Value

Ids of instances with unattached voids that cut this element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InstanceVoidCutUtils Class


GetElementsBeingCut Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..GetElementsBeingCut Method
InstanceVoidCutUtils Class See Also Send Feedback
Return ids of the elements being cut by the instance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetElementsBeingCut(
    Element cuttingInstance
)
Visual Basic
Public Shared Function GetElementsBeingCut ( _
    cuttingInstance As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetElementsBeingCut(
    Element^ cuttingInstance
)

Parameters

cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Return Value

Ids of elements being cut by cuttingInstance

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InstanceVoidCutUtils Class


InstanceVoidCutExists Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..InstanceVoidCutExists Method
InstanceVoidCutUtils Class See Also Send Feedback
Check whether the instance is cutting the element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool InstanceVoidCutExists(
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Function InstanceVoidCutExists ( _
    element As Element, _
    cuttingInstance As Element _
) As Boolean
Visual C++
public:
static bool InstanceVoidCutExists(
    Element^ element,
    Element^ cuttingInstance
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element being cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Return Value

Returns true if the instance is cutting the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InstanceVoidCutUtils Class


IsVoidInstanceCuttingElement Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..IsVoidInstanceCuttingElement Method
InstanceVoidCutUtils Class See Also Send Feedback
Indicates if the element is a family instance with unattached voids that can cut other elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsVoidInstanceCuttingElement(
    Element element
)
Visual Basic
Public Shared Function IsVoidInstanceCuttingElement ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsVoidInstanceCuttingElement(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Return Value

Returns true if the element is a family instance with unattached voids that can cut other elements.

Remarks

A family instance can cut if the family has unattached voids and the family's parameter "Cut with Voids When Loaded" is checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InstanceVoidCutUtils Class


RemoveInstanceVoidCut Method

[image]

Revit 2013 API
InstanceVoidCutUtils..::..RemoveInstanceVoidCut Method
InstanceVoidCutUtils Class Example See Also Send Feedback
Remove a cut applied to the element by a cutting instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveInstanceVoidCut(
    Document document,
    Element element,
    Element cuttingInstance
)
Visual Basic
Public Shared Sub RemoveInstanceVoidCut ( _
    document As Document, _
    element As Element, _
    cuttingInstance As Element _
)
Visual C++
public:
static void RemoveInstanceVoidCut(
    Document^ document,
    Element^ element,
    Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
element
Type: Autodesk.Revit.DB..::..Element
The element being cut
cuttingInstance
Type: Autodesk.Revit.DB..::..Element
The cutting family instance

Examples

CopyC#
// remove all cuts in all family instances created by void-cutting instances
void RemoveVoidCuts(Autodesk.Revit.DB.Document doc, FamilySymbol cuttingSymbol)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.WherePasses(new FamilyInstanceFilter(doc, cuttingSymbol.Id)); // find elements that are family instances of the cutting family

    foreach (FamilyInstance instance in collector)
    {
        foreach (ElementId elementId in InstanceVoidCutUtils.GetElementsBeingCut(instance)) // elements being cut by this instance of the cutting family
        {
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance); // remove the cut
        }
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No instance void cut exists between the two elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to remove the instance cut from the element

See Also

InstanceVoidCutUtils Class


InsulationLiningBase Class

[image]

Revit 2013 API
InsulationLiningBase Class
Members See Also Send Feedback
Acts as the base class for duct insulation, pipe insulation and duct lining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class InsulationLiningBase : MEPCurve
Visual Basic
Public Class InsulationLiningBase _
    Inherits MEPCurve
Visual C++
public ref class InsulationLiningBase : public MEPCurve

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..DuctInsulation
Autodesk.Revit.DB.Mechanical..::..DuctLining
Autodesk.Revit.DB.Plumbing..::..PipeInsulation

See Also

InsulationLiningBase Members


InsulationLiningBase Members

[image] [image]

Revit 2013 API
InsulationLiningBase Members
InsulationLiningBase Class Methods Properties See Also Send Feedback

The InsulationLiningBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsulationLiningBase Class


InsulationLiningBase Methods

[image] [image]

Revit 2013 API
InsulationLiningBase Methods
InsulationLiningBase Class See Also Send Feedback

The InsulationLiningBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInsulationIds | Returns the ids of the insulation elements associated to a given element.
 | GetLiningIds | Returns the ids of the lining elements associated to a given element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidThickness | Identifies if the given thickness value is valid for assignment to insulation or lining elements.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationLiningBase Class


GetInsulationIds Method

[image]

Revit 2013 API
InsulationLiningBase..::..GetInsulationIds Method
InsulationLiningBase Class See Also Send Feedback
Returns the ids of the insulation elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetInsulationIds(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function GetInsulationIds ( _
    document As Document, _
    elemId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetInsulationIds(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element.

Return Value

A collection of the ids of the insulation elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a valid host for insulation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InsulationLiningBase Class


GetLiningIds Method

[image]

Revit 2013 API
InsulationLiningBase..::..GetLiningIds Method
InsulationLiningBase Class See Also Send Feedback
Returns the ids of the lining elements associated to a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetLiningIds(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function GetLiningIds ( _
    document As Document, _
    elemId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetLiningIds(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The element.

Return Value

A collection of the ids of the lining elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a duct, fitting, or accessory element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InsulationLiningBase Class


IsValidThickness Method

[image]

Revit 2013 API
InsulationLiningBase..::..IsValidThickness Method
InsulationLiningBase Class See Also Send Feedback
Identifies if the given thickness value is valid for assignment to insulation or lining elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidThickness(
    double thickness
)
Visual Basic
Public Shared Function IsValidThickness ( _
    thickness As Double _
) As Boolean
Visual C++
public:
static bool IsValidThickness(
    double thickness
)

Parameters

thickness
Type: System..::..Double
Thickness of the insulation and lining elements.

Return Value

True if the thickness is valid, false otherwise.

See Also

InsulationLiningBase Class


InsulationLiningBase Properties

[image] [image]

Revit 2013 API
InsulationLiningBase Properties
InsulationLiningBase Class See Also Send Feedback

The InsulationLiningBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsulationLiningBase Class


HostElementId Property

[image]

Revit 2013 API
InsulationLiningBase..::..HostElementId Property
InsulationLiningBase Class See Also Send Feedback
The id of the host element for the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId HostElementId { get; }
Visual Basic
Public ReadOnly Property HostElementId As ElementId
    Get
Visual C++
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}

See Also

InsulationLiningBase Class


Parameter Property

[image] [image]

Revit 2013 API
InsulationLiningBase..::..Parameter Property
InsulationLiningBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

InsulationLiningBase Class
InsulationLiningBase Members


Thickness Property

[image]

Revit 2013 API
InsulationLiningBase..::..Thickness Property
InsulationLiningBase Class See Also Send Feedback
Thickness of the insulation or lining element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Thickness { get; set; }
Visual Basic
Public Property Thickness As Double
    Get
    Set
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Thickness is not valid for assignment to insulation or lining elements.

See Also

InsulationLiningBase Class


InternalDefinition Class

[image]

Revit 2013 API
InternalDefinition Class
Members See Also Send Feedback
This object represents a parameter definition in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InternalDefinition : Definition
Visual Basic
Public Class InternalDefinition _
    Inherits Definition
Visual C++
public ref class InternalDefinition : public Definition

Remarks

This object adds no properties or methods and is used purely for type identification.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Definition
Autodesk.Revit.DB..::..InternalDefinition

See Also

InternalDefinition Members


InternalDefinition Members

[image] [image]

Revit 2013 API
InternalDefinition Members
InternalDefinition Class Methods Properties See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user-visible name for the parameter. (Overrides Definition..::..Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

InternalDefinition Class


InternalDefinition Methods

[image] [image]

Revit 2013 API
InternalDefinition Methods
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinition Class


InternalDefinition Properties

[image] [image]

Revit 2013 API
InternalDefinition Properties
InternalDefinition Class See Also Send Feedback

The InternalDefinition type exposes the following members.

Properties

 | Name | Description
Public property | BuiltInParameter | Identifies if the parameter is a BuiltIn parameter.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | The user-visible name for the parameter. (Overrides Definition..::..Name.)
Public property | ParameterGroup | Returns the group ID of the parameter definition. (Overrides Definition..::..ParameterGroup.)
Public property | ParameterType | Returns the user-visible interpretation of the parameter data. (Overrides Definition..::..ParameterType.)
Public property | Visible | Indicates if the parameter is visible in the Autodesk Revit user interface.

See Also

InternalDefinition Class


BuiltInParameter Property

[image]

Revit 2013 API
InternalDefinition..::..BuiltInParameter Property
InternalDefinition Class See Also Send Feedback
Identifies if the parameter is a BuiltIn parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BuiltInParameter BuiltInParameter { get; }
Visual Basic
Public ReadOnly Property BuiltInParameter As BuiltInParameter
    Get
Visual C++
public:
property BuiltInParameter BuiltInParameter {
    BuiltInParameter get ();
}

Remarks

If the parameter is not a BuiltIn parameter (e.g. it is a shared parameter or family parameter), BuiltInParameter.INVALID will be returned.

See Also

InternalDefinition Class


Name Property

[image]

Revit 2013 API
InternalDefinition..::..Name Property
InternalDefinition Class See Also Send Feedback
The user-visible name for the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

See Also

InternalDefinition Class


ParameterGroup Property

[image]

Revit 2013 API
InternalDefinition..::..ParameterGroup Property
InternalDefinition Class See Also Send Feedback
Returns the group ID of the parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override BuiltInParameterGroup ParameterGroup { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterGroup As BuiltInParameterGroup
    Get
Visual C++
public:
virtual property BuiltInParameterGroup ParameterGroup {
    BuiltInParameterGroup get () override;
}

See Also

InternalDefinition Class


ParameterType Property

[image]

Revit 2013 API
InternalDefinition..::..ParameterType Property
InternalDefinition Class See Also Send Feedback
Returns the user-visible interpretation of the parameter data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override ParameterType ParameterType { get; }
Visual Basic
Public Overrides ReadOnly Property ParameterType As ParameterType
    Get
Visual C++
public:
virtual property ParameterType ParameterType {
    ParameterType get () override;
}

Remarks

The data within the parameter is stored as an integer, double, string or an element id. To the user these values may be more meaningful as Length, Volume, Mass etc. This parameter returns the interpretation that should be used for the data.

See Also

InternalDefinition Class


Visible Property

[image]

Revit 2013 API
InternalDefinition..::..Visible Property
InternalDefinition Class See Also Send Feedback
Indicates if the parameter is visible in the Autodesk Revit user interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Visible { get; }
Visual Basic
Public Overridable ReadOnly Property Visible As Boolean
    Get
Visual C++
public:
virtual property bool Visible {
    bool get ();
}

Remarks

The visible property controls whether a shared parameter is hidden from the user. This is useful if you wish to add data to an element that is only meaningful to your application and not to the user. This value can only be set when the shared parameter definition is created.

See Also

InternalDefinition Class


InternalDefinitions Class

[image]

Revit 2013 API
InternalDefinitions Class
Members See Also Send Feedback
This object blocks attempts to create new internal definitions as they are not permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InternalDefinitions : Definitions
Visual Basic
Public Class InternalDefinitions _
    Inherits Definitions
Visual C++
public ref class InternalDefinitions : public Definitions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Definitions
Autodesk.Revit.DB..::..InternalDefinitions

See Also

InternalDefinitions Members


InternalDefinitions Members

[image] [image]

Revit 2013 API
InternalDefinitions Members
InternalDefinitions Class Constructors Methods Properties See Also Send Feedback

The InternalDefinitions type exposes the following members.

Constructors

 | Name | Description
Public method | InternalDefinitions | Initializes a new instance of the InternalDefinitions class

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

InternalDefinitions Class


InternalDefinitions Constructor

[image]

Revit 2013 API
InternalDefinitions Constructor
InternalDefinitions Class See Also Send Feedback
Initializes a new instance of the InternalDefinitions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InternalDefinitions()
Visual Basic
Public Sub New
Visual C++
public:
InternalDefinitions()

See Also

InternalDefinitions Class


InternalDefinitions Methods

[image] [image]

Revit 2013 API
InternalDefinitions Methods
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Tests for the existence of a definition within the set. (Inherited from Definitions.)
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)
Public method | Dispose | (Inherited from Definitions.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Definitions.)
Public method | GetEnumerator | Retrieves an enumerator to the collection. (Inherited from Definitions.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InternalDefinitions Class


Create Method

[image] [image]

Revit 2013 API
InternalDefinitions..::..Create Method
InternalDefinitions Class See Also Send Feedback
Creates a new parameter definition.

Overload List

 | Name | Description
Public method | Create(String, ParameterType) | Creates a new parameter definition using name, type and visibility. (Inherited from Definitions.)
Public method | Create(String, ParameterType, Boolean) | Creates a new parameter definition using name and type. (Inherited from Definitions.)

See Also

InternalDefinitions Class
InternalDefinitions Members


InternalDefinitions Properties

[image] [image]

Revit 2013 API
InternalDefinitions Properties
InternalDefinitions Class See Also Send Feedback

The InternalDefinitions type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the definitions collection is empty. (Inherited from Definitions.)
Public property | Item | Retrieves a definition by a given name. (Inherited from Definitions.)
Public property | Size | The number of definitions in the collection. (Inherited from Definitions.)

See Also

InternalDefinitions Class


IntersectionResult Class

[image]

Revit 2013 API
IntersectionResult Class
Members See Also Send Feedback
This class captures results of intersecting geometric entities. "Intersecting" is meant in generalized sense, so the same class will be used for projection, containment, etc. Refer to the documentation of the method providing the result for the precise meaning of properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class IntersectionResult : APIObject
Visual Basic
Public Class IntersectionResult _
    Inherits APIObject
Visual C++
public ref class IntersectionResult : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResult

See Also

IntersectionResult Members


IntersectionResult Members

[image] [image]

Revit 2013 API
IntersectionResult Members
IntersectionResult Class Constructors Methods Properties See Also Send Feedback

The IntersectionResult type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResult | Initializes a new instance of the IntersectionResult class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


IntersectionResult Constructor

[image]

Revit 2013 API
IntersectionResult Constructor
IntersectionResult Class See Also Send Feedback
Initializes a new instance of the IntersectionResult class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResult()
Visual Basic
Public Sub New
Visual C++
public:
IntersectionResult()

See Also

IntersectionResult Class


IntersectionResult Methods

[image] [image]

Revit 2013 API
IntersectionResult Methods
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResult Class


IntersectionResult Properties

[image] [image]

Revit 2013 API
IntersectionResult Properties
IntersectionResult Class See Also Send Feedback

The IntersectionResult type exposes the following members.

Properties

 | Name | Description
Public property | Distance | Distance from the original object to located point.
Public property | EdgeObject | Edge of the face close to the point of intersection.
Public property | EdgeParameter | Parameter of a point on the edge closest to the point of intersection.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Parameter | 1d parameter of the point of intersection.
Public property | UVPoint | 2d (or two 1d) parameters of the point of intersection.
Public property | XYZPoint | Point of intersection in local 3d coordinates.

See Also

IntersectionResult Class


Distance Property

[image]

Revit 2013 API
IntersectionResult..::..Distance Property
IntersectionResult Class See Also Send Feedback
Distance from the original object to located point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Distance { get; internal set; }
Visual Basic
Public Property Distance As Double
    Get
    Friend Set
Visual C++
public:
property double Distance {
    double get ();
    internal: void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


EdgeObject Property

[image]

Revit 2013 API
IntersectionResult..::..EdgeObject Property
IntersectionResult Class See Also Send Feedback
Edge of the face close to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Edge EdgeObject { get; internal set; }
Visual Basic
Public Property EdgeObject As Edge
    Get
    Friend Set
Visual C++
public:
property Edge^ EdgeObject {
    Edge^ get ();
    internal: void set (Edge^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


EdgeParameter Property

[image]

Revit 2013 API
IntersectionResult..::..EdgeParameter Property
IntersectionResult Class See Also Send Feedback
Parameter of a point on the edge closest to the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double EdgeParameter { get; internal set; }
Visual Basic
Public Property EdgeParameter As Double
    Get
    Friend Set
Visual C++
public:
property double EdgeParameter {
    double get ();
    internal: void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


Parameter Property

[image]

Revit 2013 API
IntersectionResult..::..Parameter Property
IntersectionResult Class See Also Send Feedback
1d parameter of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Parameter { get; internal set; }
Visual Basic
Public Property Parameter As Double
    Get
    Friend Set
Visual C++
public:
property double Parameter {
    double get ();
    internal: void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


UVPoint Property

[image]

Revit 2013 API
IntersectionResult..::..UVPoint Property
IntersectionResult Class See Also Send Feedback
2d (or two 1d) parameters of the point of intersection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV UVPoint { get; internal set; }
Visual Basic
Public Property UVPoint As UV
    Get
    Friend Set
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
    internal: void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


XYZPoint Property

[image]

Revit 2013 API
IntersectionResult..::..XYZPoint Property
IntersectionResult Class See Also Send Feedback
Point of intersection in local 3d coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ XYZPoint { get; internal set; }
Visual Basic
Public Property XYZPoint As XYZ
    Get
    Friend Set
Visual C++
public:
property XYZ^ XYZPoint {
    XYZ^ get ();
    internal: void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown in the getter when this property has not been set by the method providing the result.

See Also

IntersectionResult Class


IntersectionResultArray Class

[image]

Revit 2013 API
IntersectionResultArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class IntersectionResultArray : APIObject,
    IEnumerable
Visual Basic
Public Class IntersectionResultArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class IntersectionResultArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResultArray

See Also

IntersectionResultArray Members


IntersectionResultArray Members

[image] [image]

Revit 2013 API
IntersectionResultArray Members
IntersectionResultArray Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResultArray | Initializes a new instance of the IntersectionResultArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Constructor

[image]

Revit 2013 API
IntersectionResultArray Constructor
IntersectionResultArray Class See Also Send Feedback
Initializes a new instance of the IntersectionResultArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResultArray()
Visual Basic
Public Sub New
Visual C++
public:
IntersectionResultArray()

See Also

IntersectionResultArray Class


IntersectionResultArray Methods

[image] [image]

Revit 2013 API
IntersectionResultArray Methods
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArray Class


Append Method

[image]

Revit 2013 API
IntersectionResultArray..::..Append Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    IntersectionResult item
)
Visual Basic
Public Overridable Sub Append ( _
    item As IntersectionResult _
)
Visual C++
public:
virtual void Append(
    IntersectionResult^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..IntersectionResult

See Also

IntersectionResultArray Class


Clear Method

[image]

Revit 2013 API
IntersectionResultArray..::..Clear Method
IntersectionResultArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

IntersectionResultArray Class


ForwardIterator Method

[image]

Revit 2013 API
IntersectionResultArray..::..ForwardIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

IntersectionResultArray Class


GetEnumerator Method

[image]

Revit 2013 API
IntersectionResultArray..::..GetEnumerator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

IntersectionResultArray Class


Insert Method

[image]

Revit 2013 API
IntersectionResultArray..::..Insert Method
IntersectionResultArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    IntersectionResult item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As IntersectionResult, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IntersectionResult^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..IntersectionResult
index
Type: System..::..Int32

See Also

IntersectionResultArray Class


ReverseIterator Method

[image]

Revit 2013 API
IntersectionResultArray..::..ReverseIterator Method
IntersectionResultArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IntersectionResultArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As IntersectionResultArrayIterator
Visual C++
public:
virtual IntersectionResultArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

IntersectionResultArray Class


IntersectionResultArray Properties

[image] [image]

Revit 2013 API
IntersectionResultArray Properties
IntersectionResultArray Class See Also Send Feedback

The IntersectionResultArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

IntersectionResultArray Class


IsEmpty Property

[image]

Revit 2013 API
IntersectionResultArray..::..IsEmpty Property
IntersectionResultArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

IntersectionResultArray Class


Item Property

[image]

Revit 2013 API
IntersectionResultArray..::..Item Property
IntersectionResultArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IntersectionResult this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As IntersectionResult
    Get
    Set
Visual C++
public:
virtual property IntersectionResult^ Item[int index] {
    IntersectionResult^ get (int index);
    void set (int index, IntersectionResult^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

IntersectionResultArray Class


Size Property

[image]

Revit 2013 API
IntersectionResultArray..::..Size Property
IntersectionResultArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

IntersectionResultArray Class


IntersectionResultArrayIterator Class

[image]

Revit 2013 API
IntersectionResultArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class IntersectionResultArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class IntersectionResultArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class IntersectionResultArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..IntersectionResultArrayIterator

See Also

IntersectionResultArrayIterator Members


IntersectionResultArrayIterator Members

[image] [image]

Revit 2013 API
IntersectionResultArrayIterator Members
IntersectionResultArrayIterator Class Constructors Methods Properties See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | IntersectionResultArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Constructor

[image]

Revit 2013 API
IntersectionResultArrayIterator Constructor
IntersectionResultArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IntersectionResultArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
IntersectionResultArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Methods

[image] [image]

Revit 2013 API
IntersectionResultArrayIterator Methods
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IntersectionResultArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
IntersectionResultArrayIterator..::..MoveNext Method
IntersectionResultArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


Reset Method

[image]

Revit 2013 API
IntersectionResultArrayIterator..::..Reset Method
IntersectionResultArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

IntersectionResultArrayIterator Class


IntersectionResultArrayIterator Properties

[image] [image]

Revit 2013 API
IntersectionResultArrayIterator Properties
IntersectionResultArrayIterator Class See Also Send Feedback

The IntersectionResultArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

IntersectionResultArrayIterator Class


Current Property

[image]

Revit 2013 API
IntersectionResultArrayIterator..::..Current Property
IntersectionResultArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

IntersectionResultArrayIterator Class


IPerformanceAdviserRule Interface

[image]

Revit 2013 API
IPerformanceAdviserRule Interface
Members See Also Send Feedback
Base class to derive specific performance adviser rules from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public interface IPerformanceAdviserRule
Visual Basic
Public Interface IPerformanceAdviserRule
Visual C++
public interface class IPerformanceAdviserRule

See Also

IPerformanceAdviserRule Members


IPerformanceAdviserRule Members

[image] [image]

Revit 2013 API
IPerformanceAdviserRule Members
IPerformanceAdviserRule Interface Methods See Also Send Feedback

The IPerformanceAdviserRule type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface


IPerformanceAdviserRule Methods

[image] [image]

Revit 2013 API
IPerformanceAdviserRule Methods
IPerformanceAdviserRule Interface See Also Send Feedback

The IPerformanceAdviserRule type exposes the following members.

Methods

 | Name | Description
Public method | ExecuteElementCheck | Invoked by performance advisor for each element to be checked.
Public method | FinalizeCheck | Invoked by performance advisor once in the end of the check.
Public method | GetDescription | Retrieves the description of the rule.
Public method | GetElementFilter | Retrieves a filter to restrict elements to be checked.
Public method | GetName | Retrieves the name of the rule.
Public method | InitCheck | Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.
Public method | WillCheckElements | Reports if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface


ExecuteElementCheck Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..ExecuteElementCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor for each element to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void ExecuteElementCheck(
    Document document,
    Element element
)
Visual Basic
Sub ExecuteElementCheck ( _
    document As Document, _
    element As Element _
)
Visual C++
void ExecuteElementCheck(
    Document^ document,
    Element^ element
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.
element
Type: Autodesk.Revit.DB..::..Element
The Element being checked for performance problems.

See Also

IPerformanceAdviserRule Interface


FinalizeCheck Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..FinalizeCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor once in the end of the check.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void FinalizeCheck(
    Document document
)
Visual Basic
Sub FinalizeCheck ( _
    document As Document _
)
Visual C++
void FinalizeCheck(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

See Also

IPerformanceAdviserRule Interface


GetDescription Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..GetDescription Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
string GetDescription()
Visual Basic
Function GetDescription As String
Visual C++
String^ GetDescription()

Return Value

The description of the rule.

Remarks

Method should return a brief (one-two sentences) description of the rule. String should be localized.

See Also

IPerformanceAdviserRule Interface


GetElementFilter Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..GetElementFilter Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
ElementFilter GetElementFilter(
    Document document
)
Visual Basic
Function GetElementFilter ( _
    document As Document _
) As ElementFilter
Visual C++
ElementFilter^ GetElementFilter(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Remarks

If the rule needs to be executed on individual elements, it should return a filter that defines what elements the rule should apply to. Otherwise, nothing (i.e. null) should be returned. If filter is returned, it should stay valid till the end of the check.

See Also

IPerformanceAdviserRule Interface


GetName Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..GetName Method
IPerformanceAdviserRule Interface See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

The name of the rule.

Remarks

Method should return a short string naming the rule, typically as a one word in TitleCase. String should be localized.

See Also

IPerformanceAdviserRule Interface


InitCheck Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..InitCheck Method
IPerformanceAdviserRule Interface See Also Send Feedback
Invoked by performance advisor once in the beginning of the check. If rule checks document as a whole, the check can be performed in this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void InitCheck(
    Document document
)
Visual Basic
Sub InitCheck ( _
    document As Document _
)
Visual C++
void InitCheck(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

See Also

IPerformanceAdviserRule Interface


WillCheckElements Method

[image]

Revit 2013 API
IPerformanceAdviserRule..::..WillCheckElements Method
IPerformanceAdviserRule Interface See Also Send Feedback
Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
bool WillCheckElements()
Visual Basic
Function WillCheckElements As Boolean
Visual C++
bool WillCheckElements()

Return Value

True if rule needs to be executed on individual elements.

See Also

IPerformanceAdviserRule Interface


IPrintSetting Interface

[image]

Revit 2013 API
IPrintSetting Interface
Members See Also Send Feedback
An interface which represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IPrintSetting
Visual Basic
Public Interface IPrintSetting
Visual C++
public interface class IPrintSetting

See Also

IPrintSetting Members


IPrintSetting Members

[image] [image]

Revit 2013 API
IPrintSetting Members
IPrintSetting Interface Properties See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


IPrintSetting Properties

[image] [image]

Revit 2013 API
IPrintSetting Properties
IPrintSetting Interface See Also Send Feedback

The IPrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | PrintParameters | Returns the Parameters of Print Setup.

See Also

IPrintSetting Interface


PrintParameters Property

[image]

Revit 2013 API
IPrintSetting..::..PrintParameters Property
IPrintSetting Interface See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
PrintParameters PrintParameters { get; }
Visual Basic
ReadOnly Property PrintParameters As PrintParameters
    Get
Visual C++
property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

IPrintSetting Interface


ITransactionFinalizer Interface

[image]

Revit 2013 API
ITransactionFinalizer Interface
Members See Also Send Feedback
An interface that may be used to perform a custom action at the end of a transaction. A method of the interface will be called when a transaction is either committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public interface ITransactionFinalizer
Visual Basic
Public Interface ITransactionFinalizer
Visual C++
public interface class ITransactionFinalizer

See Also

ITransactionFinalizer Members


ITransactionFinalizer Members

[image] [image]

Revit 2013 API
ITransactionFinalizer Members
ITransactionFinalizer Interface Methods See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


ITransactionFinalizer Methods

[image] [image]

Revit 2013 API
ITransactionFinalizer Methods
ITransactionFinalizer Interface See Also Send Feedback

The ITransactionFinalizer type exposes the following members.

Methods

 | Name | Description
Public method | OnCommitted | This method is called at the end of committing a transaction
Public method | OnRolledBack | This method is called at the end of rolling back a transaction

See Also

ITransactionFinalizer Interface


OnCommitted Method

[image]

Revit 2013 API
ITransactionFinalizer..::..OnCommitted Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of committing a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
void OnCommitted(
    Document document,
    string strTransactionName
)
Visual Basic
Sub OnCommitted ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnCommitted(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document associated with the transaction
strTransactionName
Type: System..::..String
The transaction's name

See Also

ITransactionFinalizer Interface


OnRolledBack Method

[image]

Revit 2013 API
ITransactionFinalizer..::..OnRolledBack Method
ITransactionFinalizer Interface See Also Send Feedback
This method is called at the end of rolling back a transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
void OnRolledBack(
    Document document,
    string strTransactionName
)
Visual Basic
Sub OnRolledBack ( _
    document As Document, _
    strTransactionName As String _
)
Visual C++
void OnRolledBack(
    Document^ document,
    String^ strTransactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document associated with the transaction
strTransactionName
Type: System..::..String
The transaction's name

See Also

ITransactionFinalizer Interface


IUpdater Interface

[image]

Revit 2013 API
IUpdater Interface
Members Example See Also Send Feedback
The interface used to create an updater capable of reacting to changes in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public interface IUpdater
Visual Basic
Public Interface IUpdater
Visual C++
public interface class IUpdater

Remarks

Implement this interface and register an instance of the derived class with the UpdaterRegistry.

Examples

CopyC#
public class WallUpdaterApplication : Autodesk.Revit.UI.IExternalApplication
{
    public Result OnStartup(Autodesk.Revit.UI.UIControlledApplication application)
    {
        // Register wall updater with Revit
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.RegisterUpdater(updater);

        // Change Scope = any Wall element
        ElementClassFilter wallFilter = new ElementClassFilter(typeof(Wall));

        // Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter,
                                    Element.GetChangeTypeElementAddition());
        return Result.Succeeded;
    }

    public Result OnShutdown(Autodesk.Revit.UI.UIControlledApplication application)
    {
        WallUpdater updater = new WallUpdater(application.ActiveAddInId);
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId());
        return Result.Succeeded;
    }
}

public class WallUpdater : IUpdater
{
    static AddInId m_appId;
    static UpdaterId m_updaterId;
    WallType m_wallType = null;

    // constructor takes the AddInId for the add-in associated with this updater
    public WallUpdater(AddInId id)
    {
        m_appId = id;
        m_updaterId = new UpdaterId(m_appId, new Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"));
    }

    public void Execute(UpdaterData data)
    {
        Document doc = data.GetDocument();

        // Cache the wall type
        if (m_wallType == null)
        {
            FilteredElementCollector collector = new FilteredElementCollector(doc);
            collector.OfClass(typeof(WallType));
            var wallTypes = from element in collector
                            where
                                element.Name == "Exterior - Brick on CMU"
                            select element;
            if (wallTypes.Count<Element>() > 0)
            {
                m_wallType = wallTypes.Cast<WallType>().ElementAt<WallType>(0);
            }
        }

        if (m_wallType != null)
        {
            // Change the wall to the cached wall type.
            foreach (ElementId addedElemId in data.GetAddedElementIds())
            {
                Wall wall = doc.GetElement(addedElemId) as Wall;
                if (wall != null)
                {
                    wall.WallType = m_wallType;
                }
            }
        }
    }

    public string GetAdditionalInformation()
    {
        return "Wall type updater example: updates all newly created walls to a special wall";
    }

    public ChangePriority GetChangePriority()
    {
        return ChangePriority.FloorsRoofsStructuralWalls;
    }

    public UpdaterId GetUpdaterId()
    {
        return m_updaterId;
    }

    public string GetUpdaterName()
    {
        return "Wall Type Updater";
    }
}
CopyVB.NET
<Autodesk.Revit.Attributes.Regeneration(Autodesk.Revit.Attributes.RegenerationOption.Manual)> _
Public Class WallUpdaterApplication
    Implements Autodesk.Revit.UI.IExternalApplication
    Public Function OnStartup(ByVal application As Autodesk.Revit.UI.UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register wall updater with Revit
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.RegisterUpdater(updater)

        ' Change Scope = any Wall element
        Dim wallFilter As New ElementClassFilter(GetType(Wall))

        ' Change type = element addition
        UpdaterRegistry.AddTrigger(updater.GetUpdaterId(), wallFilter, Autodesk.Revit.DB.Element.GetChangeTypeElementAddition())
        Return Result.Succeeded
    End Function

    Public Function OnShutdown(ByVal application As Autodesk.Revit.UI.UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        Dim updater As New WallUpdater(application.ActiveAddInId)
        UpdaterRegistry.UnregisterUpdater(updater.GetUpdaterId())
        Return Result.Succeeded
    End Function
End Class

Public Class WallUpdater
    Implements IUpdater
    Shared m_appId As AddInId
    Shared m_updaterId As UpdaterId
    Private m_wallType As WallType = Nothing

    ' constructor takes the AddInId for the add-in associated with this updater
    Public Sub New(ByVal id As AddInId)
        m_appId = id
        m_updaterId = New UpdaterId(m_appId, New Guid("FBFBF6B2-4C06-42d4-97C1-D1B4EB593EFF"))
    End Sub

    Public Sub Execute(ByVal data As UpdaterData) Implements IUpdater.Execute
        Dim doc As Document = data.GetDocument()

        ' Cache the wall type
        If m_wallType Is Nothing Then
            Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(doc)
            collector.OfClass(GetType(WallType))
            Dim wallTypes As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
            wallTypes = From element In collector _
             Where element.Name = "Exterior - Brick on CMU" _
             Select element
            If wallTypes.Count() > 0 Then
                m_wallType = wallTypes.Cast(Of WallType)().ElementAt(0)
            End If
        End If

        If m_wallType IsNot Nothing Then
            ' Change the wall to the cached wall type.
            For Each addedElemId As ElementId In data.GetAddedElementIds()
                Dim wall As Wall = TryCast(doc.GetElement(addedElemId), Wall)
                If wall IsNot Nothing Then
                    wall.WallType = m_wallType
                End If
            Next
        End If
    End Sub

    Public Function GetAdditionalInformation() As String Implements IUpdater.GetAdditionalInformation
        Return "Wall type updater example: updates all newly created walls to a special wall"
    End Function

    Public Function GetChangePriority() As ChangePriority Implements IUpdater.GetChangePriority
        Return ChangePriority.FloorsRoofsStructuralWalls
    End Function

    Public Function GetUpdaterId() As UpdaterId Implements IUpdater.GetUpdaterId
        Return m_updaterId
    End Function

    Public Function GetUpdaterName() As String Implements IUpdater.GetUpdaterName
        Return "Wall Type Updater"
    End Function
End Class

See Also

IUpdater Members


IUpdater Members

[image] [image]

Revit 2013 API
IUpdater Members
IUpdater Interface Methods See Also Send Feedback

The IUpdater type exposes the following members.

Methods

 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface


IUpdater Methods

[image] [image]

Revit 2013 API
IUpdater Methods
IUpdater Interface See Also Send Feedback

The IUpdater type exposes the following members.

Methods

 | Name | Description
Public method | Execute | The method that Revit will invoke to perform an update.
Public method | GetAdditionalInformation | Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public method | GetChangePriority | Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public method | GetUpdaterId | Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public method | GetUpdaterName | Returns a name that the Updater can be identified by to the user

See Also

IUpdater Interface


Execute Method

[image]

Revit 2013 API
IUpdater..::..Execute Method
IUpdater Interface See Also Send Feedback
The method that Revit will invoke to perform an update.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
void Execute(
    UpdaterData data
)
Visual Basic
Sub Execute ( _
    data As UpdaterData _
)
Visual C++
void Execute(
    UpdaterData^ data
)

Parameters

data
Type: Autodesk.Revit.DB..::..UpdaterData
Provides all necessary data needed to perform the update, including the document and information about the changes that triggered the update.

Remarks

The purpose of this method is to allow your updater to react to changes that have been made to the document, and make appropriate related changes to the same document. Although it can be used to also update data outside of the document, such changes will not become part of the original transaction and will not be subject to undo or redo when the original transaction is undone or redone. If you do use this method to modify data outside of the document, you should also subscribe to the DocumentChanged event to update your data when the original transaction is undone or redone.

The method is invoked by Revit at the end of a document transaction in which elements that matched the UpdateTrigger for this Updater were added, changed or deleted. The method may be invoked more than once for the same transaction due to changes made by other Updaters.

All changes to the document made during the invocation of this method will become a part of the invoking transaction, and maintained for undo and redo operations. When implementing this method you may not open any new transactions (an exception will be thrown), but you may use sub-transactions as required.

The following methods may not be called while executing an Updater, because they introduce cross references between elements. A ForbiddenForDynamicUpdateException will be thrown when an updater attempts to call any of these methods:

  • void Autodesk.Revit.DB.ViewSheet.AddView(Autodesk.Revit.DB.View, Autodesk.Revit.DB.UV)
  • Autodesk.Revit.DB.Family Autodesk.Revit.DB.Document.LoadFamily(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.IFamilyLoadOptions)
  • Autodesk.Revit.DB.Structure.AreaReinforcement Autodesk.Revit.Creation.Document.NewAreaReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, Autodesk.Revit.DB.XYZ)
  • Autodesk.Revit.DB.Structure.PathReinforcement Autodesk.Revit.Creation.Document.NewPathReinforcement(Autodesk.Revit.DB.Element, Autodesk.Revit.DB.CurveArray, bool)
  • void Autodesk.Revit.DB.MEPSystem.Add(Autodesk.Revit.DB.ConnectorSet)

Although the following methods are allowed during execution of an updater, they can also throw ForbiddenForDynamicUpdateException when cross-references between elements are established as a result of the call. One such example could be creating a face wall that intersect with an existing face wall, so those two would have to be joined together. Apply caution when calling these methods from an updater:

  • Autodesk.Revit.DB.ElementSet Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstances(System.Collections.Generic.List<Autodesk.Revit.Creation.FamilyInstanceCreationData>)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.ItemFactoryBase.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element,Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FamilyInstance Autodesk.Revit.Creation.Document.NewFamilyInstance(Autodesk.Revit.DB.XYZ, Autodesk.Revit.DB.FamilySymbol, Autodesk.Revit.DB.Element, Autodesk.Revit.DB.Level, Autodesk.Revit.DB.Structure.StructuralType)
  • Autodesk.Revit.DB.FaceWall Autodesk.Revit.DB.FaceWall.Create(Autodesk.Revit.DB.Document, Autodesk.Revit.DB.ElementId, Autodesk.Revit.DB.WallLocationLine, Autodesk.Revit.DB.Reference)

Some UI methods may not be called while executing an Updater too, otherwise ForbiddenForDynamicUpdateException will be thrown. Such methods include: PickObject, PickObjects, PickElementsByRectangle, PickPoint, PickOne and WindowSelect.

Also, most of the methods of the UpdaterRegistry class may not be called during an updater's execution otherwise an InvalidOperationException would be thrown.

In addition to the forbidden methods listed above, other API methods that require documents to be in transaction-free state may not be called either. Such methods include but are not limited to Save, SaveAs, Close, LoadFamily, etc. Please refer to the documentation of the respective methods for more information.

See Also

IUpdater Interface


GetAdditionalInformation Method

[image]

Revit 2013 API
IUpdater..::..GetAdditionalInformation Method
IUpdater Interface See Also Send Feedback
Auxiliary text that Revit will use to inform the end user when the Updater is not loaded

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
string GetAdditionalInformation()
Visual Basic
Function GetAdditionalInformation As String
Visual C++
String^ GetAdditionalInformation()

See Also

IUpdater Interface


GetChangePriority Method

[image]

Revit 2013 API
IUpdater..::..GetChangePriority Method
IUpdater Interface See Also Send Feedback
Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
ChangePriority GetChangePriority()
Visual Basic
Function GetChangePriority As ChangePriority
Visual C++
ChangePriority GetChangePriority()

See Also

IUpdater Interface


GetUpdaterId Method

[image]

Revit 2013 API
IUpdater..::..GetUpdaterId Method
IUpdater Interface See Also Send Feedback
Returns globally unique updater id - used to identify the Updater Called once during registration of the updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
UpdaterId GetUpdaterId()
Visual Basic
Function GetUpdaterId As UpdaterId
Visual C++
UpdaterId^ GetUpdaterId()

See Also

IUpdater Interface


GetUpdaterName Method

[image]

Revit 2013 API
IUpdater..::..GetUpdaterName Method
IUpdater Interface See Also Send Feedback
Returns a name that the Updater can be identified by to the user

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
string GetUpdaterName()
Visual Basic
Function GetUpdaterName As String
Visual C++
String^ GetUpdaterName()

See Also

IUpdater Interface


IViewSheetSet Interface

[image]

Revit 2013 API
IViewSheetSet Interface
Members See Also Send Feedback
This interface represents a selected set of views/sheets which will be used for printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IViewSheetSet
Visual Basic
Public Interface IViewSheetSet
Visual C++
public interface class IViewSheetSet

See Also

IViewSheetSet Members


IViewSheetSet Members

[image] [image]

Revit 2013 API
IViewSheetSet Members
IViewSheetSet Interface Properties See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | Views | The views.

See Also

IViewSheetSet Interface


IViewSheetSet Properties

[image] [image]

Revit 2013 API
IViewSheetSet Properties
IViewSheetSet Interface See Also Send Feedback

The IViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | Views | The views.

See Also

IViewSheetSet Interface


Views Property

[image]

Revit 2013 API
IViewSheetSet..::..Views Property
IViewSheetSet Interface See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
ViewSet Views { get; set; }
Visual Basic
Property Views As ViewSet
    Get
    Set
Visual C++
property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

IViewSheetSet Interface


JoinType Enumeration

[image]

Revit 2013 API
JoinType Enumeration
See Also Send Feedback
The type of join at the end of an element. The join type affects only the graphic treatment, i.e. cleaning of the end, not the physical join behavior.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum JoinType
Visual Basic
Public Enumeration JoinType
Visual C++
public enum class JoinType

Members

Member name | Description
None | No join type
Abut | Abut Join
Miter | Miter Join
SquareOff | Square-off Join
Extension | Extension Join

See Also


JunctionType Enumeration

[image]

Revit 2013 API
JunctionType Enumeration
See Also Send Feedback
An enumerated type listing all the junction types for MEP curve types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum JunctionType
Visual Basic
Public Enumeration JunctionType
Visual C++
public enum class JunctionType

Members

Member name | Description
Tap | The junction type is tap.
Tee | The junction type is tee.

See Also


LabelUtils Class

[image]

Revit 2013 API
LabelUtils Class
Members See Also Send Feedback
Used to obtain user-visible name for certain enums.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class LabelUtils
Visual Basic
Public Class LabelUtils
Visual C++
public ref class LabelUtils

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LabelUtils

See Also

LabelUtils Members


LabelUtils Members

[image] [image]

Revit 2013 API
LabelUtils Members
LabelUtils Class Constructors Methods See Also Send Feedback

The LabelUtils type exposes the following members.

Constructors

 | Name | Description
Public method | LabelUtils | Initializes a new instance of the LabelUtils class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLabelFor(BuiltInParameter) | Gets user-visible name for BuiltInParameter.
 | GetLabelFor(BuiltInParameterGroup) | Gets user-visible name for BuiltInParameterGroup.
 | GetLabelFor(DisplayUnitType) | Gets user-visible name for DisplayUnitType.
 | GetLabelFor(ParameterType) | Gets user-visible name for ParameterType.
 | GetLabelFor(UnitType) | Gets user-visible name for UnitType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets user-visible names for DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets user-visible name for gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets user-visible names for PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets user-visible names for PipeLossMethodType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelUtils Class


LabelUtils Constructor

[image]

Revit 2013 API
LabelUtils Constructor
LabelUtils Class See Also Send Feedback
Initializes a new instance of the LabelUtils class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LabelUtils()
Visual Basic
Public Sub New
Visual C++
public:
LabelUtils()

See Also

LabelUtils Class


LabelUtils Methods

[image] [image]

Revit 2013 API
LabelUtils Methods
LabelUtils Class See Also Send Feedback

The LabelUtils type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLabelFor(BuiltInParameter) | Gets user-visible name for BuiltInParameter.
 | GetLabelFor(BuiltInParameterGroup) | Gets user-visible name for BuiltInParameterGroup.
 | GetLabelFor(DisplayUnitType) | Gets user-visible name for DisplayUnitType.
 | GetLabelFor(ParameterType) | Gets user-visible name for ParameterType.
 | GetLabelFor(UnitType) | Gets user-visible name for UnitType.
 | GetLabelFor(DuctLossMethodType, Document) | Gets user-visible names for DuctLossMethodType.
 | GetLabelFor(gbXMLBuildingType, Document) | Gets user-visible name for gbXMLBuildingType.
 | GetLabelFor(PipeFlowState, Document) | Gets user-visible names for PipeFlowState.
 | GetLabelFor(PipeLossMethodType, Document) | Gets user-visible names for PipeLossMethodType.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LabelUtils Class


GetLabelFor Method

[image] [image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method
LabelUtils Class See Also Send Feedback

Overload List

Name | Description
GetLabelFor(BuiltInParameter) | Gets user-visible name for BuiltInParameter.
GetLabelFor(BuiltInParameterGroup) | Gets user-visible name for BuiltInParameterGroup.
GetLabelFor(DisplayUnitType) | Gets user-visible name for DisplayUnitType.
GetLabelFor(ParameterType) | Gets user-visible name for ParameterType.
GetLabelFor(UnitType) | Gets user-visible name for UnitType.
GetLabelFor(DuctLossMethodType, Document) | Gets user-visible names for DuctLossMethodType.
GetLabelFor(gbXMLBuildingType, Document) | Gets user-visible name for gbXMLBuildingType.
GetLabelFor(PipeFlowState, Document) | Gets user-visible names for PipeFlowState.
GetLabelFor(PipeLossMethodType, Document) | Gets user-visible names for PipeLossMethodType.

See Also

LabelUtils Class
LabelUtils Members


GetLabelFor Method (BuiltInParameter)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (BuiltInParameter)
LabelUtils Class See Also Send Feedback
Gets user-visible name for BuiltInParameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    BuiltInParameter builtInParam
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInParam As BuiltInParameter _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameter builtInParam
)

Parameters

builtInParam
Type: Autodesk.Revit.DB..::..BuiltInParameter
The BuiltInParameter to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the BuiltInParameter cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (BuiltInParameterGroup)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (BuiltInParameterGroup)
LabelUtils Class See Also Send Feedback
Gets user-visible name for BuiltInParameterGroup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)
Visual Basic
Public Shared Function GetLabelFor ( _
    builtInParamGroup As BuiltInParameterGroup _
) As String
Visual C++
public:
static String^ GetLabelFor(
    BuiltInParameterGroup builtInParamGroup
)

Parameters

builtInParamGroup
Type: Autodesk.Revit.DB..::..BuiltInParameterGroup
The BuiltInParameterGroup to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (DisplayUnitType)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (DisplayUnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for DisplayUnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    DisplayUnitType displayUnitType
)
Visual Basic
Public Shared Function GetLabelFor ( _
    displayUnitType As DisplayUnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    DisplayUnitType displayUnitType
)

Parameters

displayUnitType
Type: Autodesk.Revit.DB..::..DisplayUnitType
The DisplayUnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input DisplayUnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (ParameterType)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (ParameterType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for ParameterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    ParameterType paramType
)
Visual Basic
Public Shared Function GetLabelFor ( _
    paramType As ParameterType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    ParameterType paramType
)

Parameters

paramType
Type: Autodesk.Revit.DB..::..ParameterType
The ParameterType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to get user-visible name for the input ParameterType.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (UnitType)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (UnitType)
LabelUtils Class See Also Send Feedback
Gets user-visible name for UnitType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    UnitType unitType
)
Visual Basic
Public Shared Function GetLabelFor ( _
    unitType As UnitType _
) As String
Visual C++
public:
static String^ GetLabelFor(
    UnitType unitType
)

Parameters

unitType
Type: Autodesk.Revit.DB..::..UnitType
The UnitType to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input UnitType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (DuctLossMethodType, Document)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (DuctLossMethodType, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible names for DuctLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    ductLossMethodType As DuctLossMethodType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    DuctLossMethodType ductLossMethodType,
    Document^ doc
)

Parameters

ductLossMethodType
Type: Autodesk.Revit.DB.Mechanical..::..DuctLossMethodType
The DuctLossMethodType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the DuctLossMethodType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input DuctLossMethodType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (gbXMLBuildingType, Document)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (gbXMLBuildingType, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible name for gbXMLBuildingType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    gbXMLBuildingType As gbXMLBuildingType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    gbXMLBuildingType gbXMLBuildingType,
    Document^ doc
)

Parameters

gbXMLBuildingType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The gbXMLBuildingType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the gbXMLBuildingType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"doc"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the gbXMLBuildingType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (PipeFlowState, Document)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (PipeFlowState, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible names for PipeFlowState.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    PipeFlowState pipeFlowState,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    pipeFlowState As PipeFlowState, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    PipeFlowState pipeFlowState,
    Document^ doc
)

Parameters

pipeFlowState
Type: Autodesk.Revit.DB.Plumbing..::..PipeFlowState
The PipeFlowState to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeFlowState.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeFlowState cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


GetLabelFor Method (PipeLossMethodType, Document)

[image]

Revit 2013 API
LabelUtils..::..GetLabelFor Method (PipeLossMethodType, Document)
LabelUtils Class See Also Send Feedback
Gets user-visible names for PipeLossMethodType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document doc
)
Visual Basic
Public Shared Function GetLabelFor ( _
    pipeLossMethodType As PipeLossMethodType, _
    doc As Document _
) As String
Visual C++
public:
static String^ GetLabelFor(
    PipeLossMethodType pipeLossMethodType,
    Document^ doc
)

Parameters

pipeLossMethodType
Type: Autodesk.Revit.DB.Plumbing..::..PipeLossMethodType
The PipeLossMethodType to get the user-visible name.
doc
Type: Autodesk.Revit.DB..::..Document
The document from which to get the PipeLossMethodType.

Remarks

The name is obtained in the current Revit language.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when information for the input PipeLossMethodType cannot be found.

See Also

LabelUtils Class
GetLabelFor Overload


LayoutRule Class

[image]

Revit 2013 API
LayoutRule Class
Members See Also Send Feedback
The LayoutRule object is a base object for all type of layout rules for Beam System within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LayoutRule : APIObject
Visual Basic
Public MustInherit Class LayoutRule _
    Inherits APIObject
Visual C++
public ref class LayoutRule abstract : public APIObject

Remarks

This class just used as the base class of those concrete LayoutRule classes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleClearSpacing
Autodesk.Revit.DB..::..LayoutRuleFixedDistance
Autodesk.Revit.DB..::..LayoutRuleFixedNumber
Autodesk.Revit.DB..::..LayoutRuleMaximumSpacing

See Also

LayoutRule Members


LayoutRule Members

[image] [image]

Revit 2013 API
LayoutRule Members
LayoutRule Class Methods Properties See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class


LayoutRule Methods

[image] [image]

Revit 2013 API
LayoutRule Methods
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRule Class


LayoutRule Properties

[image] [image]

Revit 2013 API
LayoutRule Properties
LayoutRule Class See Also Send Feedback

The LayoutRule type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LayoutRule Class


LayoutRuleClearSpacing Class

[image]

Revit 2013 API
LayoutRuleClearSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Clear-Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LayoutRuleClearSpacing : LayoutRule
Visual Basic
Public Class LayoutRuleClearSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleClearSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleClearSpacing myLayoutRuleClearSpacing =
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleClearSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleClearSpacing As New LayoutRuleClearSpacing(10, BeamSystemJustifyType.Beginning)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing

    Dim clearSpacing As LayoutRuleClearSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleClearSpacing)
    If clearSpacing Is Nothing Then
        Return False
    End If

    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = clearSpacing.JustifyType

    Dim spacing As Double = clearSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & clearSpacing.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing.ToString()
    message += vbLf & "New BeamSystem justification: " & justifyType.ToString()

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleClearSpacing

See Also

LayoutRuleClearSpacing Members


LayoutRuleClearSpacing Members

[image] [image]

Revit 2013 API
LayoutRuleClearSpacing Members
LayoutRuleClearSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleClearSpacing | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Constructor

[image]

Revit 2013 API
LayoutRuleClearSpacing Constructor
LayoutRuleClearSpacing Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleClearSpacing(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be in [0, 30000).
justifyType
Type: Autodesk.Revit.DB..::..BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Methods

[image] [image]

Revit 2013 API
LayoutRuleClearSpacing Methods
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleClearSpacing Class


LayoutRuleClearSpacing Properties

[image] [image]

Revit 2013 API
LayoutRuleClearSpacing Properties
LayoutRuleClearSpacing Class See Also Send Feedback

The LayoutRuleClearSpacing type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleClearSpacing Class


JustifyType Property

[image]

Revit 2013 API
LayoutRuleClearSpacing..::..JustifyType Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleClearSpacing Class


Spacing Property

[image]

Revit 2013 API
LayoutRuleClearSpacing..::..Spacing Property
LayoutRuleClearSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleClearSpacing Class


LayoutRuleFixedDistance Class

[image]

Revit 2013 API
LayoutRuleFixedDistance Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Distance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LayoutRuleFixedDistance : LayoutRule
Visual Basic
Public Class LayoutRuleFixedDistance _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedDistance : public LayoutRule

Remarks

To use this type of LayoutRule, the distance between the beams and the justify-type must be set.

Examples

CopyC#
private bool LayoutRuleFixedDistanceInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedDistance myLayoutRuleFixedDistance =
                new LayoutRuleFixedDistance(10.0, BeamSystemJustifyType.End);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance;

    LayoutRuleFixedDistance fixedDistance = beamSystem.LayoutRule as LayoutRuleFixedDistance;
    if (null == fixedDistance)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = fixedDistance.JustifyType;

    double spacing = fixedDistance.Spacing;

    message += "\nNew BeamSystem layout rule: " + fixedDistance;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedDistanceInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedDistance As New LayoutRuleFixedDistance(10, BeamSystemJustifyType.[End])

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedDistance

    Dim fixedDistance As LayoutRuleFixedDistance = TryCast(beamSystem.LayoutRule, LayoutRuleFixedDistance)
    If fixedDistance Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim justifyType As BeamSystemJustifyType = fixedDistance.JustifyType

    Dim spacing As Double = fixedDistance.Spacing

    message += vbLf & "New BeamSystem layout rule: " & fixedDistance.ToString()
    message += vbLf & "New BeamSystem spacing: " & spacing.ToString()
    message += vbLf & "New BeamSystem justification: " & justifyType.ToString()

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleFixedDistance

See Also

LayoutRuleFixedDistance Members


LayoutRuleFixedDistance Members

[image] [image]

Revit 2013 API
LayoutRuleFixedDistance Members
LayoutRuleFixedDistance Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleFixedDistance | Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Constructor

[image]

Revit 2013 API
LayoutRuleFixedDistance Constructor
LayoutRuleFixedDistance Class See Also Send Feedback
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)
Visual Basic
Public Sub New ( _
    spacing As Double, _
    justifyType As BeamSystemJustifyType _
)
Visual C++
public:
LayoutRuleFixedDistance(
    double spacing,
    BeamSystemJustifyType justifyType
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be between 0 and 30000.
justifyType
Type: Autodesk.Revit.DB..::..BeamSystemJustifyType
The type of the justification, it's corresponding to the items in the element properties dialog.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Methods

[image] [image]

Revit 2013 API
LayoutRuleFixedDistance Methods
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedDistance Properties

[image] [image]

Revit 2013 API
LayoutRuleFixedDistance Properties
LayoutRuleFixedDistance Class See Also Send Feedback

The LayoutRuleFixedDistance type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JustifyType | Get or set the type of justification.
Public property | Spacing | Get or set spacing of the Beam System.

See Also

LayoutRuleFixedDistance Class


JustifyType Property

[image]

Revit 2013 API
LayoutRuleFixedDistance..::..JustifyType Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set the type of justification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BeamSystemJustifyType JustifyType { get; set; }
Visual Basic
Public Property JustifyType As BeamSystemJustifyType
    Get
    Set
Visual C++
public:
property BeamSystemJustifyType JustifyType {
    BeamSystemJustifyType get ();
    void set (BeamSystemJustifyType value);
}

Remarks

The justifyType passed in must be a valid object.

See Also

LayoutRuleFixedDistance Class


Spacing Property

[image]

Revit 2013 API
LayoutRuleFixedDistance..::..Spacing Property
LayoutRuleFixedDistance Class See Also Send Feedback
Get or set spacing of the Beam System.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be between 0 and 30000.

See Also

LayoutRuleFixedDistance Class


LayoutRuleFixedNumber Class

[image]

Revit 2013 API
LayoutRuleFixedNumber Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Fixed-Number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LayoutRuleFixedNumber : LayoutRule
Visual Basic
Public Class LayoutRuleFixedNumber _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleFixedNumber : public LayoutRule

Remarks

To use this type of LayoutRule, only the number of the beams must be set.

Examples

CopyC#
private bool LayoutRuleFixedNumberInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleFixedNumber myLayoutRuleFixedNumber =
                        new LayoutRuleFixedNumber(8);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber;

    LayoutRuleFixedNumber fixedNumber = beamSystem.LayoutRule as LayoutRuleFixedNumber;

    if (null == fixedNumber)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    int numberOfLines = fixedNumber.NumberOfLines;

    message += "\nNew BeamSystem layout rule: " + fixedNumber;
    message += "\nNew BeamSystem number of beams: " + numberOfLines;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleFixedNumberInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleFixedNumber As New LayoutRuleFixedNumber(8)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleFixedNumber

    Dim fixedNumber As LayoutRuleFixedNumber = TryCast(beamSystem.LayoutRule, LayoutRuleFixedNumber)

    If fixedNumber Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim numberOfLines As Integer = fixedNumber.NumberOfLines

    message += vbLf & "New BeamSystem layout rule: " & fixedNumber.ToString()
    message += vbLf & "New BeamSystem number of beams: " + numberOfLines

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleFixedNumber

See Also

LayoutRuleFixedNumber Members


LayoutRuleFixedNumber Members

[image] [image]

Revit 2013 API
LayoutRuleFixedNumber Members
LayoutRuleFixedNumber Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleFixedNumber | Constructor of LayoutRuleFixedNumber.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Constructor

[image]

Revit 2013 API
LayoutRuleFixedNumber Constructor
LayoutRuleFixedNumber Class See Also Send Feedback
Constructor of LayoutRuleFixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LayoutRuleFixedNumber(
    int numberOfLines
)
Visual Basic
Public Sub New ( _
    numberOfLines As Integer _
)
Visual C++
public:
LayoutRuleFixedNumber(
    int numberOfLines
)

Parameters

numberOfLines
Type: System..::..Int32
The value of numberOfLines must be positive.

Remarks

Create a LayoutRuleFixedNumber object with the number of the beams and this number must be positive.

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Methods

[image] [image]

Revit 2013 API
LayoutRuleFixedNumber Methods
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleFixedNumber Class


LayoutRuleFixedNumber Properties

[image] [image]

Revit 2013 API
LayoutRuleFixedNumber Properties
LayoutRuleFixedNumber Class See Also Send Feedback

The LayoutRuleFixedNumber type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfLines | Get or set the number of the beams in a beam system.

See Also

LayoutRuleFixedNumber Class


NumberOfLines Property

[image]

Revit 2013 API
LayoutRuleFixedNumber..::..NumberOfLines Property
LayoutRuleFixedNumber Class See Also Send Feedback
Get or set the number of the beams in a beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfLines { get; set; }
Visual Basic
Public Property NumberOfLines As Integer
    Get
    Set
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

Remarks

The number must be positive.

See Also

LayoutRuleFixedNumber Class


LayoutRuleMaximumSpacing Class

[image]

Revit 2013 API
LayoutRuleMaximumSpacing Class
Members Example See Also Send Feedback
This class indicate the layout rule of a Beam System is Max-Spacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LayoutRuleMaximumSpacing : LayoutRule
Visual Basic
Public Class LayoutRuleMaximumSpacing _
    Inherits LayoutRule
Visual C++
public ref class LayoutRuleMaximumSpacing : public LayoutRule

Remarks

To use this type of LayoutRule, only the maximum spacing must be set and it must be in (0, 30000).

Examples

CopyC#
private bool LayoutRuleMaximumSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class
    LayoutRuleMaximumSpacing myLayoutRuleMaximumSpacing =
                        new LayoutRuleMaximumSpacing(10.0);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing;

    LayoutRuleMaximumSpacing maximunSpacing = beamSystem.LayoutRule as LayoutRuleMaximumSpacing;
    if (null == maximunSpacing)
    {
        return false;
    }
    //try to get the property value of the beamsystem LayoutRule
    double spacing = maximunSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + maximunSpacing;
    message += "\nNew BeamSystem maximum spacing: " + spacing;

    TaskDialog.Show("Revit",message);

    return true;
}
CopyVB.NET
Private Function LayoutRuleMaximumSpacingInformation(ByVal beamSystem As BeamSystem) As Boolean
    'get the layoutRule of the beamsystem
    Dim layoutRule As Autodesk.Revit.DB.LayoutRule = beamSystem.LayoutRule

    Dim message As String = "BeamSystem layout rule : " & layoutRule.ToString()

    'create a new instance of the LayoutRuleClearSpacing class
    Dim myLayoutRuleMaximumSpacing As New LayoutRuleMaximumSpacing(10)

    'set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleMaximumSpacing

    Dim maximunSpacing As LayoutRuleMaximumSpacing = TryCast(beamSystem.LayoutRule, LayoutRuleMaximumSpacing)
    If maximunSpacing Is Nothing Then
        Return False
    End If
    'try to get the property value of the beamsystem LayoutRule
    Dim spacing As Double = maximunSpacing.Spacing

    message += vbLf & "New BeamSystem layout rule: " & maximunSpacing.ToString()
    message += vbLf & "New BeamSystem maximum spacing: " + spacing

    TaskDialog.Show("Revit", message)

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LayoutRule
Autodesk.Revit.DB..::..LayoutRuleMaximumSpacing

See Also

LayoutRuleMaximumSpacing Members


LayoutRuleMaximumSpacing Members

[image] [image]

Revit 2013 API
LayoutRuleMaximumSpacing Members
LayoutRuleMaximumSpacing Class Constructors Methods Properties See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Constructors

 | Name | Description
Public method | LayoutRuleMaximumSpacing | Constructor of LayoutRuleMaximumSpacing.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Constructor

[image]

Revit 2013 API
LayoutRuleMaximumSpacing Constructor
LayoutRuleMaximumSpacing Class See Also Send Feedback
Constructor of LayoutRuleMaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LayoutRuleMaximumSpacing(
    double spacing
)
Visual Basic
Public Sub New ( _
    spacing As Double _
)
Visual C++
public:
LayoutRuleMaximumSpacing(
    double spacing
)

Parameters

spacing
Type: System..::..Double
The value of spacing must be in (0, 30000).

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Methods

[image] [image]

Revit 2013 API
LayoutRuleMaximumSpacing Methods
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LayoutRuleMaximumSpacing Class


LayoutRuleMaximumSpacing Properties

[image] [image]

Revit 2013 API
LayoutRuleMaximumSpacing Properties
LayoutRuleMaximumSpacing Class See Also Send Feedback

The LayoutRuleMaximumSpacing type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Spacing | Get or set the spacing of the beam system.

See Also

LayoutRuleMaximumSpacing Class


Spacing Property

[image]

Revit 2013 API
LayoutRuleMaximumSpacing..::..Spacing Property
LayoutRuleMaximumSpacing Class See Also Send Feedback
Get or set the spacing of the beam system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Spacing { get; set; }
Visual Basic
Public Property Spacing As Double
    Get
    Set
Visual C++
public:
property double Spacing {
    double get ();
    void set (double value);
}

Remarks

The value of spacing must be in (0, 30000), but in fact the spacing should not be too small or too great.

See Also

LayoutRuleMaximumSpacing Class


Leader Class

[image]

Revit 2013 API
Leader Class
Members See Also Send Feedback
An object that represents a Leader within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Leader : APIObject
Visual Basic
Public Class Leader _
    Inherits APIObject
Visual C++
public ref class Leader : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Leader.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Leader

See Also

Leader Members


Leader Members

[image] [image]

Revit 2013 API
Leader Members
Leader Class Methods Properties See Also Send Feedback

The Leader type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elbow | Retrieves and sets the Elbow point of the Leader.
Public property | End | Retrieves and sets the End point of the Leader.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class


Leader Methods

[image] [image]

Revit 2013 API
Leader Methods
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Leader Class


Leader Properties

[image] [image]

Revit 2013 API
Leader Properties
Leader Class See Also Send Feedback

The Leader type exposes the following members.

Properties

 | Name | Description
Public property | Elbow | Retrieves and sets the Elbow point of the Leader.
Public property | End | Retrieves and sets the End point of the Leader.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Leader Class


Elbow Property

[image]

Revit 2013 API
Leader..::..Elbow Property
Leader Class See Also Send Feedback
Retrieves and sets the Elbow point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Elbow { get; set; }
Visual Basic
Public Property Elbow As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Elbow {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Elbow point of the specified Leader object can be taken and set with this Elbow property.

See Also

Leader Class


End Property

[image]

Revit 2013 API
Leader..::..End Property
Leader Class See Also Send Feedback
Retrieves and sets the End point of the Leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ End { get; set; }
Visual Basic
Public Property End As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The End point of the specified Leader object can be taken and set with this End property.

See Also

Leader Class


LeaderArray Class

[image]

Revit 2013 API
LeaderArray Class
Members See Also Send Feedback
An array that can contain any number of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LeaderArray : APIObject,
    IEnumerable
Visual Basic
Public Class LeaderArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LeaderArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LeaderArray

See Also

LeaderArray Members


LeaderArray Members

[image] [image]

Revit 2013 API
LeaderArray Members
LeaderArray Class Constructors Methods Properties See Also Send Feedback

The LeaderArray type exposes the following members.

Constructors

 | Name | Description
Public method | LeaderArray | Initializes a new instance of the LeaderArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class


LeaderArray Constructor

[image]

Revit 2013 API
LeaderArray Constructor
LeaderArray Class See Also Send Feedback
Initializes a new instance of the LeaderArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LeaderArray()
Visual Basic
Public Sub New
Visual C++
public:
LeaderArray()

See Also

LeaderArray Class


LeaderArray Methods

[image] [image]

Revit 2013 API
LeaderArray Methods
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArray Class


Append Method

[image]

Revit 2013 API
LeaderArray..::..Append Method
LeaderArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Leader item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Leader _
)
Visual C++
public:
virtual void Append(
    Leader^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Leader
The item to be added.

See Also

LeaderArray Class


Clear Method

[image]

Revit 2013 API
LeaderArray..::..Clear Method
LeaderArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LeaderArray Class


ForwardIterator Method

[image]

Revit 2013 API
LeaderArray..::..ForwardIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LeaderArray Class


GetEnumerator Method

[image]

Revit 2013 API
LeaderArray..::..GetEnumerator Method
LeaderArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LeaderArray Class


Insert Method

[image]

Revit 2013 API
LeaderArray..::..Insert Method
LeaderArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Leader item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Leader, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Leader^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Leader
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

LeaderArray Class


ReverseIterator Method

[image]

Revit 2013 API
LeaderArray..::..ReverseIterator Method
LeaderArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LeaderArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LeaderArrayIterator
Visual C++
public:
virtual LeaderArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LeaderArray Class


LeaderArray Properties

[image] [image]

Revit 2013 API
LeaderArray Properties
LeaderArray Class See Also Send Feedback

The LeaderArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LeaderArray Class


IsEmpty Property

[image]

Revit 2013 API
LeaderArray..::..IsEmpty Property
LeaderArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LeaderArray Class


Item Property

[image]

Revit 2013 API
LeaderArray..::..Item Property
LeaderArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Leader this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Leader
    Get
    Set
Visual C++
public:
virtual property Leader^ Item[int index] {
    Leader^ get (int index);
    void set (int index, Leader^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LeaderArray Class


Size Property

[image]

Revit 2013 API
LeaderArray..::..Size Property
LeaderArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LeaderArray Class


LeaderArrayIterator Class

[image]

Revit 2013 API
LeaderArrayIterator Class
Members See Also Send Feedback
An iterator to an array of leaders.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LeaderArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LeaderArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LeaderArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LeaderArrayIterator

See Also

LeaderArrayIterator Members


LeaderArrayIterator Members

[image] [image]

Revit 2013 API
LeaderArrayIterator Members
LeaderArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LeaderArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class


LeaderArrayIterator Constructor

[image]

Revit 2013 API
LeaderArrayIterator Constructor
LeaderArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LeaderArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
LeaderArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LeaderArrayIterator Class


LeaderArrayIterator Methods

[image] [image]

Revit 2013 API
LeaderArrayIterator Methods
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LeaderArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
LeaderArrayIterator..::..MoveNext Method
LeaderArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class


Reset Method

[image]

Revit 2013 API
LeaderArrayIterator..::..Reset Method
LeaderArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LeaderArrayIterator Class


LeaderArrayIterator Properties

[image] [image]

Revit 2013 API
LeaderArrayIterator Properties
LeaderArrayIterator Class See Also Send Feedback

The LeaderArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LeaderArrayIterator Class


Current Property

[image]

Revit 2013 API
LeaderArrayIterator..::..Current Property
LeaderArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LeaderArrayIterator Class


LeaderEndCondition Enumeration

[image]

Revit 2013 API
LeaderEndCondition Enumeration
See Also Send Feedback
An enumerated type listing Leader end conditions that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LeaderEndCondition
Visual Basic
Public Enumeration LeaderEndCondition
Visual C++
public enum class LeaderEndCondition

Members

Member name | Description
Attached | The Leader of the tag is attached.
Free | The Leader of the tag is free.

See Also


Level Class

[image]

Revit 2013 API
Level Class
Members Example See Also Send Feedback
Represents a Level line within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Level : Element
Visual Basic
Public Class Level _
    Inherits Element
Visual C++
public ref class Level : public Element

Remarks

The Name property can be used to retrieve the user visible name of the level that appears in the level bubble.

Examples

CopyC#
private void Getinfo_Level(Document document)
{
    StringBuilder levelInformation = new StringBuilder();
    int levelNumber = 0;
    FilteredElementCollector collector = new FilteredElementCollector(document);
    ICollection<Element> collection = collector.OfClass(typeof(Level)).ToElements();
    foreach (Element e in collection)
    {
        Level level = e as Level;

        if (null != level)
        {
            // keep track of number of levels
            levelNumber++;

            //get the name of the level
            levelInformation.Append("\nLevel Name: " + level.Name);

            //get the elevation of the level
            levelInformation.Append("\n\tElevation: " + level.Elevation);

            // get the project elevation of the level
            levelInformation.Append("\n\tProject Elevation: " + level.ProjectElevation);
        }
    }

    //number of total levels in current document
    levelInformation.Append("\n\n There are " + levelNumber + " levels in the document!");

    //show the level information in the messagebox
    TaskDialog.Show("Revit",levelInformation.ToString());
}
CopyVB.NET
Private Sub Getinfo_Level(ByVal document As Document)
    Dim levelInformation As New StringBuilder()
    Dim levelNumber As Integer = 0
    Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
    Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Autodesk.Revit.DB.Level)).ToElements()
    For Each e As Autodesk.Revit.DB.Element In collection
        Dim level As Autodesk.Revit.DB.Level = TryCast(e, Autodesk.Revit.DB.Level)

        If level IsNot Nothing Then
            ' keep track of number of levels
            System.Math.Max(System.Threading.Interlocked.Increment(levelNumber), levelNumber - 1)

            'get the name of the level
            levelInformation.Append(vbLf & "Level Name: " + level.Name)

            'get the elevation of the level
            levelInformation.Append(vbLf & vbTab & "Elevation: " + level.Elevation)

            ' get the project elevation of the level
            levelInformation.Append(vbLf & vbTab & "Project Elevation: " + level.ProjectElevation)
        End If
    Next

    'number of total levels in current document
    levelInformation.Append(vbLf & vbLf & " There are " + levelNumber + " levels in the document!")

    'show the level information in the messagebox
    TaskDialog.Show("Revit", levelInformation.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Level

See Also

Level Members


Level Members

[image] [image]

Revit 2013 API
Level Members
Level Class Methods Properties See Also Send Feedback

The Level type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelType | The level style of this level.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlaneReference | Returns a reference to this element as a plane.
Public property | ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Level Class


Level Methods

[image] [image]

Revit 2013 API
Level Methods
Level Class See Also Send Feedback

The Level type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Level Class


Level Properties

[image] [image]

Revit 2013 API
Level Properties
Level Class See Also Send Feedback

The Level type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elevation | Retrieves or changes the elevation above or below the ground level.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelType | The level style of this level.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlaneReference | Returns a reference to this element as a plane.
Public property | ProjectElevation | Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Level Class


Elevation Property

[image]

Revit 2013 API
Level..::..Elevation Property
Level Class See Also Send Feedback
Retrieves or changes the elevation above or below the ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

This property retrieves or changes the elevation above or below the ground level of the project. If the Elevation Base parameter is set to Project, the elevation is relative to project origin. If the Elevation Base parameter is set to Shared, the elevation is relative to shared origin which can be changed by relocate operation. The value is given in decimal feet.

See Also

Level Class


LevelType Property

[image]

Revit 2013 API
Level..::..LevelType Property
Level Class See Also Send Feedback
The level style of this level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LevelType LevelType { get; set; }
Visual Basic
Public Property LevelType As LevelType
    Get
    Set
Visual C++
public:
property LevelType^ LevelType {
    LevelType^ get ();
    void set (LevelType^ value);
}

See Also

Level Class


Parameter Property

[image] [image]

Revit 2013 API
Level..::..Parameter Property
Level Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Level Class
Level Members


PlaneReference Property

[image]

Revit 2013 API
Level..::..PlaneReference Property
Level Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic
Public ReadOnly Property PlaneReference As Reference
    Get
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

Level Class


ProjectElevation Property

[image]

Revit 2013 API
Level..::..ProjectElevation Property
Level Class See Also Send Feedback
Retrieve the elevation relative to project origin, no matter what values of the Elevation Base parameter is set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ProjectElevation { get; }
Visual Basic
Public ReadOnly Property ProjectElevation As Double
    Get
Visual C++
public:
property double ProjectElevation {
    double get ();
}

Remarks

This read only property returns the elevation relative to project origin.

See Also

Level Class


LevelType Class

[image]

Revit 2013 API
LevelType Class
Members See Also Send Feedback
An object that represents a Level type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LevelType : LineAndTextAttrSymbol
Visual Basic
Public Class LevelType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class LevelType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..LevelType

See Also

LevelType Members


LevelType Members

[image] [image]

Revit 2013 API
LevelType Members
LevelType Class Methods Properties See Also Send Feedback

The LevelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LevelType Class


LevelType Methods

[image] [image]

Revit 2013 API
LevelType Methods
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelType Class


LevelType Properties

[image] [image]

Revit 2013 API
LevelType Properties
LevelType Class See Also Send Feedback

The LevelType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LevelType Class


Parameter Property

[image] [image]

Revit 2013 API
LevelType..::..Parameter Property
LevelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LevelType Class
LevelType Members


LevelTypeSet Class

[image]

Revit 2013 API
LevelTypeSet Class
Members See Also Send Feedback
A set that contains level types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LevelTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class LevelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LevelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LevelTypeSet

See Also

LevelTypeSet Members


LevelTypeSet Members

[image] [image]

Revit 2013 API
LevelTypeSet Members
LevelTypeSet Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | LevelTypeSet | Initializes a new instance of the LevelTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every level type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a level type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified level type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified level type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class


LevelTypeSet Constructor

[image]

Revit 2013 API
LevelTypeSet Constructor
LevelTypeSet Class See Also Send Feedback
Initializes a new instance of the LevelTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LevelTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
LevelTypeSet()

See Also

LevelTypeSet Class


LevelTypeSet Methods

[image] [image]

Revit 2013 API
LevelTypeSet Methods
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every level type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a level type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified level type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified level type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSet Class


Clear Method

[image]

Revit 2013 API
LevelTypeSet..::..Clear Method
LevelTypeSet Class See Also Send Feedback
Removes every level type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LevelTypeSet Class


Contains Method

[image]

Revit 2013 API
LevelTypeSet..::..Contains Method
LevelTypeSet Class See Also Send Feedback
Tests for the existence of a level type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    LevelType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..LevelType
The level type to be searched for.

Return Value

The Contains method returns True if the level type is within the set, otherwise False.

See Also

LevelTypeSet Class


Erase Method

[image]

Revit 2013 API
LevelTypeSet..::..Erase Method
LevelTypeSet Class See Also Send Feedback
Removes a specified level type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    LevelType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As LevelType _
) As Integer
Visual C++
public:
virtual int Erase(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..LevelType
The level type to be erased.

Return Value

The number of level types that were erased from the set.

See Also

LevelTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
LevelTypeSet..::..ForwardIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LevelTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
LevelTypeSet..::..GetEnumerator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LevelTypeSet Class


Insert Method

[image]

Revit 2013 API
LevelTypeSet..::..Insert Method
LevelTypeSet Class See Also Send Feedback
Insert the specified level type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    LevelType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As LevelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LevelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..LevelType
The level type to be inserted into the set.

Return Value

Returns whether the level type was inserted into the set.

See Also

LevelTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
LevelTypeSet..::..ReverseIterator Method
LevelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LevelTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LevelTypeSetIterator
Visual C++
public:
virtual LevelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LevelTypeSet Class


LevelTypeSet Properties

[image] [image]

Revit 2013 API
LevelTypeSet Properties
LevelTypeSet Class See Also Send Feedback

The LevelTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of level types that are in the set.

See Also

LevelTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
LevelTypeSet..::..IsEmpty Property
LevelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LevelTypeSet Class


Size Property

[image]

Revit 2013 API
LevelTypeSet..::..Size Property
LevelTypeSet Class See Also Send Feedback
Returns the number of level types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LevelTypeSet Class


LevelTypeSetIterator Class

[image]

Revit 2013 API
LevelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a level type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LevelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LevelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LevelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..LevelTypeSetIterator

See Also

LevelTypeSetIterator Members


LevelTypeSetIterator Members

[image] [image]

Revit 2013 API
LevelTypeSetIterator Members
LevelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LevelTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Constructor

[image]

Revit 2013 API
LevelTypeSetIterator Constructor
LevelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LevelTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
LevelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Methods

[image] [image]

Revit 2013 API
LevelTypeSetIterator Methods
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LevelTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
LevelTypeSetIterator..::..MoveNext Method
LevelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
LevelTypeSetIterator..::..Reset Method
LevelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LevelTypeSetIterator Class


LevelTypeSetIterator Properties

[image] [image]

Revit 2013 API
LevelTypeSetIterator Properties
LevelTypeSetIterator Class See Also Send Feedback

The LevelTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LevelTypeSetIterator Class


Current Property

[image]

Revit 2013 API
LevelTypeSetIterator..::..Current Property
LevelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LevelTypeSetIterator Class


LightingSource Enumeration

[image]

Revit 2013 API
LightingSource Enumeration
See Also Send Feedback
Indicates the lighting scheme type in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum LightingSource
Visual Basic
Public Enumeration LightingSource
Visual C++
public enum class LightingSource

Members

Member name | Description
ExteriorSun | Exterior source of light, sun only.
ExteriorSunAndArtificial | Exterior source of light, sun and artificial light.
ExteriorArtificial | Exterior source of light, artificial light only.
InteriorSun | Interior source of light, sun only.
InteriorSunAndArtificial | Interior source of light, sun and artificial light.
InteriorArtificial | Interior source of light, artificial light only.

See Also


Line Class

[image]

Revit 2013 API
Line Class
Members See Also Send Feedback
A line in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Line : Curve
Visual Basic
Public Class Line _
    Inherits Curve
Visual C++
public ref class Line : public Curve

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..Line

See Also

Line Members


Line Members

[image] [image]

Revit 2013 API
Line Members
Line Class Methods Properties See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | Direction | Returns the direction of the line.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Line Methods

[image] [image]

Revit 2013 API
Line Methods
Line Class See Also Send Feedback

The Line type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class


Intersect Method

[image] [image]

Revit 2013 API
Line..::..Intersect Method
Line Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

Line Class
Line Members


IsInside Method

[image] [image]

Revit 2013 API
Line..::..IsInside Method
Line Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

Line Class
Line Members


Line Properties

[image] [image]

Revit 2013 API
Line Properties
Line Class See Also Send Feedback

The Line type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
 | Bound | Returns the bounded line between the specified points.
Public property | Direction | Returns the direction of the line.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Origin | Returns the origin of the line.
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
 | Unbound | Returns the unbounded line that passes through the specified point in the direction of the specified vector.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Line Class


Bound Property

[image]

Revit 2013 API
Line..::..Bound Property
Line Class See Also Send Feedback
Returns the bounded line between the specified points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Line this[
    XYZ startPoint,
    XYZ endPoint
] { get; }
Visual Basic
Public Shared ReadOnly Property Bound ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Line
    Get
Visual C++
public:
static property Line^ Bound[XYZ^ startPoint, XYZ^ endPoint] {
    Line^ get (XYZ^ startPoint, XYZ^ endPoint);
}

Parameters

startPoint
Type: Autodesk.Revit.DB..::..XYZ
The start point of the line.
endPoint
Type: Autodesk.Revit.DB..::..XYZ
The end point of the line.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified points are almost equal.

See Also

Line Class


Direction Property

[image]

Revit 2013 API
Line..::..Direction Property
Line Class See Also Send Feedback
Returns the direction of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

Line Class


Origin Property

[image]

Revit 2013 API
Line..::..Origin Property
Line Class See Also Send Feedback
Returns the origin of the line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

Line Class


Unbound Property

[image]

Revit 2013 API
Line..::..Unbound Property
Line Class See Also Send Feedback
Returns the unbounded line that passes through the specified point in the direction of the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Line this[
    XYZ origin,
    XYZ vector
] { get; }
Visual Basic
Public Shared ReadOnly Property Unbound ( _
    origin As XYZ, _
    vector As XYZ _
) As Line
    Get
Visual C++
public:
static property Line^ Unbound[XYZ^ origin, XYZ^ vector] {
    Line^ get (XYZ^ origin, XYZ^ vector);
}

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The start point of the line.
vector
Type: Autodesk.Revit.DB..::..XYZ
The direction vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified vector is almost zero and cannot be normalized.

See Also

Line Class


LineAndTextAttrSymbol Class

[image]

Revit 2013 API
LineAndTextAttrSymbol Class
Members See Also Send Feedback
An object that represents a dimension style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LineAndTextAttrSymbol : ElementType
Visual Basic
Public Class LineAndTextAttrSymbol _
    Inherits ElementType
Visual C++
public ref class LineAndTextAttrSymbol : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..FilledRegionType
Autodesk.Revit.DB..::..GridType
Autodesk.Revit.DB..::..LevelType
Autodesk.Revit.DB..::..TextElementType

See Also

LineAndTextAttrSymbol Members


LineAndTextAttrSymbol Members

[image] [image]

Revit 2013 API
LineAndTextAttrSymbol Members
LineAndTextAttrSymbol Class Methods Properties See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Methods

[image] [image]

Revit 2013 API
LineAndTextAttrSymbol Methods
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineAndTextAttrSymbol Class


LineAndTextAttrSymbol Properties

[image] [image]

Revit 2013 API
LineAndTextAttrSymbol Properties
LineAndTextAttrSymbol Class See Also Send Feedback

The LineAndTextAttrSymbol type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class


Parameter Property

[image] [image]

Revit 2013 API
LineAndTextAttrSymbol..::..Parameter Property
LineAndTextAttrSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LineAndTextAttrSymbol Class
LineAndTextAttrSymbol Members


LinearArray Class

[image]

Revit 2013 API
LinearArray Class
Members See Also Send Feedback
An object that represents an Array created linearly within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LinearArray : BaseArray
Visual Basic
Public Class LinearArray _
    Inherits BaseArray
Visual C++
public ref class LinearArray : public BaseArray

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..LinearArray

See Also

LinearArray Members


LinearArray Members

[image] [image]

Revit 2013 API
LinearArray Members
LinearArray Class Methods Properties See Also Send Feedback

The LinearArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsElementArrayable | Indicates whether the input element is arrayable.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinearArray Class


LinearArray Methods

[image] [image]

Revit 2013 API
LinearArray Methods
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new linear array from a set of elements.
 | ArrayElementWithoutAssociation | Creates a new linear array from a single element.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsElementArrayable | Indicates whether the input element is arrayable.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinearArray Class


ArrayElementsWithoutAssociation Method

[image]

Revit 2013 API
LinearArray..::..ArrayElementsWithoutAssociation Method
LinearArray Class See Also Send Feedback
Creates a new linear array from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementsWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The ids of the elements created during the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ids is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class


ArrayElementWithoutAssociation Method

[image]

Revit 2013 API
LinearArray..::..ArrayElementWithoutAssociation Method
LinearArray Class See Also Send Feedback
Creates a new linear array from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The ids of the elements created during the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class


Create Method

[image] [image]

Revit 2013 API
LinearArray..::..Create Method
LinearArray Class See Also Send Feedback

Overload List

Name | Description
Create(Document, View, ElementId, Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a single element.
Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, XYZ, ArrayAnchorMember) | Creates a new linear array element from a set of elements.

See Also

LinearArray Class
LinearArray Members


Create Method (Document, View, ElementId, Int32, XYZ, ArrayAnchorMember)

[image]

Revit 2013 API
LinearArray..::..Create Method (Document, View, ElementId, Int32, XYZ, ArrayAnchorMember)
LinearArray Class See Also Send Feedback
Creates a new linear array element from a single element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As LinearArray
Visual C++
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new linear array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class
Create Overload


Create Method (Document, View, ICollection(ElementId), Int32, XYZ, ArrayAnchorMember)

[image]

Revit 2013 API
LinearArray..::..Create Method (Document, View, ICollection<(Of <(<'ElementId>)>)>, Int32, XYZ, ArrayAnchorMember)
LinearArray Class See Also Send Feedback
Creates a new linear array element from a set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static LinearArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    XYZ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    translationToAnchorMember As XYZ, _
    anchorMember As ArrayAnchorMember _
) As LinearArray
Visual C++
public:
static LinearArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    XYZ^ translationToAnchorMember,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements to array.
count
Type: System..::..Int32
The number of array members to create including the initial element grouping. Must between 2 and 200.
translationToAnchorMember
Type: Autodesk.Revit.DB..::..XYZ
The translation vector for the array.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new linear array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ids is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 2 and 200. -or- The view is invalid for specific view elements array. -or- The translation point vector is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the linear array.

See Also

LinearArray Class
Create Overload


GetCopiedMemberIds Method

[image]

Revit 2013 API
LinearArray..::..GetCopiedMemberIds Method
LinearArray Class See Also Send Feedback
Retrieves the copied member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetCopiedMemberIds()
Visual Basic
Public Overrides Function GetCopiedMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() override

Return Value

The copied member Ids of the Array

See Also

LinearArray Class


GetOriginalMemberIds Method

[image]

Revit 2013 API
LinearArray..::..GetOriginalMemberIds Method
LinearArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override

Return Value

The original member Ids of the Array

See Also

LinearArray Class


IsElementArrayable Method

[image]

Revit 2013 API
LinearArray..::..IsElementArrayable Method
LinearArray Class See Also Send Feedback
Indicates whether the input element is arrayable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsElementArrayable(
    Document aDoc,
    ElementId id
)
Visual Basic
Public Shared Function IsElementArrayable ( _
    aDoc As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementArrayable(
    Document^ aDoc,
    ElementId^ id
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the input element is arrayable, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinearArray Class


IsValidArraySize Method

[image]

Revit 2013 API
LinearArray..::..IsValidArraySize Method
LinearArray Class See Also Send Feedback
This indicates whether the input count is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidArraySize(
    int count
)
Visual Basic
Public Shared Function IsValidArraySize ( _
    count As Integer _
) As Boolean
Visual C++
public:
static bool IsValidArraySize(
    int count
)

Parameters

count
Type: System..::..Int32
The count.

Return Value

True if the input count is between 2 and 200, false otherwise.

See Also

LinearArray Class


LinearArray Properties

[image] [image]

Revit 2013 API
LinearArray Properties
LinearArray Class See Also Send Feedback

The LinearArray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinearArray Class


CopyMembers Property

[image]

Revit 2013 API
LinearArray..::..CopyMembers Property
LinearArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public override ElementArray CopyMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")> _
Public Overrides ReadOnly Property CopyMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class


NumMembers Property

[image]

Revit 2013 API
LinearArray..::..NumMembers Property
LinearArray Class See Also Send Feedback
Retrieves or changes the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic
Public Overrides Property NumMembers As Integer
    Get
    Set
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

LinearArray Class


OrigMembers Property

[image]

Revit 2013 API
LinearArray..::..OrigMembers Property
LinearArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public override ElementArray OrigMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")> _
Public Overrides ReadOnly Property OrigMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

LinearArray Class


Parameter Property

[image] [image]

Revit 2013 API
LinearArray..::..Parameter Property
LinearArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LinearArray Class
LinearArray Members


LinePattern Class

[image]

Revit 2013 API
LinePattern Class
Members See Also Send Feedback
Represents a line pattern definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LinePattern : IDisposable
Visual Basic
Public Class LinePattern _
    Implements IDisposable
Visual C++
public ref class LinePattern : IDisposable

Remarks

A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit. Line patterns are used in the definition of GraphicsStyle objects. A line pattern is defined by a repeating sequence segments. Each segment is a dash, a dot or a space. A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinePattern

See Also

LinePattern Members


LinePattern Members

[image] [image]

Revit 2013 API
LinePattern Members
LinePattern Class Constructors Methods Properties See Also Send Feedback

The LinePattern type exposes the following members.

Constructors

 | Name | Description
Public method | LinePattern()()()() | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePattern
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | Line pattern name.

See Also

LinePattern Class


LinePattern Constructor

[image] [image]

Revit 2013 API
LinePattern Constructor
LinePattern Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinePattern()()()() | Creates a simple line pattern.
Public method | LinePattern(String) | Creates a line pattern with given name.

See Also

LinePattern Class
LinePattern Members


LinePattern Constructor

[image]

Revit 2013 API
LinePattern Constructor
LinePattern Class See Also Send Feedback
Creates a simple line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePattern()
Visual Basic
Public Sub New
Visual C++
public:
LinePattern()

See Also

LinePattern Class
LinePattern Overload


LinePattern Constructor (String)

[image]

Revit 2013 API
LinePattern Constructor (String)
LinePattern Class See Also Send Feedback
Creates a line pattern with given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePattern(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
LinePattern(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePattern Class
LinePattern Overload


LinePattern Methods

[image] [image]

Revit 2013 API
LinePattern Methods
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSegments | Gets the sequence of segments that defines this line pattern.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetSegments | Sets the sequence of segments that defines this line pattern.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePattern Class


Dispose Method

[image]

Revit 2013 API
LinePattern..::..Dispose Method
LinePattern Class See Also Send Feedback
Releases all resources used by the LinePattern

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LinePattern Class


GetSegments Method

[image]

Revit 2013 API
LinePattern..::..GetSegments Method
LinePattern Class See Also Send Feedback
Gets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<LinePatternSegment> GetSegments()
Visual Basic
Public Function GetSegments As IList(Of LinePatternSegment)
Visual C++
public:
IList<LinePatternSegment^>^ GetSegments()

Return Value

The sequence of segments.

See Also

LinePattern Class


SetSegments Method

[image]

Revit 2013 API
LinePattern..::..SetSegments Method
LinePattern Class See Also Send Feedback
Sets the sequence of segments that defines this line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegments(
    IList<LinePatternSegment> lineSegs
)
Visual Basic
Public Sub SetSegments ( _
    lineSegs As IList(Of LinePatternSegment) _
)
Visual C++
public:
void SetSegments(
    IList<LinePatternSegment^>^ lineSegs
)

Parameters

lineSegs
Type: System.Collections.Generic..::..IList<(Of <(<'LinePatternSegment>)>)>
The sequence of segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePattern Class


LinePattern Properties

[image] [image]

Revit 2013 API
LinePattern Properties
LinePattern Class See Also Send Feedback

The LinePattern type exposes the following members.

Properties

 | Name | Description
Public property | Name | Line pattern name.

See Also

LinePattern Class


Name Property

[image]

Revit 2013 API
LinePattern..::..Name Property
LinePattern Class See Also Send Feedback
Line pattern name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

LinePattern Class


LinePatternElement Class

[image]

Revit 2013 API
LinePatternElement Class
Members See Also Send Feedback
An element that represents a line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class LinePatternElement : Element
Visual Basic
Public Class LinePatternElement _
    Inherits Element
Visual C++
public ref class LinePatternElement : public Element

Remarks

The LinePatternElement represents a line pattern in a project. It enables the user to retrieve, modify or create a line pattern in a project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..LinePatternElement

See Also

LinePatternElement Members


LinePatternElement Members

[image] [image]

Revit 2013 API
LinePatternElement Members
LinePatternElement Class Methods Properties See Also Send Feedback

The LinePatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinePatternElement Class


LinePatternElement Methods

[image] [image]

Revit 2013 API
LinePatternElement Methods
LinePatternElement Class See Also Send Feedback

The LinePatternElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new LinePatternElement.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.
 | GetLinePatternElementByName | Retrieves the LinePatternElement by its name.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
 | GetSolidPatternId | Gets the solid line pattern element id.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinePattern | Sets the LinePattern associated to this element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternElement Class


Create Method

[image]

Revit 2013 API
LinePatternElement..::..Create Method
LinePatternElement Class See Also Send Feedback
Creates a new LinePatternElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static LinePatternElement Create(
    Document document,
    LinePattern linePattern
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    linePattern As LinePattern _
) As LinePatternElement
Visual C++
public:
static LinePatternElement^ Create(
    Document^ document,
    LinePattern^ linePattern
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the LinePatternElement.
linePattern
Type: Autodesk.Revit.DB..::..LinePattern
The LinePattern associated to the newly created LinePatternElement.

Return Value

The newly created LinePatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePatternElement Class


GetLinePattern Method

[image] [image]

Revit 2013 API
LinePatternElement..::..GetLinePattern Method
LinePatternElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetLinePattern()()()() | Gets the LinePattern associated to this element.
 | GetLinePattern(Document, ElementId) | Gets the LinePattern associated to an element or from a built-in line pattern.

See Also

LinePatternElement Class
LinePatternElement Members


GetLinePattern Method

[image]

Revit 2013 API
LinePatternElement..::..GetLinePattern Method
LinePatternElement Class See Also Send Feedback
Gets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinePattern GetLinePattern()
Visual Basic
Public Function GetLinePattern As LinePattern
Visual C++
public:
LinePattern^ GetLinePattern()

Return Value

A copy of LinePattern object.

See Also

LinePatternElement Class
GetLinePattern Overload


GetLinePattern Method (Document, ElementId)

[image]

Revit 2013 API
LinePatternElement..::..GetLinePattern Method (Document, ElementId)
LinePatternElement Class See Also Send Feedback
Gets the LinePattern associated to an element or from a built-in line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static LinePattern GetLinePattern(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetLinePattern ( _
    document As Document, _
    elementId As ElementId _
) As LinePattern
Visual C++
public:
static LinePattern^ GetLinePattern(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the LinePattern.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the LinePatternElement or the built-in line pattern id.

Return Value

A copy of LinePattern object. nullNothingnullptra null reference (Nothing in Visual Basic) if the ElementId doesn't represent a line pattern element or built-in line pattern. nullNothingnullptra null reference (Nothing in Visual Basic) for Solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePatternElement Class
GetLinePattern Overload


GetLinePatternElementByName Method

[image]

Revit 2013 API
LinePatternElement..::..GetLinePatternElementByName Method
LinePatternElement Class See Also Send Feedback
Retrieves the LinePatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static LinePatternElement GetLinePatternElementByName(
    Document document,
    string name
)
Visual Basic
Public Shared Function GetLinePatternElementByName ( _
    document As Document, _
    name As String _
) As LinePatternElement
Visual C++
public:
static LinePatternElement^ GetLinePatternElementByName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to retrieve the LinePatternElement.
name
Type: System..::..String
The name of the LinePatternElement.

Return Value

The LinePatternElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePatternElement Class


GetSolidPatternId Method

[image]

Revit 2013 API
LinePatternElement..::..GetSolidPatternId Method
LinePatternElement Class See Also Send Feedback
Gets the solid line pattern element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetSolidPatternId()
Visual Basic
Public Shared Function GetSolidPatternId As ElementId
Visual C++
public:
static ElementId^ GetSolidPatternId()

Return Value

The element id of the solid line pattern.

Remarks

Note that Solid is special. It isn't a line pattern at all -- it is a special code that tells drawing and export code to use solid lines rather than patterned lines. Solid is visible to the user when selecting line patterns.

See Also

LinePatternElement Class


SetLinePattern Method

[image]

Revit 2013 API
LinePatternElement..::..SetLinePattern Method
LinePatternElement Class See Also Send Feedback
Sets the LinePattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetLinePattern(
    LinePattern newLinePattern
)
Visual Basic
Public Sub SetLinePattern ( _
    newLinePattern As LinePattern _
)
Visual C++
public:
void SetLinePattern(
    LinePattern^ newLinePattern
)

Parameters

newLinePattern
Type: Autodesk.Revit.DB..::..LinePattern
The new LinePattern object.

Remarks

The data stored inside the input LinePattern will be copied into this element. The input LinePattern itself will not be associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Line Pattern is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LinePatternElement Class


LinePatternElement Properties

[image] [image]

Revit 2013 API
LinePatternElement Properties
LinePatternElement Class See Also Send Feedback

The LinePatternElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LinePatternElement Class


Parameter Property

[image] [image]

Revit 2013 API
LinePatternElement..::..Parameter Property
LinePatternElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LinePatternElement Class
LinePatternElement Members


LinePatternSegment Class

[image]

Revit 2013 API
LinePatternSegment Class
Members See Also Send Feedback
Represents a segment in a line pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LinePatternSegment : IDisposable
Visual Basic
Public Class LinePatternSegment _
    Implements IDisposable
Visual C++
public ref class LinePatternSegment : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinePatternSegment

See Also

LinePatternSegment Members


LinePatternSegment Members

[image] [image]

Revit 2013 API
LinePatternSegment Members
LinePatternSegment Class Constructors Methods Properties See Also Send Feedback

The LinePatternSegment type exposes the following members.

Constructors

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LinePatternSegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class


LinePatternSegment Constructor

[image] [image]

Revit 2013 API
LinePatternSegment Constructor
LinePatternSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinePatternSegment()()()() | Creates a line pattern segment.
Public method | LinePatternSegment(LinePatternSegmentType, Double) | Creates a line pattern segment with given type and length.

See Also

LinePatternSegment Class
LinePatternSegment Members


LinePatternSegment Constructor

[image]

Revit 2013 API
LinePatternSegment Constructor
LinePatternSegment Class See Also Send Feedback
Creates a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternSegment()
Visual Basic
Public Sub New
Visual C++
public:
LinePatternSegment()

See Also

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment Constructor (LinePatternSegmentType, Double)

[image]

Revit 2013 API
LinePatternSegment Constructor (LinePatternSegmentType, Double)
LinePatternSegment Class See Also Send Feedback
Creates a line pattern segment with given type and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternSegment(
    LinePatternSegmentType type,
    double length
)
Visual Basic
Public Sub New ( _
    type As LinePatternSegmentType, _
    length As Double _
)
Visual C++
public:
LinePatternSegment(
    LinePatternSegmentType type,
    double length
)

Parameters

type
Type: Autodesk.Revit.DB..::..LinePatternSegmentType
The segment type.
length
Type: System..::..Double
The length.

See Also

LinePatternSegment Class
LinePatternSegment Overload


LinePatternSegment Methods

[image] [image]

Revit 2013 API
LinePatternSegment Methods
LinePatternSegment Class See Also Send Feedback

The LinePatternSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinePatternSegment Class


Dispose Method

[image]

Revit 2013 API
LinePatternSegment..::..Dispose Method
LinePatternSegment Class See Also Send Feedback
Releases all resources used by the LinePatternSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LinePatternSegment Class


LinePatternSegment Properties

[image] [image]

Revit 2013 API
LinePatternSegment Properties
LinePatternSegment Class See Also Send Feedback

The LinePatternSegment type exposes the following members.

Properties

 | Name | Description
Public property | Length | Gets and sets the length of the segment.
Public property | Type | Gets and sets the type of the segment.

See Also

LinePatternSegment Class


Length Property

[image]

Revit 2013 API
LinePatternSegment..::..Length Property
LinePatternSegment Class See Also Send Feedback
Gets and sets the length of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; set; }
Visual Basic
Public Property Length As Double
    Get
    Set
Visual C++
public:
property double Length {
    double get ();
    void set (double value);
}

Field Value

The length of the segment.

See Also

LinePatternSegment Class


Type Property

[image]

Revit 2013 API
LinePatternSegment..::..Type Property
LinePatternSegment Class See Also Send Feedback
Gets and sets the type of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternSegmentType Type { get; set; }
Visual Basic
Public Property Type As LinePatternSegmentType
    Get
    Set
Visual C++
public:
property LinePatternSegmentType Type {
    LinePatternSegmentType get ();
    void set (LinePatternSegmentType value);
}

See Also

LinePatternSegment Class


LinePatternSegmentType Enumeration

[image]

Revit 2013 API
LinePatternSegmentType Enumeration
See Also Send Feedback
Represents the type of a line pattern segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LinePatternSegmentType
Visual Basic
Public Enumeration LinePatternSegmentType
Visual C++
public enum class LinePatternSegmentType

Members

Member name | Description
Dash | A dash
Space | A space
Dot | A dot
Invalid |

See Also


LineScaling Enumeration

[image]

Revit 2013 API
LineScaling Enumeration
See Also Send Feedback
An enumerated type listing possible LineType scaling modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LineScaling
Visual Basic
Public Enumeration LineScaling
Visual C++
public enum class LineScaling

Members

Member name | Description
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity.
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0.
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE.

Remarks

Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash. Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.

See Also


LinkedFileStatus Enumeration

[image]

Revit 2013 API
LinkedFileStatus Enumeration
See Also Send Feedback
Enum displaying the loaded status of a linked file

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum LinkedFileStatus
Visual Basic
Public Enumeration LinkedFileStatus
Visual C++
public enum class LinkedFileStatus

Members

Member name | Description
Invalid | This value is the uninitialized value for the enum. It indicates that the link has not been properly initialized.
Loaded | The link is loaded.
Unloaded | The link is unloaded.
Imported | The element represented by this value was imported into Revit rather than linked into Revit.
NotFound | The linked file was not able to be found the last time Revit tried to load it.

See Also


LinkElementId Class

[image]

Revit 2013 API
LinkElementId Class
Members See Also Send Feedback
LinkElementId represents an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class LinkElementId
Visual Basic
Public Class LinkElementId
Visual C++
public ref class LinkElementId

Remarks

The id contains two element ids:
  1. The id of the linked model element in host document.
  2. The id of the element in the linked model document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..LinkElementId

See Also

LinkElementId Members


LinkElementId Members

[image] [image]

Revit 2013 API
LinkElementId Members
LinkElementId Class Constructors Methods Operators Properties See Also Send Feedback

The LinkElementId type exposes the following members.

Constructors

 | Name | Description
Public method | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
Public method | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether these two LinkElementIds are the same.
Inequality | Determines whether these two LinkElementIds are different.

Properties

 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.

See Also

LinkElementId Class


LinkElementId Constructor

[image] [image]

Revit 2013 API
LinkElementId Constructor
LinkElementId Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LinkElementId(ElementId) | Creates a new LinkElementId representing an element in the host document.
Public method | LinkElementId(ElementId, ElementId) | Creates a new LinkElementId representing an element in a linked document.

See Also

LinkElementId Class
LinkElementId Members


LinkElementId Constructor (ElementId)

[image]

Revit 2013 API
LinkElementId Constructor (ElementId)
LinkElementId Class See Also Send Feedback
Creates a new LinkElementId representing an element in the host document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId elementId
)
Visual Basic
Public Sub New ( _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in the host document.

See Also

LinkElementId Class
LinkElementId Overload


LinkElementId Constructor (ElementId, ElementId)

[image]

Revit 2013 API
LinkElementId Constructor (ElementId, ElementId)
LinkElementId Class See Also Send Feedback
Creates a new LinkElementId representing an element in a linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LinkElementId(
    ElementId linkInstanceId,
    ElementId elementId
)
Visual Basic
Public Sub New ( _
    linkInstanceId As ElementId, _
    elementId As ElementId _
)
Visual C++
public:
LinkElementId(
    ElementId^ linkInstanceId,
    ElementId^ elementId
)

Parameters

linkInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The id of the linked model element in the host document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in the linked model document.

See Also

LinkElementId Class
LinkElementId Overload


LinkElementId Methods

[image] [image]

Revit 2013 API
LinkElementId Methods
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LinkElementId Class


Equals Method

[image]

Revit 2013 API
LinkElementId..::..Equals Method
LinkElementId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

LinkElementId Class


LinkElementId Operators

[image] [image]

Revit 2013 API
LinkElementId Operators
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Operators

Name | Description
Equality | Determines whether these two LinkElementIds are the same.
Inequality | Determines whether these two LinkElementIds are different.

See Also

LinkElementId Class


Equality Operator

[image]

Revit 2013 API
LinkElementId..::..Equality Operator
LinkElementId Class See Also Send Feedback
Determines whether these two LinkElementIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    LinkElementId first,
    LinkElementId second
)
Visual Basic
Public Shared Operator = ( _
    first As LinkElementId, _
    second As LinkElementId _
) As Boolean
Visual C++
public:
static bool operator ==(
    LinkElementId^ first,
    LinkElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..LinkElementId
The first LinkElementId.
second
Type: Autodesk.Revit.DB..::..LinkElementId
The second LinkElementId.

Return Value

True if the LinkElementIds are the same; otherwise, false.

See Also

LinkElementId Class


Inequality Operator

[image]

Revit 2013 API
LinkElementId..::..Inequality Operator
LinkElementId Class See Also Send Feedback
Determines whether these two LinkElementIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    LinkElementId first,
    LinkElementId second
)
Visual Basic
Public Shared Operator <> ( _
    first As LinkElementId, _
    second As LinkElementId _
) As Boolean
Visual C++
public:
static bool operator !=(
    LinkElementId^ first,
    LinkElementId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..LinkElementId
The first LinkElementId.
second
Type: Autodesk.Revit.DB..::..LinkElementId
The second LinkElementId.

Return Value

True if the LinkElementIds are different; otherwise, false.

See Also

LinkElementId Class


LinkElementId Properties

[image] [image]

Revit 2013 API
LinkElementId Properties
LinkElementId Class See Also Send Feedback

The LinkElementId type exposes the following members.

Properties

 | Name | Description
Public property | HostElementId | The id of the element in the host, or invalidElementId if there is a link.
Public property | LinkedElementId | The id of the element in the link, or invalidElementId if no link.
Public property | LinkInstanceId | The id of the link, or invalidElementId if no link.

See Also

LinkElementId Class


HostElementId Property

[image]

Revit 2013 API
LinkElementId..::..HostElementId Property
LinkElementId Class See Also Send Feedback
The id of the element in the host, or invalidElementId if there is a link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId HostElementId { get; }
Visual Basic
Public ReadOnly Property HostElementId As ElementId
    Get
Visual C++
public:
property ElementId^ HostElementId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkedElementId Property

[image]

Revit 2013 API
LinkElementId..::..LinkedElementId Property
LinkElementId Class See Also Send Feedback
The id of the element in the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LinkedElementId { get; }
Visual Basic
Public ReadOnly Property LinkedElementId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkedElementId {
    ElementId^ get ();
}

See Also

LinkElementId Class


LinkInstanceId Property

[image]

Revit 2013 API
LinkElementId..::..LinkInstanceId Property
LinkElementId Class See Also Send Feedback
The id of the link, or invalidElementId if no link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId LinkInstanceId { get; }
Visual Basic
Public ReadOnly Property LinkInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ LinkInstanceId {
    ElementId^ get ();
}

See Also

LinkElementId Class


Location Class

[image]

Revit 2013 API
Location Class
Members Example See Also Send Feedback
Provides location functionality for all elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Location : APIObject
Visual Basic
Public Class Location _
    Inherits APIObject
Visual C++
public ref class Location : public APIObject

Remarks

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.

Examples

CopyC#
void ShowLocationUsage(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    // Get the location instance.
    Autodesk.Revit.DB.Location position = wall.Location;

    // Check whether the wall is pinned.
    if (wall.Pinned)
    {
        throw new Exception("The wall has been pinned.");
    }

    // Move the wall location, it provides same fuction as Move method of Document class.
    XYZ direction = new XYZ(10, 0, 0);
    bool result = position.Move(direction);
    if (!result)
    {
        throw new Exception("Move wall location failed.");
    }

    // Rotate the wall location, it provides same fuction as Rotate method of Document class.
    XYZ axisStart = new XYZ(0, 0, 0);
    XYZ axisEnd = new XYZ(0, 0, 1);
    Line axis = application.Create.NewLineUnbound(axisStart, axisEnd);
    result = position.Rotate(axis, 30);
    if (!result)
    {
        throw new Exception("Rotate wall location failed.");
    }
}
CopyVB.NET
Sub ShowLocationUsage(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall)
    ' Get the location instance.
    Dim position As Autodesk.Revit.DB.Location = wall.Location

    ' Check whether the wall is pinned.
    If wall.Pinned Then
        Throw New Exception("The wall has been pinned.")
    End If

    ' Move the wall location, it provides same fuction as Move method of Document class.
    Dim direction As New Autodesk.Revit.DB.XYZ(10, 0, 0)
    Dim result As Boolean = position.Move(direction)
    If Not result Then
        Throw New Exception("Move wall location failed.")
    End If

    ' Rotate the wall location, it provides same fuction as Rotate method of Document class.
    Dim axisStart As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim axisEnd As New Autodesk.Revit.DB.XYZ(0, 0, 1)
    Dim axis As Line = application.Create.NewLineUnbound(axisStart, axisEnd)
    result = position.Rotate(axis, 30)
    If Not result Then
        Throw New Exception("Rotate wall location failed.")
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationCurve
Autodesk.Revit.DB..::..LocationPoint

See Also

Location Members


Location Members

[image] [image]

Revit 2013 API
Location Members
Location Class Methods Properties See Also Send Feedback

The Location type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector.
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


Location Methods

[image] [image]

Revit 2013 API
Location Methods
Location Class See Also Send Feedback

The Location type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector.
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Location Class


Move Method

[image]

Revit 2013 API
Location..::..Move Method
Location Class Example See Also Send Feedback
Move the element within the project by a specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Move(
    XYZ translation
)
Visual Basic
Public Function Move ( _
    translation As XYZ _
) As Boolean
Visual C++
public:
bool Move(
    XYZ^ translation
)

Parameters

translation
Type: Autodesk.Revit.DB..::..XYZ
The vector by which the element is to be moved.

Return Value

If the element is moved successfully then the method return True, otherwise False.

Remarks

The move method is used to move an element within the project. Other elements may also be moved when this element is moved, for example: if the element is wall and it contains windows, the windows will also be moved.

Examples

CopyC#
bool MoveUsingLocationCurve(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ translationVec = new XYZ(10, 20, 0);
    return (wallLine.Move(translationVec));
}
CopyVB.NET
Function MoveUsingLocationCurve(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall) As Boolean
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim translationVec As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Return (wallLine.Move(translationVec))
End Function

See Also

Location Class


Rotate Method

[image]

Revit 2013 API
Location..::..Rotate Method
Location Class Example See Also Send Feedback
Rotate the element within the project by a specified angle around a given axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Rotate(
    Line axis,
    double angle
)
Visual Basic
Public Function Rotate ( _
    axis As Line, _
    angle As Double _
) As Boolean
Visual C++
public:
bool Rotate(
    Line^ axis,
    double angle
)

Parameters

axis
Type: Autodesk.Revit.DB..::..Line
An unbounded line that represents the axis of rotation.
angle
Type: System..::..Double
The angle, in radians, by which the element is to be rotated around the specified axis.

Return Value

If the element is rotate successfully then the method returns True, otherwise False.

Remarks

The rotate method is used to rotate an element within the project. Other elements may also be rotated when this element is rotated because they are dependent upon the element being rotated. An unbounded line for the axis can be created by using the Application.Create object and its methods.

Examples

CopyC#
bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    // Rotate the element via its location curve.
    LocationCurve curve = element.Location as LocationCurve;
    if (null != curve)
    {
        Curve line = curve.Curve;
        XYZ aa = line.get_EndPoint(0);
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = curve.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Function LocationRotate(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    ' Rotate the element via its location curve.
    Dim curve As LocationCurve = TryCast(element.Location, LocationCurve)
    If curve IsNot Nothing Then
        Dim line As Curve = curve.Curve
        Dim aa As Autodesk.Revit.DB.XYZ = line.EndPoint(0)
        Dim cc As New Autodesk.Revit.DB.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = curve.Rotate(axis, Math.PI / 2)
    End If

    Return rotated
End Function

See Also

Location Class


Location Properties

[image] [image]

Revit 2013 API
Location Properties
Location Class See Also Send Feedback

The Location type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Location Class


LocationCurve Class

[image]

Revit 2013 API
LocationCurve Class
Members See Also Send Feedback
Provides location functionality for all elements that are based upon a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LocationCurve : Location
Visual Basic
Public Class LocationCurve _
    Inherits Location
Visual C++
public ref class LocationCurve : public Location

Remarks

The location line objects adds additional functionality to its base location object class. This includes reading and writing the curve contained within the element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationCurve

See Also

LocationCurve Members


LocationCurve Members

[image] [image]

Revit 2013 API
LocationCurve Members
LocationCurve Class Methods Properties See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


LocationCurve Methods

[image] [image]

Revit 2013 API
LocationCurve Methods
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationCurve Class


LocationCurve Properties

[image] [image]

Revit 2013 API
LocationCurve Properties
LocationCurve Class See Also Send Feedback

The LocationCurve type exposes the following members.

Properties

 | Name | Description
Public property | Curve | Provides the ability to get and set the curve of a curve based element.
Public property | ElementsAtJoin | Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JoinType | Get/change the type of the join at the specified end.

See Also

LocationCurve Class


Curve Property

[image]

Revit 2013 API
LocationCurve..::..Curve Property
LocationCurve Class Example See Also Send Feedback
Provides the ability to get and set the curve of a curve based element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; set; }
Visual Basic
Public Property Curve As Curve
    Get
    Set
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
    void set (Curve^ value);
}

Remarks

This property can be used to set the location of curve based element to any desired position. Many elements are curve based. Some examples are walls, beams and braces.

Examples

CopyC#
void MoveUsingCurveParam(Autodesk.Revit.ApplicationServices.Application application, Wall wall)
{
    LocationCurve wallLine = wall.Location as LocationCurve;
    XYZ p1 = XYZ.Zero;
    XYZ p2 = new XYZ(10, 20, 0);
    Line newWallLine = application.Create.NewLineBound(p1, p2);

    // Change the wall line to a new line.
    wallLine.Curve = newWallLine;
}
CopyVB.NET
Sub MoveUsingCurveParam(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal wall As Wall)
    Dim wallLine As LocationCurve = TryCast(wall.Location, LocationCurve)
    Dim p1 As Autodesk.Revit.DB.XYZ = Autodesk.Revit.DB.XYZ.Zero
    Dim p2 As New Autodesk.Revit.DB.XYZ(10, 20, 0)
    Dim newWallLine As Line = application.Create.NewLineBound(p1, p2)

    ' Change the wall line to a new line.
    wallLine.Curve = newWallLine
End Sub

See Also

LocationCurve Class


ElementsAtJoin Property

[image]

Revit 2013 API
LocationCurve..::..ElementsAtJoin Property
LocationCurve Class See Also Send Feedback
Get all elements joining to the end of this element's location curve or change the order of elements participation in the end join with this location curve's end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementArray this[
    int end
] { get; set; }
Visual Basic
Public Property ElementsAtJoin ( _
    end As Integer _
) As ElementArray
    Get
    Set
Visual C++
public:
property ElementArray^ ElementsAtJoin[int end] {
    ElementArray^ get (int end);
    void set (int end, ElementArray^ value);
}

Parameters

end
Type: System..::..Int32
The end at which the join occurs.

Remarks

The list of elements is expected to be a permutation of the elements already in the join at the end. It is expected that no new elements will be introduced, and existing ones will not be removed.

See Also

LocationCurve Class


JoinType Property

[image]

Revit 2013 API
LocationCurve..::..JoinType Property
LocationCurve Class See Also Send Feedback
Get/change the type of the join at the specified end.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public JoinType this[
    int end
] { get; set; }
Visual Basic
Public Property JoinType ( _
    end As Integer _
) As JoinType
    Get
    Set
Visual C++
public:
property JoinType JoinType[int end] {
    JoinType get (int end);
    void set (int end, JoinType value);
}

Parameters

end
Type: System..::..Int32
The end of the location curve driver under question.

Remarks

This property allows to get join type of wall and concrete beam and to set wall's join type. The new join type is expected to be different from the current one for this end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The element is neither a wall nor a concrete beam when it tries to get the property. The element is not a wall when it tries to set the property.
Autodesk.Revit.Exceptions..::..InvalidOperationException | A failure occurred while attempting to set the new type.

See Also

LocationCurve Class


LocationPoint Class

[image]

Revit 2013 API
LocationPoint Class
Members Example See Also Send Feedback
Provides location functionality for all elements that have a single insertion point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LocationPoint : Location
Visual Basic
Public Class LocationPoint _
    Inherits Location
Visual C++
public ref class LocationPoint : public Location

Remarks

The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.

Examples

CopyC#
void LocationInformation(LocationPoint position)
{
    String prompt = "The selected column location information:";
    prompt += "\nPoint:  (" + position.Point.X + ", "
            + position.Point.Y + ", " + position.Point.Z + ")";
    prompt += "\nRotation: " + position.Rotation;

    TaskDialog.Show("Revit",prompt);
}

bool LocationRotate(Autodesk.Revit.ApplicationServices.Application application, Autodesk.Revit.DB.Element element)
{
    bool rotated = false;
    LocationPoint location = element.Location as LocationPoint;

    if (null != location)
    {
        XYZ aa = location.Point;
        XYZ cc = new XYZ(aa.X, aa.Y, aa.Z + 10);
        Line axis = application.Create.NewLineBound(aa, cc);
        rotated = location.Rotate(axis, Math.PI / 2.0);
    }

    return rotated;
}
CopyVB.NET
Sub LocationInformation(ByVal position As LocationPoint)
    Dim prompt As [String] = "The selected column location information:"
    prompt += vbLf & "Point:  (" + position.Point.X + ", " + position.Point.Y + ", " + position.Point.Z + ")"
    prompt += vbLf & "Rotation: " + position.Rotation

    TaskDialog.Show("Revit", prompt)
End Sub

Function LocationRotate(ByVal application As Autodesk.Revit.ApplicationServices.Application, ByVal element As Autodesk.Revit.DB.Element) As Boolean
    Dim rotated As Boolean = False
    Dim location As LocationPoint = TryCast(element.Location, LocationPoint)

    If location IsNot Nothing Then
        Dim aa As Autodesk.Revit.DB.XYZ = location.Point
        Dim cc As New Autodesk.Revit.DB.XYZ(aa.X, aa.Y, aa.Z + 10)
        Dim axis As Line = application.Create.NewLineBound(aa, cc)
        rotated = location.Rotate(axis, Math.PI / 2)
    End If

    Return rotated
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Location
Autodesk.Revit.DB..::..LocationPoint

See Also

LocationPoint Members


LocationPoint Members

[image] [image]

Revit 2013 API
LocationPoint Members
LocationPoint Class Methods Properties See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class


LocationPoint Methods

[image] [image]

Revit 2013 API
LocationPoint Methods
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Move | Move the element within the project by a specified vector. (Inherited from Location.)
Public method | Rotate | Rotate the element within the project by a specified angle around a given axis. (Inherited from Location.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LocationPoint Class


LocationPoint Properties

[image] [image]

Revit 2013 API
LocationPoint Properties
LocationPoint Class See Also Send Feedback

The LocationPoint type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Point | Get and set the physical location of the element.
Public property | Rotation | Retrieve the angle of rotation around the insertion point.

See Also

LocationPoint Class


Point Property

[image]

Revit 2013 API
LocationPoint..::..Point Property
LocationPoint Class Example See Also Send Feedback
Get and set the physical location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Examples

CopyC#
void LocationMove(FamilyInstance column)
{
    LocationPoint columnPoint = column.Location as LocationPoint;
    if (null != columnPoint)
    {
        XYZ newLocation = new XYZ(10, 20, 0);
        // Move the column to the new location
        columnPoint.Point = newLocation;
    }
}
CopyVB.NET
Sub LocationMove(ByVal column As Autodesk.Revit.DB.FamilyInstance)
    Dim columnPoint As LocationPoint = TryCast(column.Location, LocationPoint)
    If columnPoint IsNot Nothing Then
        Dim newLocation As New Autodesk.Revit.DB.XYZ(10, 20, 0)
        ' Move the column to the new location
        columnPoint.Point = newLocation
    End If
End Sub

See Also

LocationPoint Class


Rotation Property

[image]

Revit 2013 API
LocationPoint..::..Rotation Property
LocationPoint Class See Also Send Feedback
Retrieve the angle of rotation around the insertion point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Rotation { get; }
Visual Basic
Public ReadOnly Property Rotation As Double
    Get
Visual C++
public:
property double Rotation {
    double get ();
}

See Also

LocationPoint Class


LogicalAndFilter Class

[image]

Revit 2013 API
LogicalAndFilter Class
Members Example See Also Send Feedback
A filter that contains a set of filters. The filter passes when all filters in the set pass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class LogicalAndFilter : ElementLogicalFilter
Visual Basic
Public Class LogicalAndFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalAndFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Examples

CopyC#
// Find all door instances in the project by finding all elements that both belong to the door
// category and are family instances.
ElementClassFilter familyInstanceFilter = new ElementClassFilter(typeof(FamilyInstance));

// Create a category filter for Doors
ElementCategoryFilter doorsCategoryfilter = new ElementCategoryFilter(BuiltInCategory.OST_Doors);

// Create a logic And filter for all Door FamilyInstances
LogicalAndFilter doorInstancesFilter = new LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> doors = collector.WherePasses(doorInstancesFilter).ToElements();
CopyVB.NET
' Find all door instances in the project by finding all elements that both belong to the door
' category and are family instances.
Dim familyInstanceFilter As New ElementClassFilter(GetType(FamilyInstance))

' Create a category filter for Doors
Dim doorsCategoryfilter As New ElementCategoryFilter(BuiltInCategory.OST_Doors)

' Create a logic And filter for all Door FamilyInstances
Dim doorInstancesFilter As New LogicalAndFilter(familyInstanceFilter, doorsCategoryfilter)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim doors As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(doorInstancesFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalAndFilter

See Also

LogicalAndFilter Members


LogicalAndFilter Members

[image] [image]

Revit 2013 API
LogicalAndFilter Members
LogicalAndFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalAndFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalAndFilter Constructor

[image] [image]

Revit 2013 API
LogicalAndFilter Constructor
LogicalAndFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogicalAndFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalAndFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalAndFilter Class
LogicalAndFilter Members


LogicalAndFilter Constructor (IList(ElementFilter))

[image]

Revit 2013 API
LogicalAndFilter Constructor (IList<(Of <(<'ElementFilter>)>)>)
LogicalAndFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LogicalAndFilter(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalAndFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<'ElementFilter>)>)>
A collection of input filters.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter Constructor (ElementFilter, ElementFilter)

[image]

Revit 2013 API
LogicalAndFilter Constructor (ElementFilter, ElementFilter)
LogicalAndFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LogicalAndFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalAndFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::..ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::..ElementFilter
The second filter.

Remarks

The input filters will be copied.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LogicalAndFilter Class
LogicalAndFilter Overload


LogicalAndFilter Methods

[image] [image]

Revit 2013 API
LogicalAndFilter Methods
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalAndFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
LogicalAndFilter..::..PassesFilter Method
LogicalAndFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class
LogicalAndFilter Members


LogicalAndFilter Properties

[image] [image]

Revit 2013 API
LogicalAndFilter Properties
LogicalAndFilter Class See Also Send Feedback

The LogicalAndFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalAndFilter Class


LogicalOrFilter Class

[image]

Revit 2013 API
LogicalOrFilter Class
Members See Also Send Feedback
A filter that contains a set of filters. The filter passes when any filter in the set passes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class LogicalOrFilter : ElementLogicalFilter
Visual Basic
Public Class LogicalOrFilter _
    Inherits ElementLogicalFilter
Visual C++
public ref class LogicalOrFilter : public ElementLogicalFilter

Remarks

The component filters may be reordered by Revit to cause the quickest acting filters to be evaluated first.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementLogicalFilter
Autodesk.Revit.DB..::..LogicalOrFilter

See Also

LogicalOrFilter Members


LogicalOrFilter Members

[image] [image]

Revit 2013 API
LogicalOrFilter Members
LogicalOrFilter Class Constructors Methods Properties See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Constructors

 | Name | Description
Public method | LogicalOrFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


LogicalOrFilter Constructor

[image] [image]

Revit 2013 API
LogicalOrFilter Constructor
LogicalOrFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogicalOrFilter(IList<(Of <<'(ElementFilter>)>>)) | Constructs a new instance of the logical filter with any number of input filters.
Public method | LogicalOrFilter(ElementFilter, ElementFilter) | Constructs a new instance of the logical filter with two input filters.

See Also

LogicalOrFilter Class
LogicalOrFilter Members


LogicalOrFilter Constructor (IList(ElementFilter))

[image]

Revit 2013 API
LogicalOrFilter Constructor (IList<(Of <(<'ElementFilter>)>)>)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with any number of input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LogicalOrFilter(
    IList<ElementFilter> filters
)
Visual Basic
Public Sub New ( _
    filters As IList(Of ElementFilter) _
)
Visual C++
public:
LogicalOrFilter(
    IList<ElementFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<'ElementFilter>)>)>
A collection of input filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The filter collection is empty, or contains invalid inputs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Constructor (ElementFilter, ElementFilter)

[image]

Revit 2013 API
LogicalOrFilter Constructor (ElementFilter, ElementFilter)
LogicalOrFilter Class See Also Send Feedback
Constructs a new instance of the logical filter with two input filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public LogicalOrFilter(
    ElementFilter filter1,
    ElementFilter filter2
)
Visual Basic
Public Sub New ( _
    filter1 As ElementFilter, _
    filter2 As ElementFilter _
)
Visual C++
public:
LogicalOrFilter(
    ElementFilter^ filter1,
    ElementFilter^ filter2
)

Parameters

filter1
Type: Autodesk.Revit.DB..::..ElementFilter
The first filter.
filter2
Type: Autodesk.Revit.DB..::..ElementFilter
The second filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LogicalOrFilter Class
LogicalOrFilter Overload


LogicalOrFilter Methods

[image] [image]

Revit 2013 API
LogicalOrFilter Methods
LogicalOrFilter Class See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogicalOrFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
LogicalOrFilter..::..PassesFilter Method
LogicalOrFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class
LogicalOrFilter Members


LogicalOrFilter Properties

[image] [image]

Revit 2013 API
LogicalOrFilter Properties
LogicalOrFilter Class See Also Send Feedback

The LogicalOrFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

LogicalOrFilter Class


MarginType Enumeration

[image]

Revit 2013 API
MarginType Enumeration
See Also Send Feedback
An enumerated type listing all Margin types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum MarginType
Visual Basic
Public Enumeration MarginType
Visual C++
public enum class MarginType

Members

Member name | Description
NoMargin | The type of Margin is No Margin.
PrinterLimit | The type of Margin is Printer Limit.
UserDefined | The type of Margin is User Defined .

See Also


MassDisplayTemporaryOverrideType Enumeration

[image]

Revit 2013 API
MassDisplayTemporaryOverrideType Enumeration
See Also Send Feedback
This enum identifies the mass display overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum MassDisplayTemporaryOverrideType
Visual Basic
Public Enumeration MassDisplayTemporaryOverrideType
Visual C++
public enum class MassDisplayTemporaryOverrideType

Members

Member name | Description
ShowMassByViewSettings | Mass will be displayed in each view based on the visibility settings of that view.
ShowMassFormAndFloors | Mass form and mass floor subcategories will be displayed in all views.
ShowMassSurfaceTypes | Mass energy analysis surface subcategories (and Mass Floors) will be displayed.
ShowMassZonesAndShades | Mass zone and mass shade subcategories will be displayed.

See Also


MassInstanceUtils Class

[image]

Revit 2013 API
MassInstanceUtils Class
Members See Also Send Feedback
A static class that contains methods for processing curves driven by points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassInstanceUtils : IDisposable
Visual Basic
Public Class MassInstanceUtils _
    Implements IDisposable
Visual C++
public ref class MassInstanceUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MassInstanceUtils

See Also

MassInstanceUtils Members


MassInstanceUtils Members

[image] [image]

Revit 2013 API
MassInstanceUtils Members
MassInstanceUtils Class Methods See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose | Releases all resources used by the MassInstanceUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassInstanceUtils Class


MassInstanceUtils Methods

[image] [image]

Revit 2013 API
MassInstanceUtils Methods
MassInstanceUtils Class See Also Send Feedback

The MassInstanceUtils type exposes the following members.

Methods

 | Name | Description
 | AddMassLevelDataToMassInstance | Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetGrossFloorArea | Get the total occupiable floor area represented by a mass instance.
 | GetGrossSurfaceArea | Get the total exterior building surface area represented by a mass instance.
 | GetGrossVolume | Get the total building volume represented by a mass instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJoinedElementIds | Get the ElementIds of Elements that are joined to a mass instance.
 | GetMassLevelDataIds | Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.
 | GetMassLevelIds | Get the ElementIds of the Levels associated with a mass instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RemoveMassLevelDataFromMassInstance | Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassInstanceUtils Class


AddMassLevelDataToMassInstance Method

[image]

Revit 2013 API
MassInstanceUtils..::..AddMassLevelDataToMassInstance Method
MassInstanceUtils Class See Also Send Feedback
Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId AddMassLevelDataToMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic
Public Shared Function AddMassLevelDataToMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ AddMassLevelDataToMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Level to associate with the mass instance.

Return Value

The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


Dispose Method

[image]

Revit 2013 API
MassInstanceUtils..::..Dispose Method
MassInstanceUtils Class See Also Send Feedback
Releases all resources used by the MassInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MassInstanceUtils Class


GetGrossFloorArea Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetGrossFloorArea Method
MassInstanceUtils Class See Also Send Feedback
Get the total occupiable floor area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetGrossFloorArea(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetGrossFloorArea ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossFloorArea(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The gross floor area in square feet.

Remarks

The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetGrossSurfaceArea Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetGrossSurfaceArea Method
MassInstanceUtils Class See Also Send Feedback
Get the total exterior building surface area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetGrossSurfaceArea(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetGrossSurfaceArea ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossSurfaceArea(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The gross surface area in square feet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetGrossVolume Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetGrossVolume Method
MassInstanceUtils Class See Also Send Feedback
Get the total building volume represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetGrossVolume(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetGrossVolume ( _
    document As Document, _
    massInstanceId As ElementId _
) As Double
Visual C++
public:
static double GetGrossVolume(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The gross volume in cubic feet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetJoinedElementIds Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetJoinedElementIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of Elements that are joined to a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetJoinedElementIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetJoinedElementIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetJoinedElementIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

ElementIds of Elements joined to the mass instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetMassLevelDataIds Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetMassLevelDataIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the MassLevelDatas (Mass Floors) associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetMassLevelDataIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetMassLevelDataIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelDataIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the MassLevelDatas.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


GetMassLevelIds Method

[image]

Revit 2013 API
MassInstanceUtils..::..GetMassLevelIds Method
MassInstanceUtils Class See Also Send Feedback
Get the ElementIds of the Levels associated with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetMassLevelIds(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetMassLevelIds ( _
    document As Document, _
    massInstanceId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetMassLevelIds(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.

Return Value

The ElementIds of the Levels

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


RemoveMassLevelDataFromMassInstance Method

[image]

Revit 2013 API
MassInstanceUtils..::..RemoveMassLevelDataFromMassInstance Method
MassInstanceUtils Class See Also Send Feedback
Delete the MassLevelData (Mass Floor) that associates a Level with a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RemoveMassLevelDataFromMassInstance(
    Document document,
    ElementId massInstanceId,
    ElementId levelId
)
Visual Basic
Public Shared Sub RemoveMassLevelDataFromMassInstance ( _
    document As Document, _
    massInstanceId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
static void RemoveMassLevelDataFromMassInstance(
    Document^ document,
    ElementId^ massInstanceId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass instance.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Level to disassociate from the mass instance.

Remarks

Alternatively, you could just delete the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassInstanceUtils Class


Material Class

[image]

Revit 2013 API
Material Class
Members Example See Also Send Feedback
Represents a material element within an Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Material : Element
Visual Basic
Public Class Material _
    Inherits Element
Visual C++
public ref class Material : public Element

Remarks

This is the parent class for concrete material subclasses. Currently, the supported materials are wood, steel, generic, concrete and other.

Examples

CopyC#
private void GetMaterialInformation(Material material)
{
    StringBuilder message = new StringBuilder("Material : " + material.Name);
    //color of the material
    message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                    material.Color.Red, material.Color.Green, material.Color.Blue));

    //cut pattern and pattern color of the material
    if (null != material.CutPattern)
    {
        message.Append("\nCut Pattern: " + material.CutPattern.Name);
        message.Append(string.Format("\nCut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue));
    }

    //surface pattern and pattern color of the material
    if (null != material.SurfacePattern)
    {
        message.Append("\nSurface Pattern: " + material.SurfacePattern.Name);
        message.Append(string.Format("\nSurface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                        material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue));
    }

    //some shading property of the material
    bool glow = material.Glow;
    message.Append("\nMaterial can glow: " + glow);
    int shininess = material.Shininess;
    message.Append("\nShininess: " + shininess);
    int smoothness = material.Smoothness;
    message.Append("\nSmoothness: " + smoothness);
    int transparency = material.Transparency;
    message.Append("\nTransparency: " + transparency);

    TaskDialog.Show("Revit",message.ToString());
}
CopyVB.NET
Private Sub GetMaterialInformation(ByVal material As Autodesk.Revit.DB.Material)
    Dim message As New StringBuilder("Material : " + material.Name)
    'color of the material
    message.Append(String.Format(vbLf & "Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.Color.Red, material.Color.Green, material.Color.Blue))

    'cut pattern and pattern color of the material
    If material.CutPattern IsNot Nothing Then
        message.Append(vbLf & "Cut Pattern: " + material.CutPattern.Name)
        message.Append(String.Format(vbLf & "Cut Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.CutPatternColor.Red, material.CutPatternColor.Green, material.CutPatternColor.Blue))
    End If

    'surface pattern and pattern color of the material
    If material.SurfacePattern IsNot Nothing Then
        message.Append(vbLf & "Surface Pattern: " + material.SurfacePattern.Name)
        message.Append(String.Format(vbLf & "Surface Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]", material.SurfacePatternColor.Red, material.SurfacePatternColor.Green, material.SurfacePatternColor.Blue))
    End If

    'some shading property of the material
    Dim glow As Boolean = material.Glow
    message.Append(vbLf & "Material can glow: " + glow)
    Dim shininess As Integer = material.Shininess
    message.Append(vbLf & "Shininess: " + shininess)
    Dim smoothness As Integer = material.Smoothness
    message.Append(vbLf & "Smoothness: " + smoothness)
    Dim transparency As Integer = material.Transparency
    message.Append(vbLf & "Transparency: " + transparency)

    TaskDialog.Show("Revit", message.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Material

See Also

Material Members


Material Members

[image] [image]

Revit 2013 API
Material Members
Material Class Methods Properties See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the material.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCutPatternColor | Returns the color of the cut pattern for the material element.
Public method | GetCutPatternId | Returns the cut pattern id of the material.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialAspectPropertySet | Obsolete. Gets the identifier of the shared property set for a given aspect.
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSmoothness | Obsolete. Gets the smoothness value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMaterialAspect | Obsolete. Set the value of an aspect of the material
Public method | SetMaterialAspectByPropertySet | Set an aspect of the material to a shared property set.
Public method | SetMaterialAspectToIndependent | Obsolete. Set an aspect of the material from a shared property set to a custom property set owned by the material.
Public method | SetSmoothness | Obsolete. Sets the smoothness value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Material Class


Material Methods

[image] [image]

Revit 2013 API
Material Methods
Material Class See Also Send Feedback

The Material type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearMaterialAspect | Removes an aspect from the material.
 | Create | Creates a new material.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the material.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCutPatternColor | Returns the color of the cut pattern for the material element.
Public method | GetCutPatternId | Returns the cut pattern id of the material.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialAspectPropertySet | Obsolete. Gets the identifier of the shared property set for a given aspect.
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSmoothness | Obsolete. Gets the smoothness value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMaterialAspect | Obsolete. Set the value of an aspect of the material
Public method | SetMaterialAspectByPropertySet | Set an aspect of the material to a shared property set.
Public method | SetMaterialAspectToIndependent | Obsolete. Set an aspect of the material from a shared property set to a custom property set owned by the material.
Public method | SetSmoothness | Obsolete. Sets the smoothness value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Material Class


ClearMaterialAspect Method

[image]

Revit 2013 API
Material..::..ClearMaterialAspect Method
Material Class See Also Send Feedback
Removes an aspect from the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ClearMaterialAspect(
    MaterialAspect aspect
)
Visual Basic
Public Sub ClearMaterialAspect ( _
    aspect As MaterialAspect _
)
Visual C++
public:
void ClearMaterialAspect(
    MaterialAspect aspect
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.

See Also

Material Class


Create Method

[image]

Revit 2013 API
Material..::..Create Method
Material Class Example See Also Send Feedback
Creates a new material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ElementId Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the material.
name
Type: System..::..String
The name of the new material.

Return Value

Identifier of the new material.

Examples

CopyC#
//Create the material
ElementId materialId = Material.Create(document, "My Material");
Material material = document.GetElement(materialId) as Material;

//Create a new property set that can be used by this material or other materials.
PropertySetElement propertySet = PropertySetElement.Create(document, Autodesk.Revit.DB.MaterialAspect.Structural);

//Edit parameters in the property set.
propertySet.get_Parameter(BuiltInParameter.PROPERTY_SET_NAME).Set("My Property Set");
propertySet.get_Parameter(BuiltInParameter.PHY_MATERIAL_PARAM_CLASS).Set((int)StructuralMaterialType.Concrete);
propertySet.get_Parameter(BuiltInParameter.PHY_MATERIAL_PARAM_UNIT_WEIGHT).Set(232);

//Assign the property set to the material.
material.SetMaterialAspectByPropertySet(Autodesk.Revit.DB.MaterialAspect.Structural, propertySet.Id);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class


Duplicate Method

[image]

Revit 2013 API
Material..::..Duplicate Method
Material Class Example See Also Send Feedback
Duplicates the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Material Duplicate(
    string name
)
Visual Basic
Public Overridable Function Duplicate ( _
    name As String _
) As Material
Visual C++
public:
virtual Material^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the new material.

Return Value

The new material.

Remarks

If the name specified contains invalid characters, or the name has been used by other materials in the project, an ArgumentException will be thrown. If duplication fails, nullNothingnullptra null reference (Nothing in Visual Basic) will be returned.

Examples

CopyC#
private bool DuplicateMaterial(Material material)
{
    bool duplicated = false;
    //try to duplicate a new instance of Material class using duplicate method
    //make sure the name of new material is unique in MaterailSet
    string newName = "new" + material.Name;
    Material myMaterial = material.Duplicate(newName);
    if (null == myMaterial)
    {
        TaskDialog.Show("Revit","Failed to duplicate a material!");
    }
    else
    {
        duplicated = true;
    }

    return duplicated;
}
CopyVB.NET
Private Function DuplicateMaterial(ByVal material As Autodesk.Revit.DB.Material) As Boolean
    Dim duplicated As Boolean = False
    'try to duplicate a new instance of Material class using duplicate method
    'make sure the name of new material is unique in MaterailSet
    Dim newName As String = "new" + material.Name
    Dim myMaterial As Autodesk.Revit.DB.Material = material.Duplicate(newName)
    If myMaterial Is Nothing Then
        TaskDialog.Show("Revit", "Failed to duplicate a material!")
    Else
        duplicated = True
    End If

    Return duplicated
End Function

See Also

Material Class


GetCutPatternColor Method

[image]

Revit 2013 API
Material..::..GetCutPatternColor Method
Material Class See Also Send Feedback
Returns the color of the cut pattern for the material element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color GetCutPatternColor()
Visual Basic
Public Function GetCutPatternColor As Color
Visual C++
public:
Color^ GetCutPatternColor()

Return Value

The color.

See Also

Material Class


GetCutPatternId Method

[image]

Revit 2013 API
Material..::..GetCutPatternId Method
Material Class See Also Send Feedback
Returns the cut pattern id of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCutPatternId()
Visual Basic
Public Function GetCutPatternId As ElementId
Visual C++
public:
ElementId^ GetCutPatternId()

Return Value

The cut pattern id.

See Also

Material Class


GetMaterialAspectPropertySet Method

[image]

Revit 2013 API
Material..::..GetMaterialAspectPropertySet Method
Material Class See Also Send Feedback
Gets the identifier of the shared property set for a given aspect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")]
public ElementId GetMaterialAspectPropertySet(
    MaterialAspect aspect
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")> _
Public Function GetMaterialAspectPropertySet ( _
    aspect As MaterialAspect _
) As ElementId
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use getStructuralAssetId or getThermalAssetId instead.")]
public:
ElementId^ GetMaterialAspectPropertySet(
    MaterialAspect aspect
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.

Return Value

Identifier of the shared property set, or invalidElementId if independent (i.e. owned by the material).

See Also

Material Class


GetSmoothness Method

[image]

Revit 2013 API
Material..::..GetSmoothness Method
Material Class See Also Send Feedback
Gets the smoothness value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public float GetSmoothness()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")> _
Public Function GetSmoothness As Single
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public:
float GetSmoothness()

Return Value

The smoothness value.

See Also

Material Class


SetMaterialAspect Method

[image]

Revit 2013 API
Material..::..SetMaterialAspect Method
Material Class See Also Send Feedback
Set the value of an aspect of the material

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public void SetMaterialAspect(
    MaterialAspect aspect,
    ElementId propertySetId,
    bool bShared
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")> _
Public Sub SetMaterialAspect ( _
    aspect As MaterialAspect, _
    propertySetId As ElementId, _
    bShared As Boolean _
)
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public:
void SetMaterialAspect(
    MaterialAspect aspect,
    ElementId^ propertySetId,
    bool bShared
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect
propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of a property set (an instance of PropertySetElement)
bShared
Type: System..::..Boolean
Set the property set as shared or custom

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class


SetMaterialAspectByPropertySet Method

[image]

Revit 2013 API
Material..::..SetMaterialAspectByPropertySet Method
Material Class See Also Send Feedback
Set an aspect of the material to a shared property set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId propertySetId
)
Visual Basic
Public Sub SetMaterialAspectByPropertySet ( _
    aspect As MaterialAspect, _
    propertySetId As ElementId _
)
Visual C++
public:
void SetMaterialAspectByPropertySet(
    MaterialAspect aspect,
    ElementId^ propertySetId
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.
propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of a shared property set (an instance of PropertySetElement).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Material Class


SetMaterialAspectToIndependent Method

[image]

Revit 2013 API
Material..::..SetMaterialAspectToIndependent Method
Material Class See Also Send Feedback
Set an aspect of the material from a shared property set to a custom property set owned by the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public void SetMaterialAspectToIndependent(
    MaterialAspect aspect
)
Visual Basic
<ObsoleteAttribute("This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")> _
Public Sub SetMaterialAspectToIndependent ( _
    aspect As MaterialAspect _
)
Visual C++
[ObsoleteAttribute(L"This function will be removed in a future release. Use setStructuralAssetId or setThermalAssetId instead.")]
public:
void SetMaterialAspectToIndependent(
    MaterialAspect aspect
)

Parameters

aspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.

Remarks

If the material previously owned a custom property for the given aspect, do nothing If the material previously referred to a shared property set for the given aspect, Revit will create a copy of the shared property set to be owned by this material. If the material did not previously refer to a shared property set, Revit will create a default property set for the given aspect.

See Also

Material Class


SetSmoothness Method

[image]

Revit 2013 API
Material..::..SetSmoothness Method
Material Class See Also Send Feedback
Sets the smoothness value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public void SetSmoothness(
    float val
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")> _
Public Sub SetSmoothness ( _
    val As Single _
)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Autodesk Revit 2013.  Please use the Smoothness property instead.")]
public:
void SetSmoothness(
    float val
)

Parameters

val
Type: System..::..Single
The smoothness value, ranges from 0 to 1.

See Also

Material Class


Material Properties

[image] [image]

Revit 2013 API
Material Properties
Material Class See Also Send Feedback

The Material type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Color | The color of the material.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutPattern | The cut pattern of the material.
Public property | CutPatternColor | The cut pattern color of the material.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Glow | Whether the material can glow.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialClass | The name of the general material type, e.g. 'Wood.'
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RenderAppearance | The rendering appearance property of the material.
Public property | Shininess | The shininess of the material.
Public property | Smoothness | The smoothness of the material.
Public property | StructuralAssetId | The ElementId of the structural PropertySetElement.
Public property | SurfacePattern | The surface pattern of the material.
Public property | SurfacePatternColor | The surface pattern color of the material.
Public property | ThermalAssetId | The ElementId of the thermal PropertySetElement.
Public property | Transparency | The transparency of the material.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Material Class


Color Property

[image]

Revit 2013 API
Material..::..Color Property
Material Class See Also Send Feedback
The color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color Color { get; set; }
Visual Basic
Public Property Color As Color
    Get
    Set
Visual C++
public:
property Color^ Color {
    Color^ get ();
    void set (Color^ value);
}

See Also

Material Class


CutPattern Property

[image]

Revit 2013 API
Material..::..CutPattern Property
Material Class See Also Send Feedback
The cut pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPatternElement CutPattern { get; set; }
Visual Basic
Public Property CutPattern As FillPatternElement
    Get
    Set
Visual C++
public:
property FillPatternElement^ CutPattern {
    FillPatternElement^ get ();
    void set (FillPatternElement^ value);
}

Field Value

The cut pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated cut pattern.

See Also

Material Class


CutPatternColor Property

[image]

Revit 2013 API
Material..::..CutPatternColor Property
Material Class See Also Send Feedback
The cut pattern color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color CutPatternColor { get; set; }
Visual Basic
Public Property CutPatternColor As Color
    Get
    Set
Visual C++
public:
property Color^ CutPatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the cut pattern color for this material.

See Also

Material Class


Glow Property

[image]

Revit 2013 API
Material..::..Glow Property
Material Class See Also Send Feedback
Whether the material can glow.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Glow { get; set; }
Visual Basic
Public Property Glow As Boolean
    Get
    Set
Visual C++
public:
property bool Glow {
    bool get ();
    void set (bool value);
}

Field Value

True if the material can glow, false if it cannot.

Remarks

This value is obsolete in Autodesk Revit 2009 due to a similar change in the UI.

See Also

Material Class


MaterialClass Property

[image]

Revit 2013 API
Material..::..MaterialClass Property
Material Class See Also Send Feedback
The name of the general material type, e.g. 'Wood.'

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string MaterialClass { get; set; }
Visual Basic
Public Property MaterialClass As String
    Get
    Set
Visual C++
public:
property String^ MaterialClass {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Material Class


Parameter Property

[image] [image]

Revit 2013 API
Material..::..Parameter Property
Material Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Material Class
Material Members


RenderAppearance Property

[image]

Revit 2013 API
Material..::..RenderAppearance Property
Material Class See Also Send Feedback
The rendering appearance property of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Asset RenderAppearance { get; set; }
Visual Basic
Public Property RenderAppearance As Asset
    Get
    Set
Visual C++
public:
property Asset^ RenderAppearance {
    Asset^ get ();
    void set (Asset^ value);
}

Field Value

The rendering appearance property, or nullNothingnullptra null reference (Nothing in Visual Basic), if the render library isn't available.

See Also

Material Class


Shininess Property

[image]

Revit 2013 API
Material..::..Shininess Property
Material Class See Also Send Feedback
The shininess of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Shininess { get; set; }
Visual Basic
Public Property Shininess As Integer
    Get
    Set
Visual C++
public:
property int Shininess {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 128. If trying to set the value out of the range, ArgumentException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: values for shininess must be between 0 and 128

See Also

Material Class


Smoothness Property

[image]

Revit 2013 API
Material..::..Smoothness Property
Material Class See Also Send Feedback
The smoothness of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Smoothness { get; set; }
Visual Basic
Public Property Smoothness As Integer
    Get
    Set
Visual C++
public:
property int Smoothness {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class


StructuralAssetId Property

[image]

Revit 2013 API
Material..::..StructuralAssetId Property
Material Class See Also Send Feedback
The ElementId of the structural PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId StructuralAssetId { get; set; }
Visual Basic
Public Property StructuralAssetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StructuralAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Material Class


SurfacePattern Property

[image]

Revit 2013 API
Material..::..SurfacePattern Property
Material Class See Also Send Feedback
The surface pattern of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FillPatternElement SurfacePattern { get; set; }
Visual Basic
Public Property SurfacePattern As FillPatternElement
    Get
    Set
Visual C++
public:
property FillPatternElement^ SurfacePattern {
    FillPatternElement^ get ();
    void set (FillPatternElement^ value);
}

Field Value

The surface pattern element, or nullNothingnullptra null reference (Nothing in Visual Basic), if the material does not have an associated surface pattern.

See Also

Material Class


SurfacePatternColor Property

[image]

Revit 2013 API
Material..::..SurfacePatternColor Property
Material Class See Also Send Feedback
The surface pattern color of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color SurfacePatternColor { get; set; }
Visual Basic
Public Property SurfacePatternColor As Color
    Get
    Set
Visual C++
public:
property Color^ SurfacePatternColor {
    Color^ get ();
    void set (Color^ value);
}

Remarks

Changing the returned color will not change the surface pattern color for this material

See Also

Material Class


ThermalAssetId Property

[image]

Revit 2013 API
Material..::..ThermalAssetId Property
Material Class See Also Send Feedback
The ElementId of the thermal PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId ThermalAssetId { get; set; }
Visual Basic
Public Property ThermalAssetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ThermalAssetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Material Class


Transparency Property

[image]

Revit 2013 API
Material..::..Transparency Property
Material Class See Also Send Feedback
The transparency of the material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Transparency { get; set; }
Visual Basic
Public Property Transparency As Integer
    Get
    Set
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Field Value

The value ranges from 0 to 100. If trying to set the value out of the range, ArgumentException will be thrown.

See Also

Material Class


MaterialAspect Enumeration

[image]

Revit 2013 API
MaterialAspect Enumeration
See Also Send Feedback
A list of all material aspects that a material can store PropertySetElements for.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MaterialAspect
Visual Basic
Public Enumeration MaterialAspect
Visual C++
public enum class MaterialAspect

Members

Member name | Description
Structural | Structural
Thermal | Thermal

See Also


MaterialFunctionAssignment Enumeration

[image]

Revit 2013 API
MaterialFunctionAssignment Enumeration
See Also Send Feedback
Used in class CompoundStructure to specify the function of a layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MaterialFunctionAssignment
Visual Basic
Public Enumeration MaterialFunctionAssignment
Visual C++
public enum class MaterialFunctionAssignment

Members

Member name | Description
None | Priority = 0 This is deprecated and should not be used.
Structure | Priority = 1 (highest priority)
Substrate | Priority = 2
Insulation | Priority = 3
Finish1 | Priority = 4
Finish2 | Priority = 5
Membrane | A membrane layer must have thickness 0. It is not represented graphically.
StructuralDeck | Indicates layer is a structural deck.

Remarks

The function is used primarily to determine layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate lower priority layers and merge with layers of the same priority.

See Also


MaterialPropertyPathType Enumeration

[image]

Revit 2013 API
MaterialPropertyPathType Enumeration
See Also Send Feedback
Enum class indicating kinds of paths which ExternalFileReferenceType.Material references can have.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum MaterialPropertyPathType
Visual Basic
Public Enumeration MaterialPropertyPathType
Visual C++
public enum class MaterialPropertyPathType

Members

Member name | Description
General | General image, for various material types
Transparency | Transparency image, for generic materials
Cutouts | Cutouts image, for generic or metal materials
Bump | Bump pattern, for generic materials
FinishBumps | Finish bumps, pattern for various material types
ReliefPattern | Relief pattern, for various material types
Weathering | Weathering image, for concrete materials

See Also


MaterialSet Class

[image]

Revit 2013 API
MaterialSet Class
Members See Also Send Feedback
An set that contains materials.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MaterialSet : APIObject,
    IEnumerable
Visual Basic
Public Class MaterialSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MaterialSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MaterialSet

See Also

MaterialSet Members


MaterialSet Members

[image] [image]

Revit 2013 API
MaterialSet Members
MaterialSet Class Constructors Methods Properties See Also Send Feedback

The MaterialSet type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialSet | Initializes a new instance of the MaterialSet class

Methods

 | Name | Description
Public method | Clear | Removes every material from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class


MaterialSet Constructor

[image]

Revit 2013 API
MaterialSet Constructor
MaterialSet Class See Also Send Feedback
Initializes a new instance of the MaterialSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MaterialSet()
Visual Basic
Public Sub New
Visual C++
public:
MaterialSet()

See Also

MaterialSet Class


MaterialSet Methods

[image] [image]

Revit 2013 API
MaterialSet Methods
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every material from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSet Class


Clear Method

[image]

Revit 2013 API
MaterialSet..::..Clear Method
MaterialSet Class See Also Send Feedback
Removes every material from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MaterialSet Class


Contains Method

[image]

Revit 2013 API
MaterialSet..::..Contains Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Material item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Material

See Also

MaterialSet Class


Erase Method

[image]

Revit 2013 API
MaterialSet..::..Erase Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Material item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Material _
) As Integer
Visual C++
public:
virtual int Erase(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Material

See Also

MaterialSet Class


ForwardIterator Method

[image]

Revit 2013 API
MaterialSet..::..ForwardIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MaterialSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MaterialSet Class


GetEnumerator Method

[image]

Revit 2013 API
MaterialSet..::..GetEnumerator Method
MaterialSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MaterialSet Class


Insert Method

[image]

Revit 2013 API
MaterialSet..::..Insert Method
MaterialSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Material item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Material _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Material^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Material

See Also

MaterialSet Class


ReverseIterator Method

[image]

Revit 2013 API
MaterialSet..::..ReverseIterator Method
MaterialSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MaterialSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As MaterialSetIterator
Visual C++
public:
virtual MaterialSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MaterialSet Class


MaterialSet Properties

[image] [image]

Revit 2013 API
MaterialSet Properties
MaterialSet Class See Also Send Feedback

The MaterialSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of materials that are in the set.

See Also

MaterialSet Class


IsEmpty Property

[image]

Revit 2013 API
MaterialSet..::..IsEmpty Property
MaterialSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MaterialSet Class


Size Property

[image]

Revit 2013 API
MaterialSet..::..Size Property
MaterialSet Class See Also Send Feedback
Returns the number of materials that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MaterialSet Class


MaterialSetIterator Class

[image]

Revit 2013 API
MaterialSetIterator Class
Members See Also Send Feedback
An iterator to a material set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use FilteredElementCollector objects to find materials instead.")]
public abstract class MaterialSetIterator : APIObject,
    IEnumerator
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use FilteredElementCollector objects to find materials instead.")> _
Public MustInherit Class MaterialSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use FilteredElementCollector objects to find materials instead.")]
public ref class MaterialSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MaterialSetIterator

See Also

MaterialSetIterator Members


MaterialSetIterator Members

[image] [image]

Revit 2013 API
MaterialSetIterator Members
MaterialSetIterator Class Constructors Methods Properties See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MaterialSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class


MaterialSetIterator Constructor

[image]

Revit 2013 API
MaterialSetIterator Constructor
MaterialSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MaterialSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
MaterialSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MaterialSetIterator Class


MaterialSetIterator Methods

[image] [image]

Revit 2013 API
MaterialSetIterator Methods
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialSetIterator Class


MoveNext Method

[image]

Revit 2013 API
MaterialSetIterator..::..MoveNext Method
MaterialSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MaterialSetIterator Class


Reset Method

[image]

Revit 2013 API
MaterialSetIterator..::..Reset Method
MaterialSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MaterialSetIterator Class


MaterialSetIterator Properties

[image] [image]

Revit 2013 API
MaterialSetIterator Properties
MaterialSetIterator Class See Also Send Feedback

The MaterialSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MaterialSetIterator Class


Current Property

[image]

Revit 2013 API
MaterialSetIterator..::..Current Property
MaterialSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MaterialSetIterator Class


MEPCurve Class

[image]

Revit 2013 API
MEPCurve Class
Members See Also Send Feedback
A curve object for duct or pipe blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPCurve : HostObject
Visual Basic
Public Class MEPCurve _
    Inherits HostObject
Visual C++
public ref class MEPCurve : public HostObject

Remarks

The curve object is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Electrical..::..CableTrayConduitBase
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..Duct
Autodesk.Revit.DB.Mechanical..::..FlexDuct
Autodesk.Revit.DB.Plumbing..::..FlexPipe
Autodesk.Revit.DB.Plumbing..::..Pipe

See Also

MEPCurve Members


MEPCurve Members

[image] [image]

Revit 2013 API
MEPCurve Members
MEPCurve Class Methods Properties See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurve Class


MEPCurve Methods

[image] [image]

Revit 2013 API
MEPCurve Methods
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurve Class


MEPCurve Properties

[image] [image]

Revit 2013 API
MEPCurve Properties
MEPCurve Class See Also Send Feedback

The MEPCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurve Class


ConnectorManager Property

[image]

Revit 2013 API
MEPCurve..::..ConnectorManager Property
MEPCurve Class See Also Send Feedback
The connector manager of this MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

MEPCurve Class


Diameter Property

[image]

Revit 2013 API
MEPCurve..::..Diameter Property
MEPCurve Class See Also Send Feedback
The diameter of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic
Public ReadOnly Property Diameter As Double
    Get
Visual C++
public:
property double Diameter {
    double get ();
}

Remarks

This property is used to retrieve the diameter of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's Shape is not round.

See Also

MEPCurve Class


Height Property

[image]

Revit 2013 API
MEPCurve..::..Height Property
MEPCurve Class See Also Send Feedback
The height of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

This property is used to retrieve the height of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's Shape is not rectangular.

See Also

MEPCurve Class


LevelOffset Property

[image]

Revit 2013 API
MEPCurve..::..LevelOffset Property
MEPCurve Class See Also Send Feedback
The offset of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LevelOffset { get; set; }
Visual Basic
Public Property LevelOffset As Double
    Get
    Set
Visual C++
public:
property double LevelOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the offset of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's offset.

See Also

MEPCurve Class


MEPSystem Property

[image]

Revit 2013 API
MEPCurve..::..MEPSystem Property
MEPCurve Class See Also Send Feedback
The system of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPSystem MEPSystem { get; }
Visual Basic
Public ReadOnly Property MEPSystem As MEPSystem
    Get
Visual C++
public:
property MEPSystem^ MEPSystem {
    MEPSystem^ get ();
}

Remarks

Returns the system of this MEP curve. If the curve does not belong to any systems, the value will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

MEPCurve Class


Parameter Property

[image] [image]

Revit 2013 API
MEPCurve..::..Parameter Property
MEPCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPCurve Class
MEPCurve Members


ReferenceLevel Property

[image]

Revit 2013 API
MEPCurve..::..ReferenceLevel Property
MEPCurve Class See Also Send Feedback
The reference level of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level ReferenceLevel { get; set; }
Visual Basic
Public Property ReferenceLevel As Level
    Get
    Set
Visual C++
public:
property Level^ ReferenceLevel {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to retrieve the reference level of the MEP curve. If the curve is not in a horizontal plane, this value will be the start point's reference level.

See Also

MEPCurve Class


Width Property

[image]

Revit 2013 API
MEPCurve..::..Width Property
MEPCurve Class See Also Send Feedback
The width of the MEP curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

Remarks

This property is used to retrieve the width of the MEP curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the MEP curve's shape is not rectangular.

See Also

MEPCurve Class


MEPCurveType Class

[image]

Revit 2013 API
MEPCurveType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPCurveType : HostObjAttributes
Visual Basic
Public Class MEPCurveType _
    Inherits HostObjAttributes
Visual C++
public ref class MEPCurveType : public HostObjAttributes

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Electrical..::..CableTrayType
Autodesk.Revit.DB.Electrical..::..ConduitType
Autodesk.Revit.DB.Mechanical..::..DuctType
Autodesk.Revit.DB.Mechanical..::..FlexDuctType
Autodesk.Revit.DB.Plumbing..::..FlexPipeType
Autodesk.Revit.DB.Plumbing..::..PipeType

See Also

MEPCurveType Members


MEPCurveType Members

[image] [image]

Revit 2013 API
MEPCurveType Members
MEPCurveType Class Methods Properties See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurveType Class


MEPCurveType Methods

[image] [image]

Revit 2013 API
MEPCurveType Methods
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPCurveType Class


MEPCurveType Properties

[image] [image]

Revit 2013 API
MEPCurveType Properties
MEPCurveType Class See Also Send Feedback

The MEPCurveType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type.
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType
Public property | Tap | The default tap fitting of the MEP curve type.
Public property | Tee | The default tee fitting of the MEP curve type.
Public property | Transition | The default transition fitting of the MEP curve type.
Public property | Union | The default union fitting of the MEP curve type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPCurveType Class


Cross Property

[image]

Revit 2013 API
MEPCurveType..::..Cross Property
MEPCurveType Class See Also Send Feedback
The default cross fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Cross { get; set; }
Visual Basic
Public Property Cross As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Cross {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default cross fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Elbow Property

[image]

Revit 2013 API
MEPCurveType..::..Elbow Property
MEPCurveType Class See Also Send Feedback
The default elbow fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Elbow { get; set; }
Visual Basic
Public Property Elbow As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Elbow {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default elbow fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


MultiShapeTransition Property

[image]

Revit 2013 API
MEPCurveType..::..MultiShapeTransition Property
MEPCurveType Class See Also Send Feedback
The default multi shape transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol MultiShapeTransition { get; set; }
Visual Basic
Public Property MultiShapeTransition As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ MultiShapeTransition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default multi shape transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Parameter Property

[image] [image]

Revit 2013 API
MEPCurveType..::..Parameter Property
MEPCurveType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPCurveType Class
MEPCurveType Members


PreferredJunctionType Property

[image]

Revit 2013 API
MEPCurveType..::..PreferredJunctionType Property
MEPCurveType Class See Also Send Feedback
The preferred junction type of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public JunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As JunctionType
    Get
    Set
Visual C++
public:
property JunctionType PreferredJunctionType {
    JunctionType get ();
    void set (JunctionType value);
}

Remarks

Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Roughness Property

[image]

Revit 2013 API
MEPCurveType..::..Roughness Property
MEPCurveType Class See Also Send Feedback
The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
    Get
    Set
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

See Also

MEPCurveType Class


RoutingPreferenceManager Property

[image]

Revit 2013 API
MEPCurveType..::..RoutingPreferenceManager Property
MEPCurveType Class See Also Send Feedback
The RoutingPreferenceManager for the MEPCurveType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingPreferenceManager RoutingPreferenceManager { get; }
Visual Basic
Public ReadOnly Property RoutingPreferenceManager As RoutingPreferenceManager
    Get
Visual C++
public:
property RoutingPreferenceManager^ RoutingPreferenceManager {
    RoutingPreferenceManager^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

MEPCurveType Class


Tap Property

[image]

Revit 2013 API
MEPCurveType..::..Tap Property
MEPCurveType Class See Also Send Feedback
The default tap fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Tap { get; set; }
Visual Basic
Public Property Tap As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Tap {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tap fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Tee Property

[image]

Revit 2013 API
MEPCurveType..::..Tee Property
MEPCurveType Class See Also Send Feedback
The default tee fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Tee { get; set; }
Visual Basic
Public Property Tee As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Tee {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default tee fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Transition Property

[image]

Revit 2013 API
MEPCurveType..::..Transition Property
MEPCurveType Class See Also Send Feedback
The default transition fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Transition { get; set; }
Visual Basic
Public Property Transition As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Transition {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default transition fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


Union Property

[image]

Revit 2013 API
MEPCurveType..::..Union Property
MEPCurveType Class See Also Send Feedback
The default union fitting of the MEP curve type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbol Union { get; set; }
Visual Basic
Public Property Union As FamilySymbol
    Get
    Set
Visual C++
public:
property FamilySymbol^ Union {
    FamilySymbol^ get ();
    void set (FamilySymbol^ value);
}

Remarks

This property is used to retrieve the default union fitting of the MEP curve type, and can be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no default value. Use RoutingPreferenceManager to set this property for PipeType MEPCurves.

See Also

MEPCurveType Class


MEPModel Class

[image]

Revit 2013 API
MEPModel Class
Members See Also Send Feedback
Supports all MEP models that are persistent within the Autodesk Revit project

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPModel : APIObject
Visual Basic
Public Class MEPModel _
    Inherits APIObject
Visual C++
public ref class MEPModel : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Electrical..::..ElectricalEquipment
Autodesk.Revit.DB.Electrical..::..LightingDevice
Autodesk.Revit.DB.Electrical..::..LightingFixture
Autodesk.Revit.DB.Mechanical..::..MechanicalEquipment
Autodesk.Revit.DB.Mechanical..::..MechanicalFitting

See Also

MEPModel Members


MEPModel Members

[image] [image]

Revit 2013 API
MEPModel Members
MEPModel Class Methods Properties See Also Send Feedback

The MEPModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class


MEPModel Methods

[image] [image]

Revit 2013 API
MEPModel Methods
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPModel Class


MEPModel Properties

[image] [image]

Revit 2013 API
MEPModel Properties
MEPModel Class See Also Send Feedback

The MEPModel type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to.
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPModel Class


AssignedElectricalSystems Property

[image]

Revit 2013 API
MEPModel..::..AssignedElectricalSystems Property
MEPModel Class See Also Send Feedback
Retrieves the electrical systems this electrical panel currently is assigned to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemSet AssignedElectricalSystems { get; }
Visual Basic
Public ReadOnly Property AssignedElectricalSystems As ElectricalSystemSet
    Get
Visual C++
public:
property ElectricalSystemSet^ AssignedElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class


ConnectorManager Property

[image]

Revit 2013 API
MEPModel..::..ConnectorManager Property
MEPModel Class See Also Send Feedback
Retrieves the Connector Manager from this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

This property returns Connector Manager from this MEPModel.

See Also

MEPModel Class


ElectricalSystems Property

[image]

Revit 2013 API
MEPModel..::..ElectricalSystems Property
MEPModel Class See Also Send Feedback
Retrieves the electrical systems that are currently created using this MEPModel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemSet ElectricalSystems { get; }
Visual Basic
Public ReadOnly Property ElectricalSystems As ElectricalSystemSet
    Get
Visual C++
public:
property ElectricalSystemSet^ ElectricalSystems {
    ElectricalSystemSet^ get ();
}

Remarks

This property returns a set of Electrical Systems. If there are no electrical systems created for this model, this property will be an empty set.

See Also

MEPModel Class


MEPSize Class

[image]

Revit 2013 API
MEPSize Class
Members See Also Send Feedback
Stores the basic size information for an MEP duct, pipe, cable tray, or conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MEPSize : IDisposable
Visual Basic
Public Class MEPSize _
    Implements IDisposable
Visual C++
public ref class MEPSize : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..MEPSize

See Also

MEPSize Members


MEPSize Members

[image] [image]

Revit 2013 API
MEPSize Members
MEPSize Class Constructors Methods Properties See Also Send Feedback

The MEPSize type exposes the following members.

Constructors

 | Name | Description
Public method | MEPSize | Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSize
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.

See Also

MEPSize Class


MEPSize Constructor

[image]

Revit 2013 API
MEPSize Constructor
MEPSize Class See Also Send Feedback
Constructs an object that stores the basic size information for MEP duct, pipe, cable tray and conduit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)
Visual Basic
Public Sub New ( _
    nominalDiameter As Double, _
    innerDiameter As Double, _
    outerDiameter As Double, _
    usedInSizeLists As Boolean, _
    usedInSizing As Boolean _
)
Visual C++
public:
MEPSize(
    double nominalDiameter,
    double innerDiameter,
    double outerDiameter,
    bool usedInSizeLists,
    bool usedInSizing
)

Parameters

nominalDiameter
Type: System..::..Double
Nominal diameter. The value should be a valid, positive Revit length.
innerDiameter
Type: System..::..Double
Inner diameter. The value should be a valid, positive Revit length.
outerDiameter
Type: System..::..Double
Outer diameter. The value should be a valid, positive Revit length.
usedInSizeLists
Type: System..::..Boolean
Whether it is used in size lists.
usedInSizing
Type: System..::..Boolean
Whether is used in sizing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for nominalDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for innerDiameter must be greater than 0 and no more than 30000 feet. -or- The given value for outerDiameter must be greater than 0 and no more than 30000 feet.

See Also

MEPSize Class


MEPSize Methods

[image] [image]

Revit 2013 API
MEPSize Methods
MEPSize Class See Also Send Feedback

The MEPSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSize Class


Dispose Method

[image]

Revit 2013 API
MEPSize..::..Dispose Method
MEPSize Class See Also Send Feedback
Releases all resources used by the MEPSize

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MEPSize Class


MEPSize Properties

[image] [image]

Revit 2013 API
MEPSize Properties
MEPSize Class See Also Send Feedback

The MEPSize type exposes the following members.

Properties

 | Name | Description
Public property | InnerDiameter | Inner diameter
Public property | NominalDiameter | Nominal diameter
Public property | OuterDiameter | Outer diameter
Public property | UsedInSizeLists | Whether it is used in size lists.
Public property | UsedInSizing | Whether is used in sizing.

See Also

MEPSize Class


InnerDiameter Property

[image]

Revit 2013 API
MEPSize..::..InnerDiameter Property
MEPSize Class See Also Send Feedback
Inner diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double InnerDiameter { get; }
Visual Basic
Public ReadOnly Property InnerDiameter As Double
    Get
Visual C++
public:
property double InnerDiameter {
    double get ();
}

See Also

MEPSize Class


NominalDiameter Property

[image]

Revit 2013 API
MEPSize..::..NominalDiameter Property
MEPSize Class See Also Send Feedback
Nominal diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NominalDiameter { get; }
Visual Basic
Public ReadOnly Property NominalDiameter As Double
    Get
Visual C++
public:
property double NominalDiameter {
    double get ();
}

See Also

MEPSize Class


OuterDiameter Property

[image]

Revit 2013 API
MEPSize..::..OuterDiameter Property
MEPSize Class See Also Send Feedback
Outer diameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double OuterDiameter { get; }
Visual Basic
Public ReadOnly Property OuterDiameter As Double
    Get
Visual C++
public:
property double OuterDiameter {
    double get ();
}

See Also

MEPSize Class


UsedInSizeLists Property

[image]

Revit 2013 API
MEPSize..::..UsedInSizeLists Property
MEPSize Class See Also Send Feedback
Whether it is used in size lists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool UsedInSizeLists { get; }
Visual Basic
Public ReadOnly Property UsedInSizeLists As Boolean
    Get
Visual C++
public:
property bool UsedInSizeLists {
    bool get ();
}

See Also

MEPSize Class


UsedInSizing Property

[image]

Revit 2013 API
MEPSize..::..UsedInSizing Property
MEPSize Class See Also Send Feedback
Whether is used in sizing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool UsedInSizing { get; }
Visual Basic
Public ReadOnly Property UsedInSizing As Boolean
    Get
Visual C++
public:
property bool UsedInSizing {
    bool get ();
}

See Also

MEPSize Class


MEPSystem Class

[image]

Revit 2013 API
MEPSystem Class
Members See Also Send Feedback
A system in the Autodesk Revit MEP product. Default constructor Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class MEPSystem : Element
Visual Basic
Public Class MEPSystem _
    Inherits Element
Visual C++
public ref class MEPSystem : public Element

Remarks

This is the base class for electrical, mechanical and piping systems, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Electrical..::..ElectricalSystem
Autodesk.Revit.DB.Mechanical..::..MechanicalSystem
Autodesk.Revit.DB.Plumbing..::..PipingSystem

See Also

MEPSystem Members


MEPSystem Members

[image] [image]

Revit 2013 API
MEPSystem Members
MEPSystem Class Methods Properties See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.
Public method | Remove(ElementSet) | Obsolete. Remove elements from system.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystem Class


MEPSystem Methods

[image] [image]

Revit 2013 API
MEPSystem Methods
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index.
Public method | GetSectionByNumber | Get the Section from section number
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.
Public method | Remove(ElementSet) | Obsolete. Remove elements from system.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSystem Class


Add Method

[image]

Revit 2013 API
MEPSystem..::..Add Method
MEPSystem Class See Also Send Feedback
Add elements into the system and connect them with the system using given connectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Add(
    ConnectorSet connectors
)
Visual Basic
Public Overridable Sub Add ( _
    connectors As ConnectorSet _
)
Visual C++
public:
virtual void Add(
    ConnectorSet^ connectors
)

Parameters

connectors
Type: Autodesk.Revit.DB..::..ConnectorSet
Connectors which are used to connect with the system.

Remarks

Note: this method may not be called during dynamic update.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument connectors is nullNothingnullptra null reference (Nothing in Visual Basic), or any connector in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

MEPSystem Class


GetCriticalPathSectionNumbers Method

[image]

Revit 2013 API
MEPSystem..::..GetCriticalPathSectionNumbers Method
MEPSystem Class See Also Send Feedback
Obtains a list of the critical path section numbers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<int> GetCriticalPathSectionNumbers()
Visual Basic
Public Function GetCriticalPathSectionNumbers As IList(Of Integer)
Visual C++
public:
IList<int>^ GetCriticalPathSectionNumbers()

Return Value

The section numbers.

Remarks

The section numbers are returned in order in the direction of flow.

See Also

MEPSystem Class


GetSectionByIndex Method

[image]

Revit 2013 API
MEPSystem..::..GetSectionByIndex Method
MEPSystem Class See Also Send Feedback
Get the section from the index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public MEPSection GetSectionByIndex(
    int index
)
Visual Basic
Public Function GetSectionByIndex ( _
    index As Integer _
) As MEPSection
Visual C++
public:
MEPSection^ GetSectionByIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the section in the system.

Return Value

The section.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The section index is out of range.

See Also

MEPSystem Class


GetSectionByNumber Method

[image]

Revit 2013 API
MEPSystem..::..GetSectionByNumber Method
MEPSystem Class See Also Send Feedback
Get the Section from section number

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public MEPSection GetSectionByNumber(
    int sectionNumber
)
Visual Basic
Public Function GetSectionByNumber ( _
    sectionNumber As Integer _
) As MEPSection
Visual C++
public:
MEPSection^ GetSectionByNumber(
    int sectionNumber
)

Parameters

sectionNumber
Type: System..::..Int32
The Section number.

Return Value

The section. nullNothingnullptra null reference (Nothing in Visual Basic) if the no section exists for the input section number.

See Also

MEPSystem Class


Remove Method

[image] [image]

Revit 2013 API
MEPSystem..::..Remove Method
MEPSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system.
Public method | Remove(ElementSet) | Obsolete. Remove elements from system.

See Also

MEPSystem Class
MEPSystem Members


Remove Method (ICollection(ElementId))

[image]

Revit 2013 API
MEPSystem..::..Remove Method (ICollection<(Of <(<'ElementId>)>)>)
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Remove(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Overridable Sub Remove ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
virtual void Remove(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Remove Overload


Remove Method (ElementSet)

[image]

Revit 2013 API
MEPSystem..::..Remove Method (ElementSet)
MEPSystem Class See Also Send Feedback
Remove elements from system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Remove(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIds) instead.")]
public virtual void Remove(
    ElementSet elements
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013.  Call Remove(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIds) instead.")> _
Public Overridable Sub Remove ( _
    elements As ElementSet _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013.  Call Remove(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIds) instead.")]
public:
virtual void Remove(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
The elements to be removed from the system.

Remarks

It is forbidden to remove all terminal elements from system. Terminal elements will be removed from the system automatically after removing this system from document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument elements is nullNothingnullptra null reference (Nothing in Visual Basic), or any element in that collection is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when some of the elements can't be removed, or when trying to remove all elements from the system. The element which connect to the base equipment can't be removed,
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the operation failed.

See Also

MEPSystem Class
Remove Overload


MEPSystem Properties

[image] [image]

Revit 2013 API
MEPSystem Properties
MEPSystem Class See Also Send Feedback

The MEPSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system.
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not.
Public property | IsEmpty | Indicates if the system is empty or not.
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path.
Public property | SectionsCount | The number of sections.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystem Class


BaseEquipment Property

[image]

Revit 2013 API
MEPSystem..::..BaseEquipment Property
MEPSystem Class See Also Send Feedback
The base panel or equipment of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyInstance BaseEquipment { get; }
Visual Basic
Public ReadOnly Property BaseEquipment As FamilyInstance
    Get
Visual C++
public:
property FamilyInstance^ BaseEquipment {
    FamilyInstance^ get ();
}

See Also

MEPSystem Class


BaseEquipmentConnector Property

[image]

Revit 2013 API
MEPSystem..::..BaseEquipmentConnector Property
MEPSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; }
Visual Basic
Public ReadOnly Property BaseEquipmentConnector As Connector
    Get
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
}

Return Value

Returns the connector which connects with the system within base equipment if base equipment has been assigned to system, otherwise returns nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

MEPSystem Class


ConnectorManager Property

[image]

Revit 2013 API
MEPSystem..::..ConnectorManager Property
MEPSystem Class See Also Send Feedback
Connector manager of the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

Remarks

The connector manager includes connectors which are used to connect with terminal elements and base equipment.

See Also

MEPSystem Class


Elements Property

[image]

Revit 2013 API
MEPSystem..::..Elements Property
MEPSystem Class See Also Send Feedback
Terminal elements in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet Elements { get; }
Visual Basic
Public ReadOnly Property Elements As ElementSet
    Get
Visual C++
public:
property ElementSet^ Elements {
    ElementSet^ get ();
}

Remarks

The return value is a read only collection and doesn't include the base equipment or panel.

See Also

MEPSystem Class


IsDefaultSystem Property

[image]

Revit 2013 API
MEPSystem..::..IsDefaultSystem Property
MEPSystem Class See Also Send Feedback
Indicates if the system is a default system or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDefaultSystem { get; }
Visual Basic
Public ReadOnly Property IsDefaultSystem As Boolean
    Get
Visual C++
public:
property bool IsDefaultSystem {
    bool get ();
}

Return Value

True if the system is default, otherwise returns false.

Remarks

Terminals which are not assigned to a system manually in mechanical and piping system are in default systems.

See Also

MEPSystem Class


IsEmpty Property

[image]

Revit 2013 API
MEPSystem..::..IsEmpty Property
MEPSystem Class See Also Send Feedback
Indicates if the system is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

Remarks

returns true if the system doesn't contain any components

See Also

MEPSystem Class


IsValid Property

[image]

Revit 2013 API
MEPSystem..::..IsValid Property
MEPSystem Class See Also Send Feedback
Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValid { get; }
Visual Basic
Public ReadOnly Property IsValid As Boolean
    Get
Visual C++
public:
property bool IsValid {
    bool get ();
}

See Also

MEPSystem Class


Parameter Property

[image] [image]

Revit 2013 API
MEPSystem..::..Parameter Property
MEPSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPSystem Class
MEPSystem Members


PressureLossOfCriticalPath Property

[image]

Revit 2013 API
MEPSystem..::..PressureLossOfCriticalPath Property
MEPSystem Class See Also Send Feedback
The total pressure loss of the sections in critical path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double PressureLossOfCriticalPath { get; }
Visual Basic
Public ReadOnly Property PressureLossOfCriticalPath As Double
    Get
Visual C++
public:
property double PressureLossOfCriticalPath {
    double get ();
}

See Also

MEPSystem Class


SectionsCount Property

[image]

Revit 2013 API
MEPSystem..::..SectionsCount Property
MEPSystem Class See Also Send Feedback
The number of sections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SectionsCount { get; }
Visual Basic
Public ReadOnly Property SectionsCount As Integer
    Get
Visual C++
public:
property int SectionsCount {
    int get ();
}

See Also

MEPSystem Class


MEPSystemClassification Enumeration

[image]

Revit 2013 API
MEPSystemClassification Enumeration
See Also Send Feedback
This enumeration is used to classify MEP connectors and systems and drives certain behavior for a particular system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum MEPSystemClassification
Visual Basic
Public Enumeration MEPSystemClassification
Visual C++
public enum class MEPSystemClassification

Members

Member name | Description
UndefinedSystemClassification | A system classification not yet defined
SupplyAir | A supply air duct system
ReturnAir | A return air duct system
ExhaustAir | Obsolete classification not used anymore
OtherAir | An user classified air duct system
DataCircuit | An electrical data circuit
PowerCircuit | An electrical circuit
SupplyHydronic | A hydronic supply piping system
ReturnHydronic | A hydronic return piping system
Telephone | An electrical circuit classified as telephone
Security | An electrical security circuit
FireAlarm | An electrical fire alarm circuit
NurseCall | An electrical circuit classified as nurse call
Controls | An electrical circuit classified as controls
Communication | An electrical circuit classified as communication
CondensateDrain | Reserved for future use
Sanitary | A sanitary piping system
Vent | A piping ventilation system
Storm | Reserved for future use
DomesticHotWater | A hot water piping system
DomesticColdWater | A cold water piping system
Recirculation | Reserved for future use
OtherPipe | An user classified piping system
FireProtectWet | A wet fire protection system
FireProtectDry | A dry fire protection system
FireProtectPreaction | A preaction fire protection system
FireProtectOther | A user defined fire protection system
SwitchTopology | An electrical switch system
Fitting | Reserved for application usage, used for UI filtering in Family Editor
Global | Reserved for application usage, used for UI filtering in Family Editor
PowerBalanced | Equivalent with PowerCircuit
PowerUnBalanced | Equivalent with PowerCircuit
CableTrayConduit | Indicates the default type for cable trays and conduits

See Also


MEPSystemType Class

[image]

Revit 2013 API
MEPSystemType Class
Members See Also Send Feedback
A system type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MEPSystemType : ElementType
Visual Basic
Public Class MEPSystemType _
    Inherits ElementType
Visual C++
public ref class MEPSystemType : public ElementType

Remarks

This is the base class for mechanical and piping system types, available only in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Mechanical..::..MechanicalSystemType
Autodesk.Revit.DB.Plumbing..::..PipingSystemType

See Also

MEPSystemType Members


MEPSystemType Members

[image] [image]

Revit 2013 API
MEPSystemType Members
MEPSystemType Class Methods Properties See Also Send Feedback

The MEPSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SystemClassification | Identifies the classification for the system type
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystemType Class


MEPSystemType Methods

[image] [image]

Revit 2013 API
MEPSystemType Methods
MEPSystemType Class See Also Send Feedback

The MEPSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSystemType Class


MEPSystemType Properties

[image] [image]

Revit 2013 API
MEPSystemType Properties
MEPSystemType Class See Also Send Feedback

The MEPSystemType type exposes the following members.

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system.
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system.
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SystemClassification | Identifies the classification for the system type
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPSystemType Class


Abbreviation Property

[image]

Revit 2013 API
MEPSystemType..::..Abbreviation Property
MEPSystemType Class See Also Send Feedback
Identifies the abbreviation, the short name, for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Abbreviation { get; set; }
Visual Basic
Public Property Abbreviation As String
    Get
    Set
Visual C++
public:
property String^ Abbreviation {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MEPSystemType Class


CalculationLevel Property

[image]

Revit 2013 API
MEPSystemType..::..CalculationLevel Property
MEPSystemType Class See Also Send Feedback
Identifies the calculation level for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SystemCalculationLevel CalculationLevel { get; }
Visual Basic
Public ReadOnly Property CalculationLevel As SystemCalculationLevel
    Get
Visual C++
public:
property SystemCalculationLevel CalculationLevel {
    SystemCalculationLevel get ();
}

See Also

MEPSystemType Class


LineColor Property

[image]

Revit 2013 API
MEPSystemType..::..LineColor Property
MEPSystemType Class See Also Send Feedback
Indicates the color that should override the line color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Color LineColor { get; set; }
Visual Basic
Public Property LineColor As Color
    Get
    Set
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MEPSystemType Class


LinePatternId Property

[image]

Revit 2013 API
MEPSystemType..::..LinePatternId Property
MEPSystemType Class See Also Send Feedback
Indicates the line pattern color that should override the line color for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LinePatternId { get; set; }
Visual Basic
Public Property LinePatternId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LinePatternId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MEPSystemType Class


LineWeight Property

[image]

Revit 2013 API
MEPSystemType..::..LineWeight Property
MEPSystemType Class See Also Send Feedback
Indicates the weight that should override the line weight for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int LineWeight { get; set; }
Visual Basic
Public Property LineWeight As Integer
    Get
    Set
Visual C++
public:
property int LineWeight {
    int get ();
    void set (int value);
}

See Also

MEPSystemType Class


MaterialId Property

[image]

Revit 2013 API
MEPSystemType..::..MaterialId Property
MEPSystemType Class See Also Send Feedback
Indicates the material id that should override the material for all components in the system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MEPSystemType Class


Parameter Property

[image] [image]

Revit 2013 API
MEPSystemType..::..Parameter Property
MEPSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPSystemType Class
MEPSystemType Members


SystemClassification Property

[image]

Revit 2013 API
MEPSystemType..::..SystemClassification Property
MEPSystemType Class See Also Send Feedback
Identifies the classification for the system type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MEPSystemClassification SystemClassification { get; }
Visual Basic
Public ReadOnly Property SystemClassification As MEPSystemClassification
    Get
Visual C++
public:
property MEPSystemClassification SystemClassification {
    MEPSystemClassification get ();
}

Remarks

The system classification drives certain behavior such as sizing and connections to other systems

See Also

MEPSystemType Class


Mesh Class

[image]

Revit 2013 API
Mesh Class
Members See Also Send Feedback
A triangular mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Mesh : GeometryObject
Visual Basic
Public Class Mesh _
    Inherits GeometryObject
Visual C++
public ref class Mesh : public GeometryObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Mesh

See Also

Mesh Members


Mesh Members

[image] [image]

Revit 2013 API
Mesh Members
Mesh Class Methods Properties See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


Mesh Methods

[image] [image]

Revit 2013 API
Mesh Methods
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mesh Class


Mesh Properties

[image] [image]

Revit 2013 API
Mesh Properties
Mesh Class See Also Send Feedback

The Mesh type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialElementId | Element ID of the material from which this mesh is composed.
Public property | NumTriangles | The number of triangles that the mesh contains.
Public property | Transformed | Transforms this mesh and returns the result.
Public property | Triangle | Retrieves a specific triangle.
Public property | Vertices | Retrieves all vertices used to define this mesh. Intended for indexed access.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Mesh Class


MaterialElementId Property

[image]

Revit 2013 API
Mesh..::..MaterialElementId Property
Mesh Class See Also Send Feedback
Element ID of the material from which this mesh is composed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId MaterialElementId { get; }
Visual Basic
Public ReadOnly Property MaterialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialElementId {
    ElementId^ get ();
}

See Also

Mesh Class


NumTriangles Property

[image]

Revit 2013 API
Mesh..::..NumTriangles Property
Mesh Class See Also Send Feedback
The number of triangles that the mesh contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumTriangles { get; }
Visual Basic
Public ReadOnly Property NumTriangles As Integer
    Get
Visual C++
public:
property int NumTriangles {
    int get ();
}

See Also

Mesh Class


Transformed Property

[image]

Revit 2013 API
Mesh..::..Transformed Property
Mesh Class See Also Send Feedback
Transforms this mesh and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Mesh this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Mesh
    Get
Visual C++
public:
property Mesh^ Transformed[Transform^ transform] {
    Mesh^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation used to transform the profile.

Return Value

The transformed mesh.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Mesh Class


Triangle Property

[image]

Revit 2013 API
Mesh..::..Triangle Property
Mesh Class See Also Send Feedback
Retrieves a specific triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MeshTriangle this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Triangle ( _
    idx As Integer _
) As MeshTriangle
    Get
Visual C++
public:
property MeshTriangle^ Triangle[int idx] {
    MeshTriangle^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the triangle, must be in [0, NumTriangles).

See Also

Mesh Class


Vertices Property

[image]

Revit 2013 API
Mesh..::..Vertices Property
Mesh Class See Also Send Feedback
Retrieves all vertices used to define this mesh. Intended for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Vertices { get; }
Visual Basic
Public ReadOnly Property Vertices As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ Vertices {
    IList<XYZ^>^ get ();
}

See Also

Mesh Class


MeshArray Class

[image]

Revit 2013 API
MeshArray Class
Members See Also Send Feedback
An array that contains meshes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MeshArray : APIObject, IEnumerable
Visual Basic
Public Class MeshArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MeshArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MeshArray

See Also

MeshArray Members


MeshArray Members

[image] [image]

Revit 2013 API
MeshArray Members
MeshArray Class Constructors Methods Properties See Also Send Feedback

The MeshArray type exposes the following members.

Constructors

 | Name | Description
Public method | MeshArray | Initializes a new instance of the MeshArray class

Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class


MeshArray Constructor

[image]

Revit 2013 API
MeshArray Constructor
MeshArray Class See Also Send Feedback
Initializes a new instance of the MeshArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MeshArray()
Visual Basic
Public Sub New
Visual C++
public:
MeshArray()

See Also

MeshArray Class


MeshArray Methods

[image] [image]

Revit 2013 API
MeshArray Methods
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the mesh to the end of the array.
Public method | Clear | Removes every mesh from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mesh into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArray Class


Append Method

[image]

Revit 2013 API
MeshArray..::..Append Method
MeshArray Class See Also Send Feedback
Add the mesh to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Mesh item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Mesh _
)
Visual C++
public:
virtual void Append(
    Mesh^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Mesh
The mesh to be added.

See Also

MeshArray Class


Clear Method

[image]

Revit 2013 API
MeshArray..::..Clear Method
MeshArray Class See Also Send Feedback
Removes every mesh from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MeshArray Class


ForwardIterator Method

[image]

Revit 2013 API
MeshArray..::..ForwardIterator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MeshArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

MeshArray Class


GetEnumerator Method

[image]

Revit 2013 API
MeshArray..::..GetEnumerator Method
MeshArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MeshArray Class


Insert Method

[image]

Revit 2013 API
MeshArray..::..Insert Method
MeshArray Class See Also Send Feedback
Insert the specified mesh into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Mesh item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Mesh, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Mesh^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Mesh
The mesh to be inserted into the array.
index
Type: System..::..Int32
The mesh will be inserted before this index.

Return Value

Returns whether the mesh was inserted into the array.

See Also

MeshArray Class


ReverseIterator Method

[image]

Revit 2013 API
MeshArray..::..ReverseIterator Method
MeshArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MeshArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As MeshArrayIterator
Visual C++
public:
virtual MeshArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

MeshArray Class


MeshArray Properties

[image] [image]

Revit 2013 API
MeshArray Properties
MeshArray Class See Also Send Feedback

The MeshArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a mesh at a specified index within the array.
Public property | Size | Returns the number of meshes that are in the array.

See Also

MeshArray Class


IsEmpty Property

[image]

Revit 2013 API
MeshArray..::..IsEmpty Property
MeshArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

MeshArray Class


Item Property

[image]

Revit 2013 API
MeshArray..::..Item Property
MeshArray Class See Also Send Feedback
Gets or sets a mesh at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Mesh this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Mesh
    Get
    Set
Visual C++
public:
virtual property Mesh^ Item[int index] {
    Mesh^ get (int index);
    void set (int index, Mesh^ value);
}

Parameters

index
Type: System..::..Int32
The index of the mesh to be set or retrieved.

Return Value

Returns the mesh at the specified index.

See Also

MeshArray Class


Size Property

[image]

Revit 2013 API
MeshArray..::..Size Property
MeshArray Class See Also Send Feedback
Returns the number of meshes that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MeshArray Class


MeshArrayIterator Class

[image]

Revit 2013 API
MeshArrayIterator Class
Members See Also Send Feedback
An iterator to a mesh array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class MeshArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class MeshArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MeshArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MeshArrayIterator

See Also

MeshArrayIterator Members


MeshArrayIterator Members

[image] [image]

Revit 2013 API
MeshArrayIterator Members
MeshArrayIterator Class Constructors Methods Properties See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MeshArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class


MeshArrayIterator Constructor

[image]

Revit 2013 API
MeshArrayIterator Constructor
MeshArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MeshArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
MeshArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MeshArrayIterator Class


MeshArrayIterator Methods

[image] [image]

Revit 2013 API
MeshArrayIterator Methods
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
MeshArrayIterator..::..MoveNext Method
MeshArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MeshArrayIterator Class


Reset Method

[image]

Revit 2013 API
MeshArrayIterator..::..Reset Method
MeshArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MeshArrayIterator Class


MeshArrayIterator Properties

[image] [image]

Revit 2013 API
MeshArrayIterator Properties
MeshArrayIterator Class See Also Send Feedback

The MeshArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MeshArrayIterator Class


Current Property

[image]

Revit 2013 API
MeshArrayIterator..::..Current Property
MeshArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MeshArrayIterator Class


MeshTriangle Class

[image]

Revit 2013 API
MeshTriangle Class
Members See Also Send Feedback
One triangle of a mesh.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MeshTriangle : APIObject
Visual Basic
Public Class MeshTriangle _
    Inherits APIObject
Visual C++
public ref class MeshTriangle : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MeshTriangle

See Also

MeshTriangle Members


MeshTriangle Members

[image] [image]

Revit 2013 API
MeshTriangle Members
MeshTriangle Class Methods Properties See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


MeshTriangle Methods

[image] [image]

Revit 2013 API
MeshTriangle Methods
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MeshTriangle Class


MeshTriangle Properties

[image] [image]

Revit 2013 API
MeshTriangle Properties
MeshTriangle Class See Also Send Feedback

The MeshTriangle type exposes the following members.

Properties

 | Name | Description
Public property | Index | The index of the vertex in the Vertices array of the mesh, for indexed access.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Vertex | A vertex of the triangle.

See Also

MeshTriangle Class


Index Property

[image]

Revit 2013 API
MeshTriangle..::..Index Property
MeshTriangle Class See Also Send Feedback
The index of the vertex in the Vertices array of the mesh, for indexed access.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public uint this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Index ( _
    idx As Integer _
) As UInteger
    Get
Visual C++
public:
property unsigned int Index[int idx] {
    unsigned int get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


Vertex Property

[image]

Revit 2013 API
MeshTriangle..::..Vertex Property
MeshTriangle Class See Also Send Feedback
A vertex of the triangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Property Vertex ( _
    idx As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Vertex[int idx] {
    XYZ^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of the vertex in the triangle: 0, 1 or 2.

See Also

MeshTriangle Class


ModelArc Class

[image]

Revit 2013 API
ModelArc Class
Members See Also Send Feedback
Represents a ModelArc within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelArc : ModelCurve
Visual Basic
Public Class ModelArc _
    Inherits ModelCurve
Visual C++
public ref class ModelArc : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelArc

See Also

ModelArc Members


ModelArc Members

[image] [image]

Revit 2013 API
ModelArc Members
ModelArc Class Methods Properties See Also Send Feedback

The ModelArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelArc Class


ModelArc Methods

[image] [image]

Revit 2013 API
ModelArc Methods
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelArc Class


ModelArc Properties

[image] [image]

Revit 2013 API
ModelArc Properties
ModelArc Class See Also Send Feedback

The ModelArc type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelArc Class


Parameter Property

[image] [image]

Revit 2013 API
ModelArc..::..Parameter Property
ModelArc Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelArc Class
ModelArc Members


ModelCurve Class

[image]

Revit 2013 API
ModelCurve Class
Members See Also Send Feedback
A model element that exists in 3D space and is visible in all views of a Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelCurve : CurveElement
Visual Basic
Public Class ModelCurve _
    Inherits CurveElement
Visual C++
public ref class ModelCurve : public CurveElement

Remarks

You can use model curves to represent 3D geometry in a building design, such as cords or cables that secure a tarp.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelArc
Autodesk.Revit.DB..::..ModelEllipse
Autodesk.Revit.DB..::..ModelHermiteSpline
Autodesk.Revit.DB..::..ModelLine
Autodesk.Revit.DB..::..ModelNurbSpline

See Also

ModelCurve Members


ModelCurve Members

[image] [image]

Revit 2013 API
ModelCurve Members
ModelCurve Class Methods Properties See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | TrussCurveType | The truss curve type of this model curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelCurve Class


ModelCurve Methods

[image] [image]

Revit 2013 API
ModelCurve Methods
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurve Class


ChangeToReferenceLine Method

[image]

Revit 2013 API
ModelCurve..::..ChangeToReferenceLine Method
ModelCurve Class See Also Send Feedback
Changes this curve to a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ChangeToReferenceLine()
Visual Basic
Public Sub ChangeToReferenceLine
Visual C++
public:
void ChangeToReferenceLine()

See Also

ModelCurve Class


GetVisibility Method

[image]

Revit 2013 API
ModelCurve..::..GetVisibility Method
ModelCurve Class See Also Send Feedback
Gets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model curve in a family document.

See Also

ModelCurve Class


SetVisibility Method

[image]

Revit 2013 API
ModelCurve..::..SetVisibility Method
ModelCurve Class See Also Send Feedback
Sets the visibility for the model curve in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the model curve geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelCurve Class


ModelCurve Properties

[image] [image]

Revit 2013 API
ModelCurve Properties
ModelCurve Class See Also Send Feedback

The ModelCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | TrussCurveType | The truss curve type of this model curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelCurve Class


IsReferenceLine Property

[image]

Revit 2013 API
ModelCurve..::..IsReferenceLine Property
ModelCurve Class See Also Send Feedback
Indicates if this curve is a reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReferenceLine { get; }
Visual Basic
Public ReadOnly Property IsReferenceLine As Boolean
    Get
Visual C++
public:
property bool IsReferenceLine {
    bool get ();
}

See Also

ModelCurve Class


Parameter Property

[image] [image]

Revit 2013 API
ModelCurve..::..Parameter Property
ModelCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelCurve Class
ModelCurve Members


Subcategory Property

[image]

Revit 2013 API
ModelCurve..::..Subcategory Property
ModelCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic
Public Property Subcategory As GraphicsStyle
    Get
    Set
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

ModelCurve Class


TrussCurveType Property

[image]

Revit 2013 API
ModelCurve..::..TrussCurveType Property
ModelCurve Class See Also Send Feedback
The truss curve type of this model curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussCurveType TrussCurveType { get; set; }
Visual Basic
Public Property TrussCurveType As TrussCurveType
    Get
    Set
Visual C++
public:
property TrussCurveType TrussCurveType {
    TrussCurveType get ();
    void set (TrussCurveType value);
}

Remarks

This property is applicable only to curves in Truss families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to set this property to a curve not in a truss family.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc).

See Also

ModelCurve Class


ModelCurveArrArray Class

[image]

Revit 2013 API
ModelCurveArrArray Class
Members See Also Send Feedback
An array that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelCurveArrArray : APIObject,
    IEnumerable
Visual Basic
Public Class ModelCurveArrArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArrArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArrArray

See Also

ModelCurveArrArray Members


ModelCurveArrArray Members

[image] [image]

Revit 2013 API
ModelCurveArrArray Members
ModelCurveArrArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Constructors

 | Name | Description
Public method | ModelCurveArrArray | Initializes a new instance of the ModelCurveArrArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class


ModelCurveArrArray Constructor

[image]

Revit 2013 API
ModelCurveArrArray Constructor
ModelCurveArrArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArrArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArrArray()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArrArray()

See Also

ModelCurveArrArray Class


ModelCurveArrArray Methods

[image] [image]

Revit 2013 API
ModelCurveArrArray Methods
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArray Class


Append Method

[image]

Revit 2013 API
ModelCurveArrArray..::..Append Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurveArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ModelCurveArray _
)
Visual C++
public:
virtual void Append(
    ModelCurveArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurveArray

See Also

ModelCurveArrArray Class


Clear Method

[image]

Revit 2013 API
ModelCurveArrArray..::..Clear Method
ModelCurveArrArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArrArray Class


ForwardIterator Method

[image]

Revit 2013 API
ModelCurveArrArray..::..ForwardIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArrArray Class


GetEnumerator Method

[image]

Revit 2013 API
ModelCurveArrArray..::..GetEnumerator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ModelCurveArrArray Class


Insert Method

[image]

Revit 2013 API
ModelCurveArrArray..::..Insert Method
ModelCurveArrArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurveArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ModelCurveArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurveArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurveArray
index
Type: System..::..Int32

See Also

ModelCurveArrArray Class


ReverseIterator Method

[image]

Revit 2013 API
ModelCurveArrArray..::..ReverseIterator Method
ModelCurveArrArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurveArrArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ModelCurveArrArrayIterator
Visual C++
public:
virtual ModelCurveArrArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArrArray Class


ModelCurveArrArray Properties

[image] [image]

Revit 2013 API
ModelCurveArrArray Properties
ModelCurveArrArray Class See Also Send Feedback

The ModelCurveArrArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ModelCurveArrArray Class


IsEmpty Property

[image]

Revit 2013 API
ModelCurveArrArray..::..IsEmpty Property
ModelCurveArrArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArrArray Class


Item Property

[image]

Revit 2013 API
ModelCurveArrArray..::..Item Property
ModelCurveArrArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurveArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurveArray
    Get
    Set
Visual C++
public:
virtual property ModelCurveArray^ Item[int index] {
    ModelCurveArray^ get (int index);
    void set (int index, ModelCurveArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ModelCurveArrArray Class


Size Property

[image]

Revit 2013 API
ModelCurveArrArray..::..Size Property
ModelCurveArrArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArrArray Class


ModelCurveArrArrayIterator Class

[image]

Revit 2013 API
ModelCurveArrArrayIterator Class
Members See Also Send Feedback
An iterator to a array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ModelCurveArrArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ModelCurveArrArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArrArrayIterator

See Also

ModelCurveArrArrayIterator Members


ModelCurveArrArrayIterator Members

[image] [image]

Revit 2013 API
ModelCurveArrArrayIterator Members
ModelCurveArrArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ModelCurveArrArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Constructor

[image]

Revit 2013 API
ModelCurveArrArrayIterator Constructor
ModelCurveArrArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArrArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArrArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Methods

[image] [image]

Revit 2013 API
ModelCurveArrArrayIterator Methods
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ModelCurveArrArrayIterator..::..MoveNext Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class


Reset Method

[image]

Revit 2013 API
ModelCurveArrArrayIterator..::..Reset Method
ModelCurveArrArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArrArrayIterator Properties

[image] [image]

Revit 2013 API
ModelCurveArrArrayIterator Properties
ModelCurveArrArrayIterator Class See Also Send Feedback

The ModelCurveArrArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrArrayIterator Class


Current Property

[image]

Revit 2013 API
ModelCurveArrArrayIterator..::..Current Property
ModelCurveArrArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrArrayIterator Class


ModelCurveArray Class

[image]

Revit 2013 API
ModelCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelCurveArray : APIObject,
    IEnumerable
Visual Basic
Public Class ModelCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ModelCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArray

See Also

ModelCurveArray Members


ModelCurveArray Members

[image] [image]

Revit 2013 API
ModelCurveArray Members
ModelCurveArray Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | ModelCurveArray | Initializes a new instance of the ModelCurveArray class

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class


ModelCurveArray Constructor

[image]

Revit 2013 API
ModelCurveArray Constructor
ModelCurveArray Class See Also Send Feedback
Initializes a new instance of the ModelCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArray()

See Also

ModelCurveArray Class


ModelCurveArray Methods

[image] [image]

Revit 2013 API
ModelCurveArray Methods
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArray Class


Append Method

[image]

Revit 2013 API
ModelCurveArray..::..Append Method
ModelCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    ModelCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ModelCurve _
)
Visual C++
public:
virtual void Append(
    ModelCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurve
The model curve to be added.

See Also

ModelCurveArray Class


Clear Method

[image]

Revit 2013 API
ModelCurveArray..::..Clear Method
ModelCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ModelCurveArray Class


ForwardIterator Method

[image]

Revit 2013 API
ModelCurveArray..::..ForwardIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ModelCurveArray Class


GetEnumerator Method

[image]

Revit 2013 API
ModelCurveArray..::..GetEnumerator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ModelCurveArray Class


Insert Method

[image]

Revit 2013 API
ModelCurveArray..::..Insert Method
ModelCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ModelCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ModelCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ModelCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ModelCurve
The model curve to be inserted into the array.
index
Type: System..::..Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

ModelCurveArray Class


ReverseIterator Method

[image]

Revit 2013 API
ModelCurveArray..::..ReverseIterator Method
ModelCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ModelCurveArrayIterator
Visual C++
public:
virtual ModelCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ModelCurveArray Class


ModelCurveArray Properties

[image] [image]

Revit 2013 API
ModelCurveArray Properties
ModelCurveArray Class See Also Send Feedback

The ModelCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

ModelCurveArray Class


IsEmpty Property

[image]

Revit 2013 API
ModelCurveArray..::..IsEmpty Property
ModelCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ModelCurveArray Class


Item Property

[image]

Revit 2013 API
ModelCurveArray..::..Item Property
ModelCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ModelCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ModelCurve
    Get
    Set
Visual C++
public:
virtual property ModelCurve^ Item[int index] {
    ModelCurve^ get (int index);
    void set (int index, ModelCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

ModelCurveArray Class


Size Property

[image]

Revit 2013 API
ModelCurveArray..::..Size Property
ModelCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ModelCurveArray Class


ModelCurveArrayIterator Class

[image]

Revit 2013 API
ModelCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ModelCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ModelCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ModelCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ModelCurveArrayIterator

See Also

ModelCurveArrayIterator Members


ModelCurveArrayIterator Members

[image] [image]

Revit 2013 API
ModelCurveArrayIterator Members
ModelCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ModelCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Constructor

[image]

Revit 2013 API
ModelCurveArrayIterator Constructor
ModelCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelCurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ModelCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Methods

[image] [image]

Revit 2013 API
ModelCurveArrayIterator Methods
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelCurveArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ModelCurveArrayIterator..::..MoveNext Method
ModelCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


Reset Method

[image]

Revit 2013 API
ModelCurveArrayIterator..::..Reset Method
ModelCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ModelCurveArrayIterator Class


ModelCurveArrayIterator Properties

[image] [image]

Revit 2013 API
ModelCurveArrayIterator Properties
ModelCurveArrayIterator Class See Also Send Feedback

The ModelCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ModelCurveArrayIterator Class


Current Property

[image]

Revit 2013 API
ModelCurveArrayIterator..::..Current Property
ModelCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ModelCurveArrayIterator Class


ModelEllipse Class

[image]

Revit 2013 API
ModelEllipse Class
Members See Also Send Feedback
Represents a ModelEllipse within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelEllipse : ModelCurve
Visual Basic
Public Class ModelEllipse _
    Inherits ModelCurve
Visual C++
public ref class ModelEllipse : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelEllipse

See Also

ModelEllipse Members


ModelEllipse Members

[image] [image]

Revit 2013 API
ModelEllipse Members
ModelEllipse Class Methods Properties See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelEllipse Class


ModelEllipse Methods

[image] [image]

Revit 2013 API
ModelEllipse Methods
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelEllipse Class


ModelEllipse Properties

[image] [image]

Revit 2013 API
ModelEllipse Properties
ModelEllipse Class See Also Send Feedback

The ModelEllipse type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelEllipse Class


Parameter Property

[image] [image]

Revit 2013 API
ModelEllipse..::..Parameter Property
ModelEllipse Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelEllipse Class
ModelEllipse Members


ModelHermiteSpline Class

[image]

Revit 2013 API
ModelHermiteSpline Class
Members See Also Send Feedback
Represents a ModelHermiteSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelHermiteSpline : ModelCurve
Visual Basic
Public Class ModelHermiteSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelHermiteSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelHermiteSpline

See Also

ModelHermiteSpline Members


ModelHermiteSpline Members

[image] [image]

Revit 2013 API
ModelHermiteSpline Members
ModelHermiteSpline Class Methods Properties See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Methods

[image] [image]

Revit 2013 API
ModelHermiteSpline Methods
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelHermiteSpline Class


ModelHermiteSpline Properties

[image] [image]

Revit 2013 API
ModelHermiteSpline Properties
ModelHermiteSpline Class See Also Send Feedback

The ModelHermiteSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelHermiteSpline Class


Parameter Property

[image] [image]

Revit 2013 API
ModelHermiteSpline..::..Parameter Property
ModelHermiteSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelHermiteSpline Class
ModelHermiteSpline Members


ModelLine Class

[image]

Revit 2013 API
ModelLine Class
Members See Also Send Feedback
Represents a ModelLine within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelLine : ModelCurve
Visual Basic
Public Class ModelLine _
    Inherits ModelCurve
Visual C++
public ref class ModelLine : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelLine

See Also

ModelLine Members


ModelLine Members

[image] [image]

Revit 2013 API
ModelLine Members
ModelLine Class Methods Properties See Also Send Feedback

The ModelLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelLine Class


ModelLine Methods

[image] [image]

Revit 2013 API
ModelLine Methods
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelLine Class


ModelLine Properties

[image] [image]

Revit 2013 API
ModelLine Properties
ModelLine Class See Also Send Feedback

The ModelLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelLine Class


Parameter Property

[image] [image]

Revit 2013 API
ModelLine..::..Parameter Property
ModelLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelLine Class
ModelLine Members


ModelNurbSpline Class

[image]

Revit 2013 API
ModelNurbSpline Class
Members See Also Send Feedback
Represents a ModelNurbSpline within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelNurbSpline : ModelCurve
Visual Basic
Public Class ModelNurbSpline _
    Inherits ModelCurve
Visual C++
public ref class ModelNurbSpline : public ModelCurve

Remarks

Currently it's just a place holder for specific type. All the geometry-related functionality is provided by geometry curve object from ModelCurve::geometryCurve property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..ModelCurve
Autodesk.Revit.DB..::..ModelNurbSpline

See Also

ModelNurbSpline Members


ModelNurbSpline Members

[image] [image]

Revit 2013 API
ModelNurbSpline Members
ModelNurbSpline Class Methods Properties See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelNurbSpline Class


ModelNurbSpline Methods

[image] [image]

Revit 2013 API
ModelNurbSpline Methods
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeToReferenceLine | Changes this curve to a reference curve. (Inherited from ModelCurve.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model curve in a family document. (Inherited from ModelCurve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelNurbSpline Class


ModelNurbSpline Properties

[image] [image]

Revit 2013 API
ModelNurbSpline Properties
ModelNurbSpline Class See Also Send Feedback

The ModelNurbSpline type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsReferenceLine | Indicates if this curve is a reference curve. (Inherited from ModelCurve.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory. (Inherited from ModelCurve.)
Public property | TrussCurveType | The truss curve type of this model curve. (Inherited from ModelCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelNurbSpline Class


Parameter Property

[image] [image]

Revit 2013 API
ModelNurbSpline..::..Parameter Property
ModelNurbSpline Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelNurbSpline Class
ModelNurbSpline Members


ModelPath Class

[image]

Revit 2013 API
ModelPath Class
Members See Also Send Feedback
A path to a file stored on a disk or on a server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ModelPath : IDisposable
Visual Basic
Public Class ModelPath _
    Implements IDisposable
Visual C++
public ref class ModelPath : IDisposable

Remarks

ModelPaths are paths to another file. They can refer to Revit models, or to any of Revit's external file references (DWG links, for example.) Paths can be relative or absolute, but they must include an extension indicating what kind of file it is. Relative paths are generally relative to the currently opened document. If the current document is workshared, paths will be treated as relative to the central model. To create a ModelPath, use the derived classes FilePath and ServerPath. The class ModelPathUtils contains utility functions for converting ModelPaths to and from strings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..FilePath
Autodesk.Revit.DB..::..ServerPath

See Also

ModelPath Members


ModelPath Members

[image] [image]

Revit 2013 API
ModelPath Members
ModelPath Class Methods Properties See Also Send Feedback

The ModelPath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another
Public method | Dispose | Releases all resources used by the ModelPath
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server.
Public property | ServerPath | Whether this path is a server path or a file path

See Also

ModelPath Class


ModelPath Methods

[image] [image]

Revit 2013 API
ModelPath Methods
ModelPath Class See Also Send Feedback

The ModelPath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelPath Class


Compare Method

[image]

Revit 2013 API
ModelPath..::..Compare Method
ModelPath Class See Also Send Feedback
Compares this ModelPath with another

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Compare(
    ModelPath otherPath
)
Visual Basic
Public Function Compare ( _
    otherPath As ModelPath _
) As Integer
Visual C++
public:
int Compare(
    ModelPath^ otherPath
)

Parameters

otherPath
Type: Autodesk.Revit.DB..::..ModelPath
The path to compare against.

Return Value

A signed integer indicating the lexical relationship between two ModelPaths. Value is less than zero if this path is less than the given path; zero if the two are the same; and more than zero otherwise

Remarks

The comparison is case-insensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ModelPath Class


Dispose Method

[image]

Revit 2013 API
ModelPath..::..Dispose Method
ModelPath Class See Also Send Feedback
Releases all resources used by the ModelPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ModelPath Class


ModelPath Properties

[image] [image]

Revit 2013 API
ModelPath Properties
ModelPath Class See Also Send Feedback

The ModelPath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server.
Public property | ServerPath | Whether this path is a server path or a file path

See Also

ModelPath Class


CentralServerPath Property

[image]

Revit 2013 API
ModelPath..::..CentralServerPath Property
ModelPath Class See Also Send Feedback
A path to the location of the central Revit server.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string CentralServerPath { get; }
Visual Basic
Public ReadOnly Property CentralServerPath As String
    Get
Visual C++
public:
property String^ CentralServerPath {
    String^ get ();
}

See Also

ModelPath Class


ServerPath Property

[image]

Revit 2013 API
ModelPath..::..ServerPath Property
ModelPath Class See Also Send Feedback
Whether this path is a server path or a file path

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ServerPath { get; }
Visual Basic
Public ReadOnly Property ServerPath As Boolean
    Get
Visual C++
public:
property bool ServerPath {
    bool get ();
}

Field Value

True if this path is a server path. False if this path is a file path.

See Also

ModelPath Class


ModelPathUtils Class

[image]

Revit 2013 API
ModelPathUtils Class
Members See Also Send Feedback
Utility functions using ModelPaths

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ModelPathUtils : IDisposable
Visual Basic
Public Class ModelPathUtils _
    Implements IDisposable
Visual C++
public ref class ModelPathUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPathUtils

See Also

ModelPathUtils Members


ModelPathUtils Members

[image] [image]

Revit 2013 API
ModelPathUtils Members
ModelPathUtils Class Methods See Also Send Feedback

The ModelPathUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
 | ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
Public method | Dispose | Releases all resources used by the ModelPathUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelPathUtils Class


ModelPathUtils Methods

[image] [image]

Revit 2013 API
ModelPathUtils Methods
ModelPathUtils Class See Also Send Feedback

The ModelPathUtils type exposes the following members.

Methods

 | Name | Description
 | ConvertModelPathToUserVisiblePath | Gets a string version of the path of a given ModelPath.
 | ConvertUserVisiblePathToModelPath | Converts a user-visible path (string) to a ModelPath.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidUserVisibleFullServerPath | Determines whether the given string represents a valid server path.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelPathUtils Class


ConvertModelPathToUserVisiblePath Method

[image]

Revit 2013 API
ModelPathUtils..::..ConvertModelPathToUserVisiblePath Method
ModelPathUtils Class See Also Send Feedback
Gets a string version of the path of a given ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string ConvertModelPathToUserVisiblePath(
    ModelPath path
)
Visual Basic
Public Shared Function ConvertModelPathToUserVisiblePath ( _
    path As ModelPath _
) As String
Visual C++
public:
static String^ ConvertModelPathToUserVisiblePath(
    ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath representing a file path or a server path.

Return Value

The path in string form

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ModelPathUtils Class


ConvertUserVisiblePathToModelPath Method

[image]

Revit 2013 API
ModelPathUtils..::..ConvertUserVisiblePathToModelPath Method
ModelPathUtils Class See Also Send Feedback
Converts a user-visible path (string) to a ModelPath.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ModelPath ConvertUserVisiblePathToModelPath(
    string strPath
)
Visual Basic
Public Shared Function ConvertUserVisiblePathToModelPath ( _
    strPath As String _
) As ModelPath
Visual C++
public:
static ModelPath^ ConvertUserVisiblePathToModelPath(
    String^ strPath
)

Parameters

strPath
Type: System..::..String
The path in string form, like RSN://{HostNodeName}/school/project.rvt

Return Value

A ModelPath representing either a server or file path.

Remarks

The path may be a server or file path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ModelPathUtils Class


Dispose Method

[image]

Revit 2013 API
ModelPathUtils..::..Dispose Method
ModelPathUtils Class See Also Send Feedback
Releases all resources used by the ModelPathUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ModelPathUtils Class


IsValidUserVisibleFullServerPath Method

[image]

Revit 2013 API
ModelPathUtils..::..IsValidUserVisibleFullServerPath Method
ModelPathUtils Class See Also Send Feedback
Determines whether the given string represents a valid server path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidUserVisibleFullServerPath(
    string strPath
)
Visual Basic
Public Shared Function IsValidUserVisibleFullServerPath ( _
    strPath As String _
) As Boolean
Visual C++
public:
static bool IsValidUserVisibleFullServerPath(
    String^ strPath
)

Parameters

strPath
Type: System..::..String
The path, in string form

Return Value

True if the given path is a valid server path, false otherwise.

Remarks

ServerPaths must refer to Revit models.

ServerPaths are relative to the central server location, and are of the form "RSN://{HostNodeName}/{model_path}".

The {model_path} portion is a relative path to a Revit model. For example:

  • RSN://EXS/hospital.rvt
  • RSN://EXS.autodesk.com/Old Files/hotel2.rvt
  • RSN://EXS.autodesk.com/Old Files/Last Week/Tuesday\hotel2.rvt
are all valid server paths.
  • //EXS/Old Files/.rvt
  • EXS/hospital
are not valid server paths. If this function returns false, it does not necessarily mean the given path is a file path. It may be a malformed string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ModelPathUtils Class


ModelText Class

[image]

Revit 2013 API
ModelText Class
Members See Also Send Feedback
A model text element in an Autodesk Revit family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelText : Element
Visual Basic
Public Class ModelText _
    Inherits Element
Visual C++
public ref class ModelText : public Element

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ModelText

See Also

ModelText Members


ModelText Members

[image] [image]

Revit 2013 API
ModelText Members
ModelText Class Methods Properties See Also Send Feedback

The ModelText type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Depth | The depth of the model text.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalAlignment | The horizontal alignment.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | ModelTextType | The type for the model text.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelText Class


ModelText Methods

[image] [image]

Revit 2013 API
ModelText Methods
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the model text in a family document.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the model text in a family document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelText Class


GetVisibility Method

[image]

Revit 2013 API
ModelText..::..GetVisibility Method
ModelText Class See Also Send Feedback
Gets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the model text in a family document.

See Also

ModelText Class


SetVisibility Method

[image]

Revit 2013 API
ModelText..::..SetVisibility Method
ModelText Class See Also Send Feedback
Sets the visibility for the model text in a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the model text geometry can be changed for different types of views and detail levels in the family document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed, or the model curve is in a project document.

See Also

ModelText Class


ModelText Properties

[image] [image]

Revit 2013 API
ModelText Properties
ModelText Class See Also Send Feedback

The ModelText type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Depth | The depth of the model text.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalAlignment | The horizontal alignment.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | ModelTextType | The type for the model text.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Subcategory | The subcategory.
Public property | Text | The text string in the model text.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelText Class


Depth Property

[image]

Revit 2013 API
ModelText..::..Depth Property
ModelText Class See Also Send Feedback
The depth of the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Depth { get; set; }
Visual Basic
Public Property Depth As Double
    Get
    Set
Visual C++
public:
property double Depth {
    double get ();
    void set (double value);
}

See Also

ModelText Class


HorizontalAlignment Property

[image]

Revit 2013 API
ModelText..::..HorizontalAlignment Property
ModelText Class See Also Send Feedback
The horizontal alignment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HorizontalAlign HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As HorizontalAlign
    Get
    Set
Visual C++
public:
property HorizontalAlign HorizontalAlignment {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an invalid value is assigned to the property.

See Also

ModelText Class


Location Property

[image]

Revit 2013 API
ModelText..::..Location Property
ModelText Class See Also Send Feedback
This property is used to find the physical location of an instance within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

ModelText Class


ModelTextType Property

[image]

Revit 2013 API
ModelText..::..ModelTextType Property
ModelText Class See Also Send Feedback
The type for the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelTextType ModelTextType { get; set; }
Visual Basic
Public Property ModelTextType As ModelTextType
    Get
    Set
Visual C++
public:
property ModelTextType^ ModelTextType {
    ModelTextType^ get ();
    void set (ModelTextType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to this property.

See Also

ModelText Class


Parameter Property

[image] [image]

Revit 2013 API
ModelText..::..Parameter Property
ModelText Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelText Class
ModelText Members


Subcategory Property

[image]

Revit 2013 API
ModelText..::..Subcategory Property
ModelText Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Category Subcategory { get; set; }
Visual Basic
Public Property Subcategory As Category
    Get
    Set
Visual C++
public:
property Category^ Subcategory {
    Category^ get ();
    void set (Category^ value);
}

Remarks

The subcategory can be set to either the family category or one of its subcategories.

See Also

ModelText Class


Text Property

[image]

Revit 2013 API
ModelText..::..Text Property
ModelText Class See Also Send Feedback
The text string in the model text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is assigned to text.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is assigned to text.

See Also

ModelText Class


ModelTextType Class

[image]

Revit 2013 API
ModelTextType Class
Members See Also Send Feedback
A model text type symbol in the Autodesk Revit Family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ModelTextType : ElementType
Visual Basic
Public Class ModelTextType _
    Inherits ElementType
Visual C++
public ref class ModelTextType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..ModelTextType

See Also

ModelTextType Members


ModelTextType Members

[image] [image]

Revit 2013 API
ModelTextType Members
ModelTextType Class Methods Properties See Also Send Feedback

The ModelTextType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelTextType Class


ModelTextType Methods

[image] [image]

Revit 2013 API
ModelTextType Methods
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ModelTextType Class


ModelTextType Properties

[image] [image]

Revit 2013 API
ModelTextType Properties
ModelTextType Class See Also Send Feedback

The ModelTextType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ModelTextType Class


Parameter Property

[image] [image]

Revit 2013 API
ModelTextType..::..Parameter Property
ModelTextType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ModelTextType Class
ModelTextType Members


ModelUpdatesStatus Enumeration

[image]

Revit 2013 API
ModelUpdatesStatus Enumeration
See Also Send Feedback
Indicates whether an element in the current model has additional user changes in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ModelUpdatesStatus
Visual Basic
Public Enumeration ModelUpdatesStatus
Visual C++
public enum class ModelUpdatesStatus

Members

Member name | Description
CurrentWithCentral | The element has no additional changes in the central model.
NotYetInCentral | The element is new in the current model and has not been saved to the central model. Note that this status will apply to newly created elements even if they are created in the central model.
DeletedInCentral | The element has been deleted in the central model.
UpdatedInCentral | The element has additional user changes in the central model. A reload latest will be required before it can be modified in the current model.

Remarks

Note that this status only indicates that the element has user changes in the central model. A user change is typically an action specifically taken by a user. Making a user change to an element requires that the user making the change reload all other user changes made to the element in the central model. Making a user change also causes the element to be checked out to the current user so other users will not be able to make user changes to the same element.

Elements can also be modified by system changes. A system change is one which is done automatically by Revit to fully update the model after a user change occurs. Users may make changes to an element in their local model even if the element contains additional system changes in the central model.

Example: Suppose Alice and Bob are working on the same model. Alice moves a wall which contains windows. Then Alice synchronizes with the central file. The wall was explicitly changed by Alice and so it will report as "UpdatedInCentral" in Bob's model. Bob would have to reload latest before he could make user changes to that wall. In contrast, Revit automatically moved the windows with the wall, so the windows do not contain any user changes. The windows would therefore report "CurrentWithCentral" and Bob would be allowed to modify them in his local model without reloading latest.

See Also


Mullion Class

[image]

Revit 2013 API
Mullion Class
Members See Also Send Feedback
Represents a CurtainGrid within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Mullion : FamilyInstance
Visual Basic
Public Class Mullion _
    Inherits FamilyInstance
Visual C++
public ref class Mullion : public FamilyInstance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..Mullion

See Also

Mullion Members


Mullion Members

[image] [image]

Revit 2013 API
Mullion Members
Mullion Class Methods Properties See Also Send Feedback

The Mullion type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Mullion Class


Mullion Methods

[image] [image]

Revit 2013 API
Mullion Methods
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | BreakMullion | This method is used to break the current Mullion at ends with its neighboring mullions.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | JoinMullion | This method is used to control the join condition the current Mullion with its neighboring mullions.
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mullion Class


BreakMullion Method

[image]

Revit 2013 API
Mullion..::..BreakMullion Method
Mullion Class See Also Send Feedback
This method is used to break the current Mullion at ends with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void BreakMullion()
Visual Basic
Public Sub BreakMullion
Visual C++
public:
void BreakMullion()

Remarks

The mullions being perpendicular to it will be joined accordingly.

See Also

Mullion Class


JoinMullion Method

[image]

Revit 2013 API
Mullion..::..JoinMullion Method
Mullion Class See Also Send Feedback
This method is used to control the join condition the current Mullion with its neighboring mullions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void JoinMullion()
Visual Basic
Public Sub JoinMullion
Visual C++
public:
void JoinMullion()

Remarks

The mullions being perpendicular to it will be broken accordingly.

See Also

Mullion Class


Mullion Properties

[image] [image]

Revit 2013 API
Mullion Properties
Mullion Class See Also Send Feedback

The Mullion type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | LocationCurve | This method get the curve location of the current Mullion.
Public property | Lock | Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.
Public property | Lockable | Get - to get whether the Mullion can be lock or unlock.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | MullionType | The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Mullion Class


FromRoom Property

[image] [image]

Revit 2013 API
Mullion..::..FromRoom Property
Mullion Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


LocationCurve Property

[image]

Revit 2013 API
Mullion..::..LocationCurve Property
Mullion Class See Also Send Feedback
This method get the curve location of the current Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve LocationCurve { get; }
Visual Basic
Public ReadOnly Property LocationCurve As Curve
    Get
Visual C++
public:
property Curve^ LocationCurve {
    Curve^ get ();
}

See Also

Mullion Class


Lock Property

[image]

Revit 2013 API
Mullion..::..Lock Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion line is locked. Set - Lock/unlock the Mullion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Lock { get; set; }
Visual Basic
Public Property Lock As Boolean
    Get
    Set
Visual C++
public:
property bool Lock {
    bool get ();
    void set (bool value);
}

See Also

Mullion Class


Lockable Property

[image]

Revit 2013 API
Mullion..::..Lockable Property
Mullion Class See Also Send Feedback
Get - to get whether the Mullion can be lock or unlock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic
Public ReadOnly Property Lockable As Boolean
    Get
Visual C++
public:
property bool Lockable {
    bool get ();
}

See Also

Mullion Class


MullionType Property

[image]

Revit 2013 API
Mullion..::..MullionType Property
Mullion Class See Also Send Feedback
The MullionType style of this Mullion. Get - to access type of mullion Set - change type of mullion. If the mullion is locked, InvalidOperationException exception will be thrown.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MullionType MullionType { get; set; }
Visual Basic
Public Property MullionType As MullionType
    Get
    Set
Visual C++
public:
property MullionType^ MullionType {
    MullionType^ get ();
    void set (MullionType^ value);
}

See Also

Mullion Class


Parameter Property

[image] [image]

Revit 2013 API
Mullion..::..Parameter Property
Mullion Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Mullion Class
Mullion Members


Room Property

[image] [image]

Revit 2013 API
Mullion..::..Room Property
Mullion Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


Space Property

[image] [image]

Revit 2013 API
Mullion..::..Space Property
Mullion Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


ToRoom Property

[image] [image]

Revit 2013 API
Mullion..::..ToRoom Property
Mullion Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Mullion Class
Mullion Members


MullionType Class

[image]

Revit 2013 API
MullionType Class
Members See Also Send Feedback
An object that represents a mullion type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MullionType : FamilySymbol
Visual Basic
Public Class MullionType _
    Inherits FamilySymbol
Visual C++
public ref class MullionType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..MullionType

See Also

MullionType Members


MullionType Members

[image] [image]

Revit 2013 API
MullionType Members
MullionType Class Methods Properties See Also Send Feedback

The MullionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MullionType Class


MullionType Methods

[image] [image]

Revit 2013 API
MullionType Methods
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionType Class


MullionType Properties

[image] [image]

Revit 2013 API
MullionType Properties
MullionType Class See Also Send Feedback

The MullionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MullionType Class


Parameter Property

[image] [image]

Revit 2013 API
MullionType..::..Parameter Property
MullionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MullionType Class
MullionType Members


MullionTypeSet Class

[image]

Revit 2013 API
MullionTypeSet Class
Members See Also Send Feedback
A set that contains mullion types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MullionTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class MullionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MullionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MullionTypeSet

See Also

MullionTypeSet Members


MullionTypeSet Members

[image] [image]

Revit 2013 API
MullionTypeSet Members
MullionTypeSet Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | MullionTypeSet | Initializes a new instance of the MullionTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class


MullionTypeSet Constructor

[image]

Revit 2013 API
MullionTypeSet Constructor
MullionTypeSet Class See Also Send Feedback
Initializes a new instance of the MullionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MullionTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
MullionTypeSet()

See Also

MullionTypeSet Class


MullionTypeSet Methods

[image] [image]

Revit 2013 API
MullionTypeSet Methods
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every mullion type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a mullion type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified mullion type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified mullion type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSet Class


Clear Method

[image]

Revit 2013 API
MullionTypeSet..::..Clear Method
MullionTypeSet Class See Also Send Feedback
Removes every mullion type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MullionTypeSet Class


Contains Method

[image]

Revit 2013 API
MullionTypeSet..::..Contains Method
MullionTypeSet Class See Also Send Feedback
Tests for the existence of a mullion type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    MullionType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..MullionType
The mullion type to be searched for.

Return Value

The Contains method returns True if the mullion type is within the set, otherwise False.

See Also

MullionTypeSet Class


Erase Method

[image]

Revit 2013 API
MullionTypeSet..::..Erase Method
MullionTypeSet Class See Also Send Feedback
Removes a specified mullion type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    MullionType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As MullionType _
) As Integer
Visual C++
public:
virtual int Erase(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..MullionType
The mullion type to be erased.

Return Value

The number of mullion types that were erased from the set.

See Also

MullionTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
MullionTypeSet..::..ForwardIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MullionTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
MullionTypeSet..::..GetEnumerator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MullionTypeSet Class


Insert Method

[image]

Revit 2013 API
MullionTypeSet..::..Insert Method
MullionTypeSet Class See Also Send Feedback
Insert the specified mullion type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    MullionType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As MullionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MullionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..MullionType
The mullion type to be inserted into the set.

Return Value

Returns whether the mullion type was inserted into the set.

See Also

MullionTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
MullionTypeSet..::..ReverseIterator Method
MullionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MullionTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As MullionTypeSetIterator
Visual C++
public:
virtual MullionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MullionTypeSet Class


MullionTypeSet Properties

[image] [image]

Revit 2013 API
MullionTypeSet Properties
MullionTypeSet Class See Also Send Feedback

The MullionTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of mullion types that are in the set.

See Also

MullionTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
MullionTypeSet..::..IsEmpty Property
MullionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MullionTypeSet Class


Size Property

[image]

Revit 2013 API
MullionTypeSet..::..Size Property
MullionTypeSet Class See Also Send Feedback
Returns the number of mullion types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MullionTypeSet Class


MullionTypeSetIterator Class

[image]

Revit 2013 API
MullionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a mullion type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class MullionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class MullionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MullionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MullionTypeSetIterator

See Also

MullionTypeSetIterator Members


MullionTypeSetIterator Members

[image] [image]

Revit 2013 API
MullionTypeSetIterator Members
MullionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MullionTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Constructor

[image]

Revit 2013 API
MullionTypeSetIterator Constructor
MullionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MullionTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
MullionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Methods

[image] [image]

Revit 2013 API
MullionTypeSetIterator Methods
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MullionTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
MullionTypeSetIterator..::..MoveNext Method
MullionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
MullionTypeSetIterator..::..Reset Method
MullionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MullionTypeSetIterator Class


MullionTypeSetIterator Properties

[image] [image]

Revit 2013 API
MullionTypeSetIterator Properties
MullionTypeSetIterator Class See Also Send Feedback

The MullionTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MullionTypeSetIterator Class


Current Property

[image]

Revit 2013 API
MullionTypeSetIterator..::..Current Property
MullionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MullionTypeSetIterator Class


MultiSegmentGrid Class

[image]

Revit 2013 API
MultiSegmentGrid Class
Members See Also Send Feedback
This element acts as a multi-segmented Grid. The individual grids associated to the MultiSegmentGrid behave as a single unit and all share the same text. They inherit their type (GridType) from the MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class MultiSegmentGrid : Element
Visual Basic
Public Class MultiSegmentGrid _
    Inherits Element
Visual C++
public ref class MultiSegmentGrid : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MultiSegmentGrid

See Also

MultiSegmentGrid Members


MultiSegmentGrid Members

[image] [image]

Revit 2013 API
MultiSegmentGrid Members
MultiSegmentGrid Class Methods Properties See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Methods

 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Text | name shared by grids in this MultiSegmentGrid
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiSegmentGrid Class


MultiSegmentGrid Methods

[image] [image]

Revit 2013 API
MultiSegmentGrid Methods
MultiSegmentGrid Class See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Methods

 | Name | Description
 | AreGridsInSameMultiSegmentGrid | Determine whether two Grids are members of the same GridChain.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a MultiSegmentGrid element from the specified curve loop.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGridIds | Get the element ids of the Grids that make up this MultiSegmentGrid.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetMultiSegementGridId | Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCurveLoop | Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.
 | IsValidSketchPlaneId | Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiSegmentGrid Class


AreGridsInSameMultiSegmentGrid Method

[image]

Revit 2013 API
MultiSegmentGrid..::..AreGridsInSameMultiSegmentGrid Method
MultiSegmentGrid Class See Also Send Feedback
Determine whether two Grids are members of the same GridChain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool AreGridsInSameMultiSegmentGrid(
    Grid grid1,
    Grid grid2
)
Visual Basic
Public Shared Function AreGridsInSameMultiSegmentGrid ( _
    grid1 As Grid, _
    grid2 As Grid _
) As Boolean
Visual C++
public:
static bool AreGridsInSameMultiSegmentGrid(
    Grid^ grid1,
    Grid^ grid2
)

Parameters

grid1
Type: Autodesk.Revit.DB..::..Grid
A Grid.
grid2
Type: Autodesk.Revit.DB..::..Grid
A Grid.

Return Value

Returns true if both of the specified Grids are associated to the same MultiSegmentGrid, i.e. getMultiSegementGridId returns the same valid element id for both Grids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MultiSegmentGrid Class


Create Method

[image]

Revit 2013 API
MultiSegmentGrid..::..Create Method
MultiSegmentGrid Class See Also Send Feedback
Create a MultiSegmentGrid element from the specified curve loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ElementId Create(
    Document document,
    ElementId typeId,
    CurveLoop curveLoop,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    curveLoop As CurveLoop, _
    sketchPlaneId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ Create(
    Document^ document,
    ElementId^ typeId,
    CurveLoop^ curveLoop,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the MultiSegmentGrid.
typeId
Type: Autodesk.Revit.DB..::..ElementId
Element id of a GridType element.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
An open curve loop consisting of lines and arcs.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Element id of a SketchPlane for the curves elements that will be created from the curveLoop.

Return Value

The element id of the new MultiSegmentGrid element.

Remarks

For each curve in the curve loop, a corresponding Grid will be created.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id should refer to a valid horizontal SketchPlane. -or- The element id should refer to a GridType element. -or- The curve loop should be an open loop consisting of lines and arcs.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

MultiSegmentGrid Class


GetGridIds Method

[image]

Revit 2013 API
MultiSegmentGrid..::..GetGridIds Method
MultiSegmentGrid Class See Also Send Feedback
Get the element ids of the Grids that make up this MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetGridIds()
Visual Basic
Public Function GetGridIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetGridIds()

Return Value

Element ids of Grids that make up this MultiSegmentGrid.

See Also

MultiSegmentGrid Class


GetMultiSegementGridId Method

[image]

Revit 2013 API
MultiSegmentGrid..::..GetMultiSegementGridId Method
MultiSegmentGrid Class See Also Send Feedback
Retrieve the element id of the MultiSegmentGrid of which the specified Grid is a member.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ElementId GetMultiSegementGridId(
    Grid grid
)
Visual Basic
Public Shared Function GetMultiSegementGridId ( _
    grid As Grid _
) As ElementId
Visual C++
public:
static ElementId^ GetMultiSegementGridId(
    Grid^ grid
)

Parameters

grid
Type: Autodesk.Revit.DB..::..Grid
A Grid.

Return Value

The element id of the associated GridChain. If the Grid is not associated to a GridChain, this will return invalidElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MultiSegmentGrid Class


IsValidCurveLoop Method

[image]

Revit 2013 API
MultiSegmentGrid..::..IsValidCurveLoop Method
MultiSegmentGrid Class See Also Send Feedback
Identifies whether the specified curve loop is valid for creation of a MultiSegmentGrid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidCurveLoop(
    CurveLoop curveLoop
)
Visual Basic
Public Shared Function IsValidCurveLoop ( _
    curveLoop As CurveLoop _
) As Boolean
Visual C++
public:
static bool IsValidCurveLoop(
    CurveLoop^ curveLoop
)

Parameters

curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The curve loop.

Return Value

True if the curve loop is an open curve loop consisting of lines and arcs, and false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MultiSegmentGrid Class


IsValidSketchPlaneId Method

[image]

Revit 2013 API
MultiSegmentGrid..::..IsValidSketchPlaneId Method
MultiSegmentGrid Class See Also Send Feedback
Identifies whether provided element id corresponds to a SketchPlane that is valid for GridChain creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidSketchPlaneId(
    Document document,
    ElementId elemId
)
Visual Basic
Public Shared Function IsValidSketchPlaneId ( _
    document As Document, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSketchPlaneId(
    Document^ document,
    ElementId^ elemId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elemId
Type: Autodesk.Revit.DB..::..ElementId
Element id.

Return Value

True if elemId is the element id of a horizontal SketchPlane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MultiSegmentGrid Class


MultiSegmentGrid Properties

[image] [image]

Revit 2013 API
MultiSegmentGrid Properties
MultiSegmentGrid Class See Also Send Feedback

The MultiSegmentGrid type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Text | name shared by grids in this MultiSegmentGrid
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MultiSegmentGrid Class


Parameter Property

[image] [image]

Revit 2013 API
MultiSegmentGrid..::..Parameter Property
MultiSegmentGrid Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MultiSegmentGrid Class
MultiSegmentGrid Members


Text Property

[image]

Revit 2013 API
MultiSegmentGrid..::..Text Property
MultiSegmentGrid Class See Also Send Feedback
name shared by grids in this MultiSegmentGrid

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MultiSegmentGrid Class


NumberSystem Class

[image]

Revit 2013 API
NumberSystem Class
Members See Also Send Feedback
An annotation that consists of a series of numeric tags attached to and describing a host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class NumberSystem : Element
Visual Basic
Public Class NumberSystem _
    Inherits Element
Visual C++
public ref class NumberSystem : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..NumberSystem

See Also

NumberSystem Members


NumberSystem Members

[image] [image]

Revit 2013 API
NumberSystem Members
NumberSystem Class Methods Properties See Also Send Feedback

The NumberSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceOffset | The offset to the reference curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberSystem Class


NumberSystem Methods

[image] [image]

Revit 2013 API
NumberSystem Methods
NumberSystem Class See Also Send Feedback

The NumberSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencePick | Gets the reference curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetReferencePick | Sets the reference pick.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumberSystem Class


GetReferencePick Method

[image]

Revit 2013 API
NumberSystem..::..GetReferencePick Method
NumberSystem Class See Also Send Feedback
Gets the reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Reference GetReferencePick()
Visual Basic
Public Function GetReferencePick As Reference
Visual C++
public:
Reference^ GetReferencePick()

Return Value

The pick of reference curve.

See Also

NumberSystem Class


SetReferencePick Method

[image]

Revit 2013 API
NumberSystem..::..SetReferencePick Method
NumberSystem Class See Also Send Feedback
Sets the reference pick.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetReferencePick(
    Reference referencePick
)
Visual Basic
Public Sub SetReferencePick ( _
    referencePick As Reference _
)
Visual C++
public:
void SetReferencePick(
    Reference^ referencePick
)

Parameters

referencePick
Type: Autodesk.Revit.DB..::..Reference
The pick to set.

Remarks

It is suggested to get the new reference via getNumberSystemReference() from the host element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The referencePick is not a valid reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

NumberSystem Class


NumberSystem Properties

[image] [image]

Revit 2013 API
NumberSystem Properties
NumberSystem Class See Also Send Feedback

The NumberSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | JustifyOffset | The offset to the justification curve.
Public property | JustifyOption | The number justify option of number system.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberDisplayRule | The display rule of the number system.
Public property | NumberedElementId | The LinkElementId of the numbered host element.
Public property | NumberOrientation | The number orientation of number system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceOffset | The offset to the reference curve.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

NumberSystem Class


JustifyOffset Property

[image]

Revit 2013 API
NumberSystem..::..JustifyOffset Property
NumberSystem Class See Also Send Feedback
The offset to the justification curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double JustifyOffset { get; set; }
Visual Basic
Public Property JustifyOffset As Double
    Get
    Set
Visual C++
public:
property double JustifyOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for justifyOffset must be no more than 30000 feet in absolute value.

See Also

NumberSystem Class


JustifyOption Property

[image]

Revit 2013 API
NumberSystem..::..JustifyOption Property
NumberSystem Class See Also Send Feedback
The number justify option of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public NumberSystemJustifyOption JustifyOption { get; set; }
Visual Basic
Public Property JustifyOption As NumberSystemJustifyOption
    Get
    Set
Visual C++
public:
property NumberSystemJustifyOption JustifyOption {
    NumberSystemJustifyOption get ();
    void set (NumberSystemJustifyOption value);
}

See Also

NumberSystem Class


NumberDisplayRule Property

[image]

Revit 2013 API
NumberSystem..::..NumberDisplayRule Property
NumberSystem Class See Also Send Feedback
The display rule of the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public NumberSystemDisplayRule NumberDisplayRule { get; set; }
Visual Basic
Public Property NumberDisplayRule As NumberSystemDisplayRule
    Get
    Set
Visual C++
public:
property NumberSystemDisplayRule NumberDisplayRule {
    NumberSystemDisplayRule get ();
    void set (NumberSystemDisplayRule value);
}

See Also

NumberSystem Class


NumberedElementId Property

[image]

Revit 2013 API
NumberSystem..::..NumberedElementId Property
NumberSystem Class See Also Send Feedback
The LinkElementId of the numbered host element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LinkElementId NumberedElementId { get; }
Visual Basic
Public ReadOnly Property NumberedElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ NumberedElementId {
    LinkElementId^ get ();
}

See Also

NumberSystem Class


NumberOrientation Property

[image]

Revit 2013 API
NumberSystem..::..NumberOrientation Property
NumberSystem Class See Also Send Feedback
The number orientation of number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TagOrientation NumberOrientation { get; set; }
Visual Basic
Public Property NumberOrientation As TagOrientation
    Get
    Set
Visual C++
public:
property TagOrientation NumberOrientation {
    TagOrientation get ();
    void set (TagOrientation value);
}

See Also

NumberSystem Class


Parameter Property

[image] [image]

Revit 2013 API
NumberSystem..::..Parameter Property
NumberSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

NumberSystem Class
NumberSystem Members


ReferenceOffset Property

[image]

Revit 2013 API
NumberSystem..::..ReferenceOffset Property
NumberSystem Class See Also Send Feedback
The offset to the reference curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ReferenceOffset { get; set; }
Visual Basic
Public Property ReferenceOffset As Double
    Get
    Set
Visual C++
public:
property double ReferenceOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for referenceOffset must be no more than 30000 feet in absolute value.

See Also

NumberSystem Class


NumberSystemDisplayRule Enumeration

[image]

Revit 2013 API
NumberSystemDisplayRule Enumeration
See Also Send Feedback
The available options for display of numeric values in the number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum NumberSystemDisplayRule
Visual Basic
Public Enumeration NumberSystemDisplayRule
Visual C++
public enum class NumberSystemDisplayRule

Members

Member name | Description
All | The number system will display all the numbers.
Odd | The number system will only display the odd numbers.
Even | The number system will only display the even numbers.
StartAndEnd | The number system will only display the start and end numbers.

See Also


NumberSystemJustifyOption Enumeration

[image]

Revit 2013 API
NumberSystemJustifyOption Enumeration
See Also Send Feedback
The available options for justification of the numbers in a number system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum NumberSystemJustifyOption
Visual Basic
Public Enumeration NumberSystemJustifyOption
Visual C++
public enum class NumberSystemJustifyOption

Members

Member name | Description
Front | The number will locate in front of the annotated object along the annotating direction.
Center | The number will locate in the center of the annotated object along the annotating direction.
Back | The number will locate in back of the annotated object along the annotating direction.

See Also


NurbSpline Class

[image]

Revit 2013 API
NurbSpline Class
Members See Also Send Feedback
A nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class NurbSpline : Curve
Visual Basic
Public Class NurbSpline _
    Inherits Curve
Visual C++
public ref class NurbSpline : public Curve

Remarks

The nurb spline lies in the plane defined by control point, weight,knots,degree.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Curve
Autodesk.Revit.DB..::..NurbSpline

See Also

NurbSpline Members


NurbSpline Members

[image] [image]

Revit 2013 API
NurbSpline Members
NurbSpline Class Methods Properties See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class


NurbSpline Methods

[image] [image]

Revit 2013 API
NurbSpline Methods
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this curve. (Inherited from Curve.)
Public method | ComputeDerivatives | Returns the vectors describing the curve at the specified parameter. (Inherited from Curve.)
Public method | ComputeNormalizedParameter | Computes the normalized curve parameter from the raw parameter. (Inherited from Curve.)
Public method | ComputeRawParameter | Computes the raw parameter from the normalized parameter. (Inherited from Curve.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Distance | Returns the shortest distance from the specified point to this curve. (Inherited from Curve.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the curve. (Inherited from Curve.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)
Public method | MakeBound | Changes the bounds of this curve to the specified values. (Inherited from Curve.)
Public method | MakeUnbound | Makes this curve unbound. (Inherited from Curve.)
Public method | Project | Projects the specified point on this curve. (Inherited from Curve.)
Public method | SetControlPointsAndWeights | Set the control points, weights simultaneously.
Public method | Tessellate | Valid only if the curve is bound. Returns a polyline approximation to the curve. (Inherited from Curve.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NurbSpline Class


Intersect Method

[image] [image]

Revit 2013 API
NurbSpline..::..Intersect Method
NurbSpline Class See Also Send Feedback
Calculates the intersection of this curve with the specified curve.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of this curve with the specified curve. (Inherited from Curve.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of this curve with the specified curve and returns the intersection results. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


IsInside Method

[image] [image]

Revit 2013 API
NurbSpline..::..IsInside Method
NurbSpline Class See Also Send Feedback
Indicates whether the specified parameter value is within this curve's bounds.

Overload List

 | Name | Description
Public method | IsInside(Double) | Indicates whether the specified parameter value is within this curve's bounds. (Inherited from Curve.)
Public method | IsInside(Double, Int32%) | Indicates whether the specified parameter value is within this curve's bounds and outputs the end index. (Inherited from Curve.)

See Also

NurbSpline Class
NurbSpline Members


SetControlPointsAndWeights Method

[image]

Revit 2013 API
NurbSpline..::..SetControlPointsAndWeights Method
NurbSpline Class See Also Send Feedback
Set the control points, weights simultaneously.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetControlPointsAndWeights(
    IList<XYZ> ctrlPoints,
    DoubleArray weights
)
Visual Basic
Public Sub SetControlPointsAndWeights ( _
    ctrlPoints As IList(Of XYZ), _
    weights As DoubleArray _
)
Visual C++
public:
void SetControlPointsAndWeights(
    IList<XYZ^>^ ctrlPoints,
    DoubleArray^ weights
)

Parameters

ctrlPoints
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
weights
Type: Autodesk.Revit.DB..::..DoubleArray

See Also

NurbSpline Class


NurbSpline Properties

[image] [image]

Revit 2013 API
NurbSpline Properties
NurbSpline Class See Also Send Feedback

The NurbSpline type exposes the following members.

Properties

 | Name | Description
Public property | ApproximateLength | The approximate length of the curve. (Inherited from Curve.)
Public property | CtrlPoints | Returns the control points of the nurb spline.
Public property | Degree | Returns the degree of the nurb spline.
Public property | EndParameter | The parameter of the start or the end point of the curve. (Inherited from Curve.)
Public property | EndPoint | The start or the end point of this curve. (Inherited from Curve.)
Public property | EndPointReference | Returns a stable reference to the start point or the end point of the curve. (Inherited from Curve.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsBound | Describes whether the parameter of the curve is restricted to a particular interval. (Inherited from Curve.)
Public property | isClosed | Return/set the nurb spline's isClosed property.
Public property | IsCyclic | The boolean value that indicates whether this curve is cyclic. (Inherited from Curve.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | isRational | Returns whether the nurb spline is rational or not.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Knots | Return/set the knots of the nurb spline.
Public property | Length | The exact length of the curve. (Inherited from Curve.)
Public property | Period | The period of this curve. (Inherited from Curve.)
Public property | Reference | Returns a stable reference to the curve. (Inherited from Curve.)
Public property | Transformed | Applies the specified transformation to this curve and returns the result. (Inherited from Curve.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Weights | Returns the weights of the nurb spline.

See Also

NurbSpline Class


CtrlPoints Property

[image]

Revit 2013 API
NurbSpline..::..CtrlPoints Property
NurbSpline Class See Also Send Feedback
Returns the control points of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> CtrlPoints { get; }
Visual Basic
Public ReadOnly Property CtrlPoints As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ CtrlPoints {
    IList<XYZ^>^ get ();
}

See Also

NurbSpline Class


Degree Property

[image]

Revit 2013 API
NurbSpline..::..Degree Property
NurbSpline Class See Also Send Feedback
Returns the degree of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Degree { get; }
Visual Basic
Public ReadOnly Property Degree As Integer
    Get
Visual C++
public:
property int Degree {
    int get ();
}

See Also

NurbSpline Class


isClosed Property

[image]

Revit 2013 API
NurbSpline..::..isClosed Property
NurbSpline Class See Also Send Feedback
Return/set the nurb spline's isClosed property.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool isClosed { get; set; }
Visual Basic
Public Property isClosed As Boolean
    Get
    Set
Visual C++
public:
property bool isClosed {
    bool get ();
    void set (bool value);
}

See Also

NurbSpline Class


isRational Property

[image]

Revit 2013 API
NurbSpline..::..isRational Property
NurbSpline Class See Also Send Feedback
Returns whether the nurb spline is rational or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool isRational { get; }
Visual Basic
Public ReadOnly Property isRational As Boolean
    Get
Visual C++
public:
property bool isRational {
    bool get ();
}

See Also

NurbSpline Class


Knots Property

[image]

Revit 2013 API
NurbSpline..::..Knots Property
NurbSpline Class See Also Send Feedback
Return/set the knots of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Knots { get; set; }
Visual Basic
Public Property Knots As DoubleArray
    Get
    Set
Visual C++
public:
property DoubleArray^ Knots {
    DoubleArray^ get ();
    void set (DoubleArray^ value);
}

See Also

NurbSpline Class


Weights Property

[image]

Revit 2013 API
NurbSpline..::..Weights Property
NurbSpline Class See Also Send Feedback
Returns the weights of the nurb spline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Weights { get; }
Visual Basic
Public ReadOnly Property Weights As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Weights {
    DoubleArray^ get ();
}

See Also

NurbSpline Class


ObjectFactory Class

[image]

Revit 2013 API
ObjectFactory Class
Members See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ObjectFactory : IDisposable
Visual Basic
Public Class ObjectFactory _
    Implements IDisposable
Visual C++
public ref class ObjectFactory : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ObjectFactory

See Also

ObjectFactory Members


ObjectFactory Members

[image] [image]

Revit 2013 API
ObjectFactory Members
ObjectFactory Class Constructors Methods See Also Send Feedback

The ObjectFactory type exposes the following members.

Constructors

 | Name | Description
Public method | ObjectFactory | For Internal Use Only.

Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | For Internal Use Only.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstance | For Internal Use Only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveInstance | For Internal Use Only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class


ObjectFactory Constructor

[image]

Revit 2013 API
ObjectFactory Constructor
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ObjectFactory()
Visual Basic
Public Sub New
Visual C++
public:
ObjectFactory()

Return Value

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ObjectFactory Class


ObjectFactory Methods

[image] [image]

Revit 2013 API
ObjectFactory Methods
ObjectFactory Class See Also Send Feedback

The ObjectFactory type exposes the following members.

Methods

 | Name | Description
Public method | CreateInstance | For Internal Use Only.
Public method | Dispose | For Internal Use Only.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstance | For Internal Use Only.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveInstance | For Internal Use Only.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ObjectFactory Class


CreateInstance Method

[image]

Revit 2013 API
ObjectFactory..::..CreateInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Object CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic
Public Function CreateInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As Object
Visual C++
public:
Object^ CreateInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::..IntPtr
pData
Type: System..::..IntPtr
tag
Type: System..::..IntPtr

Return Value

See Also

ObjectFactory Class


Dispose Method

[image]

Revit 2013 API
ObjectFactory..::..Dispose Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ObjectFactory Class


GetInstance Method

[image]

Revit 2013 API
ObjectFactory..::..GetInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Object GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)
Visual Basic
Public Function GetInstance ( _
    pRuntimeClass As IntPtr, _
    pData As IntPtr, _
    tag As IntPtr _
) As Object
Visual C++
public:
Object^ GetInstance(
    IntPtr pRuntimeClass,
    IntPtr pData,
    IntPtr tag
)

Parameters

pRuntimeClass
Type: System..::..IntPtr
pData
Type: System..::..IntPtr
tag
Type: System..::..IntPtr

Return Value

See Also

ObjectFactory Class


RemoveInstance Method

[image]

Revit 2013 API
ObjectFactory..::..RemoveInstance Method
ObjectFactory Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveInstance(
    IntPtr tag
)
Visual Basic
Public Sub RemoveInstance ( _
    tag As IntPtr _
)
Visual C++
public:
void RemoveInstance(
    IntPtr tag
)

Parameters

tag
Type: System..::..IntPtr

See Also

ObjectFactory Class


Opening Class

[image]

Revit 2013 API
Opening Class
Members Example See Also Send Feedback
An opening in an Autodesk Revit project or family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Opening : Element
Visual Basic
Public Class Opening _
    Inherits Element
Visual C++
public ref class Opening : public Element

Remarks

The object represents a variety of different types of openings:
  • A rectangular opening in a wall created by two boundary points in a revit project.
  • An opening created by a set of curves applied to a roof, floor, ceiling, beam, brace or column.
  • A vertical shaft opening extending one or more levels.
  • A simple opening created on a wall or ceiling in a family document.
Depending upon the type of opening, some of the properties of this class will not be available.

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object also supports access to a structural analytical model but this feature is only available with Autodesk Revit Structure.

Examples

CopyC#
private void Getinfo_Opening(Opening opening)
{
    string message = "Opening:";

    //get the host element of this opening
    message += "\nThe id of the opening's host element is : " + opening.Host.Id.IntegerValue;

    //get the information whether the opening has a rect boundary
    //If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    //Otherwise we should get the geometry information from BoundaryCurves property
    if (opening.IsRectBoundary)
    {
        message += "\nThe opening has a rectangular boundary.";
        //array contains two XYZ objects: the max and min coords of boundary
        IList<XYZ> boundaryRect = opening.BoundaryRect;

        //get the coordinate value of the min coordinate point
        XYZ point = opening.BoundaryRect[0];
        message += "\nMin coordinate point:(" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";

        //get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect[1];
        message += "\nMax coordinate point: (" + point.X + ", "
                                + point.Y + ", " + point.Z + ")";
    }
    else
    {
        message += "\nThe opening doesn't have a rectangular boundary.";
        // Get curve number
        int curves = opening.BoundaryCurves.Size;
        message += "\nNumber of curves is : " + curves;
        for (int i = 0; i < curves; i++)
        {
            Autodesk.Revit.DB.Curve curve = opening.BoundaryCurves.get_Item(i);
            // Get curve start point
            message += "\nCurve start point: " + XYZToString(curve.get_EndPoint(0));
            // Get curve end point
            message += "; Curve end point: " + XYZToString(curve.get_EndPoint(1));
        }
    }
    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Opening(ByVal opening As Autodesk.Revit.DB.Opening)
    Dim message As String = "Opening:"

    'get the host element of this opening
    message += vbLf & "The id of the opening's host element is : " + opening.Host.Id.IntegerValue

    'get the information whether the opening has a rect boundary
    'If the opening has a rect boundary, we can get the geometry information from BoundaryRect property.
    'Otherwise we should get the geometry information from BoundaryCurves property
    If opening.IsRectBoundary Then
        message += vbLf & "The opening has a rectangular boundary."
        'array contains two XYZ objects: the max and min coords of boundary
        Dim boundaryRect As IList(Of Autodesk.Revit.DB.XYZ) = opening.BoundaryRect

        'get the coordinate value of the min coordinate point
        Dim point As Autodesk.Revit.DB.XYZ = opening.BoundaryRect(0)
        message += vbLf & "Min coordinate point:(" + point.X + ", " + point.Y + ", " + point.Z + ")"

        'get the coordinate value of the Max coordinate point
        point = opening.BoundaryRect(1)
        message += vbLf & "Max coordinate point: (" + point.X + ", " + point.Y + ", " + point.Z + ")"
    Else
        message += vbLf & "The opening doesn't have a rectangular boundary."
        ' Get curve number
        Dim curves As Integer = opening.BoundaryCurves.Size
        message += vbLf & "Number of curves is : " + curves
        Dim i As Integer = 0
        While i < curves
            Dim curve As Autodesk.Revit.DB.Curve = opening.BoundaryCurves.Item(i)
            ' Get curve start point
            message += vbLf & "Curve start point: " + XYZToString(curve.EndPoint(0))
            ' Get curve end point
            message += "; Curve end point: " + XYZToString(curve.EndPoint(1))
            System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
        End While
    End If
    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Opening

See Also

Opening Members


Opening Members

[image] [image]

Revit 2013 API
Opening Members
Opening Class Methods Properties See Also Send Feedback

The Opening type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Opening Class


Opening Methods

[image] [image]

Revit 2013 API
Opening Methods
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Opening Class


Opening Properties

[image] [image]

Revit 2013 API
Opening Properties
Opening Class See Also Send Feedback

The Opening type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundaryCurves | The geometry information for non-rectangular openings in project documents, or for all openings in family documents.
Public property | BoundaryRect | Retrieves the geometry information if the opening boundary is a rect.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Host | Retrieves the host element of this opening.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsRectBoundary | Retrieves the information whether the opening has a rectangular boundary.
Public property | IsTransparentIn3D | Indicates if the opening is transparent in 3D view when loaded into the project.
Public property | IsTransparentInElevation | Indicates if the opening is transparent in elevation view when loaded into the project.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Opening Class


BoundaryCurves Property

[image]

Revit 2013 API
Opening..::..BoundaryCurves Property
Opening Class See Also Send Feedback
The geometry information for non-rectangular openings in project documents, or for all openings in family documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray BoundaryCurves { get; }
Visual Basic
Public ReadOnly Property BoundaryCurves As CurveArray
    Get
Visual C++
public:
property CurveArray^ BoundaryCurves {
    CurveArray^ get ();
}

Remarks

If IsRectBoundary is true, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


BoundaryRect Property

[image]

Revit 2013 API
Opening..::..BoundaryRect Property
Opening Class See Also Send Feedback
Retrieves the geometry information if the opening boundary is a rect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> BoundaryRect { get; }
Visual Basic
Public ReadOnly Property BoundaryRect As IList(Of XYZ)
    Get
Visual C++
public:
property IList<XYZ^>^ BoundaryRect {
    IList<XYZ^>^ get ();
}

Remarks

If IsRectBoundary is false, this value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Opening Class


Host Property

[image]

Revit 2013 API
Opening..::..Host Property
Opening Class See Also Send Feedback
Retrieves the host element of this opening.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Host { get; }
Visual Basic
Public ReadOnly Property Host As Element
    Get
Visual C++
public:
property Element^ Host {
    Element^ get ();
}

See Also

Opening Class


IsRectBoundary Property

[image]

Revit 2013 API
Opening..::..IsRectBoundary Property
Opening Class See Also Send Feedback
Retrieves the information whether the opening has a rectangular boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRectBoundary { get; }
Visual Basic
Public ReadOnly Property IsRectBoundary As Boolean
    Get
Visual C++
public:
property bool IsRectBoundary {
    bool get ();
}

Remarks

If the opening has a rectangular boundary, we can get the geometry information from BoundaryRect property. Otherwise we should get the geometry information from BoundaryCurves property.

See Also

Opening Class


IsTransparentIn3D Property

[image]

Revit 2013 API
Opening..::..IsTransparentIn3D Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in 3D view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsTransparentIn3D { get; set; }
Visual Basic
Public Property IsTransparentIn3D As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransparentIn3D {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class


IsTransparentInElevation Property

[image]

Revit 2013 API
Opening..::..IsTransparentInElevation Property
Opening Class See Also Send Feedback
Indicates if the opening is transparent in elevation view when loaded into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsTransparentInElevation { get; set; }
Visual Basic
Public Property IsTransparentInElevation As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransparentInElevation {
    bool get ();
    void set (bool value);
}

Remarks

This property is only valid in Revit family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when access this property in an opening belonging to a Revit project document.

See Also

Opening Class


Parameter Property

[image] [image]

Revit 2013 API
Opening..::..Parameter Property
Opening Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Opening Class
Opening Members


OpeningWrappingCondition Enumeration

[image]

Revit 2013 API
OpeningWrappingCondition Enumeration
See Also Send Feedback
Used by CompoundStructure to describe which shell layers participate in wrapping at openings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum OpeningWrappingCondition
Visual Basic
Public Enumeration OpeningWrappingCondition
Visual C++
public enum class OpeningWrappingCondition

Members

Member name | Description
None | None of the shell layers participate in wrapping at openings.
Exterior | Only the exterior shell layers participate in wrapping at openings.
Interior | Only the interior shell layers participate in wrapping at openings.
ExteriorAndInterior | Both interior and exterior shell layers participate in wrapping at openings.

See Also


OpenOptions Class

[image]

Revit 2013 API
OpenOptions Class
Members See Also Send Feedback
This class contains options available for opening a document from disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class OpenOptions : IDisposable
Visual Basic
Public Class OpenOptions _
    Implements IDisposable
Visual C++
public ref class OpenOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..OpenOptions

See Also

OpenOptions Members


OpenOptions Members

[image] [image]

Revit 2013 API
OpenOptions Members
OpenOptions Class Constructors Methods Properties See Also Send Feedback

The OpenOptions type exposes the following members.

Constructors

 | Name | Description
Public method | OpenOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OpenOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DetachFromCentralOption | Specifies whether or not a workset-enabled document is detached from its central document.

See Also

OpenOptions Class


OpenOptions Constructor

[image]

Revit 2013 API
OpenOptions Constructor
OpenOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public OpenOptions()
Visual Basic
Public Sub New
Visual C++
public:
OpenOptions()

See Also

OpenOptions Class


OpenOptions Methods

[image] [image]

Revit 2013 API
OpenOptions Methods
OpenOptions Class See Also Send Feedback

The OpenOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenOptions Class


Dispose Method

[image]

Revit 2013 API
OpenOptions..::..Dispose Method
OpenOptions Class See Also Send Feedback
Releases all resources used by the OpenOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

OpenOptions Class


OpenOptions Properties

[image] [image]

Revit 2013 API
OpenOptions Properties
OpenOptions Class See Also Send Feedback

The OpenOptions type exposes the following members.

Properties

 | Name | Description
Public property | DetachFromCentralOption | Specifies whether or not a workset-enabled document is detached from its central document.

See Also

OpenOptions Class


DetachFromCentralOption Property

[image]

Revit 2013 API
OpenOptions..::..DetachFromCentralOption Property
OpenOptions Class See Also Send Feedback
Specifies whether or not a workset-enabled document is detached from its central document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DetachFromCentralOption DetachFromCentralOption { get; set; }
Visual Basic
Public Property DetachFromCentralOption As DetachFromCentralOption
    Get
    Set
Visual C++
public:
property DetachFromCentralOption DetachFromCentralOption {
    DetachFromCentralOption get ();
    void set (DetachFromCentralOption value);
}

See Also

OpenOptions Class


OptionalFunctionalityUtils Class

[image]

Revit 2013 API
OptionalFunctionalityUtils Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class OptionalFunctionalityUtils : IDisposable
Visual Basic
Public Class OptionalFunctionalityUtils _
    Implements IDisposable
Visual C++
public ref class OptionalFunctionalityUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..OptionalFunctionalityUtils

See Also

OptionalFunctionalityUtils Members


OptionalFunctionalityUtils Members

[image] [image]

Revit 2013 API
OptionalFunctionalityUtils Members
OptionalFunctionalityUtils Class Methods See Also Send Feedback

The OptionalFunctionalityUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OptionalFunctionalityUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDGNExportAvailable | Check whether the DGN Export functionality is available in the installed Revit.
 | IsDGNImportLinkAvailable | Check whether the DGN Import/Link functionality is available in the installed Revit.
 | IsDWFExportAvailable | Check whether the DWF/DWFx Export functionality is available in the installed Revit.
 | IsDWGExportAvailable | Check whether the DWG Export functionality is available in the installed Revit.
 | IsDWGImportLinkAvailable | Check whether the DWG Import/Link functionality is available in the installed Revit.
 | IsDXFExportAvailable | Check whether the DXF Export functionality is available in the installed Revit.
 | IsFBXExportAvailable | Check whether the FBX Export functionality is available in the installed Revit.
 | IsGraphicsAvailable | Check whether the graphics functionality is available to support display, print, and export functionality.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionalFunctionalityUtils Class


OptionalFunctionalityUtils Methods

[image] [image]

Revit 2013 API
OptionalFunctionalityUtils Methods
OptionalFunctionalityUtils Class See Also Send Feedback

The OptionalFunctionalityUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDGNExportAvailable | Check whether the DGN Export functionality is available in the installed Revit.
 | IsDGNImportLinkAvailable | Check whether the DGN Import/Link functionality is available in the installed Revit.
 | IsDWFExportAvailable | Check whether the DWF/DWFx Export functionality is available in the installed Revit.
 | IsDWGExportAvailable | Check whether the DWG Export functionality is available in the installed Revit.
 | IsDWGImportLinkAvailable | Check whether the DWG Import/Link functionality is available in the installed Revit.
 | IsDXFExportAvailable | Check whether the DXF Export functionality is available in the installed Revit.
 | IsFBXExportAvailable | Check whether the FBX Export functionality is available in the installed Revit.
 | IsGraphicsAvailable | Check whether the graphics functionality is available to support display, print, and export functionality.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OptionalFunctionalityUtils Class


Dispose Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..Dispose Method
OptionalFunctionalityUtils Class See Also Send Feedback
Releases all resources used by the OptionalFunctionalityUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

OptionalFunctionalityUtils Class


IsDGNExportAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDGNExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DGN Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDGNExportAvailable()
Visual Basic
Public Shared Function IsDGNExportAvailable As Boolean
Visual C++
public:
static bool IsDGNExportAvailable()

Return Value

True if the DGN Export functionality is available in the installed Revit.

Remarks

DGN Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsDGNImportLinkAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDGNImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DGN Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDGNImportLinkAvailable()
Visual Basic
Public Shared Function IsDGNImportLinkAvailable As Boolean
Visual C++
public:
static bool IsDGNImportLinkAvailable()

Return Value

True if the DGN Import/Link functionality is available in the installed Revit.

Remarks

DGN Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsDWFExportAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDWFExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DWF/DWFx Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDWFExportAvailable()
Visual Basic
Public Shared Function IsDWFExportAvailable As Boolean
Visual C++
public:
static bool IsDWFExportAvailable()

Return Value

True if the DWF/DWFx Export functionality is available in the installed Revit.

Remarks

DWF/DWFx Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsDWGExportAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDWGExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DWG Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDWGExportAvailable()
Visual Basic
Public Shared Function IsDWGExportAvailable As Boolean
Visual C++
public:
static bool IsDWGExportAvailable()

Return Value

True if the DWG Export functionality is available in the installed Revit.

Remarks

DWG Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsDWGImportLinkAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDWGImportLinkAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DWG Import/Link functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDWGImportLinkAvailable()
Visual Basic
Public Shared Function IsDWGImportLinkAvailable As Boolean
Visual C++
public:
static bool IsDWGImportLinkAvailable()

Return Value

True if the DWG Import/Link functionality is available in the installed Revit.

Remarks

DWG Import/Link is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


IsDXFExportAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsDXFExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the DXF Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsDXFExportAvailable()
Visual Basic
Public Shared Function IsDXFExportAvailable As Boolean
Visual C++
public:
static bool IsDXFExportAvailable()

Return Value

True if the DXF Export functionality is available in the installed Revit.

Remarks

DXF Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsFBXExportAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsFBXExportAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the FBX Export functionality is available in the installed Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsFBXExportAvailable()
Visual Basic
Public Shared Function IsFBXExportAvailable As Boolean
Visual C++
public:
static bool IsFBXExportAvailable()

Return Value

True if the FBX Export functionality is available in the installed Revit.

Remarks

FBX Export requires presence of certain modules that are optional and may not be part of the installed Revit.

See Also

OptionalFunctionalityUtils Class


IsGraphicsAvailable Method

[image]

Revit 2013 API
OptionalFunctionalityUtils..::..IsGraphicsAvailable Method
OptionalFunctionalityUtils Class See Also Send Feedback
Check whether the graphics functionality is available to support display, print, and export functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsGraphicsAvailable()
Visual Basic
Public Shared Function IsGraphicsAvailable As Boolean
Visual C++
public:
static bool IsGraphicsAvailable()

Return Value

True if the Graphics functionality is available in the installed Revit.

Remarks

Graphics functionality is optional functionality that does not have to be part of the Revit installation.

See Also

OptionalFunctionalityUtils Class


Options Class

[image]

Revit 2013 API
Options Class
Members See Also Send Feedback
User preferences for parsing of geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Options : APIObject
Visual Basic
Public Class Options _
    Inherits APIObject
Visual C++
public ref class Options : public APIObject

Remarks

This class determines the output of the Element.Geometry property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Options

See Also

Options Members


Options Members

[image] [image]

Revit 2013 API
Options Members
Options Class Constructors Methods Properties See Also Send Feedback

The Options type exposes the following members.

Constructors

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | The view used for geometry extraction.

See Also

Options Class


Options Constructor

[image] [image]

Revit 2013 API
Options Constructor
Options Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Options()()()() | Creates a default Options object.
Public method | Options(Options) | Copy constructor.

See Also

Options Class
Options Members


Options Constructor

[image]

Revit 2013 API
Options Constructor
Options Class See Also Send Feedback
Creates a default Options object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Options()
Visual Basic
Public Sub New
Visual C++
public:
Options()

Remarks

Defaults to medium detail, no references and no view.

See Also

Options Class
Options Overload


Options Constructor (Options)

[image]

Revit 2013 API
Options Constructor (Options)
Options Class See Also Send Feedback
Copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Options(
    Options pOptions
)
Visual Basic
Public Sub New ( _
    pOptions As Options _
)
Visual C++
public:
Options(
    Options^ pOptions
)

Parameters

pOptions
Type: Autodesk.Revit.DB..::..Options

See Also

Options Class
Options Overload


Options Methods

[image] [image]

Revit 2013 API
Options Methods
Options Class See Also Send Feedback

The Options type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Options Class


Options Properties

[image] [image]

Revit 2013 API
Options Properties
Options Class See Also Send Feedback

The Options type exposes the following members.

Properties

 | Name | Description
Public property | ComputeReferences | Determines whether or not references to geometric objects are computed.
Public property | DetailLevel | The detail level for the geometry extracted with these options.
Public property | IncludeNonVisibleObjects | Whether to extract element geometry objects not set as Visible. The default is false.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | View | The view used for geometry extraction.

See Also

Options Class


ComputeReferences Property

[image]

Revit 2013 API
Options..::..ComputeReferences Property
Options Class See Also Send Feedback
Determines whether or not references to geometric objects are computed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ComputeReferences { get; set; }
Visual Basic
Public Property ComputeReferences As Boolean
    Get
    Set
Visual C++
public:
property bool ComputeReferences {
    bool get ();
    void set (bool value);
}

See Also

Options Class


DetailLevel Property

[image]

Revit 2013 API
Options..::..DetailLevel Property
Options Class See Also Send Feedback
The detail level for the geometry extracted with these options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewDetailLevel DetailLevel { get; set; }
Visual Basic
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
Visual C++
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if View is already set. When View is set the detail level of the view is used.

See Also

Options Class


IncludeNonVisibleObjects Property

[image]

Revit 2013 API
Options..::..IncludeNonVisibleObjects Property
Options Class See Also Send Feedback
Whether to extract element geometry objects not set as Visible. The default is false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IncludeNonVisibleObjects { get; set; }
Visual Basic
Public Property IncludeNonVisibleObjects As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeNonVisibleObjects {
    bool get ();
    void set (bool value);
}

See Also

Options Class


View Property

[image]

Revit 2013 API
Options..::..View Property
Options Class See Also Send Feedback
The view used for geometry extraction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

Remarks

If a view-specific version of an element exists, it will be extracted in the retrieval of geometry. Also, the detail level of the geometry will be taken from the view's detail level.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting this property with a nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if DetailLevel is already set. When DetailLevel is set view-specific geometry can't be extracted.

See Also

Options Class


Outline Class

[image]

Revit 2013 API
Outline Class
Members See Also Send Feedback
Outline is a generic object that provides a bounding box/bounding outline. It supports operations to scale and transform. It also supports intersections and contains operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class Outline : IDisposable
Visual Basic
Public Class Outline _
    Implements IDisposable
Visual C++
public ref class Outline : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Outline

See Also

Outline Members


Outline Members

[image] [image]

Revit 2013 API
Outline Members
Outline Class Constructors Methods Properties See Also Send Feedback

The Outline type exposes the following members.

Constructors

 | Name | Description
Public method | Outline(Outline) | The copy constructor.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose | Releases all resources used by the Outline
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


Outline Constructor

[image] [image]

Revit 2013 API
Outline Constructor
Outline Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Outline(Outline) | The copy constructor.
Public method | Outline(XYZ, XYZ) | Constructor that uses a minimum and maximum XYZ point to initialize the outline.

See Also

Outline Class
Outline Members


Outline Constructor (Outline)

[image]

Revit 2013 API
Outline Constructor (Outline)
Outline Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Outline(
    Outline OtherOutline
)
Visual Basic
Public Sub New ( _
    OtherOutline As Outline _
)
Visual C++
public:
Outline(
    Outline^ OtherOutline
)

Parameters

OtherOutline
Type: Autodesk.Revit.DB..::..Outline
The outline to copy into this one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class
Outline Overload


Outline Constructor (XYZ, XYZ)

[image]

Revit 2013 API
Outline Constructor (XYZ, XYZ)
Outline Class See Also Send Feedback
Constructor that uses a minimum and maximum XYZ point to initialize the outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Outline(
    XYZ minimumPoint,
    XYZ maximumPoint
)
Visual Basic
Public Sub New ( _
    minimumPoint As XYZ, _
    maximumPoint As XYZ _
)
Visual C++
public:
Outline(
    XYZ^ minimumPoint,
    XYZ^ maximumPoint
)

Parameters

minimumPoint
Type: Autodesk.Revit.DB..::..XYZ
The minimum point
maximumPoint
Type: Autodesk.Revit.DB..::..XYZ
The maximum point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class
Outline Overload


Outline Methods

[image] [image]

Revit 2013 API
Outline Methods
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Methods

 | Name | Description
Public method | AddPoint | Adds a point to the bounding box, expanding it if the point is outside the existing boundary.
Public method | Contains | Determine if this Outline contains the specified point to within a tolerance.
Public method | ContainsOtherOutline | Determine if this Outline contains another Outline to within tolerance.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersects | Determine if this Outline intersects the input Outline to within a specified tolerance.
Public method | IsScaleValid | Checks if given scale is valid. Should be greater than zero.
Public method | Scale | Scales the bounding box by given scale.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Outline Class


AddPoint Method

[image]

Revit 2013 API
Outline..::..AddPoint Method
Outline Class See Also Send Feedback
Adds a point to the bounding box, expanding it if the point is outside the existing boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddPoint(
    XYZ point
)
Visual Basic
Public Sub AddPoint ( _
    point As XYZ _
)
Visual C++
public:
void AddPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


Contains Method

[image]

Revit 2013 API
Outline..::..Contains Method
Outline Class See Also Send Feedback
Determine if this Outline contains the specified point to within a tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Contains(
    XYZ point,
    double tolerance
)
Visual Basic
Public Function Contains ( _
    point As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Contains(
    XYZ^ point,
    double tolerance
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to test for containment.
tolerance
Type: System..::..Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given point, or false otherwise.

Remarks

If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


ContainsOtherOutline Method

[image]

Revit 2013 API
Outline..::..ContainsOtherOutline Method
Outline Class See Also Send Feedback
Determine if this Outline contains another Outline to within tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ContainsOtherOutline(
    Outline otherOutline,
    double tolerance
)
Visual Basic
Public Function ContainsOtherOutline ( _
    otherOutline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool ContainsOtherOutline(
    Outline^ otherOutline,
    double tolerance
)

Parameters

otherOutline
Type: Autodesk.Revit.DB..::..Outline
The outline to test for containment.
tolerance
Type: System..::..Double
The tolerance to use when determining whether the point is contained. Defaults to zero.

Return Value

True if this outline contains the given outline, or false otherwise.

Remarks

If the tolerance is positive, the other Outline may extend the tolerance distance outside of this Outline in each coordinate. If the tolerance is negative, the other Outline must lie at least the tolerance distance inside of this Outline in each coordinate to be a match.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


Dispose Method

[image]

Revit 2013 API
Outline..::..Dispose Method
Outline Class See Also Send Feedback
Releases all resources used by the Outline

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Outline Class


Intersects Method

[image]

Revit 2013 API
Outline..::..Intersects Method
Outline Class See Also Send Feedback
Determine if this Outline intersects the input Outline to within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Intersects(
    Outline outline,
    double tolerance
)
Visual Basic
Public Function Intersects ( _
    outline As Outline, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool Intersects(
    Outline^ outline,
    double tolerance
)

Parameters

outline
Type: Autodesk.Revit.DB..::..Outline
The outline to test for intersection with this one.
tolerance
Type: System..::..Double
The tolerance to use when determining intersection. Defaults to zero.

Return Value

True if the given outline intersects this outline.

Remarks

If the tolerance is positive, the outlines may be separated by the tolerance distance in each coordinate. If the tolerance is negative, the outlines must overlap by at least the tolerance distance in each coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Outline Class


IsScaleValid Method

[image]

Revit 2013 API
Outline..::..IsScaleValid Method
Outline Class See Also Send Feedback
Checks if given scale is valid. Should be greater than zero.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsScaleValid(
    double scale
)
Visual Basic
Public Function IsScaleValid ( _
    scale As Double _
) As Boolean
Visual C++
public:
bool IsScaleValid(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale.

Return Value

True if the scale is valid, false otherwise.

See Also

Outline Class


Scale Method

[image]

Revit 2013 API
Outline..::..Scale Method
Outline Class See Also Send Feedback
Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Scale(
    double scale
)
Visual Basic
Public Sub Scale ( _
    scale As Double _
)
Visual C++
public:
void Scale(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value. It should be greater than zero.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The scale is invalid.

See Also

Outline Class


Outline Properties

[image] [image]

Revit 2013 API
Outline Properties
Outline Class See Also Send Feedback

The Outline type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Identifies if the outline represents an empty outline.
Public property | MaximumPoint | The maximum point of the bounding box.
Public property | MinimumPoint | The minimum point of the bounding box.

See Also

Outline Class


IsEmpty Property

[image]

Revit 2013 API
Outline..::..IsEmpty Property
Outline Class See Also Send Feedback
Identifies if the outline represents an empty outline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEmpty { get; }
Visual Basic
Public ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
property bool IsEmpty {
    bool get ();
}

See Also

Outline Class


MaximumPoint Property

[image]

Revit 2013 API
Outline..::..MaximumPoint Property
Outline Class See Also Send Feedback
The maximum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ MaximumPoint { get; set; }
Visual Basic
Public Property MaximumPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ MaximumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Outline Class


MinimumPoint Property

[image]

Revit 2013 API
Outline..::..MinimumPoint Property
Outline Class See Also Send Feedback
The minimum point of the bounding box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ MinimumPoint { get; set; }
Visual Basic
Public Property MinimumPoint As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ MinimumPoint {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Outline Class


PageOrientationType Enumeration

[image]

Revit 2013 API
PageOrientationType Enumeration
See Also Send Feedback
An enumerated type listing all Page Orientation types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PageOrientationType
Visual Basic
Public Enumeration PageOrientationType
Visual C++
public enum class PageOrientationType

Members

Member name | Description
Portrait | The type of Page Orientation is Portrait.
Landscape | The type of Page Orientation is Landscape.

See Also


Panel Class

[image]

Revit 2013 API
Panel Class
Members See Also Send Feedback
This object represents a curtain panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Panel : FamilyInstance
Visual Basic
Public Class Panel _
    Inherits FamilyInstance
Visual C++
public ref class Panel : public FamilyInstance

Remarks

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..FamilyInstance
Autodesk.Revit.DB..::..Panel

See Also

Panel Members


Panel Members

[image] [image]

Revit 2013 API
Panel Members
Panel Class Methods Properties See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Panel Class


Panel Methods

[image] [image]

Revit 2013 API
Panel Methods
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Methods

 | Name | Description
Public method | AddCoping | Adds a coping (cut) to a steel beam. (Inherited from FamilyInstance.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | flipFacing | The orientation of family instance facing will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | FlipFromToRoom | Flips the settings of "From Room" and "To Room" for the door or window instance. (Inherited from FamilyInstance.)
Public method | flipHand | The orientation of family instance hand will be flipped. If it can not be flipped, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopingIds | Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetCopings | Obsolete. Lists the elements currently used as coping cutters for this element. (Inherited from FamilyInstance.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointPlacementReferences | Returns the Point Placement References for the Family Instance. (Inherited from FamilyInstance.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalGeometry | Returns the original geometry of the instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing. (Inherited from FamilyInstance.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRefGridLines | This method is used to get the reference gridlines.
Public method | GetSubComponentIds | Gets the sub component ElementIds of the current family instance. (Inherited from FamilyInstance.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCoping | Removes a coping (cut) from a steel beam. (Inherited from FamilyInstance.)
Public method | rotate | The family instance will be flipped by 180 degrees. If it can not be rotated, return false, otherwise return true. (Inherited from FamilyInstance.)
Public method | SetCopingIds | Specifies the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetCopings | Obsolete. Specify the set of coping cutters on this element. (Inherited from FamilyInstance.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Panel Class


GetRefGridLines Method

[image]

Revit 2013 API
Panel..::..GetRefGridLines Method
Panel Class See Also Send Feedback
This method is used to get the reference gridlines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void GetRefGridLines(
    ref ElementId uGridLineId,
    ref ElementId vGridLineId
)
Visual Basic
Public Sub GetRefGridLines ( _
    ByRef uGridLineId As ElementId, _
    ByRef vGridLineId As ElementId _
)
Visual C++
public:
void GetRefGridLines(
    ElementId^% uGridLineId,
    ElementId^% vGridLineId
)

Parameters

uGridLineId
Type: Autodesk.Revit.DB..::..ElementId%
vGridLineId
Type: Autodesk.Revit.DB..::..ElementId%

See Also

Panel Class


Panel Properties

[image] [image]

Revit 2013 API
Panel Properties
Panel Class See Also Send Feedback

The Panel type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanFlipFacing | Property to test whether the orientation of family instance facing can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipHand | Property to test whether the orientation of family instance hand can be flipped. (Inherited from FamilyInstance.)
Public property | CanFlipWorkPlane | Identifies if the instance can flip its work plane. (Inherited from FamilyInstance.)
Public property | CanRotate | Property to test whether the family instance can be rotated by 180 degrees. (Inherited from FamilyInstance.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ExtensionUtility | Property to check whether the instance can be extended and return the interface for extension operation. (Inherited from FamilyInstance.)
Public property | FacingFlipped | Property to test whether the orientation of family instance facing is flipped. (Inherited from FamilyInstance.)
Public property | FacingOrientation | Property to get the orientation of family instance facing. (Inherited from FamilyInstance.)
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandFlipped | Property to test whether the orientation of family instance hand is flipped. (Inherited from FamilyInstance.)
Public property | HandOrientation | Property to get the orientation of family instance hand. (Inherited from FamilyInstance.)
Public property | Host | If the instance is contained within another element, this property returns the containing element. An instance that is face hosted will return the element containing the face. (Inherited from FamilyInstance.)
Public property | HostFace | Property to get the reference to the host face of family instance. (Inherited from FamilyInstance.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Invisible | Property to test whether the family instance is invisible. (Inherited from FamilyInstance.)
Public property | IsSlantedColumn | Indicates if the family instance is a slanted column. (Inherited from FamilyInstance.)
Public property | IsWorkPlaneFlipped | Identifies if the instance's work plane is flipped. (Inherited from FamilyInstance.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an instance within project. (Inherited from FamilyInstance.)
Public property | Lockable | This property is used to know whether a panel can be locked.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPModel | Retrieves the MEP model for the family instance. (Inherited from FamilyInstance.)
Public property | Mirrored | Property to test whether the family instance is mirrored. (only one axis is flipped); (Inherited from FamilyInstance.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelType | The Panel style of this Panel.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | StructuralMaterialId | Identifies the material that defines the instance's structural analysis properties. (Inherited from FamilyInstance.)
Public property | StructuralMaterialType | This property returns the physical material from which the instance is made. (Inherited from FamilyInstance.)
Public property | StructuralType | Provides the primary structural type of the instance, such as beam or column etc. (Inherited from FamilyInstance.)
Public property | StructuralUsage | Provides the primary structural usage of the instance, such as brace, girder etc. (Inherited from FamilyInstance.)
Public property | SubComponents | Obsolete. Property to get the sub components of current family instance. (Inherited from FamilyInstance.)
Public property | SuperComponent | Property to get the super component of current family instance. (Inherited from FamilyInstance.)
Public property | Symbol | Returns or changes the FamilySymbol object that represents the type of the instance. (Inherited from FamilyInstance.)
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)
Public property | Transform | This property is used to find the transform of a curtain panel within project.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Panel Class


FromRoom Property

[image] [image]

Revit 2013 API
Panel..::..FromRoom Property
Panel Class See Also Send Feedback
The "From Room" set for the door or window.

Overload List

 | Name | Description
Public property | FromRoom | The "From Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | FromRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Lockable Property

[image]

Revit 2013 API
Panel..::..Lockable Property
Panel Class See Also Send Feedback
This property is used to know whether a panel can be locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Lockable { get; }
Visual Basic
Public ReadOnly Property Lockable As Boolean
    Get
Visual C++
public:
property bool Lockable {
    bool get ();
}

Remarks

If the panel can be locked, return true, else false.

See Also

Panel Class


PanelType Property

[image]

Revit 2013 API
Panel..::..PanelType Property
Panel Class See Also Send Feedback
The Panel style of this Panel.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelType PanelType { get; set; }
Visual Basic
Public Property PanelType As PanelType
    Get
    Set
Visual C++
public:
property PanelType^ PanelType {
    PanelType^ get ();
    void set (PanelType^ value);
}

Remarks

The Symbol property can be used to retrieve the kind of the panel. This property can also be used to change the type of a panel by setting it to a different type. All the panel types in the project can be found using the Document.CurtainPanelTypes property.

See Also

Panel Class


Parameter Property

[image] [image]

Revit 2013 API
Panel..::..Parameter Property
Panel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Panel Class
Panel Members


Room Property

[image] [image]

Revit 2013 API
Panel..::..Room Property
Panel Class See Also Send Feedback
The room in which the instance is located.

Overload List

 | Name | Description
Public property | Room | The room in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Room[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Space Property

[image] [image]

Revit 2013 API
Panel..::..Space Property
Panel Class See Also Send Feedback
The space in which the instance is located.

Overload List

 | Name | Description
Public property | Space | The space in which the instance is located (during the last phase of the project). (Inherited from FamilyInstance.)
Public property | Space[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


ToRoom Property

[image] [image]

Revit 2013 API
Panel..::..ToRoom Property
Panel Class See Also Send Feedback
The "To Room" set for the door or window.

Overload List

 | Name | Description
Public property | ToRoom | The "To Room" set for the door or window in the last phase of the project. (Inherited from FamilyInstance.)
Public property | ToRoom[([( Phase])]) | (Inherited from FamilyInstance.)

See Also

Panel Class
Panel Members


Transform Property

[image]

Revit 2013 API
Panel..::..Transform Property
Panel Class See Also Send Feedback
This property is used to find the transform of a curtain panel within project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Transform { get; }
Visual Basic
Public ReadOnly Property Transform As Transform
    Get
Visual C++
public:
property Transform^ Transform {
    Transform^ get ();
}

Remarks

The Transform property returns a Autodesk::Revit::DB::Transform object that can be used to find the transfer matrix of a curtain panel within the project.

See Also

Panel Class


PanelType Class

[image]

Revit 2013 API
PanelType Class
Members See Also Send Feedback
An object that represents a curtain panel type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PanelType : FamilySymbol
Visual Basic
Public Class PanelType _
    Inherits FamilySymbol
Visual C++
public ref class PanelType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB..::..PanelType

See Also

PanelType Members


PanelType Members

[image] [image]

Revit 2013 API
PanelType Members
PanelType Class Methods Properties See Also Send Feedback

The PanelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelType Class


PanelType Methods

[image] [image]

Revit 2013 API
PanelType Methods
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelType Class


PanelType Properties

[image] [image]

Revit 2013 API
PanelType Properties
PanelType Class See Also Send Feedback

The PanelType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelType Class


Parameter Property

[image] [image]

Revit 2013 API
PanelType..::..Parameter Property
PanelType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PanelType Class
PanelType Members


PanelTypeSet Class

[image]

Revit 2013 API
PanelTypeSet Class
Members See Also Send Feedback
A set that contains panel types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PanelTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class PanelTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PanelTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PanelTypeSet

See Also

PanelTypeSet Members


PanelTypeSet Members

[image] [image]

Revit 2013 API
PanelTypeSet Members
PanelTypeSet Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PanelTypeSet | Initializes a new instance of the PanelTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


PanelTypeSet Constructor

[image]

Revit 2013 API
PanelTypeSet Constructor
PanelTypeSet Class See Also Send Feedback
Initializes a new instance of the PanelTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
PanelTypeSet()

See Also

PanelTypeSet Class


PanelTypeSet Methods

[image] [image]

Revit 2013 API
PanelTypeSet Methods
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every panel type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a panel type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified panel type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified panel type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSet Class


Clear Method

[image]

Revit 2013 API
PanelTypeSet..::..Clear Method
PanelTypeSet Class See Also Send Feedback
Removes every panel type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PanelTypeSet Class


Contains Method

[image]

Revit 2013 API
PanelTypeSet..::..Contains Method
PanelTypeSet Class See Also Send Feedback
Tests for the existence of a panel type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PanelType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PanelType
The panel type to be searched for.

Return Value

The Contains method returns True if the panel type is within the set, otherwise False.

See Also

PanelTypeSet Class


Erase Method

[image]

Revit 2013 API
PanelTypeSet..::..Erase Method
PanelTypeSet Class See Also Send Feedback
Removes a specified panel type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PanelType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PanelType _
) As Integer
Visual C++
public:
virtual int Erase(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PanelType
The panel type to be erased.

Return Value

The number of panel types that were erased from the set.

See Also

PanelTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
PanelTypeSet..::..ForwardIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PanelTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
PanelTypeSet..::..GetEnumerator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PanelTypeSet Class


Insert Method

[image]

Revit 2013 API
PanelTypeSet..::..Insert Method
PanelTypeSet Class See Also Send Feedback
Insert the specified panel type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PanelType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PanelType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PanelType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PanelType
The panel type to be inserted into the set.

Return Value

Returns whether the panel type was inserted into the set.

See Also

PanelTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
PanelTypeSet..::..ReverseIterator Method
PanelTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PanelTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PanelTypeSetIterator
Visual C++
public:
virtual PanelTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PanelTypeSet Class


PanelTypeSet Properties

[image] [image]

Revit 2013 API
PanelTypeSet Properties
PanelTypeSet Class See Also Send Feedback

The PanelTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of panel types that are in the set.

See Also

PanelTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
PanelTypeSet..::..IsEmpty Property
PanelTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PanelTypeSet Class


Size Property

[image]

Revit 2013 API
PanelTypeSet..::..Size Property
PanelTypeSet Class See Also Send Feedback
Returns the number of panel types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PanelTypeSet Class


PanelTypeSetIterator Class

[image]

Revit 2013 API
PanelTypeSetIterator Class
Members See Also Send Feedback
An iterator to a panel type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PanelTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PanelTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PanelTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PanelTypeSetIterator

See Also

PanelTypeSetIterator Members


PanelTypeSetIterator Members

[image] [image]

Revit 2013 API
PanelTypeSetIterator Members
PanelTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PanelTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Constructor

[image]

Revit 2013 API
PanelTypeSetIterator Constructor
PanelTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PanelTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Methods

[image] [image]

Revit 2013 API
PanelTypeSetIterator Methods
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
PanelTypeSetIterator..::..MoveNext Method
PanelTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
PanelTypeSetIterator..::..Reset Method
PanelTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PanelTypeSetIterator Class


PanelTypeSetIterator Properties

[image] [image]

Revit 2013 API
PanelTypeSetIterator Properties
PanelTypeSetIterator Class See Also Send Feedback

The PanelTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PanelTypeSetIterator Class


Current Property

[image]

Revit 2013 API
PanelTypeSetIterator..::..Current Property
PanelTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PanelTypeSetIterator Class


PaperPlacementType Enumeration

[image]

Revit 2013 API
PaperPlacementType Enumeration
See Also Send Feedback
An enumerated type listing all Paper Placement types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PaperPlacementType
Visual Basic
Public Enumeration PaperPlacementType
Visual C++
public enum class PaperPlacementType

Members

Member name | Description
Center | The type of Paper Placement is Center.
Margins | The type of Paper Placement is Margins.

See Also


PaperSize Class

[image]

Revit 2013 API
PaperSize Class
Members See Also Send Feedback
An object that represents a Paper Size of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PaperSize : APIObject
Visual Basic
Public Class PaperSize _
    Inherits APIObject
Visual C++
public ref class PaperSize : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSize

See Also

PaperSize Members


PaperSize Members

[image] [image]

Revit 2013 API
PaperSize Members
PaperSize Class Methods Properties See Also Send Feedback

The PaperSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper size name of current project.

See Also

PaperSize Class


PaperSize Methods

[image] [image]

Revit 2013 API
PaperSize Methods
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSize Class


PaperSize Properties

[image] [image]

Revit 2013 API
PaperSize Properties
PaperSize Class See Also Send Feedback

The PaperSize type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper size name of current project.

See Also

PaperSize Class


Name Property

[image]

Revit 2013 API
PaperSize..::..Name Property
PaperSize Class See Also Send Feedback
Retrieve the paper size name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSize Class


PaperSizeSet Class

[image]

Revit 2013 API
PaperSizeSet Class
Members See Also Send Feedback
A set that can contain any number of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PaperSizeSet : APIObject,
    IEnumerable
Visual Basic
Public Class PaperSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSizeSet

See Also

PaperSizeSet Members


PaperSizeSet Members

[image] [image]

Revit 2013 API
PaperSizeSet Members
PaperSizeSet Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSizeSet | Initializes a new instance of the PaperSizeSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


PaperSizeSet Constructor

[image]

Revit 2013 API
PaperSizeSet Constructor
PaperSizeSet Class See Also Send Feedback
Initializes a new instance of the PaperSizeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSizeSet()
Visual Basic
Public Sub New
Visual C++
public:
PaperSizeSet()

See Also

PaperSizeSet Class


PaperSizeSet Methods

[image] [image]

Revit 2013 API
PaperSizeSet Methods
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSet Class


Clear Method

[image]

Revit 2013 API
PaperSizeSet..::..Clear Method
PaperSizeSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSizeSet Class


Contains Method

[image]

Revit 2013 API
PaperSizeSet..::..Contains Method
PaperSizeSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSize item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSizeSet Class


Erase Method

[image]

Revit 2013 API
PaperSizeSet..::..Erase Method
PaperSizeSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSize item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PaperSize _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSizeSet Class


ForwardIterator Method

[image]

Revit 2013 API
PaperSizeSet..::..ForwardIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSizeSet Class


GetEnumerator Method

[image]

Revit 2013 API
PaperSizeSet..::..GetEnumerator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PaperSizeSet Class


Insert Method

[image]

Revit 2013 API
PaperSizeSet..::..Insert Method
PaperSizeSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSize item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PaperSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSize
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PaperSizeSet Class


ReverseIterator Method

[image]

Revit 2013 API
PaperSizeSet..::..ReverseIterator Method
PaperSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PaperSizeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PaperSizeSetIterator
Visual C++
public:
virtual PaperSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSizeSet Class


PaperSizeSet Properties

[image] [image]

Revit 2013 API
PaperSizeSet Properties
PaperSizeSet Class See Also Send Feedback

The PaperSizeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSizeSet Class


IsEmpty Property

[image]

Revit 2013 API
PaperSizeSet..::..IsEmpty Property
PaperSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSizeSet Class


Size Property

[image]

Revit 2013 API
PaperSizeSet..::..Size Property
PaperSizeSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSizeSet Class


PaperSizeSetIterator Class

[image]

Revit 2013 API
PaperSizeSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper size objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PaperSizeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PaperSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSizeSetIterator

See Also

PaperSizeSetIterator Members


PaperSizeSetIterator Members

[image] [image]

Revit 2013 API
PaperSizeSetIterator Members
PaperSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSizeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Constructor

[image]

Revit 2013 API
PaperSizeSetIterator Constructor
PaperSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSizeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PaperSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Methods

[image] [image]

Revit 2013 API
PaperSizeSetIterator Methods
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSizeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
PaperSizeSetIterator..::..MoveNext Method
PaperSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


Reset Method

[image]

Revit 2013 API
PaperSizeSetIterator..::..Reset Method
PaperSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSizeSetIterator Class


PaperSizeSetIterator Properties

[image] [image]

Revit 2013 API
PaperSizeSetIterator Properties
PaperSizeSetIterator Class See Also Send Feedback

The PaperSizeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSizeSetIterator Class


Current Property

[image]

Revit 2013 API
PaperSizeSetIterator..::..Current Property
PaperSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSizeSetIterator Class


PaperSource Class

[image]

Revit 2013 API
PaperSource Class
Members See Also Send Feedback
An object that represents a Paper Source of Print Setup within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PaperSource : APIObject
Visual Basic
Public Class PaperSource _
    Inherits APIObject
Visual C++
public ref class PaperSource : public APIObject

Remarks

This object derived from the APIObject base object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSource

See Also

PaperSource Members


PaperSource Members

[image] [image]

Revit 2013 API
PaperSource Members
PaperSource Class Methods Properties See Also Send Feedback

The PaperSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


PaperSource Methods

[image] [image]

Revit 2013 API
PaperSource Methods
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSource Class


PaperSource Properties

[image] [image]

Revit 2013 API
PaperSource Properties
PaperSource Class See Also Send Feedback

The PaperSource type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Retrieve the paper source name of current project.

See Also

PaperSource Class


Name Property

[image]

Revit 2013 API
PaperSource..::..Name Property
PaperSource Class See Also Send Feedback
Retrieve the paper source name of current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

PaperSource Class


PaperSourceSet Class

[image]

Revit 2013 API
PaperSourceSet Class
Members See Also Send Feedback
A set that can contain any number of paper source objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PaperSourceSet : APIObject,
    IEnumerable
Visual Basic
Public Class PaperSourceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PaperSourceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSourceSet

See Also

PaperSourceSet Members


PaperSourceSet Members

[image] [image]

Revit 2013 API
PaperSourceSet Members
PaperSourceSet Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSet type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSourceSet | Initializes a new instance of the PaperSourceSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class


PaperSourceSet Constructor

[image]

Revit 2013 API
PaperSourceSet Constructor
PaperSourceSet Class See Also Send Feedback
Initializes a new instance of the PaperSourceSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSourceSet()
Visual Basic
Public Sub New
Visual C++
public:
PaperSourceSet()

See Also

PaperSourceSet Class


PaperSourceSet Methods

[image] [image]

Revit 2013 API
PaperSourceSet Methods
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSet Class


Clear Method

[image]

Revit 2013 API
PaperSourceSet..::..Clear Method
PaperSourceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PaperSourceSet Class


Contains Method

[image]

Revit 2013 API
PaperSourceSet..::..Contains Method
PaperSourceSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PaperSource item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PaperSourceSet Class


Erase Method

[image]

Revit 2013 API
PaperSourceSet..::..Erase Method
PaperSourceSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PaperSource item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PaperSource _
) As Integer
Visual C++
public:
virtual int Erase(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PaperSourceSet Class


ForwardIterator Method

[image]

Revit 2013 API
PaperSourceSet..::..ForwardIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PaperSourceSet Class


GetEnumerator Method

[image]

Revit 2013 API
PaperSourceSet..::..GetEnumerator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PaperSourceSet Class


Insert Method

[image]

Revit 2013 API
PaperSourceSet..::..Insert Method
PaperSourceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PaperSource item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PaperSource _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PaperSource^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PaperSource

See Also

PaperSourceSet Class


ReverseIterator Method

[image]

Revit 2013 API
PaperSourceSet..::..ReverseIterator Method
PaperSourceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PaperSourceSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PaperSourceSetIterator
Visual C++
public:
virtual PaperSourceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PaperSourceSet Class


PaperSourceSet Properties

[image] [image]

Revit 2013 API
PaperSourceSet Properties
PaperSourceSet Class See Also Send Feedback

The PaperSourceSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PaperSourceSet Class


IsEmpty Property

[image]

Revit 2013 API
PaperSourceSet..::..IsEmpty Property
PaperSourceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PaperSourceSet Class


Size Property

[image]

Revit 2013 API
PaperSourceSet..::..Size Property
PaperSourceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PaperSourceSet Class


PaperSourceSetIterator Class

[image]

Revit 2013 API
PaperSourceSetIterator Class
Members See Also Send Feedback
An iterator to a set of paper source objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PaperSourceSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PaperSourceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PaperSourceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PaperSourceSetIterator

See Also

PaperSourceSetIterator Members


PaperSourceSetIterator Members

[image] [image]

Revit 2013 API
PaperSourceSetIterator Members
PaperSourceSetIterator Class Constructors Methods Properties See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PaperSourceSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Constructor

[image]

Revit 2013 API
PaperSourceSetIterator Constructor
PaperSourceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSourceSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PaperSourceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Methods

[image] [image]

Revit 2013 API
PaperSourceSetIterator Methods
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaperSourceSetIterator Class


MoveNext Method

[image]

Revit 2013 API
PaperSourceSetIterator..::..MoveNext Method
PaperSourceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Reset Method

[image]

Revit 2013 API
PaperSourceSetIterator..::..Reset Method
PaperSourceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PaperSourceSetIterator Class


PaperSourceSetIterator Properties

[image] [image]

Revit 2013 API
PaperSourceSetIterator Properties
PaperSourceSetIterator Class See Also Send Feedback

The PaperSourceSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PaperSourceSetIterator Class


Current Property

[image]

Revit 2013 API
PaperSourceSetIterator..::..Current Property
PaperSourceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PaperSourceSetIterator Class


Parameter Class

[image]

Revit 2013 API
Parameter Class
Members See Also Send Feedback
The parameter object contains the value data assigned to that parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Parameter : APIObject
Visual Basic
Public Class Parameter _
    Inherits APIObject
Visual C++
public ref class Parameter : public APIObject

Remarks

The piece of data contained within the parameter can be either a Double, Integer, String or ElementId. The parameter object can be retrieved from any Element object using either a built in id, definition object or shared parameter guid. All Elements within Autodesk Revit contain Parameters. These are options that can be accessed in a generic fashion. Revit contains many built in parameter types but users and now developers, via the API, can add their own parameters in the form of shared parameters. The developer should become familiar with the Revit user interface for added and managing parameters and shared parameters before using this API. The user interface components can be found in the following locations: Element Properties dialog, Shared Parameters dialog (available from the File menu), Project Parameters dialog (available from the Settings menu), Family Types dialog (available from the Settings menu when editing a family). There are several relationships between the objects that make up the APIs exposure of parameters. The parameter object contains the data value. Parameter objects can be retrieved from Elements if you know its built-in id, its definition or its shared parameter guid. Each parameter has a definition. New parameters can be added to Elements by adding a ParameterBinding object to the Document object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Parameter

See Also

Parameter Members


Parameter Members

[image] [image]

Revit 2013 API
Parameter Members
Parameter Class Methods Properties See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class


Parameter Methods

[image] [image]

Revit 2013 API
Parameter Methods
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Methods

 | Name | Description
Public method | AsDouble | Provides access to the double precision number within the parameter.
Public method | AsElementId | Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.
Public method | AsInteger | Provides access to the integer number within the parameter.
Public method | AsString | Provides access to the string contents of the parameter.
Public method | AsValueString | Get the parameter value as a string with unit.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.
Public method | SetValueString | Set the parameter value according to the input string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class


AsDouble Method

[image]

Revit 2013 API
Parameter..::..AsDouble Method
Parameter Class See Also Send Feedback
Provides access to the double precision number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AsDouble()
Visual Basic
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value contained in the parameter.

Remarks

The AsDouble method should only be used if the StorageType property returns that the internal contents of the parameter is a double.

See Also

Parameter Class


AsElementId Method

[image]

Revit 2013 API
Parameter..::..AsElementId Method
Parameter Class See Also Send Feedback
Provides access to the Autodesk::Revit::DB::ElementId^ stored within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AsElementId()
Visual Basic
Public Function AsElementId As ElementId
Visual C++
public:
ElementId^ AsElementId()

Return Value

The Autodesk::Revit::DB::ElementId^ contained in the parameter.

Remarks

The AsAutodesk::Revit::DB::ElementId^ method should only be used if the StorageType property returns that the internal contents of the parameter is an ElementId.

See Also

Parameter Class


AsInteger Method

[image]

Revit 2013 API
Parameter..::..AsInteger Method
Parameter Class See Also Send Feedback
Provides access to the integer number within the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int AsInteger()
Visual Basic
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The integer value contained in the parameter.

Remarks

The AsInteger method should only be used if the StorageType property returns that the internal contents of the parameter is an integer.

See Also

Parameter Class


AsString Method

[image]

Revit 2013 API
Parameter..::..AsString Method
Parameter Class See Also Send Feedback
Provides access to the string contents of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string contained in the parameter.

Remarks

The AsString method should only be used if the StorageType property returns that the internal contents of the parameter is a string.

See Also

Parameter Class


AsValueString Method

[image]

Revit 2013 API
Parameter..::..AsValueString Method
Parameter Class Example See Also Send Feedback
Get the parameter value as a string with unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string AsValueString()
Visual Basic
Public Function AsValueString As String
Visual C++
public:
String^ AsValueString()

Return Value

The string that represents the parameter value.

Remarks

The method only applies to parameters of value types. If the parameter is not a value, the method returns nullNothingnullptra null reference (Nothing in Visual Basic).

Examples

CopyC#
String ShowValueParameterInformation(Parameter attribute)
{
    string paramValue = null;
    switch (attribute.StorageType)
    {
        case StorageType.Integer:
            if (ParameterType.YesNo
                                == attribute.Definition.ParameterType)
            {
                paramValue = null;
            }
            else
            {
                paramValue = attribute.AsValueString();
            }
            break;
        case StorageType.Double:
            paramValue = attribute.AsValueString();
            break;
        default:
            paramValue = null;
            break;
    }

    return paramValue;
}
CopyVB.NET
Function ShowValueParameterInformation(ByVal attribute As Parameter) As [String]
    Dim paramValue As String = Nothing
    Select Case attribute.StorageType
        Case StorageType.[Integer]
            If ParameterType.YesNo = attribute.Definition.ParameterType Then
                paramValue = Nothing
            Else
                paramValue = attribute.AsValueString()
            End If
            Exit Select
        Case StorageType.[Double]
            paramValue = attribute.AsValueString()
            Exit Select
        Case Else
            paramValue = Nothing
            Exit Select
    End Select

    Return paramValue
End Function

See Also

Parameter Class


Set Method

[image] [image]

Revit 2013 API
Parameter..::..Set Method
Parameter Class See Also Send Feedback
Sets the parameter to a new value.

Overload List

 | Name | Description
Public method | Set(Double) | Sets the parameter to a new real number value.
Public method | Set(Int32) | Sets the parameter to a new integer value.
Public method | Set(String) | Sets the parameter to a new string of text.
Public method | Set(ElementId) | Sets the parameter to a new element id.

See Also

Parameter Class
Parameter Members


Set Method (Double)

[image]

Revit 2013 API
Parameter..::..Set Method (Double)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new real number value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Set(
    double value
)
Visual Basic
Public Function Set ( _
    value As Double _
) As Boolean
Visual C++
public:
bool Set(
    double value
)

Parameters

value
Type: System..::..Double
The new double value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a Double.

Examples

CopyC#
public bool SetParameter(Parameter parameter, double value)
{
    bool result = false;
    //if the parameter is readonly, you can�t change the value of it
    if (null != parameter && !parameter.IsReadOnly)
    {
        StorageType parameterType = parameter.StorageType;
        if (StorageType.Double != parameterType)
        {
            throw new Exception("The storagetypes of value and parameter are different!");
        }
        //If successful, the result is true
        result = parameter.Set(value);
    }

    return result;
}
CopyVB.NET
Public Function SetParameter(ByVal parameter As Parameter, ByVal value As Double) As Boolean
    Dim result As Boolean = False
    'if the parameter is readonly, you can't change the value of it
    If parameter IsNot Nothing AndAlso Not parameter.IsReadOnly Then
        Dim parameterType As StorageType = parameter.StorageType
        If StorageType.[Double] <> parameterType Then
            Throw New Exception("The storagetypes of value and parameter are different!")
        End If
        'If successful, the result is true
        result = parameter.[Set](value)
    End If

    Return result
End Function

See Also

Parameter Class
Set Overload


Set Method (Int32)

[image]

Revit 2013 API
Parameter..::..Set Method (Int32)
Parameter Class See Also Send Feedback
Sets the parameter to a new integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Set(
    int value
)
Visual Basic
Public Function Set ( _
    value As Integer _
) As Boolean
Visual C++
public:
bool Set(
    int value
)

Parameters

value
Type: System..::..Int32
The new integer value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an integer.

See Also

Parameter Class
Set Overload


Set Method (String)

[image]

Revit 2013 API
Parameter..::..Set Method (String)
Parameter Class Example See Also Send Feedback
Sets the parameter to a new string of text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Set(
    string value
)
Visual Basic
Public Function Set ( _
    value As String _
) As Boolean
Visual C++
public:
bool Set(
    String^ value
)

Parameters

value
Type: System..::..String
The new text value to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as a String.

Examples

CopyC#
void AddInstanceComment(Wall wall)
{
    // Get the comment parameter of the element instance
    Parameter commentPara = wall.get_Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS);
    if (null != commentPara)
    {
        // Add a greeting string to the comment
        commentPara.Set("Hello Everyone.");
    }
}
CopyVB.NET
Sub AddInstanceComment(ByVal wall As Wall)
    ' Get the comment parameter of the element instance
    Dim commentPara As Parameter = wall.Parameter(BuiltInParameter.ALL_MODEL_INSTANCE_COMMENTS)
    If commentPara IsNot Nothing Then
        ' Add a greeting string to the comment
        commentPara.[Set]("Hello Everyone.")
    End If
End Sub

See Also

Parameter Class
Set Overload


Set Method (ElementId)

[image]

Revit 2013 API
Parameter..::..Set Method (ElementId)
Parameter Class See Also Send Feedback
Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Set(
    ElementId value
)
Visual Basic
Public Function Set ( _
    value As ElementId _
) As Boolean
Visual C++
public:
bool Set(
    ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB..::..ElementId
The new element id to which the parameter is to be set.

Return Value

The Set method will return True if the parameter was successfully set to the new value, otherwise false.

Remarks

You should only use this method if the StorageType property reports the type of the parameter as an ElementId.

See Also

Parameter Class
Set Overload


SetValueString Method

[image]

Revit 2013 API
Parameter..::..SetValueString Method
Parameter Class Example See Also Send Feedback
Set the parameter value according to the input string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetValueString(
    string valueString
)
Visual Basic
Public Function SetValueString ( _
    valueString As String _
) As Boolean
Visual C++
public:
bool SetValueString(
    String^ valueString
)

Parameters

valueString
Type: System..::..String
The string that represents the parameter value.

Return Value

Indicates whether the parameter value is successfully set.

Remarks

The method only applies to parameters of value types.

Examples

CopyC#
public bool SetWithValueString(Parameter foundParameter)
{
    bool result = false;
    if (!foundParameter.IsReadOnly)
    {
        //If successful, the result is true
        result = foundParameter.SetValueString("-22\'3\"");
    }
    return result;
}
CopyVB.NET
Public Function SetWithValueString(ByVal foundParameter As Parameter) As Boolean
    Dim result As Boolean = False
    If Not foundParameter.IsReadOnly Then
        'If successful, the result is true
        result = foundParameter.SetValueString("-22'3""")
    End If
    Return result
End Function

See Also

Parameter Class


Parameter Properties

[image] [image]

Revit 2013 API
Parameter Properties
Parameter Class See Also Send Feedback

The Parameter type exposes the following members.

Properties

 | Name | Description
Public property | Definition | Returns the Definition object that describes the data type, name and other details of the parameter.
Public property | DisplayUnitType | Get the display unit type of the parameter object.
Public property | Element | The element to which this parameter belongs.
Public property | GUID | The Guid for a shared parameter.
Public property | HasValue | Identifies if the parameter has an assigned value.
Public property | Id | The id of the parameter.
Public property | IsReadOnly | Get the readonly property of the parameter. (Overrides APIObject..::..IsReadOnly.)
Public property | IsShared | Identifies if the parameter is a shared parameter.
Public property | StorageType | Describes the type that is used internally within the parameter to store its value.

See Also

Parameter Class


Definition Property

[image]

Revit 2013 API
Parameter..::..Definition Property
Parameter Class See Also Send Feedback
Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Definition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As Definition
    Get
Visual C++
public:
property Definition^ Definition {
    Definition^ get ();
}

Remarks

This will always be an InternalDefinition object. If you want the Guid for a shared parameter, use GUID.

See Also

Parameter Class


DisplayUnitType Property

[image]

Revit 2013 API
Parameter..::..DisplayUnitType Property
Parameter Class See Also Send Feedback
Get the display unit type of the parameter object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic
Public ReadOnly Property DisplayUnitType As DisplayUnitType
    Get
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

Return Value

The display unit type of the parameter.

Remarks

The property only applies to parameters of value types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this parameter is not of value type.

See Also

Parameter Class


Element Property

[image]

Revit 2013 API
Parameter..::..Element Property
Parameter Class See Also Send Feedback
The element to which this parameter belongs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

See Also

Parameter Class


GUID Property

[image]

Revit 2013 API
Parameter..::..GUID Property
Parameter Class See Also Send Feedback
The Guid for a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the parameter is not a shared parameter.

See Also

Parameter Class


HasValue Property

[image]

Revit 2013 API
Parameter..::..HasValue Property
Parameter Class See Also Send Feedback
Identifies if the parameter has an assigned value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

See Also

Parameter Class


Id Property

[image]

Revit 2013 API
Parameter..::..Id Property
Parameter Class See Also Send Feedback
The id of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

Parameter Class


IsReadOnly Property

[image]

Revit 2013 API
Parameter..::..IsReadOnly Property
Parameter Class See Also Send Feedback
Get the readonly property of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool IsReadOnly { get; }
Visual Basic
Public Overrides ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
public:
virtual property bool IsReadOnly {
    bool get () override;
}

Remarks

This function can be used to check if the parameter is read-only.

See Also

Parameter Class


IsShared Property

[image]

Revit 2013 API
Parameter..::..IsShared Property
Parameter Class See Also Send Feedback
Identifies if the parameter is a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsShared { get; }
Visual Basic
Public ReadOnly Property IsShared As Boolean
    Get
Visual C++
public:
property bool IsShared {
    bool get ();
}

See Also

Parameter Class


StorageType Property

[image]

Revit 2013 API
Parameter..::..StorageType Property
Parameter Class See Also Send Feedback
Describes the type that is used internally within the parameter to store its value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StorageType StorageType { get; }
Visual Basic
Public ReadOnly Property StorageType As StorageType
    Get
Visual C++
public:
property StorageType StorageType {
    StorageType get ();
}

Remarks

The property will return one of the following possibilities: String, Integer, Double or ElementId. Based on the value of this property the correct access and set methods should be used to retrieve and set the parameter's data value.

See Also

Parameter Class


ParameterFilterElement Class

[image]

Revit 2013 API
ParameterFilterElement Class
Members Example See Also Send Feedback
Admits elements that satisfy two conditions:
  1. The element's category must be one of a certain set of allowed categories.
  2. The element must pass a series of filter rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterElement : FilterElement
Visual Basic
Public Class ParameterFilterElement _
    Inherits FilterElement
Visual C++
public ref class ParameterFilterElement : public FilterElement

Examples

CopyC#
private void CreateViewFilter(Autodesk.Revit.DB.Document doc)
{
    List<ElementId> categories = new List<ElementId>();
    categories.Add(new ElementId(BuiltInCategory.OST_Walls));
    ParameterFilterElement parameterFilterElement = ParameterFilterElement.Create(doc, "Comments = foo", categories);

    FilteredElementCollector parameterCollector = new FilteredElementCollector(doc);
    Parameter parameter = parameterCollector.OfClass(typeof(Wall)).FirstElement().get_Parameter("Comments");

    List<FilterRule> filterRules = new List<FilterRule>();
    filterRules.Add(ParameterFilterRuleFactory.CreateEqualsRule(parameter.Id, "foo", true));
    parameterFilterElement.SetRules(filterRules);
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..ParameterFilterElement

See Also

ParameterFilterElement Members


ParameterFilterElement Members

[image] [image]

Revit 2013 API
ParameterFilterElement Members
ParameterFilterElement Class Methods Properties See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | AllRuleParametersApplicable(IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for the given set of categories.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Creates a new ParameterFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
 | GetRuleParameter | Returns the parameter for a given filter rule.
Public method | GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
Public method | GetRules | Returns the rules of this filter, in the order in which they are applied.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ParameterFilterElement Class


ParameterFilterElement Methods

[image] [image]

Revit 2013 API
ParameterFilterElement Methods
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Methods

 | Name | Description
 | AllCategoriesFilterable | Checks that all of the given categories are filterable.
Public method | AllRuleParametersApplicable(IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for the given set of categories.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearRules | Removes all rules from this filter.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
 | Create(Document, String, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Creates a new ParameterFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCategories | Gets the categories admitted by this filter.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
 | GetRuleParameter | Returns the parameter for a given filter rule.
Public method | GetRuleParameters | Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.
Public method | GetRules | Returns the rules of this filter, in the order in which they are applied.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCategories | Sets the categories admitted by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetRules | Sets the rules, all of which must be satisfied for a given element to pass this filter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterElement Class


AllCategoriesFilterable Method

[image]

Revit 2013 API
ParameterFilterElement..::..AllCategoriesFilterable Method
ParameterFilterElement Class See Also Send Feedback
Checks that all of the given categories are filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool AllCategoriesFilterable(
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function AllCategoriesFilterable ( _
    categories As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AllCategoriesFilterable(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


AllRuleParametersApplicable Method

[image] [image]

Revit 2013 API
ParameterFilterElement..::..AllRuleParametersApplicable Method
ParameterFilterElement Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllRuleParametersApplicable(IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for this filter's categories.
 | AllRuleParametersApplicable(Document, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Checks that the parameters of the given rules are valid for the given set of categories.

See Also

ParameterFilterElement Class
ParameterFilterElement Members


AllRuleParametersApplicable Method (IList(FilterRule))

[image]

Revit 2013 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (IList<(Of <(<'FilterRule>)>)>)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AllRuleParametersApplicable(
    IList<FilterRule> rules
)
Visual Basic
Public Function AllRuleParametersApplicable ( _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
bool AllRuleParametersApplicable(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


AllRuleParametersApplicable Method (Document, ICollection(ElementId), IList(FilterRule))

[image]

Revit 2013 API
ParameterFilterElement..::..AllRuleParametersApplicable Method (Document, ICollection<(Of <(<'ElementId>)>)>, IList<(Of <(<'FilterRule>)>)>)
ParameterFilterElement Class See Also Send Feedback
Checks that the parameters of the given rules are valid for the given set of categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool AllRuleParametersApplicable(
    Document aDocument,
    ICollection<ElementId> categories,
    IList<FilterRule> rules
)
Visual Basic
Public Shared Function AllRuleParametersApplicable ( _
    aDocument As Document, _
    categories As ICollection(Of ElementId), _
    rules As IList(Of FilterRule) _
) As Boolean
Visual C++
public:
static bool AllRuleParametersApplicable(
    Document^ aDocument,
    ICollection<ElementId^>^ categories,
    IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the filter, categories, and parameters involved in this validation.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories against which to check the rule parameters.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
AllRuleParametersApplicable Overload


ClearRules Method

[image]

Revit 2013 API
ParameterFilterElement..::..ClearRules Method
ParameterFilterElement Class See Also Send Feedback
Removes all rules from this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ClearRules()
Visual Basic
Public Sub ClearRules
Visual C++
public:
void ClearRules()

See Also

ParameterFilterElement Class


Create Method

[image] [image]

Revit 2013 API
ParameterFilterElement..::..Create Method
ParameterFilterElement Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String, ICollection<(Of <<'(ElementId>)>>)) | Creates a new ParameterFilterElement in the given document.
Create(Document, String, ICollection<(Of <<'(ElementId>)>>), IList<(Of <<'(FilterRule>)>>)) | Creates a new ParameterFilterElement in the given document.

See Also

ParameterFilterElement Class
ParameterFilterElement Members


Create Method (Document, String, ICollection(ElementId))

[image]

Revit 2013 API
ParameterFilterElement..::..Create Method (Document, String, ICollection<(Of <(<'ElementId>)>)>)
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
name
Type: System..::..String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- The given value for name is already in use as a filter element name. -or- One of the given categories is not filterable
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
Create Overload


Create Method (Document, String, ICollection(ElementId), IList(FilterRule))

[image]

Revit 2013 API
ParameterFilterElement..::..Create Method (Document, String, ICollection<(Of <(<'ElementId>)>)>, IList<(Of <(<'FilterRule>)>)>)
ParameterFilterElement Class See Also Send Feedback
Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ParameterFilterElement Create(
    Document aDocument,
    string name,
    ICollection<ElementId> categories,
    IList<FilterRule> rules
)
Visual Basic
Public Shared Function Create ( _
    aDocument As Document, _
    name As String, _
    categories As ICollection(Of ElementId), _
    rules As IList(Of FilterRule) _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
    Document^ aDocument,
    String^ name,
    ICollection<ElementId^>^ categories,
    IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document in which to create the ParameterFilterElement.
name
Type: System..::..String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories for the new ParameterFilterElement.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>
The rules for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- The given value for name is already in use as a filter element name. -or- One of the given categories is not filterable -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class
Create Overload


GetCategories Method

[image]

Revit 2013 API
ParameterFilterElement..::..GetCategories Method
ParameterFilterElement Class See Also Send Feedback
Gets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetCategories()
Visual Basic
Public Function GetCategories As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetCategories()

See Also

ParameterFilterElement Class


GetRuleParameter Method

[image]

Revit 2013 API
ParameterFilterElement..::..GetRuleParameter Method
ParameterFilterElement Class See Also Send Feedback
Returns the parameter for a given filter rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetRuleParameter(
    FilterRule rule
)
Visual Basic
Public Shared Function GetRuleParameter ( _
    rule As FilterRule _
) As ElementId
Visual C++
public:
static ElementId^ GetRuleParameter(
    FilterRule^ rule
)

Parameters

rule
Type: Autodesk.Revit.DB..::..FilterRule
The rule to query.

Return Value

The identifier of the rule's parameter.

Remarks

If the given rule is a FilterInverseRule, then getRuleParameter will return the parameter of its inner rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given rule is not parameter-based.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


GetRuleParameters Method

[image]

Revit 2013 API
ParameterFilterElement..::..GetRuleParameters Method
ParameterFilterElement Class See Also Send Feedback
Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ElementId> GetRuleParameters()
Visual Basic
Public Function GetRuleParameters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRuleParameters()

Return Value

An array of parameter identifiers.

See Also

ParameterFilterElement Class


GetRules Method

[image]

Revit 2013 API
ParameterFilterElement..::..GetRules Method
ParameterFilterElement Class See Also Send Feedback
Returns the rules of this filter, in the order in which they are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<FilterRule> GetRules()
Visual Basic
Public Function GetRules As IList(Of FilterRule)
Visual C++
public:
IList<FilterRule^>^ GetRules()

See Also

ParameterFilterElement Class


SetCategories Method

[image]

Revit 2013 API
ParameterFilterElement..::..SetCategories Method
ParameterFilterElement Class See Also Send Feedback
Sets the categories admitted by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Sub SetCategories ( _
    categories As ICollection(Of ElementId) _
)
Visual C++
public:
void SetCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

Remarks

Testing that an element's category is a member of this set is, essentially, the first rule of the filter.

Changing the set of categories will clear the element's filter rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given categories is not filterable
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


SetRules Method

[image]

Revit 2013 API
ParameterFilterElement..::..SetRules Method
ParameterFilterElement Class See Also Send Feedback
Sets the rules, all of which must be satisfied for a given element to pass this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetRules(
    IList<FilterRule> rules
)
Visual Basic
Public Sub SetRules ( _
    rules As IList(Of FilterRule) _
)
Visual C++
public:
void SetRules(
    IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic..::..IList<(Of <(<'FilterRule>)>)>

Remarks

The rules are applied in the order given. If an element fails to pass a certain rule, no further testing is done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One of the given rules refers to a parameter that does not apply to this filter's categories. -or- One of the rules in the given array is NULL
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterElement Class


ParameterFilterElement Properties

[image] [image]

Revit 2013 API
ParameterFilterElement Properties
ParameterFilterElement Class See Also Send Feedback

The ParameterFilterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ParameterFilterElement Class


Parameter Property

[image] [image]

Revit 2013 API
ParameterFilterElement..::..Parameter Property
ParameterFilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ParameterFilterElement Class
ParameterFilterElement Members


ParameterFilterRuleFactory Class

[image]

Revit 2013 API
ParameterFilterRuleFactory Class
Members See Also Send Feedback
Contains functions that create appropriate FilterRule objects based on the parameters given.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterRuleFactory : IDisposable
Visual Basic
Public Class ParameterFilterRuleFactory _
    Implements IDisposable
Visual C++
public ref class ParameterFilterRuleFactory : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterFilterRuleFactory

See Also

ParameterFilterRuleFactory Members


ParameterFilterRuleFactory Members

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory Members
ParameterFilterRuleFactory Class Methods See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Methods

 | Name | Description
 | CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
 | CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
 | CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
 | CreateLessRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Public method | Dispose | Releases all resources used by the ParameterFilterRuleFactory
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterRuleFactory Class


ParameterFilterRuleFactory Methods

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory Methods
ParameterFilterRuleFactory Class See Also Send Feedback

The ParameterFilterRuleFactory type exposes the following members.

Methods

 | Name | Description
 | CreateBeginsWithRule | Creates a filter rule that determines whether strings from the document begin with a certain string value.
 | CreateContainsRule | Creates a filter rule that determines whether strings from the document contain a certain string value.
 | CreateEndsWithRule | Creates a filter rule that determines whether strings from the document end with a certain string value.
 | CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
 | CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
 | CreateEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document equal a certain value.
 | CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
 | CreateGreaterOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.
 | CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
 | CreateGreaterRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than a certain value.
 | CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
 | CreateLessOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.
 | CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
 | CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
 | CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
 | CreateLessRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than a certain value.
 | CreateNotBeginsWithRule | Creates a filter rule that determines whether strings from the document do not begin with a certain string value.
 | CreateNotContainsRule | Creates a filter rule that determines whether strings from the document do not contain a certain string value.
 | CreateNotEndsWithRule | Creates a filter rule that determines whether strings from the document do not end with a certain string value.
 | CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
 | CreateNotEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document do not equal a certain value.
 | CreateSharedParameterApplicableRule | Creates a filter rule that tests elements for support of a shared parameter.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterRuleFactory Class


CreateBeginsWithRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateContainsRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateContainsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateEndsWithRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateEqualsRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document equal a certain value.
CreateEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document equal a certain value.
CreateEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document equal a certain value.
CreateEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateEqualsRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateEqualsRule Overload


CreateGreaterOrEqualRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.
CreateGreaterOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values less than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateGreaterOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterOrEqualRule Overload


CreateGreaterRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateGreaterRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are greater than a certain value.
CreateGreaterRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.
CreateGreaterRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are greater than a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateGreaterRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than value but within epsilon are considered equal, not greater.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateGreaterRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateGreaterRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are greater than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateGreaterRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateGreaterRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateGreaterRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateGreaterRule Overload


CreateLessOrEqualRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateLessOrEqualRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.
CreateLessOrEqualRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateLessOrEqualRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values greater than the user-supplied value but within epsilon are considered equal; therefore, such values satisfy the condition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessOrEqualRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessOrEqualRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessOrEqualRule Overload


CreateLessRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateLessRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document are less than a certain value.
CreateLessRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document are less than a certain value.
CreateLessRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document are less than a certain value.
CreateLessRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document are less than a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateLessRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Remarks

Values less than the user-supplied value but within epsilon are considered equal, not less.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateLessRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateLessRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateLessRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateLessRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateLessRule Overload


CreateNotBeginsWithRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotBeginsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not begin with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotBeginsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateNotBeginsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotBeginsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotContainsRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotContainsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not contain a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotContainsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateNotContainsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotContainsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotEndsWithRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEndsWithRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not end with a certain string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEndsWithRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateNotEndsWithRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEndsWithRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value for which values from the document will be searched.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


CreateNotEqualsRule Method

[image] [image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method
ParameterFilterRuleFactory Class See Also Send Feedback

Overload List

Name | Description
CreateNotEqualsRule(ElementId, ElementId) | Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Int32) | Creates a filter rule that determines whether integer values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, Double, Double) | Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.
CreateNotEqualsRule(ElementId, String, Boolean) | Creates a filter rule that determines whether strings from the document do not equal a certain value.

See Also

ParameterFilterRuleFactory Class
ParameterFilterRuleFactory Members


CreateNotEqualsRule Method (ElementId, ElementId)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, ElementId)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether ElementId values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    ElementId value
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As ElementId _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    ElementId^ value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value
Type: Autodesk.Revit.DB..::..ElementId
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, Int32)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, Int32)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether integer values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    int value
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Integer _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    int value
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
An integer-typed parameter used to get values from the document for a given element.
value
Type: System..::..Int32
The user-supplied value against which values from the document will be compared.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, Double, Double)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, Double, Double)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether double-precision values from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    double value,
    double epsilon
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As Double, _
    epsilon As Double _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    double value,
    double epsilon
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
value
Type: System..::..Double
The user-supplied value against which values from the document will be compared.
epsilon
Type: System..::..Double
Defines the tolerance within which two values may be considered equal.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateNotEqualsRule Method (ElementId, String, Boolean)

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateNotEqualsRule Method (ElementId, String, Boolean)
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that determines whether strings from the document do not equal a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateNotEqualsRule(
    ElementId parameter,
    string value,
    bool caseSensitive
)
Visual Basic
Public Shared Function CreateNotEqualsRule ( _
    parameter As ElementId, _
    value As String, _
    caseSensitive As Boolean _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateNotEqualsRule(
    ElementId^ parameter,
    String^ value,
    bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: System..::..String
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: System..::..Boolean
If true, the string comparison will be case-sensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class
CreateNotEqualsRule Overload


CreateSharedParameterApplicableRule Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..CreateSharedParameterApplicableRule Method
ParameterFilterRuleFactory Class See Also Send Feedback
Creates a filter rule that tests elements for support of a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static FilterRule CreateSharedParameterApplicableRule(
    string parameterName
)
Visual Basic
Public Shared Function CreateSharedParameterApplicableRule ( _
    parameterName As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateSharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::..String
The name of the parameter that elements must support to satisfy this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterRuleFactory Class


Dispose Method

[image]

Revit 2013 API
ParameterFilterRuleFactory..::..Dispose Method
ParameterFilterRuleFactory Class See Also Send Feedback
Releases all resources used by the ParameterFilterRuleFactory

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ParameterFilterRuleFactory Class


ParameterFilterUtilities Class

[image]

Revit 2013 API
ParameterFilterUtilities Class
Members See Also Send Feedback
Contains static utility functions for enumerating the categories and parameters that are available for use by ParameterFilterElement objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ParameterFilterUtilities : IDisposable
Visual Basic
Public Class ParameterFilterUtilities _
    Implements IDisposable
Visual C++
public ref class ParameterFilterUtilities : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ParameterFilterUtilities

See Also

ParameterFilterUtilities Members


ParameterFilterUtilities Members

[image] [image]

Revit 2013 API
ParameterFilterUtilities Members
ParameterFilterUtilities Class Methods See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ParameterFilterUtilities
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
 | GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsParameterApplicable | Used to determine whether the element supports the given parameter.
 | RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class


ParameterFilterUtilities Methods

[image] [image]

Revit 2013 API
ParameterFilterUtilities Methods
ParameterFilterUtilities Class See Also Send Feedback

The ParameterFilterUtilities type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllFilterableCategories | Returns the set of categories that may be used in a ParameterFilterElement.
 | GetFilterableParametersInCommon | Returns the filterable parameters common to the given categories.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInapplicableParameters | Returns the parameters that are not among the set of filterable parameters common to the given categories.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsParameterApplicable | Used to determine whether the element supports the given parameter.
 | RemoveUnfilterableCategories | Removes from the given set the categories that are not filterable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterFilterUtilities Class


Dispose Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..Dispose Method
ParameterFilterUtilities Class See Also Send Feedback
Releases all resources used by the ParameterFilterUtilities

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ParameterFilterUtilities Class


GetAllFilterableCategories Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..GetAllFilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the set of categories that may be used in a ParameterFilterElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetAllFilterableCategories()
Visual Basic
Public Shared Function GetAllFilterableCategories As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllFilterableCategories()

Return Value

The set of all filterable categories.

See Also

ParameterFilterUtilities Class


GetFilterableParametersInCommon Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..GetFilterableParametersInCommon Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetFilterableParametersInCommon(
    Document aDoc,
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function GetFilterableParametersInCommon ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetFilterableParametersInCommon(
    Document^ aDoc,
    ICollection<ElementId^>^ categories
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories for which to determine the common parameters.

Return Value

The set of filterable parameters common to the given categories.

Remarks

A filterable category in Revit has a set of filterable parameters. The filterable parameters common to a set of categories is the intersection of all these filterable parameter sets.

This set defines the set of parameters that may be used to define a rule on a ParameterFilterElement with a certain set of categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


GetInapplicableParameters Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..GetInapplicableParameters Method
ParameterFilterUtilities Class See Also Send Feedback
Returns the parameters that are not among the set of filterable parameters common to the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static IList<ElementId> GetInapplicableParameters(
    Document aDoc,
    ICollection<ElementId> categories,
    IList<ElementId> parameters
)
Visual Basic
Public Shared Function GetInapplicableParameters ( _
    aDoc As Document, _
    categories As ICollection(Of ElementId), _
    parameters As IList(Of ElementId) _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetInapplicableParameters(
    Document^ aDoc,
    ICollection<ElementId^>^ categories,
    IList<ElementId^>^ parameters
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document containing the categories and parameters to query.
categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The categories that define the set of possibly filterable parameters.
parameters
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The parameters desired for use in a parameter filter.

Return Value

A list of parameters from the given array that are not valid for use in a parameter filter with the given categories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


IsParameterApplicable Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..IsParameterApplicable Method
ParameterFilterUtilities Class See Also Send Feedback
Used to determine whether the element supports the given parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsParameterApplicable(
    Element element,
    ElementId parameter
)
Visual Basic
Public Shared Function IsParameterApplicable ( _
    element As Element, _
    parameter As ElementId _
) As Boolean
Visual C++
public:
static bool IsParameterApplicable(
    Element^ element,
    ElementId^ parameter
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to query for support of the given parameter.
parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter for which to query support.

Return Value

True if the element supports the given parameter, false otherwise.

Remarks

This operation is supported for external (e.g., shared, project) parameters only.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


RemoveUnfilterableCategories Method

[image]

Revit 2013 API
ParameterFilterUtilities..::..RemoveUnfilterableCategories Method
ParameterFilterUtilities Class See Also Send Feedback
Removes from the given set the categories that are not filterable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> RemoveUnfilterableCategories(
    ICollection<ElementId> categories
)
Visual Basic
Public Shared Function RemoveUnfilterableCategories ( _
    categories As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ RemoveUnfilterableCategories(
    ICollection<ElementId^>^ categories
)

Parameters

categories
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of categories to check.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterFilterUtilities Class


ParameterMap Class

[image]

Revit 2013 API
ParameterMap Class
Members See Also Send Feedback
A map that can contain a mapping of a parameter name (a String) to a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ParameterMap : APIObject,
    IEnumerable
Visual Basic
Public Class ParameterMap _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterMap : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterMap

See Also

ParameterMap Members


ParameterMap Members

[image] [image]

Revit 2013 API
ParameterMap Members
ParameterMap Class Constructors Methods Properties See Also Send Feedback

The ParameterMap type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterMap | Initializes a new instance of the ParameterMap class

Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


ParameterMap Constructor

[image]

Revit 2013 API
ParameterMap Constructor
ParameterMap Class See Also Send Feedback
Initializes a new instance of the ParameterMap class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterMap()
Visual Basic
Public Sub New
Visual C++
public:
ParameterMap()

See Also

ParameterMap Class


ParameterMap Methods

[image] [image]

Revit 2013 API
ParameterMap Methods
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the map, rendering it empty.
Public method | Contains | Tests for the existence of a key within the map.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a object with the specified key from the map.
Public method | ForwardIterator | Retrieve a forward moving iterator to the map.
Public method | GetEnumerator | Retrieve a forward moving iterator to the map.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item with the specified key into the map.
Public method | ReverseIterator | Retrieve a backward moving iterator to the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMap Class


Clear Method

[image]

Revit 2013 API
ParameterMap..::..Clear Method
ParameterMap Class See Also Send Feedback
Removes every item from the map, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterMap Class


Contains Method

[image]

Revit 2013 API
ParameterMap..::..Contains Method
ParameterMap Class See Also Send Feedback
Tests for the existence of a key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    string key
)
Visual Basic
Public Overridable Function Contains ( _
    key As String _
) As Boolean
Visual C++
public:
virtual bool Contains(
    String^ key
)

Parameters

key
Type: System..::..String
The key to be searched for.

Return Value

The Contains method returns True if the key is within the map, otherwise False.

See Also

ParameterMap Class


Erase Method

[image]

Revit 2013 API
ParameterMap..::..Erase Method
ParameterMap Class See Also Send Feedback
Removes a object with the specified key from the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    string key
)
Visual Basic
Public Overridable Function Erase ( _
    key As String _
) As Integer
Visual C++
public:
virtual int Erase(
    String^ key
)

Parameters

key
Type: System..::..String
The key of the item to be erased.

Return Value

The number of items that were erased from the map.

See Also

ParameterMap Class


ForwardIterator Method

[image]

Revit 2013 API
ParameterMap..::..ForwardIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ParameterMapIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the map.

See Also

ParameterMap Class


GetEnumerator Method

[image]

Revit 2013 API
ParameterMap..::..GetEnumerator Method
ParameterMap Class See Also Send Feedback
Retrieve a forward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the map.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ParameterMap Class


Insert Method

[image]

Revit 2013 API
ParameterMap..::..Insert Method
ParameterMap Class See Also Send Feedback
Insert the specified item with the specified key into the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    string key,
    Parameter item
)
Visual Basic
Public Overridable Function Insert ( _
    key As String, _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    String^ key,
    Parameter^ item
)

Parameters

key
Type: System..::..String
The key to be used for inserting the item into the map.
item
Type: Autodesk.Revit.DB..::..Parameter
The item to be inserted into the map.

Return Value

Returns whether the item was inserted into the map.

See Also

ParameterMap Class


ReverseIterator Method

[image]

Revit 2013 API
ParameterMap..::..ReverseIterator Method
ParameterMap Class See Also Send Feedback
Retrieve a backward moving iterator to the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ParameterMapIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ParameterMapIterator
Visual C++
public:
virtual ParameterMapIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the map.

See Also

ParameterMap Class


ParameterMap Properties

[image] [image]

Revit 2013 API
ParameterMap Properties
ParameterMap Class See Also Send Feedback

The ParameterMap type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the map is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified key within the map.
Public property | Size | Returns the number of objects that are in the map.

See Also

ParameterMap Class


IsEmpty Property

[image]

Revit 2013 API
ParameterMap..::..IsEmpty Property
ParameterMap Class See Also Send Feedback
Test to see if the map is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the map is empty then True will be returned, otherwise False.

See Also

ParameterMap Class


Item Property

[image]

Revit 2013 API
ParameterMap..::..Item Property
ParameterMap Class See Also Send Feedback
Gets or sets an item at a specified key within the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Parameter this[
    string key
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    key As String _
) As Parameter
    Get
    Set
Visual C++
public:
virtual property Parameter^ Item[String^ key] {
    Parameter^ get (String^ key);
    void set (String^ key, Parameter^ value);
}

Parameters

key
Type: System..::..String
The key of the item to be set or retrieved.

Return Value

Returns the object at the specified key.

See Also

ParameterMap Class


Size Property

[image]

Revit 2013 API
ParameterMap..::..Size Property
ParameterMap Class See Also Send Feedback
Returns the number of objects that are in the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterMap Class


ParameterMapIterator Class

[image]

Revit 2013 API
ParameterMapIterator Class
Members See Also Send Feedback
An iterator to a map relating a parameter name (the key, a String) to a parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ParameterMapIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ParameterMapIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterMapIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterMapIterator

See Also

ParameterMapIterator Members


ParameterMapIterator Members

[image] [image]

Revit 2013 API
ParameterMapIterator Members
ParameterMapIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterMapIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


ParameterMapIterator Constructor

[image]

Revit 2013 API
ParameterMapIterator Constructor
ParameterMapIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterMapIterator()
Visual Basic
Public Sub New
Visual C++
public:
ParameterMapIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterMapIterator Class


ParameterMapIterator Methods

[image] [image]

Revit 2013 API
ParameterMapIterator Methods
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the map.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterMapIterator Class


MoveNext Method

[image]

Revit 2013 API
ParameterMapIterator..::..MoveNext Method
ParameterMapIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the map.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Reset Method

[image]

Revit 2013 API
ParameterMapIterator..::..Reset Method
ParameterMapIterator Class See Also Send Feedback
Bring the iterator back to the start of the map.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the map in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterMapIterator Class


ParameterMapIterator Properties

[image] [image]

Revit 2013 API
ParameterMapIterator Properties
ParameterMapIterator Class See Also Send Feedback

The ParameterMapIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Key | Retrieves the key that is the current focus of the iterator.

See Also

ParameterMapIterator Class


Current Property

[image]

Revit 2013 API
ParameterMapIterator..::..Current Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


Key Property

[image]

Revit 2013 API
ParameterMapIterator..::..Key Property
ParameterMapIterator Class See Also Send Feedback
Retrieves the key that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string Key { get; }
Visual Basic
Public Overridable ReadOnly Property Key As String
    Get
Visual C++
public:
virtual property String^ Key {
    String^ get ();
}

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid key as per expected behavior of IEnumerator.

See Also

ParameterMapIterator Class


ParameterSet Class

[image]

Revit 2013 API
ParameterSet Class
Members See Also Send Feedback
A set that contains parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ParameterSet : APIObject,
    IEnumerable
Visual Basic
Public Class ParameterSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ParameterSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterSet

See Also

ParameterSet Members


ParameterSet Members

[image] [image]

Revit 2013 API
ParameterSet Members
ParameterSet Class Constructors Methods Properties See Also Send Feedback

The ParameterSet type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterSet | Initializes a new instance of the ParameterSet class

Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class


ParameterSet Constructor

[image]

Revit 2013 API
ParameterSet Constructor
ParameterSet Class See Also Send Feedback
Initializes a new instance of the ParameterSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterSet()
Visual Basic
Public Sub New
Visual C++
public:
ParameterSet()

See Also

ParameterSet Class


ParameterSet Methods

[image] [image]

Revit 2013 API
ParameterSet Methods
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every parameter from the set, rendering it empty.
Public method | Contains | Tests for the existence of a parameter within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified parameter from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified parameter into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSet Class


Clear Method

[image]

Revit 2013 API
ParameterSet..::..Clear Method
ParameterSet Class See Also Send Feedback
Removes every parameter from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ParameterSet Class


Contains Method

[image]

Revit 2013 API
ParameterSet..::..Contains Method
ParameterSet Class See Also Send Feedback
Tests for the existence of a parameter within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Parameter item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Parameter
The parameter to be searched for.

Return Value

The Contains method returns True if the parameter is within the set, otherwise False.

See Also

ParameterSet Class


Erase Method

[image]

Revit 2013 API
ParameterSet..::..Erase Method
ParameterSet Class See Also Send Feedback
Removes a specified parameter from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Parameter item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Parameter _
) As Integer
Visual C++
public:
virtual int Erase(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Parameter
The parameter to be erased.

Return Value

The number of parameters that were erased from the set.

See Also

ParameterSet Class


ForwardIterator Method

[image]

Revit 2013 API
ParameterSet..::..ForwardIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ParameterSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ParameterSet Class


GetEnumerator Method

[image]

Revit 2013 API
ParameterSet..::..GetEnumerator Method
ParameterSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ParameterSet Class


Insert Method

[image]

Revit 2013 API
ParameterSet..::..Insert Method
ParameterSet Class See Also Send Feedback
Insert the specified parameter into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Parameter item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Parameter _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Parameter^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Parameter
The parameter to be inserted into the set.

Return Value

Returns whether the parameter was inserted into the set.

See Also

ParameterSet Class


ReverseIterator Method

[image]

Revit 2013 API
ParameterSet..::..ReverseIterator Method
ParameterSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ParameterSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ParameterSetIterator
Visual C++
public:
virtual ParameterSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ParameterSet Class


ParameterSet Properties

[image] [image]

Revit 2013 API
ParameterSet Properties
ParameterSet Class See Also Send Feedback

The ParameterSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of parameters that are in the set.

See Also

ParameterSet Class


IsEmpty Property

[image]

Revit 2013 API
ParameterSet..::..IsEmpty Property
ParameterSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ParameterSet Class


Size Property

[image]

Revit 2013 API
ParameterSet..::..Size Property
ParameterSet Class See Also Send Feedback
Returns the number of parameters that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ParameterSet Class


ParameterSetIterator Class

[image]

Revit 2013 API
ParameterSetIterator Class
Members See Also Send Feedback
An iterator to a parameter set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ParameterSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ParameterSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ParameterSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ParameterSetIterator

See Also

ParameterSetIterator Members


ParameterSetIterator Members

[image] [image]

Revit 2013 API
ParameterSetIterator Members
ParameterSetIterator Class Constructors Methods Properties See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class


ParameterSetIterator Constructor

[image]

Revit 2013 API
ParameterSetIterator Constructor
ParameterSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ParameterSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ParameterSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ParameterSetIterator Class


ParameterSetIterator Methods

[image] [image]

Revit 2013 API
ParameterSetIterator Methods
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ParameterSetIterator..::..MoveNext Method
ParameterSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


Reset Method

[image]

Revit 2013 API
ParameterSetIterator..::..Reset Method
ParameterSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ParameterSetIterator Class


ParameterSetIterator Properties

[image] [image]

Revit 2013 API
ParameterSetIterator Properties
ParameterSetIterator Class See Also Send Feedback

The ParameterSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ParameterSetIterator Class


Current Property

[image]

Revit 2013 API
ParameterSetIterator..::..Current Property
ParameterSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ParameterSetIterator Class


ParameterType Enumeration

[image]

Revit 2013 API
ParameterType Enumeration
See Also Send Feedback
An enumerated type listing all of the data type interpretation that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ParameterType
Visual Basic
Public Enumeration ParameterType
Visual C++
public enum class ParameterType

Members

Member name | Description
Invalid | The parameter type is invalid. This value should not be used.
Text | The parameter data should be interpreted as a string of text.
Integer | The parameter data should be interpreted as a whole number, positive or negative.
Number | The parameter data should be interpreted as a real number, possibly including decimal points.
Length | The parameter data represents a length.
Area | The parameter data represents an area.
Volume | The parameter data represents a volume.
Angle | The parameter data represents an angle.
URL | A text string that represents a web address.
Material | The value of this property is considered to be a material.
YesNo | A boolean value that will be represented as Yes or No.
Force | The data value will be represented as a force.
LinearForce | The data value will be represented as a linear force.
AreaForce | The data value will be represented as an area force.
Moment | The data value will be represented as a moment.
NumberOfPoles | A parameter value that represents the number of poles, as used in electrical disciplines.
FixtureUnit | A parameter value that represents the fixture units, as used in piping disciplines.
FamilyType | A parameter used to control the type of a family nested within another family.
LoadClassification | A parameter value that represents the load classification units, as used in electrical disciplines.
HVACDensity | The data value will be represented as a HVACDensity.
HVACEnergy | The data value will be represented as a HVACEnergy.
HVACFriction | The data value will be represented as a HVACFriction.
HVACPower | The data value will be represented as a HVACPower.
HVACPowerDensity | The data value will be represented as a HVACPowerDensity.
HVACPressure | The data value will be represented as a HVACPressure.
HVACTemperature | The data value will be represented as a HVACTemperature.
HVACVelocity | The data value will be represented as a HVACVelocity.
HVACAirflow | The data value will be represented as a HVACAirflow.
HVACDuctSize | The data value will be represented as a HVACDuctSize.
HVACCrossSection | The data value will be represented as a HVACCrossSection.
HVACHeatGain | The data value will be represented as a HVACHeatGain.
ElectricalCurrent | The data value will be represented as an ElectricalCurrent.
ElectricalPotential | The data value will be represented as an ElectricalPotential.
ElectricalFrequency | The data value will be represented as an ElectricalFrequency.
ElectricalIlluminance | The data value will be represented as an ElectricalIlluminance.
ElectricalLuminousFlux | The data value will be represented as an ElectricalLuminousFlux.
ElectricalPower | The data value will be represented as an ElectricalPower.
HVACRoughness | The data value will be represented as a HVACRoughness.
ElectricalApparentPower | The data value will be represented as an ElectricalApparentPower.
ElectricalPowerDensity | The data value will be represented as an ElectricalPowerDensity.
PipingDensity | The data value will be represented as a PipingDensity.
PipingFlow | The data value will be represented as a PipingFlow.
PipingFriction | The data value will be represented as a PipingFriction.
PipingPressure | The data value will be represented as a PipingPressure.
PipingTemperature | The data value will be represented as a PipingTemperature.
PipingVelocity | The data value will be represented as a PipingVelocity.
PipingViscosity | The data value will be represented as a PipingViscosity.
PipeSize | The data value will be represented as a PipeSize.
PipingRoughness | The data value will be represented as a PipingRoughness.
Stress | The data value will be represented as a Stress.
UnitWeight | The data value will be represented as a UnitWeight.
ThermalExpansion | The data value will be represented as a ThermalExpansion.
LinearMoment | The data value will be represented as a LinearMoment.
ForcePerLength | The data value will be represented as a ForcePerLength.
ForceLengthPerAngle | The data value will be represented as a ForceLengthPerAngle.
LinearForcePerLength | The data value will be represented as a LinearForcePerLength.
LinearForceLengthPerAngle | The data value will be represented as a LinearForceLengthPerAngle.
AreaForcePerLength | The data value will be represented as an AreaForcePerLength.
PipingVolume | The data value will be represented as a PipingVolume.
HVACViscosity | The data value will be represented as a HVACViscosity.
HVACCoefficientOfHeatTransfer | The data value will be represented as a HVACCoefficientOfHeatTransfer.
HVACAirflowDensity | The data value will be represented as a HVACAirflowDensity.
Slope | The data value will be represented as a Slope.
HVACCoolingLoad | The data value will be represented as a HVACCoolingLoad.
HVACCoolingLoadDividedByArea | The data value will be represented as a HVACCoolingLoadDividedByArea.
HVACCoolingLoadDividedByVolume | The data value will be represented as a HVACCoolingLoadDividedByVolume.
HVACHeatingLoad | The data value will be represented as a HVACHeatingLoad.
HVACHeatingLoadDividedByArea | The data value will be represented as a HVACHeatingLoadDividedByArea.
HVACHeatingLoadDividedByVolume | The data value will be represented as a HVACHeatingLoadDividedByVolume.
HVACAirflowDividedByVolume | The data value will be represented as a HVACAirflowDividedByVolume.
HVACAirflowDividedByCoolingLoad | The data value will be represented as a HVACAirflowDividedByCoolingLoad.
HVACAreaDividedByCoolingLoad | The data value will be represented as a HVACAreaDividedByCoolingLoad.
WireSize | The data value will be represented as a WireSize.
HVACSlope | The data value will be represented as a HVACSlope.
PipingSlope | The data value will be represented as a PipingSlope.
Currency | The data value will be represented as a Currency.
ElectricalEfficacy | The data value will be represented as an ElectricalEfficacy.
ElectricalWattage | The data value will be represented as an ElectricalWattage.
ColorTemperature | The data value will be represented as a ColorTemperature.
ElectricalLuminousIntensity | The data value will be represented as an ElectricalLuminousIntensity.
ElectricalLuminance | The data value will be represented as an ElectricalLuminance.
HVACAreaDividedByHeatingLoad | The data value will be represented as a HVACAreaDividedByHeatingLoad.
HVACFactor | The data value will be represented as a HVACFactor.
ElectricalTemperature | The data value will be represented as a ElectricalTemperature.
ElectricalCableTraySize | The data value will be represented as a ElectricalCableTraySize.
ElectricalConduitSize | The data value will be represented as a ElectricalConduitSize.
ReinforcementVolume | The data value will be represented as a ReinforcementVolume.
ReinforcementLength | The data value will be represented as a ReinforcementLength.
ElectricalDemandFactor | The data value will be represented as a ElectricalDemandFactor.
HVACDuctInsulationThickness | The data value will be represented as a HVACDuctInsulationThickness.
HVACDuctLiningThickness | The data value will be represented as a HVACDuctLiningThickness.
PipeInsulationThickness | The data value will be represented as a PipeInsulationThickness.
HVACThermalResistance | The data value will be represented as a HVACThermalResistance.
HVACThermalMass | The data value will be represented as a HVACThermalMass.
Acceleration | The data value will be represented as an Acceleration.
BarDiameter | The data value will be represented as a BarDiameter.
CrackWidth | The data value will be represented as a CrackWidth.
DisplacementDeflection | The data value will be represented as a DisplacementDeflection.
Energy | The data value will be represented as an Energy.
StructuralFrequency | The data value will be represented as a StructuralFrequency.
Mass | The data value will be represented as a Mass.
MassPerUnitLength | The data value will be represented as a MassPerUnitLength.
MomentOfInertia | The data value will be represented as a MomentOfInertia.
SurfaceArea | The data value will be represented as a SurfaceArea.
Period | The data value will be represented as a Period.
Pulsation | The data value will be represented as a Pulsation.
ReinforcementArea | The data value will be represented as a ReinforcementArea.
ReinforcementAreaPerUnitLength | The data value will be represented as a ReinforcementAreaPerUnitLength.
ReinforcementCover | The data value will be represented as a ReinforcementCover.
ReinforcementSpacing | The data value will be represented as a ReinforcementSpacing.
Rotation | The data value will be represented as a Rotation.
SectionArea | The data value will be represented as a SectionArea.
SectionDimension | The data value will be represented as a SectionDimension.
SectionModulus | The data value will be represented as a SectionModulus.
SectionProperty | The data value will be represented as a SectionProperty.
StructuralVelocity | The data value will be represented as a StructuralVelocity.
WarpingConstant | The data value will be represented as a WarpingConstant.
Weight | The data value will be represented as a Weight.
WeightPerUnitLength | The data value will be represented as a WeightPerUnitLength.
HVACThermalConductivity | The data value will be represented as a HVACThermalConductivity.
HVACSpecificHeat | The data value will be represented as a HVACSpecificHeat.
HVACSpecificHeatOfVaporization | The data value will be represented as a HVACSpecificHeatOfVaporization.
HVACPermeability | The data value will be represented as a HVACPermeability.
ElectricalResistivity | The data value will be represented as a ElectricalResistivity.
MassDensity | The data value will be represented as a MassDensity.
MassPerUnitArea | The data value will be represented as a MassPerUnitArea.

See Also


ParameterValueProvider Class

[image]

Revit 2013 API
ParameterValueProvider Class
Members See Also Send Feedback
Gets the value of a parameter from any element passed to getStringValue, getDoubleValue, getIntegerValue, or getElementIdValue.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ParameterValueProvider : FilterableValueProvider
Visual Basic
Public Class ParameterValueProvider _
    Inherits FilterableValueProvider
Visual C++
public ref class ParameterValueProvider : public FilterableValueProvider

Remarks

For any parameter, only one of isStringValueSupported, isDoubleValueSupported, isIntegerValueSupported, isElementIdValueSupported will return true. No attempt to convert between types is made. For example, calling getStringValue, passing the identifier of a numeric-typed parameter will give an empty string. No exception will be thrown, and ParameterValueProvider will not attempt to convert the numeric value to a string.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterableValueProvider
Autodesk.Revit.DB..::..ParameterValueProvider

See Also

ParameterValueProvider Members


ParameterValueProvider Members

[image] [image]

Revit 2013 API
ParameterValueProvider Members
ParameterValueProvider Class Constructors Methods Properties See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterValueProvider | Constructs an instance of ParameterValueProvider.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class


ParameterValueProvider Constructor

[image]

Revit 2013 API
ParameterValueProvider Constructor
ParameterValueProvider Class See Also Send Feedback
Constructs an instance of ParameterValueProvider.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ParameterValueProvider(
    ElementId parameter
)
Visual Basic
Public Sub New ( _
    parameter As ElementId _
)
Visual C++
public:
ParameterValueProvider(
    ElementId^ parameter
)

Parameters

parameter
Type: Autodesk.Revit.DB..::..ElementId
The parameter used to provide a string, integer, and double-precision, or ElementId value on request for a given element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ParameterValueProvider Class


ParameterValueProvider Methods

[image] [image]

Revit 2013 API
ParameterValueProvider Methods
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterableValueProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets a double-precision numeric value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetElementIdValue | Gets an ElementId value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets an integer value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetStringValue | Gets a string value from the given element. (Inherited from FilterableValueProvider.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDoubleValueSupported | Determines whether the provide can provide a double-precision numeric value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsElementIdValueSupported | Determines whether the provide can provide an ElementId value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsIntegerValueSupported | Determines whether the provide can provide an integer value for the given element. (Inherited from FilterableValueProvider.)
Public method | IsStringValueSupported | Determines whether the provide can provide a string value for the given element. (Inherited from FilterableValueProvider.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterValueProvider Class


ParameterValueProvider Properties

[image] [image]

Revit 2013 API
ParameterValueProvider Properties
ParameterValueProvider Class See Also Send Feedback

The ParameterValueProvider type exposes the following members.

Properties

 | Name | Description
Public property | Parameter | The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

See Also

ParameterValueProvider Class


Parameter Property

[image]

Revit 2013 API
ParameterValueProvider..::..Parameter Property
ParameterValueProvider Class See Also Send Feedback
The parameter used to provide a string, integer, double-precision, or ElementId value on request for a given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId Parameter { get; set; }
Visual Basic
Public Property Parameter As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Parameter {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ParameterValueProvider Class


Part Class

[image]

Revit 2013 API
Part Class
Members See Also Send Feedback
This element represents a part of another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Part : Element
Visual Basic
Public Class Part _
    Inherits Element
Visual C++
public ref class Part : public Element

Remarks

A part is associated with a PartMaker element that creates it.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Part

See Also

Part Members


Part Members

[image] [image]

Revit 2013 API
Part Members
Part Class Methods Properties See Also Send Feedback

The Part type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedParents | Obsolete. Returns ids of divided elements that lead to the creation of this Part.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Excluded | True if the part is excluded, false otherwise
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OriginalDividedElementId | Obsolete. The original (non-Part) element of which this element is a part of.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParentDividedElementId | Obsolete. The parent element id that this Part is created from.
Public property | PartMaker | The PartMaker that created this Part.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Part Class


Part Methods

[image] [image]

Revit 2013 API
Part Methods
Part Class See Also Send Feedback

The Part type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanOffsetFace | Checks if it is possible to offset the given face.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedParents | Obsolete. Returns ids of divided elements that lead to the creation of this Part.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSourceElementIds | Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.
Public method | GetSourceElementOriginalCategoryIds | Gets the category ids of the source elements which were used to form this part.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ResetPartShape | Resets all face offsets applied to part faces.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFaceOffset | Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Part Class


CanOffsetFace Method

[image]

Revit 2013 API
Part..::..CanOffsetFace Method
Part Class See Also Send Feedback
Checks if it is possible to offset the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool CanOffsetFace(
    Face face
)
Visual Basic
Public Function CanOffsetFace ( _
    face As Face _
) As Boolean
Visual C++
public:
bool CanOffsetFace(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
face to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Part Class


GetDividedParents Method

[image]

Revit 2013 API
Part..::..GetDividedParents Method
Part Class See Also Send Feedback
Returns ids of divided elements that lead to the creation of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute]
public ICollection<ElementId> GetDividedParents()
Visual Basic
<ObsoleteAttribute> _
Public Function GetDividedParents As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute]
public:
ICollection<ElementId^>^ GetDividedParents()

Return Value

Ids of divided elements that lead to the creation of this Part.

See Also

Part Class


GetSourceElementIds Method

[image]

Revit 2013 API
Part..::..GetSourceElementIds Method
Part Class See Also Send Feedback
Gets a collection of elements from which this Part is created by the PartMaker. May return more than one source only if there is merge involved somewhere in the history of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<LinkElementId> GetSourceElementIds()
Visual Basic
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
Visual C++
public:
ICollection<LinkElementId^>^ GetSourceElementIds()

Return Value

The collection of elements

Remarks

A source element is one of the elements in the original file that the PartMaker uses to create a Part. For example, a floor or a wall used to create a Part can be called a source element.

See Also

Part Class


GetSourceElementOriginalCategoryIds Method

[image]

Revit 2013 API
Part..::..GetSourceElementOriginalCategoryIds Method
Part Class See Also Send Feedback
Gets the category ids of the source elements which were used to form this part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetSourceElementOriginalCategoryIds()
Visual Basic
Public Function GetSourceElementOriginalCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSourceElementOriginalCategoryIds()

Return Value

The category ids.

See Also

Part Class


ResetPartShape Method

[image]

Revit 2013 API
Part..::..ResetPartShape Method
Part Class See Also Send Feedback
Resets all face offsets applied to part faces.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ResetPartShape()
Visual Basic
Public Sub ResetPartShape
Visual C++
public:
void ResetPartShape()

See Also

Part Class


SetFaceOffset Method

[image]

Revit 2013 API
Part..::..SetFaceOffset Method
Part Class See Also Send Feedback
Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFaceOffset(
    Face face,
    double offset
)
Visual Basic
Public Sub SetFaceOffset ( _
    face As Face, _
    offset As Double _
)
Visual C++
public:
void SetFaceOffset(
    Face^ face,
    double offset
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face to offset.
offset
Type: System..::..Double
The magnitude of the offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | -or- The face to be offset should be planar and satisfy constraints of its parent element
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Part Class


Part Properties

[image] [image]

Revit 2013 API
Part Properties
Part Class See Also Send Feedback

The Part type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Excluded | True if the part is excluded, false otherwise
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OriginalCategoryId | The category Id of the original element corresponding to this Part.
Public property | OriginalDividedElementId | Obsolete. The original (non-Part) element of which this element is a part of.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParentDividedElementId | Obsolete. The parent element id that this Part is created from.
Public property | PartMaker | The PartMaker that created this Part.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Part Class


Excluded Property

[image]

Revit 2013 API
Part..::..Excluded Property
Part Class See Also Send Feedback
True if the part is excluded, false otherwise

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Excluded { get; set; }
Visual Basic
Public Property Excluded As Boolean
    Get
    Set
Visual C++
public:
property bool Excluded {
    bool get ();
    void set (bool value);
}

See Also

Part Class


OriginalCategoryId Property

[image]

Revit 2013 API
Part..::..OriginalCategoryId Property
Part Class See Also Send Feedback
The category Id of the original element corresponding to this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId OriginalCategoryId { get; set; }
Visual Basic
Public Property OriginalCategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ OriginalCategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: dPartOriginalCategoryId is not an available member of the original category ids of the elements which formed this Part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Part Class


OriginalDividedElementId Property

[image]

Revit 2013 API
Part..::..OriginalDividedElementId Property
Part Class See Also Send Feedback
The original (non-Part) element of which this element is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be osolete in the next version. It may now throw an exception in certain cases.")]
public ElementId OriginalDividedElementId { get; }
Visual Basic
<ObsoleteAttribute("This method will be osolete in the next version. It may now throw an exception in certain cases.")> _
Public ReadOnly Property OriginalDividedElementId As ElementId
    Get
Visual C++
[ObsoleteAttribute(L"This method will be osolete in the next version. It may now throw an exception in certain cases.")]
public:
property ElementId^ OriginalDividedElementId {
    ElementId^ get ();
}

See Also

Part Class


Parameter Property

[image] [image]

Revit 2013 API
Part..::..Parameter Property
Part Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Part Class
Part Members


ParentDividedElementId Property

[image]

Revit 2013 API
Part..::..ParentDividedElementId Property
Part Class See Also Send Feedback
The parent element id that this Part is created from.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be osolete in the next version. It may now throw an exception in certain cases.")]
public ElementId ParentDividedElementId { get; }
Visual Basic
<ObsoleteAttribute("This method will be osolete in the next version. It may now throw an exception in certain cases.")> _
Public ReadOnly Property ParentDividedElementId As ElementId
    Get
Visual C++
[ObsoleteAttribute(L"This method will be osolete in the next version. It may now throw an exception in certain cases.")]
public:
property ElementId^ ParentDividedElementId {
    ElementId^ get ();
}

See Also

Part Class


PartMaker Property

[image]

Revit 2013 API
Part..::..PartMaker Property
Part Class See Also Send Feedback
The PartMaker that created this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PartMaker PartMaker { get; }
Visual Basic
Public ReadOnly Property PartMaker As PartMaker
    Get
Visual C++
public:
property PartMaker^ PartMaker {
    PartMaker^ get ();
}

See Also

Part Class


PartEdgeConditionOrientation Enumeration

[image]

Revit 2013 API
PartEdgeConditionOrientation Enumeration
See Also Send Feedback
Relative orientation of the right/lower and left/upper edge condition profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PartEdgeConditionOrientation
Visual Basic
Public Enumeration PartEdgeConditionOrientation
Visual C++
public enum class PartEdgeConditionOrientation

Members

Member name | Description
Complement | Before division gap is applied the left/upper and right/lower profiles coincide and neighboring panels complement each other precisely.
Mirrored | Right/lower profile is obtained by mirroring the left/upper profile with respect to the division line. The division gap is not applied.
MirroredAndRotated | Right/lower profile is obtained first by mirroring the left/upper profile with respect to the division line and then by mirroring the result with respect to the center line of the divided thickness. The division gap is not applied.

Remarks

A family-based profile defines the shape of the left/upper profile and this value defines how a matching right/lower profile is obtained.

See Also


PartMaker Class

[image]

Revit 2013 API
PartMaker Class
Members See Also Send Feedback
This element manages the strategy to make Part elements for one or more original elements. accessors to PartMakerMethod methods ------------------------------------------------ TWEAK_DIVIDED_VOLUME Depending from the use case scenarios, it can be beneficial to unite getAdjacentDPartIds() and getOtherComponentsDPartIds() in a single function. To run them sequentially would be rather inefficient ---------------------------------------------------------------------------------

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PartMaker : Element
Visual Basic
Public Class PartMaker _
    Inherits Element
Visual C++
public ref class PartMaker : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PartMaker

See Also

PartMaker Members


PartMaker Members

[image] [image]

Revit 2013 API
PartMaker Members
PartMaker Class Methods Properties See Also Send Feedback

The PartMaker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedElementIds | Obsolete. Get the divided elements for the PartMaker.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSourceElementIds | Get the source elements for the PartMaker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsElementDivided | Obsolete. Is the element a source for this PartMaker
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSourceElement | Is the element a source for this PartMaker
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetDividedElementIds | Obsolete. Set the divided elements for the PartMaker.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSourceElementIds | Set the source elements for the PartMaker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PartMaker Class


PartMaker Methods

[image] [image]

Revit 2013 API
PartMaker Methods
PartMaker Class See Also Send Feedback

The PartMaker type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedElementIds | Obsolete. Get the divided elements for the PartMaker.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSourceElementIds | Get the source elements for the PartMaker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsElementDivided | Obsolete. Is the element a source for this PartMaker
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSourceElement | Is the element a source for this PartMaker
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetDividedElementIds | Obsolete. Set the divided elements for the PartMaker.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSourceElementIds | Set the source elements for the PartMaker.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PartMaker Class


GetDividedElementIds Method

[image]

Revit 2013 API
PartMaker..::..GetDividedElementIds Method
PartMaker Class See Also Send Feedback
Get the divided elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete from the next release. Use getSourceElementIds instead.")]
public ICollection<ElementId> GetDividedElementIds()
Visual Basic
<ObsoleteAttribute("This method will be obsolete from the next release. Use getSourceElementIds instead.")> _
Public Function GetDividedElementIds As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method will be obsolete from the next release. Use getSourceElementIds instead.")]
public:
ICollection<ElementId^>^ GetDividedElementIds()

Return Value

Elements that are divided.

See Also

PartMaker Class


GetSourceElementIds Method

[image]

Revit 2013 API
PartMaker..::..GetSourceElementIds Method
PartMaker Class See Also Send Feedback
Get the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<LinkElementId> GetSourceElementIds()
Visual Basic
Public Function GetSourceElementIds As ICollection(Of LinkElementId)
Visual C++
public:
ICollection<LinkElementId^>^ GetSourceElementIds()

Return Value

Elements that are the sources for this PartMaker.

See Also

PartMaker Class


IsElementDivided Method

[image]

Revit 2013 API
PartMaker..::..IsElementDivided Method
PartMaker Class See Also Send Feedback
Is the element a source for this PartMaker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete from the next release. Use isSourceElement instead.")]
public bool IsElementDivided(
    ElementId elemId
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete from the next release. Use isSourceElement instead.")> _
Public Function IsElementDivided ( _
    elemId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete from the next release. Use isSourceElement instead.")]
public:
bool IsElementDivided(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

Returns true if elemId is among the source elements of this PartMaker

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class


IsSourceElement Method

[image]

Revit 2013 API
PartMaker..::..IsSourceElement Method
PartMaker Class See Also Send Feedback
Is the element a source for this PartMaker

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSourceElement(
    ElementId elemId
)
Visual Basic
Public Function IsSourceElement ( _
    elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsSourceElement(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

Returns true if elemId is among the source elements of this PartMaker

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class


SetDividedElementIds Method

[image]

Revit 2013 API
PartMaker..::..SetDividedElementIds Method
PartMaker Class See Also Send Feedback
Set the divided elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete from the next release. Use setSourceElementIds instead.")]
public void SetDividedElementIds(
    ICollection<ElementId> dividedElementIds
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete from the next release. Use setSourceElementIds instead.")> _
Public Sub SetDividedElementIds ( _
    dividedElementIds As ICollection(Of ElementId) _
)
Visual C++
[ObsoleteAttribute(L"This method will be obsolete from the next release. Use setSourceElementIds instead.")]
public:
void SetDividedElementIds(
    ICollection<ElementId^>^ dividedElementIds
)

Parameters

dividedElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Elements to be divided.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be a source for this PartMaker Elements should be Parts that have no PartMaker yet
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class


SetSourceElementIds Method

[image]

Revit 2013 API
PartMaker..::..SetSourceElementIds Method
PartMaker Class See Also Send Feedback
Set the source elements for the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSourceElementIds(
    ICollection<ElementId> sourceElementIds
)
Visual Basic
Public Sub SetSourceElementIds ( _
    sourceElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetSourceElementIds(
    ICollection<ElementId^>^ sourceElementIds
)

Parameters

sourceElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Elements to be the sources for this PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be a source for this PartMaker Elements should be Parts that have no PartMaker yet
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMaker Class


PartMaker Properties

[image] [image]

Revit 2013 API
PartMaker Properties
PartMaker Class See Also Send Feedback

The PartMaker type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PartMaker Class


Parameter Property

[image] [image]

Revit 2013 API
PartMaker..::..Parameter Property
PartMaker Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PartMaker Class
PartMaker Members


PartMakerMethodToDivideVolumes Class

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes Class
Members See Also Send Feedback
By-References dividing strategy used by PartMaker element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PartMakerMethodToDivideVolumes : IDisposable
Visual Basic
Public Class PartMakerMethodToDivideVolumes _
    Implements IDisposable
Visual C++
public ref class PartMakerMethodToDivideVolumes : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PartMakerMethodToDivideVolumes

See Also

PartMakerMethodToDivideVolumes Members


PartMakerMethodToDivideVolumes Members

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes Members
PartMakerMethodToDivideVolumes Class Methods Properties See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose | Releases all resources used by the PartMakerMethodToDivideVolumes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.

See Also

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes Methods

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes Methods
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Methods

 | Name | Description
Public method | AddIntersectingReference | Adds intersecting reference with an offset.
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOffsetForIntersectingReference | Gets offset for the intersecting reference.
Public method | GetPlaneOfSketch | Gets the plane of the sketch.
Public method | GetSketchCurves | Populates the array with copies of curves in the sketch.
Public method | GetSplitRefsOffsets | Returns offsets for plane-defining splitters.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.
 | IsValidSketchPlane | Identifies if provided sketch plane is valid.
Public method | RemoveIntersectingReference | Removed intersecting reference.
Public method | SetOffsetForIntersectingReference | Sets offset for the intersecting reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesReference | Identifies if the PartMaker uses the intersecting reference.

See Also

PartMakerMethodToDivideVolumes Class


AddIntersectingReference Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..AddIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Adds intersecting reference with an offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AddIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Visual Basic
Public Function AddIntersectingReference ( _
    intersectingReference As ElementId, _
    offset As Double _
) As Boolean
Visual C++
public:
bool AddIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Id of the new intersecting reference.
offset
Type: System..::..Double
The Offste for the new intersecting reference.

Return Value

True if the PartMaker did not already use this intersecting reference and it was added, false if the PartMaker already used this intersecting reference and this call only updated its offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


AreElementsValidIntersectingReferences Method

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AreElementsValidIntersectingReferences(ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.
 | AreElementsValidIntersectingReferences(Document, ICollection<(Of <<'(ElementId>)>>)) | Identifies if provided members are valid.

See Also

PartMakerMethodToDivideVolumes Class
PartMakerMethodToDivideVolumes Members


AreElementsValidIntersectingReferences Method (ICollection(ElementId))

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method (ICollection<(Of <(<'ElementId>)>)>)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreElementsValidIntersectingReferences(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Function AreElementsValidIntersectingReferences ( _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
bool AreElementsValidIntersectingReferences(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


AreElementsValidIntersectingReferences Method (Document, ICollection(ElementId))

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..AreElementsValidIntersectingReferences Method (Document, ICollection<(Of <(<'ElementId>)>)>)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool AreElementsValidIntersectingReferences(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function AreElementsValidIntersectingReferences ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsValidIntersectingReferences(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
AreElementsValidIntersectingReferences Overload


CanBeDivisionProfile Method

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..CanBeDivisionProfile Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CanBeDivisionProfile(ElementId) | Checks whether a family defines a profile which can be used by this method.
 | CanBeDivisionProfile(ElementId, Document) | Checks whether a family defines a profile which can be used by this method.

See Also

PartMakerMethodToDivideVolumes Class
PartMakerMethodToDivideVolumes Members


CanBeDivisionProfile Method (ElementId)

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..CanBeDivisionProfile Method (ElementId)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanBeDivisionProfile(
    ElementId familyId
)
Visual Basic
Public Function CanBeDivisionProfile ( _
    familyId As ElementId _
) As Boolean
Visual C++
public:
bool CanBeDivisionProfile(
    ElementId^ familyId
)

Parameters

familyId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the family.

Return Value

True if the family defines a profile which can be used by a part maker, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
CanBeDivisionProfile Overload


CanBeDivisionProfile Method (ElementId, Document)

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..CanBeDivisionProfile Method (ElementId, Document)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Checks whether a family defines a profile which can be used by this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool CanBeDivisionProfile(
    ElementId familyId,
    Document familyDocument
)
Visual Basic
Public Shared Function CanBeDivisionProfile ( _
    familyId As ElementId, _
    familyDocument As Document _
) As Boolean
Visual C++
public:
static bool CanBeDivisionProfile(
    ElementId^ familyId,
    Document^ familyDocument
)

Parameters

familyId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the family.
familyDocument
Type: Autodesk.Revit.DB..::..Document
The document containing the family to be tested.

Return Value

True if the family defines a profile which can be used by a part maker, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
CanBeDivisionProfile Overload


Dispose Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..Dispose Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Releases all resources used by the PartMakerMethodToDivideVolumes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PartMakerMethodToDivideVolumes Class


GetOffsetForIntersectingReference Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..GetOffsetForIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Gets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetOffsetForIntersectingReference(
    ElementId intersectingReference
)
Visual Basic
Public Function GetOffsetForIntersectingReference ( _
    intersectingReference As ElementId _
) As Double
Visual C++
public:
double GetOffsetForIntersectingReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference to obtain offset value from.

Return Value

The offset for the intersecting reference

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


GetPlaneOfSketch Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..GetPlaneOfSketch Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Gets the plane of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Plane GetPlaneOfSketch()
Visual Basic
Public Function GetPlaneOfSketch As Plane
Visual C++
public:
Plane^ GetPlaneOfSketch()

Return Value

The plane of the sketch.

See Also

PartMakerMethodToDivideVolumes Class


GetSketchCurves Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..GetSketchCurves Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Populates the array with copies of curves in the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void GetSketchCurves(
    out IList<Curve> curveArray
)
Visual Basic
Public Sub GetSketchCurves ( _
    <OutAttribute> ByRef curveArray As IList(Of Curve) _
)
Visual C++
public:
void GetSketchCurves(
    [OutAttribute] IList<Curve^>^% curveArray
)

Parameters

curveArray
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>%
Curves in the sketch. Tags of the curves are consistent with the curve tags used in part keys.

See Also

PartMakerMethodToDivideVolumes Class


GetSplitRefsOffsets Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..GetSplitRefsOffsets Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Returns offsets for plane-defining splitters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IDictionary<ElementId, double> GetSplitRefsOffsets()
Visual Basic
Public Function GetSplitRefsOffsets As IDictionary(Of ElementId, Double)
Visual C++
public:
IDictionary<ElementId^, double>^ GetSplitRefsOffsets()

See Also

PartMakerMethodToDivideVolumes Class


IsElementValidIntersectingReference Method

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..IsElementValidIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsElementValidIntersectingReference(ElementId) | Identifies if the provided member is valid.
 | IsElementValidIntersectingReference(Document, ElementId) | Identifies if the provided member is valid.

See Also

PartMakerMethodToDivideVolumes Class
PartMakerMethodToDivideVolumes Members


IsElementValidIntersectingReference Method (ElementId)

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..IsElementValidIntersectingReference Method (ElementId)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsElementValidIntersectingReference(
    ElementId elementId
)
Visual Basic
Public Function IsElementValidIntersectingReference ( _
    elementId As ElementId _
) As Boolean
Visual C++
public:
bool IsElementValidIntersectingReference(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for validity for intersecting references.

Return Value

True if the reference is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload


IsElementValidIntersectingReference Method (Document, ElementId)

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..IsElementValidIntersectingReference Method (Document, ElementId)
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if the provided member is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsElementValidIntersectingReference(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function IsElementValidIntersectingReference ( _
    document As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsElementValidIntersectingReference(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for validity for intersecting references.

Return Value

True if the reference is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class
IsElementValidIntersectingReference Overload


IsValidSketchPlane Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..IsValidSketchPlane Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if provided sketch plane is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidSketchPlane(
    Document document,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function IsValidSketchPlane ( _
    document As Document, _
    sketchPlaneId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSketchPlane(
    Document^ document,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane ids to be tested for validity for PartMaker.

Return Value

True if SketchPlane valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


RemoveIntersectingReference Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..RemoveIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Removed intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool RemoveIntersectingReference(
    ElementId intersectingReference
)
Visual Basic
Public Function RemoveIntersectingReference ( _
    intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool RemoveIntersectingReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Id of the intersecting reference to remove.

Return Value

True if the PartMaker used this intersecting reference and this call removed it, false if the PartMaker did not use this intersecting reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


SetOffsetForIntersectingReference Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..SetOffsetForIntersectingReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Sets offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetOffsetForIntersectingReference(
    ElementId intersectingReference,
    double offset
)
Visual Basic
Public Sub SetOffsetForIntersectingReference ( _
    intersectingReference As ElementId, _
    offset As Double _
)
Visual C++
public:
void SetOffsetForIntersectingReference(
    ElementId^ intersectingReference,
    double offset
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference that will be offset.
offset
Type: System..::..Double
The new offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


UsesReference Method

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..UsesReference Method
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool UsesReference(
    ElementId intersectingReference
)
Visual Basic
Public Function UsesReference ( _
    intersectingReference As ElementId _
) As Boolean
Visual C++
public:
bool UsesReference(
    ElementId^ intersectingReference
)

Parameters

intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Intersecting reference to be tested.

Return Value

True if the intersecting reference is used by the PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


PartMakerMethodToDivideVolumes Properties

[image] [image]

Revit 2013 API
PartMakerMethodToDivideVolumes Properties
PartMakerMethodToDivideVolumes Class See Also Send Feedback

The PartMakerMethodToDivideVolumes type exposes the following members.

Properties

 | Name | Description
Public property | DivisionGap | The gap which is created between matching profiles of parts.
Public property | ProfileFlipAcross | True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileFlipAlong | True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.
Public property | ProfileMatch | Determines how two profiles match.
Public property | ProfileOffset | The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.
Public property | ProfileType | The id of the profile family applied to boundaries between parts.

See Also

PartMakerMethodToDivideVolumes Class


DivisionGap Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..DivisionGap Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The gap which is created between matching profiles of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double DivisionGap { get; set; }
Visual Basic
Public Property DivisionGap As Double
    Get
    Set
Visual C++
public:
property double DivisionGap {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for divisionGap must be between 0 and 30000 feet.

See Also

PartMakerMethodToDivideVolumes Class


ProfileFlipAcross Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..ProfileFlipAcross Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
True if the corresponding left/upper parts profile are mirrored with respect to the division line. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ProfileFlipAcross { get; set; }
Visual Basic
Public Property ProfileFlipAcross As Boolean
    Get
    Set
Visual C++
public:
property bool ProfileFlipAcross {
    bool get ();
    void set (bool value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileFlipAlong Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..ProfileFlipAlong Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
True if the corresponding left/upper parts profile are mirrored with respect to the center line of the hosts to be divided. False if the profile of left/upper parts are defined directly by the profile family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ProfileFlipAlong { get; set; }
Visual Basic
Public Property ProfileFlipAlong As Boolean
    Get
    Set
Visual C++
public:
property bool ProfileFlipAlong {
    bool get ();
    void set (bool value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileMatch Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..ProfileMatch Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
Determines how two profiles match.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PartEdgeConditionOrientation ProfileMatch { get; set; }
Visual Basic
Public Property ProfileMatch As PartEdgeConditionOrientation
    Get
    Set
Visual C++
public:
property PartEdgeConditionOrientation ProfileMatch {
    PartEdgeConditionOrientation get ();
    void set (PartEdgeConditionOrientation value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileOffset Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..ProfileOffset Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The offset which is applied to a family-defined profile in the direction away from the division line and toward left/upper part to obtain its profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ProfileOffset { get; set; }
Visual Basic
Public Property ProfileOffset As Double
    Get
    Set
Visual C++
public:
property double ProfileOffset {
    double get ();
    void set (double value);
}

See Also

PartMakerMethodToDivideVolumes Class


ProfileType Property

[image]

Revit 2013 API
PartMakerMethodToDivideVolumes..::..ProfileType Property
PartMakerMethodToDivideVolumes Class See Also Send Feedback
The id of the profile family applied to boundaries between parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ProfileType { get; set; }
Visual Basic
Public Property ProfileType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProfileType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

PartMakerMethodToDivideVolumes Class


PartsVisibility Enumeration

[image]

Revit 2013 API
PartsVisibility Enumeration
See Also Send Feedback
Indicates the visibility of parts for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PartsVisibility
Visual Basic
Public Enumeration PartsVisibility
Visual C++
public enum class PartsVisibility

Members

Member name | Description
Unset | Parts visibility is not set for the view.
ShowPartsOnly | Show only parts for the view.
ShowOriginalOnly | Show original elements, not parts, for the view.
ShowPartsAndOriginal | Show both original elements and parts for the view.

See Also


PartType Enumeration

[image]

Revit 2013 API
PartType Enumeration
See Also Send Feedback
An enumerated type listing all MEP family part types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PartType
Visual Basic
Public Enumeration PartType
Visual C++
public enum class PartType

Members

Member name | Description
Undefined | Undefined part type
Normal | Normal part type
DuctMounted | Duct mounted part type
JunctionBox | JunctionBox part type
AttachesTo | Attaches to part type
BreaksInto | Breaks into part type
Elbow | Elbow part type
Tee | Tee part type
Transition | Transition part type
Cross | Cross part type
Cap | Cap part type
TapPerpendicular | Tap perpendicular part type
TapAdjustable | Tap adjustable part type
Offset | Offset part type
Union | Union part type
PanelBoard | Panel board part type
Transformer | Transformer part type
SwitchBoard | Switch board part type
OtherPanel | Other panel part type
EquipmentSwitch | Equipment switch part type
Switch | Switch part type
ValveBreaksInto | Valve breaks into part type
SpudPerpendicular | Spud perpendicular part type
SpudAdjustable | Spud adjustable part type
Damper | Damper part type
Wye | Wye part type
LateralTee | Lateral tee part type
LateralCross | Lateral cross part type
Pants | Pants part type
MultiPort | Multi port part type
ValveNormal | Valve normal part type
JunctionBoxTee | JunctionBox tee part type
JunctionBoxCross | JunctionBox cross part type
PipeFlange | Pipe flange part type
JunctionBoxElbow | JunctionBox elbow part type
ChannelCableTrayElbow | Channel CableTray Elbow part type
ChannelCableTrayVerticalElbow | Channel CableTray Vertical Elbow part type
ChannelCableTrayCross | Channel CableTray Cross part type
ChannelCableTrayTee | Channel CableTray Tee part type
ChannelCableTrayTransition | Channel CableTray Transition part type
ChannelCableTrayUnion | Channel CableTray Union part type
ChannelCableTrayOffset | Channel CableTray Offset part type
ChannelCableTrayMultiPort | Channel CableTray MultiPort part type
LadderCableTrayElbow | Ladder CableTray Elbow part type
LadderCableTrayVerticalElbow | Ladder CableTray Vertical Elbow part type
LadderCableTrayCross | Ladder CableTray Cross part type
LadderCableTrayTee | Ladder CableTray Tee part type
LadderCableTrayTransition | Ladder CableTray Transition part type
LadderCableTrayUnion | Ladder CableTray Union part type
LadderCableTrayOffset | Ladder CableTray Offset part type
LadderCableTrayMultiPort | Ladder CableTray MultiPort part type
InlineSensor | Inline Sensor part type
Sensor | Sensor part type
PartTypeEndCap | PartType EndCap part type
HandrailBracketHardware | Handrail Bracket Hardware part type
PanelBracketHardware | Panel Bracket Hardware part type
TerminationHardware | Termination Hardware part type
Rails | Rails part type
Handrails | Handrails part type
TopRails | Top Rails part type
PipeMechanicalCoupling | Pipe Mechanical Coupling part type

See Also


PartUtils Class

[image]

Revit 2013 API
PartUtils Class
Members See Also Send Feedback
General Part utility methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PartUtils : IDisposable
Visual Basic
Public Class PartUtils _
    Implements IDisposable
Visual C++
public ref class PartUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PartUtils

See Also

PartUtils Members


PartUtils Members

[image] [image]

Revit 2013 API
PartUtils Members
PartUtils Class Methods See Also Send Feedback

The PartUtils type exposes the following members.

Methods

 | Name | Description
 | AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
 | AreElementsValidForDivide | Obsolete. Identifies if provided members are valid for dividing parts.
 | AreElementsValidIntersectingReferences | Obsolete. Identifies if provided members are valid.
 | ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
 | ArePartsValidForMerge | Identifies whether Part elements may be merged.
 | CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
 | CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
 | CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.
Public method | Dispose | Releases all resources used by the PartUtils
 | DivideParts | Creates divided parts out of parts.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
 | GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
 | GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
 | GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
 | GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
 | GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
 | GetDividedParents | Obsolete. Returns an array of elements that lead to the creation of this Part.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMergedParts | Retrieves the element ids of the source elements of a merged part.
 | GetOffsetForIntersectingReference | Obsolete. Get offset for the intersecting reference.
 | GetPartMakerMethodToDivideVolume | Obtains the object allowing access to the divided volume properties of the PartMaker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
 | HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
 | IsMaxDivisionDepthReached | Obsolete. Identifies if elements have reached their maximum division depth.
 | IsMergedPart | Is the Part the result of a merge.
 | IsPartDerivedFromLink | Is the Part derived from link geometry.
 | IsValidForCreateParts | Identifies if the given element can be used to create parts.
 | IsValidSketchPlane | Obsolete. Identifies if provided sketch plane is valid.
 | PartMakerUsesReference | Obsolete. Identifies if the PartMaker uses the intersecting reference.
 | SetOffsetForIntersectingReference | Obsolete. Set offset for the intersecting reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PartUtils Class


PartUtils Methods

[image] [image]

Revit 2013 API
PartUtils Methods
PartUtils Class See Also Send Feedback

The PartUtils type exposes the following members.

Methods

 | Name | Description
 | AreElementsValidForCreateParts | Identifies if the given elements can be used to create parts.
 | AreElementsValidForDivide | Obsolete. Identifies if provided members are valid for dividing parts.
 | AreElementsValidIntersectingReferences | Obsolete. Identifies if provided members are valid.
 | ArePartsValidForDivide | Identifies if provided members are valid for dividing parts.
 | ArePartsValidForMerge | Identifies whether Part elements may be merged.
 | CreateMergedPart | Create a single merged part which represents the Parts specified by partsToMerge.
 | CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
 | CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.
Public method | Dispose |
 | DivideParts | Creates divided parts out of parts.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindMergeableClusters | Segregates a set of elements into subsets which are valid for merge.
 | GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
 | GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.
 | GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
 | GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element
 | GetChainLengthToOriginal | Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.
 | GetDividedParents | Obsolete. Returns an array of elements that lead to the creation of this Part.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMergedParts | Retrieves the element ids of the source elements of a merged part.
 | GetOffsetForIntersectingReference | Obsolete. Get offset for the intersecting reference.
 | GetPartMakerMethodToDivideVolume | Obtains the object allowing access to the divided volume properties of the PartMaker.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
 | HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.
 | IsMaxDivisionDepthReached | Obsolete. Identifies if elements have reached their maximum division depth.
 | IsMergedPart | Is the Part the result of a merge.
 | IsPartDerivedFromLink | Is the Part derived from link geometry.
 | IsValidForCreateParts | Identifies if the given element can be used to create parts.
 | IsValidSketchPlane | Obsolete. Identifies if provided sketch plane is valid.
 | PartMakerUsesReference | Obsolete. Identifies if the PartMaker uses the intersecting reference.
 | SetOffsetForIntersectingReference | Obsolete. Set offset for the intersecting reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PartUtils Class


AreElementsValidForCreateParts Method

[image]

Revit 2013 API
PartUtils..::..AreElementsValidForCreateParts Method
PartUtils Class See Also Send Feedback
Identifies if the given elements can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool AreElementsValidForCreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Function AreElementsValidForCreateParts ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool AreElementsValidForCreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for creating parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


AreElementsValidForDivide Method

[image]

Revit 2013 API
PartUtils..::..AreElementsValidForDivide Method
PartUtils Class See Also Send Feedback
Identifies if provided members are valid for dividing parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")]
public static bool AreElementsValidForDivide(
    Document document,
    ICollection<ElementId> elementIdsToDivide
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")> _
Public Shared Function AreElementsValidForDivide ( _
    document As Document, _
    elementIdsToDivide As ICollection(Of ElementId) _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version. Use ArePartsValidForDivide instead.")]
public:
static bool AreElementsValidForDivide(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIdsToDivide
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for dividing parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


AreElementsValidIntersectingReferences Method

[image]

Revit 2013 API
PartUtils..::..AreElementsValidIntersectingReferences Method
PartUtils Class See Also Send Feedback
Identifies if provided members are valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")]
public static bool AreElementsValidIntersectingReferences(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")> _
Public Shared Function AreElementsValidIntersectingReferences ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.AreElementsValidIntersectingReferences() instead.")]
public:
static bool AreElementsValidIntersectingReferences(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for intersecting references.

Return Value

True if all references are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


ArePartsValidForDivide Method

[image]

Revit 2013 API
PartUtils..::..ArePartsValidForDivide Method
PartUtils Class See Also Send Feedback
Identifies if provided members are valid for dividing parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool ArePartsValidForDivide(
    Document document,
    ICollection<ElementId> elementIdsToDivide
)
Visual Basic
Public Shared Function ArePartsValidForDivide ( _
    document As Document, _
    elementIdsToDivide As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ArePartsValidForDivide(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementIdsToDivide
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity for dividing parts.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


ArePartsValidForMerge Method

[image]

Revit 2013 API
PartUtils..::..ArePartsValidForMerge Method
PartUtils Class See Also Send Feedback
Identifies whether Part elements may be merged.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool ArePartsValidForMerge(
    Document document,
    ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function ArePartsValidForMerge ( _
    document As Document, _
    partIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool ArePartsValidForMerge(
    Document^ document,
    ICollection<ElementId^>^ partIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids of Parts.

Return Value

True if all element ids correspond to Part elements, none of the parts already has associated parts, the parts have contiguous geometry, all report the same materials, and all have the same creation and demolition phases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


CreateMergedPart Method

[image]

Revit 2013 API
PartUtils..::..CreateMergedPart Method
PartUtils Class See Also Send Feedback
Create a single merged part which represents the Parts specified by partsToMerge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PartMaker CreateMergedPart(
    Document document,
    ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function CreateMergedPart ( _
    document As Document, _
    partIds As ICollection(Of ElementId) _
) As PartMaker
Visual C++
public:
static PartMaker^ CreateMergedPart(
    Document^ document,
    ICollection<ElementId^>^ partIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that the merged part will be created from.

Return Value

The newly created PartMaker. nullNothingnullptra null reference (Nothing in Visual Basic) if no parts are merged.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not suitable for merging with the others. Specified elements should all be Parts, report the same material, creation and demolition phases, and have contiguous geometry.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class


CreateParts Method

[image] [image]

Revit 2013 API
PartUtils..::..CreateParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
CreateParts(Document, ICollection<(Of <<'(ElementId>)>>)) | Creates a new set of parts out of the original elements.
CreateParts(Document, ICollection<(Of <<'(LinkElementId>)>>)) | Creates a new set of parts out of the original elements.

See Also

PartUtils Class
PartUtils Members


CreateParts Method (Document, ICollection(ElementId))

[image]

Revit 2013 API
PartUtils..::..CreateParts Method (Document, ICollection<(Of <(<'ElementId>)>)>)
PartUtils Class See Also Send Feedback
Creates a new set of parts out of the original elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateParts(
    Document document,
    ICollection<ElementId> elementIds
)
Visual Basic
Public Shared Sub CreateParts ( _
    document As Document, _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void CreateParts(
    Document^ document,
    ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that parts will be created from.

Remarks

Parts will be added to the model after regeneration.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for creating parts. Elements should be of a valid category and the ids should be valid and should not already be divided into parts.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class
CreateParts Overload


CreateParts Method (Document, ICollection(LinkElementId))

[image]

Revit 2013 API
PartUtils..::..CreateParts Method (Document, ICollection<(Of <(<'LinkElementId>)>)>)
PartUtils Class See Also Send Feedback
Creates a new set of parts out of the original elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void CreateParts(
    Document document,
    ICollection<LinkElementId> hostOrLinkElementIds
)
Visual Basic
Public Shared Sub CreateParts ( _
    document As Document, _
    hostOrLinkElementIds As ICollection(Of LinkElementId) _
)
Visual C++
public:
static void CreateParts(
    Document^ document,
    ICollection<LinkElementId^>^ hostOrLinkElementIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the elements.
hostOrLinkElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'LinkElementId>)>)>
The elements that parts will be created from.

Remarks

Parts will be added to the model after regeneration. To get the ids of the parts created by this method use PartUtils.GetAssociatedParts() with the contents of hostOrLinkElementIds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for creating parts. HostOrLinkElements should be of a valid category and the ids should be valid and should not already be divided into parts.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class
CreateParts Overload


Dispose Method

[image]

Revit 2013 API
PartUtils..::..Dispose Method
PartUtils Class See Also Send Feedback
Releases all resources used by the PartUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PartUtils Class


DivideParts Method

[image]

Revit 2013 API
PartUtils..::..DivideParts Method
PartUtils Class See Also Send Feedback
Creates divided parts out of parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PartMaker DivideParts(
    Document document,
    ICollection<ElementId> elementIdsToDivide,
    ICollection<ElementId> intersectingReferenceIds,
    IList<Curve> curveArray,
    ElementId sketchPlaneId
)
Visual Basic
Public Shared Function DivideParts ( _
    document As Document, _
    elementIdsToDivide As ICollection(Of ElementId), _
    intersectingReferenceIds As ICollection(Of ElementId), _
    curveArray As IList(Of Curve), _
    sketchPlaneId As ElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ DivideParts(
    Document^ document,
    ICollection<ElementId^>^ elementIdsToDivide,
    ICollection<ElementId^>^ intersectingReferenceIds,
    IList<Curve^>^ curveArray,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the parts.
elementIdsToDivide
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The elements that will be divided.
intersectingReferenceIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Intersecting references that will divide the elements.
curveArray
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
Array of curves that will divide the elements.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane id for the curves that divide the elements.

Return Value

The newly created PartMaker. nullNothingnullptra null reference (Nothing in Visual Basic) if no parts are divided.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted for dividing parts. Elements should be parts that are not yet divided and maximum distance from an original has not yet been reached. -or- One or more element ids was not permitted as intersecting references. Intersecting references should be levels, grids, or reference planes. -or- The element id should refer to a valid SketchPlane. -or- The input curveArray contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PartUtils Class


FindMergeableClusters Method

[image]

Revit 2013 API
PartUtils..::..FindMergeableClusters Method
PartUtils Class See Also Send Feedback
Segregates a set of elements into subsets which are valid for merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ICollection<ElementId>> FindMergeableClusters(
    Document doc,
    ICollection<ElementId> partIds
)
Visual Basic
Public Shared Function FindMergeableClusters ( _
    doc As Document, _
    partIds As ICollection(Of ElementId) _
) As IList(Of ICollection(Of ElementId))
Visual C++
public:
static IList<ICollection<ElementId^>^>^ FindMergeableClusters(
    Document^ doc,
    ICollection<ElementId^>^ partIds
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
partIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids.

Return Value

An array of clusters such that all the elements in a single cluster are valid for merge. Each cluster will be maximal in that appending any of the other Parts specified as input will result in a collection that is not valid for merge.

Remarks

Element ids in the input set that do not correspond to Part elements will be ignored, as will element ids corresponding to Part elements that already have associated parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


GetAssociatedPartMaker Method

[image] [image]

Revit 2013 API
PartUtils..::..GetAssociatedPartMaker Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
GetAssociatedPartMaker(Document, ElementId) | Gets associated PartMaker for an element.
GetAssociatedPartMaker(Document, LinkElementId) | Gets associated PartMaker for an element.

See Also

PartUtils Class
PartUtils Members


GetAssociatedPartMaker Method (Document, ElementId)

[image]

Revit 2013 API
PartUtils..::..GetAssociatedPartMaker Method (Document, ElementId)
PartUtils Class See Also Send Feedback
Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PartMaker GetAssociatedPartMaker(
    Document hostDocument,
    ElementId elementId
)
Visual Basic
Public Shared Function GetAssociatedPartMaker ( _
    hostDocument As Document, _
    elementId As ElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ GetAssociatedPartMaker(
    Document^ hostDocument,
    ElementId^ elementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id for the element to be checked for associated Parts

Return Value

The PartMaker element that is making Parts for this element. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no associated PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
GetAssociatedPartMaker Overload


GetAssociatedPartMaker Method (Document, LinkElementId)

[image]

Revit 2013 API
PartUtils..::..GetAssociatedPartMaker Method (Document, LinkElementId)
PartUtils Class See Also Send Feedback
Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PartMaker GetAssociatedPartMaker(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function GetAssociatedPartMaker ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ GetAssociatedPartMaker(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The id for the element to be checked for associated Parts

Return Value

The PartMaker element that is making Parts for this element. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no associated PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
GetAssociatedPartMaker Overload


GetAssociatedParts Method

[image] [image]

Revit 2013 API
PartUtils..::..GetAssociatedParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
GetAssociatedParts(Document, ElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element.
GetAssociatedParts(Document, LinkElementId, Boolean, Boolean) | Returns all Parts that are associated with the given element

See Also

PartUtils Class
PartUtils Members


GetAssociatedParts Method (Document, ElementId, Boolean, Boolean)

[image]

Revit 2013 API
PartUtils..::..GetAssociatedParts Method (Document, ElementId, Boolean, Boolean)
PartUtils Class See Also Send Feedback
Returns all Parts that are associated with the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    ElementId elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Visual Basic
Public Shared Function GetAssociatedParts ( _
    hostDocument As Document, _
    elementId As ElementId, _
    includePartsWithAssociatedParts As Boolean, _
    includeAllChildren As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document of the element.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts
Type: System..::..Boolean
If true, include parts that have associated parts.
includeAllChildren
Type: System..::..Boolean
If true, return all associated Parts recursively for all children. If false, only return immediate children.

Return Value

Parts that are associated to the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
GetAssociatedParts Overload


GetAssociatedParts Method (Document, LinkElementId, Boolean, Boolean)

[image]

Revit 2013 API
PartUtils..::..GetAssociatedParts Method (Document, LinkElementId, Boolean, Boolean)
PartUtils Class See Also Send Feedback
Returns all Parts that are associated with the given element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)
Visual Basic
Public Shared Function GetAssociatedParts ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId, _
    includePartsWithAssociatedParts As Boolean, _
    includeAllChildren As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId,
    bool includePartsWithAssociatedParts,
    bool includeAllChildren
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document of the element
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts
Type: System..::..Boolean
If true, include parts that have associated parts
includeAllChildren
Type: System..::..Boolean
If true, return all associated Parts recursively for all children If false, only return immediate children

Return Value

Parts that are associated to the element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
GetAssociatedParts Overload


GetChainLengthToOriginal Method

[image]

Revit 2013 API
PartUtils..::..GetChainLengthToOriginal Method
PartUtils Class See Also Send Feedback
Calculates the length of the longest chain of divisions/merges to reach to an original non-Part element that is the source of the tested part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static int GetChainLengthToOriginal(
    Part part
)
Visual Basic
Public Shared Function GetChainLengthToOriginal ( _
    part As Part _
) As Integer
Visual C++
public:
static int GetChainLengthToOriginal(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
The part to be tested

Return Value

The length of the longest chain.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


GetDividedParents Method

[image]

Revit 2013 API
PartUtils..::..GetDividedParents Method
PartUtils Class See Also Send Feedback
Returns an array of elements that lead to the creation of this Part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version.")]
public static ICollection<ElementId> GetDividedParents(
    Part part
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version.")> _
Public Shared Function GetDividedParents ( _
    part As Part _
) As ICollection(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version.")]
public:
static ICollection<ElementId^>^ GetDividedParents(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
The Part element

Return Value

Ids of divided elements that lead to the creation of this Part

Remarks

The array is ordered by the order of creation of the returned elements. The first element is the original element. Each consecutive element is a Part made from the previous element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


GetMergedParts Method

[image]

Revit 2013 API
PartUtils..::..GetMergedParts Method
PartUtils Class See Also Send Feedback
Retrieves the element ids of the source elements of a merged part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetMergedParts(
    Part part
)
Visual Basic
Public Shared Function GetMergedParts ( _
    part As Part _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetMergedParts(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part
A merged part.

Return Value

The element ids of the parts that were merged to create the specified merged part.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The specified Part is not a merged part.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


GetOffsetForIntersectingReference Method

[image]

Revit 2013 API
PartUtils..::..GetOffsetForIntersectingReference Method
PartUtils Class See Also Send Feedback
Get offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")]
public static double GetOffsetForIntersectingReference(
    PartMaker partMaker,
    ElementId intersectingReference
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")> _
Public Shared Function GetOffsetForIntersectingReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId _
) As Double
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.GetOffsetForIntersectingReference() instead.")]
public:
static double GetOffsetForIntersectingReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker that uses the intersecting reference.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference to obtain offset value from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


GetPartMakerMethodToDivideVolume Method

[image]

Revit 2013 API
PartUtils..::..GetPartMakerMethodToDivideVolume Method
PartUtils Class See Also Send Feedback
Obtains the object allowing access to the divided volume properties of the PartMaker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PartMakerMethodToDivideVolumes GetPartMakerMethodToDivideVolume(
    PartMaker partMaker
)
Visual Basic
Public Shared Function GetPartMakerMethodToDivideVolume ( _
    partMaker As PartMaker _
) As PartMakerMethodToDivideVolumes
Visual C++
public:
static PartMakerMethodToDivideVolumes^ GetPartMakerMethodToDivideVolume(
    PartMaker^ partMaker
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
The PartMaker.

Return Value

The object handle. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the PartMaker does not represent divided volumes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


HasAssociatedParts Method

[image] [image]

Revit 2013 API
PartUtils..::..HasAssociatedParts Method
PartUtils Class See Also Send Feedback

Overload List

Name | Description
HasAssociatedParts(Document, ElementId) | Checks if an element has associated parts.
HasAssociatedParts(Document, LinkElementId) | Checks if an element has associated parts.

See Also

PartUtils Class
PartUtils Members


HasAssociatedParts Method (Document, ElementId)

[image]

Revit 2013 API
PartUtils..::..HasAssociatedParts Method (Document, ElementId)
PartUtils Class See Also Send Feedback
Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool HasAssociatedParts(
    Document hostDocument,
    ElementId elementId
)
Visual Basic
Public Shared Function HasAssociatedParts ( _
    hostDocument As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    ElementId^ elementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for associated Parts

Return Value

True if the element has associated Parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
HasAssociatedParts Overload


HasAssociatedParts Method (Document, LinkElementId)

[image]

Revit 2013 API
PartUtils..::..HasAssociatedParts Method (Document, LinkElementId)
PartUtils Class See Also Send Feedback
Checks if an element has associated parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool HasAssociatedParts(
    Document hostDocument,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function HasAssociatedParts ( _
    hostDocument As Document, _
    hostOrLinkElementId As LinkElementId _
) As Boolean
Visual C++
public:
static bool HasAssociatedParts(
    Document^ hostDocument,
    LinkElementId^ hostOrLinkElementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document.
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
The element to be checked for associated Parts.

Return Value

True if the element has associated Parts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class
HasAssociatedParts Overload


IsMaxDivisionDepthReached Method

[image]

Revit 2013 API
PartUtils..::..IsMaxDivisionDepthReached Method
PartUtils Class See Also Send Feedback
Identifies if elements have reached their maximum division depth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method will be obsolete in the next version. It returns false always.")]
public static bool IsMaxDivisionDepthReached(
    Document doc,
    ElementId elementId
)
Visual Basic
<ObsoleteAttribute("This method will be obsolete in the next version. It returns false always.")> _
Public Shared Function IsMaxDivisionDepthReached ( _
    doc As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method will be obsolete in the next version. It returns false always.")]
public:
static bool IsMaxDivisionDepthReached(
    Document^ doc,
    ElementId^ elementId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
Element ids to be tested for division

Return Value

True if maximum division depth was reached for an element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


IsMergedPart Method

[image]

Revit 2013 API
PartUtils..::..IsMergedPart Method
PartUtils Class See Also Send Feedback
Is the Part the result of a merge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsMergedPart(
    Part part
)
Visual Basic
Public Shared Function IsMergedPart ( _
    part As Part _
) As Boolean
Visual C++
public:
static bool IsMergedPart(
    Part^ part
)

Parameters

part
Type: Autodesk.Revit.DB..::..Part

Return Value

True if the Part is the result of a merge operation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


IsPartDerivedFromLink Method

[image]

Revit 2013 API
PartUtils..::..IsPartDerivedFromLink Method
PartUtils Class See Also Send Feedback
Is the Part derived from link geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsPartDerivedFromLink(
    Part dPart
)
Visual Basic
Public Shared Function IsPartDerivedFromLink ( _
    dPart As Part _
) As Boolean
Visual C++
public:
static bool IsPartDerivedFromLink(
    Part^ dPart
)

Parameters

dPart
Type: Autodesk.Revit.DB..::..Part

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


IsValidForCreateParts Method

[image]

Revit 2013 API
PartUtils..::..IsValidForCreateParts Method
PartUtils Class See Also Send Feedback
Identifies if the given element can be used to create parts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidForCreateParts(
    Document document,
    LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function IsValidForCreateParts ( _
    document As Document, _
    hostOrLinkElementId As LinkElementId _
) As Boolean
Visual C++
public:
static bool IsValidForCreateParts(
    Document^ document,
    LinkElementId^ hostOrLinkElementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
hostOrLinkElementId
Type: Autodesk.Revit.DB..::..LinkElementId
Id to be tested for validity for creating part.

Return Value

True if this id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


IsValidSketchPlane Method

[image]

Revit 2013 API
PartUtils..::..IsValidSketchPlane Method
PartUtils Class See Also Send Feedback
Identifies if provided sketch plane is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")]
public static bool IsValidSketchPlane(
    Document document,
    ElementId sketchPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")> _
Public Shared Function IsValidSketchPlane ( _
    document As Document, _
    sketchPlaneId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.IsValidSketchPlane() instead.")]
public:
static bool IsValidSketchPlane(
    Document^ document,
    ElementId^ sketchPlaneId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
sketchPlaneId
Type: Autodesk.Revit.DB..::..ElementId
SketchPlane ids to be tested for validity for PartMaker.

Return Value

True if SketchPlane valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


PartMakerUsesReference Method

[image]

Revit 2013 API
PartUtils..::..PartMakerUsesReference Method
PartUtils Class See Also Send Feedback
Identifies if the PartMaker uses the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")]
public static bool PartMakerUsesReference(
    PartMaker partMaker,
    ElementId intersectingReference
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")> _
Public Shared Function PartMakerUsesReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.PartMakerUsesReference() instead.")]
public:
static bool PartMakerUsesReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker to be tested.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
Intersecting reference to be tested.

Return Value

True if the intersecting reference is used by the PartMaker.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


SetOffsetForIntersectingReference Method

[image]

Revit 2013 API
PartUtils..::..SetOffsetForIntersectingReference Method
PartUtils Class See Also Send Feedback
Set offset for the intersecting reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")]
public static void SetOffsetForIntersectingReference(
    PartMaker partMaker,
    ElementId intersectingReference,
    double offset
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")> _
Public Shared Sub SetOffsetForIntersectingReference ( _
    partMaker As PartMaker, _
    intersectingReference As ElementId, _
    offset As Double _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013; use PartMakerMethodToDivideVolumes.SetOffsetForIntersectingReference() instead.")]
public:
static void SetOffsetForIntersectingReference(
    PartMaker^ partMaker,
    ElementId^ intersectingReference,
    double offset
)

Parameters

partMaker
Type: Autodesk.Revit.DB..::..PartMaker
PartMaker that uses the intersecting reference to be offset.
intersectingReference
Type: Autodesk.Revit.DB..::..ElementId
The intersecting reference that will be offset.
offset
Type: System..::..Double
Offset amount for the intersecting reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | PartMaker does not use the specified intersecting reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PartUtils Class


Path3d Class

[image]

Revit 2013 API
Path3d Class
Members See Also Send Feedback
Provides access to the Generic 3D path object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Path3d : SketchBase
Visual Basic
Public Class Path3d _
    Inherits SketchBase
Visual C++
public ref class Path3d : public SketchBase

Remarks

This object represents a 3D path sketch of Sweep.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Path3d

See Also

Path3d Members


Path3d Members

[image] [image]

Revit 2013 API
Path3d Members
Path3d Class Methods Properties See Also Send Feedback

The Path3d type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Path3d Class


Path3d Methods

[image] [image]

Revit 2013 API
Path3d Methods
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Path3d Class


Path3d Properties

[image] [image]

Revit 2013 API
Path3d Properties
Path3d Class See Also Send Feedback

The Path3d type exposes the following members.

Properties

 | Name | Description
Public property | AllCurveLoops | Get all the Curve Loops of Path3d.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveLoop | Get the Curve Loop of Path3d via index.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurveLoops | Get the Number of Curve Loops of Path3d.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Path3d Class


AllCurveLoops Property

[image]

Revit 2013 API
Path3d..::..AllCurveLoops Property
Path3d Class See Also Send Feedback
Get all the Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray AllCurveLoops { get; }
Visual Basic
Public ReadOnly Property AllCurveLoops As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ AllCurveLoops {
    CurveArrArray^ get ();
}

Remarks

Returns all the Curve Loops of Path3d.

See Also

Path3d Class


CurveLoop Property

[image]

Revit 2013 API
Path3d..::..CurveLoop Property
Path3d Class See Also Send Feedback
Get the Curve Loop of Path3d via index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property CurveLoop ( _
    index As Integer _
) As CurveArray
    Get
Visual C++
public:
property CurveArray^ CurveLoop[int index] {
    CurveArray^ get (int index);
}

Parameters

index
Type: System..::..Int32

Remarks

Returns the index order Curve Loop of Path3d.

See Also

Path3d Class


NumCurveLoops Property

[image]

Revit 2013 API
Path3d..::..NumCurveLoops Property
Path3d Class See Also Send Feedback
Get the Number of Curve Loops of Path3d.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumCurveLoops { get; }
Visual Basic
Public ReadOnly Property NumCurveLoops As Integer
    Get
Visual C++
public:
property int NumCurveLoops {
    int get ();
}

Remarks

Returns the Number of Curve Loops of Path3d.

See Also

Path3d Class


Parameter Property

[image] [image]

Revit 2013 API
Path3d..::..Parameter Property
Path3d Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Path3d Class
Path3d Members


PathType Enumeration

[image]

Revit 2013 API
PathType Enumeration
See Also Send Feedback
Enum determining what kind of path a given external file reference path is. Paths are valid for all types of external file references unless otherwise specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PathType
Visual Basic
Public Enumeration PathType
Visual C++
public enum class PathType

Members

Member name | Description
Relative | The path is relative to the host file's location, or to the central model's location if the host is workshared.
Absolute | The path is an absolute path to a location on disk or the network.
Server | The path is to a Revit Server location. This value is only valid for ExternalFileReferenceType.RevitLink
Content | The path is relative to a location in the Revit content libraries. This value is only valid for ExternalFileReferenceType.KeynoteTable or ExternalFileReferenceType.Decal

See Also


PerformanceAdviser Class

[image]

Revit 2013 API
PerformanceAdviser Class
Members Example See Also Send Feedback
The tool to report performance problems in a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PerformanceAdviser : IDisposable
Visual Basic
Public Class PerformanceAdviser _
    Implements IDisposable
Visual C++
public ref class PerformanceAdviser : IDisposable

Remarks

Class is an application-wide singleton that performs a dual role: it is a repository of rules to run in order to detect potential performance problems as well as an access point to execute checks.

Examples

CopyC#
//Get the name of each registered PerformanceRule and then execute all of them.
foreach (PerformanceAdviserRuleId id in PerformanceAdviser.GetPerformanceAdviser().GetAllRuleIds())
{
    string ruleName = PerformanceAdviser.GetPerformanceAdviser().GetRuleName(id);
}
PerformanceAdviser.GetPerformanceAdviser().ExecuteAllRules(document);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PerformanceAdviser

See Also

PerformanceAdviser Members


PerformanceAdviser Members

[image] [image]

Revit 2013 API
PerformanceAdviser Members
PerformanceAdviser Class Methods See Also Send Feedback

The PerformanceAdviser type exposes the following members.

Methods

 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose | Releases all resources used by the PerformanceAdviser
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class


PerformanceAdviser Methods

[image] [image]

Revit 2013 API
PerformanceAdviser Methods
PerformanceAdviser Class See Also Send Feedback

The PerformanceAdviser type exposes the following members.

Methods

 | Name | Description
Public method | AddRule | Adds a performance adviser rule to the list of rules.
Public method | DeleteRule | Deletes a performance adviser rule from the list of rules.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteAllRules | Executes all rules in the list on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.
Public method | GetAllRuleIds | Retrieves an enumeration of rule Ids.
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfRules | Retrieves number of performance adviser rules in the list.
 | GetPerformanceAdviser | Returns the only instance of PerformanceAdviser in the Application.
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.
Public method | GetRuleId | Retrieves an id of a rule for a given index in the list.
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.
Public method | PostWarning | Reports a problem detected during execution of a rule.
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class


AddRule Method

[image]

Revit 2013 API
PerformanceAdviser..::..AddRule Method
PerformanceAdviser Class See Also Send Feedback
Adds a performance adviser rule to the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddRule(
    PerformanceAdviserRuleId id,
    IPerformanceAdviserRule rule
)
Visual Basic
Public Sub AddRule ( _
    id As PerformanceAdviserRuleId, _
    rule As IPerformanceAdviserRule _
)
Visual C++
public:
void AddRule(
    PerformanceAdviserRuleId^ id,
    IPerformanceAdviserRule^ rule
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be added to the list of rules.
rule
Type: Autodesk.Revit.DB..::..IPerformanceAdviserRule
The rule to be added

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class


DeleteRule Method

[image]

Revit 2013 API
PerformanceAdviser..::..DeleteRule Method
PerformanceAdviser Class See Also Send Feedback
Deletes a performance adviser rule from the list of rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void DeleteRule(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Sub DeleteRule ( _
    id As PerformanceAdviserRuleId _
)
Visual C++
public:
void DeleteRule(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
An id of the rule to be deleted from the list of rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class


Dispose Method

[image]

Revit 2013 API
PerformanceAdviser..::..Dispose Method
PerformanceAdviser Class See Also Send Feedback
Releases all resources used by the PerformanceAdviser

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PerformanceAdviser Class


ExecuteAllRules Method

[image]

Revit 2013 API
PerformanceAdviser..::..ExecuteAllRules Method
PerformanceAdviser Class See Also Send Feedback
Executes all rules in the list on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<FailureMessage> ExecuteAllRules(
    Document document
)
Visual Basic
Public Function ExecuteAllRules ( _
    document As Document _
) As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ ExecuteAllRules(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document on which the rules will be executed.

Return Value

Failure messages explaining performance problems detected in the document.

Remarks

Disabled rules are not executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class


ExecuteRules Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..ExecuteRules Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExecuteRules(Document, IList<(Of <<'(PerformanceAdviserRuleId>)>>)) | Executes selected rules on a given document.
Public method | ExecuteRules(Document, IList<(Of <<'(Int32>)>>)) | Executes selected rules on a given document.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


ExecuteRules Method (Document, IList(PerformanceAdviserRuleId))

[image]

Revit 2013 API
PerformanceAdviser..::..ExecuteRules Method (Document, IList<(Of <(<'PerformanceAdviserRuleId>)>)>)
PerformanceAdviser Class See Also Send Feedback
Executes selected rules on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<FailureMessage> ExecuteRules(
    Document document,
    IList<PerformanceAdviserRuleId> rules
)
Visual Basic
Public Function ExecuteRules ( _
    document As Document, _
    rules As IList(Of PerformanceAdviserRuleId) _
) As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ ExecuteRules(
    Document^ document,
    IList<PerformanceAdviserRuleId^>^ rules
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document on which the rules will be executed.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'PerformanceAdviserRuleId>)>)>
Ids of rules to be executed.

Return Value

Failure messages explaining performance problems detected in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
ExecuteRules Overload


ExecuteRules Method (Document, IList(Int32))

[image]

Revit 2013 API
PerformanceAdviser..::..ExecuteRules Method (Document, IList<(Of <(<'Int32>)>)>)
PerformanceAdviser Class See Also Send Feedback
Executes selected rules on a given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<FailureMessage> ExecuteRules(
    Document document,
    IList<int> rules
)
Visual Basic
Public Function ExecuteRules ( _
    document As Document, _
    rules As IList(Of Integer) _
) As IList(Of FailureMessage)
Visual C++
public:
IList<FailureMessage^>^ ExecuteRules(
    Document^ document,
    IList<int>^ rules
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document on which the rules will be executed.
rules
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
Indices of rules to be executed.

Return Value

Failure messages explaining performance problems detected in the document.

Remarks

Disabled rules are not executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
ExecuteRules Overload


GetAllRuleIds Method

[image]

Revit 2013 API
PerformanceAdviser..::..GetAllRuleIds Method
PerformanceAdviser Class See Also Send Feedback
Retrieves an enumeration of rule Ids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<PerformanceAdviserRuleId> GetAllRuleIds()
Visual Basic
Public Function GetAllRuleIds As IList(Of PerformanceAdviserRuleId)
Visual C++
public:
IList<PerformanceAdviserRuleId^>^ GetAllRuleIds()

Return Value

A collection of rule Ids

See Also

PerformanceAdviser Class


GetElementFilterFromRule Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..GetElementFilterFromRule Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetElementFilterFromRule(Int32, Document) | Retrieves a filter to restrict elements to be checked.
Public method | GetElementFilterFromRule(PerformanceAdviserRuleId, Document) | Retrieves a filter to restrict elements to be checked.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetElementFilterFromRule Method (Int32, Document)

[image]

Revit 2013 API
PerformanceAdviser..::..GetElementFilterFromRule Method (Int32, Document)
PerformanceAdviser Class See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementFilter GetElementFilterFromRule(
    int index,
    Document document
)
Visual Basic
Public Function GetElementFilterFromRule ( _
    index As Integer, _
    document As Document _
) As ElementFilter
Visual C++
public:
ElementFilter^ GetElementFilterFromRule(
    int index,
    Document^ document
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.
document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
GetElementFilterFromRule Overload


GetElementFilterFromRule Method (PerformanceAdviserRuleId, Document)

[image]

Revit 2013 API
PerformanceAdviser..::..GetElementFilterFromRule Method (PerformanceAdviserRuleId, Document)
PerformanceAdviser Class See Also Send Feedback
Retrieves a filter to restrict elements to be checked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementFilter GetElementFilterFromRule(
    PerformanceAdviserRuleId id,
    Document document
)
Visual Basic
Public Function GetElementFilterFromRule ( _
    id As PerformanceAdviserRuleId, _
    document As Document _
) As ElementFilter
Visual C++
public:
ElementFilter^ GetElementFilterFromRule(
    PerformanceAdviserRuleId^ id,
    Document^ document
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.
document
Type: Autodesk.Revit.DB..::..Document
Document for which performance problems are being checked.

Return Value

The filter to restrict elements to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
GetElementFilterFromRule Overload


GetNumberOfRules Method

[image]

Revit 2013 API
PerformanceAdviser..::..GetNumberOfRules Method
PerformanceAdviser Class See Also Send Feedback
Retrieves number of performance adviser rules in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetNumberOfRules()
Visual Basic
Public Function GetNumberOfRules As Integer
Visual C++
public:
int GetNumberOfRules()

Return Value

Number of performance adviser rules in the list.

See Also

PerformanceAdviser Class


GetPerformanceAdviser Method

[image]

Revit 2013 API
PerformanceAdviser..::..GetPerformanceAdviser Method
PerformanceAdviser Class See Also Send Feedback
Returns the only instance of PerformanceAdviser in the Application.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PerformanceAdviser GetPerformanceAdviser()
Visual Basic
Public Shared Function GetPerformanceAdviser As PerformanceAdviser
Visual C++
public:
static PerformanceAdviser^ GetPerformanceAdviser()

Return Value

The only instance of PerformanceAdviser in the Application.

See Also

PerformanceAdviser Class


GetRuleDescription Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..GetRuleDescription Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuleDescription(Int32) | Retrieves the description of the rule.
Public method | GetRuleDescription(PerformanceAdviserRuleId) | Retrieves the description of the rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetRuleDescription Method (Int32)

[image]

Revit 2013 API
PerformanceAdviser..::..GetRuleDescription Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetRuleDescription(
    int index
)
Visual Basic
Public Function GetRuleDescription ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetRuleDescription(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

The description of the rule.

See Also

PerformanceAdviser Class
GetRuleDescription Overload


GetRuleDescription Method (PerformanceAdviserRuleId)

[image]

Revit 2013 API
PerformanceAdviser..::..GetRuleDescription Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetRuleDescription(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function GetRuleDescription ( _
    id As PerformanceAdviserRuleId _
) As String
Visual C++
public:
String^ GetRuleDescription(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.

Return Value

The description of the rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
GetRuleDescription Overload


GetRuleId Method

[image]

Revit 2013 API
PerformanceAdviser..::..GetRuleId Method
PerformanceAdviser Class See Also Send Feedback
Retrieves an id of a rule for a given index in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PerformanceAdviserRuleId GetRuleId(
    int index
)
Visual Basic
Public Function GetRuleId ( _
    index As Integer _
) As PerformanceAdviserRuleId
Visual C++
public:
PerformanceAdviserRuleId^ GetRuleId(
    int index
)

Parameters

index
Type: System..::..Int32
The index to retrieve the rule id for.

Return Value

The rule id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range.

See Also

PerformanceAdviser Class


GetRuleName Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..GetRuleName Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRuleName(Int32) | Retrieves the name of the rule.
Public method | GetRuleName(PerformanceAdviserRuleId) | Retrieves the name of the rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


GetRuleName Method (Int32)

[image]

Revit 2013 API
PerformanceAdviser..::..GetRuleName Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetRuleName(
    int index
)
Visual Basic
Public Function GetRuleName ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetRuleName(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

The name of the rule.

See Also

PerformanceAdviser Class
GetRuleName Overload


GetRuleName Method (PerformanceAdviserRuleId)

[image]

Revit 2013 API
PerformanceAdviser..::..GetRuleName Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Retrieves the name of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetRuleName(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function GetRuleName ( _
    id As PerformanceAdviserRuleId _
) As String
Visual C++
public:
String^ GetRuleName(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.

Return Value

The name of the rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
GetRuleName Overload


IsRuleEnabled Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..IsRuleEnabled Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsRuleEnabled(Int32) | Retrieves an enabled/disabled status for the given rule.
Public method | IsRuleEnabled(PerformanceAdviserRuleId) | Retrieves an enabled/disabled status for the given rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


IsRuleEnabled Method (Int32)

[image]

Revit 2013 API
PerformanceAdviser..::..IsRuleEnabled Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsRuleEnabled(
    int index
)
Visual Basic
Public Function IsRuleEnabled ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsRuleEnabled(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to retrieve enabled/disabled status for.

Return Value

True if rule is disabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range.

See Also

PerformanceAdviser Class
IsRuleEnabled Overload


IsRuleEnabled Method (PerformanceAdviserRuleId)

[image]

Revit 2013 API
PerformanceAdviser..::..IsRuleEnabled Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsRuleEnabled(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function IsRuleEnabled ( _
    id As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
bool IsRuleEnabled(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to retrieve enabled/disabled status for.

Return Value

True if rule is disabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id does not correspond to any registered rule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
IsRuleEnabled Overload


PostWarning Method

[image]

Revit 2013 API
PerformanceAdviser..::..PostWarning Method
PerformanceAdviser Class See Also Send Feedback
Reports a problem detected during execution of a rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void PostWarning(
    FailureMessage message
)
Visual Basic
Public Sub PostWarning ( _
    message As FailureMessage _
)
Visual C++
public:
void PostWarning(
    FailureMessage^ message
)

Parameters

message
Type: Autodesk.Revit.DB..::..FailureMessage
Warning describing the problem detected by a rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The message must have severity "warning".
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Performance advisor is not executing rules.

See Also

PerformanceAdviser Class


SetRuleEnabled Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..SetRuleEnabled Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetRuleEnabled(Int32, Boolean) | Retrieves an enabled/disabled status for the given rule.
Public method | SetRuleEnabled(PerformanceAdviserRuleId, Boolean) | Retrieves an enabled/disabled status for the given rule.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


SetRuleEnabled Method (Int32, Boolean)

[image]

Revit 2013 API
PerformanceAdviser..::..SetRuleEnabled Method (Int32, Boolean)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetRuleEnabled(
    int index,
    bool enabled
)
Visual Basic
Public Sub SetRuleEnabled ( _
    index As Integer, _
    enabled As Boolean _
)
Visual C++
public:
void SetRuleEnabled(
    int index,
    bool enabled
)

Parameters

index
Type: System..::..Int32
The rule index to set enabled/disabled status for.
enabled
Type: System..::..Boolean
True enables the rule, false disables.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is outside of acceptable range.

See Also

PerformanceAdviser Class
SetRuleEnabled Overload


SetRuleEnabled Method (PerformanceAdviserRuleId, Boolean)

[image]

Revit 2013 API
PerformanceAdviser..::..SetRuleEnabled Method (PerformanceAdviserRuleId, Boolean)
PerformanceAdviser Class See Also Send Feedback
Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetRuleEnabled(
    PerformanceAdviserRuleId id,
    bool enabled
)
Visual Basic
Public Sub SetRuleEnabled ( _
    id As PerformanceAdviserRuleId, _
    enabled As Boolean _
)
Visual C++
public:
void SetRuleEnabled(
    PerformanceAdviserRuleId^ id,
    bool enabled
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to set enabled/disabled status for.
enabled
Type: System..::..Boolean
True enables the rule, false disables.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The id does not correspond to any registered rule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
SetRuleEnabled Overload


WillRuleCheckElements Method

[image] [image]

Revit 2013 API
PerformanceAdviser..::..WillRuleCheckElements Method
PerformanceAdviser Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WillRuleCheckElements(Int32) | Reports if rule needs to be executed on individual elements.
Public method | WillRuleCheckElements(PerformanceAdviserRuleId) | Reports if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class
PerformanceAdviser Members


WillRuleCheckElements Method (Int32)

[image]

Revit 2013 API
PerformanceAdviser..::..WillRuleCheckElements Method (Int32)
PerformanceAdviser Class See Also Send Feedback
Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool WillRuleCheckElements(
    int index
)
Visual Basic
Public Function WillRuleCheckElements ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool WillRuleCheckElements(
    int index
)

Parameters

index
Type: System..::..Int32
The rule index to get information for.

Return Value

True if rule needs to be executed on individual elements.

See Also

PerformanceAdviser Class
WillRuleCheckElements Overload


WillRuleCheckElements Method (PerformanceAdviserRuleId)

[image]

Revit 2013 API
PerformanceAdviser..::..WillRuleCheckElements Method (PerformanceAdviserRuleId)
PerformanceAdviser Class See Also Send Feedback
Reports if rule needs to be executed on individual elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool WillRuleCheckElements(
    PerformanceAdviserRuleId id
)
Visual Basic
Public Function WillRuleCheckElements ( _
    id As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
bool WillRuleCheckElements(
    PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The rule id to get information for.

Return Value

True if rule needs to be executed on individual elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PerformanceAdviser Class
WillRuleCheckElements Overload


PerformanceAdviserRuleId Class

[image]

Revit 2013 API
PerformanceAdviserRuleId Class
Members See Also Send Feedback
The unique identifier of a PerformanceAdviserRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PerformanceAdviserRuleId : GuidEnum
Visual Basic
Public Class PerformanceAdviserRuleId _
    Inherits GuidEnum
Visual C++
public ref class PerformanceAdviserRuleId : public GuidEnum

Remarks

Each performance adviser rule registered in application must be given a unique id that can be used to identify and unregister rule later.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB..::..PerformanceAdviserRuleId

See Also

PerformanceAdviserRuleId Members


PerformanceAdviserRuleId Members

[image] [image]

Revit 2013 API
PerformanceAdviserRuleId Members
PerformanceAdviserRuleId Class Constructors Methods Operators Properties See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Constructors

 | Name | Description
Public method | PerformanceAdviserRuleId | Creates a new PerformanceAdviserRuleId instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two PerformanceAdviserRuleId instances.
Inequality | Compares two PerformanceAdviserRuleId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Constructor

[image]

Revit 2013 API
PerformanceAdviserRuleId Constructor
PerformanceAdviserRuleId Class See Also Send Feedback
Creates a new PerformanceAdviserRuleId instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PerformanceAdviserRuleId(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
PerformanceAdviserRuleId(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the PerformanceAdviserRuleId.

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Methods

[image] [image]

Revit 2013 API
PerformanceAdviserRuleId Methods
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Operators

[image] [image]

Revit 2013 API
PerformanceAdviserRuleId Operators
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Operators

Name | Description
Equality | Compares two PerformanceAdviserRuleId instances.
Inequality | Compares two PerformanceAdviserRuleId instances.

See Also

PerformanceAdviserRuleId Class


Equality Operator

[image]

Revit 2013 API
PerformanceAdviserRuleId..::..Equality Operator
PerformanceAdviserRuleId Class See Also Send Feedback
Compares two PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    PerformanceAdviserRuleId first,
    PerformanceAdviserRuleId second
)
Visual Basic
Public Shared Operator = ( _
    first As PerformanceAdviserRuleId, _
    second As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
static bool operator ==(
    PerformanceAdviserRuleId^ first,
    PerformanceAdviserRuleId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The first PerformanceAdviserRuleId.
second
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The second PerformanceAdviserRuleId.

Return Value

True if the inputs are identical, false if they are different.

See Also

PerformanceAdviserRuleId Class


Inequality Operator

[image]

Revit 2013 API
PerformanceAdviserRuleId..::..Inequality Operator
PerformanceAdviserRuleId Class See Also Send Feedback
Compares two PerformanceAdviserRuleId instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    PerformanceAdviserRuleId first,
    PerformanceAdviserRuleId second
)
Visual Basic
Public Shared Operator <> ( _
    first As PerformanceAdviserRuleId, _
    second As PerformanceAdviserRuleId _
) As Boolean
Visual C++
public:
static bool operator !=(
    PerformanceAdviserRuleId^ first,
    PerformanceAdviserRuleId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The first PerformanceAdviserRuleId.
second
Type: Autodesk.Revit.DB..::..PerformanceAdviserRuleId
The second PerformanceAdviserRuleId.

Return Value

True if the inputs are different, false if they are identical.

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRuleId Properties

[image] [image]

Revit 2013 API
PerformanceAdviserRuleId Properties
PerformanceAdviserRuleId Class See Also Send Feedback

The PerformanceAdviserRuleId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

PerformanceAdviserRuleId Class


PerformanceAdviserRules Class

[image]

Revit 2013 API
PerformanceAdviserRules Class
See Also Send Feedback
Provides a container of all Revit built-in instances.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class PerformanceAdviserRules
Visual Basic
Public NotInheritable Class PerformanceAdviserRules
Visual C++
public ref class PerformanceAdviserRules abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PerformanceAdviserRules

See Also


Phase Class

[image]

Revit 2013 API
Phase Class
Members See Also Send Feedback
Represents a phase in the life of a building.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Phase : Element
Visual Basic
Public Class Phase _
    Inherits Element
Visual C++
public ref class Phase : public Element

Remarks

The lifetime of an element within a building can be controlled by using phases. Each element will have a construction phase but only those elements that have a finite lifetime will have a destruction phase. All the phases within a project can be retrieved from the Document object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Phase

See Also

Phase Members


Phase Members

[image] [image]

Revit 2013 API
Phase Members
Phase Class Methods Properties See Also Send Feedback

The Phase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Phase Class


Phase Methods

[image] [image]

Revit 2013 API
Phase Methods
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Phase Class


Phase Properties

[image] [image]

Revit 2013 API
Phase Properties
Phase Class See Also Send Feedback

The Phase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Phase Class


Parameter Property

[image] [image]

Revit 2013 API
Phase..::..Parameter Property
Phase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Phase Class
Phase Members


PhaseArray Class

[image]

Revit 2013 API
PhaseArray Class
Members See Also Send Feedback
An array that contains phase objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PhaseArray : APIObject, IEnumerable
Visual Basic
Public Class PhaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PhaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PhaseArray

See Also

PhaseArray Members


PhaseArray Members

[image] [image]

Revit 2013 API
PhaseArray Members
PhaseArray Class Constructors Methods Properties See Also Send Feedback

The PhaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseArray | Initializes a new instance of the PhaseArray class

Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class


PhaseArray Constructor

[image]

Revit 2013 API
PhaseArray Constructor
PhaseArray Class See Also Send Feedback
Initializes a new instance of the PhaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PhaseArray()
Visual Basic
Public Sub New
Visual C++
public:
PhaseArray()

See Also

PhaseArray Class


PhaseArray Methods

[image] [image]

Revit 2013 API
PhaseArray Methods
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the phase to the end of the array.
Public method | Clear | Removes every phase from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified phase into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArray Class


Append Method

[image]

Revit 2013 API
PhaseArray..::..Append Method
PhaseArray Class See Also Send Feedback
Add the phase to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Phase item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Phase _
)
Visual C++
public:
virtual void Append(
    Phase^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Phase
The phase to be added.

See Also

PhaseArray Class


Clear Method

[image]

Revit 2013 API
PhaseArray..::..Clear Method
PhaseArray Class See Also Send Feedback
Removes every phase from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PhaseArray Class


ForwardIterator Method

[image]

Revit 2013 API
PhaseArray..::..ForwardIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

PhaseArray Class


GetEnumerator Method

[image]

Revit 2013 API
PhaseArray..::..GetEnumerator Method
PhaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PhaseArray Class


Insert Method

[image]

Revit 2013 API
PhaseArray..::..Insert Method
PhaseArray Class See Also Send Feedback
Insert the specified phase into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Phase item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Phase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Phase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Phase
The phase to be inserted into the array.
index
Type: System..::..Int32
The phase will be inserted before this index.

Return Value

Returns whether the phase was inserted into the array.

See Also

PhaseArray Class


ReverseIterator Method

[image]

Revit 2013 API
PhaseArray..::..ReverseIterator Method
PhaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PhaseArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PhaseArrayIterator
Visual C++
public:
virtual PhaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

PhaseArray Class


PhaseArray Properties

[image] [image]

Revit 2013 API
PhaseArray Properties
PhaseArray Class See Also Send Feedback

The PhaseArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a phase at a specified index within the array.
Public property | Size | Returns the number of phases that are in the array.

See Also

PhaseArray Class


IsEmpty Property

[image]

Revit 2013 API
PhaseArray..::..IsEmpty Property
PhaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

PhaseArray Class


Item Property

[image]

Revit 2013 API
PhaseArray..::..Item Property
PhaseArray Class See Also Send Feedback
Gets or sets a phase at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Phase this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Phase
    Get
    Set
Visual C++
public:
virtual property Phase^ Item[int index] {
    Phase^ get (int index);
    void set (int index, Phase^ value);
}

Parameters

index
Type: System..::..Int32
The index of the phase to be set or retrieved.

Return Value

Returns the phase at the specified index.

See Also

PhaseArray Class


Size Property

[image]

Revit 2013 API
PhaseArray..::..Size Property
PhaseArray Class See Also Send Feedback
Returns the number of phases that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PhaseArray Class


PhaseArrayIterator Class

[image]

Revit 2013 API
PhaseArrayIterator Class
Members See Also Send Feedback
An iterator to a phase array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PhaseArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PhaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PhaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PhaseArrayIterator

See Also

PhaseArrayIterator Members


PhaseArrayIterator Members

[image] [image]

Revit 2013 API
PhaseArrayIterator Members
PhaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PhaseArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class


PhaseArrayIterator Constructor

[image]

Revit 2013 API
PhaseArrayIterator Constructor
PhaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PhaseArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
PhaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PhaseArrayIterator Class


PhaseArrayIterator Methods

[image] [image]

Revit 2013 API
PhaseArrayIterator Methods
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
PhaseArrayIterator..::..MoveNext Method
PhaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


Reset Method

[image]

Revit 2013 API
PhaseArrayIterator..::..Reset Method
PhaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PhaseArrayIterator Class


PhaseArrayIterator Properties

[image] [image]

Revit 2013 API
PhaseArrayIterator Properties
PhaseArrayIterator Class See Also Send Feedback

The PhaseArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PhaseArrayIterator Class


Current Property

[image]

Revit 2013 API
PhaseArrayIterator..::..Current Property
PhaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PhaseArrayIterator Class


PhaseFilter Class

[image]

Revit 2013 API
PhaseFilter Class
Members See Also Send Feedback
Represents an phase filter within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PhaseFilter : Element
Visual Basic
Public Class PhaseFilter _
    Inherits Element
Visual C++
public ref class PhaseFilter : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PhaseFilter

See Also

PhaseFilter Members


PhaseFilter Members

[image] [image]

Revit 2013 API
PhaseFilter Members
PhaseFilter Class Methods Properties See Also Send Feedback

The PhaseFilter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new phase filter with default status presentation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PhaseFilter Class


PhaseFilter Methods

[image] [image]

Revit 2013 API
PhaseFilter Methods
PhaseFilter Class See Also Send Feedback

The PhaseFilter type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new phase filter with default status presentation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPhaseStatusPresentation | Gets the phase status presentation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPhaseStatusPresentation | Sets the phase status presentation.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhaseFilter Class


Create Method

[image]

Revit 2013 API
PhaseFilter..::..Create Method
PhaseFilter Class See Also Send Feedback
Creates a new phase filter with default status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PhaseFilter Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As PhaseFilter
Visual C++
public:
static PhaseFilter^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
name
Type: System..::..String
The name.

Return Value

The newly created phase filter.

Remarks

The default status presentation is ShowByCategory for New status, and ShowOverriden for Existing, Demolished and Temporary statuses.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is already in use.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PhaseFilter Class


GetPhaseStatusPresentation Method

[image]

Revit 2013 API
PhaseFilter..::..GetPhaseStatusPresentation Method
PhaseFilter Class See Also Send Feedback
Gets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)
Visual Basic
Public Function GetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus _
) As PhaseStatusPresentation
Visual C++
public:
PhaseStatusPresentation GetPhaseStatusPresentation(
    ElementOnPhaseStatus status
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.

Return Value

The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.

See Also

PhaseFilter Class


SetPhaseStatusPresentation Method

[image]

Revit 2013 API
PhaseFilter..::..SetPhaseStatusPresentation Method
PhaseFilter Class See Also Send Feedback
Sets the phase status presentation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)
Visual Basic
Public Sub SetPhaseStatusPresentation ( _
    status As ElementOnPhaseStatus, _
    presentation As PhaseStatusPresentation _
)
Visual C++
public:
void SetPhaseStatusPresentation(
    ElementOnPhaseStatus status,
    PhaseStatusPresentation presentation
)

Parameters

status
Type: Autodesk.Revit.DB..::..ElementOnPhaseStatus
The element phase status.
presentation
Type: Autodesk.Revit.DB..::..PhaseStatusPresentation
The phase status presentation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | status is invalid for presentation query.

See Also

PhaseFilter Class


PhaseFilter Properties

[image] [image]

Revit 2013 API
PhaseFilter Properties
PhaseFilter Class See Also Send Feedback

The PhaseFilter type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates whether this filter is the default one.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PhaseFilter Class


IsDefault Property

[image]

Revit 2013 API
PhaseFilter..::..IsDefault Property
PhaseFilter Class See Also Send Feedback
Indicates whether this filter is the default one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get
Visual C++
public:
property bool IsDefault {
    bool get ();
}

See Also

PhaseFilter Class


Parameter Property

[image] [image]

Revit 2013 API
PhaseFilter..::..Parameter Property
PhaseFilter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PhaseFilter Class
PhaseFilter Members


PhaseStatusPresentation Enumeration

[image]

Revit 2013 API
PhaseStatusPresentation Enumeration
See Also Send Feedback
An enumerated type listing the options for element display in a phase filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PhaseStatusPresentation
Visual Basic
Public Enumeration PhaseStatusPresentation
Visual C++
public enum class PhaseStatusPresentation

Members

Member name | Description
DontShow | Don't show elements from the given phase status.
ShowByCategory | Show elements from the given phase status by category.
ShowOverriden | Show elements from the given phase status by graphics overrides.

See Also


PlanarFace Class

[image]

Revit 2013 API
PlanarFace Class
Members Example See Also Send Feedback
A planar face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanarFace : Face
Visual Basic
Public Class PlanarFace _
    Inherits Face
Visual C++
public ref class PlanarFace : public Face

Remarks

Planar faces are defined by planes bounded by edge loops. The planes provide natural UV parameterization to the faces. S(u, v) = Origin + u*Vector[0] + v*Vector[1]

Examples

CopyC#
private void GetPlanarFaceInfo(Face face)
{
    PlanarFace planarFace = face as PlanarFace;
    if (null != planarFace)
    {
       XYZ origin = planarFace.Origin;
        XYZ normal = planarFace.Normal;
        XYZ vector = planarFace.get_Vector(0);
    }
}
CopyVB.NET
Private Sub GetPlanarFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim planarFace As PlanarFace = TryCast(face, PlanarFace)
    If planarFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = planarFace.Origin
        Dim normal As Autodesk.Revit.DB.XYZ = planarFace.Normal
        Dim vector As Autodesk.Revit.DB.XYZ = planarFace.Vector(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..PlanarFace

See Also

PlanarFace Members


PlanarFace Members

[image] [image]

Revit 2013 API
PlanarFace Members
PlanarFace Class Methods Properties See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Normal | Normal of the surface.
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Vector | Defining vectors of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class


PlanarFace Methods

[image] [image]

Revit 2013 API
PlanarFace Methods
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

PlanarFace Class


Intersect Method

[image] [image]

Revit 2013 API
PlanarFace..::..Intersect Method
PlanarFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


IsInside Method

[image] [image]

Revit 2013 API
PlanarFace..::..IsInside Method
PlanarFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


Triangulate Method

[image] [image]

Revit 2013 API
PlanarFace..::..Triangulate Method
PlanarFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

PlanarFace Class
PlanarFace Members


PlanarFace Properties

[image] [image]

Revit 2013 API
PlanarFace Properties
PlanarFace Class See Also Send Feedback

The PlanarFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Normal | Normal of the surface.
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Vector | Defining vectors of the surface.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PlanarFace Class


Normal Property

[image]

Revit 2013 API
PlanarFace..::..Normal Property
PlanarFace Class See Also Send Feedback
Normal of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is the "surface normal" vector. This is not necessarily the normal vector pointing out of the solid that contains the face, to get that value use ComputeNormal(UV).

See Also

PlanarFace Class


Origin Property

[image]

Revit 2013 API
PlanarFace..::..Origin Property
PlanarFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

PlanarFace Class


Vector Property

[image]

Revit 2013 API
PlanarFace..::..Vector Property
PlanarFace Class See Also Send Feedback
Defining vectors of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Vector ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Vector[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

PlanarFace Class


PlanCircuit Class

[image]

Revit 2013 API
PlanCircuit Class
Members See Also Send Feedback
An object that represents an enclosed area in a plan view within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanCircuit : APIObject
Visual Basic
Public Class PlanCircuit _
    Inherits APIObject
Visual C++
public ref class PlanCircuit : public APIObject

Remarks

Plan circuits are enclosed regions as seen on a plan view. They are used to determine the boundary extents of rooms based on the placement of walls. In the Autodesk Revit API, you can use plan circuits to create new rooms.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuit

See Also

PlanCircuit Members


PlanCircuit Members

[image] [image]

Revit 2013 API
PlanCircuit Members
PlanCircuit Class Methods Properties See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


PlanCircuit Methods

[image] [image]

Revit 2013 API
PlanCircuit Methods
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuit Class


PlanCircuit Properties

[image] [image]

Revit 2013 API
PlanCircuit Properties
PlanCircuit Class See Also Send Feedback

The PlanCircuit type exposes the following members.

Properties

 | Name | Description
Public property | Area | The enclosed area of the circuit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsRoomLocated | Reports whether there is a room located in this circuit.
Public property | SideNum | The number of sides in the circuit.

See Also

PlanCircuit Class


Area Property

[image]

Revit 2013 API
PlanCircuit..::..Area Property
PlanCircuit Class See Also Send Feedback
The enclosed area of the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

See Also

PlanCircuit Class


IsRoomLocated Property

[image]

Revit 2013 API
PlanCircuit..::..IsRoomLocated Property
PlanCircuit Class See Also Send Feedback
Reports whether there is a room located in this circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRoomLocated { get; }
Visual Basic
Public ReadOnly Property IsRoomLocated As Boolean
    Get
Visual C++
public:
property bool IsRoomLocated {
    bool get ();
}

Field Value

True if there is a room located in this circuit on the circuit's level, false if there is no room located in this circuit on the circuit's level.

See Also

PlanCircuit Class


SideNum Property

[image]

Revit 2013 API
PlanCircuit..::..SideNum Property
PlanCircuit Class See Also Send Feedback
The number of sides in the circuit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int SideNum { get; }
Visual Basic
Public ReadOnly Property SideNum As Integer
    Get
Visual C++
public:
property int SideNum {
    int get ();
}

See Also

PlanCircuit Class


PlanCircuitSet Class

[image]

Revit 2013 API
PlanCircuitSet Class
Members See Also Send Feedback
A set that can contain any number of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanCircuitSet : APIObject,
    IEnumerable
Visual Basic
Public Class PlanCircuitSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanCircuitSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuitSet

See Also

PlanCircuitSet Members


PlanCircuitSet Members

[image] [image]

Revit 2013 API
PlanCircuitSet Members
PlanCircuitSet Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Constructors

 | Name | Description
Public method | PlanCircuitSet | Initializes a new instance of the PlanCircuitSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Constructor

[image]

Revit 2013 API
PlanCircuitSet Constructor
PlanCircuitSet Class See Also Send Feedback
Initializes a new instance of the PlanCircuitSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanCircuitSet()
Visual Basic
Public Sub New
Visual C++
public:
PlanCircuitSet()

See Also

PlanCircuitSet Class


PlanCircuitSet Methods

[image] [image]

Revit 2013 API
PlanCircuitSet Methods
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSet Class


Clear Method

[image]

Revit 2013 API
PlanCircuitSet..::..Clear Method
PlanCircuitSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanCircuitSet Class


Contains Method

[image]

Revit 2013 API
PlanCircuitSet..::..Contains Method
PlanCircuitSet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanCircuit item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanCircuit
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanCircuitSet Class


Erase Method

[image]

Revit 2013 API
PlanCircuitSet..::..Erase Method
PlanCircuitSet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PlanCircuit item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PlanCircuit _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanCircuit
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanCircuitSet Class


ForwardIterator Method

[image]

Revit 2013 API
PlanCircuitSet..::..ForwardIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanCircuitSet Class


GetEnumerator Method

[image]

Revit 2013 API
PlanCircuitSet..::..GetEnumerator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PlanCircuitSet Class


Insert Method

[image]

Revit 2013 API
PlanCircuitSet..::..Insert Method
PlanCircuitSet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanCircuit item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PlanCircuit _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanCircuit^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanCircuit
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanCircuitSet Class


ReverseIterator Method

[image]

Revit 2013 API
PlanCircuitSet..::..ReverseIterator Method
PlanCircuitSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PlanCircuitSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PlanCircuitSetIterator
Visual C++
public:
virtual PlanCircuitSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanCircuitSet Class


PlanCircuitSet Properties

[image] [image]

Revit 2013 API
PlanCircuitSet Properties
PlanCircuitSet Class See Also Send Feedback

The PlanCircuitSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanCircuitSet Class


IsEmpty Property

[image]

Revit 2013 API
PlanCircuitSet..::..IsEmpty Property
PlanCircuitSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanCircuitSet Class


Size Property

[image]

Revit 2013 API
PlanCircuitSet..::..Size Property
PlanCircuitSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanCircuitSet Class


PlanCircuitSetIterator Class

[image]

Revit 2013 API
PlanCircuitSetIterator Class
Members See Also Send Feedback
An iterator to a set of plan circuit objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PlanCircuitSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PlanCircuitSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanCircuitSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanCircuitSetIterator

See Also

PlanCircuitSetIterator Members


PlanCircuitSetIterator Members

[image] [image]

Revit 2013 API
PlanCircuitSetIterator Members
PlanCircuitSetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PlanCircuitSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Constructor

[image]

Revit 2013 API
PlanCircuitSetIterator Constructor
PlanCircuitSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanCircuitSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PlanCircuitSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Methods

[image] [image]

Revit 2013 API
PlanCircuitSetIterator Methods
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanCircuitSetIterator Class


MoveNext Method

[image]

Revit 2013 API
PlanCircuitSetIterator..::..MoveNext Method
PlanCircuitSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class


Reset Method

[image]

Revit 2013 API
PlanCircuitSetIterator..::..Reset Method
PlanCircuitSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanCircuitSetIterator Class


PlanCircuitSetIterator Properties

[image] [image]

Revit 2013 API
PlanCircuitSetIterator Properties
PlanCircuitSetIterator Class See Also Send Feedback

The PlanCircuitSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanCircuitSetIterator Class


Current Property

[image]

Revit 2013 API
PlanCircuitSetIterator..::..Current Property
PlanCircuitSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanCircuitSetIterator Class


Plane Class

[image]

Revit 2013 API
Plane Class
Members Example See Also Send Feedback
Provides access to the geometry plane object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Plane : APIObject
Visual Basic
Public Class Plane _
    Inherits APIObject
Visual C++
public ref class Plane : public APIObject

Remarks

The user can construct a plane object, get or set the vectors and origin through this class.

Examples

CopyC#
public void GetPlaneInfo(Plane plane)
{
    XYZ origin = plane.Origin;
    XYZ normal = plane.Normal;
    XYZ xVec = plane.XVec;
    XYZ yVec = plane.YVec;

    StringBuilder info = new StringBuilder();
    info.AppendLine("Plane Data:");
    info.AppendLine(string.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z));
    info.AppendLine(string.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z));
    info.AppendLine(string.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z));
    info.AppendLine(string.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z));

    TaskDialog.Show("Revit",info.ToString());
}
CopyVB.NET
Public Sub GetPlaneInfo(ByVal plane As Autodesk.Revit.DB.Plane)
    Dim origin As Autodesk.Revit.DB.XYZ = plane.Origin
    Dim normal As Autodesk.Revit.DB.XYZ = plane.Normal
    Dim xVec As Autodesk.Revit.DB.XYZ = plane.XVec
    Dim yVec As Autodesk.Revit.DB.XYZ = plane.YVec

    Dim info As New StringBuilder()
    info.AppendLine("Plane Data:")
    info.AppendLine(String.Format("     Origin: ({0},{1},{2})", origin.X, origin.Y, origin.Z))
    info.AppendLine(String.Format("     Normal: ({0},{1},{2})", normal.X, normal.Y, normal.Z))
    info.AppendLine(String.Format("     XVec: ({0},{1},{2})", xVec.X, xVec.Y, xVec.Z))
    info.AppendLine(String.Format("     YVec: ({0},{1},{2})", yVec.X, yVec.Y, yVec.Z))

    TaskDialog.Show("Revit", info.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Plane

See Also

Plane Members


Plane Members

[image] [image]

Revit 2013 API
Plane Members
Plane Class Constructors Methods Properties See Also Send Feedback

The Plane type exposes the following members.

Constructors

 | Name | Description
Public method | Plane(XYZ, XYZ) | Constructor for geometry plane.
Public method | Plane(XYZ, XYZ, XYZ) | Constructor for geometry plane.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Normal | Get the Normal of the plane.
Public property | Origin | Get the Origin of the plane.
Public property | XVec | Get the XVec of the plane.
Public property | YVec | Get the YVec of the plane.

See Also

Plane Class


Plane Constructor

[image] [image]

Revit 2013 API
Plane Constructor
Plane Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Plane(XYZ, XYZ) | Constructor for geometry plane.
Public method | Plane(XYZ, XYZ, XYZ) | Constructor for geometry plane.

See Also

Plane Class
Plane Members


Plane Constructor (XYZ, XYZ)

[image]

Revit 2013 API
Plane Constructor (XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane(
    XYZ norm,
    XYZ origin
)
Visual Basic
Public Sub New ( _
    norm As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ norm,
    XYZ^ origin
)

Parameters

norm
Type: Autodesk.Revit.DB..::..XYZ
The normal vector of the plane.
origin
Type: Autodesk.Revit.DB..::..XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload


Plane Constructor (XYZ, XYZ, XYZ)

[image]

Revit 2013 API
Plane Constructor (XYZ, XYZ, XYZ)
Plane Class See Also Send Feedback
Constructor for geometry plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane(
    XYZ xVec,
    XYZ yVec,
    XYZ origin
)
Visual Basic
Public Sub New ( _
    xVec As XYZ, _
    yVec As XYZ, _
    origin As XYZ _
)
Visual C++
public:
Plane(
    XYZ^ xVec,
    XYZ^ yVec,
    XYZ^ origin
)

Parameters

xVec
Type: Autodesk.Revit.DB..::..XYZ
The vector for x-axis.
yVec
Type: Autodesk.Revit.DB..::..XYZ
The vector for y-axis.
origin
Type: Autodesk.Revit.DB..::..XYZ
The coordinates for the origin.

Remarks

Used to construct a new Plane object.

See Also

Plane Class
Plane Overload


Plane Methods

[image] [image]

Revit 2013 API
Plane Methods
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Plane Class


Plane Properties

[image] [image]

Revit 2013 API
Plane Properties
Plane Class See Also Send Feedback

The Plane type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Normal | Get the Normal of the plane.
Public property | Origin | Get the Origin of the plane.
Public property | XVec | Get the XVec of the plane.
Public property | YVec | Get the YVec of the plane.

See Also

Plane Class


Normal Property

[image]

Revit 2013 API
Plane..::..Normal Property
Plane Class See Also Send Feedback
Get the Normal of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

Remarks

This property is used to get the Normal of the plane.

See Also

Plane Class


Origin Property

[image]

Revit 2013 API
Plane..::..Origin Property
Plane Class See Also Send Feedback
Get the Origin of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Remarks

This property is used to get the Origin of the plane.

See Also

Plane Class


XVec Property

[image]

Revit 2013 API
Plane..::..XVec Property
Plane Class See Also Send Feedback
Get the XVec of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ XVec { get; }
Visual Basic
Public ReadOnly Property XVec As XYZ
    Get
Visual C++
public:
property XYZ^ XVec {
    XYZ^ get ();
}

Remarks

This property is used to get the XVec of the plane.

See Also

Plane Class


YVec Property

[image]

Revit 2013 API
Plane..::..YVec Property
Plane Class See Also Send Feedback
Get the YVec of the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ YVec { get; }
Visual Basic
Public ReadOnly Property YVec As XYZ
    Get
Visual C++
public:
property XYZ^ YVec {
    XYZ^ get ();
}

Remarks

This property is used to get the YVec of the plane.

See Also

Plane Class


PlanTopology Class

[image]

Revit 2013 API
PlanTopology Class
Members See Also Send Feedback
An object that represents a Plan Topology within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanTopology : APIObject
Visual Basic
Public Class PlanTopology _
    Inherits APIObject
Visual C++
public ref class PlanTopology : public APIObject

Remarks

This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopology

See Also

PlanTopology Members


PlanTopology Members

[image] [image]

Revit 2013 API
PlanTopology Members
PlanTopology Class Methods Properties See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

 | Name | Description
Public method | ~PlanTopology |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Public property | Rooms | Obsolete. Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class


PlanTopology Methods

[image] [image]

Revit 2013 API
PlanTopology Methods
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Methods

 | Name | Description
Public method | ~PlanTopology |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoomIds | Retrieves room ElementIds of the PlanTopology in the last phase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopology Class


~PlanTopology Method

[image]

Revit 2013 API
PlanTopology..::..~PlanTopology Method
PlanTopology Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ~PlanTopology()
Visual Basic
Public Sub ~PlanTopology
Visual C++
public:
void ~PlanTopology()

See Also

PlanTopology Class


GetRoomIds Method

[image]

Revit 2013 API
PlanTopology..::..GetRoomIds Method
PlanTopology Class See Also Send Feedback
Retrieves room ElementIds of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetRoomIds()
Visual Basic
Public Function GetRoomIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetRoomIds()

Return Value

The PlanTopology Room ElementIds of the last phase.

Remarks

The Rooms Ids returned are in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class


PlanTopology Properties

[image] [image]

Revit 2013 API
PlanTopology Properties
PlanTopology Class See Also Send Feedback

The PlanTopology type exposes the following members.

Properties

 | Name | Description
Public property | Circuits | The Circuits of the PlanTopology.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Level | The Level of the PlanTopology.
Public property | Phase | The phase of the PlanTopology.
Public property | Rooms | Obsolete. Retrieves rooms of the PlanTopology in the last phase.

See Also

PlanTopology Class


Circuits Property

[image]

Revit 2013 API
PlanTopology..::..Circuits Property
PlanTopology Class See Also Send Feedback
The Circuits of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanCircuitSet Circuits { get; }
Visual Basic
Public ReadOnly Property Circuits As PlanCircuitSet
    Get
Visual C++
public:
property PlanCircuitSet^ Circuits {
    PlanCircuitSet^ get ();
}

See Also

PlanTopology Class


Level Property

[image]

Revit 2013 API
PlanTopology..::..Level Property
PlanTopology Class See Also Send Feedback
The Level of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level Level { get; }
Visual Basic
Public ReadOnly Property Level As Level
    Get
Visual C++
public:
property Level^ Level {
    Level^ get ();
}

See Also

PlanTopology Class


Phase Property

[image]

Revit 2013 API
PlanTopology..::..Phase Property
PlanTopology Class See Also Send Feedback
The phase of the PlanTopology.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic
Public ReadOnly Property Phase As Phase
    Get
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

See Also

PlanTopology Class


Rooms Property

[image]

Revit 2013 API
PlanTopology..::..Rooms Property
PlanTopology Class See Also Send Feedback
Retrieves rooms of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")]
public ElementSet Rooms { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")> _
Public ReadOnly Property Rooms As ElementSet
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Call GetRoomIds() instead.")]
public:
property ElementSet^ Rooms {
    ElementSet^ get ();
}

Remarks

The Rooms returned are in the phase of PlanTopology and the current design option.

See Also

PlanTopology Class


PlanTopologySet Class

[image]

Revit 2013 API
PlanTopologySet Class
Members See Also Send Feedback
A set that can contain any number of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PlanTopologySet : APIObject,
    IEnumerable
Visual Basic
Public Class PlanTopologySet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PlanTopologySet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopologySet

See Also

PlanTopologySet Members


PlanTopologySet Members

[image] [image]

Revit 2013 API
PlanTopologySet Members
PlanTopologySet Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySet type exposes the following members.

Constructors

 | Name | Description
Public method | PlanTopologySet | Initializes a new instance of the PlanTopologySet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


PlanTopologySet Constructor

[image]

Revit 2013 API
PlanTopologySet Constructor
PlanTopologySet Class See Also Send Feedback
Initializes a new instance of the PlanTopologySet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopologySet()
Visual Basic
Public Sub New
Visual C++
public:
PlanTopologySet()

See Also

PlanTopologySet Class


PlanTopologySet Methods

[image] [image]

Revit 2013 API
PlanTopologySet Methods
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains | Tests for the existence of an item within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified object from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySet Class


Clear Method

[image]

Revit 2013 API
PlanTopologySet..::..Clear Method
PlanTopologySet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PlanTopologySet Class


Contains Method

[image]

Revit 2013 API
PlanTopologySet..::..Contains Method
PlanTopologySet Class See Also Send Feedback
Tests for the existence of an item within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PlanTopology item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanTopology
The item to be searched for.

Return Value

The Contains method returns True if the item is within the set, otherwise False.

See Also

PlanTopologySet Class


Erase Method

[image]

Revit 2013 API
PlanTopologySet..::..Erase Method
PlanTopologySet Class See Also Send Feedback
Removes a specified object from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PlanTopology item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PlanTopology _
) As Integer
Visual C++
public:
virtual int Erase(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanTopology
The item to be erased.

Return Value

The number of items that were erased from the set.

See Also

PlanTopologySet Class


ForwardIterator Method

[image]

Revit 2013 API
PlanTopologySet..::..ForwardIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PlanTopologySet Class


GetEnumerator Method

[image]

Revit 2013 API
PlanTopologySet..::..GetEnumerator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PlanTopologySet Class


Insert Method

[image]

Revit 2013 API
PlanTopologySet..::..Insert Method
PlanTopologySet Class See Also Send Feedback
Insert the specified item into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PlanTopology item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PlanTopology _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PlanTopology^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..PlanTopology
The item to be inserted into the set.

Return Value

Returns whether the item was inserted into the set.

See Also

PlanTopologySet Class


ReverseIterator Method

[image]

Revit 2013 API
PlanTopologySet..::..ReverseIterator Method
PlanTopologySet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PlanTopologySetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PlanTopologySetIterator
Visual C++
public:
virtual PlanTopologySetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PlanTopologySet Class


PlanTopologySet Properties

[image] [image]

Revit 2013 API
PlanTopologySet Properties
PlanTopologySet Class See Also Send Feedback

The PlanTopologySet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

PlanTopologySet Class


IsEmpty Property

[image]

Revit 2013 API
PlanTopologySet..::..IsEmpty Property
PlanTopologySet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PlanTopologySet Class


Size Property

[image]

Revit 2013 API
PlanTopologySet..::..Size Property
PlanTopologySet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PlanTopologySet Class


PlanTopologySetIterator Class

[image]

Revit 2013 API
PlanTopologySetIterator Class
Members See Also Send Feedback
An iterator to a set of plan topology objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PlanTopologySetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PlanTopologySetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PlanTopologySetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PlanTopologySetIterator

See Also

PlanTopologySetIterator Members


PlanTopologySetIterator Members

[image] [image]

Revit 2013 API
PlanTopologySetIterator Members
PlanTopologySetIterator Class Constructors Methods Properties See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PlanTopologySetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Constructor

[image]

Revit 2013 API
PlanTopologySetIterator Constructor
PlanTopologySetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PlanTopologySetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PlanTopologySetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Methods

[image] [image]

Revit 2013 API
PlanTopologySetIterator Methods
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanTopologySetIterator Class


MoveNext Method

[image]

Revit 2013 API
PlanTopologySetIterator..::..MoveNext Method
PlanTopologySetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


Reset Method

[image]

Revit 2013 API
PlanTopologySetIterator..::..Reset Method
PlanTopologySetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PlanTopologySetIterator Class


PlanTopologySetIterator Properties

[image] [image]

Revit 2013 API
PlanTopologySetIterator Properties
PlanTopologySetIterator Class See Also Send Feedback

The PlanTopologySetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PlanTopologySetIterator Class


Current Property

[image]

Revit 2013 API
PlanTopologySetIterator..::..Current Property
PlanTopologySetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PlanTopologySetIterator Class


PlanViewDirection Enumeration

[image]

Revit 2013 API
PlanViewDirection Enumeration
See Also Send Feedback
This enumerated type represents the possible directions for a plan view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PlanViewDirection
Visual Basic
Public Enumeration PlanViewDirection
Visual C++
public enum class PlanViewDirection

Members

Member name | Description
Undefined | View does not use Plan View Direction
Down | Revit looks down onto the plan view
Up | Revit looks up to the plan view

See Also


PlanViewPlane Enumeration

[image]

Revit 2013 API
PlanViewPlane Enumeration
See Also Send Feedback
Locations where view range offsets can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PlanViewPlane
Visual Basic
Public Enumeration PlanViewPlane
Visual C++
public enum class PlanViewPlane

Members

Member name | Description
CutPlane | Cut Plane
TopClipPlane | Top Clip Plane
BottomClipPlane | Bottom Clip Plane
ViewDepthPlane | View Depth Plane
UnderlayBottom | Underlay Bottom Plane

See Also


PlanViewRange Class

[image]

Revit 2013 API
PlanViewRange Class
Members See Also Send Feedback
This class represents the view range of a plan view or a plan region. It records the element ids of the levels which a plane is relative to and the offset of each plane from that level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PlanViewRange : IDisposable
Visual Basic
Public Class PlanViewRange _
    Implements IDisposable
Visual C++
public ref class PlanViewRange : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PlanViewRange

See Also

PlanViewRange Members


PlanViewRange Members

[image] [image]

Revit 2013 API
PlanViewRange Members
PlanViewRange Class Methods Properties See Also Send Feedback

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PlanViewRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | View range for the current plane
Public property | LevelAbove | View range for the level above the specified plane
Public property | LevelBelow | View range for the level below the specified plane
Public property | Unlimited | View range is unlimited

See Also

PlanViewRange Class


PlanViewRange Methods

[image] [image]

Revit 2013 API
PlanViewRange Methods
PlanViewRange Class See Also Send Feedback

The PlanViewRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelId | Get the element id of the level for a View Depth plane
Public method | GetOffset | Get the offset value associated with a View Depth plane
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLevelId | Set the level for a View Depth plane
Public method | SetOffset | Set the offset value associated with a View Depth plane
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlanViewRange Class


Dispose Method

[image]

Revit 2013 API
PlanViewRange..::..Dispose Method
PlanViewRange Class See Also Send Feedback
Releases all resources used by the PlanViewRange

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PlanViewRange Class


GetLevelId Method

[image]

Revit 2013 API
PlanViewRange..::..GetLevelId Method
PlanViewRange Class See Also Send Feedback
Get the element id of the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetLevelId(
    PlanViewPlane planViewPlane
)
Visual Basic
Public Function GetLevelId ( _
    planViewPlane As PlanViewPlane _
) As ElementId
Visual C++
public:
ElementId^ GetLevelId(
    PlanViewPlane planViewPlane
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
The plane whose level will be returned

Return Value

Id of the level

See Also

PlanViewRange Class


GetOffset Method

[image]

Revit 2013 API
PlanViewRange..::..GetOffset Method
PlanViewRange Class See Also Send Feedback
Get the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetOffset(
    PlanViewPlane planViewPlane
)
Visual Basic
Public Function GetOffset ( _
    planViewPlane As PlanViewPlane _
) As Double
Visual C++
public:
double GetOffset(
    PlanViewPlane planViewPlane
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
View Depth plane

Return Value

Offset value

See Also

PlanViewRange Class


SetLevelId Method

[image]

Revit 2013 API
PlanViewRange..::..SetLevelId Method
PlanViewRange Class See Also Send Feedback
Set the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId id
)
Visual Basic
Public Sub SetLevelId ( _
    planViewPlane As PlanViewPlane, _
    id As ElementId _
)
Visual C++
public:
void SetLevelId(
    PlanViewPlane planViewPlane,
    ElementId^ id
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
The View Depth plane
id
Type: Autodesk.Revit.DB..::..ElementId
Id of the level

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlanViewRange Class


SetOffset Method

[image]

Revit 2013 API
PlanViewRange..::..SetOffset Method
PlanViewRange Class See Also Send Feedback
Set the offset value associated with a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)
Visual Basic
Public Sub SetOffset ( _
    planViewPlane As PlanViewPlane, _
    offset As Double _
)
Visual C++
public:
void SetOffset(
    PlanViewPlane planViewPlane,
    double offset
)

Parameters

planViewPlane
Type: Autodesk.Revit.DB..::..PlanViewPlane
View Depth plane
offset
Type: System..::..Double
Offset value

See Also

PlanViewRange Class


PlanViewRange Properties

[image] [image]

Revit 2013 API
PlanViewRange Properties
PlanViewRange Class See Also Send Feedback

The PlanViewRange type exposes the following members.

Properties

 | Name | Description
Public property | Current | View range for the current plane
Public property | LevelAbove | View range for the level above the specified plane
Public property | LevelBelow | View range for the level below the specified plane
Public property | Unlimited | View range is unlimited

See Also

PlanViewRange Class


Current Property

[image]

Revit 2013 API
PlanViewRange..::..Current Property
PlanViewRange Class See Also Send Feedback
View range for the current plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Current { get; }
Visual Basic
Public ReadOnly Property Current As ElementId
    Get
Visual C++
public:
property ElementId^ Current {
    ElementId^ get ();
}

See Also

PlanViewRange Class


LevelAbove Property

[image]

Revit 2013 API
PlanViewRange..::..LevelAbove Property
PlanViewRange Class See Also Send Feedback
View range for the level above the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId LevelAbove { get; }
Visual Basic
Public ReadOnly Property LevelAbove As ElementId
    Get
Visual C++
public:
property ElementId^ LevelAbove {
    ElementId^ get ();
}

See Also

PlanViewRange Class


LevelBelow Property

[image]

Revit 2013 API
PlanViewRange..::..LevelBelow Property
PlanViewRange Class See Also Send Feedback
View range for the level below the specified plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId LevelBelow { get; }
Visual Basic
Public ReadOnly Property LevelBelow As ElementId
    Get
Visual C++
public:
property ElementId^ LevelBelow {
    ElementId^ get ();
}

See Also

PlanViewRange Class


Unlimited Property

[image]

Revit 2013 API
PlanViewRange..::..Unlimited Property
PlanViewRange Class See Also Send Feedback
View range is unlimited

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Unlimited { get; }
Visual Basic
Public ReadOnly Property Unlimited As ElementId
    Get
Visual C++
public:
property ElementId^ Unlimited {
    ElementId^ get ();
}

See Also

PlanViewRange Class


PlanViewRangeError Enumeration

[image]

Revit 2013 API
PlanViewRangeError Enumeration
See Also Send Feedback
Describes errors in the location of planes in a PlanViewRange object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PlanViewRangeError
Visual Basic
Public Enumeration PlanViewRangeError
Visual C++
public enum class PlanViewRangeError

Members

Member name | Description
TopClipBelowCutPlane | Top clip plane is below the cut plane.
BottomClipAboveCutPlane | Bottom clip plane is above the cut plane.
ViewDepthAboveBottomClip | View depth is above the bottom clip plane.
ViewDepthBelowTopClip | View depth is below the top clip plane.

See Also


PlanViewRangeLevel Enumeration

[image]

Revit 2013 API
PlanViewRangeLevel Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PlanViewRangeLevel
Visual Basic
Public Enumeration PlanViewRangeLevel
Visual C++
public enum class PlanViewRangeLevel

Members

Member name | Description
Unused |
Below | View range is the level below
Current | View range is the current level
Above | View range is the level above
Unlimited | View range is unlimited

See Also


Point Class

[image]

Revit 2013 API
Point Class
Members See Also Send Feedback
A 3D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Point : GeometryObject
Visual Basic
Public Class Point _
    Inherits GeometryObject
Visual C++
public ref class Point : public GeometryObject

Remarks

The point lies at a given XYZ coordinate location.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Point

See Also

Point Members


Point Members

[image] [image]

Revit 2013 API
Point Members
Point Class Methods Properties See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Coord | Returns the coordinates of the point.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the point.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class


Point Methods

[image] [image]

Revit 2013 API
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class


Point Properties

[image] [image]

Revit 2013 API
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

 | Name | Description
Public property | Coord | Returns the coordinates of the point.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Reference | Returns a stable reference to the point.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Point Class


Coord Property

[image]

Revit 2013 API
Point..::..Coord Property
Point Class See Also Send Feedback
Returns the coordinates of the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Coord { get; }
Visual Basic
Public ReadOnly Property Coord As XYZ
    Get
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
}

See Also

Point Class


Reference Property

[image]

Revit 2013 API
Point..::..Reference Property
Point Class See Also Send Feedback
Returns a stable reference to the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

Point Class


PointCloudFoundStatus Enumeration

[image]

Revit 2013 API
PointCloudFoundStatus Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum PointCloudFoundStatus
Visual Basic
Public Enumeration PointCloudFoundStatus
Visual C++
public enum class PointCloudFoundStatus

Members

Member name | Description
Unknown | Initial state. Loading of the Point Cloud hasn't been attempted.
NotFound | File-based Point Cloud cannot be located and hence can't be loaded.
FoundOK | File-based Point Cloud has been located and can be loaded.

See Also


PointCloudInstance Class

[image]

Revit 2013 API
PointCloudInstance Class
Members See Also Send Feedback
Represents a single instance of a point cloud in the Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointCloudInstance : Instance
Visual Basic
Public Class PointCloudInstance _
    Inherits Instance
Visual C++
public ref class PointCloudInstance : public Instance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..PointCloudInstance

See Also

PointCloudInstance Members


PointCloudInstance Members

[image] [image]

Revit 2013 API
PointCloudInstance Members
PointCloudInstance Class Methods Properties See Also Send Feedback

The PointCloudInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoints | Extracts a collection of points based on a filter.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudInstance Class


PointCloudInstance Methods

[image] [image]

Revit 2013 API
PointCloudInstance Methods
PointCloudInstance Class See Also Send Feedback

The PointCloudInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a point cloud based on an input point cloud type and transformation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoints | Extracts a collection of points based on a filter.
Public method | GetSelectionFilter | Returns the currently active selection filter for this point cloud.
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetSelectionFilter | Sets active selection filter by cloning of the one passed to it.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudInstance Class


Create Method

[image]

Revit 2013 API
PointCloudInstance..::..Create Method
PointCloudInstance Class See Also Send Feedback
Creates a new instance of a point cloud based on an input point cloud type and transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PointCloudInstance Create(
    Document document,
    ElementId typeId,
    Transform transform
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    typeId As ElementId, _
    transform As Transform _
) As PointCloudInstance
Visual C++
public:
static PointCloudInstance^ Create(
    Document^ document,
    ElementId^ typeId,
    Transform^ transform
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new instance is created
typeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the PointCloudType.
transform
Type: Autodesk.Revit.DB..::..Transform
The transform that defines the placement of the instance in the Revit document coordinate system.

Return Value

The newly created point cloud instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId typeId is not a valid PointCloudType. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PointCloudInstance Class


GetPoints Method

[image]

Revit 2013 API
PointCloudInstance..::..GetPoints Method
PointCloudInstance Class Example See Also Send Feedback
Extracts a collection of points based on a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointCollection GetPoints(
    PointCloudFilter filter,
    int numPoints
)
Visual Basic
Public Function GetPoints ( _
    filter As PointCloudFilter, _
    numPoints As Integer _
) As PointCollection
Visual C++
public:
PointCollection^ GetPoints(
    PointCloudFilter^ filter,
    int numPoints
)

Parameters

filter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter to control which points are extracted. The filter should be passed in the coordinates of the Revit model.
numPoints
Type: System..::..Int32
The maximum number of points requested.

Return Value

A collection object containing points that pass the filter, but no more than the maximum number requested.

Remarks

If there are more points in the cloud passing the filter than the number requested in this function, the results may not be consistent if the same call is made again.

Examples

CopyC#
private void GetPointCloudDataByIteration(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    // read points by iteration
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, 10000); // Get points.  Number of points is determined by the needs of the client
    foreach (CloudPoint point in points)
    {
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}
    // read points by pointer
public unsafe void GetPointCloudDataByPointer(PointCloudInstance pcInstance, PointCloudFilter pointCloudFilter)
{
    PointCollection points = pcInstance.GetPoints(pointCloudFilter, 10000);
    CloudPoint* pointBuffer = (CloudPoint*)points.GetPointBufferPointer().ToPointer();
    int totalCount = points.Count;
    for (int numberOfPoints = 0; numberOfPoints < totalCount; numberOfPoints++)
    {
        CloudPoint point = *(pointBuffer + numberOfPoints);
        // Process each point
        System.Drawing.Color color = System.Drawing.ColorTranslator.FromWin32(point.Color);
        String pointDescription = String.Format("({0}, {1}, {2}, {3}", point.X, point.Y, point.Z, color.ToString());
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The number of points read must range from 1 to 1000000.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudInstance Class


GetSelectionFilter Method

[image]

Revit 2013 API
PointCloudInstance..::..GetSelectionFilter Method
PointCloudInstance Class See Also Send Feedback
Returns the currently active selection filter for this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointCloudFilter GetSelectionFilter()
Visual Basic
Public Function GetSelectionFilter As PointCloudFilter
Visual C++
public:
PointCloudFilter^ GetSelectionFilter()

Return Value

Currently active selection filter or nullNothingnullptra null reference (Nothing in Visual Basic) if none is active.

See Also

PointCloudInstance Class


SetSelectionFilter Method

[image]

Revit 2013 API
PointCloudInstance..::..SetSelectionFilter Method
PointCloudInstance Class See Also Send Feedback
Sets active selection filter by cloning of the one passed to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSelectionFilter(
    PointCloudFilter pFilter
)
Visual Basic
Public Sub SetSelectionFilter ( _
    pFilter As PointCloudFilter _
)
Visual C++
public:
void SetSelectionFilter(
    PointCloudFilter^ pFilter
)

Parameters

pFilter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter object to be made active. If nullNothingnullptra null reference (Nothing in Visual Basic) is supplied, the active filter is removed.

Remarks

The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The selection filter is not preserved when the Revit document is saved.

See Also

PointCloudInstance Class


PointCloudInstance Properties

[image] [image]

Revit 2013 API
PointCloudInstance Properties
PointCloudInstance Class See Also Send Feedback

The PointCloudInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FilterAction | The action taken based on the results of the selection filter applied to this point cloud.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudInstance Class


FilterAction Property

[image]

Revit 2013 API
PointCloudInstance..::..FilterAction Property
PointCloudInstance Class See Also Send Feedback
The action taken based on the results of the selection filter applied to this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SelectionFilterAction FilterAction { get; set; }
Visual Basic
Public Property FilterAction As SelectionFilterAction
    Get
    Set
Visual C++
public:
property SelectionFilterAction FilterAction {
    SelectionFilterAction get ();
    void set (SelectionFilterAction value);
}

Remarks

If no selection filter is applied, changing this value will have no visible effect. The filter is provided in the coordinates of the Revit model. If the point cloud is altered (e.g. by moving, rotating, scaling or other modifications) the point cloud filter is not modified and the set of highlighted or isolated points will change. The filter action is not preserved when the Revit document is saved.

See Also

PointCloudInstance Class


Parameter Property

[image] [image]

Revit 2013 API
PointCloudInstance..::..Parameter Property
PointCloudInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PointCloudInstance Class
PointCloudInstance Members


PointCloudType Class

[image]

Revit 2013 API
PointCloudType Class
Members See Also Send Feedback
Represents a type of point cloud loaded into a Revit document. Each PointCloudType maps to a single file or identifier (depending upon the type of Point Cloud Engine which governs it).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudType : ElementType
Visual Basic
Public Class PointCloudType _
    Inherits ElementType
Visual C++
public ref class PointCloudType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..PointCloudType

See Also

PointCloudType Members


PointCloudType Members

[image] [image]

Revit 2013 API
PointCloudType Members
PointCloudType Class Methods Properties See Also Send Feedback

The PointCloudType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | Offset | Returns the offset stored in the point cloud.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudType Class


PointCloudType Methods

[image] [image]

Revit 2013 API
PointCloudType Methods
PointCloudType Class See Also Send Feedback

The PointCloudType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new point cloud type for a given point cloud engine.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudType Class


Create Method

[image]

Revit 2013 API
PointCloudType..::..Create Method
PointCloudType Class See Also Send Feedback
Creates a new point cloud type for a given point cloud engine.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PointCloudType Create(
    Document document,
    string engineIdentifier,
    string typeIdentifier
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    engineIdentifier As String, _
    typeIdentifier As String _
) As PointCloudType
Visual C++
public:
static PointCloudType^ Create(
    Document^ document,
    String^ engineIdentifier,
    String^ typeIdentifier
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the point cloud.
engineIdentifier
Type: System..::..String
The string identifying the engine to be invoked. It should be the file extension or engine identifier registered by the third party.
typeIdentifier
Type: System..::..String
The file name or the identification string for a non-file based engine.

Return Value

The newly created PointCloudType object to be used to create instances of this point cloud.

Remarks

A list of supported engine identifiers and whether they are file-based or not can be obtained from PointCloudEngineRegistry. The method GetSupportedEngines() returns a list of the identifiers registered for engines.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The engine identifier was not found in the Revit session. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileNotFoundException | The external file could not be found or loaded.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to create a point cloud from the third party engine.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PointCloudType Class


PointCloudType Properties

[image] [image]

Revit 2013 API
PointCloudType Properties
PointCloudType Class See Also Send Feedback

The PointCloudType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ColorEncoding | The color encoding used by points extracted from instances of this point cloud.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EngineIdentifier | The identifier of the engine responsible for handling of the point cloud.
Public property | FoundStatus | Shows whether the Point Cloud external file could be found.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | Offset | Returns the offset stored in the point cloud.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Scale | The multiplier applied to the points in all instances of this point cloud.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointCloudType Class


ColorEncoding Property

[image]

Revit 2013 API
PointCloudType..::..ColorEncoding Property
PointCloudType Class See Also Send Feedback
The color encoding used by points extracted from instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointCloudColorEncoding ColorEncoding { get; }
Visual Basic
Public ReadOnly Property ColorEncoding As PointCloudColorEncoding
    Get
Visual C++
public:
property PointCloudColorEncoding ColorEncoding {
    PointCloudColorEncoding get ();
}

See Also

PointCloudType Class


EngineIdentifier Property

[image]

Revit 2013 API
PointCloudType..::..EngineIdentifier Property
PointCloudType Class See Also Send Feedback
The identifier of the engine responsible for handling of the point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string EngineIdentifier { get; }
Visual Basic
Public ReadOnly Property EngineIdentifier As String
    Get
Visual C++
public:
property String^ EngineIdentifier {
    String^ get ();
}

Remarks

The built-in engine provides "pcg" here.

See Also

PointCloudType Class


FoundStatus Property

[image]

Revit 2013 API
PointCloudType..::..FoundStatus Property
PointCloudType Class See Also Send Feedback
Shows whether the Point Cloud external file could be found.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointCloudFoundStatus FoundStatus { get; }
Visual Basic
Public ReadOnly Property FoundStatus As PointCloudFoundStatus
    Get
Visual C++
public:
property PointCloudFoundStatus FoundStatus {
    PointCloudFoundStatus get ();
}

See Also

PointCloudType Class


Offset Property

[image]

Revit 2013 API
PointCloudType..::..Offset Property
PointCloudType Class See Also Send Feedback
Returns the offset stored in the point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Offset { get; }
Visual Basic
Public ReadOnly Property Offset As XYZ
    Get
Visual C++
public:
property XYZ^ Offset {
    XYZ^ get ();
}

Remarks

All points are assumed to be offset by the same offset vector. The offset will be used by Revit if the user chooses to place an instance relative to another point cloud (the "Auto - Origin To Last Placed" placement option).

See Also

PointCloudType Class


Parameter Property

[image] [image]

Revit 2013 API
PointCloudType..::..Parameter Property
PointCloudType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PointCloudType Class
PointCloudType Members


Scale Property

[image]

Revit 2013 API
PointCloudType..::..Scale Property
PointCloudType Class See Also Send Feedback
The multiplier applied to the points in all instances of this point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

Remarks

Scale converts the units in which the coordinates of individual points of the point cloud are interpreted.

See Also

PointCloudType Class


PointElementReference Class

[image]

Revit 2013 API
PointElementReference Class
Members See Also Send Feedback
Base class for objects defining a way to constrain a ReferencePoint to one or more other objects in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PointElementReference
Visual Basic
Public MustInherit Class PointElementReference
Visual C++
public ref class PointElementReference abstract

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdge
Autodesk.Revit.DB..::..PointOnEdgeEdgeIntersection
Autodesk.Revit.DB..::..PointOnEdgeFaceIntersection
Autodesk.Revit.DB..::..PointOnFace
Autodesk.Revit.DB..::..PointOnPlane
Autodesk.Revit.DB..::..PointRelativeToPoint

See Also

PointElementReference Members


PointElementReference Members

[image] [image]

Revit 2013 API
PointElementReference Members
PointElementReference Class Constructors Methods See Also Send Feedback

The PointElementReference type exposes the following members.

Constructors

 | Name | Description
Public method | PointElementReference | Initializes a new instance of the PointElementReference class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class


PointElementReference Constructor

[image]

Revit 2013 API
PointElementReference Constructor
PointElementReference Class See Also Send Feedback
Initializes a new instance of the PointElementReference class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointElementReference()
Visual Basic
Public Sub New
Visual C++
public:
PointElementReference()

See Also

PointElementReference Class


PointElementReference Methods

[image] [image]

Revit 2013 API
PointElementReference Methods
PointElementReference Class See Also Send Feedback

The PointElementReference type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointElementReference Class


PointLocationOnCurve Class

[image]

Revit 2013 API
PointLocationOnCurve Class
Members See Also Send Feedback
Defines the measurement parameters necessary to create a point at a specific location on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointLocationOnCurve : IDisposable
Visual Basic
Public Class PointLocationOnCurve _
    Implements IDisposable
Visual C++
public ref class PointLocationOnCurve : IDisposable

Remarks

The class will store the following and provides functions to deal with them:
  • The user visible Measurement Type (driving parameter type).
  • The corresponding measurement value (driving parameter).
  • MeasureFrom that tells from where the (driving parameter) measurement is calculated.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointLocationOnCurve

See Also

PointLocationOnCurve Members


PointLocationOnCurve Members

[image] [image]

Revit 2013 API
PointLocationOnCurve Members
PointLocationOnCurve Class Constructors Methods Properties See Also Send Feedback

The PointLocationOnCurve type exposes the following members.

Constructors

 | Name | Description
Public method | PointLocationOnCurve | Constructs a new instance of a class, with given or default values, to place a point on a curve.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointLocationOnCurve
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.

See Also

PointLocationOnCurve Class


PointLocationOnCurve Constructor

[image]

Revit 2013 API
PointLocationOnCurve Constructor
PointLocationOnCurve Class See Also Send Feedback
Constructs a new instance of a class, with given or default values, to place a point on a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)
Visual Basic
Public Sub New ( _
    measType As PointOnCurveMeasurementType, _
    measValue As Double, _
    measFrom As PointOnCurveMeasureFrom _
)
Visual C++
public:
PointLocationOnCurve(
    PointOnCurveMeasurementType measType,
    double measValue,
    PointOnCurveMeasureFrom measFrom
)

Parameters

measType
Type: Autodesk.Revit.DB..::..PointOnCurveMeasurementType
measValue
Type: System..::..Double
measFrom
Type: Autodesk.Revit.DB..::..PointOnCurveMeasureFrom

See Also

PointLocationOnCurve Class


PointLocationOnCurve Methods

[image] [image]

Revit 2013 API
PointLocationOnCurve Methods
PointLocationOnCurve Class See Also Send Feedback

The PointLocationOnCurve type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLocationOnCurve Class


Dispose Method

[image]

Revit 2013 API
PointLocationOnCurve..::..Dispose Method
PointLocationOnCurve Class See Also Send Feedback
Releases all resources used by the PointLocationOnCurve

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointLocationOnCurve Class


PointLocationOnCurve Properties

[image] [image]

Revit 2013 API
PointLocationOnCurve Properties
PointLocationOnCurve Class See Also Send Feedback

The PointLocationOnCurve type exposes the following members.

Properties

 | Name | Description
Public property | MeasureFrom | The location on the curve from which the measurement is taken.
Public property | MeasurementType | The measurement type.
Public property | MeasurementValue | The measurement value.

See Also

PointLocationOnCurve Class


MeasureFrom Property

[image]

Revit 2013 API
PointLocationOnCurve..::..MeasureFrom Property
PointLocationOnCurve Class See Also Send Feedback
The location on the curve from which the measurement is taken.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointOnCurveMeasureFrom MeasureFrom { get; set; }
Visual Basic
Public Property MeasureFrom As PointOnCurveMeasureFrom
    Get
    Set
Visual C++
public:
property PointOnCurveMeasureFrom MeasureFrom {
    PointOnCurveMeasureFrom get ();
    void set (PointOnCurveMeasureFrom value);
}

Remarks

The measure-from is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measure-from must be valid for the curve.

See Also

PointLocationOnCurve Class


MeasurementType Property

[image]

Revit 2013 API
PointLocationOnCurve..::..MeasurementType Property
PointLocationOnCurve Class See Also Send Feedback
The measurement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointOnCurveMeasurementType MeasurementType { get; set; }
Visual Basic
Public Property MeasurementType As PointOnCurveMeasurementType
    Get
    Set
Visual C++
public:
property PointOnCurveMeasurementType MeasurementType {
    PointOnCurveMeasurementType get ();
    void set (PointOnCurveMeasurementType value);
}

Remarks

The measurement type is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measurement type must be valid for the curve.

See Also

PointLocationOnCurve Class


MeasurementValue Property

[image]

Revit 2013 API
PointLocationOnCurve..::..MeasurementValue Property
PointLocationOnCurve Class See Also Send Feedback
The measurement value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double MeasurementValue { get; set; }
Visual Basic
Public Property MeasurementValue As Double
    Get
    Set
Visual C++
public:
property double MeasurementValue {
    double get ();
    void set (double value);
}

Remarks

The measurement value is not checked until this class is assigned for a particular reference point on a particular curve. At that time, the measurement value must match the expected range for the curve for the given measurement type and measure-from.

See Also

PointLocationOnCurve Class


PointOnCurveMeasureFrom Enumeration

[image]

Revit 2013 API
PointOnCurveMeasureFrom Enumeration
See Also Send Feedback
Point on curve MeasureFrom - It tells from which end of the host curve the point location is measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PointOnCurveMeasureFrom
Visual Basic
Public Enumeration PointOnCurveMeasureFrom
Visual C++
public enum class PointOnCurveMeasureFrom

Members

Member name | Description
Beginning | Beginning of the host curve.
End | End of the host curve.

See Also


PointOnCurveMeasurementType Enumeration

[image]

Revit 2013 API
PointOnCurveMeasurementType Enumeration
See Also Send Feedback
Point on curve measurement type Defines the types of measurements that may be used when placing a point at a designated distance along a curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PointOnCurveMeasurementType
Visual Basic
Public Enumeration PointOnCurveMeasurementType
Visual C++
public enum class PointOnCurveMeasurementType

Members

Member name | Description
NonNormalizedCurveParameter | The non-normalized (actual) curve parameter value of the given point. The curve parameter is the defining parameter of the curve. It is also known as the raw/natural parameter.
NormalizedCurveParameter | Normalized value of the curve parameter. It is defined for curves with user defined bounds or natural bounds, start and end. It is measured as the fraction of the curve parameter (t) over the total parametric range = (t-start) / (end-start). Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
SegmentLength | Length of the curve segment between the start point and the given point.
NormalizedSegmentLength | Normalized segment length. It is defined for curves with user defined bounds or natural bounds. It is measured as the fraction of the segment length over the total length of the curve. Its value varies between 0 and 1. 0 corresponds to the start and 1 corresponds to the end.
ChordLength | Chord length = length of the chord (line segment) joining the start point and the given point. Also known as 3D distance
Angle | Angle - defined only for arc and circle. It is the angle subtended at the center by the portion of the curve from the star to the given point.

See Also


PointOnEdge Class

[image]

Revit 2013 API
PointOnEdge Class
Members See Also Send Feedback
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointOnEdge : PointElementReference
Visual Basic
Public Class PointOnEdge _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdge : public PointElementReference

Remarks

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdge

See Also

PointOnEdge Members


PointOnEdge Members

[image] [image]

Revit 2013 API
PointOnEdge Members
PointOnEdge Class Methods Properties See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LocationOnCurve | The point location on curve.

See Also

PointOnEdge Class


PointOnEdge Methods

[image] [image]

Revit 2013 API
PointOnEdge Methods
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdge Class


GetEdgeReference Method

[image]

Revit 2013 API
PointOnEdge..::..GetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdge Class


SetEdgeReference Method

[image]

Revit 2013 API
PointOnEdge..::..SetEdgeReference Method
PointOnEdge Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference reference
)
Visual Basic
Public Sub SetEdgeReference ( _
    reference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdge Class


PointOnEdge Properties

[image] [image]

Revit 2013 API
PointOnEdge Properties
PointOnEdge Class See Also Send Feedback

The PointOnEdge type exposes the following members.

Properties

 | Name | Description
Public property | LocationOnCurve | The point location on curve.

See Also

PointOnEdge Class


LocationOnCurve Property

[image]

Revit 2013 API
PointOnEdge..::..LocationOnCurve Property
PointOnEdge Class See Also Send Feedback
The point location on curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointLocationOnCurve LocationOnCurve { get; }
Visual Basic
Public ReadOnly Property LocationOnCurve As PointLocationOnCurve
    Get
Visual C++
public:
property PointLocationOnCurve^ LocationOnCurve {
    PointLocationOnCurve^ get ();
}

See Also

PointOnEdge Class


PointOnEdgeEdgeIntersection Class

[image]

Revit 2013 API
PointOnEdgeEdgeIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of two referenceable lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointOnEdgeEdgeIntersection : PointElementReference
Visual Basic
Public Class PointOnEdgeEdgeIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeEdgeIntersection : public PointElementReference

Remarks

The ReferencePoint is actually placed on the first line (Edge1) at the closest point to the second line (Edge2). Its X basis vector is constrained to be parallel to the first line.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeEdgeIntersection

See Also

PointOnEdgeEdgeIntersection Members


PointOnEdgeEdgeIntersection Members

[image] [image]

Revit 2013 API
PointOnEdgeEdgeIntersection Members
PointOnEdgeEdgeIntersection Class Methods See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference1 | Get a copy of the first edge or curve reference.
Public method | GetEdgeReference2 | Get a copy of the second edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference1 | Change the first edge or curve reference.
Public method | SetEdgeReference2 | Change the second edge or curve reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class


PointOnEdgeEdgeIntersection Methods

[image] [image]

Revit 2013 API
PointOnEdgeEdgeIntersection Methods
PointOnEdgeEdgeIntersection Class See Also Send Feedback

The PointOnEdgeEdgeIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference1 | Get a copy of the first edge or curve reference.
Public method | GetEdgeReference2 | Get a copy of the second edge or curve reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference1 | Change the first edge or curve reference.
Public method | SetEdgeReference2 | Change the second edge or curve reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeEdgeIntersection Class


GetEdgeReference1 Method

[image]

Revit 2013 API
PointOnEdgeEdgeIntersection..::..GetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetEdgeReference1()
Visual Basic
Public Function GetEdgeReference1 As Reference
Visual C++
public:
Reference^ GetEdgeReference1()

See Also

PointOnEdgeEdgeIntersection Class


GetEdgeReference2 Method

[image]

Revit 2013 API
PointOnEdgeEdgeIntersection..::..GetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Get a copy of the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetEdgeReference2()
Visual Basic
Public Function GetEdgeReference2 As Reference
Visual C++
public:
Reference^ GetEdgeReference2()

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference1 Method

[image]

Revit 2013 API
PointOnEdgeEdgeIntersection..::..SetEdgeReference1 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetEdgeReference1(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference1 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference1(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


SetEdgeReference2 Method

[image]

Revit 2013 API
PointOnEdgeEdgeIntersection..::..SetEdgeReference2 Method
PointOnEdgeEdgeIntersection Class See Also Send Feedback
Change the second edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetEdgeReference2(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference2 ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference2(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also

PointOnEdgeEdgeIntersection Class


PointOnEdgeFaceIntersection Class

[image]

Revit 2013 API
PointOnEdgeFaceIntersection Class
Members See Also Send Feedback
Define a ReferencePoint at the intersection of a referenceable edge or curve and a referenceable face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointOnEdgeFaceIntersection : PointElementReference
Visual Basic
Public Class PointOnEdgeFaceIntersection _
    Inherits PointElementReference
Visual C++
public ref class PointOnEdgeFaceIntersection : public PointElementReference

Remarks

The ReferencePoint's orientation is partially constrained either to the edge (in the manner of PointOnEdge) or to the face (in the manner of PointOnFace).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeFaceIntersection

See Also

PointOnEdgeFaceIntersection Members


PointOnEdgeFaceIntersection Members

[image] [image]

Revit 2013 API
PointOnEdgeFaceIntersection Members
PointOnEdgeFaceIntersection Class Methods Properties See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Methods

[image] [image]

Revit 2013 API
PointOnEdgeFaceIntersection Methods
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetEdgeReference | Get a copy of the edge or curve reference.
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetEdgeReference | Change the edge or curve reference.
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnEdgeFaceIntersection Class


GetEdgeReference Method

[image]

Revit 2013 API
PointOnEdgeFaceIntersection..::..GetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetEdgeReference()
Visual Basic
Public Function GetEdgeReference As Reference
Visual C++
public:
Reference^ GetEdgeReference()

See Also

PointOnEdgeFaceIntersection Class


GetFaceReference Method

[image]

Revit 2013 API
PointOnEdgeFaceIntersection..::..GetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnEdgeFaceIntersection Class


SetEdgeReference Method

[image]

Revit 2013 API
PointOnEdgeFaceIntersection..::..SetEdgeReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetEdgeReference(
    Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference ( _
    edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference(
    Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or CurveElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR.

See Also

PointOnEdgeFaceIntersection Class


SetFaceReference Method

[image]

Revit 2013 API
PointOnEdgeFaceIntersection..::..SetFaceReference Method
PointOnEdgeFaceIntersection Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnEdgeFaceIntersection Class


PointOnEdgeFaceIntersection Properties

[image] [image]

Revit 2013 API
PointOnEdgeFaceIntersection Properties
PointOnEdgeFaceIntersection Class See Also Send Feedback

The PointOnEdgeFaceIntersection type exposes the following members.

Properties

 | Name | Description
Public property | OrientWithEdge | Whether to orient the ReferencePoint to the edge or the face.

See Also

PointOnEdgeFaceIntersection Class


OrientWithEdge Property

[image]

Revit 2013 API
PointOnEdgeFaceIntersection..::..OrientWithEdge Property
PointOnEdgeFaceIntersection Class See Also Send Feedback
Whether to orient the ReferencePoint to the edge or the face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool OrientWithEdge { get; set; }
Visual Basic
Public Property OrientWithEdge As Boolean
    Get
    Set
Visual C++
public:
property bool OrientWithEdge {
    bool get ();
    void set (bool value);
}

Remarks

If true, the X basis vector will be parallel to the edge. If false, the X and Y basis vectors will be parallel to the face.

See Also

PointOnEdgeFaceIntersection Class


PointOnFace Class

[image]

Revit 2013 API
PointOnFace Class
Members See Also Send Feedback
Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic
Public Class PointOnFace _
    Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnFace

See Also

PointOnFace Members


PointOnFace Members

[image] [image]

Revit 2013 API
PointOnFace Members
PointOnFace Class Methods Properties See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


PointOnFace Methods

[image] [image]

Revit 2013 API
PointOnFace Methods
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFaceReference | Get a copy of the face reference.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFaceReference | Change the face reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnFace Class


GetFaceReference Method

[image]

Revit 2013 API
PointOnFace..::..GetFaceReference Method
PointOnFace Class See Also Send Feedback
Get a copy of the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetFaceReference()
Visual Basic
Public Function GetFaceReference As Reference
Visual C++
public:
Reference^ GetFaceReference()

See Also

PointOnFace Class


SetFaceReference Method

[image]

Revit 2013 API
PointOnFace..::..SetFaceReference Method
PointOnFace Class See Also Send Feedback
Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFaceReference(
    Reference reference
)
Visual Basic
Public Sub SetFaceReference ( _
    reference As Reference _
)
Visual C++
public:
void SetFaceReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane. The Reference's UVPoint property is ignored.

See Also

PointOnFace Class


PointOnFace Properties

[image] [image]

Revit 2013 API
PointOnFace Properties
PointOnFace Class See Also Send Feedback

The PointOnFace type exposes the following members.

Properties

 | Name | Description
Public property | UV | The location of the point in the surface's coordinate system.

See Also

PointOnFace Class


UV Property

[image]

Revit 2013 API
PointOnFace..::..UV Property
PointOnFace Class See Also Send Feedback
The location of the point in the surface's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV UV { get; set; }
Visual Basic
Public Property UV As UV
    Get
    Set
Visual C++
public:
property UV^ UV {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnFace Class


PointOnPlane Class

[image]

Revit 2013 API
PointOnPlane Class
Members See Also Send Feedback
Define a ReferencePoint relative to a planar reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointOnPlane : PointElementReference
Visual Basic
Public Class PointOnPlane _
    Inherits PointElementReference
Visual C++
public ref class PointOnPlane : public PointElementReference

Remarks

A ReferencePoint on a plane has its X and Y basis vectors parallel to the plane, but is free to rotate around its Z basis vector. It can lie on the plane or have an offset.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnPlane

See Also

PointOnPlane Members


PointOnPlane Members

[image] [image]

Revit 2013 API
PointOnPlane Members
PointOnPlane Class Methods Properties See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


PointOnPlane Methods

[image] [image]

Revit 2013 API
PointOnPlane Methods
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPlaneReference | The geometric plane reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidPlaneReference | Check whether a geometry reference corresponds to a referenceable plane.
 | NewPointOnPlane | Construct a PointOnPlane given a reference and a location in space.
Public method | SetPlaneReference | Change the geometric plane reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointOnPlane Class


GetPlaneReference Method

[image]

Revit 2013 API
PointOnPlane..::..GetPlaneReference Method
PointOnPlane Class See Also Send Feedback
The geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetPlaneReference()
Visual Basic
Public Function GetPlaneReference As Reference
Visual C++
public:
Reference^ GetPlaneReference()

Return Value

A copy of the reference stored in the PointOnPlane object.

See Also

PointOnPlane Class


IsValidPlaneReference Method

[image]

Revit 2013 API
PointOnPlane..::..IsValidPlaneReference Method
PointOnPlane Class See Also Send Feedback
Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidPlaneReference(
    Document doc,
    Reference planeReference
)
Visual Basic
Public Shared Function IsValidPlaneReference ( _
    doc As Document, _
    planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
    Document^ doc,
    Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
planeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane; the Reference property of ReferencePlane.

See Also

PointOnPlane Class


NewPointOnPlane Method

[image]

Revit 2013 API
PointOnPlane..::..NewPointOnPlane Method
PointOnPlane Class See Also Send Feedback
Construct a PointOnPlane given a reference and a location in space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PointOnPlane NewPointOnPlane(
    Document doc,
    Reference planeReference,
    XYZ position,
    XYZ xvec
)
Visual Basic
Public Shared Function NewPointOnPlane ( _
    doc As Document, _
    planeReference As Reference, _
    position As XYZ, _
    xvec As XYZ _
) As PointOnPlane
Visual C++
public:
static PointOnPlane^ NewPointOnPlane(
    Document^ doc,
    Reference^ planeReference,
    XYZ^ position,
    XYZ^ xvec
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing the plane reference.
planeReference
Type: Autodesk.Revit.DB..::..Reference
position
Type: Autodesk.Revit.DB..::..XYZ
A 3-dimensional position.
xvec
Type: Autodesk.Revit.DB..::..XYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.

Return Value

A new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.

See Also

PointOnPlane Class


SetPlaneReference Method

[image]

Revit 2013 API
PointOnPlane..::..SetPlaneReference Method
PointOnPlane Class See Also Send Feedback
Change the geometric plane reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetPlaneReference(
    Reference planeReference
)
Visual Basic
Public Sub SetPlaneReference ( _
    planeReference As Reference _
)
Visual C++
public:
void SetPlaneReference(
    Reference^ planeReference
)

Parameters

planeReference
Type: Autodesk.Revit.DB..::..Reference
A reference to some plane in the document. (Note: the reference must satisfy IsValidPlaneReference(), but this is not checked until this PointOnPlane object is assigned to a ReferencePoint.)

See Also

PointOnPlane Class


PointOnPlane Properties

[image] [image]

Revit 2013 API
PointOnPlane Properties
PointOnPlane Class See Also Send Feedback

The PointOnPlane type exposes the following members.

Properties

 | Name | Description
Public property | Offset | Signed offset from the plane.
Public property | Position | The coordinates of the point (or its projection) on the plane.
Public property | XVec | The X-coordinate vector of the point, in the plane's coordinate system.

See Also

PointOnPlane Class


Offset Property

[image]

Revit 2013 API
PointOnPlane..::..Offset Property
PointOnPlane Class See Also Send Feedback
Signed offset from the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

The point's position is offset in the direction of the normal vector returned by the Plane.Normal property.

See Also

PointOnPlane Class


Position Property

[image]

Revit 2013 API
PointOnPlane..::..Position Property
PointOnPlane Class See Also Send Feedback
The coordinates of the point (or its projection) on the plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Position { get; set; }
Visual Basic
Public Property Position As UV
    Get
    Set
Visual C++
public:
property UV^ Position {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


XVec Property

[image]

Revit 2013 API
PointOnPlane..::..XVec Property
PointOnPlane Class See Also Send Feedback
The X-coordinate vector of the point, in the plane's coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV XVec { get; set; }
Visual Basic
Public Property XVec As UV
    Get
    Set
Visual C++
public:
property UV^ XVec {
    UV^ get ();
    void set (UV^ value);
}

See Also

PointOnPlane Class


PointRelativeToPoint Class

[image]

Revit 2013 API
PointRelativeToPoint Class
Members See Also Send Feedback
Represents a point placed relative to another point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PointRelativeToPoint : PointElementReference
Visual Basic
Public Class PointRelativeToPoint _
    Inherits PointElementReference
Visual C++
public ref class PointRelativeToPoint : public PointElementReference

Remarks

For this release, the only workflow supported is that the point is placed coincident with the referenced host (a relative transformation of Transform.Identity).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointRelativeToPoint

See Also

PointRelativeToPoint Members


PointRelativeToPoint Members

[image] [image]

Revit 2013 API
PointRelativeToPoint Members
PointRelativeToPoint Class Methods See Also Send Feedback

The PointRelativeToPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointRelativeToPoint Class


PointRelativeToPoint Methods

[image] [image]

Revit 2013 API
PointRelativeToPoint Methods
PointRelativeToPoint Class See Also Send Feedback

The PointRelativeToPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostPointReference | Get a copy of the host point reference.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetHostPointReference | Change the host point reference.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointRelativeToPoint Class


GetHostPointReference Method

[image]

Revit 2013 API
PointRelativeToPoint..::..GetHostPointReference Method
PointRelativeToPoint Class See Also Send Feedback
Get a copy of the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Reference GetHostPointReference()
Visual Basic
Public Function GetHostPointReference As Reference
Visual C++
public:
Reference^ GetHostPointReference()

See Also

PointRelativeToPoint Class


SetHostPointReference Method

[image]

Revit 2013 API
PointRelativeToPoint..::..SetHostPointReference Method
PointRelativeToPoint Class See Also Send Feedback
Change the host point reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetHostPointReference(
    Reference hostPointReference
)
Visual Basic
Public Sub SetHostPointReference ( _
    hostPointReference As Reference _
)
Visual C++
public:
void SetHostPointReference(
    Reference^ hostPointReference
)

Parameters

hostPointReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

Allowed references are to another Autodesk.Revit.DB.ReferencePoint element or to an Autodesk.Revit.DB.Point.

See Also

PointRelativeToPoint Class


PolyLine Class

[image]

Revit 2013 API
PolyLine Class
Members See Also Send Feedback
A polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PolyLine : GeometryObject
Visual Basic
Public Class PolyLine _
    Inherits GeometryObject
Visual C++
public ref class PolyLine : public GeometryObject

Remarks

A polyline in space is defined by a set of coordinate points.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..PolyLine

See Also

PolyLine Members


PolyLine Members

[image] [image]

Revit 2013 API
PolyLine Members
PolyLine Class Methods Properties See Also Send Feedback

The PolyLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PolyLine Class


PolyLine Methods

[image] [image]

Revit 2013 API
PolyLine Methods
PolyLine Class See Also Send Feedback

The PolyLine type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this polyline.
 | Create | Creates a polyline with coordinate points provided.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates a parameter on the polyline.
Public method | GetCoordinate | Gets the coordinate point of the specified index.
Public method | GetCoordinates | Gets the coordinate points of the polyline.
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetOutline | Gets the outline of the polyline.
Public method | GetTransformed | Gets the copy of the polyline which is applied the specified transformation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolyLine Class


Clone Method

[image]

Revit 2013 API
PolyLine..::..Clone Method
PolyLine Class See Also Send Feedback
Returns a copy of this polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PolyLine Clone()
Visual Basic
Public Function Clone As PolyLine
Visual C++
public:
PolyLine^ Clone()

See Also

PolyLine Class


Create Method

[image]

Revit 2013 API
PolyLine..::..Create Method
PolyLine Class See Also Send Feedback
Creates a polyline with coordinate points provided.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PolyLine Create(
    IList<XYZ> coordinates
)
Visual Basic
Public Shared Function Create ( _
    coordinates As IList(Of XYZ) _
) As PolyLine
Visual C++
public:
static PolyLine^ Create(
    IList<XYZ^>^ coordinates
)

Parameters

coordinates
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the count of coordinates is less than 2.

See Also

PolyLine Class


Evaluate Method

[image]

Revit 2013 API
PolyLine..::..Evaluate Method
PolyLine Class See Also Send Feedback
Evaluates a parameter on the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Evaluate(
    double param
)
Visual Basic
Public Function Evaluate ( _
    param As Double _
) As XYZ
Visual C++
public:
XYZ^ Evaluate(
    double param
)

Parameters

param
Type: System..::..Double
The parameter to be evaluated. It is expected to be in [0,1] interval mapped to the bounds of the whole polyline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the param value is not between 0.0 and 1.0.

See Also

PolyLine Class


GetCoordinate Method

[image]

Revit 2013 API
PolyLine..::..GetCoordinate Method
PolyLine Class See Also Send Feedback
Gets the coordinate point of the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ GetCoordinate(
    int index
)
Visual Basic
Public Function GetCoordinate ( _
    index As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetCoordinate(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the index value is out of range.

See Also

PolyLine Class


GetCoordinates Method

[image]

Revit 2013 API
PolyLine..::..GetCoordinates Method
PolyLine Class See Also Send Feedback
Gets the coordinate points of the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> GetCoordinates()
Visual Basic
Public Function GetCoordinates As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetCoordinates()

See Also

PolyLine Class


GetOutline Method

[image]

Revit 2013 API
PolyLine..::..GetOutline Method
PolyLine Class See Also Send Feedback
Gets the outline of the polyline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Outline GetOutline()
Visual Basic
Public Function GetOutline As Outline
Visual C++
public:
Outline^ GetOutline()

See Also

PolyLine Class


GetTransformed Method

[image]

Revit 2013 API
PolyLine..::..GetTransformed Method
PolyLine Class See Also Send Feedback
Gets the copy of the polyline which is applied the specified transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PolyLine GetTransformed(
    Transform transform
)
Visual Basic
Public Function GetTransformed ( _
    transform As Transform _
) As PolyLine
Visual C++
public:
PolyLine^ GetTransformed(
    Transform^ transform
)

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the transform is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

PolyLine Class


PolyLine Properties

[image] [image]

Revit 2013 API
PolyLine Properties
PolyLine Class See Also Send Feedback

The PolyLine type exposes the following members.

Properties

 | Name | Description
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NumberOfCoordinates | Gets the number of the coordinate points.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

PolyLine Class


NumberOfCoordinates Property

[image]

Revit 2013 API
PolyLine..::..NumberOfCoordinates Property
PolyLine Class See Also Send Feedback
Gets the number of the coordinate points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfCoordinates { get; }
Visual Basic
Public ReadOnly Property NumberOfCoordinates As Integer
    Get
Visual C++
public:
property int NumberOfCoordinates {
    int get ();
}

See Also

PolyLine Class


PreferredJunctionType Enumeration

[image]

Revit 2013 API
PreferredJunctionType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum PreferredJunctionType
Visual Basic
Public Enumeration PreferredJunctionType
Visual C++
public enum class PreferredJunctionType

Members

Member name | Description
Undefined | Undefined junction type.
Tee | Tee junction type.
Tap | Tap junction type.

See Also


PrimaryDesignOptionMemberFilter Class

[image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Class
Members Example See Also Send Feedback
A filter used to find elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class PrimaryDesignOptionMemberFilter : ElementSlowFilter
Visual Basic
Public Class PrimaryDesignOptionMemberFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class PrimaryDesignOptionMemberFilter : public ElementSlowFilter

Remarks

This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.

Examples

CopyC#
// Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
PrimaryDesignOptionMemberFilter filter = new PrimaryDesignOptionMemberFilter();

// Apply the filter to the elements in the active document
// Use shortcut command OfClass() to only find wall instances
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> wallsOfPrimaryOpt = collector.OfClass(typeof(Wall)).WherePasses(filter).ToElements();

// Find walls not contained within primary design options: Use inverted filter to match walls
PrimaryDesignOptionMemberFilter notPrimaryOptFilter = new PrimaryDesignOptionMemberFilter(true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notPrimaryDesignOptFounds =
    collector.OfClass(typeof(Wall)).WherePasses(notPrimaryOptFilter).ToElements();
CopyVB.NET
' Create a PrimaryDesignOptionMember filter to find all Walls contained within all primary design options
Dim filter As New PrimaryDesignOptionMemberFilter()

' Apply the filter to the elements in the active document
' Use shortcut command OfClass() to only find wall instances
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim wallsOfPrimaryOpt As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(filter).ToElements()

' Find walls not contained within primary design options: Use inverted filter to match walls
Dim notPrimaryOptFilter As New PrimaryDesignOptionMemberFilter(True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notPrimaryDesignOptFounds As ICollection(Of Autodesk.Revit.DB.Element) = collector.OfClass(GetType(Wall)).WherePasses(notPrimaryOptFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..PrimaryDesignOptionMemberFilter

See Also

PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Members

[image] [image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Members
PrimaryDesignOptionMemberFilter Class Constructors Methods Properties See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Constructors

 | Name | Description
Public method | PrimaryDesignOptionMemberFilter()()()() | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimaryDesignOptionMemberFilter Constructor

[image] [image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrimaryDesignOptionMemberFilter()()()() | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.
Public method | PrimaryDesignOptionMemberFilter(Boolean) | Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Constructor

[image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Constructor
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter()
Visual Basic
Public Sub New
Visual C++
public:
PrimaryDesignOptionMemberFilter()

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Constructor (Boolean)

[image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Constructor (Boolean)
PrimaryDesignOptionMemberFilter Class See Also Send Feedback
Constructs a new instance of a filter to match elements contained in any primary design option of any design option set, with the option to invert the filter and find elements not contained in any primary design option of any design option set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public PrimaryDesignOptionMemberFilter(
    bool inverted
)
Visual Basic
Public Sub New ( _
    inverted As Boolean _
)
Visual C++
public:
PrimaryDesignOptionMemberFilter(
    bool inverted
)

Parameters

inverted
Type: System..::..Boolean
True if the filter should match all elements which are not contained within a particular design option.

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Overload


PrimaryDesignOptionMemberFilter Methods

[image] [image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Methods
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrimaryDesignOptionMemberFilter Class


PassesFilter Method

[image] [image]

Revit 2013 API
PrimaryDesignOptionMemberFilter..::..PassesFilter Method
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class
PrimaryDesignOptionMemberFilter Members


PrimaryDesignOptionMemberFilter Properties

[image] [image]

Revit 2013 API
PrimaryDesignOptionMemberFilter Properties
PrimaryDesignOptionMemberFilter Class See Also Send Feedback

The PrimaryDesignOptionMemberFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

PrimaryDesignOptionMemberFilter Class


PrimarySizeCriterion Class

[image]

Revit 2013 API
PrimarySizeCriterion Class
Members See Also Send Feedback
This class contains a size criterion for a RoutingPreferenceRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PrimarySizeCriterion : RoutingCriterionBase
Visual Basic
Public Class PrimarySizeCriterion _
    Inherits RoutingCriterionBase
Visual C++
public ref class PrimarySizeCriterion : public RoutingCriterionBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCriterionBase
Autodesk.Revit.DB..::..PrimarySizeCriterion

See Also

PrimarySizeCriterion Members


PrimarySizeCriterion Members

[image] [image]

Revit 2013 API
PrimarySizeCriterion Members
PrimarySizeCriterion Class Constructors Methods Properties See Also Send Feedback

The PrimarySizeCriterion type exposes the following members.

Constructors

 | Name | Description
Public method | PrimarySizeCriterion | Constructs a PrimarySizeCriterion with a minimum and maximum size.

Methods

 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase.)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.

See Also

PrimarySizeCriterion Class


PrimarySizeCriterion Constructor

[image]

Revit 2013 API
PrimarySizeCriterion Constructor
PrimarySizeCriterion Class See Also Send Feedback
Constructs a PrimarySizeCriterion with a minimum and maximum size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)
Visual Basic
Public Sub New ( _
    minimumSize As Double, _
    maximumSize As Double _
)
Visual C++
public:
PrimarySizeCriterion(
    double minimumSize,
    double maximumSize
)

Parameters

minimumSize
Type: System..::..Double
maximumSize
Type: System..::..Double

See Also

PrimarySizeCriterion Class


PrimarySizeCriterion Methods

[image] [image]

Revit 2013 API
PrimarySizeCriterion Methods
PrimarySizeCriterion Class See Also Send Feedback

The PrimarySizeCriterion type exposes the following members.

Methods

 | Name | Description
 | All | Creates a criterion with a range of all sizes.
Public method | Dispose | (Inherited from RoutingCriterionBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same. (Inherited from RoutingCriterionBase.)
 | None | Creates a criterion with a range of no sizes.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrimarySizeCriterion Class


All Method

[image]

Revit 2013 API
PrimarySizeCriterion..::..All Method
PrimarySizeCriterion Class See Also Send Feedback
Creates a criterion with a range of all sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PrimarySizeCriterion All()
Visual Basic
Public Shared Function All As PrimarySizeCriterion
Visual C++
public:
static PrimarySizeCriterion^ All()

Return Value

The new criterion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


None Method

[image]

Revit 2013 API
PrimarySizeCriterion..::..None Method
PrimarySizeCriterion Class See Also Send Feedback
Creates a criterion with a range of no sizes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PrimarySizeCriterion None()
Visual Basic
Public Shared Function None As PrimarySizeCriterion
Visual C++
public:
static PrimarySizeCriterion^ None()

Return Value

The new criterion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


PrimarySizeCriterion Properties

[image] [image]

Revit 2013 API
PrimarySizeCriterion Properties
PrimarySizeCriterion Class See Also Send Feedback

The PrimarySizeCriterion type exposes the following members.

Properties

 | Name | Description
Public property | MaximumSize | The maximum size of this criterion.
Public property | MinimumSize | The minimum size of this criterion.

See Also

PrimarySizeCriterion Class


MaximumSize Property

[image]

Revit 2013 API
PrimarySizeCriterion..::..MaximumSize Property
PrimarySizeCriterion Class See Also Send Feedback
The maximum size of this criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MaximumSize { get; set; }
Visual Basic
Public Property MaximumSize As Double
    Get
    Set
Visual C++
public:
property double MaximumSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


MinimumSize Property

[image]

Revit 2013 API
PrimarySizeCriterion..::..MinimumSize Property
PrimarySizeCriterion Class See Also Send Feedback
The minimum size of this criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinimumSize { get; set; }
Visual Basic
Public Property MinimumSize As Double
    Get
    Set
Visual C++
public:
property double MinimumSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PrimarySizeCriterion Class


PrinterResolution Enumeration

[image]

Revit 2013 API
PrinterResolution Enumeration
See Also Send Feedback
Controls the resolution level in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum PrinterResolution
Visual Basic
Public Enumeration PrinterResolution
Visual C++
public enum class PrinterResolution

Members

Member name | Description
Low | Low printer resolution.
Medium | Medium printer resolution.
High | High printer resolution.
VeryHigh | VeryHigh printer resolution.

Remarks

It is applicable only when using printer resolution. The suitable resolution value for each resolution level is decided by default in Revit.

See Also


PrintManager Class

[image]

Revit 2013 API
PrintManager Class
Members Example See Also Send Feedback
The PrintManager object is used to configure the global print settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PrintManager : APIObject
Visual Basic
Public Class PrintManager _
    Inherits APIObject
Visual C++
public ref class PrintManager : public APIObject

Remarks

Global print settings include PrintToFile, CombinedFile, PrintToFileName, PrintRange, CopyNumber, PrintOrderReverse, Collate. Once PrintManager is acquired from a document, changes of its global print setting properties are not automatically applied toward the global print setting. Should the local setting be used, the user needs to call the Apply method. If the user calls SubmitPrint methods, not only that printing will use the current state of properties of the (local) print manager, but the setting will also be applied to the global settings.

Examples

CopyC#
private void CreateAndPrintViewSet(Document document, ViewSet viewSet)
{
    PrintManager printManager = document.PrintManager;
    printManager.PrintRange = PrintRange.Select;
    ViewSheetSetting viewSheetSetting = printManager.ViewSheetSetting;
    viewSheetSetting.CurrentViewSheetSet.Views = viewSet;
    viewSheetSetting.SaveAs("MyViewSet");
    printManager.CombinedFile = true;
    printManager.SubmitPrint();
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintManager

See Also

PrintManager Members


PrintManager Members

[image] [image]

Revit 2013 API
PrintManager Members
PrintManager Class Methods Properties See Also Send Feedback

The PrintManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class


PrintManager Methods

[image] [image]

Revit 2013 API
PrintManager Methods
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Methods

 | Name | Description
Public method | Apply | Apply the local print settings to global for all documents.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SelectNewPrintDriver | Select a new printer.
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintManager Class


Apply Method

[image]

Revit 2013 API
PrintManager..::..Apply Method
PrintManager Class See Also Send Feedback
Apply the local print settings to global for all documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Apply()
Visual Basic
Public Sub Apply
Visual C++
public:
void Apply()

Remarks

This method will change the settings for the current printer to match what is set in the Print Manager. When the user attempts to print with this printer in the future, the changes made by the API session will be visible.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class


SelectNewPrintDriver Method

[image]

Revit 2013 API
PrintManager..::..SelectNewPrintDriver Method
PrintManager Class See Also Send Feedback
Select a new printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SelectNewPrintDriver(
    string strPrinterName
)
Visual Basic
Public Sub SelectNewPrintDriver ( _
    strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
    String^ strPrinterName
)

Parameters

strPrinterName
Type: System..::..String
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-strPrinterName-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also

PrintManager Class


SubmitPrint Method

[image] [image]

Revit 2013 API
PrintManager..::..SubmitPrint Method
PrintManager Class See Also Send Feedback
Print with the current PrintManager settings.

Overload List

 | Name | Description
Public method | SubmitPrint()()()() | Print the views and sheets defined in the current local PrintManager settings.
Public method | SubmitPrint(View) | Print a view with the current PrintManager settings.

See Also

PrintManager Class
PrintManager Members


SubmitPrint Method

[image]

Revit 2013 API
PrintManager..::..SubmitPrint Method
PrintManager Class See Also Send Feedback
Print the views and sheets defined in the current local PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SubmitPrint()
Visual Basic
Public Function SubmitPrint As Boolean
Visual C++
public:
bool SubmitPrint()

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the view/views/sheets which user defined with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


SubmitPrint Method (View)

[image]

Revit 2013 API
PrintManager..::..SubmitPrint Method (View)
PrintManager Class See Also Send Feedback
Print a view with the current PrintManager settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SubmitPrint(
    View view
)
Visual Basic
Public Function SubmitPrint ( _
    view As View _
) As Boolean
Visual C++
public:
bool SubmitPrint(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The User-assigned view.

Return Value

True if successful, otherwise False.

Remarks

PrintManager will apply the local settings to global and print the user-assigned view with the current settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this operation is not allowed in the current application mode, or the print resource is occupied by others.

See Also

PrintManager Class
SubmitPrint Overload


PrintManager Properties

[image] [image]

Revit 2013 API
PrintManager Properties
PrintManager Class See Also Send Feedback

The PrintManager type exposes the following members.

Properties

 | Name | Description
Public property | Collate | Indicates whether to collate of the current print.
Public property | CombinedFile | Indicates whether to combine multiple selected views/sheets into a single file.
Public property | CopyNumber | The copy number.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsVirtual | The virtual type in Autodesk Revit.
Public property | PaperSizes | Get all print sizes of current printer.
Public property | PaperSources | Get all print sources of current printer.
Public property | PrinterName | The name of the current printer.
Public property | PrintOrderReverse | Indicates whether to reverse the print order of the current print.
Public property | PrintRange | The print range.
Public property | PrintSetup | The PrintSetup which manages the print settings of current document.
Public property | PrintToFile | Indicates whether to print to file.
Public property | PrintToFileName | The file name when printing to file.
Public property | ViewSheetSetting | The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

See Also

PrintManager Class


Collate Property

[image]

Revit 2013 API
PrintManager..::..Collate Property
PrintManager Class See Also Send Feedback
Indicates whether to collate of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Collate { get; set; }
Visual Basic
Public Property Collate As Boolean
    Get
    Set
Visual C++
public:
property bool Collate {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is only one view or only one copy in the current settings.

See Also

PrintManager Class


CombinedFile Property

[image]

Revit 2013 API
PrintManager..::..CombinedFile Property
PrintManager Class See Also Send Feedback
Indicates whether to combine multiple selected views/sheets into a single file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CombinedFile { get; set; }
Visual Basic
Public Property CombinedFile As Boolean
    Get
    Set
Visual C++
public:
property bool CombinedFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current printer is not a virtual printer.

See Also

PrintManager Class


CopyNumber Property

[image]

Revit 2013 API
PrintManager..::..CopyNumber Property
PrintManager Class See Also Send Feedback
The copy number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int CopyNumber { get; set; }
Visual Basic
Public Property CopyNumber As Integer
    Get
    Set
Visual C++
public:
property int CopyNumber {
    int get ();
    void set (int value);
}

Remarks

Returns 0 if current printer does not support CopyNumber property. The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


IsVirtual Property

[image]

Revit 2013 API
PrintManager..::..IsVirtual Property
PrintManager Class See Also Send Feedback
The virtual type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VirtualPrinterType IsVirtual { get; }
Visual Basic
Public ReadOnly Property IsVirtual As VirtualPrinterType
    Get
Visual C++
public:
property VirtualPrinterType IsVirtual {
    VirtualPrinterType get ();
}

See Also

PrintManager Class


PaperSizes Property

[image]

Revit 2013 API
PrintManager..::..PaperSizes Property
PrintManager Class See Also Send Feedback
Get all print sizes of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSizeSet PaperSizes { get; }
Visual Basic
Public ReadOnly Property PaperSizes As PaperSizeSet
    Get
Visual C++
public:
property PaperSizeSet^ PaperSizes {
    PaperSizeSet^ get ();
}

Remarks

These are the valid paper sizes for the current printer.

See Also

PrintManager Class


PaperSources Property

[image]

Revit 2013 API
PrintManager..::..PaperSources Property
PrintManager Class See Also Send Feedback
Get all print sources of current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSourceSet PaperSources { get; }
Visual Basic
Public ReadOnly Property PaperSources As PaperSourceSet
    Get
Visual C++
public:
property PaperSourceSet^ PaperSources {
    PaperSourceSet^ get ();
}

Remarks

These are the valid paper source for the current printer.

See Also

PrintManager Class


PrinterName Property

[image]

Revit 2013 API
PrintManager..::..PrinterName Property
PrintManager Class See Also Send Feedback
The name of the current printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string PrinterName { get; }
Visual Basic
Public ReadOnly Property PrinterName As String
    Get
Visual C++
public:
property String^ PrinterName {
    String^ get ();
}

See Also

PrintManager Class


PrintOrderReverse Property

[image]

Revit 2013 API
PrintManager..::..PrintOrderReverse Property
PrintManager Class See Also Send Feedback
Indicates whether to reverse the print order of the current print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool PrintOrderReverse { get; set; }
Visual Basic
Public Property PrintOrderReverse As Boolean
    Get
    Set
Visual C++
public:
property bool PrintOrderReverse {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


PrintRange Property

[image]

Revit 2013 API
PrintManager..::..PrintRange Property
PrintManager Class See Also Send Feedback
The print range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PrintRange PrintRange { get; set; }
Visual Basic
Public Property PrintRange As PrintRange
    Get
    Set
Visual C++
public:
property PrintRange PrintRange {
    PrintRange get ();
    void set (PrintRange value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the argument is out of range.

See Also

PrintManager Class


PrintSetup Property

[image]

Revit 2013 API
PrintManager..::..PrintSetup Property
PrintManager Class See Also Send Feedback
The PrintSetup which manages the print settings of current document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PrintSetup PrintSetup { get; }
Visual Basic
Public ReadOnly Property PrintSetup As PrintSetup
    Get
Visual C++
public:
property PrintSetup^ PrintSetup {
    PrintSetup^ get ();
}

Remarks

PrintSetup is an interface cluster just like File->Print->Settings->Setup or File->Print Setup in UI.

See Also

PrintManager Class


PrintToFile Property

[image]

Revit 2013 API
PrintManager..::..PrintToFile Property
PrintManager Class See Also Send Feedback
Indicates whether to print to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool PrintToFile { get; set; }
Visual Basic
Public Property PrintToFile As Boolean
    Get
    Set
Visual C++
public:
property bool PrintToFile {
    bool get ();
    void set (bool value);
}

Remarks

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

See Also

PrintManager Class


PrintToFileName Property

[image]

Revit 2013 API
PrintManager..::..PrintToFileName Property
PrintManager Class See Also Send Feedback
The file name when printing to file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string PrintToFileName { get; set; }
Visual Basic
Public Property PrintToFileName As String
    Get
    Set
Visual C++
public:
property String^ PrintToFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

A default file name will be used when the PrintToFile is true and PrintToFileName is not be set.

The value of this property represents the global print setting property used for print operations on any document. In order to make a change to this property, after setting it call the Apply() method, or one of the SubmitPrint() methods, which save the local changes as modifications to the global print settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input file name is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input file name is an invalid string.

See Also

PrintManager Class


ViewSheetSetting Property

[image]

Revit 2013 API
PrintManager..::..ViewSheetSetting Property
PrintManager Class See Also Send Feedback
The ViewSheetSetting which manages the view/sheet set information of current document, and you can change the default view/sheet set for current project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSheetSetting ViewSheetSetting { get; }
Visual Basic
Public ReadOnly Property ViewSheetSetting As ViewSheetSetting
    Get
Visual C++
public:
property ViewSheetSetting^ ViewSheetSetting {
    ViewSheetSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the print range is not selected views/sheets.

See Also

PrintManager Class


PrintParameters Class

[image]

Revit 2013 API
PrintParameters Class
Members See Also Send Feedback
An object that contains settings used for printing the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PrintParameters : APIObject
Visual Basic
Public Class PrintParameters _
    Inherits APIObject
Visual C++
public ref class PrintParameters : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintParameters

See Also

PrintParameters Members


PrintParameters Members

[image] [image]

Revit 2013 API
PrintParameters Members
PrintParameters Class Methods Properties See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTages | Indicates whether to hide unreferenced view tags when printing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | The print margin type.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | The User defined X value of offset from left bottom corner.
Public property | UserDefinedMarginY | The User defined Y value of offset from left bottom corner
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.

See Also

PrintParameters Class


PrintParameters Methods

[image] [image]

Revit 2013 API
PrintParameters Methods
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintParameters Class


PrintParameters Properties

[image] [image]

Revit 2013 API
PrintParameters Properties
PrintParameters Class See Also Send Feedback

The PrintParameters type exposes the following members.

Properties

 | Name | Description
Public property | ColorDepth | The color depth type.
Public property | HiddenLineViews | The hidden line views type.
Public property | HideCropBoundaries | Indicates whether to hide crop boundaries when printing.
Public property | HideReforWorkPlanes | Indicates whether to hide reference/work planes when printing.
Public property | HideScopeBoxes | Indicates whether to hide scope boxes when printing.
Public property | HideUnreferencedViewTages | Indicates whether to hide unreferenced view tags when printing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MarginType | The print margin type.
Public property | PageOrientation | The Page Orientation of the Print Setting.
Public property | PaperPlacement | The paper placement type.
Public property | PaperSize | The page size.
Public property | PaperSource | The page source.
Public property | RasterQuality | The raster quality type.
Public property | ReplaceHalftoneWithThinLines | Indicates whether to replace halftone with thin lines when printing.
Public property | UserDefinedMarginX | The User defined X value of offset from left bottom corner.
Public property | UserDefinedMarginY | The User defined Y value of offset from left bottom corner
Public property | ViewLinksinBlue | Indicates whether to view links in blue when printing.
Public property | Zoom | The zoom value to a percentage of the original size.
Public property | ZoomType | The zoom type.

See Also

PrintParameters Class


ColorDepth Property

[image]

Revit 2013 API
PrintParameters..::..ColorDepth Property
PrintParameters Class See Also Send Feedback
The color depth type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ColorDepthType ColorDepth { get; set; }
Visual Basic
Public Property ColorDepth As ColorDepthType
    Get
    Set
Visual C++
public:
property ColorDepthType ColorDepth {
    ColorDepthType get ();
    void set (ColorDepthType value);
}

See Also

PrintParameters Class


HiddenLineViews Property

[image]

Revit 2013 API
PrintParameters..::..HiddenLineViews Property
PrintParameters Class See Also Send Feedback
The hidden line views type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HiddenLineViewsType HiddenLineViews { get; set; }
Visual Basic
Public Property HiddenLineViews As HiddenLineViewsType
    Get
    Set
Visual C++
public:
property HiddenLineViewsType HiddenLineViews {
    HiddenLineViewsType get ();
    void set (HiddenLineViewsType value);
}

See Also

PrintParameters Class


HideCropBoundaries Property

[image]

Revit 2013 API
PrintParameters..::..HideCropBoundaries Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide crop boundaries when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HideCropBoundaries { get; set; }
Visual Basic
Public Property HideCropBoundaries As Boolean
    Get
    Set
Visual C++
public:
property bool HideCropBoundaries {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideReforWorkPlanes Property

[image]

Revit 2013 API
PrintParameters..::..HideReforWorkPlanes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide reference/work planes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HideReforWorkPlanes { get; set; }
Visual Basic
Public Property HideReforWorkPlanes As Boolean
    Get
    Set
Visual C++
public:
property bool HideReforWorkPlanes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideScopeBoxes Property

[image]

Revit 2013 API
PrintParameters..::..HideScopeBoxes Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide scope boxes when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HideScopeBoxes { get; set; }
Visual Basic
Public Property HideScopeBoxes As Boolean
    Get
    Set
Visual C++
public:
property bool HideScopeBoxes {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


HideUnreferencedViewTages Property

[image]

Revit 2013 API
PrintParameters..::..HideUnreferencedViewTages Property
PrintParameters Class See Also Send Feedback
Indicates whether to hide unreferenced view tags when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HideUnreferencedViewTages { get; set; }
Visual Basic
Public Property HideUnreferencedViewTages As Boolean
    Get
    Set
Visual C++
public:
property bool HideUnreferencedViewTages {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


MarginType Property

[image]

Revit 2013 API
PrintParameters..::..MarginType Property
PrintParameters Class See Also Send Feedback
The print margin type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MarginType MarginType { get; set; }
Visual Basic
Public Property MarginType As MarginType
    Get
    Set
Visual C++
public:
property MarginType MarginType {
    MarginType get ();
    void set (MarginType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the PaperPlacement is not Margins type.

See Also

PrintParameters Class


PageOrientation Property

[image]

Revit 2013 API
PrintParameters..::..PageOrientation Property
PrintParameters Class See Also Send Feedback
The Page Orientation of the Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PageOrientationType PageOrientation { get; set; }
Visual Basic
Public Property PageOrientation As PageOrientationType
    Get
    Set
Visual C++
public:
property PageOrientationType PageOrientation {
    PageOrientationType get ();
    void set (PageOrientationType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperPlacement Property

[image]

Revit 2013 API
PrintParameters..::..PaperPlacement Property
PrintParameters Class See Also Send Feedback
The paper placement type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperPlacementType PaperPlacement { get; set; }
Visual Basic
Public Property PaperPlacement As PaperPlacementType
    Get
    Set
Visual C++
public:
property PaperPlacementType PaperPlacement {
    PaperPlacementType get ();
    void set (PaperPlacementType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PaperSize Property

[image]

Revit 2013 API
PrintParameters..::..PaperSize Property
PrintParameters Class See Also Send Feedback
The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic
Public Property PaperSize As PaperSize
    Get
    Set
Visual C++
public:
property PaperSize^ PaperSize {
    PaperSize^ get ();
    void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class


PaperSource Property

[image]

Revit 2013 API
PrintParameters..::..PaperSource Property
PrintParameters Class See Also Send Feedback
The page source.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PaperSource PaperSource { get; set; }
Visual Basic
Public Property PaperSource As PaperSource
    Get
    Set
Visual C++
public:
property PaperSource^ PaperSource {
    PaperSource^ get ();
    void set (PaperSource^ value);
}

Remarks

User can select the candidate via PaperSources and then set the Page source of the Print Setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument is invalid for current printer.

See Also

PrintParameters Class


RasterQuality Property

[image]

Revit 2013 API
PrintParameters..::..RasterQuality Property
PrintParameters Class See Also Send Feedback
The raster quality type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RasterQualityType RasterQuality { get; set; }
Visual Basic
Public Property RasterQuality As RasterQualityType
    Get
    Set
Visual C++
public:
property RasterQualityType RasterQuality {
    RasterQualityType get ();
    void set (RasterQualityType value);
}

See Also

PrintParameters Class


ReplaceHalftoneWithThinLines Property

[image]

Revit 2013 API
PrintParameters..::..ReplaceHalftoneWithThinLines Property
PrintParameters Class See Also Send Feedback
Indicates whether to replace halftone with thin lines when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ReplaceHalftoneWithThinLines { get; set; }
Visual Basic
Public Property ReplaceHalftoneWithThinLines As Boolean
    Get
    Set
Visual C++
public:
property bool ReplaceHalftoneWithThinLines {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


UserDefinedMarginX Property

[image]

Revit 2013 API
PrintParameters..::..UserDefinedMarginX Property
PrintParameters Class See Also Send Feedback
The User defined X value of offset from left bottom corner.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double UserDefinedMarginX { get; set; }
Visual Basic
Public Property UserDefinedMarginX As Double
    Get
    Set
Visual C++
public:
property double UserDefinedMarginX {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


UserDefinedMarginY Property

[image]

Revit 2013 API
PrintParameters..::..UserDefinedMarginY Property
PrintParameters Class See Also Send Feedback
The User defined Y value of offset from left bottom corner

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double UserDefinedMarginY { get; set; }
Visual Basic
Public Property UserDefinedMarginY As Double
    Get
    Set
Visual C++
public:
property double UserDefinedMarginY {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if PaperPlacement is not Margins and MarginType is not User defined type.

See Also

PrintParameters Class


ViewLinksinBlue Property

[image]

Revit 2013 API
PrintParameters..::..ViewLinksinBlue Property
PrintParameters Class See Also Send Feedback
Indicates whether to view links in blue when printing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ViewLinksinBlue { get; set; }
Visual Basic
Public Property ViewLinksinBlue As Boolean
    Get
    Set
Visual C++
public:
property bool ViewLinksinBlue {
    bool get ();
    void set (bool value);
}

See Also

PrintParameters Class


Zoom Property

[image]

Revit 2013 API
PrintParameters..::..Zoom Property
PrintParameters Class See Also Send Feedback
The zoom value to a percentage of the original size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Zoom { get; set; }
Visual Basic
Public Property Zoom As Integer
    Get
    Set
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if current ZoomType is not Zoom type.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if input zoom value less than 1.

See Also

PrintParameters Class


ZoomType Property

[image]

Revit 2013 API
PrintParameters..::..ZoomType Property
PrintParameters Class See Also Send Feedback
The zoom type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ZoomType ZoomType { get; set; }
Visual Basic
Public Property ZoomType As ZoomType
    Get
    Set
Visual C++
public:
property ZoomType ZoomType {
    ZoomType get ();
    void set (ZoomType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument is out of range.

See Also

PrintParameters Class


PrintRange Enumeration

[image]

Revit 2013 API
PrintRange Enumeration
See Also Send Feedback
An enumerated type listing all Print Range types of Print.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PrintRange
Visual Basic
Public Enumeration PrintRange
Visual C++
public enum class PrintRange

Members

Member name | Description
Current | A range that represents just the currently active view.
Visible | Visible portion of current window.
Select | A range that represents a list of selected views and sheets.

See Also


PrintSetting Class

[image]

Revit 2013 API
PrintSetting Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PrintSetting : Element,
    IPrintSetting
Visual Basic
Public Class PrintSetting _
    Inherits Element _
    Implements IPrintSetting
Visual C++
public ref class PrintSetting : public Element,
    IPrintSetting

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PrintSetting

See Also

PrintSetting Members


PrintSetting Members

[image] [image]

Revit 2013 API
PrintSetting Members
PrintSetting Class Methods Properties See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns the Name of Print Setup. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PrintParameters | Returns the Parameters of Print Setup.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PrintSetting Class


PrintSetting Methods

[image] [image]

Revit 2013 API
PrintSetting Methods
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetting Class


PrintSetting Properties

[image] [image]

Revit 2013 API
PrintSetting Properties
PrintSetting Class See Also Send Feedback

The PrintSetting type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns the Name of Print Setup. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PrintParameters | Returns the Parameters of Print Setup.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PrintSetting Class


Name Property

[image]

Revit 2013 API
PrintSetting..::..Name Property
PrintSetting Class See Also Send Feedback
Returns the Name of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

Retrieve/set the name of Print Setup.

See Also

PrintSetting Class


Parameter Property

[image] [image]

Revit 2013 API
PrintSetting..::..Parameter Property
PrintSetting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PrintSetting Class
PrintSetting Members


PrintParameters Property

[image]

Revit 2013 API
PrintSetting..::..PrintParameters Property
PrintSetting Class See Also Send Feedback
Returns the Parameters of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PrintParameters PrintParameters { get; }
Visual Basic
Public Overridable ReadOnly Property PrintParameters As PrintParameters
    Get
Visual C++
public:
virtual property PrintParameters^ PrintParameters {
    PrintParameters^ get ();
}

Implements

IPrintSetting..::..PrintParameters

Remarks

The Parameters of Print Setup. Refer to the Print Setup dialog in Revit for details.

See Also

PrintSetting Class


PrintSetup Class

[image]

Revit 2013 API
PrintSetup Class
Members See Also Send Feedback
Represents the Print Setup (Application Menu->Print->Print Setup) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PrintSetup : APIObject
Visual Basic
Public Class PrintSetup _
    Inherits APIObject
Visual C++
public ref class PrintSetup : public APIObject

Remarks

The Print Setup object can only get from PrintManager object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..PrintSetup

See Also

PrintSetup Members


PrintSetup Members

[image] [image]

Revit 2013 API
PrintSetup Members
PrintSetup Class Methods Properties See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentPrintSetting | The current Print Setting of Print Setup.
Public property | InSession | The in-session Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class


PrintSetup Methods

[image] [image]

Revit 2013 API
PrintSetup Methods
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current print setting, and make the In-Session setting as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current print setting with the specified name.
Public method | Revert | Revert the current print setting.
Public method | Save | Save the changes for the current print setting.
Public method | SaveAs | Save the current print setting to another print setting with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrintSetup Class


Delete Method

[image]

Revit 2013 API
PrintSetup..::..Delete Method
PrintSetup Class See Also Send Feedback
Delete the current print setting, and make the In-Session setting as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class


Rename Method

[image]

Revit 2013 API
PrintSetup..::..Rename Method
PrintSetup Class See Also Send Feedback
Rename the current print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::..String
print setting name to be renamed as.

Return Value

False if Rename operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class


Revert Method

[image]

Revit 2013 API
PrintSetup..::..Revert Method
PrintSetup Class See Also Send Feedback
Revert the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Revert()
Visual Basic
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current print setting is In-Session.

See Also

PrintSetup Class


Save Method

[image]

Revit 2013 API
PrintSetup..::..Save Method
PrintSetup Class See Also Send Feedback
Save the changes for the current print setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Save()
Visual Basic
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current print setting is In-Session or the current print setting has not changed.

See Also

PrintSetup Class


SaveAs Method

[image]

Revit 2013 API
PrintSetup..::..SaveAs Method
PrintSetup Class See Also Send Feedback
Save the current print setting to another print setting with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::..String
print setting name to be saved as.

Return Value

False if Save As operation fails, otherwise true.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input newName already exists in current print setting list.

See Also

PrintSetup Class


PrintSetup Properties

[image] [image]

Revit 2013 API
PrintSetup Properties
PrintSetup Class See Also Send Feedback

The PrintSetup type exposes the following members.

Properties

 | Name | Description
Public property | CurrentPrintSetting | The current Print Setting of Print Setup.
Public property | InSession | The in-session Print Setting of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PrintSetup Class


CurrentPrintSetting Property

[image]

Revit 2013 API
PrintSetup..::..CurrentPrintSetting Property
PrintSetup Class See Also Send Feedback
The current Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IPrintSetting CurrentPrintSetting { get; set; }
Visual Basic
Public Property CurrentPrintSetting As IPrintSetting
    Get
    Set
Visual C++
public:
property IPrintSetting^ CurrentPrintSetting {
    IPrintSetting^ get ();
    void set (IPrintSetting^ value);
}

See Also

PrintSetup Class


InSession Property

[image]

Revit 2013 API
PrintSetup..::..InSession Property
PrintSetup Class See Also Send Feedback
The in-session Print Setting of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InSessionPrintSetting InSession { get; }
Visual Basic
Public ReadOnly Property InSession As InSessionPrintSetting
    Get
Visual C++
public:
property InSessionPrintSetting^ InSession {
    InSessionPrintSetting^ get ();
}

See Also

PrintSetup Class


Profile Class

[image]

Revit 2013 API
Profile Class
Members Example See Also Send Feedback
A geometric profile consisting of a loop of curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Profile : GeometryObject
Visual Basic
Public Class Profile _
    Inherits GeometryObject
Visual C++
public ref class Profile : public GeometryObject

Remarks

The profile may be filled.

Examples

CopyC#
public void GetProfile(Element element)
{
    string messageInfo = "Profile : ";
    if (element is FamilyInstance)
    {
        FamilyInstance beam = element as FamilyInstance;
        if (beam.StructuralType == StructuralType.Beam)
        {
            AnalyticalModel modelFrame = beam.GetAnalyticalModel() as AnalyticalModel;
            Autodesk.Revit.DB.Curve curve = modelFrame.GetCurve();
            // Get AnalyticalModel swept profile
            Autodesk.Revit.DB.Structure.AnalyticalModelSweptProfile sweptProfile = modelFrame.GetSweptProfile();
            Autodesk.Revit.DB.Profile profile = sweptProfile.GetSweptProfile();
            // Get AnalyticalModel swept profile curves size
            messageInfo += "\nSelection name : " + beam.Name;
            messageInfo += "\nSwept Profile Driving Curve size is " + profile.Curves.Size;
            messageInfo += "\nProfile is filled :  " + profile.Filled;
            if (!profile.IsReadOnly)
            {
                profile.Filled = !profile.Filled;
                messageInfo += "\nProfile is filled after setting:  " + profile.Filled;
            }
            TaskDialog.Show("Revit",messageInfo);
        }
    }
}
CopyVB.NET
Public Sub GetProfile(ByVal element As Autodesk.Revit.DB.Element)
    Dim messageInfo As String = "Profile : "
    If TypeOf element Is Autodesk.Revit.DB.FamilyInstance Then
        Dim beam As Autodesk.Revit.DB.FamilyInstance = TryCast(element, Autodesk.Revit.DB.FamilyInstance)
        If beam.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Beam Then
            Dim modelFrame As Autodesk.Revit.DB.Structure.AnalyticalModel = TryCast(beam.GetAnalyticalModel(), Autodesk.Revit.DB.Structure.AnalyticalModel)
            Dim curve As Autodesk.Revit.DB.Curve = modelFrame.GetCurve()
            ' Get AnalyticalModel swept profile

            'HARRY
            Dim sweptProfile As Autodesk.Revit.DB.Structure.AnalyticalModelSweptProfile = modelFrame.GetSweptProfile()
            Dim profile As Autodesk.Revit.DB.Profile = sweptProfile.GetSweptProfile()
            ' Get AnalyticalModel swept profile curves size
            messageInfo += vbLf & "Selection name : " + beam.Name
            messageInfo += vbLf & "Swept Profile Driving Curve size is " + profile.Curves.Size
            messageInfo += vbLf & "Profile is filled :  " + profile.Filled
            If Not profile.IsReadOnly Then
                profile.Filled = Not profile.Filled
                messageInfo += vbLf & "Profile is filled after setting:  " + profile.Filled
            End If
            TaskDialog.Show("Revit", messageInfo)
        End If
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Profile

See Also

Profile Members


Profile Members

[image] [image]

Revit 2013 API
Profile Members
Profile Class Methods Properties See Also Send Feedback

The Profile type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Profile Methods

[image] [image]

Revit 2013 API
Profile Methods
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of this profile.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profile Class


Clone Method

[image]

Revit 2013 API
Profile..::..Clone Method
Profile Class See Also Send Feedback
Returns a copy of this profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Profile Clone()
Visual Basic
Public Function Clone As Profile
Visual C++
public:
Profile^ Clone()

See Also

Profile Class


Profile Properties

[image] [image]

Revit 2013 API
Profile Properties
Profile Class See Also Send Feedback

The Profile type exposes the following members.

Properties

 | Name | Description
Public property | Curves | Retrieve the curves that make up the boundary of the profile.
Public property | Filled | Get or set whether the profile is filled.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Transformed | Transforms this profile and returns the result.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

Profile Class


Curves Property

[image]

Revit 2013 API
Profile..::..Curves Property
Profile Class See Also Send Feedback
Retrieve the curves that make up the boundary of the profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic
Public ReadOnly Property Curves As CurveArray
    Get
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

See Also

Profile Class


Filled Property

[image]

Revit 2013 API
Profile..::..Filled Property
Profile Class See Also Send Feedback
Get or set whether the profile is filled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Filled { get; set; }
Visual Basic
Public Property Filled As Boolean
    Get
    Set
Visual C++
public:
property bool Filled {
    bool get ();
    void set (bool value);
}

See Also

Profile Class


Transformed Property

[image]

Revit 2013 API
Profile..::..Transformed Property
Profile Class See Also Send Feedback
Transforms this profile and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Profile this[
    Transform transform
] { get; }
Visual Basic
Public ReadOnly Property Transformed ( _
    transform As Transform _
) As Profile
    Get
Visual C++
public:
property Profile^ Transformed[Transform^ transform] {
    Profile^ get (Transform^ transform);
}

Parameters

transform
Type: Autodesk.Revit.DB..::..Transform
The transformation used to transform the profile.

Return Value

The transformed profile.

Remarks

Transforms all the curves that define the boundary of this profile.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to transform a curve in the profile.

See Also

Profile Class


ProfilePlaneLocation Enumeration

[image]

Revit 2013 API
ProfilePlaneLocation Enumeration
See Also Send Feedback
Indicates the location of Sweep profile plane on the path curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ProfilePlaneLocation
Visual Basic
Public Enumeration ProfilePlaneLocation
Visual C++
public enum class ProfilePlaneLocation

Members

Member name | Description
Start | Indicates the profile plane located at the start of the path curve.
MidPoint | Indicates the profile plane located at the Middle point of the path curve.
End | Indicates the profile plane located at the End of the path curve.

Remarks

Use this enum in the NewSweep() method to create generic forms.

See Also


ProjectInfo Class

[image]

Revit 2013 API
ProjectInfo Class
Members Example See Also Send Feedback
An object that represents a Project Information within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectInfo : Element
Visual Basic
Public Class ProjectInfo _
    Inherits Element
Visual C++
public ref class ProjectInfo : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Examples

CopyC#
ProjectInfo projectInfo = document.ProjectInformation;

if (null != projectInfo)
{
    string message = "Project information:";
    //get the project name
    message += "\nName: " + projectInfo.Name;
    string newName = "My project";
    //set the project name
    projectInfo.Name = newName;
    message += "\nProject Name after set: " + projectInfo.Name;

    //get the project number
    message += "\nNumber: " + projectInfo.Number;
    string newNumber = "TestNumber";
    //set the project number
    projectInfo.Number = newNumber;
    message += "\nProject Number after set: " + projectInfo.Number;

    //get the status of the project
    message += "\nStatus: " + projectInfo.Status;
    string newStatus = "TestStatus";
    //set the project status
    projectInfo.Status = newStatus;
    message += "\nProject status after set: " + projectInfo.Status;

    //get the address of the project
    message += "\nAddress: " + projectInfo.Address;
    string newAddress = "TestAddress";
    //set the project address
    projectInfo.Address = newAddress;
    message += "\nProject address after set: " + projectInfo.Address;

    //get the client name of the project
    message += "\nClient Name: " + projectInfo.ClientName;
    string newClient = "TestClientName";
    //set the client name
    projectInfo.ClientName = newClient;
    message += "\nProject client name after set: " + projectInfo.ClientName;

    //get the gbXmlSetting of the project
    EnergyDataSettings energyDataSetting = EnergyDataSettings.GetFromDocument(document);
    message += "\nBuilding type: " + energyDataSetting.BuildingType.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Dim projectInfo As Autodesk.Revit.DB.ProjectInfo = document.ProjectInformation

If projectInfo IsNot Nothing Then
    Dim message As String = "Project information:"
    'get the project name
    message += vbLf & "Name: " + projectInfo.Name
    Dim newName As String = "My project"
    'set the project name
    projectInfo.Name = newName
    message += vbLf & "Project Name after set: " + projectInfo.Name

    'get the project number
    message += vbLf & "Number: " + projectInfo.Number
    Dim newNumber As String = "TestNumber"
    'set the project number
    projectInfo.Number = newNumber
    message += vbLf & "Project Number after set: " + projectInfo.Number

    'get the status of the project
    message += vbLf & "Status: " + projectInfo.Status
    Dim newStatus As String = "TestStatus"
    'set the project status
    projectInfo.Status = newStatus
    message += vbLf & "Project status after set: " + projectInfo.Status

    'get the address of the project
    message += vbLf & "Address: " + projectInfo.Address
    Dim newAddress As String = "TestAddress"
    'set the project address
    projectInfo.Address = newAddress
    message += vbLf & "Project address after set: " + projectInfo.Address

    'get the client name of the project
    message += vbLf & "Client Name: " + projectInfo.ClientName
    Dim newClient As String = "TestClientName"
    'set the client name
    projectInfo.ClientName = newClient
    message += vbLf & "Project client name after set: " + projectInfo.ClientName

    'get the gbXmlSetting of the project
    Dim energyDataSetting As Autodesk.Revit.DB.Analysis.EnergyDataSettings = Autodesk.Revit.DB.Analysis.EnergyDataSettings.GetFromDocument(document)
    message += vbLf & "Building type: " + energyDataSetting.BuildingType.ToString()

    TaskDialog.Show("Revit", message)
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ProjectInfo

See Also

ProjectInfo Members


ProjectInfo Members

[image] [image]

Revit 2013 API
ProjectInfo Members
ProjectInfo Class Methods Properties See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Author | Get or Set the Project Author of the Project Information.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingName | Get or Set the Building Name of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClientName | Get or Set the Client Name of the Project Information.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | OrganizationDescription | Get or Set the Organization Description of the Project Information.
Public property | OrganizationName | Get or Set the Organization Name of the Project Information.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Status | Get or Set the Project Status of the Project Information.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectInfo Class


ProjectInfo Methods

[image] [image]

Revit 2013 API
ProjectInfo Methods
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectInfo Class


ProjectInfo Properties

[image] [image]

Revit 2013 API
ProjectInfo Properties
ProjectInfo Class See Also Send Feedback

The ProjectInfo type exposes the following members.

Properties

 | Name | Description
Public property | Address | Get or Set the Project Address of the Project Information.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Author | Get or Set the Project Author of the Project Information.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BuildingName | Get or Set the Building Name of the Project Information.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClientName | Get or Set the Client Name of the Project Information.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IssueDate | Get or Set the Project Issue Date of the Project Information.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get or Set the Project Name of the Project Information.
Public property | Number | Get or Set the Project Number of the Project Information.
Public property | OrganizationDescription | Get or Set the Organization Description of the Project Information.
Public property | OrganizationName | Get or Set the Organization Name of the Project Information.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Status | Get or Set the Project Status of the Project Information.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectInfo Class


Address Property

[image]

Revit 2013 API
ProjectInfo..::..Address Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Address of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Address { get; set; }
Visual Basic
Public Property Address As String
    Get
    Set
Visual C++
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Address of the Project Information.

See Also

ProjectInfo Class


Author Property

[image]

Revit 2013 API
ProjectInfo..::..Author Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Author of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Author { get; set; }
Visual Basic
Public Property Author As String
    Get
    Set
Visual C++
public:
property String^ Author {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Author of the Project Information.

See Also

ProjectInfo Class


BuildingName Property

[image]

Revit 2013 API
ProjectInfo..::..BuildingName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Building Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string BuildingName { get; set; }
Visual Basic
Public Property BuildingName As String
    Get
    Set
Visual C++
public:
property String^ BuildingName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


ClientName Property

[image]

Revit 2013 API
ProjectInfo..::..ClientName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Client Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ClientName { get; set; }
Visual Basic
Public Property ClientName As String
    Get
    Set
Visual C++
public:
property String^ ClientName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Client Name of the Project Information.

See Also

ProjectInfo Class


IssueDate Property

[image]

Revit 2013 API
ProjectInfo..::..IssueDate Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Issue Date of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string IssueDate { get; set; }
Visual Basic
Public Property IssueDate As String
    Get
    Set
Visual C++
public:
property String^ IssueDate {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Issue Date of the Project Information.

See Also

ProjectInfo Class


Name Property

[image]

Revit 2013 API
ProjectInfo..::..Name Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Name of the Project Information.

See Also

ProjectInfo Class


Number Property

[image]

Revit 2013 API
ProjectInfo..::..Number Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Number of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic
Public Property Number As String
    Get
    Set
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


OrganizationDescription Property

[image]

Revit 2013 API
ProjectInfo..::..OrganizationDescription Property
ProjectInfo Class See Also Send Feedback
Get or Set the Organization Description of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string OrganizationDescription { get; set; }
Visual Basic
Public Property OrganizationDescription As String
    Get
    Set
Visual C++
public:
property String^ OrganizationDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


OrganizationName Property

[image]

Revit 2013 API
ProjectInfo..::..OrganizationName Property
ProjectInfo Class See Also Send Feedback
Get or Set the Organization Name of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string OrganizationName { get; set; }
Visual Basic
Public Property OrganizationName As String
    Get
    Set
Visual C++
public:
property String^ OrganizationName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Number of the Project Information.

See Also

ProjectInfo Class


Parameter Property

[image] [image]

Revit 2013 API
ProjectInfo..::..Parameter Property
ProjectInfo Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ProjectInfo Class
ProjectInfo Members


Status Property

[image]

Revit 2013 API
ProjectInfo..::..Status Property
ProjectInfo Class See Also Send Feedback
Get or Set the Project Status of the Project Information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Status { get; set; }
Visual Basic
Public Property Status As String
    Get
    Set
Visual C++
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to get or set the Project Status of the Project Information.

See Also

ProjectInfo Class


ProjectLocation Class

[image]

Revit 2013 API
ProjectLocation Class
Members Example See Also Send Feedback
An object that represents a named location in a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectLocation : Instance
Visual Basic
Public Class ProjectLocation _
    Inherits Instance
Visual C++
public ref class ProjectLocation : public Instance

Remarks

Revit Architecture projects can have named locations. A named location is the position of a model instance in a Revit Architecture project. By default, each Revit Architecture project contains at least one named location, called Internal. Existing ProjectLocation objects can be found by using the ProjectLocations property on the Document object. New project locations can be created by duplicating an existing project location using the Duplicate method, and modifying the location's project position.

Examples

CopyC#
public void ShowActiveProjectLocationUsage(Autodesk.Revit.DB.Document document)
{
    // Get the project location handle
    ProjectLocation projectLocation = document.ActiveProjectLocation;

    // Show the information of current project location
    XYZ origin = new XYZ(0, 0, 0);
    ProjectPosition position = projectLocation.get_ProjectPosition(origin);
    if (null == position)
    {
        throw new Exception("No project position in origin point.");
    }

    // Format the prompt string to show the message.
    String prompt = "Current project location information:\n";
    prompt += "\n\t" + "Origin point position:";
    prompt += "\n\t\t" + "Angle: " + position.Angle;
    prompt += "\n\t\t" + "East to West offset: " + position.EastWest;
    prompt += "\n\t\t" + "Elevation: " + position.Elevation;
    prompt += "\n\t\t" + "North to South offset: " + position.NorthSouth;

    // Angles are in radians when coming from Revit API, so we
    // convert to degrees for display
    const double angleRatio = Math.PI / 180;   // angle conversion factor

    SiteLocation site = projectLocation.SiteLocation;
    prompt += "\n\t" + "Site location:";
    prompt += "\n\t\t" + "Latitude: " + site.Latitude / angleRatio + "��";
    prompt += "\n\t\t" + "Longitude: " + site.Longitude / angleRatio + "��";
    prompt += "\n\t\t" + "TimeZone: " + site.TimeZone;

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub ShowActiveProjectLocationUsage(ByVal document As Autodesk.Revit.DB.Document)
    ' Get the project location handle
    Dim projectLocation As ProjectLocation = document.ActiveProjectLocation

    ' Show the information of current project location
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
    Dim position As ProjectPosition = projectLocation.ProjectPosition(origin)
    If position Is Nothing Then
        Throw New Exception("No project position in origin point.")
    End If

    ' Format the prompt string to show the message.
    Dim prompt As [String] = "Current project location information:" & vbLf
    prompt += vbLf & vbTab + "Origin point position:"
    prompt += vbLf & vbTab & vbTab + "Angle: " + position.Angle
    prompt += vbLf & vbTab & vbTab + "East to West offset: " + position.EastWest
    prompt += vbLf & vbTab & vbTab + "Elevation: " + position.Elevation
    prompt += vbLf & vbTab & vbTab + "North to South offset: " + position.NorthSouth

    ' Angles are in radians when coming from Revit API, so we
    ' convert to degrees for display
    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim site As SiteLocation = projectLocation.SiteLocation
    prompt += vbLf & vbTab + "Site location:"
    prompt += vbLf & vbTab & vbTab + "Latitude: " + site.Latitude / angleRatio + "¡ã"
    prompt += vbLf & vbTab & vbTab + "Longitude: " + site.Longitude / angleRatio + "¡ã"
    prompt += vbLf & vbTab & vbTab + "TimeZone: " + site.TimeZone

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..ProjectLocation

See Also

ProjectLocation Members


ProjectLocation Members

[image] [image]

Revit 2013 API
ProjectLocation Members
ProjectLocation Class Methods Properties See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name of the project location. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
Public property | SiteLocation | The site location to which this project location refers.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectLocation Class


ProjectLocation Methods

[image] [image]

Revit 2013 API
ProjectLocation Methods
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Generate a copy of this project location with the specified name.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocation Class


Duplicate Method

[image]

Revit 2013 API
ProjectLocation..::..Duplicate Method
ProjectLocation Class Example See Also Send Feedback
Generate a copy of this project location with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocation Duplicate(
    string name
)
Visual Basic
Public Function Duplicate ( _
    name As String _
) As ProjectLocation
Visual C++
public:
ProjectLocation^ Duplicate(
    String^ name
)

Parameters

name
Type: System..::..String
The name to be assigned to the duplicated project location.

Return Value

If successful a duplicate of this project location object with the specified name.

Remarks

The name must not be the same as any existing site location objects.

Examples

CopyC#
public ProjectLocation DuplicateLocation(Autodesk.Revit.DB.Document document, string newName)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;
    ProjectLocationSet locations = document.ProjectLocations;
    foreach (ProjectLocation projectLocation in locations)
    {
        if (projectLocation.Name == newName)
        {
            throw new Exception("The name is same as a project location's name, please change one.");
        }
    }
    return currentLocation.Duplicate(newName);
}
CopyVB.NET
Public Function DuplicateLocation(ByVal document As Autodesk.Revit.DB.Document, ByVal newName As String) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation
    Dim locations As ProjectLocationSet = document.ProjectLocations
    For Each projectLocation As ProjectLocation In locations
        If projectLocation.Name = newName Then
            Throw New Exception("The name is same as a project location's name, please change one.")
        End If
    Next
    Return currentLocation.Duplicate(newName)
End Function

See Also

ProjectLocation Class


ProjectLocation Properties

[image] [image]

Revit 2013 API
ProjectLocation Properties
ProjectLocation Class See Also Send Feedback

The ProjectLocation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name of the project location. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectPosition | Gets or sets the coordinates of a point in the project location coordinate system.
Public property | SiteLocation | The site location to which this project location refers.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectLocation Class


Name Property

[image]

Revit 2013 API
ProjectLocation..::..Name Property
ProjectLocation Class See Also Send Feedback
The name of the project location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Remarks

This property is used to get or set the name of the project location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failing to set the name (for example, because it is not unique).

See Also

ProjectLocation Class


Parameter Property

[image] [image]

Revit 2013 API
ProjectLocation..::..Parameter Property
ProjectLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ProjectLocation Class
ProjectLocation Members


ProjectPosition Property

[image]

Revit 2013 API
ProjectLocation..::..ProjectPosition Property
ProjectLocation Class Example See Also Send Feedback
Gets or sets the coordinates of a point in the project location coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectPosition this[
    XYZ point
] { get; set; }
Visual Basic
Public Property ProjectPosition ( _
    point As XYZ _
) As ProjectPosition
    Get
    Set
Visual C++
public:
property ProjectPosition^ ProjectPosition[XYZ^ point] {
    ProjectPosition^ get (XYZ^ point);
    void set (XYZ^ point, ProjectPosition^ value);
}

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point in model coordinates.

Remarks

When getting this property, the North/South, East/West, and Elevation values report the coordinates of the point similar to the Revit command "Report Shared Coordinates". To get the values of the transformations applied by this project location, pass XYZ.Zero.

If the project has acquired shared coordinates from a linked model, the shared coordinate transformation will be reflected in the coordinates of the transformed point returned by this property.

When setting this property, the transformations applied to the location are modified such that the passed point becomes the specified North/South, East/West and Elevation, and the coordinate transform will have the designated angular rotation. This is similar to the Revit command "Specify Coordinates at Point".

Examples

CopyC#
//get and set the value of the projectlocation
public ProjectLocation GetProjectLocation(Autodesk.Revit.DB.Document document)
{
    ProjectLocation currentLocation = document.ActiveProjectLocation;

    //get the project position
    XYZ origin = new XYZ(0, 0, 0);

    const double angleRatio = Math.PI / 180;   // angle conversion factor

    ProjectPosition projectPosition = currentLocation.get_ProjectPosition(origin);
    //Angle from True North
    double angle = 30.0 * angleRatio;   // convert degrees to radian
    double eastWest = 30.0;     //East to West offset
    double northSouth = 23.32;   //North to South offset
    double elevation = 22.14;    //Elevation above ground level

    //create a new project position
    ProjectPosition newPosition =
      document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle);

    if (null != newPosition)
    {
        //set the value of the project position
        currentLocation.set_ProjectPosition(origin, newPosition);
    }

    return currentLocation;
}
CopyVB.NET
'get and set the value of the projectlocation
Public Function GetProjectLocation(ByVal document As Autodesk.Revit.DB.Document) As ProjectLocation
    Dim currentLocation As ProjectLocation = document.ActiveProjectLocation

    'get the project position
    Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)

    Const angleRatio As Double = Math.PI / 180
    ' angle conversion factor
    Dim projectPosition As ProjectPosition = currentLocation.ProjectPosition(origin)
    'Angle from True North
    Dim angle As Double = 30 * angleRatio
    ' convert degrees to radian
    Dim eastWest As Double = 30
    'East to West offset
    Dim northSouth As Double = 23.32
    'North to South offset
    Dim elevation As Double = 22.14
    'Elevation above ground level
    'create a new project position
    Dim newPosition As ProjectPosition = document.Application.Create.NewProjectPosition(eastWest, northSouth, elevation, angle)

    If newPosition IsNot Nothing Then
        'set the value of the project position
        currentLocation.ProjectPosition(origin) = newPosition
    End If

    Return currentLocation
End Function

See Also

ProjectLocation Class


SiteLocation Property

[image]

Revit 2013 API
ProjectLocation..::..SiteLocation Property
ProjectLocation Class See Also Send Feedback
The site location to which this project location refers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SiteLocation SiteLocation { get; }
Visual Basic
Public ReadOnly Property SiteLocation As SiteLocation
    Get
Visual C++
public:
property SiteLocation^ SiteLocation {
    SiteLocation^ get ();
}

Remarks

The site location object contains the longitude, latitude and time-zone of the entire project site.

See Also

ProjectLocation Class


ProjectLocationSet Class

[image]

Revit 2013 API
ProjectLocationSet Class
Members See Also Send Feedback
An set that contains project locations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectLocationSet : APIObject,
    IEnumerable
Visual Basic
Public Class ProjectLocationSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ProjectLocationSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ProjectLocationSet

See Also

ProjectLocationSet Members


ProjectLocationSet Members

[image] [image]

Revit 2013 API
ProjectLocationSet Members
ProjectLocationSet Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectLocationSet | Initializes a new instance of the ProjectLocationSet class

Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class


ProjectLocationSet Constructor

[image]

Revit 2013 API
ProjectLocationSet Constructor
ProjectLocationSet Class See Also Send Feedback
Initializes a new instance of the ProjectLocationSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocationSet()
Visual Basic
Public Sub New
Visual C++
public:
ProjectLocationSet()

See Also

ProjectLocationSet Class


ProjectLocationSet Methods

[image] [image]

Revit 2013 API
ProjectLocationSet Methods
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every project location from the set, rendering it empty.
Public method | Contains | Tests for the existence of a project location within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified project location from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified project location into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSet Class


Clear Method

[image]

Revit 2013 API
ProjectLocationSet..::..Clear Method
ProjectLocationSet Class See Also Send Feedback
Removes every project location from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ProjectLocationSet Class


Contains Method

[image]

Revit 2013 API
ProjectLocationSet..::..Contains Method
ProjectLocationSet Class See Also Send Feedback
Tests for the existence of a project location within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Contains ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be searched for.

Return Value

The Contains method returns True if the project location is within the set, otherwise False.

See Also

ProjectLocationSet Class


Erase Method

[image]

Revit 2013 API
ProjectLocationSet..::..Erase Method
ProjectLocationSet Class See Also Send Feedback
Removes a specified project location from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Erase ( _
    item As ProjectLocation _
) As Integer
Visual C++
public:
virtual int Erase(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be erased.

Return Value

The number of project locations that were erased from the set.

See Also

ProjectLocationSet Class


ForwardIterator Method

[image]

Revit 2013 API
ProjectLocationSet..::..ForwardIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ProjectLocationSet Class


GetEnumerator Method

[image]

Revit 2013 API
ProjectLocationSet..::..GetEnumerator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ProjectLocationSet Class


Insert Method

[image]

Revit 2013 API
ProjectLocationSet..::..Insert Method
ProjectLocationSet Class See Also Send Feedback
Insert the specified project location into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    ProjectLocation item
)
Visual Basic
Public Overridable Function Insert ( _
    item As ProjectLocation _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ProjectLocation^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ProjectLocation
The project location to be inserted into the set.

Return Value

Returns whether the project location was inserted into the set.

See Also

ProjectLocationSet Class


ReverseIterator Method

[image]

Revit 2013 API
ProjectLocationSet..::..ReverseIterator Method
ProjectLocationSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ProjectLocationSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ProjectLocationSetIterator
Visual C++
public:
virtual ProjectLocationSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ProjectLocationSet Class


ProjectLocationSet Properties

[image] [image]

Revit 2013 API
ProjectLocationSet Properties
ProjectLocationSet Class See Also Send Feedback

The ProjectLocationSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of project locations that are in the set.

See Also

ProjectLocationSet Class


IsEmpty Property

[image]

Revit 2013 API
ProjectLocationSet..::..IsEmpty Property
ProjectLocationSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ProjectLocationSet Class


Size Property

[image]

Revit 2013 API
ProjectLocationSet..::..Size Property
ProjectLocationSet Class See Also Send Feedback
Returns the number of project locations that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ProjectLocationSet Class


ProjectLocationSetIterator Class

[image]

Revit 2013 API
ProjectLocationSetIterator Class
Members See Also Send Feedback
An iterator to a project location set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ProjectLocationSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ProjectLocationSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ProjectLocationSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ProjectLocationSetIterator

See Also

ProjectLocationSetIterator Members


ProjectLocationSetIterator Members

[image] [image]

Revit 2013 API
ProjectLocationSetIterator Members
ProjectLocationSetIterator Class Constructors Methods Properties See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectLocationSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Constructor

[image]

Revit 2013 API
ProjectLocationSetIterator Constructor
ProjectLocationSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectLocationSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ProjectLocationSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Methods

[image] [image]

Revit 2013 API
ProjectLocationSetIterator Methods
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectLocationSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ProjectLocationSetIterator..::..MoveNext Method
ProjectLocationSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


Reset Method

[image]

Revit 2013 API
ProjectLocationSetIterator..::..Reset Method
ProjectLocationSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ProjectLocationSetIterator Class


ProjectLocationSetIterator Properties

[image] [image]

Revit 2013 API
ProjectLocationSetIterator Properties
ProjectLocationSetIterator Class See Also Send Feedback

The ProjectLocationSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ProjectLocationSetIterator Class


Current Property

[image]

Revit 2013 API
ProjectLocationSetIterator..::..Current Property
ProjectLocationSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ProjectLocationSetIterator Class


ProjectPosition Class

[image]

Revit 2013 API
ProjectPosition Class
Members See Also Send Feedback
An object that is used to represent a geographical offset and rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectPosition : APIObject
Visual Basic
Public Class ProjectPosition _
    Inherits APIObject
Visual C++
public ref class ProjectPosition : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ProjectPosition

See Also

ProjectPosition Members


ProjectPosition Members

[image] [image]

Revit 2013 API
ProjectPosition Members
ProjectPosition Class Constructors Methods Properties See Also Send Feedback

The ProjectPosition type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectPosition | Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Angle | Angle from True North
Public property | EastWest | East/West offset
Public property | Elevation | Elevation above ground level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NorthSouth | North/South offset

See Also

ProjectPosition Class


ProjectPosition Constructor

[image]

Revit 2013 API
ProjectPosition Constructor
ProjectPosition Class See Also Send Feedback
Construct a new ProjectPosition object with the specified East/West offset, North/South offset, elevation offset and angle of rotation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)
Visual Basic
Public Sub New ( _
    ew As Double, _
    ns As Double, _
    elevation As Double, _
    angle As Double _
)
Visual C++
public:
ProjectPosition(
    double ew,
    double ns,
    double elevation,
    double angle
)

Parameters

ew
Type: System..::..Double
East/West offset
ns
Type: System..::..Double
North/South offset
elevation
Type: System..::..Double
Elevation offset
angle
Type: System..::..Double
Rotation from true north, in radians.

Remarks

The angle can be in the range of +PI to -PI

See Also

ProjectPosition Class


ProjectPosition Methods

[image] [image]

Revit 2013 API
ProjectPosition Methods
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectPosition Class


ProjectPosition Properties

[image] [image]

Revit 2013 API
ProjectPosition Properties
ProjectPosition Class See Also Send Feedback

The ProjectPosition type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Angle from True North
Public property | EastWest | East/West offset
Public property | Elevation | Elevation above ground level.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | NorthSouth | North/South offset

See Also

ProjectPosition Class


Angle Property

[image]

Revit 2013 API
ProjectPosition..::..Angle Property
ProjectPosition Class See Also Send Feedback
Angle from True North

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Angle { get; set; }
Visual Basic
Public Property Angle As Double
    Get
    Set
Visual C++
public:
property double Angle {
    double get ();
    void set (double value);
}

Remarks

This is the angle difference between project north and true north measured in radians. It can have a value from -PI to +PI.

See Also

ProjectPosition Class


EastWest Property

[image]

Revit 2013 API
ProjectPosition..::..EastWest Property
ProjectPosition Class See Also Send Feedback
East/West offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double EastWest { get; set; }
Visual Basic
Public Property EastWest As Double
    Get
    Set
Visual C++
public:
property double EastWest {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the east/west direction. Measured in decimal feet.

See Also

ProjectPosition Class


Elevation Property

[image]

Revit 2013 API
ProjectPosition..::..Elevation Property
ProjectPosition Class See Also Send Feedback
Elevation above ground level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Elevation { get; set; }
Visual Basic
Public Property Elevation As Double
    Get
    Set
Visual C++
public:
property double Elevation {
    double get ();
    void set (double value);
}

Remarks

Measured in decimal feet.

See Also

ProjectPosition Class


NorthSouth Property

[image]

Revit 2013 API
ProjectPosition..::..NorthSouth Property
ProjectPosition Class See Also Send Feedback
North/South offset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double NorthSouth { get; set; }
Visual Basic
Public Property NorthSouth As Double
    Get
    Set
Visual C++
public:
property double NorthSouth {
    double get ();
    void set (double value);
}

Remarks

The offset of the project location from the site location in the north/south direction. Measured in decimal feet.

See Also

ProjectPosition Class


ProjectUnit Class

[image]

Revit 2013 API
ProjectUnit Class
Members Example See Also Send Feedback
Provides access to the Project Unit... in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ProjectUnit : Element
Visual Basic
Public Class ProjectUnit _
    Inherits Element
Visual C++
public ref class ProjectUnit : public Element

Remarks

The ProjectUnit object can be queried for its D in space planning tools.

Examples

CopyC#
ProjectUnit projectUnit = document.ProjectUnit;

if (null != projectUnit)
{
    string message = "Project Unit: ";

    //get the DecimalSymbolType
    message += "\nDecimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString();

    //show the usage for FormatOptions property
    message += "\nFormat Options: ";
    FormatOptions formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Length);
    message += "\n\tLength : " + formatOptions.Name;
    formatOptions = projectUnit.get_FormatOptions(UnitType.UT_Volume);
    message += "\n\tVolume : " + formatOptions.Name;

    //get the Digit Grouping Amount of the project
    DigitGroupingAmount dga = projectUnit.DigitGroupingAmount;
    message += "\nDigit Grouping Amount: " + dga.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Dim projectUnit As ProjectUnit = document.ProjectUnit

If projectUnit IsNot Nothing Then
    Dim message As String = "Project Unit: "

    'get the DecimalSymbolType
    message += vbLf & "Decimal Symbol Type: " + projectUnit.DecimalSymbolType.ToString()

    'show the usage for FormatOptions property
    message += vbLf & "Format Options: "
    Dim formatOptions As Autodesk.Revit.DB.FormatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Length)
    message += vbLf & vbTab & "Length : " + formatOptions.Name
    formatOptions = projectUnit.FormatOptions(Autodesk.Revit.DB.UnitType.UT_Volume)
    message += vbLf & vbTab & "Volume : " + formatOptions.Name

    'get the Digit Grouping Amount of the project
    Dim dga As Autodesk.Revit.DB.DigitGroupingAmount = projectUnit.DigitGroupingAmount
    message += vbLf & "Digit Grouping Amount: " + dga.ToString()

    TaskDialog.Show("Revit", message)
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ProjectUnit

See Also

ProjectUnit Members


ProjectUnit Members

[image] [image]

Revit 2013 API
ProjectUnit Members
ProjectUnit Class Methods Properties See Also Send Feedback

The ProjectUnit type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | setDigitGroupingType | Set the Digit Grouping Amount, using the three types
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
Public property | DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FormatOptions | Get the Format Options of the Project Unit Settings.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectUnit Class


ProjectUnit Methods

[image] [image]

Revit 2013 API
ProjectUnit Methods
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | setDigitGroupingType | Set the Digit Grouping Amount, using the three types
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProjectUnit Class


setDigitGroupingType Method

[image]

Revit 2013 API
ProjectUnit..::..setDigitGroupingType Method
ProjectUnit Class See Also Send Feedback
Set the Digit Grouping Amount, using the three types

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)
Visual Basic
Public Sub setDigitGroupingType ( _
    dst As DecimalSymbolType, _
    dgst As DigitGroupingSymbolType, _
    dga As DigitGroupingAmount _
)
Visual C++
public:
void setDigitGroupingType(
    DecimalSymbolType dst,
    DigitGroupingSymbolType dgst,
    DigitGroupingAmount dga
)

Parameters

dst
Type: Autodesk.Revit.DB..::..DecimalSymbolType
dgst
Type: Autodesk.Revit.DB..::..DigitGroupingSymbolType
dga
Type: Autodesk.Revit.DB..::..DigitGroupingAmount

See Also

ProjectUnit Class


ProjectUnit Properties

[image] [image]

Revit 2013 API
ProjectUnit Properties
ProjectUnit Class See Also Send Feedback

The ProjectUnit type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DecimalSymbolType | Get the Decimal Symbol type of Project Unit Settings.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DigitGroupingAmount | Get the Digit Grouping Amount of Project Unit Settings.
Public property | DigitGroupingSymbolType | Get the Digit Grouping Symbol type of Project Unit Settings.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FormatOptions | Get the Format Options of the Project Unit Settings.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ProjectUnit Class


DecimalSymbolType Property

[image]

Revit 2013 API
ProjectUnit..::..DecimalSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Decimal Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DecimalSymbolType DecimalSymbolType { get; }
Visual Basic
Public ReadOnly Property DecimalSymbolType As DecimalSymbolType
    Get
Visual C++
public:
property DecimalSymbolType DecimalSymbolType {
    DecimalSymbolType get ();
}

Return Value

The type of the Decimal Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DecimalSymbolType::DST_DOT.

See Also

ProjectUnit Class


DigitGroupingAmount Property

[image]

Revit 2013 API
ProjectUnit..::..DigitGroupingAmount Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Amount of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DigitGroupingAmount DigitGroupingAmount { get; }
Visual Basic
Public ReadOnly Property DigitGroupingAmount As DigitGroupingAmount
    Get
Visual C++
public:
property DigitGroupingAmount DigitGroupingAmount {
    DigitGroupingAmount get ();
}

Return Value

The type of the Digit Grouping Amount.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DigitGroupingAmount::DGA_THREE.

See Also

ProjectUnit Class


DigitGroupingSymbolType Property

[image]

Revit 2013 API
ProjectUnit..::..DigitGroupingSymbolType Property
ProjectUnit Class See Also Send Feedback
Get the Digit Grouping Symbol type of Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DigitGroupingSymbolType DigitGroupingSymbolType { get; }
Visual Basic
Public ReadOnly Property DigitGroupingSymbolType As DigitGroupingSymbolType
    Get
Visual C++
public:
property DigitGroupingSymbolType DigitGroupingSymbolType {
    DigitGroupingSymbolType get ();
}

Return Value

The type of the Digit Grouping Symbol.

Remarks

The property only applies to parameters of value types. If the parameter is not a value, the get method returns Revit::DB::DigitGroupingSymbolType::DGST_COMMA.

See Also

ProjectUnit Class


FormatOptions Property

[image]

Revit 2013 API
ProjectUnit..::..FormatOptions Property
ProjectUnit Class See Also Send Feedback
Get the Format Options of the Project Unit Settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FormatOptions this[
    UnitType ut
] { get; }
Visual Basic
Public ReadOnly Property FormatOptions ( _
    ut As UnitType _
) As FormatOptions
    Get
Visual C++
public:
property FormatOptions^ FormatOptions[UnitType ut] {
    FormatOptions^ get (UnitType ut);
}

Parameters

ut
Type: Autodesk.Revit.DB..::..UnitType

Remarks

.

See Also

ProjectUnit Class


Name Property

[image]

Revit 2013 API
ProjectUnit..::..Name Property
ProjectUnit Class See Also Send Feedback
Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The method set is override to forbid the user to change the Name. When the user tries to call the method set for ProjectUnit object, an InvalidOperationException will be thrown.

See Also

ProjectUnit Class


Parameter Property

[image] [image]

Revit 2013 API
ProjectUnit..::..Parameter Property
ProjectUnit Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ProjectUnit Class
ProjectUnit Members


PropertyLine Class

[image]

Revit 2013 API
PropertyLine Class
Members See Also Send Feedback
Represents kinds of PropertyLines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PropertyLine : Element
Visual Basic
Public Class PropertyLine _
    Inherits Element
Visual C++
public ref class PropertyLine : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PropertyLine

See Also

PropertyLine Members


PropertyLine Members

[image] [image]

Revit 2013 API
PropertyLine Members
PropertyLine Class Methods Properties See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertyLine Class


PropertyLine Methods

[image] [image]

Revit 2013 API
PropertyLine Methods
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyLine Class


PropertyLine Properties

[image] [image]

Revit 2013 API
PropertyLine Properties
PropertyLine Class See Also Send Feedback

The PropertyLine type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertyLine Class


Parameter Property

[image] [image]

Revit 2013 API
PropertyLine..::..Parameter Property
PropertyLine Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PropertyLine Class
PropertyLine Members


PropertySetElement Class

[image]

Revit 2013 API
PropertySetElement Class
Members See Also Send Feedback
An element that groups together a set of related parameters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PropertySetElement : Element
Visual Basic
Public Class PropertySetElement _
    Inherits Element
Visual C++
public ref class PropertySetElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PropertySetElement

See Also

PropertySetElement Members


PropertySetElement Members

[image] [image]

Revit 2013 API
PropertySetElement Members
PropertySetElement Class Methods Properties See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, MaterialAspect) | Obsolete. Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStructuralAsset |
Public method | GetThermalAsset |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralAsset |
Public method | SetThermalAsset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetElement Class


PropertySetElement Methods

[image] [image]

Revit 2013 API
PropertySetElement Methods
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, MaterialAspect) | Obsolete. Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.
 | Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
 | Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Creates a duplicate of this PropertySetElement.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStructuralAsset |
Public method | GetThermalAsset |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetStructuralAsset |
Public method | SetThermalAsset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertySetElement Class


Create Method

[image] [image]

Revit 2013 API
PropertySetElement..::..Create Method
PropertySetElement Class See Also Send Feedback

Overload List

Name | Description
Create(Document, MaterialAspect) | Obsolete. Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.
Create(Document, StructuralAsset) | Creates a new PropertySetElement to contain the given asset.
Create(Document, ThermalAsset) | Creates a new PropertySetElement to contain the given asset.

See Also

PropertySetElement Class
PropertySetElement Members


Create Method (Document, MaterialAspect)

[image]

Revit 2013 API
PropertySetElement..::..Create Method (Document, MaterialAspect)
PropertySetElement Class See Also Send Feedback
Creates a new PropertySetElement initialized with default properties pertinent to the given material aspect.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")]
public static PropertySetElement Create(
    Document document,
    MaterialAspect materialAspect
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")> _
Public Shared Function Create ( _
    document As Document, _
    materialAspect As MaterialAspect _
) As PropertySetElement
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Use the version that takes an asset (StructuralAsset, ThermalAsset, etc.) argument instead.")]
public:
static PropertySetElement^ Create(
    Document^ document,
    MaterialAspect materialAspect
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
materialAspect
Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect that defines the default values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given material aspect is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class
Create Overload


Create Method (Document, StructuralAsset)

[image]

Revit 2013 API
PropertySetElement..::..Create Method (Document, StructuralAsset)
PropertySetElement Class See Also Send Feedback
Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PropertySetElement Create(
    Document document,
    StructuralAsset structuralAsset
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    structuralAsset As StructuralAsset _
) As PropertySetElement
Visual C++
public:
static PropertySetElement^ Create(
    Document^ document,
    StructuralAsset^ structuralAsset
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset containing the values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class
Create Overload


Create Method (Document, ThermalAsset)

[image]

Revit 2013 API
PropertySetElement..::..Create Method (Document, ThermalAsset)
PropertySetElement Class See Also Send Feedback
Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PropertySetElement Create(
    Document document,
    ThermalAsset thermalAsset
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    thermalAsset As ThermalAsset _
) As PropertySetElement
Visual C++
public:
static PropertySetElement^ Create(
    Document^ document,
    ThermalAsset^ thermalAsset
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
thermalAsset
Type: Autodesk.Revit.DB..::..ThermalAsset
The thermal asset containing the values that will be present in the PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class
Create Overload


Duplicate Method

[image]

Revit 2013 API
PropertySetElement..::..Duplicate Method
PropertySetElement Class See Also Send Feedback
Creates a duplicate of this PropertySetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PropertySetElement Duplicate(
    Document document,
    string name
)
Visual Basic
Public Function Duplicate ( _
    document As Document, _
    name As String _
) As PropertySetElement
Visual C++
public:
PropertySetElement^ Duplicate(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
name
Type: System..::..String
The name to use for the new PropertySetElement.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for name is already in use as a property set name. -or- name is an empty string. -or- name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class


GetStructuralAsset Method

[image]

Revit 2013 API
PropertySetElement..::..GetStructuralAsset Method
PropertySetElement Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public StructuralAsset GetStructuralAsset()
Visual Basic
Public Function GetStructuralAsset As StructuralAsset
Visual C++
public:
StructuralAsset^ GetStructuralAsset()

See Also

PropertySetElement Class


GetThermalAsset Method

[image]

Revit 2013 API
PropertySetElement..::..GetThermalAsset Method
PropertySetElement Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ThermalAsset GetThermalAsset()
Visual Basic
Public Function GetThermalAsset As ThermalAsset
Visual C++
public:
ThermalAsset^ GetThermalAsset()

See Also

PropertySetElement Class


SetStructuralAsset Method

[image]

Revit 2013 API
PropertySetElement..::..SetStructuralAsset Method
PropertySetElement Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetStructuralAsset(
    StructuralAsset structuralAsset
)
Visual Basic
Public Sub SetStructuralAsset ( _
    structuralAsset As StructuralAsset _
)
Visual C++
public:
void SetStructuralAsset(
    StructuralAsset^ structuralAsset
)

Parameters

structuralAsset
Type: Autodesk.Revit.DB..::..StructuralAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class


SetThermalAsset Method

[image]

Revit 2013 API
PropertySetElement..::..SetThermalAsset Method
PropertySetElement Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetThermalAsset(
    ThermalAsset thermalAsset
)
Visual Basic
Public Sub SetThermalAsset ( _
    thermalAsset As ThermalAsset _
)
Visual C++
public:
void SetThermalAsset(
    ThermalAsset^ thermalAsset
)

Parameters

thermalAsset
Type: Autodesk.Revit.DB..::..ThermalAsset

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetElement Class


PropertySetElement Properties

[image] [image]

Revit 2013 API
PropertySetElement Properties
PropertySetElement Class See Also Send Feedback

The PropertySetElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetElement Class


Parameter Property

[image] [image]

Revit 2013 API
PropertySetElement..::..Parameter Property
PropertySetElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PropertySetElement Class
PropertySetElement Members


PropertySetLibrary Class

[image]

Revit 2013 API
PropertySetLibrary Class
Members See Also Send Feedback
A named collection of property sets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
[ObsoleteAttribute("This class is deprecated in Revit 2013.  It will be replaced in a future version of Revit.")]
public class PropertySetLibrary : Element
Visual Basic
<ObsoleteAttribute("This class is deprecated in Revit 2013.  It will be replaced in a future version of Revit.")> _
Public Class PropertySetLibrary _
    Inherits Element
Visual C++
[ObsoleteAttribute(L"This class is deprecated in Revit 2013.  It will be replaced in a future version of Revit.")]
public ref class PropertySetLibrary : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..PropertySetLibrary

See Also

PropertySetLibrary Members


PropertySetLibrary Members

[image] [image]

Revit 2013 API
PropertySetLibrary Members
PropertySetLibrary Class Methods Properties See Also Send Feedback

The PropertySetLibrary type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertySet | Adds a property set from the document to this library.
Public method | AddPropertySetWithName | Adds a property set from the document to this library using an alternate name.
Public method | AddToDocument | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
Public method | AddToDocumentWithName | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new property set library in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportXml | Export this property set library to an external, XML-based file.
 | Find | Finds an existing PropertySetLibrary with a given name.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetName |
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasPropertySet | Determines whether the library has a property set with a given name.
 | ImportXml | Import an external property set library into a Revit document.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemovePropertySet | Removes a property set with a given name from the library.
Public method | RenamePropertySet | Renames a property set in the library.
Public method | RenameSubclass | Changes the subclass field of all property sets in this library from one value to another.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetName |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Locked | Indicates whether a property set library is locked into a document or not. Locked libraries are read-only and cannot be removed.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReadOnly | Indicates whether a property set library is read-only or not. Read-only libraries cannot be renamed, or added to.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetLibrary Class


PropertySetLibrary Methods

[image] [image]

Revit 2013 API
PropertySetLibrary Methods
PropertySetLibrary Class See Also Send Feedback

The PropertySetLibrary type exposes the following members.

Methods

 | Name | Description
Public method | AddPropertySet | Adds a property set from the document to this library.
Public method | AddPropertySetWithName | Adds a property set from the document to this library using an alternate name.
Public method | AddToDocument | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
Public method | AddToDocumentWithName | Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new property set library in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportXml | Export this property set library to an external, XML-based file.
 | Find | Finds an existing PropertySetLibrary with a given name.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetName |
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasPropertySet | Determines whether the library has a property set with a given name.
 | ImportXml | Import an external property set library into a Revit document.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemovePropertySet | Removes a property set with a given name from the library.
Public method | RenamePropertySet | Renames a property set in the library.
Public method | RenameSubclass | Changes the subclass field of all property sets in this library from one value to another.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetName |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertySetLibrary Class


AddPropertySet Method

[image]

Revit 2013 API
PropertySetLibrary..::..AddPropertySet Method
PropertySetLibrary Class See Also Send Feedback
Adds a property set from the document to this library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddPropertySet(
    ElementId propertySetId
)
Visual Basic
Public Sub AddPropertySet ( _
    propertySetId As ElementId _
)
Visual C++
public:
void AddPropertySet(
    ElementId^ propertySetId
)

Parameters

propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the property set to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given ElementId does not refer to a PropertySetElement
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


AddPropertySetWithName Method

[image]

Revit 2013 API
PropertySetLibrary..::..AddPropertySetWithName Method
PropertySetLibrary Class See Also Send Feedback
Adds a property set from the document to this library using an alternate name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddPropertySetWithName(
    ElementId propertySetId,
    string name
)
Visual Basic
Public Sub AddPropertySetWithName ( _
    propertySetId As ElementId, _
    name As String _
)
Visual C++
public:
void AddPropertySetWithName(
    ElementId^ propertySetId,
    String^ name
)

Parameters

propertySetId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of the property set to add.
name
Type: System..::..String
The alternate name to use for the property set in the library.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given ElementId does not refer to a PropertySetElement -or- The library already contains a property set with the given name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


AddToDocument Method

[image]

Revit 2013 API
PropertySetLibrary..::..AddToDocument Method
PropertySetLibrary Class See Also Send Feedback
Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PropertySetElement AddToDocument(
    string name,
    Document document,
    bool overwrite
)
Visual Basic
Public Function AddToDocument ( _
    name As String, _
    document As Document, _
    overwrite As Boolean _
) As PropertySetElement
Visual C++
public:
PropertySetElement^ AddToDocument(
    String^ name,
    Document^ document,
    bool overwrite
)

Parameters

name
Type: System..::..String
The name of the property set in the library to add to the document. Will also become the name of the property set element created in the document.
document
Type: Autodesk.Revit.DB..::..Document
The document to which the property set will be added.
overwrite
Type: System..::..Boolean
If true, any existing property set with the given name will be overwritten.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No property set with the given name exists in the library.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | a PropertySetElement with the given name already exists and the overwrite flag is false.

See Also

PropertySetLibrary Class


AddToDocumentWithName Method

[image]

Revit 2013 API
PropertySetLibrary..::..AddToDocumentWithName Method
PropertySetLibrary Class See Also Send Feedback
Adds a property set from a library to the document. The property set will be available for use even if the library is unloaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PropertySetElement AddToDocumentWithName(
    string name,
    Document document,
    bool overwrite,
    string addAsName
)
Visual Basic
Public Function AddToDocumentWithName ( _
    name As String, _
    document As Document, _
    overwrite As Boolean, _
    addAsName As String _
) As PropertySetElement
Visual C++
public:
PropertySetElement^ AddToDocumentWithName(
    String^ name,
    Document^ document,
    bool overwrite,
    String^ addAsName
)

Parameters

name
Type: System..::..String
The name of the property set in the library to add to the document.
document
Type: Autodesk.Revit.DB..::..Document
The document to which the property set will be added.
overwrite
Type: System..::..Boolean
If true, any existing property set with the given name will be overwritten.
addAsName
Type: System..::..String
The name to use for the new property set element in the document.

Return Value

The new PropertySetElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No property set with the given name exists in the library. -or- addAsName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | a PropertySetElement with the given name already exists and the overwrite flag is false.

See Also

PropertySetLibrary Class


Create Method

[image]

Revit 2013 API
PropertySetLibrary..::..Create Method
PropertySetLibrary Class See Also Send Feedback
Creates a new property set library in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PropertySetLibrary Create(
    Document document
)
Visual Basic
Public Shared Function Create ( _
    document As Document _
) As PropertySetLibrary
Visual C++
public:
static PropertySetLibrary^ Create(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the new property set library.

Return Value

The new PropertySetLibrary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetLibrary Class


ExportXml Method

[image]

Revit 2013 API
PropertySetLibrary..::..ExportXml Method
PropertySetLibrary Class See Also Send Feedback
Export this property set library to an external, XML-based file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportXml(
    string fileName
)
Visual Basic
Public Function ExportXml ( _
    fileName As String _
) As Boolean
Visual C++
public:
bool ExportXml(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Name of the file to write.

Return Value

True if the export succeeded, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.

See Also

PropertySetLibrary Class


Find Method

[image]

Revit 2013 API
PropertySetLibrary..::..Find Method
PropertySetLibrary Class See Also Send Feedback
Finds an existing PropertySetLibrary with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId Find(
    Document doc,
    string name
)
Visual Basic
Public Shared Function Find ( _
    doc As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ Find(
    Document^ doc,
    String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document in which to look for PropertySetLibrary elements with the given name.
name
Type: System..::..String
The name to search for.

Return Value

Identifier of the PropertySetLibrary with the given name, or invalidElementId if no library with that name exists.

Remarks

The search is case-insensitive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetLibrary Class


GetName Method

[image]

Revit 2013 API
PropertySetLibrary..::..GetName Method
PropertySetLibrary Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

PropertySetLibrary Class


HasPropertySet Method

[image]

Revit 2013 API
PropertySetLibrary..::..HasPropertySet Method
PropertySetLibrary Class See Also Send Feedback
Determines whether the library has a property set with a given name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasPropertySet(
    string name
)
Visual Basic
Public Function HasPropertySet ( _
    name As String _
) As Boolean
Visual C++
public:
bool HasPropertySet(
    String^ name
)

Parameters

name
Type: System..::..String
The property set name to look for.

Return Value

True if the library contains a property set with the given name, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PropertySetLibrary Class


ImportXml Method

[image]

Revit 2013 API
PropertySetLibrary..::..ImportXml Method
PropertySetLibrary Class See Also Send Feedback
Import an external property set library into a Revit document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PropertySetLibrary ImportXml(
    Document document,
    string fileName,
    bool overwriteExisting
)
Visual Basic
Public Shared Function ImportXml ( _
    document As Document, _
    fileName As String, _
    overwriteExisting As Boolean _
) As PropertySetLibrary
Visual C++
public:
static PropertySetLibrary^ ImportXml(
    Document^ document,
    String^ fileName,
    bool overwriteExisting
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
fileName
Type: System..::..String
Full path to a file containing a property set library definition.
overwriteExisting
Type: System..::..Boolean
If true, any name conflicts will be resolved by overwriting existing libraries in the document with those being imported.

Return Value

The new PropertySetLibrary.

Remarks

If overwriteExisting is false and a name conflict occurs, Revit will throw an InvalidOperationException.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | File does not exist.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Attempting to import a property set library with a name that already exists in the document.

See Also

PropertySetLibrary Class


RemovePropertySet Method

[image]

Revit 2013 API
PropertySetLibrary..::..RemovePropertySet Method
PropertySetLibrary Class See Also Send Feedback
Removes a property set with a given name from the library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RemovePropertySet(
    string name
)
Visual Basic
Public Function RemovePropertySet ( _
    name As String _
) As Boolean
Visual C++
public:
bool RemovePropertySet(
    String^ name
)

Parameters

name
Type: System..::..String
The name of the property set name to remove.

Return Value

True if a property set with the given name was found and removed, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


RenamePropertySet Method

[image]

Revit 2013 API
PropertySetLibrary..::..RenamePropertySet Method
PropertySetLibrary Class See Also Send Feedback
Renames a property set in the library.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RenamePropertySet(
    string name,
    string newName
)
Visual Basic
Public Function RenamePropertySet ( _
    name As String, _
    newName As String _
) As Boolean
Visual C++
public:
bool RenamePropertySet(
    String^ name,
    String^ newName
)

Parameters

name
Type: System..::..String
The name of the existing property set name to rename.
newName
Type: System..::..String
The new name for the property set.

Return Value

True if the property set was found and renamed, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No property set with the given name exists in the library. -or- The library already contains a property set with the given name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


RenameSubclass Method

[image]

Revit 2013 API
PropertySetLibrary..::..RenameSubclass Method
PropertySetLibrary Class See Also Send Feedback
Changes the subclass field of all property sets in this library from one value to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int RenameSubclass(
    string oldSubclass,
    string newSubclass
)
Visual Basic
Public Function RenameSubclass ( _
    oldSubclass As String, _
    newSubclass As String _
) As Integer
Visual C++
public:
int RenameSubclass(
    String^ oldSubclass,
    String^ newSubclass
)

Parameters

oldSubclass
Type: System..::..String
The existing subclass to rename.
newSubclass
Type: System..::..String
The new subclass applied to all property sets matching the given oldSubclass.

Return Value

The number of property sets whose subclass was changed.

Remarks

A subclass can be "deleted" from the library by passing an empty string as the new subclass.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


SetName Method

[image]

Revit 2013 API
PropertySetLibrary..::..SetName Method
PropertySetLibrary Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name is not unique.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ObjectAccessException | The property set library is read-only.

See Also

PropertySetLibrary Class


PropertySetLibrary Properties

[image] [image]

Revit 2013 API
PropertySetLibrary Properties
PropertySetLibrary Class See Also Send Feedback

The PropertySetLibrary type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Locked | Indicates whether a property set library is locked into a document or not. Locked libraries are read-only and cannot be removed.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReadOnly | Indicates whether a property set library is read-only or not. Read-only libraries cannot be renamed, or added to.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PropertySetLibrary Class


Locked Property

[image]

Revit 2013 API
PropertySetLibrary..::..Locked Property
PropertySetLibrary Class See Also Send Feedback
Indicates whether a property set library is locked into a document or not. Locked libraries are read-only and cannot be removed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Locked { get; }
Visual Basic
Public ReadOnly Property Locked As Boolean
    Get
Visual C++
public:
property bool Locked {
    bool get ();
}

See Also

PropertySetLibrary Class


Parameter Property

[image] [image]

Revit 2013 API
PropertySetLibrary..::..Parameter Property
PropertySetLibrary Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PropertySetLibrary Class
PropertySetLibrary Members


ReadOnly Property

[image]

Revit 2013 API
PropertySetLibrary..::..ReadOnly Property
PropertySetLibrary Class See Also Send Feedback
Indicates whether a property set library is read-only or not. Read-only libraries cannot be renamed, or added to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic
Public Property ReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

PropertySetLibrary Class


PropOverrideMode Enumeration

[image]

Revit 2013 API
PropOverrideMode Enumeration
See Also Send Feedback
An enumerated type listing ways how overridden object styles get exported.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PropOverrideMode
Visual Basic
Public Enumeration PropOverrideMode
Visual C++
public enum class PropOverrideMode

Members

Member name | Description
ByEntity | Category properties BYLAYER, overrides BYENTITY. Entities generated by a specific category are assigned to a layer accordingly to the layer settings. To preserve visual fidelity, overridden attributes result in entity-specific attributes
ByLayer | All properties BYLAYER, no overrides Forces all entities to follow visual properties as set by their layer. Visual fidelity is lost, but this produces the least number of layers while still providing by-layer control over exported entities.
NewLayer | All properties BYLAYER, New Layers for overrides. Visual fidelity is preserved and there is by-layer control over all entities, although number of layers in the exported file might be increased.

See Also


RadialArray Class

[image]

Revit 2013 API
RadialArray Class
Members See Also Send Feedback
An object that represents an Array created along a circle arc within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RadialArray : BaseArray
Visual Basic
Public Class RadialArray _
    Inherits BaseArray
Visual C++
public ref class RadialArray : public BaseArray

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..BaseArray
Autodesk.Revit.DB..::..RadialArray

See Also

RadialArray Members


RadialArray Members

[image] [image]

Revit 2013 API
RadialArray Members
RadialArray Class Methods Properties See Also Send Feedback

The RadialArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RadialArray Class


RadialArray Methods

[image] [image]

Revit 2013 API
RadialArray Methods
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | ArrayElementsWithoutAssociation | Creates a new radial array from a set of elements based on an input rotation axis.
 | ArrayElementWithoutAssociation | Creates a new radial array from a single element based on an input rotation axis.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
 | Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCopiedMemberIds | Retrieves the copied member Ids of the Array. (Overrides BaseArray..::..GetCopiedMemberIds()()()().)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOriginalMemberIds | Retrieves the original member Ids of the Array. (Overrides BaseArray..::..GetOriginalMemberIds()()()().)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidArraySize | This indicates whether the input count is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadialArray Class


ArrayElementsWithoutAssociation Method

[image]

Revit 2013 API
RadialArray..::..ArrayElementsWithoutAssociation Method
RadialArray Class See Also Send Feedback
Creates a new radial array from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementsWithoutAssociation(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementsWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementsWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The elements created by the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ids is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class


ArrayElementWithoutAssociation Method

[image]

Revit 2013 API
RadialArray..::..ArrayElementWithoutAssociation Method
RadialArray Class See Also Send Feedback
Creates a new radial array from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ICollection<ElementId> ArrayElementWithoutAssociation(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function ArrayElementWithoutAssociation ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ArrayElementWithoutAssociation(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
dBView
Type: Autodesk.Revit.DB..::..View
The view.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The elements created by the operation.

Remarks

The resulting elements will not be associated with an array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class


Create Method

[image] [image]

Revit 2013 API
RadialArray..::..Create Method
RadialArray Class See Also Send Feedback

Overload List

Name | Description
Create(Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a single element based on an input rotation axis.
Create(Document, View, ICollection<(Of <<'(ElementId>)>>), Int32, Line, Double, ArrayAnchorMember) | Creates a new radial array element from a set of elements based on an input rotation axis.

See Also

RadialArray Class
RadialArray Members


Create Method (Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember)

[image]

Revit 2013 API
RadialArray..::..Create Method (Document, View, ElementId, Int32, Line, Double, ArrayAnchorMember)
RadialArray Class See Also Send Feedback
Creates a new radial array element from a single element based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ElementId id,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    id As ElementId, _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As RadialArray
Visual C++
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ElementId^ id,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
id
Type: Autodesk.Revit.DB..::..ElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new radial array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class
Create Overload


Create Method (Document, View, ICollection(ElementId), Int32, Line, Double, ArrayAnchorMember)

[image]

Revit 2013 API
RadialArray..::..Create Method (Document, View, ICollection<(Of <(<'ElementId>)>)>, Int32, Line, Double, ArrayAnchorMember)
RadialArray Class See Also Send Feedback
Creates a new radial array element from a set of elements based on an input rotation axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RadialArray Create(
    Document aDoc,
    View dBView,
    ICollection<ElementId> ids,
    int count,
    Line axis,
    double angle,
    ArrayAnchorMember anchorMember
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    dBView As View, _
    ids As ICollection(Of ElementId), _
    count As Integer, _
    axis As Line, _
    angle As Double, _
    anchorMember As ArrayAnchorMember _
) As RadialArray
Visual C++
public:
static RadialArray^ Create(
    Document^ aDoc,
    View^ dBView,
    ICollection<ElementId^>^ ids,
    int count,
    Line^ axis,
    double angle,
    ArrayAnchorMember anchorMember
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.
dBView
Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements. If elements include view-specific elements, they must belong to this view.
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to array. The position of the rotation axis is determined by the cumulative center of the elements' bounding boxes.
count
Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
axis
Type: Autodesk.Revit.DB..::..Line
The rotation axis.
angle
Type: System..::..Double
The angle in radians of the rotation.
anchorMember
Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.

Return Value

The new radial array element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ids is empty. -or- One or more elements in ids do not exist in the document. -or- One or more elements in ids is owned by different views and thus cannot be arrayed together. -or- One or more elements in ids is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the radial array.

See Also

RadialArray Class
Create Overload


GetCopiedMemberIds Method

[image]

Revit 2013 API
RadialArray..::..GetCopiedMemberIds Method
RadialArray Class See Also Send Feedback
Retrieves the copied member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetCopiedMemberIds()
Visual Basic
Public Overrides Function GetCopiedMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetCopiedMemberIds() override

Return Value

The copied member Ids of the Array

See Also

RadialArray Class


GetOriginalMemberIds Method

[image]

Revit 2013 API
RadialArray..::..GetOriginalMemberIds Method
RadialArray Class See Also Send Feedback
Retrieves the original member Ids of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public override ICollection<ElementId> GetOriginalMemberIds()
Visual Basic
Public Overrides Function GetOriginalMemberIds As ICollection(Of ElementId)
Visual C++
public:
virtual ICollection<ElementId^>^ GetOriginalMemberIds() override

Return Value

The original member Ids of the Array

See Also

RadialArray Class


IsValidArraySize Method

[image]

Revit 2013 API
RadialArray..::..IsValidArraySize Method
RadialArray Class See Also Send Feedback
This indicates whether the input count is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidArraySize(
    int count
)
Visual Basic
Public Shared Function IsValidArraySize ( _
    count As Integer _
) As Boolean
Visual C++
public:
static bool IsValidArraySize(
    int count
)

Parameters

count
Type: System..::..Int32
The count.

Return Value

True if the input count is between 3 and 200, false otherwise.

See Also

RadialArray Class


RadialArray Properties

[image] [image]

Revit 2013 API
RadialArray Properties
RadialArray Class See Also Send Feedback

The RadialArray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CopyMembers | Obsolete. Retrieve the copied members of the Array. (Overrides BaseArray..::..CopyMembers.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Label | The family parameter label of the BaseArray. (Inherited from BaseArray.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from BaseArray.)
Public property | NumMembers | Retrieves or changes the number of the arrayed members. (Overrides BaseArray..::..NumMembers.)
Public property | OrigMembers | Obsolete. Retrieve the original members of the Array. (Overrides BaseArray..::..OrigMembers.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RadialArray Class


CopyMembers Property

[image]

Revit 2013 API
RadialArray..::..CopyMembers Property
RadialArray Class See Also Send Feedback
Retrieve the copied members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public override ElementArray CopyMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")> _
Public Overrides ReadOnly Property CopyMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCopiedMemberIds() instead.")]
public:
virtual property ElementArray^ CopyMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class


NumMembers Property

[image]

Revit 2013 API
RadialArray..::..NumMembers Property
RadialArray Class See Also Send Feedback
Retrieves or changes the number of the arrayed members.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int NumMembers { get; set; }
Visual Basic
Public Overrides Property NumMembers As Integer
    Get
    Set
Visual C++
public:
virtual property int NumMembers {
    int get () override;
    void set (int value) override;
}

See Also

RadialArray Class


OrigMembers Property

[image]

Revit 2013 API
RadialArray..::..OrigMembers Property
RadialArray Class See Also Send Feedback
Retrieve the original members of the Array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public override ElementArray OrigMembers { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")> _
Public Overrides ReadOnly Property OrigMembers As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetOriginalMemberIds() instead.")]
public:
virtual property ElementArray^ OrigMembers {
    ElementArray^ get () override;
}

See Also

RadialArray Class


Parameter Property

[image] [image]

Revit 2013 API
RadialArray..::..Parameter Property
RadialArray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RadialArray Class
RadialArray Members


RasterQualityType Enumeration

[image]

Revit 2013 API
RasterQualityType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RasterQualityType
Visual Basic
Public Enumeration RasterQualityType
Visual C++
public enum class RasterQualityType

Members

Member name | Description
Low | The type of Raster Quality is Low.
Medium | The type of Raster Quality is Medium.
High | The type of Raster Quality is High.
Presentation | The type of Raster Quality is Presentation.

See Also


Rectangle Class

[image]

Revit 2013 API
Rectangle Class
Members See Also Send Feedback
Stores a set of four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Rectangle
Visual Basic
Public Class Rectangle
Visual C++
public ref class Rectangle

Remarks

It usually represents a rectangle on the screen. Left must be less than right and top must be less than bottom.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Rectangle

See Also

Rectangle Members


Rectangle Members

[image] [image]

Revit 2013 API
Rectangle Members
Rectangle Class Constructors Methods Properties See Also Send Feedback

The Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | Rectangle | Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Public property | Left | Gets x-coordinate of the top-left corner of the rectangle.
Public property | Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


Rectangle Constructor

[image]

Revit 2013 API
Rectangle Constructor
Rectangle Class See Also Send Feedback
Creates an Rectangle instance with the specified four integers that represent the left, top, right and bottom of a rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Rectangle(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
Rectangle(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::..Int32
The x-coordinate of the top-left corner.
top
Type: System..::..Int32
The y-coordinate of the top-left corner.
right
Type: System..::..Int32
The x-coordinate of the bottom-right corner.
bottom
Type: System..::..Int32
The y-coordinate of the bottom-right corner.

See Also

Rectangle Class


Rectangle Methods

[image] [image]

Revit 2013 API
Rectangle Methods
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rectangle Class


Rectangle Properties

[image] [image]

Revit 2013 API
Rectangle Properties
Rectangle Class See Also Send Feedback

The Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Gets y-coordinate of the bottom-right corner of the rectangle.
Public property | Left | Gets x-coordinate of the top-left corner of the rectangle.
Public property | Right | Gets x-coordinate of the bottom-right corner of the rectangle.
Public property | Top | Gets y-coordinate of the top-left corner of the rectangle.

See Also

Rectangle Class


Bottom Property

[image]

Revit 2013 API
Rectangle..::..Bottom Property
Rectangle Class See Also Send Feedback
Gets y-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Bottom { get; }
Visual Basic
Public ReadOnly Property Bottom As Integer
    Get
Visual C++
public:
property int Bottom {
    int get ();
}

See Also

Rectangle Class


Left Property

[image]

Revit 2013 API
Rectangle..::..Left Property
Rectangle Class See Also Send Feedback
Gets x-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Left { get; }
Visual Basic
Public ReadOnly Property Left As Integer
    Get
Visual C++
public:
property int Left {
    int get ();
}

See Also

Rectangle Class


Right Property

[image]

Revit 2013 API
Rectangle..::..Right Property
Rectangle Class See Also Send Feedback
Gets x-coordinate of the bottom-right corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Right { get; }
Visual Basic
Public ReadOnly Property Right As Integer
    Get
Visual C++
public:
property int Right {
    int get ();
}

See Also

Rectangle Class


Top Property

[image]

Revit 2013 API
Rectangle..::..Top Property
Rectangle Class See Also Send Feedback
Gets y-coordinate of the top-left corner of the rectangle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Top { get; }
Visual Basic
Public ReadOnly Property Top As Integer
    Get
Visual C++
public:
property int Top {
    int get ();
}

See Also

Rectangle Class


RectangularGridSegmentOrientation Enumeration

[image]

Revit 2013 API
RectangularGridSegmentOrientation Enumeration
See Also Send Feedback
The orientation type of rectangular grid segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum RectangularGridSegmentOrientation
Visual Basic
Public Enumeration RectangularGridSegmentOrientation
Visual C++
public enum class RectangularGridSegmentOrientation

Members

Member name | Description
Vertical | A vertical GridSegment
Horizontal | A horizontal GridSegment

See Also


Reference Class

[image]

Revit 2013 API
Reference Class
Members See Also Send Feedback
A stable reference to a geometric object in a Revit model.
An array that contains reference objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Reference : APIObject
Visual Basic
Public Class Reference _
    Inherits APIObject
Visual C++
public ref class Reference : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Reference

See Also

Reference Members


Reference Members

[image] [image]

Revit 2013 API
Reference Members
Reference Class Constructors Methods Properties See Also Send Feedback

The Reference type exposes the following members.

Constructors

 | Name | Description
Public method | Reference | Creates a Reference with the supplied element.

Methods

 | Name | Description
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


Reference Constructor

[image]

Revit 2013 API
Reference Constructor
Reference Class See Also Send Feedback
Creates a Reference with the supplied element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Reference(
    Element element
)
Visual Basic
Public Sub New ( _
    element As Element _
)
Visual C++
public:
Reference(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to create a reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Reference Class


Reference Methods

[image] [image]

Revit 2013 API
Reference Methods
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Methods

 | Name | Description
Public method | ConvertToStableRepresentation | Converts the reference to a stable String representation.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | ParseFromStableRepresentation | Converts a stable String representation of a reference to a Reference object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reference Class


ConvertToStableRepresentation Method

[image]

Revit 2013 API
Reference..::..ConvertToStableRepresentation Method
Reference Class Example See Also Send Feedback
Converts the reference to a stable String representation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ConvertToStableRepresentation(
    Document document
)
Visual Basic
Public Function ConvertToStableRepresentation ( _
    document As Document _
) As String
Visual C++
public:
String^ ConvertToStableRepresentation(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Remarks

The stable representation can be used to preserve and restore the reference later in the same Revit session or even in a different session where the same document is present. Use ParseFromStableRepresentation(Document, String) to restore the reference. The representation is based on the internal Revit structure and is not intended to be parsed expect by ParseFromStableRepresentation(Document, String).

Examples

CopyC#
public string SerializeReference(Document doc, Reference reference)
{
    String ids = String.Empty;
    ids = reference.ConvertToStableRepresentation(doc);
    TaskDialog.Show("SerializeReference", "Representation:\n" + ids);
    return ids;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | document was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidObjectException | Reference contained element ids not found in this document.

See Also

Reference Class


ParseFromStableRepresentation Method

[image]

Revit 2013 API
Reference..::..ParseFromStableRepresentation Method
Reference Class Example See Also Send Feedback
Converts a stable String representation of a reference to a Reference object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Reference ParseFromStableRepresentation(
    Document document,
    string representation
)
Visual Basic
Public Shared Function ParseFromStableRepresentation ( _
    document As Document, _
    representation As String _
) As Reference
Visual C++
public:
static Reference^ ParseFromStableRepresentation(
    Document^ document,
    String^ representation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
representation
Type: System..::..String
The reference representation.

Remarks

Use ConvertToStableRepresentation(Document) to obtain the representation. The Reference will have only the following information set:
  • ElementReferenceType
  • ElementId
You will also be able to pass the reference to Document.GetElement(reference) and Element.GetGeometryObjectFromReference(reference) to obtain the element and geometry object referred to.

Examples

CopyC#
public Reference ParseReference(Document doc, String str)
{
    Reference reference = Reference.ParseFromStableRepresentation(doc, str);
    if (null == reference)
    {
        TaskDialog.Show("ParseReference", "Reference is Null.");
    }
    return reference;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | One or more arguments was nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Reference representation could not be successfully parsed, or element id obtained from reference representation could not be found in this document.

See Also

Reference Class


Reference Properties

[image] [image]

Revit 2013 API
Reference Properties
Reference Class See Also Send Feedback

The Reference type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The element id for this reference.
Public property | ElementReferenceType | The type of reference.
Public property | GlobalPoint | The position on which the reference is hit.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | UVPoint | The UV parameters of the reference, if the reference contains a face.

See Also

Reference Class


ElementId Property

[image]

Revit 2013 API
Reference..::..ElementId Property
Reference Class See Also Send Feedback
The element id for this reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ElementId { get; }
Visual Basic
Public ReadOnly Property ElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

Remarks

InvalidElementId will be returned for references that don't refer to a particular element.

See Also

Reference Class


ElementReferenceType Property

[image]

Revit 2013 API
Reference..::..ElementReferenceType Property
Reference Class See Also Send Feedback
The type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementReferenceType ElementReferenceType { get; }
Visual Basic
Public ReadOnly Property ElementReferenceType As ElementReferenceType
    Get
Visual C++
public:
property ElementReferenceType ElementReferenceType {
    ElementReferenceType get ();
}

See Also

Reference Class


GlobalPoint Property

[image]

Revit 2013 API
Reference..::..GlobalPoint Property
Reference Class See Also Send Feedback
The position on which the reference is hit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ GlobalPoint { get; }
Visual Basic
Public ReadOnly Property GlobalPoint As XYZ
    Get
Visual C++
public:
property XYZ^ GlobalPoint {
    XYZ^ get ();
}

Return Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the reference doesn't have a global point.

Remarks

When using a plan view, the Z-value of a GlobalPoint is not meaningful.

See Also

Reference Class


UVPoint Property

[image]

Revit 2013 API
Reference..::..UVPoint Property
Reference Class See Also Send Feedback
The UV parameters of the reference, if the reference contains a face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV UVPoint { get; }
Visual Basic
Public ReadOnly Property UVPoint As UV
    Get
Visual C++
public:
property UV^ UVPoint {
    UV^ get ();
}

Remarks

This value is valid only for references of type REFERENCE_TYPE_SURFACE. It is nullNothingnullptra null reference (Nothing in Visual Basic) for all other types.

See Also

Reference Class


ReferenceArray Class

[image]

Revit 2013 API
ReferenceArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ReferenceArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferenceArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArray

See Also

ReferenceArray Members


ReferenceArray Members

[image] [image]

Revit 2013 API
ReferenceArray Members
ReferenceArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArray type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArray | Initializes a new instance of the ReferenceArray class

Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class


ReferenceArray Constructor

[image]

Revit 2013 API
ReferenceArray Constructor
ReferenceArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArray()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArray()

See Also

ReferenceArray Class


ReferenceArray Methods

[image] [image]

Revit 2013 API
ReferenceArray Methods
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the reference to the end of the array.
Public method | Clear | Removes every reference from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified reference into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArray Class


Append Method

[image]

Revit 2013 API
ReferenceArray..::..Append Method
ReferenceArray Class See Also Send Feedback
Add the reference to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Reference item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Reference _
)
Visual C++
public:
virtual void Append(
    Reference^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Reference
The reference to be added.

See Also

ReferenceArray Class


Clear Method

[image]

Revit 2013 API
ReferenceArray..::..Clear Method
ReferenceArray Class See Also Send Feedback
Removes every reference from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArray Class


ForwardIterator Method

[image]

Revit 2013 API
ReferenceArray..::..ForwardIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArray Class


GetEnumerator Method

[image]

Revit 2013 API
ReferenceArray..::..GetEnumerator Method
ReferenceArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferenceArray Class


Insert Method

[image]

Revit 2013 API
ReferenceArray..::..Insert Method
ReferenceArray Class See Also Send Feedback
Insert the specified reference into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Reference item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Reference, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Reference^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Reference
The reference to be inserted into the array.
index
Type: System..::..Int32
The reference will be inserted before this index.

Return Value

Returns whether the reference was inserted into the array.

See Also

ReferenceArray Class


ReverseIterator Method

[image]

Revit 2013 API
ReferenceArray..::..ReverseIterator Method
ReferenceArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferenceArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferenceArrayIterator
Visual C++
public:
virtual ReferenceArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArray Class


ReferenceArray Properties

[image] [image]

Revit 2013 API
ReferenceArray Properties
ReferenceArray Class See Also Send Feedback

The ReferenceArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a reference at a specified index within the array.
Public property | Size | Returns the number of references that are in the array.

See Also

ReferenceArray Class


IsEmpty Property

[image]

Revit 2013 API
ReferenceArray..::..IsEmpty Property
ReferenceArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArray Class


Item Property

[image]

Revit 2013 API
ReferenceArray..::..Item Property
ReferenceArray Class See Also Send Feedback
Gets or sets a reference at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Reference this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Reference
    Get
    Set
Visual C++
public:
virtual property Reference^ Item[int index] {
    Reference^ get (int index);
    void set (int index, Reference^ value);
}

Parameters

index
Type: System..::..Int32
The index of the reference to be set or retrieved.

Return Value

Returns the reference at the specified index.

See Also

ReferenceArray Class


Size Property

[image]

Revit 2013 API
ReferenceArray..::..Size Property
ReferenceArray Class See Also Send Feedback
Returns the number of references that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArray Class


ReferenceArrayArray Class

[image]

Revit 2013 API
ReferenceArrayArray Class
Members See Also Send Feedback
An array that contains ReferenceArray objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ReferenceArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferenceArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferenceArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArrayArray

See Also

ReferenceArrayArray Members


ReferenceArrayArray Members

[image] [image]

Revit 2013 API
ReferenceArrayArray Members
ReferenceArrayArray Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayArray | Initializes a new instance of the ReferenceArrayArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class


ReferenceArrayArray Constructor

[image]

Revit 2013 API
ReferenceArrayArray Constructor
ReferenceArrayArray Class See Also Send Feedback
Initializes a new instance of the ReferenceArrayArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayArray()

See Also

ReferenceArrayArray Class


ReferenceArrayArray Methods

[image] [image]

Revit 2013 API
ReferenceArrayArray Methods
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every ReferenceArray from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArray Class


Append Method

[image]

Revit 2013 API
ReferenceArrayArray..::..Append Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    ReferenceArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ReferenceArray _
)
Visual C++
public:
virtual void Append(
    ReferenceArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferenceArray

See Also

ReferenceArrayArray Class


Clear Method

[image]

Revit 2013 API
ReferenceArrayArray..::..Clear Method
ReferenceArrayArray Class See Also Send Feedback
Removes every ReferenceArray from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferenceArrayArray Class


ForwardIterator Method

[image]

Revit 2013 API
ReferenceArrayArray..::..ForwardIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ReferenceArrayArray Class


GetEnumerator Method

[image]

Revit 2013 API
ReferenceArrayArray..::..GetEnumerator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferenceArrayArray Class


Insert Method

[image]

Revit 2013 API
ReferenceArrayArray..::..Insert Method
ReferenceArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ReferenceArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ReferenceArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferenceArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferenceArray
index
Type: System..::..Int32

See Also

ReferenceArrayArray Class


ReverseIterator Method

[image]

Revit 2013 API
ReferenceArrayArray..::..ReverseIterator Method
ReferenceArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferenceArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferenceArrayArrayIterator
Visual C++
public:
virtual ReferenceArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ReferenceArrayArray Class


ReferenceArrayArray Properties

[image] [image]

Revit 2013 API
ReferenceArrayArray Properties
ReferenceArrayArray Class See Also Send Feedback

The ReferenceArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a ReferenceArray at a specified index within the array.
Public property | Size | Returns the number of ReferenceArrays that are in the array.

See Also

ReferenceArrayArray Class


IsEmpty Property

[image]

Revit 2013 API
ReferenceArrayArray..::..IsEmpty Property
ReferenceArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ReferenceArrayArray Class


Item Property

[image]

Revit 2013 API
ReferenceArrayArray..::..Item Property
ReferenceArrayArray Class See Also Send Feedback
Gets or sets a ReferenceArray at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferenceArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ReferenceArray
    Get
    Set
Visual C++
public:
virtual property ReferenceArray^ Item[int index] {
    ReferenceArray^ get (int index);
    void set (int index, ReferenceArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the ReferenceArray to be set or retrieved.

Return Value

Returns the ReferenceArray at the specified index.

See Also

ReferenceArrayArray Class


Size Property

[image]

Revit 2013 API
ReferenceArrayArray..::..Size Property
ReferenceArrayArray Class See Also Send Feedback
Returns the number of ReferenceArrays that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferenceArrayArray Class


ReferenceArrayArrayIterator Class

[image]

Revit 2013 API
ReferenceArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a ReferenceArray array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ReferenceArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ReferenceArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArrayArrayIterator

See Also

ReferenceArrayArrayIterator Members


ReferenceArrayArrayIterator Members

[image] [image]

Revit 2013 API
ReferenceArrayArrayIterator Members
ReferenceArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Constructor

[image]

Revit 2013 API
ReferenceArrayArrayIterator Constructor
ReferenceArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Methods

[image] [image]

Revit 2013 API
ReferenceArrayArrayIterator Methods
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ReferenceArrayArrayIterator..::..MoveNext Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


Reset Method

[image]

Revit 2013 API
ReferenceArrayArrayIterator..::..Reset Method
ReferenceArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayArrayIterator Properties

[image] [image]

Revit 2013 API
ReferenceArrayArrayIterator Properties
ReferenceArrayArrayIterator Class See Also Send Feedback

The ReferenceArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayArrayIterator Class


Current Property

[image]

Revit 2013 API
ReferenceArrayArrayIterator..::..Current Property
ReferenceArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayArrayIterator Class


ReferenceArrayIterator Class

[image]

Revit 2013 API
ReferenceArrayIterator Class
Members See Also Send Feedback
An iterator to a reference array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ReferenceArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ReferenceArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferenceArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferenceArrayIterator

See Also

ReferenceArrayIterator Members


ReferenceArrayIterator Members

[image] [image]

Revit 2013 API
ReferenceArrayIterator Members
ReferenceArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Constructor

[image]

Revit 2013 API
ReferenceArrayIterator Constructor
ReferenceArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferenceArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Methods

[image] [image]

Revit 2013 API
ReferenceArrayIterator Methods
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ReferenceArrayIterator..::..MoveNext Method
ReferenceArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


Reset Method

[image]

Revit 2013 API
ReferenceArrayIterator..::..Reset Method
ReferenceArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ReferenceArrayIterator Class


ReferenceArrayIterator Properties

[image] [image]

Revit 2013 API
ReferenceArrayIterator Properties
ReferenceArrayIterator Class See Also Send Feedback

The ReferenceArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferenceArrayIterator Class


Current Property

[image]

Revit 2013 API
ReferenceArrayIterator..::..Current Property
ReferenceArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ReferenceArrayIterator Class


ReferenceIntersector Class

[image]

Revit 2013 API
ReferenceIntersector Class
Members See Also Send Feedback
A class used to intersect and return elements based on an origin point and direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ReferenceIntersector : IDisposable
Visual Basic
Public Class ReferenceIntersector _
    Implements IDisposable
Visual C++
public ref class ReferenceIntersector : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReferenceIntersector

See Also

ReferenceIntersector Members


ReferenceIntersector Members

[image] [image]

Revit 2013 API
ReferenceIntersector Members
ReferenceIntersector Class Constructors Methods Properties See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Constructors

 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes the filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollection<(Of <<'(ElementId>)>>), FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements. # Find any intersection with any of the target elements.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceIntersector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFilter | Sets the ElementFilter used in intersection testing
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TargetType | The type of reference to find
Public property | ViewId | The 3DView used for intersecting

See Also

ReferenceIntersector Class


ReferenceIntersector Constructor

[image] [image]

Revit 2013 API
ReferenceIntersector Constructor
ReferenceIntersector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ReferenceIntersector(View3D) | Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.
Public method | ReferenceIntersector(ElementFilter, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any element which passes the filter.
Public method | ReferenceIntersector(ElementId, FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from a single target element only.
Public method | ReferenceIntersector(ICollection<(Of <<'(ElementId>)>>), FindReferenceTarget, View3D) | Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements. # Find any intersection with any of the target elements.

See Also

ReferenceIntersector Class
ReferenceIntersector Members


ReferenceIntersector Constructor (View3D)

[image]

Revit 2013 API
ReferenceIntersector Constructor (View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from all elements and representing all reference target types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    View3D^ dbView3d
)

Parameters

dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)

[image]

Revit 2013 API
ReferenceIntersector Constructor (ElementFilter, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from any element which passes the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ElementFilter filter,
    FindReferenceTarget targetType,
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    filter As ElementFilter, _
    targetType As FindReferenceTarget, _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ElementFilter^ filter,
    FindReferenceTarget targetType,
    View3D^ dbView3d
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The element filter. All references will belong to elements passing this filter.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ElementId, FindReferenceTarget, View3D)

[image]

Revit 2013 API
ReferenceIntersector Constructor (ElementId, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from a single target element only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ElementId targetElementId,
    FindReferenceTarget targetType,
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    targetElementId As ElementId, _
    targetType As FindReferenceTarget, _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ElementId^ targetElementId,
    FindReferenceTarget targetType,
    View3D^ dbView3d
)

Parameters

targetElementId
Type: Autodesk.Revit.DB..::..ElementId
The target element id.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Constructor (ICollection(ElementId), FindReferenceTarget, View3D)

[image]

Revit 2013 API
ReferenceIntersector Constructor (ICollection<(Of <(<'ElementId>)>)>, FindReferenceTarget, View3D)
ReferenceIntersector Class See Also Send Feedback
Constructs a ReferenceIntersector which is set to return intersections from any of a set of target elements. # Find any intersection with any of the target elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceIntersector(
    ICollection<ElementId> targetElementIds,
    FindReferenceTarget targetType,
    View3D dbView3d
)
Visual Basic
Public Sub New ( _
    targetElementIds As ICollection(Of ElementId), _
    targetType As FindReferenceTarget, _
    dbView3d As View3D _
)
Visual C++
public:
ReferenceIntersector(
    ICollection<ElementId^>^ targetElementIds,
    FindReferenceTarget targetType,
    View3D^ dbView3d
)

Parameters

targetElementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The target element ids.
targetType
Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
dbView3d
Type: Autodesk.Revit.DB..::..View3D
The view to find references in

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class
ReferenceIntersector Overload


ReferenceIntersector Methods

[image] [image]

Revit 2013 API
ReferenceIntersector Methods
ReferenceIntersector Class See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Find | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | FindNearest | Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.
Public method | GetFilter | Gets the ElementFilter used in intersection testing
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTargetElementIds | Gets the set of ElementIds to test from in intersection testing
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFilter | Sets the ElementFilter used in intersection testing
Public method | SetTargetElementIds | Sets the set of ElementIds to test from in intersection testing
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceIntersector Class


Dispose Method

[image]

Revit 2013 API
ReferenceIntersector..::..Dispose Method
ReferenceIntersector Class See Also Send Feedback
Releases all resources used by the ReferenceIntersector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReferenceIntersector Class


Find Method

[image]

Revit 2013 API
ReferenceIntersector..::..Find Method
ReferenceIntersector Class See Also Send Feedback
Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ReferenceWithContext> Find(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Function Find ( _
    origin As XYZ, _
    direction As XYZ _
) As IList(Of ReferenceWithContext)
Visual C++
public:
IList<ReferenceWithContext^>^ Find(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.

Return Value

A collection containing the intersected references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class


FindNearest Method

[image]

Revit 2013 API
ReferenceIntersector..::..FindNearest Method
ReferenceIntersector Class See Also Send Feedback
Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector’s criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReferenceWithContext FindNearest(
    XYZ origin,
    XYZ direction
)
Visual Basic
Public Function FindNearest ( _
    origin As XYZ, _
    direction As XYZ _
) As ReferenceWithContext
Visual C++
public:
ReferenceWithContext^ FindNearest(
    XYZ^ origin,
    XYZ^ direction
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
direction
Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.

Return Value

The intersected reference nearest to the ray origin, nullNothingnullptra null reference (Nothing in Visual Basic) if none is found

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class


GetFilter Method

[image]

Revit 2013 API
ReferenceIntersector..::..GetFilter Method
ReferenceIntersector Class See Also Send Feedback
Gets the ElementFilter used in intersection testing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementFilter GetFilter()
Visual Basic
Public Function GetFilter As ElementFilter
Visual C++
public:
ElementFilter^ GetFilter()

Return Value

The ElementFilter

See Also

ReferenceIntersector Class


GetTargetElementIds Method

[image]

Revit 2013 API
ReferenceIntersector..::..GetTargetElementIds Method
ReferenceIntersector Class See Also Send Feedback
Gets the set of ElementIds to test from in intersection testing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetTargetElementIds()
Visual Basic
Public Function GetTargetElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetTargetElementIds()

Return Value

The target ElementIds

See Also

ReferenceIntersector Class


SetFilter Method

[image]

Revit 2013 API
ReferenceIntersector..::..SetFilter Method
ReferenceIntersector Class See Also Send Feedback
Sets the ElementFilter used in intersection testing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFilter(
    ElementFilter filter
)
Visual Basic
Public Sub SetFilter ( _
    filter As ElementFilter _
)
Visual C++
public:
void SetFilter(
    ElementFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ElementFilter
The ElementFilter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class


SetTargetElementIds Method

[image]

Revit 2013 API
ReferenceIntersector..::..SetTargetElementIds Method
ReferenceIntersector Class See Also Send Feedback
Sets the set of ElementIds to test from in intersection testing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetTargetElementIds(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub SetTargetElementIds ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void SetTargetElementIds(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The target ElementIds

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ReferenceIntersector Class


ReferenceIntersector Properties

[image] [image]

Revit 2013 API
ReferenceIntersector Properties
ReferenceIntersector Class See Also Send Feedback

The ReferenceIntersector type exposes the following members.

Properties

 | Name | Description
Public property | TargetType | The type of reference to find
Public property | ViewId | The 3DView used for intersecting

See Also

ReferenceIntersector Class


TargetType Property

[image]

Revit 2013 API
ReferenceIntersector..::..TargetType Property
ReferenceIntersector Class See Also Send Feedback
The type of reference to find

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FindReferenceTarget TargetType { get; set; }
Visual Basic
Public Property TargetType As FindReferenceTarget
    Get
    Set
Visual C++
public:
property FindReferenceTarget TargetType {
    FindReferenceTarget get ();
    void set (FindReferenceTarget value);
}

See Also

ReferenceIntersector Class


ViewId Property

[image]

Revit 2013 API
ReferenceIntersector..::..ViewId Property
ReferenceIntersector Class See Also Send Feedback
The 3DView used for intersecting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ReferenceIntersector Class


ReferencePlane Class

[image]

Revit 2013 API
ReferencePlane Class
Members Example See Also Send Feedback
Represents a reference plane of Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ReferencePlane : Element
Visual Basic
Public Class ReferencePlane _
    Inherits Element
Visual C++
public ref class ReferencePlane : public Element

Examples

CopyC#
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned
    Autodesk.Revit.DB.Plane plane = refPlane.Plane;
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ReferencePlane(ByVal refPlane As ReferencePlane)
    Dim message As String = "Reference Plane: "
    'get the bubble end of the reference plane
    Dim bubbleEnd As Autodesk.Revit.DB.XYZ = refPlane.BubbleEnd
    message += vbLf & "Bubble end: (" + bubbleEnd.X + ", " + bubbleEnd.Y + ", " + bubbleEnd.Z + ")"

    'get the direction of the reference plane
    Dim direction As Autodesk.Revit.DB.XYZ = refPlane.Direction
    message += vbLf & "Direction: (" + direction.X + ", " + direction.Y + ", " + direction.Z + ")"

    'get the freeEnd of the reference plane
    Dim freeEnd As Autodesk.Revit.DB.XYZ = refPlane.FreeEnd
    message += vbLf & "Free End: (" + freeEnd.X + ", " + freeEnd.Y + ", " + freeEnd.Z + ")"

    'get the name of the reference plane
    message += vbLf & "Name: " + refPlane.Name

    'get the normal vector of the reference plane
    Dim normal As Autodesk.Revit.DB.XYZ = refPlane.Normal
    message += vbLf & "Normal vector: (" + normal.X + ", " + normal.Y + ", " + normal.Z + ")"

    'get the geometry plane to which the reference plane assigned
    Dim plane As Autodesk.Revit.DB.Plane = refPlane.Plane
    message += vbLf & "origin of the plane: (" + plane.Origin.X + ", " + plane.Origin.Y + ", " + plane.Origin.Z + ")"

    message += vbLf & "normal of the plane: (" + plane.Normal.X + ", " + plane.Normal.Y + ", " + plane.Normal.Z + ")"

    message += vbLf & "Xvec of the plane: (" + plane.XVec.X + ", " + plane.XVec.Y + ", " + plane.XVec.Z + ")"

    message += vbLf & "Yvec of the plane: (" + plane.YVec.X + ", " + plane.YVec.Y + ", " + plane.YVec.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ReferencePlane

See Also

ReferencePlane Members


ReferencePlane Members

[image] [image]

Revit 2013 API
ReferencePlane Members
ReferencePlane Class Methods Properties See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FreeEnd | The free end of the reference plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plane | The geometry plane to which the reference plane is assigned.
Public property | Reference | The geometry reference of the reference plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePlane Class


ReferencePlane Methods

[image] [image]

Revit 2013 API
ReferencePlane Methods
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the orientation of the reference plane.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePlane Class


Flip Method

[image]

Revit 2013 API
ReferencePlane..::..Flip Method
ReferencePlane Class See Also Send Feedback
Flips the orientation of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

ReferencePlane Class


ReferencePlane Properties

[image] [image]

Revit 2013 API
ReferencePlane Properties
ReferencePlane Class See Also Send Feedback

The ReferencePlane type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | BubbleEnd | The bubble end of the reference plane.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | The direction of the reference plane.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FreeEnd | The free end of the reference plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name property of the reference plane.
Public property | Normal | The normal vector of the reference plane.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plane | The geometry plane to which the reference plane is assigned.
Public property | Reference | The geometry reference of the reference plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePlane Class


BubbleEnd Property

[image]

Revit 2013 API
ReferencePlane..::..BubbleEnd Property
ReferencePlane Class See Also Send Feedback
The bubble end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ BubbleEnd { get; set; }
Visual Basic
Public Property BubbleEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BubbleEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the bubble end is set to almost the same point as free end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class


Direction Property

[image]

Revit 2013 API
ReferencePlane..::..Direction Property
ReferencePlane Class See Also Send Feedback
The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Direction { get; set; }
Visual Basic
Public Property Direction As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the direction vector is almost zero or if it is not perpendicular to the normal vector.

See Also

ReferencePlane Class


FreeEnd Property

[image]

Revit 2013 API
ReferencePlane..::..FreeEnd Property
ReferencePlane Class See Also Send Feedback
The free end of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ FreeEnd { get; set; }
Visual Basic
Public Property FreeEnd As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ FreeEnd {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

When setting this property, an exception will be thrown if the free end is set to almost the same point as bubble end or if the vector from BubbleEnd -> FreeEnd is not perpendicular to the normal vector.

See Also

ReferencePlane Class


Name Property

[image]

Revit 2013 API
ReferencePlane..::..Name Property
ReferencePlane Class See Also Send Feedback
The name property of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

This property overrides Element's default implementation.

See Also

ReferencePlane Class


Normal Property

[image]

Revit 2013 API
ReferencePlane..::..Normal Property
ReferencePlane Class See Also Send Feedback
The normal vector of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

ReferencePlane Class


Parameter Property

[image] [image]

Revit 2013 API
ReferencePlane..::..Parameter Property
ReferencePlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ReferencePlane Class
ReferencePlane Members


Plane Property

[image]

Revit 2013 API
ReferencePlane..::..Plane Property
ReferencePlane Class See Also Send Feedback
The geometry plane to which the reference plane is assigned.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic
Public ReadOnly Property Plane As Plane
    Get
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

See Also

ReferencePlane Class


Reference Property

[image]

Revit 2013 API
ReferencePlane..::..Reference Property
ReferencePlane Class See Also Send Feedback
The geometry reference of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference Reference { get; }
Visual Basic
Public ReadOnly Property Reference As Reference
    Get
Visual C++
public:
property Reference^ Reference {
    Reference^ get ();
}

See Also

ReferencePlane Class


ReferencePoint Class

[image]

Revit 2013 API
ReferencePoint Class
Members See Also Send Feedback
A reference point in an Autodesk Revit family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ReferencePoint : Element
Visual Basic
Public Class ReferencePoint _
    Inherits Element
Visual C++
public ref class ReferencePoint : public Element

Remarks

A ReferencePoint represents a point in space together with a local coordinate system. ReferencePoints can be free, or constrained to other elements in several ways. When the point is constrained, the coordinate system is also constrained in certain ways.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ReferencePoint

See Also

ReferencePoint Members


ReferencePoint Members

[image] [image]

Revit 2013 API
ReferencePoint Members
ReferencePoint Class Methods Properties See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePoint Class


ReferencePoint Methods

[image] [image]

Revit 2013 API
ReferencePoint Methods
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCoordinatePlaneReferenceXY | A reference for the XY plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceXZ | A reference for the XZ plane of the coordinate system.
Public method | GetCoordinatePlaneReferenceYZ | A reference for the YZ plane of the coordinate system.
Public method | GetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubId | Id of associated Hub.
Public method | GetInterpolatingCurves | The set of CurveByPoints elements that interpolate a ReferencePoint.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPointElementReference | Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the point.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCoordinateSystem | The position and orientation of the ReferencePoint.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetPointElementReference | Change the rule for computing the location of the ReferencePoint relative to other elements in the document.
Public method | SetVisibility | Sets the visibility for the point.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceXY Method

[image]

Revit 2013 API
ReferencePoint..::..GetCoordinatePlaneReferenceXY Method
ReferencePoint Class See Also Send Feedback
A reference for the XY plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXY()
Visual Basic
Public Function GetCoordinatePlaneReferenceXY As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXY()

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceXZ Method

[image]

Revit 2013 API
ReferencePoint..::..GetCoordinatePlaneReferenceXZ Method
ReferencePoint Class See Also Send Feedback
A reference for the XZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceXZ()
Visual Basic
Public Function GetCoordinatePlaneReferenceXZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceXZ()

See Also

ReferencePoint Class


GetCoordinatePlaneReferenceYZ Method

[image]

Revit 2013 API
ReferencePoint..::..GetCoordinatePlaneReferenceYZ Method
ReferencePoint Class See Also Send Feedback
A reference for the YZ plane of the coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference GetCoordinatePlaneReferenceYZ()
Visual Basic
Public Function GetCoordinatePlaneReferenceYZ As Reference
Visual C++
public:
Reference^ GetCoordinatePlaneReferenceYZ()

See Also

ReferencePoint Class


GetCoordinateSystem Method

[image]

Revit 2013 API
ReferencePoint..::..GetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform GetCoordinateSystem()
Visual Basic
Public Function GetCoordinateSystem As Transform
Visual C++
public:
Transform^ GetCoordinateSystem()

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ.

See Also

ReferencePoint Class


GetHubId Method

[image]

Revit 2013 API
ReferencePoint..::..GetHubId Method
ReferencePoint Class See Also Send Feedback
Id of associated Hub.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetHubId()
Visual Basic
Public Function GetHubId As ElementId
Visual C++
public:
ElementId^ GetHubId()

See Also

ReferencePoint Class


GetInterpolatingCurves Method

[image]

Revit 2013 API
ReferencePoint..::..GetInterpolatingCurves Method
ReferencePoint Class See Also Send Feedback
The set of CurveByPoints elements that interpolate a ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveByPointsArray GetInterpolatingCurves()
Visual Basic
Public Function GetInterpolatingCurves As CurveByPointsArray
Visual C++
public:
CurveByPointsArray^ GetInterpolatingCurves()

Remarks

A CurveByPoints is in the GetInterpolatingCurves()()()() array if and only if the ReferencePoint is in the Points array of CurveByPoints.

See Also

ReferencePoint Class


GetPointElementReference Method

[image]

Revit 2013 API
ReferencePoint..::..GetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Retrieve a copy of the rule that computes the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointElementReference GetPointElementReference()
Visual Basic
Public Function GetPointElementReference As PointElementReference
Visual C++
public:
PointElementReference^ GetPointElementReference()

Return Value

A PointElementReference object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the ReferencePoint does not have a reference.

See Also

ReferencePoint Class


GetVisibility Method

[image]

Revit 2013 API
ReferencePoint..::..GetVisibility Method
ReferencePoint Class See Also Send Feedback
Gets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the ReferencePoint.

See Also

ReferencePoint Class


SetCoordinateSystem Method

[image]

Revit 2013 API
ReferencePoint..::..SetCoordinateSystem Method
ReferencePoint Class See Also Send Feedback
The position and orientation of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCoordinateSystem(
    Transform coordinateSystem
)
Visual Basic
Public Sub SetCoordinateSystem ( _
    coordinateSystem As Transform _
)
Visual C++
public:
void SetCoordinateSystem(
    Transform^ coordinateSystem
)

Parameters

coordinateSystem
Type: Autodesk.Revit.DB..::..Transform

Remarks

The position of the point is given by CoordinateSystem.Origin, and the orientation is specified by the three unit vectors CoordinateSystem.BasisX, BasisY, BasisZ. The basis vectors must be unit length and mutually perpendicular. Whenever the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), changing the CoordinateSystem property has a compound effect. First the point is moved to the specified location. Then the point is moved to conform to its Reference, by the shortest possible distance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when coordinateSystem does not specify an orthonormal basis.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


SetPointElementReference Method

[image]

Revit 2013 API
ReferencePoint..::..SetPointElementReference Method
ReferencePoint Class See Also Send Feedback
Change the rule for computing the location of the ReferencePoint relative to other elements in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetPointElementReference(
    PointElementReference pointElementReference
)
Visual Basic
Public Sub SetPointElementReference ( _
    pointElementReference As PointElementReference _
)
Visual C++
public:
void SetPointElementReference(
    PointElementReference^ pointElementReference
)

Parameters

pointElementReference
Type: Autodesk.Revit.DB..::..PointElementReference
An object specifying a rule for the location and orientation of a ReferencePoint. (Note: The ReferencePoint object does not store the pointElementReference object after this call.)

Remarks

pointElementReference may be nullNothingnullptra null reference (Nothing in Visual Basic), in which case the ReferencePoint does not follow any other element. When Reference is changed from nullNothingnullptra null reference (Nothing in Visual Basic) to a non-null value, the point moves and rotates to the prescribed location and orientation. Where the coordinate system has some freedom, it will remain as close to the old orientation as possible. When the reference is set to nullNothingnullptra null reference (Nothing in Visual Basic), the point does not move or rotate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when Reference is set to a non-null object, and the ReferencePoint is unable to move to the new reference.

See Also

ReferencePoint Class


SetVisibility Method

[image]

Revit 2013 API
ReferencePoint..::..SetVisibility Method
ReferencePoint Class See Also Send Feedback
Sets the visibility for the point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the point can be changed for different types of views and detail levels in the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

ReferencePoint Class


ReferencePoint Properties

[image] [image]

Revit 2013 API
ReferencePoint Properties
ReferencePoint Class See Also Send Feedback

The ReferencePoint type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinatePlaneVisibility | Visibility settings for the coordinate reference planes.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the ReferencePoint.
Public property | ShowNormalReferencePlaneOnly | Whether all three coordinate planes are shown, or only the normal (XY) plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Whether the point is visible when the family is loaded into a project.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ReferencePoint Class


CoordinatePlaneVisibility Property

[image]

Revit 2013 API
ReferencePoint..::..CoordinatePlaneVisibility Property
ReferencePoint Class See Also Send Feedback
Visibility settings for the coordinate reference planes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CoordinatePlaneVisibility CoordinatePlaneVisibility { get; set; }
Visual Basic
Public Property CoordinatePlaneVisibility As CoordinatePlaneVisibility
    Get
    Set
Visual C++
public:
property CoordinatePlaneVisibility CoordinatePlaneVisibility {
    CoordinatePlaneVisibility get ();
    void set (CoordinatePlaneVisibility value);
}

See Also

ReferencePoint Class


Name Property

[image]

Revit 2013 API
ReferencePoint..::..Name Property
ReferencePoint Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

See Also

ReferencePoint Class


Parameter Property

[image] [image]

Revit 2013 API
ReferencePoint..::..Parameter Property
ReferencePoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ReferencePoint Class
ReferencePoint Members


Position Property

[image]

Revit 2013 API
ReferencePoint..::..Position Property
ReferencePoint Class See Also Send Feedback
The position of the ReferencePoint.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is an alternate interface to the property CoordinateSystem.Origin. When set, the effect is the same as setting the CoordinateSystem property to the same as its current value but with a different Origin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when CoordinateSystem is set while the Reference property is not nullNothingnullptra null reference (Nothing in Visual Basic), and the ReferencePoint is unable to move to the new location.

See Also

ReferencePoint Class


ShowNormalReferencePlaneOnly Property

[image]

Revit 2013 API
ReferencePoint..::..ShowNormalReferencePlaneOnly Property
ReferencePoint Class See Also Send Feedback
Whether all three coordinate planes are shown, or only the normal (XY) plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ShowNormalReferencePlaneOnly { get; set; }
Visual Basic
Public Property ShowNormalReferencePlaneOnly As Boolean
    Get
    Set
Visual C++
public:
property bool ShowNormalReferencePlaneOnly {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class


Visible Property

[image]

Revit 2013 API
ReferencePoint..::..Visible Property
ReferencePoint Class See Also Send Feedback
Whether the point is visible when the family is loaded into a project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

ReferencePoint Class


ReferencePointArray Class

[image]

Revit 2013 API
ReferencePointArray Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ReferencePointArray : APIObject,
    IEnumerable
Visual Basic
Public Class ReferencePointArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ReferencePointArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferencePointArray

See Also

ReferencePointArray Members


ReferencePointArray Members

[image] [image]

Revit 2013 API
ReferencePointArray Members
ReferencePointArray Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArray type exposes the following members.

Constructors

 | Name | Description
Public method | ReferencePointArray | Initializes a new instance of the ReferencePointArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size |

See Also

ReferencePointArray Class


ReferencePointArray Constructor

[image]

Revit 2013 API
ReferencePointArray Constructor
ReferencePointArray Class See Also Send Feedback
Initializes a new instance of the ReferencePointArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePointArray()
Visual Basic
Public Sub New
Visual C++
public:
ReferencePointArray()

See Also

ReferencePointArray Class


ReferencePointArray Methods

[image] [image]

Revit 2013 API
ReferencePointArray Methods
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArray Class


Append Method

[image]

Revit 2013 API
ReferencePointArray..::..Append Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    ReferencePoint item
)
Visual Basic
Public Overridable Sub Append ( _
    item As ReferencePoint _
)
Visual C++
public:
virtual void Append(
    ReferencePoint^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferencePoint

See Also

ReferencePointArray Class


Clear Method

[image]

Revit 2013 API
ReferencePointArray..::..Clear Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ReferencePointArray Class


ForwardIterator Method

[image]

Revit 2013 API
ReferencePointArray..::..ForwardIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ForwardIterator()

See Also

ReferencePointArray Class


GetEnumerator Method

[image]

Revit 2013 API
ReferencePointArray..::..GetEnumerator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ReferencePointArray Class


Insert Method

[image]

Revit 2013 API
ReferencePointArray..::..Insert Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    ReferencePoint item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As ReferencePoint, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    ReferencePoint^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..ReferencePoint
index
Type: System..::..Int32

See Also

ReferencePointArray Class


ReverseIterator Method

[image]

Revit 2013 API
ReferencePointArray..::..ReverseIterator Method
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferencePointArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ReferencePointArrayIterator
Visual C++
public:
virtual ReferencePointArrayIterator^ ReverseIterator()

See Also

ReferencePointArray Class


ReferencePointArray Properties

[image] [image]

Revit 2013 API
ReferencePointArray Properties
ReferencePointArray Class See Also Send Feedback

The ReferencePointArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item |
Public property | Size |

See Also

ReferencePointArray Class


IsEmpty Property

[image]

Revit 2013 API
ReferencePointArray..::..IsEmpty Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

ReferencePointArray Class


Item Property

[image]

Revit 2013 API
ReferencePointArray..::..Item Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ReferencePoint this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As ReferencePoint
    Get
    Set
Visual C++
public:
virtual property ReferencePoint^ Item[int index] {
    ReferencePoint^ get (int index);
    void set (int index, ReferencePoint^ value);
}

Parameters

index
Type: System..::..Int32

See Also

ReferencePointArray Class


Size Property

[image]

Revit 2013 API
ReferencePointArray..::..Size Property
ReferencePointArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ReferencePointArray Class


ReferencePointArrayIterator Class

[image]

Revit 2013 API
ReferencePointArrayIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ReferencePointArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ReferencePointArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ReferencePointArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ReferencePointArrayIterator

See Also

ReferencePointArrayIterator Members


ReferencePointArrayIterator Members

[image] [image]

Revit 2013 API
ReferencePointArrayIterator Members
ReferencePointArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ReferencePointArrayIterator | Initializes a new instance of the ReferencePointArrayIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Constructor

[image]

Revit 2013 API
ReferencePointArrayIterator Constructor
ReferencePointArrayIterator Class See Also Send Feedback
Initializes a new instance of the ReferencePointArrayIterator class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferencePointArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ReferencePointArrayIterator()

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Methods

[image] [image]

Revit 2013 API
ReferencePointArrayIterator Methods
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferencePointArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
ReferencePointArrayIterator..::..MoveNext Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

ReferencePointArrayIterator Class


Reset Method

[image]

Revit 2013 API
ReferencePointArrayIterator..::..Reset Method
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

ReferencePointArrayIterator Class


ReferencePointArrayIterator Properties

[image] [image]

Revit 2013 API
ReferencePointArrayIterator Properties
ReferencePointArrayIterator Class See Also Send Feedback

The ReferencePointArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ReferencePointArrayIterator Class


Current Property

[image]

Revit 2013 API
ReferencePointArrayIterator..::..Current Property
ReferencePointArrayIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

ReferencePointArrayIterator Class


ReferenceType Enumeration

[image]

Revit 2013 API
ReferenceType Enumeration
See Also Send Feedback
Reference types of curve element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ReferenceType
Visual Basic
Public Enumeration ReferenceType
Visual C++
public enum class ReferenceType

Members

Member name | Description
None |
WeakReference |
StrongReference |

See Also


ReferenceWithContext Class

[image]

Revit 2013 API
ReferenceWithContext Class
Members See Also Send Feedback
An object including a reference to a geometric object and related context, as instance transform etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ReferenceWithContext : IDisposable
Visual Basic
Public Class ReferenceWithContext _
    Implements IDisposable
Visual C++
public ref class ReferenceWithContext : IDisposable

Remarks

The ReferenceWithContext is used as the returned value from the method FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or or ReferenceIntersector.Find(XYZ, XYZ). It includes a reference intersecting a line extended in a certain direction from an origin point and the context of the geometric object, as the transform and proximity.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ReferenceWithContext

See Also

ReferenceWithContext Members


ReferenceWithContext Members

[image] [image]

Revit 2013 API
ReferenceWithContext Members
ReferenceWithContext Class Methods Properties See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReferenceWithContext
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


ReferenceWithContext Methods

[image] [image]

Revit 2013 API
ReferenceWithContext Methods
ReferenceWithContext Class See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInstanceTransform | Gets the transform of the instance.
Public method | GetReference | Gets the reference of the geometric object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReferenceWithContext Class


Dispose Method

[image]

Revit 2013 API
ReferenceWithContext..::..Dispose Method
ReferenceWithContext Class See Also Send Feedback
Releases all resources used by the ReferenceWithContext

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReferenceWithContext Class


GetInstanceTransform Method

[image]

Revit 2013 API
ReferenceWithContext..::..GetInstanceTransform Method
ReferenceWithContext Class See Also Send Feedback
Gets the transform of the instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform GetInstanceTransform()
Visual Basic
Public Function GetInstanceTransform As Transform
Visual C++
public:
Transform^ GetInstanceTransform()

Return Value

The transform of an instance when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


GetReference Method

[image]

Revit 2013 API
ReferenceWithContext..::..GetReference Method
ReferenceWithContext Class See Also Send Feedback
Gets the reference of the geometric object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Reference GetReference()
Visual Basic
Public Function GetReference As Reference
Visual C++
public:
Reference^ GetReference()

Return Value

The reference of a geometric object when it is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


ReferenceWithContext Properties

[image] [image]

Revit 2013 API
ReferenceWithContext Properties
ReferenceWithContext Class See Also Send Feedback

The ReferenceWithContext type exposes the following members.

Properties

 | Name | Description
Public property | Proximity | The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

See Also

ReferenceWithContext Class


Proximity Property

[image]

Revit 2013 API
ReferenceWithContext..::..Proximity Property
ReferenceWithContext Class See Also Send Feedback
The proximity value to the ray's origin when the reference is returned by FindReferencesWithContextByDirection(XYZ, XYZ, View3D) or ReferenceIntersector.Find(XYZ, XYZ).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Proximity { get; }
Visual Basic
Public ReadOnly Property Proximity As Double
    Get
Visual C++
public:
property double Proximity {
    double get ();
}

See Also

ReferenceWithContext Class


RenderingImageExposureSettings Class

[image]

Revit 2013 API
RenderingImageExposureSettings Class
Members See Also Send Feedback
Represents the exposure settings of rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RenderingImageExposureSettings : IDisposable
Visual Basic
Public Class RenderingImageExposureSettings _
    Implements IDisposable
Visual C++
public ref class RenderingImageExposureSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingImageExposureSettings

See Also

RenderingImageExposureSettings Members


RenderingImageExposureSettings Members

[image] [image]

Revit 2013 API
RenderingImageExposureSettings Members
RenderingImageExposureSettings Class Methods Properties See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingImageExposureSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | MidTones | The midtones value.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.

See Also

RenderingImageExposureSettings Class


RenderingImageExposureSettings Methods

[image] [image]

Revit 2013 API
RenderingImageExposureSettings Methods
RenderingImageExposureSettings Class See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingImageExposureSettings Class


Dispose Method

[image]

Revit 2013 API
RenderingImageExposureSettings..::..Dispose Method
RenderingImageExposureSettings Class See Also Send Feedback
Releases all resources used by the RenderingImageExposureSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderingImageExposureSettings Class


RenderingImageExposureSettings Properties

[image] [image]

Revit 2013 API
RenderingImageExposureSettings Properties
RenderingImageExposureSettings Class See Also Send Feedback

The RenderingImageExposureSettings type exposes the following members.

Properties

 | Name | Description
Public property | ExposureValue | The value of rendering image exposure.
Public property | Highlights | The highlights value.
Public property | MidTones | The midtones value.
Public property | Saturation | The value of rendering image saturation.
Public property | Shadows | The shadows value.
Public property | WhitePoint | The white point value.

See Also

RenderingImageExposureSettings Class


ExposureValue Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..ExposureValue Property
RenderingImageExposureSettings Class See Also Send Feedback
The value of rendering image exposure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ExposureValue { get; set; }
Visual Basic
Public Property ExposureValue As Double
    Get
    Set
Visual C++
public:
property double ExposureValue {
    double get ();
    void set (double value);
}

Remarks

Default exposure value based on Lighting Scheme.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of rendering image exposure is not valid. The valid range is -6 to 16.

See Also

RenderingImageExposureSettings Class


Highlights Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..Highlights Property
RenderingImageExposureSettings Class See Also Send Feedback
The highlights value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Highlights { get; set; }
Visual Basic
Public Property Highlights As Double
    Get
    Set
Visual C++
public:
property double Highlights {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get brighter highlights.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of highlights is not valid. The valid range is 0 to 1.

See Also

RenderingImageExposureSettings Class


MidTones Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..MidTones Property
RenderingImageExposureSettings Class See Also Send Feedback
The midtones value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MidTones { get; set; }
Visual Basic
Public Property MidTones As Double
    Get
    Set
Visual C++
public:
property double MidTones {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get brighter midtones.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of mid tones is not valid. The valid range is 0.1 to 4.

See Also

RenderingImageExposureSettings Class


Saturation Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..Saturation Property
RenderingImageExposureSettings Class See Also Send Feedback
The value of rendering image saturation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Saturation { get; set; }
Visual Basic
Public Property Saturation As Integer
    Get
    Set
Visual C++
public:
property int Saturation {
    int get ();
    void set (int value);
}

Remarks

Increase this value to get more intense colors.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of saturation is not valid. The valid range is 0 to 5.

See Also

RenderingImageExposureSettings Class


Shadows Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..Shadows Property
RenderingImageExposureSettings Class See Also Send Feedback
The shadows value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Shadows { get; set; }
Visual Basic
Public Property Shadows As Double
    Get
    Set
Visual C++
public:
property double Shadows {
    double get ();
    void set (double value);
}

Remarks

Increase this value to get darker shadows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of shadows is not valid. The valid range is 0.1 to 4.

See Also

RenderingImageExposureSettings Class


WhitePoint Property

[image]

Revit 2013 API
RenderingImageExposureSettings..::..WhitePoint Property
RenderingImageExposureSettings Class See Also Send Feedback
The white point value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WhitePoint { get; set; }
Visual Basic
Public Property WhitePoint As Double
    Get
    Set
Visual C++
public:
property double WhitePoint {
    double get ();
    void set (double value);
}

Remarks

Specify the white balance of the rendering(measured in Kelvin). Incandescent lighting:2800 K; Daylight 6500K.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of white point is not valid. The valid range is 1800 to 15000.

See Also

RenderingImageExposureSettings Class


RenderingQuality Enumeration

[image]

Revit 2013 API
RenderingQuality Enumeration
See Also Send Feedback
Indicates the rendering quality in rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RenderingQuality
Visual Basic
Public Enumeration RenderingQuality
Visual C++
public enum class RenderingQuality

Members

Member name | Description
Draft | Draft level quality.
Low | Low level quality.
Medium | Medium level quality.
High | High level quality.
VeryHigh | Very high level quality.
Custom | Custom level quality.

See Also


RenderingQualitySettings Class

[image]

Revit 2013 API
RenderingQualitySettings Class
Members See Also Send Feedback
Represents the quality settings of rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RenderingQualitySettings : IDisposable
Visual Basic
Public Class RenderingQualitySettings _
    Implements IDisposable
Visual C++
public ref class RenderingQualitySettings : IDisposable

Remarks

The other properties in this class can only be modified if the RenderingQuality property is currently set to Custom.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingQualitySettings

See Also

RenderingQualitySettings Members


RenderingQualitySettings Members

[image] [image]

Revit 2013 API
RenderingQualitySettings Members
RenderingQualitySettings Class Methods Properties See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingQualitySettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreCurtainWallsDaylightPortals | Indicates whether curtain walls daylight portals.
Public property | AreDoorsDaylightPortals | Indicates whether doors daylight portals.
Public property | AreShadowsEnabled | Indicates whether to make shadow edges soft(blurred).
Public property | AreWindowsDaylightPortals | Indicates whether windows daylight portals.
Public property | BlurredReflectionPrecision | The blurred reflections precision.
Public property | BlurredRefractionPrecision | The blurred refractions precision.
Public property | ImagePrecision | A value that controls how antialiasing is applied to the background image.
Public property | IndirectIlluminationBounces | The indirect illumination bounces value.
Public property | IndirectIlluminationPrecision | The indirect illumination precision value.
Public property | IndirectIlluminationSmoothness | The indirect illumination smoothness value.
Public property | MaxReflections | The maximum number of reflections.
Public property | MaxRefractions | The maximum number of refractions.
Public property | RenderingQuality | The quality applied for rendering.
Public property | ShouldComputeIndirectAndSkyIllumination | Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.
Public property | SoftShadowsPrecision | The soft shadows precision value.

See Also

RenderingQualitySettings Class


RenderingQualitySettings Methods

[image] [image]

Revit 2013 API
RenderingQualitySettings Methods
RenderingQualitySettings Class See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingQualitySettings Class


Dispose Method

[image]

Revit 2013 API
RenderingQualitySettings..::..Dispose Method
RenderingQualitySettings Class See Also Send Feedback
Releases all resources used by the RenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderingQualitySettings Class


RenderingQualitySettings Properties

[image] [image]

Revit 2013 API
RenderingQualitySettings Properties
RenderingQualitySettings Class See Also Send Feedback

The RenderingQualitySettings type exposes the following members.

Properties

 | Name | Description
Public property | AreCurtainWallsDaylightPortals | Indicates whether curtain walls daylight portals.
Public property | AreDoorsDaylightPortals | Indicates whether doors daylight portals.
Public property | AreShadowsEnabled | Indicates whether to make shadow edges soft(blurred).
Public property | AreWindowsDaylightPortals | Indicates whether windows daylight portals.
Public property | BlurredReflectionPrecision | The blurred reflections precision.
Public property | BlurredRefractionPrecision | The blurred refractions precision.
Public property | ImagePrecision | A value that controls how antialiasing is applied to the background image.
Public property | IndirectIlluminationBounces | The indirect illumination bounces value.
Public property | IndirectIlluminationPrecision | The indirect illumination precision value.
Public property | IndirectIlluminationSmoothness | The indirect illumination smoothness value.
Public property | MaxReflections | The maximum number of reflections.
Public property | MaxRefractions | The maximum number of refractions.
Public property | RenderingQuality | The quality applied for rendering.
Public property | ShouldComputeIndirectAndSkyIllumination | Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.
Public property | SoftShadowsPrecision | The soft shadows precision value.

See Also

RenderingQualitySettings Class


AreCurtainWallsDaylightPortals Property

[image]

Revit 2013 API
RenderingQualitySettings..::..AreCurtainWallsDaylightPortals Property
RenderingQualitySettings Class See Also Send Feedback
Indicates whether curtain walls daylight portals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreCurtainWallsDaylightPortals { get; set; }
Visual Basic
Public Property AreCurtainWallsDaylightPortals As Boolean
    Get
    Set
Visual C++
public:
property bool AreCurtainWallsDaylightPortals {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true when sunlighting coming through a curtain wall looks splotchy, this can slow down rendering but helps for rooms with few places for sunlight to enter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


AreDoorsDaylightPortals Property

[image]

Revit 2013 API
RenderingQualitySettings..::..AreDoorsDaylightPortals Property
RenderingQualitySettings Class See Also Send Feedback
Indicates whether doors daylight portals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreDoorsDaylightPortals { get; set; }
Visual Basic
Public Property AreDoorsDaylightPortals As Boolean
    Get
    Set
Visual C++
public:
property bool AreDoorsDaylightPortals {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true when sunlighting coming through a door looks splotchy, this can slow down rendering but helps for rooms with few places for sunlight to enter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


AreShadowsEnabled Property

[image]

Revit 2013 API
RenderingQualitySettings..::..AreShadowsEnabled Property
RenderingQualitySettings Class See Also Send Feedback
Indicates whether to make shadow edges soft(blurred).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreShadowsEnabled { get; set; }
Visual Basic
Public Property AreShadowsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool AreShadowsEnabled {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


AreWindowsDaylightPortals Property

[image]

Revit 2013 API
RenderingQualitySettings..::..AreWindowsDaylightPortals Property
RenderingQualitySettings Class See Also Send Feedback
Indicates whether windows daylight portals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AreWindowsDaylightPortals { get; set; }
Visual Basic
Public Property AreWindowsDaylightPortals As Boolean
    Get
    Set
Visual C++
public:
property bool AreWindowsDaylightPortals {
    bool get ();
    void set (bool value);
}

Remarks

Set this property to true when sunlighting coming through windows looks splotchy, this can slow down rendering but helps for rooms with few or small windows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


BlurredReflectionPrecision Property

[image]

Revit 2013 API
RenderingQualitySettings..::..BlurredReflectionPrecision Property
RenderingQualitySettings Class See Also Send Feedback
The blurred reflections precision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int BlurredReflectionPrecision { get; set; }
Visual Basic
Public Property BlurredReflectionPrecision As Integer
    Get
    Set
Visual C++
public:
property int BlurredReflectionPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of objects in blurred reflections are speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The blurred reflections precision is not valid. The valid range is 1 to 11.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


BlurredRefractionPrecision Property

[image]

Revit 2013 API
RenderingQualitySettings..::..BlurredRefractionPrecision Property
RenderingQualitySettings Class See Also Send Feedback
The blurred refractions precision.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int BlurredRefractionPrecision { get; set; }
Visual Basic
Public Property BlurredRefractionPrecision As Integer
    Get
    Set
Visual C++
public:
property int BlurredRefractionPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of objects seen through rough glass are speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The blurred refractions precision is not valid. The valid range is 1 to 11.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


ImagePrecision Property

[image]

Revit 2013 API
RenderingQualitySettings..::..ImagePrecision Property
RenderingQualitySettings Class See Also Send Feedback
A value that controls how antialiasing is applied to the background image.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ImagePrecision { get; set; }
Visual Basic
Public Property ImagePrecision As Integer
    Get
    Set
Visual C++
public:
property int ImagePrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value to smooth out jagged edges in the rendering.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The image precision value is not valid. The valid range is 0 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


IndirectIlluminationBounces Property

[image]

Revit 2013 API
RenderingQualitySettings..::..IndirectIlluminationBounces Property
RenderingQualitySettings Class See Also Send Feedback
The indirect illumination bounces value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int IndirectIlluminationBounces { get; set; }
Visual Basic
Public Property IndirectIlluminationBounces As Integer
    Get
    Set
Visual C++
public:
property int IndirectIlluminationBounces {
    int get ();
    void set (int value);
}

Remarks

Increase this value when areas of the scene that should be indirectly illuminated are left in darkness.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The indirect illumination bounces value is not valid. The valid range is 1 to 5.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Should not compute indirect and sky illumination.

See Also

RenderingQualitySettings Class


IndirectIlluminationPrecision Property

[image]

Revit 2013 API
RenderingQualitySettings..::..IndirectIlluminationPrecision Property
RenderingQualitySettings Class See Also Send Feedback
The indirect illumination precision value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int IndirectIlluminationPrecision { get; set; }
Visual Basic
Public Property IndirectIlluminationPrecision As Integer
    Get
    Set
Visual C++
public:
property int IndirectIlluminationPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value to get more detailed indirect illumination and shadows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The indirect illumination precision value is not valid. The valid range is 1 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Should not compute indirect and sky illumination.

See Also

RenderingQualitySettings Class


IndirectIlluminationSmoothness Property

[image]

Revit 2013 API
RenderingQualitySettings..::..IndirectIlluminationSmoothness Property
RenderingQualitySettings Class See Also Send Feedback
The indirect illumination smoothness value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int IndirectIlluminationSmoothness { get; set; }
Visual Basic
Public Property IndirectIlluminationSmoothness As Integer
    Get
    Set
Visual C++
public:
property int IndirectIlluminationSmoothness {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the indirect illumination looks splotchy or scaly.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The indirect illumination smoothness value is not valid. The valid range is 1 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Should not compute indirect and sky illumination.

See Also

RenderingQualitySettings Class


MaxReflections Property

[image]

Revit 2013 API
RenderingQualitySettings..::..MaxReflections Property
RenderingQualitySettings Class See Also Send Feedback
The maximum number of reflections.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MaxReflections { get; set; }
Visual Basic
Public Property MaxReflections As Integer
    Get
    Set
Visual C++
public:
property int MaxReflections {
    int get ();
    void set (int value);
}

Remarks

Increase this value when objects are missing from reflections.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximum number of reflections is not valid. The valid range is 0 to 100.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


MaxRefractions Property

[image]

Revit 2013 API
RenderingQualitySettings..::..MaxRefractions Property
RenderingQualitySettings Class See Also Send Feedback
The maximum number of refractions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MaxRefractions { get; set; }
Visual Basic
Public Property MaxRefractions As Integer
    Get
    Set
Visual C++
public:
property int MaxRefractions {
    int get ();
    void set (int value);
}

Remarks

Increase this value when you can not see objects through multiple panes of glass.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maximum number of refractions is not valid. The valid range is 0 to 100.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


RenderingQuality Property

[image]

Revit 2013 API
RenderingQualitySettings..::..RenderingQuality Property
RenderingQualitySettings Class See Also Send Feedback
The quality applied for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RenderingQuality RenderingQuality { get; set; }
Visual Basic
Public Property RenderingQuality As RenderingQuality
    Get
    Set
Visual C++
public:
property RenderingQuality RenderingQuality {
    RenderingQuality get ();
    void set (RenderingQuality value);
}

See Also

RenderingQualitySettings Class


ShouldComputeIndirectAndSkyIllumination Property

[image]

Revit 2013 API
RenderingQualitySettings..::..ShouldComputeIndirectAndSkyIllumination Property
RenderingQualitySettings Class See Also Send Feedback
Indicates whether to include light that bounces off other objects, and light from the sky when calculating the lighting for this scene.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShouldComputeIndirectAndSkyIllumination { get; set; }
Visual Basic
Public Property ShouldComputeIndirectAndSkyIllumination As Boolean
    Get
    Set
Visual C++
public:
property bool ShouldComputeIndirectAndSkyIllumination {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom.

See Also

RenderingQualitySettings Class


SoftShadowsPrecision Property

[image]

Revit 2013 API
RenderingQualitySettings..::..SoftShadowsPrecision Property
RenderingQualitySettings Class See Also Send Feedback
The soft shadows precision value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SoftShadowsPrecision { get; set; }
Visual Basic
Public Property SoftShadowsPrecision As Integer
    Get
    Set
Visual C++
public:
property int SoftShadowsPrecision {
    int get ();
    void set (int value);
}

Remarks

Increase this value when the edges of soft shadows appear to be speckled, rather than smoothly blurred.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The soft shadows precision value is not valid. The valid range is 1 to 10.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. -or- When setting this property: Shadows are not enabled.

See Also

RenderingQualitySettings Class


RenderingSettings Class

[image]

Revit 2013 API
RenderingSettings Class
Members See Also Send Feedback
Represents the rendering settings for a 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RenderingSettings : IDisposable
Visual Basic
Public Class RenderingSettings _
    Implements IDisposable
Visual C++
public ref class RenderingSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RenderingSettings

See Also

RenderingSettings Members


RenderingSettings Members

[image] [image]

Revit 2013 API
RenderingSettings Members
RenderingSettings Class Methods Properties See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RenderingSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.

See Also

RenderingSettings Class


RenderingSettings Methods

[image] [image]

Revit 2013 API
RenderingSettings Methods
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBackgroundSettings | Returns an object that represents the rendering background settings.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRenderingImageExposureSettings | Returns an object that represents the rendering image exposure settings.
Public method | GetRenderingQualitySettings | Returns an object that represents the rendering quality settings.
Public method | GetRenderingRegionOutline | Returns the outline of the rendering region.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetBackgroundSettings | Changes the rendering background settings details for the current background style.
Public method | SetRenderingImageExposureSettings | Changes the rendering image exposure settings.
Public method | SetRenderingQualitySettings | Change rendering quality settings.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderingSettings Class


Dispose Method

[image]

Revit 2013 API
RenderingSettings..::..Dispose Method
RenderingSettings Class See Also Send Feedback
Releases all resources used by the RenderingSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RenderingSettings Class


GetBackgroundSettings Method

[image]

Revit 2013 API
RenderingSettings..::..GetBackgroundSettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BackgroundSettings GetBackgroundSettings()
Visual Basic
Public Function GetBackgroundSettings As BackgroundSettings
Visual C++
public:
BackgroundSettings^ GetBackgroundSettings()

Return Value

The rendering background settings.

Remarks

Different kind of settings object will be returned according to different background style. It could be SkyBackgroundSettings, ColorBackgroundSettings, or ImageBackgroundSettings.

See Also

RenderingSettings Class


GetRenderingImageExposureSettings Method

[image]

Revit 2013 API
RenderingSettings..::..GetRenderingImageExposureSettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RenderingImageExposureSettings GetRenderingImageExposureSettings()
Visual Basic
Public Function GetRenderingImageExposureSettings As RenderingImageExposureSettings
Visual C++
public:
RenderingImageExposureSettings^ GetRenderingImageExposureSettings()

Return Value

The rendering image exposure settings.

See Also

RenderingSettings Class


GetRenderingQualitySettings Method

[image]

Revit 2013 API
RenderingSettings..::..GetRenderingQualitySettings Method
RenderingSettings Class See Also Send Feedback
Returns an object that represents the rendering quality settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RenderingQualitySettings GetRenderingQualitySettings()
Visual Basic
Public Function GetRenderingQualitySettings As RenderingQualitySettings
Visual C++
public:
RenderingQualitySettings^ GetRenderingQualitySettings()

Return Value

The rendering quality settings.

See Also

RenderingSettings Class


GetRenderingRegionOutline Method

[image]

Revit 2013 API
RenderingSettings..::..GetRenderingRegionOutline Method
RenderingSettings Class See Also Send Feedback
Returns the outline of the rendering region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Outline GetRenderingRegionOutline()
Visual Basic
Public Function GetRenderingRegionOutline As Outline
Visual C++
public:
Outline^ GetRenderingRegionOutline()

Return Value

The outline of the rendering region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The RenderingSettings are not currently using region rendering.

See Also

RenderingSettings Class


SetBackgroundSettings Method

[image]

Revit 2013 API
RenderingSettings..::..SetBackgroundSettings Method
RenderingSettings Class See Also Send Feedback
Changes the rendering background settings details for the current background style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetBackgroundSettings(
    BackgroundSettings background
)
Visual Basic
Public Sub SetBackgroundSettings ( _
    background As BackgroundSettings _
)
Visual C++
public:
void SetBackgroundSettings(
    BackgroundSettings^ background
)

Parameters

background
Type: Autodesk.Revit.DB..::..BackgroundSettings
An instance of the new rendering background settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RenderingSettings Class


SetRenderingImageExposureSettings Method

[image]

Revit 2013 API
RenderingSettings..::..SetRenderingImageExposureSettings Method
RenderingSettings Class See Also Send Feedback
Changes the rendering image exposure settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings exposure
)
Visual Basic
Public Sub SetRenderingImageExposureSettings ( _
    exposure As RenderingImageExposureSettings _
)
Visual C++
public:
void SetRenderingImageExposureSettings(
    RenderingImageExposureSettings^ exposure
)

Parameters

exposure
Type: Autodesk.Revit.DB..::..RenderingImageExposureSettings
An instance of the new rendering image exposure settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RenderingSettings Class


SetRenderingQualitySettings Method

[image]

Revit 2013 API
RenderingSettings..::..SetRenderingQualitySettings Method
RenderingSettings Class See Also Send Feedback
Change rendering quality settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetRenderingQualitySettings(
    RenderingQualitySettings settings
)
Visual Basic
Public Sub SetRenderingQualitySettings ( _
    settings As RenderingQualitySettings _
)
Visual C++
public:
void SetRenderingQualitySettings(
    RenderingQualitySettings^ settings
)

Parameters

settings
Type: Autodesk.Revit.DB..::..RenderingQualitySettings
An instance of the new rendering quality settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RenderingSettings Class


RenderingSettings Properties

[image] [image]

Revit 2013 API
RenderingSettings Properties
RenderingSettings Class See Also Send Feedback

The RenderingSettings type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundStyle | The enum value that controls the background style for rendering.
Public property | LightingSource | The lighting scheme type.
Public property | PrinterResolution | The resolution level when using printer.
Public property | ResolutionTarget | The resolution target.
Public property | ResolutionValue | The rendering resolution in dots per inch (DPI).
Public property | UsesRegionRendering | The bool value that indicates whether to use region rendering.

See Also

RenderingSettings Class


BackgroundStyle Property

[image]

Revit 2013 API
RenderingSettings..::..BackgroundStyle Property
RenderingSettings Class See Also Send Feedback
The enum value that controls the background style for rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BackgroundStyle BackgroundStyle { get; set; }
Visual Basic
Public Property BackgroundStyle As BackgroundStyle
    Get
    Set
Visual C++
public:
property BackgroundStyle BackgroundStyle {
    BackgroundStyle get ();
    void set (BackgroundStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for BackgroundStyle.

See Also

RenderingSettings Class


LightingSource Property

[image]

Revit 2013 API
RenderingSettings..::..LightingSource Property
RenderingSettings Class See Also Send Feedback
The lighting scheme type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightingSource LightingSource { get; set; }
Visual Basic
Public Property LightingSource As LightingSource
    Get
    Set
Visual C++
public:
property LightingSource LightingSource {
    LightingSource get ();
    void set (LightingSource value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not valid for Lighting.

See Also

RenderingSettings Class


PrinterResolution Property

[image]

Revit 2013 API
RenderingSettings..::..PrinterResolution Property
RenderingSettings Class See Also Send Feedback
The resolution level when using printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PrinterResolution PrinterResolution { get; set; }
Visual Basic
Public Property PrinterResolution As PrinterResolution
    Get
    Set
Visual C++
public:
property PrinterResolution PrinterResolution {
    PrinterResolution get ();
    void set (PrinterResolution value);
}

Remarks

The suitable resolution value is decided by default. You may obtain it from the ResolutionValue property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for PrinterResolution.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resolution target is not printer.

See Also

RenderingSettings Class


ResolutionTarget Property

[image]

Revit 2013 API
RenderingSettings..::..ResolutionTarget Property
RenderingSettings Class See Also Send Feedback
The resolution target.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ResolutionTarget ResolutionTarget { get; set; }
Visual Basic
Public Property ResolutionTarget As ResolutionTarget
    Get
    Set
Visual C++
public:
property ResolutionTarget ResolutionTarget {
    ResolutionTarget get ();
    void set (ResolutionTarget value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for ResolutionTarget.

See Also

RenderingSettings Class


ResolutionValue Property

[image]

Revit 2013 API
RenderingSettings..::..ResolutionValue Property
RenderingSettings Class See Also Send Feedback
The rendering resolution in dots per inch (DPI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ResolutionValue { get; }
Visual Basic
Public ReadOnly Property ResolutionValue As Integer
    Get
Visual C++
public:
property int ResolutionValue {
    int get ();
}

See Also

RenderingSettings Class


UsesRegionRendering Property

[image]

Revit 2013 API
RenderingSettings..::..UsesRegionRendering Property
RenderingSettings Class See Also Send Feedback
The bool value that indicates whether to use region rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool UsesRegionRendering { get; set; }
Visual Basic
Public Property UsesRegionRendering As Boolean
    Get
    Set
Visual C++
public:
property bool UsesRegionRendering {
    bool get ();
    void set (bool value);
}

See Also

RenderingSettings Class


ResolutionTarget Enumeration

[image]

Revit 2013 API
ResolutionTarget Enumeration
See Also Send Feedback
Indicates the resolution target(Screen or Printer) used for rendering settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ResolutionTarget
Visual Basic
Public Enumeration ResolutionTarget
Visual C++
public enum class ResolutionTarget

Members

Member name | Description
Screen | Uses screen resolution for rendering output settings.
Printer | Uses printer resolution for rendering output settings.

See Also


RevitLinkInstance Class

[image]

Revit 2013 API
RevitLinkInstance Class
Members See Also Send Feedback
Represents an instance of a RevitLinkType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RevitLinkInstance : Instance
Visual Basic
Public Class RevitLinkInstance _
    Inherits Instance
Visual C++
public ref class RevitLinkInstance : public Instance

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Instance
Autodesk.Revit.DB..::..RevitLinkInstance

See Also

RevitLinkInstance Members


RevitLinkInstance Members

[image] [image]

Revit 2013 API
RevitLinkInstance Members
RevitLinkInstance Class Methods Properties See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a linked Revit project (RevitLinkType).
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkInstance Class


RevitLinkInstance Methods

[image] [image]

Revit 2013 API
RevitLinkInstance Methods
RevitLinkInstance Class See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a linked Revit project (RevitLinkType).
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalTransform | Gets the total transform, which includes the true north transform for instances like import instances. (Inherited from Instance.)
Public method | GetTransform | Gets the transform of the instance. (Inherited from Instance.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitLinkInstance Class


Create Method

[image]

Revit 2013 API
RevitLinkInstance..::..Create Method
RevitLinkInstance Class See Also Send Feedback
Creates a new instance of a linked Revit project (RevitLinkType).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static RevitLinkInstance Create(
    Document document,
    ElementId revitLinkTypeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    revitLinkTypeId As ElementId _
) As RevitLinkInstance
Visual C++
public:
static RevitLinkInstance^ Create(
    Document^ document,
    ElementId^ revitLinkTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new instance should be created.
revitLinkTypeId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the RevitLinkType.

Return Value

The newly-created RevitLinkInstance.

Remarks

Instances will be placed origin-to-origin. This function cannot be used to create instances of nested links.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | revitLinkTypeId isn't a RevitLinkType. -or- revitLinkTypeId is not a top-level link. -or- revitLinkTypeId is not a loaded RevitLinkType -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkInstance Class


RevitLinkInstance Properties

[image] [image]

Revit 2013 API
RevitLinkInstance Properties
RevitLinkInstance Class See Also Send Feedback

The RevitLinkInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkInstance Class


Parameter Property

[image] [image]

Revit 2013 API
RevitLinkInstance..::..Parameter Property
RevitLinkInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevitLinkInstance Class
RevitLinkInstance Members


RevitLinkLoadResult Class

[image]

Revit 2013 API
RevitLinkLoadResult Class
Members See Also Send Feedback
This class stores the results of trying to load a single linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RevitLinkLoadResult : IDisposable
Visual Basic
Public Class RevitLinkLoadResult _
    Implements IDisposable
Visual C++
public ref class RevitLinkLoadResult : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RevitLinkLoadResult

See Also

RevitLinkLoadResult Members


RevitLinkLoadResult Members

[image] [image]

Revit 2013 API
RevitLinkLoadResult Members
RevitLinkLoadResult Class Constructors Methods Properties See Also Send Feedback

The RevitLinkLoadResult type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkLoadResult | Initializes a new instance of the RevitLinkLoadResult class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkLoadResult
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

RevitLinkLoadResult Class


RevitLinkLoadResult Constructor

[image]

Revit 2013 API
RevitLinkLoadResult Constructor
RevitLinkLoadResult Class See Also Send Feedback
Initializes a new instance of the RevitLinkLoadResult class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RevitLinkLoadResult(
    RevitLinkLoadResult other
)
Visual Basic
Public Sub New ( _
    other As RevitLinkLoadResult _
)
Visual C++
public:
RevitLinkLoadResult(
    RevitLinkLoadResult^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..RevitLinkLoadResult

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RevitLinkLoadResult Class


RevitLinkLoadResult Methods

[image] [image]

Revit 2013 API
RevitLinkLoadResult Methods
RevitLinkLoadResult Class See Also Send Feedback

The RevitLinkLoadResult type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCentralModelName | Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModelName | Gets the name of the model.
Public method | GetNestedLinkLoadResults | Gets the results for this link's nested links.
Public method | GetParentModelName | Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitLinkLoadResult Class


Dispose Method

[image]

Revit 2013 API
RevitLinkLoadResult..::..Dispose Method
RevitLinkLoadResult Class See Also Send Feedback
Releases all resources used by the RevitLinkLoadResult

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RevitLinkLoadResult Class


GetCentralModelName Method

[image]

Revit 2013 API
RevitLinkLoadResult..::..GetCentralModelName Method
RevitLinkLoadResult Class See Also Send Feedback
Gets the central model's name. If the link is not workshared, this returns an empty FilePath. If the link is itself a central model, this returns the link's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ModelPath GetCentralModelName()
Visual Basic
Public Function GetCentralModelName As ModelPath
Visual C++
public:
ModelPath^ GetCentralModelName()

Remarks

If the link could not be found or loaded, this name may be blank.

See Also

RevitLinkLoadResult Class


GetModelName Method

[image]

Revit 2013 API
RevitLinkLoadResult..::..GetModelName Method
RevitLinkLoadResult Class See Also Send Feedback
Gets the name of the model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ModelPath GetModelName()
Visual Basic
Public Function GetModelName As ModelPath
Visual C++
public:
ModelPath^ GetModelName()

See Also

RevitLinkLoadResult Class


GetNestedLinkLoadResults Method

[image]

Revit 2013 API
RevitLinkLoadResult..::..GetNestedLinkLoadResults Method
RevitLinkLoadResult Class See Also Send Feedback
Gets the results for this link's nested links.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IDictionary<string, RevitLinkLoadResult> GetNestedLinkLoadResults()
Visual Basic
Public Function GetNestedLinkLoadResults As IDictionary(Of String, RevitLinkLoadResult)
Visual C++
public:
IDictionary<String^, RevitLinkLoadResult^>^ GetNestedLinkLoadResults()

Return Value

A map from nested link paths to the load results for that nested link.

See Also

RevitLinkLoadResult Class


GetParentModelName Method

[image]

Revit 2013 API
RevitLinkLoadResult..::..GetParentModelName Method
RevitLinkLoadResult Class See Also Send Feedback
Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ModelPath GetParentModelName()
Visual Basic
Public Function GetParentModelName As ModelPath
Visual C++
public:
ModelPath^ GetParentModelName()

See Also

RevitLinkLoadResult Class


RevitLinkLoadResult Properties

[image] [image]

Revit 2013 API
RevitLinkLoadResult Properties
RevitLinkLoadResult Class See Also Send Feedback

The RevitLinkLoadResult type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The id of the created or loaded linked model.
Public property | IsCircularLink | True if these results are part of a link cycle.
Public property | IsNested | True if these results represent a nested link; false otherwise.
Public property | LoadResult | Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

See Also

RevitLinkLoadResult Class


ElementId Property

[image]

Revit 2013 API
RevitLinkLoadResult..::..ElementId Property
RevitLinkLoadResult Class See Also Send Feedback
The id of the created or loaded linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ElementId { get; }
Visual Basic
Public ReadOnly Property ElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

Remarks

This may be invalidElementId if there were errors (for example, LinkLoadResultType.SameModelAsHost causes no link to be created).

See Also

RevitLinkLoadResult Class


IsCircularLink Property

[image]

Revit 2013 API
RevitLinkLoadResult..::..IsCircularLink Property
RevitLinkLoadResult Class See Also Send Feedback
True if these results are part of a link cycle.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCircularLink { get; }
Visual Basic
Public ReadOnly Property IsCircularLink As Boolean
    Get
Visual C++
public:
property bool IsCircularLink {
    bool get ();
}

Remarks

A link cycle occurs when, for example, model A links model B as an attachment, which links model C as an attachment, which links model A as an attachment. Revit will only load one copy of model A; it will ignore the instance of A linked under C. Circular links do not abort the load process, so they do not appear as a result type in LinkLoadResultType.Enum.

See Also

RevitLinkLoadResult Class


IsNested Property

[image]

Revit 2013 API
RevitLinkLoadResult..::..IsNested Property
RevitLinkLoadResult Class See Also Send Feedback
True if these results represent a nested link; false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsNested { get; }
Visual Basic
Public ReadOnly Property IsNested As Boolean
    Get
Visual C++
public:
property bool IsNested {
    bool get ();
}

See Also

RevitLinkLoadResult Class


LoadResult Property

[image]

Revit 2013 API
RevitLinkLoadResult..::..LoadResult Property
RevitLinkLoadResult Class See Also Send Feedback
Holds the results of creating or loading a link. Results can be LinkLoadResultType.LinkLoaded for success, or a variety of errors. See LinkLoadResultType for the full list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RevitLinkLoadResultType LoadResult { get; }
Visual Basic
Public ReadOnly Property LoadResult As RevitLinkLoadResultType
    Get
Visual C++
public:
property RevitLinkLoadResultType LoadResult {
    RevitLinkLoadResultType get ();
}

See Also

RevitLinkLoadResult Class


RevitLinkLoadResultType Enumeration

[image]

Revit 2013 API
RevitLinkLoadResultType Enumeration
See Also Send Feedback
Enum listing the possible results after loading a linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum RevitLinkLoadResultType
Visual Basic
Public Enumeration RevitLinkLoadResultType
Visual C++
public enum class RevitLinkLoadResultType

Members

Member name | Description
LinkLoaded | The linked model loaded correctly.
LinkNotFound | The linked model could not be found.
LinkNotOpenable | An error occurred trying to read the linked model.
LinkOpenAsHost | The linked model is already opened directly in Revit.
SameModelAsHost | The linked model has the same path as the currently active document.
SameCentralModelAsHost | Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central.
LinkNotLoadedOtherError | An unknown error occurred.

Remarks

For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).

See Also


RevitLinkOptions Class

[image]

Revit 2013 API
RevitLinkOptions Class
Members See Also Send Feedback
This class contains the options in use when creating or loading a Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RevitLinkOptions : IDisposable
Visual Basic
Public Class RevitLinkOptions _
    Implements IDisposable
Visual C++
public ref class RevitLinkOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RevitLinkOptions

See Also

RevitLinkOptions Members


RevitLinkOptions Members

[image] [image]

Revit 2013 API
RevitLinkOptions Members
RevitLinkOptions Class Constructors Methods Properties See Also Send Feedback

The RevitLinkOptions type exposes the following members.

Constructors

 | Name | Description
Public method | RevitLinkOptions | Initializes a new instance of the RevitLinkOptions class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitLinkOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRelative | The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.

See Also

RevitLinkOptions Class


RevitLinkOptions Constructor

[image]

Revit 2013 API
RevitLinkOptions Constructor
RevitLinkOptions Class See Also Send Feedback
Initializes a new instance of the RevitLinkOptions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RevitLinkOptions(
    bool relative
)
Visual Basic
Public Sub New ( _
    relative As Boolean _
)
Visual C++
public:
RevitLinkOptions(
    bool relative
)

Parameters

relative
Type: System..::..Boolean

See Also

RevitLinkOptions Class


RevitLinkOptions Methods

[image] [image]

Revit 2013 API
RevitLinkOptions Methods
RevitLinkOptions Class See Also Send Feedback

The RevitLinkOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitLinkOptions Class


Dispose Method

[image]

Revit 2013 API
RevitLinkOptions..::..Dispose Method
RevitLinkOptions Class See Also Send Feedback
Releases all resources used by the RevitLinkOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RevitLinkOptions Class


RevitLinkOptions Properties

[image] [image]

Revit 2013 API
RevitLinkOptions Properties
RevitLinkOptions Class See Also Send Feedback

The RevitLinkOptions type exposes the following members.

Properties

 | Name | Description
Public property | IsRelative | The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.

See Also

RevitLinkOptions Class


IsRelative Property

[image]

Revit 2013 API
RevitLinkOptions..::..IsRelative Property
RevitLinkOptions Class See Also Send Feedback
The type of path to use when creating the link. If true, Revit will store a relative path for the link. If false, Revit will store an absolute path. If the link is to a Revit Server location, isRelative must be false.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsRelative { get; set; }
Visual Basic
Public Property IsRelative As Boolean
    Get
    Set
Visual C++
public:
property bool IsRelative {
    bool get ();
    void set (bool value);
}

See Also

RevitLinkOptions Class


RevitLinkType Class

[image]

Revit 2013 API
RevitLinkType Class
Members See Also Send Feedback
This class represents another Revit Document ("link") brought into the current one ("host").

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RevitLinkType : ElementType
Visual Basic
Public Class RevitLinkType _
    Inherits ElementType
Visual C++
public ref class RevitLinkType : public ElementType

Remarks

Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..RevitLinkType

See Also

RevitLinkType Members


RevitLinkType Members

[image] [image]

Revit 2013 API
RevitLinkType Members
RevitLinkType Class Methods Properties See Also Send Feedback

The RevitLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new Revit link type and loads the linked document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
 | GetTopLevelLink | Returns the ElementId of the (top-level) linked model with the given path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkType Class


RevitLinkType Methods

[image] [image]

Revit 2013 API
RevitLinkType Methods
RevitLinkType Class See Also Send Feedback

The RevitLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new Revit link type and loads the linked document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetChildIds | Gets the ids of the immediate children of this link.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetParentId | Gets the id of this link's immediate parent.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetRootId | Gets the id of the top-level link which this link is linked into.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
 | GetTopLevelLink | Returns the ElementId of the (top-level) linked model with the given path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLoaded | Checks whether the link with this id is loaded.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitLinkType Class


Create Method

[image]

Revit 2013 API
RevitLinkType..::..Create Method
RevitLinkType Class See Also Send Feedback
Creates a new Revit link type and loads the linked document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static RevitLinkLoadResult Create(
    Document document,
    ModelPath path,
    RevitLinkOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    path As ModelPath, _
    options As RevitLinkOptions _
) As RevitLinkLoadResult
Visual C++
public:
static RevitLinkLoadResult^ Create(
    Document^ document,
    ModelPath^ path,
    RevitLinkOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the Revit link.
path
Type: Autodesk.Revit.DB..::..ModelPath
The path of the link to load. This may be a server path. This must be a full path.
options
Type: Autodesk.Revit.DB..::..RevitLinkOptions
An options class for loading Revit links.

Return Value

An object containing the results of creating and loading the Revit link type. It contains the ElementId of the new link.

Remarks

This function regenerates the input document. While the options argument allows specification of a path type, the input path argument must be a full path. Relative vs. absolute determines how Revit will store the path, but it needs a complete path to find the linked document initially.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- Server paths cannot be relative. -or- document already contains a linked model at path path.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

RevitLinkType Class


GetChildIds Method

[image]

Revit 2013 API
RevitLinkType..::..GetChildIds Method
RevitLinkType Class See Also Send Feedback
Gets the ids of the immediate children of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetChildIds()
Visual Basic
Public Function GetChildIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetChildIds()

Return Value

The element ids of all links which are linked directly into this one (immediate children)

Remarks

This function only returns the ids of immediate children. Given the link structure A -> B -> C, then calling this function on A will only return B's id.

See Also

RevitLinkType Class


GetParentId Method

[image]

Revit 2013 API
RevitLinkType..::..GetParentId Method
RevitLinkType Class See Also Send Feedback
Gets the id of this link's immediate parent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetParentId()
Visual Basic
Public Function GetParentId As ElementId
Visual C++
public:
ElementId^ GetParentId()

Return Value

The id of the immediate parent of this link, or invalidElementId if this link is a top-level link.

Remarks

This function returns the immediate parent id. Given the link structure A -> B -> C, then calling this function on C will return B's id. Call GetRootId to get A's id.

See Also

RevitLinkType Class


GetRootId Method

[image]

Revit 2013 API
RevitLinkType..::..GetRootId Method
RevitLinkType Class See Also Send Feedback
Gets the id of the top-level link which this link is linked into.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetRootId()
Visual Basic
Public Function GetRootId As ElementId
Visual C++
public:
ElementId^ GetRootId()

Return Value

The id of the top-level link which this link is ultimately linked under, or invalidElementId if this link is a top-level link.

Remarks

This function will always return the id of a top-level link, or invalidElementId. Given the link structure A -> B -> C, then calling this function on C will return A's id. Call GetParentId to get B's id.

See Also

RevitLinkType Class


GetTopLevelLink Method

[image]

Revit 2013 API
RevitLinkType..::..GetTopLevelLink Method
RevitLinkType Class See Also Send Feedback
Returns the ElementId of the (top-level) linked model with the given path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ElementId GetTopLevelLink(
    Document document,
    ModelPath path
)
Visual Basic
Public Shared Function GetTopLevelLink ( _
    document As Document, _
    path As ModelPath _
) As ElementId
Visual C++
public:
static ElementId^ GetTopLevelLink(
    Document^ document,
    ModelPath^ path
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to look for the linked model in.
path
Type: Autodesk.Revit.DB..::..ModelPath
A path indicating which linked model to return.

Return Value

The id of the link with the given path, or invalidElementId if there is no top-level link at that path.

Remarks

This function will not return nested links.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RevitLinkType Class


IsLoaded Method

[image]

Revit 2013 API
RevitLinkType..::..IsLoaded Method
RevitLinkType Class See Also Send Feedback
Checks whether the link with this id is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsLoaded(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function IsLoaded ( _
    document As Document, _
    typeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsLoaded(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
A document. Revit will see if typeId corresponds to a loaded link in this document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
An element id. Revit will check if typeId corresponds to a loaded link in the given document.

Return Value

True if typeId corresponds to a loaded RevitLinkType. False otherwise.

Remarks

Returns false if typeId is not the id of a RevitLinkType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RevitLinkType Class


RevitLinkType Properties

[image] [image]

Revit 2013 API
RevitLinkType Properties
RevitLinkType Class See Also Send Feedback

The RevitLinkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AttachmentType | The attachment/overlay status of this link.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsNestedLink | Indicates whether this link is a nested or top-level link.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RevitLinkType Class


AttachmentType Property

[image]

Revit 2013 API
RevitLinkType..::..AttachmentType Property
RevitLinkType Class See Also Send Feedback
The attachment/overlay status of this link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AttachmentType AttachmentType { get; }
Visual Basic
Public ReadOnly Property AttachmentType As AttachmentType
    Get
Visual C++
public:
property AttachmentType AttachmentType {
    AttachmentType get ();
}

Field Value

AttachmentType.Overlay if this link is an overlay, AttachmentType.Attachment if this link is an attachment.

Remarks

"Attachment" links are considered to be part of their parent link and will be brought along if their parent is linked into another document. "Overlay" links are only visible when their parent is open directly. For example: A user has a file B which contains a link C, and they wish to link B into another file, A. If C is an overlay, C will not be loaded into A. If C is an attachment, then C will be loaded into A along with B.

See Also

RevitLinkType Class


IsNestedLink Property

[image]

Revit 2013 API
RevitLinkType..::..IsNestedLink Property
RevitLinkType Class See Also Send Feedback
Indicates whether this link is a nested or top-level link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsNestedLink { get; }
Visual Basic
Public ReadOnly Property IsNestedLink As Boolean
    Get
Visual C++
public:
property bool IsNestedLink {
    bool get ();
}

Field Value

True if this is a nested link (i.e. it has some other link as a parent), false if it's a top-level link.

See Also

RevitLinkType Class


Parameter Property

[image] [image]

Revit 2013 API
RevitLinkType..::..Parameter Property
RevitLinkType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RevitLinkType Class
RevitLinkType Members


Revolution Class

[image]

Revit 2013 API
Revolution Class
Members See Also Send Feedback
A revolution solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Revolution : GenericForm
Visual Basic
Public Class Revolution _
    Inherits GenericForm
Visual C++
public ref class Revolution : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Revolution

See Also

Revolution Members


Revolution Members

[image] [image]

Revit 2013 API
Revolution Members
Revolution Class Methods Properties See Also Send Feedback

The Revolution type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revolution Class


Revolution Methods

[image] [image]

Revit 2013 API
Revolution Methods
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Revolution Class


Revolution Properties

[image] [image]

Revit 2013 API
Revolution Properties
Revolution Class See Also Send Feedback

The Revolution type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Axis | Returns the Axis of the Revolution.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndAngle | The end angle of the revolution relative to the sketch plane.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Sketch | Returns the Sketch of the Revolution.
Public property | StartAngle | The start angle of the revolution relative to the sketch plane.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Revolution Class


Axis Property

[image]

Revit 2013 API
Revolution..::..Axis Property
Revolution Class See Also Send Feedback
Returns the Axis of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ModelLine Axis { get; }
Visual Basic
Public ReadOnly Property Axis As ModelLine
    Get
Visual C++
public:
property ModelLine^ Axis {
    ModelLine^ get ();
}

Remarks

This property is used to retrieve the Axis of the Revolution.

See Also

Revolution Class


EndAngle Property

[image]

Revit 2013 API
Revolution..::..EndAngle Property
Revolution Class See Also Send Feedback
The end angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double EndAngle { get; set; }
Visual Basic
Public Property EndAngle As Double
    Get
    Set
Visual C++
public:
property double EndAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


Parameter Property

[image] [image]

Revit 2013 API
Revolution..::..Parameter Property
Revolution Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Revolution Class
Revolution Members


Sketch Property

[image]

Revit 2013 API
Revolution..::..Sketch Property
Revolution Class See Also Send Feedback
Returns the Sketch of the Revolution.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch Sketch { get; }
Visual Basic
Public ReadOnly Property Sketch As Sketch
    Get
Visual C++
public:
property Sketch^ Sketch {
    Sketch^ get ();
}

Remarks

This property is used to retrieve the Sketch of the Revolution.

See Also

Revolution Class


StartAngle Property

[image]

Revit 2013 API
Revolution..::..StartAngle Property
Revolution Class See Also Send Feedback
The start angle of the revolution relative to the sketch plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StartAngle { get; set; }
Visual Basic
Public Property StartAngle As Double
    Get
    Set
Visual C++
public:
property double StartAngle {
    double get ();
    void set (double value);
}

Remarks

The direction of the angle is based on the normal of the sketch plane. A positive angle is on the same side as the normal, a negative angle on the opposite side.

See Also

Revolution Class


RevolvedFace Class

[image]

Revit 2013 API
RevolvedFace Class
Members Example See Also Send Feedback
A revolved face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RevolvedFace : Face
Visual Basic
Public Class RevolvedFace _
    Inherits Face
Visual C++
public ref class RevolvedFace : public Face

Remarks

Revolved faces are defined by revolved surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces. S(u, v) = Origin + Curve0(v)*cos(u)*Radius[0] + Curve0(v)*sin(u)*Radius[1] + Curve1(v)*Axis, where the profile curve has the parametric equation (Curve0(t), Curve1(t)).

Examples

CopyC#
private void GetRevolvedFaceInfo(Face face)
{
    RevolvedFace revolvedFace = face as RevolvedFace;
    if (null != revolvedFace)
    {
       XYZ origin = revolvedFace.Origin;
       XYZ axis = revolvedFace.Axis;
        Curve curve = revolvedFace.Curve;
        XYZ redius = revolvedFace.get_Radius(0);
    }
}
CopyVB.NET
Private Sub GetRevolvedFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace)
    If revolvedFace IsNot Nothing Then
        Dim origin As Autodesk.Revit.DB.XYZ = revolvedFace.Origin
        Dim axis As Autodesk.Revit.DB.XYZ = revolvedFace.Axis
        Dim curve As Curve = revolvedFace.Curve
        Dim redius As Autodesk.Revit.DB.XYZ = revolvedFace.Radius(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RevolvedFace

See Also

RevolvedFace Members


RevolvedFace Members

[image] [image]

Revit 2013 API
RevolvedFace Members
RevolvedFace Class Methods Properties See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


RevolvedFace Methods

[image] [image]

Revit 2013 API
RevolvedFace Methods
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class


Intersect Method

[image] [image]

Revit 2013 API
RevolvedFace..::..Intersect Method
RevolvedFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


IsInside Method

[image] [image]

Revit 2013 API
RevolvedFace..::..IsInside Method
RevolvedFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


Triangulate Method

[image] [image]

Revit 2013 API
RevolvedFace..::..Triangulate Method
RevolvedFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RevolvedFace Class
RevolvedFace Members


RevolvedFace Properties

[image] [image]

Revit 2013 API
RevolvedFace Properties
RevolvedFace Class See Also Send Feedback

The RevolvedFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Axis | Axis of the surface.
Public property | Curve | Profile curve of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Origin | Origin of the surface.
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Radius | Radius of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RevolvedFace Class


Axis Property

[image]

Revit 2013 API
RevolvedFace..::..Axis Property
RevolvedFace Class See Also Send Feedback
Axis of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Axis { get; }
Visual Basic
Public ReadOnly Property Axis As XYZ
    Get
Visual C++
public:
property XYZ^ Axis {
    XYZ^ get ();
}

See Also

RevolvedFace Class


Curve Property

[image]

Revit 2013 API
RevolvedFace..::..Curve Property
RevolvedFace Class See Also Send Feedback
Profile curve of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

RevolvedFace Class


Origin Property

[image]

Revit 2013 API
RevolvedFace..::..Origin Property
RevolvedFace Class See Also Send Feedback
Origin of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

See Also

RevolvedFace Class


Radius Property

[image]

Revit 2013 API
RevolvedFace..::..Radius Property
RevolvedFace Class See Also Send Feedback
Radius of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Radius ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Radius[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

RevolvedFace Class


RoofBase Class

[image]

Revit 2013 API
RoofBase Class
Members See Also Send Feedback
Represents all kinds of Roofs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoofBase : HostObject
Visual Basic
Public Class RoofBase _
    Inherits HostObject
Visual C++
public ref class RoofBase : public HostObject

Remarks

The RoofBase object represents all kinds of roof in Revit.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..RoofBase
Autodesk.Revit.DB..::..ExtrusionRoof
Autodesk.Revit.DB..::..FootPrintRoof

See Also

RoofBase Members


RoofBase Members

[image] [image]

Revit 2013 API
RoofBase Members
RoofBase Class Methods Properties See Also Send Feedback

The RoofBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofBase Class


RoofBase Methods

[image] [image]

Revit 2013 API
RoofBase Methods
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofBase Class


RoofBase Properties

[image] [image]

Revit 2013 API
RoofBase Properties
RoofBase Class See Also Send Feedback

The RoofBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EaveCuts | Retrieve or set the EaveCutterType.
Public property | FasciaDepth | Retrieve or set the FasciaDepth.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RoofType | Retrieve or set the Type.
Public property | SlabShapeEditor | Get the SlabShapeEditor used for slab shape editing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofBase Class


EaveCuts Property

[image]

Revit 2013 API
RoofBase..::..EaveCuts Property
RoofBase Class See Also Send Feedback
Retrieve or set the EaveCutterType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EaveCutterType EaveCuts { get; set; }
Visual Basic
Public Property EaveCuts As EaveCutterType
    Get
    Set
Visual C++
public:
property EaveCutterType EaveCuts {
    EaveCutterType get ();
    void set (EaveCutterType value);
}

See Also

RoofBase Class


FasciaDepth Property

[image]

Revit 2013 API
RoofBase..::..FasciaDepth Property
RoofBase Class See Also Send Feedback
Retrieve or set the FasciaDepth.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double FasciaDepth { get; set; }
Visual Basic
Public Property FasciaDepth As Double
    Get
    Set
Visual C++
public:
property double FasciaDepth {
    double get ();
    void set (double value);
}

Remarks

If the EaveCutterType is PlumbCut, this property doesn't make sense.

See Also

RoofBase Class


Parameter Property

[image] [image]

Revit 2013 API
RoofBase..::..Parameter Property
RoofBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoofBase Class
RoofBase Members


RoofType Property

[image]

Revit 2013 API
RoofBase..::..RoofType Property
RoofBase Class See Also Send Feedback
Retrieve or set the Type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoofType RoofType { get; set; }
Visual Basic
Public Property RoofType As RoofType
    Get
    Set
Visual C++
public:
property RoofType^ RoofType {
    RoofType^ get ();
    void set (RoofType^ value);
}

See Also

RoofBase Class


SlabShapeEditor Property

[image]

Revit 2013 API
RoofBase..::..SlabShapeEditor Property
RoofBase Class See Also Send Feedback
Get the SlabShapeEditor used for slab shape editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeEditor SlabShapeEditor { get; }
Visual Basic
Public ReadOnly Property SlabShapeEditor As SlabShapeEditor
    Get
Visual C++
public:
property SlabShapeEditor^ SlabShapeEditor {
    SlabShapeEditor^ get ();
}

Remarks

Roofs cannot be attached to another roof, and the roof cannot be a curtain roof. If either of these conditions is not met, the ShapeEditor will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RoofBase Class


RoofType Class

[image]

Revit 2013 API
RoofType Class
Members See Also Send Feedback
Represents a specific type of roof.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoofType : HostObjAttributes
Visual Basic
Public Class RoofType _
    Inherits HostObjAttributes
Visual C++
public ref class RoofType : public HostObjAttributes

Remarks

All roof type objects available in the project can be retrieved from the Document object via the RoofTypes property. Every Roof object has a RoofType property that returns a RoofType object representing the type. This same RoofType property can also be used to change the type of the roof by setting it to a different type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..RoofType

See Also

RoofType Members


RoofType Members

[image] [image]

Revit 2013 API
RoofType Members
RoofType Class Methods Properties See Also Send Feedback

The RoofType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofType Class


RoofType Methods

[image] [image]

Revit 2013 API
RoofType Methods
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofType Class


RoofType Properties

[image] [image]

Revit 2013 API
RoofType Properties
RoofType Class See Also Send Feedback

The RoofType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the RoofType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoofType Class


Parameter Property

[image] [image]

Revit 2013 API
RoofType..::..Parameter Property
RoofType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoofType Class
RoofType Members


ThermalProperties Property

[image]

Revit 2013 API
RoofType..::..ThermalProperties Property
RoofType Class See Also Send Feedback
The calculated and settable thermal properties of the RoofType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the roof has no thermal properties. Curtain roofs do not store thermal properties.

See Also

RoofType Class


RoofTypeSet Class

[image]

Revit 2013 API
RoofTypeSet Class
Members See Also Send Feedback
A set that contains roof types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoofTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RoofTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoofTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..RoofTypeSet

See Also

RoofTypeSet Members


RoofTypeSet Members

[image] [image]

Revit 2013 API
RoofTypeSet Members
RoofTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RoofTypeSet | Initializes a new instance of the RoofTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class


RoofTypeSet Constructor

[image]

Revit 2013 API
RoofTypeSet Constructor
RoofTypeSet Class See Also Send Feedback
Initializes a new instance of the RoofTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoofTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
RoofTypeSet()

See Also

RoofTypeSet Class


RoofTypeSet Methods

[image] [image]

Revit 2013 API
RoofTypeSet Methods
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every roof type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a roof type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified roof type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified roof type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSet Class


Clear Method

[image]

Revit 2013 API
RoofTypeSet..::..Clear Method
RoofTypeSet Class See Also Send Feedback
Removes every roof type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoofTypeSet Class


Contains Method

[image]

Revit 2013 API
RoofTypeSet..::..Contains Method
RoofTypeSet Class See Also Send Feedback
Tests for the existence of a roof type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RoofType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..RoofType
The roof type to be searched for.

Return Value

The Contains method returns True if the roof type is within the set, otherwise False.

See Also

RoofTypeSet Class


Erase Method

[image]

Revit 2013 API
RoofTypeSet..::..Erase Method
RoofTypeSet Class See Also Send Feedback
Removes a specified roof type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RoofType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RoofType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..RoofType
The roof type to be erased.

Return Value

The number of roof types that were erased from the set.

See Also

RoofTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
RoofTypeSet..::..ForwardIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoofTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
RoofTypeSet..::..GetEnumerator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RoofTypeSet Class


Insert Method

[image]

Revit 2013 API
RoofTypeSet..::..Insert Method
RoofTypeSet Class See Also Send Feedback
Insert the specified roof type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RoofType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RoofType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoofType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..RoofType
The roof type to be inserted into the set.

Return Value

Returns whether the roof type was inserted into the set.

See Also

RoofTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
RoofTypeSet..::..ReverseIterator Method
RoofTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RoofTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RoofTypeSetIterator
Visual C++
public:
virtual RoofTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoofTypeSet Class


RoofTypeSet Properties

[image] [image]

Revit 2013 API
RoofTypeSet Properties
RoofTypeSet Class See Also Send Feedback

The RoofTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of roof types that are in the set.

See Also

RoofTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
RoofTypeSet..::..IsEmpty Property
RoofTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoofTypeSet Class


Size Property

[image]

Revit 2013 API
RoofTypeSet..::..Size Property
RoofTypeSet Class See Also Send Feedback
Returns the number of roof types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoofTypeSet Class


RoofTypeSetIterator Class

[image]

Revit 2013 API
RoofTypeSetIterator Class
Members See Also Send Feedback
An iterator to a roof type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RoofTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RoofTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoofTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..RoofTypeSetIterator

See Also

RoofTypeSetIterator Members


RoofTypeSetIterator Members

[image] [image]

Revit 2013 API
RoofTypeSetIterator Members
RoofTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RoofTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Constructor

[image]

Revit 2013 API
RoofTypeSetIterator Constructor
RoofTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoofTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RoofTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Methods

[image] [image]

Revit 2013 API
RoofTypeSetIterator Methods
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoofTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
RoofTypeSetIterator..::..MoveNext Method
RoofTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
RoofTypeSetIterator..::..Reset Method
RoofTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoofTypeSetIterator Class


RoofTypeSetIterator Properties

[image] [image]

Revit 2013 API
RoofTypeSetIterator Properties
RoofTypeSetIterator Class See Also Send Feedback

The RoofTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoofTypeSetIterator Class


Current Property

[image]

Revit 2013 API
RoofTypeSetIterator..::..Current Property
RoofTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoofTypeSetIterator Class


RoutingCondition Class

[image]

Revit 2013 API
RoutingCondition Class
Members See Also Send Feedback
RoutingCondition represents routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met. inhouse RoutingCondition is a data container that includes the routing information such as size, profile shape, connection type, and etc. Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingCondition : IDisposable
Visual Basic
Public Class RoutingCondition _
    Implements IDisposable
Visual C++
public ref class RoutingCondition : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCondition

See Also

RoutingCondition Members


RoutingCondition Members

[image] [image]

Revit 2013 API
RoutingCondition Members
RoutingCondition Class Constructors Methods Properties See Also Send Feedback

The RoutingCondition type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingCondition | Initializes a new instance of the RoutingCondition class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCondition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition. inhouse Returns zero for non-round profiles (not fully supported yet).

See Also

RoutingCondition Class


RoutingCondition Constructor

[image]

Revit 2013 API
RoutingCondition Constructor
RoutingCondition Class See Also Send Feedback
Initializes a new instance of the RoutingCondition class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoutingCondition(
    double diameter
)
Visual Basic
Public Sub New ( _
    diameter As Double _
)
Visual C++
public:
RoutingCondition(
    double diameter
)

Parameters

diameter
Type: System..::..Double

See Also

RoutingCondition Class


RoutingCondition Methods

[image] [image]

Revit 2013 API
RoutingCondition Methods
RoutingCondition Class See Also Send Feedback

The RoutingCondition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingCondition Class


Dispose Method

[image]

Revit 2013 API
RoutingCondition..::..Dispose Method
RoutingCondition Class See Also Send Feedback
Releases all resources used by the RoutingCondition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingCondition Class


RoutingCondition Properties

[image] [image]

Revit 2013 API
RoutingCondition Properties
RoutingCondition Class See Also Send Feedback

The RoutingCondition type exposes the following members.

Properties

 | Name | Description
Public property | Diameter | The diameter of the segment or fitting specified for the routing condition. inhouse Returns zero for non-round profiles (not fully supported yet).

See Also

RoutingCondition Class


Diameter Property

[image]

Revit 2013 API
RoutingCondition..::..Diameter Property
RoutingCondition Class See Also Send Feedback
The diameter of the segment or fitting specified for the routing condition. inhouse Returns zero for non-round profiles (not fully supported yet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Diameter { get; }
Visual Basic
Public ReadOnly Property Diameter As Double
    Get
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

RoutingCondition Class


RoutingConditions Class

[image]

Revit 2013 API
RoutingConditions Class
Members See Also Send Feedback
RoutingConditions contain routing information that is used as input when determining if a routing criterion, such as minimum or maximum diameter, is met. inhouse RoutingConditions is a collection of RoutingCondition data, each of them typically represents routing information on one connector. inhouse The class is passed into the routing preference manager in order to retrieve an appropriate part. inhouse For example: inhouse RoutingConditions myConditions; inhouse myConditions.appendCondition( RoutingCondition(dDiameter) ); // The array must have a primary condition inhouse myConditions.appendCondition( RoutingCondition(dDiameter2) ); // The array may have more conditions inhouse ElementId myPart = pRPM->getMEPPartId(myGroupType, myConditions); Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingConditions : IDisposable
Visual Basic
Public Class RoutingConditions _
    Implements IDisposable
Visual C++
public ref class RoutingConditions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingConditions

See Also

RoutingConditions Members


RoutingConditions Members

[image] [image]

Revit 2013 API
RoutingConditions Members
RoutingConditions Class Constructors Methods Properties See Also Send Feedback

The RoutingConditions type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingConditions | Initializes a new instance of the RoutingConditions class

Methods

 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose | Releases all resources used by the RoutingConditions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfConditions | Gets the number of included routing conditions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

See Also

RoutingConditions Class


RoutingConditions Constructor

[image]

Revit 2013 API
RoutingConditions Constructor
RoutingConditions Class See Also Send Feedback
Initializes a new instance of the RoutingConditions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)
Visual Basic
Public Sub New ( _
    errorLevel As RoutingPreferenceErrorLevel _
)
Visual C++
public:
RoutingConditions(
    RoutingPreferenceErrorLevel errorLevel
)

Parameters

errorLevel
Type: Autodesk.Revit.DB..::..RoutingPreferenceErrorLevel

See Also

RoutingConditions Class


RoutingConditions Methods

[image] [image]

Revit 2013 API
RoutingConditions Methods
RoutingConditions Class See Also Send Feedback

The RoutingConditions type exposes the following members.

Methods

 | Name | Description
Public method | AppendCondition | Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.
Public method | Clear | Clear all existing conditions
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConditionAt | Gets the routing condition at the specified index position.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfConditions | Gets the number of included routing conditions.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingConditions Class


AppendCondition Method

[image]

Revit 2013 API
RoutingConditions..::..AppendCondition Method
RoutingConditions Class See Also Send Feedback
Appends a routing condition to the end of existing routing conditions. Note that the first item (indexed at 0) is the condition for the primary connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AppendCondition(
    RoutingCondition condition
)
Visual Basic
Public Sub AppendCondition ( _
    condition As RoutingCondition _
)
Visual C++
public:
void AppendCondition(
    RoutingCondition^ condition
)

Parameters

condition
Type: Autodesk.Revit.DB..::..RoutingCondition

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


Clear Method

[image]

Revit 2013 API
RoutingConditions..::..Clear Method
RoutingConditions Class See Also Send Feedback
Clear all existing conditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


Dispose Method

[image]

Revit 2013 API
RoutingConditions..::..Dispose Method
RoutingConditions Class See Also Send Feedback
Releases all resources used by the RoutingConditions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingConditions Class


GetConditionAt Method

[image]

Revit 2013 API
RoutingConditions..::..GetConditionAt Method
RoutingConditions Class See Also Send Feedback
Gets the routing condition at the specified index position.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingCondition GetConditionAt(
    int index
)
Visual Basic
Public Function GetConditionAt ( _
    index As Integer _
) As RoutingCondition
Visual C++
public:
RoutingCondition^ GetConditionAt(
    int index
)

Parameters

index
Type: System..::..Int32
The 0-based index to access the collection of available conditions. The method throws the exception ArgumentOutOfRangeException if the index is out of range.

Return Value

The found routing condition.

See Also

RoutingConditions Class


GetNumberOfConditions Method

[image]

Revit 2013 API
RoutingConditions..::..GetNumberOfConditions Method
RoutingConditions Class See Also Send Feedback
Gets the number of included routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetNumberOfConditions()
Visual Basic
Public Function GetNumberOfConditions As Integer
Visual C++
public:
int GetNumberOfConditions()

See Also

RoutingConditions Class


RoutingConditions Properties

[image] [image]

Revit 2013 API
RoutingConditions Properties
RoutingConditions Class See Also Send Feedback

The RoutingConditions type exposes the following members.

Properties

 | Name | Description
Public property | ErrorLevel | The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error
Public property | PreferredJunctionType | The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

See Also

RoutingConditions Class


ErrorLevel Property

[image]

Revit 2013 API
RoutingConditions..::..ErrorLevel Property
RoutingConditions Class See Also Send Feedback
The error level that the routing preference manager should post errors if the routing conditions do not meet any routing preference rule, could be None, Warning, or Error

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingPreferenceErrorLevel ErrorLevel { get; set; }
Visual Basic
Public Property ErrorLevel As RoutingPreferenceErrorLevel
    Get
    Set
Visual C++
public:
property RoutingPreferenceErrorLevel ErrorLevel {
    RoutingPreferenceErrorLevel get ();
    void set (RoutingPreferenceErrorLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


PreferredJunctionType Property

[image]

Revit 2013 API
RoutingConditions..::..PreferredJunctionType Property
RoutingConditions Class See Also Send Feedback
The junction type (Tee or Tap) to select if defined fittings of both junction types meet all routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingConditions Class


RoutingCriterionBase Class

[image]

Revit 2013 API
RoutingCriterionBase Class
Members See Also Send Feedback
RoutingCriteriaBase is the base class for all routing criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingCriterionBase : IDisposable
Visual Basic
Public Class RoutingCriterionBase _
    Implements IDisposable
Visual C++
public ref class RoutingCriterionBase : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingCriterionBase
Autodesk.Revit.DB..::..PrimarySizeCriterion

See Also

RoutingCriterionBase Members


RoutingCriterionBase Members

[image] [image]

Revit 2013 API
RoutingCriterionBase Members
RoutingCriterionBase Class Methods See Also Send Feedback

The RoutingCriterionBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RoutingCriterionBase
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingCriterionBase Class


RoutingCriterionBase Methods

[image] [image]

Revit 2013 API
RoutingCriterionBase Methods
RoutingCriterionBase Class See Also Send Feedback

The RoutingCriterionBase type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Verify if two criteria are the same.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingCriterionBase Class


Dispose Method

[image]

Revit 2013 API
RoutingCriterionBase..::..Dispose Method
RoutingCriterionBase Class See Also Send Feedback
Releases all resources used by the RoutingCriterionBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingCriterionBase Class


IsEqual Method

[image]

Revit 2013 API
RoutingCriterionBase..::..IsEqual Method
RoutingCriterionBase Class See Also Send Feedback
Verify if two criteria are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsEqual(
    RoutingCriterionBase pOther
)
Visual Basic
Public Function IsEqual ( _
    pOther As RoutingCriterionBase _
) As Boolean
Visual C++
public:
bool IsEqual(
    RoutingCriterionBase^ pOther
)

Parameters

pOther
Type: Autodesk.Revit.DB..::..RoutingCriterionBase

Return Value

True if the criterion is equal to the other, false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RoutingCriterionBase Class


RoutingPreferenceErrorLevel Enumeration

[image]

Revit 2013 API
RoutingPreferenceErrorLevel Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum RoutingPreferenceErrorLevel
Visual Basic
Public Enumeration RoutingPreferenceErrorLevel
Visual C++
public enum class RoutingPreferenceErrorLevel

Members

Member name | Description
None | Do not post any warning or error if there is no rule in the routing preference satisfying the current condition.
Warning | Post Revit warnings if there is no rule in the routing preference satisfying the current condition.
Error | Post Revit errors if there is no rule in the routing preference satisfying the current condition.

See Also


RoutingPreferenceManager Class

[image]

Revit 2013 API
RoutingPreferenceManager Class
Members See Also Send Feedback
Manages default pipe segments, fittings, and selection criteria for a given MEPCurveType Default constructor. Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingPreferenceManager : IDisposable
Visual Basic
Public Class RoutingPreferenceManager _
    Implements IDisposable
Visual C++
public ref class RoutingPreferenceManager : IDisposable

Remarks

MEPCurveTypes contain a RoutingPreferenceManager property. The RoutingPreferenceManager contains rules for selecting segment types and sizes as well as fitting types based on user selection criteria.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingPreferenceManager

See Also

RoutingPreferenceManager Members


RoutingPreferenceManager Members

[image] [image]

Revit 2013 API
RoutingPreferenceManager Members
RoutingPreferenceManager Class Methods Properties See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose | Releases all resources used by the RoutingPreferenceManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.

See Also

RoutingPreferenceManager Class


RoutingPreferenceManager Methods

[image] [image]

Revit 2013 API
RoutingPreferenceManager Methods
RoutingPreferenceManager Class See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Methods

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMEPPartId | Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.
Public method | GetNumberOfRules | The number of RoutingPreference rules in a group.
Public method | GetRule | Gets the specified rule.
Public method | GetSharedSizes | Gets a list of all segments of a given profile shape that define a given size.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveRule | Removes an existing routing preference rule. Thrown if the index is out of bounds.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingPreferenceManager Class


AddRule Method

[image] [image]

Revit 2013 API
RoutingPreferenceManager..::..AddRule Method
RoutingPreferenceManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule) | Adds a new routing preference rule to the rule group.
Public method | AddRule(RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32) | Adds a new routing preference rule to the specified position in the rule group.

See Also

RoutingPreferenceManager Class
RoutingPreferenceManager Members


AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule)

[image]

Revit 2013 API
RoutingPreferenceManager..::..AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule)
RoutingPreferenceManager Class See Also Send Feedback
Adds a new routing preference rule to the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule
)
Visual Basic
Public Sub AddRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    rule As RoutingPreferenceRule _
)
Visual C++
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group in which the rule should be added.
rule
Type: Autodesk.Revit.DB..::..RoutingPreferenceRule
The new rule to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class
AddRule Overload


AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32)

[image]

Revit 2013 API
RoutingPreferenceManager..::..AddRule Method (RoutingPreferenceRuleGroupType, RoutingPreferenceRule, Int32)
RoutingPreferenceManager Class See Also Send Feedback
Adds a new routing preference rule to the specified position in the rule group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule rule,
    int index
)
Visual Basic
Public Sub AddRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    rule As RoutingPreferenceRule, _
    index As Integer _
)
Visual C++
public:
void AddRule(
    RoutingPreferenceRuleGroupType groupType,
    RoutingPreferenceRule^ rule,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be added.
rule
Type: Autodesk.Revit.DB..::..RoutingPreferenceRule
The new rule to be added.
index
Type: System..::..Int32
The zero-based index position where the new rule will be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or- The rule cannot be added to the groupType. -or- Thrown if the index is out of bounds, or the rule is not valid for this group (e.g. an elbow may not be added to the junction group).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class
AddRule Overload


Dispose Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..Dispose Method
RoutingPreferenceManager Class See Also Send Feedback
Releases all resources used by the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingPreferenceManager Class


GetMEPPartId Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..GetMEPPartId Method
RoutingPreferenceManager Class See Also Send Feedback
Gets a fitting or segment id of given routing preference group that meets the specified routing conditions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions conditions
)
Visual Basic
Public Function GetMEPPartId ( _
    groupType As RoutingPreferenceRuleGroupType, _
    conditions As RoutingConditions _
) As ElementId
Visual C++
public:
ElementId^ GetMEPPartId(
    RoutingPreferenceRuleGroupType groupType,
    RoutingConditions^ conditions
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group
conditions
Type: Autodesk.Revit.DB..::..RoutingConditions
A set of routing conditions

Return Value

The Id of the fitting or segment that met the given routing conditions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RoutingPreferenceManager Class


GetNumberOfRules Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..GetNumberOfRules Method
RoutingPreferenceManager Class See Also Send Feedback
The number of RoutingPreference rules in a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetNumberOfRules(
    RoutingPreferenceRuleGroupType eGroupType
)
Visual Basic
Public Function GetNumberOfRules ( _
    eGroupType As RoutingPreferenceRuleGroupType _
) As Integer
Visual C++
public:
int GetNumberOfRules(
    RoutingPreferenceRuleGroupType eGroupType
)

Parameters

eGroupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType

See Also

RoutingPreferenceManager Class


GetRule Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..GetRule Method
RoutingPreferenceManager Class See Also Send Feedback
Gets the specified rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingPreferenceRule GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Visual Basic
Public Function GetRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    index As Integer _
) As RoutingPreferenceRule
Visual C++
public:
RoutingPreferenceRule^ GetRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type from which the rule should be returned.
index
Type: System..::..Int32
The zero-based index where the rule should be returned.

Return Value

The rule at the specified group and zero-based index position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or- Thrown if the index is out of bounds

See Also

RoutingPreferenceManager Class


GetSharedSizes Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..GetSharedSizes Method
RoutingPreferenceManager Class See Also Send Feedback
Gets a list of all segments of a given profile shape that define a given size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetSharedSizes(
    double size,
    ConnectorProfileType shape
)
Visual Basic
Public Function GetSharedSizes ( _
    size As Double, _
    shape As ConnectorProfileType _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSharedSizes(
    double size,
    ConnectorProfileType shape
)

Parameters

size
Type: System..::..Double
The size to search for.
shape
Type: Autodesk.Revit.DB..::..ConnectorProfileType
The profile shape of segment object.

Return Value

A list of all segments that define a given size.

See Also

RoutingPreferenceManager Class


RemoveRule Method

[image]

Revit 2013 API
RoutingPreferenceManager..::..RemoveRule Method
RoutingPreferenceManager Class See Also Send Feedback
Removes an existing routing preference rule. Thrown if the index is out of bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)
Visual Basic
Public Sub RemoveRule ( _
    groupType As RoutingPreferenceRuleGroupType, _
    index As Integer _
)
Visual C++
public:
void RemoveRule(
    RoutingPreferenceRuleGroupType groupType,
    int index
)

Parameters

groupType
Type: Autodesk.Revit.DB..::..RoutingPreferenceRuleGroupType
The routing preference group type in which the rule should be removed.
index
Type: System..::..Int32
The index position of removed routing preference rule in the group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index within groupType. -or-
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class


RoutingPreferenceManager Properties

[image] [image]

Revit 2013 API
RoutingPreferenceManager Properties
RoutingPreferenceManager Class See Also Send Feedback

The RoutingPreferenceManager type exposes the following members.

Properties

 | Name | Description
Public property | OwnerId | The Id of the MEPCurveType that owns the RoutingPreferenceManager
Public property | PreferredJunctionType | The preferred junction type.

See Also

RoutingPreferenceManager Class


OwnerId Property

[image]

Revit 2013 API
RoutingPreferenceManager..::..OwnerId Property
RoutingPreferenceManager Class See Also Send Feedback
The Id of the MEPCurveType that owns the RoutingPreferenceManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}

See Also

RoutingPreferenceManager Class


PreferredJunctionType Property

[image]

Revit 2013 API
RoutingPreferenceManager..::..PreferredJunctionType Property
RoutingPreferenceManager Class See Also Send Feedback
The preferred junction type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PreferredJunctionType PreferredJunctionType { get; set; }
Visual Basic
Public Property PreferredJunctionType As PreferredJunctionType
    Get
    Set
Visual C++
public:
property PreferredJunctionType PreferredJunctionType {
    PreferredJunctionType get ();
    void set (PreferredJunctionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceManager Class


RoutingPreferenceRule Class

[image]

Revit 2013 API
RoutingPreferenceRule Class
Members See Also Send Feedback
Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RoutingPreferenceRule : IDisposable
Visual Basic
Public Class RoutingPreferenceRule _
    Implements IDisposable
Visual C++
public ref class RoutingPreferenceRule : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..RoutingPreferenceRule

See Also

RoutingPreferenceRule Members


RoutingPreferenceRule Members

[image] [image]

Revit 2013 API
RoutingPreferenceRule Members
RoutingPreferenceRule Class Constructors Methods Properties See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Constructors

 | Name | Description
Public method | RoutingPreferenceRule | Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose | Releases all resources used by the RoutingPreferenceRule
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Constructor

[image]

Revit 2013 API
RoutingPreferenceRule Constructor
RoutingPreferenceRule Class See Also Send Feedback
Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingPreferenceRule(
    ElementId MEPPartId,
    string description
)
Visual Basic
Public Sub New ( _
    MEPPartId As ElementId, _
    description As String _
)
Visual C++
public:
RoutingPreferenceRule(
    ElementId^ MEPPartId,
    String^ description
)

Parameters

MEPPartId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the segment or fitting. InvalidElementId may be specified if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
description
Type: System..::..String
The description of the rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Methods

[image] [image]

Revit 2013 API
RoutingPreferenceRule Methods
RoutingPreferenceRule Class See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Methods

 | Name | Description
Public method | AddCriterion | Adds a new routing criterion.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCriterion | Gets the specified criteria.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveCriteron | Removes an existing criterion.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoutingPreferenceRule Class


AddCriterion Method

[image]

Revit 2013 API
RoutingPreferenceRule..::..AddCriterion Method
RoutingPreferenceRule Class See Also Send Feedback
Adds a new routing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddCriterion(
    RoutingCriterionBase myCriterion
)
Visual Basic
Public Sub AddCriterion ( _
    myCriterion As RoutingCriterionBase _
)
Visual C++
public:
void AddCriterion(
    RoutingCriterionBase^ myCriterion
)

Parameters

myCriterion
Type: Autodesk.Revit.DB..::..RoutingCriterionBase
The criterion to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceRule Class


Dispose Method

[image]

Revit 2013 API
RoutingPreferenceRule..::..Dispose Method
RoutingPreferenceRule Class See Also Send Feedback
Releases all resources used by the RoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RoutingPreferenceRule Class


GetCriterion Method

[image]

Revit 2013 API
RoutingPreferenceRule..::..GetCriterion Method
RoutingPreferenceRule Class See Also Send Feedback
Gets the specified criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingCriterionBase GetCriterion(
    int index
)
Visual Basic
Public Function GetCriterion ( _
    index As Integer _
) As RoutingCriterionBase
Visual C++
public:
RoutingCriterionBase^ GetCriterion(
    int index
)

Parameters

index
Type: System..::..Int32

Return Value

The criterion at the specified zero-based index position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index. -or- Thrown if the index is out of bounds.

See Also

RoutingPreferenceRule Class


RemoveCriteron Method

[image]

Revit 2013 API
RoutingPreferenceRule..::..RemoveCriteron Method
RoutingPreferenceRule Class See Also Send Feedback
Removes an existing criterion.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveCriteron(
    int index
)
Visual Basic
Public Sub RemoveCriteron ( _
    index As Integer _
)
Visual C++
public:
void RemoveCriteron(
    int index
)

Parameters

index
Type: System..::..Int32
The index position of removed routing preference rule in the group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not a valid zero-based index. -or- Thrown if the index is out of bounds.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

RoutingPreferenceRule Class


RoutingPreferenceRule Properties

[image] [image]

Revit 2013 API
RoutingPreferenceRule Properties
RoutingPreferenceRule Class See Also Send Feedback

The RoutingPreferenceRule type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description of the routing preference rule.
Public property | MEPPartId | The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public property | NumberOfCriteria | Gets the number of routing criteria.
Public property | RoutingPreferenceManager | Gets the routing preference manager that owns this rule.

See Also

RoutingPreferenceRule Class


Description Property

[image]

Revit 2013 API
RoutingPreferenceRule..::..Description Property
RoutingPreferenceRule Class See Also Send Feedback
The description of the routing preference rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

RoutingPreferenceRule Class


MEPPartId Property

[image]

Revit 2013 API
RoutingPreferenceRule..::..MEPPartId Property
RoutingPreferenceRule Class See Also Send Feedback
The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MEPPartId { get; }
Visual Basic
Public ReadOnly Property MEPPartId As ElementId
    Get
Visual C++
public:
property ElementId^ MEPPartId {
    ElementId^ get ();
}

See Also

RoutingPreferenceRule Class


NumberOfCriteria Property

[image]

Revit 2013 API
RoutingPreferenceRule..::..NumberOfCriteria Property
RoutingPreferenceRule Class See Also Send Feedback
Gets the number of routing criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfCriteria { get; }
Visual Basic
Public ReadOnly Property NumberOfCriteria As Integer
    Get
Visual C++
public:
property int NumberOfCriteria {
    int get ();
}

See Also

RoutingPreferenceRule Class


RoutingPreferenceManager Property

[image]

Revit 2013 API
RoutingPreferenceRule..::..RoutingPreferenceManager Property
RoutingPreferenceRule Class See Also Send Feedback
Gets the routing preference manager that owns this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RoutingPreferenceManager RoutingPreferenceManager { get; }
Visual Basic
Public ReadOnly Property RoutingPreferenceManager As RoutingPreferenceManager
    Get
Visual C++
public:
property RoutingPreferenceManager^ RoutingPreferenceManager {
    RoutingPreferenceManager^ get ();
}

See Also

RoutingPreferenceRule Class


RoutingPreferenceRuleGroupType Enumeration

[image]

Revit 2013 API
RoutingPreferenceRuleGroupType Enumeration
See Also Send Feedback
Add more rule group type here.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum RoutingPreferenceRuleGroupType
Visual Basic
Public Enumeration RoutingPreferenceRuleGroupType
Visual C++
public enum class RoutingPreferenceRuleGroupType

Members

Member name | Description
Undefined | The undefined group type, the default initial value.
Segments | The segment types (e.g. pipe stocks)
Elbows | The elbow types.
Junctions | The junction types (e.g. takeoff, tee, wye, tap).
Crosses | The cross types.
Transitions | The transition types (Note that the multi-shape transitions may have their own groups).
Unions | The union types that connect two segments together.
MechanicalJoints | The mechanical joint types that connect fitting to fitting, segment to fitting, or segment to segment.
TransitionsRectangularToRound | The multi-shape transition from the rectangular profile to the round profile.
TransitionsRectangularToOval | The multi-shape transition from the rectangular profile to the oval profile.
TransitionsOvalToRound | The multi-shape transition from the oval profile to the round profile.

See Also


RuledFace Class

[image]

Revit 2013 API
RuledFace Class
Members Example See Also Send Feedback
A ruled face of a 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RuledFace : Face
Visual Basic
Public Class RuledFace _
    Inherits Face
Visual C++
public ref class RuledFace : public Face

Remarks

Ruled faces are defined by ruled surfaces bounded by edge loops. The surfaces provide natural UV parameterization to the faces.

Examples

CopyC#
private void GetRuledFaceInfo(Face face)
{
    RuledFace ruledFace = face as RuledFace;
    if (null != ruledFace)
    {
        Curve curve = ruledFace.get_Curve(0);
        XYZ point = ruledFace.get_Point(0);
    }
}
CopyVB.NET
Private Sub GetRuledFaceInfo(ByVal face As Autodesk.Revit.DB.Face)
    Dim ruledFace As RuledFace = TryCast(face, RuledFace)
    If ruledFace IsNot Nothing Then
        Dim curve As Curve = ruledFace.Curve(0)
        Dim point As Autodesk.Revit.DB.XYZ = ruledFace.Point(0)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RuledFace

See Also

RuledFace Members


RuledFace Members

[image] [image]

Revit 2013 API
RuledFace Members
RuledFace Class Methods Properties See Also Send Feedback

The RuledFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


RuledFace Methods

[image] [image]

Revit 2013 API
RuledFace Methods
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Methods

 | Name | Description
Public method | ComputeDerivatives | Returns the vectors describing the face at the specified point. (Inherited from Face.)
Public method | ComputeNormal | Returns the normal vector for the face at the given point. (Inherited from Face.)
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | Evaluate | Evaluates parameters on the face. (Inherited from Face.)
Public method | GetBoundingBox | Returns the UV bounding box of the face. (Inherited from Face.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetRegions | Face regions (created with the Split Face command) of the face. (Inherited from Face.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)
Public method | Project | Projects the specified point on this face. (Inherited from Face.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RuledFace Class


Intersect Method

[image] [image]

Revit 2013 API
RuledFace..::..Intersect Method
RuledFace Class See Also Send Feedback
Calculates the intersection of the specified curve with this face.

Overload List

 | Name | Description
Public method | Intersect(Curve) | Calculates the intersection of the specified curve with this face. (Inherited from Face.)
Public method | Intersect(Curve, IntersectionResultArray%) | Calculates the intersection of the specified curve with this face and returns the intersection results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


IsInside Method

[image] [image]

Revit 2013 API
RuledFace..::..IsInside Method
RuledFace Class See Also Send Feedback
Indicates whether the specified point is within this face.

Overload List

 | Name | Description
Public method | IsInside(UV) | Indicates whether the specified point is within this face. (Inherited from Face.)
Public method | IsInside(UV, IntersectionResult%) | Indicates whether the specified point is within this face and outputs additional results. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


Triangulate Method

[image] [image]

Revit 2013 API
RuledFace..::..Triangulate Method
RuledFace Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Triangulate()()()() | Returns a triangular mesh approximation to the face. (Inherited from Face.)
Public method | Triangulate(Double) | Returns a triangular mesh approximation to the face. (Inherited from Face.)

See Also

RuledFace Class
RuledFace Members


RuledFace Properties

[image] [image]

Revit 2013 API
RuledFace Properties
RuledFace Class See Also Send Feedback

The RuledFace type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area of this face. (Inherited from Face.)
Public property | Curve | Profile curves of the surface.
Public property | EdgeLoops | Each edge loop is a closed boundary of the face. (Inherited from Face.)
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | HasRegions | Reports if the face contains regions created with the Split Face command. (Inherited from Face.)
Public property | IsCyclic | The boolean value that indicates whether this face is periodic in the specified parametric direction. (Inherited from Face.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTwoSided | Determines if a face is two-sided (degenerate); (Inherited from Face.)
Public property | MaterialElementId | Element ID of the material from which this face is composed. (Inherited from Face.)
Public property | Period | The period of this face in the specified parametric direction. (Inherited from Face.)
Public property | Point | Profile points of the surface.
Public property | Reference | Returns a stable reference to the face. (Inherited from Face.)
Public property | Visibility | The visibility. (Inherited from GeometryObject.)

See Also

RuledFace Class


Curve Property

[image]

Revit 2013 API
RuledFace..::..Curve Property
RuledFace Class See Also Send Feedback
Profile curves of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Curve ( _
    index As Integer _
) As Curve
    Get
Visual C++
public:
property Curve^ Curve[int index] {
    Curve^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

RuledFace Class


Point Property

[image]

Revit 2013 API
RuledFace..::..Point Property
RuledFace Class See Also Send Feedback
Profile points of the surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

RuledFace Class


SATExportOptions Class

[image]

Revit 2013 API
SATExportOptions Class
Members See Also Send Feedback
Export options specific to AutoCAD file formats.
SAT Export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SATExportOptions : CADExportOptions
Visual Basic
Public Class SATExportOptions _
    Inherits CADExportOptions
Visual C++
public ref class SATExportOptions : public CADExportOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..CADExportOptions
Autodesk.Revit.DB..::..SATExportOptions

See Also

SATExportOptions Members


SATExportOptions Members

[image] [image]

Revit 2013 API
SATExportOptions Members
SATExportOptions Class Constructors Methods See Also Send Feedback

The SATExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SATExportOptions | Default constructor. Sets all options to their default values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SATExportOptions Class


SATExportOptions Constructor

[image]

Revit 2013 API
SATExportOptions Constructor
SATExportOptions Class See Also Send Feedback
Default constructor. Sets all options to their default values.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SATExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
SATExportOptions()

See Also

SATExportOptions Class


SATExportOptions Methods

[image] [image]

Revit 2013 API
SATExportOptions Methods
SATExportOptions Class See Also Send Feedback

The SATExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SATExportOptions Class


SaveAsOptions Class

[image]

Revit 2013 API
SaveAsOptions Class
Members See Also Send Feedback
This class contains options available for saving a document to disk with a new filename.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SaveAsOptions : IDisposable
Visual Basic
Public Class SaveAsOptions _
    Implements IDisposable
Visual C++
public ref class SaveAsOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SaveAsOptions

See Also

SaveAsOptions Members


SaveAsOptions Members

[image] [image]

Revit 2013 API
SaveAsOptions Members
SaveAsOptions Class Constructors Methods Properties See Also Send Feedback

The SaveAsOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveAsOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveAsOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Public property | Rename | Identifies if the operation should rename the saved document, or save a copy.

See Also

SaveAsOptions Class


SaveAsOptions Constructor

[image]

Revit 2013 API
SaveAsOptions Constructor
SaveAsOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SaveAsOptions()
Visual Basic
Public Sub New
Visual C++
public:
SaveAsOptions()

See Also

SaveAsOptions Class


SaveAsOptions Methods

[image] [image]

Revit 2013 API
SaveAsOptions Methods
SaveAsOptions Class See Also Send Feedback

The SaveAsOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveAsOptions Class


Dispose Method

[image]

Revit 2013 API
SaveAsOptions..::..Dispose Method
SaveAsOptions Class See Also Send Feedback
Releases all resources used by the SaveAsOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SaveAsOptions Class


SaveAsOptions Properties

[image] [image]

Revit 2013 API
SaveAsOptions Properties
SaveAsOptions Class See Also Send Feedback

The SaveAsOptions type exposes the following members.

Properties

 | Name | Description
Public property | OverwriteExistingFile | Identifies if the operation should be able to overwrite an existing file.
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.
Public property | Rename | Identifies if the operation should rename the saved document, or save a copy.

See Also

SaveAsOptions Class


OverwriteExistingFile Property

[image]

Revit 2013 API
SaveAsOptions..::..OverwriteExistingFile Property
SaveAsOptions Class See Also Send Feedback
Identifies if the operation should be able to overwrite an existing file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool OverwriteExistingFile { get; set; }
Visual Basic
Public Property OverwriteExistingFile As Boolean
    Get
    Set
Visual C++
public:
property bool OverwriteExistingFile {
    bool get ();
    void set (bool value);
}

Field Value

True if the SaveAs operation should silently overwrite an existing target file, if it exists. False if the operation should fail if there is already a file at the target location. Default is false.

See Also

SaveAsOptions Class


PreviewViewId Property

[image]

Revit 2013 API
SaveAsOptions..::..PreviewViewId Property
SaveAsOptions Class See Also Send Feedback
The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic
Public Property PreviewViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The id must be valid for use as a preview view (check DocumentPreviewSettings.IsValidPreviewViewId()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs(). Default is InvalidElementId.

Remarks

If this id is set to a view id, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SaveAsOptions Class


Rename Property

[image]

Revit 2013 API
SaveAsOptions..::..Rename Property
SaveAsOptions Class See Also Send Feedback
Identifies if the operation should rename the saved document, or save a copy.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Rename { get; set; }
Visual Basic
Public Property Rename As Boolean
    Get
    Set
Visual C++
public:
property bool Rename {
    bool get ();
    void set (bool value);
}

Field Value

True if the operation should associate the saved document in memory with the new filename and path. False if the operation should not change the document in memory, the new document will be a copy. Default is true.

See Also

SaveAsOptions Class


SaveOptions Class

[image]

Revit 2013 API
SaveOptions Class
Members See Also Send Feedback
This class contains options available for saving a document to disk.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SaveOptions : IDisposable
Visual Basic
Public Class SaveOptions _
    Implements IDisposable
Visual C++
public ref class SaveOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SaveOptions

See Also

SaveOptions Members


SaveOptions Members

[image] [image]

Revit 2013 API
SaveOptions Members
SaveOptions Class Constructors Methods Properties See Also Send Feedback

The SaveOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SaveOptions | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SaveOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveOptions Class


SaveOptions Constructor

[image]

Revit 2013 API
SaveOptions Constructor
SaveOptions Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SaveOptions()
Visual Basic
Public Sub New
Visual C++
public:
SaveOptions()

Remarks

PreviewViewId will be InvalidElementId.

See Also

SaveOptions Class


SaveOptions Methods

[image] [image]

Revit 2013 API
SaveOptions Methods
SaveOptions Class See Also Send Feedback

The SaveOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SaveOptions Class


Dispose Method

[image]

Revit 2013 API
SaveOptions..::..Dispose Method
SaveOptions Class See Also Send Feedback
Releases all resources used by the SaveOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SaveOptions Class


SaveOptions Properties

[image] [image]

Revit 2013 API
SaveOptions Properties
SaveOptions Class See Also Send Feedback

The SaveOptions type exposes the following members.

Properties

 | Name | Description
Public property | PreviewViewId | The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

See Also

SaveOptions Class


PreviewViewId Property

[image]

Revit 2013 API
SaveOptions..::..PreviewViewId Property
SaveOptions Class See Also Send Feedback
The view id that will be used to generate the preview; this id is not saved to the document's permanent settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId PreviewViewId { get; set; }
Visual Basic
Public Property PreviewViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PreviewViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The id must be valid for use as a preview view (check DocumentPreviewSettings.IsViewIdValidForPreview()). Revit does not check validity when setting this value, only when the options are used in a call to SaveAs().

Remarks

If this id is set, the indicated view will be used to generate the preview even if DocumentPreviewSettings.PreviewViewId is also set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SaveOptions Class


SchedulableField Class

[image]

Revit 2013 API
SchedulableField Class
Members See Also Send Feedback
A non-calculated field eligible to be included in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SchedulableField : IDisposable
Visual Basic
Public Class SchedulableField _
    Implements IDisposable
Visual C++
public ref class SchedulableField : IDisposable

Remarks

The SchedulableField class represents a non-calculated field that is eligible to be included in a schedule. A list of fields that can be included in a schedule can be obtained from ScheduleDefinition.GetSchedulableFields.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SchedulableField

See Also

SchedulableField Members


SchedulableField Members

[image] [image]

Revit 2013 API
SchedulableField Members
SchedulableField Class Constructors Methods Operators Properties See Also Send Feedback

The SchedulableField type exposes the following members.

Constructors

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SchedulableField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

Properties

 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | ParameterId | The ID of the parameter displayed by the field.

See Also

SchedulableField Class


SchedulableField Constructor

[image] [image]

Revit 2013 API
SchedulableField Constructor
SchedulableField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SchedulableField()()()() | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType) | Creates a new SchedulableField.
Public method | SchedulableField(ScheduleFieldType, ElementId) | Creates a new SchedulableField.

See Also

SchedulableField Class
SchedulableField Members


SchedulableField Constructor

[image]

Revit 2013 API
SchedulableField Constructor
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField()
Visual Basic
Public Sub New
Visual C++
public:
SchedulableField()

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Constructor (ScheduleFieldType)

[image]

Revit 2013 API
SchedulableField Constructor (ScheduleFieldType)
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField(
    ScheduleFieldType fieldType
)
Visual Basic
Public Sub New ( _
    fieldType As ScheduleFieldType _
)
Visual C++
public:
SchedulableField(
    ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldType is a calculated field type (Formula or Percentage).

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Constructor (ScheduleFieldType, ElementId)

[image]

Revit 2013 API
SchedulableField Constructor (ScheduleFieldType, ElementId)
SchedulableField Class See Also Send Feedback
Creates a new SchedulableField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Sub New ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
)
Visual C++
public:
SchedulableField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldType is a calculated field type (Formula or Percentage).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SchedulableField Class
SchedulableField Overload


SchedulableField Methods

[image] [image]

Revit 2013 API
SchedulableField Methods
SchedulableField Class See Also Send Feedback

The SchedulableField type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the SchedulableField as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetName | Gets the name of the field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SchedulableField Class


Dispose Method

[image]

Revit 2013 API
SchedulableField..::..Dispose Method
SchedulableField Class See Also Send Feedback
Releases all resources used by the SchedulableField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SchedulableField Class


Equals Method

[image]

Revit 2013 API
SchedulableField..::..Equals Method
SchedulableField Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The other object to evaluate.

See Also

SchedulableField Class


GetHashCode Method

[image]

Revit 2013 API
SchedulableField..::..GetHashCode Method
SchedulableField Class See Also Send Feedback
Gets the integer value of the SchedulableField as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

SchedulableField Class


GetName Method

[image]

Revit 2013 API
SchedulableField..::..GetName Method
SchedulableField Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetName(
    Document document
)
Visual Basic
Public Function GetName ( _
    document As Document _
) As String
Visual C++
public:
String^ GetName(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the field will be used.

Return Value

The name of the field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The parameter doesn't exist in document.

See Also

SchedulableField Class


SchedulableField Operators

[image] [image]

Revit 2013 API
SchedulableField Operators
SchedulableField Class See Also Send Feedback

The SchedulableField type exposes the following members.

Operators

Name | Description
Equality | Determines whether two SchedulableField are the same.
Inequality | Determines whether two SchedulableField are different.

See Also

SchedulableField Class


Equality Operator

[image]

Revit 2013 API
SchedulableField..::..Equality Operator
SchedulableField Class See Also Send Feedback
Determines whether two SchedulableField are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    SchedulableField first,
    SchedulableField second
)
Visual Basic
Public Shared Operator = ( _
    first As SchedulableField, _
    second As SchedulableField _
) As Boolean
Visual C++
public:
static bool operator ==(
    SchedulableField^ first,
    SchedulableField^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..SchedulableField
The first SchedulableField.
second
Type: Autodesk.Revit.DB..::..SchedulableField
The second SchedulableField.

Return Value

True if the SchedulableField are the same, otherwise false.

See Also

SchedulableField Class


Inequality Operator

[image]

Revit 2013 API
SchedulableField..::..Inequality Operator
SchedulableField Class See Also Send Feedback
Determines whether two SchedulableField are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    SchedulableField first,
    SchedulableField second
)
Visual Basic
Public Shared Operator <> ( _
    first As SchedulableField, _
    second As SchedulableField _
) As Boolean
Visual C++
public:
static bool operator !=(
    SchedulableField^ first,
    SchedulableField^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..SchedulableField
The first SchedulableField.
second
Type: Autodesk.Revit.DB..::..SchedulableField
The second SchedulableField.

Return Value

True if the SchedulableField are different, otherwise false.

See Also

SchedulableField Class


SchedulableField Properties

[image] [image]

Revit 2013 API
SchedulableField Properties
SchedulableField Class See Also Send Feedback

The SchedulableField type exposes the following members.

Properties

 | Name | Description
Public property | FieldType | The type of data displayed by the field.
Public property | ParameterId | The ID of the parameter displayed by the field.

See Also

SchedulableField Class


FieldType Property

[image]

Revit 2013 API
SchedulableField..::..FieldType Property
SchedulableField Class See Also Send Feedback
The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldType FieldType { get; set; }
Visual Basic
Public Property FieldType As ScheduleFieldType
    Get
    Set
Visual C++
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
    void set (ScheduleFieldType value);
}

Field Value

See ScheduleFieldType for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fieldType is a calculated field type (Formula or Percentage).

See Also

SchedulableField Class


ParameterId Property

[image]

Revit 2013 API
SchedulableField..::..ParameterId Property
SchedulableField Class See Also Send Feedback
The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ParameterId { get; set; }
Visual Basic
Public Property ParameterId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ParameterId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The parameter ID, or InvalidElementId.

Remarks

Most non-calculated field types require a parameter ID. The Count field doesn't have a parameter ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SchedulableField Class


ScheduleDefinition Class

[image]

Revit 2013 API
ScheduleDefinition Class
Members See Also Send Feedback
Settings that define the contents of a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleDefinition : IDisposable
Visual Basic
Public Class ScheduleDefinition _
    Implements IDisposable
Visual C++
public ref class ScheduleDefinition : IDisposable

Remarks

The ScheduleDefinition class contains various settings that define the contents of a schedule view, including:

  • The schedule's category and other basic properties that determine the type of schedule.
  • A set of fields that become the columns of the schedule.
  • Filters that restrict the set of elements visible in the schedule.
  • Sorting and grouping criteria.

Most schedules contain a single ScheduleDefinition. In Revit MEP, schedules of certain categories can contain an "embedded schedule" containing elements associated with the elements in the primary schedule, for example a room schedule showing the elements inside each room or a duct system schedule showing the elements associated with each system. An embedded schedule has its own category, fields, filters, etc. Those settings are stored in a second ScheduleDefinition object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleDefinition

See Also

ScheduleDefinition Members


ScheduleDefinition Members

[image] [image]

Revit 2013 API
ScheduleDefinition Members
ScheduleDefinition Class Methods Properties See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddEmbeddedSchedule | Adds an embedded ScheduleDefinition.
Public method | AddField(SchedulableField) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddFilter | Adds a new filter at the end of the list.
Public method | AddSortGroupField | Adds a new sorting/grouping field at the end of the list.
Public method | CanFilter | Checks whether filters can be added to this ScheduleDefinition.
Public method | CanFilterByParameterExistence | Checks whether a field can be used with a HasParameter filter.
Public method | CanFilterBySubstring | Checks whether a field can be used with a substring-based filter.
Public method | CanFilterByValue | Checks whether a field can be used with a value-based filter.
Public method | CanHaveEmbeddedSchedule | Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.
Public method | CanIncludeLinkedFiles | Checks whether the schedule is a type that supports including elements from linked files.
Public method | CanSortByField | Checks whether a field can be used for sorting/grouping.
Public method | ClearFields | Removes all fields.
Public method | ClearFilters | Removes all filters.
Public method | ClearSortGroupFields | Removes all sorting/grouping fields.
Public method | Dispose | Releases all resources used by the ScheduleDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Public method | GetFieldCount | Gets the number of fields in this ScheduleDefinition.
Public method | GetFieldId | Converts a field index to the corresponding field ID.
Public method | GetFieldIndex | Converts a field ID to the corresponding field index.
Public method | GetFieldOrder | Gets the IDs of the current list of fields in order.
Public method | GetFilter | Gets a filter.
Public method | GetFilterCount | Gets the number of filters in this ScheduleDefinition.
Public method | GetFilters | Gets all filters in this ScheduleDefinition.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchedulableFields | Gets a list of all non-calculated fields that are eligible to be included in this schedule.
Public method | GetSortGroupField | Gets a sorting/grouping field.
Public method | GetSortGroupFieldCount | Gets the number of sorting/grouping fields in this ScheduleDefinition.
Public method | GetSortGroupFields | Gets all sorting/grouping fields in this ScheduleDefinition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidCategoriesForEmbeddedSchedule | Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | InsertField(SchedulableField, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertFilter | Adds a new filter at the specified position in the list.
Public method | InsertSortGroupField | Adds a new sorting/grouping field at the specified position in the list.
Public method | IsSchedulableField | Checks whether a non-calculated field is eligible to be included in this schedule.
Public method | IsValidCategoryForEmbeddedSchedule | Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | IsValidFieldId | Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.
Public method | IsValidFieldIndex | Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.
Public method | RemoveEmbeddedSchedule | Removes the embedded ScheduleDefinition.
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Public method | RemoveFilter | Removes a filter.
Public method | RemoveSortGroupField | Removes a sorting/grouping field.
Public method | SetFieldOrder | Reorders the fields in the schedule.
Public method | SetFilter | Replaces a filter.
Public method | SetFilters | Replaces all filters in this ScheduleDefinition.
Public method | SetSortGroupField | Replaces a sorting/grouping field.
Public method | SetSortGroupFields | Replaces all sorting/grouping fields in this ScheduleDefinition.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.

See Also

ScheduleDefinition Class


ScheduleDefinition Methods

[image] [image]

Revit 2013 API
ScheduleDefinition Methods
ScheduleDefinition Class See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddEmbeddedSchedule | Adds an embedded ScheduleDefinition.
Public method | AddField(SchedulableField) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddFilter | Adds a new filter at the end of the list.
Public method | AddSortGroupField | Adds a new sorting/grouping field at the end of the list.
Public method | CanFilter | Checks whether filters can be added to this ScheduleDefinition.
Public method | CanFilterByParameterExistence | Checks whether a field can be used with a HasParameter filter.
Public method | CanFilterBySubstring | Checks whether a field can be used with a substring-based filter.
Public method | CanFilterByValue | Checks whether a field can be used with a value-based filter.
Public method | CanHaveEmbeddedSchedule | Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.
Public method | CanIncludeLinkedFiles | Checks whether the schedule is a type that supports including elements from linked files.
Public method | CanSortByField | Checks whether a field can be used for sorting/grouping.
Public method | ClearFields | Removes all fields.
Public method | ClearFilters | Removes all filters.
Public method | ClearSortGroupFields | Removes all sorting/grouping fields.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.
Public method | GetFieldCount | Gets the number of fields in this ScheduleDefinition.
Public method | GetFieldId | Converts a field index to the corresponding field ID.
Public method | GetFieldIndex | Converts a field ID to the corresponding field index.
Public method | GetFieldOrder | Gets the IDs of the current list of fields in order.
Public method | GetFilter | Gets a filter.
Public method | GetFilterCount | Gets the number of filters in this ScheduleDefinition.
Public method | GetFilters | Gets all filters in this ScheduleDefinition.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSchedulableFields | Gets a list of all non-calculated fields that are eligible to be included in this schedule.
Public method | GetSortGroupField | Gets a sorting/grouping field.
Public method | GetSortGroupFieldCount | Gets the number of sorting/grouping fields in this ScheduleDefinition.
Public method | GetSortGroupFields | Gets all sorting/grouping fields in this ScheduleDefinition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidCategoriesForEmbeddedSchedule | Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | InsertField(SchedulableField, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertFilter | Adds a new filter at the specified position in the list.
Public method | InsertSortGroupField | Adds a new sorting/grouping field at the specified position in the list.
Public method | IsSchedulableField | Checks whether a non-calculated field is eligible to be included in this schedule.
Public method | IsValidCategoryForEmbeddedSchedule | Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Public method | IsValidFieldId | Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.
Public method | IsValidFieldIndex | Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.
Public method | RemoveEmbeddedSchedule | Removes the embedded ScheduleDefinition.
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.
Public method | RemoveFilter | Removes a filter.
Public method | RemoveSortGroupField | Removes a sorting/grouping field.
Public method | SetFieldOrder | Reorders the fields in the schedule.
Public method | SetFilter | Replaces a filter.
Public method | SetFilters | Replaces all filters in this ScheduleDefinition.
Public method | SetSortGroupField | Replaces a sorting/grouping field.
Public method | SetSortGroupFields | Replaces all sorting/grouping fields in this ScheduleDefinition.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleDefinition Class


AddEmbeddedSchedule Method

[image]

Revit 2013 API
ScheduleDefinition..::..AddEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Adds an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddEmbeddedSchedule(
    ElementId categoryId
)
Visual Basic
Public Sub AddEmbeddedSchedule ( _
    categoryId As ElementId _
)
Visual C++
public:
void AddEmbeddedSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID of elements to display in the embedded schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition.

See Also

ScheduleDefinition Class


AddField Method

[image] [image]

Revit 2013 API
ScheduleDefinition..::..AddField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddField(SchedulableField) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType) | Adds a regular (non-calculated) field at the end of the list.
Public method | AddField(ScheduleFieldType, ElementId) | Adds a regular (non-calculated) field at the end of the list.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


AddField Method (SchedulableField)

[image]

Revit 2013 API
ScheduleDefinition..::..AddField Method (SchedulableField)
ScheduleDefinition Class Example See Also Send Feedback
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    SchedulableField schedulableField
)
Visual Basic
Public Function AddField ( _
    schedulableField As SchedulableField _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    SchedulableField^ schedulableField
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.

Return Value

The new field.

Examples

CopyC#
/// <summary>
/// Add fields to view schedule.
/// </summary>
/// <param name="schedules">List of view schedule.</param>
public void AddFieldToSchedule(List<ViewSchedule> schedules)
{
    IList<SchedulableField> schedulableFields = null;

    foreach (ViewSchedule vs in schedules)
    {
        //Get all schedulable fields from view schedule definition.
        schedulableFields = vs.Definition.GetSchedulableFields();

        foreach (SchedulableField sf in schedulableFields)
        {
            bool fieldAlreadyAdded = false;
            //Get all schedule field ids
            IList<ScheduleFieldId> ids = vs.Definition.GetFieldOrder();
            foreach (ScheduleFieldId id in ids)
            {
                //If the GetSchedulableField() method of gotten schedule field returns same schedulable field, it means the field is already added to the view schedule.
                if (vs.Definition.GetField(id).GetSchedulableField() == sf)
                {
                    fieldAlreadyAdded = true;
                    break;
                }
            }

            //If schedulable field doesn't exist in view schedule, add it.
            if (fieldAlreadyAdded == false)
            {
                vs.Definition.AddField(sf);
            }
        }
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class
AddField Overload


AddField Method (ScheduleFieldType)

[image]

Revit 2013 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
AddField Overload


AddField Method (ScheduleFieldType, ElementId)

[image]

Revit 2013 API
ScheduleDefinition..::..AddField Method (ScheduleFieldType, ElementId)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField AddField(
    ScheduleFieldType fieldType,
    ElementId parameterId
)
Visual Basic
Public Function AddField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId _
) As ScheduleField
Visual C++
public:
ScheduleField^ AddField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
AddField Overload


AddFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..AddFilter Method
ScheduleDefinition Class See Also Send Feedback
Adds a new filter at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddFilter(
    ScheduleFilter filter
)
Visual Basic
Public Sub AddFilter ( _
    filter As ScheduleFilter _
)
Visual C++
public:
void AddFilter(
    ScheduleFilter^ filter
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 4.

See Also

ScheduleDefinition Class


AddSortGroupField Method

[image]

Revit 2013 API
ScheduleDefinition..::..AddSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Adds a new sorting/grouping field at the end of the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSortGroupField(
    ScheduleSortGroupField sortGroupField
)
Visual Basic
Public Sub AddSortGroupField ( _
    sortGroupField As ScheduleSortGroupField _
)
Visual C++
public:
void AddSortGroupField(
    ScheduleSortGroupField^ sortGroupField
)

Parameters

sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The sorting/grouping field to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.

See Also

ScheduleDefinition Class


CanFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanFilter Method
ScheduleDefinition Class See Also Send Feedback
Checks whether filters can be added to this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilter()
Visual Basic
Public Function CanFilter As Boolean
Visual C++
public:
bool CanFilter()

Return Value

True if this ScheduleDefinition supports filters, false otherwise.

Remarks

Key schedules and revision schedules do not support filters.

See Also

ScheduleDefinition Class


CanFilterByParameterExistence Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanFilterByParameterExistence Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a HasParameter filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilterByParameterExistence(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByParameterExistence ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByParameterExistence(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a HasParameter filter, false otherwise.

Remarks

The HasParameter filter type only supports shared parameters, and only with the Instance or ElementType field types.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


CanFilterBySubstring Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanFilterBySubstring Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a substring-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilterBySubstring(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterBySubstring ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterBySubstring(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a substring-based filter, false otherwise.

Remarks

The substring-based filter types are Contains, NotContains, BeginsWith, NonBeginsWith, EndsWith and NotEndsWith.

Only string parameters can be filtered by substring.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


CanFilterByValue Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanFilterByValue Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used with a value-based filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanFilterByValue(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanFilterByValue ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanFilterByValue(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used with a value based filter, false otherwise.

Remarks

The value-based filter types are Equal, NotEqual, GreaterThan, GreaterThanOrEqual, LessThan and LessThanOrEqual.

Only certain types of parameters can be filtered by value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


CanHaveEmbeddedSchedule Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanHaveEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Indicates if this ScheduleDefinition can have an embedded ScheduleDefinition added.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanHaveEmbeddedSchedule()
Visual Basic
Public Function CanHaveEmbeddedSchedule As Boolean
Visual C++
public:
bool CanHaveEmbeddedSchedule()

Return Value

True if this ScheduleDefinition can have an embedded ScheduleDefinition, false otherwise.

Remarks

Only schedules of the following categories can have an embedded ScheduleDefinition:

  • Rooms
  • Spaces
  • Electrical Circuits
  • Duct Systems
  • Piping Systems

Key schedules cannot have embedded schedules.

See Also

ScheduleDefinition Class


CanIncludeLinkedFiles Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanIncludeLinkedFiles Method
ScheduleDefinition Class See Also Send Feedback
Checks whether the schedule is a type that supports including elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanIncludeLinkedFiles()
Visual Basic
Public Function CanIncludeLinkedFiles As Boolean
Visual C++
public:
bool CanIncludeLinkedFiles()

Return Value

True if elements from linked files can be included, false otherwise.

Remarks

Elements from linked files can be included in schedules of normal model elements and in sheet lists, but not in most other specialized kinds of schedules.

See Also

ScheduleDefinition Class


CanSortByField Method

[image]

Revit 2013 API
ScheduleDefinition..::..CanSortByField Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a field can be used for sorting/grouping.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanSortByField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CanSortByField ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CanSortByField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to check.

Return Value

True if the field can be used for sorting/grouping, false otherwise.

Remarks

Schedules cannot be sorted/grouped by the Count field, Percentage fields, or Formula fields that depend on Percentage fields because those types of fields don't have meaningful values until after sorting and grouping takes place.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


ClearFields Method

[image]

Revit 2013 API
ScheduleDefinition..::..ClearFields Method
ScheduleDefinition Class See Also Send Feedback
Removes all fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ClearFields()
Visual Basic
Public Sub ClearFields
Visual C++
public:
void ClearFields()

See Also

ScheduleDefinition Class


ClearFilters Method

[image]

Revit 2013 API
ScheduleDefinition..::..ClearFilters Method
ScheduleDefinition Class See Also Send Feedback
Removes all filters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ClearFilters()
Visual Basic
Public Sub ClearFilters
Visual C++
public:
void ClearFilters()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


ClearSortGroupFields Method

[image]

Revit 2013 API
ScheduleDefinition..::..ClearSortGroupFields Method
ScheduleDefinition Class See Also Send Feedback
Removes all sorting/grouping fields.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ClearSortGroupFields()
Visual Basic
Public Sub ClearSortGroupFields
Visual C++
public:
void ClearSortGroupFields()

See Also

ScheduleDefinition Class


Dispose Method

[image]

Revit 2013 API
ScheduleDefinition..::..Dispose Method
ScheduleDefinition Class See Also Send Feedback
Releases all resources used by the ScheduleDefinition

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleDefinition Class


GetField Method

[image] [image]

Revit 2013 API
ScheduleDefinition..::..GetField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetField(Int32) | Gets a field.
Public method | GetField(ScheduleFieldId) | Gets a field.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


GetField Method (Int32)

[image]

Revit 2013 API
ScheduleDefinition..::..GetField Method (Int32)
ScheduleDefinition Class See Also Send Feedback
Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField GetField(
    int index
)
Visual Basic
Public Function GetField ( _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ GetField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the field.

Return Value

The field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class
GetField Overload


GetField Method (ScheduleFieldId)

[image]

Revit 2013 API
ScheduleDefinition..::..GetField Method (ScheduleFieldId)
ScheduleDefinition Class See Also Send Feedback
Gets a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField GetField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function GetField ( _
    fieldId As ScheduleFieldId _
) As ScheduleField
Visual C++
public:
ScheduleField^ GetField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field.

Return Value

The field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class
GetField Overload


GetFieldCount Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFieldCount Method
ScheduleDefinition Class See Also Send Feedback
Gets the number of fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetFieldCount()
Visual Basic
Public Function GetFieldCount As Integer
Visual C++
public:
int GetFieldCount()

Return Value

The number of fields.

See Also

ScheduleDefinition Class


GetFieldId Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFieldId Method
ScheduleDefinition Class See Also Send Feedback
Converts a field index to the corresponding field ID.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId GetFieldId(
    int index
)
Visual Basic
Public Function GetFieldId ( _
    index As Integer _
) As ScheduleFieldId
Visual C++
public:
ScheduleFieldId^ GetFieldId(
    int index
)

Parameters

index
Type: System..::..Int32
The field index.

Return Value

The field ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class


GetFieldIndex Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFieldIndex Method
ScheduleDefinition Class See Also Send Feedback
Converts a field ID to the corresponding field index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetFieldIndex(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function GetFieldIndex ( _
    fieldId As ScheduleFieldId _
) As Integer
Visual C++
public:
int GetFieldIndex(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The field ID.

Return Value

The field index.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


GetFieldOrder Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFieldOrder Method
ScheduleDefinition Class See Also Send Feedback
Gets the IDs of the current list of fields in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ScheduleFieldId> GetFieldOrder()
Visual Basic
Public Function GetFieldOrder As IList(Of ScheduleFieldId)
Visual C++
public:
IList<ScheduleFieldId^>^ GetFieldOrder()

Return Value

The IDs of the current list of fields.

See Also

ScheduleDefinition Class


GetFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFilter Method
ScheduleDefinition Class See Also Send Feedback
Gets a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter GetFilter(
    int index
)
Visual Basic
Public Function GetFilter ( _
    index As Integer _
) As ScheduleFilter
Visual C++
public:
ScheduleFilter^ GetFilter(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the filter.

Return Value

A copy of the filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.

See Also

ScheduleDefinition Class


GetFilterCount Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFilterCount Method
ScheduleDefinition Class See Also Send Feedback
Gets the number of filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetFilterCount()
Visual Basic
Public Function GetFilterCount As Integer
Visual C++
public:
int GetFilterCount()

Return Value

The number of filters.

See Also

ScheduleDefinition Class


GetFilters Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetFilters Method
ScheduleDefinition Class See Also Send Feedback
Gets all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ScheduleFilter> GetFilters()
Visual Basic
Public Function GetFilters As IList(Of ScheduleFilter)
Visual C++
public:
IList<ScheduleFilter^>^ GetFilters()

Return Value

A list of all filters.

See Also

ScheduleDefinition Class


GetSchedulableFields Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetSchedulableFields Method
ScheduleDefinition Class See Also Send Feedback
Gets a list of all non-calculated fields that are eligible to be included in this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<SchedulableField> GetSchedulableFields()
Visual Basic
Public Function GetSchedulableFields As IList(Of SchedulableField)
Visual C++
public:
IList<SchedulableField^>^ GetSchedulableFields()

Return Value

A list of SchedulableField objects representing the non-calculated fields that may be included in the schedule.

See Also

ScheduleDefinition Class


GetSortGroupField Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Gets a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortGroupField GetSortGroupField(
    int index
)
Visual Basic
Public Function GetSortGroupField ( _
    index As Integer _
) As ScheduleSortGroupField
Visual C++
public:
ScheduleSortGroupField^ GetSortGroupField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field.

Return Value

A copy of the sorting/grouping field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


GetSortGroupFieldCount Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetSortGroupFieldCount Method
ScheduleDefinition Class See Also Send Feedback
Gets the number of sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetSortGroupFieldCount()
Visual Basic
Public Function GetSortGroupFieldCount As Integer
Visual C++
public:
int GetSortGroupFieldCount()

Return Value

The number of sorting/grouping fields.

See Also

ScheduleDefinition Class


GetSortGroupFields Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetSortGroupFields Method
ScheduleDefinition Class See Also Send Feedback
Gets all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ScheduleSortGroupField> GetSortGroupFields()
Visual Basic
Public Function GetSortGroupFields As IList(Of ScheduleSortGroupField)
Visual C++
public:
IList<ScheduleSortGroupField^>^ GetSortGroupFields()

Return Value

A list of all sorting/grouping fields.

See Also

ScheduleDefinition Class


GetValidCategoriesForEmbeddedSchedule Method

[image]

Revit 2013 API
ScheduleDefinition..::..GetValidCategoriesForEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Get all categories that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetValidCategoriesForEmbeddedSchedule()
Visual Basic
Public Function GetValidCategoriesForEmbeddedSchedule As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetValidCategoriesForEmbeddedSchedule()

Return Value

The IDs of all valid categories.

See Also

ScheduleDefinition Class


InsertField Method

[image] [image]

Revit 2013 API
ScheduleDefinition..::..InsertField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InsertField(SchedulableField, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, Int32) | Adds a regular (non-calculated) field at the specified position in the list.
Public method | InsertField(ScheduleFieldType, ElementId, Int32) | Adds a regular (non-calculated) field at the specified position in the list.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


InsertField Method (SchedulableField, Int32)

[image]

Revit 2013 API
ScheduleDefinition..::..InsertField Method (SchedulableField, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    SchedulableField schedulableField,
    int index
)
Visual Basic
Public Function InsertField ( _
    schedulableField As SchedulableField, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    SchedulableField^ schedulableField,
    int index
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
A SchedulableField object representing the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by schedulableField may not included in this ScheduleDefinition. -or- The field specified by schedulableField is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.

See Also

ScheduleDefinition Class
InsertField Overload


InsertField Method (ScheduleFieldType, Int32)

[image]

Revit 2013 API
ScheduleDefinition..::..InsertField Method (ScheduleFieldType, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    int index
)
Visual Basic
Public Function InsertField ( _
    fieldType As ScheduleFieldType, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    int index
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.

See Also

ScheduleDefinition Class
InsertField Overload


InsertField Method (ScheduleFieldType, ElementId, Int32)

[image]

Revit 2013 API
ScheduleDefinition..::..InsertField Method (ScheduleFieldType, ElementId, Int32)
ScheduleDefinition Class See Also Send Feedback
Adds a regular (non-calculated) field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleField InsertField(
    ScheduleFieldType fieldType,
    ElementId parameterId,
    int index
)
Visual Basic
Public Function InsertField ( _
    fieldType As ScheduleFieldType, _
    parameterId As ElementId, _
    index As Integer _
) As ScheduleField
Visual C++
public:
ScheduleField^ InsertField(
    ScheduleFieldType fieldType,
    ElementId^ parameterId,
    int index
)

Parameters

fieldType
Type: Autodesk.Revit.DB..::..ScheduleFieldType
The type of data displayed by the field.
parameterId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the parameter displayed by the field.
index
Type: System..::..Int32
The index in the list of fields.

Return Value

The new field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The field specified by fieldType and parameterId may not included in this ScheduleDefinition. -or- The field specified by fieldType and parameterId is already included in this ScheduleDefinition.

See Also

ScheduleDefinition Class
InsertField Overload


InsertFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..InsertFilter Method
ScheduleDefinition Class See Also Send Feedback
Adds a new filter at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void InsertFilter(
    ScheduleFilter filter,
    int index
)
Visual Basic
Public Sub InsertFilter ( _
    filter As ScheduleFilter, _
    index As Integer _
)
Visual C++
public:
void InsertFilter(
    ScheduleFilter^ filter,
    int index
)

Parameters

filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The filter to add.
index
Type: System..::..Int32
The index in the list of filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters. -or- The resulting filter count would be greater than 4.

See Also

ScheduleDefinition Class


InsertSortGroupField Method

[image]

Revit 2013 API
ScheduleDefinition..::..InsertSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Adds a new sorting/grouping field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void InsertSortGroupField(
    ScheduleSortGroupField sortGroupField,
    int index
)
Visual Basic
Public Sub InsertSortGroupField ( _
    sortGroupField As ScheduleSortGroupField, _
    index As Integer _
)
Visual C++
public:
void InsertSortGroupField(
    ScheduleSortGroupField^ sortGroupField,
    int index
)

Parameters

sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The sorting/grouping field to add.
index
Type: System..::..Int32
The index in the list of sorting/grouping fields.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resulting sorting/grouping field count would be greater than 4.

See Also

ScheduleDefinition Class


IsSchedulableField Method

[image]

Revit 2013 API
ScheduleDefinition..::..IsSchedulableField Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a non-calculated field is eligible to be included in this schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSchedulableField(
    SchedulableField schedulableField
)
Visual Basic
Public Function IsSchedulableField ( _
    schedulableField As SchedulableField _
) As Boolean
Visual C++
public:
bool IsSchedulableField(
    SchedulableField^ schedulableField
)

Parameters

schedulableField
Type: Autodesk.Revit.DB..::..SchedulableField
The field to check.

Return Value

True if the field may be included in the schedule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


IsValidCategoryForEmbeddedSchedule Method

[image]

Revit 2013 API
ScheduleDefinition..::..IsValidCategoryForEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Indicates if a category can be used for an embedded ScheduleDefinition in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidCategoryForEmbeddedSchedule(
    ElementId categoryId
)
Visual Basic
Public Function IsValidCategoryForEmbeddedSchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidCategoryForEmbeddedSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for an embedded ScheduleDefinition, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


IsValidFieldId Method

[image]

Revit 2013 API
ScheduleDefinition..::..IsValidFieldId Method
ScheduleDefinition Class See Also Send Feedback
Checks whether a ScheduleFieldId is the ID of a field in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidFieldId(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function IsValidFieldId ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool IsValidFieldId(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The field ID to check.

Return Value

True if the field ID is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


IsValidFieldIndex Method

[image]

Revit 2013 API
ScheduleDefinition..::..IsValidFieldIndex Method
ScheduleDefinition Class See Also Send Feedback
Checks whether an integer is a valid zero-based field index in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidFieldIndex(
    int index
)
Visual Basic
Public Function IsValidFieldIndex ( _
    index As Integer _
) As Boolean
Visual C++
public:
bool IsValidFieldIndex(
    int index
)

Parameters

index
Type: System..::..Int32
The field index to check.

Return Value

True if the field index is valid, false otherwise.

See Also

ScheduleDefinition Class


RemoveEmbeddedSchedule Method

[image]

Revit 2013 API
ScheduleDefinition..::..RemoveEmbeddedSchedule Method
ScheduleDefinition Class See Also Send Feedback
Removes the embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveEmbeddedSchedule()
Visual Basic
Public Sub RemoveEmbeddedSchedule
Visual C++
public:
void RemoveEmbeddedSchedule()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not have an embedded ScheduleDefinition.

See Also

ScheduleDefinition Class


RemoveField Method

[image] [image]

Revit 2013 API
ScheduleDefinition..::..RemoveField Method
ScheduleDefinition Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RemoveField(Int32) | Removes a field.
Public method | RemoveField(ScheduleFieldId) | Removes a field.

See Also

ScheduleDefinition Class
ScheduleDefinition Members


RemoveField Method (Int32)

[image]

Revit 2013 API
ScheduleDefinition..::..RemoveField Method (Int32)
ScheduleDefinition Class See Also Send Feedback
Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveField(
    int index
)
Visual Basic
Public Sub RemoveField ( _
    index As Integer _
)
Visual C++
public:
void RemoveField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid field index in this ScheduleDefinition.

See Also

ScheduleDefinition Class
RemoveField Overload


RemoveField Method (ScheduleFieldId)

[image]

Revit 2013 API
ScheduleDefinition..::..RemoveField Method (ScheduleFieldId)
ScheduleDefinition Class See Also Send Feedback
Removes a field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Sub RemoveField ( _
    fieldId As ScheduleFieldId _
)
Visual C++
public:
void RemoveField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not the ID of a field in this ScheduleDefinition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class
RemoveField Overload


RemoveFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..RemoveFilter Method
ScheduleDefinition Class See Also Send Feedback
Removes a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveFilter(
    int index
)
Visual Basic
Public Sub RemoveFilter ( _
    index As Integer _
)
Visual C++
public:
void RemoveFilter(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the filter to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


RemoveSortGroupField Method

[image]

Revit 2013 API
ScheduleDefinition..::..RemoveSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Removes a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveSortGroupField(
    int index
)
Visual Basic
Public Sub RemoveSortGroupField ( _
    index As Integer _
)
Visual C++
public:
void RemoveSortGroupField(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


SetFieldOrder Method

[image]

Revit 2013 API
ScheduleDefinition..::..SetFieldOrder Method
ScheduleDefinition Class See Also Send Feedback
Reorders the fields in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFieldOrder(
    IList<ScheduleFieldId> fieldIds
)
Visual Basic
Public Sub SetFieldOrder ( _
    fieldIds As IList(Of ScheduleFieldId) _
)
Visual C++
public:
void SetFieldOrder(
    IList<ScheduleFieldId^>^ fieldIds
)

Parameters

fieldIds
Type: System.Collections.Generic..::..IList<(Of <(<'ScheduleFieldId>)>)>
The field IDs in a new order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldIds does not contain exactly the same field IDs as this ScheduleDefinition currently contains.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


SetFilter Method

[image]

Revit 2013 API
ScheduleDefinition..::..SetFilter Method
ScheduleDefinition Class See Also Send Feedback
Replaces a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFilter(
    int index,
    ScheduleFilter filter
)
Visual Basic
Public Sub SetFilter ( _
    index As Integer, _
    filter As ScheduleFilter _
)
Visual C++
public:
void SetFilter(
    int index,
    ScheduleFilter^ filter
)

Parameters

index
Type: System..::..Int32
The index of the filter to replace.
filter
Type: Autodesk.Revit.DB..::..ScheduleFilter
The new filter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field and filter type cannot be used to filter this ScheduleDefinition. -or- The filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid filter index.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


SetFilters Method

[image]

Revit 2013 API
ScheduleDefinition..::..SetFilters Method
ScheduleDefinition Class See Also Send Feedback
Replaces all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFilters(
    IList<ScheduleFilter> filters
)
Visual Basic
Public Sub SetFilters ( _
    filters As IList(Of ScheduleFilter) _
)
Visual C++
public:
void SetFilters(
    IList<ScheduleFilter^>^ filters
)

Parameters

filters
Type: System.Collections.Generic..::..IList<(Of <(<'ScheduleFilter>)>)>
The new list of filters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resulting filter count would be greater than 4. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field and filter type cannot be used to filter this ScheduleDefinition. -or- A filter value is not valid for the field and filter type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleDefinition does not support filters.

See Also

ScheduleDefinition Class


SetSortGroupField Method

[image]

Revit 2013 API
ScheduleDefinition..::..SetSortGroupField Method
ScheduleDefinition Class See Also Send Feedback
Replaces a sorting/grouping field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSortGroupField(
    int index,
    ScheduleSortGroupField sortGroupField
)
Visual Basic
Public Sub SetSortGroupField ( _
    index As Integer, _
    sortGroupField As ScheduleSortGroupField _
)
Visual C++
public:
void SetSortGroupField(
    int index,
    ScheduleSortGroupField^ sortGroupField
)

Parameters

index
Type: System..::..Int32
The index of the sorting/grouping field to replace.
sortGroupField
Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The new sorting/grouping field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index.

See Also

ScheduleDefinition Class


SetSortGroupFields Method

[image]

Revit 2013 API
ScheduleDefinition..::..SetSortGroupFields Method
ScheduleDefinition Class See Also Send Feedback
Replaces all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSortGroupFields(
    IList<ScheduleSortGroupField> sortGroupFields
)
Visual Basic
Public Sub SetSortGroupFields ( _
    sortGroupFields As IList(Of ScheduleSortGroupField) _
)
Visual C++
public:
void SetSortGroupFields(
    IList<ScheduleSortGroupField^>^ sortGroupFields
)

Parameters

sortGroupFields
Type: System.Collections.Generic..::..IList<(Of <(<'ScheduleSortGroupField>)>)>
The new list of sorting/grouping fields.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The resulting sorting/grouping field count would be greater than 4. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field cannot be used for sorting/grouping.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleDefinition Class


ScheduleDefinition Properties

[image] [image]

Revit 2013 API
ScheduleDefinition Properties
ScheduleDefinition Class See Also Send Feedback

The ScheduleDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AreaSchemeId | In an area schedule, the ID of the area scheme to display.
Public property | CategoryId | The category ID of elements appearing in the schedule.
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | FamilyId | In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.
Public property | HasEmbeddedSchedule | Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.
Public property | IncludeLinkedFiles | Indicates if the schedule includes elements from linked files.
Public property | IsEmbedded | Indicates if this is an embedded ScheduleDefinition.
Public property | IsItemized | Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.
Public property | IsKeySchedule | Indicates if the schedule is a key schedule.
Public property | IsMaterialTakeoff | Indicates if the schedule is a material takeoff.
Public property | ShowGrandTotal | Indicates if a grand total row should be displayed at the bottom of the schedule.
Public property | ShowGrandTotalCount | Indicates if the grand total row should display a count of elements in the schedule.
Public property | ShowGrandTotalTitle | Indicates if the grand total row should display a title.

See Also

ScheduleDefinition Class


AreaSchemeId Property

[image]

Revit 2013 API
ScheduleDefinition..::..AreaSchemeId Property
ScheduleDefinition Class See Also Send Feedback
In an area schedule, the ID of the area scheme to display.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId AreaSchemeId { get; }
Visual Basic
Public ReadOnly Property AreaSchemeId As ElementId
    Get
Visual C++
public:
property ElementId^ AreaSchemeId {
    ElementId^ get ();
}

Field Value

The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Remarks

Schedules of the Areas category show area elements belonging to a single area scheme.

Key schedules of the Areas category apply to all area schemes, so they don't have an area scheme ID.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class


CategoryId Property

[image]

Revit 2013 API
ScheduleDefinition..::..CategoryId Property
ScheduleDefinition Class See Also Send Feedback
The category ID of elements appearing in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId CategoryId { get; }
Visual Basic
Public ReadOnly Property CategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
}

Field Value

The ID of the schedule's category.

Remarks

Most schedules show elements of a single category. In multi-category schedules, the category ID is InvalidElementId. In key schedules, the the schedule's category is the category of elements that the keys are associated with.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class


EmbeddedDefinition Property

[image]

Revit 2013 API
ScheduleDefinition..::..EmbeddedDefinition Property
ScheduleDefinition Class See Also Send Feedback
The embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleDefinition EmbeddedDefinition { get; }
Visual Basic
Public ReadOnly Property EmbeddedDefinition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ EmbeddedDefinition {
    ScheduleDefinition^ get ();
}

Field Value

The ScheduleDefinition if present, or nullNothingnullptra null reference (Nothing in Visual Basic) if absent.

See Also

ScheduleDefinition Class


FamilyId Property

[image]

Revit 2013 API
ScheduleDefinition..::..FamilyId Property
ScheduleDefinition Class See Also Send Feedback
In a note block schedule, the ID of the Generic Annotation family displayed by the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId FamilyId { get; }
Visual Basic
Public ReadOnly Property FamilyId As ElementId
    Get
Visual C++
public:
property ElementId^ FamilyId {
    ElementId^ get ();
}

Field Value

The ID of a Generic Annotation family in a Note Block schedule, InvalidElementId otherwise.

Remarks

A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleDefinition Class


HasEmbeddedSchedule Property

[image]

Revit 2013 API
ScheduleDefinition..::..HasEmbeddedSchedule Property
ScheduleDefinition Class See Also Send Feedback
Indicates if this ScheduleDefinition has an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasEmbeddedSchedule { get; }
Visual Basic
Public ReadOnly Property HasEmbeddedSchedule As Boolean
    Get
Visual C++
public:
property bool HasEmbeddedSchedule {
    bool get ();
}

Field Value

True if this ScheduleDefinition has an embedded ScheduleDefinition, false otherwise.

See Also

ScheduleDefinition Class


IncludeLinkedFiles Property

[image]

Revit 2013 API
ScheduleDefinition..::..IncludeLinkedFiles Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule includes elements from linked files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IncludeLinkedFiles { get; set; }
Visual Basic
Public Property IncludeLinkedFiles As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeLinkedFiles {
    bool get ();
    void set (bool value);
}

Field Value

True if elements in linked files should be included, false otherwise.

Remarks

For an embedded ScheduleDefinition, this setting is controlled by the primary ScheduleDefinition and cannot be set in the embedded ScheduleDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleDefinition does not support including elements from linked files. -or- When setting this property: This ScheduleDefinition is an embedded ScheduleDefinition.

See Also

ScheduleDefinition Class


IsEmbedded Property

[image]

Revit 2013 API
ScheduleDefinition..::..IsEmbedded Property
ScheduleDefinition Class See Also Send Feedback
Indicates if this is an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsEmbedded { get; }
Visual Basic
Public ReadOnly Property IsEmbedded As Boolean
    Get
Visual C++
public:
property bool IsEmbedded {
    bool get ();
}

Field Value

True if this is an embedded ScheduleDefinition, false otherwise.

See Also

ScheduleDefinition Class


IsItemized Property

[image]

Revit 2013 API
ScheduleDefinition..::..IsItemized Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule displays each element on a separate row or combines multiple grouped elements onto the same row.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsItemized { get; set; }
Visual Basic
Public Property IsItemized As Boolean
    Get
    Set
Visual C++
public:
property bool IsItemized {
    bool get ();
    void set (bool value);
}

Field Value

True if the schedule displays each element on a separate row. False if multiple grouped elements are combined on the same row.

Remarks

In an itemized schedule, each scheduled element is displayed on a separate row.

In a non-itemized schedule, elements that are grouped together according to the schedule's grouping criteria are combined onto a single row. For example, if a schedule is grouped by Level and Type, elements having the same Level and Type will appear on the same row. In non-itemized schedules, the Count field can be used to display the number of elements on the row, and totaled fields will display the sum of the values from all elements on the row. If a field is not totaled and the elements on the row have different values for the field, an empty cell will be displayed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleDefinition is a key schedule.

See Also

ScheduleDefinition Class


IsKeySchedule Property

[image]

Revit 2013 API
ScheduleDefinition..::..IsKeySchedule Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule is a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsKeySchedule { get; }
Visual Basic
Public ReadOnly Property IsKeySchedule As Boolean
    Get
Visual C++
public:
property bool IsKeySchedule {
    bool get ();
}

Field Value

True if the schedule is a key schedule, false otherwise.

Remarks

A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.

See Also

ScheduleDefinition Class


IsMaterialTakeoff Property

[image]

Revit 2013 API
ScheduleDefinition..::..IsMaterialTakeoff Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the schedule is a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMaterialTakeoff { get; }
Visual Basic
Public ReadOnly Property IsMaterialTakeoff As Boolean
    Get
Visual C++
public:
property bool IsMaterialTakeoff {
    bool get ();
}

Field Value

True if the schedule is a material takeoff, false otherwise.

Remarks

A material takeoff is a schedule that displays information about the materials that make up elements in the model. Unlike regular schedules where each row (before grouping) represents a single element, each row in a material takeoff represents a single <element, material> pair.

See Also

ScheduleDefinition Class


ShowGrandTotal Property

[image]

Revit 2013 API
ScheduleDefinition..::..ShowGrandTotal Property
ScheduleDefinition Class See Also Send Feedback
Indicates if a grand total row should be displayed at the bottom of the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowGrandTotal { get; set; }
Visual Basic
Public Property ShowGrandTotal As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotal {
    bool get ();
    void set (bool value);
}

Field Value

True if a grand total row should be displayed, false otherwise.

Remarks

The grand total row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowGrandTotalTitle) and a count of elements (see ShowGrandTotalCount).

See Also

ScheduleDefinition Class


ShowGrandTotalCount Property

[image]

Revit 2013 API
ScheduleDefinition..::..ShowGrandTotalCount Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the grand total row should display a count of elements in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowGrandTotalCount { get; set; }
Visual Basic
Public Property ShowGrandTotalCount As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotalCount {
    bool get ();
    void set (bool value);
}

Field Value

True if an element count should be displayed, false otherwise.

Remarks

ShowGrandTotalCount can only be enabled if ShowGrandTotal is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of a grand total row is not enabled.

See Also

ScheduleDefinition Class


ShowGrandTotalTitle Property

[image]

Revit 2013 API
ScheduleDefinition..::..ShowGrandTotalTitle Property
ScheduleDefinition Class See Also Send Feedback
Indicates if the grand total row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowGrandTotalTitle { get; set; }
Visual Basic
Public Property ShowGrandTotalTitle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrandTotalTitle {
    bool get ();
    void set (bool value);
}

Field Value

True if a title should be displayed, false otherwise.

Remarks

The title consists of the text "Grand total".

ShowGrandTotalTitle can only be enabled if ShowGrandTotal is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of a grand total row is not enabled.

See Also

ScheduleDefinition Class


ScheduleField Class

[image]

Revit 2013 API
ScheduleField Class
Members See Also Send Feedback
A field in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleField : IDisposable
Visual Basic
Public Class ScheduleField _
    Implements IDisposable
Visual C++
public ref class ScheduleField : IDisposable

Remarks

The ScheduleField class represents a single field in a ScheduleDefinition's list of fields. Each (non-hidden) field becomes a column in the schedule.

Most commonly, a field represents an instance or type parameter of elements appearing in the schedule. Some fields represent parameters of other related elements, like the room that a scheduled element belongs to. Fields can also represent data calculated from other fields in the schedule, specifically Formula and Percentage fields.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleField

See Also

ScheduleField Members


ScheduleField Members

[image] [image]

Revit 2013 API
ScheduleField Members
ScheduleField Class Methods Properties See Also Send Feedback

The ScheduleField type exposes the following members.

Methods

 | Name | Description
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose | Releases all resources used by the ScheduleField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in characters.
Public property | HasTotals | Indicates if the field displays totals.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of text in the column.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

See Also

ScheduleField Class


ScheduleField Methods

[image] [image]

Revit 2013 API
ScheduleField Methods
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Methods

 | Name | Description
Public method | CanTotal | Indicates if totals can be enabled for this field.
Public method | CanTotalByAssemblyType | Indicates if totals by assembly type can be enabled for this field.
Public method | CreatesCircularReferences | Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the field.
Public method | GetSchedulableField | Gets a SchedulableField object representing this field.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCalculatedField | Indicates if the field is a calculated field (Formula or Percentage).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleField Class


CanTotal Method

[image]

Revit 2013 API
ScheduleField..::..CanTotal Method
ScheduleField Class See Also Send Feedback
Indicates if totals can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanTotal()
Visual Basic
Public Function CanTotal As Boolean
Visual C++
public:
bool CanTotal()

Return Value

True if this field can be totaled, false otherwise.

See Also

ScheduleField Class


CanTotalByAssemblyType Method

[image]

Revit 2013 API
ScheduleField..::..CanTotalByAssemblyType Method
ScheduleField Class See Also Send Feedback
Indicates if totals by assembly type can be enabled for this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanTotalByAssemblyType()
Visual Basic
Public Function CanTotalByAssemblyType As Boolean
Visual C++
public:
bool CanTotalByAssemblyType()

Return Value

True if this field can be totaled by assembly type, false otherwise.

See Also

ScheduleField Class


CreatesCircularReferences Method

[image]

Revit 2013 API
ScheduleField..::..CreatesCircularReferences Method
ScheduleField Class See Also Send Feedback
Checks whether a field ID would create a circular chain of references when used by the PercentageOf property of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CreatesCircularReferences(
    ScheduleFieldId fieldId
)
Visual Basic
Public Function CreatesCircularReferences ( _
    fieldId As ScheduleFieldId _
) As Boolean
Visual C++
public:
bool CreatesCircularReferences(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The field ID to check.

Return Value

True if the field ID would create a circular chain of references, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fieldId is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleField Class


Dispose Method

[image]

Revit 2013 API
ScheduleField..::..Dispose Method
ScheduleField Class See Also Send Feedback
Releases all resources used by the ScheduleField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleField Class


GetName Method

[image]

Revit 2013 API
ScheduleField..::..GetName Method
ScheduleField Class See Also Send Feedback
Gets the name of the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The name of the field.

See Also

ScheduleField Class


GetSchedulableField Method

[image]

Revit 2013 API
ScheduleField..::..GetSchedulableField Method
ScheduleField Class See Also Send Feedback
Gets a SchedulableField object representing this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SchedulableField GetSchedulableField()
Visual Basic
Public Function GetSchedulableField As SchedulableField
Visual C++
public:
SchedulableField^ GetSchedulableField()

Return Value

The SchedulableField object.

Remarks

A SchedulableField object can only be obtained for non-calculated fields (field types other than Formula or Percentage).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ScheduleField is a calculated field (Formula or Percentage).

See Also

ScheduleField Class


IsCalculatedField Method

[image]

Revit 2013 API
ScheduleField..::..IsCalculatedField Method
ScheduleField Class See Also Send Feedback
Indicates if the field is a calculated field (Formula or Percentage).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCalculatedField()
Visual Basic
Public Function IsCalculatedField As Boolean
Visual C++
public:
bool IsCalculatedField()

Return Value

True if the field is a calculated field, false otherwise.

See Also

ScheduleField Class


ScheduleField Properties

[image] [image]

Revit 2013 API
ScheduleField Properties
ScheduleField Class See Also Send Feedback

The ScheduleField type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeading | The column heading text.
Public property | Definition | The ScheduleDefinition that this field belongs to.
Public property | FieldId | The ID of the field in the containing ScheduleDefinition.
Public property | FieldIndex | The index of the field in the containing ScheduleDefinition.
Public property | FieldType | The type of data displayed by the field.
Public property | GridColumnWidth | The width of the column in the editable grid view, measured in characters.
Public property | HasTotals | Indicates if the field displays totals.
Public property | HeadingOrientation | The orientation of the column heading text.
Public property | HorizontalAlignment | The horizontal alignment of text in the column.
Public property | IsHidden | Indicates if the field is hidden in the schedule.
Public property | ParameterId | The ID of the parameter displayed by the field.
Public property | PercentageBy | The ID of the grouped schedule field used to calculate percentage totals.
Public property | PercentageOf | The ID of the field to calculate percentages of.
Public property | Schedule | The schedule that this field belongs to.
Public property | SheetColumnWidth | The width of the column on a sheet.
Public property | TotalByAssemblyType | In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

See Also

ScheduleField Class


ColumnHeading Property

[image]

Revit 2013 API
ScheduleField..::..ColumnHeading Property
ScheduleField Class See Also Send Feedback
The column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string ColumnHeading { get; set; }
Visual Basic
Public Property ColumnHeading As String
    Get
    Set
Visual C++
public:
property String^ ColumnHeading {
    String^ get ();
    void set (String^ value);
}

Field Value

The heading text.

Remarks

On initial creation of a ScheduleField, the column heading is initialized based on the field name (typically a parameter name).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleField Class


Definition Property

[image]

Revit 2013 API
ScheduleField..::..Definition Property
ScheduleField Class See Also Send Feedback
The ScheduleDefinition that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleDefinition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ Definition {
    ScheduleDefinition^ get ();
}

Field Value

The ScheduleDefinition.

See Also

ScheduleField Class


FieldId Property

[image]

Revit 2013 API
ScheduleField..::..FieldId Property
ScheduleField Class See Also Send Feedback
The ID of the field in the containing ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId FieldId { get; }
Visual Basic
Public ReadOnly Property FieldId As ScheduleFieldId
    Get
Visual C++
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
}

Field Value

The field ID.

See Also

ScheduleField Class


FieldIndex Property

[image]

Revit 2013 API
ScheduleField..::..FieldIndex Property
ScheduleField Class See Also Send Feedback
The index of the field in the containing ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int FieldIndex { get; }
Visual Basic
Public ReadOnly Property FieldIndex As Integer
    Get
Visual C++
public:
property int FieldIndex {
    int get ();
}

Field Value

The field index.

See Also

ScheduleField Class


FieldType Property

[image]

Revit 2013 API
ScheduleField..::..FieldType Property
ScheduleField Class See Also Send Feedback
The type of data displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldType FieldType { get; }
Visual Basic
Public ReadOnly Property FieldType As ScheduleFieldType
    Get
Visual C++
public:
property ScheduleFieldType FieldType {
    ScheduleFieldType get ();
}

Field Value

See ScheduleFieldType for details.

See Also

ScheduleField Class


GridColumnWidth Property

[image]

Revit 2013 API
ScheduleField..::..GridColumnWidth Property
ScheduleField Class See Also Send Feedback
The width of the column in the editable grid view, measured in characters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GridColumnWidth { get; set; }
Visual Basic
Public Property GridColumnWidth As Double
    Get
    Set
Visual C++
public:
property double GridColumnWidth {
    double get ();
    void set (double value);
}

Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: gridColumnWidth is negative.

See Also

ScheduleField Class


HasTotals Property

[image]

Revit 2013 API
ScheduleField..::..HasTotals Property
ScheduleField Class See Also Send Feedback
Indicates if the field displays totals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasTotals { get; set; }
Visual Basic
Public Property HasTotals As Boolean
    Get
    Set
Visual C++
public:
property bool HasTotals {
    bool get ();
    void set (bool value);
}

Field Value

True if the field displays totals, false otherwise.

Remarks

To display totals below a series of schedule rows, a footer row must be enabled where the totals will be displayed. It can either be a grand total row at the end of the schedule or a footer row for one of the schedule's grouped fields.

In a non-itemized schedule, totals are also displayed in regular rows when multiple elements appear on the same row.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField cannot be totaled.

See Also

ScheduleField Class


HeadingOrientation Property

[image]

Revit 2013 API
ScheduleField..::..HeadingOrientation Property
ScheduleField Class See Also Send Feedback
The orientation of the column heading text.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleHeadingOrientation HeadingOrientation { get; set; }
Visual Basic
Public Property HeadingOrientation As ScheduleHeadingOrientation
    Get
    Set
Visual C++
public:
property ScheduleHeadingOrientation HeadingOrientation {
    ScheduleHeadingOrientation get ();
    void set (ScheduleHeadingOrientation value);
}

See Also

ScheduleField Class


HorizontalAlignment Property

[image]

Revit 2013 API
ScheduleField..::..HorizontalAlignment Property
ScheduleField Class See Also Send Feedback
The horizontal alignment of text in the column.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleHorizontalAlignment HorizontalAlignment { get; set; }
Visual Basic
Public Property HorizontalAlignment As ScheduleHorizontalAlignment
    Get
    Set
Visual C++
public:
property ScheduleHorizontalAlignment HorizontalAlignment {
    ScheduleHorizontalAlignment get ();
    void set (ScheduleHorizontalAlignment value);
}

See Also

ScheduleField Class


IsHidden Property

[image]

Revit 2013 API
ScheduleField..::..IsHidden Property
ScheduleField Class See Also Send Feedback
Indicates if the field is hidden in the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsHidden { get; set; }
Visual Basic
Public Property IsHidden As Boolean
    Get
    Set
Visual C++
public:
property bool IsHidden {
    bool get ();
    void set (bool value);
}

Field Value

True if the field is hidden, false otherwise.

Remarks

A hidden field is not displayed in the schedule, but it can be used for filtering, sorting, grouping, and conditional formatting and can be referenced by Formula and Percentage fields.

See Also

ScheduleField Class


ParameterId Property

[image]

Revit 2013 API
ScheduleField..::..ParameterId Property
ScheduleField Class See Also Send Feedback
The ID of the parameter displayed by the field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ParameterId { get; }
Visual Basic
Public ReadOnly Property ParameterId As ElementId
    Get
Visual C++
public:
property ElementId^ ParameterId {
    ElementId^ get ();
}

Field Value

The parameter ID, or InvalidElementId.

Remarks

Most field types require a parameter ID. Count, Formula, and Percentage fields don't have parameter IDs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleField Class


PercentageBy Property

[image]

Revit 2013 API
ScheduleField..::..PercentageBy Property
ScheduleField Class See Also Send Feedback
The ID of the grouped schedule field used to calculate percentage totals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId PercentageBy { get; set; }
Visual Basic
Public Property PercentageBy As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ PercentageBy {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Field Value

InvalidElementId or the ID of the grouped field.

Remarks

A Percentage field calculates what percent of the total of another field each element represents. If PercentageBy is InvalidScheduleFieldId, the total is of all elements in the schedule. If PercentageBy is the ID of one of the fields that the schedule is grouped by, the total is of all elements in that group.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.

See Also

ScheduleField Class


PercentageOf Property

[image]

Revit 2013 API
ScheduleField..::..PercentageOf Property
ScheduleField Class See Also Send Feedback
The ID of the field to calculate percentages of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId PercentageOf { get; set; }
Visual Basic
Public Property PercentageOf As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ PercentageOf {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Field Value

The ID of the field, or InvalidElementId.

Remarks

A Percentage field calculates what percent of the total of another field each element represents. PercentageOf is the ID of the field used to calculate percentages. If PercentageOf is InvalidScheduleFieldId, no data is displayed.

Percentages can only be calculated for numeric fields. The Count field and other percentage fields cannot be used to calculate percentages.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: percentageOf is not InvalidScheduleFieldId or the ID of a field that can be used to calculated percentages. -or- When setting this property: percentageOf would create a circular chain of references.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField is not a percentage field.

See Also

ScheduleField Class


Schedule Property

[image]

Revit 2013 API
ScheduleField..::..Schedule Property
ScheduleField Class See Also Send Feedback
The schedule that this field belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewSchedule Schedule { get; }
Visual Basic
Public ReadOnly Property Schedule As ViewSchedule
    Get
Visual C++
public:
property ViewSchedule^ Schedule {
    ViewSchedule^ get ();
}

Field Value

The schedule.

See Also

ScheduleField Class


SheetColumnWidth Property

[image]

Revit 2013 API
ScheduleField..::..SheetColumnWidth Property
ScheduleField Class See Also Send Feedback
The width of the column on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SheetColumnWidth { get; set; }
Visual Basic
Public Property SheetColumnWidth As Double
    Get
    Set
Visual C++
public:
property double SheetColumnWidth {
    double get ();
    void set (double value);
}

Field Value

The width of the column.

Remarks

In a schedule with an embedded ScheduleDefinition, a column may display two fields, one from each ScheduleDefinition. In that case, the larger of the two widths is used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: sheetColumnWidth is negative.

See Also

ScheduleField Class


TotalByAssemblyType Property

[image]

Revit 2013 API
ScheduleField..::..TotalByAssemblyType Property
ScheduleField Class See Also Send Feedback
In an assembly schedule view, indicates if totals are calculated for all assembly instances of the same type or only for a single instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool TotalByAssemblyType { get; set; }
Visual Basic
Public Property TotalByAssemblyType As Boolean
    Get
    Set
Visual C++
public:
property bool TotalByAssemblyType {
    bool get ();
    void set (bool value);
}

Field Value

True if totals are calculated for all assembly instances. False if totals are calculated for one instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This ScheduleField cannot be totaled by assembly type. -or- When setting this property: Totals are not enabled for this ScheduleField.

See Also

ScheduleField Class


ScheduleFieldId Class

[image]

Revit 2013 API
ScheduleFieldId Class
Members See Also Send Feedback
The ScheduleFieldId object is used as a unique identification for a field in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ScheduleFieldId
Visual Basic
Public Class ScheduleFieldId
Visual C++
public ref class ScheduleFieldId

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleFieldId

See Also

ScheduleFieldId Members


ScheduleFieldId Members

[image] [image]

Revit 2013 API
ScheduleFieldId Members
ScheduleFieldId Class Constructors Methods Operators Properties See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFieldId | Initializes a new instance of the ScheduleFieldId class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether two ScheduleFieldIds are the same.
Inequality | Determines whether two ScheduleFieldId are different.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.

See Also

ScheduleFieldId Class


ScheduleFieldId Constructor

[image]

Revit 2013 API
ScheduleFieldId Constructor
ScheduleFieldId Class See Also Send Feedback
Initializes a new instance of the ScheduleFieldId class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId(
    int id
)
Visual Basic
Public Sub New ( _
    id As Integer _
)
Visual C++
public:
ScheduleFieldId(
    int id
)

Parameters

id
Type: System..::..Int32

See Also

ScheduleFieldId Class


ScheduleFieldId Methods

[image] [image]

Revit 2013 API
ScheduleFieldId Methods
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

See Also

ScheduleFieldId Class


Equals Method

[image]

Revit 2013 API
ScheduleFieldId..::..Equals Method
ScheduleFieldId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
The other object to evaluate.

See Also

ScheduleFieldId Class


GetHashCode Method

[image]

Revit 2013 API
ScheduleFieldId..::..GetHashCode Method
ScheduleFieldId Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

ScheduleFieldId Class


ToString Method

[image]

Revit 2013 API
ScheduleFieldId..::..ToString Method
ScheduleFieldId Class See Also Send Feedback
Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

ScheduleFieldId Class


ScheduleFieldId Operators

[image] [image]

Revit 2013 API
ScheduleFieldId Operators
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Operators

Name | Description
Equality | Determines whether two ScheduleFieldIds are the same.
Inequality | Determines whether two ScheduleFieldId are different.

See Also

ScheduleFieldId Class


Equality Operator

[image]

Revit 2013 API
ScheduleFieldId..::..Equality Operator
ScheduleFieldId Class See Also Send Feedback
Determines whether two ScheduleFieldIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Visual Basic
Public Shared Operator = ( _
    first As ScheduleFieldId, _
    second As ScheduleFieldId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The first ScheduleFieldId.
second
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The second ScheduleFieldId.

Return Value

True if the ScheduleFieldIds are the same, otherwise false.

See Also

ScheduleFieldId Class


Inequality Operator

[image]

Revit 2013 API
ScheduleFieldId..::..Inequality Operator
ScheduleFieldId Class See Also Send Feedback
Determines whether two ScheduleFieldId are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    ScheduleFieldId first,
    ScheduleFieldId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ScheduleFieldId, _
    second As ScheduleFieldId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ScheduleFieldId^ first,
    ScheduleFieldId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The first ScheduleFieldId.
second
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The second ScheduleFieldId.

Return Value

True if the ScheduleFieldId are different, otherwise false.

See Also

ScheduleFieldId Class


ScheduleFieldId Properties

[image] [image]

Revit 2013 API
ScheduleFieldId Properties
ScheduleFieldId Class See Also Send Feedback

The ScheduleFieldId type exposes the following members.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the ScheduleFieldId as an integer.
 | InvalidScheduleFieldId | Get the invalid ScheduleFieldId whose IntegerValue is -1.

See Also

ScheduleFieldId Class


IntegerValue Property

[image]

Revit 2013 API
ScheduleFieldId..::..IntegerValue Property
ScheduleFieldId Class See Also Send Feedback
Provides the value of the ScheduleFieldId as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int IntegerValue { get; }
Visual Basic
Public ReadOnly Property IntegerValue As Integer
    Get
Visual C++
public:
property int IntegerValue {
    int get ();
}

See Also

ScheduleFieldId Class


InvalidScheduleFieldId Property

[image]

Revit 2013 API
ScheduleFieldId..::..InvalidScheduleFieldId Property
ScheduleFieldId Class See Also Send Feedback
Get the invalid ScheduleFieldId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ScheduleFieldId InvalidScheduleFieldId { get; }
Visual Basic
Public Shared ReadOnly Property InvalidScheduleFieldId As ScheduleFieldId
    Get
Visual C++
public:
static property ScheduleFieldId^ InvalidScheduleFieldId {
    ScheduleFieldId^ get ();
}

See Also

ScheduleFieldId Class


ScheduleFieldType Enumeration

[image]

Revit 2013 API
ScheduleFieldType Enumeration
See Also Send Feedback
The type of data displayed in a schedule field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleFieldType
Visual Basic
Public Enumeration ScheduleFieldType
Visual C++
public enum class ScheduleFieldType

Members

Member name | Description
Instance | An instance parameter of the scheduled elements. All shared parameters also use this type, regardless of whether they are instance or type parameters.
ElementType | A type parameter of the scheduled elements.
Count | The number of elements appearing on the schedule row.
ViewBased

A specialized type of field used for a few parameters whose displayed values can change based on the settings of the view:

  • ROOM_AREA and ROOM_PERIMETER in room and space schedules.
  • PROJECT_REVISION_REVISION_NUM in revision schedules.
  • KEYNOTE_NUMBER in keynote legends that are numbered by sheet.
Formula | A formula calculated from the values of other fields in the schedule.
Percentage | A value indicating what percent of the total of another field each element represents.
Room | A parameter of the room that a scheduled element belongs to.
FromRoom | A parameter of the room on the "from" side of a door or window.
ToRoom | A parameter of the room on the "to" side of a door or window.
ProjectInfo | A parameter of the Project Info element in the project that the scheduled element belongs to, which may be a linked file. Only allowed in schedules that include elements from linked files.
Material | In a material takeoff, a parameter of one of the materials of a scheduled element.
MaterialQuantity | In a material takeoff, a value representing how a particular material is used within a scheduled element. The parameter ID can be MATERIAL_AREA, MATERIAL_VOLUME, or MATERIAL_ASPAINT.
RevitLinkInstance | A parameter of the RevitLinkInstance that an element in a linked file belongs to. Currently RVT_LINK_INSTANCE_NAME is the only supported parameter. Only allowed in schedules that include elements from linked files.
RevitLinkType | A parameter of the RevitLinkType that an element in a linked file belongs to. Currently RVT_LINK_FILE_NAME_WITHOUT_EXT is the only supported parameter. Only allowed in schedules that include elements from linked files.
StructuralMaterial | A parameter of the structural material of a scheduled element.
Space | A parameter of the space that a scheduled element belongs to.

See Also


ScheduleFilter Class

[image]

Revit 2013 API
ScheduleFilter Class
Members See Also Send Feedback
A filter in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleFilter : IDisposable
Visual Basic
Public Class ScheduleFilter _
    Implements IDisposable
Visual C++
public ref class ScheduleFilter : IDisposable

Remarks

The ScheduleFilter class represents a single filter in a schedule. A filter is a condition that must be satisfied for an element to appear in the schedule. All filters must be satisfied for an element to appear in the schedule.

A schedule can be filtered by data that is not displayed in the schedule by marking the field used for filtering as hidden using the ScheduleField.IsHidden property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleFilter

See Also

ScheduleFilter Members


ScheduleFilter Members

[image] [image]

Revit 2013 API
ScheduleFilter Members
ScheduleFilter Class Constructors Methods Properties See Also Send Feedback

The ScheduleFilter type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleFilter()()()() | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.

See Also

ScheduleFilter Class


ScheduleFilter Constructor

[image] [image]

Revit 2013 API
ScheduleFilter Constructor
ScheduleFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleFilter()()()() | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, ElementId) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Double) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, Int32) | Creates a new ScheduleFilter.
Public method | ScheduleFilter(ScheduleFieldId, ScheduleFilterType, String) | Creates a new ScheduleFilter.

See Also

ScheduleFilter Class
ScheduleFilter Members


ScheduleFilter Constructor

[image]

Revit 2013 API
ScheduleFilter Constructor
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleFilter()

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType)

[image]

Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, ElementId)

[image]

Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, ElementId)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    ElementId value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As ElementId _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    ElementId^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: Autodesk.Revit.DB..::..ElementId
The filter value for a filter using an ElementId value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Double)

[image]

Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Double)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    double value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As Double _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    double value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..Double
The filter value for a filter using a double value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Int32)

[image]

Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, Int32)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    int value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As Integer _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    int value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..Int32
The filter value for a filter using an integer value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, String)

[image]

Revit 2013 API
ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, String)
ScheduleFilter Class See Also Send Feedback
Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilter(
    ScheduleFieldId fieldId,
    ScheduleFilterType filterType,
    string value
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    filterType As ScheduleFilterType, _
    value As String _
)
Visual C++
public:
ScheduleFilter(
    ScheduleFieldId^ fieldId,
    ScheduleFilterType filterType,
    String^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DB..::..ScheduleFilterType
The filter type.
value
Type: System..::..String
The filter value for a filter using a string value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
ScheduleFilter Overload


ScheduleFilter Methods

[image] [image]

Revit 2013 API
ScheduleFilter Methods
ScheduleFilter Class See Also Send Feedback

The ScheduleFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDoubleValue | Gets the filter value for a filter using a double value.
Public method | GetElementIdValue | Gets the filter value for a filter using an ElementId value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerValue | Gets the filter value for a filter using an integer value.
Public method | GetStringValue | Gets the filter value for a filter using a string value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetNullValue | Sets the filter to have no specified value (used for HasParameter filters).
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleFilter Class


Dispose Method

[image]

Revit 2013 API
ScheduleFilter..::..Dispose Method
ScheduleFilter Class See Also Send Feedback
Releases all resources used by the ScheduleFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleFilter Class


GetDoubleValue Method

[image]

Revit 2013 API
ScheduleFilter..::..GetDoubleValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetDoubleValue()
Visual Basic
Public Function GetDoubleValue As Double
Visual C++
public:
double GetDoubleValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not a double.

See Also

ScheduleFilter Class


GetElementIdValue Method

[image]

Revit 2013 API
ScheduleFilter..::..GetElementIdValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using an ElementId value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetElementIdValue()
Visual Basic
Public Function GetElementIdValue As ElementId
Visual C++
public:
ElementId^ GetElementIdValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not an ElementId.

See Also

ScheduleFilter Class


GetIntegerValue Method

[image]

Revit 2013 API
ScheduleFilter..::..GetIntegerValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using an integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetIntegerValue()
Visual Basic
Public Function GetIntegerValue As Integer
Visual C++
public:
int GetIntegerValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not an integer.

See Also

ScheduleFilter Class


GetStringValue Method

[image]

Revit 2013 API
ScheduleFilter..::..GetStringValue Method
ScheduleFilter Class See Also Send Feedback
Gets the filter value for a filter using a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetStringValue()
Visual Basic
Public Function GetStringValue As String
Visual C++
public:
String^ GetStringValue()

Return Value

The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The filter value is not a string.

See Also

ScheduleFilter Class


SetNullValue Method

[image]

Revit 2013 API
ScheduleFilter..::..SetNullValue Method
ScheduleFilter Class See Also Send Feedback
Sets the filter to have no specified value (used for HasParameter filters).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetNullValue()
Visual Basic
Public Sub SetNullValue
Visual C++
public:
void SetNullValue()

See Also

ScheduleFilter Class


SetValue Method

[image] [image]

Revit 2013 API
ScheduleFilter..::..SetValue Method
ScheduleFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(Double) | Set the filter value to a double.
Public method | SetValue(Int32) | Set the filter value to an integer.
Public method | SetValue(String) | Set the filter value to a string.
Public method | SetValue(ElementId) | Set the filter value to an ElementId.

See Also

ScheduleFilter Class
ScheduleFilter Members


SetValue Method (Double)

[image]

Revit 2013 API
ScheduleFilter..::..SetValue Method (Double)
ScheduleFilter Class See Also Send Feedback
Set the filter value to a double.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetValue(
    double value
)
Visual Basic
Public Sub SetValue ( _
    value As Double _
)
Visual C++
public:
void SetValue(
    double value
)

Parameters

value
Type: System..::..Double
The filter value.

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (Int32)

[image]

Revit 2013 API
ScheduleFilter..::..SetValue Method (Int32)
ScheduleFilter Class See Also Send Feedback
Set the filter value to an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetValue(
    int value
)
Visual Basic
Public Sub SetValue ( _
    value As Integer _
)
Visual C++
public:
void SetValue(
    int value
)

Parameters

value
Type: System..::..Int32
The filter value.

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (String)

[image]

Revit 2013 API
ScheduleFilter..::..SetValue Method (String)
ScheduleFilter Class See Also Send Feedback
Set the filter value to a string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetValue(
    string string
)
Visual Basic
Public Sub SetValue ( _
    string As String _
)
Visual C++
public:
void SetValue(
    String^ string
)

Parameters

string
Type: System..::..String
The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
SetValue Overload


SetValue Method (ElementId)

[image]

Revit 2013 API
ScheduleFilter..::..SetValue Method (ElementId)
ScheduleFilter Class See Also Send Feedback
Set the filter value to an ElementId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetValue(
    ElementId id
)
Visual Basic
Public Sub SetValue ( _
    id As ElementId _
)
Visual C++
public:
void SetValue(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The filter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleFilter Class
SetValue Overload


ScheduleFilter Properties

[image] [image]

Revit 2013 API
ScheduleFilter Properties
ScheduleFilter Class See Also Send Feedback

The ScheduleFilter type exposes the following members.

Properties

 | Name | Description
Public property | FieldId | The ID of the field used to filter the schedule.
Public property | FilterType | The filter type.
Public property | IsDoubleValue | Indicates if the filter has a double value.
Public property | IsElementIdValue | Indicates if the filter has an ElementId value.
Public property | IsIntegerValue | Indicates if the filter has an integer value.
Public property | IsNullValue | Indicates if the filter has no specified value.
Public property | IsStringValue | Indicates if the filter has a string value.

See Also

ScheduleFilter Class


FieldId Property

[image]

Revit 2013 API
ScheduleFilter..::..FieldId Property
ScheduleFilter Class See Also Send Feedback
The ID of the field used to filter the schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId FieldId { get; set; }
Visual Basic
Public Property FieldId As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleFilter Class


FilterType Property

[image]

Revit 2013 API
ScheduleFilter..::..FilterType Property
ScheduleFilter Class See Also Send Feedback
The filter type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFilterType FilterType { get; set; }
Visual Basic
Public Property FilterType As ScheduleFilterType
    Get
    Set
Visual C++
public:
property ScheduleFilterType FilterType {
    ScheduleFilterType get ();
    void set (ScheduleFilterType value);
}

Remarks

See ScheduleFilterType for details.

See Also

ScheduleFilter Class


IsDoubleValue Property

[image]

Revit 2013 API
ScheduleFilter..::..IsDoubleValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has a double value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsDoubleValue { get; }
Visual Basic
Public ReadOnly Property IsDoubleValue As Boolean
    Get
Visual C++
public:
property bool IsDoubleValue {
    bool get ();
}

Field Value

True if the filter has a double value, false otherwise.

See Also

ScheduleFilter Class


IsElementIdValue Property

[image]

Revit 2013 API
ScheduleFilter..::..IsElementIdValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has an ElementId value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsElementIdValue { get; }
Visual Basic
Public ReadOnly Property IsElementIdValue As Boolean
    Get
Visual C++
public:
property bool IsElementIdValue {
    bool get ();
}

Field Value

True if the filter has an ElementId value, false otherwise.

See Also

ScheduleFilter Class


IsIntegerValue Property

[image]

Revit 2013 API
ScheduleFilter..::..IsIntegerValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has an integer value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsIntegerValue { get; }
Visual Basic
Public ReadOnly Property IsIntegerValue As Boolean
    Get
Visual C++
public:
property bool IsIntegerValue {
    bool get ();
}

Field Value

True if the filter has an integer value, false otherwise.

See Also

ScheduleFilter Class


IsNullValue Property

[image]

Revit 2013 API
ScheduleFilter..::..IsNullValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has no specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsNullValue { get; }
Visual Basic
Public ReadOnly Property IsNullValue As Boolean
    Get
Visual C++
public:
property bool IsNullValue {
    bool get ();
}

Field Value

True if the filter has no value, false if the filter has a value.

See Also

ScheduleFilter Class


IsStringValue Property

[image]

Revit 2013 API
ScheduleFilter..::..IsStringValue Property
ScheduleFilter Class See Also Send Feedback
Indicates if the filter has a string value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsStringValue { get; }
Visual Basic
Public ReadOnly Property IsStringValue As Boolean
    Get
Visual C++
public:
property bool IsStringValue {
    bool get ();
}

Field Value

True if the filter has a string value, false otherwise.

See Also

ScheduleFilter Class


ScheduleFilterType Enumeration

[image]

Revit 2013 API
ScheduleFilterType Enumeration
See Also Send Feedback
Type of schedule filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ScheduleFilterType
Visual Basic
Public Enumeration ScheduleFilterType
Visual C++
public enum class ScheduleFilterType

Members

Member name | Description
Invalid | An invalid filter. Do not use.
HasParameter | The element has the parameter specified by the field. Used with shared parameters. No value is specified for this filter type.
Equal | The field value is equal to the specified value.
NotEqual | The field value is not equal to the specified value.
GreaterThan | The field value is greater than the specified value.
GreaterThanOrEqual | The field value is greater than or equal to the specified value.
LessThan | Less The field value is less than to the specified value.
LessThanOrEqual | The field value is less than or equal to the specified value.
Contains | For a string field, the field value contains the specified string.
NotContains | For a string field, the field value does not contain the specified string.
BeginsWith | For a string field, the field value begins with the specified string.
NotBeginsWith | For a string field, the field value does not begin with the specified string.
EndsWith | For a string field, the field value ends with specified string.
NotEndsWith | For a string field, the field value does not end with the specified string.

See Also


ScheduleHeadingOrientation Enumeration

[image]

Revit 2013 API
ScheduleHeadingOrientation Enumeration
See Also Send Feedback
Orientation of schedule heading.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleHeadingOrientation
Visual Basic
Public Enumeration ScheduleHeadingOrientation
Visual C++
public enum class ScheduleHeadingOrientation

Members

Member name | Description
Horizontal | Horizontal
Vertical | Vertical

See Also


ScheduleHorizontalAlignment Enumeration

[image]

Revit 2013 API
ScheduleHorizontalAlignment Enumeration
See Also Send Feedback
Horizontal alignment of data in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ScheduleHorizontalAlignment
Visual Basic
Public Enumeration ScheduleHorizontalAlignment
Visual C++
public enum class ScheduleHorizontalAlignment

Members

Member name | Description
Left | Left aligned
Center | Center aligned
Right | Right aligned

See Also


ScheduleSheetInstance Class

[image]

Revit 2013 API
ScheduleSheetInstance Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleSheetInstance : Element
Visual Basic
Public Class ScheduleSheetInstance _
    Inherits Element
Visual C++
public ref class ScheduleSheetInstance : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ScheduleSheetInstance

See Also

ScheduleSheetInstance Members


ScheduleSheetInstance Members

[image] [image]

Revit 2013 API
ScheduleSheetInstance Members
ScheduleSheetInstance Class Methods Properties See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create an instance of a schedule on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the "master" schedule that generates this ScheduleInstance.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ScheduleSheetInstance Class


ScheduleSheetInstance Methods

[image] [image]

Revit 2013 API
ScheduleSheetInstance Methods
ScheduleSheetInstance Class See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create an instance of a schedule on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleSheetInstance Class


Create Method

[image]

Revit 2013 API
ScheduleSheetInstance..::..Create Method
ScheduleSheetInstance Class See Also Send Feedback
Create an instance of a schedule on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ScheduleSheetInstance Create(
    Document document,
    ElementId viewSheetId,
    ElementId scheduleId,
    XYZ origin
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    scheduleId As ElementId, _
    origin As XYZ _
) As ScheduleSheetInstance
Visual C++
public:
static ScheduleSheetInstance^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ scheduleId,
    XYZ^ origin
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The id of the sheet where the schedule will be placed.
scheduleId
Type: Autodesk.Revit.DB..::..ElementId
The id of the schedule view.
origin
Type: Autodesk.Revit.DB..::..XYZ
Location on the sheet where the schedule will be placed.

Return Value

The new ScheduleInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules that are not user-visible but that are used in Revit to manage Keynotes and Revisions cannot be added to sheets. -or- viewSheetId is not a ViewSheet.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ScheduleSheetInstance Class


ScheduleSheetInstance Properties

[image] [image]

Revit 2013 API
ScheduleSheetInstance Properties
ScheduleSheetInstance Class See Also Send Feedback

The ScheduleSheetInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).
Public property | Rotation | Rotation of the ScheduleInstance.
Public property | ScheduleId | Id of the "master" schedule that generates this ScheduleInstance.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ScheduleSheetInstance Class


IsTitleblockRevisionSchedule Property

[image]

Revit 2013 API
ScheduleSheetInstance..::..IsTitleblockRevisionSchedule Property
ScheduleSheetInstance Class See Also Send Feedback
Identifies if this ScheduleSheetInstance is a revision schedule in a titleblock family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsTitleblockRevisionSchedule { get; }
Visual Basic
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
Visual C++
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}

Field Value

True if the ScheduleSheetInstance is a revision schedule in a titleblock family, false otherwise.

Remarks

These schedule instances should not be modified in the project environment. To modify the revision schedule on a titleblock, edit the titleblock family.

See Also

ScheduleSheetInstance Class


Parameter Property

[image] [image]

Revit 2013 API
ScheduleSheetInstance..::..Parameter Property
ScheduleSheetInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ScheduleSheetInstance Class
ScheduleSheetInstance Members


Point Property

[image]

Revit 2013 API
ScheduleSheetInstance..::..Point Property
ScheduleSheetInstance Class See Also Send Feedback
Location on the sheet where the ScheduleInstance is placed (in sheet coordinates).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Point { get; set; }
Visual Basic
Public Property Point As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks.

See Also

ScheduleSheetInstance Class


Rotation Property

[image]

Revit 2013 API
ScheduleSheetInstance..::..Rotation Property
ScheduleSheetInstance Class See Also Send Feedback
Rotation of the ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewportRotation Rotation { get; set; }
Visual Basic
Public Property Rotation As ViewportRotation
    Get
    Set
Visual C++
public:
property ViewportRotation Rotation {
    ViewportRotation get ();
    void set (ViewportRotation value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation is prohibited for ScheduleInstances associated with revision schedules in titleblocks.

See Also

ScheduleSheetInstance Class


ScheduleId Property

[image]

Revit 2013 API
ScheduleSheetInstance..::..ScheduleId Property
ScheduleSheetInstance Class See Also Send Feedback
Id of the "master" schedule that generates this ScheduleInstance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ScheduleId { get; }
Visual Basic
Public ReadOnly Property ScheduleId As ElementId
    Get
Visual C++
public:
property ElementId^ ScheduleId {
    ElementId^ get ();
}

See Also

ScheduleSheetInstance Class


ScheduleSortGroupField Class

[image]

Revit 2013 API
ScheduleSortGroupField Class
Members See Also Send Feedback
A field that is used for sorting and/or grouping in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ScheduleSortGroupField : IDisposable
Visual Basic
Public Class ScheduleSortGroupField _
    Implements IDisposable
Visual C++
public ref class ScheduleSortGroupField : IDisposable

Remarks

A schedule may be sorted or grouped by one or more of the schedule's fields. The ScheduleSortGroupField class represents one of the fields that the schedule is sorted or grouped by.

Sorting and grouping are related operations. In either case, elements appearing in the schedule are sorted based on their values for the field that the schedule is sorted/grouped by, which automatically causes elements with identical values to be grouped together. By enabling extra header, footer, or blank rows, visual separation between groups can be achieved.

If ScheduleDefinition.IsItemized is false, elements having the same values for all of the fields used for sorting/grouping will be combined onto the same row.

A schedule can be sorted or grouped by data that is not displayed in the schedule by marking the field used for sorting/grouping as hidden using the ScheduleField.IsHidden property.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ScheduleSortGroupField

See Also

ScheduleSortGroupField Members


ScheduleSortGroupField Members

[image] [image]

Revit 2013 API
ScheduleSortGroupField Members
ScheduleSortGroupField Class Constructors Methods Properties See Also Send Feedback

The ScheduleSortGroupField type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleSortGroupField()()()() | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ScheduleSortGroupField
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.

See Also

ScheduleSortGroupField Class


ScheduleSortGroupField Constructor

[image] [image]

Revit 2013 API
ScheduleSortGroupField Constructor
ScheduleSortGroupField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduleSortGroupField()()()() | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId) | Creates a new ScheduleSortGroupField.
Public method | ScheduleSortGroupField(ScheduleFieldId, ScheduleSortOrder) | Creates a new ScheduleSortGroupField.

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Members


ScheduleSortGroupField Constructor

[image]

Revit 2013 API
ScheduleSortGroupField Constructor
ScheduleSortGroupField Class See Also Send Feedback
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortGroupField()
Visual Basic
Public Sub New
Visual C++
public:
ScheduleSortGroupField()

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Constructor (ScheduleFieldId)

[image]

Revit 2013 API
ScheduleSortGroupField Constructor (ScheduleFieldId)
ScheduleSortGroupField Class See Also Send Feedback
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortGroupField(
    ScheduleFieldId fieldId
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId _
)
Visual C++
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Constructor (ScheduleFieldId, ScheduleSortOrder)

[image]

Revit 2013 API
ScheduleSortGroupField Constructor (ScheduleFieldId, ScheduleSortOrder)
ScheduleSortGroupField Class See Also Send Feedback
Creates a new ScheduleSortGroupField.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortGroupField(
    ScheduleFieldId fieldId,
    ScheduleSortOrder sortOrder
)
Visual Basic
Public Sub New ( _
    fieldId As ScheduleFieldId, _
    sortOrder As ScheduleSortOrder _
)
Visual C++
public:
ScheduleSortGroupField(
    ScheduleFieldId^ fieldId,
    ScheduleSortOrder sortOrder
)

Parameters

fieldId
Type: Autodesk.Revit.DB..::..ScheduleFieldId
The ID of the field that the schedule will be sorted or grouped by.
sortOrder
Type: Autodesk.Revit.DB..::..ScheduleSortOrder
The sort order, ascending or descending.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ScheduleSortGroupField Class
ScheduleSortGroupField Overload


ScheduleSortGroupField Methods

[image] [image]

Revit 2013 API
ScheduleSortGroupField Methods
ScheduleSortGroupField Class See Also Send Feedback

The ScheduleSortGroupField type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleSortGroupField Class


Dispose Method

[image]

Revit 2013 API
ScheduleSortGroupField..::..Dispose Method
ScheduleSortGroupField Class See Also Send Feedback
Releases all resources used by the ScheduleSortGroupField

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ScheduleSortGroupField Class


ScheduleSortGroupField Properties

[image] [image]

Revit 2013 API
ScheduleSortGroupField Properties
ScheduleSortGroupField Class See Also Send Feedback

The ScheduleSortGroupField type exposes the following members.

Properties

 | Name | Description
Public property | FieldId | The ID of the field that the schedule will be sorted or grouped by.
Public property | ShowBlankLine | Indicates if an empty row should be displayed between groups.
Public property | ShowFooter | Indicates if a footer row should be displayed after each group.
Public property | ShowFooterCount | Indicates if the footer row should display a count of elements in the group.
Public property | ShowFooterTitle | Indicates if the footer row should display a title.
Public property | ShowHeader | Indicates if a header row should be displayed before each group.
Public property | SortOrder | Indicates if elements in the schedule will be sorted in ascending or descending order.

See Also

ScheduleSortGroupField Class


FieldId Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..FieldId Property
ScheduleSortGroupField Class See Also Send Feedback
The ID of the field that the schedule will be sorted or grouped by.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleFieldId FieldId { get; set; }
Visual Basic
Public Property FieldId As ScheduleFieldId
    Get
    Set
Visual C++
public:
property ScheduleFieldId^ FieldId {
    ScheduleFieldId^ get ();
    void set (ScheduleFieldId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ScheduleSortGroupField Class


ShowBlankLine Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..ShowBlankLine Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if an empty row should be displayed between groups.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowBlankLine { get; set; }
Visual Basic
Public Property ShowBlankLine As Boolean
    Get
    Set
Visual C++
public:
property bool ShowBlankLine {
    bool get ();
    void set (bool value);
}

Remarks

True if an empty row should be displayed, false otherwise.

See Also

ScheduleSortGroupField Class


ShowFooter Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..ShowFooter Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if a footer row should be displayed after each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowFooter { get; set; }
Visual Basic
Public Property ShowFooter As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooter {
    bool get ();
    void set (bool value);
}

Field Value

True if a footer row should be displayed, false otherwise.

Remarks

The footer row displays totals of each field for which totals are enabled. It can also optionally display a title (see ShowFooterTitle) and a count of elements (see ShowFooterCount).

See Also

ScheduleSortGroupField Class


ShowFooterCount Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..ShowFooterCount Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if the footer row should display a count of elements in the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowFooterCount { get; set; }
Visual Basic
Public Property ShowFooterCount As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterCount {
    bool get ();
    void set (bool value);
}

Field Value

True if an element count should be displayed, false otherwise.

Remarks

ShowFooterCount can only be enabled if ShowFooter is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of footer rows is not enabled.

See Also

ScheduleSortGroupField Class


ShowFooterTitle Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..ShowFooterTitle Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if the footer row should display a title.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowFooterTitle { get; set; }
Visual Basic
Public Property ShowFooterTitle As Boolean
    Get
    Set
Visual C++
public:
property bool ShowFooterTitle {
    bool get ();
    void set (bool value);
}

Field Value

True if a title should be displayed, false otherwise.

Remarks

The title consists of the value of the field that the schedule is grouped by.

ShowFooterTitle can only be enabled if ShowFooter is enabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Display of footer rows is not enabled.

See Also

ScheduleSortGroupField Class


ShowHeader Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..ShowHeader Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if a header row should be displayed before each group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowHeader { get; set; }
Visual Basic
Public Property ShowHeader As Boolean
    Get
    Set
Visual C++
public:
property bool ShowHeader {
    bool get ();
    void set (bool value);
}

Field Value

True if a header row should be displayed, false otherwise.

Remarks

The header row displays a title consisting of the value of the field that the schedule is grouped by.

See Also

ScheduleSortGroupField Class


SortOrder Property

[image]

Revit 2013 API
ScheduleSortGroupField..::..SortOrder Property
ScheduleSortGroupField Class See Also Send Feedback
Indicates if elements in the schedule will be sorted in ascending or descending order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleSortOrder SortOrder { get; set; }
Visual Basic
Public Property SortOrder As ScheduleSortOrder
    Get
    Set
Visual C++
public:
property ScheduleSortOrder SortOrder {
    ScheduleSortOrder get ();
    void set (ScheduleSortOrder value);
}

See Also

ScheduleSortGroupField Class


ScheduleSortOrder Enumeration

[image]

Revit 2013 API
ScheduleSortOrder Enumeration
See Also Send Feedback
Options for sort order of rows in a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ScheduleSortOrder
Visual Basic
Public Enumeration ScheduleSortOrder
Visual C++
public enum class ScheduleSortOrder

Members

Member name | Description
Ascending | Sort in ascending order.
Descending | Sort in descending order.

See Also


SectionType Enumeration

[image]

Revit 2013 API
SectionType Enumeration
See Also Send Feedback
Declares the section data type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum SectionType
Visual Basic
Public Enumeration SectionType
Visual C++
public enum class SectionType

Members

Member name | Description
None |
Header |
Body |
Summary |
Footer |

See Also


Segment Class

[image]

Revit 2013 API
Segment Class
Members See Also Send Feedback
Base class for pipe, duct, cable tray and conduit segment. Default constructor Default destructor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Segment : Element
Visual Basic
Public Class Segment _
    Inherits Element
Visual C++
public ref class Segment : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB.Plumbing..::..PipeSegment

See Also

Segment Members


Segment Members

[image] [image]

Revit 2013 API
Segment Members
Segment Class Methods Properties See Also Send Feedback

The Segment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of the segment.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Segment Class


Segment Methods

[image] [image]

Revit 2013 API
Segment Methods
Segment Class See Also Send Feedback

The Segment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSizes | Gets the defined sizes of the segment.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Segment Class


AddSize Method

[image]

Revit 2013 API
Segment..::..AddSize Method
Segment Class See Also Send Feedback
Adds a new MEPSize to the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSize(
    MEPSize size
)
Visual Basic
Public Sub AddSize ( _
    size As MEPSize _
)
Visual C++
public:
void AddSize(
    MEPSize^ size
)

Parameters

size
Type: Autodesk.Revit.DB..::..MEPSize
The new MEPSize to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is already a same size in the settings. -or- The size already exists in the segment.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


GetSizes Method

[image]

Revit 2013 API
Segment..::..GetSizes Method
Segment Class See Also Send Feedback
Gets the defined sizes of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<MEPSize> GetSizes()
Visual Basic
Public Function GetSizes As ICollection(Of MEPSize)
Visual C++
public:
ICollection<MEPSize^>^ GetSizes()

See Also

Segment Class


RemoveSize Method

[image]

Revit 2013 API
Segment..::..RemoveSize Method
Segment Class See Also Send Feedback
Remove the existing MEPSize with this nominal diameter from the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveSize(
    double nominalDiameter
)
Visual Basic
Public Sub RemoveSize ( _
    nominalDiameter As Double _
)
Visual C++
public:
void RemoveSize(
    double nominalDiameter
)

Parameters

nominalDiameter
Type: System..::..Double
The nominal diameter of the size.

Remarks

Does nothing if there is no existing MEPSize with this nominal diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The last size of the segment cannot be removed.

See Also

Segment Class


Segment Properties

[image] [image]

Revit 2013 API
Segment Properties
Segment Class See Also Send Feedback

The Segment type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of the segment.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the MaterialElem.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness | The roughness value for given material.
Public property | SizeCount | The number of size objects in the segment.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Segment Class


Description Property

[image]

Revit 2013 API
Segment..::..Description Property
Segment Class See Also Send Feedback
The description of the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


MaterialId Property

[image]

Revit 2013 API
Segment..::..MaterialId Property
Segment Class See Also Send Feedback
The ElementId of the MaterialElem.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MaterialId { get; }
Visual Basic
Public ReadOnly Property MaterialId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}

See Also

Segment Class


Parameter Property

[image] [image]

Revit 2013 API
Segment..::..Parameter Property
Segment Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Segment Class
Segment Members


Roughness Property

[image]

Revit 2013 API
Segment..::..Roughness Property
Segment Class See Also Send Feedback
The roughness value for given material.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
    Get
    Set
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Segment Class


SizeCount Property

[image]

Revit 2013 API
Segment..::..SizeCount Property
Segment Class See Also Send Feedback
The number of size objects in the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SizeCount { get; }
Visual Basic
Public ReadOnly Property SizeCount As Integer
    Get
Visual C++
public:
property int SizeCount {
    int get ();
}

See Also

Segment Class


SelectionFilterAction Enumeration

[image]

Revit 2013 API
SelectionFilterAction Enumeration
See Also Send Feedback
An enumerated type containing the type of actions that may be taken with a selection filter applied to a point cloud.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum SelectionFilterAction
Visual Basic
Public Enumeration SelectionFilterAction
Visual C++
public enum class SelectionFilterAction

Members

Member name | Description
None | Selection filter is ignored.
Highlight | Points that pass the filter are highlighted.
Isolate | Only points that pass the filter are visible.

See Also


SelectionFilterElement Class

[image]

Revit 2013 API
SelectionFilterElement Class
Members See Also Send Feedback
A filter element that stores an explicit list of ElementIds. Only elements whose ElementIds are in this list will pass the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SelectionFilterElement : FilterElement
Visual Basic
Public Class SelectionFilterElement _
    Inherits FilterElement
Visual C++
public ref class SelectionFilterElement : public FilterElement

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..FilterElement
Autodesk.Revit.DB..::..SelectionFilterElement

See Also

SelectionFilterElement Members


SelectionFilterElement Members

[image] [image]

Revit 2013 API
SelectionFilterElement Members
SelectionFilterElement Class Methods Properties See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SelectionFilterElement Class


SelectionFilterElement Methods

[image] [image]

Revit 2013 API
SelectionFilterElement Methods
SelectionFilterElement Class See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Methods

 | Name | Description
Public method | AddSet | Adds a set of ElementIds to the filter's set.
Public method | AddSingle | Adds a single ElementId to the filter's set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | Clear | Removes all ElementIds from the filter.
Public method | Contains | Returns true if the given ElementId is a member of this filter's set.
 | Create | Creates a new SelectionFilterElement in the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementIds | Returns the set of ElementIds contained by this filter.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Determines whether this filter's set is empty or not.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsNameUnique | Determines whether a potential filter element name is unique. (Inherited from FilterElement.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSet | Removes a set of ElementIds from the filter's set.
Public method | RemoveSingle | Removes a single ElementId from the filter's set.
Public method | SetElementIds | Replaces the set of ElementIds contained by this filter.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectionFilterElement Class


AddSet Method

[image]

Revit 2013 API
SelectionFilterElement..::..AddSet Method
SelectionFilterElement Class See Also Send Feedback
Adds a set of ElementIds to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSet(
    ICollection<ElementId> ids
)
Visual Basic
Public Sub AddSet ( _
    ids As ICollection(Of ElementId) _
)
Visual C++
public:
void AddSet(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of ElementIds to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


AddSingle Method

[image]

Revit 2013 API
SelectionFilterElement..::..AddSingle Method
SelectionFilterElement Class See Also Send Feedback
Adds a single ElementId to the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSingle(
    ElementId id
)
Visual Basic
Public Sub AddSingle ( _
    id As ElementId _
)
Visual C++
public:
void AddSingle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to add.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid ElementId
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


Clear Method

[image]

Revit 2013 API
SelectionFilterElement..::..Clear Method
SelectionFilterElement Class See Also Send Feedback
Removes all ElementIds from the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SelectionFilterElement Class


Contains Method

[image]

Revit 2013 API
SelectionFilterElement..::..Contains Method
SelectionFilterElement Class See Also Send Feedback
Returns true if the given ElementId is a member of this filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Contains(
    ElementId id
)
Visual Basic
Public Function Contains ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool Contains(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to look for.

Return Value

True if the given ElementId is a member of the filter, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid ElementId
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


Create Method

[image]

Revit 2013 API
SelectionFilterElement..::..Create Method
SelectionFilterElement Class See Also Send Feedback
Creates a new SelectionFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static SelectionFilterElement Create(
    Document document,
    string name
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    name As String _
) As SelectionFilterElement
Visual C++
public:
static SelectionFilterElement^ Create(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which to create the SelectionFilterElement.
name
Type: System..::..String
The name for the new SelectionFilterElement.

Return Value

The new SelectionFilterElement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- The given value for name is already in use as a filter element name.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


GetElementIds Method

[image]

Revit 2013 API
SelectionFilterElement..::..GetElementIds Method
SelectionFilterElement Class See Also Send Feedback
Returns the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetElementIds()
Visual Basic
Public Function GetElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetElementIds()

Return Value

The set of ElementIds.

See Also

SelectionFilterElement Class


IsEmpty Method

[image]

Revit 2013 API
SelectionFilterElement..::..IsEmpty Method
SelectionFilterElement Class See Also Send Feedback
Determines whether this filter's set is empty or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

True if the set is empty, otherwise false.

See Also

SelectionFilterElement Class


RemoveSet Method

[image]

Revit 2013 API
SelectionFilterElement..::..RemoveSet Method
SelectionFilterElement Class See Also Send Feedback
Removes a set of ElementIds from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int RemoveSet(
    ICollection<ElementId> ids
)
Visual Basic
Public Function RemoveSet ( _
    ids As ICollection(Of ElementId) _
) As Integer
Visual C++
public:
int RemoveSet(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of ElementIds to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


RemoveSingle Method

[image]

Revit 2013 API
SelectionFilterElement..::..RemoveSingle Method
SelectionFilterElement Class See Also Send Feedback
Removes a single ElementId from the filter's set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveSingle(
    ElementId id
)
Visual Basic
Public Sub RemoveSingle ( _
    id As ElementId _
)
Visual C++
public:
void RemoveSingle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to remove.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid ElementId
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


SetElementIds Method

[image]

Revit 2013 API
SelectionFilterElement..::..SetElementIds Method
SelectionFilterElement Class See Also Send Feedback
Replaces the set of ElementIds contained by this filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetElementIds(
    ICollection<ElementId> ids
)
Visual Basic
Public Sub SetElementIds ( _
    ids As ICollection(Of ElementId) _
)
Visual C++
public:
void SetElementIds(
    ICollection<ElementId^>^ ids
)

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The new set of ElementIds.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SelectionFilterElement Class


SelectionFilterElement Properties

[image] [image]

Revit 2013 API
SelectionFilterElement Properties
SelectionFilterElement Class See Also Send Feedback

The SelectionFilterElement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SelectionFilterElement Class


Parameter Property

[image] [image]

Revit 2013 API
SelectionFilterElement..::..Parameter Property
SelectionFilterElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SelectionFilterElement Class
SelectionFilterElement Members


ServerPath Class

[image]

Revit 2013 API
ServerPath Class
Members See Also Send Feedback
This class represents a path to a Revit server location, rather than a location on disk or a network drive.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ServerPath : ModelPath
Visual Basic
Public Class ServerPath _
    Inherits ModelPath
Visual C++
public ref class ServerPath : public ModelPath

Remarks

ServerPaths must refer to Revit files. ServerPaths are relative to the central server location, and are of the form "Revit Server\{filepath}". The {filename} portion is a relative path to a Revit file. For example: Revit Server\filename.rvt Revit Server\Old Files\filename.rvt and Revit Server\Old Files\Last Week\Tuesday\filename.rvt are all valid server paths. Revit Server\Old Files\.rvt and Revit Server\filename are not valid server paths.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ModelPath
Autodesk.Revit.DB..::..ServerPath

See Also

ServerPath Members


ServerPath Members

[image] [image]

Revit 2013 API
ServerPath Members
ServerPath Class Constructors Methods Properties See Also Send Feedback

The ServerPath type exposes the following members.

Constructors

 | Name | Description
Public method | ServerPath | Constructs a ServerPath

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another; (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path or a file path; (Inherited from ModelPath.)

See Also

ServerPath Class


ServerPath Constructor

[image]

Revit 2013 API
ServerPath Constructor
ServerPath Class See Also Send Feedback
Constructs a ServerPath

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ServerPath(
    string centralServerName,
    string path
)
Visual Basic
Public Sub New ( _
    centralServerName As String, _
    path As String _
)
Visual C++
public:
ServerPath(
    String^ centralServerName,
    String^ path
)

Parameters

centralServerName
Type: System..::..String
The name of the central Revit server
path
Type: System..::..String
The path of the file. This path must be relative, but not have "Revit Server\" pre-pended.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ServerPath Class


ServerPath Methods

[image] [image]

Revit 2013 API
ServerPath Methods
ServerPath Class See Also Send Feedback

The ServerPath type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares this ModelPath with another; (Inherited from ModelPath.)
Public method | Dispose | (Inherited from ModelPath.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ServerPath Class


ServerPath Properties

[image] [image]

Revit 2013 API
ServerPath Properties
ServerPath Class See Also Send Feedback

The ServerPath type exposes the following members.

Properties

 | Name | Description
Public property | CentralServerPath | A path to the location of the central Revit server. (Inherited from ModelPath.)
Public property | ServerPath | Whether this path is a server path or a file path; (Inherited from ModelPath.)

See Also

ServerPath Class


ServiceType Enumeration

[image]

Revit 2013 API
ServiceType Enumeration
See Also Send Feedback
An enumerated type listing all of the built-in parameter groups supported by Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ServiceType
Visual Basic
Public Enumeration ServiceType
Visual C++
public enum class ServiceType

Members

Member name | Description
kNoServiceType | Service Type is NoServiceType.
kCentralHeatingRadiators | Service Type is CentralHeatingRadiators.
kCentralHeatingConvectors | Service Type is CentralHeatingConvectors.
kCentralHeatingRadiantFloor | Service Type is CentralHeatingRadiantFloor.
kCentralHeatingHotAir | Service Type is CentralHeatingHotAir.
kOtherRoomHeater | Service Type is OtherRoomHeater.
kRadiantHeaterFlue | Service Type is RadiantHeaterFlue.
kRadiantHeaterNoFlue | Service Type is RadiantHeaterNoFlue.
kRadiantHeaterMultiburner | Service Type is RadiantHeaterMultiburner.
kForcedConvectionHeaterFlue | Service Type is ForcedConvectionHeaterFlue.
kForcedConvectionHeaterNoFlue | Service Type is ForcedConvectionHeaterNoFlue.
kVAVSingleDuct | Service Type is VAVSingleDuct.
kVAVDualDuct | Service Type is VAVDualDuct.
kVAVIndoorPackagedCabinet | Service Type is VAVIndoorPackagedCabinet.
kVAVTerminalReheat | Service Type is VAVTerminalReheat.
kFanCoilSystem | Service Type is FanCoilSystem.
kInductionSystem | Service Type is InductionSystem.
kConstantVolumeFixedOA | Service Type is ConstantVolumeFixedOA.
kConstantVolumeVariableOA | Service Type is ConstantVolumeVariableOA.
kConstantVolumeTerminalReheat | Service Type is ConstantVolumeTerminalReheat.
kMultizoneHotDeckColdDeck | Service Type is MultizoneHotDeckColdDeck.
kConstantVolumeDualDuct | Service Type is ConstantVolumeDualDuct.
kRadiantCooledCeilings | Service Type is RadiantCooledCeilings.
kActiveChilledBeams | Service Type is ActiveChilledBeams.
kWaterLoopHeatPump | Service Type is WaterLoopHeatPump.
kVariableRefrigerantFlow | Service Type is VariableRefrigerantFlow.
kSplitSystemsWithNaturalVentilation | Service Type is SplitSystemsWithNaturalVentilation.
kSplitSystemsWithMechanicalVentilation | Service Type is SplitSystemsWithMechanicalVentilation.
kSplitSystemsWithMechanicalVentilationWithCooling | Service Type is SplitSystemsWithMechanicalVentilationWithCooling.

Remarks

Parameter groups are used to sort parameters within the gbXML Setting item of the Project Information dialog.

See Also


SetComparisonResult Enumeration

[image]

Revit 2013 API
SetComparisonResult Enumeration
See Also Send Feedback
An enumerated type listing all the relationship types between two sets of arbitrary nature.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SetComparisonResult
Visual Basic
Public Enumeration SetComparisonResult
Visual C++
public enum class SetComparisonResult

Members

Member name | Description
LeftEmpty | The left set is empty and the right set is not.
RightEmpty | The right set is empty and the left set is not.
BothEmpty | Both sets are empty.
Disjoint | Both sets are not empty and don't overlap.
Overlap | The overlap of two sets is not empty and strict subset of both.
Subset | Both sets are not empty and the left set is strict subset of the right.
Superset | Both sets are not empty and the left set is strict superset of the right.
Equal | Two nonempty sets are equal.

See Also


Settings Class

[image]

Revit 2013 API
Settings Class
Members Example See Also Send Feedback
The settings object provides access to general components of the Autodesk Revit application, such as Categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Settings : APIObject
Visual Basic
Public Class Settings _
    Inherits APIObject
Visual C++
public ref class Settings : public APIObject

Examples

CopyC#
// Get some of the settings information, including categories and FillPatterns
Settings settings = document.Settings;

// Format the prompt information string
String prompt = "Setting information: ";
prompt += "\nNumber of Categories: " + settings.Categories.Size;
FilteredElementCollector fillPatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Fill Patterns: " + fillPatternCollector.OfClass(typeof(FillPatternElement)).Count();
FilteredElementCollector linePatternCollector = new FilteredElementCollector(document);
prompt += "\nNumber of Line Patterns: " + linePatternCollector.OfClass(typeof(LinePatternElement)).Count();

// Give the user some information
TaskDialog.Show("Revit",prompt);
CopyVB.NET
' Get some of the settings information, inluding categories, Materials and FillPatterns
Dim settings As Settings = document.Settings

' Format the prompt information string
Dim prompt As [String] = "Setting information: "
prompt += vbLf & "Number of Categories: " + settings.Categories.Size
prompt += vbLf & "Number of Fill Patterns: " + settings.FillPatterns.Size
prompt += vbLf & "Number of Line Patterns: " + settings.LinePatterns.Size

' Give the user some information
TaskDialog.Show("Revit", prompt)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Settings

See Also

Settings Members


Settings Members

[image] [image]

Revit 2013 API
Settings Members
Settings Class Methods Properties See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class


Settings Methods

[image] [image]

Revit 2013 API
Settings Methods
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Settings Class


Settings Properties

[image] [image]

Revit 2013 API
Settings Properties
Settings Class See Also Send Feedback

The Settings type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.
Public property | ElectricalSetting | Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | TilePatterns | Retrieves an object that provides access to the TilePattern objects in the document.
Public property | VolumeCalculationSetting | Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

See Also

Settings Class


Categories Property

[image]

Revit 2013 API
Settings..::..Categories Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the categories contained in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Categories Categories { get; }
Visual Basic
Public ReadOnly Property Categories As Categories
    Get
Visual C++
public:
property Categories^ Categories {
    Categories^ get ();
}

See Also

Settings Class


ElectricalSetting Property

[image]

Revit 2013 API
Settings..::..ElectricalSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to all the electrical settings include voltage type, distribution system type, demand factor, wire type in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSetting ElectricalSetting { get; }
Visual Basic
Public ReadOnly Property ElectricalSetting As ElectricalSetting
    Get
Visual C++
public:
property ElectricalSetting^ ElectricalSetting {
    ElectricalSetting^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Electrical settings can be accessed only if Revit MEP product is available.

See Also

Settings Class


TilePatterns Property

[image]

Revit 2013 API
Settings..::..TilePatterns Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to the TilePattern objects in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TilePatterns TilePatterns { get; }
Visual Basic
Public ReadOnly Property TilePatterns As TilePatterns
    Get
Visual C++
public:
property TilePatterns^ TilePatterns {
    TilePatterns^ get ();
}

See Also

Settings Class


VolumeCalculationSetting Property

[image]

Revit 2013 API
Settings..::..VolumeCalculationSetting Property
Settings Class See Also Send Feedback
Retrieves an object that provides access to Volume Calculation Setting in the Autodesk Revit application and project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VolumeCalculationSetting VolumeCalculationSetting { get; }
Visual Basic
Public ReadOnly Property VolumeCalculationSetting As VolumeCalculationSetting
    Get
Visual C++
public:
property VolumeCalculationSetting^ VolumeCalculationSetting {
    VolumeCalculationSetting^ get ();
}

See Also

Settings Class


SharedParameterApplicableRule Class

[image]

Revit 2013 API
SharedParameterApplicableRule Class
Members See Also Send Feedback
Tests whether an element supports a shared parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SharedParameterApplicableRule : FilterRule
Visual Basic
Public Class SharedParameterApplicableRule _
    Inherits FilterRule
Visual C++
public ref class SharedParameterApplicableRule : public FilterRule

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..FilterRule
Autodesk.Revit.DB..::..SharedParameterApplicableRule

See Also

SharedParameterApplicableRule Members


SharedParameterApplicableRule Members

[image] [image]

Revit 2013 API
SharedParameterApplicableRule Members
SharedParameterApplicableRule Class Constructors Methods Properties See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Constructors

 | Name | Description
Public method | SharedParameterApplicableRule | Constructs an instance of SharedParameterApplicableRule.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Constructor

[image]

Revit 2013 API
SharedParameterApplicableRule Constructor
SharedParameterApplicableRule Class See Also Send Feedback
Constructs an instance of SharedParameterApplicableRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SharedParameterApplicableRule(
    string parameterName
)
Visual Basic
Public Sub New ( _
    parameterName As String _
)
Visual C++
public:
SharedParameterApplicableRule(
    String^ parameterName
)

Parameters

parameterName
Type: System..::..String
The name of the parameter that an element must support to pass this rule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Methods

[image] [image]

Revit 2013 API
SharedParameterApplicableRule Methods
SharedParameterApplicableRule Class See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FilterRule.)
Public method | ElementPasses | Derived classes override this method to implement the test that determines whether the given element passes this rule or not. (Inherited from FilterRule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SharedParameterApplicableRule Class


SharedParameterApplicableRule Properties

[image] [image]

Revit 2013 API
SharedParameterApplicableRule Properties
SharedParameterApplicableRule Class See Also Send Feedback

The SharedParameterApplicableRule type exposes the following members.

Properties

 | Name | Description
Public property | ParameterName | The name of the parameter that an element must support to pass this rule.

See Also

SharedParameterApplicableRule Class


ParameterName Property

[image]

Revit 2013 API
SharedParameterApplicableRule..::..ParameterName Property
SharedParameterApplicableRule Class See Also Send Feedback
The name of the parameter that an element must support to pass this rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string ParameterName { get; set; }
Visual Basic
Public Property ParameterName As String
    Get
    Set
Visual C++
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SharedParameterApplicableRule Class


ShellLayerType Enumeration

[image]

Revit 2013 API
ShellLayerType Enumeration
See Also Send Feedback
Used to distinguish exterior and interior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ShellLayerType
Visual Basic
Public Enumeration ShellLayerType
Visual C++
public enum class ShellLayerType

Members

Member name | Description
Interior | Interior shell layer.
Exterior | Exterior shell layer.

Remarks

Used as an argument to methods of CompoundStructure that deal with shell layers.

See Also


SiteLocation Class

[image]

Revit 2013 API
SiteLocation Class
Members Example See Also Send Feedback
Contains the geographical location information for the project's site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SiteLocation : ElementType
Visual Basic
Public Class SiteLocation _
    Inherits ElementType
Visual C++
public ref class SiteLocation : public ElementType

Remarks

Each project may have one site which dictates where in the world the project is based. On this site there may be several locations of the same project. These are represented by ProjectLocation objects. The site location object can be found by using the SiteLocation property on the Document object. The properties of this object can be changed such that it represents any location on the planet or to a known city. Cities already programmed into Revit can be found from the Cities property on the Application object.

Examples

CopyC#
// Get the SiteLocation instance.
Autodesk.Revit.DB.SiteLocation site = document.SiteLocation;

// Angles are in radians when coming from Revit API, so we
// convert to degrees for display
const double angleRatio = Math.PI / 180;   // angle conversion factor

// Format the prompt information.
String prompt = "Current project's Site location information:";
prompt += "\n\t" + "Latitude: " + site.Latitude / angleRatio + "��";
prompt += "\n\t" + "Longitude: " + site.Longitude / angleRatio + "��";
prompt += "\n\t" + "TimeZone: " + site.TimeZone;

// Give the user some information.
TaskDialog.Show("Revit",prompt);

// Change the SiteLocation property data.
site.Latitude = 0.5;    // latitude information
site.Longitude = 0.5;   // longitude information
site.TimeZone = -5;     // TimeZone information
CopyVB.NET
' Get the SiteLocation instance.
Dim site As Autodesk.Revit.DB.SiteLocation = document.SiteLocation

' Angles are in radians when coming from Revit API, so we
' convert to degrees for display
Const  angleRatio As Double = Math.PI / 180
' angle conversion factor
' Format the prompt information.
Dim prompt As [String] = "Current project's Site location information:"
prompt += vbLf & vbTab + "Latitude: " + site.Latitude / angleRatio + "¡ã"
prompt += vbLf & vbTab + "Longitude: " + site.Longitude / angleRatio + "¡ã"
prompt += vbLf & vbTab + "TimeZone: " + site.TimeZone

' Give the user some information.
TaskDialog.Show("Revit", prompt)

' Change the SiteLocation property data.
site.Latitude = 0.5
' latitude information
site.Longitude = 0.5
' longitude information
site.TimeZone = -5
' TimeZone information

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..SiteLocation

See Also

SiteLocation Members


SiteLocation Members

[image] [image]

Revit 2013 API
SiteLocation Members
SiteLocation Class Methods Properties See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Latitude | The latitude of the site location.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | The longitude of the site location.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlaceName | The place name of the site.
Public property | TimeZone | Time-zone that contains the site
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SiteLocation Class


SiteLocation Methods

[image] [image]

Revit 2013 API
SiteLocation Methods
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertFromProjectTime | Converts project time to UTC time.
Public method | ConvertToProjectTime | Converts local time or UTC time to project time.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SiteLocation Class


ConvertFromProjectTime Method

[image]

Revit 2013 API
SiteLocation..::..ConvertFromProjectTime Method
SiteLocation Class See Also Send Feedback
Converts project time to UTC time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DateTime ConvertFromProjectTime(
    DateTime projectTime
)
Visual Basic
Public Function ConvertFromProjectTime ( _
    projectTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertFromProjectTime(
    DateTime projectTime
)

Parameters

projectTime
Type: System..::..DateTime
The project time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the projectTime's kind is not Unspecified.

See Also

SiteLocation Class


ConvertToProjectTime Method

[image]

Revit 2013 API
SiteLocation..::..ConvertToProjectTime Method
SiteLocation Class See Also Send Feedback
Converts local time or UTC time to project time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DateTime ConvertToProjectTime(
    DateTime inputTime
)
Visual Basic
Public Function ConvertToProjectTime ( _
    inputTime As DateTime _
) As DateTime
Visual C++
public:
DateTime ConvertToProjectTime(
    DateTime inputTime
)

Parameters

inputTime
Type: System..::..DateTime
The input local time or UTC time.

Remarks

Daylight savings time is not considered during this conversion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the inputTime's kind is neither Local nor Utc.

See Also

SiteLocation Class


SiteLocation Properties

[image] [image]

Revit 2013 API
SiteLocation Properties
SiteLocation Class See Also Send Feedback

The SiteLocation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Latitude | The latitude of the site location.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | The longitude of the site location.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlaceName | The place name of the site.
Public property | TimeZone | Time-zone that contains the site
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SiteLocation Class


Latitude Property

[image]

Revit 2013 API
SiteLocation..::..Latitude Property
SiteLocation Class See Also Send Feedback
The latitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Latitude { get; set; }
Visual Basic
Public Property Latitude As Double
    Get
    Set
Visual C++
public:
property double Latitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the latitude of the site location. The value of this property is in radians between +PI/2 and -PI/2.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will attempt to automatically adjust the time zone value to match the new Latitude value set using CalculateTimeZone(Double, Double). For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value out of the permitted range.

See Also

SiteLocation Class


Longitude Property

[image]

Revit 2013 API
SiteLocation..::..Longitude Property
SiteLocation Class See Also Send Feedback
The longitude of the site location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Longitude { get; set; }
Visual Basic
Public Property Longitude As Double
    Get
    Set
Visual C++
public:
property double Longitude {
    double get ();
    void set (double value);
}

Remarks

A property that contains the longitude of the site location. The value of this property is in radians between +PI and -PI.

When setting this property:

  1. Revit will attempt to match the coordinates to a city it knows about, and if a match is found, will set the name accordingly.
  2. Revit will attempt to automatically adjust the time zone value to match the new Longitude value set using CalculateTimeZone(Double, Double). For some boundary cases, the time zone calculated may not be correct. You can set the TimeZone property directly to the correct value if necessary.

See Also

SiteLocation Class


Parameter Property

[image] [image]

Revit 2013 API
SiteLocation..::..Parameter Property
SiteLocation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SiteLocation Class
SiteLocation Members


PlaceName Property

[image]

Revit 2013 API
SiteLocation..::..PlaceName Property
SiteLocation Class See Also Send Feedback
The place name of the site.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string PlaceName { get; set; }
Visual Basic
Public Property PlaceName As String
    Get
    Set
Visual C++
public:
property String^ PlaceName {
    String^ get ();
    void set (String^ value);
}

See Also

SiteLocation Class


TimeZone Property

[image]

Revit 2013 API
SiteLocation..::..TimeZone Property
SiteLocation Class See Also Send Feedback
Time-zone that contains the site

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TimeZone { get; set; }
Visual Basic
Public Property TimeZone As Double
    Get
    Set
Visual C++
public:
property double TimeZone {
    double get ();
    void set (double value);
}

Remarks

A property that returns the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Set this property directly if for your desired latitude and longitude, Revit's calculation does not match with the actual time zone for your location. Note that there are no restrictions preventing you from setting this to an incorrect value for the site location, and incorrect times for Solar Studies may result.

See Also

SiteLocation Class


Sketch Class

[image]

Revit 2013 API
Sketch Class
Members See Also Send Feedback
Provides access to the Sketch in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Sketch : SketchBase
Visual Basic
Public Class Sketch _
    Inherits SketchBase
Visual C++
public ref class Sketch : public SketchBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Sketch

See Also

Sketch Members


Sketch Members

[image] [image]

Revit 2013 API
Sketch Members
Sketch Class Methods Properties See Also Send Feedback

The Sketch type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sketch Class


Sketch Methods

[image] [image]

Revit 2013 API
Sketch Methods
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sketch Class


Sketch Properties

[image] [image]

Revit 2013 API
Sketch Properties
Sketch Class See Also Send Feedback

The Sketch type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Profile | Returns the Profile of the Sketch.
Public property | SketchPlane | Returns the Sketch Plane of the Sketch.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sketch Class


Parameter Property

[image] [image]

Revit 2013 API
Sketch..::..Parameter Property
Sketch Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Sketch Class
Sketch Members


Profile Property

[image]

Revit 2013 API
Sketch..::..Profile Property
Sketch Class See Also Send Feedback
Returns the Profile of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray Profile { get; }
Visual Basic
Public ReadOnly Property Profile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ Profile {
    CurveArrArray^ get ();
}

Remarks

This property is used to retrieve the Profile of Sketch.

See Also

Sketch Class


SketchPlane Property

[image]

Revit 2013 API
Sketch..::..SketchPlane Property
Sketch Class See Also Send Feedback
Returns the Sketch Plane of the Sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; }
Visual Basic
Public ReadOnly Property SketchPlane As SketchPlane
    Get
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
}

Remarks

This property is used to retrieve the Sketch Plane of Sketch.

See Also

Sketch Class


SketchBase Class

[image]

Revit 2013 API
SketchBase Class
Members See Also Send Feedback
Provides access to the SketchBase in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SketchBase : Element
Visual Basic
Public Class SketchBase _
    Inherits Element
Visual C++
public ref class SketchBase : public Element

Remarks

SketchBase is the base class of Sketch.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchBase
Autodesk.Revit.DB..::..Path3d
Autodesk.Revit.DB..::..Sketch

See Also

SketchBase Members


SketchBase Members

[image] [image]

Revit 2013 API
SketchBase Members
SketchBase Class Methods Properties See Also Send Feedback

The SketchBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchBase Class


SketchBase Methods

[image] [image]

Revit 2013 API
SketchBase Methods
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchBase Class


SketchBase Properties

[image] [image]

Revit 2013 API
SketchBase Properties
SketchBase Class See Also Send Feedback

The SketchBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchBase Class


Parameter Property

[image] [image]

Revit 2013 API
SketchBase..::..Parameter Property
SketchBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SketchBase Class
SketchBase Members


SketchPlane Class

[image]

Revit 2013 API
SketchPlane Class
Members Example See Also Send Feedback
Represents a sketch plane or work plane within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SketchPlane : Element
Visual Basic
Public Class SketchPlane _
    Inherits Element
Visual C++
public ref class SketchPlane : public Element

Remarks

A SketchPlane object is used as an input to creation of sketch-referencing elements such as Model Curves or sketch-owning elements such as Generic Forms. The SketchPlane can be obtained from an existing element or created from a geometric plane or planar face. Note that the sketch plane element passed as input to create an element may not be the actual sketch plane assigned to that element; Revit may look for a geometrically equivalent plane to use, or may create a new one if the input plane is already used for other purposes. Some sketch planes (such as those obtained from detail curves) are suitable only for use in creating detail elements; they will be rejected when used for other element types.

Examples

CopyC#
public void ShowSketchPlane(SketchPlane sketchPlane)
{
    // get the information of the created sketch plane
    string information = "Sketch Plane: ";
    //get the corresponding Plane
    Autodesk.Revit.DB.Plane plane = sketchPlane.Plane;
    //show the plane's origin point
    information += "\norigin of the plane:  " + XYZToString(plane.Origin);
    //show the plane's normal vector
    information += "\nnormal of the plane:  " + XYZToString(plane.Normal);
    //show the plane's Xvec vector
    information += "\nXvec of the plane: (" + XYZToString(plane.XVec);
    //show the plane's Yvec vector
    information += "\nYvec of the plane: (" + XYZToString(plane.YVec);

    TaskDialog.Show("Revit",information);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Public Sub ShowSketchPlane(ByVal sketchPlane As Autodesk.Revit.DB.SketchPlane)
    ' get the information of the created sketch plane
    Dim information As String = "Sketch Plane: "
    'get the corresponding Plane
    Dim plane As Autodesk.Revit.DB.Plane = sketchPlane.Plane
    'show the plane's origin point
    information += vbLf & "origin of the plane:  " + XYZToString(plane.Origin)
    'show the plane's normal vector
    information += vbLf & "normal of the plane:  " + XYZToString(plane.Normal)
    'show the plane's Xvec vector
    information += vbLf & "Xvec of the plane: (" + XYZToString(plane.XVec)
    'show the plane's Yvec vector
    information += vbLf & "Yvec of the plane: (" + XYZToString(plane.YVec)

    TaskDialog.Show("Revit", information)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SketchPlane

See Also

SketchPlane Members


SketchPlane Members

[image] [image]

Revit 2013 API
SketchPlane Members
SketchPlane Class Methods Properties See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plane | Returns the corresponding Plane.
Public property | PlaneReference | Returns a reference to this element as a plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchPlane Class


SketchPlane Methods

[image] [image]

Revit 2013 API
SketchPlane Methods
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SketchPlane Class


SketchPlane Properties

[image] [image]

Revit 2013 API
SketchPlane Properties
SketchPlane Class See Also Send Feedback

The SketchPlane type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSuitableForModelElements | Identifies if the sketch plane can be assigned to model elements.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plane | Returns the corresponding Plane.
Public property | PlaneReference | Returns a reference to this element as a plane.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SketchPlane Class


IsSuitableForModelElements Property

[image]

Revit 2013 API
SketchPlane..::..IsSuitableForModelElements Property
SketchPlane Class See Also Send Feedback
Identifies if the sketch plane can be assigned to model elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSuitableForModelElements { get; }
Visual Basic
Public ReadOnly Property IsSuitableForModelElements As Boolean
    Get
Visual C++
public:
property bool IsSuitableForModelElements {
    bool get ();
}

Remarks

Sketch planes with this property set to true are suitable to be used to create model elements. Planes where this property is false will be rejected when used to create model curves, symbolic curves, generic forms, or other sketched elements.

See Also

SketchPlane Class


Parameter Property

[image] [image]

Revit 2013 API
SketchPlane..::..Parameter Property
SketchPlane Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SketchPlane Class
SketchPlane Members


Plane Property

[image]

Revit 2013 API
SketchPlane..::..Plane Property
SketchPlane Class See Also Send Feedback
Returns the corresponding Plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Plane Plane { get; }
Visual Basic
Public ReadOnly Property Plane As Plane
    Get
Visual C++
public:
property Plane^ Plane {
    Plane^ get ();
}

Remarks

This property returns the plane upon which elements created with this sketch plane will lie.

See Also

SketchPlane Class


PlaneReference Property

[image]

Revit 2013 API
SketchPlane..::..PlaneReference Property
SketchPlane Class See Also Send Feedback
Returns a reference to this element as a plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PlaneReference { get; }
Visual Basic
Public ReadOnly Property PlaneReference As Reference
    Get
Visual C++
public:
property Reference^ PlaneReference {
    Reference^ get ();
}

Remarks

The object returned here can be used with the PointOnPlane class.

See Also

SketchPlane Class


SkyBackgroundSettings Class

[image]

Revit 2013 API
SkyBackgroundSettings Class
Members See Also Send Feedback
Represents the rendering sky background settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SkyBackgroundSettings : BackgroundSettings
Visual Basic
Public Class SkyBackgroundSettings _
    Inherits BackgroundSettings
Visual C++
public ref class SkyBackgroundSettings : public BackgroundSettings

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..BackgroundSettings
Autodesk.Revit.DB..::..SkyBackgroundSettings

See Also

SkyBackgroundSettings Members


SkyBackgroundSettings Members

[image] [image]

Revit 2013 API
SkyBackgroundSettings Members
SkyBackgroundSettings Class Methods Properties See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | VisibilityDistance | The visibility distance of sky background.

See Also

SkyBackgroundSettings Class


SkyBackgroundSettings Methods

[image] [image]

Revit 2013 API
SkyBackgroundSettings Methods
SkyBackgroundSettings Class See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from BackgroundSettings.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkyBackgroundSettings Class


SkyBackgroundSettings Properties

[image] [image]

Revit 2013 API
SkyBackgroundSettings Properties
SkyBackgroundSettings Class See Also Send Feedback

The SkyBackgroundSettings type exposes the following members.

Properties

 | Name | Description
Public property | VisibilityDistance | The visibility distance of sky background.

See Also

SkyBackgroundSettings Class


VisibilityDistance Property

[image]

Revit 2013 API
SkyBackgroundSettings..::..VisibilityDistance Property
SkyBackgroundSettings Class See Also Send Feedback
The visibility distance of sky background.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public float VisibilityDistance { get; set; }
Visual Basic
Public Property VisibilityDistance As Single
    Get
    Set
Visual C++
public:
property float VisibilityDistance {
    float get ();
    void set (float value);
}

Remarks

Modify this value to control the haziness.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value of visibility distance is not valid. The valid range is 0 to 500.

See Also

SkyBackgroundSettings Class


SlabEdge Class

[image]

Revit 2013 API
SlabEdge Class
Members See Also Send Feedback
An object that represents a slab edge within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabEdge : HostedSweep
Visual Basic
Public Class SlabEdge _
    Inherits HostedSweep
Visual C++
public ref class SlabEdge : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB..::..SlabEdge

See Also

SlabEdge Members


SlabEdge Members

[image] [image]

Revit 2013 API
SlabEdge Members
SlabEdge Class Methods Properties See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdge Class


SlabEdge Methods

[image] [image]

Revit 2013 API
SlabEdge Methods
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the slab edge. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

SlabEdge Class


AddSegment Method

[image]

Revit 2013 API
SlabEdge..::..AddSegment Method
SlabEdge Class See Also Send Feedback
Add segments to the slab edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is nullNothingnullptra null reference (Nothing in Visual Basic). 2. Input targetRef is not nullNothingnullptra null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the slab edge. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a slab edge as required. The reference allowed is : 1. Model Line 2. Floor's horizontal edges 3. Other slab edge's horizontal edges

See Also

SlabEdge Class


SlabEdge Properties

[image] [image]

Revit 2013 API
SlabEdge Properties
SlabEdge Class See Also Send Feedback

The SlabEdge type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | SlabEdgeType | Retrieves/set an object that represents the type of the SlabEdge.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdge Class


Parameter Property

[image] [image]

Revit 2013 API
SlabEdge..::..Parameter Property
SlabEdge Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SlabEdge Class
SlabEdge Members


SlabEdgeType Property

[image]

Revit 2013 API
SlabEdge..::..SlabEdgeType Property
SlabEdge Class See Also Send Feedback
Retrieves/set an object that represents the type of the SlabEdge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdgeType SlabEdgeType { get; set; }
Visual Basic
Public Property SlabEdgeType As SlabEdgeType
    Get
    Set
Visual C++
public:
property SlabEdgeType^ SlabEdgeType {
    SlabEdgeType^ get ();
    void set (SlabEdgeType^ value);
}

See Also

SlabEdge Class


SlabEdgeType Class

[image]

Revit 2013 API
SlabEdgeType Class
Members See Also Send Feedback
An object that represents the slab edge type in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabEdgeType : HostedSweepType
Visual Basic
Public Class SlabEdgeType _
    Inherits HostedSweepType
Visual C++
public ref class SlabEdgeType : public HostedSweepType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB..::..SlabEdgeType

See Also

SlabEdgeType Members


SlabEdgeType Members

[image] [image]

Revit 2013 API
SlabEdgeType Members
SlabEdgeType Class Methods Properties See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdgeType Class


SlabEdgeType Methods

[image] [image]

Revit 2013 API
SlabEdgeType Methods
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeType Class


SlabEdgeType Properties

[image] [image]

Revit 2013 API
SlabEdgeType Properties
SlabEdgeType Class See Also Send Feedback

The SlabEdgeType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SlabEdgeType Class


Parameter Property

[image] [image]

Revit 2013 API
SlabEdgeType..::..Parameter Property
SlabEdgeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SlabEdgeType Class
SlabEdgeType Members


SlabEdgeTypeSet Class

[image]

Revit 2013 API
SlabEdgeTypeSet Class
Members See Also Send Feedback
A set that contains slab edge types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabEdgeTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class SlabEdgeTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabEdgeTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabEdgeTypeSet

See Also

SlabEdgeTypeSet Members


SlabEdgeTypeSet Members

[image] [image]

Revit 2013 API
SlabEdgeTypeSet Members
SlabEdgeTypeSet Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdgeTypeSet | Initializes a new instance of the SlabEdgeTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every slab edge type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a slab edge type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified slab edge type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified slab edge type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Constructor

[image]

Revit 2013 API
SlabEdgeTypeSet Constructor
SlabEdgeTypeSet Class See Also Send Feedback
Initializes a new instance of the SlabEdgeTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdgeTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
SlabEdgeTypeSet()

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Methods

[image] [image]

Revit 2013 API
SlabEdgeTypeSet Methods
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every slab edge type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a slab edge type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified slab edge type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified slab edge type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSet Class


Clear Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..Clear Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes every slab edge type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabEdgeTypeSet Class


Contains Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..Contains Method
SlabEdgeTypeSet Class See Also Send Feedback
Tests for the existence of a slab edge type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    SlabEdgeType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabEdgeType
The slab edge type to be searched for.

Return Value

The Contains method returns True if the slab edge type is within the set, otherwise False.

See Also

SlabEdgeTypeSet Class


Erase Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..Erase Method
SlabEdgeTypeSet Class See Also Send Feedback
Removes a specified slab edge type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    SlabEdgeType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As SlabEdgeType _
) As Integer
Visual C++
public:
virtual int Erase(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabEdgeType
The slab edge type to be erased.

Return Value

The number of slab edge types that were erased from the set.

See Also

SlabEdgeTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..ForwardIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SlabEdgeTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..GetEnumerator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabEdgeTypeSet Class


Insert Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..Insert Method
SlabEdgeTypeSet Class See Also Send Feedback
Insert the specified slab edge type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    SlabEdgeType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As SlabEdgeType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SlabEdgeType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabEdgeType
The slab edge type to be inserted into the set.

Return Value

Returns whether the slab edge type was inserted into the set.

See Also

SlabEdgeTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
SlabEdgeTypeSet..::..ReverseIterator Method
SlabEdgeTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabEdgeTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SlabEdgeTypeSetIterator
Visual C++
public:
virtual SlabEdgeTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSet Properties

[image] [image]

Revit 2013 API
SlabEdgeTypeSet Properties
SlabEdgeTypeSet Class See Also Send Feedback

The SlabEdgeTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of slab edge types that are in the set.

See Also

SlabEdgeTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
SlabEdgeTypeSet..::..IsEmpty Property
SlabEdgeTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SlabEdgeTypeSet Class


Size Property

[image]

Revit 2013 API
SlabEdgeTypeSet..::..Size Property
SlabEdgeTypeSet Class See Also Send Feedback
Returns the number of slab edge types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabEdgeTypeSet Class


SlabEdgeTypeSetIterator Class

[image]

Revit 2013 API
SlabEdgeTypeSetIterator Class
Members See Also Send Feedback
An iterator to a slab edge type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SlabEdgeTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SlabEdgeTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabEdgeTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabEdgeTypeSetIterator

See Also

SlabEdgeTypeSetIterator Members


SlabEdgeTypeSetIterator Members

[image] [image]

Revit 2013 API
SlabEdgeTypeSetIterator Members
SlabEdgeTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SlabEdgeTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Constructor

[image]

Revit 2013 API
SlabEdgeTypeSetIterator Constructor
SlabEdgeTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabEdgeTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
SlabEdgeTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Methods

[image] [image]

Revit 2013 API
SlabEdgeTypeSetIterator Methods
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabEdgeTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
SlabEdgeTypeSetIterator..::..MoveNext Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
SlabEdgeTypeSetIterator..::..Reset Method
SlabEdgeTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabEdgeTypeSetIterator Class


SlabEdgeTypeSetIterator Properties

[image] [image]

Revit 2013 API
SlabEdgeTypeSetIterator Properties
SlabEdgeTypeSetIterator Class See Also Send Feedback

The SlabEdgeTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabEdgeTypeSetIterator Class


Current Property

[image]

Revit 2013 API
SlabEdgeTypeSetIterator..::..Current Property
SlabEdgeTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabEdgeTypeSetIterator Class


SlabShapeCrease Class

[image]

Revit 2013 API
SlabShapeCrease Class
Members See Also Send Feedback
A crease used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabShapeCrease
Visual Basic
Public Class SlabShapeCrease
Visual C++
public ref class SlabShapeCrease

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeCrease

See Also

SlabShapeCrease Members


SlabShapeCrease Members

[image] [image]

Revit 2013 API
SlabShapeCrease Members
SlabShapeCrease Class Methods Properties See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


SlabShapeCrease Methods

[image] [image]

Revit 2013 API
SlabShapeCrease Methods
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCrease Class


SlabShapeCrease Properties

[image] [image]

Revit 2013 API
SlabShapeCrease Properties
SlabShapeCrease Class See Also Send Feedback

The SlabShapeCrease type exposes the following members.

Properties

 | Name | Description
Public property | CreaseType | The type of the crease.
Public property | Curve | The geometry of the crease.
Public property | EndPoints | The vertices of the crease.

See Also

SlabShapeCrease Class


CreaseType Property

[image]

Revit 2013 API
SlabShapeCrease..::..CreaseType Property
SlabShapeCrease Class See Also Send Feedback
The type of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeCreaseType CreaseType { get; }
Visual Basic
Public ReadOnly Property CreaseType As SlabShapeCreaseType
    Get
Visual C++
public:
property SlabShapeCreaseType CreaseType {
    SlabShapeCreaseType get ();
}

See Also

SlabShapeCrease Class


Curve Property

[image]

Revit 2013 API
SlabShapeCrease..::..Curve Property
SlabShapeCrease Class See Also Send Feedback
The geometry of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

SlabShapeCrease Class


EndPoints Property

[image]

Revit 2013 API
SlabShapeCrease..::..EndPoints Property
SlabShapeCrease Class See Also Send Feedback
The vertices of the crease.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertexArray EndPoints { get; }
Visual Basic
Public ReadOnly Property EndPoints As SlabShapeVertexArray
    Get
Visual C++
public:
property SlabShapeVertexArray^ EndPoints {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeCrease Class


SlabShapeCreaseArray Class

[image]

Revit 2013 API
SlabShapeCreaseArray Class
Members See Also Send Feedback
An array that can contain any number of creases used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabShapeCreaseArray : APIObject,
    IEnumerable
Visual Basic
Public Class SlabShapeCreaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeCreaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeCreaseArray

See Also

SlabShapeCreaseArray Members


SlabShapeCreaseArray Members

[image] [image]

Revit 2013 API
SlabShapeCreaseArray Members
SlabShapeCreaseArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeCreaseArray | Initializes a new instance of the SlabShapeCreaseArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Constructor

[image]

Revit 2013 API
SlabShapeCreaseArray Constructor
SlabShapeCreaseArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeCreaseArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeCreaseArray()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeCreaseArray()

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Methods

[image] [image]

Revit 2013 API
SlabShapeCreaseArray Methods
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArray Class


Append Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..Append Method
SlabShapeCreaseArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeCrease item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SlabShapeCrease _
)
Visual C++
public:
virtual void Append(
    SlabShapeCrease^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The item to be added.

See Also

SlabShapeCreaseArray Class


Clear Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..Clear Method
SlabShapeCreaseArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeCreaseArray Class


ForwardIterator Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..ForwardIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


GetEnumerator Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..GetEnumerator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabShapeCreaseArray Class


Insert Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..Insert Method
SlabShapeCreaseArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeCrease item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SlabShapeCrease, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeCrease^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeCreaseArray Class


ReverseIterator Method

[image]

Revit 2013 API
SlabShapeCreaseArray..::..ReverseIterator Method
SlabShapeCreaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeCreaseArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SlabShapeCreaseArrayIterator
Visual C++
public:
virtual SlabShapeCreaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArray Properties

[image] [image]

Revit 2013 API
SlabShapeCreaseArray Properties
SlabShapeCreaseArray Class See Also Send Feedback

The SlabShapeCreaseArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeCreaseArray Class


IsEmpty Property

[image]

Revit 2013 API
SlabShapeCreaseArray..::..IsEmpty Property
SlabShapeCreaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeCreaseArray Class


Item Property

[image]

Revit 2013 API
SlabShapeCreaseArray..::..Item Property
SlabShapeCreaseArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeCrease this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeCrease
    Get
    Set
Visual C++
public:
virtual property SlabShapeCrease^ Item[int index] {
    SlabShapeCrease^ get (int index);
    void set (int index, SlabShapeCrease^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeCreaseArray Class


Size Property

[image]

Revit 2013 API
SlabShapeCreaseArray..::..Size Property
SlabShapeCreaseArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeCreaseArray Class


SlabShapeCreaseArrayIterator Class

[image]

Revit 2013 API
SlabShapeCreaseArrayIterator Class
Members See Also Send Feedback
An iterator to an array of creases used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SlabShapeCreaseArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SlabShapeCreaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeCreaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeCreaseArrayIterator

See Also

SlabShapeCreaseArrayIterator Members


SlabShapeCreaseArrayIterator Members

[image] [image]

Revit 2013 API
SlabShapeCreaseArrayIterator Members
SlabShapeCreaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeCreaseArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Constructor

[image]

Revit 2013 API
SlabShapeCreaseArrayIterator Constructor
SlabShapeCreaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeCreaseArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeCreaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Methods

[image] [image]

Revit 2013 API
SlabShapeCreaseArrayIterator Methods
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeCreaseArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
SlabShapeCreaseArrayIterator..::..MoveNext Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


Reset Method

[image]

Revit 2013 API
SlabShapeCreaseArrayIterator..::..Reset Method
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseArrayIterator Properties

[image] [image]

Revit 2013 API
SlabShapeCreaseArrayIterator Properties
SlabShapeCreaseArrayIterator Class See Also Send Feedback

The SlabShapeCreaseArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeCreaseArrayIterator Class


Current Property

[image]

Revit 2013 API
SlabShapeCreaseArrayIterator..::..Current Property
SlabShapeCreaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeCreaseArrayIterator Class


SlabShapeCreaseType Enumeration

[image]

Revit 2013 API
SlabShapeCreaseType Enumeration
See Also Send Feedback
An enumerated type listing all Crease types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SlabShapeCreaseType
Visual Basic
Public Enumeration SlabShapeCreaseType
Visual C++
public enum class SlabShapeCreaseType

Members

Member name | Description
Invalid | The type of Crease is Invalid.
Boundary | The type of Crease is Boundary.
UserDrawn | The type of Crease is UserDrawn.
Auto | The type of Crease is Auto.

See Also


SlabShapeEditor Class

[image]

Revit 2013 API
SlabShapeEditor Class
Members See Also Send Feedback
An object used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabShapeEditor
Visual Basic
Public Class SlabShapeEditor
Visual C++
public ref class SlabShapeEditor

Remarks

The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeEditor

See Also

SlabShapeEditor Members


SlabShapeEditor Members

[image] [image]

Revit 2013 API
SlabShapeEditor Members
SlabShapeEditor Class Methods Properties See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class


SlabShapeEditor Methods

[image] [image]

Revit 2013 API
SlabShapeEditor Methods
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Methods

 | Name | Description
Public method | DrawPoint | Adds a point to the corresponding slab, roof or floor.
Public method | DrawSplitLine | Draws a split line on the corresponding slab, roof or floor.
Public method | Enable | Enables the slab shape editing functionality.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.
Public method | PickSupport | Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public method | ResetSlabShape | Removes the modifications made during editing and resets the element geometry back to the unmodified state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeEditor Class


DrawPoint Method

[image]

Revit 2013 API
SlabShapeEditor..::..DrawPoint Method
SlabShapeEditor Class See Also Send Feedback
Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertex DrawPoint(
    XYZ location
)
Visual Basic
Public Function DrawPoint ( _
    location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
    XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.DB..::..XYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return nullNothingnullptra null reference (Nothing in Visual Basic). Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the location is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SlabShapeEditor Class


DrawSplitLine Method

[image]

Revit 2013 API
SlabShapeEditor..::..DrawSplitLine Method
SlabShapeEditor Class See Also Send Feedback
Draws a split line on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeCreaseArray DrawSplitLine(
    SlabShapeVertex startVertex,
    SlabShapeVertex endVertex
)
Visual Basic
Public Function DrawSplitLine ( _
    startVertex As SlabShapeVertex, _
    endVertex As SlabShapeVertex _
) As SlabShapeCreaseArray
Visual C++
public:
SlabShapeCreaseArray^ DrawSplitLine(
    SlabShapeVertex^ startVertex,
    SlabShapeVertex^ endVertex
)

Parameters

startVertex
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex to start the split line.
endVertex
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex to end the split line.

Return Value

The newly created creases.

Remarks

Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input vertex is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input vertex is invalid.

See Also

SlabShapeEditor Class


Enable Method

[image]

Revit 2013 API
SlabShapeEditor..::..Enable Method
SlabShapeEditor Class See Also Send Feedback
Enables the slab shape editing functionality.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Enable()
Visual Basic
Public Sub Enable
Visual C++
public:
void Enable()

See Also

SlabShapeEditor Class


ModifySubElement Method

[image] [image]

Revit 2013 API
SlabShapeEditor..::..ModifySubElement Method
SlabShapeEditor Class See Also Send Feedback
Manipulates an entity on the corresponding slab, roof or floor.

Overload List

 | Name | Description
Public method | ModifySubElement(SlabShapeCrease, Double) | Manipulates the crease on the corresponding slab, roof or floor.
Public method | ModifySubElement(SlabShapeVertex, Double) | Manipulates the vertex on the corresponding slab, roof or floor.

See Also

SlabShapeEditor Class
SlabShapeEditor Members


ModifySubElement Method (SlabShapeCrease, Double)

[image]

Revit 2013 API
SlabShapeEditor..::..ModifySubElement Method (SlabShapeCrease, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the crease on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeCrease crease,
    double offset
)
Visual Basic
Public Sub ModifySubElement ( _
    crease As SlabShapeCrease, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeCrease^ crease,
    double offset
)

Parameters

crease
Type: Autodesk.Revit.DB..::..SlabShapeCrease
The crease.
offset
Type: System..::..Double
The new value of the crease offset, which is the average of offsets of its ends.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the crease is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the crease is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


ModifySubElement Method (SlabShapeVertex, Double)

[image]

Revit 2013 API
SlabShapeEditor..::..ModifySubElement Method (SlabShapeVertex, Double)
SlabShapeEditor Class See Also Send Feedback
Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ModifySubElement(
    SlabShapeVertex vertex,
    double offset
)
Visual Basic
Public Sub ModifySubElement ( _
    vertex As SlabShapeVertex, _
    offset As Double _
)
Visual C++
public:
void ModifySubElement(
    SlabShapeVertex^ vertex,
    double offset
)

Parameters

vertex
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex.
offset
Type: System..::..Double
The new value of the vertex offset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the vertex is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the vertex is invalid.

See Also

SlabShapeEditor Class
ModifySubElement Overload


PickSupport Method

[image]

Revit 2013 API
SlabShapeEditor..::..PickSupport Method
SlabShapeEditor Class See Also Send Feedback
Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void PickSupport(
    Line gLine
)
Visual Basic
Public Sub PickSupport ( _
    gLine As Line _
)
Visual C++
public:
void PickSupport(
    Line^ gLine
)

Parameters

gLine
Type: Autodesk.Revit.DB..::..Line
A line from a support element such as a beam.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input line is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input line is invalid.

See Also

SlabShapeEditor Class


ResetSlabShape Method

[image]

Revit 2013 API
SlabShapeEditor..::..ResetSlabShape Method
SlabShapeEditor Class Example See Also Send Feedback
Removes the modifications made during editing and resets the element geometry back to the unmodified state.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ResetSlabShape()
Visual Basic
Public Sub ResetSlabShape
Visual C++
public:
void ResetSlabShape()

Remarks

Calling this method will reset the slab back to its original state and disable Slab Shape Editing. If further editing is needed, call Enable again.

Examples

CopyC#
private void ResetSlabShapes(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    Selection choices = uidoc.Selection;
    ElementSet collection = choices.Elements;
    foreach (Autodesk.Revit.DB.Element elem in collection)
    {
        Floor floor = elem as Floor;
        if (floor != null)
        {
            SlabShapeEditor slabShapeEditor = floor.SlabShapeEditor;
            slabShapeEditor.ResetSlabShape();
        }
    }

}
CopyVB.NET
Private Sub ResetSlabShapes(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
    Dim collection As ElementSet = choices.Elements
    For Each elem As Autodesk.Revit.DB.Element In collection
        Dim floor As Floor = TryCast(elem, Floor)
        If floor IsNot Nothing Then
            Dim slabShapeEditor As SlabShapeEditor = floor.SlabShapeEditor
            slabShapeEditor.ResetSlabShape()
        End If
    Next

End Sub

See Also

SlabShapeEditor Class


SlabShapeEditor Properties

[image] [image]

Revit 2013 API
SlabShapeEditor Properties
SlabShapeEditor Class See Also Send Feedback

The SlabShapeEditor type exposes the following members.

Properties

 | Name | Description
Public property | IsEnabled | Identifies if the slab shape editing functionality is enabled.
Public property | SlabShapeCreases | All of the creases that can be edited.
Public property | SlabShapeVertices | All of the vertices that can be edited.

See Also

SlabShapeEditor Class


IsEnabled Property

[image]

Revit 2013 API
SlabShapeEditor..::..IsEnabled Property
SlabShapeEditor Class See Also Send Feedback
Identifies if the slab shape editing functionality is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEnabled { get; }
Visual Basic
Public ReadOnly Property IsEnabled As Boolean
    Get
Visual C++
public:
property bool IsEnabled {
    bool get ();
}

Remarks

If true, the creases and vertices are accessible and modifiable. If false, no creases and vertices are accessible.

See Also

SlabShapeEditor Class


SlabShapeCreases Property

[image]

Revit 2013 API
SlabShapeEditor..::..SlabShapeCreases Property
SlabShapeEditor Class See Also Send Feedback
All of the creases that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeCreaseArray SlabShapeCreases { get; }
Visual Basic
Public ReadOnly Property SlabShapeCreases As SlabShapeCreaseArray
    Get
Visual C++
public:
property SlabShapeCreaseArray^ SlabShapeCreases {
    SlabShapeCreaseArray^ get ();
}

See Also

SlabShapeEditor Class


SlabShapeVertices Property

[image]

Revit 2013 API
SlabShapeEditor..::..SlabShapeVertices Property
SlabShapeEditor Class See Also Send Feedback
All of the vertices that can be edited.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertexArray SlabShapeVertices { get; }
Visual Basic
Public ReadOnly Property SlabShapeVertices As SlabShapeVertexArray
    Get
Visual C++
public:
property SlabShapeVertexArray^ SlabShapeVertices {
    SlabShapeVertexArray^ get ();
}

See Also

SlabShapeEditor Class


SlabShapeVertex Class

[image]

Revit 2013 API
SlabShapeVertex Class
Members See Also Send Feedback
A vertex used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabShapeVertex
Visual Basic
Public Class SlabShapeVertex
Visual C++
public ref class SlabShapeVertex

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SlabShapeVertex

See Also

SlabShapeVertex Members


SlabShapeVertex Members

[image] [image]

Revit 2013 API
SlabShapeVertex Members
SlabShapeVertex Class Methods Properties See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Position | The position of the vertex.
Public property | VertexType | The type of the vertex.

See Also

SlabShapeVertex Class


SlabShapeVertex Methods

[image] [image]

Revit 2013 API
SlabShapeVertex Methods
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertex Class


SlabShapeVertex Properties

[image] [image]

Revit 2013 API
SlabShapeVertex Properties
SlabShapeVertex Class See Also Send Feedback

The SlabShapeVertex type exposes the following members.

Properties

 | Name | Description
Public property | Position | The position of the vertex.
Public property | VertexType | The type of the vertex.

See Also

SlabShapeVertex Class


Position Property

[image]

Revit 2013 API
SlabShapeVertex..::..Position Property
SlabShapeVertex Class See Also Send Feedback
The position of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Position { get; }
Visual Basic
Public ReadOnly Property Position As XYZ
    Get
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
}

See Also

SlabShapeVertex Class


VertexType Property

[image]

Revit 2013 API
SlabShapeVertex..::..VertexType Property
SlabShapeVertex Class See Also Send Feedback
The type of the vertex.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertexType VertexType { get; }
Visual Basic
Public ReadOnly Property VertexType As SlabShapeVertexType
    Get
Visual C++
public:
property SlabShapeVertexType VertexType {
    SlabShapeVertexType get ();
}

See Also

SlabShapeVertex Class


SlabShapeVertexArray Class

[image]

Revit 2013 API
SlabShapeVertexArray Class
Members See Also Send Feedback
An array that can contain any number of vertices used in Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SlabShapeVertexArray : APIObject,
    IEnumerable
Visual Basic
Public Class SlabShapeVertexArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SlabShapeVertexArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeVertexArray

See Also

SlabShapeVertexArray Members


SlabShapeVertexArray Members

[image] [image]

Revit 2013 API
SlabShapeVertexArray Members
SlabShapeVertexArray Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeVertexArray | Initializes a new instance of the SlabShapeVertexArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Constructor

[image]

Revit 2013 API
SlabShapeVertexArray Constructor
SlabShapeVertexArray Class See Also Send Feedback
Initializes a new instance of the SlabShapeVertexArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertexArray()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeVertexArray()

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Methods

[image] [image]

Revit 2013 API
SlabShapeVertexArray Methods
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArray Class


Append Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..Append Method
SlabShapeVertexArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    SlabShapeVertex item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SlabShapeVertex _
)
Visual C++
public:
virtual void Append(
    SlabShapeVertex^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The item to be added.

See Also

SlabShapeVertexArray Class


Clear Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..Clear Method
SlabShapeVertexArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SlabShapeVertexArray Class


ForwardIterator Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..ForwardIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SlabShapeVertexArray Class


GetEnumerator Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..GetEnumerator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SlabShapeVertexArray Class


Insert Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..Insert Method
SlabShapeVertexArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    SlabShapeVertex item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SlabShapeVertex, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SlabShapeVertex^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SlabShapeVertex
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

SlabShapeVertexArray Class


ReverseIterator Method

[image]

Revit 2013 API
SlabShapeVertexArray..::..ReverseIterator Method
SlabShapeVertexArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeVertexArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SlabShapeVertexArrayIterator
Visual C++
public:
virtual SlabShapeVertexArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SlabShapeVertexArray Class


SlabShapeVertexArray Properties

[image] [image]

Revit 2013 API
SlabShapeVertexArray Properties
SlabShapeVertexArray Class See Also Send Feedback

The SlabShapeVertexArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

SlabShapeVertexArray Class


IsEmpty Property

[image]

Revit 2013 API
SlabShapeVertexArray..::..IsEmpty Property
SlabShapeVertexArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SlabShapeVertexArray Class


Item Property

[image]

Revit 2013 API
SlabShapeVertexArray..::..Item Property
SlabShapeVertexArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SlabShapeVertex this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As SlabShapeVertex
    Get
    Set
Visual C++
public:
virtual property SlabShapeVertex^ Item[int index] {
    SlabShapeVertex^ get (int index);
    void set (int index, SlabShapeVertex^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

SlabShapeVertexArray Class


Size Property

[image]

Revit 2013 API
SlabShapeVertexArray..::..Size Property
SlabShapeVertexArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SlabShapeVertexArray Class


SlabShapeVertexArrayIterator Class

[image]

Revit 2013 API
SlabShapeVertexArrayIterator Class
Members See Also Send Feedback
An iterator to an array of vertices used for Slab Shape Editing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SlabShapeVertexArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SlabShapeVertexArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SlabShapeVertexArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SlabShapeVertexArrayIterator

See Also

SlabShapeVertexArrayIterator Members


SlabShapeVertexArrayIterator Members

[image] [image]

Revit 2013 API
SlabShapeVertexArrayIterator Members
SlabShapeVertexArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SlabShapeVertexArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Constructor

[image]

Revit 2013 API
SlabShapeVertexArrayIterator Constructor
SlabShapeVertexArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SlabShapeVertexArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SlabShapeVertexArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Methods

[image] [image]

Revit 2013 API
SlabShapeVertexArrayIterator Methods
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SlabShapeVertexArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
SlabShapeVertexArrayIterator..::..MoveNext Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


Reset Method

[image]

Revit 2013 API
SlabShapeVertexArrayIterator..::..Reset Method
SlabShapeVertexArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexArrayIterator Properties

[image] [image]

Revit 2013 API
SlabShapeVertexArrayIterator Properties
SlabShapeVertexArrayIterator Class See Also Send Feedback

The SlabShapeVertexArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SlabShapeVertexArrayIterator Class


Current Property

[image]

Revit 2013 API
SlabShapeVertexArrayIterator..::..Current Property
SlabShapeVertexArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SlabShapeVertexArrayIterator Class


SlabShapeVertexType Enumeration

[image]

Revit 2013 API
SlabShapeVertexType Enumeration
See Also Send Feedback
An enumerated type listing all Vertex types of Slab Shape Edit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SlabShapeVertexType
Visual Basic
Public Enumeration SlabShapeVertexType
Visual C++
public enum class SlabShapeVertexType

Members

Member name | Description
Invalid | The type of Vertex is Invalid.
Corner | The type of Vertex is Corner.
Edge | The type of Vertex is Edge.
Interior | The type of Vertex is Interior.

See Also


SlantedOrVerticalColumnType Enumeration

[image]

Revit 2013 API
SlantedOrVerticalColumnType Enumeration
See Also Send Feedback
This enum class is used for the BuiltInParameter SLANTED_COLUMN_TYPE_PARAM.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SlantedOrVerticalColumnType
Visual Basic
Public Enumeration SlantedOrVerticalColumnType
Visual C++
public enum class SlantedOrVerticalColumnType

Members

Member name | Description
CT_Vertical |
CT_Angle |
CT_EndPoint |

See Also


Solid Class

[image]

Revit 2013 API
Solid Class
Members Example See Also Send Feedback
A 3d solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Solid : GeometryObject
Visual Basic
Public Class Solid _
    Inherits GeometryObject
Visual C++
public ref class Solid : public GeometryObject

Remarks

A solid is defined by the faces and edges that form its boundary.

Examples

CopyC#
private void GetAndTransformSolidInfo(Application application, Element element, Options geoOptions)
{
    // Get geometry element of the selected element
    Autodesk.Revit.DB.GeometryElement geoElement = element.get_Geometry(geoOptions);

    // Get geometry object
    foreach (GeometryObject geoObject in geoElement.Objects)
    {
        // Get the geometry instance which contains the geometry information
        Autodesk.Revit.DB.GeometryInstance instance = geoObject as Autodesk.Revit.DB.GeometryInstance;
        if (null != instance)
        {
            foreach (GeometryObject instObj in instance.SymbolGeometry.Objects)
            {
                Solid solid = instObj as Solid;
                if (null == solid || 0 == solid.Faces.Size || 0 == solid.Edges.Size)
                {
                    continue;
                }

                Transform instTransform = instance.Transform;
                // Get the faces and edges from solid, and transform the formed points
                foreach (Face face in solid.Faces)
                {
                    Mesh mesh = face.Triangulate();
                    foreach (XYZ ii in mesh.Vertices)
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
                foreach (Edge edge in solid.Edges)
                {
                   foreach (XYZ ii in edge.Tessellate())
                    {
                       XYZ point = ii;
                        XYZ transformedPoint = instTransform.OfPoint(point);
                    }
                }
            }
        }
    }

}
CopyVB.NET
Private Sub GetAndTransformSolidInfo(ByVal application As Application, ByVal element As Autodesk.Revit.DB.Element, ByVal geoOptions As Autodesk.Revit.DB.Options)
    ' Get geometry element of the selected element
    Dim geoElement As Autodesk.Revit.DB.GeometryElement = element.Geometry(geoOptions)

    ' Get geometry object
    For Each geoObject As GeometryObject In geoElement.Objects
        ' Get the geometry instance which contains the geometry information
        Dim instance As Autodesk.Revit.DB.GeometryInstance = TryCast(geoObject, Autodesk.Revit.DB.GeometryInstance)
        If instance IsNot Nothing Then
            For Each instObj As GeometryObject In instance.SymbolGeometry.Objects
                Dim solid As Solid = TryCast(instObj, Solid)
                If solid Is Nothing OrElse 0 = solid.Faces.Size OrElse 0 = solid.Edges.Size Then
                    Continue For
                End If

                Dim instTransform As Transform = instance.Transform
                ' Get the faces and edges from solid, and transform the formed points
                For Each face As Autodesk.Revit.DB.Face In solid.Faces
                    Dim mesh As Mesh = face.Triangulate()
                    For Each ii As Autodesk.Revit.DB.XYZ In mesh.Vertices
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
                For Each edge As Autodesk.Revit.DB.Edge In solid.Edges
                    For Each ii As Autodesk.Revit.DB.XYZ In edge.Tessellate()
                        Dim point As Autodesk.Revit.DB.XYZ = ii
                        Dim transformedPoint As Autodesk.Revit.DB.XYZ = instTransform.OfPoint(point)
                    Next
                Next
            Next
        End If
    Next

End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Solid

See Also

Solid Members


Solid Members

[image] [image]

Revit 2013 API
Solid Members
Solid Class Methods Properties See Also Send Feedback

The Solid type exposes the following members.

Methods

 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid Class


Solid Methods

[image] [image]

Revit 2013 API
Solid Methods
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Methods

 | Name | Description
Public method | ComputeCentroid | Returns the Centroid of this solid.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from GeometryObject.)
Public method | GetHashCode | Gets the integer value of the geometry object as hash code; (Inherited from GeometryObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Solid Class


ComputeCentroid Method

[image]

Revit 2013 API
Solid..::..ComputeCentroid Method
Solid Class See Also Send Feedback
Returns the Centroid of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ ComputeCentroid()
Visual Basic
Public Function ComputeCentroid As XYZ
Visual C++
public:
XYZ^ ComputeCentroid()

Return Value

The XYZ point of the Centroid of this solid.

Remarks

Calculates the centroid of the solid using an approximation, with an accuracy suitable for architectural purposes. This will correspond only with the center of gravity if the solid represents a homogeneous structure of a single material.

See Also

Solid Class


Solid Properties

[image] [image]

Revit 2013 API
Solid Properties
Solid Class See Also Send Feedback

The Solid type exposes the following members.

Properties

 | Name | Description
Public property | Edges | The edges that belong to the solid.
Public property | Faces | The faces that belong to the solid.
Public property | GraphicsStyleId | The ElementId of the GeometryObject's GraphicsStyle; (Inherited from GeometryObject.)
Public property | IsElementGeometry | Indicates whether this geometry is obtained directly from an Element. (Inherited from GeometryObject.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | SurfaceArea | Returns the total surface area of this solid.
Public property | Visibility | The visibility. (Inherited from GeometryObject.)
Public property | Volume | Returns the signed volume of this solid.

See Also

Solid Class


Edges Property

[image]

Revit 2013 API
Solid..::..Edges Property
Solid Class See Also Send Feedback
The edges that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EdgeArray Edges { get; }
Visual Basic
Public ReadOnly Property Edges As EdgeArray
    Get
Visual C++
public:
property EdgeArray^ Edges {
    EdgeArray^ get ();
}

See Also

Solid Class


Faces Property

[image]

Revit 2013 API
Solid..::..Faces Property
Solid Class Example See Also Send Feedback
The faces that belong to the solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FaceArray Faces { get; }
Visual Basic
Public ReadOnly Property Faces As FaceArray
    Get
Visual C++
public:
property FaceArray^ Faces {
    FaceArray^ get ();
}

Remarks

A face may be degenerate. This can be determined with the Face property IsTwoSided.

Examples

CopyC#
private void GetFacesAndEdges(Wall wall)
{
    String faceInfo = "";

    Autodesk.Revit.DB.Options opt = new Options();
    Autodesk.Revit.DB.GeometryElement geomElem = wall.get_Geometry(opt);
    foreach (GeometryObject geomObj in geomElem.Objects)
    {
        Solid geomSolid = geomObj as Solid;
        if (null != geomSolid)
        {
            int faces = 0;
            double totalArea = 0;
            foreach (Face geomFace in geomSolid.Faces)
            {
                faces++;
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + "\n";
                totalArea += geomFace.Area;
            }
            faceInfo += "Number of faces: " + faces + "\n";
            faceInfo += "Total area: " + totalArea.ToString() + "\n";
            foreach (Edge geomEdge in geomSolid.Edges)
            {
                // get wall's geometry edges
            }
        }
    }

    TaskDialog.Show("Revit",faceInfo);
}
CopyVB.NET
Private Sub GetFacesAndEdges(ByVal wall As Wall)
    Dim faceInfo As [String] = ""

    Dim opt As Autodesk.Revit.DB.Options = New Autodesk.Revit.DB.Options()
    Dim geomElem As Autodesk.Revit.DB.GeometryElement = wall.Geometry(opt)
    For Each geomObj As GeometryObject In geomElem.Objects
        Dim geomSolid As Solid = TryCast(geomObj, Solid)
        If geomSolid IsNot Nothing Then
            Dim faces As Integer = 0
            Dim totalArea As Double = 0
            For Each geomFace As Autodesk.Revit.DB.Face In geomSolid.Faces
                System.Math.Max(System.Threading.Interlocked.Increment(faces), faces - 1)
                faceInfo += "Face " + faces + " area: " + geomFace.Area.ToString() + vbLf
                totalArea += geomFace.Area
            Next
            faceInfo += "Number of faces: " + faces + vbLf
            faceInfo += "Total area: " + totalArea.ToString() + vbLf
            ' get wall's geometry edges
            For Each geomEdge As Autodesk.Revit.DB.Edge In geomSolid.Edges
            Next
        End If
    Next

    TaskDialog.Show("Revit", faceInfo)
End Sub

See Also

Solid Class


SurfaceArea Property

[image]

Revit 2013 API
Solid..::..SurfaceArea Property
Solid Class See Also Send Feedback
Returns the total surface area of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SurfaceArea { get; }
Visual Basic
Public ReadOnly Property SurfaceArea As Double
    Get
Visual C++
public:
property double SurfaceArea {
    double get ();
}

Return Value

The real number equal to the total area of this solid.

Remarks

Calculates the surface area by adding together the areas of faces comprising this solid. Will slightly underestimate if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this solid is not a valid Geometry object.

See Also

Solid Class


Volume Property

[image]

Revit 2013 API
Solid..::..Volume Property
Solid Class See Also Send Feedback
Returns the signed volume of this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

Return Value

The real number equal to the signed volume of this solid.

Remarks

Revit attempts to compute the volume analytically, if possible. If an analytical solution is not possible, it uses tessellated faces to calculate a reasonable approximation for the volume. The calculated volume may be slightly underestimated or overestimated if curved surfaces are present.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this solid is not a valid Geometry object or the volume calculation failed.

See Also

Solid Class


SolidArray Class

[image]

Revit 2013 API
SolidArray Class
Members See Also Send Feedback
An array that contains solids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SolidArray : APIObject, IEnumerable
Visual Basic
Public Class SolidArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SolidArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SolidArray

See Also

SolidArray Members


SolidArray Members

[image] [image]

Revit 2013 API
SolidArray Members
SolidArray Class Constructors Methods Properties See Also Send Feedback

The SolidArray type exposes the following members.

Constructors

 | Name | Description
Public method | SolidArray | Initializes a new instance of the SolidArray class

Methods

 | Name | Description
Public method | Append | Add the solid to the end of the array.
Public method | Clear | Removes every solid from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified solid into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a solid at a specified index within the array.
Public property | Size | Returns the number of solids that are in the array.

See Also

SolidArray Class


SolidArray Constructor

[image]

Revit 2013 API
SolidArray Constructor
SolidArray Class See Also Send Feedback
Initializes a new instance of the SolidArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SolidArray()
Visual Basic
Public Sub New
Visual C++
public:
SolidArray()

See Also

SolidArray Class


SolidArray Methods

[image] [image]

Revit 2013 API
SolidArray Methods
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the solid to the end of the array.
Public method | Clear | Removes every solid from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified solid into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArray Class


Append Method

[image]

Revit 2013 API
SolidArray..::..Append Method
SolidArray Class See Also Send Feedback
Add the solid to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    Solid item
)
Visual Basic
Public Overridable Sub Append ( _
    item As Solid _
)
Visual C++
public:
virtual void Append(
    Solid^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..Solid
The solid to be added.

See Also

SolidArray Class


Clear Method

[image]

Revit 2013 API
SolidArray..::..Clear Method
SolidArray Class See Also Send Feedback
Removes every solid from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SolidArray Class


ForwardIterator Method

[image]

Revit 2013 API
SolidArray..::..ForwardIterator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SolidArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SolidArray Class


GetEnumerator Method

[image]

Revit 2013 API
SolidArray..::..GetEnumerator Method
SolidArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SolidArray Class


Insert Method

[image]

Revit 2013 API
SolidArray..::..Insert Method
SolidArray Class See Also Send Feedback
Insert the specified solid into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    Solid item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As Solid, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    Solid^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..Solid
The solid to be inserted into the array.
index
Type: System..::..Int32
The solid will be inserted before this index.

Return Value

Returns whether the solid was inserted into the array.

See Also

SolidArray Class


ReverseIterator Method

[image]

Revit 2013 API
SolidArray..::..ReverseIterator Method
SolidArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SolidArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SolidArrayIterator
Visual C++
public:
virtual SolidArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SolidArray Class


SolidArray Properties

[image] [image]

Revit 2013 API
SolidArray Properties
SolidArray Class See Also Send Feedback

The SolidArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a solid at a specified index within the array.
Public property | Size | Returns the number of solids that are in the array.

See Also

SolidArray Class


IsEmpty Property

[image]

Revit 2013 API
SolidArray..::..IsEmpty Property
SolidArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SolidArray Class


Item Property

[image]

Revit 2013 API
SolidArray..::..Item Property
SolidArray Class See Also Send Feedback
Gets or sets a solid at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Solid this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As Solid
    Get
    Set
Visual C++
public:
virtual property Solid^ Item[int index] {
    Solid^ get (int index);
    void set (int index, Solid^ value);
}

Parameters

index
Type: System..::..Int32
The index of the solid to be set or retrieved.

Return Value

Returns the solid at the specified index.

See Also

SolidArray Class


Size Property

[image]

Revit 2013 API
SolidArray..::..Size Property
SolidArray Class See Also Send Feedback
Returns the number of solids that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SolidArray Class


SolidArrayIterator Class

[image]

Revit 2013 API
SolidArrayIterator Class
Members See Also Send Feedback
An iterator to a solids array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SolidArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SolidArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SolidArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SolidArrayIterator

See Also

SolidArrayIterator Members


SolidArrayIterator Members

[image] [image]

Revit 2013 API
SolidArrayIterator Members
SolidArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SolidArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class


SolidArrayIterator Constructor

[image]

Revit 2013 API
SolidArrayIterator Constructor
SolidArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SolidArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SolidArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SolidArrayIterator Class


SolidArrayIterator Methods

[image] [image]

Revit 2013 API
SolidArrayIterator Methods
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
SolidArrayIterator..::..MoveNext Method
SolidArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SolidArrayIterator Class


Reset Method

[image]

Revit 2013 API
SolidArrayIterator..::..Reset Method
SolidArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SolidArrayIterator Class


SolidArrayIterator Properties

[image] [image]

Revit 2013 API
SolidArrayIterator Properties
SolidArrayIterator Class See Also Send Feedback

The SolidArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SolidArrayIterator Class


Current Property

[image]

Revit 2013 API
SolidArrayIterator..::..Current Property
SolidArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SolidArrayIterator Class


SolidGeometry Enumeration

[image]

Revit 2013 API
SolidGeometry Enumeration
See Also Send Feedback
An enumerated type listing possible ways of exporting solids in 3D views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SolidGeometry
Visual Basic
Public Enumeration SolidGeometry
Visual C++
public enum class SolidGeometry

Members

Member name | Description
Polymesh | All visible solids are exported as polymesh.
ACIS | All visible Revit Building geometry is exported as ACIS 3D solids (except for any elements that are already a polymesh.)

See Also


SolidOrShellTessellationControls Class

[image]

Revit 2013 API
SolidOrShellTessellationControls Class
Members See Also Send Feedback
Controls various aspects of the triangulation produced by SolutUtils::tessellateSolidOrShell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SolidOrShellTessellationControls : IDisposable
Visual Basic
Public Class SolidOrShellTessellationControls _
    Implements IDisposable
Visual C++
public ref class SolidOrShellTessellationControls : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidOrShellTessellationControls

See Also

SolidOrShellTessellationControls Members


SolidOrShellTessellationControls Members

[image] [image]

Revit 2013 API
SolidOrShellTessellationControls Members
SolidOrShellTessellationControls Class Constructors Methods Properties See Also Send Feedback

The SolidOrShellTessellationControls type exposes the following members.

Constructors

 | Name | Description
Public method | SolidOrShellTessellationControls | Default constructor.

Methods

 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose | Releases all resources used by the SolidOrShellTessellationControls
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Properties

 | Name | Description
Public property | Accuracy | A positive real number specifying how accurately a triangulation should approximate a solid or shell.
Public property | LevelOfDetail | An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Public property | MinAngleInTriangle | A positive real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Public property | MinExternalAngleBetweenTriangles | A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

See Also

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls Constructor

[image]

Revit 2013 API
SolidOrShellTessellationControls Constructor
SolidOrShellTessellationControls Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SolidOrShellTessellationControls()
Visual Basic
Public Sub New
Visual C++
public:
SolidOrShellTessellationControls()

See Also

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls Methods

[image] [image]

Revit 2013 API
SolidOrShellTessellationControls Methods
SolidOrShellTessellationControls Class See Also Send Feedback

The SolidOrShellTessellationControls type exposes the following members.

Methods

 | Name | Description
Public method | DisableLevelOfDetail | Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UseLevelOfDetail | Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

See Also

SolidOrShellTessellationControls Class


DisableLevelOfDetail Method

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..DisableLevelOfDetail Method
SolidOrShellTessellationControls Class See Also Send Feedback
Disables the use of levelOfDetail. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void DisableLevelOfDetail()
Visual Basic
Public Sub DisableLevelOfDetail
Visual C++
public:
void DisableLevelOfDetail()

See Also

SolidOrShellTessellationControls Class


Dispose Method

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..Dispose Method
SolidOrShellTessellationControls Class See Also Send Feedback
Releases all resources used by the SolidOrShellTessellationControls

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidOrShellTessellationControls Class


UseLevelOfDetail Method

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..UseLevelOfDetail Method
SolidOrShellTessellationControls Class See Also Send Feedback
Returns true if the use of levelOfDetail is enabled, false if not. The use of levelOfDetail is enabled by calling setLevelOfDetail (with a valid input).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool UseLevelOfDetail()
Visual Basic
Public Function UseLevelOfDetail As Boolean
Visual C++
public:
bool UseLevelOfDetail()

See Also

SolidOrShellTessellationControls Class


SolidOrShellTessellationControls Properties

[image] [image]

Revit 2013 API
SolidOrShellTessellationControls Properties
SolidOrShellTessellationControls Class See Also Send Feedback

The SolidOrShellTessellationControls type exposes the following members.

Properties

 | Name | Description
Public property | Accuracy | A positive real number specifying how accurately a triangulation should approximate a solid or shell.
Public property | LevelOfDetail | An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.
Public property | MinAngleInTriangle | A positive real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Public property | MinExternalAngleBetweenTriangles | A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

See Also

SolidOrShellTessellationControls Class


Accuracy Property

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..Accuracy Property
SolidOrShellTessellationControls Class See Also Send Feedback
A positive real number specifying how accurately a triangulation should approximate a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Accuracy { get; set; }
Visual Basic
Public Property Accuracy As Double
    Get
    Set
Visual C++
public:
property double Accuracy {
    double get ();
    void set (double value);
}

Remarks

The maximum distance from a point on the triangulation to the nearest point on the solid or shell should be no greater than the specified accuracy. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for accuracy must be greater than 0 and no more than 30000 feet.

See Also

SolidOrShellTessellationControls Class


LevelOfDetail Property

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..LevelOfDetail Property
SolidOrShellTessellationControls Class See Also Send Feedback
An number between 0 and 1 (inclusive) specifying the level of detail for the triangulation of a solid or shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LevelOfDetail { get; set; }
Visual Basic
Public Property LevelOfDetail As Double
    Get
    Set
Visual C++
public:
property double LevelOfDetail {
    double get ();
    void set (double value);
}

Remarks

Smaller values yield coarser triangulations (fewer triangles), while larger values yield finer triangulations (more triangles).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for levelOfDetail must lie between 0 and 1 (inclusive).

See Also

SolidOrShellTessellationControls Class


MinAngleInTriangle Property

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..MinAngleInTriangle Property
SolidOrShellTessellationControls Class See Also Send Feedback
A positive real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinAngleInTriangle { get; set; }
Visual Basic
Public Property MinAngleInTriangle As Double
    Get
    Set
Visual C++
public:
property double MinAngleInTriangle {
    double get ();
    void set (double value);
}

Remarks

A small value can be useful when triangulating long, thin objects, in order to keep the number of triangles small, but it can result in long, thin triangles, which are not acceptable for all applications. If the value is too large, this constraint may not be satisfiable, causing the triangulation to fail. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minAngleInTriangle must lie between 0 and 60 degrees (exclusive), expressed in radians.

See Also

SolidOrShellTessellationControls Class


MinExternalAngleBetweenTriangles Property

[image]

Revit 2013 API
SolidOrShellTessellationControls..::..MinExternalAngleBetweenTriangles Property
SolidOrShellTessellationControls Class See Also Send Feedback
A positive real number specifying the minimum allowed value for the external angle between two adjacent triangles, in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinExternalAngleBetweenTriangles { get; set; }
Visual Basic
Public Property MinExternalAngleBetweenTriangles As Double
    Get
    Set
Visual C++
public:
property double MinExternalAngleBetweenTriangles {
    double get ();
    void set (double value);
}

Remarks

A small value yields more smoothly curved triangulated surfaces, usually at the expense of an increase in the number of triangles. Note that this setting has no effect for planar surfaces. This constraint may be approximately enforced.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minExternalAngleBetweenTriangles must be greater than 0 and no more than 30000 feet.

See Also

SolidOrShellTessellationControls Class


SolidSolidCutUtils Class

[image]

Revit 2013 API
SolidSolidCutUtils Class
Members See Also Send Feedback
Exposes utilities which can cause one solid to cut another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SolidSolidCutUtils : IDisposable
Visual Basic
Public Class SolidSolidCutUtils _
    Implements IDisposable
Visual C++
public ref class SolidSolidCutUtils : IDisposable

Remarks

These utilities are applicable for the generic forms, geometry combinations and family instances in conceptual model, pattern based curtain panel, or adaptive component families, and family instances which are permitted to participate in joining in projects. Thus, for example, a beam cannot cut a wall (as the wall is not a family instance) in projects. Nor can a steel beam participate in cutting another family (because steel beams do not participate in joining).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidSolidCutUtils

See Also

SolidSolidCutUtils Members


SolidSolidCutUtils Members

[image] [image]

Revit 2013 API
SolidSolidCutUtils Members
SolidSolidCutUtils Class Methods See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
 | AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
 | CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
 | CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
Public method | Dispose | Releases all resources used by the SolidSolidCutUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingSolids | Gets all the solids which cut the input element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSolidsBeingCut | Get all the solids which are cut by the input element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
 | IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
 | RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
 | SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class


SolidSolidCutUtils Methods

[image] [image]

Revit 2013 API
SolidSolidCutUtils Methods
SolidSolidCutUtils Class See Also Send Feedback

The SolidSolidCutUtils type exposes the following members.

Methods

 | Name | Description
 | AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
 | AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
 | CanElementCutElement | Verifies if the cutting element can add a solid cut to the target element.
 | CutExistsBetweenElements | Checks that if there is a solid-solid cut between two elements.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCuttingSolids | Gets all the solids which cut the input element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSolidsBeingCut | Get all the solids which are cut by the input element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsAllowedForSolidCut | Validates that the element is eligible for a solid-solid cut.
 | IsElementFromAppropriateContext | Validates that the element is from an appropriate document.
 | RemoveCutBetweenSolids | Removes the solid-solid cut between the two elements if it exists.
 | SplitFacesOfCuttingSolid | Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidSolidCutUtils Class


AddCutBetweenSolids Method

[image] [image]

Revit 2013 API
SolidSolidCutUtils..::..AddCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback

Overload List

Name | Description
AddCutBetweenSolids(Document, Element, Element) | Adds a solid-solid cut for the two elements.
AddCutBetweenSolids(Document, Element, Element, Boolean) | Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.

See Also

SolidSolidCutUtils Class
SolidSolidCutUtils Members


AddCutBetweenSolids Method (Document, Element, Element)

[image]

Revit 2013 API
SolidSolidCutUtils..::..AddCutBetweenSolids Method (Document, Element, Element)
SolidSolidCutUtils Class See Also Send Feedback
Adds a solid-solid cut for the two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddCutBetweenSolids(
    Document document,
    Element solidToBeCut,
    Element cuttingSolid
)
Visual Basic
Public Shared Sub AddCutBetweenSolids ( _
    document As Document, _
    solidToBeCut As Element, _
    cuttingSolid As Element _
)
Visual C++
public:
static void AddCutBetweenSolids(
    Document^ document,
    Element^ solidToBeCut,
    Element^ cuttingSolid
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
solidToBeCut
Type: Autodesk.Revit.DB..::..Element
The solid to be cut.
cuttingSolid
Type: Autodesk.Revit.DB..::..Element
The cutting solid.

Remarks

This utility will split faces of cutting solid by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to add solid-solid cut for the two elements.

See Also

SolidSolidCutUtils Class
AddCutBetweenSolids Overload


AddCutBetweenSolids Method (Document, Element, Element, Boolean)

[image]

Revit 2013 API
SolidSolidCutUtils..::..AddCutBetweenSolids Method (Document, Element, Element, Boolean)
SolidSolidCutUtils Class See Also Send Feedback
Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddCutBetweenSolids(
    Document document,
    Element solidToBeCut,
    Element cuttingSolid,
    bool splitFacesOfCuttingSolid
)
Visual Basic
Public Shared Sub AddCutBetweenSolids ( _
    document As Document, _
    solidToBeCut As Element, _
    cuttingSolid As Element, _
    splitFacesOfCuttingSolid As Boolean _
)
Visual C++
public:
static void AddCutBetweenSolids(
    Document^ document,
    Element^ solidToBeCut,
    Element^ cuttingSolid,
    bool splitFacesOfCuttingSolid
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
solidToBeCut
Type: Autodesk.Revit.DB..::..Element
The solid to be cut.
cuttingSolid
Type: Autodesk.Revit.DB..::..Element
The cutting solid.
splitFacesOfCuttingSolid
Type: System..::..Boolean
True to split faces of cutting solid where it intersects the solid to be cut, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to add solid-solid cut for the two elements.

See Also

SolidSolidCutUtils Class
AddCutBetweenSolids Overload


CanElementCutElement Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..CanElementCutElement Method
SolidSolidCutUtils Class See Also Send Feedback
Verifies if the cutting element can add a solid cut to the target element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CanElementCutElement(
    Element cuttingElement,
    Element cutElement,
    out CutFailureReason reason
)
Visual Basic
Public Shared Function CanElementCutElement ( _
    cuttingElement As Element, _
    cutElement As Element, _
    <OutAttribute> ByRef reason As CutFailureReason _
) As Boolean
Visual C++
public:
static bool CanElementCutElement(
    Element^ cuttingElement,
    Element^ cutElement,
    [OutAttribute] CutFailureReason% reason
)

Parameters

cuttingElement
Type: Autodesk.Revit.DB..::..Element
The cutting element.
cutElement
Type: Autodesk.Revit.DB..::..Element
The element to be cut.
reason
Type: Autodesk.Revit.DB..::..CutFailureReason%
The reason that the cutting element cannot add a solid cut to the cut element.

Return Value

True if the cutting element can add a solid cut to the target element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


CutExistsBetweenElements Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..CutExistsBetweenElements Method
SolidSolidCutUtils Class See Also Send Feedback
Checks that if there is a solid-solid cut between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CutExistsBetweenElements(
    Element first,
    Element second,
    out bool firstCutsSecond
)
Visual Basic
Public Shared Function CutExistsBetweenElements ( _
    first As Element, _
    second As Element, _
    <OutAttribute> ByRef firstCutsSecond As Boolean _
) As Boolean
Visual C++
public:
static bool CutExistsBetweenElements(
    Element^ first,
    Element^ second,
    [OutAttribute] bool% firstCutsSecond
)

Parameters

first
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.
second
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.
firstCutsSecond
Type: System..::..Boolean%
If the return value of this function is true, this indicates which element is the cutting element from the pair. True if the first solid cuts the second one, false if the second solid cuts the first one.

Return Value

True if there is a solid-solid cut between the input elements, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


Dispose Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..Dispose Method
SolidSolidCutUtils Class See Also Send Feedback
Releases all resources used by the SolidSolidCutUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidSolidCutUtils Class


GetCuttingSolids Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..GetCuttingSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Gets all the solids which cut the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetCuttingSolids(
    Element element
)
Visual Basic
Public Shared Function GetCuttingSolids ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetCuttingSolids(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The input element.

Return Value

The ids of the solids which cut the input element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


GetSolidsBeingCut Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..GetSolidsBeingCut Method
SolidSolidCutUtils Class See Also Send Feedback
Get all the solids which are cut by the input element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetSolidsBeingCut(
    Element element
)
Visual Basic
Public Shared Function GetSolidsBeingCut ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetSolidsBeingCut(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The input element.

Return Value

The ids of the solids which are cut by the input element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


IsAllowedForSolidCut Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..IsAllowedForSolidCut Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is eligible for a solid-solid cut.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsAllowedForSolidCut(
    Element element
)
Visual Basic
Public Shared Function IsAllowedForSolidCut ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsAllowedForSolidCut(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The solid to be cut or the cutting solid.

Return Value

True if the input element can participate in a solid-solid cut. False otherwise.

Remarks

The element must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


IsElementFromAppropriateContext Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..IsElementFromAppropriateContext Method
SolidSolidCutUtils Class See Also Send Feedback
Validates that the element is from an appropriate document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsElementFromAppropriateContext(
    Element element
)
Visual Basic
Public Shared Function IsElementFromAppropriateContext ( _
    element As Element _
) As Boolean
Visual C++
public:
static bool IsElementFromAppropriateContext(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The solid to be cut or the cutting solid.

Return Value

True if the element is from an appropriate document for solid-solid cuts, false otherwise.

Remarks

Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family may participate in solid-solid cuts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


RemoveCutBetweenSolids Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..RemoveCutBetweenSolids Method
SolidSolidCutUtils Class See Also Send Feedback
Removes the solid-solid cut between the two elements if it exists.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveCutBetweenSolids(
    Document document,
    Element first,
    Element second
)
Visual Basic
Public Shared Sub RemoveCutBetweenSolids ( _
    document As Document, _
    first As Element, _
    second As Element _
)
Visual C++
public:
static void RemoveCutBetweenSolids(
    Document^ document,
    Element^ first,
    Element^ second
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the two elements
first
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.
second
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidSolidCutUtils Class


SplitFacesOfCuttingSolid Method

[image]

Revit 2013 API
SolidSolidCutUtils..::..SplitFacesOfCuttingSolid Method
SolidSolidCutUtils Class See Also Send Feedback
Causes the faces of the cutting element where it intersects the element it is cutting to be split or unsplit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void SplitFacesOfCuttingSolid(
    Element first,
    Element second,
    bool split
)
Visual Basic
Public Shared Sub SplitFacesOfCuttingSolid ( _
    first As Element, _
    second As Element, _
    split As Boolean _
)
Visual C++
public:
static void SplitFacesOfCuttingSolid(
    Element^ first,
    Element^ second,
    bool split
)

Parameters

first
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
second
Type: Autodesk.Revit.DB..::..Element
The solid being cut or the cutting solid
split
Type: System..::..Boolean
True to split the faces of intersection, false to unsplit them.

Remarks

There must be a cut between the input elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no solid-solid cut between the input elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to split or unsplit faces of cutting solid

See Also

SolidSolidCutUtils Class


SolidUtils Class

[image]

Revit 2013 API
SolidUtils Class
Members See Also Send Feedback
Contains utility functions for solid operations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SolidUtils : IDisposable
Visual Basic
Public Class SolidUtils _
    Implements IDisposable
Visual C++
public ref class SolidUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SolidUtils

See Also

SolidUtils Members


SolidUtils Members

[image] [image]

Revit 2013 API
SolidUtils Members
SolidUtils Class Methods See Also Send Feedback

The SolidUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SolidUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
 | SplitVolumes | Splits a solid geometry into several separate solids.
 | TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidUtils Class


SolidUtils Methods

[image] [image]

Revit 2013 API
SolidUtils Methods
SolidUtils Class See Also Send Feedback

The SolidUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidForTessellation | Tests if the input solid or shell is valid for tessellation.
 | SplitVolumes | Splits a solid geometry into several separate solids.
 | TessellateSolidOrShell | This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SolidUtils Class


Dispose Method

[image]

Revit 2013 API
SolidUtils..::..Dispose Method
SolidUtils Class See Also Send Feedback
Releases all resources used by the SolidUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SolidUtils Class


IsValidForTessellation Method

[image]

Revit 2013 API
SolidUtils..::..IsValidForTessellation Method
SolidUtils Class See Also Send Feedback
Tests if the input solid or shell is valid for tessellation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidForTessellation(
    Solid solidOrShell
)
Visual Basic
Public Shared Function IsValidForTessellation ( _
    solidOrShell As Solid _
) As Boolean
Visual C++
public:
static bool IsValidForTessellation(
    Solid^ solidOrShell
)

Parameters

solidOrShell
Type: Autodesk.Revit.DB..::..Solid
The solid or shell.

Return Value

True if the solid or shell is valid for tessellation, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SolidUtils Class


SplitVolumes Method

[image]

Revit 2013 API
SolidUtils..::..SplitVolumes Method
SolidUtils Class See Also Send Feedback
Splits a solid geometry into several separate solids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<Solid> SplitVolumes(
    Solid solid
)
Visual Basic
Public Shared Function SplitVolumes ( _
    solid As Solid _
) As IList(Of Solid)
Visual C++
public:
static IList<Solid^>^ SplitVolumes(
    Solid^ solid
)

Parameters

solid
Type: Autodesk.Revit.DB..::..Solid
The solid.

Return Value

The split solid geometries.

Remarks

If no splitting is done, a copy of the input solid will be returned in the output array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to split the solid geometry.

See Also

SolidUtils Class


TessellateSolidOrShell Method

[image]

Revit 2013 API
SolidUtils..::..TessellateSolidOrShell Method
SolidUtils Class See Also Send Feedback
This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static TriangulatedSolidOrShell TessellateSolidOrShell(
    Solid solidOrShell,
    SolidOrShellTessellationControls tessellationControls
)
Visual Basic
Public Shared Function TessellateSolidOrShell ( _
    solidOrShell As Solid, _
    tessellationControls As SolidOrShellTessellationControls _
) As TriangulatedSolidOrShell
Visual C++
public:
static TriangulatedSolidOrShell^ TessellateSolidOrShell(
    Solid^ solidOrShell,
    SolidOrShellTessellationControls^ tessellationControls
)

Parameters

solidOrShell
Type: Autodesk.Revit.DB..::..Solid
The solid or shell to be faceted.
tessellationControls
Type: Autodesk.Revit.DB..::..SolidOrShellTessellationControls
This input controls various aspects of the triangulation.

Return Value

The triangulated structures corresponding to the boundary components of the input solid or the components of the input shell.

Remarks

Every point on the triangulation of a boundary component of the solid (or shell) should lie within the 3D distance specified by the “accuracy” input of some point on the triangulation, and vice-versa. In some cases, this constraint may be implemented heuristically (not rigorously).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | solidOrShell is not valid for triangulation (for example, it contains no faces).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to triangulate the solid or shell.

See Also

SolidUtils Class


SpacingRule Class

[image]

Revit 2013 API
SpacingRule Class
Members See Also Send Feedback
A rule for specifying a set of equidistant, parallel gridlines within a region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpacingRule : APIObject
Visual Basic
Public Class SpacingRule _
    Inherits APIObject
Visual C++
public ref class SpacingRule : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SpacingRule

See Also

SpacingRule Members


SpacingRule Members

[image] [image]

Revit 2013 API
SpacingRule Members
SpacingRule Class Methods Properties See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class


SpacingRule Methods

[image] [image]

Revit 2013 API
SpacingRule Methods
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLayoutFixedDistance | Set the Layout property to FixedDistance.
Public method | SetLayoutFixedNumber | Set the Layout property to FixedNumber.
Public method | SetLayoutMaximumSpacing | Set the Layout property to MaximumSpacing.
Public method | SetLayoutMinimumSpacing | Set the Layout property to MinimumSpacing.
Public method | SetLayoutNone | Set the Layout property to None.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpacingRule Class


SetLayoutFixedDistance Method

[image]

Revit 2013 API
SpacingRule..::..SetLayoutFixedDistance Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedDistance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutFixedDistance ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedDistance(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::..Double
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to FixedDistance, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutFixedNumber Method

[image]

Revit 2013 API
SpacingRule..::..SetLayoutFixedNumber Method
SpacingRule Class See Also Send Feedback
Set the Layout property to FixedNumber.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutFixedNumber ( _
    number As Integer, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutFixedNumber(
    int number,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

number
Type: System..::..Int32
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to FixedNumber, you must also simultaneously set the Number, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutMaximumSpacing Method

[image]

Revit 2013 API
SpacingRule..::..SetLayoutMaximumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MaximumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutMaximumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMaximumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::..Double
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to MaximumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutMinimumSpacing Method

[image]

Revit 2013 API
SpacingRule..::..SetLayoutMinimumSpacing Method
SpacingRule Class See Also Send Feedback
Set the Layout property to MinimumSpacing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)
Visual Basic
Public Sub SetLayoutMinimumSpacing ( _
    distance As Double, _
    just As SpacingRuleJustification, _
    gridlinesRotation As Double, _
    offset As Double _
)
Visual C++
public:
void SetLayoutMinimumSpacing(
    double distance,
    SpacingRuleJustification just,
    double gridlinesRotation,
    double offset
)

Parameters

distance
Type: System..::..Double
just
Type: Autodesk.Revit.DB..::..SpacingRuleJustification
gridlinesRotation
Type: System..::..Double
offset
Type: System..::..Double

Remarks

When changing the Layout to MinimumSpacing, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.

See Also

SpacingRule Class


SetLayoutNone Method

[image]

Revit 2013 API
SpacingRule..::..SetLayoutNone Method
SpacingRule Class See Also Send Feedback
Set the Layout property to None.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLayoutNone()
Visual Basic
Public Sub SetLayoutNone
Visual C++
public:
void SetLayoutNone()

Remarks

No internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


SpacingRule Properties

[image] [image]

Revit 2013 API
SpacingRule Properties
SpacingRule Class See Also Send Feedback

The SpacingRule type exposes the following members.

Properties

 | Name | Description
Public property | BeltMeasurement | On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property | Distance | The exact distance between layout lines.
Public property | GridlinesRotation | An additional rotation to be applied to this set of grid lines.
Public property | HasBeltMeasurement | True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Justification | The justification of the lines within the region.
Public property | Layout | A choice of several gridline layout rules.
Public property | Number | The exact number of lines in the region.
Public property | Offset | An additional offset applied to the first gridline.

See Also

SpacingRule Class


BeltMeasurement Property

[image]

Revit 2013 API
SpacingRule..::..BeltMeasurement Property
SpacingRule Class See Also Send Feedback
On a curved surface, BeltMeasurement specifies where the grid's distances are measured.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BeltMeasurement { get; set; }
Visual Basic
Public Property BeltMeasurement As Double
    Get
    Set
Visual C++
public:
property double BeltMeasurement {
    double get ();
    void set (double value);
}

Remarks

On a conical surface, the distance between the radial gridlines is not constant. To interpret the Distance property, a circumferential gridline is taken as the "belt." Distance is then measured along the belt. The BeltMeasurement property gives the location of the belt relative to the extremes of the surface. The belt is used whenever gridlines are not parallel. It defaults to 0.5.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ].
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property.

See Also

SpacingRule Class


Distance Property

[image]

Revit 2013 API
SpacingRule..::..Distance Property
SpacingRule Class See Also Send Feedback
The exact distance between layout lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, MaximumSpacing, or MinimumSpacing. Must be a positive value less than 30000'.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the Layout property is None or FixedNumber.

See Also

SpacingRule Class


GridlinesRotation Property

[image]

Revit 2013 API
SpacingRule..::..GridlinesRotation Property
SpacingRule Class See Also Send Feedback
An additional rotation to be applied to this set of grid lines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GridlinesRotation { get; set; }
Visual Basic
Public Property GridlinesRotation As Double
    Get
    Set
Visual C++
public:
property double GridlinesRotation {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when angle is outside of the range ( -PI/2, PI/2 ).

See Also

SpacingRule Class


HasBeltMeasurement Property

[image]

Revit 2013 API
SpacingRule..::..HasBeltMeasurement Property
SpacingRule Class See Also Send Feedback
True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasBeltMeasurement { get; }
Visual Basic
Public ReadOnly Property HasBeltMeasurement As Boolean
    Get
Visual C++
public:
property bool HasBeltMeasurement {
    bool get ();
}

See Also

SpacingRule Class


Justification Property

[image]

Revit 2013 API
SpacingRule..::..Justification Property
SpacingRule Class See Also Send Feedback
The justification of the lines within the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpacingRuleJustification Justification { get; set; }
Visual Basic
Public Property Justification As SpacingRuleJustification
    Get
    Set
Visual C++
public:
property SpacingRuleJustification Justification {
    SpacingRuleJustification get ();
    void set (SpacingRuleJustification value);
}

Remarks

This property is only available when Layout is equal to FixedDistance, FixedNumber, MaximumSpacing, or MinimumSpacing.

See Also

SpacingRule Class


Layout Property

[image]

Revit 2013 API
SpacingRule..::..Layout Property
SpacingRule Class See Also Send Feedback
A choice of several gridline layout rules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpacingRuleLayout Layout { get; }
Visual Basic
Public ReadOnly Property Layout As SpacingRuleLayout
    Get
Visual C++
public:
property SpacingRuleLayout Layout {
    SpacingRuleLayout get ();
}

Remarks

If "None" is chosen, no internal lines will be generated, but the effect is equivalent to having two lines, one at each end of the region.

See Also

SpacingRule Class


Number Property

[image]

Revit 2013 API
SpacingRule..::..Number Property
SpacingRule Class See Also Send Feedback
The exact number of lines in the region.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Number { get; set; }
Visual Basic
Public Property Number As Integer
    Get
    Set
Visual C++
public:
property int Number {
    int get ();
    void set (int value);
}

Remarks

This property is only available when Layout is equal to FixedNumber. Lines will be placed exactly at the boundaries if possible, so if your region is 100' long and you specify Number = 11, your lines will be 10' apart. Must be between 1 and 200.

See Also

SpacingRule Class


Offset Property

[image]

Revit 2013 API
SpacingRule..::..Offset Property
SpacingRule Class See Also Send Feedback
An additional offset applied to the first gridline.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Offset { get; set; }
Visual Basic
Public Property Offset As Double
    Get
    Set
Visual C++
public:
property double Offset {
    double get ();
    void set (double value);
}

Remarks

Measured in feet. Must be between -30000' and 30000'.

See Also

SpacingRule Class


SpacingRuleJustification Enumeration

[image]

Revit 2013 API
SpacingRuleJustification Enumeration
See Also Send Feedback
Justification property of spacing rule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SpacingRuleJustification
Visual Basic
Public Enumeration SpacingRuleJustification
Visual C++
public enum class SpacingRuleJustification

Members

Member name | Description
Center |
Beginning |
End |

See Also


SpacingRuleLayout Enumeration

[image]

Revit 2013 API
SpacingRuleLayout Enumeration
See Also Send Feedback
Rules for laying out a series of equidistant points or parallel lines

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SpacingRuleLayout
Visual Basic
Public Enumeration SpacingRuleLayout
Visual C++
public enum class SpacingRuleLayout

Members

Member name | Description
None | No points or lines will be created.
FixedDistance | Points or lines are separated by a fixed distance.
FixedNumber | Fixed number of points or lines with uniform distance between them.
MaximumSpacing | Points or lines are separated by at most the max distance.
MinimumSpacing | Points or lines are separated by at least the minimum distance.

See Also


SpatialElement Class

[image]

Revit 2013 API
SpatialElement Class
Members See Also Send Feedback
Represents an enclosed area or volume in the Revit model. This is the parent class for rooms, spaces and areas.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpatialElement : Element
Visual Basic
Public Class SpatialElement _
    Inherits Element
Visual C++
public ref class SpatialElement : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB.Architecture..::..Room
Autodesk.Revit.DB..::..Area
Autodesk.Revit.DB.Mechanical..::..Space

See Also

SpatialElement Members


SpatialElement Members

[image] [image]

Revit 2013 API
SpatialElement Members
SpatialElement Class Methods Properties See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Overrides Element..::..Level.)
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElement Class


SpatialElement Methods

[image] [image]

Revit 2013 API
SpatialElement Methods
SpatialElement Class See Also Send Feedback

The SpatialElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElement Class


GetBoundarySegments Method

[image]

Revit 2013 API
SpatialElement..::..GetBoundarySegments Method
SpatialElement Class See Also Send Feedback
Returns the boundary segments.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<IList<BoundarySegment>> GetBoundarySegments(
    SpatialElementBoundaryOptions options
)
Visual Basic
Public Function GetBoundarySegments ( _
    options As SpatialElementBoundaryOptions _
) As IList(Of IList(Of BoundarySegment))
Visual C++
public:
IList<IList<BoundarySegment^>^>^ GetBoundarySegments(
    SpatialElementBoundaryOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The SpatialElementBoundaryOptions.

Remarks

This method is used to retrieve the segments that constitute the boundary of the spatial element. Each spatial element may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the BoundarySegment object for more details about the segments that make up the spatial element topology.

See Also

SpatialElement Class


SpatialElement Properties

[image] [image]

Revit 2013 API
SpatialElement Properties
SpatialElement Class See Also Send Feedback

The SpatialElement type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Overrides Element..::..Level.)
Public property | Location | The location of the element. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Overrides Element..::..Name.)
Public property | Number | The number.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElement Class


Area Property

[image]

Revit 2013 API
SpatialElement..::..Area Property
SpatialElement Class See Also Send Feedback
The area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

See Also

SpatialElement Class


Level Property

[image]

Revit 2013 API
SpatialElement..::..Level Property
SpatialElement Class See Also Send Feedback
Gets the level of the room.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Level Level { get; }
Visual Basic
Public Overrides ReadOnly Property Level As Level
    Get
Visual C++
public:
virtual property Level^ Level {
    Level^ get () override;
}

See Also

SpatialElement Class


Location Property

[image]

Revit 2013 API
SpatialElement..::..Location Property
SpatialElement Class See Also Send Feedback
The location of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

This is the location of the room within the level. The Z location should be the elevation of the level and not changeable.

See Also

SpatialElement Class


Name Property

[image]

Revit 2013 API
SpatialElement..::..Name Property
SpatialElement Class See Also Send Feedback
A human readable name for the Element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

The Name property is a human readable name for the element, such as Wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the name of the element cannot be changed.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the element requires a unique name and a non-unique name is set.

See Also

SpatialElement Class


Number Property

[image]

Revit 2013 API
SpatialElement..::..Number Property
SpatialElement Class See Also Send Feedback
The number.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Number { get; set; }
Visual Basic
Public Property Number As String
    Get
    Set
Visual C++
public:
property String^ Number {
    String^ get ();
    void set (String^ value);
}

See Also

SpatialElement Class


Parameter Property

[image] [image]

Revit 2013 API
SpatialElement..::..Parameter Property
SpatialElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElement Class
SpatialElement Members


Perimeter Property

[image]

Revit 2013 API
SpatialElement..::..Perimeter Property
SpatialElement Class See Also Send Feedback
The perimeter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic
Public ReadOnly Property Perimeter As Double
    Get
Visual C++
public:
property double Perimeter {
    double get ();
}

See Also

SpatialElement Class


SpatialElementBoundaryLocation Enumeration

[image]

Revit 2013 API
SpatialElementBoundaryLocation Enumeration
See Also Send Feedback
An enumerated type listing boundary options of spatial element geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SpatialElementBoundaryLocation
Visual Basic
Public Enumeration SpatialElementBoundaryLocation
Visual C++
public enum class SpatialElementBoundaryLocation

Members

Member name | Description
Finish | Spatial element finish face.
Center | Spatial element centerline.

See Also


SpatialElementBoundaryOptions Class

[image]

Revit 2013 API
SpatialElementBoundaryOptions Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SpatialElementBoundaryOptions : IDisposable
Visual Basic
Public Class SpatialElementBoundaryOptions _
    Implements IDisposable
Visual C++
public ref class SpatialElementBoundaryOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementBoundaryOptions

See Also

SpatialElementBoundaryOptions Members


SpatialElementBoundaryOptions Members

[image] [image]

Revit 2013 API
SpatialElementBoundaryOptions Members
SpatialElementBoundaryOptions Class Constructors Methods Properties See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementBoundaryOptions | Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundaryOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Constructor

[image]

Revit 2013 API
SpatialElementBoundaryOptions Constructor
SpatialElementBoundaryOptions Class See Also Send Feedback
Constructs default options for calculation of the geometry of spatial elements (rooms, spaces).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementBoundaryOptions()
Visual Basic
Public Sub New
Visual C++
public:
SpatialElementBoundaryOptions()

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Methods

[image] [image]

Revit 2013 API
SpatialElementBoundaryOptions Methods
SpatialElementBoundaryOptions Class See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementBoundaryOptions Class


Dispose Method

[image]

Revit 2013 API
SpatialElementBoundaryOptions..::..Dispose Method
SpatialElementBoundaryOptions Class See Also Send Feedback
Releases all resources used by the SpatialElementBoundaryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryOptions Properties

[image] [image]

Revit 2013 API
SpatialElementBoundaryOptions Properties
SpatialElementBoundaryOptions Class See Also Send Feedback

The SpatialElementBoundaryOptions type exposes the following members.

Properties

 | Name | Description
Public property | SpatialElementBoundaryLocation | The boundary of spatial element for geometry calculation.
Public property | StoreFreeBoundaryFaces | Indicates whether to include the free boundary faces in the result.

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundaryLocation Property

[image]

Revit 2013 API
SpatialElementBoundaryOptions..::..SpatialElementBoundaryLocation Property
SpatialElementBoundaryOptions Class See Also Send Feedback
The boundary of spatial element for geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementBoundaryLocation SpatialElementBoundaryLocation { get; set; }
Visual Basic
Public Property SpatialElementBoundaryLocation As SpatialElementBoundaryLocation
    Get
    Set
Visual C++
public:
property SpatialElementBoundaryLocation SpatialElementBoundaryLocation {
    SpatialElementBoundaryLocation get ();
    void set (SpatialElementBoundaryLocation value);
}

See Also

SpatialElementBoundaryOptions Class


StoreFreeBoundaryFaces Property

[image]

Revit 2013 API
SpatialElementBoundaryOptions..::..StoreFreeBoundaryFaces Property
SpatialElementBoundaryOptions Class See Also Send Feedback
Indicates whether to include the free boundary faces in the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool StoreFreeBoundaryFaces { get; set; }
Visual Basic
Public Property StoreFreeBoundaryFaces As Boolean
    Get
    Set
Visual C++
public:
property bool StoreFreeBoundaryFaces {
    bool get ();
    void set (bool value);
}

Remarks

A free subface is a portion of a spatial element face that is not (partially) coincident with a face of a bounding element.

See Also

SpatialElementBoundaryOptions Class


SpatialElementBoundarySubface Class

[image]

Revit 2013 API
SpatialElementBoundarySubface Class
Members See Also Send Feedback
SpatialElementBoundarySubface represents the geometry boundary information of spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SpatialElementBoundarySubface : IDisposable
Visual Basic
Public Class SpatialElementBoundarySubface _
    Implements IDisposable
Visual C++
public ref class SpatialElementBoundarySubface : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementBoundarySubface

See Also

SpatialElementBoundarySubface Members


SpatialElementBoundarySubface Members

[image] [image]

Revit 2013 API
SpatialElementBoundarySubface Members
SpatialElementBoundarySubface Class Methods Properties See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementBoundarySubface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.

See Also

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface Methods

[image] [image]

Revit 2013 API
SpatialElementBoundarySubface Methods
SpatialElementBoundarySubface Class See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundingElementFace | Returns the face of the bounding element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSpatialElementFace | Returns the face of the spatial element's 3D geometry.
Public method | GetSubface | Returns a face that represents the portion of the room face bounded by the boundary element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementBoundarySubface Class


Dispose Method

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..Dispose Method
SpatialElementBoundarySubface Class See Also Send Feedback
Releases all resources used by the SpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementBoundarySubface Class


GetBoundingElementFace Method

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..GetBoundingElementFace Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns the face of the bounding element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Face GetBoundingElementFace()
Visual Basic
Public Function GetBoundingElementFace As Face
Visual C++
public:
Face^ GetBoundingElementFace()

Return Value

The face of the bounding element.

Remarks

Applies only if the options chosen for the extraction of the element's geometry is Finish. Faces do not contain voids in room-bounding elements (such the voids in walls created by doors and windows).

See Also

SpatialElementBoundarySubface Class


GetSpatialElementFace Method

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..GetSpatialElementFace Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns the face of the spatial element's 3D geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Face GetSpatialElementFace()
Visual Basic
Public Function GetSpatialElementFace As Face
Visual C++
public:
Face^ GetSpatialElementFace()

Return Value

The face of the spatial element's 3D geometry.

See Also

SpatialElementBoundarySubface Class


GetSubface Method

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..GetSubface Method
SpatialElementBoundarySubface Class See Also Send Feedback
Returns a face that represents the portion of the room face bounded by the boundary element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Face GetSubface()
Visual Basic
Public Function GetSubface As Face
Visual C++
public:
Face^ GetSubface()

Return Value

The sub-face.

Remarks

If the spatial element's face is adjacent to multiple bounding elements (such as two different walls), there will be one sub-face for each portion of the spatial element's face where it is adjacent to one of those room-bounding elements. This is equivalent to the return of GetRoomFace() if the entire room face is created by the boundary element.

See Also

SpatialElementBoundarySubface Class


SpatialElementBoundarySubface Properties

[image] [image]

Revit 2013 API
SpatialElementBoundarySubface Properties
SpatialElementBoundarySubface Class See Also Send Feedback

The SpatialElementBoundarySubface type exposes the following members.

Properties

 | Name | Description
Public property | SpatialBoundaryElement | Element that gave rise to this room face.
Public property | SubfaceArisesFromElementFace | Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public property | SubfaceType | Type of the subface.

See Also

SpatialElementBoundarySubface Class


SpatialBoundaryElement Property

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..SpatialBoundaryElement Property
SpatialElementBoundarySubface Class See Also Send Feedback
Element that gave rise to this room face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinkElementId SpatialBoundaryElement { get; }
Visual Basic
Public ReadOnly Property SpatialBoundaryElement As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ SpatialBoundaryElement {
    LinkElementId^ get ();
}

See Also

SpatialElementBoundarySubface Class


SubfaceArisesFromElementFace Property

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..SubfaceArisesFromElementFace Property
SpatialElementBoundarySubface Class See Also Send Feedback
Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SubfaceArisesFromElementFace { get; }
Visual Basic
Public ReadOnly Property SubfaceArisesFromElementFace As Boolean
    Get
Visual C++
public:
property bool SubfaceArisesFromElementFace {
    bool get ();
}

See Also

SpatialElementBoundarySubface Class


SubfaceType Property

[image]

Revit 2013 API
SpatialElementBoundarySubface..::..SubfaceType Property
SpatialElementBoundarySubface Class See Also Send Feedback
Type of the subface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SubfaceType SubfaceType { get; }
Visual Basic
Public ReadOnly Property SubfaceType As SubfaceType
    Get
Visual C++
public:
property SubfaceType SubfaceType {
    SubfaceType get ();
}

See Also

SpatialElementBoundarySubface Class


SpatialElementCalculationPoint Class

[image]

Revit 2013 API
SpatialElementCalculationPoint Class
Members See Also Send Feedback
A Spatial Element Calculation Point is used as a search point for room and space relations for all instances of this family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SpatialElementCalculationPoint : Element
Visual Basic
Public Class SpatialElementCalculationPoint _
    Inherits Element
Visual C++
public ref class SpatialElementCalculationPoint : public Element

Remarks

The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family. A user can turn on the Spatial Element Calculation Point in the family editor. An application can turn on the Spatial Element Calculation Point by setting the family's ROOM_CALCULATION_POINT parameter. A user can move the location of the Spatial Element Calculation Point in the family editor. A user can visually verify the location of the Spatial Element Calculation Point by selecting the fixture in the project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementCalculationPoint

See Also

SpatialElementCalculationPoint Members


SpatialElementCalculationPoint Members

[image] [image]

Revit 2013 API
SpatialElementCalculationPoint Members
SpatialElementCalculationPoint Class Methods Properties See Also Send Feedback

The SpatialElementCalculationPoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation point marker.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the spatial element calculation point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementCalculationPoint Class


SpatialElementCalculationPoint Methods

[image] [image]

Revit 2013 API
SpatialElementCalculationPoint Methods
SpatialElementCalculationPoint Class See Also Send Feedback

The SpatialElementCalculationPoint type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementCalculationPoint Class


SpatialElementCalculationPoint Properties

[image] [image]

Revit 2013 API
SpatialElementCalculationPoint Properties
SpatialElementCalculationPoint Class See Also Send Feedback

The SpatialElementCalculationPoint type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MarkerPosition | The position of the spatial element calculation point marker.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Position | The position of the spatial element calculation point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementCalculationPoint Class


MarkerPosition Property

[image]

Revit 2013 API
SpatialElementCalculationPoint..::..MarkerPosition Property
SpatialElementCalculationPoint Class See Also Send Feedback
The position of the spatial element calculation point marker.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ MarkerPosition { get; set; }
Visual Basic
Public Property MarkerPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ MarkerPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SpatialElementCalculationPoint Class


Parameter Property

[image] [image]

Revit 2013 API
SpatialElementCalculationPoint..::..Parameter Property
SpatialElementCalculationPoint Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementCalculationPoint Class
SpatialElementCalculationPoint Members


Position Property

[image]

Revit 2013 API
SpatialElementCalculationPoint..::..Position Property
SpatialElementCalculationPoint Class See Also Send Feedback
The position of the spatial element calculation point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Position { get; set; }
Visual Basic
Public Property Position As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Position {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This is used as the search point for family instances placement inside rooms and spaces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SpatialElementCalculationPoint Class


SpatialElementGeometryCalculator Class

[image]

Revit 2013 API
SpatialElementGeometryCalculator Class
Members Example See Also Send Feedback
Use this class to calculate the geometry of a spatial element and obtain the relationships between the geometry and the element's boundary elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SpatialElementGeometryCalculator : IDisposable
Visual Basic
Public Class SpatialElementGeometryCalculator _
    Implements IDisposable
Visual C++
public ref class SpatialElementGeometryCalculator : IDisposable

Remarks

This class maintains an internal cache for geometry it has already processed. If you intend to calculate geometry for several elements in the same project you should use a single instance of this class. Note that the cache will be cleared when any change is made to the document.

Examples

CopyC#
// Calculate a room's geometry and find its boundary faces
SpatialElementGeometryCalculator calculator = new SpatialElementGeometryCalculator(doc);
SpatialElementGeometryResults results = calculator.CalculateSpatialElementGeometry(room); // compute the room geometry
Solid roomSolid = results.GetGeometry(); // get the solid representing the room's geometry
foreach (Face face in roomSolid.Faces)
{
    double faceArea = face.Area;
    IList<SpatialElementBoundarySubface> subfaceList = results.GetBoundaryFaceInfo(face); // get the sub-faces for the face of the room
    foreach (SpatialElementBoundarySubface subface in subfaceList)
    {
        if (subfaceList.Count > 1) // there are multiple sub-faces that define the face
        {
            double subfaceArea = subface.GetSubface().Area; // get the area of each sub-face
            // sub-faces exist in situations such as when a room-bounding wall has been
            // horizontally split and the faces of each split wall combine to create the
            // entire face of the room
        }
    }
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementGeometryCalculator

See Also

SpatialElementGeometryCalculator Members


SpatialElementGeometryCalculator Members

[image] [image]

Revit 2013 API
SpatialElementGeometryCalculator Members
SpatialElementGeometryCalculator Class Constructors Methods See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Constructors

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose | Releases all resources used by the SpatialElementGeometryCalculator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementGeometryCalculator Class


SpatialElementGeometryCalculator Constructor

[image] [image]

Revit 2013 API
SpatialElementGeometryCalculator Constructor
SpatialElementGeometryCalculator Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SpatialElementGeometryCalculator(Document) | Constructs a new calculator with default options for the geometry of spatial elements.
Public method | SpatialElementGeometryCalculator(Document, SpatialElementBoundaryOptions) | Constructs a new calculator for the geometry of spatial elements.

See Also

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Members


SpatialElementGeometryCalculator Constructor (Document)

[image]

Revit 2013 API
SpatialElementGeometryCalculator Constructor (Document)
SpatialElementGeometryCalculator Class See Also Send Feedback
Constructs a new calculator with default options for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementGeometryCalculator(
    Document aDoc
)
Visual Basic
Public Sub New ( _
    aDoc As Document _
)
Visual C++
public:
SpatialElementGeometryCalculator(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document that contains the spatial elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Overload


SpatialElementGeometryCalculator Constructor (Document, SpatialElementBoundaryOptions)

[image]

Revit 2013 API
SpatialElementGeometryCalculator Constructor (Document, SpatialElementBoundaryOptions)
SpatialElementGeometryCalculator Class See Also Send Feedback
Constructs a new calculator for the geometry of spatial elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementGeometryCalculator(
    Document aDoc,
    SpatialElementBoundaryOptions options
)
Visual Basic
Public Sub New ( _
    aDoc As Document, _
    options As SpatialElementBoundaryOptions _
)
Visual C++
public:
SpatialElementGeometryCalculator(
    Document^ aDoc,
    SpatialElementBoundaryOptions^ options
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document that contains the spatial elements.
options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The options to control the calculation rules.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryCalculator Class
SpatialElementGeometryCalculator Overload


SpatialElementGeometryCalculator Methods

[image] [image]

Revit 2013 API
SpatialElementGeometryCalculator Methods
SpatialElementGeometryCalculator Class See Also Send Feedback

The SpatialElementGeometryCalculator type exposes the following members.

Methods

 | Name | Description
Public method | CalculateSpatialElementGeometry | Compute the spatial element geometry and returns the boundary face information.
 | CanCalculateGeometry | This indicates whether the input spatial element is a valid one.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOptions | The options that control the calculation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsRoomOrSpace | This indicates whether the input spatial element is a room or a space.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementGeometryCalculator Class


CalculateSpatialElementGeometry Method

[image]

Revit 2013 API
SpatialElementGeometryCalculator..::..CalculateSpatialElementGeometry Method
SpatialElementGeometryCalculator Class See Also Send Feedback
Compute the spatial element geometry and returns the boundary face information.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementGeometryResults CalculateSpatialElementGeometry(
    SpatialElement spatialElement
)
Visual Basic
Public Function CalculateSpatialElementGeometry ( _
    spatialElement As SpatialElement _
) As SpatialElementGeometryResults
Visual C++
public:
SpatialElementGeometryResults^ CalculateSpatialElementGeometry(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
Specifies the spatial element needs to be computed, should be Room or Space.

Return Value

Requested boundary face information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | spatialElement is not a room or a space, and thus has no 3D geometry to calculate. -or- spatialElement is not enclosed in 2d or has no location, or the height is too small, and thus has no 3D geometry to calculate.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to compute the given spatial element's geometry.

See Also

SpatialElementGeometryCalculator Class


CanCalculateGeometry Method

[image]

Revit 2013 API
SpatialElementGeometryCalculator..::..CanCalculateGeometry Method
SpatialElementGeometryCalculator Class See Also Send Feedback
This indicates whether the input spatial element is a valid one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanCalculateGeometry(
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function CanCalculateGeometry ( _
    spatialElement As SpatialElement _
) As Boolean
Visual C++
public:
static bool CanCalculateGeometry(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element to be checked if its geometry can be calculated.

Return Value

It will return false if the room/space is not enclosed in 2d or has no location, or the height is too small.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryCalculator Class


Dispose Method

[image]

Revit 2013 API
SpatialElementGeometryCalculator..::..Dispose Method
SpatialElementGeometryCalculator Class See Also Send Feedback
Releases all resources used by the SpatialElementGeometryCalculator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementGeometryCalculator Class


GetOptions Method

[image]

Revit 2013 API
SpatialElementGeometryCalculator..::..GetOptions Method
SpatialElementGeometryCalculator Class See Also Send Feedback
The options that control the calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SpatialElementBoundaryOptions GetOptions()
Visual Basic
Public Function GetOptions As SpatialElementBoundaryOptions
Visual C++
public:
SpatialElementBoundaryOptions^ GetOptions()

Return Value

The options.

See Also

SpatialElementGeometryCalculator Class


IsRoomOrSpace Method

[image]

Revit 2013 API
SpatialElementGeometryCalculator..::..IsRoomOrSpace Method
SpatialElementGeometryCalculator Class See Also Send Feedback
This indicates whether the input spatial element is a room or a space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsRoomOrSpace(
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function IsRoomOrSpace ( _
    spatialElement As SpatialElement _
) As Boolean
Visual C++
public:
static bool IsRoomOrSpace(
    SpatialElement^ spatialElement
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element to be checked if it is a room or a space or not.

Return Value

True if the input spatial element is a room or a space, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryCalculator Class


SpatialElementGeometryResults Class

[image]

Revit 2013 API
SpatialElementGeometryResults Class
Members See Also Send Feedback
The results of spatial element geometry calculation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SpatialElementGeometryResults : IDisposable
Visual Basic
Public Class SpatialElementGeometryResults _
    Implements IDisposable
Visual C++
public ref class SpatialElementGeometryResults : IDisposable

Remarks

The subfaces of a SpatialElement at the base height and top height are not associated with floors, roofs, and ceilings at the same height.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SpatialElementGeometryResults

See Also

SpatialElementGeometryResults Members


SpatialElementGeometryResults Members

[image] [image]

Revit 2013 API
SpatialElementGeometryResults Members
SpatialElementGeometryResults Class Methods See Also Send Feedback

The SpatialElementGeometryResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the SpatialElementGeometryResults
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementGeometryResults Class


SpatialElementGeometryResults Methods

[image] [image]

Revit 2013 API
SpatialElementGeometryResults Methods
SpatialElementGeometryResults Class See Also Send Feedback

The SpatialElementGeometryResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryFaceInfo | Query the spatial element boundary face information with the given face.
Public method | GetGeometry | The solid from the spatial element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementGeometryResults Class


Dispose Method

[image]

Revit 2013 API
SpatialElementGeometryResults..::..Dispose Method
SpatialElementGeometryResults Class See Also Send Feedback
Releases all resources used by the SpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SpatialElementGeometryResults Class


GetBoundaryFaceInfo Method

[image]

Revit 2013 API
SpatialElementGeometryResults..::..GetBoundaryFaceInfo Method
SpatialElementGeometryResults Class See Also Send Feedback
Query the spatial element boundary face information with the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo(
    Face face
)
Visual Basic
Public Function GetBoundaryFaceInfo ( _
    face As Face _
) As IList(Of SpatialElementBoundarySubface)
Visual C++
public:
IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo(
    Face^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
The face from the spatial element's geometry.

Return Value

Sub-faces related to the room bounding elements that define the spatial element face. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no corresponding boundary information with the given face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialElementGeometryResults Class


GetGeometry Method

[image]

Revit 2013 API
SpatialElementGeometryResults..::..GetGeometry Method
SpatialElementGeometryResults Class See Also Send Feedback
The solid from the spatial element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Solid GetGeometry()
Visual Basic
Public Function GetGeometry As Solid
Visual C++
public:
Solid^ GetGeometry()

Return Value

Requested solid.

See Also

SpatialElementGeometryResults Class


SpatialElementTag Class

[image]

Revit 2013 API
SpatialElementTag Class
Members See Also Send Feedback
A tag attached to an SpatialElement (room, space or area) in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpatialElementTag : Element
Visual Basic
Public Class SpatialElementTag _
    Inherits Element
Visual C++
public ref class SpatialElementTag : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB.Architecture..::..RoomTag
Autodesk.Revit.DB..::..AreaTag
Autodesk.Revit.DB.Mechanical..::..SpaceTag

See Also

SpatialElementTag Members


SpatialElementTag Members

[image] [image]

Revit 2013 API
SpatialElementTag Members
SpatialElementTag Class Methods Properties See Also Send Feedback

The SpatialElementTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementTag Class


SpatialElementTag Methods

[image] [image]

Revit 2013 API
SpatialElementTag Methods
SpatialElementTag Class See Also Send Feedback

The SpatialElementTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpatialElementTag Class


SpatialElementTag Properties

[image] [image]

Revit 2013 API
SpatialElementTag Properties
SpatialElementTag Class See Also Send Feedback

The SpatialElementTag type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialElementTag Class


HasLeader Property

[image]

Revit 2013 API
SpatialElementTag..::..HasLeader Property
SpatialElementTag Class See Also Send Feedback
Identifies if a leader is displayed for the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasLeader { get; set; }
Visual Basic
Public Property HasLeader As Boolean
    Get
    Set
Visual C++
public:
property bool HasLeader {
    bool get ();
    void set (bool value);
}

Field Value

True if a leader is displayed, otherwise false.

See Also

SpatialElementTag Class


Location Property

[image]

Revit 2013 API
SpatialElementTag..::..Location Property
SpatialElementTag Class See Also Send Feedback
The location of the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

Remarks

Allows you to get and set the location of the tag within the level. The Z location should be the elevation of the level and is not changeable.

See Also

SpatialElementTag Class


Name Property

[image]

Revit 2013 API
SpatialElementTag..::..Name Property
SpatialElementTag Class See Also Send Feedback
The name associated with the tag.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This overrides Element.Name to allow the API to prevent modifications to the tag's name (because this is not permitted to be modified in the Autodesk Revit UI).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to set this property, as the name of the tag may not be changed.

See Also

SpatialElementTag Class


Parameter Property

[image] [image]

Revit 2013 API
SpatialElementTag..::..Parameter Property
SpatialElementTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialElementTag Class
SpatialElementTag Members


View Property

[image]

Revit 2013 API
SpatialElementTag..::..View Property
SpatialElementTag Class See Also Send Feedback
The view in which the tag was placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

SpatialElementTag Class


SpotDimension Class

[image]

Revit 2013 API
SpotDimension Class
Members Example See Also Send Feedback
An object that represents a spot dimension within the Revit project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpotDimension : Dimension
Visual Basic
Public Class SpotDimension _
    Inherits Dimension
Visual C++
public ref class SpotDimension : public Dimension

Examples

CopyC#
private void Getinfo_SpotDimension(SpotDimension spotDimension)
{
    string message = "SpotDimension's Location : ";
    Location location = spotDimension.Location;

    if (location is LocationPoint)
    {
        LocationPoint point = location as LocationPoint;

        message += "\n" + location.GetType().Name + " : ";
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")";
    }
    else
    {
        LocationCurve locCurve = location as LocationCurve;
        Curve curve = locCurve.Curve;
        message += "\n" + location.GetType().Name + " : ";
        message += "\nStart Point : " + "(" + curve.get_EndPoint(0).X + ", "
                    + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        message += "\nEnd point : " + "(" + curve.get_EndPoint(1).X + ", "
                    + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_SpotDimension(ByVal spotDimension As SpotDimension)
    Dim message As String = "SpotDimension's Location : "
    Dim location As Location = spotDimension.Location

    If TypeOf location Is LocationPoint Then
        Dim point As LocationPoint = TryCast(location, LocationPoint)

        message += vbLf + location.[GetType]().Name + " : "
        message += "(" + point.Point.X + ", " + point.Point.Y + ", " + point.Point.Z + ")"
    Else
        Dim locCurve As LocationCurve = TryCast(location, LocationCurve)
        Dim curve As Curve = locCurve.Curve
        message += vbLf + location.[GetType]().Name + " : "
        message += vbLf & "Start Point : " + "(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        message += vbLf & "End point : " + "(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Dimension
Autodesk.Revit.DB..::..SpotDimension

See Also

SpotDimension Members


SpotDimension Members

[image] [image]

Revit 2013 API
SpotDimension Members
SpotDimension Class Methods Properties See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | Label | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimension Class


SpotDimension Methods

[image] [image]

Revit 2013 API
SpotDimension Methods
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimension Class


SpotDimension Properties

[image] [image]

Revit 2013 API
SpotDimension Properties
SpotDimension Class See Also Send Feedback

The SpotDimension type exposes the following members.

Properties

 | Name | Description
Public property | Above | The text shown above the segment's value. (Inherited from Dimension.)
Public property | AreSegmentsEqual | Indicates if all segments are forced to be equal. (Inherited from Dimension.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Below | The text shown below the segment's value. (Inherited from Dimension.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | A curve that represents the dimension line. (Inherited from Dimension.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DimensionShape | The shape of this dimension. (Inherited from Dimension.)
Public property | DimensionType | The dimension style of this dimension. (Inherited from Dimension.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if this dimension is locked. (Inherited from Dimension.)
Public property | Label | The family parameter label of the dimension. (Inherited from Dimension.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | Get a location point object. This is the location of the spot dimension. (Overrides Element..::..Location.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Retrieves or changes the name associated with the Dimension. (Inherited from Dimension.)
Public property | NumberOfSegments | The number of segments for the dimension. (Inherited from Dimension.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Prefix | The text shown before the segment's value. (Inherited from Dimension.)
Public property | References | Returns an array of geometric references to which the dimension is attached. (Inherited from Dimension.)
Public property | Segments | The segments in the dimension. (Inherited from Dimension.)
Public property | SpotDimensionType | The dimension style of this dimension.
Public property | Suffix | The text shown after the segment's value. (Inherited from Dimension.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Value | The value of the dimension. (Inherited from Dimension.)
Public property | ValueOverride | The text that replaces the segment's value. (Inherited from Dimension.)
Public property | ValueString | The dimension value as a user visible string. (Inherited from Dimension.)
Public property | View | Supplies the view that contains the dimension if the dimension is view specific. (Inherited from Dimension.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimension Class


Location Property

[image]

Revit 2013 API
SpotDimension..::..Location Property
SpotDimension Class See Also Send Feedback
Get a location point object. This is the location of the spot dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override Location Location { get; }
Visual Basic
Public Overrides ReadOnly Property Location As Location
    Get
Visual C++
public:
virtual property Location^ Location {
    Location^ get () override;
}

See Also

SpotDimension Class


Parameter Property

[image] [image]

Revit 2013 API
SpotDimension..::..Parameter Property
SpotDimension Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpotDimension Class
SpotDimension Members


SpotDimensionType Property

[image]

Revit 2013 API
SpotDimension..::..SpotDimensionType Property
SpotDimension Class See Also Send Feedback
The dimension style of this dimension.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimensionType SpotDimensionType { get; set; }
Visual Basic
Public Property SpotDimensionType As SpotDimensionType
    Get
    Set
Visual C++
public:
property SpotDimensionType^ SpotDimensionType {
    SpotDimensionType^ get ();
    void set (SpotDimensionType^ value);
}

See Also

SpotDimension Class


SpotDimensionType Class

[image]

Revit 2013 API
SpotDimensionType Class
Members See Also Send Feedback
An object that specifies the type of a spot dimension in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpotDimensionType : DimensionType
Visual Basic
Public Class SpotDimensionType _
    Inherits DimensionType
Visual C++
public ref class SpotDimensionType : public DimensionType

Remarks

The types of a spot dimension can be accessed via this object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..DimensionType
Autodesk.Revit.DB..::..SpotDimensionType

See Also

SpotDimensionType Members


SpotDimensionType Members

[image] [image]

Revit 2013 API
SpotDimensionType Members
SpotDimensionType Class Methods Properties See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimensionType Class


SpotDimensionType Methods

[image] [image]

Revit 2013 API
SpotDimensionType Methods
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionType Class


SpotDimensionType Properties

[image] [image]

Revit 2013 API
SpotDimensionType Properties
SpotDimensionType Class See Also Send Feedback

The SpotDimensionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StyleType | The dimension style type of this DimensionType. (Inherited from DimensionType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpotDimensionType Class


Parameter Property

[image] [image]

Revit 2013 API
SpotDimensionType..::..Parameter Property
SpotDimensionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpotDimensionType Class
SpotDimensionType Members


SpotDimensionTypeSet Class

[image]

Revit 2013 API
SpotDimensionTypeSet Class
Members See Also Send Feedback
A set that contains spotdimension types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpotDimensionTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class SpotDimensionTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpotDimensionTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SpotDimensionTypeSet

See Also

SpotDimensionTypeSet Members


SpotDimensionTypeSet Members

[image] [image]

Revit 2013 API
SpotDimensionTypeSet Members
SpotDimensionTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SpotDimensionTypeSet | Initializes a new instance of the SpotDimensionTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Constructor

[image]

Revit 2013 API
SpotDimensionTypeSet Constructor
SpotDimensionTypeSet Class See Also Send Feedback
Initializes a new instance of the SpotDimensionTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimensionTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
SpotDimensionTypeSet()

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Methods

[image] [image]

Revit 2013 API
SpotDimensionTypeSet Methods
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every spotdimension type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a spotdimension type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified spotdimension type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified spotdimension type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSet Class


Clear Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..Clear Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes every spotdimension type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpotDimensionTypeSet Class


Contains Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..Contains Method
SpotDimensionTypeSet Class See Also Send Feedback
Tests for the existence of a spotdimension type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    SpotDimensionType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SpotDimensionType
The spotdimension type to be searched for.

Return Value

The Contains method returns True if the spotdimension type is within the set, otherwise False.

See Also

SpotDimensionTypeSet Class


Erase Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..Erase Method
SpotDimensionTypeSet Class See Also Send Feedback
Removes a specified spotdimension type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    SpotDimensionType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As SpotDimensionType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SpotDimensionType
The spotdimension type to be erased.

Return Value

The number of spotdimension types that were erased from the set.

See Also

SpotDimensionTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..ForwardIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpotDimensionTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..GetEnumerator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SpotDimensionTypeSet Class


Insert Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..Insert Method
SpotDimensionTypeSet Class See Also Send Feedback
Insert the specified spotdimension type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    SpotDimensionType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As SpotDimensionType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpotDimensionType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SpotDimensionType
The spotdimension type to be inserted into the set.

Return Value

Returns whether the spotdimension type was inserted into the set.

See Also

SpotDimensionTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
SpotDimensionTypeSet..::..ReverseIterator Method
SpotDimensionTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpotDimensionTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SpotDimensionTypeSetIterator
Visual C++
public:
virtual SpotDimensionTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSet Properties

[image] [image]

Revit 2013 API
SpotDimensionTypeSet Properties
SpotDimensionTypeSet Class See Also Send Feedback

The SpotDimensionTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of spotdimension types that are in the set.

See Also

SpotDimensionTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
SpotDimensionTypeSet..::..IsEmpty Property
SpotDimensionTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpotDimensionTypeSet Class


Size Property

[image]

Revit 2013 API
SpotDimensionTypeSet..::..Size Property
SpotDimensionTypeSet Class See Also Send Feedback
Returns the number of spotdimension types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpotDimensionTypeSet Class


SpotDimensionTypeSetIterator Class

[image]

Revit 2013 API
SpotDimensionTypeSetIterator Class
Members See Also Send Feedback
An iterator to a spotdimension type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SpotDimensionTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SpotDimensionTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpotDimensionTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SpotDimensionTypeSetIterator

See Also

SpotDimensionTypeSetIterator Members


SpotDimensionTypeSetIterator Members

[image] [image]

Revit 2013 API
SpotDimensionTypeSetIterator Members
SpotDimensionTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SpotDimensionTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Constructor

[image]

Revit 2013 API
SpotDimensionTypeSetIterator Constructor
SpotDimensionTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpotDimensionTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
SpotDimensionTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Methods

[image] [image]

Revit 2013 API
SpotDimensionTypeSetIterator Methods
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotDimensionTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
SpotDimensionTypeSetIterator..::..MoveNext Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
SpotDimensionTypeSetIterator..::..Reset Method
SpotDimensionTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpotDimensionTypeSetIterator Class


SpotDimensionTypeSetIterator Properties

[image] [image]

Revit 2013 API
SpotDimensionTypeSetIterator Properties
SpotDimensionTypeSetIterator Class See Also Send Feedback

The SpotDimensionTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpotDimensionTypeSetIterator Class


Current Property

[image]

Revit 2013 API
SpotDimensionTypeSetIterator..::..Current Property
SpotDimensionTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpotDimensionTypeSetIterator Class


StairsEditScope Class

[image]

Revit 2013 API
StairsEditScope Class
Members See Also Send Feedback
StairsEditScope allows user to maintain a stairs-editing session.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsEditScope : IDisposable
Visual Basic
Public Class StairsEditScope _
    Implements IDisposable
Visual C++
public ref class StairsEditScope : IDisposable

Remarks

Start/end of a StairsEditScope will start/end a transaction group. After a StairsEditScope is started, user can start transactions and edit the stairs. Individual transactions the user creates inside StairsEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into StairsEditScope constructor.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StairsEditScope

See Also

StairsEditScope Members


StairsEditScope Members

[image] [image]

Revit 2013 API
StairsEditScope Members
StairsEditScope Class Constructors Methods Properties See Also Send Feedback

The StairsEditScope type exposes the following members.

Constructors

 | Name | Description
Public method | StairsEditScope | Instantiates a StairsEditScope object.

Methods

 | Name | Description
Public method | Cancel | Cancels editing for the stairs.
Public method | Commit | Finishes editing for the stairs.
Public method | Dispose | Releases all resources used by the StairsEditScope
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsActive | Tells if the StairsEditScope is active. In other word, the StairsEditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the StairsEditScope is permitted to start.

See Also

StairsEditScope Class


StairsEditScope Constructor

[image]

Revit 2013 API
StairsEditScope Constructor
StairsEditScope Class See Also Send Feedback
Instantiates a StairsEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsEditScope(
    Document document,
    string transactionName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transactionName As String _
)
Visual C++
public:
StairsEditScope(
    Document^ document,
    String^ transactionName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this StairsEditScope is going to be used.
transactionName
Type: System..::..String
The name that will appear in the Undo menu in Revit after the StairsEditScope is successfully committed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StairsEditScope Class


StairsEditScope Methods

[image] [image]

Revit 2013 API
StairsEditScope Methods
StairsEditScope Class See Also Send Feedback

The StairsEditScope type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Cancels editing for the stairs.
Public method | Commit | Finishes editing for the stairs.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsEditScope Class


Cancel Method

[image]

Revit 2013 API
StairsEditScope..::..Cancel Method
StairsEditScope Class See Also Send Feedback
Cancels editing for the stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

All the changes made after starting the StairsEditScope will be rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not active. StairsEditScope can only be committed or cancelled when it is active. -or- StairsEditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also

StairsEditScope Class


Commit Method

[image]

Revit 2013 API
StairsEditScope..::..Commit Method
StairsEditScope Class See Also Send Feedback
Finishes editing for the stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Commit()
Visual Basic
Public Sub Commit
Visual C++
public:
void Commit()

Remarks

All the changes made after starting the StairsEditScope will be committed and merged into one transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not active. StairsEditScope can only be committed or cancelled when it is active. -or- StairsEditScope cannot be closed, for there is a transaction or transaction group still open in the document.

See Also

StairsEditScope Class


Dispose Method

[image]

Revit 2013 API
StairsEditScope..::..Dispose Method
StairsEditScope Class See Also Send Feedback
Releases all resources used by the StairsEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StairsEditScope Class


Start Method

[image] [image]

Revit 2013 API
StairsEditScope..::..Start Method
StairsEditScope Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start(ElementId) | Starts an stairs edit mode for an existing Stairs element
Public method | Start(ElementId, ElementId) | Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.

See Also

StairsEditScope Class
StairsEditScope Members


Start Method (ElementId)

[image]

Revit 2013 API
StairsEditScope..::..Start Method (ElementId)
StairsEditScope Class See Also Send Feedback
Starts an stairs edit mode for an existing Stairs element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Start(
    ElementId stairsId
)
Visual Basic
Public Function Start ( _
    stairsId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ Start(
    ElementId^ stairsId
)

Parameters

stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs element to be edited.

Return Value

ElementId of the editing stairs. It should be the same as the input stairsId

Remarks

User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Stair's id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not permitted to start at this moment for one of the following reasons: The document is in read-only state, or the document is currently modifiable, or there already is a stairs edit mode active in the document.

See Also

StairsEditScope Class
Start Overload


Start Method (ElementId, ElementId)

[image]

Revit 2013 API
StairsEditScope..::..Start Method (ElementId, ElementId)
StairsEditScope Class See Also Send Feedback
Creates a new empty stairs element with a default stairs type in the specified levels and then starts stairs edit mode and editing the new stairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Start(
    ElementId baseLevelId,
    ElementId topLevelId
)
Visual Basic
Public Function Start ( _
    baseLevelId As ElementId, _
    topLevelId As ElementId _
) As ElementId
Visual C++
public:
ElementId^ Start(
    ElementId^ baseLevelId,
    ElementId^ topLevelId
)

Parameters

baseLevelId
Type: Autodesk.Revit.DB..::..ElementId
The base level on which the stairs is to be placed.
topLevelId
Type: Autodesk.Revit.DB..::..ElementId
The top level where the stairs is to reach.

Return Value

ElementId of the new stairs.

Remarks

A new stairs will be created after this operation. User will need to start a transaction to actually make changes to the stairs element. StairsEditScope can only be started when there is no transaction active Thus it does not work for commands running in automatic transaction mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Level's id. -or- Top level should be higher than base level.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not permitted to start at this moment for one of the following reasons: The document is in read-only state, or the document is currently modifiable, or there already is a stairs edit mode active in the document.

See Also

StairsEditScope Class
Start Overload


StairsEditScope Properties

[image] [image]

Revit 2013 API
StairsEditScope Properties
StairsEditScope Class See Also Send Feedback

The StairsEditScope type exposes the following members.

Properties

 | Name | Description
Public property | IsActive | Tells if the StairsEditScope is active. In other word, the StairsEditScope has started but not committed/canceled yet.
Public property | IsPermitted | Tells if the StairsEditScope is permitted to start.

See Also

StairsEditScope Class


IsActive Property

[image]

Revit 2013 API
StairsEditScope..::..IsActive Property
StairsEditScope Class See Also Send Feedback
Tells if the StairsEditScope is active. In other word, the StairsEditScope has started but not committed/canceled yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsActive { get; }
Visual Basic
Public ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
property bool IsActive {
    bool get ();
}

Remarks

Starting the stairs edit mode is not permitted when it is active. Canceling/committing is not allowed when the stairs edit mode is not active.

See Also

StairsEditScope Class


IsPermitted Property

[image]

Revit 2013 API
StairsEditScope..::..IsPermitted Property
StairsEditScope Class See Also Send Feedback
Tells if the StairsEditScope is permitted to start.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPermitted { get; }
Visual Basic
Public ReadOnly Property IsPermitted As Boolean
    Get
Visual C++
public:
property bool IsPermitted {
    bool get ();
}

Remarks

The StairsEditScope is not permitted to start if any other edit mode is active in the same document.

See Also

StairsEditScope Class


StartingViewSettings Class

[image]

Revit 2013 API
StartingViewSettings Class
Members See Also Send Feedback
The initial view settings for a document dictate which view will initially be open when this model is opened. These settings are available for all Revit project documents. This element is unique and should be created only by upgrade.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class StartingViewSettings : IDisposable
Visual Basic
Public Class StartingViewSettings _
    Implements IDisposable
Visual C++
public ref class StartingViewSettings : IDisposable

Remarks

If worksharing is enabled, the same settings will be used by the central model and all local files and the settings will live in the Project Info workset.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StartingViewSettings

See Also

StartingViewSettings Members


StartingViewSettings Members

[image] [image]

Revit 2013 API
StartingViewSettings Members
StartingViewSettings Class Methods Properties See Also Send Feedback

The StartingViewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the StartingViewSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.

See Also

StartingViewSettings Class


StartingViewSettings Methods

[image] [image]

Revit 2013 API
StartingViewSettings Methods
StartingViewSettings Class See Also Send Feedback

The StartingViewSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStartingViewSettings | Returns the starting view settings for the specified document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAcceptableStartingView | Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StartingViewSettings Class


Dispose Method

[image]

Revit 2013 API
StartingViewSettings..::..Dispose Method
StartingViewSettings Class See Also Send Feedback
Releases all resources used by the StartingViewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StartingViewSettings Class


GetStartingViewSettings Method

[image]

Revit 2013 API
StartingViewSettings..::..GetStartingViewSettings Method
StartingViewSettings Class See Also Send Feedback
Returns the starting view settings for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static StartingViewSettings GetStartingViewSettings(
    Document doc
)
Visual Basic
Public Shared Function GetStartingViewSettings ( _
    doc As Document _
) As StartingViewSettings
Visual C++
public:
static StartingViewSettings^ GetStartingViewSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document to get the settings from, which must be a project document.

Return Value

The starting view settings for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StartingViewSettings Class


IsAcceptableStartingView Method

[image]

Revit 2013 API
StartingViewSettings..::..IsAcceptableStartingView Method
StartingViewSettings Class See Also Send Feedback
Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsAcceptableStartingView(
    ElementId viewId
)
Visual Basic
Public Function IsAcceptableStartingView ( _
    viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsAcceptableStartingView(
    ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the element to check.

Return Value

True if the view is acceptable, False if it is not.

Remarks

Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable. In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable. Special views such as the project browser, system navigator, reports, revision schedules, internal schedules, sheets that are not actually in use, and views that belong to a family are not acceptable.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StartingViewSettings Class


StartingViewSettings Properties

[image] [image]

Revit 2013 API
StartingViewSettings Properties
StartingViewSettings Class See Also Send Feedback

The StartingViewSettings type exposes the following members.

Properties

 | Name | Description
Public property | ViewId | Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.

See Also

StartingViewSettings Class


ViewId Property

[image]

Revit 2013 API
StartingViewSettings..::..ViewId Property
StartingViewSettings Class See Also Send Feedback
Indicates the specific view that will be opened when the model is loaded. InvalidElementId indicates that no view has been specified. In that case, Revit will open the last views that were open at the time the file was saved.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ViewId { get; set; }
Visual Basic
Public Property ViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

Note that InvalidElementId will cause Revit to open the same view it would have used in Revit 2011 and prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: viewId is not an acceptable starting view for this model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StartingViewSettings Class


StickSymbolLocation Enumeration

[image]

Revit 2013 API
StickSymbolLocation Enumeration
See Also Send Feedback
Indicates the stick symbol location on the UI, which is used for the BuiltInParameter STRUCTURAL_STICK_SYMBOL_LOCATION.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum StickSymbolLocation
Visual Basic
Public Enumeration StickSymbolLocation
Visual C++
public enum class StickSymbolLocation

Members

Member name | Description
StickViewCenter |
StickViewTop |
StickViewBottom |
StickViewLocLine |

See Also


StorageType Enumeration

[image]

Revit 2013 API
StorageType Enumeration
See Also Send Feedback
An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum StorageType
Visual Basic
Public Enumeration StorageType
Visual C++
public enum class StorageType

Members

Member name | Description
None | None represents an invalid storage type. This value should not be used.
Integer | The internal data is stored in the form of a signed 32 bit integer.
Double | The data will be stored internally in the form of an 8 byte floating point number.
String | The internal data will be stored in the form of a string of characters.
ElementId | The data type represents an element and is stored as the id of the element.

See Also


StructDeckEmbeddingType Enumeration

[image]

Revit 2013 API
StructDeckEmbeddingType Enumeration
See Also Send Feedback
Used in class CompoundStructure to specify the usage of a layer whose function is StructuralDeck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum StructDeckEmbeddingType
Visual Basic
Public Enumeration StructDeckEmbeddingType
Visual C++
public enum class StructDeckEmbeddingType

Members

Member name | Description
Invalid | Invalid usage.
MergeWithLayerAbove | Bound layer above.
Standalone | Standalone deck.

See Also


StructuralAsset Class

[image]

Revit 2013 API
StructuralAsset Class
Members See Also Send Feedback
Represents the properties of a material pertinent to structural analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StructuralAsset : IDisposable
Visual Basic
Public Class StructuralAsset _
    Implements IDisposable
Visual C++
public ref class StructuralAsset : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..StructuralAsset

See Also

StructuralAsset Members


StructuralAsset Members

[image] [image]

Revit 2013 API
StructuralAsset Members
StructuralAsset Class Constructors Methods Properties See Also Send Feedback

The StructuralAsset type exposes the following members.

Constructors

 | Name | Description
Public method | StructuralAsset | Constructs an instance of StructuralAsset.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the StructuralAsset
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Behavior |
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | DampingRatio | The damping ratio of the asset.
Public property | Density | The density of the asset.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | UnitWeight | Obsolete. The weight per unit volume of the material described by the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.

See Also

StructuralAsset Class


StructuralAsset Constructor

[image]

Revit 2013 API
StructuralAsset Constructor
StructuralAsset Class See Also Send Feedback
Constructs an instance of StructuralAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StructuralAsset(
    string name,
    StructuralAssetClass structuralAssetClass
)
Visual Basic
Public Sub New ( _
    name As String, _
    structuralAssetClass As StructuralAssetClass _
)
Visual C++
public:
StructuralAsset(
    String^ name,
    StructuralAssetClass structuralAssetClass
)

Parameters

name
Type: System..::..String
The name of the asset.
structuralAssetClass
Type: Autodesk.Revit.DB..::..StructuralAssetClass
The type of structural material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralAsset Class


StructuralAsset Methods

[image] [image]

Revit 2013 API
StructuralAsset Methods
StructuralAsset Class See Also Send Feedback

The StructuralAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPoissonRatio | Sets the Poisson ratio of the asset.
Public method | SetShearModulus | Sets the shear modulus of the asset.
Public method | SetThermalExpansionCoefficient | Sets the thermal expansion coefficient of the asset.
Public method | SetYoungModulus | Sets the Young's modulus of the asset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralAsset Class


Copy Method

[image]

Revit 2013 API
StructuralAsset..::..Copy Method
StructuralAsset Class See Also Send Feedback
Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StructuralAsset Copy()
Visual Basic
Public Function Copy As StructuralAsset
Visual C++
public:
StructuralAsset^ Copy()

Return Value

A copy of the asset.

See Also

StructuralAsset Class


Dispose Method

[image]

Revit 2013 API
StructuralAsset..::..Dispose Method
StructuralAsset Class See Also Send Feedback
Releases all resources used by the StructuralAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StructuralAsset Class


Equals Method

[image] [image]

Revit 2013 API
StructuralAsset..::..Equals Method
StructuralAsset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(StructuralAsset) | Determines whether this structural asset is equal to another.

See Also

StructuralAsset Class
StructuralAsset Members


Equals Method (StructuralAsset)

[image]

Revit 2013 API
StructuralAsset..::..Equals Method (StructuralAsset)
StructuralAsset Class See Also Send Feedback
Determines whether this structural asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Equals(
    StructuralAsset other
)
Visual Basic
Public Function Equals ( _
    other As StructuralAsset _
) As Boolean
Visual C++
public:
bool Equals(
    StructuralAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset with which to compare this structural asset.

Return Value

True if the given structural asset is equal to this one, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralAsset Class
Equals Overload


SetPoissonRatio Method

[image]

Revit 2013 API
StructuralAsset..::..SetPoissonRatio Method
StructuralAsset Class See Also Send Feedback
Sets the Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetPoissonRatio(
    double poissonRatio
)
Visual Basic
Public Sub SetPoissonRatio ( _
    poissonRatio As Double _
)
Visual C++
public:
void SetPoissonRatio(
    double poissonRatio
)

Parameters

poissonRatio
Type: System..::..Double

Remarks

The Poisson ratio is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value.

See Also

StructuralAsset Class


SetShearModulus Method

[image]

Revit 2013 API
StructuralAsset..::..SetShearModulus Method
StructuralAsset Class See Also Send Feedback
Sets the shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetShearModulus(
    double shearModulus
)
Visual Basic
Public Sub SetShearModulus ( _
    shearModulus As Double _
)
Visual C++
public:
void SetShearModulus(
    double shearModulus
)

Parameters

shearModulus
Type: System..::..Double

Remarks

The shear modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft · m)).

See Also

StructuralAsset Class


SetThermalExpansionCoefficient Method

[image]

Revit 2013 API
StructuralAsset..::..SetThermalExpansionCoefficient Method
StructuralAsset Class See Also Send Feedback
Sets the thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)
Visual Basic
Public Sub SetThermalExpansionCoefficient ( _
    thermalExpCoeff As Double _
)
Visual C++
public:
void SetThermalExpansionCoefficient(
    double thermalExpCoeff
)

Parameters

thermalExpCoeff
Type: System..::..Double

Remarks

The thermal expansion coefficient is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in inverse Kelvin (1/K).

See Also

StructuralAsset Class


SetYoungModulus Method

[image]

Revit 2013 API
StructuralAsset..::..SetYoungModulus Method
StructuralAsset Class See Also Send Feedback
Sets the Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetYoungModulus(
    double youngModulus
)
Visual Basic
Public Sub SetYoungModulus ( _
    youngModulus As Double _
)
Visual C++
public:
void SetYoungModulus(
    double youngModulus
)

Parameters

youngModulus
Type: System..::..Double

Remarks

The Young's modulus is one-dimensional for wood-based and isotropic materials. This method sets the x, y, and z components to the same value. The value is in Newtons per foot meter (N/(ft · m)).

See Also

StructuralAsset Class


StructuralAsset Properties

[image] [image]

Revit 2013 API
StructuralAsset Properties
StructuralAsset Class See Also Send Feedback

The StructuralAsset type exposes the following members.

Properties

 | Name | Description
Public property | Behavior |
Public property | ConcreteBendingReinforcement | The bending reinforcement of the asset.
Public property | ConcreteCompression | The compression strength of concrete-based assets.
Public property | ConcreteShearReinforcement | The shear reinforcement of the asset.
Public property | ConcreteShearStrengthReduction | The shear strength reduction of the asset.
Public property | DampingRatio | The damping ratio of the asset.
Public property | Density | The density of the asset.
Public property | Lightweight | Flag indicating whether the asset describes a material that is light-weight or not.
Public property | MetalReductionFactor | The reduction factor of the asset.
Public property | MetalResistanceCalculationStrength | The resistance calculation strength of the asset.
Public property | MinimumTensileStrength | The minimum tensile strength of the asset.
Public property | MinimumYieldStress | The minimum yield stress of the asset.
Public property | Name | The name of the structural asset.
Public property | PoissonRatio | The Poisson ratio of the asset.
Public property | ShearModulus | The shear modulus of the asset.
Public property | StructuralAssetClass | The type of material that this structural asset describes (e.g. wood, concrete, metal.)
Public property | SubClass | The sub-class of the asset.
Public property | ThermalExpansionCoefficient | The thermal expansion coefficient of the asset.
Public property | UnitWeight | Obsolete. The weight per unit volume of the material described by the asset.
Public property | WoodBendingStrength | The bending strength of the asset.
Public property | WoodGrade | The grade of wood used in a wood-based asset.
Public property | WoodParallelCompressionStrength | The parallel compression strength of the asset.
Public property | WoodParallelShearStrength | The parallel shear strength of the asset.
Public property | WoodPerpendicularCompressionStrength | The perpendicular compression strength of the asset.
Public property | WoodPerpendicularShearStrength | The perpendicular shear strength of the asset.
Public property | WoodSpecies | The species of wood used in a wood-based asset.
Public property | YoungModulus | The Young's modulus of the asset.

See Also

StructuralAsset Class


Behavior Property

[image]

Revit 2013 API
StructuralAsset..::..Behavior Property
StructuralAsset Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralBehavior Behavior { get; set; }
Visual Basic
Public Property Behavior As StructuralBehavior
    Get
    Set
Visual C++
public:
property StructuralBehavior Behavior {
    StructuralBehavior get ();
    void set (StructuralBehavior value);
}

See Also

StructuralAsset Class


ConcreteBendingReinforcement Property

[image]

Revit 2013 API
StructuralAsset..::..ConcreteBendingReinforcement Property
StructuralAsset Class See Also Send Feedback
The bending reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ConcreteBendingReinforcement { get; set; }
Visual Basic
Public Property ConcreteBendingReinforcement As Double
    Get
    Set
Visual C++
public:
property double ConcreteBendingReinforcement {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteCompression Property

[image]

Revit 2013 API
StructuralAsset..::..ConcreteCompression Property
StructuralAsset Class See Also Send Feedback
The compression strength of concrete-based assets.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ConcreteCompression { get; set; }
Visual Basic
Public Property ConcreteCompression As Double
    Get
    Set
Visual C++
public:
property double ConcreteCompression {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteShearReinforcement Property

[image]

Revit 2013 API
StructuralAsset..::..ConcreteShearReinforcement Property
StructuralAsset Class See Also Send Feedback
The shear reinforcement of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ConcreteShearReinforcement { get; set; }
Visual Basic
Public Property ConcreteShearReinforcement As Double
    Get
    Set
Visual C++
public:
property double ConcreteShearReinforcement {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


ConcreteShearStrengthReduction Property

[image]

Revit 2013 API
StructuralAsset..::..ConcreteShearStrengthReduction Property
StructuralAsset Class See Also Send Feedback
The shear strength reduction of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ConcreteShearStrengthReduction { get; set; }
Visual Basic
Public Property ConcreteShearStrengthReduction As Double
    Get
    Set
Visual C++
public:
property double ConcreteShearStrengthReduction {
    double get ();
    void set (double value);
}

Remarks

Applies to concrete-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be concrete to set this property.

See Also

StructuralAsset Class


DampingRatio Property

[image]

Revit 2013 API
StructuralAsset..::..DampingRatio Property
StructuralAsset Class See Also Send Feedback
The damping ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double DampingRatio { get; set; }
Visual Basic
Public Property DampingRatio As Double
    Get
    Set
Visual C++
public:
property double DampingRatio {
    double get ();
    void set (double value);
}

See Also

StructuralAsset Class


Density Property

[image]

Revit 2013 API
StructuralAsset..::..Density Property
StructuralAsset Class See Also Send Feedback
The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Density { get; set; }
Visual Basic
Public Property Density As Double
    Get
    Set
Visual C++
public:
property double Density {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per cubed feet (kg/ft³) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.

See Also

StructuralAsset Class


Lightweight Property

[image]

Revit 2013 API
StructuralAsset..::..Lightweight Property
StructuralAsset Class See Also Send Feedback
Flag indicating whether the asset describes a material that is light-weight or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Lightweight { get; set; }
Visual Basic
Public Property Lightweight As Boolean
    Get
    Set
Visual C++
public:
property bool Lightweight {
    bool get ();
    void set (bool value);
}

See Also

StructuralAsset Class


MetalReductionFactor Property

[image]

Revit 2013 API
StructuralAsset..::..MetalReductionFactor Property
StructuralAsset Class See Also Send Feedback
The reduction factor of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MetalReductionFactor { get; set; }
Visual Basic
Public Property MetalReductionFactor As Double
    Get
    Set
Visual C++
public:
property double MetalReductionFactor {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal to set this property.

See Also

StructuralAsset Class


MetalResistanceCalculationStrength Property

[image]

Revit 2013 API
StructuralAsset..::..MetalResistanceCalculationStrength Property
StructuralAsset Class See Also Send Feedback
The resistance calculation strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MetalResistanceCalculationStrength { get; set; }
Visual Basic
Public Property MetalResistanceCalculationStrength As Double
    Get
    Set
Visual C++
public:
property double MetalResistanceCalculationStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to metal-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal to set this property.

See Also

StructuralAsset Class


MinimumTensileStrength Property

[image]

Revit 2013 API
StructuralAsset..::..MinimumTensileStrength Property
StructuralAsset Class See Also Send Feedback
The minimum tensile strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinimumTensileStrength { get; set; }
Visual Basic
Public Property MinimumTensileStrength As Double
    Get
    Set
Visual C++
public:
property double MinimumTensileStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.

See Also

StructuralAsset Class


MinimumYieldStress Property

[image]

Revit 2013 API
StructuralAsset..::..MinimumYieldStress Property
StructuralAsset Class See Also Send Feedback
The minimum yield stress of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinimumYieldStress { get; set; }
Visual Basic
Public Property MinimumYieldStress As Double
    Get
    Set
Visual C++
public:
property double MinimumYieldStress {
    double get ();
    void set (double value);
}

Remarks

Applies to Metal-based and generic structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be Metal or generic to set this property.

See Also

StructuralAsset Class


Name Property

[image]

Revit 2013 API
StructuralAsset..::..Name Property
StructuralAsset Class See Also Send Feedback
The name of the structural asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StructuralAsset Class


PoissonRatio Property

[image]

Revit 2013 API
StructuralAsset..::..PoissonRatio Property
StructuralAsset Class See Also Send Feedback
The Poisson ratio of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ PoissonRatio { get; set; }
Visual Basic
Public Property PoissonRatio As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ PoissonRatio {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the Poisson ratio for wood-based and isotropic materials. For such assets, use setPoissonRatio instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


ShearModulus Property

[image]

Revit 2013 API
StructuralAsset..::..ShearModulus Property
StructuralAsset Class See Also Send Feedback
The shear modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ ShearModulus { get; set; }
Visual Basic
Public Property ShearModulus As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ShearModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the shear modulus for wood-based and isotropic materials. For such assets, use setShearModulus instead. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


StructuralAssetClass Property

[image]

Revit 2013 API
StructuralAsset..::..StructuralAssetClass Property
StructuralAsset Class See Also Send Feedback
The type of material that this structural asset describes (e.g. wood, concrete, metal.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StructuralAssetClass StructuralAssetClass { get; }
Visual Basic
Public ReadOnly Property StructuralAssetClass As StructuralAssetClass
    Get
Visual C++
public:
property StructuralAssetClass StructuralAssetClass {
    StructuralAssetClass get ();
}

See Also

StructuralAsset Class


SubClass Property

[image]

Revit 2013 API
StructuralAsset..::..SubClass Property
StructuralAsset Class See Also Send Feedback
The sub-class of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string SubClass { get; set; }
Visual Basic
Public Property SubClass As String
    Get
    Set
Visual C++
public:
property String^ SubClass {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StructuralAsset Class


ThermalExpansionCoefficient Property

[image]

Revit 2013 API
StructuralAsset..::..ThermalExpansionCoefficient Property
StructuralAsset Class See Also Send Feedback
The thermal expansion coefficient of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ ThermalExpansionCoefficient { get; set; }
Visual Basic
Public Property ThermalExpansionCoefficient As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ThermalExpansionCoefficient {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the thermal expansion coefficient for wood-based and isotropic materials. For such assets, use setThermalExpansionCoefficient instead. The value is in inverse Kelvin (1/K).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


UnitWeight Property

[image]

Revit 2013 API
StructuralAsset..::..UnitWeight Property
StructuralAsset Class See Also Send Feedback
The weight per unit volume of the material described by the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
[ObsoleteAttribute("Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")]
public double UnitWeight { get; set; }
Visual Basic
<ObsoleteAttribute("Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")> _
Public Property UnitWeight As Double
    Get
    Set
Visual C++
[ObsoleteAttribute(L"Unit weight is deprecated and will be removed in a future version of Revit. Use density instead.")]
public:
property double UnitWeight {
    double get ();
    void set (double value);
}

Remarks

The value is in kilograms per square foot, square second (kg / ft² · s²).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for unitWeight must be non-negative.

See Also

StructuralAsset Class


WoodBendingStrength Property

[image]

Revit 2013 API
StructuralAsset..::..WoodBendingStrength Property
StructuralAsset Class See Also Send Feedback
The bending strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WoodBendingStrength { get; set; }
Visual Basic
Public Property WoodBendingStrength As Double
    Get
    Set
Visual C++
public:
property double WoodBendingStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodGrade Property

[image]

Revit 2013 API
StructuralAsset..::..WoodGrade Property
StructuralAsset Class See Also Send Feedback
The grade of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string WoodGrade { get; set; }
Visual Basic
Public Property WoodGrade As String
    Get
    Set
Visual C++
public:
property String^ WoodGrade {
    String^ get ();
    void set (String^ value);
}

Remarks

Applies to wood-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodParallelCompressionStrength Property

[image]

Revit 2013 API
StructuralAsset..::..WoodParallelCompressionStrength Property
StructuralAsset Class See Also Send Feedback
The parallel compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WoodParallelCompressionStrength { get; set; }
Visual Basic
Public Property WoodParallelCompressionStrength As Double
    Get
    Set
Visual C++
public:
property double WoodParallelCompressionStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodParallelShearStrength Property

[image]

Revit 2013 API
StructuralAsset..::..WoodParallelShearStrength Property
StructuralAsset Class See Also Send Feedback
The parallel shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WoodParallelShearStrength { get; set; }
Visual Basic
Public Property WoodParallelShearStrength As Double
    Get
    Set
Visual C++
public:
property double WoodParallelShearStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodPerpendicularCompressionStrength Property

[image]

Revit 2013 API
StructuralAsset..::..WoodPerpendicularCompressionStrength Property
StructuralAsset Class See Also Send Feedback
The perpendicular compression strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WoodPerpendicularCompressionStrength { get; set; }
Visual Basic
Public Property WoodPerpendicularCompressionStrength As Double
    Get
    Set
Visual C++
public:
property double WoodPerpendicularCompressionStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodPerpendicularShearStrength Property

[image]

Revit 2013 API
StructuralAsset..::..WoodPerpendicularShearStrength Property
StructuralAsset Class See Also Send Feedback
The perpendicular shear strength of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WoodPerpendicularShearStrength { get; set; }
Visual Basic
Public Property WoodPerpendicularShearStrength As Double
    Get
    Set
Visual C++
public:
property double WoodPerpendicularShearStrength {
    double get ();
    void set (double value);
}

Remarks

Applies to wood-based structural assets. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


WoodSpecies Property

[image]

Revit 2013 API
StructuralAsset..::..WoodSpecies Property
StructuralAsset Class See Also Send Feedback
The species of wood used in a wood-based asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string WoodSpecies { get; set; }
Visual Basic
Public Property WoodSpecies As String
    Get
    Set
Visual C++
public:
property String^ WoodSpecies {
    String^ get ();
    void set (String^ value);
}

Remarks

Applies to wood-based structural assets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type must be wood to set this property.

See Also

StructuralAsset Class


YoungModulus Property

[image]

Revit 2013 API
StructuralAsset..::..YoungModulus Property
StructuralAsset Class See Also Send Feedback
The Young's modulus of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ YoungModulus { get; set; }
Visual Basic
Public Property YoungModulus As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ YoungModulus {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This property cannot be used to set the Young's modulus for wood-based and isotropic materials. For such assets, use setYoungModulus instead. The value is in Newtons per foot meter (N/(ft · m)).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the material type is wood. -or- When setting this property: the behavior is isotropic.

See Also

StructuralAsset Class


StructuralAssetClass Enumeration

[image]

Revit 2013 API
StructuralAssetClass Enumeration
See Also Send Feedback
Represents the type of material described by a structural asset. This enum value is returned by Autodesk::Revit::DB::StructuralAsset::StructuralAssetClass.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum StructuralAssetClass
Visual Basic
Public Enumeration StructuralAssetClass
Visual C++
public enum class StructuralAssetClass

Members

Member name | Description
Undefined | Structural asset class is undefined.
Basic | Structural asset class is basic.
Generic | Structural asset class is generic.
Metal | Structural asset class is metal.
Concrete | Structural asset class is concrete.
Wood | Structural asset class is wood.
Liquid | Structural asset class is liquid.
Gas | Structural asset class is gas.
Plastic | Structural asset class is plastic.

See Also


StructuralBehavior Enumeration

[image]

Revit 2013 API
StructuralBehavior Enumeration
See Also Send Feedback
Specifies whether structural elements behave orthotropically, isotropically, or transverse-isotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum StructuralBehavior
Visual Basic
Public Enumeration StructuralBehavior
Visual C++
public enum class StructuralBehavior

Members

Member name | Description
Isotropic | The structural element behaves isotropically.
Orthotropic | The structural element behaves orthotropically.
TransverseIsotropic | The structural element behaves transverse-isotropically.

See Also


StructuralReleaseType Enumeration

[image]

Revit 2013 API
StructuralReleaseType Enumeration
See Also Send Feedback
Type of structural release, which is used for the BuiltIn parameter STRUCTURAL_END_RELEASE_TYPE.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum StructuralReleaseType
Visual Basic
Public Enumeration StructuralReleaseType
Visual C++
public enum class StructuralReleaseType

Members

Member name | Description
kFixed |
kPinned |
kBendingMoment |
kUserDefined |

See Also


SubfaceType Enumeration

[image]

Revit 2013 API
SubfaceType Enumeration
See Also Send Feedback
Meaning of a subface's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum SubfaceType
Visual Basic
Public Enumeration SubfaceType
Visual C++
public enum class SubfaceType

Members

Member name | Description
Bottom | A horizontal face at the bottom of the room, as defined by the room's level and base offset, or a face of the room that is bounded below by a room-bounding element.
Top | A horizontal top face of the room as defined by the room's level and height, or a face of the room that is bounded above by a room-bounding element.
Side | Any face which does not meet the criteria to be Top or Bottom.

See Also


SubTransaction Class

[image]

Revit 2013 API
SubTransaction Class
Members See Also Send Feedback
Sub-transactions are objects that provide control over a subset of changes in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SubTransaction : IDisposable
Visual Basic
Public Class SubTransaction _
    Implements IDisposable
Visual C++
public ref class SubTransaction : IDisposable

Remarks

A Sub-transaction can only be active as a part of an open transaction. Sub-transactions may be nested inside each other, but with the restriction that every nested sub-transaction is entirely contained (opened and closed) in the parent sub-transaction.

If a sub-transaction was started and not committed or rolled back by the time the SubTransaction object is about to be disposed, the destructor will roll back the sub-transaction automatically, thus all changes made to the document during the sub-transaction will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the sub-transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..SubTransaction

See Also

SubTransaction Members


SubTransaction Members

[image] [image]

Revit 2013 API
SubTransaction Members
SubTransaction Class Constructors Methods See Also Send Feedback

The SubTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | SubTransaction | Instantiates a sub-transaction object

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose | Releases all resources used by the SubTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class


SubTransaction Constructor

[image]

Revit 2013 API
SubTransaction Constructor
SubTransaction Class See Also Send Feedback
Instantiates a sub-transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SubTransaction(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
SubTransaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this sub-transaction is going to be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SubTransaction Class


SubTransaction Methods

[image] [image]

Revit 2013 API
SubTransaction Methods
SubTransaction Class See Also Send Feedback

The SubTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the model made during the sub-transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStatus | Returns the current status of the sub-transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the sub-transaction has ended already.
Public method | HasStarted | Determines whether the sub-transaction has been started yet.
Public method | RollBack | Discards all changes made to the model during the sub-transaction.
Public method | Start | Starts the sub-transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SubTransaction Class


Commit Method

[image]

Revit 2013 API
SubTransaction..::..Commit Method
SubTransaction Class See Also Send Feedback
Commits all changes made to the model made during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed

Remarks

The changes are not permanently committed to the document yet. They will be committed only when the active transaction is committed. If the transaction is rolled back instead, the changes committed during this sub-transaction will be discarded.

Commit can be called only when all inner sub-transactions, if any, are already finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to commit this outer sub-transaction will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


Dispose Method

[image]

Revit 2013 API
SubTransaction..::..Dispose Method
SubTransaction Class See Also Send Feedback
Releases all resources used by the SubTransaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SubTransaction Class


GetStatus Method

[image]

Revit 2013 API
SubTransaction..::..GetStatus Method
SubTransaction Class See Also Send Feedback
Returns the current status of the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

Return Value

The current status of the sub-transaction.

See Also

SubTransaction Class


HasEnded Method

[image]

Revit 2013 API
SubTransaction..::..HasEnded Method
SubTransaction Class See Also Send Feedback
Determines whether the sub-transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Return Value

True if the sub-transaction has already been committed or rolled back, False otherwise.

Remarks

A sub-transaction is ended by completing either the Commit or RollBack method. Another way of testing whether a sub-transaction has ended is by testing its current status returned from (see GetStatus()()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

SubTransaction Class


HasStarted Method

[image]

Revit 2013 API
SubTransaction..::..HasStarted Method
SubTransaction Class See Also Send Feedback
Determines whether the sub-transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Return Value

True if the sub-transaction has already started, False otherwise.

Remarks

A sub-transaction is considered being started after the Start method was called and until the sub-transaction is either committed or rolled back.

See Also

SubTransaction Class


RollBack Method

[image]

Revit 2013 API
SubTransaction..::..RollBack Method
SubTransaction Class See Also Send Feedback
Discards all changes made to the model during the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Remarks

The parent transaction (or a parent sub-transaction, if any) can still be committed, but the changes rolled back by this method will not be part of the committed transaction.

RollBack can be called only when all inner sub-transaction, if any, are finished, i.e. they were either committed or rolled back. If there is still a sub-transaction open, an attempt to roll this outer sub-transaction back will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction's current status is not TransactionStatus.Started, therefore it may not be committed or rolled back.

See Also

SubTransaction Class


Start Method

[image]

Revit 2013 API
SubTransaction..::..Start Method
SubTransaction Class See Also Send Feedback
Starts the sub-transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If started successfully, this method returns TransactionStatus.Started.

Remarks

A sub-transaction can only be started in an open transaction, and it must be closed (committed or rolled back) while still inside the open transaction.

A sub-transaction can be started in another open sub-transaction, but then it must be closed before the parent sub-transaction is closed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- A sub-transaction can only be active inside an open Transaction. -or- The sub-transaction was already started and has not finished yet.

See Also

SubTransaction Class


SunAndShadowSettings Class

[image]

Revit 2013 API
SunAndShadowSettings Class
Members Example See Also Send Feedback
The SunAndShadowSettings class represents the sun control.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SunAndShadowSettings : Element
Visual Basic
Public Class SunAndShadowSettings _
    Inherits Element
Visual C++
public ref class SunAndShadowSettings : public Element

Remarks

The SunAndShadowSettings element represents the settings applied to a project or view regarding the position, dates, time intervals and other options for the sun control and solar studies. To differentiate between the project and view settings, test the ViewSpecific or OwnerViewId property. If the element is not view-specific this element represents a project-wide setting. If the element is associated to a view, this element represents a per view SunAndShadowSettings. When you create a new view, a new view-specific SunAndShadowSettings element is automatically created for it.

Examples

CopyC#
SunAndShadowSettings sunSettings = view.SunAndShadowSettings; // get current settings from view

// modify Sun and Shadow Settings
DateTime sunrise = sunSettings.GetSunrise(DateTime.SpecifyKind(new DateTime(2011, 4, 20), DateTimeKind.Local)); // sunrise on April 20, 2011
DateTime sunset = sunSettings.GetSunset(DateTime.SpecifyKind(new DateTime(2011, 4, 22), DateTimeKind.Local)); // sunset on April 22, 2011
sunSettings.SunAndShadowType = SunAndShadowType.MultiDayStudy;
sunSettings.StartDateAndTime = sunrise.AddHours(2); // start 2 hours after sunrise on April 20, 2011
sunSettings.EndDateAndTime = sunset.AddHours(-2); // end 2 hours before sunset on April 22, 2011
if (sunSettings.IsTimeIntervalValid(SunStudyTimeInterval.Hour)) // check that this interval is valid for this SunAndShadowType
    sunSettings.TimeInterval = SunStudyTimeInterval.Hour;

// check for validity of start and end times
if (!(sunSettings.IsAfterStartDateAndTime(sunSettings.EndDateAndTime)
    && sunSettings.IsBeforeEndDateAndTime(sunSettings.StartDateAndTime)))
    TaskDialog.Show("Error", "Start and End dates are invalid");

view.get_Parameter(BuiltInParameter.VIEW_GRAPH_SUN_PATH).Set(1); // turn on display of the sun path

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SunAndShadowSettings

See Also

SunAndShadowSettings Members


SunAndShadowSettings Members

[image] [image]

Revit 2013 API
SunAndShadowSettings Members
SunAndShadowSettings Class Methods Properties See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLevelValid | Checks whether the element represents a valid level.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndDateAndTime | Identifies the end date and time.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SunAndShadowSettings Class


SunAndShadowSettings Methods

[image] [image]

Revit 2013 API
SunAndShadowSettings Methods
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CalculateTimeZone | Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FitToModel | Adjust SunAndShadowSettings to fit around the current model geometry.
 | GetActiveSunAndShadowSettings | Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFrameAltitude | Identifies the altitude of the sun (angle in radians) for a specific frame.
Public method | GetFrameAzimuth | Identifies the azimuth of the sun (angle in radians) for a specific frame.
Public method | GetFrameTime | Identifies the date and time of the SunAndShadowSettings element for a given frame.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMatchingPreset | Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSunrise | Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetSunset | Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAfterStartDateAndTime | Checks whether the end date and time is valid.
Public method | IsBeforeEndDateAndTime | Checks whether the start date and time is valid.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFrameValid | Checks whether the frame is valid for the supplied SunAndShadowSettings.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsLevelValid | Checks whether the element represents a valid level.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTimeIntervalValid | Checks whether the time interval is valid for the SunAndShadowType.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SunAndShadowSettings Class


CalculateTimeZone Method

[image]

Revit 2013 API
SunAndShadowSettings..::..CalculateTimeZone Method
SunAndShadowSettings Class See Also Send Feedback
Use Revit's utilities to calculate the time zone for a given longitude and latitude.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double CalculateTimeZone(
    double latitude,
    double longitude
)
Visual Basic
Public Shared Function CalculateTimeZone ( _
    latitude As Double, _
    longitude As Double _
) As Double
Visual C++
public:
static double CalculateTimeZone(
    double latitude,
    double longitude
)

Parameters

latitude
Type: System..::..Double
The latitude.
longitude
Type: System..::..Double
The longitude.

Return Value

The time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.

Remarks

For some latitude and longitude boundary cases, the time zone calculated may not be correct. The API offers the ability to adjust the time zone independent of Revit's calculations for situations where this happens.

See Also

SunAndShadowSettings Class


FitToModel Method

[image]

Revit 2013 API
SunAndShadowSettings..::..FitToModel Method
SunAndShadowSettings Class See Also Send Feedback
Adjust SunAndShadowSettings to fit around the current model geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void FitToModel()
Visual Basic
Public Sub FitToModel
Visual C++
public:
void FitToModel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class


GetActiveSunAndShadowSettings Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetActiveSunAndShadowSettings Method
SunAndShadowSettings Class See Also Send Feedback
Returns the current SunAndShadowSettings element assigned to the active view for the supplied document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static Element GetActiveSunAndShadowSettings(
    Document aDocument
)
Visual Basic
Public Shared Function GetActiveSunAndShadowSettings ( _
    aDocument As Document _
) As Element
Visual C++
public:
static Element^ GetActiveSunAndShadowSettings(
    Document^ aDocument
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The active SunAndShadowSettings element for the supplied document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class


GetFrameAltitude Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetFrameAltitude Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the altitude of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GetFrameAltitude(
    double frame
)
Visual Basic
Public Function GetFrameAltitude ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAltitude(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame for which time is requested

Return Value

Altitude angle (radians)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetFrameAzimuth Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetFrameAzimuth Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the azimuth of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GetFrameAzimuth(
    double frame
)
Visual Basic
Public Function GetFrameAzimuth ( _
    frame As Double _
) As Double
Visual C++
public:
double GetFrameAzimuth(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame for which time is requested

Return Value

Azimuth angle (radians). This is measured counterclockwise from the X axis (East direction). Note that this is a different frame of reference than is used by Revit for the Lighting Study Azimuth value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetFrameTime Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetFrameTime Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for a given frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime GetFrameTime(
    double frame
)
Visual Basic
Public Function GetFrameTime ( _
    frame As Double _
) As DateTime
Visual C++
public:
DateTime GetFrameTime(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame for which time is requested

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the frame value frame is not valid.

See Also

SunAndShadowSettings Class


GetMatchingPreset Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetMatchingPreset Method
SunAndShadowSettings Class See Also Send Feedback
Finds the name of the 'per-document' SunAndShadowSettings that matches the properties of this per-view element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetMatchingPreset()
Visual Basic
Public Function GetMatchingPreset As String
Visual C++
public:
String^ GetMatchingPreset()

Return Value

Name of the per-document SunAndShadowSettings that matches the view specific element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The SunAndShadowSettings is not view-specific.

See Also

SunAndShadowSettings Class


GetSunrise Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetSunrise Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunrise time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime GetSunrise(
    DateTime date
)
Visual Basic
Public Function GetSunrise ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunrise(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date for which to determine sunrise time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunrise value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


GetSunset Method

[image]

Revit 2013 API
SunAndShadowSettings..::..GetSunset Method
SunAndShadowSettings Class See Also Send Feedback
Identifies the sunset time for the SunAndShadowSettings element at its current location and indicated date.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime GetSunset(
    DateTime date
)
Visual Basic
Public Function GetSunset ( _
    date As DateTime _
) As DateTime
Visual C++
public:
DateTime GetSunset(
    DateTime date
)

Parameters

date
Type: System..::..DateTime
The date for which to determine sunset time.

Return Value

The date and time. The value will be in Coordinated Universal Time (UTC).

Remarks

The value returned is affected by the value of the UsesDST flag set for the current location. If this value is true, the sunset value will be adjusted for Daylight Savings Time, regardless of the value of the input date.

See Also

SunAndShadowSettings Class


IsAfterStartDateAndTime Method

[image]

Revit 2013 API
SunAndShadowSettings..::..IsAfterStartDateAndTime Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the end date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAfterStartDateAndTime(
    DateTime time
)
Visual Basic
Public Function IsAfterStartDateAndTime ( _
    time As DateTime _
) As Boolean
Visual C++
public:
bool IsAfterStartDateAndTime(
    DateTime time
)

Parameters

time
Type: System..::..DateTime
Date and time value

Return Value

True if the date and time is valid, false otherwise.

See Also

SunAndShadowSettings Class


IsBeforeEndDateAndTime Method

[image]

Revit 2013 API
SunAndShadowSettings..::..IsBeforeEndDateAndTime Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the start date and time is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsBeforeEndDateAndTime(
    DateTime time
)
Visual Basic
Public Function IsBeforeEndDateAndTime ( _
    time As DateTime _
) As Boolean
Visual C++
public:
bool IsBeforeEndDateAndTime(
    DateTime time
)

Parameters

time
Type: System..::..DateTime
Date and time value

Return Value

True if the date and time is valid, false otherwise.

See Also

SunAndShadowSettings Class


IsFrameValid Method

[image]

Revit 2013 API
SunAndShadowSettings..::..IsFrameValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the frame is valid for the supplied SunAndShadowSettings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsFrameValid(
    double frame
)
Visual Basic
Public Function IsFrameValid ( _
    frame As Double _
) As Boolean
Visual C++
public:
bool IsFrameValid(
    double frame
)

Parameters

frame
Type: System..::..Double
Frame value

Return Value

True if the frame is valid for the SunAndShadowSettings, false otherwise.

See Also

SunAndShadowSettings Class


IsLevelValid Method

[image]

Revit 2013 API
SunAndShadowSettings..::..IsLevelValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the element represents a valid level.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsLevelValid(
    ElementId levelId
)
Visual Basic
Public Function IsLevelValid ( _
    levelId As ElementId _
) As Boolean
Visual C++
public:
bool IsLevelValid(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
Level element id.

Return Value

True if the element is a valid Level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SunAndShadowSettings Class


IsTimeIntervalValid Method

[image]

Revit 2013 API
SunAndShadowSettings..::..IsTimeIntervalValid Method
SunAndShadowSettings Class See Also Send Feedback
Checks whether the time interval is valid for the SunAndShadowType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)
Visual Basic
Public Function IsTimeIntervalValid ( _
    interval As SunStudyTimeInterval _
) As Boolean
Visual C++
public:
bool IsTimeIntervalValid(
    SunStudyTimeInterval interval
)

Parameters

interval
Type: Autodesk.Revit.DB..::..SunStudyTimeInterval
Time interval value.

Return Value

True if the time interval is valid for the current SunAndShadowType, false otherwise.

See Also

SunAndShadowSettings Class


SunAndShadowSettings Properties

[image] [image]

Revit 2013 API
SunAndShadowSettings Properties
SunAndShadowSettings Class See Also Send Feedback

The SunAndShadowSettings type exposes the following members.

Properties

 | Name | Description
Public property | ActiveFrame | Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.
Public property | ActiveFrameTime | Identifies the date and time of the SunAndShadowSettings element for the active frame.
Public property | Altitude | Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Azimuth | Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndDateAndTime | Identifies the end date and time.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundPlaneHeight | Identifies the ground plane height.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Latitude | Identifies the current latitude used by the SunAndShadowSettings element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelId | Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Longitude | Identifies the current longitude used by the SunAndShadowSettings element.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfFrames | Identifies the total number of animation frames for a single-day or multi-day study.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjectLocationId | Identifies the ProjectLocation element used by the SunAndShadowSettings element.
Public property | ProjectLocationName | Identifies the name of the project location used by the SunAndShadowSettings element.
Public property | RelativeToView | Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.
Public property | SharesSettings | Identifies whether settings are shared globally.
Public property | StartDateAndTime | Identifies the start or current date and time.
Public property | SunAndShadowType | Identifies the type of the SunAndShadowSettings element.
Public property | SunriseToSunset | Identifies whether the current single day sun study is set to run from sunrise to sunset.
Public property | TimeInterval | Identifies the time interval between animation frames.
Public property | TimeZone | Identifies the time zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsesDST | Identifies whether the SunAndShadowSettings element is using daylight savings time.
Public property | UsesGroundPlane | Identifies whether the SunAndShadowSettings element uses a ground plane.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | Visibility in current view for a per-view SunAndShadowSettings element.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SunAndShadowSettings Class


ActiveFrame Property

[image]

Revit 2013 API
SunAndShadowSettings..::..ActiveFrame Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the active animation frame for a single-day or multi-day study, starting at 1.0 for the first frame and incrementing in intervals of 1.0.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double ActiveFrame { get; set; }
Visual Basic
Public Property ActiveFrame As Double
    Get
    Set
Visual C++
public:
property double ActiveFrame {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the frame value frame is not valid.

See Also

SunAndShadowSettings Class


ActiveFrameTime Property

[image]

Revit 2013 API
SunAndShadowSettings..::..ActiveFrameTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the date and time of the SunAndShadowSettings element for the active frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime ActiveFrameTime { get; }
Visual Basic
Public ReadOnly Property ActiveFrameTime As DateTime
    Get
Visual C++
public:
property DateTime ActiveFrameTime {
    DateTime get ();
}

Field Value

The date and time. The value will be in Coordinated Universal Time (UTC).

See Also

SunAndShadowSettings Class


Altitude Property

[image]

Revit 2013 API
SunAndShadowSettings..::..Altitude Property
SunAndShadowSettings Class See Also Send Feedback
Altitude setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Altitude { get; set; }
Visual Basic
Public Property Altitude As Double
    Get
    Set
Visual C++
public:
property double Altitude {
    double get ();
    void set (double value);
}

Field Value

Altitude angle (radians)

See Also

SunAndShadowSettings Class


Azimuth Property

[image]

Revit 2013 API
SunAndShadowSettings..::..Azimuth Property
SunAndShadowSettings Class See Also Send Feedback
Azimuth setting (angle in radians). This is only relevant when dealing with a SunAndShadowSettings element that uses lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Azimuth { get; set; }
Visual Basic
Public Property Azimuth As Double
    Get
    Set
Visual C++
public:
property double Azimuth {
    double get ();
    void set (double value);
}

Field Value

Azimuth angle (radians)

See Also

SunAndShadowSettings Class


EndDateAndTime Property

[image]

Revit 2013 API
SunAndShadowSettings..::..EndDateAndTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the end date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime EndDateAndTime { get; set; }
Visual Basic
Public Property EndDateAndTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime EndDateAndTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.

Remarks

This property represents the end time for a single-day or multi-day study. The end date and time can be set for any study type, but is not always used. Note that Revit may ignore this value if the SunriseToSunset flag is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.

See Also

SunAndShadowSettings Class


GroundPlaneHeight Property

[image]

Revit 2013 API
SunAndShadowSettings..::..GroundPlaneHeight Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the ground plane height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GroundPlaneHeight { get; }
Visual Basic
Public ReadOnly Property GroundPlaneHeight As Double
    Get
Visual C++
public:
property double GroundPlaneHeight {
    double get ();
}

See Also

SunAndShadowSettings Class


Latitude Property

[image]

Revit 2013 API
SunAndShadowSettings..::..Latitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current latitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Latitude { get; }
Visual Basic
Public ReadOnly Property Latitude As Double
    Get
Visual C++
public:
property double Latitude {
    double get ();
}

See Also

SunAndShadowSettings Class


LevelId Property

[image]

Revit 2013 API
SunAndShadowSettings..::..LevelId Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the element id of the Ground Plane level for the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId LevelId { get; set; }
Visual Basic
Public Property LevelId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the element level is not a valid Level element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SunAndShadowSettings Class


Longitude Property

[image]

Revit 2013 API
SunAndShadowSettings..::..Longitude Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the current longitude used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Longitude { get; }
Visual Basic
Public ReadOnly Property Longitude As Double
    Get
Visual C++
public:
property double Longitude {
    double get ();
}

See Also

SunAndShadowSettings Class


NumberOfFrames Property

[image]

Revit 2013 API
SunAndShadowSettings..::..NumberOfFrames Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the total number of animation frames for a single-day or multi-day study.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double NumberOfFrames { get; }
Visual Basic
Public ReadOnly Property NumberOfFrames As Double
    Get
Visual C++
public:
property double NumberOfFrames {
    double get ();
}

See Also

SunAndShadowSettings Class


Parameter Property

[image] [image]

Revit 2013 API
SunAndShadowSettings..::..Parameter Property
SunAndShadowSettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SunAndShadowSettings Class
SunAndShadowSettings Members


ProjectLocationId Property

[image]

Revit 2013 API
SunAndShadowSettings..::..ProjectLocationId Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the ProjectLocation element used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ProjectLocationId { get; }
Visual Basic
Public ReadOnly Property ProjectLocationId As ElementId
    Get
Visual C++
public:
property ElementId^ ProjectLocationId {
    ElementId^ get ();
}

See Also

SunAndShadowSettings Class


ProjectLocationName Property

[image]

Revit 2013 API
SunAndShadowSettings..::..ProjectLocationName Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the name of the project location used by the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string ProjectLocationName { get; }
Visual Basic
Public ReadOnly Property ProjectLocationName As String
    Get
Visual C++
public:
property String^ ProjectLocationName {
    String^ get ();
}

See Also

SunAndShadowSettings Class


RelativeToView Property

[image]

Revit 2013 API
SunAndShadowSettings..::..RelativeToView Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is relative to the view direction. This is only relevant for lighting mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool RelativeToView { get; set; }
Visual Basic
Public Property RelativeToView As Boolean
    Get
    Set
Visual C++
public:
property bool RelativeToView {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


SharesSettings Property

[image]

Revit 2013 API
SunAndShadowSettings..::..SharesSettings Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether settings are shared globally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool SharesSettings { get; set; }
Visual Basic
Public Property SharesSettings As Boolean
    Get
    Set
Visual C++
public:
property bool SharesSettings {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the per-view SunAndShadowSettings element shares global settings. Global settings are a special case that allows multiple views to be associated together in order that a change in one view affects that same change in other views. There cannot be multiple such groups, and a SunAndShadowSettings element is either a global setting or not.

See Also

SunAndShadowSettings Class


StartDateAndTime Property

[image]

Revit 2013 API
SunAndShadowSettings..::..StartDateAndTime Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the start or current date and time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public DateTime StartDateAndTime { get; set; }
Visual Basic
Public Property StartDateAndTime As DateTime
    Get
    Set
Visual C++
public:
property DateTime StartDateAndTime {
    DateTime get ();
    void set (DateTime value);
}

Field Value

The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be in local time as well.

Remarks

This property represents the start time for a single-day or multi-day study, or the current time for a still sun study. Note that Revit may ignore this value if the SunriseToSunset flag is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.

See Also

SunAndShadowSettings Class


SunAndShadowType Property

[image]

Revit 2013 API
SunAndShadowSettings..::..SunAndShadowType Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the type of the SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowType SunAndShadowType { get; set; }
Visual Basic
Public Property SunAndShadowType As SunAndShadowType
    Get
    Set
Visual C++
public:
property SunAndShadowType SunAndShadowType {
    SunAndShadowType get ();
    void set (SunAndShadowType value);
}

Remarks

There are no restrictions on setting the type, but do note that some properties are not relevant for certain types. For example, the property EndDateAndTime is not relevant for the type SunAndShadowType.StillImage. In this example (and elsewhere), the previous value for the property is remembered for when the type is reverted. If that property has not been set yet, default values will apply.

See Also

SunAndShadowSettings Class


SunriseToSunset Property

[image]

Revit 2013 API
SunAndShadowSettings..::..SunriseToSunset Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the current single day sun study is set to run from sunrise to sunset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool SunriseToSunset { get; set; }
Visual Basic
Public Property SunriseToSunset As Boolean
    Get
    Set
Visual C++
public:
property bool SunriseToSunset {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


TimeInterval Property

[image]

Revit 2013 API
SunAndShadowSettings..::..TimeInterval Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SunStudyTimeInterval TimeInterval { get; set; }
Visual Basic
Public Property TimeInterval As SunStudyTimeInterval
    Get
    Set
Visual C++
public:
property SunStudyTimeInterval TimeInterval {
    SunStudyTimeInterval get ();
    void set (SunStudyTimeInterval value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the time interval value interval is not valid for the current SunAndShadowType.

See Also

SunAndShadowSettings Class


TimeZone Property

[image]

Revit 2013 API
SunAndShadowSettings..::..TimeZone Property
SunAndShadowSettings Class See Also Send Feedback
Identifies the time zone.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double TimeZone { get; }
Visual Basic
Public ReadOnly Property TimeZone As Double
    Get
Visual C++
public:
property double TimeZone {
    double get ();
}

Remarks

Identifies the time zone used by the SunAndShadowSettings element. This property indicates the time zone in which the site resides. The value is in hours, ranging from +12 hours to -12 hours with 0 being GMT.

See Also

SunAndShadowSettings Class


UsesDST Property

[image]

Revit 2013 API
SunAndShadowSettings..::..UsesDST Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element is using daylight savings time.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UsesDST { get; }
Visual Basic
Public ReadOnly Property UsesDST As Boolean
    Get
Visual C++
public:
property bool UsesDST {
    bool get ();
}

See Also

SunAndShadowSettings Class


UsesGroundPlane Property

[image]

Revit 2013 API
SunAndShadowSettings..::..UsesGroundPlane Property
SunAndShadowSettings Class See Also Send Feedback
Identifies whether the SunAndShadowSettings element uses a ground plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UsesGroundPlane { get; set; }
Visual Basic
Public Property UsesGroundPlane As Boolean
    Get
    Set
Visual C++
public:
property bool UsesGroundPlane {
    bool get ();
    void set (bool value);
}

See Also

SunAndShadowSettings Class


Visible Property

[image]

Revit 2013 API
SunAndShadowSettings..::..Visible Property
SunAndShadowSettings Class See Also Send Feedback
Visibility in current view for a per-view SunAndShadowSettings element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

Visibility

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element is not view specific (in which case visibility is not relevant) or if internally its view is not accessible.

See Also

SunAndShadowSettings Class


SunAndShadowType Enumeration

[image]

Revit 2013 API
SunAndShadowType Enumeration
See Also Send Feedback
Sun study type enum of SunAndShadowSettings.
Enum of sun study type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunAndShadowType
Visual Basic
Public Enumeration SunAndShadowType
Visual C++
public enum class SunAndShadowType

Members

Member name | Description
StillImage | Still image study type (single point in time).
OneDayStudy | Single day study type (time range over a specific day).
MultiDayStudy | Multi day study type (range over date and time).
Lighting | Lighting study type (fixed sun position regardless of date and time).

See Also


SunStudyTimeInterval Enumeration

[image]

Revit 2013 API
SunStudyTimeInterval Enumeration
See Also Send Feedback
Time interval enum for a single or multi-day sun study.
Enum of sun study time interval.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum SunStudyTimeInterval
Visual Basic
Public Enumeration SunStudyTimeInterval
Visual C++
public enum class SunStudyTimeInterval

Members

Member name | Description
Minutes15 | Interval occurs every 15 minutes.
Minutes30 | Interval occurs every 30 minutes.
Minutes45 | Interval occurs every 45 minutes.
Hour | Interval occurs every hour.
Day | Interval occurs every day.
Week | Interval occurs once a week.
Month | Interval occurs once a month.

See Also


Sweep Class

[image]

Revit 2013 API
Sweep Class
Members See Also Send Feedback
A sweep solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Sweep : GenericForm
Visual Basic
Public Class Sweep _
    Inherits GenericForm
Visual C++
public ref class Sweep : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..Sweep

See Also

Sweep Members


Sweep Members

[image] [image]

Revit 2013 API
Sweep Members
Sweep Class Methods Properties See Also Send Feedback

The Sweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sweep Class


Sweep Methods

[image] [image]

Revit 2013 API
Sweep Methods
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sweep Class


Sweep Properties

[image] [image]

Revit 2013 API
Sweep Properties
Sweep Class See Also Send Feedback

The Sweep type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | IsTrajectorySegmentationEnabled | The trajectory segmentation option for the sweep.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSegmentAngle | The maximum segment angle of the sweep in radians.
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Path3d | The selected curves used for the sweep path.
Public property | PathSketch | The sketched path for the sweep.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileSketch | The profile sketch of the sweep.
Public property | ProfileSymbol | The family symbol profile details for the sweep.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Sweep Class


IsTrajectorySegmentationEnabled Property

[image]

Revit 2013 API
Sweep..::..IsTrajectorySegmentationEnabled Property
Sweep Class See Also Send Feedback
The trajectory segmentation option for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsTrajectorySegmentationEnabled { get; set; }
Visual Basic
Public Property IsTrajectorySegmentationEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsTrajectorySegmentationEnabled {
    bool get ();
    void set (bool value);
}

Remarks

This property is used to retrieve/set the trajectory segmentation state of the sweep. if return is true, means user can control the MaxSegmentAngle, otherwise is disable.

See Also

Sweep Class


MaxSegmentAngle Property

[image]

Revit 2013 API
Sweep..::..MaxSegmentAngle Property
Sweep Class See Also Send Feedback
The maximum segment angle of the sweep in radians.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double MaxSegmentAngle { get; set; }
Visual Basic
Public Property MaxSegmentAngle As Double
    Get
    Set
Visual C++
public:
property double MaxSegmentAngle {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve/set the maximum segment angle of the sweep. It is settable only when the trajectory segmentation is enabled.

See Also

Sweep Class


Parameter Property

[image] [image]

Revit 2013 API
Sweep..::..Parameter Property
Sweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Sweep Class
Sweep Members


Path3d Property

[image]

Revit 2013 API
Sweep..::..Path3d Property
Sweep Class See Also Send Feedback
The selected curves used for the sweep path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Path3d Path3d { get; }
Visual Basic
Public ReadOnly Property Path3d As Path3d
    Get
Visual C++
public:
property Path3d^ Path3d {
    Path3d^ get ();
}

Remarks

If the sweep is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


PathSketch Property

[image]

Revit 2013 API
Sweep..::..PathSketch Property
Sweep Class See Also Send Feedback
The sketched path for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic
Public ReadOnly Property PathSketch As Sketch
    Get
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the sweep is based on selected 3d curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSketch Property

[image]

Revit 2013 API
Sweep..::..ProfileSketch Property
Sweep Class See Also Send Feedback
The profile sketch of the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch ProfileSketch { get; }
Visual Basic
Public ReadOnly Property ProfileSketch As Sketch
    Get
Visual C++
public:
property Sketch^ ProfileSketch {
    Sketch^ get ();
}

Remarks

If the profile is not based on sketched curves, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


ProfileSymbol Property

[image]

Revit 2013 API
Sweep..::..ProfileSymbol Property
Sweep Class See Also Send Feedback
The family symbol profile details for the sweep.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolProfile ProfileSymbol { get; }
Visual Basic
Public ReadOnly Property ProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ ProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the profile is not based on a profile family, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Sweep Class


SweepProfile Class

[image]

Revit 2013 API
SweepProfile Class
Members See Also Send Feedback
Represents a profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SweepProfile : APIObject
Visual Basic
Public Class SweepProfile _
    Inherits APIObject
Visual C++
public ref class SweepProfile : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SweepProfile
Autodesk.Revit.DB..::..CurveLoopsProfile
Autodesk.Revit.DB..::..FamilySymbolProfile

See Also

SweepProfile Members


SweepProfile Members

[image] [image]

Revit 2013 API
SweepProfile Members
SweepProfile Class Methods Properties See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweepProfile Methods

[image] [image]

Revit 2013 API
SweepProfile Methods
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweepProfile Class


SweepProfile Properties

[image] [image]

Revit 2013 API
SweepProfile Properties
SweepProfile Class See Also Send Feedback

The SweepProfile type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SweepProfile Class


SweptBlend Class

[image]

Revit 2013 API
SweptBlend Class
Members See Also Send Feedback
A swept blend solid or void form.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SweptBlend : GenericForm
Visual Basic
Public Class SweptBlend _
    Inherits GenericForm
Visual C++
public ref class SweptBlend : public GenericForm

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CombinableElement
Autodesk.Revit.DB..::..GenericForm
Autodesk.Revit.DB..::..SweptBlend

See Also

SweptBlend Members


SweptBlend Members

[image] [image]

Revit 2013 API
SweptBlend Members
SweptBlend Class Methods Properties See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathSketch | The sketched path for the swept blend.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SweptBlend Class


SweptBlend Methods

[image] [image]

Revit 2013 API
SweptBlend Methods
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVertexConnectionMap | Gets the mapping between the vertices in the top and bottom profiles.
Public method | GetVisibility | Gets the visibility for the generic form. (Inherited from GenericForm.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVertexConnectionMap | Sets the mapping between the vertices in the top and bottom profiles.
Public method | SetVisibility | Sets the visibility for the generic form. (Inherited from GenericForm.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SweptBlend Class


GetVertexConnectionMap Method

[image]

Revit 2013 API
SweptBlend..::..GetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Gets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPairArray GetVertexConnectionMap()
Visual Basic
Public Function GetVertexConnectionMap As VertexIndexPairArray
Visual C++
public:
VertexIndexPairArray^ GetVertexConnectionMap()

Remarks

Each vertex refers to the start point of the curve from the top and bottom profiles.

See Also

SweptBlend Class


SetVertexConnectionMap Method

[image]

Revit 2013 API
SweptBlend..::..SetVertexConnectionMap Method
SweptBlend Class See Also Send Feedback
Sets the mapping between the vertices in the top and bottom profiles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVertexConnectionMap(
    VertexIndexPairArray vertexMap
)
Visual Basic
Public Sub SetVertexConnectionMap ( _
    vertexMap As VertexIndexPairArray _
)
Visual C++
public:
void SetVertexConnectionMap(
    VertexIndexPairArray^ vertexMap
)

Parameters

vertexMap
Type: Autodesk.Revit.DB..::..VertexIndexPairArray

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"vertexMap"-is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"vertexMap"-is empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the document failed to regenerate.

See Also

SweptBlend Class


SweptBlend Properties

[image] [image]

Revit 2013 API
SweptBlend Properties
SweptBlend Class See Also Send Feedback

The SweptBlend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BottomProfile | The curves which make up the bottom profile of the sketch.
Public property | BottomProfileSymbol | The bottom family symbol profile of the swept blend.
Public property | BottomSketch | The bottom profile sketch of the swept blend.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Combinations | The geometry combinations that this element belongs to. (Inherited from CombinableElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsSolid | Identifies if the GenericForm is a solid or a void element. (Inherited from GenericForm.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get and Set the Name property; (Inherited from GenericForm.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathSketch | The sketched path for the swept blend.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SelectedPath | The selected curve used for the swept blend path.
Public property | Subcategory | The subcategory. (Inherited from GenericForm.)
Public property | TopProfile | The curves which make up the top profile of the sketch.
Public property | TopProfileSymbol | The top family symbol profile of the swept blend.
Public property | TopSketch | The top profile sketch of the swept blend.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Visible | The visibility of the GenericForm. (Inherited from GenericForm.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SweptBlend Class


BottomProfile Property

[image]

Revit 2013 API
SweptBlend..::..BottomProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the bottom profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray BottomProfile { get; }
Visual Basic
Public ReadOnly Property BottomProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ BottomProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class


BottomProfileSymbol Property

[image]

Revit 2013 API
SweptBlend..::..BottomProfileSymbol Property
SweptBlend Class See Also Send Feedback
The bottom family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolProfile BottomProfileSymbol { get; }
Visual Basic
Public ReadOnly Property BottomProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ BottomProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the bottom profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


BottomSketch Property

[image]

Revit 2013 API
SweptBlend..::..BottomSketch Property
SweptBlend Class See Also Send Feedback
The bottom profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch BottomSketch { get; }
Visual Basic
Public ReadOnly Property BottomSketch As Sketch
    Get
Visual C++
public:
property Sketch^ BottomSketch {
    Sketch^ get ();
}

Remarks

If the bottom profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


Parameter Property

[image] [image]

Revit 2013 API
SweptBlend..::..Parameter Property
SweptBlend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SweptBlend Class
SweptBlend Members


PathSketch Property

[image]

Revit 2013 API
SweptBlend..::..PathSketch Property
SweptBlend Class See Also Send Feedback
The sketched path for the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch PathSketch { get; }
Visual Basic
Public ReadOnly Property PathSketch As Sketch
    Get
Visual C++
public:
property Sketch^ PathSketch {
    Sketch^ get ();
}

Remarks

If the swept blend is based on selected 3d curve, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SelectedPath Property

[image]

Revit 2013 API
SweptBlend..::..SelectedPath Property
SweptBlend Class See Also Send Feedback
The selected curve used for the swept blend path.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve SelectedPath { get; }
Visual Basic
Public ReadOnly Property SelectedPath As Curve
    Get
Visual C++
public:
property Curve^ SelectedPath {
    Curve^ get ();
}

Remarks

If the swept blend is based on a sketched path, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopProfile Property

[image]

Revit 2013 API
SweptBlend..::..TopProfile Property
SweptBlend Class See Also Send Feedback
The curves which make up the top profile of the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArrArray TopProfile { get; }
Visual Basic
Public ReadOnly Property TopProfile As CurveArrArray
    Get
Visual C++
public:
property CurveArrArray^ TopProfile {
    CurveArrArray^ get ();
}

Remarks

The indices of the curves in this array match the indices used in the vertex connection map.

See Also

SweptBlend Class


TopProfileSymbol Property

[image]

Revit 2013 API
SweptBlend..::..TopProfileSymbol Property
SweptBlend Class See Also Send Feedback
The top family symbol profile of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilySymbolProfile TopProfileSymbol { get; }
Visual Basic
Public ReadOnly Property TopProfileSymbol As FamilySymbolProfile
    Get
Visual C++
public:
property FamilySymbolProfile^ TopProfileSymbol {
    FamilySymbolProfile^ get ();
}

Remarks

If the top profile is sketch-based, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


TopSketch Property

[image]

Revit 2013 API
SweptBlend..::..TopSketch Property
SweptBlend Class See Also Send Feedback
The top profile sketch of the swept blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Sketch TopSketch { get; }
Visual Basic
Public ReadOnly Property TopSketch As Sketch
    Get
Visual C++
public:
property Sketch^ TopSketch {
    Sketch^ get ();
}

Remarks

If the top profile is based on a family symbol, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SweptBlend Class


SymbolicCurve Class

[image]

Revit 2013 API
SymbolicCurve Class
Members See Also Send Feedback
A curve that provides information but is not intended to represent actual geometry in an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SymbolicCurve : CurveElement
Visual Basic
Public Class SymbolicCurve _
    Inherits CurveElement
Visual C++
public ref class SymbolicCurve : public CurveElement

Remarks

For example, when creating a door family, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic curves are visible parallel to the view in which you sketch them.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB..::..SymbolicCurve

See Also

SymbolicCurve Members


SymbolicCurve Members

[image] [image]

Revit 2013 API
SymbolicCurve Members
SymbolicCurve Class Methods Properties See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SymbolicCurve Class


SymbolicCurve Methods

[image] [image]

Revit 2013 API
SymbolicCurve Methods
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVisibility | Gets the visibility for the symbolic curve.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVisibility | Sets the visibility for the symbolic curve.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurve Class


GetVisibility Method

[image]

Revit 2013 API
SymbolicCurve..::..GetVisibility Method
SymbolicCurve Class See Also Send Feedback
Gets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FamilyElementVisibility GetVisibility()
Visual Basic
Public Function GetVisibility As FamilyElementVisibility
Visual C++
public:
FamilyElementVisibility^ GetVisibility()

Return Value

A copy of visibility settings for the symbolic curve.

See Also

SymbolicCurve Class


SetVisibility Method

[image]

Revit 2013 API
SymbolicCurve..::..SetVisibility Method
SymbolicCurve Class See Also Send Feedback
Sets the visibility for the symbolic curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVisibility(
    FamilyElementVisibility visibility
)
Visual Basic
Public Sub SetVisibility ( _
    visibility As FamilyElementVisibility _
)
Visual C++
public:
void SetVisibility(
    FamilyElementVisibility^ visibility
)

Parameters

visibility
Type: Autodesk.Revit.DB..::..FamilyElementVisibility

Remarks

The visibility of the symbolic curve geometry can be changed for different detail levels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when visibility is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when visibility is not valid for symbolic curves.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class


SymbolicCurve Properties

[image] [image]

Revit 2013 API
SymbolicCurve Properties
SymbolicCurve Class See Also Send Feedback

The SymbolicCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDrawnInForeground | Indicates if this curve will be drawn in the foreground of the family instance.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceType | Indicates the type of reference.
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | Subcategory | The subcategory.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SymbolicCurve Class


IsDrawnInForeground Property

[image]

Revit 2013 API
SymbolicCurve..::..IsDrawnInForeground Property
SymbolicCurve Class See Also Send Feedback
Indicates if this curve will be drawn in the foreground of the family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDrawnInForeground { get; set; }
Visual Basic
Public Property IsDrawnInForeground As Boolean
    Get
    Set
Visual C++
public:
property bool IsDrawnInForeground {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed. Thrown when the value for this property cannot be changed.

See Also

SymbolicCurve Class


Parameter Property

[image] [image]

Revit 2013 API
SymbolicCurve..::..Parameter Property
SymbolicCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SymbolicCurve Class
SymbolicCurve Members


ReferenceType Property

[image]

Revit 2013 API
SymbolicCurve..::..ReferenceType Property
SymbolicCurve Class See Also Send Feedback
Indicates the type of reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReferenceType ReferenceType { get; set; }
Visual Basic
Public Property ReferenceType As ReferenceType
    Get
    Set
Visual C++
public:
property ReferenceType ReferenceType {
    ReferenceType get ();
    void set (ReferenceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when argument is out of range.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration failed.

See Also

SymbolicCurve Class


Subcategory Property

[image]

Revit 2013 API
SymbolicCurve..::..Subcategory Property
SymbolicCurve Class See Also Send Feedback
The subcategory.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GraphicsStyle Subcategory { get; set; }
Visual Basic
Public Property Subcategory As GraphicsStyle
    Get
    Set
Visual C++
public:
property GraphicsStyle^ Subcategory {
    GraphicsStyle^ get ();
    void set (GraphicsStyle^ value);
}

Remarks

If the family category is non-cuttable, the subcategory can be set to be the family category or one of its subcategories. If the family category is cuttable, the subcategory can be set as the graphics styles of the family category, its subcategories, or the invisible lines graphics style.

See Also

SymbolicCurve Class


SymbolicCurveArray Class

[image]

Revit 2013 API
SymbolicCurveArray Class
Members See Also Send Feedback
An array that contains model curves.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SymbolicCurveArray : APIObject,
    IEnumerable
Visual Basic
Public Class SymbolicCurveArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SymbolicCurveArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SymbolicCurveArray

See Also

SymbolicCurveArray Members


SymbolicCurveArray Members

[image] [image]

Revit 2013 API
SymbolicCurveArray Members
SymbolicCurveArray Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolicCurveArray | Initializes a new instance of the SymbolicCurveArray class

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Constructor

[image]

Revit 2013 API
SymbolicCurveArray Constructor
SymbolicCurveArray Class See Also Send Feedback
Initializes a new instance of the SymbolicCurveArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SymbolicCurveArray()
Visual Basic
Public Sub New
Visual C++
public:
SymbolicCurveArray()

See Also

SymbolicCurveArray Class


SymbolicCurveArray Methods

[image] [image]

Revit 2013 API
SymbolicCurveArray Methods
SymbolicCurveArray Class See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the model curve to the end of the array.
Public method | Clear | Removes every model curve from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified model curve into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurveArray Class


Append Method

[image]

Revit 2013 API
SymbolicCurveArray..::..Append Method
SymbolicCurveArray Class See Also Send Feedback
Add the model curve to the end of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    SymbolicCurve item
)
Visual Basic
Public Overridable Sub Append ( _
    item As SymbolicCurve _
)
Visual C++
public:
virtual void Append(
    SymbolicCurve^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..SymbolicCurve
The model curve to be added.

See Also

SymbolicCurveArray Class


Clear Method

[image]

Revit 2013 API
SymbolicCurveArray..::..Clear Method
SymbolicCurveArray Class See Also Send Feedback
Removes every model curve from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SymbolicCurveArray Class


ForwardIterator Method

[image]

Revit 2013 API
SymbolicCurveArray..::..ForwardIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SymbolicCurveArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

SymbolicCurveArray Class


GetEnumerator Method

[image]

Revit 2013 API
SymbolicCurveArray..::..GetEnumerator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SymbolicCurveArray Class


Insert Method

[image]

Revit 2013 API
SymbolicCurveArray..::..Insert Method
SymbolicCurveArray Class See Also Send Feedback
Insert the specified model curve into the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    SymbolicCurve item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As SymbolicCurve, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    SymbolicCurve^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..SymbolicCurve
The model curve to be inserted into the array.
index
Type: System..::..Int32
The model curve will be inserted before this index.

Return Value

Returns whether the model curve was inserted into the array.

See Also

SymbolicCurveArray Class


ReverseIterator Method

[image]

Revit 2013 API
SymbolicCurveArray..::..ReverseIterator Method
SymbolicCurveArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SymbolicCurveArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SymbolicCurveArrayIterator
Visual C++
public:
virtual SymbolicCurveArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

SymbolicCurveArray Class


SymbolicCurveArray Properties

[image] [image]

Revit 2013 API
SymbolicCurveArray Properties
SymbolicCurveArray Class See Also Send Feedback

The SymbolicCurveArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a model curve at a specified index within the array.
Public property | Size | Returns the number of model curves that are in the array.

See Also

SymbolicCurveArray Class


IsEmpty Property

[image]

Revit 2013 API
SymbolicCurveArray..::..IsEmpty Property
SymbolicCurveArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

SymbolicCurveArray Class


Item Property

[image]

Revit 2013 API
SymbolicCurveArray..::..Item Property
SymbolicCurveArray Class See Also Send Feedback
Gets or sets a model curve at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SymbolicCurve this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As SymbolicCurve
    Get
    Set
Visual C++
public:
virtual property SymbolicCurve^ Item[int index] {
    SymbolicCurve^ get (int index);
    void set (int index, SymbolicCurve^ value);
}

Parameters

index
Type: System..::..Int32
The index of the model curve to be set or retrieved.

Return Value

Returns the model curve at the specified index.

See Also

SymbolicCurveArray Class


Size Property

[image]

Revit 2013 API
SymbolicCurveArray..::..Size Property
SymbolicCurveArray Class See Also Send Feedback
Returns the number of model curves that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SymbolicCurveArray Class


SymbolicCurveArrayIterator Class

[image]

Revit 2013 API
SymbolicCurveArrayIterator Class
Members See Also Send Feedback
An iterator to a model curve array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SymbolicCurveArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SymbolicCurveArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SymbolicCurveArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..SymbolicCurveArrayIterator

See Also

SymbolicCurveArrayIterator Members


SymbolicCurveArrayIterator Members

[image] [image]

Revit 2013 API
SymbolicCurveArrayIterator Members
SymbolicCurveArrayIterator Class Constructors Methods Properties See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SymbolicCurveArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Constructor

[image]

Revit 2013 API
SymbolicCurveArrayIterator Constructor
SymbolicCurveArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SymbolicCurveArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
SymbolicCurveArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Methods

[image] [image]

Revit 2013 API
SymbolicCurveArrayIterator Methods
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SymbolicCurveArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
SymbolicCurveArrayIterator..::..MoveNext Method
SymbolicCurveArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SymbolicCurveArrayIterator Class


Reset Method

[image]

Revit 2013 API
SymbolicCurveArrayIterator..::..Reset Method
SymbolicCurveArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SymbolicCurveArrayIterator Class


SymbolicCurveArrayIterator Properties

[image] [image]

Revit 2013 API
SymbolicCurveArrayIterator Properties
SymbolicCurveArrayIterator Class See Also Send Feedback

The SymbolicCurveArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SymbolicCurveArrayIterator Class


Current Property

[image]

Revit 2013 API
SymbolicCurveArrayIterator..::..Current Property
SymbolicCurveArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SymbolicCurveArrayIterator Class


TableCellCalculatedValueData Class

[image]

Revit 2013 API
TableCellCalculatedValueData Class
Members See Also Send Feedback
The TableCellCalculatedValueData stores the data for calculated value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableCellCalculatedValueData : IDisposable
Visual Basic
Public Class TableCellCalculatedValueData _
    Implements IDisposable
Visual C++
public ref class TableCellCalculatedValueData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableCellCalculatedValueData

See Also

TableCellCalculatedValueData Members


TableCellCalculatedValueData Members

[image] [image]

Revit 2013 API
TableCellCalculatedValueData Members
TableCellCalculatedValueData Class Methods See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellCalculatedValueData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCalculatedValueData Class


TableCellCalculatedValueData Methods

[image] [image]

Revit 2013 API
TableCellCalculatedValueData Methods
TableCellCalculatedValueData Class See Also Send Feedback

The TableCellCalculatedValueData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Gets the name of the calculated value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCalculatedValueData Class


Dispose Method

[image]

Revit 2013 API
TableCellCalculatedValueData..::..Dispose Method
TableCellCalculatedValueData Class See Also Send Feedback
Releases all resources used by the TableCellCalculatedValueData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableCellCalculatedValueData Class


GetName Method

[image]

Revit 2013 API
TableCellCalculatedValueData..::..GetName Method
TableCellCalculatedValueData Class See Also Send Feedback
Gets the name of the calculated value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

See Also

TableCellCalculatedValueData Class


TableCellCombinedParameterData Class

[image]

Revit 2013 API
TableCellCombinedParameterData Class
Members See Also Send Feedback
The TableCellCombinedParameterData stores the data for combined parameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableCellCombinedParameterData : IDisposable
Visual Basic
Public Class TableCellCombinedParameterData _
    Implements IDisposable
Visual C++
public ref class TableCellCombinedParameterData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableCellCombinedParameterData

See Also

TableCellCombinedParameterData Members


TableCellCombinedParameterData Members

[image] [image]

Revit 2013 API
TableCellCombinedParameterData Members
TableCellCombinedParameterData Class Methods Properties See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellCombinedParameterData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Methods

[image] [image]

Revit 2013 API
TableCellCombinedParameterData Methods
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellCombinedParameterData Class


Dispose Method

[image]

Revit 2013 API
TableCellCombinedParameterData..::..Dispose Method
TableCellCombinedParameterData Class See Also Send Feedback
Releases all resources used by the TableCellCombinedParameterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableCellCombinedParameterData Class


TableCellCombinedParameterData Properties

[image] [image]

Revit 2013 API
TableCellCombinedParameterData Properties
TableCellCombinedParameterData Class See Also Send Feedback

The TableCellCombinedParameterData type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | Category id for this parameter
Public property | ParamId | The parameter id
Public property | Prefix | The prefix for this parameter
Public property | SampleValue | The sample/example value for the parameter in text form
Public property | Separator | The separator for this parameter
Public property | Suffix | The suffix for this parameter

See Also

TableCellCombinedParameterData Class


CategoryId Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..CategoryId Property
TableCellCombinedParameterData Class See Also Send Feedback
Category id for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId CategoryId { get; set; }
Visual Basic
Public Property CategoryId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ CategoryId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


ParamId Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..ParamId Property
TableCellCombinedParameterData Class See Also Send Feedback
The parameter id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId ParamId { get; set; }
Visual Basic
Public Property ParamId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ParamId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


Prefix Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..Prefix Property
TableCellCombinedParameterData Class See Also Send Feedback
The prefix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Prefix { get; set; }
Visual Basic
Public Property Prefix As String
    Get
    Set
Visual C++
public:
property String^ Prefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


SampleValue Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..SampleValue Property
TableCellCombinedParameterData Class See Also Send Feedback
The sample/example value for the parameter in text form

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string SampleValue { get; set; }
Visual Basic
Public Property SampleValue As String
    Get
    Set
Visual C++
public:
property String^ SampleValue {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


Separator Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..Separator Property
TableCellCombinedParameterData Class See Also Send Feedback
The separator for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Separator { get; set; }
Visual Basic
Public Property Separator As String
    Get
    Set
Visual C++
public:
property String^ Separator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


Suffix Property

[image]

Revit 2013 API
TableCellCombinedParameterData..::..Suffix Property
TableCellCombinedParameterData Class See Also Send Feedback
The suffix for this parameter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Suffix { get; set; }
Visual Basic
Public Property Suffix As String
    Get
    Set
Visual C++
public:
property String^ Suffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellCombinedParameterData Class


TableCellStyle Class

[image]

Revit 2013 API
TableCellStyle Class
Members See Also Send Feedback
The TableCellStyle class contains the appearance settings for a given table cell, column, or table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableCellStyle : IDisposable
Visual Basic
Public Class TableCellStyle _
    Implements IDisposable
Visual C++
public ref class TableCellStyle : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableCellStyle

See Also

TableCellStyle Members


TableCellStyle Members

[image] [image]

Revit 2013 API
TableCellStyle Members
TableCellStyle Class Constructors Methods Properties See Also Send Feedback

The TableCellStyle type exposes the following members.

Constructors

 | Name | Description
Public method | TableCellStyle()()()() | Initializes a new instance of the TableCellStyle class
Public method | TableCellStyle(TableCellStyle) | Initializes a new instance of the TableCellStyle class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableCellStyle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundColor | The back ground color of this cell.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.

See Also

TableCellStyle Class


TableCellStyle Constructor

[image] [image]

Revit 2013 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TableCellStyle()()()() | Initializes a new instance of the TableCellStyle class
Public method | TableCellStyle(TableCellStyle) | Initializes a new instance of the TableCellStyle class

See Also

TableCellStyle Class
TableCellStyle Members


TableCellStyle Constructor

[image]

Revit 2013 API
TableCellStyle Constructor
TableCellStyle Class See Also Send Feedback
Initializes a new instance of the TableCellStyle class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableCellStyle()
Visual Basic
Public Sub New
Visual C++
public:
TableCellStyle()

See Also

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Constructor (TableCellStyle)

[image]

Revit 2013 API
TableCellStyle Constructor (TableCellStyle)
TableCellStyle Class See Also Send Feedback
Initializes a new instance of the TableCellStyle class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableCellStyle(
    TableCellStyle other
)
Visual Basic
Public Sub New ( _
    other As TableCellStyle _
)
Visual C++
public:
TableCellStyle(
    TableCellStyle^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableCellStyle Class
TableCellStyle Overload


TableCellStyle Methods

[image] [image]

Revit 2013 API
TableCellStyle Methods
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableCellStyle Class


Dispose Method

[image]

Revit 2013 API
TableCellStyle..::..Dispose Method
TableCellStyle Class See Also Send Feedback
Releases all resources used by the TableCellStyle

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableCellStyle Class


TableCellStyle Properties

[image] [image]

Revit 2013 API
TableCellStyle Properties
TableCellStyle Class See Also Send Feedback

The TableCellStyle type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The back ground color of this cell.
Public property | BorderBottomLineStyle | The element id (GraphicsStyle element) for the bottom line of the cell border.
Public property | BorderLeftLineStyle | The element id (GraphicsStyle element) for the left line of the cell border.
Public property | BorderRightLineStyle | The element id (GraphicsStyle element) for the right line of the cell border.
Public property | BorderTopLineStyle | The element id (GraphicsStyle element) for the top line of the cell border.
Public property | FontHorizontalAlignment | The horizontal alignment style of text font.
Public property | FontName | The font used for this style
Public property | FontVerticalAlignment | The vertical alignment style of text font.
Public property | IsEnabled | Gets or sets the status whether this cell is enabled.
Public property | IsFontBold | Gets or sets whether the text font is set to bold of this cell.
Public property | IsFontItalic | Gets or sets whether the text font is set to italic of this cell.
Public property | IsFontUnderline | Gets or sets whether the text font is set to Underline of this cell.
Public property | IsInactivePhaseload | Gets or sets whether this is an inactive phase load cell.
Public property | IsReadOnly | Gets or sets whether this cell is read only.
Public property | TextColor | The text color of this cell.
Public property | TextOrientation | the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10
Public property | TextSize | The text size.

See Also

TableCellStyle Class


BackgroundColor Property

[image]

Revit 2013 API
TableCellStyle..::..BackgroundColor Property
TableCellStyle Class See Also Send Feedback
The back ground color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic
Public Property BackgroundColor As Color
    Get
    Set
Visual C++
public:
property Color^ BackgroundColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


BorderBottomLineStyle Property

[image]

Revit 2013 API
TableCellStyle..::..BorderBottomLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the bottom line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderBottomLineStyle { get; set; }
Visual Basic
Public Property BorderBottomLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderBottomLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


BorderLeftLineStyle Property

[image]

Revit 2013 API
TableCellStyle..::..BorderLeftLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the left line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderLeftLineStyle { get; set; }
Visual Basic
Public Property BorderLeftLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderLeftLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


BorderRightLineStyle Property

[image]

Revit 2013 API
TableCellStyle..::..BorderRightLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the right line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderRightLineStyle { get; set; }
Visual Basic
Public Property BorderRightLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderRightLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


BorderTopLineStyle Property

[image]

Revit 2013 API
TableCellStyle..::..BorderTopLineStyle Property
TableCellStyle Class See Also Send Feedback
The element id (GraphicsStyle element) for the top line of the cell border.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderTopLineStyle { get; set; }
Visual Basic
Public Property BorderTopLineStyle As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BorderTopLineStyle {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


FontHorizontalAlignment Property

[image]

Revit 2013 API
TableCellStyle..::..FontHorizontalAlignment Property
TableCellStyle Class See Also Send Feedback
The horizontal alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public HorizontalAlignmentStyle FontHorizontalAlignment { get; set; }
Visual Basic
Public Property FontHorizontalAlignment As HorizontalAlignmentStyle
    Get
    Set
Visual C++
public:
property HorizontalAlignmentStyle FontHorizontalAlignment {
    HorizontalAlignmentStyle get ();
    void set (HorizontalAlignmentStyle value);
}

Field Value

Alignment style.

See Also

TableCellStyle Class


FontName Property

[image]

Revit 2013 API
TableCellStyle..::..FontName Property
TableCellStyle Class See Also Send Feedback
The font used for this style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string FontName { get; set; }
Visual Basic
Public Property FontName As String
    Get
    Set
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


FontVerticalAlignment Property

[image]

Revit 2013 API
TableCellStyle..::..FontVerticalAlignment Property
TableCellStyle Class See Also Send Feedback
The vertical alignment style of text font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VerticalAlignmentStyle FontVerticalAlignment { get; set; }
Visual Basic
Public Property FontVerticalAlignment As VerticalAlignmentStyle
    Get
    Set
Visual C++
public:
property VerticalAlignmentStyle FontVerticalAlignment {
    VerticalAlignmentStyle get ();
    void set (VerticalAlignmentStyle value);
}

Field Value

Alignment style.

See Also

TableCellStyle Class


IsEnabled Property

[image]

Revit 2013 API
TableCellStyle..::..IsEnabled Property
TableCellStyle Class See Also Send Feedback
Gets or sets the status whether this cell is enabled.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEnabled { get; set; }
Visual Basic
Public Property IsEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}

Field Value

true if this cell is enabled; otherwise false.

See Also

TableCellStyle Class


IsFontBold Property

[image]

Revit 2013 API
TableCellStyle..::..IsFontBold Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to bold of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFontBold { get; set; }
Visual Basic
Public Property IsFontBold As Boolean
    Get
    Set
Visual C++
public:
property bool IsFontBold {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is bold; otherwise false.

See Also

TableCellStyle Class


IsFontItalic Property

[image]

Revit 2013 API
TableCellStyle..::..IsFontItalic Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to italic of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFontItalic { get; set; }
Visual Basic
Public Property IsFontItalic As Boolean
    Get
    Set
Visual C++
public:
property bool IsFontItalic {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is italic; otherwise false.

See Also

TableCellStyle Class


IsFontUnderline Property

[image]

Revit 2013 API
TableCellStyle..::..IsFontUnderline Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether the text font is set to Underline of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFontUnderline { get; set; }
Visual Basic
Public Property IsFontUnderline As Boolean
    Get
    Set
Visual C++
public:
property bool IsFontUnderline {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is Underline; otherwise false.

See Also

TableCellStyle Class


IsInactivePhaseload Property

[image]

Revit 2013 API
TableCellStyle..::..IsInactivePhaseload Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether this is an inactive phase load cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInactivePhaseload { get; set; }
Visual Basic
Public Property IsInactivePhaseload As Boolean
    Get
    Set
Visual C++
public:
property bool IsInactivePhaseload {
    bool get ();
    void set (bool value);
}

Field Value

true if the font is an inactive phase load cell; otherwise false.

See Also

TableCellStyle Class


IsReadOnly Property

[image]

Revit 2013 API
TableCellStyle..::..IsReadOnly Property
TableCellStyle Class See Also Send Feedback
Gets or sets whether this cell is read only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}

Field Value

true if this cell is read only; otherwise false.

See Also

TableCellStyle Class


TextColor Property

[image]

Revit 2013 API
TableCellStyle..::..TextColor Property
TableCellStyle Class See Also Send Feedback
The text color of this cell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color TextColor { get; set; }
Visual Basic
Public Property TextColor As Color
    Get
    Set
Visual C++
public:
property Color^ TextColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableCellStyle Class


TextOrientation Property

[image]

Revit 2013 API
TableCellStyle..::..TextOrientation Property
TableCellStyle Class See Also Send Feedback
the orientation of the cell (for vertical/horizontal text) with input in degrees multiplied by 10

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int TextOrientation { get; set; }
Visual Basic
Public Property TextOrientation As Integer
    Get
    Set
Visual C++
public:
property int TextOrientation {
    int get ();
    void set (int value);
}

See Also

TableCellStyle Class


TextSize Property

[image]

Revit 2013 API
TableCellStyle..::..TextSize Property
TableCellStyle Class See Also Send Feedback
The text size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TextSize { get; set; }
Visual Basic
Public Property TextSize As Double
    Get
    Set
Visual C++
public:
property double TextSize {
    double get ();
    void set (double value);
}

See Also

TableCellStyle Class


TableData Class

[image]

Revit 2013 API
TableData Class
Members See Also Send Feedback
The TableData class is implemented to hold most of the data that describe the style of the rows, columns, and cells in a table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableData : IDisposable
Visual Basic
Public Class TableData _
    Implements IDisposable
Visual C++
public ref class TableData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableData
Autodesk.Revit.DB.Electrical..::..PanelScheduleData

See Also

TableData Members


TableData Members

[image] [image]

Revit 2013 API
TableData Members
TableData Class Methods Properties See Also Send Feedback

The TableData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionData | Returns the section data array element at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in pixels

See Also

TableData Class


TableData Methods

[image] [image]

Revit 2013 API
TableData Methods
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionData | Returns the section data array element at the specified index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableData Class


Dispose Method

[image]

Revit 2013 API
TableData..::..Dispose Method
TableData Class See Also Send Feedback
Releases all resources used by the TableData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableData Class


GetSectionData Method

[image]

Revit 2013 API
TableData..::..GetSectionData Method
TableData Class See Also Send Feedback
Returns the section data array element at the specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    int nIndex
)
Visual Basic
Public Function GetSectionData ( _
    nIndex As Integer _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
The index of section data array. If the index is out of the boundary of section data array, nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

TableData Class


IsEqual Method

[image]

Revit 2013 API
TableData..::..IsEqual Method
TableData Class See Also Send Feedback
Checks if this element is equal in value to the other element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEqual(
    TableData OtherElem
)
Visual Basic
Public Function IsEqual ( _
    OtherElem As TableData _
) As Boolean
Visual C++
public:
bool IsEqual(
    TableData^ OtherElem
)

Parameters

OtherElem
Type: Autodesk.Revit.DB..::..TableData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableData Class


TableData Properties

[image] [image]

Revit 2013 API
TableData Properties
TableData Class See Also Send Feedback

The TableData type exposes the following members.

Properties

 | Name | Description
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips
Public property | NumberOfSections | Gets the number of items in section data array.
Public property | Width | Gets or sets the table width in feet
Public property | WidthInPixels | Gets the width of the panel schedule in pixels

See Also

TableData Class


FreezeColumnsAndRows Property

[image]

Revit 2013 API
TableData..::..FreezeColumnsAndRows Property
TableData Class See Also Send Feedback
set to true if the columns and rows should be unmovable by the slider grips

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool FreezeColumnsAndRows { get; set; }
Visual Basic
Public Property FreezeColumnsAndRows As Boolean
    Get
    Set
Visual C++
public:
property bool FreezeColumnsAndRows {
    bool get ();
    void set (bool value);
}

See Also

TableData Class


NumberOfSections Property

[image]

Revit 2013 API
TableData..::..NumberOfSections Property
TableData Class See Also Send Feedback
Gets the number of items in section data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfSections { get; }
Visual Basic
Public ReadOnly Property NumberOfSections As Integer
    Get
Visual C++
public:
property int NumberOfSections {
    int get ();
}

See Also

TableData Class


Width Property

[image]

Revit 2013 API
TableData..::..Width Property
TableData Class See Also Send Feedback
Gets or sets the table width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

See Also

TableData Class


WidthInPixels Property

[image]

Revit 2013 API
TableData..::..WidthInPixels Property
TableData Class See Also Send Feedback
Gets the width of the panel schedule in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int WidthInPixels { get; }
Visual Basic
Public ReadOnly Property WidthInPixels As Integer
    Get
Visual C++
public:
property int WidthInPixels {
    int get ();
}

See Also

TableData Class


TableMergedCell Class

[image]

Revit 2013 API
TableMergedCell Class
Members See Also Send Feedback
The TableMergedCell class defines a merged area of the upper-left and lower-right of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TableMergedCell : IDisposable
Visual Basic
Public Class TableMergedCell _
    Implements IDisposable
Visual C++
public ref class TableMergedCell : IDisposable

Remarks

A TableMergedCell contains member variables that define the top-left and bottom-right row and column indexes of a table grid. A TableMergedCell object can be passed as a function parameter wherever a TableMergedCell can be passed.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableMergedCell

See Also

TableMergedCell Members


TableMergedCell Members

[image] [image]

Revit 2013 API
TableMergedCell Members
TableMergedCell Class Constructors Methods Properties See Also Send Feedback

The TableMergedCell type exposes the following members.

Constructors

 | Name | Description
Public method | TableMergedCell()()()() | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableMergedCell
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


TableMergedCell Constructor

[image] [image]

Revit 2013 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TableMergedCell()()()() | Default constructor.
Public method | TableMergedCell(Int32, Int32, Int32, Int32) | Constructor.

See Also

TableMergedCell Class
TableMergedCell Members


TableMergedCell Constructor

[image]

Revit 2013 API
TableMergedCell Constructor
TableMergedCell Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TableMergedCell()
Visual Basic
Public Sub New
Visual C++
public:
TableMergedCell()

See Also

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Constructor (Int32, Int32, Int32, Int32)

[image]

Revit 2013 API
TableMergedCell Constructor (Int32, Int32, Int32, Int32)
TableMergedCell Class See Also Send Feedback
Constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)
Visual Basic
Public Sub New ( _
    top As Integer, _
    left As Integer, _
    bottom As Integer, _
    right As Integer _
)
Visual C++
public:
TableMergedCell(
    int top,
    int left,
    int bottom,
    int right
)

Parameters

top
Type: System..::..Int32
Row index of the top-left of a table grid.
left
Type: System..::..Int32
Column index of the top-left of a table grid.
bottom
Type: System..::..Int32
Row index of the bottom-right of a table grid.
right
Type: System..::..Int32
Column index of the bottom-right of a table grid.

See Also

TableMergedCell Class
TableMergedCell Overload


TableMergedCell Methods

[image] [image]

Revit 2013 API
TableMergedCell Methods
TableMergedCell Class See Also Send Feedback

The TableMergedCell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableMergedCell Class


Dispose Method

[image]

Revit 2013 API
TableMergedCell..::..Dispose Method
TableMergedCell Class See Also Send Feedback
Releases all resources used by the TableMergedCell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableMergedCell Class


TableMergedCell Properties

[image] [image]

Revit 2013 API
TableMergedCell Properties
TableMergedCell Class See Also Send Feedback

The TableMergedCell type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Specifies the row index of the bottom-right corner of a table grid.
Public property | Left | Specifies the column index of the top-left corner of a table grid.
Public property | Right | Specifies the column index of the bottom-right corner of a table grid.
Public property | Top | Specifies the row index of the top-left corner of a table grid.

See Also

TableMergedCell Class


Bottom Property

[image]

Revit 2013 API
TableMergedCell..::..Bottom Property
TableMergedCell Class See Also Send Feedback
Specifies the row index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Left Property

[image]

Revit 2013 API
TableMergedCell..::..Left Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Left { get; set; }
Visual Basic
Public Property Left As Integer
    Get
    Set
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Right Property

[image]

Revit 2013 API
TableMergedCell..::..Right Property
TableMergedCell Class See Also Send Feedback
Specifies the column index of the bottom-right corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Right { get; set; }
Visual Basic
Public Property Right As Integer
    Get
    Set
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


Top Property

[image]

Revit 2013 API
TableMergedCell..::..Top Property
TableMergedCell Class See Also Send Feedback
Specifies the row index of the top-left corner of a table grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

TableMergedCell Class


TableSectionData Class

[image]

Revit 2013 API
TableSectionData Class
Members See Also Send Feedback
The TableSectionData class represents a serialized version of an instance of section table data. The class holds row, column and cell data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableSectionData : IDisposable
Visual Basic
Public Class TableSectionData _
    Implements IDisposable
Visual C++
public ref class TableSectionData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableSectionData

See Also

TableSectionData Members


TableSectionData Members

[image] [image]

Revit 2013 API
TableSectionData Members
TableSectionData Class Methods Properties See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TableSectionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellText | Returns a cell's text depending on its type
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in pixels
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeCells | Merges cells for the given area.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's style
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in pixels
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HideSection |
Public property | NeedsRefresh |
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


TableSectionData Methods

[image] [image]

Revit 2013 API
TableSectionData Methods
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column
Public method | GetCellText | Returns a cell's text depending on its type
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section
Public method | GetColumnWidth | Returns a column's width in feet
Public method | GetColumnWidthInPixels | This returns a column's width in pixels
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMergedCell | Gets the whole merged cell that this cell is a part of.
Public method | GetRowHeight | Returns a row's height in feet
Public method | GetRowHeightInPixels | This returns a row's height in pixels
Public method | GetTableCellStyle | Returns a cell's style and if no style exists for this cell, it would come from the column, or the section
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MergeCells | Merges cells for the given area.
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style
Public method | SetCellText | Sets a cell's style
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type
Public method | SetColumnWidth | Sets a column's width in feet
Public method | SetColumnWidthInPixels | This sets a column's width in pixels
Public method | SetMergedCell | Sets the merged cell that this cell is a part of.
Public method | SetRowHeight | Sets a row's height in feet
Public method | SetRowHeightInPixels | This sets a row's height in pixels
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TableSectionData Class


Dispose Method

[image]

Revit 2013 API
TableSectionData..::..Dispose Method
TableSectionData Class See Also Send Feedback
Releases all resources used by the TableSectionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TableSectionData Class


GetCellCalculatedValue Method

[image] [image]

Revit 2013 API
TableSectionData..::..GetCellCalculatedValue Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCalculatedValue(Int32) | Gets the calculated value for the specified column
Public method | GetCellCalculatedValue(Int32, Int32) | Gets the calculated value for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCalculatedValue Method (Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCalculatedValue Method (Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nCol
)
Visual Basic
Public Function GetCellCalculatedValue ( _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCalculatedValue Method (Int32, Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCalculatedValue Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Gets the calculated value for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableCellCalculatedValueData GetCellCalculatedValue(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellCalculatedValueData
Visual C++
public:
TableCellCalculatedValueData^ GetCellCalculatedValue(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCalculatedValue Overload


GetCellCategoryId Method

[image] [image]

Revit 2013 API
TableSectionData..::..GetCellCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCategoryId(Int32) | Returns a column's ParamId Associated with the paramId to find the correct element
Public method | GetCellCategoryId(Int32, Int32) | Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

See Also

TableSectionData Class
TableSectionData Members


GetCellCategoryId Method (Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCategoryId Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's ParamId Associated with the paramId to find the correct element

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCellCategoryId(
    int nCol
)
Visual Basic
Public Function GetCellCategoryId ( _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCategoryId Method (Int32, Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCategoryId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's CategoryId and if no CategoryId exists for this cell, it would come from the column. Associated with the paramId to find the correct element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCellCategoryId(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCategoryId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellCategoryId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCategoryId Overload


GetCellCombinedParameters Method

[image] [image]

Revit 2013 API
TableSectionData..::..GetCellCombinedParameters Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellCombinedParameters(Int32) | Returns an array of combined parameter data for the specified column
Public method | GetCellCombinedParameters(Int32, Int32) | Returns an array of combined parameter data for the specified cell

See Also

TableSectionData Class
TableSectionData Members


GetCellCombinedParameters Method (Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCombinedParameters Method (Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nCol
)
Visual Basic
Public Function GetCellCombinedParameters ( _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellCombinedParameters Method (Int32, Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellCombinedParameters Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns an array of combined parameter data for the specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<TableCellCombinedParameterData> GetCellCombinedParameters(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer _
) As IList(Of TableCellCombinedParameterData)
Visual C++
public:
IList<TableCellCombinedParameterData^>^ GetCellCombinedParameters(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellCombinedParameters Overload


GetCellParamId Method

[image] [image]

Revit 2013 API
TableSectionData..::..GetCellParamId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellParamId(Int32) | Returns a column's ParamId
Public method | GetCellParamId(Int32, Int32) | Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

See Also

TableSectionData Class
TableSectionData Members


GetCellParamId Method (Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellParamId Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's ParamId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCellParamId(
    int nCol
)
Visual Basic
Public Function GetCellParamId ( _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellParamId(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellParamId Overload


GetCellParamId Method (Int32, Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellParamId Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's ParamId and if no ParamId exists for this cell, it would come from the column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCellParamId(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellParamId ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCellParamId(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellParamId Overload


GetCellText Method

[image]

Revit 2013 API
TableSectionData..::..GetCellText Method
TableSectionData Class See Also Send Feedback
Returns a cell's text depending on its type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCellText(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellText ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class


GetCellType Method

[image] [image]

Revit 2013 API
TableSectionData..::..GetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCellType(Int32) | Returns a column's cell type and if no type exists for this column, it would come from the section
Public method | GetCellType(Int32, Int32) | Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

See Also

TableSectionData Class
TableSectionData Members


GetCellType Method (Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellType Method (Int32)
TableSectionData Class See Also Send Feedback
Returns a column's cell type and if no type exists for this column, it would come from the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CellType GetCellType(
    int nCol
)
Visual Basic
Public Function GetCellType ( _
    nCol As Integer _
) As CellType
Visual C++
public:
CellType GetCellType(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellType Overload


GetCellType Method (Int32, Int32)

[image]

Revit 2013 API
TableSectionData..::..GetCellType Method (Int32, Int32)
TableSectionData Class See Also Send Feedback
Returns a cell's Type and if no Type exists for this cell, it would come from the column, or the row, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CellType GetCellType(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellType ( _
    nRow As Integer, _
    nCol As Integer _
) As CellType
Visual C++
public:
CellType GetCellType(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class
GetCellType Overload


GetColumnWidth Method

[image]

Revit 2013 API
TableSectionData..::..GetColumnWidth Method
TableSectionData Class See Also Send Feedback
Returns a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetColumnWidth(
    int nCol
)
Visual Basic
Public Function GetColumnWidth ( _
    nCol As Integer _
) As Double
Visual C++
public:
double GetColumnWidth(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class


GetColumnWidthInPixels Method

[image]

Revit 2013 API
TableSectionData..::..GetColumnWidthInPixels Method
TableSectionData Class See Also Send Feedback
This returns a column's width in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetColumnWidthInPixels(
    int nCol
)
Visual Basic
Public Function GetColumnWidthInPixels ( _
    nCol As Integer _
) As Integer
Visual C++
public:
int GetColumnWidthInPixels(
    int nCol
)

Parameters

nCol
Type: System..::..Int32

See Also

TableSectionData Class


GetMergedCell Method

[image]

Revit 2013 API
TableSectionData..::..GetMergedCell Method
TableSectionData Class See Also Send Feedback
Gets the whole merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableMergedCell GetMergedCell(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetMergedCell ( _
    nRow As Integer, _
    nCol As Integer _
) As TableMergedCell
Visual C++
public:
TableMergedCell^ GetMergedCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class


GetRowHeight Method

[image]

Revit 2013 API
TableSectionData..::..GetRowHeight Method
TableSectionData Class See Also Send Feedback
Returns a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetRowHeight(
    int nRow
)
Visual Basic
Public Function GetRowHeight ( _
    nRow As Integer _
) As Double
Visual C++
public:
double GetRowHeight(
    int nRow
)

Parameters

nRow
Type: System..::..Int32

See Also

TableSectionData Class


GetRowHeightInPixels Method

[image]

Revit 2013 API
TableSectionData..::..GetRowHeightInPixels Method
TableSectionData Class See Also Send Feedback
This returns a row's height in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetRowHeightInPixels(
    int nRow
)
Visual Basic
Public Function GetRowHeightInPixels ( _
    nRow As Integer _
) As Integer
Visual C++
public:
int GetRowHeightInPixels(
    int nRow
)

Parameters

nRow
Type: System..::..Int32

See Also

TableSectionData Class


GetTableCellStyle Method

[image]

Revit 2013 API
TableSectionData..::..GetTableCellStyle Method
TableSectionData Class See Also Send Feedback
Returns a cell's style and if no style exists for this cell, it would come from the column, or the section

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableCellStyle GetTableCellStyle(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetTableCellStyle ( _
    nRow As Integer, _
    nCol As Integer _
) As TableCellStyle
Visual C++
public:
TableCellStyle^ GetTableCellStyle(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableSectionData Class


MergeCells Method

[image]

Revit 2013 API
TableSectionData..::..MergeCells Method
TableSectionData Class See Also Send Feedback
Merges cells for the given area.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void MergeCells(
    TableMergedCell mergedCell
)
Visual Basic
Public Sub MergeCells ( _
    mergedCell As TableMergedCell _
)
Visual C++
public:
void MergeCells(
    TableMergedCell^ mergedCell
)

Parameters

mergedCell
Type: Autodesk.Revit.DB..::..TableMergedCell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetCellCalculatedValue Method

[image] [image]

Revit 2013 API
TableSectionData..::..SetCellCalculatedValue Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellCalculatedValue(Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified column
Public method | SetCellCalculatedValue(Int32, Int32, TableCellCalculatedValueData) | Allows the caller to set the calculated value for a specified cell

See Also

TableSectionData Class
TableSectionData Members


SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)

[image]

Revit 2013 API
TableSectionData..::..SetCellCalculatedValue Method (Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nCol
Type: System..::..Int32
pCalcValue
Type: Autodesk.Revit.DB..::..TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)

[image]

Revit 2013 API
TableSectionData..::..SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)
TableSectionData Class See Also Send Feedback
Allows the caller to set the calculated value for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
    nRow As Integer, _
    nCol As Integer, _
    pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
    int nRow,
    int nCol,
    TableCellCalculatedValueData^ pCalcValue
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
pCalcValue
Type: Autodesk.Revit.DB..::..TableCellCalculatedValueData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCalculatedValue Overload


SetCellCombinedParameters Method

[image] [image]

Revit 2013 API
TableSectionData..::..SetCellCombinedParameters Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellCombinedParameters(Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified column
Public method | SetCellCombinedParameters(Int32, Int32, IList<(Of <<'(TableCellCombinedParameterData>)>>)) | Allows the caller to set combined parameter for a specified cell

See Also

TableSectionData Class
TableSectionData Members


SetCellCombinedParameters Method (Int32, IList(TableCellCombinedParameterData))

[image]

Revit 2013 API
TableSectionData..::..SetCellCombinedParameters Method (Int32, IList<(Of <(<'TableCellCombinedParameterData>)>)>)
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified column

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic
Public Sub SetCellCombinedParameters ( _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nCol
Type: System..::..Int32
paramData
Type: System.Collections.Generic..::..IList<(Of <(<'TableCellCombinedParameterData>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCombinedParameters Overload


SetCellCombinedParameters Method (Int32, Int32, IList(TableCellCombinedParameterData))

[image]

Revit 2013 API
TableSectionData..::..SetCellCombinedParameters Method (Int32, Int32, IList<(Of <(<'TableCellCombinedParameterData>)>)>)
TableSectionData Class See Also Send Feedback
Allows the caller to set combined parameter for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData> paramData
)
Visual Basic
Public Sub SetCellCombinedParameters ( _
    nRow As Integer, _
    nCol As Integer, _
    paramData As IList(Of TableCellCombinedParameterData) _
)
Visual C++
public:
void SetCellCombinedParameters(
    int nRow,
    int nCol,
    IList<TableCellCombinedParameterData^>^ paramData
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramData
Type: System.Collections.Generic..::..IList<(Of <(<'TableCellCombinedParameterData>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellCombinedParameters Overload


SetCellParamIdAndCategoryId Method

[image] [image]

Revit 2013 API
TableSectionData..::..SetCellParamIdAndCategoryId Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellParamIdAndCategoryId(Int32, ElementId, ElementId) | Sets a column's category and parameter Id
Public method | SetCellParamIdAndCategoryId(Int32, Int32, ElementId, ElementId) | Sets a cell's category and parameter Id

See Also

TableSectionData Class
TableSectionData Members


SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)

[image]

Revit 2013 API
TableSectionData..::..SetCellParamIdAndCategoryId Method (Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a column's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)

[image]

Revit 2013 API
TableSectionData..::..SetCellParamIdAndCategoryId Method (Int32, Int32, ElementId, ElementId)
TableSectionData Class See Also Send Feedback
Sets a cell's category and parameter Id

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId paramId,
    ElementId categoryId
)
Visual Basic
Public Sub SetCellParamIdAndCategoryId ( _
    nRow As Integer, _
    nCol As Integer, _
    paramId As ElementId, _
    categoryId As ElementId _
)
Visual C++
public:
void SetCellParamIdAndCategoryId(
    int nRow,
    int nCol,
    ElementId^ paramId,
    ElementId^ categoryId
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
paramId
Type: Autodesk.Revit.DB..::..ElementId
categoryId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellParamIdAndCategoryId Overload


SetCellStyle Method

[image] [image]

Revit 2013 API
TableSectionData..::..SetCellStyle Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellStyle(TableCellStyle) | Sets a section's style
Public method | SetCellStyle(Int32, TableCellStyle) | Sets a column's style
Public method | SetCellStyle(Int32, Int32, TableCellStyle) | Sets a cell's style

See Also

TableSectionData Class
TableSectionData Members


SetCellStyle Method (TableCellStyle)

[image]

Revit 2013 API
TableSectionData..::..SetCellStyle Method (TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a section's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellStyle(
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    TableCellStyle^ Style
)

Parameters

Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, TableCellStyle)

[image]

Revit 2013 API
TableSectionData..::..SetCellStyle Method (Int32, TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a column's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellStyle(
    int nCol,
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nCol,
    TableCellStyle^ Style
)

Parameters

nCol
Type: System..::..Int32
Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellStyle Method (Int32, Int32, TableCellStyle)

[image]

Revit 2013 API
TableSectionData..::..SetCellStyle Method (Int32, Int32, TableCellStyle)
TableSectionData Class See Also Send Feedback
Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle Style
)
Visual Basic
Public Sub SetCellStyle ( _
    nRow As Integer, _
    nCol As Integer, _
    Style As TableCellStyle _
)
Visual C++
public:
void SetCellStyle(
    int nRow,
    int nCol,
    TableCellStyle^ Style
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
Style
Type: Autodesk.Revit.DB..::..TableCellStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class
SetCellStyle Overload


SetCellText Method

[image]

Revit 2013 API
TableSectionData..::..SetCellText Method
TableSectionData Class See Also Send Feedback
Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellText(
    int nRow,
    int nCol,
    string text
)
Visual Basic
Public Sub SetCellText ( _
    nRow As Integer, _
    nCol As Integer, _
    text As String _
)
Visual C++
public:
void SetCellText(
    int nRow,
    int nCol,
    String^ text
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
text
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetCellType Method

[image] [image]

Revit 2013 API
TableSectionData..::..SetCellType Method
TableSectionData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetCellType(Int32, CellType) | Sets a column's cell type
Public method | SetCellType(Int32, Int32, CellType) | Sets a cell's Type

See Also

TableSectionData Class
TableSectionData Members


SetCellType Method (Int32, CellType)

[image]

Revit 2013 API
TableSectionData..::..SetCellType Method (Int32, CellType)
TableSectionData Class See Also Send Feedback
Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellType(
    int nCol,
    CellType type
)
Visual Basic
Public Sub SetCellType ( _
    nCol As Integer, _
    type As CellType _
)
Visual C++
public:
void SetCellType(
    int nCol,
    CellType type
)

Parameters

nCol
Type: System..::..Int32
type
Type: Autodesk.Revit.DB..::..CellType

See Also

TableSectionData Class
SetCellType Overload


SetCellType Method (Int32, Int32, CellType)

[image]

Revit 2013 API
TableSectionData..::..SetCellType Method (Int32, Int32, CellType)
TableSectionData Class See Also Send Feedback
Sets a cell's Type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCellType(
    int nRow,
    int nCol,
    CellType type
)
Visual Basic
Public Sub SetCellType ( _
    nRow As Integer, _
    nCol As Integer, _
    type As CellType _
)
Visual C++
public:
void SetCellType(
    int nRow,
    int nCol,
    CellType type
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
type
Type: Autodesk.Revit.DB..::..CellType

See Also

TableSectionData Class
SetCellType Overload


SetColumnWidth Method

[image]

Revit 2013 API
TableSectionData..::..SetColumnWidth Method
TableSectionData Class See Also Send Feedback
Sets a column's width in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetColumnWidth(
    int nCol,
    double width
)
Visual Basic
Public Sub SetColumnWidth ( _
    nCol As Integer, _
    width As Double _
)
Visual C++
public:
void SetColumnWidth(
    int nCol,
    double width
)

Parameters

nCol
Type: System..::..Int32
width
Type: System..::..Double

See Also

TableSectionData Class


SetColumnWidthInPixels Method

[image]

Revit 2013 API
TableSectionData..::..SetColumnWidthInPixels Method
TableSectionData Class See Also Send Feedback
This sets a column's width in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetColumnWidthInPixels(
    int nCol,
    int width
)
Visual Basic
Public Sub SetColumnWidthInPixels ( _
    nCol As Integer, _
    width As Integer _
)
Visual C++
public:
void SetColumnWidthInPixels(
    int nCol,
    int width
)

Parameters

nCol
Type: System..::..Int32
width
Type: System..::..Int32

See Also

TableSectionData Class


SetMergedCell Method

[image]

Revit 2013 API
TableSectionData..::..SetMergedCell Method
TableSectionData Class See Also Send Feedback
Sets the merged cell that this cell is a part of.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell mergedCell
)
Visual Basic
Public Sub SetMergedCell ( _
    nRow As Integer, _
    nCol As Integer, _
    mergedCell As TableMergedCell _
)
Visual C++
public:
void SetMergedCell(
    int nRow,
    int nCol,
    TableMergedCell^ mergedCell
)

Parameters

nRow
Type: System..::..Int32
nCol
Type: System..::..Int32
mergedCell
Type: Autodesk.Revit.DB..::..TableMergedCell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TableSectionData Class


SetRowHeight Method

[image]

Revit 2013 API
TableSectionData..::..SetRowHeight Method
TableSectionData Class See Also Send Feedback
Sets a row's height in feet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetRowHeight(
    int nRow,
    double height
)
Visual Basic
Public Sub SetRowHeight ( _
    nRow As Integer, _
    height As Double _
)
Visual C++
public:
void SetRowHeight(
    int nRow,
    double height
)

Parameters

nRow
Type: System..::..Int32
height
Type: System..::..Double

See Also

TableSectionData Class


SetRowHeightInPixels Method

[image]

Revit 2013 API
TableSectionData..::..SetRowHeightInPixels Method
TableSectionData Class See Also Send Feedback
This sets a row's height in pixels

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetRowHeightInPixels(
    int nRow,
    int height
)
Visual Basic
Public Sub SetRowHeightInPixels ( _
    nRow As Integer, _
    height As Integer _
)
Visual C++
public:
void SetRowHeightInPixels(
    int nRow,
    int height
)

Parameters

nRow
Type: System..::..Int32
height
Type: System..::..Int32

See Also

TableSectionData Class


TableSectionData Properties

[image] [image]

Revit 2013 API
TableSectionData Properties
TableSectionData Class See Also Send Feedback

The TableSectionData type exposes the following members.

Properties

 | Name | Description
Public property | HideSection |
Public property | NeedsRefresh |
Public property | NumberOfColumns | Gets or sets the number of items in column data array.
Public property | NumberOfRows | Gets or sets the number of items in row data array.

See Also

TableSectionData Class


HideSection Property

[image]

Revit 2013 API
TableSectionData..::..HideSection Property
TableSectionData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HideSection { get; set; }
Visual Basic
Public Property HideSection As Boolean
    Get
    Set
Visual C++
public:
property bool HideSection {
    bool get ();
    void set (bool value);
}

See Also

TableSectionData Class


NeedsRefresh Property

[image]

Revit 2013 API
TableSectionData..::..NeedsRefresh Property
TableSectionData Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool NeedsRefresh { get; set; }
Visual Basic
Public Property NeedsRefresh As Boolean
    Get
    Set
Visual C++
public:
property bool NeedsRefresh {
    bool get ();
    void set (bool value);
}

See Also

TableSectionData Class


NumberOfColumns Property

[image]

Revit 2013 API
TableSectionData..::..NumberOfColumns Property
TableSectionData Class See Also Send Feedback
Gets or sets the number of items in column data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfColumns { get; set; }
Visual Basic
Public Property NumberOfColumns As Integer
    Get
    Set
Visual C++
public:
property int NumberOfColumns {
    int get ();
    void set (int value);
}

See Also

TableSectionData Class


NumberOfRows Property

[image]

Revit 2013 API
TableSectionData..::..NumberOfRows Property
TableSectionData Class See Also Send Feedback
Gets or sets the number of items in row data array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfRows { get; set; }
Visual Basic
Public Property NumberOfRows As Integer
    Get
    Set
Visual C++
public:
property int NumberOfRows {
    int get ();
    void set (int value);
}

See Also

TableSectionData Class


TableView Class

[image]

Revit 2013 API
TableView Class
Members See Also Send Feedback
This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TableView : View
Visual Basic
Public Class TableView _
    Inherits View
Visual C++
public ref class TableView : public View

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..TableView
Autodesk.Revit.DB.Electrical..::..PanelScheduleView

See Also

TableView Members


TableView Members

[image] [image]

Revit 2013 API
TableView Members
TableView Class Methods Properties See Also Send Feedback

The TableView type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAvailableParameterCategories | Get all available parameter categories.
Public method | GetAvailableParameters | Get available parameters for the specified category.
Public method | GetCalculatedValueName | Returns the calculated value name for template view
Public method | GetCalculatedValueText | Returns the calculated value text for instance view
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOkToEditParam |
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TableView Class


TableView Methods

[image] [image]

Revit 2013 API
TableView Methods
TableView Class See Also Send Feedback

The TableView type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAvailableParameterCategories | Get all available parameter categories.
Public method | GetAvailableParameters | Get available parameters for the specified category.
Public method | GetCalculatedValueName | Returns the calculated value name for template view
Public method | GetCalculatedValueText | Returns the calculated value text for instance view
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOkToEditParam |
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

TableView Class


GetAvailableParameterCategories Method

[image]

Revit 2013 API
TableView..::..GetAvailableParameterCategories Method
TableView Class See Also Send Feedback
Get all available parameter categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> GetAvailableParameterCategories(
    SectionType typeSection,
    int nLogRow
)
Visual Basic
Public Function GetAvailableParameterCategories ( _
    typeSection As SectionType, _
    nLogRow As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameterCategories(
    SectionType typeSection,
    int nLogRow
)

Parameters

typeSection
Type: Autodesk.Revit.DB..::..SectionType
nLogRow
Type: System..::..Int32

See Also

TableView Class


GetAvailableParameters Method

[image]

Revit 2013 API
TableView..::..GetAvailableParameters Method
TableView Class See Also Send Feedback
Get available parameters for the specified category.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> GetAvailableParameters(
    int categoryId
)
Visual Basic
Public Function GetAvailableParameters ( _
    categoryId As Integer _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAvailableParameters(
    int categoryId
)

Parameters

categoryId
Type: System..::..Int32

See Also

TableView Class


GetCalculatedValueName Method

[image]

Revit 2013 API
TableView..::..GetCalculatedValueName Method
TableView Class See Also Send Feedback
Returns the calculated value name for template view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCalculatedValueName(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCalculatedValueName ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueName(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableView Class


GetCalculatedValueText Method

[image]

Revit 2013 API
TableView..::..GetCalculatedValueText Method
TableView Class See Also Send Feedback
Returns the calculated value text for instance view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCalculatedValueText(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCalculatedValueText ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCalculatedValueText(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableView Class


IsOkToEditParam Method

[image]

Revit 2013 API
TableView..::..IsOkToEditParam Method
TableView Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsOkToEditParam(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function IsOkToEditParam ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsOkToEditParam(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
nRow
Type: System..::..Int32
nCol
Type: System..::..Int32

See Also

TableView Class


Print Method

[image] [image]

Revit 2013 API
TableView..::..Print Method
TableView Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

TableView Class
TableView Members


TableView Properties

[image] [image]

Revit 2013 API
TableView Properties
TableView Class See Also Send Feedback

The TableView type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinimumColumnWidth | Gets the minimum column width
Public property | MinimumRowHeight | Gets the minimum row height
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TableView Class


MinimumColumnWidth Property

[image]

Revit 2013 API
TableView..::..MinimumColumnWidth Property
TableView Class See Also Send Feedback
Gets the minimum column width

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int MinimumColumnWidth { get; }
Visual Basic
Public ReadOnly Property MinimumColumnWidth As Integer
    Get
Visual C++
public:
property int MinimumColumnWidth {
    int get ();
}

See Also

TableView Class


MinimumRowHeight Property

[image]

Revit 2013 API
TableView..::..MinimumRowHeight Property
TableView Class See Also Send Feedback
Gets the minimum row height

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int MinimumRowHeight { get; }
Visual Basic
Public ReadOnly Property MinimumRowHeight As Integer
    Get
Visual C++
public:
property int MinimumRowHeight {
    int get ();
}

See Also

TableView Class


Parameter Property

[image] [image]

Revit 2013 API
TableView..::..Parameter Property
TableView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TableView Class
TableView Members


TargetId Property

[image]

Revit 2013 API
TableView..::..TargetId Property
TableView Class See Also Send Feedback
the element id of the element that is being viewed

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId TargetId { get; set; }
Visual Basic
Public Property TargetId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TargetId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TableView Class


TagMode Enumeration

[image]

Revit 2013 API
TagMode Enumeration
See Also Send Feedback
An enumerated type listing tag mode that are supported for IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TagMode
Visual Basic
Public Enumeration TagMode
Visual C++
public enum class TagMode

Members

Member name | Description
TM_ADDBY_CATEGORY | The Tag you add by Category.
TM_ADDBY_MULTICATEGORY | The Tag you add by Multi-Category.
TM_ADDBY_MATERIAL | The Tag you add by Material.

See Also


TagOrientation Enumeration

[image]

Revit 2013 API
TagOrientation Enumeration
See Also Send Feedback
An enumerated type listing tag orientation options that are supported by IndependentTags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TagOrientation
Visual Basic
Public Enumeration TagOrientation
Visual C++
public enum class TagOrientation

Members

Member name | Description
Horizontal | The Orientation of tag is Horizontal.
Vertical | The Orientation of tag is Vertical.

See Also


TemporaryViewMode Enumeration

[image]

Revit 2013 API
TemporaryViewMode Enumeration
See Also Send Feedback
Enumeration to represent the various temporary view modes a view can be in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum TemporaryViewMode
Visual Basic
Public Enumeration TemporaryViewMode
Visual C++
public enum class TemporaryViewMode

Members

Member name | Description
RevealHiddenElements | The view is in reveal hidden elements mode
TemporaryHideIsolate | The view is in temporary hide/isolate mode
WorksharingDisplay | The view is in one of the worksharing display modes
AnalyticalModel | The view is in the mode that isolates the analytical model
Raytrace | The view is in the mode that shows the model in interactive raytracing

See Also


TextAlignFlags Enumeration

[image]

Revit 2013 API
TextAlignFlags Enumeration
See Also Send Feedback
An enumerated type listing all the Text align flags.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextAlignFlags
Visual Basic
Public Enumeration TextAlignFlags
Visual C++
public enum class TextAlignFlags

Members

Member name | Description
TEF_ALIGN_LEFT | Align text left
TEF_ALIGN_CENTER | Align text center
TEF_ALIGN_RIGHT | Align text right
TEF_ALIGN_TOP | Align text top
TEF_ALIGN_MIDDLE | Align text middle
TEF_ALIGN_BOTTOM | Align text bottom

See Also


TextAlignMask Enumeration

[image]

Revit 2013 API
TextAlignMask Enumeration
See Also Send Feedback
An enumerated type listing all the Text align mask.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextAlignMask
Visual Basic
Public Enumeration TextAlignMask
Visual C++
public enum class TextAlignMask

Members

Member name | Description
horzAlignMask | The mask of the Text object being aligned in the horizontal direction.
vertAlignMask | The mask of the Text object being aligned in the vertical direction.

See Also


TextElement Class

[image]

Revit 2013 API
TextElement Class
Members See Also Send Feedback
Represents the TextElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextElement : Element
Visual Basic
Public Class TextElement _
    Inherits Element
Visual C++
public ref class TextElement : public Element

Remarks

This class can be parent class of TextNote and other Text related classes.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..TextElement
Autodesk.Revit.DB..::..TextNote

See Also

TextElement Members


TextElement Members

[image] [image]

Revit 2013 API
TextElement Members
TextElement Class Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Align | The align.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | The base direction.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWidth | The line width.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | Get and set the content of the TextElement object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElement Class


TextElement Methods

[image] [image]

Revit 2013 API
TextElement Methods
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElement Class


TextElement Properties

[image] [image]

Revit 2013 API
TextElement Properties
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Properties

 | Name | Description
Public property | Align | The align.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | The base direction.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWidth | The line width.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object.
Public property | Text | Get and set the content of the TextElement object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElement Class


Align Property

[image]

Revit 2013 API
TextElement..::..Align Property
TextElement Class See Also Send Feedback
The align.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public TextAlignFlags Align { get; }
Visual Basic
Public ReadOnly Property Align As TextAlignFlags
    Get
Visual C++
public:
property TextAlignFlags Align {
    TextAlignFlags get ();
}

See Also

TextElement Class


BaseDirection Property

[image]

Revit 2013 API
TextElement..::..BaseDirection Property
TextElement Class See Also Send Feedback
The base direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ BaseDirection { get; }
Visual Basic
Public ReadOnly Property BaseDirection As XYZ
    Get
Visual C++
public:
property XYZ^ BaseDirection {
    XYZ^ get ();
}

See Also

TextElement Class


Height Property

[image]

Revit 2013 API
TextElement..::..Height Property
TextElement Class See Also Send Feedback
The height.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

TextElement Class


LineWidth Property

[image]

Revit 2013 API
TextElement..::..LineWidth Property
TextElement Class See Also Send Feedback
The line width.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double LineWidth { get; }
Visual Basic
Public ReadOnly Property LineWidth As Double
    Get
Visual C++
public:
property double LineWidth {
    double get ();
}

See Also

TextElement Class


Parameter Property

[image] [image]

Revit 2013 API
TextElement..::..Parameter Property
TextElement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextElement Class
TextElement Members


Symbol Property

[image]

Revit 2013 API
TextElement..::..Symbol Property
TextElement Class See Also Send Feedback
Get the type of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextElementType Symbol { get; }
Visual Basic
Public ReadOnly Property Symbol As TextElementType
    Get
Visual C++
public:
property TextElementType^ Symbol {
    TextElementType^ get ();
}

Remarks

The user can call this property to get the related type.

See Also

TextElement Class


Text Property

[image]

Revit 2013 API
TextElement..::..Text Property
TextElement Class See Also Send Feedback
Get and set the content of the TextElement object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Remarks

The content of TextElement object can also be accessed through the Built-In parameter TEXT_TEXT.

See Also

TextElement Class


UpDirection Property

[image]

Revit 2013 API
TextElement..::..UpDirection Property
TextElement Class See Also Send Feedback
The direction towards the top of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

TextElement Class


TextElementBackground Enumeration

[image]

Revit 2013 API
TextElementBackground Enumeration
See Also Send Feedback
An enumerated type listing all the background mode for the built-in parameter TEXT_BACKGROUND.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextElementBackground
Visual Basic
Public Enumeration TextElementBackground
Visual C++
public enum class TextElementBackground

Members

Member name | Description
TBGR_OPAQUE | The TextElement object is opaque.
TBGR_TRANSPARENT | The TextElement object is transparent.

See Also


TextElementType Class

[image]

Revit 2013 API
TextElementType Class
Members See Also Send Feedback
An object that represents a text style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextElementType : LineAndTextAttrSymbol
Visual Basic
Public Class TextElementType _
    Inherits LineAndTextAttrSymbol
Visual C++
public ref class TextElementType : public LineAndTextAttrSymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..TextElementType
Autodesk.Revit.DB..::..TextNoteType

See Also

TextElementType Members


TextElementType Members

[image] [image]

Revit 2013 API
TextElementType Members
TextElementType Class Methods Properties See Also Send Feedback

The TextElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElementType Class


TextElementType Methods

[image] [image]

Revit 2013 API
TextElementType Methods
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextElementType Class


TextElementType Properties

[image] [image]

Revit 2013 API
TextElementType Properties
TextElementType Class See Also Send Feedback

The TextElementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextElementType Class


Parameter Property

[image] [image]

Revit 2013 API
TextElementType..::..Parameter Property
TextElementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextElementType Class
TextElementType Members


TextNote Class

[image]

Revit 2013 API
TextNote Class
Members See Also Send Feedback
Provides access to the TextNote object in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextNote : TextElement
Visual Basic
Public Class TextNote _
    Inherits TextElement
Visual C++
public ref class TextNote : public TextElement

Remarks

The user can create TextNote object and change the internal property as Leaders and so on.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..TextElement
Autodesk.Revit.DB..::..TextNote

See Also

TextNote Members


TextNote Members

[image] [image]

Revit 2013 API
TextNote Members
TextNote Class Methods Properties See Also Send Feedback

The TextNote type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Add a leader for the current TextNote object and return the new leader.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveLeaders | Remove all the leaders for the current TextNote object.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Align | The align. (Inherited from TextElement.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | The base direction. (Inherited from TextElement.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Access the position of the TextNote object.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height. (Inherited from TextElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Leaders | Retrieves all the leaders belongs to the current TextNote object.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWidth | The line width. (Inherited from TextElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Public property | Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
Public property | TextNoteType | Access the type of the TextNote object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from TextElement.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Access the width of the TextNote object.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNote Class


TextNote Methods

[image] [image]

Revit 2013 API
TextNote Methods
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Methods

 | Name | Description
Public method | AddLeader | Add a leader for the current TextNote object and return the new leader.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveLeaders | Remove all the leaders for the current TextNote object.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNote Class


AddLeader Method

[image]

Revit 2013 API
TextNote..::..AddLeader Method
TextNote Class See Also Send Feedback
Add a leader for the current TextNote object and return the new leader.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Leader AddLeader(
    TextNoteLeaderTypes
)
Visual Basic
Public Function AddLeader ( _
     As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
    TextNoteLeaderTypes
)

Parameters

Type: Autodesk.Revit.DB..::..TextNoteLeaderTypes

Remarks

If the current leader type is not same with the input type, Autodesk::Revit::Exceptions::InvalidOperationException will be thrown.

See Also

TextNote Class


RemoveLeaders Method

[image]

Revit 2013 API
TextNote..::..RemoveLeaders Method
TextNote Class See Also Send Feedback
Remove all the leaders for the current TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveLeaders()
Visual Basic
Public Sub RemoveLeaders
Visual C++
public:
void RemoveLeaders()

Remarks

It is different to the method AddLeader, in which one Leader is added. Calling this method will remove all the leaders.

See Also

TextNote Class


TextNote Properties

[image] [image]

Revit 2013 API
TextNote Properties
TextNote Class See Also Send Feedback

The TextNote type exposes the following members.

Properties

 | Name | Description
Public property | Align | The align. (Inherited from TextElement.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseDirection | The base direction. (Inherited from TextElement.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Coord | Access the position of the TextNote object.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height. (Inherited from TextElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Leaders | Retrieves all the leaders belongs to the current TextNote object.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineWidth | The line width. (Inherited from TextElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Symbol | Get the type of the TextElement object. (Inherited from TextElement.)
Public property | Text | Get and set the content of the TextElement object. (Inherited from TextElement.)
Public property | TextNoteType | Access the type of the TextNote object.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from TextElement.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Access the width of the TextNote object.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNote Class


Coord Property

[image]

Revit 2013 API
TextNote..::..Coord Property
TextNote Class See Also Send Feedback
Access the position of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Coord { get; set; }
Visual Basic
Public Property Coord As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Coord {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

With this method, the position of the TextNote object can be retrieved and changed.

See Also

TextNote Class


Leaders Property

[image]

Revit 2013 API
TextNote..::..Leaders Property
TextNote Class See Also Send Feedback
Retrieves all the leaders belongs to the current TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LeaderArray Leaders { get; }
Visual Basic
Public ReadOnly Property Leaders As LeaderArray
    Get
Visual C++
public:
property LeaderArray^ Leaders {
    LeaderArray^ get ();
}

Remarks

This property is ReadOnly.

See Also

TextNote Class


Parameter Property

[image] [image]

Revit 2013 API
TextNote..::..Parameter Property
TextNote Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextNote Class
TextNote Members


TextNoteType Property

[image]

Revit 2013 API
TextNote..::..TextNoteType Property
TextNote Class See Also Send Feedback
Access the type of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteType TextNoteType { get; set; }
Visual Basic
Public Property TextNoteType As TextNoteType
    Get
    Set
Visual C++
public:
property TextNoteType^ TextNoteType {
    TextNoteType^ get ();
    void set (TextNoteType^ value);
}

Remarks

The type of the TextNote object can be retrieved or changed.

See Also

TextNote Class


Width Property

[image]

Revit 2013 API
TextNote..::..Width Property
TextNote Class See Also Send Feedback
Access the width of the TextNote object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

With this method, the width of the TextNote object can be retrieved and changed. The set method will calculate the real width of the TextNote. If the requested width is less than the real width, the real width will be set instead of the requested width.

See Also

TextNote Class


TextNoteLeaderStyles Enumeration

[image]

Revit 2013 API
TextNoteLeaderStyles Enumeration
See Also Send Feedback
An enumerated type listing all the Leader styles.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextNoteLeaderStyles
Visual Basic
Public Enumeration TextNoteLeaderStyles
Visual C++
public enum class TextNoteLeaderStyles

Members

Member name | Description
LCS_NONE | No leader.
LCS_ONE_SEG_LINE | The leader only includes one line segment.
LCS_ONE_SEG_ARC | The leader is an arc.
LCS_TWO_SEG_LINE | The leader include two line segments.

See Also


TextNoteLeaderTypes Enumeration

[image]

Revit 2013 API
TextNoteLeaderTypes Enumeration
See Also Send Feedback
An enumerated type listing all the Leader types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextNoteLeaderTypes
Visual Basic
Public Enumeration TextNoteLeaderTypes
Visual C++
public enum class TextNoteLeaderTypes

Members

Member name | Description
TNLT_STRAIGHT_L | The leader is put at the left of the Text object and in the straight style.
TNLT_STRAIGHT_R | The leader is put at the right of the Text object and in the straight style.
TNLT_ARC_L | The leader is put at the left of the Text object and in the arc style.
TNLT_ARC_R | The leader is put at the right of the Text object and in the arc style.

See Also


TextNoteType Class

[image]

Revit 2013 API
TextNoteType Class
Members See Also Send Feedback
An object that represents a text note style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextNoteType : TextElementType
Visual Basic
Public Class TextNoteType _
    Inherits TextElementType
Visual C++
public ref class TextNoteType : public TextElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..LineAndTextAttrSymbol
Autodesk.Revit.DB..::..TextElementType
Autodesk.Revit.DB..::..TextNoteType

See Also

TextNoteType Members


TextNoteType Members

[image] [image]

Revit 2013 API
TextNoteType Members
TextNoteType Class Methods Properties See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNoteType Class


TextNoteType Methods

[image] [image]

Revit 2013 API
TextNoteType Methods
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteType Class


TextNoteType Properties

[image] [image]

Revit 2013 API
TextNoteType Properties
TextNoteType Class See Also Send Feedback

The TextNoteType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TextNoteType Class


Parameter Property

[image] [image]

Revit 2013 API
TextNoteType..::..Parameter Property
TextNoteType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TextNoteType Class
TextNoteType Members


TextNoteTypeSet Class

[image]

Revit 2013 API
TextNoteTypeSet Class
Members See Also Send Feedback
A set that contains textnote types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextNoteTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class TextNoteTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TextNoteTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..TextNoteTypeSet

See Also

TextNoteTypeSet Members


TextNoteTypeSet Members

[image] [image]

Revit 2013 API
TextNoteTypeSet Members
TextNoteTypeSet Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | TextNoteTypeSet | Initializes a new instance of the TextNoteTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class


TextNoteTypeSet Constructor

[image]

Revit 2013 API
TextNoteTypeSet Constructor
TextNoteTypeSet Class See Also Send Feedback
Initializes a new instance of the TextNoteTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
TextNoteTypeSet()

See Also

TextNoteTypeSet Class


TextNoteTypeSet Methods

[image] [image]

Revit 2013 API
TextNoteTypeSet Methods
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every textnote type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a textnote type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified textnote type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified textnote type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSet Class


Clear Method

[image]

Revit 2013 API
TextNoteTypeSet..::..Clear Method
TextNoteTypeSet Class See Also Send Feedback
Removes every textnote type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TextNoteTypeSet Class


Contains Method

[image]

Revit 2013 API
TextNoteTypeSet..::..Contains Method
TextNoteTypeSet Class See Also Send Feedback
Tests for the existence of a textnote type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    TextNoteType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..TextNoteType
The textnote type to be searched for.

Return Value

The Contains method returns True if the textnote type is within the set, otherwise False.

See Also

TextNoteTypeSet Class


Erase Method

[image]

Revit 2013 API
TextNoteTypeSet..::..Erase Method
TextNoteTypeSet Class See Also Send Feedback
Removes a specified textnote type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    TextNoteType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As TextNoteType _
) As Integer
Visual C++
public:
virtual int Erase(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..TextNoteType
The textnote type to be erased.

Return Value

The number of textnote types that were erased from the set.

See Also

TextNoteTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
TextNoteTypeSet..::..ForwardIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TextNoteTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
TextNoteTypeSet..::..GetEnumerator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

TextNoteTypeSet Class


Insert Method

[image]

Revit 2013 API
TextNoteTypeSet..::..Insert Method
TextNoteTypeSet Class See Also Send Feedback
Insert the specified textnote type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    TextNoteType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As TextNoteType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TextNoteType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..TextNoteType
The textnote type to be inserted into the set.

Return Value

Returns whether the textnote type was inserted into the set.

See Also

TextNoteTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
TextNoteTypeSet..::..ReverseIterator Method
TextNoteTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TextNoteTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As TextNoteTypeSetIterator
Visual C++
public:
virtual TextNoteTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TextNoteTypeSet Class


TextNoteTypeSet Properties

[image] [image]

Revit 2013 API
TextNoteTypeSet Properties
TextNoteTypeSet Class See Also Send Feedback

The TextNoteTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of textnote types that are in the set.

See Also

TextNoteTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
TextNoteTypeSet..::..IsEmpty Property
TextNoteTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TextNoteTypeSet Class


Size Property

[image]

Revit 2013 API
TextNoteTypeSet..::..Size Property
TextNoteTypeSet Class See Also Send Feedback
Returns the number of textnote types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TextNoteTypeSet Class


TextNoteTypeSetIterator Class

[image]

Revit 2013 API
TextNoteTypeSetIterator Class
Members See Also Send Feedback
An iterator to a textnote type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class TextNoteTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class TextNoteTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TextNoteTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..TextNoteTypeSetIterator

See Also

TextNoteTypeSetIterator Members


TextNoteTypeSetIterator Members

[image] [image]

Revit 2013 API
TextNoteTypeSetIterator Members
TextNoteTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | TextNoteTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Constructor

[image]

Revit 2013 API
TextNoteTypeSetIterator Constructor
TextNoteTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TextNoteTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
TextNoteTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Methods

[image] [image]

Revit 2013 API
TextNoteTypeSetIterator Methods
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextNoteTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
TextNoteTypeSetIterator..::..MoveNext Method
TextNoteTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
TextNoteTypeSetIterator..::..Reset Method
TextNoteTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TextNoteTypeSetIterator Class


TextNoteTypeSetIterator Properties

[image] [image]

Revit 2013 API
TextNoteTypeSetIterator Properties
TextNoteTypeSetIterator Class See Also Send Feedback

The TextNoteTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TextNoteTypeSetIterator Class


Current Property

[image]

Revit 2013 API
TextNoteTypeSetIterator..::..Current Property
TextNoteTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TextNoteTypeSetIterator Class


TextTreatment Enumeration

[image]

Revit 2013 API
TextTreatment Enumeration
See Also Send Feedback
An enumerated type listing possible text treatment modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TextTreatment
Visual Basic
Public Enumeration TextTreatment
Visual C++
public enum class TextTreatment

Members

Member name | Description
Exact | Export texts as exact visual fidelity. Formatting intelligence will be lost.
Approximate | Export texts as approximate visual fidelity. Formatting intelligence will be maintained.

See Also


ThermalAsset Class

[image]

Revit 2013 API
ThermalAsset Class
Members See Also Send Feedback
Represents the properties of a material pertinent to energy analysis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ThermalAsset : IDisposable
Visual Basic
Public Class ThermalAsset _
    Implements IDisposable
Visual C++
public ref class ThermalAsset : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ThermalAsset

See Also

ThermalAsset Members


ThermalAsset Members

[image] [image]

Revit 2013 API
ThermalAsset Members
ThermalAsset Class Constructors Methods Properties See Also Send Feedback

The ThermalAsset type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalAsset | Constructs an instance of ThermalAsset.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose | Releases all resources used by the ThermalAsset
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.

See Also

ThermalAsset Class


ThermalAsset Constructor

[image]

Revit 2013 API
ThermalAsset Constructor
ThermalAsset Class See Also Send Feedback
Constructs an instance of ThermalAsset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalAsset(
    string name,
    ThermalMaterialType materialType
)
Visual Basic
Public Sub New ( _
    name As String, _
    materialType As ThermalMaterialType _
)
Visual C++
public:
ThermalAsset(
    String^ name,
    ThermalMaterialType materialType
)

Parameters

name
Type: System..::..String
The name of the asset.
materialType
Type: Autodesk.Revit.DB..::..ThermalMaterialType
The type of thermal material that this asset will describe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string. -or- name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ThermalAsset Class


ThermalAsset Methods

[image] [image]

Revit 2013 API
ThermalAsset Methods
ThermalAsset Class See Also Send Feedback

The ThermalAsset type exposes the following members.

Methods

 | Name | Description
Public method | Copy | Produces a copy of the asset.
Public method | Dispose |
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThermalAsset Class


Copy Method

[image]

Revit 2013 API
ThermalAsset..::..Copy Method
ThermalAsset Class See Also Send Feedback
Produces a copy of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalAsset Copy()
Visual Basic
Public Function Copy As ThermalAsset
Visual C++
public:
ThermalAsset^ Copy()

Return Value

A copy of the asset.

See Also

ThermalAsset Class


Dispose Method

[image]

Revit 2013 API
ThermalAsset..::..Dispose Method
ThermalAsset Class See Also Send Feedback
Releases all resources used by the ThermalAsset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ThermalAsset Class


Equals Method

[image] [image]

Revit 2013 API
ThermalAsset..::..Equals Method
ThermalAsset Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(ThermalAsset) | Determines whether this thermal asset is equal to another.

See Also

ThermalAsset Class
ThermalAsset Members


Equals Method (ThermalAsset)

[image]

Revit 2013 API
ThermalAsset..::..Equals Method (ThermalAsset)
ThermalAsset Class See Also Send Feedback
Determines whether this thermal asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Equals(
    ThermalAsset other
)
Visual Basic
Public Function Equals ( _
    other As ThermalAsset _
) As Boolean
Visual C++
public:
bool Equals(
    ThermalAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..ThermalAsset
The thermal asset to compare with this one.

Return Value

True if the given thermal asset is equal to this one, otherwise false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ThermalAsset Class
Equals Overload


ThermalAsset Properties

[image] [image]

Revit 2013 API
ThermalAsset Properties
ThermalAsset Class See Also Send Feedback

The ThermalAsset type exposes the following members.

Properties

 | Name | Description
Public property | Behavior | Flag indicating whether elements of this material behave isotropically or orthotropically.
Public property | Compressibility | The compressibility of the asset.
Public property | Density | The density of the asset.
Public property | ElectricalResistivity | The electrical resistivity of the asset.
Public property | Emissivity | The emissivity of the asset.
Public property | GasViscosity | The gas viscosity of the asset.
Public property | LiquidViscosity | The liquid viscosity of the asset.
Public property | Name | The name of the thermal asset.
Public property | Permeability | The permeability of the asset.
Public property | Porosity | The porosity of the asset.
Public property | Reflectivity | The reflectivity of the asset.
Public property | SpecificHeatOfVaporization | The specific heat of vaporization of the asset.
Public property | ThermalConductivity | The thermal conductivity of the asset.
Public property | ThermalMaterialType | The type of material that this thermal asset describes (e.g. solid, liquid, gas.)
Public property | TransmitsLight | A boolean flag that indicates whether or not the asset transmits light.
Public property | VaporPressure | The vapor pressure of the asset.

See Also

ThermalAsset Class


Behavior Property

[image]

Revit 2013 API
ThermalAsset..::..Behavior Property
ThermalAsset Class See Also Send Feedback
Flag indicating whether elements of this material behave isotropically or orthotropically.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StructuralBehavior Behavior { get; set; }
Visual Basic
Public Property Behavior As StructuralBehavior
    Get
    Set
Visual C++
public:
property StructuralBehavior Behavior {
    StructuralBehavior get ();
    void set (StructuralBehavior value);
}

See Also

ThermalAsset Class


Compressibility Property

[image]

Revit 2013 API
ThermalAsset..::..Compressibility Property
ThermalAsset Class See Also Send Feedback
The compressibility of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Compressibility { get; set; }
Visual Basic
Public Property Compressibility As Double
    Get
    Set
Visual C++
public:
property double Compressibility {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for compressibility is out of range

See Also

ThermalAsset Class


Density Property

[image]

Revit 2013 API
ThermalAsset..::..Density Property
ThermalAsset Class See Also Send Feedback
The density of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Density { get; set; }
Visual Basic
Public Property Density As Double
    Get
    Set
Visual C++
public:
property double Density {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per cubed feet (kg/ft³) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for density must be non-negative.

See Also

ThermalAsset Class


ElectricalResistivity Property

[image]

Revit 2013 API
ThermalAsset..::..ElectricalResistivity Property
ThermalAsset Class See Also Send Feedback
The electrical resistivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ElectricalResistivity { get; set; }
Visual Basic
Public Property ElectricalResistivity As Double
    Get
    Set
Visual C++
public:
property double ElectricalResistivity {
    double get ();
    void set (double value);
}

Remarks

Values are in ohm-meters and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for electricalResistivity must be non-negative.

See Also

ThermalAsset Class


Emissivity Property

[image]

Revit 2013 API
ThermalAsset..::..Emissivity Property
ThermalAsset Class See Also Send Feedback
The emissivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Emissivity { get; set; }
Visual Basic
Public Property Emissivity As Double
    Get
    Set
Visual C++
public:
property double Emissivity {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for emissivity is out of range

See Also

ThermalAsset Class


GasViscosity Property

[image]

Revit 2013 API
ThermalAsset..::..GasViscosity Property
ThermalAsset Class See Also Send Feedback
The gas viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GasViscosity { get; set; }
Visual Basic
Public Property GasViscosity As Double
    Get
    Set
Visual C++
public:
property double GasViscosity {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet-second (kg/(ft · s)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for gasViscosity must be non-negative.
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the asset must be gas to set this property.

See Also

ThermalAsset Class


LiquidViscosity Property

[image]

Revit 2013 API
ThermalAsset..::..LiquidViscosity Property
ThermalAsset Class See Also Send Feedback
The liquid viscosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LiquidViscosity { get; set; }
Visual Basic
Public Property LiquidViscosity As Double
    Get
    Set
Visual C++
public:
property double LiquidViscosity {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet-second (kg/(ft · s)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for liquidViscosity must be non-negative.
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: the asset must be liquid to set this property.

See Also

ThermalAsset Class


Name Property

[image]

Revit 2013 API
ThermalAsset..::..Name Property
ThermalAsset Class See Also Send Feedback
The name of the thermal asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ThermalAsset Class


Permeability Property

[image]

Revit 2013 API
ThermalAsset..::..Permeability Property
ThermalAsset Class See Also Send Feedback
The permeability of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Permeability { get; set; }
Visual Basic
Public Property Permeability As Double
    Get
    Set
Visual C++
public:
property double Permeability {
    double get ();
    void set (double value);
}

Remarks

Values are in seconds per foot (s/ft) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for permeability must be non-negative.

See Also

ThermalAsset Class


Porosity Property

[image]

Revit 2013 API
ThermalAsset..::..Porosity Property
ThermalAsset Class See Also Send Feedback
The porosity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Porosity { get; set; }
Visual Basic
Public Property Porosity As Double
    Get
    Set
Visual C++
public:
property double Porosity {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for porosity is out of range

See Also

ThermalAsset Class


Reflectivity Property

[image]

Revit 2013 API
ThermalAsset..::..Reflectivity Property
ThermalAsset Class See Also Send Feedback
The reflectivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Reflectivity { get; set; }
Visual Basic
Public Property Reflectivity As Double
    Get
    Set
Visual C++
public:
property double Reflectivity {
    double get ();
    void set (double value);
}

Remarks

Values must be in the range 0 to 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for reflectivity is out of range

See Also

ThermalAsset Class


SpecificHeatOfVaporization Property

[image]

Revit 2013 API
ThermalAsset..::..SpecificHeatOfVaporization Property
ThermalAsset Class See Also Send Feedback
The specific heat of vaporization of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SpecificHeatOfVaporization { get; set; }
Visual Basic
Public Property SpecificHeatOfVaporization As Double
    Get
    Set
Visual C++
public:
property double SpecificHeatOfVaporization {
    double get ();
    void set (double value);
}

Remarks

Values are in feet per squared-second (ft/s²) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for specificHeatOfVaporization must be non-negative.

See Also

ThermalAsset Class


ThermalConductivity Property

[image]

Revit 2013 API
ThermalAsset..::..ThermalConductivity Property
ThermalAsset Class See Also Send Feedback
The thermal conductivity of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ThermalConductivity { get; set; }
Visual Basic
Public Property ThermalConductivity As Double
    Get
    Set
Visual C++
public:
property double ThermalConductivity {
    double get ();
    void set (double value);
}

Remarks

Values are in feet-kilograms per Kelvin-cubed-second ((ft · kg)/(K · s³)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for thermalConductivity must be non-negative.

See Also

ThermalAsset Class


ThermalMaterialType Property

[image]

Revit 2013 API
ThermalAsset..::..ThermalMaterialType Property
ThermalAsset Class See Also Send Feedback
The type of material that this thermal asset describes (e.g. solid, liquid, gas.)

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalMaterialType ThermalMaterialType { get; }
Visual Basic
Public ReadOnly Property ThermalMaterialType As ThermalMaterialType
    Get
Visual C++
public:
property ThermalMaterialType ThermalMaterialType {
    ThermalMaterialType get ();
}

See Also

ThermalAsset Class


TransmitsLight Property

[image]

Revit 2013 API
ThermalAsset..::..TransmitsLight Property
ThermalAsset Class See Also Send Feedback
A boolean flag that indicates whether or not the asset transmits light.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool TransmitsLight { get; set; }
Visual Basic
Public Property TransmitsLight As Boolean
    Get
    Set
Visual C++
public:
property bool TransmitsLight {
    bool get ();
    void set (bool value);
}

See Also

ThermalAsset Class


VaporPressure Property

[image]

Revit 2013 API
ThermalAsset..::..VaporPressure Property
ThermalAsset Class See Also Send Feedback
The vapor pressure of the asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double VaporPressure { get; set; }
Visual Basic
Public Property VaporPressure As Double
    Get
    Set
Visual C++
public:
property double VaporPressure {
    double get ();
    void set (double value);
}

Remarks

Values are in kilograms per feet, squared-second (kg/(ft · s²)) and must be non-negative.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for vaporPressure must be non-negative.

See Also

ThermalAsset Class


ThermalMaterialType Enumeration

[image]

Revit 2013 API
ThermalMaterialType Enumeration
See Also Send Feedback
Represents the thermal material type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ThermalMaterialType
Visual Basic
Public Enumeration ThermalMaterialType
Visual C++
public enum class ThermalMaterialType

Members

Member name | Description
Undefined | Thermal material type is undefined.
Gas | Thermal material type is gas.
Liquid | Thermal material type is liquid.
Solid | Thermal material type is solid.

See Also


ThermalProperties Class

[image]

Revit 2013 API
ThermalProperties Class
Members See Also Send Feedback
Class specific to thermal properties for assembly types, such as Wall, Floor, Ceiling, Roof and Building Pad.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ThermalProperties : APIObject
Visual Basic
Public Class ThermalProperties _
    Inherits APIObject
Visual C++
public ref class ThermalProperties : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ThermalProperties

See Also

ThermalProperties Members


ThermalProperties Members

[image] [image]

Revit 2013 API
ThermalProperties Members
ThermalProperties Class Methods Properties See Also Send Feedback

The ThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class


ThermalProperties Methods

[image] [image]

Revit 2013 API
ThermalProperties Methods
ThermalProperties Class See Also Send Feedback

The ThermalProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ThermalProperties Class


ThermalProperties Properties

[image] [image]

Revit 2013 API
ThermalProperties Properties
ThermalProperties Class See Also Send Feedback

The ThermalProperties type exposes the following members.

Properties

 | Name | Description
Public property | Absorptance | Value of absorptance.
Public property | HeatTransferCoefficient | The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Roughness | Value of roughness.
Public property | ThermalMass | The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).
Public property | ThermalResistance | The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

See Also

ThermalProperties Class


Absorptance Property

[image]

Revit 2013 API
ThermalProperties..::..Absorptance Property
ThermalProperties Class See Also Send Feedback
Value of absorptance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Absorptance { get; set; }
Visual Basic
Public Property Absorptance As Double
    Get
    Set
Visual C++
public:
property double Absorptance {
    double get ();
    void set (double value);
}

See Also

ThermalProperties Class


HeatTransferCoefficient Property

[image]

Revit 2013 API
ThermalProperties..::..HeatTransferCoefficient Property
ThermalProperties Class See Also Send Feedback
The heat transfer coefficient value (U-Value). The unit is watts per meter-squared kelvin (W/(m^2*K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double HeatTransferCoefficient { get; }
Visual Basic
Public ReadOnly Property HeatTransferCoefficient As Double
    Get
Visual C++
public:
property double HeatTransferCoefficient {
    double get ();
}

See Also

ThermalProperties Class


Roughness Property

[image]

Revit 2013 API
ThermalProperties..::..Roughness Property
ThermalProperties Class See Also Send Feedback
Value of roughness.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Roughness { get; set; }
Visual Basic
Public Property Roughness As Integer
    Get
    Set
Visual C++
public:
property int Roughness {
    int get ();
    void set (int value);
}

See Also

ThermalProperties Class


ThermalMass Property

[image]

Revit 2013 API
ThermalProperties..::..ThermalMass Property
ThermalProperties Class See Also Send Feedback
The calculated thermal mass value. The unit is kilogram feet-squared per second squared kelvin (kg ft^2/(s^2 K)).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ThermalMass { get; }
Visual Basic
Public ReadOnly Property ThermalMass As Double
    Get
Visual C++
public:
property double ThermalMass {
    double get ();
}

See Also

ThermalProperties Class


ThermalResistance Property

[image]

Revit 2013 API
ThermalProperties..::..ThermalResistance Property
ThermalProperties Class See Also Send Feedback
The calculated thermal resistance value (R-Value). The unit is meter-squared kelvin per watt ((m^2*K)/Watt).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ThermalResistance { get; }
Visual Basic
Public ReadOnly Property ThermalResistance As Double
    Get
Visual C++
public:
property double ThermalResistance {
    double get ();
}

See Also

ThermalProperties Class


TilePattern Class

[image]

Revit 2013 API
TilePattern Class
Members See Also Send Feedback
An object representing a tile pattern that may be applied to a DividedSurface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TilePattern : ElementType
Visual Basic
Public Class TilePattern _
    Inherits ElementType
Visual C++
public ref class TilePattern : public ElementType

Remarks

TilePatterns cannot be created. A fixed selection is built into each Conceptual Mass family. TilePatterns can be retrieved by key from the Revit::DB::Document::Settings::TilePatternTable object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..TilePattern

See Also

TilePattern Members


TilePattern Members

[image] [image]

Revit 2013 API
TilePattern Members
TilePattern Class Methods Properties See Also Send Feedback

The TilePattern type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TilePattern Class


TilePattern Methods

[image] [image]

Revit 2013 API
TilePattern Methods
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePattern Class


TilePattern Properties

[image] [image]

Revit 2013 API
TilePattern Properties
TilePattern Class See Also Send Feedback

The TilePattern type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TilePatternType | The built-in system tile pattern specified by this object.
Public property | TilesPerSeedNode | Get the number of tiles located at each seed node.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TilePattern Class


Parameter Property

[image] [image]

Revit 2013 API
TilePattern..::..Parameter Property
TilePattern Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TilePattern Class
TilePattern Members


TilePatternType Property

[image]

Revit 2013 API
TilePattern..::..TilePatternType Property
TilePattern Class See Also Send Feedback
The built-in system tile pattern specified by this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TilePatternsBuiltIn TilePatternType { get; }
Visual Basic
Public ReadOnly Property TilePatternType As TilePatternsBuiltIn
    Get
Visual C++
public:
property TilePatternsBuiltIn TilePatternType {
    TilePatternsBuiltIn get ();
}

See Also

TilePattern Class


TilesPerSeedNode Property

[image]

Revit 2013 API
TilePattern..::..TilesPerSeedNode Property
TilePattern Class See Also Send Feedback
Get the number of tiles located at each seed node.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int TilesPerSeedNode { get; }
Visual Basic
Public ReadOnly Property TilesPerSeedNode As Integer
    Get
Visual C++
public:
property int TilesPerSeedNode {
    int get ();
}

Remarks

Currently the number of tiles per seed node is always either 1 or 2.

See Also

TilePattern Class


TilePatterns Class

[image]

Revit 2013 API
TilePatterns Class
Members See Also Send Feedback
The TilePatterns object is an interface for retrieving the TilePattern objects within the Document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TilePatterns : APIObject
Visual Basic
Public Class TilePatterns _
    Inherits APIObject
Visual C++
public ref class TilePatterns : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..TilePatterns

See Also

TilePatterns Members


TilePatterns Members

[image] [image]

Revit 2013 API
TilePatterns Members
TilePatterns Class Methods Properties See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatterns Methods

[image] [image]

Revit 2013 API
TilePatterns Methods
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTilePattern | Retrieve a TilePattern object from a built-in type.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TilePatterns Class


GetTilePattern Method

[image]

Revit 2013 API
TilePatterns..::..GetTilePattern Method
TilePatterns Class See Also Send Feedback
Retrieve a TilePattern object from a built-in type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TilePattern GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)
Visual Basic
Public Function GetTilePattern ( _
    tilePatternBuiltIn As TilePatternsBuiltIn _
) As TilePattern
Visual C++
public:
TilePattern^ GetTilePattern(
    TilePatternsBuiltIn tilePatternBuiltIn
)

Parameters

tilePatternBuiltIn
Type: Autodesk.Revit.DB..::..TilePatternsBuiltIn

Return Value

A TilePattern object, or nullNothingnullptra null reference (Nothing in Visual Basic) if the document is not a Massing Family.

See Also

TilePatterns Class


TilePatterns Properties

[image] [image]

Revit 2013 API
TilePatterns Properties
TilePatterns Class See Also Send Feedback

The TilePatterns type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TilePatterns Class


TilePatternsBuiltIn Enumeration

[image]

Revit 2013 API
TilePatternsBuiltIn Enumeration
See Also Send Feedback
Revit's built-in tile patterns. See TilePattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TilePatternsBuiltIn
Visual Basic
Public Enumeration TilePatternsBuiltIn
Visual C++
public enum class TilePatternsBuiltIn

Members

Member name | Description
Rectangle |
Triangle_Bent |
Rhomboid |
Hexagon |
HalfStep |
ThirdStep |
TriangleCheckerboard_Bent |
RectangleCheckerboard |
RhomboidCheckerboard |
TriangleStep_Bent |
Arrows |
ZigZag |
Octagon |
OctagonRotate |
Triangle_Flat |
TriangleCheckerboard_Flat |

See Also


TopographySurface Class

[image]

Revit 2013 API
TopographySurface Class
Members See Also Send Feedback
An object that is used to represent a topography surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TopographySurface : Element
Visual Basic
Public Class TopographySurface _
    Inherits Element
Visual C++
public ref class TopographySurface : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..TopographySurface

See Also

TopographySurface Members


TopographySurface Members

[image] [image]

Revit 2013 API
TopographySurface Members
TopographySurface Class Methods Properties See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

 | Name | Description
Public method | AddPoints | Adds new points to a topography surface element.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopographySurface Class


TopographySurface Methods

[image] [image]

Revit 2013 API
TopographySurface Methods
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Methods

 | Name | Description
Public method | AddPoints | Adds new points to a topography surface element.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopographySurface Class


AddPoints Method

[image]

Revit 2013 API
TopographySurface..::..AddPoints Method
TopographySurface Class See Also Send Feedback
Adds new points to a topography surface element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddPoints(
    IList<XYZ> points
)
Visual Basic
Public Sub AddPoints ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
void AddPoints(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
An array of points for the topography surface.

Remarks

This method will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the topography surface is invalid or regeneration fails.

See Also

TopographySurface Class


TopographySurface Properties

[image] [image]

Revit 2013 API
TopographySurface Properties
TopographySurface Class See Also Send Feedback

The TopographySurface type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopographySurface Class


Parameter Property

[image] [image]

Revit 2013 API
TopographySurface..::..Parameter Property
TopographySurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TopographySurface Class
TopographySurface Members


Transaction Class

[image]

Revit 2013 API
Transaction Class
Members Example See Also Send Feedback
Transactions are context-like objects that guard any changes made to a Revit model

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Transaction : IDisposable
Visual Basic
Public Class Transaction _
    Implements IDisposable
Visual C++
public ref class Transaction : IDisposable

Remarks

Any change to a document can only be made while there is an active transaction open for that document. Changes do not become part of the document until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly by the transaction's destructor.

A document can have only one transaction open at any given time.

Transactions cannot be started when the document is in read-only mode, either permanently or temporarily. See the Document class methods IsReadOnly and IsModifiable for more details.

Transactions in linked documents are not permitted, for linked documents are not allowed to be modified.

If a transaction was started and not finished yet by the time the Transaction object is about to be disposed, the default destructor will roll it back automatically, thus all changes made to the document while this transaction was open will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit or RollBack explicitly before the transaction object gets disposed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Examples

CopyC#
// Get the document
Autodesk.Revit.DB.Document document = uiApplication.ActiveUIDocument.Document;

// Create a geometry line in Revit application
XYZ Point1 = new XYZ(0, 0, 0);
XYZ Point2 = new XYZ(10, 0, 0);
XYZ Point3 = new XYZ(10, 10, 0);
XYZ Point4 = new XYZ(0, 10, 0);

// Transient Elements,so they are not managed by transactions
Line geomLine1 = application.Create.NewLine(Point1, Point2, true);
Line geomLine2 = application.Create.NewLine(Point4, Point3, true);
Line geomLine3 = application.Create.NewLine(Point1, Point4, true);

// Create a geometry plane in Revit application
XYZ origin = new XYZ(0, 0, 0);
XYZ normal = new XYZ(0, 0, 1);
Plane geomPlane = application.Create.NewPlane(normal, origin);

// non-transient elements,so they are grouped into transaction as atomic user actions
Transaction transaction = new Transaction(document);
if (transaction.Start("Create new curves") == TransactionStatus.Started)
{
    // Create a sketch plane in current document
    SketchPlane sketch = document.Create.NewSketchPlane(geomPlane);

    // Create a ModelLine element using the created geometry line and sketch plane
    ModelLine line1 = document.Create.NewModelCurve(geomLine1, sketch) as ModelLine;
    ModelLine line2 = document.Create.NewModelCurve(geomLine2, sketch) as ModelLine;
    ModelLine line3 = document.Create.NewModelCurve(geomLine3, sketch) as ModelLine;

    TaskDialog taskDialog = new TaskDialog("Revit");
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback().";
    TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok | TaskDialogCommonButtons.Cancel;
    taskDialog.CommonButtons = buttons;
    TaskDialogResult result = taskDialog.Show();

    if (TaskDialogResult.Ok == result)
    {
        transaction.Commit();
    }
    else
    {
        transaction.RollBack();
    }
}
CopyVB.NET
' Get the document
Dim document As Autodesk.Revit.DB.Document = uiApplication.ActiveUIDocument.Document

' Create a geometry line in Revit application
Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)
Dim Point3 As New Autodesk.Revit.DB.XYZ(10, 10, 0)
Dim Point4 As New Autodesk.Revit.DB.XYZ(0, 10, 0)

' Transient Elements,so they are not managed by transactions
Dim geomLine1 As Line = application.Create.NewLine(Point1, Point2, True)
Dim geomLine2 As Line = application.Create.NewLine(Point4, Point3, True)
Dim geomLine3 As Line = application.Create.NewLine(Point1, Point4, True)

' Create a geometry plane in Revit application
Dim origin As New Autodesk.Revit.DB.XYZ(0, 0, 0)
Dim normal As New Autodesk.Revit.DB.XYZ(0, 0, 1)
Dim geomPlane As Plane = application.Create.NewPlane(normal, origin)

' non-transient elements,so they are grouped into transaction as atomic user actions
Dim transaction As New Transaction(document)
If transaction.Start("Create new curves") = TransactionStatus.Started Then
    ' Create a sketch plane in current document
    Dim sketch As SketchPlane = document.Create.NewSketchPlane(geomPlane)

    ' Create a ModelLine element using the created geometry line and sketch plane
    Dim line1 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine1, sketch), ModelLine)
    Dim line2 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine2, sketch), ModelLine)
    Dim line3 As ModelLine = TryCast(document.Create.NewModelCurve(geomLine3, sketch), ModelLine)

    Dim taskDialog As New TaskDialog("Revit")
    taskDialog.MainContent = "Click OK to call Transaction.Commit(), otherwise Transaction.Rollback()."
    Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
    taskDialog.CommonButtons = buttons
    Dim result As TaskDialogResult = taskDialog.Show()

    If TaskDialogResult.Ok = result Then
        transaction.Commit()
    Else
        transaction.RollBack()
    End If
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Transaction

See Also

Transaction Members


Transaction Members

[image] [image]

Revit 2013 API
Transaction Members
Transaction Class Constructors Methods See Also Send Feedback

The Transaction type exposes the following members.

Constructors

 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object

Methods

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose | Releases all resources used by the Transaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Public method | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
Public method | SetName | Sets the transaction's name.
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transaction Class


Transaction Constructor

[image] [image]

Revit 2013 API
Transaction Constructor
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Transaction(Document) | Instantiates a transaction object.
Public method | Transaction(Document, String) | Instantiates a transaction object

See Also

Transaction Class
Transaction Members


Transaction Constructor (Document)

[image]

Revit 2013 API
Transaction Constructor (Document)
Transaction Class See Also Send Feedback
Instantiates a transaction object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transaction(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
Transaction(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction is going to be used.

Remarks

The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.

A transaction cannot start unless is has a valid (non-empty) name. Because this constructor does not take a name, a name must be assigned later before or during the 'Start' method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Document is a linked file. Transactions can only be used in primary documents (projects or families.)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload


Transaction Constructor (Document, String)

[image]

Revit 2013 API
Transaction Constructor (Document, String)
Transaction Class See Also Send Feedback
Instantiates a transaction object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transaction(
    Document document,
    string name
)
Visual Basic
Public Sub New ( _
    document As Document, _
    name As String _
)
Visual C++
public:
Transaction(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction is going to be used.
name
Type: System..::..String
The name of the transaction. This name will appear in the undo menu once the transaction is successfully committed. The name must not be empty. The name can be reset later by either calling SetName(String) or by using the name argument in the Start(String) method.

Remarks

The transaction does not start by creating a transaction object. One of the 'Start' methods will need to be called in order to start this transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string. -or- Document is a linked file. Transactions can only be used in primary documents (projects or families.)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class
Transaction Overload


Transaction Methods

[image] [image]

Revit 2013 API
Transaction Methods
Transaction Class See Also Send Feedback

The Transaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailureHandlingOptions | Returns the current failure handling options.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction's name.
Public method | GetStatus | Returns the current status of the transaction.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.
Public method | SetFailureHandlingOptions | Sets options for handling failures to be used when the transaction is being committed or rolled back.
Public method | SetName | Sets the transaction's name.
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transaction Class


Commit Method

[image] [image]

Revit 2013 API
Transaction..::..Commit Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Commit()()()() | Commits all changes made to the model during the transaction.
Public method | Commit(FailureHandlingOptions) | Commits all changes made to the model during the transaction.

See Also

Transaction Class
Transaction Members


Commit Method

[image]

Revit 2013 API
Transaction..::..Commit Method
Transaction Class See Also Send Feedback
Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus::Pending is returned it means that failure handling has not been finalized yet and Revit awaits a user actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

The returned status does not have to be necessarily the same as the status returned by GetStatus()()()() even when the method is called immediately after committing the transaction. Such a difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Remarks

By committing a transaction, all changes made to the model during the transaction are accepted. A new undo item will appear in the Undo menu in Revit, which allows the user to undo the changes. The undo item will have this transaction's name. Commit may only be called for a transaction that has been started. (Use the GetStatus()()()() method to check the current state.) Be aware that committing may fail or can be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was committed successfully. Only after a transaction is successfully committed (or rolled back as a result of handling transaction failures), it may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload


Commit Method (FailureHandlingOptions)

[image]

Revit 2013 API
Transaction..::..Commit Method (FailureHandlingOptions)
Transaction Class See Also Send Feedback
Commits all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus Commit(
    FailureHandlingOptions options
)
Visual Basic
Public Function Commit ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus Commit(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

The options are only used temporarily during the commitment process. After the transaction is finished, the options will be reset to their default values.

Return Value

If finished successfully, this method returns TransactionStatus.Committed

Note it is possible the RolledBack status is returned instead as an outcome of failure handling. If TransactionStatus.Pending is returned it means that failure handling has not been finalized yet and Revit awaits user's actions. Until committing is fully finalized, no changes to the document can be made (including starting of new transactions).

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus()()()() even when the method is called immediately after committing the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
Commit Overload


Dispose Method

[image]

Revit 2013 API
Transaction..::..Dispose Method
Transaction Class See Also Send Feedback
Releases all resources used by the Transaction

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Transaction Class


GetFailureHandlingOptions Method

[image]

Revit 2013 API
Transaction..::..GetFailureHandlingOptions Method
Transaction Class See Also Send Feedback
Returns the current failure handling options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FailureHandlingOptions GetFailureHandlingOptions()
Visual Basic
Public Function GetFailureHandlingOptions As FailureHandlingOptions
Visual C++
public:
FailureHandlingOptions^ GetFailureHandlingOptions()

Return Value

An instance of FailureHandlingOptions

Remarks

The returned instance is a copy of the options. If changes are made to the options, the new version can be set back to the transaction by calling the SetFailureHandlingOptions(FailureHandlingOptions) method.

See Also

Transaction Class


GetName Method

[image]

Revit 2013 API
Transaction..::..GetName Method
Transaction Class See Also Send Feedback
Returns the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The transaction's current name.

See Also

Transaction Class


GetStatus Method

[image]

Revit 2013 API
Transaction..::..GetStatus Method
Transaction Class See Also Send Feedback
Returns the current status of the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

Return Value

The current status of the transaction.

Remarks

If the status was set to TransactionStatus.Pending as the result of calling Commit or RollBack, the status will be changed later to either 'Committed' or 'RolledBack' after failure handling is finished. That status change will be made asynchronously.

See Also

Transaction Class


HasEnded Method

[image]

Revit 2013 API
Transaction..::..HasEnded Method
Transaction Class See Also Send Feedback
Determines whether the transaction has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasEnded()
Visual Basic
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Return Value

True if the transaction has already been committed or rolled back, False otherwise.

Remarks

A transaction is ended by completing either the 'Commit' or 'RollBack' method. Another way of testing whether a transaction has ended is by testing the current status (see GetStatus()()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

Transaction Class


HasStarted Method

[image]

Revit 2013 API
Transaction..::..HasStarted Method
Transaction Class See Also Send Feedback
Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasStarted()
Visual Basic
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Return Value

True if the transaction has already started, False otherwise.

Remarks

A transaction is considered being started after a 'Start' method was called and until the transaction is either completely committed or rolled back.

HasStarted may return True even after 'Commit' or 'RollBack' was called if the method returned the TransactionStatus.Pending value.

A transaction can only be Started when HasStarted returns false.

See Also

Transaction Class


RollBack Method

[image] [image]

Revit 2013 API
Transaction..::..RollBack Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RollBack()()()() | Rolls back all changes made to the model during the transaction.
Public method | RollBack(FailureHandlingOptions) | Rolls back all changes made to the model during the transaction.

See Also

Transaction Class
Transaction Members


RollBack Method

[image]

Revit 2013 API
Transaction..::..RollBack Method
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus()()()() even when the method is called immediately after rolling back the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Remarks

By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus()()()() method to check the current state.) Be aware that rolling back may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is fully completed, the transaction may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
RollBack Overload


RollBack Method (FailureHandlingOptions)

[image]

Revit 2013 API
Transaction..::..RollBack Method (FailureHandlingOptions)
Transaction Class See Also Send Feedback
Rolls back all changes made to the model during the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus RollBack(
    FailureHandlingOptions options
)
Visual Basic
Public Function RollBack ( _
    options As FailureHandlingOptions _
) As TransactionStatus
Visual C++
public:
TransactionStatus RollBack(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
A set of options to be used for handling eventual failures during this call.

The options are only used temporarily during this rolling back process. After the transaction is finished, the options will be reset to their default values.

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Be aware that the returned status does not have to be necessarily the same like the status returned by GetStatus()()()() even when the method is called immediately after rolling back the transaction. Such difference may happen due to actions made by a transaction finalizer, if there was one set. (See FailureHandlingOptions for more details.)

Remarks

By rolling back a transaction, all changes made to the model are discarded. RollBack may only be called for a transaction that has been started. (Use the GetStatus()()()() method to check the current state.) Be aware that rolling back may be delayed (as a result of failure handling.) Callers should always check the returned status to test whether a transaction was rolled back successfully. Only after rolling back is fully completed, the transaction may be started again.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current status of the transaction is not 'Started'. Transaction must be started before calling Commit or Rollback. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished.

See Also

Transaction Class
RollBack Overload


SetFailureHandlingOptions Method

[image]

Revit 2013 API
Transaction..::..SetFailureHandlingOptions Method
Transaction Class Example See Also Send Feedback
Sets options for handling failures to be used when the transaction is being committed or rolled back.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetFailureHandlingOptions(
    FailureHandlingOptions options
)
Visual Basic
Public Sub SetFailureHandlingOptions ( _
    options As FailureHandlingOptions _
)
Visual C++
public:
void SetFailureHandlingOptions(
    FailureHandlingOptions^ options
)

Parameters

options
Type: Autodesk.Revit.DB..::..FailureHandlingOptions
An instance of FailureHandlingOptions to be applied to the transaction

Remarks

Options can be set at any time before the transaction is either committed or rolled back. See FailureHandlingOptions for details about available options. Once committed or rolled back, the transaction object will reset its options to their default values.

Examples

CopyC#
Transaction t = new Transaction(doc);
t.Start("room");
FailureHandlingOptions failOpt = t.GetFailureHandlingOptions();
failOpt.SetFailuresPreprocessor(new RoomWarningSwallower());
t.SetFailureHandlingOptions(failOpt);

doc.Create.NewRoom(level, new UV(0, 0));
t.Commit();
CopyVB.NET
Dim t As New Transaction(doc)
t.Start("room")
Dim failOpt As Autodesk.Revit.DB.FailureHandlingOptions
failOpt = t.GetFailureHandlingOptions()
failOpt.SetFailuresPreprocessor(New RoomWarningSwallower())
t.SetFailureHandlingOptions(failOpt)

doc.Create.NewRoom(level, New Autodesk.Revit.DB.UV(0, 0))
t.Commit()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class


SetName Method

[image]

Revit 2013 API
Transaction..::..SetName Method
Transaction Class See Also Send Feedback
Sets the transaction's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
A name for the transaction.

Remarks

A transaction needs a name before it can be started, i.e. before one of the 'Start' method is invoked for this transaction object. The name will later appear in the Undo menu in Revit after a transaction is successfully committed.

Another ways of setting the name is either during construction or during the Start(String) method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Transaction Class


Start Method

[image] [image]

Revit 2013 API
Transaction..::..Start Method
Transaction Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start()()()() | Starts the transaction.
Public method | Start(String) | Starts the transaction with an assigned name.

See Also

Transaction Class
Transaction Members


Start Method

[image]

Revit 2013 API
Transaction..::..Start Method
Transaction Class See Also Send Feedback
Starts the transaction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus Start()
Visual Basic
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.

Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back. In order to start a transaction, it must have a name assigned. If the name was not specified when the transaction object was instantiated, it has to be set by calling the SetName(String) method.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary). -or- The transaction does not have a valid name assigned yet.

See Also

Transaction Class
Start Overload


Start Method (String)

[image]

Revit 2013 API
Transaction..::..Start Method (String)
Transaction Class See Also Send Feedback
Starts the transaction with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TransactionStatus Start(
    string name
)
Visual Basic
Public Function Start ( _
    name As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the transaction; If the transaction already has name, this new one will preplace it. The name will appear on the Undo menu in Revit if the transaction is successfully committed.

Return Value

If finished successfully, this method returns TransactionStatus.Started. Note that unless starting is successful, changes cannot be made to the document.

Remarks

A transaction may be started only after it was instantiated or after it was previously committed or rolled back.

Be aware that every time a transaction starts, Failure Handling Options will be reset to their default values. If a specific failure handling is required, programmers need to use SetFailureHandlingOptions(FailureHandlingOptions) before the transaction is committed or rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name argument is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- The transaction's document is currently in failure mode. No transaction operations are permitted until failure handling is finished. -or- The transaction started already and has not been completed yet. -or- Starting a new transaction is not permitted. It could be because another transaction already started and has not been completed yet, or the document is in a state in which it cannot start a new transaction (e.g. during failure handling or a read-only mode, which could be either permanent or temporary).

See Also

Transaction Class
Start Overload


TransactionGroup Class

[image]

Revit 2013 API
TransactionGroup Class
Members See Also Send Feedback
Transaction groups aggregate a number of transactions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TransactionGroup : IDisposable
Visual Basic
Public Class TransactionGroup _
    Implements IDisposable
Visual C++
public ref class TransactionGroup : IDisposable

Remarks

A transaction group controls whether transactions committed inside the group should stay committed or should be all discarded. If the group is committed, all the transactions remain committed, but if the transaction group is rolled back instead, all the inner, already committed transactions will be undone (and removed).

There are two ways of committing a group - Commit and Assimilate. By committing, all transactions committed inside a group stay as they are, while by assimilating, all inner transactions will be merged into a single transaction.

A transaction group can only be started when no transaction is active, and must be closed only after the last transaction started inside the group is finished, i.e. after it was either committed or rolled back.

Transaction groups may be nested inside each other with the restriction that every nested transaction group is entirely contained (opened and closed) in the parent transaction group.

If a transaction group was started and not finished yet by the time the TransactionGroup object is about to be, the default destructor will roll it back automatically, thus all changes made to the document while this transaction group was open will be discarded. It is not recommended to rely on this default behavior though. Instead, it is advised to always call either Commit()()()(), RollBack()()()(), or Assimilate()()()() explicitly before the group object gets destroyed. Please note that unless invoked explicitly the actual destruction of an object in managed code might not happen until the object is collected by the garbage collector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TransactionGroup

See Also

TransactionGroup Members


TransactionGroup Members

[image] [image]

Revit 2013 API
TransactionGroup Members
TransactionGroup Class Constructors Methods Properties See Also Send Feedback

The TransactionGroup type exposes the following members.

Constructors

 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object

Methods

 | Name | Description
Public method | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
Public method | Commit | Commits the transaction group.
Public method | Dispose | Releases all resources used by the TransactionGroup
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.

See Also

TransactionGroup Class


TransactionGroup Constructor

[image] [image]

Revit 2013 API
TransactionGroup Constructor
TransactionGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransactionGroup(Document) | Constructs a transaction group object.
Public method | TransactionGroup(Document, String) | It constructs a transaction group object

See Also

TransactionGroup Class
TransactionGroup Members


TransactionGroup Constructor (Document)

[image]

Revit 2013 API
TransactionGroup Constructor (Document)
TransactionGroup Class See Also Send Feedback
Constructs a transaction group object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document
)
Visual Basic
Public Sub New ( _
    document As Document _
)
Visual C++
public:
TransactionGroup(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction group is being used.

Remarks

The group does not start until its Start method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Constructor (Document, String)

[image]

Revit 2013 API
TransactionGroup Constructor (Document, String)
TransactionGroup Class See Also Send Feedback
It constructs a transaction group object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionGroup(
    Document document,
    string transGroupName
)
Visual Basic
Public Sub New ( _
    document As Document, _
    transGroupName As String _
)
Visual C++
public:
TransactionGroup(
    Document^ document,
    String^ transGroupName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which this transaction group is being used.
transGroupName
Type: System..::..String
Name of the group. The name will be used only for a group that is assimilated at the end.

Remarks

The group does not start until its Start method is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class
TransactionGroup Overload


TransactionGroup Methods

[image] [image]

Revit 2013 API
TransactionGroup Methods
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Methods

 | Name | Description
Public method | Assimilate | Assimilates all inner transactions by merging them into a single undo item.
Public method | Commit | Commits the transaction group.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetName | Returns the transaction group's name. It could be an empty string.
Public method | GetStatus | Gets the current status of the transaction group.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasEnded | Determines whether the transaction group has ended already.
Public method | HasStarted | Determines whether the transaction has been started yet.
Public method | RollBack | Rolls back the transaction group, which effectively undoes all transactions committed inside the group.
Public method | SetName | Sets the transaction group's name.
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransactionGroup Class


Assimilate Method

[image]

Revit 2013 API
TransactionGroup..::..Assimilate Method
TransactionGroup Class Example See Also Send Feedback
Assimilates all inner transactions by merging them into a single undo item.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Assimilate()
Visual Basic
Public Function Assimilate As TransactionStatus
Visual C++
public:
TransactionStatus Assimilate()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Remarks

After a successful assimilation the transaction group is committed.

All transactions committed inside this group will be merged into one single transaction. The resulting undo item will bear this group's name, unless there was only one transaction in the group in which case the item's name will be the single transaction's name.

Assimilate can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

Examples

CopyC#
TransactionStatus status = TransactionStatus.Uninitialized;
bool bAssimilate = true;
TransactionGroup transGroup = new TransactionGroup(document, "Group Change");
if (transGroup.Start() == TransactionStatus.Started)
{
    Transaction levelTransaction = new Transaction(document, "Add Level");
    try
    {
        if (levelTransaction.Start() == TransactionStatus.Started)
        {
            document.Create.NewLevel(25.0);
            levelTransaction.Commit();
        }
    }
    catch
    {
        // if either internal transaction fails, rollback group, too
        levelTransaction.RollBack();
        bAssimilate = false;
    }

    // if first transaction was successful, continue with next
    if (bAssimilate == true)
    {
        Transaction gridTransaction = new Transaction(document, "Add Grid");
        try
        {
            if (gridTransaction.Start() == TransactionStatus.Started)
            {
                XYZ Point1 = new XYZ(0, 0, 0);
                XYZ Point2 = new XYZ(10, 0, 0);

                Line gridLine = document.Application.Create.NewLine(Point1, Point2, true);
                document.Create.NewGrid(gridLine);
                gridTransaction.Commit();
            }
        }
        catch
        {
            // if either internal transaction fails, rollback group, too
            gridTransaction.RollBack();
            bAssimilate = false;
        }
    }

    // if both transactions are successful, assimilate the group
    if (bAssimilate == true)
    {
        status = transGroup.Assimilate();
    }
    else
    {
        status = transGroup.RollBack();
    }
}
CopyVB.NET
Dim status As TransactionStatus = TransactionStatus.Uninitialized
Dim bAssimilate As Boolean = True
Dim transGroup As New TransactionGroup(document, "Group Change")
If transGroup.Start() = TransactionStatus.Started Then
    Dim levelTransaction As New Transaction(document, "Add Level")
    Try
        If levelTransaction.Start() = TransactionStatus.Started Then
            document.Create.NewLevel(25)
            levelTransaction.Commit()
        End If
    Catch
        ' if either internal transaction fails, rollback group, too
        levelTransaction.RollBack()
        bAssimilate = False
    End Try

    ' if first transaction was successful, continue with next
    If bAssimilate = True Then
        Dim gridTransaction As New Transaction(document, "Add Grid")
        Try
            If gridTransaction.Start() = TransactionStatus.Started Then
                Dim Point1 As New Autodesk.Revit.DB.XYZ(0, 0, 0)
                Dim Point2 As New Autodesk.Revit.DB.XYZ(10, 0, 0)

                Dim gridLine As Line = document.Application.Create.NewLine(Point1, Point2, True)
                document.Create.NewGrid(gridLine)
                gridTransaction.Commit()
            End If
        Catch
            ' if either internal transaction fails, rollback group, too
            gridTransaction.RollBack()
            bAssimilate = False
        End Try
    End If

    ' if both transactions are successful, assimilate the group
    If bAssimilate = True Then
        status = transGroup.Assimilate()
    Else
        status = transGroup.RollBack()
    End If
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


Commit Method

[image]

Revit 2013 API
TransactionGroup..::..Commit Method
TransactionGroup Class See Also Send Feedback
Commits the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Commit()
Visual Basic
Public Function Commit As TransactionStatus
Visual C++
public:
TransactionStatus Commit()

Return Value

If finished successfully, this method returns TransactionStatus.Committed.

Remarks

Committing a group does not change the model. It only confirms the commitment of all inner groups and transactions.

Commit can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back. If there is still a transaction or an inner transaction group open, an attempt to commit this outer group will cause an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


Dispose Method

[image]

Revit 2013 API
TransactionGroup..::..Dispose Method
TransactionGroup Class See Also Send Feedback
Releases all resources used by the TransactionGroup

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TransactionGroup Class


GetName Method

[image]

Revit 2013 API
TransactionGroup..::..GetName Method
TransactionGroup Class See Also Send Feedback
Returns the transaction group's name. It could be an empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The transaction group's current name.

See Also

TransactionGroup Class


GetStatus Method

[image]

Revit 2013 API
TransactionGroup..::..GetStatus Method
TransactionGroup Class See Also Send Feedback
Gets the current status of the transaction group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus GetStatus()
Visual Basic
Public Function GetStatus As TransactionStatus
Visual C++
public:
TransactionStatus GetStatus()

Return Value

The current status of the transaction group.

See Also

TransactionGroup Class


HasEnded Method

[image]

Revit 2013 API
TransactionGroup..::..HasEnded Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction group has ended already.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasEnded()
Visual Basic
Public Function HasEnded As Boolean
Visual C++
public:
bool HasEnded()

Return Value

True if the transaction group has already been committed or rolled back, False otherwise.

Remarks

A transaction is ended by completing either the Commit or RollBack or Assimilate method. Another way of testing whether a transaction group has ended is by testing its current status returned from (see GetStatus()()()()). It must be either 'TransactionStatus.Committed' or 'TransactionStatus.RolledBack'

See Also

TransactionGroup Class


HasStarted Method

[image]

Revit 2013 API
TransactionGroup..::..HasStarted Method
TransactionGroup Class See Also Send Feedback
Determines whether the transaction has been started yet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasStarted()
Visual Basic
Public Function HasStarted As Boolean
Visual C++
public:
bool HasStarted()

Return Value

True if the transaction group has already started, False otherwise.

Remarks

A transaction group is considered being started after the Start method was called and until the transaction group is either completely committed or rolled back. A transaction group can only be Started when HasStarted returns false.

See Also

TransactionGroup Class


RollBack Method

[image]

Revit 2013 API
TransactionGroup..::..RollBack Method
TransactionGroup Class See Also Send Feedback
Rolls back the transaction group, which effectively undoes all transactions committed inside the group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus RollBack()
Visual Basic
Public Function RollBack As TransactionStatus
Visual C++
public:
TransactionStatus RollBack()

Return Value

If finished successfully, this method returns TransactionStatus.RolledBack.

Remarks

Note that once a group is rolled back, the undone transactions cannot be redone.

RollBack can be called only when all inner transaction groups and transactions are finished, i.e. after they were either committed or rolled back.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Transaction group has not been started (its status is not 'Started').. -or- The transaction's document is currently in failure mode. Transaction groups cannot be closed until failure handling is finished. You may use a transaction finalizer to close a group after the failure handling ends.

See Also

TransactionGroup Class


SetName Method

[image]

Revit 2013 API
TransactionGroup..::..SetName Method
TransactionGroup Class See Also Send Feedback
Sets the transaction group's name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
A name for the transaction group.

Remarks

Transaction group only needs a name if it is going to be assimilated at the end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransactionGroup Class


Start Method

[image] [image]

Revit 2013 API
TransactionGroup..::..Start Method
TransactionGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Start()()()() | Starts the transaction group
Public method | Start(String) | Starts the transaction group with an assigned name.

See Also

TransactionGroup Class
TransactionGroup Members


Start Method

[image]

Revit 2013 API
TransactionGroup..::..Start Method
TransactionGroup Class See Also Send Feedback
Starts the transaction group

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start()
Visual Basic
Public Function Start As TransactionStatus
Visual C++
public:
TransactionStatus Start()

Return Value

If started successfully, this method returns TransactionStatus.Started.

Remarks

A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group. When groups are nested inside each other it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started.

See Also

TransactionGroup Class
Start Overload


Start Method (String)

[image]

Revit 2013 API
TransactionGroup..::..Start Method (String)
TransactionGroup Class See Also Send Feedback
Starts the transaction group with an assigned name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TransactionStatus Start(
    string transGroupName
)
Visual Basic
Public Function Start ( _
    transGroupName As String _
) As TransactionStatus
Visual C++
public:
TransactionStatus Start(
    String^ transGroupName
)

Parameters

transGroupName
Type: System..::..String
Name of the group. The name will be used only for a group that is assimilated at the end.

Return Value

If started successfully, this method returns TransactionStatus.Started.

Remarks

A transaction group can be started only when there is no transaction started currently. It can be started inside another transaction group though. With such group nesting it is required that inner transaction groups are finished (i.e. rolled back, committed, or assimilated) before outer groups are.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot modify the document for either a read-only external command is being executed, or changes to the document are temporarily disabled. -or- Transaction group cannot be started during an active transaction. -or- The Transaction group has already been started.

See Also

TransactionGroup Class
Start Overload


TransactionGroup Properties

[image] [image]

Revit 2013 API
TransactionGroup Properties
TransactionGroup Class See Also Send Feedback

The TransactionGroup type exposes the following members.

Properties

 | Name | Description
Public property | IsFailureHandlingForcedModal | Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.

See Also

TransactionGroup Class


IsFailureHandlingForcedModal Property

[image]

Revit 2013 API
TransactionGroup..::..IsFailureHandlingForcedModal Property
TransactionGroup Class See Also Send Feedback
Forces all transactions finished inside this group to use modal failure handling regardless of what failure handling options are set for those transactions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsFailureHandlingForcedModal { get; set; }
Visual Basic
Public Property IsFailureHandlingForcedModal As Boolean
    Get
    Set
Visual C++
public:
property bool IsFailureHandlingForcedModal {
    bool get ();
    void set (bool value);
}

Remarks

This property is ignored during events, when failure handling is always modal.

See Also

TransactionGroup Class


TransactionStatus Enumeration

[image]

Revit 2013 API
TransactionStatus Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TransactionStatus
Visual Basic
Public Enumeration TransactionStatus
Visual C++
public enum class TransactionStatus

Members

Member name | Description
Uninitialized | initial value, the transaction has not been started yet in this status
Started | transaction has begun (until committed or rolled back)
RolledBack | rolled back (aborted)
Committed | simply committed, ended an empty transaction, flushed all, or undo is disabled
Pending | returned from error handling that took over managing the transaction
Error | error while committing or rolling back
Proceed | while still in error handling (internal status)

See Also


Transform Class

[image]

Revit 2013 API
Transform Class
Members Example See Also Send Feedback
A transformation of the affine 3-space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Transform : APIObject
Visual Basic
Public Class Transform _
    Inherits APIObject
Visual C++
public ref class Transform : public APIObject

Examples

CopyC#
public static XYZ TransformPoint(XYZ point, Transform transform)
{
    double x = point.X;
    double y = point.Y;
    double z = point.Z;

    //transform basis of the old coordinate system in the new coordinate // system
    XYZ b0 = transform.get_Basis(0);
    XYZ b1 = transform.get_Basis(1);
    XYZ b2 = transform.get_Basis(2);
    XYZ origin = transform.Origin;

    //transform the origin of the old coordinate system in the new
    //coordinate system
    double xTemp = x * b0.X + y * b1.X + z * b2.X + origin.X;
    double yTemp = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y;
    double zTemp = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z;

    return new XYZ(xTemp, yTemp, zTemp);
}
CopyVB.NET
Public Shared Function TransformPoint(ByVal point As Autodesk.Revit.DB.XYZ, ByVal transform As Transform) As Autodesk.Revit.DB.XYZ
    Dim x As Double = point.X
    Dim y As Double = point.Y
    Dim z As Double = point.Z

    'transform basis of the old coordinate system in the new coordinate // system
    Dim b0 As Autodesk.Revit.DB.XYZ = transform.Basis(0)
    Dim b1 As Autodesk.Revit.DB.XYZ = transform.Basis(1)
    Dim b2 As Autodesk.Revit.DB.XYZ = transform.Basis(2)
    Dim origin As Autodesk.Revit.DB.XYZ = transform.Origin

    'transform the origin of the old coordinate system in the new
    'coordinate system
    Dim xTemp As Double = x * b0.X + y * b1.X + z * b2.X + origin.X
    Dim yTemp As Double = x * b0.Y + y * b1.Y + z * b2.Y + origin.Y
    Dim zTemp As Double = x * b0.Z + y * b1.Z + z * b2.Z + origin.Z

    Return New Autodesk.Revit.DB.XYZ(xTemp, yTemp, zTemp)
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Transform

See Also

Transform Members


Transform Members

[image] [image]

Revit 2013 API
Transform Members
Transform Class Constructors Methods Operators Properties See Also Send Feedback

The Transform type exposes the following members.

Constructors

 | Name | Description
Public method | Transform | The copy constructor.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
 | Reflection | The transformation that reflects about the specified plane.
 | Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Public property | Scale | The real number that represents the scale of the transformation.
 | Translation | The transformation that translates by the specified vector.

See Also

Transform Class


Transform Constructor

[image]

Revit 2013 API
Transform Constructor
Transform Class See Also Send Feedback
The copy constructor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform(
    Transform source
)
Visual Basic
Public Sub New ( _
    source As Transform _
)
Visual C++
public:
Transform(
    Transform^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..Transform

See Also

Transform Class


Transform Methods

[image] [image]

Revit 2013 API
Transform Methods
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Methods

 | Name | Description
Public method | AlmostEqual | Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Multiply | Multiplies this transformation by the specified transformation and returns the result.
Public method | OfPoint | Applies the transformation to the point and returns the result.
Public method | OfVector | Applies the transform to the vector
Public method | ScaleBasis | Scales the basis vectors of this transformation and returns the result.
Public method | ScaleBasisAndOrigin | Scales the basis vectors and the origin of this transformation and returns the result.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transform Class


AlmostEqual Method

[image]

Revit 2013 API
Transform..::..AlmostEqual Method
Transform Class See Also Send Feedback
Determines whether this transformation and the specified transformation are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AlmostEqual(
    Transform right
)
Visual Basic
Public Function AlmostEqual ( _
    right As Transform _
) As Boolean
Visual C++
public:
bool AlmostEqual(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform
The transformation to compare with this transformation.

Return Value

True if the two transformations are equal; otherwise, false.

Remarks

The tolerance is applied memberwise for comparison.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Multiply Method

[image]

Revit 2013 API
Transform..::..Multiply Method
Transform Class See Also Send Feedback
Multiplies this transformation by the specified transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Multiply(
    Transform right
)
Visual Basic
Public Function Multiply ( _
    right As Transform _
) As Transform
Visual C++
public:
Transform^ Multiply(
    Transform^ right
)

Parameters

right
Type: Autodesk.Revit.DB..::..Transform
The specified transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the specified transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


OfPoint Method

[image]

Revit 2013 API
Transform..::..OfPoint Method
Transform Class See Also Send Feedback
Applies the transformation to the point and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ OfPoint(
    XYZ point
)
Visual Basic
Public Function OfPoint ( _
    point As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfPoint(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
The point to transform.

Return Value

The transformed point.

Remarks

Transformation of a point is affected by the translational part of the transformation.

See Also

Transform Class


OfVector Method

[image]

Revit 2013 API
Transform..::..OfVector Method
Transform Class See Also Send Feedback
Applies the transform to the vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ OfVector(
    XYZ vec
)
Visual Basic
Public Function OfVector ( _
    vec As XYZ _
) As XYZ
Visual C++
public:
XYZ^ OfVector(
    XYZ^ vec
)

Parameters

vec
Type: Autodesk.Revit.DB..::..XYZ
The vector to be transformed

Return Value

The new vector after transform

Remarks

Transformation of a vector is not affected by the translational part of the transformation.

See Also

Transform Class


ScaleBasis Method

[image]

Revit 2013 API
Transform..::..ScaleBasis Method
Transform Class See Also Send Feedback
Scales the basis vectors of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ScaleBasis(
    double scale
)
Visual Basic
Public Function ScaleBasis ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasis(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


ScaleBasisAndOrigin Method

[image]

Revit 2013 API
Transform..::..ScaleBasisAndOrigin Method
Transform Class See Also Send Feedback
Scales the basis vectors and the origin of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform ScaleBasisAndOrigin(
    double scale
)
Visual Basic
Public Function ScaleBasisAndOrigin ( _
    scale As Double _
) As Transform
Visual C++
public:
Transform^ ScaleBasisAndOrigin(
    double scale
)

Parameters

scale
Type: System..::..Double
The scale value.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The resulting transformation is equivalent to the application of this transformation and then the uniform scale, in this order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

Transform Class


Transform Operators

[image] [image]

Revit 2013 API
Transform Operators
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Operators

Name | Description
Multiply | Multiplies the two specified transforms.

See Also

Transform Class


Multiply Operator

[image]

Revit 2013 API
Transform..::..Multiply Operator
Transform Class See Also Send Feedback
Multiplies the two specified transforms.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform operator *(
    Transform left,
    Transform right
)
Visual Basic
Public Shared Operator * ( _
    left As Transform, _
    right As Transform _
) As Transform
Visual C++
public:
static Transform^ operator *(
    Transform^ left,
    Transform^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..Transform
The first transformation.
right
Type: Autodesk.Revit.DB..::..Transform
The second transformation.

Return Value

The transformation equal to the composition of the two transformations.

Remarks

The combined transformation has the same effect as applying the right transformation first, and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the first or second transformation is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Transform Properties

[image] [image]

Revit 2013 API
Transform Properties
Transform Class See Also Send Feedback

The Transform type exposes the following members.

Properties

 | Name | Description
Public property | Basis | Defines the basis of the old coordinate system in the new coordinate system.
Public property | BasisX | The basis of the X axis of this transformation.
Public property | BasisY | The basis of the Y axis of this transformation.
Public property | BasisZ | The basis of the Z axis of this transformation.
Public property | Determinant | The determinant of this transformation.
Public property | HasReflection | The boolean value that indicates whether this transformation produces reflection.
 | Identity | The identity transformation.
Public property | Inverse | The inverse transformation of this transformation.
Public property | IsConformal | The boolean value that indicates whether this transformation is conformal.
Public property | IsIdentity | The boolean value that indicates whether this transformation is an identity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | IsTranslation | The boolean value that indicates whether this transformation is a translation.
Public property | Origin | Defines the origin of the old coordinate system in the new coordinate system.
 | Reflection | The transformation that reflects about the specified plane.
 | Rotation | The transformation that rotates by the specified angle about the specified axis and point.
Public property | Scale | The real number that represents the scale of the transformation.
 | Translation | The transformation that translates by the specified vector.

See Also

Transform Class


Basis Property

[image]

Revit 2013 API
Transform..::..Basis Property
Transform Class See Also Send Feedback
Defines the basis of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int idx
] { get; set; }
Visual Basic
Public Property Basis ( _
    idx As Integer _
) As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Basis[int idx] {
    XYZ^ get (int idx);
    void set (int idx, XYZ^ value);
}

Parameters

idx
Type: System..::..Int32
The index of the basis vector: 0, 1 or 2.

Remarks

This corresponds to the first three column vectors of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the given index is larger than 2 in the getter and setter.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisX Property

[image]

Revit 2013 API
Transform..::..BasisX Property
Transform Class See Also Send Feedback
The basis of the X axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ BasisX { get; set; }
Visual Basic
Public Property BasisX As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisX {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The X axis of the old coordinate system in the new coordinate system, or the 1st column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisY Property

[image]

Revit 2013 API
Transform..::..BasisY Property
Transform Class See Also Send Feedback
The basis of the Y axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ BasisY { get; set; }
Visual Basic
Public Property BasisY As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisY {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Y axis of the old coordinate system in the new coordinate system, or the 2nd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


BasisZ Property

[image]

Revit 2013 API
Transform..::..BasisZ Property
Transform Class See Also Send Feedback
The basis of the Z axis of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ BasisZ { get; set; }
Visual Basic
Public Property BasisZ As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ BasisZ {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The Z axis of the old coordinate system in the new coordinate system, or the 3rd column of the conventional 3x4 matrix representation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Determinant Property

[image]

Revit 2013 API
Transform..::..Determinant Property
Transform Class See Also Send Feedback
The determinant of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Determinant { get; }
Visual Basic
Public ReadOnly Property Determinant As Double
    Get
Visual C++
public:
property double Determinant {
    double get ();
}

Remarks

The geometric meaning of a determinant is as the scale factor for volume when applied as linear transformation.

See Also

Transform Class


HasReflection Property

[image]

Revit 2013 API
Transform..::..HasReflection Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation produces reflection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HasReflection { get; }
Visual Basic
Public ReadOnly Property HasReflection As Boolean
    Get
Visual C++
public:
property bool HasReflection {
    bool get ();
}

Remarks

Reflection transformation changes the handedness of a coordinate system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this transformation is not conformal and the reflection is undefined.

See Also

Transform Class


Identity Property

[image]

Revit 2013 API
Transform..::..Identity Property
Transform Class See Also Send Feedback
The identity transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform Identity { get; }
Visual Basic
Public Shared ReadOnly Property Identity As Transform
    Get
Visual C++
public:
static property Transform^ Identity {
    Transform^ get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


Inverse Property

[image]

Revit 2013 API
Transform..::..Inverse Property
Transform Class See Also Send Feedback
The inverse transformation of this transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Transform Inverse { get; }
Visual Basic
Public ReadOnly Property Inverse As Transform
    Get
Visual C++
public:
property Transform^ Inverse {
    Transform^ get ();
}

Remarks

The transformation matrix A is invertible if there exists a transformation matrix B such that A*B = B*A = I (identity).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this transformation is not conformal or invertible.

See Also

Transform Class


IsConformal Property

[image]

Revit 2013 API
Transform..::..IsConformal Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is conformal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsConformal { get; }
Visual Basic
Public ReadOnly Property IsConformal As Boolean
    Get
Visual C++
public:
property bool IsConformal {
    bool get ();
}

Remarks

This property is true if this transformation can be decomposed as the product of a rigid-body motion, uniform scale and reflection. Such transformation preserves angles between vectors.

See Also

Transform Class


IsIdentity Property

[image]

Revit 2013 API
Transform..::..IsIdentity Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is an identity.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsIdentity { get; }
Visual Basic
Public ReadOnly Property IsIdentity As Boolean
    Get
Visual C++
public:
property bool IsIdentity {
    bool get ();
}

Remarks

The identity transformation does not change a point or a vector that it is applied to.

See Also

Transform Class


IsTranslation Property

[image]

Revit 2013 API
Transform..::..IsTranslation Property
Transform Class See Also Send Feedback
The boolean value that indicates whether this transformation is a translation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsTranslation { get; }
Visual Basic
Public ReadOnly Property IsTranslation As Boolean
    Get
Visual C++
public:
property bool IsTranslation {
    bool get ();
}

Remarks

This property is true if the only effect of transformation is translation. It checks that the basis of the transform is identity. The translation vector may be zero (which would make this an identity transformation) or nonzero (which would make this a non-trivial translation).

See Also

Transform Class


Origin Property

[image]

Revit 2013 API
Transform..::..Origin Property
Transform Class See Also Send Feedback
Defines the origin of the old coordinate system in the new coordinate system.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

This corresponds to the fourth column vector of the conventional 3x4 matrix representation. Also, this is the translation component of the transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the transform is internally marked as read-only.

See Also

Transform Class


Reflection Property

[image]

Revit 2013 API
Transform..::..Reflection Property
Transform Class Example See Also Send Feedback
The transformation that reflects about the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform this[
    Plane plane
] { get; }
Visual Basic
Public Shared ReadOnly Property Reflection ( _
    plane As Plane _
) As Transform
    Get
Visual C++
public:
static property Transform^ Reflection[Plane^ plane] {
    Transform^ get (Plane^ plane);
}

Parameters

plane
Type: Autodesk.Revit.DB..::..Plane
The plane to reflect about.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.get_Reflection(refPlane.Plane);

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(ByVal refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.Reflection(refPlane.Plane)

    Return mirTrans
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the handle of the plane is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

Transform Class


Rotation Property

[image]

Revit 2013 API
Transform..::..Rotation Property
Transform Class See Also Send Feedback
The transformation that rotates by the specified angle about the specified axis and point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform this[
    XYZ origin,
    XYZ axis,
    double angle
] { get; }
Visual Basic
Public Shared ReadOnly Property Rotation ( _
    origin As XYZ, _
    axis As XYZ, _
    angle As Double _
) As Transform
    Get
Visual C++
public:
static property Transform^ Rotation[XYZ^ origin, XYZ^ axis, double angle] {
    Transform^ get (XYZ^ origin, XYZ^ axis, double angle);
}

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
The point to rotate about.
axis
Type: Autodesk.Revit.DB..::..XYZ
The axis vector to rotate about.
angle
Type: System..::..Double
The rotation angle in radians.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified values fail to define the transformation.

See Also

Transform Class


Scale Property

[image]

Revit 2013 API
Transform..::..Scale Property
Transform Class See Also Send Feedback
The real number that represents the scale of the transformation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Scale { get; }
Visual Basic
Public ReadOnly Property Scale As Double
    Get
Visual C++
public:
property double Scale {
    double get ();
}

Remarks

When the transformation is conformal and can be decomposed as the product of a rigid-body motion, uniform scale and reflection, this property returns the scale value of the uniform scale transformation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this transformation is not conformal and the scale is undefined.

See Also

Transform Class


Translation Property

[image]

Revit 2013 API
Transform..::..Translation Property
Transform Class See Also Send Feedback
The transformation that translates by the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Transform this[
    XYZ vec
] { get; }
Visual Basic
Public Shared ReadOnly Property Translation ( _
    vec As XYZ _
) As Transform
    Get
Visual C++
public:
static property Transform^ Translation[XYZ^ vec] {
    Transform^ get (XYZ^ vec);
}

Parameters

vec
Type: Autodesk.Revit.DB..::..XYZ
The translation vector.

See Also

Transform Class


TransmissionData Class

[image]

Revit 2013 API
TransmissionData Class
Members Example See Also Send Feedback
A class representing information on all external file references in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class TransmissionData : IDisposable
Visual Basic
Public Class TransmissionData _
    Implements IDisposable
Visual C++
public ref class TransmissionData : IDisposable

Remarks

TransmissionData stores information on both the previous state and requested state of an external file reference. This means that it stores the load state and path of the reference from the most recent time this TransmissionData's document was opened. It also stores load state and path information for what Revit should do the next time the document is opened.

As such, TransmissionData can be used to perform operations on external file references without having to open the entire associated Revit document. The methods ReadTransmissionData and WriteTransmissionData can be used to obtain information about external references, or to change that information. For example, calling WriteTransmissionData with a TransmissionData object which has had all references set to LinkedFileStatus.Unloaded would cause no references to be loaded upon next opening the document.

TransmissionData cannot add or remove references to external files. If AddExternalFileReference is called using an ElementId which does not correspond to an element which is an external file reference, the information will be ignored on file load.

Note that TransmissionData objects must be set to "transmitted" for the requested reference data to be meaningful. Revit ignores the TransmissionData for non-transmitted files. Marking a file as transmitted has other effects - workshared files are opened as detached from the central model, and creation of new local files is prohibited, until the file is in its final location and the file has been marked as no longer transmitted.

Examples

CopyC#
    void UnloadRevitLinks(ModelPath location)
///  This method will set all Revit links to be unloaded the next time the document at the given location is opened.
///  The TransmissionData for a given document only contains top-level Revit links, not nested links.
///  However, nested links will be unloaded if their parent links are unloaded, so this function only needs to look at the document's immediate links.
    {
       // access transmission data in the given Revit file
       TransmissionData transData = TransmissionData.ReadTransmissionData(location);

       if (transData != null)
       {
          // collect all (immediate) external references in the model
          ICollection<ElementId> externalReferences = transData.GetAllExternalFileReferenceIds();

          // find every reference that is a link
          foreach (ElementId refId in externalReferences)
          {
             ExternalFileReference extRef = transData.GetLastSavedReferenceData(refId);

             if (extRef.ExternalFileReferenceType == ExternalFileReferenceType.RevitLink)
             {
                // we do not want to change neither the path nor the path-type
                // we only want the links to be unloaded (shouldLoad = false)
                transData.SetDesiredReferenceData(refId, extRef.GetPath(), extRef.PathType, false);
             }
          }

          // make sure the IsTransmitted property is set
          transData.IsTransmitted = true;

          // modified transmission data must be saved back to the model
          TransmissionData.WriteTransmissionData(location, transData);
       }
       else
       {
          Autodesk.Revit.UI.TaskDialog.Show("Unload Links", "The document does not have any transmission data");
       }
    }

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TransmissionData

See Also

TransmissionData Members


TransmissionData Members

[image] [image]

Revit 2013 API
TransmissionData Members
TransmissionData Class Constructors Methods Properties See Also Send Feedback

The TransmissionData type exposes the following members.

Constructors

 | Name | Description
Public method | TransmissionData | Constructs a TransmissionData from another TransmissionData

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TransmissionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

Properties

 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData

See Also

TransmissionData Class


TransmissionData Constructor

[image]

Revit 2013 API
TransmissionData Constructor
TransmissionData Class See Also Send Feedback
Constructs a TransmissionData from another TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public TransmissionData(
    TransmissionData other
)
Visual Basic
Public Sub New ( _
    other As TransmissionData _
)
Visual C++
public:
TransmissionData(
    TransmissionData^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TransmissionData

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class


TransmissionData Methods

[image] [image]

Revit 2013 API
TransmissionData Methods
TransmissionData Class See Also Send Feedback

The TransmissionData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllExternalFileReferenceIds | Gets the ids of all ExternalFileReferences.
Public method | GetDesiredReferenceData | Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLastSavedReferenceData | Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsDocumentTransmitted | Determines whether the document at a given file location is transmitted.
 | ReadTransmissionData | Reads the TransmissionData associated with the file at the given location.
Public method | SetDesiredReferenceData | Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteTransmissionData | Writes the given TransmissionData into the Revit file at the given location.

See Also

TransmissionData Class


Dispose Method

[image]

Revit 2013 API
TransmissionData..::..Dispose Method
TransmissionData Class See Also Send Feedback
Releases all resources used by the TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TransmissionData Class


GetAllExternalFileReferenceIds Method

[image]

Revit 2013 API
TransmissionData..::..GetAllExternalFileReferenceIds Method
TransmissionData Class See Also Send Feedback
Gets the ids of all ExternalFileReferences.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetAllExternalFileReferenceIds()
Visual Basic
Public Function GetAllExternalFileReferenceIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllExternalFileReferenceIds()

Return Value

The ids of all ExternalFileReferences.

See Also

TransmissionData Class


GetDesiredReferenceData Method

[image]

Revit 2013 API
TransmissionData..::..GetDesiredReferenceData Method
TransmissionData Class See Also Send Feedback
Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReference GetDesiredReferenceData(
    ElementId elemId
)
Visual Basic
Public Function GetDesiredReferenceData ( _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
ExternalFileReference^ GetDesiredReferenceData(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

An ExternalFileReference containing the requested path and load status information for an external file

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class


GetLastSavedReferenceData Method

[image]

Revit 2013 API
TransmissionData..::..GetLastSavedReferenceData Method
TransmissionData Class See Also Send Feedback
Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ExternalFileReference GetLastSavedReferenceData(
    ElementId elemId
)
Visual Basic
Public Function GetLastSavedReferenceData ( _
    elemId As ElementId _
) As ExternalFileReference
Visual C++
public:
ExternalFileReference^ GetLastSavedReferenceData(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

An ExternalFileReference containing the previous path and load status information for an external file

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class


IsDocumentTransmitted Method

[image]

Revit 2013 API
TransmissionData..::..IsDocumentTransmitted Method
TransmissionData Class See Also Send Feedback
Determines whether the document at a given file location is transmitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsDocumentTransmitted(
    ModelPath filePath
)
Visual Basic
Public Shared Function IsDocumentTransmitted ( _
    filePath As ModelPath _
) As Boolean
Visual C++
public:
static bool IsDocumentTransmitted(
    ModelPath^ filePath
)

Parameters

filePath
Type: Autodesk.Revit.DB..::..ModelPath
The path to the document whose transmitted state will be checked.

Return Value

True if the document is a transmitted file, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class


ReadTransmissionData Method

[image]

Revit 2013 API
TransmissionData..::..ReadTransmissionData Method
TransmissionData Class See Also Send Feedback
Reads the TransmissionData associated with the file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static TransmissionData ReadTransmissionData(
    ModelPath path
)
Visual Basic
Public Shared Function ReadTransmissionData ( _
    path As ModelPath _
) As TransmissionData
Visual C++
public:
static TransmissionData^ ReadTransmissionData(
    ModelPath^ path
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should read the TransmissionData of. If this ModelPath is a file path, it must be an absolute path.

Return Value

The TransmissionData containing external file information for the file at the given location.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException | There is a network communication error happening.
Autodesk.Revit.Exceptions..::..RevitServerInternalException | There is a server internal error happening.
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException | The server-based model is being accessed by other users.

See Also

TransmissionData Class


SetDesiredReferenceData Method

[image]

Revit 2013 API
TransmissionData..::..SetDesiredReferenceData Method
TransmissionData Class See Also Send Feedback
Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetDesiredReferenceData(
    ElementId elemId,
    ModelPath path,
    PathType pathType,
    bool shouldLoad
)
Visual Basic
Public Sub SetDesiredReferenceData ( _
    elemId As ElementId, _
    path As ModelPath, _
    pathType As PathType, _
    shouldLoad As Boolean _
)
Visual C++
public:
void SetDesiredReferenceData(
    ElementId^ elemId,
    ModelPath^ path,
    PathType pathType,
    bool shouldLoad
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element associated with this reference.
path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the location to load the external file reference from.
pathType
Type: Autodesk.Revit.DB..::..PathType
A PathType value indicating what type of path the ModelPath is.
shouldLoad
Type: System..::..Boolean
True if the external file should be loaded the next time Revit opens the document. False if it should be unloaded.

Remarks

There must already be a reference associated with the given id for this function to be valid. Create a reference using AddExternalFileReference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elemId does not correspond to an ExternalFileReference contained in this TransmissionData. -or- These inputs will not produce a valid ExternalFileReference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TransmissionData Class


WriteTransmissionData Method

[image]

Revit 2013 API
TransmissionData..::..WriteTransmissionData Method
TransmissionData Class See Also Send Feedback
Writes the given TransmissionData into the Revit file at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void WriteTransmissionData(
    ModelPath path,
    TransmissionData data
)
Visual Basic
Public Shared Sub WriteTransmissionData ( _
    path As ModelPath, _
    data As TransmissionData _
)
Visual C++
public:
static void WriteTransmissionData(
    ModelPath^ path,
    TransmissionData^ data
)

Parameters

path
Type: Autodesk.Revit.DB..::..ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
data
Type: Autodesk.Revit.DB..::..TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.

Remarks

This function will overwrite the existing TransmissionData in the file. This function will not support models on Revit server. This must be called on a closed document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | There is not a valid Revit file at path's location
Autodesk.Revit.Exceptions..::..InvalidOperationException | Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document.

See Also

TransmissionData Class


TransmissionData Properties

[image] [image]

Revit 2013 API
TransmissionData Properties
TransmissionData Class See Also Send Feedback

The TransmissionData type exposes the following members.

Properties

 | Name | Description
Public property | IsTransmitted | Determines whether this file has been transmitted or not.
Public property | UserData | A string which users can store notes in.
Public property | Version | The format version for TransmissionData

See Also

TransmissionData Class


IsTransmitted Property

[image]

Revit 2013 API
TransmissionData..::..IsTransmitted Property
TransmissionData Class See Also Send Feedback
Determines whether this file has been transmitted or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsTransmitted { get; set; }
Visual Basic
Public Property IsTransmitted As Boolean
    Get
    Set
Visual C++
public:
property bool IsTransmitted {
    bool get ();
    void set (bool value);
}

Remarks

"Transmitted" files have been moved from one place to another and are considered to be in a not-final state. Revit will read the TransmissionData on file open and overwrite any data stored in the external file reference elements themselves.

See Also

TransmissionData Class


UserData Property

[image]

Revit 2013 API
TransmissionData..::..UserData Property
TransmissionData Class See Also Send Feedback
A string which users can store notes in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string UserData { get; set; }
Visual Basic
Public Property UserData As String
    Get
    Set
Visual C++
public:
property String^ UserData {
    String^ get ();
    void set (String^ value);
}

Remarks

Revit merely stores this data; it is never used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

TransmissionData Class


Version Property

[image]

Revit 2013 API
TransmissionData..::..Version Property
TransmissionData Class See Also Send Feedback
The format version for TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Version { get; }
Visual Basic
Public ReadOnly Property Version As Integer
    Get
Visual C++
public:
property int Version {
    int get ();
}

See Also

TransmissionData Class


TransmittedModelOptions Enumeration

[image]

Revit 2013 API
TransmittedModelOptions Enumeration
See Also Send Feedback
Enum giving desired behavior when opening or saving a transmitted workshared model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum TransmittedModelOptions
Visual Basic
Public Enumeration TransmittedModelOptions
Visual C++
public enum class TransmittedModelOptions

Members

Member name | Description
SaveAsNewCentral | The model should be saved as a new central. (On open, it will be saved as a new central in its current location. On save, it will be saved as central but the user can choose a location.)
KeepAsTransmitted | The model will remain marked as transmitted; users will not be able to create locals until it is saved as a new central.
CancelOperation | Cancel the save or load operation.

See Also


TriangleInShellComponent Class

[image]

Revit 2013 API
TriangleInShellComponent Class
Members See Also Send Feedback
This class represents a triangle in a TriangulatedShellComponent object. The triangle is defined by its vertices, which are specified by their indices in the TriangulatedShellComponent’s array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriangleInShellComponent : IDisposable
Visual Basic
Public Class TriangleInShellComponent _
    Implements IDisposable
Visual C++
public ref class TriangleInShellComponent : IDisposable

Remarks

A TriangulatedShellComponent stores an array of TriangleInShellComponent objects representing the triangles of the triangulation. An external class is used because the API does not allow the use of a triple of integers. Note that a TriangleInShellComponent must only be used in the context of a single, fixed TriangulatedShellComponent.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangleInShellComponent

See Also

TriangleInShellComponent Members


TriangleInShellComponent Members

[image] [image]

Revit 2013 API
TriangleInShellComponent Members
TriangleInShellComponent Class Constructors Methods Properties See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangleInShellComponent | Creates a copy of the given TriangleInShellComponent

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangleInShellComponent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | VertexIndex0 | Index of the triangle’s first vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex1 | Index of the triangle’s second vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex2 | Index of the triangle’s third vertex in the TriangulatedShellComponent’s array of vertices.

See Also

TriangleInShellComponent Class


TriangleInShellComponent Constructor

[image]

Revit 2013 API
TriangleInShellComponent Constructor
TriangleInShellComponent Class See Also Send Feedback
Creates a copy of the given TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TriangleInShellComponent(
    TriangleInShellComponent other
)
Visual Basic
Public Sub New ( _
    other As TriangleInShellComponent _
)
Visual C++
public:
TriangleInShellComponent(
    TriangleInShellComponent^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..TriangleInShellComponent

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TriangleInShellComponent Class


TriangleInShellComponent Methods

[image] [image]

Revit 2013 API
TriangleInShellComponent Methods
TriangleInShellComponent Class See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangleInShellComponent Class


Dispose Method

[image]

Revit 2013 API
TriangleInShellComponent..::..Dispose Method
TriangleInShellComponent Class See Also Send Feedback
Releases all resources used by the TriangleInShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangleInShellComponent Class


TriangleInShellComponent Properties

[image] [image]

Revit 2013 API
TriangleInShellComponent Properties
TriangleInShellComponent Class See Also Send Feedback

The TriangleInShellComponent type exposes the following members.

Properties

 | Name | Description
Public property | VertexIndex0 | Index of the triangle’s first vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex1 | Index of the triangle’s second vertex in the TriangulatedShellComponent’s array of vertices.
Public property | VertexIndex2 | Index of the triangle’s third vertex in the TriangulatedShellComponent’s array of vertices.

See Also

TriangleInShellComponent Class


VertexIndex0 Property

[image]

Revit 2013 API
TriangleInShellComponent..::..VertexIndex0 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle’s first vertex in the TriangulatedShellComponent’s array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int VertexIndex0 { get; }
Visual Basic
Public ReadOnly Property VertexIndex0 As Integer
    Get
Visual C++
public:
property int VertexIndex0 {
    int get ();
}

See Also

TriangleInShellComponent Class


VertexIndex1 Property

[image]

Revit 2013 API
TriangleInShellComponent..::..VertexIndex1 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle’s second vertex in the TriangulatedShellComponent’s array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int VertexIndex1 { get; }
Visual Basic
Public ReadOnly Property VertexIndex1 As Integer
    Get
Visual C++
public:
property int VertexIndex1 {
    int get ();
}

See Also

TriangleInShellComponent Class


VertexIndex2 Property

[image]

Revit 2013 API
TriangleInShellComponent..::..VertexIndex2 Property
TriangleInShellComponent Class See Also Send Feedback
Index of the triangle’s third vertex in the TriangulatedShellComponent’s array of vertices.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int VertexIndex2 { get; }
Visual Basic
Public ReadOnly Property VertexIndex2 As Integer
    Get
Visual C++
public:
property int VertexIndex2 {
    int get ();
}

See Also

TriangleInShellComponent Class


TriangulatedShellComponent Class

[image]

Revit 2013 API
TriangulatedShellComponent Class
Members See Also Send Feedback
This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriangulatedShellComponent : IDisposable
Visual Basic
Public Class TriangulatedShellComponent _
    Implements IDisposable
Visual C++
public ref class TriangulatedShellComponent : IDisposable

Remarks

The triangulation is “topologically connected” in the following sense: if two triangles share an edge geometrically, then they share a single edge topologically (i.e., they share two vertices defining the geometrically shared edge).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulatedShellComponent

See Also

TriangulatedShellComponent Members


TriangulatedShellComponent Members

[image] [image]

Revit 2013 API
TriangulatedShellComponent Members
TriangulatedShellComponent Class Methods Properties See Also Send Feedback

The TriangulatedShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose | Releases all resources used by the TriangulatedShellComponent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Returns the vertex with a given index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property | TriangleCount | The number of triangles in the triangulation.
Public property | VertexCount | The number of vertices in the triangulation.

See Also

TriangulatedShellComponent Class


TriangulatedShellComponent Methods

[image] [image]

Revit 2013 API
TriangulatedShellComponent Methods
TriangulatedShellComponent Class See Also Send Feedback

The TriangulatedShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Empties the contents of this TriangulatedShellComponent.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTriangle | Returns the triangle corresponding to the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Returns the vertex with a given index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulatedShellComponent Class


Clear Method

[image]

Revit 2013 API
TriangulatedShellComponent..::..Clear Method
TriangulatedShellComponent Class See Also Send Feedback
Empties the contents of this TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

TriangulatedShellComponent Class


Dispose Method

[image]

Revit 2013 API
TriangulatedShellComponent..::..Dispose Method
TriangulatedShellComponent Class See Also Send Feedback
Releases all resources used by the TriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulatedShellComponent Class


GetTriangle Method

[image]

Revit 2013 API
TriangulatedShellComponent..::..GetTriangle Method
TriangulatedShellComponent Class See Also Send Feedback
Returns the triangle corresponding to the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TriangleInShellComponent GetTriangle(
    int triangleIndex
)
Visual Basic
Public Function GetTriangle ( _
    triangleIndex As Integer _
) As TriangleInShellComponent
Visual C++
public:
TriangleInShellComponent^ GetTriangle(
    int triangleIndex
)

Parameters

triangleIndex
Type: System..::..Int32
The index of the triangle (between 0 and TriangleCount-1, inclusive).

Return Value

The triangle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | triangleIndex is out of range.

See Also

TriangulatedShellComponent Class


GetVertex Method

[image]

Revit 2013 API
TriangulatedShellComponent..::..GetVertex Method
TriangulatedShellComponent Class See Also Send Feedback
Returns the vertex with a given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ GetVertex(
    int vertexIndex
)
Visual Basic
Public Function GetVertex ( _
    vertexIndex As Integer _
) As XYZ
Visual C++
public:
XYZ^ GetVertex(
    int vertexIndex
)

Parameters

vertexIndex
Type: System..::..Int32
The index of the vertex (between 0 and getVertexCount()-1, inclusive).

Return Value

A copy of the requested vertex.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is out of range.

See Also

TriangulatedShellComponent Class


TriangulatedShellComponent Properties

[image] [image]

Revit 2013 API
TriangulatedShellComponent Properties
TriangulatedShellComponent Class See Also Send Feedback

The TriangulatedShellComponent type exposes the following members.

Properties

 | Name | Description
Public property | IsClosed | True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property | TriangleCount | The number of triangles in the triangulation.
Public property | VertexCount | The number of vertices in the triangulation.

See Also

TriangulatedShellComponent Class


IsClosed Property

[image]

Revit 2013 API
TriangulatedShellComponent..::..IsClosed Property
TriangulatedShellComponent Class See Also Send Feedback
True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsClosed { get; }
Visual Basic
Public ReadOnly Property IsClosed As Boolean
    Get
Visual C++
public:
property bool IsClosed {
    bool get ();
}

See Also

TriangulatedShellComponent Class


TriangleCount Property

[image]

Revit 2013 API
TriangulatedShellComponent..::..TriangleCount Property
TriangulatedShellComponent Class See Also Send Feedback
The number of triangles in the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int TriangleCount { get; }
Visual Basic
Public ReadOnly Property TriangleCount As Integer
    Get
Visual C++
public:
property int TriangleCount {
    int get ();
}

See Also

TriangulatedShellComponent Class


VertexCount Property

[image]

Revit 2013 API
TriangulatedShellComponent..::..VertexCount Property
TriangulatedShellComponent Class See Also Send Feedback
The number of vertices in the triangulation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int VertexCount { get; }
Visual Basic
Public ReadOnly Property VertexCount As Integer
    Get
Visual C++
public:
property int VertexCount {
    int get ();
}

See Also

TriangulatedShellComponent Class


TriangulatedSolidOrShell Class

[image]

Revit 2013 API
TriangulatedSolidOrShell Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TriangulatedSolidOrShell : IDisposable
Visual Basic
Public Class TriangulatedSolidOrShell _
    Implements IDisposable
Visual C++
public ref class TriangulatedSolidOrShell : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulatedSolidOrShell

See Also

TriangulatedSolidOrShell Members


TriangulatedSolidOrShell Members

[image] [image]

Revit 2013 API
TriangulatedSolidOrShell Members
TriangulatedSolidOrShell Class Methods Properties See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulatedSolidOrShell
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

See Also

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell Methods

[image] [image]

Revit 2013 API
TriangulatedSolidOrShell Methods
TriangulatedSolidOrShell Class See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShellComponent | Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulatedSolidOrShell Class


Dispose Method

[image]

Revit 2013 API
TriangulatedSolidOrShell..::..Dispose Method
TriangulatedSolidOrShell Class See Also Send Feedback
Releases all resources used by the TriangulatedSolidOrShell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulatedSolidOrShell Class


GetShellComponent Method

[image]

Revit 2013 API
TriangulatedSolidOrShell..::..GetShellComponent Method
TriangulatedSolidOrShell Class See Also Send Feedback
Returns the specified shell component of a solid or shell. Input componentIndex must lie between 0 and ShellComponentCount-1, inclusive. The returned TriangulatedShellComponent should not be modified by the caller.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TriangulatedShellComponent GetShellComponent(
    int componentIndex
)
Visual Basic
Public Function GetShellComponent ( _
    componentIndex As Integer _
) As TriangulatedShellComponent
Visual C++
public:
TriangulatedShellComponent^ GetShellComponent(
    int componentIndex
)

Parameters

componentIndex
Type: System..::..Int32
The component index, must be between 0 and ShellComponentCount – 1, inclusive.

Return Value

The component.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Shell component index componentIndex is out of range.

See Also

TriangulatedSolidOrShell Class


TriangulatedSolidOrShell Properties

[image] [image]

Revit 2013 API
TriangulatedSolidOrShell Properties
TriangulatedSolidOrShell Class See Also Send Feedback

The TriangulatedSolidOrShell type exposes the following members.

Properties

 | Name | Description
Public property | ShellComponentCount | The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

See Also

TriangulatedSolidOrShell Class


ShellComponentCount Property

[image]

Revit 2013 API
TriangulatedSolidOrShell..::..ShellComponentCount Property
TriangulatedSolidOrShell Class See Also Send Feedback
The number of TriangulatedShellComponents that this TriangulatedSolidOrShell contains.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ShellComponentCount { get; }
Visual Basic
Public ReadOnly Property ShellComponentCount As Integer
    Get
Visual C++
public:
property int ShellComponentCount {
    int get ();
}

See Also

TriangulatedSolidOrShell Class


TriangulationInterface Class

[image]

Revit 2013 API
TriangulationInterface Class
Members See Also Send Feedback
This abstract class provides an interface for querying a triangulation structure (vertices and triangles).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriangulationInterface : IDisposable
Visual Basic
Public Class TriangulationInterface _
    Implements IDisposable
Visual C++
public ref class TriangulationInterface : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedSolidOrShell

See Also

TriangulationInterface Members


TriangulationInterface Members

[image] [image]

Revit 2013 API
TriangulationInterface Members
TriangulationInterface Class Methods See Also Send Feedback

The TriangulationInterface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriangulationInterface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterface Class


TriangulationInterface Methods

[image] [image]

Revit 2013 API
TriangulationInterface Methods
TriangulationInterface Class See Also Send Feedback

The TriangulationInterface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterface Class


Dispose Method

[image]

Revit 2013 API
TriangulationInterface..::..Dispose Method
TriangulationInterface Class See Also Send Feedback
Releases all resources used by the TriangulationInterface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriangulationInterface Class


TriangulationInterfaceForTriangulatedShellComponent Class

[image]

Revit 2013 API
TriangulationInterfaceForTriangulatedShellComponent Class
Members See Also Send Feedback
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriangulationInterfaceForTriangulatedShellComponent : TriangulationInterface
Visual Basic
Public Class TriangulationInterfaceForTriangulatedShellComponent _
    Inherits TriangulationInterface
Visual C++
public ref class TriangulationInterfaceForTriangulatedShellComponent : public TriangulationInterface

Remarks

Compare to TriangulationInterfaceForTriangulatedSolidOrShell, which treats with the entire solid or shell as a single triangulated structure.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedShellComponent

See Also

TriangulationInterfaceForTriangulatedShellComponent Members


TriangulationInterfaceForTriangulatedShellComponent Members

[image] [image]

Revit 2013 API
TriangulationInterfaceForTriangulatedShellComponent Members
TriangulationInterfaceForTriangulatedShellComponent Class Constructors Methods See Also Send Feedback

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Constructors

 | Name | Description
Public method | TriangulationInterfaceForTriangulatedShellComponent | Constructs an interface object for a TriangulatedShellComponent.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Constructor

[image]

Revit 2013 API
TriangulationInterfaceForTriangulatedShellComponent Constructor
TriangulationInterfaceForTriangulatedShellComponent Class See Also Send Feedback
Constructs an interface object for a TriangulatedShellComponent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent externalTriangulatedShellComponent
)
Visual Basic
Public Sub New ( _
    externalTriangulatedShellComponent As TriangulatedShellComponent _
)
Visual C++
public:
TriangulationInterfaceForTriangulatedShellComponent(
    TriangulatedShellComponent^ externalTriangulatedShellComponent
)

Parameters

externalTriangulatedShellComponent
Type: Autodesk.Revit.DB..::..TriangulatedShellComponent
The TriangulatedShellComponent that the interface object represents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedShellComponent Methods

[image] [image]

Revit 2013 API
TriangulationInterfaceForTriangulatedShellComponent Methods
TriangulationInterfaceForTriangulatedShellComponent Class See Also Send Feedback

The TriangulationInterfaceForTriangulatedShellComponent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterfaceForTriangulatedShellComponent Class


TriangulationInterfaceForTriangulatedSolidOrShell Class

[image]

Revit 2013 API
TriangulationInterfaceForTriangulatedSolidOrShell Class
Members See Also Send Feedback
This class is used to call FacetingUtils::convertTrianglesToQuads with a triangulation defined by a TriangulatedSolidOrShell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriangulationInterfaceForTriangulatedSolidOrShell : TriangulationInterface
Visual Basic
Public Class TriangulationInterfaceForTriangulatedSolidOrShell _
    Inherits TriangulationInterface
Visual C++
public ref class TriangulationInterfaceForTriangulatedSolidOrShell : public TriangulationInterface

Remarks

The vertex and triangle indices used by this class treat the triangulated solid or shell as if all the vertices and triangles of the different shell components were collected into single sets of vertices and triangles, respectively. For example, if a solid has two shell components and the first has ten vertices while the second has five vertices, vertexIndex 6 refers to vertex[6] of the first shell component, and vertexIndex 12 refers to vertex[2] of the second shell component. You can use the class TriangulationInterfaceForTriangulatedShellComponent to get a faceting of an individual shell component.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriangulationInterface
Autodesk.Revit.DB..::..TriangulationInterfaceForTriangulatedSolidOrShell

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Members


TriangulationInterfaceForTriangulatedSolidOrShell Members

[image] [image]

Revit 2013 API
TriangulationInterfaceForTriangulatedSolidOrShell Members
TriangulationInterfaceForTriangulatedSolidOrShell Class Constructors Methods See Also Send Feedback

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Constructors

 | Name | Description
Public method | TriangulationInterfaceForTriangulatedSolidOrShell | Construct an interface object for a TriangulatedSolidOrShell.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Constructor

[image]

Revit 2013 API
TriangulationInterfaceForTriangulatedSolidOrShell Constructor
TriangulationInterfaceForTriangulatedSolidOrShell Class See Also Send Feedback
Construct an interface object for a TriangulatedSolidOrShell.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell externalTriangulatedSolidOrShell
)
Visual Basic
Public Sub New ( _
    externalTriangulatedSolidOrShell As TriangulatedSolidOrShell _
)
Visual C++
public:
TriangulationInterfaceForTriangulatedSolidOrShell(
    TriangulatedSolidOrShell^ externalTriangulatedSolidOrShell
)

Parameters

externalTriangulatedSolidOrShell
Type: Autodesk.Revit.DB..::..TriangulatedSolidOrShell
The TriangulatedSolidOrShell that the interface object represents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriangulationInterfaceForTriangulatedSolidOrShell Methods

[image] [image]

Revit 2013 API
TriangulationInterfaceForTriangulatedSolidOrShell Methods
TriangulationInterfaceForTriangulatedSolidOrShell Class See Also Send Feedback

The TriangulationInterfaceForTriangulatedSolidOrShell type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from TriangulationInterface.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriangulationInterfaceForTriangulatedSolidOrShell Class


TriOrQuadFacet Class

[image]

Revit 2013 API
TriOrQuadFacet Class
Members See Also Send Feedback
This class represents a triangle or quadrilateral in a faceted structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TriOrQuadFacet : IDisposable
Visual Basic
Public Class TriOrQuadFacet _
    Implements IDisposable
Visual C++
public ref class TriOrQuadFacet : IDisposable

Remarks

This class defines a triangle or quadrilateral with reference to an external triangulation structure. The vertices of this TriOrQuadFacet are indices into the triangulation structure's array of vertices.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TriOrQuadFacet

See Also

TriOrQuadFacet Members


TriOrQuadFacet Members

[image] [image]

Revit 2013 API
TriOrQuadFacet Members
TriOrQuadFacet Class Methods Properties See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the TriOrQuadFacet
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

See Also

TriOrQuadFacet Class


TriOrQuadFacet Methods

[image] [image]

Revit 2013 API
TriOrQuadFacet Methods
TriOrQuadFacet Class See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertexIndex | Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TriOrQuadFacet Class


Dispose Method

[image]

Revit 2013 API
TriOrQuadFacet..::..Dispose Method
TriOrQuadFacet Class See Also Send Feedback
Releases all resources used by the TriOrQuadFacet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

TriOrQuadFacet Class


GetVertexIndex Method

[image]

Revit 2013 API
TriOrQuadFacet..::..GetVertexIndex Method
TriOrQuadFacet Class See Also Send Feedback
Returns the index of the specified vertex of this facet (as an index into the external array of vertices in the TriangulationInterface that was used to create the list of TriOrQuadFacets).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetVertexIndex(
    int index
)
Visual Basic
Public Function GetVertexIndex ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetVertexIndex(
    int index
)

Parameters

index
Type: System..::..Int32
Index of the desired vertex in this TriOrQuadFacet (between 0 and NumberOfVertices-1, inclusive).

Return Value

The index of the specified vertex in the external array of vertices (only valid if NumberOfVertices >= 3).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is out of range..

See Also

TriOrQuadFacet Class


TriOrQuadFacet Properties

[image] [image]

Revit 2013 API
TriOrQuadFacet Properties
TriOrQuadFacet Class See Also Send Feedback

The TriOrQuadFacet type exposes the following members.

Properties

 | Name | Description
Public property | Normal | A unit normal vector for this facet.
Public property | NumberOfVertices | The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

See Also

TriOrQuadFacet Class


Normal Property

[image]

Revit 2013 API
TriOrQuadFacet..::..Normal Property
TriOrQuadFacet Class See Also Send Feedback
A unit normal vector for this facet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

TriOrQuadFacet Class


NumberOfVertices Property

[image]

Revit 2013 API
TriOrQuadFacet..::..NumberOfVertices Property
TriOrQuadFacet Class See Also Send Feedback
The number of vertices (3 for a triangle, 4 for a quadrilateral, 0 for an unset TriOrQuadFacet).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfVertices { get; }
Visual Basic
Public ReadOnly Property NumberOfVertices As Integer
    Get
Visual C++
public:
property int NumberOfVertices {
    int get ();
}

See Also

TriOrQuadFacet Class


TypeBinding Class

[image]

Revit 2013 API
TypeBinding Class
Members Example See Also Send Feedback
TypeBinding objects are used to bind a property to a Revit type, such as a wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TypeBinding : ElementBinding
Visual Basic
Public Class TypeBinding _
    Inherits ElementBinding
Visual C++
public ref class TypeBinding : public ElementBinding

Remarks

This differs from Instance bindings in that the property is then shared by all instances that use that type. Changing the parameter for one type affects all other instances that use that type.

Examples

CopyC#
public bool SetNewParameterToTypeWall(UIApplication app, DefinitionFile myDefinitionFile)
{
    // Create a new group in the shared parameters file
    DefinitionGroups myGroups = myDefinitionFile.Groups;
    DefinitionGroup myGroup = myGroups.Create("MyParameters");

    // Create a type definition
    Definition myDefinition_CompanyName =
       myGroup.Definitions.Create("CompanyName", ParameterType.Text);

    // Create a category set and insert category of wall to it
    CategorySet myCategories = app.Application.Create.NewCategorySet();
    // Use BuiltInCategory to get category of wall
    Category myCategory = app.ActiveUIDocument.Document.Settings.Categories.get_Item(
                                    BuiltInCategory.OST_Walls);
    myCategories.Insert(myCategory);

    //Create an object of TypeBinding according to the Categories
    TypeBinding typeBinding = app.Application.Create.NewTypeBinding(myCategories);

    // Get the BingdingMap of current document.
    BindingMap bindingMap = app.ActiveUIDocument.Document.ParameterBindings;

    // Bind the definitions to the document
    bool typeBindOK = bindingMap.Insert(myDefinition_CompanyName, typeBinding,
      BuiltInParameterGroup.PG_TEXT);
    return typeBindOK;
}
CopyVB.NET
Public Function SetNewParameterToTypeWall(ByVal app As UIApplication, ByVal myDefinitionFile As DefinitionFile) As Boolean
    ' Create a new group in the shared parameters file
    Dim myGroups As DefinitionGroups = myDefinitionFile.Groups
    Dim myGroup As DefinitionGroup = myGroups.Create("MyParameters")

    ' Create a type definition
    Dim myDefinition_CompanyName As Definition = myGroup.Definitions.Create("CompanyName", ParameterType.Text)

    ' Create a category set and insert category of wall to it
    Dim myCategories As CategorySet = app.Application.Create.NewCategorySet()
    ' Use BuiltInCategory to get category of wall
    Dim myCategory As Autodesk.Revit.DB.Category = app.ActiveUIDocument.Document.Settings.Categories.Item(BuiltInCategory.OST_Walls)
    myCategories.Insert(myCategory)

    'Create an object of TypeBinding according to the Categories
    Dim typeBinding As TypeBinding = app.Application.Create.NewTypeBinding(myCategories)

    ' Get the BingdingMap of current document.
    Dim bindingMap As BindingMap = app.ActiveUIDocument.Document.ParameterBindings

    ' Bind the definitions to the document
    Dim typeBindOK As Boolean = bindingMap.Insert(myDefinition_CompanyName, typeBinding, BuiltInParameterGroup.PG_TEXT)
    Return typeBindOK
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..Binding
Autodesk.Revit.DB..::..ElementBinding
Autodesk.Revit.DB..::..TypeBinding

See Also

TypeBinding Members


TypeBinding Members

[image] [image]

Revit 2013 API
TypeBinding Members
TypeBinding Class Constructors Methods Properties See Also Send Feedback

The TypeBinding type exposes the following members.

Constructors

 | Name | Description
Public method | TypeBinding()()()() | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


TypeBinding Constructor

[image] [image]

Revit 2013 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TypeBinding()()()() | Constructs an empty type binding.
Public method | TypeBinding(CategorySet) | Constructs a type binding with the set of categories passed.

See Also

TypeBinding Class
TypeBinding Members


TypeBinding Constructor

[image]

Revit 2013 API
TypeBinding Constructor
TypeBinding Class See Also Send Feedback
Constructs an empty type binding.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TypeBinding()
Visual Basic
Public Sub New
Visual C++
public:
TypeBinding()

Remarks

Categories can be set a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload


TypeBinding Constructor (CategorySet)

[image]

Revit 2013 API
TypeBinding Constructor (CategorySet)
TypeBinding Class See Also Send Feedback
Constructs a type binding with the set of categories passed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TypeBinding(
    CategorySet categories
)
Visual Basic
Public Sub New ( _
    categories As CategorySet _
)
Visual C++
public:
TypeBinding(
    CategorySet^ categories
)

Parameters

categories
Type: Autodesk.Revit.DB..::..CategorySet

Remarks

Categories can be set or changed at a later time by using the Categories property of this object.

See Also

TypeBinding Class
TypeBinding Overload


TypeBinding Methods

[image] [image]

Revit 2013 API
TypeBinding Methods
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TypeBinding Class


TypeBinding Properties

[image] [image]

Revit 2013 API
TypeBinding Properties
TypeBinding Class See Also Send Feedback

The TypeBinding type exposes the following members.

Properties

 | Name | Description
Public property | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TypeBinding Class


UnitGroup Enumeration

[image]

Revit 2013 API
UnitGroup Enumeration
See Also Send Feedback
An enumerated type listing Discipline of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum UnitGroup
Visual Basic
Public Enumeration UnitGroup
Visual C++
public enum class UnitGroup

Members

Member name | Description
UG_Common |
UG_Structural |
UG_HVAC |
UG_Electrical |
UG_Piping |
UG_Energy |

See Also


UnitSymbolType Enumeration

[image]

Revit 2013 API
UnitSymbolType Enumeration
See Also Send Feedback
An enumerated type listing Display Unit types of the Unit types that Autodesk Revit supports.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum UnitSymbolType
Visual Basic
Public Enumeration UnitSymbolType
Visual C++
public enum class UnitSymbolType

Members

Member name | Description
UST_NONE |
UST_M |
UST_CM |
UST_MM |
UST_LF |
UST_FOOT_SINGLE_QUOTE |
UST_INCH_DOUBLE_QUOTE |
UST_ACRES |
UST_HECTARES |
UST_CY |
UST_SF |
UST_FT_SUP_2 |
UST_FT_CARET_2 |
UST_M_SUP_2 |
UST_M_CARET_2 |
UST_CF |
UST_FT_SUP_3 |
UST_FT_CARET_3 |
UST_M_SUP_3 |
UST_M_CARET_3 |
UST_DEGREE_SYMBOL |
UST_PERCENT_SIGN |
UST_IN_SUP_2 |
UST_IN_CARET_2 |
UST_CM_SUP_2 |
UST_CM_CARET_2 |
UST_MM_SUP_2 |
UST_MM_CARET_2 |
UST_IN_SUP_3 |
UST_IN_CARET_3 |
UST_CM_SUP_3 |
UST_CM_CARET_3 |
UST_MM_SUP_3 |
UST_MM_CARET_3 |
UST_L |
UST_GAL |
UST_KG_PER_CU_M |
UST_LB_MASS_PER_CU_FT |
UST_LBM_PER_CU_FT |
UST_LB_MASS_PER_CU_IN |
UST_LBM_PER_CU_IN |
UST_BTU |
UST_CAL |
UST_KCAL |
UST_JOULE |
UST_KWH |
UST_THERM |
UST_IN_WG_PER_100FT |
UST_PASCAL_PER_M |
UST_WATT |
UST_KILOWATT |
UST_BTU_PER_S |
UST_BTU_PER_H |
UST_CAL_PER_S |
UST_KCAL_PER_S |
UST_WATT_PER_SQ_FT |
UST_WATT_PER_SQ_M |
UST_IN_WG |
UST_PASCAL |
UST_KILOPASCAL |
UST_MEGAPASCAL |
UST_PSI |
UST_LB_FORCE_PER_SQ_IN |
UST_PSIG |
UST_PSIA |
UST_LBF_PER_SQ_IN |
UST_IN_HG |
UST_MM_HG |
UST_ATM |
UST_BAR |
UST_DEGREE_F |
UST_DEGREE_C |
UST_KELVIN |
UST_DEGREE_R |
UST_FT_PER_MIN |
UST_FPM |
UST_M_PER_S |
UST_CM_PER_MIN |
UST_CU_FT_PER_MIN |
UST_CFM |
UST_L_PER_S |
UST_LPS |
UST_CU_M_PER_S |
UST_CMS |
UST_CU_M_PER_H |
UST_CMH |
UST_GAL_PER_MIN |
UST_GPM |
UST_USGPM |
UST_GAL_PER_H |
UST_GPH |
UST_USGPH |
UST_AMPERE |
UST_KILOAMPERE |
UST_MILLIAMPERE |
UST_VOLT |
UST_KILOVOLT |
UST_MILLIVOLT |
UST_HZ |
UST_CPS |
UST_LX |
UST_FC |
UST_FTC |
UST_FL |
UST_FL_LOWERCASE |
UST_FTL |
UST_CD_PER_SQ_M |
UST_CD |
UST_LM |
UST_VOLTAMPERE |
UST_KILOVOLTAMPERE |
UST_HP |
UST_N |
UST_DA_N |
UST_K_N |
UST_M_N |
UST_KIP |
UST_KGF |
UST_TF |
UST_LB_FORCE |
UST_LBF |
UST_N_PER_M |
UST_DA_N_PER_M |
UST_K_N_PER_M |
UST_M_N_PER_M |
UST_KIP_PER_FT |
UST_KGF_PER_M |
UST_TF_PER_M |
UST_LB_FORCE_PER_FT |
UST_LBF_PER_FT |
UST_N_PER_M_SUP_2 |
UST_DA_N_PER_M_SUP_2 |
UST_K_N_PER_M_SUP_2 |
UST_M_N_PER_M_SUP_2 |
UST_KSF |
UST_KIP_PER_SQ_FT |
UST_KGF_PER_M_SUP_2 |
UST_TF_PER_M_SUP_2 |
UST_PSF |
UST_LB_FORCE_PER_SQ_FT |
UST_LBF_PER_SQ_FT |
UST_N_DASH_M |
UST_DA_N_DASH_M |
UST_K_N_DASH_M |
UST_M_N_DASH_M |
UST_KIP_DASH_FT |
UST_KGF_DASH_M |
UST_TF_DASH_M |
UST_LB_FORCE_DASH_FT |
UST_LBF_DASH_FT |
UST_M_PER_K_N |
UST_FT_PER_KIP |
UST_M_SUP_2_PER_K_N |
UST_FT_SUP_2_PER_KIP |
UST_M_SUP_3_PER_K_N |
UST_FT_SUP_3_PER_KIP |
UST_INV_K_N |
UST_INV_KIP |
UST_FTH2O_PER_100FT |
UST_FT_OF_WATER_PER_100FT |
UST_FEET_OF_WATER_PER_100FT |
UST_FTH2O |
UST_FT_OF_WATER |
UST_FEET_OF_WATER |
UST_PA_S |
UST_LB_FORCE_PER_FT_S |
UST_LBM_PER_FT_S |
UST_CP |
UST_FT_PER_S |
UST_FPS |
UST_KSI |
UST_KIP_PER_SQ_IN |
UST_KN_PER_M_SUP_3 |
UST_LB_FORCE_PER_CU_FT |
UST_LBF_PER_CU_FT |
UST_KIP_PER_IN_SUP_3 |
UST_INV_DEGREE_F |
UST_INV_DEGREE_C |
UST_N_DASH_M_PER_M |
UST_DA_N_DASH_M_PER_M |
UST_K_N_DASH_M_PER_M |
UST_M_N_DASH_M_PER_M |
UST_KIP_DASH_FT_PER_FT |
UST_KGF_DASH_M_PER_M |
UST_TF_DASH_M_PER_M |
UST_LB_FORCE_DASH_FT_PER_FT |
UST_LBF_DASH_FT_PER_FT |
UST_LB_FORCE_PER_FT_H |
UST_LBM_PER_FT_H |
UST_KIPS_PER_IN |
UST_KIPS_PER_CU_FT |
UST_KIP_FT_PER_DEGREE |
UST_K_N_M_PER_DEGREE |
UST_KIP_FT_PER_DEGREE_PER_FT |
UST_K_N_M_PER_DEGREE_PER_M |
UST_WATT_PER_SQ_M_K |
UST_BTU_PER_H_SQ_FT_DEGREE_F |
UST_CFM_PER_SQ_FT |
UST_CFM_PER_SF |
UST_LPS_PER_SQ_M |
UST_L_PER_S_SQ_M |
UST_COLON_10 |
UST_COLON_12 |
UST_SLOPE_DEGREE_SYMBOL |
UST_WATT_PER_CU_FT |
UST_WATT_PER_CU_M |
UST_BTU_PER_H_SQ_FT |
UST_BTU_PER_H_CU_FT |
UST_TON |
UST_CFM_PER_CU_FT |
UST_CFM_PER_CF |
UST_L_PER_S_CU_M |
UST_CFM_PER_TON |
UST_L_PER_S_KW |
UST_SQ_FT_PER_TON |
UST_SF_PER_TON |
UST_SQ_M_PER_KW |
UST_DOLLAR |
UST_EURO_SUFFIX |
UST_EURO_PREFIX |
UST_POUND |
UST_YEN |
UST_CHINESE_HONG_KONG_SAR |
UST_WON |
UST_SHEQEL |
UST_DONG |
UST_BAHT |
UST_KRONER |
UST_LM_PER_W |
UST_SF_PER_MBH |
UST_SF_PER_KBTU_PER_H |
UST_SQ_FT_PER_MBH |
UST_SQ_FT_PER_KBTU_PER_H |
UST_K_N_PER_CM_SUP_2 |
UST_N_PER_MM_SUP_2 |
UST_K_N_PER_MM_SUP_2 |
UST_1_COLON |
UST_H_SQ_FT_DEGREE_F_PER_BTU |
UST_SQ_M_K_PER_WATT |
UST_BTU_PER_F |
UST_J_PER_KELVIN |
UST_KJ_PER_KELVIN |
UST_KGM |
UST_TM |
UST_LB_MASS |
UST_LBM |
UST_M_PER_SQ_S |
UST_KM_PER_SQ_S |
UST_IN_PER_SQ_S |
UST_FT_PER_SQ_S |
UST_MI_PER_SQ_S |
UST_FT_SUP_4 |
UST_IN_SUP_4 |
UST_MM_SUP_4 |
UST_CM_SUP_4 |
UST_M_SUP_4 |
UST_FT_SUP_6 |
UST_IN_SUP_6 |
UST_MM_SUP_6 |
UST_CM_SUP_6 |
UST_M_SUP_6 |
UST_SQ_FT_PER_FT |
UST_SQ_IN_PER_FT |
UST_SQ_MM_PER_M |
UST_SQ_CM_PER_M |
UST_SQ_M_PER_M |
UST_KGM_PER_M |
UST_LB_MASS_PER_FT |
UST_LBM_PER_FT |
UST_RAD |
UST_GRAD |
UST_RAD_PER_S |
UST_MS |
UST_S |
UST_MIN |
UST_H |
UST_KM_PER_H |
UST_MI_PER_H |
UST_KJ |
UST_KGM_PER_SQ_M |
UST_LBM_PER_SQ_FT |
UST_WATTS_PER_METER_KELVIN |
UST_J_PER_G_CELSIUS |
UST_J_PER_G |
UST_NG_PER_PA_S_SQ_M |
UST_OHM_M |
UST_BTU_PER_H_FT_DEGREE_F |
UST_BTU_PER_LB_DEGREE_F |
UST_BTU_PER_LB |
UST_GR_PER_H_SQ_FT_IN_HG |
UST_PER_MILLE_SIGN |
UST_DM |
UST_J_PER_KG_CELSIUS |
UST_UM_PER_M_C |
UST_UIN_PER_IN_F |

See Also


UnitType Enumeration

[image]

Revit 2013 API
UnitType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum UnitType
Visual Basic
Public Enumeration UnitType
Visual C++
public enum class UnitType

Members

Member name | Description
UT_Undefined | Undefined unit value
UT_Custom | A custom unit value
UT_Length | Length, e.g. ft, in, m, mm
UT_Area | Area, e.g. ft², in², m², mm²
UT_Volume | Volume, e.g. ft³, in³, m³, mm³
UT_Angle | Angular measurement, e.g. radians, degrees
UT_Number | General format unit, appropriate for general counts or percentages
UT_SheetLength | Sheet length
UT_SiteAngle | Site angle
UT_HVAC_Density | Density (HVAC) e.g. kg/m³
UT_HVAC_Energy | Energy (HVAC) e.g. (m² · kg)/s², J
UT_HVAC_Friction | Friction (HVAC) e.g. kg/(m² · s²), Pa/m
UT_HVAC_Power | Power (HVAC) e.g. (m² · kg)/s³, W
UT_HVAC_Power_Density | Power Density (HVAC), e.g. kg/s³, W/m²
UT_HVAC_Pressure | Pressure (HVAC) e.g. kg/(m · s²), Pa
UT_HVAC_Temperature | Temperature (HVAC) e.g. K, C, F
UT_HVAC_Velocity | Velocity (HVAC) e.g. m/s
UT_HVAC_Airflow | Air Flow (HVAC) e.g. m³/s
UT_HVAC_DuctSize | Duct Size (HVAC) e.g. mm, in
UT_HVAC_CrossSection | Cross Section (HVAC) e.g. mm², in²
UT_HVAC_HeatGain | Heat Gain (HVAC) e.g. (m² · kg)/s³, W
UT_Electrical_Current | Current (Electrical) e.g. A
UT_Electrical_Potential | Electrical Potential e.g. (m² · kg) / (s³· A), V
UT_Electrical_Frequency | Frequency (Electrical) e.g. 1/s, Hz
UT_Electrical_Illuminance | Illuminance (Electrical) e.g. (cd · sr)/m², lm/m²
UT_Electrical_Luminous_Flux | Luminous Flux (Electrical) e.g. cd · sr, lm
UT_Electrical_Power | Power (Electrical) e.g. (m² · kg)/s³, W
UT_HVAC_Roughness | Roughness factor (HVAC) e,g. ft, in, mm
UT_Force | Force, e.g. (kg · m)/s², N
UT_LinearForce | Force per unit length, e.g. kg/s², N/m
UT_AreaForce | Force per unit area, e.g. kg/(m · s²), N/m²
UT_Moment | Moment, e.g. (kg · m²)/s², N · m
UT_ForceScale | Force scale, e.g. m / N
UT_LinearForceScale | Linear force scale, e.g. m² / N
UT_AreaForceScale | Area force scale, e.g. m³ / N
UT_MomentScale | Moment scale, e.g. 1 / N
UT_Electrical_Apparent_Power | Apparent Power (Electrical), e.g. (m² · kg)/s³, W
UT_Electrical_Power_Density | Power Density (Electrical), e.g. kg/s³, W/m²
UT_Piping_Density | Density (Piping) e.g. kg/m³
UT_Piping_Flow | Flow (Piping), e.g. m³/s
UT_Piping_Friction | Friction (Piping), e.g. kg/(m² · s²), Pa/m
UT_Piping_Pressure | Pressure (Piping), e.g. kg/(m · s²), Pa
UT_Piping_Temperature | Temperature (Piping), e.g. K
UT_Piping_Velocity | Velocity (Piping), e.g. m/s
UT_Piping_Viscosity | Viscosity (Piping), e.g. kg/(m · s), Pa · s
UT_PipeSize | Pipe Size (Piping), e.g. m
UT_Piping_Roughness | Roughness factor (Piping), e.g. ft, in, mm
UT_Stress | Stress, e.g. kg/(m · s²), ksi, MPa
UT_UnitWeight | Unit weight, e.g. N/m³
UT_ThermalExpansion | Thermal expansion, e.g. 1/K
UT_LinearMoment | Linear moment, e,g. (N · m)/m, lbf / ft
UT_LinearMomentScale | Linear moment scale, e.g. ft/kip, m/kN
UT_ForcePerLength | Point Spring Coefficient, e.g. kg/s², N/m
UT_ForceLengthPerAngle | Rotational Point Spring Coefficient, e.g. (kg · m²)/(s² · rad), (N · m)/rad
UT_LinearForcePerLength | Line Spring Coefficient, e.g. kg/(m · s²), (N · m)/m²
UT_LinearForceLengthPerAngle | Rotational Line Spring Coefficient, e.g. (kg · m)/(s² · rad), N/rad
UT_AreaForcePerLength | Area Spring Coefficient, e.g. kg/(m² · s²), N/m³
UT_Piping_Volume | Pipe Volume, e.g. gallons, liters
UT_HVAC_Viscosity | Viscosity (HVAC), e.g. kg/(m · s), Pa · s
UT_HVAC_CoefficientOfHeatTransfer | Coefficient of Heat Transfer (U-value) (HVAC), e.g. kg/(s³ · K), W/(m² · K)
UT_HVAC_Airflow_Density | Air Flow Density (HVAC), m³/(s · m²)
UT_Slope | Slope, rise/run
UT_HVAC_Cooling_Load | Cooling load (HVAC), e.g. (m² · kg)/s³, W, kW, Btu/s, Btu/h
UT_HVAC_Cooling_Load_Divided_By_Area | Cooling load per unit area (HVAC), e.g. kg/s³, W/m², W/ft², Btu/(h·ft²)
UT_HVAC_Cooling_Load_Divided_By_Volume | Cooling load per unit volume (HVAC), e.g. kg/(s³ · m), W/m³, Btu/(h·ft³)
UT_HVAC_Heating_Load | Heating load (HVAC), e.g. (m² · kg)/s³, W, kW, Btu/s, Btu/h
UT_HVAC_Heating_Load_Divided_By_Area | Heating load per unit area (HVAC), e.g. kg/s³, W/m², W/ft², Btu/(h·ft²)
UT_HVAC_Heating_Load_Divided_By_Volume | Heating load per unit volume (HVAC), e.g. kg/(s³ · m), W/m³, Btu/(h·ft³)
UT_HVAC_Airflow_Divided_By_Volume | Airflow per unit volume (HVAC), e.g. m³/(s · m³), CFM/ft³, CFM/CF, L/(s·m³)
UT_HVAC_Airflow_Divided_By_Cooling_Load | Airflow per unit cooling load (HVAC), e.g. (m · s²)/kg, ft²/ton, SF/ton, m²/kW
UT_HVAC_Area_Divided_By_Cooling_Load | Area per unit cooling load (HVAC), e.g. s³/kg, ft²/ton, m²/kW
UT_WireSize | Wire Size (Electrical), e.g. mm, inch
UT_HVAC_Slope | Slope (HVAC)
UT_Piping_Slope | Slope (Piping)
UT_Currency | Currency
UT_Electrical_Efficacy | Electrical efficacy (lighting), e.g. cd·sr·s³/(m²·kg), lm/W
UT_Electrical_Wattage | Wattage (lighting), e.g. (m² · kg)/s³, W
UT_Color_Temperature | Color temperature (lighting), e.g. K
UT_DecSheetLength | Sheet length in decimal form, decimal inches, mm
UT_Electrical_Luminous_Intensity | Luminous Intensity (Lighting), e.g. cd, cd
UT_Electrical_Luminance | Luminance (Lighting), cd/m², cd/m²
UT_HVAC_Area_Divided_By_Heating_Load | Area per unit heating load (HVAC), e.g. s³/kg, ft²/ton, m²/kW
UT_HVAC_Factor | Heating and coooling factor, percentage
UT_Electrical_Temperature | Temperature (electrical), e.g. F, C
UT_Electrical_CableTraySize | Cable tray size (electrical), e.g. in, mm
UT_Electrical_ConduitSize | Conduit size (electrical), e.g. in, mm
UT_Reinforcement_Volume | Structural reinforcement volume, e.g. in³, cm³
UT_Reinforcement_Length | Structural reinforcement length, e.g. mm, in, ft
UT_Electrical_Demand_Factor | Electrical demand factor, percentage
UT_HVAC_DuctInsulationThickness | Duct Insulation Thickness (HVAC), e.g. mm, in
UT_HVAC_DuctLiningThickness | Duct Lining Thickness (HVAC), e.g. mm, in
UT_PipeInsulationThickness | Pipe Insulation Thickness (Piping), e.g. mm, in
UT_HVAC_ThermalResistance | Thermal Resistance (HVAC), R Value, e.g. m²·K/W
UT_HVAC_ThermalMass | Thermal Mass (HVAC), e.g. J/K, BTU/F
UT_Acceleration | Acceleration, e.g. m/s², km/s², in/s², ft/s², mi/s²
UT_Bar_Diameter | Bar Diameter, e.g. ', LF, ", m, cm, mm
UT_Crack_Width | Crack Width, e.g. ', LF, ", m, cm, mm
UT_Displacement_Deflection | Displacement/Deflection, e.g. ', LF, ", m, cm, mm
UT_Energy | Energy, e.g. J, kJ, kgf-m, lb-ft, N-m
UT_Structural_Frequency | FREQUENCY, Frequency (Structural) e.g. Hz
UT_Mass | Mass, e.g. kg, lb, t
UT_Mass_per_Unit_Length | Mass per Unit Length, e.g. kg/m, lb/ft
UT_Moment_of_Inertia | Moment of Inertia, e.g. ft^4, in^4, mm^4, cm^4, m^4
UT_Surface_Area | Surface Area, e.g. ft²/ft, m²/m
UT_Period | Period, e.g. ms, s, min, h
UT_Pulsation | Pulsation, e.g. rad/s
UT_Reinforcement_Area | Reinforcement Area, e.g. SF, ft², in², mm², cm², m²
UT_Reinforcement_Area_per_Unit_Length | Reinforcement Area per Unit Length, e.g. ft²/ft, in²/ft, mm²/m, cm²/m, m²/m
UT_Reinforcement_Cover | Reinforcement Cover, e.g. ', LF, ", m, cm, mm
UT_Reinforcement_Spacing | Reinforcement Spacing, e.g. ', LF, ", m, cm, mm
UT_Rotation | Rotation, e.g. °, rad, grad
UT_Section_Area | Section Area, e.g. ft²/ft, in²/ft, mm²/m, cm²/m, m²/m
UT_Section_Dimension | Section Dimension, e.g. ', LF, ", m, cm, mm
UT_Section_Modulus | Section Modulus, e.g. ft^3, in^3, mm^3, cm^3, m^3
UT_Section_Property | Section Property, e.g. ', LF, ", m, cm, mm
UT_Structural_Velocity | Section Property, e.g. km/h, m/s, ft/min, ft/s, mph
UT_Warping_Constant | Warping Constant, e.g. ft^6, in^6, mm^6, cm^6, m^6
UT_Weight | Weight, e.g. N, daN, kN, MN, kip, kgf, Tf, lb, lbf
UT_Weight_per_Unit_Length | Weight per Unit Length, e.g. N/m, daN/m, kN/m, MN/m, kip/ft, kgf/m, Tf/m, lb/ft, lbf/ft, kip/in
UT_HVAC_ThermalConductivity | Thermal Conductivity (HVAC), e.g. W/(m·K)
UT_HVAC_SpecificHeat | Specific Heat (HVAC), e.g. J/(g·°C)
UT_HVAC_SpecificHeatOfVaporization | Specific Heat of Vaporization, e.g. J/g
UT_HVAC_Permeability | Permeability, e.g. ng/(Pa·s·m²)
UT_Electrical_Resistivity | Electrical Resistivity, e.g.
UT_MassDensity | Mass Density, e.g. kg/m³, lb/ft³
UT_MassPerUnitArea | Mass Per Unit Area, e.g. kg/m², lb/ft²

See Also


UpdaterData Class

[image]

Revit 2013 API
UpdaterData Class
Members See Also Send Feedback
Service class that is passed to an Updater to prove access to update execution context

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class UpdaterData : IDisposable
Visual Basic
Public Class UpdaterData _
    Implements IDisposable
Visual C++
public ref class UpdaterData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterData

See Also

UpdaterData Members


UpdaterData Members

[image] [image]

Revit 2013 API
UpdaterData Members
UpdaterData Class Methods See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterData Class


UpdaterData Methods

[image] [image]

Revit 2013 API
UpdaterData Methods
UpdaterData Class See Also Send Feedback

The UpdaterData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().
Public method | GetDocument | Returns document associated with this UpdaterData
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsChangeTriggered | Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterData Class


Dispose Method

[image]

Revit 2013 API
UpdaterData..::..Dispose Method
UpdaterData Class See Also Send Feedback
Releases all resources used by the UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterData Class


GetAddedElementIds Method

[image]

Revit 2013 API
UpdaterData..::..GetAddedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements newly added to the document. This set is mutually exclusive of elements returned by getDeletedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

Set of elements that were added to the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementAddition()

See Also

UpdaterData Class


GetDeletedElementIds Method

[image]

Revit 2013 API
UpdaterData..::..GetDeletedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetDeletedElementIds()
Visual Basic
Public Function GetDeletedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDeletedElementIds()

Return Value

Set of elements that were deleted from the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementDeletion()

See Also

UpdaterData Class


GetDocument Method

[image]

Revit 2013 API
UpdaterData..::..GetDocument Method
UpdaterData Class See Also Send Feedback
Returns document associated with this UpdaterData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

See Also

UpdaterData Class


GetModifiedElementIds Method

[image]

Revit 2013 API
UpdaterData..::..GetModifiedElementIds Method
UpdaterData Class See Also Send Feedback
Returns set of elements that were modified. This set is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetModifiedElementIds()
Visual Basic
Public Function GetModifiedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetModifiedElementIds()

Return Value

Set of elements that were modified in the document and triggered the call to execute() Note: This set only contains modified elements (i.e. it is mutually exclusive of elements returned by getAddedElementIds() and getDeletedElementIds()). It does not contain any elements that were added to or deleted from the document during the current transaction. Newly added/deleted elements will be reported by getAddedElementIds()/getDeletedElementIds(), even if they were also modified during the same transaction, but only if ChangeTypeElementAddition/Deletion is registered as a trigger for the current Updater. I.e. Element creation and modification in the same transaction is considered to be "creation" only. Newly created elements are not considered to be "modified" and are therefore not returned as part of getModifiedElementIds()

See Also

UpdaterData Class


IsChangeTriggered Method

[image]

Revit 2013 API
UpdaterData..::..IsChangeTriggered Method
UpdaterData Class See Also Send Feedback
Allows updater to check if specific change has happened to an element. Compares input type to the types that caused Updater::execute() to be triggered. If input type was not registered as a trigger for the associated Updater, this method will always return false for that ChangeType. For example, if the only trigger registered for UpdaterX is ChangeTypeAny for Element A, then passing in ChangeTypeGeometry will return false even if the geometry of A changed because the registered trigger was ChangeTypeAny. However, passing in ChangeTypeAny will return true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsChangeTriggered(
    ElementId id,
    ChangeType type
)
Visual Basic
Public Function IsChangeTriggered ( _
    id As ElementId, _
    type As ChangeType _
) As Boolean
Visual C++
public:
bool IsChangeTriggered(
    ElementId^ id,
    ChangeType^ type
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
Id of element to check
type
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType to check

Return Value

True if ChangeType happened to specified element

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterData Class


UpdaterId Class

[image]

Revit 2013 API
UpdaterId Class
Members See Also Send Feedback
A unique identifier of an Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class UpdaterId : IDisposable
Visual Basic
Public Class UpdaterId _
    Implements IDisposable
Visual C++
public ref class UpdaterId : IDisposable

Remarks

UpdaterID used as a key to register and unregister Updaters and UpdateTriggers in Revit application

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterId

See Also

UpdaterId Members


UpdaterId Members

[image] [image]

Revit 2013 API
UpdaterId Members
UpdaterId Class Constructors Methods See Also Send Feedback

The UpdaterId type exposes the following members.

Constructors

 | Name | Description
Public method | UpdaterId | creates an instance of UpdaterId for given AddInId and a given GUID value

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterId
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterId Class


UpdaterId Constructor

[image]

Revit 2013 API
UpdaterId Constructor
UpdaterId Class See Also Send Feedback
creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public UpdaterId(
    AddInId addInId,
    Guid val
)
Visual Basic
Public Sub New ( _
    addInId As AddInId, _
    val As Guid _
)
Visual C++
public:
UpdaterId(
    AddInId^ addInId,
    Guid val
)

Parameters

addInId
Type: Autodesk.Revit.DB..::..AddInId
Id of addin that registers an Updater
val
Type: System..::..Guid
a GUID identifying the Updater within addin

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | addInId is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterId Class


UpdaterId Methods

[image] [image]

Revit 2013 API
UpdaterId Methods
UpdaterId Class See Also Send Feedback

The UpdaterId type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddInId | AddInId of the UpdaterId
Public method | GetGUID | GUID value of the UpdaterId
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterId Class


Dispose Method

[image]

Revit 2013 API
UpdaterId..::..Dispose Method
UpdaterId Class See Also Send Feedback
Releases all resources used by the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterId Class


GetAddInId Method

[image]

Revit 2013 API
UpdaterId..::..GetAddInId Method
UpdaterId Class See Also Send Feedback
AddInId of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AddInId GetAddInId()
Visual Basic
Public Function GetAddInId As AddInId
Visual C++
public:
AddInId^ GetAddInId()

See Also

UpdaterId Class


GetGUID Method

[image]

Revit 2013 API
UpdaterId..::..GetGUID Method
UpdaterId Class See Also Send Feedback
GUID value of the UpdaterId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Guid GetGUID()
Visual Basic
Public Function GetGUID As Guid
Visual C++
public:
Guid GetGUID()

See Also

UpdaterId Class


UpdaterInfo Class

[image]

Revit 2013 API
UpdaterInfo Class
Members See Also Send Feedback
Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class UpdaterInfo : IDisposable
Visual Basic
Public Class UpdaterInfo _
    Implements IDisposable
Visual C++
public ref class UpdaterInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterInfo

See Also

UpdaterInfo Members


UpdaterInfo Members

[image] [image]

Revit 2013 API
UpdaterInfo Members
UpdaterInfo Class Methods Properties See Also Send Feedback

The UpdaterInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UpdaterInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalInformation | Additional information about the updater.
Public property | ApplicationName | Name of the application that owns the updater.
Public property | IsOptional | Whether the updater is optional or not.
Public property | UpdaterName | Name of the updater.

See Also

UpdaterInfo Class


UpdaterInfo Methods

[image] [image]

Revit 2013 API
UpdaterInfo Methods
UpdaterInfo Class See Also Send Feedback

The UpdaterInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdaterInfo Class


Dispose Method

[image]

Revit 2013 API
UpdaterInfo..::..Dispose Method
UpdaterInfo Class See Also Send Feedback
Releases all resources used by the UpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterInfo Class


UpdaterInfo Properties

[image] [image]

Revit 2013 API
UpdaterInfo Properties
UpdaterInfo Class See Also Send Feedback

The UpdaterInfo type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalInformation | Additional information about the updater.
Public property | ApplicationName | Name of the application that owns the updater.
Public property | IsOptional | Whether the updater is optional or not.
Public property | UpdaterName | Name of the updater.

See Also

UpdaterInfo Class


AdditionalInformation Property

[image]

Revit 2013 API
UpdaterInfo..::..AdditionalInformation Property
UpdaterInfo Class See Also Send Feedback
Additional information about the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string AdditionalInformation { get; }
Visual Basic
Public ReadOnly Property AdditionalInformation As String
    Get
Visual C++
public:
property String^ AdditionalInformation {
    String^ get ();
}

See Also

UpdaterInfo Class


ApplicationName Property

[image]

Revit 2013 API
UpdaterInfo..::..ApplicationName Property
UpdaterInfo Class See Also Send Feedback
Name of the application that owns the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string ApplicationName { get; }
Visual Basic
Public ReadOnly Property ApplicationName As String
    Get
Visual C++
public:
property String^ ApplicationName {
    String^ get ();
}

See Also

UpdaterInfo Class


IsOptional Property

[image]

Revit 2013 API
UpdaterInfo..::..IsOptional Property
UpdaterInfo Class See Also Send Feedback
Whether the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsOptional { get; }
Visual Basic
Public ReadOnly Property IsOptional As Boolean
    Get
Visual C++
public:
property bool IsOptional {
    bool get ();
}

See Also

UpdaterInfo Class


UpdaterName Property

[image]

Revit 2013 API
UpdaterInfo..::..UpdaterName Property
UpdaterInfo Class See Also Send Feedback
Name of the updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string UpdaterName { get; }
Visual Basic
Public ReadOnly Property UpdaterName As String
    Get
Visual C++
public:
property String^ UpdaterName {
    String^ get ();
}

See Also

UpdaterInfo Class


UpdaterRegistry Class

[image]

Revit 2013 API
UpdaterRegistry Class
Members See Also Send Feedback
Application level singleton that stores registered Updaters Note: In order to use UpdaterRegistry functionality, add-ins must be registered using manifest files (rather than Revit.ini) UpdaterId::getAddInId() for any Updater/UpdaterId to be modified must match the addInId field in the add-in's manifest file. An add-in cannot add, remove, or modify updaters that do not belong to it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class UpdaterRegistry : IDisposable
Visual Basic
Public Class UpdaterRegistry _
    Implements IDisposable
Visual C++
public ref class UpdaterRegistry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UpdaterRegistry

See Also

UpdaterRegistry Members


UpdaterRegistry Members

[image] [image]

Revit 2013 API
UpdaterRegistry Members
UpdaterRegistry Class Methods See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
Public method | Dispose | Releases all resources used by the UpdaterRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns UpdaterInfos for all the updaters applicable to the specified document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUpdaterRegistered | Checks whether an updater with the given id is registered
 | RegisterUpdater(IUpdater) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document) | Registers the updater for the specified document
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for the specified document
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Set kind of specified updater.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class


UpdaterRegistry Methods

[image] [image]

Revit 2013 API
UpdaterRegistry Methods
UpdaterRegistry Class See Also Send Feedback

The UpdaterRegistry type exposes the following members.

Methods

 | Name | Description
 | AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
 | AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
 | AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIsUpdaterOptional | Check if the updater is optional or not.
 | GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
 | GetRegisteredUpdaterInfos(Document) | Returns UpdaterInfos for all the updaters applicable to the specified document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsUpdaterRegistered | Checks whether an updater with the given id is registered
 | RegisterUpdater(IUpdater) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document) | Registers the updater for the specified document
 | RegisterUpdater(IUpdater, Boolean) | Registers an updater on an application level
 | RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for the specified document
 | RemoveAllTriggers | Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.
 | RemoveDocumentTriggers | Removes all triggers associated with specified document and Updater Does not unregister updater.
 | SetExecutionOrder | Forces execution order between two updaters Execution order: first before second
 | SetIsUpdaterOptional | Set kind of specified updater.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterUpdater | Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

See Also

UpdaterRegistry Class


AddTrigger Method

[image] [image]

Revit 2013 API
UpdaterRegistry..::..AddTrigger Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
AddTrigger(UpdaterId, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater
AddTrigger(UpdaterId, Document, ElementFilter, ChangeType) | Adds trigger with the specified element filter and ChangeType for the specified document
AddTrigger(UpdaterId, Document, ICollection<(Of <<'(ElementId>)>>), ChangeType) | Adds a trigger to an updater with specified set of elements and ChangeType

See Also

UpdaterRegistry Class
UpdaterRegistry Members


AddTrigger Method (UpdaterId, ElementFilter, ChangeType)

[image]

Revit 2013 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    ElementFilter filter,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
filter
Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)

[image]

Revit 2013 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, Document, ElementFilter, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds trigger with the specified element filter and ChangeType for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document doc,
    ElementFilter filter,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    doc As Document, _
    filter As ElementFilter, _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ doc,
    ElementFilter^ filter,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
doc
Type: Autodesk.Revit.DB..::..Document
Document that elements in 'elements' are contained in
filter
Type: Autodesk.Revit.DB..::..ElementFilter
Element filter that defines elements that affect this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Remarks

This method only works with CategoryFilter and ParameterFilter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


AddTrigger Method (UpdaterId, Document, ICollection(ElementId), ChangeType)

[image]

Revit 2013 API
UpdaterRegistry..::..AddTrigger Method (UpdaterId, Document, ICollection<(Of <(<'ElementId>)>)>, ChangeType)
UpdaterRegistry Class See Also Send Feedback
Adds a trigger to an updater with specified set of elements and ChangeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void AddTrigger(
    UpdaterId id,
    Document doc,
    ICollection<ElementId> elements,
    ChangeType change
)
Visual Basic
Public Shared Sub AddTrigger ( _
    id As UpdaterId, _
    doc As Document, _
    elements As ICollection(Of ElementId), _
    change As ChangeType _
)
Visual C++
public:
static void AddTrigger(
    UpdaterId^ id,
    Document^ doc,
    ICollection<ElementId^>^ elements,
    ChangeType^ change
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater that trigger should be added to
doc
Type: Autodesk.Revit.DB..::..Document
Document that elements in 'elements' are contained in
elements
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Set of elements which define this trigger
change
Type: Autodesk.Revit.DB..::..ChangeType
ChangeType associated with this trigger

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- id does not correspond to any registered Updaters -or- AddTrigger called while executing an updater.

See Also

UpdaterRegistry Class
AddTrigger Overload


Dispose Method

[image]

Revit 2013 API
UpdaterRegistry..::..Dispose Method
UpdaterRegistry Class See Also Send Feedback
Releases all resources used by the UpdaterRegistry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UpdaterRegistry Class


GetIsUpdaterOptional Method

[image]

Revit 2013 API
UpdaterRegistry..::..GetIsUpdaterOptional Method
UpdaterRegistry Class See Also Send Feedback
Check if the updater is optional or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool GetIsUpdaterOptional(
    UpdaterId id
)
Visual Basic
Public Shared Function GetIsUpdaterOptional ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool GetIsUpdaterOptional(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater to check

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater has not been registered.

See Also

UpdaterRegistry Class


GetRegisteredUpdaterInfos Method

[image] [image]

Revit 2013 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
GetRegisteredUpdaterInfos()()()() | Returns UpdaterInfos for all the application-wide updaters.
GetRegisteredUpdaterInfos(Document) | Returns UpdaterInfos for all the updaters applicable to the specified document.

See Also

UpdaterRegistry Class
UpdaterRegistry Members


GetRegisteredUpdaterInfos Method

[image]

Revit 2013 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method
UpdaterRegistry Class See Also Send Feedback
Returns UpdaterInfos for all the application-wide updaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos()
Visual Basic
Public Shared Function GetRegisteredUpdaterInfos As IList(Of UpdaterInfo)
Visual C++
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos()

See Also

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload


GetRegisteredUpdaterInfos Method (Document)

[image]

Revit 2013 API
UpdaterRegistry..::..GetRegisteredUpdaterInfos Method (Document)
UpdaterRegistry Class See Also Send Feedback
Returns UpdaterInfos for all the updaters applicable to the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos(
    Document doc
)
Visual Basic
Public Shared Function GetRegisteredUpdaterInfos ( _
    doc As Document _
) As IList(Of UpdaterInfo)
Visual C++
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document the updater registered to.

Remarks

The returned value includes UpdaterInfos for all the application-wide updaters and updaters registered to the specified document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class
GetRegisteredUpdaterInfos Overload


IsUpdaterRegistered Method

[image]

Revit 2013 API
UpdaterRegistry..::..IsUpdaterRegistered Method
UpdaterRegistry Class See Also Send Feedback
Checks whether an updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsUpdaterRegistered(
    UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterRegistered ( _
    id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id to check in the registry

Return Value

Returns true if the updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

UpdaterRegistry Class


RegisterUpdater Method

[image] [image]

Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method
UpdaterRegistry Class See Also Send Feedback

Overload List

Name | Description
RegisterUpdater(IUpdater) | Registers an updater on an application level
RegisterUpdater(IUpdater, Document) | Registers the updater for the specified document
RegisterUpdater(IUpdater, Boolean) | Registers an updater on an application level
RegisterUpdater(IUpdater, Document, Boolean) | Registers the updater for the specified document

See Also

UpdaterRegistry Class
UpdaterRegistry Members


RegisterUpdater Method (IUpdater)

[image]

Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater)
UpdaterRegistry Class See Also Send Feedback
Registers an updater on an application level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- updater is already registered on the application level -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Document)

[image]

Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Document)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document doc
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    doc As Document _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ doc
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
doc
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater is already registered for this document or on the application level -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Boolean)

[image]

Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Boolean)
UpdaterRegistry Class See Also Send Feedback
Registers an updater on an application level

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    bool isOptional
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    isOptional As Boolean _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    bool isOptional
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
isOptional
Type: System..::..Boolean
Kind of the updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- updater is already registered on the application level -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RegisterUpdater Method (IUpdater, Document, Boolean)

[image]

Revit 2013 API
UpdaterRegistry..::..RegisterUpdater Method (IUpdater, Document, Boolean)
UpdaterRegistry Class See Also Send Feedback
Registers the updater for the specified document

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RegisterUpdater(
    IUpdater updater,
    Document doc,
    bool isOptional
)
Visual Basic
Public Shared Sub RegisterUpdater ( _
    updater As IUpdater, _
    doc As Document, _
    isOptional As Boolean _
)
Visual C++
public:
static void RegisterUpdater(
    IUpdater^ updater,
    Document^ doc,
    bool isOptional
)

Parameters

updater
Type: Autodesk.Revit.DB..::..IUpdater
Updater to be registered
doc
Type: Autodesk.Revit.DB..::..Document
Document for which this updater is registered
isOptional
Type: System..::..Boolean
Kind of the updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Updater's Id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater is already registered for this document or on the application level -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- RegisterUpdater called while executing an updater.

See Also

UpdaterRegistry Class
RegisterUpdater Overload


RemoveAllTriggers Method

[image]

Revit 2013 API
UpdaterRegistry..::..RemoveAllTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with Updater with specified UpdaterId. Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveAllTriggers(
    UpdaterId id
)
Visual Basic
Public Shared Sub RemoveAllTriggers ( _
    id As UpdaterId _
)
Visual C++
public:
static void RemoveAllTriggers(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of specified updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- RemoveAllTriggers called while executing an updater.

See Also

UpdaterRegistry Class


RemoveDocumentTriggers Method

[image]

Revit 2013 API
UpdaterRegistry..::..RemoveDocumentTriggers Method
UpdaterRegistry Class See Also Send Feedback
Removes all triggers associated with specified document and Updater Does not unregister updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void RemoveDocumentTriggers(
    UpdaterId id,
    Document doc
)
Visual Basic
Public Shared Sub RemoveDocumentTriggers ( _
    id As UpdaterId, _
    doc As Document _
)
Visual C++
public:
static void RemoveDocumentTriggers(
    UpdaterId^ id,
    Document^ doc
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of specified updater
doc
Type: Autodesk.Revit.DB..::..Document
Document for which to remove triggers

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | updater's owner AddIn does not match currently active AddIn -or- RemoveDocumentTriggers called while executing an updater.

See Also

UpdaterRegistry Class


SetExecutionOrder Method

[image]

Revit 2013 API
UpdaterRegistry..::..SetExecutionOrder Method
UpdaterRegistry Class See Also Send Feedback
Forces execution order between two updaters Execution order: first before second

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void SetExecutionOrder(
    UpdaterId first,
    UpdaterId second
)
Visual Basic
Public Shared Sub SetExecutionOrder ( _
    first As UpdaterId, _
    second As UpdaterId _
)
Visual C++
public:
static void SetExecutionOrder(
    UpdaterId^ first,
    UpdaterId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..UpdaterId
Id of first Updater
second
Type: Autodesk.Revit.DB..::..UpdaterId
Id of second Updater

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The updaters do not report the same ChangePriority

See Also

UpdaterRegistry Class


SetIsUpdaterOptional Method

[image]

Revit 2013 API
UpdaterRegistry..::..SetIsUpdaterOptional Method
UpdaterRegistry Class See Also Send Feedback
Set kind of specified updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void SetIsUpdaterOptional(
    UpdaterId id,
    bool isOptional
)
Visual Basic
Public Shared Sub SetIsUpdaterOptional ( _
    id As UpdaterId, _
    isOptional As Boolean _
)
Visual C++
public:
static void SetIsUpdaterOptional(
    UpdaterId^ id,
    bool isOptional
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of the updater
isOptional
Type: System..::..Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The updater has not been registered.

See Also

UpdaterRegistry Class


UnregisterUpdater Method

[image]

Revit 2013 API
UpdaterRegistry..::..UnregisterUpdater Method
UpdaterRegistry Class See Also Send Feedback
Removes the updater associated with the input id from the UpdaterRegistry. Also removes all triggers associated with the Updater.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void UnregisterUpdater(
    UpdaterId id
)
Visual Basic
Public Shared Sub UnregisterUpdater ( _
    id As UpdaterId _
)
Visual C++
public:
static void UnregisterUpdater(
    UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..UpdaterId
Id of updater to be removed

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Updater has not been registered -or- updater's owner AddIn does not match currently active AddIn i.e. IUpdater::getUpdaterId()::getAddInId() != add-in's addInId field in the manifest file -or- Throws exception when attempting to unregister an updater that is currently being executed.

See Also

UpdaterRegistry Class


UV Class

[image]

Revit 2013 API
UV Class
Members See Also Send Feedback
Object representing coordinates in 2-dimensional space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class UV
Visual Basic
Public Class UV
Visual C++
public ref class UV

Remarks

Usually this means parameters on a surface. In actual use, it could be interpreted as either point or vector in 2-dimensional space.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..UV

See Also

UV Members


UV Members

[image] [image]

Revit 2013 API
UV Members
UV Class Constructors Methods Operators Properties See Also Send Feedback

The UV type exposes the following members.

Constructors

 | Name | Description
Public method | UV()()()() | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

Properties

 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item | Indexed access to coordinates.
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class


UV Constructor

[image] [image]

Revit 2013 API
UV Constructor
UV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UV()()()() | Creates a default UV with the values (0, 0).
Public method | UV(Double, Double) | Creates a UV with the supplied coordinates.

See Also

UV Class
UV Members


UV Constructor

[image]

Revit 2013 API
UV Constructor
UV Class See Also Send Feedback
Creates a default UV with the values (0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV()
Visual Basic
Public Sub New
Visual C++
public:
UV()

See Also

UV Class
UV Overload


UV Constructor (Double, Double)

[image]

Revit 2013 API
UV Constructor (Double, Double)
UV Class See Also Send Feedback
Creates a UV with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV(
    double u,
    double v
)
Visual Basic
Public Sub New ( _
    u As Double, _
    v As Double _
)
Visual C++
public:
UV(
    double u,
    double v
)

Parameters

u
Type: System..::..Double
The first coordinate.
v
Type: System..::..Double
The second coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the U or V property.

See Also

UV Class
UV Overload


UV Methods

[image] [image]

Revit 2013 API
UV Methods
UV Class See Also Send Feedback

The UV type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified 2-D vector to this 2-D vector and returns the result.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this 2-D vector and the specified 2-D vector.
Public method | DistanceTo | Returns the distance from this 2-D point to the specified 2-D point.
Public method | Divide | Divides this 2-D vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this 2-D vector and the specified 2-D vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | The length of this 2-D vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.
Public method | IsUnitLength | The boolean value indicates whether this 2-D vector is of unit length.
Public method | IsZeroLength | The boolean value indicates whether this 2-D vector is a zero vector.
Public method | Multiply | Multiplies this 2-D vector by the specified value and returns the result.
Public method | Negate | Negates this 2-D vector.
Public method | Normalize | Returns a new UV whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified 2-D vector from this 2-D vector and returns the result.
Public method | ToString | Gets formatted string showing (U, V) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)

See Also

UV Class


Add Method

[image]

Revit 2013 API
UV..::..Add Method
UV Class See Also Send Feedback
Adds the specified 2-D vector to this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Add(
    UV source
)
Visual Basic
Public Function Add ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Add(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to add to this vector.

Return Value

The 2-D vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


AngleTo Method

[image]

Revit 2013 API
UV..::..AngleTo Method
UV Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AngleTo(
    UV source
)
Visual Basic
Public Function AngleTo ( _
    source As UV _
) As Double
Visual C++
public:
double AngleTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The specified vector.

Return Value

The real number between 0 and 2*PI equal to the angle between the two vectors in radians.

Remarks

The angle is measured counterclockwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


CrossProduct Method

[image]

Revit 2013 API
UV..::..CrossProduct Method
UV Class See Also Send Feedback
The cross product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CrossProduct(
    UV source
)
Visual Basic
Public Function CrossProduct ( _
    source As UV _
) As Double
Visual C++
public:
double CrossProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the cross product.

Remarks

The cross product of the two vectors in 2-D space is equivalent to the area of the parallelogram they span.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


DistanceTo Method

[image]

Revit 2013 API
UV..::..DistanceTo Method
UV Class See Also Send Feedback
Returns the distance from this 2-D point to the specified 2-D point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DistanceTo(
    UV source
)
Visual Basic
Public Function DistanceTo ( _
    source As UV _
) As Double
Visual C++
public:
double DistanceTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Divide Method

[image]

Revit 2013 API
UV..::..Divide Method
UV Class See Also Send Feedback
Divides this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Divide(
    double value
)
Visual Basic
Public Function Divide ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Divide(
    double value
)

Parameters

value
Type: System..::..Double
The value to divide this vector by.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is zero.

See Also

UV Class


DotProduct Method

[image]

Revit 2013 API
UV..::..DotProduct Method
UV Class See Also Send Feedback
The dot product of this 2-D vector and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DotProduct(
    UV source
)
Visual Basic
Public Function DotProduct ( _
    source As UV _
) As Double
Visual C++
public:
double DotProduct(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Pu * Ru + Pv * Rv.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


GetLength Method

[image]

Revit 2013 API
UV..::..GetLength Method
UV Class See Also Send Feedback
The length of this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetLength()
Visual Basic
Public Function GetLength As Double
Visual C++
public:
double GetLength()

Remarks

In 2-D Euclidean space, the length of the vector is the square root of the sum of the two coordinates squared.

See Also

UV Class


IsAlmostEqualTo Method

[image] [image]

Revit 2013 API
UV..::..IsAlmostEqualTo Method
UV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAlmostEqualTo(UV) | Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(UV, Double) | Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

See Also

UV Class
UV Members


IsAlmostEqualTo Method (UV)

[image]

Revit 2013 API
UV..::..IsAlmostEqualTo Method (UV)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    UV source
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As UV _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
IsAlmostEqualTo Overload


IsAlmostEqualTo Method (UV, Double)

[image]

Revit 2013 API
UV..::..IsAlmostEqualTo Method (UV, Double)
UV Class See Also Send Feedback
Determines whether this 2-D vector and the specified 2-D vector are the same within a specified tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    UV source,
    double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As UV, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    UV^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to compare with this vector.
tolerance
Type: System..::..Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when tolerance is less than 0.

See Also

UV Class
IsAlmostEqualTo Overload


IsUnitLength Method

[image]

Revit 2013 API
UV..::..IsUnitLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsUnitLength()
Visual Basic
Public Function IsUnitLength As Boolean
Visual C++
public:
bool IsUnitLength()

Remarks

A unit length vector has a length of one, and is considered normalized.

See Also

UV Class


IsZeroLength Method

[image]

Revit 2013 API
UV..::..IsZeroLength Method
UV Class See Also Send Feedback
The boolean value indicates whether this 2-D vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsZeroLength()
Visual Basic
Public Function IsZeroLength As Boolean
Visual C++
public:
bool IsZeroLength()

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

UV Class


Multiply Method

[image]

Revit 2013 API
UV..::..Multiply Method
UV Class See Also Send Feedback
Multiplies this 2-D vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Multiply(
    double value
)
Visual Basic
Public Function Multiply ( _
    value As Double _
) As UV
Visual C++
public:
UV^ Multiply(
    double value
)

Parameters

value
Type: System..::..Double
The value to multiply with this vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

UV Class


Negate Method

[image]

Revit 2013 API
UV..::..Negate Method
UV Class See Also Send Feedback
Negates this 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Negate()
Visual Basic
Public Function Negate As UV
Visual C++
public:
UV^ Negate()

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

UV Class


Normalize Method

[image]

Revit 2013 API
UV..::..Normalize Method
UV Class See Also Send Feedback
Returns a new UV whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Normalize()
Visual Basic
Public Function Normalize As UV
Visual C++
public:
UV^ Normalize()

Return Value

The normalized UV or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

UV Class


Subtract Method

[image]

Revit 2013 API
UV..::..Subtract Method
UV Class See Also Send Feedback
Subtracts the specified 2-D vector from this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public UV Subtract(
    UV source
)
Visual Basic
Public Function Subtract ( _
    source As UV _
) As UV
Visual C++
public:
UV^ Subtract(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV
The vector to subtract from this vector.

Return Value

The 2-D vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


ToString Method

[image]

Revit 2013 API
UV..::..ToString Method
UV Class See Also Send Feedback
Gets formatted string showing (U, V) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

UV Class


UV Operators

[image] [image]

Revit 2013 API
UV Operators
UV Class See Also Send Feedback

The UV type exposes the following members.

Operators

Name | Description
Addition | Adds the two specified 2-D vectors and returns the result.
Division | Divides the specified 2-D vector by the specified value.
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.
Subtraction | Subtracts the two specified 2-D vectors and returns the result.
UnaryNegation | Negates this 2-D vector and returns the result.

See Also

UV Class


Addition Operator

[image]

Revit 2013 API
UV..::..Addition Operator
UV Class See Also Send Feedback
Adds the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator +(
    UV left,
    UV right
)
Visual Basic
Public Shared Operator + ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator +(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The first vector.
right
Type: Autodesk.Revit.DB..::..UV
The second vector.

Return Value

The 2-D vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Division Operator

[image]

Revit 2013 API
UV..::..Division Operator
UV Class See Also Send Feedback
Divides the specified 2-D vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator /(
    UV left,
    double value
)
Visual Basic
Public Shared Operator / ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator /(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The value to divide the vector by.
value
Type: System..::..Double
The vector to divide by the value.

Return Value

The divided 2-D vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number or zero.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


Multiply Operator

[image] [image]

Revit 2013 API
UV..::..Multiply Operator
UV Class See Also Send Feedback

Overload List

Name | Description
Multiply(Double, UV) | The product of the specified number and the specified 2-D vector.
Multiply(UV, Double) | The product of the specified number and the specified 2-D vector.

See Also

UV Class
UV Members


Multiply Operator (Double, UV)

[image]

Revit 2013 API
UV..::..Multiply Operator (Double, UV)
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator *(
    double value,
    UV right
)
Visual Basic
Public Shared Operator * ( _
    value As Double, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator *(
    double value,
    UV^ right
)

Parameters

value
Type: System..::..Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with the value.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Multiply Operator (UV, Double)

[image]

Revit 2013 API
UV..::..Multiply Operator (UV, Double)
UV Class See Also Send Feedback
The product of the specified number and the specified 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator *(
    UV left,
    double value
)
Visual Basic
Public Shared Operator * ( _
    left As UV, _
    value As Double _
) As UV
Visual C++
public:
static UV^ operator *(
    UV^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The vector to multiply with the value.
value
Type: System..::..Double
The value to multiply with the specified vector.

Return Value

The multiplied 2-D vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class
Multiply Overload


Subtraction Operator

[image]

Revit 2013 API
UV..::..Subtraction Operator
UV Class See Also Send Feedback
Subtracts the two specified 2-D vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator -(
    UV left,
    UV right
)
Visual Basic
Public Shared Operator - ( _
    left As UV, _
    right As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ left,
    UV^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..UV
The first vector.
right
Type: Autodesk.Revit.DB..::..UV
The second vector.

Return Value

The 2-D vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


UnaryNegation Operator

[image]

Revit 2013 API
UV..::..UnaryNegation Operator
UV Class See Also Send Feedback
Negates this 2-D vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV operator -(
    UV source
)
Visual Basic
Public Shared Operator - ( _
    source As UV _
) As UV
Visual C++
public:
static UV^ operator -(
    UV^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..UV

Return Value

The 2-D vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UV Class


UV Properties

[image] [image]

Revit 2013 API
UV Properties
UV Class See Also Send Feedback

The UV type exposes the following members.

Properties

 | Name | Description
 | BasisU | The basis of the U axis.
 | BasisV | The basis of the V axis.
Public property | Item | Indexed access to coordinates.
Public property | U | Gets the first coordinate.
Public property | V | Gets the second coordinate.
 | Zero | The coordinate origin or zero 2-D vector.

See Also

UV Class


BasisU Property

[image]

Revit 2013 API
UV..::..BasisU Property
UV Class See Also Send Feedback
The basis of the U axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV BasisU { get; }
Visual Basic
Public Shared ReadOnly Property BasisU As UV
    Get
Visual C++
public:
static property UV^ BasisU {
    UV^ get ();
}

Remarks

The basis of the U axis is the vector (1,0), the unit vector on the U axis.

See Also

UV Class


BasisV Property

[image]

Revit 2013 API
UV..::..BasisV Property
UV Class See Also Send Feedback
The basis of the V axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV BasisV { get; }
Visual Basic
Public Shared ReadOnly Property BasisV As UV
    Get
Visual C++
public:
static property UV^ BasisV {
    UV^ get ();
}

Remarks

The basis of the V axis is the vector (0,1), the unit vector on the V axis.

See Also

UV Class


Item Property

[image]

Revit 2013 API
UV..::..Item Property
UV Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
    Get
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::..Int32
Use 0 for U and 1 for V.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an attempt is made to access coordinates with an index that is larger than 1.

See Also

UV Class


U Property

[image]

Revit 2013 API
UV..::..U Property
UV Class See Also Send Feedback
Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double U { get; }
Visual Basic
Public ReadOnly Property U As Double
    Get
Visual C++
public:
property double U {
    double get ();
}

See Also

UV Class


V Property

[image]

Revit 2013 API
UV..::..V Property
UV Class See Also Send Feedback
Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double V { get; }
Visual Basic
Public ReadOnly Property V As Double
    Get
Visual C++
public:
property double V {
    double get ();
}

See Also

UV Class


Zero Property

[image]

Revit 2013 API
UV..::..Zero Property
UV Class See Also Send Feedback
The coordinate origin or zero 2-D vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static UV Zero { get; }
Visual Basic
Public Shared ReadOnly Property Zero As UV
    Get
Visual C++
public:
static property UV^ Zero {
    UV^ get ();
}

Remarks

The zero vector is (0,0).

See Also

UV Class


ValueAtPointBase Class

[image]

Revit 2013 API
ValueAtPointBase Class
Members See Also Send Feedback
Base class for classes containing values for point. Stores a set of flags corresponding to a measurement: flag values combine bitwise flags defined in class ValueAtPointFlags

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ValueAtPointBase : IDisposable
Visual Basic
Public Class ValueAtPointBase _
    Implements IDisposable
Visual C++
public ref class ValueAtPointBase : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..ValueAtPoint
Autodesk.Revit.DB.Analysis..::..VectorAtPoint

See Also

ValueAtPointBase Members


ValueAtPointBase Members

[image] [image]

Revit 2013 API
ValueAtPointBase Members
ValueAtPointBase Class Methods See Also Send Feedback

The ValueAtPointBase type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements
Public method | ClearFlagsAt | Clears flags for the given measurement
Public method | Dispose | Releases all resources used by the ValueAtPointBase
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags
Public method | SetFlags(Int32) | Sets all flags using the value of one flag
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPointBase Class


ValueAtPointBase Methods

[image] [image]

Revit 2013 API
ValueAtPointBase Methods
ValueAtPointBase Class See Also Send Feedback

The ValueAtPointBase type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements
Public method | ClearFlagsAt | Clears flags for the given measurement
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags
Public method | SetFlags(Int32) | Sets all flags using the value of one flag
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPointBase Class


ClearAllFlags Method

[image]

Revit 2013 API
ValueAtPointBase..::..ClearAllFlags Method
ValueAtPointBase Class See Also Send Feedback
Clears flags for all measurements

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ClearAllFlags()
Visual Basic
Public Sub ClearAllFlags
Visual C++
public:
void ClearAllFlags()

See Also

ValueAtPointBase Class


ClearFlagsAt Method

[image]

Revit 2013 API
ValueAtPointBase..::..ClearFlagsAt Method
ValueAtPointBase Class See Also Send Feedback
Clears flags for the given measurement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ClearFlagsAt(
    int measurement
)
Visual Basic
Public Sub ClearFlagsAt ( _
    measurement As Integer _
)
Visual C++
public:
void ClearFlagsAt(
    int measurement
)

Parameters

measurement
Type: System..::..Int32
Measurement for which to clear flags

See Also

ValueAtPointBase Class


Dispose Method

[image]

Revit 2013 API
ValueAtPointBase..::..Dispose Method
ValueAtPointBase Class See Also Send Feedback
Releases all resources used by the ValueAtPointBase

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ValueAtPointBase Class


GetFlags Method

[image]

Revit 2013 API
ValueAtPointBase..::..GetFlags Method
ValueAtPointBase Class See Also Send Feedback
Returns flags for the given measurement

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetFlags(
    int measurement
)
Visual Basic
Public Function GetFlags ( _
    measurement As Integer _
) As Integer
Visual C++
public:
int GetFlags(
    int measurement
)

Parameters

measurement
Type: System..::..Int32
Measurement number for which flags are returned

See Also

ValueAtPointBase Class


SetFlags Method

[image] [image]

Revit 2013 API
ValueAtPointBase..::..SetFlags Method
ValueAtPointBase Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags
Public method | SetFlags(Int32) | Sets all flags using the value of one flag

See Also

ValueAtPointBase Class
ValueAtPointBase Members


SetFlags Method (IList(Int32))

[image]

Revit 2013 API
ValueAtPointBase..::..SetFlags Method (IList<(Of <(<'Int32>)>)>)
ValueAtPointBase Class See Also Send Feedback
Sets flags from an array of flags

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFlags(
    IList<int> flags
)
Visual Basic
Public Sub SetFlags ( _
    flags As IList(Of Integer) _
)
Visual C++
public:
void SetFlags(
    IList<int>^ flags
)

Parameters

flags
Type: System.Collections.Generic..::..IList<(Of <(<'Int32>)>)>
Array of flags, each member corresponding to measurement

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ValueAtPointBase Class
SetFlags Overload


SetFlags Method (Int32)

[image]

Revit 2013 API
ValueAtPointBase..::..SetFlags Method (Int32)
ValueAtPointBase Class See Also Send Feedback
Sets all flags using the value of one flag

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFlags(
    int flags
)
Visual Basic
Public Sub SetFlags ( _
    flags As Integer _
)
Visual C++
public:
void SetFlags(
    int flags
)

Parameters

flags
Type: System..::..Int32
Value of flags, uniform for all measurements

See Also

ValueAtPointBase Class
SetFlags Overload


ValueAtPointFlags Enumeration

[image]

Revit 2013 API
ValueAtPointFlags Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum ValueAtPointFlags
Visual Basic
Public Enumeration ValueAtPointFlags
Visual C++
public enum class ValueAtPointFlags

Members

Member name | Description
DisplayText |
DisplayFence |

See Also


VertexIndexPair Class

[image]

Revit 2013 API
VertexIndexPair Class
Members See Also Send Feedback
Represents a connection between vertices in the top and bottom profile of a blend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VertexIndexPair
Visual Basic
Public Class VertexIndexPair
Visual C++
public ref class VertexIndexPair

Remarks

Use objects of this type in GetVertexConnectionMap()()()(), SetVertexConnectionMap(VertexIndexPairArray), GetVertexConnectionMap()()()() and SetVertexConnectionMap(VertexIndexPairArray) to get/set the vertex connection map.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VertexIndexPair

See Also

VertexIndexPair Members


VertexIndexPair Members

[image] [image]

Revit 2013 API
VertexIndexPair Members
VertexIndexPair Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPair type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPair | Initializes a new instance of the VertexIndexPair class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


VertexIndexPair Constructor

[image]

Revit 2013 API
VertexIndexPair Constructor
VertexIndexPair Class See Also Send Feedback
Initializes a new instance of the VertexIndexPair class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPair(
    int iTop,
    int iBottom
)
Visual Basic
Public Sub New ( _
    iTop As Integer, _
    iBottom As Integer _
)
Visual C++
public:
VertexIndexPair(
    int iTop,
    int iBottom
)

Parameters

iTop
Type: System..::..Int32
iBottom
Type: System..::..Int32

See Also

VertexIndexPair Class


VertexIndexPair Methods

[image] [image]

Revit 2013 API
VertexIndexPair Methods
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPair Class


VertexIndexPair Properties

[image] [image]

Revit 2013 API
VertexIndexPair Properties
VertexIndexPair Class See Also Send Feedback

The VertexIndexPair type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | The index of the vertex pair from the bottom profile.
Public property | Top | The index of the vertex pair from the top profile.

See Also

VertexIndexPair Class


Bottom Property

[image]

Revit 2013 API
VertexIndexPair..::..Bottom Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the bottom profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Bottom { get; set; }
Visual Basic
Public Property Bottom As Integer
    Get
    Set
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


Top Property

[image]

Revit 2013 API
VertexIndexPair..::..Top Property
VertexIndexPair Class See Also Send Feedback
The index of the vertex pair from the top profile.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Top { get; set; }
Visual Basic
Public Property Top As Integer
    Get
    Set
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

VertexIndexPair Class


VertexIndexPairArray Class

[image]

Revit 2013 API
VertexIndexPairArray Class
Members See Also Send Feedback
An array that contains VertexIndex pairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VertexIndexPairArray : APIObject,
    IEnumerable
Visual Basic
Public Class VertexIndexPairArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VertexIndexPairArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..VertexIndexPairArray

See Also

VertexIndexPairArray Members


VertexIndexPairArray Members

[image] [image]

Revit 2013 API
VertexIndexPairArray Members
VertexIndexPairArray Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPairArray | Initializes a new instance of the VertexIndexPairArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class


VertexIndexPairArray Constructor

[image]

Revit 2013 API
VertexIndexPairArray Constructor
VertexIndexPairArray Class See Also Send Feedback
Initializes a new instance of the VertexIndexPairArray class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPairArray()
Visual Basic
Public Sub New
Visual C++
public:
VertexIndexPairArray()

See Also

VertexIndexPairArray Class


VertexIndexPairArray Methods

[image] [image]

Revit 2013 API
VertexIndexPairArray Methods
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every VertexIndex pair from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArray Class


Append Method

[image]

Revit 2013 API
VertexIndexPairArray..::..Append Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    VertexIndexPair item
)
Visual Basic
Public Overridable Sub Append ( _
    item As VertexIndexPair _
)
Visual C++
public:
virtual void Append(
    VertexIndexPair^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..VertexIndexPair

See Also

VertexIndexPairArray Class


Clear Method

[image]

Revit 2013 API
VertexIndexPairArray..::..Clear Method
VertexIndexPairArray Class See Also Send Feedback
Removes every VertexIndex pair from the array, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VertexIndexPairArray Class


ForwardIterator Method

[image]

Revit 2013 API
VertexIndexPairArray..::..ForwardIterator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

VertexIndexPairArray Class


GetEnumerator Method

[image]

Revit 2013 API
VertexIndexPairArray..::..GetEnumerator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VertexIndexPairArray Class


Insert Method

[image]

Revit 2013 API
VertexIndexPairArray..::..Insert Method
VertexIndexPairArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    VertexIndexPair item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As VertexIndexPair, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    VertexIndexPair^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB..::..VertexIndexPair
index
Type: System..::..Int32

See Also

VertexIndexPairArray Class


ReverseIterator Method

[image]

Revit 2013 API
VertexIndexPairArray..::..ReverseIterator Method
VertexIndexPairArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual VertexIndexPairArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As VertexIndexPairArrayIterator
Visual C++
public:
virtual VertexIndexPairArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

VertexIndexPairArray Class


VertexIndexPairArray Properties

[image] [image]

Revit 2013 API
VertexIndexPairArray Properties
VertexIndexPairArray Class See Also Send Feedback

The VertexIndexPairArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a VertexIndex pair at a specified index within the array.
Public property | Size | Returns the number of VertexIndex pairs that are in the array.

See Also

VertexIndexPairArray Class


IsEmpty Property

[image]

Revit 2013 API
VertexIndexPairArray..::..IsEmpty Property
VertexIndexPairArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

VertexIndexPairArray Class


Item Property

[image]

Revit 2013 API
VertexIndexPairArray..::..Item Property
VertexIndexPairArray Class See Also Send Feedback
Gets or sets a VertexIndex pair at a specified index within the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual VertexIndexPair this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As VertexIndexPair
    Get
    Set
Visual C++
public:
virtual property VertexIndexPair^ Item[int index] {
    VertexIndexPair^ get (int index);
    void set (int index, VertexIndexPair^ value);
}

Parameters

index
Type: System..::..Int32
The index of the VertexIndex pair to be set or retrieved.

Return Value

Returns the VertexIndex pair at the specified index.

See Also

VertexIndexPairArray Class


Size Property

[image]

Revit 2013 API
VertexIndexPairArray..::..Size Property
VertexIndexPairArray Class See Also Send Feedback
Returns the number of VertexIndex pairs that are in the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VertexIndexPairArray Class


VertexIndexPairArrayIterator Class

[image]

Revit 2013 API
VertexIndexPairArrayIterator Class
Members See Also Send Feedback
An iterator to an array of VertexIndex pairs.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class VertexIndexPairArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class VertexIndexPairArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VertexIndexPairArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..VertexIndexPairArrayIterator

See Also

VertexIndexPairArrayIterator Members


VertexIndexPairArrayIterator Members

[image] [image]

Revit 2013 API
VertexIndexPairArrayIterator Members
VertexIndexPairArrayIterator Class Constructors Methods Properties See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | VertexIndexPairArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Constructor

[image]

Revit 2013 API
VertexIndexPairArrayIterator Constructor
VertexIndexPairArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VertexIndexPairArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
VertexIndexPairArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Methods

[image] [image]

Revit 2013 API
VertexIndexPairArrayIterator Methods
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexIndexPairArrayIterator Class


MoveNext Method

[image]

Revit 2013 API
VertexIndexPairArrayIterator..::..MoveNext Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


Reset Method

[image]

Revit 2013 API
VertexIndexPairArrayIterator..::..Reset Method
VertexIndexPairArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VertexIndexPairArrayIterator Class


VertexIndexPairArrayIterator Properties

[image] [image]

Revit 2013 API
VertexIndexPairArrayIterator Properties
VertexIndexPairArrayIterator Class See Also Send Feedback

The VertexIndexPairArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VertexIndexPairArrayIterator Class


Current Property

[image]

Revit 2013 API
VertexIndexPairArrayIterator..::..Current Property
VertexIndexPairArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VertexIndexPairArrayIterator Class


VertexPair Class

[image]

Revit 2013 API
VertexPair Class
Members See Also Send Feedback
Indices of a pair of vertices in two CurveLoops(one vertex in each loop).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class VertexPair : IDisposable
Visual Basic
Public Class VertexPair _
    Implements IDisposable
Visual C++
public ref class VertexPair : IDisposable

Remarks

A vertex is specified by the index in the CurveLoop of the curve having that vertex as its start point. Indexes start at 0.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VertexPair

See Also

VertexPair Members


VertexPair Members

[image] [image]

Revit 2013 API
VertexPair Members
VertexPair Class Constructors Methods Properties See Also Send Feedback

The VertexPair type exposes the following members.

Constructors

 | Name | Description
Public method | VertexPair | Initializes a new instance of the VertexPair class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the VertexPair
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | Second | Identifies the second index of VertexPair.

See Also

VertexPair Class


VertexPair Constructor

[image]

Revit 2013 API
VertexPair Constructor
VertexPair Class See Also Send Feedback
Initializes a new instance of the VertexPair class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)
Visual Basic
Public Sub New ( _
    firstVertexIdx As Integer, _
    secondVertexIdx As Integer _
)
Visual C++
public:
VertexPair(
    int firstVertexIdx,
    int secondVertexIdx
)

Parameters

firstVertexIdx
Type: System..::..Int32
secondVertexIdx
Type: System..::..Int32

See Also

VertexPair Class


VertexPair Methods

[image] [image]

Revit 2013 API
VertexPair Methods
VertexPair Class See Also Send Feedback

The VertexPair type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexPair Class


Dispose Method

[image]

Revit 2013 API
VertexPair..::..Dispose Method
VertexPair Class See Also Send Feedback
Releases all resources used by the VertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

VertexPair Class


VertexPair Properties

[image] [image]

Revit 2013 API
VertexPair Properties
VertexPair Class See Also Send Feedback

The VertexPair type exposes the following members.

Properties

 | Name | Description
Public property | First | Identifies the first index of VertexPair.
Public property | Second | Identifies the second index of VertexPair.

See Also

VertexPair Class


First Property

[image]

Revit 2013 API
VertexPair..::..First Property
VertexPair Class See Also Send Feedback
Identifies the first index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int First { get; set; }
Visual Basic
Public Property First As Integer
    Get
    Set
Visual C++
public:
property int First {
    int get ();
    void set (int value);
}

See Also

VertexPair Class


Second Property

[image]

Revit 2013 API
VertexPair..::..Second Property
VertexPair Class See Also Send Feedback
Identifies the second index of VertexPair.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Second { get; set; }
Visual Basic
Public Property Second As Integer
    Get
    Set
Visual C++
public:
property int Second {
    int get ();
    void set (int value);
}

See Also

VertexPair Class


VerticalAlignmentStyle Enumeration

[image]

Revit 2013 API
VerticalAlignmentStyle Enumeration
See Also Send Feedback
Declares the vertical alignment style of font.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum VerticalAlignmentStyle
Visual Basic
Public Enumeration VerticalAlignmentStyle
Visual C++
public enum class VerticalAlignmentStyle

Members

Member name | Description
Top | Alignment to top
Middle | Alignment to middle
Bottom | Alignment to bottom

See Also


View Class

[image]

Revit 2013 API
View Class
Members Example See Also Send Feedback
Base class for all types of views in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class View : Element
Visual Basic
Public Class View _
    Inherits Element
Visual C++
public ref class View : public Element

Remarks

A view can display an image produced from a Revit model. Views can be graphical (e.g. plans, elevations, or 3D views) or textual (e.g. schedules). Views keep track of Elements that can be seen in them.

Examples

CopyC#
private void Getinfo_View(Autodesk.Revit.DB.View view)
{
    string message = "View: ";

    //get the name of the view
    message += "\nView name: " + view.ViewName;

    //The crop box sets display bounds of the view
    BoundingBoxXYZ cropBox = view.CropBox;
    XYZ max = cropBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = cropBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nCrop Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

   //get the origin of the screen
    XYZ origin = view.Origin;
    message += "\nOrigin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")";

    //The bounds of the view in paper space (in inches).
    BoundingBoxUV outline = view.Outline;
    UV maxUv = outline.Max; //Maximum coordinates (upper-right corner of the box).
    UV minUv = outline.Min; //Minimum coordinates (lower-left corner of the box).
    message += "\nOutline: ";
    message += "\nMaximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")";
    message += "\nMinimum coordinates: (" + minUv.U + ", " + minUv.V + ")";

    //The direction towards the right side of the screen
    XYZ rightDirection = view.RightDirection;
    message += "\nRight direction: (" + rightDirection.X + ", " +
                   rightDirection.Y + ", " + rightDirection.Z + ")";

    //The direction towards the top of the screen
    XYZ upDirection = view.UpDirection;
    message += "\nUp direction: (" + upDirection.X + ", " +
                   upDirection.Y + ", " + upDirection.Z + ")";

    //The direction towards the viewer
    XYZ viewDirection = view.ViewDirection;
    message += "\nView direction: (" + viewDirection.X + ", " +
                   viewDirection.Y + ", " + viewDirection.Z + ")";

    //The scale of the view
    message += "\nScale: " + view.Scale;
    // Scale is meaningless for Schedules
    if (view.ViewType != ViewType.Schedule)
    {
        int testScale = 5;
        //set the scale of the view
        view.Scale = testScale;
        message += "\nScale after set: " + view.Scale;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_View(ByVal view As Autodesk.Revit.DB.View)
    Dim message As String = "View: "

    'get the name of the view
    message += vbLf & "View name: " + view.ViewName

    'The crop box sets display bounds of the view
    Dim cropBox As BoundingBoxXYZ = view.CropBox
    Dim max As Autodesk.Revit.DB.XYZ = cropBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.DB.XYZ = cropBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Crop Box: "
    message += vbLf & "Maximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")"
    message += vbLf & "Minimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")"

    'get the origin of the screen
    Dim origin As Autodesk.Revit.DB.XYZ = view.Origin
    message += vbLf & "Origin: (" + origin.X + ", " + origin.Y + ", " + origin.Z + ")"

    'The bounds of the view in paper space (in inches).
    Dim outline As BoundingBoxUV = view.Outline
    Dim maxUv As Autodesk.Revit.DB.UV = outline.Max
    'Maximum coordinates (upper-right corner of the box).
    Dim minUv As Autodesk.Revit.DB.UV = outline.Min
    'Minimum coordinates (lower-left corner of the box).
    message += vbLf & "Outline: "
    message += vbLf & "Maximum coordinates: (" + maxUv.U + ", " + maxUv.V + ")"
    message += vbLf & "Minimum coordinates: (" + minUv.U + ", " + minUv.V + ")"

    'The direction towards the right side of the screen
    Dim rightDirection As Autodesk.Revit.DB.XYZ = view.RightDirection
    message += vbLf & "Right direction: (" + rightDirection.X + ", " + rightDirection.Y + ", " + rightDirection.Z + ")"

    'The direction towards the top of the screen
    Dim upDirection As Autodesk.Revit.DB.XYZ = view.UpDirection
    message += vbLf & "Up direction: (" + upDirection.X + ", " + upDirection.Y + ", " + upDirection.Z + ")"

    'The direction towards the viewer
    Dim viewDirection As Autodesk.Revit.DB.XYZ = view.ViewDirection
    message += vbLf & "View direction: (" + viewDirection.X + ", " + viewDirection.Y + ", " + viewDirection.Z + ")"

    'The scale of the view
    message += vbLf & "Scale: " + view.Scale
    ' Scale is meaningless for Schedules
    If view.ViewType <> Autodesk.Revit.DB.ViewType.Schedule Then
        Dim testScale As Integer = 5
        'set the scale of the view
        view.Scale = testScale
        message += vbLf & "Scale after set: " + view.Scale
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..TableView
Autodesk.Revit.DB..::..View3D
Autodesk.Revit.DB..::..ViewDrafting
Autodesk.Revit.DB..::..ViewPlan
Autodesk.Revit.DB..::..ViewSchedule
Autodesk.Revit.DB..::..ViewSection
Autodesk.Revit.DB..::..ViewSheet

See Also

View Members


View Members

[image] [image]

Revit 2013 API
View Members
View Class Methods Properties See Also Send Feedback

The View type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Checks if the view can be duplicated
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | Hide | Obsolete. Sets the elements to be hidden in the view.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view.
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored).
Public method | setVisibility | Set if elements of the given category will be visible in this view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds.
Public property | ViewType | The type of the view.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View Class


View Methods

[image] [image]

Revit 2013 API
View Methods
View Class See Also Send Feedback

The View type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view.
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view.
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified.
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified.
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes
Public method | CanViewBeDuplicated | Checks if the view can be duplicated
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode.
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode.
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view.
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view.
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view.
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view.
Public method | HasDetailLevel | Check if the view has a Detail Level property
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property
Public method | Hide | Obsolete. Sets the elements to be hidden in the view.
Public method | HideActiveWorkPlane | Hide the active work plane of the view.
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view.
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view.
Public method | HideElements | Sets the elements to be hidden in the view.
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view.
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view.
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view.
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view.
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view.
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model.
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidViewScale | This validator checks that the view scale is in the allowable range.
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view.
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored).
Public method | setVisibility | Set if elements of the given category will be visible in this view.
Public method | SetWorksetVisibility | Sets visibility for a workset in this view.
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view.
Public method | ShowActiveWorkPlane | Show the active work plane of the view.
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden.
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden.

See Also

View Class


ApplyTemplate Method

[image]

Revit 2013 API
View..::..ApplyTemplate Method
View Class See Also Send Feedback
Applies a view template to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")]
public void ApplyTemplate(
    View viewTemplate
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")> _
Public Sub ApplyTemplate ( _
    viewTemplate As View _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Use property ViewTemplateId or call Revit.DB.View.ApplyViewTemplateParameters(Autodesk.Revit.DB.View viewTemplate) instead.")]
public:
void ApplyTemplate(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
View to be used as the template.

See Also

View Class


ApplyViewTemplateParameters Method

[image]

Revit 2013 API
View..::..ApplyViewTemplateParameters Method
View Class See Also Send Feedback
Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ApplyViewTemplateParameters(
    View otherView
)
Visual Basic
Public Sub ApplyViewTemplateParameters ( _
    otherView As View _
)
Visual C++
public:
void ApplyViewTemplateParameters(
    View^ otherView
)

Parameters

otherView
Type: Autodesk.Revit.DB..::..View
View whose parameters are to be applied to this view. It does not have to be a valid template (property IsTemplate can be true or false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


CanCategoryBeHiddenTemporary Method

[image]

Revit 2013 API
View..::..CanCategoryBeHiddenTemporary Method
View Class See Also Send Feedback
Check if category can be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanCategoryBeHiddenTemporary(
    ElementId elementId
)
Visual Basic
Public Function CanCategoryBeHiddenTemporary ( _
    elementId As ElementId _
) As Boolean
Visual C++
public:
bool CanCategoryBeHiddenTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category to be checked

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


CanModifyDetailLevel Method

[image]

Revit 2013 API
View..::..CanModifyDetailLevel Method
View Class See Also Send Feedback
Check if Detail Level can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanModifyDetailLevel()
Visual Basic
Public Function CanModifyDetailLevel As Boolean
Visual C++
public:
bool CanModifyDetailLevel()

Return Value

True if Detail Level can be modified.

See Also

View Class


CanModifyDisplayStyle Method

[image]

Revit 2013 API
View..::..CanModifyDisplayStyle Method
View Class See Also Send Feedback
Indicates if DisplayStyle can be modified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanModifyDisplayStyle()
Visual Basic
Public Function CanModifyDisplayStyle As Boolean
Visual C++
public:
bool CanModifyDisplayStyle()

Return Value

True if DisplayStyle can be modified.

See Also

View Class


CanModifyViewDiscipline Method

[image]

Revit 2013 API
View..::..CanModifyViewDiscipline Method
View Class See Also Send Feedback
Indicates if the View Discipline can be modified

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanModifyViewDiscipline()
Visual Basic
Public Function CanModifyViewDiscipline As Boolean
Visual C++
public:
bool CanModifyViewDiscipline()

Return Value

True if View Discipline can be modified

See Also

View Class


CanUseTemporaryVisibilityModes Method

[image]

Revit 2013 API
View..::..CanUseTemporaryVisibilityModes Method
View Class See Also Send Feedback
Indicates if view can use temporary visibility modes

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanUseTemporaryVisibilityModes()
Visual Basic
Public Function CanUseTemporaryVisibilityModes As Boolean
Visual C++
public:
bool CanUseTemporaryVisibilityModes()

Return Value

True if view can use temporary visibility modes

See Also

View Class


CanViewBeDuplicated Method

[image]

Revit 2013 API
View..::..CanViewBeDuplicated Method
View Class See Also Send Feedback
Checks if the view can be duplicated

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)
Visual Basic
Public Function CanViewBeDuplicated ( _
    duplicateOption As ViewDuplicateOption _
) As Boolean
Visual C++
public:
bool CanViewBeDuplicated(
    ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..ViewDuplicateOption
The manner in which the view will be duplicated

Return Value

True if the view can be duplicated

See Also

View Class


ConvertTemporaryHideIsolateToPermanent Method

[image]

Revit 2013 API
View..::..ConvertTemporaryHideIsolateToPermanent Method
View Class See Also Send Feedback
Convert all temporary hidden elements or categories to permanently hidden in view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ConvertTemporaryHideIsolateToPermanent()
Visual Basic
Public Sub ConvertTemporaryHideIsolateToPermanent
Visual C++
public:
void ConvertTemporaryHideIsolateToPermanent()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | This View is an internal element, such as a component of a loaded family or a group type. -or- The document containing this View is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This View is a member of a group or sketch, and the document is not currently editing the group or sketch.

See Also

View Class


DisableTemporaryViewMode Method

[image]

Revit 2013 API
View..::..DisableTemporaryViewMode Method
View Class See Also Send Feedback
Disables the specified temporary view mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void DisableTemporaryViewMode(
    TemporaryViewMode mode
)
Visual Basic
Public Sub DisableTemporaryViewMode ( _
    mode As TemporaryViewMode _
)
Visual C++
public:
void DisableTemporaryViewMode(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode to disable.

Remarks

Has no effect if the mode is already disabled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot use temporary visibility modes.

See Also

View Class


Duplicate Method

[image]

Revit 2013 API
View..::..Duplicate Method
View Class See Also Send Feedback
Duplicates the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Duplicate(
    ViewDuplicateOption duplicateOption
)
Visual Basic
Public Function Duplicate ( _
    duplicateOption As ViewDuplicateOption _
) As ElementId
Visual C++
public:
ElementId^ Duplicate(
    ViewDuplicateOption duplicateOption
)

Parameters

duplicateOption
Type: Autodesk.Revit.DB..::..ViewDuplicateOption

Return Value

The id of the newly created view

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot be duplicated

See Also

View Class


EnableRevealHiddenMode Method

[image]

Revit 2013 API
View..::..EnableRevealHiddenMode Method
View Class See Also Send Feedback
Enables Reveal Hidden elements mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void EnableRevealHiddenMode()
Visual Basic
Public Sub EnableRevealHiddenMode
Visual C++
public:
void EnableRevealHiddenMode()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot use temporary visibility modes.

See Also

View Class


EnableTemporaryAnalyticalDisplayMode Method

[image]

Revit 2013 API
View..::..EnableTemporaryAnalyticalDisplayMode Method
View Class See Also Send Feedback
Enables temporary display of Analytical Model categories only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void EnableTemporaryAnalyticalDisplayMode()
Visual Basic
Public Sub EnableTemporaryAnalyticalDisplayMode
Visual C++
public:
void EnableTemporaryAnalyticalDisplayMode()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot use temporary visibility modes.

See Also

View Class


GetDependentViewIds Method

[image]

Revit 2013 API
View..::..GetDependentViewIds Method
View Class See Also Send Feedback
Get the ids of dependent views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetDependentViewIds()
Visual Basic
Public Function GetDependentViewIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDependentViewIds()

Return Value

Ids of the dependent views.

See Also

View Class


GetNonControlledTemplateParameterIds Method

[image]

Revit 2013 API
View..::..GetNonControlledTemplateParameterIds Method
View Class See Also Send Feedback
Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetNonControlledTemplateParameterIds()
Visual Basic
Public Function GetNonControlledTemplateParameterIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetNonControlledTemplateParameterIds()

See Also

View Class


GetPrimaryViewId Method

[image]

Revit 2013 API
View..::..GetPrimaryViewId Method
View Class See Also Send Feedback
Get the id of the primary view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetPrimaryViewId()
Visual Basic
Public Function GetPrimaryViewId As ElementId
Visual C++
public:
ElementId^ GetPrimaryViewId()

Return Value

The id of the primary view, or InvalidElementId if there is no primary view.

Remarks

The primary view is the view from which a dependent view is created.

See Also

View Class


GetTemplateParameterIds Method

[image]

Revit 2013 API
View..::..GetTemplateParameterIds Method
View Class See Also Send Feedback
Returns list of parameters that may be controlled when this view is used as a template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetTemplateParameterIds()
Visual Basic
Public Function GetTemplateParameterIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetTemplateParameterIds()

See Also

View Class


getVisibility Method

[image]

Revit 2013 API
View..::..getVisibility Method
View Class See Also Send Feedback
Checks if elements of the given category are set to be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool getVisibility(
    Category category
)
Visual Basic
Public Function getVisibility ( _
    category As Category _
) As Boolean
Visual C++
public:
bool getVisibility(
    Category^ category
)

Parameters

category
Type: Autodesk.Revit.DB..::..Category
The category.

See Also

View Class


GetWorksetVisibility Method

[image]

Revit 2013 API
View..::..GetWorksetVisibility Method
View Class See Also Send Feedback
Returns the visibility settings of a workset for this particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetVisibility GetWorksetVisibility(
    WorksetId worksetId
)
Visual Basic
Public Function GetWorksetVisibility ( _
    worksetId As WorksetId _
) As WorksetVisibility
Visual C++
public:
WorksetVisibility GetWorksetVisibility(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.

Return Value

The visibility of a workset for this particular view.

Remarks

The settings does not reflect the fact of whether a workset is currently closed or not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


GetWorksharingDisplayMode Method

[image]

Revit 2013 API
View..::..GetWorksharingDisplayMode Method
View Class See Also Send Feedback
Gets the current worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WorksharingDisplayMode GetWorksharingDisplayMode()
Visual Basic
Public Function GetWorksharingDisplayMode As WorksharingDisplayMode
Visual C++
public:
WorksharingDisplayMode GetWorksharingDisplayMode()

Return Value

The active worksharing display mode in this view.

Remarks

Returns "Off" if no worksharing display mode is currently enabled.

See Also

View Class


HasDetailLevel Method

[image]

Revit 2013 API
View..::..HasDetailLevel Method
View Class See Also Send Feedback
Check if the view has a Detail Level property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasDetailLevel()
Visual Basic
Public Function HasDetailLevel As Boolean
Visual C++
public:
bool HasDetailLevel()

Return Value

True if the view has a Detail Level, false otherwise

See Also

View Class


HasDisplayStyle Method

[image]

Revit 2013 API
View..::..HasDisplayStyle Method
View Class See Also Send Feedback
Indicates if view has a DisplayStyle property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasDisplayStyle()
Visual Basic
Public Function HasDisplayStyle As Boolean
Visual C++
public:
bool HasDisplayStyle()

Return Value

True if view has a DisplayStyle property

See Also

View Class


HasViewDiscipline Method

[image]

Revit 2013 API
View..::..HasViewDiscipline Method
View Class See Also Send Feedback
Indicates if the view has a Discipline property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasViewDiscipline()
Visual Basic
Public Function HasViewDiscipline As Boolean
Visual C++
public:
bool HasViewDiscipline()

Return Value

True if the view has a Discipline property

See Also

View Class


Hide Method

[image]

Revit 2013 API
View..::..Hide Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call HideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")]
public void Hide(
    ElementSet elemSet
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call HideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")> _
Public Sub Hide ( _
    elemSet As ElementSet _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call HideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")]
public:
void Hide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents. To hide a group, obtain the elements in the group from Members, and hide these elements individually. To hide an array, obtain the groups in the array from OrigMembers and CopyMembers, then hide elements in the groups individually.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


HideActiveWorkPlane Method

[image]

Revit 2013 API
View..::..HideActiveWorkPlane Method
View Class See Also Send Feedback
Hide the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void HideActiveWorkPlane()
Visual Basic
Public Sub HideActiveWorkPlane
Visual C++
public:
void HideActiveWorkPlane()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.

See Also

View Class


HideCategoriesTemporary Method

[image]

Revit 2013 API
View..::..HideCategoriesTemporary Method
View Class See Also Send Feedback
Set multiple categories to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void HideCategoriesTemporary(
    IList<ElementId> elementIds
)
Visual Basic
Public Sub HideCategoriesTemporary ( _
    elementIds As IList(Of ElementId) _
)
Visual C++
public:
void HideCategoriesTemporary(
    IList<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of the categories to be hidden

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some elements in elementIds do not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


HideCategoryTemporary Method

[image]

Revit 2013 API
View..::..HideCategoryTemporary Method
View Class See Also Send Feedback
Set one category to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void HideCategoryTemporary(
    ElementId elementId
)
Visual Basic
Public Sub HideCategoryTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void HideCategoryTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of the category to be hidden

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


HideElements Method

[image]

Revit 2013 API
View..::..HideElements Method
View Class See Also Send Feedback
Sets the elements to be hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void HideElements(
    ICollection<ElementId> elementIdSet
)
Visual Basic
Public Sub HideElements ( _
    elementIdSet As ICollection(Of ElementId) _
)
Visual C++
public:
void HideElements(
    ICollection<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of ElementIds to be hidden.

Remarks

This change is permanent until the elements are unhidden. All elements in the set must be currently unhidden and must be allowed to be hidden. An application can check this with IsHidden(View) and CanBeHidden(View).

Some elements cannot be hidden directly. Examples include: group, array, constraint, edit cut profile, face splitter and link to external documents. To hide a group, obtain the elements in the group from Members, and hide these elements individually. To hide an array, obtain the groups in the array from OrigMembers and CopyMembers, then hide elements in the groups individually.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be hidden is empty or one of the elements can not be hidden. Also thrown when the set of elements to be hidden includes the view itself.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


HideElementsTemporary Method

[image]

Revit 2013 API
View..::..HideElementsTemporary Method
View Class See Also Send Feedback
Set multiple elements to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void HideElementsTemporary(
    IList<ElementId> elementIdSet
)
Visual Basic
Public Sub HideElementsTemporary ( _
    elementIdSet As IList(Of ElementId) _
)
Visual C++
public:
void HideElementsTemporary(
    IList<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of the elements to be temporarily hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


HideElementTemporary Method

[image]

Revit 2013 API
View..::..HideElementTemporary Method
View Class See Also Send Feedback
Set one element to be temporarily hidden in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void HideElementTemporary(
    ElementId elementId
)
Visual Basic
Public Sub HideElementTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void HideElementTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element to be temporarily hidden.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsElementVisibleInTemporaryViewMode Method

[image]

Revit 2013 API
View..::..IsElementVisibleInTemporaryViewMode Method
View Class See Also Send Feedback
Identifies if the input element is visible for the temporary view mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId id
)
Visual Basic
Public Function IsElementVisibleInTemporaryViewMode ( _
    mode As TemporaryViewMode, _
    id As ElementId _
) As Boolean
Visual C++
public:
bool IsElementVisibleInTemporaryViewMode(
    TemporaryViewMode mode,
    ElementId^ id
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported by this option. Other modes will result in an exception.
id
Type: Autodesk.Revit.DB..::..ElementId
The element id.

Return Value

True if the element is visible, false if the element is hidden in the view mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view mode is not supported for checking element visibility.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsInTemporaryViewMode Method

[image]

Revit 2013 API
View..::..IsInTemporaryViewMode Method
View Class See Also Send Feedback
Returns true if the view is in a particular temporary view mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)
Visual Basic
Public Function IsInTemporaryViewMode ( _
    mode As TemporaryViewMode _
) As Boolean
Visual C++
public:
bool IsInTemporaryViewMode(
    TemporaryViewMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..TemporaryViewMode
The mode.

Return Value

True if this view is in the temporary view mode indicated, false otherwise.

See Also

View Class


IsolateCategoriesTemporary Method

[image]

Revit 2013 API
View..::..IsolateCategoriesTemporary Method
View Class See Also Send Feedback
Set categories to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void IsolateCategoriesTemporary(
    IList<ElementId> elementIds
)
Visual Basic
Public Sub IsolateCategoriesTemporary ( _
    elementIds As IList(Of ElementId) _
)
Visual C++
public:
void IsolateCategoriesTemporary(
    IList<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of categories to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some elements in elementIds do not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsolateCategoryTemporary Method

[image]

Revit 2013 API
View..::..IsolateCategoryTemporary Method
View Class See Also Send Feedback
Set one category to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void IsolateCategoryTemporary(
    ElementId elementId
)
Visual Basic
Public Sub IsolateCategoryTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void IsolateCategoryTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of category to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | elementId does not correspond to a Category.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsolateElementsTemporary Method

[image]

Revit 2013 API
View..::..IsolateElementsTemporary Method
View Class See Also Send Feedback
Set multiple elements to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void IsolateElementsTemporary(
    IList<ElementId> elementIds
)
Visual Basic
Public Sub IsolateElementsTemporary ( _
    elementIds As IList(Of ElementId) _
)
Visual C++
public:
void IsolateElementsTemporary(
    IList<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Ids of elements to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsolateElementTemporary Method

[image]

Revit 2013 API
View..::..IsolateElementTemporary Method
View Class See Also Send Feedback
Set one element to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void IsolateElementTemporary(
    ElementId elementId
)
Visual Basic
Public Sub IsolateElementTemporary ( _
    elementId As ElementId _
)
Visual C++
public:
void IsolateElementTemporary(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Id of element to be isolated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsTemporaryAnalyticalModeActive Method

[image]

Revit 2013 API
View..::..IsTemporaryAnalyticalModeActive Method
View Class See Also Send Feedback
Indicates if the view is temporarily displaying only the Analytical model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsTemporaryAnalyticalModeActive()
Visual Basic
Public Function IsTemporaryAnalyticalModeActive As Boolean
Visual C++
public:
bool IsTemporaryAnalyticalModeActive()

Return Value

True if temporary analytical mode is active, false otherwise.

See Also

View Class


IsTemporaryHideIsolateActive Method

[image]

Revit 2013 API
View..::..IsTemporaryHideIsolateActive Method
View Class See Also Send Feedback
Indicates if the view is temporarily hiding or isolating elements or categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsTemporaryHideIsolateActive()
Visual Basic
Public Function IsTemporaryHideIsolateActive As Boolean
Visual C++
public:
bool IsTemporaryHideIsolateActive()

Return Value

True if elements/categories are being temporarily hidden or isolated, false otherwise.

See Also

View Class


IsValidViewScale Method

[image]

Revit 2013 API
View..::..IsValidViewScale Method
View Class See Also Send Feedback
This validator checks that the view scale is in the allowable range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidViewScale(
    int viewScale
)
Visual Basic
Public Shared Function IsValidViewScale ( _
    viewScale As Integer _
) As Boolean
Visual C++
public:
static bool IsValidViewScale(
    int viewScale
)

Parameters

viewScale
Type: System..::..Int32
The denominator X in the view scale 1/X.

Return Value

True if the view scale is within the allowable range, false otherwise.

Remarks

The view scale is expressed as 1/X, where X is an integer the range 1 to 24,000.

See Also

View Class


IsValidViewTemplate Method

[image]

Revit 2013 API
View..::..IsValidViewTemplate Method
View Class See Also Send Feedback
Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidViewTemplate(
    ElementId templateId
)
Visual Basic
Public Function IsValidViewTemplate ( _
    templateId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidViewTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
Id to be validated as view template.

Return Value

True if %templateId% is valid as view template, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


IsWorksetVisible Method

[image]

Revit 2013 API
View..::..IsWorksetVisible Method
View Class See Also Send Feedback
Indicates whether the workset is visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsWorksetVisible(
    WorksetId worksetId
)
Visual Basic
Public Function IsWorksetVisible ( _
    worksetId As WorksetId _
) As Boolean
Visual C++
public:
bool IsWorksetVisible(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.

Return Value

Whether the workset is visible.

Remarks

It will take into account whether the workset is opened or closed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


Print Method

[image] [image]

Revit 2013 API
View..::..Print Method
View Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document.
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document.
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.

See Also

View Class
View Members


Print Method

[image]

Revit 2013 API
View..::..Print Method
View Class See Also Send Feedback
Print this view with the default view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print()
Visual Basic
Public Sub Print
Visual C++
public:
void Print()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (Boolean)

[image]

Revit 2013 API
View..::..Print Method (Boolean)
View Class See Also Send Feedback
Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    bool useCurrentPrintSettings
)

Parameters

useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View)

[image]

Revit 2013 API
View..::..Print Method (View)
View Class See Also Send Feedback
Print this view with the given view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    View viewTemplate
)
Visual Basic
Public Sub Print ( _
    viewTemplate As View _
)
Visual C++
public:
void Print(
    View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


Print Method (View, Boolean)

[image]

Revit 2013 API
View..::..Print Method (View, Boolean)
View Class See Also Send Feedback
Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Print(
    View viewTemplate,
    bool useCurrentPrintSettings
)
Visual Basic
Public Sub Print ( _
    viewTemplate As View, _
    useCurrentPrintSettings As Boolean _
)
Visual C++
public:
void Print(
    View^ viewTemplate,
    bool useCurrentPrintSettings
)

Parameters

viewTemplate
Type: Autodesk.Revit.DB..::..View
The view template which apply to the view.
useCurrentPrintSettings
Type: System..::..Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the view cannot be printed.

See Also

View Class
Print Overload


SetNonControlledTemplateParameterIds Method

[image]

Revit 2013 API
View..::..SetNonControlledTemplateParameterIds Method
View Class See Also Send Feedback
Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetNonControlledTemplateParameterIds(
    ICollection<ElementId> newSet
)
Visual Basic
Public Sub SetNonControlledTemplateParameterIds ( _
    newSet As ICollection(Of ElementId) _
)
Visual C++
public:
void SetNonControlledTemplateParameterIds(
    ICollection<ElementId^>^ newSet
)

Parameters

newSet
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


setVisibility Method

[image]

Revit 2013 API
View..::..setVisibility Method
View Class See Also Send Feedback
Set if elements of the given category will be visible in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void setVisibility(
    Category category,
    bool visible
)
Visual Basic
Public Sub setVisibility ( _
    category As Category, _
    visible As Boolean _
)
Visual C++
public:
void setVisibility(
    Category^ category,
    bool visible
)

Parameters

category
Type: Autodesk.Revit.DB..::..Category
The category.
visible
Type: System..::..Boolean
True to make elements of this category visible, false to make them invisible.

See Also

View Class


SetWorksetVisibility Method

[image]

Revit 2013 API
View..::..SetWorksetVisibility Method
View Class See Also Send Feedback
Sets visibility for a workset in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetWorksetVisibility(
    WorksetId worksetId,
    WorksetVisibility visible
)
Visual Basic
Public Sub SetWorksetVisibility ( _
    worksetId As WorksetId, _
    visible As WorksetVisibility _
)
Visual C++
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    WorksetVisibility visible
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
visible
Type: Autodesk.Revit.DB..::..WorksetVisibility
The visibility of the workset.

Remarks

It works even when the workset is closed. This settings overrules implicit visibility of the workset (for this particular view only).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document associated with this view.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View Class


SetWorksharingDisplayMode Method

[image]

Revit 2013 API
View..::..SetWorksharingDisplayMode Method
View Class See Also Send Feedback
Sets the worksharing display mode for this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)
Visual Basic
Public Sub SetWorksharingDisplayMode ( _
    displayMode As WorksharingDisplayMode _
)
Visual C++
public:
void SetWorksharingDisplayMode(
    WorksharingDisplayMode displayMode
)

Parameters

displayMode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The desired display mode. "Off" will turn off all worksharing display modes.

Remarks

Turning on a worksharing display mode will disable other temporary view modes such as reveal hidden elements and temporary hide/isolate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View does not support the requested worksharing display mode.

See Also

View Class


ShowActiveWorkPlane Method

[image]

Revit 2013 API
View..::..ShowActiveWorkPlane Method
View Class See Also Send Feedback
Show the active work plane of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ShowActiveWorkPlane()
Visual Basic
Public Sub ShowActiveWorkPlane
Visual C++
public:
void ShowActiveWorkPlane()

Remarks

If this method is invoked while the current work plane is hidden, only the outline of the updated work plane will be shown immediately. The updated sketch plane will be shown fully after the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is no active sketch plane, or when an error occurs during setting the sketch plane visibility.

See Also

View Class


SupportsWorksharingDisplayMode Method

[image]

Revit 2013 API
View..::..SupportsWorksharingDisplayMode Method
View Class See Also Send Feedback
Checks whether this view supports the given worksharing display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)
Visual Basic
Public Function SupportsWorksharingDisplayMode ( _
    mode As WorksharingDisplayMode _
) As Boolean
Visual C++
public:
bool SupportsWorksharingDisplayMode(
    WorksharingDisplayMode mode
)

Parameters

mode
Type: Autodesk.Revit.DB..::..WorksharingDisplayMode
The mode of interest.

Return Value

Returns True if this view is a graphical view in a workshared document or if the desired mode is Off. Returns False if this view is a non-graphical view (such as a schedule or the project browser) or if this view is not in a workshared document.

Remarks

For convenience, the "Off" mode is always supported. Other display modes are supported by graphical views in workshared documents.

See Also

View Class


Unhide Method

[image]

Revit 2013 API
View..::..Unhide Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2013. Call UnhideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")]
public void Unhide(
    ElementSet elemSet
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2013. Call UnhideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")> _
Public Sub Unhide ( _
    elemSet As ElementSet _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2013. Call UnhideElements(System::Collections::Generic::ICollection<Autodesk::Revit::DB::ElementId^>^ elementIdSet) instead.")]
public:
void Unhide(
    ElementSet^ elemSet
)

Parameters

elemSet
Type: Autodesk.Revit.DB..::..ElementSet
A set of elements to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


UnhideElements Method

[image]

Revit 2013 API
View..::..UnhideElements Method
View Class See Also Send Feedback
Sets the elements to be shown in the given view if they are currently hidden.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UnhideElements(
    ICollection<ElementId> elementIdSet
)
Visual Basic
Public Sub UnhideElements ( _
    elementIdSet As ICollection(Of ElementId) _
)
Visual C++
public:
void UnhideElements(
    ICollection<ElementId^>^ elementIdSet
)

Parameters

elementIdSet
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of ElementIds to be unhidden.

Remarks

This change is permanent until the elements are hidden again. All elements in the set must be currently hidden. An application can check this with IsHidden(View).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when argument is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the set of elements to be unhidden is empty or one of the elements can not be unhidden.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when document regeneration failed.

See Also

View Class


View Properties

[image] [image]

Revit 2013 API
View Properties
View Class See Also Send Feedback

The View type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view.
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view.
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view.
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view.
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view.
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view.
Public property | Discipline | The Discipline of the view.
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen.
Public property | Outline | The bounds of the view in paper space (in inches).
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view.
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view.
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view.
Public property | RightDirection | The direction towards the right side of the screen.
Public property | Scale | The scale of the view.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation.
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen.
Public property | ViewDirection | The direction towards the viewer.
Public property | ViewName | The name of the view.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds.
Public property | ViewType | The type of the view.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View Class


AnalysisDisplayStyleId Property

[image]

Revit 2013 API
View..::..AnalysisDisplayStyleId Property
View Class See Also Send Feedback
Element id of Analysis Display Style associated with the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId AnalysisDisplayStyleId { get; set; }
Visual Basic
Public Property AnalysisDisplayStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

View Class


AssociatedAssemblyInstanceId Property

[image]

Revit 2013 API
View..::..AssociatedAssemblyInstanceId Property
View Class See Also Send Feedback
The Id of the assembly instance that owns the assembly view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AssociatedAssemblyInstanceId { get; }
Visual Basic
Public ReadOnly Property AssociatedAssemblyInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ AssociatedAssemblyInstanceId {
    ElementId^ get ();
}

Field Value

The assembly instance id, or InvalidElementId if the view is not an assembly view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

View Class


CanBePrinted Property

[image]

Revit 2013 API
View..::..CanBePrinted Property
View Class See Also Send Feedback
Test whether the view can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CanBePrinted { get; }
Visual Basic
Public ReadOnly Property CanBePrinted As Boolean
    Get
Visual C++
public:
property bool CanBePrinted {
    bool get ();
}

See Also

View Class


CropBox Property

[image]

Revit 2013 API
View..::..CropBox Property
View Class See Also Send Feedback
The crop box applied to the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ CropBox { get; set; }
Visual Basic
Public Property CropBox As BoundingBoxXYZ
    Get
    Set
Visual C++
public:
property BoundingBoxXYZ^ CropBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the view is a template.

Remarks

The X direction of the box is right on screen; Y, up; Z, towards the user.

See Also

View Class


CropBoxActive Property

[image]

Revit 2013 API
View..::..CropBoxActive Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is active for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CropBoxActive { get; set; }
Visual Basic
Public Property CropBoxActive As Boolean
    Get
    Set
Visual C++
public:
property bool CropBoxActive {
    bool get ();
    void set (bool value);
}

Remarks

Identifies whether the crop region modifies the graphical appearance of elements in the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


CropBoxVisible Property

[image]

Revit 2013 API
View..::..CropBoxVisible Property
View Class See Also Send Feedback
Whether or not the Crop Box/Region is visible for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CropBoxVisible { get; set; }
Visual Basic
Public Property CropBoxVisible As Boolean
    Get
    Set
Visual C++
public:
property bool CropBoxVisible {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and cannot have a crop box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a crop box applied.

See Also

View Class


CutColorOverrideByElement Property

[image]

Revit 2013 API
View..::..CutColorOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' color by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property CutColorOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Color
    Get
    Set
Visual C++
public:
property Color^ CutColorOverrideByElement[ICollection<ElementId^>^ ids] {
    Color^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, Color^ value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


CutLinePatternOverrideByElement Property

[image]

Revit 2013 API
View..::..CutLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' pattern by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternElement this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property CutLinePatternOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As LinePatternElement
    Get
    Set
Visual C++
public:
property LinePatternElement^ CutLinePatternOverrideByElement[ICollection<ElementId^>^ ids] {
    LinePatternElement^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, LinePatternElement^ value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


CutLineWeightOverrideByElement Property

[image]

Revit 2013 API
View..::..CutLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the cut lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property CutLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
    Get
    Set
Visual C++
public:
property int CutLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class


DetailLevel Property

[image]

Revit 2013 API
View..::..DetailLevel Property
View Class See Also Send Feedback
The detail level of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewDetailLevel DetailLevel { get; set; }
Visual Basic
Public Property DetailLevel As ViewDetailLevel
    Get
    Set
Visual C++
public:
property ViewDetailLevel DetailLevel {
    ViewDetailLevel get ();
    void set (ViewDetailLevel value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Cannot set ViewDetailLevel to Unassigned
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View does not have a Detail Level property -or- When setting this property: Detail Level cannot be modified.

See Also

View Class


Discipline Property

[image]

Revit 2013 API
View..::..Discipline Property
View Class See Also Send Feedback
The Discipline of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewDiscipline Discipline { get; set; }
Visual Basic
Public Property Discipline As ViewDiscipline
    Get
    Set
Visual C++
public:
property ViewDiscipline Discipline {
    ViewDiscipline get ();
    void set (ViewDiscipline value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View must have a Discipline property -or- When setting this property: View Discipline must be modifiable.

See Also

View Class


DisplayStyle Property

[image]

Revit 2013 API
View..::..DisplayStyle Property
View Class See Also Send Feedback
The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DisplayStyle DisplayStyle { get; set; }
Visual Basic
Public Property DisplayStyle As DisplayStyle
    Get
    Set
Visual C++
public:
property DisplayStyle DisplayStyle {
    DisplayStyle get ();
    void set (DisplayStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: DisplayStyle cannot be set to Raytrace. Because setting a view's display style to raytrace enters a special restricted mode with limited capabilities, it is not permitted to directly assign the display style to this value. -or- When setting this property: DisplayStyle cannot be set to Undefined. -or- When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: DisplayStyle cannot be modified. -or- When setting this property: View does not have a DisplayStyle property.

See Also

View Class


GenLevel Property

[image]

Revit 2013 API
View..::..GenLevel Property
View Class See Also Send Feedback
The level for the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level GenLevel { get; }
Visual Basic
Public ReadOnly Property GenLevel As Level
    Get
Visual C++
public:
property Level^ GenLevel {
    Level^ get ();
}

Remarks

This will obtain the level for views related to levels, such as Plan Views. If this View is not generated by a level, this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

View Class


IsTemplate Property

[image]

Revit 2013 API
View..::..IsTemplate Property
View Class See Also Send Feedback
Test whether the view is a view template.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsTemplate { get; }
Visual Basic
Public ReadOnly Property IsTemplate As Boolean
    Get
Visual C++
public:
property bool IsTemplate {
    bool get ();
}

See Also

View Class


Origin Property

[image]

Revit 2013 API
View..::..Origin Property
View Class See Also Send Feedback
Returns the origin of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Origin { get; }
Visual Basic
Public ReadOnly Property Origin As XYZ
    Get
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
}

Field Value

nullNothingnullptra null reference (Nothing in Visual Basic) if the view is a template.

See Also

View Class


Outline Property

[image]

Revit 2013 API
View..::..Outline Property
View Class See Also Send Feedback
The bounds of the view in paper space (in inches).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxUV Outline { get; }
Visual Basic
Public ReadOnly Property Outline As BoundingBoxUV
    Get
Visual C++
public:
property BoundingBoxUV^ Outline {
    BoundingBoxUV^ get ();
}

Remarks

Returns all zeros for empty views.

See Also

View Class


Parameter Property

[image] [image]

Revit 2013 API
View..::..Parameter Property
View Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

View Class
View Members


PartsVisibility Property

[image]

Revit 2013 API
View..::..PartsVisibility Property
View Class See Also Send Feedback
The visibility setting for parts in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PartsVisibility PartsVisibility { get; set; }
Visual Basic
Public Property PartsVisibility As PartsVisibility
    Get
    Set
Visual C++
public:
property PartsVisibility PartsVisibility {
    PartsVisibility get ();
    void set (PartsVisibility value);
}

See Also

View Class


ProjColorOverrideByElement Property

[image]

Revit 2013 API
View..::..ProjColorOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' color by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Color this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property ProjColorOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Color
    Get
    Set
Visual C++
public:
property Color^ ProjColorOverrideByElement[ICollection<ElementId^>^ ids] {
    Color^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, Color^ value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The override color of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


ProjLinePatternOverrideByElement Property

[image]

Revit 2013 API
View..::..ProjLinePatternOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' pattern by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LinePatternElement this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property ProjLinePatternOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As LinePatternElement
    Get
    Set
Visual C++
public:
property LinePatternElement^ ProjLinePatternOverrideByElement[ICollection<ElementId^>^ ids] {
    LinePatternElement^ get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, LinePatternElement^ value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. nullNothingnullptra null reference (Nothing in Visual Basic) indicates that no override should be applied.

See Also

View Class


ProjLineWeightOverrideByElement Property

[image]

Revit 2013 API
View..::..ProjLineWeightOverrideByElement Property
View Class See Also Send Feedback
Override the projection lines' weight by Element in this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int this[
    ICollection<ElementId> ids
] { get; set; }
Visual Basic
Public Property ProjLineWeightOverrideByElement ( _
    ids As ICollection(Of ElementId) _
) As Integer
    Get
    Set
Visual C++
public:
property int ProjLineWeightOverrideByElement[ICollection<ElementId^>^ ids] {
    int get (ICollection<ElementId^>^ ids);
    void set (ICollection<ElementId^>^ ids, int value);
}

Parameters

ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A set of element ids for the elements that are to be overridden.

Field Value

The line pattern of the elements that are to be overridden. A negative value indicates that no override should be applied.

See Also

View Class


RightDirection Property

[image]

Revit 2013 API
View..::..RightDirection Property
View Class See Also Send Feedback
The direction towards the right side of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ RightDirection { get; }
Visual Basic
Public ReadOnly Property RightDirection As XYZ
    Get
Visual C++
public:
property XYZ^ RightDirection {
    XYZ^ get ();
}

See Also

View Class


Scale Property

[image]

Revit 2013 API
View..::..Scale Property
View Class See Also Send Feedback
The scale of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Scale { get; set; }
Visual Basic
Public Property Scale As Integer
    Get
    Set
Visual C++
public:
property int Scale {
    int get ();
    void set (int value);
}

Remarks

The scale is the ratio of true model size to paper size. This property is meaningless for perspective views. When setting the scale if the scale corresponds to a predefined scale, the predefined item will be applied. Otherwise, a custom scale will be applied.

See Also

View Class


SketchPlane Property

[image]

Revit 2013 API
View..::..SketchPlane Property
View Class See Also Send Feedback
The sketch plane assigned to the view for model curve creation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SketchPlane SketchPlane { get; set; }
Visual Basic
Public Property SketchPlane As SketchPlane
    Get
    Set
Visual C++
public:
property SketchPlane^ SketchPlane {
    SketchPlane^ get ();
    void set (SketchPlane^ value);
}

Field Value

The sketch plane, or nullNothingnullptra null reference (Nothing in Visual Basic) for views which don't allow sketching (such as schedules) or for views that allow model curve creation but have no current sketch plane assigned.

Remarks

If this property is set in when the current work plane is visible, the updated work plane will not be shown until the current transaction is committed. Therefore it is recommended the Add-On commits the transaction before performing UI operations (for example, PickPoint).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the property to a sketch plane that cannot be used to create model elements, or when the input sketch plane is orthogonal to the view orientation.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting the property to a view that does not permit model curve creation, or when other errors occur.

See Also

View Class


SunAndShadowSettings Property

[image]

Revit 2013 API
View..::..SunAndShadowSettings Property
View Class See Also Send Feedback
The sun and shadow settings assigned to the view for shadow calculation and rendering.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SunAndShadowSettings SunAndShadowSettings { get; }
Visual Basic
Public ReadOnly Property SunAndShadowSettings As SunAndShadowSettings
    Get
Visual C++
public:
property SunAndShadowSettings^ SunAndShadowSettings {
    SunAndShadowSettings^ get ();
}

Field Value

The sun and shadow settings, or null for views which don't allow this (such as schedules).

See Also

View Class


UpDirection Property

[image]

Revit 2013 API
View..::..UpDirection Property
View Class See Also Send Feedback
The direction towards the top of the screen.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

View Class


ViewDirection Property

[image]

Revit 2013 API
View..::..ViewDirection Property
View Class See Also Send Feedback
The direction towards the viewer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ ViewDirection { get; }
Visual Basic
Public ReadOnly Property ViewDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ViewDirection {
    XYZ^ get ();
}

Remarks

In orthographic views, all objects are projected onto the screen along this direction. In perspective views, the view target point is projected along this direction, but other points are projected towards the eye along different vectors.

See Also

View Class


ViewName Property

[image]

Revit 2013 API
View..::..ViewName Property
View Class See Also Send Feedback
The name of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ViewName { get; set; }
Visual Basic
Public Property ViewName As String
    Get
    Set
Visual C++
public:
property String^ ViewName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the name provided already exists, or is invalid for this view.

See Also

View Class


ViewTemplateId Property

[image]

Revit 2013 API
View..::..ViewTemplateId Property
View Class See Also Send Feedback
Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewTemplateId { get; set; }
Visual Basic
Public Property ViewTemplateId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ViewTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as view template id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

View Class


ViewType Property

[image]

Revit 2013 API
View..::..ViewType Property
View Class Example See Also Send Feedback
The type of the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewType ViewType { get; }
Visual Basic
Public ReadOnly Property ViewType As ViewType
    Get
Visual C++
public:
property ViewType ViewType {
    ViewType get ();
}

Examples

CopyC#
public void GetViewType(Autodesk.Revit.DB.View view)
{
    // Get the view type of the given view, and format the prompt string
    String prompt = "The view is ";

    switch (view.ViewType)
    {
        case ViewType.AreaPlan:
            prompt += "an area view.";
            break;
        case ViewType.CeilingPlan:
            prompt += "a reflected ceiling plan view.";
            break;
        case ViewType.ColumnSchedule:
            prompt += "a column schedule view.";
            break;
        case ViewType.CostReport:
            prompt += "a cost report view.";
            break;
        case ViewType.Detail:
            prompt += "a detail view.";
            break;
        case ViewType.DraftingView:
            prompt += "a drafting view.";
            break;
        case ViewType.DrawingSheet:
            prompt += "a drawing sheet view.";
            break;
        case ViewType.Elevation:
            prompt += "an elevation view.";
            break;
        case ViewType.EngineeringPlan:
            prompt += "an engineering view.";
            break;
        case ViewType.FloorPlan:
            prompt += "afloor plan view.";
            break;
        case ViewType.Internal:
            prompt += "Revit's internal view.";
            break;
        case ViewType.Legend:
            prompt += "a legend view.";
            break;
        case ViewType.LoadsReport:
            prompt += "a loads report view.";
            break;
        case ViewType.PanelSchedule:
            prompt += "a panel schedule view.";
            break;
        case ViewType.PresureLossReport:
            prompt += "a pressure loss report view.";
            break;
        case ViewType.Rendering:
            prompt += "a rendering view.";
            break;
        case ViewType.Report:
            prompt += "a report view.";
            break;
        case ViewType.Schedule:
            prompt += "a schedule view.";
            break;
        case ViewType.Section:
            prompt += "a cross section view.";
            break;
        case ViewType.ThreeD:
            prompt += "a 3-D view.";
            break;
        case ViewType.Undefined:
            prompt += "an undefined/unspecified view.";
            break;
        case ViewType.Walkthrough:
            prompt += "a walkthrough view.";
            break;
        default:
            break;
    }

    // Give the user some information
    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Public Sub GetViewType(ByVal view As Autodesk.Revit.DB.View)
    ' Get the view type of the given view, and format the prompt string
    Dim prompt As [String] = "The view is "

    Select Case view.ViewType
        Case Autodesk.Revit.DB.ViewType.AreaPlan
            prompt += "an area view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CeilingPlan
            prompt += "a reflected ceiling plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ColumnSchedule
            prompt += "a column schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.CostReport
            prompt += "a cost report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Detail
            prompt += "a detail view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DraftingView
            prompt += "a drafting view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.DrawingSheet
            prompt += "a drawing sheet view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Elevation
            prompt += "an elevation view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.EngineeringPlan
            prompt += "an engineering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.FloorPlan
            prompt += "afloor plan view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Internal
            prompt += "Revit's internal view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Legend
            prompt += "a legend view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.LoadsReport
            prompt += "a loads report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PanelSchedule
            prompt += "a panel schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.PresureLossReport
            prompt += "a pressure loss report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Rendering
            prompt += "a rendering view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Report
            prompt += "a report view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Schedule
            prompt += "a schedule view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Section
            prompt += "a cross section view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.ThreeD
            prompt += "a 3-D view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Undefined
            prompt += "an undefined/unspecified view."
            Exit Select
        Case Autodesk.Revit.DB.ViewType.Walkthrough
            prompt += "a walkthrough view."
            Exit Select
        Case Else
            Exit Select
    End Select

    ' Give the user some information
    TaskDialog.Show("Revit", prompt)
End Sub

See Also

View Class


View3D Class

[image]

Revit 2013 API
View3D Class
Members Example See Also Send Feedback
Class for 3D views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class View3D : View
Visual Basic
Public Class View3D _
    Inherits View
Visual C++
public ref class View3D : public View

Examples

CopyC#
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";
    // The position of the camera.
    XYZ eyePosition = view3D.EyePosition;
    message += "\nCamera position: (" + eyePosition.X + ", " +
                eyePosition.Y + ", " + eyePosition.Z + ")";

    // Identifies whether this is a perspective view.
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective.";
    }

    // The section box of the 3D view cuts the model by its bounds.
    BoundingBoxXYZ sectionBox = view3D.SectionBox;
    XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box).
    XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box).
    message += "\nSection Box: ";
    message += "\nMaximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")";
    message += "\nMinimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_View3D(ByVal view3D As View3D)
    Dim message As String = "View3D: "
    ' The position of the camera.
    Dim eyePosition As Autodesk.Revit.DB.XYZ = view3D.EyePosition
    message += vbLf & "Camera position: (" + eyePosition.X + ", " + eyePosition.Y + ", " + eyePosition.Z + ")"

    ' Identifies whether this is a perspective view.
    If view3D.IsPerspective Then
        message += vbLf & "The view is a perspective."
    End If

    ' The section box of the 3D view cuts the model by its bounds.
    Dim sectionBox As BoundingBoxXYZ = view3D.SectionBox
    Dim max As Autodesk.Revit.DB.XYZ = sectionBox.Max
    'Maximum coordinates (upper-right-front corner of the box).
    Dim min As Autodesk.Revit.DB.XYZ = sectionBox.Min
    'Minimum coordinates (lower-left-rear corner of the box).
    message += vbLf & "Section Box: "
    message += vbLf & "Maximum coordinates: (" + max.X + ", " + max.Y + ", " + max.Z + ")"
    message += vbLf & "Minimum coordinates: (" + min.X + ", " + min.Y + ", " + min.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..View3D

See Also

View3D Members


View3D Members

[image] [image]

Revit 2013 API
View3D Members
View3D Class Methods Properties See Also Send Feedback

The View3D type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EyePosition | Obsolete. The position of the camera.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SectionBox | The section box of the 3D view cuts the model by its bounds.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View3D Class


View3D Methods

[image] [image]

Revit 2013 API
View3D Methods
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanSaveOrientation | Returns true if the View3D's orientation can be saved, false otherwise.
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateIsometric | Returns a new isometric View3D.
 | CreatePerspective | Returns a new perspective View3D.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetOrientation | Gets the current non-saved orientation of the View3D.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetRenderingSettings | Returns the current rendering settings for this 3d view.
Public method | GetSavedOrientation | Gets the saved orientation of the View3D.
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasBeenLocked | Identifies if the view has ever been locked.
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RestoreOrientationAndLock | Locks the view and restores its orientation.
Public method | SaveOrientation | Converts the temporary orientation of the View3D into its saved orientation.
Public method | SaveOrientationAndLock | Locks the view and saves its orientation
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetOrientation | Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method | SetRenderingSettings | Changes the rendering settings for this 3d view.
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | Unlock | Unlocks the view. Has no effect if the view is already unlocked.

See Also

View3D Class


CanSaveOrientation Method

[image]

Revit 2013 API
View3D..::..CanSaveOrientation Method
View3D Class See Also Send Feedback
Returns true if the View3D's orientation can be saved, false otherwise.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanSaveOrientation()
Visual Basic
Public Function CanSaveOrientation As Boolean
Visual C++
public:
bool CanSaveOrientation()

Return Value

True if the View3D's orientation can be saved, false otherwise.

Remarks

The saved orientation of the default 3D view cannot be overwritten. To convert the default 3D view into a normal 3D view, rename the default 3D view.

See Also

View3D Class


CreateIsometric Method

[image]

Revit 2013 API
View3D..::..CreateIsometric Method
View3D Class See Also Send Feedback
Returns a new isometric View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static View3D CreateIsometric(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function CreateIsometric ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As View3D
Visual C++
public:
static View3D^ CreateIsometric(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new View3D will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

The new isometric View3D.

Remarks

The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

View3D Class


CreatePerspective Method

[image]

Revit 2013 API
View3D..::..CreatePerspective Method
View3D Class See Also Send Feedback
Returns a new perspective View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static View3D CreatePerspective(
    Document document,
    ElementId viewFamilyTypeId
)
Visual Basic
Public Shared Function CreatePerspective ( _
    document As Document, _
    viewFamilyTypeId As ElementId _
) As View3D
Visual C++
public:
static View3D^ CreatePerspective(
    Document^ document,
    ElementId^ viewFamilyTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new View3D will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.

Return Value

The new perspective View3D.

Remarks

The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

View3D Class


GetOrientation Method

[image]

Revit 2013 API
View3D..::..GetOrientation Method
View3D Class See Also Send Feedback
Gets the current non-saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewOrientation3D GetOrientation()
Visual Basic
Public Function GetOrientation As ViewOrientation3D
Visual C++
public:
ViewOrientation3D^ GetOrientation()

Return Value

The current non-saved orientation of the View3D.

See Also

View3D Class


GetRenderingSettings Method

[image]

Revit 2013 API
View3D..::..GetRenderingSettings Method
View3D Class See Also Send Feedback
Returns the current rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RenderingSettings GetRenderingSettings()
Visual Basic
Public Function GetRenderingSettings As RenderingSettings
Visual C++
public:
RenderingSettings^ GetRenderingSettings()

Return Value

The returned object represents the current rendering settings. If you change the returned object, you need to call SetRenderingSettings to apply the new settings back to Revit.

See Also

View3D Class


GetSavedOrientation Method

[image]

Revit 2013 API
View3D..::..GetSavedOrientation Method
View3D Class See Also Send Feedback
Gets the saved orientation of the View3D.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewOrientation3D GetSavedOrientation()
Visual Basic
Public Function GetSavedOrientation As ViewOrientation3D
Visual C++
public:
ViewOrientation3D^ GetSavedOrientation()

Return Value

The saved orientation of the View3D.

See Also

View3D Class


HasBeenLocked Method

[image]

Revit 2013 API
View3D..::..HasBeenLocked Method
View3D Class See Also Send Feedback
Identifies if the view has ever been locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasBeenLocked()
Visual Basic
Public Function HasBeenLocked As Boolean
Visual C++
public:
bool HasBeenLocked()

See Also

View3D Class


Print Method

[image] [image]

Revit 2013 API
View3D..::..Print Method
View3D Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

View3D Class
View3D Members


RestoreOrientationAndLock Method

[image]

Revit 2013 API
View3D..::..RestoreOrientationAndLock Method
View3D Class See Also Send Feedback
Locks the view and restores its orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RestoreOrientationAndLock()
Visual Basic
Public Sub RestoreOrientationAndLock
Visual C++
public:
void RestoreOrientationAndLock()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View has never been locked.

See Also

View3D Class


SaveOrientation Method

[image]

Revit 2013 API
View3D..::..SaveOrientation Method
View3D Class See Also Send Feedback
Converts the temporary orientation of the View3D into its saved orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SaveOrientation()
Visual Basic
Public Sub SaveOrientation
Visual C++
public:
void SaveOrientation()

Remarks

The View3D will be oriented to its saved orientation on file open. To save the orientation of the default View3D, first rename the default View3D.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The orientation of the View3D cannot be saved.

See Also

View3D Class


SaveOrientationAndLock Method

[image]

Revit 2013 API
View3D..::..SaveOrientationAndLock Method
View3D Class See Also Send Feedback
Locks the view and saves its orientation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SaveOrientationAndLock()
Visual Basic
Public Sub SaveOrientationAndLock
Visual C++
public:
void SaveOrientationAndLock()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot be a template view. -or- The orientation of the View3D cannot be saved.

See Also

View3D Class


SetOrientation Method

[image]

Revit 2013 API
View3D..::..SetOrientation Method
View3D Class See Also Send Feedback
Sets the temporary orientation of the View3D. The new orientation is not saved in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetOrientation(
    ViewOrientation3D newViewOrientation3D
)
Visual Basic
Public Sub SetOrientation ( _
    newViewOrientation3D As ViewOrientation3D _
)
Visual C++
public:
void SetOrientation(
    ViewOrientation3D^ newViewOrientation3D
)

Parameters

newViewOrientation3D
Type: Autodesk.Revit.DB..::..ViewOrientation3D
The new orientation to set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is locked and cannot be reoriented.

See Also

View3D Class


SetRenderingSettings Method

[image]

Revit 2013 API
View3D..::..SetRenderingSettings Method
View3D Class See Also Send Feedback
Changes the rendering settings for this 3d view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetRenderingSettings(
    RenderingSettings settings
)
Visual Basic
Public Sub SetRenderingSettings ( _
    settings As RenderingSettings _
)
Visual C++
public:
void SetRenderingSettings(
    RenderingSettings^ settings
)

Parameters

settings
Type: Autodesk.Revit.DB..::..RenderingSettings
The new rendering settings to be applied to this view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

View3D Class


Unlock Method

[image]

Revit 2013 API
View3D..::..Unlock Method
View3D Class See Also Send Feedback
Unlocks the view. Has no effect if the view is already unlocked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Unlock()
Visual Basic
Public Sub Unlock
Visual C++
public:
void Unlock()

See Also

View3D Class


View3D Properties

[image] [image]

Revit 2013 API
View3D Properties
View3D Class See Also Send Feedback

The View3D type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EyePosition | Obsolete. The position of the camera.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsLocked | Indicates if the view is locked.
Public property | IsPerspective | Identifies whether this is a perspective view.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SectionBox | The section box of the 3D view cuts the model by its bounds.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

View3D Class


EyePosition Property

[image]

Revit 2013 API
View3D..::..EyePosition Property
View3D Class See Also Send Feedback
The position of the camera.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")]
public XYZ EyePosition { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")> _
Public ReadOnly Property EyePosition As XYZ
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use ViewOrientation3D.EyePosition or View.Origin instead.")]
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The view is a template and does not have an eye position applied.

See Also

View3D Class


IsLocked Property

[image]

Revit 2013 API
View3D..::..IsLocked Property
View3D Class See Also Send Feedback
Indicates if the view is locked.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As Boolean
    Get
Visual C++
public:
property bool IsLocked {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | View cannot be a template view.

See Also

View3D Class


IsPerspective Property

[image]

Revit 2013 API
View3D..::..IsPerspective Property
View3D Class See Also Send Feedback
Identifies whether this is a perspective view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPerspective { get; }
Visual Basic
Public ReadOnly Property IsPerspective As Boolean
    Get
Visual C++
public:
property bool IsPerspective {
    bool get ();
}

Remarks

If this is false, the view is orthographic - the view direction is constant. In a perspective view, view direction is variable - it is the direction that connects a particular point on the model with the eye position. The view direction property becomes less meaningful - it only describes the general orientation of the camera.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The view is a template and does not have a perspective setting applied.

See Also

View3D Class


Parameter Property

[image] [image]

Revit 2013 API
View3D..::..Parameter Property
View3D Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

View3D Class
View3D Members


SectionBox Property

[image]

Revit 2013 API
View3D..::..SectionBox Property
View3D Class See Also Send Feedback
The section box of the 3D view cuts the model by its bounds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundingBoxXYZ SectionBox { get; set; }
Visual Basic
Public Property SectionBox As BoundingBoxXYZ
    Get
    Set
Visual C++
public:
property BoundingBoxXYZ^ SectionBox {
    BoundingBoxXYZ^ get ();
    void set (BoundingBoxXYZ^ value);
}

Remarks

To turn off section box, pass in nullNothingnullptra null reference (Nothing in Visual Basic) or a disabled box. Individual bound enabled flags are currently ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when getting this property, if the view is a template and does not have a section box applied.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting this property, if the view is a template and cannot have a section box applied.

See Also

View3D Class


ViewDetailLevel Enumeration

[image]

Revit 2013 API
ViewDetailLevel Enumeration
See Also Send Feedback
Detail level of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ViewDetailLevel
Visual Basic
Public Enumeration ViewDetailLevel
Visual C++
public enum class ViewDetailLevel

Members

Member name | Description
Undefined | View does not use Detail Level
Coarse | Coarse
Medium | Medium
Fine | Fine

See Also


ViewDiscipline Enumeration

[image]

Revit 2013 API
ViewDiscipline Enumeration
See Also Send Feedback
Discipline of the view

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ViewDiscipline
Visual Basic
Public Enumeration ViewDiscipline
Visual C++
public enum class ViewDiscipline

Members

Member name | Description
Architectural | Architectural
Structural | Structural
Mechanical | Mechanical
Electrical | Electrical
Plumbing | Plumbing
Coordination | Coordination

See Also


ViewDrafting Class

[image]

Revit 2013 API
ViewDrafting Class
Members See Also Send Feedback
Class for drafting views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewDrafting : View
Visual Basic
Public Class ViewDrafting _
    Inherits View
Visual C++
public ref class ViewDrafting : public View

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewDrafting
Autodesk.Revit.DB..::..ImageView

See Also

ViewDrafting Members


ViewDrafting Members

[image] [image]

Revit 2013 API
ViewDrafting Members
ViewDrafting Class Methods Properties See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewDrafting Class


ViewDrafting Methods

[image] [image]

Revit 2013 API
ViewDrafting Methods
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewDrafting Class


Print Method

[image] [image]

Revit 2013 API
ViewDrafting..::..Print Method
ViewDrafting Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewDrafting Class
ViewDrafting Members


ViewDrafting Properties

[image] [image]

Revit 2013 API
ViewDrafting Properties
ViewDrafting Class See Also Send Feedback

The ViewDrafting type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewDrafting Class


Parameter Property

[image] [image]

Revit 2013 API
ViewDrafting..::..Parameter Property
ViewDrafting Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewDrafting Class
ViewDrafting Members


ViewDuplicateOption Enumeration

[image]

Revit 2013 API
ViewDuplicateOption Enumeration
See Also Send Feedback
Options for duplicating views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ViewDuplicateOption
Visual Basic
Public Enumeration ViewDuplicateOption
Visual C++
public enum class ViewDuplicateOption

Members

Member name | Description
Duplicate | Duplicate view
AsDependent | Duplicate as Dependent
WithDetailing | Duplicate with Detailing

See Also


ViewFamily Enumeration

[image]

Revit 2013 API
ViewFamily Enumeration
See Also Send Feedback
An enumerated type that corresponds to the type of a Revit view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ViewFamily
Visual Basic
Public Enumeration ViewFamily
Visual C++
public enum class ViewFamily

Members

Member name | Description
Invalid | Invalid view type.
ThreeDimensional | 3D view.
Walkthrough | Walkthrough view.
ImageView | Rendering view.
Schedule | Schedule view.
CostReport | Cost report view (obsolete).
Sheet | Sheet view.
Drafting | Drafting view.
FloorPlan | Floor plan view.
AreaPlan | Area plan view.
CeilingPlan | Ceiling plan view.
Section | Section view.
Detail | Detail view.
Elevation | Elevation view.
LoadsReport | HVAC load report.
PressureLossReport | Pressure loss report.
Legend | Legend view.
PanelSchedule | Panel schedule.
GraphicalColumnSchedule | Graphical column schedule.
StructuralPlan | Structural plan view.

See Also


ViewFamilyType Class

[image]

Revit 2013 API
ViewFamilyType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ViewFamilyType : ElementType
Visual Basic
Public Class ViewFamilyType _
    Inherits ElementType
Visual C++
public ref class ViewFamilyType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..ViewFamilyType

See Also

ViewFamilyType Members


ViewFamilyType Members

[image] [image]

Revit 2013 API
ViewFamilyType Members
ViewFamilyType Class Methods Properties See Also Send Feedback

The ViewFamilyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultTemplate | Verify that %templateId% can be default template for this view type: it can be invalidElementId or represent template view that is compatible with this view type
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultTemplateId | Default template id. It will be the view template for all newly created instances of this view type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlanViewDirection | The PlanViewDirection of this view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewFamily | ViewFamily for this object
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewFamilyType Class


ViewFamilyType Methods

[image] [image]

Revit 2013 API
ViewFamilyType Methods
ViewFamilyType Class See Also Send Feedback

The ViewFamilyType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidDefaultTemplate | Verify that %templateId% can be default template for this view type: it can be invalidElementId or represent template view that is compatible with this view type
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewFamilyType Class


IsValidDefaultTemplate Method

[image]

Revit 2013 API
ViewFamilyType..::..IsValidDefaultTemplate Method
ViewFamilyType Class See Also Send Feedback
Verify that %templateId% can be default template for this view type: it can be invalidElementId or represent template view that is compatible with this view type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidDefaultTemplate(
    ElementId templateId
)
Visual Basic
Public Function IsValidDefaultTemplate ( _
    templateId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDefaultTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
Id to be validated as default template.

Return Value

True if %templateId% is valid as default template, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewFamilyType Class


ViewFamilyType Properties

[image] [image]

Revit 2013 API
ViewFamilyType Properties
ViewFamilyType Class See Also Send Feedback

The ViewFamilyType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultTemplateId | Default template id. It will be the view template for all newly created instances of this view type.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PlanViewDirection | The PlanViewDirection of this view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewFamily | ViewFamily for this object
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewFamilyType Class


DefaultTemplateId Property

[image]

Revit 2013 API
ViewFamilyType..::..DefaultTemplateId Property
ViewFamilyType Class See Also Send Feedback
Default template id. It will be the view template for all newly created instances of this view type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId DefaultTemplateId { get; set; }
Visual Basic
Public Property DefaultTemplateId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DefaultTemplateId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: val is not valid as default template id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ViewFamilyType Class


Parameter Property

[image] [image]

Revit 2013 API
ViewFamilyType..::..Parameter Property
ViewFamilyType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewFamilyType Class
ViewFamilyType Members


PlanViewDirection Property

[image]

Revit 2013 API
ViewFamilyType..::..PlanViewDirection Property
ViewFamilyType Class See Also Send Feedback
The PlanViewDirection of this view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PlanViewDirection PlanViewDirection { get; set; }
Visual Basic
Public Property PlanViewDirection As PlanViewDirection
    Get
    Set
Visual C++
public:
property PlanViewDirection PlanViewDirection {
    PlanViewDirection get ();
    void set (PlanViewDirection value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: Cannot set PlanViewDirection to Undefined
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: View must be a Structural Plan

See Also

ViewFamilyType Class


ViewFamily Property

[image]

Revit 2013 API
ViewFamilyType..::..ViewFamily Property
ViewFamilyType Class See Also Send Feedback
ViewFamily for this object

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewFamily ViewFamily { get; }
Visual Basic
Public ReadOnly Property ViewFamily As ViewFamily
    Get
Visual C++
public:
property ViewFamily ViewFamily {
    ViewFamily get ();
}

See Also

ViewFamilyType Class


ViewOrientation3D Class

[image]

Revit 2013 API
ViewOrientation3D Class
Members See Also Send Feedback
Container for the point and vectors which define View3D's orientation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ViewOrientation3D : IDisposable
Visual Basic
Public Class ViewOrientation3D _
    Implements IDisposable
Visual C++
public ref class ViewOrientation3D : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewOrientation3D

See Also

ViewOrientation3D Members


ViewOrientation3D Members

[image] [image]

Revit 2013 API
ViewOrientation3D Members
ViewOrientation3D Class Constructors Methods Properties See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Constructors

 | Name | Description
Public method | ViewOrientation3D | Initializes a new instance of the ViewOrientation3D class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewOrientation3D
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | UpDirection | The up direction vector

See Also

ViewOrientation3D Class


ViewOrientation3D Constructor

[image]

Revit 2013 API
ViewOrientation3D Constructor
ViewOrientation3D Class See Also Send Feedback
Initializes a new instance of the ViewOrientation3D class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewOrientation3D(
    XYZ eyePosition,
    XYZ upDirection,
    XYZ forwardDirection
)
Visual Basic
Public Sub New ( _
    eyePosition As XYZ, _
    upDirection As XYZ, _
    forwardDirection As XYZ _
)
Visual C++
public:
ViewOrientation3D(
    XYZ^ eyePosition,
    XYZ^ upDirection,
    XYZ^ forwardDirection
)

Parameters

eyePosition
Type: Autodesk.Revit.DB..::..XYZ
The eye position
upDirection
Type: Autodesk.Revit.DB..::..XYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
forwardDirection
Type: Autodesk.Revit.DB..::..XYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or both of the input vectors cannot be normalized.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular.

See Also

ViewOrientation3D Class


ViewOrientation3D Methods

[image] [image]

Revit 2013 API
ViewOrientation3D Methods
ViewOrientation3D Class See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewOrientation3D Class


Dispose Method

[image]

Revit 2013 API
ViewOrientation3D..::..Dispose Method
ViewOrientation3D Class See Also Send Feedback
Releases all resources used by the ViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewOrientation3D Class


ViewOrientation3D Properties

[image] [image]

Revit 2013 API
ViewOrientation3D Properties
ViewOrientation3D Class See Also Send Feedback

The ViewOrientation3D type exposes the following members.

Properties

 | Name | Description
Public property | EyePosition | The eye position point
Public property | ForwardDirection | The forward direction vector
Public property | UpDirection | The up direction vector

See Also

ViewOrientation3D Class


EyePosition Property

[image]

Revit 2013 API
ViewOrientation3D..::..EyePosition Property
ViewOrientation3D Class See Also Send Feedback
The eye position point

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ EyePosition { get; }
Visual Basic
Public ReadOnly Property EyePosition As XYZ
    Get
Visual C++
public:
property XYZ^ EyePosition {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


ForwardDirection Property

[image]

Revit 2013 API
ViewOrientation3D..::..ForwardDirection Property
ViewOrientation3D Class See Also Send Feedback
The forward direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ ForwardDirection { get; }
Visual Basic
Public ReadOnly Property ForwardDirection As XYZ
    Get
Visual C++
public:
property XYZ^ ForwardDirection {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


UpDirection Property

[image]

Revit 2013 API
ViewOrientation3D..::..UpDirection Property
ViewOrientation3D Class See Also Send Feedback
The up direction vector

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ UpDirection { get; }
Visual Basic
Public ReadOnly Property UpDirection As XYZ
    Get
Visual C++
public:
property XYZ^ UpDirection {
    XYZ^ get ();
}

See Also

ViewOrientation3D Class


ViewPlan Class

[image]

Revit 2013 API
ViewPlan Class
Members See Also Send Feedback
Class for plan views

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewPlan : View
Visual Basic
Public Class ViewPlan _
    Inherits View
Visual C++
public ref class ViewPlan : public View

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewPlan

See Also

ViewPlan Members


ViewPlan Members

[image] [image]

Revit 2013 API
ViewPlan Members
ViewPlan Class Methods Properties See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewRange | Gets the view range.
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetViewRange | Sets the view range.
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewPlan Class


ViewPlan Methods

[image] [image]

Revit 2013 API
ViewPlan Methods
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CheckPlanViewRangeValidity | Checks if the plan view range is valid.
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | Create | Creates a new ViewPlan.
 | CreateAreaPlan | Creates a new area plan ViewPlan.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetViewRange | Gets the view range.
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetViewRange | Sets the view range.
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewPlan Class


CheckPlanViewRangeValidity Method

[image]

Revit 2013 API
ViewPlan..::..CheckPlanViewRangeValidity Method
ViewPlan Class See Also Send Feedback
Checks if the plan view range is valid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<PlanViewRangeError> CheckPlanViewRangeValidity(
    PlanViewRange planViewRange
)
Visual Basic
Public Function CheckPlanViewRangeValidity ( _
    planViewRange As PlanViewRange _
) As IList(Of PlanViewRangeError)
Visual C++
public:
IList<PlanViewRangeError>^ CheckPlanViewRangeValidity(
    PlanViewRange^ planViewRange
)

Parameters

planViewRange
Type: Autodesk.Revit.DB..::..PlanViewRange
The view range to validate.

Return Value

List of enums describing any errors in the plan view range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewPlan Class


Create Method

[image]

Revit 2013 API
ViewPlan..::..Create Method
ViewPlan Class See Also Send Feedback
Creates a new ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewPlan Create(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    levelId As ElementId _
) As ViewPlan
Visual C++
public:
static ViewPlan^ Create(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewPlan will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new ViewPlan. The type needs to be a FloorPlan, CeilingPlan, AreaPlan, or StructuralPlan ViewType.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level to associate with the new plan view.

Return Value

The new ViewPlan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This view family type is not a plan view type. -or- The ElementId levelId does not correspond to a Level. -or- The view family type cannot be created in this discipline of Revit. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewPlan Class


CreateAreaPlan Method

[image]

Revit 2013 API
ViewPlan..::..CreateAreaPlan Method
ViewPlan Class See Also Send Feedback
Creates a new area plan ViewPlan.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewPlan CreateAreaPlan(
    Document document,
    ElementId areaSchemeId,
    ElementId levelId
)
Visual Basic
Public Shared Function CreateAreaPlan ( _
    document As Document, _
    areaSchemeId As ElementId, _
    levelId As ElementId _
) As ViewPlan
Visual C++
public:
static ViewPlan^ CreateAreaPlan(
    Document^ document,
    ElementId^ areaSchemeId,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the area plan will be added.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the AreaScheme which will be used by the area plan.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The id of the Level to associate with the area plan.

Return Value

The new area plan ViewPlan.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The AreaScheme id is not valid and cannot be used for area plan views. -or- The ElementId levelId does not correspond to a Level. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewPlan Class


GetViewRange Method

[image]

Revit 2013 API
ViewPlan..::..GetViewRange Method
ViewPlan Class See Also Send Feedback
Gets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PlanViewRange GetViewRange()
Visual Basic
Public Function GetViewRange As PlanViewRange
Visual C++
public:
PlanViewRange^ GetViewRange()

Return Value

The view range.

See Also

ViewPlan Class


Print Method

[image] [image]

Revit 2013 API
ViewPlan..::..Print Method
ViewPlan Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewPlan Class
ViewPlan Members


SetViewRange Method

[image]

Revit 2013 API
ViewPlan..::..SetViewRange Method
ViewPlan Class See Also Send Feedback
Sets the view range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetViewRange(
    PlanViewRange planViewRange
)
Visual Basic
Public Sub SetViewRange ( _
    planViewRange As PlanViewRange _
)
Visual C++
public:
void SetViewRange(
    PlanViewRange^ planViewRange
)

Parameters

planViewRange
Type: Autodesk.Revit.DB..::..PlanViewRange
The view range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Plan view range is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewPlan Class


ViewPlan Properties

[image] [image]

Revit 2013 API
ViewPlan Properties
ViewPlan Class See Also Send Feedback

The ViewPlan type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AreaScheme | The area scheme.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewPlan Class


AreaScheme Property

[image]

Revit 2013 API
ViewPlan..::..AreaScheme Property
ViewPlan Class See Also Send Feedback
The area scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaScheme AreaScheme { get; }
Visual Basic
Public ReadOnly Property AreaScheme As AreaScheme
    Get
Visual C++
public:
property AreaScheme^ AreaScheme {
    AreaScheme^ get ();
}

Field Value

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if this plan view is not an area plan.

See Also

ViewPlan Class


Parameter Property

[image] [image]

Revit 2013 API
ViewPlan..::..Parameter Property
ViewPlan Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewPlan Class
ViewPlan Members


ViewPlanType Enumeration

[image]

Revit 2013 API
ViewPlanType Enumeration
See Also Send Feedback
An enumerated type listing plan view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ViewPlanType
Visual Basic
Public Enumeration ViewPlanType
Visual C++
public enum class ViewPlanType

Members

Member name | Description
FloorPlan | Floor plan view.
CeilingPlan | Reflected ceiling plan view.

See Also


Viewport Class

[image]

Revit 2013 API
Viewport Class
Members See Also Send Feedback
An element that establishes the placement of a view on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Viewport : Element
Visual Basic
Public Class Viewport _
    Inherits Element
Visual C++
public ref class Viewport : public Element

Remarks

Viewports are used in Revit for purposes other than placement of views on sheets. Thus iteration of viewport elements in the model may locate viewports which are not assigned to sheets; you can use the SheetId property to filter these out.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Viewport

See Also

Viewport Members


Viewport Members

[image] [image]

Revit 2013 API
Viewport Members
Viewport Class Methods Properties See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewId | The element id of the associated View.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Viewport Class


Viewport Methods

[image] [image]

Revit 2013 API
Viewport Methods
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
 | CanAddViewToSheet | Verifies that the view can be added to the ViewSheet.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new Viewport at a given location on a sheet.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoxOutline | Returns the outline of the viewport on the sheet, excluding the viewport label.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLabelOutline | Gets the outline viewport's label on the sheet.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Viewport Class


CanAddViewToSheet Method

[image]

Revit 2013 API
Viewport..::..CanAddViewToSheet Method
Viewport Class See Also Send Feedback
Verifies that the view can be added to the ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool CanAddViewToSheet(
    Document document,
    ElementId viewSheetId,
    ElementId viewId
)
Visual Basic
Public Shared Function CanAddViewToSheet ( _
    document As Document, _
    viewSheetId As ElementId, _
    viewId As ElementId _
) As Boolean
Visual C++
public:
static bool CanAddViewToSheet(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the views reside.
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The ViewSheet on which the view will be placed.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view which will be checked to see if it can be placed on the sheet.

Return Value

True if the view can be added to the ViewSheet, false otherwise.

Remarks

Schedule views are not handled by the Viewport class. Refer to ScheduleInstance for information about adding schedules to sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Viewport Class


Create Method

[image]

Revit 2013 API
Viewport..::..Create Method
Viewport Class See Also Send Feedback
Creates a new Viewport at a given location on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Viewport Create(
    Document document,
    ElementId viewSheetId,
    ElementId viewId,
    XYZ point
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    viewSheetId As ElementId, _
    viewId As ElementId, _
    point As XYZ _
) As Viewport
Visual C++
public:
static Viewport^ Create(
    Document^ document,
    ElementId^ viewSheetId,
    ElementId^ viewId,
    XYZ^ point
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new Viewport will be added.
viewSheetId
Type: Autodesk.Revit.DB..::..ElementId
The ViewSheet on which the new Viewport will be placed.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view shown in the Viewport.
point
Type: Autodesk.Revit.DB..::..XYZ
The new Viewport will be centered on this point.

Return Value

The new Viewport.

Remarks

Use ScheduleInstance.Create() to add schedules to sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | viewSheetId is not a ViewSheet. -or- viewId cannot be added to the ViewSheet. -or- Plan view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Viewport Class


GetBoxOutline Method

[image]

Revit 2013 API
Viewport..::..GetBoxOutline Method
Viewport Class See Also Send Feedback
Returns the outline of the viewport on the sheet, excluding the viewport label.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Outline GetBoxOutline()
Visual Basic
Public Function GetBoxOutline As Outline
Visual C++
public:
Outline^ GetBoxOutline()

Return Value

The outline of the viewport on the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet.

See Also

Viewport Class


GetLabelOutline Method

[image]

Revit 2013 API
Viewport..::..GetLabelOutline Method
Viewport Class See Also Send Feedback
Gets the outline viewport's label on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Outline GetLabelOutline()
Visual Basic
Public Function GetLabelOutline As Outline
Visual C++
public:
Outline^ GetLabelOutline()

Return Value

The outline of the viewport's label on the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The viewport is not on a sheet.

See Also

Viewport Class


Viewport Properties

[image] [image]

Revit 2013 API
Viewport Properties
Viewport Class See Also Send Feedback

The Viewport type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetId | The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewId | The element id of the associated View.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Viewport Class


Parameter Property

[image] [image]

Revit 2013 API
Viewport..::..Parameter Property
Viewport Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Viewport Class
Viewport Members


SheetId Property

[image]

Revit 2013 API
Viewport..::..SheetId Property
Viewport Class See Also Send Feedback
The element id of the ViewSheet on which the viewport appears, or InvalidElementId if this viewport does not associate a view with placement onto a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SheetId { get; }
Visual Basic
Public ReadOnly Property SheetId As ElementId
    Get
Visual C++
public:
property ElementId^ SheetId {
    ElementId^ get ();
}

See Also

Viewport Class


ViewId Property

[image]

Revit 2013 API
Viewport..::..ViewId Property
Viewport Class See Also Send Feedback
The element id of the associated View.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Viewport Class


ViewportRotation Enumeration

[image]

Revit 2013 API
ViewportRotation Enumeration
See Also Send Feedback
Rotation of the viewport

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ViewportRotation
Visual Basic
Public Enumeration ViewportRotation
Visual C++
public enum class ViewportRotation

Members

Member name | Description
None | Viewport is not rotated.
Clockwise | Viewport is rotated 90 degrees clockwise.
Counterclockwise | Viewport is rotated 90 degrees counterclockwise.

See Also


ViewSchedule Class

[image]

Revit 2013 API
ViewSchedule Class
Members See Also Send Feedback
A schedule view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ViewSchedule : View
Visual Basic
Public Class ViewSchedule _
    Inherits View
Visual C++
public ref class ViewSchedule : public View

Remarks

The ViewSchedule class represents schedules and other schedule-like views, including single-category and multi-category schedules, key schedules, material takeoffs, view lists, sheet lists, keynote legends, revision schedules, and note blocks. The ViewSchedule class is not used for panel schedules (see PanelScheduleView) or graphical column schedules.

A schedule is a tabular representation of data. A typical schedule shows all elements of a category (doors, rooms, etc.) with each row representing an element and each column representing a parameter. This basic structure can be modified using filters, sorting, grouping, totals, formulas, and other features.

The ScheduleDefinition class contains most settings that determine the contents of a schedule, including category, fields, filters, and sorting.

A graphical representation of a schedule can be placed on a sheet using the ScheduleSheetInstance class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewSchedule

See Also

ViewSchedule Members


ViewSchedule Members

[image] [image]

Revit 2013 API
ViewSchedule Members
ViewSchedule Class Methods Properties See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | Definition | The primary ScheduleDefinition.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSchedule Class


ViewSchedule Methods

[image] [image]

Revit 2013 API
ViewSchedule Methods
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateKeynoteLegend | Creates a keynote legend.
 | CreateKeySchedule | Create a key schedule.
 | CreateMaterialTakeoff | Creates a material takeoff.
 | CreateNoteBlock | Creates a note block.
 | CreateRevisionSchedule | Creates a revision schedule.
 | CreateSchedule(Document, ElementId) | Creates a regular schedule.
 | CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule.
 | CreateSheetList | Creates a sheet list.
 | CreateViewList | Creates a view list.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Export | Exports the schedule data to a text file.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
 | GetDefaultNameForKeynoteLegend | Gets the default view name that will be used when creating a keynote legend.
 | GetDefaultNameForKeySchedule | Gets the default view name that will be used when creating a key schedule.
 | GetDefaultNameForMaterialTakeoff | Gets the default view name that will be used when creating a material takeoff.
 | GetDefaultNameForNoteBlock | Gets the default view name that will be used when creating a note block.
 | GetDefaultNameForRevisionSchedule | Gets the default view name that will be used when creating a revision schedule.
 | GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
 | GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.
 | GetDefaultNameForSheetList | Gets the default view name that will be used when creating a sheet list.
 | GetDefaultNameForViewList | Gets the default view name that will be used when creating a view list.
 | GetDefaultParameterNameForKeySchedule | Gets the default parameter name that will be used when creating a key schedule.
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
 | GetValidCategoriesForKeySchedule | Gets a list of categories that can be used for a key schedule.
 | GetValidCategoriesForMaterialTakeoff | Gets a list of categories that can be used for a material takeoff.
 | GetValidCategoriesForSchedule | Gets a list of categories that can be used for a regular schedule.
 | GetValidFamiliesForNoteBlock | Gets a list of families that can be used for a note block.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
 | IsValidCategoryForKeySchedule | Checks whether a category can be used for a key schedule.
 | IsValidCategoryForMaterialTakeoff | Checks whether a category can be used for a material takeoff.
 | IsValidCategoryForSchedule | Checks whether a category can be used for a regular schedule.
 | IsValidFamilyForNoteBlock | Checks whether a family can be used for a note block.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSchedule Class


CreateKeynoteLegend Method

[image]

Revit 2013 API
ViewSchedule..::..CreateKeynoteLegend Method
ViewSchedule Class See Also Send Feedback
Creates a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateKeynoteLegend(
    Document document
)
Visual Basic
Public Shared Function CreateKeynoteLegend ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateKeynoteLegend(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A keynote legend is a schedule of the Keynote Tags category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateKeySchedule Method

[image]

Revit 2013 API
ViewSchedule..::..CreateKeySchedule Method
ViewSchedule Class See Also Send Feedback
Create a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The newly created schedule.

Remarks

A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateMaterialTakeoff Method

[image]

Revit 2013 API
ViewSchedule..::..CreateMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Creates a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateMaterialTakeoff(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateMaterialTakeoff ( _
    document As Document, _
    categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateMaterialTakeoff(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The newly created schedule.

Remarks

A material takeoff is a schedule that displays information about the materials that make up elements in the model. Unlike regular schedules where each row (before grouping) represents a single element, each row in a material takeoff represents a single <element, material> pair.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a material takeoff.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateNoteBlock Method

[image]

Revit 2013 API
ViewSchedule..::..CreateNoteBlock Method
ViewSchedule Class Example See Also Send Feedback
Creates a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateNoteBlock(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function CreateNoteBlock ( _
    document As Document, _
    familyId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateNoteBlock(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the family whose elements will be included in the schedule.

Return Value

The newly created schedule.

Remarks

A note block is a schedule of the Generic Annotations category that shows elements of a single family rather than all elements in the category.

Examples

CopyC#
//Get first ElementId of AnnotationSymbolType families.
ElementId annotationSymbolTypeId = ElementId.InvalidElementId;
if (!doc.AnnotationSymbolTypes.IsEmpty)
{
    foreach (AnnotationSymbolType type in doc.AnnotationSymbolTypes)
    {
        annotationSymbolTypeId = type.Family.Id;
        break;
    }
}

//Create a noteblock view schedule.
ViewSchedule noteBlockSchedule = ViewSchedule.CreateNoteBlock(doc, annotationSymbolTypeId);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- familyId is not a valid family for a note block.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateRevisionSchedule Method

[image]

Revit 2013 API
ViewSchedule..::..CreateRevisionSchedule Method
ViewSchedule Class See Also Send Feedback
Creates a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateRevisionSchedule(
    Document document
)
Visual Basic
Public Shared Function CreateRevisionSchedule ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateRevisionSchedule(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The titleblock family document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

Revision schedules are added to titleblock families and become visible as part of titleblocks on sheets.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a titleblock family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateSchedule Method

[image] [image]

Revit 2013 API
ViewSchedule..::..CreateSchedule Method
ViewSchedule Class See Also Send Feedback

Overload List

Name | Description
CreateSchedule(Document, ElementId) | Creates a regular schedule.
CreateSchedule(Document, ElementId, ElementId) | Creates a regular schedule.

See Also

ViewSchedule Class
ViewSchedule Members


CreateSchedule Method (Document, ElementId)

[image]

Revit 2013 API
ViewSchedule..::..CreateSchedule Method (Document, ElementId)
ViewSchedule Class See Also Send Feedback
Creates a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function CreateSchedule ( _
    document As Document, _
    categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The newly created schedule.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class
CreateSchedule Overload


CreateSchedule Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
ViewSchedule..::..CreateSchedule Method (Document, ElementId, ElementId)
ViewSchedule Class Example See Also Send Feedback
Creates a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Visual Basic
Public Shared Function CreateSchedule ( _
    document As Document, _
    categoryId As ElementId, _
    areaSchemeId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

The newly created schedule.

Examples

CopyC#
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
collector1.OfCategory(BuiltInCategory.OST_AreaSchemes);
//Get first ElementId of AreaScheme.
ElementId areaSchemeId = collector1.FirstElementId();

//If you want to create an area schedule, you must use CreateSchedule method with three arguments. The input of second argument must be ElementId of BuiltInCategory.OST_Areas category and the input of third argument must be ElementId of a areaScheme.
ViewSchedule areaSchedule = Autodesk.Revit.DB.ViewSchedule.CreateSchedule(doc, new ElementId(BuiltInCategory.OST_Areas), areaSchemeId);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class
CreateSchedule Overload


CreateSheetList Method

[image]

Revit 2013 API
ViewSchedule..::..CreateSheetList Method
ViewSchedule Class See Also Send Feedback
Creates a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateSheetList(
    Document document
)
Visual Basic
Public Shared Function CreateSheetList ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateSheetList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A sheet list is a schedule of sheets in the project. It is a schedule of the Sheets category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


CreateViewList Method

[image]

Revit 2013 API
ViewSchedule..::..CreateViewList Method
ViewSchedule Class See Also Send Feedback
Creates a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSchedule CreateViewList(
    Document document
)
Visual Basic
Public Shared Function CreateViewList ( _
    document As Document _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateViewList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The newly created schedule.

Remarks

A view list is a schedule of views in the project. It is a schedule of the Views category.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSchedule Class


Export Method

[image]

Revit 2013 API
ViewSchedule..::..Export Method
ViewSchedule Class See Also Send Feedback
Exports the schedule data to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Export(
    string folder,
    string name,
    ViewScheduleExportOptions options
)
Visual Basic
Public Sub Export ( _
    folder As String, _
    name As String, _
    options As ViewScheduleExportOptions _
)
Visual C++
public:
void Export(
    String^ folder,
    String^ name,
    ViewScheduleExportOptions^ options
)

Parameters

folder
Type: System..::..String
Path to the location where the file will be saved.
name
Type: System..::..String
Name of file.
options
Type: Autodesk.Revit.DB..::..ViewScheduleExportOptions
Options that relate to schedule export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | NullOrEmpty -or- Contains invalid characters
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException | The folder does not exist.

See Also

ViewSchedule Class


GetDefaultNameForKeynoteLegend Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForKeynoteLegend Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a keynote legend.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForKeynoteLegend(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForKeynoteLegend ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForKeynoteLegend(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForKeySchedule Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForMaterialTakeoff Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForMaterialTakeoff(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForMaterialTakeoff ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForMaterialTakeoff(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a material takeoff.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForNoteBlock Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForNoteBlock(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForNoteBlock ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForNoteBlock(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForRevisionSchedule Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForRevisionSchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a revision schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForRevisionSchedule(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForRevisionSchedule ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForRevisionSchedule(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The titleblock family document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a titleblock family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForSchedule Method

[image] [image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForSchedule Method
ViewSchedule Class See Also Send Feedback

Overload List

Name | Description
GetDefaultNameForSchedule(Document, ElementId) | Gets the default view name that will be used when creating a regular schedule.
GetDefaultNameForSchedule(Document, ElementId, ElementId) | Gets the default view name that will be used when creating a schedule.

See Also

ViewSchedule Class
ViewSchedule Members


GetDefaultNameForSchedule Method (Document, ElementId)

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForSchedule Method (Document, ElementId)
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForSchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultNameForSchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForSchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- The Areas category was specified but an area scheme ID was not provided.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class
GetDefaultNameForSchedule Overload


GetDefaultNameForSchedule Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForSchedule Method (Document, ElementId, ElementId)
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForSchedule(
    Document document,
    ElementId categoryId,
    ElementId areaSchemeId
)
Visual Basic
Public Shared Function GetDefaultNameForSchedule ( _
    document As Document, _
    categoryId As ElementId, _
    areaSchemeId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultNameForSchedule(
    Document^ document,
    ElementId^ categoryId,
    ElementId^ areaSchemeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category whose elements will be included in the schedule, or InvalidElementId for a multi-category schedule.
areaSchemeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of an area scheme in an area schedule, InvalidElementId otherwise.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a regular schedule. -or- In a non-area schedule, areaSchemeId is not InvalidElementId. -or- In an area schedule, areaSchemeId is not the ID of an area scheme.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class
GetDefaultNameForSchedule Overload


GetDefaultNameForSheetList Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForSheetList Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a sheet list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForSheetList(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForSheetList ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForSheetList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultNameForViewList Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultNameForViewList Method
ViewSchedule Class See Also Send Feedback
Gets the default view name that will be used when creating a view list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultNameForViewList(
    Document document
)
Visual Basic
Public Shared Function GetDefaultNameForViewList ( _
    document As Document _
) As String
Visual C++
public:
static String^ GetDefaultNameForViewList(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.

Return Value

The default view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetDefaultParameterNameForKeySchedule Method

[image]

Revit 2013 API
ViewSchedule..::..GetDefaultParameterNameForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets the default parameter name that will be used when creating a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetDefaultParameterNameForKeySchedule(
    Document document,
    ElementId categoryId
)
Visual Basic
Public Shared Function GetDefaultParameterNameForKeySchedule ( _
    document As Document, _
    categoryId As ElementId _
) As String
Visual C++
public:
static String^ GetDefaultParameterNameForKeySchedule(
    Document^ document,
    ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The default parameter name.

Remarks

See ViewSchedule.KeyScheduleParameterName for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


GetValidCategoriesForKeySchedule Method

[image]

Revit 2013 API
ViewSchedule..::..GetValidCategoriesForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForKeySchedule()
Visual Basic
Public Shared Function GetValidCategoriesForKeySchedule As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForKeySchedule()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidCategoriesForMaterialTakeoff Method

[image]

Revit 2013 API
ViewSchedule..::..GetValidCategoriesForMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForMaterialTakeoff()
Visual Basic
Public Shared Function GetValidCategoriesForMaterialTakeoff As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForMaterialTakeoff()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidCategoriesForSchedule Method

[image]

Revit 2013 API
ViewSchedule..::..GetValidCategoriesForSchedule Method
ViewSchedule Class See Also Send Feedback
Gets a list of categories that can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidCategoriesForSchedule()
Visual Basic
Public Shared Function GetValidCategoriesForSchedule As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidCategoriesForSchedule()

Return Value

The IDs of all valid categories.

See Also

ViewSchedule Class


GetValidFamiliesForNoteBlock Method

[image]

Revit 2013 API
ViewSchedule..::..GetValidFamiliesForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Gets a list of families that can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetValidFamiliesForNoteBlock(
    Document document
)
Visual Basic
Public Shared Function GetValidFamiliesForNoteBlock ( _
    document As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetValidFamiliesForNoteBlock(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The IDs of all valid families.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


IsValidCategoryForKeySchedule Method

[image]

Revit 2013 API
ViewSchedule..::..IsValidCategoryForKeySchedule Method
ViewSchedule Class See Also Send Feedback
Checks whether a category can be used for a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidCategoryForKeySchedule(
    ElementId categoryId
)
Visual Basic
Public Shared Function IsValidCategoryForKeySchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCategoryForKeySchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for a key schedule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


IsValidCategoryForMaterialTakeoff Method

[image]

Revit 2013 API
ViewSchedule..::..IsValidCategoryForMaterialTakeoff Method
ViewSchedule Class See Also Send Feedback
Checks whether a category can be used for a material takeoff.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidCategoryForMaterialTakeoff(
    ElementId categoryId
)
Visual Basic
Public Shared Function IsValidCategoryForMaterialTakeoff ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCategoryForMaterialTakeoff(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for a material takeoff, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


IsValidCategoryForSchedule Method

[image]

Revit 2013 API
ViewSchedule..::..IsValidCategoryForSchedule Method
ViewSchedule Class See Also Send Feedback
Checks whether a category can be used for a regular schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidCategoryForSchedule(
    ElementId categoryId
)
Visual Basic
Public Shared Function IsValidCategoryForSchedule ( _
    categoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCategoryForSchedule(
    ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category ID to check.

Return Value

True if the category can be used for a regular schedule, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


IsValidFamilyForNoteBlock Method

[image]

Revit 2013 API
ViewSchedule..::..IsValidFamilyForNoteBlock Method
ViewSchedule Class See Also Send Feedback
Checks whether a family can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidFamilyForNoteBlock(
    Document document,
    ElementId familyId
)
Visual Basic
Public Shared Function IsValidFamilyForNoteBlock ( _
    document As Document, _
    familyId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidFamilyForNoteBlock(
    Document^ document,
    ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
familyId
Type: Autodesk.Revit.DB..::..ElementId
The family ID to check.

Return Value

True if the family can be used for a note block, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSchedule Class


Print Method

[image] [image]

Revit 2013 API
ViewSchedule..::..Print Method
ViewSchedule Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewSchedule Class
ViewSchedule Members


ViewSchedule Properties

[image] [image]

Revit 2013 API
ViewSchedule Properties
ViewSchedule Class See Also Send Feedback

The ViewSchedule type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | Definition | The primary ScheduleDefinition.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EmbeddedDefinition | The embedded ScheduleDefinition.
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInternalKeynoteSchedule | Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | IsTitleblockRevisionSchedule | Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.
Public property | KeyScheduleParameterName | In a key schedule, the name of the parameter for choosing one of the keys.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSchedule Class


Definition Property

[image]

Revit 2013 API
ViewSchedule..::..Definition Property
ViewSchedule Class See Also Send Feedback
The primary ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleDefinition Definition { get; }
Visual Basic
Public ReadOnly Property Definition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ Definition {
    ScheduleDefinition^ get ();
}

Field Value

The ScheduleDefinition.

See Also

ViewSchedule Class


EmbeddedDefinition Property

[image]

Revit 2013 API
ViewSchedule..::..EmbeddedDefinition Property
ViewSchedule Class See Also Send Feedback
The embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ScheduleDefinition EmbeddedDefinition { get; }
Visual Basic
Public ReadOnly Property EmbeddedDefinition As ScheduleDefinition
    Get
Visual C++
public:
property ScheduleDefinition^ EmbeddedDefinition {
    ScheduleDefinition^ get ();
}

Field Value

The ScheduleDefinition if present, or nullNothingnullptra null reference (Nothing in Visual Basic) if absent.

See Also

ViewSchedule Class


IsInternalKeynoteSchedule Property

[image]

Revit 2013 API
ViewSchedule..::..IsInternalKeynoteSchedule Property
ViewSchedule Class See Also Send Feedback
Identifies if this ViewSchedule is an internal schedule used when keynotes are filtered based on the elements that are shown on a sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsInternalKeynoteSchedule { get; }
Visual Basic
Public ReadOnly Property IsInternalKeynoteSchedule As Boolean
    Get
Visual C++
public:
property bool IsInternalKeynoteSchedule {
    bool get ();
}

Field Value

True if the ViewSchedule is a internal keynote schedule, false otherwise.

Remarks

These schedules cannot be modified by the user or placed on sheets.

See Also

ViewSchedule Class


IsTitleblockRevisionSchedule Property

[image]

Revit 2013 API
ViewSchedule..::..IsTitleblockRevisionSchedule Property
ViewSchedule Class See Also Send Feedback
Identifies if this ViewSchedule is an internal schedule used to display revision schedules as part of a titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsTitleblockRevisionSchedule { get; }
Visual Basic
Public ReadOnly Property IsTitleblockRevisionSchedule As Boolean
    Get
Visual C++
public:
property bool IsTitleblockRevisionSchedule {
    bool get ();
}

Field Value

True if the ViewSchedule is a titleblock revision schedule, false otherwise.

Remarks

These schedules cannot be modified by the user or placed on sheets.

See Also

ViewSchedule Class


KeyScheduleParameterName Property

[image]

Revit 2013 API
ViewSchedule..::..KeyScheduleParameterName Property
ViewSchedule Class See Also Send Feedback
In a key schedule, the name of the parameter for choosing one of the keys.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string KeyScheduleParameterName { get; set; }
Visual Basic
Public Property KeyScheduleParameterName As String
    Get
    Set
Visual C++
public:
property String^ KeyScheduleParameterName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the key schedule parameter.

Remarks

When a key schedule is created, elements of the schedule's category receive a new parameter for choosing one of the keys defined in the key schedule. This is the name of that parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This ViewSchedule is not key schedule.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | When setting this property: The document containing this ViewSchedule is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- When setting this property: The document containing this ViewSchedule is being loaded, or is in the midst of another sensitive process. -or- When setting this property: This ViewSchedule is an internal element, such as a component of a loaded family or a group type. -or- When setting this property: The document containing this ViewSchedule is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- When setting this property: This ViewSchedule is a member of a group or sketch, and the document is not currently editing the group or sketch.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | When setting this property: The document containing this ViewSchedule has no open transaction.

See Also

ViewSchedule Class


Parameter Property

[image] [image]

Revit 2013 API
ViewSchedule..::..Parameter Property
ViewSchedule Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSchedule Class
ViewSchedule Members


ViewScheduleExportOptions Class

[image]

Revit 2013 API
ViewScheduleExportOptions Class
Members See Also Send Feedback
The export options used to export schedule views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ViewScheduleExportOptions : IDisposable
Visual Basic
Public Class ViewScheduleExportOptions _
    Implements IDisposable
Visual C++
public ref class ViewScheduleExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ViewScheduleExportOptions

See Also

ViewScheduleExportOptions Members


ViewScheduleExportOptions Members

[image] [image]

Revit 2013 API
ViewScheduleExportOptions Members
ViewScheduleExportOptions Class Constructors Methods Properties See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | ViewScheduleExportOptions()()()() | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new instance of the ViewScheduleExportOptions class from an existing instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ViewScheduleExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.

See Also

ViewScheduleExportOptions Class


ViewScheduleExportOptions Constructor

[image] [image]

Revit 2013 API
ViewScheduleExportOptions Constructor
ViewScheduleExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ViewScheduleExportOptions()()()() | Constructs a new instance of the ViewScheduleExportOptions class
Public method | ViewScheduleExportOptions(ViewScheduleExportOptions) | Constructs a new instance of the ViewScheduleExportOptions class from an existing instance.

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Members


ViewScheduleExportOptions Constructor

[image]

Revit 2013 API
ViewScheduleExportOptions Constructor
ViewScheduleExportOptions Class See Also Send Feedback
Constructs a new instance of the ViewScheduleExportOptions class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewScheduleExportOptions()
Visual Basic
Public Sub New
Visual C++
public:
ViewScheduleExportOptions()

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions Constructor (ViewScheduleExportOptions)

[image]

Revit 2013 API
ViewScheduleExportOptions Constructor (ViewScheduleExportOptions)
ViewScheduleExportOptions Class See Also Send Feedback
Constructs a new instance of the ViewScheduleExportOptions class from an existing instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ViewScheduleExportOptions(
    ViewScheduleExportOptions option
)
Visual Basic
Public Sub New ( _
    option As ViewScheduleExportOptions _
)
Visual C++
public:
ViewScheduleExportOptions(
    ViewScheduleExportOptions^ option
)

Parameters

option
Type: Autodesk.Revit.DB..::..ViewScheduleExportOptions
The existing ViewScheduleExportOptions instance to be used to create the new instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewScheduleExportOptions Class
ViewScheduleExportOptions Overload


ViewScheduleExportOptions Methods

[image] [image]

Revit 2013 API
ViewScheduleExportOptions Methods
ViewScheduleExportOptions Class See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewScheduleExportOptions Class


Dispose Method

[image]

Revit 2013 API
ViewScheduleExportOptions..::..Dispose Method
ViewScheduleExportOptions Class See Also Send Feedback
Releases all resources used by the ViewScheduleExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ViewScheduleExportOptions Class


ViewScheduleExportOptions Properties

[image] [image]

Revit 2013 API
ViewScheduleExportOptions Properties
ViewScheduleExportOptions Class See Also Send Feedback

The ViewScheduleExportOptions type exposes the following members.

Properties

 | Name | Description
Public property | ColumnHeaders | How to export column headers. Default is MultipleRows.
Public property | FieldDelimiter | How to delimit fields. Default is Tab.
Public property | HeadersFootersBlanks | Whether to export group headers, footers, and blank lines. Default is true.
Public property | TextQualifier | How to qualify text fields. Default is DoubleQuote.

See Also

ViewScheduleExportOptions Class


ColumnHeaders Property

[image]

Revit 2013 API
ViewScheduleExportOptions..::..ColumnHeaders Property
ViewScheduleExportOptions Class See Also Send Feedback
How to export column headers. Default is MultipleRows.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExportColumnHeaders ColumnHeaders { get; set; }
Visual Basic
Public Property ColumnHeaders As ExportColumnHeaders
    Get
    Set
Visual C++
public:
property ExportColumnHeaders ColumnHeaders {
    ExportColumnHeaders get ();
    void set (ExportColumnHeaders value);
}

See Also

ViewScheduleExportOptions Class


FieldDelimiter Property

[image]

Revit 2013 API
ViewScheduleExportOptions..::..FieldDelimiter Property
ViewScheduleExportOptions Class See Also Send Feedback
How to delimit fields. Default is Tab.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string FieldDelimiter { get; set; }
Visual Basic
Public Property FieldDelimiter As String
    Get
    Set
Visual C++
public:
property String^ FieldDelimiter {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ViewScheduleExportOptions Class


HeadersFootersBlanks Property

[image]

Revit 2013 API
ViewScheduleExportOptions..::..HeadersFootersBlanks Property
ViewScheduleExportOptions Class See Also Send Feedback
Whether to export group headers, footers, and blank lines. Default is true.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HeadersFootersBlanks { get; set; }
Visual Basic
Public Property HeadersFootersBlanks As Boolean
    Get
    Set
Visual C++
public:
property bool HeadersFootersBlanks {
    bool get ();
    void set (bool value);
}

See Also

ViewScheduleExportOptions Class


TextQualifier Property

[image]

Revit 2013 API
ViewScheduleExportOptions..::..TextQualifier Property
ViewScheduleExportOptions Class See Also Send Feedback
How to qualify text fields. Default is DoubleQuote.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExportTextQualifier TextQualifier { get; set; }
Visual Basic
Public Property TextQualifier As ExportTextQualifier
    Get
    Set
Visual C++
public:
property ExportTextQualifier TextQualifier {
    ExportTextQualifier get ();
    void set (ExportTextQualifier value);
}

See Also

ViewScheduleExportOptions Class


ViewSection Class

[image]

Revit 2013 API
ViewSection Class
Members See Also Send Feedback
ViewSection covers sections, details, elevations, and callouts, all in their reference and non-reference variations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSection : View
Visual Basic
Public Class ViewSection _
    Inherits View
Visual C++
public ref class ViewSection : public View

Remarks

The creation functions for elevations can be found in the ElevationMarker class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewSection

See Also

ViewSection Members


ViewSection Members

[image] [image]

Revit 2013 API
ViewSection Members
ViewSection Class Methods Properties See Also Send Feedback

The ViewSection type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSection Class


ViewSection Methods

[image] [image]

Revit 2013 API
ViewSection Methods
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Methods

 | Name | Description
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateCallout | Creates a new callout view.
 | CreateDetail | Returns a new detail ViewSection.
 | CreateReferenceCallout | Creates a new reference callout.
 | CreateReferenceSection | Creates a new reference section.
 | CreateSection | Returns a new section ViewSection.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
 | IsParentViewValidForCallout | This validator checks that the parent view is appropriate for callout views.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
 | IsViewFamilyTypeValidForCallout | This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSection Class


CreateCallout Method

[image]

Revit 2013 API
ViewSection..::..CreateCallout Method
ViewSection Class See Also Send Feedback
Creates a new callout view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static View CreateCallout(
    Document document,
    ElementId parentViewId,
    ElementId viewFamilyTypeId,
    XYZ point1,
    XYZ point2
)
Visual Basic
Public Shared Function CreateCallout ( _
    document As Document, _
    parentViewId As ElementId, _
    viewFamilyTypeId As ElementId, _
    point1 As XYZ, _
    point2 As XYZ _
) As View
Visual C++
public:
static View^ CreateCallout(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewFamilyTypeId,
    XYZ^ point1,
    XYZ^ point2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new callout will be added.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the callout appears. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, and Elevation ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan parent views both StructuralPlan and Detail ViewFamilyTypes are allowed.
point1
Type: Autodesk.Revit.DB..::..XYZ
Determines the extents of the callout symbol in the parent view.
point2
Type: Autodesk.Revit.DB..::..XYZ
Determine the extents of the callout symbol in the parent view.

Return Value

The new callout view. The view will be either a ViewSection, ViewPlan or ViewDetail.

Remarks

The extents of new callout are determined by using the two argument points as the opposing corners of a rectangle which is aligned to the directions of the parent view. The callout's near and far cut planes will match those of the parent view. The new view will receive a unique name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Non-reference callouts are not allowed in parent views of this type. -or- Callouts of the supplied ViewFamilyType are not allowed in the parent view. -or- point1 and point2 do not differ when projected onto a plane perpendicular to the view direction. -or- Callout view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateDetail Method

[image]

Revit 2013 API
ViewSection..::..CreateDetail Method
ViewSection Class See Also Send Feedback
Returns a new detail ViewSection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSection CreateDetail(
    Document document,
    ElementId viewFamilyTypeId,
    BoundingBoxXYZ sectionBox
)
Visual Basic
Public Shared Function CreateDetail ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    sectionBox As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetail(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    BoundingBoxXYZ^ sectionBox
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new detail ViewSection will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new detail ViewSection. The type needs to be a Detail ViewFamily.
sectionBox
Type: Autodesk.Revit.DB..::..BoundingBoxXYZ
The BoundingBoxXYZ which specifies the new ViewSection's view direction and extents.

Return Value

The new detail ViewSection.

Remarks

Create a detail ViewSection whose view volume corresponds geometrically with the specified sectionBox. The view direction of the resulting section will be sectionBox.Transform.BasisZ and the up direction will be sectionBox.Transform.BasisY. The right hand direction will be computed so that (right, up, view direction) form a left handed coordinate system. The resulting view will be cropped, and far clipping will be active. The crop region will correspond to the projections of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max onto the view’s cut plane. The far clip distance will be equal to the difference of the z-coordinates of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max. The new detail ViewSection will receive a unique view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ViewFamilyType must be a Detail ViewFamily. -or- The BoundingBoxXYZ is not appropriate for detail views. The basis vectors of must be unit length and orthonormal. The near and far bound offsets cannot be reversed or too close to each other. MinEnabled and MaxEnabled must be set to true for all three directions. -or- Detail section view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateReferenceCallout Method

[image]

Revit 2013 API
ViewSection..::..CreateReferenceCallout Method
ViewSection Class See Also Send Feedback
Creates a new reference callout.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void CreateReferenceCallout(
    Document document,
    ElementId parentViewId,
    ElementId viewIdToReference,
    XYZ point1,
    XYZ point2
)
Visual Basic
Public Shared Sub CreateReferenceCallout ( _
    document As Document, _
    parentViewId As ElementId, _
    viewIdToReference As ElementId, _
    point1 As XYZ, _
    point2 As XYZ _
)
Visual C++
public:
static void CreateReferenceCallout(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewIdToReference,
    XYZ^ point1,
    XYZ^ point2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new reference callout will be added.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the callout symbol appears. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, and Detail views.
viewIdToReference
Type: Autodesk.Revit.DB..::..ElementId
The view which will be referenced. The ViewFamilyType of the referenced view will be used by the new reference callout. Only cropped views can be referenced, unless the referenced view is a Drafting view. Drafting views can always be referenced regardless of the parent view type. Elevation views can be referenced from Elevation and Drafting parent views. Section views can be referenced from Section and Drafting parent views. Detail views can be referenced from all parent views except for in FloorPlan, CeilingPlan and StructuralPlan parent views where only horizontally-oriented Detail views can be referenced. FloorPlan, CeilingPlan and StructuralPlan views can be referenced from FloorPlan, CeilingPlan and StructuralPlan parent views.
point1
Type: Autodesk.Revit.DB..::..XYZ
One corner of the callout symbol in the parent view.
point2
Type: Autodesk.Revit.DB..::..XYZ
The other diagonally opposed corner of the callout symbol in the parent view.

Remarks

The reference callout will assume the ViewFamilyType of the view it references. The corners of the callout symbol will be determined by the two point arguments. The sides of the callout symbol will be aligned to the sides of the parent view's crop region.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- The ElementId parentViewId does not correspond to a View. -or- The parent view and the referenced view must be different views. -or- The parent view does not support reference callouts to views of the ViewFamily used by viewIdToReference. -or- point1 and point2 do not differ when projected onto a plane perpendicular to the view direction. -or- Callout view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateReferenceSection Method

[image]

Revit 2013 API
ViewSection..::..CreateReferenceSection Method
ViewSection Class See Also Send Feedback
Creates a new reference section.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void CreateReferenceSection(
    Document document,
    ElementId parentViewId,
    ElementId viewIdToReference,
    XYZ headPoint,
    XYZ tailPoint
)
Visual Basic
Public Shared Sub CreateReferenceSection ( _
    document As Document, _
    parentViewId As ElementId, _
    viewIdToReference As ElementId, _
    headPoint As XYZ, _
    tailPoint As XYZ _
)
Visual C++
public:
static void CreateReferenceSection(
    Document^ document,
    ElementId^ parentViewId,
    ElementId^ viewIdToReference,
    XYZ^ headPoint,
    XYZ^ tailPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the reference section will be added.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new reference section marker will appear. Reference sections can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, and Detail views.
viewIdToReference
Type: Autodesk.Revit.DB..::..ElementId
Detail, Drafting and Section views can be referenced. The ViewFamilyType of the referenced view will be used by the new reference section.
headPoint
Type: Autodesk.Revit.DB..::..XYZ
Determines the location of the section marker's head in the parent view.
tailPoint
Type: Autodesk.Revit.DB..::..XYZ
Determines the location of the section marker's tail in the parent view.

Remarks

The reference section will assume the ViewFamilyType of the view it references.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId viewIdToReference does not correspond to a View. -or- The ElementId parentViewId does not correspond to a View. -or- The parent view and the referenced view must be different views. -or- Can't create a new reference sections in parentViewId. Parent views must be FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, Drafting, or Detail views. -or- The viewIdToReference cannot be referenced by reference sections. Only Detail, Drafting and Section views can be referenced. -or- headPoint and tailPoint do not differ when projected onto a plane perpendicular to the view direction. -or- Reference section view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


CreateSection Method

[image]

Revit 2013 API
ViewSection..::..CreateSection Method
ViewSection Class See Also Send Feedback
Returns a new section ViewSection.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSection CreateSection(
    Document document,
    ElementId viewFamilyTypeId,
    BoundingBoxXYZ sectionBox
)
Visual Basic
Public Shared Function CreateSection ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    sectionBox As BoundingBoxXYZ _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateSection(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    BoundingBoxXYZ^ sectionBox
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the new section ViewSection will be added.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new section ViewSection. The type needs to be a Section ViewFamily.
sectionBox
Type: Autodesk.Revit.DB..::..BoundingBoxXYZ
The BoundingBoxXYZ which specifies the new ViewSection's view direction and extents.

Return Value

The new section ViewSection.

Remarks

Create a section whose view volume corresponds geometrically with the specified sectionBox. The view direction of the resulting section will be sectionBox.Transform.BasisZ and the up direction will be sectionBox.Transform.BasisY. The right hand direction will be computed so that (right, up, view direction) form a left handed coordinate system. The resulting view will be cropped, and far clipping will be active. The crop region will correspond to the projections of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max onto the view’s cut plane. The far clip distance will be equal to the difference of the z-coordinates of BoundingBoxXYZ.Min and BoundingBoxXYZ.Max. The new section ViewSection will receive a unique view name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ViewFamilyType must be a Section ViewFamily. -or- The BoundingBoxXYZ is not appropriate for detail views. The basis vectors of must be unit length and orthonormal. The near and far bound offsets cannot be reversed or too close to each other. MinEnabled and MaxEnabled must be set to true for all three directions. -or- Section view creation is not allowed in this family.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSection Class


IsParentViewValidForCallout Method

[image]

Revit 2013 API
ViewSection..::..IsParentViewValidForCallout Method
ViewSection Class See Also Send Feedback
This validator checks that the parent view is appropriate for callout views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsParentViewValidForCallout(
    Document document,
    ElementId parentViewId
)
Visual Basic
Public Shared Function IsParentViewValidForCallout ( _
    document As Document, _
    parentViewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsParentViewValidForCallout(
    Document^ document,
    ElementId^ parentViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which contains the ViewFamilyType and parent view.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSection Class


IsViewFamilyTypeValidForCallout Method

[image]

Revit 2013 API
ViewSection..::..IsViewFamilyTypeValidForCallout Method
ViewSection Class See Also Send Feedback
This validator checks that the ViewFamilyType is appropriate for callout views in the input parent view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsViewFamilyTypeValidForCallout(
    Document document,
    ElementId viewFamilyTypeId,
    ElementId parentViewId
)
Visual Basic
Public Shared Function IsViewFamilyTypeValidForCallout ( _
    document As Document, _
    viewFamilyTypeId As ElementId, _
    parentViewId As ElementId _
) As Boolean
Visual C++
public:
static bool IsViewFamilyTypeValidForCallout(
    Document^ document,
    ElementId^ viewFamilyTypeId,
    ElementId^ parentViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document which contains the ViewFamilyType and parent view.
viewFamilyTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the ViewFamilyType which will be used by the new callout ViewSection. Detail ViewFamilyTypes can be used in all parent views except for CeilingPlan and Drafting views. FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail ViewFamilyTypes may be be used in parent views that also use a type with the same ViewFamily enum value. For example, in StructuralPlan views both StructuralPlan and Detail ViewFamilyTypes are allowed.
parentViewId
Type: Autodesk.Revit.DB..::..ElementId
The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.

Return Value

True if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSection Class


Print Method

[image] [image]

Revit 2013 API
ViewSection..::..Print Method
ViewSection Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewSection Class
ViewSection Members


ViewSection Properties

[image] [image]

Revit 2013 API
ViewSection Properties
ViewSection Class See Also Send Feedback

The ViewSection type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSection Class


Parameter Property

[image] [image]

Revit 2013 API
ViewSection..::..Parameter Property
ViewSection Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSection Class
ViewSection Members


ViewSet Class

[image]

Revit 2013 API
ViewSet Class
Members See Also Send Feedback
A set that contains views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSet : APIObject, IEnumerable
Visual Basic
Public Class ViewSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSet

See Also

ViewSet Members


ViewSet Members

[image] [image]

Revit 2013 API
ViewSet Members
ViewSet Class Constructors Methods Properties See Also Send Feedback

The ViewSet type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSet | Initializes a new instance of the ViewSet class

Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet Class


ViewSet Constructor

[image]

Revit 2013 API
ViewSet Constructor
ViewSet Class See Also Send Feedback
Initializes a new instance of the ViewSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSet()
Visual Basic
Public Sub New
Visual C++
public:
ViewSet()

See Also

ViewSet Class


ViewSet Methods

[image] [image]

Revit 2013 API
ViewSet Methods
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every view from the set, rendering it empty.
Public method | Contains | Tests for the existence of a view within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified view from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified view into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSet Class


Clear Method

[image]

Revit 2013 API
ViewSet..::..Clear Method
ViewSet Class See Also Send Feedback
Removes every view from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSet Class


Contains Method

[image]

Revit 2013 API
ViewSet..::..Contains Method
ViewSet Class See Also Send Feedback
Tests for the existence of a view within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    View item
)
Visual Basic
Public Overridable Function Contains ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Contains(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be searched for.

Return Value

The Contains method returns True if the view is within the set, otherwise False.

See Also

ViewSet Class


Erase Method

[image]

Revit 2013 API
ViewSet..::..Erase Method
ViewSet Class See Also Send Feedback
Removes a specified view from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    View item
)
Visual Basic
Public Overridable Function Erase ( _
    item As View _
) As Integer
Visual C++
public:
virtual int Erase(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be erased.

Return Value

The number of views that were erased from the set.

See Also

ViewSet Class


ForwardIterator Method

[image]

Revit 2013 API
ViewSet..::..ForwardIterator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSet Class


GetEnumerator Method

[image]

Revit 2013 API
ViewSet..::..GetEnumerator Method
ViewSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ViewSet Class


Insert Method

[image]

Revit 2013 API
ViewSet..::..Insert Method
ViewSet Class See Also Send Feedback
Insert the specified view into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    View item
)
Visual Basic
Public Overridable Function Insert ( _
    item As View _
) As Boolean
Visual C++
public:
virtual bool Insert(
    View^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..View
The view to be inserted into the set.

Return Value

Returns whether the view was inserted into the set.

See Also

ViewSet Class


ReverseIterator Method

[image]

Revit 2013 API
ViewSet..::..ReverseIterator Method
ViewSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ViewSetIterator
Visual C++
public:
virtual ViewSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSet Class


ViewSet Properties

[image] [image]

Revit 2013 API
ViewSet Properties
ViewSet Class See Also Send Feedback

The ViewSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of views that are in the set.

See Also

ViewSet Class


IsEmpty Property

[image]

Revit 2013 API
ViewSet..::..IsEmpty Property
ViewSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSet Class


Size Property

[image]

Revit 2013 API
ViewSet..::..Size Property
ViewSet Class See Also Send Feedback
Returns the number of views that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSet Class


ViewSetIterator Class

[image]

Revit 2013 API
ViewSetIterator Class
Members See Also Send Feedback
An iterator to a view set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ViewSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ViewSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSetIterator

See Also

ViewSetIterator Members


ViewSetIterator Members

[image] [image]

Revit 2013 API
ViewSetIterator Members
ViewSetIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class


ViewSetIterator Constructor

[image]

Revit 2013 API
ViewSetIterator Constructor
ViewSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ViewSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSetIterator Class


ViewSetIterator Methods

[image] [image]

Revit 2013 API
ViewSetIterator Methods
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSetIterator Class


MoveNext Method

[image]

Revit 2013 API
ViewSetIterator..::..MoveNext Method
ViewSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSetIterator Class


Reset Method

[image]

Revit 2013 API
ViewSetIterator..::..Reset Method
ViewSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSetIterator Class


ViewSetIterator Properties

[image] [image]

Revit 2013 API
ViewSetIterator Properties
ViewSetIterator Class See Also Send Feedback

The ViewSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSetIterator Class


Current Property

[image]

Revit 2013 API
ViewSetIterator..::..Current Property
ViewSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSetIterator Class


ViewSheet Class

[image]

Revit 2013 API
ViewSheet Class
Members Example See Also Send Feedback
Class for ViewSheet

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSheet : View
Visual Basic
Public Class ViewSheet _
    Inherits View
Visual C++
public ref class ViewSheet : public View

Examples

CopyC#
private void Getinfo_ViewSheet(ViewSheet viewSheet)
{
    string message = "ViewSheet: ";
    //Get the number of the Sheet
    string sheetNumber = viewSheet.SheetNumber;
    message += "\nSheet Number: " + sheetNumber;

    //Exception occurs when set SheetNumber to a number that isn't unique
    string TestSheetNumber = "My sheet";
    viewSheet.SheetNumber = TestSheetNumber;
    message += "\nSheet Number after set: " + sheetNumber;

    ViewSet views = viewSheet.Views;
    message += "\nNumber of views in the sheet : " + views.Size;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_ViewSheet(ByVal viewSheet As ViewSheet)
    Dim message As String = "ViewSheet: "
    'Get the number of the Sheet
    Dim sheetNumber As String = viewSheet.SheetNumber
    message += vbLf & "Sheet Number: " + sheetNumber

    'Exception occurs when set SheetNumber to a number that isn't unique
    Dim TestSheetNumber As String = "My sheet"
    viewSheet.SheetNumber = TestSheetNumber
    message += vbLf & "Sheet Number after set: " + sheetNumber

    Dim views As ViewSet = viewSheet.Views
    message += vbLf & "Number of views in the sheet : " + views.Size

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..ViewSheet

See Also

ViewSheet Members


ViewSheet Members

[image] [image]

Revit 2013 API
ViewSheet Members
ViewSheet Class Methods Properties See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | AddView | Obsolete. Places view on the sheet at the given location.
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Create a placeholder sheet in document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SheetNumber | Sheet number is unique in the document.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | Views | Returns the set of all views on the sheet.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheet Class


ViewSheet Methods

[image] [image]

Revit 2013 API
ViewSheet Methods
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Methods

 | Name | Description
Public method | AddView | Obsolete. Places view on the sheet at the given location.
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
Public method | ConvertToRealSheet | Convert a placeholder sheet to a real one with an optional titleblock
 | Create | Creates a new ViewSheet.
 | CreatePlaceholder | Create a placeholder sheet in document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DeleteViewport | Removes a viewport from the sheet by deleting it from the document.
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllViewports | Returns the ElementIds of Viewports on this sheet.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

ViewSheet Class


AddView Method

[image]

Revit 2013 API
ViewSheet..::..AddView Method
ViewSheet Class Example See Also Send Feedback
Places view on the sheet at the given location.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This method is obsolete in 2013. Call Viewport.Create instead.")]
public void AddView(
    View newView,
    UV location
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in 2013. Call Viewport.Create instead.")> _
Public Sub AddView ( _
    newView As View, _
    location As UV _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in 2013. Call Viewport.Create instead.")]
public:
void AddView(
    View^ newView,
    UV^ location
)

Parameters

newView
Type: Autodesk.Revit.DB..::..View
The view to be placed.
location
Type: Autodesk.Revit.DB..::..UV
Sheet coordinates (in inches) of the center of the view.

Remarks

Views cannot be added to placeholder sheets. Invalid operation exception occurs if the sheet is a placeholder sheet. Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet) or the view is already placed on another sheet. The lower left corner of the sheet has coordinates [0,0]. Empty views are not placed on the sheet but no exception occurs.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
private void PlaceViewOnSheet(Document document, ViewSheet viewSheet)
{
    //Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    //or the view is already placed on another sheet.
    //The lower left corner of the sheet has coordinates [0,0].
    //Empty views are not placed on the sheet but no exception occurs.

    //put a view into the sheet
    //the location of the view in the view sheet
   UV viewLocation = new UV(1.5, 1.5);
    //get a view form the view list
    Autodesk.Revit.DB.View tempView = document.ActiveView;
    if (null != tempView)
    {
        viewSheet.AddView(tempView, viewLocation);
        TaskDialog.Show("Revit","Added a view to the sheet successfully.");
    }
}
CopyVB.NET
Private Sub PlaceViewOnSheet(ByVal document As Document, ByVal viewSheet As ViewSheet)
    'Argument exception occurs if the view is of inappropriate type (e.g. ViewSheet)
    'or the view is already placed on another sheet.
    'The lower left corner of the sheet has coordinates [0,0].
    'Empty views are not placed on the sheet but no exception occurs.

    'put a view into the sheet
    'the location of the view in the view sheet
    Dim viewLocation As New Autodesk.Revit.DB.UV(1.5, 1.5)
    'get a view form the view list
    Dim tempView As Autodesk.Revit.DB.View = document.ActiveView
    If tempView IsNot Nothing Then
        viewSheet.AddView(tempView, viewLocation)
        TaskDialog.Show("Revit", "nAdd a view to the viewSheet successfully.")
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

ViewSheet Class


ConvertToRealSheet Method

[image]

Revit 2013 API
ViewSheet..::..ConvertToRealSheet Method
ViewSheet Class See Also Send Feedback
Convert a placeholder sheet to a real one with an optional titleblock

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void ConvertToRealSheet(
    ElementId titleblockElementId
)
Visual Basic
Public Sub ConvertToRealSheet ( _
    titleblockElementId As ElementId _
)
Visual C++
public:
void ConvertToRealSheet(
    ElementId^ titleblockElementId
)

Parameters

titleblockElementId
Type: Autodesk.Revit.DB..::..ElementId
The type id of titleblock for the real sheet. If it is nullNothingnullptra null reference (Nothing in Visual Basic) or an InvalidElementId, no titleblock will be created.

Remarks

This method should only be called on a placeholder sheet, otherwise exception will occur.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | If titleblockElementId is a valid type id but not a titleblock symbol id.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If the method is not called on a placeholder sheet or the input titleblock could not be applied.

See Also

ViewSheet Class


Create Method

[image]

Revit 2013 API
ViewSheet..::..Create Method
ViewSheet Class See Also Send Feedback
Creates a new ViewSheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ViewSheet Create(
    Document document,
    ElementId titleBlockTypeId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    titleBlockTypeId As ElementId _
) As ViewSheet
Visual C++
public:
static ViewSheet^ Create(
    Document^ document,
    ElementId^ titleBlockTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to which the ViewSheet will be added.
titleBlockTypeId
Type: Autodesk.Revit.DB..::..ElementId
The type id of the TitleBlock type which will be used by the new ViewSheet. For no TitleBlock, pass invalid element ID.

Return Value

The new ViewSheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId titleBlockTypeId does not correspond to a TitleBlock type. -or- document is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

ViewSheet Class


CreatePlaceholder Method

[image]

Revit 2013 API
ViewSheet..::..CreatePlaceholder Method
ViewSheet Class See Also Send Feedback
Create a placeholder sheet in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ViewSheet CreatePlaceholder(
    Document document
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    document As Document _
) As ViewSheet
Visual C++
public:
static ViewSheet^ CreatePlaceholder(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the placeholder sheet will be created.

Remarks

Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.

See Also

ViewSheet Class


DeleteViewport Method

[image]

Revit 2013 API
ViewSheet..::..DeleteViewport Method
ViewSheet Class See Also Send Feedback
Removes a viewport from the sheet by deleting it from the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void DeleteViewport(
    Viewport viewport
)
Visual Basic
Public Sub DeleteViewport ( _
    viewport As Viewport _
)
Visual C++
public:
void DeleteViewport(
    Viewport^ viewport
)

Parameters

viewport
Type: Autodesk.Revit.DB..::..Viewport
The viewport that will be deleted and removed from the sheet.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ViewSheet Class


GetAllViewports Method

[image]

Revit 2013 API
ViewSheet..::..GetAllViewports Method
ViewSheet Class See Also Send Feedback
Returns the ElementIds of Viewports on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetAllViewports()
Visual Basic
Public Function GetAllViewports As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAllViewports()

Return Value

The Viewports on this sheet.

See Also

ViewSheet Class


Print Method

[image] [image]

Revit 2013 API
ViewSheet..::..Print Method
ViewSheet Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

ViewSheet Class
ViewSheet Members


ViewSheet Properties

[image] [image]

Revit 2013 API
ViewSheet Properties
ViewSheet Class See Also Send Feedback

The ViewSheet type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies whether or not the view sheet represents a placeholder sheet.
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SheetNumber | Sheet number is unique in the document.
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | Views | Returns the set of all views on the sheet.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheet Class


IsPlaceholder Property

[image]

Revit 2013 API
ViewSheet..::..IsPlaceholder Property
ViewSheet Class See Also Send Feedback
Identifies whether or not the view sheet represents a placeholder sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsPlaceholder { get; }
Visual Basic
Public ReadOnly Property IsPlaceholder As Boolean
    Get
Visual C++
public:
property bool IsPlaceholder {
    bool get ();
}

Remarks

Placeholder sheets represent sheets stored outside of the Revit model, but which should be organized along with the Revit sheets.

See Also

ViewSheet Class


Parameter Property

[image] [image]

Revit 2013 API
ViewSheet..::..Parameter Property
ViewSheet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSheet Class
ViewSheet Members


SheetNumber Property

[image]

Revit 2013 API
ViewSheet..::..SheetNumber Property
ViewSheet Class See Also Send Feedback
Sheet number is unique in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string SheetNumber { get; set; }
Visual Basic
Public Property SheetNumber As String
    Get
    Set
Visual C++
public:
property String^ SheetNumber {
    String^ get ();
    void set (String^ value);
}

Remarks

Exception occurs when trying to set the value that is not unique.

See Also

ViewSheet Class


Views Property

[image]

Revit 2013 API
ViewSheet..::..Views Property
ViewSheet Class See Also Send Feedback
Returns the set of all views on the sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSet Views { get; }
Visual Basic
Public ReadOnly Property Views As ViewSet
    Get
Visual C++
public:
property ViewSet^ Views {
    ViewSet^ get ();
}

See Also

ViewSheet Class


ViewSheetSet Class

[image]

Revit 2013 API
ViewSheetSet Class
Members See Also Send Feedback
Represents ViewSheetSets stored in a document. ViewSheetSets can be stored so that the same printing task can be executed multiple times.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSheetSet : Element,
    IViewSheetSet
Visual Basic
Public Class ViewSheetSet _
    Inherits Element _
    Implements IViewSheetSet
Visual C++
public ref class ViewSheetSet : public Element,
    IViewSheetSet

Remarks

For the in-session ViewSheetSet, see the class InSessionViewSheetSet.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ViewSheetSet

See Also

ViewSheetSet Members


ViewSheetSet Members

[image] [image]

Revit 2013 API
ViewSheetSet Members
ViewSheetSet Class Methods Properties See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The view sheet set name. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheetSet Class


ViewSheetSet Methods

[image] [image]

Revit 2013 API
ViewSheetSet Methods
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSet Class


ViewSheetSet Properties

[image] [image]

Revit 2013 API
ViewSheetSet Properties
ViewSheetSet Class See Also Send Feedback

The ViewSheetSet type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The view sheet set name. (Overrides Element..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | Views | The views.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ViewSheetSet Class


Name Property

[image]

Revit 2013 API
ViewSheetSet..::..Name Property
ViewSheetSet Class See Also Send Feedback
The view sheet set name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; set; }
Visual Basic
Public Overrides Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to set the name. Instead, set the name with the Rename(String) method.

See Also

ViewSheetSet Class


Parameter Property

[image] [image]

Revit 2013 API
ViewSheetSet..::..Parameter Property
ViewSheetSet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ViewSheetSet Class
ViewSheetSet Members


Views Property

[image]

Revit 2013 API
ViewSheetSet..::..Views Property
ViewSheetSet Class See Also Send Feedback
The views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSet Views { get; set; }
Visual Basic
Public Overridable Property Views As ViewSet
    Get
    Set
Visual C++
public:
virtual property ViewSet^ Views {
    ViewSet^ get ();
    void set (ViewSet^ value);
}

Implements

IViewSheetSet..::..Views

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input views is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed due to invalid view which cannot be printed.

See Also

ViewSheetSet Class


ViewSheetSets Class

[image]

Revit 2013 API
ViewSheetSets Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSheetSets : APIObject,
    IEnumerable
Visual Basic
Public Class ViewSheetSets _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ViewSheetSets : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSheetSets

See Also

ViewSheetSets Members


ViewSheetSets Members

[image] [image]

Revit 2013 API
ViewSheetSets Members
ViewSheetSets Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSets type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSheetSets | Initializes a new instance of the ViewSheetSets class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class


ViewSheetSets Constructor

[image]

Revit 2013 API
ViewSheetSets Constructor
ViewSheetSets Class See Also Send Feedback
Initializes a new instance of the ViewSheetSets class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSheetSets()
Visual Basic
Public Sub New
Visual C++
public:
ViewSheetSets()

See Also

ViewSheetSets Class


ViewSheetSets Methods

[image] [image]

Revit 2013 API
ViewSheetSets Methods
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSets Class


Clear Method

[image]

Revit 2013 API
ViewSheetSets..::..Clear Method
ViewSheetSets Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ViewSheetSets Class


Contains Method

[image]

Revit 2013 API
ViewSheetSets..::..Contains Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    ViewSheetSet item
)
Visual Basic
Public Overridable Function Contains ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ViewSheetSet

See Also

ViewSheetSets Class


Erase Method

[image]

Revit 2013 API
ViewSheetSets..::..Erase Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    ViewSheetSet item
)
Visual Basic
Public Overridable Function Erase ( _
    item As ViewSheetSet _
) As Integer
Visual C++
public:
virtual int Erase(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ViewSheetSet

See Also

ViewSheetSets Class


ForwardIterator Method

[image]

Revit 2013 API
ViewSheetSets..::..ForwardIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ViewSheetSets Class


GetEnumerator Method

[image]

Revit 2013 API
ViewSheetSets..::..GetEnumerator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ViewSheetSets Class


Insert Method

[image]

Revit 2013 API
ViewSheetSets..::..Insert Method
ViewSheetSets Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    ViewSheetSet item
)
Visual Basic
Public Overridable Function Insert ( _
    item As ViewSheetSet _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ViewSheetSet^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..ViewSheetSet

See Also

ViewSheetSets Class


ReverseIterator Method

[image]

Revit 2013 API
ViewSheetSets..::..ReverseIterator Method
ViewSheetSets Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ViewSheetSetsIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ViewSheetSetsIterator
Visual C++
public:
virtual ViewSheetSetsIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ViewSheetSets Class


ViewSheetSets Properties

[image] [image]

Revit 2013 API
ViewSheetSets Properties
ViewSheetSets Class See Also Send Feedback

The ViewSheetSets type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ViewSheetSets Class


IsEmpty Property

[image]

Revit 2013 API
ViewSheetSets..::..IsEmpty Property
ViewSheetSets Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ViewSheetSets Class


Size Property

[image]

Revit 2013 API
ViewSheetSets..::..Size Property
ViewSheetSets Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ViewSheetSets Class


ViewSheetSetsIterator Class

[image]

Revit 2013 API
ViewSheetSetsIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ViewSheetSetsIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ViewSheetSetsIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ViewSheetSetsIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSheetSetsIterator

See Also

ViewSheetSetsIterator Members


ViewSheetSetsIterator Members

[image] [image]

Revit 2013 API
ViewSheetSetsIterator Members
ViewSheetSetsIterator Class Constructors Methods Properties See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ViewSheetSetsIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Constructor

[image]

Revit 2013 API
ViewSheetSetsIterator Constructor
ViewSheetSetsIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSheetSetsIterator()
Visual Basic
Public Sub New
Visual C++
public:
ViewSheetSetsIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Methods

[image] [image]

Revit 2013 API
ViewSheetSetsIterator Methods
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetsIterator Class


MoveNext Method

[image]

Revit 2013 API
ViewSheetSetsIterator..::..MoveNext Method
ViewSheetSetsIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class


Reset Method

[image]

Revit 2013 API
ViewSheetSetsIterator..::..Reset Method
ViewSheetSetsIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ViewSheetSetsIterator Class


ViewSheetSetsIterator Properties

[image] [image]

Revit 2013 API
ViewSheetSetsIterator Properties
ViewSheetSetsIterator Class See Also Send Feedback

The ViewSheetSetsIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetsIterator Class


Current Property

[image]

Revit 2013 API
ViewSheetSetsIterator..::..Current Property
ViewSheetSetsIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ViewSheetSetsIterator Class


ViewSheetSetting Class

[image]

Revit 2013 API
ViewSheetSetting Class
Members See Also Send Feedback
Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewSheetSetting : APIObject
Visual Basic
Public Class ViewSheetSetting _
    Inherits APIObject
Visual C++
public ref class ViewSheetSetting : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ViewSheetSetting

See Also

ViewSheetSetting Members


ViewSheetSetting Members

[image] [image]

Revit 2013 API
ViewSheetSetting Members
ViewSheetSetting Class Methods Properties See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


ViewSheetSetting Methods

[image] [image]

Revit 2013 API
ViewSheetSetting Methods
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Methods

 | Name | Description
Public method | Delete | Delete the current view sheet set, and make the In-Session set as the current one.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Rename | Rename the current view sheet set.
Public method | Revert | Revert the current view sheet set.
Public method | Save | Save the changes for the current view sheet set.
Public method | SaveAs | Save the current view sheet set to another view sheet set with the specified name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewSheetSetting Class


Delete Method

[image]

Revit 2013 API
ViewSheetSetting..::..Delete Method
ViewSheetSetting Class See Also Send Feedback
Delete the current view sheet set, and make the In-Session set as the current one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Delete()
Visual Basic
Public Function Delete As Boolean
Visual C++
public:
bool Delete()

Return Value

False if Delete operation fails, otherwise True.

Remarks

If the current view sheet set is In-Session, an InvalidOperationException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Rename Method

[image]

Revit 2013 API
ViewSheetSetting..::..Rename Method
ViewSheetSetting Class See Also Send Feedback
Rename the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Rename(
    string newName
)
Visual Basic
Public Function Rename ( _
    newName As String _
) As Boolean
Visual C++
public:
bool Rename(
    String^ newName
)

Parameters

newName
Type: System..::..String
View sheet set name to be renamed as.

Return Value

False if Rename operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


Revert Method

[image]

Revit 2013 API
ViewSheetSetting..::..Revert Method
ViewSheetSetting Class See Also Send Feedback
Revert the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Revert()
Visual Basic
Public Sub Revert
Visual C++
public:
void Revert()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session.

See Also

ViewSheetSetting Class


Save Method

[image]

Revit 2013 API
ViewSheetSetting..::..Save Method
ViewSheetSetting Class See Also Send Feedback
Save the changes for the current view sheet set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Save()
Visual Basic
Public Function Save As Boolean
Visual C++
public:
bool Save()

Return Value

False if save operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current view sheet set is In-Session or the current view sheet set is unchanged.

See Also

ViewSheetSetting Class


SaveAs Method

[image]

Revit 2013 API
ViewSheetSetting..::..SaveAs Method
ViewSheetSetting Class See Also Send Feedback
Save the current view sheet set to another view sheet set with the specified name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs(
    string newName
)
Visual Basic
Public Function SaveAs ( _
    newName As String _
) As Boolean
Visual C++
public:
bool SaveAs(
    String^ newName
)

Parameters

newName
Type: System..::..String
View sheet set name to be saved as.

Return Value

False if Save As operation fails, otherwise True.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input name is already existed in current view sheet set list.

See Also

ViewSheetSetting Class


ViewSheetSetting Properties

[image] [image]

Revit 2013 API
ViewSheetSetting Properties
ViewSheetSetting Class See Also Send Feedback

The ViewSheetSetting type exposes the following members.

Properties

 | Name | Description
Public property | AvailableViews | All views that can be printed.
Public property | CurrentViewSheetSet | The current view sheet set of PrintSetup.
Public property | InSession | The in-session view sheet set of Print Setup.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ViewSheetSetting Class


AvailableViews Property

[image]

Revit 2013 API
ViewSheetSetting..::..AvailableViews Property
ViewSheetSetting Class See Also Send Feedback
All views that can be printed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ViewSet AvailableViews { get; }
Visual Basic
Public ReadOnly Property AvailableViews As ViewSet
    Get
Visual C++
public:
property ViewSet^ AvailableViews {
    ViewSet^ get ();
}

Remarks

Users can select the view/sheet from this view set to printing.

See Also

ViewSheetSetting Class


CurrentViewSheetSet Property

[image]

Revit 2013 API
ViewSheetSetting..::..CurrentViewSheetSet Property
ViewSheetSetting Class See Also Send Feedback
The current view sheet set of PrintSetup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IViewSheetSet CurrentViewSheetSet { get; set; }
Visual Basic
Public Property CurrentViewSheetSet As IViewSheetSet
    Get
    Set
Visual C++
public:
property IViewSheetSet^ CurrentViewSheetSet {
    IViewSheetSet^ get ();
    void set (IViewSheetSet^ value);
}

See Also

ViewSheetSetting Class


InSession Property

[image]

Revit 2013 API
ViewSheetSetting..::..InSession Property
ViewSheetSetting Class See Also Send Feedback
The in-session view sheet set of Print Setup.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InSessionViewSheetSet InSession { get; }
Visual Basic
Public ReadOnly Property InSession As InSessionViewSheetSet
    Get
Visual C++
public:
property InSessionViewSheetSet^ InSession {
    InSessionViewSheetSet^ get ();
}

See Also

ViewSheetSetting Class


ViewTemplateApplicationOption Enumeration

[image]

Revit 2013 API
ViewTemplateApplicationOption Enumeration
See Also Send Feedback
Options for applying view templates

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ViewTemplateApplicationOption
Visual Basic
Public Enumeration ViewTemplateApplicationOption
Visual C++
public enum class ViewTemplateApplicationOption

Members

Member name | Description
AllParameters | Apply all parameters controlled by template
UncontrolledParameters | Apply only parameters controlled by template and not controlled by currently assigned view template
AllParametersAndStickIfNone | Apply all parameters controlled by template and if none is currently assigned make it view template

See Also


ViewType Enumeration

[image]

Revit 2013 API
ViewType Enumeration
See Also Send Feedback
An enumerated type listing available view types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ViewType
Visual Basic
Public Enumeration ViewType
Visual C++
public enum class ViewType

Members

Member name | Description
Undefined | Undefined/unspecified type of view.
FloorPlan | Floor plan type of view.
CeilingPlan | Reflected ceiling plan type of view.
Elevation | Elevation type of view.
ThreeD | 3-D type of view.
Schedule | Schedule type of view.
DrawingSheet | Drawing sheet type of view.
Report | Report type of view.
DraftingView | Drafting type of view.
Legend | Legend type of view.
EngineeringPlan | Engineering Floor Plan type of view.
AreaPlan | Area plan type of view.
Section | Cross section type of view.
Detail | Detail type of view.
CostReport | Cost Report view.
LoadsReport | Loads Report view.
PresureLossReport | Pressure Loss Report view.
ColumnSchedule | Column Schedule type of view.
PanelSchedule | Panel Schedule Report view.
Walkthrough | Walk-Through type of 3D view.
Rendering | Rendering type of view.
Internal | Revit's internal type of view

See Also


VirtualPrinterType Enumeration

[image]

Revit 2013 API
VirtualPrinterType Enumeration
See Also Send Feedback
An enumerated to list Virtual Printer Types in Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum VirtualPrinterType
Visual Basic
Public Enumeration VirtualPrinterType
Visual C++
public enum class VirtualPrinterType

Members

Member name | Description
None | None.
AdobePDF | AdobePDF.
DWFWriter | DWFWriter.
XPSWriter | Microsoft XPS Document Writer.

See Also


Visibility Enumeration

[image]

Revit 2013 API
Visibility Enumeration
See Also Send Feedback
Describes the visibility of a particular geometry object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum Visibility
Visual Basic
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Visible | The geometry object is always visible. This type of geometry is always returned by Geometry[([( Options])])
Highlight | The geometry object is visible, but is affected by highlight or prehighlight special coloration. This type of geometry is returned by Geometry[([( Options])]) if IncludeNonVisibleObjects is true.
Contextual | The geometry object is visible in some contexts, but not in others. This type of geometry is always returned by Geometry[([( Options])]) , even when Revit is in a context where the geometry should not be visible, but only if IncludeNonVisibleObjects is true. Examples of geometry of this class include Solids representing insulation and lining for MEP ducts and pipes.
Invisible | The geometry object is never visible. This type of geometry is never returned by Geometry[([( Options])]) but may be obtained by other API operations.

See Also


VolumeCalculationOptions Class

[image]

Revit 2013 API
VolumeCalculationOptions Class
Members See Also Send Feedback
This class provides access to options related to room volume and area computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VolumeCalculationOptions
Visual Basic
Public Class VolumeCalculationOptions
Visual C++
public ref class VolumeCalculationOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VolumeCalculationOptions

See Also

VolumeCalculationOptions Members


VolumeCalculationOptions Members

[image] [image]

Revit 2013 API
VolumeCalculationOptions Members
VolumeCalculationOptions Class Constructors Methods Properties See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Constructors

 | Name | Description
Public method | VolumeCalculationOptions | Creates a new instance of the volume calculation options.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Constructor

[image]

Revit 2013 API
VolumeCalculationOptions Constructor
VolumeCalculationOptions Class See Also Send Feedback
Creates a new instance of the volume calculation options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VolumeCalculationOptions()
Visual Basic
Public Sub New
Visual C++
public:
VolumeCalculationOptions()

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Methods

[image] [image]

Revit 2013 API
VolumeCalculationOptions Methods
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationOptions Class


VolumeCalculationOptions Properties

[image] [image]

Revit 2013 API
VolumeCalculationOptions Properties
VolumeCalculationOptions Class See Also Send Feedback

The VolumeCalculationOptions type exposes the following members.

Properties

 | Name | Description
Public property | RoomAreaBoundaryLocation | The location used to calculate area and volume from room boundaries.
Public property | VolumeComputationEnable | True to enable volume computation in Revit. False to disable it.

See Also

VolumeCalculationOptions Class


RoomAreaBoundaryLocation Property

[image]

Revit 2013 API
VolumeCalculationOptions..::..RoomAreaBoundaryLocation Property
VolumeCalculationOptions Class See Also Send Feedback
The location used to calculate area and volume from room boundaries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundaryLocationType RoomAreaBoundaryLocation { get; set; }
Visual Basic
Public Property RoomAreaBoundaryLocation As BoundaryLocationType
    Get
    Set
Visual C++
public:
property BoundaryLocationType RoomAreaBoundaryLocation {
    BoundaryLocationType get ();
    void set (BoundaryLocationType value);
}

See Also

VolumeCalculationOptions Class


VolumeComputationEnable Property

[image]

Revit 2013 API
VolumeCalculationOptions..::..VolumeComputationEnable Property
VolumeCalculationOptions Class Example See Also Send Feedback
True to enable volume computation in Revit. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool VolumeComputationEnable { get; set; }
Visual Basic
Public Property VolumeComputationEnable As Boolean
    Get
    Set
Visual C++
public:
property bool VolumeComputationEnable {
    bool get ();
    void set (bool value);
}

Examples

CopyC#
public void GetRoomDimensions(Document doc, Room room)
{
    String roominfo = "Room dimensions:\n";
    // turn on volume calculations:
    VolumeCalculationOptions options = new VolumeCalculationOptions();
    options.VolumeComputationEnable = true;
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options;
    roominfo += "Vol: " + room.Volume + "\n";
    roominfo += "Area: " + room.Area + "\n";
    roominfo += "Perimeter: " + room.Perimeter + "\n";
    roominfo += "Unbounded height: " + room.UnboundedHeight + "\n";
    TaskDialog.Show("Revit",roominfo);
}
CopyVB.NET
Public Sub GetRoomDimensions(ByVal doc As Document, ByVal room As Room)
    Dim roominfo As [String] = "Room dimensions:" & vbLf
    ' turn on volume calculations:
    Dim options As New VolumeCalculationOptions()
    options.VolumeComputationEnable = True
    doc.Settings.VolumeCalculationSetting.VolumeCalculationOptions = options
    roominfo += "Vol: " + room.Volume + vbLf
    roominfo += "Area: " + room.Area + vbLf
    roominfo += "Perimiter: " + room.Perimeter + vbLf
    roominfo += "Unbounded height: " + room.UnboundedHeight + vbLf
    TaskDialog.Show("Revit", roominfo)
End Sub

See Also

VolumeCalculationOptions Class


VolumeCalculationSetting Class

[image]

Revit 2013 API
VolumeCalculationSetting Class
Members See Also Send Feedback
This class provides access to settings related to room volume and area computations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VolumeCalculationSetting
Visual Basic
Public Class VolumeCalculationSetting
Visual C++
public ref class VolumeCalculationSetting

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..VolumeCalculationSetting

See Also

VolumeCalculationSetting Members


VolumeCalculationSetting Members

[image] [image]

Revit 2013 API
VolumeCalculationSetting Members
VolumeCalculationSetting Class Methods Properties See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | VolumeCalculationOptions | Retrieves or changes the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class


VolumeCalculationSetting Methods

[image] [image]

Revit 2013 API
VolumeCalculationSetting Methods
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VolumeCalculationSetting Class


VolumeCalculationSetting Properties

[image] [image]

Revit 2013 API
VolumeCalculationSetting Properties
VolumeCalculationSetting Class See Also Send Feedback

The VolumeCalculationSetting type exposes the following members.

Properties

 | Name | Description
Public property | VolumeCalculationOptions | Retrieves or changes the application settings related to automatic calculation of room volumes.

See Also

VolumeCalculationSetting Class


VolumeCalculationOptions Property

[image]

Revit 2013 API
VolumeCalculationSetting..::..VolumeCalculationOptions Property
VolumeCalculationSetting Class See Also Send Feedback
Retrieves or changes the application settings related to automatic calculation of room volumes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VolumeCalculationOptions VolumeCalculationOptions { get; set; }
Visual Basic
Public Property VolumeCalculationOptions As VolumeCalculationOptions
    Get
    Set
Visual C++
public:
property VolumeCalculationOptions^ VolumeCalculationOptions {
    VolumeCalculationOptions^ get ();
    void set (VolumeCalculationOptions^ value);
}

See Also

VolumeCalculationSetting Class


Wall Class

[image]

Revit 2013 API
Wall Class
Members Example See Also Send Feedback
Represents a wall in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Wall : HostObject
Visual Basic
Public Class Wall _
    Inherits HostObject
Visual C++
public ref class Wall : public HostObject

Remarks

The wall object represents all the different kinds of walls in Revit.

Examples

CopyC#
public void GetInfo_Wall(Wall wall)
{
    string message = "Wall : ";
    // Get wall AnalyticalModel type
    AnalyticalModel model = wall.GetAnalyticalModel();
    if (null != model)
    {
        // For some situation(such as architecture wall or in building version),
        // this property may return null, but if it doesn't return null, it should
        // be AnalyticalModelWall.
        message += "\nWall AnalyticalModel type is : " + model;
    }

    wall.Flip();
    message += "\nIf wall Flipped : " + wall.Flipped;
    // Get curve start point
    message += "\nWall orientation point is :(" + wall.Orientation.X + ", "
        + wall.Orientation.Y + ", " + wall.Orientation.Z + ")";
    // Get wall StructuralUsage
    message += "\nWall StructuralUsage is : " + wall.StructuralUsage;
    // Get wall type name
    message += "\nWall type name is : " + wall.WallType.Name;
    // Get wall width
    message += "\nWall width is : " + wall.Width;

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_Wall(ByVal wall As Wall)
    Dim message As String = "Wall : "
    ' Get wall AnalyticalModel type
    Dim model As Autodesk.Revit.DB.Structure.AnalyticalModel = wall.GetAnalyticalModel()
    If model IsNot Nothing Then
        ' For some situation(such as architecture wall or in building version),
        ' this property may return null, but if it doesn't return null, it should
        ' be AnalyticalModelWall.
        message += vbLf & "Wall AnalyticalModel type is : " & model.ToString()
    End If

    wall.flip()
    message += vbLf & "If wall Flipped : " + wall.Flipped
    ' Get curve start point
    message += vbLf & "Wall orientation point is :(" + wall.Orientation.X + ", " + wall.Orientation.Y + ", " + wall.Orientation.Z + ")"
    ' Get wall StructuralUsage
    message += vbLf & "Wall StructuralUsage is : " + wall.StructuralUsage
    ' Get wall type name
    message += vbLf & "Wall type name is : " + wall.WallType.Name
    ' Get wall width
    message += vbLf & "Wall width is : " + wall.Width

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..Wall

See Also

Wall Members


Wall Members

[image] [image]

Revit 2013 API
Wall Members
Wall Class Methods Properties See Also Send Feedback

The Wall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | Flip | The wall orientation will be flipped.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Wall Class


Wall Methods

[image] [image]

Revit 2013 API
Wall Methods
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
 | Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
 | Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
 | Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | Flip | The wall orientation will be flipped.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wall Class


Create Method

[image] [image]

Revit 2013 API
Wall..::..Create Method
Wall Class See Also Send Feedback

Overload List

Name | Description
Create(Document, IList<(Of <<'(Curve>)>>), Boolean) | Creates a non rectangular profile wall within the project using the default wall type.
Create(Document, Curve, ElementId, Boolean) | Creates a new rectangular profile wall within the project using the default wall style.
Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean) | Creates a non rectangular profile wall within the project using the specified wall type.
Create(Document, IList<(Of <<'(Curve>)>>), ElementId, ElementId, Boolean, XYZ) | Creates a non rectangular profile wall within the project using the specified wall type and normal vector.
Create(Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean) | Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

See Also

Wall Class
Wall Members


Create Method (Document, IList(Curve), Boolean)

[image]

Revit 2013 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, Boolean)
Wall Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the default wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of planar lines and arcs that represent the vertical profile of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, Curve, ElementId, Boolean)

[image]

Revit 2013 API
Wall..::..Create Method (Document, Curve, ElementId, Boolean)
Wall Class See Also Send Feedback
Creates a new rectangular profile wall within the project using the default wall style.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId levelId,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    levelId As ElementId, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ levelId,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for rectangular wall creation. -or- The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, IList(Curve), ElementId, ElementId, Boolean)

[image]

Revit 2013 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, ElementId, ElementId, Boolean)
Wall Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of planar lines and arcs that represent the vertical profile of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, IList(Curve), ElementId, ElementId, Boolean, XYZ)

[image]

Revit 2013 API
Wall..::..Create Method (Document, IList<(Of <(<'Curve>)>)>, ElementId, ElementId, Boolean, XYZ)
Wall Class See Also Send Feedback
Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    IList<Curve> profile,
    ElementId wallTypeId,
    ElementId levelId,
    bool structural,
    XYZ normal
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    profile As IList(Of Curve), _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    structural As Boolean, _
    normal As XYZ _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    IList<Curve^>^ profile,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    bool structural,
    XYZ^ normal
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
profile
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of planar lines and arcs that represent the vertical profile of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
normal
Type: Autodesk.Revit.DB..::..XYZ
A vector that must be perpendicular to the profile which dictates which side of the wall is considered to be inside and outside.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input profile contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the wall.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)

[image]

Revit 2013 API
Wall..::..Create Method (Document, Curve, ElementId, ElementId, Double, Double, Boolean, Boolean)
Wall Class See Also Send Feedback
Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Wall Create(
    Document document,
    Curve curve,
    ElementId wallTypeId,
    ElementId levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    curve As Curve, _
    wallTypeId As ElementId, _
    levelId As ElementId, _
    height As Double, _
    offset As Double, _
    flip As Boolean, _
    structural As Boolean _
) As Wall
Visual C++
public:
static Wall^ Create(
    Document^ document,
    Curve^ curve,
    ElementId^ wallTypeId,
    ElementId^ levelId,
    double height,
    double offset,
    bool flip,
    bool structural
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
curve
Type: Autodesk.Revit.DB..::..Curve
An arc or line representing the base line of the wall.
wallTypeId
Type: Autodesk.Revit.DB..::..ElementId
Id of the wall type to be used by the new wall instead of the default type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level on which the wall is to be placed.
height
Type: System..::..Double
The height of the wall other than the default height.
offset
Type: System..::..Double
Modifies the wall's Base Offset parameter to determine its vertical placement.
flip
Type: System..::..Boolean
Change which side of the wall is considered to be the inside and outside of the wall.
structural
Type: System..::..Boolean
If set, specifies that the wall is structural in nature.

Return Value

If successful a new wall object within the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The curve argument is not valid for rectangular wall creation. -or- The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for offset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Wall Class
Create Overload


Flip Method

[image]

Revit 2013 API
Wall..::..Flip Method
Wall Class See Also Send Feedback
The wall orientation will be flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

See Also

Wall Class


Wall Properties

[image] [image]

Revit 2013 API
Wall Properties
Wall Class See Also Send Feedback

The Wall type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurtainGrid | Get the grid object of a curtain wall
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Property to test whether the wall orientation is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Orientation | The normal vector projected from the exterior side of the wall.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralUsage | Retrieves or changes the wall's designated structural usage.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WallType | Retrieves or changes the type of the wall.
Public property | Width | Get the overall thickness of the wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Wall Class


CurtainGrid Property

[image]

Revit 2013 API
Wall..::..CurtainGrid Property
Wall Class See Also Send Feedback
Get the grid object of a curtain wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurtainGrid CurtainGrid { get; }
Visual Basic
Public ReadOnly Property CurtainGrid As CurtainGrid
    Get
Visual C++
public:
property CurtainGrid^ CurtainGrid {
    CurtainGrid^ get ();
}

Remarks

This property is readonly.

See Also

Wall Class


Flipped Property

[image]

Revit 2013 API
Wall..::..Flipped Property
Wall Class See Also Send Feedback
Property to test whether the wall orientation is flipped.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Flipped { get; }
Visual Basic
Public ReadOnly Property Flipped As Boolean
    Get
Visual C++
public:
property bool Flipped {
    bool get ();
}

See Also

Wall Class


Orientation Property

[image]

Revit 2013 API
Wall..::..Orientation Property
Wall Class See Also Send Feedback
The normal vector projected from the exterior side of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Orientation { get; }
Visual Basic
Public ReadOnly Property Orientation As XYZ
    Get
Visual C++
public:
property XYZ^ Orientation {
    XYZ^ get ();
}

See Also

Wall Class


Parameter Property

[image] [image]

Revit 2013 API
Wall..::..Parameter Property
Wall Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Wall Class
Wall Members


StructuralUsage Property

[image]

Revit 2013 API
Wall..::..StructuralUsage Property
Wall Class See Also Send Feedback
Retrieves or changes the wall's designated structural usage.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public StructuralWallUsage StructuralUsage { get; set; }
Visual Basic
Public Property StructuralUsage As StructuralWallUsage
    Get
    Set
Visual C++
public:
property StructuralWallUsage StructuralUsage {
    StructuralWallUsage get ();
    void set (StructuralWallUsage value);
}

Field Value

The wall's designated structural usage, such as bearing or non bearing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The enum value is not invalid for StructuralWallUsage.

See Also

Wall Class


WallType Property

[image]

Revit 2013 API
Wall..::..WallType Property
Wall Class See Also Send Feedback
Retrieves or changes the type of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallType WallType { get; set; }
Visual Basic
Public Property WallType As WallType
    Get
    Set
Visual C++
public:
property WallType^ WallType {
    WallType^ get ();
    void set (WallType^ value);
}

Remarks

The WallType property can be used to retrieve the kind of the wall. This property can also be used to change the type of a wall by setting it to a different wall type. All the wall types in the project can be found using the Document.WallTypes property.

See Also

Wall Class


Width Property

[image]

Revit 2013 API
Wall..::..Width Property
Wall Class See Also Send Feedback
Get the overall thickness of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

See Also

Wall Class


WallFunction Enumeration

[image]

Revit 2013 API
WallFunction Enumeration
See Also Send Feedback
Indicates the function of a specified WallType, which is used for the BuiltInParameter WALL_ATTR_EXTERIOR.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum WallFunction
Visual Basic
Public Enumeration WallFunction
Visual C++
public enum class WallFunction

Members

Member name | Description
Interior |
Exterior |
Foundation |
Retaining |
Soffit |
Coreshaft |

See Also


WallKind Enumeration

[image]

Revit 2013 API
WallKind Enumeration
See Also Send Feedback
Describes the fundamental type of wall, such as curtain wall or stacked wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum WallKind
Visual Basic
Public Enumeration WallKind
Visual C++
public enum class WallKind

Members

Member name | Description
Unknown | The basic type is not known.
Basic | A standard wall.
Curtain | A curtain wall.
Stacked | A stacked wall of several wall types.

See Also


WallLocationLine Enumeration

[image]

Revit 2013 API
WallLocationLine Enumeration
See Also Send Feedback
This enumerated type represents the options for alignment of a wall's location line.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum WallLocationLine
Visual Basic
Public Enumeration WallLocationLine
Visual C++
public enum class WallLocationLine

Members

Member name | Description
WallCenterline | The wall location line is aligned to the center of the wall.
CoreCenterline | The wall location line is aligned to the center of the core.
FinishFaceExterior | The wall location line is aligned to the exterior face of the wall.
FinishFaceInterior | The wall location line is aligned to the interior face of the wall.
CoreExterior | The wall location line is aligned to the exterior face of the core.
CoreInterior | The wall location line is aligned to the exterior face of the core.

See Also


WallSide Enumeration

[image]

Revit 2013 API
WallSide Enumeration
See Also Send Feedback
Represents the possible sides of a wall where a sweep or reveal may be attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WallSide
Visual Basic
Public Enumeration WallSide
Visual C++
public enum class WallSide

Members

Member name | Description
Exterior | The exterior of the wall.
Interior | The interior of the wall.

See Also


WallSweep Class

[image]

Revit 2013 API
WallSweep Class
Members See Also Send Feedback
Represents a wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WallSweep : HostObject
Visual Basic
Public Class WallSweep _
    Inherits HostObject
Visual C++
public ref class WallSweep : public HostObject

Remarks

This element may represent either a standalone sweep or reveal element created by the Revit user interface or API, or a "fixed" wall sweep or reveal that was created by the contents of a wall's compound structure.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..WallSweep

See Also

WallSweep Members


WallSweep Members

[image] [image]

Revit 2013 API
WallSweep Members
WallSweep Class Methods Properties See Also Send Feedback

The WallSweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new wall sweep or reveal.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostIds | Gets a list of all host walls on which the sweep resides.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetWallSweepInfo | Gets the information of the wall sweep or reveal.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WallAllowsWallSweep | Validates that the wall is of a type that may be a host for a wall sweep or reveal.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WallSweep Class


WallSweep Methods

[image] [image]

Revit 2013 API
WallSweep Methods
WallSweep Class See Also Send Feedback

The WallSweep type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new wall sweep or reveal.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostIds | Gets a list of all host walls on which the sweep resides.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetWallSweepInfo | Gets the information of the wall sweep or reveal.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | WallAllowsWallSweep | Validates that the wall is of a type that may be a host for a wall sweep or reveal.

See Also

WallSweep Class


Create Method

[image]

Revit 2013 API
WallSweep..::..Create Method
WallSweep Class See Also Send Feedback
Creates a new wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static WallSweep Create(
    Wall wall,
    ElementId wallSweepType,
    WallSweepInfo wallSweepInfo
)
Visual Basic
Public Shared Function Create ( _
    wall As Wall, _
    wallSweepType As ElementId, _
    wallSweepInfo As WallSweepInfo _
) As WallSweep
Visual C++
public:
static WallSweep^ Create(
    Wall^ wall,
    ElementId^ wallSweepType,
    WallSweepInfo^ wallSweepInfo
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall upon which to create the new sweep or reveal.
wallSweepType
Type: Autodesk.Revit.DB..::..ElementId
The wall sweep or reveal type.
wallSweepInfo
Type: Autodesk.Revit.DB..::..WallSweepInfo
The information that describes the new wall sweep or reveal.

Return Value

The new wall sweep.

Remarks

The wall sweep's profile and type are taken from the wall sweep type properties. The values set in the WallSweepInfo are ignored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wall sweep info represents a fixed wall sweep. Fixed wall sweeps may not be assigned to standalone wall sweep elements. -or- The WallSweepInfo id must be set to -1 for a non-fixed wall sweep. -or- wall may not host a wall sweep or reveal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallSweep Class


GetHostIds Method

[image]

Revit 2013 API
WallSweep..::..GetHostIds Method
WallSweep Class See Also Send Feedback
Gets a list of all host walls on which the sweep resides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ElementId> GetHostIds()
Visual Basic
Public Function GetHostIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetHostIds()

Return Value

The list of wall ids.

Remarks

Fixed wall sweeps from vertically compound structures will return only one host element.

See Also

WallSweep Class


GetWallSweepInfo Method

[image]

Revit 2013 API
WallSweep..::..GetWallSweepInfo Method
WallSweep Class See Also Send Feedback
Gets the information of the wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSweepInfo GetWallSweepInfo()
Visual Basic
Public Function GetWallSweepInfo As WallSweepInfo
Visual C++
public:
WallSweepInfo^ GetWallSweepInfo()

Return Value

The information that describes the wall sweep or reveal.

See Also

WallSweep Class


WallAllowsWallSweep Method

[image]

Revit 2013 API
WallSweep..::..WallAllowsWallSweep Method
WallSweep Class See Also Send Feedback
Validates that the wall is of a type that may be a host for a wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool WallAllowsWallSweep(
    Wall wall
)
Visual Basic
Public Shared Function WallAllowsWallSweep ( _
    wall As Wall _
) As Boolean
Visual C++
public:
static bool WallAllowsWallSweep(
    Wall^ wall
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

True if the wall may host a wall sweep, false otherwise.

Remarks

This function excludes curtain walls and the main wall of a set of stacked walls. The wall must be fully regenerated for this function to work correctly.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallSweep Class


WallSweep Properties

[image] [image]

Revit 2013 API
WallSweep Properties
WallSweep Class See Also Send Feedback

The WallSweep type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WallSweep Class


Parameter Property

[image] [image]

Revit 2013 API
WallSweep..::..Parameter Property
WallSweep Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

WallSweep Class
WallSweep Members


WallSweepInfo Class

[image]

Revit 2013 API
WallSweepInfo Class
Members See Also Send Feedback
Represents a wall sweep or reveal of a vertically compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WallSweepInfo : IDisposable
Visual Basic
Public Class WallSweepInfo _
    Implements IDisposable
Visual C++
public ref class WallSweepInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WallSweepInfo

See Also

WallSweepInfo Members


WallSweepInfo Members

[image] [image]

Revit 2013 API
WallSweepInfo Members
WallSweepInfo Class Constructors Methods Properties See Also Send Feedback

The WallSweepInfo type exposes the following members.

Constructors

 | Name | Description
Public method | WallSweepInfo(Boolean, WallSweepType) | Constructs a new WallSweepInfo instance.
Public method | WallSweepInfo(WallSweepType, Boolean) | Constructs a new WallSweepInfo instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WallSweepInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CutsWall | Indicates if you want the sweep to cut geometry out of the host wall.
Public property | DefaultSetback | The sweep setback distance from inserts, such as windows and doors.
Public property | Distance | The distance from either the top or base of the wall.
Public property | DistanceMeasuredFrom | Indicates if Distance is measured from the top or bottom of the wall.
Public property | Id | The id of the sweep or reveal.
Public property | IsCutByInserts | Indicates if the sweep is cut by wall inserts.
Public property | IsFixed | Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public property | IsProfileFlipped | Indicates if the profile is applied upside-down.
Public property | IsVertical | Indicates whether the sweep or reveal is swept vertically or horizontally.
Public property | MaterialId | The element id of the material used to create the sweep or reveal.
Public property | ProfileId | The element id of the profile family used to create the sweep or reveal.
Public property | WallOffset | The offset from the sweep or reveal to the wall.
Public property | WallSide | The side of the wall to which the sweep or reveal is attached.
Public property | WallSweepType | The type (either a wall sweep or a reveal).

See Also

WallSweepInfo Class


WallSweepInfo Constructor

[image] [image]

Revit 2013 API
WallSweepInfo Constructor
WallSweepInfo Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WallSweepInfo(Boolean, WallSweepType) | Constructs a new WallSweepInfo instance.
Public method | WallSweepInfo(WallSweepType, Boolean) | Constructs a new WallSweepInfo instance.

See Also

WallSweepInfo Class
WallSweepInfo Members


WallSweepInfo Constructor (Boolean, WallSweepType)

[image]

Revit 2013 API
WallSweepInfo Constructor (Boolean, WallSweepType)
WallSweepInfo Class See Also Send Feedback
Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSweepInfo(
    bool fixed,
    WallSweepType type
)
Visual Basic
Public Sub New ( _
    fixed As Boolean, _
    type As WallSweepType _
)
Visual C++
public:
WallSweepInfo(
    bool fixed,
    WallSweepType type
)

Parameters

fixed
Type: System..::..Boolean
True if the WallSweepInfo should be fixed (suitable for use in CompoundStructure.AddWallSweep()). False if the WallSweepInfo should be suitable for use in standalone wall sweep or reveal elements.
type
Type: Autodesk.Revit.DB..::..WallSweepType
The type of the WallSweepInfo instance.

See Also

WallSweepInfo Class
WallSweepInfo Overload


WallSweepInfo Constructor (WallSweepType, Boolean)

[image]

Revit 2013 API
WallSweepInfo Constructor (WallSweepType, Boolean)
WallSweepInfo Class See Also Send Feedback
Constructs a new WallSweepInfo instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSweepInfo(
    WallSweepType type,
    bool vertical
)
Visual Basic
Public Sub New ( _
    type As WallSweepType, _
    vertical As Boolean _
)
Visual C++
public:
WallSweepInfo(
    WallSweepType type,
    bool vertical
)

Parameters

type
Type: Autodesk.Revit.DB..::..WallSweepType
The type of the WallSweepInfo instance.
vertical
Type: System..::..Boolean
True to construct a vertical wall sweep, false otherwise.

See Also

WallSweepInfo Class
WallSweepInfo Overload


WallSweepInfo Methods

[image] [image]

Revit 2013 API
WallSweepInfo Methods
WallSweepInfo Class See Also Send Feedback

The WallSweepInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallSweepInfo Class


Dispose Method

[image]

Revit 2013 API
WallSweepInfo..::..Dispose Method
WallSweepInfo Class See Also Send Feedback
Releases all resources used by the WallSweepInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WallSweepInfo Class


IsEqual Method

[image]

Revit 2013 API
WallSweepInfo..::..IsEqual Method
WallSweepInfo Class See Also Send Feedback

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEqual(
    WallSweepInfo toCompare
)
Visual Basic
Public Function IsEqual ( _
    toCompare As WallSweepInfo _
) As Boolean
Visual C++
public:
bool IsEqual(
    WallSweepInfo^ toCompare
)

Parameters

toCompare
Type: Autodesk.Revit.DB..::..WallSweepInfo

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallSweepInfo Class


WallSweepInfo Properties

[image] [image]

Revit 2013 API
WallSweepInfo Properties
WallSweepInfo Class See Also Send Feedback

The WallSweepInfo type exposes the following members.

Properties

 | Name | Description
Public property | CutsWall | Indicates if you want the sweep to cut geometry out of the host wall.
Public property | DefaultSetback | The sweep setback distance from inserts, such as windows and doors.
Public property | Distance | The distance from either the top or base of the wall.
Public property | DistanceMeasuredFrom | Indicates if Distance is measured from the top or bottom of the wall.
Public property | Id | The id of the sweep or reveal.
Public property | IsCutByInserts | Indicates if the sweep is cut by wall inserts.
Public property | IsFixed | Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.
Public property | IsProfileFlipped | Indicates if the profile is applied upside-down.
Public property | IsVertical | Indicates whether the sweep or reveal is swept vertically or horizontally.
Public property | MaterialId | The element id of the material used to create the sweep or reveal.
Public property | ProfileId | The element id of the profile family used to create the sweep or reveal.
Public property | WallOffset | The offset from the sweep or reveal to the wall.
Public property | WallSide | The side of the wall to which the sweep or reveal is attached.
Public property | WallSweepType | The type (either a wall sweep or a reveal).

See Also

WallSweepInfo Class


CutsWall Property

[image]

Revit 2013 API
WallSweepInfo..::..CutsWall Property
WallSweepInfo Class See Also Send Feedback
Indicates if you want the sweep to cut geometry out of the host wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool CutsWall { get; set; }
Visual Basic
Public Property CutsWall As Boolean
    Get
    Set
Visual C++
public:
property bool CutsWall {
    bool get ();
    void set (bool value);
}

Remarks

When a sweep is offset and embedded in the wall, it cuts the geometry from the wall.

See Also

WallSweepInfo Class


DefaultSetback Property

[image]

Revit 2013 API
WallSweepInfo..::..DefaultSetback Property
WallSweepInfo Class See Also Send Feedback
The sweep setback distance from inserts, such as windows and doors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double DefaultSetback { get; set; }
Visual Basic
Public Property DefaultSetback As Double
    Get
    Set
Visual C++
public:
property double DefaultSetback {
    double get ();
    void set (double value);
}

See Also

WallSweepInfo Class


Distance Property

[image]

Revit 2013 API
WallSweepInfo..::..Distance Property
WallSweepInfo Class See Also Send Feedback
The distance from either the top or base of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Field Value

DistanceMeasuredFrom determines whether the measurement is from the top or base of the wall. If the sweep or reveal is vertical, this is the horizontal distance from the start or end of the wall.

See Also

WallSweepInfo Class


DistanceMeasuredFrom Property

[image]

Revit 2013 API
WallSweepInfo..::..DistanceMeasuredFrom Property
WallSweepInfo Class See Also Send Feedback
Indicates if Distance is measured from the top or bottom of the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public DistanceMeasuredFrom DistanceMeasuredFrom { get; set; }
Visual Basic
Public Property DistanceMeasuredFrom As DistanceMeasuredFrom
    Get
    Set
Visual C++
public:
property DistanceMeasuredFrom DistanceMeasuredFrom {
    DistanceMeasuredFrom get ();
    void set (DistanceMeasuredFrom value);
}

Field Value

If the sweep or reveal is vertical, DistanceMeasuredFrom.Base represents the start of the wall's location curve (t=0), and DistanceMeasuredFrom.Top represents the end of the wall's location curve (t=1).

See Also

WallSweepInfo Class


Id Property

[image]

Revit 2013 API
WallSweepInfo..::..Id Property
WallSweepInfo Class See Also Send Feedback
The id of the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Id { get; set; }
Visual Basic
Public Property Id As Integer
    Get
    Set
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

Field Value

If the wall sweep belongs to a vertically compound structure, this must be a non-negative value. If the wall sweep belongs to a sweep defined outside of compound structures by UI or API the id will typically be -1 and is not used.

See Also

WallSweepInfo Class


IsCutByInserts Property

[image]

Revit 2013 API
WallSweepInfo..::..IsCutByInserts Property
WallSweepInfo Class See Also Send Feedback
Indicates if the sweep is cut by wall inserts.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsCutByInserts { get; set; }
Visual Basic
Public Property IsCutByInserts As Boolean
    Get
    Set
Visual C++
public:
property bool IsCutByInserts {
    bool get ();
    void set (bool value);
}

Field Value

True if the sweep is cut by wall inserts, false otherwise.

See Also

WallSweepInfo Class


IsFixed Property

[image]

Revit 2013 API
WallSweepInfo..::..IsFixed Property
WallSweepInfo Class See Also Send Feedback
Indicates if the described wall sweep is fixed. A sweep is fixed if it is a part of a vertical compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFixed { get; }
Visual Basic
Public ReadOnly Property IsFixed As Boolean
    Get
Visual C++
public:
property bool IsFixed {
    bool get ();
}

Field Value

True if it is fixed, false if it is allowed to be moved.

Remarks

Wall sweeps from the definition of a vertical compound structure are fixed based on the wall type's definition. They are not permitted to be moved by users. Other wall sweeps defined outside of CompoundStructure by UI or API are permitted to be moved.

See Also

WallSweepInfo Class


IsProfileFlipped Property

[image]

Revit 2013 API
WallSweepInfo..::..IsProfileFlipped Property
WallSweepInfo Class See Also Send Feedback
Indicates if the profile is applied upside-down.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsProfileFlipped { get; set; }
Visual Basic
Public Property IsProfileFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsProfileFlipped {
    bool get ();
    void set (bool value);
}

Field Value

True if the profile is applied upside-down, false otherwise.

See Also

WallSweepInfo Class


IsVertical Property

[image]

Revit 2013 API
WallSweepInfo..::..IsVertical Property
WallSweepInfo Class See Also Send Feedback
Indicates whether the sweep or reveal is swept vertically or horizontally.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsVertical { get; }
Visual Basic
Public ReadOnly Property IsVertical As Boolean
    Get
Visual C++
public:
property bool IsVertical {
    bool get ();
}

Field Value

True if the sweep or reveal is swept vertically, false if it is swept horizontally.

Remarks

Wall sweeps defined as a part of a vertical compound structure will always be horizontal.

See Also

WallSweepInfo Class


MaterialId Property

[image]

Revit 2013 API
WallSweepInfo..::..MaterialId Property
WallSweepInfo Class See Also Send Feedback
The element id of the material used to create the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

This value is not used when creating standalone wall sweeps. The material id of the wall sweep's type is used instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

WallSweepInfo Class


ProfileId Property

[image]

Revit 2013 API
WallSweepInfo..::..ProfileId Property
WallSweepInfo Class See Also Send Feedback
The element id of the profile family used to create the sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ProfileId { get; set; }
Visual Basic
Public Property ProfileId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

May be InvalidElementId if the default profile is used.

Remarks

This value is not used when creating standalone wall sweeps. The profile id of the wall sweep's type is used instead.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

WallSweepInfo Class


WallOffset Property

[image]

Revit 2013 API
WallSweepInfo..::..WallOffset Property
WallSweepInfo Class See Also Send Feedback
The offset from the sweep or reveal to the wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double WallOffset { get; set; }
Visual Basic
Public Property WallOffset As Double
    Get
    Set
Visual C++
public:
property double WallOffset {
    double get ();
    void set (double value);
}

Field Value

A negative value moves the sweep toward the wall core.

See Also

WallSweepInfo Class


WallSide Property

[image]

Revit 2013 API
WallSweepInfo..::..WallSide Property
WallSweepInfo Class See Also Send Feedback
The side of the wall to which the sweep or reveal is attached.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSide WallSide { get; set; }
Visual Basic
Public Property WallSide As WallSide
    Get
    Set
Visual C++
public:
property WallSide WallSide {
    WallSide get ();
    void set (WallSide value);
}

See Also

WallSweepInfo Class


WallSweepType Property

[image]

Revit 2013 API
WallSweepInfo..::..WallSweepType Property
WallSweepInfo Class See Also Send Feedback
The type (either a wall sweep or a reveal).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WallSweepType WallSweepType { get; set; }
Visual Basic
Public Property WallSweepType As WallSweepType
    Get
    Set
Visual C++
public:
property WallSweepType WallSweepType {
    WallSweepType get ();
    void set (WallSweepType value);
}

See Also

WallSweepInfo Class


WallSweepType Enumeration

[image]

Revit 2013 API
WallSweepType Enumeration
See Also Send Feedback
Represents the possible types for methods affecting wall sweeps or reveals.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WallSweepType
Visual Basic
Public Enumeration WallSweepType
Visual C++
public enum class WallSweepType

Members

Member name | Description
Sweep | Represents a wall sweep.
Reveal | Represents a reveal.

See Also


WallType Class

[image]

Revit 2013 API
WallType Class
Members Example See Also Send Feedback
Represents a specific type of wall, such as 'Generic -8" '.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WallType : HostObjAttributes
Visual Basic
Public Class WallType _
    Inherits HostObjAttributes
Visual C++
public ref class WallType : public HostObjAttributes

Remarks

All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.

Examples

CopyC#
public void GetInfo_WallType(WallType wallType)
{
    string message;
    // Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString();

    // Get the overall thickness of this type of wall.
    message += "\nThe wall type Width is : " + wallType.Width.ToString();

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_WallType(ByVal wallType As WallType)
    Dim message As String
    ' Reports the nature of the wall
    message = "The wall type kind is : " + wallType.Kind.ToString()

    ' Get the overall thickness of this type of wall.
    message += vbLf & "The wall type Width is : " + wallType.Width.ToString()

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..WallType

See Also

WallType Members


WallType Members

[image] [image]

Revit 2013 API
WallType Members
WallType Class Methods Properties See Also Send Feedback

The WallType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Kind | Reports the nature of the wall
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the WallType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Returns the overall thickness of this type of wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WallType Class


WallType Methods

[image] [image]

Revit 2013 API
WallType Methods
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallType Class


WallType Properties

[image] [image]

Revit 2013 API
WallType Properties
WallType Class See Also Send Feedback

The WallType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Kind | Reports the nature of the wall
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ThermalProperties | The calculated and settable thermal properties of the WallType
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | Returns the overall thickness of this type of wall.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WallType Class


Kind Property

[image]

Revit 2013 API
WallType..::..Kind Property
WallType Class See Also Send Feedback
Reports the nature of the wall

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallKind Kind { get; }
Visual Basic
Public ReadOnly Property Kind As WallKind
    Get
Visual C++
public:
property WallKind Kind {
    WallKind get ();
}

See Also

WallType Class


Parameter Property

[image] [image]

Revit 2013 API
WallType..::..Parameter Property
WallType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

WallType Class
WallType Members


ThermalProperties Property

[image]

Revit 2013 API
WallType..::..ThermalProperties Property
WallType Class See Also Send Feedback
The calculated and settable thermal properties of the WallType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ThermalProperties ThermalProperties { get; }
Visual Basic
Public ReadOnly Property ThermalProperties As ThermalProperties
    Get
Visual C++
public:
property ThermalProperties^ ThermalProperties {
    ThermalProperties^ get ();
}

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the wall has no thermal properties. Curtain walls and stacked walls do not store thermal properties.

See Also

WallType Class


Width Property

[image]

Revit 2013 API
WallType..::..Width Property
WallType Class See Also Send Feedback
Returns the overall thickness of this type of wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

See Also

WallType Class


WallTypeSet Class

[image]

Revit 2013 API
WallTypeSet Class
Members See Also Send Feedback
A set that contains wall types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WallTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class WallTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WallTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..WallTypeSet

See Also

WallTypeSet Members


WallTypeSet Members

[image] [image]

Revit 2013 API
WallTypeSet Members
WallTypeSet Class Constructors Methods Properties See Also Send Feedback

The WallTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WallTypeSet | Initializes a new instance of the WallTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every wall type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wall type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wall type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wall type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class


WallTypeSet Constructor

[image]

Revit 2013 API
WallTypeSet Constructor
WallTypeSet Class See Also Send Feedback
Initializes a new instance of the WallTypeSet class

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
WallTypeSet()

See Also

WallTypeSet Class


WallTypeSet Methods

[image] [image]

Revit 2013 API
WallTypeSet Methods
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every wall type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wall type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wall type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wall type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSet Class


Clear Method

[image]

Revit 2013 API
WallTypeSet..::..Clear Method
WallTypeSet Class See Also Send Feedback
Removes every wall type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WallTypeSet Class


Contains Method

[image]

Revit 2013 API
WallTypeSet..::..Contains Method
WallTypeSet Class See Also Send Feedback
Tests for the existence of a wall type within the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    WallType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..WallType
The wall type to be searched for.

Return Value

The Contains method returns True if the wall type is within the set, otherwise False.

See Also

WallTypeSet Class


Erase Method

[image]

Revit 2013 API
WallTypeSet..::..Erase Method
WallTypeSet Class See Also Send Feedback
Removes a specified wall type from the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    WallType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As WallType _
) As Integer
Visual C++
public:
virtual int Erase(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..WallType
The wall type to be erased.

Return Value

The number of wall types that were erased from the set.

See Also

WallTypeSet Class


ForwardIterator Method

[image]

Revit 2013 API
WallTypeSet..::..ForwardIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WallTypeSet Class


GetEnumerator Method

[image]

Revit 2013 API
WallTypeSet..::..GetEnumerator Method
WallTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WallTypeSet Class


Insert Method

[image]

Revit 2013 API
WallTypeSet..::..Insert Method
WallTypeSet Class See Also Send Feedback
Insert the specified wall type into the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    WallType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As WallType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WallType^ item
)

Parameters

item
Type: Autodesk.Revit.DB..::..WallType
The wall type to be inserted into the set.

Return Value

Returns whether the wall type was inserted into the set.

See Also

WallTypeSet Class


ReverseIterator Method

[image]

Revit 2013 API
WallTypeSet..::..ReverseIterator Method
WallTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WallTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WallTypeSetIterator
Visual C++
public:
virtual WallTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WallTypeSet Class


WallTypeSet Properties

[image] [image]

Revit 2013 API
WallTypeSet Properties
WallTypeSet Class See Also Send Feedback

The WallTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wall types that are in the set.

See Also

WallTypeSet Class


IsEmpty Property

[image]

Revit 2013 API
WallTypeSet..::..IsEmpty Property
WallTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WallTypeSet Class


Size Property

[image]

Revit 2013 API
WallTypeSet..::..Size Property
WallTypeSet Class See Also Send Feedback
Returns the number of wall types that are in the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WallTypeSet Class


WallTypeSetIterator Class

[image]

Revit 2013 API
WallTypeSetIterator Class
Members See Also Send Feedback
An iterator to a wall type set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WallTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WallTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WallTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..WallTypeSetIterator

See Also

WallTypeSetIterator Members


WallTypeSetIterator Members

[image] [image]

Revit 2013 API
WallTypeSetIterator Members
WallTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WallTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class


WallTypeSetIterator Constructor

[image]

Revit 2013 API
WallTypeSetIterator Constructor
WallTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WallTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WallTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WallTypeSetIterator Class


WallTypeSetIterator Methods

[image] [image]

Revit 2013 API
WallTypeSetIterator Methods
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallTypeSetIterator Class


MoveNext Method

[image]

Revit 2013 API
WallTypeSetIterator..::..MoveNext Method
WallTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class


Reset Method

[image]

Revit 2013 API
WallTypeSetIterator..::..Reset Method
WallTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WallTypeSetIterator Class


WallTypeSetIterator Properties

[image] [image]

Revit 2013 API
WallTypeSetIterator Properties
WallTypeSetIterator Class See Also Send Feedback

The WallTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WallTypeSetIterator Class


Current Property

[image]

Revit 2013 API
WallTypeSetIterator..::..Current Property
WallTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WallTypeSetIterator Class


WallUtils Class

[image]

Revit 2013 API
WallUtils Class
Members See Also Send Feedback
General Wall utility methods

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WallUtils : IDisposable
Visual Basic
Public Class WallUtils _
    Implements IDisposable
Visual C++
public ref class WallUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WallUtils

See Also

WallUtils Members


WallUtils Members

[image] [image]

Revit 2013 API
WallUtils Members
WallUtils Class Methods See Also Send Feedback

The WallUtils type exposes the following members.

Methods

 | Name | Description
 | AllowWallJoinAtEnd | Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
 | DisallowWallJoinAtEnd | Sets the wall's end not to join to other walls.
Public method | Dispose | Releases all resources used by the WallUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsWallJoinAllowedAtEnd | Identifies if the indicated end of the wall allows joins or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallUtils Class


WallUtils Methods

[image] [image]

Revit 2013 API
WallUtils Methods
WallUtils Class See Also Send Feedback

The WallUtils type exposes the following members.

Methods

 | Name | Description
 | AllowWallJoinAtEnd | Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
 | DisallowWallJoinAtEnd | Sets the wall's end not to join to other walls.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsWallJoinAllowedAtEnd | Identifies if the indicated end of the wall allows joins or not.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WallUtils Class


AllowWallJoinAtEnd Method

[image]

Revit 2013 API
WallUtils..::..AllowWallJoinAtEnd Method
WallUtils Class See Also Send Feedback
Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void AllowWallJoinAtEnd(
    Wall wall,
    int end
)
Visual Basic
Public Shared Sub AllowWallJoinAtEnd ( _
    wall As Wall, _
    end As Integer _
)
Visual C++
public:
static void AllowWallJoinAtEnd(
    Wall^ wall,
    int end
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall in question
end
Type: System..::..Int32
0 or 1 for the beginning or end of the wall's curve

Remarks

By default all walls are allowed to join at ends, so this function is only needed if this wall end is already disallowed to join. If this wall is a stacked wall, all subwalls at this end will be allowed to join.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallUtils Class


DisallowWallJoinAtEnd Method

[image]

Revit 2013 API
WallUtils..::..DisallowWallJoinAtEnd Method
WallUtils Class See Also Send Feedback
Sets the wall's end not to join to other walls.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void DisallowWallJoinAtEnd(
    Wall wall,
    int end
)
Visual Basic
Public Shared Sub DisallowWallJoinAtEnd ( _
    wall As Wall, _
    end As Integer _
)
Visual C++
public:
static void DisallowWallJoinAtEnd(
    Wall^ wall,
    int end
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall in question
end
Type: System..::..Int32
0 or 1 for the beginning or end of the wall's curve

Remarks

If this wall is already joined at this end, it will become disconnected. If this wall is a stacked wall, all subwalls at this end will be disallowed to join.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallUtils Class


Dispose Method

[image]

Revit 2013 API
WallUtils..::..Dispose Method
WallUtils Class See Also Send Feedback
Releases all resources used by the WallUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WallUtils Class


IsWallJoinAllowedAtEnd Method

[image]

Revit 2013 API
WallUtils..::..IsWallJoinAllowedAtEnd Method
WallUtils Class See Also Send Feedback
Identifies if the indicated end of the wall allows joins or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsWallJoinAllowedAtEnd(
    Wall wall,
    int end
)
Visual Basic
Public Shared Function IsWallJoinAllowedAtEnd ( _
    wall As Wall, _
    end As Integer _
) As Boolean
Visual C++
public:
static bool IsWallJoinAllowedAtEnd(
    Wall^ wall,
    int end
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall in question
end
Type: System..::..Int32
0 or 1 for the beginning or end of the wall's curve

Return Value

true if it is allowed to join. false if it is disallowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WallUtils Class


Workset Class

[image]

Revit 2013 API
Workset Class
Members Example See Also Send Feedback
Represents a workset in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Workset : IDisposable
Visual Basic
Public Class Workset _
    Implements IDisposable
Visual C++
public ref class Workset : IDisposable

Remarks

Worksets are a way to divide a set of elements in the Revit document into subsets for worksharing. There may be one or many worksets in a document. Each element in the document must belong to one and only one workset.

Examples

CopyC#
public Workset GetActiveWorkset(Document doc)
{
    // Get the workset table from the document
    WorksetTable worksetTable = doc.GetWorksetTable();
    // Get the Id of the active workset
    WorksetId activeId = worksetTable.GetActiveWorksetId();
    // Find the workset with that Id
    Workset workset = worksetTable.GetWorkset(activeId);
    return workset;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Workset

See Also

Workset Members


Workset Members

[image] [image]

Revit 2013 API
Workset Members
Workset Class Methods Properties See Also Send Feedback

The Workset type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Workset
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | Id of the workset.
Public property | IsDefaultWorkset | Whether the workset is the default one.
Public property | IsEditable | Whether the workset is editable.
Public property | IsOpen | Whether the workset is open (rather than closed).
Public property | IsVisibleByDefault | Whether the workset is visible by default.
Public property | Kind | Kind of the workset.
Public property | Name | Name of the workset.
Public property | Owner | User name of the workset.
Public property | UniqueId | UniqueId of the workset.

See Also

Workset Class


Workset Methods

[image] [image]

Revit 2013 API
Workset Methods
Workset Class See Also Send Feedback

The Workset type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Workset Class


Dispose Method

[image]

Revit 2013 API
Workset..::..Dispose Method
Workset Class See Also Send Feedback
Releases all resources used by the Workset

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Workset Class


Workset Properties

[image] [image]

Revit 2013 API
Workset Properties
Workset Class See Also Send Feedback

The Workset type exposes the following members.

Properties

 | Name | Description
Public property | Id | Id of the workset.
Public property | IsDefaultWorkset | Whether the workset is the default one.
Public property | IsEditable | Whether the workset is editable.
Public property | IsOpen | Whether the workset is open (rather than closed).
Public property | IsVisibleByDefault | Whether the workset is visible by default.
Public property | Kind | Kind of the workset.
Public property | Name | Name of the workset.
Public property | Owner | User name of the workset.
Public property | UniqueId | UniqueId of the workset.

See Also

Workset Class


Id Property

[image]

Revit 2013 API
Workset..::..Id Property
Workset Class See Also Send Feedback
Id of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId Id { get; }
Visual Basic
Public ReadOnly Property Id As WorksetId
    Get
Visual C++
public:
property WorksetId^ Id {
    WorksetId^ get ();
}

Remarks

Id of the workset may be changed while synchronizing with central. Please use UniqueId to reliably identify worksets despite changes which occur due to synchronization with central.

See Also

Workset Class


IsDefaultWorkset Property

[image]

Revit 2013 API
Workset..::..IsDefaultWorkset Property
Workset Class See Also Send Feedback
Whether the workset is the default one.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsDefaultWorkset { get; }
Visual Basic
Public ReadOnly Property IsDefaultWorkset As Boolean
    Get
Visual C++
public:
property bool IsDefaultWorkset {
    bool get ();
}

See Also

Workset Class


IsEditable Property

[image]

Revit 2013 API
Workset..::..IsEditable Property
Workset Class See Also Send Feedback
Whether the workset is editable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEditable { get; }
Visual Basic
Public ReadOnly Property IsEditable As Boolean
    Get
Visual C++
public:
property bool IsEditable {
    bool get ();
}

Remarks

The workset is editable if owned by current user.

See Also

Workset Class


IsOpen Property

[image]

Revit 2013 API
Workset..::..IsOpen Property
Workset Class See Also Send Feedback
Whether the workset is open (rather than closed).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsOpen { get; }
Visual Basic
Public ReadOnly Property IsOpen As Boolean
    Get
Visual C++
public:
property bool IsOpen {
    bool get ();
}

Remarks

The intent of closing a workset is to ask Revit to not display or expand any element in the workset, to reduce memory usage. Note that open/closed status is independent of editability.

See Also

Workset Class


IsVisibleByDefault Property

[image]

Revit 2013 API
Workset..::..IsVisibleByDefault Property
Workset Class See Also Send Feedback
Whether the workset is visible by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsVisibleByDefault { get; }
Visual Basic
Public ReadOnly Property IsVisibleByDefault As Boolean
    Get
Visual C++
public:
property bool IsVisibleByDefault {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.

See Also

Workset Class


Kind Property

[image]

Revit 2013 API
Workset..::..Kind Property
Workset Class See Also Send Feedback
Kind of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetKind Kind { get; }
Visual Basic
Public ReadOnly Property Kind As WorksetKind
    Get
Visual C++
public:
property WorksetKind Kind {
    WorksetKind get ();
}

See Also

Workset Class


Name Property

[image]

Revit 2013 API
Workset..::..Name Property
Workset Class See Also Send Feedback
Name of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Name is case-insensitive.

See Also

Workset Class


Owner Property

[image]

Revit 2013 API
Workset..::..Owner Property
Workset Class See Also Send Feedback
User name of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Owner { get; }
Visual Basic
Public ReadOnly Property Owner As String
    Get
Visual C++
public:
property String^ Owner {
    String^ get ();
}

See Also

Workset Class


UniqueId Property

[image]

Revit 2013 API
Workset..::..UniqueId Property
Workset Class See Also Send Feedback
UniqueId of the workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid UniqueId { get; }
Visual Basic
Public ReadOnly Property UniqueId As Guid
    Get
Visual C++
public:
property Guid UniqueId {
    Guid get ();
}

Remarks

Stable identifier for a workset, UniqueId will not change while synchronizing with central.

See Also

Workset Class


WorksetDefaultVisibilitySettings Class

[image]

Revit 2013 API
WorksetDefaultVisibilitySettings Class
Members See Also Send Feedback
An object that manages default visibility of worksets in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksetDefaultVisibilitySettings : IDisposable
Visual Basic
Public Class WorksetDefaultVisibilitySettings _
    Implements IDisposable
Visual C++
public ref class WorksetDefaultVisibilitySettings : IDisposable

Remarks

WorksetDefaultVisibilitySettings does not exist for family documents. In case worksharing is disabled in a document, all elements are moved into a single workset; that workset, and any worksets (re)created if worksharing is re-enabled, is visible by default regardless of any current settings.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetDefaultVisibilitySettings

See Also

WorksetDefaultVisibilitySettings Members


WorksetDefaultVisibilitySettings Members

[image] [image]

Revit 2013 API
WorksetDefaultVisibilitySettings Members
WorksetDefaultVisibilitySettings Class Methods See Also Send Feedback

The WorksetDefaultVisibilitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetDefaultVisibilitySettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorksetDefaultVisibilitySettings | Get the WorksetDefaultVisibilitySettings of the document.
Public method | IsWorksetVisible | Indicates whether the workset is visible by default.
Public method | SetWorksetVisibility | Set the default visibility of a workset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetDefaultVisibilitySettings Class


WorksetDefaultVisibilitySettings Methods

[image] [image]

Revit 2013 API
WorksetDefaultVisibilitySettings Methods
WorksetDefaultVisibilitySettings Class See Also Send Feedback

The WorksetDefaultVisibilitySettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorksetDefaultVisibilitySettings | Get the WorksetDefaultVisibilitySettings of the document.
Public method | IsWorksetVisible | Indicates whether the workset is visible by default.
Public method | SetWorksetVisibility | Set the default visibility of a workset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetDefaultVisibilitySettings Class


Dispose Method

[image]

Revit 2013 API
WorksetDefaultVisibilitySettings..::..Dispose Method
WorksetDefaultVisibilitySettings Class See Also Send Feedback
Releases all resources used by the WorksetDefaultVisibilitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksetDefaultVisibilitySettings Class


GetWorksetDefaultVisibilitySettings Method

[image]

Revit 2013 API
WorksetDefaultVisibilitySettings..::..GetWorksetDefaultVisibilitySettings Method
WorksetDefaultVisibilitySettings Class See Also Send Feedback
Get the WorksetDefaultVisibilitySettings of the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static WorksetDefaultVisibilitySettings GetWorksetDefaultVisibilitySettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetWorksetDefaultVisibilitySettings ( _
    aDoc As Document _
) As WorksetDefaultVisibilitySettings
Visual C++
public:
static WorksetDefaultVisibilitySettings^ GetWorksetDefaultVisibilitySettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The WorksetDefaultVisibilitySettings of the document.

Remarks

WorksetDefaultVisibilitySettings is not available in family documents.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | WorksetDefaultVisibilitySettings is not applicable to family documents.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksetDefaultVisibilitySettings Class


IsWorksetVisible Method

[image]

Revit 2013 API
WorksetDefaultVisibilitySettings..::..IsWorksetVisible Method
WorksetDefaultVisibilitySettings Class See Also Send Feedback
Indicates whether the workset is visible by default.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsWorksetVisible(
    WorksetId worksetId
)
Visual Basic
Public Function IsWorksetVisible ( _
    worksetId As WorksetId _
) As Boolean
Visual C++
public:
bool IsWorksetVisible(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.

Return Value

Whether the workset is visible by default.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.

See Also

WorksetDefaultVisibilitySettings Class


SetWorksetVisibility Method

[image]

Revit 2013 API
WorksetDefaultVisibilitySettings..::..SetWorksetVisibility Method
WorksetDefaultVisibilitySettings Class Example See Also Send Feedback
Set the default visibility of a workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetWorksetVisibility(
    WorksetId worksetId,
    bool visible
)
Visual Basic
Public Sub SetWorksetVisibility ( _
    worksetId As WorksetId, _
    visible As Boolean _
)
Visual C++
public:
void SetWorksetVisibility(
    WorksetId^ worksetId,
    bool visible
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
Id of the workset.
visible
Type: System..::..Boolean
Whether the workset should be visible by default or not.

Examples

CopyC#
public void HideWorkset(Document doc, View view, WorksetId worksetId)
{
    // get the current visibility
    WorksetVisibility visibility = view.GetWorksetVisibility(worksetId);

    // and set it to 'Hidden' if it is not hidden yet
    if (visibility != WorksetVisibility.Hidden)
    {
        view.SetWorksetVisibility(worksetId, WorksetVisibility.Hidden);
    }

    // Get the workset’s default visibility
    WorksetDefaultVisibilitySettings defaultVisibility = WorksetDefaultVisibilitySettings.GetWorksetDefaultVisibilitySettings(doc);

    // and making sure it is set to 'false'
    if (true == defaultVisibility.IsWorksetVisible(worksetId))
    {
        defaultVisibility.SetWorksetVisibility(worksetId, false);
    }
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no workset with this Id in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | WorksetDefaultVisibilitySettings is not applicable to family documents.

See Also

WorksetDefaultVisibilitySettings Class


WorksetFilter Class

[image]

Revit 2013 API
WorksetFilter Class
Members See Also Send Feedback
A base class for a type of filter that accepts or rejects worksets based upon criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksetFilter : IDisposable
Visual Basic
Public Class WorksetFilter _
    Implements IDisposable
Visual C++
public ref class WorksetFilter : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetFilter
Autodesk.Revit.DB..::..WorksetKindFilter

See Also

WorksetFilter Members


WorksetFilter Members

[image] [image]

Revit 2013 API
WorksetFilter Members
WorksetFilter Class Methods Properties See Also Send Feedback

The WorksetFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.

See Also

WorksetFilter Class


WorksetFilter Methods

[image] [image]

Revit 2013 API
WorksetFilter Methods
WorksetFilter Class See Also Send Feedback

The WorksetFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetFilter Class


Dispose Method

[image]

Revit 2013 API
WorksetFilter..::..Dispose Method
WorksetFilter Class See Also Send Feedback
Releases all resources used by the WorksetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksetFilter Class


WorksetFilter Properties

[image] [image]

Revit 2013 API
WorksetFilter Properties
WorksetFilter Class See Also Send Feedback

The WorksetFilter type exposes the following members.

Properties

 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.

See Also

WorksetFilter Class


IncludeStandaloneWorksetsOnly Property

[image]

Revit 2013 API
WorksetFilter..::..IncludeStandaloneWorksetsOnly Property
WorksetFilter Class See Also Send Feedback
True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IncludeStandaloneWorksetsOnly { get; set; }
Visual Basic
Public Property IncludeStandaloneWorksetsOnly As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeStandaloneWorksetsOnly {
    bool get ();
    void set (bool value);
}

See Also

WorksetFilter Class


Inverted Property

[image]

Revit 2013 API
WorksetFilter..::..Inverted Property
WorksetFilter Class See Also Send Feedback
True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Inverted { get; }
Visual Basic
Public ReadOnly Property Inverted As Boolean
    Get
Visual C++
public:
property bool Inverted {
    bool get ();
}

See Also

WorksetFilter Class


WorksetId Class

[image]

Revit 2013 API
WorksetId Class
Members See Also Send Feedback
WorksetId identifies a workset within a single document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WorksetId
Visual Basic
Public Class WorksetId
Visual C++
public ref class WorksetId

Remarks

WorksetId is not guaranteed to be unique. It is only valid within one model and its value may change when the model is synchronized with central. If unique identification of a workset is needed, the workset's GUID should be used instead.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetId

See Also

WorksetId Members


WorksetId Members

[image] [image]

Revit 2013 API
WorksetId Members
WorksetId Class Constructors Methods Operators Properties See Also Send Feedback

The WorksetId type exposes the following members.

Constructors

 | Name | Description
Public method | WorksetId | Create an WorksetId handle with the given integer id.

Methods

 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

Operators

Name | Description
Equality | Determines whether these two WorksetIds are the same.
GreaterThan | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual | Determines whether one WorksetId is not less than another WorksetId.
Inequality | Determines whether these two WorksetIds are different.
LessThan | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual | Determines whether one WorksetId is not greater than another WorksetId.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.

See Also

WorksetId Class


WorksetId Constructor

[image]

Revit 2013 API
WorksetId Constructor
WorksetId Class See Also Send Feedback
Create an WorksetId handle with the given integer id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WorksetId(
    int id
)
Visual Basic
Public Sub New ( _
    id As Integer _
)
Visual C++
public:
WorksetId(
    int id
)

Parameters

id
Type: System..::..Int32
The id.

See Also

WorksetId Class


WorksetId Methods

[image] [image]

Revit 2013 API
WorksetId Methods
WorksetId Class See Also Send Feedback

The WorksetId type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two WorksetIds.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Gets a String representation of the integer value of the id. (Overrides Object..::..ToString()()()().)

See Also

WorksetId Class


Compare Method

[image]

Revit 2013 API
WorksetId..::..Compare Method
WorksetId Class See Also Send Feedback
Compares two WorksetIds.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Compare(
    WorksetId id
)
Visual Basic
Public Function Compare ( _
    id As WorksetId _
) As Integer
Visual C++
public:
int Compare(
    WorksetId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..WorksetId
The WorksetId to be compared with this WorksetId.

Return Value

-1 if this WorksetId is less than id, 0 if equal, 1 if greater.

See Also

WorksetId Class


Equals Method

[image]

Revit 2013 API
WorksetId..::..Equals Method
WorksetId Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

WorksetId Class


GetHashCode Method

[image]

Revit 2013 API
WorksetId..::..GetHashCode Method
WorksetId Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

WorksetId Class


ToString Method

[image]

Revit 2013 API
WorksetId..::..ToString Method
WorksetId Class See Also Send Feedback
Gets a String representation of the integer value of the id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

WorksetId Class


WorksetId Operators

[image] [image]

Revit 2013 API
WorksetId Operators
WorksetId Class See Also Send Feedback

The WorksetId type exposes the following members.

Operators

Name | Description
Equality | Determines whether these two WorksetIds are the same.
GreaterThan | Determines whether one WorksetId is greater than another WorksetId.
GreaterThanOrEqual | Determines whether one WorksetId is not less than another WorksetId.
Inequality | Determines whether these two WorksetIds are different.
LessThan | Determines whether this WorksetId is less than another WorksetId.
LessThanOrEqual | Determines whether one WorksetId is not greater than another WorksetId.

See Also

WorksetId Class


Equality Operator

[image]

Revit 2013 API
WorksetId..::..Equality Operator
WorksetId Class See Also Send Feedback
Determines whether these two WorksetIds are the same.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    WorksetId first,
    WorksetId second
)
Visual Basic
Public Shared Operator = ( _
    first As WorksetId, _
    second As WorksetId _
) As Boolean
Visual C++
public:
static bool operator ==(
    WorksetId^ first,
    WorksetId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
second
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the WorksetIds are the same; otherwise, false.

See Also

WorksetId Class


GreaterThan Operator

[image]

Revit 2013 API
WorksetId..::..GreaterThan Operator
WorksetId Class See Also Send Feedback
Determines whether one WorksetId is greater than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator >(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Visual Basic
Public Shared Operator > ( _
    WorksetId1 As WorksetId, _
    WorksetId2 As WorksetId _
) As Boolean
Visual C++
public:
static bool operator >(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)

Parameters

WorksetId1
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
WorksetId2
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the first WorksetId is greater than the second WorksetId, otherwise, false.

See Also

WorksetId Class


GreaterThanOrEqual Operator

[image]

Revit 2013 API
WorksetId..::..GreaterThanOrEqual Operator
WorksetId Class See Also Send Feedback
Determines whether one WorksetId is not less than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator >=(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Visual Basic
Public Shared Operator >= ( _
    WorksetId1 As WorksetId, _
    WorksetId2 As WorksetId _
) As Boolean
Visual C++
public:
static bool operator >=(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)

Parameters

WorksetId1
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
WorksetId2
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the first WorksetId is not less than the second WorksetId, otherwise, false.

See Also

WorksetId Class


Inequality Operator

[image]

Revit 2013 API
WorksetId..::..Inequality Operator
WorksetId Class See Also Send Feedback
Determines whether these two WorksetIds are different.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    WorksetId first,
    WorksetId second
)
Visual Basic
Public Shared Operator <> ( _
    first As WorksetId, _
    second As WorksetId _
) As Boolean
Visual C++
public:
static bool operator !=(
    WorksetId^ first,
    WorksetId^ second
)

Parameters

first
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
second
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the WorksetIds are different; otherwise, false.

See Also

WorksetId Class


LessThan Operator

[image]

Revit 2013 API
WorksetId..::..LessThan Operator
WorksetId Class See Also Send Feedback
Determines whether this WorksetId is less than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator <(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Visual Basic
Public Shared Operator < ( _
    WorksetId1 As WorksetId, _
    WorksetId2 As WorksetId _
) As Boolean
Visual C++
public:
static bool operator <(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)

Parameters

WorksetId1
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
WorksetId2
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the first WorksetId is less than the second WorksetId, otherwise, false.

See Also

WorksetId Class


LessThanOrEqual Operator

[image]

Revit 2013 API
WorksetId..::..LessThanOrEqual Operator
WorksetId Class See Also Send Feedback
Determines whether one WorksetId is not greater than another WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator <=(
    WorksetId WorksetId1,
    WorksetId WorksetId2
)
Visual Basic
Public Shared Operator <= ( _
    WorksetId1 As WorksetId, _
    WorksetId2 As WorksetId _
) As Boolean
Visual C++
public:
static bool operator <=(
    WorksetId^ WorksetId1,
    WorksetId^ WorksetId2
)

Parameters

WorksetId1
Type: Autodesk.Revit.DB..::..WorksetId
The first WorksetId.
WorksetId2
Type: Autodesk.Revit.DB..::..WorksetId
The second WorksetId.

Return Value

True if the first WorksetId is not greater than the second WorksetId, otherwise, false.

See Also

WorksetId Class


WorksetId Properties

[image] [image]

Revit 2013 API
WorksetId Properties
WorksetId Class See Also Send Feedback

The WorksetId type exposes the following members.

Properties

 | Name | Description
Public property | IntegerValue | Provides the value of the WorksetId as an integer.
 | InvalidWorksetId | Get the invalid WorksetId whose IntegerValue is -1.

See Also

WorksetId Class


IntegerValue Property

[image]

Revit 2013 API
WorksetId..::..IntegerValue Property
WorksetId Class See Also Send Feedback
Provides the value of the WorksetId as an integer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int IntegerValue { get; }
Visual Basic
Public ReadOnly Property IntegerValue As Integer
    Get
Visual C++
public:
property int IntegerValue {
    int get ();
}

See Also

WorksetId Class


InvalidWorksetId Property

[image]

Revit 2013 API
WorksetId..::..InvalidWorksetId Property
WorksetId Class See Also Send Feedback
Get the invalid WorksetId whose IntegerValue is -1.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static WorksetId InvalidWorksetId { get; }
Visual Basic
Public Shared ReadOnly Property InvalidWorksetId As WorksetId
    Get
Visual C++
public:
static property WorksetId^ InvalidWorksetId {
    WorksetId^ get ();
}

See Also

WorksetId Class


WorksetKind Enumeration

[image]

Revit 2013 API
WorksetKind Enumeration
See Also Send Feedback
Indicates one of the standard kinds of workset (as available in the UI).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WorksetKind
Visual Basic
Public Enumeration WorksetKind
Visual C++
public enum class WorksetKind

Members

Member name | Description
OtherWorkset | Any workset which is not one of the standard types included in this enum.
FamilyWorkset | Workset containing a family.
ViewWorkset | Workset containing a view.
StandardWorkset | Workset containing a standard.
UserWorkset | Workset defined by users, including the two default worksets created by Revit

See Also


WorksetKindFilter Class

[image]

Revit 2013 API
WorksetKindFilter Class
Members See Also Send Feedback
A filter used to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksetKindFilter : WorksetFilter
Visual Basic
Public Class WorksetKindFilter _
    Inherits WorksetFilter
Visual C++
public ref class WorksetKindFilter : public WorksetFilter

Remarks

This filter is a quick filter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetFilter
Autodesk.Revit.DB..::..WorksetKindFilter

See Also

WorksetKindFilter Members


WorksetKindFilter Members

[image] [image]

Revit 2013 API
WorksetKindFilter Members
WorksetKindFilter Class Constructors Methods Properties See Also Send Feedback

The WorksetKindFilter type exposes the following members.

Constructors

 | Name | Description
Public method | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public method | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Methods

 | Name | Description
Public method | Dispose | (Inherited from WorksetFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter.)
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter.)
Public property | WorksetKind | The WorksetKind.

See Also

WorksetKindFilter Class


WorksetKindFilter Constructor

[image] [image]

Revit 2013 API
WorksetKindFilter Constructor
WorksetKindFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.
Public method | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

See Also

WorksetKindFilter Class
WorksetKindFilter Members


WorksetKindFilter Constructor (WorksetKind)

[image]

Revit 2013 API
WorksetKindFilter Constructor (WorksetKind)
WorksetKindFilter Class See Also Send Feedback
Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetKindFilter(
    WorksetKind worksetKind
)
Visual Basic
Public Sub New ( _
    worksetKind As WorksetKind _
)
Visual C++
public:
WorksetKindFilter(
    WorksetKind worksetKind
)

Parameters

worksetKind
Type: Autodesk.Revit.DB..::..WorksetKind
The WorksetKind to match.

See Also

WorksetKindFilter Class
WorksetKindFilter Overload


WorksetKindFilter Constructor (WorksetKind, Boolean)

[image]

Revit 2013 API
WorksetKindFilter Constructor (WorksetKind, Boolean)
WorksetKindFilter Class See Also Send Feedback
Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetKindFilter(
    WorksetKind worksetKind,
    bool inverted
)
Visual Basic
Public Sub New ( _
    worksetKind As WorksetKind, _
    inverted As Boolean _
)
Visual C++
public:
WorksetKindFilter(
    WorksetKind worksetKind,
    bool inverted
)

Parameters

worksetKind
Type: Autodesk.Revit.DB..::..WorksetKind
The WorksetKind to match.
inverted
Type: System..::..Boolean
True if the filter should match all worksets which are not of the given WorksetKind.

See Also

WorksetKindFilter Class
WorksetKindFilter Overload


WorksetKindFilter Methods

[image] [image]

Revit 2013 API
WorksetKindFilter Methods
WorksetKindFilter Class See Also Send Feedback

The WorksetKindFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from WorksetFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetKindFilter Class


WorksetKindFilter Properties

[image] [image]

Revit 2013 API
WorksetKindFilter Properties
WorksetKindFilter Class See Also Send Feedback

The WorksetKindFilter type exposes the following members.

Properties

 | Name | Description
Public property | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter.)
Public property | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter.)
Public property | WorksetKind | The WorksetKind.

See Also

WorksetKindFilter Class


WorksetKind Property

[image]

Revit 2013 API
WorksetKindFilter..::..WorksetKind Property
WorksetKindFilter Class See Also Send Feedback
The WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetKind WorksetKind { get; }
Visual Basic
Public ReadOnly Property WorksetKind As WorksetKind
    Get
Visual C++
public:
property WorksetKind WorksetKind {
    WorksetKind get ();
}

See Also

WorksetKindFilter Class


WorksetTable Class

[image]

Revit 2013 API
WorksetTable Class
Members See Also Send Feedback
A table containing references to all the worksets contained in a document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksetTable : IDisposable
Visual Basic
Public Class WorksetTable _
    Implements IDisposable
Visual C++
public ref class WorksetTable : IDisposable

Remarks

There is one WorksetTable for each document. There will be at least one default workset in the table, even if worksharing has not been enabled in the document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksetTable

See Also

WorksetTable Members


WorksetTable Members

[image] [image]

Revit 2013 API
WorksetTable Members
WorksetTable Class Methods See Also Send Feedback

The WorksetTable type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksetTable
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveWorksetId | Returns the active workset's WorksetId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetTable Class


WorksetTable Methods

[image] [image]

Revit 2013 API
WorksetTable Methods
WorksetTable Class See Also Send Feedback

The WorksetTable type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveWorksetId | Returns the active workset's WorksetId.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksetTable Class


Dispose Method

[image]

Revit 2013 API
WorksetTable..::..Dispose Method
WorksetTable Class See Also Send Feedback
Releases all resources used by the WorksetTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksetTable Class


GetActiveWorksetId Method

[image]

Revit 2013 API
WorksetTable..::..GetActiveWorksetId Method
WorksetTable Class Example See Also Send Feedback
Returns the active workset's WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksetId GetActiveWorksetId()
Visual Basic
Public Function GetActiveWorksetId As WorksetId
Visual C++
public:
WorksetId^ GetActiveWorksetId()

Return Value

WorksetId of the active workset.

Examples

CopyC#
public Workset GetActiveWorkset(Document doc)
{
    // Get the workset table from the document
    WorksetTable worksetTable = doc.GetWorksetTable();
    // Get the Id of the active workset
    WorksetId activeId = worksetTable.GetActiveWorksetId();
    // Find the workset with that Id
    Workset workset = worksetTable.GetWorkset(activeId);
    return workset;
}

See Also

WorksetTable Class


GetWorkset Method

[image] [image]

Revit 2013 API
WorksetTable..::..GetWorkset Method
WorksetTable Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWorkset(Guid) | Returns the workset from a input Guid.
Public method | GetWorkset(WorksetId) | Returns the workset from a input WorksetId.

See Also

WorksetTable Class
WorksetTable Members


GetWorkset Method (Guid)

[image]

Revit 2013 API
WorksetTable..::..GetWorkset Method (Guid)
WorksetTable Class See Also Send Feedback
Returns the workset from a input Guid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Workset GetWorkset(
    Guid guid
)
Visual Basic
Public Function GetWorkset ( _
    guid As Guid _
) As Workset
Visual C++
public:
Workset^ GetWorkset(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
Guid of the workset.

Return Value

The returned workset. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no workset in this table with this Id.

See Also

WorksetTable Class
GetWorkset Overload


GetWorkset Method (WorksetId)

[image]

Revit 2013 API
WorksetTable..::..GetWorkset Method (WorksetId)
WorksetTable Class See Also Send Feedback
Returns the workset from a input WorksetId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Workset GetWorkset(
    WorksetId id
)
Visual Basic
Public Function GetWorkset ( _
    id As WorksetId _
) As Workset
Visual C++
public:
Workset^ GetWorkset(
    WorksetId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..WorksetId
Id of a workset.

Return Value

The returned workset. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no workset in this table with this Id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksetTable Class
GetWorkset Overload


WorksetVisibility Enumeration

[image]

Revit 2013 API
WorksetVisibility Enumeration
See Also Send Feedback
Indicates the visibility settings of a workset in a particular view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WorksetVisibility
Visual Basic
Public Enumeration WorksetVisibility
Visual C++
public enum class WorksetVisibility

Members

Member name | Description
Visible | Be visible in a view (i.e. will be visible unless it is closed).
Hidden | Be hidden in a view.
UseGlobalSetting | Do not override the visibility.

See Also


WorksharingDisplayGraphicSettings Class

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings Class
Members Example See Also Send Feedback
Represents the graphical settings that can be assigned to elements in the worksharing display modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingDisplayGraphicSettings : IDisposable
Visual Basic
Public Class WorksharingDisplayGraphicSettings _
    Implements IDisposable
Visual C++
public ref class WorksharingDisplayGraphicSettings : IDisposable

Examples

CopyC#
public WorksharingDisplayGraphicSettings GetWorksharingDisplaySettings(Document doc, String userName, WorksetId worksetId, bool ownedbyCurrentUser)
{
    WorksharingDisplayGraphicSettings graphicSettings;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get graphic settings for a user, if specified
    if (!String.IsNullOrEmpty(userName))
        graphicSettings = displaySettings.GetGraphicOverrides(userName);

    // get graphicSettings for a workset, if specified
    else if (worksetId != WorksetId.InvalidWorksetId)
        graphicSettings = displaySettings.GetGraphicOverrides(worksetId);

    // get graphic settings for the OwnedByCurrentUser status
    else if (ownedbyCurrentUser)
        graphicSettings = displaySettings.GetGraphicOverrides(CheckoutStatus.OwnedByCurrentUser);

    // otherwise get graphic settings for the CurrentWithCentral status
    else
        graphicSettings = displaySettings.GetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral);

    return graphicSettings;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings

See Also

WorksharingDisplayGraphicSettings Members


WorksharingDisplayGraphicSettings Members

[image] [image]

Revit 2013 API
WorksharingDisplayGraphicSettings Members
WorksharingDisplayGraphicSettings Class Constructors Methods Properties See Also Send Feedback

The WorksharingDisplayGraphicSettings type exposes the following members.

Constructors

 | Name | Description
Public method | WorksharingDisplayGraphicSettings | Creates a new instance.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingDisplayGraphicSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FillColor | The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property | IsApplied | Indicates whether this set of graphic overrides will be applied.
Public property | LineColor | The line color that will be applied to elements when these settings are applied.

See Also

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings Constructor

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings Constructor
WorksharingDisplayGraphicSettings Class See Also Send Feedback
Creates a new instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings(
    bool shouldApply,
    Color lineColor
)
Visual Basic
Public Sub New ( _
    shouldApply As Boolean, _
    lineColor As Color _
)
Visual C++
public:
WorksharingDisplayGraphicSettings(
    bool shouldApply,
    Color^ lineColor
)

Parameters

shouldApply
Type: System..::..Boolean
True if the settings should be applied, False if they should be set but not applied.
lineColor
Type: Autodesk.Revit.DB..::..Color
The desired line color, which must be a valid color. Note that the fill color is calculated automatically from the line color so it is not advisable to use white, black, or shades of grey.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The lineColor argument does not represent a valid color.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings Methods

[image] [image]

Revit 2013 API
WorksharingDisplayGraphicSettings Methods
WorksharingDisplayGraphicSettings Class See Also Send Feedback

The WorksharingDisplayGraphicSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksharingDisplayGraphicSettings Class


Dispose Method

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings..::..Dispose Method
WorksharingDisplayGraphicSettings Class See Also Send Feedback
Releases all resources used by the WorksharingDisplayGraphicSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksharingDisplayGraphicSettings Class


WorksharingDisplayGraphicSettings Properties

[image] [image]

Revit 2013 API
WorksharingDisplayGraphicSettings Properties
WorksharingDisplayGraphicSettings Class See Also Send Feedback

The WorksharingDisplayGraphicSettings type exposes the following members.

Properties

 | Name | Description
Public property | FillColor | The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.
Public property | IsApplied | Indicates whether this set of graphic overrides will be applied.
Public property | LineColor | The line color that will be applied to elements when these settings are applied.

See Also

WorksharingDisplayGraphicSettings Class


FillColor Property

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings..::..FillColor Property
WorksharingDisplayGraphicSettings Class See Also Send Feedback
The fill color that will be applied to elements when these settings are applied. Note that this is automatically set by increasing the luma of the specified line color by 65%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Color FillColor { get; }
Visual Basic
Public ReadOnly Property FillColor As Color
    Get
Visual C++
public:
property Color^ FillColor {
    Color^ get ();
}

See Also

WorksharingDisplayGraphicSettings Class


IsApplied Property

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings..::..IsApplied Property
WorksharingDisplayGraphicSettings Class See Also Send Feedback
Indicates whether this set of graphic overrides will be applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsApplied { get; }
Visual Basic
Public ReadOnly Property IsApplied As Boolean
    Get
Visual C++
public:
property bool IsApplied {
    bool get ();
}

See Also

WorksharingDisplayGraphicSettings Class


LineColor Property

[image]

Revit 2013 API
WorksharingDisplayGraphicSettings..::..LineColor Property
WorksharingDisplayGraphicSettings Class See Also Send Feedback
The line color that will be applied to elements when these settings are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Color LineColor { get; }
Visual Basic
Public ReadOnly Property LineColor As Color
    Get
Visual C++
public:
property Color^ LineColor {
    Color^ get ();
}

See Also

WorksharingDisplayGraphicSettings Class


WorksharingDisplayMode Enumeration

[image]

Revit 2013 API
WorksharingDisplayMode Enumeration
Example See Also Send Feedback
Indicates which worksharing display mode a view is in.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum WorksharingDisplayMode
Visual Basic
Public Enumeration WorksharingDisplayMode
Visual C++
public enum class WorksharingDisplayMode

Members

Member name | Description
Off | No active worksharing display mode.
CheckoutStatus | The view is displaying the checkout status of elements.
Owners | The view is displaying the specific owners of elements.
ModelUpdates | The view is displaying model updates.
Worksets | The view is displaying which workset each element is assigned to.

Examples

CopyC#
public void GetWorksharingDisplayMode(View view)
{
    // Get and Set worksharingDisplayMode of a given view
    WorksharingDisplayMode displayMode = view.GetWorksharingDisplayMode();
    Autodesk.Revit.UI.TaskDialog.Show("GetWorksharingDisplayMode", "WorksharingDisplayMode : " + displayMode);

    view.SetWorksharingDisplayMode(WorksharingDisplayMode.CheckoutStatus);
    Autodesk.Revit.UI.TaskDialog.Show("SetWorksharingDisplayMode", "CheckoutStatus was set for View: " + view.Name);
}

See Also


WorksharingDisplaySettings Class

[image]

Revit 2013 API
WorksharingDisplaySettings Class
Members See Also Send Feedback
WorksharingDisplaySettings controls how elements will appear when they are displayed in any of the worksharing display modes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingDisplaySettings : Element
Visual Basic
Public Class WorksharingDisplaySettings _
    Inherits Element
Visual C++
public ref class WorksharingDisplaySettings : public Element

Remarks

The colors stored in these settings are a common setting and are shared by all users in the model. Whether a given color is applied or not is specific to the current user and will not be shared by other users.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..WorksharingDisplaySettings

See Also

WorksharingDisplaySettings Members


WorksharingDisplaySettings Members

[image] [image]

Revit 2013 API
WorksharingDisplaySettings Members
WorksharingDisplaySettings Class Methods Properties See Also Send Feedback

The WorksharingDisplaySettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WorksharingDisplaySettings Class


WorksharingDisplaySettings Methods

[image] [image]

Revit 2013 API
WorksharingDisplaySettings Methods
WorksharingDisplaySettings Class See Also Send Feedback

The WorksharingDisplaySettings type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanUserHaveOverrides | Checks whether a single username can have customized graphic overrides.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllUsersWithGraphicOverrides | Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
 | GetOrCreateWorksharingDisplaySettings | Returns the worksharing display settings for the document, creating new settings for the current user if necessary.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRemovedUsers | Returns the set of users who have been explicitly removed from the settings.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveUsers | Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.
Public method | RestoreUsers | Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UserHasGraphicOverrides | Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

See Also

WorksharingDisplaySettings Class


CanUserHaveOverrides Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..CanUserHaveOverrides Method
WorksharingDisplaySettings Class See Also Send Feedback
Checks whether a single username can have customized graphic overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool CanUserHaveOverrides(
    string username
)
Visual Basic
Public Function CanUserHaveOverrides ( _
    username As String _
) As Boolean
Visual C++
public:
bool CanUserHaveOverrides(
    String^ username
)

Parameters

username
Type: System..::..String
The username to check.

Return Value

False if the username is on the list of removed users, True otherwise.

Remarks

Only users that have not been removed can have overrides. Once it is removed, a username must be restored before its associated graphic overrides can be customized.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class


GetAllUsersWithGraphicOverrides Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetAllUsersWithGraphicOverrides Method
WorksharingDisplaySettings Class See Also Send Feedback
Returns all usernames that have graphic overrides. This list consists of all users included in the user table + all users who have explicitly been assigned overrides.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<string> GetAllUsersWithGraphicOverrides()
Visual Basic
Public Function GetAllUsersWithGraphicOverrides As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ GetAllUsersWithGraphicOverrides()

Return Value

All usernames that have been assigned graphic overrides.

See Also

WorksharingDisplaySettings Class


GetGraphicOverrides Method

[image] [image]

Revit 2013 API
WorksharingDisplaySettings..::..GetGraphicOverrides Method
WorksharingDisplaySettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetGraphicOverrides(String) | Returns the graphic overrides assigned for elements owned by a particular user.
Public method | GetGraphicOverrides(CheckoutStatus) | Returns the graphic overrides associated with a particular ownership status.
Public method | GetGraphicOverrides(ModelUpdatesStatus) | Returns the graphic overrides assigned to a particular model update status.
Public method | GetGraphicOverrides(WorksetId) | Returns the graphic overrides assigned to elements in a particular workset.

See Also

WorksharingDisplaySettings Class
WorksharingDisplaySettings Members


GetGraphicOverrides Method (String)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetGraphicOverrides Method (String)
WorksharingDisplaySettings Class See Also Send Feedback
Returns the graphic overrides assigned for elements owned by a particular user.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    string username
)
Visual Basic
Public Function GetGraphicOverrides ( _
    username As String _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    String^ username
)

Parameters

username
Type: System..::..String
The username of a particular user.

Return Value

The graphic overrides assigned to this user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This WorksharingDisplaySettings does not contain graphic overrides for the specified value of username.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


GetGraphicOverrides Method (CheckoutStatus)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetGraphicOverrides Method (CheckoutStatus)
WorksharingDisplaySettings Class See Also Send Feedback
Returns the graphic overrides associated with a particular ownership status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    CheckoutStatus ownershipStatus
)
Visual Basic
Public Function GetGraphicOverrides ( _
    ownershipStatus As CheckoutStatus _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    CheckoutStatus ownershipStatus
)

Parameters

ownershipStatus
Type: Autodesk.Revit.DB..::..CheckoutStatus
The ownership status of interest.

Return Value

Returns the graphic overrides assigned to a particular ownership status.

See Also

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


GetGraphicOverrides Method (ModelUpdatesStatus)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetGraphicOverrides Method (ModelUpdatesStatus)
WorksharingDisplaySettings Class See Also Send Feedback
Returns the graphic overrides assigned to a particular model update status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    ModelUpdatesStatus statusInCentral
)
Visual Basic
Public Function GetGraphicOverrides ( _
    statusInCentral As ModelUpdatesStatus _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    ModelUpdatesStatus statusInCentral
)

Parameters

statusInCentral
Type: Autodesk.Revit.DB..::..ModelUpdatesStatus
The model update status of interest.

Return Value

Returns the graphic overrides assigned to the model update status.

See Also

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


GetGraphicOverrides Method (WorksetId)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetGraphicOverrides Method (WorksetId)
WorksharingDisplaySettings Class See Also Send Feedback
Returns the graphic overrides assigned to elements in a particular workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public WorksharingDisplayGraphicSettings GetGraphicOverrides(
    WorksetId worksetId
)
Visual Basic
Public Function GetGraphicOverrides ( _
    worksetId As WorksetId _
) As WorksharingDisplayGraphicSettings
Visual C++
public:
WorksharingDisplayGraphicSettings^ GetGraphicOverrides(
    WorksetId^ worksetId
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset id of interest. This must be a user workset.

Return Value

Returns the graphic overrides assigned to the workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
GetGraphicOverrides Overload


GetOrCreateWorksharingDisplaySettings Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetOrCreateWorksharingDisplaySettings Method
WorksharingDisplaySettings Class See Also Send Feedback
Returns the worksharing display settings for the document, creating new settings for the current user if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static WorksharingDisplaySettings GetOrCreateWorksharingDisplaySettings(
    Document doc
)
Visual Basic
Public Shared Function GetOrCreateWorksharingDisplaySettings ( _
    doc As Document _
) As WorksharingDisplaySettings
Visual C++
public:
static WorksharingDisplaySettings^ GetOrCreateWorksharingDisplaySettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document of interest.

Return Value

The worksharing display settings for the document.

Remarks

Note that these settings are available even in models that are not workshared. This is to allow pre-configuring the display settings before enabling worksets so that they can be stored in template files.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class


GetRemovedUsers Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..GetRemovedUsers Method
WorksharingDisplaySettings Class See Also Send Feedback
Returns the set of users who have been explicitly removed from the settings.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<string> GetRemovedUsers()
Visual Basic
Public Function GetRemovedUsers As ICollection(Of String)
Visual C++
public:
ICollection<String^>^ GetRemovedUsers()

Return Value

Users who have been explicitly removed from the list.

See Also

WorksharingDisplaySettings Class


RemoveUsers Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..RemoveUsers Method
WorksharingDisplaySettings Class Example See Also Send Feedback
Removes users from the list of displayed users and permanently discards any customization of the graphics. Note that a user cannot be removed if he or she owns any elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RemoveUsers(
    Document document,
    ICollection<string> usersToRemove,
    out ICollection<string> usersActuallyRemoved
)
Visual Basic
Public Sub RemoveUsers ( _
    document As Document, _
    usersToRemove As ICollection(Of String), _
    <OutAttribute> ByRef usersActuallyRemoved As ICollection(Of String) _
)
Visual C++
public:
void RemoveUsers(
    Document^ document,
    ICollection<String^>^ usersToRemove,
    [OutAttribute] ICollection<String^>^% usersActuallyRemoved
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing this.
usersToRemove
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The usernames of the users to remove.
usersActuallyRemoved
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>%
The users that were successfully removed. Note that you cannot remove users who currently own any elements.

Remarks

Note that default graphic overrides will be applied to any elements owned by these users if they take ownership of any elements or worksets while they are removed. Note also that the list of removed users will be shared by all users of the central model and will remove all customizations by all users.

Examples

CopyC#
public void RemoveAndRestoreUsers(Document doc)
{
    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // get all users with GraphicOverrides
    ICollection<String> users = displaySettings.GetAllUsersWithGraphicOverrides();

    // remove the users from the display settings (they will not have graphic overrides anymore)
    ICollection<String> outUserList;
    displaySettings.RemoveUsers(doc, users, out outUserList);

    // show the current list of removed users
    ICollection<String> removedUsers = displaySettings.GetRemovedUsers();

    String message = "Current list of removed users: ";
    if (removedUsers.Count > 0 )
    {
       foreach (String user in removedUsers)
       {
          message += "\n" + user;
       }
    }
    else
    {
        message = "[Empty]";
    }

    TaskDialog.Show("Users Removed", message);

    // restore the previously removed users
    int number = displaySettings.RestoreUsers(outUserList);

    // again, show the current list of removed users
    // it should not contain the users that were restored
    removedUsers = displaySettings.GetRemovedUsers();

    message = "Current list of removed users: ";
    if (removedUsers.Count > 0 )
    {
       foreach (String user in removedUsers)
       {
          message += "\n" + user;
       }
    }
    else
    {
        message = "[Empty]";
    }

    TaskDialog.Show("Removed Users Restored", message);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class


RestoreUsers Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..RestoreUsers Method
WorksharingDisplaySettings Class See Also Send Feedback
Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int RestoreUsers(
    ICollection<string> usersToRestore
)
Visual Basic
Public Function RestoreUsers ( _
    usersToRestore As ICollection(Of String) _
) As Integer
Visual C++
public:
int RestoreUsers(
    ICollection<String^>^ usersToRestore
)

Parameters

usersToRestore
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The usernames of the users to restore. Any usernames that are not currently removed will be ignored.

Return Value

The number of usernames that were actually restored.

Remarks

This is the opposite of removing users. Note that the user will be shown with default graphic overrides - any customizations that existed prior to removing the user will not be restored.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class


SetGraphicOverrides Method

[image] [image]

Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method
WorksharingDisplaySettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetGraphicOverrides(String, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.
Public method | SetGraphicOverrides(CheckoutStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular ownership status.
Public method | SetGraphicOverrides(ModelUpdatesStatus, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements with a particular status in the central model.
Public method | SetGraphicOverrides(WorksetId, WorksharingDisplayGraphicSettings) | Sets the graphic overrides assigned to elements in a particular user workset.

See Also

WorksharingDisplaySettings Class
WorksharingDisplaySettings Members


SetGraphicOverrides Method (String, WorksharingDisplayGraphicSettings)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (String, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class See Also Send Feedback
Sets the graphic overrides assigned to elements owned by a particular user. The username cannot be on the list of removed usernames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    string username,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    username As String, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    String^ username,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

username
Type: System..::..String
The username of the desired user.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this user.

Remarks

Note that you can specify usernames which do not yet exist in the document's user table.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The username is on the list of removed users.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


SetGraphicOverrides Method (CheckoutStatus, WorksharingDisplayGraphicSettings)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (CheckoutStatus, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class Example See Also Send Feedback
Sets the graphic overrides assigned to elements with a particular ownership status.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    CheckoutStatus status,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    status As CheckoutStatus, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    CheckoutStatus status,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

status
Type: Autodesk.Revit.DB..::..CheckoutStatus
The ownership status of interest.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this ownership status.

Examples

CopyC#
public void SetWorksharingDisplaySettings(Document doc, WorksetId worksetId, String userName)
{
    String message = String.Empty;

    // get or create a WorksharingDisplaySettings current active document
    WorksharingDisplaySettings displaySettings = WorksharingDisplaySettings.GetOrCreateWorksharingDisplaySettings(doc);

    // set a new graphicSettings for CheckoutStatus - NotOwned
    WorksharingDisplayGraphicSettings graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(255, 0, 0));
    displaySettings.SetGraphicOverrides(CheckoutStatus.NotOwned, graphicSettings);

    // set a new graphicSettings for ModelUpdatesStatus - CurrentWithCentral
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(128, 128, 0));
    displaySettings.SetGraphicOverrides(ModelUpdatesStatus.CurrentWithCentral, graphicSettings);

    // set a new graphicSettings by a given userName
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(0, 255, 0));
    displaySettings.SetGraphicOverrides(userName, graphicSettings);

    // set a new graphicSettings by a given workset Id
    graphicSettings = new WorksharingDisplayGraphicSettings(true, new Color(0, 0, 255));
    displaySettings.SetGraphicOverrides(worksetId, graphicSettings);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


SetGraphicOverrides Method (ModelUpdatesStatus, WorksharingDisplayGraphicSettings)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (ModelUpdatesStatus, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class See Also Send Feedback
Sets the graphic overrides assigned to elements with a particular status in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    status As ModelUpdatesStatus, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    ModelUpdatesStatus status,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

status
Type: Autodesk.Revit.DB..::..ModelUpdatesStatus
The status in the central model.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this status.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


SetGraphicOverrides Method (WorksetId, WorksharingDisplayGraphicSettings)

[image]

Revit 2013 API
WorksharingDisplaySettings..::..SetGraphicOverrides Method (WorksetId, WorksharingDisplayGraphicSettings)
WorksharingDisplaySettings Class See Also Send Feedback
Sets the graphic overrides assigned to elements in a particular user workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
    WorksetId worksetId,
    WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
    worksetId As WorksetId, _
    overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
    WorksetId^ worksetId,
    WorksharingDisplayGraphicSettings^ overrides
)

Parameters

worksetId
Type: Autodesk.Revit.DB..::..WorksetId
The workset of interest, which must be a user workset.
overrides
Type: Autodesk.Revit.DB..::..WorksharingDisplayGraphicSettings
The desired graphic overrides for this workset.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class
SetGraphicOverrides Overload


UserHasGraphicOverrides Method

[image]

Revit 2013 API
WorksharingDisplaySettings..::..UserHasGraphicOverrides Method
WorksharingDisplaySettings Class See Also Send Feedback
Checks whether there are graphic overrides that would apply to elements owned by the given user in the "Individual Owners" display mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool UserHasGraphicOverrides(
    string username
)
Visual Basic
Public Function UserHasGraphicOverrides ( _
    username As String _
) As Boolean
Visual C++
public:
bool UserHasGraphicOverrides(
    String^ username
)

Parameters

username
Type: System..::..String
The username to check

Return Value

True if there are graphic overrides assigned to the username, false otherwise.

Remarks

There will always be graphic overrides for all users included in the user table. In addition, there may be other users who have been explicitly assigned overrides.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingDisplaySettings Class


WorksharingDisplaySettings Properties

[image] [image]

Revit 2013 API
WorksharingDisplaySettings Properties
WorksharingDisplaySettings Class See Also Send Feedback

The WorksharingDisplaySettings type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WorksharingDisplaySettings Class


Parameter Property

[image] [image]

Revit 2013 API
WorksharingDisplaySettings..::..Parameter Property
WorksharingDisplaySettings Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

WorksharingDisplaySettings Class
WorksharingDisplaySettings Members


WorksharingTooltipInfo Class

[image]

Revit 2013 API
WorksharingTooltipInfo Class
Members See Also Send Feedback
Worksharing information about a single element suitable for display in an in-canvas tooltip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingTooltipInfo : IDisposable
Visual Basic
Public Class WorksharingTooltipInfo _
    Implements IDisposable
Visual C++
public ref class WorksharingTooltipInfo : IDisposable

Remarks

Some or all of the strings may be empty.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksharingTooltipInfo

See Also

WorksharingTooltipInfo Members


WorksharingTooltipInfo Members

[image] [image]

Revit 2013 API
WorksharingTooltipInfo Members
WorksharingTooltipInfo Class Methods Properties See Also Send Feedback

The WorksharingTooltipInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingTooltipInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRequesters | The ordered list of unique user names of users who have outstanding editing requests for the specified element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Creator | The user name of the user who created the element.
Public property | LastChangedBy | The user name of the most recent user who saved a user change of this element to the central model.
Public property | Owner | The current owner of the element or empty string if no one owns the element.

See Also

WorksharingTooltipInfo Class


WorksharingTooltipInfo Methods

[image] [image]

Revit 2013 API
WorksharingTooltipInfo Methods
WorksharingTooltipInfo Class See Also Send Feedback

The WorksharingTooltipInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRequesters | The ordered list of unique user names of users who have outstanding editing requests for the specified element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksharingTooltipInfo Class


Dispose Method

[image]

Revit 2013 API
WorksharingTooltipInfo..::..Dispose Method
WorksharingTooltipInfo Class See Also Send Feedback
Releases all resources used by the WorksharingTooltipInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksharingTooltipInfo Class


GetRequesters Method

[image]

Revit 2013 API
WorksharingTooltipInfo..::..GetRequesters Method
WorksharingTooltipInfo Class See Also Send Feedback
The ordered list of unique user names of users who have outstanding editing requests for the specified element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<string> GetRequesters()
Visual Basic
Public Function GetRequesters As IList(Of String)
Visual C++
public:
IList<String^>^ GetRequesters()

Return Value

The ordered list of unique user names.

Remarks

The list is ordered by who placed the earliest request. If the list is empty it means that nobody is currently requesting the specified element.

See Also

WorksharingTooltipInfo Class


WorksharingTooltipInfo Properties

[image] [image]

Revit 2013 API
WorksharingTooltipInfo Properties
WorksharingTooltipInfo Class See Also Send Feedback

The WorksharingTooltipInfo type exposes the following members.

Properties

 | Name | Description
Public property | Creator | The user name of the user who created the element.
Public property | LastChangedBy | The user name of the most recent user who saved a user change of this element to the central model.
Public property | Owner | The current owner of the element or empty string if no one owns the element.

See Also

WorksharingTooltipInfo Class


Creator Property

[image]

Revit 2013 API
WorksharingTooltipInfo..::..Creator Property
WorksharingTooltipInfo Class See Also Send Feedback
The user name of the user who created the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Creator { get; }
Visual Basic
Public ReadOnly Property Creator As String
    Get
Visual C++
public:
property String^ Creator {
    String^ get ();
}

See Also

WorksharingTooltipInfo Class


LastChangedBy Property

[image]

Revit 2013 API
WorksharingTooltipInfo..::..LastChangedBy Property
WorksharingTooltipInfo Class See Also Send Feedback
The user name of the most recent user who saved a user change of this element to the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string LastChangedBy { get; }
Visual Basic
Public ReadOnly Property LastChangedBy As String
    Get
Visual C++
public:
property String^ LastChangedBy {
    String^ get ();
}

See Also

WorksharingTooltipInfo Class


Owner Property

[image]

Revit 2013 API
WorksharingTooltipInfo..::..Owner Property
WorksharingTooltipInfo Class See Also Send Feedback
The current owner of the element or empty string if no one owns the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Owner { get; }
Visual Basic
Public ReadOnly Property Owner As String
    Get
Visual C++
public:
property String^ Owner {
    String^ get ();
}

See Also

WorksharingTooltipInfo Class


WorksharingUtils Class

[image]

Revit 2013 API
WorksharingUtils Class
Members Example See Also Send Feedback
A static class that contains utility functions related to worksharing.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class WorksharingUtils : IDisposable
Visual Basic
Public Class WorksharingUtils _
    Implements IDisposable
Visual C++
public ref class WorksharingUtils : IDisposable

Examples

CopyC#
public void GetElementWorksharingInfo(Document doc, ElementId elemId)
{
    String message = String.Empty;
    message += "Element Id: " + elemId;

    Element elem = doc.GetElement(elemId);
    if(null == elem)
    {
       message += "Element does not exist";
       return;
    }

    // The workset the element belongs to
    WorksetId worksetId = elem.WorksetId;
    message += ("\nWorkset Id : " + worksetId.ToString());

    // Model Updates Status of the element
    ModelUpdatesStatus updateStatus = WorksharingUtils.GetModelUpdatesStatus(doc, elemId);
    message += ("\nUpdate status : " + updateStatus.ToString());

    // Checkout Status of the element
    CheckoutStatus checkoutStatus = WorksharingUtils.GetCheckoutStatus(doc, elemId);
    message += ("\nCheckout status : " + checkoutStatus.ToString());

    // Getting WorksharingTooltipInfo of a given element Id
    WorksharingTooltipInfo tooltipInfo = WorksharingUtils.GetWorksharingTooltipInfo(doc, elemId);
    message += ("\nCreator : " + tooltipInfo.Creator);
    message += ("\nCurrent Owner : " + tooltipInfo.Owner);
    message += ("\nLast Changed by : " + tooltipInfo.LastChangedBy);

    Autodesk.Revit.UI.TaskDialog.Show("GetElementWorksharingInfo", message);
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..WorksharingUtils

See Also

WorksharingUtils Members


WorksharingUtils Members

[image] [image]

Revit 2013 API
WorksharingUtils Members
WorksharingUtils Class Methods See Also Send Feedback

The WorksharingUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the WorksharingUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
 | GetCheckoutStatus(Document, ElementId, String%) | Gets the ownership status and also the owner of an element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModelUpdatesStatus | Gets the status of an element in the central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorksharingTooltipInfo | Gets worksharing information about an element to display in an in-canvas tooltip.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksharingUtils Class


WorksharingUtils Methods

[image] [image]

Revit 2013 API
WorksharingUtils Methods
WorksharingUtils Class See Also Send Feedback

The WorksharingUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
 | GetCheckoutStatus(Document, ElementId, String%) | Gets the ownership status and also the owner of an element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetModelUpdatesStatus | Gets the status of an element in the central model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetWorksharingTooltipInfo | Gets worksharing information about an element to display in an in-canvas tooltip.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorksharingUtils Class


Dispose Method

[image]

Revit 2013 API
WorksharingUtils..::..Dispose Method
WorksharingUtils Class See Also Send Feedback
Releases all resources used by the WorksharingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

WorksharingUtils Class


GetCheckoutStatus Method

[image] [image]

Revit 2013 API
WorksharingUtils..::..GetCheckoutStatus Method
WorksharingUtils Class See Also Send Feedback

Overload List

Name | Description
GetCheckoutStatus(Document, ElementId) | Gets the ownership status of an element.
GetCheckoutStatus(Document, ElementId, String%) | Gets the ownership status and also the owner of an element.

See Also

WorksharingUtils Class
WorksharingUtils Members


GetCheckoutStatus Method (Document, ElementId)

[image]

Revit 2013 API
WorksharingUtils..::..GetCheckoutStatus Method (Document, ElementId)
WorksharingUtils Class See Also Send Feedback
Gets the ownership status of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CheckoutStatus GetCheckoutStatus(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetCheckoutStatus ( _
    document As Document, _
    elementId As ElementId _
) As CheckoutStatus
Visual C++
public:
static CheckoutStatus GetCheckoutStatus(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

A summary of whether the element is unowned, owned by the current user, or owned by another user

Remarks

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element is not expanded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class
GetCheckoutStatus Overload


GetCheckoutStatus Method (Document, ElementId, String)

[image]

Revit 2013 API
WorksharingUtils..::..GetCheckoutStatus Method (Document, ElementId, String%)
WorksharingUtils Class See Also Send Feedback
Gets the ownership status and also the owner of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static CheckoutStatus GetCheckoutStatus(
    Document document,
    ElementId elementId,
    out string owner
)
Visual Basic
Public Shared Function GetCheckoutStatus ( _
    document As Document, _
    elementId As ElementId, _
    <OutAttribute> ByRef owner As String _
) As CheckoutStatus
Visual C++
public:
static CheckoutStatus GetCheckoutStatus(
    Document^ document,
    ElementId^ elementId,
    [OutAttribute] String^% owner
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question
owner
Type: System..::..String%
If non-null, this is set to the owner of the element (empty string if no one owns it)

Return Value

A summary of whether the element is unowned, owned by the current user, or owned by another user

Remarks

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element is not expanded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class
GetCheckoutStatus Overload


GetModelUpdatesStatus Method

[image]

Revit 2013 API
WorksharingUtils..::..GetModelUpdatesStatus Method
WorksharingUtils Class See Also Send Feedback
Gets the status of an element in the central model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ModelUpdatesStatus GetModelUpdatesStatus(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetModelUpdatesStatus ( _
    document As Document, _
    elementId As ElementId _
) As ModelUpdatesStatus
Visual C++
public:
static ModelUpdatesStatus GetModelUpdatesStatus(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

The status of the element in the local session versus the central model

Remarks

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element is not expanded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class


GetWorksharingTooltipInfo Method

[image]

Revit 2013 API
WorksharingUtils..::..GetWorksharingTooltipInfo Method
WorksharingUtils Class See Also Send Feedback
Gets worksharing information about an element to display in an in-canvas tooltip.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static WorksharingTooltipInfo GetWorksharingTooltipInfo(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function GetWorksharingTooltipInfo ( _
    document As Document, _
    elementId As ElementId _
) As WorksharingTooltipInfo
Visual C++
public:
static WorksharingTooltipInfo^ GetWorksharingTooltipInfo(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document containing the element
elementId
Type: Autodesk.Revit.DB..::..ElementId
The id of the element in question

Return Value

Worksharing information about the specified element.

Remarks

If there is no element corresponding to the given id, then all the strings returned in WorksharingTooltipInfo are empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

WorksharingUtils Class


XYZ Class

[image]

Revit 2013 API
XYZ Class
Members See Also Send Feedback
Object representing coordinates in 3-dimensional space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class XYZ
Visual Basic
Public Class XYZ
Visual C++
public ref class XYZ

Remarks

Usually this means a point or a vector in 3-dimensional space, depending on the actual use.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..XYZ

See Also

XYZ Members


XYZ Members

[image] [image]

Revit 2013 API
XYZ Members
XYZ Class Constructors Methods Operators Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

 | Name | Description
Public method | XYZ()()()() | Creates a default XYZ with the values (0, 0, 0).
Public method | XYZ(Double, Double, Double) | Creates an XYZ with the supplied coordinates.

Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
Public method | AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this vector and the specified vector.
Public method | DistanceTo | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | Gets the length of this vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Public method | IsUnitLength | The boolean value that indicates whether this vector is of unit length.
Public method | IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
Public method | Negate | Negates this vector.
Public method | Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
Public method | ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

Properties

 | Name | Description
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | Item | Indexed access to coordinates.
Public property | X | Gets the first coordinate.
Public property | Y | Gets the second coordinate.
Public property | Z | Gets the third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ Class


XYZ Constructor

[image] [image]

Revit 2013 API
XYZ Constructor
XYZ Class See Also Send Feedback

Overload List

 | Name | Description
Public method | XYZ()()()() | Creates a default XYZ with the values (0, 0, 0).
Public method | XYZ(Double, Double, Double) | Creates an XYZ with the supplied coordinates.

See Also

XYZ Class
XYZ Members


XYZ Constructor

[image]

Revit 2013 API
XYZ Constructor
XYZ Class See Also Send Feedback
Creates a default XYZ with the values (0, 0, 0).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ()
Visual Basic
Public Sub New
Visual C++
public:
XYZ()

See Also

XYZ Class
XYZ Overload


XYZ Constructor (Double, Double, Double)

[image]

Revit 2013 API
XYZ Constructor (Double, Double, Double)
XYZ Class See Also Send Feedback
Creates an XYZ with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ(
    double x,
    double y,
    double z
)
Visual Basic
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
Visual C++
public:
XYZ(
    double x,
    double y,
    double z
)

Parameters

x
Type: System..::..Double
The first coordinate.
y
Type: System..::..Double
The second coordinate.
z
Type: System..::..Double
The third coordinate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting an infinite number to the X, Y or Z property.

See Also

XYZ Class
XYZ Overload


XYZ Methods

[image] [image]

Revit 2013 API
XYZ Methods
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds the specified vector to this vector and returns the result.
Public method | AngleOnPlaneTo | Returns the angle between this vector and the specified vector projected to the specified plane.
Public method | AngleTo | Returns the angle between this vector and the specified vector.
Public method | CrossProduct | The cross product of this vector and the specified vector.
Public method | DistanceTo | Returns the distance from this point to the specified point.
Public method | Divide | Divides this vector by the specified value and returns the result.
Public method | DotProduct | The dot product of this vector and the specified vector.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLength | Gets the length of this vector.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.
Public method | IsUnitLength | The boolean value that indicates whether this vector is of unit length.
Public method | IsZeroLength | The boolean value that indicates whether this vector is a zero vector.
Public method | Multiply | Multiplies this vector by the specified value and returns the result.
Public method | Negate | Negates this vector.
Public method | Normalize | Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method | Subtract | Subtracts the specified vector from this vector and returns the result.
Public method | ToString | Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places. (Overrides Object..::..ToString()()()().)
Public method | TripleProduct | The triple product of this vector and the two specified vectors.

See Also

XYZ Class


Add Method

[image]

Revit 2013 API
XYZ..::..Add Method
XYZ Class See Also Send Feedback
Adds the specified vector to this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Add(
    XYZ source
)
Visual Basic
Public Function Add ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Add(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to add to this vector.

Return Value

The vector equal to the sum of the two vectors.

Remarks

The added vector is obtained by adding each coordinate of the specified vector to the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


AngleOnPlaneTo Method

[image]

Revit 2013 API
XYZ..::..AngleOnPlaneTo Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector projected to the specified plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AngleOnPlaneTo(
    XYZ right,
    XYZ normal
)
Visual Basic
Public Function AngleOnPlaneTo ( _
    right As XYZ, _
    normal As XYZ _
) As Double
Visual C++
public:
double AngleOnPlaneTo(
    XYZ^ right,
    XYZ^ normal
)

Parameters

right
Type: Autodesk.Revit.DB..::..XYZ
The specified vector.
normal
Type: Autodesk.Revit.DB..::..XYZ
The normal vector that defines the plane.

Return Value

The real number between 0 and 2*PI equal to the projected angle between the two vectors.

Remarks

The angle is projected onto the plane orthogonal to the specified normal vector, counterclockwise with the normal pointing upwards.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right or normal is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


AngleTo Method

[image]

Revit 2013 API
XYZ..::..AngleTo Method
XYZ Class See Also Send Feedback
Returns the angle between this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AngleTo(
    XYZ source
)
Visual Basic
Public Function AngleTo ( _
    source As XYZ _
) As Double
Visual C++
public:
double AngleTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The specified vector.

Return Value

The real number between 0 and PI equal to the angle between the two vectors in radians..

Remarks

The angle between the two vectors is measured in the plane spanned by them.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


CrossProduct Method

[image]

Revit 2013 API
XYZ..::..CrossProduct Method
XYZ Class See Also Send Feedback
The cross product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ CrossProduct(
    XYZ source
)
Visual Basic
Public Function CrossProduct ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ CrossProduct(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with this vector.

Return Value

The vector equal to the cross product.

Remarks

The cross product is defined as the vector which is perpendicular to both vectors with a magnitude equal to the area of the parallelogram they span. Also known as vector product or outer product.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


DistanceTo Method

[image]

Revit 2013 API
XYZ..::..DistanceTo Method
XYZ Class See Also Send Feedback
Returns the distance from this point to the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DistanceTo(
    XYZ source
)
Visual Basic
Public Function DistanceTo ( _
    source As XYZ _
) As Double
Visual C++
public:
double DistanceTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The specified point.

Return Value

The real number equal to the distance between the two points.

Remarks

The distance between the two points is equal to the length of the vector that joins the two points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


Divide Method

[image]

Revit 2013 API
XYZ..::..Divide Method
XYZ Class See Also Send Feedback
Divides this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Divide(
    double value
)
Visual Basic
Public Function Divide ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Divide(
    double value
)

Parameters

value
Type: System..::..Double
The value to divide this vector by.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number or zero.

See Also

XYZ Class


DotProduct Method

[image]

Revit 2013 API
XYZ..::..DotProduct Method
XYZ Class See Also Send Feedback
The dot product of this vector and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DotProduct(
    XYZ source
)
Visual Basic
Public Function DotProduct ( _
    source As XYZ _
) As Double
Visual C++
public:
double DotProduct(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with this vector.

Return Value

The real number equal to the dot product.

Remarks

The dot product is the sum of the respective coordinates of the two vectors: Vx*Wx + Vy*Wy + Vz*Wz. Also known as scalar product or inner product.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


GetLength Method

[image]

Revit 2013 API
XYZ..::..GetLength Method
XYZ Class See Also Send Feedback
Gets the length of this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetLength()
Visual Basic
Public Function GetLength As Double
Visual C++
public:
double GetLength()

Remarks

In 3-D Euclidean space, the length of the vector is the square root of the sum of the three coordinates squared.

See Also

XYZ Class


IsAlmostEqualTo Method

[image] [image]

Revit 2013 API
XYZ..::..IsAlmostEqualTo Method
XYZ Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsAlmostEqualTo(XYZ) | Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method | IsAlmostEqualTo(XYZ, Double) | Determines whether 2 vectors are the same within the given tolerance.

See Also

XYZ Class
XYZ Members


IsAlmostEqualTo Method (XYZ)

[image]

Revit 2013 API
XYZ..::..IsAlmostEqualTo Method (XYZ)
XYZ Class See Also Send Feedback
Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As XYZ _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to compare with this vector.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class
IsAlmostEqualTo Overload


IsAlmostEqualTo Method (XYZ, Double)

[image]

Revit 2013 API
XYZ..::..IsAlmostEqualTo Method (XYZ, Double)
XYZ Class See Also Send Feedback
Determines whether 2 vectors are the same within the given tolerance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsAlmostEqualTo(
    XYZ source,
    double tolerance
)
Visual Basic
Public Function IsAlmostEqualTo ( _
    source As XYZ, _
    tolerance As Double _
) As Boolean
Visual C++
public:
bool IsAlmostEqualTo(
    XYZ^ source,
    double tolerance
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to compare with this vector.
tolerance
Type: System..::..Double
The tolerance for equality check.

Return Value

True if the vectors are the same; otherwise, false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when tolerance is less than 0.

See Also

XYZ Class
IsAlmostEqualTo Overload


IsUnitLength Method

[image]

Revit 2013 API
XYZ..::..IsUnitLength Method
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is of unit length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsUnitLength()
Visual Basic
Public Function IsUnitLength As Boolean
Visual C++
public:
bool IsUnitLength()

Remarks

A unit length vector has a length of one, and is considered normalized.

See Also

XYZ Class


IsZeroLength Method

[image]

Revit 2013 API
XYZ..::..IsZeroLength Method
XYZ Class See Also Send Feedback
The boolean value that indicates whether this vector is a zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsZeroLength()
Visual Basic
Public Function IsZeroLength As Boolean
Visual C++
public:
bool IsZeroLength()

Remarks

The zero vector's each component is zero within the tolerance (1.0e-09).

See Also

XYZ Class


Multiply Method

[image]

Revit 2013 API
XYZ..::..Multiply Method
XYZ Class See Also Send Feedback
Multiplies this vector by the specified value and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Multiply(
    double value
)
Visual Basic
Public Function Multiply ( _
    value As Double _
) As XYZ
Visual C++
public:
XYZ^ Multiply(
    double value
)

Parameters

value
Type: System..::..Double
The value to multiply with this vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of this vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class


Negate Method

[image]

Revit 2013 API
XYZ..::..Negate Method
XYZ Class See Also Send Feedback
Negates this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Negate()
Visual Basic
Public Function Negate As XYZ
Visual C++
public:
XYZ^ Negate()

Return Value

The vector opposite to this vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of this vector.

See Also

XYZ Class


Normalize Method

[image]

Revit 2013 API
XYZ..::..Normalize Method
XYZ Class See Also Send Feedback
Returns a new XYZ whose coordinates are the normalized values from this vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Normalize()
Visual Basic
Public Function Normalize As XYZ
Visual C++
public:
XYZ^ Normalize()

Return Value

The normalized XYZ or zero if the vector is almost Zero.

Remarks

Normalized indicates that the length of this vector equals one (a unit vector).

See Also

XYZ Class


Subtract Method

[image]

Revit 2013 API
XYZ..::..Subtract Method
XYZ Class See Also Send Feedback
Subtracts the specified vector from this vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Subtract(
    XYZ source
)
Visual Basic
Public Function Subtract ( _
    source As XYZ _
) As XYZ
Visual C++
public:
XYZ^ Subtract(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ
The vector to subtract from this vector.

Return Value

The vector equal to the difference between the two vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the specified vector from the corresponding coordinate of this vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


ToString Method

[image]

Revit 2013 API
XYZ..::..ToString Method
XYZ Class See Also Send Feedback
Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

XYZ Class


TripleProduct Method

[image]

Revit 2013 API
XYZ..::..TripleProduct Method
XYZ Class See Also Send Feedback
The triple product of this vector and the two specified vectors.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TripleProduct(
    XYZ middle,
    XYZ right
)
Visual Basic
Public Function TripleProduct ( _
    middle As XYZ, _
    right As XYZ _
) As Double
Visual C++
public:
double TripleProduct(
    XYZ^ middle,
    XYZ^ right
)

Parameters

middle
Type: Autodesk.Revit.DB..::..XYZ
The second vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The third vector.

Return Value

The real number equal to the triple product.

Remarks

The scalar triple product is defined as the dot product of one of the vectors with the cross product of the other two. Geometrically, this product is the (signed) volume of the parallelepiped formed by the three vectors given.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when middle or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


XYZ Operators

[image] [image]

Revit 2013 API
XYZ Operators
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Operators

Name | Description
Addition | Adds the two specified vectors and returns the result.
Division | Divides the specified vector by the specified value.
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.
Subtraction | Subtracts the two specified vectors and returns the result.
UnaryNegation | Negates the specified vector and returns the result.

See Also

XYZ Class


Addition Operator

[image]

Revit 2013 API
XYZ..::..Addition Operator
XYZ Class See Also Send Feedback
Adds the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator +(
    XYZ left,
    XYZ right
)
Visual Basic
Public Shared Operator + ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator +(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The second vector.

Return Value

The vector equal to the sum of the two source vectors.

Remarks

The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


Division Operator

[image]

Revit 2013 API
XYZ..::..Division Operator
XYZ Class See Also Send Feedback
Divides the specified vector by the specified value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator /(
    XYZ left,
    double value
)
Visual Basic
Public Shared Operator / ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator /(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The value to divide the vector by.
value
Type: System..::..Double
The vector to divide by the value.

Return Value

The divided vector.

Remarks

The divided vector is obtained by dividing each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number or zero.

See Also

XYZ Class


Multiply Operator

[image] [image]

Revit 2013 API
XYZ..::..Multiply Operator
XYZ Class See Also Send Feedback

Overload List

Name | Description
Multiply(Double, XYZ) | Multiplies the specified number and the specified vector.
Multiply(XYZ, Double) | Multiplies the specified number and the specified vector.

See Also

XYZ Class
XYZ Members


Multiply Operator (Double, XYZ)

[image]

Revit 2013 API
XYZ..::..Multiply Operator (Double, XYZ)
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator *(
    double value,
    XYZ right
)
Visual Basic
Public Shared Operator * ( _
    value As Double, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    double value,
    XYZ^ right
)

Parameters

value
Type: System..::..Double
The value to multiply with the specified vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with the value.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when right is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload


Multiply Operator (XYZ, Double)

[image]

Revit 2013 API
XYZ..::..Multiply Operator (XYZ, Double)
XYZ Class See Also Send Feedback
Multiplies the specified number and the specified vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator *(
    XYZ left,
    double value
)
Visual Basic
Public Shared Operator * ( _
    left As XYZ, _
    value As Double _
) As XYZ
Visual C++
public:
static XYZ^ operator *(
    XYZ^ left,
    double value
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The vector to multiply with the value.
value
Type: System..::..Double
The value to multiply with the specified vector.

Return Value

The multiplied vector.

Remarks

The multiplied vector is obtained by multiplying each coordinate of the specified vector by the specified value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified value is an infinite number.

See Also

XYZ Class
Multiply Overload


Subtraction Operator

[image]

Revit 2013 API
XYZ..::..Subtraction Operator
XYZ Class See Also Send Feedback
Subtracts the two specified vectors and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ left,
    XYZ right
)
Visual Basic
Public Shared Operator - ( _
    left As XYZ, _
    right As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ left,
    XYZ^ right
)

Parameters

left
Type: Autodesk.Revit.DB..::..XYZ
The first vector.
right
Type: Autodesk.Revit.DB..::..XYZ
The second vector.

Return Value

The vector equal to the difference between the two source vectors.

Remarks

The subtracted vector is obtained by subtracting each coordinate of the right vector from the corresponding coordinate of the left vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when left or right is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


UnaryNegation Operator

[image]

Revit 2013 API
XYZ..::..UnaryNegation Operator
XYZ Class See Also Send Feedback
Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ operator -(
    XYZ source
)
Visual Basic
Public Shared Operator - ( _
    source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
    XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

XYZ Class


XYZ Properties

[image] [image]

Revit 2013 API
XYZ Properties
XYZ Class See Also Send Feedback

The XYZ type exposes the following members.

Properties

 | Name | Description
 | BasisX | The basis of the X axis.
 | BasisY | The basis of the Y axis.
 | BasisZ | The basis of the Z axis.
Public property | Item | Indexed access to coordinates.
Public property | X | Gets the first coordinate.
Public property | Y | Gets the second coordinate.
Public property | Z | Gets the third coordinate.
 | Zero | The coordinate origin or zero vector.

See Also

XYZ Class


BasisX Property

[image]

Revit 2013 API
XYZ..::..BasisX Property
XYZ Class See Also Send Feedback
The basis of the X axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ BasisX { get; }
Visual Basic
Public Shared ReadOnly Property BasisX As XYZ
    Get
Visual C++
public:
static property XYZ^ BasisX {
    XYZ^ get ();
}

Remarks

The basis of the X axis is the vector (1,0,0), the unit vector on the X axis.

See Also

XYZ Class


BasisY Property

[image]

Revit 2013 API
XYZ..::..BasisY Property
XYZ Class See Also Send Feedback
The basis of the Y axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ BasisY { get; }
Visual Basic
Public Shared ReadOnly Property BasisY As XYZ
    Get
Visual C++
public:
static property XYZ^ BasisY {
    XYZ^ get ();
}

Remarks

The basis of the Y axis is the vector (0,1,0), the unit vector on the Y axis.

See Also

XYZ Class


BasisZ Property

[image]

Revit 2013 API
XYZ..::..BasisZ Property
XYZ Class See Also Send Feedback
The basis of the Z axis.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ BasisZ { get; }
Visual Basic
Public Shared ReadOnly Property BasisZ As XYZ
    Get
Visual C++
public:
static property XYZ^ BasisZ {
    XYZ^ get ();
}

Remarks

The basis of the Z axis is the vector (0,0,1), the unit vector on the Z axis.

See Also

XYZ Class


Item Property

[image]

Revit 2013 API
XYZ..::..Item Property
XYZ Class See Also Send Feedback
Indexed access to coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int idx
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    idx As Integer _
) As Double
    Get
Visual C++
public:
property double default[int idx] {
    double get (int idx);
}

Parameters

idx
Type: System..::..Int32
Use 0 for X, 1 for Y and 2 for Z.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when an attempt is made to access the coordinate with an index that is larger than 2.

See Also

XYZ Class


X Property

[image]

Revit 2013 API
XYZ..::..X Property
XYZ Class See Also Send Feedback
Gets the first coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double X { get; }
Visual Basic
Public ReadOnly Property X As Double
    Get
Visual C++
public:
property double X {
    double get ();
}

See Also

XYZ Class


Y Property

[image]

Revit 2013 API
XYZ..::..Y Property
XYZ Class See Also Send Feedback
Gets the second coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Y { get; }
Visual Basic
Public ReadOnly Property Y As Double
    Get
Visual C++
public:
property double Y {
    double get ();
}

See Also

XYZ Class


Z Property

[image]

Revit 2013 API
XYZ..::..Z Property
XYZ Class See Also Send Feedback
Gets the third coordinate.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Z { get; }
Visual Basic
Public ReadOnly Property Z As Double
    Get
Visual C++
public:
property double Z {
    double get ();
}

See Also

XYZ Class


Zero Property

[image]

Revit 2013 API
XYZ..::..Zero Property
XYZ Class See Also Send Feedback
The coordinate origin or zero vector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static XYZ Zero { get; }
Visual Basic
Public Shared ReadOnly Property Zero As XYZ
    Get
Visual C++
public:
static property XYZ^ Zero {
    XYZ^ get ();
}

Remarks

The zero vector is (0,0,0).

See Also

XYZ Class


ZoomFitType Enumeration

[image]

Revit 2013 API
ZoomFitType Enumeration
See Also Send Feedback
This enum is used to define type of zoom.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ZoomFitType
Visual Basic
Public Enumeration ZoomFitType
Visual C++
public enum class ZoomFitType

Members

Member name | Description
FitToPage | Fit the whole view into a specific image size.
Zoom | Calculate the size of the image using physical size of the view, zoom value and resolution.

See Also


ZoomType Enumeration

[image]

Revit 2013 API
ZoomType Enumeration
See Also Send Feedback
An enumerated type listing all Zoom types of Print Setting.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ZoomType
Visual Basic
Public Enumeration ZoomType
Visual C++
public enum class ZoomType

Members

Member name | Description
FitToPage | The type of Zoom is Fit To Page.
Zoom | The type of Zoom is user defined.

See Also


Autodesk.Revit.DB.Analysis Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Analysis Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalysisDisplayColoredSurfaceSettings | Contains colored surface settings for analysis display style element.
Public class | AnalysisDisplayColorEntry | Contains one entry of intermediate colors in color settings for analysis display style.
Public class | AnalysisDisplayColorSettings | Contains color settings for analysis display style element.
Public class | AnalysisDisplayDeformedShapeSettings | Contains deformed shape settings for analysis display style element.
Public class | AnalysisDisplayDiagramSettings | Contains diagram settings for analysis display style element.
Public class | AnalysisDisplayLegend |
Public class | AnalysisDisplayLegendSettings | Contains legend settings for analysis display style element.
Public class | AnalysisDisplayMarkersAndTextSettings | Contains markers and text settings for analysis display style element.
Public class | AnalysisDisplayStyle | Exposes API for manipulation of analysis display style.
Public class | AnalysisDisplayVectorSettings | Contains vector settings for analysis display style element.
Public class | AnalysisResultSchema | Contains all information about one analysis result. Each result may contain several measurements.
Public class | ConceptualConstructionType | This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization
Public class | ConceptualSurfaceType | This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization
Public class | EnergyAnalysisDetailModel | Manage the analytical thermal model.
Public class | EnergyAnalysisDetailModelOptions |
Public class | EnergyAnalysisOpening | Analytical opening.
Public class | EnergyAnalysisSpace | Analytical space.
Public class | EnergyAnalysisSurface | Analytical surface.
Public class | EnergyDataSettings | This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization
Public class | FieldDomainPoints | Abstract base class for various classes of field domain points
Public class | FieldDomainPointsByParameter | Represents a set of one-dimensional point coordinates (defined usually on curve)
Public class | FieldDomainPointsByUV | Represents a set of two-dimensional point coordinates (defined usually on surface)
Public class | FieldDomainPointsByXYZ | Represents a set of three-dimensional point coordinates
Public class | FieldValues | Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.
Public class | MassEnergyAnalyticalModel | This class associates a mass instance with an energy analytical model data and geometry.
Public class | MassGBXMLExportOptions | Options used when exporting a gbXML file from a mass model document.
Public class | MassLevelData | MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.
Public class | MassSurfaceData | Holds properties and other data about a face in the MassEnergyAnalyticalModel element.
Public class | MassZone | MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representations of individually heated and cooled sub-volumes of a building.
Public class | Polyloop | A Polyloop represent a planar polygon with ordered points.
Public class | SpatialFieldManager | Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.
Public class | ValueAtPoint | Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.
Public class | VectorAtPoint | Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.

Enumerations

 | Enumeration | Description
Public enumeration | AnalysisDisplayStyleColorSettingsType | Defines types for color settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDeformedShapeTextLabelType | Defines text visualization types for deformed shape settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDiagramFenceType | Defines fence visualization types for diagram settings of analysis display style.
Public enumeration | AnalysisDisplayStyleDiagramTextLabelType | Defines text label visualization types for diagram settings of analysis display style.
Public enumeration | AnalysisDisplayStyleMarkerTextLabelType | Text label visualization types for Markers and Text settings of analysis display style.
Public enumeration | AnalysisDisplayStyleMarkerType | Marker types for Markers and Text settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorArrowheadScale | Defines arrow head scaling for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorOrientation | Defines vector orientation for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorPosition | Defines vector position for vector settings of analysis display style.
Public enumeration | AnalysisDisplayStyleVectorTextType | Defines text visualization types for vector settings of analysis display style.
Public enumeration | ConceptualConstructionFloorSlabType | ConceptualConstructionType values for Floors.
Public enumeration | ConceptualConstructionOpeningType | ConceptualConstructionType values for Openings.
Public enumeration | ConceptualConstructionRoofType | ConceptualConstructionType values for Roofs.
Public enumeration | ConceptualConstructionShadeType | ConceptualConstructionType values for Shades.
Public enumeration | ConceptualConstructionWallType | ConceptualConstructionType values for Walls.
Public enumeration | ConceptualConstructionWindowSkylightType | ConceptualConstructionType values for Windows and Skylights
Public enumeration | ConstructionType | This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.
Public enumeration | EnergyAnalysisDetailModelTier | Level of computation for energy analysis model.
Public enumeration | EnergyAnalysisOpeningType | Energy analysis opening type.
Public enumeration | EnergyAnalysisSurfaceType | Analytical surface types.
Public enumeration | gbXMLBuildingHVACSystem | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLBuildingOperatingSchedule | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLBuildingType | Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
Public enumeration | gbXMLConditionType | This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.
Public enumeration | gbXMLExportComplexity | This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one “huge” opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.
Public enumeration | gbXMLOpeningType | This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.
Public enumeration | gbXMLServiceType | This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.
Public enumeration | gbXMLSpaceType | This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.
Public enumeration | gbXMLSurfaceType | This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.
Public enumeration | HVACLoadConstructionClass |
Public enumeration | HVACLoadLoadsReportType |
Public enumeration | MassSurfaceDataMaterialType | Indicates how the visualization material for the MassSurfaceData is calculated.
Public enumeration | MassSurfaceDataSource | Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.
Public enumeration | MassZoneLevelCutState | The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.
Public enumeration | MassZoneMaterialType | MassZone material type.
Public enumeration | SpatialFieldPrimitiveHideMode | Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.


AnalysisDisplayColoredSurfaceSettings Class

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Class
Members Example See Also Send Feedback
Contains colored surface settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColoredSurfaceSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayColoredSurfaceSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColoredSurfaceSettings : IDisposable

Examples

CopyC#
AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings = new AnalysisDisplayColoredSurfaceSettings();
coloredSurfaceSettings.ShowGridLines = true;
CopyVB.NET
Dim coloredSurfaceSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColoredSurfaceSettings()
coloredSurfaceSettings.ShowGridLines = True

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings

See Also

AnalysisDisplayColoredSurfaceSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Members
AnalysisDisplayColoredSurfaceSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings()()()() | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a copy of colored surface settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColoredSurfaceSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Constructor
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayColoredSurfaceSettings()()()() | Constructs a default instance of colored surface settings.
Public method | AnalysisDisplayColoredSurfaceSettings(AnalysisDisplayColoredSurfaceSettings) | Constructs a copy of colored surface settings object.

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Constructor
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Constructs a default instance of colored surface settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings()

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Constructor (AnalysisDisplayColoredSurfaceSettings)

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Constructor (AnalysisDisplayColoredSurfaceSettings)
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Constructs a copy of colored surface settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings
Colored surface settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColoredSurfaceSettings Class
AnalysisDisplayColoredSurfaceSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Methods
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..Dispose Method
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayColoredSurfaceSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..IsEqual Method
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayColoredSurfaceSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColoredSurfaceSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings
Colored surface settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColoredSurfaceSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings Properties
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback

The AnalysisDisplayColoredSurfaceSettings type exposes the following members.

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


GridColor Property

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..GridColor Property
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Color of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Color GridColor { get; set; }
Visual Basic
Public Property GridColor As Color
    Get
    Set
Visual C++
public:
property Color^ GridColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


GridLineWeight Property

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..GridLineWeight Property
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
Line weight of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int GridLineWeight { get; set; }
Visual Basic
Public Property GridLineWeight As Integer
    Get
    Set
Visual C++
public:
property int GridLineWeight {
    int get ();
    void set (int value);
}

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowContourLines Property

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..ShowContourLines Property
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
If true, show contour lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowContourLines { get; set; }
Visual Basic
Public Property ShowContourLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowContourLines {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowGridLines Property

[image]

Revit 2013 API
AnalysisDisplayColoredSurfaceSettings..::..ShowGridLines Property
AnalysisDisplayColoredSurfaceSettings Class See Also Send Feedback
If true, show grid lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowGridLines { get; set; }
Visual Basic
Public Property ShowGridLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayColoredSurfaceSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Class

[image]

Revit 2013 API
AnalysisDisplayColorEntry Class
Members See Also Send Feedback
Contains one entry of intermediate colors in color settings for analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColorEntry : IDisposable
Visual Basic
Public Class AnalysisDisplayColorEntry _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColorEntry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorEntry

See Also

AnalysisDisplayColorEntry Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Members

[image] [image]

Revit 2013 API
AnalysisDisplayColorEntry Members
AnalysisDisplayColorEntry Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorEntry()()()() | Initializes a new instance of the AnalysisDisplayColorEntry class
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorEntry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Color | Color associated with color entry.
Public property | Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayColorEntry Constructor
AnalysisDisplayColorEntry Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayColorEntry()()()() | Initializes a new instance of the AnalysisDisplayColorEntry class
Public method | AnalysisDisplayColorEntry(Color) | Constructs a color entry with no value assigned.
Public method | AnalysisDisplayColorEntry(Color, Double) | Constructs a color entry with a specific value assigned.

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor

[image]

Revit 2013 API
AnalysisDisplayColorEntry Constructor
AnalysisDisplayColorEntry Class See Also Send Feedback
Initializes a new instance of the AnalysisDisplayColorEntry class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayColorEntry()

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor (Color)

[image]

Revit 2013 API
AnalysisDisplayColorEntry Constructor (Color)
AnalysisDisplayColorEntry Class See Also Send Feedback
Constructs a color entry with no value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry(
    Color color
)
Visual Basic
Public Sub New ( _
    color As Color _
)
Visual C++
public:
AnalysisDisplayColorEntry(
    Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Color assigned to the entry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Constructor (Color, Double)

[image]

Revit 2013 API
AnalysisDisplayColorEntry Constructor (Color, Double)
AnalysisDisplayColorEntry Class See Also Send Feedback
Constructs a color entry with a specific value assigned.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorEntry(
    Color color,
    double value
)
Visual Basic
Public Sub New ( _
    color As Color, _
    value As Double _
)
Visual C++
public:
AnalysisDisplayColorEntry(
    Color^ color,
    double value
)

Parameters

color
Type: Autodesk.Revit.DB..::..Color
Color assigned to the entry.
value
Type: System..::..Double
Value assigned to the entry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorEntry Class
AnalysisDisplayColorEntry Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Methods

[image] [image]

Revit 2013 API
AnalysisDisplayColorEntry Methods
AnalysisDisplayColorEntry Class See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasValue | Check if color entry has associated value.
Public method | IsEqual | Compare color entries.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayColorEntry..::..Dispose Method
AnalysisDisplayColorEntry Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayColorEntry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


HasValue Method

[image]

Revit 2013 API
AnalysisDisplayColorEntry..::..HasValue Method
AnalysisDisplayColorEntry Class See Also Send Feedback
Check if color entry has associated value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasValue()
Visual Basic
Public Function HasValue As Boolean
Visual C++
public:
bool HasValue()

Return Value

True if entry has a value associated with it, false otherwise.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayColorEntry..::..IsEqual Method
AnalysisDisplayColorEntry Class See Also Send Feedback
Compare color entries.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColorEntry other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayColorEntry _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColorEntry^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorEntry
Color entry to compare to.

Return Value

True if color entries are equal, false otherwise.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorEntry Properties

[image] [image]

Revit 2013 API
AnalysisDisplayColorEntry Properties
AnalysisDisplayColorEntry Class See Also Send Feedback

The AnalysisDisplayColorEntry type exposes the following members.

Properties

 | Name | Description
Public property | Color | Color associated with color entry.
Public property | Value | Value associated with color entry.

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Color Property

[image]

Revit 2013 API
AnalysisDisplayColorEntry..::..Color Property
AnalysisDisplayColorEntry Class See Also Send Feedback
Color associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Color Color { get; }
Visual Basic
Public ReadOnly Property Color As Color
    Get
Visual C++
public:
property Color^ Color {
    Color^ get ();
}

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


Value Property

[image]

Revit 2013 API
AnalysisDisplayColorEntry..::..Value Property
AnalysisDisplayColorEntry Class See Also Send Feedback
Value associated with color entry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Value { get; }
Visual Basic
Public ReadOnly Property Value As Double
    Get
Visual C++
public:
property double Value {
    double get ();
}

See Also

AnalysisDisplayColorEntry Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Class

[image]

Revit 2013 API
AnalysisDisplayColorSettings Class
Members Example See Also Send Feedback
Contains color settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayColorSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayColorSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayColorSettings : IDisposable

Examples

CopyC#
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
Color orange = new Color(255, 205, 0);
Color purple = new Color(200, 0, 200);
colorSettings.MaxColor = orange;
colorSettings.MinColor = purple;
CopyVB.NET
Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
Dim orange As New Color(255, 205, 0)
Dim purple As New Color(200, 0, 200)
colorSettings.MaxColor = orange
colorSettings.MinColor = purple

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings

See Also

AnalysisDisplayColorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayColorSettings Members
AnalysisDisplayColorSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayColorSettings()()()() | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs copy of a color settings object.

Methods

 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose | Releases all resources used by the AnalysisDisplayColorSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayColorSettings Constructor
AnalysisDisplayColorSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayColorSettings()()()() | Constructs a default instance of color settings.
Public method | AnalysisDisplayColorSettings(AnalysisDisplayColorSettings) | Constructs copy of a color settings object.

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayColorSettings Constructor
AnalysisDisplayColorSettings Class See Also Send Feedback
Constructs a default instance of color settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayColorSettings()

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Constructor (AnalysisDisplayColorSettings)

[image]

Revit 2013 API
AnalysisDisplayColorSettings Constructor (AnalysisDisplayColorSettings)
AnalysisDisplayColorSettings Class See Also Send Feedback
Constructs copy of a color settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayColorSettings _
)
Visual C++
public:
AnalysisDisplayColorSettings(
    AnalysisDisplayColorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
AnalysisDisplayColorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayColorSettings Methods
AnalysisDisplayColorSettings Class See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Methods

 | Name | Description
Public method | AreIntermediateColorsValid | Verify intermediate color entries
Public method | Colors | Get number of colors, including min, max and intermediate.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntermediateColors | Get intermediate color entries (other than the minimum and maximum settings).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two color settings objects.
Public method | SetIntermediateColors | Set intermediate color entries (other than the minimum and maximum settings).
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AreIntermediateColorsValid Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..AreIntermediateColorsValid Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Verify intermediate color entries

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic
Public Function AreIntermediateColorsValid ( _
    map As IList(Of AnalysisDisplayColorEntry) _
) As Boolean
Visual C++
public:
bool AreIntermediateColorsValid(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::..IList<(Of <(<'AnalysisDisplayColorEntry>)>)>
Array of intermediate color entries.

Return Value

True if intermediate colors are valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Colors Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..Colors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Get number of colors, including min, max and intermediate.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int Colors()
Visual Basic
Public Function Colors As Integer
Visual C++
public:
int Colors()

Return Value

Number of colors, including min, max and intermediate.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..Dispose Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayColorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetIntermediateColors Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..GetIntermediateColors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Get intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<AnalysisDisplayColorEntry> GetIntermediateColors()
Visual Basic
Public Function GetIntermediateColors As IList(Of AnalysisDisplayColorEntry)
Visual C++
public:
IList<AnalysisDisplayColorEntry^>^ GetIntermediateColors()

Return Value

Array of intermediate color entries.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..IsEqual Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Compares two color settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayColorSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayColorSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayColorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings object to compare to.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetIntermediateColors Method

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..SetIntermediateColors Method
AnalysisDisplayColorSettings Class See Also Send Feedback
Set intermediate color entries (other than the minimum and maximum settings).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry> map
)
Visual Basic
Public Sub SetIntermediateColors ( _
    map As IList(Of AnalysisDisplayColorEntry) _
)
Visual C++
public:
void SetIntermediateColors(
    IList<AnalysisDisplayColorEntry^>^ map
)

Parameters

map
Type: System.Collections.Generic..::..IList<(Of <(<'AnalysisDisplayColorEntry>)>)>
Array of intermediate color entries.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | intermediate color entries with specific values are not ordered by value (min to max) or too many intermediate colors (>100).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayColorSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayColorSettings Properties
AnalysisDisplayColorSettings Class See Also Send Feedback

The AnalysisDisplayColorSettings type exposes the following members.

Properties

 | Name | Description
Public property | ColorSettingsType | Stores type of color settings
Public property | MaxColor | Color assigned to the maximum value.
Public property | MinColor | Color assigned to the minimum value.

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


ColorSettingsType Property

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..ColorSettingsType Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Stores type of color settings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayStyleColorSettingsType ColorSettingsType { get; set; }
Visual Basic
Public Property ColorSettingsType As AnalysisDisplayStyleColorSettingsType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleColorSettingsType ColorSettingsType {
    AnalysisDisplayStyleColorSettingsType get ();
    void set (AnalysisDisplayStyleColorSettingsType value);
}

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


MaxColor Property

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..MaxColor Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Color assigned to the maximum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Color MaxColor { get; set; }
Visual Basic
Public Property MaxColor As Color
    Get
    Set
Visual C++
public:
property Color^ MaxColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


MinColor Property

[image]

Revit 2013 API
AnalysisDisplayColorSettings..::..MinColor Property
AnalysisDisplayColorSettings Class See Also Send Feedback
Color assigned to the minimum value.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Color MinColor { get; set; }
Visual Basic
Public Property MinColor As Color
    Get
    Set
Visual C++
public:
property Color^ MinColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayColorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Class

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Class
Members See Also Send Feedback
Contains deformed shape settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AnalysisDisplayDeformedShapeSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayDeformedShapeSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayDeformedShapeSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings

See Also

AnalysisDisplayDeformedShapeSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Members
AnalysisDisplayDeformedShapeSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayDeformedShapeSettings()()()() | Constructs a default instance of deformed shape settings.
Public method | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a copy of deformed shape settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDeformedShapeSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two deformed shape settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Constructor
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayDeformedShapeSettings()()()() | Constructs a default instance of deformed shape settings.
Public method | AnalysisDisplayDeformedShapeSettings(AnalysisDisplayDeformedShapeSettings) | Constructs a copy of deformed shape settings object.

See Also

AnalysisDisplayDeformedShapeSettings Class
AnalysisDisplayDeformedShapeSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Constructor
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Constructs a default instance of deformed shape settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalysisDisplayDeformedShapeSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayDeformedShapeSettings()

See Also

AnalysisDisplayDeformedShapeSettings Class
AnalysisDisplayDeformedShapeSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Constructor (AnalysisDisplayDeformedShapeSettings)

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Constructor (AnalysisDisplayDeformedShapeSettings)
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Constructs a copy of deformed shape settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalysisDisplayDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayDeformedShapeSettings _
)
Visual C++
public:
AnalysisDisplayDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings
Deformed shape settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayDeformedShapeSettings Class
AnalysisDisplayDeformedShapeSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Methods
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two deformed shape settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..Dispose Method
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayDeformedShapeSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..IsEqual Method
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Compares two deformed shape settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsEqual(
    AnalysisDisplayDeformedShapeSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayDeformedShapeSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayDeformedShapeSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings
Deformed shape settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDeformedShapeSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings Properties
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback

The AnalysisDisplayDeformedShapeSettings type exposes the following members.

Properties

 | Name | Description
Public property | GridColor | Color of grid lines.
Public property | GridLineWeight | Line weight of grid lines.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in deformed shape.
Public property | ShowContourLines | If true, show contour lines in the analysis display.
Public property | ShowGridLines | If true, show grid lines in the analysis display.
Public property | TextLabelType | Type of deformed shape text visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of deformed shape color fill on surfaces

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


GridColor Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..GridColor Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Color of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Color GridColor { get; set; }
Visual Basic
Public Property GridColor As Color
    Get
    Set
Visual C++
public:
property Color^ GridColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


GridLineWeight Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..GridLineWeight Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Line weight of grid lines.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GridLineWeight { get; set; }
Visual Basic
Public Property GridLineWeight As Integer
    Get
    Set
Visual C++
public:
property int GridLineWeight {
    int get ();
    void set (int value);
}

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..Rounding Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Increment to which numeric values of analysis results are rounded in deformed shape.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowContourLines Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..ShowContourLines Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
If true, show contour lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowContourLines { get; set; }
Visual Basic
Public Property ShowContourLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowContourLines {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowGridLines Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..ShowGridLines Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
If true, show grid lines in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowGridLines { get; set; }
Visual Basic
Public Property ShowGridLines As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGridLines {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextLabelType Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..TextLabelType Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Type of deformed shape text visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalysisDisplayStyleDeformedShapeTextLabelType TextLabelType { get; set; }
Visual Basic
Public Property TextLabelType As AnalysisDisplayStyleDeformedShapeTextLabelType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleDeformedShapeTextLabelType TextLabelType {
    AnalysisDisplayStyleDeformedShapeTextLabelType get ();
    void set (AnalysisDisplayStyleDeformedShapeTextLabelType value);
}

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..TextTypeId Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId TextTypeId { get; set; }
Visual Basic
Public Property TextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


Transparency Property

[image]

Revit 2013 API
AnalysisDisplayDeformedShapeSettings..::..Transparency Property
AnalysisDisplayDeformedShapeSettings Class See Also Send Feedback
Transparency percentage of deformed shape color fill on surfaces

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Transparency { get; set; }
Visual Basic
Public Property Transparency As Integer
    Get
    Set
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: transparency is less than 0 or greater than 100

See Also

AnalysisDisplayDeformedShapeSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Class

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings Class
Members See Also Send Feedback
Contains diagram settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AnalysisDisplayDiagramSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayDiagramSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayDiagramSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings

See Also

AnalysisDisplayDiagramSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayDiagramSettings Members
AnalysisDisplayDiagramSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayDiagramSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayDiagramSettings()()()() | Constructs a default instance of diagram settings.
Public method | AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) | Constructs a copy of diagram settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayDiagramSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two diagram settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayDiagramSettings Constructor
AnalysisDisplayDiagramSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayDiagramSettings()()()() | Constructs a default instance of diagram settings.
Public method | AnalysisDisplayDiagramSettings(AnalysisDisplayDiagramSettings) | Constructs a copy of diagram settings object.

See Also

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings Constructor
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Constructs a default instance of diagram settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayDiagramSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayDiagramSettings()

See Also

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Constructor (AnalysisDisplayDiagramSettings)

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings Constructor (AnalysisDisplayDiagramSettings)
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Constructs a copy of diagram settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayDiagramSettings _
)
Visual C++
public:
AnalysisDisplayDiagramSettings(
    AnalysisDisplayDiagramSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings
Diagram settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayDiagramSettings Class
AnalysisDisplayDiagramSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayDiagramSettings Methods
AnalysisDisplayDiagramSettings Class See Also Send Feedback

The AnalysisDisplayDiagramSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two diagram settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..Dispose Method
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayDiagramSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..IsEqual Method
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Compares two diagram settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEqual(
    AnalysisDisplayDiagramSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayDiagramSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayDiagramSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings
Diagram settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayDiagramSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayDiagramSettings Properties
AnalysisDisplayDiagramSettings Class See Also Send Feedback

The AnalysisDisplayDiagramSettings type exposes the following members.

Properties

 | Name | Description
Public property | FenceType | Type of diagram fence visualization.
Public property | OutlineColor | Color of outline and fence lines in the diagram.
Public property | OutlineLineWeight | Line weight of outline and fence lines in the diagram.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in diagram.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | Transparency | Transparency percentage of diagram color fill

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


FenceType Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..FenceType Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Type of diagram fence visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleDiagramFenceType FenceType { get; set; }
Visual Basic
Public Property FenceType As AnalysisDisplayStyleDiagramFenceType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleDiagramFenceType FenceType {
    AnalysisDisplayStyleDiagramFenceType get ();
    void set (AnalysisDisplayStyleDiagramFenceType value);
}

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutlineColor Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..OutlineColor Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Color of outline and fence lines in the diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Color OutlineColor { get; set; }
Visual Basic
Public Property OutlineColor As Color
    Get
    Set
Visual C++
public:
property Color^ OutlineColor {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutlineLineWeight Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..OutlineLineWeight Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Line weight of outline and fence lines in the diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int OutlineLineWeight { get; set; }
Visual Basic
Public Property OutlineLineWeight As Integer
    Get
    Set
Visual C++
public:
property int OutlineLineWeight {
    int get ();
    void set (int value);
}

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..Rounding Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Increment to which numeric values of analysis results are rounded in diagram.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextLabelType Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..TextLabelType Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Type of diagram text label visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleDiagramTextLabelType TextLabelType { get; set; }
Visual Basic
Public Property TextLabelType As AnalysisDisplayStyleDiagramTextLabelType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleDiagramTextLabelType TextLabelType {
    AnalysisDisplayStyleDiagramTextLabelType get ();
    void set (AnalysisDisplayStyleDiagramTextLabelType value);
}

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..TextTypeId Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId TextTypeId { get; set; }
Visual Basic
Public Property TextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


Transparency Property

[image]

Revit 2013 API
AnalysisDisplayDiagramSettings..::..Transparency Property
AnalysisDisplayDiagramSettings Class See Also Send Feedback
Transparency percentage of diagram color fill

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Transparency { get; set; }
Visual Basic
Public Property Transparency As Integer
    Get
    Set
Visual C++
public:
property int Transparency {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: transparency is less than 0 or greater than 100

See Also

AnalysisDisplayDiagramSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Class

[image]

Revit 2013 API
AnalysisDisplayLegend Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayLegend : Element
Visual Basic
Public Class AnalysisDisplayLegend _
    Inherits Element
Visual C++
public ref class AnalysisDisplayLegend : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegend

See Also

AnalysisDisplayLegend Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Members

[image] [image]

Revit 2013 API
AnalysisDisplayLegend Members
AnalysisDisplayLegend Class Methods Properties See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height, in sheet size, of the legend's rectangle
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Methods

[image] [image]

Revit 2013 API
AnalysisDisplayLegend Methods
AnalysisDisplayLegend Class See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegend Properties

[image] [image]

Revit 2013 API
AnalysisDisplayLegend Properties
AnalysisDisplayLegend Class See Also Send Feedback

The AnalysisDisplayLegend type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height, in sheet size, of the legend's rectangle
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


Height Property

[image]

Revit 2013 API
AnalysisDisplayLegend..::..Height Property
AnalysisDisplayLegend Class See Also Send Feedback
The height, in sheet size, of the legend's rectangle

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

See Also

AnalysisDisplayLegend Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalysisDisplayLegend..::..Parameter Property
AnalysisDisplayLegend Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalysisDisplayLegend Class
AnalysisDisplayLegend Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Class

[image]

Revit 2013 API
AnalysisDisplayLegendSettings Class
Members Example See Also Send Feedback
Contains legend settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayLegendSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayLegendSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayLegendSettings : IDisposable

Examples

CopyC#
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.NumberOfSteps = 10;
legendSettings.Rounding = 0.05;
legendSettings.ShowDataDescription = false;
legendSettings.ShowLegend = true;
CopyVB.NET
Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
legendSettings.NumberOfSteps = 10
legendSettings.Rounding = 0.05
legendSettings.ShowDataDescription = False
legendSettings.ShowLegend = True

Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
textElements = From element In collector2 _
 Where element.Name = "LegendText" _
 Select element
If textElements.Count() > 0 Then
    ' if LegendText exists, use it for this Display Style
    Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
    legendSettings.SetTextTypeId(textType.Id, doc)
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings

See Also

AnalysisDisplayLegendSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayLegendSettings Members
AnalysisDisplayLegendSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayLegendSettings()()()() | Constructs a default instance of legend settings.
Public method | AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a copy of legend settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayLegendSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two legend settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorRangeHeight | Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | ColorRangeWidth | Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | HeadingTextTypeId | Element id of text associated with legend heading.
Public property | NumberForScale | A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).
Public property | NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Public property | Rounding | Rounding increment for numeric values of analysis results.
Public property | ScaleHeight | Height of scale (for Diagram display). Measured in paperspace units.
Public property | ShowDataDescription | If true, data description is shown in the legend.
Public property | ShowDataName | If true, data name is shown in the legend.
Public property | ShowLegend | If true, legend is shown in the view.
Public property | ShowUnits | If true, units are shown in the legend.
Public property | TextTypeId | Element id of text associated with legend body.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayLegendSettings Constructor
AnalysisDisplayLegendSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayLegendSettings()()()() | Constructs a default instance of legend settings.
Public method | AnalysisDisplayLegendSettings(AnalysisDisplayLegendSettings) | Constructs a copy of legend settings object.

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayLegendSettings Constructor
AnalysisDisplayLegendSettings Class See Also Send Feedback
Constructs a default instance of legend settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayLegendSettings()

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Constructor (AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayLegendSettings Constructor (AnalysisDisplayLegendSettings)
AnalysisDisplayLegendSettings Class See Also Send Feedback
Constructs a copy of legend settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayLegendSettings _
)
Visual C++
public:
AnalysisDisplayLegendSettings(
    AnalysisDisplayLegendSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
AnalysisDisplayLegendSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayLegendSettings Methods
AnalysisDisplayLegendSettings Class See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two legend settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..Dispose Method
AnalysisDisplayLegendSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayLegendSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..IsEqual Method
AnalysisDisplayLegendSettings Class See Also Send Feedback
Compares two legend settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayLegendSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayLegendSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayLegendSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings object to compare to.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayLegendSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayLegendSettings Properties
AnalysisDisplayLegendSettings Class See Also Send Feedback

The AnalysisDisplayLegendSettings type exposes the following members.

Properties

 | Name | Description
Public property | ColorRangeHeight | Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | ColorRangeWidth | Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.
Public property | HeadingTextTypeId | Element id of text associated with legend heading.
Public property | NumberForScale | A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).
Public property | NumberOfSteps | Number of steps (values between minimum and maximum) to be shown in legend.
Public property | Rounding | Rounding increment for numeric values of analysis results.
Public property | ScaleHeight | Height of scale (for Diagram display). Measured in paperspace units.
Public property | ShowDataDescription | If true, data description is shown in the legend.
Public property | ShowDataName | If true, data name is shown in the legend.
Public property | ShowLegend | If true, legend is shown in the view.
Public property | ShowUnits | If true, units are shown in the legend.
Public property | TextTypeId | Element id of text associated with legend body.

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ColorRangeHeight Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ColorRangeHeight Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Height of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int ColorRangeHeight { get; set; }
Visual Basic
Public Property ColorRangeHeight As Integer
    Get
    Set
Visual C++
public:
property int ColorRangeHeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: colorRangeHeight is greater than 10000 or less than 0

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ColorRangeWidth Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ColorRangeWidth Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Width of color range (for Colored Surface, Markers and Text, and Vector display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int ColorRangeWidth { get; set; }
Visual Basic
Public Property ColorRangeWidth As Integer
    Get
    Set
Visual C++
public:
property int ColorRangeWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: colorRangeWidth is greater than 10000 or less than 0

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


HeadingTextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..HeadingTextTypeId Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Element id of text associated with legend heading.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId HeadingTextTypeId { get; set; }
Visual Basic
Public Property HeadingTextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ HeadingTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


NumberForScale Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..NumberForScale Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
A fixed value to display on the legend scale (0 by default; 0 means width of legend scale is calculated dynamically).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NumberForScale { get; set; }
Visual Basic
Public Property NumberForScale As Double
    Get
    Set
Visual C++
public:
property double NumberForScale {
    double get ();
    void set (double value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


NumberOfSteps Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..NumberOfSteps Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Number of steps (values between minimum and maximum) to be shown in legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int NumberOfSteps { get; set; }
Visual Basic
Public Property NumberOfSteps As Integer
    Get
    Set
Visual C++
public:
property int NumberOfSteps {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: numberOfSteps is greater than 1000 or less than 0

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..Rounding Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Rounding increment for numeric values of analysis results.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ScaleHeight Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ScaleHeight Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Height of scale (for Diagram display). Measured in paperspace units.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int ScaleHeight { get; set; }
Visual Basic
Public Property ScaleHeight As Integer
    Get
    Set
Visual C++
public:
property int ScaleHeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: scaleHeight is greater than 10000 or less than 0

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowDataDescription Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ShowDataDescription Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If true, data description is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowDataDescription { get; set; }
Visual Basic
Public Property ShowDataDescription As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataDescription {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowDataName Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ShowDataName Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If true, data name is shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowDataName { get; set; }
Visual Basic
Public Property ShowDataName As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDataName {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowLegend Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ShowLegend Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If true, legend is shown in the view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowLegend { get; set; }
Visual Basic
Public Property ShowLegend As Boolean
    Get
    Set
Visual C++
public:
property bool ShowLegend {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowUnits Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..ShowUnits Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
If true, units are shown in the legend.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowUnits { get; set; }
Visual Basic
Public Property ShowUnits As Boolean
    Get
    Set
Visual C++
public:
property bool ShowUnits {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayLegendSettings..::..TextTypeId Property
AnalysisDisplayLegendSettings Class See Also Send Feedback
Element id of text associated with legend body.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId TextTypeId { get; set; }
Visual Basic
Public Property TextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayLegendSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Class

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Class
Members Example See Also Send Feedback
Contains markers and text settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayMarkersAndTextSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayMarkersAndTextSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayMarkersAndTextSettings : IDisposable

Examples

CopyC#
// Settings relating to the marker shape and size and the display of values
AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings();
markerSettings.MarkerSize = .05;
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle;
markerSettings.Rounding = .01;

// Settings relating to the marker color
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
colorSettings.MaxColor = new Color(255, 0, 0);
colorSettings.MinColor = new Color(0, 255, 255);

// Settings relating to the legend
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.Rounding = .01;

// Create the new display style
AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings);

// Assign the new display style to the current view
doc.ActiveView.AnalysisDisplayStyleId = ads.Id;

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings

See Also

AnalysisDisplayMarkersAndTextSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Members
AnalysisDisplayMarkersAndTextSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings()()()() | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a copy of markers and text settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | ShowText | If true, show text in the analysis display.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Constructor
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayMarkersAndTextSettings()()()() | Constructs a default instance of markers and text settings.
Public method | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a copy of markers and text settings object.

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Constructor
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Constructs a default instance of markers and text settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings()

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Constructor (AnalysisDisplayMarkersAndTextSettings)

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Constructor (AnalysisDisplayMarkersAndTextSettings)
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Constructs a copy of markers and text settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayMarkersAndTextSettings _
)
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings
Markers and text settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayMarkersAndTextSettings Class
AnalysisDisplayMarkersAndTextSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Methods
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two colored surface settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..Dispose Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayMarkersAndTextSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..IsEqual Method
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Compares two colored surface settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayMarkersAndTextSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayMarkersAndTextSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings
Markers and text settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayMarkersAndTextSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings Properties
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Properties

 | Name | Description
Public property | MarkerSize | Size of marker.
Public property | MarkerType | Type of marker.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in markers.
Public property | ShowText | If true, show text in the analysis display.
Public property | TextLabelType | Type of diagram text label visualization.
Public property | TextTypeId | Element id of text associated with the settings.

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


MarkerSize Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..MarkerSize Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Size of marker.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double MarkerSize { get; set; }
Visual Basic
Public Property MarkerSize As Double
    Get
    Set
Visual C++
public:
property double MarkerSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: markerSize is negative

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


MarkerType Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..MarkerType Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Type of marker.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayStyleMarkerType MarkerType { get; set; }
Visual Basic
Public Property MarkerType As AnalysisDisplayStyleMarkerType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleMarkerType MarkerType {
    AnalysisDisplayStyleMarkerType get ();
    void set (AnalysisDisplayStyleMarkerType value);
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..Rounding Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Increment to which numeric values of analysis results are rounded in markers.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShowText Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..ShowText Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
If true, show text in the analysis display.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowText { get; set; }
Visual Basic
Public Property ShowText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowText {
    bool get ();
    void set (bool value);
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextLabelType Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..TextLabelType Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Type of diagram text label visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayStyleMarkerTextLabelType TextLabelType { get; set; }
Visual Basic
Public Property TextLabelType As AnalysisDisplayStyleMarkerTextLabelType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleMarkerTextLabelType TextLabelType {
    AnalysisDisplayStyleMarkerTextLabelType get ();
    void set (AnalysisDisplayStyleMarkerTextLabelType value);
}

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayMarkersAndTextSettings..::..TextTypeId Property
AnalysisDisplayMarkersAndTextSettings Class See Also Send Feedback
Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId TextTypeId { get; set; }
Visual Basic
Public Property TextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayMarkersAndTextSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Class

[image]

Revit 2013 API
AnalysisDisplayStyle Class
Members Example See Also Send Feedback
Exposes API for manipulation of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalysisDisplayStyle : Element
Visual Basic
Public Class AnalysisDisplayStyle _
    Inherits Element
Visual C++
public ref class AnalysisDisplayStyle : public Element

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;

AnalysisDisplayStyle analysisDisplayStyle = null;
// Look for an existing analysis display style with a specific name
FilteredElementCollector collector1 = new FilteredElementCollector(doc);
ICollection<Element> collection = collector1.OfClass(typeof(AnalysisDisplayStyle)).ToElements();
var displayStyle = from element in collection
                   where element.Name == "Display Style 1"
                   select element;

// If display style does not already exist in the document, create it
if (displayStyle.Count() == 0)
{
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings =
        new AnalysisDisplayColoredSurfaceSettings();
    coloredSurfaceSettings.ShowGridLines = true;

    AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
    Color orange = new Color(255, 205, 0);
    Color purple = new Color(200, 0, 200);
    colorSettings.MaxColor = orange;
    colorSettings.MinColor = purple;

    AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
    legendSettings.NumberOfSteps = 10;
    legendSettings.Rounding = 0.05;
    legendSettings.ShowDataDescription = false;
    legendSettings.ShowLegend = true;

    analysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc,
        "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings);
}
else
{
    analysisDisplayStyle = displayStyle.Cast<AnalysisDisplayStyle>().ElementAt<AnalysisDisplayStyle>(0);
}

// now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyle.Id;
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document

Dim analysisDisplayStyl As Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle = Nothing
' Look for an existing analysis display style with a specific name
Dim collector1 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
Dim collection As ICollection(Of Autodesk.Revit.DB.Element) = collector1.OfClass(GetType(Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)).ToElements()
Dim displayStyle As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
displayStyle = From element In collection _
 Where element.Name = "Display Style 1" _
 Select element

' If display style does not already exist in the document, create it
If displayStyle.Count() = 0 Then
    Dim coloredSurfaceSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColoredSurfaceSettings()
    coloredSurfaceSettings.ShowGridLines = True

    Dim colorSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayColorSettings()
    Dim orange As New Color(255, 205, 0)
    Dim purple As New Color(200, 0, 200)
    colorSettings.MaxColor = orange
    colorSettings.MinColor = purple

    Dim legendSettings As New Autodesk.Revit.DB.Analysis.AnalysisDisplayLegendSettings()
    legendSettings.NumberOfSteps = 10
    legendSettings.Rounding = 0.05
    legendSettings.ShowDataDescription = False
    legendSettings.ShowLegend = True

    Dim collector2 As New Autodesk.Revit.DB.FilteredElementCollector(doc)
    Dim elementCollection As ICollection(Of Autodesk.Revit.DB.Element) = collector2.OfClass(GetType(TextNoteType)).ToElements()
    Dim textElements As System.Collections.Generic.IEnumerable(Of Autodesk.Revit.DB.Element)
    textElements = From element In collector2 _
     Where element.Name = "LegendText" _
     Select element

    ' if LegendText exists, use it for this Display Style
    If textElements.Count() > 0 Then
        Dim textType As TextNoteType = textElements.Cast(Of TextNoteType)().ElementAt(0)
        legendSettings.SetTextTypeId(textType.Id, doc)
    End If
    analysisDisplayStyl = Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Display Style 1", coloredSurfaceSettings, colorSettings, legendSettings)
Else
    analysisDisplayStyl = displayStyle.Cast(Of Autodesk.Revit.DB.Analysis.AnalysisDisplayStyle)().ElementAt(0)
End If

' now assign the display style to the view
doc.ActiveView.AnalysisDisplayStyleId = analysisDisplayStyl.Id

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayStyle

See Also

AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Members

[image] [image]

Revit 2013 API
AnalysisDisplayStyle Members
AnalysisDisplayStyle Class Methods Properties See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindByName | Finds analysis display style by name.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDiagramSettings | Get diagram settings object from the style.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasVectorSettings | If true style has vector settings.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Methods

[image] [image]

Revit 2013 API
AnalysisDisplayStyle Methods
AnalysisDisplayStyle Class See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
 | CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FindByName | Finds analysis display style by name.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetColoredSurfaceSettings | Get colored surface settings object from the style.
Public method | GetColorSettings | Get color settings object from the style.
Public method | GetDeformedShapeSettings | Get deformed shape settings object from the style.
Public method | GetDiagramSettings | Get diagram settings object from the style.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
 | GetElements | Returns set of all analysis display styles elements in the given document.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLegendSettings | Get legend settings object from the style.
Public method | GetMarkersAndTextSettings | Get markers and text settings object from the style.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetVectorSettings | Get vector settings object from the style.
Public method | HasColoredSurfaceSettings | If true style has colored surface settings.
Public method | HasDeformedShapeSettings | If true style has deformed shape settings.
Public method | HasDiagramSettings | If true style has diagram settings.
Public method | HasMarkersAndTextSettings | If true style has markers and text settings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasVectorSettings | If true style has vector settings.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
 | IsNameUnique | Verify the uniqueness of the name among all analysis display style elements of the document.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetColoredSurfaceSettings | Set colored surface settings object for the style.
Public method | SetColorSettings | Set color settings object for the style.
Public method | SetDeformedShapeSettings | Set deformed shape settings object for the style.
Public method | SetDiagramSettings | Set diagram settings object for the style.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLegendSettings | Set legend settings object for the style.
Public method | SetMarkersAndTextSettings | Set markers and text settings object for the style.
Public method | SetName | Set name of analysis display style element.
Public method | SetVectorSettings | Set vector settings object for the style.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method

[image] [image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method
AnalysisDisplayStyle Class See Also Send Feedback

Overload List

Name | Description
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Colored Surface for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Deformed Shape for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Diagram for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Markers and Text for the given document.
CreateAnalysisDisplayStyle(Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings) | Factory method - creates analysis display style object of type Vectors for the given document.

See Also

AnalysisDisplayStyle Class
AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayColoredSurfaceSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object of type Colored Surface for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
name
Type: System..::..String
Name of the analysis display style within the %document%.
coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings
Colored surface settings for the style.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document.

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDeformedShapeSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object of type Deformed Shape for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayDeformedShapeSettings deformedShapeSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    deformedShapeSettings As AnalysisDisplayDeformedShapeSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
name
Type: System..::..String
Name of the analysis display style within the %document%.
deformedShapeSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings
Deformed Shape settings for the style.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document.

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayDiagramSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object of type Diagram for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayDiagramSettings diagramSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    diagramSettings As AnalysisDisplayDiagramSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayDiagramSettings^ diagramSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
name
Type: System..::..String
Name of the analysis display style within the %document%.
diagramSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings
Diagram settings for the style.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document.

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayMarkersAndTextSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object of type Markers and Text for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
name
Type: System..::..String
Name of the analysis display style within the %document%.
markersAndTextSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings
Markers and text settings for the style.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document.

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)

[image]

Revit 2013 API
AnalysisDisplayStyle..::..CreateAnalysisDisplayStyle Method (Document, String, AnalysisDisplayVectorSettings, AnalysisDisplayColorSettings, AnalysisDisplayLegendSettings)
AnalysisDisplayStyle Class See Also Send Feedback
Factory method - creates analysis display style object of type Vectors for the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static AnalysisDisplayStyle CreateAnalysisDisplayStyle(
    Document document,
    string name,
    AnalysisDisplayVectorSettings vectorSettings,
    AnalysisDisplayColorSettings colorSettings,
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Shared Function CreateAnalysisDisplayStyle ( _
    document As Document, _
    name As String, _
    vectorSettings As AnalysisDisplayVectorSettings, _
    colorSettings As AnalysisDisplayColorSettings, _
    legendSettings As AnalysisDisplayLegendSettings _
) As AnalysisDisplayStyle
Visual C++
public:
static AnalysisDisplayStyle^ CreateAnalysisDisplayStyle(
    Document^ document,
    String^ name,
    AnalysisDisplayVectorSettings^ vectorSettings,
    AnalysisDisplayColorSettings^ colorSettings,
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document for which analysis display style object is created.
name
Type: System..::..String
Name of the analysis display style within the %document%.
vectorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayVectorSettings
Vector settings for the style.
colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings
Color settings for the style.
legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings
Legend settings for the style.

Return Value

New analysis display style object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | document is a family. -or- name is not unique in document.

See Also

AnalysisDisplayStyle Class
CreateAnalysisDisplayStyle Overload
Autodesk.Revit.DB.Analysis Namespace


FindByName Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..FindByName Method
AnalysisDisplayStyle Class See Also Send Feedback
Finds analysis display style by name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElementId FindByName(
    Document document,
    string name
)
Visual Basic
Public Shared Function FindByName ( _
    document As Document, _
    name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindByName(
    Document^ document,
    String^ name
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which to look for analysis display style element.
name
Type: System..::..String
Name of analysis display style to look for.

Return Value

Element id of the found analysis display style, invalidElementId if not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetColoredSurfaceSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get colored surface settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColoredSurfaceSettings GetColoredSurfaceSettings()
Visual Basic
Public Function GetColoredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings
Visual C++
public:
AnalysisDisplayColoredSurfaceSettings^ GetColoredSurfaceSettings()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | colored surface settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetColorSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetColorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get color settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayColorSettings GetColorSettings()
Visual Basic
Public Function GetColorSettings As AnalysisDisplayColorSettings
Visual C++
public:
AnalysisDisplayColorSettings^ GetColorSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetDeformedShapeSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetDeformedShapeSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get deformed shape settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalysisDisplayDeformedShapeSettings GetDeformedShapeSettings()
Visual Basic
Public Function GetDeformedShapeSettings As AnalysisDisplayDeformedShapeSettings
Visual C++
public:
AnalysisDisplayDeformedShapeSettings^ GetDeformedShapeSettings()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | deformed shape settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetDiagramSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetDiagramSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get diagram settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayDiagramSettings GetDiagramSettings()
Visual Basic
Public Function GetDiagramSettings As AnalysisDisplayDiagramSettings
Visual C++
public:
AnalysisDisplayDiagramSettings^ GetDiagramSettings()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | diagram settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetElements Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetElements Method
AnalysisDisplayStyle Class See Also Send Feedback
Returns set of all analysis display styles elements in the given document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ICollection<ElementId> GetElements(
    Document document
)
Visual Basic
Public Shared Function GetElements ( _
    document As Document _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetElements(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document from which analysis display style elements are retrieved.

Return Value

All analysis display style elements existing in the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetLegendSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetLegendSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get legend settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegendSettings GetLegendSettings()
Visual Basic
Public Function GetLegendSettings As AnalysisDisplayLegendSettings
Visual C++
public:
AnalysisDisplayLegendSettings^ GetLegendSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetMarkersAndTextSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get markers and text settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayMarkersAndTextSettings GetMarkersAndTextSettings()
Visual Basic
Public Function GetMarkersAndTextSettings As AnalysisDisplayMarkersAndTextSettings
Visual C++
public:
AnalysisDisplayMarkersAndTextSettings^ GetMarkersAndTextSettings()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | markers and text settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


GetVectorSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..GetVectorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Get vector settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayVectorSettings GetVectorSettings()
Visual Basic
Public Function GetVectorSettings As AnalysisDisplayVectorSettings
Visual C++
public:
AnalysisDisplayVectorSettings^ GetVectorSettings()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | vector settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


HasColoredSurfaceSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..HasColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
If true style has colored surface settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasColoredSurfaceSettings()
Visual Basic
Public Function HasColoredSurfaceSettings As Boolean
Visual C++
public:
bool HasColoredSurfaceSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


HasDeformedShapeSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..HasDeformedShapeSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
If true style has deformed shape settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasDeformedShapeSettings()
Visual Basic
Public Function HasDeformedShapeSettings As Boolean
Visual C++
public:
bool HasDeformedShapeSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


HasDiagramSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..HasDiagramSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
If true style has diagram settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasDiagramSettings()
Visual Basic
Public Function HasDiagramSettings As Boolean
Visual C++
public:
bool HasDiagramSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


HasMarkersAndTextSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..HasMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
If true style has markers and text settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasMarkersAndTextSettings()
Visual Basic
Public Function HasMarkersAndTextSettings As Boolean
Visual C++
public:
bool HasMarkersAndTextSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


HasVectorSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..HasVectorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
If true style has vector settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasVectorSettings()
Visual Basic
Public Function HasVectorSettings As Boolean
Visual C++
public:
bool HasVectorSettings()

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


IsNameUnique Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..IsNameUnique Method
AnalysisDisplayStyle Class See Also Send Feedback
Verify the uniqueness of the name among all analysis display style elements of the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsNameUnique(
    Document document,
    string name,
    AnalysisDisplayStyle excludedElement
)
Visual Basic
Public Shared Function IsNameUnique ( _
    document As Document, _
    name As String, _
    excludedElement As AnalysisDisplayStyle _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
    Document^ document,
    String^ name,
    AnalysisDisplayStyle^ excludedElement
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which name uniqueness is verified.
name
Type: System..::..String
Name to verify uniqueness of.
excludedElement
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).

Return Value

True if name is unique, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


IsTextTypeIdValid Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..IsTextTypeIdValid Method
AnalysisDisplayStyle Class See Also Send Feedback
Verify if text type id is valid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsTextTypeIdValid(
    ElementId textTypeId,
    Document doc
)
Visual Basic
Public Shared Function IsTextTypeIdValid ( _
    textTypeId As ElementId, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsTextTypeIdValid(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::..ElementId
Text type id to be validated.
doc
Type: Autodesk.Revit.DB..::..Document
Document for which %textTypeId% is validated.

Return Value

True if text type id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetColoredSurfaceSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetColoredSurfaceSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set colored surface settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings
)
Visual Basic
Public Sub SetColoredSurfaceSettings ( _
    coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings _
)
Visual C++
public:
void SetColoredSurfaceSettings(
    AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings
)

Parameters

coloredSurfaceSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | colored surface settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetColorSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetColorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set color settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetColorSettings(
    AnalysisDisplayColorSettings colorSettings
)
Visual Basic
Public Sub SetColorSettings ( _
    colorSettings As AnalysisDisplayColorSettings _
)
Visual C++
public:
void SetColorSettings(
    AnalysisDisplayColorSettings^ colorSettings
)

Parameters

colorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColorSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | for Diagram display style, colorSettings must have type SolidColorRanges and exactly one intermediate entry with zero value

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetDeformedShapeSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetDeformedShapeSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set deformed shape settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings deformedShapeSettings
)
Visual Basic
Public Sub SetDeformedShapeSettings ( _
    deformedShapeSettings As AnalysisDisplayDeformedShapeSettings _
)
Visual C++
public:
void SetDeformedShapeSettings(
    AnalysisDisplayDeformedShapeSettings^ deformedShapeSettings
)

Parameters

deformedShapeSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDeformedShapeSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Deformed shape settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetDiagramSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetDiagramSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set diagram settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetDiagramSettings(
    AnalysisDisplayDiagramSettings diagramSettings
)
Visual Basic
Public Sub SetDiagramSettings ( _
    diagramSettings As AnalysisDisplayDiagramSettings _
)
Visual C++
public:
void SetDiagramSettings(
    AnalysisDisplayDiagramSettings^ diagramSettings
)

Parameters

diagramSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayDiagramSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | diagram settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetLegendSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetLegendSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set legend settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetLegendSettings(
    AnalysisDisplayLegendSettings legendSettings
)
Visual Basic
Public Sub SetLegendSettings ( _
    legendSettings As AnalysisDisplayLegendSettings _
)
Visual C++
public:
void SetLegendSettings(
    AnalysisDisplayLegendSettings^ legendSettings
)

Parameters

legendSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayLegendSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetMarkersAndTextSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetMarkersAndTextSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set markers and text settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings markersAndTextSettings
)
Visual Basic
Public Sub SetMarkersAndTextSettings ( _
    markersAndTextSettings As AnalysisDisplayMarkersAndTextSettings _
)
Visual C++
public:
void SetMarkersAndTextSettings(
    AnalysisDisplayMarkersAndTextSettings^ markersAndTextSettings
)

Parameters

markersAndTextSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayMarkersAndTextSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | markers and text settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetName Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetName Method
AnalysisDisplayStyle Class See Also Send Feedback
Set name of analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetName(
    string name
)
Visual Basic
Public Sub SetName ( _
    name As String _
)
Visual C++
public:
void SetName(
    String^ name
)

Parameters

name
Type: System..::..String
Analysis display style element name to be set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is not unique in document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


SetVectorSettings Method

[image]

Revit 2013 API
AnalysisDisplayStyle..::..SetVectorSettings Method
AnalysisDisplayStyle Class See Also Send Feedback
Set vector settings object for the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetVectorSettings(
    AnalysisDisplayVectorSettings vectorSettings
)
Visual Basic
Public Sub SetVectorSettings ( _
    vectorSettings As AnalysisDisplayVectorSettings _
)
Visual C++
public:
void SetVectorSettings(
    AnalysisDisplayVectorSettings^ vectorSettings
)

Parameters

vectorSettings
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayVectorSettings

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Vector settings were not created with the object.

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyle Properties

[image] [image]

Revit 2013 API
AnalysisDisplayStyle Properties
AnalysisDisplayStyle Class See Also Send Feedback

The AnalysisDisplayStyle type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalysisDisplayStyle..::..Parameter Property
AnalysisDisplayStyle Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalysisDisplayStyle Class
AnalysisDisplayStyle Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleColorSettingsType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleColorSettingsType Enumeration
See Also Send Feedback
Defines types for color settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum AnalysisDisplayStyleColorSettingsType
Visual Basic
Public Enumeration AnalysisDisplayStyleColorSettingsType
Visual C++
public enum class AnalysisDisplayStyleColorSettingsType

Members

Member name | Description
GradientColor | Intermediate and min/max color settings are used to interpolate color for values between adjacent entries.
SolidColorRanges | Intermediate and min/max color settings define ranges in which the color is constant.

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDeformedShapeTextLabelType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleDeformedShapeTextLabelType Enumeration
See Also Send Feedback
Defines text visualization types for deformed shape settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum AnalysisDisplayStyleDeformedShapeTextLabelType
Visual Basic
Public Enumeration AnalysisDisplayStyleDeformedShapeTextLabelType
Visual C++
public enum class AnalysisDisplayStyleDeformedShapeTextLabelType

Members

Member name | Description
ShowAll | Show vector text label for each point
ShowNone | Don't show deformed shape text labels
ShowPredefined | Show deformed shape text label only for points that have flag ValueAtPointFlags::DisplayText

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDiagramFenceType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleDiagramFenceType Enumeration
See Also Send Feedback
Defines fence visualization types for diagram settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleDiagramFenceType
Visual Basic
Public Enumeration AnalysisDisplayStyleDiagramFenceType
Visual C++
public enum class AnalysisDisplayStyleDiagramFenceType

Members

Member name | Description
ShowAll | Show fence for each point
ShowNone | Don't show fence
ShowPredefined | Show fence only for points that have flag ValueAtPointFlags::DisplayFence

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleDiagramTextLabelType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleDiagramTextLabelType Enumeration
See Also Send Feedback
Defines text label visualization types for diagram settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleDiagramTextLabelType
Visual Basic
Public Enumeration AnalysisDisplayStyleDiagramTextLabelType
Visual C++
public enum class AnalysisDisplayStyleDiagramTextLabelType

Members

Member name | Description
ShowAll | Show diagram text label for each point
ShowNone | Don't show diagram text labels
ShowPredefined | Show diagram text label only for points that have flag ValueAtPointFlags::DisplayText

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleMarkerTextLabelType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleMarkerTextLabelType Enumeration
See Also Send Feedback
Text label visualization types for Markers and Text settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleMarkerTextLabelType
Visual Basic
Public Enumeration AnalysisDisplayStyleMarkerTextLabelType
Visual C++
public enum class AnalysisDisplayStyleMarkerTextLabelType

Members

Member name | Description
ShowAll | Show text markers for each point
ShowNone | Don't show text markers
ShowPredefined | Show text markers only for points that have flag ValueAtPointFlags::DisplayText

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleMarkerType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleMarkerType Enumeration
See Also Send Feedback
Marker types for Markers and Text settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum AnalysisDisplayStyleMarkerType
Visual Basic
Public Enumeration AnalysisDisplayStyleMarkerType
Visual C++
public enum class AnalysisDisplayStyleMarkerType

Members

Member name | Description
Circle |
Square |
Triangle |

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorArrowheadScale Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleVectorArrowheadScale Enumeration
See Also Send Feedback
Defines arrow head scaling for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleVectorArrowheadScale
Visual Basic
Public Enumeration AnalysisDisplayStyleVectorArrowheadScale
Visual C++
public enum class AnalysisDisplayStyleVectorArrowheadScale

Members

Member name | Description
NoScaling |
Length5Percent |
Length10Percent |
Length15Percent |
Length20Percent |

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorOrientation Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleVectorOrientation Enumeration
See Also Send Feedback
Defines vector orientation for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleVectorOrientation
Visual Basic
Public Enumeration AnalysisDisplayStyleVectorOrientation
Visual C++
public enum class AnalysisDisplayStyleVectorOrientation

Members

Member name | Description
Linear |
ArcAroundVectorAxis |

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorPosition Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleVectorPosition Enumeration
See Also Send Feedback
Defines vector position for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleVectorPosition
Visual Basic
Public Enumeration AnalysisDisplayStyleVectorPosition
Visual C++
public enum class AnalysisDisplayStyleVectorPosition

Members

Member name | Description
ToDataPoint |
FromDataPoint |

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleVectorTextType Enumeration

[image]

Revit 2013 API
AnalysisDisplayStyleVectorTextType Enumeration
See Also Send Feedback
Defines text visualization types for vector settings of analysis display style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AnalysisDisplayStyleVectorTextType
Visual Basic
Public Enumeration AnalysisDisplayStyleVectorTextType
Visual C++
public enum class AnalysisDisplayStyleVectorTextType

Members

Member name | Description
ShowAll | Show vector text label for each point
ShowNone | Don't show vector text labels
ShowPredefined | Show vector text label only for points that have flag ValueAtPointFlags::DisplayText

See Also

Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Class

[image]

Revit 2013 API
AnalysisDisplayVectorSettings Class
Members See Also Send Feedback
Contains vector settings for analysis display style element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AnalysisDisplayVectorSettings : IDisposable
Visual Basic
Public Class AnalysisDisplayVectorSettings _
    Implements IDisposable
Visual C++
public ref class AnalysisDisplayVectorSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisDisplayVectorSettings

See Also

AnalysisDisplayVectorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Members

[image] [image]

Revit 2013 API
AnalysisDisplayVectorSettings Members
AnalysisDisplayVectorSettings Class Constructors Methods Properties See Also Send Feedback

The AnalysisDisplayVectorSettings type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisDisplayVectorSettings()()()() | Constructs a default instance of vector settings.
Public method | AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) | Constructs a copy of vector settings object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisDisplayVectorSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two vector settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrowheadScale | Type of arrow head scaling.
Public property | ArrowLineWeight | Line weight assigned to arrow lines for vectors.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in vectors.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | VectorOrientation | Vector orientation.
Public property | VectorPosition | Vector position.
Public property | VectorTextType | Type of vector text visualization.

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Constructor

[image] [image]

Revit 2013 API
AnalysisDisplayVectorSettings Constructor
AnalysisDisplayVectorSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisDisplayVectorSettings()()()() | Constructs a default instance of vector settings.
Public method | AnalysisDisplayVectorSettings(AnalysisDisplayVectorSettings) | Constructs a copy of vector settings object.

See Also

AnalysisDisplayVectorSettings Class
AnalysisDisplayVectorSettings Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Constructor

[image]

Revit 2013 API
AnalysisDisplayVectorSettings Constructor
AnalysisDisplayVectorSettings Class See Also Send Feedback
Constructs a default instance of vector settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayVectorSettings()
Visual Basic
Public Sub New
Visual C++
public:
AnalysisDisplayVectorSettings()

See Also

AnalysisDisplayVectorSettings Class
AnalysisDisplayVectorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Constructor (AnalysisDisplayVectorSettings)

[image]

Revit 2013 API
AnalysisDisplayVectorSettings Constructor (AnalysisDisplayVectorSettings)
AnalysisDisplayVectorSettings Class See Also Send Feedback
Constructs a copy of vector settings object.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayVectorSettings(
    AnalysisDisplayVectorSettings other
)
Visual Basic
Public Sub New ( _
    other As AnalysisDisplayVectorSettings _
)
Visual C++
public:
AnalysisDisplayVectorSettings(
    AnalysisDisplayVectorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayVectorSettings
Vector settings object to copy.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisDisplayVectorSettings Class
AnalysisDisplayVectorSettings Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Methods

[image] [image]

Revit 2013 API
AnalysisDisplayVectorSettings Methods
AnalysisDisplayVectorSettings Class See Also Send Feedback

The AnalysisDisplayVectorSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Compares two vector settings objects.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..Dispose Method
AnalysisDisplayVectorSettings Class See Also Send Feedback
Releases all resources used by the AnalysisDisplayVectorSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..IsEqual Method
AnalysisDisplayVectorSettings Class See Also Send Feedback
Compares two vector settings objects.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEqual(
    AnalysisDisplayVectorSettings other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisDisplayVectorSettings _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisDisplayVectorSettings^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayVectorSettings
Vector settings object to compare with.

Return Value

True if objects are equal, false otherwise.

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayVectorSettings Properties

[image] [image]

Revit 2013 API
AnalysisDisplayVectorSettings Properties
AnalysisDisplayVectorSettings Class See Also Send Feedback

The AnalysisDisplayVectorSettings type exposes the following members.

Properties

 | Name | Description
Public property | ArrowheadScale | Type of arrow head scaling.
Public property | ArrowLineWeight | Line weight assigned to arrow lines for vectors.
Public property | Rounding | Increment to which numeric values of analysis results are rounded in vectors.
Public property | TextTypeId | Element id of text associated with the settings.
Public property | VectorOrientation | Vector orientation.
Public property | VectorPosition | Vector position.
Public property | VectorTextType | Type of vector text visualization.

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


ArrowheadScale Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..ArrowheadScale Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Type of arrow head scaling.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleVectorArrowheadScale ArrowheadScale { get; set; }
Visual Basic
Public Property ArrowheadScale As AnalysisDisplayStyleVectorArrowheadScale
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleVectorArrowheadScale ArrowheadScale {
    AnalysisDisplayStyleVectorArrowheadScale get ();
    void set (AnalysisDisplayStyleVectorArrowheadScale value);
}

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


ArrowLineWeight Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..ArrowLineWeight Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Line weight assigned to arrow lines for vectors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int ArrowLineWeight { get; set; }
Visual Basic
Public Property ArrowLineWeight As Integer
    Get
    Set
Visual C++
public:
property int ArrowLineWeight {
    int get ();
    void set (int value);
}

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


Rounding Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..Rounding Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Increment to which numeric values of analysis results are rounded in vectors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Rounding { get; set; }
Visual Basic
Public Property Rounding As Double
    Get
    Set
Visual C++
public:
property double Rounding {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | When setting this property: rounding is not positive

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


TextTypeId Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..TextTypeId Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Element id of text associated with the settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId TextTypeId { get; set; }
Visual Basic
Public Property TextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


VectorOrientation Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..VectorOrientation Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Vector orientation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleVectorOrientation VectorOrientation { get; set; }
Visual Basic
Public Property VectorOrientation As AnalysisDisplayStyleVectorOrientation
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleVectorOrientation VectorOrientation {
    AnalysisDisplayStyleVectorOrientation get ();
    void set (AnalysisDisplayStyleVectorOrientation value);
}

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


VectorPosition Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..VectorPosition Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Vector position.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleVectorPosition VectorPosition { get; set; }
Visual Basic
Public Property VectorPosition As AnalysisDisplayStyleVectorPosition
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleVectorPosition VectorPosition {
    AnalysisDisplayStyleVectorPosition get ();
    void set (AnalysisDisplayStyleVectorPosition value);
}

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


VectorTextType Property

[image]

Revit 2013 API
AnalysisDisplayVectorSettings..::..VectorTextType Property
AnalysisDisplayVectorSettings Class See Also Send Feedback
Type of vector text visualization.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisDisplayStyleVectorTextType VectorTextType { get; set; }
Visual Basic
Public Property VectorTextType As AnalysisDisplayStyleVectorTextType
    Get
    Set
Visual C++
public:
property AnalysisDisplayStyleVectorTextType VectorTextType {
    AnalysisDisplayStyleVectorTextType get ();
    void set (AnalysisDisplayStyleVectorTextType value);
}

See Also

AnalysisDisplayVectorSettings Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Class

[image]

Revit 2013 API
AnalysisResultSchema Class
Members Example See Also Send Feedback
Contains all information about one analysis result. Each result may contain several measurements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class AnalysisResultSchema : IDisposable
Visual Basic
Public Class AnalysisResultSchema _
    Implements IDisposable
Visual C++
public ref class AnalysisResultSchema : IDisposable

Remarks

In order to take effect, the AnalysisResultSchema object has to be registered by calling SpatialFieldManager::RegisterResult, which returns result index for future references; to make changes to the properties of an already registered object, use method SpatialFieldManager::SetResultSchema and supply result index and replacing object.

Examples

CopyC#
IList<string> unitNames = new List<string>();
unitNames.Add("Feet");
unitNames.Add("Inches");
IList<double> multipliers = new List<double>();
multipliers.Add(1);
multipliers.Add(12);

AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");

resultSchema.SetUnits(unitNames, multipliers);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema

See Also

AnalysisResultSchema Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Members

[image] [image]

Revit 2013 API
AnalysisResultSchema Members
AnalysisResultSchema Class Constructors Methods Properties See Also Send Feedback

The AnalysisResultSchema type exposes the following members.

Constructors

 | Name | Description
Public method | AnalysisResultSchema(AnalysisResultSchema) | Initializes a new instance of the AnalysisResultSchema class
Public method | AnalysisResultSchema(String, String) | Creates object and assigns name and description

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalysisResultSchema
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfUnits | returns number of possible units
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitsMultiplier | returns units multiplier by index
Public method | GetUnitsName | returns units name by index
Public method | IsEqual |
Public method | SetUnits | Sets names and multipliers of all units for result visualization
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden
Public property | CurrentUnits | Stores the index in the array of applicable units
Public property | Description | Description of analysis result in view
Public property | IsVisible | If true analysis result is visible in view
Public property | Name | Name of analysis result in view
Public property | Scale | Multiplier used for displaying diagram or vector values in view.

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Constructor

[image] [image]

Revit 2013 API
AnalysisResultSchema Constructor
AnalysisResultSchema Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalysisResultSchema(AnalysisResultSchema) | Initializes a new instance of the AnalysisResultSchema class
Public method | AnalysisResultSchema(String, String) | Creates object and assigns name and description

See Also

AnalysisResultSchema Class
AnalysisResultSchema Members
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Constructor (AnalysisResultSchema)

[image]

Revit 2013 API
AnalysisResultSchema Constructor (AnalysisResultSchema)
AnalysisResultSchema Class See Also Send Feedback
Initializes a new instance of the AnalysisResultSchema class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisResultSchema(
    AnalysisResultSchema otherObject
)
Visual Basic
Public Sub New ( _
    otherObject As AnalysisResultSchema _
)
Visual C++
public:
AnalysisResultSchema(
    AnalysisResultSchema^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisResultSchema Class
AnalysisResultSchema Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Constructor (String, String)

[image]

Revit 2013 API
AnalysisResultSchema Constructor (String, String)
AnalysisResultSchema Class See Also Send Feedback
Creates object and assigns name and description

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisResultSchema(
    string name,
    string description
)
Visual Basic
Public Sub New ( _
    name As String, _
    description As String _
)
Visual C++
public:
AnalysisResultSchema(
    String^ name,
    String^ description
)

Parameters

name
Type: System..::..String
Name of the result schema
description
Type: System..::..String
Description of the result schema

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisResultSchema Class
AnalysisResultSchema Overload
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Methods

[image] [image]

Revit 2013 API
AnalysisResultSchema Methods
AnalysisResultSchema Class See Also Send Feedback

The AnalysisResultSchema type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNumberOfUnits | returns number of possible units
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitsMultiplier | returns units multiplier by index
Public method | GetUnitsName | returns units name by index
Public method | IsEqual |
Public method | SetUnits | Sets names and multipliers of all units for result visualization
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
AnalysisResultSchema..::..Dispose Method
AnalysisResultSchema Class See Also Send Feedback
Releases all resources used by the AnalysisResultSchema

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


GetNumberOfUnits Method

[image]

Revit 2013 API
AnalysisResultSchema..::..GetNumberOfUnits Method
AnalysisResultSchema Class See Also Send Feedback
returns number of possible units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetNumberOfUnits()
Visual Basic
Public Function GetNumberOfUnits As Integer
Visual C++
public:
int GetNumberOfUnits()

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


GetUnitsMultiplier Method

[image]

Revit 2013 API
AnalysisResultSchema..::..GetUnitsMultiplier Method
AnalysisResultSchema Class See Also Send Feedback
returns units multiplier by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetUnitsMultiplier(
    int index
)
Visual Basic
Public Function GetUnitsMultiplier ( _
    index As Integer _
) As Double
Visual C++
public:
double GetUnitsMultiplier(
    int index
)

Parameters

index
Type: System..::..Int32
index of unit in the list

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


GetUnitsName Method

[image]

Revit 2013 API
AnalysisResultSchema..::..GetUnitsName Method
AnalysisResultSchema Class See Also Send Feedback
returns units name by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string GetUnitsName(
    int index
)
Visual Basic
Public Function GetUnitsName ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetUnitsName(
    int index
)

Parameters

index
Type: System..::..Int32
index of unit in the list

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


IsEqual Method

[image]

Revit 2013 API
AnalysisResultSchema..::..IsEqual Method
AnalysisResultSchema Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEqual(
    AnalysisResultSchema other
)
Visual Basic
Public Function IsEqual ( _
    other As AnalysisResultSchema _
) As Boolean
Visual C++
public:
bool IsEqual(
    AnalysisResultSchema^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


SetUnits Method

[image]

Revit 2013 API
AnalysisResultSchema..::..SetUnits Method
AnalysisResultSchema Class Example See Also Send Feedback
Sets names and multipliers of all units for result visualization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Visual Basic
Public Sub SetUnits ( _
    names As IList(Of String), _
    multipliers As IList(Of Double) _
)
Visual C++
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)

Parameters

names
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Unit names for all units (e.g., "Lb" and "Kg")
multipliers
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Numerical coefficients mapped to unit names. They adjust measurement values shown in the legend and display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)

Examples

CopyC#
IList<string> unitNames = new List<string>();
unitNames.Add("Feet");
unitNames.Add("Inches");
IList<double> multipliers = new List<double>();
multipliers.Add(1);
multipliers.Add(12);

AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");

resultSchema.SetUnits(unitNames, multipliers);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | names is zero-length or contains duplicate or empty names -or- multipliers contains non-positive numbers, or its length is not equal to the length of names

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisResultSchema Properties

[image] [image]

Revit 2013 API
AnalysisResultSchema Properties
AnalysisResultSchema Class See Also Send Feedback

The AnalysisResultSchema type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden
Public property | CurrentUnits | Stores the index in the array of applicable units
Public property | Description | Description of analysis result in view
Public property | IsVisible | If true analysis result is visible in view
Public property | Name | Name of analysis result in view
Public property | Scale | Multiplier used for displaying diagram or vector values in view.

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


AnalysisDisplayStyleId Property

[image]

Revit 2013 API
AnalysisResultSchema..::..AnalysisDisplayStyleId Property
AnalysisResultSchema Class See Also Send Feedback
ElementId of analysis display style overriding the style set for view; -1 if the style is not overridden

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId AnalysisDisplayStyleId { get; set; }
Visual Basic
Public Property AnalysisDisplayStyleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ AnalysisDisplayStyleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


CurrentUnits Property

[image]

Revit 2013 API
AnalysisResultSchema..::..CurrentUnits Property
AnalysisResultSchema Class See Also Send Feedback
Stores the index in the array of applicable units

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int CurrentUnits { get; set; }
Visual Basic
Public Property CurrentUnits As Integer
    Get
    Set
Visual C++
public:
property int CurrentUnits {
    int get ();
    void set (int value);
}

Remarks

Must be between 0 and (number of applicable units - 1)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: currentUnits is not in the range from 0 to (number of applicable units - 1)

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


Description Property

[image]

Revit 2013 API
AnalysisResultSchema..::..Description Property
AnalysisResultSchema Class See Also Send Feedback
Description of analysis result in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Description { get; set; }
Visual Basic
Public Property Description As String
    Get
    Set
Visual C++
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


IsVisible Property

[image]

Revit 2013 API
AnalysisResultSchema..::..IsVisible Property
AnalysisResultSchema Class See Also Send Feedback
If true analysis result is visible in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsVisible { get; set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


Name Property

[image]

Revit 2013 API
AnalysisResultSchema..::..Name Property
AnalysisResultSchema Class See Also Send Feedback
Name of analysis result in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


Scale Property

[image]

Revit 2013 API
AnalysisResultSchema..::..Scale Property
AnalysisResultSchema Class See Also Send Feedback
Multiplier used for displaying diagram or vector values in view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: scale is zero or negative

See Also

AnalysisResultSchema Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionFloorSlabType Enumeration

[image]

Revit 2013 API
ConceptualConstructionFloorSlabType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionFloorSlabType
Visual Basic
Public Enumeration ConceptualConstructionFloorSlabType
Visual C++
public enum class ConceptualConstructionFloorSlabType

Members

Member name | Description
InvalidFloorSlabTypeConstruction | Invalid/not set Floor or Slab Type construction value
LightweightConstructionHighInsulation | Lightweight Construction High Insulation Floor
LightweightConstructionTypicalInsulation | Lightweight Construction Typical Insulation Floor
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Floor
LightweightConstructionNoInsulationInterior | Lightweight Construction No Insulation Interior Floor
HighMassConstructionFrigidClimateSlabInsulation | High Mass Construction Frigid Climate Insulation Slab
HighMassConstructionColdClimateSlabInsulation | High Mass Construction Cold Climate Insulation Slab
HighMassConstructionTypicalNoInsulation | High Mass Construction Typical No Insulation Slab
NumFloorSlabTypeConstruction | Total number of Floor/Slab Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionOpeningType Enumeration

[image]

Revit 2013 API
ConceptualConstructionOpeningType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionOpeningType
Visual Basic
Public Enumeration ConceptualConstructionOpeningType
Visual C++
public enum class ConceptualConstructionOpeningType

Members

Member name | Description
InvalidOpeningTypeConstruction | Invalid value/not set Opening Type Construction
Air | Air Opening
NumOpeningTypeConstruction | Total Number of Opening Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionRoofType Enumeration

[image]

Revit 2013 API
ConceptualConstructionRoofType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Roofs.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionRoofType
Visual Basic
Public Enumeration ConceptualConstructionRoofType
Visual C++
public enum class ConceptualConstructionRoofType

Members

Member name | Description
InvalidRoofTypeConstruction | Invalid value/not set Roof Type Construction value
HighInsulationCoolRoof | High Insulation Cool Roof
HighInsulationDarkRoof | High Insulation Dark Roof
TypicalInsulationCoolRoof | Typical Insulation Cool Roof
TypicalInsulationDarkRoof | Typical Insulation Dark Roof
LowInsulationCoolRoof | Low Insulation Cool Roof
LowInsulationDarkRoof | Low Insulation Dark Roof
NoInsulationDarkRoof | No Insulation Dark Roof
NumRoofTypeConstruction | Total Number of Roof Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionShadeType Enumeration

[image]

Revit 2013 API
ConceptualConstructionShadeType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Shades.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionShadeType
Visual Basic
Public Enumeration ConceptualConstructionShadeType
Visual C++
public enum class ConceptualConstructionShadeType

Members

Member name | Description
InvalidShadeTypeConstruction | Invalid value/not set Shade Type Construction
BasicShade | Basic Shade
NumShadeTypeConstruction | Total Number of Shade Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Class

[image]

Revit 2013 API
ConceptualConstructionType Class
Members See Also Send Feedback
This element is used to describe the conceptual physical, construction, and energy properties in a manner that can be understood by both the Revit BIM model and Green Building Studio/Green Building XML. For serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ConceptualConstructionType : ElementType
Visual Basic
Public Class ConceptualConstructionType _
    Inherits ElementType
Visual C++
public ref class ConceptualConstructionType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Analysis..::..ConceptualConstructionType

See Also

ConceptualConstructionType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Members

[image] [image]

Revit 2013 API
ConceptualConstructionType Members
ConceptualConstructionType Class Methods Properties See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
Public method ArePhasesModifiable
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element.)
Public method CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
Public method CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
Public method CanHaveTypeAssigned()()()()
Identifies if the element can have a type assigned.
(Inherited from Element.)
Public method ChangeTypeId(ElementId)
Changes type of the element.
(Inherited from Element.)
Public method DeleteEntity
Deletes the existing entity created by %schema% in the element
(Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method Duplicate
Duplicate this object.
(Inherited from ElementType.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
Public method GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
Public method GetAnalyticalModelId
Retrieves the Element Id of the Analytical Model Element for this Element.
(Inherited from Element.)
Public method GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
Public method GetEntity
Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element.)
Public method GetExternalFileReference
Gets information pertaining to the external file referenced by the element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
Public method GetGBSId
Gets the Green Building Studio identifier associated with the construction.
Public method GetGeneratingElementIds
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element.)
Public method GetGeometryObjectFromReference
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
Public method GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
Public method GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
Public method GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Public method GetPhaseStatus
Gets the status of a given element in the input phase
(Inherited from Element.)
Public method GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Public method GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
Public method GetValidTypes()()()()
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
Public method HasPhases
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element.)
Public method IsExternalFileReference
Determines whether this Element represents an external file.
(Inherited from Element.)
Public method IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
Public method IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
Public method IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
Public method IsPhaseCreatedValid
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element.)
Public method IsPhaseDemolishedValid
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element.)
Public method IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
Public method IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Public method IsValidType(ElementId)
Checks if given type is valid for this element.
(Inherited from Element.)
Public method SetEntity
Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Methods

[image] [image]

Revit 2013 API
ConceptualConstructionType Methods
ConceptualConstructionType Class See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Methods

Name | Description
Public method ArePhasesModifiable
Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element.)
Public method CanBeHidden
Indicates if the element can be hidden in the view.
(Inherited from Element.)
Public method CanHaveAnalyticalModel
Indicates whether the Element can have an Analytical Model.
(Inherited from Element.)
Public method CanHaveTypeAssigned()()()()
Identifies if the element can have a type assigned.
(Inherited from Element.)
Public method ChangeTypeId(ElementId)
Changes type of the element.
(Inherited from Element.)
Public method DeleteEntity
Deletes the existing entity created by %schema% in the element
(Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method Duplicate
Duplicate this object.
(Inherited from ElementType.)
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetAllConceptualConstructionsForCategory
Get all the ids of constructions applicable to the input massSubCategory
Public method GetAnalyticalModel
Retrieves writeable Analytical Model for Element.
(Inherited from Element.)
Public method GetAnalyticalModelId
Retrieves the Element Id of the Analytical Model Element for this Element.
(Inherited from Element.)
Public method GetDividedSurfaceData
Get an interface to the divided surfaces on this element.
(Inherited from Element.)
Public method GetEntity
Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element.)
Public method GetExternalFileReference
Gets information pertaining to the external file referenced by the element.
(Inherited from Element.)
GetFloorOrSlabConstructionType
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.
Public method GetGBSId
Gets the Green Building Studio identifier associated with the construction.
Public method GetGeneratingElementIds
Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element.)
Public method GetGeometryObjectFromReference
Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element.)
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetMaterialArea
Get the area of the given material on this element.
(Inherited from Element.)
Public method GetMaterialVolume
Get the volume of the given material on this element.
(Inherited from Element.)
Public method GetMonitoredLinkElementIds
Provides the link instance IDs when the element is monitoring.
(Inherited from Element.)
Public method GetMonitoredLocalElementIds
Provides the local element IDs when the element is monitoring.
(Inherited from Element.)
GetOpeningConstructionType
Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Public method GetPhaseStatus
Gets the status of a given element in the input phase
(Inherited from Element.)
Public method GetPreviewImage
Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
(Inherited from ElementType.)
GetRoofConstructionType
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.
GetShadeConstructionType
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.
Public method GetSimilarTypes
Obtains a set of types that are similar to this type.
(Inherited from ElementType.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
Public method GetTypeId
Returns the identifier of this element's type.
(Inherited from Element.)
Public method GetValidTypes()()()()
Obtains a set of types that are valid for this element.
(Inherited from Element.)
GetWallConstructionType
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.
GetWindowOrSkylightConstructionType
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.
Public method HasPhases
Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element.)
Public method IsExternalFileReference
Determines whether this Element represents an external file.
(Inherited from Element.)
Public method IsHidden
Identifies if the element has been permanently hidden in the view.
(Inherited from Element.)
Public method IsMonitoringLinkElement
Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element.)
Public method IsMonitoringLocalElement
Indicate whether an element is monitoring other local elements.
(Inherited from Element.)
Public method IsPhaseCreatedValid
Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element.)
Public method IsPhaseDemolishedValid
Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element.)
Public method IsSimilarType
Checks if given type is similar to this type.
(Inherited from ElementType.)
IsValidConceptualConstructionId
Indicates if the ElementId is an id of a ConceptualConstructionType.
IsValidConceptualConstructionIdForCategory
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.
IsValidSubcategoryForMassSurfaceDatas
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening
Public method IsValidSurfaceSubcategoryForConstruction
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.
Public method IsValidType(ElementId)
Checks if given type is valid for this element.
(Inherited from Element.)
Public method SetEntity
Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element.)
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetAllConceptualConstructionsForCategory Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetAllConceptualConstructionsForCategory Method
ConceptualConstructionType Class See Also Send Feedback
Get all the ids of constructions applicable to the input massSubCategory

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> GetAllConceptualConstructionsForCategory(
    Document ccda,
    ElementId massSubCategoryId
)
Visual Basic
Public Shared Function GetAllConceptualConstructionsForCategory ( _
    ccda As Document, _
    massSubCategoryId As ElementId _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAllConceptualConstructionsForCategory(
    Document^ ccda,
    ElementId^ massSubCategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the mass subcategory.

Return Value

Returns a set of ElementIds that for the ConceptualConstructionTypes that are appropriate for the subcategory.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetFloorOrSlabConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetFloorOrSlabConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Floor or Slab ConceptualConstructionType by its ConceptualConstructionFloorSlabType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetFloorOrSlabConstructionType(
    Document ccda,
    ConceptualConstructionFloorSlabType typeEnum
)
Visual Basic
Public Shared Function GetFloorOrSlabConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionFloorSlabType _
) As ElementId
Visual C++
public:
static ElementId^ GetFloorOrSlabConstructionType(
    Document^ ccda,
    ConceptualConstructionFloorSlabType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionFloorSlabType
The ConceptualConstructionFloorSlabType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionFloorSlabType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetGBSId Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetGBSId Method
ConceptualConstructionType Class See Also Send Feedback
Gets the Green Building Studio identifier associated with the construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetGBSId(
    ElementId massSurfaceSubCategoryId
)
Visual Basic
Public Function GetGBSId ( _
    massSurfaceSubCategoryId As ElementId _
) As Integer
Visual C++
public:
int GetGBSId(
    ElementId^ massSurfaceSubCategoryId
)

Parameters

massSurfaceSubCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of a valid Mass subcategory of a MassSurfaceData.

Return Value

Returns the integer id used to represent the ConceptualConstructionType.

Remarks

Sometimes the GBSId is different for the same ConceptualConstructionType depending on the mass subcategory it is related to. This is usually the case, for example, for window and skylight constructions, which do not share GBSid's even when they share ConceptualConstructionTypes.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Element massSurfaceSubCategoryId is not a valid subcategory value for MassSurfaceData. -or- The ElementId massSurfaceSubCategoryId is not appropriate for this ConceptualConstructionType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetOpeningConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetOpeningConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetOpeningConstructionType(
    Document ccda,
    ConceptualConstructionOpeningType typeEnum
)
Visual Basic
Public Shared Function GetOpeningConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionOpeningType _
) As ElementId
Visual C++
public:
static ElementId^ GetOpeningConstructionType(
    Document^ ccda,
    ConceptualConstructionOpeningType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionOpeningType
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionOpeningType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetRoofConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetRoofConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Roof ConceptualConstructionType by its ConceptualConstructionRoofType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetRoofConstructionType(
    Document ccda,
    ConceptualConstructionRoofType typeEnum
)
Visual Basic
Public Shared Function GetRoofConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionRoofType _
) As ElementId
Visual C++
public:
static ElementId^ GetRoofConstructionType(
    Document^ ccda,
    ConceptualConstructionRoofType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionRoofType
The ConceptualConstructionRoofType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionRoofType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetShadeConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetShadeConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Shade ConceptualConstructionType by its ConceptualConstructionShadeType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetShadeConstructionType(
    Document ccda,
    ConceptualConstructionShadeType typeEnum
)
Visual Basic
Public Shared Function GetShadeConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionShadeType _
) As ElementId
Visual C++
public:
static ElementId^ GetShadeConstructionType(
    Document^ ccda,
    ConceptualConstructionShadeType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionShadeType
The ConceptualConstructionShadeType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionShadeType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetWallConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetWallConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Wall ConceptualConstructionType by its ConceptualConstructionWallType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetWallConstructionType(
    Document ccda,
    ConceptualConstructionWallType typeEnum
)
Visual Basic
Public Shared Function GetWallConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWallType _
) As ElementId
Visual C++
public:
static ElementId^ GetWallConstructionType(
    Document^ ccda,
    ConceptualConstructionWallType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionWallType
The ConceptualConstructionWallType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWallType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


GetWindowOrSkylightConstructionType Method

[image]

Revit 2013 API
ConceptualConstructionType..::..GetWindowOrSkylightConstructionType Method
ConceptualConstructionType Class See Also Send Feedback
Get a Window or Skylight ConceptualConstructionType by its ConceptualConstructionWindowSkylightType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetWindowOrSkylightConstructionType(
    Document ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)
Visual Basic
Public Shared Function GetWindowOrSkylightConstructionType ( _
    ccda As Document, _
    typeEnum As ConceptualConstructionWindowSkylightType _
) As ElementId
Visual C++
public:
static ElementId^ GetWindowOrSkylightConstructionType(
    Document^ ccda,
    ConceptualConstructionWindowSkylightType typeEnum
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
typeEnum
Type: Autodesk.Revit.DB.Analysis..::..ConceptualConstructionWindowSkylightType
The ConceptualConstructionWindowSkylightType to get the ConceptualConstructionType for.

Return Value

Returns ElementId of a ConceptualConstructionType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionWindowSkylightType.

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionId Method

[image]

Revit 2013 API
ConceptualConstructionType..::..IsValidConceptualConstructionId Method
ConceptualConstructionType Class See Also Send Feedback
Indicates if the ElementId is an id of a ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidConceptualConstructionId(
    Document ccda,
    ElementId constructionTypeId
)
Visual Basic
Public Shared Function IsValidConceptualConstructionId ( _
    ccda As Document, _
    constructionTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionId(
    Document^ ccda,
    ElementId^ constructionTypeId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the ConceptualConstructionType.

Return Value

Returns true if is an id of a ConceptualConstructionType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionIdForCategory Method

[image]

Revit 2013 API
ConceptualConstructionType..::..IsValidConceptualConstructionIdForCategory Method
ConceptualConstructionType Class See Also Send Feedback
Indicate if a ConceptualConstruction is appropriate to assign to a MassSurfaceData of a particular Mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidConceptualConstructionIdForCategory(
    Document ccda,
    ElementId constructionTypeId,
    ElementId massSubcategoryId
)
Visual Basic
Public Shared Function IsValidConceptualConstructionIdForCategory ( _
    ccda As Document, _
    constructionTypeId As ElementId, _
    massSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConceptualConstructionIdForCategory(
    Document^ ccda,
    ElementId^ constructionTypeId,
    ElementId^ massSubcategoryId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document.
constructionTypeId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the ConceptualConstructionType.
massSubcategoryId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the Mass subcategory.

Return Value

Returns true if valid, false otherwise

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId constructionTypeId is not an id of a ConceptualConstructionType. -or- The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassWallsAll, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassFloorsAll, OST_MassShade, OST_MassWindow, OST_MassSkylights, OST_MassGlazingAll or OST_MassOpening.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidSubcategoryForMassSurfaceDatas Method

[image]

Revit 2013 API
ConceptualConstructionType..::..IsValidSubcategoryForMassSurfaceDatas Method
ConceptualConstructionType Class See Also Send Feedback
Validate if a subcategory is appropriate for assignment to Massing surfaces (MassSurfaceData). This is the list of acceptable values:
  1. OST_MassInteriorWall
  2. OST_MassExteriorWall
  3. OST_MassExteriorWallUnderground
  4. OST_MassRoof
  5. OST_MassFloor
  6. OST_MassSlab
  7. OST_MassShade
  8. OST_MassWindow
  9. OST_MassSkylights
  10. OST_MassOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId massSubCategoryId
)
Visual Basic
Public Shared Function IsValidSubcategoryForMassSurfaceDatas ( _
    massSubCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidSubcategoryForMassSurfaceDatas(
    ElementId^ massSubCategoryId
)

Parameters

massSubCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The mass sub-category to be checked.

Return Value

True if the mass sub-category falls within the list, false otherwise.

Remarks

This excludes sub-categories which are not actually sub-categories that can be assigned to surfaces, such as OST_MassWallsAll for example.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


IsValidSurfaceSubcategoryForConstruction Method

[image]

Revit 2013 API
ConceptualConstructionType..::..IsValidSurfaceSubcategoryForConstruction Method
ConceptualConstructionType Class See Also Send Feedback
Indicates if this ConceptualConstructionType is appropriate for the input MassSurfaceData subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidSurfaceSubcategoryForConstruction(
    ElementId massSurfaceSubcategoryId
)
Visual Basic
Public Function IsValidSurfaceSubcategoryForConstruction ( _
    massSurfaceSubcategoryId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidSurfaceSubcategoryForConstruction(
    ElementId^ massSurfaceSubcategoryId
)

Parameters

massSurfaceSubcategoryId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of a Mass subcategory of a MassSurfaceData.

Return Value

Returns true if appropriate for the input subcategory, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Element massSurfaceSubcategoryId is not a valid subcategory value for MassSurfaceData.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionType Properties

[image] [image]

Revit 2013 API
ConceptualConstructionType Properties
ConceptualConstructionType Class See Also Send Feedback

The ConceptualConstructionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassSurfaceSubCategoryId | The surface type subcategory element id associated with the ConceptualConstructionType.
Public property | MaterialId | Material used for visualization of this construction.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceSubCategoryId Property

[image]

Revit 2013 API
ConceptualConstructionType..::..MassSurfaceSubCategoryId Property
ConceptualConstructionType Class See Also Send Feedback
The surface type subcategory element id associated with the ConceptualConstructionType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MassSurfaceSubCategoryId { get; }
Visual Basic
Public ReadOnly Property MassSurfaceSubCategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ MassSurfaceSubCategoryId {
    ElementId^ get ();
}

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2013 API
ConceptualConstructionType..::..MaterialId Property
ConceptualConstructionType Class See Also Send Feedback
Material used for visualization of this construction.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element materialId is not a material element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ConceptualConstructionType Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
ConceptualConstructionType..::..Parameter Property
ConceptualConstructionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ConceptualConstructionType Class
ConceptualConstructionType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWallType Enumeration

[image]

Revit 2013 API
ConceptualConstructionWallType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionWallType
Visual Basic
Public Enumeration ConceptualConstructionWallType
Visual C++
public enum class ConceptualConstructionWallType

Members

Member name | Description
InvalidExteriorWallTypeConstruction | Invalid value/not set Roof Type Construction value
LightweightConstructionHighInsulation | Lightweight Construction High Insulation Wall
LightweightConstructionTypicalColdClimateInsulation | Lightweight Construction Typical Cold Climate Insulation Wall
LightweightConstructionTypicalMildClimateInsulation | Lightweight Construction Typical Mild Climate Insulation Wall
LightweightConstructionLowInsulation | Lightweight Construction Low Insulation Wall
LightweightConstructionNoInsulationInterior | Lightweight Construction No Insulation Interior Wall
HighMassConstructionHighInsulation | High Mass Construction High Insulation Wall
HighMassConstructionTypicalColdClimateInsulation | High Mass Construction Typical Cold Climate Insulation Wall
HighMassConstructionTypicalMildClimateInsulation | High Mass Construction Typical Mild Climate Insulation Wall
HighMassConstructionNoInsulationInterior | High Mass Construction No Insulation Interior Wall
NumWallTypeConstruction | Total Number of Wall Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionWindowSkylightType Enumeration

[image]

Revit 2013 API
ConceptualConstructionWindowSkylightType Enumeration
See Also Send Feedback
ConceptualConstructionType values for Windows and Skylights

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ConceptualConstructionWindowSkylightType
Visual Basic
Public Enumeration ConceptualConstructionWindowSkylightType
Visual C++
public enum class ConceptualConstructionWindowSkylightType

Members

Member name | Description
InvalidWindowSkylightTypeConstruction | Invalid value/not set Window or Skylight Type Construction
SinglePaneClearNoCoating | Single Pane Clear No Coating Window or Skylight
SinglePaneTinted | Single Pane Tinted Window or Skylight
SinglePaneReflective | Single Pane Reflective Window or Skylight
DoublePaneClearNoCoating | Double Pane Clear No Coating Window or Skylight
DoublePaneTinted | Double Pane Tinted Window or Skylight
DoublePaneReflective | Double Pane Reflective Window or Skylight
DoublePaneClearLowEColdClimateHighSHGC | Double Pane Clear Low Energy Cold Climate High Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearLowEHotClimateLowSHGC | Double Pane Clear Low Energy Hot Climate Low Solar Heat Gain Coefficient Window or Skylight
DoublePaneClearHighestPerformanceLowEHighVisTransLowSHGC | Double Pane Clear Highest Performance Low Window or Skylight
TriplePaneClearLowEHotOrColdClimate | Triple Pane Clear Low Energy Hot or Cold Climate Window or Skylight
QuadPaneClearLowEHotOrColdClimate | Quad Pane Clear Low Energy Hot Or Cold Climate Window or Skylight
NumWindowSkylightTypeConstruction | Total Number of Window or Skylight Type Constructions

See Also

Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Class

[image]

Revit 2013 API
ConceptualSurfaceType Class
Members See Also Send Feedback
This element represents a conceptual BIM object category to assign to faces in Mass geometries. There is one ConceptualSurfaceType element for each of the Mass Surface Subcategories. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ConceptualSurfaceType : IDisposable
Visual Basic
Public Class ConceptualSurfaceType _
    Implements IDisposable
Visual C++
public ref class ConceptualSurfaceType : IDisposable

Remarks

When Conceptual Energy Analysis is enabled in Revit Projects, massing faces will be assigned to the subcategories of Mass category that these ConceptualSurfaceType's are associated with. A default ConceptualConstructionType is associated with the ConceptualSurfaceType. This default ConceptualConstructionType is assigned to Mass faces with the corresponding subcategory. Changing the default ConceptualConstructionType associated with the ConceptualSurfaceType will update the ConceptualConstruction type for all Mass faces of that subcategory which the user has not specifically provided an override value for.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..ConceptualSurfaceType

See Also

ConceptualSurfaceType Members
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Members

[image] [image]

Revit 2013 API
ConceptualSurfaceType Members
ConceptualSurfaceType Class Methods Properties See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ConceptualSurfaceType
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
Public property | MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Methods

[image] [image]

Revit 2013 API
ConceptualSurfaceType Methods
ConceptualSurfaceType Class See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllMassSubCategoryIds | Get all the mass subcategory ids for which there are ConceptualSurfaceType's.
 | GetByMassSubCategoryId | Get the ConceptualSurfaceType by its mass subcategory id.
Public method | GetConstructionTypeIds | The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
ConceptualSurfaceType..::..Dispose Method
ConceptualSurfaceType Class See Also Send Feedback
Releases all resources used by the ConceptualSurfaceType

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetAllMassSubCategoryIds Method

[image]

Revit 2013 API
ConceptualSurfaceType..::..GetAllMassSubCategoryIds Method
ConceptualSurfaceType Class See Also Send Feedback
Get all the mass subcategory ids for which there are ConceptualSurfaceType's.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetAllMassSubCategoryIds()
Visual Basic
Public Shared Function GetAllMassSubCategoryIds As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllMassSubCategoryIds()

Return Value

Returns an array of element id of mass subcategories for which there are ConceptualSurfaceType's.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetByMassSubCategoryId Method

[image]

Revit 2013 API
ConceptualSurfaceType..::..GetByMassSubCategoryId Method
ConceptualSurfaceType Class See Also Send Feedback
Get the ConceptualSurfaceType by its mass subcategory id.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ConceptualSurfaceType GetByMassSubCategoryId(
    Document cda,
    ElementId massSubCategoryId
)
Visual Basic
Public Shared Function GetByMassSubCategoryId ( _
    cda As Document, _
    massSubCategoryId As ElementId _
) As ConceptualSurfaceType
Visual C++
public:
static ConceptualSurfaceType^ GetByMassSubCategoryId(
    Document^ cda,
    ElementId^ massSubCategoryId
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The document.
massSubCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The mass subcategory id to get the ConceptualSurfaceType for.

Return Value

Returns ConceptualSurfaceType associated with input id or NULL.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The mass sub-category is none of the OST_MassInteriorWall, OST_MassExteriorWall, OST_MassExteriorWallUnderground, OST_MassRoof, OST_MassFloor, OST_MassSlab, OST_MassShade, OST_MassWindow, OST_MassSkylights, or OST_MassOpening.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


GetConstructionTypeIds Method

[image]

Revit 2013 API
ConceptualSurfaceType..::..GetConstructionTypeIds Method
ConceptualSurfaceType Class See Also Send Feedback
The element ids of the ConceptualConstructionType's associated with this ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetConstructionTypeIds()
Visual Basic
Public Function GetConstructionTypeIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetConstructionTypeIds()

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualSurfaceType Properties

[image] [image]

Revit 2013 API
ConceptualSurfaceType Properties
ConceptualSurfaceType Class See Also Send Feedback

The ConceptualSurfaceType type exposes the following members.

Properties

 | Name | Description
Public property | DefaultConstructionTypeId | The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.
Public property | MassSubCategoryId | The mass subcategory id of the ConceptualSurfaceType.

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


DefaultConstructionTypeId Property

[image]

Revit 2013 API
ConceptualSurfaceType..::..DefaultConstructionTypeId Property
ConceptualSurfaceType Class See Also Send Feedback
The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId DefaultConstructionTypeId { get; set; }
Visual Basic
Public Property DefaultConstructionTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DefaultConstructionTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element is not a constructionType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


MassSubCategoryId Property

[image]

Revit 2013 API
ConceptualSurfaceType..::..MassSubCategoryId Property
ConceptualSurfaceType Class See Also Send Feedback
The mass subcategory id of the ConceptualSurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MassSubCategoryId { get; }
Visual Basic
Public ReadOnly Property MassSubCategoryId As ElementId
    Get
Visual C++
public:
property ElementId^ MassSubCategoryId {
    ElementId^ get ();
}

See Also

ConceptualSurfaceType Class
Autodesk.Revit.DB.Analysis Namespace


ConstructionType Enumeration

[image]

Revit 2013 API
ConstructionType Enumeration
See Also Send Feedback
This enumeration specifies the available analytical construction types like external walls, windows etc. for use in the detailed analytical energy model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ConstructionType
Visual Basic
Public Enumeration ConstructionType
Visual C++
public enum class ConstructionType

Members

Member name | Description
ExteriorWall | An exterior wall surrounding the space
InteriorWall | An interior wall surrounding the space
Slab | A slab below the space
Roof | A roof over the space
Ceiling | A ceiling over the space
Floor | A floor below the space
Door | A door in a wall in the space
ExteriorWindow | A window in an exterior wall in the space
InteriorWindow | A window in an interior wall in the space
Skylight | A window in a roof in the space

See Also

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Class

[image]

Revit 2013 API
EnergyAnalysisDetailModel Class
Members Example See Also Send Feedback
Manage the analytical thermal model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisDetailModel : IDisposable
Visual Basic
Public Class EnergyAnalysisDetailModel _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisDetailModel : IDisposable

Remarks

The Export to gbXML and the Heating and Cooling Loads features produces an analytical thermal model from the physical model of a building. The analytical thermal model is composed of spaces, zones and planar surfaces that represent the actual volumetric elements of the building.

Examples

CopyC#
// Collect space and surface data from the building's analytical thermal model
EnergyAnalysisDetailModelOptions options = new EnergyAnalysisDetailModelOptions();
options.Tier = EnergyAnalysisDetailModelTier.Final; // include constructions, schedules, and non-graphical data in the computation of the energy analysis model

EnergyAnalysisDetailModel eadm = EnergyAnalysisDetailModel.Create(doc, options); // Create a new energy analysis detailed model from the physical model
IList<EnergyAnalysisSpace> spaces = eadm.GetAnalyticalSpaces();
StringBuilder builder = new StringBuilder();
builder.AppendLine("Spaces: " + spaces.Count);
foreach (EnergyAnalysisSpace space in spaces)
{
    builder.AppendLine("   >>> " + space.Name + " related to " + space.SpatialElementId);
    IList<EnergyAnalysisSurface> surfaces = space.GetAnalyticalSurfaces();
    builder.AppendLine("       has " + surfaces.Count + " surfaces.");
    foreach (EnergyAnalysisSurface surface in surfaces)
    {
        builder.AppendLine("            +++ Surface from " + surface.OriginatingElementDescription);
    }
}
TaskDialog.Show("EAM", builder.ToString());

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModel

See Also

EnergyAnalysisDetailModel Members
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Members

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModel Members
EnergyAnalysisDetailModel Class Methods Properties See Also Send Feedback

The EnergyAnalysisDetailModel type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new energy analysis detailed model.
 | Destroy | Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.
Public method | Dispose | Releases all resources used by the EnergyAnalysisDetailModel
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

Properties

 | Name | Description
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Methods

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModel Methods
EnergyAnalysisDetailModel Class See Also Send Feedback

The EnergyAnalysisDetailModel type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new energy analysis detailed model.
 | Destroy | Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalOpenings | The collection of analytical openings.
Public method | GetAnalyticalShadingSurfaces | The collection of analytical shading surfaces.
Public method | GetAnalyticalSpaces | The collection of analytical spaces.
Public method | GetAnalyticalSurfaces | The collection of analytical surfaces.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransformModel | Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


Create Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..Create Method
EnergyAnalysisDetailModel Class See Also Send Feedback
Creates a new energy analysis detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static EnergyAnalysisDetailModel Create(
    Document document,
    EnergyAnalysisDetailModelOptions options
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    options As EnergyAnalysisDetailModelOptions _
) As EnergyAnalysisDetailModel
Visual C++
public:
static EnergyAnalysisDetailModel^ Create(
    Document^ document,
    EnergyAnalysisDetailModelOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that contains the physical model of the building.
options
Type: Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModelOptions
The options to control the calculation rules.

Return Value

The created model instance.

Remarks

The generated energy model is always returned in world coordinates. The method TransformModel() transforms all surfaces in the model according to ground plane, shared coordinates and true north.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Throws if there are no valid spatial bounding elements, or no valid spatial elements in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to create the energy analysis detail model.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Throws if user aborted the energy analysis detail model creation.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


Destroy Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..Destroy Method
EnergyAnalysisDetailModel Class See Also Send Feedback
Delete the created analytical model and the analytical elements such as spaces, surfaces, and openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void Destroy(
    EnergyAnalysisDetailModel model
)
Visual Basic
Public Shared Sub Destroy ( _
    model As EnergyAnalysisDetailModel _
)
Visual C++
public:
static void Destroy(
    EnergyAnalysisDetailModel^ model
)

Parameters

model
Type: Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModel
The model will be destroyed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..Dispose Method
EnergyAnalysisDetailModel Class See Also Send Feedback
Releases all resources used by the EnergyAnalysisDetailModel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalOpenings Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..GetAnalyticalOpenings Method
EnergyAnalysisDetailModel Class See Also Send Feedback
The collection of analytical openings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisOpening> GetAnalyticalOpenings()
Visual Basic
Public Function GetAnalyticalOpenings As IList(Of EnergyAnalysisOpening)
Visual C++
public:
IList<EnergyAnalysisOpening^>^ GetAnalyticalOpenings()

Return Value

Returns the analytical openings after model calculation.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalShadingSurfaces Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..GetAnalyticalShadingSurfaces Method
EnergyAnalysisDetailModel Class See Also Send Feedback
The collection of analytical shading surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisSurface> GetAnalyticalShadingSurfaces()
Visual Basic
Public Function GetAnalyticalShadingSurfaces As IList(Of EnergyAnalysisSurface)
Visual C++
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalShadingSurfaces()

Return Value

Returns the analytical shading surfaces after model calculation.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalSpaces Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..GetAnalyticalSpaces Method
EnergyAnalysisDetailModel Class See Also Send Feedback
The collection of analytical spaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisSpace> GetAnalyticalSpaces()
Visual Basic
Public Function GetAnalyticalSpaces As IList(Of EnergyAnalysisSpace)
Visual C++
public:
IList<EnergyAnalysisSpace^>^ GetAnalyticalSpaces()

Return Value

Returns the analytical spaces after model calculation.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalSurfaces Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..GetAnalyticalSurfaces Method
EnergyAnalysisDetailModel Class See Also Send Feedback
The collection of analytical surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Visual Basic
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
Visual C++
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()

Return Value

Returns the analytical surfaces after model calculation.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


TransformModel Method

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..TransformModel Method
EnergyAnalysisDetailModel Class See Also Send Feedback
Transforms all surfaces in the model according to the document's active ground plane, shared coordinates and true north.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void TransformModel()
Visual Basic
Public Sub TransformModel
Visual C++
public:
void TransformModel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModel Properties

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModel Properties
EnergyAnalysisDetailModel Class See Also Send Feedback

The EnergyAnalysisDetailModel type exposes the following members.

Properties

 | Name | Description
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


ExportMullions Property

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..ExportMullions Property
EnergyAnalysisDetailModel Class See Also Send Feedback
Indicates if to specify the setting for exporting mullions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportMullions { get; }
Visual Basic
Public ReadOnly Property ExportMullions As Boolean
    Get
Visual C++
public:
property bool ExportMullions {
    bool get ();
}

Remarks

When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


IncludeShadingSurfaces Property

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..IncludeShadingSurfaces Property
EnergyAnalysisDetailModel Class See Also Send Feedback
Indicates if to set and get the setting for if shading surfaces should be included.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IncludeShadingSurfaces { get; }
Visual Basic
Public ReadOnly Property IncludeShadingSurfaces As Boolean
    Get
Visual C++
public:
property bool IncludeShadingSurfaces {
    bool get ();
}

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


SimplifyCurtainSystems Property

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..SimplifyCurtainSystems Property
EnergyAnalysisDetailModel Class See Also Send Feedback
Indicates if to specify the setting for simplified curtain systems.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SimplifyCurtainSystems { get; }
Visual Basic
Public ReadOnly Property SimplifyCurtainSystems As Boolean
    Get
Visual C++
public:
property bool SimplifyCurtainSystems {
    bool get ();
}

Remarks

Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


Tier Property

[image]

Revit 2013 API
EnergyAnalysisDetailModel..::..Tier Property
EnergyAnalysisDetailModel Class See Also Send Feedback
Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisDetailModelTier Tier { get; }
Visual Basic
Public ReadOnly Property Tier As EnergyAnalysisDetailModelTier
    Get
Visual C++
public:
property EnergyAnalysisDetailModelTier Tier {
    EnergyAnalysisDetailModelTier get ();
}

See Also

EnergyAnalysisDetailModel Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Class

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisDetailModelOptions : IDisposable
Visual Basic
Public Class EnergyAnalysisDetailModelOptions _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisDetailModelOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisDetailModelOptions

See Also

EnergyAnalysisDetailModelOptions Members
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Members

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModelOptions Members
EnergyAnalysisDetailModelOptions Class Constructors Methods Properties See Also Send Feedback

The EnergyAnalysisDetailModelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | EnergyAnalysisDetailModelOptions | Constructs default options for energy analysis detailed model creation.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisDetailModelOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Constructor

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions Constructor
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Constructs default options for energy analysis detailed model creation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisDetailModelOptions()
Visual Basic
Public Sub New
Visual C++
public:
EnergyAnalysisDetailModelOptions()

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Methods

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModelOptions Methods
EnergyAnalysisDetailModelOptions Class See Also Send Feedback

The EnergyAnalysisDetailModelOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions..::..Dispose Method
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Releases all resources used by the EnergyAnalysisDetailModelOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelOptions Properties

[image] [image]

Revit 2013 API
EnergyAnalysisDetailModelOptions Properties
EnergyAnalysisDetailModelOptions Class See Also Send Feedback

The EnergyAnalysisDetailModelOptions type exposes the following members.

Properties

 | Name | Description
Public property | ExportMullions | Indicates if to specify the setting for exporting mullions.
Public property | IncludeShadingSurfaces | Indicates if to set and get the setting for if shading surfaces should be included.
Public property | SimplifyCurtainSystems | Indicates if to specify the setting for simplified curtain systems.
Public property | Tier | Level of computation for energy analysis model.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


ExportMullions Property

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions..::..ExportMullions Property
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Indicates if to specify the setting for exporting mullions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportMullions { get; set; }
Visual Basic
Public Property ExportMullions As Boolean
    Get
    Set
Visual C++
public:
property bool ExportMullions {
    bool get ();
    void set (bool value);
}

Remarks

When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


IncludeShadingSurfaces Property

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions..::..IncludeShadingSurfaces Property
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Indicates if to set and get the setting for if shading surfaces should be included.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IncludeShadingSurfaces { get; set; }
Visual Basic
Public Property IncludeShadingSurfaces As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeShadingSurfaces {
    bool get ();
    void set (bool value);
}

Remarks

The default is to include the shading surfaces.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


SimplifyCurtainSystems Property

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions..::..SimplifyCurtainSystems Property
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Indicates if to specify the setting for simplified curtain systems.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SimplifyCurtainSystems { get; set; }
Visual Basic
Public Property SimplifyCurtainSystems As Boolean
    Get
    Set
Visual C++
public:
property bool SimplifyCurtainSystems {
    bool get ();
    void set (bool value);
}

Remarks

Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


Tier Property

[image]

Revit 2013 API
EnergyAnalysisDetailModelOptions..::..Tier Property
EnergyAnalysisDetailModelOptions Class See Also Send Feedback
Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisDetailModelTier Tier { get; set; }
Visual Basic
Public Property Tier As EnergyAnalysisDetailModelTier
    Get
    Set
Visual C++
public:
property EnergyAnalysisDetailModelTier Tier {
    EnergyAnalysisDetailModelTier get ();
    void set (EnergyAnalysisDetailModelTier value);
}

Remarks

The default value is EnergyAnalysisModelTier::Final.

See Also

EnergyAnalysisDetailModelOptions Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisDetailModelTier Enumeration

[image]

Revit 2013 API
EnergyAnalysisDetailModelTier Enumeration
See Also Send Feedback
Level of computation for energy analysis model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum EnergyAnalysisDetailModelTier
Visual Basic
Public Enumeration EnergyAnalysisDetailModelTier
Visual C++
public enum class EnergyAnalysisDetailModelTier

Members

Member name | Description
NotComputed | Not computed.
FirstLevelBoundaries | Spaces and zones, e.g. minimal need for display. This refers to the analytical spaces. The analytical spaces are produced from Rooms if you are using RAC, and from MEP Spaces if you are using RME.
SecondLevelBoundaries | Analytical surfaces.
Final | Constructions, schedules, non-graphical data.

See Also

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Class

[image]

Revit 2013 API
EnergyAnalysisOpening Class
Members See Also Send Feedback
Analytical opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisOpening : IDisposable
Visual Basic
Public Class EnergyAnalysisOpening _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisOpening : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisOpening

See Also

EnergyAnalysisOpening Members
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Members

[image] [image]

Revit 2013 API
EnergyAnalysisOpening Members
EnergyAnalysisOpening Class Methods Properties See Also Send Feedback

The EnergyAnalysisOpening type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisOpening
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the opening.
Public property | Name | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Methods

[image] [image]

Revit 2013 API
EnergyAnalysisOpening Methods
EnergyAnalysisOpening Class See Also Send Feedback

The EnergyAnalysisOpening type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurface | Gets the associative analytical parent surface element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Dispose Method
EnergyAnalysisOpening Class See Also Send Feedback
Releases all resources used by the EnergyAnalysisOpening

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalSurface Method

[image]

Revit 2013 API
EnergyAnalysisOpening..::..GetAnalyticalSurface Method
EnergyAnalysisOpening Class See Also Send Feedback
Gets the associative analytical parent surface element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisSurface GetAnalyticalSurface()
Visual Basic
Public Function GetAnalyticalSurface As EnergyAnalysisSurface
Visual C++
public:
EnergyAnalysisSurface^ GetAnalyticalSurface()

Return Value

The associative analytical parent surface element.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


GetPolyloop Method

[image]

Revit 2013 API
EnergyAnalysisOpening..::..GetPolyloop Method
EnergyAnalysisOpening Class See Also Send Feedback
Gets the planar polygon describing the opening geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Polyloop GetPolyloop()
Visual Basic
Public Function GetPolyloop As Polyloop
Visual C++
public:
Polyloop^ GetPolyloop()

Remarks

A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpening Properties

[image] [image]

Revit 2013 API
EnergyAnalysisOpening Properties
EnergyAnalysisOpening Class See Also Send Feedback

The EnergyAnalysisOpening type exposes the following members.

Properties

 | Name | Description
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the opening.
Public property | Name | The unique name identifier for the opening.
Public property | OpeningType | The analytical opening type.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | Type | The gbXML opening type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Corner Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Corner Property
EnergyAnalysisOpening Class See Also Send Feedback
The lower-left coordinate for the analytical rectangular geometry viewed from outside.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Corner { get; }
Visual Basic
Public ReadOnly Property Corner As XYZ
    Get
Visual C++
public:
property XYZ^ Corner {
    XYZ^ get ();
}

Remarks

A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Height Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Height Property
EnergyAnalysisOpening Class See Also Send Feedback
The height of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Id Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Id Property
EnergyAnalysisOpening Class See Also Send Feedback
The unique identifier for the opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This identification attribute is composed of the id for the parent surface, the prefix "op" and a sequential number, all separated by "-". A sample value would be "su-1-op-1".

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Name Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Name Property
EnergyAnalysisOpening Class See Also Send Feedback
The unique name identifier for the opening.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Surface and Opening elements get an Name element assigned according to the below described schema:

(Orientation)(Space#)[(Other space#)](Exposure)(Type)-(sequence number)[Opening Type+#]

Sample: N-101-102-E-W-O-77

  • N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation).
  • 101 = Space number.
  • 102 = Other space number.
  • E = Exposure - exterior/interior/underground [E/I/U].
  • W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it's letter W-Wall R-Roof C-Ceiling F-Floor S-Shade).
  • O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it's letter W-Window D-Door O-Opening).
  • 77 = sequence number.

Sample surface names:

  • N-101-E-W-84 North facing Exterior Wall #84 in space 101.
  • N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101.
  • E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102.
  • T-101-E-R-141 Top facing Exterior Roof #141 in space 101.
  • B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201.
  • X-73 Shade #73.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


OpeningType Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..OpeningType Property
EnergyAnalysisOpening Class See Also Send Feedback
The analytical opening type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisOpeningType OpeningType { get; }
Visual Basic
Public ReadOnly Property OpeningType As EnergyAnalysisOpeningType
    Get
Visual C++
public:
property EnergyAnalysisOpeningType OpeningType {
    EnergyAnalysisOpeningType get ();
}

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


OriginatingElementDescription Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..OriginatingElementDescription Property
EnergyAnalysisOpening Class See Also Send Feedback
The description for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string OriginatingElementDescription { get; }
Visual Basic
Public ReadOnly Property OriginatingElementDescription As String
    Get
Visual C++
public:
property String^ OriginatingElementDescription {
    String^ get ();
}

Remarks

Surface and Opening elements get an CADObjectId element assigned according to the below described schema, based on associative room bounding element:

(Family Name): (Family Type)[Element Id]

Sample: System Panel: System Panel [50566]

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


OriginatingElementId Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..OriginatingElementId Property
EnergyAnalysisOpening Class See Also Send Feedback
The element id for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinkElementId OriginatingElementId { get; }
Visual Basic
Public ReadOnly Property OriginatingElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ OriginatingElementId {
    LinkElementId^ get ();
}

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Type Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Type Property
EnergyAnalysisOpening Class See Also Send Feedback
The gbXML opening type attribute.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public gbXMLOpeningType Type { get; }
Visual Basic
Public ReadOnly Property Type As gbXMLOpeningType
    Get
Visual C++
public:
property gbXMLOpeningType Type {
    gbXMLOpeningType get ();
}

Remarks

The type of the opening is based on the family category for the opening and in what element it is contained in:
  • If it is a Window it will have a type of OperableWindow.
  • If it is a Door it will have a type of NonSlidingDoor.
  • If the opening is contained in a Roof it will have a type of FixedSkylight.
  • If it is a Curtain Wall Panel, the opening will default to a type of FixedWindow. If the material specified for the family, and the material transparency is less than 3%, the opening will be ignored as a solid panel.
An opening of the category Openings will have the type of Air.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


Width Property

[image]

Revit 2013 API
EnergyAnalysisOpening..::..Width Property
EnergyAnalysisOpening Class See Also Send Feedback
The width of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

Remarks

The product of width and height should be equal to the area of the polyloop for the opening. The width is adjusted to accomplish this.

See Also

EnergyAnalysisOpening Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisOpeningType Enumeration

[image]

Revit 2013 API
EnergyAnalysisOpeningType Enumeration
See Also Send Feedback
Energy analysis opening type.
Analytical opening types.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum EnergyAnalysisOpeningType
Visual Basic
Public Enumeration EnergyAnalysisOpeningType
Visual C++
public enum class EnergyAnalysisOpeningType

Members

Member name | Description
Door | Door.
Window | Window.
Skylight | Skylight.
Air | Air.

See Also

Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Class

[image]

Revit 2013 API
EnergyAnalysisSpace Class
Members See Also Send Feedback
Analytical space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisSpace : IDisposable
Visual Basic
Public Class EnergyAnalysisSpace _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisSpace : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisSpace

See Also

EnergyAnalysisSpace Members
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Members

[image] [image]

Revit 2013 API
EnergyAnalysisSpace Members
EnergyAnalysisSpace Class Methods Properties See Also Send Feedback

The EnergyAnalysisSpace type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisSpace
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticalVolume | The volume for this space.
Public property | Area | The area for this space.
Public property | ComposedName | The composed name for this space.
Public property | Description | The description.
Public property | InnerVolume | The analytical volume for this space.
Public property | Name | The name.
Public property | SpatialElementId | The id of spatial element associated with this space.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Methods

[image] [image]

Revit 2013 API
EnergyAnalysisSpace Methods
EnergyAnalysisSpace Class See Also Send Feedback

The EnergyAnalysisSpace type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalSurfaces | Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.
Public method | GetBoundary | Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.
Public method | GetClosedShell | Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyAnalysisSpace..::..Dispose Method
EnergyAnalysisSpace Class See Also Send Feedback
Releases all resources used by the EnergyAnalysisSpace

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalSurfaces Method

[image]

Revit 2013 API
EnergyAnalysisSpace..::..GetAnalyticalSurfaces Method
EnergyAnalysisSpace Class See Also Send Feedback
Provides a way to access the collection of analytical surfaces for a space. Geometry data defining an analytical space volume. Through an analytical surface you can connect a source element with each polygon in a space. The analytical surfaces defines an enclosed volume bounded by the center plane of walls and the top plane of roofs and floors.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisSurface> GetAnalyticalSurfaces()
Visual Basic
Public Function GetAnalyticalSurfaces As IList(Of EnergyAnalysisSurface)
Visual C++
public:
IList<EnergyAnalysisSurface^>^ GetAnalyticalSurfaces()

Return Value

the collection of analytical surfaces for a space.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


GetBoundary Method

[image]

Revit 2013 API
EnergyAnalysisSpace..::..GetBoundary Method
EnergyAnalysisSpace Class See Also Send Feedback
Gets the collection of polygons that form the 2D boundary. This method returns a collection of polyloops (planar polygons) that defines an enclosed area measured by interior bounding surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Polyloop> GetBoundary()
Visual Basic
Public Function GetBoundary As IList(Of Polyloop)
Visual C++
public:
IList<Polyloop^>^ GetBoundary()

Return Value

The collection of polygons that form the 2D boundary.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


GetClosedShell Method

[image]

Revit 2013 API
EnergyAnalysisSpace..::..GetClosedShell Method
EnergyAnalysisSpace Class See Also Send Feedback
Gets the collection of polygons that form a closed shell. This method returns a collection of polyloops (planar polygons) that defines an enclosed volume measured by interior bounding surfaces.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Polyloop> GetClosedShell()
Visual Basic
Public Function GetClosedShell As IList(Of Polyloop)
Visual C++
public:
IList<Polyloop^>^ GetClosedShell()

Return Value

the collection of polygons that form a closed shell.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSpace Properties

[image] [image]

Revit 2013 API
EnergyAnalysisSpace Properties
EnergyAnalysisSpace Class See Also Send Feedback

The EnergyAnalysisSpace type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticalVolume | The volume for this space.
Public property | Area | The area for this space.
Public property | ComposedName | The composed name for this space.
Public property | Description | The description.
Public property | InnerVolume | The analytical volume for this space.
Public property | Name | The name.
Public property | SpatialElementId | The id of spatial element associated with this space.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


AnalyticalVolume Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..AnalyticalVolume Property
EnergyAnalysisSpace Class See Also Send Feedback
The volume for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double AnalyticalVolume { get; }
Visual Basic
Public ReadOnly Property AnalyticalVolume As Double
    Get
Visual C++
public:
property double AnalyticalVolume {
    double get ();
}

Remarks

The analytical space volume is bounded by the center plane of walls and the top plane of roofs and floors.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


Area Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..Area Property
EnergyAnalysisSpace Class See Also Send Feedback
The area for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This value is the enclosed area measured by interior bounding surfaces.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


ComposedName Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..ComposedName Property
EnergyAnalysisSpace Class See Also Send Feedback
The composed name for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string ComposedName { get; }
Visual Basic
Public ReadOnly Property ComposedName As String
    Get
Visual C++
public:
property String^ ComposedName {
    String^ get ();
}

Remarks

This value is composed of the name and description attributes, separated by a space.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


Description Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..Description Property
EnergyAnalysisSpace Class See Also Send Feedback
The description.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


InnerVolume Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..InnerVolume Property
EnergyAnalysisSpace Class See Also Send Feedback
The analytical volume for this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double InnerVolume { get; }
Visual Basic
Public ReadOnly Property InnerVolume As Double
    Get
Visual C++
public:
property double InnerVolume {
    double get ();
}

Remarks

The inner space volume is bounded by the interior surfaces.

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


Name Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..Name Property
EnergyAnalysisSpace Class See Also Send Feedback
The name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


SpatialElementId Property

[image]

Revit 2013 API
EnergyAnalysisSpace..::..SpatialElementId Property
EnergyAnalysisSpace Class See Also Send Feedback
The id of spatial element associated with this space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId SpatialElementId { get; }
Visual Basic
Public ReadOnly Property SpatialElementId As ElementId
    Get
Visual C++
public:
property ElementId^ SpatialElementId {
    ElementId^ get ();
}

See Also

EnergyAnalysisSpace Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Class

[image]

Revit 2013 API
EnergyAnalysisSurface Class
Members See Also Send Feedback
Analytical surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class EnergyAnalysisSurface : IDisposable
Visual Basic
Public Class EnergyAnalysisSurface _
    Implements IDisposable
Visual C++
public ref class EnergyAnalysisSurface : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyAnalysisSurface

See Also

EnergyAnalysisSurface Members
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Members

[image] [image]

Revit 2013 API
EnergyAnalysisSurface Members
EnergyAnalysisSurface Class Methods Properties See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the EnergyAnalysisSurface
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Azimuth | The azimuth angle for this surface.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the surface.
Public property | Name | The unique name identifier for this surface.
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Methods

[image] [image]

Revit 2013 API
EnergyAnalysisSurface Methods
EnergyAnalysisSurface Class See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAdjacentAnalyticalSpace | Gets the secondary adjacent analytical space this surface is associated with.
Public method | GetAnalyticalOpenings | Returns the analytical openings of the analytical surface.
Public method | GetAnalyticalSpace | Gets the primary analytical space this surface is associated with.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPolyloop | Gets the planar polygon describing the opening geometry.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Dispose Method
EnergyAnalysisSurface Class See Also Send Feedback
Releases all resources used by the EnergyAnalysisSurface

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


GetAdjacentAnalyticalSpace Method

[image]

Revit 2013 API
EnergyAnalysisSurface..::..GetAdjacentAnalyticalSpace Method
EnergyAnalysisSurface Class See Also Send Feedback
Gets the secondary adjacent analytical space this surface is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisSpace GetAdjacentAnalyticalSpace()
Visual Basic
Public Function GetAdjacentAnalyticalSpace As EnergyAnalysisSpace
Visual C++
public:
EnergyAnalysisSpace^ GetAdjacentAnalyticalSpace()

Return Value

The secondary analytical space.

Remarks

An exterior surface will only have one space adjacency.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalOpenings Method

[image]

Revit 2013 API
EnergyAnalysisSurface..::..GetAnalyticalOpenings Method
EnergyAnalysisSurface Class See Also Send Feedback
Returns the analytical openings of the analytical surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<EnergyAnalysisOpening> GetAnalyticalOpenings()
Visual Basic
Public Function GetAnalyticalOpenings As IList(Of EnergyAnalysisOpening)
Visual C++
public:
IList<EnergyAnalysisOpening^>^ GetAnalyticalOpenings()

Return Value

The collection of analytical openings.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


GetAnalyticalSpace Method

[image]

Revit 2013 API
EnergyAnalysisSurface..::..GetAnalyticalSpace Method
EnergyAnalysisSurface Class See Also Send Feedback
Gets the primary analytical space this surface is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisSpace GetAnalyticalSpace()
Visual Basic
Public Function GetAnalyticalSpace As EnergyAnalysisSpace
Visual C++
public:
EnergyAnalysisSpace^ GetAnalyticalSpace()

Return Value

The primary analytical space.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


GetPolyloop Method

[image]

Revit 2013 API
EnergyAnalysisSurface..::..GetPolyloop Method
EnergyAnalysisSurface Class See Also Send Feedback
Gets the planar polygon describing the opening geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Polyloop GetPolyloop()
Visual Basic
Public Function GetPolyloop As Polyloop
Visual C++
public:
Polyloop^ GetPolyloop()

Return Value

The planar polygon describing the opening geometry.

Remarks

A planar polygon describing the surface geometry as described in gbXML. The geometry is currently measured per analytical(center-line).

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurface Properties

[image] [image]

Revit 2013 API
EnergyAnalysisSurface Properties
EnergyAnalysisSurface Class See Also Send Feedback

The EnergyAnalysisSurface type exposes the following members.

Properties

 | Name | Description
Public property | Azimuth | The azimuth angle for this surface.
Public property | Corner | The lower-left coordinate for the analytical rectangular geometry viewed from outside.
Public property | Height | The height of the analytical rectangular geometry.
Public property | Id | The unique identifier for the surface.
Public property | Name | The unique name identifier for this surface.
Public property | Normal | The outward normal for this surface.
Public property | OriginatingElementDescription | The description for the originating Revit element.
Public property | OriginatingElementId | The element id for the originating Revit element.
Public property | SurfaceType | The analytical surface type.
Public property | Tilt | The tilt angle for this surface.
Public property | Type | The gbXML surface type attribute.
Public property | Width | The width of the analytical rectangular geometry.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Azimuth Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Azimuth Property
EnergyAnalysisSurface Class See Also Send Feedback
The azimuth angle for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Azimuth { get; }
Visual Basic
Public ReadOnly Property Azimuth As Double
    Get
Visual C++
public:
property double Azimuth {
    double get ();
}

Remarks

The azimuth is computed as the angle of rotation between the outward normal of the surface and the Y-axis (clockwise is positive).

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Corner Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Corner Property
EnergyAnalysisSurface Class See Also Send Feedback
The lower-left coordinate for the analytical rectangular geometry viewed from outside.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Corner { get; }
Visual Basic
Public ReadOnly Property Corner As XYZ
    Get
Visual C++
public:
property XYZ^ Corner {
    XYZ^ get ();
}

Remarks

The analytical rectangular geometry is typically used in simulation engines.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Height Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Height Property
EnergyAnalysisSurface Class See Also Send Feedback
The height of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Id Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Id Property
EnergyAnalysisSurface Class See Also Send Feedback
The unique identifier for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Id { get; }
Visual Basic
Public ReadOnly Property Id As String
    Get
Visual C++
public:
property String^ Id {
    String^ get ();
}

Remarks

This identification attribute is composed of the prefix "su" and a sequential number, separated by "-". A sample value would be "su-1".

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Name Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Name Property
EnergyAnalysisSurface Class See Also Send Feedback
The unique name identifier for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

Remarks

Surface and Opening elements get an Name element assigned according to the below described schema:

(Orientation)(Space#)[(Other space#)](Exposure)(Type)-(sequence number)[Opening Type+#]

Sample: N-101-102-E-W-O-77

  • N = Orientation [N/NE/E/SE/S/SW/W/NW/N/T/B/X] (every surface within the sector of 22.5 degrees from the north vector gets the letter N etc) (horizontal surfaces facing upwards get the letter T for top, downwards B for bottom) (shading surfaces get the letter X for differentiation).
  • 101 = Space number.
  • 102 = Other space number.
  • E = Exposure - exterior/interior/underground [E/I/U].
  • W = Type [W/C/R/F] (Wall, Roof, Ceiling, Floor, Shade) (every surface type has it's letter W-Wall R-Roof C-Ceiling F-Floor S-Shade).
  • O = Opening Type [W/D/O] (Window, Door, Opening) (every opening type has it's letter W-Window D-Door O-Opening).
  • 77 = sequence number.

Sample surface names:

  • N-101-E-W-84 North facing Exterior Wall #84 in space 101.
  • N-101-E-W-84-D-1 Door #1 in North facing Exterior Wall #84 in space 101.
  • E-101-102-I-W-92 Vertical Interior Wall #92 between space 101 and 102.
  • T-101-E-R-141 Top facing Exterior Roof #141 in space 101.
  • B-101-201-I-F-88 Bottom facing Interior Floor #88 between space 101 and 201.
  • X-73 Shade #73.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Normal Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Normal Property
EnergyAnalysisSurface Class See Also Send Feedback
The outward normal for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


OriginatingElementDescription Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..OriginatingElementDescription Property
EnergyAnalysisSurface Class See Also Send Feedback
The description for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string OriginatingElementDescription { get; }
Visual Basic
Public ReadOnly Property OriginatingElementDescription As String
    Get
Visual C++
public:
property String^ OriginatingElementDescription {
    String^ get ();
}

Remarks

Surface and Opening elements get an originating element assigned according to the below described schema, based on associative room bounding element:

(Family Name): (Family Type)[Element Id]

Sample: Basic Wall: Cast Concrete Wall 12" [49749]

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


OriginatingElementId Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..OriginatingElementId Property
EnergyAnalysisSurface Class See Also Send Feedback
The element id for the originating Revit element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public LinkElementId OriginatingElementId { get; }
Visual Basic
Public ReadOnly Property OriginatingElementId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ OriginatingElementId {
    LinkElementId^ get ();
}

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


SurfaceType Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..SurfaceType Property
EnergyAnalysisSurface Class See Also Send Feedback
The analytical surface type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public EnergyAnalysisSurfaceType SurfaceType { get; }
Visual Basic
Public ReadOnly Property SurfaceType As EnergyAnalysisSurfaceType
    Get
Visual C++
public:
property EnergyAnalysisSurfaceType SurfaceType {
    EnergyAnalysisSurfaceType get ();
}

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Tilt Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Tilt Property
EnergyAnalysisSurface Class See Also Send Feedback
The tilt angle for this surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Tilt { get; }
Visual Basic
Public ReadOnly Property Tilt As Double
    Get
Visual C++
public:
property double Tilt {
    double get ();
}

Remarks

The tilt is computed as the angle of rotation between the outward normal of the surface and the Z-axis.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Type Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Type Property
EnergyAnalysisSurface Class See Also Send Feedback
The gbXML surface type attribute.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public gbXMLSurfaceType Type { get; }
Visual Basic
Public ReadOnly Property Type As gbXMLSurfaceType
    Get
Visual C++
public:
property gbXMLSurfaceType Type {
    gbXMLSurfaceType get ();
}

Remarks

The type of surface is figured out depending on the source element and the number of space adjacencies.
  • If there is no associate source element and no space adjacencies, it will have a type of Shade. If there are any space adjacencies, it will have a type of Air.
  • If the source element is a Wall or a Curtain Wall and have one space adjacency, it will have a type of ExteriorWall.
  • If the source element is a Wall or a Curtain Wall and have two space adjacencies, it will have a type of InteriorWall.
  • If the source element is a Wall or a Curtain Wall and the type Function parameter is set to "Interior" or "CoreShaft", it will have a type of InteriorWall.
  • If the source element is a Wall or a Curtain Wall and have one space adjacency and if it is below grade, it will have a type of UndergroundWall.
  • If the source element is a Floor and have one space adjacency, it will have a type of SlabOnGrade. If the source element is above grade, it will have a type of RaisedFloor. If the source element is below grade, it will have a type of UndergroundSlab.
  • If the source element is a Floor and have two space adjacencies, it will have a type of InteriorFloor.
  • If the source element is a Floor and the type Function parameter is set to "Interior", it will have a type of InteriorFloor.
  • If the source element is a Roof or a Ceiling and have one space adjacency, it will have a type of Roof.
  • If the source element is a Roof or a Ceiling and have one space adjacency and is below grade, it will have a type of UndergroundCeiling.
  • If the source element is a Roof or a Ceiling and have two space adjacencies, it will have a type of Ceiling.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


Width Property

[image]

Revit 2013 API
EnergyAnalysisSurface..::..Width Property
EnergyAnalysisSurface Class See Also Send Feedback
The width of the analytical rectangular geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Width { get; }
Visual Basic
Public ReadOnly Property Width As Double
    Get
Visual C++
public:
property double Width {
    double get ();
}

Remarks

The product of width and height should be equal to the area of the polyloop for the opening. The width is adjusted to accomplish this.

See Also

EnergyAnalysisSurface Class
Autodesk.Revit.DB.Analysis Namespace


EnergyAnalysisSurfaceType Enumeration

[image]

Revit 2013 API
EnergyAnalysisSurfaceType Enumeration
See Also Send Feedback
Analytical surface types.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum EnergyAnalysisSurfaceType
Visual Basic
Public Enumeration EnergyAnalysisSurfaceType
Visual C++
public enum class EnergyAnalysisSurfaceType

Members

Member name | Description
Roof | Roof.
ExteriorWall | Exterior wall.
InteriorWall | Interior wall.
Ceiling | Ceiling.
InteriorFloor | Interior floor.
ExteriorFloor | Exterior floor.
Shading | Shading.
Air | Air.
Underground | Underground.

See Also

Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Class

[image]

Revit 2013 API
EnergyDataSettings Class
Members Example See Also Send Feedback
This element contains settings for gbXML Export and Heating and Cooling Load Calculations and project level settings for Conceptual Energy Analysis. for serialization

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class EnergyDataSettings : IDisposable
Visual Basic
Public Class EnergyDataSettings _
    Implements IDisposable
Visual C++
public ref class EnergyDataSettings : IDisposable

Examples

CopyC#
public void GetInfo_EnergyData(Document document)
{
   EnergyDataSettings energyData = EnergyDataSettings.GetFromDocument(document);

   if (null != energyData)
    {
        string message = "energyData : ";
        message += "\nBuildingType : " + energyData.BuildingType;
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_EnergyData(ByVal document As Document)
    Dim energyData As Autodesk.Revit.DB.Analysis.EnergyDataSettings = Autodesk.Revit.DB.Analysis.EnergyDataSettings.GetFromDocument(document)

    If energyData IsNot Nothing Then
        Dim message As String = "energyData : "
        message += vbLf & "BuildingType : " + energyData.BuildingType
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..EnergyDataSettings

See Also

EnergyDataSettings Members
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Members

[image] [image]

Revit 2013 API
EnergyDataSettings Members
EnergyDataSettings Class Methods Properties See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Methods

Name Description
CheckBuildingConstructionClass
Checks that the building construction class falls within an appropriate range.
CheckBuildingHVACSystem
Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule
Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType
Checks that the building type falls within an appropriate range.
Public method CheckConstructionSetElement
Checks that the construction set ElementId is acceptable.
CheckExportCategory
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
CheckExportComplexity
Checks that the export complexity falls within an appropriate range.
Public method CheckGroundPlane(ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public method CheckProjectPhase
Checks that the input element is a project phase.
CheckProjectReportType
Checks that the project report type falls within an appropriate range.
CheckRangeOfMassZoneCoreOffset
Checks that the mass zone core offset is greater than or equal to zero.
CheckRangeOfPercentageGlazing
Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights
Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth
Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight
Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth
Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance
Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType
Checks that the service type falls within an appropriate range.
Public method Dispose
Releases all resources used by the EnergyDataSettings
EnableConceptualEnergyAnalyticalModel
Turns on functionality related to conceptual energy analysis.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetBuildingConstructionSetElementId
Id of the building construction set.
GetFromDocument
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDocumentUsingEnergyDataAnalyticalModel
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public method SetCreateAnalyticalModel
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

Properties

 | Name | Description
Public property | BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public property | BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
Public property | BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
Public property | BuildingType | The type of building.
Public property | CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public property | EnergyModel | if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public property | ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public property | ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
Public property | ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
Public property | GroundPlane | Id of level which represents ground level.
Public property | IncludeThermalProperties | Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public property | IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public property | IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public property | IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public property | IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public property | MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
Public property | MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
Public property | OutsideAirChangesRatePerHour |
Public property | OutsideAirPerArea |
Public property | OutsideAirPerPerson |
Public property | PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public property | PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public property | ProjectPhase | The project phase of the EnergyData information.
Public property | ProjectReportType | Report type: None, simple, standard, detailed
Public property | ServiceType | The type of heating or cooling system.
Public property | ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public property | SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public property | SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public property | SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
Public property | UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
Public property | UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public property | UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
Public property | UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Methods

[image] [image]

Revit 2013 API
EnergyDataSettings Methods
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Methods

Name | Description
CheckBuildingConstructionClass
Checks that the building construction class falls within an appropriate range.
CheckBuildingHVACSystem
Checks that the building HVAC system falls within an appropriate range.
CheckBuildingOperatingSchedule
Checks that the building operating schedule falls within an appropriate range.
CheckBuildingType
Checks that the building type falls within an appropriate range.
Public method CheckConstructionSetElement
Checks that the construction set ElementId is acceptable.
CheckExportCategory
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces
CheckExportComplexity
Checks that the export complexity falls within an appropriate range.
Public method CheckGroundPlane(ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
CheckGroundPlane(Document, ElementId)
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Public method CheckProjectPhase
Checks that the input element is a project phase.
CheckProjectReportType
Checks that the project report type falls within an appropriate range.
CheckRangeOfMassZoneCoreOffset
Checks that the mass zone core offset is greater than or equal to zero.
CheckRangeOfPercentageGlazing
Checks that the percentage glazing value is between 0.00 and 0.95.
CheckRangeOfPercentageSkylights
Checks that the percentage skylights value is between 0.00 and 0.95.
CheckRangeOfShadeDepth
Checks that the shade depth is greater than or equal to zero.
CheckRangeOfSillHeight
Checks that the sill height is greater than or equal to zero.
CheckRangeOfSkylightWidth
Checks that the skylight width is greater than or equal to eight inches.
CheckRangeOfSliverSpaceTolerance
Checks that the sliver space tolerance is greater than or equal to zero.
CheckServiceType
Checks that the service type falls within an appropriate range.
Public method | Dispose
EnableConceptualEnergyAnalyticalModel
Turns on functionality related to conceptual energy analysis.
Public method Equals
Determines whether the specified Object is equal to the current Object.
(Inherited from Object.)
GetBuildingConstructionSetElementId
Id of the building construction set.
GetFromDocument
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.
Public method GetHashCode
Serves as a hash function for a particular type.
(Inherited from Object.)
Public method GetType
Gets the Type of the current instance.
(Inherited from Object.)
IsDocumentUsingEnergyDataAnalyticalModel
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.
Public method SetCreateAnalyticalModel
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public method ToString
Returns a String that represents the current Object.
(Inherited from Object.)

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingConstructionClass Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckBuildingConstructionClass Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building construction class falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)
Visual Basic
Public Shared Function CheckBuildingConstructionClass ( _
    buildingConstructionClass As HVACLoadConstructionClass _
) As Boolean
Visual C++
public:
static bool CheckBuildingConstructionClass(
    HVACLoadConstructionClass buildingConstructionClass
)

Parameters

buildingConstructionClass
Type: Autodesk.Revit.DB.Analysis..::..HVACLoadConstructionClass
The building construction class to be checked.

Return Value

True if the building construction class falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingHVACSystem Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckBuildingHVACSystem Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building HVAC system falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)
Visual Basic
Public Shared Function CheckBuildingHVACSystem ( _
    buildingHVACSystem As gbXMLBuildingHVACSystem _
) As Boolean
Visual C++
public:
static bool CheckBuildingHVACSystem(
    gbXMLBuildingHVACSystem buildingHVACSystem
)

Parameters

buildingHVACSystem
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingHVACSystem
The building HVAC system to be checked.

Return Value

True if the building HVAC system falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingOperatingSchedule Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckBuildingOperatingSchedule Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building operating schedule falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)
Visual Basic
Public Shared Function CheckBuildingOperatingSchedule ( _
    buildingOperatingSchedule As gbXMLBuildingOperatingSchedule _
) As Boolean
Visual C++
public:
static bool CheckBuildingOperatingSchedule(
    gbXMLBuildingOperatingSchedule buildingOperatingSchedule
)

Parameters

buildingOperatingSchedule
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingOperatingSchedule
The building operating schedule to be checked.

Return Value

True if the building operating schedule falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckBuildingType Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckBuildingType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the building type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)
Visual Basic
Public Shared Function CheckBuildingType ( _
    buildingType As gbXMLBuildingType _
) As Boolean
Visual C++
public:
static bool CheckBuildingType(
    gbXMLBuildingType buildingType
)

Parameters

buildingType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLBuildingType
The building type to be checked.

Return Value

True if the building type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckConstructionSetElement Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckConstructionSetElement Method
EnergyDataSettings Class See Also Send Feedback
Checks that the construction set ElementId is acceptable.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CheckConstructionSetElement(
    ElementId constructionSetElementId
)
Visual Basic
Public Function CheckConstructionSetElement ( _
    constructionSetElementId As ElementId _
) As Boolean
Visual C++
public:
bool CheckConstructionSetElement(
    ElementId^ constructionSetElementId
)

Parameters

constructionSetElementId
Type: Autodesk.Revit.DB..::..ElementId
The construction set ElementId to be checked.

Return Value

True if the construction set ElementId is a valid construction set element, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckExportCategory Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckExportCategory Method
EnergyDataSettings Class See Also Send Feedback
Checks whether the export category falls within the list:
  1. OST_Rooms
  2. OST_MEPSpaces

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckExportCategory(
    ElementId exportCategoryId
)
Visual Basic
Public Shared Function CheckExportCategory ( _
    exportCategoryId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckExportCategory(
    ElementId^ exportCategoryId
)

Parameters

exportCategoryId
Type: Autodesk.Revit.DB..::..ElementId
The export category to be checked.

Return Value

True if the export category falls within the list, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckExportComplexity Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckExportComplexity Method
EnergyDataSettings Class See Also Send Feedback
Checks that the export complexity falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)
Visual Basic
Public Shared Function CheckExportComplexity ( _
    exportComplexity As gbXMLExportComplexity _
) As Boolean
Visual C++
public:
static bool CheckExportComplexity(
    gbXMLExportComplexity exportComplexity
)

Parameters

exportComplexity
Type: Autodesk.Revit.DB.Analysis..::..gbXMLExportComplexity
The export complexity to be checked.

Return Value

True if the export complexity falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method

[image] [image]

Revit 2013 API
EnergyDataSettings..::..CheckGroundPlane Method
EnergyDataSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CheckGroundPlane(ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
 | CheckGroundPlane(Document, ElementId) | The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

See Also

EnergyDataSettings Class
EnergyDataSettings Members
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method (ElementId)

[image]

Revit 2013 API
EnergyDataSettings..::..CheckGroundPlane Method (ElementId)
EnergyDataSettings Class See Also Send Feedback
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CheckGroundPlane(
    ElementId groundPlaneId
)
Visual Basic
Public Function CheckGroundPlane ( _
    groundPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool CheckGroundPlane(
    ElementId^ groundPlaneId
)

Parameters

groundPlaneId
Type: Autodesk.Revit.DB..::..ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

True if the input element is a level or invalidElementId, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


CheckGroundPlane Method (Document, ElementId)

[image]

Revit 2013 API
EnergyDataSettings..::..CheckGroundPlane Method (Document, ElementId)
EnergyDataSettings Class See Also Send Feedback
The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckGroundPlane(
    Document ccda,
    ElementId groundPlaneId
)
Visual Basic
Public Shared Function CheckGroundPlane ( _
    ccda As Document, _
    groundPlaneId As ElementId _
) As Boolean
Visual C++
public:
static bool CheckGroundPlane(
    Document^ ccda,
    ElementId^ groundPlaneId
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The Document.
groundPlaneId
Type: Autodesk.Revit.DB..::..ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".

Return Value

True if the input element is a level or invalidElementId, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
CheckGroundPlane Overload
Autodesk.Revit.DB.Analysis Namespace


CheckProjectPhase Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckProjectPhase Method
EnergyDataSettings Class See Also Send Feedback
Checks that the input element is a project phase.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CheckProjectPhase(
    ElementId projectPhaseId
)
Visual Basic
Public Function CheckProjectPhase ( _
    projectPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool CheckProjectPhase(
    ElementId^ projectPhaseId
)

Parameters

projectPhaseId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked.

Return Value

True if the input element is a project phase, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckProjectReportType Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckProjectReportType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the project report type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)
Visual Basic
Public Shared Function CheckProjectReportType ( _
    projectReportType As HVACLoadLoadsReportType _
) As Boolean
Visual C++
public:
static bool CheckProjectReportType(
    HVACLoadLoadsReportType projectReportType
)

Parameters

projectReportType
Type: Autodesk.Revit.DB.Analysis..::..HVACLoadLoadsReportType
The project report type to be checked.

Return Value

True if the project report type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfMassZoneCoreOffset Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfMassZoneCoreOffset Method
EnergyDataSettings Class See Also Send Feedback
Checks that the mass zone core offset is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfMassZoneCoreOffset(
    double massZoneCoreOffset
)
Visual Basic
Public Shared Function CheckRangeOfMassZoneCoreOffset ( _
    massZoneCoreOffset As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfMassZoneCoreOffset(
    double massZoneCoreOffset
)

Parameters

massZoneCoreOffset
Type: System..::..Double
The mass zone core offset to be checked. Should be greater than or equal to zero.

Return Value

True if the mass zone core offset is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfPercentageGlazing Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfPercentageGlazing Method
EnergyDataSettings Class See Also Send Feedback
Checks that the percentage glazing value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)
Visual Basic
Public Shared Function CheckRangeOfPercentageGlazing ( _
    percentageGlazing As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfPercentageGlazing(
    double percentageGlazing
)

Parameters

percentageGlazing
Type: System..::..Double
The percentage glazing to be checked.

Return Value

True if the percentage glazing value is between 0.00 and 0.95, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfPercentageSkylights Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfPercentageSkylights Method
EnergyDataSettings Class See Also Send Feedback
Checks that the percentage skylights value is between 0.00 and 0.95.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)
Visual Basic
Public Shared Function CheckRangeOfPercentageSkylights ( _
    percentageSkylights As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfPercentageSkylights(
    double percentageSkylights
)

Parameters

percentageSkylights
Type: System..::..Double
The percentage skylights to be checked.

Return Value

True if the percentage skylights value is between 0.00 and 0.95, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfShadeDepth Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfShadeDepth Method
EnergyDataSettings Class See Also Send Feedback
Checks that the shade depth is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfShadeDepth(
    double shadeDepth
)
Visual Basic
Public Shared Function CheckRangeOfShadeDepth ( _
    shadeDepth As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfShadeDepth(
    double shadeDepth
)

Parameters

shadeDepth
Type: System..::..Double
The shade depth to be checked.

Return Value

True if the shade depth is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSillHeight Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfSillHeight Method
EnergyDataSettings Class See Also Send Feedback
Checks that the sill height is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSillHeight(
    double sillHeight
)
Visual Basic
Public Shared Function CheckRangeOfSillHeight ( _
    sillHeight As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSillHeight(
    double sillHeight
)

Parameters

sillHeight
Type: System..::..Double
The sill height to be checked.

Return Value

True if the sill height falls is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSkylightWidth Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfSkylightWidth Method
EnergyDataSettings Class See Also Send Feedback
Checks that the skylight width is greater than or equal to eight inches.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)
Visual Basic
Public Shared Function CheckRangeOfSkylightWidth ( _
    skylightWidth As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSkylightWidth(
    double skylightWidth
)

Parameters

skylightWidth
Type: System..::..Double
The skylight width to be checked. Should be greater than or equal to eight inches.

Return Value

True if the skylight width is greater than or equal to eight inches, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckRangeOfSliverSpaceTolerance Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckRangeOfSliverSpaceTolerance Method
EnergyDataSettings Class See Also Send Feedback
Checks that the sliver space tolerance is greater than or equal to zero.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)
Visual Basic
Public Shared Function CheckRangeOfSliverSpaceTolerance ( _
    silverSpaceTolerance As Double _
) As Boolean
Visual C++
public:
static bool CheckRangeOfSliverSpaceTolerance(
    double silverSpaceTolerance
)

Parameters

silverSpaceTolerance
Type: System..::..Double
The sliver space tolerance to be checked.

Return Value

Returns true if the sliver space tolerance is greater than or equal to zero, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CheckServiceType Method

[image]

Revit 2013 API
EnergyDataSettings..::..CheckServiceType Method
EnergyDataSettings Class See Also Send Feedback
Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool CheckServiceType(
    gbXMLServiceType serviceType
)
Visual Basic
Public Shared Function CheckServiceType ( _
    serviceType As gbXMLServiceType _
) As Boolean
Visual C++
public:
static bool CheckServiceType(
    gbXMLServiceType serviceType
)

Parameters

serviceType
Type: Autodesk.Revit.DB.Analysis..::..gbXMLServiceType
The service type to be checked.

Return Value

True if the service type falls within an appropriate range, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
EnergyDataSettings..::..Dispose Method
EnergyDataSettings Class See Also Send Feedback
Releases all resources used by the EnergyDataSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnableConceptualEnergyAnalyticalModel Method

[image]

Revit 2013 API
EnergyDataSettings..::..EnableConceptualEnergyAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
Turns on functionality related to conceptual energy analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool EnableConceptualEnergyAnalyticalModel()
Visual Basic
Public Shared Function EnableConceptualEnergyAnalyticalModel As Boolean
Visual C++
public:
static bool EnableConceptualEnergyAnalyticalModel()

Return Value

Returns true if the Conceptual Energy Analytical model is turned on, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetBuildingConstructionSetElementId Method

[image]

Revit 2013 API
EnergyDataSettings..::..GetBuildingConstructionSetElementId Method
EnergyDataSettings Class See Also Send Feedback
Id of the building construction set.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElementId GetBuildingConstructionSetElementId(
    Document ccda
)
Visual Basic
Public Shared Function GetBuildingConstructionSetElementId ( _
    ccda As Document _
) As ElementId
Visual C++
public:
static ElementId^ GetBuildingConstructionSetElementId(
    Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document

Return Value

Returns the id of the building construction set.

Remarks

The building construction set is the default project construction set used when spaces are not assigned a construction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GetFromDocument Method

[image]

Revit 2013 API
EnergyDataSettings..::..GetFromDocument Method
EnergyDataSettings Class See Also Send Feedback
Every project document has a EnergyDataSettings element. Family documents do not have EnergyDataSettings elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static EnergyDataSettings GetFromDocument(
    Document cda
)
Visual Basic
Public Shared Function GetFromDocument ( _
    cda As Document _
) As EnergyDataSettings
Visual C++
public:
static EnergyDataSettings^ GetFromDocument(
    Document^ cda
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

Returns the EnergyDataSettings element or NULL.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsDocumentUsingEnergyDataAnalyticalModel Method

[image]

Revit 2013 API
EnergyDataSettings..::..IsDocumentUsingEnergyDataAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
Get EnergyDataSettings element and if it exists, return result from getCreateAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document ccda
)
Visual Basic
Public Shared Function IsDocumentUsingEnergyDataAnalyticalModel ( _
    ccda As Document _
) As Boolean
Visual C++
public:
static bool IsDocumentUsingEnergyDataAnalyticalModel(
    Document^ ccda
)

Parameters

ccda
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

Returns true if the Conceptual Energy Analytical Model is enabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SetCreateAnalyticalModel Method

[image]

Revit 2013 API
EnergyDataSettings..::..SetCreateAnalyticalModel Method
EnergyDataSettings Class See Also Send Feedback
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)
Visual Basic
Public Sub SetCreateAnalyticalModel ( _
    createAnalyticalModel As Boolean _
)
Visual C++
public:
void SetCreateAnalyticalModel(
    bool createAnalyticalModel
)

Parameters

createAnalyticalModel
Type: System..::..Boolean
True to enable the Energy Analytical Model otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyDataSettings Properties

[image] [image]

Revit 2013 API
EnergyDataSettings Properties
EnergyDataSettings Class See Also Send Feedback

The EnergyDataSettings type exposes the following members.

Properties

 | Name | Description
Public property | BuildingConstructionClass | Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.
Public property | BuildingHVACSystem | The type of HVAC system used by the building for conceptual model energy calculations.
Public property | BuildingOperatingSchedule | The operating schedule of the building used for conceptual model energy calculations.
Public property | BuildingType | The type of building.
Public property | CreateAnalyticalModel | If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.
Public property | EnergyModel | if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.
Public property | ExportCategory | Value is a category indicating which discipline model will be used for GreenBuildingXML export.
Public property | ExportComplexity | Value determines Export Complexity for GreenBuildingXML detailed model export.
Public property | ExportDefaults | Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.
Public property | GroundPlane | Id of level which represents ground level.
Public property | IncludeThermalProperties | Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.
Public property | IsExportMullionsEnabled | Indicates if mullions are included in GreenBuildingXML export of the detailed model.
Public property | IsExportShadingSurfacesEnabled | Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.
Public property | IsExportSimplifiedCurtainSystemsEnabled | Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.
Public property | IsGlazingShaded | If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.
Public property | MassZoneCoreOffset | It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.
Public property | MassZoneDividePerimeter | If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.
Public property | OutsideAirChangesRatePerHour |
Public property | OutsideAirPerArea |
Public property | OutsideAirPerPerson |
Public property | PercentageGlazing | Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.
Public property | PercentageSkylights | Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.
Public property | ProjectPhase | The project phase of the EnergyData information.
Public property | ProjectReportType | Report type: None, simple, standard, detailed
Public property | ServiceType | The type of heating or cooling system.
Public property | ShadeDepth | Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.
Public property | SillHeight | Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.
Public property | SkylightWidth | Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.
Public property | SliverSpaceTolerance | Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.
Public property | UseAirChangesPerHour | True if user is specifying air changes per hour, false otherwise.
Public property | UseHeatingCredits | If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.
Public property | UseOutsideAirPerArea | True is user is specifying outside air per area, false otherwise.
Public property | UseOutsideAirPerPerson | True if user is specifying outside air per person, false otherwise.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingConstructionClass Property

[image]

Revit 2013 API
EnergyDataSettings..::..BuildingConstructionClass Property
EnergyDataSettings Class See Also Send Feedback
Used for both the detailed and conceptual energy model Construction class of building as defined by: loose, medium, tight, or none.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public HVACLoadConstructionClass BuildingConstructionClass { get; set; }
Visual Basic
Public Property BuildingConstructionClass As HVACLoadConstructionClass
    Get
    Set
Visual C++
public:
property HVACLoadConstructionClass BuildingConstructionClass {
    HVACLoadConstructionClass get ();
    void set (HVACLoadConstructionClass value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building construction class does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingHVACSystem Property

[image]

Revit 2013 API
EnergyDataSettings..::..BuildingHVACSystem Property
EnergyDataSettings Class See Also Send Feedback
The type of HVAC system used by the building for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingHVACSystem BuildingHVACSystem { get; set; }
Visual Basic
Public Property BuildingHVACSystem As gbXMLBuildingHVACSystem
    Get
    Set
Visual C++
public:
property gbXMLBuildingHVACSystem BuildingHVACSystem {
    gbXMLBuildingHVACSystem get ();
    void set (gbXMLBuildingHVACSystem value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building HVAC system does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingOperatingSchedule Property

[image]

Revit 2013 API
EnergyDataSettings..::..BuildingOperatingSchedule Property
EnergyDataSettings Class See Also Send Feedback
The operating schedule of the building used for conceptual model energy calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; }
Visual Basic
Public Property BuildingOperatingSchedule As gbXMLBuildingOperatingSchedule
    Get
    Set
Visual C++
public:
property gbXMLBuildingOperatingSchedule BuildingOperatingSchedule {
    gbXMLBuildingOperatingSchedule get ();
    void set (gbXMLBuildingOperatingSchedule value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building operating schedule does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


BuildingType Property

[image]

Revit 2013 API
EnergyDataSettings..::..BuildingType Property
EnergyDataSettings Class See Also Send Feedback
The type of building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLBuildingType BuildingType { get; set; }
Visual Basic
Public Property BuildingType As gbXMLBuildingType
    Get
    Set
Visual C++
public:
property gbXMLBuildingType BuildingType {
    gbXMLBuildingType get ();
    void set (gbXMLBuildingType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


CreateAnalyticalModel Property

[image]

Revit 2013 API
EnergyDataSettings..::..CreateAnalyticalModel Property
EnergyDataSettings Class See Also Send Feedback
If this is true, data, features, and geometry related to the Energy Analytical Model will be created, allowing the energy performance to be analyzed through GreenBuilidingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CreateAnalyticalModel { get; }
Visual Basic
Public ReadOnly Property CreateAnalyticalModel As Boolean
    Get
Visual C++
public:
property bool CreateAnalyticalModel {
    bool get ();
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


EnergyModel Property

[image]

Revit 2013 API
EnergyDataSettings..::..EnergyModel Property
EnergyDataSettings Class See Also Send Feedback
if this is on there should be an energy model dependent on the current AnalysisType if it is off the conceptual energy model should be turned off but setting this datum does not do the work, just reflects the state.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool EnergyModel { get; set; }
Visual Basic
Public Property EnergyModel As Boolean
    Get
    Set
Visual C++
public:
property bool EnergyModel {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportCategory Property

[image]

Revit 2013 API
EnergyDataSettings..::..ExportCategory Property
EnergyDataSettings Class See Also Send Feedback
Value is a category indicating which discipline model will be used for GreenBuildingXML export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ExportCategory { get; set; }
Visual Basic
Public Property ExportCategory As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ExportCategory {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

OST_Rooms will use the architectural 3d rooms for export. OST_MEPSpaces will use the MEP 3d Spaces for export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The export category is neither OST_Rooms nor OST_MEPSpaces.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportComplexity Property

[image]

Revit 2013 API
EnergyDataSettings..::..ExportComplexity Property
EnergyDataSettings Class See Also Send Feedback
Value determines Export Complexity for GreenBuildingXML detailed model export.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLExportComplexity ExportComplexity { get; set; }
Visual Basic
Public Property ExportComplexity As gbXMLExportComplexity
    Get
    Set
Visual C++
public:
property gbXMLExportComplexity ExportComplexity {
    gbXMLExportComplexity get ();
    void set (gbXMLExportComplexity value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The export complexity does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ExportDefaults Property

[image]

Revit 2013 API
EnergyDataSettings..::..ExportDefaults Property
EnergyDataSettings Class See Also Send Feedback
Use for detailed model GreenBuildingXML export. When this setting is true, all building and space defaults, schedules, and constructions will be exported to GreenBuildingXML. When this setting is false, only values that are specified on the zone or space will be exported to GreenBuildingXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ExportDefaults { get; set; }
Visual Basic
Public Property ExportDefaults As Boolean
    Get
    Set
Visual C++
public:
property bool ExportDefaults {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


GroundPlane Property

[image]

Revit 2013 API
EnergyDataSettings..::..GroundPlane Property
EnergyDataSettings Class See Also Send Feedback
Id of level which represents ground level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GroundPlane { get; set; }
Visual Basic
Public Property GroundPlane As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ GroundPlane {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

The ground plane defines what is above and below ground for Conceptual Energy Analysis. The ground plane can optionally used for the rendering cast shadows.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element is not a level or invalidElementId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IncludeThermalProperties Property

[image]

Revit 2013 API
EnergyDataSettings..::..IncludeThermalProperties Property
EnergyDataSettings Class See Also Send Feedback
Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IncludeThermalProperties { get; set; }
Visual Basic
Public Property IncludeThermalProperties As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeThermalProperties {
    bool get ();
    void set (bool value);
}

Remarks

If true, Revit will include model thermal data from assemblies and components when available, when Export Category is Rooms.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportMullionsEnabled Property

[image]

Revit 2013 API
EnergyDataSettings..::..IsExportMullionsEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if mullions are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsExportMullionsEnabled { get; }
Visual Basic
Public ReadOnly Property IsExportMullionsEnabled As Boolean
    Get
Visual C++
public:
property bool IsExportMullionsEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. When this setting is on, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness, and offset.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportShadingSurfacesEnabled Property

[image]

Revit 2013 API
EnergyDataSettings..::..IsExportShadingSurfacesEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if "shading surfaces" are included in GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsExportShadingSurfacesEnabled { get; }
Visual Basic
Public ReadOnly Property IsExportShadingSurfacesEnabled As Boolean
    Get
Visual C++
public:
property bool IsExportShadingSurfacesEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. The method described by gbs/gbxml.org to calculate the shading surfaces is to take all surfaces from the MEP spaces, subtract them from the surfaces from all building elements, and then the remaining surfaces are considered to be the shading surfaces.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsExportSimplifiedCurtainSystemsEnabled Property

[image]

Revit 2013 API
EnergyDataSettings..::..IsExportSimplifiedCurtainSystemsEnabled Property
EnergyDataSettings Class See Also Send Feedback
Indicates if curtain system geometry is being simplified for GreenBuildingXML export of the detailed model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsExportSimplifiedCurtainSystemsEnabled { get; }
Visual Basic
Public ReadOnly Property IsExportSimplifiedCurtainSystemsEnabled As Boolean
    Get
Visual C++
public:
property bool IsExportSimplifiedCurtainSystemsEnabled {
    bool get ();
}

Remarks

Result is based on the ExportComplexity setting. Curtain Walls and Curtain Systems are normally exported as multiple openings, panel by panel, while for energy analysis this can be more simply represented as a single glass surface as large as the entire curtain wall/system. Normally, a curtain wall with 50 panels would be exported as 50 openings. Often, exporting a single opening with the total curtain system area is more appropriate. When this setting is on, one "large" window/opening will be exported for a curtain wall/system.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


IsGlazingShaded Property

[image]

Revit 2013 API
EnergyDataSettings..::..IsGlazingShaded Property
EnergyDataSettings Class See Also Send Feedback
If this is true, glazing/windows that are auto-created on exterior walls will automatically have a shading device created on their top edge.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsGlazingShaded { get; set; }
Visual Basic
Public Property IsGlazingShaded As Boolean
    Get
    Set
Visual C++
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneCoreOffset Property

[image]

Revit 2013 API
EnergyDataSettings..::..MassZoneCoreOffset Property
EnergyDataSettings Class See Also Send Feedback
It defines the default behavior for the automatic generation of Mass Zones for each Mass Floor in the Project. Specifying a value here will offset the outside perimeter of a Mass Zone to create the core.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic
Public Property MassZoneCoreOffset As Double
    Get
    Set
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The mass zone core offset is less than zero.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneDividePerimeter Property

[image]

Revit 2013 API
EnergyDataSettings..::..MassZoneDividePerimeter Property
EnergyDataSettings Class See Also Send Feedback
If this is true, outward facing zones on each floor of the building will be divided based on the four compass directions.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool MassZoneDividePerimeter { get; set; }
Visual Basic
Public Property MassZoneDividePerimeter As Boolean
    Get
    Set
Visual C++
public:
property bool MassZoneDividePerimeter {
    bool get ();
    void set (bool value);
}

Remarks

The quadrants will be True N, S, E, and W. The division of the quadrants will be along the axis of True NW to SE and True SW to NE. The intersection of the quadrants will be placed at the centroid of the zone. The purpose of these divisions is to ensure that auto-generated zoning is appropriate for thermal loads generated by the relative position of the building to the sun path.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirChangesRatePerHour Property

[image]

Revit 2013 API
EnergyDataSettings..::..OutsideAirChangesRatePerHour Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirChangesRatePerHour { get; set; }
Visual Basic
Public Property OutsideAirChangesRatePerHour As Double
    Get
    Set
Visual C++
public:
property double OutsideAirChangesRatePerHour {
    double get ();
    void set (double value);
}

Remarks

Air Changes per hour is "unitless". It is a number. It is the number of times the air (the volume) interchanges in the room in one hour. This number is a format for expressing the requirement for airflow. The "flow" requirement for a room might be expressed, e.g., one room of 100 CF, and 3 Air Changes per Hour (ACH), would compute to 100 CF x 3 ACH / 60 min = 5 CFM.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The outside airChangesRatePerHour does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirPerArea Property

[image]

Revit 2013 API
EnergyDataSettings..::..OutsideAirPerArea Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirPerArea { get; set; }
Visual Basic
Public Property OutsideAirPerArea As Double
    Get
    Set
Visual C++
public:
property double OutsideAirPerArea {
    double get ();
    void set (double value);
}

Remarks

Stored in cubic feet per hour per square foot.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The outside airPerArea does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


OutsideAirPerPerson Property

[image]

Revit 2013 API
EnergyDataSettings..::..OutsideAirPerPerson Property
EnergyDataSettings Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double OutsideAirPerPerson { get; set; }
Visual Basic
Public Property OutsideAirPerPerson As Double
    Get
    Set
Visual C++
public:
property double OutsideAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

Stored in cubic feet per hour.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The outside airPerPerson does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


PercentageGlazing Property

[image]

Revit 2013 API
EnergyDataSettings..::..PercentageGlazing Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate percentage of the building exterior wall surfaces which are covered by windows or other glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double PercentageGlazing { get; set; }
Visual Basic
Public Property PercentageGlazing As Double
    Get
    Set
Visual C++
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}

Remarks

This value is used to automatically model these glazed openings in massing instances for the Conceptual Energy Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage glazing value is not between 0.00 and 0.95.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


PercentageSkylights Property

[image]

Revit 2013 API
EnergyDataSettings..::..PercentageSkylights Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate percentage of the building roof surfaces in massing instances for the Conceptual Energy Analytical Model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic
Public Property PercentageSkylights As Double
    Get
    Set
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

This value is used to automatically model the skylights in massing instances when the Energy Analytical model is being created.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ProjectPhase Property

[image]

Revit 2013 API
EnergyDataSettings..::..ProjectPhase Property
EnergyDataSettings Class See Also Send Feedback
The project phase of the EnergyData information.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ProjectPhase { get; set; }
Visual Basic
Public Property ProjectPhase As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProjectPhase {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element is not a project phase.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ProjectReportType Property

[image]

Revit 2013 API
EnergyDataSettings..::..ProjectReportType Property
EnergyDataSettings Class See Also Send Feedback
Report type: None, simple, standard, detailed

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public HVACLoadLoadsReportType ProjectReportType { get; set; }
Visual Basic
Public Property ProjectReportType As HVACLoadLoadsReportType
    Get
    Set
Visual C++
public:
property HVACLoadLoadsReportType ProjectReportType {
    HVACLoadLoadsReportType get ();
    void set (HVACLoadLoadsReportType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The project report type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ServiceType Property

[image]

Revit 2013 API
EnergyDataSettings..::..ServiceType Property
EnergyDataSettings Class See Also Send Feedback
The type of heating or cooling system.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public gbXMLServiceType ServiceType { get; set; }
Visual Basic
Public Property ServiceType As gbXMLServiceType
    Get
    Set
Visual C++
public:
property gbXMLServiceType ServiceType {
    gbXMLServiceType get ();
    void set (gbXMLServiceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The service type does not fall within an appropriate range.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


ShadeDepth Property

[image]

Revit 2013 API
EnergyDataSettings..::..ShadeDepth Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. Amount that auto-generated shading will extend from auto-generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic
Public Property ShadeDepth As Double
    Get
    Set
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shade depth is less than zero.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SillHeight Property

[image]

Revit 2013 API
EnergyDataSettings..::..SillHeight Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The height from the nearest lower level used for auto-glazing created on walls.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SillHeight { get; set; }
Visual Basic
Public Property SillHeight As Double
    Get
    Set
Visual C++
public:
property double SillHeight {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The sill height is less than zero.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SkylightWidth Property

[image]

Revit 2013 API
EnergyDataSettings..::..SkylightWidth Property
EnergyDataSettings Class See Also Send Feedback
Used for the conceptual energy model. The approximate width used for the skylights in massing instances when the Energy Analytical model is being created.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SkylightWidth { get; set; }
Visual Basic
Public Property SkylightWidth As Double
    Get
    Set
Visual C++
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The skylight width is less than eight inches.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


SliverSpaceTolerance Property

[image]

Revit 2013 API
EnergyDataSettings..::..SliverSpaceTolerance Property
EnergyDataSettings Class See Also Send Feedback
Used for Detailed GreenBuildingXML export. This value is used to identify sliver spaces, i.e. spaces bounded by parallel surfaces belonging to different rooms.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SliverSpaceTolerance { get; set; }
Visual Basic
Public Property SliverSpaceTolerance As Double
    Get
    Set
Visual C++
public:
property double SliverSpaceTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The sliver space tolerance is less than zero.

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseAirChangesPerHour Property

[image]

Revit 2013 API
EnergyDataSettings..::..UseAirChangesPerHour Property
EnergyDataSettings Class See Also Send Feedback
True if user is specifying air changes per hour, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UseAirChangesPerHour { get; set; }
Visual Basic
Public Property UseAirChangesPerHour As Boolean
    Get
    Set
Visual C++
public:
property bool UseAirChangesPerHour {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseHeatingCredits Property

[image]

Revit 2013 API
EnergyDataSettings..::..UseHeatingCredits Property
EnergyDataSettings Class See Also Send Feedback
If true, Revit will use heating credits in the final load sum calculations. If false, Revit will ignore heating credits in the final load sum calculations.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UseHeatingCredits { get; set; }
Visual Basic
Public Property UseHeatingCredits As Boolean
    Get
    Set
Visual C++
public:
property bool UseHeatingCredits {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseOutsideAirPerArea Property

[image]

Revit 2013 API
EnergyDataSettings..::..UseOutsideAirPerArea Property
EnergyDataSettings Class See Also Send Feedback
True is user is specifying outside air per area, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UseOutsideAirPerArea { get; set; }
Visual Basic
Public Property UseOutsideAirPerArea As Boolean
    Get
    Set
Visual C++
public:
property bool UseOutsideAirPerArea {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


UseOutsideAirPerPerson Property

[image]

Revit 2013 API
EnergyDataSettings..::..UseOutsideAirPerPerson Property
EnergyDataSettings Class See Also Send Feedback
True if user is specifying outside air per person, false otherwise.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UseOutsideAirPerPerson { get; set; }
Visual Basic
Public Property UseOutsideAirPerPerson As Boolean
    Get
    Set
Visual C++
public:
property bool UseOutsideAirPerPerson {
    bool get ();
    void set (bool value);
}

See Also

EnergyDataSettings Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Class

[image]

Revit 2013 API
FieldDomainPoints Class
Members See Also Send Feedback
Abstract base class for various classes of field domain points

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPoints : IDisposable
Visual Basic
Public Class FieldDomainPoints _
    Implements IDisposable
Visual C++
public ref class FieldDomainPoints : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByParameter
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByUV
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByXYZ

See Also

FieldDomainPoints Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Members

[image] [image]

Revit 2013 API
FieldDomainPoints Members
FieldDomainPoints Class Methods See Also Send Feedback

The FieldDomainPoints type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldDomainPoints
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPoints Methods

[image] [image]

Revit 2013 API
FieldDomainPoints Methods
FieldDomainPoints Class See Also Send Feedback

The FieldDomainPoints type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
FieldDomainPoints..::..Dispose Method
FieldDomainPoints Class See Also Send Feedback
Releases all resources used by the FieldDomainPoints

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FieldDomainPoints Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Class

[image]

Revit 2013 API
FieldDomainPointsByParameter Class
Members Example See Also Send Feedback
Represents a set of one-dimensional point coordinates (defined usually on curve)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByParameter : FieldDomainPoints
Visual Basic
Public Class FieldDomainPointsByParameter _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByParameter : public FieldDomainPoints

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (sfm == null)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}

ReferenceArray ra = new ReferenceArray();
Reference curveRef = uiDoc.Selection.PickObject(ObjectType.Element, "Select a curve");
ra.Append(curveRef);

foreach (Reference reference in ra)
{
    ModelCurve modelCurve = doc.GetElement(reference) as ModelCurve;
    Curve curve = modelCurve.GeometryCurve;
    if (curve == null)
    {
        TaskDialog.Show("Error", "Must select a curve");
        return Result.Cancelled;
    }
    else
    {
        int idx = sfm.AddSpatialFieldPrimitive(curve.Reference);

        IList<double> pts = new List<double>();

        double range = curve.get_EndParameter(1) - curve.get_EndParameter(0);
        double u = curve.get_EndParameter(0);
        for (int ii = 0; ii < 10; ii++)
        {
            pts.Add(u);
            u = u + range / 10;
        }

        FieldDomainPointsByParameter pnts = new FieldDomainPointsByParameter(pts);

        List<double> doubleList = new List<double>();
        IList<ValueAtPoint> valList = new List<ValueAtPoint>();
        double x = 0;
        while (valList.Count < pts.Count)
        //for (double x = 0; x < 1; x = x + 0.1)
        {
            doubleList.Clear();
            doubleList.Add(x * 10);
            valList.Add(new ValueAtPoint(doubleList));
            x = x + 0.1;
        }
        FieldValues vals = new FieldValues(valList);

        AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");
        int schemaIndex = sfm.RegisterResult(resultSchema);
        sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex);
    }
}
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As Autodesk.Revit.DB.Analysis.SpatialFieldManager = Autodesk.Revit.DB.Analysis.SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
    sfm = Autodesk.Revit.DB.Analysis.SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If

Dim ra As New ReferenceArray()
Dim curveRef As Reference = uiDoc.Selection.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Element, "Select a curve")
ra.Append(curveRef)

For Each reference As Reference In ra
    Dim modelCurve As ModelCurve = TryCast(reference.Element, ModelCurve)
    Dim curve As Curve = modelCurve.GeometryCurve
    If curve Is Nothing Then
        TaskDialog.Show("Error", "Must select a curve")
        Return Result.Cancelled
    Else
        Dim idx As Integer = sfm.AddSpatialFieldPrimitive(curve.Reference)

        Dim pts As IList(Of Double) = New List(Of Double)()

        Dim range As Double = curve.EndParameter(1) - curve.EndParameter(0)
        Dim u As Double = curve.EndParameter(0)
        Dim ii As Integer = 0
        While ii < 10
            pts.Add(u)
            u = u + range / 10
            System.Math.Max(System.Threading.Interlocked.Increment(ii), ii - 1)
        End While

        Dim pnts As New Autodesk.Revit.DB.Analysis.FieldDomainPointsByParameter(pts)

        Dim doubleList As New List(Of Double)()
        Dim valList As IList(Of Autodesk.Revit.DB.Analysis.ValueAtPoint) = New List(Of Autodesk.Revit.DB.Analysis.ValueAtPoint)()
        Dim x As Double = 0
        While valList.Count < pts.Count
            'for (double x = 0; x < 1; x = x + 0.1)
            doubleList.Clear()
            doubleList.Add(x * 10)
            valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))
            x = x + 0.1
        End While
        Dim vals As New Autodesk.Revit.DB.Analysis.FieldValues(valList)

        sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals)
    End If
Next

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByParameter

See Also

FieldDomainPointsByParameter Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Members

[image] [image]

Revit 2013 API
FieldDomainPointsByParameter Members
FieldDomainPointsByParameter Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByParameter type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDomainPointsByParameter | Creates object from an array of one-dimensional point coordinates

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Constructor

[image]

Revit 2013 API
FieldDomainPointsByParameter Constructor
FieldDomainPointsByParameter Class See Also Send Feedback
Creates object from an array of one-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByParameter(
    IList<double> points
)
Visual Basic
Public Sub New ( _
    points As IList(Of Double) _
)
Visual C++
public:
FieldDomainPointsByParameter(
    IList<double>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Array of one-dimensional point coordinates representing domain points (using raw parameters when on a curve)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByParameter Methods

[image] [image]

Revit 2013 API
FieldDomainPointsByParameter Methods
FieldDomainPointsByParameter Class See Also Send Feedback

The FieldDomainPointsByParameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByParameter Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Class

[image]

Revit 2013 API
FieldDomainPointsByUV Class
Members See Also Send Feedback
Represents a set of two-dimensional point coordinates (defined usually on surface)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByUV : FieldDomainPoints
Visual Basic
Public Class FieldDomainPointsByUV _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByUV : public FieldDomainPoints

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByUV

See Also

FieldDomainPointsByUV Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Members

[image] [image]

Revit 2013 API
FieldDomainPointsByUV Members
FieldDomainPointsByUV Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByUV type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>)) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>), ICollection<(Of <<'(Double>)>>), ICollection<(Of <<'(Double>)>>)) | Creates object from an array of two-dimensional point coordinates

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor

[image] [image]

Revit 2013 API
FieldDomainPointsByUV Constructor
FieldDomainPointsByUV Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>)) | Creates object from an array of two-dimensional point coordinates
Public method | FieldDomainPointsByUV(IList<(Of <<'(UV>)>>), ICollection<(Of <<'(Double>)>>), ICollection<(Of <<'(Double>)>>)) | Creates object from an array of two-dimensional point coordinates

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor (IList(UV))

[image]

Revit 2013 API
FieldDomainPointsByUV Constructor (IList<(Of <(<'UV>)>)>)
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points
)
Visual Basic
Public Sub New ( _
    points As IList(Of UV) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'UV>)>)>
Array of two-dimensional point coordinates representing domain points (usually on surface)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Constructor (IList(UV), ICollection(Double), ICollection(Double))

[image]

Revit 2013 API
FieldDomainPointsByUV Constructor (IList<(Of <(<'UV>)>)>, ICollection<(Of <(<'Double>)>)>, ICollection<(Of <(<'Double>)>)>)
FieldDomainPointsByUV Class See Also Send Feedback
Creates object from an array of two-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByUV(
    IList<UV> points,
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Visual Basic
Public Sub New ( _
    points As IList(Of UV), _
    uCoordinates As ICollection(Of Double), _
    vCoordinates As ICollection(Of Double) _
)
Visual C++
public:
FieldDomainPointsByUV(
    IList<UV^>^ points,
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'UV>)>)>
Array of two-dimensional point coordinates representing domain points (usually on surface)
uCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of u coordinates at which to draw grid lines on the surface
vCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of v coordinates at which to draw grid lines on the surface

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
FieldDomainPointsByUV Overload
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByUV Methods

[image] [image]

Revit 2013 API
FieldDomainPointsByUV Methods
FieldDomainPointsByUV Class See Also Send Feedback

The FieldDomainPointsByUV type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetGridCoordinates | Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


SetGridCoordinates Method

[image]

Revit 2013 API
FieldDomainPointsByUV..::..SetGridCoordinates Method
FieldDomainPointsByUV Class See Also Send Feedback
Set u and v coordinates that specify a grid on the surface. The display of the grid is controlled by AnalysisDisplayColoredSurfaceSettings::getShowGridLines(). If AnalysisDisplayColoredSurfaceSettings::getShowGridLines() returns true and both sets are empty then a grid will be displayed using a default spacing; if only one of the sets is non-empty, then only the corresponding set of grid lines will be displayed, i.e. the grid will consist solely of parallel lines at the specified coordinates.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetGridCoordinates(
    ICollection<double> uCoordinates,
    ICollection<double> vCoordinates
)
Visual Basic
Public Sub SetGridCoordinates ( _
    uCoordinates As ICollection(Of Double), _
    vCoordinates As ICollection(Of Double) _
)
Visual C++
public:
void SetGridCoordinates(
    ICollection<double>^ uCoordinates,
    ICollection<double>^ vCoordinates
)

Parameters

uCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of u coordinates at which to draw grid lines
vCoordinates
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>
Set of v coordinates at which to draw grid lines

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByUV Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Class

[image]

Revit 2013 API
FieldDomainPointsByXYZ Class
Members See Also Send Feedback
Represents a set of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FieldDomainPointsByXYZ : FieldDomainPoints
Visual Basic
Public Class FieldDomainPointsByXYZ _
    Inherits FieldDomainPoints
Visual C++
public ref class FieldDomainPointsByXYZ : public FieldDomainPoints

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Autodesk.Revit.DB.Analysis..::..FieldDomainPointsByXYZ

See Also

FieldDomainPointsByXYZ Members
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Members

[image] [image]

Revit 2013 API
FieldDomainPointsByXYZ Members
FieldDomainPointsByXYZ Class Constructors Methods See Also Send Feedback

The FieldDomainPointsByXYZ type exposes the following members.

Constructors

 | Name | Description
Public method | FieldDomainPointsByXYZ | Creates object from an array of three-dimensional point coordinates

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Constructor

[image]

Revit 2013 API
FieldDomainPointsByXYZ Constructor
FieldDomainPointsByXYZ Class See Also Send Feedback
Creates object from an array of three-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldDomainPointsByXYZ(
    IList<XYZ> points
)
Visual Basic
Public Sub New ( _
    points As IList(Of XYZ) _
)
Visual C++
public:
FieldDomainPointsByXYZ(
    IList<XYZ^>^ points
)

Parameters

points
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Array of three-dimensional point coordinates representing domain points

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when supplied array points contain too many members (over 1000)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldDomainPointsByXYZ Methods

[image] [image]

Revit 2013 API
FieldDomainPointsByXYZ Methods
FieldDomainPointsByXYZ Class See Also Send Feedback

The FieldDomainPointsByXYZ type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from FieldDomainPoints.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldDomainPointsByXYZ Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Class

[image]

Revit 2013 API
FieldValues Class
Members See Also Send Feedback
Contains values corresponding to domain points. Each domain point may have an array of values, each corresponding to a separate "measurement" for which this value was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FieldValues : IDisposable
Visual Basic
Public Class FieldValues _
    Implements IDisposable
Visual C++
public ref class FieldValues : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..FieldValues

See Also

FieldValues Members
Autodesk.Revit.DB.Analysis Namespace


FieldValues Members

[image] [image]

Revit 2013 API
FieldValues Members
FieldValues Class Constructors Methods See Also Send Feedback

The FieldValues type exposes the following members.

Constructors

 | Name | Description
Public method | FieldValues(FieldValues) | Initializes a new instance of the FieldValues class
Public method | FieldValues(IList<(Of <<'(ValueAtPoint>)>>)) | Creates object from an array of domain point values
Public method | FieldValues(IList<(Of <<'(VectorAtPoint>)>>)) | Creates object from an array of domain point vectors
Public method | FieldValues(IList<(Of <<'(ValueAtPoint>)>>), XYZ) | Creates object from an array of domain point values

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldValues
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor

[image] [image]

Revit 2013 API
FieldValues Constructor
FieldValues Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldValues(FieldValues) | Initializes a new instance of the FieldValues class
Public method | FieldValues(IList<(Of <<'(ValueAtPoint>)>>)) | Creates object from an array of domain point values
Public method | FieldValues(IList<(Of <<'(VectorAtPoint>)>>)) | Creates object from an array of domain point vectors
Public method | FieldValues(IList<(Of <<'(ValueAtPoint>)>>), XYZ) | Creates object from an array of domain point values

See Also

FieldValues Class
FieldValues Members
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (FieldValues)

[image]

Revit 2013 API
FieldValues Constructor (FieldValues)
FieldValues Class See Also Send Feedback
Initializes a new instance of the FieldValues class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldValues(
    FieldValues otherObject
)
Visual Basic
Public Sub New ( _
    otherObject As FieldValues _
)
Visual C++
public:
FieldValues(
    FieldValues^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::..FieldValues

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (IList(ValueAtPoint))

[image]

Revit 2013 API
FieldValues Constructor (IList<(Of <(<'ValueAtPoint>)>)>)
FieldValues Class See Also Send Feedback
Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FieldValues(
    IList<ValueAtPoint> valueAtPoint
)
Visual Basic
Public Sub New ( _
    valueAtPoint As IList(Of ValueAtPoint) _
)
Visual C++
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint
)

Parameters

valueAtPoint
Type: System.Collections.Generic..::..IList<(Of <(<'ValueAtPoint>)>)>
Array of values, each corresponding to a domain point

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | valueAtPoint array contains members with different numbers of measurements
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (IList(VectorAtPoint))

[image]

Revit 2013 API
FieldValues Constructor (IList<(Of <(<'VectorAtPoint>)>)>)
FieldValues Class See Also Send Feedback
Creates object from an array of domain point vectors

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldValues(
    IList<VectorAtPoint> vectorAtPoint
)
Visual Basic
Public Sub New ( _
    vectorAtPoint As IList(Of VectorAtPoint) _
)
Visual C++
public:
FieldValues(
    IList<VectorAtPoint^>^ vectorAtPoint
)

Parameters

vectorAtPoint
Type: System.Collections.Generic..::..IList<(Of <(<'VectorAtPoint>)>)>
Array of vectors, each corresponding to a domain point

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Members of vectorAtPoint contain different numbers of measurements
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Constructor (IList(ValueAtPoint), XYZ)

[image]

Revit 2013 API
FieldValues Constructor (IList<(Of <(<'ValueAtPoint>)>)>, XYZ)
FieldValues Class See Also Send Feedback
Creates object from an array of domain point values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldValues(
    IList<ValueAtPoint> valueAtPoint,
    XYZ unitDirection
)
Visual Basic
Public Sub New ( _
    valueAtPoint As IList(Of ValueAtPoint), _
    unitDirection As XYZ _
)
Visual C++
public:
FieldValues(
    IList<ValueAtPoint^>^ valueAtPoint,
    XYZ^ unitDirection
)

Parameters

valueAtPoint
Type: System.Collections.Generic..::..IList<(Of <(<'ValueAtPoint>)>)>
Array of values, each corresponding to a domain point
unitDirection
Type: Autodesk.Revit.DB..::..XYZ
Unit vector that gives the same direction for values (for diagrams)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Members of valueAtPoint contain different numbers of measurements -or- unitDirection is not a unit vector
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldValues Class
FieldValues Overload
Autodesk.Revit.DB.Analysis Namespace


FieldValues Methods

[image] [image]

Revit 2013 API
FieldValues Methods
FieldValues Class See Also Send Feedback

The FieldValues type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
FieldValues..::..Dispose Method
FieldValues Class See Also Send Feedback
Releases all resources used by the FieldValues

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FieldValues Class
Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingHVACSystem Enumeration

[image]

Revit 2013 API
gbXMLBuildingHVACSystem Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum gbXMLBuildingHVACSystem
Visual Basic
Public Enumeration gbXMLBuildingHVACSystem
Visual C++
public enum class gbXMLBuildingHVACSystem

Members

Member name | Description
TwelveSEERSPointNineAFUESplitPackagedGasFiveToElevenTon |
ElevenPointThreeEERPackagedVAVEightyFourPointFourPercentBoilerHeating |
CentralVAVHWHeatChillerFivePointNinetySixCOPBoilersEightyFourPoint5Eff |
FourPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightFourPointFiveEff |
CentralVAVElectricResistanceHeatChillerFivePointNinetySixCOP |
TwelveSEERSevenPointSevenHSPFSplitPackagedHeatPump |
TwoPipeFanCoilSystemChillerFivePointNinetySixCOPBoilersEightyFourPointFiveEff |
TwelveSEEREightPointThreeHSPFPackagedTerminalHeatPumpPTAC |
ResidentialSeventeenSEERNinePointSixHSPFSplitHPLessThanFivePointFiveTon |
UnderfloorAirDistribution |
ResidentialFourteenSEERPointNineAFUESplitPackagedGasLessThanFivePointFiveTon |
ResidentialFourteenSEEREightPointThreeHSPFSplitPackagedHeatPump |
NoOfHVACSystemEnums |

Remarks

This enumeration corresponds to the HVAC System attribute in gbXML and is used to specify the Building HVAC System.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingOperatingSchedule Enumeration

[image]

Revit 2013 API
gbXMLBuildingOperatingSchedule Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum gbXMLBuildingOperatingSchedule
Visual Basic
Public Enumeration gbXMLBuildingOperatingSchedule
Visual C++
public enum class gbXMLBuildingOperatingSchedule

Members

Member name | Description
DefaultOperatingSchedule |
TwentyFourHourSevenDayFacility |
TwentyFourHourHourSixDayFacility |
TwentyFourHourHourFiveDayFacility |
TwelveHourSevenDayFacility |
TwelveHourSixDayFacility |
TwelveHourFiveDayFacility |
KindergartenThruTwelveGradeSchool |
YearRoundSchool |
TheaterPerformingArts |
Worship |
NoOfOperatingScheduleEnums |

Remarks

This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the building operating schedule.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLBuildingType Enumeration

[image]

Revit 2013 API
gbXMLBuildingType Enumeration
See Also Send Feedback
Enumerations for gbXML (Green Building XML) format, used for energy analysis, schema version 0.34.
This enumeration corresponds to the buildingType attribute in gbXML and is used to specify the most predominant building use type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLBuildingType
Visual Basic
Public Enumeration gbXMLBuildingType
Visual C++
public enum class gbXMLBuildingType

Members

Member name | Description
NoBuildingType |
AutomotiveFacility |
ConventionCenter |
Courthouse |
DiningBarLoungeOrLeisure |
DiningCafeteriaFastFood |
DiningFamily |
Dormitory |
ExerciseCenter |
FireStation |
Gymnasium |
HospitalOrHealthcare |
Hotel |
Library |
Manufacturing |
Motel |
MotionPictureTheatre |
MultiFamily |
Museum |
Office |
ParkingGarage |
Penitentiary |
PerformingArtsTheater |
PoliceStation |
PostOffice |
ReligiousBuilding |
Retail |
SchoolOrUniversity |
SingleFamily |
SportsArena |
TownHall |
Transportation |
Warehouse |
Workshop |
NoOfBuildingTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLConditionType Enumeration

[image]

Revit 2013 API
gbXMLConditionType Enumeration
See Also Send Feedback
This enumeration corresponds to the conditionType attribute in gbXML. The enumerated attribute identifies the type of heating, cooling, or ventilation the space has.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLConditionType
Visual Basic
Public Enumeration gbXMLConditionType
Visual C++
public enum class gbXMLConditionType

Members

Member name | Description
NoConditionType |
Heated |
Cooled |
HeatedAndCooled |
Unconditioned |
Vented |
NaturallyVentedOnly |
NoOfConditionTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLExportComplexity Enumeration

[image]

Revit 2013 API
gbXMLExportComplexity Enumeration
See Also Send Feedback
This enumeration specifies the level of detail of the exported analytical energy model in gbXML. Complex means that Curtain Walls and Curtain Systems are exported as several openings, panel by panel; a curtain wall with 50 panels gets exported as 50 openings. Simple means that one “huge” opening with the total opening area equal to the 50 panels is exported. This is more appropriate for most energy analysis. Mullions mean that Mullions in Curtain Walls and Systems are exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLExportComplexity
Visual Basic
Public Enumeration gbXMLExportComplexity
Visual C++
public enum class gbXMLExportComplexity

Members

Member name | Description
Simple | Curtain Walls and Curtain Systems are normally exported as several openings, panel by panel, while for energy analysis all you need is one giant window. A curtain wall with 50 panels gets exported as 50 openings, while 1 opening with the total opening area would be more appropriate. Using this enumeration, one "large" window/opening will be exported for a curtain wall/system
SimpleWithShadingSurfaces | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces
Complex | Using this enumeration, Curtain Walls and Curtain Systems will exported as several openings, panel by panel.
ComplexWithShadingSurfaces | Using this enumeration, shading surfaces will be produced from room bounding building elements that are not bounding spaces.
ComplexWithMullionsAndShadingSurfaces | Using this enumeration, mullions will be exported as shading surfaces. A "simplified" analytical shading surface is produced from a mullion based on its centerline, thickness and offset.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLOpeningType Enumeration

[image]

Revit 2013 API
gbXMLOpeningType Enumeration
See Also Send Feedback
This enumeration corresponds to the openingType attribute in gbXML and identifies the type of opening defined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum gbXMLOpeningType
Visual Basic
Public Enumeration gbXMLOpeningType
Visual C++
public enum class gbXMLOpeningType

Members

Member name | Description
FixedWindow | Fixed window.
OperableWindow | Operable window.
FixedSkylight | Fixed skylight.
OperableSkylight | Operable skylight.
SlidingDoor | Sliding door.
NonSlidingDoor | Non sliding door.
OpeningAir | Opening air.
NoOfOpeningTypes | No of opening types.

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLServiceType Enumeration

[image]

Revit 2013 API
gbXMLServiceType Enumeration
See Also Send Feedback
This enumeration corresponds to the systemType attribute in gbXML and is used for specifying the service for the building or space.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLServiceType
Visual Basic
Public Enumeration gbXMLServiceType
Visual C++
public enum class gbXMLServiceType

Members

Member name | Description
NoServiceType |
CentralHeatingRadiators |
CentralHeatingConvectors |
CentralHeatingRadiantFloor |
CentralHeatingHotAir |
OtherRoomHeater |
RadiantHeaterFlue |
RadiantHeaterNoFlue |
RadiantHeaterMultiburner |
ForcedConvectionHeaterFlue |
ForcedConvectionHeaterNoFlue |
VAVSingleDuct |
VAVDualDuct |
VAVIndoorPackagedCabinet |
VAVTerminalReheat |
FanCoilSystem |
InductionSystem |
ConstantVolumeFixedOA |
ConstantVolumeVariableOA |
ConstantVolumeTerminalReheat |
MultizoneHotDeckColdDeck |
ConstantVolumeDualDuct |
RadiantCooledCeilings |
ActiveChilledBeams |
WaterLoopHeatPump |
VariableRefrigerantFlow |
SplitSystemsWithNaturalVentilation |
SplitSystemsWithMechanicalVentilation |
SplitSystemsWithMechanicalVentilationWithCooling |
NoOfServiceTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLSpaceType Enumeration

[image]

Revit 2013 API
gbXMLSpaceType Enumeration
See Also Send Feedback
This enumeration corresponds to the spaceType attribute in gbXML. The enumerated attribute identifies the type of space defined and allows to better approximate the actual internal loads and schedules associated with the defined space type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum gbXMLSpaceType
Visual Basic
Public Enumeration gbXMLSpaceType
Visual C++
public enum class gbXMLSpaceType

Members

Member name | Description
NoSpaceType |
ActiveStorage |
ActiveStorageHospitalOrHealthcare |
AirOrTrainOrBusBaggageArea |
AirportConcourse |
AtriumEachAdditionalFloor |
AtriumFirstThreeFloors |
AudienceOrSeatingAreaPenitentiary |
AudienceOrSeatingAreaExerciseCenter |
AudienceOrSeatingAreaGymnasium |
AudienceOrSeatingAreaSportsArena |
AudienceOrSeatingAreaConventionCenter |
AudienceOrSeatingAreaMotionPictureTheatre |
AudienceOrSeatingAreaPerformingArtsTheatre |
AudienceOrSeatingAreaReligious |
AudienceOrSeatingAreaPoliceOrFireStations |
AudienceOrSeatingAreaCourtHouse |
AudienceOrSeatingAreaAuditorium |
BankCustomerArea |
BankingActivityAreaOffice |
BarberAndBeautyParlor |
CardFileAndCataloguingLibrary |
ClassroomOrLectureOrTrainingPenitentiary |
ClassroomOrLectureOrTraining |
ComfinementCellsPenitentiary |
ComfinementCellsCourtHouse |
ConferenceMeetingOrMultipurpose |
CorridorOrTransition |
CorridorOrTransitionManufacturingFacility |
CorridorsWithPatientWaitingExamHospitalOrHealthcare |
CourtSportsAreaSportsArena |
CourtroomCourtHouse |
DepartmentStoreSalesAreaRetail |
DetailedManufacturingFacility |
DiningArea |
DiningAreaHotel |
DiningAreaFamilyDining |
DiningAreaLoungeOrLeisureDining |
DiningAreaMotel |
DiningAreaTransportation |
DiningAreaPenitentiary |
DiningAreaCivilServices |
DormitoryBedroom |
DormitoryStudyHall |
DressingOrLockerOrFittingRoomGymnasium |
DressingOrLockerOrFittingRoomCourtHouse |
DressingOrLockerOrFittingRoomPerformingArtsTheatre |
DressingOrLockerOrFittingRoomAuditorium |
DressingOrLockerOrFittingRoomExerciseCenter |
ElectricalOrMechanical |
ElevatorLobbies |
EmergencyHospitalOrHealthcare |
EquipmentRoomManufacturingFacility |
ExamOrTreatmentHospitalOrHealthcare |
ExerciseAreaExerciseCenter |
ExerciseAreaGymnasium |
ExhibitSpaceConventionCenter |
FellowshipHallReligiousBuildings |
FineMaterialWarehouse |
FineMerchandiseSalesAreaRetail |
FireStationEngineRoomPoliceOrFireStation |
FoodPreparation |
GarageServiceOrRepairAutomotiveFacility |
GeneralHighBayManufacturingFacility |
GeneralLowBayManufacturingFacility |
GeneralExhibitionMuseum |
HospitalNurseryHospitalOrHealthcare |
HospitalOrMedicalSuppliesHospitalOrHealthcare |
HospitalOrRadiologyHospitalOrHealthcare |
HotelOrConferenceCenterConferenceOrMeeting |
InactiveStorage |
JudgesChambersCourtHouse |
LaboratoryOffice |
LaundryIroningAndSorting |
LaundryWashingHospitalOrHealthcare |
LibraryAudioVisualLibraryAudioVisual |
LivingQuartersDormitory |
LivingQuartersMotel |
LivingQuartersHotel |
Lobby |
LobbyReligiousBuildings |
LobbyMotionPictureTheatre |
LobbyAuditorium |
LobbyPerformingArtsTheatre |
LobbyPostOffice |
LobbyHotel |
LoungeOrRecreation |
MallConcourseSalesAreaRetail |
MassMerchandisingSalesAreaRetail |
MediumOrBulkyMaterialWarehouse |
MerchandisingSalesAreaRetail |
MuseumAndGalleryStorage |
NurseStationHospitalOrHealthcare |
OfficeEnclosed |
OfficeOpenPlan |
OfficeCommonActivityAreasInactiveStorage |
OperatingRoomHospitalOrHealthcare |
OtherTelevisedPlayingAreaSportsArena |
ParkingAreaAttendantOnlyParkingGarage |
ParkingAreaPedestrianParkingGarage |
PatientRoomHospitalOrHealthcare |
PersonalServicesSalesAreaRetail |
PharmacyHospitalOrHealthcare |
PhysicalTherapyHospitalOrHealthcare |
PlayingAreaGymnasium |
Plenum |
PoliceStationLaboratoryPoliceOrFireStations |
PublicAndStaffLoungeHospitalOrHealthcare |
ReadingAreaLibrary |
ReceptionOrWaitingTransportation |
ReceptionOrWaitingMotel |
ReceptionOrWaitingHotel |
RecoveryHospitalOrHealthcare |
RestorationMuseum |
Restrooms |
RingSportsAreaSportsArena |
SleepingQuartersPoliceOrFireStation |
SortingAreaPostOffice |
SpecialtyStoreSalesAreaRetail |
StacksLibrary |
StairsInactive |
Stairway |
SupermarketSalesAreaRetail |
TerminalTicketCounterTransportation |
WorkshopWorkshop |
WorshipPulpitChoirReligious |
NoOfSpaceTypes |

See Also

Autodesk.Revit.DB.Analysis Namespace


gbXMLSurfaceType Enumeration

[image]

Revit 2013 API
gbXMLSurfaceType Enumeration
See Also Send Feedback
This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum gbXMLSurfaceType
Visual Basic
Public Enumeration gbXMLSurfaceType
Visual C++
public enum class gbXMLSurfaceType

Members

Member name | Description
InteriorWall | Interior wall.
ExteriorWall | Exterior wall.
Roof | Roof.
InteriorFloor | Interior floor.
Shade | Shade.
UndergroundWall | Underground wall.
UndergroundSlab | Underground slab.
Ceiling | Ceiling.
SurfaceAir | Surface air.
UndergroundCeiling | Underground ceiling.
RaisedFloor | Raised floor.
SlabOnGrade | Slab on grade.
NoOfSurfaceTypes | No of surface types.

See Also

Autodesk.Revit.DB.Analysis Namespace


HVACLoadConstructionClass Enumeration

[image]

Revit 2013 API
HVACLoadConstructionClass Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum HVACLoadConstructionClass
Visual Basic
Public Enumeration HVACLoadConstructionClass
Visual C++
public enum class HVACLoadConstructionClass

Members

Member name | Description
LooseConstruction | A loose construction has an infiltration level of approximately 0.076 cfm/sqft
MediumConstruction | A medium construction has an infiltration level of approximately 0.038 cfm/sqft
TightConstruction | A tight construction has an infiltration level of approximately 0.019 cfm/sqft
NoneConstruction | A none construction has an infiltration level of 0 cfm/sqft

See Also

Autodesk.Revit.DB.Analysis Namespace


HVACLoadLoadsReportType Enumeration

[image]

Revit 2013 API
HVACLoadLoadsReportType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum HVACLoadLoadsReportType
Visual Basic
Public Enumeration HVACLoadLoadsReportType
Visual C++
public enum class HVACLoadLoadsReportType

Members

Member name | Description
NoReport | No report
SimpleReport | A simple report with summaries
StandardReport | A standard report including zones and spaces
DetailedReport | A detailed report including orientation breakdowns

See Also

Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Class

[image]

Revit 2013 API
MassEnergyAnalyticalModel Class
Members See Also Send Feedback
This class associates a mass instance with an energy analytical model data and geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassEnergyAnalyticalModel : Element
Visual Basic
Public Class MassEnergyAnalyticalModel _
    Inherits Element
Visual C++
public ref class MassEnergyAnalyticalModel : public Element

Remarks

The geometry begins as a copy of its associated mass instance geometry and is modified according to the requirements of the energy analytical model. MassZones are created from the MassEnergyAnalyticalModel and MassLevelDatas associated with a common mass instance.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..MassEnergyAnalyticalModel

See Also

MassEnergyAnalyticalModel Members
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Members

[image] [image]

Revit 2013 API
MassEnergyAnalyticalModel Members
MassEnergyAnalyticalModel Class Methods Properties See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
 | GetCoincidentEnergyAnalyticalModelFaceReference | Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.
 | GetCoincidentMassZoneFaceReferences | Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
 | GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
Public method | GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
Public method | GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
Public method | GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassId | The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.
Public property | MassZoneCoreOffset | If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Methods

[image] [image]

Revit 2013 API
MassEnergyAnalyticalModel Methods
MassEnergyAnalyticalModel Class See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
 | GetCoincidentEnergyAnalyticalModelFaceReference | Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.
 | GetCoincidentMassZoneFaceReferences | Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJoinedMassEnergyAnalyticalModelElementIds | The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.
 | GetMassEnergyAnalyticalModelIdForMassInstance | Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.
Public method | GetMassSurfaceDataIdForReference | Get the ElementId of the MassSurfaceData corresponding to the Reference.
Public method | GetMassZoneIds | Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencesToAllFaces | Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.
Public method | GetReferencesToAllShadingFaces | Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidSurfaceCategoryIdsForReference | The Mass surface subcategory ids that are appropriate values for the input Reference.
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentEnergyAnalyticalModelFaceReference Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetCoincidentEnergyAnalyticalModelFaceReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Returns a Reference to a Face from the same or a different MassEnergyAnalyticalModel that is coincident with the input Face.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Reference GetCoincidentEnergyAnalyticalModelFaceReference(
    Document document,
    Reference referenceToFace
)
Visual Basic
Public Shared Function GetCoincidentEnergyAnalyticalModelFaceReference ( _
    document As Document, _
    referenceToFace As Reference _
) As Reference
Visual C++
public:
static Reference^ GetCoincidentEnergyAnalyticalModelFaceReference(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::..Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Remarks

The result is always a Reference to a Face. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentMassZoneFaceReferences Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetCoincidentMassZoneFaceReferences Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Reference> GetCoincidentMassZoneFaceReferences(
    Document document,
    Reference referenceToFace
)
Visual Basic
Public Shared Function GetCoincidentMassZoneFaceReferences ( _
    document As Document, _
    referenceToFace As Reference _
) As IList(Of Reference)
Visual C++
public:
static IList<Reference^>^ GetCoincidentMassZoneFaceReferences(
    Document^ document,
    Reference^ referenceToFace
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
referenceToFace
Type: Autodesk.Revit.DB..::..Reference
A Reference to a Face of a MassEnergyAnalyticalModel.

Return Value

Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.

Remarks

The results are always References to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetJoinedMassEnergyAnalyticalModelElementIds Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetJoinedMassEnergyAnalyticalModelElementIds Method
MassEnergyAnalyticalModel Class See Also Send Feedback
The ElementIds of other MassEnergyAnalyticalModels that are "joined" to this one.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetJoinedMassEnergyAnalyticalModelElementIds()
Visual Basic
Public Function GetJoinedMassEnergyAnalyticalModelElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetJoinedMassEnergyAnalyticalModelElementIds()

Return Value

ElementIds of other MassEnergyAnalyticalModels that are joined to this one.

Remarks

Joined MassEnergyAnalyticalModels are created off of mass instances that are joined and which both have MassLevelData's associated. Only MassEnergyAnalyticalModels which are joined will take each other into account when regenerating surface subcategories for their Faces. For example, if two MassEnergyAnalyticalModels were adjacent but not joined, both their touching faces would be treated as "Mass Exterior Wall", instead of "Mass Interior Wall". This situation (touching things not being joined) because mass instances, and as a result, corresponding MassEnergyAnalyticalModel's are automatically joined and only become unjoined if the user unjoins them.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassEnergyAnalyticalModelIdForMassInstance Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetMassEnergyAnalyticalModelIdForMassInstance Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the ElementId of the MassEnergyAnalyticalModel for a mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ElementId GetMassEnergyAnalyticalModelIdForMassInstance(
    Document document,
    ElementId massInstanceId
)
Visual Basic
Public Shared Function GetMassEnergyAnalyticalModelIdForMassInstance ( _
    document As Document, _
    massInstanceId As ElementId _
) As ElementId
Visual C++
public:
static ElementId^ GetMassEnergyAnalyticalModelIdForMassInstance(
    Document^ document,
    ElementId^ massInstanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The Document.
massInstanceId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of a mass instance.

Return Value

ElementId of a MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId massInstanceId is not a mass instance.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassSurfaceDataIdForReference Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetMassSurfaceDataIdForReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the ElementId of the MassSurfaceData corresponding to the Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetMassSurfaceDataIdForReference(
    Reference reference
)
Visual Basic
Public Function GetMassSurfaceDataIdForReference ( _
    reference As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassSurfaceDataIdForReference(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A Reference to a face of this MassEnergyAnalyticalModel.

Return Value

ElementId of a MassSurfaceData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetMassZoneIds Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetMassZoneIds Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get the MassZone ElementIds that are created from this MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetMassZoneIds()
Visual Basic
Public Function GetMassZoneIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetMassZoneIds()

Return Value

Returns the ElementIds of MassZones.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToAllFaces Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetReferencesToAllFaces Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get References to all Faces which are meaningful for the MassEnergyAnalyticalModel. Array of References to Faces of the MassEnergyAnalyticalModel.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Reference> GetReferencesToAllFaces()
Visual Basic
Public Function GetReferencesToAllFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllFaces()

Remarks

The results are always references to Faces.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToAllShadingFaces Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetReferencesToAllShadingFaces Method
MassEnergyAnalyticalModel Class See Also Send Feedback
Get References to all Faces of the MassEnergyAnalyticalModel which are of Mass Shade subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Reference> GetReferencesToAllShadingFaces()
Visual Basic
Public Function GetReferencesToAllShadingFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToAllShadingFaces()

Return Value

Array of Reference to Faces that represent Mass Shades.

Remarks

Called out as a separate convenience method because often it is more useful to obtain information about non-shading faces from the zones, and only get information about shading faces from the MassEnergyAnalyticalModel.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


GetValidSurfaceCategoryIdsForReference Method

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..GetValidSurfaceCategoryIdsForReference Method
MassEnergyAnalyticalModel Class See Also Send Feedback
The Mass surface subcategory ids that are appropriate values for the input Reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ElementId> GetValidSurfaceCategoryIdsForReference(
    Reference reference,
    out ElementId recommendedDefaultSubcategoryId
)
Visual Basic
Public Function GetValidSurfaceCategoryIdsForReference ( _
    reference As Reference, _
    <OutAttribute> ByRef recommendedDefaultSubcategoryId As ElementId _
) As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetValidSurfaceCategoryIdsForReference(
    Reference^ reference,
    [OutAttribute] ElementId^% recommendedDefaultSubcategoryId
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A Reference to a Face of this MassEnergyAnalyticalModel.
recommendedDefaultSubcategoryId
Type: Autodesk.Revit.DB..::..ElementId%
The ElementId that is recommended as the default setting for this pick.

Return Value

Returns the ElementIds of appropriate values for input Reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Reference is not a Face of this MassEnergyAnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModel Properties

[image] [image]

Revit 2013 API
MassEnergyAnalyticalModel Properties
MassEnergyAnalyticalModel Class See Also Send Feedback

The MassEnergyAnalyticalModel type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassId | The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.
Public property | MassZoneCoreOffset | If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassId Property

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..MassId Property
MassEnergyAnalyticalModel Class See Also Send Feedback
The ElementId of the mass instance the MassEnergyAnalyticalModel is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MassId { get; }
Visual Basic
Public ReadOnly Property MassId As ElementId
    Get
Visual C++
public:
property ElementId^ MassId {
    ElementId^ get ();
}

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneCoreOffset Property

[image]

Revit 2013 API
MassEnergyAnalyticalModel..::..MassZoneCoreOffset Property
MassEnergyAnalyticalModel Class See Also Send Feedback
If this value is greater than 0.0, in the MassEnergyAnalytical model a building "core" geometry will be created for each solid geometry of the mass instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double MassZoneCoreOffset { get; set; }
Visual Basic
Public Property MassZoneCoreOffset As Double
    Get
    Set
Visual C++
public:
property double MassZoneCoreOffset {
    double get ();
    void set (double value);
}

Remarks

The resulting "core" geometry created inside the mass instance solid geometry is offset inwards at each level intersecting the mass instance solid geometry by the value of the offset. This "core" geometry is automatically cut from its parent mass instance geometry in the MassEnergyAnalyticalModel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The massZoneCoreOffset is less than zero.

See Also

MassEnergyAnalyticalModel Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
MassEnergyAnalyticalModel..::..Parameter Property
MassEnergyAnalyticalModel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MassEnergyAnalyticalModel Class
MassEnergyAnalyticalModel Members
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Class

[image]

Revit 2013 API
MassGBXMLExportOptions Class
Members See Also Send Feedback
Options used when exporting a gbXML file from a mass model document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassGBXMLExportOptions : IDisposable
Visual Basic
Public Class MassGBXMLExportOptions _
    Implements IDisposable
Visual C++
public ref class MassGBXMLExportOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..MassGBXMLExportOptions

See Also

MassGBXMLExportOptions Members
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Members

[image] [image]

Revit 2013 API
MassGBXMLExportOptions Members
MassGBXMLExportOptions Class Constructors Methods See Also Send Feedback

The MassGBXMLExportOptions type exposes the following members.

Constructors

 | Name | Description
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>), IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MassGBXMLExportOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method | GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Constructor

[image] [image]

Revit 2013 API
MassGBXMLExportOptions Constructor
MassGBXMLExportOptions Class See Also Send Feedback

Overload List

 | Name | Description
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.
Public method | MassGBXMLExportOptions(IList<(Of <<'(ElementId>)>>), IList<(Of <<'(ElementId>)>>)) | Constructs a new instance of the options used to export a mass model to gbXML.

See Also

MassGBXMLExportOptions Class
MassGBXMLExportOptions Members
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Constructor (IList(ElementId))

[image]

Revit 2013 API
MassGBXMLExportOptions Constructor (IList<(Of <(<'ElementId>)>)>)
MassGBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassGBXMLExportOptions(
    IList<ElementId> massZoneIds
)
Visual Basic
Public Sub New ( _
    massZoneIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
    IList<ElementId^>^ massZoneIds
)

Parameters

massZoneIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Indicates the mass zones to analyze in the exported gbXML.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassGBXMLExportOptions Class
MassGBXMLExportOptions Overload
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Constructor (IList(ElementId), IList(ElementId))

[image]

Revit 2013 API
MassGBXMLExportOptions Constructor (IList<(Of <(<'ElementId>)>)>, IList<(Of <(<'ElementId>)>)>)
MassGBXMLExportOptions Class See Also Send Feedback
Constructs a new instance of the options used to export a mass model to gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassGBXMLExportOptions(
    IList<ElementId> massZoneIds,
    IList<ElementId> massIds
)
Visual Basic
Public Sub New ( _
    massZoneIds As IList(Of ElementId), _
    massIds As IList(Of ElementId) _
)
Visual C++
public:
MassGBXMLExportOptions(
    IList<ElementId^>^ massZoneIds,
    IList<ElementId^>^ massIds
)

Parameters

massZoneIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Indicates the mass zones to analyze in the exported gbXML.
massIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
Indicates the masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassGBXMLExportOptions Class
MassGBXMLExportOptions Overload
Autodesk.Revit.DB.Analysis Namespace


MassGBXMLExportOptions Methods

[image] [image]

Revit 2013 API
MassGBXMLExportOptions Methods
MassGBXMLExportOptions Class See Also Send Feedback

The MassGBXMLExportOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMassIds | Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.
Public method | GetMassZoneIds | Gets a list of mass zones to analyze in the exported gbXML.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
MassGBXMLExportOptions..::..Dispose Method
MassGBXMLExportOptions Class See Also Send Feedback
Releases all resources used by the MassGBXMLExportOptions

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


GetMassIds Method

[image]

Revit 2013 API
MassGBXMLExportOptions..::..GetMassIds Method
MassGBXMLExportOptions Class See Also Send Feedback
Gets a list of masses to use as shading surfaces in the exported gbXML--these masses must not have mass floors or mass zones so as not to end up with duplicate surface information in the gbXML output.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ElementId> GetMassIds()
Visual Basic
Public Function GetMassIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMassIds()

Return Value

The ids of the masses.

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


GetMassZoneIds Method

[image]

Revit 2013 API
MassGBXMLExportOptions..::..GetMassZoneIds Method
MassGBXMLExportOptions Class See Also Send Feedback
Gets a list of mass zones to analyze in the exported gbXML.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ElementId> GetMassZoneIds()
Visual Basic
Public Function GetMassZoneIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetMassZoneIds()

Return Value

The ids of the mass zone.

See Also

MassGBXMLExportOptions Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Class

[image]

Revit 2013 API
MassLevelData Class
Members See Also Send Feedback
MassLevelData is a conceptual representation of an occupiable floor (Mass Floor) in a conceptual building model. It is defined by associating a particular level with a particular mass element in a Revit project.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassLevelData : Element
Visual Basic
Public Class MassLevelData _
    Inherits Element
Visual C++
public ref class MassLevelData : public Element

Remarks

MassLevelData reports metrics, such as floor areas, related to conceptual space planning. MassLevelData contains information, such as ConceptualConstructionType, used as part of the Conceptual Energy Analytical model. The MassLevel data geometry is determined by combining all the geometry of a mass into a single geometry, and then taking the area of intersection with the level of the MassLevelData.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..MassLevelData

See Also

MassLevelData Members
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Members

[image] [image]

Revit 2013 API
MassLevelData Members
MassLevelData Class Methods Properties See Also Send Feedback

The MassLevelData type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelId | The ElementId of the level that the MassLevelData (Mass Floor) is associated with.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Methods

[image] [image]

Revit 2013 API
MassLevelData Methods
MassLevelData Class See Also Send Feedback

The MassLevelData type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsMassFamilyInstance | Checks if the ElementId is a mass family instance.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidConceptualConstructionTypeElement | Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsEmpty Method

[image]

Revit 2013 API
MassLevelData..::..IsEmpty Method
MassLevelData Class See Also Send Feedback
Indicates if the MassLevelData (Mass Floor) has a geometrical representation. May not if the level does not intersect the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

Returns True if MassLevelData is dimensionless, False otherwise.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsMassFamilyInstance Method

[image]

Revit 2013 API
MassLevelData..::..IsMassFamilyInstance Method
MassLevelData Class See Also Send Feedback
Checks if the ElementId is a mass family instance.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsMassFamilyInstance(
    Document document,
    ElementId id
)
Visual Basic
Public Shared Function IsMassFamilyInstance ( _
    document As Document, _
    id As ElementId _
) As Boolean
Visual C++
public:
static bool IsMassFamilyInstance(
    Document^ document,
    ElementId^ id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be checked.

Return Value

True if the ElementId is a mass family instance, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


IsValidConceptualConstructionTypeElement Method

[image]

Revit 2013 API
MassLevelData..::..IsValidConceptualConstructionTypeElement Method
MassLevelData Class See Also Send Feedback
Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidConceptualConstructionTypeElement(
    ElementId id
)
Visual Basic
Public Function IsValidConceptualConstructionTypeElement ( _
    id As ElementId _
) As Boolean
Visual C++
public:
bool IsValidConceptualConstructionTypeElement(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be checked.

Return Value

True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.

Remarks

In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelData Properties

[image] [image]

Revit 2013 API
MassLevelData Properties
MassLevelData Class See Also Send Feedback

The MassLevelData type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConceptualConstructionId | The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).
Public property | ConceptualConstructionIsByEnergyData | Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelId | The ElementId of the level that the MassLevelData (Mass Floor) is associated with.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the visualization material used for the MassLevelData (Mass Floor)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NExteriorSurfaceArea | The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | NLevelFafArea | The surface area of the intersection of the MassLevelData's level with the mass geometry.
Public property | NLevelPerimeter | The perimeter of the intersection of the MassLevelData's level with the mass geometry.
Public property | NVolume | The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | OwningMassId | The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StrUsage | A String which describes the usage or occupancy type of the level of the MassLevelData.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionId Property

[image]

Revit 2013 API
MassLevelData..::..ConceptualConstructionId Property
MassLevelData Class See Also Send Feedback
The ElementId of the conceptual construction associated with the MassLevelData (Mass Floor).

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ConceptualConstructionId { get; set; }
Visual Basic
Public Property ConceptualConstructionId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input ElementId conceptualConstructionId is not a valid conceptual construction type ElementId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionIsByEnergyData Property

[image]

Revit 2013 API
MassLevelData..::..ConceptualConstructionIsByEnergyData Property
MassLevelData Class See Also Send Feedback
Indicates if the ConceptualConstructionType of the MassLevelData (Mass Floor) is synchronized with the EnergyDataSettings or if it overrides those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ConceptualConstructionIsByEnergyData { get; set; }
Visual Basic
Public Property ConceptualConstructionIsByEnergyData As Boolean
    Get
    Set
Visual C++
public:
property bool ConceptualConstructionIsByEnergyData {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: ConceptualConstructionIsByEnergyData cannot be set to conceptualConstructionIsByEnergyData.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


LevelId Property

[image]

Revit 2013 API
MassLevelData..::..LevelId Property
MassLevelData Class See Also Send Feedback
The ElementId of the level that the MassLevelData (Mass Floor) is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LevelId { get; }
Visual Basic
Public ReadOnly Property LevelId As ElementId
    Get
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2013 API
MassLevelData..::..MaterialId Property
MassLevelData Class See Also Send Feedback
The ElementId of the visualization material used for the MassLevelData (Mass Floor)

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element materialId is not a material element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2013 API
MassLevelData..::..MaterialType Property
MassLevelData Class See Also Send Feedback
Indicates if the material used for the graphical appearance is by category or a specific material, or if the material to be used should be taken from the ConceptualConstructionType of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic
Public Property MaterialType As MassSurfaceDataMaterialType
    Get
    Set
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The material type does not fall within an appropriate range.

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NExteriorSurfaceArea Property

[image]

Revit 2013 API
MassLevelData..::..NExteriorSurfaceArea Property
MassLevelData Class See Also Send Feedback
The exterior surface area of the volume of the mass between the level of this MassLevelData (Mass Floor) to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NExteriorSurfaceArea { get; }
Visual Basic
Public ReadOnly Property NExteriorSurfaceArea As Double
    Get
Visual C++
public:
property double NExteriorSurfaceArea {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NLevelFafArea Property

[image]

Revit 2013 API
MassLevelData..::..NLevelFafArea Property
MassLevelData Class See Also Send Feedback
The surface area of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NLevelFafArea { get; }
Visual Basic
Public ReadOnly Property NLevelFafArea As Double
    Get
Visual C++
public:
property double NLevelFafArea {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NLevelPerimeter Property

[image]

Revit 2013 API
MassLevelData..::..NLevelPerimeter Property
MassLevelData Class See Also Send Feedback
The perimeter of the intersection of the MassLevelData's level with the mass geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NLevelPerimeter { get; }
Visual Basic
Public ReadOnly Property NLevelPerimeter As Double
    Get
Visual C++
public:
property double NLevelPerimeter {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


NVolume Property

[image]

Revit 2013 API
MassLevelData..::..NVolume Property
MassLevelData Class See Also Send Feedback
The volume of from the level of this MassLevelData (Mass Floor) to the next in the mass.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double NVolume { get; }
Visual Basic
Public ReadOnly Property NVolume As Double
    Get
Visual C++
public:
property double NVolume {
    double get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


OwningMassId Property

[image]

Revit 2013 API
MassLevelData..::..OwningMassId Property
MassLevelData Class See Also Send Feedback
The ElementId of the mass that the MassLevelData (Mass Floor) is associated with.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId OwningMassId { get; }
Visual Basic
Public ReadOnly Property OwningMassId As ElementId
    Get
Visual C++
public:
property ElementId^ OwningMassId {
    ElementId^ get ();
}

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
MassLevelData..::..Parameter Property
MassLevelData Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MassLevelData Class
MassLevelData Members
Autodesk.Revit.DB.Analysis Namespace


StrUsage Property

[image]

Revit 2013 API
MassLevelData..::..StrUsage Property
MassLevelData Class See Also Send Feedback
A String which describes the usage or occupancy type of the level of the MassLevelData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string StrUsage { get; set; }
Visual Basic
Public Property StrUsage As String
    Get
    Set
Visual C++
public:
property String^ StrUsage {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassLevelData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Class

[image]

Revit 2013 API
MassSurfaceData Class
Members See Also Send Feedback
Holds properties and other data about a face in the MassEnergyAnalyticalModel element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassSurfaceData : Element
Visual Basic
Public Class MassSurfaceData _
    Inherits Element
Visual C++
public ref class MassSurfaceData : public Element

Remarks

Properties stored in the MassSurfaceData can be used in regeneration by the MassEnergyAnalyticalModel. For example, faces of the MassEnergyAnalyticalModel take their material values from the settings in the MassSurfaceData.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..MassSurfaceData

See Also

MassSurfaceData Members
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Members

[image] [image]

Revit 2013 API
MassSurfaceData Members
MassSurfaceData Class Methods Properties See Also Send Feedback

The MassSurfaceData type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | material type of mass zone
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Methods

[image] [image]

Revit 2013 API
MassSurfaceData Methods
MassSurfaceData Class See Also Send Feedback

The MassSurfaceData type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFaceReferences | Gets References to the faces that the MassSurfaceData provides properties for.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


GetFaceReferences Method

[image]

Revit 2013 API
MassSurfaceData..::..GetFaceReferences Method
MassSurfaceData Class See Also Send Feedback
Gets References to the faces that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Reference> GetFaceReferences()
Visual Basic
Public Function GetFaceReferences As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetFaceReferences()

Return Value

Returns an array of References to Faces that the MassSurfaceData provides properties for.

Remarks

The results are always references to Faces. The Reference Type should be REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceData Properties

[image] [image]

Revit 2013 API
MassSurfaceData Properties
MassSurfaceData Class See Also Send Feedback

The MassSurfaceData type exposes the following members.

Properties

 | Name | Description
Public property | Area | Area of the references that the MassSurfaceData provides properties for.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CategoryIdForConceptualSurfaceType | Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.
Public property | ConceptualConstructionId | The id of the conceptual construction associated with the reference surface.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsConceptualConstructionByEnergyData | True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.
Public property | IsGlazingShaded | Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.
Public property | IsSlab | Indicates if a floor is a slab.
Public property | IsUnderground | Indicates if the roof, floor, slab, or wall surface reference is underground.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MassLevelDataId | The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.
Public property | MaterialId | The visualization material used for the surface for displaying the energy analytical model.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | material type of mass zone
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PercentageGlazing | The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.
Public property | PercentageSkylights | The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceElementId | The ElementId of the element whose face the MassSurfaceData primarily refers to.
Public property | ShadeDepth | How far any auto-generated shades should extend from the wall surface.
Public property | SillHeight | The height above the level where the bottoms of auto-generated windows will be located.
Public property | SkylightWidth | The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.
Public property | SurfaceDataSource | Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


Area Property

[image]

Revit 2013 API
MassSurfaceData..::..Area Property
MassSurfaceData Class See Also Send Feedback
Area of the references that the MassSurfaceData provides properties for.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

Remarks

If it is used, should be greater than zero. Otherwise, it will be zero.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


CategoryIdForConceptualSurfaceType Property

[image]

Revit 2013 API
MassSurfaceData..::..CategoryIdForConceptualSurfaceType Property
MassSurfaceData Class See Also Send Feedback
Returns the mass subcategory ElementId used for ConceptualSurfaceType for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId CategoryIdForConceptualSurfaceType { get; }
Visual Basic
Public ReadOnly Property CategoryIdForConceptualSurfaceType As ElementId
    Get
Visual C++
public:
property ElementId^ CategoryIdForConceptualSurfaceType {
    ElementId^ get ();
}

Remarks

This value is determined by starting with the subcategory property and adjusting it according to properties such as "isSlab" or "isUnderground".

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ConceptualConstructionId Property

[image]

Revit 2013 API
MassSurfaceData..::..ConceptualConstructionId Property
MassSurfaceData Class See Also Send Feedback
The id of the conceptual construction associated with the reference surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ConceptualConstructionId { get; set; }
Visual Basic
Public Property ConceptualConstructionId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ConceptualConstructionId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element conceptualConstructionId is not a valid ConceptualConstructionType element id.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsConceptualConstructionByEnergyData Property

[image]

Revit 2013 API
MassSurfaceData..::..IsConceptualConstructionByEnergyData Property
MassSurfaceData Class See Also Send Feedback
True when the ConceptualConstructionType id is synchronized to the EnergyDataSettings. False when the ConceptualConstructionType id is overridden for this MassSurfaceData.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsConceptualConstructionByEnergyData { get; set; }
Visual Basic
Public Property IsConceptualConstructionByEnergyData As Boolean
    Get
    Set
Visual C++
public:
property bool IsConceptualConstructionByEnergyData {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: ConceptualConstructionIsByEnergyData cannot be set to conceptualConstructionIsByEnergyData.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsGlazingShaded Property

[image]

Revit 2013 API
MassSurfaceData..::..IsGlazingShaded Property
MassSurfaceData Class See Also Send Feedback
Indicates if shade geometry is auto-generated on the top edge of auto-generated glazing.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsGlazingShaded { get; set; }
Visual Basic
Public Property IsGlazingShaded As Boolean
    Get
    Set
Visual C++
public:
property bool IsGlazingShaded {
    bool get ();
    void set (bool value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsSlab Property

[image]

Revit 2013 API
MassSurfaceData..::..IsSlab Property
MassSurfaceData Class See Also Send Feedback
Indicates if a floor is a slab.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsSlab { get; }
Visual Basic
Public ReadOnly Property IsSlab As Boolean
    Get
Visual C++
public:
property bool IsSlab {
    bool get ();
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


IsUnderground Property

[image]

Revit 2013 API
MassSurfaceData..::..IsUnderground Property
MassSurfaceData Class See Also Send Feedback
Indicates if the roof, floor, slab, or wall surface reference is underground.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsUnderground { get; set; }
Visual Basic
Public Property IsUnderground As Boolean
    Get
    Set
Visual C++
public:
property bool IsUnderground {
    bool get ();
    void set (bool value);
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassLevelDataId Property

[image]

Revit 2013 API
MassSurfaceData..::..MassLevelDataId Property
MassSurfaceData Class See Also Send Feedback
The MassLevelData used when the surface is horizontal, planar, and at the same height as a MassLevelData related to the same mass as the referenced face.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MassLevelDataId { get; }
Visual Basic
Public ReadOnly Property MassLevelDataId As ElementId
    Get
Visual C++
public:
property ElementId^ MassLevelDataId {
    ElementId^ get ();
}

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2013 API
MassSurfaceData..::..MaterialId Property
MassSurfaceData Class See Also Send Feedback
The visualization material used for the surface for displaying the energy analytical model.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element materialId is not a material element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2013 API
MassSurfaceData..::..MaterialType Property
MassSurfaceData Class See Also Send Feedback
material type of mass zone

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassSurfaceDataMaterialType MaterialType { get; set; }
Visual Basic
Public Property MaterialType As MassSurfaceDataMaterialType
    Get
    Set
Visual C++
public:
property MassSurfaceDataMaterialType MaterialType {
    MassSurfaceDataMaterialType get ();
    void set (MassSurfaceDataMaterialType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The material type does not fall within an appropriate range.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
MassSurfaceData..::..Parameter Property
MassSurfaceData Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MassSurfaceData Class
MassSurfaceData Members
Autodesk.Revit.DB.Analysis Namespace


PercentageGlazing Property

[image]

Revit 2013 API
MassSurfaceData..::..PercentageGlazing Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference wall surface that is to be covered with automatically generated windows. Revit will use this number when determining the size, shape, and location of automatically generated windows.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double PercentageGlazing { get; set; }
Visual Basic
Public Property PercentageGlazing As Double
    Get
    Set
Visual C++
public:
property double PercentageGlazing {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the wall with windows is not guaranteed to match this value. It is a target.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage glazing value is not between 0.00 and 0.95.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


PercentageSkylights Property

[image]

Revit 2013 API
MassSurfaceData..::..PercentageSkylights Property
MassSurfaceData Class See Also Send Feedback
The target percentage of the reference roof surface that is to be covered with automatically generated skylights. Revit will use this number when determining the size, shape, and location of automatically generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double PercentageSkylights { get; set; }
Visual Basic
Public Property PercentageSkylights As Double
    Get
    Set
Visual C++
public:
property double PercentageSkylights {
    double get ();
    void set (double value);
}

Remarks

The resulting coverage of the roof with skylights is not guaranteed to match this value. It is a target.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage skylights value is between 0.00 and 0.95.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ReferenceElementId Property

[image]

Revit 2013 API
MassSurfaceData..::..ReferenceElementId Property
MassSurfaceData Class See Also Send Feedback
The ElementId of the element whose face the MassSurfaceData primarily refers to.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ReferenceElementId { get; }
Visual Basic
Public ReadOnly Property ReferenceElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ReferenceElementId {
    ElementId^ get ();
}

Remarks

A MassSurfaceData may represent multiple faces from the same or different elements. This generally only happens if the faces are geometrically fully coincident and logically represent a single building object. "Interior walls" of the conceptual energy building model is a common example where two different faces may be represented by a single MassSurfaceData.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


ShadeDepth Property

[image]

Revit 2013 API
MassSurfaceData..::..ShadeDepth Property
MassSurfaceData Class See Also Send Feedback
How far any auto-generated shades should extend from the wall surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ShadeDepth { get; set; }
Visual Basic
Public Property ShadeDepth As Double
    Get
    Set
Visual C++
public:
property double ShadeDepth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shade depth is less than zero.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SillHeight Property

[image]

Revit 2013 API
MassSurfaceData..::..SillHeight Property
MassSurfaceData Class See Also Send Feedback
The height above the level where the bottoms of auto-generated windows will be located.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double SillHeight { get; set; }
Visual Basic
Public Property SillHeight As Double
    Get
    Set
Visual C++
public:
property double SillHeight {
    double get ();
    void set (double value);
}

Remarks

Will be accurate unless the target glazing percentage cannot be achieved using this height. In that case, the sillHeight will be ignored and windows will be created below this height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The sill height is less than zero.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SkylightWidth Property

[image]

Revit 2013 API
MassSurfaceData..::..SkylightWidth Property
MassSurfaceData Class See Also Send Feedback
The length dimension to be used for the sides of each individual square skylight produced in the grid of auto-generated skylights.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double SkylightWidth { get; set; }
Visual Basic
Public Property SkylightWidth As Double
    Get
    Set
Visual C++
public:
property double SkylightWidth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The skylight width is less than eight inches.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


SurfaceDataSource Property

[image]

Revit 2013 API
MassSurfaceData..::..SurfaceDataSource Property
MassSurfaceData Class See Also Send Feedback
Indicates whether the MassSurfaceData properties are driven by the EnergyDataSettings of the Document or are overridden for the surface.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassSurfaceDataSource SurfaceDataSource { get; set; }
Visual Basic
Public Property SurfaceDataSource As MassSurfaceDataSource
    Get
    Set
Visual C++
public:
property MassSurfaceDataSource SurfaceDataSource {
    MassSurfaceDataSource get ();
    void set (MassSurfaceDataSource value);
}

Remarks

The Construction property is not governed by this setting and has a separate value to indicate if it is to be synchronized with EnergyDataSettings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The surface data source does not fall within an appropriate range.

See Also

MassSurfaceData Class
Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataMaterialType Enumeration

[image]

Revit 2013 API
MassSurfaceDataMaterialType Enumeration
See Also Send Feedback
Indicates how the visualization material for the MassSurfaceData is calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MassSurfaceDataMaterialType
Visual Basic
Public Enumeration MassSurfaceDataMaterialType
Visual C++
public enum class MassSurfaceDataMaterialType

Members

Member name | Description
MaterialByConstruction | The visualization material for the MassSurfaceData will be taken from the material assigned to the ConceptualConstructionType which is assigned to the MassSurfaceData.
NormalMaterial | The visualization material for the MassSurfaceData will be taken from the material associated with the object style of the subcategory of the MassSurfaceData if the materialId is InvalidElementId, or the MassSurfaceData will use the specific material indicated by the materialId property if its value is an ElementId of a MaterialElement.

See Also

Autodesk.Revit.DB.Analysis Namespace


MassSurfaceDataSource Enumeration

[image]

Revit 2013 API
MassSurfaceDataSource Enumeration
See Also Send Feedback
Indicates whether values for the properties of the MassSurfaceData are synchronized with the EnergyDataSettings of the document or instead, serve as overrides of those settings.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MassSurfaceDataSource
Visual Basic
Public Enumeration MassSurfaceDataSource
Visual C++
public enum class MassSurfaceDataSource

Members

Member name | Description
Invalid | This value indicates that the parameter has not been properly set.
EnergyData | Synchronize with the EnergyDataSettings.
Surface | Override the EnergyDataSettings values for the surface.

See Also

Autodesk.Revit.DB.Analysis Namespace


MassZone Class

[image]

Revit 2013 API
MassZone Class
Members See Also Send Feedback
MassZones are created from the MassEnergyAnalyticalModel. They are conceptual representations of individually heated and cooled sub-volumes of a building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MassZone : Element
Visual Basic
Public Class MassZone _
    Inherits Element
Visual C++
public ref class MassZone : public Element

Remarks

MassZones are created by dividing a MassEnergyAnalyticalModel into pieces by intersecting MassLevelDatas associated with a Mass FamilyInstance with the geometries of the MassEnergyAnalyticalModel associated with the same Mass FamilyInstance.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..MassZone

See Also

MassZone Members
Autodesk.Revit.DB.Analysis Namespace


MassZone Members

[image] [image]

Revit 2013 API
MassZone Members
MassZone Class Methods Properties See Also Send Feedback

The MassZone type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConditionType | The gbXMLConditionType of the MassZone.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
Public property | CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorArea | The floor area of the MassZone.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LowerLevelId | The bottom level defining the MassZone.
Public property | MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
Public property | MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Indicates how the material of MassZone faces is determined.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpaceType | The gbXMLSpaceType of the MassZone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLevelId | The upper level defining the MassZone.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of the MassZone.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZone Methods

[image] [image]

Revit 2013 API
MassZone Methods
MassZone Class See Also Send Feedback

The MassZone type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCoincidentReferenceFromAdjacentZone | This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEquivalentReferenceFromMassOrLevel | Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMassDataElementIdForZoneFaceReference | MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetReferencesToEnergyAnalysisFaces | Used to get References to all the faces of the MassZone that are used for Energy Analysis.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsEmpty | Indicates if MassZone has no geometry. Such zones should not be shown to the user.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetCoincidentReferenceFromAdjacentZone Method

[image]

Revit 2013 API
MassZone..::..GetCoincidentReferenceFromAdjacentZone Method
MassZone Class See Also Send Feedback
This method is used to get a Reference from an adjacent MassZone that is coincident to a Reference of this MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Reference GetCoincidentReferenceFromAdjacentZone(
    Reference referenceToZoneFace
)
Visual Basic
Public Function GetCoincidentReferenceFromAdjacentZone ( _
    referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetCoincidentReferenceFromAdjacentZone(
    Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB..::..Reference
Reference to face of MassZone.

Return Value

Reference to coincident face of adjacent MassZone or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no adjacent MassZone face Reference.

Remarks

The result is always a Reference to a Face. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE. The results are always references to Faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetEquivalentReferenceFromMassOrLevel Method

[image]

Revit 2013 API
MassZone..::..GetEquivalentReferenceFromMassOrLevel Method
MassZone Class See Also Send Feedback
Returns a Reference to a face of a MassEnergyAnalyticalModel element or an element Reference to a MassLevelData element. This Reference represents what the MassZone face was "cut from" when making the MassZone for the level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Reference GetEquivalentReferenceFromMassOrLevel(
    Reference referenceToZoneFace
)
Visual Basic
Public Function GetEquivalentReferenceFromMassOrLevel ( _
    referenceToZoneFace As Reference _
) As Reference
Visual C++
public:
Reference^ GetEquivalentReferenceFromMassOrLevel(
    Reference^ referenceToZoneFace
)

Parameters

referenceToZoneFace
Type: Autodesk.Revit.DB..::..Reference
Reference to a face of the zone to get an equivalent reference for.

Return Value

Reference to MassEnergyAnalyticalModel or MassLevelData. Should only be nullNothingnullptra null reference (Nothing in Visual Basic) if there is an error in the MassEnergyAnalyticalModel data or the input is not a

Remarks

If the Reference is to a MassLevelData element, it means that the MassEnergyAnalyticalModel element did not have an exterior face for this MassZone face. For this case, the MassZone face was created as the cross-section of the MassEnergyAnalyticalModel geometry where it was intersected by the level of the MassLevelData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetMassDataElementIdForZoneFaceReference Method

[image]

Revit 2013 API
MassZone..::..GetMassDataElementIdForZoneFaceReference Method
MassZone Class See Also Send Feedback
MassZone faces come from faces of MassEnergyAnalyticalModel, and those faces have MassSurfaceData or MassLevelData elements associated with them.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetMassDataElementIdForZoneFaceReference(
    Reference referenceOfZone
)
Visual Basic
Public Function GetMassDataElementIdForZoneFaceReference ( _
    referenceOfZone As Reference _
) As ElementId
Visual C++
public:
ElementId^ GetMassDataElementIdForZoneFaceReference(
    Reference^ referenceOfZone
)

Parameters

referenceOfZone
Type: Autodesk.Revit.DB..::..Reference
Reference to face of the MassZone to get data element for.

Return Value

Id of MassSurfaceData or MassLevelData element.

Remarks

This element will contain the properties associated with the MassEnergyAnalyticalModel face or MassLevelData that the MassZone Face is derived from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input Reference is not a face Reference of this MassZone.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


GetReferencesToEnergyAnalysisFaces Method

[image]

Revit 2013 API
MassZone..::..GetReferencesToEnergyAnalysisFaces Method
MassZone Class See Also Send Feedback
Used to get References to all the faces of the MassZone that are used for Energy Analysis.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Reference> GetReferencesToEnergyAnalysisFaces()
Visual Basic
Public Function GetReferencesToEnergyAnalysisFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetReferencesToEnergyAnalysisFaces()

Return Value

Array of References to faces of MassZone.

Remarks

These are the faces and face regions that are typically visible to the user when MassZones are displayed. There are other faces in the MassZone geometry that are not visible and not used for EnergyAnalysis.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


IsEmpty Method

[image]

Revit 2013 API
MassZone..::..IsEmpty Method
MassZone Class See Also Send Feedback
Indicates if MassZone has no geometry. Such zones should not be shown to the user.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsEmpty()
Visual Basic
Public Function IsEmpty As Boolean
Visual C++
public:
bool IsEmpty()

Return Value

Returns True if MassZone has no geometry.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZone Properties

[image] [image]

Revit 2013 API
MassZone Properties
MassZone Class See Also Send Feedback

The MassZone type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConditionType | The gbXMLConditionType of the MassZone.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutByLowerLevel | Indicates the relationship between the MassZone and its lower level.
Public property | CutByUpperLevel | Indicates the relationship between the MassZone and its upper level.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorArea | The floor area of the MassZone.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsZoneOccupiable | A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LowerLevelId | The bottom level defining the MassZone.
Public property | MassEnergyAnalyticalModelId | The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.
Public property | MaterialId | The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Indicates how the material of MassZone faces is determined.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpaceType | The gbXMLSpaceType of the MassZone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLevelId | The upper level defining the MassZone.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of the MassZone.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


ConditionType Property

[image]

Revit 2013 API
MassZone..::..ConditionType Property
MassZone Class See Also Send Feedback
The gbXMLConditionType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public gbXMLConditionType ConditionType { get; set; }
Visual Basic
Public Property ConditionType As gbXMLConditionType
    Get
    Set
Visual C++
public:
property gbXMLConditionType ConditionType {
    gbXMLConditionType get ();
    void set (gbXMLConditionType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The condition type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


CutByLowerLevel Property

[image]

Revit 2013 API
MassZone..::..CutByLowerLevel Property
MassZone Class See Also Send Feedback
Indicates the relationship between the MassZone and its lower level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassZoneLevelCutState CutByLowerLevel { get; }
Visual Basic
Public ReadOnly Property CutByLowerLevel As MassZoneLevelCutState
    Get
Visual C++
public:
property MassZoneLevelCutState CutByLowerLevel {
    MassZoneLevelCutState get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


CutByUpperLevel Property

[image]

Revit 2013 API
MassZone..::..CutByUpperLevel Property
MassZone Class See Also Send Feedback
Indicates the relationship between the MassZone and its upper level.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassZoneLevelCutState CutByUpperLevel { get; }
Visual Basic
Public ReadOnly Property CutByUpperLevel As MassZoneLevelCutState
    Get
Visual C++
public:
property MassZoneLevelCutState CutByUpperLevel {
    MassZoneLevelCutState get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


FloorArea Property

[image]

Revit 2013 API
MassZone..::..FloorArea Property
MassZone Class See Also Send Feedback
The floor area of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double FloorArea { get; }
Visual Basic
Public ReadOnly Property FloorArea As Double
    Get
Visual C++
public:
property double FloorArea {
    double get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


IsZoneOccupiable Property

[image]

Revit 2013 API
MassZone..::..IsZoneOccupiable Property
MassZone Class See Also Send Feedback
A MassZone must have a level as its bottom to be occupiable; If it does not, it is still a MassZone, but it is not occupiable

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsZoneOccupiable { get; }
Visual Basic
Public ReadOnly Property IsZoneOccupiable As Boolean
    Get
Visual C++
public:
property bool IsZoneOccupiable {
    bool get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


LowerLevelId Property

[image]

Revit 2013 API
MassZone..::..LowerLevelId Property
MassZone Class See Also Send Feedback
The bottom level defining the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LowerLevelId { get; }
Visual Basic
Public ReadOnly Property LowerLevelId As ElementId
    Get
Visual C++
public:
property ElementId^ LowerLevelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassEnergyAnalyticalModelId Property

[image]

Revit 2013 API
MassZone..::..MassEnergyAnalyticalModelId Property
MassZone Class See Also Send Feedback
The ElementId of the MassEnergyAnalyticalModel that the MassZone is derived from.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MassEnergyAnalyticalModelId { get; }
Visual Basic
Public ReadOnly Property MassEnergyAnalyticalModelId As ElementId
    Get
Visual C++
public:
property ElementId^ MassEnergyAnalyticalModelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MaterialId Property

[image]

Revit 2013 API
MassZone..::..MaterialId Property
MassZone Class See Also Send Feedback
The visualization material for the MassZone. Will be InvalidElementId if material is by category or the material type is by MassZoneMaterialTypeMaterialBySurfaceType.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The input element materialId is not a material element. -or- When setting this property: The MassZone does not have normal material type handling, so the material setting is not appropriate.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MaterialType Property

[image]

Revit 2013 API
MassZone..::..MaterialType Property
MassZone Class See Also Send Feedback
Indicates how the material of MassZone faces is determined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public MassZoneMaterialType MaterialType { get; set; }
Visual Basic
Public Property MaterialType As MassZoneMaterialType
    Get
    Set
Visual C++
public:
property MassZoneMaterialType MaterialType {
    MassZoneMaterialType get ();
    void set (MassZoneMaterialType value);
}

Remarks

The material of the MassZone faced will be determined in the following ways based on the material type. MassZoneMaterialTypeMaterialBySurfaceType: Each MassZone face will use the material defined by the object style of the subcategory of the Element returned by getMassDataElementIdForZoneFaceReference(..). MassZoneMaterialTypeNormalMaterial: If the materialId is InvalidElementId, then the material defined by the object style of the MassZone subcategory will be used for all faces of the MassZone. MassZoneMaterialTypeNormalMaterial: If the materialId is the id of a Material element, that material id will be used for all faces of the MassZone.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The material type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
MassZone..::..Parameter Property
MassZone Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MassZone Class
MassZone Members
Autodesk.Revit.DB.Analysis Namespace


SpaceType Property

[image]

Revit 2013 API
MassZone..::..SpaceType Property
MassZone Class See Also Send Feedback
The gbXMLSpaceType of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public gbXMLSpaceType SpaceType { get; set; }
Visual Basic
Public Property SpaceType As gbXMLSpaceType
    Get
    Set
Visual C++
public:
property gbXMLSpaceType SpaceType {
    gbXMLSpaceType get ();
    void set (gbXMLSpaceType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The space type does not fall within an appropriate range.

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


UpperLevelId Property

[image]

Revit 2013 API
MassZone..::..UpperLevelId Property
MassZone Class See Also Send Feedback
The upper level defining the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId UpperLevelId { get; }
Visual Basic
Public ReadOnly Property UpperLevelId As ElementId
    Get
Visual C++
public:
property ElementId^ UpperLevelId {
    ElementId^ get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


Volume Property

[image]

Revit 2013 API
MassZone..::..Volume Property
MassZone Class See Also Send Feedback
The volume of the MassZone.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

See Also

MassZone Class
Autodesk.Revit.DB.Analysis Namespace


MassZoneLevelCutState Enumeration

[image]

Revit 2013 API
MassZoneLevelCutState Enumeration
See Also Send Feedback
The relationship between lower level or upper level and the MassZone. The MassZone is not intersected by this level, this level just happens to be the nearest upper or lower level. The MassZone was created by cutting its source geometry with this level. The level cuts through the MassZone geometry. One or more faces of the MassZone are coincident with this level and the level does not otherwise cut through or intersect the MassZone geometry.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MassZoneLevelCutState
Visual Basic
Public Enumeration MassZoneLevelCutState
Visual C++
public enum class MassZoneLevelCutState

Members

Member name | Description
NotCut |
Cut |
NotCutButCoincident |

See Also

Autodesk.Revit.DB.Analysis Namespace


MassZoneMaterialType Enumeration

[image]

Revit 2013 API
MassZoneMaterialType Enumeration
See Also Send Feedback
MassZone material type.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum MassZoneMaterialType
Visual Basic
Public Enumeration MassZoneMaterialType
Visual C++
public enum class MassZoneMaterialType

Members

Member name | Description
MaterialBySurfaceType | Material for a given face of a MassZone comes from the category of the face of the MassEnergyAnalyticalModel that the MassZone face is created from.
NormalMaterial | If materialId is InvalidElementId, all faces of the MassZone will use the material from the MassZone category object style. If materialId is a valid material, all faces of the MassZone will use that specific material.

Remarks

Indicates how MassZone material is calculated.

See Also

Autodesk.Revit.DB.Analysis Namespace


Polyloop Class

[image]

Revit 2013 API
Polyloop Class
Members See Also Send Feedback
A Polyloop represent a planar polygon with ordered points.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Polyloop : IDisposable
Visual Basic
Public Class Polyloop _
    Implements IDisposable
Visual C++
public ref class Polyloop : IDisposable

Remarks

This class corresponds to IfcPolyLoop (see definition below). Definition from ISO/CD 10303-42:1992: An IfcPolyLoop is a loop with straight edges bounding a planar region in space. An IfcPolyLoop is a loop of genus 1 where the loop is represented by an ordered coplanar collection of points forming the vertices of the loop. The loop is composed of straight line segments joining a point in the collection to the succeeding point in the collection. The closing segment is from the last to the first point in the collection. The direction of the loop is in the direction of the line segments. All the points in the polygon defining the poly loop shall be coplanar.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Analysis..::..Polyloop

See Also

Polyloop Members
Autodesk.Revit.DB.Analysis Namespace


Polyloop Members

[image] [image]

Revit 2013 API
Polyloop Members
Polyloop Class Methods Properties See Also Send Feedback

The Polyloop type exposes the following members.

Methods

 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose | Releases all resources used by the Polyloop
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoints | Gets the array of points in the polygon
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop Methods

[image] [image]

Revit 2013 API
Polyloop Methods
Polyloop Class See Also Send Feedback

The Polyloop type exposes the following members.

Methods

 | Name | Description
Public method | ComputeArea | Gets the area for this polygon.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoints | Gets the array of points in the polygon
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


ComputeArea Method

[image]

Revit 2013 API
Polyloop..::..ComputeArea Method
Polyloop Class See Also Send Feedback
Gets the area for this polygon.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ComputeArea()
Visual Basic
Public Function ComputeArea As Double
Visual C++
public:
double ComputeArea()

Return Value

The area for this polygon.

Remarks

The area of the planar non-self-intersecting polygon computed as: A = 1/2 * (X1 Y2) - (X2 Y1) + ... + (Xn Y1) - (X1 Yn)

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Dispose Method

[image]

Revit 2013 API
Polyloop..::..Dispose Method
Polyloop Class See Also Send Feedback
Releases all resources used by the Polyloop

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


GetPoints Method

[image]

Revit 2013 API
Polyloop..::..GetPoints Method
Polyloop Class See Also Send Feedback
Gets the array of points in the polygon

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<XYZ> GetPoints()
Visual Basic
Public Function GetPoints As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetPoints()

Return Value

The array of points in the polygon

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Polyloop Properties

[image] [image]

Revit 2013 API
Polyloop Properties
Polyloop Class See Also Send Feedback

The Polyloop type exposes the following members.

Properties

 | Name | Description
Public property | Centroid | The polygon centroid.
Public property | Direction | The direction for the outward normal for this polygon.

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Centroid Property

[image]

Revit 2013 API
Polyloop..::..Centroid Property
Polyloop Class See Also Send Feedback
The polygon centroid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Centroid { get; }
Visual Basic
Public ReadOnly Property Centroid As XYZ
    Get
Visual C++
public:
property XYZ^ Centroid {
    XYZ^ get ();
}

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


Direction Property

[image]

Revit 2013 API
Polyloop..::..Direction Property
Polyloop Class See Also Send Feedback
The direction for the outward normal for this polygon.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

Polyloop Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Class

[image]

Revit 2013 API
SpatialFieldManager Class
Members Example See Also Send Feedback
Exposes all API for an external analysis application. Its primary role is creation, deletion and modification of SpatialFieldElement elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SpatialFieldManager : Element
Visual Basic
Public Class SpatialFieldManager _
    Inherits Element
Visual C++
public ref class SpatialFieldManager : public Element

Examples

CopyC#
Document doc = commandData.Application.ActiveUIDocument.Document;
UIDocument uiDoc = commandData.Application.ActiveUIDocument;

SpatialFieldManager sfm = SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView);
if (null == sfm)
{
    sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1);
}
Reference reference = uiDoc.Selection.PickObject(ObjectType.Face, "Select a face");
int idx = sfm.AddSpatialFieldPrimitive(reference);

Face face = doc.GetElement(reference).GetGeometryObjectFromReference(reference) as Face;

IList<UV> uvPts = new List<UV>();
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;
uvPts.Add(new UV(min.U,min.V));
uvPts.Add(new UV(max.U,max.V));

FieldDomainPointsByUV pnts = new FieldDomainPointsByUV(uvPts);

List<double> doubleList = new List<double>();
IList<ValueAtPoint> valList = new List<ValueAtPoint>();
doubleList.Add(0);
valList.Add(new ValueAtPoint(doubleList));
doubleList.Clear();
doubleList.Add(10);
valList.Add(new ValueAtPoint(doubleList));

FieldValues vals = new FieldValues(valList);
AnalysisResultSchema resultSchema = new AnalysisResultSchema("Schema Name", "Description");
int schemaIndex = sfm.RegisterResult(resultSchema);
sfm.UpdateSpatialFieldPrimitive(idx, pnts, vals, schemaIndex);
CopyVB.NET
Dim doc As Document = commandData.Application.ActiveUIDocument.Document
Dim uiDoc As UIDocument = commandData.Application.ActiveUIDocument

Dim sfm As Autodesk.Revit.DB.Analysis.SpatialFieldManager = Autodesk.Revit.DB.Analysis.SpatialFieldManager.GetSpatialFieldManager(doc.ActiveView)
If sfm Is Nothing Then
    sfm = Autodesk.Revit.DB.Analysis.SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 1)
End If
Dim reference As Reference = uiDoc.Selection.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Face, "Select a face")
Dim idx As Integer = sfm.AddSpatialFieldPrimitive(reference)

Dim face As Autodesk.Revit.DB.Face = TryCast(reference.GeometryObject, Autodesk.Revit.DB.Face)

Dim uvPts As IList(Of Autodesk.Revit.DB.UV) = New List(Of Autodesk.Revit.DB.UV)()
Dim bb As BoundingBoxUV = face.GetBoundingBox()
Dim min As Autodesk.Revit.DB.UV = bb.Min
Dim max As Autodesk.Revit.DB.UV = bb.Max
uvPts.Add(New Autodesk.Revit.DB.UV(min.U, min.V))
uvPts.Add(New Autodesk.Revit.DB.UV(max.U, max.V))

Dim pnts As New Autodesk.Revit.DB.Analysis.FieldDomainPointsByUV(uvPts)

Dim doubleList As New List(Of Double)()
Dim valList As IList(Of Autodesk.Revit.DB.Analysis.ValueAtPoint) = New List(Of Autodesk.Revit.DB.Analysis.ValueAtPoint)()
doubleList.Add(0)
valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))
doubleList.Clear()
doubleList.Add(10)
valList.Add(New Autodesk.Revit.DB.Analysis.ValueAtPoint(doubleList))

Dim vals As New Autodesk.Revit.DB.Analysis.FieldValues(valList)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Analysis..::..SpatialFieldManager

See Also

SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Members

[image] [image]

Revit 2013 API
SpatialFieldManager Members
SpatialFieldManager Class Methods Properties See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | SetUnits | Obsolete. Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues) | Obsolete. Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues, Int32) | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentMeasurement | Stores the currently displayed measurement
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Methods

[image] [image]

Revit 2013 API
SpatialFieldManager Methods
SpatialFieldManager Class See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Methods

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | Clear | Clear all analysis results managed by this manager object
 | CreateSpatialFieldManager | Factory method - creates manager object for the given view
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLegend | Returns legend element or NULL
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMaximum | Calculates the maximum value for all primitives
Public method | GetMinimum | Calculates the minimum value for all primitives
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRegisteredResults | Returns an array of indices of all registered results
Public method | GetResultSchema | Returns result schema by index
 | GetSpatialFieldManager | Retrieves manager object for the given view or returns NULL
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsResultSchemaNameUnique | Verify the uniqueness of the name among all registered result schemas.
 | IsTextTypeIdValid | Verify if text type id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RegisterResult | Registers result and assigns it a unique result index
Public method | RemoveSpatialFieldPrimitive | Removes analysis results primitive identified by the unique index
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMeasurementDescriptions | Sets Descriptions for all measurements
Public method | SetMeasurementNames | Sets Names for all measurements
Public method | SetResultSchema | Sets a new value for an existing result schema in the result registry
Public method | SetUnits | Obsolete. Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues) | Obsolete. Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues, Int32) | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method

[image] [image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddSpatialFieldPrimitive()()()() | Creates empty analysis results primitive not associated with any geometry element
Public method | AddSpatialFieldPrimitive(Reference) | Creates an empty analysis results primitive associated with a reference.
Public method | AddSpatialFieldPrimitive(Curve, Transform) | Creates empty analysis results primitive associated with a curve and a transform.
Public method | AddSpatialFieldPrimitive(Face, Transform) | Creates empty analysis results primitive associated with a face and a transform.
Public method | AddSpatialFieldPrimitive(Reference, SpatialFieldPrimitiveHideMode) | Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method

[image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results primitive not associated with any geometry element

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive()
Visual Basic
Public Function AddSpatialFieldPrimitive As Integer
Visual C++
public:
int AddSpatialFieldPrimitive()

Return Value

Unique index of primitive for future references

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Reference)

[image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method (Reference)
SpatialFieldManager Class See Also Send Feedback
Creates an empty analysis results primitive associated with a reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Reference reference
)
Visual Basic
Public Function AddSpatialFieldPrimitive ( _
    reference As Reference _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
Reference pointing to the curve or face to be associated with the primitive

Return Value

Unique index of primitive for future references

Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | reference points to neither face nor curve
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Curve, Transform)

[image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method (Curve, Transform)
SpatialFieldManager Class See Also Send Feedback
Creates empty analysis results primitive associated with a curve and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Curve curve,
    Transform trf
)
Visual Basic
Public Function AddSpatialFieldPrimitive ( _
    curve As Curve, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Curve^ curve,
    Transform^ trf
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
Curve to be associated with the primitive. %curve% does NOT correspond to actual Revit geometry, i.e. it cannot be associated with reference; otherwise the other overload of the method must be used (taking "reference" as the input)
trf
Type: Autodesk.Revit.DB..::..Transform
Conformal Transform to be applied to %curve%.

Return Value

Unique index of primitive for future references

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation. -or- Argument trf is not a conformal transform (see property Revit::DB::Transform::IsConformal)
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Face, Transform)

[image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method (Face, Transform)
SpatialFieldManager Class Example See Also Send Feedback
Creates empty analysis results primitive associated with a face and a transform.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int AddSpatialFieldPrimitive(
    Face face,
    Transform trf
)
Visual Basic
Public Function AddSpatialFieldPrimitive ( _
    face As Face, _
    trf As Transform _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Face^ face,
    Transform^ trf
)

Parameters

face
Type: Autodesk.Revit.DB..::..Face
Face to be associated with the primitive
trf
Type: Autodesk.Revit.DB..::..Transform
Conformal Transform to be applied to %face%

Return Value

Unique index of primitive for future references

Remarks

This method accepts a reference to a model face, and a transform to be applied to that face, allowing the display of analytical results on faces which are not strictly a part of the Revit model.

This method should not be used if the transform is the identity transform, i.e. the intent is to display results on a face which is part of the Revit model. In that case, use the overload of this method which accepts a reference.

If the input face is from the geometry of a symbol, the face will be considered to be in the location specified by its symbol geometry. If your intention is to transform the face relative to its location in the instance, your input transform must consist of the instance's transform left multiplied by the extra transform to get the results you expect.

Examples

CopyC#
// Create SpatialFieldPrimitive to display results offset from a face
BoundingBoxUV bb = face.GetBoundingBox();
UV min = bb.Min;
UV max = bb.Max;

// Find the face normal at the center of the face's bounding box
UV faceCenter = new UV((max.U + min.U) / 2, (max.V + min.V) / 2);
Transform computeDerivatives = face.ComputeDerivatives(faceCenter);
XYZ faceCenterNormal = computeDerivatives.BasisZ;

// Normalize the normal vector and multiply by 2.5
XYZ faceCenterNormalMultiplied = faceCenterNormal.Normalize().Multiply(2.5);
Transform transform = Transform.get_Translation(faceCenterNormalMultiplied);

// Use face and transform when adding the SpatialFieldPrimitive
SpatialFieldManager sfm = SpatialFieldManager.CreateSpatialFieldManager(doc.ActiveView, 3);
int idx = sfm.AddSpatialFieldPrimitive(face, transform);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | trf is not conformal
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


AddSpatialFieldPrimitive Method (Reference, SpatialFieldPrimitiveHideMode)

[image]

Revit 2013 API
SpatialFieldManager..::..AddSpatialFieldPrimitive Method (Reference, SpatialFieldPrimitiveHideMode)
SpatialFieldManager Class See Also Send Feedback
Creates an empty analysis results primitive associated with a reference, with the option to control how the reference element is hidden.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int AddSpatialFieldPrimitive(
    Reference reference,
    SpatialFieldPrimitiveHideMode hidingMode
)
Visual Basic
Public Function AddSpatialFieldPrimitive ( _
    reference As Reference, _
    hidingMode As SpatialFieldPrimitiveHideMode _
) As Integer
Visual C++
public:
int AddSpatialFieldPrimitive(
    Reference^ reference,
    SpatialFieldPrimitiveHideMode hidingMode
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
Reference pointing to the curve or face to be associated with the primitive
hidingMode
Type: Autodesk.Revit.DB.Analysis..::..SpatialFieldPrimitiveHideMode
The mode used to hide the original model element

Return Value

Unique index of primitive for future references

Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | reference points to neither face nor curve
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
AddSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


Clear Method

[image]

Revit 2013 API
SpatialFieldManager..::..Clear Method
SpatialFieldManager Class See Also Send Feedback
Clear all analysis results managed by this manager object

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Clear()
Visual Basic
Public Sub Clear
Visual C++
public:
void Clear()

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


CreateSpatialFieldManager Method

[image]

Revit 2013 API
SpatialFieldManager..::..CreateSpatialFieldManager Method
SpatialFieldManager Class See Also Send Feedback
Factory method - creates manager object for the given view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager CreateSpatialFieldManager(
    View view,
    int numberOfMeasurements
)
Visual Basic
Public Shared Function CreateSpatialFieldManager ( _
    view As View, _
    numberOfMeasurements As Integer _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ CreateSpatialFieldManager(
    View^ view,
    int numberOfMeasurements
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
View for which manager object is created or retrieved
numberOfMeasurements
Type: System..::..Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects

Return Value

Manager object for the view passed in the argument

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | numberOfMeasurements is less than one
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | View is not allowed to display analysis results or a manager object for this view already exists

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetLegend Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetLegend Method
SpatialFieldManager Class See Also Send Feedback
Returns legend element or NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalysisDisplayLegend GetLegend()
Visual Basic
Public Function GetLegend As AnalysisDisplayLegend
Visual C++
public:
AnalysisDisplayLegend^ GetLegend()

Return Value

The legend element or NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetMaximum Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetMaximum Method
SpatialFieldManager Class See Also Send Feedback
Calculates the maximum value for all primitives

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetMaximum(
    int resultIndex,
    bool rawValue
)
Visual Basic
Public Function GetMaximum ( _
    resultIndex As Integer, _
    rawValue As Boolean _
) As Double
Visual C++
public:
double GetMaximum(
    int resultIndex,
    bool rawValue
)

Parameters

resultIndex
Type: System..::..Int32
Index of result schema
rawValue
Type: System..::..Boolean
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS

Return Value

Resulting maximum value

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when current measurement is >= the number of measurements for at least one primitive

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetMinimum Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetMinimum Method
SpatialFieldManager Class See Also Send Feedback
Calculates the minimum value for all primitives

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double GetMinimum(
    int resultIndex,
    bool rawValue
)
Visual Basic
Public Function GetMinimum ( _
    resultIndex As Integer, _
    rawValue As Boolean _
) As Double
Visual C++
public:
double GetMinimum(
    int resultIndex,
    bool rawValue
)

Parameters

resultIndex
Type: System..::..Int32
Index of result schema
rawValue
Type: System..::..Boolean
If true returned value is NOT multiplied by the current result's units multiplier, otherwise it IS

Return Value

Resulting minimum value

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when current measurement is >= the number of measurements for at least one primitive

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetRegisteredResults Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetRegisteredResults Method
SpatialFieldManager Class See Also Send Feedback
Returns an array of indices of all registered results

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<int> GetRegisteredResults()
Visual Basic
Public Function GetRegisteredResults As IList(Of Integer)
Visual C++
public:
IList<int>^ GetRegisteredResults()

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetResultSchema Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetResultSchema Method
SpatialFieldManager Class See Also Send Feedback
Returns result schema by index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalysisResultSchema GetResultSchema(
    int idx
)
Visual Basic
Public Function GetResultSchema ( _
    idx As Integer _
) As AnalysisResultSchema
Visual C++
public:
AnalysisResultSchema^ GetResultSchema(
    int idx
)

Parameters

idx
Type: System..::..Int32
Index of registered result schema

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent result schema

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


GetSpatialFieldManager Method

[image]

Revit 2013 API
SpatialFieldManager..::..GetSpatialFieldManager Method
SpatialFieldManager Class See Also Send Feedback
Retrieves manager object for the given view or returns NULL

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static SpatialFieldManager GetSpatialFieldManager(
    View view
)
Visual Basic
Public Shared Function GetSpatialFieldManager ( _
    view As View _
) As SpatialFieldManager
Visual C++
public:
static SpatialFieldManager^ GetSpatialFieldManager(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
View for which manager object is retrieved

Return Value

Manager object for the view passed in the argument

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


IsResultSchemaNameUnique Method

[image]

Revit 2013 API
SpatialFieldManager..::..IsResultSchemaNameUnique Method
SpatialFieldManager Class See Also Send Feedback
Verify the uniqueness of the name among all registered result schemas.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsResultSchemaNameUnique(
    string name,
    int resultIndexToSkip
)
Visual Basic
Public Function IsResultSchemaNameUnique ( _
    name As String, _
    resultIndexToSkip As Integer _
) As Boolean
Visual C++
public:
bool IsResultSchemaNameUnique(
    String^ name,
    int resultIndexToSkip
)

Parameters

name
Type: System..::..String
Name to verify uniqueness of.
resultIndexToSkip
Type: System..::..Int32
Index of result (e.g. to be replaced) which names should not count for uniqueness; negative number means nothing is excluded from comparison.

Return Value

True if name is unique, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


IsTextTypeIdValid Method

[image]

Revit 2013 API
SpatialFieldManager..::..IsTextTypeIdValid Method
SpatialFieldManager Class See Also Send Feedback
Verify if text type id is valid.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsTextTypeIdValid(
    ElementId textTypeId,
    Document doc
)
Visual Basic
Public Shared Function IsTextTypeIdValid ( _
    textTypeId As ElementId, _
    doc As Document _
) As Boolean
Visual C++
public:
static bool IsTextTypeIdValid(
    ElementId^ textTypeId,
    Document^ doc
)

Parameters

textTypeId
Type: Autodesk.Revit.DB..::..ElementId
Text type id to be validated.
doc
Type: Autodesk.Revit.DB..::..Document
Document for which %textTypeId% is validated.

Return Value

True if text type id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


RegisterResult Method

[image]

Revit 2013 API
SpatialFieldManager..::..RegisterResult Method
SpatialFieldManager Class Example See Also Send Feedback
Registers result and assigns it a unique result index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int RegisterResult(
    AnalysisResultSchema resultSchema
)
Visual Basic
Public Function RegisterResult ( _
    resultSchema As AnalysisResultSchema _
) As Integer
Visual C++
public:
int RegisterResult(
    AnalysisResultSchema^ resultSchema
)

Parameters

resultSchema
Type: Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema
Result schema to be registered

Return Value

Unique index assigned to the result

Examples

CopyC#
// register a new result schema only if one with the same name does not already exist
IList<int> registeredResults = new List<int>();
AnalysisResultSchema resultSchema = new AnalysisResultSchema("Reactions", "Reaction Forces at Column Base");
registeredResults = spatialFieldManager.GetRegisteredResults();
int resultIndex = 999;
foreach (int myInt in registeredResults)
{
    if (spatialFieldManager.GetResultSchema(myInt).Name == "Reactions")
    {
        resultIndex = myInt;
        break;
    }
}
if (resultIndex == 999) // there are existing registered results, but none are named "Reactions"
    resultIndex = spatialFieldManager.RegisterResult(resultSchema);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name of resultSchema is not unique in view
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


RemoveSpatialFieldPrimitive Method

[image]

Revit 2013 API
SpatialFieldManager..::..RemoveSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback
Removes analysis results primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void RemoveSpatialFieldPrimitive(
    int idx
)
Visual Basic
Public Sub RemoveSpatialFieldPrimitive ( _
    idx As Integer _
)
Visual C++
public:
void RemoveSpatialFieldPrimitive(
    int idx
)

Parameters

idx
Type: System..::..Int32
Unique index identifying the primitive

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent primitive

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetMeasurementDescriptions Method

[image]

Revit 2013 API
SpatialFieldManager..::..SetMeasurementDescriptions Method
SpatialFieldManager Class See Also Send Feedback
Sets Descriptions for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetMeasurementDescriptions(
    IList<string> measurementDescriptions
)
Visual Basic
Public Sub SetMeasurementDescriptions ( _
    measurementDescriptions As IList(Of String) _
)
Visual C++
public:
void SetMeasurementDescriptions(
    IList<String^>^ measurementDescriptions
)

Parameters

measurementDescriptions
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Array of measurement descriptions. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | measurementDescriptions lengths is not equal to the number of measurements set during creation of SpatialFieldManager
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetMeasurementNames Method

[image]

Revit 2013 API
SpatialFieldManager..::..SetMeasurementNames Method
SpatialFieldManager Class See Also Send Feedback
Sets Names for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetMeasurementNames(
    IList<string> measurementNames
)
Visual Basic
Public Sub SetMeasurementNames ( _
    measurementNames As IList(Of String) _
)
Visual C++
public:
void SetMeasurementNames(
    IList<String^>^ measurementNames
)

Parameters

measurementNames
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Array of measurement names. All names in the array must be unique. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | measurementNames contains duplicate names or its lengths is not equal to the number of measurements set during creation of SpatialFieldManager
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetResultSchema Method

[image]

Revit 2013 API
SpatialFieldManager..::..SetResultSchema Method
SpatialFieldManager Class See Also Send Feedback
Sets a new value for an existing result schema in the result registry

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetResultSchema(
    int idx,
    AnalysisResultSchema resultSchema
)
Visual Basic
Public Sub SetResultSchema ( _
    idx As Integer, _
    resultSchema As AnalysisResultSchema _
)
Visual C++
public:
void SetResultSchema(
    int idx,
    AnalysisResultSchema^ resultSchema
)

Parameters

idx
Type: System..::..Int32
Index of registered result schema
resultSchema
Type: Autodesk.Revit.DB.Analysis..::..AnalysisResultSchema
Result schema replacing the existent one

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent result schema -or- name of resultSchema is not unique in view
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SetUnits Method

[image]

Revit 2013 API
SpatialFieldManager..::..SetUnits Method
SpatialFieldManager Class See Also Send Feedback
Sets names and multipliers for all units that can be used for analysis results visualization; current units can later be changed by accessor method

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012; use AnalysisResultSchema.SetUnits() and SpatialFieldManager.SetResultSchema() instead.")]
public void SetUnits(
    IList<string> names,
    IList<double> multipliers
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012; use AnalysisResultSchema.SetUnits() and SpatialFieldManager.SetResultSchema() instead.")> _
Public Sub SetUnits ( _
    names As IList(Of String), _
    multipliers As IList(Of Double) _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012; use AnalysisResultSchema.SetUnits() and SpatialFieldManager.SetResultSchema() instead.")]
public:
void SetUnits(
    IList<String^>^ names,
    IList<double>^ multipliers
)

Parameters

names
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Unit names for all units (e.g., "Lb" and "Kg")
multipliers
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Numerical coefficients mapped to unit names; they are used to adjust measurement values for display (e.g., 1.0 and 0.451 - if actual measurements are in Lb)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | names contains duplicate or empty names, or its lengths is zero -or- multipliers contains non-positive numbers, or its lengths is not equal to the length of names
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Legacy method cannot be used in new multi-result environment

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


UpdateSpatialFieldPrimitive Method

[image] [image]

Revit 2013 API
SpatialFieldManager..::..UpdateSpatialFieldPrimitive Method
SpatialFieldManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues) | Obsolete. Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Public method | UpdateSpatialFieldPrimitive(Int32, FieldDomainPoints, FieldValues, Int32) | Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues)

[image]

Revit 2013 API
SpatialFieldManager..::..UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues)
SpatialFieldManager Class See Also Send Feedback
Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012; use the overload accepting the result index instead.")]
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012; use the overload accepting the result index instead.")> _
Public Sub UpdateSpatialFieldPrimitive ( _
    idx As Integer, _
    fieldDomainPoints As FieldDomainPoints, _
    fieldValues As FieldValues _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012; use the overload accepting the result index instead.")]
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues
)

Parameters

idx
Type: System..::..Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Set of domain points. If %fieldDomainPoints% is nullNothingnullptra null reference (Nothing in Visual Basic) only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis..::..FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | fieldDomainPoints and fieldValues have inconsistent number of points
Autodesk.Revit.Exceptions..::..InvalidOperationException | Legacy method cannot be used in new multi-result environment

See Also

SpatialFieldManager Class
UpdateSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues, Int32)

[image]

Revit 2013 API
SpatialFieldManager..::..UpdateSpatialFieldPrimitive Method (Int32, FieldDomainPoints, FieldValues, Int32)
SpatialFieldManager Class See Also Send Feedback
Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints fieldDomainPoints,
    FieldValues fieldValues,
    int resultIndex
)
Visual Basic
Public Sub UpdateSpatialFieldPrimitive ( _
    idx As Integer, _
    fieldDomainPoints As FieldDomainPoints, _
    fieldValues As FieldValues, _
    resultIndex As Integer _
)
Visual C++
public:
void UpdateSpatialFieldPrimitive(
    int idx,
    FieldDomainPoints^ fieldDomainPoints,
    FieldValues^ fieldValues,
    int resultIndex
)

Parameters

idx
Type: System..::..Int32
Unique index identifying the primitive
fieldDomainPoints
Type: Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Set of domain points. If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive. If %fieldDomainPoints% is nullNothingnullptra null reference (Nothing in Visual Basic) only fieldValues are updated
fieldValues
Type: Autodesk.Revit.DB.Analysis..::..FieldValues
Set of data values. Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
resultIndex
Type: System..::..Int32
Unique index identifying the result schema

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | idx refers to non-existent primitive -or- fieldValues has incorrect number of measurements in ValueAtPoint objects -or- fieldDomainPoints has inconsistent type -or- resultIndex refers to non-existent result schema
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | fieldDomainPoints and fieldValues have inconsistent number of points

See Also

SpatialFieldManager Class
UpdateSpatialFieldPrimitive Overload
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldManager Properties

[image] [image]

Revit 2013 API
SpatialFieldManager Properties
SpatialFieldManager Class See Also Send Feedback

The SpatialFieldManager type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CurrentMeasurement | Stores the currently displayed measurement
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LegendPosition | Stores current position of analysis results legend element in view
Public property | LegendShowConfigurationName | If true legend contains analysis configuration name.
Public property | LegendShowDescription | If true legend contains analysis description.
Public property | LegendTextTypeId | Stores element id of text associated with common (result-independent) part of legend in view.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfMeasurements | Stores the total number of measurements
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ResultsVisibleInView | Enables analysis results visibility in the view.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UseRangeForAllMeasurements | Governs how minimum and maximum values (the data range) are calculated.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


CurrentMeasurement Property

[image]

Revit 2013 API
SpatialFieldManager..::..CurrentMeasurement Property
SpatialFieldManager Class See Also Send Feedback
Stores the currently displayed measurement

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int CurrentMeasurement { get; set; }
Visual Basic
Public Property CurrentMeasurement As Integer
    Get
    Set
Visual C++
public:
property int CurrentMeasurement {
    int get ();
    void set (int value);
}

Remarks

Must be in the range from 0 to (numberOfMeasurements - 1)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: measurement is not in the range from 0 to (number of measurements - 1)

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


LegendPosition Property

[image]

Revit 2013 API
SpatialFieldManager..::..LegendPosition Property
SpatialFieldManager Class See Also Send Feedback
Stores current position of analysis results legend element in view

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ LegendPosition { get; set; }
Visual Basic
Public Property LegendPosition As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ LegendPosition {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


LegendShowConfigurationName Property

[image]

Revit 2013 API
SpatialFieldManager..::..LegendShowConfigurationName Property
SpatialFieldManager Class See Also Send Feedback
If true legend contains analysis configuration name.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool LegendShowConfigurationName { get; set; }
Visual Basic
Public Property LegendShowConfigurationName As Boolean
    Get
    Set
Visual C++
public:
property bool LegendShowConfigurationName {
    bool get ();
    void set (bool value);
}

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


LegendShowDescription Property

[image]

Revit 2013 API
SpatialFieldManager..::..LegendShowDescription Property
SpatialFieldManager Class See Also Send Feedback
If true legend contains analysis description.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool LegendShowDescription { get; set; }
Visual Basic
Public Property LegendShowDescription As Boolean
    Get
    Set
Visual C++
public:
property bool LegendShowDescription {
    bool get ();
    void set (bool value);
}

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


LegendTextTypeId Property

[image]

Revit 2013 API
SpatialFieldManager..::..LegendTextTypeId Property
SpatialFieldManager Class See Also Send Feedback
Stores element id of text associated with common (result-independent) part of legend in view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LegendTextTypeId { get; set; }
Visual Basic
Public Property LegendTextTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LegendTextTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


NumberOfMeasurements Property

[image]

Revit 2013 API
SpatialFieldManager..::..NumberOfMeasurements Property
SpatialFieldManager Class See Also Send Feedback
Stores the total number of measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int NumberOfMeasurements { get; }
Visual Basic
Public ReadOnly Property NumberOfMeasurements As Integer
    Get
Visual C++
public:
property int NumberOfMeasurements {
    int get ();
}

Remarks

This number defines the length of value arrays in ValueAtPoint objects

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


Parameter Property

[image] [image]

Revit 2013 API
SpatialFieldManager..::..Parameter Property
SpatialFieldManager Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpatialFieldManager Class
SpatialFieldManager Members
Autodesk.Revit.DB.Analysis Namespace


ResultsVisibleInView Property

[image]

Revit 2013 API
SpatialFieldManager..::..ResultsVisibleInView Property
SpatialFieldManager Class See Also Send Feedback
Enables analysis results visibility in the view.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ResultsVisibleInView { get; set; }
Visual Basic
Public Property ResultsVisibleInView As Boolean
    Get
    Set
Visual C++
public:
property bool ResultsVisibleInView {
    bool get ();
    void set (bool value);
}

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


UseRangeForAllMeasurements Property

[image]

Revit 2013 API
SpatialFieldManager..::..UseRangeForAllMeasurements Property
SpatialFieldManager Class See Also Send Feedback
Governs how minimum and maximum values (the data range) are calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UseRangeForAllMeasurements { get; set; }
Visual Basic
Public Property UseRangeForAllMeasurements As Boolean
    Get
    Set
Visual C++
public:
property bool UseRangeForAllMeasurements {
    bool get ();
    void set (bool value);
}

Remarks

If true the data range is calculated from all measurements. Otherwise the data range is calculated from the current measurement only.

See Also

SpatialFieldManager Class
Autodesk.Revit.DB.Analysis Namespace


SpatialFieldPrimitiveHideMode Enumeration

[image]

Revit 2013 API
SpatialFieldPrimitiveHideMode Enumeration
See Also Send Feedback
Defines modes which can be used by a SpatialFieldPrimitive to hide the original referenced element.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum SpatialFieldPrimitiveHideMode
Visual Basic
Public Enumeration SpatialFieldPrimitiveHideMode
Visual C++
public enum class SpatialFieldPrimitiveHideMode

Members

Member name | Description
Default | For ColoredSurface display style, hide only the referenced face passed at the primitive creation time. For DeformedShape display style, hide only the referenced face or curve passed at the primitive creation time.
HideNone | Do not hide any piece of the original model element.
HideOnlyReference | Hide only the referenced face or curve.
HideWholeElement | Hide the whole referenced element.

See Also

Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Class

[image]

Revit 2013 API
ValueAtPoint Class
Members See Also Send Feedback
Stores values at one domain point. Each value corresponds to a "measurement" for which this value was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ValueAtPoint : ValueAtPointBase
Visual Basic
Public Class ValueAtPoint _
    Inherits ValueAtPointBase
Visual C++
public ref class ValueAtPoint : public ValueAtPointBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..ValueAtPoint

See Also

ValueAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Members

[image] [image]

Revit 2013 API
ValueAtPoint Members
ValueAtPoint Class Constructors Methods See Also Send Feedback

The ValueAtPoint type exposes the following members.

Constructors

 | Name | Description
Public method | ValueAtPoint(IList<(Of <<'(Double>)>>)) | Creates object from an array of values
Public method | ValueAtPoint(ValueAtPoint) | Initializes a new instance of the ValueAtPoint class

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements; (Inherited from ValueAtPointBase.)
Public method | ClearFlagsAt | Clears flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | Dispose | (Inherited from ValueAtPointBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor

[image] [image]

Revit 2013 API
ValueAtPoint Constructor
ValueAtPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ValueAtPoint(IList<(Of <<'(Double>)>>)) | Creates object from an array of values
Public method | ValueAtPoint(ValueAtPoint) | Initializes a new instance of the ValueAtPoint class

See Also

ValueAtPoint Class
ValueAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor (IList(Double))

[image]

Revit 2013 API
ValueAtPoint Constructor (IList<(Of <(<'Double>)>)>)
ValueAtPoint Class See Also Send Feedback
Creates object from an array of values

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ValueAtPoint(
    IList<double> values
)
Visual Basic
Public Sub New ( _
    values As IList(Of Double) _
)
Visual C++
public:
ValueAtPoint(
    IList<double>^ values
)

Parameters

values
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Array of values, each corresponding to "measurement"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when supplied values contain invalid (infinite or non-number) doubles
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Constructor (ValueAtPoint)

[image]

Revit 2013 API
ValueAtPoint Constructor (ValueAtPoint)
ValueAtPoint Class See Also Send Feedback
Initializes a new instance of the ValueAtPoint class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ValueAtPoint(
    ValueAtPoint otherObject
)
Visual Basic
Public Sub New ( _
    otherObject As ValueAtPoint _
)
Visual C++
public:
ValueAtPoint(
    ValueAtPoint^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::..ValueAtPoint

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ValueAtPoint Class
ValueAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


ValueAtPoint Methods

[image] [image]

Revit 2013 API
ValueAtPoint Methods
ValueAtPoint Class See Also Send Feedback

The ValueAtPoint type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements; (Inherited from ValueAtPointBase.)
Public method | ClearFlagsAt | Clears flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | Dispose | (Inherited from ValueAtPointBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValueAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


SetFlags Method

[image] [image]

Revit 2013 API
ValueAtPoint..::..SetFlags Method
ValueAtPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)

See Also

ValueAtPoint Class
ValueAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Class

[image]

Revit 2013 API
VectorAtPoint Class
Members Example See Also Send Feedback
Stores vectors at one domain point. Each vector corresponds to a "measurement" for which this vector was calculated.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class VectorAtPoint : ValueAtPointBase
Visual Basic
Public Class VectorAtPoint _
    Inherits ValueAtPointBase
Visual C++
public ref class VectorAtPoint : public ValueAtPointBase

Examples

CopyC#
// Place analysis results in the form of vectors at each of a beam or column's analytical model curve
Curve curve = familyInstance.GetAnalyticalModel().GetCurve();

Transform transform = familyInstance.GetTransform();
int index = spatialFieldManager.AddSpatialFieldPrimitive(curve, Transform.Identity);

IList<double> doubleList = new List<double>();
doubleList.Add(curve.get_EndParameter(0)); // vectors will be at each end of the analytical model curve
doubleList.Add(curve.get_EndParameter(1));
FieldDomainPointsByParameter pointsByParameter = new FieldDomainPointsByParameter(doubleList);

List<XYZ> xyzList = new List<XYZ>();
xyzList.Add(curve.ComputeDerivatives(0, true).BasisX.Normalize()); // vectors will be tangent to the curve at its ends
IList<VectorAtPoint> vectorList = new List<VectorAtPoint>();
vectorList.Add(new VectorAtPoint(xyzList));
xyzList.Clear();
xyzList.Add(curve.ComputeDerivatives(1, true).BasisX.Normalize().Negate());
vectorList.Add(new VectorAtPoint(xyzList));
FieldValues fieldValues = new FieldValues(vectorList);

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ValueAtPointBase
Autodesk.Revit.DB.Analysis..::..VectorAtPoint

See Also

VectorAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Members

[image] [image]

Revit 2013 API
VectorAtPoint Members
VectorAtPoint Class Constructors Methods See Also Send Feedback

The VectorAtPoint type exposes the following members.

Constructors

 | Name | Description
Public method | VectorAtPoint(VectorAtPoint) | Initializes a new instance of the VectorAtPoint class
Public method | VectorAtPoint(IList<(Of <<'(XYZ>)>>)) | Creates object from an array of vectors

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements; (Inherited from ValueAtPointBase.)
Public method | ClearFlagsAt | Clears flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | Dispose | (Inherited from ValueAtPointBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VectorAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Constructor

[image] [image]

Revit 2013 API
VectorAtPoint Constructor
VectorAtPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | VectorAtPoint(VectorAtPoint) | Initializes a new instance of the VectorAtPoint class
Public method | VectorAtPoint(IList<(Of <<'(XYZ>)>>)) | Creates object from an array of vectors

See Also

VectorAtPoint Class
VectorAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Constructor (VectorAtPoint)

[image]

Revit 2013 API
VectorAtPoint Constructor (VectorAtPoint)
VectorAtPoint Class See Also Send Feedback
Initializes a new instance of the VectorAtPoint class

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public VectorAtPoint(
    VectorAtPoint otherObject
)
Visual Basic
Public Sub New ( _
    otherObject As VectorAtPoint _
)
Visual C++
public:
VectorAtPoint(
    VectorAtPoint^ otherObject
)

Parameters

otherObject
Type: Autodesk.Revit.DB.Analysis..::..VectorAtPoint

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

VectorAtPoint Class
VectorAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Constructor (IList(XYZ))

[image]

Revit 2013 API
VectorAtPoint Constructor (IList<(Of <(<'XYZ>)>)>)
VectorAtPoint Class See Also Send Feedback
Creates object from an array of vectors

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public VectorAtPoint(
    IList<XYZ> vectors
)
Visual Basic
Public Sub New ( _
    vectors As IList(Of XYZ) _
)
Visual C++
public:
VectorAtPoint(
    IList<XYZ^>^ vectors
)

Parameters

vectors
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Array of vectors, each corresponding to "measurement"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when supplied vectors contain invalid (infinite or non-number) coordinates
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

VectorAtPoint Class
VectorAtPoint Overload
Autodesk.Revit.DB.Analysis Namespace


VectorAtPoint Methods

[image] [image]

Revit 2013 API
VectorAtPoint Methods
VectorAtPoint Class See Also Send Feedback

The VectorAtPoint type exposes the following members.

Methods

 | Name | Description
Public method | ClearAllFlags | Clears flags for all measurements; (Inherited from ValueAtPointBase.)
Public method | ClearFlagsAt | Clears flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | Dispose | (Inherited from ValueAtPointBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFlags | Returns flags for the given measurement; (Inherited from ValueAtPointBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VectorAtPoint Class
Autodesk.Revit.DB.Analysis Namespace


SetFlags Method

[image] [image]

Revit 2013 API
VectorAtPoint..::..SetFlags Method
VectorAtPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetFlags(IList<(Of <<'(Int32>)>>)) | Sets flags from an array of flags; (Inherited from ValueAtPointBase.)
Public method | SetFlags(Int32) | Sets all flags using the value of one flag; (Inherited from ValueAtPointBase.)

See Also

VectorAtPoint Class
VectorAtPoint Members
Autodesk.Revit.DB.Analysis Namespace


Autodesk.Revit.DB.Architecture Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Architecture Namespace
Send Feedback

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of a room boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.
Public class | ContinuousRail | Represents a continuous rail element in Autodesk Revit. Type Data Misc Data Path and Profile Data
Public class | ContinuousRailType |
Public class | CutMarkType | An object represents the cut mark type in Autodesk Revit.
Public class | Fascia | An object that represents a fascia within the Autodesk Revit project.
Public class | FasciaType | An object that represents the fascia type in Autodesk Revit.
Public class | FasciaTypeSet | A set that contains fascia types.
Public class | FasciaTypeSetIterator | An iterator to a fascia type set.
Public class | Gutter | An object that represents a gutter within the Autodesk Revit project.
Public class | GutterType | An object that represents the gutter type in Autodesk Revit.
Public class | GutterTypeSet | A set that contains gutter types.
Public class | GutterTypeSetIterator | An iterator to a gutter type set.
Public class | HandRail | Represents a hand rail element in Autodesk Revit.
Public class | HandRailType | A rail type object that is used in the generation of hand rail.
Public class | Railing | Represents a railing element in Autodesk Revit.
Public class | RailingType | A railing type object that is used in the generation of railing.
Public class | Room | Provides access to the room topology in Autodesk Revit.
Public class | RoomFilter | A filter used to match rooms.
Public class | RoomTag | Provides access to the room tag in Autodesk Revit.
Public class | RoomTagFilter | A filter used to match room tags.
Public class | RoomTagType | An object that represents a Room Tag type.
Public class | RoomTagTypeSet | A set that contains room tag types.
Public class | RoomTagTypeSetIterator | An iterator to a room tag type set.
Public class | Stairs | Represents a stairs element in Autodesk Revit.
Public class | StairsLanding | An object that represents a stairs landing in Autodesk Revit.
Public class | StairsLandingType | Represents a stairs landing type in Autodesk Revit.
Public class | StairsPath | An object that represents the stairs path.
Public class | StairsPathType | An object represents the stairs path type.
Public class | StairsRun | Represents a stairs run element in Autodesk Revit.
Public class | StairsRunType | A stairs run type object that is used in the generation of stairs run.
Public class | StairsType |
Public class | TopRail | Represents a top rail element in Autodesk Revit.
Public class | TopRailType | A rail type object that is used in the generation of top rail.

Enumerations

 | Enumeration | Description
Public enumeration | BoundaryLocationType | An enumerated type listing the options for volume computation in Autodesk Revit.
Public enumeration | CutLineType | The available line types for a stairs cut line.
Public enumeration | CutMarkSymbol | The available shapes for the cut mark symbol.
Public enumeration | HandRailPosition | The position of the hand rail.
Public enumeration | RailAngledJoinOption | The angled joins of the rails.
Public enumeration | RailConnectionOption | The connections between rails.
Public enumeration | RailExtensionStyle | The extension style of the rail.
Public enumeration | RailIndex | The continuous rail position index.
Public enumeration | RailingHeightCorrectionOption | Railing height correction option.
Public enumeration | RailingPathCurveJoinOption | The join type of the railing path.
Public enumeration | RailingPlacementPosition | Railing placement position.
Public enumeration | RailingSlopeOption | The option determines the slope of the railing.
Public enumeration | RailJoinOption | The join type of the system rails.
Public enumeration | RailSupportJustification | The justification of the rail supports.
Public enumeration | RailSupportsLayout | The layout of the rail supports.
Public enumeration | RailTagentJoinOption | The tangent joins of the rails.
Public enumeration | RailTransitionOption | The transition type of the continuous rail.
Public enumeration | RailTypeDefaultJoinOption | The default join type of the rail.
Public enumeration | RiserToTreadConnectionOption | Represents the connection style of the riser and tread in relation to each other.
Public enumeration | StairsConstructionMethod | Represents the construction method of the stairs.
Public enumeration | StairsEndConnectionType | The join style between a run and landing.
Public enumeration | StairsEndNotchOption | The style of notch width for the stairs.
Public enumeration | StairsLogicalJoinEndType | The end type of logical join between stairs components.
Public enumeration | StairsNumberSystemReferenceOption | The reference types permitted for a number system to refer to the geometry of a stairs run.
Public enumeration | StairsPathDirection | The direction style of stairs path.
Public enumeration | StairsPathLineShapeAtCorner | The options for the line shape of a stairs path at a corner.
Public enumeration | StairsRunJustification | The position of the run relative to the Up-direction path used to create the run.
Public enumeration | StairsRunStyle | The shape of a run. Different shape has different ways of manipulation.
Public enumeration | StairsSupportTopsideSurfaceType | The style of the topside surface of the support.
Public enumeration | StairsTextOrientation | The options to be used when orienting text annotations relative to stairs.
Public enumeration | StairsUndersideSurfaceStyle | The style of the underside surface of the run.
Public enumeration | StairsWinderStyle | The calculation method for the layout of the winder run steps.
Public enumeration | TreadNosingPosition | Represents on which edges of the nosing to apply the nosing profile.
Public enumeration | WinderPathResult | Flag indicates whether curves are valid to use as base lines for winder path.


BoundaryLocationType Enumeration

[image]

Revit 2013 API
BoundaryLocationType Enumeration
See Also Send Feedback
An enumerated type listing the options for volume computation in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum BoundaryLocationType
Visual Basic
Public Enumeration BoundaryLocationType
Visual C++
public enum class BoundaryLocationType

Members

Member name | Description
WallFinish | Room area is computed at wall finish.
WallCenter | Room area is computed at wall center.
WallCoreLayer | Room area is computed at wall core layer.
WallCoreCenter | Room area is computed at wall core center.

See Also

Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Class

[image]

Revit 2013 API
BoundarySegment Class
Members Example See Also Send Feedback
An object that represents a segment of a room boundary.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of a room. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Examples

CopyC#
public void GetInfo_BoundarySegment(Room room)
{
    if (room.GetBoundarySegments(new SpatialElementBoundaryOptions()) != null)
    {
        string message = "BoundarySegment";
        foreach (Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray in room.GetBoundarySegments(new SpatialElementBoundaryOptions()))
        {
           foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                message += "\nCurve start point:(" + boundarySegment.Curve.get_EndPoint(0).X + ","
                               + boundarySegment.Curve.get_EndPoint(0).Y + "," +
                              boundarySegment.Curve.get_EndPoint(0).Z + ")";
                // Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.get_EndPoint(1).X + ","
                     + boundarySegment.Curve.get_EndPoint(1).Y + "," +
                     boundarySegment.Curve.get_EndPoint(1).Z + ")";
                // Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName;
                // Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name;
            }
        }
        TaskDialog.Show("Revit",message);
    }
}
CopyVB.NET
Public Sub GetInfo_BoundarySegment(ByVal room As Room)
    If room.Boundary IsNot Nothing Then
        Dim message As String = "BoundarySegment"
        For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
            For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                ' Get curve start point
                message += vbLf & "Curve start point:(" + boundarySegment.Curve.EndPoint(0).X + "," + boundarySegment.Curve.EndPoint(0).Y + "," + boundarySegment.Curve.EndPoint(0).Z + ")"
                ' Get curve end point
                message += "; Curve end point:(" + boundarySegment.Curve.EndPoint(1).X + "," + boundarySegment.Curve.EndPoint(1).Y + "," + boundarySegment.Curve.EndPoint(1).Z + ")"
                ' Get document path name
                message += "; Document path name:" + boundarySegment.Document.PathName
                ' Get boundary segment element name
                message += "; Element name:" + boundarySegment.Element.Name
            Next
        Next
        TaskDialog.Show("Revit", message)
    End If
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Members

[image] [image]

Revit 2013 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Methods

[image] [image]

Revit 2013 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegment Properties

[image] [image]

Revit 2013 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this room.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Curve Property

[image]

Revit 2013 API
BoundarySegment..::..Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Document Property

[image]

Revit 2013 API
BoundarySegment..::..Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


Element Property

[image]

Revit 2013 API
BoundarySegment..::..Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific room.

See Also

BoundarySegment Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Class

[image]

Revit 2013 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Constructor

[image]

Revit 2013 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Append Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::..Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArray..::..IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Item Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegment this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
    Get
    Set
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2013 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment array into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Append Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback
Insert the specified boundary segment array into the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..BoundarySegmentArray
The boundary segment array to be inserted into the array.
index
Type: System..::..Int32
The boundary segment array will be inserted before this index.

Return Value

Returns whether the boundary segment array was inserted into the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Item Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
    Get
    Set
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Architecture Namespace


ContinuousRail Class

[image]

Revit 2013 API
ContinuousRail Class
Members See Also Send Feedback
Represents a continuous rail element in Autodesk Revit. Type Data Misc Data Path and Profile Data

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ContinuousRail : Element
Visual Basic
Public Class ContinuousRail _
    Inherits Element
Visual C++
public ref class ContinuousRail : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..ContinuousRail
Autodesk.Revit.DB.Architecture..::..HandRail
Autodesk.Revit.DB.Architecture..::..TopRail

See Also

ContinuousRail Members
Autodesk.Revit.DB.Architecture Namespace


ContinuousRail Members

[image] [image]

Revit 2013 API
ContinuousRail Members
ContinuousRail Class Methods Properties See Also Send Feedback

The ContinuousRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path.
Public method | GetSupports | Returns all the railing supports attached to the rail.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


ContinuousRail Methods

[image] [image]

Revit 2013 API
ContinuousRail Methods
ContinuousRail Class See Also Send Feedback

The ContinuousRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path.
Public method | GetSupports | Returns all the railing supports attached to the rail.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


GetEndExtensionPath Method

[image]

Revit 2013 API
ContinuousRail..::..GetEndExtensionPath Method
ContinuousRail Class See Also Send Feedback
Retrieves the start extension path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetEndExtensionPath()
Visual Basic
Public Function GetEndExtensionPath As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetEndExtensionPath()

Return Value

The start extension path of the rail.

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


GetPath Method

[image]

Revit 2013 API
ContinuousRail..::..GetPath Method
ContinuousRail Class See Also Send Feedback
Retrieves the rail path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetPath()
Visual Basic
Public Function GetPath As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetPath()

Return Value

The path of the rail.

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


GetStartExtensionPath Method

[image]

Revit 2013 API
ContinuousRail..::..GetStartExtensionPath Method
ContinuousRail Class See Also Send Feedback
Retrieves the start extension path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetStartExtensionPath()
Visual Basic
Public Function GetStartExtensionPath As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetStartExtensionPath()

Return Value

The start extension path of the rail.

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


GetSupports Method

[image]

Revit 2013 API
ContinuousRail..::..GetSupports Method
ContinuousRail Class See Also Send Feedback
Returns all the railing supports attached to the rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetSupports()
Visual Basic
Public Function GetSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetSupports()

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


ContinuousRail Properties

[image] [image]

Revit 2013 API
ContinuousRail Properties
ContinuousRail Class See Also Send Feedback

The ContinuousRail type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


HostRailingId Property

[image]

Revit 2013 API
ContinuousRail..::..HostRailingId Property
ContinuousRail Class See Also Send Feedback
The id of the host Railing that contains this rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId HostRailingId { get; }
Visual Basic
Public ReadOnly Property HostRailingId As ElementId
    Get
Visual C++
public:
property ElementId^ HostRailingId {
    ElementId^ get ();
}

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


Length Property

[image]

Revit 2013 API
ContinuousRail..::..Length Property
ContinuousRail Class See Also Send Feedback
The length of the rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

See Also

ContinuousRail Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
ContinuousRail..::..Parameter Property
ContinuousRail Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ContinuousRail Class
ContinuousRail Members
Autodesk.Revit.DB.Architecture Namespace


ContinuousRailType Class

[image]

Revit 2013 API
ContinuousRailType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ContinuousRailType : ElementType
Visual Basic
Public Class ContinuousRailType _
    Inherits ElementType
Visual C++
public ref class ContinuousRailType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..ContinuousRailType
Autodesk.Revit.DB.Architecture..::..HandRailType
Autodesk.Revit.DB.Architecture..::..TopRailType

See Also

ContinuousRailType Members
Autodesk.Revit.DB.Architecture Namespace


ContinuousRailType Members

[image] [image]

Revit 2013 API
ContinuousRailType Members
ContinuousRailType Class Methods Properties See Also Send Feedback

The ContinuousRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top.
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top.
Public property | EndOrTopTermination | The termination of the rail at the end or top.
Public property | FilletRadius | The fillet radius of the rail join.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path.
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom.
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom.
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom.
Public property | Transition | The transition option of the rail.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


ContinuousRailType Methods

[image] [image]

Revit 2013 API
ContinuousRailType Methods
ContinuousRailType Class See Also Send Feedback

The ContinuousRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


ContinuousRailType Properties

[image] [image]

Revit 2013 API
ContinuousRailType Properties
ContinuousRailType Class See Also Send Feedback

The ContinuousRailType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top.
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top.
Public property | EndOrTopTermination | The termination of the rail at the end or top.
Public property | FilletRadius | The fillet radius of the rail join.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path.
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom.
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom.
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom.
Public property | Transition | The transition option of the rail.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


DefaultJoinOption Property

[image]

Revit 2013 API
ContinuousRailType..::..DefaultJoinOption Property
ContinuousRailType Class See Also Send Feedback
The default join option between two rails.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailTypeDefaultJoinOption DefaultJoinOption { get; set; }
Visual Basic
Public Property DefaultJoinOption As RailTypeDefaultJoinOption
    Get
    Set
Visual C++
public:
property RailTypeDefaultJoinOption DefaultJoinOption {
    RailTypeDefaultJoinOption get ();
    void set (RailTypeDefaultJoinOption value);
}

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


EndOrTopExtensionLength Property

[image]

Revit 2013 API
ContinuousRailType..::..EndOrTopExtensionLength Property
ContinuousRailType Class See Also Send Feedback
The extension length of the rail termination at the end or top.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EndOrTopExtensionLength { get; set; }
Visual Basic
Public Property EndOrTopExtensionLength As Double
    Get
    Set
Visual C++
public:
property double EndOrTopExtensionLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for endExtensionLength must be between 0 and 30000 feet.

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


EndOrTopExtensionStyle Property

[image]

Revit 2013 API
ContinuousRailType..::..EndOrTopExtensionStyle Property
ContinuousRailType Class See Also Send Feedback
The extension style of the rail termination at the end or top.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailExtensionStyle EndOrTopExtensionStyle { get; set; }
Visual Basic
Public Property EndOrTopExtensionStyle As RailExtensionStyle
    Get
    Set
Visual C++
public:
property RailExtensionStyle EndOrTopExtensionStyle {
    RailExtensionStyle get ();
    void set (RailExtensionStyle value);
}

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


EndOrTopTermination Property

[image]

Revit 2013 API
ContinuousRailType..::..EndOrTopTermination Property
ContinuousRailType Class See Also Send Feedback
The termination of the rail at the end or top.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId EndOrTopTermination { get; set; }
Visual Basic
Public Property EndOrTopTermination As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ EndOrTopTermination {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The termination is not a valid termination symbol for continuous rail.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


FilletRadius Property

[image]

Revit 2013 API
ContinuousRailType..::..FilletRadius Property
ContinuousRailType Class See Also Send Feedback
The fillet radius of the rail join.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double FilletRadius { get; set; }
Visual Basic
Public Property FilletRadius As Double
    Get
    Set
Visual C++
public:
property double FilletRadius {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for filletRadius must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The join option of the rail is not fillet so the data being set is not applicable.

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


HandClearance Property

[image]

Revit 2013 API
ContinuousRailType..::..HandClearance Property
ContinuousRailType Class See Also Send Feedback
The horizontal distance between the inner boundary of the rail and the path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double HandClearance { get; set; }
Visual Basic
Public Property HandClearance As Double
    Get
    Set
Visual C++
public:
property double HandClearance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for clearance must be no more than 30000 feet in absolute value.

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
ContinuousRailType..::..Parameter Property
ContinuousRailType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ContinuousRailType Class
ContinuousRailType Members
Autodesk.Revit.DB.Architecture Namespace


ProfileId Property

[image]

Revit 2013 API
ContinuousRailType..::..ProfileId Property
ContinuousRailType Class See Also Send Feedback
The id of the profile of the rail

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ProfileId { get; set; }
Visual Basic
Public Property ProfileId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ProfileId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The profileId is not a valid element id. -or- When setting this property: The profileId is not a valid profile symbol for continuous rail.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


Projection Property

[image]

Revit 2013 API
ContinuousRailType..::..Projection Property
ContinuousRailType Class See Also Send Feedback
The horizontal distance between the outer boundary of the rail and the path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Projection { get; }
Visual Basic
Public ReadOnly Property Projection As Double
    Get
Visual C++
public:
property double Projection {
    double get ();
}

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


StartOrBottomExtensionLength Property

[image]

Revit 2013 API
ContinuousRailType..::..StartOrBottomExtensionLength Property
ContinuousRailType Class See Also Send Feedback
The extension length of the rail termination at the beginning or bottom.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double StartOrBottomExtensionLength { get; set; }
Visual Basic
Public Property StartOrBottomExtensionLength As Double
    Get
    Set
Visual C++
public:
property double StartOrBottomExtensionLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for startExtensionLength must be between 0 and 30000 feet.

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


StartOrBottomExtensionStyle Property

[image]

Revit 2013 API
ContinuousRailType..::..StartOrBottomExtensionStyle Property
ContinuousRailType Class See Also Send Feedback
The extension style of the rail termination at the beginning or bottom.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailExtensionStyle StartOrBottomExtensionStyle { get; set; }
Visual Basic
Public Property StartOrBottomExtensionStyle As RailExtensionStyle
    Get
    Set
Visual C++
public:
property RailExtensionStyle StartOrBottomExtensionStyle {
    RailExtensionStyle get ();
    void set (RailExtensionStyle value);
}

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


StartOrBottomTermination Property

[image]

Revit 2013 API
ContinuousRailType..::..StartOrBottomTermination Property
ContinuousRailType Class See Also Send Feedback
The termination of the rail at the beginning or bottom.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId StartOrBottomTermination { get; set; }
Visual Basic
Public Property StartOrBottomTermination As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StartOrBottomTermination {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The termination is not a valid termination symbol for continuous rail.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


Transition Property

[image]

Revit 2013 API
ContinuousRailType..::..Transition Property
ContinuousRailType Class See Also Send Feedback
The transition option of the rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailTransitionOption Transition { get; set; }
Visual Basic
Public Property Transition As RailTransitionOption
    Get
    Set
Visual C++
public:
property RailTransitionOption Transition {
    RailTransitionOption get ();
    void set (RailTransitionOption value);
}

See Also

ContinuousRailType Class
Autodesk.Revit.DB.Architecture Namespace


CutLineType Enumeration

[image]

Revit 2013 API
CutLineType Enumeration
See Also Send Feedback
The available line types for a stairs cut line.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum CutLineType
Visual Basic
Public Enumeration CutLineType
Visual C++
public enum class CutLineType

Members

Member name | Description
SingleLine | Cutline type is single-line.
DoubleLine | Cutline type is double-line.

See Also

Autodesk.Revit.DB.Architecture Namespace


CutMarkSymbol Enumeration

[image]

Revit 2013 API
CutMarkSymbol Enumeration
See Also Send Feedback
The available shapes for the cut mark symbol.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum CutMarkSymbol
Visual Basic
Public Enumeration CutMarkSymbol
Visual C++
public enum class CutMarkSymbol

Members

Member name | Description
None | Cut mark shape is linear.
Zigzag | Cut mark shape is zigzagged.
Curve | Cut mark shape is curved.

See Also

Autodesk.Revit.DB.Architecture Namespace


CutMarkType Class

[image]

Revit 2013 API
CutMarkType Class
Members See Also Send Feedback
An object represents the cut mark type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CutMarkType : ElementType
Visual Basic
Public Class CutMarkType _
    Inherits ElementType
Visual C++
public ref class CutMarkType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..CutMarkType

See Also

CutMarkType Members
Autodesk.Revit.DB.Architecture Namespace


CutMarkType Members

[image] [image]

Revit 2013 API
CutMarkType Members
CutMarkType Class Methods Properties See Also Send Feedback

The CutMarkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutLineAngle | The rotation angle of the cut mark.
Public property | CutLineDistance | The distance between 2 cut lines.
Public property | CutLineExtension | The extension distance to the boundary.
Public property | CutLineType | The cut line type of the cut mark.
Public property | CutMarkSymbol | The symbol type of the cut mark.
Public property | CutMarkSymbolSize | The size of the cut mark symbol.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutMarkType Methods

[image] [image]

Revit 2013 API
CutMarkType Methods
CutMarkType Class See Also Send Feedback

The CutMarkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutMarkType Properties

[image] [image]

Revit 2013 API
CutMarkType Properties
CutMarkType Class See Also Send Feedback

The CutMarkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutLineAngle | The rotation angle of the cut mark.
Public property | CutLineDistance | The distance between 2 cut lines.
Public property | CutLineExtension | The extension distance to the boundary.
Public property | CutLineType | The cut line type of the cut mark.
Public property | CutMarkSymbol | The symbol type of the cut mark.
Public property | CutMarkSymbolSize | The size of the cut mark symbol.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutLineAngle Property

[image]

Revit 2013 API
CutMarkType..::..CutLineAngle Property
CutMarkType Class See Also Send Feedback
The rotation angle of the cut mark.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutLineAngle { get; set; }
Visual Basic
Public Property CutLineAngle As Double
    Get
    Set
Visual C++
public:
property double CutLineAngle {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for rotationAngle is not finite

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutLineDistance Property

[image]

Revit 2013 API
CutMarkType..::..CutLineDistance Property
CutMarkType Class See Also Send Feedback
The distance between 2 cut lines.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutLineDistance { get; set; }
Visual Basic
Public Property CutLineDistance As Double
    Get
    Set
Visual C++
public:
property double CutLineDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for distanceBetweenTwoLines must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The cut mark type is not a double cut line type.

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutLineExtension Property

[image]

Revit 2013 API
CutMarkType..::..CutLineExtension Property
CutMarkType Class See Also Send Feedback
The extension distance to the boundary.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutLineExtension { get; set; }
Visual Basic
Public Property CutLineExtension As Double
    Get
    Set
Visual C++
public:
property double CutLineExtension {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for extensionDistanceToBoundary must be between 0 and 30000 feet.

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutLineType Property

[image]

Revit 2013 API
CutMarkType..::..CutLineType Property
CutMarkType Class See Also Send Feedback
The cut line type of the cut mark.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CutLineType CutLineType { get; set; }
Visual Basic
Public Property CutLineType As CutLineType
    Get
    Set
Visual C++
public:
property CutLineType CutLineType {
    CutLineType get ();
    void set (CutLineType value);
}

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutMarkSymbol Property

[image]

Revit 2013 API
CutMarkType..::..CutMarkSymbol Property
CutMarkType Class See Also Send Feedback
The symbol type of the cut mark.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CutMarkSymbol CutMarkSymbol { get; set; }
Visual Basic
Public Property CutMarkSymbol As CutMarkSymbol
    Get
    Set
Visual C++
public:
property CutMarkSymbol CutMarkSymbol {
    CutMarkSymbol get ();
    void set (CutMarkSymbol value);
}

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


CutMarkSymbolSize Property

[image]

Revit 2013 API
CutMarkType..::..CutMarkSymbolSize Property
CutMarkType Class See Also Send Feedback
The size of the cut mark symbol.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutMarkSymbolSize { get; set; }
Visual Basic
Public Property CutMarkSymbolSize As Double
    Get
    Set
Visual C++
public:
property double CutMarkSymbolSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for cutMarkSymbolSize must be greater than 0 and no more than 30000 feet.

See Also

CutMarkType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
CutMarkType..::..Parameter Property
CutMarkType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CutMarkType Class
CutMarkType Members
Autodesk.Revit.DB.Architecture Namespace


Fascia Class

[image]

Revit 2013 API
Fascia Class
Members See Also Send Feedback
An object that represents a fascia within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Fascia : HostedSweep
Visual Basic
Public Class Fascia _
    Inherits HostedSweep
Visual C++
public ref class Fascia : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB.Architecture..::..Fascia

See Also

Fascia Members
Autodesk.Revit.DB.Architecture Namespace


Fascia Members

[image] [image]

Revit 2013 API
Fascia Members
Fascia Class Methods Properties See Also Send Feedback

The Fascia type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the fascia. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FasciaType | Retrieves/set an object that represents the type of the Fascia.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Fascia Methods

[image] [image]

Revit 2013 API
Fascia Methods
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the fascia. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


AddSegment Method

[image]

Revit 2013 API
Fascia..::..AddSegment Method
Fascia Class See Also Send Feedback
Add segments to the fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is nullNothingnullptra null reference (Nothing in Visual Basic). 2. Input targetRef is not nullNothingnullptra null reference (Nothing in Visual Basic) but contains nothing.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the fascia. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | This exception will be thrown if the reference is suitable for creating a fascia as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Other fascia's horizontal edges

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Fascia Properties

[image] [image]

Revit 2013 API
Fascia Properties
Fascia Class See Also Send Feedback

The Fascia type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FasciaType | Retrieves/set an object that represents the type of the Fascia.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Property

[image]

Revit 2013 API
Fascia..::..FasciaType Property
Fascia Class See Also Send Feedback
Retrieves/set an object that represents the type of the Fascia.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FasciaType FasciaType { get; set; }
Visual Basic
Public Property FasciaType As FasciaType
    Get
    Set
Visual C++
public:
property FasciaType^ FasciaType {
    FasciaType^ get ();
    void set (FasciaType^ value);
}

See Also

Fascia Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
Fascia..::..Parameter Property
Fascia Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Fascia Class
Fascia Members
Autodesk.Revit.DB.Architecture Namespace


FasciaType Class

[image]

Revit 2013 API
FasciaType Class
Members See Also Send Feedback
An object that represents the fascia type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FasciaType : HostedSweepType
Visual Basic
Public Class FasciaType _
    Inherits HostedSweepType
Visual C++
public ref class FasciaType : public HostedSweepType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB.Architecture..::..FasciaType

See Also

FasciaType Members
Autodesk.Revit.DB.Architecture Namespace


FasciaType Members

[image] [image]

Revit 2013 API
FasciaType Members
FasciaType Class Methods Properties See Also Send Feedback

The FasciaType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Methods

[image] [image]

Revit 2013 API
FasciaType Methods
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


FasciaType Properties

[image] [image]

Revit 2013 API
FasciaType Properties
FasciaType Class See Also Send Feedback

The FasciaType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FasciaType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
FasciaType..::..Parameter Property
FasciaType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FasciaType Class
FasciaType Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Class

[image]

Revit 2013 API
FasciaTypeSet Class
Members See Also Send Feedback
A set that contains fascia types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FasciaTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class FasciaTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class FasciaTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..FasciaTypeSet

See Also

FasciaTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Members

[image] [image]

Revit 2013 API
FasciaTypeSet Members
FasciaTypeSet Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | FasciaTypeSet | Initializes a new instance of the FasciaTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every fascia type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fascia type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fascia type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fascia type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Constructor

[image]

Revit 2013 API
FasciaTypeSet Constructor
FasciaTypeSet Class See Also Send Feedback
Initializes a new instance of the FasciaTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FasciaTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
FasciaTypeSet()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Methods

[image] [image]

Revit 2013 API
FasciaTypeSet Methods
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every fascia type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a fascia type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified fascia type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified fascia type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2013 API
FasciaTypeSet..::..Clear Method
FasciaTypeSet Class See Also Send Feedback
Removes every fascia type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2013 API
FasciaTypeSet..::..Contains Method
FasciaTypeSet Class See Also Send Feedback
Tests for the existence of a fascia type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    FasciaType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The fascia type to be searched for.

Return Value

The Contains method returns True if the fascia type is within the set, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2013 API
FasciaTypeSet..::..Erase Method
FasciaTypeSet Class See Also Send Feedback
Removes a specified fascia type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    FasciaType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As FasciaType _
) As Integer
Visual C++
public:
virtual int Erase(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The fascia type to be erased.

Return Value

The number of fascia types that were erased from the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2013 API
FasciaTypeSet..::..ForwardIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2013 API
FasciaTypeSet..::..GetEnumerator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2013 API
FasciaTypeSet..::..Insert Method
FasciaTypeSet Class See Also Send Feedback
Insert the specified fascia type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    FasciaType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As FasciaType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    FasciaType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..FasciaType
The fascia type to be inserted into the set.

Return Value

Returns whether the fascia type was inserted into the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2013 API
FasciaTypeSet..::..ReverseIterator Method
FasciaTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FasciaTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As FasciaTypeSetIterator
Visual C++
public:
virtual FasciaTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSet Properties

[image] [image]

Revit 2013 API
FasciaTypeSet Properties
FasciaTypeSet Class See Also Send Feedback

The FasciaTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of fascia types that are in the set.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2013 API
FasciaTypeSet..::..IsEmpty Property
FasciaTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2013 API
FasciaTypeSet..::..Size Property
FasciaTypeSet Class See Also Send Feedback
Returns the number of fascia types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

FasciaTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Class

[image]

Revit 2013 API
FasciaTypeSetIterator Class
Members See Also Send Feedback
An iterator to a fascia type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class FasciaTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class FasciaTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class FasciaTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..FasciaTypeSetIterator

See Also

FasciaTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Members

[image] [image]

Revit 2013 API
FasciaTypeSetIterator Members
FasciaTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | FasciaTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Constructor

[image]

Revit 2013 API
FasciaTypeSetIterator Constructor
FasciaTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FasciaTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
FasciaTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Methods

[image] [image]

Revit 2013 API
FasciaTypeSetIterator Methods
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2013 API
FasciaTypeSetIterator..::..MoveNext Method
FasciaTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
FasciaTypeSetIterator..::..Reset Method
FasciaTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


FasciaTypeSetIterator Properties

[image] [image]

Revit 2013 API
FasciaTypeSetIterator Properties
FasciaTypeSetIterator Class See Also Send Feedback

The FasciaTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2013 API
FasciaTypeSetIterator..::..Current Property
FasciaTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

FasciaTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Class

[image]

Revit 2013 API
Gutter Class
Members See Also Send Feedback
An object that represents a gutter within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Gutter : HostedSweep
Visual Basic
Public Class Gutter _
    Inherits HostedSweep
Visual C++
public ref class Gutter : public HostedSweep

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..HostedSweep
Autodesk.Revit.DB.Architecture..::..Gutter

See Also

Gutter Members
Autodesk.Revit.DB.Architecture Namespace


Gutter Members

[image] [image]

Revit 2013 API
Gutter Members
Gutter Class Methods Properties See Also Send Feedback

The Gutter type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the gutter. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | GutterType | Retrieves/set an object that represents the type of the Gutter.
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Methods

[image] [image]

Revit 2013 API
Gutter Methods
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Methods

 | Name | Description
Public method | AddSegment | Add segments to the gutter. (Overrides HostedSweep..::..AddSegment(Reference).)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndPointParameter | Retrieve segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HorizontalFlip | Flip the hosted sweep object along horizontal line. (Inherited from HostedSweep.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSegment | Remove segments from the hosted sweep object. (Inherited from HostedSweep.)
Public method | SetEndPointParameter | Set segment's start point or end point parameter. (Inherited from HostedSweep.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | VerticalFlip | Flip the hosted sweep object along vertical line. (Inherited from HostedSweep.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


AddSegment Method

[image]

Revit 2013 API
Gutter..::..AddSegment Method
Gutter Class See Also Send Feedback
Add segments to the gutter.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void AddSegment(
    Reference targetRef
)
Visual Basic
Public Overrides Sub AddSegment ( _
    targetRef As Reference _
)
Visual C++
public:
virtual void AddSegment(
    Reference^ targetRef
) override

Parameters

targetRef
Type: Autodesk.Revit.DB..::..Reference
Segment's reference on which want to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | This exception will be thrown in following cases: 1. Input targetRef is null. 2. Input targetRef is not null but contains nothing.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This exception will be thrown in following cases: 1. Input targetRef has already been added into the gutter. 2. Internal code fails to create the segment object. 3. Regeneration fails.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | This exception will be thrown if the reference is not suitable for creating a gutter as required. The reference allowed is : 1. Model Line 2. Roof's horizontal edges 3. Soffit's horizontal edges 4. Fascia's horizontal edges

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Gutter Properties

[image] [image]

Revit 2013 API
Gutter Properties
Gutter Class See Also Send Feedback

The Gutter type exposes the following members.

Properties

 | Name | Description
Public property | Angle | Retrieve/set the angle of the hosted sweep object relative its references (Unit : Radian). (Inherited from HostedSweep.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | GutterType | Retrieves/set an object that represents the type of the Gutter.
Public property | HorizontalFlipped | Retrieve the horizontal flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | HorizontalOffset | Retrieve/set the horizontal offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | Retrieve the length of the hosted sweep object. (Inherited from HostedSweep.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceCurve | The curve on which the hosted sweep segment is created. (Inherited from HostedSweep.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | VerticalFlipped | Retrieve the vertical flip status of the hosted sweep object. (Inherited from HostedSweep.)
Public property | VerticalOffset | Retrieve/set the vertical offset of the hosted sweep object. (Inherited from HostedSweep.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Property

[image]

Revit 2013 API
Gutter..::..GutterType Property
Gutter Class See Also Send Feedback
Retrieves/set an object that represents the type of the Gutter.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GutterType GutterType { get; set; }
Visual Basic
Public Property GutterType As GutterType
    Get
    Set
Visual C++
public:
property GutterType^ GutterType {
    GutterType^ get ();
    void set (GutterType^ value);
}

See Also

Gutter Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
Gutter..::..Parameter Property
Gutter Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Gutter Class
Gutter Members
Autodesk.Revit.DB.Architecture Namespace


GutterType Class

[image]

Revit 2013 API
GutterType Class
Members See Also Send Feedback
An object that represents the gutter type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GutterType : HostedSweepType
Visual Basic
Public Class GutterType _
    Inherits HostedSweepType
Visual C++
public ref class GutterType : public HostedSweepType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..HostedSweepType
Autodesk.Revit.DB.Architecture..::..GutterType

See Also

GutterType Members
Autodesk.Revit.DB.Architecture Namespace


GutterType Members

[image] [image]

Revit 2013 API
GutterType Members
GutterType Class Methods Properties See Also Send Feedback

The GutterType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Methods

[image] [image]

Revit 2013 API
GutterType Methods
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


GutterType Properties

[image] [image]

Revit 2013 API
GutterType Properties
GutterType Class See Also Send Feedback

The GutterType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

GutterType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
GutterType..::..Parameter Property
GutterType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

GutterType Class
GutterType Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Class

[image]

Revit 2013 API
GutterTypeSet Class
Members See Also Send Feedback
A set that contains gutter types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GutterTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class GutterTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GutterTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..GutterTypeSet

See Also

GutterTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Members

[image] [image]

Revit 2013 API
GutterTypeSet Members
GutterTypeSet Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | GutterTypeSet | Initializes a new instance of the GutterTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every gutter type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a gutter type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified gutter type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified gutter type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Constructor

[image]

Revit 2013 API
GutterTypeSet Constructor
GutterTypeSet Class See Also Send Feedback
Initializes a new instance of the GutterTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GutterTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
GutterTypeSet()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Methods

[image] [image]

Revit 2013 API
GutterTypeSet Methods
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every gutter type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a gutter type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified gutter type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified gutter type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2013 API
GutterTypeSet..::..Clear Method
GutterTypeSet Class See Also Send Feedback
Removes every gutter type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2013 API
GutterTypeSet..::..Contains Method
GutterTypeSet Class See Also Send Feedback
Tests for the existence of a gutter type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    GutterType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The gutter type to be searched for.

Return Value

The Contains method returns True if the gutter type is within the set, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2013 API
GutterTypeSet..::..Erase Method
GutterTypeSet Class See Also Send Feedback
Removes a specified gutter type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    GutterType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As GutterType _
) As Integer
Visual C++
public:
virtual int Erase(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The gutter type to be erased.

Return Value

The number of gutter types that were erased from the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2013 API
GutterTypeSet..::..ForwardIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2013 API
GutterTypeSet..::..GetEnumerator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2013 API
GutterTypeSet..::..Insert Method
GutterTypeSet Class See Also Send Feedback
Insert the specified gutter type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    GutterType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GutterType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GutterType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..GutterType
The gutter type to be inserted into the set.

Return Value

Returns whether the gutter type was inserted into the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2013 API
GutterTypeSet..::..ReverseIterator Method
GutterTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GutterTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GutterTypeSetIterator
Visual C++
public:
virtual GutterTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSet Properties

[image] [image]

Revit 2013 API
GutterTypeSet Properties
GutterTypeSet Class See Also Send Feedback

The GutterTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of gutter types that are in the set.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2013 API
GutterTypeSet..::..IsEmpty Property
GutterTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2013 API
GutterTypeSet..::..Size Property
GutterTypeSet Class See Also Send Feedback
Returns the number of gutter types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GutterTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Class

[image]

Revit 2013 API
GutterTypeSetIterator Class
Members See Also Send Feedback
An iterator to a gutter type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GutterTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GutterTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GutterTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..GutterTypeSetIterator

See Also

GutterTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Members

[image] [image]

Revit 2013 API
GutterTypeSetIterator Members
GutterTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GutterTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Constructor

[image]

Revit 2013 API
GutterTypeSetIterator Constructor
GutterTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GutterTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GutterTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Methods

[image] [image]

Revit 2013 API
GutterTypeSetIterator Methods
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2013 API
GutterTypeSetIterator..::..MoveNext Method
GutterTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
GutterTypeSetIterator..::..Reset Method
GutterTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


GutterTypeSetIterator Properties

[image] [image]

Revit 2013 API
GutterTypeSetIterator Properties
GutterTypeSetIterator Class See Also Send Feedback

The GutterTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2013 API
GutterTypeSetIterator..::..Current Property
GutterTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GutterTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


HandRail Class

[image]

Revit 2013 API
HandRail Class
Members See Also Send Feedback
Represents a hand rail element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class HandRail : ContinuousRail
Visual Basic
Public Class HandRail _
    Inherits ContinuousRail
Visual C++
public ref class HandRail : public ContinuousRail

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..ContinuousRail
Autodesk.Revit.DB.Architecture..::..HandRail

See Also

HandRail Members
Autodesk.Revit.DB.Architecture Namespace


HandRail Members

[image] [image]

Revit 2013 API
HandRail Members
HandRail Class Methods Properties See Also Send Feedback

The HandRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path. (Inherited from ContinuousRail.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetSupports | Returns all the railing supports attached to the rail. (Inherited from ContinuousRail.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail. (Inherited from ContinuousRail.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail. (Inherited from ContinuousRail.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HandRail Class
Autodesk.Revit.DB.Architecture Namespace


HandRail Methods

[image] [image]

Revit 2013 API
HandRail Methods
HandRail Class See Also Send Feedback

The HandRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path. (Inherited from ContinuousRail.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetSupports | Returns all the railing supports attached to the rail. (Inherited from ContinuousRail.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HandRail Class
Autodesk.Revit.DB.Architecture Namespace


HandRail Properties

[image] [image]

Revit 2013 API
HandRail Properties
HandRail Class See Also Send Feedback

The HandRail type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail. (Inherited from ContinuousRail.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail. (Inherited from ContinuousRail.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HandRail Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
HandRail..::..Parameter Property
HandRail Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HandRail Class
HandRail Members
Autodesk.Revit.DB.Architecture Namespace


HandRailPosition Enumeration

[image]

Revit 2013 API
HandRailPosition Enumeration
See Also Send Feedback
The position of the hand rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum HandRailPosition
Visual Basic
Public Enumeration HandRailPosition
Visual C++
public enum class HandRailPosition

Members

Member name | Description
None | No hand rail
Left | The hand rail is on the left side of railing.
Right | The hand rail is on the right side of railing.
LeftAndRight | The handrail is on both sides of the railing.

See Also

Autodesk.Revit.DB.Architecture Namespace


HandRailType Class

[image]

Revit 2013 API
HandRailType Class
Members See Also Send Feedback
A rail type object that is used in the generation of hand rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class HandRailType : ContinuousRailType
Visual Basic
Public Class HandRailType _
    Inherits ContinuousRailType
Visual C++
public ref class HandRailType : public ContinuousRailType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..ContinuousRailType
Autodesk.Revit.DB.Architecture..::..HandRailType

See Also

HandRailType Members
Autodesk.Revit.DB.Architecture Namespace


HandRailType Members

[image] [image]

Revit 2013 API
HandRailType Members
HandRailType Class Methods Properties See Also Send Feedback

The HandRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails. (Inherited from ContinuousRailType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopTermination | The termination of the rail at the end or top. (Inherited from ContinuousRailType.)
Public property | FilletRadius | The fillet radius of the rail join. (Inherited from ContinuousRailType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | Height | The height of the handrail.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail; (Inherited from ContinuousRailType.)
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | SupportJustification | The support justification method of the handrail.
Public property | SupportLayout | The support layout method of the handrail.
Public property | SupportNumber | The number of supports of the handrail.
Public property | SupportSpacing | The support spacing of the handrail.
Public property | SupportTypeId | The support type of the handrail.
Public property | Transition | The transition option of the rail. (Inherited from ContinuousRailType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


HandRailType Methods

[image] [image]

Revit 2013 API
HandRailType Methods
HandRailType Class See Also Send Feedback

The HandRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


HandRailType Properties

[image] [image]

Revit 2013 API
HandRailType Properties
HandRailType Class See Also Send Feedback

The HandRailType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails. (Inherited from ContinuousRailType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopTermination | The termination of the rail at the end or top. (Inherited from ContinuousRailType.)
Public property | FilletRadius | The fillet radius of the rail join. (Inherited from ContinuousRailType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | Height | The height of the handrail.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail; (Inherited from ContinuousRailType.)
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | SupportJustification | The support justification method of the handrail.
Public property | SupportLayout | The support layout method of the handrail.
Public property | SupportNumber | The number of supports of the handrail.
Public property | SupportSpacing | The support spacing of the handrail.
Public property | SupportTypeId | The support type of the handrail.
Public property | Transition | The transition option of the rail. (Inherited from ContinuousRailType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


Height Property

[image]

Revit 2013 API
HandRailType..::..Height Property
HandRailType Class See Also Send Feedback
The height of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be between 0 and 30000 feet.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
HandRailType..::..Parameter Property
HandRailType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

HandRailType Class
HandRailType Members
Autodesk.Revit.DB.Architecture Namespace


SupportJustification Property

[image]

Revit 2013 API
HandRailType..::..SupportJustification Property
HandRailType Class See Also Send Feedback
The support justification method of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailSupportJustification SupportJustification { get; set; }
Visual Basic
Public Property SupportJustification As RailSupportJustification
    Get
    Set
Visual C++
public:
property RailSupportJustification SupportJustification {
    RailSupportJustification get ();
    void set (RailSupportJustification value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support or the support layout is not fixed distance so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


SupportLayout Property

[image]

Revit 2013 API
HandRailType..::..SupportLayout Property
HandRailType Class See Also Send Feedback
The support layout method of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RailSupportsLayout SupportLayout { get; set; }
Visual Basic
Public Property SupportLayout As RailSupportsLayout
    Get
    Set
Visual C++
public:
property RailSupportsLayout SupportLayout {
    RailSupportsLayout get ();
    void set (RailSupportsLayout value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support specified so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


SupportNumber Property

[image]

Revit 2013 API
HandRailType..::..SupportNumber Property
HandRailType Class See Also Send Feedback
The number of supports of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int SupportNumber { get; set; }
Visual Basic
Public Property SupportNumber As Integer
    Get
    Set
Visual C++
public:
property int SupportNumber {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The supportNumber is a negative value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support or the support layout is not fixed number so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


SupportSpacing Property

[image]

Revit 2013 API
HandRailType..::..SupportSpacing Property
HandRailType Class See Also Send Feedback
The support spacing of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SupportSpacing { get; set; }
Visual Basic
Public Property SupportSpacing As Double
    Get
    Set
Visual C++
public:
property double SupportSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for supportSpacing must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no support or the support has inappropriate layout so the data being set is not applicable.

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


SupportTypeId Property

[image]

Revit 2013 API
HandRailType..::..SupportTypeId Property
HandRailType Class See Also Send Feedback
The support type of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SupportTypeId { get; set; }
Visual Basic
Public Property SupportTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ SupportTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The supportTypeId is not a valid rail support or invalidElementId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

HandRailType Class
Autodesk.Revit.DB.Architecture Namespace


RailAngledJoinOption Enumeration

[image]

Revit 2013 API
RailAngledJoinOption Enumeration
See Also Send Feedback
The angled joins of the rails.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailAngledJoinOption
Visual Basic
Public Enumeration RailAngledJoinOption
Visual C++
public enum class RailAngledJoinOption

Members

Member name | Description
AddVerticalOrHorizontalSegments | Add vertical or horizontal segments.
NoConnector | No connector.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailConnectionOption Enumeration

[image]

Revit 2013 API
RailConnectionOption Enumeration
See Also Send Feedback
The connections between rails.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailConnectionOption
Visual Basic
Public Enumeration RailConnectionOption
Visual C++
public enum class RailConnectionOption

Members

Member name | Description
Trim | Rails will be trimmed and cut with a vertical plane.
Weld | Rails will be joined in a manner as close to a miter as possible.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailExtensionStyle Enumeration

[image]

Revit 2013 API
RailExtensionStyle Enumeration
See Also Send Feedback
The extension style of the rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailExtensionStyle
Visual Basic
Public Enumeration RailExtensionStyle
Visual C++
public enum class RailExtensionStyle

Members

Member name | Description
None | The rail extends to nothing
Wall | The rail extends to wall.
Floor | The rail extends to floor.
Post | The rail extends to post.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailIndex Enumeration

[image]

Revit 2013 API
RailIndex Enumeration
See Also Send Feedback
The continuous rail position index.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailIndex
Visual Basic
Public Enumeration RailIndex
Visual C++
public enum class RailIndex

Members

Member name | Description
Top | The rail is located on the top of the railing.
LeftPrimary | The rail is a primary rail on the left.
RightPrimary | The rail is a primary rail on the right.
LeftSecondary | The rail is a secondary rail on the left.
RightSecondary | The rail is a secondary rail on the right.

See Also

Autodesk.Revit.DB.Architecture Namespace


Railing Class

[image]

Revit 2013 API
Railing Class
Members See Also Send Feedback
Represents a railing element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Railing : Element
Visual Basic
Public Class Railing _
    Inherits Element
Visual C++
public ref class Railing : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..Railing

See Also

Railing Members
Autodesk.Revit.DB.Architecture Namespace


Railing Members

[image] [image]

Revit 2013 API
Railing Members
Railing Class Methods Properties See Also Send Feedback

The Railing type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Automatically creates new railings with the specified railing type on all sides of a stairs element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the railing.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHandRails | Get all the handrails of the railing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Gets the railing path.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidHostForNewRailing | Checks whether new railing can be created and placed on the specified host.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveHost | Removes the association between the railing and its host.
Public method | Reset | Resets the railing to the default one that the system generates.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanReset | True if the railing can be reset, False otherwise.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Indicates if the railing is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasHost | Indicates if the railing has a host.
Public property | HostId | The host of the railing.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates if the railing is the default one that system generates.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TopRail | The top rail of the railing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Railing Methods

[image] [image]

Revit 2013 API
Railing Methods
Railing Class See Also Send Feedback

The Railing type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Automatically creates new railings with the specified railing type on all sides of a stairs element.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Flip | Flips the railing.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHandRails | Get all the handrails of the railing.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Gets the railing path.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidHostForNewRailing | Checks whether new railing can be created and placed on the specified host.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveHost | Removes the association between the railing and its host.
Public method | Reset | Resets the railing to the default one that the system generates.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Create Method

[image]

Revit 2013 API
Railing..::..Create Method
Railing Class See Also Send Feedback
Automatically creates new railings with the specified railing type on all sides of a stairs element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> Create(
    Document document,
    ElementId stairsId,
    ElementId railingTypeId,
    RailingPlacementPosition placePosition
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    stairsId As ElementId, _
    railingTypeId As ElementId, _
    placePosition As RailingPlacementPosition _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ Create(
    Document^ document,
    ElementId^ stairsId,
    ElementId^ railingTypeId,
    RailingPlacementPosition placePosition
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs to which the new railing will host. The stairs should have no associated railings yet.
railingTypeId
Type: Autodesk.Revit.DB..::..ElementId
The railing type of the new railing is to be created.
placePosition
Type: Autodesk.Revit.DB.Architecture..::..RailingPlacementPosition
The placement position of the new railing.

Return Value

The new railing instances successfully created on the stairs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a stairs or ramp element. -or- The railingTypeId is not a railing type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairsId already has associated railings or is in editing mode so association of railings is not permitted.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Flip Method

[image]

Revit 2013 API
Railing..::..Flip Method
Railing Class See Also Send Feedback
Flips the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Flip()
Visual Basic
Public Sub Flip
Visual C++
public:
void Flip()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The railing has incorrect internal data.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


GetHandRails Method

[image]

Revit 2013 API
Railing..::..GetHandRails Method
Railing Class See Also Send Feedback
Get all the handrails of the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetHandRails()
Visual Basic
Public Function GetHandRails As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetHandRails()

Return Value

All handrails of the railing.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


GetPath Method

[image]

Revit 2013 API
Railing..::..GetPath Method
Railing Class See Also Send Feedback
Gets the railing path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetPath()
Visual Basic
Public Function GetPath As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetPath()

Return Value

The curve array of the railing path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The railing has incorrect internal data.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


IsValidHostForNewRailing Method

[image]

Revit 2013 API
Railing..::..IsValidHostForNewRailing Method
Railing Class See Also Send Feedback
Checks whether new railing can be created and placed on the specified host.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidHostForNewRailing(
    Document document,
    ElementId elementId
)
Visual Basic
Public Shared Function IsValidHostForNewRailing ( _
    document As Document, _
    elementId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidHostForNewRailing(
    Document^ document,
    ElementId^ elementId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to check.

Return Value

True if new railing can be created and placed on the host, False otherwise.

Remarks

This function will return true for stairs or ramps which can host new railings. Stairs or ramps can host new railings only when they have no associated railing and they are not in editing mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


RemoveHost Method

[image]

Revit 2013 API
Railing..::..RemoveHost Method
Railing Class See Also Send Feedback
Removes the association between the railing and its host.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveHost()
Visual Basic
Public Sub RemoveHost
Visual C++
public:
void RemoveHost()

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
Railing..::..Reset Method
Railing Class See Also Send Feedback
Resets the railing to the default one that the system generates.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Cannot reset the railing.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Railing Properties

[image] [image]

Revit 2013 API
Railing Properties
Railing Class See Also Send Feedback

The Railing type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanReset | True if the railing can be reset, False otherwise.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Flipped | Indicates if the railing is flipped.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasHost | Indicates if the railing has a host.
Public property | HostId | The host of the railing.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefault | Indicates if the railing is the default one that system generates.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TopRail | The top rail of the railing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


CanReset Property

[image]

Revit 2013 API
Railing..::..CanReset Property
Railing Class See Also Send Feedback
True if the railing can be reset, False otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanReset { get; }
Visual Basic
Public ReadOnly Property CanReset As Boolean
    Get
Visual C++
public:
property bool CanReset {
    bool get ();
}

Remarks

A Railing can be reset only if the railing was created in Revit later than version 9.1.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Flipped Property

[image]

Revit 2013 API
Railing..::..Flipped Property
Railing Class See Also Send Feedback
Indicates if the railing is flipped.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Flipped { get; }
Visual Basic
Public ReadOnly Property Flipped As Boolean
    Get
Visual C++
public:
property bool Flipped {
    bool get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The railing has incorrect internal data.

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


HasHost Property

[image]

Revit 2013 API
Railing..::..HasHost Property
Railing Class See Also Send Feedback
Indicates if the railing has a host.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasHost { get; }
Visual Basic
Public ReadOnly Property HasHost As Boolean
    Get
Visual C++
public:
property bool HasHost {
    bool get ();
}

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


HostId Property

[image]

Revit 2013 API
Railing..::..HostId Property
Railing Class See Also Send Feedback
The host of the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId HostId { get; set; }
Visual Basic
Public Property HostId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ HostId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The hostId is not a valid railing host.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


IsDefault Property

[image]

Revit 2013 API
Railing..::..IsDefault Property
Railing Class See Also Send Feedback
Indicates if the railing is the default one that system generates.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get
Visual C++
public:
property bool IsDefault {
    bool get ();
}

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
Railing..::..Parameter Property
Railing Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Railing Class
Railing Members
Autodesk.Revit.DB.Architecture Namespace


TopRail Property

[image]

Revit 2013 API
Railing..::..TopRail Property
Railing Class See Also Send Feedback
The top rail of the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId TopRail { get; }
Visual Basic
Public ReadOnly Property TopRail As ElementId
    Get
Visual C++
public:
property ElementId^ TopRail {
    ElementId^ get ();
}

See Also

Railing Class
Autodesk.Revit.DB.Architecture Namespace


RailingHeightCorrectionOption Enumeration

[image]

Revit 2013 API
RailingHeightCorrectionOption Enumeration
See Also Send Feedback
Railing height correction option.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailingHeightCorrectionOption
Visual Basic
Public Enumeration RailingHeightCorrectionOption
Visual C++
public enum class RailingHeightCorrectionOption

Members

Member name | Description
ByType | Railing height is determined by railing type.
Custom | User needs to define the height value of the railing.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailingPathCurveJoinOption Enumeration

[image]

Revit 2013 API
RailingPathCurveJoinOption Enumeration
See Also Send Feedback
The join type of the railing path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailingPathCurveJoinOption
Visual Basic
Public Enumeration RailingPathCurveJoinOption
Visual C++
public enum class RailingPathCurveJoinOption

Members

Member name | Description
ByType | The rails will be joined according to the settings in the rail type.
ExtendRailsToMeet | Extend rails to meet.
AddVerticalOrHorizontalSegments | Add vertical or horizontal segments.
NoConnector | No connector.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailingPlacementPosition Enumeration

[image]

Revit 2013 API
RailingPlacementPosition Enumeration
See Also Send Feedback
Railing placement position.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailingPlacementPosition
Visual Basic
Public Enumeration RailingPlacementPosition
Visual C++
public enum class RailingPlacementPosition

Members

Member name | Description
Undefined | No railing placement.
Treads | Places railing on treads.
Stringer | Places railing on stringer.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailingSlopeOption Enumeration

[image]

Revit 2013 API
RailingSlopeOption Enumeration
See Also Send Feedback
The option determines the slope of the railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailingSlopeOption
Visual Basic
Public Enumeration RailingSlopeOption
Visual C++
public enum class RailingSlopeOption

Members

Member name | Description
ByHost | The slope of the railing is determined by its host.
Flat | The slope of the railing will be kept flat.
Sloped | The slope of the railing will be specified by users.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailingType Class

[image]

Revit 2013 API
RailingType Class
Members See Also Send Feedback
A railing type object that is used in the generation of railing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RailingType : ElementType
Visual Basic
Public Class RailingType _
    Inherits ElementType
Visual C++
public ref class RailingType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..RailingType

See Also

RailingType Members
Autodesk.Revit.DB.Architecture Namespace


RailingType Members

[image] [image]

Revit 2013 API
RailingType Members
RailingType Class Methods Properties See Also Send Feedback

The RailingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PrimaryHandrailHeight | The height of the primary handrail.
Public property | PrimaryHandrailLateralOffset | The lateral offset of the primary handrail.
Public property | PrimaryHandRailPosition | The position of the primary handrail.
Public property | PrimaryHandrailType | The type of the primary handrail.
Public property | SecondaryHandrailHeight | The height of the secondary handrail.
Public property | SecondaryHandrailLateralOffset | The lateral offset of the secondary handrail.
Public property | SecondaryHandRailPosition | The position of the secondary handrail.
Public property | SecondaryHandrailType | The type of the secondary handrail.
Public property | TopRailHeight | The height of the top rail in the railing system.
Public property | TopRailType | The type of the top rail in the railing system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


RailingType Methods

[image] [image]

Revit 2013 API
RailingType Methods
RailingType Class See Also Send Feedback

The RailingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


RailingType Properties

[image] [image]

Revit 2013 API
RailingType Properties
RailingType Class See Also Send Feedback

The RailingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PrimaryHandrailHeight | The height of the primary handrail.
Public property | PrimaryHandrailLateralOffset | The lateral offset of the primary handrail.
Public property | PrimaryHandRailPosition | The position of the primary handrail.
Public property | PrimaryHandrailType | The type of the primary handrail.
Public property | SecondaryHandrailHeight | The height of the secondary handrail.
Public property | SecondaryHandrailLateralOffset | The lateral offset of the secondary handrail.
Public property | SecondaryHandRailPosition | The position of the secondary handrail.
Public property | SecondaryHandrailType | The type of the secondary handrail.
Public property | TopRailHeight | The height of the top rail in the railing system.
Public property | TopRailType | The type of the top rail in the railing system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
RailingType..::..Parameter Property
RailingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RailingType Class
RailingType Members
Autodesk.Revit.DB.Architecture Namespace


PrimaryHandrailHeight Property

[image]

Revit 2013 API
RailingType..::..PrimaryHandrailHeight Property
RailingType Class See Also Send Feedback
The height of the primary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double PrimaryHandrailHeight { get; }
Visual Basic
Public ReadOnly Property PrimaryHandrailHeight As Double
    Get
Visual C++
public:
property double PrimaryHandrailHeight {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rail has no primary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


PrimaryHandrailLateralOffset Property

[image]

Revit 2013 API
RailingType..::..PrimaryHandrailLateralOffset Property
RailingType Class See Also Send Feedback
The lateral offset of the primary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double PrimaryHandrailLateralOffset { get; }
Visual Basic
Public ReadOnly Property PrimaryHandrailLateralOffset As Double
    Get
Visual C++
public:
property double PrimaryHandrailLateralOffset {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rail has no primary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


PrimaryHandRailPosition Property

[image]

Revit 2013 API
RailingType..::..PrimaryHandRailPosition Property
RailingType Class See Also Send Feedback
The position of the primary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public HandRailPosition PrimaryHandRailPosition { get; set; }
Visual Basic
Public Property PrimaryHandRailPosition As HandRailPosition
    Get
    Set
Visual C++
public:
property HandRailPosition PrimaryHandRailPosition {
    HandRailPosition get ();
    void set (HandRailPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no primary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


PrimaryHandrailType Property

[image]

Revit 2013 API
RailingType..::..PrimaryHandrailType Property
RailingType Class See Also Send Feedback
The type of the primary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId PrimaryHandrailType { get; set; }
Visual Basic
Public Property PrimaryHandrailType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ PrimaryHandrailType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The handRailTypeId is not a valid hand rail type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


SecondaryHandrailHeight Property

[image]

Revit 2013 API
RailingType..::..SecondaryHandrailHeight Property
RailingType Class See Also Send Feedback
The height of the secondary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SecondaryHandrailHeight { get; }
Visual Basic
Public ReadOnly Property SecondaryHandrailHeight As Double
    Get
Visual C++
public:
property double SecondaryHandrailHeight {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rail has no secondary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


SecondaryHandrailLateralOffset Property

[image]

Revit 2013 API
RailingType..::..SecondaryHandrailLateralOffset Property
RailingType Class See Also Send Feedback
The lateral offset of the secondary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SecondaryHandrailLateralOffset { get; }
Visual Basic
Public ReadOnly Property SecondaryHandrailLateralOffset As Double
    Get
Visual C++
public:
property double SecondaryHandrailLateralOffset {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The rail has no secondary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


SecondaryHandRailPosition Property

[image]

Revit 2013 API
RailingType..::..SecondaryHandRailPosition Property
RailingType Class See Also Send Feedback
The position of the secondary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public HandRailPosition SecondaryHandRailPosition { get; set; }
Visual Basic
Public Property SecondaryHandRailPosition As HandRailPosition
    Get
    Set
Visual C++
public:
property HandRailPosition SecondaryHandRailPosition {
    HandRailPosition get ();
    void set (HandRailPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The rail has no secondary hand rail.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


SecondaryHandrailType Property

[image]

Revit 2013 API
RailingType..::..SecondaryHandrailType Property
RailingType Class See Also Send Feedback
The type of the secondary handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SecondaryHandrailType { get; set; }
Visual Basic
Public Property SecondaryHandrailType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ SecondaryHandrailType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The handRailTypeId is not a valid hand rail type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


TopRailHeight Property

[image]

Revit 2013 API
RailingType..::..TopRailHeight Property
RailingType Class See Also Send Feedback
The height of the top rail in the railing system.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TopRailHeight { get; set; }
Visual Basic
Public Property TopRailHeight As Double
    Get
    Set
Visual C++
public:
property double TopRailHeight {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be between 0 and 30000 feet.

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


TopRailType Property

[image]

Revit 2013 API
RailingType..::..TopRailType Property
RailingType Class See Also Send Feedback
The type of the top rail in the railing system.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId TopRailType { get; set; }
Visual Basic
Public Property TopRailType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TopRailType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The topRailType is not a valid top rail type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

RailingType Class
Autodesk.Revit.DB.Architecture Namespace


RailJoinOption Enumeration

[image]

Revit 2013 API
RailJoinOption Enumeration
See Also Send Feedback
The join type of the system rails.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailJoinOption
Visual Basic
Public Enumeration RailJoinOption
Visual C++
public enum class RailJoinOption

Members

Member name | Description
ByType | The rails will be joined according to the settings in the rail type.
Miter | The rails will be joined by a miter connection.
Fillet | The rails will be joined by a fillet connection.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailSupportJustification Enumeration

[image]

Revit 2013 API
RailSupportJustification Enumeration
See Also Send Feedback
The justification of the rail supports.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailSupportJustification
Visual Basic
Public Enumeration RailSupportJustification
Visual C++
public enum class RailSupportJustification

Members

Member name | Description
Begin | Supports are justified to the beginning of the rail.
Center | Supports are justified to the center of the rail.
End | Supports are justified to the end of the rail.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailSupportsLayout Enumeration

[image]

Revit 2013 API
RailSupportsLayout Enumeration
See Also Send Feedback
The layout of the rail supports.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailSupportsLayout
Visual Basic
Public Enumeration RailSupportsLayout
Visual C++
public enum class RailSupportsLayout

Members

Member name | Description
None | No rail support.
FixedDistance | The rail supports are laid out on a fixed distance spacing.
AlignWithRailingPosts | The rail supports are laid out aligned with the railing posts.
FixedNumber | The rail supports are laid out with a specified fixed number.
MaxSpacing | The rail supports are laid out with a maximum spacing.
MinSpacing | The rail supports are laid out with a minimum spacing.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailTagentJoinOption Enumeration

[image]

Revit 2013 API
RailTagentJoinOption Enumeration
See Also Send Feedback
The tangent joins of the rails.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailTagentJoinOption
Visual Basic
Public Enumeration RailTagentJoinOption
Visual C++
public enum class RailTagentJoinOption

Members

Member name | Description
AddVerticalOrHorizontalSegments | Add vertical or horizontal segments.
NoConnector | No connector.
ExtendRailsToMeet | Extend rails to meet.

See Also

Autodesk.Revit.DB.Architecture Namespace


RailTransitionOption Enumeration

[image]

Revit 2013 API
RailTransitionOption Enumeration
See Also Send Feedback
The transition type of the continuous rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailTransitionOption
Visual Basic
Public Enumeration RailTransitionOption
Visual C++
public enum class RailTransitionOption

Members

Member name | Description
None | No transition.
Gooseneck | Gooseneck.
Simple | Simple

See Also

Autodesk.Revit.DB.Architecture Namespace


RailTypeDefaultJoinOption Enumeration

[image]

Revit 2013 API
RailTypeDefaultJoinOption Enumeration
See Also Send Feedback
The default join type of the rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RailTypeDefaultJoinOption
Visual Basic
Public Enumeration RailTypeDefaultJoinOption
Visual C++
public enum class RailTypeDefaultJoinOption

Members

Member name | Description
Miter | The rails will be joined by a miter connection.
Fillet | The rails will be joined by a fillet connection.

See Also

Autodesk.Revit.DB.Architecture Namespace


RiserToTreadConnectionOption Enumeration

[image]

Revit 2013 API
RiserToTreadConnectionOption Enumeration
See Also Send Feedback
Represents the connection style of the riser and tread in relation to each other.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum RiserToTreadConnectionOption
Visual Basic
Public Enumeration RiserToTreadConnectionOption
Visual C++
public enum class RiserToTreadConnectionOption

Members

Member name | Description
RiserBehindTread | The connection will extend riser behind tread.
TreadUnderRiser | The connection will extend tread under riser.
JoinAll | The connection will join all risers and treads.

See Also

Autodesk.Revit.DB.Architecture Namespace


Room Class

[image]

Revit 2013 API
Room Class
Members Example See Also Send Feedback
Provides access to the room topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Room : SpatialElement
Visual Basic
Public Class Room _
    Inherits SpatialElement
Visual C++
public ref class Room : public SpatialElement

Remarks

The room object can be queried for its boundary for use in space planning tools.

Examples

CopyC#
private void Getinfo_Room(Room room)
{
    string message = "Room: ";

    //get the name of the room
    message += "\nRoom Name: " + room.Name;

    //get the room position
    LocationPoint location = room.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoom position: " + XYZToString(point);

    //get the room number
    message += "\nRoom number: " + room.Number;

    Autodesk.Revit.DB.Architecture.BoundarySegmentArray boundarySegmentArray = room.GetBoundarySegments(new SpatialElementBoundaryOptions()) as Autodesk.Revit.DB.Architecture.BoundarySegmentArray;
    if (null != boundarySegmentArray)  //the room may not be bound
    {
        if (0 != boundarySegmentArray.Size)
        {
            message += "\nBoundarySegment of the room: ";
            foreach (Autodesk.Revit.DB.Architecture.BoundarySegment boundarySegment in boundarySegmentArray)
            {
                // Get curve start point
                XYZ start = boundarySegment.Curve.get_EndPoint(0);
                message += "\nCurve start point: " + XYZToString(start);
                // Get curve end point
                XYZ end = boundarySegment.Curve.get_EndPoint(1);
                message += " Curve end point: " + XYZToString(end);

                // Show the boundary elements
                message += "\nBoundary element id: " + boundarySegment.Element.Id.IntegerValue;
            }
        }
    }

    TaskDialog.Show("Revit",message);
}

// output the point's three coordinates
string XYZToString(XYZ point)
{
    return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
}
CopyVB.NET
Private Sub Getinfo_Room(ByVal room As Room)
    Dim message As String = "Room: "

    'get the name of the room
    message += vbLf & "Room Name: " + room.Name

    'get the room position
    Dim location As LocationPoint = TryCast(room.Location, LocationPoint)
    Dim point As Autodesk.Revit.DB.XYZ = location.Point
    message += vbLf & "Room position: " + XYZToString(point)

    'get the room number
    message += vbLf & "Room number: " + room.Number

    'get the boundary segment of the room
    If room.Boundary IsNot Nothing Then
        'the room may not be bound
        If 0 <> room.Boundary.Size Then
            message += vbLf & "BoundarySegment of the room: "
            For Each boundarySegmentArray As Autodesk.Revit.DB.Architecture.BoundarySegmentArray In room.Boundary
                For Each boundarySegment As Autodesk.Revit.DB.Architecture.BoundarySegment In boundarySegmentArray
                    ' Get curve start point
                    Dim start As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(0)
                    message += vbLf & "Curve start point: " + XYZToString(start)
                    ' Get curve end point
                    Dim [end] As Autodesk.Revit.DB.XYZ = boundarySegment.Curve.EndPoint(1)
                    message += " Curve end point: " + XYZToString([end])

                    ' Show the boundary elements
                    message += vbLf & "Boundary element id: " + boundarySegment.Element.Id.IntegerValue
                Next
            Next
        End If
    End If

    TaskDialog.Show("Revit", message)
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB.Architecture..::..Room

See Also

Room Members
Autodesk.Revit.DB.Architecture Namespace


Room Members

[image] [image]

Revit 2013 API
Room Members
Room Class Methods Properties See Also Send Feedback

The Room type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsPointInRoom | Determines if a point lies within the volume of the room.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClosedShell | Return the closedShell of the Room.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Room.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Room Methods

[image] [image]

Revit 2013 API
Room Methods
Room Class See Also Send Feedback

The Room type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsPointInRoom | Determines if a point lies within the volume of the room.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unplace | Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


IsPointInRoom Method

[image]

Revit 2013 API
Room..::..IsPointInRoom Method
Room Class See Also Send Feedback
Determines if a point lies within the volume of the room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPointInRoom(
    XYZ point
)
Visual Basic
Public Function IsPointInRoom ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInRoom(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates of the point is not a number.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Unplace Method

[image]

Revit 2013 API
Room..::..Unplace Method
Room Class See Also Send Feedback
Remove the room from its location, but the project still contains the room. The room can be placed in another location after unplaced.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Unplace()
Visual Basic
Public Sub Unplace
Visual C++
public:
void Unplace()

Remarks

Note that current room is changed to unplaced and all corresponding rooms which in other group instance are deleted when in group edit mode.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Room Properties

[image] [image]

Revit 2013 API
Room Properties
Room Class See Also Send Feedback

The Room type exposes the following members.

Properties

 | Name | Description
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseOffset | Get or Set the Base Offset of the Room.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ClosedShell | Return the closedShell of the Room.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LimitOffset | Get or Set the Limit Offset of the Room.
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UnboundedHeight | Get the Unbounded Height of the Room.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Room.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Room.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


BaseOffset Property

[image]

Revit 2013 API
Room..::..BaseOffset Property
Room Class See Also Send Feedback
Get or Set the Base Offset of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic
Public Property BaseOffset As Double
    Get
    Set
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


ClosedShell Property

[image]

Revit 2013 API
Room..::..ClosedShell Property
Room Class See Also Send Feedback
Return the closedShell of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement ClosedShell { get; }
Visual Basic
Public ReadOnly Property ClosedShell As GeometryElement
    Get
Visual C++
public:
property GeometryElement^ ClosedShell {
    GeometryElement^ get ();
}

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


LimitOffset Property

[image]

Revit 2013 API
Room..::..LimitOffset Property
Room Class See Also Send Feedback
Get or Set the Limit Offset of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic
Public Property LimitOffset As Double
    Get
    Set
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
Room..::..Parameter Property
Room Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Room Class
Room Members
Autodesk.Revit.DB.Architecture Namespace


UnboundedHeight Property

[image]

Revit 2013 API
Room..::..UnboundedHeight Property
Room Class See Also Send Feedback
Get the Unbounded Height of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic
Public ReadOnly Property UnboundedHeight As Double
    Get
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


UpperLimit Property

[image]

Revit 2013 API
Room..::..UpperLimit Property
Room Class See Also Send Feedback
Get or Set the Upper Limit of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic
Public Property UpperLimit As Level
    Get
    Set
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


Volume Property

[image]

Revit 2013 API
Room..::..Volume Property
Room Class See Also Send Feedback
Get the Volume of the Room.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Room.

See Also

Room Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Class

[image]

Revit 2013 API
RoomFilter Class
Members Example See Also Send Feedback
A filter used to match rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoomFilter : ElementSlowFilter
Visual Basic
Public Class RoomFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class RoomFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
// and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
// supported by those methods.
RoomFilter filter = new RoomFilter();

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
IList<Element> rooms = collector.WherePasses(filter).ToElements();
CopyVB.NET
' Use a RoomFilter to find all room elements in the document. It is necessary to use the RoomFilter,
' and not an ElementClassFilter or the shortcut method OfClass() because the Room class is not
' supported by those methods.
Dim filter As New Autodesk.Revit.DB.Architecture.RoomFilter()

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim rooms As IList(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Architecture..::..RoomFilter

See Also

RoomFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Members

[image] [image]

Revit 2013 API
RoomFilter Members
RoomFilter Class Constructors Methods Properties See Also Send Feedback

The RoomFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RoomFilter | Constructs a filter which matches only rooms.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Constructor

[image]

Revit 2013 API
RoomFilter Constructor
RoomFilter Class See Also Send Feedback
Constructs a filter which matches only rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomFilter()
Visual Basic
Public Sub New
Visual C++
public:
RoomFilter()

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Methods

[image] [image]

Revit 2013 API
RoomFilter Methods
RoomFilter Class See Also Send Feedback

The RoomFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
RoomFilter..::..PassesFilter Method
RoomFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

RoomFilter Class
RoomFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomFilter Properties

[image] [image]

Revit 2013 API
RoomFilter Properties
RoomFilter Class See Also Send Feedback

The RoomFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Class

[image]

Revit 2013 API
RoomTag Class
Members Example See Also Send Feedback
Provides access to the room tag in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoomTag : SpatialElementTag
Visual Basic
Public Class RoomTag _
    Inherits SpatialElementTag
Visual C++
public ref class RoomTag : public SpatialElementTag

Examples

CopyC#
private void Getinfo_RoomTag(RoomTag roomTag)
{
    string message = "Room Tag : ";
    //get the location of the roomtag
    LocationPoint location = roomTag.Location as LocationPoint;
    XYZ point = location.Point;
    message += "\nRoomTag location: (" + point.X + ", " +
                   point.Y + ", " + point.Z + ")";

    //get the name of the roomTag
    message += "\nName: " + roomTag.Name;

    //get the room that the tag is associated with
    Room room = roomTag.Room;
    message += "\nThe number of the room is : " + room.Number;

    //get the view in which the tag is placed
    Autodesk.Revit.DB.View view = roomTag.View;
    if (null != view)
    {
        message += "\nView Name: " + view.Name;
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_RoomTag(ByVal roomTag As Autodesk.Revit.DB.Architecture.RoomTag)
    Dim message As String = "Room Tag : "
    'get the location of the roomtag
    Dim location As LocationPoint = TryCast(roomTag.Location, LocationPoint)
    Dim point As Autodesk.Revit.DB.XYZ = location.Point
    message += vbLf & "RoomTag location: (" + point.X + ", " + point.Y + ", " + point.Z + ")"

    'get the name of the roomTag
    message += vbLf & "Name: " + roomTag.Name

    'get the room that the tag is associated with
    Dim room As Room = roomTag.Room
    message += vbLf & "The number of the room is : " + room.Number

    'get the view in which the tag is placed
    Dim view As Autodesk.Revit.DB.View = roomTag.View
    If view IsNot Nothing Then
        message += vbLf & "View Name: " + view.Name
    End If
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB.Architecture..::..RoomTag

See Also

RoomTag Members
Autodesk.Revit.DB.Architecture Namespace


RoomTag Members

[image] [image]

Revit 2013 API
RoomTag Members
RoomTag Class Methods Properties See Also Send Feedback

The RoomTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room that the tag is associated with.
Public property | RoomTagType | The tag type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Methods

[image] [image]

Revit 2013 API
RoomTag Methods
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTag Properties

[image] [image]

Revit 2013 API
RoomTag Properties
RoomTag Class See Also Send Feedback

The RoomTag type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Room | The room that the tag is associated with.
Public property | RoomTagType | The tag type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
RoomTag..::..Parameter Property
RoomTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoomTag Class
RoomTag Members
Autodesk.Revit.DB.Architecture Namespace


Room Property

[image]

Revit 2013 API
RoomTag..::..Room Property
RoomTag Class See Also Send Feedback
The room that the tag is associated with.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic
Public ReadOnly Property Room As Room
    Get
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

Remarks

In rare cases, the tag may not be associated to a room. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Property

[image]

Revit 2013 API
RoomTag..::..RoomTagType Property
RoomTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTagType RoomTagType { get; set; }
Visual Basic
Public Property RoomTagType As RoomTagType
    Get
    Set
Visual C++
public:
property RoomTagType^ RoomTagType {
    RoomTagType^ get ();
    void set (RoomTagType^ value);
}

See Also

RoomTag Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Class

[image]

Revit 2013 API
RoomTagFilter Class
Members See Also Send Feedback
A filter used to match room tags.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoomTagFilter : ElementSlowFilter
Visual Basic
Public Class RoomTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class RoomTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Architecture..::..RoomTagFilter

See Also

RoomTagFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Members

[image] [image]

Revit 2013 API
RoomTagFilter Members
RoomTagFilter Class Constructors Methods Properties See Also Send Feedback

The RoomTagFilter type exposes the following members.

Constructors

 | Name | Description
Public method | RoomTagFilter | Constructs a filter which matches only rooms.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Constructor

[image]

Revit 2013 API
RoomTagFilter Constructor
RoomTagFilter Class See Also Send Feedback
Constructs a filter which matches only rooms.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTagFilter()
Visual Basic
Public Sub New
Visual C++
public:
RoomTagFilter()

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Methods

[image] [image]

Revit 2013 API
RoomTagFilter Methods
RoomTagFilter Class See Also Send Feedback

The RoomTagFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
RoomTagFilter..::..PassesFilter Method
RoomTagFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

RoomTagFilter Class
RoomTagFilter Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagFilter Properties

[image] [image]

Revit 2013 API
RoomTagFilter Properties
RoomTagFilter Class See Also Send Feedback

The RoomTagFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

RoomTagFilter Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Class

[image]

Revit 2013 API
RoomTagType Class
Members See Also Send Feedback
An object that represents a Room Tag type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoomTagType : FamilySymbol
Visual Basic
Public Class RoomTagType _
    Inherits FamilySymbol
Visual C++
public ref class RoomTagType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB.Architecture..::..RoomTagType

See Also

RoomTagType Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Members

[image] [image]

Revit 2013 API
RoomTagType Members
RoomTagType Class Methods Properties See Also Send Feedback

The RoomTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Methods

[image] [image]

Revit 2013 API
RoomTagType Methods
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagType Properties

[image] [image]

Revit 2013 API
RoomTagType Properties
RoomTagType Class See Also Send Feedback

The RoomTagType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RoomTagType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
RoomTagType..::..Parameter Property
RoomTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RoomTagType Class
RoomTagType Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Class

[image]

Revit 2013 API
RoomTagTypeSet Class
Members See Also Send Feedback
A set that contains room tag types.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RoomTagTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RoomTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RoomTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..RoomTagTypeSet

See Also

RoomTagTypeSet Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Members

[image] [image]

Revit 2013 API
RoomTagTypeSet Members
RoomTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RoomTagTypeSet | Initializes a new instance of the RoomTagTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every room tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a room tag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified room tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified room tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Constructor

[image]

Revit 2013 API
RoomTagTypeSet Constructor
RoomTagTypeSet Class See Also Send Feedback
Initializes a new instance of the RoomTagTypeSet class

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTagTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
RoomTagTypeSet()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Methods

[image] [image]

Revit 2013 API
RoomTagTypeSet Methods
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every room tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a room tag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified room tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified room tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Clear Method

[image]

Revit 2013 API
RoomTagTypeSet..::..Clear Method
RoomTagTypeSet Class See Also Send Feedback
Removes every room tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Contains Method

[image]

Revit 2013 API
RoomTagTypeSet..::..Contains Method
RoomTagTypeSet Class See Also Send Feedback
Tests for the existence of a room tag type within the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RoomTagType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..RoomTagType
The room tag type to be searched for.

Return Value

The Contains method returns True if the room tag type is within the set, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Erase Method

[image]

Revit 2013 API
RoomTagTypeSet..::..Erase Method
RoomTagTypeSet Class See Also Send Feedback
Removes a specified room tag type from the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RoomTagType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RoomTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..RoomTagType
The room tag type to be erased.

Return Value

The number of room tag types that were erased from the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ForwardIterator Method

[image]

Revit 2013 API
RoomTagTypeSet..::..ForwardIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


GetEnumerator Method

[image]

Revit 2013 API
RoomTagTypeSet..::..GetEnumerator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Insert Method

[image]

Revit 2013 API
RoomTagTypeSet..::..Insert Method
RoomTagTypeSet Class See Also Send Feedback
Insert the specified room tag type into the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RoomTagType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RoomTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RoomTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Architecture..::..RoomTagType
The room tag type to be inserted into the set.

Return Value

Returns whether the room tag type was inserted into the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


ReverseIterator Method

[image]

Revit 2013 API
RoomTagTypeSet..::..ReverseIterator Method
RoomTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RoomTagTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RoomTagTypeSetIterator
Visual C++
public:
virtual RoomTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSet Properties

[image] [image]

Revit 2013 API
RoomTagTypeSet Properties
RoomTagTypeSet Class See Also Send Feedback

The RoomTagTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of room tag types that are in the set.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


IsEmpty Property

[image]

Revit 2013 API
RoomTagTypeSet..::..IsEmpty Property
RoomTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


Size Property

[image]

Revit 2013 API
RoomTagTypeSet..::..Size Property
RoomTagTypeSet Class See Also Send Feedback
Returns the number of room tag types that are in the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RoomTagTypeSet Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Class

[image]

Revit 2013 API
RoomTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a room tag type set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RoomTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RoomTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RoomTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Architecture..::..RoomTagTypeSetIterator

See Also

RoomTagTypeSetIterator Members
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Members

[image] [image]

Revit 2013 API
RoomTagTypeSetIterator Members
RoomTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RoomTagTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Constructor

[image]

Revit 2013 API
RoomTagTypeSetIterator Constructor
RoomTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RoomTagTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RoomTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Methods

[image] [image]

Revit 2013 API
RoomTagTypeSetIterator Methods
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


MoveNext Method

[image]

Revit 2013 API
RoomTagTypeSetIterator..::..MoveNext Method
RoomTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Reset Method

[image]

Revit 2013 API
RoomTagTypeSetIterator..::..Reset Method
RoomTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


RoomTagTypeSetIterator Properties

[image] [image]

Revit 2013 API
RoomTagTypeSetIterator Properties
RoomTagTypeSetIterator Class See Also Send Feedback

The RoomTagTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Current Property

[image]

Revit 2013 API
RoomTagTypeSetIterator..::..Current Property
RoomTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RoomTagTypeSetIterator Class
Autodesk.Revit.DB.Architecture Namespace


Stairs Class

[image]

Revit 2013 API
Stairs Class
Members See Also Send Feedback
Represents a stairs element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class Stairs : Element
Visual Basic
Public Class Stairs _
    Inherits Element
Visual C++
public ref class Stairs : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..Stairs

See Also

Stairs Members
Autodesk.Revit.DB.Architecture Namespace


Stairs Members

[image] [image]

Revit 2013 API
Stairs Members
Stairs Class Methods Properties See Also Send Feedback

The Stairs type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAssociatedRailings | Gets a list of the Railing elements which are associated to the boundaries of the stairs.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStairsLandings | Returns all the stairs landing components in the stairs.
Public method | GetStairsRuns | Returns all the stairs run components in the stairs.
Public method | GetStairsSupports | Returns all the stairs support components in the stairs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsByComponent | Indicates if the stairs is created by stairs components(runs, landings and supports).
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInEditMode | Indicates whether the stairs is in edit mode or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualRiserHeight | The actual height of the stairs risers in the stairs.
Public property | ActualRisersNumber | The total number of actually created risers in model.
Public property | ActualTreadDepth | The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Public property | ActualTreadsNumber | The number of treads actually created in the stairs.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the stairs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesiredRisersNumber | The number of risers is calculated based on the height between levels.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the stair between the base and top levels.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfStories | The number of stories of a multi-story stair, or 1 for a single-story stair.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TopElevation | The top elevation of the stairs.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


Stairs Methods

[image] [image]

Revit 2013 API
Stairs Methods
Stairs Class See Also Send Feedback

The Stairs type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAssociatedRailings | Gets a list of the Railing elements which are associated to the boundaries of the stairs.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStairsLandings | Returns all the stairs landing components in the stairs.
Public method | GetStairsRuns | Returns all the stairs run components in the stairs.
Public method | GetStairsSupports | Returns all the stairs support components in the stairs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsByComponent | Indicates if the stairs is created by stairs components(runs, landings and supports).
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInEditMode | Indicates whether the stairs is in edit mode or not.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


GetAssociatedRailings Method

[image]

Revit 2013 API
Stairs..::..GetAssociatedRailings Method
Stairs Class See Also Send Feedback
Gets a list of the Railing elements which are associated to the boundaries of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetAssociatedRailings()
Visual Basic
Public Function GetAssociatedRailings As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAssociatedRailings()

Return Value

The ids of the Railing elements.

Remarks

This does not return railings which are sketched directly to the stairs (and are not associated to boundaries).

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


GetStairsLandings Method

[image]

Revit 2013 API
Stairs..::..GetStairsLandings Method
Stairs Class See Also Send Feedback
Returns all the stairs landing components in the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetStairsLandings()
Visual Basic
Public Function GetStairsLandings As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetStairsLandings()

Return Value

The stairs landing components in the stairs.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


GetStairsRuns Method

[image]

Revit 2013 API
Stairs..::..GetStairsRuns Method
Stairs Class See Also Send Feedback
Returns all the stairs run components in the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetStairsRuns()
Visual Basic
Public Function GetStairsRuns As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetStairsRuns()

Return Value

The stairs run components in the stairs.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


GetStairsSupports Method

[image]

Revit 2013 API
Stairs..::..GetStairsSupports Method
Stairs Class See Also Send Feedback
Returns all the stairs support components in the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetStairsSupports()
Visual Basic
Public Function GetStairsSupports As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetStairsSupports()

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


IsByComponent Method

[image]

Revit 2013 API
Stairs..::..IsByComponent Method
Stairs Class See Also Send Feedback
Indicates if the stairs is created by stairs components(runs, landings and supports).

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsByComponent(
    Document document,
    ElementId stairsId
)
Visual Basic
Public Shared Function IsByComponent ( _
    document As Document, _
    stairsId As ElementId _
) As Boolean
Visual C++
public:
static bool IsByComponent(
    Document^ document,
    ElementId^ stairsId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs element to check.

Return Value

True if the stairs is created by components, False otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element stairsId does not exist in the document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


IsInEditMode Method

[image]

Revit 2013 API
Stairs..::..IsInEditMode Method
Stairs Class See Also Send Feedback
Indicates whether the stairs is in edit mode or not.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsInEditMode()
Visual Basic
Public Function IsInEditMode As Boolean
Visual C++
public:
bool IsInEditMode()

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


Stairs Properties

[image] [image]

Revit 2013 API
Stairs Properties
Stairs Class See Also Send Feedback

The Stairs type exposes the following members.

Properties

 | Name | Description
Public property | ActualRiserHeight | The actual height of the stairs risers in the stairs.
Public property | ActualRisersNumber | The total number of actually created risers in model.
Public property | ActualTreadDepth | The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.
Public property | ActualTreadsNumber | The number of treads actually created in the stairs.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the stairs.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesiredRisersNumber | The number of risers is calculated based on the height between levels.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the stair between the base and top levels.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumberOfStories | The number of stories of a multi-story stair, or 1 for a single-story stair.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TopElevation | The top elevation of the stairs.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


ActualRiserHeight Property

[image]

Revit 2013 API
Stairs..::..ActualRiserHeight Property
Stairs Class See Also Send Feedback
The actual height of the stairs risers in the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ActualRiserHeight { get; }
Visual Basic
Public ReadOnly Property ActualRiserHeight As Double
    Get
Visual C++
public:
property double ActualRiserHeight {
    double get ();
}

Remarks

The stairs height is determined by its base and top elevation. So, the actual riser height = stairs height / desired riser number.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


ActualRisersNumber Property

[image]

Revit 2013 API
Stairs..::..ActualRisersNumber Property
Stairs Class See Also Send Feedback
The total number of actually created risers in model.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ActualRisersNumber { get; }
Visual Basic
Public ReadOnly Property ActualRisersNumber As Integer
    Get
Visual C++
public:
property int ActualRisersNumber {
    int get ();
}

Remarks

The number of steps needed to go through when moving from the base level to the top level of the stairs.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


ActualTreadDepth Property

[image]

Revit 2013 API
Stairs..::..ActualTreadDepth Property
Stairs Class See Also Send Feedback
The actual depth of the stairs treads in the stairs, actual tread depth is equal to minimum tread depth by default.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ActualTreadDepth { get; set; }
Visual Basic
Public Property ActualTreadDepth As Double
    Get
    Set
Visual C++
public:
property double ActualTreadDepth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for actualTreadDepth must be greater than 0 and no more than 30000 feet.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


ActualTreadsNumber Property

[image]

Revit 2013 API
Stairs..::..ActualTreadsNumber Property
Stairs Class See Also Send Feedback
The number of treads actually created in the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ActualTreadsNumber { get; }
Visual Basic
Public ReadOnly Property ActualTreadsNumber As Integer
    Get
Visual C++
public:
property int ActualTreadsNumber {
    int get ();
}

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


BaseElevation Property

[image]

Revit 2013 API
Stairs..::..BaseElevation Property
Stairs Class See Also Send Feedback
The base elevation of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double BaseElevation { get; }
Visual Basic
Public ReadOnly Property BaseElevation As Double
    Get
Visual C++
public:
property double BaseElevation {
    double get ();
}

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


DesiredRisersNumber Property

[image]

Revit 2013 API
Stairs..::..DesiredRisersNumber Property
Stairs Class See Also Send Feedback
The number of risers is calculated based on the height between levels.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int DesiredRisersNumber { get; set; }
Visual Basic
Public Property DesiredRisersNumber As Integer
    Get
    Set
Visual C++
public:
property int DesiredRisersNumber {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The numberOfRisers is a not positive value.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


Height Property

[image]

Revit 2013 API
Stairs..::..Height Property
Stairs Class See Also Send Feedback
The height of the stair between the base and top levels.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for stairsHeight must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs top level is not "None", so the height cannot be set independently.

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


NumberOfStories Property

[image]

Revit 2013 API
Stairs..::..NumberOfStories Property
Stairs Class See Also Send Feedback
The number of stories of a multi-story stair, or 1 for a single-story stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfStories { get; }
Visual Basic
Public ReadOnly Property NumberOfStories As Integer
    Get
Visual C++
public:
property int NumberOfStories {
    int get ();
}

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
Stairs..::..Parameter Property
Stairs Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Stairs Class
Stairs Members
Autodesk.Revit.DB.Architecture Namespace


TopElevation Property

[image]

Revit 2013 API
Stairs..::..TopElevation Property
Stairs Class See Also Send Feedback
The top elevation of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TopElevation { get; }
Visual Basic
Public ReadOnly Property TopElevation As Double
    Get
Visual C++
public:
property double TopElevation {
    double get ();
}

See Also

Stairs Class
Autodesk.Revit.DB.Architecture Namespace


StairsConstructionMethod Enumeration

[image]

Revit 2013 API
StairsConstructionMethod Enumeration
See Also Send Feedback
Represents the construction method of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsConstructionMethod
Visual Basic
Public Enumeration StairsConstructionMethod
Visual C++
public enum class StairsConstructionMethod

Members

Member name | Description
Assembled | The stairs is constructed by assembly method.
CastInPlace | The stairs is constructed by cast-in-place method.
Precast | The stairs is constructed by precast method.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsEndConnectionType Enumeration

[image]

Revit 2013 API
StairsEndConnectionType Enumeration
See Also Send Feedback
The join style between a run and landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsEndConnectionType
Visual Basic
Public Enumeration StairsEndConnectionType
Visual C++
public enum class StairsEndConnectionType

Members

Member name | Description
StraightCut | The run and landing are joined by a straight cut.
Notch | The run and landing are joined by a notch.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsEndNotchOption Enumeration

[image]

Revit 2013 API
StairsEndNotchOption Enumeration
See Also Send Feedback
The style of notch width for the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsEndNotchOption
Visual Basic
Public Enumeration StairsEndNotchOption
Visual C++
public enum class StairsEndNotchOption

Members

Member name | Description
FullRunWidth | The notch width is the run width.
Custom | The notch width is customized by user.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsLanding Class

[image]

Revit 2013 API
StairsLanding Class
Members See Also Send Feedback
An object that represents a stairs landing in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsLanding : Element
Visual Basic
Public Class StairsLanding _
    Inherits Element
Visual C++
public ref class StairsLanding : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..StairsLanding

See Also

StairsLanding Members
Autodesk.Revit.DB.Architecture Namespace


StairsLanding Members

[image] [image]

Revit 2013 API
StairsLanding Members
StairsLanding Class Methods Properties See Also Send Feedback

The StairsLanding type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateSketchedLanding | Creates a customized landing between two runs by providing the closed boundary curves of the landing.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllSupports | Returns all the supports hosting the stairs landing.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFootprintBoundary | Returns the landing's boundary curves which are projected on the stairs base level.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStairs | Returns the stairs to which the landing belongs.
Public method | GetStairsPath | Returns the stairs path curves on the landing. The curves are projected on the stairs base level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the landing.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsAutomaticLanding | True if the landing is an automatic landing, False otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Thickness | The thickness of the landing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


StairsLanding Methods

[image] [image]

Revit 2013 API
StairsLanding Methods
StairsLanding Class See Also Send Feedback

The StairsLanding type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateSketchedLanding | Creates a customized landing between two runs by providing the closed boundary curves of the landing.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllSupports | Returns all the supports hosting the stairs landing.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFootprintBoundary | Returns the landing's boundary curves which are projected on the stairs base level.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStairs | Returns the stairs to which the landing belongs.
Public method | GetStairsPath | Returns the stairs path curves on the landing. The curves are projected on the stairs base level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


CreateSketchedLanding Method

[image]

Revit 2013 API
StairsLanding..::..CreateSketchedLanding Method
StairsLanding Class See Also Send Feedback
Creates a customized landing between two runs by providing the closed boundary curves of the landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsLanding CreateSketchedLanding(
    Document document,
    ElementId stairsId,
    CurveLoop curveLoop,
    double baseElevation
)
Visual Basic
Public Shared Function CreateSketchedLanding ( _
    document As Document, _
    stairsId As ElementId, _
    curveLoop As CurveLoop, _
    baseElevation As Double _
) As StairsLanding
Visual C++
public:
static StairsLanding^ CreateSketchedLanding(
    Document^ document,
    ElementId^ stairsId,
    CurveLoop^ curveLoop,
    double baseElevation
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the landing.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs that the new sketched landing belongs to.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The closed boundary curves of the new landing.
baseElevation
Type: System..::..Double
Base elevation of the new stairs run. The elevation has following restriction:
  • The base elevation is relative to the base elevation of the stairs.
  • The base elevation will be rounded automatically to a multiple of the riser height.
  • The base elevation should be equal to or greater than half of the riser height.

Return Value

The new sketched landing.

Remarks

The new stairs landing and the document will be regenerated. This should be run from within an open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element stairsId does not exist in the document -or- The stairsId is not a valid stairs element. -or- -or- Failed to create curve element by the curveLoop.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for baseElevation must be no more than 30000 feet in absolute value. -or- The baseElevation is less than half of the riser height of the stairs.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | The curveLoop doesn't satisfy restrictions to generate sketched landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


GetAllSupports Method

[image]

Revit 2013 API
StairsLanding..::..GetAllSupports Method
StairsLanding Class See Also Send Feedback
Returns all the supports hosting the stairs landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetAllSupports()
Visual Basic
Public Function GetAllSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAllSupports()

Return Value

All the supports hosting the stairs landings.

Remarks

The supports consist of left, right and middle supports of the stairs landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


GetFootprintBoundary Method

[image]

Revit 2013 API
StairsLanding..::..GetFootprintBoundary Method
StairsLanding Class See Also Send Feedback
Returns the landing's boundary curves which are projected on the stairs base level.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CurveLoop GetFootprintBoundary()
Visual Basic
Public Function GetFootprintBoundary As CurveLoop
Visual C++
public:
CurveLoop^ GetFootprintBoundary()

Return Value

The boundary curves of the landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


GetStairs Method

[image]

Revit 2013 API
StairsLanding..::..GetStairs Method
StairsLanding Class See Also Send Feedback
Returns the stairs to which the landing belongs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Stairs GetStairs()
Visual Basic
Public Function GetStairs As Stairs
Visual C++
public:
Stairs^ GetStairs()

Return Value

The stairs to which the landing belongs.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


GetStairsPath Method

[image]

Revit 2013 API
StairsLanding..::..GetStairsPath Method
StairsLanding Class See Also Send Feedback
Returns the stairs path curves on the landing. The curves are projected on the stairs base level.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CurveLoop GetStairsPath()
Visual Basic
Public Function GetStairsPath As CurveLoop
Visual C++
public:
CurveLoop^ GetStairsPath()

Return Value

The stairs path curves of the landing.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


StairsLanding Properties

[image] [image]

Revit 2013 API
StairsLanding Properties
StairsLanding Class See Also Send Feedback

The StairsLanding type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the landing.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsAutomaticLanding | True if the landing is an automatic landing, False otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Thickness | The thickness of the landing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


BaseElevation Property

[image]

Revit 2013 API
StairsLanding..::..BaseElevation Property
StairsLanding Class See Also Send Feedback
The base elevation of the landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double BaseElevation { get; set; }
Visual Basic
Public Property BaseElevation As Double
    Get
    Set
Visual C++
public:
property double BaseElevation {
    double get ();
    void set (double value);
}

Field Value

The base elevation is relative elevation against base elevation of the stairs to which the stairs run belongs to. When setting this property the base elevation will be rounded automatically to a multiple of the riser height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for height must be no more than 30000 feet in absolute value. -or- When setting this property: The height is less than half of the riser height of the stairs.

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


IsAutomaticLanding Property

[image]

Revit 2013 API
StairsLanding..::..IsAutomaticLanding Property
StairsLanding Class See Also Send Feedback
True if the landing is an automatic landing, False otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsAutomaticLanding { get; }
Visual Basic
Public ReadOnly Property IsAutomaticLanding As Boolean
    Get
Visual C++
public:
property bool IsAutomaticLanding {
    bool get ();
}

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsLanding..::..Parameter Property
StairsLanding Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsLanding Class
StairsLanding Members
Autodesk.Revit.DB.Architecture Namespace


Thickness Property

[image]

Revit 2013 API
StairsLanding..::..Thickness Property
StairsLanding Class See Also Send Feedback
The thickness of the landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Thickness { get; }
Visual Basic
Public ReadOnly Property Thickness As Double
    Get
Visual C++
public:
property double Thickness {
    double get ();
}

See Also

StairsLanding Class
Autodesk.Revit.DB.Architecture Namespace


StairsLandingType Class

[image]

Revit 2013 API
StairsLandingType Class
Members See Also Send Feedback
Represents a stairs landing type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsLandingType : ElementType
Visual Basic
Public Class StairsLandingType _
    Inherits ElementType
Visual C++
public ref class StairsLandingType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..StairsLandingType

See Also

StairsLandingType Members
Autodesk.Revit.DB.Architecture Namespace


StairsLandingType Members

[image] [image]

Revit 2013 API
StairsLandingType Members
StairsLandingType Class Methods Properties See Also Send Feedback

The StairsLandingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMonolithic | True if the stairs landing is monolithic, false otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Thickness | Thickness of the stairs landing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsLandingType Class
Autodesk.Revit.DB.Architecture Namespace


StairsLandingType Methods

[image] [image]

Revit 2013 API
StairsLandingType Methods
StairsLandingType Class See Also Send Feedback

The StairsLandingType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsLandingType Class
Autodesk.Revit.DB.Architecture Namespace


StairsLandingType Properties

[image] [image]

Revit 2013 API
StairsLandingType Properties
StairsLandingType Class See Also Send Feedback

The StairsLandingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMonolithic | True if the stairs landing is monolithic, false otherwise.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Thickness | Thickness of the stairs landing.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsLandingType Class
Autodesk.Revit.DB.Architecture Namespace


IsMonolithic Property

[image]

Revit 2013 API
StairsLandingType..::..IsMonolithic Property
StairsLandingType Class See Also Send Feedback
True if the stairs landing is monolithic, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMonolithic { get; }
Visual Basic
Public ReadOnly Property IsMonolithic As Boolean
    Get
Visual C++
public:
property bool IsMonolithic {
    bool get ();
}

See Also

StairsLandingType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsLandingType..::..Parameter Property
StairsLandingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsLandingType Class
StairsLandingType Members
Autodesk.Revit.DB.Architecture Namespace


Thickness Property

[image]

Revit 2013 API
StairsLandingType..::..Thickness Property
StairsLandingType Class See Also Send Feedback
Thickness of the stairs landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Thickness { get; set; }
Visual Basic
Public Property Thickness As Double
    Get
    Set
Visual C++
public:
property double Thickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for thickness must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The landing type doesn't have monolithic support.

See Also

StairsLandingType Class
Autodesk.Revit.DB.Architecture Namespace


StairsLogicalJoinEndType Enumeration

[image]

Revit 2013 API
StairsLogicalJoinEndType Enumeration
See Also Send Feedback
The end type of logical join between stairs components.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsLogicalJoinEndType
Visual Basic
Public Enumeration StairsLogicalJoinEndType
Visual C++
public enum class StairsLogicalJoinEndType

Members

Member name | Description
ET_Landing | Another component is joined to the boundary of a landing.
ET_RunStart | Another component is joined to the start (lower) end of a run.
ET_RunEnd | Another component is joined to the end (upper) end of a run.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsNumberSystemReferenceOption Enumeration

[image]

Revit 2013 API
StairsNumberSystemReferenceOption Enumeration
See Also Send Feedback
The reference types permitted for a number system to refer to the geometry of a stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsNumberSystemReferenceOption
Visual Basic
Public Enumeration StairsNumberSystemReferenceOption
Visual C++
public enum class StairsNumberSystemReferenceOption

Members

Member name | Description
Center | The number system reference to stairs path.
Left | The number system reference to left boundary of stairs.
Right | The number system reference to right boundary of stairs.
LeftQuarter | The number system reference to left quarter of stairs
RightQuarter | The number system reference to right quarter of stairs

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsPath Class

[image]

Revit 2013 API
StairsPath Class
Members See Also Send Feedback
An object that represents the stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsPath : Element
Visual Basic
Public Class StairsPath _
    Inherits Element
Visual C++
public ref class StairsPath : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..StairsPath

See Also

StairsPath Members
Autodesk.Revit.DB.Architecture Namespace


StairsPath Members

[image] [image]

Revit 2013 API
StairsPath Members
StairsPath Class Methods Properties See Also Send Feedback

The StairsPath type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DownText | The stairs down text.
Public property | DownTextOffset | The offset of stairs down text.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowDownText | Represents whether show stairs down text or not.
Public property | ShowUpText | Represents whether show stairs up text or not.
Public property | StairsId | The host stairs element id.
Public property | StairsPathOffset | The offset of stairs path to center line of stairs.
Public property | TextOrientation | The orientation of stair up and down text.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpText | The stairs up text.
Public property | UpTextOffset | The offset of stairs up text.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


StairsPath Methods

[image] [image]

Revit 2013 API
StairsPath Methods
StairsPath Class See Also Send Feedback

The StairsPath type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


Create Method

[image]

Revit 2013 API
StairsPath..::..Create Method
StairsPath Class See Also Send Feedback
Creates a new stairs path for the specified stairs with the specified stairs path type only in the plan view.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsPath Create(
    Document document,
    LinkElementId stairsId,
    ElementId typeId,
    ElementId planViewId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    stairsId As LinkElementId, _
    typeId As ElementId, _
    planViewId As ElementId _
) As StairsPath
Visual C++
public:
static StairsPath^ Create(
    Document^ document,
    LinkElementId^ stairsId,
    ElementId^ typeId,
    ElementId^ planViewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..LinkElementId
The id of the stairs element either in the host document or in a linked document.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The type of stairs path.
planViewId
Type: Autodesk.Revit.DB..::..ElementId
The plan view in which the stairs path will be shown.

Return Value

The new stairs path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a valid stairs. -or- The typeId is not a valid stairs path type. -or- The planViewId is not a valid plan view. -or- The stairsId already has a stairs path. -or- The stairsId is not visible in planViewId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


StairsPath Properties

[image] [image]

Revit 2013 API
StairsPath Properties
StairsPath Class See Also Send Feedback

The StairsPath type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DownText | The stairs down text.
Public property | DownTextOffset | The offset of stairs down text.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowDownText | Represents whether show stairs down text or not.
Public property | ShowUpText | Represents whether show stairs up text or not.
Public property | StairsId | The host stairs element id.
Public property | StairsPathOffset | The offset of stairs path to center line of stairs.
Public property | TextOrientation | The orientation of stair up and down text.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpText | The stairs up text.
Public property | UpTextOffset | The offset of stairs up text.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


DownText Property

[image]

Revit 2013 API
StairsPath..::..DownText Property
StairsPath Class See Also Send Feedback
The stairs down text.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string DownText { get; set; }
Visual Basic
Public Property DownText As String
    Get
    Set
Visual C++
public:
property String^ DownText {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The type of this stairs path is not automatic up/down direction. -or- When setting this property: The stairs path doesn't show down text so the data being set is inapplicable.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


DownTextOffset Property

[image]

Revit 2013 API
StairsPath..::..DownTextOffset Property
StairsPath Class See Also Send Feedback
The offset of stairs down text.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ DownTextOffset { get; set; }
Visual Basic
Public Property DownTextOffset As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ DownTextOffset {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The z direction makes no sense in API.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The type of this stairs path is not automatic up/down direction. -or- When setting this property: The stairs path doesn't show down text so the data being set is inapplicable.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsPath..::..Parameter Property
StairsPath Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsPath Class
StairsPath Members
Autodesk.Revit.DB.Architecture Namespace


ShowDownText Property

[image]

Revit 2013 API
StairsPath..::..ShowDownText Property
StairsPath Class See Also Send Feedback
Represents whether show stairs down text or not.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowDownText { get; set; }
Visual Basic
Public Property ShowDownText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowDownText {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The type of this stairs path is not automatic up/down direction.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


ShowUpText Property

[image]

Revit 2013 API
StairsPath..::..ShowUpText Property
StairsPath Class See Also Send Feedback
Represents whether show stairs up text or not.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowUpText { get; set; }
Visual Basic
Public Property ShowUpText As Boolean
    Get
    Set
Visual C++
public:
property bool ShowUpText {
    bool get ();
    void set (bool value);
}

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


StairsId Property

[image]

Revit 2013 API
StairsPath..::..StairsId Property
StairsPath Class See Also Send Feedback
The host stairs element id.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LinkElementId StairsId { get; }
Visual Basic
Public ReadOnly Property StairsId As LinkElementId
    Get
Visual C++
public:
property LinkElementId^ StairsId {
    LinkElementId^ get ();
}

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


StairsPathOffset Property

[image]

Revit 2013 API
StairsPath..::..StairsPathOffset Property
StairsPath Class See Also Send Feedback
The offset of stairs path to center line of stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double StairsPathOffset { get; set; }
Visual Basic
Public Property StairsPathOffset As Double
    Get
    Set
Visual C++
public:
property double StairsPathOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for stairsPathOffset is not finite -or- When setting this property: The stairsPathOffset is larger than half the width of the stairs.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


TextOrientation Property

[image]

Revit 2013 API
StairsPath..::..TextOrientation Property
StairsPath Class See Also Send Feedback
The orientation of stair up and down text.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsTextOrientation TextOrientation { get; set; }
Visual Basic
Public Property TextOrientation As StairsTextOrientation
    Get
    Set
Visual C++
public:
property StairsTextOrientation TextOrientation {
    StairsTextOrientation get ();
    void set (StairsTextOrientation value);
}

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


UpText Property

[image]

Revit 2013 API
StairsPath..::..UpText Property
StairsPath Class See Also Send Feedback
The stairs up text.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string UpText { get; set; }
Visual Basic
Public Property UpText As String
    Get
    Set
Visual C++
public:
property String^ UpText {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs path doesn't not show up text so the data being set is inapplicable.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


UpTextOffset Property

[image]

Revit 2013 API
StairsPath..::..UpTextOffset Property
StairsPath Class See Also Send Feedback
The offset of stairs up text.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ UpTextOffset { get; set; }
Visual Basic
Public Property UpTextOffset As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ UpTextOffset {
    XYZ^ get ();
    void set (XYZ^ value);
}

Remarks

The z direction makes no sense in API.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs path doesn't not show up text so the data being set is inapplicable.

See Also

StairsPath Class
Autodesk.Revit.DB.Architecture Namespace


StairsPathDirection Enumeration

[image]

Revit 2013 API
StairsPathDirection Enumeration
See Also Send Feedback
The direction style of stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsPathDirection
Visual Basic
Public Enumeration StairsPathDirection
Visual C++
public enum class StairsPathDirection

Members

Member name | Description
AlwaysUp | The direction of the stair path will always be UP direction.
AutomaticUpDown | The direction of the stair path will be determined automatically.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsPathLineShapeAtCorner Enumeration

[image]

Revit 2013 API
StairsPathLineShapeAtCorner Enumeration
See Also Send Feedback
The options for the line shape of a stairs path at a corner.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsPathLineShapeAtCorner
Visual Basic
Public Enumeration StairsPathLineShapeAtCorner
Visual C++
public enum class StairsPathLineShapeAtCorner

Members

Member name | Description
Straight | The line shape of stairs path at the corner is straight.
Curved | The line shape of stairs path at the corner is curved.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsPathType Class

[image]

Revit 2013 API
StairsPathType Class
Members See Also Send Feedback
An object represents the stairs path type.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsPathType : ElementType
Visual Basic
Public Class StairsPathType _
    Inherits ElementType
Visual C++
public ref class StairsPathType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..StairsPathType

See Also

StairsPathType Members
Autodesk.Revit.DB.Architecture Namespace


StairsPathType Members

[image] [image]

Revit 2013 API
StairsPathType Members
StairsPathType Class Methods Properties See Also Send Feedback

The StairsPathType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrowheadTypeId | The arrow head type of the stairs path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistanceToCutMark | The distance from the stairs path arrow to cut mark.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DrawForEachRun | True if stairs paths should be drawn for each run, false if it should be drawn for the whole stairs.
Public property | EndAtRiser | Represents whether the stairs path ends at the riser.
Public property | FullStepArrow | True if the arrow fills the full step width, false if it fills by the specified arrow size.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineShapeAtCorner | The line shape of stairs path at the corner.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowArrowheadToCutMark | True if the stairs path arrowhead should be shown to the cutmark, false if the arrow head is not shown.
Public property | StairsPathDirection | The style of the stairs path.
Public property | StartExtension | The start extension length of the stairs path.
Public property | StartFromRiser | True if the stairs path starts from the riser, false if it starts from the tread.
Public property | StartSymbolTypeId | The start symbol type of stairs path.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StairsPathType Methods

[image] [image]

Revit 2013 API
StairsPathType Methods
StairsPathType Class See Also Send Feedback

The StairsPathType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StairsPathType Properties

[image] [image]

Revit 2013 API
StairsPathType Properties
StairsPathType Class See Also Send Feedback

The StairsPathType type exposes the following members.

Properties

 | Name | Description
Public property | ArrowheadTypeId | The arrow head type of the stairs path.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistanceToCutMark | The distance from the stairs path arrow to cut mark.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DrawForEachRun | True if stairs paths should be drawn for each run, false if it should be drawn for the whole stairs.
Public property | EndAtRiser | Represents whether the stairs path ends at the riser.
Public property | FullStepArrow | True if the arrow fills the full step width, false if it fills by the specified arrow size.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineShapeAtCorner | The line shape of stairs path at the corner.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ShowArrowheadToCutMark | True if the stairs path arrowhead should be shown to the cutmark, false if the arrow head is not shown.
Public property | StairsPathDirection | The style of the stairs path.
Public property | StartExtension | The start extension length of the stairs path.
Public property | StartFromRiser | True if the stairs path starts from the riser, false if it starts from the tread.
Public property | StartSymbolTypeId | The start symbol type of stairs path.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


ArrowheadTypeId Property

[image]

Revit 2013 API
StairsPathType..::..ArrowheadTypeId Property
StairsPathType Class See Also Send Feedback
The arrow head type of the stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ArrowheadTypeId { get; set; }
Visual Basic
Public Property ArrowheadTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ArrowheadTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The arrowheadTypeId is not a valid arrow head type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


DistanceToCutMark Property

[image]

Revit 2013 API
StairsPathType..::..DistanceToCutMark Property
StairsPathType Class See Also Send Feedback
The distance from the stairs path arrow to cut mark.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double DistanceToCutMark { get; set; }
Visual Basic
Public Property DistanceToCutMark As Double
    Get
    Set
Visual C++
public:
property double DistanceToCutMark {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for distanceToCutMark must be between 0 and 30000 feet.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


DrawForEachRun Property

[image]

Revit 2013 API
StairsPathType..::..DrawForEachRun Property
StairsPathType Class See Also Send Feedback
True if stairs paths should be drawn for each run, false if it should be drawn for the whole stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DrawForEachRun { get; set; }
Visual Basic
Public Property DrawForEachRun As Boolean
    Get
    Set
Visual C++
public:
property bool DrawForEachRun {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The StairsPathType is not fixed up direction so the data being set is not applicable.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


EndAtRiser Property

[image]

Revit 2013 API
StairsPathType..::..EndAtRiser Property
StairsPathType Class See Also Send Feedback
Represents whether the stairs path ends at the riser.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool EndAtRiser { get; set; }
Visual Basic
Public Property EndAtRiser As Boolean
    Get
    Set
Visual C++
public:
property bool EndAtRiser {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The StairsPathType is not fixed up direction so the data being set is not applicable.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


FullStepArrow Property

[image]

Revit 2013 API
StairsPathType..::..FullStepArrow Property
StairsPathType Class See Also Send Feedback
True if the arrow fills the full step width, false if it fills by the specified arrow size.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool FullStepArrow { get; set; }
Visual Basic
Public Property FullStepArrow As Boolean
    Get
    Set
Visual C++
public:
property bool FullStepArrow {
    bool get ();
    void set (bool value);
}

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


LineShapeAtCorner Property

[image]

Revit 2013 API
StairsPathType..::..LineShapeAtCorner Property
StairsPathType Class See Also Send Feedback
The line shape of stairs path at the corner.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsPathLineShapeAtCorner LineShapeAtCorner { get; set; }
Visual Basic
Public Property LineShapeAtCorner As StairsPathLineShapeAtCorner
    Get
    Set
Visual C++
public:
property StairsPathLineShapeAtCorner LineShapeAtCorner {
    StairsPathLineShapeAtCorner get ();
    void set (StairsPathLineShapeAtCorner value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: Either the stairs path direction is not AutomaticUpDown, or it is AlwaysUp but DrawForEachRun is false.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsPathType..::..Parameter Property
StairsPathType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsPathType Class
StairsPathType Members
Autodesk.Revit.DB.Architecture Namespace


ShowArrowheadToCutMark Property

[image]

Revit 2013 API
StairsPathType..::..ShowArrowheadToCutMark Property
StairsPathType Class See Also Send Feedback
True if the stairs path arrowhead should be shown to the cutmark, false if the arrow head is not shown.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowArrowheadToCutMark { get; set; }
Visual Basic
Public Property ShowArrowheadToCutMark As Boolean
    Get
    Set
Visual C++
public:
property bool ShowArrowheadToCutMark {
    bool get ();
    void set (bool value);
}

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StairsPathDirection Property

[image]

Revit 2013 API
StairsPathType..::..StairsPathDirection Property
StairsPathType Class See Also Send Feedback
The style of the stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsPathDirection StairsPathDirection { get; }
Visual Basic
Public ReadOnly Property StairsPathDirection As StairsPathDirection
    Get
Visual C++
public:
property StairsPathDirection StairsPathDirection {
    StairsPathDirection get ();
}

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StartExtension Property

[image]

Revit 2013 API
StairsPathType..::..StartExtension Property
StairsPathType Class See Also Send Feedback
The start extension length of the stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double StartExtension { get; set; }
Visual Basic
Public Property StartExtension As Double
    Get
    Set
Visual C++
public:
property double StartExtension {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for startExtension must be between 0 and 30000 feet.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StartFromRiser Property

[image]

Revit 2013 API
StairsPathType..::..StartFromRiser Property
StairsPathType Class See Also Send Feedback
True if the stairs path starts from the riser, false if it starts from the tread.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool StartFromRiser { get; set; }
Visual Basic
Public Property StartFromRiser As Boolean
    Get
    Set
Visual C++
public:
property bool StartFromRiser {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The StairsPathType is not fixed up direction so the data being set is not applicable.

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StartSymbolTypeId Property

[image]

Revit 2013 API
StairsPathType..::..StartSymbolTypeId Property
StairsPathType Class See Also Send Feedback
The start symbol type of stairs path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId StartSymbolTypeId { get; set; }
Visual Basic
Public Property StartSymbolTypeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ StartSymbolTypeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The startSymbolTypeId is not a valid start symbol type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StairsPathType Class
Autodesk.Revit.DB.Architecture Namespace


StairsRun Class

[image]

Revit 2013 API
StairsRun Class
Members See Also Send Feedback
Represents a stairs run element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsRun : Element
Visual Basic
Public Class StairsRun _
    Inherits Element
Visual C++
public ref class StairsRun : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..StairsRun

See Also

StairsRun Members
Autodesk.Revit.DB.Architecture Namespace


StairsRun Members

[image] [image]

Revit 2013 API
StairsRun Members
StairsRun Class Methods Properties See Also Send Feedback

The StairsRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateSketchedRun | Creates a sketched run in the project document by providing a group of boundary curves and riser curves.
 | CreateSpiralRun | Creates a spiral run in the project document by providing the center, start angle and included angle.
 | CreateStraightRun | Creates a straight run in the project document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllSupports | Retrieves all supports hosted by the stair's run.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFootprintBoundary | Returns the run's boundary curves which are projected on the stairs base level.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeftSupports | Retrieves all supports on the left side of run boundaries.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNumberSystemReference | Gets the number system reference corresponding to the given reference options.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRightSupports | Retrieves all supports on the right side of run boundaries.
Public method | GetStairs | Returns the stairs to which the stairs run belongs.
Public method | GetStairsPath | Returns the stairs path curves on the run. The curves are projected on base level of the stairs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualRisersNumber | The actual number of stairs risers in the stairs run.
Public property | ActualRunWidth | Specifies the value of the tread width excluding the width of independent side supports.
Public property | ActualTreadsNumber | The actual number of stairs treads in the stairs run.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the stairs run.
Public property | BeginsWithRiser | True if the stairs run begins with riser, false otherwise.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndsWithRiser | True if the stairs run ends with riser, false otherwise.
Public property | ExtensionBelowBase | Specifies a value to extend/trim the run’s first step against base elevation of the stairs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The calculated height of the stairs run.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LocationLineJustification | The position of the run relative to the Up-direction path used to create the run.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StairsRunStyle | The style of the stairs run such as straight, winder, etc.
Public property | TopElevation | The top elevation of the stairs run.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


StairsRun Methods

[image] [image]

Revit 2013 API
StairsRun Methods
StairsRun Class See Also Send Feedback

The StairsRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateSketchedRun | Creates a sketched run in the project document by providing a group of boundary curves and riser curves.
 | CreateSpiralRun | Creates a spiral run in the project document by providing the center, start angle and included angle.
 | CreateStraightRun | Creates a straight run in the project document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllSupports | Retrieves all supports hosted by the stair's run.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFootprintBoundary | Returns the run's boundary curves which are projected on the stairs base level.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLeftSupports | Retrieves all supports on the left side of run boundaries.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNumberSystemReference | Gets the number system reference corresponding to the given reference options.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRightSupports | Retrieves all supports on the right side of run boundaries.
Public method | GetStairs | Returns the stairs to which the stairs run belongs.
Public method | GetStairsPath | Returns the stairs path curves on the run. The curves are projected on base level of the stairs.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


CreateSketchedRun Method

[image]

Revit 2013 API
StairsRun..::..CreateSketchedRun Method
StairsRun Class See Also Send Feedback
Creates a sketched run in the project document by providing a group of boundary curves and riser curves.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsRun CreateSketchedRun(
    Document document,
    ElementId stairsId,
    double baseElevation,
    IList<Curve> boundaryCurves,
    IList<Curve> riserCurves,
    IList<Curve> stairsPath
)
Visual Basic
Public Shared Function CreateSketchedRun ( _
    document As Document, _
    stairsId As ElementId, _
    baseElevation As Double, _
    boundaryCurves As IList(Of Curve), _
    riserCurves As IList(Of Curve), _
    stairsPath As IList(Of Curve) _
) As StairsRun
Visual C++
public:
static StairsRun^ CreateSketchedRun(
    Document^ document,
    ElementId^ stairsId,
    double baseElevation,
    IList<Curve^>^ boundaryCurves,
    IList<Curve^>^ riserCurves,
    IList<Curve^>^ stairsPath
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs that the new stairs run will belong to.
baseElevation
Type: System..::..Double
Base elevation of the new stairs run. It has following restrictions:
  • The base elevation is relative to the base elevation of the stairs.
  • The base elevation will be rounded automatically to a multiple of the riser height.
boundaryCurves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The boundary curves of the new stairs run. The curves have following restriction:
  • The curves should consist of bound Line or Arc curves only.
  • The curves should be a pair of curve chains(two sets of curves which connect end-to-end to form the left and right boundaries).
  • The left and right boundary chain curves should not connect to each other.
  • They can be single curves or multi-segmented curves(for example, straight lines and arcs connected).
riserCurves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The riser curves of the new stairs run. The curves have following restriction:
  • The curves should consist of bound Line or Arc curves only.
  • The curves should be able to make at least two curve chains.
  • The curves in each chain should connect between the left and right boundaries.
stairsPath
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
The stair path curves of the new stairs run. The curves have following restriction:
  • The curves should consist of bound Line or Arc curves only.
  • The curves should be able to make one curve chain.
  • The curve chain should have intersection with all riser curve chains.
  • The curves should connect between the first and last riser chain curves.

Return Value

The new stairs run.

Remarks

The run type of the new stairs run will be determined by the specified stairs. The new stairs run and the document will be regenerated. This should be run from within an open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a valid stairs element. -or- The input boundaryCurves is empty and is not valid for sketch run. -or- The input riserCurves is empty and is not valid for sketch run. -or- The input stairsPath is empty and is not valid for sketch run. -or- The input boundaryCurves contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The input riserCurves contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The input stairsPath contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The riserCurves or boundaryCurves or stairsPath don't meet restrictions to create sketch run. -or- The boundaryCurves has invalid curve used as sketch boundary curve. -or- The riserCurves has invalid curve used as sketch riser curve. -or- The stairsPath has invalid curve used as sketch stairspath curve.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for baseElevation must be no more than 30000 feet in absolute value. -or- The baseElevation doesn't meet the restriction that bottom of run should not be lower than bottom of stairs.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | The boundaryCurves, riserCurves, stairsPath don't meet restrictions to generate sketch run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


CreateSpiralRun Method

[image]

Revit 2013 API
StairsRun..::..CreateSpiralRun Method
StairsRun Class See Also Send Feedback
Creates a spiral run in the project document by providing the center, start angle and included angle.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsRun CreateSpiralRun(
    Document document,
    ElementId stairsId,
    XYZ center,
    double radius,
    double startAngle,
    double includedAngle,
    bool clockwise,
    StairsRunJustification justification
)
Visual Basic
Public Shared Function CreateSpiralRun ( _
    document As Document, _
    stairsId As ElementId, _
    center As XYZ, _
    radius As Double, _
    startAngle As Double, _
    includedAngle As Double, _
    clockwise As Boolean, _
    justification As StairsRunJustification _
) As StairsRun
Visual C++
public:
static StairsRun^ CreateSpiralRun(
    Document^ document,
    ElementId^ stairsId,
    XYZ^ center,
    double radius,
    double startAngle,
    double includedAngle,
    bool clockwise,
    StairsRunJustification justification
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs that the new stairs run will belong to.
center
Type: Autodesk.Revit.DB..::..XYZ
The center of the location arc of the spiral run. The Z coordinate of the center is the base elevation for the new run (in model coordinates). It must be greater than or equal to the stairs base elevation.
radius
Type: System..::..Double
The radius of the location arc of the spiral run.
startAngle
Type: System..::..Double
The start angle of the location arc of the spiral run. The angle's coordinate system is world coordinate system which always is XYZ.BasisX and XYZ.BasisY.
includedAngle
Type: System..::..Double
The total angle covered by the spiral run. Must be a positive value (direction is determined by the clockwise flag).
clockwise
Type: System..::..Boolean
True if the spiral run will be created along clockwise direction, False otherwise.
justification
Type: Autodesk.Revit.DB.Architecture..::..StairsRunJustification
The location path justification of the new stairs run.

Return Value

The new stairs run.

Remarks

The new stairs run and the document will be regenerated. This should be run from within an open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a valid stairs element. -or- The given value for startAngle is not finite -or- The input center is not a valid center for spiral run (probably the Z coordinate doesn't meet the restrictions) -or- The includedAngle doesn't satisfy riser restriction to generate spiral run (probably it's too small).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for radius must be greater than 0 and no more than 30000 feet. -or- The includedAngle is a not positive value.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The radius is too small to generate a spiral run at the given justification.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | The center, radius, startAngle, includedAngle don't satisfy restrictions to generate spiral run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


CreateStraightRun Method

[image]

Revit 2013 API
StairsRun..::..CreateStraightRun Method
StairsRun Class See Also Send Feedback
Creates a straight run in the project document.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static StairsRun CreateStraightRun(
    Document document,
    ElementId stairsId,
    Line locationPath,
    StairsRunJustification justification
)
Visual Basic
Public Shared Function CreateStraightRun ( _
    document As Document, _
    stairsId As ElementId, _
    locationPath As Line, _
    justification As StairsRunJustification _
) As StairsRun
Visual C++
public:
static StairsRun^ CreateStraightRun(
    Document^ document,
    ElementId^ stairsId,
    Line^ locationPath,
    StairsRunJustification justification
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
stairsId
Type: Autodesk.Revit.DB..::..ElementId
The stairs that the new stairs run will belong to.
locationPath
Type: Autodesk.Revit.DB..::..Line
The line for location path of the new stairs run. The line has following restriction:
  • The line should be bound line which is parallel to the XY plane.
  • The Z coordinate of the line is the base elevation for the new run (in model coordinates). It must be greater than or equal to the stairs base elevation.
  • The number of created risers will be calculated by rounding the length of the location path to a multiple of the tread depth.
justification
Type: Autodesk.Revit.DB.Architecture..::..StairsRunJustification
The location path justification of the new stairs run.

Return Value

The new stairs run.

Remarks

The new stairs run and the document will be regenerated. This should be run from within an open transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The stairsId is not a valid stairs element. -or- The input locationPath is not a bound line. -or- The input locationPath is not a valid location path line for straight run. -or- The locationPath is not valid line used as stairs path(probably it's too short).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs element represented by stairsId is not in an active StairsEditScope. New components cannot be added to it.
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.
Autodesk.Revit.Exceptions..::..RegenerationFailedException | The locationPath doesn't satisfy restrictions to generate straight run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetAllSupports Method

[image]

Revit 2013 API
StairsRun..::..GetAllSupports Method
StairsRun Class See Also Send Feedback
Retrieves all supports hosted by the stair's run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetAllSupports()
Visual Basic
Public Function GetAllSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetAllSupports()

Return Value

All supports hosted by the stair's run.

Remarks

The supports consist of left, right, and middle supports of the stair's run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetFootprintBoundary Method

[image]

Revit 2013 API
StairsRun..::..GetFootprintBoundary Method
StairsRun Class See Also Send Feedback
Returns the run's boundary curves which are projected on the stairs base level.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CurveLoop GetFootprintBoundary()
Visual Basic
Public Function GetFootprintBoundary As CurveLoop
Visual C++
public:
CurveLoop^ GetFootprintBoundary()

Return Value

The boundary curves of the stairs run.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetLeftSupports Method

[image]

Revit 2013 API
StairsRun..::..GetLeftSupports Method
StairsRun Class See Also Send Feedback
Retrieves all supports on the left side of run boundaries.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetLeftSupports()
Visual Basic
Public Function GetLeftSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetLeftSupports()

Return Value

The supports on the left side of run boundaries.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetNumberSystemReference Method

[image]

Revit 2013 API
StairsRun..::..GetNumberSystemReference Method
StairsRun Class See Also Send Feedback
Gets the number system reference corresponding to the given reference options.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Reference GetNumberSystemReference(
    StairsNumberSystemReferenceOption referenceOption
)
Visual Basic
Public Function GetNumberSystemReference ( _
    referenceOption As StairsNumberSystemReferenceOption _
) As Reference
Visual C++
public:
Reference^ GetNumberSystemReference(
    StairsNumberSystemReferenceOption referenceOption
)

Parameters

referenceOption
Type: Autodesk.Revit.DB.Architecture..::..StairsNumberSystemReferenceOption
The reference option.

Return Value

The reference.

Remarks

The return value of this function is suitable for use in NumberSystem.Create() to associate a NumberSystem with the location on the StairsRun. Don't try to get geometry curve from the reference.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetRightSupports Method

[image]

Revit 2013 API
StairsRun..::..GetRightSupports Method
StairsRun Class See Also Send Feedback
Retrieves all supports on the right side of run boundaries.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetRightSupports()
Visual Basic
Public Function GetRightSupports As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRightSupports()

Return Value

The supports on the right side of run boundaries.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetStairs Method

[image]

Revit 2013 API
StairsRun..::..GetStairs Method
StairsRun Class See Also Send Feedback
Returns the stairs to which the stairs run belongs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Stairs GetStairs()
Visual Basic
Public Function GetStairs As Stairs
Visual C++
public:
Stairs^ GetStairs()

Return Value

The stairs to which the stairs run belongs.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


GetStairsPath Method

[image]

Revit 2013 API
StairsRun..::..GetStairsPath Method
StairsRun Class See Also Send Feedback
Returns the stairs path curves on the run. The curves are projected on base level of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CurveLoop GetStairsPath()
Visual Basic
Public Function GetStairsPath As CurveLoop
Visual C++
public:
CurveLoop^ GetStairsPath()

Return Value

The stairs path curves.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs run has no stairs path it probably because the run was not generated yet.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


StairsRun Properties

[image] [image]

Revit 2013 API
StairsRun Properties
StairsRun Class See Also Send Feedback

The StairsRun type exposes the following members.

Properties

 | Name | Description
Public property | ActualRisersNumber | The actual number of stairs risers in the stairs run.
Public property | ActualRunWidth | Specifies the value of the tread width excluding the width of independent side supports.
Public property | ActualTreadsNumber | The actual number of stairs treads in the stairs run.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseElevation | The base elevation of the stairs run.
Public property | BeginsWithRiser | True if the stairs run begins with riser, false otherwise.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndsWithRiser | True if the stairs run ends with riser, false otherwise.
Public property | ExtensionBelowBase | Specifies a value to extend/trim the run’s first step against base elevation of the stairs.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The calculated height of the stairs run.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | LocationLineJustification | The position of the run relative to the Up-direction path used to create the run.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StairsRunStyle | The style of the stairs run such as straight, winder, etc.
Public property | TopElevation | The top elevation of the stairs run.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


ActualRisersNumber Property

[image]

Revit 2013 API
StairsRun..::..ActualRisersNumber Property
StairsRun Class See Also Send Feedback
The actual number of stairs risers in the stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ActualRisersNumber { get; }
Visual Basic
Public ReadOnly Property ActualRisersNumber As Integer
    Get
Visual C++
public:
property int ActualRisersNumber {
    int get ();
}

Remarks

This is a read-only value.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


ActualRunWidth Property

[image]

Revit 2013 API
StairsRun..::..ActualRunWidth Property
StairsRun Class See Also Send Feedback
Specifies the value of the tread width excluding the width of independent side supports.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ActualRunWidth { get; set; }
Visual Basic
Public Property ActualRunWidth As Double
    Get
    Set
Visual C++
public:
property double ActualRunWidth {
    double get ();
    void set (double value);
}

Field Value

The actual width of the stairs run, 0.0 if the run is a sketched run.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for runWidth must be greater than 0 and no more than 30000 feet. -or- When setting this property: The runWidth is too small or too large to be used as actual run width, probably it doesn't satisfy the layout generation restriction of the stairs run.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run is sketched so the data being set is not applicable.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


ActualTreadsNumber Property

[image]

Revit 2013 API
StairsRun..::..ActualTreadsNumber Property
StairsRun Class See Also Send Feedback
The actual number of stairs treads in the stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int ActualTreadsNumber { get; }
Visual Basic
Public ReadOnly Property ActualTreadsNumber As Integer
    Get
Visual C++
public:
property int ActualTreadsNumber {
    int get ();
}

Remarks

This is a read-only value.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


BaseElevation Property

[image]

Revit 2013 API
StairsRun..::..BaseElevation Property
StairsRun Class See Also Send Feedback
The base elevation of the stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double BaseElevation { get; set; }
Visual Basic
Public Property BaseElevation As Double
    Get
    Set
Visual C++
public:
property double BaseElevation {
    double get ();
    void set (double value);
}

Remarks

The base elevation has following restrictions:
  • The base elevation is relative to the base elevation of the stairs to which the stairs run belongs.
  • When setting this property the value will be rounded automatically to a multiple of the riser height.
  • When setting this property for common run, the run’s height will change according to the new base/top elevation. So the value must be less than the top elevation to keep run valid.
  • When setting this property for sketched run, whose height is fixed, the run’s top elevation will be adjusted to keep the same run height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for baseElevation must be no more than 30000 feet in absolute value. -or- When setting this property: The baseElevation doesn't meet the restriction that bottom of run should not be lower than bottom of stairs. -or- When setting this property: The baseElevation doesn't meet the minimal height restriction of the stairs run. -or- When setting this property: The baseElevation impacts the top elevation which is less than extension below base.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


BeginsWithRiser Property

[image]

Revit 2013 API
StairsRun..::..BeginsWithRiser Property
StairsRun Class See Also Send Feedback
True if the stairs run begins with riser, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool BeginsWithRiser { get; set; }
Visual Basic
Public Property BeginsWithRiser As Boolean
    Get
    Set
Visual C++
public:
property bool BeginsWithRiser {
    bool get ();
    void set (bool value);
}

Remarks

If selected, Revit adds a riser to the beginning of the run. If you clear this option, Revit removes the beginning riser and positions the adjacent tread at the base elevation. Clearing this option will change the number of risers in the run. You will need to manually add a riser to maintain the original height.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


EndsWithRiser Property

[image]

Revit 2013 API
StairsRun..::..EndsWithRiser Property
StairsRun Class See Also Send Feedback
True if the stairs run ends with riser, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool EndsWithRiser { get; set; }
Visual Basic
Public Property EndsWithRiser As Boolean
    Get
    Set
Visual C++
public:
property bool EndsWithRiser {
    bool get ();
    void set (bool value);
}

Remarks

If selected, Revit adds a riser to the end of the run. Clearing this option will change the number of risers in the run. You will need to manually add or remove risers to maintain the original height.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


ExtensionBelowBase Property

[image]

Revit 2013 API
StairsRun..::..ExtensionBelowBase Property
StairsRun Class See Also Send Feedback
Specifies a value to extend/trim the run’s first step against base elevation of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ExtensionBelowBase { get; set; }
Visual Basic
Public Property ExtensionBelowBase As Double
    Get
    Set
Visual C++
public:
property double ExtensionBelowBase {
    double get ();
    void set (double value);
}

Remarks

This is useful in cases where the run attaches to the face of a floor opening rather than resting on the surface of the floor. Negative value extends the run’s first step below the stairs’ base elevation. Positive value trims it above the stairs’ base elevation. This value should not be greater than run’s top elevation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for extendBelowBase must be no more than 30000 feet in absolute value. -or- When setting this property: The extendBelowBase is not less than run height. -or- When setting this property: The extendBelowBase is greater than the top elevation of the stairs run.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run cannot extend its below base because its base joins with other stairs components.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


Height Property

[image]

Revit 2013 API
StairsRun..::..Height Property
StairsRun Class See Also Send Feedback
The calculated height of the stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

Remarks

The height is the elevation span between run’s base elevation and top elevation.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


LocationLineJustification Property

[image]

Revit 2013 API
StairsRun..::..LocationLineJustification Property
StairsRun Class See Also Send Feedback
The position of the run relative to the Up-direction path used to create the run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsRunJustification LocationLineJustification { get; set; }
Visual Basic
Public Property LocationLineJustification As StairsRunJustification
    Get
    Set
Visual C++
public:
property StairsRunJustification LocationLineJustification {
    StairsRunJustification get ();
    void set (StairsRunJustification value);
}

Remarks

Only common runs(straight, spiral, winder) have location line justification.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs run is sketched so the data being set is not applicable.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsRun..::..Parameter Property
StairsRun Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsRun Class
StairsRun Members
Autodesk.Revit.DB.Architecture Namespace


StairsRunStyle Property

[image]

Revit 2013 API
StairsRun..::..StairsRunStyle Property
StairsRun Class See Also Send Feedback
The style of the stairs run such as straight, winder, etc.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsRunStyle StairsRunStyle { get; }
Visual Basic
Public ReadOnly Property StairsRunStyle As StairsRunStyle
    Get
Visual C++
public:
property StairsRunStyle StairsRunStyle {
    StairsRunStyle get ();
}

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


TopElevation Property

[image]

Revit 2013 API
StairsRun..::..TopElevation Property
StairsRun Class See Also Send Feedback
The top elevation of the stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TopElevation { get; set; }
Visual Basic
Public Property TopElevation As Double
    Get
    Set
Visual C++
public:
property double TopElevation {
    double get ();
    void set (double value);
}

Remarks

The top elevation has following restrictions:
  • The top elevation is relative to the base elevation of the stairs to which the stairs run belongs.
  • When setting this property the value will be rounded automatically to a multiple of the riser height.
  • When setting this property for common run, the run’s height will change according to the new base/top elevation. So the value must be greater than base elevation to keep run valid.
  • When setting this property for sketched run, whose height is fixed, the run’s base elevation will be adjusted to keep the same run height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for topElevation must be no more than 30000 feet in absolute value. -or- When setting this property: The topElevation doesn't meet the minimal height restriction of the stairs run. -or- When setting this property: The topElevation is less than the extension below base of the stairs run.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run is sketched so the data being set is not applicable.

See Also

StairsRun Class
Autodesk.Revit.DB.Architecture Namespace


StairsRunJustification Enumeration

[image]

Revit 2013 API
StairsRunJustification Enumeration
See Also Send Feedback
The position of the run relative to the Up-direction path used to create the run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsRunJustification
Visual Basic
Public Enumeration StairsRunJustification
Visual C++
public enum class StairsRunJustification

Members

Member name | Description
Left | The creation path for the run is the left edge.
Center | The creation path for the run is the center.
Right | The creation path for the run is the right edge.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsRunStyle Enumeration

[image]

Revit 2013 API
StairsRunStyle Enumeration
See Also Send Feedback
The shape of a run. Different shape has different ways of manipulation.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsRunStyle
Visual Basic
Public Enumeration StairsRunStyle
Visual C++
public enum class StairsRunStyle

Members

Member name | Description
Winder | A winder run has distorted treads, for the sake of space saving at corner.
Sketched | A sketched run can have customized boundary and riser curves. User can customize stair path as well.
Straight | A straight run is defined by a straight line. All treads are rectangular.
Spiral | A spiral run is defined by a cylindrical helix. Both inner and outer boundaries are arcs. Risers are straight lines.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsRunType Class

[image]

Revit 2013 API
StairsRunType Class
Members See Also Send Feedback
A stairs run type object that is used in the generation of stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsRunType : ElementType
Visual Basic
Public Class StairsRunType _
    Inherits ElementType
Visual C++
public ref class StairsRunType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..StairsRunType

See Also

StairsRunType Members
Autodesk.Revit.DB.Architecture Namespace


StairsRunType Members

[image] [image]

Revit 2013 API
StairsRunType Members
StairsRunType Class Methods Properties See Also Send Feedback

The StairsRunType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasRisers | True if the stairs run will include risers on steps, false otherwise.
Public property | HasTreads | True if the stairs run will include treads on steps, false otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMonolithic | True if the stairs run is monolithic, false otherwise.
Public property | IsSlanted | True if risers will be slanted, false if they will be straight.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The material of the stairs run, only available for monolithic stairs run.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NosingLength | The amount of the tread depth that overhangs the next tread.
Public property | NosingProfile | The id of the nosing profile of the treads.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RiserProfile | The id of the profile of the risers.
Public property | RiserThickness | The thickness of the risers.
Public property | RiserToTreadConnect | The connection of the riser to tread in relation to each other.
Public property | StructuralDepth | The structural depth of the stairs run, only available for monolithic stairs run.
Public property | TotalDepth | The total depth of the stairs run, only available for monolithic stairs run.
Public property | TreadNosingPosition | Represents on which edges of the nosing to apply the nosing profile.
Public property | TreadProfile | The id of the profile of the treads.
Public property | TreadThickness | The thickness of the treads.
Public property | UndersideSurfaceStyle | The underside surface style of the stairs run, only available for monolithic stairs run.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


StairsRunType Methods

[image] [image]

Revit 2013 API
StairsRunType Methods
StairsRunType Class See Also Send Feedback

The StairsRunType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


StairsRunType Properties

[image] [image]

Revit 2013 API
StairsRunType Properties
StairsRunType Class See Also Send Feedback

The StairsRunType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasRisers | True if the stairs run will include risers on steps, false otherwise.
Public property | HasTreads | True if the stairs run will include treads on steps, false otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMonolithic | True if the stairs run is monolithic, false otherwise.
Public property | IsSlanted | True if risers will be slanted, false if they will be straight.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The material of the stairs run, only available for monolithic stairs run.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NosingLength | The amount of the tread depth that overhangs the next tread.
Public property | NosingProfile | The id of the nosing profile of the treads.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RiserProfile | The id of the profile of the risers.
Public property | RiserThickness | The thickness of the risers.
Public property | RiserToTreadConnect | The connection of the riser to tread in relation to each other.
Public property | StructuralDepth | The structural depth of the stairs run, only available for monolithic stairs run.
Public property | TotalDepth | The total depth of the stairs run, only available for monolithic stairs run.
Public property | TreadNosingPosition | Represents on which edges of the nosing to apply the nosing profile.
Public property | TreadProfile | The id of the profile of the treads.
Public property | TreadThickness | The thickness of the treads.
Public property | UndersideSurfaceStyle | The underside surface style of the stairs run, only available for monolithic stairs run.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


HasRisers Property

[image]

Revit 2013 API
StairsRunType..::..HasRisers Property
StairsRunType Class See Also Send Feedback
True if the stairs run will include risers on steps, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasRisers { get; set; }
Visual Basic
Public Property HasRisers As Boolean
    Get
    Set
Visual C++
public:
property bool HasRisers {
    bool get ();
    void set (bool value);
}

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


HasTreads Property

[image]

Revit 2013 API
StairsRunType..::..HasTreads Property
StairsRunType Class See Also Send Feedback
True if the stairs run will include treads on steps, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasTreads { get; set; }
Visual Basic
Public Property HasTreads As Boolean
    Get
    Set
Visual C++
public:
property bool HasTreads {
    bool get ();
    void set (bool value);
}

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


IsMonolithic Property

[image]

Revit 2013 API
StairsRunType..::..IsMonolithic Property
StairsRunType Class See Also Send Feedback
True if the stairs run is monolithic, false otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMonolithic { get; }
Visual Basic
Public ReadOnly Property IsMonolithic As Boolean
    Get
Visual C++
public:
property bool IsMonolithic {
    bool get ();
}

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


IsSlanted Property

[image]

Revit 2013 API
StairsRunType..::..IsSlanted Property
StairsRunType Class See Also Send Feedback
True if risers will be slanted, false if they will be straight.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSlanted { get; set; }
Visual Basic
Public Property IsSlanted As Boolean
    Get
    Set
Visual C++
public:
property bool IsSlanted {
    bool get ();
    void set (bool value);
}

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


MaterialId Property

[image]

Revit 2013 API
StairsRunType..::..MaterialId Property
StairsRunType Class See Also Send Feedback
The material of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

The id of the material of the stairs run, invalid ElementId if the stairs run is not monolithic.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The materialId is not a valid material element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


NosingLength Property

[image]

Revit 2013 API
StairsRunType..::..NosingLength Property
StairsRunType Class See Also Send Feedback
The amount of the tread depth that overhangs the next tread.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double NosingLength { get; set; }
Visual Basic
Public Property NosingLength As Double
    Get
    Set
Visual C++
public:
property double NosingLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for length must be between 0 and 30000 feet.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


NosingProfile Property

[image]

Revit 2013 API
StairsRunType..::..NosingProfile Property
StairsRunType Class See Also Send Feedback
The id of the nosing profile of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId NosingProfile { get; set; }
Visual Basic
Public Property NosingProfile As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ NosingProfile {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The profile is neither a valid element id nor invalidElementId. -or- When setting this property: The profile is not a valid nosing profile symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsRunType..::..Parameter Property
StairsRunType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsRunType Class
StairsRunType Members
Autodesk.Revit.DB.Architecture Namespace


RiserProfile Property

[image]

Revit 2013 API
StairsRunType..::..RiserProfile Property
StairsRunType Class See Also Send Feedback
The id of the profile of the risers.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId RiserProfile { get; set; }
Visual Basic
Public Property RiserProfile As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RiserProfile {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The profile is neither a valid element id nor invalidElementId. -or- When setting this property: The profile is not a valid riser profile symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no riser so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


RiserThickness Property

[image]

Revit 2013 API
StairsRunType..::..RiserThickness Property
StairsRunType Class See Also Send Feedback
The thickness of the risers.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double RiserThickness { get; set; }
Visual Basic
Public Property RiserThickness As Double
    Get
    Set
Visual C++
public:
property double RiserThickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for length must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no riser so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


RiserToTreadConnect Property

[image]

Revit 2013 API
StairsRunType..::..RiserToTreadConnect Property
StairsRunType Class See Also Send Feedback
The connection of the riser to tread in relation to each other.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RiserToTreadConnectionOption RiserToTreadConnect { get; set; }
Visual Basic
Public Property RiserToTreadConnect As RiserToTreadConnectionOption
    Get
    Set
Visual C++
public:
property RiserToTreadConnectionOption RiserToTreadConnect {
    RiserToTreadConnectionOption get ();
    void set (RiserToTreadConnectionOption value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no riser so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


StructuralDepth Property

[image]

Revit 2013 API
StairsRunType..::..StructuralDepth Property
StairsRunType Class See Also Send Feedback
The structural depth of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double StructuralDepth { get; set; }
Visual Basic
Public Property StructuralDepth As Double
    Get
    Set
Visual C++
public:
property double StructuralDepth {
    double get ();
    void set (double value);
}

Field Value

The structural depth of the stairs run, 0.0 if the stairs run is not monolithic.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for structuralDepth must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


TotalDepth Property

[image]

Revit 2013 API
StairsRunType..::..TotalDepth Property
StairsRunType Class See Also Send Feedback
The total depth of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalDepth { get; }
Visual Basic
Public ReadOnly Property TotalDepth As Double
    Get
Visual C++
public:
property double TotalDepth {
    double get ();
}

Field Value

The total depth of the stairs run, 0.0 if the stairs run is not monolithic.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


TreadNosingPosition Property

[image]

Revit 2013 API
StairsRunType..::..TreadNosingPosition Property
StairsRunType Class See Also Send Feedback
Represents on which edges of the nosing to apply the nosing profile.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TreadNosingPosition TreadNosingPosition { get; set; }
Visual Basic
Public Property TreadNosingPosition As TreadNosingPosition
    Get
    Set
Visual C++
public:
property TreadNosingPosition TreadNosingPosition {
    TreadNosingPosition get ();
    void set (TreadNosingPosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


TreadProfile Property

[image]

Revit 2013 API
StairsRunType..::..TreadProfile Property
StairsRunType Class See Also Send Feedback
The id of the profile of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId TreadProfile { get; set; }
Visual Basic
Public Property TreadProfile As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TreadProfile {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The profile is neither a valid element id nor invalidElementId. -or- When setting this property: The profile is not a valid tread profile symbol.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


TreadThickness Property

[image]

Revit 2013 API
StairsRunType..::..TreadThickness Property
StairsRunType Class See Also Send Feedback
The thickness of the treads.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TreadThickness { get; set; }
Visual Basic
Public Property TreadThickness As Double
    Get
    Set
Visual C++
public:
property double TreadThickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for thickness must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The run type has no tread so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


UndersideSurfaceStyle Property

[image]

Revit 2013 API
StairsRunType..::..UndersideSurfaceStyle Property
StairsRunType Class See Also Send Feedback
The underside surface style of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsUndersideSurfaceStyle UndersideSurfaceStyle { get; set; }
Visual Basic
Public Property UndersideSurfaceStyle As StairsUndersideSurfaceStyle
    Get
    Set
Visual C++
public:
property StairsUndersideSurfaceStyle UndersideSurfaceStyle {
    StairsUndersideSurfaceStyle get ();
    void set (StairsUndersideSurfaceStyle value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.

See Also

StairsRunType Class
Autodesk.Revit.DB.Architecture Namespace


StairsSupportTopsideSurfaceType Enumeration

[image]

Revit 2013 API
StairsSupportTopsideSurfaceType Enumeration
See Also Send Feedback
The style of the topside surface of the support.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsSupportTopsideSurfaceType
Visual Basic
Public Enumeration StairsSupportTopsideSurfaceType
Visual C++
public enum class StairsSupportTopsideSurfaceType

Members

Member name | Description
Closed | The style of the topside surface of the support is closed.
Open | The style of the topside surface of the support is open.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsTextOrientation Enumeration

[image]

Revit 2013 API
StairsTextOrientation Enumeration
See Also Send Feedback
The options to be used when orienting text annotations relative to stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsTextOrientation
Visual Basic
Public Enumeration StairsTextOrientation
Visual C++
public enum class StairsTextOrientation

Members

Member name | Description
Horizontal | Indicator text will be displayed horizontally.
Vertical | Indicator text will be displayed vertically.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsType Class

[image]

Revit 2013 API
StairsType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class StairsType : ElementType
Visual Basic
Public Class StairsType _
    Inherits ElementType
Visual C++
public ref class StairsType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..StairsType

See Also

StairsType Members
Autodesk.Revit.DB.Architecture Namespace


StairsType Members

[image] [image]

Revit 2013 API
StairsType Members
StairsType Class Methods Properties See Also Send Feedback

The StairsType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConstructionMethod | The construction method of the stairs.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndConnectionType | The join style between a run and landing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasMiddleSupports | True if the stairs type has middle supports, False otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LandingType | The type for all landings in the stair element.
Public property | LeftLateralOffset | The offset for the left support from the edge of the run in a horizontal direction.
Public property | LeftSideSupportType | The type of left support used in the stair.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxRiserHeight | The maximum height of each riser on the stair element.
Public property | MiddleSupportsNumber | The number of middle supports used in the stair.
Public property | MiddleSupportType | The type of middle supports used in the stair.
Public property | MinRunWidth | The initial value for the width of a common run.
Public property | MinTreadDepth | The minimum tread width along the center path for all common runs (winder, arc, and straight).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NotchExtension | The horizontal length of the notch profile.
Public property | NotchHorizontalGap | The width of the horizontal gap in the stairs notch.
Public property | NotchThickness | The vertical length of the notch profile from the top.
Public property | NotchVerticalGap | The width of the vertical gap in the stairs notch.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RightLateralOffset | The offset for the right support from the edge of the run in a horizontal direction.
Public property | RightSideSupportType | The type of right support used in the stair.
Public property | RunType | The type for all runs in the stair element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


StairsType Methods

[image] [image]

Revit 2013 API
StairsType Methods
StairsType Class See Also Send Feedback

The StairsType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


StairsType Properties

[image] [image]

Revit 2013 API
StairsType Properties
StairsType Class See Also Send Feedback

The StairsType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConstructionMethod | The construction method of the stairs.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndConnectionType | The join style between a run and landing.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasMiddleSupports | True if the stairs type has middle supports, False otherwise.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LandingType | The type for all landings in the stair element.
Public property | LeftLateralOffset | The offset for the left support from the edge of the run in a horizontal direction.
Public property | LeftSideSupportType | The type of left support used in the stair.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxRiserHeight | The maximum height of each riser on the stair element.
Public property | MiddleSupportsNumber | The number of middle supports used in the stair.
Public property | MiddleSupportType | The type of middle supports used in the stair.
Public property | MinRunWidth | The initial value for the width of a common run.
Public property | MinTreadDepth | The minimum tread width along the center path for all common runs (winder, arc, and straight).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NotchExtension | The horizontal length of the notch profile.
Public property | NotchHorizontalGap | The width of the horizontal gap in the stairs notch.
Public property | NotchThickness | The vertical length of the notch profile from the top.
Public property | NotchVerticalGap | The width of the vertical gap in the stairs notch.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RightLateralOffset | The offset for the right support from the edge of the run in a horizontal direction.
Public property | RightSideSupportType | The type of right support used in the stair.
Public property | RunType | The type for all runs in the stair element.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


ConstructionMethod Property

[image]

Revit 2013 API
StairsType..::..ConstructionMethod Property
StairsType Class See Also Send Feedback
The construction method of the stairs.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsConstructionMethod ConstructionMethod { get; }
Visual Basic
Public ReadOnly Property ConstructionMethod As StairsConstructionMethod
    Get
Visual C++
public:
property StairsConstructionMethod ConstructionMethod {
    StairsConstructionMethod get ();
}

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


EndConnectionType Property

[image]

Revit 2013 API
StairsType..::..EndConnectionType Property
StairsType Class See Also Send Feedback
The join style between a run and landing.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public StairsEndConnectionType EndConnectionType { get; set; }
Visual Basic
Public Property EndConnectionType As StairsEndConnectionType
    Get
    Set
Visual C++
public:
property StairsEndConnectionType EndConnectionType {
    StairsEndConnectionType get ();
    void set (StairsEndConnectionType value);
}

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


HasMiddleSupports Property

[image]

Revit 2013 API
StairsType..::..HasMiddleSupports Property
StairsType Class See Also Send Feedback
True if the stairs type has middle supports, False otherwise.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasMiddleSupports { get; set; }
Visual Basic
Public Property HasMiddleSupports As Boolean
    Get
    Set
Visual C++
public:
property bool HasMiddleSupports {
    bool get ();
    void set (bool value);
}

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


LandingType Property

[image]

Revit 2013 API
StairsType..::..LandingType Property
StairsType Class See Also Send Feedback
The type for all landings in the stair element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId LandingType { get; set; }
Visual Basic
Public Property LandingType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LandingType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The specified landingTypeId is not a valid landing type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


LeftLateralOffset Property

[image]

Revit 2013 API
StairsType..::..LeftLateralOffset Property
StairsType Class See Also Send Feedback
The offset for the left support from the edge of the run in a horizontal direction.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LeftLateralOffset { get; set; }
Visual Basic
Public Property LeftLateralOffset As Double
    Get
    Set
Visual C++
public:
property double LeftLateralOffset {
    double get ();
    void set (double value);
}

Field Value

0.0 if the left support is not carriage(open).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The left support style is not carriage(open), so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


LeftSideSupportType Property

[image]

Revit 2013 API
StairsType..::..LeftSideSupportType Property
StairsType Class See Also Send Feedback
The type of left support used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId LeftSideSupportType { get; set; }
Visual Basic
Public Property LeftSideSupportType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ LeftSideSupportType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: leftSideSupportTypeId is not a valid support type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The left support style is not carriage(open), so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


MaxRiserHeight Property

[image]

Revit 2013 API
StairsType..::..MaxRiserHeight Property
StairsType Class See Also Send Feedback
The maximum height of each riser on the stair element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MaxRiserHeight { get; set; }
Visual Basic
Public Property MaxRiserHeight As Double
    Get
    Set
Visual C++
public:
property double MaxRiserHeight {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for maxRiserHeight must be greater than 0 and no more than 30000 feet.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


MiddleSupportsNumber Property

[image]

Revit 2013 API
StairsType..::..MiddleSupportsNumber Property
StairsType Class See Also Send Feedback
The number of middle supports used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MiddleSupportsNumber { get; set; }
Visual Basic
Public Property MiddleSupportsNumber As Integer
    Get
    Set
Visual C++
public:
property int MiddleSupportsNumber {
    int get ();
    void set (int value);
}

Field Value

0 if the stairs type has no middle support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The supportsNumber is a negative value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs type has no middle support so the data being set is not applicable.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


MiddleSupportType Property

[image]

Revit 2013 API
StairsType..::..MiddleSupportType Property
StairsType Class See Also Send Feedback
The type of middle supports used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MiddleSupportType { get; set; }
Visual Basic
Public Property MiddleSupportType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MiddleSupportType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Field Value

invalidElementId if the stairs type has no middle support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: %supportId$ is not a valid middle support type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs type has no middle support so the data being set is not applicable.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


MinRunWidth Property

[image]

Revit 2013 API
StairsType..::..MinRunWidth Property
StairsType Class See Also Send Feedback
The initial value for the width of a common run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinRunWidth { get; set; }
Visual Basic
Public Property MinRunWidth As Double
    Get
    Set
Visual C++
public:
property double MinRunWidth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minRunWidth must be greater than 0 and no more than 30000 feet.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


MinTreadDepth Property

[image]

Revit 2013 API
StairsType..::..MinTreadDepth Property
StairsType Class See Also Send Feedback
The minimum tread width along the center path for all common runs (winder, arc, and straight).

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinTreadDepth { get; set; }
Visual Basic
Public Property MinTreadDepth As Double
    Get
    Set
Visual C++
public:
property double MinTreadDepth {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minTreadDepth must be greater than 0 and no more than 30000 feet.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


NotchExtension Property

[image]

Revit 2013 API
StairsType..::..NotchExtension Property
StairsType Class See Also Send Feedback
The horizontal length of the notch profile.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double NotchExtension { get; set; }
Visual Basic
Public Property NotchExtension As Double
    Get
    Set
Visual C++
public:
property double NotchExtension {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchExtension must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


NotchHorizontalGap Property

[image]

Revit 2013 API
StairsType..::..NotchHorizontalGap Property
StairsType Class See Also Send Feedback
The width of the horizontal gap in the stairs notch.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double NotchHorizontalGap { get; set; }
Visual Basic
Public Property NotchHorizontalGap As Double
    Get
    Set
Visual C++
public:
property double NotchHorizontalGap {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchHorizontalGap must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


NotchThickness Property

[image]

Revit 2013 API
StairsType..::..NotchThickness Property
StairsType Class See Also Send Feedback
The vertical length of the notch profile from the top.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double NotchThickness { get; set; }
Visual Basic
Public Property NotchThickness As Double
    Get
    Set
Visual C++
public:
property double NotchThickness {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchThickness must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


NotchVerticalGap Property

[image]

Revit 2013 API
StairsType..::..NotchVerticalGap Property
StairsType Class See Also Send Feedback
The width of the vertical gap in the stairs notch.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double NotchVerticalGap { get; set; }
Visual Basic
Public Property NotchVerticalGap As Double
    Get
    Set
Visual C++
public:
property double NotchVerticalGap {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for notchVerticalGap must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The construction method of the stairs type is not "Precast" or the StairsEndConnectionType of the stairs type is not "Notch", so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
StairsType..::..Parameter Property
StairsType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StairsType Class
StairsType Members
Autodesk.Revit.DB.Architecture Namespace


RightLateralOffset Property

[image]

Revit 2013 API
StairsType..::..RightLateralOffset Property
StairsType Class See Also Send Feedback
The offset for the right support from the edge of the run in a horizontal direction.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double RightLateralOffset { get; set; }
Visual Basic
Public Property RightLateralOffset As Double
    Get
    Set
Visual C++
public:
property double RightLateralOffset {
    double get ();
    void set (double value);
}

Field Value

0.0 if the right support is not carriage(open).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for offset must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The right support style is not carriage(open), so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


RightSideSupportType Property

[image]

Revit 2013 API
StairsType..::..RightSideSupportType Property
StairsType Class See Also Send Feedback
The type of right support used in the stair.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId RightSideSupportType { get; set; }
Visual Basic
Public Property RightSideSupportType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RightSideSupportType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: rightSideSupportTypeId is not a valid support type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The right support style is not carriage(open), so this related data cannot be set.

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


RunType Property

[image]

Revit 2013 API
StairsType..::..RunType Property
StairsType Class See Also Send Feedback
The type for all runs in the stair element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId RunType { get; set; }
Visual Basic
Public Property RunType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RunType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The specified runTypeId is not a valid run type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

StairsType Class
Autodesk.Revit.DB.Architecture Namespace


StairsUndersideSurfaceStyle Enumeration

[image]

Revit 2013 API
StairsUndersideSurfaceStyle Enumeration
See Also Send Feedback
The style of the underside surface of the run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsUndersideSurfaceStyle
Visual Basic
Public Enumeration StairsUndersideSurfaceStyle
Visual C++
public enum class StairsUndersideSurfaceStyle

Members

Member name | Description
Stepped | The underside surface of the run is stepped.
Smooth | The underside surface of the run is smooth.

See Also

Autodesk.Revit.DB.Architecture Namespace


StairsWinderStyle Enumeration

[image]

Revit 2013 API
StairsWinderStyle Enumeration
See Also Send Feedback
The calculation method for the layout of the winder run steps.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum StairsWinderStyle
Visual Basic
Public Enumeration StairsWinderStyle
Visual C++
public enum class StairsWinderStyle

Members

Member name | Description
Balanced | Symmetrical layout style.
SinglePoint | Asymmetrical layout style. Winder style is calculated from a single center point.

See Also

Autodesk.Revit.DB.Architecture Namespace


TopRail Class

[image]

Revit 2013 API
TopRail Class
Members See Also Send Feedback
Represents a top rail element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TopRail : ContinuousRail
Visual Basic
Public Class TopRail _
    Inherits ContinuousRail
Visual C++
public ref class TopRail : public ContinuousRail

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Architecture..::..ContinuousRail
Autodesk.Revit.DB.Architecture..::..TopRail

See Also

TopRail Members
Autodesk.Revit.DB.Architecture Namespace


TopRail Members

[image] [image]

Revit 2013 API
TopRail Members
TopRail Class Methods Properties See Also Send Feedback

The TopRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path. (Inherited from ContinuousRail.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetSupports | Returns all the railing supports attached to the rail. (Inherited from ContinuousRail.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail. (Inherited from ContinuousRail.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail. (Inherited from ContinuousRail.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopRail Class
Autodesk.Revit.DB.Architecture Namespace


TopRail Methods

[image] [image]

Revit 2013 API
TopRail Methods
TopRail Class See Also Send Feedback

The TopRail type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEndExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPath | Retrieves the rail path. (Inherited from ContinuousRail.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetStartExtensionPath | Retrieves the start extension path. (Inherited from ContinuousRail.)
Public method | GetSupports | Returns all the railing supports attached to the rail. (Inherited from ContinuousRail.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopRail Class
Autodesk.Revit.DB.Architecture Namespace


TopRail Properties

[image] [image]

Revit 2013 API
TopRail Properties
TopRail Class See Also Send Feedback

The TopRail type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostRailingId | The id of the host Railing that contains this rail. (Inherited from ContinuousRail.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the rail. (Inherited from ContinuousRail.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopRail Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
TopRail..::..Parameter Property
TopRail Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TopRail Class
TopRail Members
Autodesk.Revit.DB.Architecture Namespace


TopRailType Class

[image]

Revit 2013 API
TopRailType Class
Members See Also Send Feedback
A rail type object that is used in the generation of top rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TopRailType : ContinuousRailType
Visual Basic
Public Class TopRailType _
    Inherits ContinuousRailType
Visual C++
public ref class TopRailType : public ContinuousRailType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Architecture..::..ContinuousRailType
Autodesk.Revit.DB.Architecture..::..TopRailType

See Also

TopRailType Members
Autodesk.Revit.DB.Architecture Namespace


TopRailType Members

[image] [image]

Revit 2013 API
TopRailType Members
TopRailType Class Methods Properties See Also Send Feedback

The TopRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails. (Inherited from ContinuousRailType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopTermination | The termination of the rail at the end or top. (Inherited from ContinuousRailType.)
Public property | FilletRadius | The fillet radius of the rail join. (Inherited from ContinuousRailType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail; (Inherited from ContinuousRailType.)
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | Transition | The transition option of the rail. (Inherited from ContinuousRailType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopRailType Class
Autodesk.Revit.DB.Architecture Namespace


TopRailType Methods

[image] [image]

Revit 2013 API
TopRailType Methods
TopRailType Class See Also Send Feedback

The TopRailType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TopRailType Class
Autodesk.Revit.DB.Architecture Namespace


TopRailType Properties

[image] [image]

Revit 2013 API
TopRailType Properties
TopRailType Class See Also Send Feedback

The TopRailType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DefaultJoinOption | The default join option between two rails. (Inherited from ContinuousRailType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndOrTopExtensionLength | The extension length of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopExtensionStyle | The extension style of the rail termination at the end or top. (Inherited from ContinuousRailType.)
Public property | EndOrTopTermination | The termination of the rail at the end or top. (Inherited from ContinuousRailType.)
Public property | FilletRadius | The fillet radius of the rail join. (Inherited from ContinuousRailType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HandClearance | The horizontal distance between the inner boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProfileId | The id of the profile of the rail; (Inherited from ContinuousRailType.)
Public property | Projection | The horizontal distance between the outer boundary of the rail and the path. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionLength | The extension length of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomExtensionStyle | The extension style of the rail termination at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | StartOrBottomTermination | The termination of the rail at the beginning or bottom. (Inherited from ContinuousRailType.)
Public property | Transition | The transition option of the rail. (Inherited from ContinuousRailType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TopRailType Class
Autodesk.Revit.DB.Architecture Namespace


Parameter Property

[image] [image]

Revit 2013 API
TopRailType..::..Parameter Property
TopRailType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TopRailType Class
TopRailType Members
Autodesk.Revit.DB.Architecture Namespace


TreadNosingPosition Enumeration

[image]

Revit 2013 API
TreadNosingPosition Enumeration
See Also Send Feedback
Represents on which edges of the nosing to apply the nosing profile.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum TreadNosingPosition
Visual Basic
Public Enumeration TreadNosingPosition
Visual C++
public enum class TreadNosingPosition

Members

Member name | Description
FrontOnly | Adds nosing on the front edge of tread only.
FrontAndLeft | Adds nosing on the front and left edge of tread.
FrontAndRight | Adds nosing on the front and right edge of tread.
FrontLeftAndRight | Adds nosing on the front left and left edge of tread.

See Also

Autodesk.Revit.DB.Architecture Namespace


WinderPathResult Enumeration

[image]

Revit 2013 API
WinderPathResult Enumeration
See Also Send Feedback
Flag indicates whether curves are valid to use as base lines for winder path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum WinderPathResult
Visual Basic
Public Enumeration WinderPathResult
Visual C++
public enum class WinderPathResult

Members

Member name | Description
Success | Indicates curves are valid to use as path base lines for winder run. This is only one flag indicates curves are fine to use as winder path.
NumberOutOfRange | The curves number is not 2 or 3.
Unbound | Curve is not bound.
Noncontinuous | The curves are not continuous in one loop.
NotOpenLoop | The curves are not in one open loop.
TooShort | Curve length is too short.
ColinearOrOverlap | Two curves are collinear or overlap.
SelfIntersect | The first curve intersect with third curve.
InvalidCurveType | Curve is not line.
NotSupported | This path(for zigzag winder) is not supported yet

See Also

Autodesk.Revit.DB.Architecture Namespace


Autodesk.Revit.DB.Electrical Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Electrical Namespace
Send Feedback

Classes

 | Class | Description
Public class | CableTray | This class represents a cable tray in Autodesk Revit.
Public class | CableTrayConduitBase | The CableTrayConduitBase class is implemented as the base class for cable tray or conduit
Public class | CableTrayConduitRunBase | The base class for a cable tray or conduit run in Autodesk Revit.
Public class | CableTrayRun | This class represents a cable tray run in Autodesk Revit.
Public class | CableTrayType | This class represents a cable tray type in Autodesk Revit.
Public class | Conduit | This class represents a conduit in Autodesk Revit.
Public class | ConduitRun | This class represents a conduit run in Autodesk Revit.
Public class | ConduitType | This class represents a conduit type in Autodesk Revit.
Public class | CorrectionFactor | Represents electrical correction factor information.
Public class | CorrectionFactorSet | A set that contains correction factors.
Public class | CorrectionFactorSetIterator | An iterator to a correction factor set.
Public class | DistributionSysType | Represents a specific type of distribution system.
Public class | DistributionSysTypeSet | A set that contains DistributionSys types.
Public class | DistributionSysTypeSetIterator | An iterator to a DistributionSys type set.
Public class | ElectricalConnector | Obsolete. An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.
Public class | ElectricalDemandFactorDefinition | The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.
Public class | ElectricalDemandFactorValue | This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.
Public class | ElectricalEquipment | Provides access to the Electrical Equipment in Autodesk Revit MEP.
Public class | ElectricalLoadClassification | The ElectricalLoadClassification class represents a serialized version of an instance of load classification.
Public class | ElectricalSetting | An object that represents electrical information within the Autodesk Revit project.
Public class | ElectricalSystem | Provides access to the Electrical System in Autodesk Revit MEP.
Public class | ElectricalSystemSet | A set that can contain any type of object.
Public class | ElectricalSystemSetIterator | An iterator to a set.
Public class | GroundConductorSize | Represents electrical ground conductor size definition information.
Public class | GroundConductorSizeSet | A set that contains GroundConductorSizes.
Public class | GroundConductorSizeSetIterator | An iterator to a GroundConductorSize set.
Public class | InsulationType | Represents electrical insulation type definition information.
Public class | InsulationTypeSet |
Public class | InsulationTypeSetIterator |
Public class | LightingDevice | Provides access to the Lighting Device in Autodesk Revit MEP.
Public class | LightingFixture | Provides access to the Lighting Fixture in Autodesk Revit MEP.
Public class | PanelScheduleData | The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule
Public class | PanelScheduleSheetInstance | The class represents an instance of a panel schedule placed on sheet.
Public class | PanelScheduleTemplate | The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.
Public class | PanelScheduleView | An instance of a panel schedule view.
Public class | TemperatureRatingType | Represents temperature rating type definition information.
Public class | TemperatureRatingTypeSet |
Public class | TemperatureRatingTypeSetIterator |
Public class | VoltageType | Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
Public class | VoltageTypeSet | A set that contains voltage types.
Public class | VoltageTypeSetIterator | An iterator to a voltage type set.
Public class | Wire | An object to represent electrical wire in Revit MEP product.
Public class | WireConduitType | Represents a specific conduit type of wire type.
Public class | WireConduitTypeSet |
Public class | WireConduitTypeSetIterator |
Public class | WireMaterialType | Represents electrical wire material type definition information of wire type.
Public class | WireMaterialTypeSet |
Public class | WireMaterialTypeSetIterator |
Public class | WireSet | A set that can contain any type of object.
Public class | WireSetIterator | An iterator to a set.
Public class | WireSize | Represents specific electrical wire size information.
Public class | WireSizeSet | A set that contains wire sizes.
Public class | WireSizeSetIterator | An iterator to a wire size set.
Public class | WireType | Represents a specific wire type.
Public class | WireTypeSet |
Public class | WireTypeSetIterator |

Enumerations

 | Enumeration | Description
Public enumeration | CableTrayShape | Shape types enum of cable tray
Public enumeration | CircuitType | An enumerated type listing all the possible circuit types.
Public enumeration | ElectricalDemandFactorDefinitionData |
Public enumeration | ElectricalDemandFactorRule | This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.
Public enumeration | ElectricalLoadClassificationData | This enum is used by the ElectricalLoadClassification class as additional data whenever data members changed. It is used as the additional data when the atom corresponding to each data member is touched.
Public enumeration | ElectricalLoadClassificationSpace | This enum is used by the ElectricalLoadClassification to specify the load class for use with spaces.
Public enumeration | ElectricalPhase | An enumerated type to specify whether the electrical system is single phase or three phase.
Public enumeration | ElectricalPhaseConfiguration | An enumerated type to specify the electrical phase configuration.
Public enumeration | ElectricalSystemType | An enumerated type listing all the possible electrical system types for a connector object.
Public enumeration | LoadClassification | An enumerated type to list all demand factor classifications.
Public enumeration | LoadClassificationType | An enumerated type listing all the possible load classification types for a connector object.
Public enumeration | NeutralMode | An enumerated type to list the neutral mode for wire type.
Public enumeration | PanelConfiguration | This enum declares the configuration for given panel schedule type.
Public enumeration | PanelSchedulePhaseLoadType | Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule
Public enumeration | PanelScheduleType | This enum declares the panel schedule type.
Public enumeration | PowerFactorStateType | An enumerated type listing all the possible power factor state types for a connector object.
Public enumeration | WiringType | An enumerated type to list all wiring types.


CableTray Class

[image]

Revit 2013 API
CableTray Class
Members See Also Send Feedback
This class represents a cable tray in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CableTray : CableTrayConduitBase
Visual Basic
Public Class CableTray _
    Inherits CableTrayConduitBase
Visual C++
public ref class CableTray : public CableTrayConduitBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Electrical..::..CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::..CableTray

See Also

CableTray Members
Autodesk.Revit.DB.Electrical Namespace


CableTray Members

[image] [image]

Revit 2013 API
CableTray Members
CableTray Class Methods Properties See Also Send Feedback

The CableTray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of cable tray.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetShapeType | Returns the shape type for the cable tray.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCableTrayType | Identifies if a cable tray type is valid.
Public method | IsValidRungSpace | Identifies if the input rung space is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting; (Inherited from CableTrayConduitBase.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RungSpace |
Public property | RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTray Methods

[image] [image]

Revit 2013 API
CableTray Methods
CableTray Class See Also Send Feedback

The CableTray type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of cable tray.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetShapeType | Returns the shape type for the cable tray.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidCableTrayType | Identifies if a cable tray type is valid.
Public method | IsValidRungSpace | Identifies if the input rung space is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting; (Inherited from CableTrayConduitBase.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
CableTray..::..Create Method
CableTray Class See Also Send Feedback
Creates a new instance of cable tray.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static CableTray Create(
    Document document,
    ElementId cabletrayType,
    XYZ startPoint,
    XYZ endPoint,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    cabletrayType As ElementId, _
    startPoint As XYZ, _
    endPoint As XYZ, _
    levelId As ElementId _
) As CableTray
Visual C++
public:
static CableTray^ Create(
    Document^ document,
    ElementId^ cabletrayType,
    XYZ^ startPoint,
    XYZ^ endPoint,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
cabletrayType
Type: Autodesk.Revit.DB..::..ElementId
The cable tray type. This must be a cable tray type accepted by isValidCableTrayType(). If the input cable tray type is InvalidElementId, the default cable tray type from the document will be used.
startPoint
Type: Autodesk.Revit.DB..::..XYZ
The start point of the cable tray location line.
endPoint
Type: Autodesk.Revit.DB..::..XYZ
The end point of the cable tray location line.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the level which this cable tray based. If the input level id is invalidElementId = -1, the nearest level will be used.

Return Value

The newly created cable tray.

Remarks

This method will regenerate the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This cable tray type is invalid. -or- This level id is invalid. -or- This two end points are invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


GetShapeType Method

[image]

Revit 2013 API
CableTray..::..GetShapeType Method
CableTray Class See Also Send Feedback
Returns the shape type for the cable tray.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CableTrayShape GetShapeType()
Visual Basic
Public Function GetShapeType As CableTrayShape
Visual C++
public:
CableTrayShape GetShapeType()

Return Value

The shape type.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


IsValidCableTrayType Method

[image]

Revit 2013 API
CableTray..::..IsValidCableTrayType Method
CableTray Class See Also Send Feedback
Identifies if a cable tray type is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidCableTrayType(
    Document document,
    ElementId cabletrayType
)
Visual Basic
Public Shared Function IsValidCableTrayType ( _
    document As Document, _
    cabletrayType As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidCableTrayType(
    Document^ document,
    ElementId^ cabletrayType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
cabletrayType
Type: Autodesk.Revit.DB..::..ElementId
The cable tray type.

Return Value

True if the cable tray type is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


IsValidRungSpace Method

[image]

Revit 2013 API
CableTray..::..IsValidRungSpace Method
CableTray Class See Also Send Feedback
Identifies if the input rung space is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidRungSpace(
    double rungSpace
)
Visual Basic
Public Function IsValidRungSpace ( _
    rungSpace As Double _
) As Boolean
Visual C++
public:
bool IsValidRungSpace(
    double rungSpace
)

Parameters

rungSpace
Type: System..::..Double
The rung space to check.

Return Value

True if the value is acceptable, false otherwise.

Remarks

rung space should be at least equal to or larger than rang width which is 1 inch.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTray Properties

[image] [image]

Revit 2013 API
CableTray Properties
CableTray Class See Also Send Feedback

The CableTray type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RungSpace |
Public property | RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
CableTray..::..Parameter Property
CableTray Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CableTray Class
CableTray Members
Autodesk.Revit.DB.Electrical Namespace


RungSpace Property

[image]

Revit 2013 API
CableTray..::..RungSpace Property
CableTray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double RungSpace { get; set; }
Visual Basic
Public Property RungSpace As Double
    Get
    Set
Visual C++
public:
property double RungSpace {
    double get ();
    void set (double value);
}

Remarks

Distance between two rungs for the ladder cable tray. This should be positive.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The rung space value should be at least equal to or larger than rang width which is 1 inch.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

CableTray Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Class

[image]

Revit 2013 API
CableTrayConduitBase Class
Members See Also Send Feedback
The CableTrayConduitBase class is implemented as the base class for cable tray or conduit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CableTrayConduitBase : MEPCurve
Visual Basic
Public Class CableTrayConduitBase _
    Inherits MEPCurve
Visual C++
public ref class CableTrayConduitBase : public MEPCurve

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Electrical..::..CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::..CableTray
Autodesk.Revit.DB.Electrical..::..Conduit

See Also

CableTrayConduitBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Members

[image] [image]

Revit 2013 API
CableTrayConduitBase Members
CableTrayConduitBase Class Methods Properties See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidEndPoints | Identifies if two end points are valid.
 | IsValidLevelId | Identifies if a level id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RunId | The id of the run to which this element belongs.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Methods

[image] [image]

Revit 2013 API
CableTrayConduitBase Methods
CableTrayConduitBase Class See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidEndPoints | Identifies if two end points are valid.
 | IsValidLevelId | Identifies if a level id is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsValidEndPoints Method

[image]

Revit 2013 API
CableTrayConduitBase..::..IsValidEndPoints Method
CableTrayConduitBase Class See Also Send Feedback
Identifies if two end points are valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidEndPoints(
    XYZ startPoint,
    XYZ endPoint
)
Visual Basic
Public Shared Function IsValidEndPoints ( _
    startPoint As XYZ, _
    endPoint As XYZ _
) As Boolean
Visual C++
public:
static bool IsValidEndPoints(
    XYZ^ startPoint,
    XYZ^ endPoint
)

Parameters

startPoint
Type: Autodesk.Revit.DB..::..XYZ
The start point of the location line.
endPoint
Type: Autodesk.Revit.DB..::..XYZ
The end point of the location line.

Return Value

True if the two end points are valid, false otherwise.

Remarks

The two points should not be too close.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsValidLevelId Method

[image]

Revit 2013 API
CableTrayConduitBase..::..IsValidLevelId Method
CableTrayConduitBase Class See Also Send Feedback
Identifies if a level id is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidLevelId(
    Document document,
    ElementId levelId
)
Visual Basic
Public Shared Function IsValidLevelId ( _
    document As Document, _
    levelId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidLevelId(
    Document^ document,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id.

Return Value

True if the level id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Method

[image]

Revit 2013 API
CableTrayConduitBase..::..IsWithFitting Method
CableTrayConduitBase Class See Also Send Feedback
Return whether its cable tray/conduit type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsWithFitting()
Visual Basic
Public Function IsWithFitting As Boolean
Visual C++
public:
bool IsWithFitting()

Return Value

return true if its type is with fitting type.

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitBase Properties

[image] [image]

Revit 2013 API
CableTrayConduitBase Properties
CableTrayConduitBase Class See Also Send Feedback

The CableTrayConduitBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RunId | The id of the run to which this element belongs.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
CableTrayConduitBase..::..Parameter Property
CableTrayConduitBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CableTrayConduitBase Class
CableTrayConduitBase Members
Autodesk.Revit.DB.Electrical Namespace


RunId Property

[image]

Revit 2013 API
CableTrayConduitBase..::..RunId Property
CableTrayConduitBase Class See Also Send Feedback
The id of the run to which this element belongs.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId RunId { get; }
Visual Basic
Public ReadOnly Property RunId As ElementId
    Get
Visual C++
public:
property ElementId^ RunId {
    ElementId^ get ();
}

See Also

CableTrayConduitBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Class

[image]

Revit 2013 API
CableTrayConduitRunBase Class
Members See Also Send Feedback
The base class for a cable tray or conduit run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CableTrayConduitRunBase : Element
Visual Basic
Public Class CableTrayConduitRunBase _
    Inherits Element
Visual C++
public ref class CableTrayConduitRunBase : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::..CableTrayRun
Autodesk.Revit.DB.Electrical..::..ConduitRun

See Also

CableTrayConduitRunBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Members

[image] [image]

Revit 2013 API
CableTrayConduitRunBase Members
CableTrayConduitRunBase Class Methods Properties See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Methods

[image] [image]

Revit 2013 API
CableTrayConduitRunBase Methods
CableTrayConduitRunBase Class See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayConduitRunBase Properties

[image] [image]

Revit 2013 API
CableTrayConduitRunBase Properties
CableTrayConduitRunBase Class See Also Send Feedback

The CableTrayConduitRunBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


Length Property

[image]

Revit 2013 API
CableTrayConduitRunBase..::..Length Property
CableTrayConduitRunBase Class See Also Send Feedback
The length of the whole (cable tray or conduit) run setter public_db_only

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

See Also

CableTrayConduitRunBase Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
CableTrayConduitRunBase..::..Parameter Property
CableTrayConduitRunBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CableTrayConduitRunBase Class
CableTrayConduitRunBase Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Class

[image]

Revit 2013 API
CableTrayRun Class
Members See Also Send Feedback
This class represents a cable tray run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CableTrayRun : CableTrayConduitRunBase
Visual Basic
Public Class CableTrayRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class CableTrayRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a cable tray run. A cable tray run contains connected straight cable tray segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::..CableTrayRun

See Also

CableTrayRun Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Members

[image] [image]

Revit 2013 API
CableTrayRun Members
CableTrayRun Class Methods Properties See Also Send Feedback

The CableTrayRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only; (Inherited from CableTrayConduitRunBase.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Methods

[image] [image]

Revit 2013 API
CableTrayRun Methods
CableTrayRun Class See Also Send Feedback

The CableTrayRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayRun Properties

[image] [image]

Revit 2013 API
CableTrayRun Properties
CableTrayRun Class See Also Send Feedback

The CableTrayRun type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only; (Inherited from CableTrayConduitRunBase.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayRun Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
CableTrayRun..::..Parameter Property
CableTrayRun Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CableTrayRun Class
CableTrayRun Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayShape Enumeration

[image]

Revit 2013 API
CableTrayShape Enumeration
See Also Send Feedback
Shape types enum of cable tray
Enum of cable tray shape

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum CableTrayShape
Visual Basic
Public Enumeration CableTrayShape
Visual C++
public enum class CableTrayShape

Members

Member name | Description
Invalid | Invalid cable tray shape.
Channel | Channel cable tray shape.
Ladder | Ladder cable tray shape.

See Also

Autodesk.Revit.DB.Electrical Namespace


CableTrayType Class

[image]

Revit 2013 API
CableTrayType Class
Members See Also Send Feedback
This class represents a cable tray type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CableTrayType : MEPCurveType
Visual Basic
Public Class CableTrayType _
    Inherits MEPCurveType
Visual C++
public ref class CableTrayType : public MEPCurveType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Electrical..::..CableTrayType

See Also

CableTrayType Members
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Members

[image] [image]

Revit 2013 API
CableTrayType Members
CableTrayType Class Methods Properties See Also Send Feedback

The CableTrayType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidBendMultiplier | Identifies if the input bend multiplier is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BendMultiplier | Bend multiplier.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsWithFitting | Whether this cable tray type is with fitting
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | ShapeType | Shape of this cable tray type.
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Methods

[image] [image]

Revit 2013 API
CableTrayType Methods
CableTrayType Class See Also Send Feedback

The CableTrayType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidBendMultiplier | Identifies if the input bend multiplier is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


IsValidBendMultiplier Method

[image]

Revit 2013 API
CableTrayType..::..IsValidBendMultiplier Method
CableTrayType Class See Also Send Feedback
Identifies if the input bend multiplier is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsValidBendMultiplier(
    double bendMultiplier
)
Visual Basic
Public Function IsValidBendMultiplier ( _
    bendMultiplier As Double _
) As Boolean
Visual C++
public:
bool IsValidBendMultiplier(
    double bendMultiplier
)

Parameters

bendMultiplier
Type: System..::..Double
The bend multiplier to check.

Return Value

True if the value is acceptable, false otherwise.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CableTrayType Properties

[image] [image]

Revit 2013 API
CableTrayType Properties
CableTrayType Class See Also Send Feedback

The CableTrayType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BendMultiplier | Bend multiplier.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsWithFitting | Whether this cable tray type is with fitting
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | ShapeType | Shape of this cable tray type.
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


BendMultiplier Property

[image]

Revit 2013 API
CableTrayType..::..BendMultiplier Property
CableTrayType Class See Also Send Feedback
Bend multiplier.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BendMultiplier { get; set; }
Visual Basic
Public Property BendMultiplier As Double
    Get
    Set
Visual C++
public:
property double BendMultiplier {
    double get ();
    void set (double value);
}

Remarks

This should be positive and less than 3000.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The bend multiplier value should be positive and less than 3000.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Property

[image]

Revit 2013 API
CableTrayType..::..IsWithFitting Property
CableTrayType Class See Also Send Feedback
Whether this cable tray type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsWithFitting { get; }
Visual Basic
Public ReadOnly Property IsWithFitting As Boolean
    Get
Visual C++
public:
property bool IsWithFitting {
    bool get ();
}

Remarks

True if this cable tray type is with fitting type.

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
CableTrayType..::..Parameter Property
CableTrayType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

CableTrayType Class
CableTrayType Members
Autodesk.Revit.DB.Electrical Namespace


ShapeType Property

[image]

Revit 2013 API
CableTrayType..::..ShapeType Property
CableTrayType Class See Also Send Feedback
Shape of this cable tray type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CableTrayShape ShapeType { get; }
Visual Basic
Public ReadOnly Property ShapeType As CableTrayShape
    Get
Visual C++
public:
property CableTrayShape ShapeType {
    CableTrayShape get ();
}

See Also

CableTrayType Class
Autodesk.Revit.DB.Electrical Namespace


CircuitType Enumeration

[image]

Revit 2013 API
CircuitType Enumeration
See Also Send Feedback
An enumerated type listing all the possible circuit types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum CircuitType
Visual Basic
Public Enumeration CircuitType
Visual C++
public enum class CircuitType

Members

Member name | Description
Circuit | Circuit type is circuit.
Spare | Circuit type is spare.
Space | Circuit type is space.

See Also

Autodesk.Revit.DB.Electrical Namespace


Conduit Class

[image]

Revit 2013 API
Conduit Class
Members See Also Send Feedback
This class represents a conduit in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Conduit : CableTrayConduitBase
Visual Basic
Public Class Conduit _
    Inherits CableTrayConduitBase
Visual C++
public ref class Conduit : public CableTrayConduitBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Electrical..::..CableTrayConduitBase
Autodesk.Revit.DB.Electrical..::..Conduit

See Also

Conduit Members
Autodesk.Revit.DB.Electrical Namespace


Conduit Members

[image] [image]

Revit 2013 API
Conduit Members
Conduit Class Methods Properties See Also Send Feedback

The Conduit type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of conduit.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidConduitType | Identifies if a conduit type is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting; (Inherited from CableTrayConduitBase.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Methods

[image] [image]

Revit 2013 API
Conduit Methods
Conduit Class See Also Send Feedback

The Conduit type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of conduit.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidConduitType | Identifies if a conduit type is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsWithFitting | Return whether its cable tray/conduit type is with fitting; (Inherited from CableTrayConduitBase.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
Conduit..::..Create Method
Conduit Class See Also Send Feedback
Creates a new instance of conduit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Conduit Create(
    Document document,
    ElementId conduitType,
    XYZ startPoint,
    XYZ endPoint,
    ElementId levelId
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    conduitType As ElementId, _
    startPoint As XYZ, _
    endPoint As XYZ, _
    levelId As ElementId _
) As Conduit
Visual C++
public:
static Conduit^ Create(
    Document^ document,
    ElementId^ conduitType,
    XYZ^ startPoint,
    XYZ^ endPoint,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
conduitType
Type: Autodesk.Revit.DB..::..ElementId
The conduit type. This must be a conduit type accepted by isValidConduitType(). If the input conduit type is InvalidElementId, the default conduit type from the document will be used.
startPoint
Type: Autodesk.Revit.DB..::..XYZ
The start point of the conduit location line.
endPoint
Type: Autodesk.Revit.DB..::..XYZ
The end point of the conduit location line.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element id of the level which this conduit based. If the input level id is invalidElementId = -1, the nearest level will be used.

Return Value

The newly created conduit.

Remarks

This method will regenerate the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This conduit type is invalid. -or- This level id is invalid. -or- This two end points are invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


IsValidConduitType Method

[image]

Revit 2013 API
Conduit..::..IsValidConduitType Method
Conduit Class See Also Send Feedback
Identifies if a conduit type is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool IsValidConduitType(
    Document document,
    ElementId conduitType
)
Visual Basic
Public Shared Function IsValidConduitType ( _
    document As Document, _
    conduitType As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidConduitType(
    Document^ document,
    ElementId^ conduitType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
conduitType
Type: Autodesk.Revit.DB..::..ElementId
The conduit type.

Return Value

True if the conduit type is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Properties

[image] [image]

Revit 2013 API
Conduit Properties
Conduit Class See Also Send Feedback

The Conduit type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | RunId | The id of the run to which this element belongs. (Inherited from CableTrayConduitBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Conduit Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
Conduit..::..Parameter Property
Conduit Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Conduit Class
Conduit Members
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Class

[image]

Revit 2013 API
ConduitRun Class
Members See Also Send Feedback
This class represents a conduit run in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConduitRun : CableTrayConduitRunBase
Visual Basic
Public Class ConduitRun _
    Inherits CableTrayConduitRunBase
Visual C++
public ref class ConduitRun : public CableTrayConduitRunBase

Remarks

This class is mainly for calculating length of a conduit run. A conduit run contains connected straight conduit segments and bends between the straight segments with same type and size.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..CableTrayConduitRunBase
Autodesk.Revit.DB.Electrical..::..ConduitRun

See Also

ConduitRun Members
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Members

[image] [image]

Revit 2013 API
ConduitRun Members
ConduitRun Class Methods Properties See Also Send Feedback

The ConduitRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only; (Inherited from CableTrayConduitRunBase.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Methods

[image] [image]

Revit 2013 API
ConduitRun Methods
ConduitRun Class See Also Send Feedback

The ConduitRun type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


ConduitRun Properties

[image] [image]

Revit 2013 API
ConduitRun Properties
ConduitRun Class See Also Send Feedback

The ConduitRun type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Length | The length of the whole (cable tray or conduit) run setter public_db_only; (Inherited from CableTrayConduitRunBase.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConduitRun Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ConduitRun..::..Parameter Property
ConduitRun Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ConduitRun Class
ConduitRun Members
Autodesk.Revit.DB.Electrical Namespace


ConduitType Class

[image]

Revit 2013 API
ConduitType Class
Members See Also Send Feedback
This class represents a conduit type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ConduitType : MEPCurveType
Visual Basic
Public Class ConduitType _
    Inherits MEPCurveType
Visual C++
public ref class ConduitType : public MEPCurveType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Electrical..::..ConduitType

See Also

ConduitType Members
Autodesk.Revit.DB.Electrical Namespace


ConduitType Members

[image] [image]

Revit 2013 API
ConduitType Members
ConduitType Class Methods Properties See Also Send Feedback

The ConduitType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsWithFitting | Whether this conduit type is with fitting
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


ConduitType Methods

[image] [image]

Revit 2013 API
ConduitType Methods
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


ConduitType Properties

[image] [image]

Revit 2013 API
ConduitType Properties
ConduitType Class See Also Send Feedback

The ConduitType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsWithFitting | Whether this conduit type is with fitting
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


IsWithFitting Property

[image]

Revit 2013 API
ConduitType..::..IsWithFitting Property
ConduitType Class See Also Send Feedback
Whether this conduit type is with fitting

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsWithFitting { get; }
Visual Basic
Public ReadOnly Property IsWithFitting As Boolean
    Get
Visual C++
public:
property bool IsWithFitting {
    bool get ();
}

Remarks

True if this conduit type is with fitting type.

See Also

ConduitType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ConduitType..::..Parameter Property
ConduitType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ConduitType Class
ConduitType Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Class

[image]

Revit 2013 API
CorrectionFactor Class
Members See Also Send Feedback
Represents electrical correction factor information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CorrectionFactor : APIObject
Visual Basic
Public Class CorrectionFactor _
    Inherits APIObject
Visual C++
public ref class CorrectionFactor : public APIObject

Remarks

Correction factor is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..CorrectionFactor

See Also

CorrectionFactor Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Members

[image] [image]

Revit 2013 API
CorrectionFactor Members
CorrectionFactor Class Methods Properties See Also Send Feedback

The CorrectionFactor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Factor | Get factor value of wire correction factor.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Methods

[image] [image]

Revit 2013 API
CorrectionFactor Methods
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactor Properties

[image] [image]

Revit 2013 API
CorrectionFactor Properties
CorrectionFactor Class See Also Send Feedback

The CorrectionFactor type exposes the following members.

Properties

 | Name | Description
Public property | Factor | Get factor value of wire correction factor.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Temperature | Get temperature which is used for specifying correction factor.

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


Factor Property

[image]

Revit 2013 API
CorrectionFactor..::..Factor Property
CorrectionFactor Class See Also Send Feedback
Get factor value of wire correction factor.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Factor { get; }
Visual Basic
Public ReadOnly Property Factor As Double
    Get
Visual C++
public:
property double Factor {
    double get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


Temperature Property

[image]

Revit 2013 API
CorrectionFactor..::..Temperature Property
CorrectionFactor Class See Also Send Feedback
Get temperature which is used for specifying correction factor.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public long Temperature { get; }
Visual Basic
Public ReadOnly Property Temperature As Long
    Get
Visual C++
public:
property long long Temperature {
    long long get ();
}

See Also

CorrectionFactor Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Class

[image]

Revit 2013 API
CorrectionFactorSet Class
Members See Also Send Feedback
A set that contains correction factors.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class CorrectionFactorSet : APIObject,
    IEnumerable
Visual Basic
Public Class CorrectionFactorSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class CorrectionFactorSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSet

See Also

CorrectionFactorSet Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Members

[image] [image]

Revit 2013 API
CorrectionFactorSet Members
CorrectionFactorSet Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Constructors

 | Name | Description
Public method | CorrectionFactorSet | Initializes a new instance of the CorrectionFactorSet class

Methods

 | Name | Description
Public method | Clear | Removes every correction factor from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Constructor

[image]

Revit 2013 API
CorrectionFactorSet Constructor
CorrectionFactorSet Class See Also Send Feedback
Initializes a new instance of the CorrectionFactorSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CorrectionFactorSet()
Visual Basic
Public Sub New
Visual C++
public:
CorrectionFactorSet()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Methods

[image] [image]

Revit 2013 API
CorrectionFactorSet Methods
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every correction factor from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
CorrectionFactorSet..::..Clear Method
CorrectionFactorSet Class See Also Send Feedback
Removes every correction factor from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
CorrectionFactorSet..::..Contains Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    CorrectionFactor item
)
Visual Basic
Public Overridable Function Contains ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Contains(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
CorrectionFactorSet..::..Erase Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    CorrectionFactor item
)
Visual Basic
Public Overridable Function Erase ( _
    item As CorrectionFactor _
) As Integer
Visual C++
public:
virtual int Erase(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
CorrectionFactorSet..::..ForwardIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
CorrectionFactorSet..::..GetEnumerator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
CorrectionFactorSet..::..Insert Method
CorrectionFactorSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    CorrectionFactor item
)
Visual Basic
Public Overridable Function Insert ( _
    item As CorrectionFactor _
) As Boolean
Visual C++
public:
virtual bool Insert(
    CorrectionFactor^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..CorrectionFactor

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
CorrectionFactorSet..::..ReverseIterator Method
CorrectionFactorSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CorrectionFactorSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As CorrectionFactorSetIterator
Visual C++
public:
virtual CorrectionFactorSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSet Properties

[image] [image]

Revit 2013 API
CorrectionFactorSet Properties
CorrectionFactorSet Class See Also Send Feedback

The CorrectionFactorSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of correction factors that are in the set.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
CorrectionFactorSet..::..IsEmpty Property
CorrectionFactorSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
CorrectionFactorSet..::..Size Property
CorrectionFactorSet Class See Also Send Feedback
Returns the number of correction factors that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

CorrectionFactorSet Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Class

[image]

Revit 2013 API
CorrectionFactorSetIterator Class
Members See Also Send Feedback
An iterator to a correction factor set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class CorrectionFactorSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class CorrectionFactorSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class CorrectionFactorSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..CorrectionFactorSetIterator

See Also

CorrectionFactorSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Members

[image] [image]

Revit 2013 API
CorrectionFactorSetIterator Members
CorrectionFactorSetIterator Class Constructors Methods Properties See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | CorrectionFactorSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Constructor

[image]

Revit 2013 API
CorrectionFactorSetIterator Constructor
CorrectionFactorSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CorrectionFactorSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
CorrectionFactorSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Methods

[image] [image]

Revit 2013 API
CorrectionFactorSetIterator Methods
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
CorrectionFactorSetIterator..::..MoveNext Method
CorrectionFactorSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
CorrectionFactorSetIterator..::..Reset Method
CorrectionFactorSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactorSetIterator Properties

[image] [image]

Revit 2013 API
CorrectionFactorSetIterator Properties
CorrectionFactorSetIterator Class See Also Send Feedback

The CorrectionFactorSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
CorrectionFactorSetIterator..::..Current Property
CorrectionFactorSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

CorrectionFactorSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Class

[image]

Revit 2013 API
DistributionSysType Class
Members See Also Send Feedback
Represents a specific type of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DistributionSysType : ElementType
Visual Basic
Public Class DistributionSysType _
    Inherits ElementType
Visual C++
public ref class DistributionSysType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..DistributionSysType

See Also

DistributionSysType Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Members

[image] [image]

Revit 2013 API
DistributionSysType Members
DistributionSysType Class Methods Properties See Also Send Feedback

The DistributionSysType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
Public property | ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Get the value which indicates whether this distribution system is in service now.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NumWires | Get or set number of wires of distribution system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VoltageLineToGround | Get or set line to ground voltage of distribution system type.
Public property | VoltageLineToLine | Get or set line to line voltage type of distribution system type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Methods

[image] [image]

Revit 2013 API
DistributionSysType Methods
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysType Properties

[image] [image]

Revit 2013 API
DistributionSysType Properties
DistributionSysType Class See Also Send Feedback

The DistributionSysType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | ElectricalPhase | Get or set electrical phase (single, triple or undefined) of distribution system.
Public property | ElectricalPhaseConfiguration | Get or set electrical phase configuration (Y, delta or undefined) of distribution system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Get the value which indicates whether this distribution system is in service now.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NumWires | Get or set number of wires of distribution system.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | VoltageLineToGround | Get or set line to ground voltage of distribution system type.
Public property | VoltageLineToLine | Get or set line to line voltage type of distribution system type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalPhase Property

[image]

Revit 2013 API
DistributionSysType..::..ElectricalPhase Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase (single, triple or undefined) of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalPhase ElectricalPhase { get; set; }
Visual Basic
Public Property ElectricalPhase As ElectricalPhase
    Get
    Set
Visual C++
public:
property ElectricalPhase ElectricalPhase {
    ElectricalPhase get ();
    void set (ElectricalPhase value);
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalPhaseConfiguration Property

[image]

Revit 2013 API
DistributionSysType..::..ElectricalPhaseConfiguration Property
DistributionSysType Class See Also Send Feedback
Get or set electrical phase configuration (Y, delta or undefined) of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalPhaseConfiguration ElectricalPhaseConfiguration { get; set; }
Visual Basic
Public Property ElectricalPhaseConfiguration As ElectricalPhaseConfiguration
    Get
    Set
Visual C++
public:
property ElectricalPhaseConfiguration ElectricalPhaseConfiguration {
    ElectricalPhaseConfiguration get ();
    void set (ElectricalPhaseConfiguration value);
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
DistributionSysType..::..IsInUse Property
DistributionSysType Class See Also Send Feedback
Get the value which indicates whether this distribution system is in service now.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


NumWires Property

[image]

Revit 2013 API
DistributionSysType..::..NumWires Property
DistributionSysType Class See Also Send Feedback
Get or set number of wires of distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumWires { get; set; }
Visual Basic
Public Property NumWires As Integer
    Get
    Set
Visual C++
public:
property int NumWires {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | While assign a negative value to NumWires.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DistributionSysType..::..Parameter Property
DistributionSysType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DistributionSysType Class
DistributionSysType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageLineToGround Property

[image]

Revit 2013 API
DistributionSysType..::..VoltageLineToGround Property
DistributionSysType Class See Also Send Feedback
Get or set line to ground voltage of distribution system type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageType VoltageLineToGround { get; set; }
Visual Basic
Public Property VoltageLineToGround As VoltageType
    Get
    Set
Visual C++
public:
property VoltageType^ VoltageLineToGround {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageLineToLine Property

[image]

Revit 2013 API
DistributionSysType..::..VoltageLineToLine Property
DistributionSysType Class See Also Send Feedback
Get or set line to line voltage type of distribution system type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageType VoltageLineToLine { get; set; }
Visual Basic
Public Property VoltageLineToLine As VoltageType
    Get
    Set
Visual C++
public:
property VoltageType^ VoltageLineToLine {
    VoltageType^ get ();
    void set (VoltageType^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The voltage retrieved here is read only and actions to modify its properties it will throw an System.InvalidOperationException.

See Also

DistributionSysType Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Class

[image]

Revit 2013 API
DistributionSysTypeSet Class
Members See Also Send Feedback
A set that contains DistributionSys types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DistributionSysTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class DistributionSysTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class DistributionSysTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSet

See Also

DistributionSysTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Members

[image] [image]

Revit 2013 API
DistributionSysTypeSet Members
DistributionSysTypeSet Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | DistributionSysTypeSet | Initializes a new instance of the DistributionSysTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every DistributionSys type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a DistributionSys type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified DistributionSys type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified DistributionSys type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Constructor

[image]

Revit 2013 API
DistributionSysTypeSet Constructor
DistributionSysTypeSet Class See Also Send Feedback
Initializes a new instance of the DistributionSysTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DistributionSysTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
DistributionSysTypeSet()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Methods

[image] [image]

Revit 2013 API
DistributionSysTypeSet Methods
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every DistributionSys type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a DistributionSys type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified DistributionSys type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified DistributionSys type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..Clear Method
DistributionSysTypeSet Class See Also Send Feedback
Removes every DistributionSys type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..Contains Method
DistributionSysTypeSet Class See Also Send Feedback
Tests for the existence of a DistributionSys type within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    DistributionSysType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..DistributionSysType
The DistributionSys type to be searched for.

Return Value

The Contains method returns True if the DistributionSys type is within the set, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..Erase Method
DistributionSysTypeSet Class See Also Send Feedback
Removes a specified DistributionSys type from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    DistributionSysType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As DistributionSysType _
) As Integer
Visual C++
public:
virtual int Erase(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..DistributionSysType
The DistributionSys type to be erased.

Return Value

The number of DistributionSys types that were erased from the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..ForwardIterator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..GetEnumerator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..Insert Method
DistributionSysTypeSet Class See Also Send Feedback
Insert the specified DistributionSys type into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    DistributionSysType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As DistributionSysType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    DistributionSysType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..DistributionSysType
The DistributionSys type to be inserted into the set.

Return Value

Returns whether the DistributionSys type was inserted into the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
DistributionSysTypeSet..::..ReverseIterator Method
DistributionSysTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual DistributionSysTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As DistributionSysTypeSetIterator
Visual C++
public:
virtual DistributionSysTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSet Properties

[image] [image]

Revit 2013 API
DistributionSysTypeSet Properties
DistributionSysTypeSet Class See Also Send Feedback

The DistributionSysTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of DistributionSys types that are in the set.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
DistributionSysTypeSet..::..IsEmpty Property
DistributionSysTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
DistributionSysTypeSet..::..Size Property
DistributionSysTypeSet Class See Also Send Feedback
Returns the number of DistributionSys types that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

DistributionSysTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Class

[image]

Revit 2013 API
DistributionSysTypeSetIterator Class
Members See Also Send Feedback
An iterator to a DistributionSys type set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DistributionSysTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class DistributionSysTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class DistributionSysTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..DistributionSysTypeSetIterator

See Also

DistributionSysTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Members

[image] [image]

Revit 2013 API
DistributionSysTypeSetIterator Members
DistributionSysTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | DistributionSysTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Constructor

[image]

Revit 2013 API
DistributionSysTypeSetIterator Constructor
DistributionSysTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DistributionSysTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
DistributionSysTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Methods

[image] [image]

Revit 2013 API
DistributionSysTypeSetIterator Methods
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
DistributionSysTypeSetIterator..::..MoveNext Method
DistributionSysTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
DistributionSysTypeSetIterator..::..Reset Method
DistributionSysTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypeSetIterator Properties

[image] [image]

Revit 2013 API
DistributionSysTypeSetIterator Properties
DistributionSysTypeSetIterator Class See Also Send Feedback

The DistributionSysTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
DistributionSysTypeSetIterator..::..Current Property
DistributionSysTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

DistributionSysTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Class

[image]

Revit 2013 API
ElectricalConnector Class
Members See Also Send Feedback
An electrical connector that is assigned to an electrical equipment or device family. Provides access to the electrical connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class ElectricalConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class ElectricalConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class ElectricalConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Electrical connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Electrical..::..ElectricalConnector

See Also

ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Members

[image] [image]

Revit 2013 API
ElectricalConnector Members
ElectricalConnector Class Methods Properties See Also Send Feedback

The ElectricalConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Methods

[image] [image]

Revit 2013 API
ElectricalConnector Methods
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalConnector Properties

[image] [image]

Revit 2013 API
ElectricalConnector Properties
ElectricalConnector Class See Also Send Feedback

The ElectricalConnector type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ElectricalConnector..::..Parameter Property
ElectricalConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElectricalConnector Class
ElectricalConnector Members
Autodesk.Revit.DB.Electrical Namespace


SystemType Property

[image]

Revit 2013 API
ElectricalConnector..::..SystemType Property
ElectricalConnector Class See Also Send Feedback
The system type of the connector.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; set; }
Visual Basic
Public Property SystemType As ElectricalSystemType
    Get
    Set
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
    void set (ElectricalSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the system type is out of the permitted range of values.

See Also

ElectricalConnector Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Class

[image]

Revit 2013 API
ElectricalDemandFactorDefinition Class
Members See Also Send Feedback
The ElectricalDemandFactorDef class represents a serialized version of an instance of demand factor definition. It has a name, rule type, and values for the rules that are serialized.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElectricalDemandFactorDefinition : Element
Visual Basic
Public Class ElectricalDemandFactorDefinition _
    Inherits Element
Visual C++
public ref class ElectricalDemandFactorDefinition : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..ElectricalDemandFactorDefinition

See Also

ElectricalDemandFactorDefinition Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Members

[image] [image]

Revit 2013 API
ElectricalDemandFactorDefinition Members
ElectricalDemandFactorDefinition Class Constructors Methods Properties See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | ElectricalDemandFactorDefinition | Initializes a new instance of the ElectricalDemandFactorDefinition class

Methods

 | Name | Description
Public method | AddValue | Adds a value to the value set for this demand factor definition
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearValues | Clears all the values stored for this demand factor definition.
 | Create | Creates a new instance of a demand factor definition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetValues | Provides access to the value set stored with this demand factor definition
Public method | GetValuesCount | Returns the number of values in the set.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveValue | Removes a value to the value set for this demand factor definition
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetValues | Sets the value set to the demand factor definition.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalLoad | Additional load to be included during demand load calculation.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IncludeAdditionalLoad | Should the additional load (if set) be included in demand load calculations.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RuleType | The rule type for this demand factor definition.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Constructor

[image]

Revit 2013 API
ElectricalDemandFactorDefinition Constructor
ElectricalDemandFactorDefinition Class See Also Send Feedback
Initializes a new instance of the ElectricalDemandFactorDefinition class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorDefinition()
Visual Basic
Public Sub New
Visual C++
public:
ElectricalDemandFactorDefinition()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Methods

[image] [image]

Revit 2013 API
ElectricalDemandFactorDefinition Methods
ElectricalDemandFactorDefinition Class See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddValue | Adds a value to the value set for this demand factor definition
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearValues | Clears all the values stored for this demand factor definition.
 | Create | Creates a new instance of a demand factor definition.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetApplicableDemandFactor | This method will return the applicable demand factor for the specified number of devices or load.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetValues | Provides access to the value set stored with this demand factor definition
Public method | GetValuesCount | Returns the number of values in the set.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveValue | Removes a value to the value set for this demand factor definition
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetValues | Sets the value set to the demand factor definition.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


AddValue Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..AddValue Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Adds a value to the value set for this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddValue(
    ElectricalDemandFactorValue dfValue
)
Visual Basic
Public Sub AddValue ( _
    dfValue As ElectricalDemandFactorValue _
)
Visual C++
public:
void AddValue(
    ElectricalDemandFactorValue^ dfValue
)

Parameters

dfValue
Type: Autodesk.Revit.DB.Electrical..::..ElectricalDemandFactorValue
Value to add to the set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ClearValues Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..ClearValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Clears all the values stored for this demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void ClearValues()
Visual Basic
Public Sub ClearValues
Visual C++
public:
void ClearValues()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..Create Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Creates a new instance of a demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElectricalDemandFactorDefinition Create(
    Document ADoc,
    string strName
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    strName As String _
) As ElectricalDemandFactorDefinition
Visual C++
public:
static ElectricalDemandFactorDefinition^ Create(
    Document^ ADoc,
    String^ strName
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
strName
Type: System..::..String
The name of the electrical demand factor definition to be created.

Return Value

The newly created demand factor definition element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetApplicableDemandFactor Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..GetApplicableDemandFactor Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
This method will return the applicable demand factor for the specified number of devices or load.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GetApplicableDemandFactor(
    double numberOrLoad
)
Visual Basic
Public Function GetApplicableDemandFactor ( _
    numberOrLoad As Double _
) As Double
Visual C++
public:
double GetApplicableDemandFactor(
    double numberOrLoad
)

Parameters

numberOrLoad
Type: System..::..Double
The number of devices or load for which the demand factor should be looked up.

Return Value

The applicable demand factor.

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetValues Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..GetValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Provides access to the value set stored with this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElectricalDemandFactorValue> GetValues()
Visual Basic
Public Function GetValues As ICollection(Of ElectricalDemandFactorValue)
Visual C++
public:
ICollection<ElectricalDemandFactorValue^>^ GetValues()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


GetValuesCount Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..GetValuesCount Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Returns the number of values in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public int GetValuesCount()
Visual Basic
Public Function GetValuesCount As Integer
Visual C++
public:
int GetValuesCount()

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


RemoveValue Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..RemoveValue Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Removes a value to the value set for this demand factor definition

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void RemoveValue(
    ElectricalDemandFactorValue dfValue
)
Visual Basic
Public Sub RemoveValue ( _
    dfValue As ElectricalDemandFactorValue _
)
Visual C++
public:
void RemoveValue(
    ElectricalDemandFactorValue^ dfValue
)

Parameters

dfValue
Type: Autodesk.Revit.DB.Electrical..::..ElectricalDemandFactorValue
Value to remove from the set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


SetValues Method

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..SetValues Method
ElectricalDemandFactorDefinition Class See Also Send Feedback
Sets the value set to the demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetValues(
    ICollection<ElectricalDemandFactorValue> values
)
Visual Basic
Public Sub SetValues ( _
    values As ICollection(Of ElectricalDemandFactorValue) _
)
Visual C++
public:
void SetValues(
    ICollection<ElectricalDemandFactorValue^>^ values
)

Parameters

values
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElectricalDemandFactorValue>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinition Properties

[image] [image]

Revit 2013 API
ElectricalDemandFactorDefinition Properties
ElectricalDemandFactorDefinition Class See Also Send Feedback

The ElectricalDemandFactorDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalLoad | Additional load to be included during demand load calculation.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IncludeAdditionalLoad | Should the additional load (if set) be included in demand load calculations.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RuleType | The rule type for this demand factor definition.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


AdditionalLoad Property

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..AdditionalLoad Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Additional load to be included during demand load calculation.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AdditionalLoad { get; set; }
Visual Basic
Public Property AdditionalLoad As Double
    Get
    Set
Visual C++
public:
property double AdditionalLoad {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


IncludeAdditionalLoad Property

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..IncludeAdditionalLoad Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Should the additional load (if set) be included in demand load calculations.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IncludeAdditionalLoad { get; set; }
Visual Basic
Public Property IncludeAdditionalLoad As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeAdditionalLoad {
    bool get ();
    void set (bool value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..Parameter Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElectricalDemandFactorDefinition Class
ElectricalDemandFactorDefinition Members
Autodesk.Revit.DB.Electrical Namespace


RuleType Property

[image]

Revit 2013 API
ElectricalDemandFactorDefinition..::..RuleType Property
ElectricalDemandFactorDefinition Class See Also Send Feedback
The rule type for this demand factor definition.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorRule RuleType { get; set; }
Visual Basic
Public Property RuleType As ElectricalDemandFactorRule
    Get
    Set
Visual C++
public:
property ElectricalDemandFactorRule RuleType {
    ElectricalDemandFactorRule get ();
    void set (ElectricalDemandFactorRule value);
}

See Also

ElectricalDemandFactorDefinition Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorDefinitionData Enumeration

[image]

Revit 2013 API
ElectricalDemandFactorDefinitionData Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum ElectricalDemandFactorDefinitionData
Visual Basic
Public Enumeration ElectricalDemandFactorDefinitionData
Visual C++
public enum class ElectricalDemandFactorDefinitionData

Members

Member name | Description
Name |
AdditionalLoad |
IncludeAdditionalLoad |
RuleType |
DefinitionValues |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorRule Enumeration

[image]

Revit 2013 API
ElectricalDemandFactorRule Enumeration
See Also Send Feedback
This enum describes the different demand factor rule types available to the application. Within a demand factor a rule will be referenced and the user will have to enter values corresponding to that rule.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalDemandFactorRule
Visual Basic
Public Enumeration ElectricalDemandFactorRule
Visual C++
public enum class ElectricalDemandFactorRule

Members

Member name | Description
Constant | This rule will apply a constant demand factor to the loads, regardless of values. It will also be the default for any newly created demand factor, and the default used if a demand factor cannot be found for a load classification.
QuantityTable | This rule will apply the demand factor for the total quantity of attached objects to a panel. It is purely a look-up table. For example, the user can specify that 0 to 2 objects get 100% and 2 to 4 objects get 85% and so on.
LoadTable | This rule will apply the demand factor for the total load of attached objects to a panel. It is purely a look-up table. For example, if there are 5000 kVA, the user can specify 125% value is applied. If there are 20,000 kVA, the user can specify 100% value is applied.
QuantityTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the first two (largest) items will have a 125% demand factor applied and the remaining items will have a 75% factor applied.
LoadTablePerPortion | This rule will apply the demand factor differently for each row in the table. For example, the 3000kVA will have a 100% demand factor applied, the next 9000 will have a 35% factor applied, and the remaining items will have a 25% factor applied.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Class

[image]

Revit 2013 API
ElectricalDemandFactorValue Class
Members See Also Send Feedback
This class represents values used by a particular demand factor definition. Each instance corresponds to a row in a table of values. These values are part of the ElectricalDemandFactorDefinition class.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElectricalDemandFactorValue : IDisposable
Visual Basic
Public Class ElectricalDemandFactorValue _
    Implements IDisposable
Visual C++
public ref class ElectricalDemandFactorValue : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Electrical..::..ElectricalDemandFactorValue

See Also

ElectricalDemandFactorValue Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Members

[image] [image]

Revit 2013 API
ElectricalDemandFactorValue Members
ElectricalDemandFactorValue Class Constructors Methods Properties See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Constructors

 | Name | Description
Public method | ElectricalDemandFactorValue()()()() | Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0
Public method | ElectricalDemandFactorValue(Double, Double, Double) | Constructor. Initializes factor, minimum range and maximum range to values passed in.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ElectricalDemandFactorValue
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetMaxRangeToUnlimited | Sets the max range on the value to unlimited
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Factor | The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.
Public property | MaxRange | The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.
Public property | MinRange | The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor

[image] [image]

Revit 2013 API
ElectricalDemandFactorValue Constructor
ElectricalDemandFactorValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ElectricalDemandFactorValue()()()() | Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0
Public method | ElectricalDemandFactorValue(Double, Double, Double) | Constructor. Initializes factor, minimum range and maximum range to values passed in.

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor

[image]

Revit 2013 API
ElectricalDemandFactorValue Constructor
ElectricalDemandFactorValue Class See Also Send Feedback
Default constructor. Initializes factor to 1.0 or 100%. Min and max range are set to 0.0

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorValue()
Visual Basic
Public Sub New
Visual C++
public:
ElectricalDemandFactorValue()

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Overload
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Constructor (Double, Double, Double)

[image]

Revit 2013 API
ElectricalDemandFactorValue Constructor (Double, Double, Double)
ElectricalDemandFactorValue Class See Also Send Feedback
Constructor. Initializes factor, minimum range and maximum range to values passed in.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElectricalDemandFactorValue(
    double minRange,
    double maxRange,
    double factor
)
Visual Basic
Public Sub New ( _
    minRange As Double, _
    maxRange As Double, _
    factor As Double _
)
Visual C++
public:
ElectricalDemandFactorValue(
    double minRange,
    double maxRange,
    double factor
)

Parameters

minRange
Type: System..::..Double
maxRange
Type: System..::..Double
factor
Type: System..::..Double

See Also

ElectricalDemandFactorValue Class
ElectricalDemandFactorValue Overload
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Methods

[image] [image]

Revit 2013 API
ElectricalDemandFactorValue Methods
ElectricalDemandFactorValue Class See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetMaxRangeToUnlimited | Sets the max range on the value to unlimited
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


Dispose Method

[image]

Revit 2013 API
ElectricalDemandFactorValue..::..Dispose Method
ElectricalDemandFactorValue Class See Also Send Feedback
Releases all resources used by the ElectricalDemandFactorValue

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


SetMaxRangeToUnlimited Method

[image]

Revit 2013 API
ElectricalDemandFactorValue..::..SetMaxRangeToUnlimited Method
ElectricalDemandFactorValue Class See Also Send Feedback
Sets the max range on the value to unlimited

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetMaxRangeToUnlimited()
Visual Basic
Public Sub SetMaxRangeToUnlimited
Visual C++
public:
void SetMaxRangeToUnlimited()

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalDemandFactorValue Properties

[image] [image]

Revit 2013 API
ElectricalDemandFactorValue Properties
ElectricalDemandFactorValue Class See Also Send Feedback

The ElectricalDemandFactorValue type exposes the following members.

Properties

 | Name | Description
Public property | Factor | The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.
Public property | MaxRange | The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.
Public property | MinRange | The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


Factor Property

[image]

Revit 2013 API
ElectricalDemandFactorValue..::..Factor Property
ElectricalDemandFactorValue Class See Also Send Feedback
The demand factor for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the demand factor will be 1.0.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Factor { get; set; }
Visual Basic
Public Property Factor As Double
    Get
    Set
Visual C++
public:
property double Factor {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


MaxRange Property

[image]

Revit 2013 API
ElectricalDemandFactorValue..::..MaxRange Property
ElectricalDemandFactorValue Class See Also Send Feedback
The maximum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the maximum range will be 3.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double MaxRange { get; set; }
Visual Basic
Public Property MaxRange As Double
    Get
    Set
Visual C++
public:
property double MaxRange {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


MinRange Property

[image]

Revit 2013 API
ElectricalDemandFactorValue..::..MinRange Property
ElectricalDemandFactorValue Class See Also Send Feedback
The minimum range for this demand factor value. For example, objects 1 to 3 can have 100% demand factor. In the example above, the minimum range will be 1.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double MinRange { get; set; }
Visual Basic
Public Property MinRange As Double
    Get
    Set
Visual C++
public:
property double MinRange {
    double get ();
    void set (double value);
}

See Also

ElectricalDemandFactorValue Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Class

[image]

Revit 2013 API
ElectricalEquipment Class
Members See Also Send Feedback
Provides access to the Electrical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElectricalEquipment : MEPModel
Visual Basic
Public Class ElectricalEquipment _
    Inherits MEPModel
Visual C++
public ref class ElectricalEquipment : public MEPModel

Remarks

The Electrical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Electrical..::..ElectricalEquipment

See Also

ElectricalEquipment Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Members

[image] [image]

Revit 2013 API
ElectricalEquipment Members
ElectricalEquipment Class Methods Properties See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Methods

[image] [image]

Revit 2013 API
ElectricalEquipment Methods
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalEquipment Properties

[image] [image]

Revit 2013 API
ElectricalEquipment Properties
ElectricalEquipment Class See Also Send Feedback

The ElectricalEquipment type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | DistributionSystem | get or set the Distribution System for the Electrical Equipment.
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSystem Property

[image]

Revit 2013 API
ElectricalEquipment..::..DistributionSystem Property
ElectricalEquipment Class See Also Send Feedback
get or set the Distribution System for the Electrical Equipment.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DistributionSysType DistributionSystem { get; set; }
Visual Basic
Public Property DistributionSystem As DistributionSysType
    Get
    Set
Visual C++
public:
property DistributionSysType^ DistributionSystem {
    DistributionSysType^ get ();
    void set (DistributionSysType^ value);
}

Remarks

This property returns a Distribution System which is assigned to the Electrical Equipment. If there are no Distribution System assigned to this Electrical Equipment, this property will be nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ElectricalEquipment Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Class

[image]

Revit 2013 API
ElectricalLoadClassification Class
Members See Also Send Feedback
The ElectricalLoadClassification class represents a serialized version of an instance of load classification.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ElectricalLoadClassification : Element
Visual Basic
Public Class ElectricalLoadClassification _
    Inherits Element
Visual C++
public ref class ElectricalLoadClassification : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..ElectricalLoadClassification

See Also

ElectricalLoadClassification Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Members

[image] [image]

Revit 2013 API
ElectricalLoadClassification Members
ElectricalLoadClassification Class Methods Properties See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of load classification and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemandFactorId | The demand factor definition this load classification element uses.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Motor | Indicates if this load classification is to be used for motors.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpaceLoadClass |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Methods

[image] [image]

Revit 2013 API
ElectricalLoadClassification Methods
ElectricalLoadClassification Class See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of load classification and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
ElectricalLoadClassification..::..Create Method
ElectricalLoadClassification Class See Also Send Feedback
Creates a new instance of load classification and adds it to the document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static ElectricalLoadClassification Create(
    Document ADoc,
    string strName
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    strName As String _
) As ElectricalLoadClassification
Visual C++
public:
static ElectricalLoadClassification^ Create(
    Document^ ADoc,
    String^ strName
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
strName
Type: System..::..String
The name of the electrical load classification to be created.

Return Value

The newly created load classification element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassification Properties

[image] [image]

Revit 2013 API
ElectricalLoadClassification Properties
ElectricalLoadClassification Class See Also Send Feedback

The ElectricalLoadClassification type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemandFactorId | The demand factor definition this load classification element uses.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Motor | Indicates if this load classification is to be used for motors.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SpaceLoadClass |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


DemandFactorId Property

[image]

Revit 2013 API
ElectricalLoadClassification..::..DemandFactorId Property
ElectricalLoadClassification Class See Also Send Feedback
The demand factor definition this load classification element uses.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId DemandFactorId { get; set; }
Visual Basic
Public Property DemandFactorId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DemandFactorId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Motor Property

[image]

Revit 2013 API
ElectricalLoadClassification..::..Motor Property
ElectricalLoadClassification Class See Also Send Feedback
Indicates if this load classification is to be used for motors.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Motor { get; }
Visual Basic
Public ReadOnly Property Motor As Boolean
    Get
Visual C++
public:
property bool Motor {
    bool get ();
}

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ElectricalLoadClassification..::..Parameter Property
ElectricalLoadClassification Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElectricalLoadClassification Class
ElectricalLoadClassification Members
Autodesk.Revit.DB.Electrical Namespace


SpaceLoadClass Property

[image]

Revit 2013 API
ElectricalLoadClassification..::..SpaceLoadClass Property
ElectricalLoadClassification Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElectricalLoadClassificationSpace SpaceLoadClass { get; set; }
Visual Basic
Public Property SpaceLoadClass As ElectricalLoadClassificationSpace
    Get
    Set
Visual C++
public:
property ElectricalLoadClassificationSpace SpaceLoadClass {
    ElectricalLoadClassificationSpace get ();
    void set (ElectricalLoadClassificationSpace value);
}

See Also

ElectricalLoadClassification Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassificationData Enumeration

[image]

Revit 2013 API
ElectricalLoadClassificationData Enumeration
See Also Send Feedback
This enum is used by the ElectricalLoadClassification class as additional data whenever data members changed. It is used as the additional data when the atom corresponding to each data member is touched.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalLoadClassificationData
Visual Basic
Public Enumeration ElectricalLoadClassificationData
Visual C++
public enum class ElectricalLoadClassificationData

Members

Member name | Description
Name |
SpaceLoadClass |
DemandFactor |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalLoadClassificationSpace Enumeration

[image]

Revit 2013 API
ElectricalLoadClassificationSpace Enumeration
See Also Send Feedback
This enum is used by the ElectricalLoadClassification to specify the load class for use with spaces.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum ElectricalLoadClassificationSpace
Visual Basic
Public Enumeration ElectricalLoadClassificationSpace
Visual C++
public enum class ElectricalLoadClassificationSpace

Members

Member name | Description
None |
Lighting |
Power |

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalPhase Enumeration

[image]

Revit 2013 API
ElectricalPhase Enumeration
See Also Send Feedback
An enumerated type to specify whether the electrical system is single phase or three phase.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ElectricalPhase
Visual Basic
Public Enumeration ElectricalPhase
Visual C++
public enum class ElectricalPhase

Members

Member name | Description
SinglePhase | Electrical phase is single phase.
ThreePhase | Electrical phase is three phase.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalPhaseConfiguration Enumeration

[image]

Revit 2013 API
ElectricalPhaseConfiguration Enumeration
See Also Send Feedback
An enumerated type to specify the electrical phase configuration.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ElectricalPhaseConfiguration
Visual Basic
Public Enumeration ElectricalPhaseConfiguration
Visual C++
public enum class ElectricalPhaseConfiguration

Members

Member name | Description
Undefined | Electrical phase configuration is undefined.
Wye | Electrical phase configuration is Y.
Delta | Electrical phase configuration is delta.

See Also

Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Class

[image]

Revit 2013 API
ElectricalSetting Class
Members See Also Send Feedback
An object that represents electrical information within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElectricalSetting : APIObject
Visual Basic
Public Class ElectricalSetting _
    Inherits APIObject
Visual C++
public ref class ElectricalSetting : public APIObject

Remarks

ElectricalSetting includes voltage type, distribution system type, wire type, and demand factor setting. All basic operations of these electrical elements are supported.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..ElectricalSetting

See Also

ElectricalSetting Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Members

[image] [image]

Revit 2013 API
ElectricalSetting Members
ElectricalSetting Class Methods Properties See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireConduitTypes | Get electrical conduit types information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Methods

[image] [image]

Revit 2013 API
ElectricalSetting Methods
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Methods

 | Name | Description
Public method | AddDistributionSysType | Add a new distribution system type to project.
Public method | AddVoltageType | Add a new type definition of voltage into project.
Public method | AddWireMaterialType | Add a new type of wire material.
Public method | AddWireType | Add a new wire type to project.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveDistributionSysType | Remove an existing distribution system type from the project.
Public method | RemoveVoltageType | Remove the voltage type from project.
Public method | RemoveWireMaterialType | Remove the wire material type from project.
Public method | RemoveWireType | Remove wire type definition from project.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddDistributionSysType Method

[image]

Revit 2013 API
ElectricalSetting..::..AddDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Add a new distribution system type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DistributionSysType AddDistributionSysType(
    string name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType volLineToLine,
    VoltageType volLineToGround
)
Visual Basic
Public Function AddDistributionSysType ( _
    name As String, _
    phase As ElectricalPhase, _
    phaseConfig As ElectricalPhaseConfiguration, _
    numWire As Integer, _
    volLineToLine As VoltageType, _
    volLineToGround As VoltageType _
) As DistributionSysType
Visual C++
public:
DistributionSysType^ AddDistributionSysType(
    String^ name,
    ElectricalPhase phase,
    ElectricalPhaseConfiguration phaseConfig,
    int numWire,
    VoltageType^ volLineToLine,
    VoltageType^ volLineToGround
)

Parameters

name
Type: System..::..String
The name of new added distribution system type
phase
Type: Autodesk.Revit.DB.Electrical..::..ElectricalPhase
Single or three phase this type is
phaseConfig
Type: Autodesk.Revit.DB.Electrical..::..ElectricalPhaseConfiguration
Configuration property of given phase
numWire
Type: System..::..Int32
Wire number of this distribution system
volLineToLine
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
Type of line to line voltage in this system
volLineToGround
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
Type of line to ground voltage in this system

Return Value

New added distribution system type object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name can't be nullNothingnullptra null reference (Nothing in Visual Basic), empty string, or equal with any existing one, phaseConfig should be defined and numWire can only be 3 or 4 in case of three phase, numWire can only be 2 or 3 in case of single phase, otherwise exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddVoltageType Method

[image]

Revit 2013 API
ElectricalSetting..::..AddVoltageType Method
ElectricalSetting Class See Also Send Feedback
Add a new type definition of voltage into project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageType AddVoltageType(
    string name,
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic
Public Function AddVoltageType ( _
    name As String, _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
) As VoltageType
Visual C++
public:
VoltageType^ AddVoltageType(
    String^ name,
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

name
Type: System..::..String
Specify voltage type name
actualValue
Type: System..::..Double
Specify actual value of voltage type.
minValue
Type: System..::..Double
Specify acceptable minimum value of the voltage type.
maxValue
Type: System..::..Double
Specify acceptable maximum value of the voltage type.

Return Value

New added voltage type object.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddWireMaterialType Method

[image]

Revit 2013 API
ElectricalSetting..::..AddWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Add a new type of wire material.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialType AddWireMaterialType(
    string name,
    WireMaterialType baseMaterial
)
Visual Basic
Public Function AddWireMaterialType ( _
    name As String, _
    baseMaterial As WireMaterialType _
) As WireMaterialType
Visual C++
public:
WireMaterialType^ AddWireMaterialType(
    String^ name,
    WireMaterialType^ baseMaterial
)

Parameters

name
Type: System..::..String
Name of new material type.
baseMaterial
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType
Specify an existing material type which New material will be constructed based on.

Return Value

New added wire material type object.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


AddWireType Method

[image]

Revit 2013 API
ElectricalSetting..::..AddWireType Method
ElectricalSetting Class See Also Send Feedback
Add a new wire type to project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireType AddWireType(
    string name,
    WireMaterialType materialType,
    TemperatureRatingType temperatureRating,
    InsulationType insulation,
    WireSize maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    NeutralMode neutralMode,
    WireConduitType conduit
)
Visual Basic
Public Function AddWireType ( _
    name As String, _
    materialType As WireMaterialType, _
    temperatureRating As TemperatureRatingType, _
    insulation As InsulationType, _
    maxSize As WireSize, _
    neutralMultiplier As Double, _
    neutralRequired As Boolean, _
    neutralMode As NeutralMode, _
    conduit As WireConduitType _
) As WireType
Visual C++
public:
WireType^ AddWireType(
    String^ name,
    WireMaterialType^ materialType,
    TemperatureRatingType^ temperatureRating,
    InsulationType^ insulation,
    WireSize^ maxSize,
    double neutralMultiplier,
    bool neutralRequired,
    NeutralMode neutralMode,
    WireConduitType^ conduit
)

Parameters

name
Type: System..::..String
Name of the new wire type.
materialType
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType
Wire material of new wire type.
temperatureRating
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType
Temperature rating type information of new wire type.
insulation
Type: Autodesk.Revit.DB.Electrical..::..InsulationType
Insulation of new wire type.
maxSize
Type: Autodesk.Revit.DB.Electrical..::..WireSize
Max wire size of new wire type.
neutralMultiplier
Type: System..::..Double
Neutral multiplier of new wire type.
neutralRequired
Type: System..::..Boolean
Specify whether neutral point is required.
neutralMode
Type: Autodesk.Revit.DB.Electrical..::..NeutralMode
Specify neutral mode.
conduit
Type: Autodesk.Revit.DB.Electrical..::..WireConduitType
Conduit type of new wire type.

Return Value

New added wire type object.

Remarks

Parameter of temperatureRating should be retrieved from parameter of materialType, and parameters such as insulation and maxSize should be retrieved from temperatureRating. otherwise, this add operation is most likely to fail.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveDistributionSysType Method

[image]

Revit 2013 API
ElectricalSetting..::..RemoveDistributionSysType Method
ElectricalSetting Class See Also Send Feedback
Remove an existing distribution system type from the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveDistributionSysType(
    DistributionSysType distributionSysType
)
Visual Basic
Public Sub RemoveDistributionSysType ( _
    distributionSysType As DistributionSysType _
)
Visual C++
public:
void RemoveDistributionSysType(
    DistributionSysType^ distributionSysType
)

Parameters

distributionSysType
Type: Autodesk.Revit.DB.Electrical..::..DistributionSysType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Distribution system type can be removed only if it is not currently assigned to any devices, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveVoltageType Method

[image]

Revit 2013 API
ElectricalSetting..::..RemoveVoltageType Method
ElectricalSetting Class See Also Send Feedback
Remove the voltage type from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveVoltageType(
    VoltageType voltageType
)
Visual Basic
Public Sub RemoveVoltageType ( _
    voltageType As VoltageType _
)
Visual C++
public:
void RemoveVoltageType(
    VoltageType^ voltageType
)

Parameters

voltageType
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
Specify the voltage type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Voltage type can be removed only if it isn't in service with any distribution systems.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireMaterialType Method

[image]

Revit 2013 API
ElectricalSetting..::..RemoveWireMaterialType Method
ElectricalSetting Class See Also Send Feedback
Remove the wire material type from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveWireMaterialType(
    WireMaterialType materialType
)
Visual Basic
Public Sub RemoveWireMaterialType ( _
    materialType As WireMaterialType _
)
Visual C++
public:
void RemoveWireMaterialType(
    WireMaterialType^ materialType
)

Parameters

materialType
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType
The wire material type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Wire material type can be removed only if it is not currently assigned to any wire type, and the last one wire material type can't be removed, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireType Method

[image]

Revit 2013 API
ElectricalSetting..::..RemoveWireType Method
ElectricalSetting Class See Also Send Feedback
Remove wire type definition from project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveWireType(
    WireType wireType
)
Visual Basic
Public Sub RemoveWireType ( _
    wireType As WireType _
)
Visual C++
public:
void RemoveWireType(
    WireType^ wireType
)

Parameters

wireType
Type: Autodesk.Revit.DB.Electrical..::..WireType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Wire type can be removed only if it is not used, otherwise an exception will be thrown.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSetting Properties

[image] [image]

Revit 2013 API
ElectricalSetting Properties
ElectricalSetting Class See Also Send Feedback

The ElectricalSetting type exposes the following members.

Properties

 | Name | Description
Public property | DistributionSysTypes | Get all distribution system types of the project.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | VoltageTypes | Get all voltage type definitions information of the project.
Public property | WireConduitTypes | Get electrical conduit types information of the project.
Public property | WireMaterialTypes | Get electrical wire material types information of the project.
Public property | WireTypes | Get all wire type definition information of the project.

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


DistributionSysTypes Property

[image]

Revit 2013 API
ElectricalSetting..::..DistributionSysTypes Property
ElectricalSetting Class See Also Send Feedback
Get all distribution system types of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DistributionSysTypeSet DistributionSysTypes { get; }
Visual Basic
Public ReadOnly Property DistributionSysTypes As DistributionSysTypeSet
    Get
Visual C++
public:
property DistributionSysTypeSet^ DistributionSysTypes {
    DistributionSysTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypes Property

[image]

Revit 2013 API
ElectricalSetting..::..VoltageTypes Property
ElectricalSetting Class See Also Send Feedback
Get all voltage type definitions information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageTypeSet VoltageTypes { get; }
Visual Basic
Public ReadOnly Property VoltageTypes As VoltageTypeSet
    Get
Visual C++
public:
property VoltageTypeSet^ VoltageTypes {
    VoltageTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypes Property

[image]

Revit 2013 API
ElectricalSetting..::..WireConduitTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical conduit types information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireConduitTypeSet WireConduitTypes { get; }
Visual Basic
Public ReadOnly Property WireConduitTypes As WireConduitTypeSet
    Get
Visual C++
public:
property WireConduitTypeSet^ WireConduitTypes {
    WireConduitTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypes Property

[image]

Revit 2013 API
ElectricalSetting..::..WireMaterialTypes Property
ElectricalSetting Class See Also Send Feedback
Get electrical wire material types information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialTypeSet WireMaterialTypes { get; }
Visual Basic
Public ReadOnly Property WireMaterialTypes As WireMaterialTypeSet
    Get
Visual C++
public:
property WireMaterialTypeSet^ WireMaterialTypes {
    WireMaterialTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


WireTypes Property

[image]

Revit 2013 API
ElectricalSetting..::..WireTypes Property
ElectricalSetting Class See Also Send Feedback
Get all wire type definition information of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireTypeSet WireTypes { get; }
Visual Basic
Public ReadOnly Property WireTypes As WireTypeSet
    Get
Visual C++
public:
property WireTypeSet^ WireTypes {
    WireTypeSet^ get ();
}

See Also

ElectricalSetting Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Class

[image]

Revit 2013 API
ElectricalSystem Class
Members See Also Send Feedback
Provides access to the Electrical System in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElectricalSystem : MEPSystem
Visual Basic
Public Class ElectricalSystem _
    Inherits MEPSystem
Visual C++
public ref class ElectricalSystem : public MEPSystem

Remarks

The Electrical System object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Electrical..::..ElectricalSystem

See Also

ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Members

[image] [image]

Revit 2013 API
ElectricalSystem Members
ElectricalSystem Class Methods Properties See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | CircuitType | Get the circuit type of the Electrical System.
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | Length | Returns the Length value of the Electrical System.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadClassifications | Returns the LoadClassifications used in the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns the Name of the Electrical System. (Overrides Element..::..Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Methods

[image] [image]

Revit 2013 API
ElectricalSystem Methods
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | AddToCircuit | Add a set of exist components to the Electrical System.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisconnectPanel | Disconnect the panel for the Electrical System.
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | NewWires | Create a bunch of wires for the electrical system.
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | RemoveFromCircuit | remove a set of exist components from the Electrical System.
Public method | SelectPanel | Set the panel for the Electrical System.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


AddToCircuit Method

[image]

Revit 2013 API
ElectricalSystem..::..AddToCircuit Method
ElectricalSystem Class See Also Send Feedback
Add a set of exist components to the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AddToCircuit(
    ElementSet components
)
Visual Basic
Public Function AddToCircuit ( _
    components As ElementSet _
) As Boolean
Visual C++
public:
bool AddToCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit.DB..::..ElementSet
The components added to the electrical system.

Return Value

If successful, all the components will add to the system. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Remarks

This method will only function with the Autodesk Revit MEP application.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


DisconnectPanel Method

[image]

Revit 2013 API
ElectricalSystem..::..DisconnectPanel Method
ElectricalSystem Class See Also Send Feedback
Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DisconnectPanel()
Visual Basic
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the panel parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the panel cannot be disconnected for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


NewWires Method

[image]

Revit 2013 API
ElectricalSystem..::..NewWires Method
ElectricalSystem Class See Also Send Feedback
Create a bunch of wires for the electrical system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSet NewWires(
    View view,
    WiringType wiringType
)
Visual Basic
Public Function NewWires ( _
    view As View, _
    wiringType As WiringType _
) As WireSet
Visual C++
public:
WireSet^ NewWires(
    View^ view,
    WiringType wiringType
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view in which the wire is to be visible.
wiringType
Type: Autodesk.Revit.DB.Electrical..::..WiringType
Specify the wiring type (Arc or Chamfer) that is to be applied to all newly created wires.

Return Value

New created wires

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This method can only be used to create a bunch of wires according to specific pairs of elements, so if there exists a nullNothingnullptra null reference (Nothing in Visual Basic) element in any pair of familyInstancePairs, the exception will be thrown.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Remove Method

[image] [image]

Revit 2013 API
ElectricalSystem..::..Remove Method
ElectricalSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)

See Also

ElectricalSystem Class
ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace


RemoveFromCircuit Method

[image]

Revit 2013 API
ElectricalSystem..::..RemoveFromCircuit Method
ElectricalSystem Class See Also Send Feedback
remove a set of exist components from the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveFromCircuit(
    ElementSet components
)
Visual Basic
Public Sub RemoveFromCircuit ( _
    components As ElementSet _
)
Visual C++
public:
void RemoveFromCircuit(
    ElementSet^ components
)

Parameters

components
Type: Autodesk.Revit.DB..::..ElementSet
The components removed from the electrical system.

Remarks

If successful, all the components will remove from the system. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic) is removed. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the components parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the components cannot be removed from the system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


SelectPanel Method

[image]

Revit 2013 API
ElectricalSystem..::..SelectPanel Method
ElectricalSystem Class See Also Send Feedback
Set the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SelectPanel(
    FamilyInstance panel
)
Visual Basic
Public Sub SelectPanel ( _
    panel As FamilyInstance _
)
Visual C++
public:
void SelectPanel(
    FamilyInstance^ panel
)

Parameters

panel
Type: Autodesk.Revit.DB..::..FamilyInstance
The panel of the electrical system.

Remarks

If successful, the panel will be set for the system. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the panel parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the panel cannot be set for the electrical system.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystem Properties

[image] [image]

Revit 2013 API
ElectricalSystem Properties
ElectricalSystem Class See Also Send Feedback

The ElectricalSystem type exposes the following members.

Properties

 | Name | Description
Public property | ApparentCurrent | Returns the ApparentCurrent value of the Electrical System.
Public property | ApparentCurrentPhaseA | Returns the ApparentCurrentPhaseA value of the Electrical System.
Public property | ApparentCurrentPhaseB | Returns the ApparentCurrentPhaseB value of the Electrical System.
Public property | ApparentCurrentPhaseC | Returns the ApparentCurrentPhaseC value of the Electrical System.
Public property | ApparentLoad | Returns the ApparentLoad value of the Electrical System.
Public property | ApparentLoadPhaseA | Returns the ApparentLoadPhaseA value of the Electrical System.
Public property | ApparentLoadPhaseB | Returns the ApparentLoadPhaseB value of the Electrical System.
Public property | ApparentLoadPhaseC | Returns the ApparentLoadPhaseC value of the Electrical System.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BalancedLoad | Reports whether the BalancedLoad is on or off.
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system. (Inherited from MEPSystem.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CircuitNumber | Returns the CircuitNumber of the Electrical System.
Public property | CircuitType | Get the circuit type of the Electrical System.
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorsNumber | Returns the GroundConductors Number of the Electrical System.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HotConductorsNumber | Returns the HotConductors Number of the Electrical System.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | Length | Returns the Length value of the Electrical System.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadClassifications | Returns the LoadClassifications used in the Electrical System.
Public property | LoadName | Get/Set the LoadName of the Electrical System.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns the Name of the Electrical System. (Overrides Element..::..Name.)
Public property | NeutralConductorsNumber | Returns the NeutralConductors Number of the Electrical System.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | PanelName | Returns the Panel name of the Electrical System.
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PolesNumber | Returns the Poles Number of the Electrical System.
Public property | PowerFactor | Returns the PowerFactor value of the Electrical System.
Public property | PowerFactorState | Returns the PowerFactorState type of the Electrical System.
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | Rating | Get/Set the Rating value of the Electrical System.
Public property | RunsNumber | Returns the Runs Number of the Electrical System.
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | SystemType | Returns the Electrical System Type of the Electrical System.
Public property | TrueCurrent | Returns the TrueCurrent value of the Electrical System.
Public property | TrueCurrentPhaseA | Returns the TrueCurrentPhaseA value of the Electrical System.
Public property | TrueCurrentPhaseB | Returns the TrueCurrentPhaseB value of the Electrical System.
Public property | TrueCurrentPhaseC | Returns the TrueCurrentPhaseC value of the Electrical System.
Public property | TrueLoad | Returns the TrueLoad value of the Electrical System.
Public property | TrueLoadPhaseA | Returns the TrueLoadPhaseA value of the Electrical System.
Public property | TrueLoadPhaseB | Returns the TrueLoadPhaseB value of the Electrical System.
Public property | TrueLoadPhaseC | Returns the TrueLoadPhaseC value of the Electrical System.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Voltage | Returns the Voltage value of the Electrical System.
Public property | VoltageDrop | Returns the VoltageDrop value of the Electrical System.
Public property | WireSizeString | Returns the WireSize as a String of the Electrical System.
Public property | WireType | Get/Set the wire type of the Electrical System.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrent Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrent value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentCurrent { get; }
Visual Basic
Public ReadOnly Property ApparentCurrent As Double
    Get
Visual C++
public:
property double ApparentCurrent {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseA Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentCurrentPhaseA { get; }
Visual Basic
Public ReadOnly Property ApparentCurrentPhaseA As Double
    Get
Visual C++
public:
property double ApparentCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseB Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentCurrentPhaseB { get; }
Visual Basic
Public ReadOnly Property ApparentCurrentPhaseB As Double
    Get
Visual C++
public:
property double ApparentCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentCurrentPhaseC Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentCurrentPhaseC { get; }
Visual Basic
Public ReadOnly Property ApparentCurrentPhaseC As Double
    Get
Visual C++
public:
property double ApparentCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoad Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoad value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentLoad { get; }
Visual Basic
Public ReadOnly Property ApparentLoad As Double
    Get
Visual C++
public:
property double ApparentLoad {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseA Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentLoadPhaseA { get; }
Visual Basic
Public ReadOnly Property ApparentLoadPhaseA As Double
    Get
Visual C++
public:
property double ApparentLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseB Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentLoadPhaseB { get; }
Visual Basic
Public ReadOnly Property ApparentLoadPhaseB As Double
    Get
Visual C++
public:
property double ApparentLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ApparentLoadPhaseC Property

[image]

Revit 2013 API
ElectricalSystem..::..ApparentLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the ApparentLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ApparentLoadPhaseC { get; }
Visual Basic
Public ReadOnly Property ApparentLoadPhaseC As Double
    Get
Visual C++
public:
property double ApparentLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the ApparentLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


BalancedLoad Property

[image]

Revit 2013 API
ElectricalSystem..::..BalancedLoad Property
ElectricalSystem Class See Also Send Feedback
Reports whether the BalancedLoad is on or off.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool BalancedLoad { get; }
Visual Basic
Public ReadOnly Property BalancedLoad As Boolean
    Get
Visual C++
public:
property bool BalancedLoad {
    bool get ();
}

Remarks

This property is used to retrieve the BalancedLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


CircuitNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..CircuitNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the CircuitNumber of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string CircuitNumber { get; }
Visual Basic
Public ReadOnly Property CircuitNumber As String
    Get
Visual C++
public:
property String^ CircuitNumber {
    String^ get ();
}

Remarks

This property is used to retrieve the CircuitNumber of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


CircuitType Property

[image]

Revit 2013 API
ElectricalSystem..::..CircuitType Property
ElectricalSystem Class See Also Send Feedback
Get the circuit type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CircuitType CircuitType { get; }
Visual Basic
Public ReadOnly Property CircuitType As CircuitType
    Get
Visual C++
public:
property CircuitType CircuitType {
    CircuitType get ();
}

Remarks

This read-only property is used to retrieve the circuit type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorsNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..GroundConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the GroundConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GroundConductorsNumber { get; }
Visual Basic
Public ReadOnly Property GroundConductorsNumber As Integer
    Get
Visual C++
public:
property int GroundConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the GroundConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


HotConductorsNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..HotConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the HotConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int HotConductorsNumber { get; }
Visual Basic
Public ReadOnly Property HotConductorsNumber As Integer
    Get
Visual C++
public:
property int HotConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the HotConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Length Property

[image]

Revit 2013 API
ElectricalSystem..::..Length Property
ElectricalSystem Class See Also Send Feedback
Returns the Length value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

Remarks

This property is used to retrieve the Length value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the length cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


LoadClassifications Property

[image]

Revit 2013 API
ElectricalSystem..::..LoadClassifications Property
ElectricalSystem Class See Also Send Feedback
Returns the LoadClassifications used in the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LoadClassifications { get; }
Visual Basic
Public ReadOnly Property LoadClassifications As String
    Get
Visual C++
public:
property String^ LoadClassifications {
    String^ get ();
}

Remarks

This property is used to retrieve the LoadClassifications of the Electrical System. There may be one or more load classification in use in which case they will be semi-colon delimited.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


LoadName Property

[image]

Revit 2013 API
ElectricalSystem..::..LoadName Property
ElectricalSystem Class See Also Send Feedback
Get/Set the LoadName of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LoadName { get; set; }
Visual Basic
Public Property LoadName As String
    Get
    Set
Visual C++
public:
property String^ LoadName {
    String^ get ();
    void set (String^ value);
}

Remarks

This property is used to retrieve the LoadName of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2013 API
ElectricalSystem..::..Name Property
ElectricalSystem Class See Also Send Feedback
Returns the Name of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { get; }
Visual Basic
Public Overrides ReadOnly Property Name As String
    Get
Visual C++
public:
virtual property String^ Name {
    String^ get () override;
}

Remarks

This property is used to get or set the Name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


NeutralConductorsNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..NeutralConductorsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the NeutralConductors Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NeutralConductorsNumber { get; }
Visual Basic
Public ReadOnly Property NeutralConductorsNumber As Integer
    Get
Visual C++
public:
property int NeutralConductorsNumber {
    int get ();
}

Remarks

This property is used to retrieve the NeutralConductors Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PanelName Property

[image]

Revit 2013 API
ElectricalSystem..::..PanelName Property
ElectricalSystem Class See Also Send Feedback
Returns the Panel name of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string PanelName { get; }
Visual Basic
Public ReadOnly Property PanelName As String
    Get
Visual C++
public:
property String^ PanelName {
    String^ get ();
}

Remarks

This property is used to retrieve the Panel name of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
ElectricalSystem..::..Parameter Property
ElectricalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

ElectricalSystem Class
ElectricalSystem Members
Autodesk.Revit.DB.Electrical Namespace


PolesNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..PolesNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Poles Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int PolesNumber { get; }
Visual Basic
Public ReadOnly Property PolesNumber As Integer
    Get
Visual C++
public:
property int PolesNumber {
    int get ();
}

Remarks

This property is used to retrieve the Poles Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PowerFactor Property

[image]

Revit 2013 API
ElectricalSystem..::..PowerFactor Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactor value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double PowerFactor { get; }
Visual Basic
Public ReadOnly Property PowerFactor As Double
    Get
Visual C++
public:
property double PowerFactor {
    double get ();
}

Remarks

This property is used to retrieve the PowerFactor value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


PowerFactorState Property

[image]

Revit 2013 API
ElectricalSystem..::..PowerFactorState Property
ElectricalSystem Class See Also Send Feedback
Returns the PowerFactorState type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PowerFactorStateType PowerFactorState { get; }
Visual Basic
Public ReadOnly Property PowerFactorState As PowerFactorStateType
    Get
Visual C++
public:
property PowerFactorStateType PowerFactorState {
    PowerFactorStateType get ();
}

Remarks

This property is used to retrieve the PowerFactorState type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Rating Property

[image]

Revit 2013 API
ElectricalSystem..::..Rating Property
ElectricalSystem Class See Also Send Feedback
Get/Set the Rating value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Rating { get; set; }
Visual Basic
Public Property Rating As Double
    Get
    Set
Visual C++
public:
property double Rating {
    double get ();
    void set (double value);
}

Remarks

This property is used to retrieve the Rating value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


RunsNumber Property

[image]

Revit 2013 API
ElectricalSystem..::..RunsNumber Property
ElectricalSystem Class See Also Send Feedback
Returns the Runs Number of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int RunsNumber { get; }
Visual Basic
Public ReadOnly Property RunsNumber As Integer
    Get
Visual C++
public:
property int RunsNumber {
    int get ();
}

Remarks

This property is used to retrieve the Runs Number of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


SystemType Property

[image]

Revit 2013 API
ElectricalSystem..::..SystemType Property
ElectricalSystem Class See Also Send Feedback
Returns the Electrical System Type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemType SystemType { get; }
Visual Basic
Public ReadOnly Property SystemType As ElectricalSystemType
    Get
Visual C++
public:
property ElectricalSystemType SystemType {
    ElectricalSystemType get ();
}

Remarks

This property is used to retrieve the Electrical System Type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrent Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueCurrent Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrent value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueCurrent { get; }
Visual Basic
Public ReadOnly Property TrueCurrent As Double
    Get
Visual C++
public:
property double TrueCurrent {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrent value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseA Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueCurrentPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueCurrentPhaseA { get; }
Visual Basic
Public ReadOnly Property TrueCurrentPhaseA As Double
    Get
Visual C++
public:
property double TrueCurrentPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseB Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueCurrentPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueCurrentPhaseB { get; }
Visual Basic
Public ReadOnly Property TrueCurrentPhaseB As Double
    Get
Visual C++
public:
property double TrueCurrentPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueCurrentPhaseC Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueCurrentPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueCurrentPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueCurrentPhaseC { get; }
Visual Basic
Public ReadOnly Property TrueCurrentPhaseC As Double
    Get
Visual C++
public:
property double TrueCurrentPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueCurrentPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoad Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueLoad Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoad value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueLoad { get; }
Visual Basic
Public ReadOnly Property TrueLoad As Double
    Get
Visual C++
public:
property double TrueLoad {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoad value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseA Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueLoadPhaseA Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseA value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueLoadPhaseA { get; }
Visual Basic
Public ReadOnly Property TrueLoadPhaseA As Double
    Get
Visual C++
public:
property double TrueLoadPhaseA {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseA value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseB Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueLoadPhaseB Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseB value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueLoadPhaseB { get; }
Visual Basic
Public ReadOnly Property TrueLoadPhaseB As Double
    Get
Visual C++
public:
property double TrueLoadPhaseB {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseB value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


TrueLoadPhaseC Property

[image]

Revit 2013 API
ElectricalSystem..::..TrueLoadPhaseC Property
ElectricalSystem Class See Also Send Feedback
Returns the TrueLoadPhaseC value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double TrueLoadPhaseC { get; }
Visual Basic
Public ReadOnly Property TrueLoadPhaseC As Double
    Get
Visual C++
public:
property double TrueLoadPhaseC {
    double get ();
}

Remarks

This property is used to retrieve the TrueLoadPhaseC value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


Voltage Property

[image]

Revit 2013 API
ElectricalSystem..::..Voltage Property
ElectricalSystem Class See Also Send Feedback
Returns the Voltage value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Voltage { get; }
Visual Basic
Public ReadOnly Property Voltage As Double
    Get
Visual C++
public:
property double Voltage {
    double get ();
}

Remarks

This property is used to retrieve the Voltage value of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


VoltageDrop Property

[image]

Revit 2013 API
ElectricalSystem..::..VoltageDrop Property
ElectricalSystem Class See Also Send Feedback
Returns the VoltageDrop value of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double VoltageDrop { get; }
Visual Basic
Public ReadOnly Property VoltageDrop As Double
    Get
Visual C++
public:
property double VoltageDrop {
    double get ();
}

Remarks

This property is used to retrieve the VoltageDrop value of the Electrical System.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the voltage drop cannot be computed, because it is zero, or because the circuit is not connected to a panel.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeString Property

[image]

Revit 2013 API
ElectricalSystem..::..WireSizeString Property
ElectricalSystem Class See Also Send Feedback
Returns the WireSize as a String of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string WireSizeString { get; }
Visual Basic
Public ReadOnly Property WireSizeString As String
    Get
Visual C++
public:
property String^ WireSizeString {
    String^ get ();
}

Remarks

This property is used to retrieve the WireSize String of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


WireType Property

[image]

Revit 2013 API
ElectricalSystem..::..WireType Property
ElectricalSystem Class See Also Send Feedback
Get/Set the wire type of the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireType WireType { get; set; }
Visual Basic
Public Property WireType As WireType
    Get
    Set
Visual C++
public:
property WireType^ WireType {
    WireType^ get ();
    void set (WireType^ value);
}

Remarks

This property is used to retrieve the wire type of the Electrical System.

See Also

ElectricalSystem Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Class

[image]

Revit 2013 API
ElectricalSystemSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class ElectricalSystemSet : APIObject,
    IEnumerable
Visual Basic
Public Class ElectricalSystemSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ElectricalSystemSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..ElectricalSystemSet

See Also

ElectricalSystemSet Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Members

[image] [image]

Revit 2013 API
ElectricalSystemSet Members
ElectricalSystemSet Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Constructors

 | Name | Description
Public method | ElectricalSystemSet | Initializes a new instance of the ElectricalSystemSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Constructor

[image]

Revit 2013 API
ElectricalSystemSet Constructor
ElectricalSystemSet Class See Also Send Feedback
Initializes a new instance of the ElectricalSystemSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemSet()
Visual Basic
Public Sub New
Visual C++
public:
ElectricalSystemSet()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Methods

[image] [image]

Revit 2013 API
ElectricalSystemSet Methods
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
ElectricalSystemSet..::..Clear Method
ElectricalSystemSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
ElectricalSystemSet..::..Contains Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    ElectricalSystem item
)
Visual Basic
Public Overridable Function Contains ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Contains(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
ElectricalSystemSet..::..Erase Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    ElectricalSystem item
)
Visual Basic
Public Overridable Function Erase ( _
    item As ElectricalSystem _
) As Integer
Visual C++
public:
virtual int Erase(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
ElectricalSystemSet..::..ForwardIterator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
ElectricalSystemSet..::..GetEnumerator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
ElectricalSystemSet..::..Insert Method
ElectricalSystemSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    ElectricalSystem item
)
Visual Basic
Public Overridable Function Insert ( _
    item As ElectricalSystem _
) As Boolean
Visual C++
public:
virtual bool Insert(
    ElectricalSystem^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..ElectricalSystem

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
ElectricalSystemSet..::..ReverseIterator Method
ElectricalSystemSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ElectricalSystemSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ElectricalSystemSetIterator
Visual C++
public:
virtual ElectricalSystemSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSet Properties

[image] [image]

Revit 2013 API
ElectricalSystemSet Properties
ElectricalSystemSet Class See Also Send Feedback

The ElectricalSystemSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
ElectricalSystemSet..::..IsEmpty Property
ElectricalSystemSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
ElectricalSystemSet..::..Size Property
ElectricalSystemSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ElectricalSystemSet Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Class

[image]

Revit 2013 API
ElectricalSystemSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ElectricalSystemSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ElectricalSystemSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ElectricalSystemSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..ElectricalSystemSetIterator

See Also

ElectricalSystemSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Members

[image] [image]

Revit 2013 API
ElectricalSystemSetIterator Members
ElectricalSystemSetIterator Class Constructors Methods Properties See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ElectricalSystemSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Constructor

[image]

Revit 2013 API
ElectricalSystemSetIterator Constructor
ElectricalSystemSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystemSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
ElectricalSystemSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Methods

[image] [image]

Revit 2013 API
ElectricalSystemSetIterator Methods
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
ElectricalSystemSetIterator..::..MoveNext Method
ElectricalSystemSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
ElectricalSystemSetIterator..::..Reset Method
ElectricalSystemSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemSetIterator Properties

[image] [image]

Revit 2013 API
ElectricalSystemSetIterator Properties
ElectricalSystemSetIterator Class See Also Send Feedback

The ElectricalSystemSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
ElectricalSystemSetIterator..::..Current Property
ElectricalSystemSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ElectricalSystemSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


ElectricalSystemType Enumeration

[image]

Revit 2013 API
ElectricalSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible electrical system types for a connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum ElectricalSystemType
Visual Basic
Public Enumeration ElectricalSystemType
Visual C++
public enum class ElectricalSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type
Data | Electrical System Type is Data.
PowerCircuit | Electrical System Type is PowerCircuit.
Telephone | Electrical System Type is Telephone.
Security | Electrical System Type is Security
FireAlarm | Electrical System Type is FireAlarm
NurseCall | System Type is NurseCall.
Controls | Electrical System Type is Controls.
Communication | Electrical System Type is Communication.
PowerBalanced | Electrical System Type is PowerBalanced.
PowerUnBalanced | Electrical System Type is PowerUnBalanced.

See Also

Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Class

[image]

Revit 2013 API
GroundConductorSize Class
Members See Also Send Feedback
Represents electrical ground conductor size definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GroundConductorSize : APIObject
Visual Basic
Public Class GroundConductorSize _
    Inherits APIObject
Visual C++
public ref class GroundConductorSize : public APIObject

Remarks

Ground conductor size is defined based on corresponding wire material type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..GroundConductorSize

See Also

GroundConductorSize Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Members

[image] [image]

Revit 2013 API
GroundConductorSize Members
GroundConductorSize Class Methods Properties See Also Send Feedback

The GroundConductorSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
Public property | ConductorSize | Get conductor size corresponding to specific ampacity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Methods

[image] [image]

Revit 2013 API
GroundConductorSize Methods
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSize Properties

[image] [image]

Revit 2013 API
GroundConductorSize Properties
GroundConductorSize Class See Also Send Feedback

The GroundConductorSize type exposes the following members.

Properties

 | Name | Description
Public property | Ampacity | Get ampacity which is used for specifying size, the unit is ampere.
Public property | ConductorSize | Get conductor size corresponding to specific ampacity.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MaterialBelongTo | Get the material type which include this ground conductor size information.

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


Ampacity Property

[image]

Revit 2013 API
GroundConductorSize..::..Ampacity Property
GroundConductorSize Class See Also Send Feedback
Get ampacity which is used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic
Public ReadOnly Property Ampacity As Long
    Get
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


ConductorSize Property

[image]

Revit 2013 API
GroundConductorSize..::..ConductorSize Property
GroundConductorSize Class See Also Send Feedback
Get conductor size corresponding to specific ampacity.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ConductorSize { get; }
Visual Basic
Public ReadOnly Property ConductorSize As String
    Get
Visual C++
public:
property String^ ConductorSize {
    String^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


MaterialBelongTo Property

[image]

Revit 2013 API
GroundConductorSize..::..MaterialBelongTo Property
GroundConductorSize Class See Also Send Feedback
Get the material type which include this ground conductor size information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialType MaterialBelongTo { get; }
Visual Basic
Public ReadOnly Property MaterialBelongTo As WireMaterialType
    Get
Visual C++
public:
property WireMaterialType^ MaterialBelongTo {
    WireMaterialType^ get ();
}

See Also

GroundConductorSize Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Class

[image]

Revit 2013 API
GroundConductorSizeSet Class
Members See Also Send Feedback
A set that contains GroundConductorSizes.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class GroundConductorSizeSet : APIObject,
    IEnumerable
Visual Basic
Public Class GroundConductorSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class GroundConductorSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSet

See Also

GroundConductorSizeSet Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Members

[image] [image]

Revit 2013 API
GroundConductorSizeSet Members
GroundConductorSizeSet Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Constructors

 | Name | Description
Public method | GroundConductorSizeSet | Initializes a new instance of the GroundConductorSizeSet class

Methods

 | Name | Description
Public method | Clear | Removes every GroundConductorSize from the set, rendering it empty.
Public method | Contains | Tests for the existence of a GroundConductorSize within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GroundConductorSize from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified GroundConductorSize into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Constructor

[image]

Revit 2013 API
GroundConductorSizeSet Constructor
GroundConductorSizeSet Class See Also Send Feedback
Initializes a new instance of the GroundConductorSizeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroundConductorSizeSet()
Visual Basic
Public Sub New
Visual C++
public:
GroundConductorSizeSet()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Methods

[image] [image]

Revit 2013 API
GroundConductorSizeSet Methods
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every GroundConductorSize from the set, rendering it empty.
Public method | Contains | Tests for the existence of a GroundConductorSize within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified GroundConductorSize from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified GroundConductorSize into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..Clear Method
GroundConductorSizeSet Class See Also Send Feedback
Removes every GroundConductorSize from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..Contains Method
GroundConductorSizeSet Class See Also Send Feedback
Tests for the existence of a GroundConductorSize within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    GroundConductorSize item
)
Visual Basic
Public Overridable Function Contains ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..GroundConductorSize
The GroundConductorSize to be searched for.

Return Value

The Contains method returns True if the GroundConductorSize is within the set, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..Erase Method
GroundConductorSizeSet Class See Also Send Feedback
Removes a specified GroundConductorSize from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    GroundConductorSize item
)
Visual Basic
Public Overridable Function Erase ( _
    item As GroundConductorSize _
) As Integer
Visual C++
public:
virtual int Erase(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..GroundConductorSize
The GroundConductorSize to be erased.

Return Value

The number of GroundConductorSizes that were erased from the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..ForwardIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..GetEnumerator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..Insert Method
GroundConductorSizeSet Class See Also Send Feedback
Insert the specified GroundConductorSize into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    GroundConductorSize item
)
Visual Basic
Public Overridable Function Insert ( _
    item As GroundConductorSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    GroundConductorSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..GroundConductorSize
The GroundConductorSize to be inserted into the set.

Return Value

Returns whether the GroundConductorSize was inserted into the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
GroundConductorSizeSet..::..ReverseIterator Method
GroundConductorSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual GroundConductorSizeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As GroundConductorSizeSetIterator
Visual C++
public:
virtual GroundConductorSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSet Properties

[image] [image]

Revit 2013 API
GroundConductorSizeSet Properties
GroundConductorSizeSet Class See Also Send Feedback

The GroundConductorSizeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of GroundConductorSizes that are in the set.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
GroundConductorSizeSet..::..IsEmpty Property
GroundConductorSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
GroundConductorSizeSet..::..Size Property
GroundConductorSizeSet Class See Also Send Feedback
Returns the number of GroundConductorSizes that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

GroundConductorSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Class

[image]

Revit 2013 API
GroundConductorSizeSetIterator Class
Members See Also Send Feedback
An iterator to a GroundConductorSize set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class GroundConductorSizeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class GroundConductorSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class GroundConductorSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..GroundConductorSizeSetIterator

See Also

GroundConductorSizeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Members

[image] [image]

Revit 2013 API
GroundConductorSizeSetIterator Members
GroundConductorSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | GroundConductorSizeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Constructor

[image]

Revit 2013 API
GroundConductorSizeSetIterator Constructor
GroundConductorSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroundConductorSizeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
GroundConductorSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Methods

[image] [image]

Revit 2013 API
GroundConductorSizeSetIterator Methods
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
GroundConductorSizeSetIterator..::..MoveNext Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
GroundConductorSizeSetIterator..::..Reset Method
GroundConductorSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizeSetIterator Properties

[image] [image]

Revit 2013 API
GroundConductorSizeSetIterator Properties
GroundConductorSizeSetIterator Class See Also Send Feedback

The GroundConductorSizeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
GroundConductorSizeSetIterator..::..Current Property
GroundConductorSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

GroundConductorSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Class

[image]

Revit 2013 API
InsulationType Class
Members See Also Send Feedback
Represents electrical insulation type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InsulationType : ElementType
Visual Basic
Public Class InsulationType _
    Inherits ElementType
Visual C++
public ref class InsulationType : public ElementType

Remarks

Insulation type is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..InsulationType

See Also

InsulationType Members
Autodesk.Revit.DB.Electrical Namespace


InsulationType Members

[image] [image]

Revit 2013 API
InsulationType Members
InsulationType Class Methods Properties See Also Send Feedback

The InsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the insulation type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get name of Insulation type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Methods

[image] [image]

Revit 2013 API
InsulationType Methods
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationType Properties

[image] [image]

Revit 2013 API
InsulationType Properties
InsulationType Class See Also Send Feedback

The InsulationType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the insulation type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get name of Insulation type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
InsulationType..::..IsInUse Property
InsulationType Class See Also Send Feedback
Indicate whether the insulation type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2013 API
InsulationType..::..Name Property
InsulationType Class See Also Send Feedback
Get name of Insulation type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Set name can't be supported.

See Also

InsulationType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
InsulationType..::..Parameter Property
InsulationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

InsulationType Class
InsulationType Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Class

[image]

Revit 2013 API
InsulationTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class InsulationTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class InsulationTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class InsulationTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..InsulationTypeSet

See Also

InsulationTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Members

[image] [image]

Revit 2013 API
InsulationTypeSet Members
InsulationTypeSet Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | InsulationTypeSet | Initializes a new instance of the InsulationTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Constructor

[image]

Revit 2013 API
InsulationTypeSet Constructor
InsulationTypeSet Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InsulationTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
InsulationTypeSet()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Methods

[image] [image]

Revit 2013 API
InsulationTypeSet Methods
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
InsulationTypeSet..::..Clear Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
InsulationTypeSet..::..Contains Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    InsulationType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
InsulationTypeSet..::..Erase Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    InsulationType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As InsulationType _
) As Integer
Visual C++
public:
virtual int Erase(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
InsulationTypeSet..::..ForwardIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ForwardIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
InsulationTypeSet..::..GetEnumerator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
InsulationTypeSet..::..Insert Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    InsulationType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As InsulationType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    InsulationType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..InsulationType

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
InsulationTypeSet..::..ReverseIterator Method
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual InsulationTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As InsulationTypeSetIterator
Visual C++
public:
virtual InsulationTypeSetIterator^ ReverseIterator()

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSet Properties

[image] [image]

Revit 2013 API
InsulationTypeSet Properties
InsulationTypeSet Class See Also Send Feedback

The InsulationTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
InsulationTypeSet..::..IsEmpty Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
InsulationTypeSet..::..Size Property
InsulationTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

InsulationTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Class

[image]

Revit 2013 API
InsulationTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class InsulationTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class InsulationTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class InsulationTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..InsulationTypeSetIterator

See Also

InsulationTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Members

[image] [image]

Revit 2013 API
InsulationTypeSetIterator Members
InsulationTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | InsulationTypeSetIterator | Initializes a new instance of the InsulationTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Constructor

[image]

Revit 2013 API
InsulationTypeSetIterator Constructor
InsulationTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the InsulationTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InsulationTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
InsulationTypeSetIterator()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Methods

[image] [image]

Revit 2013 API
InsulationTypeSetIterator Methods
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
InsulationTypeSetIterator..::..MoveNext Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
InsulationTypeSetIterator..::..Reset Method
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypeSetIterator Properties

[image] [image]

Revit 2013 API
InsulationTypeSetIterator Properties
InsulationTypeSetIterator Class See Also Send Feedback

The InsulationTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
InsulationTypeSetIterator..::..Current Property
InsulationTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

InsulationTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Class

[image]

Revit 2013 API
LightingDevice Class
Members See Also Send Feedback
Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic
Public Class LightingDevice _
    Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Electrical..::..LightingDevice

See Also

LightingDevice Members
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Members

[image] [image]

Revit 2013 API
LightingDevice Members
LightingDevice Class Methods Properties See Also Send Feedback

The LightingDevice type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Methods

[image] [image]

Revit 2013 API
LightingDevice Methods
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingDevice Properties

[image] [image]

Revit 2013 API
LightingDevice Properties
LightingDevice Class See Also Send Feedback

The LightingDevice type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingDevice Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Class

[image]

Revit 2013 API
LightingFixture Class
Members See Also Send Feedback
Provides access to the Lighting Fixture in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LightingFixture : MEPModel
Visual Basic
Public Class LightingFixture _
    Inherits MEPModel
Visual C++
public ref class LightingFixture : public MEPModel

Remarks

The Lighting Fixture object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Electrical..::..LightingFixture

See Also

LightingFixture Members
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Members

[image] [image]

Revit 2013 API
LightingFixture Members
LightingFixture Class Methods Properties See Also Send Feedback

The LightingFixture type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Methods

[image] [image]

Revit 2013 API
LightingFixture Methods
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LightingFixture Properties

[image] [image]

Revit 2013 API
LightingFixture Properties
LightingFixture Class See Also Send Feedback

The LightingFixture type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LightingFixture Class
Autodesk.Revit.DB.Electrical Namespace


LoadClassification Enumeration

[image]

Revit 2013 API
LoadClassification Enumeration
See Also Send Feedback
An enumerated type to list all demand factor classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LoadClassification
Visual Basic
Public Enumeration LoadClassification
Visual C++
public enum class LoadClassification

Members

Member name | Description
Undefined | Load classification is undefined.
Power | Load classification is power.
Lighting | Load classification is lighting.
Hvac | Load classification is HVAC.

See Also

Autodesk.Revit.DB.Electrical Namespace


LoadClassificationType Enumeration

[image]

Revit 2013 API
LoadClassificationType Enumeration
See Also Send Feedback
An enumerated type listing all the possible load classification types for a connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum LoadClassificationType
Visual Basic
Public Enumeration LoadClassificationType
Visual C++
public enum class LoadClassificationType

Members

Member name | Description
Other | Load Classification Type is Other.
Power | Load Classification Type is Power.
Lighting | Load Classification Type is Lighting.
HVAC | Load Classification Type is HVAC.

See Also

Autodesk.Revit.DB.Electrical Namespace


NeutralMode Enumeration

[image]

Revit 2013 API
NeutralMode Enumeration
See Also Send Feedback
An enumerated type to list the neutral mode for wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum NeutralMode
Visual Basic
Public Enumeration NeutralMode
Visual C++
public enum class NeutralMode

Members

Member name | Description
HotConductorSize | Neutral Mode is HotConductorSize.
UnbalancedCurrent | Neutral Mode is UnbalancedCurrent.

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelConfiguration Enumeration

[image]

Revit 2013 API
PanelConfiguration Enumeration
See Also Send Feedback
This enum declares the configuration for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum PanelConfiguration
Visual Basic
Public Enumeration PanelConfiguration
Visual C++
public enum class PanelConfiguration

Members

Member name | Description
OneColumn | Circuits are numbered top-to-bottom in one single column.
TwoColumnsCircuitsAcross | Circuits are numbered left-to-right. The odd circuits down the left side, even circuits down the right side.
TwoColumnsCircuitsDown | Circuits are numbered top-to-bottom in one single column. First circuits down the left side, then the right side.

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Class

[image]

Revit 2013 API
PanelScheduleData Class
Members See Also Send Feedback
The PanelScheduleData class holds most of the data that describe the layout, appearance, and style of the rows, columns, and cells of a panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PanelScheduleData : TableData
Visual Basic
Public Class PanelScheduleData _
    Inherits TableData
Visual C++
public ref class PanelScheduleData : public TableData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..TableData
Autodesk.Revit.DB.Electrical..::..PanelScheduleData

See Also

PanelScheduleData Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Members

[image] [image]

Revit 2013 API
PanelScheduleData Members
PanelScheduleData Class Methods Properties See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoadClassification | Add a Load Classification Id to the array of Load Classifications.
Public method | Dispose | (Inherited from TableData.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadClassifications | Gets an array of the load classifications associated with this panel schedule
Public method | GetNumberOfCircuitRows | Gets the number of rows in the circuit table
Public method | GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
Public method | IsSymmetric | Check if this panel schedule is symmetric
Public method | RemoveLoadClassification | Remove a Load Classification Id from the array of Load Classifications
Public method | SetBorderAroundSchedule | Adds a border around the schedule
Public method | SetBorderAroundSections | Adds a border around the sections
Public method | SetLoadClassifications | Sets the Load Classifications associated with this panel schedule
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCircuitTableForInstance | Redraw the circuit table for the given panel with the given parameter updates
Public method | UpdateCircuitTableForTemplate | Redraw the circuit table for a template with the given parameter updates
Public method | UpdateIsSectionHidden | Update if this section is hidden or not
Public method | UpdateLoadSummary | Update the load summary section
Public method | UpdateVerticalHeadersInSection | Sets if this header should have vertical text

Properties

 | Name | Description
Public property | BodyShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | BorderAroundSchedule | Places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
Public property | BorderAroundSections | Places a border (GraphicStyle element) around each section, visible only on the instance and sheet
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips; (Inherited from TableData.)
Public property | IsFooterSectionHidden | True if the user wishes to hide the footer section; setting this value must go through the appropriate update function
Public property | IsHeaderSectionHidden | True if the user wishes to hide the header section; setting this value must go through the appropriate update function
Public property | IsPanelSinglePhase | Identifies if the panel is single phase.
Public property | IsSummarySectionHidden | True if the user wishes to hide the summary section; setting this value must go through the appropriate update function
Public property | IsThirdPhaseHidden | True if the user wishes to hide the 3rd phase column of a single phase panel
Public property | NumberOfSections | Gets the number of items in section data array. (Inherited from TableData.)
Public property | NumberOfSlots | The number of slots in the panel schedule; setting this value must go through the appropriate update function
Public property | PanelConfiguration | The panel configuration of this panel schedule
Public property | PhaseLoadType | This property determines the layout of the phase load columns; setting this value must go through the updateCircuitTable function
Public property | PhasesAsCurrents | If true, the phase columns are currents (A), otherwise they are loads (VA); setting this value must go through the appropriate update function
Public property | ScheduleType | The panel schedule type of this panel schedule
Public property | ShowCircuitNumberOnOneRowForMultiphaseCircuits | Shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise
Public property | ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise
Public property | ShowSlotFromDeviceInsteadOfTemplate | When true, the number of rows in an instance will be the number of poles on the associated device, not a set number
Public property | SummaryShowsGroups | Show groups of load classifications in the load summary section
Public property | SummaryShowsOnlyConnectedLoads | Show only the connected load classifications in the summary section
Public property | SummaryShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | Width | Gets or sets the table width in feet; (Inherited from TableData.)
Public property | WidthInPixels | Gets the width of the panel schedule in pixels; (Inherited from TableData.)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Methods

[image] [image]

Revit 2013 API
PanelScheduleData Methods
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoadClassification | Add a Load Classification Id to the array of Load Classifications.
Public method | Dispose | (Inherited from TableData.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadClassifications | Gets an array of the load classifications associated with this panel schedule
Public method | GetNumberOfCircuitRows | Gets the number of rows in the circuit table
Public method | GetSectionData | Returns the section data array element at the specified index. (Inherited from TableData.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsEqual | Checks if this element is equal in value to the other element. (Inherited from TableData.)
Public method | IsSymmetric | Check if this panel schedule is symmetric
Public method | RemoveLoadClassification | Remove a Load Classification Id from the array of Load Classifications
Public method | SetBorderAroundSchedule | Adds a border around the schedule
Public method | SetBorderAroundSections | Adds a border around the sections
Public method | SetLoadClassifications | Sets the Load Classifications associated with this panel schedule
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateCircuitTableForInstance | Redraw the circuit table for the given panel with the given parameter updates
Public method | UpdateCircuitTableForTemplate | Redraw the circuit table for a template with the given parameter updates
Public method | UpdateIsSectionHidden | Update if this section is hidden or not
Public method | UpdateLoadSummary | Update the load summary section
Public method | UpdateVerticalHeadersInSection | Sets if this header should have vertical text

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


AddLoadClassification Method

[image]

Revit 2013 API
PanelScheduleData..::..AddLoadClassification Method
PanelScheduleData Class See Also Send Feedback
Add a Load Classification Id to the array of Load Classifications.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AddLoadClassification(
    ElementId loadClassficationId
)
Visual Basic
Public Function AddLoadClassification ( _
    loadClassficationId As ElementId _
) As Boolean
Visual C++
public:
bool AddLoadClassification(
    ElementId^ loadClassficationId
)

Parameters

loadClassficationId
Type: Autodesk.Revit.DB..::..ElementId
The load classification to add

Return Value

True if success; false if the given Id has already existed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassifications Method

[image]

Revit 2013 API
PanelScheduleData..::..GetLoadClassifications Method
PanelScheduleData Class See Also Send Feedback
Gets an array of the load classifications associated with this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> GetLoadClassifications()
Visual Basic
Public Function GetLoadClassifications As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetLoadClassifications()

Return Value

The array of the load classifications

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


GetNumberOfCircuitRows Method

[image]

Revit 2013 API
PanelScheduleData..::..GetNumberOfCircuitRows Method
PanelScheduleData Class See Also Send Feedback
Gets the number of rows in the circuit table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetNumberOfCircuitRows()
Visual Basic
Public Function GetNumberOfCircuitRows As Integer
Visual C++
public:
int GetNumberOfCircuitRows()

Return Value

The number of rows

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsSymmetric Method

[image]

Revit 2013 API
PanelScheduleData..::..IsSymmetric Method
PanelScheduleData Class See Also Send Feedback
Check if this panel schedule is symmetric

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSymmetric()
Visual Basic
Public Function IsSymmetric As Boolean
Visual C++
public:
bool IsSymmetric()

Return Value

True if this panel schedule is symmetric, false otherwise.

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


RemoveLoadClassification Method

[image]

Revit 2013 API
PanelScheduleData..::..RemoveLoadClassification Method
PanelScheduleData Class See Also Send Feedback
Remove a Load Classification Id from the array of Load Classifications

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveLoadClassification(
    int nIndex
)
Visual Basic
Public Sub RemoveLoadClassification ( _
    nIndex As Integer _
)
Visual C++
public:
void RemoveLoadClassification(
    int nIndex
)

Parameters

nIndex
Type: System..::..Int32
The index at which to remove the load classification

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SetBorderAroundSchedule Method

[image]

Revit 2013 API
PanelScheduleData..::..SetBorderAroundSchedule Method
PanelScheduleData Class See Also Send Feedback
Adds a border around the schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetBorderAroundSchedule(
    ElementId borderId
)
Visual Basic
Public Sub SetBorderAroundSchedule ( _
    borderId As ElementId _
)
Visual C++
public:
void SetBorderAroundSchedule(
    ElementId^ borderId
)

Parameters

borderId
Type: Autodesk.Revit.DB..::..ElementId
The border to set around the schedule

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SetBorderAroundSections Method

[image]

Revit 2013 API
PanelScheduleData..::..SetBorderAroundSections Method
PanelScheduleData Class See Also Send Feedback
Adds a border around the sections

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetBorderAroundSections(
    ElementId borderId
)
Visual Basic
Public Sub SetBorderAroundSections ( _
    borderId As ElementId _
)
Visual C++
public:
void SetBorderAroundSections(
    ElementId^ borderId
)

Parameters

borderId
Type: Autodesk.Revit.DB..::..ElementId
The border to set around the sections

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SetLoadClassifications Method

[image]

Revit 2013 API
PanelScheduleData..::..SetLoadClassifications Method
PanelScheduleData Class See Also Send Feedback
Sets the Load Classifications associated with this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetLoadClassifications(
    IList<ElementId> loadClassificaions
)
Visual Basic
Public Sub SetLoadClassifications ( _
    loadClassificaions As IList(Of ElementId) _
)
Visual C++
public:
void SetLoadClassifications(
    IList<ElementId^>^ loadClassificaions
)

Parameters

loadClassificaions
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The load classifications to assign

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateCircuitTableForInstance Method

[image]

Revit 2013 API
PanelScheduleData..::..UpdateCircuitTableForInstance Method
PanelScheduleData Class See Also Send Feedback
Redraw the circuit table for the given panel with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateCircuitTableForInstance(
    FamilyInstance pPanel
)
Visual Basic
Public Sub UpdateCircuitTableForInstance ( _
    pPanel As FamilyInstance _
)
Visual C++
public:
void UpdateCircuitTableForInstance(
    FamilyInstance^ pPanel
)

Parameters

pPanel
Type: Autodesk.Revit.DB..::..FamilyInstance
The panel that this circuit table is being drawn for

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateCircuitTableForTemplate Method

[image]

Revit 2013 API
PanelScheduleData..::..UpdateCircuitTableForTemplate Method
PanelScheduleData Class See Also Send Feedback
Redraw the circuit table for a template with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots,
    bool bPhasesAsCurrents
)
Visual Basic
Public Sub UpdateCircuitTableForTemplate ( _
    newType As PanelSchedulePhaseLoadType, _
    nNumSlots As Integer, _
    bPhasesAsCurrents As Boolean _
)
Visual C++
public:
void UpdateCircuitTableForTemplate(
    PanelSchedulePhaseLoadType newType,
    int nNumSlots,
    bool bPhasesAsCurrents
)

Parameters

newType
Type: Autodesk.Revit.DB.Electrical..::..PanelSchedulePhaseLoadType
The new phase load type of the circuit table
nNumSlots
Type: System..::..Int32
The number of circuit slots
bPhasesAsCurrents
Type: System..::..Boolean
True if the phase columns should be currents, false if they should be loads

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateIsSectionHidden Method

[image]

Revit 2013 API
PanelScheduleData..::..UpdateIsSectionHidden Method
PanelScheduleData Class See Also Send Feedback
Update if this section is hidden or not

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateIsSectionHidden(
    SectionType sectionType,
    bool bHide
)
Visual Basic
Public Sub UpdateIsSectionHidden ( _
    sectionType As SectionType, _
    bHide As Boolean _
)
Visual C++
public:
void UpdateIsSectionHidden(
    SectionType sectionType,
    bool bHide
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The Section Type
bHide
Type: System..::..Boolean
Whether to hide this section or not

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateLoadSummary Method

[image]

Revit 2013 API
PanelScheduleData..::..UpdateLoadSummary Method
PanelScheduleData Class See Also Send Feedback
Update the load summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateLoadSummary()
Visual Basic
Public Sub UpdateLoadSummary
Visual C++
public:
void UpdateLoadSummary()

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


UpdateVerticalHeadersInSection Method

[image]

Revit 2013 API
PanelScheduleData..::..UpdateVerticalHeadersInSection Method
PanelScheduleData Class See Also Send Feedback
Sets if this header should have vertical text

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void UpdateVerticalHeadersInSection(
    SectionType sectionType,
    bool bVertical
)
Visual Basic
Public Sub UpdateVerticalHeadersInSection ( _
    sectionType As SectionType, _
    bVertical As Boolean _
)
Visual C++
public:
void UpdateVerticalHeadersInSection(
    SectionType sectionType,
    bool bVertical
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type
bVertical
Type: System..::..Boolean
Whether headers are vertical or not

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleData Properties

[image] [image]

Revit 2013 API
PanelScheduleData Properties
PanelScheduleData Class See Also Send Feedback

The PanelScheduleData type exposes the following members.

Properties

 | Name | Description
Public property | BodyShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | BorderAroundSchedule | Places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet
Public property | BorderAroundSections | Places a border (GraphicStyle element) around each section, visible only on the instance and sheet
Public property | FreezeColumnsAndRows | set to true if the columns and rows should be unmovable by the slider grips; (Inherited from TableData.)
Public property | IsFooterSectionHidden | True if the user wishes to hide the footer section; setting this value must go through the appropriate update function
Public property | IsHeaderSectionHidden | True if the user wishes to hide the header section; setting this value must go through the appropriate update function
Public property | IsPanelSinglePhase | Identifies if the panel is single phase.
Public property | IsSummarySectionHidden | True if the user wishes to hide the summary section; setting this value must go through the appropriate update function
Public property | IsThirdPhaseHidden | True if the user wishes to hide the 3rd phase column of a single phase panel
Public property | NumberOfSections | Gets the number of items in section data array. (Inherited from TableData.)
Public property | NumberOfSlots | The number of slots in the panel schedule; setting this value must go through the appropriate update function
Public property | PanelConfiguration | The panel configuration of this panel schedule
Public property | PhaseLoadType | This property determines the layout of the phase load columns; setting this value must go through the updateCircuitTable function
Public property | PhasesAsCurrents | If true, the phase columns are currents (A), otherwise they are loads (VA); setting this value must go through the appropriate update function
Public property | ScheduleType | The panel schedule type of this panel schedule
Public property | ShowCircuitNumberOnOneRowForMultiphaseCircuits | Shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise
Public property | ShowMultipleRowsForMultiphaseCircuits | shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise
Public property | ShowSlotFromDeviceInsteadOfTemplate | When true, the number of rows in an instance will be the number of poles on the associated device, not a set number
Public property | SummaryShowsGroups | Show groups of load classifications in the load summary section
Public property | SummaryShowsOnlyConnectedLoads | Show only the connected load classifications in the summary section
Public property | SummaryShowsVerticalHeaders | Shows text in the Load Summary section's headers vertically instead of horizontally
Public property | Width | Gets or sets the table width in feet; (Inherited from TableData.)
Public property | WidthInPixels | Gets the width of the panel schedule in pixels; (Inherited from TableData.)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BodyShowsVerticalHeaders Property

[image]

Revit 2013 API
PanelScheduleData..::..BodyShowsVerticalHeaders Property
PanelScheduleData Class See Also Send Feedback
Shows text in the Load Summary section's headers vertically instead of horizontally

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool BodyShowsVerticalHeaders { get; }
Visual Basic
Public ReadOnly Property BodyShowsVerticalHeaders As Boolean
    Get
Visual C++
public:
property bool BodyShowsVerticalHeaders {
    bool get ();
}

Remarks

Setting this value must go through the appropriate update function (updateVerticalHeadersInSection)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BorderAroundSchedule Property

[image]

Revit 2013 API
PanelScheduleData..::..BorderAroundSchedule Property
PanelScheduleData Class See Also Send Feedback
Places a border (GraphicStyle element) around the entire schedule, visible only on the instance and sheet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderAroundSchedule { get; }
Visual Basic
Public ReadOnly Property BorderAroundSchedule As ElementId
    Get
Visual C++
public:
property ElementId^ BorderAroundSchedule {
    ElementId^ get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


BorderAroundSections Property

[image]

Revit 2013 API
PanelScheduleData..::..BorderAroundSections Property
PanelScheduleData Class See Also Send Feedback
Places a border (GraphicStyle element) around each section, visible only on the instance and sheet

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId BorderAroundSections { get; }
Visual Basic
Public ReadOnly Property BorderAroundSections As ElementId
    Get
Visual C++
public:
property ElementId^ BorderAroundSections {
    ElementId^ get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsFooterSectionHidden Property

[image]

Revit 2013 API
PanelScheduleData..::..IsFooterSectionHidden Property
PanelScheduleData Class See Also Send Feedback
True if the user wishes to hide the footer section; setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsFooterSectionHidden { get; }
Visual Basic
Public ReadOnly Property IsFooterSectionHidden As Boolean
    Get
Visual C++
public:
property bool IsFooterSectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsHeaderSectionHidden Property

[image]

Revit 2013 API
PanelScheduleData..::..IsHeaderSectionHidden Property
PanelScheduleData Class See Also Send Feedback
True if the user wishes to hide the header section; setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsHeaderSectionHidden { get; }
Visual Basic
Public ReadOnly Property IsHeaderSectionHidden As Boolean
    Get
Visual C++
public:
property bool IsHeaderSectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsPanelSinglePhase Property

[image]

Revit 2013 API
PanelScheduleData..::..IsPanelSinglePhase Property
PanelScheduleData Class See Also Send Feedback
Identifies if the panel is single phase.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPanelSinglePhase { get; set; }
Visual Basic
Public Property IsPanelSinglePhase As Boolean
    Get
    Set
Visual C++
public:
property bool IsPanelSinglePhase {
    bool get ();
    void set (bool value);
}

Remarks

If true, the panel is single phase. If false, the panel is 3-phase.

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsSummarySectionHidden Property

[image]

Revit 2013 API
PanelScheduleData..::..IsSummarySectionHidden Property
PanelScheduleData Class See Also Send Feedback
True if the user wishes to hide the summary section; setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSummarySectionHidden { get; }
Visual Basic
Public ReadOnly Property IsSummarySectionHidden As Boolean
    Get
Visual C++
public:
property bool IsSummarySectionHidden {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


IsThirdPhaseHidden Property

[image]

Revit 2013 API
PanelScheduleData..::..IsThirdPhaseHidden Property
PanelScheduleData Class See Also Send Feedback
True if the user wishes to hide the 3rd phase column of a single phase panel

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsThirdPhaseHidden { get; set; }
Visual Basic
Public Property IsThirdPhaseHidden As Boolean
    Get
    Set
Visual C++
public:
property bool IsThirdPhaseHidden {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


NumberOfSlots Property

[image]

Revit 2013 API
PanelScheduleData..::..NumberOfSlots Property
PanelScheduleData Class See Also Send Feedback
The number of slots in the panel schedule; setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfSlots { get; }
Visual Basic
Public ReadOnly Property NumberOfSlots As Integer
    Get
Visual C++
public:
property int NumberOfSlots {
    int get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelConfiguration Property

[image]

Revit 2013 API
PanelScheduleData..::..PanelConfiguration Property
PanelScheduleData Class See Also Send Feedback
The panel configuration of this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelConfiguration PanelConfiguration { get; }
Visual Basic
Public ReadOnly Property PanelConfiguration As PanelConfiguration
    Get
Visual C++
public:
property PanelConfiguration PanelConfiguration {
    PanelConfiguration get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PhaseLoadType Property

[image]

Revit 2013 API
PanelScheduleData..::..PhaseLoadType Property
PanelScheduleData Class See Also Send Feedback
This property determines the layout of the phase load columns; setting this value must go through the updateCircuitTable function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelSchedulePhaseLoadType PhaseLoadType { get; }
Visual Basic
Public ReadOnly Property PhaseLoadType As PanelSchedulePhaseLoadType
    Get
Visual C++
public:
property PanelSchedulePhaseLoadType PhaseLoadType {
    PanelSchedulePhaseLoadType get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PhasesAsCurrents Property

[image]

Revit 2013 API
PanelScheduleData..::..PhasesAsCurrents Property
PanelScheduleData Class See Also Send Feedback
If true, the phase columns are currents (A), otherwise they are loads (VA); setting this value must go through the appropriate update function

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool PhasesAsCurrents { get; }
Visual Basic
Public ReadOnly Property PhasesAsCurrents As Boolean
    Get
Visual C++
public:
property bool PhasesAsCurrents {
    bool get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ScheduleType Property

[image]

Revit 2013 API
PanelScheduleData..::..ScheduleType Property
PanelScheduleData Class See Also Send Feedback
The panel schedule type of this panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelScheduleType ScheduleType { get; }
Visual Basic
Public ReadOnly Property ScheduleType As PanelScheduleType
    Get
Visual C++
public:
property PanelScheduleType ScheduleType {
    PanelScheduleType get ();
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ShowCircuitNumberOnOneRowForMultiphaseCircuits Property

[image]

Revit 2013 API
PanelScheduleData..::..ShowCircuitNumberOnOneRowForMultiphaseCircuits Property
PanelScheduleData Class See Also Send Feedback
Shows the circuit number broken up on each row of the multiphase circuit rows if true, all on the first row otherwise

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ShowCircuitNumberOnOneRowForMultiphaseCircuits { get; set; }
Visual Basic
Public Property ShowCircuitNumberOnOneRowForMultiphaseCircuits As Boolean
    Get
    Set
Visual C++
public:
property bool ShowCircuitNumberOnOneRowForMultiphaseCircuits {
    bool get ();
    void set (bool value);
}

Remarks

Only applicable to two column formats

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ShowMultipleRowsForMultiphaseCircuits Property

[image]

Revit 2013 API
PanelScheduleData..::..ShowMultipleRowsForMultiphaseCircuits Property
PanelScheduleData Class See Also Send Feedback
shows extra rows below multiphase circuits to indicate how many slots they take up if true, all on a single row otherwise

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ShowMultipleRowsForMultiphaseCircuits { get; set; }
Visual Basic
Public Property ShowMultipleRowsForMultiphaseCircuits As Boolean
    Get
    Set
Visual C++
public:
property bool ShowMultipleRowsForMultiphaseCircuits {
    bool get ();
    void set (bool value);
}

Remarks

only applicable to one column formats

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


ShowSlotFromDeviceInsteadOfTemplate Property

[image]

Revit 2013 API
PanelScheduleData..::..ShowSlotFromDeviceInsteadOfTemplate Property
PanelScheduleData Class See Also Send Feedback
When true, the number of rows in an instance will be the number of poles on the associated device, not a set number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ShowSlotFromDeviceInsteadOfTemplate { get; set; }
Visual Basic
Public Property ShowSlotFromDeviceInsteadOfTemplate As Boolean
    Get
    Set
Visual C++
public:
property bool ShowSlotFromDeviceInsteadOfTemplate {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsGroups Property

[image]

Revit 2013 API
PanelScheduleData..::..SummaryShowsGroups Property
PanelScheduleData Class See Also Send Feedback
Show groups of load classifications in the load summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SummaryShowsGroups { get; set; }
Visual Basic
Public Property SummaryShowsGroups As Boolean
    Get
    Set
Visual C++
public:
property bool SummaryShowsGroups {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsOnlyConnectedLoads Property

[image]

Revit 2013 API
PanelScheduleData..::..SummaryShowsOnlyConnectedLoads Property
PanelScheduleData Class See Also Send Feedback
Show only the connected load classifications in the summary section

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SummaryShowsOnlyConnectedLoads { get; set; }
Visual Basic
Public Property SummaryShowsOnlyConnectedLoads As Boolean
    Get
    Set
Visual C++
public:
property bool SummaryShowsOnlyConnectedLoads {
    bool get ();
    void set (bool value);
}

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


SummaryShowsVerticalHeaders Property

[image]

Revit 2013 API
PanelScheduleData..::..SummaryShowsVerticalHeaders Property
PanelScheduleData Class See Also Send Feedback
Shows text in the Load Summary section's headers vertically instead of horizontally

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SummaryShowsVerticalHeaders { get; }
Visual Basic
Public ReadOnly Property SummaryShowsVerticalHeaders As Boolean
    Get
Visual C++
public:
property bool SummaryShowsVerticalHeaders {
    bool get ();
}

Remarks

Setting this value must go through the appropriate update function (updateVerticalHeadersInSection)

See Also

PanelScheduleData Class
Autodesk.Revit.DB.Electrical Namespace


PanelSchedulePhaseLoadType Enumeration

[image]

Revit 2013 API
PanelSchedulePhaseLoadType Enumeration
See Also Send Feedback
Declares the panel schedule type. The comments for each enum type show a simple example of how the layout would look when applied to a panel schedule

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum PanelSchedulePhaseLoadType
Visual Basic
Public Enumeration PanelSchedulePhaseLoadType
Visual C++
public enum class PanelSchedulePhaseLoadType

Members

Member name | Description
NoLoadInformation | No load information
LoadsByPhaseInSplitColumns | | Ckt | A | B | C | Ckt | | 1 | 100 | 200 | x | x | x | x | 2 |
MirroredPhaseColumns | | Ckt | A | B | C | A | B | C | Ckt | | 1 | 100 | x | x | 200 | x | x | 2 |
LoadsByPhaseInSharedColumns | | Ckt | A | B | C | Ckt | | 1 | 100/200 | x | x | 2 |
LoadsByPhase | | Ckt | A | B | C | Ckt | | 1 | 100 | x | x | | | | 200 | x | x | 2 |
TotalLoadOnlyPerCircuit | | Ckt | Load | | 1 | 100 | | 2 | 200 |
SeperatePhaseLoadsPerCircuit | | Ckt | A | B | C | | 1 | 100 | 0 | 0 | | 2 | 200 | 0 | 0 |

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Class

[image]

Revit 2013 API
PanelScheduleSheetInstance Class
Members See Also Send Feedback
The class represents an instance of a panel schedule placed on sheet.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class PanelScheduleSheetInstance : Element
Visual Basic
Public Class PanelScheduleSheetInstance _
    Inherits Element
Visual C++
public ref class PanelScheduleSheetInstance : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..PanelScheduleSheetInstance

See Also

PanelScheduleSheetInstance Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Members

[image] [image]

Revit 2013 API
PanelScheduleSheetInstance Members
PanelScheduleSheetInstance Class Methods Properties See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of panel schedule on sheet and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSchedule | Gets the panel schedule view.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SplitSegment | Split the panel schedule into
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The sheet instance offset in drawing sheet coordinates.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ScheduleId | The panel schedule id.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Methods

[image] [image]

Revit 2013 API
PanelScheduleSheetInstance Methods
PanelScheduleSheetInstance Class See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of panel schedule on sheet and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSchedule | Gets the panel schedule view.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SplitSegment | Split the panel schedule into
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
PanelScheduleSheetInstance..::..Create Method
PanelScheduleSheetInstance Class See Also Send Feedback
Creates a new instance of panel schedule on sheet and adds it to the document.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static PanelScheduleSheetInstance Create(
    Document ADoc,
    ElementId scheduleId,
    View DBView
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    scheduleId As ElementId, _
    DBView As View _
) As PanelScheduleSheetInstance
Visual C++
public:
static PanelScheduleSheetInstance^ Create(
    Document^ ADoc,
    ElementId^ scheduleId,
    View^ DBView
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
scheduleId
Type: Autodesk.Revit.DB..::..ElementId
DBView
Type: Autodesk.Revit.DB..::..View

Return Value

The newly created panel schedule sheet instance element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


GetSchedule Method

[image]

Revit 2013 API
PanelScheduleSheetInstance..::..GetSchedule Method
PanelScheduleSheetInstance Class See Also Send Feedback
Gets the panel schedule view.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public PanelScheduleView GetSchedule()
Visual Basic
Public Function GetSchedule As PanelScheduleView
Visual C++
public:
PanelScheduleView^ GetSchedule()

Return Value

The panel schedule view element.

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


SplitSegment Method

[image]

Revit 2013 API
PanelScheduleSheetInstance..::..SplitSegment Method
PanelScheduleSheetInstance Class See Also Send Feedback
Split the panel schedule into

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool SplitSegment(
    int iSeg
)
Visual Basic
Public Function SplitSegment ( _
    iSeg As Integer _
) As Boolean
Visual C++
public:
bool SplitSegment(
    int iSeg
)

Parameters

iSeg
Type: System..::..Int32

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleSheetInstance Properties

[image] [image]

Revit 2013 API
PanelScheduleSheetInstance Properties
PanelScheduleSheetInstance Class See Also Send Feedback

The PanelScheduleSheetInstance type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The sheet instance offset in drawing sheet coordinates.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ScheduleId | The panel schedule id.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Origin Property

[image]

Revit 2013 API
PanelScheduleSheetInstance..::..Origin Property
PanelScheduleSheetInstance Class See Also Send Feedback
The sheet instance offset in drawing sheet coordinates.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ Origin { get; set; }
Visual Basic
Public Property Origin As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Origin {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
PanelScheduleSheetInstance..::..Parameter Property
PanelScheduleSheetInstance Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PanelScheduleSheetInstance Class
PanelScheduleSheetInstance Members
Autodesk.Revit.DB.Electrical Namespace


ScheduleId Property

[image]

Revit 2013 API
PanelScheduleSheetInstance..::..ScheduleId Property
PanelScheduleSheetInstance Class See Also Send Feedback
The panel schedule id.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId ScheduleId { get; set; }
Visual Basic
Public Property ScheduleId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ ScheduleId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

PanelScheduleSheetInstance Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Class

[image]

Revit 2013 API
PanelScheduleTemplate Class
Members See Also Send Feedback
The PanelScheduleTemplate class represents an instance of panel schedule template element. An instance object could be a branch panel, a switchboard or a data panel template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PanelScheduleTemplate : Element
Visual Basic
Public Class PanelScheduleTemplate _
    Inherits Element
Visual C++
public ref class PanelScheduleTemplate : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate

See Also

PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Members

[image] [image]

Revit 2013 API
PanelScheduleTemplate Members
PanelScheduleTemplate Class Methods Properties See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CopyFrom | Copies all values from other element to this object.
 | Create | Creates a new instance of a panel schedule template.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPanelScheduleType | Returns the panel schedule type.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionData | Gets the writable section data object.
Public method | GetTableData | Gets the writable table data object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSameType | Checks if given template has the same panel schedule type with this template.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetTableData | Assigns table data to this template
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
Public property | IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
Public property | IsDefault | Checks to see if this is default template for the given panel schedule type.
Public property | IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Methods

[image] [image]

Revit 2013 API
PanelScheduleTemplate Methods
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CopyFrom | Copies all values from other element to this object.
 | Create | Creates a new instance of a panel schedule template.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPanelScheduleType | Returns the panel schedule type.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionData | Gets the writable section data object.
Public method | GetTableData | Gets the writable table data object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasSameType | Checks if given template has the same panel schedule type with this template.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidPanelConfiguration | Checks if given panel configuration is valid for given panel schedule type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetTableData | Assigns table data to this template
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


CopyFrom Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..CopyFrom Method
PanelScheduleTemplate Class See Also Send Feedback
Copies all values from other element to this object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void CopyFrom(
    Document OtherADoc,
    PanelScheduleTemplate otherElem
)
Visual Basic
Public Sub CopyFrom ( _
    OtherADoc As Document, _
    otherElem As PanelScheduleTemplate _
)
Visual C++
public:
void CopyFrom(
    Document^ OtherADoc,
    PanelScheduleTemplate^ otherElem
)

Parameters

OtherADoc
Type: Autodesk.Revit.DB..::..Document
The Document for the otherElem
otherElem
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate
The element being copied from.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given template otherElem has different type of this element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


Create Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..Create Method
PanelScheduleTemplate Class See Also Send Feedback
Creates a new instance of a panel schedule template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PanelScheduleTemplate Create(
    Document document,
    PanelScheduleType type,
    PanelConfiguration config,
    string strName
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    type As PanelScheduleType, _
    config As PanelConfiguration, _
    strName As String _
) As PanelScheduleTemplate
Visual C++
public:
static PanelScheduleTemplate^ Create(
    Document^ document,
    PanelScheduleType type,
    PanelConfiguration config,
    String^ strName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
type
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The panel schedule type.
config
Type: Autodesk.Revit.DB.Electrical..::..PanelConfiguration
The panel configuration type.
strName
Type: System..::..String
The name of the panel schedule template to be created.

Return Value

The newly created panel schedule template element.

Remarks

If the given name has already been used by existing panel schedule templates, a unique name will be used for the newly created template.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The type is not valid for this element. -or- The config is not valid for panel schedule type type of this template.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetPanelScheduleType Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..GetPanelScheduleType Method
PanelScheduleTemplate Class See Also Send Feedback
Returns the panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelScheduleType GetPanelScheduleType()
Visual Basic
Public Function GetPanelScheduleType As PanelScheduleType
Visual C++
public:
PanelScheduleType GetPanelScheduleType()

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetSectionData Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..GetSectionData Method
PanelScheduleTemplate Class See Also Send Feedback
Gets the writable section data object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    SectionType sectionType
)
Visual Basic
Public Function GetSectionData ( _
    sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType

Return Value

The table section data object.

Remarks

Access to this information requires an open transaction.

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


GetTableData Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..GetTableData Method
PanelScheduleTemplate Class See Also Send Feedback
Gets the writable table data object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelScheduleData GetTableData()
Visual Basic
Public Function GetTableData As PanelScheduleData
Visual C++
public:
PanelScheduleData^ GetTableData()

Return Value

The panel schedule data object.

Remarks

Access to this information requires an open transaction.

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


HasSameType Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..HasSameType Method
PanelScheduleTemplate Class See Also Send Feedback
Checks if given template has the same panel schedule type with this template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasSameType(
    PanelScheduleTemplate otherTemplate
)
Visual Basic
Public Function HasSameType ( _
    otherTemplate As PanelScheduleTemplate _
) As Boolean
Visual C++
public:
bool HasSameType(
    PanelScheduleTemplate^ otherTemplate
)

Parameters

otherTemplate
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleTemplate
The given template to check.

Return Value

True if the given template has the same panel schedule type with this template, false otherwise.

Remarks

The panel schedule type is the enum type of PanelScheduleType class (Branch, switchboard, data etc.)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsValidPanelConfiguration Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsValidPanelConfiguration Method
PanelScheduleTemplate Class See Also Send Feedback
Checks if given panel configuration is valid for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)
Visual Basic
Public Shared Function IsValidPanelConfiguration ( _
    scheduleType As PanelScheduleType, _
    configuration As PanelConfiguration _
) As Boolean
Visual C++
public:
static bool IsValidPanelConfiguration(
    PanelScheduleType scheduleType,
    PanelConfiguration configuration
)

Parameters

scheduleType
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The panel schedule type.
configuration
Type: Autodesk.Revit.DB.Electrical..::..PanelConfiguration
The given configuration to check.

Return Value

True if panel schedule template can have a valid configuration assigned, false otherwise.

Remarks

If the panel schedule type is branch panel, the valid panel configurations are:
PanelConfiguration::Enum::OneColumn
PanelConfiguration::Enum::TwoColumnsCircuitsAcross
PanelConfiguration::Enum::TwoColumnsCircuitsDown
If the panel schedule type is switchboard or data panel, the valid panel configuration is:
PanelConfiguration::Enum::OneColumn

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsValidType Method

[image] [image]

Revit 2013 API
PanelScheduleTemplate..::..IsValidType Method
PanelScheduleTemplate Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | IsValidType(PanelScheduleType) | Checks if given type is valid for this panel schedule template element.

See Also

PanelScheduleTemplate Class
PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


IsValidType Method (PanelScheduleType)

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsValidType Method (PanelScheduleType)
PanelScheduleTemplate Class See Also Send Feedback
Checks if given type is valid for this panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsValidType(
    PanelScheduleType panelScheduleType
)
Visual Basic
Public Shared Function IsValidType ( _
    panelScheduleType As PanelScheduleType _
) As Boolean
Visual C++
public:
static bool IsValidType(
    PanelScheduleType panelScheduleType
)

Parameters

panelScheduleType
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleType
The given type to check.

Return Value

True if panel schedule template can have a type assigned and this type is valid for this element, false otherwise.

Remarks

A type is valid for a panel schedule template element if it is defined by the PanelScheduleType class. Note: PanelScheduleType::Enum::Unknown is not a valid type, it is used for initializing the variable of the PanelScheduleType::Enum.

See Also

PanelScheduleTemplate Class
IsValidType Overload
Autodesk.Revit.DB.Electrical Namespace


SetTableData Method

[image]

Revit 2013 API
PanelScheduleTemplate..::..SetTableData Method
PanelScheduleTemplate Class See Also Send Feedback
Assigns table data to this template

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetTableData(
    PanelScheduleData Data
)
Visual Basic
Public Sub SetTableData ( _
    Data As PanelScheduleData _
)
Visual C++
public:
void SetTableData(
    PanelScheduleData^ Data
)

Parameters

Data
Type: Autodesk.Revit.DB.Electrical..::..PanelScheduleData
The panel schedule data

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleTemplate Properties

[image] [image]

Revit 2013 API
PanelScheduleTemplate Properties
PanelScheduleTemplate Class See Also Send Feedback

The PanelScheduleTemplate type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsBranchPanelSchedule | Checks to see if this object is branch panel schedule template element.
Public property | IsDataPanelSchedule | Checks to see if this object is data panel schedule template element.
Public property | IsDefault | Checks to see if this is default template for the given panel schedule type.
Public property | IsSwitchboardSchedule | Checks to see if this object is switchboard schedule template element.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsBranchPanelSchedule Property

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsBranchPanelSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is branch panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsBranchPanelSchedule { get; }
Visual Basic
Public ReadOnly Property IsBranchPanelSchedule As Boolean
    Get
Visual C++
public:
property bool IsBranchPanelSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsDataPanelSchedule Property

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsDataPanelSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is data panel schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDataPanelSchedule { get; }
Visual Basic
Public ReadOnly Property IsDataPanelSchedule As Boolean
    Get
Visual C++
public:
property bool IsDataPanelSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsDefault Property

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsDefault Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this is default template for the given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDefault { get; }
Visual Basic
Public ReadOnly Property IsDefault As Boolean
    Get
Visual C++
public:
property bool IsDefault {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


IsSwitchboardSchedule Property

[image]

Revit 2013 API
PanelScheduleTemplate..::..IsSwitchboardSchedule Property
PanelScheduleTemplate Class See Also Send Feedback
Checks to see if this object is switchboard schedule template element.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSwitchboardSchedule { get; }
Visual Basic
Public ReadOnly Property IsSwitchboardSchedule As Boolean
    Get
Visual C++
public:
property bool IsSwitchboardSchedule {
    bool get ();
}

See Also

PanelScheduleTemplate Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
PanelScheduleTemplate..::..Parameter Property
PanelScheduleTemplate Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PanelScheduleTemplate Class
PanelScheduleTemplate Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleType Enumeration

[image]

Revit 2013 API
PanelScheduleType Enumeration
See Also Send Feedback
This enum declares the panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum PanelScheduleType
Visual Basic
Public Enumeration PanelScheduleType
Visual C++
public enum class PanelScheduleType

Members

Member name | Description
Unknown | Unknown panel schedule
Branch | Branch panel schedule
Switchboard | Switchboard schedule
Data | Data panel schedule

See Also

Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Class

[image]

Revit 2013 API
PanelScheduleView Class
Members See Also Send Feedback
An instance of a panel schedule view.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PanelScheduleView : TableView
Visual Basic
Public Class PanelScheduleView _
    Inherits TableView
Visual C++
public ref class PanelScheduleView : public TableView

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..View
Autodesk.Revit.DB..::..TableView
Autodesk.Revit.DB.Electrical..::..PanelScheduleView

See Also

PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Members

[image] [image]

Revit 2013 API
PanelScheduleView Members
PanelScheduleView Class Methods Properties See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

 | Name | Description
Public method | AddFontId | Adds a unique combination of font name, size, and color within the table view to the font table
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateInstanceView(Document, ElementId) | Creates a new instance of this view (using default template)
 | CreateInstanceView(Document, ElementId, ElementId) | Creates a new instance of this view (using specific template)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GenerateInstanceFromTemplate | Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetApparentPhaseValue | Gets the apparent load for the given phase for the given slotted circuit
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
Public method | GetAvailableParameters | Get available parameters for the specified category. (Inherited from TableView.)
Public method | GetCalculatedValueName | Returns the calculated value name for template view; (Inherited from TableView.)
Public method | GetCalculatedValueText | Returns the calculated value text for instance view; (Inherited from TableView.)
Public method | GetCellText | Gets the cell's text based on its type
Public method | GetCircuitByCell | Gets the circuit element for the given slot number
Public method | GetCircuitIdByCell | Gets the circuit id for the given slot number
Public method | GetCombinedParamValue | Returns the combined parameter text for instance view
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFontId(String, Double, Color) | Gets the font id for the combination of font name, size, and color
Public method | GetFontId(SectionType, Int32, Int32) | Gets the font id for the given cell
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadClassificationConnectedCurrent | Gets the Total Current for given Load Classification
Public method | GetLoadClassificationConnectedLoad | Gets the Total Load for given Load Classification
Public method | GetLoadClassificationDemandCurrent | Gets the Demand Current for given Load Classification
Public method | GetLoadClassificationDemandFactor | Gets the Demand Factor for given Load Classification
Public method | GetLoadClassificationDemandLoad | Gets the Demand Load for given Load Classification
Public method | GetLoadClassificationId | Gets the id of the associated Load Classification at the given row
Public method | GetLoadClassificationName | Gets the name of the Load Classification at the given row/column
Public method | GetLoadClassificationParamValue | Gets the load classification parameter value.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPanel | Gets the panel for this view
Public method | GetParamValue | Gets the cell's text based on its type
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetSectionData | Gets section data that will be written to
Public method | GetSlotNumberByCell | Gets the slot number in the circuit table
Public method | GetSpareCurrentValue | Gets the value of the apparent current parameter for a spare
Public method | GetSpareLoadValue | Gets the value of the apparent load parameter for a spare
Public method | GetTableData | Gets table data that can be written to
Public method | GetTemplate | Gets the template for this view (to set the template, you must go through generateInstanceFromTemplate)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsCellInPhaseLoads | Check if this cell in the phase loads
Public method | IsColumnInLoadSummary | Check if this column in the load summary
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOkToEditParam | (Inherited from TableView.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPanelScheduleTemplate | Check if this is a panel schedule template.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsRowInCircuitTable | Check if this row in the circuit table
Public method | IsSlotGrouped | Check if the slot is in a group
Public method | IsSlotLocked | Check if the circuit slot in this cell is locked.
Public method | IsSpace | Check if the selected cell is a space
Public method | IsSpare | Check if the circuit is a spare
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetParamValue | Sets the text for the given cell, returns true if successful, false otherwise
Public method | SetSpareCurrentValue | Sets the value of the apparent current parameter for a spare
Public method | SetSpareLoadValue | Sets the value of the apparent load parameter for a spare
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinimumColumnWidth | Gets the minimum column width; (Inherited from TableView.)
Public property | MinimumRowHeight | Gets the minimum row height; (Inherited from TableView.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed; (Inherited from TableView.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Methods

[image] [image]

Revit 2013 API
PanelScheduleView Methods
PanelScheduleView Class See Also Send Feedback

The PanelScheduleView type exposes the following members.

Methods

 | Name | Description
Public method | AddFontId | Adds a unique combination of font name, size, and color within the table view to the font table
Public method | ApplyTemplate | Obsolete. Applies a view template to the view. (Inherited from View.)
Public method | ApplyViewTemplateParameters | Applies to this view the parameters of %otherView% that are not controlled by the current view template. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. To get current view template use property ViewTemplateId. (Inherited from View.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanCategoryBeHiddenTemporary | Check if category can be temporarily hidden in the view. (Inherited from View.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanModifyDetailLevel | Check if Detail Level can be modified. (Inherited from View.)
Public method | CanModifyDisplayStyle | Indicates if DisplayStyle can be modified. (Inherited from View.)
Public method | CanModifyViewDiscipline | Indicates if the View Discipline can be modified; (Inherited from View.)
Public method | CanUseTemporaryVisibilityModes | Indicates if view can use temporary visibility modes; (Inherited from View.)
Public method | CanViewBeDuplicated | Checks if the view can be duplicated; (Inherited from View.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ConvertTemporaryHideIsolateToPermanent | Convert all temporary hidden elements or categories to permanently hidden in view. (Inherited from View.)
 | CreateInstanceView(Document, ElementId) | Creates a new instance of this view (using default template)
 | CreateInstanceView(Document, ElementId, ElementId) | Creates a new instance of this view (using specific template)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DisableTemporaryViewMode | Disables the specified temporary view mode. (Inherited from View.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicates the view; (Inherited from View.)
Public method | EnableRevealHiddenMode | Enables Reveal Hidden elements mode. (Inherited from View.)
Public method | EnableTemporaryAnalyticalDisplayMode | Enables temporary display of Analytical Model categories only. (Inherited from View.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GenerateInstanceFromTemplate | Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetApparentPhaseValue | Gets the apparent load for the given phase for the given slotted circuit
Public method | GetAvailableParameterCategories | Get all available parameter categories. (Inherited from TableView.)
Public method | GetAvailableParameters | Get available parameters for the specified category. (Inherited from TableView.)
Public method | GetCalculatedValueName | Returns the calculated value name for template view; (Inherited from TableView.)
Public method | GetCalculatedValueText | Returns the calculated value text for instance view; (Inherited from TableView.)
Public method | GetCellText | Gets the cell's text based on its type
Public method | GetCircuitByCell | Gets the circuit element for the given slot number
Public method | GetCircuitIdByCell | Gets the circuit id for the given slot number
Public method | GetCombinedParamValue | Returns the combined parameter text for instance view
Public method | GetDependentViewIds | Get the ids of dependent views. (Inherited from View.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFontId(String, Double, Color) | Gets the font id for the combination of font name, size, and color
Public method | GetFontId(SectionType, Int32, Int32) | Gets the font id for the given cell
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoadClassificationConnectedCurrent | Gets the Total Current for given Load Classification
Public method | GetLoadClassificationConnectedLoad | Gets the Total Load for given Load Classification
Public method | GetLoadClassificationDemandCurrent | Gets the Demand Current for given Load Classification
Public method | GetLoadClassificationDemandFactor | Gets the Demand Factor for given Load Classification
Public method | GetLoadClassificationDemandLoad | Gets the Demand Load for given Load Classification
Public method | GetLoadClassificationId | Gets the id of the associated Load Classification at the given row
Public method | GetLoadClassificationName | Gets the name of the Load Classification at the given row/column
Public method | GetLoadClassificationParamValue | Gets the load classification parameter value.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetNonControlledTemplateParameterIds | Returns list of parameters that will NOT be controlled when this view is used as a template. This is a subset of the parameters returned by getTemplateParameterIds. (Inherited from View.)
Public method | GetPanel | Gets the panel for this view
Public method | GetParamValue | Gets the cell's text based on its type
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPrimaryViewId | Get the id of the primary view. (Inherited from View.)
Public method | GetSectionData | Gets section data that will be written to
Public method | GetSlotNumberByCell | Gets the slot number in the circuit table
Public method | GetSpareCurrentValue | Gets the value of the apparent current parameter for a spare
Public method | GetSpareLoadValue | Gets the value of the apparent load parameter for a spare
Public method | GetTableData | Gets table data that can be written to
Public method | GetTemplate | Gets the template for this view (to set the template, you must go through generateInstanceFromTemplate)
Public method | GetTemplateParameterIds | Returns list of parameters that may be controlled when this view is used as a template. (Inherited from View.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | getVisibility | Checks if elements of the given category are set to be visible in this view. (Inherited from View.)
Public method | GetWorksetVisibility | Returns the visibility settings of a workset for this particular view. (Inherited from View.)
Public method | GetWorksharingDisplayMode | Gets the current worksharing display mode for this view. (Inherited from View.)
Public method | HasDetailLevel | Check if the view has a Detail Level property; (Inherited from View.)
Public method | HasDisplayStyle | Indicates if view has a DisplayStyle property; (Inherited from View.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasViewDiscipline | Indicates if the view has a Discipline property; (Inherited from View.)
Public method | Hide | Obsolete. Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideActiveWorkPlane | Hide the active work plane of the view. (Inherited from View.)
Public method | HideCategoriesTemporary | Set multiple categories to be temporarily hidden in the view. (Inherited from View.)
Public method | HideCategoryTemporary | Set one category to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElements | Sets the elements to be hidden in the view. (Inherited from View.)
Public method | HideElementsTemporary | Set multiple elements to be temporarily hidden in the view. (Inherited from View.)
Public method | HideElementTemporary | Set one element to be temporarily hidden in the view. (Inherited from View.)
Public method | IsCellInPhaseLoads | Check if this cell in the phase loads
Public method | IsColumnInLoadSummary | Check if this column in the load summary
Public method | IsElementVisibleInTemporaryViewMode | Identifies if the input element is visible for the temporary view mode for this view. (Inherited from View.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsInTemporaryViewMode | Returns true if the view is in a particular temporary view mode. (Inherited from View.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOkToEditParam | (Inherited from TableView.)
Public method | IsolateCategoriesTemporary | Set categories to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateCategoryTemporary | Set one category to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementsTemporary | Set multiple elements to be temporarily isolated in the view. (Inherited from View.)
Public method | IsolateElementTemporary | Set one element to be temporarily isolated in the view. (Inherited from View.)
Public method | IsPanelScheduleTemplate | Check if this is a panel schedule template.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsRowInCircuitTable | Check if this row in the circuit table
Public method | IsSlotGrouped | Check if the slot is in a group
Public method | IsSlotLocked | Check if the circuit slot in this cell is locked.
Public method | IsSpace | Check if the selected cell is a space
Public method | IsSpare | Check if the circuit is a spare
Public method | IsTemporaryAnalyticalModeActive | Indicates if the view is temporarily displaying only the Analytical model. (Inherited from View.)
Public method | IsTemporaryHideIsolateActive | Indicates if the view is temporarily hiding or isolating elements or categories. (Inherited from View.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | IsValidViewTemplate | Verify that %templateId% can be view template for this view: it can be invalidElementId or represent template view that is compatible with this view; (Inherited from View.)
Public method | IsWorksetVisible | Indicates whether the workset is visible in this view. (Inherited from View.)
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | RefreshAllFontIds | Clean all existing font ids and create all font ids based on the table cell styles
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetNonControlledTemplateParameterIds | Set the parameters that will NOT be applied when this view is used as a template. This should be a subset of the parameters returned by getTemplateParameterIds (other parameters will be ignored). (Inherited from View.)
Public method | SetParamValue | Sets the text for the given cell, returns true if successful, false otherwise
Public method | SetSpareCurrentValue | Sets the value of the apparent current parameter for a spare
Public method | SetSpareLoadValue | Sets the value of the apparent load parameter for a spare
Public method | setVisibility | Set if elements of the given category will be visible in this view. (Inherited from View.)
Public method | SetWorksetVisibility | Sets visibility for a workset in this view. (Inherited from View.)
Public method | SetWorksharingDisplayMode | Sets the worksharing display mode for this view. (Inherited from View.)
Public method | ShowActiveWorkPlane | Show the active work plane of the view. (Inherited from View.)
Public method | SupportsWorksharingDisplayMode | Checks whether this view supports the given worksharing display mode. (Inherited from View.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unhide | Obsolete. Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)
Public method | UnhideElements | Sets the elements to be shown in the given view if they are currently hidden. (Inherited from View.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


AddFontId Method

[image]

Revit 2013 API
PanelScheduleView..::..AddFontId Method
PanelScheduleView Class See Also Send Feedback
Adds a unique combination of font name, size, and color within the table view to the font table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId AddFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic
Public Function AddFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ AddFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::..String
The new font's name
fontSize
Type: System..::..Double
The new font's size
fontColor
Type: Autodesk.Revit.DB..::..Color
The new font's color

Return Value

The ElementId of the new font

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method

[image] [image]

Revit 2013 API
PanelScheduleView..::..CreateInstanceView Method
PanelScheduleView Class See Also Send Feedback

Overload List

Name | Description
CreateInstanceView(Document, ElementId) | Creates a new instance of this view (using default template)
CreateInstanceView(Document, ElementId, ElementId) | Creates a new instance of this view (using specific template)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method (Document, ElementId)

[image]

Revit 2013 API
PanelScheduleView..::..CreateInstanceView Method (Document, ElementId)
PanelScheduleView Class See Also Send Feedback
Creates a new instance of this view (using default template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PanelScheduleView CreateInstanceView(
    Document ADoc,
    ElementId panelId
)
Visual Basic
Public Shared Function CreateInstanceView ( _
    ADoc As Document, _
    panelId As ElementId _
) As PanelScheduleView
Visual C++
public:
static PanelScheduleView^ CreateInstanceView(
    Document^ ADoc,
    ElementId^ panelId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The Document
panelId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the electrical panel element.

Return Value

The PanelScheduleView

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
CreateInstanceView Overload
Autodesk.Revit.DB.Electrical Namespace


CreateInstanceView Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
PanelScheduleView..::..CreateInstanceView Method (Document, ElementId, ElementId)
PanelScheduleView Class See Also Send Feedback
Creates a new instance of this view (using specific template)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static PanelScheduleView CreateInstanceView(
    Document ADoc,
    ElementId templateId,
    ElementId panelId
)
Visual Basic
Public Shared Function CreateInstanceView ( _
    ADoc As Document, _
    templateId As ElementId, _
    panelId As ElementId _
) As PanelScheduleView
Visual C++
public:
static PanelScheduleView^ CreateInstanceView(
    Document^ ADoc,
    ElementId^ templateId,
    ElementId^ panelId
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The Document
templateId
Type: Autodesk.Revit.DB..::..ElementId
The templateId that this function will use
panelId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the electrical panel element.

Return Value

The PanelScheduleView

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
CreateInstanceView Overload
Autodesk.Revit.DB.Electrical Namespace


GenerateInstanceFromTemplate Method

[image]

Revit 2013 API
PanelScheduleView..::..GenerateInstanceFromTemplate Method
PanelScheduleView Class See Also Send Feedback
Assigns the data from the template to the instance and performs any tasks specific to the instance (3rd phase, borders, etc)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void GenerateInstanceFromTemplate(
    ElementId templateId
)
Visual Basic
Public Sub GenerateInstanceFromTemplate ( _
    templateId As ElementId _
)
Visual C++
public:
void GenerateInstanceFromTemplate(
    ElementId^ templateId
)

Parameters

templateId
Type: Autodesk.Revit.DB..::..ElementId
Element id of the template element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetApparentPhaseValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetApparentPhaseValue Method
PanelScheduleView Class See Also Send Feedback
Gets the apparent load for the given phase for the given slotted circuit

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetApparentPhaseValue(
    ElementId circuitId,
    ElementId apparentLoadParam
)
Visual Basic
Public Function GetApparentPhaseValue ( _
    circuitId As ElementId, _
    apparentLoadParam As ElementId _
) As Double
Visual C++
public:
double GetApparentPhaseValue(
    ElementId^ circuitId,
    ElementId^ apparentLoadParam
)

Parameters

circuitId
Type: Autodesk.Revit.DB..::..ElementId
Circuit id for the apparent phase value
apparentLoadParam
Type: Autodesk.Revit.DB..::..ElementId
The requested apparent load phase parameter

Return Value

The value of the apparent phase

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCellText Method

[image]

Revit 2013 API
PanelScheduleView..::..GetCellText Method
PanelScheduleView Class See Also Send Feedback
Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCellText ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCellText(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The requested section type
nRow
Type: System..::..Int32
Row Number in the Section
nCol
Type: System..::..Int32
Column Number in the Section

Return Value

The text for the given cell

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if this is an invalid cell

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCircuitByCell Method

[image]

Revit 2013 API
PanelScheduleView..::..GetCircuitByCell Method
PanelScheduleView Class See Also Send Feedback
Gets the circuit element for the given slot number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElectricalSystem GetCircuitByCell(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCircuitByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As ElectricalSystem
Visual C++
public:
ElectricalSystem^ GetCircuitByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number of the Body Section
nCol
Type: System..::..Int32
Column Number of the Body Section

Return Value

The circuit found at the given row and column

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCircuitIdByCell Method

[image]

Revit 2013 API
PanelScheduleView..::..GetCircuitIdByCell Method
PanelScheduleView Class See Also Send Feedback
Gets the circuit id for the given slot number

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetCircuitIdByCell(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCircuitIdByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetCircuitIdByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

ElementId of the circuit found at the given row and column

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetCombinedParamValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetCombinedParamValue Method
PanelScheduleView Class See Also Send Feedback
Returns the combined parameter text for instance view

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetCombinedParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetCombinedParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetCombinedParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
Section type
nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

The combined parameter text

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method

[image] [image]

Revit 2013 API
PanelScheduleView..::..GetFontId Method
PanelScheduleView Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetFontId(String, Double, Color) | Gets the font id for the combination of font name, size, and color
Public method | GetFontId(SectionType, Int32, Int32) | Gets the font id for the given cell

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method (String, Double, Color)

[image]

Revit 2013 API
PanelScheduleView..::..GetFontId Method (String, Double, Color)
PanelScheduleView Class See Also Send Feedback
Gets the font id for the combination of font name, size, and color

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetFontId(
    string fontName,
    double fontSize,
    Color fontColor
)
Visual Basic
Public Function GetFontId ( _
    fontName As String, _
    fontSize As Double, _
    fontColor As Color _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    String^ fontName,
    double fontSize,
    Color^ fontColor
)

Parameters

fontName
Type: System..::..String
The font's name
fontSize
Type: System..::..Double
The font's size
fontColor
Type: Autodesk.Revit.DB..::..Color
The font's color

Return Value

The id of the font

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace


GetFontId Method (SectionType, Int32, Int32)

[image]

Revit 2013 API
PanelScheduleView..::..GetFontId Method (SectionType, Int32, Int32)
PanelScheduleView Class See Also Send Feedback
Gets the font id for the given cell

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetFontId(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetFontId ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetFontId(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
Section type
nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

The id of the font

See Also

PanelScheduleView Class
GetFontId Overload
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationConnectedCurrent Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationConnectedCurrent Method
PanelScheduleView Class See Also Send Feedback
Gets the Total Current for given Load Classification

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationConnectedCurrent(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationConnectedCurrent ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationConnectedCurrent(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The Connected Current for the given Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationConnectedLoad Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationConnectedLoad Method
PanelScheduleView Class See Also Send Feedback
Gets the Total Load for given Load Classification

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationConnectedLoad(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationConnectedLoad ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationConnectedLoad(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The total load for the given Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandCurrent Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationDemandCurrent Method
PanelScheduleView Class See Also Send Feedback
Gets the Demand Current for given Load Classification

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationDemandCurrent(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationDemandCurrent ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandCurrent(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The Demand Current for the given Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandFactor Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationDemandFactor Method
PanelScheduleView Class See Also Send Feedback
Gets the Demand Factor for given Load Classification

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationDemandFactor(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationDemandFactor ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandFactor(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The Demand Factor for the given Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationDemandLoad Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationDemandLoad Method
PanelScheduleView Class See Also Send Feedback
Gets the Demand Load for given Load Classification

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationDemandLoad(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationDemandLoad ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationDemandLoad(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The Demand Load for the Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationId Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationId Method
PanelScheduleView Class See Also Send Feedback
Gets the id of the associated Load Classification at the given row

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetLoadClassificationId(
    int nRow
)
Visual Basic
Public Function GetLoadClassificationId ( _
    nRow As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetLoadClassificationId(
    int nRow
)

Parameters

nRow
Type: System..::..Int32
Row number of Load Summary Section

Return Value

The element id of the Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationName Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationName Method
PanelScheduleView Class See Also Send Feedback
Gets the name of the Load Classification at the given row/column

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationName(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationName ( _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationName(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number of the Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The name of the Load Classification

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetLoadClassificationParamValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetLoadClassificationParamValue Method
PanelScheduleView Class See Also Send Feedback
Gets the load classification parameter value.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetLoadClassificationParamValue(
    ElementId parameterId,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetLoadClassificationParamValue ( _
    parameterId As ElementId, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetLoadClassificationParamValue(
    ElementId^ parameterId,
    int nRow,
    int nCol
)

Parameters

parameterId
Type: Autodesk.Revit.DB..::..ElementId
Parameter Id of the Load Classification
nRow
Type: System..::..Int32
Row Number of the Load Summary Section
nCol
Type: System..::..Int32
Column number of Load Summary Section

Return Value

The value of the Load Classification parameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetPanel Method

[image]

Revit 2013 API
PanelScheduleView..::..GetPanel Method
PanelScheduleView Class See Also Send Feedback
Gets the panel for this view

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetPanel()
Visual Basic
Public Function GetPanel As ElementId
Visual C++
public:
ElementId^ GetPanel()

Return Value

The id of the panel for this view

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetParamValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetParamValue Method
PanelScheduleView Class See Also Send Feedback
Gets the cell's text based on its type

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)
Visual Basic
Public Function GetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer _
) As String
Visual C++
public:
String^ GetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
Section of the desired parameter value
nRow
Type: System..::..Int32
Row Number of the Section
nCol
Type: System..::..Int32
Column Number of the Section

Return Value

The cell's text

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if there is no parameter at this cell
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if attempt to call on a template

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSectionData Method

[image]

Revit 2013 API
PanelScheduleView..::..GetSectionData Method
PanelScheduleView Class See Also Send Feedback
Gets section data that will be written to

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TableSectionData GetSectionData(
    SectionType sectionType
)
Visual Basic
Public Function GetSectionData ( _
    sectionType As SectionType _
) As TableSectionData
Visual C++
public:
TableSectionData^ GetSectionData(
    SectionType sectionType
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The section type

Return Value

The TableSectionData

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSlotNumberByCell Method

[image]

Revit 2013 API
PanelScheduleView..::..GetSlotNumberByCell Method
PanelScheduleView Class See Also Send Feedback
Gets the slot number in the circuit table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GetSlotNumberByCell(
    int nRow,
    int nCol
)
Visual Basic
Public Function GetSlotNumberByCell ( _
    nRow As Integer, _
    nCol As Integer _
) As Integer
Visual C++
public:
int GetSlotNumberByCell(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Column Number
nCol
Type: System..::..Int32

Return Value

Row Number

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSpareCurrentValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetSpareCurrentValue Method
PanelScheduleView Class See Also Send Feedback
Gets the value of the apparent current parameter for a spare

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetSpareCurrentValue(
    int row,
    int column,
    ElementId idCurrentParameter
)
Visual Basic
Public Function GetSpareCurrentValue ( _
    row As Integer, _
    column As Integer, _
    idCurrentParameter As ElementId _
) As Double
Visual C++
public:
double GetSpareCurrentValue(
    int row,
    int column,
    ElementId^ idCurrentParameter
)

Parameters

row
Type: System..::..Int32
A row where the valid spare is
column
Type: System..::..Int32
A column where the valid spare is
idCurrentParameter
Type: Autodesk.Revit.DB..::..ElementId
One of 4 valid current parameters: RBS_ELEC_APPARENT_CURRENT_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM

Return Value

The value of the spare's current parameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The current parameter id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The row/column combination does not represent a valid spare.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetSpareLoadValue Method

[image]

Revit 2013 API
PanelScheduleView..::..GetSpareLoadValue Method
PanelScheduleView Class See Also Send Feedback
Gets the value of the apparent load parameter for a spare

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetSpareLoadValue(
    int row,
    int column,
    ElementId idLoadParameter
)
Visual Basic
Public Function GetSpareLoadValue ( _
    row As Integer, _
    column As Integer, _
    idLoadParameter As ElementId _
) As Double
Visual C++
public:
double GetSpareLoadValue(
    int row,
    int column,
    ElementId^ idLoadParameter
)

Parameters

row
Type: System..::..Int32
A row where the valid spare is
column
Type: System..::..Int32
A column where the valid spare is
idLoadParameter
Type: Autodesk.Revit.DB..::..ElementId
One of 4 valid load parameters: RBS_ELEC_APPARENT_LOAD, RBS_ELEC_APPARENT_LOAD_PHASEA, RBS_ELEC_APPARENT_LOAD_PHASEB, RBS_ELEC_APPARENT_LOAD_PHASEC

Return Value

The value of the spare's load parameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The load parameter id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The row/column combination does not represent a valid spare.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetTableData Method

[image]

Revit 2013 API
PanelScheduleView..::..GetTableData Method
PanelScheduleView Class See Also Send Feedback
Gets table data that can be written to

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PanelScheduleData GetTableData()
Visual Basic
Public Function GetTableData As PanelScheduleData
Visual C++
public:
PanelScheduleData^ GetTableData()

Return Value

The PanelScheduleData

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


GetTemplate Method

[image]

Revit 2013 API
PanelScheduleView..::..GetTemplate Method
PanelScheduleView Class See Also Send Feedback
Gets the template for this view (to set the template, you must go through generateInstanceFromTemplate)

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId GetTemplate()
Visual Basic
Public Function GetTemplate As ElementId
Visual C++
public:
ElementId^ GetTemplate()

Return Value

The template id for this view

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsCellInPhaseLoads Method

[image]

Revit 2013 API
PanelScheduleView..::..IsCellInPhaseLoads Method
PanelScheduleView Class See Also Send Feedback
Check if this cell in the phase loads

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsCellInPhaseLoads(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsCellInPhaseLoads ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsCellInPhaseLoads(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

True if this cell in the phase loads, false otherwise

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsColumnInLoadSummary Method

[image]

Revit 2013 API
PanelScheduleView..::..IsColumnInLoadSummary Method
PanelScheduleView Class See Also Send Feedback
Check if this column in the load summary

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsColumnInLoadSummary(
    int nCol
)
Visual Basic
Public Function IsColumnInLoadSummary ( _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsColumnInLoadSummary(
    int nCol
)

Parameters

nCol
Type: System..::..Int32
Column Number

Return Value

Check if this column in the load summary

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsPanelScheduleTemplate Method

[image]

Revit 2013 API
PanelScheduleView..::..IsPanelScheduleTemplate Method
PanelScheduleView Class See Also Send Feedback
Check if this is a panel schedule template.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPanelScheduleTemplate()
Visual Basic
Public Function IsPanelScheduleTemplate As Boolean
Visual C++
public:
bool IsPanelScheduleTemplate()

Return Value

Check if this is a panel schedule template.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsRowInCircuitTable Method

[image]

Revit 2013 API
PanelScheduleView..::..IsRowInCircuitTable Method
PanelScheduleView Class See Also Send Feedback
Check if this row in the circuit table

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsRowInCircuitTable(
    int nRow
)
Visual Basic
Public Function IsRowInCircuitTable ( _
    nRow As Integer _
) As Boolean
Visual C++
public:
bool IsRowInCircuitTable(
    int nRow
)

Parameters

nRow
Type: System..::..Int32
Row Number

Return Value

True if this row in the circuit table, false otherwise.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSlotGrouped Method

[image]

Revit 2013 API
PanelScheduleView..::..IsSlotGrouped Method
PanelScheduleView Class See Also Send Feedback
Check if the slot is in a group

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int IsSlotGrouped(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsSlotGrouped ( _
    nRow As Integer, _
    nCol As Integer _
) As Integer
Visual C++
public:
int IsSlotGrouped(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

It is not in a group if the return value equals to 0. It is in a group if the return value is greater than 0 and the return value is the group number.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSlotLocked Method

[image]

Revit 2013 API
PanelScheduleView..::..IsSlotLocked Method
PanelScheduleView Class See Also Send Feedback
Check if the circuit slot in this cell is locked.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSlotLocked(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsSlotLocked ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSlotLocked(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

True if the circuit slot in this cell is locked, false otherwise

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSpace Method

[image]

Revit 2013 API
PanelScheduleView..::..IsSpace Method
PanelScheduleView Class See Also Send Feedback
Check if the selected cell is a space

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSpace(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsSpace ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSpace(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

True if the selected cell is a space, false otherwise

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


IsSpare Method

[image]

Revit 2013 API
PanelScheduleView..::..IsSpare Method
PanelScheduleView Class See Also Send Feedback
Check if the circuit is a spare

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsSpare(
    int nRow,
    int nCol
)
Visual Basic
Public Function IsSpare ( _
    nRow As Integer, _
    nCol As Integer _
) As Boolean
Visual C++
public:
bool IsSpare(
    int nRow,
    int nCol
)

Parameters

nRow
Type: System..::..Int32
Row Number
nCol
Type: System..::..Int32
Column Number

Return Value

True if the circuit is a spare, false otherwise

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


Print Method

[image] [image]

Revit 2013 API
PanelScheduleView..::..Print Method
PanelScheduleView Class See Also Send Feedback
Print this view.

Overload List

 | Name | Description
Public method | Print()()()() | Print this view with the default view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(Boolean) | Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)
Public method | Print(View) | Print this view with the given view template and using the print setting of the current active document. (Inherited from View.)
Public method | Print(View, Boolean) | Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document. (Inherited from View.)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


RefreshAllFontIds Method

[image]

Revit 2013 API
PanelScheduleView..::..RefreshAllFontIds Method
PanelScheduleView Class See Also Send Feedback
Clean all existing font ids and create all font ids based on the table cell styles

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RefreshAllFontIds()
Visual Basic
Public Sub RefreshAllFontIds
Visual C++
public:
void RefreshAllFontIds()

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


SetParamValue Method

[image]

Revit 2013 API
PanelScheduleView..::..SetParamValue Method
PanelScheduleView Class See Also Send Feedback
Sets the text for the given cell, returns true if successful, false otherwise

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    string sValue
)
Visual Basic
Public Function SetParamValue ( _
    sectionType As SectionType, _
    nRow As Integer, _
    nCol As Integer, _
    sValue As String _
) As Boolean
Visual C++
public:
bool SetParamValue(
    SectionType sectionType,
    int nRow,
    int nCol,
    String^ sValue
)

Parameters

sectionType
Type: Autodesk.Revit.DB..::..SectionType
The associated section
nRow
Type: System..::..Int32
Row Number of the Section
nCol
Type: System..::..Int32
Column Number of the Section
sValue
Type: System..::..String
String value to set the parameter

Return Value

Returns whether the function succeeded

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown if there is no parameter at this cell
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if attempt to call on a template

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


SetSpareCurrentValue Method

[image]

Revit 2013 API
PanelScheduleView..::..SetSpareCurrentValue Method
PanelScheduleView Class See Also Send Feedback
Sets the value of the apparent current parameter for a spare

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSpareCurrentValue(
    int row,
    int column,
    ElementId idCurrentParameter,
    double value
)
Visual Basic
Public Sub SetSpareCurrentValue ( _
    row As Integer, _
    column As Integer, _
    idCurrentParameter As ElementId, _
    value As Double _
)
Visual C++
public:
void SetSpareCurrentValue(
    int row,
    int column,
    ElementId^ idCurrentParameter,
    double value
)

Parameters

row
Type: System..::..Int32
A row where the valid spare is
column
Type: System..::..Int32
A column where the valid spare is
idCurrentParameter
Type: Autodesk.Revit.DB..::..ElementId
One of 4 valid current parameters: RBS_ELEC_APPARENT_CURRENT_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM
value
Type: System..::..Double
The value of the spare's current for the given parameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The current parameter id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for value must be non-negative.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The row/column combination does not represent a valid spare.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


SetSpareLoadValue Method

[image]

Revit 2013 API
PanelScheduleView..::..SetSpareLoadValue Method
PanelScheduleView Class See Also Send Feedback
Sets the value of the apparent load parameter for a spare

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSpareLoadValue(
    int row,
    int column,
    ElementId idLoadParameter,
    double value
)
Visual Basic
Public Sub SetSpareLoadValue ( _
    row As Integer, _
    column As Integer, _
    idLoadParameter As ElementId, _
    value As Double _
)
Visual C++
public:
void SetSpareLoadValue(
    int row,
    int column,
    ElementId^ idLoadParameter,
    double value
)

Parameters

row
Type: System..::..Int32
A row where the valid spare is
column
Type: System..::..Int32
A column where the valid spare is
idLoadParameter
Type: Autodesk.Revit.DB..::..ElementId
One of 4 valid load parameters: RBS_ELEC_APPARENT_LOAD, RBS_ELEC_APPARENT_LOAD_PHASEA, RBS_ELEC_APPARENT_LOAD_PHASEB, RBS_ELEC_APPARENT_LOAD_PHASEC
value
Type: System..::..Double
The value of the spare's load for the given parameter

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The load parameter id is not valid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for value must be non-negative.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The row/column combination does not represent a valid spare.

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


PanelScheduleView Properties

[image] [image]

Revit 2013 API
PanelScheduleView Properties
PanelScheduleView Class See Also Send Feedback

The PanelScheduleView type exposes the following members.

Properties

 | Name | Description
Public property | AnalysisDisplayStyleId | Element id of Analysis Display Style associated with the view. (Inherited from View.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AssociatedAssemblyInstanceId | The Id of the assembly instance that owns the assembly view. (Inherited from View.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CanBePrinted | Test whether the view can be printed. (Inherited from View.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CropBox | The crop box applied to the view. (Inherited from View.)
Public property | CropBoxActive | Whether or not the Crop Box/Region is active for the view. (Inherited from View.)
Public property | CropBoxVisible | Whether or not the Crop Box/Region is visible for the view. (Inherited from View.)
Public property | CutColorOverrideByElement | Override the cut lines' color by Element in this view. (Inherited from View.)
Public property | CutLinePatternOverrideByElement | Override the cut lines' pattern by Element in this view. (Inherited from View.)
Public property | CutLineWeightOverrideByElement | Override the cut lines' weight by Element in this view. (Inherited from View.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DetailLevel | The detail level of this view. (Inherited from View.)
Public property | Discipline | The Discipline of the view. (Inherited from View.)
Public property | DisplayStyle | The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style. (Inherited from View.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | GenLevel | The level for the view. (Inherited from View.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsTemplate | Test whether the view is a view template. (Inherited from View.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinimumColumnWidth | Gets the minimum column width; (Inherited from TableView.)
Public property | MinimumRowHeight | Gets the minimum row height; (Inherited from TableView.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | Returns the origin of the screen. (Inherited from View.)
Public property | Outline | The bounds of the view in paper space (in inches). (Inherited from View.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PartsVisibility | The visibility setting for parts in this view. (Inherited from View.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ProjColorOverrideByElement | Override the projection lines' color by Element in this view. (Inherited from View.)
Public property | ProjLinePatternOverrideByElement | Override the projection lines' pattern by Element in this view. (Inherited from View.)
Public property | ProjLineWeightOverrideByElement | Override the projection lines' weight by Element in this view. (Inherited from View.)
Public property | RightDirection | The direction towards the right side of the screen. (Inherited from View.)
Public property | Scale | The scale of the view. (Inherited from View.)
Public property | SketchPlane | The sketch plane assigned to the view for model curve creation. (Inherited from View.)
Public property | SunAndShadowSettings | The sun and shadow settings assigned to the view for shadow calculation and rendering. (Inherited from View.)
Public property | TargetId | the element id of the element that is being viewed; (Inherited from TableView.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpDirection | The direction towards the top of the screen. (Inherited from View.)
Public property | ViewDirection | The direction towards the viewer. (Inherited from View.)
Public property | ViewName | The name of the view. (Inherited from View.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | ViewTemplateId | Id of template that controls view parameters. Parameters controlled by the template cannot be changed directly in this view. Any change to controlled parameters in the template will cause change of the corresponding parameters in this view. To get all template parameters call template's method getTemplateParameterIds. To get parameters that are not controlled by the template call template's method getNonControlledTemplateParameterIds. (Inherited from View.)
Public property | ViewType | The type of the view. (Inherited from View.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PanelScheduleView Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
PanelScheduleView..::..Parameter Property
PanelScheduleView Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PanelScheduleView Class
PanelScheduleView Members
Autodesk.Revit.DB.Electrical Namespace


PowerFactorStateType Enumeration

[image]

Revit 2013 API
PowerFactorStateType Enumeration
See Also Send Feedback
An enumerated type listing all the possible power factor state types for a connector object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PowerFactorStateType
Visual Basic
Public Enumeration PowerFactorStateType
Visual C++
public enum class PowerFactorStateType

Members

Member name | Description
Leading | Power FactorState Type is Leading.
Lagging | Power FactorState Type is Lagging.

See Also

Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Class

[image]

Revit 2013 API
TemperatureRatingType Class
Members See Also Send Feedback
Represents temperature rating type definition information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TemperatureRatingType : ElementType
Visual Basic
Public Class TemperatureRatingType _
    Inherits ElementType
Visual C++
public ref class TemperatureRatingType : public ElementType

Remarks

Temperature rating type is defined based on corresponding wire material type. It includes type information such as wire size, insulation type, correction factor, etc. Only the temperature rating types which are retrieved from WireMaterialType can work well, so don't retrieve it from Revit document directly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..TemperatureRatingType

See Also

TemperatureRatingType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Members

[image] [image]

Revit 2013 API
TemperatureRatingType Members
TemperatureRatingType Class Methods Properties See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Methods

[image] [image]

Revit 2013 API
TemperatureRatingType Methods
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Methods

 | Name | Description
Public method | AddCorrectionFactor | Add a new electrical correction factor type to this temperature rating type.
Public method | AddInsulationType | Add a new kind of insulation type into this temperature rating type.
Public method | AddWireSize | Add a new kind of wire size type into this temperature rating type.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveCorrectionFactor | Remove an existing correction factor from this temperature rating type in Revit MEP project.
Public method | RemoveInsulationType | Remove an existing insulation type from this temperature rating type.
Public method | RemoveWireSize | Remove an existing wire size type from this temperature rating type.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddCorrectionFactor Method

[image]

Revit 2013 API
TemperatureRatingType..::..AddCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Add a new electrical correction factor type to this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CorrectionFactor AddCorrectionFactor(
    long temperature,
    double factor
)
Visual Basic
Public Function AddCorrectionFactor ( _
    temperature As Long, _
    factor As Double _
) As CorrectionFactor
Visual C++
public:
CorrectionFactor^ AddCorrectionFactor(
    long long temperature,
    double factor
)

Parameters

temperature
Type: System..::..Int64
Temperature of correction factor to be added.
factor
Type: System..::..Double
Factor of correction factor to be added.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddInsulationType Method

[image]

Revit 2013 API
TemperatureRatingType..::..AddInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of insulation type into this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InsulationType AddInsulationType(
    string name
)
Visual Basic
Public Function AddInsulationType ( _
    name As String _
) As InsulationType
Visual C++
public:
InsulationType^ AddInsulationType(
    String^ name
)

Parameters

name
Type: System..::..String
Name of insulation type symbol to be constructed and added.

Return Value

Constructed insulation type instance.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


AddWireSize Method

[image]

Revit 2013 API
TemperatureRatingType..::..AddWireSize Method
TemperatureRatingType Class See Also Send Feedback
Add a new kind of wire size type into this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSize AddWireSize(
    string size,
    long ampacity,
    double diameter
)
Visual Basic
Public Function AddWireSize ( _
    size As String, _
    ampacity As Long, _
    diameter As Double _
) As WireSize
Visual C++
public:
WireSize^ AddWireSize(
    String^ size,
    long long ampacity,
    double diameter
)

Parameters

size
Type: System..::..String
Size of wire size.
ampacity
Type: System..::..Int64
Ampacity of wire size to be added.
diameter
Type: System..::..Double
Diameter of wire size to be added.

Return Value

Constructed wire size type.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveCorrectionFactor Method

[image]

Revit 2013 API
TemperatureRatingType..::..RemoveCorrectionFactor Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing correction factor from this temperature rating type in Revit MEP project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveCorrectionFactor(
    CorrectionFactor correctionFactor
)
Visual Basic
Public Sub RemoveCorrectionFactor ( _
    correctionFactor As CorrectionFactor _
)
Visual C++
public:
void RemoveCorrectionFactor(
    CorrectionFactor^ correctionFactor
)

Parameters

correctionFactor
Type: Autodesk.Revit.DB.Electrical..::..CorrectionFactor
The correction factor to be removed.

Return Value

New constructed correction factor.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveInsulationType Method

[image]

Revit 2013 API
TemperatureRatingType..::..RemoveInsulationType Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing insulation type from this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveInsulationType(
    InsulationType insulationType
)
Visual Basic
Public Sub RemoveInsulationType ( _
    insulationType As InsulationType _
)
Visual C++
public:
void RemoveInsulationType(
    InsulationType^ insulationType
)

Parameters

insulationType
Type: Autodesk.Revit.DB.Electrical..::..InsulationType
Insulation type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The last one insulation type of project and any one which is in use by a wire type can't be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveWireSize Method

[image]

Revit 2013 API
TemperatureRatingType..::..RemoveWireSize Method
TemperatureRatingType Class See Also Send Feedback
Remove an existing wire size type from this temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveWireSize(
    WireSize wireSize
)
Visual Basic
Public Sub RemoveWireSize ( _
    wireSize As WireSize _
)
Visual C++
public:
void RemoveWireSize(
    WireSize^ wireSize
)

Parameters

wireSize
Type: Autodesk.Revit.DB.Electrical..::..WireSize
The wire size type to be removed.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingType Properties

[image] [image]

Revit 2013 API
TemperatureRatingType Properties
TemperatureRatingType Class See Also Send Feedback

The TemperatureRatingType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CorrectionFactors | Get all correction factors defined in this temperature rating type and its corresponding material type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | InsulationTypes | Get all insulation types defined in this temperature rating type and its corresponding material type.
Public property | IsInUse | Indicate whether the temperature rating type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaterialType | Get the material type information which this temperature rating type belongs to.
Public property | Name | Get name of temperature rating type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireSizes | Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


CorrectionFactors Property

[image]

Revit 2013 API
TemperatureRatingType..::..CorrectionFactors Property
TemperatureRatingType Class See Also Send Feedback
Get all correction factors defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CorrectionFactorSet CorrectionFactors { get; }
Visual Basic
Public ReadOnly Property CorrectionFactors As CorrectionFactorSet
    Get
Visual C++
public:
property CorrectionFactorSet^ CorrectionFactors {
    CorrectionFactorSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


InsulationTypes Property

[image]

Revit 2013 API
TemperatureRatingType..::..InsulationTypes Property
TemperatureRatingType Class See Also Send Feedback
Get all insulation types defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InsulationTypeSet InsulationTypes { get; }
Visual Basic
Public ReadOnly Property InsulationTypes As InsulationTypeSet
    Get
Visual C++
public:
property InsulationTypeSet^ InsulationTypes {
    InsulationTypeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
TemperatureRatingType..::..IsInUse Property
TemperatureRatingType Class See Also Send Feedback
Indicate whether the temperature rating type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


MaterialType Property

[image]

Revit 2013 API
TemperatureRatingType..::..MaterialType Property
TemperatureRatingType Class See Also Send Feedback
Get the material type information which this temperature rating type belongs to.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialType MaterialType { get; }
Visual Basic
Public ReadOnly Property MaterialType As WireMaterialType
    Get
Visual C++
public:
property WireMaterialType^ MaterialType {
    WireMaterialType^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2013 API
TemperatureRatingType..::..Name Property
TemperatureRatingType Class See Also Send Feedback
Get name of temperature rating type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Set name can't be supported.

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
TemperatureRatingType..::..Parameter Property
TemperatureRatingType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TemperatureRatingType Class
TemperatureRatingType Members
Autodesk.Revit.DB.Electrical Namespace


WireSizes Property

[image]

Revit 2013 API
TemperatureRatingType..::..WireSizes Property
TemperatureRatingType Class See Also Send Feedback
Get all electrical wire sizes defined in this temperature rating type and its corresponding material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSizeSet WireSizes { get; }
Visual Basic
Public ReadOnly Property WireSizes As WireSizeSet
    Get
Visual C++
public:
property WireSizeSet^ WireSizes {
    WireSizeSet^ get ();
}

See Also

TemperatureRatingType Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Class

[image]

Revit 2013 API
TemperatureRatingTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TemperatureRatingTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class TemperatureRatingTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TemperatureRatingTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSet

See Also

TemperatureRatingTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Members

[image] [image]

Revit 2013 API
TemperatureRatingTypeSet Members
TemperatureRatingTypeSet Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | TemperatureRatingTypeSet | Initializes a new instance of the TemperatureRatingTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Constructor

[image]

Revit 2013 API
TemperatureRatingTypeSet Constructor
TemperatureRatingTypeSet Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TemperatureRatingTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
TemperatureRatingTypeSet()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Methods

[image] [image]

Revit 2013 API
TemperatureRatingTypeSet Methods
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..Clear Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..Contains Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    TemperatureRatingType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..Erase Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    TemperatureRatingType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As TemperatureRatingType _
) As Integer
Visual C++
public:
virtual int Erase(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..ForwardIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ForwardIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..GetEnumerator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..Insert Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    TemperatureRatingType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As TemperatureRatingType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TemperatureRatingType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..ReverseIterator Method
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TemperatureRatingTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As TemperatureRatingTypeSetIterator
Visual C++
public:
virtual TemperatureRatingTypeSetIterator^ ReverseIterator()

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSet Properties

[image] [image]

Revit 2013 API
TemperatureRatingTypeSet Properties
TemperatureRatingTypeSet Class See Also Send Feedback

The TemperatureRatingTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..IsEmpty Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
TemperatureRatingTypeSet..::..Size Property
TemperatureRatingTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TemperatureRatingTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Class

[image]

Revit 2013 API
TemperatureRatingTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class TemperatureRatingTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class TemperatureRatingTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TemperatureRatingTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..TemperatureRatingTypeSetIterator

See Also

TemperatureRatingTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Members

[image] [image]

Revit 2013 API
TemperatureRatingTypeSetIterator Members
TemperatureRatingTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | TemperatureRatingTypeSetIterator | Initializes a new instance of the TemperatureRatingTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Constructor

[image]

Revit 2013 API
TemperatureRatingTypeSetIterator Constructor
TemperatureRatingTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the TemperatureRatingTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TemperatureRatingTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
TemperatureRatingTypeSetIterator()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Methods

[image] [image]

Revit 2013 API
TemperatureRatingTypeSetIterator Methods
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
TemperatureRatingTypeSetIterator..::..MoveNext Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
TemperatureRatingTypeSetIterator..::..Reset Method
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatingTypeSetIterator Properties

[image] [image]

Revit 2013 API
TemperatureRatingTypeSetIterator Properties
TemperatureRatingTypeSetIterator Class See Also Send Feedback

The TemperatureRatingTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
TemperatureRatingTypeSetIterator..::..Current Property
TemperatureRatingTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

TemperatureRatingTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Class

[image]

Revit 2013 API
VoltageType Class
Members See Also Send Feedback
Represents electrical voltage type. An electrical voltage type define a range of voltages, and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VoltageType : ElementType
Visual Basic
Public Class VoltageType _
    Inherits ElementType
Visual C++
public ref class VoltageType : public ElementType

Remarks

Actual, minimum and maximum value of voltage type can retrieved through properties, but only can be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..VoltageType

See Also

VoltageType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageType Members

[image] [image]

Revit 2013 API
VoltageType Members
VoltageType Class Methods Properties See Also Send Feedback

The VoltageType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
Public property | MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Methods

[image] [image]

Revit 2013 API
VoltageType Methods
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetVoltageValue | Assign new values to modify voltage type, all of the unit are volt.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


SetVoltageValue Method

[image]

Revit 2013 API
VoltageType..::..SetVoltageValue Method
VoltageType Class See Also Send Feedback
Assign new values to modify voltage type, all of the unit are volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)
Visual Basic
Public Sub SetVoltageValue ( _
    actualValue As Double, _
    minValue As Double, _
    maxValue As Double _
)
Visual C++
public:
void SetVoltageValue(
    double actualValue,
    double minValue,
    double maxValue
)

Parameters

actualValue
Type: System..::..Double
minValue
Type: System..::..Double
maxValue
Type: System..::..Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Actual value can't be more than minValue or less than maxValue, and all of them can't be negative, otherwise the exception will be thrown.

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


VoltageType Properties

[image] [image]

Revit 2013 API
VoltageType Properties
VoltageType Class See Also Send Feedback

The VoltageType type exposes the following members.

Properties

 | Name | Description
Public property | ActualValue | Get actual voltage value of this voltage definition, the unit is volt.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicates whether this voltage type is in service now, such as by other distribution system.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxValue | Get upper boundary of voltage value of this voltage definition, the unit is volt.
Public property | MinValue | Get lower boundary of voltage value of this voltage definition, the unit is volt.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


ActualValue Property

[image]

Revit 2013 API
VoltageType..::..ActualValue Property
VoltageType Class See Also Send Feedback
Get actual voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualValue { get; }
Visual Basic
Public ReadOnly Property ActualValue As Double
    Get
Visual C++
public:
property double ActualValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
VoltageType..::..IsInUse Property
VoltageType Class See Also Send Feedback
Indicates whether this voltage type is in service now, such as by other distribution system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


MaxValue Property

[image]

Revit 2013 API
VoltageType..::..MaxValue Property
VoltageType Class See Also Send Feedback
Get upper boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double MaxValue { get; }
Visual Basic
Public ReadOnly Property MaxValue As Double
    Get
Visual C++
public:
property double MaxValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


MinValue Property

[image]

Revit 2013 API
VoltageType..::..MinValue Property
VoltageType Class See Also Send Feedback
Get lower boundary of voltage value of this voltage definition, the unit is volt.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double MinValue { get; }
Visual Basic
Public ReadOnly Property MinValue As Double
    Get
Visual C++
public:
property double MinValue {
    double get ();
}

See Also

VoltageType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
VoltageType..::..Parameter Property
VoltageType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

VoltageType Class
VoltageType Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Class

[image]

Revit 2013 API
VoltageTypeSet Class
Members See Also Send Feedback
A set that contains voltage types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class VoltageTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class VoltageTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class VoltageTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..VoltageTypeSet

See Also

VoltageTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Members

[image] [image]

Revit 2013 API
VoltageTypeSet Members
VoltageTypeSet Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | VoltageTypeSet | Initializes a new instance of the VoltageTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every voltage type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a voltage type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified voltage type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified voltage type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Constructor

[image]

Revit 2013 API
VoltageTypeSet Constructor
VoltageTypeSet Class See Also Send Feedback
Initializes a new instance of the VoltageTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
VoltageTypeSet()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Methods

[image] [image]

Revit 2013 API
VoltageTypeSet Methods
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every voltage type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a voltage type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified voltage type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified voltage type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
VoltageTypeSet..::..Clear Method
VoltageTypeSet Class See Also Send Feedback
Removes every voltage type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
VoltageTypeSet..::..Contains Method
VoltageTypeSet Class See Also Send Feedback
Tests for the existence of a voltage type within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    VoltageType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
The voltage type to be searched for.

Return Value

The Contains method returns True if the voltage type is within the set, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
VoltageTypeSet..::..Erase Method
VoltageTypeSet Class See Also Send Feedback
Removes a specified voltage type from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    VoltageType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As VoltageType _
) As Integer
Visual C++
public:
virtual int Erase(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
The voltage type to be erased.

Return Value

The number of voltage types that were erased from the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
VoltageTypeSet..::..ForwardIterator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
VoltageTypeSet..::..GetEnumerator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
VoltageTypeSet..::..Insert Method
VoltageTypeSet Class See Also Send Feedback
Insert the specified voltage type into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    VoltageType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As VoltageType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    VoltageType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..VoltageType
The voltage type to be inserted into the set.

Return Value

Returns whether the voltage type was inserted into the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
VoltageTypeSet..::..ReverseIterator Method
VoltageTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual VoltageTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As VoltageTypeSetIterator
Visual C++
public:
virtual VoltageTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSet Properties

[image] [image]

Revit 2013 API
VoltageTypeSet Properties
VoltageTypeSet Class See Also Send Feedback

The VoltageTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of voltage types that are in the set.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
VoltageTypeSet..::..IsEmpty Property
VoltageTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
VoltageTypeSet..::..Size Property
VoltageTypeSet Class See Also Send Feedback
Returns the number of voltage types that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

VoltageTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Class

[image]

Revit 2013 API
VoltageTypeSetIterator Class
Members See Also Send Feedback
An iterator to a voltage type set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class VoltageTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class VoltageTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class VoltageTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..VoltageTypeSetIterator

See Also

VoltageTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Members

[image] [image]

Revit 2013 API
VoltageTypeSetIterator Members
VoltageTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | VoltageTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Constructor

[image]

Revit 2013 API
VoltageTypeSetIterator Constructor
VoltageTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public VoltageTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
VoltageTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Methods

[image] [image]

Revit 2013 API
VoltageTypeSetIterator Methods
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
VoltageTypeSetIterator..::..MoveNext Method
VoltageTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
VoltageTypeSetIterator..::..Reset Method
VoltageTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


VoltageTypeSetIterator Properties

[image] [image]

Revit 2013 API
VoltageTypeSetIterator Properties
VoltageTypeSetIterator Class See Also Send Feedback

The VoltageTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
VoltageTypeSetIterator..::..Current Property
VoltageTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

VoltageTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Wire Class

[image]

Revit 2013 API
Wire Class
Members See Also Send Feedback
An object to represent electrical wire in Revit MEP product.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Wire : HostObject
Visual Basic
Public Class Wire _
    Inherits HostObject
Visual C++
public ref class Wire : public HostObject

Remarks

Adding wiring to a project is optional. you can create circuits and maintain the information associated with them without adding wiring to the project.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB.Electrical..::..Wire

See Also

Wire Members
Autodesk.Revit.DB.Electrical Namespace


Wire Members

[image] [image]

Revit 2013 API
Wire Members
Wire Class Methods Properties See Also Send Feedback

The Wire type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Get connector manager of the wire.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorNum | The ground conductor number. Its default value is zero after created.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WiringType | Get or set wiring type(Arc or chamfer) for the wire.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Wire Methods

[image] [image]

Revit 2013 API
Wire Methods
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Wire Properties

[image] [image]

Revit 2013 API
Wire Properties
Wire Class See Also Send Feedback

The Wire type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Get connector manager of the wire.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorNum | The ground conductor number. Its default value is zero after created.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HotConductorNum | Get or set hot conductor number. Its default value is zero after created.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NeutralConductorNum | The neutral conductor number. Its default value is zero after created.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WiringType | Get or set wiring type(Arc or chamfer) for the wire.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


ConnectorManager Property

[image]

Revit 2013 API
Wire..::..ConnectorManager Property
Wire Class See Also Send Feedback
Get connector manager of the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConnectorManager ConnectorManager { get; }
Visual Basic
Public ReadOnly Property ConnectorManager As ConnectorManager
    Get
Visual C++
public:
property ConnectorManager^ ConnectorManager {
    ConnectorManager^ get ();
}

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorNum Property

[image]

Revit 2013 API
Wire..::..GroundConductorNum Property
Wire Class See Also Send Feedback
The ground conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int GroundConductorNum { get; set; }
Visual Basic
Public Property GroundConductorNum As Integer
    Get
    Set
Visual C++
public:
property int GroundConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


HotConductorNum Property

[image]

Revit 2013 API
Wire..::..HotConductorNum Property
Wire Class See Also Send Feedback
Get or set hot conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int HotConductorNum { get; set; }
Visual Basic
Public Property HotConductorNum As Integer
    Get
    Set
Visual C++
public:
property int HotConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


NeutralConductorNum Property

[image]

Revit 2013 API
Wire..::..NeutralConductorNum Property
Wire Class See Also Send Feedback
The neutral conductor number. Its default value is zero after created.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NeutralConductorNum { get; set; }
Visual Basic
Public Property NeutralConductorNum As Integer
    Get
    Set
Visual C++
public:
property int NeutralConductorNum {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Exception is thrown when trying to assign a negative value.

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
Wire..::..Parameter Property
Wire Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Wire Class
Wire Members
Autodesk.Revit.DB.Electrical Namespace


WiringType Property

[image]

Revit 2013 API
Wire..::..WiringType Property
Wire Class See Also Send Feedback
Get or set wiring type(Arc or chamfer) for the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WiringType WiringType { get; set; }
Visual Basic
Public Property WiringType As WiringType
    Get
    Set
Visual C++
public:
property WiringType WiringType {
    WiringType get ();
    void set (WiringType value);
}

See Also

Wire Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Class

[image]

Revit 2013 API
WireConduitType Class
Members See Also Send Feedback
Represents a specific conduit type of wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireConduitType : APIObject
Visual Basic
Public Class WireConduitType _
    Inherits APIObject
Visual C++
public ref class WireConduitType : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireConduitType

See Also

WireConduitType Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Members

[image] [image]

Revit 2013 API
WireConduitType Members
WireConduitType Class Methods Properties See Also Send Feedback

The WireConduitType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name |

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Methods

[image] [image]

Revit 2013 API
WireConduitType Methods
WireConduitType Class See Also Send Feedback

The WireConduitType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitType Properties

[image] [image]

Revit 2013 API
WireConduitType Properties
WireConduitType Class See Also Send Feedback

The WireConduitType type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name |

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2013 API
WireConduitType..::..Name Property
WireConduitType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

WireConduitType Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Class

[image]

Revit 2013 API
WireConduitTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireConduitTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class WireConduitTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireConduitTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSet

See Also

WireConduitTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Members

[image] [image]

Revit 2013 API
WireConduitTypeSet Members
WireConduitTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireConduitTypeSet | Initializes a new instance of the WireConduitTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Constructor

[image]

Revit 2013 API
WireConduitTypeSet Constructor
WireConduitTypeSet Class See Also Send Feedback
Initializes a new instance of the WireConduitTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireConduitTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
WireConduitTypeSet()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Methods

[image] [image]

Revit 2013 API
WireConduitTypeSet Methods
WireConduitTypeSet Class See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
WireConduitTypeSet..::..Clear Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
WireConduitTypeSet..::..Contains Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    WireConduitType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As WireConduitType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
WireConduitTypeSet..::..Erase Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    WireConduitType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As WireConduitType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
WireConduitTypeSet..::..ForwardIterator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireConduitTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WireConduitTypeSetIterator
Visual C++
public:
virtual WireConduitTypeSetIterator^ ForwardIterator()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
WireConduitTypeSet..::..GetEnumerator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
WireConduitTypeSet..::..Insert Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    WireConduitType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As WireConduitType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireConduitType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireConduitType

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
WireConduitTypeSet..::..ReverseIterator Method
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireConduitTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WireConduitTypeSetIterator
Visual C++
public:
virtual WireConduitTypeSetIterator^ ReverseIterator()

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSet Properties

[image] [image]

Revit 2013 API
WireConduitTypeSet Properties
WireConduitTypeSet Class See Also Send Feedback

The WireConduitTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
WireConduitTypeSet..::..IsEmpty Property
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireConduitTypeSet..::..Size Property
WireConduitTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireConduitTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Class

[image]

Revit 2013 API
WireConduitTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WireConduitTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WireConduitTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireConduitTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireConduitTypeSetIterator

See Also

WireConduitTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Members

[image] [image]

Revit 2013 API
WireConduitTypeSetIterator Members
WireConduitTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WireConduitTypeSetIterator | Initializes a new instance of the WireConduitTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Constructor

[image]

Revit 2013 API
WireConduitTypeSetIterator Constructor
WireConduitTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireConduitTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireConduitTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WireConduitTypeSetIterator()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Methods

[image] [image]

Revit 2013 API
WireConduitTypeSetIterator Methods
WireConduitTypeSetIterator Class See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
WireConduitTypeSetIterator..::..MoveNext Method
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
WireConduitTypeSetIterator..::..Reset Method
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireConduitTypeSetIterator Properties

[image] [image]

Revit 2013 API
WireConduitTypeSetIterator Properties
WireConduitTypeSetIterator Class See Also Send Feedback

The WireConduitTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
WireConduitTypeSetIterator..::..Current Property
WireConduitTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

WireConduitTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Class

[image]

Revit 2013 API
WireMaterialType Class
Members See Also Send Feedback
Represents electrical wire material type definition information of wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireMaterialType : ElementType
Visual Basic
Public Class WireMaterialType _
    Inherits ElementType
Visual C++
public ref class WireMaterialType : public ElementType

Remarks

All the other properties of wire type are based on wire material type. Only the wire material types which are retrieved from ElectricalSetting can work well, so don't retrieve it from Revit project directly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..WireMaterialType

See Also

WireMaterialType Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Members

[image] [image]

Revit 2013 API
WireMaterialType Members
WireMaterialType Class Methods Properties See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get name of wire material type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Methods

[image] [image]

Revit 2013 API
WireMaterialType Methods
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Methods

 | Name | Description
Public method | AddGroundConductorSize | Add new electrical ground conductor size type into this material type.
Public method | AddTemperatureRatingType | Add a new temperature rating type into material type.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveGroundConductorSize | Remove an existing ground conductor size from this material type.
Public method | RemoveTemperatureRatingType | Remove an existing temperature rating type from this material type.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


AddGroundConductorSize Method

[image]

Revit 2013 API
WireMaterialType..::..AddGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Add new electrical ground conductor size type into this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroundConductorSize AddGroundConductorSize(
    long ampacity,
    string size
)
Visual Basic
Public Function AddGroundConductorSize ( _
    ampacity As Long, _
    size As String _
) As GroundConductorSize
Visual C++
public:
GroundConductorSize^ AddGroundConductorSize(
    long long ampacity,
    String^ size
)

Parameters

ampacity
Type: System..::..Int64
Ampacity of ground conductor size to be added.
size
Type: System..::..String
Size of ground conductor size to be added.

Return Value

New added ground conductor size.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


AddTemperatureRatingType Method

[image]

Revit 2013 API
WireMaterialType..::..AddTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Add a new temperature rating type into material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TemperatureRatingType AddTemperatureRatingType(
    string name,
    TemperatureRatingType baseOn
)
Visual Basic
Public Function AddTemperatureRatingType ( _
    name As String, _
    baseOn As TemperatureRatingType _
) As TemperatureRatingType
Visual C++
public:
TemperatureRatingType^ AddTemperatureRatingType(
    String^ name,
    TemperatureRatingType^ baseOn
)

Parameters

name
Type: System..::..String
Name of temperature type to be added.
baseOn
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType
The new temperature rating will be created base on this existing temperature rating type.

Return Value

New constructed temperature rating type.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveGroundConductorSize Method

[image]

Revit 2013 API
WireMaterialType..::..RemoveGroundConductorSize Method
WireMaterialType Class See Also Send Feedback
Remove an existing ground conductor size from this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveGroundConductorSize(
    GroundConductorSize grdConductorSize
)
Visual Basic
Public Sub RemoveGroundConductorSize ( _
    grdConductorSize As GroundConductorSize _
)
Visual C++
public:
void RemoveGroundConductorSize(
    GroundConductorSize^ grdConductorSize
)

Parameters

grdConductorSize
Type: Autodesk.Revit.DB.Electrical..::..GroundConductorSize
The ground size type to be removed.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


RemoveTemperatureRatingType Method

[image]

Revit 2013 API
WireMaterialType..::..RemoveTemperatureRatingType Method
WireMaterialType Class See Also Send Feedback
Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveTemperatureRatingType(
    TemperatureRatingType temperatureRating
)
Visual Basic
Public Sub RemoveTemperatureRatingType ( _
    temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType(
    TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
Type: Autodesk.Revit.DB.Electrical..::..TemperatureRatingType
The temperature rating type to be removed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The last temperature rating type of project and any one used by a wire type can't be removed.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialType Properties

[image] [image]

Revit 2013 API
WireMaterialType Properties
WireMaterialType Class See Also Send Feedback

The WireMaterialType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GroundConductorSizes | Get all ground conductor size types defined in this wire material type.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsInUse | Indicate whether the wire material type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get name of wire material type. (Overrides ElementType..::..Name.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TemperatureRatings | Get all temperature rating type definitions defined in this wire material type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


GroundConductorSizes Property

[image]

Revit 2013 API
WireMaterialType..::..GroundConductorSizes Property
WireMaterialType Class See Also Send Feedback
Get all ground conductor size types defined in this wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GroundConductorSizeSet GroundConductorSizes { get; }
Visual Basic
Public ReadOnly Property GroundConductorSizes As GroundConductorSizeSet
    Get
Visual C++
public:
property GroundConductorSizeSet^ GroundConductorSizes {
    GroundConductorSizeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
WireMaterialType..::..IsInUse Property
WireMaterialType Class See Also Send Feedback
Indicate whether the wire material type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


Name Property

[image]

Revit 2013 API
WireMaterialType..::..Name Property
WireMaterialType Class See Also Send Feedback
Get name of wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Set name can't be supported.

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
WireMaterialType..::..Parameter Property
WireMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

WireMaterialType Class
WireMaterialType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRatings Property

[image]

Revit 2013 API
WireMaterialType..::..TemperatureRatings Property
WireMaterialType Class See Also Send Feedback
Get all temperature rating type definitions defined in this wire material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TemperatureRatingTypeSet TemperatureRatings { get; }
Visual Basic
Public ReadOnly Property TemperatureRatings As TemperatureRatingTypeSet
    Get
Visual C++
public:
property TemperatureRatingTypeSet^ TemperatureRatings {
    TemperatureRatingTypeSet^ get ();
}

See Also

WireMaterialType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Class

[image]

Revit 2013 API
WireMaterialTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireMaterialTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class WireMaterialTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireMaterialTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSet

See Also

WireMaterialTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Members

[image] [image]

Revit 2013 API
WireMaterialTypeSet Members
WireMaterialTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireMaterialTypeSet | Initializes a new instance of the WireMaterialTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Constructor

[image]

Revit 2013 API
WireMaterialTypeSet Constructor
WireMaterialTypeSet Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
WireMaterialTypeSet()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Methods

[image] [image]

Revit 2013 API
WireMaterialTypeSet Methods
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..Clear Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..Contains Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    WireMaterialType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..Erase Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    WireMaterialType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As WireMaterialType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..ForwardIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ForwardIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..GetEnumerator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..Insert Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    WireMaterialType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As WireMaterialType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireMaterialType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireMaterialType

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
WireMaterialTypeSet..::..ReverseIterator Method
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireMaterialTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WireMaterialTypeSetIterator
Visual C++
public:
virtual WireMaterialTypeSetIterator^ ReverseIterator()

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSet Properties

[image] [image]

Revit 2013 API
WireMaterialTypeSet Properties
WireMaterialTypeSet Class See Also Send Feedback

The WireMaterialTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
WireMaterialTypeSet..::..IsEmpty Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireMaterialTypeSet..::..Size Property
WireMaterialTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireMaterialTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Class

[image]

Revit 2013 API
WireMaterialTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WireMaterialTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WireMaterialTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireMaterialTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireMaterialTypeSetIterator

See Also

WireMaterialTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Members

[image] [image]

Revit 2013 API
WireMaterialTypeSetIterator Members
WireMaterialTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WireMaterialTypeSetIterator | Initializes a new instance of the WireMaterialTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Constructor

[image]

Revit 2013 API
WireMaterialTypeSetIterator Constructor
WireMaterialTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireMaterialTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WireMaterialTypeSetIterator()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Methods

[image] [image]

Revit 2013 API
WireMaterialTypeSetIterator Methods
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
WireMaterialTypeSetIterator..::..MoveNext Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
WireMaterialTypeSetIterator..::..Reset Method
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterialTypeSetIterator Properties

[image] [image]

Revit 2013 API
WireMaterialTypeSetIterator Properties
WireMaterialTypeSetIterator Class See Also Send Feedback

The WireMaterialTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
WireMaterialTypeSetIterator..::..Current Property
WireMaterialTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

WireMaterialTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Class

[image]

Revit 2013 API
WireSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireSet : APIObject, IEnumerable
Visual Basic
Public Class WireSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireSet

See Also

WireSet Members
Autodesk.Revit.DB.Electrical Namespace


WireSet Members

[image] [image]

Revit 2013 API
WireSet Members
WireSet Class Constructors Methods Properties See Also Send Feedback

The WireSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireSet | Initializes a new instance of the WireSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Constructor

[image]

Revit 2013 API
WireSet Constructor
WireSet Class See Also Send Feedback
Initializes a new instance of the WireSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSet()
Visual Basic
Public Sub New
Visual C++
public:
WireSet()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Methods

[image] [image]

Revit 2013 API
WireSet Methods
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
WireSet..::..Clear Method
WireSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
WireSet..::..Contains Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Wire item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
WireSet..::..Erase Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Wire item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Wire _
) As Integer
Visual C++
public:
virtual int Erase(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
WireSet..::..ForwardIterator Method
WireSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
WireSet..::..GetEnumerator Method
WireSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
WireSet..::..Insert Method
WireSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Wire item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Wire _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Wire^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..Wire

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
WireSet..::..ReverseIterator Method
WireSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WireSetIterator
Visual C++
public:
virtual WireSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSet Properties

[image] [image]

Revit 2013 API
WireSet Properties
WireSet Class See Also Send Feedback

The WireSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
WireSet..::..IsEmpty Property
WireSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireSet..::..Size Property
WireSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Class

[image]

Revit 2013 API
WireSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WireSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WireSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireSetIterator

See Also

WireSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Members

[image] [image]

Revit 2013 API
WireSetIterator Members
WireSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WireSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Constructor

[image]

Revit 2013 API
WireSetIterator Constructor
WireSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WireSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Methods

[image] [image]

Revit 2013 API
WireSetIterator Methods
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
WireSetIterator..::..MoveNext Method
WireSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
WireSetIterator..::..Reset Method
WireSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSetIterator Properties

[image] [image]

Revit 2013 API
WireSetIterator Properties
WireSetIterator Class See Also Send Feedback

The WireSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
WireSetIterator..::..Current Property
WireSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Class

[image]

Revit 2013 API
WireSize Class
Members See Also Send Feedback
Represents specific electrical wire size information.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireSize : APIObject
Visual Basic
Public Class WireSize _
    Inherits APIObject
Visual C++
public ref class WireSize : public APIObject

Remarks

Wire size is defined based on corresponding wire material type and temperature rating type.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireSize

See Also

WireSize Members
Autodesk.Revit.DB.Electrical Namespace


WireSize Members

[image] [image]

Revit 2013 API
WireSize Members
WireSize Class Methods Properties See Also Send Feedback

The WireSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Public property | Diameter | Get diameter of wire.
Public property | InUse | Get or set whether the size can be used in sizing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Methods

[image] [image]

Revit 2013 API
WireSize Methods
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSize Properties

[image] [image]

Revit 2013 API
WireSize Properties
WireSize Class See Also Send Feedback

The WireSize type exposes the following members.

Properties

 | Name | Description
Public property | Ampacity | Get ampacity which be used for specifying size, the unit is ampere.
Public property | Diameter | Get diameter of wire.
Public property | InUse | Get or set whether the size can be used in sizing.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Get size symbol of wire.

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Ampacity Property

[image]

Revit 2013 API
WireSize..::..Ampacity Property
WireSize Class See Also Send Feedback
Get ampacity which be used for specifying size, the unit is ampere.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public long Ampacity { get; }
Visual Basic
Public ReadOnly Property Ampacity As Long
    Get
Visual C++
public:
property long long Ampacity {
    long long get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Diameter Property

[image]

Revit 2013 API
WireSize..::..Diameter Property
WireSize Class See Also Send Feedback
Get diameter of wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Diameter { get; }
Visual Basic
Public ReadOnly Property Diameter As Double
    Get
Visual C++
public:
property double Diameter {
    double get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


InUse Property

[image]

Revit 2013 API
WireSize..::..InUse Property
WireSize Class See Also Send Feedback
Get or set whether the size can be used in sizing.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool InUse { get; set; }
Visual Basic
Public Property InUse As Boolean
    Get
    Set
Visual C++
public:
property bool InUse {
    bool get ();
    void set (bool value);
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireSize..::..Size Property
WireSize Class See Also Send Feedback
Get size symbol of wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Size { get; }
Visual Basic
Public ReadOnly Property Size As String
    Get
Visual C++
public:
property String^ Size {
    String^ get ();
}

See Also

WireSize Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Class

[image]

Revit 2013 API
WireSizeSet Class
Members See Also Send Feedback
A set that contains wire sizes.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireSizeSet : APIObject,
    IEnumerable
Visual Basic
Public Class WireSizeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireSizeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireSizeSet

See Also

WireSizeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Members

[image] [image]

Revit 2013 API
WireSizeSet Members
WireSizeSet Class Constructors Methods Properties See Also Send Feedback

The WireSizeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireSizeSet | Initializes a new instance of the WireSizeSet class

Methods

 | Name | Description
Public method | Clear | Removes every wire size from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire size within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire size from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire size into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Constructor

[image]

Revit 2013 API
WireSizeSet Constructor
WireSizeSet Class See Also Send Feedback
Initializes a new instance of the WireSizeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSizeSet()
Visual Basic
Public Sub New
Visual C++
public:
WireSizeSet()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Methods

[image] [image]

Revit 2013 API
WireSizeSet Methods
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every wire size from the set, rendering it empty.
Public method | Contains | Tests for the existence of a wire size within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified wire size from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified wire size into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
WireSizeSet..::..Clear Method
WireSizeSet Class See Also Send Feedback
Removes every wire size from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
WireSizeSet..::..Contains Method
WireSizeSet Class See Also Send Feedback
Tests for the existence of a wire size within the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    WireSize item
)
Visual Basic
Public Overridable Function Contains ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireSize
The wire size to be searched for.

Return Value

The Contains method returns True if the wire size is within the set, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
WireSizeSet..::..Erase Method
WireSizeSet Class See Also Send Feedback
Removes a specified wire size from the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    WireSize item
)
Visual Basic
Public Overridable Function Erase ( _
    item As WireSize _
) As Integer
Visual C++
public:
virtual int Erase(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireSize
The wire size to be erased.

Return Value

The number of wire sizes that were erased from the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
WireSizeSet..::..ForwardIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
WireSizeSet..::..GetEnumerator Method
WireSizeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
WireSizeSet..::..Insert Method
WireSizeSet Class See Also Send Feedback
Insert the specified wire size into the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    WireSize item
)
Visual Basic
Public Overridable Function Insert ( _
    item As WireSize _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireSize^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireSize
The wire size to be inserted into the set.

Return Value

Returns whether the wire size was inserted into the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
WireSizeSet..::..ReverseIterator Method
WireSizeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireSizeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WireSizeSetIterator
Visual C++
public:
virtual WireSizeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSet Properties

[image] [image]

Revit 2013 API
WireSizeSet Properties
WireSizeSet Class See Also Send Feedback

The WireSizeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of wire sizes that are in the set.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
WireSizeSet..::..IsEmpty Property
WireSizeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireSizeSet..::..Size Property
WireSizeSet Class See Also Send Feedback
Returns the number of wire sizes that are in the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireSizeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Class

[image]

Revit 2013 API
WireSizeSetIterator Class
Members See Also Send Feedback
An iterator to a wire size set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WireSizeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WireSizeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireSizeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireSizeSetIterator

See Also

WireSizeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Members

[image] [image]

Revit 2013 API
WireSizeSetIterator Members
WireSizeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WireSizeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Constructor

[image]

Revit 2013 API
WireSizeSetIterator Constructor
WireSizeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSizeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WireSizeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Methods

[image] [image]

Revit 2013 API
WireSizeSetIterator Methods
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
WireSizeSetIterator..::..MoveNext Method
WireSizeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
WireSizeSetIterator..::..Reset Method
WireSizeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireSizeSetIterator Properties

[image] [image]

Revit 2013 API
WireSizeSetIterator Properties
WireSizeSetIterator Class See Also Send Feedback

The WireSizeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
WireSizeSetIterator..::..Current Property
WireSizeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

WireSizeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireType Class

[image]

Revit 2013 API
WireType Class
Members See Also Send Feedback
Represents a specific wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireType : ElementType
Visual Basic
Public Class WireType _
    Inherits ElementType
Visual C++
public ref class WireType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..WireType

See Also

WireType Members
Autodesk.Revit.DB.Electrical Namespace


WireType Members

[image] [image]

Revit 2013 API
WireType Members
WireType Class Methods Properties See Also Send Feedback

The WireType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Conduit | The conduit type of the wire type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Insulation | The insulation type.
Public property | IsInUse | Indicates whether the wire type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSize | The max size of the wire type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NeutralMultiplier | The neutral multiplier type of the wire type.
Public property | NeutralRequired | Whether or not the neutral point is required.
Public property | NeutralSize | The maximum neutral size of the wire type.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TemperatureRating | The temperature rating type of the wire type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireMaterial | The material type of the wire type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireType Methods

[image] [image]

Revit 2013 API
WireType Methods
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireType Properties

[image] [image]

Revit 2013 API
WireType Properties
WireType Class See Also Send Feedback

The WireType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Conduit | The conduit type of the wire type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Insulation | The insulation type.
Public property | IsInUse | Indicates whether the wire type is in use.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSize | The max size of the wire type.
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | NeutralMultiplier | The neutral multiplier type of the wire type.
Public property | NeutralRequired | Whether or not the neutral point is required.
Public property | NeutralSize | The maximum neutral size of the wire type.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TemperatureRating | The temperature rating type of the wire type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireMaterial | The material type of the wire type.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Conduit Property

[image]

Revit 2013 API
WireType..::..Conduit Property
WireType Class See Also Send Feedback
The conduit type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireConduitType Conduit { get; set; }
Visual Basic
Public Property Conduit As WireConduitType
    Get
    Set
Visual C++
public:
property WireConduitType^ Conduit {
    WireConduitType^ get ();
    void set (WireConduitType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Insulation Property

[image]

Revit 2013 API
WireType..::..Insulation Property
WireType Class See Also Send Feedback
The insulation type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public InsulationType Insulation { get; set; }
Visual Basic
Public Property Insulation As InsulationType
    Get
    Set
Visual C++
public:
property InsulationType^ Insulation {
    InsulationType^ get ();
    void set (InsulationType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


IsInUse Property

[image]

Revit 2013 API
WireType..::..IsInUse Property
WireType Class See Also Send Feedback
Indicates whether the wire type is in use.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsInUse { get; }
Visual Basic
Public ReadOnly Property IsInUse As Boolean
    Get
Visual C++
public:
property bool IsInUse {
    bool get ();
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


MaxSize Property

[image]

Revit 2013 API
WireType..::..MaxSize Property
WireType Class See Also Send Feedback
The max size of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireSize MaxSize { get; set; }
Visual Basic
Public Property MaxSize As WireSize
    Get
    Set
Visual C++
public:
property WireSize^ MaxSize {
    WireSize^ get ();
    void set (WireSize^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralMultiplier Property

[image]

Revit 2013 API
WireType..::..NeutralMultiplier Property
WireType Class See Also Send Feedback
The neutral multiplier type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double NeutralMultiplier { get; set; }
Visual Basic
Public Property NeutralMultiplier As Double
    Get
    Set
Visual C++
public:
property double NeutralMultiplier {
    double get ();
    void set (double value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralRequired Property

[image]

Revit 2013 API
WireType..::..NeutralRequired Property
WireType Class See Also Send Feedback
Whether or not the neutral point is required.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool NeutralRequired { get; set; }
Visual Basic
Public Property NeutralRequired As Boolean
    Get
    Set
Visual C++
public:
property bool NeutralRequired {
    bool get ();
    void set (bool value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


NeutralSize Property

[image]

Revit 2013 API
WireType..::..NeutralSize Property
WireType Class See Also Send Feedback
The maximum neutral size of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public NeutralMode NeutralSize { get; set; }
Visual Basic
Public Property NeutralSize As NeutralMode
    Get
    Set
Visual C++
public:
property NeutralMode NeutralSize {
    NeutralMode get ();
    void set (NeutralMode value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


Parameter Property

[image] [image]

Revit 2013 API
WireType..::..Parameter Property
WireType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

WireType Class
WireType Members
Autodesk.Revit.DB.Electrical Namespace


TemperatureRating Property

[image]

Revit 2013 API
WireType..::..TemperatureRating Property
WireType Class See Also Send Feedback
The temperature rating type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TemperatureRatingType TemperatureRating { get; set; }
Visual Basic
Public Property TemperatureRating As TemperatureRatingType
    Get
    Set
Visual C++
public:
property TemperatureRatingType^ TemperatureRating {
    TemperatureRatingType^ get ();
    void set (TemperatureRatingType^ value);
}

Remarks

Should retrieved from relevant WireMaterial object.

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireMaterial Property

[image]

Revit 2013 API
WireType..::..WireMaterial Property
WireType Class See Also Send Feedback
The material type of the wire type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireMaterialType WireMaterial { get; set; }
Visual Basic
Public Property WireMaterial As WireMaterialType
    Get
    Set
Visual C++
public:
property WireMaterialType^ WireMaterial {
    WireMaterialType^ get ();
    void set (WireMaterialType^ value);
}

See Also

WireType Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Class

[image]

Revit 2013 API
WireTypeSet Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class WireTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class WireTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class WireTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireTypeSet

See Also

WireTypeSet Members
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Members

[image] [image]

Revit 2013 API
WireTypeSet Members
WireTypeSet Class Constructors Methods Properties See Also Send Feedback

The WireTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | WireTypeSet | Initializes a new instance of the WireTypeSet class

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Constructor

[image]

Revit 2013 API
WireTypeSet Constructor
WireTypeSet Class See Also Send Feedback
Initializes a new instance of the WireTypeSet class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
WireTypeSet()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Methods

[image] [image]

Revit 2013 API
WireTypeSet Methods
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear |
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator |
Public method | GetEnumerator |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Clear Method

[image]

Revit 2013 API
WireTypeSet..::..Clear Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Contains Method

[image]

Revit 2013 API
WireTypeSet..::..Contains Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    WireType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Erase Method

[image]

Revit 2013 API
WireTypeSet..::..Erase Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    WireType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As WireType _
) As Integer
Visual C++
public:
virtual int Erase(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ForwardIterator Method

[image]

Revit 2013 API
WireTypeSet..::..ForwardIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ForwardIterator()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


GetEnumerator Method

[image]

Revit 2013 API
WireTypeSet..::..GetEnumerator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Insert Method

[image]

Revit 2013 API
WireTypeSet..::..Insert Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    WireType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As WireType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    WireType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Electrical..::..WireType

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


ReverseIterator Method

[image]

Revit 2013 API
WireTypeSet..::..ReverseIterator Method
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual WireTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As WireTypeSetIterator
Visual C++
public:
virtual WireTypeSetIterator^ ReverseIterator()

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSet Properties

[image] [image]

Revit 2013 API
WireTypeSet Properties
WireTypeSet Class See Also Send Feedback

The WireTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size |

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


IsEmpty Property

[image]

Revit 2013 API
WireTypeSet..::..IsEmpty Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


Size Property

[image]

Revit 2013 API
WireTypeSet..::..Size Property
WireTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

WireTypeSet Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Class

[image]

Revit 2013 API
WireTypeSetIterator Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class WireTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class WireTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class WireTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Electrical..::..WireTypeSetIterator

See Also

WireTypeSetIterator Members
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Members

[image] [image]

Revit 2013 API
WireTypeSetIterator Members
WireTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | WireTypeSetIterator | Initializes a new instance of the WireTypeSetIterator class

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Constructor

[image]

Revit 2013 API
WireTypeSetIterator Constructor
WireTypeSetIterator Class See Also Send Feedback
Initializes a new instance of the WireTypeSetIterator class

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public WireTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
WireTypeSetIterator()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Methods

[image] [image]

Revit 2013 API
WireTypeSetIterator Methods
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext |
Public method | Reset |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


MoveNext Method

[image]

Revit 2013 API
WireTypeSetIterator..::..MoveNext Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Implements

IEnumerator..::..MoveNext()()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Reset Method

[image]

Revit 2013 API
WireTypeSetIterator..::..Reset Method
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WireTypeSetIterator Properties

[image] [image]

Revit 2013 API
WireTypeSetIterator Properties
WireTypeSetIterator Class See Also Send Feedback

The WireTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


Current Property

[image]

Revit 2013 API
WireTypeSetIterator..::..Current Property
WireTypeSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

See Also

WireTypeSetIterator Class
Autodesk.Revit.DB.Electrical Namespace


WiringType Enumeration

[image]

Revit 2013 API
WiringType Enumeration
See Also Send Feedback
An enumerated type to list all wiring types.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum WiringType
Visual Basic
Public Enumeration WiringType
Visual C++
public enum class WiringType

Members

Member name | Description
Arc | Arc wiring is used to indicate wiring that is concealed within walls, ceilings, or floors.
Chamfer | Chamfered wiring can be used to indicate wiring that is exposed.

See Also

Autodesk.Revit.DB.Electrical Namespace


Autodesk.Revit.DB.Events Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Events Namespace
Send Feedback

Classes

 | Class | Description
Public class | ApplicationInitializedEventArgs | The event arguments used by the ApplicationLaunched event.
Public class | DocumentChangedEventArgs | The event arguments used by the DocumentChanged event.
Public class | DocumentClosedEventArgs | The event arguments used by the DocumentClosed event.
Public class | DocumentClosingEventArgs | The event arguments used by the DocumentClosing event.
Public class | DocumentCreatedEventArgs | The event arguments used by the DocumentCreated event.
Public class | DocumentCreatingEventArgs | The event arguments used by the DocumentCreating event.
Public class | DocumentOpenedEventArgs | The event arguments used by the DocumentOpened event.
Public class | DocumentOpeningEventArgs | The event arguments used by the DocumentOpening event.
Public class | DocumentPrintedEventArgs | The event arguments used by the DocumentPrinted event.
Public class | DocumentPrintingEventArgs | The event arguments used by the DocumentPrinting event.
Public class | DocumentSavedAsEventArgs | The event arguments used by the DocumentSavedAs event.
Public class | DocumentSavedEventArgs | The event arguments used by the DocumentSaved event.
Public class | DocumentSavingAsEventArgs | The event arguments used by the DocumentSavingAs event.
Public class | DocumentSavingEventArgs | The event arguments used by the DocumentSaving event.
Public class | DocumentSynchronizedWithCentralEventArgs | The event arguments used by the DocumentSynchronizedWithCentralEventArgs event.
Public class | DocumentSynchronizingWithCentralEventArgs | The event arguments used by the DocumentSynchronizingWithCentralEventArgs event.
Public class | FailuresProcessingEventArgs | The event arguments used by the FailuresProcessing event.
Public class | FileExportedEventArgs | The event arguments used by the FileExported event.
Public class | FileExportingEventArgs | The event arguments used by the FileExporting event.
Public class | FileImportedEventArgs | The event arguments used by the FileImported event.
Public class | FileImportingEventArgs | The event arguments used by the FileImporting event.
Public class | PostDocEventArgs | The class is used as base class for arguments of any post-event that is associated to a particular Document.
Public class | PostEventArgs | The class is used as a base class for arguments of any post-event.
Public class | PreDocEventArgs | The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.
Public class | PreEventArgs | The class is used as a base class for the arguments for any pre-event.
Public class | ProgressChangedEventArgs | The event arguments used by the ProgressChanged event.
Public class | RevitAPIEventArgs | The class is used as base class for all event argument classes.
Public class | RevitAPIPostDocEventArgs |
Public class | RevitAPIPostEventArgs | The class is used as a base class for arguments of any post-event.
Public class | RevitAPIPreDocEventArgs |
Public class | RevitAPIPreEventArgs | The class is used as a base class for the arguments for any pre-event.
Public class | RevitAPISingleEventArgs | The class is used as a base class for arguments of any single-event.
Public class | RevitEventArgs | The class is used as base class for all event argument classes.
Public class | SynchronizeWithCentralOptions | Options for save to central.
Public class | ViewPrintedEventArgs | The event arguments used by the ViewPrinted event.
Public class | ViewPrintingEventArgs | The event arguments used by the ViewPrinting event.

Enumerations

 | Enumeration | Description
Public enumeration | EventStatus | Describes the status of an action which triggered a post event.
Public enumeration | ProgressStage | The associated action of a ProgressChanged event
Public enumeration | RevitAPIEventStatus | Describes the status of an action which triggered a post event.
Public enumeration | UndoOperation | The operation associated with DocumentChanged event


ApplicationInitializedEventArgs Class

[image]

Revit 2013 API
ApplicationInitializedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ApplicationLaunched event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ApplicationInitializedEventArgs : RevitAPISingleEventArgs
Visual Basic
Public Class ApplicationInitializedEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class ApplicationInitializedEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::..ApplicationInitializedEventArgs

See Also

ApplicationInitializedEventArgs Members
Autodesk.Revit.DB.Events Namespace


ApplicationInitializedEventArgs Members

[image] [image]

Revit 2013 API
ApplicationInitializedEventArgs Members
ApplicationInitializedEventArgs Class Methods Properties See Also Send Feedback

The ApplicationInitializedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

ApplicationInitializedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ApplicationInitializedEventArgs Methods

[image] [image]

Revit 2013 API
ApplicationInitializedEventArgs Methods
ApplicationInitializedEventArgs Class See Also Send Feedback

The ApplicationInitializedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationInitializedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ApplicationInitializedEventArgs Properties

[image] [image]

Revit 2013 API
ApplicationInitializedEventArgs Properties
ApplicationInitializedEventArgs Class See Also Send Feedback

The ApplicationInitializedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

ApplicationInitializedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Class

[image]

Revit 2013 API
DocumentChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentChanged event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class DocumentChangedEventArgs : RevitAPISingleEventArgs
Visual Basic
Public Class DocumentChangedEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class DocumentChangedEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::..DocumentChangedEventArgs

See Also

DocumentChangedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Members

[image] [image]

Revit 2013 API
DocumentChangedEventArgs Members
DocumentChangedEventArgs Class Methods Properties See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document
Public method | GetDocument | Returns document associated with this event
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified
Public method | GetTransactionNames | Returns names of the transactions associated with this event
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Operation | The operation associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentChangedEventArgs Methods
DocumentChangedEventArgs Class See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAddedElementIds | Returns set of elements newly added to the document
Public method | GetDeletedElementIds | Returns set of elements that were deleted from the document
Public method | GetDocument | Returns document associated with this event
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetModifiedElementIds | Returns set of elements that were modified
Public method | GetTransactionNames | Returns names of the transactions associated with this event
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetAddedElementIds Method

[image]

Revit 2013 API
DocumentChangedEventArgs..::..GetAddedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements newly added to the document

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAddedElementIds()
Visual Basic
Public Function GetAddedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAddedElementIds()

Return Value

The set of ElementId for elements newly added to the document

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetDeletedElementIds Method

[image]

Revit 2013 API
DocumentChangedEventArgs..::..GetDeletedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements that were deleted from the document

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetDeletedElementIds()
Visual Basic
Public Function GetDeletedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetDeletedElementIds()

Return Value

The set of ElementId for elements that were deleted from the document

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetDocument Method

[image]

Revit 2013 API
DocumentChangedEventArgs..::..GetDocument Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns document associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Document GetDocument()
Visual Basic
Public Function GetDocument As Document
Visual C++
public:
Document^ GetDocument()

Return Value

The document associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetModifiedElementIds Method

[image]

Revit 2013 API
DocumentChangedEventArgs..::..GetModifiedElementIds Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns set of elements that were modified

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetModifiedElementIds()
Visual Basic
Public Function GetModifiedElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetModifiedElementIds()

Return Value

The set of ElementId for elements that were modified

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetTransactionNames Method

[image]

Revit 2013 API
DocumentChangedEventArgs..::..GetTransactionNames Method
DocumentChangedEventArgs Class See Also Send Feedback
Returns names of the transactions associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<string> GetTransactionNames()
Visual Basic
Public Function GetTransactionNames As IList(Of String)
Visual C++
public:
IList<String^>^ GetTransactionNames()

Return Value

The names of the transactions associated with this event

Remarks

Typically, there will be only one name in the array, because document changes mostly involve just one transaction

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentChangedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentChangedEventArgs Properties
DocumentChangedEventArgs Class See Also Send Feedback

The DocumentChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Operation | The operation associated with this event

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Operation Property

[image]

Revit 2013 API
DocumentChangedEventArgs..::..Operation Property
DocumentChangedEventArgs Class See Also Send Feedback
The operation associated with this event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public UndoOperation Operation { get; }
Visual Basic
Public ReadOnly Property Operation As UndoOperation
    Get
Visual C++
public:
property UndoOperation Operation {
    UndoOperation get ();
}

See Also

DocumentChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Class

[image]

Revit 2013 API
DocumentClosedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosed event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentClosedEventArgs : RevitAPIPostEventArgs
Visual Basic
Public Class DocumentClosedEventArgs _
    Inherits RevitAPIPostEventArgs
Visual C++
public ref class DocumentClosedEventArgs : public RevitAPIPostEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..DocumentClosedEventArgs

See Also

DocumentClosedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Members

[image] [image]

Revit 2013 API
DocumentClosedEventArgs Members
DocumentClosedEventArgs Class Methods Properties See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentId | Id of the document that has just been closed.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentClosedEventArgs Methods
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentClosedEventArgs Properties
DocumentClosedEventArgs Class See Also Send Feedback

The DocumentClosedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentId | Id of the document that has just been closed.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentId Property

[image]

Revit 2013 API
DocumentClosedEventArgs..::..DocumentId Property
DocumentClosedEventArgs Class See Also Send Feedback
Id of the document that has just been closed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int DocumentId { get; }
Visual Basic
Public ReadOnly Property DocumentId As Integer
    Get
Visual C++
public:
property int DocumentId {
    int get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosing event which preceded it. It serves as synchronization means for the pair of events.

See Also

DocumentClosedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Class

[image]

Revit 2013 API
DocumentClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentClosing event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentClosingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentClosingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentClosingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentClosingEventArgs

See Also

DocumentClosingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Members

[image] [image]

Revit 2013 API
DocumentClosingEventArgs Members
DocumentClosingEventArgs Class Methods Properties See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Methods

[image] [image]

Revit 2013 API
DocumentClosingEventArgs Methods
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentClosingEventArgs Properties

[image] [image]

Revit 2013 API
DocumentClosingEventArgs Properties
DocumentClosingEventArgs Class See Also Send Feedback

The DocumentClosingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | DocumentId | Id of the document that is about to be closed.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentId Property

[image]

Revit 2013 API
DocumentClosingEventArgs..::..DocumentId Property
DocumentClosingEventArgs Class See Also Send Feedback
Id of the document that is about to be closed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int DocumentId { get; }
Visual Basic
Public ReadOnly Property DocumentId As Integer
    Get
Visual C++
public:
property int DocumentId {
    int get ();
}

Remarks

This Id is only used to identify the document for the duration of this event and the DocumentClosed event which follows. It serves as synchronization means for the pair of events.

See Also

DocumentClosingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Class

[image]

Revit 2013 API
DocumentCreatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreated event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentCreatedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentCreatedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentCreatedEventArgs : public RevitAPIPostDocEventArgs

Remarks

The newly created document is supplied in these arguments.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentCreatedEventArgs

See Also

DocumentCreatedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Members

[image] [image]

Revit 2013 API
DocumentCreatedEventArgs Members
DocumentCreatedEventArgs Class Methods Properties See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentCreatedEventArgs Methods
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentCreatedEventArgs Properties
DocumentCreatedEventArgs Class See Also Send Feedback

The DocumentCreatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentCreatedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Class

[image]

Revit 2013 API
DocumentCreatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentCreating event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentCreatingEventArgs : RevitAPIPreEventArgs
Visual Basic
Public Class DocumentCreatingEventArgs _
    Inherits RevitAPIPreEventArgs
Visual C++
public ref class DocumentCreatingEventArgs : public RevitAPIPreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..DocumentCreatingEventArgs

See Also

DocumentCreatingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Members

[image] [image]

Revit 2013 API
DocumentCreatingEventArgs Members
DocumentCreatingEventArgs Class Methods Properties See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Public property | Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Methods

[image] [image]

Revit 2013 API
DocumentCreatingEventArgs Methods
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentCreatingEventArgs Properties

[image] [image]

Revit 2013 API
DocumentCreatingEventArgs Properties
DocumentCreatingEventArgs Class See Also Send Feedback

The DocumentCreatingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentType | Type of the document which is about to be created, e.g. Project or Template.
Public property | Template | The template file path to be used for creating the new document.

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentType Property

[image]

Revit 2013 API
DocumentCreatingEventArgs..::..DocumentType Property
DocumentCreatingEventArgs Class See Also Send Feedback
Type of the document which is about to be created, e.g. Project or Template.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic
Public ReadOnly Property DocumentType As DocumentType
    Get
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Template Property

[image]

Revit 2013 API
DocumentCreatingEventArgs..::..Template Property
DocumentCreatingEventArgs Class See Also Send Feedback
The template file path to be used for creating the new document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Template { get; }
Visual Basic
Public ReadOnly Property Template As String
    Get
Visual C++
public:
property String^ Template {
    String^ get ();
}

See Also

DocumentCreatingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Class

[image]

Revit 2013 API
DocumentOpenedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpened event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentOpenedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentOpenedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentOpenedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentOpenedEventArgs

See Also

DocumentOpenedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Members

[image] [image]

Revit 2013 API
DocumentOpenedEventArgs Members
DocumentOpenedEventArgs Class Methods Properties See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentOpenedEventArgs Methods
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpenedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentOpenedEventArgs Properties
DocumentOpenedEventArgs Class See Also Send Feedback

The DocumentOpenedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentOpenedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Class

[image]

Revit 2013 API
DocumentOpeningEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentOpening event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentOpeningEventArgs : RevitAPIPreEventArgs
Visual Basic
Public Class DocumentOpeningEventArgs _
    Inherits RevitAPIPreEventArgs
Visual C++
public ref class DocumentOpeningEventArgs : public RevitAPIPreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..DocumentOpeningEventArgs

See Also

DocumentOpeningEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Members

[image] [image]

Revit 2013 API
DocumentOpeningEventArgs Members
DocumentOpeningEventArgs Class Methods Properties See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentType | Type of the document, e.g. Project or Template.
Public property | PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Methods

[image] [image]

Revit 2013 API
DocumentOpeningEventArgs Methods
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentOpeningEventArgs Properties

[image] [image]

Revit 2013 API
DocumentOpeningEventArgs Properties
DocumentOpeningEventArgs Class See Also Send Feedback

The DocumentOpeningEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | DocumentType | Type of the document, e.g. Project or Template.
Public property | PathName | Path of the document to be opened.

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentType Property

[image]

Revit 2013 API
DocumentOpeningEventArgs..::..DocumentType Property
DocumentOpeningEventArgs Class See Also Send Feedback
Type of the document, e.g. Project or Template.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public DocumentType DocumentType { get; }
Visual Basic
Public ReadOnly Property DocumentType As DocumentType
    Get
Visual C++
public:
property DocumentType DocumentType {
    DocumentType get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


PathName Property

[image]

Revit 2013 API
DocumentOpeningEventArgs..::..PathName Property
DocumentOpeningEventArgs Class See Also Send Feedback
Path of the document to be opened.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentOpeningEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Class

[image]

Revit 2013 API
DocumentPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinted event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentPrintedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentPrintedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentPrintedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentPrintedEventArgs

See Also

DocumentPrintedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Members

[image] [image]

Revit 2013 API
DocumentPrintedEventArgs Members
DocumentPrintedEventArgs Class Methods Properties See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailedViewElementIds | Returns ElementIds of the views that that failed to print (if any).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrintedViewElementIds | Returns ElementIds of the views that printed successfully.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentPrintedEventArgs Methods
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailedViewElementIds | Returns ElementIds of the views that that failed to print (if any).
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPrintedViewElementIds | Returns ElementIds of the views that printed successfully.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetFailedViewElementIds Method

[image]

Revit 2013 API
DocumentPrintedEventArgs..::..GetFailedViewElementIds Method
DocumentPrintedEventArgs Class See Also Send Feedback
Returns ElementIds of the views that that failed to print (if any).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public IList<ElementId> GetFailedViewElementIds()
Visual Basic
Public Function GetFailedViewElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetFailedViewElementIds()

Return Value

ElementIds of the views that that failed to print (if any).

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetPrintedViewElementIds Method

[image]

Revit 2013 API
DocumentPrintedEventArgs..::..GetPrintedViewElementIds Method
DocumentPrintedEventArgs Class See Also Send Feedback
Returns ElementIds of the views that printed successfully.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public IList<ElementId> GetPrintedViewElementIds()
Visual Basic
Public Function GetPrintedViewElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetPrintedViewElementIds()

Return Value

ElementIds of the views that printed successfully.

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentPrintedEventArgs Properties
DocumentPrintedEventArgs Class See Also Send Feedback

The DocumentPrintedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Class

[image]

Revit 2013 API
DocumentPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentPrinting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentPrintingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentPrintingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentPrintingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentPrintingEventArgs

See Also

DocumentPrintingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Members

[image] [image]

Revit 2013 API
DocumentPrintingEventArgs Members
DocumentPrintingEventArgs Class Methods Properties See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewElementIds | Returns ElementIds of the views to be printed.
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Settings | The print settings of the active printing session.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Methods

[image] [image]

Revit 2013 API
DocumentPrintingEventArgs Methods
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewElementIds | Returns ElementIds of the views to be printed.
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetViewElementIds Method

[image]

Revit 2013 API
DocumentPrintingEventArgs..::..GetViewElementIds Method
DocumentPrintingEventArgs Class See Also Send Feedback
Returns ElementIds of the views to be printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public IList<ElementId> GetViewElementIds()
Visual Basic
Public Function GetViewElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetViewElementIds()

Return Value

ElementIds of the views to be printed.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentPrintingEventArgs Properties

[image] [image]

Revit 2013 API
DocumentPrintingEventArgs Properties
DocumentPrintingEventArgs Class See Also Send Feedback

The DocumentPrintingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Settings | The print settings of the active printing session.

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Settings Property

[image]

Revit 2013 API
DocumentPrintingEventArgs..::..Settings Property
DocumentPrintingEventArgs Class See Also Send Feedback
The print settings of the active printing session.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public IPrintSetting Settings { get; }
Visual Basic
Public ReadOnly Property Settings As IPrintSetting
    Get
Visual C++
public:
property IPrintSetting^ Settings {
    IPrintSetting^ get ();
}

See Also

DocumentPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Class

[image]

Revit 2013 API
DocumentSavedAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavedAs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSavedAsEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentSavedAsEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentSavedAsEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavedAsEventArgs

See Also

DocumentSavedAsEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Members

[image] [image]

Revit 2013 API
DocumentSavedAsEventArgs Members
DocumentSavedAsEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
Public property | OriginalPath | Original path of the document.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSavedAsEventArgs Methods
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedAsEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSavedAsEventArgs Properties
DocumentSavedAsEventArgs Class See Also Send Feedback

The DocumentSavedAsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
Public property | OriginalPath | Original path of the document.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsSavingAsMasterFile Property

[image]

Revit 2013 API
DocumentSavedAsEventArgs..::..IsSavingAsMasterFile Property
DocumentSavedAsEventArgs Class See Also Send Feedback
Indicates whether the document is to be saved as master file.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public bool IsSavingAsMasterFile { get; }
Visual Basic
Public ReadOnly Property IsSavingAsMasterFile As Boolean
    Get
Visual C++
public:
property bool IsSavingAsMasterFile {
    bool get ();
}

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


OriginalPath Property

[image]

Revit 2013 API
DocumentSavedAsEventArgs..::..OriginalPath Property
DocumentSavedAsEventArgs Class See Also Send Feedback
Original path of the document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string OriginalPath { get; }
Visual Basic
Public ReadOnly Property OriginalPath As String
    Get
Visual C++
public:
property String^ OriginalPath {
    String^ get ();
}

See Also

DocumentSavedAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Class

[image]

Revit 2013 API
DocumentSavedEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaved event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSavedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentSavedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentSavedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavedEventArgs

See Also

DocumentSavedEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Members

[image] [image]

Revit 2013 API
DocumentSavedEventArgs Members
DocumentSavedEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSavedEventArgs Methods
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavedEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSavedEventArgs Properties
DocumentSavedEventArgs Class See Also Send Feedback

The DocumentSavedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSavedEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Class

[image]

Revit 2013 API
DocumentSavingAsEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSavingAs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSavingAsEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentSavingAsEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentSavingAsEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavingAsEventArgs

See Also

DocumentSavingAsEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Members

[image] [image]

Revit 2013 API
DocumentSavingAsEventArgs Members
DocumentSavingAsEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
Public property | PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSavingAsEventArgs Methods
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingAsEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSavingAsEventArgs Properties
DocumentSavingAsEventArgs Class See Also Send Feedback

The DocumentSavingAsEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | IsSavingAsMasterFile | Indicates whether the document is to be saved as master file.
Public property | PathName | Target path to which the document is to be saved.

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsSavingAsMasterFile Property

[image]

Revit 2013 API
DocumentSavingAsEventArgs..::..IsSavingAsMasterFile Property
DocumentSavingAsEventArgs Class See Also Send Feedback
Indicates whether the document is to be saved as master file.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public bool IsSavingAsMasterFile { get; }
Visual Basic
Public ReadOnly Property IsSavingAsMasterFile As Boolean
    Get
Visual C++
public:
property bool IsSavingAsMasterFile {
    bool get ();
}

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


PathName Property

[image]

Revit 2013 API
DocumentSavingAsEventArgs..::..PathName Property
DocumentSavingAsEventArgs Class See Also Send Feedback
Target path to which the document is to be saved.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string PathName { get; }
Visual Basic
Public ReadOnly Property PathName As String
    Get
Visual C++
public:
property String^ PathName {
    String^ get ();
}

See Also

DocumentSavingAsEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Class

[image]

Revit 2013 API
DocumentSavingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSaving event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSavingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentSavingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentSavingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavingEventArgs

See Also

DocumentSavingEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Members

[image] [image]

Revit 2013 API
DocumentSavingEventArgs Members
DocumentSavingEventArgs Class Methods Properties See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSavingEventArgs Methods
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSavingEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSavingEventArgs Properties
DocumentSavingEventArgs Class See Also Send Feedback

The DocumentSavingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)

See Also

DocumentSavingEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Class

[image]

Revit 2013 API
DocumentSynchronizedWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizedWithCentralEventArgs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSynchronizedWithCentralEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class DocumentSynchronizedWithCentralEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class DocumentSynchronizedWithCentralEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSynchronizedWithCentralEventArgs

See Also

DocumentSynchronizedWithCentralEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Members

[image] [image]

Revit 2013 API
DocumentSynchronizedWithCentralEventArgs Members
DocumentSynchronizedWithCentralEventArgs Class Methods Properties See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSynchronizedWithCentralEventArgs Methods
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizedWithCentralEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSynchronizedWithCentralEventArgs Properties
DocumentSynchronizedWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizedWithCentralEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

DocumentSynchronizedWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Class

[image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs Class
Members See Also Send Feedback
The event arguments used by the DocumentSynchronizingWithCentralEventArgs event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class DocumentSynchronizingWithCentralEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class DocumentSynchronizingWithCentralEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class DocumentSynchronizingWithCentralEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentSynchronizingWithCentralEventArgs

See Also

DocumentSynchronizingWithCentralEventArgs Members
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Members

[image] [image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs Members
DocumentSynchronizingWithCentralEventArgs Class Methods Properties See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Comments | User's comments for synchronization.
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Location | Full path of the central model which is to be synchronized.
Public property | Options | User's options associated with the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Methods

[image] [image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs Methods
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


DocumentSynchronizingWithCentralEventArgs Properties

[image] [image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs Properties
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback

The DocumentSynchronizingWithCentralEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Comments | User's comments for synchronization.
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Location | Full path of the central model which is to be synchronized.
Public property | Options | User's options associated with the synchronization operation.

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Comments Property

[image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs..::..Comments Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's comments for synchronization.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Comments { get; }
Visual Basic
Public ReadOnly Property Comments As String
    Get
Visual C++
public:
property String^ Comments {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Location Property

[image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs..::..Location Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
Full path of the central model which is to be synchronized.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Location { get; }
Visual Basic
Public ReadOnly Property Location As String
    Get
Visual C++
public:
property String^ Location {
    String^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


Options Property

[image]

Revit 2013 API
DocumentSynchronizingWithCentralEventArgs..::..Options Property
DocumentSynchronizingWithCentralEventArgs Class See Also Send Feedback
User's options associated with the synchronization operation.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public SynchronizeWithCentralOptions Options { get; }
Visual Basic
Public ReadOnly Property Options As SynchronizeWithCentralOptions
    Get
Visual C++
public:
property SynchronizeWithCentralOptions^ Options {
    SynchronizeWithCentralOptions^ get ();
}

See Also

DocumentSynchronizingWithCentralEventArgs Class
Autodesk.Revit.DB.Events Namespace


EventStatus Enumeration

[image]

Revit 2013 API
EventStatus Enumeration
See Also Send Feedback
Describes the status of an action which triggered a post event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum EventStatus
Visual Basic
Public Enumeration EventStatus
Visual C++
public enum class EventStatus

Members

Member name | Description
Failed | The action that triggered this event failed.
Succeeded | The action that triggered this event succeeded.
Cancelled | The action that triggered this event was cancelled by an event handler from the pre-event for the action.

See Also

Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Class

[image]

Revit 2013 API
FailuresProcessingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FailuresProcessing event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FailuresProcessingEventArgs : RevitAPISingleEventArgs
Visual Basic
Public Class FailuresProcessingEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class FailuresProcessingEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::..FailuresProcessingEventArgs

See Also

FailuresProcessingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Members

[image] [image]

Revit 2013 API
FailuresProcessingEventArgs Members
FailuresProcessingEventArgs Class Methods Properties See Also Send Feedback

The FailuresProcessingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailuresAccessor | Provides access to the failure information in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProcessingResult | Retrieves current status of the failures processing result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | SetProcessingResult | Sets the result of the failures processing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Methods

[image] [image]

Revit 2013 API
FailuresProcessingEventArgs Methods
FailuresProcessingEventArgs Class See Also Send Feedback

The FailuresProcessingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetFailuresAccessor | Provides access to the failure information in the document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProcessingResult | Retrieves current status of the failures processing result.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | SetProcessingResult | Sets the result of the failures processing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetFailuresAccessor Method

[image]

Revit 2013 API
FailuresProcessingEventArgs..::..GetFailuresAccessor Method
FailuresProcessingEventArgs Class See Also Send Feedback
Provides access to the failure information in the document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailuresAccessor GetFailuresAccessor()
Visual Basic
Public Function GetFailuresAccessor As FailuresAccessor
Visual C++
public:
FailuresAccessor^ GetFailuresAccessor()

Return Value

The accessor to the failures in the document.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


GetProcessingResult Method

[image]

Revit 2013 API
FailuresProcessingEventArgs..::..GetProcessingResult Method
FailuresProcessingEventArgs Class See Also Send Feedback
Retrieves current status of the failures processing result.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FailureProcessingResult GetProcessingResult()
Visual Basic
Public Function GetProcessingResult As FailureProcessingResult
Visual C++
public:
FailureProcessingResult GetProcessingResult()

Return Value

The current failures processing result.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


SetProcessingResult Method

[image]

Revit 2013 API
FailuresProcessingEventArgs..::..SetProcessingResult Method
FailuresProcessingEventArgs Class See Also Send Feedback
Sets the result of the failures processing.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetProcessingResult(
    FailureProcessingResult result
)
Visual Basic
Public Sub SetProcessingResult ( _
    result As FailureProcessingResult _
)
Visual C++
public:
void SetProcessingResult(
    FailureProcessingResult result
)

Parameters

result
Type: Autodesk.Revit.DB..::..FailureProcessingResult
The result.

Remarks

Setting this result may not affect the outcome if other observers of the event are invoked after this one. The most prohibitive result set by all handlers will be used.

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FailuresProcessingEventArgs Properties

[image] [image]

Revit 2013 API
FailuresProcessingEventArgs Properties
FailuresProcessingEventArgs Class See Also Send Feedback

The FailuresProcessingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

FailuresProcessingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Class

[image]

Revit 2013 API
FileExportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExported event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class FileExportedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class FileExportedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class FileExportedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..FileExportedEventArgs

See Also

FileExportedEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Members

[image] [image]

Revit 2013 API
FileExportedEventArgs Members
FileExportedEventArgs Class Methods Properties See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the export format, e.g. DWG or image.
Public property | Path | Target path for the exported file (or files).
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Methods

[image] [image]

Revit 2013 API
FileExportedEventArgs Methods
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportedEventArgs Properties

[image] [image]

Revit 2013 API
FileExportedEventArgs Properties
FileExportedEventArgs Class See Also Send Feedback

The FileExportedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the export format, e.g. DWG or image.
Public property | Path | Target path for the exported file (or files).
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2013 API
FileExportedEventArgs..::..Format Property
FileExportedEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic
Public ReadOnly Property Format As ImportExportFileFormat
    Get
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2013 API
FileExportedEventArgs..::..Path Property
FileExportedEventArgs Class See Also Send Feedback
Target path for the exported file (or files).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

In some cases the path represents only the target directory or a template name. Such cases include batch export when more than one file is exported as one event.

See Also

FileExportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Class

[image]

Revit 2013 API
FileExportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileExporting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class FileExportingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class FileExportingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class FileExportingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..FileExportingEventArgs

See Also

FileExportingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Members

[image] [image]

Revit 2013 API
FileExportingEventArgs Members
FileExportingEventArgs Class Methods Properties See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Format | Identifies the export format, e.g. DWG or image.
Public property | Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Methods

[image] [image]

Revit 2013 API
FileExportingEventArgs Methods
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileExportingEventArgs Properties

[image] [image]

Revit 2013 API
FileExportingEventArgs Properties
FileExportingEventArgs Class See Also Send Feedback

The FileExportingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Format | Identifies the export format, e.g. DWG or image.
Public property | Path | The target path for the export.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2013 API
FileExportingEventArgs..::..Format Property
FileExportingEventArgs Class See Also Send Feedback
Identifies the export format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic
Public ReadOnly Property Format As ImportExportFileFormat
    Get
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2013 API
FileExportingEventArgs..::..Path Property
FileExportingEventArgs Class See Also Send Feedback
The target path for the export.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

Remarks

When several files are exported at the same time, 'Path' property will just report the directory instead of those full file names.

See Also

FileExportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Class

[image]

Revit 2013 API
FileImportedEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImported event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class FileImportedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class FileImportedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class FileImportedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..FileImportedEventArgs

See Also

FileImportedEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Members

[image] [image]

Revit 2013 API
FileImportedEventArgs Members
FileImportedEventArgs Class Methods Properties See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | ImportedInstanceId | The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.
Public property | Path | Path of the source file that was imported.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Methods

[image] [image]

Revit 2013 API
FileImportedEventArgs Methods
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportedEventArgs Properties

[image] [image]

Revit 2013 API
FileImportedEventArgs Properties
FileImportedEventArgs Class See Also Send Feedback

The FileImportedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | ImportedInstanceId | The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.
Public property | Path | Path of the source file that was imported.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2013 API
FileImportedEventArgs..::..Format Property
FileImportedEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic
Public ReadOnly Property Format As ImportExportFileFormat
    Get
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ImportedInstanceId Property

[image]

Revit 2013 API
FileImportedEventArgs..::..ImportedInstanceId Property
FileImportedEventArgs Class See Also Send Feedback
The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public ElementId ImportedInstanceId { get; }
Visual Basic
Public ReadOnly Property ImportedInstanceId As ElementId
    Get
Visual C++
public:
property ElementId^ ImportedInstanceId {
    ElementId^ get ();
}

Remarks

The value could be InvalidElementId for some type of import formats, such as GBXML and Inventor files.

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2013 API
FileImportedEventArgs..::..Path Property
FileImportedEventArgs Class See Also Send Feedback
Path of the source file that was imported.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportedEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Class

[image]

Revit 2013 API
FileImportingEventArgs Class
Members See Also Send Feedback
The event arguments used by the FileImporting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class FileImportingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class FileImportingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class FileImportingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..FileImportingEventArgs

See Also

FileImportingEventArgs Members
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Members

[image] [image]

Revit 2013 API
FileImportingEventArgs Members
FileImportingEventArgs Class Methods Properties See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Methods

[image] [image]

Revit 2013 API
FileImportingEventArgs Methods
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


FileImportingEventArgs Properties

[image] [image]

Revit 2013 API
FileImportingEventArgs Properties
FileImportingEventArgs Class See Also Send Feedback

The FileImportingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Format | Identifies the import format, e.g. DWG or image.
Public property | Path | Path of the source file which is about to be imported.

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Format Property

[image]

Revit 2013 API
FileImportingEventArgs..::..Format Property
FileImportingEventArgs Class See Also Send Feedback
Identifies the import format, e.g. DWG or image.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public ImportExportFileFormat Format { get; }
Visual Basic
Public ReadOnly Property Format As ImportExportFileFormat
    Get
Visual C++
public:
property ImportExportFileFormat Format {
    ImportExportFileFormat get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Path Property

[image]

Revit 2013 API
FileImportingEventArgs..::..Path Property
FileImportingEventArgs Class See Also Send Feedback
Path of the source file which is about to be imported.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public string Path { get; }
Visual Basic
Public ReadOnly Property Path As String
    Get
Visual C++
public:
property String^ Path {
    String^ get ();
}

See Also

FileImportingEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Class

[image]

Revit 2013 API
PostDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for arguments of any post-event that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PostDocEventArgs : PostEventArgs
Visual Basic
Public Class PostDocEventArgs _
    Inherits PostEventArgs
Visual C++
public ref class PostDocEventArgs : public PostEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PostEventArgs
Autodesk.Revit.DB.Events..::..PostDocEventArgs
Autodesk.Revit.UI.Events..::..ViewActivatedEventArgs

See Also

PostDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Members

[image] [image]

Revit 2013 API
PostDocEventArgs Members
PostDocEventArgs Class Methods Properties See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Document | The document associated with the event.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Methods

[image] [image]

Revit 2013 API
PostDocEventArgs Methods
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostDocEventArgs Properties

[image] [image]

Revit 2013 API
PostDocEventArgs Properties
PostDocEventArgs Class See Also Send Feedback

The PostDocEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Document | The document associated with the event.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2013 API
PostDocEventArgs..::..Document Property
PostDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Class

[image]

Revit 2013 API
PostEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any post-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PostEventArgs : RevitEventArgs
Visual Basic
Public Class PostEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PostEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PostEventArgs
Autodesk.Revit.DB.Events..::..PostDocEventArgs

See Also

PostEventArgs Members
Autodesk.Revit.DB.Events Namespace


PostEventArgs Members

[image] [image]

Revit 2013 API
PostEventArgs Members
PostEventArgs Class Methods Properties See Also Send Feedback

The PostEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Methods

[image] [image]

Revit 2013 API
PostEventArgs Methods
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PostEventArgs Properties

[image] [image]

Revit 2013 API
PostEventArgs Properties
PostEventArgs Class See Also Send Feedback

The PostEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


Status Property

[image]

Revit 2013 API
PostEventArgs..::..Status Property
PostEventArgs Class See Also Send Feedback
Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public EventStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As EventStatus
    Get
Visual C++
public:
property EventStatus Status {
    EventStatus get ();
}

See Also

PostEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Class

[image]

Revit 2013 API
PreDocEventArgs Class
Members See Also Send Feedback
The class is used as base class for the arguments of any pre-event arguments that is associated to a particular Document.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PreDocEventArgs : PreEventArgs
Visual Basic
Public Class PreDocEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class PreDocEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.DB.Events..::..PreDocEventArgs
Autodesk.Revit.UI.Events..::..ViewActivatingEventArgs

See Also

PreDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Members

[image] [image]

Revit 2013 API
PreDocEventArgs Members
PreDocEventArgs Class Methods Properties See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Methods

[image] [image]

Revit 2013 API
PreDocEventArgs Methods
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreDocEventArgs Properties

[image] [image]

Revit 2013 API
PreDocEventArgs Properties
PreDocEventArgs Class See Also Send Feedback

The PreDocEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | Document | The document associated with the event.

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2013 API
PreDocEventArgs..::..Document Property
PreDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

PreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Class

[image]

Revit 2013 API
PreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PreEventArgs : RevitEventArgs
Visual Basic
Public Class PreEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class PreEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.DB.Events..::..PreDocEventArgs
Autodesk.Revit.UI.Events..::..ApplicationClosingEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..DisplayingOptionsDialogEventArgs
Autodesk.Revit.UI.Events..::..IdlingEventArgs

See Also

PreEventArgs Members
Autodesk.Revit.DB.Events Namespace


PreEventArgs Members

[image] [image]

Revit 2013 API
PreEventArgs Members
PreEventArgs Class Methods Properties See Also Send Feedback

The PreEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Methods

[image] [image]

Revit 2013 API
PreEventArgs Methods
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


PreEventArgs Properties

[image] [image]

Revit 2013 API
PreEventArgs Properties
PreEventArgs Class See Also Send Feedback

The PreEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

PreEventArgs Class
Autodesk.Revit.DB.Events Namespace


ProgressChangedEventArgs Class

[image]

Revit 2013 API
ProgressChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ProgressChanged event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ProgressChangedEventArgs : RevitAPISingleEventArgs
Visual Basic
Public Class ProgressChangedEventArgs _
    Inherits RevitAPISingleEventArgs
Visual C++
public ref class ProgressChangedEventArgs : public RevitAPISingleEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::..ProgressChangedEventArgs

See Also

ProgressChangedEventArgs Members
Autodesk.Revit.DB.Events Namespace


ProgressChangedEventArgs Members

[image] [image]

Revit 2013 API
ProgressChangedEventArgs Members
ProgressChangedEventArgs Class Methods Properties See Also Send Feedback

The ProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Requests to cancel the progress bar's operation.
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Caption | The text from the progress bar caption that describes the operation in progress
Public property | LowerRange | Lower part of progress bar range - always zero
Public property | Position | Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property | Stage | The current stage of the progress bar
Public property | UpperRange | Upper part of progress bar range - will be any non-zero number

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ProgressChangedEventArgs Methods

[image] [image]

Revit 2013 API
ProgressChangedEventArgs Methods
ProgressChangedEventArgs Class See Also Send Feedback

The ProgressChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | Requests to cancel the progress bar's operation.
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancel Method

[image]

Revit 2013 API
ProgressChangedEventArgs..::..Cancel Method
ProgressChangedEventArgs Class See Also Send Feedback
Requests to cancel the progress bar's operation.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation cannot be cancelled.

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ProgressChangedEventArgs Properties

[image] [image]

Revit 2013 API
ProgressChangedEventArgs Properties
ProgressChangedEventArgs Class See Also Send Feedback

The ProgressChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Caption | The text from the progress bar caption that describes the operation in progress
Public property | LowerRange | Lower part of progress bar range - always zero
Public property | Position | Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public property | Stage | The current stage of the progress bar
Public property | UpperRange | Upper part of progress bar range - will be any non-zero number

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Caption Property

[image]

Revit 2013 API
ProgressChangedEventArgs..::..Caption Property
ProgressChangedEventArgs Class See Also Send Feedback
The text from the progress bar caption that describes the operation in progress

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Caption { get; }
Visual Basic
Public ReadOnly Property Caption As String
    Get
Visual C++
public:
property String^ Caption {
    String^ get ();
}

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


LowerRange Property

[image]

Revit 2013 API
ProgressChangedEventArgs..::..LowerRange Property
ProgressChangedEventArgs Class See Also Send Feedback
Lower part of progress bar range - always zero

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int LowerRange { get; }
Visual Basic
Public ReadOnly Property LowerRange As Integer
    Get
Visual C++
public:
property int LowerRange {
    int get ();
}

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Position Property

[image]

Revit 2013 API
ProgressChangedEventArgs..::..Position Property
ProgressChangedEventArgs Class See Also Send Feedback
Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Position { get; }
Visual Basic
Public ReadOnly Property Position As Integer
    Get
Visual C++
public:
property int Position {
    int get ();
}

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Stage Property

[image]

Revit 2013 API
ProgressChangedEventArgs..::..Stage Property
ProgressChangedEventArgs Class See Also Send Feedback
The current stage of the progress bar

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ProgressStage Stage { get; }
Visual Basic
Public ReadOnly Property Stage As ProgressStage
    Get
Visual C++
public:
property ProgressStage Stage {
    ProgressStage get ();
}

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


UpperRange Property

[image]

Revit 2013 API
ProgressChangedEventArgs..::..UpperRange Property
ProgressChangedEventArgs Class See Also Send Feedback
Upper part of progress bar range - will be any non-zero number

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int UpperRange { get; }
Visual Basic
Public ReadOnly Property UpperRange As Integer
    Get
Visual C++
public:
property int UpperRange {
    int get ();
}

See Also

ProgressChangedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ProgressStage Enumeration

[image]

Revit 2013 API
ProgressStage Enumeration
See Also Send Feedback
The associated action of a ProgressChanged event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ProgressStage
Visual Basic
Public Enumeration ProgressStage
Visual C++
public enum class ProgressStage

Members

Member name | Description
Started | Progress bar has started
RangeChanged | Progress bar has set new range
PositionChanged | Progress bar has set new position
CaptionChanged | Progress bar has set new Text
UserCancelled | User has cancelled the progress bar's operation.
Finished | Progress bar is finished

See Also

Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Class

[image]

Revit 2013 API
RevitAPIEventArgs Class
Members See Also Send Feedback
The class is used as base class for all event argument classes.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIEventArgs : EventArgs,
    IDisposable
Visual Basic
Public Class RevitAPIEventArgs _
    Inherits EventArgs _
    Implements IDisposable
Visual C++
public ref class RevitAPIEventArgs : public EventArgs,
    IDisposable

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs

See Also

RevitAPIEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Members

[image] [image]

Revit 2013 API
RevitAPIEventArgs Members
RevitAPIEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RevitAPIEventArgs
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPIEventArgs Methods
RevitAPIEventArgs Class See Also Send Feedback

The RevitAPIEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


Dispose Method

[image]

Revit 2013 API
RevitAPIEventArgs..::..Dispose Method
RevitAPIEventArgs Class See Also Send Feedback
Releases all resources used by the RevitAPIEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


IsCancelled Method

[image]

Revit 2013 API
RevitAPIEventArgs..::..IsCancelled Method
RevitAPIEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsCancelled()
Visual Basic
Public Function IsCancelled As Boolean
Visual C++
public:
bool IsCancelled()

Remarks

If the event is cancellable and an event delegate wishes to cancel the event, it may call the Cancel() method if it is available for a particular event's arguments.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPIEventArgs Properties
RevitAPIEventArgs Class See Also Send Feedback

The RevitAPIEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancellable Property

[image]

Revit 2013 API
RevitAPIEventArgs..::..Cancellable Property
RevitAPIEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Cancellable { get; }
Visual Basic
Public ReadOnly Property Cancellable As Boolean
    Get
Visual C++
public:
property bool Cancellable {
    bool get ();
}

Remarks

If Cancellable returns true, event delegates may cancel the command that was announced by the event. To do so, a delegate may call the Cancel() method if it is available. Typically, single-events and post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitAPIEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIEventStatus Enumeration

[image]

Revit 2013 API
RevitAPIEventStatus Enumeration
See Also Send Feedback
Describes the status of an action which triggered a post event.
Describes the status of an action which triggered a post event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum RevitAPIEventStatus
Visual Basic
Public Enumeration RevitAPIEventStatus
Visual C++
public enum class RevitAPIEventStatus

Members

Member name | Description
Failed | The action that triggered this event failed .
Succeeded | The action that triggered this event succeeded.
Cancelled | The action that triggered this event was cancelled by an event handler from the pre-event for the action.

See Also

Autodesk.Revit.DB.Events Namespace


RevitAPIPostDocEventArgs Class

[image]

Revit 2013 API
RevitAPIPostDocEventArgs Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class RevitAPIPostDocEventArgs : RevitAPIPostEventArgs
Visual Basic
Public Class RevitAPIPostDocEventArgs _
    Inherits RevitAPIPostEventArgs
Visual C++
public ref class RevitAPIPostDocEventArgs : public RevitAPIPostEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentCreatedEventArgs
Autodesk.Revit.DB.Events..::..DocumentOpenedEventArgs
Autodesk.Revit.DB.Events..::..DocumentPrintedEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavedAsEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavedEventArgs
Autodesk.Revit.DB.Events..::..DocumentSynchronizedWithCentralEventArgs
Autodesk.Revit.DB.Events..::..FileExportedEventArgs
Autodesk.Revit.DB.Events..::..FileImportedEventArgs
Autodesk.Revit.DB.Events..::..ViewPrintedEventArgs

See Also

RevitAPIPostDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPostDocEventArgs Members

[image] [image]

Revit 2013 API
RevitAPIPostDocEventArgs Members
RevitAPIPostDocEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIPostDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

RevitAPIPostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostDocEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPIPostDocEventArgs Methods
RevitAPIPostDocEventArgs Class See Also Send Feedback

The RevitAPIPostDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostDocEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPIPostDocEventArgs Properties
RevitAPIPostDocEventArgs Class See Also Send Feedback

The RevitAPIPostDocEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)

See Also

RevitAPIPostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2013 API
RevitAPIPostDocEventArgs..::..Document Property
RevitAPIPostDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

RevitAPIPostDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Class

[image]

Revit 2013 API
RevitAPIPostEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any post-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPostEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPIPostEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPostEventArgs : public RevitAPIEventArgs

Remarks

A post-event is the event raised after execution of the process that was related with the event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..DocumentClosedEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs

See Also

RevitAPIPostEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Members

[image] [image]

Revit 2013 API
RevitAPIPostEventArgs Members
RevitAPIPostEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPIPostEventArgs Methods
RevitAPIPostEventArgs Class See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPostEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPIPostEventArgs Properties
RevitAPIPostEventArgs Class See Also Send Feedback

The RevitAPIPostEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


Status Property

[image]

Revit 2013 API
RevitAPIPostEventArgs..::..Status Property
RevitAPIPostEventArgs Class See Also Send Feedback
Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public RevitAPIEventStatus Status { get; }
Visual Basic
Public ReadOnly Property Status As RevitAPIEventStatus
    Get
Visual C++
public:
property RevitAPIEventStatus Status {
    RevitAPIEventStatus get ();
}

See Also

RevitAPIPostEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreDocEventArgs Class

[image]

Revit 2013 API
RevitAPIPreDocEventArgs Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class RevitAPIPreDocEventArgs : RevitAPIPreEventArgs
Visual Basic
Public Class RevitAPIPreDocEventArgs _
    Inherits RevitAPIPreEventArgs
Visual C++
public ref class RevitAPIPreDocEventArgs : public RevitAPIPreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..DocumentClosingEventArgs
Autodesk.Revit.DB.Events..::..DocumentPrintingEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavingAsEventArgs
Autodesk.Revit.DB.Events..::..DocumentSavingEventArgs
Autodesk.Revit.DB.Events..::..DocumentSynchronizingWithCentralEventArgs
Autodesk.Revit.DB.Events..::..FileExportingEventArgs
Autodesk.Revit.DB.Events..::..FileImportingEventArgs
Autodesk.Revit.DB.Events..::..ViewPrintingEventArgs

See Also

RevitAPIPreDocEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPreDocEventArgs Members

[image] [image]

Revit 2013 API
RevitAPIPreDocEventArgs Members
RevitAPIPreDocEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIPreDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event.

See Also

RevitAPIPreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreDocEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPIPreDocEventArgs Methods
RevitAPIPreDocEventArgs Class See Also Send Feedback

The RevitAPIPreDocEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreDocEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPIPreDocEventArgs Properties
RevitAPIPreDocEventArgs Class See Also Send Feedback

The RevitAPIPreDocEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event.

See Also

RevitAPIPreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


Document Property

[image]

Revit 2013 API
RevitAPIPreDocEventArgs..::..Document Property
RevitAPIPreDocEventArgs Class See Also Send Feedback
The document associated with the event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

RevitAPIPreDocEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Class

[image]

Revit 2013 API
RevitAPIPreEventArgs Class
Members See Also Send Feedback
The class is used as a base class for the arguments for any pre-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RevitAPIPreEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPIPreEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPIPreEventArgs : public RevitAPIEventArgs

Remarks

A pre-event is the event raised before executing the process that was related with the event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..DocumentCreatingEventArgs
Autodesk.Revit.DB.Events..::..DocumentOpeningEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs

See Also

RevitAPIPreEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Members

[image] [image]

Revit 2013 API
RevitAPIPreEventArgs Members
RevitAPIPreEventArgs Class Methods Properties See Also Send Feedback

The RevitAPIPreEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it.
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPIPreEventArgs Methods
RevitAPIPreEventArgs Class See Also Send Feedback

The RevitAPIPreEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it.
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancel Method

[image]

Revit 2013 API
RevitAPIPreEventArgs..::..Cancel Method
RevitAPIPreEventArgs Class See Also Send Feedback
When the event is cancellable, may call the Cancel() method to cancel it.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

Not every event is cancellable. Whether or not an event may be cancelled is indicated by IsCancellable() method.

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPIPreEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPIPreEventArgs Properties
RevitAPIPreEventArgs Class See Also Send Feedback

The RevitAPIPreEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

RevitAPIPreEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Class

[image]

Revit 2013 API
RevitAPISingleEventArgs Class
Members See Also Send Feedback
The class is used as a base class for arguments of any single-event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RevitAPISingleEventArgs : RevitAPIEventArgs
Visual Basic
Public Class RevitAPISingleEventArgs _
    Inherits RevitAPIEventArgs
Visual C++
public ref class RevitAPISingleEventArgs : public RevitAPIEventArgs

Remarks

A single event is an event that is not directly related to another event, meaning that there is no corresponding pre-event or post-event surrounding a single event.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPISingleEventArgs
Autodesk.Revit.DB.Events..::..ApplicationInitializedEventArgs
Autodesk.Revit.DB.Events..::..DocumentChangedEventArgs
Autodesk.Revit.DB.Events..::..FailuresProcessingEventArgs
Autodesk.Revit.DB.Events..::..ProgressChangedEventArgs

See Also

RevitAPISingleEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Members

[image] [image]

Revit 2013 API
RevitAPISingleEventArgs Members
RevitAPISingleEventArgs Class Methods Properties See Also Send Feedback

The RevitAPISingleEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

RevitAPISingleEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Methods

[image] [image]

Revit 2013 API
RevitAPISingleEventArgs Methods
RevitAPISingleEventArgs Class See Also Send Feedback

The RevitAPISingleEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitAPISingleEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitAPISingleEventArgs Properties

[image] [image]

Revit 2013 API
RevitAPISingleEventArgs Properties
RevitAPISingleEventArgs Class See Also Send Feedback

The RevitAPISingleEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)

See Also

RevitAPISingleEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Class

[image]

Revit 2013 API
RevitEventArgs Class
Members See Also Send Feedback
The class is used as base class for all event argument classes.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RevitEventArgs : EventArgs
Visual Basic
Public Class RevitEventArgs _
    Inherits EventArgs
Visual C++
public ref class RevitEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PostEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..CommandEventArgs

See Also

RevitEventArgs Members
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Members

[image] [image]

Revit 2013 API
RevitEventArgs Members
RevitEventArgs Class Methods Properties See Also Send Feedback

The RevitEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Methods

[image] [image]

Revit 2013 API
RevitEventArgs Methods
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


RevitEventArgs Properties

[image] [image]

Revit 2013 API
RevitEventArgs Properties
RevitEventArgs Class See Also Send Feedback

The RevitEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancel Property

[image]

Revit 2013 API
RevitEventArgs..::..Cancel Property
RevitEventArgs Class See Also Send Feedback
Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Cancel { get; set; }
Visual Basic
Public Overridable Property Cancel As Boolean
    Get
    Set
Visual C++
public:
virtual property bool Cancel {
    bool get ();
    void set (bool value);
}

Remarks

If an event delegate wishes to cancel the event, it should set the value of this property to True. Not every event is cancellable. Whether or not an event may be cancelled is indicated by the value of 'Cancellable' property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if an event delegate attempts to cancel a non-cancellable event.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


Cancellable Property

[image]

Revit 2013 API
RevitEventArgs..::..Cancellable Property
RevitEventArgs Class See Also Send Feedback
Indicates whether an event may be cancelled by an event delegate.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Cancellable { get; }
Visual Basic
Public Overridable ReadOnly Property Cancellable As Boolean
    Get
Visual C++
public:
virtual property bool Cancellable {
    bool get ();
}

Remarks

If 'Cancellable' is true, event delegates may cancel the command that was announced by the event. To do so, a delegate would set the 'Cancel' property to True. Typically, post-events (e.g. DocumentPrinted) are not cancellable, while most pre-events (e.g. DocumentPrinting) are cancellable, except for special conditions and situations, such as when the Revit application is being closed or if an event is raised during another event.

See Also

RevitEventArgs Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Class

[image]

Revit 2013 API
SynchronizeWithCentralOptions Class
Members See Also Send Feedback
Options for save to central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SynchronizeWithCentralOptions
Visual Basic
Public Class SynchronizeWithCentralOptions
Visual C++
public ref class SynchronizeWithCentralOptions

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Events..::..SynchronizeWithCentralOptions

See Also

SynchronizeWithCentralOptions Members
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Members

[image] [image]

Revit 2013 API
SynchronizeWithCentralOptions Members
SynchronizeWithCentralOptions Class Methods Properties See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CompactCentralFile | Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save.
Public property | RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property | RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property | RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property | RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
Public property | RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property | SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Methods

[image] [image]

Revit 2013 API
SynchronizeWithCentralOptions Methods
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SynchronizeWithCentralOptions Properties

[image] [image]

Revit 2013 API
SynchronizeWithCentralOptions Properties
SynchronizeWithCentralOptions Class See Also Send Feedback

The SynchronizeWithCentralOptions type exposes the following members.

Properties

 | Name | Description
Public property | CompactCentralFile | Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save.
Public property | RelinquishBorrowedElements | Indicates whether Revit should relinquish borrowed elements after synchronizing with central.
Public property | RelinquishFamilyWorksets | Indicates whether Revit should relinquish Family worksets after synchronizing with central.
Public property | RelinquishProjectStandardWorksets | Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.
Public property | RelinquishUserCreatedWorksets | Indicates whether Revit should relinquish user-created worksets after synchronizing with central.
Public property | RelinquishViewWorksets | Indicates whether Revit should relinquish View worksets after synchronizing with central.
Public property | SaveLocalFile | Indicates whether Revit should save the local file before and after synchronizing with central.

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


CompactCentralFile Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..CompactCentralFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should compact the central model while synchronizing with central. This option reduces the size of the central model but many increase the time it takes to perform the save.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool CompactCentralFile { get; }
Visual Basic
Public ReadOnly Property CompactCentralFile As Boolean
    Get
Visual C++
public:
property bool CompactCentralFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishBorrowedElements Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..RelinquishBorrowedElements Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish borrowed elements after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RelinquishBorrowedElements { get; }
Visual Basic
Public ReadOnly Property RelinquishBorrowedElements As Boolean
    Get
Visual C++
public:
property bool RelinquishBorrowedElements {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishFamilyWorksets Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..RelinquishFamilyWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Family worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RelinquishFamilyWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishFamilyWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishFamilyWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishProjectStandardWorksets Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..RelinquishProjectStandardWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish Project Standard worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RelinquishProjectStandardWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishProjectStandardWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishProjectStandardWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishUserCreatedWorksets Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..RelinquishUserCreatedWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish user-created worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RelinquishUserCreatedWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishUserCreatedWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishUserCreatedWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


RelinquishViewWorksets Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..RelinquishViewWorksets Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should relinquish View worksets after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RelinquishViewWorksets { get; }
Visual Basic
Public ReadOnly Property RelinquishViewWorksets As Boolean
    Get
Visual C++
public:
property bool RelinquishViewWorksets {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


SaveLocalFile Property

[image]

Revit 2013 API
SynchronizeWithCentralOptions..::..SaveLocalFile Property
SynchronizeWithCentralOptions Class See Also Send Feedback
Indicates whether Revit should save the local file before and after synchronizing with central.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveLocalFile { get; }
Visual Basic
Public ReadOnly Property SaveLocalFile As Boolean
    Get
Visual C++
public:
property bool SaveLocalFile {
    bool get ();
}

See Also

SynchronizeWithCentralOptions Class
Autodesk.Revit.DB.Events Namespace


UndoOperation Enumeration

[image]

Revit 2013 API
UndoOperation Enumeration
See Also Send Feedback
The operation associated with DocumentChanged event

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum UndoOperation
Visual Basic
Public Enumeration UndoOperation
Visual C++
public enum class UndoOperation

Members

Member name | Description
TransactionCommitted | A transaction was committed
TransactionRolledBack | A transaction was rolled back
TransactionGroupRolledBack | A transaction group was rolled back
TransactionUndone | A transaction was undone
TransactionRedone | A transaction was redone

See Also

Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Class

[image]

Revit 2013 API
ViewPrintedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewPrinted event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class ViewPrintedEventArgs : RevitAPIPostDocEventArgs
Visual Basic
Public Class ViewPrintedEventArgs _
    Inherits RevitAPIPostDocEventArgs
Visual C++
public ref class ViewPrintedEventArgs : public RevitAPIPostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events..::..ViewPrintedEventArgs

See Also

ViewPrintedEventArgs Members
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Members

[image] [image]

Revit 2013 API
ViewPrintedEventArgs Members
ViewPrintedEventArgs Class Methods Properties See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Index | The index of the view being printed out of the set of all views being printed.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)
Public property | TotalViews | The number of all views being printed.
Public property | View | The view that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Methods

[image] [image]

Revit 2013 API
ViewPrintedEventArgs Methods
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintedEventArgs Properties

[image] [image]

Revit 2013 API
ViewPrintedEventArgs Properties
ViewPrintedEventArgs Class See Also Send Feedback

The ViewPrintedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPostDocEventArgs.)
Public property | Index | The index of the view being printed out of the set of all views being printed.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler). (Inherited from RevitAPIPostEventArgs.)
Public property | TotalViews | The number of all views being printed.
Public property | View | The view that was printed.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


Index Property

[image]

Revit 2013 API
ViewPrintedEventArgs..::..Index Property
ViewPrintedEventArgs Class See Also Send Feedback
The index of the view being printed out of the set of all views being printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Remarks

The index is zero-based. When a single view is being printed, this value should be 0.

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


TotalViews Property

[image]

Revit 2013 API
ViewPrintedEventArgs..::..TotalViews Property
ViewPrintedEventArgs Class See Also Send Feedback
The number of all views being printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int TotalViews { get; }
Visual Basic
Public ReadOnly Property TotalViews As Integer
    Get
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


View Property

[image]

Revit 2013 API
ViewPrintedEventArgs..::..View Property
ViewPrintedEventArgs Class See Also Send Feedback
The view that was printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintedEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Class

[image]

Revit 2013 API
ViewPrintingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewPrinting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public class ViewPrintingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class ViewPrintingEventArgs _
    Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class ViewPrintingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitAPIEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreEventArgs
Autodesk.Revit.DB.Events..::..RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events..::..ViewPrintingEventArgs

See Also

ViewPrintingEventArgs Members
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Members

[image] [image]

Revit 2013 API
ViewPrintingEventArgs Members
ViewPrintingEventArgs Class Methods Properties See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Index | The index of the view being printed out of the set of all views being printed.
Public property | Settings | The print settings of the active printing session.
Public property | TotalViews | The number of all views being printed.
Public property | View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Methods

[image] [image]

Revit 2013 API
ViewPrintingEventArgs Methods
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Cancel | When the event is cancellable, may call the Cancel() method to cancel it. (Inherited from RevitAPIPreEventArgs.)
Public method | Dispose | (Inherited from RevitAPIEventArgs.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsCancelled | Indicates whether the event is being cancelled. (Inherited from RevitAPIEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


ViewPrintingEventArgs Properties

[image] [image]

Revit 2013 API
ViewPrintingEventArgs Properties
ViewPrintingEventArgs Class See Also Send Feedback

The ViewPrintingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitAPIEventArgs.)
Public property | Document | The document associated with the event. (Inherited from RevitAPIPreDocEventArgs.)
Public property | Index | The index of the view being printed out of the set of all views being printed.
Public property | Settings | The print settings of the active printing session.
Public property | TotalViews | The number of all views being printed.
Public property | View | The view to be printed.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Index Property

[image]

Revit 2013 API
ViewPrintingEventArgs..::..Index Property
ViewPrintingEventArgs Class See Also Send Feedback
The index of the view being printed out of the set of all views being printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int Index { get; }
Visual Basic
Public ReadOnly Property Index As Integer
    Get
Visual C++
public:
property int Index {
    int get ();
}

Remarks

The index is zero-based. When a single view is being printed, this value should be 0.

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Settings Property

[image]

Revit 2013 API
ViewPrintingEventArgs..::..Settings Property
ViewPrintingEventArgs Class See Also Send Feedback
The print settings of the active printing session.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public IPrintSetting Settings { get; }
Visual Basic
Public ReadOnly Property Settings As IPrintSetting
    Get
Visual C++
public:
property IPrintSetting^ Settings {
    IPrintSetting^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


TotalViews Property

[image]

Revit 2013 API
ViewPrintingEventArgs..::..TotalViews Property
ViewPrintingEventArgs Class See Also Send Feedback
The number of all views being printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public int TotalViews { get; }
Visual Basic
Public ReadOnly Property TotalViews As Integer
    Get
Visual C++
public:
property int TotalViews {
    int get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


View Property

[image]

Revit 2013 API
ViewPrintingEventArgs..::..View Property
ViewPrintingEventArgs Class See Also Send Feedback
The view to be printed.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2010

Syntax

C#
public View View { get; }
Visual Basic
Public ReadOnly Property View As View
    Get
Visual C++
public:
property View^ View {
    View^ get ();
}

See Also

ViewPrintingEventArgs Class
Autodesk.Revit.DB.Events Namespace


Autodesk.Revit.DB.ExtensibleStorage Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.ExtensibleStorage Namespace
Send Feedback

Classes

 | Class | Description
Public class | DataStorage | An element which allows an API applications to organize and store data.
Public class | Entity | An object stored in the Extensible Storage framework. An Entity is described by a Schema, which serves both to identify an Entity, and to describe its contents (Fields).
Public class | Field | The description of a field within a Schema in the Extensible Storage framework. Contains the field's name, type, access control and documentation.
Public class | FieldBuilder | This class is used to create Fields in the Extensible Storage framework.
Public class | Schema | The description of a single object (Entity) in the Extensible Storage framework. Contains identity information, documentation and the list of fields to be stored in the Entity.
Public class | SchemaBuilder | This class is used to create Schemas in the Extensible Storage framework.

Enumerations

 | Enumeration | Description
Public enumeration | AccessLevel | Defines access levels to objects in the Extensible Storage framework.
Public enumeration | ContainerType |


AccessLevel Enumeration

[image]

Revit 2013 API
AccessLevel Enumeration
See Also Send Feedback
Defines access levels to objects in the Extensible Storage framework.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum AccessLevel
Visual Basic
Public Enumeration AccessLevel
Visual C++
public enum class AccessLevel

Members

Member name | Description
Public | Anybody has access to the object.
Vendor | Only object vendor has access to it.
Application | Only application that created the object has access to it.

See Also

Autodesk.Revit.DB.ExtensibleStorage Namespace


ContainerType Enumeration

[image]

Revit 2013 API
ContainerType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ContainerType
Visual Basic
Public Enumeration ContainerType
Visual C++
public enum class ContainerType

Members

Member name | Description
Simple | One instance of the value included directly
Array | An expandable array of values
Map | An ordered map from keys to values

See Also

Autodesk.Revit.DB.ExtensibleStorage Namespace


DataStorage Class

[image]

Revit 2013 API
DataStorage Class
Members See Also Send Feedback
An element which allows an API applications to organize and store data.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DataStorage : Element
Visual Basic
Public Class DataStorage _
    Inherits Element
Visual C++
public ref class DataStorage : public Element

Remarks

Applications can create instances of these elements to logically organize different sets of ExtensibleStorage entities into separate elements. This allows an application to update one set of data in a local workshared project without locking other elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.ExtensibleStorage..::..DataStorage

See Also

DataStorage Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


DataStorage Members

[image] [image]

Revit 2013 API
DataStorage Members
DataStorage Class Methods Properties See Also Send Feedback

The DataStorage type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new DataStorage element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DataStorage Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


DataStorage Methods

[image] [image]

Revit 2013 API
DataStorage Methods
DataStorage Class See Also Send Feedback

The DataStorage type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new DataStorage element and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataStorage Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Create Method

[image]

Revit 2013 API
DataStorage..::..Create Method
DataStorage Class See Also Send Feedback
Creates a new DataStorage element and adds it to the document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static DataStorage Create(
    Document doc
)
Visual Basic
Public Shared Function Create ( _
    doc As Document _
) As DataStorage
Visual C++
public:
static DataStorage^ Create(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document to which the new element should be added.

Return Value

The newly created DataStorage element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DataStorage Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


DataStorage Properties

[image] [image]

Revit 2013 API
DataStorage Properties
DataStorage Class See Also Send Feedback

The DataStorage type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DataStorage Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Parameter Property

[image] [image]

Revit 2013 API
DataStorage..::..Parameter Property
DataStorage Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DataStorage Class
DataStorage Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Class

[image]

Revit 2013 API
Entity Class
Members See Also Send Feedback
An object stored in the Extensible Storage framework. An Entity is described by a Schema, which serves both to identify an Entity, and to describe its contents (Fields).

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Entity : IDisposable
Visual Basic
Public Class Entity _
    Implements IDisposable
Visual C++
public ref class Entity : IDisposable

Remarks

An Entity is similar to an object in most object-oriented languages, while a Schema is the class of that object. The Get and Set methods are central - they provide access to the fields of the Entity. Note that an unitialized Entity retrieved from an Element or another Entity (if it has not been created yet) will be represented as an invalid entity, not nullNothingnullptra null reference (Nothing in Visual Basic). If an Element containing an Entity is split (e.g., a wall split), the Entity and its data will exist in both new Elements. If an Element containing an Entity is copied, the Element copy will also contain a copy of the Entity and its data. If an Entity stores an ElementId, and the Element with that ElementId is deleted, the stored ElementId will automatically be set to ElementId.InvalidElementId (-1).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage..::..Entity

See Also

Entity Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Members

[image] [image]

Revit 2013 API
Entity Members
Entity Class Constructors Methods Properties See Also Send Feedback

The Entity type exposes the following members.

Constructors

 | Name | Description
Public method | Entity()()()() | The default-constructed Entity is invalid.
Public method | Entity(Guid) | Creates a new Entity corresponding to the Schema of the specified GUID.
Public method | Entity(Entity) | Initializes a new instance of the Entity class
Public method | Entity(Schema) | Creates a new Entity corresponding to the Schema.

Methods

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.
Public method | Dispose | Releases all resources used by the Entity
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks whether this Entity has a live Schema corresponding to it.
Public method | ReadAccessGranted | Checks whether this Entity may be retrieved by the current add-in.
Public method | RecognizedField | Checks whether a Field belongs to the same Schema as this Entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether this Entity may be stored by the current add-in.

Properties

 | Name | Description
Public property | Schema | The Schema describing this Entity.
Public property | SchemaGUID | The GUID of the Schema describing this Entity.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Constructor

[image] [image]

Revit 2013 API
Entity Constructor
Entity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Entity()()()() | The default-constructed Entity is invalid.
Public method | Entity(Guid) | Creates a new Entity corresponding to the Schema of the specified GUID.
Public method | Entity(Entity) | Initializes a new instance of the Entity class
Public method | Entity(Schema) | Creates a new Entity corresponding to the Schema.

See Also

Entity Class
Entity Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Constructor

[image]

Revit 2013 API
Entity Constructor
Entity Class See Also Send Feedback
The default-constructed Entity is invalid.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Entity()
Visual Basic
Public Sub New
Visual C++
public:
Entity()

Remarks

Invalid entities may be used as token values. E.g., setting an invalid subentity is equivalent to deleting the stored one.

See Also

Entity Class
Entity Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Constructor (Guid)

[image]

Revit 2013 API
Entity Constructor (Guid)
Entity Class See Also Send Feedback
Creates a new Entity corresponding to the Schema of the specified GUID.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Entity(
    Guid schemaGUID
)
Visual Basic
Public Sub New ( _
    schemaGUID As Guid _
)
Visual C++
public:
Entity(
    Guid schemaGUID
)

Parameters

schemaGUID
Type: System..::..Guid

Remarks

You can store the newly created Entity in an Element or in another Entity. If you do not have write access to the Schema, an exception will be thrown. If the GUID does not correspond to a known Schema, the Entity will be invalid and an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The GUID does not correspond to any Schema in memory.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Writing of Entities of this Schema is not allowed to the current add-in.

See Also

Entity Class
Entity Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Constructor (Entity)

[image]

Revit 2013 API
Entity Constructor (Entity)
Entity Class See Also Send Feedback
Initializes a new instance of the Entity class

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Entity(
    Entity entity
)
Visual Basic
Public Sub New ( _
    entity As Entity _
)
Visual C++
public:
Entity(
    Entity^ entity
)

Parameters

entity
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Entity

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Entity Class
Entity Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Constructor (Schema)

[image]

Revit 2013 API
Entity Constructor (Schema)
Entity Class See Also Send Feedback
Creates a new Entity corresponding to the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Entity(
    Schema schema
)
Visual Basic
Public Sub New ( _
    schema As Schema _
)
Visual C++
public:
Entity(
    Schema^ schema
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema

Remarks

You can store the newly created Entity in an Element or in another Entity. If you do not have write access to the Schema, an exception will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Writing of Entities of this Schema is not allowed to the current add-in.

See Also

Entity Class
Entity Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Methods

[image] [image]

Revit 2013 API
Entity Methods
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Methods

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Checks whether this Entity has a live Schema corresponding to it.
Public method | ReadAccessGranted | Checks whether this Entity may be retrieved by the current add-in.
Public method | RecognizedField | Checks whether a Field belongs to the same Schema as this Entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether this Entity may be stored by the current add-in.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Clear Method

[image] [image]

Revit 2013 API
Entity..::..Clear Method
Entity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Clear(String) | Resets the field to its default value.
Public method | Clear(Field) | Resets the field to its default value.

See Also

Entity Class
Entity Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Clear Method (String)

[image]

Revit 2013 API
Entity..::..Clear Method (String)
Entity Class See Also Send Feedback
Resets the field to its default value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Clear(
    string fieldName
)
Visual Basic
Public Sub Clear ( _
    fieldName As String _
)
Visual C++
public:
void Clear(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
The name of the field to clear.

Remarks

The default value is zero for numeric fields, invalid value for identifiers and entities, and empty for strings and containers. This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema. -or- This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Entity is invalid.

See Also

Entity Class
Clear Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Clear Method (Field)

[image]

Revit 2013 API
Entity..::..Clear Method (Field)
Entity Class See Also Send Feedback
Resets the field to its default value.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Clear(
    Field field
)
Visual Basic
Public Sub Clear ( _
    field As Field _
)
Visual C++
public:
void Clear(
    Field^ field
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The field to clear.

Remarks

The default value is zero for numeric fields, invalid value for identifiers and entities, and empty for strings and containers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Field belongs to a different Schema from this Entity, or this Entity is invalid. -or- This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Entity Class
Clear Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Dispose Method

[image]

Revit 2013 API
Entity..::..Dispose Method
Entity Class See Also Send Feedback
Releases all resources used by the Entity

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Get Method

[image] [image]

Revit 2013 API
Entity..::..Get Method
Entity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Get<(Of <<'(FieldType>)>>)(String) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(String, DisplayUnitType) | Retrieves the value of the field in the entity.
Public method | Get<(Of <<'(FieldType>)>>)(Field, DisplayUnitType) | Retrieves the value of the field in the entity.

See Also

Entity Class
Entity Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Get(FieldType) Method (String)

[image]

Revit 2013 API
Entity..::..Get<(Of <(<'FieldType>)>)> Method (String)
Entity Class See Also Send Feedback
Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldType Get<FieldType>(
    string fieldName
)
Visual Basic
Public Function Get(Of FieldType) ( _
    fieldName As String _
) As FieldType
Visual C++
public:
generic<typename FieldType>
FieldType Get(
    String^ fieldName
)

Parameters

fieldName
Type: System..::..String
The name of the field to retrieve.

Type Parameters

FieldType

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits parameter is required for floating-point fields.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents reading.

See Also

Entity Class
Get Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Get(FieldType) Method (Field)

[image]

Revit 2013 API
Entity..::..Get<(Of <(<'FieldType>)>)> Method (Field)
Entity Class See Also Send Feedback
Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldType Get<FieldType>(
    Field field
)
Visual Basic
Public Function Get(Of FieldType) ( _
    field As Field _
) As FieldType
Visual C++
public:
generic<typename FieldType>
FieldType Get(
    Field^ field
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The field to retrieve.

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits parameter is required for floating-point fields.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents reading.

See Also

Entity Class
Get Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Get(FieldType) Method (String, DisplayUnitType)

[image]

Revit 2013 API
Entity..::..Get<(Of <(<'FieldType>)>)> Method (String, DisplayUnitType)
Entity Class See Also Send Feedback
Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldType Get<FieldType>(
    string fieldName,
    DisplayUnitType displayUnits
)
Visual Basic
Public Function Get(Of FieldType) ( _
    fieldName As String, _
    displayUnits As DisplayUnitType _
) As FieldType
Visual C++
public:
generic<typename FieldType>
FieldType Get(
    String^ fieldName,
    DisplayUnitType displayUnits
)

Parameters

fieldName
Type: System..::..String
The name of the field to retrieve.
displayUnits
Type: Autodesk.Revit.DB..::..DisplayUnitType
The units to which the value will be converted before returning. Must match the UnitType specified when creating the Schema.

Type Parameters

FieldType

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits value is not compatible with the field description.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents reading.

See Also

Entity Class
Get Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Get(FieldType) Method (Field, DisplayUnitType)

[image]

Revit 2013 API
Entity..::..Get<(Of <(<'FieldType>)>)> Method (Field, DisplayUnitType)
Entity Class See Also Send Feedback
Retrieves the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldType Get<FieldType>(
    Field field,
    DisplayUnitType displayUnits
)
Visual Basic
Public Function Get(Of FieldType) ( _
    field As Field, _
    displayUnits As DisplayUnitType _
) As FieldType
Visual C++
public:
generic<typename FieldType>
FieldType Get(
    Field^ field,
    DisplayUnitType displayUnits
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The field to retrieve.
displayUnits
Type: Autodesk.Revit.DB..::..DisplayUnitType
The units to which the value will be converted before returning. Must match the UnitType specified when creating the Schema.

Type Parameters

FieldType

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits value is not compatible with the field description.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents reading.

See Also

Entity Class
Get Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


IsValid Method

[image]

Revit 2013 API
Entity..::..IsValid Method
Entity Class See Also Send Feedback
Checks whether this Entity has a live Schema corresponding to it.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the Entity is valid.

Remarks

Invalid entities may be used as token values. E.g., setting an invalid subentity is equivalent to deleting the stored one.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ReadAccessGranted Method

[image]

Revit 2013 API
Entity..::..ReadAccessGranted Method
Entity Class See Also Send Feedback
Checks whether this Entity may be retrieved by the current add-in.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ReadAccessGranted()
Visual Basic
Public Function ReadAccessGranted As Boolean
Visual C++
public:
bool ReadAccessGranted()

Return Value

True if read access is allowed.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


RecognizedField Method

[image]

Revit 2013 API
Entity..::..RecognizedField Method
Entity Class See Also Send Feedback
Checks whether a Field belongs to the same Schema as this Entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RecognizedField(
    Field field
)
Visual Basic
Public Function RecognizedField ( _
    field As Field _
) As Boolean
Visual C++
public:
bool RecognizedField(
    Field^ field
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The Field to check.

Return Value

True if the Field belongs to the same Schema as this Entity.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Set Method

[image] [image]

Revit 2013 API
Entity..::..Set Method
Entity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(String, FieldType, DisplayUnitType) | Stores the value of the field in the entity.
Public method | Set<(Of <<'(FieldType>)>>)(Field, FieldType, DisplayUnitType) | Stores the value of the field in the entity.

See Also

Entity Class
Entity Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Set(FieldType) Method (String, FieldType)

[image]

Revit 2013 API
Entity..::..Set<(Of <(<'FieldType>)>)> Method (String, FieldType)
Entity Class See Also Send Feedback
Stores the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set<FieldType>(
    string fieldName,
    FieldType value
)
Visual Basic
Public Sub Set(Of FieldType) ( _
    fieldName As String, _
    value As FieldType _
)
Visual C++
public:
generic<typename FieldType>
void Set(
    String^ fieldName,
    FieldType value
)

Parameters

fieldName
Type: System..::..String
The name of the field to update.
value
Type: FieldType

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits parameter is required for floating-point fields.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid floating-point value.

See Also

Entity Class
Set Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Set(FieldType) Method (Field, FieldType)

[image]

Revit 2013 API
Entity..::..Set<(Of <(<'FieldType>)>)> Method (Field, FieldType)
Entity Class See Also Send Feedback
Stores the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set<FieldType>(
    Field field,
    FieldType value
)
Visual Basic
Public Sub Set(Of FieldType) ( _
    field As Field, _
    value As FieldType _
)
Visual C++
public:
generic<typename FieldType>
void Set(
    Field^ field,
    FieldType value
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The field to update.
value
Type: FieldType

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits parameter is required for floating-point fields.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid floating-point value.

See Also

Entity Class
Set Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Set(FieldType) Method (String, FieldType, DisplayUnitType)

[image]

Revit 2013 API
Entity..::..Set<(Of <(<'FieldType>)>)> Method (String, FieldType, DisplayUnitType)
Entity Class See Also Send Feedback
Stores the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set<FieldType>(
    string fieldName,
    FieldType value,
    DisplayUnitType displayUnits
)
Visual Basic
Public Sub Set(Of FieldType) ( _
    fieldName As String, _
    value As FieldType, _
    displayUnits As DisplayUnitType _
)
Visual C++
public:
generic<typename FieldType>
void Set(
    String^ fieldName,
    FieldType value,
    DisplayUnitType displayUnits
)

Parameters

fieldName
Type: System..::..String
The name of the field to update.
value
Type: FieldType
displayUnits
Type: Autodesk.Revit.DB..::..DisplayUnitType
The units from which the value will be converted before storing. Must match the UnitType specified when creating the Schema.

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The name matches no field in this Entity's Schema.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits value is not compatible with the field description.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid floating-point value.

See Also

Entity Class
Set Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


Set(FieldType) Method (Field, FieldType, DisplayUnitType)

[image]

Revit 2013 API
Entity..::..Set<(Of <(<'FieldType>)>)> Method (Field, FieldType, DisplayUnitType)
Entity Class See Also Send Feedback
Stores the value of the field in the entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set<FieldType>(
    Field field,
    FieldType value,
    DisplayUnitType displayUnits
)
Visual Basic
Public Sub Set(Of FieldType) ( _
    field As Field, _
    value As FieldType, _
    displayUnits As DisplayUnitType _
)
Visual C++
public:
generic<typename FieldType>
void Set(
    Field^ field,
    FieldType value,
    DisplayUnitType displayUnits
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
The field to update.
value
Type: FieldType
displayUnits
Type: Autodesk.Revit.DB..::..DisplayUnitType
The units from which the value will be converted before storing. Must match the UnitType specified when creating the Schema.

Type Parameters

FieldType
The type of the field

Remarks

The template parameter must match the type of the field (specified when creating the Schema) exactly; no conversions will be performed inside this method (but may be performed on the returned value). The types for containers are IList for arrays and IDictionary for maps.

This method only modifies your copy of the Entity. Store the Entity in an element or another Entity to save the new value. Write access check is not performed on each call to Set. Instead, write access is checked when you try to save the Entity in an Element or another Entity.

This method is a shortcut that will look up the field by name. If you want to call it on many entities, it is faster if you look up the field yourself.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The Field belongs to a different Schema from this Entity, or this Entity is invalid.
Autodesk.Revit.Exceptions..::..ArgumentException | Requested type does not match the field type.
Autodesk.Revit.Exceptions..::..ArgumentException | The displayUnits value is not compatible with the field description.
Autodesk.Revit.Exceptions..::..ArgumentException | This field's subschema prevents writing.
Autodesk.Revit.Exceptions..::..ArgumentException | Invalid floating-point value.

See Also

Entity Class
Set Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


WriteAccessGranted Method

[image]

Revit 2013 API
Entity..::..WriteAccessGranted Method
Entity Class See Also Send Feedback
Checks whether this Entity may be stored by the current add-in.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool WriteAccessGranted()
Visual Basic
Public Function WriteAccessGranted As Boolean
Visual C++
public:
bool WriteAccessGranted()

Return Value

True if write access is allowed.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Entity Properties

[image] [image]

Revit 2013 API
Entity Properties
Entity Class See Also Send Feedback

The Entity type exposes the following members.

Properties

 | Name | Description
Public property | Schema | The Schema describing this Entity.
Public property | SchemaGUID | The GUID of the Schema describing this Entity.

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Property

[image]

Revit 2013 API
Entity..::..Schema Property
Entity Class See Also Send Feedback
The Schema describing this Entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Schema Schema { get; }
Visual Basic
Public ReadOnly Property Schema As Schema
    Get
Visual C++
public:
property Schema^ Schema {
    Schema^ get ();
}

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaGUID Property

[image]

Revit 2013 API
Entity..::..SchemaGUID Property
Entity Class See Also Send Feedback
The GUID of the Schema describing this Entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid SchemaGUID { get; }
Visual Basic
Public ReadOnly Property SchemaGUID As Guid
    Get
Visual C++
public:
property Guid SchemaGUID {
    Guid get ();
}

See Also

Entity Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Field Class

[image]

Revit 2013 API
Field Class
Members See Also Send Feedback
The description of a field within a Schema in the Extensible Storage framework. Contains the field's name, type, access control and documentation.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Field : IDisposable
Visual Basic
Public Class Field _
    Implements IDisposable
Visual C++
public ref class Field : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage..::..Field

See Also

Field Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Field Members

[image] [image]

Revit 2013 API
Field Members
Field Class Methods Properties See Also Send Feedback

The Field type exposes the following members.

Methods

 | Name | Description
Public method | CompatibleDisplayUnitType | Checks if the specified type is compatible with the field description.
Public method | Dispose | Releases all resources used by the Field
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SubEntityReadAccessGranted | Checks whether there is read access to subentities storable in this field.
Public method | SubEntityWriteAccessGranted | Checks whether there is write access to subentities storable in this field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContainerType | Reports whether this is a simple field containing one value, or a container of multiple values.
Public property | Documentation | The overall description of the Field.
Public property | FieldName | The name of the field.
Public property | KeyType | The type of the keys stored in the field.
Public property | Schema | The Schema to which this Field belongs.
Public property | SubSchema | The Schema describing the subentity (or subentities) stored in this Field.
Public property | SubSchemaGUID | The GUID of the Schema describing the subentity (or subentities) stored in this Field.
Public property | UnitType | The type of units represented by values stored in this field
Public property | ValueType | The type of the values stored in the field.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Field Methods

[image] [image]

Revit 2013 API
Field Methods
Field Class See Also Send Feedback

The Field type exposes the following members.

Methods

 | Name | Description
Public method | CompatibleDisplayUnitType | Checks if the specified type is compatible with the field description.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SubEntityReadAccessGranted | Checks whether there is read access to subentities storable in this field.
Public method | SubEntityWriteAccessGranted | Checks whether there is write access to subentities storable in this field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


CompatibleDisplayUnitType Method

[image]

Revit 2013 API
Field..::..CompatibleDisplayUnitType Method
Field Class See Also Send Feedback
Checks if the specified type is compatible with the field description.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool CompatibleDisplayUnitType(
    DisplayUnitType type
)
Visual Basic
Public Function CompatibleDisplayUnitType ( _
    type As DisplayUnitType _
) As Boolean
Visual C++
public:
bool CompatibleDisplayUnitType(
    DisplayUnitType type
)

Parameters

type
Type: Autodesk.Revit.DB..::..DisplayUnitType
The type to check.

Return Value

True if the type is compatible, false otherwise.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Dispose Method

[image]

Revit 2013 API
Field..::..Dispose Method
Field Class See Also Send Feedback
Releases all resources used by the Field

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SubEntityReadAccessGranted Method

[image]

Revit 2013 API
Field..::..SubEntityReadAccessGranted Method
Field Class See Also Send Feedback
Checks whether there is read access to subentities storable in this field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SubEntityReadAccessGranted()
Visual Basic
Public Function SubEntityReadAccessGranted As Boolean
Visual C++
public:
bool SubEntityReadAccessGranted()

Return Value

True if subentities are readable.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SubEntityWriteAccessGranted Method

[image]

Revit 2013 API
Field..::..SubEntityWriteAccessGranted Method
Field Class See Also Send Feedback
Checks whether there is write access to subentities storable in this field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SubEntityWriteAccessGranted()
Visual Basic
Public Function SubEntityWriteAccessGranted As Boolean
Visual C++
public:
bool SubEntityWriteAccessGranted()

Return Value

True if subentities are writable.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Field Properties

[image] [image]

Revit 2013 API
Field Properties
Field Class See Also Send Feedback

The Field type exposes the following members.

Properties

 | Name | Description
Public property | ContainerType | Reports whether this is a simple field containing one value, or a container of multiple values.
Public property | Documentation | The overall description of the Field.
Public property | FieldName | The name of the field.
Public property | KeyType | The type of the keys stored in the field.
Public property | Schema | The Schema to which this Field belongs.
Public property | SubSchema | The Schema describing the subentity (or subentities) stored in this Field.
Public property | SubSchemaGUID | The GUID of the Schema describing the subentity (or subentities) stored in this Field.
Public property | UnitType | The type of units represented by values stored in this field
Public property | ValueType | The type of the values stored in the field.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ContainerType Property

[image]

Revit 2013 API
Field..::..ContainerType Property
Field Class See Also Send Feedback
Reports whether this is a simple field containing one value, or a container of multiple values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ContainerType ContainerType { get; }
Visual Basic
Public ReadOnly Property ContainerType As ContainerType
    Get
Visual C++
public:
property ContainerType ContainerType {
    ContainerType get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Documentation Property

[image]

Revit 2013 API
Field..::..Documentation Property
Field Class See Also Send Feedback
The overall description of the Field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Documentation { get; }
Visual Basic
Public ReadOnly Property Documentation As String
    Get
Visual C++
public:
property String^ Documentation {
    String^ get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldName Property

[image]

Revit 2013 API
Field..::..FieldName Property
Field Class See Also Send Feedback
The name of the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string FieldName { get; }
Visual Basic
Public ReadOnly Property FieldName As String
    Get
Visual C++
public:
property String^ FieldName {
    String^ get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


KeyType Property

[image]

Revit 2013 API
Field..::..KeyType Property
Field Class See Also Send Feedback
The type of the keys stored in the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Type KeyType { get; }
Visual Basic
Public ReadOnly Property KeyType As Type
    Get
Visual C++
public:
property Type^ KeyType {
    Type^ get ();
}

Remarks

For key-value maps, this is the key type. For all other field, this is NULL.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Property

[image]

Revit 2013 API
Field..::..Schema Property
Field Class See Also Send Feedback
The Schema to which this Field belongs.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Schema Schema { get; }
Visual Basic
Public ReadOnly Property Schema As Schema
    Get
Visual C++
public:
property Schema^ Schema {
    Schema^ get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SubSchema Property

[image]

Revit 2013 API
Field..::..SubSchema Property
Field Class See Also Send Feedback
The Schema describing the subentity (or subentities) stored in this Field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Schema SubSchema { get; }
Visual Basic
Public ReadOnly Property SubSchema As Schema
    Get
Visual C++
public:
property Schema^ SubSchema {
    Schema^ get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SubSchemaGUID Property

[image]

Revit 2013 API
Field..::..SubSchemaGUID Property
Field Class See Also Send Feedback
The GUID of the Schema describing the subentity (or subentities) stored in this Field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid SubSchemaGUID { get; }
Visual Basic
Public ReadOnly Property SubSchemaGUID As Guid
    Get
Visual C++
public:
property Guid SubSchemaGUID {
    Guid get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


UnitType Property

[image]

Revit 2013 API
Field..::..UnitType Property
Field Class See Also Send Feedback
The type of units represented by values stored in this field

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UnitType UnitType { get; }
Visual Basic
Public ReadOnly Property UnitType As UnitType
    Get
Visual C++
public:
property UnitType UnitType {
    UnitType get ();
}

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ValueType Property

[image]

Revit 2013 API
Field..::..ValueType Property
Field Class See Also Send Feedback
The type of the values stored in the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Type ValueType { get; }
Visual Basic
Public ReadOnly Property ValueType As Type
    Get
Visual C++
public:
property Type^ ValueType {
    Type^ get ();
}

Remarks

For key-value maps, this is the value type.

See Also

Field Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Class

[image]

Revit 2013 API
FieldBuilder Class
Members See Also Send Feedback
This class is used to create Fields in the Extensible Storage framework.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class FieldBuilder : IDisposable
Visual Basic
Public Class FieldBuilder _
    Implements IDisposable
Visual C++
public ref class FieldBuilder : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage..::..FieldBuilder

See Also

FieldBuilder Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Members

[image] [image]

Revit 2013 API
FieldBuilder Members
FieldBuilder Class Constructors Methods See Also Send Feedback

The FieldBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | FieldBuilder(FieldBuilder) | Initializes a new instance of the FieldBuilder class
Public method | FieldBuilder(Field, SchemaBuilder) | Initializes a new instance of the FieldBuilder class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FieldBuilder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NeedsSubSchemaGUID | Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method | NeedsUnits | Checks whether the field type requires explicit unit conversions.
Public method | Ready | Checks whether the builder may be used.
Public method | SetDocumentation | Sets the documentation string for the Field.
Public method | SetSubSchemaGUID | Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Public method | SetUnitType | Sets the type of units for the field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Constructor

[image] [image]

Revit 2013 API
FieldBuilder Constructor
FieldBuilder Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FieldBuilder(FieldBuilder) | Initializes a new instance of the FieldBuilder class
Public method | FieldBuilder(Field, SchemaBuilder) | Initializes a new instance of the FieldBuilder class

See Also

FieldBuilder Class
FieldBuilder Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Constructor (FieldBuilder)

[image]

Revit 2013 API
FieldBuilder Constructor (FieldBuilder)
FieldBuilder Class See Also Send Feedback
Initializes a new instance of the FieldBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder(
    FieldBuilder from
)
Visual Basic
Public Sub New ( _
    from As FieldBuilder _
)
Visual C++
public:
FieldBuilder(
    FieldBuilder^ from
)

Parameters

from
Type: Autodesk.Revit.DB.ExtensibleStorage..::..FieldBuilder

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldBuilder Class
FieldBuilder Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Constructor (Field, SchemaBuilder)

[image]

Revit 2013 API
FieldBuilder Constructor (Field, SchemaBuilder)
FieldBuilder Class See Also Send Feedback
Initializes a new instance of the FieldBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder(
    Field field,
    SchemaBuilder builder
)
Visual Basic
Public Sub New ( _
    field As Field, _
    builder As SchemaBuilder _
)
Visual C++
public:
FieldBuilder(
    Field^ field,
    SchemaBuilder^ builder
)

Parameters

field
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Field
builder
Type: Autodesk.Revit.DB.ExtensibleStorage..::..SchemaBuilder

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FieldBuilder Class
FieldBuilder Overload
Autodesk.Revit.DB.ExtensibleStorage Namespace


FieldBuilder Methods

[image] [image]

Revit 2013 API
FieldBuilder Methods
FieldBuilder Class See Also Send Feedback

The FieldBuilder type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NeedsSubSchemaGUID | Checks whether the SubSchema GUID needs to be explicitly specified for this field type.
Public method | NeedsUnits | Checks whether the field type requires explicit unit conversions.
Public method | Ready | Checks whether the builder may be used.
Public method | SetDocumentation | Sets the documentation string for the Field.
Public method | SetSubSchemaGUID | Sets the GUID of the Schema of the Entities that are intended to be stored in this field.
Public method | SetUnitType | Sets the type of units for the field.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Dispose Method

[image]

Revit 2013 API
FieldBuilder..::..Dispose Method
FieldBuilder Class See Also Send Feedback
Releases all resources used by the FieldBuilder

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


NeedsSubSchemaGUID Method

[image]

Revit 2013 API
FieldBuilder..::..NeedsSubSchemaGUID Method
FieldBuilder Class See Also Send Feedback
Checks whether the SubSchema GUID needs to be explicitly specified for this field type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool NeedsSubSchemaGUID()
Visual Basic
Public Function NeedsSubSchemaGUID As Boolean
Visual C++
public:
bool NeedsSubSchemaGUID()

Return Value

True if SubSchemaGUID is required.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


NeedsUnits Method

[image]

Revit 2013 API
FieldBuilder..::..NeedsUnits Method
FieldBuilder Class See Also Send Feedback
Checks whether the field type requires explicit unit conversions.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool NeedsUnits()
Visual Basic
Public Function NeedsUnits As Boolean
Visual C++
public:
bool NeedsUnits()

Return Value

True if units are required.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Ready Method

[image]

Revit 2013 API
FieldBuilder..::..Ready Method
FieldBuilder Class See Also Send Feedback
Checks whether the builder may be used.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Ready()
Visual Basic
Public Function Ready As Boolean
Visual C++
public:
bool Ready()

Return Value

True if the SchemaBuilder has not yet been finished.

Remarks

All newly constructed FieldBuilders are usable until the call to the Finish method of the constructing SchemaBuilder.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetDocumentation Method

[image]

Revit 2013 API
FieldBuilder..::..SetDocumentation Method
FieldBuilder Class See Also Send Feedback
Sets the documentation string for the Field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder SetDocumentation(
    string documentation
)
Visual Basic
Public Function SetDocumentation ( _
    documentation As String _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ SetDocumentation(
    String^ documentation
)

Parameters

documentation
Type: System..::..String
The documentation string.

Return Value

The FieldBuilder object may be used to add more details to the field.

Remarks

While Entities may be hidden using access levels, Schemas and Fields are visible to clients and other developers. In the interest of clarity and interoperability, you are very strongly encouraged to provide good documentation with your Schemas. Explain the intent of the data and how it is meant to be interpreted. It is not useful to repeat information that can be observed directly (e.g. types and units). Note that documentation, like all other contents of Schemas and Fields is immutable once the add-in using the Schema is published.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetSubSchemaGUID Method

[image]

Revit 2013 API
FieldBuilder..::..SetSubSchemaGUID Method
FieldBuilder Class See Also Send Feedback
Sets the GUID of the Schema of the Entities that are intended to be stored in this field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder SetSubSchemaGUID(
    Guid guid
)
Visual Basic
Public Function SetSubSchemaGUID ( _
    guid As Guid _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ SetSubSchemaGUID(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The GUID of the subschema.

Return Value

The FieldBuilder object may be used to add more details to the field.

Remarks

Fields of type Entity - subentities - need to specify their Schema. The framework will prevent subentities with incorrect schemas from being stored in the entity. Additionally, the access level of the subschema will be checked against the currently executing add-in and access to restricted subentities will be prevented.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize SubSchemas.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetUnitType Method

[image]

Revit 2013 API
FieldBuilder..::..SetUnitType Method
FieldBuilder Class See Also Send Feedback
Sets the type of units for the field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder SetUnitType(
    UnitType units
)
Visual Basic
Public Function SetUnitType ( _
    units As UnitType _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ SetUnitType(
    UnitType units
)

Parameters

units
Type: Autodesk.Revit.DB..::..UnitType
Units type value to be set

Return Value

The FieldBuilder object may be used to add more details to the field.

Remarks

All floating-point fields (float, double, XYZ, UV and containers of these values) will be internally stored in the metric system. You must specify the unit type (length, temperature, etc.) via this method for such fields. Conversely, all other field types may not have units. Do not call this method on those fields.

The dimension of the field (3 for XYZ, 2 for UV, arbitrary for array) extends the power of the unit type by allowing you to represent vectors of values of specific units. Each component will be converted independently. Using vectors to represent multiple independent values will work efficiently, but make sure the documentation is adequate.

The Get and Set methods will need you to specify the units in which your program works, as a DisplayUnitType. These units must be compatible with the UnitType. Revit will convert the stored values from/to the units you specify.

Use UT_Custom and DUT_CUSTOM to explicitly disable conversions for a field.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize unit conversions.

See Also

FieldBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Class

[image]

Revit 2013 API
Schema Class
Members See Also Send Feedback
The description of a single object (Entity) in the Extensible Storage framework. Contains identity information, documentation and the list of fields to be stored in the Entity.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Schema : IDisposable
Visual Basic
Public Class Schema _
    Implements IDisposable
Visual C++
public ref class Schema : IDisposable

Remarks

A Schema is similar to a class in most object-oriented languages, or to a C struct, while an Entity is an object of that class. The Schema object is immutable. To create and populate a Schema, use the SchemaBuilder class. Schemas are stored in the memory of the running instance of Revit and may be retrieved with the Lookup method. When a document containing Entities of a Schema is saved, the Schema is saved with the document too. Opening that document reintroduces the Schema into memory. As you plan to store your data in Revit, please be aware that the data will be stored in Revit elements. Overwhelming the Revit database will impact performance and stability, and will make the user unhappy. Also, remember that multiple add-ins may be storing their data simultaneously. Several kB per element or several MB per file are reasonable maximums for one add-in. If you have larger requirements, consider storing them in a separate database (such as SQLite) and storing keys into that database in Revit.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage..::..Schema

See Also

Schema Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Members

[image] [image]

Revit 2013 API
Schema Members
Schema Class Methods Properties See Also Send Feedback

The Schema type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the Schema
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EraseSchemaAndAllEntities | Erases all Entities corresponding to this Schema from all open documents, and erases this Schema from memory.
Public method | GetField | Gets a Field of a given name from the Schema.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListFields | The complete list of fields in the Schema, sorted by name.
 | ListSchemas | Lists all schemas in memory.
 | Lookup | Finds the Schema corresponding to the GUID in memory.
Public method | ReadAccessGranted | Checks whether Entities of this Schema may be retrieved by the current add-in.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether Entities of this Schema may be stored by the current add-in.

Properties

 | Name | Description
Public property | ApplicationGUID | The GUID of the application or add-in that may access entities of this Schema under the Application access level.
Public property | Documentation | The overall description of the Schema.
Public property | GUID | The identifier of the Schema.
Public property | ReadAccessLevel | Read access level of the schema.
Public property | SchemaName | The user-friendly name of the Schema.
Public property | VendorId | The id of the third-party vendor that may access entities of this Schema under the Vendor access level.
Public property | WriteAccessLevel | Write access level of the schema.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Methods

[image] [image]

Revit 2013 API
Schema Methods
Schema Class See Also Send Feedback

The Schema type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EraseSchemaAndAllEntities | Erases all Entities corresponding to this Schema from all open documents, and erases this Schema from memory.
Public method | GetField | Gets a Field of a given name from the Schema.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ListFields | The complete list of fields in the Schema, sorted by name.
 | ListSchemas | Lists all schemas in memory.
 | Lookup | Finds the Schema corresponding to the GUID in memory.
Public method | ReadAccessGranted | Checks whether Entities of this Schema may be retrieved by the current add-in.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteAccessGranted | Checks whether Entities of this Schema may be stored by the current add-in.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Dispose Method

[image]

Revit 2013 API
Schema..::..Dispose Method
Schema Class See Also Send Feedback
Releases all resources used by the Schema

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


EraseSchemaAndAllEntities Method

[image]

Revit 2013 API
Schema..::..EraseSchemaAndAllEntities Method
Schema Class See Also Send Feedback
Erases all Entities corresponding to this Schema from all open documents, and erases this Schema from memory.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void EraseSchemaAndAllEntities(
    Schema schema,
    bool overrideWriteAccessWithUserPermission
)
Visual Basic
Public Shared Sub EraseSchemaAndAllEntities ( _
    schema As Schema, _
    overrideWriteAccessWithUserPermission As Boolean _
)
Visual C++
public:
static void EraseSchemaAndAllEntities(
    Schema^ schema,
    bool overrideWriteAccessWithUserPermission
)

Parameters

schema
Type: Autodesk.Revit.DB.ExtensibleStorage..::..Schema
The Schema to erase.
overrideWriteAccessWithUserPermission
Type: System..::..Boolean
Normally, the usual write access controls apply to prevent deletion of Entities that you don't have write permissions for. However, the user may choose to override the controls. Set this flag to true only if the user gave explicit permission to destroy the Schema.

Remarks

The intent of this method is to let the user control the amount of memory consumed by Extensible Storage data. It may also be useful during development. Obviously, this method cannot erase the Schema from closed documents, so if a saved and closed document contains Entities of this Schema, it will reintroduce it into memory. Top-level Entities corresponding to this Schema are erased; subentities are replaced with invalid Entities. It may be tempting to use this method to replace subentities such that the GUID is the same, but the Schema definition is different. This will break schema uniqueness when a new Schema is already in memory, and the old one is in a newly opened file. Never assign the same GUID to different Schemas.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | No write access to this Schema.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


GetField Method

[image]

Revit 2013 API
Schema..::..GetField Method
Schema Class See Also Send Feedback
Gets a Field of a given name from the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Field GetField(
    string name
)
Visual Basic
Public Function GetField ( _
    name As String _
) As Field
Visual C++
public:
Field^ GetField(
    String^ name
)

Parameters

name
Type: System..::..String
The Field name

Return Value

The Field

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ListFields Method

[image]

Revit 2013 API
Schema..::..ListFields Method
Schema Class See Also Send Feedback
The complete list of fields in the Schema, sorted by name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Field> ListFields()
Visual Basic
Public Function ListFields As IList(Of Field)
Visual C++
public:
IList<Field^>^ ListFields()

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ListSchemas Method

[image]

Revit 2013 API
Schema..::..ListSchemas Method
Schema Class See Also Send Feedback
Lists all schemas in memory.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<Schema> ListSchemas()
Visual Basic
Public Shared Function ListSchemas As IList(Of Schema)
Visual C++
public:
static IList<Schema^>^ ListSchemas()

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Lookup Method

[image]

Revit 2013 API
Schema..::..Lookup Method
Schema Class See Also Send Feedback
Finds the Schema corresponding to the GUID in memory.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Schema Lookup(
    Guid guid
)
Visual Basic
Public Shared Function Lookup ( _
    guid As Guid _
) As Schema
Visual C++
public:
static Schema^ Lookup(
    Guid guid
)

Parameters

guid
Type: System..::..Guid

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ReadAccessGranted Method

[image]

Revit 2013 API
Schema..::..ReadAccessGranted Method
Schema Class See Also Send Feedback
Checks whether Entities of this Schema may be retrieved by the current add-in.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ReadAccessGranted()
Visual Basic
Public Function ReadAccessGranted As Boolean
Visual C++
public:
bool ReadAccessGranted()

Return Value

True if read access is allowed.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


WriteAccessGranted Method

[image]

Revit 2013 API
Schema..::..WriteAccessGranted Method
Schema Class See Also Send Feedback
Checks whether Entities of this Schema may be stored by the current add-in.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool WriteAccessGranted()
Visual Basic
Public Function WriteAccessGranted As Boolean
Visual C++
public:
bool WriteAccessGranted()

Return Value

True if write access is allowed.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Schema Properties

[image] [image]

Revit 2013 API
Schema Properties
Schema Class See Also Send Feedback

The Schema type exposes the following members.

Properties

 | Name | Description
Public property | ApplicationGUID | The GUID of the application or add-in that may access entities of this Schema under the Application access level.
Public property | Documentation | The overall description of the Schema.
Public property | GUID | The identifier of the Schema.
Public property | ReadAccessLevel | Read access level of the schema.
Public property | SchemaName | The user-friendly name of the Schema.
Public property | VendorId | The id of the third-party vendor that may access entities of this Schema under the Vendor access level.
Public property | WriteAccessLevel | Write access level of the schema.

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ApplicationGUID Property

[image]

Revit 2013 API
Schema..::..ApplicationGUID Property
Schema Class See Also Send Feedback
The GUID of the application or add-in that may access entities of this Schema under the Application access level.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid ApplicationGUID { get; }
Visual Basic
Public ReadOnly Property ApplicationGUID As Guid
    Get
Visual C++
public:
property Guid ApplicationGUID {
    Guid get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Documentation Property

[image]

Revit 2013 API
Schema..::..Documentation Property
Schema Class See Also Send Feedback
The overall description of the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Documentation { get; }
Visual Basic
Public ReadOnly Property Documentation As String
    Get
Visual C++
public:
property String^ Documentation {
    String^ get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


GUID Property

[image]

Revit 2013 API
Schema..::..GUID Property
Schema Class See Also Send Feedback
The identifier of the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Guid GUID { get; }
Visual Basic
Public ReadOnly Property GUID As Guid
    Get
Visual C++
public:
property Guid GUID {
    Guid get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


ReadAccessLevel Property

[image]

Revit 2013 API
Schema..::..ReadAccessLevel Property
Schema Class See Also Send Feedback
Read access level of the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AccessLevel ReadAccessLevel { get; }
Visual Basic
Public ReadOnly Property ReadAccessLevel As AccessLevel
    Get
Visual C++
public:
property AccessLevel ReadAccessLevel {
    AccessLevel get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaName Property

[image]

Revit 2013 API
Schema..::..SchemaName Property
Schema Class See Also Send Feedback
The user-friendly name of the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string SchemaName { get; }
Visual Basic
Public ReadOnly Property SchemaName As String
    Get
Visual C++
public:
property String^ SchemaName {
    String^ get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


VendorId Property

[image]

Revit 2013 API
Schema..::..VendorId Property
Schema Class See Also Send Feedback
The id of the third-party vendor that may access entities of this Schema under the Vendor access level.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string VendorId { get; }
Visual Basic
Public ReadOnly Property VendorId As String
    Get
Visual C++
public:
property String^ VendorId {
    String^ get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


WriteAccessLevel Property

[image]

Revit 2013 API
Schema..::..WriteAccessLevel Property
Schema Class See Also Send Feedback
Write access level of the schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AccessLevel WriteAccessLevel { get; }
Visual Basic
Public ReadOnly Property WriteAccessLevel As AccessLevel
    Get
Visual C++
public:
property AccessLevel WriteAccessLevel {
    AccessLevel get ();
}

See Also

Schema Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaBuilder Class

[image]

Revit 2013 API
SchemaBuilder Class
Members Example See Also Send Feedback
This class is used to create Schemas in the Extensible Storage framework.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class SchemaBuilder : IDisposable
Visual Basic
Public Class SchemaBuilder _
    Implements IDisposable
Visual C++
public ref class SchemaBuilder : IDisposable

Remarks

Named parameter idiom: Methods that set up the Schema return a reference to the builder so you can invoke multiple methods in a chain (e.g., builder.setReadAccessLevel(...).setWriteAccessLevel(...)). Methods that add fields return a FieldBuilder instead.

Examples

CopyC#
// Create a data structure, attach it to a wall, populate it with data, and retrieve the data back from the wall
void StoreDataInWall(Wall wall, XYZ dataToStore)
{
    Transaction createSchemaAndStoreData = new Transaction(wall.Document, "tCreateAndStore");
    createSchemaAndStoreData.Start();
    SchemaBuilder schemaBuilder = new SchemaBuilder(new Guid("720080CB-DA99-40DC-9415-E53F280AA1F0"));
    schemaBuilder.SetReadAccessLevel(AccessLevel.Public); // allow anyone to read the object
    schemaBuilder.SetWriteAccessLevel(AccessLevel.Vendor); // restrict writing to this vendor only
    schemaBuilder.SetVendorId("ADSK"); // required because of restricted write-access
    schemaBuilder.SetSchemaName("WireSpliceLocation");
    FieldBuilder fieldBuilder = schemaBuilder.AddSimpleField("WireSpliceLocation", typeof(XYZ)); // create a field to store an XYZ
    fieldBuilder.SetUnitType(UnitType.UT_Length);
    fieldBuilder.SetDocumentation("A stored location value representing a wiring splice in a wall.");

    Schema schema = schemaBuilder.Finish(); // register the Schema object
    Entity entity = new Entity(schema); // create an entity (object) for this schema (class)
    Field fieldSpliceLocation = schema.GetField("WireSpliceLocation"); // get the field from the schema
    entity.Set<XYZ>(fieldSpliceLocation, dataToStore, DisplayUnitType.DUT_METERS); // set the value for this entity

    wall.SetEntity(entity); // store the entity in the element

    // get the data back from the wall
    Entity retrievedEntity = wall.GetEntity(schema);
    XYZ retrievedData = retrievedEntity.Get<XYZ>(schema.GetField("WireSpliceLocation"), DisplayUnitType.DUT_METERS);
    createSchemaAndStoreData.Commit();
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExtensibleStorage..::..SchemaBuilder

See Also

SchemaBuilder Members
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaBuilder Members

[image] [image]

Revit 2013 API
SchemaBuilder Members
SchemaBuilder Class Constructors Methods See Also Send Feedback

The SchemaBuilder type exposes the following members.

Constructors

 | Name | Description
Public method | SchemaBuilder | Initializes a new instance of the SchemaBuilder class

Methods

 | Name | Description
Public method | AcceptableName | Checks whether a string is an acceptable name for a Schema or a Field.
Public method | AddArrayField | Creates a field containing an array of values in the Schema, with given name and type of contained values.
Public method | AddMapField | Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.
Public method | AddSimpleField | Creates a field containing a single value in the Schema, with given name and type.
Public method | Dispose | Releases all resources used by the SchemaBuilder
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Registers and returns the created Schema object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GUIDIsValid | Checks whether the supplied GUID value is valid.
Public method | Ready | Checks whether the builder may be used.
Public method | SetApplicationGUID | Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.
Public method | SetDocumentation | Sets the documentation string for the Schema.
Public method | SetReadAccessLevel | Sets top level read access (for entities)
Public method | SetSchemaName | Sets the name of the Schema.
Public method | SetVendorId | Sets the id of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Public method | SetWriteAccessLevel | Sets top level write access (for entities)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VendorIdIsValid | Checks whether the supplied vendor id string is valid.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaBuilder Constructor

[image]

Revit 2013 API
SchemaBuilder Constructor
SchemaBuilder Class See Also Send Feedback
Initializes a new instance of the SchemaBuilder class

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
SchemaBuilder(
    Guid guid
)

Parameters

guid
Type: System..::..Guid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The guid value is invalid.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SchemaBuilder Methods

[image] [image]

Revit 2013 API
SchemaBuilder Methods
SchemaBuilder Class See Also Send Feedback

The SchemaBuilder type exposes the following members.

Methods

 | Name | Description
Public method | AcceptableName | Checks whether a string is an acceptable name for a Schema or a Field.
Public method | AddArrayField | Creates a field containing an array of values in the Schema, with given name and type of contained values.
Public method | AddMapField | Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.
Public method | AddSimpleField | Creates a field containing a single value in the Schema, with given name and type.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Finish | Registers and returns the created Schema object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GUIDIsValid | Checks whether the supplied GUID value is valid.
Public method | Ready | Checks whether the builder may be used.
Public method | SetApplicationGUID | Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.
Public method | SetDocumentation | Sets the documentation string for the Schema.
Public method | SetReadAccessLevel | Sets top level read access (for entities)
Public method | SetSchemaName | Sets the name of the Schema.
Public method | SetVendorId | Sets the id of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.
Public method | SetWriteAccessLevel | Sets top level write access (for entities)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | VendorIdIsValid | Checks whether the supplied vendor id string is valid.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


AcceptableName Method

[image]

Revit 2013 API
SchemaBuilder..::..AcceptableName Method
SchemaBuilder Class See Also Send Feedback
Checks whether a string is an acceptable name for a Schema or a Field.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool AcceptableName(
    string name
)
Visual Basic
Public Function AcceptableName ( _
    name As String _
) As Boolean
Visual C++
public:
bool AcceptableName(
    String^ name
)

Parameters

name
Type: System..::..String
The string to check.

Return Value

True if the name is acceptable.

Remarks

For interoperability, names are required to be usable as C++ identifiers. The allowable characters are ASCII letters, numbers (except the first character) and underscore. The length must be between 1 and 247 characters.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


AddArrayField Method

[image]

Revit 2013 API
SchemaBuilder..::..AddArrayField Method
SchemaBuilder Class See Also Send Feedback
Creates a field containing an array of values in the Schema, with given name and type of contained values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder AddArrayField(
    string fieldName,
    Type fieldType
)
Visual Basic
Public Function AddArrayField ( _
    fieldName As String, _
    fieldType As Type _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ AddArrayField(
    String^ fieldName,
    Type^ fieldType
)

Parameters

fieldName
Type: System..::..String
The name of the new field.
fieldType
Type: System..::..Type
The type of the contents in the new field.

Return Value

The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.

Remarks

The supported types for the contents are the same as for simple fields. See AddSimpleField(String, Type) for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


AddMapField Method

[image]

Revit 2013 API
SchemaBuilder..::..AddMapField Method
SchemaBuilder Class See Also Send Feedback
Creates a field containing an ordered key-value map in the Schema, with given name and type of contained values.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder AddMapField(
    string fieldName,
    Type keyType,
    Type valueType
)
Visual Basic
Public Function AddMapField ( _
    fieldName As String, _
    keyType As Type, _
    valueType As Type _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ AddMapField(
    String^ fieldName,
    Type^ keyType,
    Type^ valueType
)

Parameters

fieldName
Type: System..::..String
The name of the new field.
keyType
Type: System..::..Type
The type of the keys for the new field.
valueType
Type: System..::..Type
The type of the values for the new field.

Return Value

The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.

Remarks

The supported types for the keys are Boolean, Byte, Int16, Int32, ElementId, GUID and String. Floating-point types (Float, Double, XYZ and UV) are not supported because round-off errors frequently cause numeric instability. Subentities are not supported because they require a custom comparison operator. The suggested workarounds are either placing key values into an Array and using array indices for keys, or just using an Array of subentities. Natural comparison of contained types is used for sorting. The supported types for values are the same as for simple fields. See AddSimpleField(String, Type) for details.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The combination of key and value types is not supported.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


AddSimpleField Method

[image]

Revit 2013 API
SchemaBuilder..::..AddSimpleField Method
SchemaBuilder Class See Also Send Feedback
Creates a field containing a single value in the Schema, with given name and type.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FieldBuilder AddSimpleField(
    string fieldName,
    Type fieldType
)
Visual Basic
Public Function AddSimpleField ( _
    fieldName As String, _
    fieldType As Type _
) As FieldBuilder
Visual C++
public:
FieldBuilder^ AddSimpleField(
    String^ fieldName,
    Type^ fieldType
)

Parameters

fieldName
Type: System..::..String
The name of the new field.
fieldType
Type: System..::..Type
The type of the new field.

Return Value

The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.

Remarks

The supported types are Boolean, Byte, Int16, Int32, Float, Double, ElementId, GUID, String, XYZ, UV and Entity.

Note that data of type ElementId is not copied to new elements that are created via copy/paste or a linear or radial array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Dispose Method

[image]

Revit 2013 API
SchemaBuilder..::..Dispose Method
SchemaBuilder Class See Also Send Feedback
Releases all resources used by the SchemaBuilder

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Finish Method

[image]

Revit 2013 API
SchemaBuilder..::..Finish Method
SchemaBuilder Class See Also Send Feedback
Registers and returns the created Schema object.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Schema Finish()
Visual Basic
Public Function Finish As Schema
Visual C++
public:
Schema^ Finish()

Return Value

The newly created Schema.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- A different Schema with a matching identity already exists. -or- Two fields with the same name are detected. -or- At least one field has invalid units. -or- SchemaName is not set. -or- VendorId is not set for a restricted access level. -or- ApplicationGUID is not set for an application access level.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


GUIDIsValid Method

[image]

Revit 2013 API
SchemaBuilder..::..GUIDIsValid Method
SchemaBuilder Class See Also Send Feedback
Checks whether the supplied GUID value is valid.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool GUIDIsValid(
    Guid guid
)
Visual Basic
Public Shared Function GUIDIsValid ( _
    guid As Guid _
) As Boolean
Visual C++
public:
static bool GUIDIsValid(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The GUID to check

Return Value

True if the GUID is valid

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Ready Method

[image]

Revit 2013 API
SchemaBuilder..::..Ready Method
SchemaBuilder Class See Also Send Feedback
Checks whether the builder may be used.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool Ready()
Visual Basic
Public Function Ready As Boolean
Visual C++
public:
bool Ready()

Return Value

True if the SchemaBuilder has not yet been finished.

Remarks

All newly constructed SchemaBuilders are usable until the call to the Finish method.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetApplicationGUID Method

[image]

Revit 2013 API
SchemaBuilder..::..SetApplicationGUID Method
SchemaBuilder Class See Also Send Feedback
Sets the GUID of the application or add-in that may access entities of this Schema under the Application acess level.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetApplicationGUID(
    Guid applicationGUID
)
Visual Basic
Public Function SetApplicationGUID ( _
    applicationGUID As Guid _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetApplicationGUID(
    Guid applicationGUID
)

Parameters

applicationGUID
Type: System..::..Guid
The application id.

Return Value

The SchemaBuilder object may be used to add more settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetDocumentation Method

[image]

Revit 2013 API
SchemaBuilder..::..SetDocumentation Method
SchemaBuilder Class See Also Send Feedback
Sets the documentation string for the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetDocumentation(
    string documentation
)
Visual Basic
Public Function SetDocumentation ( _
    documentation As String _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetDocumentation(
    String^ documentation
)

Parameters

documentation
Type: System..::..String
The documentation string.

Return Value

The SchemaBuilder object may be used to add more settings.

Remarks

While Entities may be hidden using access levels, Schemas and Fields are visible to clients and other developers. In the interest of clarity and interoperability, you are very strongly encouraged to provide good documentation with your Schemas. Explain the intent of the data and how it is meant to be interpreted. It is not useful to repeat information that can be observed directly (e.g. types and units). Note that documentation, like all other contents of Schemas and Fields is immutable once the add-in using the Schema is published.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetReadAccessLevel Method

[image]

Revit 2013 API
SchemaBuilder..::..SetReadAccessLevel Method
SchemaBuilder Class See Also Send Feedback
Sets top level read access (for entities)

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetReadAccessLevel(
    AccessLevel readAccessLevel
)
Visual Basic
Public Function SetReadAccessLevel ( _
    readAccessLevel As AccessLevel _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetReadAccessLevel(
    AccessLevel readAccessLevel
)

Parameters

readAccessLevel
Type: Autodesk.Revit.DB.ExtensibleStorage..::..AccessLevel
Read access level value to be set

Return Value

The SchemaBuilder object may be used to add more settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetSchemaName Method

[image]

Revit 2013 API
SchemaBuilder..::..SetSchemaName Method
SchemaBuilder Class See Also Send Feedback
Sets the name of the Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetSchemaName(
    string schemaName
)
Visual Basic
Public Function SetSchemaName ( _
    schemaName As String _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetSchemaName(
    String^ schemaName
)

Parameters

schemaName
Type: System..::..String
The name for the Schema.

Return Value

The SchemaBuilder object may be used to add more settings.

Remarks

The name is a user-friendly identifier of the Schema. GUIDs are used exclusively for Schema identity, but the name is useful to identify the Schema during development or in an error message. This field is required.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The parameter schemaName is not acceptable for naming Extensible Storage objects.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetVendorId Method

[image]

Revit 2013 API
SchemaBuilder..::..SetVendorId Method
SchemaBuilder Class See Also Send Feedback
Sets the id of the third-party vendor that may access entities of this Schema under the Vendor acess level, and to generally identify the owner of this Schema.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetVendorId(
    string vendorId
)
Visual Basic
Public Function SetVendorId ( _
    vendorId As String _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetVendorId(
    String^ vendorId
)

Parameters

vendorId
Type: System..::..String
The vendor id.

Return Value

The SchemaBuilder object may be used to add more settings.

Remarks

The vendor id is the registered developer symbol. The registration interface is available at http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=1075006 Since vendor ids are not case sensitive, the string will be converted to upper case before it is stored in the schema.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The vendorId is invalid.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


SetWriteAccessLevel Method

[image]

Revit 2013 API
SchemaBuilder..::..SetWriteAccessLevel Method
SchemaBuilder Class See Also Send Feedback
Sets top level write access (for entities)

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public SchemaBuilder SetWriteAccessLevel(
    AccessLevel writeAccessLevel
)
Visual Basic
Public Function SetWriteAccessLevel ( _
    writeAccessLevel As AccessLevel _
) As SchemaBuilder
Visual C++
public:
SchemaBuilder^ SetWriteAccessLevel(
    AccessLevel writeAccessLevel
)

Parameters

writeAccessLevel
Type: Autodesk.Revit.DB.ExtensibleStorage..::..AccessLevel
Write access level value to be set

Return Value

The SchemaBuilder object may be used to add more settings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The SchemaBuilder has already finished building the Schema.

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


VendorIdIsValid Method

[image]

Revit 2013 API
SchemaBuilder..::..VendorIdIsValid Method
SchemaBuilder Class See Also Send Feedback
Checks whether the supplied vendor id string is valid.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool VendorIdIsValid(
    string vendorId
)
Visual Basic
Public Shared Function VendorIdIsValid ( _
    vendorId As String _
) As Boolean
Visual C++
public:
static bool VendorIdIsValid(
    String^ vendorId
)

Parameters

vendorId
Type: System..::..String
The vendor id to check

Return Value

True if teh vendor id is valid

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SchemaBuilder Class
Autodesk.Revit.DB.ExtensibleStorage Namespace


Autodesk.Revit.DB.ExternalService Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.ExternalService Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExternalService | This base class represents an external service inside Revit application.
Public class | ExternalServiceId | Unique identifier of an external service.
Public class | ExternalServiceRegistry | This class gives access to external services. Use it to register external services with Revit and execute them. Only the application that registers a service is allowed to execute it.
Public class | ExternalServices | Provides a container of all Revit built-in ExternalServiceId instances.
Public class | MultiServerService | This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.
Public class | SingleServerService | This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.

Interfaces

 | Interface | Description
Public interface | IExternalData | The base interface for data classes used when executing servers of external services.
Public interface | IExternalServer | The base interface for all external servers.
Public interface | IExternalService | The base interface class for all external services.
Public interface | IMultiServerService | The base interface class for all multi-server services.
Public interface | ISingleServerService | The base interface class for all single-server services.

Enumerations

 | Enumeration | Description
Public enumeration | ExecutionPolicy | Controls how servers of multi-server external services are executed.
Public enumeration | ExternalServiceResult | An enumerated value representing a result from executing an external service.
Public enumeration | ServerChangeCause | Indicates the cause for the active server to be changed


ExecutionPolicy Enumeration

[image]

Revit 2013 API
ExecutionPolicy Enumeration
See Also Send Feedback
Controls how servers of multi-server external services are executed.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ExecutionPolicy
Visual Basic
Public Enumeration ExecutionPolicy
Visual C++
public enum class ExecutionPolicy

Members

Member name | Description
FirstApplicableServer | This policy instructs to find the first applicable server, which would be the first one that the service claims (by returning True from the CanExecute method) it can be executed. With that server the service will be called to execute it. If the execution fails or if an unhandled exception is raised from it the result will be ExternalServiceResult.Failed, otherwise it will be ExternalServiceResult.Succeeded, unless no applicable server can be found, which would cause returning ExternalServiceResult.Unhandled.
AllApplicableServers | Under this policy the framework will call to execute a service with all applicable servers, that is the servers that are currently set as active and for which the service responds affirmatively to the CanExecute method. If and only if the service can execute all applicable servers successfully the execution returns ExternalServiceResult.Succeeded. If execution of any applicable server fails, the execution loop breaks and the return value will be ExternalServiceResult.Failed. If no applicable servers can be found, the return value will be ExternalServiceResult.Unhandled.

See Also

Autodesk.Revit.DB.ExternalService Namespace


ExternalService Class

[image]

Revit 2013 API
ExternalService Class
Members See Also Send Feedback
This base class represents an external service inside Revit application.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExternalService : IDisposable
Visual Basic
Public Class ExternalService _
    Implements IDisposable
Visual C++
public ref class ExternalService : IDisposable

Remarks

This is a base class from which SingleServerService and MultiServerService classes are inherited. It implements all basic methods, but the two inherited classes add more methods specific for that kind of service the class represents. Use this base class to get information about a service and its servers. Use the specific inherited classes to set or get active servers.

Summary of common methods:
  • Adding and removing a server to and from a service
  • Getting information about a service
  • Querying a number of servers registered for a service
  • Accessing servers currently registered for a service
Summary of the service-specific methods:
  • Getting and setting active server (or servers) for a service

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExternalService..::..ExternalService
Autodesk.Revit.DB.ExternalService..::..MultiServerService
Autodesk.Revit.DB.ExternalService..::..SingleServerService

See Also

ExternalService Members
Autodesk.Revit.DB.ExternalService Namespace


ExternalService Members

[image] [image]

Revit 2013 API
ExternalService Members
ExternalService Class Methods Properties See Also Send Feedback

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose | Releases all resources used by the ExternalService
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description for the service
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not.
Public property | Name | The name of the service
Public property | NumberOfServers | Indicates the number of servers currently registered with the service.
Public property | ServiceId | The Id of the service
Public property | VendorId | The vendor who provided the service

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalService Methods

[image] [image]

Revit 2013 API
ExternalService Methods
ExternalService Class See Also Send Feedback

The ExternalService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service.
Public method | GetServer | Returns the instance that provides implementation for a registered server.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service.
Public method | RemoveServer | Removes/unregisters a server from the service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


AddServer Method

[image]

Revit 2013 API
ExternalService..::..AddServer Method
ExternalService Class See Also Send Feedback
Registers a server with its service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddServer(
    IExternalServer server
)
Visual Basic
Public Sub AddServer ( _
    server As IExternalServer _
)
Visual C++
public:
void AddServer(
    IExternalServer^ server
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
The instance of the server. The server must implement the interface provided by the service.

Remarks

Servers must be registered with their services. There has to be at least one server registered for a service in order to be able to execute the service.

A server can be added only once. An attempt to add a server again will lead to an exception. A server cannot be removed during the service's execution or when another server is just being added or removed (e.g. during OnServersChanged call-back to the service).

Adding a server to a service does not make the server active yet. A registered server means it may be used with the service, not that it is going to be automatically used (executed). In order to make a service applicable to its service, the server must set as the active server (or be a part of the set of active servers, in a multi-server service).

Servers can be registered at any time; registering does not need to happen during an application's start-up, but it must happen - naturally - after the respective service has been registered. Since all built-in services are automatically registered during initialization of Revit, their servers can be added as early as during the OnStartup method. Third-party services, on the other hand, get registered during the OnStartup method, therefore their servers need to be added later. The next earliest opportunity for adding servers to a third-party service is on the ApplicationInitialized event.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Server object is not valid or its service Id does not match the service. -or- A server with the same Id has already been registered with the service. -or- The given server does not return valid values from the interface methods. At least one of the Name, VendorId, Description, and ServerId is empty or invalid. -or- The server does not represent a server of a valid type to be used with the service.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed. -or- The service provider is not valid.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


Dispose Method

[image]

Revit 2013 API
ExternalService..::..Dispose Method
ExternalService Class See Also Send Feedback
Releases all resources used by the ExternalService

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


GetDefaultServerId Method

[image]

Revit 2013 API
ExternalService..::..GetDefaultServerId Method
ExternalService Class See Also Send Feedback
Returns the Id of the default server if one was assigned to the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid GetDefaultServerId()
Visual Basic
Public Function GetDefaultServerId As Guid
Visual C++
public:
Guid GetDefaultServerId()

Return Value

The GUID of the default server, or an invalid GUID if there is none assigned.

Remarks

Only mandatory services have default servers assigned. Only built-in service can currently be mandatory. All third-party services are optional and cannot (amd may not) have default servers.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


GetRegisteredServerIds Method

[image]

Revit 2013 API
ExternalService..::..GetRegisteredServerIds Method
ExternalService Class See Also Send Feedback
Returns Ids of all servers registered for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Guid> GetRegisteredServerIds()
Visual Basic
Public Function GetRegisteredServerIds As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetRegisteredServerIds()

Return Value

An array of Ids of all registered servers. The array may be empty.

Remarks

The list includes all registered servers regardless of whether they are currently active or not.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


GetServer Method

[image]

Revit 2013 API
ExternalService..::..GetServer Method
ExternalService Class See Also Send Feedback
Returns the instance that provides implementation for a registered server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IExternalServer GetServer(
    Guid serverId
)
Visual Basic
Public Function GetServer ( _
    serverId As Guid _
) As IExternalServer
Visual C++
public:
IExternalServer^ GetServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
Id of a registered server

Return Value

An instance of the server interface. NULL is returned if the server is invalid (e.g. destroyed)

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A server with this Id has not been registered for this service.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


IsRegisteredServerId Method

[image]

Revit 2013 API
ExternalService..::..IsRegisteredServerId Method
ExternalService Class See Also Send Feedback
Checks if the Id represents a valid server that have been registered for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsRegisteredServerId(
    Guid serverId
)
Visual Basic
Public Function IsRegisteredServerId ( _
    serverId As Guid _
) As Boolean
Visual C++
public:
bool IsRegisteredServerId(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
An Id of a server

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


RemoveServer Method

[image]

Revit 2013 API
ExternalService..::..RemoveServer Method
ExternalService Class See Also Send Feedback
Removes/unregisters a server from the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveServer(
    Guid serverId
)
Visual Basic
Public Sub RemoveServer ( _
    serverId As Guid _
)
Visual C++
public:
void RemoveServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
Id of the server to be unregistered.

Remarks

It is possible to remove servers that are currently set as active, because it is possible for a service having assigned no active server. This does not apply to mandatory services, which will always have at least one server registered - the default server - and at least one server set as active at all times.

A server cannot be removed during the service's execution or when another server is just being added or removed (e.g. during OnServersChanged call-back to the service).

Default server may not be removed. An attempt to do so will lead to an exception.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A server with this Id has not been registered for this service. -or- The given serverId belongs to the default server of the service. Default servers may not be removed.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed. -or- The service provider is not valid.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalService Properties

[image] [image]

Revit 2013 API
ExternalService Properties
ExternalService Class See Also Send Feedback

The ExternalService type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description for the service
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not.
Public property | Name | The name of the service
Public property | NumberOfServers | Indicates the number of servers currently registered with the service.
Public property | ServiceId | The Id of the service
Public property | VendorId | The vendor who provided the service

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


Description Property

[image]

Revit 2013 API
ExternalService..::..Description Property
ExternalService Class See Also Send Feedback
The description for the service

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Description { get; }
Visual Basic
Public ReadOnly Property Description As String
    Get
Visual C++
public:
property String^ Description {
    String^ get ();
}

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


IsSerializable Property

[image]

Revit 2013 API
ExternalService..::..IsSerializable Property
ExternalService Class See Also Send Feedback
Indicates whether executions of the service requires serialization in documents or not.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSerializable { get; }
Visual Basic
Public ReadOnly Property IsSerializable As Boolean
    Get
Visual C++
public:
property bool IsSerializable {
    bool get ();
}

Remarks

When a serializable service is executed in a document, a record about the executed server (or servers) is stored in the document's history. This allows active servers to be synchronized next time a saved document is opened in Revit.

Executions of a serializable service in a document must happen inside a transaction.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


Name Property

[image]

Revit 2013 API
ExternalService..::..Name Property
ExternalService Class See Also Send Feedback
The name of the service

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


NumberOfServers Property

[image]

Revit 2013 API
ExternalService..::..NumberOfServers Property
ExternalService Class See Also Send Feedback
Indicates the number of servers currently registered with the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfServers { get; }
Visual Basic
Public ReadOnly Property NumberOfServers As Integer
    Get
Visual C++
public:
property int NumberOfServers {
    int get ();
}

Remarks

This is the muber of all registered servers, not just of the ones that are currently active.

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


ServiceId Property

[image]

Revit 2013 API
ExternalService..::..ServiceId Property
ExternalService Class See Also Send Feedback
The Id of the service

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExternalServiceId ServiceId { get; }
Visual Basic
Public ReadOnly Property ServiceId As ExternalServiceId
    Get
Visual C++
public:
property ExternalServiceId^ ServiceId {
    ExternalServiceId^ get ();
}

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


VendorId Property

[image]

Revit 2013 API
ExternalService..::..VendorId Property
ExternalService Class See Also Send Feedback
The vendor who provided the service

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string VendorId { get; }
Visual Basic
Public ReadOnly Property VendorId As String
    Get
Visual C++
public:
property String^ VendorId {
    String^ get ();
}

See Also

ExternalService Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Class

[image]

Revit 2013 API
ExternalServiceId Class
Members See Also Send Feedback
Unique identifier of an external service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExternalServiceId : GuidEnum
Visual Basic
Public Class ExternalServiceId _
    Inherits GuidEnum
Visual C++
public ref class ExternalServiceId : public GuidEnum

Remarks

Each external service must have a unique ExternalServiceId. The Id can be registered with Revit for servers to easily find it. Unique ExternalServiceId should be created using GUID generation tool. ExternalServiceId can later be used to access registered external services.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..GuidEnum
Autodesk.Revit.DB.ExternalService..::..ExternalServiceId

See Also

ExternalServiceId Members
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Members

[image] [image]

Revit 2013 API
ExternalServiceId Members
ExternalServiceId Class Constructors Methods Operators Properties See Also Send Feedback

The ExternalServiceId type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalServiceId | Creates a new ExternalServiceId instance.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Compares two ExternalServiceId instances.
Inequality | Compares two ExternalServiceId instances.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Constructor

[image]

Revit 2013 API
ExternalServiceId Constructor
ExternalServiceId Class See Also Send Feedback
Creates a new ExternalServiceId instance.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ExternalServiceId(
    Guid guid
)
Visual Basic
Public Sub New ( _
    guid As Guid _
)
Visual C++
public:
ExternalServiceId(
    Guid guid
)

Parameters

guid
Type: System..::..Guid
The identifier for the ExternalServiceId.

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Methods

[image] [image]

Revit 2013 API
ExternalServiceId Methods
ExternalServiceId Class See Also Send Feedback

The ExternalServiceId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Operators

[image] [image]

Revit 2013 API
ExternalServiceId Operators
ExternalServiceId Class See Also Send Feedback

The ExternalServiceId type exposes the following members.

Operators

Name | Description
Equality | Compares two ExternalServiceId instances.
Inequality | Compares two ExternalServiceId instances.

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


Equality Operator

[image]

Revit 2013 API
ExternalServiceId..::..Equality Operator
ExternalServiceId Class See Also Send Feedback
Compares two ExternalServiceId instances.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    ExternalServiceId first,
    ExternalServiceId second
)
Visual Basic
Public Shared Operator = ( _
    first As ExternalServiceId, _
    second As ExternalServiceId _
) As Boolean
Visual C++
public:
static bool operator ==(
    ExternalServiceId^ first,
    ExternalServiceId^ second
)

Parameters

first
Type: Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
The first ExternalServiceId.
second
Type: Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
The second ExternalServiceId.

Return Value

True if the inputs are identical, false if they are different.

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


Inequality Operator

[image]

Revit 2013 API
ExternalServiceId..::..Inequality Operator
ExternalServiceId Class See Also Send Feedback
Compares two ExternalServiceId instances.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    ExternalServiceId first,
    ExternalServiceId second
)
Visual Basic
Public Shared Operator <> ( _
    first As ExternalServiceId, _
    second As ExternalServiceId _
) As Boolean
Visual C++
public:
static bool operator !=(
    ExternalServiceId^ first,
    ExternalServiceId^ second
)

Parameters

first
Type: Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
The first ExternalServiceId.
second
Type: Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
The second ExternalServiceId.

Return Value

True if the inputs are different, false if they are identical.

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceId Properties

[image] [image]

Revit 2013 API
ExternalServiceId Properties
ExternalServiceId Class See Also Send Feedback

The ExternalServiceId type exposes the following members.

Properties

 | Name | Description
Public property | Guid | The Guid of GUID-based enum object. (Inherited from GuidEnum.)

See Also

ExternalServiceId Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceRegistry Class

[image]

Revit 2013 API
ExternalServiceRegistry Class
Members See Also Send Feedback
This class gives access to external services. Use it to register external services with Revit and execute them. Only the application that registers a service is allowed to execute it.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExternalServiceRegistry : IDisposable
Visual Basic
Public Class ExternalServiceRegistry _
    Implements IDisposable
Visual C++
public ref class ExternalServiceRegistry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExternalService..::..ExternalServiceRegistry

See Also

ExternalServiceRegistry Members
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceRegistry Members

[image] [image]

Revit 2013 API
ExternalServiceRegistry Members
ExternalServiceRegistry Class Methods See Also Send Feedback

The ExternalServiceRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExternalServiceRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteService(Guid, IExternalData) | Execute a service independently of any document.
 | ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetService | Returns an instance of an object that represents the external service with the given Id.
 | GetServices | Returns a collection of all external services currently registered in Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RegisterService(ISingleServerService, Boolean) | A method to register a single-server service.
 | RegisterService(IMultiServerService, Boolean, ExecutionPolicy) | A method to register a multi-server service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceRegistry Methods

[image] [image]

Revit 2013 API
ExternalServiceRegistry Methods
ExternalServiceRegistry Class See Also Send Feedback

The ExternalServiceRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecuteService(Guid, IExternalData) | Execute a service independently of any document.
 | ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetService | Returns an instance of an object that represents the external service with the given Id.
 | GetServices | Returns a collection of all external services currently registered in Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RegisterService(ISingleServerService, Boolean) | A method to register a single-server service.
 | RegisterService(IMultiServerService, Boolean, ExecutionPolicy) | A method to register a multi-server service.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace


Dispose Method

[image]

Revit 2013 API
ExternalServiceRegistry..::..Dispose Method
ExternalServiceRegistry Class See Also Send Feedback
Releases all resources used by the ExternalServiceRegistry

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace


ExecuteService Method

[image] [image]

Revit 2013 API
ExternalServiceRegistry..::..ExecuteService Method
ExternalServiceRegistry Class See Also Send Feedback

Overload List

Name | Description
ExecuteService(Guid, IExternalData) | Execute a service independently of any document.
ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document.

See Also

ExternalServiceRegistry Class
ExternalServiceRegistry Members
Autodesk.Revit.DB.ExternalService Namespace


ExecuteService Method (Guid, IExternalData)

[image]

Revit 2013 API
ExternalServiceRegistry..::..ExecuteService Method (Guid, IExternalData)
ExternalServiceRegistry Class See Also Send Feedback
Execute a service independently of any document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalServiceResult ExecuteService(
    Guid executionKey,
    IExternalData data
)
Visual Basic
Public Shared Function ExecuteService ( _
    executionKey As Guid, _
    data As IExternalData _
) As ExternalServiceResult
Visual C++
public:
static ExternalServiceResult ExecuteService(
    Guid executionKey,
    IExternalData^ data
)

Parameters

executionKey
Type: System..::..Guid
Access key of the service to be executed. The key is not the same as the service's Id. It is the value that was returned to the caller who registered the service.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated data. The type is defined by the service.

Return Value

The result of executing the external service.

Remarks

Execution of a service should be invoked only by the application that registered the service. The execution will use the currently active server (or servers in the case of a multi-server service).

This method does not take a document as one of its argument and therefore it is not intended for executions that modify documents. If the service or its server(s) is expected to modify documents, the other ExecuteService method is supposed to be used. Please note that only serializable services are allowed to modify the document in which a service is being executed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The execution key is either invalid or of a service that is not registered. To execute a service, the key returned by RegisterService method must be used. -or- The execution key is of a service that is already being executed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalServiceRegistry Class
ExecuteService Overload
Autodesk.Revit.DB.ExternalService Namespace


ExecuteService Method (Guid, Document, IExternalData)

[image]

Revit 2013 API
ExternalServiceRegistry..::..ExecuteService Method (Guid, Document, IExternalData)
ExternalServiceRegistry Class See Also Send Feedback
Execute the service for the given document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalServiceResult ExecuteService(
    Guid executionKey,
    Document document,
    IExternalData data
)
Visual Basic
Public Shared Function ExecuteService ( _
    executionKey As Guid, _
    document As Document, _
    data As IExternalData _
) As ExternalServiceResult
Visual C++
public:
static ExternalServiceResult ExecuteService(
    Guid executionKey,
    Document^ document,
    IExternalData^ data
)

Parameters

executionKey
Type: System..::..Guid
Access key of the service to be executed. The key is not the same as the service's Id. It is the value that was returned to the caller who registered the service.
document
Type: Autodesk.Revit.DB..::..Document
The document for which the service is going to be executed.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated data. The type must be of the class defined by the service.

Return Value

The result of executing the external service.

Remarks

Execution of a service should be invoked only by the application that registered the service. The execution will use the active server (or servers in the case of a multi-server service) currently set for the given document. If there is no server specifically set for the document the current application-wide server (or servers) will be applied.

This method is primarily intended for executing of serializable services. If the service was registered as non-serializable, the document should not be modified during the execution (it means no server's information will be stored inside the document.) In such a case the given document simply indicates to execute the server(s) that were registered for that particular document.

Be aware that serializable service may only be executed in a document that is currently modifiable. An exception will be thrown if it isn't so. This requirement does not apply to non-serializable services.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The execution key is either invalid or of a service that is not registered. To execute a service, the key returned by RegisterService method must be used. -or- The execution key is of a service that is already being executed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Executing a serializable service in a document that is not modifiable.

See Also

ExternalServiceRegistry Class
ExecuteService Overload
Autodesk.Revit.DB.ExternalService Namespace


GetService Method

[image]

Revit 2013 API
ExternalServiceRegistry..::..GetService Method
ExternalServiceRegistry Class See Also Send Feedback
Returns an instance of an object that represents the external service with the given Id.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalService GetService(
    ExternalServiceId serviceId
)
Visual Basic
Public Shared Function GetService ( _
    serviceId As ExternalServiceId _
) As ExternalService
Visual C++
public:
static ExternalService^ GetService(
    ExternalServiceId^ serviceId
)

Parameters

serviceId
Type: Autodesk.Revit.DB.ExternalService..::..ExternalServiceId
Id of the service.

Return Value

The instance of the service or NULL if it cannot be found.

Remarks

The returned instance is either of type SingleServerService or MultiServerService. Users should cast the returned object to one of the classes if they need access to active servers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace


GetServices Method

[image]

Revit 2013 API
ExternalServiceRegistry..::..GetServices Method
ExternalServiceRegistry Class See Also Send Feedback
Returns a collection of all external services currently registered in Revit.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ExternalService> GetServices()
Visual Basic
Public Shared Function GetServices As IList(Of ExternalService)
Visual C++
public:
static IList<ExternalService^>^ GetServices()

Return Value

Array of ExternalService instances.

See Also

ExternalServiceRegistry Class
Autodesk.Revit.DB.ExternalService Namespace


RegisterService Method

[image] [image]

Revit 2013 API
ExternalServiceRegistry..::..RegisterService Method
ExternalServiceRegistry Class See Also Send Feedback

Overload List

Name | Description
RegisterService(ISingleServerService, Boolean) | A method to register a single-server service.
RegisterService(IMultiServerService, Boolean, ExecutionPolicy) | A method to register a multi-server service.

See Also

ExternalServiceRegistry Class
ExternalServiceRegistry Members
Autodesk.Revit.DB.ExternalService Namespace


RegisterService Method (ISingleServerService, Boolean)

[image]

Revit 2013 API
ExternalServiceRegistry..::..RegisterService Method (ISingleServerService, Boolean)
ExternalServiceRegistry Class See Also Send Feedback
A method to register a single-server service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Guid RegisterService(
    ISingleServerService service,
    bool isSerializable
)
Visual Basic
Public Shared Function RegisterService ( _
    service As ISingleServerService, _
    isSerializable As Boolean _
) As Guid
Visual C++
public:
static Guid RegisterService(
    ISingleServerService^ service,
    bool isSerializable
)

Parameters

service
Type: Autodesk.Revit.DB.ExternalService..::..ISingleServerService
An instance of the external service class that implements ISingleServerService interface.
isSerializable
Type: System..::..Boolean
Designates the service as either serializable or non-serializable.

Return Value

An access key to the service. The key is needed to execute the service.

Remarks

Each service can only be registered once. Revit checks the Id of every service getting registered and throws an exception upon an attempt to register a service with an Id that already exists.

Services need to be registered before Revit ends its initialization. For external applications that means they have to register their services during OnStartup. This will give servers which need to register to services a chance to do so during the ApplicationInitialized event, which is raised after a successfully processing OnStartup routines.

A service can be registered as either serializable or non-serializable. It is expected that a service that is once registered as serializable will always be registered as serializable. Failure to comply with this policy may lead to data loss in some documents when they are opened in a Revit session with the service currently registered as non-serializable.

A service is supposed to be executed only by the application that registered it. To enforce this requirement, the registering method return an execution key (a Guid) that is required as an argument to ExecuteService methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given service is not a valid implementation of ISingleServerService. -or- The given service does not return valid values from the interface methods. At least one of the Name, VendorId, Description, and ServiceId is either empty or invalid. -or- A service with this Id is either invalid or not unique.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Service cannot be registered because the registry of services has been already closed. All external services must be registered before the ApplicationInitialized event is raised.

See Also

ExternalServiceRegistry Class
RegisterService Overload
Autodesk.Revit.DB.ExternalService Namespace


RegisterService Method (IMultiServerService, Boolean, ExecutionPolicy)

[image]

Revit 2013 API
ExternalServiceRegistry..::..RegisterService Method (IMultiServerService, Boolean, ExecutionPolicy)
ExternalServiceRegistry Class See Also Send Feedback
A method to register a multi-server service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Guid RegisterService(
    IMultiServerService service,
    bool isSerializable,
    ExecutionPolicy policy
)
Visual Basic
Public Shared Function RegisterService ( _
    service As IMultiServerService, _
    isSerializable As Boolean, _
    policy As ExecutionPolicy _
) As Guid
Visual C++
public:
static Guid RegisterService(
    IMultiServerService^ service,
    bool isSerializable,
    ExecutionPolicy policy
)

Parameters

service
Type: Autodesk.Revit.DB.ExternalService..::..IMultiServerService
An instance of the external service class that implements IMultiServerService interface.
isSerializable
Type: System..::..Boolean
Designates the service as either serializable or non-serializable.
policy
Type: Autodesk.Revit.DB.ExternalService..::..ExecutionPolicy
Specifies how the service handles servers during its execution.

Return Value

An execution key to access the service when executing it.

Remarks

Each service can only be registered once. Revit checks the Id of every service getting registered and throws an exception upon an attempt to register a service with an Id that already exists.

Services need to be registered before Revit ends its initialization. For external applications that means they have to register their services during OnStartup. This will give servers which need to register to services a chance to do so during the ApplicationInitialized event, which is raised after a successfully processing OnStartup routines.

A service can be registered as either serializable or non-serializable. It is expected that a service that is once registered as serializable will always be registered as serializable. Failure to comply with this policy may lead to data loss in some documents when they are opened in a Revit session with the service currently registered as non-serializable.

An application registering a service must specify a policy to follow when executing the service. Once set, the policy remain constant during the Revit session, but a different policy may be used next time, if there is ever a need for such a change. More about the various execution policies can be found in the description of the ExecutionPolicy enumerated type.

A service is supposed to be executed only by the application that registered it. To enforce this requirement, the registering method return an execution key (a Guid) that is required as an argument to ExecuteService methods.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given service is not a valid implementation of ISingleServerService. -or- The given service does not return valid values from the interface methods. At least one of the Name, VendorId, Description, and ServiceId is either empty or invalid. -or- A service with this Id is either invalid or not unique.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Service cannot be registered because the registry of services has been already closed. All external services must be registered before the ApplicationInitialized event is raised.

See Also

ExternalServiceRegistry Class
RegisterService Overload
Autodesk.Revit.DB.ExternalService Namespace


ExternalServiceResult Enumeration

[image]

Revit 2013 API
ExternalServiceResult Enumeration
See Also Send Feedback
An enumerated value representing a result from executing an external service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ExternalServiceResult
Visual Basic
Public Enumeration ExternalServiceResult
Visual C++
public enum class ExternalServiceResult

Members

Member name | Description
Succeeded | Service has been executed successfully.
Failed | Service execution has failed.
Unhandled | Execution of a service has not been handled; possibly because there are no applicable servers.

See Also

Autodesk.Revit.DB.ExternalService Namespace


ExternalServices Class

[image]

Revit 2013 API
ExternalServices Class
See Also Send Feedback
Provides a container of all Revit built-in ExternalServiceId instances.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static class ExternalServices
Visual Basic
Public NotInheritable Class ExternalServices
Visual C++
public ref class ExternalServices abstract sealed

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExternalService..::..ExternalServices

See Also

Autodesk.Revit.DB.ExternalService Namespace


IExternalData Interface

[image]

Revit 2013 API
IExternalData Interface
See Also Send Feedback
The base interface for data classes used when executing servers of external services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IExternalData
Visual Basic
Public Interface IExternalData
Visual C++
public interface class IExternalData

Remarks

Each and every external service defines a concrete class derived from this interface and adds data and methods as it sees fit for executions of such a particular service.

See Also

Autodesk.Revit.DB.ExternalService Namespace


IExternalServer Interface

[image]

Revit 2013 API
IExternalServer Interface
Members See Also Send Feedback
The base interface for all external servers.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IExternalServer
Visual Basic
Public Interface IExternalServer
Visual C++
public interface class IExternalServer

Remarks

Every external service in Revit declares a specific interface for its servers. Each interface must be derived from this IExternalServer. Providers of external servers implement the server interfaces defined by the respective external services to which the servers belong. The whole process of creating a server and registering it with Revit as a server of a concrete external service can be outlined in the following steps:
  1. A provider of an external service declares a server interface derived from IExternalServer
  2. The provider of the service will make it known that this interface is for the servers of that service
  3. An application wanting to have a server will implement the appropriate interface
  4. The server's application obtains the service from Revit using the ExternalServiceRegistry.GetService method
  5. An instance of the server class can then be registered with Revit by using the ExternalService.AddServer method

See Also

IExternalServer Members
Autodesk.Revit.DB.ExternalService Namespace


IExternalServer Members

[image] [image]

Revit 2013 API
IExternalServer Members
IExternalServer Interface Methods See Also Send Feedback

The IExternalServer type exposes the following members.

Methods

 | Name | Description
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


IExternalServer Methods

[image] [image]

Revit 2013 API
IExternalServer Methods
IExternalServer Interface See Also Send Feedback

The IExternalServer type exposes the following members.

Methods

 | Name | Description
Public method | GetDescription | Implement this method to return a description of the server.
Public method | GetName | Implement this method to return the name of the server.
Public method | GetServerId | Implement this method to return the id of the server.
Public method | GetServiceId | Implement this method to return the id of the service.
Public method | GetVendorId | Implement this method to return the id of the vendor of the server.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


GetDescription Method

[image]

Revit 2013 API
IExternalServer..::..GetDescription Method
IExternalServer Interface See Also Send Feedback
Implement this method to return a description of the server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetDescription()
Visual Basic
Function GetDescription As String
Visual C++
String^ GetDescription()

Return Value

Description of the server.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


GetName Method

[image]

Revit 2013 API
IExternalServer..::..GetName Method
IExternalServer Interface See Also Send Feedback
Implement this method to return the name of the server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

Name of the server.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


GetServerId Method

[image]

Revit 2013 API
IExternalServer..::..GetServerId Method
IExternalServer Interface See Also Send Feedback
Implement this method to return the id of the server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
Guid GetServerId()
Visual Basic
Function GetServerId As Guid
Visual C++
Guid GetServerId()

Return Value

The id of the server.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


GetServiceId Method

[image]

Revit 2013 API
IExternalServer..::..GetServiceId Method
IExternalServer Interface See Also Send Feedback
Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
ExternalServiceId GetServiceId()
Visual Basic
Function GetServiceId As ExternalServiceId
Visual C++
ExternalServiceId^ GetServiceId()

Return Value

The id of the service to which the server belongs.

Remarks

An external server belongs to only one external service. This method must return an Id that matches the Id the corresponding service was registered with.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


GetVendorId Method

[image]

Revit 2013 API
IExternalServer..::..GetVendorId Method
IExternalServer Interface See Also Send Feedback
Implement this method to return the id of the vendor of the server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetVendorId()
Visual Basic
Function GetVendorId As String
Visual C++
String^ GetVendorId()

Return Value

Vendor Id of the server.

Remarks

The Id is expected to be a string consisting of 4 characters.

See Also

IExternalServer Interface
Autodesk.Revit.DB.ExternalService Namespace


IExternalService Interface

[image]

Revit 2013 API
IExternalService Interface
Members See Also Send Feedback
The base interface class for all external services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IExternalService
Visual Basic
Public Interface IExternalService
Visual C++
public interface class IExternalService

Remarks

Both supported kinds of services - single-server and multi-server - will derive their classes from this interface, albeit indirectly through an interface specific to the particular kind. External services never derive directly from this class - they always have to derive from either ISingleServerService or IMultiServerService, respectivelly.

See Also

IExternalService Members
Autodesk.Revit.DB.ExternalService Namespace


IExternalService Members

[image] [image]

Revit 2013 API
IExternalService Members
IExternalService Interface Methods See Also Send Feedback

The IExternalService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server.
Public method | GetDescription | Implement this method to return a description of the service.
Public method | GetName | Implement this method to return the name of the service.
Public method | GetServiceId | Implement this method to return the unique Id of the service.
Public method | GetVendorId | Implement this method to return the vendor Id of the service.
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service.
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


IExternalService Methods

[image] [image]

Revit 2013 API
IExternalService Methods
IExternalService Interface See Also Send Feedback

The IExternalService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server.
Public method | GetDescription | Implement this method to return a description of the service.
Public method | GetName | Implement this method to return the name of the service.
Public method | GetServiceId | Implement this method to return the unique Id of the service.
Public method | GetVendorId | Implement this method to return the vendor Id of the service.
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service.
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed.
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


Execute Method

[image]

Revit 2013 API
IExternalService..::..Execute Method
IExternalService Interface See Also Send Feedback
Implement this method to execute the given server.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool Execute(
    IExternalServer server,
    Document document,
    IExternalData data
)
Visual Basic
Function Execute ( _
    server As IExternalServer, _
    document As Document, _
    data As IExternalData _
) As Boolean
Visual C++
bool Execute(
    IExternalServer^ server,
    Document^ document,
    IExternalData^ data
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be executed.
document
Type: Autodesk.Revit.DB..::..Document
The associated document. It may be NULL if the service is not being executed in a document.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated service data.

Return Value

True indicates a successful execution of the call. False indicates a failure.

If a multi-server service returns false from the call, the service manager will stop the execution loop and marks the service execution as unsuccessful.

Remarks

It is completely upon the service to decide what the communication with the server should be like, for it is the service provider who also defines what the server's interface looks like. It could be as simple as calling one method (e.g. Execute, Run, Calculate, etc.) or it could be a set of inquiries and executing calls to the server.

The framework invokes this method when the service is requested to be executed. The framework first checks what the applicable server (or servers, in a multi-server service) is and then it calls this method with that server as an argument.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


GetDescription Method

[image]

Revit 2013 API
IExternalService..::..GetDescription Method
IExternalService Interface See Also Send Feedback
Implement this method to return a description of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetDescription()
Visual Basic
Function GetDescription As String
Visual C++
String^ GetDescription()

Return Value

Description of the service.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


GetName Method

[image]

Revit 2013 API
IExternalService..::..GetName Method
IExternalService Interface See Also Send Feedback
Implement this method to return the name of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

Name of the service.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


GetServiceId Method

[image]

Revit 2013 API
IExternalService..::..GetServiceId Method
IExternalService Interface See Also Send Feedback
Implement this method to return the unique Id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
ExternalServiceId GetServiceId()
Visual Basic
Function GetServiceId As ExternalServiceId
Visual C++
ExternalServiceId^ GetServiceId()

Return Value

The extensible enum value representing the Id of the service.

Remarks

A service Id is an item in an extensible enum in which all service Ids are contained.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


GetVendorId Method

[image]

Revit 2013 API
IExternalService..::..GetVendorId Method
IExternalService Interface See Also Send Feedback
Implement this method to return the vendor Id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetVendorId()
Visual Basic
Function GetVendorId As String
Visual C++
String^ GetVendorId()

Return Value

Vendor Id of the service.

Remarks

The Id is expected to be a string consisting of 4 characters.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


IsValidServer Method

[image]

Revit 2013 API
IExternalService..::..IsValidServer Method
IExternalService Interface See Also Send Feedback
Implement this method to check if the given instance represents a valid server of this service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool IsValidServer(
    IExternalServer server
)
Visual Basic
Function IsValidServer ( _
    server As IExternalServer _
) As Boolean
Visual C++
bool IsValidServer(
    IExternalServer^ server
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be validated.

Return Value

True if the server is valid, False otherwise

Remarks

This method is invoked by the framework upon registration of a server for this service. The simplest implementation would be to test if the type of the object is as expected.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


OnServersChanged Method

[image]

Revit 2013 API
IExternalService..::..OnServersChanged Method
IExternalService Interface See Also Send Feedback
Implement this method to handle situations when servers for the service have changed.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
void OnServersChanged(
    Document document,
    ServerChangeCause cause,
    IList<Guid> oldServers
)
Visual Basic
Sub OnServersChanged ( _
    document As Document, _
    cause As ServerChangeCause, _
    oldServers As IList(Of Guid) _
)
Visual C++
void OnServersChanged(
    Document^ document,
    ServerChangeCause cause,
    IList<Guid>^ oldServers
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The corresponding document
cause
Type: Autodesk.Revit.DB.ExternalService..::..ServerChangeCause
Indicates in what situation the servers are changed. Currently available values indicate whether the change is a result of an explicit user request, or by an implicit change of situation within the service - for example when a document is updated upon opening.
oldServers
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
Ids of servers previously used in the document. Please note that the Ids may belong to servers that are not registered with service anymore.

Remarks

This method may only be invoked in a serializable service. Services registered as non-serializable never receive this call.

It is imperative to understand this method is not called just when an active server (or servers) is (are) changed for a service. It is invoked only when the active server is changed so it is different from those previously used (i.e. actually executed) in a document. Because of that, this notification is never sent when active server is set or reset in a document in which the service was never executed before.

If a document has explicitly set active server (or servers), OnServersChanged is never called for that document when the application-wide active server (servers) gets changed. The document would still be executed with its own active servers applied. A similar case is when the active server (servers) is unset for a document but the currently active application-wide server happens to be the same as the one that was set in the document.

It is up to the service provider to decide what should be the appropriate action. In some cases, if not all, the service will probably want to execute again, now with the new active server(s), but that it is not necessary - the service invoker may as well decide to wait for the end-user to trigger execution if the service (e.g. by clicking a corresponding command in the menu.)

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


OnServersDisparity Method

[image]

Revit 2013 API
IExternalService..::..OnServersDisparity Method
IExternalService Interface See Also Send Feedback
Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool OnServersDisparity(
    Document document,
    IList<Guid> oldServers
)
Visual Basic
Function OnServersDisparity ( _
    document As Document, _
    oldServers As IList(Of Guid) _
) As Boolean
Visual C++
bool OnServersDisparity(
    Document^ document,
    IList<Guid>^ oldServers
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The coresponding document
oldServers
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
Ids of servers previously used in the document. Please note that the Ids may belong to servers that are currently not registered with the service.

Return Value

Return False if you want the framework to handle the situation; return True if the situation has already been handled.

Remarks

This method may only be invoked in a serializable service. Services registered as non-serializable never receive this call.

This notification is sent when Revit opens a document which has a record of the service used (executed at least once) and the record shows that the server (or servers) used differ from those currently set as active for the service.

Unless the situation is explicitly handled in this call (by returning True), the framework will follow up by assigning the formerly used servers as the currently active servers of that document, after it will notify the service about the change by invoking the OnServersChanged method on the services interface.

See Also

IExternalService Interface
Autodesk.Revit.DB.ExternalService Namespace


IMultiServerService Interface

[image]

Revit 2013 API
IMultiServerService Interface
Members See Also Send Feedback
The base interface class for all multi-server services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IMultiServerService : IExternalService
Visual Basic
Public Interface IMultiServerService _
    Inherits IExternalService
Visual C++
public interface class IMultiServerService : IExternalService

Remarks

Both a single-server and multi-server service may have more than one server registered for them. The difference between these two kinds is while there can only be one active server at any given time for a single-sever service, there may be a whole set of active servers assigned for a multi-server service.

When a multi-server service gets executed, the framework iterates through the set of currently active servers (application-wide or document-specific depending on the situation) and invokes the service's interface with a CanExecute call. If the service replies the current server cannot be executed, the framework skips it and continues with the next one in the queue. When a server is found it can be executed, the framework calls the service's interface again, this time with the Execute method. Whether the execution loop ends after the first executed server or not is controlled by execution policy, which is supplied for the service upon its registration.

See Also

IMultiServerService Members
Autodesk.Revit.DB.ExternalService Namespace


IMultiServerService Members

[image] [image]

Revit 2013 API
IMultiServerService Members
IMultiServerService Interface Methods See Also Send Feedback

The IMultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | CanExecute | Implement this to test whether a particular server should be executed.
Public method | Execute | Implement this method to execute the given server. (Inherited from IExternalService.)
Public method | GetDescription | Implement this method to return a description of the service. (Inherited from IExternalService.)
Public method | GetName | Implement this method to return the name of the service. (Inherited from IExternalService.)
Public method | GetServiceId | Implement this method to return the unique Id of the service. (Inherited from IExternalService.)
Public method | GetVendorId | Implement this method to return the vendor Id of the service. (Inherited from IExternalService.)
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service. (Inherited from IExternalService.)
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed. (Inherited from IExternalService.)
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service. (Inherited from IExternalService.)

See Also

IMultiServerService Interface
Autodesk.Revit.DB.ExternalService Namespace


IMultiServerService Methods

[image] [image]

Revit 2013 API
IMultiServerService Methods
IMultiServerService Interface See Also Send Feedback

The IMultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | CanExecute | Implement this to test whether a particular server should be executed.
Public method | Execute | Implement this method to execute the given server. (Inherited from IExternalService.)
Public method | GetDescription | Implement this method to return a description of the service. (Inherited from IExternalService.)
Public method | GetName | Implement this method to return the name of the service. (Inherited from IExternalService.)
Public method | GetServiceId | Implement this method to return the unique Id of the service. (Inherited from IExternalService.)
Public method | GetVendorId | Implement this method to return the vendor Id of the service. (Inherited from IExternalService.)
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service. (Inherited from IExternalService.)
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed. (Inherited from IExternalService.)
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service. (Inherited from IExternalService.)

See Also

IMultiServerService Interface
Autodesk.Revit.DB.ExternalService Namespace


CanExecute Method

[image]

Revit 2013 API
IMultiServerService..::..CanExecute Method
IMultiServerService Interface See Also Send Feedback
Implement this to test whether a particular server should be executed.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
bool CanExecute(
    IExternalServer server,
    Document document,
    IExternalData data
)
Visual Basic
Function CanExecute ( _
    server As IExternalServer, _
    document As Document, _
    data As IExternalData _
) As Boolean
Visual C++
bool CanExecute(
    IExternalServer^ server,
    Document^ document,
    IExternalData^ data
)

Parameters

server
Type: Autodesk.Revit.DB.ExternalService..::..IExternalServer
An instance of a server that is to be tested.
document
Type: Autodesk.Revit.DB..::..Document
The associated document. It may be NULL if not applicable.
data
Type: Autodesk.Revit.DB.ExternalService..::..IExternalData
The associated service data. It is the same data the Execute method would receive.

See Also

IMultiServerService Interface
Autodesk.Revit.DB.ExternalService Namespace


ISingleServerService Interface

[image]

Revit 2013 API
ISingleServerService Interface
Members See Also Send Feedback
The base interface class for all single-server services.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface ISingleServerService : IExternalService
Visual Basic
Public Interface ISingleServerService _
    Inherits IExternalService
Visual C++
public interface class ISingleServerService : IExternalService

Remarks

Both single-server and multi-server services may have more than one server registered for them. The difference between these two kinds is while there can only be one active server at any given time for a single-sever service, there may be a set of active servers assigned for a multi-server service.

ISingleServerService does not have any specific methods (currently) added to those inherited from the common IExternalService interface.

See Also

ISingleServerService Members
Autodesk.Revit.DB.ExternalService Namespace


ISingleServerService Members

[image] [image]

Revit 2013 API
ISingleServerService Members
ISingleServerService Interface Methods See Also Send Feedback

The ISingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server. (Inherited from IExternalService.)
Public method | GetDescription | Implement this method to return a description of the service. (Inherited from IExternalService.)
Public method | GetName | Implement this method to return the name of the service. (Inherited from IExternalService.)
Public method | GetServiceId | Implement this method to return the unique Id of the service. (Inherited from IExternalService.)
Public method | GetVendorId | Implement this method to return the vendor Id of the service. (Inherited from IExternalService.)
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service. (Inherited from IExternalService.)
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed. (Inherited from IExternalService.)
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service. (Inherited from IExternalService.)

See Also

ISingleServerService Interface
Autodesk.Revit.DB.ExternalService Namespace


ISingleServerService Methods

[image] [image]

Revit 2013 API
ISingleServerService Methods
ISingleServerService Interface See Also Send Feedback

The ISingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to execute the given server. (Inherited from IExternalService.)
Public method | GetDescription | Implement this method to return a description of the service. (Inherited from IExternalService.)
Public method | GetName | Implement this method to return the name of the service. (Inherited from IExternalService.)
Public method | GetServiceId | Implement this method to return the unique Id of the service. (Inherited from IExternalService.)
Public method | GetVendorId | Implement this method to return the vendor Id of the service. (Inherited from IExternalService.)
Public method | IsValidServer | Implement this method to check if the given instance represents a valid server of this service. (Inherited from IExternalService.)
Public method | OnServersChanged | Implement this method to handle situations when servers for the service have changed. (Inherited from IExternalService.)
Public method | OnServersDisparity | Implements this method to get notified that the servers in a just opened document differ from those currently set as active for the service. (Inherited from IExternalService.)

See Also

ISingleServerService Interface
Autodesk.Revit.DB.ExternalService Namespace


MultiServerService Class

[image]

Revit 2013 API
MultiServerService Class
Members See Also Send Feedback
This class represents a multi-server service inside Revit application. It is created when an instance of IMultiServerService is registered with Revit.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class MultiServerService : ExternalService
Visual Basic
Public Class MultiServerService _
    Inherits ExternalService
Visual C++
public ref class MultiServerService : public ExternalService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExternalService..::..ExternalService
Autodesk.Revit.DB.ExternalService..::..MultiServerService

See Also

MultiServerService Members
Autodesk.Revit.DB.ExternalService Namespace


MultiServerService Members

[image] [image]

Revit 2013 API
MultiServerService Members
MultiServerService Class Methods Properties See Also Send Feedback

The MultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerIds()()()() | Returns Ids of the currently active application-level servers registered for the service.
Public method | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>)) | Changes the active servers and/or their order.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>), Document) | Changes the active servers and/or their order for the given document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Description | The description for the service; (Inherited from ExternalService.)
Public property | ExecutionPolicy | Specifies how a multi-server service executes servers during its execution.
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService.)
Public property | Name | The name of the service; (Inherited from ExternalService.)
Public property | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService.)
Public property | ServiceId | The Id of the service; (Inherited from ExternalService.)
Public property | VendorId | The vendor who provided the service; (Inherited from ExternalService.)

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace


MultiServerService Methods

[image] [image]

Revit 2013 API
MultiServerService Methods
MultiServerService Class See Also Send Feedback

The MultiServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerIds()()()() | Returns Ids of the currently active application-level servers registered for the service.
Public method | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>)) | Changes the active servers and/or their order.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>), Document) | Changes the active servers and/or their order for the given document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerIds Method

[image] [image]

Revit 2013 API
MultiServerService..::..GetActiveServerIds Method
MultiServerService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetActiveServerIds()()()() | Returns Ids of the currently active application-level servers registered for the service.
Public method | GetActiveServerIds(Document) | Returns Ids of the servers currently applicable to the given document for the service.

See Also

MultiServerService Class
MultiServerService Members
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerIds Method

[image]

Revit 2013 API
MultiServerService..::..GetActiveServerIds Method
MultiServerService Class See Also Send Feedback
Returns Ids of the currently active application-level servers registered for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Guid> GetActiveServerIds()
Visual Basic
Public Function GetActiveServerIds As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetActiveServerIds()

Return Value

A set of GUIDs of the application-wide active servers; the list may be empty.

Remarks

More than one application-level server can be active at a given time in a multi-server service, but it is possible that no server is active (unless the service is mandatory).

See Also

MultiServerService Class
GetActiveServerIds Overload
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerIds Method (Document)

[image]

Revit 2013 API
MultiServerService..::..GetActiveServerIds Method (Document)
MultiServerService Class See Also Send Feedback
Returns Ids of the servers currently applicable to the given document for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Guid> GetActiveServerIds(
    Document document
)
Visual Basic
Public Function GetActiveServerIds ( _
    document As Document _
) As IList(Of Guid)
Visual C++
public:
IList<Guid>^ GetActiveServerIds(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The associated document.

Return Value

A set of GUIDs of the document-applicable active servers; the list may be empty.

Remarks

The Ids would be of all the servers explicitly assigned to the specified document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MultiServerService Class
GetActiveServerIds Overload
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServers Method

[image] [image]

Revit 2013 API
MultiServerService..::..SetActiveServers Method
MultiServerService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>)) | Changes the active servers and/or their order.
Public method | SetActiveServers(IList<(Of <<'(Guid>)>>), Document) | Changes the active servers and/or their order for the given document.

See Also

MultiServerService Class
MultiServerService Members
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServers Method (IList(Guid))

[image]

Revit 2013 API
MultiServerService..::..SetActiveServers Method (IList<(Of <(<'Guid>)>)>)
MultiServerService Class See Also Send Feedback
Changes the active servers and/or their order.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetActiveServers(
    IList<Guid> serverIds
)
Visual Basic
Public Sub SetActiveServers ( _
    serverIds As IList(Of Guid) _
)
Visual C++
public:
void SetActiveServers(
    IList<Guid>^ serverIds
)

Parameters

serverIds
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
A set of Ids of servers that are to be set as active for this service or an empty set if no server should currently be set as active.

Remarks

More than one server can be active at any given time in a multi-server service, but it is possible that no server is active (unless the service is mandatory).

An application-wide active servers get executed when the service is invoked in the scope of the entire application (i.e. without a specific document), or if the service is executed in a document but the document does not have active servers explicitly set.

Setting active servers replaces previously active servers. Both the number of servers and their orders is significant. Servers do always get executed in the order in which they were set as active. If it is desired the order of execution is different, the same set of active servers must be set again, but in the modified, desired order.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some of the given Ids do not represent valid servers of the service. -or- The list of servers contains duplicates. The SetActiveServers method expects a set of unique servers.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

MultiServerService Class
SetActiveServers Overload
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServers Method (IList(Guid), Document)

[image]

Revit 2013 API
MultiServerService..::..SetActiveServers Method (IList<(Of <(<'Guid>)>)>, Document)
MultiServerService Class See Also Send Feedback
Changes the active servers and/or their order for the given document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetActiveServers(
    IList<Guid> serverIds,
    Document document
)
Visual Basic
Public Sub SetActiveServers ( _
    serverIds As IList(Of Guid), _
    document As Document _
)
Visual C++
public:
void SetActiveServers(
    IList<Guid>^ serverIds,
    Document^ document
)

Parameters

serverIds
Type: System.Collections.Generic..::..IList<(Of <(<'Guid>)>)>
A set of Ids of servers that are to be set as active for this service in this document or an empty set if no server should currently be set as active in this particular document.
document
Type: Autodesk.Revit.DB..::..Document
The document for which the servers are set as active.

Remarks

More than one server per document can be set as active at any given time in a multi-server service. A document does not have to have an explicitly set active servers though - the application-wide active servers would be normally used when the service is executed for such a document.

Having active servers for a document overrules the active servers set for the application. That means if the service gets executed in this particular document, the document-specific servers will be used instead of the application-wide ones.

It is possible to set servers as active when other servers already are active for that service in this document. Setting a new set or the same set but with a different order will automatically replace the previously active servers in that document

All the servers must be valid (registered with the service) and must be unique in the set. The set may be empty though which allows to unset active servers from a document, which means that the document will be executed with the currently active servers set application-wide

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Some of the given Ids do not represent valid servers of the service. -or- The list of servers contains duplicates. The SetActiveServers method expects a set of unique servers.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

MultiServerService Class
SetActiveServers Overload
Autodesk.Revit.DB.ExternalService Namespace


MultiServerService Properties

[image] [image]

Revit 2013 API
MultiServerService Properties
MultiServerService Class See Also Send Feedback

The MultiServerService type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description for the service; (Inherited from ExternalService.)
Public property | ExecutionPolicy | Specifies how a multi-server service executes servers during its execution.
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService.)
Public property | Name | The name of the service; (Inherited from ExternalService.)
Public property | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService.)
Public property | ServiceId | The Id of the service; (Inherited from ExternalService.)
Public property | VendorId | The vendor who provided the service; (Inherited from ExternalService.)

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace


ExecutionPolicy Property

[image]

Revit 2013 API
MultiServerService..::..ExecutionPolicy Property
MultiServerService Class See Also Send Feedback
Specifies how a multi-server service executes servers during its execution.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExecutionPolicy ExecutionPolicy { get; }
Visual Basic
Public ReadOnly Property ExecutionPolicy As ExecutionPolicy
    Get
Visual C++
public:
property ExecutionPolicy ExecutionPolicy {
    ExecutionPolicy get ();
}

Remarks

Read descriptions for the items in the ExecutionPolicy enum to find out details about all applicable execution policies.

See Also

MultiServerService Class
Autodesk.Revit.DB.ExternalService Namespace


ServerChangeCause Enumeration

[image]

Revit 2013 API
ServerChangeCause Enumeration
See Also Send Feedback
Indicates the cause for the active server to be changed

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum ServerChangeCause
Visual Basic
Public Enumeration ServerChangeCause
Visual C++
public enum class ServerChangeCause

Members

Member name | Description
ImposedChange | The active server is being changed as a result of other operations in Revit.
UserChange | The change of the active server has been explicitly requested by the end user.

See Also

Autodesk.Revit.DB.ExternalService Namespace


SingleServerService Class

[image]

Revit 2013 API
SingleServerService Class
Members See Also Send Feedback
This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SingleServerService : ExternalService
Visual Basic
Public Class SingleServerService _
    Inherits ExternalService
Visual C++
public ref class SingleServerService : public ExternalService

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.ExternalService..::..ExternalService
Autodesk.Revit.DB.ExternalService..::..SingleServerService

See Also

SingleServerService Members
Autodesk.Revit.DB.ExternalService Namespace


SingleServerService Members

[image] [image]

Revit 2013 API
SingleServerService Members
SingleServerService Class Methods Properties See Also Send Feedback

The SingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerId()()()() | Returns the Id of the currently active application-level server of the service.
Public method | GetActiveServerId(Document) | Returns the Id of the server currently associated with the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServer(Guid) | Set an active server applicable application-wide for the service.
Public method | SetActiveServer(Guid, Document) | Change the active server for a specific document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetActiveServer | Unset the active server for the particular document.

Properties

 | Name | Description
Public property | Description | The description for the service; (Inherited from ExternalService.)
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService.)
Public property | Name | The name of the service; (Inherited from ExternalService.)
Public property | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService.)
Public property | ServiceId | The Id of the service; (Inherited from ExternalService.)
Public property | VendorId | The vendor who provided the service; (Inherited from ExternalService.)

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace


SingleServerService Methods

[image] [image]

Revit 2013 API
SingleServerService Methods
SingleServerService Class See Also Send Feedback

The SingleServerService type exposes the following members.

Methods

 | Name | Description
Public method | AddServer | Registers a server with its service. (Inherited from ExternalService.)
Public method | Dispose | (Inherited from ExternalService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetActiveServerId()()()() | Returns the Id of the currently active application-level server of the service.
Public method | GetActiveServerId(Document) | Returns the Id of the server currently associated with the given document for the service.
Public method | GetDefaultServerId | Returns the Id of the default server if one was assigned to the service. (Inherited from ExternalService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRegisteredServerIds | Returns Ids of all servers registered for the service. (Inherited from ExternalService.)
Public method | GetServer | Returns the instance that provides implementation for a registered server. (Inherited from ExternalService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsRegisteredServerId | Checks if the Id represents a valid server that have been registered for the service. (Inherited from ExternalService.)
Public method | RemoveServer | Removes/unregisters a server from the service. (Inherited from ExternalService.)
Public method | SetActiveServer(Guid) | Set an active server applicable application-wide for the service.
Public method | SetActiveServer(Guid, Document) | Change the active server for a specific document.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UnsetActiveServer | Unset the active server for the particular document.

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerId Method

[image] [image]

Revit 2013 API
SingleServerService..::..GetActiveServerId Method
SingleServerService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetActiveServerId()()()() | Returns the Id of the currently active application-level server of the service.
Public method | GetActiveServerId(Document) | Returns the Id of the server currently associated with the given document for the service.

See Also

SingleServerService Class
SingleServerService Members
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerId Method

[image]

Revit 2013 API
SingleServerService..::..GetActiveServerId Method
SingleServerService Class See Also Send Feedback
Returns the Id of the currently active application-level server of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid GetActiveServerId()
Visual Basic
Public Function GetActiveServerId As Guid
Visual C++
public:
Guid GetActiveServerId()

Return Value

The GUID of the active server, or an invalid GUID if there is no active server assigned.

See Also

SingleServerService Class
GetActiveServerId Overload
Autodesk.Revit.DB.ExternalService Namespace


GetActiveServerId Method (Document)

[image]

Revit 2013 API
SingleServerService..::..GetActiveServerId Method (Document)
SingleServerService Class See Also Send Feedback
Returns the Id of the server currently associated with the given document for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Guid GetActiveServerId(
    Document document
)
Visual Basic
Public Function GetActiveServerId ( _
    document As Document _
) As Guid
Visual C++
public:
Guid GetActiveServerId(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document for which the server is being set as active.

Return Value

The Guid of the active server, or an invalid Guid if there is no active server assigned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SingleServerService Class
GetActiveServerId Overload
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServer Method

[image] [image]

Revit 2013 API
SingleServerService..::..SetActiveServer Method
SingleServerService Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetActiveServer(Guid) | Set an active server applicable application-wide for the service.
Public method | SetActiveServer(Guid, Document) | Change the active server for a specific document.

See Also

SingleServerService Class
SingleServerService Members
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServer Method (Guid)

[image]

Revit 2013 API
SingleServerService..::..SetActiveServer Method (Guid)
SingleServerService Class See Also Send Feedback
Set an active server applicable application-wide for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetActiveServer(
    Guid serverId
)
Visual Basic
Public Sub SetActiveServer ( _
    serverId As Guid _
)
Visual C++
public:
void SetActiveServer(
    Guid serverId
)

Parameters

serverId
Type: System..::..Guid
Id of the application server.

Remarks

Only one server can be active at any given time in a single-server service, but it is possible that no server is active (unless the service is mandatory).

An application-wide active server gets executed when the service is invoked in the scope of the entire application (i.e. without a specific document), or if the service is executed in a document but the document does not have an active server explicitly set.

It is possible to set a server as active when another server is already active for that service. Making a server active will automatically deactivate the server that was active before this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id is not of a server registered with the service.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

SingleServerService Class
SetActiveServer Overload
Autodesk.Revit.DB.ExternalService Namespace


SetActiveServer Method (Guid, Document)

[image]

Revit 2013 API
SingleServerService..::..SetActiveServer Method (Guid, Document)
SingleServerService Class See Also Send Feedback
Change the active server for a specific document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetActiveServer(
    Guid serverId,
    Document document
)
Visual Basic
Public Sub SetActiveServer ( _
    serverId As Guid, _
    document As Document _
)
Visual C++
public:
void SetActiveServer(
    Guid serverId,
    Document^ document
)

Parameters

serverId
Type: System..::..Guid
Id of the server.
document
Type: Autodesk.Revit.DB..::..Document
The document for which the server is being set as active.

Remarks

Only one server per document can be set as active at any given time in a single-server service. A document does not have to have an explicitly set active server though - the application-wide active server would be normally used when the service is executed for such a document.

Having an active server for a document overrules the active server set for the application. That means if the service gets executed in this particular document, the document-specific server will be used instead of the application-wide one.

It is possible to set a server as active when another server is already active for that service in this document. Making a server active will automatically deactivate the server that was active before this call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id is not of a server registered with the service.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

SingleServerService Class
SetActiveServer Overload
Autodesk.Revit.DB.ExternalService Namespace


UnsetActiveServer Method

[image]

Revit 2013 API
SingleServerService..::..UnsetActiveServer Method
SingleServerService Class See Also Send Feedback
Unset the active server for the particular document.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void UnsetActiveServer(
    Document document
)
Visual Basic
Public Sub UnsetActiveServer ( _
    document As Document _
)
Visual C++
public:
void UnsetActiveServer(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document

Remarks

After unsetting the active server, the document will be using the application-wide active server, if one was already set.

Note it is not possible to unset a server that acts as an application-wide active server for a service. On the other hand, there should be no reason to ever do so, for each and every registered service should have (ideally) an active server set applicatiton-wide.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation is not allowed because the service is being executed.

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace


SingleServerService Properties

[image] [image]

Revit 2013 API
SingleServerService Properties
SingleServerService Class See Also Send Feedback

The SingleServerService type exposes the following members.

Properties

 | Name | Description
Public property | Description | The description for the service; (Inherited from ExternalService.)
Public property | IsSerializable | Indicates whether executions of the service requires serialization in documents or not. (Inherited from ExternalService.)
Public property | Name | The name of the service; (Inherited from ExternalService.)
Public property | NumberOfServers | Indicates the number of servers currently registered with the service. (Inherited from ExternalService.)
Public property | ServiceId | The Id of the service; (Inherited from ExternalService.)
Public property | VendorId | The vendor who provided the service; (Inherited from ExternalService.)

See Also

SingleServerService Class
Autodesk.Revit.DB.ExternalService Namespace


Autodesk.Revit.DB.IFC Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.IFC Namespace
Send Feedback

Classes

 | Class | Description
Public class | ExporterIFC | The main class provided by Revit to allow implementation of IFC export.
Public class | ExporterIFCRegistry | Application level singleton that stores registered IFC exporters.
Public class | ExporterIFCUtils | A class that contains utilities needed to implement Revit's version of the IFC export client application.
Public class | IFCAggregate | A collection of IFC handles or attributes.
Public class | IFCAggregateIterator | A class used to iterate individual objects in an IFCAggregate.
Public class | IFCAnyHandle | A handle representing an item in an IFC file.
Public class | IFCConnectedWallData | A class that contains the IFC-specific information about how an element is joined to another element.
Public class | IFCData | A specialized type of abstract data block that can represent any data type.
Public class | IFCDoorWindowInfo | Represents information used by IFC export of door and window family instances.
Public class | IFCExtrusionCalculatorOptions | This class contains the options used to calculate extrusions from Revit geometry.
Public class | IFCExtrusionCalculatorUtils | A utility class used to calculate extrusion data from Revit geometry for IFC export.
Public class | IFCExtrusionCreationData | A utility object that is used to pass information related to extrusion creation.
Public class | IFCExtrusionData | Represents the geometry of an extrusion (a solid body or opening) generated from Revit geometry.
Public class | IFCFamilyInstanceExtrusionExportResults | This class represents the results of a geometric analysis of a family instance.
Public class | IFCFile | Represents the IFC file which is being created during export.
Public class | IFCFileModelOptions | This class contains options to create an IFC file model.
Public class | IFCFileWriteOptions | This class contains options to write an IFC file.
Public class | IFCGeometryInfo | A container class for Revit geometry extracted from an element.
Public class | IFCLegacyStairOrRamp | The class contains the components of a legacy stair or ramp.
Public class | IFCLevelInfo | Represents information about a particular level in the document.
Public class | IFCPlacementSetter | A state-based class that establishes the current IfcLocalPlacement applied to an element being exported.
Public class | IFCProductWrapper | This class is used to ensure that elements and objects are associated with the current IfcProduct.
Public class | IFCRange | Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.
Public class | IFCStairRampContainerInfo | Keep track of stair/ramp, flights and railing connectivity information
Public class | IFCTransaction | IFC transactions are context-like objects that guard any changes made to an IFC file.
Public class | IFCTransformSetter | A state-based class that forces an extra transformation applied to objects being exported.
Public class | IFCTypeInfo | An info class representing data about a given element type, typically used for Revit family types.

Interfaces

 | Interface | Description
Public interface | IExporterIFC | The interface used to implement a custom IFC exporter.

Enumerations

 | Enumeration | Description
Public enumeration | IFCConnectedWallDataLocation | An enumerated type that represents the location where an element is connected to a wall.
Public enumeration | IFCDataPrimitiveType | Used in operations to specify the primitive type of an IFCData.
Public enumeration | IFCDoorStyleOperation | The types of door operations, as defined in IFC2x3. This relates to how the door opens.
Public enumeration | IFCExtrusionAxes | Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.
Public enumeration | IFCExtrusionBasis | This enumerated type represents the possible bases for derivation of extrusion geometry.
Public enumeration | IFCFileFormat | The IFC file format.
Public enumeration | IFCLogical | A datatype can have values TRUE, FALSE or UNKNOWN.
Public enumeration | IFCProjectLevelGUIDType | The type of the GUID to be retrieved from Revit.
Public enumeration | IFCWindowStyleOperation | The types of window configurations, as defined in IFC2x3.


ExporterIFC Class

[image]

Revit 2013 API
ExporterIFC Class
Members See Also Send Feedback
The main class provided by Revit to allow implementation of IFC export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExporterIFC : IDisposable
Visual Basic
Public Class ExporterIFC _
    Implements IDisposable
Visual C++
public ref class ExporterIFC : IDisposable

Remarks

An instance of this class is provided to clients which implement IExporterIFC in order to provide an implementation for IFC export. It contains information on the options selected by the user for the export operation, as well as members used to access specific types of data needed to implement the export properly.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..ExporterIFC

See Also

ExporterIFC Members
Autodesk.Revit.DB.IFC Namespace


ExporterIFC Members

[image] [image]

Revit 2013 API
ExporterIFC Members
ExporterIFC Class Methods Properties See Also Send Feedback

The ExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | AddBuildingStorey | Adds building storey to the exporter's internal cache.
Public method | AddViewIdToExport | Adds a view to be exported to the exporter's internal cache.
Public method | Dispose | Releases all resources used by the ExporterIFC
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindSpaceBoundingElementHandle | Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.
Public method | FindSpatialElementHandle | Looks up the handle associated to the element id from the ExporterIFC's internal cache.
Public method | Get2DContextHandle | Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Get3DContextHandle | Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | GetBuilding | Gets the global IfcBuilding object.
Public method | GetFamilyName | Gets the name of the element assigned to the current export state.
Public method | GetFile | Gets the handle to the IFC file being created during this export operation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostObjects | Returns a collection containing the host object handles in the document.
Public method | GetLevelInfo | Returns an object representing the information about a level in the document.
Public method | GetLevelInfos | Returns a collection containing the information about all levels in the document.
Public method | GetMaterialIdForCurrentExportState | This gets the material id that is associated with the element in the current export state.
Public method | GetName | Gets the name of the element assigned to the current export state.
Public method | GetOptions | Gets the collection of named options set by the exporter client.
Public method | GetOrCreateFillPattern | Get (or create) the IfcFillPatternStyle associated with an ElementId.
Public method | GetOwnerHistoryHandle | Gets the handle to the IfcOwnerHistory for the file.
Public method | GetProject | Gets the global IfcProject object.
Public method | GetRelatedElements | Gets all elements not associated to stories.
Public method | GetRelatedProducts | Gets all products not associated to stories.
Public method | GetSite | Gets the global IfcSite object.
Public method | GetStairRampContainers | Returns all of the IFCStairContainmentInfos created, with the id of the associated Stairs or Ramp element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewIdsToExport | Returns the ids of the views to be exported.
Public method | PopExportState | Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.
Public method | PushExportState | Sets the internal state of the exporter to process the geometry and properties of the input element.
Public method | RegisterDoorWindowForOpeningUpdate | Registers information about a door or window with the ExporterIFC's internal cache so that an existing opening applied to wall elements will have its size updated based on the size of the instance.
Public method | RegisterDoorWindowForUncreatedOpening | Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.
Public method | RegisterShapeForPresentationLayer | Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.
Public method | RegisterSpaceBoundingElementHandle | Stores a handle representing a space bounding element to the ExporterIFC's internal cache.
Public method | RegisterSpatialElementHandle | Stores a handle representing a spatial element to the ExporterIFC's internal cache.
Public method | RelateSpatialElement | Relates the input element handle to the given spatial element.
Public method | RemoveBuildingStorey | Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.
Public method | Set2DContextHandle | Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Set3DContextHandle | Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | SetBuilding | Sets the global IfcBuilding object.
Public method | SetFile | Sets the handle to the IFC file being created during this export operation.
Public method | SetMaterialIdForCurrentExportState | This sets the material id that is to be associated with the element in the current export state.
Public method | SetOwnerHistoryHandle | Sets the handle to the IfcOwnerHistory for the file.
Public method | SetProject | Sets the global IfcProject object.
Public method | SetSite | Sets the global IfcSite object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExportAs2x2 | Identifies if the file version being exported is 2x2.
Public property | ExportAs2x3 | Identifies if the file version being exported is 2x3.
Public property | ExportBaseQuantities | Identifies if the export should include IFC standard quantities currently supported by Revit.
Public property | FileName |
Public property | FileVersion | Identifies the file version being exported.
Public property | LinearScale | The scale factor from feet to the display units of the document.
Public property | SpaceBoundaryLevel | Identifies the level of space boundaries being exported.
Public property | WallAndColumnSplitting | Identifies if division of multi-level walls and columns by levels should take place during this export.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFC Methods

[image] [image]

Revit 2013 API
ExporterIFC Methods
ExporterIFC Class See Also Send Feedback

The ExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | AddBuildingStorey | Adds building storey to the exporter's internal cache.
Public method | AddViewIdToExport | Adds a view to be exported to the exporter's internal cache.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindSpaceBoundingElementHandle | Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.
Public method | FindSpatialElementHandle | Looks up the handle associated to the element id from the ExporterIFC's internal cache.
Public method | Get2DContextHandle | Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Get3DContextHandle | Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | GetBuilding | Gets the global IfcBuilding object.
Public method | GetFamilyName | Gets the name of the element assigned to the current export state.
Public method | GetFile | Gets the handle to the IFC file being created during this export operation.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHostObjects | Returns a collection containing the host object handles in the document.
Public method | GetLevelInfo | Returns an object representing the information about a level in the document.
Public method | GetLevelInfos | Returns a collection containing the information about all levels in the document.
Public method | GetMaterialIdForCurrentExportState | This gets the material id that is associated with the element in the current export state.
Public method | GetName | Gets the name of the element assigned to the current export state.
Public method | GetOptions | Gets the collection of named options set by the exporter client.
Public method | GetOrCreateFillPattern | Get (or create) the IfcFillPatternStyle associated with an ElementId.
Public method | GetOwnerHistoryHandle | Gets the handle to the IfcOwnerHistory for the file.
Public method | GetProject | Gets the global IfcProject object.
Public method | GetRelatedElements | Gets all elements not associated to stories.
Public method | GetRelatedProducts | Gets all products not associated to stories.
Public method | GetSite | Gets the global IfcSite object.
Public method | GetStairRampContainers | Returns all of the IFCStairContainmentInfos created, with the id of the associated Stairs or Ramp element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetViewIdsToExport | Returns the ids of the views to be exported.
Public method | PopExportState | Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.
Public method | PushExportState | Sets the internal state of the exporter to process the geometry and properties of the input element.
Public method | RegisterDoorWindowForOpeningUpdate | Registers information about a door or window with the ExporterIFC's internal cache so that an existing opening applied to wall elements will have its size updated based on the size of the instance.
Public method | RegisterDoorWindowForUncreatedOpening | Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.
Public method | RegisterShapeForPresentationLayer | Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.
Public method | RegisterSpaceBoundingElementHandle | Stores a handle representing a space bounding element to the ExporterIFC's internal cache.
Public method | RegisterSpatialElementHandle | Stores a handle representing a spatial element to the ExporterIFC's internal cache.
Public method | RelateSpatialElement | Relates the input element handle to the given spatial element.
Public method | RemoveBuildingStorey | Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.
Public method | Set2DContextHandle | Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method | Set3DContextHandle | Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method | SetBuilding | Sets the global IfcBuilding object.
Public method | SetFile | Sets the handle to the IFC file being created during this export operation.
Public method | SetMaterialIdForCurrentExportState | This sets the material id that is to be associated with the element in the current export state.
Public method | SetOwnerHistoryHandle | Sets the handle to the IfcOwnerHistory for the file.
Public method | SetProject | Sets the global IfcProject object.
Public method | SetSite | Sets the global IfcSite object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


AddBuildingStorey Method

[image]

Revit 2013 API
ExporterIFC..::..AddBuildingStorey Method
ExporterIFC Class See Also Send Feedback
Adds building storey to the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddBuildingStorey(
    ElementId id,
    IFCLevelInfo levelInfo
)
Visual Basic
Public Sub AddBuildingStorey ( _
    id As ElementId, _
    levelInfo As IFCLevelInfo _
)
Visual C++
public:
void AddBuildingStorey(
    ElementId^ id,
    IFCLevelInfo^ levelInfo
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The level id.
levelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
The IFCLevelInfo object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


AddViewIdToExport Method

[image]

Revit 2013 API
ExporterIFC..::..AddViewIdToExport Method
ExporterIFC Class See Also Send Feedback
Adds a view to be exported to the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddViewIdToExport(
    ElementId viewId,
    ElementId levelId
)
Visual Basic
Public Sub AddViewIdToExport ( _
    viewId As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
void AddViewIdToExport(
    ElementId^ viewId,
    ElementId^ levelId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
ExporterIFC..::..Dispose Method
ExporterIFC Class See Also Send Feedback
Releases all resources used by the ExporterIFC

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


FindSpaceBoundingElementHandle Method

[image]

Revit 2013 API
ExporterIFC..::..FindSpaceBoundingElementHandle Method
ExporterIFC Class See Also Send Feedback
Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle FindSpaceBoundingElementHandle(
    ElementId id,
    ElementId levelId
)
Visual Basic
Public Function FindSpaceBoundingElementHandle ( _
    id As ElementId, _
    levelId As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ FindSpaceBoundingElementHandle(
    ElementId^ id,
    ElementId^ levelId
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The Revit element id to look for.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The element level id.

Return Value

The handle associated to the element and level id. If the id is not found in the cache, an empty handle is returned (HasValue == false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


FindSpatialElementHandle Method

[image]

Revit 2013 API
ExporterIFC..::..FindSpatialElementHandle Method
ExporterIFC Class See Also Send Feedback
Looks up the handle associated to the element id from the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle FindSpatialElementHandle(
    ElementId id
)
Visual Basic
Public Function FindSpatialElementHandle ( _
    id As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ FindSpatialElementHandle(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id to look for.

Return Value

The handle associated to the element id. If the id is not found in the cache, an empty handle is returned (HasValue == false).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


Get2DContextHandle Method

[image]

Revit 2013 API
ExporterIFC..::..Get2DContextHandle Method
ExporterIFC Class See Also Send Feedback
Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle Get2DContextHandle()
Visual Basic
Public Function Get2DContextHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ Get2DContextHandle()

Return Value

The IfcRepresentationContext.

Remarks

The context handle is automatically applied with a 1:100 scale.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


Get3DContextHandle Method

[image]

Revit 2013 API
ExporterIFC..::..Get3DContextHandle Method
ExporterIFC Class See Also Send Feedback
Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle Get3DContextHandle(
    string subContextName
)
Visual Basic
Public Function Get3DContextHandle ( _
    subContextName As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ Get3DContextHandle(
    String^ subContextName
)

Parameters

subContextName
Type: System..::..String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.

Return Value

The IfcRepresentationContext for 3D entities.

Remarks

The context handle automatically incorporates the angle to true north for the document.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetBuilding Method

[image]

Revit 2013 API
ExporterIFC..::..GetBuilding Method
ExporterIFC Class See Also Send Feedback
Gets the global IfcBuilding object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetBuilding()
Visual Basic
Public Function GetBuilding As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetBuilding()

Return Value

The handle.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetFamilyName Method

[image]

Revit 2013 API
ExporterIFC..::..GetFamilyName Method
ExporterIFC Class See Also Send Feedback
Gets the name of the element assigned to the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetFamilyName()
Visual Basic
Public Function GetFamilyName As String
Visual C++
public:
String^ GetFamilyName()

Return Value

The family name.

Remarks

The family name is prepared for use in IFC output during the call to PushExportState().

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetFile Method

[image]

Revit 2013 API
ExporterIFC..::..GetFile Method
ExporterIFC Class See Also Send Feedback
Gets the handle to the IFC file being created during this export operation.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCFile GetFile()
Visual Basic
Public Function GetFile As IFCFile
Visual C++
public:
IFCFile^ GetFile()

Return Value

The handle to the file.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetHostObjects Method

[image]

Revit 2013 API
ExporterIFC..::..GetHostObjects Method
ExporterIFC Class See Also Send Feedback
Returns a collection containing the host object handles in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IDictionary<ElementId, IFCAnyHandle>> GetHostObjects()
Visual Basic
Public Function GetHostObjects As IList(Of IDictionary(Of ElementId, IFCAnyHandle))
Visual C++
public:
IList<IDictionary<ElementId^, IFCAnyHandle^>^>^ GetHostObjects()

Return Value

The collection of host objects.

Remarks

Host object handles is currently collected by RegisterSpaceBoundingElementHandle and exporting internal element and cached in the ExporterIFC object. This method returns the cached information which is needed to create wall connectivity objects.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetLevelInfo Method

[image]

Revit 2013 API
ExporterIFC..::..GetLevelInfo Method
ExporterIFC Class See Also Send Feedback
Returns an object representing the information about a level in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCLevelInfo GetLevelInfo(
    ElementId levelId
)
Visual Basic
Public Function GetLevelInfo ( _
    levelId As ElementId _
) As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetLevelInfo(
    ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id.

Return Value

The level information.

Remarks

Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information for a given level, which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetLevelInfos Method

[image]

Revit 2013 API
ExporterIFC..::..GetLevelInfos Method
ExporterIFC Class See Also Send Feedback
Returns a collection containing the information about all levels in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IDictionary<ElementId, IFCLevelInfo> GetLevelInfos()
Visual Basic
Public Function GetLevelInfos As IDictionary(Of ElementId, IFCLevelInfo)
Visual C++
public:
IDictionary<ElementId^, IFCLevelInfo^>^ GetLevelInfos()

Return Value

The collection of level information.

Remarks

Level information is currently automatically collected and cached in the ExporterIFC object. This method returns the cached information which is often needed during export of particular building elements which reference levels, as well as to implement automatic wall and column splitting.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetMaterialIdForCurrentExportState Method

[image]

Revit 2013 API
ExporterIFC..::..GetMaterialIdForCurrentExportState Method
ExporterIFC Class See Also Send Feedback
This gets the material id that is associated with the element in the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetMaterialIdForCurrentExportState()
Visual Basic
Public Function GetMaterialIdForCurrentExportState As ElementId
Visual C++
public:
ElementId^ GetMaterialIdForCurrentExportState()

Return Value

The material id.

Remarks

Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetName Method

[image]

Revit 2013 API
ExporterIFC..::..GetName Method
ExporterIFC Class See Also Send Feedback
Gets the name of the element assigned to the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetName()
Visual Basic
Public Function GetName As String
Visual C++
public:
String^ GetName()

Return Value

The name.

Remarks

The name is prepared for use in IFC output during the call to PushExportState().

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetOptions Method

[image]

Revit 2013 API
ExporterIFC..::..GetOptions Method
ExporterIFC Class See Also Send Feedback
Gets the collection of named options set by the exporter client.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IDictionary<string, string> GetOptions()
Visual Basic
Public Function GetOptions As IDictionary(Of String, String)
Visual C++
public:
IDictionary<String^, String^>^ GetOptions()

Return Value

The collection of named options.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetOrCreateFillPattern Method

[image]

Revit 2013 API
ExporterIFC..::..GetOrCreateFillPattern Method
ExporterIFC Class See Also Send Feedback
Get (or create) the IfcFillPatternStyle associated with an ElementId.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetOrCreateFillPattern(
    ElementId fillPatternId,
    Color color,
    double planScale
)
Visual Basic
Public Function GetOrCreateFillPattern ( _
    fillPatternId As ElementId, _
    color As Color, _
    planScale As Double _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOrCreateFillPattern(
    ElementId^ fillPatternId,
    Color^ color,
    double planScale
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
The fill pattern id.
color
Type: Autodesk.Revit.DB..::..Color
The pattern color.
planScale
Type: System..::..Double
The view scale.

Return Value

The IfcSurfaceStyle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetOwnerHistoryHandle Method

[image]

Revit 2013 API
ExporterIFC..::..GetOwnerHistoryHandle Method
ExporterIFC Class See Also Send Feedback
Gets the handle to the IfcOwnerHistory for the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetOwnerHistoryHandle()
Visual Basic
Public Function GetOwnerHistoryHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOwnerHistoryHandle()

Return Value

The handle to the IfcOwnerHistory for the file.

Remarks

IfcOwnerHistory defines all history and identification related information. In order to provide fast access it is directly attached to all independent objects, relationships and properties. IfcOwnerHistory is used to identify the creating and owning application and user for the associated object, as well as capture the last modifying application and user. Currently in Revit export to IFC, there is one owner history for the entire file with some default (for the file) values.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetProject Method

[image]

Revit 2013 API
ExporterIFC..::..GetProject Method
ExporterIFC Class See Also Send Feedback
Gets the global IfcProject object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetProject()
Visual Basic
Public Function GetProject As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetProject()

Return Value

The handle.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetRelatedElements Method

[image]

Revit 2013 API
ExporterIFC..::..GetRelatedElements Method
ExporterIFC Class See Also Send Feedback
Gets all elements not associated to stories.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetRelatedElements()
Visual Basic
Public Function GetRelatedElements As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetRelatedElements()

Return Value

The collection of elements.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetRelatedProducts Method

[image]

Revit 2013 API
ExporterIFC..::..GetRelatedProducts Method
ExporterIFC Class See Also Send Feedback
Gets all products not associated to stories.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetRelatedProducts()
Visual Basic
Public Function GetRelatedProducts As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetRelatedProducts()

Return Value

The collection of products.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetSite Method

[image]

Revit 2013 API
ExporterIFC..::..GetSite Method
ExporterIFC Class See Also Send Feedback
Gets the global IfcSite object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetSite()
Visual Basic
Public Function GetSite As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetSite()

Return Value

The handle.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetStairRampContainers Method

[image]

Revit 2013 API
ExporterIFC..::..GetStairRampContainers Method
ExporterIFC Class See Also Send Feedback
Returns all of the IFCStairContainmentInfos created, with the id of the associated Stairs or Ramp element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IDictionary<ElementId, IFCStairRampContainerInfo> GetStairRampContainers()
Visual Basic
Public Function GetStairRampContainers As IDictionary(Of ElementId, IFCStairRampContainerInfo)
Visual C++
public:
IDictionary<ElementId^, IFCStairRampContainerInfo^>^ GetStairRampContainers()

Return Value

The collection of containers.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


GetViewIdsToExport Method

[image]

Revit 2013 API
ExporterIFC..::..GetViewIdsToExport Method
ExporterIFC Class See Also Send Feedback
Returns the ids of the views to be exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<ElementId> GetViewIdsToExport()
Visual Basic
Public Function GetViewIdsToExport As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetViewIdsToExport()

Return Value

The ids of the views to be exported.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


PopExportState Method

[image]

Revit 2013 API
ExporterIFC..::..PopExportState Method
ExporterIFC Class See Also Send Feedback
Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void PopExportState()
Visual Basic
Public Sub PopExportState
Visual C++
public:
void PopExportState()

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


PushExportState Method

[image]

Revit 2013 API
ExporterIFC..::..PushExportState Method
ExporterIFC Class See Also Send Feedback
Sets the internal state of the exporter to process the geometry and properties of the input element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void PushExportState(
    Element Elem,
    GeometryElement GRep
)
Visual Basic
Public Sub PushExportState ( _
    Elem As Element, _
    GRep As GeometryElement _
)
Visual C++
public:
void PushExportState(
    Element^ Elem,
    GeometryElement^ GRep
)

Parameters

Elem
Type: Autodesk.Revit.DB..::..Element
The element.
GRep
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

The element will be assigned until PopExportState() is called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RegisterDoorWindowForOpeningUpdate Method

[image]

Revit 2013 API
ExporterIFC..::..RegisterDoorWindowForOpeningUpdate Method
ExporterIFC Class See Also Send Feedback
Registers information about a door or window with the ExporterIFC's internal cache so that an existing opening applied to wall elements will have its size updated based on the size of the instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterDoorWindowForOpeningUpdate(
    IFCDoorWindowInfo info
)
Visual Basic
Public Sub RegisterDoorWindowForOpeningUpdate ( _
    info As IFCDoorWindowInfo _
)
Visual C++
public:
void RegisterDoorWindowForOpeningUpdate(
    IFCDoorWindowInfo^ info
)

Parameters

info
Type: Autodesk.Revit.DB.IFC..::..IFCDoorWindowInfo
The door or window info handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RegisterDoorWindowForUncreatedOpening Method

[image]

Revit 2013 API
ExporterIFC..::..RegisterDoorWindowForUncreatedOpening Method
ExporterIFC Class See Also Send Feedback
Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterDoorWindowForUncreatedOpening(
    ElementId familyInstanceId,
    IFCAnyHandle instanceHandle
)
Visual Basic
Public Sub RegisterDoorWindowForUncreatedOpening ( _
    familyInstanceId As ElementId, _
    instanceHandle As IFCAnyHandle _
)
Visual C++
public:
void RegisterDoorWindowForUncreatedOpening(
    ElementId^ familyInstanceId,
    IFCAnyHandle^ instanceHandle
)

Parameters

familyInstanceId
Type: Autodesk.Revit.DB..::..ElementId
The id of the door or window.
instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle to the IfcDoor or IfcWindow created for this instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RegisterShapeForPresentationLayer Method

[image]

Revit 2013 API
ExporterIFC..::..RegisterShapeForPresentationLayer Method
ExporterIFC Class See Also Send Feedback
Sets an IfcShapeRepresentation to be used for the IfcPresentationLayerAssignment associated with the given Revit category and element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterShapeForPresentationLayer(
    Element pElement,
    ElementId categoryId,
    IFCAnyHandle newShapeRepresentation
)
Visual Basic
Public Sub RegisterShapeForPresentationLayer ( _
    pElement As Element, _
    categoryId As ElementId, _
    newShapeRepresentation As IFCAnyHandle _
)
Visual C++
public:
void RegisterShapeForPresentationLayer(
    Element^ pElement,
    ElementId^ categoryId,
    IFCAnyHandle^ newShapeRepresentation
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.
categoryId
Type: Autodesk.Revit.DB..::..ElementId
The category id.
newShapeRepresentation
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcShapeRepresentation handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RegisterSpaceBoundingElementHandle Method

[image]

Revit 2013 API
ExporterIFC..::..RegisterSpaceBoundingElementHandle Method
ExporterIFC Class See Also Send Feedback
Stores a handle representing a space bounding element to the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterSpaceBoundingElementHandle(
    IFCAnyHandle instanceHandle,
    ElementId id,
    ElementId levelId
)
Visual Basic
Public Sub RegisterSpaceBoundingElementHandle ( _
    instanceHandle As IFCAnyHandle, _
    id As ElementId, _
    levelId As ElementId _
)
Visual C++
public:
void RegisterSpaceBoundingElementHandle(
    IFCAnyHandle^ instanceHandle,
    ElementId^ id,
    ElementId^ levelId
)

Parameters

instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle to the space bounding element.
id
Type: Autodesk.Revit.DB..::..ElementId
The Revit element id associated to this handle.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id assigned to the space bounding object.

Remarks

The cache of space bounding elements will be used during completion of export to create relationship objects such as IfcRelSpaceBoundary and IfcRelConnectsPathElements. The types of Revit elements accepted by this function are:
  • Walls
  • Curtain walls
  • Roofs
  • Floors
  • Doors
  • Windows

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RegisterSpatialElementHandle Method

[image]

Revit 2013 API
ExporterIFC..::..RegisterSpatialElementHandle Method
ExporterIFC Class See Also Send Feedback
Stores a handle representing a spatial element to the ExporterIFC's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RegisterSpatialElementHandle(
    ElementId id,
    IFCAnyHandle hnd
)
Visual Basic
Public Sub RegisterSpatialElementHandle ( _
    id As ElementId, _
    hnd As IFCAnyHandle _
)
Visual C++
public:
void RegisterSpatialElementHandle(
    ElementId^ id,
    IFCAnyHandle^ hnd
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id.
hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle representing the spatial element.

Remarks

The cache of spatial elements will be used in UpdateRoomRelativeCoordinates and during completion of export to create relationship objects such as IfcRelContainedInSpatialStructure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RelateSpatialElement Method

[image]

Revit 2013 API
ExporterIFC..::..RelateSpatialElement Method
ExporterIFC Class See Also Send Feedback
Relates the input element handle to the given spatial element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RelateSpatialElement(
    ElementId roomId,
    IFCAnyHandle elemHnd
)
Visual Basic
Public Sub RelateSpatialElement ( _
    roomId As ElementId, _
    elemHnd As IFCAnyHandle _
)
Visual C++
public:
void RelateSpatialElement(
    ElementId^ roomId,
    IFCAnyHandle^ elemHnd
)

Parameters

roomId
Type: Autodesk.Revit.DB..::..ElementId
The spatial element id, which must have been registered with RegisterSpatialElementHandle().
elemHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The element handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


RemoveBuildingStorey Method

[image]

Revit 2013 API
ExporterIFC..::..RemoveBuildingStorey Method
ExporterIFC Class See Also Send Feedback
Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveBuildingStorey(
    ElementId id
)
Visual Basic
Public Sub RemoveBuildingStorey ( _
    id As ElementId _
)
Visual C++
public:
void RemoveBuildingStorey(
    ElementId^ id
)

Parameters

id
Type: Autodesk.Revit.DB..::..ElementId
The level id.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


Set2DContextHandle Method

[image]

Revit 2013 API
ExporterIFC..::..Set2DContextHandle Method
ExporterIFC Class See Also Send Feedback
Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Set2DContextHandle(
    IFCAnyHandle contextHandle
)
Visual Basic
Public Sub Set2DContextHandle ( _
    contextHandle As IFCAnyHandle _
)
Visual C++
public:
void Set2DContextHandle(
    IFCAnyHandle^ contextHandle
)

Parameters

contextHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcRepresentationContext.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


Set3DContextHandle Method

[image]

Revit 2013 API
ExporterIFC..::..Set3DContextHandle Method
ExporterIFC Class See Also Send Feedback
Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Set3DContextHandle(
    IFCAnyHandle contextHandle,
    string subContextName
)
Visual Basic
Public Sub Set3DContextHandle ( _
    contextHandle As IFCAnyHandle, _
    subContextName As String _
)
Visual C++
public:
void Set3DContextHandle(
    IFCAnyHandle^ contextHandle,
    String^ subContextName
)

Parameters

contextHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcRepresentationContext for 3D entities.
subContextName
Type: System..::..String
The name of the IfcRepresentationSubContext, or the IfcRepresentationContext if the string is empty, for 3D entities.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetBuilding Method

[image]

Revit 2013 API
ExporterIFC..::..SetBuilding Method
ExporterIFC Class See Also Send Feedback
Sets the global IfcBuilding object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetBuilding(
    IFCAnyHandle building
)
Visual Basic
Public Sub SetBuilding ( _
    building As IFCAnyHandle _
)
Visual C++
public:
void SetBuilding(
    IFCAnyHandle^ building
)

Parameters

building
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcBuilding handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetFile Method

[image]

Revit 2013 API
ExporterIFC..::..SetFile Method
ExporterIFC Class See Also Send Feedback
Sets the handle to the IFC file being created during this export operation.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetFile(
    IFCFile file
)
Visual Basic
Public Sub SetFile ( _
    file As IFCFile _
)
Visual C++
public:
void SetFile(
    IFCFile^ file
)

Parameters

file
Type: Autodesk.Revit.DB.IFC..::..IFCFile
The handle to the file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetMaterialIdForCurrentExportState Method

[image]

Revit 2013 API
ExporterIFC..::..SetMaterialIdForCurrentExportState Method
ExporterIFC Class See Also Send Feedback
This sets the material id that is to be associated with the element in the current export state.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetMaterialIdForCurrentExportState(
    ElementId elementId
)
Visual Basic
Public Sub SetMaterialIdForCurrentExportState ( _
    elementId As ElementId _
)
Visual C++
public:
void SetMaterialIdForCurrentExportState(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
The material id.

Remarks

Even though there could be several materials associated with the element (set during PushExportState()), unless the element has support for IfcMaterialLayerSet, IFC output will include only this one.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetOwnerHistoryHandle Method

[image]

Revit 2013 API
ExporterIFC..::..SetOwnerHistoryHandle Method
ExporterIFC Class See Also Send Feedback
Sets the handle to the IfcOwnerHistory for the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetOwnerHistoryHandle(
    IFCAnyHandle ownerHistory
)
Visual Basic
Public Sub SetOwnerHistoryHandle ( _
    ownerHistory As IFCAnyHandle _
)
Visual C++
public:
void SetOwnerHistoryHandle(
    IFCAnyHandle^ ownerHistory
)

Parameters

ownerHistory
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetProject Method

[image]

Revit 2013 API
ExporterIFC..::..SetProject Method
ExporterIFC Class See Also Send Feedback
Sets the global IfcProject object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetProject(
    IFCAnyHandle proj
)
Visual Basic
Public Sub SetProject ( _
    proj As IFCAnyHandle _
)
Visual C++
public:
void SetProject(
    IFCAnyHandle^ proj
)

Parameters

proj
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcProject handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SetSite Method

[image]

Revit 2013 API
ExporterIFC..::..SetSite Method
ExporterIFC Class See Also Send Feedback
Sets the global IfcSite object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSite(
    IFCAnyHandle site
)
Visual Basic
Public Sub SetSite ( _
    site As IFCAnyHandle _
)
Visual C++
public:
void SetSite(
    IFCAnyHandle^ site
)

Parameters

site
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcSite handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFC Properties

[image] [image]

Revit 2013 API
ExporterIFC Properties
ExporterIFC Class See Also Send Feedback

The ExporterIFC type exposes the following members.

Properties

 | Name | Description
Public property | ExportAs2x2 | Identifies if the file version being exported is 2x2.
Public property | ExportAs2x3 | Identifies if the file version being exported is 2x3.
Public property | ExportBaseQuantities | Identifies if the export should include IFC standard quantities currently supported by Revit.
Public property | FileName |
Public property | FileVersion | Identifies the file version being exported.
Public property | LinearScale | The scale factor from feet to the display units of the document.
Public property | SpaceBoundaryLevel | Identifies the level of space boundaries being exported.
Public property | WallAndColumnSplitting | Identifies if division of multi-level walls and columns by levels should take place during this export.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExportAs2x2 Property

[image]

Revit 2013 API
ExporterIFC..::..ExportAs2x2 Property
ExporterIFC Class See Also Send Feedback
Identifies if the file version being exported is 2x2.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportAs2x2 { get; }
Visual Basic
Public ReadOnly Property ExportAs2x2 As Boolean
    Get
Visual C++
public:
property bool ExportAs2x2 {
    bool get ();
}

Remarks

Returns true even for alternative formats equivalent to 2x2, such as BCA.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExportAs2x3 Property

[image]

Revit 2013 API
ExporterIFC..::..ExportAs2x3 Property
ExporterIFC Class See Also Send Feedback
Identifies if the file version being exported is 2x3.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportAs2x3 { get; }
Visual Basic
Public ReadOnly Property ExportAs2x3 As Boolean
    Get
Visual C++
public:
property bool ExportAs2x3 {
    bool get ();
}

Remarks

Returns true even for alternative formats equivalent to 2x3, such as COBIE.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExportBaseQuantities Property

[image]

Revit 2013 API
ExporterIFC..::..ExportBaseQuantities Property
ExporterIFC Class See Also Send Feedback
Identifies if the export should include IFC standard quantities currently supported by Revit.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ExportBaseQuantities { get; }
Visual Basic
Public ReadOnly Property ExportBaseQuantities As Boolean
    Get
Visual C++
public:
property bool ExportBaseQuantities {
    bool get ();
}

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


FileName Property

[image]

Revit 2013 API
ExporterIFC..::..FileName Property
ExporterIFC Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


FileVersion Property

[image]

Revit 2013 API
ExporterIFC..::..FileVersion Property
ExporterIFC Class See Also Send Feedback
Identifies the file version being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCVersion FileVersion { get; }
Visual Basic
Public ReadOnly Property FileVersion As IFCVersion
    Get
Visual C++
public:
property IFCVersion FileVersion {
    IFCVersion get ();
}

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


LinearScale Property

[image]

Revit 2013 API
ExporterIFC..::..LinearScale Property
ExporterIFC Class See Also Send Feedback
The scale factor from feet to the display units of the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double LinearScale { get; set; }
Visual Basic
Public Property LinearScale As Double
    Get
    Set
Visual C++
public:
property double LinearScale {
    double get ();
    void set (double value);
}

Remarks

During IFC export the output is expected to be in the display units of the document. Most length distances must be scaled accordingly by this scale factor.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


SpaceBoundaryLevel Property

[image]

Revit 2013 API
ExporterIFC..::..SpaceBoundaryLevel Property
ExporterIFC Class See Also Send Feedback
Identifies the level of space boundaries being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int SpaceBoundaryLevel { get; }
Visual Basic
Public ReadOnly Property SpaceBoundaryLevel As Integer
    Get
Visual C++
public:
property int SpaceBoundaryLevel {
    int get ();
}

Remarks

There are three valid values for this integer:
0 = export no space boundaries.  This can save space if the receiving application doesn't use them.
1 = export 1st level space boundaries.  This is the default.
2 = export 2nd level space boundaries.  This is primarily for use in energy analysis programs, and the GSA.

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


WallAndColumnSplitting Property

[image]

Revit 2013 API
ExporterIFC..::..WallAndColumnSplitting Property
ExporterIFC Class See Also Send Feedback
Identifies if division of multi-level walls and columns by levels should take place during this export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool WallAndColumnSplitting { get; }
Visual Basic
Public ReadOnly Property WallAndColumnSplitting As Boolean
    Get
Visual C++
public:
property bool WallAndColumnSplitting {
    bool get ();
}

See Also

ExporterIFC Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFCRegistry Class

[image]

Revit 2013 API
ExporterIFCRegistry Class
Members See Also Send Feedback
Application level singleton that stores registered IFC exporters.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExporterIFCRegistry : IDisposable
Visual Basic
Public Class ExporterIFCRegistry _
    Implements IDisposable
Visual C++
public ref class ExporterIFCRegistry : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..ExporterIFCRegistry

See Also

ExporterIFCRegistry Members
Autodesk.Revit.DB.IFC Namespace


ExporterIFCRegistry Members

[image] [image]

Revit 2013 API
ExporterIFCRegistry Members
ExporterIFCRegistry Class Methods See Also Send Feedback

The ExporterIFCRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ExporterIFCRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsIFCExporterRegistered | Check if there is already an IFC exporter registered on the application-level.
 | RegisterIFCExporter | Registers an IFC Exporter with the Revit application.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFCRegistry Methods

[image] [image]

Revit 2013 API
ExporterIFCRegistry Methods
ExporterIFCRegistry Class See Also Send Feedback

The ExporterIFCRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsIFCExporterRegistered | Check if there is already an IFC exporter registered on the application-level.
 | RegisterIFCExporter | Registers an IFC Exporter with the Revit application.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
ExporterIFCRegistry..::..Dispose Method
ExporterIFCRegistry Class See Also Send Feedback
Releases all resources used by the ExporterIFCRegistry

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace


IsIFCExporterRegistered Method

[image]

Revit 2013 API
ExporterIFCRegistry..::..IsIFCExporterRegistered Method
ExporterIFCRegistry Class See Also Send Feedback
Check if there is already an IFC exporter registered on the application-level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsIFCExporterRegistered()
Visual Basic
Public Shared Function IsIFCExporterRegistered As Boolean
Visual C++
public:
static bool IsIFCExporterRegistered()

Return Value

True if there is already an IFC exporter registered on the application-level, false otherwise. current session.

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace


RegisterIFCExporter Method

[image]

Revit 2013 API
ExporterIFCRegistry..::..RegisterIFCExporter Method
ExporterIFCRegistry Class See Also Send Feedback
Registers an IFC Exporter with the Revit application.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RegisterIFCExporter(
    IExporterIFC exporter
)
Visual Basic
Public Shared Sub RegisterIFCExporter ( _
    exporter As IExporterIFC _
)
Visual C++
public:
static void RegisterIFCExporter(
    IExporterIFC^ exporter
)

Parameters

exporter
Type: Autodesk.Revit.DB.IFC..::..IExporterIFC
Exporter to be registered

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is already an IFC exporter registered on the application-level. Only one exporter can be registered in a given session of Revit. Check the journal file for the path of the DLL which was successfully registered as the IFC exporter for the session.

See Also

ExporterIFCRegistry Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFCUtils Class

[image]

Revit 2013 API
ExporterIFCUtils Class
Members See Also Send Feedback
A class that contains utilities needed to implement Revit's version of the IFC export client application.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class ExporterIFCUtils : IDisposable
Visual Basic
Public Class ExporterIFCUtils _
    Implements IDisposable
Visual C++
public ref class ExporterIFCUtils : IDisposable

Remarks

This class contains special API utilities needed to enable the implementation of the client application for IFC export. Some of these utilities will be needed temporarily while the code for IFC export is migrated into the export client. These temporary interfaces are likely to change in upcoming Revit releases.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..ExporterIFCUtils

See Also

ExporterIFCUtils Members
Autodesk.Revit.DB.IFC Namespace


ExporterIFCUtils Members

[image] [image]

Revit 2013 API
ExporterIFCUtils Members
ExporterIFCUtils Class Methods See Also Send Feedback

The ExporterIFCUtils type exposes the following members.

Methods

 | Name | Description
 | AddClippingsToBaseExtrusion | Processes the geometry of the wall to create an extruded area solid representing the geometry of the wall (including any clippings imposed by neighboring elements).
 | AddOpeningsToElement | Adds the openings from the element as separate IfcElements related to the element.
 | AddValueString | Adds a string value to a built-in parameter.
 | AreSolidsEqual | Determines whether two solids are identical, potentially offset from each other.
 | CanExportWallGeometryAsExtrusion | Identifies if the base geometry of the wall can be represented as an extrusion.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | ComputeAreaOfCurveLoops | Computes total area of the list of curve loops. If the area cannot be calculated, returns 0.0.
 | ComputeRoofProjectedArea | Returns the projected area of the room, unscaled.
 | ConvertUnits | Converts a value from universal units to display units.
 | CreateAlternateGUID | Creates a GUID for the given element.
 | CreateBeamColumnBaseQuantities | Creates the beam and column base quantities and adds them to the export.
 | CreateColumnPropertySet | Adds the column-specific property set to the export.
 | CreateCoveringPropertySet | Adds the covering-specific property set to the export.
 | CreateCurtainWallPropertySet | Adds the curtain wall-specific property set to the export.
 | CreateCurveFromCurveLoop | Creates an IFCCurve from a Curve Loop, projected onto a plane.
 | CreateDoorPropertySet | Adds the door-specific property set to the export.
 | CreateDoorWindowBaseQuantities | Creates the door or window base quantities and adds them to the export.
 | CreateExtrudedSurfaceFromCurve | Creates an IfcConnectionGeometry handle from the extrusion of a curve into a surface.
 | CreateGUID()()()() | Creates a randomized GUID.
 | CreateGUID(Element) | Creates a GUID for the given element.
 | CreateNonCOBIERoomQuantities | Creates the non-COBIE spatial element quantities and adds them to the export.
 | CreateOpeningQuantities | Creates the opening quantities and adds them to the export.
 | CreatePreCOBIEGSAQuantities | Creates the spatial element quantities required by GSA before COBIE and adds them to the export.
 | CreateProjectLevelGUID | Creates a GUID from Revit project for given GUIDType.
 | CreateSubElementGUID | Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.
 | CreateWallBaseQuantities | Creates the wall base quantities and adds them to the export.
 | CreateWindowPropertySet | Adds the window-specific property set to the export.
Public method | Dispose | Releases all resources used by the ExporterIFCUtils
 | EndExportInternal | Use the internal Revit implementation to relate elements at the end of export.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportExtrudedSlabOpenings |
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportLegacyStairsAsContainer | Adds data from a legacy staircase to the export.
 | ExportRampAsContainer | Adds data from a ramp to the export.
 | ExportRoofAsContainer | Exports a roof as a container of multiple roof slabs. Returns the handle, if successful.
 | ExportSlabAsExtrusion |
 | GetAttachedColumns | Obtains a list of columns known to Revit as intersecting with this wall.
 | GetConnectedWalls | Obtains the IFC-specific information regarding the connections between this wall and other elements.
 | GetElevationProfile | Obtains the curve loops which bound the wall's elevation profile.
 | GetFamilyName | Gets the family name of an ElementType.
 | GetGeometryFromInplaceWall | Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
 | GetGlobal2DDirectionHandles | Obtains the handles representing the cardinal directions in 2D.
 | GetGlobal2DOriginHandle | Obtains the handle representing the 2D origin.
 | GetGlobal3DDirectionHandles | Obtains the handles representing the cardinal directions in 3D.
 | GetGlobal3DOriginHandle | Obtains the handle representing the 3D origin.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIFCClassName | Obtains the IFC class name associated to the given element for the current export.
 | GetIFCClassNameByCategory | Obtains the IFC class name associated to a given category id for the current export.
 | GetIFCType | Obtains the IFC type associated to the given element for the current export.
 | GetLegacyCurtainSubElements | Gets the sub elements from a legacy curtain element.
 | GetLegacyStairOrRampComponents | Gets the components of a stair or ramp.
 | GetLegacyStairsProperties | Returns one or more properties for legacy (created in R2012 or before) Stairs.
 | GetLoopsFromTopBottomFace | Gets the curve loop(s) that represent the bottom or top face of the wall.
 | GetMinSymbolHeight | Obtains the minimum height of the given FamilySymbol.
 | GetMinSymbolWidth | Obtains the minimum width of the given FamilySymbol.
 | GetNumBuildingStoreys | Returns the number of non-empty, non-duplicate building stories in the file.
 | GetOriginalSymbol | Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
 | GetRebarGeometry | Generates the geometry for a Rebar for a specific view. The filter view is allowed to be null, but no geometry will be generated if it is.
 | GetRelativeLocalPlacementOffsetTransform | Obtains the relative transform between two IfcLocalPlacement handles.
 | GetRoomBoundaryAsCurveLoopArray | Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
 | GetSpatialElementBoundaryOptions | Obtains the SpatialElementBoundaryOptions needed for IFC export.
 | GetTransformForDoorOrWindow | Obtains the transform for the door or window instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUnscaledTransform | Obtains the unscaled transform from an IfcLocalPlacement handle.
 | GetWallBaseOffset | Obtains the base offset of the wall.
 | GetWallHeightDirection |
 | GetWallTrimmedCurve | Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.
 | HasElevationProfile | Identifies if the wall has a sketched elevation profile.
 | IsCurveFromOtherElementSketch | Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.
 | IsCurveLoopConvexWithOpenings | Checks if the region bounded by the input curve loop can be represented as the subtraction of 0 or more convex polygons from a base convex polygon.
 | IsWallBaseRectangular | Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
 | IsWallCompletelyClipped | Determines if the input wall is completely removed by interaction with other elements within the given range.
 | IsWallJoinedToTop | Checks if wall is joined to top.
 | SetGlobal2DDirectionHandles | Sets the handles representing the cardinal directions in 2D.
 | SetGlobal2DOriginHandle | Sets the handle representing the 2D origin.
 | SetGlobal3DDirectionHandles | Sets the handles representing the cardinal directions in 3D.
 | SetGlobal3DOriginHandle | Sets the handle representing the 3D origin.
 | SortCurveLoops | Sorts a set of curve loops such that outer and inner loops are separated.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformAndScalePoint | Converts a point from global Revit coordinates to current IFC coordinates, including scale.
 | TransformAndScaleVector | Converts a vector from global Revit coordinates to current IFC coordinates, including scale.
 | UpdateBuildingPlacement | Update building local placement to be to site local placement.
 | UsesInstanceGeometry | Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
 | ValidateCurveLoops | Does validity checks on a list of curve loops to ensure that they are all co-planar, closed, and properly oriented.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExporterIFCUtils Methods

[image] [image]

Revit 2013 API
ExporterIFCUtils Methods
ExporterIFCUtils Class See Also Send Feedback

The ExporterIFCUtils type exposes the following members.

Methods

 | Name | Description
 | AddClippingsToBaseExtrusion | Processes the geometry of the wall to create an extruded area solid representing the geometry of the wall (including any clippings imposed by neighboring elements).
 | AddOpeningsToElement | Adds the openings from the element as separate IfcElements related to the element.
 | AddValueString | Adds a string value to a built-in parameter.
 | AreSolidsEqual | Determines whether two solids are identical, potentially offset from each other.
 | CanExportWallGeometryAsExtrusion | Identifies if the base geometry of the wall can be represented as an extrusion.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
 | ComputeAreaOfCurveLoops | Computes total area of the list of curve loops. If the area cannot be calculated, returns 0.0.
 | ComputeRoofProjectedArea | Returns the projected area of the room, unscaled.
 | ConvertUnits | Converts a value from universal units to display units.
 | CreateAlternateGUID | Creates a GUID for the given element.
 | CreateBeamColumnBaseQuantities | Creates the beam and column base quantities and adds them to the export.
 | CreateColumnPropertySet | Adds the column-specific property set to the export.
 | CreateCoveringPropertySet | Adds the covering-specific property set to the export.
 | CreateCurtainWallPropertySet | Adds the curtain wall-specific property set to the export.
 | CreateCurveFromCurveLoop | Creates an IFCCurve from a Curve Loop, projected onto a plane.
 | CreateDoorPropertySet | Adds the door-specific property set to the export.
 | CreateDoorWindowBaseQuantities | Creates the door or window base quantities and adds them to the export.
 | CreateExtrudedSurfaceFromCurve | Creates an IfcConnectionGeometry handle from the extrusion of a curve into a surface.
 | CreateGUID()()()() | Creates a randomized GUID.
 | CreateGUID(Element) | Creates a GUID for the given element.
 | CreateNonCOBIERoomQuantities | Creates the non-COBIE spatial element quantities and adds them to the export.
 | CreateOpeningQuantities | Creates the opening quantities and adds them to the export.
 | CreatePreCOBIEGSAQuantities | Creates the spatial element quantities required by GSA before COBIE and adds them to the export.
 | CreateProjectLevelGUID | Creates a GUID from Revit project for given GUIDType.
 | CreateSubElementGUID | Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.
 | CreateWallBaseQuantities | Creates the wall base quantities and adds them to the export.
 | CreateWindowPropertySet | Adds the window-specific property set to the export.
Public method | Dispose |
 | EndExportInternal | Use the internal Revit implementation to relate elements at the end of export.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportExtrudedSlabOpenings |
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
 | ExportLegacyStairsAsContainer | Adds data from a legacy staircase to the export.
 | ExportRampAsContainer | Adds data from a ramp to the export.
 | ExportRoofAsContainer | Exports a roof as a container of multiple roof slabs. Returns the handle, if successful.
 | ExportSlabAsExtrusion |
 | GetAttachedColumns | Obtains a list of columns known to Revit as intersecting with this wall.
 | GetConnectedWalls | Obtains the IFC-specific information regarding the connections between this wall and other elements.
 | GetElevationProfile | Obtains the curve loops which bound the wall's elevation profile.
 | GetFamilyName | Gets the family name of an ElementType.
 | GetGeometryFromInplaceWall | Obtains a special snapshot of the geometry of an in-place wall element suitable for export.
 | GetGlobal2DDirectionHandles | Obtains the handles representing the cardinal directions in 2D.
 | GetGlobal2DOriginHandle | Obtains the handle representing the 2D origin.
 | GetGlobal3DDirectionHandles | Obtains the handles representing the cardinal directions in 3D.
 | GetGlobal3DOriginHandle | Obtains the handle representing the 3D origin.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetIFCClassName | Obtains the IFC class name associated to the given element for the current export.
 | GetIFCClassNameByCategory | Obtains the IFC class name associated to a given category id for the current export.
 | GetIFCType | Obtains the IFC type associated to the given element for the current export.
 | GetLegacyCurtainSubElements | Gets the sub elements from a legacy curtain element.
 | GetLegacyStairOrRampComponents | Gets the components of a stair or ramp.
 | GetLegacyStairsProperties | Returns one or more properties for legacy (created in R2012 or before) Stairs.
 | GetLoopsFromTopBottomFace | Gets the curve loop(s) that represent the bottom or top face of the wall.
 | GetMinSymbolHeight | Obtains the minimum height of the given FamilySymbol.
 | GetMinSymbolWidth | Obtains the minimum width of the given FamilySymbol.
 | GetNumBuildingStoreys | Returns the number of non-empty, non-duplicate building stories in the file.
 | GetOriginalSymbol | Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.
 | GetRebarGeometry | Generates the geometry for a Rebar for a specific view. The filter view is allowed to be null, but no geometry will be generated if it is.
 | GetRelativeLocalPlacementOffsetTransform | Obtains the relative transform between two IfcLocalPlacement handles.
 | GetRoomBoundaryAsCurveLoopArray | Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
 | GetSpatialElementBoundaryOptions | Obtains the SpatialElementBoundaryOptions needed for IFC export.
 | GetTransformForDoorOrWindow | Obtains the transform for the door or window instance.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetUnscaledTransform | Obtains the unscaled transform from an IfcLocalPlacement handle.
 | GetWallBaseOffset | Obtains the base offset of the wall.
 | GetWallHeightDirection |
 | GetWallTrimmedCurve | Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.
 | HasElevationProfile | Identifies if the wall has a sketched elevation profile.
 | IsCurveFromOtherElementSketch | Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.
 | IsCurveLoopConvexWithOpenings | Checks if the region bounded by the input curve loop can be represented as the subtraction of 0 or more convex polygons from a base convex polygon.
 | IsWallBaseRectangular | Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
 | IsWallCompletelyClipped | Determines if the input wall is completely removed by interaction with other elements within the given range.
 | IsWallJoinedToTop | Checks if wall is joined to top.
 | SetGlobal2DDirectionHandles | Sets the handles representing the cardinal directions in 2D.
 | SetGlobal2DOriginHandle | Sets the handle representing the 2D origin.
 | SetGlobal3DDirectionHandles | Sets the handles representing the cardinal directions in 3D.
 | SetGlobal3DOriginHandle | Sets the handle representing the 3D origin.
 | SortCurveLoops | Sorts a set of curve loops such that outer and inner loops are separated.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | TransformAndScalePoint | Converts a point from global Revit coordinates to current IFC coordinates, including scale.
 | TransformAndScaleVector | Converts a vector from global Revit coordinates to current IFC coordinates, including scale.
 | UpdateBuildingPlacement | Update building local placement to be to site local placement.
 | UsesInstanceGeometry | Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.
 | ValidateCurveLoops | Does validity checks on a list of curve loops to ensure that they are all co-planar, closed, and properly oriented.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


AddClippingsToBaseExtrusion Method

[image]

Revit 2013 API
ExporterIFCUtils..::..AddClippingsToBaseExtrusion Method
ExporterIFCUtils Class See Also Send Feedback
Processes the geometry of the wall to create an extruded area solid representing the geometry of the wall (including any clippings imposed by neighboring elements).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle AddClippingsToBaseExtrusion(
    ExporterIFC exporterIFC,
    Wall wall,
    XYZ setterOffset,
    IFCRange range,
    IFCRange zSpan,
    IFCAnyHandle baseBodyItemHandle,
    out IList<IFCExtrusionData> pCutPairOpenings
)
Visual Basic
Public Shared Function AddClippingsToBaseExtrusion ( _
    exporterIFC As ExporterIFC, _
    wall As Wall, _
    setterOffset As XYZ, _
    range As IFCRange, _
    zSpan As IFCRange, _
    baseBodyItemHandle As IFCAnyHandle, _
    <OutAttribute> ByRef pCutPairOpenings As IList(Of IFCExtrusionData) _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ AddClippingsToBaseExtrusion(
    ExporterIFC^ exporterIFC,
    Wall^ wall,
    XYZ^ setterOffset,
    IFCRange^ range,
    IFCRange^ zSpan,
    IFCAnyHandle^ baseBodyItemHandle,
    [OutAttribute] IList<IFCExtrusionData^>^% pCutPairOpenings
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wall
Type: Autodesk.Revit.DB..::..Wall
The wall.
setterOffset
Type: Autodesk.Revit.DB..::..XYZ
The offset from the placement setter.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.
zSpan
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The overall span in Z of the wall.
baseBodyItemHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcExtrudedAreaSolid handle generated initially for the wall.
pCutPairOpenings
Type: System.Collections.Generic..::..IList<(Of <(<'IFCExtrusionData>)>)>%
A collection of extruded openings that can be derived from the wall geometry.

Return Value

IfcEtxtrudedAreaSolid handle. This may be the same handle as was input, or a modified handle derived from the clipping geometry. If the function fails this handle will have no value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


AddOpeningsToElement Method

[image]

Revit 2013 API
ExporterIFCUtils..::..AddOpeningsToElement Method
ExporterIFCUtils Class See Also Send Feedback
Adds the openings from the element as separate IfcElements related to the element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void AddOpeningsToElement(
    ExporterIFC exporterIFC,
    IFCAnyHandle elementHandle,
    Element element,
    double scaledWidth,
    IFCRange range,
    IFCPlacementSetter setter,
    IFCAnyHandle localPlacement,
    IFCProductWrapper localWrapper
)
Visual Basic
Public Shared Sub AddOpeningsToElement ( _
    exporterIFC As ExporterIFC, _
    elementHandle As IFCAnyHandle, _
    element As Element, _
    scaledWidth As Double, _
    range As IFCRange, _
    setter As IFCPlacementSetter, _
    localPlacement As IFCAnyHandle, _
    localWrapper As IFCProductWrapper _
)
Visual C++
public:
static void AddOpeningsToElement(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ elementHandle,
    Element^ element,
    double scaledWidth,
    IFCRange^ range,
    IFCPlacementSetter^ setter,
    IFCAnyHandle^ localPlacement,
    IFCProductWrapper^ localWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The element handle.
element
Type: Autodesk.Revit.DB..::..Element
The element.
scaledWidth
Type: System..::..Double
The width of the element, scaled in the units of export.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire element is used.
setter
Type: Autodesk.Revit.DB.IFC..::..IFCPlacementSetter
The placement setter.
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The local placement for the element.
localWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


AddValueString Method

[image]

Revit 2013 API
ExporterIFCUtils..::..AddValueString Method
ExporterIFCUtils Class See Also Send Feedback
Adds a string value to a built-in parameter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AddValueString(
    Element element,
    ElementId builtInParameter,
    string propertyValue
)
Visual Basic
Public Shared Sub AddValueString ( _
    element As Element, _
    builtInParameter As ElementId, _
    propertyValue As String _
)
Visual C++
public:
static void AddValueString(
    Element^ element,
    ElementId^ builtInParameter,
    String^ propertyValue
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
builtInParameter
Type: Autodesk.Revit.DB..::..ElementId
The built-in parameter id.
propertyValue
Type: System..::..String
The new value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


AreSolidsEqual Method

[image]

Revit 2013 API
ExporterIFCUtils..::..AreSolidsEqual Method
ExporterIFCUtils Class See Also Send Feedback
Determines whether two solids are identical, potentially offset from each other.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool AreSolidsEqual(
    Solid first,
    Solid second,
    out Transform trf
)
Visual Basic
Public Shared Function AreSolidsEqual ( _
    first As Solid, _
    second As Solid, _
    <OutAttribute> ByRef trf As Transform _
) As Boolean
Visual C++
public:
static bool AreSolidsEqual(
    Solid^ first,
    Solid^ second,
    [OutAttribute] Transform^% trf
)

Parameters

first
Type: Autodesk.Revit.DB..::..Solid
The first solid.
second
Type: Autodesk.Revit.DB..::..Solid
The second solid
trf
Type: Autodesk.Revit.DB..::..Transform%
The offset transform

Return Value

True if they are identical, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CanExportWallGeometryAsExtrusion Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CanExportWallGeometryAsExtrusion Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the base geometry of the wall can be represented as an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool CanExportWallGeometryAsExtrusion(
    Element element,
    IFCRange range
)
Visual Basic
Public Shared Function CanExportWallGeometryAsExtrusion ( _
    element As Element, _
    range As IFCRange _
) As Boolean
Visual C++
public:
static bool CanExportWallGeometryAsExtrusion(
    Element^ element,
    IFCRange^ range
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The wall or in-place wall element.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.

Return Value

True if the wall export can be made in the form of an extrusion, false if the geometry cannot be assigned to an extrusion.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CollectGeometryInfo Method

[image] [image]

Revit 2013 API
ExporterIFCUtils..::..CollectGeometryInfo Method
ExporterIFCUtils Class See Also Send Feedback

Overload List

Name | Description
CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.
CollectGeometryInfo(ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform) | Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.

See Also

ExporterIFCUtils Class
ExporterIFCUtils Members
Autodesk.Revit.DB.IFC Namespace


CollectGeometryInfo Method (ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean)

[image]

Revit 2013 API
ExporterIFCUtils..::..CollectGeometryInfo Method (ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean)
ExporterIFCUtils Class See Also Send Feedback
Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CollectGeometryInfo(
    ExporterIFC exporterIFC,
    IFCGeometryInfo geometryInfo,
    GeometryObject gNode,
    XYZ offset,
    bool forceVisible
)
Visual Basic
Public Shared Sub CollectGeometryInfo ( _
    exporterIFC As ExporterIFC, _
    geometryInfo As IFCGeometryInfo, _
    gNode As GeometryObject, _
    offset As XYZ, _
    forceVisible As Boolean _
)
Visual C++
public:
static void CollectGeometryInfo(
    ExporterIFC^ exporterIFC,
    IFCGeometryInfo^ geometryInfo,
    GeometryObject^ gNode,
    XYZ^ offset,
    bool forceVisible
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
geometryInfo
Type: Autodesk.Revit.DB.IFC..::..IFCGeometryInfo
The container object which collects the geometry.
gNode
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object to be processed.
offset
Type: Autodesk.Revit.DB..::..XYZ
The offset to apply to each of the collected geometry handles.
forceVisible
Type: System..::..Boolean
True to process geometry which is not set as visible. False to only process visible geometry.

Remarks

The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
CollectGeometryInfo Overload
Autodesk.Revit.DB.IFC Namespace


CollectGeometryInfo Method (ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform)

[image]

Revit 2013 API
ExporterIFCUtils..::..CollectGeometryInfo Method (ExporterIFC, IFCGeometryInfo, GeometryObject, XYZ, Boolean, Transform)
ExporterIFCUtils Class See Also Send Feedback
Collects all the target geometry from the input geometry object and adds it as IFC handles to the IFCInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CollectGeometryInfo(
    ExporterIFC exporterIFC,
    IFCGeometryInfo geometryInfo,
    GeometryObject gNode,
    XYZ offset,
    bool forceVisible,
    Transform transform
)
Visual Basic
Public Shared Sub CollectGeometryInfo ( _
    exporterIFC As ExporterIFC, _
    geometryInfo As IFCGeometryInfo, _
    gNode As GeometryObject, _
    offset As XYZ, _
    forceVisible As Boolean, _
    transform As Transform _
)
Visual C++
public:
static void CollectGeometryInfo(
    ExporterIFC^ exporterIFC,
    IFCGeometryInfo^ geometryInfo,
    GeometryObject^ gNode,
    XYZ^ offset,
    bool forceVisible,
    Transform^ transform
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
geometryInfo
Type: Autodesk.Revit.DB.IFC..::..IFCGeometryInfo
The container object which collects the geometry.
gNode
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object to be processed.
offset
Type: Autodesk.Revit.DB..::..XYZ
The offset to apply to each of the collected geometry handles.
forceVisible
Type: System..::..Boolean
True to process geometry which is not set as visible. False to only process visible geometry.
transform
Type: Autodesk.Revit.DB..::..Transform
An overall transform to apply to each of the collected geometry handles.

Remarks

The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
CollectGeometryInfo Overload
Autodesk.Revit.DB.IFC Namespace


ComputeAreaOfCurveLoops Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ComputeAreaOfCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Computes total area of the list of curve loops. If the area cannot be calculated, returns 0.0.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double ComputeAreaOfCurveLoops(
    IList<CurveLoop> curveLoops
)
Visual Basic
Public Shared Function ComputeAreaOfCurveLoops ( _
    curveLoops As IList(Of CurveLoop) _
) As Double
Visual C++
public:
static double ComputeAreaOfCurveLoops(
    IList<CurveLoop^>^ curveLoops
)

Parameters

curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>

Return Value

Computed area.

Remarks

All curve loops in the list must be planar and lie in the same plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ComputeRoofProjectedArea Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ComputeRoofProjectedArea Method
ExporterIFCUtils Class See Also Send Feedback
Returns the projected area of the room, unscaled.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static double ComputeRoofProjectedArea(
    Element pElem
)
Visual Basic
Public Shared Function ComputeRoofProjectedArea ( _
    pElem As Element _
) As Double
Visual C++
public:
static double ComputeRoofProjectedArea(
    Element^ pElem
)

Parameters

pElem
Type: Autodesk.Revit.DB..::..Element
The roof.

Return Value

The projected area.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ConvertUnits Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ConvertUnits Method
ExporterIFCUtils Class See Also Send Feedback
Converts a value from universal units to display units.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static double ConvertUnits(
    Document Doc,
    double value,
    DisplayUnitType displayUnitType
)
Visual Basic
Public Shared Function ConvertUnits ( _
    Doc As Document, _
    value As Double, _
    displayUnitType As DisplayUnitType _
) As Double
Visual C++
public:
static double ConvertUnits(
    Document^ Doc,
    double value,
    DisplayUnitType displayUnitType
)

Parameters

Doc
Type: Autodesk.Revit.DB..::..Document
The document.
value
Type: System..::..Double
The value to be converted.
displayUnitType
Type: Autodesk.Revit.DB..::..DisplayUnitType
The display unit type.

Return Value

The converted value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateAlternateGUID Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateAlternateGUID Method
ExporterIFCUtils Class See Also Send Feedback
Creates a GUID for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateAlternateGUID(
    Element pElement
)
Visual Basic
Public Shared Function CreateAlternateGUID ( _
    pElement As Element _
) As String
Visual C++
public:
static String^ CreateAlternateGUID(
    Element^ pElement
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateBeamColumnBaseQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateBeamColumnBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the beam and column base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateBeamColumnBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle beamColumnElement,
    Element pElem,
    IFCTypeInfo typeInfo
)
Visual Basic
Public Shared Sub CreateBeamColumnBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    beamColumnElement As IFCAnyHandle, _
    pElem As Element, _
    typeInfo As IFCTypeInfo _
)
Visual C++
public:
static void CreateBeamColumnBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ beamColumnElement,
    Element^ pElem,
    IFCTypeInfo^ typeInfo
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
beamColumnElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The beam or column element handle.
pElem
Type: Autodesk.Revit.DB..::..Element
The beam or column.
typeInfo
Type: Autodesk.Revit.DB.IFC..::..IFCTypeInfo
Information about the type of the beam or column.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateColumnPropertySet Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateColumnPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the column-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateColumnPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCExtrusionCreationData params,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateColumnPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    params As IFCExtrusionCreationData, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateColumnPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCExtrusionCreationData^ params,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The column element.
params
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The geometric parameters related to the column.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateCoveringPropertySet Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateCoveringPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the covering-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void CreateCoveringPropertySet(
    ExporterIFC exporterIFC,
    Element elem,
    IFCProductWrapper wrapper
)
Visual Basic
Public Shared Sub CreateCoveringPropertySet ( _
    exporterIFC As ExporterIFC, _
    elem As Element, _
    wrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateCoveringPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ elem,
    IFCProductWrapper^ wrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elem
Type: Autodesk.Revit.DB..::..Element
The covering element.
wrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateCurtainWallPropertySet Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateCurtainWallPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the curtain wall-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateCurtainWallPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateCurtainWallPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateCurtainWallPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The curtain wall element.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateCurveFromCurveLoop Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateCurveFromCurveLoop Method
ExporterIFCUtils Class See Also Send Feedback
Creates an IFCCurve from a Curve Loop, projected onto a plane.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCAnyHandle CreateCurveFromCurveLoop(
    ExporterIFC exporterIFC,
    CurveLoop curveLoop,
    Plane plane,
    XYZ projDir
)
Visual Basic
Public Shared Function CreateCurveFromCurveLoop ( _
    exporterIFC As ExporterIFC, _
    curveLoop As CurveLoop, _
    plane As Plane, _
    projDir As XYZ _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ CreateCurveFromCurveLoop(
    ExporterIFC^ exporterIFC,
    CurveLoop^ curveLoop,
    Plane^ plane,
    XYZ^ projDir
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
curveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The curve loop.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane to project the curve onto.
projDir
Type: Autodesk.Revit.DB..::..XYZ
The projection direction.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateDoorPropertySet Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateDoorPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the door-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateDoorPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateDoorPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateDoorPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The door element.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateDoorWindowBaseQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateDoorWindowBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the door or window base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateDoorWindowBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle instanceHandle,
    double scaledHeight,
    double scaledWidth
)
Visual Basic
Public Shared Sub CreateDoorWindowBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    instanceHandle As IFCAnyHandle, _
    scaledHeight As Double, _
    scaledWidth As Double _
)
Visual C++
public:
static void CreateDoorWindowBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ instanceHandle,
    double scaledHeight,
    double scaledWidth
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The door or window handle.
scaledHeight
Type: System..::..Double
The height of the element, in the units of export.
scaledWidth
Type: System..::..Double
The width of the element, in the units of export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateExtrudedSurfaceFromCurve Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateExtrudedSurfaceFromCurve Method
ExporterIFCUtils Class See Also Send Feedback
Creates an IfcConnectionGeometry handle from the extrusion of a curve into a surface.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle CreateExtrudedSurfaceFromCurve(
    ExporterIFC exporterIFC,
    Curve curve,
    XYZ extrusionDir,
    double length,
    double baseHeightNonScaled
)
Visual Basic
Public Shared Function CreateExtrudedSurfaceFromCurve ( _
    exporterIFC As ExporterIFC, _
    curve As Curve, _
    extrusionDir As XYZ, _
    length As Double, _
    baseHeightNonScaled As Double _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ CreateExtrudedSurfaceFromCurve(
    ExporterIFC^ exporterIFC,
    Curve^ curve,
    XYZ^ extrusionDir,
    double length,
    double baseHeightNonScaled
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
curve
Type: Autodesk.Revit.DB..::..Curve
The curve.
extrusionDir
Type: Autodesk.Revit.DB..::..XYZ
The direction of extrusion.
length
Type: System..::..Double
The length of the extrusion.
baseHeightNonScaled
Type: System..::..Double
The Z location of the base of the extrusion. This value will be subtracted from the Z coordinate of the endpoint of the curve to determine the placement.

Return Value

The IfcConnectionGeometry handle.

Remarks

At the conclusion of this method, an IfcProfileDef handle representing the swept curve, an IfcSurface handle representing the extrusion, and an IfcConnectionGeometry will all be created and added to the export file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve is a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateGUID Method

[image] [image]

Revit 2013 API
ExporterIFCUtils..::..CreateGUID Method
ExporterIFCUtils Class See Also Send Feedback

Overload List

Name | Description
CreateGUID()()()() | Creates a randomized GUID.
CreateGUID(Element) | Creates a GUID for the given element.

See Also

ExporterIFCUtils Class
ExporterIFCUtils Members
Autodesk.Revit.DB.IFC Namespace


CreateGUID Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateGUID Method
ExporterIFCUtils Class See Also Send Feedback
Creates a randomized GUID.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateGUID()
Visual Basic
Public Shared Function CreateGUID As String
Visual C++
public:
static String^ CreateGUID()

Return Value

The guid string.

See Also

ExporterIFCUtils Class
CreateGUID Overload
Autodesk.Revit.DB.IFC Namespace


CreateGUID Method (Element)

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateGUID Method (Element)
ExporterIFCUtils Class See Also Send Feedback
Creates a GUID for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateGUID(
    Element element
)
Visual Basic
Public Shared Function CreateGUID ( _
    element As Element _
) As String
Visual C++
public:
static String^ CreateGUID(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
CreateGUID Overload
Autodesk.Revit.DB.IFC Namespace


CreateNonCOBIERoomQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateNonCOBIERoomQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the non-COBIE spatial element quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateNonCOBIERoomQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle spaceHnd,
    SpatialElement roomElem,
    double scaledArea,
    double scaledHeight
)
Visual Basic
Public Shared Sub CreateNonCOBIERoomQuantities ( _
    exporterIFC As ExporterIFC, _
    spaceHnd As IFCAnyHandle, _
    roomElem As SpatialElement, _
    scaledArea As Double, _
    scaledHeight As Double _
)
Visual C++
public:
static void CreateNonCOBIERoomQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ spaceHnd,
    SpatialElement^ roomElem,
    double scaledArea,
    double scaledHeight
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
spaceHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The spatial element handle.
roomElem
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element.
scaledArea
Type: System..::..Double
The area of the spatial element, in the units of export.
scaledHeight
Type: System..::..Double
The height of the spatial element, in the units of export.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateOpeningQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateOpeningQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the opening quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateOpeningQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle openingElement,
    IFCExtrusionCreationData extraParams
)
Visual Basic
Public Shared Sub CreateOpeningQuantities ( _
    exporterIFC As ExporterIFC, _
    openingElement As IFCAnyHandle, _
    extraParams As IFCExtrusionCreationData _
)
Visual C++
public:
static void CreateOpeningQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ openingElement,
    IFCExtrusionCreationData^ extraParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
openingElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The opening element handle.
extraParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
Geometric information obtained from the opening.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreatePreCOBIEGSAQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreatePreCOBIEGSAQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the spatial element quantities required by GSA before COBIE and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreatePreCOBIEGSAQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle elemHnd,
    string quantityName,
    string areaName,
    double dArea
)
Visual Basic
Public Shared Sub CreatePreCOBIEGSAQuantities ( _
    exporterIFC As ExporterIFC, _
    elemHnd As IFCAnyHandle, _
    quantityName As String, _
    areaName As String, _
    dArea As Double _
)
Visual C++
public:
static void CreatePreCOBIEGSAQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ elemHnd,
    String^ quantityName,
    String^ areaName,
    double dArea
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The spatial element handle.
quantityName
Type: System..::..String
The name of the quantity.
areaName
Type: System..::..String
The name of the area.
dArea
Type: System..::..Double
The area value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateProjectLevelGUID Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateProjectLevelGUID Method
ExporterIFCUtils Class See Also Send Feedback
Creates a GUID from Revit project for given GUIDType.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateProjectLevelGUID(
    Document document,
    IFCProjectLevelGUIDType guidType
)
Visual Basic
Public Shared Function CreateProjectLevelGUID ( _
    document As Document, _
    guidType As IFCProjectLevelGUIDType _
) As String
Visual C++
public:
static String^ CreateProjectLevelGUID(
    Document^ document,
    IFCProjectLevelGUIDType guidType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
guidType
Type: Autodesk.Revit.DB.IFC..::..IFCProjectLevelGUIDType
The GUID type.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateSubElementGUID Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateSubElementGUID Method
ExporterIFCUtils Class See Also Send Feedback
Creates a consistent GUID for an IFC entity related to a Revit element. A "related" sub-element is one that is unique for a given type of element, and can therefore by identified by a simple index value (e.g. PSet_Wall_Common property set for a wall.) The index value 0 is reserved, as this would generate the GUID of the element itself. A listing of known sub-elements is contained in IFCSubElementEnums.cs; it is expected that this list would be maintained up-to-date, instead of passing arbitrary values into this function.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string CreateSubElementGUID(
    Element pElement,
    int subElementIndex
)
Visual Basic
Public Shared Function CreateSubElementGUID ( _
    pElement As Element, _
    subElementIndex As Integer _
) As String
Visual C++
public:
static String^ CreateSubElementGUID(
    Element^ pElement,
    int subElementIndex
)

Parameters

pElement
Type: Autodesk.Revit.DB..::..Element
The element.
subElementIndex
Type: System..::..Int32
The global index for this sub-element.

Return Value

The guid string.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateWallBaseQuantities Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateWallBaseQuantities Method
ExporterIFCUtils Class See Also Send Feedback
Creates the wall base quantities and adds them to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateWallBaseQuantities(
    ExporterIFC exporterIFC,
    IFCAnyHandle wallElement,
    Wall pElem,
    double width
)
Visual Basic
Public Shared Sub CreateWallBaseQuantities ( _
    exporterIFC As ExporterIFC, _
    wallElement As IFCAnyHandle, _
    pElem As Wall, _
    width As Double _
)
Visual C++
public:
static void CreateWallBaseQuantities(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ wallElement,
    Wall^ pElem,
    double width
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wallElement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The wall element handle.
pElem
Type: Autodesk.Revit.DB..::..Wall
The wall element.
width
Type: System..::..Double
The width of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


CreateWindowPropertySet Method

[image]

Revit 2013 API
ExporterIFCUtils..::..CreateWindowPropertySet Method
ExporterIFCUtils Class See Also Send Feedback
Adds the window-specific property set to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void CreateWindowPropertySet(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub CreateWindowPropertySet ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void CreateWindowPropertySet(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElem
Type: Autodesk.Revit.DB..::..Element
The window element.
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
ExporterIFCUtils..::..Dispose Method
ExporterIFCUtils Class See Also Send Feedback
Releases all resources used by the ExporterIFCUtils

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


EndExportInternal Method

[image]

Revit 2013 API
ExporterIFCUtils..::..EndExportInternal Method
ExporterIFCUtils Class See Also Send Feedback
Use the internal Revit implementation to relate elements at the end of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void EndExportInternal(
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Sub EndExportInternal ( _
    exporterIFC As ExporterIFC _
)
Visual C++
public:
static void EndExportInternal(
    ExporterIFC^ exporterIFC
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExportExtrudedSlabOpenings Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportExtrudedSlabOpenings Method
ExporterIFCUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void ExportExtrudedSlabOpenings(
    ExporterIFC exporterIFC,
    Element pElem,
    IFCPlacementSetter setter,
    IFCAnyHandle localPlacementAny,
    IList<IFCAnyHandle> elementSlabAnyArr,
    IList<IList<CurveLoop>> extrusionLoops,
    Plane plane,
    IFCProductWrapper pWrapper
)
Visual Basic
Public Shared Sub ExportExtrudedSlabOpenings ( _
    exporterIFC As ExporterIFC, _
    pElem As Element, _
    setter As IFCPlacementSetter, _
    localPlacementAny As IFCAnyHandle, _
    elementSlabAnyArr As IList(Of IFCAnyHandle), _
    extrusionLoops As IList(Of IList(Of CurveLoop)), _
    plane As Plane, _
    pWrapper As IFCProductWrapper _
)
Visual C++
public:
static void ExportExtrudedSlabOpenings(
    ExporterIFC^ exporterIFC,
    Element^ pElem,
    IFCPlacementSetter^ setter,
    IFCAnyHandle^ localPlacementAny,
    IList<IFCAnyHandle^>^ elementSlabAnyArr,
    IList<IList<CurveLoop^>^>^ extrusionLoops,
    Plane^ plane,
    IFCProductWrapper^ pWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
pElem
Type: Autodesk.Revit.DB..::..Element
setter
Type: Autodesk.Revit.DB.IFC..::..IFCPlacementSetter
localPlacementAny
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
elementSlabAnyArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
extrusionLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'CurveLoop>)>)>>)>)>
plane
Type: Autodesk.Revit.DB..::..Plane
pWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExportFamilyInstanceAsExtrusion Method

[image] [image]

Revit 2013 API
ExporterIFCUtils..::..ExportFamilyInstanceAsExtrusion Method
ExporterIFCUtils Class See Also Send Feedback

Overload List

Name | Description
ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.
ExportFamilyInstanceAsExtrusion(ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData) | Creates a single extruded solid handle to represent the given family instance.

See Also

ExporterIFCUtils Class
ExporterIFCUtils Members
Autodesk.Revit.DB.IFC Namespace


ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData)

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, ElementId, IFCExtrusionCreationData)
ExporterIFCUtils Class See Also Send Feedback
Creates a single extruded solid handle to represent the given family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCFamilyInstanceExtrusionExportResults ExportFamilyInstanceAsExtrusion(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    bool useInstanceGeometry,
    ElementId overrideLevelId,
    IFCExtrusionCreationData extraParams
)
Visual Basic
Public Shared Function ExportFamilyInstanceAsExtrusion ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    useInstanceGeometry As Boolean, _
    overrideLevelId As ElementId, _
    extraParams As IFCExtrusionCreationData _
) As IFCFamilyInstanceExtrusionExportResults
Visual C++
public:
static IFCFamilyInstanceExtrusionExportResults^ ExportFamilyInstanceAsExtrusion(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    bool useInstanceGeometry,
    ElementId^ overrideLevelId,
    IFCExtrusionCreationData^ extraParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance to export.
useInstanceGeometry
Type: System..::..Boolean
True to use the geometry of the instance (with the transformation applied to the geometry). False to use the geometry of the symbol.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level to which the geometry should be related.
extraParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data to associate with the created extrusion.

Return Value

The results of the export operation.

Remarks

The return value includes the extruded solid handle, the best material id to assign to it, an "extra offset" calculated during the extrusion process, and a collection of "openings" (extrusions which cut the base handle). This routine currently only works for families which consist of one Extrusion element. If the function fails, HasValue for the handle returned will be false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
ExportFamilyInstanceAsExtrusion Overload
Autodesk.Revit.DB.IFC Namespace


ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData)

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportFamilyInstanceAsExtrusion Method (ExporterIFC, FamilyInstance, Boolean, IFCRange, ElementId, IFCExtrusionCreationData)
ExporterIFCUtils Class See Also Send Feedback
Creates a single extruded solid handle to represent the given family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCFamilyInstanceExtrusionExportResults ExportFamilyInstanceAsExtrusion(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    bool useInstanceGeometry,
    IFCRange range,
    ElementId overrideLevelId,
    IFCExtrusionCreationData extraParams
)
Visual Basic
Public Shared Function ExportFamilyInstanceAsExtrusion ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    useInstanceGeometry As Boolean, _
    range As IFCRange, _
    overrideLevelId As ElementId, _
    extraParams As IFCExtrusionCreationData _
) As IFCFamilyInstanceExtrusionExportResults
Visual C++
public:
static IFCFamilyInstanceExtrusionExportResults^ ExportFamilyInstanceAsExtrusion(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    bool useInstanceGeometry,
    IFCRange^ range,
    ElementId^ overrideLevelId,
    IFCExtrusionCreationData^ extraParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance to export.
useInstanceGeometry
Type: System..::..Boolean
True to use the geometry of the instance (with the transformation applied to the geometry). False to use the geometry of the symbol.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire instance is used. This is only used if the instance is a column.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id of the level to which the geometry should be related.
extraParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data to associate with the created extrusion.

Return Value

The results of the export operation.

Remarks

The return value includes the extruded solid handle, the best material id to assign to it, an "extra offset" calculated during the extrusion process, and a collection of "openings" (extrusions which cut the base handle). This routine currently only works for families which consist of one Extrusion element. If the function fails, HasValue for the handle returned will be false.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
ExportFamilyInstanceAsExtrusion Overload
Autodesk.Revit.DB.IFC Namespace


ExportLegacyStairsAsContainer Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportLegacyStairsAsContainer Method
ExporterIFCUtils Class See Also Send Feedback
Adds data from a legacy staircase to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void ExportLegacyStairsAsContainer(
    ExporterIFC exporterIFC,
    string ifcEnumType,
    Element element,
    GeometryElement geometry,
    bool useCoarseTessellation,
    IFCProductWrapper productWrapper
)
Visual Basic
Public Shared Sub ExportLegacyStairsAsContainer ( _
    exporterIFC As ExporterIFC, _
    ifcEnumType As String, _
    element As Element, _
    geometry As GeometryElement, _
    useCoarseTessellation As Boolean, _
    productWrapper As IFCProductWrapper _
)
Visual C++
public:
static void ExportLegacyStairsAsContainer(
    ExporterIFC^ exporterIFC,
    String^ ifcEnumType,
    Element^ element,
    GeometryElement^ geometry,
    bool useCoarseTessellation,
    IFCProductWrapper^ productWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
ifcEnumType
Type: System..::..String
The stairs type.
element
Type: Autodesk.Revit.DB..::..Element
The stairs.
geometry
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the wall.
useCoarseTessellation
Type: System..::..Boolean
Export using a coarse tessellation if true, default tessellation if false.
productWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Remarks

This function applies only to legacy stairs found in documents create in R2012 or before.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExportRampAsContainer Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportRampAsContainer Method
ExporterIFCUtils Class See Also Send Feedback
Adds data from a ramp to the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void ExportRampAsContainer(
    ExporterIFC exporterIFC,
    string ifcEnumType,
    Element element,
    GeometryElement geometry,
    bool useCoarseTessellation,
    IFCProductWrapper productWrapper
)
Visual Basic
Public Shared Sub ExportRampAsContainer ( _
    exporterIFC As ExporterIFC, _
    ifcEnumType As String, _
    element As Element, _
    geometry As GeometryElement, _
    useCoarseTessellation As Boolean, _
    productWrapper As IFCProductWrapper _
)
Visual C++
public:
static void ExportRampAsContainer(
    ExporterIFC^ exporterIFC,
    String^ ifcEnumType,
    Element^ element,
    GeometryElement^ geometry,
    bool useCoarseTessellation,
    IFCProductWrapper^ productWrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
ifcEnumType
Type: System..::..String
The stairs type.
element
Type: Autodesk.Revit.DB..::..Element
The stairs.
geometry
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the wall.
useCoarseTessellation
Type: System..::..Boolean
Export using a coarse tessellation if true, default tessellation if false.
productWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExportRoofAsContainer Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportRoofAsContainer Method
ExporterIFCUtils Class See Also Send Feedback
Exports a roof as a container of multiple roof slabs. Returns the handle, if successful.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCAnyHandle ExportRoofAsContainer(
    ExporterIFC exporterIFC,
    string ifcEnumType,
    Element pRoofBase,
    GeometryElement geometry,
    IFCProductWrapper wrapper
)
Visual Basic
Public Shared Function ExportRoofAsContainer ( _
    exporterIFC As ExporterIFC, _
    ifcEnumType As String, _
    pRoofBase As Element, _
    geometry As GeometryElement, _
    wrapper As IFCProductWrapper _
) As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ ExportRoofAsContainer(
    ExporterIFC^ exporterIFC,
    String^ ifcEnumType,
    Element^ pRoofBase,
    GeometryElement^ geometry,
    IFCProductWrapper^ wrapper
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
ifcEnumType
Type: System..::..String
The roof type.
pRoofBase
Type: Autodesk.Revit.DB..::..Element
The roof element.
geometry
Type: Autodesk.Revit.DB..::..GeometryElement
The geometry of the element.
wrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The product wrapper.

Return Value

The IfcRoof container.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ExportSlabAsExtrusion Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ExportSlabAsExtrusion Method
ExporterIFCUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ExportSlabAsExtrusion(
    ExporterIFC exporterIFC,
    Element pCeilingAndFloor,
    GeometryElement pGRep,
    IFCTransformSetter pTmpTrfSetter,
    IFCAnyHandle localPlacement,
    out IList<IFCAnyHandle> localPlacementAnyArr,
    out IList<IFCAnyHandle> reps,
    out IList<IList<CurveLoop>> extrusionLoops,
    out IList<IFCExtrusionCreationData> loopExtraParams,
    Plane plane
)
Visual Basic
Public Shared Function ExportSlabAsExtrusion ( _
    exporterIFC As ExporterIFC, _
    pCeilingAndFloor As Element, _
    pGRep As GeometryElement, _
    pTmpTrfSetter As IFCTransformSetter, _
    localPlacement As IFCAnyHandle, _
    <OutAttribute> ByRef localPlacementAnyArr As IList(Of IFCAnyHandle), _
    <OutAttribute> ByRef reps As IList(Of IFCAnyHandle), _
    <OutAttribute> ByRef extrusionLoops As IList(Of IList(Of CurveLoop)), _
    <OutAttribute> ByRef loopExtraParams As IList(Of IFCExtrusionCreationData), _
    plane As Plane _
) As Boolean
Visual C++
public:
static bool ExportSlabAsExtrusion(
    ExporterIFC^ exporterIFC,
    Element^ pCeilingAndFloor,
    GeometryElement^ pGRep,
    IFCTransformSetter^ pTmpTrfSetter,
    IFCAnyHandle^ localPlacement,
    [OutAttribute] IList<IFCAnyHandle^>^% localPlacementAnyArr,
    [OutAttribute] IList<IFCAnyHandle^>^% reps,
    [OutAttribute] IList<IList<CurveLoop^>^>^% extrusionLoops,
    [OutAttribute] IList<IFCExtrusionCreationData^>^% loopExtraParams,
    Plane^ plane
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
pCeilingAndFloor
Type: Autodesk.Revit.DB..::..Element
pGRep
Type: Autodesk.Revit.DB..::..GeometryElement
pTmpTrfSetter
Type: Autodesk.Revit.DB.IFC..::..IFCTransformSetter
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
localPlacementAnyArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>%
reps
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>%
extrusionLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'CurveLoop>)>)>>)>)>%
loopExtraParams
Type: System.Collections.Generic..::..IList<(Of <(<'IFCExtrusionCreationData>)>)>%
plane
Type: Autodesk.Revit.DB..::..Plane

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetAttachedColumns Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetAttachedColumns Method
ExporterIFCUtils Class See Also Send Feedback
Obtains a list of columns known to Revit as intersecting with this wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<FamilyInstance> GetAttachedColumns(
    Wall pWallElem
)
Visual Basic
Public Shared Function GetAttachedColumns ( _
    pWallElem As Wall _
) As IList(Of FamilyInstance)
Visual C++
public:
static IList<FamilyInstance^>^ GetAttachedColumns(
    Wall^ pWallElem
)

Parameters

pWallElem
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The columns found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetConnectedWalls Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetConnectedWalls Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the IFC-specific information regarding the connections between this wall and other elements.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCConnectedWallData> GetConnectedWalls(
    Wall pWallElem,
    IFCConnectedWallDataLocation locaction
)
Visual Basic
Public Shared Function GetConnectedWalls ( _
    pWallElem As Wall, _
    locaction As IFCConnectedWallDataLocation _
) As IList(Of IFCConnectedWallData)
Visual C++
public:
static IList<IFCConnectedWallData^>^ GetConnectedWalls(
    Wall^ pWallElem,
    IFCConnectedWallDataLocation locaction
)

Parameters

pWallElem
Type: Autodesk.Revit.DB..::..Wall
The wall.
locaction
Type: Autodesk.Revit.DB.IFC..::..IFCConnectedWallDataLocation
The location on the wall from where the connections should be obtained. This should be either IFCConnectedWallDataLocation.Start or IFCConnectedWallDataLocation.End.

Return Value

The connection information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetElevationProfile Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetElevationProfile Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the curve loops which bound the wall's elevation profile.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetElevationProfile(
    Wall pVWall
)
Visual Basic
Public Shared Function GetElevationProfile ( _
    pVWall As Wall _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetElevationProfile(
    Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The collection of curve loops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The wall does not have an elevation profile.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetFamilyName Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetFamilyName Method
ExporterIFCUtils Class See Also Send Feedback
Gets the family name of an ElementType.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string GetFamilyName(
    ElementType elemType
)
Visual Basic
Public Shared Function GetFamilyName ( _
    elemType As ElementType _
) As String
Visual C++
public:
static String^ GetFamilyName(
    ElementType^ elemType
)

Parameters

elemType
Type: Autodesk.Revit.DB..::..ElementType
The element type element.

Return Value

The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetGeometryFromInplaceWall Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetGeometryFromInplaceWall Method
ExporterIFCUtils Class See Also Send Feedback
Obtains a special snapshot of the geometry of an in-place wall element suitable for export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static GeometryElement GetGeometryFromInplaceWall(
    FamilyInstance pFamInstWallElem
)
Visual Basic
Public Shared Function GetGeometryFromInplaceWall ( _
    pFamInstWallElem As FamilyInstance _
) As GeometryElement
Visual C++
public:
static GeometryElement^ GetGeometryFromInplaceWall(
    FamilyInstance^ pFamInstWallElem
)

Parameters

pFamInstWallElem
Type: Autodesk.Revit.DB..::..FamilyInstance
The in-place wall instance.

Return Value

The in-place wall geometry. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no special geometry for the wall needed for export; the standard geometry of the wall can be used.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetGlobal2DDirectionHandles Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetGlobal2DDirectionHandles Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the handles representing the cardinal directions in 2D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCAnyHandle> GetGlobal2DDirectionHandles(
    bool positive
)
Visual Basic
Public Shared Function GetGlobal2DDirectionHandles ( _
    positive As Boolean _
) As IList(Of IFCAnyHandle)
Visual C++
public:
static IList<IFCAnyHandle^>^ GetGlobal2DDirectionHandles(
    bool positive
)

Parameters

positive
Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.

Return Value

The collection of handles.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetGlobal2DOriginHandle Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetGlobal2DOriginHandle Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the handle representing the 2D origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle GetGlobal2DOriginHandle()
Visual Basic
Public Shared Function GetGlobal2DOriginHandle As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ GetGlobal2DOriginHandle()

Return Value

The handle.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetGlobal3DDirectionHandles Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetGlobal3DDirectionHandles Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the handles representing the cardinal directions in 3D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCAnyHandle> GetGlobal3DDirectionHandles(
    bool positive
)
Visual Basic
Public Shared Function GetGlobal3DDirectionHandles ( _
    positive As Boolean _
) As IList(Of IFCAnyHandle)
Visual C++
public:
static IList<IFCAnyHandle^>^ GetGlobal3DDirectionHandles(
    bool positive
)

Parameters

positive
Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.

Return Value

The collection of handles.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetGlobal3DOriginHandle Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetGlobal3DOriginHandle Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the handle representing the 3D origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCAnyHandle GetGlobal3DOriginHandle()
Visual Basic
Public Shared Function GetGlobal3DOriginHandle As IFCAnyHandle
Visual C++
public:
static IFCAnyHandle^ GetGlobal3DOriginHandle()

Return Value

The handle.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetIFCClassName Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetIFCClassName Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the IFC class name associated to the given element for the current export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string GetIFCClassName(
    Element element,
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetIFCClassName ( _
    element As Element, _
    exporterIFC As ExporterIFC _
) As String
Visual C++
public:
static String^ GetIFCClassName(
    Element^ element,
    ExporterIFC^ exporterIFC
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.

Remarks

IFC class names are affected by the user's entries in the mapping file set for a given export operation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetIFCClassNameByCategory Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetIFCClassNameByCategory Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the IFC class name associated to a given category id for the current export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static string GetIFCClassNameByCategory(
    ElementId catId,
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetIFCClassNameByCategory ( _
    catId As ElementId, _
    exporterIFC As ExporterIFC _
) As String
Visual C++
public:
static String^ GetIFCClassNameByCategory(
    ElementId^ catId,
    ExporterIFC^ exporterIFC
)

Parameters

catId
Type: Autodesk.Revit.DB..::..ElementId
The category id.
exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The IFC class name. This is an empty string if the element should not be exported because it is not found in the mapping file.

Remarks

IFC class names are affected by the user's entries in the mapping file set for a given export operation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetIFCType Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetIFCType Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the IFC type associated to the given element for the current export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static string GetIFCType(
    Element element,
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetIFCType ( _
    element As Element, _
    exporterIFC As ExporterIFC _
) As String
Visual C++
public:
static String^ GetIFCType(
    Element^ element,
    ExporterIFC^ exporterIFC
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The IFC type. This is an empty string if the element should not be exported because it is not found in the mapping file.

Remarks

IFC type names are affected by the user's entries in the mapping file set for a given export operation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetLegacyCurtainSubElements Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetLegacyCurtainSubElements Method
ExporterIFCUtils Class See Also Send Feedback
Gets the sub elements from a legacy curtain element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ICollection<ElementId> GetLegacyCurtainSubElements(
    Element element
)
Visual Basic
Public Shared Function GetLegacyCurtainSubElements ( _
    element As Element _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetLegacyCurtainSubElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The legacy curtain element.

Return Value

The element array.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetLegacyStairOrRampComponents Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetLegacyStairOrRampComponents Method
ExporterIFCUtils Class See Also Send Feedback
Gets the components of a stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCLegacyStairOrRamp GetLegacyStairOrRampComponents(
    ExporterIFC exporterIFC,
    Element element
)
Visual Basic
Public Shared Function GetLegacyStairOrRampComponents ( _
    exporterIFC As ExporterIFC, _
    element As Element _
) As IFCLegacyStairOrRamp
Visual C++
public:
static IFCLegacyStairOrRamp^ GetLegacyStairOrRampComponents(
    ExporterIFC^ exporterIFC,
    Element^ element
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The legacy stair or ramp element.

Return Value

The LegacyStairOrRamp that contains the components. NULL means the components can't be determined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetLegacyStairsProperties Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetLegacyStairsProperties Method
ExporterIFCUtils Class See Also Send Feedback
Returns one or more properties for legacy (created in R2012 or before) Stairs.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void GetLegacyStairsProperties(
    ExporterIFC exporterIFC,
    Element pElement,
    out int pNumRisers,
    out int pNumTreads,
    out double pRiserHeight,
    out double pTreadLength,
    out double pMinTreadLength,
    out double pNosingLength,
    out double pWaistThickness
)
Visual Basic
Public Shared Sub GetLegacyStairsProperties ( _
    exporterIFC As ExporterIFC, _
    pElement As Element, _
    <OutAttribute> ByRef pNumRisers As Integer, _
    <OutAttribute> ByRef pNumTreads As Integer, _
    <OutAttribute> ByRef pRiserHeight As Double, _
    <OutAttribute> ByRef pTreadLength As Double, _
    <OutAttribute> ByRef pMinTreadLength As Double, _
    <OutAttribute> ByRef pNosingLength As Double, _
    <OutAttribute> ByRef pWaistThickness As Double _
)
Visual C++
public:
static void GetLegacyStairsProperties(
    ExporterIFC^ exporterIFC,
    Element^ pElement,
    [OutAttribute] int% pNumRisers,
    [OutAttribute] int% pNumTreads,
    [OutAttribute] double% pRiserHeight,
    [OutAttribute] double% pTreadLength,
    [OutAttribute] double% pMinTreadLength,
    [OutAttribute] double% pNosingLength,
    [OutAttribute] double% pWaistThickness
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
pElement
Type: Autodesk.Revit.DB..::..Element
the legacy stair.
pNumRisers
Type: System..::..Int32%
Number of Risers in the Stair.
pNumTreads
Type: System..::..Int32%
Number of Treads in the Stair.
pRiserHeight
Type: System..::..Double%
Riser Height of the risers in the Stair.
pTreadLength
Type: System..::..Double%
Tread length of the treads in the Stair.
pMinTreadLength
Type: System..::..Double%
Minimum Tread length of the treads in the Stair.
pNosingLength
Type: System..::..Double%
Nosing length of the treads in the Stair.
pWaistThickness
Type: System..::..Double%
Waist thickness of the flight of stair.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetLoopsFromTopBottomFace Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetLoopsFromTopBottomFace Method
ExporterIFCUtils Class See Also Send Feedback
Gets the curve loop(s) that represent the bottom or top face of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetLoopsFromTopBottomFace(
    ExporterIFC exporterIFC,
    Wall wall
)
Visual Basic
Public Shared Function GetLoopsFromTopBottomFace ( _
    exporterIFC As ExporterIFC, _
    wall As Wall _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetLoopsFromTopBottomFace(
    ExporterIFC^ exporterIFC,
    Wall^ wall
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The curve loops. If the function has failed, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetMinSymbolHeight Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetMinSymbolHeight Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the minimum height of the given FamilySymbol.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetMinSymbolHeight(
    FamilySymbol symbol
)
Visual Basic
Public Shared Function GetMinSymbolHeight ( _
    symbol As FamilySymbol _
) As Double
Visual C++
public:
static double GetMinSymbolHeight(
    FamilySymbol^ symbol
)

Parameters

symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.

Return Value

The minimum height.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetMinSymbolWidth Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetMinSymbolWidth Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the minimum width of the given FamilySymbol.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetMinSymbolWidth(
    FamilySymbol symbol
)
Visual Basic
Public Shared Function GetMinSymbolWidth ( _
    symbol As FamilySymbol _
) As Double
Visual C++
public:
static double GetMinSymbolWidth(
    FamilySymbol^ symbol
)

Parameters

symbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.

Return Value

The minimum width.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetNumBuildingStoreys Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetNumBuildingStoreys Method
ExporterIFCUtils Class See Also Send Feedback
Returns the number of non-empty, non-duplicate building stories in the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static int GetNumBuildingStoreys(
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Function GetNumBuildingStoreys ( _
    exporterIFC As ExporterIFC _
) As Integer
Visual C++
public:
static int GetNumBuildingStoreys(
    ExporterIFC^ exporterIFC
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Return Value

The number of stories.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetOriginalSymbol Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetOriginalSymbol Method
ExporterIFCUtils Class See Also Send Feedback
Returns the original family symbol of this family instance, before the instance is modified by joins, cuts, coping, extensions, or other post-processing.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static FamilySymbol GetOriginalSymbol(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function GetOriginalSymbol ( _
    familyInstance As FamilyInstance _
) As FamilySymbol
Visual C++
public:
static FamilySymbol^ GetOriginalSymbol(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The FamilyInstance.

Return Value

The original FamilySymbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetRebarGeometry Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetRebarGeometry Method
ExporterIFCUtils Class See Also Send Feedback
Generates the geometry for a Rebar for a specific view. The filter view is allowed to be null, but no geometry will be generated if it is.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static GeometryElement GetRebarGeometry(
    Rebar rebar,
    View filterView
)
Visual Basic
Public Shared Function GetRebarGeometry ( _
    rebar As Rebar, _
    filterView As View _
) As GeometryElement
Visual C++
public:
static GeometryElement^ GetRebarGeometry(
    Rebar^ rebar,
    View^ filterView
)

Parameters

rebar
Type: Autodesk.Revit.DB.Structure..::..Rebar
The rebar element.
filterView
Type: Autodesk.Revit.DB..::..View
The view in which the geometry is generated.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetRelativeLocalPlacementOffsetTransform Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetRelativeLocalPlacementOffsetTransform Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the relative transform between two IfcLocalPlacement handles.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetRelativeLocalPlacementOffsetTransform(
    IFCAnyHandle originalPlacement,
    IFCAnyHandle relativePlacement
)
Visual Basic
Public Shared Function GetRelativeLocalPlacementOffsetTransform ( _
    originalPlacement As IFCAnyHandle, _
    relativePlacement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetRelativeLocalPlacementOffsetTransform(
    IFCAnyHandle^ originalPlacement,
    IFCAnyHandle^ relativePlacement
)

Parameters

originalPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The original placement from which the result transforms coordinates and directions.
relativePlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The relative placement to which the result transforms coordinates and directions.

Return Value

The transform from the original placement to the new placement.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetRoomBoundaryAsCurveLoopArray Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetRoomBoundaryAsCurveLoopArray Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<CurveLoop> GetRoomBoundaryAsCurveLoopArray(
    SpatialElement spatialElement,
    SpatialElementBoundaryOptions options,
    bool cleanCurves
)
Visual Basic
Public Shared Function GetRoomBoundaryAsCurveLoopArray ( _
    spatialElement As SpatialElement, _
    options As SpatialElementBoundaryOptions, _
    cleanCurves As Boolean _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ GetRoomBoundaryAsCurveLoopArray(
    SpatialElement^ spatialElement,
    SpatialElementBoundaryOptions^ options,
    bool cleanCurves
)

Parameters

spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element.
options
Type: Autodesk.Revit.DB..::..SpatialElementBoundaryOptions
The options for extraction of the boundaries.
cleanCurves
Type: System..::..Boolean
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.

Return Value

The list of CurveLoops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to get boundary curve loops for the spatial element.

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetSpatialElementBoundaryOptions Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetSpatialElementBoundaryOptions Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the SpatialElementBoundaryOptions needed for IFC export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static SpatialElementBoundaryOptions GetSpatialElementBoundaryOptions(
    ExporterIFC exporterIFC,
    SpatialElement spatialElement
)
Visual Basic
Public Shared Function GetSpatialElementBoundaryOptions ( _
    exporterIFC As ExporterIFC, _
    spatialElement As SpatialElement _
) As SpatialElementBoundaryOptions
Visual C++
public:
static SpatialElementBoundaryOptions^ GetSpatialElementBoundaryOptions(
    ExporterIFC^ exporterIFC,
    SpatialElement^ spatialElement
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
spatialElement
Type: Autodesk.Revit.DB..::..SpatialElement
The spatial element for which the options are required. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) generic options will be obtained.

Return Value

The options.

Remarks

Some varieties of these options cannot be created directly from SpatialElementBoundaryOptions so far.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetTransformForDoorOrWindow Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetTransformForDoorOrWindow Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the transform for the door or window instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetTransformForDoorOrWindow(
    FamilyInstance familyInstance,
    FamilySymbol familySymbol,
    IFCDoorWindowInfo info
)
Visual Basic
Public Shared Function GetTransformForDoorOrWindow ( _
    familyInstance As FamilyInstance, _
    familySymbol As FamilySymbol, _
    info As IFCDoorWindowInfo _
) As Transform
Visual C++
public:
static Transform^ GetTransformForDoorOrWindow(
    FamilyInstance^ familyInstance,
    FamilySymbol^ familySymbol,
    IFCDoorWindowInfo^ info
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.
familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.
info
Type: Autodesk.Revit.DB.IFC..::..IFCDoorWindowInfo
The door or window info.

Return Value

The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetUnscaledTransform Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetUnscaledTransform Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the unscaled transform from an IfcLocalPlacement handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Transform GetUnscaledTransform(
    ExporterIFC exporterIFC,
    IFCAnyHandle placement
)
Visual Basic
Public Shared Function GetUnscaledTransform ( _
    exporterIFC As ExporterIFC, _
    placement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetUnscaledTransform(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ placement
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
placement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The placement handle.

Return Value

The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetWallBaseOffset Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetWallBaseOffset Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the base offset of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static double GetWallBaseOffset(
    Wall wall
)
Visual Basic
Public Shared Function GetWallBaseOffset ( _
    wall As Wall _
) As Double
Visual C++
public:
static double GetWallBaseOffset(
    Wall^ wall
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The base offset of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetWallHeightDirection Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetWallHeightDirection Method
ExporterIFCUtils Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static XYZ GetWallHeightDirection(
    Wall wall
)
Visual Basic
Public Shared Function GetWallHeightDirection ( _
    wall As Wall _
) As XYZ
Visual C++
public:
static XYZ^ GetWallHeightDirection(
    Wall^ wall
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The direction of the wall.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


GetWallTrimmedCurve Method

[image]

Revit 2013 API
ExporterIFCUtils..::..GetWallTrimmedCurve Method
ExporterIFCUtils Class See Also Send Feedback
Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Curve GetWallTrimmedCurve(
    Wall pVWall
)
Visual Basic
Public Shared Function GetWallTrimmedCurve ( _
    pVWall As Wall _
) As Curve
Visual C++
public:
static Curve^ GetWallTrimmedCurve(
    Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

The trimmed or extended curve.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


HasElevationProfile Method

[image]

Revit 2013 API
ExporterIFCUtils..::..HasElevationProfile Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the wall has a sketched elevation profile.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool HasElevationProfile(
    Wall pVWall
)
Visual Basic
Public Shared Function HasElevationProfile ( _
    pVWall As Wall _
) As Boolean
Visual C++
public:
static bool HasElevationProfile(
    Wall^ pVWall
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

True if the wall has a sketch elevation profile, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IsCurveFromOtherElementSketch Method

[image]

Revit 2013 API
ExporterIFCUtils..::..IsCurveFromOtherElementSketch Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the given curve element is generated by another element's sketch, or if it represents an independent curve element accessible directly by the user.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsCurveFromOtherElementSketch(
    CurveElement curveElement
)
Visual Basic
Public Shared Function IsCurveFromOtherElementSketch ( _
    curveElement As CurveElement _
) As Boolean
Visual C++
public:
static bool IsCurveFromOtherElementSketch(
    CurveElement^ curveElement
)

Parameters

curveElement
Type: Autodesk.Revit.DB..::..CurveElement
The curve element.

Return Value

True if the curve element was generated by a sketch, false if it is independent.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IsCurveLoopConvexWithOpenings Method

[image]

Revit 2013 API
ExporterIFCUtils..::..IsCurveLoopConvexWithOpenings Method
ExporterIFCUtils Class See Also Send Feedback
Checks if the region bounded by the input curve loop can be represented as the subtraction of 0 or more convex polygons from a base convex polygon.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsCurveLoopConvexWithOpenings(
    CurveLoop inputCurveLoop,
    Wall wall,
    IFCRange range,
    out bool loopIsDegenerate
)
Visual Basic
Public Shared Function IsCurveLoopConvexWithOpenings ( _
    inputCurveLoop As CurveLoop, _
    wall As Wall, _
    range As IFCRange, _
    <OutAttribute> ByRef loopIsDegenerate As Boolean _
) As Boolean
Visual C++
public:
static bool IsCurveLoopConvexWithOpenings(
    CurveLoop^ inputCurveLoop,
    Wall^ wall,
    IFCRange^ range,
    [OutAttribute] bool% loopIsDegenerate
)

Parameters

inputCurveLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The input curve loop. It is intended that this curve loop have been obtained from the elevation profile of a wall.
wall
Type: Autodesk.Revit.DB..::..Wall
The wall from which the curve loop was obtained.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range extents of the wall.
loopIsDegenerate
Type: System..::..Boolean%
If the function returns false but this returns true, the loop could be obtained but was degenerate. Thus there is no extrusion that can be produced.

Return Value

True if the region can be represented by a boolean combination of polygons, false otherwise.

Remarks

This function is intended to be used to determine if the geometry of a wall with an elevation profile can be successfully represented as a vertical extrusion with one or more openings removed. If this function is to return true, the subtracting polygons must each have at least one edge coincident with the base convex polygon. Before the check is performed, this input curve will be trimmed by the range extents of the wall, if any.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IsWallBaseRectangular Method

[image]

Revit 2013 API
ExporterIFCUtils..::..IsWallBaseRectangular Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsWallBaseRectangular(
    Wall wall,
    Curve curve
)
Visual Basic
Public Shared Function IsWallBaseRectangular ( _
    wall As Wall, _
    curve As Curve _
) As Boolean
Visual C++
public:
static bool IsWallBaseRectangular(
    Wall^ wall,
    Curve^ curve
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.
curve
Type: Autodesk.Revit.DB..::..Curve
The wall's base curve.

Return Value

True if the wall's base can be represented by a direct thickening of the wall's base curve. False is the wall's base shape is affected by other geometry, and thus cannot be represented by a direct thickening of the wall's base cure.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IsWallCompletelyClipped Method

[image]

Revit 2013 API
ExporterIFCUtils..::..IsWallCompletelyClipped Method
ExporterIFCUtils Class See Also Send Feedback
Determines if the input wall is completely removed by interaction with other elements within the given range.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsWallCompletelyClipped(
    Wall pVWall,
    ExporterIFC exporterIFC,
    IFCRange range
)
Visual Basic
Public Shared Function IsWallCompletelyClipped ( _
    pVWall As Wall, _
    exporterIFC As ExporterIFC, _
    range As IFCRange _
) As Boolean
Visual C++
public:
static bool IsWallCompletelyClipped(
    Wall^ pVWall,
    ExporterIFC^ exporterIFC,
    IFCRange^ range
)

Parameters

pVWall
Type: Autodesk.Revit.DB..::..Wall
The wall.
exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
range
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire wall is used.

Return Value

True if the wall should be ignored within the given range.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IsWallJoinedToTop Method

[image]

Revit 2013 API
ExporterIFCUtils..::..IsWallJoinedToTop Method
ExporterIFCUtils Class See Also Send Feedback
Checks if wall is joined to top.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsWallJoinedToTop(
    Wall wall
)
Visual Basic
Public Shared Function IsWallJoinedToTop ( _
    wall As Wall _
) As Boolean
Visual C++
public:
static bool IsWallJoinedToTop(
    Wall^ wall
)

Parameters

wall
Type: Autodesk.Revit.DB..::..Wall
The wall.

Return Value

True if wall is joined to top, false if not.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


SetGlobal2DDirectionHandles Method

[image]

Revit 2013 API
ExporterIFCUtils..::..SetGlobal2DDirectionHandles Method
ExporterIFCUtils Class See Also Send Feedback
Sets the handles representing the cardinal directions in 2D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SetGlobal2DDirectionHandles(
    bool positive,
    IFCAnyHandle xDir,
    IFCAnyHandle yDir
)
Visual Basic
Public Shared Sub SetGlobal2DDirectionHandles ( _
    positive As Boolean, _
    xDir As IFCAnyHandle, _
    yDir As IFCAnyHandle _
)
Visual C++
public:
static void SetGlobal2DDirectionHandles(
    bool positive,
    IFCAnyHandle^ xDir,
    IFCAnyHandle^ yDir
)

Parameters

positive
Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
xDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The X direction handle.
yDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Y direction handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


SetGlobal2DOriginHandle Method

[image]

Revit 2013 API
ExporterIFCUtils..::..SetGlobal2DOriginHandle Method
ExporterIFCUtils Class See Also Send Feedback
Sets the handle representing the 2D origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SetGlobal2DOriginHandle(
    IFCAnyHandle origin
)
Visual Basic
Public Shared Sub SetGlobal2DOriginHandle ( _
    origin As IFCAnyHandle _
)
Visual C++
public:
static void SetGlobal2DOriginHandle(
    IFCAnyHandle^ origin
)

Parameters

origin
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The origin handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


SetGlobal3DDirectionHandles Method

[image]

Revit 2013 API
ExporterIFCUtils..::..SetGlobal3DDirectionHandles Method
ExporterIFCUtils Class See Also Send Feedback
Sets the handles representing the cardinal directions in 3D.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SetGlobal3DDirectionHandles(
    bool positive,
    IFCAnyHandle xDir,
    IFCAnyHandle yDir,
    IFCAnyHandle zDir
)
Visual Basic
Public Shared Sub SetGlobal3DDirectionHandles ( _
    positive As Boolean, _
    xDir As IFCAnyHandle, _
    yDir As IFCAnyHandle, _
    zDir As IFCAnyHandle _
)
Visual C++
public:
static void SetGlobal3DDirectionHandles(
    bool positive,
    IFCAnyHandle^ xDir,
    IFCAnyHandle^ yDir,
    IFCAnyHandle^ zDir
)

Parameters

positive
Type: System..::..Boolean
True if the handles returned should be in the positive direction, false if the handles should be in the negative direction.
xDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The X direction handle.
yDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Y direction handle.
zDir
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The Z direction handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


SetGlobal3DOriginHandle Method

[image]

Revit 2013 API
ExporterIFCUtils..::..SetGlobal3DOriginHandle Method
ExporterIFCUtils Class See Also Send Feedback
Sets the handle representing the 3D origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void SetGlobal3DOriginHandle(
    IFCAnyHandle origin
)
Visual Basic
Public Shared Sub SetGlobal3DOriginHandle ( _
    origin As IFCAnyHandle _
)
Visual C++
public:
static void SetGlobal3DOriginHandle(
    IFCAnyHandle^ origin
)

Parameters

origin
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The origin handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


SortCurveLoops Method

[image]

Revit 2013 API
ExporterIFCUtils..::..SortCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Sorts a set of curve loops such that outer and inner loops are separated.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IList<CurveLoop>> SortCurveLoops(
    IList<CurveLoop> loops
)
Visual Basic
Public Shared Function SortCurveLoops ( _
    loops As IList(Of CurveLoop) _
) As IList(Of IList(Of CurveLoop))
Visual C++
public:
static IList<IList<CurveLoop^>^>^ SortCurveLoops(
    IList<CurveLoop^>^ loops
)

Parameters

loops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The curve loops.

Return Value

The sorted collection of loops.

Remarks

Outer loops are separated and inner loops are grouped according to their outer loop. Loops are assumed to be non-intersecting, and there will be no nesting of inner loops (that is, an inner loop of an inner loop is another outer loop).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


TransformAndScalePoint Method

[image]

Revit 2013 API
ExporterIFCUtils..::..TransformAndScalePoint Method
ExporterIFCUtils Class See Also Send Feedback
Converts a point from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static XYZ TransformAndScalePoint(
    ExporterIFC exporterIFC,
    XYZ origPt
)
Visual Basic
Public Shared Function TransformAndScalePoint ( _
    exporterIFC As ExporterIFC, _
    origPt As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ TransformAndScalePoint(
    ExporterIFC^ exporterIFC,
    XYZ^ origPt
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
origPt
Type: Autodesk.Revit.DB..::..XYZ
The original point.

Return Value

The transformed and scaled point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


TransformAndScaleVector Method

[image]

Revit 2013 API
ExporterIFCUtils..::..TransformAndScaleVector Method
ExporterIFCUtils Class See Also Send Feedback
Converts a vector from global Revit coordinates to current IFC coordinates, including scale.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static XYZ TransformAndScaleVector(
    ExporterIFC exporterIFC,
    XYZ origVector
)
Visual Basic
Public Shared Function TransformAndScaleVector ( _
    exporterIFC As ExporterIFC, _
    origVector As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ TransformAndScaleVector(
    ExporterIFC^ exporterIFC,
    XYZ^ origVector
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
origVector
Type: Autodesk.Revit.DB..::..XYZ
The original vector.

Return Value

The transformed and scaled point.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


UpdateBuildingPlacement Method

[image]

Revit 2013 API
ExporterIFCUtils..::..UpdateBuildingPlacement Method
ExporterIFCUtils Class See Also Send Feedback
Update building local placement to be to site local placement.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void UpdateBuildingPlacement(
    ExporterIFC exporterIFC
)
Visual Basic
Public Shared Sub UpdateBuildingPlacement ( _
    exporterIFC As ExporterIFC _
)
Visual C++
public:
static void UpdateBuildingPlacement(
    ExporterIFC^ exporterIFC
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


UsesInstanceGeometry Method

[image]

Revit 2013 API
ExporterIFCUtils..::..UsesInstanceGeometry Method
ExporterIFCUtils Class See Also Send Feedback
Identifies if the family instance has its own geometry, or uses the symbol's geometry with a transform.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool UsesInstanceGeometry(
    FamilyInstance familyInstance
)
Visual Basic
Public Shared Function UsesInstanceGeometry ( _
    familyInstance As FamilyInstance _
) As Boolean
Visual C++
public:
static bool UsesInstanceGeometry(
    FamilyInstance^ familyInstance
)

Parameters

familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.

Return Value

True if the instance has its own geometry. False if the symbol's geometry is used.

Remarks

A Family Instance can have its own copy of geometry, or use the symbol's geometry with a transform. This method identifies the source of this family instance's geometry.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


ValidateCurveLoops Method

[image]

Revit 2013 API
ExporterIFCUtils..::..ValidateCurveLoops Method
ExporterIFCUtils Class See Also Send Feedback
Does validity checks on a list of curve loops to ensure that they are all co-planar, closed, and properly oriented.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<CurveLoop> ValidateCurveLoops(
    IList<CurveLoop> curveLoops,
    XYZ extrDirVec
)
Visual Basic
Public Shared Function ValidateCurveLoops ( _
    curveLoops As IList(Of CurveLoop), _
    extrDirVec As XYZ _
) As IList(Of CurveLoop)
Visual C++
public:
static IList<CurveLoop^>^ ValidateCurveLoops(
    IList<CurveLoop^>^ curveLoops,
    XYZ^ extrDirVec
)

Parameters

curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
The loops to check.
extrDirVec
Type: Autodesk.Revit.DB..::..XYZ
The normal.

Return Value

returns the curve loops properly oriented, if possible. If not, the return contains no loops.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExporterIFCUtils Class
Autodesk.Revit.DB.IFC Namespace


IExporterIFC Interface

[image]

Revit 2013 API
IExporterIFC Interface
Members See Also Send Feedback
The interface used to implement a custom IFC exporter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public interface IExporterIFC
Visual Basic
Public Interface IExporterIFC
Visual C++
public interface class IExporterIFC

Remarks

Implement this interface and register an instance of the derived class with ExporterIFCRegistry.

See Also

IExporterIFC Members
Autodesk.Revit.DB.IFC Namespace


IExporterIFC Members

[image] [image]

Revit 2013 API
IExporterIFC Members
IExporterIFC Interface Methods See Also Send Feedback

The IExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | ExportIFC | The method that Revit will invoke to perform an export to IFC.

See Also

IExporterIFC Interface
Autodesk.Revit.DB.IFC Namespace


IExporterIFC Methods

[image] [image]

Revit 2013 API
IExporterIFC Methods
IExporterIFC Interface See Also Send Feedback

The IExporterIFC type exposes the following members.

Methods

 | Name | Description
Public method | ExportIFC | The method that Revit will invoke to perform an export to IFC.

See Also

IExporterIFC Interface
Autodesk.Revit.DB.IFC Namespace


ExportIFC Method

[image]

Revit 2013 API
IExporterIFC..::..ExportIFC Method
IExporterIFC Interface See Also Send Feedback
The method that Revit will invoke to perform an export to IFC.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void ExportIFC(
    Document document,
    ExporterIFC exporter,
    View filterView
)
Visual Basic
Sub ExportIFC ( _
    document As Document, _
    exporter As ExporterIFC, _
    filterView As View _
)
Visual C++
void ExportIFC(
    Document^ document,
    ExporterIFC^ exporter,
    View^ filterView
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document to export.
exporter
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The IFC exporter object.
filterView
Type: Autodesk.Revit.DB..::..View
The view whose filter visibility settings govern the export.

Remarks

There will be a transaction group opened for the document. Any changes made to the document must be temporary, as the transaction group will automatically be rolled back at the end.

See Also

IExporterIFC Interface
Autodesk.Revit.DB.IFC Namespace


IFCAggregate Class

[image]

Revit 2013 API
IFCAggregate Class
Members See Also Send Feedback
A collection of IFC handles or attributes.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCAggregate : IEnumerable<IFCData>,
    IDisposable
Visual Basic
Public Class IFCAggregate _
    Implements IEnumerable(Of IFCData), IDisposable
Visual C++
public ref class IFCAggregate : IEnumerable<IFCData^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCAggregate

See Also

IFCAggregate Members
Autodesk.Revit.DB.IFC Namespace


IFCAggregate Members

[image] [image]

Revit 2013 API
IFCAggregate Members
IFCAggregate Class Methods Properties See Also Send Feedback

The IFCAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the aggregate.
Public method | AddAggregate | Creates a nested aggregate and adds it to the aggregate.
Public method | Delete | Delete the aggregate object from the IFCFile model.
Public method | Dispose | Releases all resources used by the IFCAggregate
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIFCAggregateIterator | Returns a IFCAggregateIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of the data values in the aggregate.
Public property | Item | Get the IFCData for this aggregate.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


IFCAggregate Methods

[image] [image]

Revit 2013 API
IFCAggregate Methods
IFCAggregate Class See Also Send Feedback

The IFCAggregate type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an element to the aggregate.
Public method | AddAggregate | Creates a nested aggregate and adds it to the aggregate.
Public method | Delete | Delete the aggregate object from the IFCFile model.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIFCAggregateIterator | Returns a IFCAggregateIterator that iterates through the collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


Add Method

[image]

Revit 2013 API
IFCAggregate..::..Add Method
IFCAggregate Class See Also Send Feedback
Adds an element to the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Add(
    IFCData ifcData
)
Visual Basic
Public Sub Add ( _
    ifcData As IFCData _
)
Visual C++
public:
void Add(
    IFCData^ ifcData
)

Parameters

ifcData
Type: Autodesk.Revit.DB.IFC..::..IFCData
The IFCData element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The aggregate is not valid.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


AddAggregate Method

[image]

Revit 2013 API
IFCAggregate..::..AddAggregate Method
IFCAggregate Class See Also Send Feedback
Creates a nested aggregate and adds it to the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAggregate AddAggregate()
Visual Basic
Public Function AddAggregate As IFCAggregate
Visual C++
public:
IFCAggregate^ AddAggregate()

Return Value

The nested aggregate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The aggregate is not valid.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


Delete Method

[image]

Revit 2013 API
IFCAggregate..::..Delete Method
IFCAggregate Class See Also Send Feedback
Delete the aggregate object from the IFCFile model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCAggregate..::..Dispose Method
IFCAggregate Class See Also Send Feedback
Releases all resources used by the IFCAggregate

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


GetBasicIEnumerator Method

[image]

Revit 2013 API
IFCAggregate..::..GetBasicIEnumerator Method
IFCAggregate Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


GetEnumerator Method

[image]

Revit 2013 API
IFCAggregate..::..GetEnumerator Method
IFCAggregate Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<IFCData> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of IFCData)
Visual C++
public:
virtual IEnumerator<IFCData^>^ GetEnumerator()

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


GetIFCAggregateIterator Method

[image]

Revit 2013 API
IFCAggregate..::..GetIFCAggregateIterator Method
IFCAggregate Class See Also Send Feedback
Returns a IFCAggregateIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IFCAggregateIterator GetIFCAggregateIterator()
Visual Basic
Public Function GetIFCAggregateIterator As IFCAggregateIterator
Visual C++
public:
IFCAggregateIterator^ GetIFCAggregateIterator()

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


IFCAggregate Properties

[image] [image]

Revit 2013 API
IFCAggregate Properties
IFCAggregate Class See Also Send Feedback

The IFCAggregate type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of the data values in the aggregate.
Public property | Item | Get the IFCData for this aggregate.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


Count Property

[image]

Revit 2013 API
IFCAggregate..::..Count Property
IFCAggregate Class See Also Send Feedback
The number of the data values in the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


Item Property

[image]

Revit 2013 API
IFCAggregate..::..Item Property
IFCAggregate Class See Also Send Feedback
Get the IFCData for this aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IFCData this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    index As Integer _
) As IFCData
    Get
Visual C++
public:
property IFCData^ Item[int index] {
    IFCData^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index.

Return Value

The IFCData.

See Also

IFCAggregate Class
Autodesk.Revit.DB.IFC Namespace


IFCAggregateIterator Class

[image]

Revit 2013 API
IFCAggregateIterator Class
Members See Also Send Feedback
A class used to iterate individual objects in an IFCAggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCAggregateIterator : IEnumerator<IFCData>
Visual Basic
Public Class IFCAggregateIterator _
    Implements IEnumerator(Of IFCData)
Visual C++
public ref class IFCAggregateIterator : IEnumerator<IFCData^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCAggregateIterator

See Also

IFCAggregateIterator Members
Autodesk.Revit.DB.IFC Namespace


IFCAggregateIterator Members

[image] [image]

Revit 2013 API
IFCAggregateIterator Members
IFCAggregateIterator Class Methods Properties See Also Send Feedback

The IFCAggregateIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCAggregateIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Increments the iterator to the next object in the IFCAggregate.
Public method | Reset | Resets the iterator to the beginning of the aggregate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


IFCAggregateIterator Methods

[image] [image]

Revit 2013 API
IFCAggregateIterator Methods
IFCAggregateIterator Class See Also Send Feedback

The IFCAggregateIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Increments the iterator to the next object in the IFCAggregate.
Public method | Reset | Resets the iterator to the beginning of the aggregate.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCAggregateIterator..::..Dispose Method
IFCAggregateIterator Class See Also Send Feedback
Releases all resources used by the IFCAggregateIterator

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


MoveNext Method

[image]

Revit 2013 API
IFCAggregateIterator..::..MoveNext Method
IFCAggregateIterator Class See Also Send Feedback
Increments the iterator to the next object in the IFCAggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available object in this iterator. False if the iterator has completed all available objects.

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


Reset Method

[image]

Revit 2013 API
IFCAggregateIterator..::..Reset Method
IFCAggregateIterator Class See Also Send Feedback
Resets the iterator to the beginning of the aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


IFCAggregateIterator Properties

[image] [image]

Revit 2013 API
IFCAggregateIterator Properties
IFCAggregateIterator Class See Also Send Feedback

The IFCAggregateIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


Current Property

[image]

Revit 2013 API
IFCAggregateIterator..::..Current Property
IFCAggregateIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IFCData Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As IFCData
    Get
Visual C++
public:
virtual property IFCData^ Current {
    IFCData^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


CurrentObject Property

[image]

Revit 2013 API
IFCAggregateIterator..::..CurrentObject Property
IFCAggregateIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

IFCAggregateIterator Class
Autodesk.Revit.DB.IFC Namespace


IFCAnyHandle Class

[image]

Revit 2013 API
IFCAnyHandle Class
Members See Also Send Feedback
A handle representing an item in an IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCAnyHandle : IDisposable
Visual Basic
Public Class IFCAnyHandle _
    Implements IDisposable
Visual C++
public ref class IFCAnyHandle : IDisposable

Remarks

Handles are used to populate each line item in an IFC file. Each handle is assigned a unique identifier (an integer) which can be seen in the file contents at the start of the line.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCAnyHandle

See Also

IFCAnyHandle Members
Autodesk.Revit.DB.IFC Namespace


IFCAnyHandle Members

[image] [image]

Revit 2013 API
IFCAnyHandle Members
IFCAnyHandle Class Methods Operators Properties See Also Send Feedback

The IFCAnyHandle type exposes the following members.

Methods

 | Name | Description
Public method | CreateAggregateAttribute | Creates an attribute that is an aggregate.
Public method | Delete | Deletes the handle.
Public method | Dispose | Releases all resources used by the IFCAnyHandle
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetAttribute | Gets the attribute by name.
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubTypeOf | Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.
Public method | IsTypeOf | Determines whether the instance is an instance of exactly the specified instance type.
Public method | SetAttribute(String, IFCAnyHandle) | Sets the attribute value.
Public method | SetAttribute(String, IFCData) | Sets the attribute value.
Public method | SetAttribute(String, Boolean) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(IFCAnyHandle>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Boolean>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Double>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Int32>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(String>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, Double) | Sets the attribute value.
Public method | SetAttribute(String, Int32) | Sets the attribute value.
Public method | SetAttribute(String, String) | Sets the attribute value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unset | Clears the handle.
Public method | UnsetAttribute | Unsets the attribute value.

Operators

Name | Description
Equality | Determines whether two IFCAnyHandles are the same.
Inequality | Determines whether two IFCAnyHandles are different.

Properties

 | Name | Description
Public property | HasValue | Identifies if the handle is empty or contains a value.
Public property | Id | The integer identifier for the handle.
Public property | TypeName | The name of the type of the handle.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IFCAnyHandle Methods

[image] [image]

Revit 2013 API
IFCAnyHandle Methods
IFCAnyHandle Class See Also Send Feedback

The IFCAnyHandle type exposes the following members.

Methods

 | Name | Description
Public method | CreateAggregateAttribute | Creates an attribute that is an aggregate.
Public method | Delete | Deletes the handle.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetAttribute | Gets the attribute by name.
Public method | GetHashCode | Gets the integer value of the id as hash code; (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsSubTypeOf | Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.
Public method | IsTypeOf | Determines whether the instance is an instance of exactly the specified instance type.
Public method | SetAttribute(String, IFCAnyHandle) | Sets the attribute value.
Public method | SetAttribute(String, IFCData) | Sets the attribute value.
Public method | SetAttribute(String, Boolean) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(IFCAnyHandle>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Boolean>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Double>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Int32>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(String>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, Double) | Sets the attribute value.
Public method | SetAttribute(String, Int32) | Sets the attribute value.
Public method | SetAttribute(String, String) | Sets the attribute value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unset | Clears the handle.
Public method | UnsetAttribute | Unsets the attribute value.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


CreateAggregateAttribute Method

[image]

Revit 2013 API
IFCAnyHandle..::..CreateAggregateAttribute Method
IFCAnyHandle Class See Also Send Feedback
Creates an attribute that is an aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAggregate CreateAggregateAttribute(
    string name
)
Visual Basic
Public Function CreateAggregateAttribute ( _
    name As String _
) As IFCAggregate
Visual C++
public:
IFCAggregate^ CreateAggregateAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The attribute name.

Return Value

The aggregate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Delete Method

[image]

Revit 2013 API
IFCAnyHandle..::..Delete Method
IFCAnyHandle Class See Also Send Feedback
Deletes the handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Delete()
Visual Basic
Public Sub Delete
Visual C++
public:
void Delete()

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCAnyHandle..::..Dispose Method
IFCAnyHandle Class See Also Send Feedback
Releases all resources used by the IFCAnyHandle

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Equals Method

[image]

Revit 2013 API
IFCAnyHandle..::..Equals Method
IFCAnyHandle Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


GetAttribute Method

[image]

Revit 2013 API
IFCAnyHandle..::..GetAttribute Method
IFCAnyHandle Class See Also Send Feedback
Gets the attribute by name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCData GetAttribute(
    string name
)
Visual Basic
Public Function GetAttribute ( _
    name As String _
) As IFCData
Visual C++
public:
IFCData^ GetAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The name.

Return Value

The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


GetHashCode Method

[image]

Revit 2013 API
IFCAnyHandle..::..GetHashCode Method
IFCAnyHandle Class See Also Send Feedback
Gets the integer value of the id as hash code

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IsSubTypeOf Method

[image]

Revit 2013 API
IFCAnyHandle..::..IsSubTypeOf Method
IFCAnyHandle Class See Also Send Feedback
Determines whether the instance is an instance of the specified instance type or a subtype of this instance type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsSubTypeOf(
    string typeName
)
Visual Basic
Public Function IsSubTypeOf ( _
    typeName As String _
) As Boolean
Visual C++
public:
bool IsSubTypeOf(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The instance type name.

Return Value

True if the instance is an instance of the specified instance type or its subtype, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IsTypeOf Method

[image]

Revit 2013 API
IFCAnyHandle..::..IsTypeOf Method
IFCAnyHandle Class See Also Send Feedback
Determines whether the instance is an instance of exactly the specified instance type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsTypeOf(
    string typeName
)
Visual Basic
Public Function IsTypeOf ( _
    typeName As String _
) As Boolean
Visual C++
public:
bool IsTypeOf(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The instance type name.

Return Value

True if the instance is an instance of the specified instance type, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method

[image] [image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method
IFCAnyHandle Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAttribute(String, IFCAnyHandle) | Sets the attribute value.
Public method | SetAttribute(String, IFCData) | Sets the attribute value.
Public method | SetAttribute(String, Boolean) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(IFCAnyHandle>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Boolean>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Double>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(Int32>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, ICollection<(Of <<'(String>)>>)) | Sets the attribute value.
Public method | SetAttribute(String, Double) | Sets the attribute value.
Public method | SetAttribute(String, Int32) | Sets the attribute value.
Public method | SetAttribute(String, String) | Sets the attribute value.

See Also

IFCAnyHandle Class
IFCAnyHandle Members
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, IFCAnyHandle)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, IFCAnyHandle)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    IFCAnyHandle value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As IFCAnyHandle _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    IFCAnyHandle^ value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, IFCData)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, IFCData)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    IFCData value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As IFCData _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    IFCData^ value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: Autodesk.Revit.DB.IFC..::..IFCData
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, Boolean)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, Boolean)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    bool value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As Boolean _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    bool value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: System..::..Boolean
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, ICollection(IFCAnyHandle))

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'IFCAnyHandle>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<IFCAnyHandle> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of IFCAnyHandle) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<IFCAnyHandle^>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'IFCAnyHandle>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, ICollection(Boolean))

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'Boolean>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<bool> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of Boolean) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<bool>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'Boolean>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, ICollection(Double))

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'Double>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<double> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of Double) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<double>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'Double>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, ICollection(Int32))

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'Int32>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<int> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of Integer) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<int>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'Int32>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, ICollection(String))

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, ICollection<(Of <(<'String>)>)>)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    ICollection<string> values
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    values As ICollection(Of String) _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    ICollection<String^>^ values
)

Parameters

name
Type: System..::..String
The attribute name.
values
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, Double)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, Double)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    double value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As Double _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    double value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: System..::..Double
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, Int32)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, Int32)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    int value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As Integer _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    int value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: System..::..Int32
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


SetAttribute Method (String, String)

[image]

Revit 2013 API
IFCAnyHandle..::..SetAttribute Method (String, String)
IFCAnyHandle Class See Also Send Feedback
Sets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetAttribute(
    string name,
    string value
)
Visual Basic
Public Sub SetAttribute ( _
    name As String, _
    value As String _
)
Visual C++
public:
void SetAttribute(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::..String
The attribute name.
value
Type: System..::..String
The value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
SetAttribute Overload
Autodesk.Revit.DB.IFC Namespace


Unset Method

[image]

Revit 2013 API
IFCAnyHandle..::..Unset Method
IFCAnyHandle Class See Also Send Feedback
Clears the handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Unset()
Visual Basic
Public Sub Unset
Visual C++
public:
void Unset()

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


UnsetAttribute Method

[image]

Revit 2013 API
IFCAnyHandle..::..UnsetAttribute Method
IFCAnyHandle Class See Also Send Feedback
Unsets the attribute value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void UnsetAttribute(
    string name
)
Visual Basic
Public Sub UnsetAttribute ( _
    name As String _
)
Visual C++
public:
void UnsetAttribute(
    String^ name
)

Parameters

name
Type: System..::..String
The attribute name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IFCAnyHandle Operators

[image] [image]

Revit 2013 API
IFCAnyHandle Operators
IFCAnyHandle Class See Also Send Feedback

The IFCAnyHandle type exposes the following members.

Operators

Name | Description
Equality | Determines whether two IFCAnyHandles are the same.
Inequality | Determines whether two IFCAnyHandles are different.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Equality Operator

[image]

Revit 2013 API
IFCAnyHandle..::..Equality Operator
IFCAnyHandle Class See Also Send Feedback
Determines whether two IFCAnyHandles are the same.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    IFCAnyHandle first,
    IFCAnyHandle second
)
Visual Basic
Public Shared Operator = ( _
    first As IFCAnyHandle, _
    second As IFCAnyHandle _
) As Boolean
Visual C++
public:
static bool operator ==(
    IFCAnyHandle^ first,
    IFCAnyHandle^ second
)

Parameters

first
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The first IFCAnyHandle.
second
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The second IFCAnyHandle.

Return Value

True if the IFCAnyHandles are the same; otherwise, false.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Inequality Operator

[image]

Revit 2013 API
IFCAnyHandle..::..Inequality Operator
IFCAnyHandle Class See Also Send Feedback
Determines whether two IFCAnyHandles are different.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    IFCAnyHandle first,
    IFCAnyHandle second
)
Visual Basic
Public Shared Operator <> ( _
    first As IFCAnyHandle, _
    second As IFCAnyHandle _
) As Boolean
Visual C++
public:
static bool operator !=(
    IFCAnyHandle^ first,
    IFCAnyHandle^ second
)

Parameters

first
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The first IFCAnyHandle.
second
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The second IFCAnyHandle.

Return Value

True if the IFCAnyHandles are different; otherwise, false.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IFCAnyHandle Properties

[image] [image]

Revit 2013 API
IFCAnyHandle Properties
IFCAnyHandle Class See Also Send Feedback

The IFCAnyHandle type exposes the following members.

Properties

 | Name | Description
Public property | HasValue | Identifies if the handle is empty or contains a value.
Public property | Id | The integer identifier for the handle.
Public property | TypeName | The name of the type of the handle.

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


HasValue Property

[image]

Revit 2013 API
IFCAnyHandle..::..HasValue Property
IFCAnyHandle Class See Also Send Feedback
Identifies if the handle is empty or contains a value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


Id Property

[image]

Revit 2013 API
IFCAnyHandle..::..Id Property
IFCAnyHandle Class See Also Send Feedback
The integer identifier for the handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Id { get; }
Visual Basic
Public ReadOnly Property Id As Integer
    Get
Visual C++
public:
property int Id {
    int get ();
}

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


TypeName Property

[image]

Revit 2013 API
IFCAnyHandle..::..TypeName Property
IFCAnyHandle Class See Also Send Feedback
The name of the type of the handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string TypeName { get; }
Visual Basic
Public ReadOnly Property TypeName As String
    Get
Visual C++
public:
property String^ TypeName {
    String^ get ();
}

See Also

IFCAnyHandle Class
Autodesk.Revit.DB.IFC Namespace


IFCConnectedWallData Class

[image]

Revit 2013 API
IFCConnectedWallData Class
Members See Also Send Feedback
A class that contains the IFC-specific information about how an element is joined to another element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCConnectedWallData : IDisposable
Visual Basic
Public Class IFCConnectedWallData _
    Implements IDisposable
Visual C++
public ref class IFCConnectedWallData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCConnectedWallData

See Also

IFCConnectedWallData Members
Autodesk.Revit.DB.IFC Namespace


IFCConnectedWallData Members

[image] [image]

Revit 2013 API
IFCConnectedWallData Members
IFCConnectedWallData Class Methods Properties See Also Send Feedback

The IFCConnectedWallData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCConnectedWallData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElementId | The element id to which this element is joined.
Public property | Location | The location for the join.

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


IFCConnectedWallData Methods

[image] [image]

Revit 2013 API
IFCConnectedWallData Methods
IFCConnectedWallData Class See Also Send Feedback

The IFCConnectedWallData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCConnectedWallData..::..Dispose Method
IFCConnectedWallData Class See Also Send Feedback
Releases all resources used by the IFCConnectedWallData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


IFCConnectedWallData Properties

[image] [image]

Revit 2013 API
IFCConnectedWallData Properties
IFCConnectedWallData Class See Also Send Feedback

The IFCConnectedWallData type exposes the following members.

Properties

 | Name | Description
Public property | ElementId | The element id to which this element is joined.
Public property | Location | The location for the join.

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


ElementId Property

[image]

Revit 2013 API
IFCConnectedWallData..::..ElementId Property
IFCConnectedWallData Class See Also Send Feedback
The element id to which this element is joined.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId ElementId { get; }
Visual Basic
Public ReadOnly Property ElementId As ElementId
    Get
Visual C++
public:
property ElementId^ ElementId {
    ElementId^ get ();
}

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


Location Property

[image]

Revit 2013 API
IFCConnectedWallData..::..Location Property
IFCConnectedWallData Class See Also Send Feedback
The location for the join.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCConnectedWallDataLocation Location { get; }
Visual Basic
Public ReadOnly Property Location As IFCConnectedWallDataLocation
    Get
Visual C++
public:
property IFCConnectedWallDataLocation Location {
    IFCConnectedWallDataLocation get ();
}

See Also

IFCConnectedWallData Class
Autodesk.Revit.DB.IFC Namespace


IFCConnectedWallDataLocation Enumeration

[image]

Revit 2013 API
IFCConnectedWallDataLocation Enumeration
See Also Send Feedback
An enumerated type that represents the location where an element is connected to a wall.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum IFCConnectedWallDataLocation
Visual Basic
Public Enumeration IFCConnectedWallDataLocation
Visual C++
public enum class IFCConnectedWallDataLocation

Members

Member name | Description
Path | The conection is at some point along the path of the location line.
Start | The connection is at the start of the wall location line.
End | The connection is at the end of the wall location line.
NotDefined | The connection type is not defined for this connection.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCData Class

[image]

Revit 2013 API
IFCData Class
Members See Also Send Feedback
A specialized type of abstract data block that can represent any data type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCData : IDisposable
Visual Basic
Public Class IFCData _
    Implements IDisposable
Visual C++
public ref class IFCData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCData

See Also

IFCData Members
Autodesk.Revit.DB.IFC Namespace


IFCData Members

[image] [image]

Revit 2013 API
IFCData Members
IFCData Class Constructors Methods Operators Properties See Also Send Feedback

The IFCData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCData | Creates a copy object.

Methods

 | Name | Description
Public method | AsAggregate | Gets storage value as IFCAggregate when its PrimitiveType is aggregate.
Public method | AsBoolean | Gets storage value as boolean when its PrimitiveType is boolean.
Public method | AsDouble | Gets storage value as double when its PrimitiveType is double.
Public method | AsInstance | Gets storage value as IFCAnyHandle when its PrimitiveType is instance.
Public method | AsInteger | Gets storage value as integer when its PrimitiveType is integer.
Public method | AsLogical | Gets storage value as IFCLogical when its PrimitiveType is logical.
Public method | AsString | Gets storage value as string when its PrimitiveType is string, binary or enumeration.
 | CreateBinary | Creates a binary data object.
 | CreateBoolean | Creates a boolean data object.
 | CreateBooleanOfType | Creates a boolean data object of the specified type.
 | CreateDouble | Creates a double data object.
 | CreateDoubleOfType | Creates a double data object of the specified type.
 | CreateEnumeration | Creates a enum data object.
 | CreateIFCAggregate | Creates an IFCAggregate data object.
 | CreateIFCAnyHandle | Creates an IFCAnyHandle data object.
 | CreateInteger | Creates an integer data object.
 | CreateIntegerOfType | Creates an integer data object of the specified type.
 | CreateLogical | Creates a logical data object.
 | CreateString | Creates a string data object.
 | CreateStringOfType | Creates a string data object of the specified type.
Public method | Dispose | Releases all resources used by the IFCData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetSimpleType | Gets the IFC type name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeList | Gets the multiple strings represent one IFC type name.
Public method | SetSimpleType | Sets the corresponding IFC type by its name.
Public method | SetTypeList | Sets the corresponding IFC type by its type list name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality | Determines whether two IFCDatas are the same.
Inequality | Determines whether two IFCDatas are different.

Properties

 | Name | Description
Public property | HasValue | Identifies if the data is empty or contains a value.
Public property | PrimitiveType | The primitive data type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


IFCData Constructor

[image]

Revit 2013 API
IFCData Constructor
IFCData Class See Also Send Feedback
Creates a copy object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCData(
    IFCData from
)
Visual Basic
Public Sub New ( _
    from As IFCData _
)
Visual C++
public:
IFCData(
    IFCData^ from
)

Parameters

from
Type: Autodesk.Revit.DB.IFC..::..IFCData
The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


IFCData Methods

[image] [image]

Revit 2013 API
IFCData Methods
IFCData Class See Also Send Feedback

The IFCData type exposes the following members.

Methods

 | Name | Description
Public method | AsAggregate | Gets storage value as IFCAggregate when its PrimitiveType is aggregate.
Public method | AsBoolean | Gets storage value as boolean when its PrimitiveType is boolean.
Public method | AsDouble | Gets storage value as double when its PrimitiveType is double.
Public method | AsInstance | Gets storage value as IFCAnyHandle when its PrimitiveType is instance.
Public method | AsInteger | Gets storage value as integer when its PrimitiveType is integer.
Public method | AsLogical | Gets storage value as IFCLogical when its PrimitiveType is logical.
Public method | AsString | Gets storage value as string when its PrimitiveType is string, binary or enumeration.
 | CreateBinary | Creates a binary data object.
 | CreateBoolean | Creates a boolean data object.
 | CreateBooleanOfType | Creates a boolean data object of the specified type.
 | CreateDouble | Creates a double data object.
 | CreateDoubleOfType | Creates a double data object of the specified type.
 | CreateEnumeration | Creates a enum data object.
 | CreateIFCAggregate | Creates an IFCAggregate data object.
 | CreateIFCAnyHandle | Creates an IFCAnyHandle data object.
 | CreateInteger | Creates an integer data object.
 | CreateIntegerOfType | Creates an integer data object of the specified type.
 | CreateLogical | Creates a logical data object.
 | CreateString | Creates a string data object.
 | CreateStringOfType | Creates a string data object of the specified type.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Gets the hash code. (Overrides Object..::..GetHashCode()()()().)
Public method | GetSimpleType | Gets the IFC type name.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeList | Gets the multiple strings represent one IFC type name.
Public method | SetSimpleType | Sets the corresponding IFC type by its name.
Public method | SetTypeList | Sets the corresponding IFC type by its type list name.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsAggregate Method

[image]

Revit 2013 API
IFCData..::..AsAggregate Method
IFCData Class See Also Send Feedback
Gets storage value as IFCAggregate when its PrimitiveType is aggregate.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAggregate AsAggregate()
Visual Basic
Public Function AsAggregate As IFCAggregate
Visual C++
public:
IFCAggregate^ AsAggregate()

Return Value

The IFCAggregate.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not aggregate.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsBoolean Method

[image]

Revit 2013 API
IFCData..::..AsBoolean Method
IFCData Class See Also Send Feedback
Gets storage value as boolean when its PrimitiveType is boolean.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AsBoolean()
Visual Basic
Public Function AsBoolean As Boolean
Visual C++
public:
bool AsBoolean()

Return Value

The bool value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not boolean.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsDouble Method

[image]

Revit 2013 API
IFCData..::..AsDouble Method
IFCData Class See Also Send Feedback
Gets storage value as double when its PrimitiveType is double.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double AsDouble()
Visual Basic
Public Function AsDouble As Double
Visual C++
public:
double AsDouble()

Return Value

The double value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not double.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsInstance Method

[image]

Revit 2013 API
IFCData..::..AsInstance Method
IFCData Class See Also Send Feedback
Gets storage value as IFCAnyHandle when its PrimitiveType is instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle AsInstance()
Visual Basic
Public Function AsInstance As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ AsInstance()

Return Value

The IFCAnyHandle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not instance.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsInteger Method

[image]

Revit 2013 API
IFCData..::..AsInteger Method
IFCData Class See Also Send Feedback
Gets storage value as integer when its PrimitiveType is integer.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int AsInteger()
Visual Basic
Public Function AsInteger As Integer
Visual C++
public:
int AsInteger()

Return Value

The int value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not integer.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsLogical Method

[image]

Revit 2013 API
IFCData..::..AsLogical Method
IFCData Class See Also Send Feedback
Gets storage value as IFCLogical when its PrimitiveType is logical.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCLogical AsLogical()
Visual Basic
Public Function AsLogical As IFCLogical
Visual C++
public:
IFCLogical AsLogical()

Return Value

The IFCLogical value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not logical.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


AsString Method

[image]

Revit 2013 API
IFCData..::..AsString Method
IFCData Class See Also Send Feedback
Gets storage value as string when its PrimitiveType is string, binary or enumeration.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string AsString()
Visual Basic
Public Function AsString As String
Visual C++
public:
String^ AsString()

Return Value

The string value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | The primitive type is not string, binary or enumeration.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateBinary Method

[image]

Revit 2013 API
IFCData..::..CreateBinary Method
IFCData Class See Also Send Feedback
Creates a binary data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateBinary(
    string value
)
Visual Basic
Public Shared Function CreateBinary ( _
    value As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateBinary(
    String^ value
)

Parameters

value
Type: System..::..String
The string value.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateBoolean Method

[image]

Revit 2013 API
IFCData..::..CreateBoolean Method
IFCData Class See Also Send Feedback
Creates a boolean data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateBoolean(
    bool value
)
Visual Basic
Public Shared Function CreateBoolean ( _
    value As Boolean _
) As IFCData
Visual C++
public:
static IFCData^ CreateBoolean(
    bool value
)

Parameters

value
Type: System..::..Boolean
The boolean value.

Return Value

The IFCData object.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateBooleanOfType Method

[image]

Revit 2013 API
IFCData..::..CreateBooleanOfType Method
IFCData Class See Also Send Feedback
Creates a boolean data object of the specified type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateBooleanOfType(
    bool value,
    string typeName
)
Visual Basic
Public Shared Function CreateBooleanOfType ( _
    value As Boolean, _
    typeName As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateBooleanOfType(
    bool value,
    String^ typeName
)

Parameters

value
Type: System..::..Boolean
The boolean value.
typeName
Type: System..::..String
The type name.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateDouble Method

[image]

Revit 2013 API
IFCData..::..CreateDouble Method
IFCData Class See Also Send Feedback
Creates a double data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateDouble(
    double value
)
Visual Basic
Public Shared Function CreateDouble ( _
    value As Double _
) As IFCData
Visual C++
public:
static IFCData^ CreateDouble(
    double value
)

Parameters

value
Type: System..::..Double
The double value.

Return Value

The IFCData object.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateDoubleOfType Method

[image]

Revit 2013 API
IFCData..::..CreateDoubleOfType Method
IFCData Class See Also Send Feedback
Creates a double data object of the specified type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateDoubleOfType(
    double value,
    string typeName
)
Visual Basic
Public Shared Function CreateDoubleOfType ( _
    value As Double, _
    typeName As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateDoubleOfType(
    double value,
    String^ typeName
)

Parameters

value
Type: System..::..Double
The double value.
typeName
Type: System..::..String
The type name.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateEnumeration Method

[image]

Revit 2013 API
IFCData..::..CreateEnumeration Method
IFCData Class See Also Send Feedback
Creates a enum data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateEnumeration(
    string value
)
Visual Basic
Public Shared Function CreateEnumeration ( _
    value As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateEnumeration(
    String^ value
)

Parameters

value
Type: System..::..String
The string value.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateIFCAggregate Method

[image]

Revit 2013 API
IFCData..::..CreateIFCAggregate Method
IFCData Class See Also Send Feedback
Creates an IFCAggregate data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateIFCAggregate(
    IFCAggregate value
)
Visual Basic
Public Shared Function CreateIFCAggregate ( _
    value As IFCAggregate _
) As IFCData
Visual C++
public:
static IFCData^ CreateIFCAggregate(
    IFCAggregate^ value
)

Parameters

value
Type: Autodesk.Revit.DB.IFC..::..IFCAggregate
The IFCAggregate value.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateIFCAnyHandle Method

[image]

Revit 2013 API
IFCData..::..CreateIFCAnyHandle Method
IFCData Class See Also Send Feedback
Creates an IFCAnyHandle data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateIFCAnyHandle(
    IFCAnyHandle value
)
Visual Basic
Public Shared Function CreateIFCAnyHandle ( _
    value As IFCAnyHandle _
) As IFCData
Visual C++
public:
static IFCData^ CreateIFCAnyHandle(
    IFCAnyHandle^ value
)

Parameters

value
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IFCAnyHandle value.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateInteger Method

[image]

Revit 2013 API
IFCData..::..CreateInteger Method
IFCData Class See Also Send Feedback
Creates an integer data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateInteger(
    int value
)
Visual Basic
Public Shared Function CreateInteger ( _
    value As Integer _
) As IFCData
Visual C++
public:
static IFCData^ CreateInteger(
    int value
)

Parameters

value
Type: System..::..Int32
The integer value.

Return Value

The IFCData object.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateIntegerOfType Method

[image]

Revit 2013 API
IFCData..::..CreateIntegerOfType Method
IFCData Class See Also Send Feedback
Creates an integer data object of the specified type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateIntegerOfType(
    int value,
    string typeName
)
Visual Basic
Public Shared Function CreateIntegerOfType ( _
    value As Integer, _
    typeName As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateIntegerOfType(
    int value,
    String^ typeName
)

Parameters

value
Type: System..::..Int32
The integer value.
typeName
Type: System..::..String
The type name.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateLogical Method

[image]

Revit 2013 API
IFCData..::..CreateLogical Method
IFCData Class See Also Send Feedback
Creates a logical data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateLogical(
    IFCLogical value
)
Visual Basic
Public Shared Function CreateLogical ( _
    value As IFCLogical _
) As IFCData
Visual C++
public:
static IFCData^ CreateLogical(
    IFCLogical value
)

Parameters

value
Type: Autodesk.Revit.DB.IFC..::..IFCLogical
The IFCLogical value.

Return Value

The IFCData object.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateString Method

[image]

Revit 2013 API
IFCData..::..CreateString Method
IFCData Class See Also Send Feedback
Creates a string data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateString(
    string value
)
Visual Basic
Public Shared Function CreateString ( _
    value As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateString(
    String^ value
)

Parameters

value
Type: System..::..String
The string value.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


CreateStringOfType Method

[image]

Revit 2013 API
IFCData..::..CreateStringOfType Method
IFCData Class See Also Send Feedback
Creates a string data object of the specified type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCData CreateStringOfType(
    string value,
    string typeName
)
Visual Basic
Public Shared Function CreateStringOfType ( _
    value As String, _
    typeName As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateStringOfType(
    String^ value,
    String^ typeName
)

Parameters

value
Type: System..::..String
The string value.
typeName
Type: System..::..String
The type name.

Return Value

The IFCData object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCData..::..Dispose Method
IFCData Class See Also Send Feedback
Releases all resources used by the IFCData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


Equals Method

[image]

Revit 2013 API
IFCData..::..Equals Method
IFCData Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another object.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


GetHashCode Method

[image]

Revit 2013 API
IFCData..::..GetHashCode Method
IFCData Class See Also Send Feedback
Gets the hash code.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


GetSimpleType Method

[image]

Revit 2013 API
IFCData..::..GetSimpleType Method
IFCData Class See Also Send Feedback
Gets the IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetSimpleType()
Visual Basic
Public Function GetSimpleType As String
Visual C++
public:
String^ GetSimpleType()

Return Value

The name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | No type assigned or it is not a simple type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


GetTypeList Method

[image]

Revit 2013 API
IFCData..::..GetTypeList Method
IFCData Class See Also Send Feedback
Gets the multiple strings represent one IFC type name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<string> GetTypeList()
Visual Basic
Public Function GetTypeList As IList(Of String)
Visual C++
public:
IList<String^>^ GetTypeList()

Return Value

The strings.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | No type assigned or it is a simple type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


SetSimpleType Method

[image]

Revit 2013 API
IFCData..::..SetSimpleType Method
IFCData Class See Also Send Feedback
Sets the corresponding IFC type by its name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetSimpleType(
    string typeName
)
Visual Basic
Public Sub SetSimpleType ( _
    typeName As String _
)
Visual C++
public:
void SetSimpleType(
    String^ typeName
)

Parameters

typeName
Type: System..::..String
The name of the type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


SetTypeList Method

[image]

Revit 2013 API
IFCData..::..SetTypeList Method
IFCData Class See Also Send Feedback
Sets the corresponding IFC type by its type list name.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetTypeList(
    IList<string> typeList
)
Visual Basic
Public Sub SetTypeList ( _
    typeList As IList(Of String) _
)
Visual C++
public:
void SetTypeList(
    IList<String^>^ typeList
)

Parameters

typeList
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
The strings represent the name.

Remarks

This sets the IFC type represented by a string list. For example, DIMENSION(DIAMETER(INCH(5.0))). It's primitive type is double and the value is 5.0. Its IFC type is DIMENSION/DIAMETER/INCH. The string list represents the type is "DIMENSION"-"DIAMETER"-"INCH".

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


IFCData Operators

[image] [image]

Revit 2013 API
IFCData Operators
IFCData Class See Also Send Feedback

The IFCData type exposes the following members.

Operators

Name | Description
Equality | Determines whether two IFCDatas are the same.
Inequality | Determines whether two IFCDatas are different.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


Equality Operator

[image]

Revit 2013 API
IFCData..::..Equality Operator
IFCData Class See Also Send Feedback
Determines whether two IFCDatas are the same.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator ==(
    IFCData first,
    IFCData second
)
Visual Basic
Public Shared Operator = ( _
    first As IFCData, _
    second As IFCData _
) As Boolean
Visual C++
public:
static bool operator ==(
    IFCData^ first,
    IFCData^ second
)

Parameters

first
Type: Autodesk.Revit.DB.IFC..::..IFCData
The first IFCData.
second
Type: Autodesk.Revit.DB.IFC..::..IFCData
The second IFCData.

Return Value

True if the IFCDatas are the same; otherwise, false.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


Inequality Operator

[image]

Revit 2013 API
IFCData..::..Inequality Operator
IFCData Class See Also Send Feedback
Determines whether two IFCDatas are different.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool operator !=(
    IFCData first,
    IFCData second
)
Visual Basic
Public Shared Operator <> ( _
    first As IFCData, _
    second As IFCData _
) As Boolean
Visual C++
public:
static bool operator !=(
    IFCData^ first,
    IFCData^ second
)

Parameters

first
Type: Autodesk.Revit.DB.IFC..::..IFCData
The first IFCData.
second
Type: Autodesk.Revit.DB.IFC..::..IFCData
The second IFCData.

Return Value

True if the IFCDatas are different; otherwise, false.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


IFCData Properties

[image] [image]

Revit 2013 API
IFCData Properties
IFCData Class See Also Send Feedback

The IFCData type exposes the following members.

Properties

 | Name | Description
Public property | HasValue | Identifies if the data is empty or contains a value.
Public property | PrimitiveType | The primitive data type.

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


HasValue Property

[image]

Revit 2013 API
IFCData..::..HasValue Property
IFCData Class See Also Send Feedback
Identifies if the data is empty or contains a value.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasValue { get; }
Visual Basic
Public ReadOnly Property HasValue As Boolean
    Get
Visual C++
public:
property bool HasValue {
    bool get ();
}

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


PrimitiveType Property

[image]

Revit 2013 API
IFCData..::..PrimitiveType Property
IFCData Class See Also Send Feedback
The primitive data type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCDataPrimitiveType PrimitiveType { get; set; }
Visual Basic
Public Property PrimitiveType As IFCDataPrimitiveType
    Get
    Set
Visual C++
public:
property IFCDataPrimitiveType PrimitiveType {
    IFCDataPrimitiveType get ();
    void set (IFCDataPrimitiveType value);
}

See Also

IFCData Class
Autodesk.Revit.DB.IFC Namespace


IFCDataPrimitiveType Enumeration

[image]

Revit 2013 API
IFCDataPrimitiveType Enumeration
See Also Send Feedback
Used in operations to specify the primitive type of an IFCData.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum IFCDataPrimitiveType
Visual Basic
Public Enumeration IFCDataPrimitiveType
Visual C++
public enum class IFCDataPrimitiveType

Members

Member name | Description
Integer | Integer.
Double | Double.
Boolean | Boolean.
Logical | IFCLogical type.
String | String.
Binary | Binary. When reading or writing an IFCData of primitive type Binary, the value will be the string representation of the binary value as seen in the IFC specification.
Enumeration | Enumeration. When reading or writing an IFCData of primitive type Enumeration, the value will be the string representation of the enumeration value as seen in the IFC specification.
Instance | Represents IFCAnyHandle.
Aggregate | Represents IFCAggregate.
Unknown | Unknown.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCDoorStyleOperation Enumeration

[image]

Revit 2013 API
IFCDoorStyleOperation Enumeration
See Also Send Feedback
The types of door operations, as defined in IFC2x3. This relates to how the door opens.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum IFCDoorStyleOperation
Visual Basic
Public Enumeration IFCDoorStyleOperation
Visual C++
public enum class IFCDoorStyleOperation

Members

Member name | Description
SingleSwingLeft | Single swing door to the left.
SingleSwingRight | Single swing door to the right.
DoubleDoorSingleSwing | Double door, single swing.
DoubleDoorSingleSwingOppositeLeft | Double door, single swing opposite left.
DoubleDoorSingleSwingOppositeRight | Double door, single swing opposite right.
DoubleSwingLeft | Double door swing left.
DoubleSwingRight | Double door swing right.
DoubleDoorDoubleSwing | Double door double swing.
SlidingToLeft | Sliding door, sliding to the left.
SlidingToRight | Sliding door, sliding to the right.
DoubleDoorSliding | Sliding double door.
FoldingToLeft | Folding door to the left.
FoldingToRight | Folding door to the right.
DoubleDoorFolding | Double folding door.
Revolving | Revolving Door.
RollingUp | Door rolls up.
UserDefined | User-defined door operation.
NotDefined | Undefined door operation.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCDoorWindowInfo Class

[image]

Revit 2013 API
IFCDoorWindowInfo Class
Members See Also Send Feedback
Represents information used by IFC export of door and window family instances.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCDoorWindowInfo : IDisposable
Visual Basic
Public Class IFCDoorWindowInfo _
    Implements IDisposable
Visual C++
public ref class IFCDoorWindowInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCDoorWindowInfo

See Also

IFCDoorWindowInfo Members
Autodesk.Revit.DB.IFC Namespace


IFCDoorWindowInfo Members

[image] [image]

Revit 2013 API
IFCDoorWindowInfo Members
IFCDoorWindowInfo Class Methods Properties See Also Send Feedback

The IFCDoorWindowInfo type exposes the following members.

Methods

 | Name | Description
 | CreateDoorInfo | Creates a new instance of IFCDoorWindowInfo representing a door to be exported.
 | CreateWindowInfo | Creates a new instance of IFCDoorWindowInfo representing a window to be exported.
Public method | Dispose | Releases all resources used by the IFCDoorWindowInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Obtains the IfcLocalPlacement handle stored with this door/window info.
Public method | GetOpening | Obtains the handle to the IfcOpeningElement handle stored within this door/window info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDelayedFamilyInstance |
Public method | SetLocalPlacement | Sets the IfcLocalPlacement handle stored with this door/window info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedLevelId | The level id assigned to this instance.
Public property | DoorOperationType | The door operation type calculated for the door instance.
Public property | HostId | The id of the host element of the door or window.
Public property | InsertId | The id of the door or window element.
Public property | IsFlippedInX | True if the door or window is flipped in the X direction, false otherwise.
Public property | IsFlippedInY | True if the door or window is flipped in the Y direction, false otherwise.
Public property | IsSymbolFlipped | True if the element type geometry for the door or window should be flipped, false otherwise.
Public property | NeedsOpening | True if the door or window should be exported related to a rectangular opening in the host wall, false otherwise.
Public property | OpeningHeight | The height of the opening.
Public property | OpeningWidth | The width of the opening.
Public property | RepresentsDoor | True if the information is related to door export, false if it related to window export.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCDoorWindowInfo Methods

[image] [image]

Revit 2013 API
IFCDoorWindowInfo Methods
IFCDoorWindowInfo Class See Also Send Feedback

The IFCDoorWindowInfo type exposes the following members.

Methods

 | Name | Description
 | CreateDoorInfo | Creates a new instance of IFCDoorWindowInfo representing a door to be exported.
 | CreateWindowInfo | Creates a new instance of IFCDoorWindowInfo representing a window to be exported.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Obtains the IfcLocalPlacement handle stored with this door/window info.
Public method | GetOpening | Obtains the handle to the IfcOpeningElement handle stored within this door/window info.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetDelayedFamilyInstance |
Public method | SetLocalPlacement | Sets the IfcLocalPlacement handle stored with this door/window info.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


CreateDoorInfo Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..CreateDoorInfo Method
IFCDoorWindowInfo Class See Also Send Feedback
Creates a new instance of IFCDoorWindowInfo representing a door to be exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCDoorWindowInfo CreateDoorInfo(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    FamilySymbol familyType,
    HostObject hostObj,
    ElementId overrideLevelId,
    Transform trf
)
Visual Basic
Public Shared Function CreateDoorInfo ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    familyType As FamilySymbol, _
    hostObj As HostObject, _
    overrideLevelId As ElementId, _
    trf As Transform _
) As IFCDoorWindowInfo
Visual C++
public:
static IFCDoorWindowInfo^ CreateDoorInfo(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    FamilySymbol^ familyType,
    HostObject^ hostObj,
    ElementId^ overrideLevelId,
    Transform^ trf
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter handle.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The door instance.
familyType
Type: Autodesk.Revit.DB..::..FamilySymbol
The door element type.
hostObj
Type: Autodesk.Revit.DB..::..HostObject
The host for the door. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) the door will be considered unhosted in the output.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id for the level to associate to the door. If InvalidElementId, this will be obtained from the instance itself.
trf
Type: Autodesk.Revit.DB..::..Transform
Transform of the door instance.

Return Value

The new IFCDoorWindowInfo handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


CreateWindowInfo Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..CreateWindowInfo Method
IFCDoorWindowInfo Class See Also Send Feedback
Creates a new instance of IFCDoorWindowInfo representing a window to be exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCDoorWindowInfo CreateWindowInfo(
    ExporterIFC exporterIFC,
    FamilyInstance familyInstance,
    FamilySymbol FamilyType,
    HostObject hostObj,
    ElementId overrideLevelId,
    Transform trf
)
Visual Basic
Public Shared Function CreateWindowInfo ( _
    exporterIFC As ExporterIFC, _
    familyInstance As FamilyInstance, _
    FamilyType As FamilySymbol, _
    hostObj As HostObject, _
    overrideLevelId As ElementId, _
    trf As Transform _
) As IFCDoorWindowInfo
Visual C++
public:
static IFCDoorWindowInfo^ CreateWindowInfo(
    ExporterIFC^ exporterIFC,
    FamilyInstance^ familyInstance,
    FamilySymbol^ FamilyType,
    HostObject^ hostObj,
    ElementId^ overrideLevelId,
    Transform^ trf
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter handle.
familyInstance
Type: Autodesk.Revit.DB..::..FamilyInstance
The window instance.
FamilyType
Type: Autodesk.Revit.DB..::..FamilySymbol
The window element type.
hostObj
Type: Autodesk.Revit.DB..::..HostObject
The host for the window. Optional, if nullNothingnullptra null reference (Nothing in Visual Basic) the window will be considered unhosted in the output.
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
Id for the level to associate to the window. If InvalidElementId, this will be obtained from the instance itself.
trf
Type: Autodesk.Revit.DB..::..Transform
Transform of the window instance.

Return Value

The new IFCDoorWindowInfo handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..Dispose Method
IFCDoorWindowInfo Class See Also Send Feedback
Releases all resources used by the IFCDoorWindowInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


GetLocalPlacement Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..GetLocalPlacement Method
IFCDoorWindowInfo Class See Also Send Feedback
Obtains the IfcLocalPlacement handle stored with this door/window info.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetLocalPlacement()
Visual Basic
Public Function GetLocalPlacement As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetLocalPlacement()

Return Value

The local placement handle.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


GetOpening Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..GetOpening Method
IFCDoorWindowInfo Class See Also Send Feedback
Obtains the handle to the IfcOpeningElement handle stored within this door/window info.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetOpening()
Visual Basic
Public Function GetOpening As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetOpening()

Return Value

The opening element handle.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


SetDelayedFamilyInstance Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..SetDelayedFamilyInstance Method
IFCDoorWindowInfo Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool SetDelayedFamilyInstance(
    IFCAnyHandle instanceHandle,
    IFCAnyHandle localPlacement,
    ElementId levelId
)
Visual Basic
Public Function SetDelayedFamilyInstance ( _
    instanceHandle As IFCAnyHandle, _
    localPlacement As IFCAnyHandle, _
    levelId As ElementId _
) As Boolean
Visual C++
public:
bool SetDelayedFamilyInstance(
    IFCAnyHandle^ instanceHandle,
    IFCAnyHandle^ localPlacement,
    ElementId^ levelId
)

Parameters

instanceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
levelId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


SetLocalPlacement Method

[image]

Revit 2013 API
IFCDoorWindowInfo..::..SetLocalPlacement Method
IFCDoorWindowInfo Class See Also Send Feedback
Sets the IfcLocalPlacement handle stored with this door/window info.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetLocalPlacement(
    IFCAnyHandle localPlacement
)
Visual Basic
Public Sub SetLocalPlacement ( _
    localPlacement As IFCAnyHandle _
)
Visual C++
public:
void SetLocalPlacement(
    IFCAnyHandle^ localPlacement
)

Parameters

localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The local placement handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCDoorWindowInfo Properties

[image] [image]

Revit 2013 API
IFCDoorWindowInfo Properties
IFCDoorWindowInfo Class See Also Send Feedback

The IFCDoorWindowInfo type exposes the following members.

Properties

 | Name | Description
Public property | AssignedLevelId | The level id assigned to this instance.
Public property | DoorOperationType | The door operation type calculated for the door instance.
Public property | HostId | The id of the host element of the door or window.
Public property | InsertId | The id of the door or window element.
Public property | IsFlippedInX | True if the door or window is flipped in the X direction, false otherwise.
Public property | IsFlippedInY | True if the door or window is flipped in the Y direction, false otherwise.
Public property | IsSymbolFlipped | True if the element type geometry for the door or window should be flipped, false otherwise.
Public property | NeedsOpening | True if the door or window should be exported related to a rectangular opening in the host wall, false otherwise.
Public property | OpeningHeight | The height of the opening.
Public property | OpeningWidth | The width of the opening.
Public property | RepresentsDoor | True if the information is related to door export, false if it related to window export.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


AssignedLevelId Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..AssignedLevelId Property
IFCDoorWindowInfo Class See Also Send Feedback
The level id assigned to this instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId AssignedLevelId { get; }
Visual Basic
Public ReadOnly Property AssignedLevelId As ElementId
    Get
Visual C++
public:
property ElementId^ AssignedLevelId {
    ElementId^ get ();
}

Remarks

This may have been obtained from the instance, or overridden with the overrideLevelId parameter during creation. Revit may assign a different level id if there are duplicates found at the same location.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


DoorOperationType Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..DoorOperationType Property
IFCDoorWindowInfo Class See Also Send Feedback
The door operation type calculated for the door instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCDoorStyleOperation DoorOperationType { get; }
Visual Basic
Public ReadOnly Property DoorOperationType As IFCDoorStyleOperation
    Get
Visual C++
public:
property IFCDoorStyleOperation DoorOperationType {
    IFCDoorStyleOperation get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


HostId Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..HostId Property
IFCDoorWindowInfo Class See Also Send Feedback
The id of the host element of the door or window.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId HostId { get; }
Visual Basic
Public ReadOnly Property HostId As ElementId
    Get
Visual C++
public:
property ElementId^ HostId {
    ElementId^ get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


InsertId Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..InsertId Property
IFCDoorWindowInfo Class See Also Send Feedback
The id of the door or window element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId InsertId { get; }
Visual Basic
Public ReadOnly Property InsertId As ElementId
    Get
Visual C++
public:
property ElementId^ InsertId {
    ElementId^ get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IsFlippedInX Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..IsFlippedInX Property
IFCDoorWindowInfo Class See Also Send Feedback
True if the door or window is flipped in the X direction, false otherwise.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFlippedInX { get; }
Visual Basic
Public ReadOnly Property IsFlippedInX As Boolean
    Get
Visual C++
public:
property bool IsFlippedInX {
    bool get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IsFlippedInY Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..IsFlippedInY Property
IFCDoorWindowInfo Class See Also Send Feedback
True if the door or window is flipped in the Y direction, false otherwise.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFlippedInY { get; }
Visual Basic
Public ReadOnly Property IsFlippedInY As Boolean
    Get
Visual C++
public:
property bool IsFlippedInY {
    bool get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IsSymbolFlipped Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..IsSymbolFlipped Property
IFCDoorWindowInfo Class See Also Send Feedback
True if the element type geometry for the door or window should be flipped, false otherwise.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsSymbolFlipped { get; set; }
Visual Basic
Public Property IsSymbolFlipped As Boolean
    Get
    Set
Visual C++
public:
property bool IsSymbolFlipped {
    bool get ();
    void set (bool value);
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


NeedsOpening Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..NeedsOpening Property
IFCDoorWindowInfo Class See Also Send Feedback
True if the door or window should be exported related to a rectangular opening in the host wall, false otherwise.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool NeedsOpening { get; set; }
Visual Basic
Public Property NeedsOpening As Boolean
    Get
    Set
Visual C++
public:
property bool NeedsOpening {
    bool get ();
    void set (bool value);
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


OpeningHeight Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..OpeningHeight Property
IFCDoorWindowInfo Class See Also Send Feedback
The height of the opening.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double OpeningHeight { get; set; }
Visual Basic
Public Property OpeningHeight As Double
    Get
    Set
Visual C++
public:
property double OpeningHeight {
    double get ();
    void set (double value);
}

Remarks

Ignored if NeedsOpening is false or if the value is non-positive.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


OpeningWidth Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..OpeningWidth Property
IFCDoorWindowInfo Class See Also Send Feedback
The width of the opening.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double OpeningWidth { get; set; }
Visual Basic
Public Property OpeningWidth As Double
    Get
    Set
Visual C++
public:
property double OpeningWidth {
    double get ();
    void set (double value);
}

Remarks

Ignored if NeedsOpening is false or if the value is non-positive.

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


RepresentsDoor Property

[image]

Revit 2013 API
IFCDoorWindowInfo..::..RepresentsDoor Property
IFCDoorWindowInfo Class See Also Send Feedback
True if the information is related to door export, false if it related to window export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool RepresentsDoor { get; }
Visual Basic
Public ReadOnly Property RepresentsDoor As Boolean
    Get
Visual C++
public:
property bool RepresentsDoor {
    bool get ();
}

See Also

IFCDoorWindowInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionAxes Enumeration

[image]

Revit 2013 API
IFCExtrusionAxes Enumeration
See Also Send Feedback
Represents the possible axes to try when generating an extrusion using IFCCreateExtrusionData.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum IFCExtrusionAxes
Visual Basic
Public Enumeration IFCExtrusionAxes
Visual C++
public enum class IFCExtrusionAxes

Members

Member name | Description
TryDefault | The default value.
TryX | The x-axis.
TryY | The y-axis.
TryXY | The x- and y-axes.
TryZ | The z-axis.
TryXZ | The x- and z-axes.
TryYZ | The y- and z-axes.
TryXYZ | The x-, y-, and z-axes.
TryCustom | A custom direction.
TryXYZAndCustom | The x-, y-, and z-axes, and a custom direction.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCExtrusionBasis Enumeration

[image]

Revit 2013 API
IFCExtrusionBasis Enumeration
See Also Send Feedback
This enumerated type represents the possible bases for derivation of extrusion geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum IFCExtrusionBasis
Visual Basic
Public Enumeration IFCExtrusionBasis
Visual C++
public enum class IFCExtrusionBasis

Members

Member name | Description
InvalidBasis | An invalid basis (typically indicating that the extrusion extraction was unsuccessful).
BasisX | The X direction.
BasisY | The Y direction.
BasisZ | The Z direction.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorOptions Class

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions Class
Members See Also Send Feedback
This class contains the options used to calculate extrusions from Revit geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCExtrusionCalculatorOptions : IDisposable
Visual Basic
Public Class IFCExtrusionCalculatorOptions _
    Implements IDisposable
Visual C++
public ref class IFCExtrusionCalculatorOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions

See Also

IFCExtrusionCalculatorOptions Members
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorOptions Members

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorOptions Members
IFCExtrusionCalculatorOptions Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionCalculatorOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionCalculatorOptions | Constructs a new instance of a class used to calculate extrusions from Revit geometry.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCExtrusionCalculatorOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CustomAxis | The custom axis to try (if extrusionAxes includes an option for a custom direction).
Public property | ExtrusionAxes | The extrusion axes to try when doing the calculation.
Public property | Scale | The scaling factor for length measurements from the default Revit units to the export units.

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorOptions Constructor

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions Constructor
IFCExtrusionCalculatorOptions Class See Also Send Feedback
Constructs a new instance of a class used to calculate extrusions from Revit geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionCalculatorOptions(
    ExporterIFC exporterIFC,
    IFCExtrusionAxes extrusionAxes,
    XYZ customAxis,
    double scale
)
Visual Basic
Public Sub New ( _
    exporterIFC As ExporterIFC, _
    extrusionAxes As IFCExtrusionAxes, _
    customAxis As XYZ, _
    scale As Double _
)
Visual C++
public:
IFCExtrusionCalculatorOptions(
    ExporterIFC^ exporterIFC,
    IFCExtrusionAxes extrusionAxes,
    XYZ^ customAxis,
    double scale
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
extrusionAxes
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionAxes
The extrusion axes to try when doing the calculation.
customAxis
Type: Autodesk.Revit.DB..::..XYZ
The custom axis to try (if extrusionAxes includes an option for a custom direction).
scale
Type: System..::..Double
The scaling factor for length measurements from the default Revit units to the export units.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorOptions Methods

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorOptions Methods
IFCExtrusionCalculatorOptions Class See Also Send Feedback

The IFCExtrusionCalculatorOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions..::..Dispose Method
IFCExtrusionCalculatorOptions Class See Also Send Feedback
Releases all resources used by the IFCExtrusionCalculatorOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorOptions Properties

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorOptions Properties
IFCExtrusionCalculatorOptions Class See Also Send Feedback

The IFCExtrusionCalculatorOptions type exposes the following members.

Properties

 | Name | Description
Public property | CustomAxis | The custom axis to try (if extrusionAxes includes an option for a custom direction).
Public property | ExtrusionAxes | The extrusion axes to try when doing the calculation.
Public property | Scale | The scaling factor for length measurements from the default Revit units to the export units.

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


CustomAxis Property

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions..::..CustomAxis Property
IFCExtrusionCalculatorOptions Class See Also Send Feedback
The custom axis to try (if extrusionAxes includes an option for a custom direction).

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ CustomAxis { get; set; }
Visual Basic
Public Property CustomAxis As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ CustomAxis {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


ExtrusionAxes Property

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions..::..ExtrusionAxes Property
IFCExtrusionCalculatorOptions Class See Also Send Feedback
The extrusion axes to try when doing the calculation.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionAxes ExtrusionAxes { get; set; }
Visual Basic
Public Property ExtrusionAxes As IFCExtrusionAxes
    Get
    Set
Visual C++
public:
property IFCExtrusionAxes ExtrusionAxes {
    IFCExtrusionAxes get ();
    void set (IFCExtrusionAxes value);
}

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


Scale Property

[image]

Revit 2013 API
IFCExtrusionCalculatorOptions..::..Scale Property
IFCExtrusionCalculatorOptions Class See Also Send Feedback
The scaling factor for length measurements from the default Revit units to the export units.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Scale { get; set; }
Visual Basic
Public Property Scale As Double
    Get
    Set
Visual C++
public:
property double Scale {
    double get ();
    void set (double value);
}

See Also

IFCExtrusionCalculatorOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorUtils Class

[image]

Revit 2013 API
IFCExtrusionCalculatorUtils Class
Members See Also Send Feedback
A utility class used to calculate extrusion data from Revit geometry for IFC export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCExtrusionCalculatorUtils : IDisposable
Visual Basic
Public Class IFCExtrusionCalculatorUtils _
    Implements IDisposable
Visual C++
public ref class IFCExtrusionCalculatorUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorUtils

See Also

IFCExtrusionCalculatorUtils Members
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorUtils Members

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorUtils Members
IFCExtrusionCalculatorUtils Class Methods See Also Send Feedback

The IFCExtrusionCalculatorUtils type exposes the following members.

Methods

 | Name | Description
 | CalculateExtrusionData(IFCExtrusionCalculatorOptions, GeometryObject) | Calculates the extrusion data from a Revit geometry object.
 | CalculateExtrusionData(IFCExtrusionCalculatorOptions, IList<(Of <<'(Face>)>>)) | Calculates the extrusion data from a collection of Revit geometry faces.
Public method | Dispose | Releases all resources used by the IFCExtrusionCalculatorUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionCalculatorUtils Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCalculatorUtils Methods

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorUtils Methods
IFCExtrusionCalculatorUtils Class See Also Send Feedback

The IFCExtrusionCalculatorUtils type exposes the following members.

Methods

 | Name | Description
 | CalculateExtrusionData(IFCExtrusionCalculatorOptions, GeometryObject) | Calculates the extrusion data from a Revit geometry object.
 | CalculateExtrusionData(IFCExtrusionCalculatorOptions, IList<(Of <<'(Face>)>>)) | Calculates the extrusion data from a collection of Revit geometry faces.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionCalculatorUtils Class
Autodesk.Revit.DB.IFC Namespace


CalculateExtrusionData Method

[image] [image]

Revit 2013 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method
IFCExtrusionCalculatorUtils Class See Also Send Feedback

Overload List

Name | Description
CalculateExtrusionData(IFCExtrusionCalculatorOptions, GeometryObject) | Calculates the extrusion data from a Revit geometry object.
CalculateExtrusionData(IFCExtrusionCalculatorOptions, IList<(Of <<'(Face>)>>)) | Calculates the extrusion data from a collection of Revit geometry faces.

See Also

IFCExtrusionCalculatorUtils Class
IFCExtrusionCalculatorUtils Members
Autodesk.Revit.DB.IFC Namespace


CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, GeometryObject)

[image]

Revit 2013 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, GeometryObject)
IFCExtrusionCalculatorUtils Class See Also Send Feedback
Calculates the extrusion data from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCExtrusionData> CalculateExtrusionData(
    IFCExtrusionCalculatorOptions extrusionOptions,
    GeometryObject geometryObject
)
Visual Basic
Public Shared Function CalculateExtrusionData ( _
    extrusionOptions As IFCExtrusionCalculatorOptions, _
    geometryObject As GeometryObject _
) As IList(Of IFCExtrusionData)
Visual C++
public:
static IList<IFCExtrusionData^>^ CalculateExtrusionData(
    IFCExtrusionCalculatorOptions^ extrusionOptions,
    GeometryObject^ geometryObject
)

Parameters

extrusionOptions
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions
The options for extrusion extraction.
geometryObject
Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object.

Return Value

A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorUtils Class
CalculateExtrusionData Overload
Autodesk.Revit.DB.IFC Namespace


CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, IList(Face))

[image]

Revit 2013 API
IFCExtrusionCalculatorUtils..::..CalculateExtrusionData Method (IFCExtrusionCalculatorOptions, IList<(Of <(<'Face>)>)>)
IFCExtrusionCalculatorUtils Class See Also Send Feedback
Calculates the extrusion data from a collection of Revit geometry faces.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<IFCExtrusionData> CalculateExtrusionData(
    IFCExtrusionCalculatorOptions extrInfo,
    IList<Face> allInputFaces
)
Visual Basic
Public Shared Function CalculateExtrusionData ( _
    extrInfo As IFCExtrusionCalculatorOptions, _
    allInputFaces As IList(Of Face) _
) As IList(Of IFCExtrusionData)
Visual C++
public:
static IList<IFCExtrusionData^>^ CalculateExtrusionData(
    IFCExtrusionCalculatorOptions^ extrInfo,
    IList<Face^>^ allInputFaces
)

Parameters

extrInfo
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCalculatorOptions
The options for extrusion extraction.
allInputFaces
Type: System.Collections.Generic..::..IList<(Of <(<'Face>)>)>
The collection of faces.

Return Value

A collection of extrusion data calculated for the geometry. If the function fails to calculate one or more valid extrusions, this collection will be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCalculatorUtils Class
CalculateExtrusionData Overload
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCExtrusionCalculatorUtils..::..Dispose Method
IFCExtrusionCalculatorUtils Class See Also Send Feedback
Releases all resources used by the IFCExtrusionCalculatorUtils

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCExtrusionCalculatorUtils Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCreationData Class

[image]

Revit 2013 API
IFCExtrusionCreationData Class
Members See Also Send Feedback
A utility object that is used to pass information related to extrusion creation.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCExtrusionCreationData : IDisposable
Visual Basic
Public Class IFCExtrusionCreationData _
    Implements IDisposable
Visual C++
public ref class IFCExtrusionCreationData : IDisposable

Remarks

This class accepts input used to attempt to create an extrusion (possibly with openings) from Revit geometry. The output contains information about the created extrusion and its openings. The information set is used to generate properties for the extruded body and related opening elements in the IFC file.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData

See Also

IFCExtrusionCreationData Members
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCreationData Members

[image] [image]

Revit 2013 API
IFCExtrusionCreationData Members
IFCExtrusionCreationData Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionCreationData | The default constructor.

Methods

 | Name | Description
Public method | AddOpening | Adds an opening to the data.
Public method | ClearOpenings | Removes all cached openings from the data.
Public method | Dispose | Releases all resources used by the IFCExtrusionCreationData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.
Public method | GetOpenings | Gets a collection of all of the openings stored in this data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLocalPlacement | Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowVerticalOffsetOfBReps | Allows vertical shifting of breps when moving towards the origin.
Public property | AreInnerRegionsOpenings | True if inner regions of the extrusion should become openings, false otherwise.
Public property | CustomAxis | The custom extrusion axis to try when generating an extrusion.
Public property | ExtrusionDirection | The extrusion direction to generate an extrusion.
Public property | HasCustomAxis | Identifies if the data contains a custom extrusion axis.
Public property | HasExtrusionDirection | Identifies if the data contains a extrusion direction.
Public property | PossibleExtrusionAxes | The axes to try when generating the properties of the extrusion.
Public property | ReuseLocalPlacement | Allows re-use of local placement when creating a new local placement due to shifting of breps when moving towards the origin.
Public property | ScaledArea | The area of the extrusion, scaled to the units of export.
Public property | ScaledHeight | The height of the extrusion, scaled to the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the extrusion, scaled to the units of export.
Public property | ScaledLength | The length of the extrusion, scaled to the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the extrusion, scaled to the units of export.
Public property | ScaledWidth | The width of the extrusion, scaled to the units of export.
Public property | Slope | The slope of the extrusion, in degrees.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCreationData Constructor

[image]

Revit 2013 API
IFCExtrusionCreationData Constructor
IFCExtrusionCreationData Class See Also Send Feedback
The default constructor.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionCreationData()
Visual Basic
Public Sub New
Visual C++
public:
IFCExtrusionCreationData()

Remarks

All input data will be considered uninitialized.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCreationData Methods

[image] [image]

Revit 2013 API
IFCExtrusionCreationData Methods
IFCExtrusionCreationData Class See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Methods

 | Name | Description
Public method | AddOpening | Adds an opening to the data.
Public method | ClearOpenings | Removes all cached openings from the data.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.
Public method | GetOpenings | Gets a collection of all of the openings stored in this data.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLocalPlacement | Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


AddOpening Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..AddOpening Method
IFCExtrusionCreationData Class See Also Send Feedback
Adds an opening to the data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddOpening(
    IFCExtrusionData data
)
Visual Basic
Public Sub AddOpening ( _
    data As IFCExtrusionData _
)
Visual C++
public:
void AddOpening(
    IFCExtrusionData^ data
)

Parameters

data
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionData
The opening.

Remarks

The opening is stored for retrieval later via GetOpenings().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ClearOpenings Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ClearOpenings Method
IFCExtrusionCreationData Class See Also Send Feedback
Removes all cached openings from the data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ClearOpenings()
Visual Basic
Public Sub ClearOpenings
Visual C++
public:
void ClearOpenings()

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..Dispose Method
IFCExtrusionCreationData Class See Also Send Feedback
Releases all resources used by the IFCExtrusionCreationData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


GetLocalPlacement Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..GetLocalPlacement Method
IFCExtrusionCreationData Class See Also Send Feedback
Gets the reference to the IfcLocalPlacement handle used when creating the extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetLocalPlacement()
Visual Basic
Public Function GetLocalPlacement As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetLocalPlacement()

Return Value

The IfcLocalPlacement handle.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


GetOpenings Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..GetOpenings Method
IFCExtrusionCreationData Class See Also Send Feedback
Gets a collection of all of the openings stored in this data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<IFCExtrusionData> GetOpenings()
Visual Basic
Public Function GetOpenings As IList(Of IFCExtrusionData)
Visual C++
public:
IList<IFCExtrusionData^>^ GetOpenings()

Return Value

The opening information.

Remarks

Contains all of the openings stored via AddOpening().

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


SetLocalPlacement Method

[image]

Revit 2013 API
IFCExtrusionCreationData..::..SetLocalPlacement Method
IFCExtrusionCreationData Class See Also Send Feedback
Sets the data to reference an IfcLocalPlacement handle when creating the extrusion. Side effect: will set ReuseLocalPlacement to true.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetLocalPlacement(
    IFCAnyHandle localPlacement
)
Visual Basic
Public Sub SetLocalPlacement ( _
    localPlacement As IFCAnyHandle _
)
Visual C++
public:
void SetLocalPlacement(
    IFCAnyHandle^ localPlacement
)

Parameters

localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcLocalPlacement handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionCreationData Properties

[image] [image]

Revit 2013 API
IFCExtrusionCreationData Properties
IFCExtrusionCreationData Class See Also Send Feedback

The IFCExtrusionCreationData type exposes the following members.

Properties

 | Name | Description
Public property | AllowVerticalOffsetOfBReps | Allows vertical shifting of breps when moving towards the origin.
Public property | AreInnerRegionsOpenings | True if inner regions of the extrusion should become openings, false otherwise.
Public property | CustomAxis | The custom extrusion axis to try when generating an extrusion.
Public property | ExtrusionDirection | The extrusion direction to generate an extrusion.
Public property | HasCustomAxis | Identifies if the data contains a custom extrusion axis.
Public property | HasExtrusionDirection | Identifies if the data contains a extrusion direction.
Public property | PossibleExtrusionAxes | The axes to try when generating the properties of the extrusion.
Public property | ReuseLocalPlacement | Allows re-use of local placement when creating a new local placement due to shifting of breps when moving towards the origin.
Public property | ScaledArea | The area of the extrusion, scaled to the units of export.
Public property | ScaledHeight | The height of the extrusion, scaled to the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the extrusion, scaled to the units of export.
Public property | ScaledLength | The length of the extrusion, scaled to the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the extrusion, scaled to the units of export.
Public property | ScaledWidth | The width of the extrusion, scaled to the units of export.
Public property | Slope | The slope of the extrusion, in degrees.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


AllowVerticalOffsetOfBReps Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..AllowVerticalOffsetOfBReps Property
IFCExtrusionCreationData Class See Also Send Feedback
Allows vertical shifting of breps when moving towards the origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool AllowVerticalOffsetOfBReps { get; set; }
Visual Basic
Public Property AllowVerticalOffsetOfBReps As Boolean
    Get
    Set
Visual C++
public:
property bool AllowVerticalOffsetOfBReps {
    bool get ();
    void set (bool value);
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


AreInnerRegionsOpenings Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..AreInnerRegionsOpenings Property
IFCExtrusionCreationData Class See Also Send Feedback
True if inner regions of the extrusion should become openings, false otherwise.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool AreInnerRegionsOpenings { get; set; }
Visual Basic
Public Property AreInnerRegionsOpenings As Boolean
    Get
    Set
Visual C++
public:
property bool AreInnerRegionsOpenings {
    bool get ();
    void set (bool value);
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


CustomAxis Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..CustomAxis Property
IFCExtrusionCreationData Class See Also Send Feedback
The custom extrusion axis to try when generating an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ CustomAxis { get; set; }
Visual Basic
Public Property CustomAxis As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ CustomAxis {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ExtrusionDirection Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ExtrusionDirection Property
IFCExtrusionCreationData Class See Also Send Feedback
The extrusion direction to generate an extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ ExtrusionDirection { get; set; }
Visual Basic
Public Property ExtrusionDirection As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ExtrusionDirection {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


HasCustomAxis Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..HasCustomAxis Property
IFCExtrusionCreationData Class See Also Send Feedback
Identifies if the data contains a custom extrusion axis.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasCustomAxis { get; }
Visual Basic
Public ReadOnly Property HasCustomAxis As Boolean
    Get
Visual C++
public:
property bool HasCustomAxis {
    bool get ();
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


HasExtrusionDirection Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..HasExtrusionDirection Property
IFCExtrusionCreationData Class See Also Send Feedback
Identifies if the data contains a extrusion direction.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasExtrusionDirection { get; }
Visual Basic
Public ReadOnly Property HasExtrusionDirection As Boolean
    Get
Visual C++
public:
property bool HasExtrusionDirection {
    bool get ();
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


PossibleExtrusionAxes Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..PossibleExtrusionAxes Property
IFCExtrusionCreationData Class See Also Send Feedback
The axes to try when generating the properties of the extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionAxes PossibleExtrusionAxes { get; set; }
Visual Basic
Public Property PossibleExtrusionAxes As IFCExtrusionAxes
    Get
    Set
Visual C++
public:
property IFCExtrusionAxes PossibleExtrusionAxes {
    IFCExtrusionAxes get ();
    void set (IFCExtrusionAxes value);
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ReuseLocalPlacement Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ReuseLocalPlacement Property
IFCExtrusionCreationData Class See Also Send Feedback
Allows re-use of local placement when creating a new local placement due to shifting of breps when moving towards the origin.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ReuseLocalPlacement { get; set; }
Visual Basic
Public Property ReuseLocalPlacement As Boolean
    Get
    Set
Visual C++
public:
property bool ReuseLocalPlacement {
    bool get ();
    void set (bool value);
}

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledArea Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledArea Property
IFCExtrusionCreationData Class See Also Send Feedback
The area of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledArea { get; set; }
Visual Basic
Public Property ScaledArea As Double
    Get
    Set
Visual C++
public:
property double ScaledArea {
    double get ();
    void set (double value);
}

Field Value

The value will be 0.0 if the area has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledHeight Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledHeight Property
IFCExtrusionCreationData Class See Also Send Feedback
The height of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledHeight { get; set; }
Visual Basic
Public Property ScaledHeight As Double
    Get
    Set
Visual C++
public:
property double ScaledHeight {
    double get ();
    void set (double value);
}

Field Value

Zero if the height has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledInnerPerimeter Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledInnerPerimeter Property
IFCExtrusionCreationData Class See Also Send Feedback
The inner perimeter of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledInnerPerimeter { get; set; }
Visual Basic
Public Property ScaledInnerPerimeter As Double
    Get
    Set
Visual C++
public:
property double ScaledInnerPerimeter {
    double get ();
    void set (double value);
}

Field Value

This value represents the perimeter of all of the inner curve loops within the area of the extrusion. Zero if the perimeter has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledLength Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledLength Property
IFCExtrusionCreationData Class See Also Send Feedback
The length of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledLength { get; set; }
Visual Basic
Public Property ScaledLength As Double
    Get
    Set
Visual C++
public:
property double ScaledLength {
    double get ();
    void set (double value);
}

Field Value

Zero if the length has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledOuterPerimeter Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledOuterPerimeter Property
IFCExtrusionCreationData Class See Also Send Feedback
The outer perimeter of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledOuterPerimeter { get; set; }
Visual Basic
Public Property ScaledOuterPerimeter As Double
    Get
    Set
Visual C++
public:
property double ScaledOuterPerimeter {
    double get ();
    void set (double value);
}

Field Value

This value represents the perimeter of the outermost curve loop bounding the area of the extrusion. Zero if the perimeter has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


ScaledWidth Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..ScaledWidth Property
IFCExtrusionCreationData Class See Also Send Feedback
The width of the extrusion, scaled to the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledWidth { get; set; }
Visual Basic
Public Property ScaledWidth As Double
    Get
    Set
Visual C++
public:
property double ScaledWidth {
    double get ();
    void set (double value);
}

Field Value

Zero if the width has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


Slope Property

[image]

Revit 2013 API
IFCExtrusionCreationData..::..Slope Property
IFCExtrusionCreationData Class See Also Send Feedback
The slope of the extrusion, in degrees.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Slope { get; set; }
Visual Basic
Public Property Slope As Double
    Get
    Set
Visual C++
public:
property double Slope {
    double get ();
    void set (double value);
}

Field Value

Zero if the slope has never been set on this object.

See Also

IFCExtrusionCreationData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionData Class

[image]

Revit 2013 API
IFCExtrusionData Class
Members See Also Send Feedback
Represents the geometry of an extrusion (a solid body or opening) generated from Revit geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCExtrusionData : IDisposable
Visual Basic
Public Class IFCExtrusionData _
    Implements IDisposable
Visual C++
public ref class IFCExtrusionData : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCExtrusionData

See Also

IFCExtrusionData Members
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionData Members

[image] [image]

Revit 2013 API
IFCExtrusionData Members
IFCExtrusionData Class Constructors Methods Properties See Also Send Feedback

The IFCExtrusionData type exposes the following members.

Constructors

 | Name | Description
Public method | IFCExtrusionData | Constructs a new empty extrusion data object.

Methods

 | Name | Description
Public method | AddLoop | Adds a curve loop to the extrusion data.
Public method | ClearLoops | Clears the curve loops stored in the extrusion data.
Public method | Dispose | Releases all resources used by the IFCExtrusionData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoops | Gets the curve loops that form the base shape of the extrusion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines if the extrusion data represents a valid extrusion.
Public method | RemoveLoopAt | Removes the loop at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExtrusionBasis | The basis used for the extrusion.
Public property | ExtrusionDirection | The direction used for the extrusion.
Public property | ScaledExtrusionLength | The length of the extrusion, scaled in the units of the export.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionData Constructor

[image]

Revit 2013 API
IFCExtrusionData Constructor
IFCExtrusionData Class See Also Send Feedback
Constructs a new empty extrusion data object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionData()
Visual Basic
Public Sub New
Visual C++
public:
IFCExtrusionData()

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionData Methods

[image] [image]

Revit 2013 API
IFCExtrusionData Methods
IFCExtrusionData Class See Also Send Feedback

The IFCExtrusionData type exposes the following members.

Methods

 | Name | Description
Public method | AddLoop | Adds a curve loop to the extrusion data.
Public method | ClearLoops | Clears the curve loops stored in the extrusion data.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLoops | Gets the curve loops that form the base shape of the extrusion.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Determines if the extrusion data represents a valid extrusion.
Public method | RemoveLoopAt | Removes the loop at the specified index.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


AddLoop Method

[image]

Revit 2013 API
IFCExtrusionData..::..AddLoop Method
IFCExtrusionData Class See Also Send Feedback
Adds a curve loop to the extrusion data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddLoop(
    CurveLoop pLoop
)
Visual Basic
Public Sub AddLoop ( _
    pLoop As CurveLoop _
)
Visual C++
public:
void AddLoop(
    CurveLoop^ pLoop
)

Parameters

pLoop
Type: Autodesk.Revit.DB..::..CurveLoop
The curve loop.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


ClearLoops Method

[image]

Revit 2013 API
IFCExtrusionData..::..ClearLoops Method
IFCExtrusionData Class See Also Send Feedback
Clears the curve loops stored in the extrusion data.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ClearLoops()
Visual Basic
Public Sub ClearLoops
Visual C++
public:
void ClearLoops()

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCExtrusionData..::..Dispose Method
IFCExtrusionData Class See Also Send Feedback
Releases all resources used by the IFCExtrusionData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


GetLoops Method

[image]

Revit 2013 API
IFCExtrusionData..::..GetLoops Method
IFCExtrusionData Class See Also Send Feedback
Gets the curve loops that form the base shape of the extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<CurveLoop> GetLoops()
Visual Basic
Public Function GetLoops As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetLoops()

Return Value

The collection of loops.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


IsValid Method

[image]

Revit 2013 API
IFCExtrusionData..::..IsValid Method
IFCExtrusionData Class See Also Send Feedback
Determines if the extrusion data represents a valid extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the extrusion is valid, false otherwise.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


RemoveLoopAt Method

[image]

Revit 2013 API
IFCExtrusionData..::..RemoveLoopAt Method
IFCExtrusionData Class See Also Send Feedback
Removes the loop at the specified index.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RemoveLoopAt(
    int index
)
Visual Basic
Public Sub RemoveLoopAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveLoopAt(
    int index
)

Parameters

index
Type: System..::..Int32
The zero-based index of the loop to remove.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


IFCExtrusionData Properties

[image] [image]

Revit 2013 API
IFCExtrusionData Properties
IFCExtrusionData Class See Also Send Feedback

The IFCExtrusionData type exposes the following members.

Properties

 | Name | Description
Public property | ExtrusionBasis | The basis used for the extrusion.
Public property | ExtrusionDirection | The direction used for the extrusion.
Public property | ScaledExtrusionLength | The length of the extrusion, scaled in the units of the export.

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


ExtrusionBasis Property

[image]

Revit 2013 API
IFCExtrusionData..::..ExtrusionBasis Property
IFCExtrusionData Class See Also Send Feedback
The basis used for the extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionBasis ExtrusionBasis { get; set; }
Visual Basic
Public Property ExtrusionBasis As IFCExtrusionBasis
    Get
    Set
Visual C++
public:
property IFCExtrusionBasis ExtrusionBasis {
    IFCExtrusionBasis get ();
    void set (IFCExtrusionBasis value);
}

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


ExtrusionDirection Property

[image]

Revit 2013 API
IFCExtrusionData..::..ExtrusionDirection Property
IFCExtrusionData Class See Also Send Feedback
The direction used for the extrusion.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ ExtrusionDirection { get; set; }
Visual Basic
Public Property ExtrusionDirection As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ ExtrusionDirection {
    XYZ^ get ();
    void set (XYZ^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


ScaledExtrusionLength Property

[image]

Revit 2013 API
IFCExtrusionData..::..ScaledExtrusionLength Property
IFCExtrusionData Class See Also Send Feedback
The length of the extrusion, scaled in the units of the export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledExtrusionLength { get; set; }
Visual Basic
Public Property ScaledExtrusionLength As Double
    Get
    Set
Visual C++
public:
property double ScaledExtrusionLength {
    double get ();
    void set (double value);
}

See Also

IFCExtrusionData Class
Autodesk.Revit.DB.IFC Namespace


IFCFamilyInstanceExtrusionExportResults Class

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults Class
Members See Also Send Feedback
This class represents the results of a geometric analysis of a family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCFamilyInstanceExtrusionExportResults : IDisposable
Visual Basic
Public Class IFCFamilyInstanceExtrusionExportResults _
    Implements IDisposable
Visual C++
public ref class IFCFamilyInstanceExtrusionExportResults : IDisposable

Remarks

The analysis attempts to convert the geometry of the instance into a single extrusion with additional extruded openings cutting the main solid.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCFamilyInstanceExtrusionExportResults

See Also

IFCFamilyInstanceExtrusionExportResults Members
Autodesk.Revit.DB.IFC Namespace


IFCFamilyInstanceExtrusionExportResults Members

[image] [image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults Members
IFCFamilyInstanceExtrusionExportResults Class Methods Properties See Also Send Feedback

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFamilyInstanceExtrusionExportResults
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCutPairOpenings | Gets the set of "openings" determined from the analysis of the instance geometry.
Public method | GetExtrusionHandle | Gets the extruded solid handle generated for the family instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ExtraOffset | The extra offset determined from the geometry of the family instance.
Public property | MaterialId | The best material id determined for the family instance.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


IFCFamilyInstanceExtrusionExportResults Methods

[image] [image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults Methods
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCutPairOpenings | Gets the set of "openings" determined from the analysis of the instance geometry.
Public method | GetExtrusionHandle | Gets the extruded solid handle generated for the family instance.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults..::..Dispose Method
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback
Releases all resources used by the IFCFamilyInstanceExtrusionExportResults

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


GetCutPairOpenings Method

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults..::..GetCutPairOpenings Method
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback
Gets the set of "openings" determined from the analysis of the instance geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<IFCExtrusionData> GetCutPairOpenings()
Visual Basic
Public Function GetCutPairOpenings As IList(Of IFCExtrusionData)
Visual C++
public:
IList<IFCExtrusionData^>^ GetCutPairOpenings()

Return Value

The extra openings.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


GetExtrusionHandle Method

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults..::..GetExtrusionHandle Method
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback
Gets the extruded solid handle generated for the family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetExtrusionHandle()
Visual Basic
Public Function GetExtrusionHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetExtrusionHandle()

Return Value

The handle. If the extrusion analysis failed for the family, this will be a handle with no value assigned.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


IFCFamilyInstanceExtrusionExportResults Properties

[image] [image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults Properties
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback

The IFCFamilyInstanceExtrusionExportResults type exposes the following members.

Properties

 | Name | Description
Public property | ExtraOffset | The extra offset determined from the geometry of the family instance.
Public property | MaterialId | The best material id determined for the family instance.

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


ExtraOffset Property

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults..::..ExtraOffset Property
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback
The extra offset determined from the geometry of the family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ ExtraOffset { get; }
Visual Basic
Public ReadOnly Property ExtraOffset As XYZ
    Get
Visual C++
public:
property XYZ^ ExtraOffset {
    XYZ^ get ();
}

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


MaterialId Property

[image]

Revit 2013 API
IFCFamilyInstanceExtrusionExportResults..::..MaterialId Property
IFCFamilyInstanceExtrusionExportResults Class See Also Send Feedback
The best material id determined for the family instance.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; }
Visual Basic
Public ReadOnly Property MaterialId As ElementId
    Get
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
}

See Also

IFCFamilyInstanceExtrusionExportResults Class
Autodesk.Revit.DB.IFC Namespace


IFCFile Class

[image]

Revit 2013 API
IFCFile Class
Members See Also Send Feedback
Represents the IFC file which is being created during export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCFile : IDisposable
Visual Basic
Public Class IFCFile _
    Implements IDisposable
Visual C++
public ref class IFCFile : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCFile

See Also

IFCFile Members
Autodesk.Revit.DB.IFC Namespace


IFCFile Members

[image] [image]

Revit 2013 API
IFCFile Members
IFCFile Class Methods See Also Send Feedback

The IFCFile type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close the IFC file.
 | Create | Creates an IFC file for exporting.
Public method | CreateCurveBoundedPlane | Creates a handle representing an IfcCurveBoundedPlane and assigns it to the file.
Public method | CreateHeaderInstance | Creates an IFC header instance in the file model.
Public method | CreateInstance | Creates an IFC instance in the file model.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | Dispose | Releases all resources used by the IFCFile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | Writes content to a file of IFC format.

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


IFCFile Methods

[image] [image]

Revit 2013 API
IFCFile Methods
IFCFile Class See Also Send Feedback

The IFCFile type exposes the following members.

Methods

 | Name | Description
Public method | Close | Close the IFC file.
 | Create | Creates an IFC file for exporting.
Public method | CreateCurveBoundedPlane | Creates a handle representing an IfcCurveBoundedPlane and assigns it to the file.
Public method | CreateHeaderInstance | Creates an IFC header instance in the file model.
Public method | CreateInstance | Creates an IFC instance in the file model.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Write | Writes content to a file of IFC format.

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


Close Method

[image]

Revit 2013 API
IFCFile..::..Close Method
IFCFile Class See Also Send Feedback
Close the IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image]

Revit 2013 API
IFCFile..::..Create Method
IFCFile Class See Also Send Feedback
Creates an IFC file for exporting.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCFile Create(
    IFCFileModelOptions modelOptions
)
Visual Basic
Public Shared Function Create ( _
    modelOptions As IFCFileModelOptions _
) As IFCFile
Visual C++
public:
static IFCFile^ Create(
    IFCFileModelOptions^ modelOptions
)

Parameters

modelOptions
Type: Autodesk.Revit.DB.IFC..::..IFCFileModelOptions
The options.

Return Value

The IFC file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


CreateCurveBoundedPlane Method

[image]

Revit 2013 API
IFCFile..::..CreateCurveBoundedPlane Method
IFCFile Class See Also Send Feedback
Creates a handle representing an IfcCurveBoundedPlane and assigns it to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle CreateCurveBoundedPlane(
    IList<XYZ> outerLoop,
    IList<IList<XYZ>> innerLoops
)
Visual Basic
Public Function CreateCurveBoundedPlane ( _
    outerLoop As IList(Of XYZ), _
    innerLoops As IList(Of IList(Of XYZ)) _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateCurveBoundedPlane(
    IList<XYZ^>^ outerLoop,
    IList<IList<XYZ^>^>^ innerLoops
)

Parameters

outerLoop
Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
A set of points that represents the outer boundary.
innerLoops
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'XYZ>)>)>>)>)>
A collection of sets of points that represent inner loops.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A transaction is required for this operation.

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


CreateHeaderInstance Method

[image]

Revit 2013 API
IFCFile..::..CreateHeaderInstance Method
IFCFile Class See Also Send Feedback
Creates an IFC header instance in the file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle CreateHeaderInstance(
    string name
)
Visual Basic
Public Function CreateHeaderInstance ( _
    name As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateHeaderInstance(
    String^ name
)

Parameters

name
Type: System..::..String
The instance name.

Return Value

The instance handle.

Remarks

file_schema, file_description and file_name must be created to get IFC file written successfully. Otherwise, the output IFC file would be empty.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


CreateInstance Method

[image]

Revit 2013 API
IFCFile..::..CreateInstance Method
IFCFile Class See Also Send Feedback
Creates an IFC instance in the file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle CreateInstance(
    string name
)
Visual Basic
Public Function CreateInstance ( _
    name As String _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateInstance(
    String^ name
)

Parameters

name
Type: System..::..String
The instance name.

Return Value

The instance handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


CreateStyle Method

[image] [image]

Revit 2013 API
IFCFile..::..CreateStyle Method
IFCFile Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateStyle(ExporterIFC, IFCAnyHandle) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.
Public method | CreateStyle(ExporterIFC, IFCAnyHandle, Color, ElementId) | Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

See Also

IFCFile Class
IFCFile Members
Autodesk.Revit.DB.IFC Namespace


CreateStyle Method (ExporterIFC, IFCAnyHandle)

[image]

Revit 2013 API
IFCFile..::..CreateStyle Method (ExporterIFC, IFCAnyHandle)
IFCFile Class See Also Send Feedback
Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle CreateStyle(
    ExporterIFC exporterIFC,
    IFCAnyHandle repItem
)
Visual Basic
Public Function CreateStyle ( _
    exporterIFC As ExporterIFC, _
    repItem As IFCAnyHandle _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateStyle(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ repItem
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
repItem
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The representation item.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A transaction is required for this operation.

See Also

IFCFile Class
CreateStyle Overload
Autodesk.Revit.DB.IFC Namespace


CreateStyle Method (ExporterIFC, IFCAnyHandle, Color, ElementId)

[image]

Revit 2013 API
IFCFile..::..CreateStyle Method (ExporterIFC, IFCAnyHandle, Color, ElementId)
IFCFile Class See Also Send Feedback
Creates and populates an IfcStyledItem for an IfcRepresentationItem with a IfcSurfaceStyle, IfcCurveStyle, and/or an IfcFillStyle, and assigns them to the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle CreateStyle(
    ExporterIFC exporterIFC,
    IFCAnyHandle repItem,
    Color color,
    ElementId fillPatternId
)
Visual Basic
Public Function CreateStyle ( _
    exporterIFC As ExporterIFC, _
    repItem As IFCAnyHandle, _
    color As Color, _
    fillPatternId As ElementId _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ CreateStyle(
    ExporterIFC^ exporterIFC,
    IFCAnyHandle^ repItem,
    Color^ color,
    ElementId^ fillPatternId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
repItem
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The representation item.
color
Type: Autodesk.Revit.DB..::..Color
The color.
fillPatternId
Type: Autodesk.Revit.DB..::..ElementId
The fill pattern id.

Return Value

The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | A transaction is required for this operation.

See Also

IFCFile Class
CreateStyle Overload
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCFile..::..Dispose Method
IFCFile Class See Also Send Feedback
Releases all resources used by the IFCFile

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


Write Method

[image]

Revit 2013 API
IFCFile..::..Write Method
IFCFile Class See Also Send Feedback
Writes content to a file of IFC format.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Write(
    IFCFileWriteOptions writeOptions
)
Visual Basic
Public Sub Write ( _
    writeOptions As IFCFileWriteOptions _
)
Visual C++
public:
void Write(
    IFCFileWriteOptions^ writeOptions
)

Parameters

writeOptions
Type: Autodesk.Revit.DB.IFC..::..IFCFileWriteOptions
The IFC file write options.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCFile Class
Autodesk.Revit.DB.IFC Namespace


IFCFileFormat Enumeration

[image]

Revit 2013 API
IFCFileFormat Enumeration
See Also Send Feedback
The IFC file format.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum IFCFileFormat
Visual Basic
Public Enumeration IFCFileFormat
Visual C++
public enum class IFCFileFormat

Members

Member name | Description
Ifc | IFC format.
IfcXML | IFC-XML format.
IfcZIP | IFC file, zipped to IFC-ZIP format.
IfcXMLZIP | IFC-XML file, zipped to IFC-ZIP format.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCFileModelOptions Class

[image]

Revit 2013 API
IFCFileModelOptions Class
Members See Also Send Feedback
This class contains options to create an IFC file model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCFileModelOptions : IDisposable
Visual Basic
Public Class IFCFileModelOptions _
    Implements IDisposable
Visual C++
public ref class IFCFileModelOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCFileModelOptions

See Also

IFCFileModelOptions Members
Autodesk.Revit.DB.IFC Namespace


IFCFileModelOptions Members

[image] [image]

Revit 2013 API
IFCFileModelOptions Members
IFCFileModelOptions Class Constructors Methods Properties See Also Send Feedback

The IFCFileModelOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileModelOptions | Creates a default IFCFileModelOptions. The default schema file is empty and cache size is 8192.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileModelOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CacheSize | The cache size of the file.
Public property | SchemaFile | The full name of an IFC schema file.
Public property | SchemaName | The name of the schema.
Public property | UserControlledInverses | Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileModelOptions Constructor

[image]

Revit 2013 API
IFCFileModelOptions Constructor
IFCFileModelOptions Class See Also Send Feedback
Creates a default IFCFileModelOptions. The default schema file is empty and cache size is 8192.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCFileModelOptions()
Visual Basic
Public Sub New
Visual C++
public:
IFCFileModelOptions()

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileModelOptions Methods

[image] [image]

Revit 2013 API
IFCFileModelOptions Methods
IFCFileModelOptions Class See Also Send Feedback

The IFCFileModelOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCFileModelOptions..::..Dispose Method
IFCFileModelOptions Class See Also Send Feedback
Releases all resources used by the IFCFileModelOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileModelOptions Properties

[image] [image]

Revit 2013 API
IFCFileModelOptions Properties
IFCFileModelOptions Class See Also Send Feedback

The IFCFileModelOptions type exposes the following members.

Properties

 | Name | Description
Public property | CacheSize | The cache size of the file.
Public property | SchemaFile | The full name of an IFC schema file.
Public property | SchemaName | The name of the schema.
Public property | UserControlledInverses | Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


CacheSize Property

[image]

Revit 2013 API
IFCFileModelOptions..::..CacheSize Property
IFCFileModelOptions Class See Also Send Feedback
The cache size of the file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int CacheSize { get; set; }
Visual Basic
Public Property CacheSize As Integer
    Get
    Set
Visual C++
public:
property int CacheSize {
    int get ();
    void set (int value);
}

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


SchemaFile Property

[image]

Revit 2013 API
IFCFileModelOptions..::..SchemaFile Property
IFCFileModelOptions Class See Also Send Feedback
The full name of an IFC schema file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string SchemaFile { get; set; }
Visual Basic
Public Property SchemaFile As String
    Get
    Set
Visual C++
public:
property String^ SchemaFile {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


SchemaName Property

[image]

Revit 2013 API
IFCFileModelOptions..::..SchemaName Property
IFCFileModelOptions Class See Also Send Feedback
The name of the schema.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string SchemaName { get; set; }
Visual Basic
Public Property SchemaName As String
    Get
    Set
Visual C++
public:
property String^ SchemaName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


UserControlledInverses Property

[image]

Revit 2013 API
IFCFileModelOptions..::..UserControlledInverses Property
IFCFileModelOptions Class See Also Send Feedback
Indicates if the inverses are controlled by Revit or users. True by users, false by Revit.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool UserControlledInverses { get; set; }
Visual Basic
Public Property UserControlledInverses As Boolean
    Get
    Set
Visual C++
public:
property bool UserControlledInverses {
    bool get ();
    void set (bool value);
}

See Also

IFCFileModelOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileWriteOptions Class

[image]

Revit 2013 API
IFCFileWriteOptions Class
Members See Also Send Feedback
This class contains options to write an IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCFileWriteOptions : IDisposable
Visual Basic
Public Class IFCFileWriteOptions _
    Implements IDisposable
Visual C++
public ref class IFCFileWriteOptions : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCFileWriteOptions

See Also

IFCFileWriteOptions Members
Autodesk.Revit.DB.IFC Namespace


IFCFileWriteOptions Members

[image] [image]

Revit 2013 API
IFCFileWriteOptions Members
IFCFileWriteOptions Class Constructors Methods Properties See Also Send Feedback

The IFCFileWriteOptions type exposes the following members.

Constructors

 | Name | Description
Public method | IFCFileWriteOptions | Creates a default IFCFileWriteOptions. The default file format is ifc.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCFileWriteOptions
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FileFormat | The file format of the IFC file.
Public property | FileName | The full file name of the IFC file to be written.
Public property | XMLConfigFileName | The XML configuration file name. It is used only for writing IFC-XML format file.

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileWriteOptions Constructor

[image]

Revit 2013 API
IFCFileWriteOptions Constructor
IFCFileWriteOptions Class See Also Send Feedback
Creates a default IFCFileWriteOptions. The default file format is ifc.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCFileWriteOptions()
Visual Basic
Public Sub New
Visual C++
public:
IFCFileWriteOptions()

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileWriteOptions Methods

[image] [image]

Revit 2013 API
IFCFileWriteOptions Methods
IFCFileWriteOptions Class See Also Send Feedback

The IFCFileWriteOptions type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCFileWriteOptions..::..Dispose Method
IFCFileWriteOptions Class See Also Send Feedback
Releases all resources used by the IFCFileWriteOptions

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCFileWriteOptions Properties

[image] [image]

Revit 2013 API
IFCFileWriteOptions Properties
IFCFileWriteOptions Class See Also Send Feedback

The IFCFileWriteOptions type exposes the following members.

Properties

 | Name | Description
Public property | FileFormat | The file format of the IFC file.
Public property | FileName | The full file name of the IFC file to be written.
Public property | XMLConfigFileName | The XML configuration file name. It is used only for writing IFC-XML format file.

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


FileFormat Property

[image]

Revit 2013 API
IFCFileWriteOptions..::..FileFormat Property
IFCFileWriteOptions Class See Also Send Feedback
The file format of the IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCFileFormat FileFormat { get; set; }
Visual Basic
Public Property FileFormat As IFCFileFormat
    Get
    Set
Visual C++
public:
property IFCFileFormat FileFormat {
    IFCFileFormat get ();
    void set (IFCFileFormat value);
}

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


FileName Property

[image]

Revit 2013 API
IFCFileWriteOptions..::..FileName Property
IFCFileWriteOptions Class See Also Send Feedback
The full file name of the IFC file to be written.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string FileName { get; set; }
Visual Basic
Public Property FileName As String
    Get
    Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


XMLConfigFileName Property

[image]

Revit 2013 API
IFCFileWriteOptions..::..XMLConfigFileName Property
IFCFileWriteOptions Class See Also Send Feedback
The XML configuration file name. It is used only for writing IFC-XML format file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string XMLConfigFileName { get; set; }
Visual Basic
Public Property XMLConfigFileName As String
    Get
    Set
Visual C++
public:
property String^ XMLConfigFileName {
    String^ get ();
    void set (String^ value);
}

Remarks

It uses default configuration if it is not set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCFileWriteOptions Class
Autodesk.Revit.DB.IFC Namespace


IFCGeometryInfo Class

[image]

Revit 2013 API
IFCGeometryInfo Class
Members See Also Send Feedback
A container class for Revit geometry extracted from an element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCGeometryInfo : IDisposable
Visual Basic
Public Class IFCGeometryInfo _
    Implements IDisposable
Visual C++
public ref class IFCGeometryInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCGeometryInfo

See Also

IFCGeometryInfo Members
Autodesk.Revit.DB.IFC Namespace


IFCGeometryInfo Members

[image] [image]

Revit 2013 API
IFCGeometryInfo Members
IFCGeometryInfo Class Methods See Also Send Feedback

The IFCGeometryInfo type exposes the following members.

Methods

 | Name | Description
 | CreateCurveGeometryInfo | Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateSurfaceGeometryInfo | Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.
Public method | Dispose | Releases all resources used by the IFCGeometryInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurves | Gets the IfcCurve handles created representing the processed geometry and stored in this object.
Public method | GetFaces | Gets the IfcFace handles created representing the processed geometry and stored in this object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRepresentations | Gets the representation handles created representing the processed geometry and stored in this object.
Public method | GetSurfaces | Gets the IfcSurface handles created representing the processed geometry and stored in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCGeometryInfo Methods

[image] [image]

Revit 2013 API
IFCGeometryInfo Methods
IFCGeometryInfo Class See Also Send Feedback

The IFCGeometryInfo type exposes the following members.

Methods

 | Name | Description
 | CreateCurveGeometryInfo | Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
 | CreateSurfaceGeometryInfo | Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurves | Gets the IfcCurve handles created representing the processed geometry and stored in this object.
Public method | GetFaces | Gets the IfcFace handles created representing the processed geometry and stored in this object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRepresentations | Gets the representation handles created representing the processed geometry and stored in this object.
Public method | GetSurfaces | Gets the IfcSurface handles created representing the processed geometry and stored in this object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


CreateCurveGeometryInfo Method

[image]

Revit 2013 API
IFCGeometryInfo..::..CreateCurveGeometryInfo Method
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCGeometryInfo CreateCurveGeometryInfo(
    ExporterIFC ExporterIFC,
    Plane plane,
    XYZ projectionDir,
    bool planViewOnly
)
Visual Basic
Public Shared Function CreateCurveGeometryInfo ( _
    ExporterIFC As ExporterIFC, _
    plane As Plane, _
    projectionDir As XYZ, _
    planViewOnly As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateCurveGeometryInfo(
    ExporterIFC^ ExporterIFC,
    Plane^ plane,
    XYZ^ projectionDir,
    bool planViewOnly
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
plane
Type: Autodesk.Revit.DB..::..Plane
The plane in which the curve handles must lie.
projectionDir
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the input plane.
planViewOnly
Type: System..::..Boolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.

Return Value

The new geometry info container.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


CreateFaceGeometryInfo Method

[image] [image]

Revit 2013 API
IFCGeometryInfo..::..CreateFaceGeometryInfo Method
IFCGeometryInfo Class See Also Send Feedback

Overload List

Name | Description
CreateFaceGeometryInfo(Double) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
CreateFaceGeometryInfo(Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) | Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

See Also

IFCGeometryInfo Class
IFCGeometryInfo Members
Autodesk.Revit.DB.IFC Namespace


CreateFaceGeometryInfo Method (Double)

[image]

Revit 2013 API
IFCGeometryInfo..::..CreateFaceGeometryInfo Method (Double)
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCGeometryInfo CreateFaceGeometryInfo(
    double epsilon
)
Visual Basic
Public Shared Function CreateFaceGeometryInfo ( _
    epsilon As Double _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateFaceGeometryInfo(
    double epsilon
)

Parameters

epsilon
Type: System..::..Double
The epsilon value used to process surfaces.

Return Value

The new geometry info container.

See Also

IFCGeometryInfo Class
CreateFaceGeometryInfo Overload
Autodesk.Revit.DB.IFC Namespace


CreateFaceGeometryInfo Method (Double, Boolean)

[image]

Revit 2013 API
IFCGeometryInfo..::..CreateFaceGeometryInfo Method (Double, Boolean)
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCGeometryInfo CreateFaceGeometryInfo(
    double epsilon,
    bool isCoarse
)
Visual Basic
Public Shared Function CreateFaceGeometryInfo ( _
    epsilon As Double, _
    isCoarse As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateFaceGeometryInfo(
    double epsilon,
    bool isCoarse
)

Parameters

epsilon
Type: System..::..Double
The epsilon value used to process surfaces.
isCoarse
Type: System..::..Boolean
Indicates whether we should use a coarse representation.

Return Value

The new geometry info container.

See Also

IFCGeometryInfo Class
CreateFaceGeometryInfo Overload
Autodesk.Revit.DB.IFC Namespace


CreateFaceGeometryInfo Method (ExporterIFC, Plane, XYZ, Double, Boolean)

[image]

Revit 2013 API
IFCGeometryInfo..::..CreateFaceGeometryInfo Method (ExporterIFC, Plane, XYZ, Double, Boolean)
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcFace handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCGeometryInfo CreateFaceGeometryInfo(
    ExporterIFC ExporterIFC,
    Plane Plane,
    XYZ ProjDir,
    double epsilon,
    bool createRepresentations
)
Visual Basic
Public Shared Function CreateFaceGeometryInfo ( _
    ExporterIFC As ExporterIFC, _
    Plane As Plane, _
    ProjDir As XYZ, _
    epsilon As Double, _
    createRepresentations As Boolean _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateFaceGeometryInfo(
    ExporterIFC^ ExporterIFC,
    Plane^ Plane,
    XYZ^ ProjDir,
    double epsilon,
    bool createRepresentations
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
Plane
Type: Autodesk.Revit.DB..::..Plane
The plane in which the face handles must lie.
ProjDir
Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the input plane.
epsilon
Type: System..::..Double
The epsilon value used to process surfaces.
createRepresentations
Type: System..::..Boolean
Indicates if this should also create geometry representation handles.

Return Value

The new geometry info container.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCGeometryInfo Class
CreateFaceGeometryInfo Overload
Autodesk.Revit.DB.IFC Namespace


CreateSurfaceGeometryInfo Method

[image]

Revit 2013 API
IFCGeometryInfo..::..CreateSurfaceGeometryInfo Method
IFCGeometryInfo Class See Also Send Feedback
Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCGeometryInfo CreateSurfaceGeometryInfo(
    double epsilon
)
Visual Basic
Public Shared Function CreateSurfaceGeometryInfo ( _
    epsilon As Double _
) As IFCGeometryInfo
Visual C++
public:
static IFCGeometryInfo^ CreateSurfaceGeometryInfo(
    double epsilon
)

Parameters

epsilon
Type: System..::..Double
The epsilon value used to process surfaces.

Return Value

The new geometry info container.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCGeometryInfo..::..Dispose Method
IFCGeometryInfo Class See Also Send Feedback
Releases all resources used by the IFCGeometryInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


GetCurves Method

[image]

Revit 2013 API
IFCGeometryInfo..::..GetCurves Method
IFCGeometryInfo Class See Also Send Feedback
Gets the IfcCurve handles created representing the processed geometry and stored in this object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<IFCAnyHandle> GetCurves()
Visual Basic
Public Function GetCurves As IList(Of IFCAnyHandle)
Visual C++
public:
IList<IFCAnyHandle^>^ GetCurves()

Return Value

The collection of curve handles.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


GetFaces Method

[image]

Revit 2013 API
IFCGeometryInfo..::..GetFaces Method
IFCGeometryInfo Class See Also Send Feedback
Gets the IfcFace handles created representing the processed geometry and stored in this object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<ICollection<IFCAnyHandle>> GetFaces()
Visual Basic
Public Function GetFaces As IList(Of ICollection(Of IFCAnyHandle))
Visual C++
public:
IList<ICollection<IFCAnyHandle^>^>^ GetFaces()

Return Value

The collection of face handles.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


GetRepresentations Method

[image]

Revit 2013 API
IFCGeometryInfo..::..GetRepresentations Method
IFCGeometryInfo Class See Also Send Feedback
Gets the representation handles created representing the processed geometry and stored in this object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetRepresentations()
Visual Basic
Public Function GetRepresentations As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetRepresentations()

Return Value

The collection of representation handles.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


GetSurfaces Method

[image]

Revit 2013 API
IFCGeometryInfo..::..GetSurfaces Method
IFCGeometryInfo Class See Also Send Feedback
Gets the IfcSurface handles created representing the processed geometry and stored in this object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<IFCAnyHandle> GetSurfaces()
Visual Basic
Public Function GetSurfaces As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetSurfaces()

Return Value

The collection of surface handles.

See Also

IFCGeometryInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCLegacyStairOrRamp Class

[image]

Revit 2013 API
IFCLegacyStairOrRamp Class
Members See Also Send Feedback
The class contains the components of a legacy stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCLegacyStairOrRamp : IDisposable
Visual Basic
Public Class IFCLegacyStairOrRamp _
    Implements IDisposable
Visual C++
public ref class IFCLegacyStairOrRamp : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCLegacyStairOrRamp

See Also

IFCLegacyStairOrRamp Members
Autodesk.Revit.DB.IFC Namespace


IFCLegacyStairOrRamp Members

[image] [image]

Revit 2013 API
IFCLegacyStairOrRamp Members
IFCLegacyStairOrRamp Class Methods Properties See Also Send Feedback

The IFCLegacyStairOrRamp type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCLegacyStairOrRamp
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryRepresentations | Gets the boundary representations.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLandingGeometries | Gets the geometries of landings.
Public method | GetNumberOfRisers | Gets the number of risers.
Public method | GetNumberOfTreads | Gets the number of treads.
Public method | GetRunGeometries | Gets the geometries of runs.
Public method | GetStringerGeometries | Gets the geometries of stringers.
Public method | GetTreadsLength | Gets the length of treads.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWalkingLineRepresentations | Gets the walking line representations
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsRamp | True if it is a ramp, false if it is a stair.
Public property | RiserHeight | The height of riser.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


IFCLegacyStairOrRamp Methods

[image] [image]

Revit 2013 API
IFCLegacyStairOrRamp Methods
IFCLegacyStairOrRamp Class See Also Send Feedback

The IFCLegacyStairOrRamp type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBoundaryRepresentations | Gets the boundary representations.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLandingGeometries | Gets the geometries of landings.
Public method | GetNumberOfRisers | Gets the number of risers.
Public method | GetNumberOfTreads | Gets the number of treads.
Public method | GetRunGeometries | Gets the geometries of runs.
Public method | GetStringerGeometries | Gets the geometries of stringers.
Public method | GetTreadsLength | Gets the length of treads.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWalkingLineRepresentations | Gets the walking line representations
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..Dispose Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Releases all resources used by the IFCLegacyStairOrRamp

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetBoundaryRepresentations Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetBoundaryRepresentations Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the boundary representations.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IFCAnyHandle> GetBoundaryRepresentations()
Visual Basic
Public Function GetBoundaryRepresentations As IList(Of IFCAnyHandle)
Visual C++
public:
IList<IFCAnyHandle^>^ GetBoundaryRepresentations()

Return Value

The representations of boundaries.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetLandingGeometries Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetLandingGeometries Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the geometries of landings.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IList<GeometryObject>> GetLandingGeometries()
Visual Basic
Public Function GetLandingGeometries As IList(Of IList(Of GeometryObject))
Visual C++
public:
IList<IList<GeometryObject^>^>^ GetLandingGeometries()

Return Value

The geometries of landings.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetNumberOfRisers Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetNumberOfRisers Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the number of risers.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<int> GetNumberOfRisers()
Visual Basic
Public Function GetNumberOfRisers As IList(Of Integer)
Visual C++
public:
IList<int>^ GetNumberOfRisers()

Return Value

The list of numbers of risers.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetNumberOfTreads Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetNumberOfTreads Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the number of treads.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<int> GetNumberOfTreads()
Visual Basic
Public Function GetNumberOfTreads As IList(Of Integer)
Visual C++
public:
IList<int>^ GetNumberOfTreads()

Return Value

The list of numbers of treads.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetRunGeometries Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetRunGeometries Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the geometries of runs.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IList<GeometryObject>> GetRunGeometries()
Visual Basic
Public Function GetRunGeometries As IList(Of IList(Of GeometryObject))
Visual C++
public:
IList<IList<GeometryObject^>^>^ GetRunGeometries()

Return Value

The geometries of runs.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetStringerGeometries Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetStringerGeometries Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the geometries of stringers.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<GeometryObject> GetStringerGeometries()
Visual Basic
Public Function GetStringerGeometries As IList(Of GeometryObject)
Visual C++
public:
IList<GeometryObject^>^ GetStringerGeometries()

Return Value

The geometries of stringers.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetTreadsLength Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetTreadsLength Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the length of treads.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<double> GetTreadsLength()
Visual Basic
Public Function GetTreadsLength As IList(Of Double)
Visual C++
public:
IList<double>^ GetTreadsLength()

Return Value

The length of treads.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


GetWalkingLineRepresentations Method

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..GetWalkingLineRepresentations Method
IFCLegacyStairOrRamp Class See Also Send Feedback
Gets the walking line representations

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IFCAnyHandle> GetWalkingLineRepresentations()
Visual Basic
Public Function GetWalkingLineRepresentations As IList(Of IFCAnyHandle)
Visual C++
public:
IList<IFCAnyHandle^>^ GetWalkingLineRepresentations()

Return Value

The representations of walking lines.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


IFCLegacyStairOrRamp Properties

[image] [image]

Revit 2013 API
IFCLegacyStairOrRamp Properties
IFCLegacyStairOrRamp Class See Also Send Feedback

The IFCLegacyStairOrRamp type exposes the following members.

Properties

 | Name | Description
Public property | IsRamp | True if it is a ramp, false if it is a stair.
Public property | RiserHeight | The height of riser.

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


IsRamp Property

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..IsRamp Property
IFCLegacyStairOrRamp Class See Also Send Feedback
True if it is a ramp, false if it is a stair.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsRamp { get; }
Visual Basic
Public ReadOnly Property IsRamp As Boolean
    Get
Visual C++
public:
property bool IsRamp {
    bool get ();
}

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


RiserHeight Property

[image]

Revit 2013 API
IFCLegacyStairOrRamp..::..RiserHeight Property
IFCLegacyStairOrRamp Class See Also Send Feedback
The height of riser.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double RiserHeight { get; }
Visual Basic
Public ReadOnly Property RiserHeight As Double
    Get
Visual C++
public:
property double RiserHeight {
    double get ();
}

See Also

IFCLegacyStairOrRamp Class
Autodesk.Revit.DB.IFC Namespace


IFCLevelInfo Class

[image]

Revit 2013 API
IFCLevelInfo Class
Members See Also Send Feedback
Represents information about a particular level in the document.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCLevelInfo : IDisposable
Visual Basic
Public Class IFCLevelInfo _
    Implements IDisposable
Visual C++
public ref class IFCLevelInfo : IDisposable

Remarks

Level information includes the height, which is the distance to from this level to the next available level, and the actual elevation of the level, in the Revit default units.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCLevelInfo

See Also

IFCLevelInfo Members
Autodesk.Revit.DB.IFC Namespace


IFCLevelInfo Members

[image] [image]

Revit 2013 API
IFCLevelInfo Members
IFCLevelInfo Class Methods Properties See Also Send Feedback

The IFCLevelInfo type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an IFCLevelInfo.
Public method | Dispose | Releases all resources used by the IFCLevelInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBuildingStorey | Gets the IfcBuildingStorey handle.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRelatedElements | Gets all building elements on this level.
Public method | GetRelatedProducts | Gets all building products on this level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DistanceToNextLevel | The distance to the next story level.
Public property | Elevation | The elevation of the level.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCLevelInfo Methods

[image] [image]

Revit 2013 API
IFCLevelInfo Methods
IFCLevelInfo Class See Also Send Feedback

The IFCLevelInfo type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an IFCLevelInfo.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBuildingStorey | Gets the IfcBuildingStorey handle.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRelatedElements | Gets all building elements on this level.
Public method | GetRelatedProducts | Gets all building products on this level.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image]

Revit 2013 API
IFCLevelInfo..::..Create Method
IFCLevelInfo Class See Also Send Feedback
Creates an IFCLevelInfo.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCLevelInfo Create(
    IFCAnyHandle buildingStorey,
    IFCAnyHandle localPlacement,
    double height,
    double elevation,
    double scaleFactor,
    bool isPrimaryLevel
)
Visual Basic
Public Shared Function Create ( _
    buildingStorey As IFCAnyHandle, _
    localPlacement As IFCAnyHandle, _
    height As Double, _
    elevation As Double, _
    scaleFactor As Double, _
    isPrimaryLevel As Boolean _
) As IFCLevelInfo
Visual C++
public:
static IFCLevelInfo^ Create(
    IFCAnyHandle^ buildingStorey,
    IFCAnyHandle^ localPlacement,
    double height,
    double elevation,
    double scaleFactor,
    bool isPrimaryLevel
)

Parameters

buildingStorey
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The building storey handle (IfcBuildingStorey).
localPlacement
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The local placement handle (IfcLocalPlacement).
height
Type: System..::..Double
The height of the level.
elevation
Type: System..::..Double
The elevation of the level.
scaleFactor
Type: System..::..Double
The scale factor.
isPrimaryLevel
Type: System..::..Boolean
True if this is primary level, false otherwise.

Return Value

The IFCLevelInfo object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCLevelInfo..::..Dispose Method
IFCLevelInfo Class See Also Send Feedback
Releases all resources used by the IFCLevelInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


GetBuildingStorey Method

[image]

Revit 2013 API
IFCLevelInfo..::..GetBuildingStorey Method
IFCLevelInfo Class See Also Send Feedback
Gets the IfcBuildingStorey handle.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetBuildingStorey()
Visual Basic
Public Function GetBuildingStorey As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetBuildingStorey()

Return Value

The handle.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


GetRelatedElements Method

[image]

Revit 2013 API
IFCLevelInfo..::..GetRelatedElements Method
IFCLevelInfo Class See Also Send Feedback
Gets all building elements on this level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetRelatedElements()
Visual Basic
Public Function GetRelatedElements As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetRelatedElements()

Return Value

The collection of elements.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


GetRelatedProducts Method

[image]

Revit 2013 API
IFCLevelInfo..::..GetRelatedProducts Method
IFCLevelInfo Class See Also Send Feedback
Gets all building products on this level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetRelatedProducts()
Visual Basic
Public Function GetRelatedProducts As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetRelatedProducts()

Return Value

The collection of products.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCLevelInfo Properties

[image] [image]

Revit 2013 API
IFCLevelInfo Properties
IFCLevelInfo Class See Also Send Feedback

The IFCLevelInfo type exposes the following members.

Properties

 | Name | Description
Public property | DistanceToNextLevel | The distance to the next story level.
Public property | Elevation | The elevation of the level.

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


DistanceToNextLevel Property

[image]

Revit 2013 API
IFCLevelInfo..::..DistanceToNextLevel Property
IFCLevelInfo Class See Also Send Feedback
The distance to the next story level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double DistanceToNextLevel { get; }
Visual Basic
Public ReadOnly Property DistanceToNextLevel As Double
    Get
Visual C++
public:
property double DistanceToNextLevel {
    double get ();
}

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


Elevation Property

[image]

Revit 2013 API
IFCLevelInfo..::..Elevation Property
IFCLevelInfo Class See Also Send Feedback
The elevation of the level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Elevation { get; }
Visual Basic
Public ReadOnly Property Elevation As Double
    Get
Visual C++
public:
property double Elevation {
    double get ();
}

See Also

IFCLevelInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCLogical Enumeration

[image]

Revit 2013 API
IFCLogical Enumeration
See Also Send Feedback
A datatype can have values TRUE, FALSE or UNKNOWN.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum IFCLogical
Visual Basic
Public Enumeration IFCLogical
Visual C++
public enum class IFCLogical

Members

Member name | Description
False | False.
Unknown | Unknown.
True | True.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCPlacementSetter Class

[image]

Revit 2013 API
IFCPlacementSetter Class
Members See Also Send Feedback
A state-based class that establishes the current IfcLocalPlacement applied to an element being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCPlacementSetter : IDisposable
Visual Basic
Public Class IFCPlacementSetter _
    Implements IDisposable
Visual C++
public ref class IFCPlacementSetter : IDisposable

Remarks

This class is intended to maintain the placement for the duration that it is needed. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCPlacementSetter

See Also

IFCPlacementSetter Members
Autodesk.Revit.DB.IFC Namespace


IFCPlacementSetter Members

[image] [image]

Revit 2013 API
IFCPlacementSetter Members
IFCPlacementSetter Class Methods Properties See Also Send Feedback

The IFCPlacementSetter type exposes the following members.

Methods

 | Name | Description
 | Create(ExporterIFC, Element) | Creates a new placement setter instance for the given element.
 | Create(ExporterIFC, Element, Transform, Transform, ElementId) | Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.
Public method | Dispose | Releases all resources used by the IFCPlacementSetter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelInfo | Gets the level info related to the element's local placement.
Public method | GetOffsetLevelInfoAndHandle | Gets the level info related to an offset of the element's local placement.
Public method | GetPlacement | Gets the handle to the IfcLocalPlacement stored with this setter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRoomRelativeCoordinates | Obtains the handle to an alternate local placement for a room-related element.

Properties

 | Name | Description
Public property | BaseOffset | The offset to the base level.
Public property | LevelId | The level id associated with the element and placement.
Public property | Offset | The offset to the level.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


IFCPlacementSetter Methods

[image] [image]

Revit 2013 API
IFCPlacementSetter Methods
IFCPlacementSetter Class See Also Send Feedback

The IFCPlacementSetter type exposes the following members.

Methods

 | Name | Description
 | Create(ExporterIFC, Element) | Creates a new placement setter instance for the given element.
 | Create(ExporterIFC, Element, Transform, Transform, ElementId) | Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLevelInfo | Gets the level info related to the element's local placement.
Public method | GetOffsetLevelInfoAndHandle | Gets the level info related to an offset of the element's local placement.
Public method | GetPlacement | Gets the handle to the IfcLocalPlacement stored with this setter.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UpdateRoomRelativeCoordinates | Obtains the handle to an alternate local placement for a room-related element.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image] [image]

Revit 2013 API
IFCPlacementSetter..::..Create Method
IFCPlacementSetter Class See Also Send Feedback

Overload List

Name | Description
Create(ExporterIFC, Element) | Creates a new placement setter instance for the given element.
Create(ExporterIFC, Element, Transform, Transform, ElementId) | Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.

See Also

IFCPlacementSetter Class
IFCPlacementSetter Members
Autodesk.Revit.DB.IFC Namespace


Create Method (ExporterIFC, Element)

[image]

Revit 2013 API
IFCPlacementSetter..::..Create Method (ExporterIFC, Element)
IFCPlacementSetter Class See Also Send Feedback
Creates a new placement setter instance for the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCPlacementSetter Create(
    ExporterIFC exporterIFC,
    Element element
)
Visual Basic
Public Shared Function Create ( _
    exporterIFC As ExporterIFC, _
    element As Element _
) As IFCPlacementSetter
Visual C++
public:
static IFCPlacementSetter^ Create(
    ExporterIFC^ exporterIFC,
    Element^ element
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The element.

Return Value

The placement setter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A transaction is required for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Create Method (ExporterIFC, Element, Transform, Transform, ElementId)

[image]

Revit 2013 API
IFCPlacementSetter..::..Create Method (ExporterIFC, Element, Transform, Transform, ElementId)
IFCPlacementSetter Class See Also Send Feedback
Creates a new placement setter instance for the given element with the ability to specific overridden transformations and level id.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCPlacementSetter Create(
    ExporterIFC exporterIFC,
    Element element,
    Transform instanceOffsetTrf,
    Transform orientationTrf,
    ElementId overrideLevelId
)
Visual Basic
Public Shared Function Create ( _
    exporterIFC As ExporterIFC, _
    element As Element, _
    instanceOffsetTrf As Transform, _
    orientationTrf As Transform, _
    overrideLevelId As ElementId _
) As IFCPlacementSetter
Visual C++
public:
static IFCPlacementSetter^ Create(
    ExporterIFC^ exporterIFC,
    Element^ element,
    Transform^ instanceOffsetTrf,
    Transform^ orientationTrf,
    ElementId^ overrideLevelId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB..::..Element
The element.
instanceOffsetTrf
Type: Autodesk.Revit.DB..::..Transform
The offset transformation for the instance of a type. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
orientationTrf
Type: Autodesk.Revit.DB..::..Transform
The orientation transformation for the local coordinates being used to export the element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
overrideLevelId
Type: Autodesk.Revit.DB..::..ElementId
The level id to reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | A transaction is required for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCPlacementSetter..::..Dispose Method
IFCPlacementSetter Class See Also Send Feedback
Releases all resources used by the IFCPlacementSetter

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


GetLevelInfo Method

[image]

Revit 2013 API
IFCPlacementSetter..::..GetLevelInfo Method
IFCPlacementSetter Class See Also Send Feedback
Gets the level info related to the element's local placement.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCLevelInfo GetLevelInfo()
Visual Basic
Public Function GetLevelInfo As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetLevelInfo()

Return Value

The level info.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


GetOffsetLevelInfoAndHandle Method

[image]

Revit 2013 API
IFCPlacementSetter..::..GetOffsetLevelInfoAndHandle Method
IFCPlacementSetter Class See Also Send Feedback
Gets the level info related to an offset of the element's local placement.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCLevelInfo GetOffsetLevelInfoAndHandle(
    double offset,
    double scale,
    out IFCAnyHandle pPlacementHnd,
    out double pScaledOffsetFromNewLevel
)
Visual Basic
Public Function GetOffsetLevelInfoAndHandle ( _
    offset As Double, _
    scale As Double, _
    <OutAttribute> ByRef pPlacementHnd As IFCAnyHandle, _
    <OutAttribute> ByRef pScaledOffsetFromNewLevel As Double _
) As IFCLevelInfo
Visual C++
public:
IFCLevelInfo^ GetOffsetLevelInfoAndHandle(
    double offset,
    double scale,
    [OutAttribute] IFCAnyHandle^% pPlacementHnd,
    [OutAttribute] double% pScaledOffsetFromNewLevel
)

Parameters

offset
Type: System..::..Double
The vertical offset to the local placement.
scale
Type: System..::..Double
The linear scale.
pPlacementHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle%
The handle to the new local placement.
pScaledOffsetFromNewLevel
Type: System..::..Double%
The scaled offset from the new level.

Return Value

The level info.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


GetPlacement Method

[image]

Revit 2013 API
IFCPlacementSetter..::..GetPlacement Method
IFCPlacementSetter Class See Also Send Feedback
Gets the handle to the IfcLocalPlacement stored with this setter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetPlacement()
Visual Basic
Public Function GetPlacement As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetPlacement()

Return Value

The handle.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


UpdateRoomRelativeCoordinates Method

[image]

Revit 2013 API
IFCPlacementSetter..::..UpdateRoomRelativeCoordinates Method
IFCPlacementSetter Class See Also Send Feedback
Obtains the handle to an alternate local placement for a room-related element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId UpdateRoomRelativeCoordinates(
    Element element,
    out IFCAnyHandle placementToUse
)
Visual Basic
Public Function UpdateRoomRelativeCoordinates ( _
    element As Element, _
    <OutAttribute> ByRef placementToUse As IFCAnyHandle _
) As ElementId
Visual C++
public:
ElementId^ UpdateRoomRelativeCoordinates(
    Element^ element,
    [OutAttribute] IFCAnyHandle^% placementToUse
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element.
placementToUse
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle%
The handle to the IfcLocalPlacement to use for the given room-related element.

Return Value

The id of the spatial element related to the element. InvalidElementId if the element is not room-related, in which case the output will contain the placement handle from GetPlacement().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


IFCPlacementSetter Properties

[image] [image]

Revit 2013 API
IFCPlacementSetter Properties
IFCPlacementSetter Class See Also Send Feedback

The IFCPlacementSetter type exposes the following members.

Properties

 | Name | Description
Public property | BaseOffset | The offset to the base level.
Public property | LevelId | The level id associated with the element and placement.
Public property | Offset | The offset to the level.

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


BaseOffset Property

[image]

Revit 2013 API
IFCPlacementSetter..::..BaseOffset Property
IFCPlacementSetter Class See Also Send Feedback
The offset to the base level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double BaseOffset { get; }
Visual Basic
Public ReadOnly Property BaseOffset As Double
    Get
Visual C++
public:
property double BaseOffset {
    double get ();
}

Remarks

This may differ from Offset as this comes from the base level info, which could be different from the level info (level info is based on a calculated level for the object; baseLevelInfo is based strictly on input level, regardless of overrides).

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


LevelId Property

[image]

Revit 2013 API
IFCPlacementSetter..::..LevelId Property
IFCPlacementSetter Class See Also Send Feedback
The level id associated with the element and placement.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId LevelId { get; }
Visual Basic
Public ReadOnly Property LevelId As ElementId
    Get
Visual C++
public:
property ElementId^ LevelId {
    ElementId^ get ();
}

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


Offset Property

[image]

Revit 2013 API
IFCPlacementSetter..::..Offset Property
IFCPlacementSetter Class See Also Send Feedback
The offset to the level.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Offset { get; }
Visual Basic
Public ReadOnly Property Offset As Double
    Get
Visual C++
public:
property double Offset {
    double get ();
}

See Also

IFCPlacementSetter Class
Autodesk.Revit.DB.IFC Namespace


IFCProductWrapper Class

[image]

Revit 2013 API
IFCProductWrapper Class
Members See Also Send Feedback
This class is used to ensure that elements and objects are associated with the current IfcProduct.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCProductWrapper : IDisposable
Visual Basic
Public Class IFCProductWrapper _
    Implements IDisposable
Visual C++
public ref class IFCProductWrapper : IDisposable

Remarks

Each instance makes sure that any elements and products created during its lifetime are properly associated to their parent level (or other containing object). To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCProductWrapper

See Also

IFCProductWrapper Members
Autodesk.Revit.DB.IFC Namespace


IFCProductWrapper Members

[image] [image]

Revit 2013 API
IFCProductWrapper Members
IFCProductWrapper Class Methods Properties See Also Send Feedback

The IFCProductWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation handle to associate with the IfcProduct in this wrapper.
Public method | AddBuilding | Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddFinishMaterial | Adds an material handle to associate with the IfcProduct in this wrapper.
Public method | AddSite | Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.
Public method | AddSpace | Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Public method | ClearFinishMaterials | Clear finish materials in this wrapper.
 | Create(IFCProductWrapper) | Establishes a new product manager for elements and objects derived from a parent product manager.
 | Create(ExporterIFC, Boolean) | Establishes a new baseline product manager for elements and objects.
 | Create(IFCProductWrapper, Boolean) | Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel
Public method | Dispose | Releases all resources used by the IFCProductWrapper
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindExtrusionCreationParameters | Obtains the extrusion creation data associated with the given element.
Public method | GetAllObjects | Gets all objects associated with the IfcProduct in this wrapper.
Public method | GetAnElement | Gets the first element handle added to this wrapper.
Public method | GetElements | Gets the element handles added to this wrapper.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProducts | Gets the product element handles added to this wrapper.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of objects associated with the IfcProduct in this wrapper.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


IFCProductWrapper Methods

[image] [image]

Revit 2013 API
IFCProductWrapper Methods
IFCProductWrapper Class See Also Send Feedback

The IFCProductWrapper type exposes the following members.

Methods

 | Name | Description
Public method | AddAnnotation | Adds an annotation handle to associate with the IfcProduct in this wrapper.
Public method | AddBuilding | Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddFinishMaterial | Adds an material handle to associate with the IfcProduct in this wrapper.
Public method | AddSite | Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.
Public method | AddSpace | Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.
Public method | ClearFinishMaterials | Clear finish materials in this wrapper.
 | Create(IFCProductWrapper) | Establishes a new product manager for elements and objects derived from a parent product manager.
 | Create(ExporterIFC, Boolean) | Establishes a new baseline product manager for elements and objects.
 | Create(IFCProductWrapper, Boolean) | Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindExtrusionCreationParameters | Obtains the extrusion creation data associated with the given element.
Public method | GetAllObjects | Gets all objects associated with the IfcProduct in this wrapper.
Public method | GetAnElement | Gets the first element handle added to this wrapper.
Public method | GetElements | Gets the element handles added to this wrapper.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProducts | Gets the product element handles added to this wrapper.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


AddAnnotation Method

[image]

Revit 2013 API
IFCProductWrapper..::..AddAnnotation Method
IFCProductWrapper Class See Also Send Feedback
Adds an annotation handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddAnnotation(
    IFCAnyHandle annoHnd,
    IFCLevelInfo levelInfo,
    bool relateToLevel
)
Visual Basic
Public Sub AddAnnotation ( _
    annoHnd As IFCAnyHandle, _
    levelInfo As IFCLevelInfo, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddAnnotation(
    IFCAnyHandle^ annoHnd,
    IFCLevelInfo^ levelInfo,
    bool relateToLevel
)

Parameters

annoHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The annotation handle.
levelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
Information on the associated level. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the annotation to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


AddBuilding Method

[image]

Revit 2013 API
IFCProductWrapper..::..AddBuilding Method
IFCProductWrapper Class See Also Send Feedback
Adds an IfcBuilding handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddBuilding(
    IFCAnyHandle buildingHandle
)
Visual Basic
Public Sub AddBuilding ( _
    buildingHandle As IFCAnyHandle _
)
Visual C++
public:
void AddBuilding(
    IFCAnyHandle^ buildingHandle
)

Parameters

buildingHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcBuilding handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


AddElement Method

[image] [image]

Revit 2013 API
IFCProductWrapper..::..AddElement Method
IFCProductWrapper Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddElement(IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.
Public method | AddElement(IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean) | Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

See Also

IFCProductWrapper Class
IFCProductWrapper Members
Autodesk.Revit.DB.IFC Namespace


AddElement Method (IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean)

[image]

Revit 2013 API
IFCProductWrapper..::..AddElement Method (IFCAnyHandle, IFCLevelInfo, IFCExtrusionCreationData, Boolean)
IFCProductWrapper Class See Also Send Feedback
Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddElement(
    IFCAnyHandle elementHandle,
    IFCLevelInfo pLevelInfo,
    IFCExtrusionCreationData params,
    bool relateToLevel
)
Visual Basic
Public Sub AddElement ( _
    elementHandle As IFCAnyHandle, _
    pLevelInfo As IFCLevelInfo, _
    params As IFCExtrusionCreationData, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddElement(
    IFCAnyHandle^ elementHandle,
    IFCLevelInfo^ pLevelInfo,
    IFCExtrusionCreationData^ params,
    bool relateToLevel
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcElement handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
The level info.
params
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the element to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
AddElement Overload
Autodesk.Revit.DB.IFC Namespace


AddElement Method (IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean)

[image]

Revit 2013 API
IFCProductWrapper..::..AddElement Method (IFCAnyHandle, IFCPlacementSetter, IFCExtrusionCreationData, Boolean)
IFCProductWrapper Class See Also Send Feedback
Adds an IfcElement handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddElement(
    IFCAnyHandle elementHandle,
    IFCPlacementSetter setter,
    IFCExtrusionCreationData pParams,
    bool relateToLevel
)
Visual Basic
Public Sub AddElement ( _
    elementHandle As IFCAnyHandle, _
    setter As IFCPlacementSetter, _
    pParams As IFCExtrusionCreationData, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddElement(
    IFCAnyHandle^ elementHandle,
    IFCPlacementSetter^ setter,
    IFCExtrusionCreationData^ pParams,
    bool relateToLevel
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcElement handle.
setter
Type: Autodesk.Revit.DB.IFC..::..IFCPlacementSetter
The placement setter.
pParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given element. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the element to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
AddElement Overload
Autodesk.Revit.DB.IFC Namespace


AddFinishMaterial Method

[image]

Revit 2013 API
IFCProductWrapper..::..AddFinishMaterial Method
IFCProductWrapper Class See Also Send Feedback
Adds an material handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddFinishMaterial(
    IFCAnyHandle material
)
Visual Basic
Public Sub AddFinishMaterial ( _
    material As IFCAnyHandle _
)
Visual C++
public:
void AddFinishMaterial(
    IFCAnyHandle^ material
)

Parameters

material
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The material handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


AddSite Method

[image]

Revit 2013 API
IFCProductWrapper..::..AddSite Method
IFCProductWrapper Class See Also Send Feedback
Adds a site (IfcObject) handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSite(
    IFCAnyHandle siteHandle
)
Visual Basic
Public Sub AddSite ( _
    siteHandle As IFCAnyHandle _
)
Visual C++
public:
void AddSite(
    IFCAnyHandle^ siteHandle
)

Parameters

siteHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The site handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


AddSpace Method

[image]

Revit 2013 API
IFCProductWrapper..::..AddSpace Method
IFCProductWrapper Class See Also Send Feedback
Adds an IfcSpace handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddSpace(
    IFCAnyHandle spaceHandle,
    IFCLevelInfo pLevelInfo,
    IFCExtrusionCreationData pParams,
    bool relateToLevel
)
Visual Basic
Public Sub AddSpace ( _
    spaceHandle As IFCAnyHandle, _
    pLevelInfo As IFCLevelInfo, _
    pParams As IFCExtrusionCreationData, _
    relateToLevel As Boolean _
)
Visual C++
public:
void AddSpace(
    IFCAnyHandle^ spaceHandle,
    IFCLevelInfo^ pLevelInfo,
    IFCExtrusionCreationData^ pParams,
    bool relateToLevel
)

Parameters

spaceHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The IfcSpace handle.
pLevelInfo
Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
Information on the associated level.
pParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data associated with the given space. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
relateToLevel
Type: System..::..Boolean
True to relate the space to the level, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


ClearFinishMaterials Method

[image]

Revit 2013 API
IFCProductWrapper..::..ClearFinishMaterials Method
IFCProductWrapper Class See Also Send Feedback
Clear finish materials in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ClearFinishMaterials()
Visual Basic
Public Sub ClearFinishMaterials
Visual C++
public:
void ClearFinishMaterials()

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image] [image]

Revit 2013 API
IFCProductWrapper..::..Create Method
IFCProductWrapper Class See Also Send Feedback

Overload List

Name | Description
Create(IFCProductWrapper) | Establishes a new product manager for elements and objects derived from a parent product manager.
Create(ExporterIFC, Boolean) | Establishes a new baseline product manager for elements and objects.
Create(IFCProductWrapper, Boolean) | Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel

See Also

IFCProductWrapper Class
IFCProductWrapper Members
Autodesk.Revit.DB.IFC Namespace


Create Method (IFCProductWrapper)

[image]

Revit 2013 API
IFCProductWrapper..::..Create Method (IFCProductWrapper)
IFCProductWrapper Class See Also Send Feedback
Establishes a new product manager for elements and objects derived from a parent product manager.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCProductWrapper Create(
    IFCProductWrapper pProductWrapper
)
Visual Basic
Public Shared Function Create ( _
    pProductWrapper As IFCProductWrapper _
) As IFCProductWrapper
Visual C++
public:
static IFCProductWrapper^ Create(
    IFCProductWrapper^ pProductWrapper
)

Parameters

pProductWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The parent product manager.

Return Value

The new product manager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Create Method (ExporterIFC, Boolean)

[image]

Revit 2013 API
IFCProductWrapper..::..Create Method (ExporterIFC, Boolean)
IFCProductWrapper Class See Also Send Feedback
Establishes a new baseline product manager for elements and objects.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCProductWrapper Create(
    ExporterIFC ExporterIFC,
    bool allowRelateToLevel
)
Visual Basic
Public Shared Function Create ( _
    ExporterIFC As ExporterIFC, _
    allowRelateToLevel As Boolean _
) As IFCProductWrapper
Visual C++
public:
static IFCProductWrapper^ Create(
    ExporterIFC^ ExporterIFC,
    bool allowRelateToLevel
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
allowRelateToLevel
Type: System..::..Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

The new baseline product manager.

Remarks

Elements and objects associated to this product manager will be associated to a top-level IfcProduct based on the world coordinate system of the output file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Create Method (IFCProductWrapper, Boolean)

[image]

Revit 2013 API
IFCProductWrapper..::..Create Method (IFCProductWrapper, Boolean)
IFCProductWrapper Class See Also Send Feedback
Establishes a new product manager for elements and objects derived from a parent product manager, allowing override of allowRelateToLevel

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCProductWrapper Create(
    IFCProductWrapper pProductWrapper,
    bool allowRelateToLevel
)
Visual Basic
Public Shared Function Create ( _
    pProductWrapper As IFCProductWrapper, _
    allowRelateToLevel As Boolean _
) As IFCProductWrapper
Visual C++
public:
static IFCProductWrapper^ Create(
    IFCProductWrapper^ pProductWrapper,
    bool allowRelateToLevel
)

Parameters

pProductWrapper
Type: Autodesk.Revit.DB.IFC..::..IFCProductWrapper
The parent product manager.
allowRelateToLevel
Type: System..::..Boolean
True to allow associated elements and objects to relate to a level, false to never allow such a relationship.

Return Value

The new product manager.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCProductWrapper..::..Dispose Method
IFCProductWrapper Class See Also Send Feedback
Releases all resources used by the IFCProductWrapper

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


FindExtrusionCreationParameters Method

[image]

Revit 2013 API
IFCProductWrapper..::..FindExtrusionCreationParameters Method
IFCProductWrapper Class See Also Send Feedback
Obtains the extrusion creation data associated with the given element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCExtrusionCreationData FindExtrusionCreationParameters(
    IFCAnyHandle elementHandle
)
Visual Basic
Public Function FindExtrusionCreationParameters ( _
    elementHandle As IFCAnyHandle _
) As IFCExtrusionCreationData
Visual C++
public:
IFCExtrusionCreationData^ FindExtrusionCreationParameters(
    IFCAnyHandle^ elementHandle
)

Parameters

elementHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Return Value

The parameters. nullNothingnullptra null reference (Nothing in Visual Basic) if no parameters are associated with the element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


GetAllObjects Method

[image]

Revit 2013 API
IFCProductWrapper..::..GetAllObjects Method
IFCProductWrapper Class See Also Send Feedback
Gets all objects associated with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ICollection<IFCAnyHandle> GetAllObjects()
Visual Basic
Public Function GetAllObjects As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetAllObjects()

Return Value

The collection of objects.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


GetAnElement Method

[image]

Revit 2013 API
IFCProductWrapper..::..GetAnElement Method
IFCProductWrapper Class See Also Send Feedback
Gets the first element handle added to this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetAnElement()
Visual Basic
Public Function GetAnElement As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetAnElement()

Return Value

The handle.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


GetElements Method

[image]

Revit 2013 API
IFCProductWrapper..::..GetElements Method
IFCProductWrapper Class See Also Send Feedback
Gets the element handles added to this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetElements()
Visual Basic
Public Function GetElements As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetElements()

Return Value

The collection of the element handles.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


GetProducts Method

[image]

Revit 2013 API
IFCProductWrapper..::..GetProducts Method
IFCProductWrapper Class See Also Send Feedback
Gets the product element handles added to this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<IFCAnyHandle> GetProducts()
Visual Basic
Public Function GetProducts As ICollection(Of IFCAnyHandle)
Visual C++
public:
ICollection<IFCAnyHandle^>^ GetProducts()

Return Value

The collection of the product element handles.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


IFCProductWrapper Properties

[image] [image]

Revit 2013 API
IFCProductWrapper Properties
IFCProductWrapper Class See Also Send Feedback

The IFCProductWrapper type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of objects associated with the IfcProduct in this wrapper.

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


Count Property

[image]

Revit 2013 API
IFCProductWrapper..::..Count Property
IFCProductWrapper Class See Also Send Feedback
The number of objects associated with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

IFCProductWrapper Class
Autodesk.Revit.DB.IFC Namespace


IFCProjectLevelGUIDType Enumeration

[image]

Revit 2013 API
IFCProjectLevelGUIDType Enumeration
See Also Send Feedback
The type of the GUID to be retrieved from Revit.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum IFCProjectLevelGUIDType
Visual Basic
Public Enumeration IFCProjectLevelGUIDType
Visual C++
public enum class IFCProjectLevelGUIDType

Members

Member name | Description
Project | The project GUID.
Building | The building GUID.
Site | The site GUID.

See Also

Autodesk.Revit.DB.IFC Namespace


IFCRange Class

[image]

Revit 2013 API
IFCRange Class
Members See Also Send Feedback
Typically for IFC export, this represents the lower and upper elevations for split wall and column geometry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCRange : IDisposable
Visual Basic
Public Class IFCRange _
    Implements IDisposable
Visual C++
public ref class IFCRange : IDisposable

Remarks

It contains two double values representing the starting and ending values as a range.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCRange

See Also

IFCRange Members
Autodesk.Revit.DB.IFC Namespace


IFCRange Members

[image] [image]

Revit 2013 API
IFCRange Members
IFCRange Class Constructors Methods Properties See Also Send Feedback

The IFCRange type exposes the following members.

Constructors

 | Name | Description
Public method | IFCRange()()()() | Instantiates a default IFCRange object.
Public method | IFCRange(IFCRange) | Instantiates an IFCRange object by copy.
Public method | IFCRange(Double, Double) | Instantiates an IFCRange object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCRange
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | End | The ending value of the range.
Public property | Start | The starting value of the range.

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


IFCRange Constructor

[image] [image]

Revit 2013 API
IFCRange Constructor
IFCRange Class See Also Send Feedback

Overload List

 | Name | Description
Public method | IFCRange()()()() | Instantiates a default IFCRange object.
Public method | IFCRange(IFCRange) | Instantiates an IFCRange object by copy.
Public method | IFCRange(Double, Double) | Instantiates an IFCRange object.

See Also

IFCRange Class
IFCRange Members
Autodesk.Revit.DB.IFC Namespace


IFCRange Constructor

[image]

Revit 2013 API
IFCRange Constructor
IFCRange Class See Also Send Feedback
Instantiates a default IFCRange object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCRange()
Visual Basic
Public Sub New
Visual C++
public:
IFCRange()

Remarks

The starting and ending value are both set to zero.

See Also

IFCRange Class
IFCRange Overload
Autodesk.Revit.DB.IFC Namespace


IFCRange Constructor (IFCRange)

[image]

Revit 2013 API
IFCRange Constructor (IFCRange)
IFCRange Class See Also Send Feedback
Instantiates an IFCRange object by copy.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCRange(
    IFCRange from
)
Visual Basic
Public Sub New ( _
    from As IFCRange _
)
Visual C++
public:
IFCRange(
    IFCRange^ from
)

Parameters

from
Type: Autodesk.Revit.DB.IFC..::..IFCRange
The IFCRange object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCRange Class
IFCRange Overload
Autodesk.Revit.DB.IFC Namespace


IFCRange Constructor (Double, Double)

[image]

Revit 2013 API
IFCRange Constructor (Double, Double)
IFCRange Class See Also Send Feedback
Instantiates an IFCRange object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCRange(
    double start,
    double end
)
Visual Basic
Public Sub New ( _
    start As Double, _
    end As Double _
)
Visual C++
public:
IFCRange(
    double start,
    double end
)

Parameters

start
Type: System..::..Double
The starting value of the range.
end
Type: System..::..Double
The ending value of the range.

See Also

IFCRange Class
IFCRange Overload
Autodesk.Revit.DB.IFC Namespace


IFCRange Methods

[image] [image]

Revit 2013 API
IFCRange Methods
IFCRange Class See Also Send Feedback

The IFCRange type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCRange..::..Dispose Method
IFCRange Class See Also Send Feedback
Releases all resources used by the IFCRange

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


IFCRange Properties

[image] [image]

Revit 2013 API
IFCRange Properties
IFCRange Class See Also Send Feedback

The IFCRange type exposes the following members.

Properties

 | Name | Description
Public property | End | The ending value of the range.
Public property | Start | The starting value of the range.

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


End Property

[image]

Revit 2013 API
IFCRange..::..End Property
IFCRange Class See Also Send Feedback
The ending value of the range.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double End { get; set; }
Visual Basic
Public Property End As Double
    Get
    Set
Visual C++
public:
property double End {
    double get ();
    void set (double value);
}

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


Start Property

[image]

Revit 2013 API
IFCRange..::..Start Property
IFCRange Class See Also Send Feedback
The starting value of the range.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Start { get; set; }
Visual Basic
Public Property Start As Double
    Get
    Set
Visual C++
public:
property double Start {
    double get ();
    void set (double value);
}

See Also

IFCRange Class
Autodesk.Revit.DB.IFC Namespace


IFCStairRampContainerInfo Class

[image]

Revit 2013 API
IFCStairRampContainerInfo Class
Members See Also Send Feedback
Keep track of stair/ramp, flights and railing connectivity information

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class IFCStairRampContainerInfo : IDisposable
Visual Basic
Public Class IFCStairRampContainerInfo _
    Implements IDisposable
Visual C++
public ref class IFCStairRampContainerInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCStairRampContainerInfo

See Also

IFCStairRampContainerInfo Members
Autodesk.Revit.DB.IFC Namespace


IFCStairRampContainerInfo Members

[image] [image]

Revit 2013 API
IFCStairRampContainerInfo Members
IFCStairRampContainerInfo Class Methods See Also Send Feedback

The IFCStairRampContainerInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds a handle to one of the contained component lists.
 | AddStairRampContainerInfo | Add or replace stair/ramp containment information in the exporter class.
 | AppendStairRampContainerInfo | Appends stair/ramp containment information to an existing entry.
 | ContainsStairOrRamp | Checks if the stair or ramp element id has containment information.
 | Create(IFCAnyHandle, IList<(Of <<'(IFCAnyHandle>)>>), IFCAnyHandle) | Creates a new instance of an IFCStairRamp.
 | Create(IList<(Of <<'(IFCAnyHandle>)>>), IList<(Of <<'(IList<(Of <<'(IFCAnyHandle>)>>)>)>>), IList<(Of <<'(IFCAnyHandle>)>>)) | Creates a new instance of an IFCStairRamp.
Public method | Dispose | Releases all resources used by the IFCStairRampContainerInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetComponents | Gets the list of handles to one of the contained component lists.
 | GetContainerInfo | Gets the containment information for a stair or ramp.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Gets the local placement of one of the contained component lists.
Public method | GetStairOrRampHandles | Returns the handles of the hosts in this container.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCStairRampContainerInfo Methods

[image] [image]

Revit 2013 API
IFCStairRampContainerInfo Methods
IFCStairRampContainerInfo Class See Also Send Feedback

The IFCStairRampContainerInfo type exposes the following members.

Methods

 | Name | Description
Public method | AddComponent | Adds a handle to one of the contained component lists.
 | AddStairRampContainerInfo | Add or replace stair/ramp containment information in the exporter class.
 | AppendStairRampContainerInfo | Appends stair/ramp containment information to an existing entry.
 | ContainsStairOrRamp | Checks if the stair or ramp element id has containment information.
 | Create(IFCAnyHandle, IList<(Of <<'(IFCAnyHandle>)>>), IFCAnyHandle) | Creates a new instance of an IFCStairRamp.
 | Create(IList<(Of <<'(IFCAnyHandle>)>>), IList<(Of <<'(IList<(Of <<'(IFCAnyHandle>)>>)>)>>), IList<(Of <<'(IFCAnyHandle>)>>)) | Creates a new instance of an IFCStairRamp.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetComponents | Gets the list of handles to one of the contained component lists.
 | GetContainerInfo | Gets the containment information for a stair or ramp.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalPlacement | Gets the local placement of one of the contained component lists.
Public method | GetStairOrRampHandles | Returns the handles of the hosts in this container.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


AddComponent Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..AddComponent Method
IFCStairRampContainerInfo Class See Also Send Feedback
Adds a handle to one of the contained component lists.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddComponent(
    int index,
    IFCAnyHandle hnd
)
Visual Basic
Public Sub AddComponent ( _
    index As Integer, _
    hnd As IFCAnyHandle _
)
Visual C++
public:
void AddComponent(
    int index,
    IFCAnyHandle^ hnd
)

Parameters

index
Type: System..::..Int32
The component list index.
hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


AddStairRampContainerInfo Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..AddStairRampContainerInfo Method
IFCStairRampContainerInfo Class See Also Send Feedback
Add or replace stair/ramp containment information in the exporter class.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AddStairRampContainerInfo(
    ExporterIFC exporterIFC,
    ElementId stairId,
    IFCStairRampContainerInfo info
)
Visual Basic
Public Shared Sub AddStairRampContainerInfo ( _
    exporterIFC As ExporterIFC, _
    stairId As ElementId, _
    info As IFCStairRampContainerInfo _
)
Visual C++
public:
static void AddStairRampContainerInfo(
    ExporterIFC^ exporterIFC,
    ElementId^ stairId,
    IFCStairRampContainerInfo^ info
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
stairId
Type: Autodesk.Revit.DB..::..ElementId
The stairs id.
info
Type: Autodesk.Revit.DB.IFC..::..IFCStairRampContainerInfo
The containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


AppendStairRampContainerInfo Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..AppendStairRampContainerInfo Method
IFCStairRampContainerInfo Class See Also Send Feedback
Appends stair/ramp containment information to an existing entry.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void AppendStairRampContainerInfo(
    ExporterIFC exporterIFC,
    ElementId stairId,
    IFCStairRampContainerInfo info
)
Visual Basic
Public Shared Sub AppendStairRampContainerInfo ( _
    exporterIFC As ExporterIFC, _
    stairId As ElementId, _
    info As IFCStairRampContainerInfo _
)
Visual C++
public:
static void AppendStairRampContainerInfo(
    ExporterIFC^ exporterIFC,
    ElementId^ stairId,
    IFCStairRampContainerInfo^ info
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
stairId
Type: Autodesk.Revit.DB..::..ElementId
The stairs id.
info
Type: Autodesk.Revit.DB.IFC..::..IFCStairRampContainerInfo
The containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


ContainsStairOrRamp Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..ContainsStairOrRamp Method
IFCStairRampContainerInfo Class See Also Send Feedback
Checks if the stair or ramp element id has containment information.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool ContainsStairOrRamp(
    ExporterIFC exporterIFC,
    ElementId elemId
)
Visual Basic
Public Shared Function ContainsStairOrRamp ( _
    exporterIFC As ExporterIFC, _
    elemId As ElementId _
) As Boolean
Visual C++
public:
static bool ContainsStairOrRamp(
    ExporterIFC^ exporterIFC,
    ElementId^ elemId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The stair or ramp element id.

Return Value

Returns true if the stair or ramp element id has containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image] [image]

Revit 2013 API
IFCStairRampContainerInfo..::..Create Method
IFCStairRampContainerInfo Class See Also Send Feedback

Overload List

Name | Description
Create(IFCAnyHandle, IList<(Of <<'(IFCAnyHandle>)>>), IFCAnyHandle) | Creates a new instance of an IFCStairRamp.
Create(IList<(Of <<'(IFCAnyHandle>)>>), IList<(Of <<'(IList<(Of <<'(IFCAnyHandle>)>>)>)>>), IList<(Of <<'(IFCAnyHandle>)>>)) | Creates a new instance of an IFCStairRamp.

See Also

IFCStairRampContainerInfo Class
IFCStairRampContainerInfo Members
Autodesk.Revit.DB.IFC Namespace


Create Method (IFCAnyHandle, IList(IFCAnyHandle), IFCAnyHandle)

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..Create Method (IFCAnyHandle, IList<(Of <(<'IFCAnyHandle>)>)>, IFCAnyHandle)
IFCStairRampContainerInfo Class See Also Send Feedback
Creates a new instance of an IFCStairRamp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo Create(
    IFCAnyHandle hnd,
    IList<IFCAnyHandle> comps,
    IFCAnyHandle pLocalPlacementHnd
)
Visual Basic
Public Shared Function Create ( _
    hnd As IFCAnyHandle, _
    comps As IList(Of IFCAnyHandle), _
    pLocalPlacementHnd As IFCAnyHandle _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ Create(
    IFCAnyHandle^ hnd,
    IList<IFCAnyHandle^>^ comps,
    IFCAnyHandle^ pLocalPlacementHnd
)

Parameters

hnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
Stairs IFC handle
comps
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Handles of created sub-components
pLocalPlacementHnd
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
Local placement of the Stairs

Return Value

The new IFCStairRamp.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Create Method (IList(IFCAnyHandle), IList(IList(IFCAnyHandle)), IList(IFCAnyHandle))

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..Create Method (IList<(Of <(<'IFCAnyHandle>)>)>, IList<(Of <(<'IList<(Of <(<'IFCAnyHandle>)>)>>)>)>, IList<(Of <(<'IFCAnyHandle>)>)>)
IFCStairRampContainerInfo Class See Also Send Feedback
Creates a new instance of an IFCStairRamp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo Create(
    IList<IFCAnyHandle> hnds,
    IList<IList<IFCAnyHandle>> comps,
    IList<IFCAnyHandle> localPlacementHndArr
)
Visual Basic
Public Shared Function Create ( _
    hnds As IList(Of IFCAnyHandle), _
    comps As IList(Of IList(Of IFCAnyHandle)), _
    localPlacementHndArr As IList(Of IFCAnyHandle) _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ Create(
    IList<IFCAnyHandle^>^ hnds,
    IList<IList<IFCAnyHandle^>^>^ comps,
    IList<IFCAnyHandle^>^ localPlacementHndArr
)

Parameters

hnds
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Stairs IFC handles
comps
Type: System.Collections.Generic..::..IList<(Of <(<'IList<(Of <(<'IFCAnyHandle>)>)>>)>)>
Handles of created sub-components
localPlacementHndArr
Type: System.Collections.Generic..::..IList<(Of <(<'IFCAnyHandle>)>)>
Local placement of the Stairs

Return Value

The new IFCStairRamp.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Create Overload
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..Dispose Method
IFCStairRampContainerInfo Class See Also Send Feedback
Releases all resources used by the IFCStairRampContainerInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


GetComponents Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..GetComponents Method
IFCStairRampContainerInfo Class See Also Send Feedback
Gets the list of handles to one of the contained component lists.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IFCAnyHandle> GetComponents(
    int index
)
Visual Basic
Public Function GetComponents ( _
    index As Integer _
) As IList(Of IFCAnyHandle)
Visual C++
public:
IList<IFCAnyHandle^>^ GetComponents(
    int index
)

Parameters

index
Type: System..::..Int32
The component list index.

Return Value

The handles.

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


GetContainerInfo Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..GetContainerInfo Method
IFCStairRampContainerInfo Class See Also Send Feedback
Gets the containment information for a stair or ramp.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IFCStairRampContainerInfo GetContainerInfo(
    ExporterIFC exporterIFC,
    ElementId elemId
)
Visual Basic
Public Shared Function GetContainerInfo ( _
    exporterIFC As ExporterIFC, _
    elemId As ElementId _
) As IFCStairRampContainerInfo
Visual C++
public:
static IFCStairRampContainerInfo^ GetContainerInfo(
    ExporterIFC^ exporterIFC,
    ElementId^ elemId
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
elemId
Type: Autodesk.Revit.DB..::..ElementId
The stair or ramp element id.

Return Value

The containment information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


GetLocalPlacement Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..GetLocalPlacement Method
IFCStairRampContainerInfo Class See Also Send Feedback
Gets the local placement of one of the contained component lists.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IFCAnyHandle GetLocalPlacement(
    int index
)
Visual Basic
Public Function GetLocalPlacement ( _
    index As Integer _
) As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetLocalPlacement(
    int index
)

Parameters

index
Type: System..::..Int32
The component list index.

Return Value

The handle

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


GetStairOrRampHandles Method

[image]

Revit 2013 API
IFCStairRampContainerInfo..::..GetStairOrRampHandles Method
IFCStairRampContainerInfo Class See Also Send Feedback
Returns the handles of the hosts in this container.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<IFCAnyHandle> GetStairOrRampHandles()
Visual Basic
Public Function GetStairOrRampHandles As IList(Of IFCAnyHandle)
Visual C++
public:
IList<IFCAnyHandle^>^ GetStairOrRampHandles()

Return Value

The handles.

See Also

IFCStairRampContainerInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCTransaction Class

[image]

Revit 2013 API
IFCTransaction Class
Members See Also Send Feedback
IFC transactions are context-like objects that guard any changes made to an IFC file.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCTransaction : IDisposable
Visual Basic
Public Class IFCTransaction _
    Implements IDisposable
Visual C++
public ref class IFCTransaction : IDisposable

Remarks

Any change to an IFC file can only be made while there is an active transaction open for that file. Changes do not become a part of the file until the active transaction is committed. Consequently, all changes made in a transaction can be rolled back either explicitly or implicitly (by the destructor).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTransaction

See Also

IFCTransaction Members
Autodesk.Revit.DB.IFC Namespace


IFCTransaction Members

[image] [image]

Revit 2013 API
IFCTransaction Members
IFCTransaction Class Constructors Methods See Also Send Feedback

The IFCTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | IFCTransaction | Instantiates a transaction object.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the IFC file during the transaction.
Public method | Dispose | Releases all resources used by the IFCTransaction
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RollBack | Rolls back all changes made to the IFC file during the transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


IFCTransaction Constructor

[image]

Revit 2013 API
IFCTransaction Constructor
IFCTransaction Class See Also Send Feedback
Instantiates a transaction object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCTransaction(
    IFCFile file
)
Visual Basic
Public Sub New ( _
    file As IFCFile _
)
Visual C++
public:
IFCTransaction(
    IFCFile^ file
)

Parameters

file
Type: Autodesk.Revit.DB.IFC..::..IFCFile
The IFC file for which this transaction is going to be used.

Remarks

The transaction starts by creating a transaction object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


IFCTransaction Methods

[image] [image]

Revit 2013 API
IFCTransaction Methods
IFCTransaction Class See Also Send Feedback

The IFCTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Commit | Commits all changes made to the IFC file during the transaction.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RollBack | Rolls back all changes made to the IFC file during the transaction.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


Commit Method

[image]

Revit 2013 API
IFCTransaction..::..Commit Method
IFCTransaction Class See Also Send Feedback
Commits all changes made to the IFC file during the transaction.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Commit()
Visual Basic
Public Sub Commit
Visual C++
public:
void Commit()

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCTransaction..::..Dispose Method
IFCTransaction Class See Also Send Feedback
Releases all resources used by the IFCTransaction

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


RollBack Method

[image]

Revit 2013 API
IFCTransaction..::..RollBack Method
IFCTransaction Class See Also Send Feedback
Rolls back all changes made to the IFC file during the transaction.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void RollBack()
Visual Basic
Public Sub RollBack
Visual C++
public:
void RollBack()

See Also

IFCTransaction Class
Autodesk.Revit.DB.IFC Namespace


IFCTransformSetter Class

[image]

Revit 2013 API
IFCTransformSetter Class
Members See Also Send Feedback
A state-based class that forces an extra transformation applied to objects being exported.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCTransformSetter : IDisposable
Visual Basic
Public Class IFCTransformSetter _
    Implements IDisposable
Visual C++
public ref class IFCTransformSetter : IDisposable

Remarks

IFC has a system of local placements; these are created from a set of transforms in Revit. Sometimes there is a need to create a 'fake' transform to get the right local placement structure for IFC. This class is intended to maintain the transformation for the duration that it is needed. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTransformSetter

See Also

IFCTransformSetter Members
Autodesk.Revit.DB.IFC Namespace


IFCTransformSetter Members

[image] [image]

Revit 2013 API
IFCTransformSetter Members
IFCTransformSetter Class Methods See Also Send Feedback

The IFCTransformSetter type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of a transform setter.
Public method | Dispose | Releases all resources used by the IFCTransformSetter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the transformation in the transform setter.
Public method | InitializeFromBoundingBox | Initializes the transformation in the transform setter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


IFCTransformSetter Methods

[image] [image]

Revit 2013 API
IFCTransformSetter Methods
IFCTransformSetter Class See Also Send Feedback

The IFCTransformSetter type exposes the following members.

Methods

 | Name | Description
 | Create | Creates a new instance of a transform setter.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the transformation in the transform setter.
Public method | InitializeFromBoundingBox | Initializes the transformation in the transform setter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


Create Method

[image]

Revit 2013 API
IFCTransformSetter..::..Create Method
IFCTransformSetter Class See Also Send Feedback
Creates a new instance of a transform setter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IFCTransformSetter Create()
Visual Basic
Public Shared Function Create As IFCTransformSetter
Visual C++
public:
static IFCTransformSetter^ Create()

Return Value

The new transform setter.

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCTransformSetter..::..Dispose Method
IFCTransformSetter Class See Also Send Feedback
Releases all resources used by the IFCTransformSetter

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


Initialize Method

[image]

Revit 2013 API
IFCTransformSetter..::..Initialize Method
IFCTransformSetter Class See Also Send Feedback
Initializes the transformation in the transform setter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Initialize(
    ExporterIFC exporterIFC,
    Transform transform
)
Visual Basic
Public Sub Initialize ( _
    exporterIFC As ExporterIFC, _
    transform As Transform _
)
Visual C++
public:
void Initialize(
    ExporterIFC^ exporterIFC,
    Transform^ transform
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
transform
Type: Autodesk.Revit.DB..::..Transform
The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


InitializeFromBoundingBox Method

[image]

Revit 2013 API
IFCTransformSetter..::..InitializeFromBoundingBox Method
IFCTransformSetter Class See Also Send Feedback
Initializes the transformation in the transform setter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform InitializeFromBoundingBox(
    ExporterIFC exporterIFC,
    IList<GeometryObject> geometryList,
    IFCExtrusionCreationData exportBodyParams
)
Visual Basic
Public Function InitializeFromBoundingBox ( _
    exporterIFC As ExporterIFC, _
    geometryList As IList(Of GeometryObject), _
    exportBodyParams As IFCExtrusionCreationData _
) As Transform
Visual C++
public:
Transform^ InitializeFromBoundingBox(
    ExporterIFC^ exporterIFC,
    IList<GeometryObject^>^ geometryList,
    IFCExtrusionCreationData^ exportBodyParams
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
geometryList
Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
The set of geometry used to determine the bounding box.
exportBodyParams
Type: Autodesk.Revit.DB.IFC..::..IFCExtrusionCreationData
The extrusion creation data which contains the local placement.

Return Value

The transform corresponding to the movement, if any.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTransformSetter Class
Autodesk.Revit.DB.IFC Namespace


IFCTypeInfo Class

[image]

Revit 2013 API
IFCTypeInfo Class
Members See Also Send Feedback
An info class representing data about a given element type, typically used for Revit family types.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class IFCTypeInfo : IDisposable
Visual Basic
Public Class IFCTypeInfo _
    Implements IDisposable
Visual C++
public ref class IFCTypeInfo : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTypeInfo

See Also

IFCTypeInfo Members
Autodesk.Revit.DB.IFC Namespace


IFCTypeInfo Members

[image] [image]

Revit 2013 API
IFCTypeInfo Members
IFCTypeInfo Class Constructors Methods Properties See Also Send Feedback

The IFCTypeInfo type exposes the following members.

Constructors

 | Name | Description
Public method | IFCTypeInfo | Constructs a new empty type info object.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the IFCTypeInfo
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get2DMapHandle | Gets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Get3DMapHandle | Gets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStyle | Gets the associated handle to an IfcTypeProduct for the type.
Public method | GetStyleTransform | Gets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Identifies if the object represents a valid type info.
Public method | Set2DMapHandle | Sets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Set3DMapHandle | Sets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | SetStyle | Sets the associated handle to an IfcTypeProduct for the type.
Public method | SetStyleTransform | Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | MaterialId | The material id associated with this type.
Public property | ScaledArea | The area of the type's cross-section, scaled into the units of export.
Public property | ScaledDepth | The depth of the type, scaled into the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the boundaries of the type's cross-section, scaled into the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the boundaries of the type's cross-section, scaled into the units of export.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCTypeInfo Constructor

[image]

Revit 2013 API
IFCTypeInfo Constructor
IFCTypeInfo Class See Also Send Feedback
Constructs a new empty type info object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCTypeInfo()
Visual Basic
Public Sub New
Visual C++
public:
IFCTypeInfo()

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCTypeInfo Methods

[image] [image]

Revit 2013 API
IFCTypeInfo Methods
IFCTypeInfo Class See Also Send Feedback

The IFCTypeInfo type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Get2DMapHandle | Gets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Get3DMapHandle | Gets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetStyle | Gets the associated handle to an IfcTypeProduct for the type.
Public method | GetStyleTransform | Gets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsValid | Identifies if the object represents a valid type info.
Public method | Set2DMapHandle | Sets the associated handle to a 2D IfcRepresentationMap for the type.
Public method | Set3DMapHandle | Sets the associated handle to a 3D IfcRepresentationMap for the type.
Public method | SetStyle | Sets the associated handle to an IfcTypeProduct for the type.
Public method | SetStyleTransform | Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


Dispose Method

[image]

Revit 2013 API
IFCTypeInfo..::..Dispose Method
IFCTypeInfo Class See Also Send Feedback
Releases all resources used by the IFCTypeInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


Get2DMapHandle Method

[image]

Revit 2013 API
IFCTypeInfo..::..Get2DMapHandle Method
IFCTypeInfo Class See Also Send Feedback
Gets the associated handle to a 2D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle Get2DMapHandle()
Visual Basic
Public Function Get2DMapHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ Get2DMapHandle()

Return Value

The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


Get3DMapHandle Method

[image]

Revit 2013 API
IFCTypeInfo..::..Get3DMapHandle Method
IFCTypeInfo Class See Also Send Feedback
Gets the associated handle to a 3D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle Get3DMapHandle()
Visual Basic
Public Function Get3DMapHandle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ Get3DMapHandle()

Return Value

The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


GetStyle Method

[image]

Revit 2013 API
IFCTypeInfo..::..GetStyle Method
IFCTypeInfo Class See Also Send Feedback
Gets the associated handle to an IfcTypeProduct for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IFCAnyHandle GetStyle()
Visual Basic
Public Function GetStyle As IFCAnyHandle
Visual C++
public:
IFCAnyHandle^ GetStyle()

Return Value

The handle.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


GetStyleTransform Method

[image]

Revit 2013 API
IFCTypeInfo..::..GetStyleTransform Method
IFCTypeInfo Class See Also Send Feedback
Gets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public Transform GetStyleTransform()
Visual Basic
Public Function GetStyleTransform As Transform
Visual C++
public:
Transform^ GetStyleTransform()

Return Value

The transform.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


IsValid Method

[image]

Revit 2013 API
IFCTypeInfo..::..IsValid Method
IFCTypeInfo Class See Also Send Feedback
Identifies if the object represents a valid type info.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValid()
Visual Basic
Public Function IsValid As Boolean
Visual C++
public:
bool IsValid()

Return Value

True if the object is valid, false otherwise.

Remarks

A type info must have either the style, 3d map handle, or 2d map handle set to a valid value to be valid.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


Set2DMapHandle Method

[image]

Revit 2013 API
IFCTypeInfo..::..Set2DMapHandle Method
IFCTypeInfo Class See Also Send Feedback
Sets the associated handle to a 2D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set2DMapHandle(
    IFCAnyHandle representationMapHandle
)
Visual Basic
Public Sub Set2DMapHandle ( _
    representationMapHandle As IFCAnyHandle _
)
Visual C++
public:
void Set2DMapHandle(
    IFCAnyHandle^ representationMapHandle
)

Parameters

representationMapHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


Set3DMapHandle Method

[image]

Revit 2013 API
IFCTypeInfo..::..Set3DMapHandle Method
IFCTypeInfo Class See Also Send Feedback
Sets the associated handle to a 3D IfcRepresentationMap for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Set3DMapHandle(
    IFCAnyHandle representationMapHandle
)
Visual Basic
Public Sub Set3DMapHandle ( _
    representationMapHandle As IFCAnyHandle _
)
Visual C++
public:
void Set3DMapHandle(
    IFCAnyHandle^ representationMapHandle
)

Parameters

representationMapHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Remarks

Typically used only for Building Element Proxy elements (masses).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


SetStyle Method

[image]

Revit 2013 API
IFCTypeInfo..::..SetStyle Method
IFCTypeInfo Class See Also Send Feedback
Sets the associated handle to an IfcTypeProduct for the type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetStyle(
    IFCAnyHandle typeProductHandle
)
Visual Basic
Public Sub SetStyle ( _
    typeProductHandle As IFCAnyHandle _
)
Visual C++
public:
void SetStyle(
    IFCAnyHandle^ typeProductHandle
)

Parameters

typeProductHandle
Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The handle.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


SetStyleTransform Method

[image]

Revit 2013 API
IFCTypeInfo..::..SetStyleTransform Method
IFCTypeInfo Class See Also Send Feedback
Sets the transform between the coordinate system of the type and the coordinate system of the instance's location in the Revit model.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetStyleTransform(
    Transform trf
)
Visual Basic
Public Sub SetStyleTransform ( _
    trf As Transform _
)
Visual C++
public:
void SetStyleTransform(
    Transform^ trf
)

Parameters

trf
Type: Autodesk.Revit.DB..::..Transform
The transform.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCTypeInfo Properties

[image] [image]

Revit 2013 API
IFCTypeInfo Properties
IFCTypeInfo Class See Also Send Feedback

The IFCTypeInfo type exposes the following members.

Properties

 | Name | Description
Public property | MaterialId | The material id associated with this type.
Public property | ScaledArea | The area of the type's cross-section, scaled into the units of export.
Public property | ScaledDepth | The depth of the type, scaled into the units of export.
Public property | ScaledInnerPerimeter | The inner perimeter of the boundaries of the type's cross-section, scaled into the units of export.
Public property | ScaledOuterPerimeter | The outer perimeter of the boundaries of the type's cross-section, scaled into the units of export.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


MaterialId Property

[image]

Revit 2013 API
IFCTypeInfo..::..MaterialId Property
IFCTypeInfo Class See Also Send Feedback
The material id associated with this type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId MaterialId { get; set; }
Visual Basic
Public Property MaterialId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MaterialId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


ScaledArea Property

[image]

Revit 2013 API
IFCTypeInfo..::..ScaledArea Property
IFCTypeInfo Class See Also Send Feedback
The area of the type's cross-section, scaled into the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledArea { get; set; }
Visual Basic
Public Property ScaledArea As Double
    Get
    Set
Visual C++
public:
property double ScaledArea {
    double get ();
    void set (double value);
}

Remarks

This property is typically used only for columns, beams and other framing members.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


ScaledDepth Property

[image]

Revit 2013 API
IFCTypeInfo..::..ScaledDepth Property
IFCTypeInfo Class See Also Send Feedback
The depth of the type, scaled into the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledDepth { get; set; }
Visual Basic
Public Property ScaledDepth As Double
    Get
    Set
Visual C++
public:
property double ScaledDepth {
    double get ();
    void set (double value);
}

Remarks

This property is typically used only for columns, beams and other framing members.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


ScaledInnerPerimeter Property

[image]

Revit 2013 API
IFCTypeInfo..::..ScaledInnerPerimeter Property
IFCTypeInfo Class See Also Send Feedback
The inner perimeter of the boundaries of the type's cross-section, scaled into the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledInnerPerimeter { get; set; }
Visual Basic
Public Property ScaledInnerPerimeter As Double
    Get
    Set
Visual C++
public:
property double ScaledInnerPerimeter {
    double get ();
    void set (double value);
}

Remarks

This property is typically used only for columns, beams and other framing members.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


ScaledOuterPerimeter Property

[image]

Revit 2013 API
IFCTypeInfo..::..ScaledOuterPerimeter Property
IFCTypeInfo Class See Also Send Feedback
The outer perimeter of the boundaries of the type's cross-section, scaled into the units of export.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ScaledOuterPerimeter { get; set; }
Visual Basic
Public Property ScaledOuterPerimeter As Double
    Get
    Set
Visual C++
public:
property double ScaledOuterPerimeter {
    double get ();
    void set (double value);
}

Remarks

This property is typically used only for columns, beams and other framing members.

See Also

IFCTypeInfo Class
Autodesk.Revit.DB.IFC Namespace


IFCWindowStyleOperation Enumeration

[image]

Revit 2013 API
IFCWindowStyleOperation Enumeration
See Also Send Feedback
The types of window configurations, as defined in IFC2x3.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum IFCWindowStyleOperation
Visual Basic
Public Enumeration IFCWindowStyleOperation
Visual C++
public enum class IFCWindowStyleOperation

Members

Member name | Description
SinglePanel | Window has a single panel.
DoublePanelVertical | Window has two vertically stacked panels.
DoublePanelHorizontal | Window has two panels side to side.
TriplePanelVertical | Window has three vertically stacked panels.
TriplePanelBottom | Window has two panels side to side, and one panel below these two.
TriplePanelTop | Window has two panels side to side, and one panel above these two.
TriplePanelLeft | Window has two vertically stacked panels, and one panel to the left of these.
TriplePanelRight | Window has two vertically stacked panels, and one panel to the right of these.
TriplePanelHorizontal | Window has three panels side to side.
UserDefined | User-defined window operation.
NotDefined | Undefined window operation.

See Also

Autodesk.Revit.DB.IFC Namespace


Autodesk.Revit.DB.Lighting Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Lighting Namespace
Send Feedback

Classes

 | Class | Description
Public class | AdvancedLossFactor | This class encapsulates advanced lighting loss factor calculation.
Public class | BasicLossFactor | This class encapsulates basic lighting loss factor calculation.
Public class | CircleLightShape | This class encapsulates a circle light shape.
Public class | CustomInitialColor | This class encapsulates a custom initial lighting color.
Public class | HemisphericalLightDistribution | This class encapsulates a hemispherical light distribution.
Public class | InitialColor | This class is the base class for calculating initial light color.
Public class | InitialFluxIntensity | This class encapsulates initial flux intensity calculation.
Public class | InitialIlluminanceIntensity | This class encapsulates initial illuminance intensity calculation.
Public class | InitialIntensity | This class is the base class for calculating lighting initial intensity.
Public class | InitialLuminousIntensity | This class encapsulates initial luminous intensity calculation.
Public class | InitialWattageIntensity | This class encapsulates initial wattage intensity calculation.
Public class | LightDistribution | This class is the base class for specifying light distribution.
Public class | LightFamily | This class encapsulates light family information.
Public class | LightGroup | This class represents a set of lights grouped together for easier management of various lighting scenarios
Public class | LightGroupManager | This class represents a set of light groups that are used for easier management of various lighting scenarios
Public class | LightShape | This class is the base class for specifying light shape.
Public class | LightType | This class encapsulates light information.
Public class | LineLightShape | This class encapsulates a line light shape.
Public class | LossFactor | This class is the base class for calculating lighting loss factor.
Public class | PhotometricWebLightDistribution | This class encapsulates a photometric web light distribution.
Public class | PointLightShape | This class encapsulates a point light shape.
Public class | PresetInitialColor | This class encapsulates a preset initial lighting color.
Public class | RectangleLightShape | This class encapsulates a rectangle light shape.
Public class | SphericalLightDistribution | This class encapsulates a spherical light distribution.
Public class | SpotLightDistribution | This class encapsulates a spot light distribution.

Enumerations

 | Enumeration | Description
Public enumeration | ColorPreset | Preset values of initial colors for specific lighting types
Public enumeration | LightDimmingColor | Tags for specific light dimming colors
Public enumeration | LightDistributionStyle | Tags for specific light distribution styles
Public enumeration | LightShapeStyle | Tags for specific light shape styles


AdvancedLossFactor Class

[image]

Revit 2013 API
AdvancedLossFactor Class
Members See Also Send Feedback
This class encapsulates advanced lighting loss factor calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AdvancedLossFactor : LossFactor
Visual Basic
Public Class AdvancedLossFactor _
    Inherits LossFactor
Visual C++
public ref class AdvancedLossFactor : public LossFactor

Remarks

Advanced lighting loss factor is a combination of several different factors. Each factor has a value of 0.0 (total loss) to 1.0 (no loss).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LossFactor
Autodesk.Revit.DB.Lighting..::..AdvancedLossFactor

See Also

AdvancedLossFactor Members
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Members

[image] [image]

Revit 2013 API
AdvancedLossFactor Members
AdvancedLossFactor Class Constructors Methods Properties See Also Send Feedback

The AdvancedLossFactor type exposes the following members.

Constructors

 | Name | Description
Public method | AdvancedLossFactor()()()() | Creates an advanced loss factor object with values set to no loss.
Public method | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object
Public method | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor.)
Public method | Dispose | (Inherited from LossFactor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BallastLossFactor | The ballast loss factor.
Public property | LampLumenDepreciation | The lamp lumen depreciation loss factor.
Public property | LampTiltLossFactor | The lamp tilt loss factor.
Public property | LossFactorValue | The calculated loss factor value; (Inherited from LossFactor.)
Public property | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor.
Public property | SurfaceDepreciationLossFactor | The surface depreciation loss factor.
Public property | TemperatureLossFactor | The temperature loss factor.
Public property | VoltageLossFactor | The voltage loss factor.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Constructor

[image] [image]

Revit 2013 API
AdvancedLossFactor Constructor
AdvancedLossFactor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AdvancedLossFactor()()()() | Creates an advanced loss factor object with values set to no loss.
Public method | AdvancedLossFactor(AdvancedLossFactor) | Creates a copy of the given advanced loss factor object
Public method | AdvancedLossFactor(Double, Double, Double, Double, Double, Double, Double) | Creates an advanced loss factor object with the given values.

See Also

AdvancedLossFactor Class
AdvancedLossFactor Members
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Constructor

[image]

Revit 2013 API
AdvancedLossFactor Constructor
AdvancedLossFactor Class See Also Send Feedback
Creates an advanced loss factor object with values set to no loss.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AdvancedLossFactor()
Visual Basic
Public Sub New
Visual C++
public:
AdvancedLossFactor()

See Also

AdvancedLossFactor Class
AdvancedLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Constructor (AdvancedLossFactor)

[image]

Revit 2013 API
AdvancedLossFactor Constructor (AdvancedLossFactor)
AdvancedLossFactor Class See Also Send Feedback
Creates a copy of the given advanced loss factor object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AdvancedLossFactor(
    AdvancedLossFactor other
)
Visual Basic
Public Sub New ( _
    other As AdvancedLossFactor _
)
Visual C++
public:
AdvancedLossFactor(
    AdvancedLossFactor^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..AdvancedLossFactor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AdvancedLossFactor Class
AdvancedLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Constructor (Double, Double, Double, Double, Double, Double, Double)

[image]

Revit 2013 API
AdvancedLossFactor Constructor (Double, Double, Double, Double, Double, Double, Double)
AdvancedLossFactor Class See Also Send Feedback
Creates an advanced loss factor object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AdvancedLossFactor(
    double ballastLossFactorIn,
    double lampLumenDepreciationIn,
    double lampTiltLossFactorIn,
    double luminaireDirtDepreciationIn,
    double surfaceDepreciationLossFactorIn,
    double temperatureLossFactorIn,
    double voltageLossFactorIn
)
Visual Basic
Public Sub New ( _
    ballastLossFactorIn As Double, _
    lampLumenDepreciationIn As Double, _
    lampTiltLossFactorIn As Double, _
    luminaireDirtDepreciationIn As Double, _
    surfaceDepreciationLossFactorIn As Double, _
    temperatureLossFactorIn As Double, _
    voltageLossFactorIn As Double _
)
Visual C++
public:
AdvancedLossFactor(
    double ballastLossFactorIn,
    double lampLumenDepreciationIn,
    double lampTiltLossFactorIn,
    double luminaireDirtDepreciationIn,
    double surfaceDepreciationLossFactorIn,
    double temperatureLossFactorIn,
    double voltageLossFactorIn
)

Parameters

ballastLossFactorIn
Type: System..::..Double
The ballast loss factor as a numerical value between 0.0 and 1.0.
lampLumenDepreciationIn
Type: System..::..Double
The lamp lumen depreciation loss factor as a numerical value between 0.0 and 1.0.
lampTiltLossFactorIn
Type: System..::..Double
The lamp tilt loss factor as a numerical value between 0.0 and 1.0.
luminaireDirtDepreciationIn
Type: System..::..Double
The luminaire dirt depreciation loss factor as a numerical value between 0.0 and 1.0.
surfaceDepreciationLossFactorIn
Type: System..::..Double
The surface depreciation loss factor as a numerical value between 0.0 and 1.0.
temperatureLossFactorIn
Type: System..::..Double
The temperature loss factor as a numerical value between 0.0 and 2.0.
voltageLossFactorIn
Type: System..::..Double
The voltage loss factor as a numerical value between 0.0 and 2.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The loss factor is not valid because it is not between 0.0 and 1.0. -or- The loss factor is not valid because it is not between 0.0 and 2.0.

See Also

AdvancedLossFactor Class
AdvancedLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Methods

[image] [image]

Revit 2013 API
AdvancedLossFactor Methods
AdvancedLossFactor Class See Also Send Feedback

The AdvancedLossFactor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor.)
Public method | Dispose | (Inherited from LossFactor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


AdvancedLossFactor Properties

[image] [image]

Revit 2013 API
AdvancedLossFactor Properties
AdvancedLossFactor Class See Also Send Feedback

The AdvancedLossFactor type exposes the following members.

Properties

 | Name | Description
Public property | BallastLossFactor | The ballast loss factor.
Public property | LampLumenDepreciation | The lamp lumen depreciation loss factor.
Public property | LampTiltLossFactor | The lamp tilt loss factor.
Public property | LossFactorValue | The calculated loss factor value; (Inherited from LossFactor.)
Public property | LuminaireDirtDepreciation | The luminaire dirt depreciation loss factor.
Public property | SurfaceDepreciationLossFactor | The surface depreciation loss factor.
Public property | TemperatureLossFactor | The temperature loss factor.
Public property | VoltageLossFactor | The voltage loss factor.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


BallastLossFactor Property

[image]

Revit 2013 API
AdvancedLossFactor..::..BallastLossFactor Property
AdvancedLossFactor Class See Also Send Feedback
The ballast loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double BallastLossFactor { get; set; }
Visual Basic
Public Property BallastLossFactor As Double
    Get
    Set
Visual C++
public:
property double BallastLossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 1.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 1.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LampLumenDepreciation Property

[image]

Revit 2013 API
AdvancedLossFactor..::..LampLumenDepreciation Property
AdvancedLossFactor Class See Also Send Feedback
The lamp lumen depreciation loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LampLumenDepreciation { get; set; }
Visual Basic
Public Property LampLumenDepreciation As Double
    Get
    Set
Visual C++
public:
property double LampLumenDepreciation {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 1.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 1.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LampTiltLossFactor Property

[image]

Revit 2013 API
AdvancedLossFactor..::..LampTiltLossFactor Property
AdvancedLossFactor Class See Also Send Feedback
The lamp tilt loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LampTiltLossFactor { get; set; }
Visual Basic
Public Property LampTiltLossFactor As Double
    Get
    Set
Visual C++
public:
property double LampTiltLossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 1.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 1.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LuminaireDirtDepreciation Property

[image]

Revit 2013 API
AdvancedLossFactor..::..LuminaireDirtDepreciation Property
AdvancedLossFactor Class See Also Send Feedback
The luminaire dirt depreciation loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LuminaireDirtDepreciation { get; set; }
Visual Basic
Public Property LuminaireDirtDepreciation As Double
    Get
    Set
Visual C++
public:
property double LuminaireDirtDepreciation {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 1.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 1.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


SurfaceDepreciationLossFactor Property

[image]

Revit 2013 API
AdvancedLossFactor..::..SurfaceDepreciationLossFactor Property
AdvancedLossFactor Class See Also Send Feedback
The surface depreciation loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SurfaceDepreciationLossFactor { get; set; }
Visual Basic
Public Property SurfaceDepreciationLossFactor As Double
    Get
    Set
Visual C++
public:
property double SurfaceDepreciationLossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 1.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 1.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


TemperatureLossFactor Property

[image]

Revit 2013 API
AdvancedLossFactor..::..TemperatureLossFactor Property
AdvancedLossFactor Class See Also Send Feedback
The temperature loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TemperatureLossFactor { get; set; }
Visual Basic
Public Property TemperatureLossFactor As Double
    Get
    Set
Visual C++
public:
property double TemperatureLossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 2.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 2.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


VoltageLossFactor Property

[image]

Revit 2013 API
AdvancedLossFactor..::..VoltageLossFactor Property
AdvancedLossFactor Class See Also Send Feedback
The voltage loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double VoltageLossFactor { get; set; }
Visual Basic
Public Property VoltageLossFactor As Double
    Get
    Set
Visual C++
public:
property double VoltageLossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 2.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 2.0.

See Also

AdvancedLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Class

[image]

Revit 2013 API
BasicLossFactor Class
Members See Also Send Feedback
This class encapsulates basic lighting loss factor calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class BasicLossFactor : LossFactor
Visual Basic
Public Class BasicLossFactor _
    Inherits LossFactor
Visual C++
public ref class BasicLossFactor : public LossFactor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LossFactor
Autodesk.Revit.DB.Lighting..::..BasicLossFactor

See Also

BasicLossFactor Members
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Members

[image] [image]

Revit 2013 API
BasicLossFactor Members
BasicLossFactor Class Constructors Methods Properties See Also Send Feedback

The BasicLossFactor type exposes the following members.

Constructors

 | Name | Description
Public method | BasicLossFactor()()()() | Creates a basic loss factor object with no loss.
Public method | BasicLossFactor(Double) | Creates a basic loss factor object with the given value.
Public method | BasicLossFactor(BasicLossFactor) | Creates a copy of the given basic loss factor object

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor.)
Public method | Dispose | (Inherited from LossFactor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LossFactor | The loss factor.
Public property | LossFactorValue | The calculated loss factor value; (Inherited from LossFactor.)

See Also

BasicLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Constructor

[image] [image]

Revit 2013 API
BasicLossFactor Constructor
BasicLossFactor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BasicLossFactor()()()() | Creates a basic loss factor object with no loss.
Public method | BasicLossFactor(Double) | Creates a basic loss factor object with the given value.
Public method | BasicLossFactor(BasicLossFactor) | Creates a copy of the given basic loss factor object

See Also

BasicLossFactor Class
BasicLossFactor Members
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Constructor

[image]

Revit 2013 API
BasicLossFactor Constructor
BasicLossFactor Class See Also Send Feedback
Creates a basic loss factor object with no loss.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BasicLossFactor()
Visual Basic
Public Sub New
Visual C++
public:
BasicLossFactor()

See Also

BasicLossFactor Class
BasicLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Constructor (Double)

[image]

Revit 2013 API
BasicLossFactor Constructor (Double)
BasicLossFactor Class See Also Send Feedback
Creates a basic loss factor object with the given value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BasicLossFactor(
    double lossFactorIn
)
Visual Basic
Public Sub New ( _
    lossFactorIn As Double _
)
Visual C++
public:
BasicLossFactor(
    double lossFactorIn
)

Parameters

lossFactorIn
Type: System..::..Double
The loss factor as a numerical value between 0.0 and 4.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The loss factor is not valid because it is not between 0.0 and 4.0.

See Also

BasicLossFactor Class
BasicLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Constructor (BasicLossFactor)

[image]

Revit 2013 API
BasicLossFactor Constructor (BasicLossFactor)
BasicLossFactor Class See Also Send Feedback
Creates a copy of the given basic loss factor object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public BasicLossFactor(
    BasicLossFactor other
)
Visual Basic
Public Sub New ( _
    other As BasicLossFactor _
)
Visual C++
public:
BasicLossFactor(
    BasicLossFactor^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..BasicLossFactor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

BasicLossFactor Class
BasicLossFactor Overload
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Methods

[image] [image]

Revit 2013 API
BasicLossFactor Methods
BasicLossFactor Class See Also Send Feedback

The BasicLossFactor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object. (Inherited from LossFactor.)
Public method | Dispose | (Inherited from LossFactor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasicLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


BasicLossFactor Properties

[image] [image]

Revit 2013 API
BasicLossFactor Properties
BasicLossFactor Class See Also Send Feedback

The BasicLossFactor type exposes the following members.

Properties

 | Name | Description
Public property | LossFactor | The loss factor.
Public property | LossFactorValue | The calculated loss factor value; (Inherited from LossFactor.)

See Also

BasicLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LossFactor Property

[image]

Revit 2013 API
BasicLossFactor..::..LossFactor Property
BasicLossFactor Class See Also Send Feedback
The loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LossFactor { get; set; }
Visual Basic
Public Property LossFactor As Double
    Get
    Set
Visual C++
public:
property double LossFactor {
    double get ();
    void set (double value);
}

Field Value

The loss factor as a numerical value between 0.0 and 4.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The loss factor is not valid because it is not between 0.0 and 4.0.

See Also

BasicLossFactor Class
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Class

[image]

Revit 2013 API
CircleLightShape Class
Members See Also Send Feedback
This class encapsulates a circle light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CircleLightShape : LightShape
Visual Basic
Public Class CircleLightShape _
    Inherits LightShape
Visual C++
public ref class CircleLightShape : public LightShape

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightShape
Autodesk.Revit.DB.Lighting..::..CircleLightShape

See Also

CircleLightShape Members
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Members

[image] [image]

Revit 2013 API
CircleLightShape Members
CircleLightShape Class Constructors Methods Properties See Also Send Feedback

The CircleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | CircleLightShape()()()() | Creates a circle light shape object with 2.0' emit diameter.
Public method | CircleLightShape(Double) | Creates a circle light shape object with the given emit diameter.
Public method | CircleLightShape(CircleLightShape) | Creates a copy of the given circle light shape

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitDiameter | The emit diameter.

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Constructor

[image] [image]

Revit 2013 API
CircleLightShape Constructor
CircleLightShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CircleLightShape()()()() | Creates a circle light shape object with 2.0' emit diameter.
Public method | CircleLightShape(Double) | Creates a circle light shape object with the given emit diameter.
Public method | CircleLightShape(CircleLightShape) | Creates a copy of the given circle light shape

See Also

CircleLightShape Class
CircleLightShape Members
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Constructor

[image]

Revit 2013 API
CircleLightShape Constructor
CircleLightShape Class See Also Send Feedback
Creates a circle light shape object with 2.0' emit diameter.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CircleLightShape()
Visual Basic
Public Sub New
Visual C++
public:
CircleLightShape()

See Also

CircleLightShape Class
CircleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Constructor (Double)

[image]

Revit 2013 API
CircleLightShape Constructor (Double)
CircleLightShape Class See Also Send Feedback
Creates a circle light shape object with the given emit diameter.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CircleLightShape(
    double emitDiameter
)
Visual Basic
Public Sub New ( _
    emitDiameter As Double _
)
Visual C++
public:
CircleLightShape(
    double emitDiameter
)

Parameters

emitDiameter
Type: System..::..Double
The emit diameter as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

CircleLightShape Class
CircleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Constructor (CircleLightShape)

[image]

Revit 2013 API
CircleLightShape Constructor (CircleLightShape)
CircleLightShape Class See Also Send Feedback
Creates a copy of the given circle light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CircleLightShape(
    CircleLightShape other
)
Visual Basic
Public Sub New ( _
    other As CircleLightShape _
)
Visual C++
public:
CircleLightShape(
    CircleLightShape^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..CircleLightShape

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CircleLightShape Class
CircleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Methods

[image] [image]

Revit 2013 API
CircleLightShape Methods
CircleLightShape Class See Also Send Feedback

The CircleLightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


CircleLightShape Properties

[image] [image]

Revit 2013 API
CircleLightShape Properties
CircleLightShape Class See Also Send Feedback

The CircleLightShape type exposes the following members.

Properties

 | Name | Description
Public property | EmitDiameter | The emit diameter.

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


EmitDiameter Property

[image]

Revit 2013 API
CircleLightShape..::..EmitDiameter Property
CircleLightShape Class See Also Send Feedback
The emit diameter.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EmitDiameter { get; set; }
Visual Basic
Public Property EmitDiameter As Double
    Get
    Set
Visual C++
public:
property double EmitDiameter {
    double get ();
    void set (double value);
}

Field Value

The emit diameter as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

CircleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


ColorPreset Enumeration

[image]

Revit 2013 API
ColorPreset Enumeration
See Also Send Feedback
Preset values of initial colors for specific lighting types

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ColorPreset
Visual Basic
Public Enumeration ColorPreset
Visual C++
public enum class ColorPreset

Members

Member name | Description
D65 | D65.
D50 | D50.
Halogen | Halogen.
Incandescent | Incandescent.
Xenon | Xenon.
Quartz | Quartz.
FluorescentWarm | F4 fluorescent warm white.
FluorescentCool | F4 fluorescent cool white.
FluorescentWhite | F4 fluorescent white.
FluorescentDayLight | F4 fluorescent day light.
FluorescentLightWhite | F4 fluorescent light white.
MetalHalide | Metal halide.
HighPressureSodium | High pressure sodium.
LowPressureSodium | Low pressure sodium.
Mercury | Mercury.
PhosphorMercury | Phosphor mercury.

See Also

Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Class

[image]

Revit 2013 API
CustomInitialColor Class
Members See Also Send Feedback
This class encapsulates a custom initial lighting color.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CustomInitialColor : InitialColor
Visual Basic
Public Class CustomInitialColor _
    Inherits InitialColor
Visual C++
public ref class CustomInitialColor : public InitialColor

Remarks

This color is called an initial color because a color filter can also be added to modify the color.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialColor
Autodesk.Revit.DB.Lighting..::..CustomInitialColor

See Also

CustomInitialColor Members
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Members

[image] [image]

Revit 2013 API
CustomInitialColor Members
CustomInitialColor Class Constructors Methods Properties See Also Send Feedback

The CustomInitialColor type exposes the following members.

Constructors

 | Name | Description
Public method | CustomInitialColor(Double) | Creates a custom initial color set to the given color
Public method | CustomInitialColor(CustomInitialColor) | Creates a copy of the given custom initial color

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object. (Inherited from InitialColor.)
Public method | Dispose | (Inherited from InitialColor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Temperature | The custom color temperature value.
Public property | TemperatureValue | The light color temperature value in Kelvins. (Inherited from InitialColor.)

See Also

CustomInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Constructor

[image] [image]

Revit 2013 API
CustomInitialColor Constructor
CustomInitialColor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CustomInitialColor(Double) | Creates a custom initial color set to the given color
Public method | CustomInitialColor(CustomInitialColor) | Creates a copy of the given custom initial color

See Also

CustomInitialColor Class
CustomInitialColor Members
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Constructor (Double)

[image]

Revit 2013 API
CustomInitialColor Constructor (Double)
CustomInitialColor Class See Also Send Feedback
Creates a custom initial color set to the given color

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CustomInitialColor(
    double temperature
)
Visual Basic
Public Sub New ( _
    temperature As Double _
)
Visual C++
public:
CustomInitialColor(
    double temperature
)

Parameters

temperature
Type: System..::..Double
The color temperature in Kelvin as a numerical value between 1800 and 20000

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The color temperature is not valid because it is not in the range of 1800 to 20000.

See Also

CustomInitialColor Class
CustomInitialColor Overload
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Constructor (CustomInitialColor)

[image]

Revit 2013 API
CustomInitialColor Constructor (CustomInitialColor)
CustomInitialColor Class See Also Send Feedback
Creates a copy of the given custom initial color

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public CustomInitialColor(
    CustomInitialColor other
)
Visual Basic
Public Sub New ( _
    other As CustomInitialColor _
)
Visual C++
public:
CustomInitialColor(
    CustomInitialColor^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..CustomInitialColor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

CustomInitialColor Class
CustomInitialColor Overload
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Methods

[image] [image]

Revit 2013 API
CustomInitialColor Methods
CustomInitialColor Class See Also Send Feedback

The CustomInitialColor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object. (Inherited from InitialColor.)
Public method | Dispose | (Inherited from InitialColor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


CustomInitialColor Properties

[image] [image]

Revit 2013 API
CustomInitialColor Properties
CustomInitialColor Class See Also Send Feedback

The CustomInitialColor type exposes the following members.

Properties

 | Name | Description
Public property | Temperature | The custom color temperature value.
Public property | TemperatureValue | The light color temperature value in Kelvins. (Inherited from InitialColor.)

See Also

CustomInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


Temperature Property

[image]

Revit 2013 API
CustomInitialColor..::..Temperature Property
CustomInitialColor Class See Also Send Feedback
The custom color temperature value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Temperature { get; set; }
Visual Basic
Public Property Temperature As Double
    Get
    Set
Visual C++
public:
property double Temperature {
    double get ();
    void set (double value);
}

Field Value

The color temperature in Kelvin as a numerical value between 1800 and 20000

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The color temperature is not valid because it is not in the range of 1800 to 20000.

See Also

CustomInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Class

[image]

Revit 2013 API
HemisphericalLightDistribution Class
Members See Also Send Feedback
This class encapsulates a hemispherical light distribution.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class HemisphericalLightDistribution : LightDistribution
Visual Basic
Public Class HemisphericalLightDistribution _
    Inherits LightDistribution
Visual C++
public ref class HemisphericalLightDistribution : public LightDistribution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightDistribution
Autodesk.Revit.DB.Lighting..::..HemisphericalLightDistribution

See Also

HemisphericalLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Members

[image] [image]

Revit 2013 API
HemisphericalLightDistribution Members
HemisphericalLightDistribution Class Constructors Methods See Also Send Feedback

The HemisphericalLightDistribution type exposes the following members.

Constructors

 | Name | Description
Public method | HemisphericalLightDistribution()()()() | Creates a hemispherical light distribution object.
Public method | HemisphericalLightDistribution(HemisphericalLightDistribution) | Creates a copy of the given hemispherical light distribution

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HemisphericalLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Constructor

[image] [image]

Revit 2013 API
HemisphericalLightDistribution Constructor
HemisphericalLightDistribution Class See Also Send Feedback

Overload List

 | Name | Description
Public method | HemisphericalLightDistribution()()()() | Creates a hemispherical light distribution object.
Public method | HemisphericalLightDistribution(HemisphericalLightDistribution) | Creates a copy of the given hemispherical light distribution

See Also

HemisphericalLightDistribution Class
HemisphericalLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Constructor

[image]

Revit 2013 API
HemisphericalLightDistribution Constructor
HemisphericalLightDistribution Class See Also Send Feedback
Creates a hemispherical light distribution object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public HemisphericalLightDistribution()
Visual Basic
Public Sub New
Visual C++
public:
HemisphericalLightDistribution()

See Also

HemisphericalLightDistribution Class
HemisphericalLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Constructor (HemisphericalLightDistribution)

[image]

Revit 2013 API
HemisphericalLightDistribution Constructor (HemisphericalLightDistribution)
HemisphericalLightDistribution Class See Also Send Feedback
Creates a copy of the given hemispherical light distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public HemisphericalLightDistribution(
    HemisphericalLightDistribution other
)
Visual Basic
Public Sub New ( _
    other As HemisphericalLightDistribution _
)
Visual C++
public:
HemisphericalLightDistribution(
    HemisphericalLightDistribution^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..HemisphericalLightDistribution

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

HemisphericalLightDistribution Class
HemisphericalLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


HemisphericalLightDistribution Methods

[image] [image]

Revit 2013 API
HemisphericalLightDistribution Methods
HemisphericalLightDistribution Class See Also Send Feedback

The HemisphericalLightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HemisphericalLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


InitialColor Class

[image]

Revit 2013 API
InitialColor Class
Members See Also Send Feedback
This class is the base class for calculating initial light color.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialColor : IDisposable
Visual Basic
Public Class InitialColor _
    Implements IDisposable
Visual C++
public ref class InitialColor : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialColor
Autodesk.Revit.DB.Lighting..::..CustomInitialColor
Autodesk.Revit.DB.Lighting..::..PresetInitialColor

See Also

InitialColor Members
Autodesk.Revit.DB.Lighting Namespace


InitialColor Members

[image] [image]

Revit 2013 API
InitialColor Members
InitialColor Class Methods Properties See Also Send Feedback

The InitialColor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object.
Public method | Dispose | Releases all resources used by the InitialColor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TemperatureValue | The light color temperature value in Kelvins.

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


InitialColor Methods

[image] [image]

Revit 2013 API
InitialColor Methods
InitialColor Class See Also Send Feedback

The InitialColor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


Clone Method

[image]

Revit 2013 API
InitialColor..::..Clone Method
InitialColor Class See Also Send Feedback
Creates a copy of the InitialColor derived object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialColor Clone()
Visual Basic
Public Function Clone As InitialColor
Visual C++
public:
InitialColor^ Clone()

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
InitialColor..::..Dispose Method
InitialColor Class See Also Send Feedback
Releases all resources used by the InitialColor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


InitialColor Properties

[image] [image]

Revit 2013 API
InitialColor Properties
InitialColor Class See Also Send Feedback

The InitialColor type exposes the following members.

Properties

 | Name | Description
Public property | TemperatureValue | The light color temperature value in Kelvins.

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


TemperatureValue Property

[image]

Revit 2013 API
InitialColor..::..TemperatureValue Property
InitialColor Class See Also Send Feedback
The light color temperature value in Kelvins.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TemperatureValue { get; }
Visual Basic
Public ReadOnly Property TemperatureValue As Double
    Get
Visual C++
public:
property double TemperatureValue {
    double get ();
}

See Also

InitialColor Class
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Class

[image]

Revit 2013 API
InitialFluxIntensity Class
Members See Also Send Feedback
This class encapsulates initial flux intensity calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialFluxIntensity : InitialIntensity
Visual Basic
Public Class InitialFluxIntensity _
    Inherits InitialIntensity
Visual C++
public ref class InitialFluxIntensity : public InitialIntensity

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialIntensity
Autodesk.Revit.DB.Lighting..::..InitialFluxIntensity

See Also

InitialFluxIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Members

[image] [image]

Revit 2013 API
InitialFluxIntensity Members
InitialFluxIntensity Class Constructors Methods Properties See Also Send Feedback

The InitialFluxIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialFluxIntensity(Double) | Creates an initial flux intensity object with the given document and flux values.
Public method | InitialFluxIntensity(InitialFluxIntensity) | Creates a copy of the given initial flux intensity object

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Flux | The flux intensity value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)

See Also

InitialFluxIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Constructor

[image] [image]

Revit 2013 API
InitialFluxIntensity Constructor
InitialFluxIntensity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InitialFluxIntensity(Double) | Creates an initial flux intensity object with the given document and flux values.
Public method | InitialFluxIntensity(InitialFluxIntensity) | Creates a copy of the given initial flux intensity object

See Also

InitialFluxIntensity Class
InitialFluxIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Constructor (Double)

[image]

Revit 2013 API
InitialFluxIntensity Constructor (Double)
InitialFluxIntensity Class See Also Send Feedback
Creates an initial flux intensity object with the given document and flux values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialFluxIntensity(
    double flux
)
Visual Basic
Public Sub New ( _
    flux As Double _
)
Visual C++
public:
InitialFluxIntensity(
    double flux
)

Parameters

flux
Type: System..::..Double
The flux value in lm as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The flux intensity value is not valid because it is not between 0 and 1e+30.

See Also

InitialFluxIntensity Class
InitialFluxIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Constructor (InitialFluxIntensity)

[image]

Revit 2013 API
InitialFluxIntensity Constructor (InitialFluxIntensity)
InitialFluxIntensity Class See Also Send Feedback
Creates a copy of the given initial flux intensity object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialFluxIntensity(
    InitialFluxIntensity other
)
Visual Basic
Public Sub New ( _
    other As InitialFluxIntensity _
)
Visual C++
public:
InitialFluxIntensity(
    InitialFluxIntensity^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..InitialFluxIntensity

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InitialFluxIntensity Class
InitialFluxIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Methods

[image] [image]

Revit 2013 API
InitialFluxIntensity Methods
InitialFluxIntensity Class See Also Send Feedback

The InitialFluxIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialFluxIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialFluxIntensity Properties

[image] [image]

Revit 2013 API
InitialFluxIntensity Properties
InitialFluxIntensity Class See Also Send Feedback

The InitialFluxIntensity type exposes the following members.

Properties

 | Name | Description
Public property | Flux | The flux intensity value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)

See Also

InitialFluxIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Flux Property

[image]

Revit 2013 API
InitialFluxIntensity..::..Flux Property
InitialFluxIntensity Class See Also Send Feedback
The flux intensity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Flux { get; set; }
Visual Basic
Public Property Flux As Double
    Get
    Set
Visual C++
public:
property double Flux {
    double get ();
    void set (double value);
}

Field Value

The flux value in lm as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The flux intensity value is not valid because it is not between 0 and 1e+30.

See Also

InitialFluxIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Class

[image]

Revit 2013 API
InitialIlluminanceIntensity Class
Members See Also Send Feedback
This class encapsulates initial illuminance intensity calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialIlluminanceIntensity : InitialIntensity
Visual Basic
Public Class InitialIlluminanceIntensity _
    Inherits InitialIntensity
Visual C++
public ref class InitialIlluminanceIntensity : public InitialIntensity

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialIntensity
Autodesk.Revit.DB.Lighting..::..InitialIlluminanceIntensity

See Also

InitialIlluminanceIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Members

[image] [image]

Revit 2013 API
InitialIlluminanceIntensity Members
InitialIlluminanceIntensity Class Constructors Methods Properties See Also Send Feedback

The InitialIlluminanceIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialIlluminanceIntensity(InitialIlluminanceIntensity) | Creates a copy of the given initial illuminance intensity object
Public method | InitialIlluminanceIntensity(Double, Double) | Creates an initial illuminance intensity object with the given document and illuminance values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Distance | The illuminance intensity distance value.
Public property | Illuminance | The illuminance intensity value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Constructor

[image] [image]

Revit 2013 API
InitialIlluminanceIntensity Constructor
InitialIlluminanceIntensity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InitialIlluminanceIntensity(InitialIlluminanceIntensity) | Creates a copy of the given initial illuminance intensity object
Public method | InitialIlluminanceIntensity(Double, Double) | Creates an initial illuminance intensity object with the given document and illuminance values.

See Also

InitialIlluminanceIntensity Class
InitialIlluminanceIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Constructor (InitialIlluminanceIntensity)

[image]

Revit 2013 API
InitialIlluminanceIntensity Constructor (InitialIlluminanceIntensity)
InitialIlluminanceIntensity Class See Also Send Feedback
Creates a copy of the given initial illuminance intensity object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialIlluminanceIntensity(
    InitialIlluminanceIntensity other
)
Visual Basic
Public Sub New ( _
    other As InitialIlluminanceIntensity _
)
Visual C++
public:
InitialIlluminanceIntensity(
    InitialIlluminanceIntensity^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..InitialIlluminanceIntensity

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InitialIlluminanceIntensity Class
InitialIlluminanceIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Constructor (Double, Double)

[image]

Revit 2013 API
InitialIlluminanceIntensity Constructor (Double, Double)
InitialIlluminanceIntensity Class See Also Send Feedback
Creates an initial illuminance intensity object with the given document and illuminance values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialIlluminanceIntensity(
    double distance,
    double illuminance
)
Visual Basic
Public Sub New ( _
    distance As Double, _
    illuminance As Double _
)
Visual C++
public:
InitialIlluminanceIntensity(
    double distance,
    double illuminance
)

Parameters

distance
Type: System..::..Double
The illuminance distance value in feet as a numerical value between 0 and 1e+30.
illuminance
Type: System..::..Double
The illuminance value in lx as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The distance value is not valid because it is not between 0 and 1e+30. -or- The illuminance value is not valid because it is not between 0 and 1e+30.

See Also

InitialIlluminanceIntensity Class
InitialIlluminanceIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Methods

[image] [image]

Revit 2013 API
InitialIlluminanceIntensity Methods
InitialIlluminanceIntensity Class See Also Send Feedback

The InitialIlluminanceIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIlluminanceIntensity Properties

[image] [image]

Revit 2013 API
InitialIlluminanceIntensity Properties
InitialIlluminanceIntensity Class See Also Send Feedback

The InitialIlluminanceIntensity type exposes the following members.

Properties

 | Name | Description
Public property | Distance | The illuminance intensity distance value.
Public property | Illuminance | The illuminance intensity value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Distance Property

[image]

Revit 2013 API
InitialIlluminanceIntensity..::..Distance Property
InitialIlluminanceIntensity Class See Also Send Feedback
The illuminance intensity distance value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
    Get
    Set
Visual C++
public:
property double Distance {
    double get ();
    void set (double value);
}

Field Value

The illuminance distance value in feet as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The distance value is not valid because it is not between 0 and 1e+30.

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Illuminance Property

[image]

Revit 2013 API
InitialIlluminanceIntensity..::..Illuminance Property
InitialIlluminanceIntensity Class See Also Send Feedback
The illuminance intensity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Illuminance { get; set; }
Visual Basic
Public Property Illuminance As Double
    Get
    Set
Visual C++
public:
property double Illuminance {
    double get ();
    void set (double value);
}

Field Value

The illuminance value in lx as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The illuminance value is not valid because it is not between 0 and 1e+30.

See Also

InitialIlluminanceIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIntensity Class

[image]

Revit 2013 API
InitialIntensity Class
Members See Also Send Feedback
This class is the base class for calculating lighting initial intensity.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialIntensity : IDisposable
Visual Basic
Public Class InitialIntensity _
    Implements IDisposable
Visual C++
public ref class InitialIntensity : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialIntensity
Autodesk.Revit.DB.Lighting..::..InitialFluxIntensity
Autodesk.Revit.DB.Lighting..::..InitialIlluminanceIntensity
Autodesk.Revit.DB.Lighting..::..InitialLuminousIntensity
Autodesk.Revit.DB.Lighting..::..InitialWattageIntensity

See Also

InitialIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialIntensity Members

[image] [image]

Revit 2013 API
InitialIntensity Members
InitialIntensity Class Methods Properties See Also Send Feedback

The InitialIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object.
Public method | Dispose | Releases all resources used by the InitialIntensity
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InitialIntensityValue | The calculated initial intensity value.

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIntensity Methods

[image] [image]

Revit 2013 API
InitialIntensity Methods
InitialIntensity Class See Also Send Feedback

The InitialIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Clone Method

[image]

Revit 2013 API
InitialIntensity..::..Clone Method
InitialIntensity Class See Also Send Feedback
Creates a copy of the InitialIntensity derived object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialIntensity Clone()
Visual Basic
Public Function Clone As InitialIntensity
Visual C++
public:
InitialIntensity^ Clone()

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
InitialIntensity..::..Dispose Method
InitialIntensity Class See Also Send Feedback
Releases all resources used by the InitialIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIntensity Properties

[image] [image]

Revit 2013 API
InitialIntensity Properties
InitialIntensity Class See Also Send Feedback

The InitialIntensity type exposes the following members.

Properties

 | Name | Description
Public property | InitialIntensityValue | The calculated initial intensity value.

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialIntensityValue Property

[image]

Revit 2013 API
InitialIntensity..::..InitialIntensityValue Property
InitialIntensity Class See Also Send Feedback
The calculated initial intensity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double InitialIntensityValue { get; }
Visual Basic
Public ReadOnly Property InitialIntensityValue As Double
    Get
Visual C++
public:
property double InitialIntensityValue {
    double get ();
}

See Also

InitialIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Class

[image]

Revit 2013 API
InitialLuminousIntensity Class
Members See Also Send Feedback
This class encapsulates initial luminous intensity calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialLuminousIntensity : InitialIntensity
Visual Basic
Public Class InitialLuminousIntensity _
    Inherits InitialIntensity
Visual C++
public ref class InitialLuminousIntensity : public InitialIntensity

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialIntensity
Autodesk.Revit.DB.Lighting..::..InitialLuminousIntensity

See Also

InitialLuminousIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Members

[image] [image]

Revit 2013 API
InitialLuminousIntensity Members
InitialLuminousIntensity Class Constructors Methods Properties See Also Send Feedback

The InitialLuminousIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialLuminousIntensity(Double) | Creates an initial luminous intensity object with the given document and luminosity values.
Public method | InitialLuminousIntensity(InitialLuminousIntensity) | Creates a copy of the given initial luminous intensity object

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)
Public property | Luminosity | The luminosity value.

See Also

InitialLuminousIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Constructor

[image] [image]

Revit 2013 API
InitialLuminousIntensity Constructor
InitialLuminousIntensity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InitialLuminousIntensity(Double) | Creates an initial luminous intensity object with the given document and luminosity values.
Public method | InitialLuminousIntensity(InitialLuminousIntensity) | Creates a copy of the given initial luminous intensity object

See Also

InitialLuminousIntensity Class
InitialLuminousIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Constructor (Double)

[image]

Revit 2013 API
InitialLuminousIntensity Constructor (Double)
InitialLuminousIntensity Class See Also Send Feedback
Creates an initial luminous intensity object with the given document and luminosity values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialLuminousIntensity(
    double luminosity
)
Visual Basic
Public Sub New ( _
    luminosity As Double _
)
Visual C++
public:
InitialLuminousIntensity(
    double luminosity
)

Parameters

luminosity
Type: System..::..Double
The luminosity value in cd as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The luminosity value is not valid because it is not between 0 and 1e+30.

See Also

InitialLuminousIntensity Class
InitialLuminousIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Constructor (InitialLuminousIntensity)

[image]

Revit 2013 API
InitialLuminousIntensity Constructor (InitialLuminousIntensity)
InitialLuminousIntensity Class See Also Send Feedback
Creates a copy of the given initial luminous intensity object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialLuminousIntensity(
    InitialLuminousIntensity other
)
Visual Basic
Public Sub New ( _
    other As InitialLuminousIntensity _
)
Visual C++
public:
InitialLuminousIntensity(
    InitialLuminousIntensity^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..InitialLuminousIntensity

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InitialLuminousIntensity Class
InitialLuminousIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Methods

[image] [image]

Revit 2013 API
InitialLuminousIntensity Methods
InitialLuminousIntensity Class See Also Send Feedback

The InitialLuminousIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialLuminousIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialLuminousIntensity Properties

[image] [image]

Revit 2013 API
InitialLuminousIntensity Properties
InitialLuminousIntensity Class See Also Send Feedback

The InitialLuminousIntensity type exposes the following members.

Properties

 | Name | Description
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)
Public property | Luminosity | The luminosity value.

See Also

InitialLuminousIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Luminosity Property

[image]

Revit 2013 API
InitialLuminousIntensity..::..Luminosity Property
InitialLuminousIntensity Class See Also Send Feedback
The luminosity value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Luminosity { get; set; }
Visual Basic
Public Property Luminosity As Double
    Get
    Set
Visual C++
public:
property double Luminosity {
    double get ();
    void set (double value);
}

Field Value

The luminosity value in cd as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The luminosity value is not valid because it is not between 0 and 1e+30.

See Also

InitialLuminousIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Class

[image]

Revit 2013 API
InitialWattageIntensity Class
Members See Also Send Feedback
This class encapsulates initial wattage intensity calculation.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class InitialWattageIntensity : InitialIntensity
Visual Basic
Public Class InitialWattageIntensity _
    Inherits InitialIntensity
Visual C++
public ref class InitialWattageIntensity : public InitialIntensity

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialIntensity
Autodesk.Revit.DB.Lighting..::..InitialWattageIntensity

See Also

InitialWattageIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Members

[image] [image]

Revit 2013 API
InitialWattageIntensity Members
InitialWattageIntensity Class Constructors Methods Properties See Also Send Feedback

The InitialWattageIntensity type exposes the following members.

Constructors

 | Name | Description
Public method | InitialWattageIntensity(InitialWattageIntensity) | Creates a copy of the given initial wattage intensity object
Public method | InitialWattageIntensity(Double, Double) | Creates an initial wattage intensity object with the given values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Efficacy | The efficacy value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)
Public property | Wattage | The wattage value.

See Also

InitialWattageIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Constructor

[image] [image]

Revit 2013 API
InitialWattageIntensity Constructor
InitialWattageIntensity Class See Also Send Feedback

Overload List

 | Name | Description
Public method | InitialWattageIntensity(InitialWattageIntensity) | Creates a copy of the given initial wattage intensity object
Public method | InitialWattageIntensity(Double, Double) | Creates an initial wattage intensity object with the given values.

See Also

InitialWattageIntensity Class
InitialWattageIntensity Members
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Constructor (InitialWattageIntensity)

[image]

Revit 2013 API
InitialWattageIntensity Constructor (InitialWattageIntensity)
InitialWattageIntensity Class See Also Send Feedback
Creates a copy of the given initial wattage intensity object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialWattageIntensity(
    InitialWattageIntensity other
)
Visual Basic
Public Sub New ( _
    other As InitialWattageIntensity _
)
Visual C++
public:
InitialWattageIntensity(
    InitialWattageIntensity^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..InitialWattageIntensity

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

InitialWattageIntensity Class
InitialWattageIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Constructor (Double, Double)

[image]

Revit 2013 API
InitialWattageIntensity Constructor (Double, Double)
InitialWattageIntensity Class See Also Send Feedback
Creates an initial wattage intensity object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialWattageIntensity(
    double efficacy,
    double wattage
)
Visual Basic
Public Sub New ( _
    efficacy As Double, _
    wattage As Double _
)
Visual C++
public:
InitialWattageIntensity(
    double efficacy,
    double wattage
)

Parameters

efficacy
Type: System..::..Double
The universal unit efficacy value as a numerical value between 0 and 1e+30.
wattage
Type: System..::..Double
The universal unit wattage value as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The efficacy value is not valid because it is not between 0 and 1e+30. -or- The wattage value is not valid because it is not between 0 and 1e+30.

See Also

InitialWattageIntensity Class
InitialWattageIntensity Overload
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Methods

[image] [image]

Revit 2013 API
InitialWattageIntensity Methods
InitialWattageIntensity Class See Also Send Feedback

The InitialWattageIntensity type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity.)
Public method | Dispose | (Inherited from InitialIntensity.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InitialWattageIntensity Class
Autodesk.Revit.DB.Lighting Namespace


InitialWattageIntensity Properties

[image] [image]

Revit 2013 API
InitialWattageIntensity Properties
InitialWattageIntensity Class See Also Send Feedback

The InitialWattageIntensity type exposes the following members.

Properties

 | Name | Description
Public property | Efficacy | The efficacy value.
Public property | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity.)
Public property | Wattage | The wattage value.

See Also

InitialWattageIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Efficacy Property

[image]

Revit 2013 API
InitialWattageIntensity..::..Efficacy Property
InitialWattageIntensity Class See Also Send Feedback
The efficacy value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Efficacy { get; set; }
Visual Basic
Public Property Efficacy As Double
    Get
    Set
Visual C++
public:
property double Efficacy {
    double get ();
    void set (double value);
}

Field Value

The efficacy value in lm/W as a numerical value greater than 0.0 and less than 1.0e+10.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The efficacy value is not valid because it is not between 0 and 1e+30.

See Also

InitialWattageIntensity Class
Autodesk.Revit.DB.Lighting Namespace


Wattage Property

[image]

Revit 2013 API
InitialWattageIntensity..::..Wattage Property
InitialWattageIntensity Class See Also Send Feedback
The wattage value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Wattage { get; set; }
Visual Basic
Public Property Wattage As Double
    Get
    Set
Visual C++
public:
property double Wattage {
    double get ();
    void set (double value);
}

Field Value

The wattage value in W as a numerical value between 0 and 1e+30.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The wattage value is not valid because it is not between 0 and 1e+30.

See Also

InitialWattageIntensity Class
Autodesk.Revit.DB.Lighting Namespace


LightDimmingColor Enumeration

[image]

Revit 2013 API
LightDimmingColor Enumeration
See Also Send Feedback
Tags for specific light dimming colors

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum LightDimmingColor
Visual Basic
Public Enumeration LightDimmingColor
Visual C++
public enum class LightDimmingColor

Members

Member name | Description
None | No dimming color.
Incandescent | Incandescent lamp curve dimming color.

See Also

Autodesk.Revit.DB.Lighting Namespace


LightDistribution Class

[image]

Revit 2013 API
LightDistribution Class
Members See Also Send Feedback
This class is the base class for specifying light distribution.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightDistribution : IDisposable
Visual Basic
Public Class LightDistribution _
    Implements IDisposable
Visual C++
public ref class LightDistribution : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightDistribution
Autodesk.Revit.DB.Lighting..::..HemisphericalLightDistribution
Autodesk.Revit.DB.Lighting..::..PhotometricWebLightDistribution
Autodesk.Revit.DB.Lighting..::..SphericalLightDistribution
Autodesk.Revit.DB.Lighting..::..SpotLightDistribution

See Also

LightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


LightDistribution Members

[image] [image]

Revit 2013 API
LightDistribution Members
LightDistribution Class Methods See Also Send Feedback

The LightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object.
Public method | Dispose | Releases all resources used by the LightDistribution
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


LightDistribution Methods

[image] [image]

Revit 2013 API
LightDistribution Methods
LightDistribution Class See Also Send Feedback

The LightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


Clone Method

[image]

Revit 2013 API
LightDistribution..::..Clone Method
LightDistribution Class See Also Send Feedback
Creates a copy of the LightDistribution derived object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightDistribution Clone()
Visual Basic
Public Function Clone As LightDistribution
Visual C++
public:
LightDistribution^ Clone()

See Also

LightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightDistribution..::..Dispose Method
LightDistribution Class See Also Send Feedback
Releases all resources used by the LightDistribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


LightDistributionStyle Enumeration

[image]

Revit 2013 API
LightDistributionStyle Enumeration
See Also Send Feedback
Tags for specific light distribution styles

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum LightDistributionStyle
Visual Basic
Public Enumeration LightDistributionStyle
Visual C++
public enum class LightDistributionStyle

Members

Member name | Description
Spherical | Spherical light distribution.
Hemispherical | Hemispherical light distribution.
Spot | Spot light distribution.
PhotometricWeb | Photometric web (IES) light distribution.

See Also

Autodesk.Revit.DB.Lighting Namespace


LightFamily Class

[image]

Revit 2013 API
LightFamily Class
Members See Also Send Feedback
This class encapsulates light family information.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightFamily : IDisposable
Visual Basic
Public Class LightFamily _
    Implements IDisposable
Visual C++
public ref class LightFamily : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightFamily

See Also

LightFamily Members
Autodesk.Revit.DB.Lighting Namespace


LightFamily Members

[image] [image]

Revit 2013 API
LightFamily Members
LightFamily Class Methods See Also Send Feedback

The LightFamily type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LightFamily
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDistributionStyle | Returns a LightDistributionStyle value for the light distribution
 | GetLightFamily | Creates a light family object from the given family document
Public method | GetLightShapeStyle | Returns a LightShapeStyle value for the light shape
Public method | GetLightSourceTransform | Returns the transformation matrix of the relocated light source.
Public method | GetLightType | Return a LightType object for the light type at the given index
Public method | GetLightTypeName | Return the name for the light type at the given index
Public method | GetNumberOfLightTypes | Return the number of light types contained in this light family
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLightDistributionStyle | Set the light distribution style to the given shape distribution
Public method | SetLightShapeStyle | Set the light shape style to the given shape style
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


LightFamily Methods

[image] [image]

Revit 2013 API
LightFamily Methods
LightFamily Class See Also Send Feedback

The LightFamily type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDistributionStyle | Returns a LightDistributionStyle value for the light distribution
 | GetLightFamily | Creates a light family object from the given family document
Public method | GetLightShapeStyle | Returns a LightShapeStyle value for the light shape
Public method | GetLightSourceTransform | Returns the transformation matrix of the relocated light source.
Public method | GetLightType | Return a LightType object for the light type at the given index
Public method | GetLightTypeName | Return the name for the light type at the given index
Public method | GetNumberOfLightTypes | Return the number of light types contained in this light family
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetLightDistributionStyle | Set the light distribution style to the given shape distribution
Public method | SetLightShapeStyle | Set the light shape style to the given shape style
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightFamily..::..Dispose Method
LightFamily Class See Also Send Feedback
Releases all resources used by the LightFamily

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightDistributionStyle Method

[image]

Revit 2013 API
LightFamily..::..GetLightDistributionStyle Method
LightFamily Class See Also Send Feedback
Returns a LightDistributionStyle value for the light distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightDistributionStyle GetLightDistributionStyle()
Visual Basic
Public Function GetLightDistributionStyle As LightDistributionStyle
Visual C++
public:
LightDistributionStyle GetLightDistributionStyle()

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightFamily Method

[image]

Revit 2013 API
LightFamily..::..GetLightFamily Method
LightFamily Class See Also Send Feedback
Creates a light family object from the given family document

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightFamily GetLightFamily(
    Document document
)
Visual Basic
Public Shared Function GetLightFamily ( _
    document As Document _
) As LightFamily
Visual C++
public:
static LightFamily^ GetLightFamily(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The family document

Return Value

The newly created LightFamily object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The Document is the argument that is being validated The document is not valid because it is not a light family document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightShapeStyle Method

[image]

Revit 2013 API
LightFamily..::..GetLightShapeStyle Method
LightFamily Class See Also Send Feedback
Returns a LightShapeStyle value for the light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightShapeStyle GetLightShapeStyle()
Visual Basic
Public Function GetLightShapeStyle As LightShapeStyle
Visual C++
public:
LightShapeStyle GetLightShapeStyle()

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightSourceTransform Method

[image]

Revit 2013 API
LightFamily..::..GetLightSourceTransform Method
LightFamily Class See Also Send Feedback
Returns the transformation matrix of the relocated light source.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Transform GetLightSourceTransform()
Visual Basic
Public Function GetLightSourceTransform As Transform
Visual C++
public:
Transform^ GetLightSourceTransform()

Return Value

The light source transform.

Remarks

When the user moves or rotates the light source in family editor, the returned value contains the transformation matrix of the new location. It may be an identity matrix.

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightType Method

[image]

Revit 2013 API
LightFamily..::..GetLightType Method
LightFamily Class See Also Send Feedback
Return a LightType object for the light type at the given index

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightType GetLightType(
    int index
)
Visual Basic
Public Function GetLightType ( _
    index As Integer _
) As LightType
Visual C++
public:
LightType^ GetLightType(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the light type

Return Value

A LightType object for the light type at the given index

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is the argument that is being validated The index is not valid because it does not correspond to a valid light type

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetLightTypeName Method

[image]

Revit 2013 API
LightFamily..::..GetLightTypeName Method
LightFamily Class See Also Send Feedback
Return the name for the light type at the given index

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string GetLightTypeName(
    int index
)
Visual Basic
Public Function GetLightTypeName ( _
    index As Integer _
) As String
Visual C++
public:
String^ GetLightTypeName(
    int index
)

Parameters

index
Type: System..::..Int32
The index of the light type

Return Value

The name of the light type at the given index

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The index is the argument that is being validated The index is not valid because it does not correspond to a valid light type

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


GetNumberOfLightTypes Method

[image]

Revit 2013 API
LightFamily..::..GetNumberOfLightTypes Method
LightFamily Class See Also Send Feedback
Return the number of light types contained in this light family

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetNumberOfLightTypes()
Visual Basic
Public Function GetNumberOfLightTypes As Integer
Visual C++
public:
int GetNumberOfLightTypes()

Return Value

The number of light types contained in this light family

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


SetLightDistributionStyle Method

[image]

Revit 2013 API
LightFamily..::..SetLightDistributionStyle Method
LightFamily Class See Also Send Feedback
Set the light distribution style to the given shape distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightDistributionStyle(
    LightDistributionStyle lightDistributionStyle
)
Visual Basic
Public Sub SetLightDistributionStyle ( _
    lightDistributionStyle As LightDistributionStyle _
)
Visual C++
public:
void SetLightDistributionStyle(
    LightDistributionStyle lightDistributionStyle
)

Parameters

lightDistributionStyle
Type: Autodesk.Revit.DB.Lighting..::..LightDistributionStyle
The light distribution style to set the light distribution type to

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


SetLightShapeStyle Method

[image]

Revit 2013 API
LightFamily..::..SetLightShapeStyle Method
LightFamily Class See Also Send Feedback
Set the light shape style to the given shape style

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightShapeStyle(
    LightShapeStyle lightShapeStyle
)
Visual Basic
Public Sub SetLightShapeStyle ( _
    lightShapeStyle As LightShapeStyle _
)
Visual C++
public:
void SetLightShapeStyle(
    LightShapeStyle lightShapeStyle
)

Parameters

lightShapeStyle
Type: Autodesk.Revit.DB.Lighting..::..LightShapeStyle
The light shape style value to set the light shape style to

See Also

LightFamily Class
Autodesk.Revit.DB.Lighting Namespace


LightGroup Class

[image]

Revit 2013 API
LightGroup Class
Members See Also Send Feedback
This class represents a set of lights grouped together for easier management of various lighting scenarios

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightGroup : IDisposable
Visual Basic
Public Class LightGroup _
    Implements IDisposable
Visual C++
public ref class LightGroup : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightGroup

See Also

LightGroup Members
Autodesk.Revit.DB.Lighting Namespace


LightGroup Members

[image] [image]

Revit 2013 API
LightGroup Members
LightGroup Class Methods Properties See Also Send Feedback

The LightGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddLight | Add a new light instance to the group
Public method | Dispose | Releases all resources used by the LightGroup
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLights | Get the set of contained light instances The set of light instances
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveLight | Remove the given light instance from the set of light instances in this group
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The ElementId of the LightGroup
Public property | Name | The name of the LightGroup

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


LightGroup Methods

[image] [image]

Revit 2013 API
LightGroup Methods
LightGroup Class See Also Send Feedback

The LightGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddLight | Add a new light instance to the group
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLights | Get the set of contained light instances The set of light instances
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveLight | Remove the given light instance from the set of light instances in this group
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


AddLight Method

[image]

Revit 2013 API
LightGroup..::..AddLight Method
LightGroup Class See Also Send Feedback
Add a new light instance to the group

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddLight(
    ElementId lightId
)
Visual Basic
Public Sub AddLight ( _
    lightId As ElementId _
)
Visual C++
public:
void AddLight(
    ElementId^ lightId
)

Parameters

lightId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the light instance to add to the group

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element ID does not correspond to a light instance -or- The light instance is in this LightGroup
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightGroup..::..Dispose Method
LightGroup Class See Also Send Feedback
Releases all resources used by the LightGroup

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


GetLights Method

[image]

Revit 2013 API
LightGroup..::..GetLights Method
LightGroup Class See Also Send Feedback
Get the set of contained light instances The set of light instances

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetLights()
Visual Basic
Public Function GetLights As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetLights()

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


RemoveLight Method

[image]

Revit 2013 API
LightGroup..::..RemoveLight Method
LightGroup Class See Also Send Feedback
Remove the given light instance from the set of light instances in this group

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveLight(
    ElementId lightId
)
Visual Basic
Public Sub RemoveLight ( _
    lightId As ElementId _
)
Visual C++
public:
void RemoveLight(
    ElementId^ lightId
)

Parameters

lightId
Type: Autodesk.Revit.DB..::..ElementId
The light instance to remove

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The light instance is not in this LightGroup
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


LightGroup Properties

[image] [image]

Revit 2013 API
LightGroup Properties
LightGroup Class See Also Send Feedback

The LightGroup type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ElementId of the LightGroup
Public property | Name | The name of the LightGroup

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


Id Property

[image]

Revit 2013 API
LightGroup..::..Id Property
LightGroup Class See Also Send Feedback
The ElementId of the LightGroup

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Id { get; }
Visual Basic
Public ReadOnly Property Id As ElementId
    Get
Visual C++
public:
property ElementId^ Id {
    ElementId^ get ();
}

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


Name Property

[image]

Revit 2013 API
LightGroup..::..Name Property
LightGroup Class See Also Send Feedback
The name of the LightGroup

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: name cannot include prohibited characters. -or- When setting this property: The name is not valid because it is not unique within this LightGroupManager
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

LightGroup Class
Autodesk.Revit.DB.Lighting Namespace


LightGroupManager Class

[image]

Revit 2013 API
LightGroupManager Class
Members See Also Send Feedback
This class represents a set of light groups that are used for easier management of various lighting scenarios

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightGroupManager : IDisposable
Visual Basic
Public Class LightGroupManager _
    Implements IDisposable
Visual C++
public ref class LightGroupManager : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightGroupManager

See Also

LightGroupManager Members
Autodesk.Revit.DB.Lighting Namespace


LightGroupManager Members

[image] [image]

Revit 2013 API
LightGroupManager Members
LightGroupManager Class Methods See Also Send Feedback

The LightGroupManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateGroup | Create a new LightGroup object with the given name
Public method | DeleteGroup | Remove the given LightGroup object from the set of LightGroup objects
Public method | Dispose | Releases all resources used by the LightGroupManager
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGroups | Get the set of contained LightGroup objects The set of LightGroup objects
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDimmer | Gets the dimmer value for the given light for rendering the given view
 | GetLightGroupManager | Creates a light group manager object from the given document
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLightGroupOn | Returns true if the given light group is on
Public method | IsLightOn | Returns true if the given light is on for rendering the given view
Public method | SetLightDimmer | Sets the dimmer value for the given light for rendering the given view
Public method | SetLightGroupOn | Turns the given light group on or off for rendering the given view depending on the bool argument
Public method | SetLightOn | Turns the given light on or off for rendering the given view depending on the bool argument
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


LightGroupManager Methods

[image] [image]

Revit 2013 API
LightGroupManager Methods
LightGroupManager Class See Also Send Feedback

The LightGroupManager type exposes the following members.

Methods

 | Name | Description
Public method | CreateGroup | Create a new LightGroup object with the given name
Public method | DeleteGroup | Remove the given LightGroup object from the set of LightGroup objects
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetGroups | Get the set of contained LightGroup objects The set of LightGroup objects
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLightDimmer | Gets the dimmer value for the given light for rendering the given view
 | GetLightGroupManager | Creates a light group manager object from the given document
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsLightGroupOn | Returns true if the given light group is on
Public method | IsLightOn | Returns true if the given light is on for rendering the given view
Public method | SetLightDimmer | Sets the dimmer value for the given light for rendering the given view
Public method | SetLightGroupOn | Turns the given light group on or off for rendering the given view depending on the bool argument
Public method | SetLightOn | Turns the given light on or off for rendering the given view depending on the bool argument
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


CreateGroup Method

[image]

Revit 2013 API
LightGroupManager..::..CreateGroup Method
LightGroupManager Class See Also Send Feedback
Create a new LightGroup object with the given name

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightGroup CreateGroup(
    string name
)
Visual Basic
Public Function CreateGroup ( _
    name As String _
) As LightGroup
Visual C++
public:
LightGroup^ CreateGroup(
    String^ name
)

Parameters

name
Type: System..::..String
The name to use for the new LightGroup object

Return Value

The new LightGroup object that was created

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The name is not valid because it is not unique within this LightGroupManager -or- name cannot include prohibited characters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


DeleteGroup Method

[image]

Revit 2013 API
LightGroupManager..::..DeleteGroup Method
LightGroupManager Class See Also Send Feedback
Remove the given LightGroup object from the set of LightGroup objects

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void DeleteGroup(
    ElementId groupId
)
Visual Basic
Public Sub DeleteGroup ( _
    groupId As ElementId _
)
Visual C++
public:
void DeleteGroup(
    ElementId^ groupId
)

Parameters

groupId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the LightGroup object to remove

Remarks

Note that only the group is deleted, not the lights contained in the group The lights will still exist but will not be in a group any longer

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a light group -or- The LightGroup is not contained by this LightGroupManager
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightGroupManager..::..Dispose Method
LightGroupManager Class See Also Send Feedback
Releases all resources used by the LightGroupManager

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


GetGroups Method

[image]

Revit 2013 API
LightGroupManager..::..GetGroups Method
LightGroupManager Class See Also Send Feedback
Get the set of contained LightGroup objects The set of LightGroup objects

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<LightGroup> GetGroups()
Visual Basic
Public Function GetGroups As IList(Of LightGroup)
Visual C++
public:
IList<LightGroup^>^ GetGroups()

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


GetLightDimmer Method

[image]

Revit 2013 API
LightGroupManager..::..GetLightDimmer Method
LightGroupManager Class See Also Send Feedback
Gets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetLightDimmer(
    ElementId viewId,
    ElementId lightId
)
Visual Basic
Public Function GetLightDimmer ( _
    viewId As ElementId, _
    lightId As ElementId _
) As Double
Visual C++
public:
double GetLightDimmer(
    ElementId^ viewId,
    ElementId^ lightId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
lightId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light to turn on or off

Remarks

The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


GetLightGroupManager Method

[image]

Revit 2013 API
LightGroupManager..::..GetLightGroupManager Method
LightGroupManager Class See Also Send Feedback
Creates a light group manager object from the given document

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightGroupManager GetLightGroupManager(
    Document document
)
Visual Basic
Public Shared Function GetLightGroupManager ( _
    document As Document _
) As LightGroupManager
Visual C++
public:
static LightGroupManager^ GetLightGroupManager(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document the manager is from

Return Value

The newly created Light group manager object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document is not valid because it is not a project (rvt) document
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


IsLightGroupOn Method

[image]

Revit 2013 API
LightGroupManager..::..IsLightGroupOn Method
LightGroupManager Class See Also Send Feedback
Returns true if the given light group is on

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsLightGroupOn(
    ElementId viewId,
    ElementId groupId
)
Visual Basic
Public Function IsLightGroupOn ( _
    viewId As ElementId, _
    groupId As ElementId _
) As Boolean
Visual C++
public:
bool IsLightGroupOn(
    ElementId^ viewId,
    ElementId^ groupId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
groupId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light group

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light group
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


IsLightOn Method

[image]

Revit 2013 API
LightGroupManager..::..IsLightOn Method
LightGroupManager Class See Also Send Feedback
Returns true if the given light is on for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsLightOn(
    ElementId viewId,
    ElementId lightId
)
Visual Basic
Public Function IsLightOn ( _
    viewId As ElementId, _
    lightId As ElementId _
) As Boolean
Visual C++
public:
bool IsLightOn(
    ElementId^ viewId,
    ElementId^ lightId
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
lightId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


SetLightDimmer Method

[image]

Revit 2013 API
LightGroupManager..::..SetLightDimmer Method
LightGroupManager Class See Also Send Feedback
Sets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightDimmer(
    ElementId viewId,
    ElementId lightId,
    double dimmingValue
)
Visual Basic
Public Sub SetLightDimmer ( _
    viewId As ElementId, _
    lightId As ElementId, _
    dimmingValue As Double _
)
Visual C++
public:
void SetLightDimmer(
    ElementId^ viewId,
    ElementId^ lightId,
    double dimmingValue
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
lightId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light to turn on or off
dimmingValue
Type: System..::..Double
The dimmer value to set int the range of [0.0, 1.0]

Remarks

The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance -or- The given dimming value is not in the range [0.0, 1.0]
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


SetLightGroupOn Method

[image]

Revit 2013 API
LightGroupManager..::..SetLightGroupOn Method
LightGroupManager Class See Also Send Feedback
Turns the given light group on or off for rendering the given view depending on the bool argument

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightGroupOn(
    ElementId viewId,
    ElementId groupId,
    bool turnOn
)
Visual Basic
Public Sub SetLightGroupOn ( _
    viewId As ElementId, _
    groupId As ElementId, _
    turnOn As Boolean _
)
Visual C++
public:
void SetLightGroupOn(
    ElementId^ viewId,
    ElementId^ groupId,
    bool turnOn
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
groupId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light group
turnOn
Type: System..::..Boolean
Turns the light group on if true, off if false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light group
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


SetLightOn Method

[image]

Revit 2013 API
LightGroupManager..::..SetLightOn Method
LightGroupManager Class See Also Send Feedback
Turns the given light on or off for rendering the given view depending on the bool argument

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightOn(
    ElementId viewId,
    ElementId lightId,
    bool turnOn
)
Visual Basic
Public Sub SetLightOn ( _
    viewId As ElementId, _
    lightId As ElementId, _
    turnOn As Boolean _
)
Visual C++
public:
void SetLightOn(
    ElementId^ viewId,
    ElementId^ lightId,
    bool turnOn
)

Parameters

viewId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the view
lightId
Type: Autodesk.Revit.DB..::..ElementId
The Id of the light to turn on or off
turnOn
Type: System..::..Boolean
Turns the light on if true, off if false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightGroupManager Class
Autodesk.Revit.DB.Lighting Namespace


LightShape Class

[image]

Revit 2013 API
LightShape Class
Members See Also Send Feedback
This class is the base class for specifying light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightShape : IDisposable
Visual Basic
Public Class LightShape _
    Implements IDisposable
Visual C++
public ref class LightShape : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightShape
Autodesk.Revit.DB.Lighting..::..CircleLightShape
Autodesk.Revit.DB.Lighting..::..LineLightShape
Autodesk.Revit.DB.Lighting..::..PointLightShape
Autodesk.Revit.DB.Lighting..::..RectangleLightShape

See Also

LightShape Members
Autodesk.Revit.DB.Lighting Namespace


LightShape Members

[image] [image]

Revit 2013 API
LightShape Members
LightShape Class Methods See Also Send Feedback

The LightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object.
Public method | Dispose | Releases all resources used by the LightShape
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightShape Class
Autodesk.Revit.DB.Lighting Namespace


LightShape Methods

[image] [image]

Revit 2013 API
LightShape Methods
LightShape Class See Also Send Feedback

The LightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightShape Class
Autodesk.Revit.DB.Lighting Namespace


Clone Method

[image]

Revit 2013 API
LightShape..::..Clone Method
LightShape Class See Also Send Feedback
Creates a copy of the LightShape derived object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightShape Clone()
Visual Basic
Public Function Clone As LightShape
Visual C++
public:
LightShape^ Clone()

See Also

LightShape Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightShape..::..Dispose Method
LightShape Class See Also Send Feedback
Releases all resources used by the LightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightShape Class
Autodesk.Revit.DB.Lighting Namespace


LightShapeStyle Enumeration

[image]

Revit 2013 API
LightShapeStyle Enumeration
See Also Send Feedback
Tags for specific light shape styles

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum LightShapeStyle
Visual Basic
Public Enumeration LightShapeStyle
Visual C++
public enum class LightShapeStyle

Members

Member name | Description
Point | Point light shape.
Line | Line light shape.
Rectangle | Rectangular light shape.
Circle | Circular light shape.

See Also

Autodesk.Revit.DB.Lighting Namespace


LightType Class

[image]

Revit 2013 API
LightType Class
Members See Also Send Feedback
This class encapsulates light information.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LightType : IDisposable
Visual Basic
Public Class LightType _
    Implements IDisposable
Visual C++
public ref class LightType : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightType

See Also

LightType Members
Autodesk.Revit.DB.Lighting Namespace


LightType Members

[image] [image]

Revit 2013 API
LightType Members
LightType Class Methods Properties See Also Send Feedback

The LightType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the LightType
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInitialColor | Return a copy of an object derived from InitialColor
Public method | GetInitialIntensity | Return a copy of an object derived from InitialIntensity
Public method | GetLightDistribution | Return a copy of an object derived from LightDistribution
Public method | GetLightShape | Return a copy of an object derived from LightShape
 | GetLightType | Creates a light type object from the given document and family type ID
 | GetLightTypeFromInstance | Creates a light type object from the given document and element ID
Public method | GetLossFactor | Return a copy of an object derived from LossFactor
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInitialColor | Replace the current initial color object with the given object
Public method | SetInitialIntensity | Replace the current initial intensity object with the given object
Public method | SetLightDistribution | Replace the current LightDistribution object with the given object
Public method | SetLightShape | Replace the current LightShape object with the given object
Public method | SetLossFactor | Replace the current loss factor object with the given object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColorFilter | The light filter color.
Public property | DimmingColor | The dimming temperature value in Kelvins.

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


LightType Methods

[image] [image]

Revit 2013 API
LightType Methods
LightType Class See Also Send Feedback

The LightType type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInitialColor | Return a copy of an object derived from InitialColor
Public method | GetInitialIntensity | Return a copy of an object derived from InitialIntensity
Public method | GetLightDistribution | Return a copy of an object derived from LightDistribution
Public method | GetLightShape | Return a copy of an object derived from LightShape
 | GetLightType | Creates a light type object from the given document and family type ID
 | GetLightTypeFromInstance | Creates a light type object from the given document and element ID
Public method | GetLossFactor | Return a copy of an object derived from LossFactor
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetInitialColor | Replace the current initial color object with the given object
Public method | SetInitialIntensity | Replace the current initial intensity object with the given object
Public method | SetLightDistribution | Replace the current LightDistribution object with the given object
Public method | SetLightShape | Replace the current LightShape object with the given object
Public method | SetLossFactor | Replace the current loss factor object with the given object
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LightType..::..Dispose Method
LightType Class See Also Send Feedback
Releases all resources used by the LightType

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetInitialColor Method

[image]

Revit 2013 API
LightType..::..GetInitialColor Method
LightType Class See Also Send Feedback
Return a copy of an object derived from InitialColor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialColor GetInitialColor()
Visual Basic
Public Function GetInitialColor As InitialColor
Visual C++
public:
InitialColor^ GetInitialColor()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetInitialIntensity Method

[image]

Revit 2013 API
LightType..::..GetInitialIntensity Method
LightType Class See Also Send Feedback
Return a copy of an object derived from InitialIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public InitialIntensity GetInitialIntensity()
Visual Basic
Public Function GetInitialIntensity As InitialIntensity
Visual C++
public:
InitialIntensity^ GetInitialIntensity()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetLightDistribution Method

[image]

Revit 2013 API
LightType..::..GetLightDistribution Method
LightType Class See Also Send Feedback
Return a copy of an object derived from LightDistribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightDistribution GetLightDistribution()
Visual Basic
Public Function GetLightDistribution As LightDistribution
Visual C++
public:
LightDistribution^ GetLightDistribution()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetLightShape Method

[image]

Revit 2013 API
LightType..::..GetLightShape Method
LightType Class See Also Send Feedback
Return a copy of an object derived from LightShape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightShape GetLightShape()
Visual Basic
Public Function GetLightShape As LightShape
Visual C++
public:
LightShape^ GetLightShape()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetLightType Method

[image]

Revit 2013 API
LightType..::..GetLightType Method
LightType Class See Also Send Feedback
Creates a light type object from the given document and family type ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightType GetLightType(
    Document document,
    ElementId typeId
)
Visual Basic
Public Shared Function GetLightType ( _
    document As Document, _
    typeId As ElementId _
) As LightType
Visual C++
public:
static LightType^ GetLightType(
    Document^ document,
    ElementId^ typeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document the typeId is from
typeId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the light family type

Return Value

The newly created LightType object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetLightTypeFromInstance Method

[image]

Revit 2013 API
LightType..::..GetLightTypeFromInstance Method
LightType Class See Also Send Feedback
Creates a light type object from the given document and element ID

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static LightType GetLightTypeFromInstance(
    Document document,
    ElementId instanceId
)
Visual Basic
Public Shared Function GetLightTypeFromInstance ( _
    document As Document, _
    instanceId As ElementId _
) As LightType
Visual C++
public:
static LightType^ GetLightTypeFromInstance(
    Document^ document,
    ElementId^ instanceId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document the instanceId is from
instanceId
Type: Autodesk.Revit.DB..::..ElementId
The ID of the light fixture instance

Return Value

The newly created LightType object

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId is the argument that is being validated The ElementId is not valid because it is not for a light element.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


GetLossFactor Method

[image]

Revit 2013 API
LightType..::..GetLossFactor Method
LightType Class See Also Send Feedback
Return a copy of an object derived from LossFactor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LossFactor GetLossFactor()
Visual Basic
Public Function GetLossFactor As LossFactor
Visual C++
public:
LossFactor^ GetLossFactor()

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


SetInitialColor Method

[image]

Revit 2013 API
LightType..::..SetInitialColor Method
LightType Class See Also Send Feedback
Replace the current initial color object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetInitialColor(
    InitialColor initialColor
)
Visual Basic
Public Sub SetInitialColor ( _
    initialColor As InitialColor _
)
Visual C++
public:
void SetInitialColor(
    InitialColor^ initialColor
)

Parameters

initialColor
Type: Autodesk.Revit.DB.Lighting..::..InitialColor
An object derived from an InitialColor object The object pointed to is cloned internally

Remarks

The argument object is cloned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


SetInitialIntensity Method

[image]

Revit 2013 API
LightType..::..SetInitialIntensity Method
LightType Class See Also Send Feedback
Replace the current initial intensity object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetInitialIntensity(
    InitialIntensity initialIntensity
)
Visual Basic
Public Sub SetInitialIntensity ( _
    initialIntensity As InitialIntensity _
)
Visual C++
public:
void SetInitialIntensity(
    InitialIntensity^ initialIntensity
)

Parameters

initialIntensity
Type: Autodesk.Revit.DB.Lighting..::..InitialIntensity
An object derived from an InitialIntensity object

Remarks

The argument object is cloned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


SetLightDistribution Method

[image]

Revit 2013 API
LightType..::..SetLightDistribution Method
LightType Class See Also Send Feedback
Replace the current LightDistribution object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightDistribution(
    LightDistribution lightDistribution
)
Visual Basic
Public Sub SetLightDistribution ( _
    lightDistribution As LightDistribution _
)
Visual C++
public:
void SetLightDistribution(
    LightDistribution^ lightDistribution
)

Parameters

lightDistribution
Type: Autodesk.Revit.DB.Lighting..::..LightDistribution
An instance of an object derived from LightDistribution

Remarks

The argument object is cloned Light distribution is a family element parameter. All other LightType properties and methods except for light shape are family type parameters. Changes to family type parameters may not be committed in the same transaction with changes to family element parameters, otherwise the modifications to the family type may be lost. Always use a separate transaction for changes to the shape and distribution of a light.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The LightDistribution is the argument that is being validated The LightDistribution is not valid because it of a different derived type than the current LightDistribution derived type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


SetLightShape Method

[image]

Revit 2013 API
LightType..::..SetLightShape Method
LightType Class See Also Send Feedback
Replace the current LightShape object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLightShape(
    LightShape lightShape
)
Visual Basic
Public Sub SetLightShape ( _
    lightShape As LightShape _
)
Visual C++
public:
void SetLightShape(
    LightShape^ lightShape
)

Parameters

lightShape
Type: Autodesk.Revit.DB.Lighting..::..LightShape
An instance of an object derived from LightShape

Remarks

The argument object is cloned. Light shape is a family element parameter. All other LightType properties and methods except for light distribution are family type parameters. Changes to family type parameters may not be committed in the same transaction with changes to family element parameters, otherwise the modifications to the family type may be lost. Always use a separate transaction for changes to the shape and distribution of a light.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The LightShape is the argument that is being validated The LightShape is not valid because it of a different derived type than the current LightShape derived type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


SetLossFactor Method

[image]

Revit 2013 API
LightType..::..SetLossFactor Method
LightType Class See Also Send Feedback
Replace the current loss factor object with the given object

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetLossFactor(
    LossFactor lossFactor
)
Visual Basic
Public Sub SetLossFactor ( _
    lossFactor As LossFactor _
)
Visual C++
public:
void SetLossFactor(
    LossFactor^ lossFactor
)

Parameters

lossFactor
Type: Autodesk.Revit.DB.Lighting..::..LossFactor
An object derived from a LossFactor object

Remarks

The argument object is cloned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


LightType Properties

[image] [image]

Revit 2013 API
LightType Properties
LightType Class See Also Send Feedback

The LightType type exposes the following members.

Properties

 | Name | Description
Public property | ColorFilter | The light filter color.
Public property | DimmingColor | The dimming temperature value in Kelvins.

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


ColorFilter Property

[image]

Revit 2013 API
LightType..::..ColorFilter Property
LightType Class See Also Send Feedback
The light filter color.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Color ColorFilter { get; set; }
Visual Basic
Public Property ColorFilter As Color
    Get
    Set
Visual C++
public:
property Color^ ColorFilter {
    Color^ get ();
    void set (Color^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


DimmingColor Property

[image]

Revit 2013 API
LightType..::..DimmingColor Property
LightType Class See Also Send Feedback
The dimming temperature value in Kelvins.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LightDimmingColor DimmingColor { get; set; }
Visual Basic
Public Property DimmingColor As LightDimmingColor
    Get
    Set
Visual C++
public:
property LightDimmingColor DimmingColor {
    LightDimmingColor get ();
    void set (LightDimmingColor value);
}

See Also

LightType Class
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Class

[image]

Revit 2013 API
LineLightShape Class
Members See Also Send Feedback
This class encapsulates a line light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LineLightShape : LightShape
Visual Basic
Public Class LineLightShape _
    Inherits LightShape
Visual C++
public ref class LineLightShape : public LightShape

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightShape
Autodesk.Revit.DB.Lighting..::..LineLightShape

See Also

LineLightShape Members
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Members

[image] [image]

Revit 2013 API
LineLightShape Members
LineLightShape Class Constructors Methods Properties See Also Send Feedback

The LineLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | LineLightShape()()()() | Creates a line light shape object with 2.0' emit length.
Public method | LineLightShape(Double) | Creates a line light shape object with the given emit length.
Public method | LineLightShape(LineLightShape) | Creates a copy of the given line light shape

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitLength | The emit length.

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Constructor

[image] [image]

Revit 2013 API
LineLightShape Constructor
LineLightShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineLightShape()()()() | Creates a line light shape object with 2.0' emit length.
Public method | LineLightShape(Double) | Creates a line light shape object with the given emit length.
Public method | LineLightShape(LineLightShape) | Creates a copy of the given line light shape

See Also

LineLightShape Class
LineLightShape Members
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Constructor

[image]

Revit 2013 API
LineLightShape Constructor
LineLightShape Class See Also Send Feedback
Creates a line light shape object with 2.0' emit length.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LineLightShape()
Visual Basic
Public Sub New
Visual C++
public:
LineLightShape()

See Also

LineLightShape Class
LineLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Constructor (Double)

[image]

Revit 2013 API
LineLightShape Constructor (Double)
LineLightShape Class See Also Send Feedback
Creates a line light shape object with the given emit length.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LineLightShape(
    double emitLength
)
Visual Basic
Public Sub New ( _
    emitLength As Double _
)
Visual C++
public:
LineLightShape(
    double emitLength
)

Parameters

emitLength
Type: System..::..Double
The emit length as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

LineLightShape Class
LineLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Constructor (LineLightShape)

[image]

Revit 2013 API
LineLightShape Constructor (LineLightShape)
LineLightShape Class See Also Send Feedback
Creates a copy of the given line light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LineLightShape(
    LineLightShape other
)
Visual Basic
Public Sub New ( _
    other As LineLightShape _
)
Visual C++
public:
LineLightShape(
    LineLightShape^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..LineLightShape

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

LineLightShape Class
LineLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Methods

[image] [image]

Revit 2013 API
LineLightShape Methods
LineLightShape Class See Also Send Feedback

The LineLightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace


LineLightShape Properties

[image] [image]

Revit 2013 API
LineLightShape Properties
LineLightShape Class See Also Send Feedback

The LineLightShape type exposes the following members.

Properties

 | Name | Description
Public property | EmitLength | The emit length.

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace


EmitLength Property

[image]

Revit 2013 API
LineLightShape..::..EmitLength Property
LineLightShape Class See Also Send Feedback
The emit length.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EmitLength { get; set; }
Visual Basic
Public Property EmitLength As Double
    Get
    Set
Visual C++
public:
property double EmitLength {
    double get ();
    void set (double value);
}

Field Value

The emit length as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

LineLightShape Class
Autodesk.Revit.DB.Lighting Namespace


LossFactor Class

[image]

Revit 2013 API
LossFactor Class
Members See Also Send Feedback
This class is the base class for calculating lighting loss factor.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class LossFactor : IDisposable
Visual Basic
Public Class LossFactor _
    Implements IDisposable
Visual C++
public ref class LossFactor : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LossFactor
Autodesk.Revit.DB.Lighting..::..AdvancedLossFactor
Autodesk.Revit.DB.Lighting..::..BasicLossFactor

See Also

LossFactor Members
Autodesk.Revit.DB.Lighting Namespace


LossFactor Members

[image] [image]

Revit 2013 API
LossFactor Members
LossFactor Class Methods Properties See Also Send Feedback

The LossFactor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object.
Public method | Dispose | Releases all resources used by the LossFactor
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LossFactorValue | The calculated loss factor value

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LossFactor Methods

[image] [image]

Revit 2013 API
LossFactor Methods
LossFactor Class See Also Send Feedback

The LossFactor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LossFactor derived object.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


Clone Method

[image]

Revit 2013 API
LossFactor..::..Clone Method
LossFactor Class See Also Send Feedback
Creates a copy of the LossFactor derived object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public LossFactor Clone()
Visual Basic
Public Function Clone As LossFactor
Visual C++
public:
LossFactor^ Clone()

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


Dispose Method

[image]

Revit 2013 API
LossFactor..::..Dispose Method
LossFactor Class See Also Send Feedback
Releases all resources used by the LossFactor

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LossFactor Properties

[image] [image]

Revit 2013 API
LossFactor Properties
LossFactor Class See Also Send Feedback

The LossFactor type exposes the following members.

Properties

 | Name | Description
Public property | LossFactorValue | The calculated loss factor value

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


LossFactorValue Property

[image]

Revit 2013 API
LossFactor..::..LossFactorValue Property
LossFactor Class See Also Send Feedback
The calculated loss factor value

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double LossFactorValue { get; }
Visual Basic
Public ReadOnly Property LossFactorValue As Double
    Get
Visual C++
public:
property double LossFactorValue {
    double get ();
}

See Also

LossFactor Class
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Class

[image]

Revit 2013 API
PhotometricWebLightDistribution Class
Members See Also Send Feedback
This class encapsulates a photometric web light distribution.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PhotometricWebLightDistribution : LightDistribution
Visual Basic
Public Class PhotometricWebLightDistribution _
    Inherits LightDistribution
Visual C++
public ref class PhotometricWebLightDistribution : public LightDistribution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightDistribution
Autodesk.Revit.DB.Lighting..::..PhotometricWebLightDistribution

See Also

PhotometricWebLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Members

[image] [image]

Revit 2013 API
PhotometricWebLightDistribution Members
PhotometricWebLightDistribution Class Constructors Methods Properties See Also Send Feedback

The PhotometricWebLightDistribution type exposes the following members.

Constructors

 | Name | Description
Public method | PhotometricWebLightDistribution(PhotometricWebLightDistribution) | Creates a copy of the given photometric web light distribution
Public method | PhotometricWebLightDistribution(String, Double) | Creates a photometric web light distribution object with the given filename and tilt.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | PhotometricWebFile | The filename of an IES photometric web file.
Public property | TiltAngle | The tilt angle.

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Constructor

[image] [image]

Revit 2013 API
PhotometricWebLightDistribution Constructor
PhotometricWebLightDistribution Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PhotometricWebLightDistribution(PhotometricWebLightDistribution) | Creates a copy of the given photometric web light distribution
Public method | PhotometricWebLightDistribution(String, Double) | Creates a photometric web light distribution object with the given filename and tilt.

See Also

PhotometricWebLightDistribution Class
PhotometricWebLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Constructor (PhotometricWebLightDistribution)

[image]

Revit 2013 API
PhotometricWebLightDistribution Constructor (PhotometricWebLightDistribution)
PhotometricWebLightDistribution Class See Also Send Feedback
Creates a copy of the given photometric web light distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PhotometricWebLightDistribution(
    PhotometricWebLightDistribution other
)
Visual Basic
Public Sub New ( _
    other As PhotometricWebLightDistribution _
)
Visual C++
public:
PhotometricWebLightDistribution(
    PhotometricWebLightDistribution^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..PhotometricWebLightDistribution

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PhotometricWebLightDistribution Class
PhotometricWebLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Constructor (String, Double)

[image]

Revit 2013 API
PhotometricWebLightDistribution Constructor (String, Double)
PhotometricWebLightDistribution Class See Also Send Feedback
Creates a photometric web light distribution object with the given filename and tilt.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PhotometricWebLightDistribution(
    string photometricWebFile,
    double tiltAngle
)
Visual Basic
Public Sub New ( _
    photometricWebFile As String, _
    tiltAngle As Double _
)
Visual C++
public:
PhotometricWebLightDistribution(
    String^ photometricWebFile,
    double tiltAngle
)

Parameters

photometricWebFile
Type: System..::..String
The filename of the IES file to use.
tiltAngle
Type: System..::..Double
The tilt angle as a numerical value in degrees between -180.0 and 180.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The angle is not valid because it is not between -180.0 and 180.0.

See Also

PhotometricWebLightDistribution Class
PhotometricWebLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Methods

[image] [image]

Revit 2013 API
PhotometricWebLightDistribution Methods
PhotometricWebLightDistribution Class See Also Send Feedback

The PhotometricWebLightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebLightDistribution Properties

[image] [image]

Revit 2013 API
PhotometricWebLightDistribution Properties
PhotometricWebLightDistribution Class See Also Send Feedback

The PhotometricWebLightDistribution type exposes the following members.

Properties

 | Name | Description
Public property | PhotometricWebFile | The filename of an IES photometric web file.
Public property | TiltAngle | The tilt angle.

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


PhotometricWebFile Property

[image]

Revit 2013 API
PhotometricWebLightDistribution..::..PhotometricWebFile Property
PhotometricWebLightDistribution Class See Also Send Feedback
The filename of an IES photometric web file.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string PhotometricWebFile { get; set; }
Visual Basic
Public Property PhotometricWebFile As String
    Get
    Set
Visual C++
public:
property String^ PhotometricWebFile {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


TiltAngle Property

[image]

Revit 2013 API
PhotometricWebLightDistribution..::..TiltAngle Property
PhotometricWebLightDistribution Class See Also Send Feedback
The tilt angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TiltAngle { get; set; }
Visual Basic
Public Property TiltAngle As Double
    Get
    Set
Visual C++
public:
property double TiltAngle {
    double get ();
    void set (double value);
}

Field Value

The tilt angle as a numerical value in degrees between -180.0 and 180.0.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The angle is not valid because it is not between -180.0 and 180.0.

See Also

PhotometricWebLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Class

[image]

Revit 2013 API
PointLightShape Class
Members See Also Send Feedback
This class encapsulates a point light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PointLightShape : LightShape
Visual Basic
Public Class PointLightShape _
    Inherits LightShape
Visual C++
public ref class PointLightShape : public LightShape

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightShape
Autodesk.Revit.DB.Lighting..::..PointLightShape

See Also

PointLightShape Members
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Members

[image] [image]

Revit 2013 API
PointLightShape Members
PointLightShape Class Constructors Methods See Also Send Feedback

The PointLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | PointLightShape()()()() | Creates a point light shape object.
Public method | PointLightShape(PointLightShape) | Creates a copy of the given point light shape

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLightShape Class
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Constructor

[image] [image]

Revit 2013 API
PointLightShape Constructor
PointLightShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PointLightShape()()()() | Creates a point light shape object.
Public method | PointLightShape(PointLightShape) | Creates a copy of the given point light shape

See Also

PointLightShape Class
PointLightShape Members
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Constructor

[image]

Revit 2013 API
PointLightShape Constructor
PointLightShape Class See Also Send Feedback
Creates a point light shape object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PointLightShape()
Visual Basic
Public Sub New
Visual C++
public:
PointLightShape()

See Also

PointLightShape Class
PointLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Constructor (PointLightShape)

[image]

Revit 2013 API
PointLightShape Constructor (PointLightShape)
PointLightShape Class See Also Send Feedback
Creates a copy of the given point light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PointLightShape(
    PointLightShape other
)
Visual Basic
Public Sub New ( _
    other As PointLightShape _
)
Visual C++
public:
PointLightShape(
    PointLightShape^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..PointLightShape

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointLightShape Class
PointLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


PointLightShape Methods

[image] [image]

Revit 2013 API
PointLightShape Methods
PointLightShape Class See Also Send Feedback

The PointLightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLightShape Class
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Class

[image]

Revit 2013 API
PresetInitialColor Class
Members See Also Send Feedback
This class encapsulates a preset initial lighting color.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PresetInitialColor : InitialColor
Visual Basic
Public Class PresetInitialColor _
    Inherits InitialColor
Visual C++
public ref class PresetInitialColor : public InitialColor

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..InitialColor
Autodesk.Revit.DB.Lighting..::..PresetInitialColor

See Also

PresetInitialColor Members
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Members

[image] [image]

Revit 2013 API
PresetInitialColor Members
PresetInitialColor Class Constructors Methods Properties See Also Send Feedback

The PresetInitialColor type exposes the following members.

Constructors

 | Name | Description
Public method | PresetInitialColor(ColorPreset) | Creates an initial color preset object with the given preset value.
Public method | PresetInitialColor(PresetInitialColor) | Creates a copy of the given preset initial color

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object. (Inherited from InitialColor.)
Public method | Dispose | (Inherited from InitialColor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Preset | The preset value
Public property | TemperatureValue | The light color temperature value in Kelvins. (Inherited from InitialColor.)

See Also

PresetInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Constructor

[image] [image]

Revit 2013 API
PresetInitialColor Constructor
PresetInitialColor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PresetInitialColor(ColorPreset) | Creates an initial color preset object with the given preset value.
Public method | PresetInitialColor(PresetInitialColor) | Creates a copy of the given preset initial color

See Also

PresetInitialColor Class
PresetInitialColor Members
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Constructor (ColorPreset)

[image]

Revit 2013 API
PresetInitialColor Constructor (ColorPreset)
PresetInitialColor Class See Also Send Feedback
Creates an initial color preset object with the given preset value.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PresetInitialColor(
    ColorPreset presetIn
)
Visual Basic
Public Sub New ( _
    presetIn As ColorPreset _
)
Visual C++
public:
PresetInitialColor(
    ColorPreset presetIn
)

Parameters

presetIn
Type: Autodesk.Revit.DB.Lighting..::..ColorPreset
The enum value which determines the preset value

See Also

PresetInitialColor Class
PresetInitialColor Overload
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Constructor (PresetInitialColor)

[image]

Revit 2013 API
PresetInitialColor Constructor (PresetInitialColor)
PresetInitialColor Class See Also Send Feedback
Creates a copy of the given preset initial color

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PresetInitialColor(
    PresetInitialColor other
)
Visual Basic
Public Sub New ( _
    other As PresetInitialColor _
)
Visual C++
public:
PresetInitialColor(
    PresetInitialColor^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..PresetInitialColor

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PresetInitialColor Class
PresetInitialColor Overload
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Methods

[image] [image]

Revit 2013 API
PresetInitialColor Methods
PresetInitialColor Class See Also Send Feedback

The PresetInitialColor type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the InitialColor derived object. (Inherited from InitialColor.)
Public method | Dispose | (Inherited from InitialColor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PresetInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


PresetInitialColor Properties

[image] [image]

Revit 2013 API
PresetInitialColor Properties
PresetInitialColor Class See Also Send Feedback

The PresetInitialColor type exposes the following members.

Properties

 | Name | Description
Public property | Preset | The preset value
Public property | TemperatureValue | The light color temperature value in Kelvins. (Inherited from InitialColor.)

See Also

PresetInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


Preset Property

[image]

Revit 2013 API
PresetInitialColor..::..Preset Property
PresetInitialColor Class See Also Send Feedback
The preset value

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ColorPreset Preset { get; set; }
Visual Basic
Public Property Preset As ColorPreset
    Get
    Set
Visual C++
public:
property ColorPreset Preset {
    ColorPreset get ();
    void set (ColorPreset value);
}

See Also

PresetInitialColor Class
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Class

[image]

Revit 2013 API
RectangleLightShape Class
Members See Also Send Feedback
This class encapsulates a rectangle light shape.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RectangleLightShape : LightShape
Visual Basic
Public Class RectangleLightShape _
    Inherits LightShape
Visual C++
public ref class RectangleLightShape : public LightShape

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightShape
Autodesk.Revit.DB.Lighting..::..RectangleLightShape

See Also

RectangleLightShape Members
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Members

[image] [image]

Revit 2013 API
RectangleLightShape Members
RectangleLightShape Class Constructors Methods Properties See Also Send Feedback

The RectangleLightShape type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleLightShape()()()() | Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.
Public method | RectangleLightShape(RectangleLightShape) | Creates a copy of the given rectangle light shape
Public method | RectangleLightShape(Double, Double) | Creates a rectangle light shape object with the given emit length and width.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EmitLength | The emit length.
Public property | EmitWidth | The emit width.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Constructor

[image] [image]

Revit 2013 API
RectangleLightShape Constructor
RectangleLightShape Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangleLightShape()()()() | Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.
Public method | RectangleLightShape(RectangleLightShape) | Creates a copy of the given rectangle light shape
Public method | RectangleLightShape(Double, Double) | Creates a rectangle light shape object with the given emit length and width.

See Also

RectangleLightShape Class
RectangleLightShape Members
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Constructor

[image]

Revit 2013 API
RectangleLightShape Constructor
RectangleLightShape Class See Also Send Feedback
Creates a rectangle light shape object with 4.0' emit length and a 2.0' emit width.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RectangleLightShape()
Visual Basic
Public Sub New
Visual C++
public:
RectangleLightShape()

See Also

RectangleLightShape Class
RectangleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Constructor (RectangleLightShape)

[image]

Revit 2013 API
RectangleLightShape Constructor (RectangleLightShape)
RectangleLightShape Class See Also Send Feedback
Creates a copy of the given rectangle light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RectangleLightShape(
    RectangleLightShape other
)
Visual Basic
Public Sub New ( _
    other As RectangleLightShape _
)
Visual C++
public:
RectangleLightShape(
    RectangleLightShape^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..RectangleLightShape

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RectangleLightShape Class
RectangleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Constructor (Double, Double)

[image]

Revit 2013 API
RectangleLightShape Constructor (Double, Double)
RectangleLightShape Class See Also Send Feedback
Creates a rectangle light shape object with the given emit length and width.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RectangleLightShape(
    double emitLength,
    double emitWidth
)
Visual Basic
Public Sub New ( _
    emitLength As Double, _
    emitWidth As Double _
)
Visual C++
public:
RectangleLightShape(
    double emitLength,
    double emitWidth
)

Parameters

emitLength
Type: System..::..Double
The emit length as a numerical value in feet between 1.0e-9 and 30000.0
emitWidth
Type: System..::..Double
The emit width as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

RectangleLightShape Class
RectangleLightShape Overload
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Methods

[image] [image]

Revit 2013 API
RectangleLightShape Methods
RectangleLightShape Class See Also Send Feedback

The RectangleLightShape type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightShape derived object. (Inherited from LightShape.)
Public method | Dispose | (Inherited from LightShape.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


RectangleLightShape Properties

[image] [image]

Revit 2013 API
RectangleLightShape Properties
RectangleLightShape Class See Also Send Feedback

The RectangleLightShape type exposes the following members.

Properties

 | Name | Description
Public property | EmitLength | The emit length.
Public property | EmitWidth | The emit width.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


EmitLength Property

[image]

Revit 2013 API
RectangleLightShape..::..EmitLength Property
RectangleLightShape Class See Also Send Feedback
The emit length.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EmitLength { get; set; }
Visual Basic
Public Property EmitLength As Double
    Get
    Set
Visual C++
public:
property double EmitLength {
    double get ();
    void set (double value);
}

Field Value

The emit length as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


EmitWidth Property

[image]

Revit 2013 API
RectangleLightShape..::..EmitWidth Property
RectangleLightShape Class See Also Send Feedback
The emit width.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double EmitWidth { get; set; }
Visual Basic
Public Property EmitWidth As Double
    Get
    Set
Visual C++
public:
property double EmitWidth {
    double get ();
    void set (double value);
}

Field Value

The emit width as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also

RectangleLightShape Class
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Class

[image]

Revit 2013 API
SphericalLightDistribution Class
Members See Also Send Feedback
This class encapsulates a spherical light distribution.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SphericalLightDistribution : LightDistribution
Visual Basic
Public Class SphericalLightDistribution _
    Inherits LightDistribution
Visual C++
public ref class SphericalLightDistribution : public LightDistribution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightDistribution
Autodesk.Revit.DB.Lighting..::..SphericalLightDistribution

See Also

SphericalLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Members

[image] [image]

Revit 2013 API
SphericalLightDistribution Members
SphericalLightDistribution Class Constructors Methods See Also Send Feedback

The SphericalLightDistribution type exposes the following members.

Constructors

 | Name | Description
Public method | SphericalLightDistribution()()()() | Creates a spherical light distribution object.
Public method | SphericalLightDistribution(SphericalLightDistribution) | Creates a copy of the given spherical light distribution

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SphericalLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Constructor

[image] [image]

Revit 2013 API
SphericalLightDistribution Constructor
SphericalLightDistribution Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SphericalLightDistribution()()()() | Creates a spherical light distribution object.
Public method | SphericalLightDistribution(SphericalLightDistribution) | Creates a copy of the given spherical light distribution

See Also

SphericalLightDistribution Class
SphericalLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Constructor

[image]

Revit 2013 API
SphericalLightDistribution Constructor
SphericalLightDistribution Class See Also Send Feedback
Creates a spherical light distribution object.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SphericalLightDistribution()
Visual Basic
Public Sub New
Visual C++
public:
SphericalLightDistribution()

See Also

SphericalLightDistribution Class
SphericalLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Constructor (SphericalLightDistribution)

[image]

Revit 2013 API
SphericalLightDistribution Constructor (SphericalLightDistribution)
SphericalLightDistribution Class See Also Send Feedback
Creates a copy of the given spherical light distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SphericalLightDistribution(
    SphericalLightDistribution other
)
Visual Basic
Public Sub New ( _
    other As SphericalLightDistribution _
)
Visual C++
public:
SphericalLightDistribution(
    SphericalLightDistribution^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..SphericalLightDistribution

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SphericalLightDistribution Class
SphericalLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


SphericalLightDistribution Methods

[image] [image]

Revit 2013 API
SphericalLightDistribution Methods
SphericalLightDistribution Class See Also Send Feedback

The SphericalLightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SphericalLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Class

[image]

Revit 2013 API
SpotLightDistribution Class
Members See Also Send Feedback
This class encapsulates a spot light distribution.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class SpotLightDistribution : LightDistribution
Visual Basic
Public Class SpotLightDistribution _
    Inherits LightDistribution
Visual C++
public ref class SpotLightDistribution : public LightDistribution

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Lighting..::..LightDistribution
Autodesk.Revit.DB.Lighting..::..SpotLightDistribution

See Also

SpotLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Members

[image] [image]

Revit 2013 API
SpotLightDistribution Members
SpotLightDistribution Class Constructors Methods Properties See Also Send Feedback

The SpotLightDistribution type exposes the following members.

Constructors

Name Description
Public method SpotLightDistribution()()()()
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution)
Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double)
Creates a spot light distribution object with the given values.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SpotBeamAngle | The spot beam angle.
Public property | SpotFieldAngle | The spot field angle.
Public property | TiltAngle | The tilt angle.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Constructor

[image] [image]

Revit 2013 API
SpotLightDistribution Constructor
SpotLightDistribution Class See Also Send Feedback

Overload List

Name Description
Public method SpotLightDistribution()()()()
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle
Public method SpotLightDistribution(SpotLightDistribution)
Creates a copy of the given spotlight distribution
Public method SpotLightDistribution(Double, Double, Double)
Creates a spot light distribution object with the given values.

See Also

SpotLightDistribution Class
SpotLightDistribution Members
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Constructor

[image]

Revit 2013 API
SpotLightDistribution Constructor
SpotLightDistribution Class See Also Send Feedback
Creates a spot light distribution object with the following values;
  • PI/6 radians spot beam angle
  • PI/2 radians spot field angle
  • PI/6 radians tilt angle

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpotLightDistribution()
Visual Basic
Public Sub New
Visual C++
public:
SpotLightDistribution()

See Also

SpotLightDistribution Class
SpotLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Constructor (SpotLightDistribution)

[image]

Revit 2013 API
SpotLightDistribution Constructor (SpotLightDistribution)
SpotLightDistribution Class See Also Send Feedback
Creates a copy of the given spotlight distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpotLightDistribution(
    SpotLightDistribution other
)
Visual Basic
Public Sub New ( _
    other As SpotLightDistribution _
)
Visual C++
public:
SpotLightDistribution(
    SpotLightDistribution^ other
)

Parameters

other
Type: Autodesk.Revit.DB.Lighting..::..SpotLightDistribution

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

SpotLightDistribution Class
SpotLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Constructor (Double, Double, Double)

[image]

Revit 2013 API
SpotLightDistribution Constructor (Double, Double, Double)
SpotLightDistribution Class See Also Send Feedback
Creates a spot light distribution object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public SpotLightDistribution(
    double spotBeamAngle,
    double spotFieldAngle,
    double tiltAngle
)
Visual Basic
Public Sub New ( _
    spotBeamAngle As Double, _
    spotFieldAngle As Double, _
    tiltAngle As Double _
)
Visual C++
public:
SpotLightDistribution(
    double spotBeamAngle,
    double spotFieldAngle,
    double tiltAngle
)

Parameters

spotBeamAngle
Type: System..::..Double
The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.
spotFieldAngle
Type: System..::..Double
The spot field angle as a numerical value in radians between 0 and (8/9)*PI.
tiltAngle
Type: System..::..Double
The tilt angle as a numerical value in radians between -PI and PI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The angle is not valid because it is not between 1.0e-2 and 160.0. -or- The angle is not valid because it is not between -180.0 and 180.0.

See Also

SpotLightDistribution Class
SpotLightDistribution Overload
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Methods

[image] [image]

Revit 2013 API
SpotLightDistribution Methods
SpotLightDistribution Class See Also Send Feedback

The SpotLightDistribution type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the LightDistribution derived object. (Inherited from LightDistribution.)
Public method | Dispose | (Inherited from LightDistribution.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SpotLightDistribution Properties

[image] [image]

Revit 2013 API
SpotLightDistribution Properties
SpotLightDistribution Class See Also Send Feedback

The SpotLightDistribution type exposes the following members.

Properties

 | Name | Description
Public property | SpotBeamAngle | The spot beam angle.
Public property | SpotFieldAngle | The spot field angle.
Public property | TiltAngle | The tilt angle.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SpotBeamAngle Property

[image]

Revit 2013 API
SpotLightDistribution..::..SpotBeamAngle Property
SpotLightDistribution Class See Also Send Feedback
The spot beam angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SpotBeamAngle { get; set; }
Visual Basic
Public Property SpotBeamAngle As Double
    Get
    Set
Visual C++
public:
property double SpotBeamAngle {
    double get ();
    void set (double value);
}

Field Value

The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The angle is not valid because it is not between 1.0e-2 and 160.0.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


SpotFieldAngle Property

[image]

Revit 2013 API
SpotLightDistribution..::..SpotFieldAngle Property
SpotLightDistribution Class See Also Send Feedback
The spot field angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SpotFieldAngle { get; set; }
Visual Basic
Public Property SpotFieldAngle As Double
    Get
    Set
Visual C++
public:
property double SpotFieldAngle {
    double get ();
    void set (double value);
}

Field Value

The spot beam angle as a numerical value in radians between 0 and (8/9)*PI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The angle is not valid because it is not between 1.0e-2 and 160.0.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


TiltAngle Property

[image]

Revit 2013 API
SpotLightDistribution..::..TiltAngle Property
SpotLightDistribution Class See Also Send Feedback
The tilt angle.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TiltAngle { get; set; }
Visual Basic
Public Property TiltAngle As Double
    Get
    Set
Visual C++
public:
property double TiltAngle {
    double get ();
    void set (double value);
}

Field Value

The tilt angle as a numerical value in radians between -PI and PI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The angle is not valid because it is not between -180.0 and 180.0.

See Also

SpotLightDistribution Class
Autodesk.Revit.DB.Lighting Namespace


Autodesk.Revit.DB.Mechanical Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Mechanical Namespace
Send Feedback

Classes

 | Class | Description
Public class | BoundarySegment | An object that represents a segment of an area boundary.
Public class | BoundarySegmentArray | An array that contains boundary segments.
Public class | BoundarySegmentArrayArray | An array that contains boundary segment arrays.
Public class | BoundarySegmentArrayArrayIterator | An iterator to a array of boundary segment arrays.
Public class | BoundarySegmentArrayIterator | An iterator to a boundary segment array.
Public class | Duct | A duct in the Autodesk Revit MEP product.
Public class | DuctConnector | Obsolete. A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.
Public class | DuctInsulation | Represents insulation applied to the outside of a given duct , fitting or accessory.
Public class | DuctInsulationType | This class represents a duct insulation type in Autodesk Revit.
Public class | DuctLining | Represents Lining applied to the inside of a given duct, fitting or accessory.
Public class | DuctLiningType | This class represents a duct lining type in Autodesk Revit.
Public class | DuctSizeIterator | An iterator to a set of MEP duct sizes from DuctSizes.
Public class | DuctSizes | Class RbsDuctSizes being used to store the duct sizes
Public class | DuctSizeSettingIterator | An iterator to a set of items from DuctSizeSettings. Each item is a KeyValuePair(DuctShape::Enum, DuctSizes).
Public class | DuctSizeSettings | Duct sizes settings
Public class | DuctType |
Public class | FlexDuct | A flex duct in the Autodesk Revit MEP product.
Public class | FlexDuctType | A flex duct type in the Autodesk Revit MEP product.
Public class | MechanicalEquipment | Provides access to the Mechanical Equipment in Autodesk Revit MEP.
Public class | MechanicalFitting | A mechanical fitting in the Autodesk Revit MEP product.
Public class | MechanicalSystem | Default constructor Default destructor
Public class | MechanicalSystemType | Base class for duct system types
Public class | MechanicalUtils | General utility methods in the Autodesk Revit MEP product.
Public class | MEPBuildingConstruction | Construction definition for Project Information.
Public class | MEPBuildingConstructionSet | A set that contains MEPBuildingConstructions.
Public class | MEPBuildingConstructionSetIterator | An iterator to a MEPBuildingConstruction set.
Public class | MEPSection | A section in the Autodesk Revit MEP product.
Public class | MEPSpaceConstruction | Construction definition for Space.
Public class | Space | Provides access to the space topology in Autodesk Revit.
Public class | SpaceFilter | A filter used to match spaces.
Public class | SpaceSet | A set that can contain any type of object.
Public class | SpaceSetIterator | An iterator to a set.
Public class | SpaceTag | Provides access to the space tag in Autodesk Revit.
Public class | SpaceTagFilter | A filter used to match space tags.
Public class | SpaceTagType | An object that represents a Space Tag style.
Public class | SpaceTagTypeSet | A set that contains space tag types.
Public class | SpaceTagTypeSetIterator | An iterator to a space tag type set.
Public class | Zone | Provides access to the Zone Element in Autodesk Revit.

Enumerations

 | Enumeration | Description
Public enumeration | ConditionType | An enumerated type listing all the possible condition types for a space object.
Public enumeration | DuctFlowConfigurationType | An enumerated type listing all duct flow configuration types for a connector.
Public enumeration | DuctLossMethodType | An enumerated type listing all duct loss calculation methods for a connector.
Public enumeration | DuctShape |
Public enumeration | DuctSystemType | An enumerated type listing all the possible duct system types for a connector object.
Public enumeration | OccupancyUnit | An enumerated type listing the occupancy unit of measure for a space object.
Public enumeration | ReturnAirflowType | An enumerated type listing all the possible return airflow types for a space object.
Public enumeration | RiseDropSymbol | This enumeration corresponds to the rise/drop symbol used in mechanical systems
Public enumeration | SpaceType | An enumerated type listing all the possible space types for a space object.
Public enumeration | SystemCalculationLevel |


BoundarySegment Class

[image]

Revit 2013 API
BoundarySegment Class
Members See Also Send Feedback
An object that represents a segment of an area boundary.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegment : APIObject
Visual Basic
Public Class BoundarySegment _
    Inherits APIObject
Visual C++
public ref class BoundarySegment : public APIObject

Remarks

These objects define the exterior boundary of an area. The geometry of the segment can be retrieved along with the element that is responsible for producing that boundary.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..BoundarySegment

See Also

BoundarySegment Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Members

[image] [image]

Revit 2013 API
BoundarySegment Members
BoundarySegment Class Methods Properties See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Methods

[image] [image]

Revit 2013 API
BoundarySegment Methods
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegment Properties

[image] [image]

Revit 2013 API
BoundarySegment Properties
BoundarySegment Class See Also Send Feedback

The BoundarySegment type exposes the following members.

Properties

 | Name | Description
Public property | Curve | Get the curve that is formed by the element that defines the edge of this area.
Public property | Document | Provides the document in which the element that created this segment resides.
Public property | Element | Retrieve the element that is responsible for producing this boundary segment.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Curve Property

[image]

Revit 2013 API
BoundarySegment..::..Curve Property
BoundarySegment Class See Also Send Feedback
Get the curve that is formed by the element that defines the edge of this area.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Document Property

[image]

Revit 2013 API
BoundarySegment..::..Document Property
BoundarySegment Class See Also Send Feedback
Provides the document in which the element that created this segment resides.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


Element Property

[image]

Revit 2013 API
BoundarySegment..::..Element Property
BoundarySegment Class See Also Send Feedback
Retrieve the element that is responsible for producing this boundary segment.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element Element { get; }
Visual Basic
Public ReadOnly Property Element As Element
    Get
Visual C++
public:
property Element^ Element {
    Element^ get ();
}

Remarks

The element property is useful for finding all the elements that bound a specific area.

See Also

BoundarySegment Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Class

[image]

Revit 2013 API
BoundarySegmentArray Class
Members See Also Send Feedback
An array that contains boundary segments.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArray

See Also

BoundarySegmentArray Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArray Members
BoundarySegmentArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArray | Initializes a new instance of the BoundarySegmentArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Constructor

[image]

Revit 2013 API
BoundarySegmentArray Constructor
BoundarySegmentArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArray class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArray()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArray Methods
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment to the end of the array.
Public method | Clear | Removes every boundary segment from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified boundary segment into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Append Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Append Method
BoundarySegmentArray Class See Also Send Feedback
Add the boundary segment to the end of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegment item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegment _
)
Visual C++
public:
virtual void Append(
    BoundarySegment^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..BoundarySegment
The boundary segment to be added.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Clear Method
BoundarySegmentArray Class See Also Send Feedback
Removes every boundary segment from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ForwardIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..GetEnumerator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2013 API
BoundarySegmentArray..::..Insert Method
BoundarySegmentArray Class See Also Send Feedback
Insert the specified boundary segment into the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegment item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegment, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegment^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..BoundarySegment
The boundary segment to be inserted into the array.
index
Type: System..::..Int32
The boundary segment will be inserted before this index.

Return Value

Returns whether the boundary segment was inserted into the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArray..::..ReverseIterator Method
BoundarySegmentArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArray Properties
BoundarySegmentArray Class See Also Send Feedback

The BoundarySegmentArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment at a specified index within the array.
Public property | Size | Returns the number of boundary segments that are in the array.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArray..::..IsEmpty Property
BoundarySegmentArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Item Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Item Property
BoundarySegmentArray Class See Also Send Feedback
Gets or sets a boundary segment at a specified index within the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegment this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegment
    Get
    Set
Visual C++
public:
virtual property BoundarySegment^ Item[int index] {
    BoundarySegment^ get (int index);
    void set (int index, BoundarySegment^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment to be set or retrieved.

Return Value

Returns the boundary segment at the specified index.

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2013 API
BoundarySegmentArray..::..Size Property
BoundarySegmentArray Class See Also Send Feedback
Returns the number of boundary segments that are in the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Class

[image]

Revit 2013 API
BoundarySegmentArrayArray Class
Members See Also Send Feedback
An array that contains boundary segment arrays.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class BoundarySegmentArrayArray : APIObject,
    IEnumerable
Visual Basic
Public Class BoundarySegmentArrayArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class BoundarySegmentArrayArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayArray

See Also

BoundarySegmentArrayArray Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Members
BoundarySegmentArrayArray Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArray | Initializes a new instance of the BoundarySegmentArrayArray class

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArray Constructor
BoundarySegmentArrayArray Class See Also Send Feedback
Initializes a new instance of the BoundarySegmentArrayArray class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArray()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArray()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Methods
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the boundary segment array to the end of the array.
Public method | Clear | Removes every boundary segment array from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Append Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Append Method
BoundarySegmentArrayArray Class See Also Send Feedback
Add the boundary segment array to the end of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    BoundarySegmentArray item
)
Visual Basic
Public Overridable Sub Append ( _
    item As BoundarySegmentArray _
)
Visual C++
public:
virtual void Append(
    BoundarySegmentArray^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArray
The boundary segment array to be added.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Clear Method
BoundarySegmentArrayArray Class See Also Send Feedback
Removes every boundary segment array from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ForwardIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..GetEnumerator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Insert Method
BoundarySegmentArrayArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    BoundarySegmentArray item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As BoundarySegmentArray, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    BoundarySegmentArray^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArray
index
Type: System..::..Int32

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..ReverseIterator Method
BoundarySegmentArrayArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArrayArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As BoundarySegmentArrayArrayIterator
Visual C++
public:
virtual BoundarySegmentArrayArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArray Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArray Properties
BoundarySegmentArrayArray Class See Also Send Feedback

The BoundarySegmentArrayArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets a boundary segment array at a specified index within the array.
Public property | Size | Returns the number of boundary segment arrays that are in the array.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..IsEmpty Property
BoundarySegmentArrayArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Item Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Item Property
BoundarySegmentArrayArray Class See Also Send Feedback
Gets or sets a boundary segment array at a specified index within the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual BoundarySegmentArray this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As BoundarySegmentArray
    Get
    Set
Visual C++
public:
virtual property BoundarySegmentArray^ Item[int index] {
    BoundarySegmentArray^ get (int index);
    void set (int index, BoundarySegmentArray^ value);
}

Parameters

index
Type: System..::..Int32
The index of the boundary segment array to be set or retrieved.

Return Value

Returns the boundary segment array at the specified index.

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2013 API
BoundarySegmentArrayArray..::..Size Property
BoundarySegmentArrayArray Class See Also Send Feedback
Returns the number of boundary segment arrays that are in the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

BoundarySegmentArrayArray Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Class
Members See Also Send Feedback
An iterator to a array of boundary segment arrays.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayArrayIterator

See Also

BoundarySegmentArrayArrayIterator Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Members
BoundarySegmentArrayArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Constructor
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Methods
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..MoveNext Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Reset Method
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayArrayIterator Properties
BoundarySegmentArrayArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayArrayIterator..::..Current Property
BoundarySegmentArrayArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Class

[image]

Revit 2013 API
BoundarySegmentArrayIterator Class
Members See Also Send Feedback
An iterator to a boundary segment array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class BoundarySegmentArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class BoundarySegmentArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class BoundarySegmentArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..BoundarySegmentArrayIterator

See Also

BoundarySegmentArrayIterator Members
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Members

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Members
BoundarySegmentArrayIterator Class Constructors Methods Properties See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | BoundarySegmentArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Constructor

[image]

Revit 2013 API
BoundarySegmentArrayIterator Constructor
BoundarySegmentArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BoundarySegmentArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
BoundarySegmentArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Methods

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Methods
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..MoveNext Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Reset Method
BoundarySegmentArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


BoundarySegmentArrayIterator Properties

[image] [image]

Revit 2013 API
BoundarySegmentArrayIterator Properties
BoundarySegmentArrayIterator Class See Also Send Feedback

The BoundarySegmentArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
BoundarySegmentArrayIterator..::..Current Property
BoundarySegmentArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

BoundarySegmentArrayIterator Class
Autodesk.Revit.DB.Mechanical Namespace


ConditionType Enumeration

[image]

Revit 2013 API
ConditionType Enumeration
See Also Send Feedback
An enumerated type listing all the possible condition types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ConditionType
Visual Basic
Public Enumeration ConditionType
Visual C++
public enum class ConditionType

Members

Member name | Description
Heated | Condition Type is Heated.
Cooled | Condition Type is Cooled.
HeatedAndCooled | Condition Type is HeatedAndCooled.
Unconditioned | Condition Type is Unconditioned.
Vented | Condition Type is Vented.
NaturallyVentedOnly | Condition Type is NaturallyVentedOnly.
NoOfConditionTypes | Condition Type is NoOfConditionTypes.

See Also

Autodesk.Revit.DB.Mechanical Namespace


Duct Class

[image]

Revit 2013 API
Duct Class
Members See Also Send Feedback
A duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Duct : MEPCurve
Visual Basic
Public Class Duct _
    Inherits MEPCurve
Visual C++
public ref class Duct : public MEPCurve

Remarks

The duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Mechanical..::..Duct

See Also

Duct Members
Autodesk.Revit.DB.Mechanical Namespace


Duct Members

[image] [image]

Revit 2013 API
Duct Members
Duct Class Methods Properties See Also Send Feedback

The Duct type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreatePlaceholder | Creates a new placeholder duct.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsDuctTypeId | Checks if given type is valid duct type.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLevelId | Checks if given element id is valid level element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DuctType | The duct type of this duct.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies if the duct is a placeholder or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Duct Methods

[image] [image]

Revit 2013 API
Duct Methods
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreatePlaceholder | Creates a new placeholder duct.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
 | IsDuctTypeId | Checks if given type is valid duct type.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLevelId | Checks if given element id is valid level element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


CreatePlaceholder Method

[image]

Revit 2013 API
Duct..::..CreatePlaceholder Method
Duct Class See Also Send Feedback
Creates a new placeholder duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Duct CreatePlaceholder(
    Document document,
    ElementId ductTypeId,
    ElementId levelId,
    XYZ firstPoint,
    XYZ secondPoint
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    document As Document, _
    ductTypeId As ElementId, _
    levelId As ElementId, _
    firstPoint As XYZ, _
    secondPoint As XYZ _
) As Duct
Visual C++
public:
static Duct^ CreatePlaceholder(
    Document^ document,
    ElementId^ ductTypeId,
    ElementId^ levelId,
    XYZ^ firstPoint,
    XYZ^ secondPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ductTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the duct type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the duct.
firstPoint
Type: Autodesk.Revit.DB..::..XYZ
The first point of the placeholder line.
secondPoint
Type: Autodesk.Revit.DB..::..XYZ
The second point of the placeholder line.

Return Value

The placeholder duct.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The duct type ductTypeId is not valid duct type. -or- The level id levelId is not valid. -or- The points of firstPoint and secondPoint are equal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


IsDuctTypeId Method

[image]

Revit 2013 API
Duct..::..IsDuctTypeId Method
Duct Class See Also Send Feedback
Checks if given type is valid duct type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsDuctTypeId(
    Document document,
    ElementId ductTypeId
)
Visual Basic
Public Shared Function IsDuctTypeId ( _
    document As Document, _
    ductTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsDuctTypeId(
    Document^ document,
    ElementId^ ductTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ductTypeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the duct type to check.

Return Value

True if duct type can used for this duct, false otherwise.

Remarks

A type is valid for duct if it can be used to the duct element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


IsLevelId Method

[image]

Revit 2013 API
Duct..::..IsLevelId Method
Duct Class See Also Send Feedback
Checks if given element id is valid level element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsLevelId(
    Document document,
    ElementId levelId
)
Visual Basic
Public Shared Function IsLevelId ( _
    document As Document, _
    levelId As ElementId _
) As Boolean
Visual C++
public:
static bool IsLevelId(
    Document^ document,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
levelId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the level to check.

Return Value

True if given level id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Duct Properties

[image] [image]

Revit 2013 API
Duct Properties
Duct Class See Also Send Feedback

The Duct type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DuctType | The duct type of this duct.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies if the duct is a placeholder or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Property

[image]

Revit 2013 API
Duct..::..DuctType Property
Duct Class See Also Send Feedback
The duct type of this duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctType DuctType { get; set; }
Visual Basic
Public Property DuctType As DuctType
    Get
    Set
Visual C++
public:
property DuctType^ DuctType {
    DuctType^ get ();
    void set (DuctType^ value);
}

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


IsPlaceholder Property

[image]

Revit 2013 API
Duct..::..IsPlaceholder Property
Duct Class See Also Send Feedback
Identifies if the duct is a placeholder or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPlaceholder { get; }
Visual Basic
Public ReadOnly Property IsPlaceholder As Boolean
    Get
Visual C++
public:
property bool IsPlaceholder {
    bool get ();
}

See Also

Duct Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
Duct..::..Parameter Property
Duct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Duct Class
Duct Members
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Class

[image]

Revit 2013 API
DuctConnector Class
Members See Also Send Feedback
A duct connector that is assigned to a mechanical equipment or duct fitting family. Provides access to the duct connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class DuctConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class DuctConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class DuctConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Duct connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Mechanical..::..DuctConnector

See Also

DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Members

[image] [image]

Revit 2013 API
DuctConnector Members
DuctConnector Class Methods Properties See Also Send Feedback

The DuctConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LinkedConnector | Obsolete. The linked duct connector.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the duct connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Methods

[image] [image]

Revit 2013 API
DuctConnector Methods
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctConnector Properties

[image] [image]

Revit 2013 API
DuctConnector Properties
DuctConnector Class See Also Send Feedback

The DuctConnector type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LinkedConnector | Obsolete. The linked duct connector.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the duct connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


LinkedConnector Property

[image]

Revit 2013 API
DuctConnector..::..LinkedConnector Property
DuctConnector Class See Also Send Feedback
The linked duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public DuctConnector LinkedConnector { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")> _
Public Property LinkedConnector As DuctConnector
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public:
property DuctConnector^ LinkedConnector {
    DuctConnector^ get ();
    void set (DuctConnector^ value);
}

Remarks

Get this property to acquire the current linked duct connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another duct connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the connector to link to is the same as the connector being linked to.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the document is not modifiable or document regeneration fails.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctConnector..::..Parameter Property
DuctConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctConnector Class
DuctConnector Members
Autodesk.Revit.DB.Mechanical Namespace


SystemType Property

[image]

Revit 2013 API
DuctConnector..::..SystemType Property
DuctConnector Class See Also Send Feedback
The system type of the duct connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; set; }
Visual Basic
Public Property SystemType As DuctSystemType
    Get
    Set
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
    void set (DuctSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

DuctConnector Class
Autodesk.Revit.DB.Mechanical Namespace


DuctFlowConfigurationType Enumeration

[image]

Revit 2013 API
DuctFlowConfigurationType Enumeration
See Also Send Feedback
An enumerated type listing all duct flow configuration types for a connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DuctFlowConfigurationType
Visual Basic
Public Enumeration DuctFlowConfigurationType
Visual C++
public enum class DuctFlowConfigurationType

Members

Member name | Description
Calculated | Duct flow configuration is calculated.
Preset | Duct flow configuration is preset.
System | Duct flow configuration depends on system.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctInsulation Class

[image]

Revit 2013 API
DuctInsulation Class
Members See Also Send Feedback
Represents insulation applied to the outside of a given duct , fitting or accessory.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DuctInsulation : InsulationLiningBase
Visual Basic
Public Class DuctInsulation _
    Inherits InsulationLiningBase
Visual C++
public ref class DuctInsulation : public InsulationLiningBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..DuctInsulation

See Also

DuctInsulation Members
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulation Members

[image] [image]

Revit 2013 API
DuctInsulation Members
DuctInsulation Class Methods Properties See Also Send Feedback

The DuctInsulation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of duct insulation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctInsulation Class
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulation Methods

[image] [image]

Revit 2013 API
DuctInsulation Methods
DuctInsulation Class See Also Send Feedback

The DuctInsulation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of duct insulation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctInsulation Class
Autodesk.Revit.DB.Mechanical Namespace


Create Method

[image]

Revit 2013 API
DuctInsulation..::..Create Method
DuctInsulation Class See Also Send Feedback
Creates a new instance of duct insulation.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static DuctInsulation Create(
    Document document,
    ElementId ductOrContentElementId,
    ElementId ductInsulationTypeId,
    double Thickness
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ductOrContentElementId As ElementId, _
    ductInsulationTypeId As ElementId, _
    Thickness As Double _
) As DuctInsulation
Visual C++
public:
static DuctInsulation^ Create(
    Document^ document,
    ElementId^ ductOrContentElementId,
    ElementId^ ductInsulationTypeId,
    double Thickness
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ductOrContentElementId
Type: Autodesk.Revit.DB..::..ElementId
The duct , fitting or accessory ElementId to which insulation will be added.
ductInsulationTypeId
Type: Autodesk.Revit.DB..::..ElementId
The duct insulation type. If the input duct insulation type is InvalidElementId, the default insulation type from the document will be used.
Thickness
Type: System..::..Double
The thickness of the insulation.

Return Value

The newly created duct insulation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a duct, fitting, or accessory element. -or- This duct insulation type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DuctInsulation Class
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulation Properties

[image] [image]

Revit 2013 API
DuctInsulation Properties
DuctInsulation Class See Also Send Feedback

The DuctInsulation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctInsulation Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctInsulation..::..Parameter Property
DuctInsulation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctInsulation Class
DuctInsulation Members
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulationType Class

[image]

Revit 2013 API
DuctInsulationType Class
Members See Also Send Feedback
This class represents a duct insulation type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DuctInsulationType : ElementType
Visual Basic
Public Class DuctInsulationType _
    Inherits ElementType
Visual C++
public ref class DuctInsulationType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Mechanical..::..DuctInsulationType

See Also

DuctInsulationType Members
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulationType Members

[image] [image]

Revit 2013 API
DuctInsulationType Members
DuctInsulationType Class Methods Properties See Also Send Feedback

The DuctInsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctInsulationType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulationType Methods

[image] [image]

Revit 2013 API
DuctInsulationType Methods
DuctInsulationType Class See Also Send Feedback

The DuctInsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctInsulationType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctInsulationType Properties

[image] [image]

Revit 2013 API
DuctInsulationType Properties
DuctInsulationType Class See Also Send Feedback

The DuctInsulationType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctInsulationType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctInsulationType..::..Parameter Property
DuctInsulationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctInsulationType Class
DuctInsulationType Members
Autodesk.Revit.DB.Mechanical Namespace


DuctLining Class

[image]

Revit 2013 API
DuctLining Class
Members See Also Send Feedback
Represents Lining applied to the inside of a given duct, fitting or accessory.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DuctLining : InsulationLiningBase
Visual Basic
Public Class DuctLining _
    Inherits InsulationLiningBase
Visual C++
public ref class DuctLining : public InsulationLiningBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Mechanical..::..DuctLining

See Also

DuctLining Members
Autodesk.Revit.DB.Mechanical Namespace


DuctLining Members

[image] [image]

Revit 2013 API
DuctLining Members
DuctLining Class Methods Properties See Also Send Feedback

The DuctLining type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of duct lining.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctLining Class
Autodesk.Revit.DB.Mechanical Namespace


DuctLining Methods

[image] [image]

Revit 2013 API
DuctLining Methods
DuctLining Class See Also Send Feedback

The DuctLining type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of duct lining.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctLining Class
Autodesk.Revit.DB.Mechanical Namespace


Create Method

[image]

Revit 2013 API
DuctLining..::..Create Method
DuctLining Class See Also Send Feedback
Creates a new instance of duct lining.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static DuctLining Create(
    Document document,
    ElementId ductOrContentElementId,
    ElementId ductLiningTypeId,
    double Thickness
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    ductOrContentElementId As ElementId, _
    ductLiningTypeId As ElementId, _
    Thickness As Double _
) As DuctLining
Visual C++
public:
static DuctLining^ Create(
    Document^ document,
    ElementId^ ductOrContentElementId,
    ElementId^ ductLiningTypeId,
    double Thickness
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
ductOrContentElementId
Type: Autodesk.Revit.DB..::..ElementId
The duct, fitting or accessory ElementId to which lining will be added.
ductLiningTypeId
Type: Autodesk.Revit.DB..::..ElementId
The duct lining type. If the input duct lining type is InvalidElementId, the default lining type from the document will be used.
Thickness
Type: System..::..Double
The thickness of the lining.

Return Value

The newly created duct lining.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a duct, fitting, or accessory element. -or- This duct Lining type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

DuctLining Class
Autodesk.Revit.DB.Mechanical Namespace


DuctLining Properties

[image] [image]

Revit 2013 API
DuctLining Properties
DuctLining Class See Also Send Feedback

The DuctLining type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctLining Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctLining..::..Parameter Property
DuctLining Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctLining Class
DuctLining Members
Autodesk.Revit.DB.Mechanical Namespace


DuctLiningType Class

[image]

Revit 2013 API
DuctLiningType Class
Members See Also Send Feedback
This class represents a duct lining type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class DuctLiningType : ElementType
Visual Basic
Public Class DuctLiningType _
    Inherits ElementType
Visual C++
public ref class DuctLiningType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Mechanical..::..DuctLiningType

See Also

DuctLiningType Members
Autodesk.Revit.DB.Mechanical Namespace


DuctLiningType Members

[image] [image]

Revit 2013 API
DuctLiningType Members
DuctLiningType Class Methods Properties See Also Send Feedback

The DuctLiningType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidRoughness | Identifies if the input roughness is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctLiningType Methods

[image] [image]

Revit 2013 API
DuctLiningType Methods
DuctLiningType Class See Also Send Feedback

The DuctLiningType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidRoughness | Identifies if the input roughness is valid.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace


IsValidRoughness Method

[image]

Revit 2013 API
DuctLiningType..::..IsValidRoughness Method
DuctLiningType Class See Also Send Feedback
Identifies if the input roughness is valid.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidRoughness(
    double roughness
)
Visual Basic
Public Function IsValidRoughness ( _
    roughness As Double _
) As Boolean
Visual C++
public:
bool IsValidRoughness(
    double roughness
)

Parameters

roughness
Type: System..::..Double
The roughness to check.

Return Value

True if the value is acceptable, false otherwise.

Remarks

Roughness should be at least equal to or larger than 0.

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctLiningType Properties

[image] [image]

Revit 2013 API
DuctLiningType Properties
DuctLiningType Class See Also Send Feedback

The DuctLiningType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctLiningType..::..Parameter Property
DuctLiningType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctLiningType Class
DuctLiningType Members
Autodesk.Revit.DB.Mechanical Namespace


Roughness Property

[image]

Revit 2013 API
DuctLiningType..::..Roughness Property
DuctLiningType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
    Get
    Set
Visual C++
public:
property double Roughness {
    double get ();
    void set (double value);
}

Remarks

The roughness of Duct Lining.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The roughness value should be at least equal to or larger than 0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

DuctLiningType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctLossMethodType Enumeration

[image]

Revit 2013 API
DuctLossMethodType Enumeration
See Also Send Feedback
An enumerated type listing all duct loss calculation methods for a connector.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum DuctLossMethodType
Visual Basic
Public Enumeration DuctLossMethodType
Visual C++
public enum class DuctLossMethodType

Members

Member name | Description
NotDefined | Duct loss method is undefined.
SpecificLoss | Duct loss method is specified.
Coefficient | Duct loss method depends on the loss coefficient.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctShape Enumeration

[image]

Revit 2013 API
DuctShape Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum DuctShape
Visual Basic
Public Enumeration DuctShape
Visual C++
public enum class DuctShape

Members

Member name | Description
Round |
Rectangular |
Oval |

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctSizeIterator Class

[image]

Revit 2013 API
DuctSizeIterator Class
Members See Also Send Feedback
An iterator to a set of MEP duct sizes from DuctSizes.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DuctSizeIterator : IEnumerator<MEPSize>
Visual Basic
Public Class DuctSizeIterator _
    Implements IEnumerator(Of MEPSize)
Visual C++
public ref class DuctSizeIterator : IEnumerator<MEPSize^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..DuctSizeIterator

See Also

DuctSizeIterator Members
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeIterator Members

[image] [image]

Revit 2013 API
DuctSizeIterator Members
DuctSizeIterator Class Methods Properties See Also Send Feedback

The DuctSizeIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctSizeIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | Returns the current MEPSize.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCurrent | Identifies if the iterator has a current item.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeIterator Methods

[image] [image]

Revit 2013 API
DuctSizeIterator Methods
DuctSizeIterator Class See Also Send Feedback

The DuctSizeIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | Returns the current MEPSize.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCurrent | Identifies if the iterator has a current item.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
DuctSizeIterator..::..Dispose Method
DuctSizeIterator Class See Also Send Feedback
Releases all resources used by the DuctSizeIterator

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


GetCurrent Method

[image]

Revit 2013 API
DuctSizeIterator..::..GetCurrent Method
DuctSizeIterator Class See Also Send Feedback
Returns the current MEPSize.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public MEPSize GetCurrent()
Visual Basic
Public Function GetCurrent As MEPSize
Visual C++
public:
MEPSize^ GetCurrent()

Return Value

The current MEPSize.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


HasCurrent Method

[image]

Revit 2013 API
DuctSizeIterator..::..HasCurrent Method
DuctSizeIterator Class See Also Send Feedback
Identifies if the iterator has a current item.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasCurrent()
Visual Basic
Public Function HasCurrent As Boolean
Visual C++
public:
bool HasCurrent()

Return Value

True if there is a current item.

Remarks

There is no current item if the iterator has not started yet or has been done.

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


IsDone Method

[image]

Revit 2013 API
DuctSizeIterator..::..IsDone Method
DuctSizeIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
DuctSizeIterator..::..MoveNext Method
DuctSizeIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
DuctSizeIterator..::..Reset Method
DuctSizeIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeIterator Properties

[image] [image]

Revit 2013 API
DuctSizeIterator Properties
DuctSizeIterator Class See Also Send Feedback

The DuctSizeIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
DuctSizeIterator..::..Current Property
DuctSizeIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MEPSize Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As MEPSize
    Get
Visual C++
public:
virtual property MEPSize^ Current {
    MEPSize^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


CurrentObject Property

[image]

Revit 2013 API
DuctSizeIterator..::..CurrentObject Property
DuctSizeIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

DuctSizeIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizes Class

[image]

Revit 2013 API
DuctSizes Class
Members See Also Send Feedback
Class RbsDuctSizes being used to store the duct sizes

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DuctSizes : IEnumerable<MEPSize>,
    IDisposable
Visual Basic
Public Class DuctSizes _
    Implements IEnumerable(Of MEPSize), IDisposable
Visual C++
public ref class DuctSizes : IEnumerable<MEPSize^>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..DuctSizes

See Also

DuctSizes Members
Autodesk.Revit.DB.Mechanical Namespace


DuctSizes Members

[image] [image]

Revit 2013 API
DuctSizes Members
DuctSizes Class Methods Properties See Also Send Feedback

The DuctSizes type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Checks whether a duct size with the nominal diameter exists.
Public method | Dispose | Releases all resources used by the DuctSizes
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeIterator | Returns a DuctSizeIterator that iterates through the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizes Methods

[image] [image]

Revit 2013 API
DuctSizes Methods
DuctSizes Class See Also Send Feedback

The DuctSizes type exposes the following members.

Methods

 | Name | Description
Public method | Contains | Checks whether a duct size with the nominal diameter exists.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeIterator | Returns a DuctSizeIterator that iterates through the collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2013 API
DuctSizes..::..Contains Method
DuctSizes Class See Also Send Feedback
Checks whether a duct size with the nominal diameter exists.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool Contains(
    double nominalDiameter
)
Visual Basic
Public Function Contains ( _
    nominalDiameter As Double _
) As Boolean
Visual C++
public:
bool Contains(
    double nominalDiameter
)

Parameters

nominalDiameter
Type: System..::..Double
Nominal diameter.

Return Value

True if a duct size with the nominal diameter exists.

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
DuctSizes..::..Dispose Method
DuctSizes Class See Also Send Feedback
Releases all resources used by the DuctSizes

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


GetBasicIEnumerator Method

[image]

Revit 2013 API
DuctSizes..::..GetBasicIEnumerator Method
DuctSizes Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


GetDuctSizeIterator Method

[image]

Revit 2013 API
DuctSizes..::..GetDuctSizeIterator Method
DuctSizes Class See Also Send Feedback
Returns a DuctSizeIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSizeIterator GetDuctSizeIterator()
Visual Basic
Public Function GetDuctSizeIterator As DuctSizeIterator
Visual C++
public:
DuctSizeIterator^ GetDuctSizeIterator()

Return Value

A DuctSizeIterator object that can be used to iterate through key-value pairs in the collection.

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
DuctSizes..::..GetEnumerator Method
DuctSizes Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<MEPSize> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of MEPSize)
Visual C++
public:
virtual IEnumerator<MEPSize^>^ GetEnumerator()

Return Value

An IEnumerator(MEPSize) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizes Properties

[image] [image]

Revit 2013 API
DuctSizes Properties
DuctSizes Class See Also Send Feedback

The DuctSizes type exposes the following members.

Properties

 | Name | Description
Public property | Count | Count of the items contained in the collection.

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


Count Property

[image]

Revit 2013 API
DuctSizes..::..Count Property
DuctSizes Class See Also Send Feedback
Count of the items contained in the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

DuctSizes Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettingIterator Class

[image]

Revit 2013 API
DuctSizeSettingIterator Class
Members See Also Send Feedback
An iterator to a set of items from DuctSizeSettings. Each item is a KeyValuePair(DuctShape::Enum, DuctSizes).

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DuctSizeSettingIterator : IEnumerator<KeyValuePair<DuctShape, DuctSizes>>
Visual Basic
Public Class DuctSizeSettingIterator _
    Implements IEnumerator(Of KeyValuePair(Of DuctShape, DuctSizes))
Visual C++
public ref class DuctSizeSettingIterator : IEnumerator<KeyValuePair<DuctShape, DuctSizes^>>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..DuctSizeSettingIterator

See Also

DuctSizeSettingIterator Members
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettingIterator Members

[image] [image]

Revit 2013 API
DuctSizeSettingIterator Members
DuctSizeSettingIterator Class Methods Properties See Also Send Feedback

The DuctSizeSettingIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the DuctSizeSettingIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCurrent | Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the enumerator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettingIterator Methods

[image] [image]

Revit 2013 API
DuctSizeSettingIterator Methods
DuctSizeSettingIterator Class See Also Send Feedback

The DuctSizeSettingIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasCurrent | Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the enumerator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
DuctSizeSettingIterator..::..Dispose Method
DuctSizeSettingIterator Class See Also Send Feedback
Releases all resources used by the DuctSizeSettingIterator

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


HasCurrent Method

[image]

Revit 2013 API
DuctSizeSettingIterator..::..HasCurrent Method
DuctSizeSettingIterator Class See Also Send Feedback
Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasCurrent()
Visual Basic
Public Function HasCurrent As Boolean
Visual C++
public:
bool HasCurrent()

Return Value

True if there is a current item.

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


IsDone Method

[image]

Revit 2013 API
DuctSizeSettingIterator..::..IsDone Method
DuctSizeSettingIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
DuctSizeSettingIterator..::..MoveNext Method
DuctSizeSettingIterator Class See Also Send Feedback
Increments the enumerator to the next item.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this enumerator. False if the enumerator has completed all available items.

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
DuctSizeSettingIterator..::..Reset Method
DuctSizeSettingIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettingIterator Properties

[image] [image]

Revit 2013 API
DuctSizeSettingIterator Properties
DuctSizeSettingIterator Class See Also Send Feedback

The DuctSizeSettingIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Protected property | CurrentObject |

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
DuctSizeSettingIterator..::..Current Property
DuctSizeSettingIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual KeyValuePair<DuctShape, DuctSizes> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of DuctShape, DuctSizes)
    Get
Visual C++
public:
virtual property KeyValuePair<DuctShape, DuctSizes^> Current {
    KeyValuePair<DuctShape, DuctSizes^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


CurrentObject Property

[image]

Revit 2013 API
DuctSizeSettingIterator..::..CurrentObject Property
DuctSizeSettingIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

DuctSizeSettingIterator Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettings Class

[image]

Revit 2013 API
DuctSizeSettings Class
Members See Also Send Feedback
Duct sizes settings

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DuctSizeSettings : IEnumerable<KeyValuePair<DuctShape, DuctSizes>>,
    IDisposable
Visual Basic
Public Class DuctSizeSettings _
    Implements IEnumerable(Of KeyValuePair(Of DuctShape, DuctSizes)),  _
    IDisposable
Visual C++
public ref class DuctSizeSettings : IEnumerable<KeyValuePair<DuctShape, DuctSizes^>>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..DuctSizeSettings

See Also

DuctSizeSettings Members
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettings Members

[image] [image]

Revit 2013 API
DuctSizeSettings Members
DuctSizeSettings Class Methods Properties See Also Send Feedback

The DuctSizeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.
Public method | Dispose | Releases all resources used by the DuctSizeSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeSettingIterator | Returns a DuctSizeSettingIterator object that iterates through the collection.
 | GetDuctSizeSettings | Get the duct size settings of the project.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSizeCount | Get the size count of the duct size table. The duct shape determines the location of the size in the size table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSize | Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Item | Get the DuctSizes for this DuctShape.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettings Methods

[image] [image]

Revit 2013 API
DuctSizeSettings Methods
DuctSizeSettings Class See Also Send Feedback

The DuctSizeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDuctSizeSettingIterator | Returns a DuctSizeSettingIterator object that iterates through the collection.
 | GetDuctSizeSettings | Get the duct size settings of the project.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSizeCount | Get the size count of the duct size table. The duct shape determines the location of the size in the size table.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveSize | Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


AddSize Method

[image]

Revit 2013 API
DuctSizeSettings..::..AddSize Method
DuctSizeSettings Class See Also Send Feedback
Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddSize(
    DuctShape shape,
    MEPSize sizeInfo
)
Visual Basic
Public Sub AddSize ( _
    shape As DuctShape, _
    sizeInfo As MEPSize _
)
Visual C++
public:
void AddSize(
    DuctShape shape,
    MEPSize^ sizeInfo
)

Parameters

shape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The shape of duct.
sizeInfo
Type: Autodesk.Revit.DB..::..MEPSize
The new MEPSize to be added.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Throws if there is no size set determined by the duct shape or there is already the same size in the size set determined by the duct shape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if the function is called during iterating the size set.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
DuctSizeSettings..::..Dispose Method
DuctSizeSettings Class See Also Send Feedback
Releases all resources used by the DuctSizeSettings

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


GetBasicIEnumerator Method

[image]

Revit 2013 API
DuctSizeSettings..::..GetBasicIEnumerator Method
DuctSizeSettings Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


GetDuctSizeSettingIterator Method

[image]

Revit 2013 API
DuctSizeSettings..::..GetDuctSizeSettingIterator Method
DuctSizeSettings Class See Also Send Feedback
Returns a DuctSizeSettingIterator object that iterates through the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSizeSettingIterator GetDuctSizeSettingIterator()
Visual Basic
Public Function GetDuctSizeSettingIterator As DuctSizeSettingIterator
Visual C++
public:
DuctSizeSettingIterator^ GetDuctSizeSettingIterator()

Return Value

A DuctSizeSettingIterator object that can be used to iterate through key-value pairs in the collection.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


GetDuctSizeSettings Method

[image]

Revit 2013 API
DuctSizeSettings..::..GetDuctSizeSettings Method
DuctSizeSettings Class See Also Send Feedback
Get the duct size settings of the project.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static DuctSizeSettings GetDuctSizeSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetDuctSizeSettings ( _
    aDoc As Document _
) As DuctSizeSettings
Visual C++
public:
static DuctSizeSettings^ GetDuctSizeSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The duct size settings of the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
DuctSizeSettings..::..GetEnumerator Method
DuctSizeSettings Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<KeyValuePair<DuctShape, DuctSizes>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of KeyValuePair(Of DuctShape, DuctSizes))
Visual C++
public:
virtual IEnumerator<KeyValuePair<DuctShape, DuctSizes^>>^ GetEnumerator()

Return Value

An IEnumerator( KeyValuePair(DuctShape::Enum^,DuctSizes^) ) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


GetSizeCount Method

[image]

Revit 2013 API
DuctSizeSettings..::..GetSizeCount Method
DuctSizeSettings Class See Also Send Feedback
Get the size count of the duct size table. The duct shape determines the location of the size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int GetSizeCount(
    DuctShape shape
)
Visual Basic
Public Function GetSizeCount ( _
    shape As DuctShape _
) As Integer
Visual C++
public:
int GetSizeCount(
    DuctShape shape
)

Parameters

shape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The shape of duct.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


RemoveSize Method

[image]

Revit 2013 API
DuctSizeSettings..::..RemoveSize Method
DuctSizeSettings Class See Also Send Feedback
Erase the existing MEPSize with this nominal diameter. The duct shape determines the location of the size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveSize(
    DuctShape shape,
    double nominalDiameter
)
Visual Basic
Public Sub RemoveSize ( _
    shape As DuctShape, _
    nominalDiameter As Double _
)
Visual C++
public:
void RemoveSize(
    DuctShape shape,
    double nominalDiameter
)

Parameters

shape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The shape of duct.
nominalDiameter
Type: System..::..Double
Nominal diameter.

Remarks

Does nothing if there is no existing MEPSize with this nominal diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Throws if the function is called during iterating the size set.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSizeSettings Properties

[image] [image]

Revit 2013 API
DuctSizeSettings Properties
DuctSizeSettings Class See Also Send Feedback

The DuctSizeSettings type exposes the following members.

Properties

 | Name | Description
Public property | Item | Get the DuctSizes for this DuctShape.

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


Item Property

[image]

Revit 2013 API
DuctSizeSettings..::..Item Property
DuctSizeSettings Class See Also Send Feedback
Get the DuctSizes for this DuctShape.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public DuctSizes this[
    DuctShape ductShape
] { get; }
Visual Basic
Public ReadOnly Property Item ( _
    ductShape As DuctShape _
) As DuctSizes
    Get
Visual C++
public:
property DuctSizes^ Item[DuctShape ductShape] {
    DuctSizes^ get (DuctShape ductShape);
}

Parameters

ductShape
Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The duct shape.

Return Value

The DuctSizes for this DuctShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | There is no DuctSizes for this DuctShape.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

DuctSizeSettings Class
Autodesk.Revit.DB.Mechanical Namespace


DuctSystemType Enumeration

[image]

Revit 2013 API
DuctSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible duct system types for a connector object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum DuctSystemType
Visual Basic
Public Enumeration DuctSystemType
Visual C++
public enum class DuctSystemType

Members

Member name | Description
UndefinedSystemType | Undefined system type.
SupplyAir | Duct System Type is SupplyAir.
ReturnAir | Duct System Type is ReturnAir.
ExhaustAir | Duct System Type is ExhaustAir.
OtherAir | Duct System Type is OtherAir.
Fitting | Duct System Type is Fitting.
Global | Duct System Type is Global.

See Also

Autodesk.Revit.DB.Mechanical Namespace


DuctType Class

[image]

Revit 2013 API
DuctType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class DuctType : MEPCurveType
Visual Basic
Public Class DuctType _
    Inherits MEPCurveType
Visual C++
public ref class DuctType : public MEPCurveType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Mechanical..::..DuctType

See Also

DuctType Members
Autodesk.Revit.DB.Mechanical Namespace


DuctType Members

[image] [image]

Revit 2013 API
DuctType Members
DuctType Class Methods Properties See Also Send Feedback

The DuctType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Methods

[image] [image]

Revit 2013 API
DuctType Methods
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


DuctType Properties

[image] [image]

Revit 2013 API
DuctType Properties
DuctType Class See Also Send Feedback

The DuctType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

DuctType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
DuctType..::..Parameter Property
DuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

DuctType Class
DuctType Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Class

[image]

Revit 2013 API
FlexDuct Class
Members See Also Send Feedback
A flex duct in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FlexDuct : MEPCurve
Visual Basic
Public Class FlexDuct _
    Inherits MEPCurve
Visual C++
public ref class FlexDuct : public MEPCurve

Remarks

The flex duct is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Mechanical..::..FlexDuct

See Also

FlexDuct Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Members

[image] [image]

Revit 2013 API
FlexDuct Members
FlexDuct Class Methods Properties See Also Send Feedback

The FlexDuct type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlexDuctType | The flex duct type of this flex duct.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Points | The points of the flex duct.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Methods

[image] [image]

Revit 2013 API
FlexDuct Methods
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuct Properties

[image] [image]

Revit 2013 API
FlexDuct Properties
FlexDuct Class See Also Send Feedback

The FlexDuct type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlexDuctType | The flex duct type of this flex duct.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Points | The points of the flex duct.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Property

[image]

Revit 2013 API
FlexDuct..::..FlexDuctType Property
FlexDuct Class See Also Send Feedback
The flex duct type of this flex duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexDuctType FlexDuctType { get; set; }
Visual Basic
Public Property FlexDuctType As FlexDuctType
    Get
    Set
Visual C++
public:
property FlexDuctType^ FlexDuctType {
    FlexDuctType^ get ();
    void set (FlexDuctType^ value);
}

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
FlexDuct..::..Parameter Property
FlexDuct Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FlexDuct Class
FlexDuct Members
Autodesk.Revit.DB.Mechanical Namespace


Points Property

[image]

Revit 2013 API
FlexDuct..::..Points Property
FlexDuct Class See Also Send Feedback
The points of the flex duct.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic
Public Property Points As IList(Of XYZ)
    Get
    Set
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex duct, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexDuct Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Class

[image]

Revit 2013 API
FlexDuctType Class
Members See Also Send Feedback
A flex duct type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FlexDuctType : MEPCurveType
Visual Basic
Public Class FlexDuctType _
    Inherits MEPCurveType
Visual C++
public ref class FlexDuctType : public MEPCurveType

Remarks

The flex duct type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Mechanical..::..FlexDuctType

See Also

FlexDuctType Members
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Members

[image] [image]

Revit 2013 API
FlexDuctType Members
FlexDuctType Class Methods Properties See Also Send Feedback

The FlexDuctType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Methods

[image] [image]

Revit 2013 API
FlexDuctType Methods
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


FlexDuctType Properties

[image] [image]

Revit 2013 API
FlexDuctType Properties
FlexDuctType Class See Also Send Feedback

The FlexDuctType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexDuctType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
FlexDuctType..::..Parameter Property
FlexDuctType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FlexDuctType Class
FlexDuctType Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Class

[image]

Revit 2013 API
MechanicalEquipment Class
Members See Also Send Feedback
Provides access to the Mechanical Equipment in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MechanicalEquipment : MEPModel
Visual Basic
Public Class MechanicalEquipment _
    Inherits MEPModel
Visual C++
public ref class MechanicalEquipment : public MEPModel

Remarks

The Mechanical Equipment object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Mechanical..::..MechanicalEquipment

See Also

MechanicalEquipment Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Members

[image] [image]

Revit 2013 API
MechanicalEquipment Members
MechanicalEquipment Class Methods Properties See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Methods

[image] [image]

Revit 2013 API
MechanicalEquipment Methods
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalEquipment Properties

[image] [image]

Revit 2013 API
MechanicalEquipment Properties
MechanicalEquipment Class See Also Send Feedback

The MechanicalEquipment type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MechanicalEquipment Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Class

[image]

Revit 2013 API
MechanicalFitting Class
Members See Also Send Feedback
A mechanical fitting in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MechanicalFitting : MEPModel
Visual Basic
Public Class MechanicalFitting _
    Inherits MEPModel
Visual C++
public ref class MechanicalFitting : public MEPModel

Remarks

The mechanical fitting is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..MEPModel
Autodesk.Revit.DB.Mechanical..::..MechanicalFitting

See Also

MechanicalFitting Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Members

[image] [image]

Revit 2013 API
MechanicalFitting Members
MechanicalFitting Class Methods Properties See Also Send Feedback

The MechanicalFitting type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Methods

[image] [image]

Revit 2013 API
MechanicalFitting Methods
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalFitting Properties

[image] [image]

Revit 2013 API
MechanicalFitting Properties
MechanicalFitting Class See Also Send Feedback

The MechanicalFitting type exposes the following members.

Properties

 | Name | Description
Public property | AssignedElectricalSystems | Retrieves the electrical systems this electrical panel currently is assigned to. (Inherited from MEPModel.)
Public property | ConnectorManager | Retrieves the Connector Manager from this MEPModel. (Inherited from MEPModel.)
Public property | ElectricalSystems | Retrieves the electrical systems that are currently created using this MEPModel. (Inherited from MEPModel.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | PartType | The part type of the mechanical fitting.

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


PartType Property

[image]

Revit 2013 API
MechanicalFitting..::..PartType Property
MechanicalFitting Class See Also Send Feedback
The part type of the mechanical fitting.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PartType PartType { get; }
Visual Basic
Public ReadOnly Property PartType As PartType
    Get
Visual C++
public:
property PartType PartType {
    PartType get ();
}

See Also

MechanicalFitting Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Class

[image]

Revit 2013 API
MechanicalSystem Class
Members See Also Send Feedback
Default constructor Default destructor

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class MechanicalSystem : MEPSystem
Visual Basic
Public Class MechanicalSystem _
    Inherits MEPSystem
Visual C++
public ref class MechanicalSystem : public MEPSystem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Mechanical..::..MechanicalSystem

See Also

MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Members

[image] [image]

Revit 2013 API
MechanicalSystem Members
MechanicalSystem Class Methods Properties See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a mechanical system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a mechanical system and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DuctNetwork | The ducts and fittings contained within the system.
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | Flow | Indicates the computed total flow for the mechanical system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | StaticPressure | Indicates the computed static pressure for the mechanical system.
Public property | SystemType | The type of this duct system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Methods

[image] [image]

Revit 2013 API
MechanicalSystem Methods
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a mechanical system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a mechanical system and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


Create Method

[image] [image]

Revit 2013 API
MechanicalSystem..::..Create Method
MechanicalSystem Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates a new instance of a mechanical system and adds it to the document.
Create(Document, ElementId, String) | Creates a new instance of a mechanical system and adds it to the document.

See Also

MechanicalSystem Class
MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


Create Method (Document, ElementId)

[image]

Revit 2013 API
MechanicalSystem..::..Create Method (Document, ElementId)
MechanicalSystem Class See Also Send Feedback
Creates a new instance of a mechanical system and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static MechanicalSystem Create(
    Document ADocument,
    ElementId typeId
)
Visual Basic
Public Shared Function Create ( _
    ADocument As Document, _
    typeId As ElementId _
) As MechanicalSystem
Visual C++
public:
static MechanicalSystem^ Create(
    Document^ ADocument,
    ElementId^ typeId
)

Parameters

ADocument
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The identifier of this mechanical system element's type.

Return Value

The newly created mechanical system element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The typeId is not an element id for a valid mechanical system type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

MechanicalSystem Class
Create Overload
Autodesk.Revit.DB.Mechanical Namespace


Create Method (Document, ElementId, String)

[image]

Revit 2013 API
MechanicalSystem..::..Create Method (Document, ElementId, String)
MechanicalSystem Class See Also Send Feedback
Creates a new instance of a mechanical system and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static MechanicalSystem Create(
    Document ADocument,
    ElementId typeId,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADocument As Document, _
    typeId As ElementId, _
    name As String _
) As MechanicalSystem
Visual C++
public:
static MechanicalSystem^ Create(
    Document^ ADocument,
    ElementId^ typeId,
    String^ name
)

Parameters

ADocument
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The identifier of this mechanical system element's type.
name
Type: System..::..String
The name of the mechanical system to be created.

Return Value

The newly created mechanical system element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The typeId is not an element id for a valid mechanical system type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

MechanicalSystem Class
Create Overload
Autodesk.Revit.DB.Mechanical Namespace


Remove Method

[image] [image]

Revit 2013 API
MechanicalSystem..::..Remove Method
MechanicalSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)

See Also

MechanicalSystem Class
MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystem Properties

[image] [image]

Revit 2013 API
MechanicalSystem Properties
MechanicalSystem Class See Also Send Feedback

The MechanicalSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within the base equipment which is used to connect with the system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | DuctNetwork | The ducts and fittings contained within the system.
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | Flow | Indicates the computed total flow for the mechanical system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | StaticPressure | Indicates the computed static pressure for the mechanical system.
Public property | SystemType | The type of this duct system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


BaseEquipmentConnector Property

[image]

Revit 2013 API
MechanicalSystem..::..BaseEquipmentConnector Property
MechanicalSystem Class See Also Send Feedback
The connector within the base equipment which is used to connect with the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic
Public Property BaseEquipmentConnector As Connector
    Get
    Set
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Assigning nullNothingnullptra null reference (Nothing in Visual Basic) to the base equipment connector will disconnect the base equipment from the system.

Remarks

Setting this property will regenerate the document even in manual regeneration mode.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


DuctNetwork Property

[image]

Revit 2013 API
MechanicalSystem..::..DuctNetwork Property
MechanicalSystem Class See Also Send Feedback
The ducts and fittings contained within the system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet DuctNetwork { get; }
Visual Basic
Public ReadOnly Property DuctNetwork As ElementSet
    Get
Visual C++
public:
property ElementSet^ DuctNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include terminals or equipments, the ducts and fittings are returned in no particular order.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


Flow Property

[image]

Revit 2013 API
MechanicalSystem..::..Flow Property
MechanicalSystem Class See Also Send Feedback
Indicates the computed total flow for the mechanical system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Flow { get; }
Visual Basic
Public ReadOnly Property Flow As Double
    Get
Visual C++
public:
property double Flow {
    double get ();
}

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


IsWellConnected Property

[image]

Revit 2013 API
MechanicalSystem..::..IsWellConnected Property
MechanicalSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic
Public ReadOnly Property IsWellConnected As Boolean
    Get
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
MechanicalSystem..::..Parameter Property
MechanicalSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MechanicalSystem Class
MechanicalSystem Members
Autodesk.Revit.DB.Mechanical Namespace


StaticPressure Property

[image]

Revit 2013 API
MechanicalSystem..::..StaticPressure Property
MechanicalSystem Class See Also Send Feedback
Indicates the computed static pressure for the mechanical system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double StaticPressure { get; }
Visual Basic
Public ReadOnly Property StaticPressure As Double
    Get
Visual C++
public:
property double StaticPressure {
    double get ();
}

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


SystemType Property

[image]

Revit 2013 API
MechanicalSystem..::..SystemType Property
MechanicalSystem Class See Also Send Feedback
The type of this duct system.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DuctSystemType SystemType { get; }
Visual Basic
Public ReadOnly Property SystemType As DuctSystemType
    Get
Visual C++
public:
property DuctSystemType SystemType {
    DuctSystemType get ();
}

See Also

MechanicalSystem Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystemType Class

[image]

Revit 2013 API
MechanicalSystemType Class
Members See Also Send Feedback
Base class for duct system types

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MechanicalSystemType : MEPSystemType
Visual Basic
Public Class MechanicalSystemType _
    Inherits MEPSystemType
Visual C++
public ref class MechanicalSystemType : public MEPSystemType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Mechanical..::..MechanicalSystemType

See Also

MechanicalSystemType Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystemType Members

[image] [image]

Revit 2013 API
MechanicalSystemType Members
MechanicalSystemType Class Methods Properties See Also Send Feedback

The MechanicalSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a mechanical system type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateRiseDropSymbolType | Confirm the parameter is a valid hvac rise/drop symbol type

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type; (Inherited from MEPSystemType.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type; (Inherited from MEPSystemType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system. (Inherited from MEPSystemType.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system. (Inherited from MEPSystemType.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RiseDropSettings | indicates the rise/drop symbol given the system type
Public property | SystemClassification | Identifies the classification for the system type; (Inherited from MEPSystemType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystemType Methods

[image] [image]

Revit 2013 API
MechanicalSystemType Methods
MechanicalSystemType Class See Also Send Feedback

The MechanicalSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a mechanical system type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateRiseDropSymbolType | Confirm the parameter is a valid hvac rise/drop symbol type

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


Create Method

[image]

Revit 2013 API
MechanicalSystemType..::..Create Method
MechanicalSystemType Class See Also Send Feedback
Creates a new instance of a mechanical system type and adds it to the document.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static MechanicalSystemType Create(
    Document ADoc,
    MEPSystemClassification systemClassification,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    systemClassification As MEPSystemClassification, _
    name As String _
) As MechanicalSystemType
Visual C++
public:
static MechanicalSystemType^ Create(
    Document^ ADoc,
    MEPSystemClassification systemClassification,
    String^ name
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
systemClassification
Type: Autodesk.Revit.DB..::..MEPSystemClassification
The classification for the mechanical system type to be created
name
Type: System..::..String
The name of the mechanical system type to be created.

Return Value

The newly created mechanical system type element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The system classification is not valid for the domain of this system type.

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


ValidateRiseDropSymbolType Method

[image]

Revit 2013 API
MechanicalSystemType..::..ValidateRiseDropSymbolType Method
MechanicalSystemType Class See Also Send Feedback
Confirm the parameter is a valid hvac rise/drop symbol type

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ValidateRiseDropSymbolType(
    RiseDropSymbol risedropType
)
Visual Basic
Public Function ValidateRiseDropSymbolType ( _
    risedropType As RiseDropSymbol _
) As Boolean
Visual C++
public:
bool ValidateRiseDropSymbolType(
    RiseDropSymbol risedropType
)

Parameters

risedropType
Type: Autodesk.Revit.DB.Mechanical..::..RiseDropSymbol

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalSystemType Properties

[image] [image]

Revit 2013 API
MechanicalSystemType Properties
MechanicalSystemType Class See Also Send Feedback

The MechanicalSystemType type exposes the following members.

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type; (Inherited from MEPSystemType.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type; (Inherited from MEPSystemType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system. (Inherited from MEPSystemType.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system. (Inherited from MEPSystemType.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RiseDropSettings | indicates the rise/drop symbol given the system type
Public property | SystemClassification | Identifies the classification for the system type; (Inherited from MEPSystemType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
MechanicalSystemType..::..Parameter Property
MechanicalSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MechanicalSystemType Class
MechanicalSystemType Members
Autodesk.Revit.DB.Mechanical Namespace


RiseDropSettings Property

[image]

Revit 2013 API
MechanicalSystemType..::..RiseDropSettings Property
MechanicalSystemType Class See Also Send Feedback
indicates the rise/drop symbol given the system type

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol RiseDropSettings { get; set; }
Visual Basic
Public Property RiseDropSettings As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol RiseDropSettings {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

MechanicalSystemType Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalUtils Class

[image]

Revit 2013 API
MechanicalUtils Class
Members See Also Send Feedback
General utility methods in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class MechanicalUtils : IDisposable
Visual Basic
Public Class MechanicalUtils _
    Implements IDisposable
Visual C++
public ref class MechanicalUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..MechanicalUtils

See Also

MechanicalUtils Members
Autodesk.Revit.DB.Mechanical Namespace


MechanicalUtils Members

[image] [image]

Revit 2013 API
MechanicalUtils Members
MechanicalUtils Class Methods See Also Send Feedback

The MechanicalUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertDuctPlaceholders | Converts a collection of duct placeholder elements into duct elements.
Public method | Dispose | Releases all resources used by the MechanicalUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace


MechanicalUtils Methods

[image] [image]

Revit 2013 API
MechanicalUtils Methods
MechanicalUtils Class See Also Send Feedback

The MechanicalUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertDuctPlaceholders | Converts a collection of duct placeholder elements into duct elements.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtCross Method

[image] [image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method
MechanicalUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
ConnectDuctPlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
ConnectDuctPlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.

See Also

MechanicalUtils Class
MechanicalUtils Members
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId)
MechanicalUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtCross(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtCross ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtCross(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of duct placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders must intersect each other. If connection succeeds, a new placeholder is created. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtCross Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId, ElementId)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method (Document, ElementId, ElementId, ElementId)
MechanicalUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtCross(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id,
    ElementId placeholder3Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtCross ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId, _
    placeholder3Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtCross(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id,
    ElementId^ placeholder3Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of duct placeholder that intersects with first one.
placeholder3Id
Type: Autodesk.Revit.DB..::..ElementId
The third element Id of duct placeholder that intersects with first one.

Return Value

True if connection succeeds, false otherwise.

Remarks

If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The element id placeholder3Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder3Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder2Id and placeholder3Id are not collinear.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtCross Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtCross Method (Document, Connector, Connector, Connector, Connector)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtCross Method (Document, Connector, Connector, Connector, Connector)
MechanicalUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtCross(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtCross ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtCross(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the forth.
connector4
Type: Autodesk.Revit.DB..::..Connector
The fourth end connector of placeholder to be connected to the third.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may or may not have physical connection. However a) The ends of four connectors should intersect at same point; b) the first and second placeholders should be collinear each other; c) the third and fourth placeholders should be collinear each other and d) the third and fourth should have intersection with first or second placeholder. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end. -or- The curves of connector3 and connector4 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtCross Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtElbow Method

[image] [image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtElbow Method
MechanicalUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectDuctPlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
ConnectDuctPlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.

See Also

MechanicalUtils Class
MechanicalUtils Members
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtElbow Method (Document, Connector, Connector)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtElbow Method (Document, Connector, Connector)
MechanicalUtils Class Example See Also Send Feedback
Connects placeholders that looks like elbow connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtElbow(
    Document document,
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtElbow ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtElbow(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may have physical connection or may not connect at all. In the latter case, the first one connects to the end of second one. If connection fails, the placeholders cannot be physically connected.

Examples

CopyC#
//Create a point to be the connection point of two ductPlaceholders
XYZ connectionPoint = new XYZ(150, 0, 0);

//Create two new ductPlaceholders, duct1 and duct2, each ductPlaceholder has connectionPoint as its parameter
Duct duct1 = Duct.CreatePlaceholder(document, ductTypeId, levelId, new XYZ(100, 0, 0), connectionPoint);
Duct duct2 = Duct.CreatePlaceholder(document, ductTypeId, levelId, connectionPoint, new XYZ(150, 50, 0));

//Get Connectors of duct1 and duct2's ConnectorManager and change their type to IEnumerable<Connector>
//Get the first connector from the IEnumerable where the origin of the connector is almost equal to connectionPoint
Connector connector1 = duct1.ConnectorManager.Connectors.Cast<Connector>().Where(c => c.Origin.IsAlmostEqualTo(connectionPoint)).First();
Connector connector2 = duct2.ConnectorManager.Connectors.Cast<Connector>().Where(c => c.Origin.IsAlmostEqualTo(connectionPoint)).First();

//Connect duct1 and duct2 with elbow fitting by their intersecting connectors(whose origin is almost equal to connectionPoint)
bool connectResult = MechanicalUtils.ConnectDuctPlaceholdersAtElbow(document, connector1, connector2);

//Convert duct1 and duct2 to real ducts
ICollection<ElementId> convertedElementsId = MechanicalUtils.ConvertDuctPlaceholders(document, new ElementId[] { duct1.Id, duct2.Id });

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtElbow Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtElbow Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtElbow Method (Document, ElementId, ElementId)
MechanicalUtils Class See Also Send Feedback
Connects placeholders that looks like elbow connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtElbow(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtElbow ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtElbow(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The element Id of duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The element Id of duct placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

There must be a physical end connection of placeholders. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder1Id and placeholder2Id are not physically connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtElbow Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtTee Method

[image] [image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtTee Method
MechanicalUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectDuctPlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
ConnectDuctPlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.

See Also

MechanicalUtils Class
MechanicalUtils Members
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtTee Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtTee Method (Document, ElementId, ElementId)
MechanicalUtils Class See Also Send Feedback
Connects two placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtTee(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtTee ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtTee(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of duct placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of duct placeholder which connects to first.

Return Value

True if connection succeeds, false otherwise.

Remarks

The second placeholder must have physically connection with the first one. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not duct placeholder. -or- The element id placeholder2Id is not duct placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtTee Overload
Autodesk.Revit.DB.Mechanical Namespace


ConnectDuctPlaceholdersAtTee Method (Document, Connector, Connector, Connector)

[image]

Revit 2013 API
MechanicalUtils..::..ConnectDuctPlaceholdersAtTee Method (Document, Connector, Connector, Connector)
MechanicalUtils Class See Also Send Feedback
Connects three placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectDuctPlaceholdersAtTee(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic
Public Shared Function ConnectDuctPlaceholdersAtTee ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectDuctPlaceholdersAtTee(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the first or second.

Return Value

True if connection succeeds, false otherwise.

Remarks

The three placeholders may or may not have physically connections. However, the first one should be collinear with the second and third one must have intersection with first and second. If first placeholder and second placeholder have the same size, the second one is merged with first one and original placeholder element will be invalid. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not duct placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
ConnectDuctPlaceholdersAtTee Overload
Autodesk.Revit.DB.Mechanical Namespace


ConvertDuctPlaceholders Method

[image]

Revit 2013 API
MechanicalUtils..::..ConvertDuctPlaceholders Method
MechanicalUtils Class See Also Send Feedback
Converts a collection of duct placeholder elements into duct elements.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> ConvertDuctPlaceholders(
    Document document,
    ICollection<ElementId> placeholderIds
)
Visual Basic
Public Shared Function ConvertDuctPlaceholders ( _
    document As Document, _
    placeholderIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ConvertDuctPlaceholders(
    Document^ document,
    ICollection<ElementId^>^ placeholderIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholderIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs of duct placeholders.

Return Value

A collection of element IDs of ducts and fittings.

Remarks

Once conversion succeeds, the duct placeholder elements are deleted. The new duct and fitting elements are created and connections are established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element IDs set is empty. -or- The given element IDs (placeholderIds) are not duct placeholders. -or- The elements belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
MechanicalUtils..::..Dispose Method
MechanicalUtils Class See Also Send Feedback
Releases all resources used by the MechanicalUtils

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MechanicalUtils Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Class

[image]

Revit 2013 API
MEPBuildingConstruction Class
Members See Also Send Feedback
Construction definition for Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPBuildingConstruction : ElementType
Visual Basic
Public Class MEPBuildingConstruction _
    Inherits ElementType
Visual C++
public ref class MEPBuildingConstruction : public ElementType

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction

See Also

MEPBuildingConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Members

[image] [image]

Revit 2013 API
MEPBuildingConstruction Members
MEPBuildingConstruction Class Methods Properties See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBuildingConstruction | Gets the current Building Construction from the project information.
Public method | GetBuildingConstructionOverride | Gets the Building Construction override for a ConstructionType.
Public method | GetConstructions | Gets all the Building Constructions corresponding to the specific Construction type.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetBuildingConstruction | Sets the Building Construction of the Project Information.
Public method | SetBuildingConstructionOverride | Sets the Building Construction override for a ConstructionType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Methods

[image] [image]

Revit 2013 API
MEPBuildingConstruction Methods
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBuildingConstruction | Gets the current Building Construction from the project information.
Public method | GetBuildingConstructionOverride | Gets the Building Construction override for a ConstructionType.
Public method | GetConstructions | Gets all the Building Constructions corresponding to the specific Construction type.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetBuildingConstruction | Sets the Building Construction of the Project Information.
Public method | SetBuildingConstructionOverride | Sets the Building Construction override for a ConstructionType.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


GetBuildingConstruction Method

[image]

Revit 2013 API
MEPBuildingConstruction..::..GetBuildingConstruction Method
MEPBuildingConstruction Class See Also Send Feedback
Gets the current Building Construction from the project information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Construction GetBuildingConstruction(
    ConstructionType constructionType
)
Visual Basic
Public Function GetBuildingConstruction ( _
    constructionType As ConstructionType _
) As Construction
Visual C++
public:
Construction^ GetBuildingConstruction(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The Construction Type of Building Construction.

Return Value

The Building Construction of the Project Information.

Remarks

This function is used to get the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


GetBuildingConstructionOverride Method

[image]

Revit 2013 API
MEPBuildingConstruction..::..GetBuildingConstructionOverride Method
MEPBuildingConstruction Class See Also Send Feedback
Gets the Building Construction override for a ConstructionType.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool GetBuildingConstructionOverride(
    ConstructionType constructionType
)
Visual Basic
Public Function GetBuildingConstructionOverride ( _
    constructionType As ConstructionType _
) As Boolean
Visual C++
public:
bool GetBuildingConstructionOverride(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The ConstructionType override value to get.

Return Value

True if analytical construction properties specified in Constructions.xml are used for the given ConstructionType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The ConstructionType is invalid.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


GetConstructions Method

[image]

Revit 2013 API
MEPBuildingConstruction..::..GetConstructions Method
MEPBuildingConstruction Class See Also Send Feedback
Gets all the Building Constructions corresponding to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<Construction> GetConstructions(
    ConstructionType constructionType
)
Visual Basic
Public Function GetConstructions ( _
    constructionType As ConstructionType _
) As ICollection(Of Construction)
Visual C++
public:
ICollection<Construction^>^ GetConstructions(
    ConstructionType constructionType
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The Construction Type of Building Construction.

Return Value

A collection containing Building constructions matching the construction type.

Remarks

This function is used to get the Building Construction of the Project Information.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


SetBuildingConstruction Method

[image]

Revit 2013 API
MEPBuildingConstruction..::..SetBuildingConstruction Method
MEPBuildingConstruction Class See Also Send Feedback
Sets the Building Construction of the Project Information.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetBuildingConstruction(
    ConstructionType constructionType,
    Construction buildingConstruction
)
Visual Basic
Public Sub SetBuildingConstruction ( _
    constructionType As ConstructionType, _
    buildingConstruction As Construction _
)
Visual C++
public:
void SetBuildingConstruction(
    ConstructionType constructionType,
    Construction^ buildingConstruction
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The Construction Type of Building Construction.
buildingConstruction
Type: Autodesk.Revit.DB..::..Construction
The Building Construction to be set.

Remarks

This function is used to set the Building Construction of the Project Information.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | buildingConstruction is NULL.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Sets construction type to an invalid value. - or - Can not set construction type.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


SetBuildingConstructionOverride Method

[image]

Revit 2013 API
MEPBuildingConstruction..::..SetBuildingConstructionOverride Method
MEPBuildingConstruction Class See Also Send Feedback
Sets the Building Construction override for a ConstructionType.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetBuildingConstructionOverride(
    ConstructionType constructionType,
    bool override
)
Visual Basic
Public Sub SetBuildingConstructionOverride ( _
    constructionType As ConstructionType, _
    override As Boolean _
)
Visual C++
public:
void SetBuildingConstructionOverride(
    ConstructionType constructionType,
    bool override
)

Parameters

constructionType
Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The ConstructionType to override.
override
Type: System..::..Boolean
True to use analytical construction properties specified in Constructions.xml in the given ConstructionType, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The ConstructionType is invalid.

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstruction Properties

[image] [image]

Revit 2013 API
MEPBuildingConstruction Properties
MEPBuildingConstruction Class See Also Send Feedback

The MEPBuildingConstruction type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
MEPBuildingConstruction..::..Parameter Property
MEPBuildingConstruction Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

MEPBuildingConstruction Class
MEPBuildingConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Class

[image]

Revit 2013 API
MEPBuildingConstructionSet Class
Members See Also Send Feedback
A set that contains MEPBuildingConstructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPBuildingConstructionSet : APIObject,
    IEnumerable
Visual Basic
Public Class MEPBuildingConstructionSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class MEPBuildingConstructionSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSet

See Also

MEPBuildingConstructionSet Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Members

[image] [image]

Revit 2013 API
MEPBuildingConstructionSet Members
MEPBuildingConstructionSet Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Constructors

 | Name | Description
Public method | MEPBuildingConstructionSet | Initializes a new instance of the MEPBuildingConstructionSet class

Methods

 | Name | Description
Public method | Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Public method | Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified MEPBuildingConstruction from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified MEPBuildingConstruction into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Constructor

[image]

Revit 2013 API
MEPBuildingConstructionSet Constructor
MEPBuildingConstructionSet Class See Also Send Feedback
Initializes a new instance of the MEPBuildingConstructionSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstructionSet()
Visual Basic
Public Sub New
Visual C++
public:
MEPBuildingConstructionSet()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Methods

[image] [image]

Revit 2013 API
MEPBuildingConstructionSet Methods
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every MEPBuildingConstruction from the set, rendering it empty.
Public method | Contains | Tests for the existence of a MEPBuildingConstruction within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified MEPBuildingConstruction from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified MEPBuildingConstruction into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..Clear Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes every MEPBuildingConstruction from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..Contains Method
MEPBuildingConstructionSet Class See Also Send Feedback
Tests for the existence of a MEPBuildingConstruction within the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    MEPBuildingConstruction item
)
Visual Basic
Public Overridable Function Contains ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Contains(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The MEPBuildingConstruction to be searched for.

Return Value

The Contains method returns True if the MEPBuildingConstruction is within the set, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..Erase Method
MEPBuildingConstructionSet Class See Also Send Feedback
Removes a specified MEPBuildingConstruction from the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    MEPBuildingConstruction item
)
Visual Basic
Public Overridable Function Erase ( _
    item As MEPBuildingConstruction _
) As Integer
Visual C++
public:
virtual int Erase(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The MEPBuildingConstruction to be erased.

Return Value

The number of MEPBuildingConstructions that were erased from the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..ForwardIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..GetEnumerator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..Insert Method
MEPBuildingConstructionSet Class See Also Send Feedback
Insert the specified MEPBuildingConstruction into the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    MEPBuildingConstruction item
)
Visual Basic
Public Overridable Function Insert ( _
    item As MEPBuildingConstruction _
) As Boolean
Visual C++
public:
virtual bool Insert(
    MEPBuildingConstruction^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The MEPBuildingConstruction to be inserted into the set.

Return Value

Returns whether the MEPBuildingConstruction was inserted into the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..ReverseIterator Method
MEPBuildingConstructionSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual MEPBuildingConstructionSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As MEPBuildingConstructionSetIterator
Visual C++
public:
virtual MEPBuildingConstructionSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSet Properties

[image] [image]

Revit 2013 API
MEPBuildingConstructionSet Properties
MEPBuildingConstructionSet Class See Also Send Feedback

The MEPBuildingConstructionSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of MEPBuildingConstructions that are in the set.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..IsEmpty Property
MEPBuildingConstructionSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2013 API
MEPBuildingConstructionSet..::..Size Property
MEPBuildingConstructionSet Class See Also Send Feedback
Returns the number of MEPBuildingConstructions that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

MEPBuildingConstructionSet Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Class

[image]

Revit 2013 API
MEPBuildingConstructionSetIterator Class
Members See Also Send Feedback
An iterator to a MEPBuildingConstruction set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class MEPBuildingConstructionSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class MEPBuildingConstructionSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class MEPBuildingConstructionSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstructionSetIterator

See Also

MEPBuildingConstructionSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Members

[image] [image]

Revit 2013 API
MEPBuildingConstructionSetIterator Members
MEPBuildingConstructionSetIterator Class Constructors Methods Properties See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | MEPBuildingConstructionSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Constructor

[image]

Revit 2013 API
MEPBuildingConstructionSetIterator Constructor
MEPBuildingConstructionSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstructionSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
MEPBuildingConstructionSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Methods

[image] [image]

Revit 2013 API
MEPBuildingConstructionSetIterator Methods
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
MEPBuildingConstructionSetIterator..::..MoveNext Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
MEPBuildingConstructionSetIterator..::..Reset Method
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPBuildingConstructionSetIterator Properties

[image] [image]

Revit 2013 API
MEPBuildingConstructionSetIterator Properties
MEPBuildingConstructionSetIterator Class See Also Send Feedback

The MEPBuildingConstructionSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
MEPBuildingConstructionSetIterator..::..Current Property
MEPBuildingConstructionSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

MEPBuildingConstructionSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSection Class

[image]

Revit 2013 API
MEPSection Class
Members See Also Send Feedback
A section in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class MEPSection : IDisposable
Visual Basic
Public Class MEPSection _
    Implements IDisposable
Visual C++
public ref class MEPSection : IDisposable

Remarks

This is the base class for duct and pipe section. This class is mainly for pressure loss calculation. It is a series of connected elements (segments - ducts or pipes, fittings, terminals and accessories). All section members should have same flow analysis properties: Flow, Size, Velocity, Friction and Roughness. One section member element which contains more than one connector can belongs to multiple section. e.g.: One Tee which has 3 connectors, usually, it belongs 3 sections. One segment which connect to a tap will be divided into 2 sections.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..MEPSection

See Also

MEPSection Members
Autodesk.Revit.DB.Mechanical Namespace


MEPSection Members

[image] [image]

Revit 2013 API
MEPSection Members
MEPSection Class Methods Properties See Also Send Feedback

The MEPSection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the MEPSection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCoefficient | Gets the loss coefficient for the specified element id in this section.
Public method | GetElementIds | Gets all element ids that are contained in the section.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPressureDrop | Gets the pressure drop for the specified element id in this section.
Public method | GetSegmentLength | Get the length for the specified segment id in this section.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMain | Check whether the type of fitting in this section is main.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | FixtureUnit | The fixture unit of the section.
Public property | Flow | The flow of the section.
Public property | Friction | The friction of the section.
Public property | FrictionFactor | The friction factor of the section.
Public property | Number | The Section number.
Public property | ReynoldsNumber | The Reynolds number of the section.
Public property | Roughness | The roughness of the section.
Public property | TotalCoefficient | The loss coefficient of the section.
Public property | TotalCurveLength | The total length of all segments in the section.
Public property | TotalPressureLoss | The total pressure loss of the section.
Public property | Velocity | The velocity of the section.
Public property | VelocityPressure | The velocity pressure of the section.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSection Methods

[image] [image]

Revit 2013 API
MEPSection Methods
MEPSection Class See Also Send Feedback

The MEPSection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCoefficient | Gets the loss coefficient for the specified element id in this section.
Public method | GetElementIds | Gets all element ids that are contained in the section.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPressureDrop | Gets the pressure drop for the specified element id in this section.
Public method | GetSegmentLength | Get the length for the specified segment id in this section.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMain | Check whether the type of fitting in this section is main.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Dispose Method

[image]

Revit 2013 API
MEPSection..::..Dispose Method
MEPSection Class See Also Send Feedback
Releases all resources used by the MEPSection

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


GetCoefficient Method

[image]

Revit 2013 API
MEPSection..::..GetCoefficient Method
MEPSection Class See Also Send Feedback
Gets the loss coefficient for the specified element id in this section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetCoefficient(
    ElementId elemId
)
Visual Basic
Public Function GetCoefficient ( _
    elemId As ElementId _
) As Double
Visual C++
public:
double GetCoefficient(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The element id which can be duct segment, duct fitting , pipe segment and pipe fitting.

Remarks

For Duct, it is loss coefficient. For Pipe, the loss coefficient is equivalent to the friction factor. Loss coefficient is a number. The unit type is UT_Number.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId elemId does not correspond to a valid section member.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


GetElementIds Method

[image]

Revit 2013 API
MEPSection..::..GetElementIds Method
MEPSection Class See Also Send Feedback
Gets all element ids that are contained in the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetElementIds()
Visual Basic
Public Function GetElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetElementIds()

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


GetPressureDrop Method

[image]

Revit 2013 API
MEPSection..::..GetPressureDrop Method
MEPSection Class See Also Send Feedback
Gets the pressure drop for the specified element id in this section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetPressureDrop(
    ElementId elemId
)
Visual Basic
Public Function GetPressureDrop ( _
    elemId As ElementId _
) As Double
Visual C++
public:
double GetPressureDrop(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The element id which can be duct segment, duct fitting , pipe segment and pipe fitting.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId elemId does not correspond to a valid section member.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


GetSegmentLength Method

[image]

Revit 2013 API
MEPSection..::..GetSegmentLength Method
MEPSection Class See Also Send Feedback
Get the length for the specified segment id in this section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetSegmentLength(
    ElementId segmentId
)
Visual Basic
Public Function GetSegmentLength ( _
    segmentId As ElementId _
) As Double
Visual C++
public:
double GetSegmentLength(
    ElementId^ segmentId
)

Parameters

segmentId
Type: Autodesk.Revit.DB..::..ElementId
The element id which can be duct segment and pipe segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId segmentId does not correspond to a valid section segment member.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


IsMain Method

[image]

Revit 2013 API
MEPSection..::..IsMain Method
MEPSection Class See Also Send Feedback
Check whether the type of fitting in this section is main.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsMain(
    ElementId fittingId
)
Visual Basic
Public Function IsMain ( _
    fittingId As ElementId _
) As Boolean
Visual C++
public:
bool IsMain(
    ElementId^ fittingId
)

Parameters

fittingId
Type: Autodesk.Revit.DB..::..ElementId
The element id which can be duct fitting and pipe fitting.

Return Value

True if the type of fitting in this section is main False if the type of fitting in this section is branch

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId fittingId does not correspond to a valid section fitting member.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSection Properties

[image] [image]

Revit 2013 API
MEPSection Properties
MEPSection Class See Also Send Feedback

The MEPSection type exposes the following members.

Properties

 | Name | Description
Public property | FixtureUnit | The fixture unit of the section.
Public property | Flow | The flow of the section.
Public property | Friction | The friction of the section.
Public property | FrictionFactor | The friction factor of the section.
Public property | Number | The Section number.
Public property | ReynoldsNumber | The Reynolds number of the section.
Public property | Roughness | The roughness of the section.
Public property | TotalCoefficient | The loss coefficient of the section.
Public property | TotalCurveLength | The total length of all segments in the section.
Public property | TotalPressureLoss | The total pressure loss of the section.
Public property | Velocity | The velocity of the section.
Public property | VelocityPressure | The velocity pressure of the section.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


FixtureUnit Property

[image]

Revit 2013 API
MEPSection..::..FixtureUnit Property
MEPSection Class See Also Send Feedback
The fixture unit of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double FixtureUnit { get; }
Visual Basic
Public ReadOnly Property FixtureUnit As Double
    Get
Visual C++
public:
property double FixtureUnit {
    double get ();
}

Remarks

In one section, all section members have same fixture unit. Fixture Unit is a number. The unit type is UT_Number.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Flow Property

[image]

Revit 2013 API
MEPSection..::..Flow Property
MEPSection Class See Also Send Feedback
The flow of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Flow { get; }
Visual Basic
Public ReadOnly Property Flow As Double
    Get
Visual C++
public:
property double Flow {
    double get ();
}

Remarks

In one section, all section members have same flow. Default unit is Cubic feet per second. For Duct, unit type is UT_HVAC_Airflow. For Pipe, unit type is UT_Piping_Flow

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Friction Property

[image]

Revit 2013 API
MEPSection..::..Friction Property
MEPSection Class See Also Send Feedback
The friction of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Friction { get; }
Visual Basic
Public ReadOnly Property Friction As Double
    Get
Visual C++
public:
property double Friction {
    double get ();
}

Remarks

In one section, all section members have same flow. Default unit is Feet of Water (60 °F) per 100 feet. For Duct, unit type is UT_HVAC_Friction. For Pipe, unit type is UT_Piping_Friction

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


FrictionFactor Property

[image]

Revit 2013 API
MEPSection..::..FrictionFactor Property
MEPSection Class See Also Send Feedback
The friction factor of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double FrictionFactor { get; }
Visual Basic
Public ReadOnly Property FrictionFactor As Double
    Get
Visual C++
public:
property double FrictionFactor {
    double get ();
}

Remarks

Friction Factor is a number. The friction factor type is UT_Number.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Number Property

[image]

Revit 2013 API
MEPSection..::..Number Property
MEPSection Class See Also Send Feedback
The Section number.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Number { get; }
Visual Basic
Public ReadOnly Property Number As Integer
    Get
Visual C++
public:
property int Number {
    int get ();
}

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


ReynoldsNumber Property

[image]

Revit 2013 API
MEPSection..::..ReynoldsNumber Property
MEPSection Class See Also Send Feedback
The Reynolds number of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ReynoldsNumber { get; }
Visual Basic
Public ReadOnly Property ReynoldsNumber As Double
    Get
Visual C++
public:
property double ReynoldsNumber {
    double get ();
}

Remarks

Reynolds number is a number. The Reynolds number type is UT_Number.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Roughness Property

[image]

Revit 2013 API
MEPSection..::..Roughness Property
MEPSection Class See Also Send Feedback
The roughness of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Roughness { get; }
Visual Basic
Public ReadOnly Property Roughness As Double
    Get
Visual C++
public:
property double Roughness {
    double get ();
}

Remarks

In one section, all section members have same roughness. Default unit is Decimal feet. For Duct, unit type is UT_HVAC_Roughness. For Pipe, unit type is UT_Piping_Roughness

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


TotalCoefficient Property

[image]

Revit 2013 API
MEPSection..::..TotalCoefficient Property
MEPSection Class See Also Send Feedback
The loss coefficient of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalCoefficient { get; }
Visual Basic
Public ReadOnly Property TotalCoefficient As Double
    Get
Visual C++
public:
property double TotalCoefficient {
    double get ();
}

Remarks

It's total of all fittings and segments. Coefficient is a number. The unit type is UT_Number.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


TotalCurveLength Property

[image]

Revit 2013 API
MEPSection..::..TotalCurveLength Property
MEPSection Class See Also Send Feedback
The total length of all segments in the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalCurveLength { get; }
Visual Basic
Public ReadOnly Property TotalCurveLength As Double
    Get
Visual C++
public:
property double TotalCurveLength {
    double get ();
}

Remarks

Default unit is Decimal feet. The unit type is UT_Length.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


TotalPressureLoss Property

[image]

Revit 2013 API
MEPSection..::..TotalPressureLoss Property
MEPSection Class See Also Send Feedback
The total pressure loss of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalPressureLoss { get; }
Visual Basic
Public ReadOnly Property TotalPressureLoss As Double
    Get
Visual C++
public:
property double TotalPressureLoss {
    double get ();
}

Remarks

It's total of all fittings and segments. Default unit is Kgf per square feet. For Duct, unit type is UT_HVAC_Pressure. For Pipe, unit type is UT_Piping_Pressure.

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


Velocity Property

[image]

Revit 2013 API
MEPSection..::..Velocity Property
MEPSection Class See Also Send Feedback
The velocity of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Velocity { get; }
Visual Basic
Public ReadOnly Property Velocity As Double
    Get
Visual C++
public:
property double Velocity {
    double get ();
}

Remarks

In one section, all section members have same flow. Default unit is Feet per second. For Duct, unit type is UT_HVAC_Velocity. For Pipe, unit type is UT_Piping_Velocity

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


VelocityPressure Property

[image]

Revit 2013 API
MEPSection..::..VelocityPressure Property
MEPSection Class See Also Send Feedback
The velocity pressure of the section.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double VelocityPressure { get; }
Visual Basic
Public ReadOnly Property VelocityPressure As Double
    Get
Visual C++
public:
property double VelocityPressure {
    double get ();
}

Remarks

Default unit is Kgf per square feet. For Duct, unit type is UT_HVAC_Pressure. For Pipe, unit type is UT_Piping_Pressure

See Also

MEPSection Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Class

[image]

Revit 2013 API
MEPSpaceConstruction Class
Members See Also Send Feedback
Construction definition for Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class MEPSpaceConstruction
Visual Basic
Public Class MEPSpaceConstruction
Visual C++
public ref class MEPSpaceConstruction

Remarks

This is used to define the information in Constructions.xml.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Mechanical..::..MEPSpaceConstruction

See Also

MEPSpaceConstruction Members
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Members

[image] [image]

Revit 2013 API
MEPSpaceConstruction Members
MEPSpaceConstruction Class Methods Properties See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Methods

 | Name | Description
Public method | DeleteConstruction | Remove an existing construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Methods

[image] [image]

Revit 2013 API
MEPSpaceConstruction Methods
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Methods

 | Name | Description
Public method | DeleteConstruction | Remove an existing construction from Space constructions.
Public method | DuplicateConstruction | Create a new construction for Space constructions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | NewConstruction | Create a new construction for Space constructions.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


DeleteConstruction Method

[image]

Revit 2013 API
MEPSpaceConstruction..::..DeleteConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Remove an existing construction from Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void DeleteConstruction(
    MEPBuildingConstruction pCurrentConstruction
)
Visual Basic
Public Sub DeleteConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction _
)
Visual C++
public:
void DeleteConstruction(
    MEPBuildingConstruction^ pCurrentConstruction
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The Construction will be deleted.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


DuplicateConstruction Method

[image]

Revit 2013 API
MEPSpaceConstruction..::..DuplicateConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstruction DuplicateConstruction(
    MEPBuildingConstruction pCurrentConstruction,
    string pName
)
Visual Basic
Public Function DuplicateConstruction ( _
    pCurrentConstruction As MEPBuildingConstruction, _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ DuplicateConstruction(
    MEPBuildingConstruction^ pCurrentConstruction,
    String^ pName
)

Parameters

pCurrentConstruction
Type: Autodesk.Revit.DB.Mechanical..::..MEPBuildingConstruction
The existing construction to be duplicated.
pName
Type: System..::..String
The name of the new construction.

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


NewConstruction Method

[image]

Revit 2013 API
MEPSpaceConstruction..::..NewConstruction Method
MEPSpaceConstruction Class See Also Send Feedback
Create a new construction for Space constructions.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstruction NewConstruction(
    string pName
)
Visual Basic
Public Function NewConstruction ( _
    pName As String _
) As MEPBuildingConstruction
Visual C++
public:
MEPBuildingConstruction^ NewConstruction(
    String^ pName
)

Parameters

pName
Type: System..::..String
The name of the new Construction.

Remarks

If the name is same as an existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


MEPSpaceConstruction Properties

[image] [image]

Revit 2013 API
MEPSpaceConstruction Properties
MEPSpaceConstruction Class See Also Send Feedback

The MEPSpaceConstruction type exposes the following members.

Properties

 | Name | Description
Public property | CurrentConstruction | Get all the Building Constructions according to the specific Construction type.
Public property | SpaceConstructions | Return all the Space constructions of current space.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


CurrentConstruction Property

[image]

Revit 2013 API
MEPSpaceConstruction..::..CurrentConstruction Property
MEPSpaceConstruction Class See Also Send Feedback
Get all the Building Constructions according to the specific Construction type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstruction CurrentConstruction { get; set; }
Visual Basic
Public Property CurrentConstruction As MEPBuildingConstruction
    Get
    Set
Visual C++
public:
property MEPBuildingConstruction^ CurrentConstruction {
    MEPBuildingConstruction^ get ();
    void set (MEPBuildingConstruction^ value);
}

Remarks

This property is used to get or set the Building Service of the Project Information.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceConstructions Property

[image]

Revit 2013 API
MEPSpaceConstruction..::..SpaceConstructions Property
MEPSpaceConstruction Class See Also Send Feedback
Return all the Space constructions of current space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPBuildingConstructionSet SpaceConstructions { get; }
Visual Basic
Public ReadOnly Property SpaceConstructions As MEPBuildingConstructionSet
    Get
Visual C++
public:
property MEPBuildingConstructionSet^ SpaceConstructions {
    MEPBuildingConstructionSet^ get ();
}

Remarks

If the name is same with the existing one, an exception will be thrown.

See Also

MEPSpaceConstruction Class
Autodesk.Revit.DB.Mechanical Namespace


OccupancyUnit Enumeration

[image]

Revit 2013 API
OccupancyUnit Enumeration
See Also Send Feedback
An enumerated type listing the occupancy unit of measure for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum OccupancyUnit
Visual Basic
Public Enumeration OccupancyUnit
Visual C++
public enum class OccupancyUnit

Members

Member name | Description
UseDefaultValues | OccupancyUnit is UseDefaultValues.
NumberOfPeople | OccupancyUnit is NumberOfPeople.
AreaPerPerson | OccupancyUnit is AreaPerPerson.

See Also

Autodesk.Revit.DB.Mechanical Namespace


ReturnAirflowType Enumeration

[image]

Revit 2013 API
ReturnAirflowType Enumeration
See Also Send Feedback
An enumerated type listing all the possible return airflow types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ReturnAirflowType
Visual Basic
Public Enumeration ReturnAirflowType
Visual C++
public enum class ReturnAirflowType

Members

Member name | Description
Specified | Return Airflow Type is Specified.
SpecifiedSupplyAirflow | Return Airflow Type is SpecifiedSupplyAirflow.
CalculatedSupplyAirflow | Return Airflow Type is CalculatedSupplyAirflow.
ActualSupplyAirflow | Return Airflow Type is ActualSupplyAirflow.

See Also

Autodesk.Revit.DB.Mechanical Namespace


RiseDropSymbol Enumeration

[image]

Revit 2013 API
RiseDropSymbol Enumeration
See Also Send Feedback
This enumeration corresponds to the rise/drop symbol used in mechanical systems

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum RiseDropSymbol
Visual Basic
Public Enumeration RiseDropSymbol
Visual C++
public enum class RiseDropSymbol

Members

Member name | Description
NoSymbol | No rise/drop graphics will be used
Outline | Outline only no internal geometry
Cross | Duct supply rise/drop with X pattern
CrossFilled | Duct supply rise/drop with X pattern and top and bottom of X is filled
Slash | Duct return rise/drop with / pattern
SlashFilled | Duct return rise/drop with / pattern and lower right / is filled
Backslash | Duct return rise/drop with \ pattern
BackslashFilled | Duct return rise/drop with \ pattern and lower left \ is filled
Wye | Duct exhaust rise/drop with \/ pattern
ReverseWye | Duct exhaust rise/drop with /\ pattern
OutlineFilled | Outline only no internal geometry and filled to be solid
YinYang | Pipe contour rise/drop and 2 half circles (yin-yang)
YinYangFilled | Pipe contour rise/drop and 2 half circles (yin-yang) left side is filled
BendThreeQuarterCircle | Pipe 1 Line bend 3/4 circle
BendFullCircle | Pipe 1 Line bend full circle
TeeHalfCircle | Pipe 1 Line junction 1/2 circle on each side
TeeFullCircle | Pipe 1 Line junction full circle
CrossNoOutline | Cable Tray 1 Line a cross without outline

See Also

Autodesk.Revit.DB.Mechanical Namespace


Space Class

[image]

Revit 2013 API
Space Class
Members See Also Send Feedback
Provides access to the space topology in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Space : SpatialElement
Visual Basic
Public Class Space _
    Inherits SpatialElement
Visual C++
public ref class Space : public SpatialElement

Remarks

The space object can be queried for its boundary for use in space planning tools.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElement
Autodesk.Revit.DB.Mechanical..::..Space

See Also

Space Members
Autodesk.Revit.DB.Mechanical Namespace


Space Members

[image] [image]

Revit 2013 API
Space Members
Space Class Methods Properties See Also Send Feedback

The Space type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsPointInSpace | Determines if a point lies within the volume of the Space.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseHeatLoadOn | The heat load-on.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)
Public property | Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Space Methods

[image] [image]

Revit 2013 API
Space Methods
Space Class See Also Send Feedback

The Space type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBoundarySegments | Returns the boundary segments. (Inherited from SpatialElement.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsPointInSpace | Determines if a point lies within the volume of the Space.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


IsPointInSpace Method

[image]

Revit 2013 API
Space..::..IsPointInSpace Method
Space Class See Also Send Feedback
Determines if a point lies within the volume of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPointInSpace(
    XYZ point
)
Visual Basic
Public Function IsPointInSpace ( _
    point As XYZ _
) As Boolean
Visual C++
public:
bool IsPointInSpace(
    XYZ^ point
)

Parameters

point
Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates of the point is not a number.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Space Properties

[image] [image]

Revit 2013 API
Space Properties
Space Class See Also Send Feedback

The Space type exposes the following members.

Properties

 | Name | Description
Public property | ActualExhaustAirflow | Get the Actual Exhaust Airflow of the Space.
Public property | ActualHVACLoad | Get or set the Actual HVAC Load of the Space.
Public property | ActualLightingLoad | Get the Actual Lighting Load of the Space.
Public property | ActualOtherLoad | Get or set the Actual Other Load of the Space.
Public property | ActualPowerLoad | Get the Actual Power Load of the Space.
Public property | ActualReturnAirflow | Get or set the Actual Return Airflow of the Space.
Public property | ActualSupplyAirflow | Get or set the Actual Supply Airflow of the Space.
Public property | Area | The area. (Inherited from SpatialElement.)
Public property | AreaperPerson | Get the Area per Person of the Space.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | AverageEstimatedIllumination | Get the Average Estimated Illumination of the Space.
Public property | BaseHeatLoadOn | The heat load-on.
Public property | BaseOffset | Get or Set the Base Offset of the Space.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Space.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Space.
Public property | CalculatedSupplyAirflow | Get or set the Calculated Supply Airflow of the Space.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CeilingReflectance | Get or set the Ceiling Reflectance of the Space.
Public property | ClosedShell | Return the closedShell of the space.
Public property | ConditionType | Get or set the Condition type of the Space.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignCoolingLoad | Get the Design Cooling Load of the Space.
Public property | DesignExhaustAirflow | Get or set the Specified Exhaust Airflow of the Space.
Public property | DesignHeatingLoad | Get the Design Heating Load of the Space.
Public property | DesignHVACLoadperArea | Get or set the Design HVAC Load per Area of the Space.
Public property | DesignLightingLoad | Get or set the Design Lighting Load of the Space.
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DesignOtherLoadperArea | Get or set the Design Other Load per Area of the Space.
Public property | DesignPowerLoad | Get or set the Design Power Load of the Space.
Public property | DesignReturnAirflow | Get or set the Specified Return Airflow of the Space.
Public property | DesignSupplyAirflow | Get or set the Specified Supply Airflow of the Space.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FloorReflectance | Get or set the Floor Reflectance of the Space.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LatentHeatGainperPerson | Get or set the Latent Heat Gain per Person of the Space.
Public property | Level | Gets the level of the room. (Inherited from SpatialElement.)
Public property | LightingCalculationWorkplane | Get the Lighting Calculation Workplane of the Space.
Public property | LightingLoadUnit | Get or Set the Lighting Load Unit of the Space.
Public property | LimitOffset | Get or Set the Limit Offset of the Space.
Public property | Location | The location of the element. (Inherited from SpatialElement.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from SpatialElement.)
Public property | Number | The number. (Inherited from SpatialElement.)
Public property | NumberofPeople | Get the Number of People of the Space.
Public property | OccupancyUnit | Get the Occupancy Unit of the Space.
Public property | Occupiable | Reports whether this zone is Occupiable or not.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | The perimeter. (Inherited from SpatialElement.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Plenum | Reports whether this zone is Plenum or not.
Public property | PowerLoadUnit | Get or Set the Power Load Unit of the Space.
Public property | ReturnAirflow | Get or set the Return type of Supply Airflow of the Space.
Public property | Room | Return the Room of the space.
Public property | SensibleHeatGainperPerson | Get the Sensible Heat Gain per Person of the Space.
Public property | SpaceCavityRatio | Get the Space Cavity Ratio of the Space.
Public property | SpaceConstruction | Get the Space Construction of the Space.
Public property | SpaceType | Get or set the Space type of the Space.
Public property | UnboundedHeight | Get the Unbounded Height of the Space.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UpperLimit | Get or Set the Upper Limit of the Space.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Space.
Public property | WallReflectance | Get or set the Wall Reflectance of the Space.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)
Public property | Zone | Reports this space belong to which Zone.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualExhaustAirflow Property

[image]

Revit 2013 API
Space..::..ActualExhaustAirflow Property
Space Class See Also Send Feedback
Get the Actual Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualExhaustAirflow { get; }
Visual Basic
Public ReadOnly Property ActualExhaustAirflow As Double
    Get
Visual C++
public:
property double ActualExhaustAirflow {
    double get ();
}

Remarks

This property is used to get the Actual Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualHVACLoad Property

[image]

Revit 2013 API
Space..::..ActualHVACLoad Property
Space Class See Also Send Feedback
Get or set the Actual HVAC Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualHVACLoad { get; }
Visual Basic
Public ReadOnly Property ActualHVACLoad As Double
    Get
Visual C++
public:
property double ActualHVACLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual HVAC Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualLightingLoad Property

[image]

Revit 2013 API
Space..::..ActualLightingLoad Property
Space Class See Also Send Feedback
Get the Actual Lighting Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualLightingLoad { get; }
Visual Basic
Public ReadOnly Property ActualLightingLoad As Double
    Get
Visual C++
public:
property double ActualLightingLoad {
    double get ();
}

Remarks

This property is used to get the Actual Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualOtherLoad Property

[image]

Revit 2013 API
Space..::..ActualOtherLoad Property
Space Class See Also Send Feedback
Get or set the Actual Other Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualOtherLoad { get; }
Visual Basic
Public ReadOnly Property ActualOtherLoad As Double
    Get
Visual C++
public:
property double ActualOtherLoad {
    double get ();
}

Remarks

This property is used to get or set the Actual Other Load (Unit: W) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualPowerLoad Property

[image]

Revit 2013 API
Space..::..ActualPowerLoad Property
Space Class See Also Send Feedback
Get the Actual Power Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualPowerLoad { get; }
Visual Basic
Public ReadOnly Property ActualPowerLoad As Double
    Get
Visual C++
public:
property double ActualPowerLoad {
    double get ();
}

Remarks

This property is used to get the Actual Power Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualReturnAirflow Property

[image]

Revit 2013 API
Space..::..ActualReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Return Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualReturnAirflow { get; }
Visual Basic
Public ReadOnly Property ActualReturnAirflow As Double
    Get
Visual C++
public:
property double ActualReturnAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ActualSupplyAirflow Property

[image]

Revit 2013 API
Space..::..ActualSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Actual Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double ActualSupplyAirflow { get; }
Visual Basic
Public ReadOnly Property ActualSupplyAirflow As Double
    Get
Visual C++
public:
property double ActualSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Actual Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


AreaperPerson Property

[image]

Revit 2013 API
Space..::..AreaperPerson Property
Space Class See Also Send Feedback
Get the Area per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AreaperPerson { get; set; }
Visual Basic
Public Property AreaperPerson As Double
    Get
    Set
Visual C++
public:
property double AreaperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Area per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


AverageEstimatedIllumination Property

[image]

Revit 2013 API
Space..::..AverageEstimatedIllumination Property
Space Class See Also Send Feedback
Get the Average Estimated Illumination of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double AverageEstimatedIllumination { get; }
Visual Basic
Public ReadOnly Property AverageEstimatedIllumination As Double
    Get
Visual C++
public:
property double AverageEstimatedIllumination {
    double get ();
}

Remarks

This property is used to get the Average Estimated Illumination of the Space. (Unit: fc)

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


BaseHeatLoadOn Property

[image]

Revit 2013 API
Space..::..BaseHeatLoadOn Property
Space Class See Also Send Feedback
The heat load-on.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BaseLoadOn BaseHeatLoadOn { get; set; }
Visual Basic
Public Property BaseHeatLoadOn As BaseLoadOn
    Get
    Set
Visual C++
public:
property BaseLoadOn BaseHeatLoadOn {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the values is not kUseDefaultLoad or kUseEnteredLoad.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


BaseOffset Property

[image]

Revit 2013 API
Space..::..BaseOffset Property
Space Class See Also Send Feedback
Get or Set the Base Offset of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BaseOffset { get; set; }
Visual Basic
Public Property BaseOffset As Double
    Get
    Set
Visual C++
public:
property double BaseOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Base Offset of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedCoolingLoad Property

[image]

Revit 2013 API
Space..::..CalculatedCoolingLoad Property
Space Class See Also Send Feedback
Get the Calculated Cooling Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic
Public ReadOnly Property CalculatedCoolingLoad As Double
    Get
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedHeatingLoad Property

[image]

Revit 2013 API
Space..::..CalculatedHeatingLoad Property
Space Class See Also Send Feedback
Get the Calculated Heating Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic
Public ReadOnly Property CalculatedHeatingLoad As Double
    Get
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2013 API
Space..::..CalculatedSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Calculated Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic
Public ReadOnly Property CalculatedSupplyAirflow As Double
    Get
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get or set the Calculated Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


CeilingReflectance Property

[image]

Revit 2013 API
Space..::..CeilingReflectance Property
Space Class See Also Send Feedback
Get or set the Ceiling Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CeilingReflectance { get; set; }
Visual Basic
Public Property CeilingReflectance As Double
    Get
    Set
Visual C++
public:
property double CeilingReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Ceiling Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ClosedShell Property

[image]

Revit 2013 API
Space..::..ClosedShell Property
Space Class See Also Send Feedback
Return the closedShell of the space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public GeometryElement ClosedShell { get; }
Visual Basic
Public ReadOnly Property ClosedShell As GeometryElement
    Get
Visual C++
public:
property GeometryElement^ ClosedShell {
    GeometryElement^ get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ConditionType Property

[image]

Revit 2013 API
Space..::..ConditionType Property
Space Class See Also Send Feedback
Get or set the Condition type of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ConditionType ConditionType { get; set; }
Visual Basic
Public Property ConditionType As ConditionType
    Get
    Set
Visual C++
public:
property ConditionType ConditionType {
    ConditionType get ();
    void set (ConditionType value);
}

Remarks

This property is used to get or set the Condition type of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignCoolingLoad Property

[image]

Revit 2013 API
Space..::..DesignCoolingLoad Property
Space Class See Also Send Feedback
Get the Design Cooling Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignCoolingLoad { get; set; }
Visual Basic
Public Property DesignCoolingLoad As Double
    Get
    Set
Visual C++
public:
property double DesignCoolingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Cooling Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignExhaustAirflow Property

[image]

Revit 2013 API
Space..::..DesignExhaustAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Exhaust Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignExhaustAirflow { get; set; }
Visual Basic
Public Property DesignExhaustAirflow As Double
    Get
    Set
Visual C++
public:
property double DesignExhaustAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Exhaust Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignHeatingLoad Property

[image]

Revit 2013 API
Space..::..DesignHeatingLoad Property
Space Class See Also Send Feedback
Get the Design Heating Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignHeatingLoad { get; set; }
Visual Basic
Public Property DesignHeatingLoad As Double
    Get
    Set
Visual C++
public:
property double DesignHeatingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Design Heating Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignHVACLoadperArea Property

[image]

Revit 2013 API
Space..::..DesignHVACLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design HVAC Load per Area of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignHVACLoadperArea { get; set; }
Visual Basic
Public Property DesignHVACLoadperArea As Double
    Get
    Set
Visual C++
public:
property double DesignHVACLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design HVAC Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignLightingLoad Property

[image]

Revit 2013 API
Space..::..DesignLightingLoad Property
Space Class See Also Send Feedback
Get or set the Design Lighting Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignLightingLoad { get; set; }
Visual Basic
Public Property DesignLightingLoad As Double
    Get
    Set
Visual C++
public:
property double DesignLightingLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Lighting Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignOtherLoadperArea Property

[image]

Revit 2013 API
Space..::..DesignOtherLoadperArea Property
Space Class See Also Send Feedback
Get or set the Design Other Load per Area of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignOtherLoadperArea { get; set; }
Visual Basic
Public Property DesignOtherLoadperArea As Double
    Get
    Set
Visual C++
public:
property double DesignOtherLoadperArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Other Load per Area (Unit: W/ft2) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignPowerLoad Property

[image]

Revit 2013 API
Space..::..DesignPowerLoad Property
Space Class See Also Send Feedback
Get or set the Design Power Load of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignPowerLoad { get; set; }
Visual Basic
Public Property DesignPowerLoad As Double
    Get
    Set
Visual C++
public:
property double DesignPowerLoad {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Design Power Load of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignReturnAirflow Property

[image]

Revit 2013 API
Space..::..DesignReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Return Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignReturnAirflow { get; set; }
Visual Basic
Public Property DesignReturnAirflow As Double
    Get
    Set
Visual C++
public:
property double DesignReturnAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Return Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


DesignSupplyAirflow Property

[image]

Revit 2013 API
Space..::..DesignSupplyAirflow Property
Space Class See Also Send Feedback
Get or set the Specified Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DesignSupplyAirflow { get; set; }
Visual Basic
Public Property DesignSupplyAirflow As Double
    Get
    Set
Visual C++
public:
property double DesignSupplyAirflow {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Specified Supply Airflow (Unit: CFM) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


FloorReflectance Property

[image]

Revit 2013 API
Space..::..FloorReflectance Property
Space Class See Also Send Feedback
Get or set the Floor Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double FloorReflectance { get; set; }
Visual Basic
Public Property FloorReflectance As Double
    Get
    Set
Visual C++
public:
property double FloorReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Floor Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LatentHeatGainperPerson Property

[image]

Revit 2013 API
Space..::..LatentHeatGainperPerson Property
Space Class See Also Send Feedback
Get or set the Latent Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LatentHeatGainperPerson { get; set; }
Visual Basic
Public Property LatentHeatGainperPerson As Double
    Get
    Set
Visual C++
public:
property double LatentHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Latent Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LightingCalculationWorkplane Property

[image]

Revit 2013 API
Space..::..LightingCalculationWorkplane Property
Space Class See Also Send Feedback
Get the Lighting Calculation Workplane of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LightingCalculationWorkplane { get; set; }
Visual Basic
Public Property LightingCalculationWorkplane As Double
    Get
    Set
Visual C++
public:
property double LightingCalculationWorkplane {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Lighting Calculation Workplane (Unit: feet) of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LightingLoadUnit Property

[image]

Revit 2013 API
Space..::..LightingLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Lighting Load Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BaseLoadOn LightingLoadUnit { get; set; }
Visual Basic
Public Property LightingLoadUnit As BaseLoadOn
    Get
    Set
Visual C++
public:
property BaseLoadOn LightingLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Lighting Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


LimitOffset Property

[image]

Revit 2013 API
Space..::..LimitOffset Property
Space Class See Also Send Feedback
Get or Set the Limit Offset of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double LimitOffset { get; set; }
Visual Basic
Public Property LimitOffset As Double
    Get
    Set
Visual C++
public:
property double LimitOffset {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Limit Offset of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


NumberofPeople Property

[image]

Revit 2013 API
Space..::..NumberofPeople Property
Space Class See Also Send Feedback
Get the Number of People of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double NumberofPeople { get; set; }
Visual Basic
Public Property NumberofPeople As Double
    Get
    Set
Visual C++
public:
property double NumberofPeople {
    double get ();
    void set (double value);
}

Remarks

This property is used to get Number of People of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


OccupancyUnit Property

[image]

Revit 2013 API
Space..::..OccupancyUnit Property
Space Class See Also Send Feedback
Get the Occupancy Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public OccupancyUnit OccupancyUnit { get; set; }
Visual Basic
Public Property OccupancyUnit As OccupancyUnit
    Get
    Set
Visual C++
public:
property OccupancyUnit OccupancyUnit {
    OccupancyUnit get ();
    void set (OccupancyUnit value);
}

Remarks

This property is used to get the Occupancy Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Occupiable Property

[image]

Revit 2013 API
Space..::..Occupiable Property
Space Class See Also Send Feedback
Reports whether this zone is Occupiable or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Occupiable { get; }
Visual Basic
Public ReadOnly Property Occupiable As Boolean
    Get
Visual C++
public:
property bool Occupiable {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
Space..::..Parameter Property
Space Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Space Class
Space Members
Autodesk.Revit.DB.Mechanical Namespace


Plenum Property

[image]

Revit 2013 API
Space..::..Plenum Property
Space Class See Also Send Feedback
Reports whether this zone is Plenum or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Plenum { get; }
Visual Basic
Public ReadOnly Property Plenum As Boolean
    Get
Visual C++
public:
property bool Plenum {
    bool get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


PowerLoadUnit Property

[image]

Revit 2013 API
Space..::..PowerLoadUnit Property
Space Class See Also Send Feedback
Get or Set the Power Load Unit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public BaseLoadOn PowerLoadUnit { get; set; }
Visual Basic
Public Property PowerLoadUnit As BaseLoadOn
    Get
    Set
Visual C++
public:
property BaseLoadOn PowerLoadUnit {
    BaseLoadOn get ();
    void set (BaseLoadOn value);
}

Remarks

This property is used to get or set the Power Load Unit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


ReturnAirflow Property

[image]

Revit 2013 API
Space..::..ReturnAirflow Property
Space Class See Also Send Feedback
Get or set the Return type of Supply Airflow of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ReturnAirflowType ReturnAirflow { get; set; }
Visual Basic
Public Property ReturnAirflow As ReturnAirflowType
    Get
    Set
Visual C++
public:
property ReturnAirflowType ReturnAirflow {
    ReturnAirflowType get ();
    void set (ReturnAirflowType value);
}

Remarks

This property is used to get or set the Return type of Supply Airflow of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Room Property

[image]

Revit 2013 API
Space..::..Room Property
Space Class See Also Send Feedback
Return the Room of the space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Room Room { get; }
Visual Basic
Public ReadOnly Property Room As Room
    Get
Visual C++
public:
property Room^ Room {
    Room^ get ();
}

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SensibleHeatGainperPerson Property

[image]

Revit 2013 API
Space..::..SensibleHeatGainperPerson Property
Space Class See Also Send Feedback
Get the Sensible Heat Gain per Person of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SensibleHeatGainperPerson { get; set; }
Visual Basic
Public Property SensibleHeatGainperPerson As Double
    Get
    Set
Visual C++
public:
property double SensibleHeatGainperPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get the Sensible Heat Gain per Person of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceCavityRatio Property

[image]

Revit 2013 API
Space..::..SpaceCavityRatio Property
Space Class See Also Send Feedback
Get the Space Cavity Ratio of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double SpaceCavityRatio { get; }
Visual Basic
Public ReadOnly Property SpaceCavityRatio As Double
    Get
Visual C++
public:
property double SpaceCavityRatio {
    double get ();
}

Remarks

This property is used to get the Space Cavity Ratio of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceConstruction Property

[image]

Revit 2013 API
Space..::..SpaceConstruction Property
Space Class See Also Send Feedback
Get the Space Construction of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public MEPSpaceConstruction SpaceConstruction { get; }
Visual Basic
Public ReadOnly Property SpaceConstruction As MEPSpaceConstruction
    Get
Visual C++
public:
property MEPSpaceConstruction^ SpaceConstruction {
    MEPSpaceConstruction^ get ();
}

Remarks

This property is used to get the Space Construction of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceType Property

[image]

Revit 2013 API
Space..::..SpaceType Property
Space Class See Also Send Feedback
Get or set the Space type of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceType SpaceType { get; set; }
Visual Basic
Public Property SpaceType As SpaceType
    Get
    Set
Visual C++
public:
property SpaceType SpaceType {
    SpaceType get ();
    void set (SpaceType value);
}

Remarks

This property is used to get or set the Space type of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


UnboundedHeight Property

[image]

Revit 2013 API
Space..::..UnboundedHeight Property
Space Class See Also Send Feedback
Get the Unbounded Height of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double UnboundedHeight { get; }
Visual Basic
Public ReadOnly Property UnboundedHeight As Double
    Get
Visual C++
public:
property double UnboundedHeight {
    double get ();
}

Remarks

This property is used to get the Unbounded Height of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


UpperLimit Property

[image]

Revit 2013 API
Space..::..UpperLimit Property
Space Class See Also Send Feedback
Get or Set the Upper Limit of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Level UpperLimit { get; set; }
Visual Basic
Public Property UpperLimit As Level
    Get
    Set
Visual C++
public:
property Level^ UpperLimit {
    Level^ get ();
    void set (Level^ value);
}

Remarks

This property is used to get or set the Upper Limit of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Volume Property

[image]

Revit 2013 API
Space..::..Volume Property
Space Class See Also Send Feedback
Get the Volume of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


WallReflectance Property

[image]

Revit 2013 API
Space..::..WallReflectance Property
Space Class See Also Send Feedback
Get or set the Wall Reflectance of the Space.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double WallReflectance { get; set; }
Visual Basic
Public Property WallReflectance As Double
    Get
    Set
Visual C++
public:
property double WallReflectance {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Wall Reflectance of the Space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Property

[image]

Revit 2013 API
Space..::..Zone Property
Space Class See Also Send Feedback
Reports this space belong to which Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Zone Zone { get; }
Visual Basic
Public ReadOnly Property Zone As Zone
    Get
Visual C++
public:
property Zone^ Zone {
    Zone^ get ();
}

Remarks

This property is used to retrieve the host zone of this space.

See Also

Space Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Class

[image]

Revit 2013 API
SpaceFilter Class
Members See Also Send Feedback
A filter used to match spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceFilter : ElementSlowFilter
Visual Basic
Public Class SpaceFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class SpaceFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Mechanical..::..SpaceFilter

See Also

SpaceFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Members

[image] [image]

Revit 2013 API
SpaceFilter Members
SpaceFilter Class Constructors Methods Properties See Also Send Feedback

The SpaceFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceFilter | Constructs a filter which matches only spaces.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Constructor

[image]

Revit 2013 API
SpaceFilter Constructor
SpaceFilter Class See Also Send Feedback
Constructs a filter which matches only spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceFilter()
Visual Basic
Public Sub New
Visual C++
public:
SpaceFilter()

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Methods

[image] [image]

Revit 2013 API
SpaceFilter Methods
SpaceFilter Class See Also Send Feedback

The SpaceFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
SpaceFilter..::..PassesFilter Method
SpaceFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

SpaceFilter Class
SpaceFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceFilter Properties

[image] [image]

Revit 2013 API
SpaceFilter Properties
SpaceFilter Class See Also Send Feedback

The SpaceFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Class

[image]

Revit 2013 API
SpaceSet Class
Members See Also Send Feedback
A set that can contain any type of object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceSet : APIObject, IEnumerable
Visual Basic
Public Class SpaceSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..SpaceSet

See Also

SpaceSet Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Members

[image] [image]

Revit 2013 API
SpaceSet Members
SpaceSet Class Constructors Methods Properties See Also Send Feedback

The SpaceSet type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceSet | Initializes a new instance of the SpaceSet class

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Constructor

[image]

Revit 2013 API
SpaceSet Constructor
SpaceSet Class See Also Send Feedback
Initializes a new instance of the SpaceSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceSet()
Visual Basic
Public Sub New
Visual C++
public:
SpaceSet()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Methods

[image] [image]

Revit 2013 API
SpaceSet Methods
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every item from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2013 API
SpaceSet..::..Clear Method
SpaceSet Class See Also Send Feedback
Removes every item from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2013 API
SpaceSet..::..Contains Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Space item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2013 API
SpaceSet..::..Erase Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Space item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Space _
) As Integer
Visual C++
public:
virtual int Erase(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2013 API
SpaceSet..::..ForwardIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpaceSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
SpaceSet..::..GetEnumerator Method
SpaceSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2013 API
SpaceSet..::..Insert Method
SpaceSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Space item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Space _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Space^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..Space

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2013 API
SpaceSet..::..ReverseIterator Method
SpaceSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpaceSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SpaceSetIterator
Visual C++
public:
virtual SpaceSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSet Properties

[image] [image]

Revit 2013 API
SpaceSet Properties
SpaceSet Class See Also Send Feedback

The SpaceSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of objects that are in the set.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2013 API
SpaceSet..::..IsEmpty Property
SpaceSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2013 API
SpaceSet..::..Size Property
SpaceSet Class See Also Send Feedback
Returns the number of objects that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Class

[image]

Revit 2013 API
SpaceSetIterator Class
Members See Also Send Feedback
An iterator to a set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SpaceSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SpaceSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..SpaceSetIterator

See Also

SpaceSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Members

[image] [image]

Revit 2013 API
SpaceSetIterator Members
SpaceSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Constructor

[image]

Revit 2013 API
SpaceSetIterator Constructor
SpaceSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
SpaceSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Methods

[image] [image]

Revit 2013 API
SpaceSetIterator Methods
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
SpaceSetIterator..::..MoveNext Method
SpaceSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
SpaceSetIterator..::..Reset Method
SpaceSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceSetIterator Properties

[image] [image]

Revit 2013 API
SpaceSetIterator Properties
SpaceSetIterator Class See Also Send Feedback

The SpaceSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
SpaceSetIterator..::..Current Property
SpaceSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Class

[image]

Revit 2013 API
SpaceTag Class
Members See Also Send Feedback
Provides access to the space tag in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceTag : SpatialElementTag
Visual Basic
Public Class SpaceTag _
    Inherits SpatialElementTag
Visual C++
public ref class SpaceTag : public SpatialElementTag

Remarks

The space Tag object can be queried for space information.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..SpatialElementTag
Autodesk.Revit.DB.Mechanical..::..SpaceTag

See Also

SpaceTag Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Members

[image] [image]

Revit 2013 API
SpaceTag Members
SpaceTag Class Methods Properties See Also Send Feedback

The SpaceTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Space | The space that the tag is associated with.
Public property | SpaceTagType | The tag type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Methods

[image] [image]

Revit 2013 API
SpaceTag Methods
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTag Properties

[image] [image]

Revit 2013 API
SpaceTag Properties
SpaceTag Class See Also Send Feedback

The SpaceTag type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Identifies if a leader is displayed for the tag. (Inherited from SpatialElementTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | The location of the tag. (Inherited from SpatialElementTag.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | The name associated with the tag. (Inherited from SpatialElementTag.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Space | The space that the tag is associated with.
Public property | SpaceTagType | The tag type.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | View | The view in which the tag was placed. (Inherited from SpatialElementTag.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
SpaceTag..::..Parameter Property
SpaceTag Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpaceTag Class
SpaceTag Members
Autodesk.Revit.DB.Mechanical Namespace


Space Property

[image]

Revit 2013 API
SpaceTag..::..Space Property
SpaceTag Class See Also Send Feedback
The space that the tag is associated with.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Space Space { get; }
Visual Basic
Public ReadOnly Property Space As Space
    Get
Visual C++
public:
property Space^ Space {
    Space^ get ();
}

Remarks

In rare cases, the tag may not be associated to a space. The property will be nullNothingnullptra null reference (Nothing in Visual Basic) in these situations.

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Property

[image]

Revit 2013 API
SpaceTag..::..SpaceTagType Property
SpaceTag Class See Also Send Feedback
The tag type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTagType SpaceTagType { get; set; }
Visual Basic
Public Property SpaceTagType As SpaceTagType
    Get
    Set
Visual C++
public:
property SpaceTagType^ SpaceTagType {
    SpaceTagType^ get ();
    void set (SpaceTagType^ value);
}

See Also

SpaceTag Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Class

[image]

Revit 2013 API
SpaceTagFilter Class
Members See Also Send Feedback
A filter used to match space tags.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceTagFilter : ElementSlowFilter
Visual Basic
Public Class SpaceTagFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class SpaceTagFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Mechanical..::..SpaceTagFilter

See Also

SpaceTagFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Members

[image] [image]

Revit 2013 API
SpaceTagFilter Members
SpaceTagFilter Class Constructors Methods Properties See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceTagFilter | Constructs a filter which matches only spaces.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Constructor

[image]

Revit 2013 API
SpaceTagFilter Constructor
SpaceTagFilter Class See Also Send Feedback
Constructs a filter which matches only spaces.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTagFilter()
Visual Basic
Public Sub New
Visual C++
public:
SpaceTagFilter()

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Methods

[image] [image]

Revit 2013 API
SpaceTagFilter Methods
SpaceTagFilter Class See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
SpaceTagFilter..::..PassesFilter Method
SpaceTagFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

SpaceTagFilter Class
SpaceTagFilter Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagFilter Properties

[image] [image]

Revit 2013 API
SpaceTagFilter Properties
SpaceTagFilter Class See Also Send Feedback

The SpaceTagFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)

See Also

SpaceTagFilter Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Class

[image]

Revit 2013 API
SpaceTagType Class
Members See Also Send Feedback
An object that represents a Space Tag style.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceTagType : FamilySymbol
Visual Basic
Public Class SpaceTagType _
    Inherits FamilySymbol
Visual C++
public ref class SpaceTagType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB.Mechanical..::..SpaceTagType

See Also

SpaceTagType Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Members

[image] [image]

Revit 2013 API
SpaceTagType Members
SpaceTagType Class Methods Properties See Also Send Feedback

The SpaceTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Methods

[image] [image]

Revit 2013 API
SpaceTagType Methods
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagType Properties

[image] [image]

Revit 2013 API
SpaceTagType Properties
SpaceTagType Class See Also Send Feedback

The SpaceTagType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

SpaceTagType Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
SpaceTagType..::..Parameter Property
SpaceTagType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

SpaceTagType Class
SpaceTagType Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Class

[image]

Revit 2013 API
SpaceTagTypeSet Class
Members See Also Send Feedback
A set that contains space tag types.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class SpaceTagTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class SpaceTagTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class SpaceTagTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..SpaceTagTypeSet

See Also

SpaceTagTypeSet Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Members

[image] [image]

Revit 2013 API
SpaceTagTypeSet Members
SpaceTagTypeSet Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceTagTypeSet | Initializes a new instance of the SpaceTagTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every space tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a space tag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified space tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified space tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Constructor

[image]

Revit 2013 API
SpaceTagTypeSet Constructor
SpaceTagTypeSet Class See Also Send Feedback
Initializes a new instance of the SpaceTagTypeSet class

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTagTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
SpaceTagTypeSet()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Methods

[image] [image]

Revit 2013 API
SpaceTagTypeSet Methods
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every space tag type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a space tag type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified space tag type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified space tag type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Clear Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..Clear Method
SpaceTagTypeSet Class See Also Send Feedback
Removes every space tag type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Contains Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..Contains Method
SpaceTagTypeSet Class See Also Send Feedback
Tests for the existence of a space tag type within the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    SpaceTagType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..SpaceTagType
The space tag type to be searched for.

Return Value

The Contains method returns True if the space tag type is within the set, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Erase Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..Erase Method
SpaceTagTypeSet Class See Also Send Feedback
Removes a specified space tag type from the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    SpaceTagType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As SpaceTagType _
) As Integer
Visual C++
public:
virtual int Erase(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..SpaceTagType
The space tag type to be erased.

Return Value

The number of space tag types that were erased from the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


ForwardIterator Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..ForwardIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


GetEnumerator Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..GetEnumerator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Insert Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..Insert Method
SpaceTagTypeSet Class See Also Send Feedback
Insert the specified space tag type into the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    SpaceTagType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As SpaceTagType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    SpaceTagType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Mechanical..::..SpaceTagType
The space tag type to be inserted into the set.

Return Value

Returns whether the space tag type was inserted into the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


ReverseIterator Method

[image]

Revit 2013 API
SpaceTagTypeSet..::..ReverseIterator Method
SpaceTagTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual SpaceTagTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As SpaceTagTypeSetIterator
Visual C++
public:
virtual SpaceTagTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSet Properties

[image] [image]

Revit 2013 API
SpaceTagTypeSet Properties
SpaceTagTypeSet Class See Also Send Feedback

The SpaceTagTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of space tag types that are in the set.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


IsEmpty Property

[image]

Revit 2013 API
SpaceTagTypeSet..::..IsEmpty Property
SpaceTagTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


Size Property

[image]

Revit 2013 API
SpaceTagTypeSet..::..Size Property
SpaceTagTypeSet Class See Also Send Feedback
Returns the number of space tag types that are in the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

SpaceTagTypeSet Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Class

[image]

Revit 2013 API
SpaceTagTypeSetIterator Class
Members See Also Send Feedback
An iterator to a space tag type set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class SpaceTagTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class SpaceTagTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class SpaceTagTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Mechanical..::..SpaceTagTypeSetIterator

See Also

SpaceTagTypeSetIterator Members
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Members

[image] [image]

Revit 2013 API
SpaceTagTypeSetIterator Members
SpaceTagTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | SpaceTagTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Constructor

[image]

Revit 2013 API
SpaceTagTypeSetIterator Constructor
SpaceTagTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceTagTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
SpaceTagTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Methods

[image] [image]

Revit 2013 API
SpaceTagTypeSetIterator Methods
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


MoveNext Method

[image]

Revit 2013 API
SpaceTagTypeSetIterator..::..MoveNext Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Reset Method

[image]

Revit 2013 API
SpaceTagTypeSetIterator..::..Reset Method
SpaceTagTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceTagTypeSetIterator Properties

[image] [image]

Revit 2013 API
SpaceTagTypeSetIterator Properties
SpaceTagTypeSetIterator Class See Also Send Feedback

The SpaceTagTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


Current Property

[image]

Revit 2013 API
SpaceTagTypeSetIterator..::..Current Property
SpaceTagTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

SpaceTagTypeSetIterator Class
Autodesk.Revit.DB.Mechanical Namespace


SpaceType Enumeration

[image]

Revit 2013 API
SpaceType Enumeration
See Also Send Feedback
An enumerated type listing all the possible space types for a space object.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SpaceType
Visual Basic
Public Enumeration SpaceType
Visual C++
public enum class SpaceType

Members

Member name | Description
NoSpaceType | Space Type is NoSpaceType.
kActiveStorage | Space Type is ActiveStorage.
kActiveStorageHospitalOrHealthcare | Space Type is ActiveStorageHospitalOrHealthcare.
kAirOrTrainOrBusBaggageArea | Space Type is AirOrTrainOrBusBaggageArea.
kAirportConcourse | Space Type is AirportConcourse.
kAtriumEachAdditionalFloor | Space Type is AtriumEachAdditionalFloor.
kAtriumFirstThreeFloors | Space Type is AtriumFirstThreeFloors.
kAudienceOrSeatingAreaPenitentiary | Space Type is AudienceOrSeatingAreaPenitentiary.
kAudienceOrSeatingAreaExerciseCenter | Space Type is AudienceOrSeatingAreaExerciseCenter.
kAudienceOrSeatingAreaGymnasium | Space Type is AudienceOrSeatingAreaGymnasium.
kAudienceOrSeatingAreaSportsArena | Space Type is AudienceOrSeatingAreaSportsArena.
kAudienceOrSeatingAreaConventionCenter | Space Type is AudienceOrSeatingAreaConventionCenter.
kAudienceOrSeatingAreaMotionPictureTheatre | Space Type is AudienceOrSeatingAreaMotionPictureTheatre.
kAudienceOrSeatingAreaPerformingArtsTheatre | Space Type is AudienceOrSeatingAreaPerformingArtsTheatre.
kAudienceOrSeatingAreaReligious | Space Type is AudienceOrSeatingAreaReligious.
kAudienceOrSeatingAreaPoliceOrFireStations | Space Type is AudienceOrSeatingAreaPoliceOrFireStations.
kAudienceOrSeatingAreaCourtHouse | Space Type is AudienceOrSeatingAreaCourtHouse.
kAudienceOrSeatingAreaAuditorium | Space Type is AudienceOrSeatingAreaAuditorium.
kBankCustomerArea | Space Type is BankCustomerArea.
kBankingActivityAreaOffice | Space Type is BankingActivityAreaOffice.
kBarberAndBeautyParlor | Space Type is BarberAndBeautyParlor.
kCardFileAndCataloguingLibrary | Space Type is CardFileAndCataloguingLibrary.
kClassroomOrLectureOrTrainingPenitentiary | Space Type is ClassroomOrLectureOrTrainingPenitentiary.
kClassroomOrLectureOrTraining | Space Type is ClassroomOrLectureOrTraining.
kComfinementCellsPenitentiary | Space Type is ComfinementCellsPenitentiary.
kComfinementCellsCourtHouse | Space Type is ComfinementCellsCourtHouse.
kConferenceMeetingOrMultipurpose | Space Type is ConferenceMeetingOrMultipurpose.
kCorridorOrTransition | Space Type is CorridorOrTransition.
kCorridorOrTransitionManufacturingFacility | Space Type is CorridorOrTransitionManufacturingFacility.
kCorridorsWithPatientWaitingExamHospitalOrHealthcare | Space Type is CorridorsWithPatientWaitingExamHospitalOrHealthcare.
kCourtSportsAreaSportsArena | Space Type is CourtSportsAreaSportsArena.
kCourtroomCourtHouse | Space Type is CourtroomCourtHouse.
kDepartmentStoreSalesAreaRetail | Space Type is DepartmentStoreSalesAreaRetail.
kDetailedManufacturingFacility | Space Type is DetailedManufacturingFacility.
kDiningArea | Space Type is DiningArea.
kDiningAreaHotel | Space Type is DiningAreaHotel.
kDiningAreaFamilyDining | Space Type is DiningAreaFamilyDining.
kDiningAreaLoungeOrLeisureDining | Space Type is DiningAreaLoungeOrLeisureDining.
kDiningAreaMotel | Space Type is DiningAreaMotel.
kDiningAreaTransportation | Space Type is DiningAreaTransportation.
kDiningAreaPenitentiary | Space Type is DiningAreaPenitentiary.
kDiningAreaCivilServices | Space Type is DiningAreaCivilServices.
kDormitoryBedroom | Space Type is DormitoryBedroom.
kDormitoryStudyHall | Space Type is DormitoryStudyHall.
kDressingOrLockerOrFittingRoomGymnasium | Space Type is DressingOrLockerOrFittingRoomGymnasium.
kDressingOrLockerOrFittingRoomCourtHouse | Space Type is DressingOrLockerOrFittingRoomCourtHouse.
kDressingOrLockerOrFittingRoomPerformingArtsTheatre | Space Type is DressingOrLockerOrFittingRoomPerformingArtsTheatre.
kDressingOrLockerOrFittingRoomAuditorium | Space Type is DressingOrLockerOrFittingRoomAuditorium.
kDressingOrLockerOrFittingRoomExerciseCenter | Space Type is DressingOrLockerOrFittingRoomExerciseCenter.
kElectricalOrMechanical | Space Type is ElectricalOrMechanical.
kElevatorLobbies | Space Type is ElevatorLobbies.
kEmergencyHospitalOrHealthcare | Space Type is EmergencyHospitalOrHealthcare.
kEquipmentRoomManufacturingFacility | Space Type is EquipmentRoomManufacturingFacility.
kExamOrTreatmentHospitalOrHealthcare | Space Type is ExamOrTreatmentHospitalOrHealthcare.
kExerciseAreaExerciseCenter | Space Type is ExerciseAreaExerciseCenter.
kExerciseAreaGymnasium | Space Type is ExerciseAreaGymnasium.
kExhibitSpaceConventionCenter | Space Type is ExhibitSpaceConventionCenter.
kFellowshipHallReligiousBuildings | Space Type is FellowshipHallReligiousBuildings.
kFineMaterialWarehouse | Space Type is FineMaterialWarehouse.
kFineMerchandiseSalesAreaRetail | Space Type is FineMerchandiseSalesAreaRetail.
kFireStationEngineRoomPoliceOrFireStation | Space Type is FireStationEngineRoomPoliceOrFireStation.
kFoodPreparation | Space Type is FoodPreparation.
kGarageServiceOrRepairAutomotiveFacility | Space Type is GarageServiceOrRepairAutomotiveFacility.
kGeneralHighBayManufacturingFacility | Space Type is GeneralHighBayManufacturingFacility.
kGeneralLowBayManufacturingFacility | Space Type is GeneralLowBayManufacturingFacility.
kGeneralExhibitionMuseum | Space Type is GeneralExhibitionMuseum.
kHospitalNurseryHospitalOrHealthcare | Space Type is HospitalNurseryHospitalOrHealthcare.
kHospitalOrMedicalSuppliesHospitalOrHealthcare | Space Type is HospitalOrMedicalSuppliesHospitalOrHealthcare.
kHospitalOrRadiologyHospitalOrHealthcare | Space Type is HospitalOrRadiologyHospitalOrHealthcare.
kHotelOrConferenceCenterConferenceOrMeeting | Space Type is HotelOrConferenceCenterConferenceOrMeeting.
kInactiveStorage | Space Type is InactiveStorage.
kJudgesChambersCourtHouse | Space Type is JudgesChambersCourtHouse.
kLaboratoryOffice | Space Type is LaboratoryOffice.
kLaundryIroningAndSorting | Space Type is LaundryIroningAndSorting.
kLaundryWashingHospitalOrHealthcare | Space Type is LaundryWashingHospitalOrHealthcare.
kLibraryAudioVisualLibraryAudioVisual | Space Type is LibraryAudioVisualLibraryAudioVisual.
kLivingQuartersDormitory | Space Type is LivingQuartersDormitory.
kLivingQuartersMotel | Space Type is LivingQuartersMotel.
kLivingQuartersHotel | Space Type is LivingQuartersHotel.
kLobby | Space Type is Lobby.
kLobbyReligiousBuildings | Space Type is LobbyReligiousBuildings.
kLobbyMotionPictureTheatre | Space Type is LobbyMotionPictureTheatre.
kLobbyAuditorium | Space Type is LobbyAuditorium.
kLobbyPerformingArtsTheatre | Space Type is LobbyPerformingArtsTheatre.
kLobbyPostOffice | Space Type is LobbyPostOffice.
kLobbyHotel | Space Type is LobbyHotel.
kLoungeOrRecreation | Space Type is LoungeOrRecreation.
kMallConcourseSalesAreaRetail | Space Type is MallConcourseSalesAreaRetail.
kMassMerchandisingSalesAreaRetail | Space Type is MassMerchandisingSalesAreaRetail.
kMediumOrBulkyMaterialWarehouse | Space Type is MediumOrBulkyMaterialWarehouse.
kMerchandisingSalesAreaRetail | Space Type is MerchandisingSalesAreaRetail.
kMuseumAndGalleryStorage | Space Type is MuseumAndGalleryStorage.
kNurseStationHospitalOrHealthcare | Space Type is NurseStationHospitalOrHealthcare.
kOfficeEnclosed | Space Type is OfficeEnclosed.
kOfficeOpenPlan | Space Type is OfficeOpenPlan.
kOfficeCommonActivityAreasInactiveStorage | Space Type is OfficeCommonActivityAreasInactiveStorage.
kOperatingRoomHospitalOrHealthcare | Space Type is OperatingRoomHospitalOrHealthcare.
kOtherTelevisedPlayingAreaSportsArena | Space Type is OtherTelevisedPlayingAreaSportsArena.
kParkingAreaAttendantOnlyParkingGarage | Space Type is ParkingAreaAttendantOnlyParkingGarage.
kParkingAreaPedestrianParkingGarage | Space Type is ParkingAreaPedestrianParkingGarage.
kPatientRoomHospitalOrHealthcare | Space Type is PatientRoomHospitalOrHealthcare.
kPersonalServicesSalesAreaRetail | Space Type is PersonalServicesSalesAreaRetail.
kPharmacyHospitalOrHealthcare | Space Type is PharmacyHospitalOrHealthcare.
kPhysicalTherapyHospitalOrHealthcare | Space Type is PhysicalTherapyHospitalOrHealthcare.
kPlayingAreaGymnasium | Space Type is PlayingAreaGymnasium.
kPlenum | Space Type is Plenum.
kPoliceStationLaboratoryPoliceOrFireStations | Space Type is PoliceStationLaboratoryPoliceOrFireStations.
kPublicAndStaffLoungeHospitalOrHealthcare | Space Type is PublicAndStaffLoungeHospitalOrHealthcare.
kReadingAreaLibrary | Space Type is ReadingAreaLibrary.
kReceptionOrWaitingTransportation | Space Type is ReceptionOrWaitingTransportation.
kReceptionOrWaitingMotel | Space Type is ReceptionOrWaitingMotel.
kReceptionOrWaitingHotel | Space Type is ReceptionOrWaitingHotel.
kRecoveryHospitalOrHealthcare | Space Type is RecoveryHospitalOrHealthcare.
kRestorationMuseum | Space Type is RestorationMuseum.
kRestrooms | Space Type is Restrooms.
kRingSportsAreaSportsArena | Space Type is RingSportsAreaSportsArena.
kSleepingQuartersPoliceOrFireStation | Space Type is SleepingQuartersPoliceOrFireStation.
kSortingAreaPostOffice | Space Type is SortingAreaPostOffice.
kSpecialtyStoreSalesAreaRetail | Space Type is SpecialtyStoreSalesAreaRetail.
kStacksLibrary | Space Type is StacksLibrary.
kStairsInactive | Space Type is StairsInactive.
kStairway | Space Type is Stairway.
kSupermarketSalesAreaRetail | Space Type is SupermarketSalesAreaRetail.
kTerminalTicketCounterTransportation | Space Type is TerminalTicketCounterTransportation.
kWorkshopWorkshop | Space Type is WorkshopWorkshop.
kWorshipPulpitChoirReligious | Space Type is WorshipPulpitChoirReligious.
kNoOfSpaceTypes | Space Type is NoOfSpaceTypes.

See Also

Autodesk.Revit.DB.Mechanical Namespace


SystemCalculationLevel Enumeration

[image]

Revit 2013 API
SystemCalculationLevel Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum SystemCalculationLevel
Visual Basic
Public Enumeration SystemCalculationLevel
Visual C++
public enum class SystemCalculationLevel

Members

Member name | Description
All | System calculation is on for everything (with every bit being 1)
None | System calculation is off
Flow | System calculation is only for flow

See Also

Autodesk.Revit.DB.Mechanical Namespace


Zone Class

[image]

Revit 2013 API
Zone Class
Members See Also Send Feedback
Provides access to the Zone Element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Zone : Element
Visual Basic
Public Class Zone _
    Inherits Element
Visual C++
public ref class Zone : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. This object is only available in Revit MEP.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Mechanical..::..Zone

See Also

Zone Members
Autodesk.Revit.DB.Mechanical Namespace


Zone Members

[image] [image]

Revit 2013 API
Zone Members
Zone Class Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element..::..Name.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Methods

[image] [image]

Revit 2013 API
Zone Methods
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Methods

 | Name | Description
Public method | AddSpaces | Add a set of existing spaces to Zone element.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSpaces | Remove a set of existing spaces to the current Zone element.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


AddSpaces Method

[image]

Revit 2013 API
Zone..::..AddSpaces Method
Zone Class See Also Send Feedback
Add a set of existing spaces to Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool AddSpaces(
    SpaceSet spaces
)
Visual Basic
Public Function AddSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool AddSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.DB.Mechanical..::..SpaceSet
The spaces which want to add to zone element.

Return Value

If successful the current zone element will add a set of input spaces, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input spaces cannot be added to current zone element.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


RemoveSpaces Method

[image]

Revit 2013 API
Zone..::..RemoveSpaces Method
Zone Class See Also Send Feedback
Remove a set of existing spaces to the current Zone element.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool RemoveSpaces(
    SpaceSet spaces
)
Visual Basic
Public Function RemoveSpaces ( _
    spaces As SpaceSet _
) As Boolean
Visual C++
public:
bool RemoveSpaces(
    SpaceSet^ spaces
)

Parameters

spaces
Type: Autodesk.Revit.DB.Mechanical..::..SpaceSet
The spaces which want to delete from the current zone element.

Return Value

If successful the current zone element will remove a set of input spaces, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the specified parameter Value is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input spaces cannot be deleted from current zone element.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Zone Properties

[image] [image]

Revit 2013 API
Zone Properties
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Properties

 | Name | Description
Public property | Area | Get the Area of the Zone.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | Boundary | Returns the boundary of the Zone.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculatedCoolingLoad | Get the Calculated Cooling Load of the Zone.
Public property | CalculatedHeatingLoad | Get the Calculated Heating Load of the Zone.
Public property | CalculatedSupplyAirflow | Get the Calculated Supply Airflow of the Zone.
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoolingAirTemperature | Get or set the Cooling Air Temperature of the Zone.
Public property | CoolingSetPoint | Get or set the Cooling Set Point of the Zone.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DehumidificationSetPoint | Get or set the DeHumidification Set Point of the Zone.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GrossArea | Get the Gross Area of the Zone.
Public property | GrossVolume | Get the Gross Volume of the Zone.
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HeatingAirTemperature | Get or set the Heating Air Temperature of the Zone.
Public property | HeatingSetPoint | Get or set the Heating Set Point of the Zone.
Public property | HumidificationSetPoint | Get or set the Humidification Set Point of the Zone.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultZone | Reports whether this zone is default or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Get or Set the Name of the Zone. (Overrides Element..::..Name.)
Public property | OutDoorAirPerArea | Get or set the OutDoor Air Per Area of the Zone.
Public property | OutDoorAirPerPerson | Get or set the OutDoor Air Per Person of the Zone.
Public property | OutdoorAirRatePerAirChangesPerHour | Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | Perimeter | Get the Perimeter of the Zone.
Public property | Phase | Get the Phase of the Zone.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ServiceType | Get or set the Service Type of the Zone.
Public property | Spaces | Get the Spaces of the Zone.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | Get the Volume of the Zone.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Area Property

[image]

Revit 2013 API
Zone..::..Area Property
Zone Class See Also Send Feedback
Get the Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Area { get; }
Visual Basic
Public ReadOnly Property Area As Double
    Get
Visual C++
public:
property double Area {
    double get ();
}

Remarks

This property is used to get the Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Boundary Property

[image]

Revit 2013 API
Zone..::..Boundary Property
Zone Class See Also Send Feedback
Returns the boundary of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray Boundary { get; }
Visual Basic
Public ReadOnly Property Boundary As CurveArray
    Get
Visual C++
public:
property CurveArray^ Boundary {
    CurveArray^ get ();
}

Remarks

This property is used to retrieve the segments that constitute the boundary of the Zone. Each Zone may have several regions, each of which have several segments hence the data is returned in the form of an array of boundary segment arrays. See the Zone.BoundarySegment object for more details about the segments that make up the Zone topology.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedCoolingLoad Property

[image]

Revit 2013 API
Zone..::..CalculatedCoolingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Cooling Load of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedCoolingLoad { get; }
Visual Basic
Public ReadOnly Property CalculatedCoolingLoad As Double
    Get
Visual C++
public:
property double CalculatedCoolingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Cooling Load of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedHeatingLoad Property

[image]

Revit 2013 API
Zone..::..CalculatedHeatingLoad Property
Zone Class See Also Send Feedback
Get the Calculated Heating Load of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedHeatingLoad { get; }
Visual Basic
Public ReadOnly Property CalculatedHeatingLoad As Double
    Get
Visual C++
public:
property double CalculatedHeatingLoad {
    double get ();
}

Remarks

This property is used to get the Calculated Heating Load of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CalculatedSupplyAirflow Property

[image]

Revit 2013 API
Zone..::..CalculatedSupplyAirflow Property
Zone Class See Also Send Feedback
Get the Calculated Supply Airflow of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CalculatedSupplyAirflow { get; }
Visual Basic
Public ReadOnly Property CalculatedSupplyAirflow As Double
    Get
Visual C++
public:
property double CalculatedSupplyAirflow {
    double get ();
}

Remarks

This property is used to get the Calculated Supply Airflow (Unit: Airflow ) of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CoolingAirTemperature Property

[image]

Revit 2013 API
Zone..::..CoolingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Cooling Air Temperature of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CoolingAirTemperature { get; set; }
Visual Basic
Public Property CoolingAirTemperature As Double
    Get
    Set
Visual C++
public:
property double CoolingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


CoolingSetPoint Property

[image]

Revit 2013 API
Zone..::..CoolingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Cooling Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CoolingSetPoint { get; set; }
Visual Basic
Public Property CoolingSetPoint As Double
    Get
    Set
Visual C++
public:
property double CoolingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Cooling Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


DehumidificationSetPoint Property

[image]

Revit 2013 API
Zone..::..DehumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the DeHumidification Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double DehumidificationSetPoint { get; set; }
Visual Basic
Public Property DehumidificationSetPoint As Double
    Get
    Set
Visual C++
public:
property double DehumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the DeHumidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


GrossArea Property

[image]

Revit 2013 API
Zone..::..GrossArea Property
Zone Class See Also Send Feedback
Get the Gross Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GrossArea { get; }
Visual Basic
Public ReadOnly Property GrossArea As Double
    Get
Visual C++
public:
property double GrossArea {
    double get ();
}

Remarks

This property is used to get the Gross Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


GrossVolume Property

[image]

Revit 2013 API
Zone..::..GrossVolume Property
Zone Class See Also Send Feedback
Get the Gross Volume of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GrossVolume { get; }
Visual Basic
Public ReadOnly Property GrossVolume As Double
    Get
Visual C++
public:
property double GrossVolume {
    double get ();
}

Remarks

This property is used to get the Gross Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HeatingAirTemperature Property

[image]

Revit 2013 API
Zone..::..HeatingAirTemperature Property
Zone Class See Also Send Feedback
Get or set the Heating Air Temperature of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HeatingAirTemperature { get; set; }
Visual Basic
Public Property HeatingAirTemperature As Double
    Get
    Set
Visual C++
public:
property double HeatingAirTemperature {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Air Temperature of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HeatingSetPoint Property

[image]

Revit 2013 API
Zone..::..HeatingSetPoint Property
Zone Class See Also Send Feedback
Get or set the Heating Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HeatingSetPoint { get; set; }
Visual Basic
Public Property HeatingSetPoint As Double
    Get
    Set
Visual C++
public:
property double HeatingSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Heating Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


HumidificationSetPoint Property

[image]

Revit 2013 API
Zone..::..HumidificationSetPoint Property
Zone Class See Also Send Feedback
Get or set the Humidification Set Point of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HumidificationSetPoint { get; set; }
Visual Basic
Public Property HumidificationSetPoint As Double
    Get
    Set
Visual C++
public:
property double HumidificationSetPoint {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Humidification Set Point of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


IsDefaultZone Property

[image]

Revit 2013 API
Zone..::..IsDefaultZone Property
Zone Class See Also Send Feedback
Reports whether this zone is default or not.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDefaultZone { get; set; }
Visual Basic
Public Property IsDefaultZone As Boolean
    Get
    Set
Visual C++
public:
property bool IsDefaultZone {
    bool get ();
    void set (bool value);
}

Remarks

This property can be used to set the current zone as the default zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Name Property

[image]

Revit 2013 API
Zone..::..Name Property
Zone Class See Also Send Feedback
Get or Set the Name of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Name { set; }
Visual Basic
Public Overrides WriteOnly Property Name As String
    Set
Visual C++
public:
virtual property String^ Name {
    void set (String^ value) override;
}

Remarks

This property is used to get or set the Name of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutDoorAirPerArea Property

[image]

Revit 2013 API
Zone..::..OutDoorAirPerArea Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Area of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double OutDoorAirPerArea { get; set; }
Visual Basic
Public Property OutDoorAirPerArea As Double
    Get
    Set
Visual C++
public:
property double OutDoorAirPerArea {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the OutDoor Air Per Area of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutDoorAirPerPerson Property

[image]

Revit 2013 API
Zone..::..OutDoorAirPerPerson Property
Zone Class See Also Send Feedback
Get or set the OutDoor Air Per Person of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double OutDoorAirPerPerson { get; set; }
Visual Basic
Public Property OutDoorAirPerPerson As Double
    Get
    Set
Visual C++
public:
property double OutDoorAirPerPerson {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the OutDoor Air Per Person of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


OutdoorAirRatePerAirChangesPerHour Property

[image]

Revit 2013 API
Zone..::..OutdoorAirRatePerAirChangesPerHour Property
Zone Class See Also Send Feedback
Get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double OutdoorAirRatePerAirChangesPerHour { get; set; }
Visual Basic
Public Property OutdoorAirRatePerAirChangesPerHour As Double
    Get
    Set
Visual C++
public:
property double OutdoorAirRatePerAirChangesPerHour {
    double get ();
    void set (double value);
}

Remarks

This property is used to get or set the Outdoor Air Rate Per Air Changes Per Hour of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Parameter Property

[image] [image]

Revit 2013 API
Zone..::..Parameter Property
Zone Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Zone Class
Zone Members
Autodesk.Revit.DB.Mechanical Namespace


Perimeter Property

[image]

Revit 2013 API
Zone..::..Perimeter Property
Zone Class See Also Send Feedback
Get the Perimeter of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Perimeter { get; }
Visual Basic
Public ReadOnly Property Perimeter As Double
    Get
Visual C++
public:
property double Perimeter {
    double get ();
}

Remarks

This property is used to get the Perimeter of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Phase Property

[image]

Revit 2013 API
Zone..::..Phase Property
Zone Class See Also Send Feedback
Get the Phase of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Phase Phase { get; }
Visual Basic
Public ReadOnly Property Phase As Phase
    Get
Visual C++
public:
property Phase^ Phase {
    Phase^ get ();
}

Remarks

This property is used to get the Phase of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


ServiceType Property

[image]

Revit 2013 API
Zone..::..ServiceType Property
Zone Class See Also Send Feedback
Get or set the Service Type of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ServiceType ServiceType { get; set; }
Visual Basic
Public Property ServiceType As ServiceType
    Get
    Set
Visual C++
public:
property ServiceType ServiceType {
    ServiceType get ();
    void set (ServiceType value);
}

Remarks

This property is used to get or set the Service Type of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Spaces Property

[image]

Revit 2013 API
Zone..::..Spaces Property
Zone Class See Also Send Feedback
Get the Spaces of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public SpaceSet Spaces { get; }
Visual Basic
Public ReadOnly Property Spaces As SpaceSet
    Get
Visual C++
public:
property SpaceSet^ Spaces {
    SpaceSet^ get ();
}

Remarks

This property is used to get the Spaces of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Volume Property

[image]

Revit 2013 API
Zone..::..Volume Property
Zone Class See Also Send Feedback
Get the Volume of the Zone.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

Remarks

This property is used to get the Volume of the Zone.

See Also

Zone Class
Autodesk.Revit.DB.Mechanical Namespace


Autodesk.Revit.DB.Plumbing Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Plumbing Namespace
Send Feedback

Classes

 | Class | Description
Public class | FlexPipe | A flex pipe in the Autodesk Revit MEP product.
Public class | FlexPipeType | A flex pipe type in the Autodesk Revit MEP product.
Public class | FluidTemperature | Represents the viscosity and density properties as defined at a certain temperature.
Public class | FluidTemperatureSetIterator | An iterator to a set of FluidTemperature from FluidType.
Public class | FluidType | Has been extended to provide read and write access to a collection of FluidTemperature objects which represent the fluid's properties at various temperatures.
Public class | Pipe | A pipe in the Autodesk Revit MEP product.
Public class | PipeConnectionType | A pipe connection type in the Autodesk Revit MEP product.
Public class | PipeConnector | Obsolete. A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.
Public class | PipeInsulation | Represents insulation applied to the outside of a given pipe, fitting or content.
Public class | PipeInsulationType | This class represents a pipe insulation type in Autodesk Revit.
Public class | PipeMaterialType | Obsolete. A pipe material type in the Autodesk Revit MEP product.
Public class | PipeScheduleType | A pipe schedule type in the Autodesk Revit MEP product.
Public class | PipeSegment | The PipeSegment class represents an instance of pipe segment which has the design data for routing preference. Default constructor Default destructor
Public class | PipeSettings | The pipe setting class.
Public class | PipeType |
Public class | PipingSystem | Default constructor Default destructor
Public class | PipingSystemType | Base class for piping system types
Public class | PlumbingUtils | General utility methods in the Autodesk Revit MEP product.

Enumerations

 | Enumeration | Description
Public enumeration | FlowConversionMode |
Public enumeration | PipeFlowConfigurationType | An enumerated type listing all pipe flow configuration types for a connector
Public enumeration | PipeFlowState | An enumerated type listing all the pipe flow states for a pipe.
Public enumeration | PipeLossMethodType | An enumerated type listing all pipe loss method types for a connector
Public enumeration | PipeSystemType | An enumerated type listing all the possible pipe system types for a connector object.


FlexPipe Class

[image]

Revit 2013 API
FlexPipe Class
Members See Also Send Feedback
A flex pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FlexPipe : MEPCurve
Visual Basic
Public Class FlexPipe _
    Inherits MEPCurve
Visual C++
public ref class FlexPipe : public MEPCurve

Remarks

The flex pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Plumbing..::..FlexPipe

See Also

FlexPipe Members
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Members

[image] [image]

Revit 2013 API
FlexPipe Members
FlexPipe Class Methods Properties See Also Send Feedback

The FlexPipe type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlexPipeType | The flex pipe type of this flex pipe.
Public property | FlowState | The flow state of the pipe.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Points | The points of the flex pipe.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Methods

[image] [image]

Revit 2013 API
FlexPipe Methods
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipe Properties

[image] [image]

Revit 2013 API
FlexPipe Properties
FlexPipe Class See Also Send Feedback

The FlexPipe type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlexPipeType | The flex pipe type of this flex pipe.
Public property | FlowState | The flow state of the pipe.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Points | The points of the flex pipe.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Property

[image]

Revit 2013 API
FlexPipe..::..FlexPipeType Property
FlexPipe Class See Also Send Feedback
The flex pipe type of this flex pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FlexPipeType FlexPipeType { get; set; }
Visual Basic
Public Property FlexPipeType As FlexPipeType
    Get
    Set
Visual C++
public:
property FlexPipeType^ FlexPipeType {
    FlexPipeType^ get ();
    void set (FlexPipeType^ value);
}

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlowState Property

[image]

Revit 2013 API
FlexPipe..::..FlowState Property
FlexPipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic
Public ReadOnly Property FlowState As PipeFlowState
    Get
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
FlexPipe..::..Parameter Property
FlexPipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FlexPipe Class
FlexPipe Members
Autodesk.Revit.DB.Plumbing Namespace


Points Property

[image]

Revit 2013 API
FlexPipe..::..Points Property
FlexPipe Class See Also Send Feedback
The points of the flex pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<XYZ> Points { get; set; }
Visual Basic
Public Property Points As IList(Of XYZ)
    Get
    Set
Visual C++
public:
property IList<XYZ^>^ Points {
    IList<XYZ^>^ get ();
    void set (IList<XYZ^>^ value);
}

Remarks

This property is used to retrieve the points of flex pipe, including the end points. If the end points are changed, the connection will be maintained by Revit automatically. The set operation will fail if the modification makes the connection invalid.

See Also

FlexPipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Class

[image]

Revit 2013 API
FlexPipeType Class
Members See Also Send Feedback
A flex pipe type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class FlexPipeType : MEPCurveType
Visual Basic
Public Class FlexPipeType _
    Inherits MEPCurveType
Visual C++
public ref class FlexPipeType : public MEPCurveType

Remarks

The flex pipe type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Plumbing..::..FlexPipeType

See Also

FlexPipeType Members
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Members

[image] [image]

Revit 2013 API
FlexPipeType Members
FlexPipeType Class Methods Properties See Also Send Feedback

The FlexPipeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Methods

[image] [image]

Revit 2013 API
FlexPipeType Methods
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


FlexPipeType Properties

[image] [image]

Revit 2013 API
FlexPipeType Properties
FlexPipeType Class See Also Send Feedback

The FlexPipeType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | The roughness of the MEP curve type. For PipeTypes, please use Segment::Roughness; (Inherited from MEPCurveType.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FlexPipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
FlexPipeType..::..Parameter Property
FlexPipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FlexPipeType Class
FlexPipeType Members
Autodesk.Revit.DB.Plumbing Namespace


FlowConversionMode Enumeration

[image]

Revit 2013 API
FlowConversionMode Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum FlowConversionMode
Visual Basic
Public Enumeration FlowConversionMode
Visual C++
public enum class FlowConversionMode

Members

Member name | Description
Invalid |
Valves |
Tanks |

See Also

Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Class

[image]

Revit 2013 API
FluidTemperature Class
Members See Also Send Feedback
Represents the viscosity and density properties as defined at a certain temperature.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FluidTemperature : IDisposable
Visual Basic
Public Class FluidTemperature _
    Implements IDisposable
Visual C++
public ref class FluidTemperature : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Plumbing..::..FluidTemperature

See Also

FluidTemperature Members
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Members

[image] [image]

Revit 2013 API
FluidTemperature Members
FluidTemperature Class Constructors Methods Properties See Also Send Feedback

The FluidTemperature type exposes the following members.

Constructors

 | Name | Description
Public method | FluidTemperature | Creates a new fluid temperature with given temperature, viscosity and density.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FluidTemperature
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Density | The density value
Public property | Temperature | The temperature value
Public property | Viscosity | The viscosity value

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Constructor

[image]

Revit 2013 API
FluidTemperature Constructor
FluidTemperature Class See Also Send Feedback
Creates a new fluid temperature with given temperature, viscosity and density.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FluidTemperature(
    double temperature,
    double viscosity,
    double density
)
Visual Basic
Public Sub New ( _
    temperature As Double, _
    viscosity As Double, _
    density As Double _
)
Visual C++
public:
FluidTemperature(
    double temperature,
    double viscosity,
    double density
)

Parameters

temperature
Type: System..::..Double
The temperature value.
viscosity
Type: System..::..Double
The viscosity value.
density
Type: System..::..Double
The density value.

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Methods

[image] [image]

Revit 2013 API
FluidTemperature Methods
FluidTemperature Class See Also Send Feedback

The FluidTemperature type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


Dispose Method

[image]

Revit 2013 API
FluidTemperature..::..Dispose Method
FluidTemperature Class See Also Send Feedback
Releases all resources used by the FluidTemperature

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Properties

[image] [image]

Revit 2013 API
FluidTemperature Properties
FluidTemperature Class See Also Send Feedback

The FluidTemperature type exposes the following members.

Properties

 | Name | Description
Public property | Density | The density value
Public property | Temperature | The temperature value
Public property | Viscosity | The viscosity value

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


Density Property

[image]

Revit 2013 API
FluidTemperature..::..Density Property
FluidTemperature Class See Also Send Feedback
The density value

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Density { get; set; }
Visual Basic
Public Property Density As Double
    Get
    Set
Visual C++
public:
property double Density {
    double get ();
    void set (double value);
}

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


Temperature Property

[image]

Revit 2013 API
FluidTemperature..::..Temperature Property
FluidTemperature Class See Also Send Feedback
The temperature value

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Temperature { get; set; }
Visual Basic
Public Property Temperature As Double
    Get
    Set
Visual C++
public:
property double Temperature {
    double get ();
    void set (double value);
}

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


Viscosity Property

[image]

Revit 2013 API
FluidTemperature..::..Viscosity Property
FluidTemperature Class See Also Send Feedback
The viscosity value

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Viscosity { get; set; }
Visual Basic
Public Property Viscosity As Double
    Get
    Set
Visual C++
public:
property double Viscosity {
    double get ();
    void set (double value);
}

See Also

FluidTemperature Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperatureSetIterator Class

[image]

Revit 2013 API
FluidTemperatureSetIterator Class
Members See Also Send Feedback
An iterator to a set of FluidTemperature from FluidType.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FluidTemperatureSetIterator : IEnumerator<FluidTemperature>
Visual Basic
Public Class FluidTemperatureSetIterator _
    Implements IEnumerator(Of FluidTemperature)
Visual C++
public ref class FluidTemperatureSetIterator : IEnumerator<FluidTemperature^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Plumbing..::..FluidTemperatureSetIterator

See Also

FluidTemperatureSetIterator Members
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperatureSetIterator Members

[image] [image]

Revit 2013 API
FluidTemperatureSetIterator Members
FluidTemperatureSetIterator Class Methods Properties See Also Send Feedback

The FluidTemperatureSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the FluidTemperatureSetIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | Returns the current FluidTemperature.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperatureSetIterator Methods

[image] [image]

Revit 2013 API
FluidTemperatureSetIterator Methods
FluidTemperatureSetIterator Class See Also Send Feedback

The FluidTemperatureSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurrent | Returns the current FluidTemperature.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has completed.
Public method | MoveNext | Increments the iterator to the next item.
Public method | Reset | Resets the iterator to the initial state.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


Dispose Method

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..Dispose Method
FluidTemperatureSetIterator Class See Also Send Feedback
Releases all resources used by the FluidTemperatureSetIterator

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


GetCurrent Method

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..GetCurrent Method
FluidTemperatureSetIterator Class See Also Send Feedback
Returns the current FluidTemperature.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FluidTemperature GetCurrent()
Visual Basic
Public Function GetCurrent As FluidTemperature
Visual C++
public:
FluidTemperature^ GetCurrent()

Return Value

The current FluidTemperature.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


IsDone Method

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..IsDone Method
FluidTemperatureSetIterator Class See Also Send Feedback
Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more items. False if there are more items to be iterated.

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


MoveNext Method

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..MoveNext Method
FluidTemperatureSetIterator Class See Also Send Feedback
Increments the iterator to the next item.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is a next available item in this iterator. False if the iterator has completed all available items.

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


Reset Method

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..Reset Method
FluidTemperatureSetIterator Class See Also Send Feedback
Resets the iterator to the initial state.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperatureSetIterator Properties

[image] [image]

Revit 2013 API
FluidTemperatureSetIterator Properties
FluidTemperatureSetIterator Class See Also Send Feedback

The FluidTemperatureSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the item at the current position of the iterator.
Protected property | CurrentObject |

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


Current Property

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..Current Property
FluidTemperatureSetIterator Class See Also Send Feedback
Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual FluidTemperature Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As FluidTemperature
    Get
Visual C++
public:
virtual property FluidTemperature^ Current {
    FluidTemperature^ get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | There is no current item in the iterator.

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


CurrentObject Property

[image]

Revit 2013 API
FluidTemperatureSetIterator..::..CurrentObject Property
FluidTemperatureSetIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal Object CurrentObject { get; }
Visual Basic
Friend ReadOnly Property CurrentObject As Object
    Get
Visual C++
internal:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

FluidTemperatureSetIterator Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Class

[image]

Revit 2013 API
FluidType Class
Members See Also Send Feedback
Has been extended to provide read and write access to a collection of FluidTemperature objects which represent the fluid's properties at various temperatures.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FluidType : ElementType, IEnumerable<FluidTemperature>
Visual Basic
Public Class FluidType _
    Inherits ElementType _
    Implements IEnumerable(Of FluidTemperature)
Visual C++
public ref class FluidType : public ElementType,
    IEnumerable<FluidTemperature^>

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..FluidType

See Also

FluidType Members
Autodesk.Revit.DB.Plumbing Namespace


FluidType Members

[image] [image]

Revit 2013 API
FluidType Members
FluidType Class Methods Properties See Also Send Feedback

The FluidType type exposes the following members.

Methods

 | Name | Description
Public method | AddTemperature | Adds a fluid temperature to the set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearAllTemperatures | Clears all fluid temperatures in the set.
 | Create(Document, String) | Creates a new empty fluid type and adds it to the document.
 | Create(Document, String, FluidType) | Creates a new fluid type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFluidTemperatureSetIterator | Returns a FluidTemperatureSetIterator that iterates through the collection.
 | GetFluidType | Gets a fluid type by name.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetTemperature | Gets the FluidTemperature object corresponding to a given temperature value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
 | IsFluidInUse | Identifies if the fluid type is in use.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveTemperature | Removes a fluid temperature via the temperature value from the set.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Methods

[image] [image]

Revit 2013 API
FluidType Methods
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Methods

 | Name | Description
Public method | AddTemperature | Adds a fluid temperature to the set.
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | ClearAllTemperatures | Clears all fluid temperatures in the set.
 | Create(Document, String) | Creates a new empty fluid type and adds it to the document.
 | Create(Document, String, FluidType) | Creates a new fluid type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFluidTemperatureSetIterator | Returns a FluidTemperatureSetIterator that iterates through the collection.
 | GetFluidType | Gets a fluid type by name.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetTemperature | Gets the FluidTemperature object corresponding to a given temperature value.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
 | IsFluidInUse | Identifies if the fluid type is in use.
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveTemperature | Removes a fluid temperature via the temperature value from the set.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


AddTemperature Method

[image]

Revit 2013 API
FluidType..::..AddTemperature Method
FluidType Class See Also Send Feedback
Adds a fluid temperature to the set.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddTemperature(
    FluidTemperature fluidTemperature
)
Visual Basic
Public Sub AddTemperature ( _
    fluidTemperature As FluidTemperature _
)
Visual C++
public:
void AddTemperature(
    FluidTemperature^ fluidTemperature
)

Parameters

fluidTemperature
Type: Autodesk.Revit.DB.Plumbing..::..FluidTemperature
The fluid temperature being inserted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


ClearAllTemperatures Method

[image]

Revit 2013 API
FluidType..::..ClearAllTemperatures Method
FluidType Class See Also Send Feedback
Clears all fluid temperatures in the set.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ClearAllTemperatures()
Visual Basic
Public Sub ClearAllTemperatures
Visual C++
public:
void ClearAllTemperatures()

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


Create Method

[image] [image]

Revit 2013 API
FluidType..::..Create Method
FluidType Class See Also Send Feedback

Overload List

Name | Description
Create(Document, String) | Creates a new empty fluid type and adds it to the document.
Create(Document, String, FluidType) | Creates a new fluid type and adds it to the document.

See Also

FluidType Class
FluidType Members
Autodesk.Revit.DB.Plumbing Namespace


Create Method (Document, String)

[image]

Revit 2013 API
FluidType..::..Create Method (Document, String)
FluidType Class See Also Send Feedback
Creates a new empty fluid type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FluidType Create(
    Document document,
    string fluidTypeName
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    fluidTypeName As String _
) As FluidType
Visual C++
public:
static FluidType^ Create(
    Document^ document,
    String^ fluidTypeName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
fluidTypeName
Type: System..::..String
The name of fluid type.

Return Value

The newly created fluid type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FluidType Class
Create Overload
Autodesk.Revit.DB.Plumbing Namespace


Create Method (Document, String, FluidType)

[image]

Revit 2013 API
FluidType..::..Create Method (Document, String, FluidType)
FluidType Class See Also Send Feedback
Creates a new fluid type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FluidType Create(
    Document document,
    string fluidTypeName,
    FluidType basedOnFluidType
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    fluidTypeName As String, _
    basedOnFluidType As FluidType _
) As FluidType
Visual C++
public:
static FluidType^ Create(
    Document^ document,
    String^ fluidTypeName,
    FluidType^ basedOnFluidType
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
fluidTypeName
Type: System..::..String
The name of new created fluid type.
basedOnFluidType
Type: Autodesk.Revit.DB.Plumbing..::..FluidType
The existing fluid type which is based on.

Return Value

The newly created fluid type.

Remarks

The new fluid type will be a duplicate of the input type.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FluidType Class
Create Overload
Autodesk.Revit.DB.Plumbing Namespace


GetBasicIEnumerator Method

[image]

Revit 2013 API
FluidType..::..GetBasicIEnumerator Method
FluidType Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


GetEnumerator Method

[image]

Revit 2013 API
FluidType..::..GetEnumerator Method
FluidType Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<FluidTemperature> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of FluidTemperature)
Visual C++
public:
virtual IEnumerator<FluidTemperature^>^ GetEnumerator()

Return Value

An IEnumerator(FluidTemperature) object that can be used to iterate through key-value pairs in the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


GetFluidTemperatureSetIterator Method

[image]

Revit 2013 API
FluidType..::..GetFluidTemperatureSetIterator Method
FluidType Class See Also Send Feedback
Returns a FluidTemperatureSetIterator that iterates through the collection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FluidTemperatureSetIterator GetFluidTemperatureSetIterator()
Visual Basic
Public Function GetFluidTemperatureSetIterator As FluidTemperatureSetIterator
Visual C++
public:
FluidTemperatureSetIterator^ GetFluidTemperatureSetIterator()

Return Value

A FluidTemperatureSetIterator object that can be used to iterate through key-value pairs in the collection.

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


GetFluidType Method

[image]

Revit 2013 API
FluidType..::..GetFluidType Method
FluidType Class See Also Send Feedback
Gets a fluid type by name.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FluidType GetFluidType(
    Document document,
    string fluidTypeName
)
Visual Basic
Public Shared Function GetFluidType ( _
    document As Document, _
    fluidTypeName As String _
) As FluidType
Visual C++
public:
static FluidType^ GetFluidType(
    Document^ document,
    String^ fluidTypeName
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
fluidTypeName
Type: System..::..String
The name of fluid type.

Return Value

The fluid type. nullNothingnullptra null reference (Nothing in Visual Basic) if the fluid type was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


GetTemperature Method

[image]

Revit 2013 API
FluidType..::..GetTemperature Method
FluidType Class See Also Send Feedback
Gets the FluidTemperature object corresponding to a given temperature value.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FluidTemperature GetTemperature(
    double temperature
)
Visual Basic
Public Function GetTemperature ( _
    temperature As Double _
) As FluidTemperature
Visual C++
public:
FluidTemperature^ GetTemperature(
    double temperature
)

Parameters

temperature
Type: System..::..Double
The temperature value.

Return Value

The fluid temperature. nullNothingnullptra null reference (Nothing in Visual Basic) if not found.

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


IsFluidInUse Method

[image]

Revit 2013 API
FluidType..::..IsFluidInUse Method
FluidType Class See Also Send Feedback
Identifies if the fluid type is in use.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsFluidInUse(
    Document document,
    ElementId fluidId
)
Visual Basic
Public Shared Function IsFluidInUse ( _
    document As Document, _
    fluidId As ElementId _
) As Boolean
Visual C++
public:
static bool IsFluidInUse(
    Document^ document,
    ElementId^ fluidId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
fluidId
Type: Autodesk.Revit.DB..::..ElementId
The id of the fluid type.

Return Value

True if the fluid type is in use. False if the fluid type is not in use.

Remarks

If a fluid type is in use, it cannot be deleted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


RemoveTemperature Method

[image]

Revit 2013 API
FluidType..::..RemoveTemperature Method
FluidType Class See Also Send Feedback
Removes a fluid temperature via the temperature value from the set.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveTemperature(
    double temperature
)
Visual Basic
Public Sub RemoveTemperature ( _
    temperature As Double _
)
Visual C++
public:
void RemoveTemperature(
    double temperature
)

Parameters

temperature
Type: System..::..Double
The temperature value.

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Properties

[image] [image]

Revit 2013 API
FluidType Properties
FluidType Class See Also Send Feedback

The FluidType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FluidType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
FluidType..::..Parameter Property
FluidType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FluidType Class
FluidType Members
Autodesk.Revit.DB.Plumbing Namespace


Pipe Class

[image]

Revit 2013 API
Pipe Class
Members See Also Send Feedback
A pipe in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Pipe : MEPCurve
Visual Basic
Public Class Pipe _
    Inherits MEPCurve
Visual C++
public ref class Pipe : public MEPCurve

Remarks

The pipe is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB.Plumbing..::..Pipe

See Also

Pipe Members
Autodesk.Revit.DB.Plumbing Namespace


Pipe Members

[image] [image]

Revit 2013 API
Pipe Members
Pipe Class Methods Properties See Also Send Feedback

The Pipe type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreatePlaceholder | Creates a new placeholder pipe.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLevelId | Checks if given element id is valid level element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsPipeTypeId | Checks if given type is valid pipe type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlowState | The flow state of the pipe.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies if the pipe is a placeholder or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PipeType | The pipe type of this pipe.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Pipe Methods

[image] [image]

Revit 2013 API
Pipe Methods
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreatePlaceholder | Creates a new placeholder pipe.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
 | IsLevelId | Checks if given element id is valid level element.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsPipeTypeId | Checks if given type is valid pipe type.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


CreatePlaceholder Method

[image]

Revit 2013 API
Pipe..::..CreatePlaceholder Method
Pipe Class See Also Send Feedback
Creates a new placeholder pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static Pipe CreatePlaceholder(
    Document document,
    ElementId pipeTypeId,
    ElementId levelId,
    XYZ firstPoint,
    XYZ secondPoint
)
Visual Basic
Public Shared Function CreatePlaceholder ( _
    document As Document, _
    pipeTypeId As ElementId, _
    levelId As ElementId, _
    firstPoint As XYZ, _
    secondPoint As XYZ _
) As Pipe
Visual C++
public:
static Pipe^ CreatePlaceholder(
    Document^ document,
    ElementId^ pipeTypeId,
    ElementId^ levelId,
    XYZ^ firstPoint,
    XYZ^ secondPoint
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
pipeTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of the pipe type.
levelId
Type: Autodesk.Revit.DB..::..ElementId
The level id for the pipe.
firstPoint
Type: Autodesk.Revit.DB..::..XYZ
The first point of the placeholder line.
secondPoint
Type: Autodesk.Revit.DB..::..XYZ
The second point of the placeholder line.

Return Value

The placeholder pipe.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The pipe type pipeTypeId is not valid pipe type. -or- The level id levelId is not valid. -or- The points of firstPoint and secondPoint are equal.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


IsLevelId Method

[image]

Revit 2013 API
Pipe..::..IsLevelId Method
Pipe Class See Also Send Feedback
Checks if given element id is valid level element.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsLevelId(
    Document document,
    ElementId levelId
)
Visual Basic
Public Shared Function IsLevelId ( _
    document As Document, _
    levelId As ElementId _
) As Boolean
Visual C++
public:
static bool IsLevelId(
    Document^ document,
    ElementId^ levelId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
levelId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the level to check.

Return Value

True if the given level id is valid, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


IsPipeTypeId Method

[image]

Revit 2013 API
Pipe..::..IsPipeTypeId Method
Pipe Class See Also Send Feedback
Checks if given type is valid pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool IsPipeTypeId(
    Document document,
    ElementId pipeTypeId
)
Visual Basic
Public Shared Function IsPipeTypeId ( _
    document As Document, _
    pipeTypeId As ElementId _
) As Boolean
Visual C++
public:
static bool IsPipeTypeId(
    Document^ document,
    ElementId^ pipeTypeId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
pipeTypeId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of the pipe type to check.

Return Value

True if pipe type can used for this pipe, false otherwise.

Remarks

A type is valid for pipe if it can be used to the pipe element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Pipe Properties

[image] [image]

Revit 2013 API
Pipe Properties
Pipe Class See Also Send Feedback

The Pipe type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlowState | The flow state of the pipe.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPlaceholder | Identifies if the pipe is a placeholder or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PipeType | The pipe type of this pipe.
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


FlowState Property

[image]

Revit 2013 API
Pipe..::..FlowState Property
Pipe Class See Also Send Feedback
The flow state of the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeFlowState FlowState { get; }
Visual Basic
Public ReadOnly Property FlowState As PipeFlowState
    Get
Visual C++
public:
property PipeFlowState FlowState {
    PipeFlowState get ();
}

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


IsPlaceholder Property

[image]

Revit 2013 API
Pipe..::..IsPlaceholder Property
Pipe Class See Also Send Feedback
Identifies if the pipe is a placeholder or not.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsPlaceholder { get; }
Visual Basic
Public ReadOnly Property IsPlaceholder As Boolean
    Get
Visual C++
public:
property bool IsPlaceholder {
    bool get ();
}

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
Pipe..::..Parameter Property
Pipe Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Pipe Class
Pipe Members
Autodesk.Revit.DB.Plumbing Namespace


PipeType Property

[image]

Revit 2013 API
Pipe..::..PipeType Property
Pipe Class See Also Send Feedback
The pipe type of this pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeType PipeType { get; set; }
Visual Basic
Public Property PipeType As PipeType
    Get
    Set
Visual C++
public:
property PipeType^ PipeType {
    PipeType^ get ();
    void set (PipeType^ value);
}

See Also

Pipe Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Class

[image]

Revit 2013 API
PipeConnectionType Class
Members See Also Send Feedback
A pipe connection type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PipeConnectionType : ElementType
Visual Basic
Public Class PipeConnectionType _
    Inherits ElementType
Visual C++
public ref class PipeConnectionType : public ElementType

Remarks

The pipe connection type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..PipeConnectionType

See Also

PipeConnectionType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Members

[image] [image]

Revit 2013 API
PipeConnectionType Members
PipeConnectionType Class Methods Properties See Also Send Feedback

The PipeConnectionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Methods

[image] [image]

Revit 2013 API
PipeConnectionType Methods
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnectionType Properties

[image] [image]

Revit 2013 API
PipeConnectionType Properties
PipeConnectionType Class See Also Send Feedback

The PipeConnectionType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeConnectionType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeConnectionType..::..Parameter Property
PipeConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeConnectionType Class
PipeConnectionType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Class

[image]

Revit 2013 API
PipeConnector Class
Members See Also Send Feedback
A pipe connector that is assigned to a mechanical equipment or pipe fitting family. Provides access to the pipe connector in Autodesk Revit MEP family document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public class PipeConnector : ConnectorElement
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use ConnectorElement instead.")> _
Public Class PipeConnector _
    Inherits ConnectorElement
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use ConnectorElement instead.")]
public ref class PipeConnector : public ConnectorElement

Remarks

This element type is accessible only in Autodesk Revit MEP family documents. Pipe connectors that are accessible in MEP project documents are not elements, and are represented by Connector.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ConnectorElement
Autodesk.Revit.DB.Plumbing..::..PipeConnector

See Also

PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Members

[image] [image]

Revit 2013 API
PipeConnector Members
PipeConnector Class Methods Properties See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LinkedConnector | Obsolete. The linked pipe connector.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the pipe connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Methods

[image] [image]

Revit 2013 API
PipeConnector Methods
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AssignAsPrimary | Assign a connector as a primary connector. (Inherited from ConnectorElement.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLinkedConnectorElement | Get the linked connector element. (Inherited from ConnectorElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLinkedConnectorElement | Set the linked connector element. (Inherited from ConnectorElement.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeConnector Properties

[image] [image]

Revit 2013 API
PipeConnector Properties
PipeConnector Class See Also Send Feedback

The PipeConnector type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoordinateSystem | The coordinate system of the connector. (Inherited from ConnectorElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Domain | The domain of the connector. (Inherited from ConnectorElement.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the connector. (Inherited from ConnectorElement.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsPrimary | Identifies if this is the primary connector in the family. (Inherited from ConnectorElement.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LinkedConnector | Obsolete. The linked pipe connector.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Origin | The location of the connector in family document. (Inherited from ConnectorElement.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Radius | The radius of the connector. (Inherited from ConnectorElement.)
Public property | Shape | The shape of the connector. (Inherited from ConnectorElement.)
Public property | SystemType | The system type of the pipe connector.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the connector. (Inherited from ConnectorElement.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


LinkedConnector Property

[image]

Revit 2013 API
PipeConnector..::..LinkedConnector Property
PipeConnector Class See Also Send Feedback
The linked pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public PipeConnector LinkedConnector { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")> _
Public Property LinkedConnector As PipeConnector
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please call GetLinkedConnectorElement and SetLinkedConnectorElement() instead.")]
public:
property PipeConnector^ LinkedConnector {
    PipeConnector^ get ();
    void set (PipeConnector^ value);
}

Remarks

Get this property to acquire the current linked pipe connector. If the property is nullNothingnullptra null reference (Nothing in Visual Basic), the connector has no link. Set this property to link this connector to another pipe connector. Set it to nullNothingnullptra null reference (Nothing in Visual Basic) to remove the link.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the connector to link to is the same as the connector being linked to.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if the document is not modifiable or document regeneration fails.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeConnector..::..Parameter Property
PipeConnector Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeConnector Class
PipeConnector Members
Autodesk.Revit.DB.Plumbing Namespace


SystemType Property

[image]

Revit 2013 API
PipeConnector..::..SystemType Property
PipeConnector Class See Also Send Feedback
The system type of the pipe connector.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; set; }
Visual Basic
Public Property SystemType As PipeSystemType
    Get
    Set
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
    void set (PipeSystemType value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input system type is not within the permitted range.

See Also

PipeConnector Class
Autodesk.Revit.DB.Plumbing Namespace


PipeFlowConfigurationType Enumeration

[image]

Revit 2013 API
PipeFlowConfigurationType Enumeration
See Also Send Feedback
An enumerated type listing all pipe flow configuration types for a connector

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PipeFlowConfigurationType
Visual Basic
Public Enumeration PipeFlowConfigurationType
Visual C++
public enum class PipeFlowConfigurationType

Members

Member name | Description
Calculated | pipe flow configuration is calculated.
Preset | pipe flow configuration is Preset.
System | pipe flow configuration depends on system.
Demand | pipe flow configuration depends on demand.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeFlowState Enumeration

[image]

Revit 2013 API
PipeFlowState Enumeration
See Also Send Feedback
An enumerated type listing all the pipe flow states for a pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PipeFlowState
Visual Basic
Public Enumeration PipeFlowState
Visual C++
public enum class PipeFlowState

Members

Member name | Description
LaminarState | The flow state is Laminar.
TransitionState | The flow state is Transition.
TurbulentState | The flow state is Turbulent.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeInsulation Class

[image]

Revit 2013 API
PipeInsulation Class
Members See Also Send Feedback
Represents insulation applied to the outside of a given pipe, fitting or content.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PipeInsulation : InsulationLiningBase
Visual Basic
Public Class PipeInsulation _
    Inherits InsulationLiningBase
Visual C++
public ref class PipeInsulation : public InsulationLiningBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..HostObject
Autodesk.Revit.DB..::..MEPCurve
Autodesk.Revit.DB..::..InsulationLiningBase
Autodesk.Revit.DB.Plumbing..::..PipeInsulation

See Also

PipeInsulation Members
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulation Members

[image] [image]

Revit 2013 API
PipeInsulation Members
PipeInsulation Class Methods Properties See Also Send Feedback

The PipeInsulation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of pipe insulation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeInsulation Class
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulation Methods

[image] [image]

Revit 2013 API
PipeInsulation Methods
PipeInsulation Class See Also Send Feedback

The PipeInsulation type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of pipe insulation.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FindInserts | Gets the ids of the instances inserted into this host object. (Inherited from HostObject.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeInsulation Class
Autodesk.Revit.DB.Plumbing Namespace


Create Method

[image]

Revit 2013 API
PipeInsulation..::..Create Method
PipeInsulation Class See Also Send Feedback
Creates a new instance of pipe insulation.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PipeInsulation Create(
    Document document,
    ElementId pipeOrContentElementId,
    ElementId pipeInsulationTypeId,
    double Thickness
)
Visual Basic
Public Shared Function Create ( _
    document As Document, _
    pipeOrContentElementId As ElementId, _
    pipeInsulationTypeId As ElementId, _
    Thickness As Double _
) As PipeInsulation
Visual C++
public:
static PipeInsulation^ Create(
    Document^ document,
    ElementId^ pipeOrContentElementId,
    ElementId^ pipeInsulationTypeId,
    double Thickness
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
pipeOrContentElementId
Type: Autodesk.Revit.DB..::..ElementId
The pipe, fitting, accessory ElementId to which insulation will be added.
pipeInsulationTypeId
Type: Autodesk.Revit.DB..::..ElementId
The pipe insulation type. If the input pipe insulation type is InvalidElementId, the default insulation type from the document will be used.
Thickness
Type: System..::..Double
The thickness of the insulation.

Return Value

The newly created pipe insulation.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This id does not represent a pipe, fitting, or accessory element. -or- This pipe insulation type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction.

See Also

PipeInsulation Class
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulation Properties

[image] [image]

Revit 2013 API
PipeInsulation Properties
PipeInsulation Class See Also Send Feedback

The PipeInsulation type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | The connector manager of this MEP curve. (Inherited from MEPCurve.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Diameter | The diameter of the MEP curve. (Inherited from MEPCurve.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | The height of the MEP curve. (Inherited from MEPCurve.)
Public property | HostElementId | The id of the host element for the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LevelOffset | The offset of the MEP curve. (Inherited from MEPCurve.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MEPSystem | The system of the MEP curve. (Inherited from MEPCurve.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | ReferenceLevel | The reference level of the MEP curve. (Inherited from MEPCurve.)
Public property | Thickness | Thickness of the insulation or lining element. (Inherited from InsulationLiningBase.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Width | The width of the MEP curve. (Inherited from MEPCurve.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeInsulation Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeInsulation..::..Parameter Property
PipeInsulation Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeInsulation Class
PipeInsulation Members
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulationType Class

[image]

Revit 2013 API
PipeInsulationType Class
Members See Also Send Feedback
This class represents a pipe insulation type in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PipeInsulationType : ElementType
Visual Basic
Public Class PipeInsulationType _
    Inherits ElementType
Visual C++
public ref class PipeInsulationType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..PipeInsulationType

See Also

PipeInsulationType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulationType Members

[image] [image]

Revit 2013 API
PipeInsulationType Members
PipeInsulationType Class Methods Properties See Also Send Feedback

The PipeInsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeInsulationType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulationType Methods

[image] [image]

Revit 2013 API
PipeInsulationType Methods
PipeInsulationType Class See Also Send Feedback

The PipeInsulationType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeInsulationType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeInsulationType Properties

[image] [image]

Revit 2013 API
PipeInsulationType Properties
PipeInsulationType Class See Also Send Feedback

The PipeInsulationType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeInsulationType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeInsulationType..::..Parameter Property
PipeInsulationType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeInsulationType Class
PipeInsulationType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeLossMethodType Enumeration

[image]

Revit 2013 API
PipeLossMethodType Enumeration
See Also Send Feedback
An enumerated type listing all pipe loss method types for a connector

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PipeLossMethodType
Visual Basic
Public Enumeration PipeLossMethodType
Visual C++
public enum class PipeLossMethodType

Members

Member name | Description
NotDefined | pipe loss method is undefined.
Table | pipe loss method is depend on the coefficient from table.
SpecificLoss | pipe loss method is specified.
Coefficient | pipe loss method depend on coefficient.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Class

[image]

Revit 2013 API
PipeMaterialType Class
Members See Also Send Feedback
A pipe material type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")]
public class PipeMaterialType : ElementType
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")> _
Public Class PipeMaterialType _
    Inherits ElementType
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Material instead.")]
public ref class PipeMaterialType : public ElementType

Remarks

The pipe material type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..PipeMaterialType

See Also

PipeMaterialType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Members

[image] [image]

Revit 2013 API
PipeMaterialType Members
PipeMaterialType Class Methods Properties See Also Send Feedback

The PipeMaterialType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Methods

[image] [image]

Revit 2013 API
PipeMaterialType Methods
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeMaterialType Properties

[image] [image]

Revit 2013 API
PipeMaterialType Properties
PipeMaterialType Class See Also Send Feedback

The PipeMaterialType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeMaterialType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeMaterialType..::..Parameter Property
PipeMaterialType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeMaterialType Class
PipeMaterialType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Class

[image]

Revit 2013 API
PipeScheduleType Class
Members See Also Send Feedback
A pipe schedule type in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PipeScheduleType : ElementType
Visual Basic
Public Class PipeScheduleType _
    Inherits ElementType
Visual C++
public ref class PipeScheduleType : public ElementType

Remarks

The pipe schedule type is only available in the Autodesk Revit MEP product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Plumbing..::..PipeScheduleType

See Also

PipeScheduleType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Members

[image] [image]

Revit 2013 API
PipeScheduleType Members
PipeScheduleType Class Methods Properties See Also Send Feedback

The PipeScheduleType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Methods

[image] [image]

Revit 2013 API
PipeScheduleType Methods
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeScheduleType Properties

[image] [image]

Revit 2013 API
PipeScheduleType Properties
PipeScheduleType Class See Also Send Feedback

The PipeScheduleType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeScheduleType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeScheduleType..::..Parameter Property
PipeScheduleType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeScheduleType Class
PipeScheduleType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeSegment Class

[image]

Revit 2013 API
PipeSegment Class
Members See Also Send Feedback
The PipeSegment class represents an instance of pipe segment which has the design data for routing preference. Default constructor Default destructor

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PipeSegment : Segment
Visual Basic
Public Class PipeSegment _
    Inherits Segment
Visual C++
public ref class PipeSegment : public Segment

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..Segment
Autodesk.Revit.DB.Plumbing..::..PipeSegment

See Also

PipeSegment Members
Autodesk.Revit.DB.Plumbing Namespace


PipeSegment Members

[image] [image]

Revit 2013 API
PipeSegment Members
PipeSegment Class Methods Properties See Also Send Feedback

The PipeSegment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment. (Inherited from Segment.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a PipeSegment and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSizes | Gets the defined sizes of the segment. (Inherited from Segment.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment. (Inherited from Segment.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of the segment. (Inherited from Segment.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the MaterialElem. (Inherited from Segment.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness | The roughness value for given material. (Inherited from Segment.)
Public property | ScheduleTypeId | The ElementId of the PipeScheduleType.
Public property | SizeCount | The number of size objects in the segment. (Inherited from Segment.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeSegment Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSegment Methods

[image] [image]

Revit 2013 API
PipeSegment Methods
PipeSegment Class See Also Send Feedback

The PipeSegment type exposes the following members.

Methods

 | Name | Description
Public method | AddSize | Adds a new MEPSize to the segment. (Inherited from Segment.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a PipeSegment and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSizes | Gets the defined sizes of the segment. (Inherited from Segment.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveSize | Remove the existing MEPSize with this nominal diameter from the segment. (Inherited from Segment.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeSegment Class
Autodesk.Revit.DB.Plumbing Namespace


Create Method

[image]

Revit 2013 API
PipeSegment..::..Create Method
PipeSegment Class See Also Send Feedback
Creates a new instance of a PipeSegment and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static PipeSegment Create(
    Document ADocument,
    ElementId MaterialId,
    ElementId ScheduleId,
    ICollection<MEPSize> sizeSet
)
Visual Basic
Public Shared Function Create ( _
    ADocument As Document, _
    MaterialId As ElementId, _
    ScheduleId As ElementId, _
    sizeSet As ICollection(Of MEPSize) _
) As PipeSegment
Visual C++
public:
static PipeSegment^ Create(
    Document^ ADocument,
    ElementId^ MaterialId,
    ElementId^ ScheduleId,
    ICollection<MEPSize^>^ sizeSet
)

Parameters

ADocument
Type: Autodesk.Revit.DB..::..Document
The document where the PipeSegment will be created and added.
MaterialId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the MaterialElem of the pipe segment.
ScheduleId
Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the PipeScheduleType of the pipe segment.
sizeSet
Type: System.Collections.Generic..::..ICollection<(Of <(<'MEPSize>)>)>
A set of one or more sizes.

Return Value

The newly created pipe segment element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The size list is empty. -or- The MaterialId and ScheduleId was already used by another pipe segment. Please use a new Material, a new Schedule/Type, or both.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PipeSegment Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSegment Properties

[image] [image]

Revit 2013 API
PipeSegment Properties
PipeSegment Class See Also Send Feedback

The PipeSegment type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | Description | The description of the segment. (Inherited from Segment.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | The ElementId of the MaterialElem. (Inherited from Segment.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Roughness | The roughness value for given material. (Inherited from Segment.)
Public property | ScheduleTypeId | The ElementId of the PipeScheduleType.
Public property | SizeCount | The number of size objects in the segment. (Inherited from Segment.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeSegment Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeSegment..::..Parameter Property
PipeSegment Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeSegment Class
PipeSegment Members
Autodesk.Revit.DB.Plumbing Namespace


ScheduleTypeId Property

[image]

Revit 2013 API
PipeSegment..::..ScheduleTypeId Property
PipeSegment Class See Also Send Feedback
The ElementId of the PipeScheduleType.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ScheduleTypeId { get; }
Visual Basic
Public ReadOnly Property ScheduleTypeId As ElementId
    Get
Visual C++
public:
property ElementId^ ScheduleTypeId {
    ElementId^ get ();
}

See Also

PipeSegment Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSettings Class

[image]

Revit 2013 API
PipeSettings Class
Members See Also Send Feedback
The pipe setting class.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PipeSettings : IDisposable
Visual Basic
Public Class PipeSettings _
    Implements IDisposable
Visual C++
public ref class PipeSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Plumbing..::..PipeSettings

See Also

PipeSettings Members
Autodesk.Revit.DB.Plumbing Namespace


PipeSettings Members

[image] [image]

Revit 2013 API
PipeSettings Members
PipeSettings Class Methods Properties See Also Send Feedback

The PipeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddPipeSlope | Add a pipe slope value.
Public method | Dispose | Releases all resources used by the PipeSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipeSettings | Get the pipe settings of the project.
Public method | GetPipeSlopes | Get pipe slopes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPipeSlopes | Set pipe slope values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConnectorSeparator | The connector separator string.
Public property | ConnectorTolerance | The connector tolerance value.
Public property | ElbowAngleIncrement | The value of elbow angle increment.
Public property | FittingAnnotationSize | The value of fitting annotation size.
Public property | SizePrefix | The size prefix string.
Public property | SizeSuffix | The size suffix string.
Public property | UseAnnotationScaleForSingleLineFittings | Indicates whether use annotation scale for single line fittings or not.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSettings Methods

[image] [image]

Revit 2013 API
PipeSettings Methods
PipeSettings Class See Also Send Feedback

The PipeSettings type exposes the following members.

Methods

 | Name | Description
Public method | AddPipeSlope | Add a pipe slope value.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPipeSettings | Get the pipe settings of the project.
Public method | GetPipeSlopes | Get pipe slopes.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPipeSlopes | Set pipe slope values.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


AddPipeSlope Method

[image]

Revit 2013 API
PipeSettings..::..AddPipeSlope Method
PipeSettings Class See Also Send Feedback
Add a pipe slope value.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void AddPipeSlope(
    double slope
)
Visual Basic
Public Sub AddPipeSlope ( _
    slope As Double _
)
Visual C++
public:
void AddPipeSlope(
    double slope
)

Parameters

slope
Type: System..::..Double
The pipe slope value. Revit stores the slope value as a percentage (0-100).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for slope must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Can not add a pipe slope value that was already added.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


Dispose Method

[image]

Revit 2013 API
PipeSettings..::..Dispose Method
PipeSettings Class See Also Send Feedback
Releases all resources used by the PipeSettings

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


GetPipeSettings Method

[image]

Revit 2013 API
PipeSettings..::..GetPipeSettings Method
PipeSettings Class See Also Send Feedback
Get the pipe settings of the project.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PipeSettings GetPipeSettings(
    Document aDoc
)
Visual Basic
Public Shared Function GetPipeSettings ( _
    aDoc As Document _
) As PipeSettings
Visual C++
public:
static PipeSettings^ GetPipeSettings(
    Document^ aDoc
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

The pipe settings of the project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


GetPipeSlopes Method

[image]

Revit 2013 API
PipeSettings..::..GetPipeSlopes Method
PipeSettings Class See Also Send Feedback
Get pipe slopes.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<double> GetPipeSlopes()
Visual Basic
Public Function GetPipeSlopes As IList(Of Double)
Visual C++
public:
IList<double>^ GetPipeSlopes()

Return Value

Pipe slope values. Revit stores the slope value as a percentage (0-100).

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


SetPipeSlopes Method

[image]

Revit 2013 API
PipeSettings..::..SetPipeSlopes Method
PipeSettings Class See Also Send Feedback
Set pipe slope values.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetPipeSlopes(
    IList<double> slopes
)
Visual Basic
Public Sub SetPipeSlopes ( _
    slopes As IList(Of Double) _
)
Visual C++
public:
void SetPipeSlopes(
    IList<double>^ slopes
)

Parameters

slopes
Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
Pipe slope values. Revit stores the slope value as a percentage (0-100).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Each value of the slopes must be between 0 and 100. Slope value is stored in percentage. e.g. 100 means 100%, and it is 45 degree.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This operation failed.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSettings Properties

[image] [image]

Revit 2013 API
PipeSettings Properties
PipeSettings Class See Also Send Feedback

The PipeSettings type exposes the following members.

Properties

 | Name | Description
Public property | ConnectorSeparator | The connector separator string.
Public property | ConnectorTolerance | The connector tolerance value.
Public property | ElbowAngleIncrement | The value of elbow angle increment.
Public property | FittingAnnotationSize | The value of fitting annotation size.
Public property | SizePrefix | The size prefix string.
Public property | SizeSuffix | The size suffix string.
Public property | UseAnnotationScaleForSingleLineFittings | Indicates whether use annotation scale for single line fittings or not.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


ConnectorSeparator Property

[image]

Revit 2013 API
PipeSettings..::..ConnectorSeparator Property
PipeSettings Class See Also Send Feedback
The connector separator string.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string ConnectorSeparator { get; set; }
Visual Basic
Public Property ConnectorSeparator As String
    Get
    Set
Visual C++
public:
property String^ ConnectorSeparator {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation failed.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


ConnectorTolerance Property

[image]

Revit 2013 API
PipeSettings..::..ConnectorTolerance Property
PipeSettings Class See Also Send Feedback
The connector tolerance value.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ConnectorTolerance { get; set; }
Visual Basic
Public Property ConnectorTolerance As Double
    Get
    Set
Visual C++
public:
property double ConnectorTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for dValue is not finite
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation failed.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


ElbowAngleIncrement Property

[image]

Revit 2013 API
PipeSettings..::..ElbowAngleIncrement Property
PipeSettings Class See Also Send Feedback
The value of elbow angle increment.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double ElbowAngleIncrement { get; set; }
Visual Basic
Public Property ElbowAngleIncrement As Double
    Get
    Set
Visual C++
public:
property double ElbowAngleIncrement {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for dValue is not finite

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


FittingAnnotationSize Property

[image]

Revit 2013 API
PipeSettings..::..FittingAnnotationSize Property
PipeSettings Class See Also Send Feedback
The value of fitting annotation size.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double FittingAnnotationSize { get; set; }
Visual Basic
Public Property FittingAnnotationSize As Double
    Get
    Set
Visual C++
public:
property double FittingAnnotationSize {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for dValue must be no more than 30000 feet in absolute value.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


SizePrefix Property

[image]

Revit 2013 API
PipeSettings..::..SizePrefix Property
PipeSettings Class See Also Send Feedback
The size prefix string.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string SizePrefix { get; set; }
Visual Basic
Public Property SizePrefix As String
    Get
    Set
Visual C++
public:
property String^ SizePrefix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation failed.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


SizeSuffix Property

[image]

Revit 2013 API
PipeSettings..::..SizeSuffix Property
PipeSettings Class See Also Send Feedback
The size suffix string.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string SizeSuffix { get; set; }
Visual Basic
Public Property SizeSuffix As String
    Get
    Set
Visual C++
public:
property String^ SizeSuffix {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This operation failed.

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


UseAnnotationScaleForSingleLineFittings Property

[image]

Revit 2013 API
PipeSettings..::..UseAnnotationScaleForSingleLineFittings Property
PipeSettings Class See Also Send Feedback
Indicates whether use annotation scale for single line fittings or not.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool UseAnnotationScaleForSingleLineFittings { get; set; }
Visual Basic
Public Property UseAnnotationScaleForSingleLineFittings As Boolean
    Get
    Set
Visual C++
public:
property bool UseAnnotationScaleForSingleLineFittings {
    bool get ();
    void set (bool value);
}

See Also

PipeSettings Class
Autodesk.Revit.DB.Plumbing Namespace


PipeSystemType Enumeration

[image]

Revit 2013 API
PipeSystemType Enumeration
See Also Send Feedback
An enumerated type listing all the possible pipe system types for a connector object.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PipeSystemType
Visual Basic
Public Enumeration PipeSystemType
Visual C++
public enum class PipeSystemType

Members

Member name | Description
UndefinedSystemType | Pipe System Type is UndefinedSystemClassification.
SupplyHydronic | Pipe System Type is SupplyHydronic.
ReturnHydronic | Pipe System Type is ReturnHydronic.
Sanitary | Pipe System Type is Sanitary.
Vent | Pipe System Type is Vent.
DomesticHotWater | Pipe System Type is DomesticHotWater.
DomesticColdWater | Pipe System Type is DomesticColdWater.
OtherPipe | Pipe System Type is OtherPipe.
FireProtectWet | Pipe System Type is FireProtectWet.
FireProtectDry | Pipe System Type is FireProtectDry.
FireProtectPreaction | Pipe System Type is FireProtectPreaction.
FireProtectOther | Pipe System Type is FireProtectOther.
Fitting | Pipe System Type is Fitting.
Global | Pipe System Type is Global.

See Also

Autodesk.Revit.DB.Plumbing Namespace


PipeType Class

[image]

Revit 2013 API
PipeType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PipeType : MEPCurveType
Visual Basic
Public Class PipeType _
    Inherits MEPCurveType
Visual C++
public ref class PipeType : public MEPCurveType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..HostObjAttributes
Autodesk.Revit.DB..::..MEPCurveType
Autodesk.Revit.DB.Plumbing..::..PipeType

See Also

PipeType Members
Autodesk.Revit.DB.Plumbing Namespace


PipeType Members

[image] [image]

Revit 2013 API
PipeType Members
PipeType Class Methods Properties See Also Send Feedback

The PipeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Class | The schedule type of the pipe type.
Public property | ConnectionType | The connection type of the pipe type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Material | Obsolete. The material type of the pipe type.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | Obsolete. The roughness of the pipe type. (Overrides MEPCurveType..::..Roughness.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeType Methods

[image] [image]

Revit 2013 API
PipeType Methods
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCompoundStructure | Returns an object that represents the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetCompoundStructure | Sets the compound structure of the element. (Inherited from HostObjAttributes.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipeType Properties

[image] [image]

Revit 2013 API
PipeType Properties
PipeType Class See Also Send Feedback

The PipeType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | Class | The schedule type of the pipe type.
Public property | ConnectionType | The connection type of the pipe type.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Cross | The default cross fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elbow | The default elbow fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Material | Obsolete. The material type of the pipe type.
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MultiShapeTransition | The default multi shape transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PreferredJunctionType | The preferred junction type of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Roughness | Obsolete. The roughness of the pipe type. (Overrides MEPCurveType..::..Roughness.)
Public property | RoutingPreferenceManager | The RoutingPreferenceManager for the MEPCurveType; (Inherited from MEPCurveType.)
Public property | Tap | The default tap fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Tee | The default tee fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Transition | The default transition fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | Union | The default union fitting of the MEP curve type. (Inherited from MEPCurveType.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Class Property

[image]

Revit 2013 API
PipeType..::..Class Property
PipeType Class See Also Send Feedback
The schedule type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeScheduleType Class { get; }
Visual Basic
Public ReadOnly Property Class As PipeScheduleType
    Get
Visual C++
public:
property PipeScheduleType^ Class {
    PipeScheduleType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


ConnectionType Property

[image]

Revit 2013 API
PipeType..::..ConnectionType Property
PipeType Class See Also Send Feedback
The connection type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeConnectionType ConnectionType { get; }
Visual Basic
Public ReadOnly Property ConnectionType As PipeConnectionType
    Get
Visual C++
public:
property PipeConnectionType^ ConnectionType {
    PipeConnectionType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Material Property

[image]

Revit 2013 API
PipeType..::..Material Property
PipeType Class See Also Send Feedback
The material type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")]
public PipeMaterialType Material { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")> _
Public ReadOnly Property Material As PipeMaterialType
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please use Autodesk::Revit::DB::Plumbing::PipeSegment::MaterialId instead.")]
public:
property PipeMaterialType^ Material {
    PipeMaterialType^ get ();
}

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipeType..::..Parameter Property
PipeType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipeType Class
PipeType Members
Autodesk.Revit.DB.Plumbing Namespace


Roughness Property

[image]

Revit 2013 API
PipeType..::..Roughness Property
PipeType Class See Also Send Feedback
The roughness of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")]
public override double Roughness { set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")> _
Public Overrides WriteOnly Property Roughness As Double
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013.  Please use Segment::Roughness instead.")]
public:
virtual property double Roughness {
    void set (double value) override;
}

Remarks

set for this property will always throw an exception.

See Also

PipeType Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Class

[image]

Revit 2013 API
PipingSystem Class
Members See Also Send Feedback
Default constructor Default destructor

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class PipingSystem : MEPSystem
Visual Basic
Public Class PipingSystem _
    Inherits MEPSystem
Visual C++
public ref class PipingSystem : public MEPSystem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..MEPSystem
Autodesk.Revit.DB.Plumbing..::..PipingSystem

See Also

PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Members

[image] [image]

Revit 2013 API
PipingSystem Members
PipingSystem Class Methods Properties See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a piping system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a piping system and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | FixtureUnits | Indicates the computed total fixture units for the piping system.
Public property | Flow | Indicates the computed total flow for the piping system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PipingNetwork | Pipes and fittings which are contained in this system.
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | StaticPressure | Indicates the computed static pressure for the piping system.
Public property | SystemType | The type of this piping system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Methods

[image] [image]

Revit 2013 API
PipingSystem Methods
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add elements into the system and connect them with the system using given connectors. (Inherited from MEPSystem.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create(Document, ElementId) | Creates a new instance of a piping system and adds it to the document.
 | Create(Document, ElementId, String) | Creates a new instance of a piping system and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCriticalPathSectionNumbers | Obtains a list of the critical path section numbers. (Inherited from MEPSystem.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetSectionByIndex | Get the section from the index. (Inherited from MEPSystem.)
Public method | GetSectionByNumber | Get the Section from section number; (Inherited from MEPSystem.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Create Method

[image] [image]

Revit 2013 API
PipingSystem..::..Create Method
PipingSystem Class See Also Send Feedback

Overload List

Name | Description
Create(Document, ElementId) | Creates a new instance of a piping system and adds it to the document.
Create(Document, ElementId, String) | Creates a new instance of a piping system and adds it to the document.

See Also

PipingSystem Class
PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


Create Method (Document, ElementId)

[image]

Revit 2013 API
PipingSystem..::..Create Method (Document, ElementId)
PipingSystem Class See Also Send Feedback
Creates a new instance of a piping system and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static PipingSystem Create(
    Document ADocument,
    ElementId typeId
)
Visual Basic
Public Shared Function Create ( _
    ADocument As Document, _
    typeId As ElementId _
) As PipingSystem
Visual C++
public:
static PipingSystem^ Create(
    Document^ ADocument,
    ElementId^ typeId
)

Parameters

ADocument
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The identifier of this piping system element's type.

Return Value

The newly created piping system element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The typeId is not an element id for a valid piping system type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PipingSystem Class
Create Overload
Autodesk.Revit.DB.Plumbing Namespace


Create Method (Document, ElementId, String)

[image]

Revit 2013 API
PipingSystem..::..Create Method (Document, ElementId, String)
PipingSystem Class See Also Send Feedback
Creates a new instance of a piping system and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static PipingSystem Create(
    Document ADocument,
    ElementId typeId,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADocument As Document, _
    typeId As ElementId, _
    name As String _
) As PipingSystem
Visual C++
public:
static PipingSystem^ Create(
    Document^ ADocument,
    ElementId^ typeId,
    String^ name
)

Parameters

ADocument
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
typeId
Type: Autodesk.Revit.DB..::..ElementId
The identifier of this piping system element's type.
name
Type: System..::..String
The name of the piping system to be created.

Return Value

The newly created piping system element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The typeId is not an element id for a valid piping system type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also

PipingSystem Class
Create Overload
Autodesk.Revit.DB.Plumbing Namespace


Remove Method

[image] [image]

Revit 2013 API
PipingSystem..::..Remove Method
PipingSystem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Remove(ICollection<(Of <<'(ElementId>)>>)) | Remove elements from system. (Inherited from MEPSystem.)
Public method | Remove(ElementSet) | Obsolete. Remove elements from system. (Inherited from MEPSystem.)

See Also

PipingSystem Class
PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


PipingSystem Properties

[image] [image]

Revit 2013 API
PipingSystem Properties
PipingSystem Class See Also Send Feedback

The PipingSystem type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BaseEquipment | The base panel or equipment of the system. (Inherited from MEPSystem.)
Public property | BaseEquipmentConnector | The connector within base equipment which is used to connect with system.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | ConnectorManager | Connector manager of the system. (Inherited from MEPSystem.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Elements | Terminal elements in the system. (Inherited from MEPSystem.)
Public property | FixtureUnits | Indicates the computed total fixture units for the piping system.
Public property | Flow | Indicates the computed total flow for the piping system.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsDefaultSystem | Indicates if the system is a default system or not. (Inherited from MEPSystem.)
Public property | IsEmpty | Indicates if the system is empty or not. (Inherited from MEPSystem.)
Public property | IsValid | Indicates if the system is valid or not. atom AtomValidateSystem default false setter setIsValid public_api; (Inherited from MEPSystem.)
Public property | IsWellConnected | Indicates if the system is well connected or not.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | PipingNetwork | Pipes and fittings which are contained in this system.
Public property | PressureLossOfCriticalPath | The total pressure loss of the sections in critical path. (Inherited from MEPSystem.)
Public property | SectionsCount | The number of sections. (Inherited from MEPSystem.)
Public property | StaticPressure | Indicates the computed static pressure for the piping system.
Public property | SystemType | The type of this piping system.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


BaseEquipmentConnector Property

[image]

Revit 2013 API
PipingSystem..::..BaseEquipmentConnector Property
PipingSystem Class See Also Send Feedback
The connector within base equipment which is used to connect with system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Connector BaseEquipmentConnector { get; set; }
Visual Basic
Public Property BaseEquipmentConnector As Connector
    Get
    Set
Visual C++
public:
property Connector^ BaseEquipmentConnector {
    Connector^ get ();
    void set (Connector^ value);
}

Remarks

Setting this property to nullNothingnullptra null reference (Nothing in Visual Basic) will disconnect base equipment from system.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when assigning a connector which is used in a system, or when the connector's owner is not of type 'mechanical equipment'.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the set operation failed.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


FixtureUnits Property

[image]

Revit 2013 API
PipingSystem..::..FixtureUnits Property
PipingSystem Class See Also Send Feedback
Indicates the computed total fixture units for the piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double FixtureUnits { get; }
Visual Basic
Public ReadOnly Property FixtureUnits As Double
    Get
Visual C++
public:
property double FixtureUnits {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Flow Property

[image]

Revit 2013 API
PipingSystem..::..Flow Property
PipingSystem Class See Also Send Feedback
Indicates the computed total flow for the piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Flow { get; }
Visual Basic
Public ReadOnly Property Flow As Double
    Get
Visual C++
public:
property double Flow {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


IsWellConnected Property

[image]

Revit 2013 API
PipingSystem..::..IsWellConnected Property
PipingSystem Class See Also Send Feedback
Indicates if the system is well connected or not.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsWellConnected { get; }
Visual Basic
Public ReadOnly Property IsWellConnected As Boolean
    Get
Visual C++
public:
property bool IsWellConnected {
    bool get ();
}

Remarks

If the system is not well connected, parameters which need to be calculated are invalid.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipingSystem..::..Parameter Property
PipingSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipingSystem Class
PipingSystem Members
Autodesk.Revit.DB.Plumbing Namespace


PipingNetwork Property

[image]

Revit 2013 API
PipingSystem..::..PipingNetwork Property
PipingSystem Class See Also Send Feedback
Pipes and fittings which are contained in this system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementSet PipingNetwork { get; }
Visual Basic
Public ReadOnly Property PipingNetwork As ElementSet
    Get
Visual C++
public:
property ElementSet^ PipingNetwork {
    ElementSet^ get ();
}

Remarks

The return value doesn't include mechanical equipment elements. The pipes and fittings are not returned in any particular order.

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


StaticPressure Property

[image]

Revit 2013 API
PipingSystem..::..StaticPressure Property
PipingSystem Class See Also Send Feedback
Indicates the computed static pressure for the piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double StaticPressure { get; }
Visual Basic
Public ReadOnly Property StaticPressure As Double
    Get
Visual C++
public:
property double StaticPressure {
    double get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


SystemType Property

[image]

Revit 2013 API
PipingSystem..::..SystemType Property
PipingSystem Class See Also Send Feedback
The type of this piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PipeSystemType SystemType { get; }
Visual Basic
Public ReadOnly Property SystemType As PipeSystemType
    Get
Visual C++
public:
property PipeSystemType SystemType {
    PipeSystemType get ();
}

See Also

PipingSystem Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystemType Class

[image]

Revit 2013 API
PipingSystemType Class
Members See Also Send Feedback
Base class for piping system types

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PipingSystemType : MEPSystemType
Visual Basic
Public Class PipingSystemType _
    Inherits MEPSystemType
Visual C++
public ref class PipingSystemType : public MEPSystemType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..MEPSystemType
Autodesk.Revit.DB.Plumbing..::..PipingSystemType

See Also

PipingSystemType Members
Autodesk.Revit.DB.Plumbing Namespace


PipingSystemType Members

[image] [image]

Revit 2013 API
PipingSystemType Members
PipingSystemType Class Methods Properties See Also Send Feedback

The PipingSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a piping system type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateRiseDropSymbolType | Confirm the parameter is a valid piping rise/drop symbol type

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type; (Inherited from MEPSystemType.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type; (Inherited from MEPSystemType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlowConversionMethod |
Public property | FluidTemperature | Fluid Temperature
Public property | FluidType | Fluid Type
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system. (Inherited from MEPSystemType.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system. (Inherited from MEPSystemType.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SingleLineBendDropType | Symbol for a 1 line drop
Public property | SingleLineBendRiseType | Symbol for a 1 line rise
Public property | SingleLineJunctionDropType | Symbol for a 1 line junction drop
Public property | SingleLineJunctionRiseType | Symbol for a 1 line junction rise
Public property | SystemClassification | Identifies the classification for the system type; (Inherited from MEPSystemType.)
Public property | TwoLineDropType | Symbol for a 2 line drop
Public property | TwoLineRiseType | Symbol for a 2 line rise
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystemType Methods

[image] [image]

Revit 2013 API
PipingSystemType Methods
PipingSystemType Class See Also Send Feedback

The PipingSystemType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a piping system type and adds it to the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ValidateRiseDropSymbolType | Confirm the parameter is a valid piping rise/drop symbol type

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


Create Method

[image]

Revit 2013 API
PipingSystemType..::..Create Method
PipingSystemType Class See Also Send Feedback
Creates a new instance of a piping system type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PipingSystemType Create(
    Document ADoc,
    MEPSystemClassification systemClassification,
    string name
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document, _
    systemClassification As MEPSystemClassification, _
    name As String _
) As PipingSystemType
Visual C++
public:
static PipingSystemType^ Create(
    Document^ ADoc,
    MEPSystemClassification systemClassification,
    String^ name
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document
The document where the element will be created and added.
systemClassification
Type: Autodesk.Revit.DB..::..MEPSystemClassification
The classification for the piping system type to be created
name
Type: System..::..String
The name of the piping system type to be created.

Return Value

The newly created piping system type element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The system classification is not valid for the domain of this system type.

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


ValidateRiseDropSymbolType Method

[image]

Revit 2013 API
PipingSystemType..::..ValidateRiseDropSymbolType Method
PipingSystemType Class See Also Send Feedback
Confirm the parameter is a valid piping rise/drop symbol type

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool ValidateRiseDropSymbolType(
    RiseDropSymbol risedropType
)
Visual Basic
Public Function ValidateRiseDropSymbolType ( _
    risedropType As RiseDropSymbol _
) As Boolean
Visual C++
public:
bool ValidateRiseDropSymbolType(
    RiseDropSymbol risedropType
)

Parameters

risedropType
Type: Autodesk.Revit.DB.Mechanical..::..RiseDropSymbol

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


PipingSystemType Properties

[image] [image]

Revit 2013 API
PipingSystemType Properties
PipingSystemType Class See Also Send Feedback

The PipingSystemType type exposes the following members.

Properties

 | Name | Description
Public property | Abbreviation | Identifies the abbreviation, the short name, for the system type; (Inherited from MEPSystemType.)
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | CalculationLevel | Identifies the calculation level for the system type; (Inherited from MEPSystemType.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FlowConversionMethod |
Public property | FluidTemperature | Fluid Temperature
Public property | FluidType | Fluid Type
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineColor | Indicates the color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LinePatternId | Indicates the line pattern color that should override the line color for all components in the system. (Inherited from MEPSystemType.)
Public property | LineWeight | Indicates the weight that should override the line weight for all components in the system. (Inherited from MEPSystemType.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MaterialId | Indicates the material id that should override the material for all components in the system. (Inherited from MEPSystemType.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SingleLineBendDropType | Symbol for a 1 line drop
Public property | SingleLineBendRiseType | Symbol for a 1 line rise
Public property | SingleLineJunctionDropType | Symbol for a 1 line junction drop
Public property | SingleLineJunctionRiseType | Symbol for a 1 line junction rise
Public property | SystemClassification | Identifies the classification for the system type; (Inherited from MEPSystemType.)
Public property | TwoLineDropType | Symbol for a 2 line drop
Public property | TwoLineRiseType | Symbol for a 2 line rise
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


FlowConversionMethod Property

[image]

Revit 2013 API
PipingSystemType..::..FlowConversionMethod Property
PipingSystemType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public FlowConversionMode FlowConversionMethod { get; set; }
Visual Basic
Public Property FlowConversionMethod As FlowConversionMode
    Get
    Set
Visual C++
public:
property FlowConversionMode FlowConversionMethod {
    FlowConversionMode get ();
    void set (FlowConversionMode value);
}

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidTemperature Property

[image]

Revit 2013 API
PipingSystemType..::..FluidTemperature Property
PipingSystemType Class See Also Send Feedback
Fluid Temperature

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double FluidTemperature { get; set; }
Visual Basic
Public Property FluidTemperature As Double
    Get
    Set
Visual C++
public:
property double FluidTemperature {
    double get ();
    void set (double value);
}

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


FluidType Property

[image]

Revit 2013 API
PipingSystemType..::..FluidType Property
PipingSystemType Class See Also Send Feedback
Fluid Type

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId FluidType { get; set; }
Visual Basic
Public Property FluidType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ FluidType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: fluidTypeId is not a fluid type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


Parameter Property

[image] [image]

Revit 2013 API
PipingSystemType..::..Parameter Property
PipingSystemType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PipingSystemType Class
PipingSystemType Members
Autodesk.Revit.DB.Plumbing Namespace


SingleLineBendDropType Property

[image]

Revit 2013 API
PipingSystemType..::..SingleLineBendDropType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 1 line drop

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol SingleLineBendDropType { get; set; }
Visual Basic
Public Property SingleLineBendDropType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol SingleLineBendDropType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


SingleLineBendRiseType Property

[image]

Revit 2013 API
PipingSystemType..::..SingleLineBendRiseType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 1 line rise

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol SingleLineBendRiseType { get; set; }
Visual Basic
Public Property SingleLineBendRiseType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol SingleLineBendRiseType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


SingleLineJunctionDropType Property

[image]

Revit 2013 API
PipingSystemType..::..SingleLineJunctionDropType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 1 line junction drop

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol SingleLineJunctionDropType { get; set; }
Visual Basic
Public Property SingleLineJunctionDropType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol SingleLineJunctionDropType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


SingleLineJunctionRiseType Property

[image]

Revit 2013 API
PipingSystemType..::..SingleLineJunctionRiseType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 1 line junction rise

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol SingleLineJunctionRiseType { get; set; }
Visual Basic
Public Property SingleLineJunctionRiseType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol SingleLineJunctionRiseType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


TwoLineDropType Property

[image]

Revit 2013 API
PipingSystemType..::..TwoLineDropType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 2 line drop

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol TwoLineDropType { get; set; }
Visual Basic
Public Property TwoLineDropType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol TwoLineDropType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


TwoLineRiseType Property

[image]

Revit 2013 API
PipingSystemType..::..TwoLineRiseType Property
PipingSystemType Class See Also Send Feedback
Symbol for a 2 line rise

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RiseDropSymbol TwoLineRiseType { get; set; }
Visual Basic
Public Property TwoLineRiseType As RiseDropSymbol
    Get
    Set
Visual C++
public:
property RiseDropSymbol TwoLineRiseType {
    RiseDropSymbol get ();
    void set (RiseDropSymbol value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property:

See Also

PipingSystemType Class
Autodesk.Revit.DB.Plumbing Namespace


PlumbingUtils Class

[image]

Revit 2013 API
PlumbingUtils Class
Members See Also Send Feedback
General utility methods in the Autodesk Revit MEP product.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PlumbingUtils : IDisposable
Visual Basic
Public Class PlumbingUtils _
    Implements IDisposable
Visual C++
public ref class PlumbingUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Plumbing..::..PlumbingUtils

See Also

PlumbingUtils Members
Autodesk.Revit.DB.Plumbing Namespace


PlumbingUtils Members

[image] [image]

Revit 2013 API
PlumbingUtils Members
PlumbingUtils Class Methods See Also Send Feedback

The PlumbingUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectPipePlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertPipePlaceholders | Converts a collection of pipe placeholder elements into pipe elements.
Public method | Dispose | Releases all resources used by the PlumbingUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlumbingUtils Class
Autodesk.Revit.DB.Plumbing Namespace


PlumbingUtils Methods

[image] [image]

Revit 2013 API
PlumbingUtils Methods
PlumbingUtils Class See Also Send Feedback

The PlumbingUtils type exposes the following members.

Methods

 | Name | Description
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.
 | ConnectPipePlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.
 | ConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
 | ConnectPipePlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.
 | ConvertPipePlaceholders | Converts a collection of pipe placeholder elements into pipe elements.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PlumbingUtils Class
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtCross Method

[image] [image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtCross Method
PlumbingUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
ConnectPipePlaceholdersAtCross(Document, ElementId, ElementId, ElementId) | Connects placeholders that looks like Cross connection.
ConnectPipePlaceholdersAtCross(Document, Connector, Connector, Connector, Connector) | Connects placeholders that looks like Cross connection.

See Also

PlumbingUtils Class
PlumbingUtils Members
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtCross Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtCross Method (Document, ElementId, ElementId)
PlumbingUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtCross(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtCross ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtCross(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of pipe placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of pipe placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders must intersect each other. If connection succeeds, a new placeholder is created. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtCross Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtCross Method (Document, ElementId, ElementId, ElementId)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtCross Method (Document, ElementId, ElementId, ElementId)
PlumbingUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtCross(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id,
    ElementId placeholder3Id
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtCross ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId, _
    placeholder3Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtCross(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id,
    ElementId^ placeholder3Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of pipe placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of pipe placeholder that intersects with first one.
placeholder3Id
Type: Autodesk.Revit.DB..::..ElementId
The third element Id of pipe placeholder that intersects with first one.

Return Value

True if connection succeeds, false otherwise.

Remarks

If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The element id placeholder3Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder3Id does not connect on the curve placeholder1Id or vice versa. -or- The curve placeholder2Id and placeholder3Id are not collinear.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtCross Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtCross Method (Document, Connector, Connector, Connector, Connector)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtCross Method (Document, Connector, Connector, Connector, Connector)
PlumbingUtils Class See Also Send Feedback
Connects placeholders that looks like Cross connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtCross(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3,
    Connector connector4
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtCross ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector, _
    connector4 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtCross(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3,
    Connector^ connector4
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the forth.
connector4
Type: Autodesk.Revit.DB..::..Connector
The fourth end connector of placeholder to be connected to the third.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may or may not have physical connection. However a) The ends of four connectors should intersect at same point; b) the first and second placeholders should be collinear each other; c) the third and fourth placeholders should be collinear each other and d) the third and fourth should have intersection with first or second placeholder. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtCross Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtElbow Method

[image] [image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtElbow Method
PlumbingUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectPipePlaceholdersAtElbow(Document, Connector, Connector) | Connects placeholders that looks like elbow connection.
ConnectPipePlaceholdersAtElbow(Document, ElementId, ElementId) | Connects placeholders that looks like elbow connection.

See Also

PlumbingUtils Class
PlumbingUtils Members
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtElbow Method (Document, Connector, Connector)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtElbow Method (Document, Connector, Connector)
PlumbingUtils Class See Also Send Feedback
Connects placeholders that looks like elbow connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtElbow(
    Document document,
    Connector connector1,
    Connector connector2
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtElbow ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtElbow(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to.

Return Value

True if connection succeeds, false otherwise.

Remarks

The placeholders may have physical connection or may not connect at all. In the latter case, the first one connects to the end of second one. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtElbow Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtElbow Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtElbow Method (Document, ElementId, ElementId)
PlumbingUtils Class See Also Send Feedback
Connects placeholders that looks like elbow connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtElbow(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtElbow ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtElbow(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The element Id of pipe placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The element Id of pipe placeholder.

Return Value

True if connection succeeds, false otherwise.

Remarks

There must be a physical end connection of placeholders. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder1Id and placeholder2Id are not physically connected.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtElbow Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtTee Method

[image] [image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtTee Method
PlumbingUtils Class See Also Send Feedback

Overload List

Name | Description
ConnectPipePlaceholdersAtTee(Document, ElementId, ElementId) | Connects two placeholders that looks like Tee connection.
ConnectPipePlaceholdersAtTee(Document, Connector, Connector, Connector) | Connects three placeholders that looks like Tee connection.

See Also

PlumbingUtils Class
PlumbingUtils Members
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtTee Method (Document, ElementId, ElementId)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtTee Method (Document, ElementId, ElementId)
PlumbingUtils Class See Also Send Feedback
Connects two placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtTee(
    Document document,
    ElementId placeholder1Id,
    ElementId placeholder2Id
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtTee ( _
    document As Document, _
    placeholder1Id As ElementId, _
    placeholder2Id As ElementId _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtTee(
    Document^ document,
    ElementId^ placeholder1Id,
    ElementId^ placeholder2Id
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholder1Id
Type: Autodesk.Revit.DB..::..ElementId
The first element Id of pipe placeholder.
placeholder2Id
Type: Autodesk.Revit.DB..::..ElementId
The second element Id of pipe placeholder which connects to first.

Return Value

True if connection succeeds, false otherwise.

Remarks

The second placeholder must have physically connection with the first one. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtTee Overload
Autodesk.Revit.DB.Plumbing Namespace


ConnectPipePlaceholdersAtTee Method (Document, Connector, Connector, Connector)

[image]

Revit 2013 API
PlumbingUtils..::..ConnectPipePlaceholdersAtTee Method (Document, Connector, Connector, Connector)
PlumbingUtils Class See Also Send Feedback
Connects three placeholders that looks like Tee connection.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool ConnectPipePlaceholdersAtTee(
    Document document,
    Connector connector1,
    Connector connector2,
    Connector connector3
)
Visual Basic
Public Shared Function ConnectPipePlaceholdersAtTee ( _
    document As Document, _
    connector1 As Connector, _
    connector2 As Connector, _
    connector3 As Connector _
) As Boolean
Visual C++
public:
static bool ConnectPipePlaceholdersAtTee(
    Document^ document,
    Connector^ connector1,
    Connector^ connector2,
    Connector^ connector3
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
connector1
Type: Autodesk.Revit.DB..::..Connector
The first end connector of placeholder to be connected to the second.
connector2
Type: Autodesk.Revit.DB..::..Connector
The second end connector of placeholder to be connected to the first.
connector3
Type: Autodesk.Revit.DB..::..Connector
The third end connector of placeholder to be connected to the first or second.

Return Value

True if connection succeeds, false otherwise.

Remarks

The three placeholders may or may not have physically connections. However, the first one should be collinear with the second and third one must have intersection with first and second. If first placeholder and second placeholder have the same size, the second one is merged with first one and original placeholder element will be invalid. If connection fails, the placeholders cannot be physically connected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The owner of connector is not pipe placeholder. -or- The owners of connectors belong to different types of system. -or- The curves of connector1 and connector2 are not collinear or either the connecto1 or connector2 is not connector of curve end.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
ConnectPipePlaceholdersAtTee Overload
Autodesk.Revit.DB.Plumbing Namespace


ConvertPipePlaceholders Method

[image]

Revit 2013 API
PlumbingUtils..::..ConvertPipePlaceholders Method
PlumbingUtils Class See Also Send Feedback
Converts a collection of pipe placeholder elements into pipe elements.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static ICollection<ElementId> ConvertPipePlaceholders(
    Document document,
    ICollection<ElementId> placeholderIds
)
Visual Basic
Public Shared Function ConvertPipePlaceholders ( _
    document As Document, _
    placeholderIds As ICollection(Of ElementId) _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ ConvertPipePlaceholders(
    Document^ document,
    ICollection<ElementId^>^ placeholderIds
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
placeholderIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
A collection of element IDs of pipe placeholders.

Return Value

A collection of element IDs of pipe and fitting.

Remarks

Once conversion succeeds, the pipe placeholder elements are deleted. The new pipe and fitting elements are created and connections are established.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given element IDs set is empty. -or- The given element ids (placeholderIds) are not pipe placeholders. -or- The elements belong to different types of system.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PlumbingUtils Class
Autodesk.Revit.DB.Plumbing Namespace


Dispose Method

[image]

Revit 2013 API
PlumbingUtils..::..Dispose Method
PlumbingUtils Class See Also Send Feedback
Releases all resources used by the PlumbingUtils

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PlumbingUtils Class
Autodesk.Revit.DB.Plumbing Namespace


Autodesk.Revit.DB.PointClouds Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.PointClouds Namespace
Send Feedback

Classes

 | Class | Description
Public class | PointCloudEngineRegistry | This class supports registration of custom Point Cloud Engines in a Revit session.
Public class | PointCloudFilter | A class used to describe the criteria an application desires when obtaining members of a point cloud.
Public class | PointCloudFilterFactory | A factory class for creating point cloud filters.
Public class | PointCloudFilterUtils | Utilities specific to point cloud filters.
Public class | PointCollection | A class that represents a set of points created and returned by Revit in response to a query.
Public class | PointIterator | A class used to iterate individual points in a PointCollection.

Structures

 | Structure | Description
Public structure | CloudPoint | Represents a point obtained from a Point cloud.

Interfaces

 | Interface | Description
Public interface | IPointCloudAccess | An interface that provides functionality for working with an individual Point Cloud.
Public interface | IPointCloudEngine | An interface that controls the behavior of the link from Revit to a custom Point Cloud Engine.
Public interface | IPointSetIterator | An interface that Revit will call when iterating through sets of points on the engine.

Enumerations

 | Enumeration | Description
Public enumeration | PointCloudColorEncoding | The color encodings supported by Revit point clouds.


CloudPoint Structure

[image]

Revit 2013 API
CloudPoint Structure
Members See Also Send Feedback
Represents a point obtained from a Point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public struct CloudPoint
Visual Basic
Public Structure CloudPoint
Visual C++
public value class CloudPoint

See Also

CloudPoint Members
Autodesk.Revit.DB.PointClouds Namespace


CloudPoint Members

[image] [image]

Revit 2013 API
CloudPoint Members
CloudPoint Structure Constructors Methods Operators Fields See Also Send Feedback

The CloudPoint type exposes the following members.

Constructors

 | Name | Description
Public method | CloudPoint | Creates a new cloud point.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(CloudPoint to XYZ) | Creates an XYZ object from this point cloud.

Fields

 | Name | Description
Public field | Color | The color
Public field | X | The X coordinate
Public field | Y | The Y coordinate
Public field | Z | The Z coordinate

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


CloudPoint Constructor

[image]

Revit 2013 API
CloudPoint Constructor
CloudPoint Structure See Also Send Feedback
Creates a new cloud point.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CloudPoint(
    float x,
    float y,
    float z,
    int color
)
Visual Basic
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single, _
    color As Integer _
)
Visual C++
public:
CloudPoint(
    float x,
    float y,
    float z,
    int color
)

Parameters

x
Type: System..::..Single
The X coordinate.
y
Type: System..::..Single
The Y coordinate.
z
Type: System..::..Single
The Z coordinate.
color
Type: System..::..Int32
The color.

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


CloudPoint Fields

[image] [image]

Revit 2013 API
CloudPoint Fields
CloudPoint Structure See Also Send Feedback

The CloudPoint type exposes the following members.

Fields

 | Name | Description
Public field | Color | The color
Public field | X | The X coordinate
Public field | Y | The Y coordinate
Public field | Z | The Z coordinate

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


Color Field

[image]

Revit 2013 API
CloudPoint..::..Color Field
CloudPoint Structure See Also Send Feedback
The color

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Color
Visual Basic
Public Color As Integer
Visual C++
public:
int Color

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


X Field

[image]

Revit 2013 API
CloudPoint..::..X Field
CloudPoint Structure See Also Send Feedback
The X coordinate

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public float X
Visual Basic
Public X As Single
Visual C++
public:
float X

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


Y Field

[image]

Revit 2013 API
CloudPoint..::..Y Field
CloudPoint Structure See Also Send Feedback
The Y coordinate

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public float Y
Visual Basic
Public Y As Single
Visual C++
public:
float Y

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


Z Field

[image]

Revit 2013 API
CloudPoint..::..Z Field
CloudPoint Structure See Also Send Feedback
The Z coordinate

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public float Z
Visual Basic
Public Z As Single
Visual C++
public:
float Z

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


CloudPoint Methods

[image] [image]

Revit 2013 API
CloudPoint Methods
CloudPoint Structure See Also Send Feedback

The CloudPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


CloudPoint Type Conversions

[image] [image]

Revit 2013 API
CloudPoint Type Conversions
CloudPoint Structure See Also Send Feedback

The CloudPoint type exposes the following members.

Operators

Name | Description
ImplicitWideningImplicitImplicitImplicit(CloudPoint to XYZ) | Creates an XYZ object from this point cloud.

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


Implicit Conversion (CloudPoint to XYZ)

[image]

Revit 2013 API
CloudPoint ImplicitWideningImplicitImplicitImplicit Conversion (CloudPoint to XYZ)
CloudPoint Structure See Also Send Feedback
Creates an XYZ object from this point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static implicit operator XYZ (
    CloudPoint cp
)
Visual Basic
Public Shared Widening Operator CType ( _
    cp As CloudPoint _
) As XYZ
Visual C++
static implicit operator XYZ^ (
    CloudPoint cp
)

Parameters

cp
Type: Autodesk.Revit.DB.PointClouds..::..CloudPoint

See Also

CloudPoint Structure
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudAccess Interface

[image]

Revit 2013 API
IPointCloudAccess Interface
Members See Also Send Feedback
An interface that provides functionality for working with an individual Point Cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public interface IPointCloudAccess
Visual Basic
Public Interface IPointCloudAccess
Visual C++
public interface class IPointCloudAccess

Remarks

An instance of this interface is obtained from the associated point cloud engine when the engine's CreatePointCloudAccess method is called.

See Also

IPointCloudAccess Members
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudAccess Members

[image] [image]

Revit 2013 API
IPointCloudAccess Members
IPointCloudAccess Interface Methods See Also Send Feedback

The IPointCloudAccess type exposes the following members.

Methods

 | Name | Description
Public method | CreatePointSetIterator(PointCloudFilter, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | CreatePointSetIterator(PointCloudFilter, Double, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | Free | Completes the lifetime of the object providing this interface.
Public method | GetColorEncoding | Returns the encoding used by points in this point cloud.
Public method | GetExtent | Implement this method to returns an object that contains the bounding box of the entire point cloud, aligned to the point cloud coordinate system.
Public method | GetName | Implement this method to return the name of the point cloud that will be used when Revit needs to refer to the point cloud type, e.g. in the Manage Links dialog or in the Type Properties dialog.
Public method | GetOffset | Implement this method to return the offset stored in the point cloud.
Public method | GetUnitsToFeetConversionFactor | Implement this method to return the conversion factor from the units of the point cloud to feet.
Public method | ReadPoints | Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudAccess Methods

[image] [image]

Revit 2013 API
IPointCloudAccess Methods
IPointCloudAccess Interface See Also Send Feedback

The IPointCloudAccess type exposes the following members.

Methods

 | Name | Description
Public method | CreatePointSetIterator(PointCloudFilter, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | CreatePointSetIterator(PointCloudFilter, Double, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | Free | Completes the lifetime of the object providing this interface.
Public method | GetColorEncoding | Returns the encoding used by points in this point cloud.
Public method | GetExtent | Implement this method to returns an object that contains the bounding box of the entire point cloud, aligned to the point cloud coordinate system.
Public method | GetName | Implement this method to return the name of the point cloud that will be used when Revit needs to refer to the point cloud type, e.g. in the Manage Links dialog or in the Type Properties dialog.
Public method | GetOffset | Implement this method to return the offset stored in the point cloud.
Public method | GetUnitsToFeetConversionFactor | Implement this method to return the conversion factor from the units of the point cloud to feet.
Public method | ReadPoints | Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


CreatePointSetIterator Method

[image] [image]

Revit 2013 API
IPointCloudAccess..::..CreatePointSetIterator Method
IPointCloudAccess Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreatePointSetIterator(PointCloudFilter, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.
Public method | CreatePointSetIterator(PointCloudFilter, Double, ElementId) | Implement this method to return an iterator for iterating over blocks of this point cloud.

See Also

IPointCloudAccess Interface
IPointCloudAccess Members
Autodesk.Revit.DB.PointClouds Namespace


CreatePointSetIterator Method (PointCloudFilter, ElementId)

[image]

Revit 2013 API
IPointCloudAccess..::..CreatePointSetIterator Method (PointCloudFilter, ElementId)
IPointCloudAccess Interface See Also Send Feedback
Implement this method to return an iterator for iterating over blocks of this point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
IPointSetIterator CreatePointSetIterator(
    PointCloudFilter rFilter,
    ElementId viewId
)
Visual Basic
Function CreatePointSetIterator ( _
    rFilter As PointCloudFilter, _
    viewId As ElementId _
) As IPointSetIterator
Visual C++
IPointSetIterator^ CreatePointSetIterator(
    PointCloudFilter^ rFilter,
    ElementId^ viewId
)

Parameters

rFilter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.

Return Value

The newly created iterator.

See Also

IPointCloudAccess Interface
CreatePointSetIterator Overload
Autodesk.Revit.DB.PointClouds Namespace


CreatePointSetIterator Method (PointCloudFilter, Double, ElementId)

[image]

Revit 2013 API
IPointCloudAccess..::..CreatePointSetIterator Method (PointCloudFilter, Double, ElementId)
IPointCloudAccess Interface See Also Send Feedback
Implement this method to return an iterator for iterating over blocks of this point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
IPointSetIterator CreatePointSetIterator(
    PointCloudFilter rFilter,
    double density,
    ElementId viewId
)
Visual Basic
Function CreatePointSetIterator ( _
    rFilter As PointCloudFilter, _
    density As Double, _
    viewId As ElementId _
) As IPointSetIterator
Visual C++
IPointSetIterator^ CreatePointSetIterator(
    PointCloudFilter^ rFilter,
    double density,
    ElementId^ viewId
)

Parameters

rFilter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
density
Type: System..::..Double
Desired number of points per unit area. Area is computed in native units of the point cloud. Another iterator, created with the same density and a more restrictive filter, should return a subset of the points returned by this iterator.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.

Return Value

The newly created iterator.

See Also

IPointCloudAccess Interface
CreatePointSetIterator Overload
Autodesk.Revit.DB.PointClouds Namespace


Free Method

[image]

Revit 2013 API
IPointCloudAccess..::..Free Method
IPointCloudAccess Interface See Also Send Feedback
Completes the lifetime of the object providing this interface.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void Free()
Visual Basic
Sub Free
Visual C++
void Free()

Remarks

Calling this function indicates that the IPointCloudAccess interface is not going to be used after the call returns, and the provider of the interface can dispose of all allocated resources.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


GetColorEncoding Method

[image]

Revit 2013 API
IPointCloudAccess..::..GetColorEncoding Method
IPointCloudAccess Interface See Also Send Feedback
Returns the encoding used by points in this point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
PointCloudColorEncoding GetColorEncoding()
Visual Basic
Function GetColorEncoding As PointCloudColorEncoding
Visual C++
PointCloudColorEncoding GetColorEncoding()

Return Value

The encoding.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


GetExtent Method

[image]

Revit 2013 API
IPointCloudAccess..::..GetExtent Method
IPointCloudAccess Interface See Also Send Feedback
Implement this method to returns an object that contains the bounding box of the entire point cloud, aligned to the point cloud coordinate system.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
Outline GetExtent()
Visual Basic
Function GetExtent As Outline
Visual C++
Outline^ GetExtent()

Return Value

The bounding box of the point cloud.

Remarks

The extents should reflect the maximum and minimum coordinates of the stored points, and not incorporate the offset.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


GetName Method

[image]

Revit 2013 API
IPointCloudAccess..::..GetName Method
IPointCloudAccess Interface See Also Send Feedback
Implement this method to return the name of the point cloud that will be used when Revit needs to refer to the point cloud type, e.g. in the Manage Links dialog or in the Type Properties dialog.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

The name of the point cloud for Revit's user interface.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


GetOffset Method

[image]

Revit 2013 API
IPointCloudAccess..::..GetOffset Method
IPointCloudAccess Interface See Also Send Feedback
Implement this method to return the offset stored in the point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
XYZ GetOffset()
Visual Basic
Function GetOffset As XYZ
Visual C++
XYZ^ GetOffset()

Return Value

The offset vector of this point cloud's coordinate system.

Remarks

All points are assumed to be offset by the same offset vector. The offset should be expressed in the same units as used by the point coordinates (the scale conversion factor is not applied). The offset will be used by Revit if the user chooses to place an instance relative to another point cloud (the "Auto - Origin To Last Placed" placement option).

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


GetUnitsToFeetConversionFactor Method

[image]

Revit 2013 API
IPointCloudAccess..::..GetUnitsToFeetConversionFactor Method
IPointCloudAccess Interface See Also Send Feedback
Implement this method to return the conversion factor from the units of the point cloud to feet.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
double GetUnitsToFeetConversionFactor()
Visual Basic
Function GetUnitsToFeetConversionFactor As Double
Visual C++
double GetUnitsToFeetConversionFactor()

Return Value

The multiplication factor to convert coordinates of points in this cloud to feet.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


ReadPoints Method

[image]

Revit 2013 API
IPointCloudAccess..::..ReadPoints Method
IPointCloudAccess Interface See Also Send Feedback
Implement this method so that on successive invocations it will return distinct subsets of points which meet the criterion.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
int ReadPoints(
    PointCloudFilter rFilter,
    ElementId viewId,
    IntPtr buffer,
    int nBufferSize
)
Visual Basic
Function ReadPoints ( _
    rFilter As PointCloudFilter, _
    viewId As ElementId, _
    buffer As IntPtr, _
    nBufferSize As Integer _
) As Integer
Visual C++
int ReadPoints(
    PointCloudFilter^ rFilter,
    ElementId^ viewId,
    IntPtr buffer,
    int nBufferSize
)

Parameters

rFilter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
The filter used to process cloud points and determine which ones lie with the target volume.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id for the current view passed as auxiliary information to allow the engine to optimize retrieval of points. If viewId == InvalidElementId, the query is not for a view display operation.
buffer
Type: System..::..IntPtr
Memory buffer into which the points should be written. The buffer was allocated by Revit and it is guaranteed to be valid for the duration of the call.
nBufferSize
Type: System..::..Int32
The maximum number of CloudPoint objects that may be copied into the buffer.

Return Value

The actual number of CloudPoint objects placed in the buffer (can be less than the length of the buffer). If there are no points available that match the filter criteria, return 0.

See Also

IPointCloudAccess Interface
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudEngine Interface

[image]

Revit 2013 API
IPointCloudEngine Interface
Members See Also Send Feedback
An interface that controls the behavior of the link from Revit to a custom Point Cloud Engine.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public interface IPointCloudEngine
Visual Basic
Public Interface IPointCloudEngine
Visual C++
public interface class IPointCloudEngine

Remarks

An instance of this interface should be created by the engine provider and registered with the PointCloudEnginesRegistry. The engine may associated with a particular file name extension during registration (for example, Revit supplies a built-in engine for working with files with the extension "pcg"). Alternatively, the engine may be associated with an identifier which is not expected to the be the extension of a particular file.

See Also

IPointCloudEngine Members
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudEngine Members

[image] [image]

Revit 2013 API
IPointCloudEngine Members
IPointCloudEngine Interface Methods See Also Send Feedback

The IPointCloudEngine type exposes the following members.

Methods

 | Name | Description
Public method | CreatePointCloudAccess | Implement this method to construct the IPointCloudAccess interface for the point cloud designated by the identifier. This method is called once during the creation of a PointCloudType.
Public method | Free | Revit will call this method when done using the engine.

See Also

IPointCloudEngine Interface
Autodesk.Revit.DB.PointClouds Namespace


IPointCloudEngine Methods

[image] [image]

Revit 2013 API
IPointCloudEngine Methods
IPointCloudEngine Interface See Also Send Feedback

The IPointCloudEngine type exposes the following members.

Methods

 | Name | Description
Public method | CreatePointCloudAccess | Implement this method to construct the IPointCloudAccess interface for the point cloud designated by the identifier. This method is called once during the creation of a PointCloudType.
Public method | Free | Revit will call this method when done using the engine.

See Also

IPointCloudEngine Interface
Autodesk.Revit.DB.PointClouds Namespace


CreatePointCloudAccess Method

[image]

Revit 2013 API
IPointCloudEngine..::..CreatePointCloudAccess Method
IPointCloudEngine Interface See Also Send Feedback
Implement this method to construct the IPointCloudAccess interface for the point cloud designated by the identifier. This method is called once during the creation of a PointCloudType.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
IPointCloudAccess CreatePointCloudAccess(
    string identifier
)
Visual Basic
Function CreatePointCloudAccess ( _
    identifier As String _
) As IPointCloudAccess
Visual C++
IPointCloudAccess^ CreatePointCloudAccess(
    String^ identifier
)

Parameters

identifier
Type: System..::..String
An identifier unique to the point cloud. This will be a file name if the engine was registered as file-based, or an arbitrary identifier if the engine is not file-based.

Return Value

The object that can be used to create iterators and interrogate the point cloud for its features.

Remarks

The instance of the returned IPointCloudAccess is then used by Revit to display instances of the point cloud in Revit graphics and in the user interface.

See Also

IPointCloudEngine Interface
Autodesk.Revit.DB.PointClouds Namespace


Free Method

[image]

Revit 2013 API
IPointCloudEngine..::..Free Method
IPointCloudEngine Interface See Also Send Feedback
Revit will call this method when done using the engine.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void Free()
Visual Basic
Sub Free
Visual C++
void Free()

See Also

IPointCloudEngine Interface
Autodesk.Revit.DB.PointClouds Namespace


IPointSetIterator Interface

[image]

Revit 2013 API
IPointSetIterator Interface
Members See Also Send Feedback
An interface that Revit will call when iterating through sets of points on the engine.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public interface IPointSetIterator
Visual Basic
Public Interface IPointSetIterator
Visual C++
public interface class IPointSetIterator

Remarks

An instance of this interface is obtained from the Point Cloud engine when the engine's CreatePointSetIterator method is called.

See Also

IPointSetIterator Members
Autodesk.Revit.DB.PointClouds Namespace


IPointSetIterator Members

[image] [image]

Revit 2013 API
IPointSetIterator Members
IPointSetIterator Interface Methods See Also Send Feedback

The IPointSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Free | Use this method to discard any resources consumed by the iterator. Revit will call it when done using the iterator.
Public method | ReadPoints | Implement this method to fill the provided buffer with points up to the number of maximum points for which the buffer was allocated.

See Also

IPointSetIterator Interface
Autodesk.Revit.DB.PointClouds Namespace


IPointSetIterator Methods

[image] [image]

Revit 2013 API
IPointSetIterator Methods
IPointSetIterator Interface See Also Send Feedback

The IPointSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Free | Use this method to discard any resources consumed by the iterator. Revit will call it when done using the iterator.
Public method | ReadPoints | Implement this method to fill the provided buffer with points up to the number of maximum points for which the buffer was allocated.

See Also

IPointSetIterator Interface
Autodesk.Revit.DB.PointClouds Namespace


Free Method

[image]

Revit 2013 API
IPointSetIterator..::..Free Method
IPointSetIterator Interface See Also Send Feedback
Use this method to discard any resources consumed by the iterator. Revit will call it when done using the iterator.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
void Free()
Visual Basic
Sub Free
Visual C++
void Free()

See Also

IPointSetIterator Interface
Autodesk.Revit.DB.PointClouds Namespace


ReadPoints Method

[image]

Revit 2013 API
IPointSetIterator..::..ReadPoints Method
IPointSetIterator Interface See Also Send Feedback
Implement this method to fill the provided buffer with points up to the number of maximum points for which the buffer was allocated.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
int ReadPoints(
    IntPtr buffer,
    int bufferSize
)
Visual Basic
Function ReadPoints ( _
    buffer As IntPtr, _
    bufferSize As Integer _
) As Integer
Visual C++
int ReadPoints(
    IntPtr buffer,
    int bufferSize
)

Parameters

buffer
Type: System..::..IntPtr
Memory buffer into which the points should be written. The buffer was allocated by Revit and it is guaranteed to be valid for the duration of the call.
bufferSize
Type: System..::..Int32
The maximum number of CloudPoint objects that may be copied into the buffer.

Return Value

The actual number of CloudPoint objects placed in the buffer (can be less than the length of the buffer). If there are no more points available, return 0.

See Also

IPointSetIterator Interface
Autodesk.Revit.DB.PointClouds Namespace


PointCloudColorEncoding Enumeration

[image]

Revit 2013 API
PointCloudColorEncoding Enumeration
See Also Send Feedback
The color encodings supported by Revit point clouds.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum PointCloudColorEncoding
Visual Basic
Public Enumeration PointCloudColorEncoding
Visual C++
public enum class PointCloudColorEncoding

Members

Member name | Description
ARGB | The point cloud uses colors arranged in ARGB format.
ABGR | The point cloud uses colors arranged in ABGR format (common in Windows).

See Also

Autodesk.Revit.DB.PointClouds Namespace


PointCloudEngineRegistry Class

[image]

Revit 2013 API
PointCloudEngineRegistry Class
Members See Also Send Feedback
This class supports registration of custom Point Cloud Engines in a Revit session.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudEngineRegistry : IDisposable
Visual Basic
Public Class PointCloudEngineRegistry _
    Implements IDisposable
Visual C++
public ref class PointCloudEngineRegistry : IDisposable

Remarks

This class is the start point for engine providers. A custom engine implementation consists of the following:

  • An implementation of IPointCloudEngine registered to Revit via the PointCloudEngineRegistry.
  • An implementation of IPointCloudAccess coded to respond to inquiries from Revit regarding the properties of a single point cloud.
  • An implementation of IPointSetIterator code to return sets of points to Revit when requested.

Engine implementations may be file-based or non-file-based:

  • File-based implementations require that each point cloud be mapped to a single file on disk. Revit will allow users to create new point cloud instances in a document directly by selecting point cloud files whose extension matches the engine identifier. These files are treated as external links in Revit and may be reloaded and remapped when necessary from the Manage Links dialog.
  • Non-file-based engine implementations may obtain point clouds from anywhere (e.g. from a database, from a server, or from one part of a larger aggregate file). Because there is no file that the user may select, Revit's user interface will not allow a user to create a point cloud of this type. The engine provider should supply a custom command using PointCloudType.Create() and PointCloudInstance.Create() to create and place point clouds of this type. The Manage Links dialog will show the point clouds of this type, but since there is no file associated to the point cloud, the user cannot manage, reload or remap point clouds of this type.

Regardless of the type of engine used, the implementation must supply enough information to Revit to display the contents of the point cloud. There are two ReadPoints methods which must be implemented:

  • IPointCloudAccess.ReadPoints() - this provides a single set of points in a one-time call from Revit. Revit uses this during some display activities including selection prehighlighting. It is also possible for API clients to call this method directly (via PointCloudInstance.GetPoints()).
  • IPointSetIterator.ReadPoints() - this provides a subset of points as a part of a larger iteration of points in the cloud. Revit uses this method during normal display of the point cloud; quantities of points will be requested repeatedly until it obtains enough points or until something in the display changes. The engine implementation must keep track of which points have been returned to Revit during any given point set iteration.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudEngineRegistry

See Also

PointCloudEngineRegistry Members
Autodesk.Revit.DB.PointClouds Namespace


PointCloudEngineRegistry Members

[image] [image]

Revit 2013 API
PointCloudEngineRegistry Members
PointCloudEngineRegistry Class Methods See Also Send Feedback

The PointCloudEngineRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointCloudEngineRegistry
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSupportedEngines | Returns a list of the identifiers supported by point cloud engines registered to Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEngineFileBased | Identifies if a given engine is file-based.
 | RegisterPointCloudEngine | Registers a new point cloud engine and associates it to a particular file extension.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterPointCloudEngine | Unregisters the point cloud engine associated to a particular identifier.

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudEngineRegistry Methods

[image] [image]

Revit 2013 API
PointCloudEngineRegistry Methods
PointCloudEngineRegistry Class See Also Send Feedback

The PointCloudEngineRegistry type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetSupportedEngines | Returns a list of the identifiers supported by point cloud engines registered to Revit.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsEngineFileBased | Identifies if a given engine is file-based.
 | RegisterPointCloudEngine | Registers a new point cloud engine and associates it to a particular file extension.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | UnregisterPointCloudEngine | Unregisters the point cloud engine associated to a particular identifier.

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointCloudEngineRegistry..::..Dispose Method
PointCloudEngineRegistry Class See Also Send Feedback
Releases all resources used by the PointCloudEngineRegistry

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


GetSupportedEngines Method

[image]

Revit 2013 API
PointCloudEngineRegistry..::..GetSupportedEngines Method
PointCloudEngineRegistry Class See Also Send Feedback
Returns a list of the identifiers supported by point cloud engines registered to Revit.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<string> GetSupportedEngines()
Visual Basic
Public Shared Function GetSupportedEngines As IList(Of String)
Visual C++
public:
static IList<String^>^ GetSupportedEngines()

Return Value

The list of identifiers.

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


IsEngineFileBased Method

[image]

Revit 2013 API
PointCloudEngineRegistry..::..IsEngineFileBased Method
PointCloudEngineRegistry Class See Also Send Feedback
Identifies if a given engine is file-based.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsEngineFileBased(
    string identifier
)
Visual Basic
Public Shared Function IsEngineFileBased ( _
    identifier As String _
) As Boolean
Visual C++
public:
static bool IsEngineFileBased(
    String^ identifier
)

Parameters

identifier
Type: System..::..String
The engine identifier.

Return Value

True if the engine is file-based, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


RegisterPointCloudEngine Method

[image]

Revit 2013 API
PointCloudEngineRegistry..::..RegisterPointCloudEngine Method
PointCloudEngineRegistry Class See Also Send Feedback
Registers a new point cloud engine and associates it to a particular file extension.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void RegisterPointCloudEngine(
    string identifier,
    IPointCloudEngine engine,
    bool isFileBased
)
Visual Basic
Public Shared Sub RegisterPointCloudEngine ( _
    identifier As String, _
    engine As IPointCloudEngine, _
    isFileBased As Boolean _
)
Visual C++
public:
static void RegisterPointCloudEngine(
    String^ identifier,
    IPointCloudEngine^ engine,
    bool isFileBased
)

Parameters

identifier
Type: System..::..String
A string that distinguishes the engine being registered. If isFileBased is true, this should be the file extension (e.g. "pcg"). If isFileBased is false, this identifier is used only by API calls and should be unique.
engine
Type: Autodesk.Revit.DB.PointClouds..::..IPointCloudEngine
The point cloud engine that governs point clouds matching the input identifier.
isFileBased
Type: System..::..Boolean
Indicates to Revit if a single Point Cloud corresponds to a single file on disk.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The same identifier has already been registered by another engine.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


UnregisterPointCloudEngine Method

[image]

Revit 2013 API
PointCloudEngineRegistry..::..UnregisterPointCloudEngine Method
PointCloudEngineRegistry Class See Also Send Feedback
Unregisters the point cloud engine associated to a particular identifier.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static void UnregisterPointCloudEngine(
    string identifier
)
Visual Basic
Public Shared Sub UnregisterPointCloudEngine ( _
    identifier As String _
)
Visual C++
public:
static void UnregisterPointCloudEngine(
    String^ identifier
)

Parameters

identifier
Type: System..::..String
The identifier of the engine to be unregistered.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudEngineRegistry Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilter Class

[image]

Revit 2013 API
PointCloudFilter Class
Members Example See Also Send Feedback
A class used to describe the criteria an application desires when obtaining members of a point cloud.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudFilter : IDisposable
Visual Basic
Public Class PointCloudFilter _
    Implements IDisposable
Visual C++
public ref class PointCloudFilter : IDisposable

Remarks

Client applications which wish to obtain points from a point cloud will have to create a PointCloudFilter to define the volume of interest (see PointCloudFilterFactory). Engine implementations will need to use the methods contained within the point cloud to determine which points to return to Revit.

Examples

CopyC#
    // Filter will match 1/8 of the overall point cloud
    // Use the bounding box (filter coordinates are in the coordinates of the model)
    BoundingBoxXYZ boundingBox = pointCloudInstance.get_BoundingBox(null);
    List<Plane> planes = new List<Plane>();
    XYZ midpoint = (boundingBox.Min + boundingBox.Max) / 2.0;

    // X boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisX, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisX, midpoint));

    // Y boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisY, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisY, midpoint));

    // Z boundaries
    planes.Add(app.Create.NewPlane(XYZ.BasisZ, boundingBox.Min));
    planes.Add(app.Create.NewPlane(-XYZ.BasisZ, midpoint));

    // Create filter
    PointCloudFilter filter = PointCloudFilterFactory.CreateMultiPlaneFilter(planes);

    return filter;
}

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudFilter

See Also

PointCloudFilter Members
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilter Members

[image] [image]

Revit 2013 API
PointCloudFilter Members
PointCloudFilter Class Methods See Also Send Feedback

The PointCloudFilter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of the filter. The engine is permitted to copy the filter multiple times e.g. to parallelize filtering.
Public method | Dispose | Releases all resources used by the PointCloudFilter
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareForCell | Informs the filter that a series of points within a given cell is about to be checked.
Public method | TestCell | Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.
Public method | TestPoint | Checks if a point is inside the volume of interest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilter Methods

[image] [image]

Revit 2013 API
PointCloudFilter Methods
PointCloudFilter Class See Also Send Feedback

The PointCloudFilter type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Returns a copy of the filter. The engine is permitted to copy the filter multiple times e.g. to parallelize filtering.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PrepareForCell | Informs the filter that a series of points within a given cell is about to be checked.
Public method | TestCell | Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.
Public method | TestPoint | Checks if a point is inside the volume of interest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


Clone Method

[image]

Revit 2013 API
PointCloudFilter..::..Clone Method
PointCloudFilter Class See Also Send Feedback
Returns a copy of the filter. The engine is permitted to copy the filter multiple times e.g. to parallelize filtering.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointCloudFilter Clone()
Visual Basic
Public Function Clone As PointCloudFilter
Visual C++
public:
PointCloudFilter^ Clone()

Return Value

A copy of the original filter.

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointCloudFilter..::..Dispose Method
PointCloudFilter Class See Also Send Feedback
Releases all resources used by the PointCloudFilter

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


PrepareForCell Method

[image]

Revit 2013 API
PointCloudFilter..::..PrepareForCell Method
PointCloudFilter Class See Also Send Feedback
Informs the filter that a series of points within a given cell is about to be checked.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void PrepareForCell(
    XYZ min,
    XYZ max,
    int numTests
)
Visual Basic
Public Sub PrepareForCell ( _
    min As XYZ, _
    max As XYZ, _
    numTests As Integer _
)
Visual C++
public:
void PrepareForCell(
    XYZ^ min,
    XYZ^ max,
    int numTests
)

Parameters

min
Type: Autodesk.Revit.DB..::..XYZ
The lower corner of the cell.
max
Type: Autodesk.Revit.DB..::..XYZ
The upper corner of the cell.
numTests
Type: System..::..Int32
The engine's estimate of the number of TestPoint() calls it is going to make for this cell.

Remarks

This is a performance hook that the filter can use to minimize computational work per TestPoint() call within a given cell. The engine should guarantee that all points passed to TestPoint() calls will fall inside the (min, max) box specified here. This promise must be in effect until the next PrepareForCell() call.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


TestCell Method

[image]

Revit 2013 API
PointCloudFilter..::..TestCell Method
PointCloudFilter Class See Also Send Feedback
Checks whether a given cell, i.e. a box aligned with the XYZ axes, is inside, outside or on the border of the volume of interest.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int TestCell(
    XYZ min,
    XYZ max
)
Visual Basic
Public Function TestCell ( _
    min As XYZ, _
    max As XYZ _
) As Integer
Visual C++
public:
int TestCell(
    XYZ^ min,
    XYZ^ max
)

Parameters

min
Type: Autodesk.Revit.DB..::..XYZ
The lower corner of the cell.
max
Type: Autodesk.Revit.DB..::..XYZ
The upper corner of the cell.

Return Value

  • -1 -- The cell is entirely rejected.
  • 0 -- The cell partially belongs to the volume of interest. Use PrepareForCell() and TestPoint() to evaluate individual points.
  • 1 -- The cell is fully accepted.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


TestPoint Method

[image]

Revit 2013 API
PointCloudFilter..::..TestPoint Method
PointCloudFilter Class See Also Send Feedback
Checks if a point is inside the volume of interest.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool TestPoint(
    CloudPoint point
)
Visual Basic
Public Overridable Function TestPoint ( _
    point As CloudPoint _
) As Boolean
Visual C++
public:
virtual bool TestPoint(
    CloudPoint point
)

Parameters

point
Type: Autodesk.Revit.DB.PointClouds..::..CloudPoint
The point to be tested.

Return Value

If true, the point is accepted, if false, the point is not accepted.

See Also

PointCloudFilter Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterFactory Class

[image]

Revit 2013 API
PointCloudFilterFactory Class
Members See Also Send Feedback
A factory class for creating point cloud filters.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudFilterFactory : IDisposable
Visual Basic
Public Class PointCloudFilterFactory _
    Implements IDisposable
Visual C++
public ref class PointCloudFilterFactory : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudFilterFactory

See Also

PointCloudFilterFactory Members
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterFactory Members

[image] [image]

Revit 2013 API
PointCloudFilterFactory Members
PointCloudFilterFactory Class Methods See Also Send Feedback

The PointCloudFilterFactory type exposes the following members.

Methods

 | Name | Description
 | CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>)) | Creates a new point cloud filter based upon planar boundaries.
 | CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>), Int32) | Creates a new point cloud filter based upon planar boundaries.
Public method | Dispose | Releases all resources used by the PointCloudFilterFactory
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilterFactory Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterFactory Methods

[image] [image]

Revit 2013 API
PointCloudFilterFactory Methods
PointCloudFilterFactory Class See Also Send Feedback

The PointCloudFilterFactory type exposes the following members.

Methods

 | Name | Description
 | CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>)) | Creates a new point cloud filter based upon planar boundaries.
 | CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>), Int32) | Creates a new point cloud filter based upon planar boundaries.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilterFactory Class
Autodesk.Revit.DB.PointClouds Namespace


CreateMultiPlaneFilter Method

[image] [image]

Revit 2013 API
PointCloudFilterFactory..::..CreateMultiPlaneFilter Method
PointCloudFilterFactory Class See Also Send Feedback

Overload List

Name | Description
CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>)) | Creates a new point cloud filter based upon planar boundaries.
CreateMultiPlaneFilter(IList<(Of <<'(Plane>)>>), Int32) | Creates a new point cloud filter based upon planar boundaries.

See Also

PointCloudFilterFactory Class
PointCloudFilterFactory Members
Autodesk.Revit.DB.PointClouds Namespace


CreateMultiPlaneFilter Method (IList(Plane))

[image]

Revit 2013 API
PointCloudFilterFactory..::..CreateMultiPlaneFilter Method (IList<(Of <(<'Plane>)>)>)
PointCloudFilterFactory Class See Also Send Feedback
Creates a new point cloud filter based upon planar boundaries.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PointCloudFilter CreateMultiPlaneFilter(
    IList<Plane> planes
)
Visual Basic
Public Shared Function CreateMultiPlaneFilter ( _
    planes As IList(Of Plane) _
) As PointCloudFilter
Visual C++
public:
static PointCloudFilter^ CreateMultiPlaneFilter(
    IList<Plane^>^ planes
)

Parameters

planes
Type: System.Collections.Generic..::..IList<(Of <(<'Plane>)>)>
All planes used for filtering; positive direction of the normal should point inside the volume of interest. Only points on the "positive" side of all planes will pass the filter.

Return Value

Filter object; can be used to get representative set of cloud points passing through the filter.

Remarks

The filter will check whether a point is located on the “positive” side of each plane, as indicated by the positive direction of the plane normal. Therefore, such filter implicitly defines a volume, which is the intersection of the positive half-spaces corresponding to all the planes. This volume does not have to be closed, but it will always be convex.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilterFactory Class
CreateMultiPlaneFilter Overload
Autodesk.Revit.DB.PointClouds Namespace


CreateMultiPlaneFilter Method (IList(Plane), Int32)

[image]

Revit 2013 API
PointCloudFilterFactory..::..CreateMultiPlaneFilter Method (IList<(Of <(<'Plane>)>)>, Int32)
PointCloudFilterFactory Class See Also Send Feedback
Creates a new point cloud filter based upon planar boundaries.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static PointCloudFilter CreateMultiPlaneFilter(
    IList<Plane> planes,
    int exactPlaneCount
)
Visual Basic
Public Shared Function CreateMultiPlaneFilter ( _
    planes As IList(Of Plane), _
    exactPlaneCount As Integer _
) As PointCloudFilter
Visual C++
public:
static PointCloudFilter^ CreateMultiPlaneFilter(
    IList<Plane^>^ planes,
    int exactPlaneCount
)

Parameters

planes
Type: System.Collections.Generic..::..IList<(Of <(<'Plane>)>)>
All planes used for filtering; positive direction of the normal should point inside the volume of interest.
exactPlaneCount
Type: System..::..Int32
This value represents the number of planes (taken in order of their addition) which will be used for exact filtering of individual points. Other planes in the filter will be used for faster, but inexact filtering based on cells.

Return Value

Filter object; can be used to get representative set of cloud points passing through the filter.

Remarks

The filter will check whether a point is located on the “positive” side of each plane, as indicated by the positive direction of the plane normal. Therefore, such filter implicitly defines a volume, which is the intersection of the positive half-spaces corresponding to all the planes. This volume does not have to be closed, but it will always be convex.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilterFactory Class
CreateMultiPlaneFilter Overload
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointCloudFilterFactory..::..Dispose Method
PointCloudFilterFactory Class See Also Send Feedback
Releases all resources used by the PointCloudFilterFactory

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointCloudFilterFactory Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterUtils Class

[image]

Revit 2013 API
PointCloudFilterUtils Class
Members See Also Send Feedback
Utilities specific to point cloud filters.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCloudFilterUtils : IDisposable
Visual Basic
Public Class PointCloudFilterUtils _
    Implements IDisposable
Visual C++
public ref class PointCloudFilterUtils : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCloudFilterUtils

See Also

PointCloudFilterUtils Members
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterUtils Members

[image] [image]

Revit 2013 API
PointCloudFilterUtils Members
PointCloudFilterUtils Class Methods See Also Send Feedback

The PointCloudFilterUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointCloudFilterUtils
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFilteredOutline | Computes outline of a part of a box that satisfies given PointCloudFilter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilterUtils Class
Autodesk.Revit.DB.PointClouds Namespace


PointCloudFilterUtils Methods

[image] [image]

Revit 2013 API
PointCloudFilterUtils Methods
PointCloudFilterUtils Class See Also Send Feedback

The PointCloudFilterUtils type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetFilteredOutline | Computes outline of a part of a box that satisfies given PointCloudFilter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCloudFilterUtils Class
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointCloudFilterUtils..::..Dispose Method
PointCloudFilterUtils Class See Also Send Feedback
Releases all resources used by the PointCloudFilterUtils

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointCloudFilterUtils Class
Autodesk.Revit.DB.PointClouds Namespace


GetFilteredOutline Method

[image]

Revit 2013 API
PointCloudFilterUtils..::..GetFilteredOutline Method
PointCloudFilterUtils Class See Also Send Feedback
Computes outline of a part of a box that satisfies given PointCloudFilter.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static Outline GetFilteredOutline(
    PointCloudFilter filter,
    Outline box
)
Visual Basic
Public Shared Function GetFilteredOutline ( _
    filter As PointCloudFilter, _
    box As Outline _
) As Outline
Visual C++
public:
static Outline^ GetFilteredOutline(
    PointCloudFilter^ filter,
    Outline^ box
)

Parameters

filter
Type: Autodesk.Revit.DB.PointClouds..::..PointCloudFilter
Point cloud filter.
box
Type: Autodesk.Revit.DB..::..Outline
A box aligned with coordinate axes.

Return Value

The bounding box of the set of all points within the original box that satisfy the filter. Not every point within the resulting outline satisfies the filter, but any point that is contained in the original box and satisfies the filter is guaranteed to be within the resulting outline.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

PointCloudFilterUtils Class
Autodesk.Revit.DB.PointClouds Namespace


PointCollection Class

[image]

Revit 2013 API
PointCollection Class
Members See Also Send Feedback
A class that represents a set of points created and returned by Revit in response to a query.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointCollection : IEnumerable<CloudPoint>,
    IDisposable
Visual Basic
Public Class PointCollection _
    Implements IEnumerable(Of CloudPoint), IDisposable
Visual C++
public ref class PointCollection : IEnumerable<CloudPoint>,
    IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointCollection

See Also

PointCollection Members
Autodesk.Revit.DB.PointClouds Namespace


PointCollection Members

[image] [image]

Revit 2013 API
PointCollection Members
PointCollection Class Methods Properties See Also Send Feedback

The PointCollection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointCollection
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointBufferPointer | Returns an unsafe pointer to the buffer in which this collection stores the points.
Public method | GetPointIterator | Creates and returns an iterator for the points contained in this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | The number of points in this collection.

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


PointCollection Methods

[image] [image]

Revit 2013 API
PointCollection Methods
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | GetBasicIEnumerator | Returns an enumerator that iterates through a collection.
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPointBufferPointer | Returns an unsafe pointer to the buffer in which this collection stores the points.
Public method | GetPointIterator | Creates and returns an iterator for the points contained in this collection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointCollection..::..Dispose Method
PointCollection Class See Also Send Feedback
Releases all resources used by the PointCollection

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


GetBasicIEnumerator Method

[image]

Revit 2013 API
PointCollection..::..GetBasicIEnumerator Method
PointCollection Class See Also Send Feedback
Returns an enumerator that iterates through a collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
internal virtual IEnumerator GetBasicIEnumerator()
Visual Basic
Friend Overridable Function GetBasicIEnumerator As IEnumerator
Visual C++
internal:
virtual IEnumerator^ GetBasicIEnumerator()

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


GetEnumerator Method

[image]

Revit 2013 API
PointCollection..::..GetEnumerator Method
PointCollection Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator<CloudPoint> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of CloudPoint)
Visual C++
public:
virtual IEnumerator<CloudPoint>^ GetEnumerator()

Return Value

An IEnumerator(Autodesk.Revit.DB.PointClouds.CloudPoint) object that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


GetPointBufferPointer Method

[image]

Revit 2013 API
PointCollection..::..GetPointBufferPointer Method
PointCollection Class See Also Send Feedback
Returns an unsafe pointer to the buffer in which this collection stores the points.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IntPtr GetPointBufferPointer()
Visual Basic
Public Function GetPointBufferPointer As IntPtr
Visual C++
public:
IntPtr GetPointBufferPointer()

Return Value

The pointer to the collection's storage.

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


GetPointIterator Method

[image]

Revit 2013 API
PointCollection..::..GetPointIterator Method
PointCollection Class See Also Send Feedback
Creates and returns an iterator for the points contained in this collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public PointIterator GetPointIterator()
Visual Basic
Public Function GetPointIterator As PointIterator
Visual C++
public:
PointIterator^ GetPointIterator()

Return Value

New iterator created, make sure to call 'free' on it when finished using it.

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


PointCollection Properties

[image] [image]

Revit 2013 API
PointCollection Properties
PointCollection Class See Also Send Feedback

The PointCollection type exposes the following members.

Properties

 | Name | Description
Public property | Count | The number of points in this collection.

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


Count Property

[image]

Revit 2013 API
PointCollection..::..Count Property
PointCollection Class See Also Send Feedback
The number of points in this collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

PointCollection Class
Autodesk.Revit.DB.PointClouds Namespace


PointIterator Class

[image]

Revit 2013 API
PointIterator Class
Members See Also Send Feedback
A class used to iterate individual points in a PointCollection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class PointIterator : IEnumerator<CloudPoint>
Visual Basic
Public Class PointIterator _
    Implements IEnumerator(Of CloudPoint)
Visual C++
public ref class PointIterator : IEnumerator<CloudPoint>

Remarks

Points may be iterated in two different ways:
  1. In the traditional IEnumerable interface, you can iterate the resulting points directly from the PointCollection.
  2. In an unsafe interface usable only from C# and C++/CLI, you can get a pointer to the point storage of the collection and access the points directly in memory. Although you must deal with pointers directly, there may be performance improvements when traversing large buffers of points.
Regardless of the approach used to obtain the points, the points are reported in the coordinate system of the point cloud. If you need the points in the coordinate system of the model, you will need to transform the point in those coordinates. The most direct way to do this is to obtain the transformation matrix from the PointCloudInstance (GetTransform()), convert the CloudPoint to an XYZ using the implicit conversion operator, and use Transform.OfPoint(XYZ).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.PointClouds..::..PointIterator

See Also

PointIterator Members
Autodesk.Revit.DB.PointClouds Namespace


PointIterator Members

[image] [image]

Revit 2013 API
PointIterator Members
PointIterator Class Methods Properties See Also Send Feedback

The PointIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the PointIterator
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Free | Completes lifetime of the iterator. Call it when done using the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has reached the end of the collection.
Public method | MoveNext | Increments the iterator to the next point in the collection.
Public method | Reset | Resets the iterator to the beginning of the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current |
Public property | CurrentObject |

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


PointIterator Methods

[image] [image]

Revit 2013 API
PointIterator Methods
PointIterator Class See Also Send Feedback

The PointIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Free | Completes lifetime of the iterator. Call it when done using the iterator.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDone | Identifies if the iteration has reached the end of the collection.
Public method | MoveNext | Increments the iterator to the next point in the collection.
Public method | Reset | Resets the iterator to the beginning of the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


Dispose Method

[image]

Revit 2013 API
PointIterator..::..Dispose Method
PointIterator Class See Also Send Feedback
Releases all resources used by the PointIterator

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


Free Method

[image]

Revit 2013 API
PointIterator..::..Free Method
PointIterator Class See Also Send Feedback
Completes lifetime of the iterator. Call it when done using the iterator.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Free()
Visual Basic
Public Sub Free
Visual C++
public:
void Free()

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


IsDone Method

[image]

Revit 2013 API
PointIterator..::..IsDone Method
PointIterator Class See Also Send Feedback
Identifies if the iteration has reached the end of the collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsDone()
Visual Basic
Public Function IsDone As Boolean
Visual C++
public:
bool IsDone()

Return Value

True if the iteration has reached the end, false otherwise.

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


MoveNext Method

[image]

Revit 2013 API
PointIterator..::..MoveNext Method
PointIterator Class See Also Send Feedback
Increments the iterator to the next point in the collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available point in this iterator. False if the iterator has completed all available points.

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


Reset Method

[image]

Revit 2013 API
PointIterator..::..Reset Method
PointIterator Class See Also Send Feedback
Resets the iterator to the beginning of the collection.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


PointIterator Properties

[image] [image]

Revit 2013 API
PointIterator Properties
PointIterator Class See Also Send Feedback

The PointIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current |
Public property | CurrentObject |

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


Current Property

[image]

Revit 2013 API
PointIterator..::..Current Property
PointIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual CloudPoint Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As CloudPoint
    Get
Visual C++
public:
virtual property CloudPoint Current {
    CloudPoint get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


CurrentObject Property

[image]

Revit 2013 API
PointIterator..::..CurrentObject Property
PointIterator Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Object CurrentObject { get; }
Visual Basic
Public ReadOnly Property CurrentObject As Object
    Get
Visual C++
public:
virtual property Object^ CurrentObject {
    Object^ get () sealed;
}

Implements

IEnumerator..::..Current

See Also

PointIterator Class
Autodesk.Revit.DB.PointClouds Namespace


Autodesk.Revit.DB.Structure Namespace

[image]

Revit 2013 API
Autodesk.Revit.DB.Structure Namespace
Send Feedback

Classes

 | Class | Description
Public class | AnalyticalConsistencyChecking |
Public class | AnalyticalLink | An analytical link element that is used to create connections between other AnalyticalModel elements.
Public class | AnalyticalLinkType | An object that specifies the analysis properties for an AnalyticalLink element.
Public class | AnalyticalModel | AnalyticalModel represents the Analytical Model portion of a given Structural Element.
Public class | AnalyticalModelSelector | Defines a portion of an Analytical Model for an Element.
Public class | AnalyticalModelSketchComponent | This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.
Public class | AnalyticalModelSupport | Represents one support for an Element, in the realm of the Analytical Model.
Public class | AnalyticalModelSurface |
Public class | AnalyticalModelSweptProfile | Represents an extruded profile swept along a driving curve.
Public class | AnalyticalSupportChecking |
Public class | AreaLoad | An object that represents a force applied across an area.
Public class | AreaLoadType | An object that represents a Load type.
Public class | AreaLoadTypeSet | A set that contains areaload types.
Public class | AreaLoadTypeSetIterator | An iterator to a areaload type set.
Public class | AreaReinforcement | An object that represents an Area Reinforcement within the Autodesk Revit project.
Public class | AreaReinforcementCurve | An object that specifies the type of a floor in Autodesk Revit.
Public class | AreaReinforcementType | An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.
Public class | BarDescription | Obsolete. A description of a straight rebar, possibly with hooks.
Public class | FabricArea | An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.
Public class | FabricAreaType | A FabricAreaType object is used in FabricArea object generation.
Public class | FabricReinSpanSymbol | Represents a FabricSheet Span Symbol element in Autodesk Revit.
Public class | FabricSheet | An object that represents an Fabric Sheet Element within the Autodesk Revit project.
Public class | FabricSheetType | A Fabric Sheet Type object that is used in the generation of Fabric Wire.
Public class | FabricWireType | A Fabric Wire Type object that is used in the generation of Fabric Wire.
Public class | FamilyStructuralMaterialTypeFilter | A filter used to match families that have the given structural material type.
Public class | Hub | Represents a connection between two or more Autodesk Revit Elements.
Public class | LineLoad | An object that represents a force/moment applied in a linear manner.
Public class | LineLoadType | An object that represents a Load type.
Public class | LineLoadTypeSet | A set that contains lineload types.
Public class | LineLoadTypeSetIterator | An iterator to a lineload type set.
Public class | LoadBase | The LoadBase object is the base class for all load objects within the Autodesk Revit API.
Public class | LoadCase | This object represents a load case within the project.
Public class | LoadCaseArray | An array that contains load case objects.
Public class | LoadCaseArrayIterator | An iterator to an load case array.
Public class | LoadCaseSet | A set that contains load cases.
Public class | LoadCaseSetIterator | An iterator to a load case set.
Public class | LoadCombination | An object that represents a load combination.
Public class | LoadCombinationArray | An array that can contain LoadCombination objects.
Public class | LoadCombinationArrayIterator | An iterator to an array.
Public class | LoadNature | A structural Load nature object.
Public class | LoadTypeBase | An object that represents a Load type.
Public class | LoadTypeBaseSet | A set that contains load type bases.
Public class | LoadTypeBaseSetIterator | An iterator to a load type base set.
Public class | LoadUsage | This object represents a load case within the project.
Public class | LoadUsageArray | An array that contains load usage objects.
Public class | LoadUsageArrayIterator | An iterator to an load usage array.
Public class | PathReinforcement | An object that represents an Path Reinforcement within the Autodesk Revit project.
Public class | PathReinforcementType | An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.
Public class | PointLoad | An object that represents a force/moment applied to a single point.
Public class | PointLoadType | An object that represents a Load type.
Public class | PointLoadTypeSet | A set that contains pointload types.
Public class | PointLoadTypeSetIterator | An iterator to a pointload type set.
Public class | Rebar | Represents a rebar element in Autodesk Revit.
Public class | RebarBarType | A Rebar type object that is used in the generation of Rebar
Public class | RebarBarTypeSet | A set that contains RebarBar types.
Public class | RebarBarTypeSetIterator | An iterator to a RebarBar type set.
Public class | RebarBendData | The class contains values that specify the bar diameter, bend diameters, and hook lengths of a rebar.
Public class | RebarCoverType | A named value for a clear cover distance.
Public class | RebarCoverTypeSet | A set that contains RebarCover types.
Public class | RebarCoverTypeSetIterator | An iterator to a RebarCover type set.
Public class | RebarHookType | A Rebar Hook type object that is used in the generation of Rebar.
Public class | RebarHookTypeSet | A set that contains RebarHook types.
Public class | RebarHookTypeSetIterator | An iterator to a RebarHook type set.
Public class | RebarHostData | Interface to rebar-specific data stored in each valid rebar host element.
Public class | RebarInSystem | Represents a rebar element that is part of a system.
Public class | RebarShape | RebarShape specifies the shape type for a Rebar instance.
Public class | RebarShapeConstraint | A dimension or other constraint that takes part in a RebarShapeDefinition.
Public class | RebarShapeConstraint180DegreeBendArcLength | A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.
Public class | RebarShapeConstraint180DegreeBendRadius | A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the radius of the arc.
Public class | RebarShapeConstraint180DegreeDefaultBend | A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.
Public class | RebarShapeConstraintAngleFromFixedDir | A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.
Public class | RebarShapeConstraintArcLength | An arc-length constraint associated with an arc in a RebarShapeDefinition.
Public class | RebarShapeConstraintChordLength | A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.
Public class | RebarShapeConstraintCircumference | A circumference constraint associated with an arc in a RebarShapeDefinition.
Public class | RebarShapeConstraintDiameter | A diameter constraint associated with an arc in a RebarShapeDefinition.
Public class | RebarShapeConstraintFixedSegmentDir | A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Public class | RebarShapeConstraintProjectedSegmentLength | A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.
Public class | RebarShapeConstraintRadius | A radius constraint associated with an arc in a RebarShapeDefinition.
Public class | RebarShapeConstraintSagittaLength | A constraint that can be applied to a RebarShapeDefinitionByArc and drives the height of the arc.
Public class | RebarShapeConstraintSegmentLength | A constraint that controls the length of a segment.
Public class | RebarShapeDefinition | A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Public class | RebarShapeDefinitionByArc | Definition of a shape whose size and position can determined by a single arc.
Public class | RebarShapeDefinitionBySegments | Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.
Public class | RebarShapeMultiplanarDefinition | A specification for a simple 3D rebar shape.
Public class | RebarShapeParameters | Class containing functions that create and retrieve shared parameters for RebarShapes.
Public class | RebarShapeSegment | Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition.
Public class | RebarShapeSet | An set that contains rebar shapes.
Public class | RebarShapeSetIterator | An iterator to a rebar shape set.
Public class | RebarShapeVertex | A bend between segments of a rebar shape definition.
Public class | ReinforcementSettings | Provides access to project-wide reinforcement settings.
Public class | StructuralConnectionType |
Public class | StructuralInstanceUsageFilter | A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.
Public class | StructuralMaterialTypeFilter | A filter used to match family instances that have the given structural material type.
Public class | StructuralSettings | Provides access to project-wide structural settings.
Public class | StructuralWallUsageFilter | A filter used to match walls that have the given structural wall usage.
Public class | Truss | Represents all kinds of Trusses.
Public class | TrussMemberInfo | Provides access to the information of a truss member in Autodesk Revit.
Public class | TrussType | Represents a specific type of truss.
Public class | TrussTypeSet | A set that contains Truss types.
Public class | TrussTypeSetIterator | An iterator to a Truss type set.

Enumerations

 | Enumeration | Description
Public enumeration | AnalyticalAlignmentMethod | Specifies how analytical model is being aligned in space
Public enumeration | AnalyticalCurveSelector | Specifies which portion of an Analytical Curve is of interest.
Public enumeration | AnalyticalCurveType | Identifies what type of Analytical Model curves should be extracted.
Public enumeration | AnalyticalDirection | Specifies a direction for manipulating analytical model.
Public enumeration | AnalyticalElementSelector | Specifies a portion of an Analytical Element or the whole element.
Public enumeration | AnalyticalFixityState | Specifies the fixity setting of individual degrees of freedom in analytical release conditions.
Public enumeration | AnalyticalLoopType | Specifies kind of analytical model loop.
Public enumeration | AnalyticalProjectionType | Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements
Public enumeration | AnalyticalRigidLinksOption | Specifies how Rigid Links will be made for the Analytical Model.
Public enumeration | AnalyticalSupportPriority | Defines how "highly" another Element is giving support for one Element.
Public enumeration | AnalyticalSupportType | Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Public enumeration | AnalyzeAs | Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.
Public enumeration | BoundaryConditionsType | This enum declares type of BoundaryConditions.
Public enumeration | BracePlanRepresentation | The possible representations for braces in plan views.
Public enumeration | FabricLapSplicePosition | Fabric lap splice position in the fabric distribution
Public enumeration | FabricLocation | Fabric location in the host
Public enumeration | FabricSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public enumeration | FabricSheetLayoutPattern | The pattern for how the wires in Fabric Sheet are laid out.
Public enumeration | FabricTagComponentReference | How FabricSheet tag text will be aligned to the FabricSheet symbol.
Public enumeration | PositionOnCurve | Specifies position on analytical curve to calculate direction.
Public enumeration | RebarHookOrientation | Orientation of a rebar hook relative to the path of the Rebar Shape.
Public enumeration | RebarLayoutRule | The rule for how the rebars in rebar set are laid out
Public enumeration | RebarShapeArcReferenceType | A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.
Public enumeration | RebarShapeBendAngle | A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.
Public enumeration | RebarShapeDefinitionByArcType | A RebarShapeDefinitionByArc takes one of three forms.
Public enumeration | RebarShapeSegmentEndReferenceType | A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.
Public enumeration | RebarShapeVertexTurn | Specify whether a bend at a RebarShapeVertex represents a left or right turn.
Public enumeration | RebarStyle | Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.
Public enumeration | ReinforcementLayerDirection | Describes the direction of reinforcement layer.
Public enumeration | ReinforcementLayerFace | Describes the position of layer at area or path reinforcement's host.
Public enumeration | SlabFoundationType | SlabFoundation type.
Public enumeration | StirrupTieAttachmentType |
Public enumeration | StructuralConnectionApplyTo |
Public enumeration | StructuralInstanceUsage |
Public enumeration | StructuralMaterialType | Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.
Public enumeration | StructuralType | Represents the structural type of a family instance.
Public enumeration | StructuralWallUsage | Represents the structural usage of a wall.
Public enumeration | TranslationRotationValue | Values for BoundaryConditions Translation and Rotation parameters.
Public enumeration | TrussChordLocation | This enumerated type represents the options for the Truss Chord Location.
Public enumeration | TrussCurveType | Types of curves created in truss families.
Public enumeration | TrussMemberType | Indicates the "kind" of a truss member.
Public enumeration | WireDistributionDirection | Defines direction of distribution of wires in a Fabric Sheet.


AnalyticalAlignmentMethod Enumeration

[image]

Revit 2013 API
AnalyticalAlignmentMethod Enumeration
See Also Send Feedback
Specifies how analytical model is being aligned in space

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalAlignmentMethod
Visual Basic
Public Enumeration AnalyticalAlignmentMethod
Visual C++
public enum class AnalyticalAlignmentMethod

Members

Member name | Description
AutoDetect | Auto-detect projections for analytical model.
Projection | Manually set projections for analytical model using projection parameters.
ManuallyAdjusted | Reports if analytical model has been manually adjusted, this value can only set internally by Revit.
Varies | Alignment types are different at each end.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Class

[image]

Revit 2013 API
AnalyticalConsistencyChecking Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AnalyticalConsistencyChecking : IDisposable
Visual Basic
Public Class AnalyticalConsistencyChecking _
    Implements IDisposable
Visual C++
public ref class AnalyticalConsistencyChecking : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalConsistencyChecking

See Also

AnalyticalConsistencyChecking Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Members

[image] [image]

Revit 2013 API
AnalyticalConsistencyChecking Members
AnalyticalConsistencyChecking Class Methods See Also Send Feedback

The AnalyticalConsistencyChecking type exposes the following members.

Methods

 | Name | Description
 | CheckAnalyticalConsistency | Checks consistency of the Analytical Model.
Public method | Dispose | Releases all resources used by the AnalyticalConsistencyChecking
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalConsistencyChecking Methods

[image] [image]

Revit 2013 API
AnalyticalConsistencyChecking Methods
AnalyticalConsistencyChecking Class See Also Send Feedback

The AnalyticalConsistencyChecking type exposes the following members.

Methods

 | Name | Description
 | CheckAnalyticalConsistency | Checks consistency of the Analytical Model.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


CheckAnalyticalConsistency Method

[image]

Revit 2013 API
AnalyticalConsistencyChecking..::..CheckAnalyticalConsistency Method
AnalyticalConsistencyChecking Class See Also Send Feedback
Checks consistency of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool CheckAnalyticalConsistency(
    Document document
)
Visual Basic
Public Shared Function CheckAnalyticalConsistency ( _
    document As Document _
) As Boolean
Visual C++
public:
static bool CheckAnalyticalConsistency(
    Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which to perform consistency checks.

Return Value

True if run succeeded, false otherwise.

Remarks

Existence of inconsistencies will not affect the return value. If inconsistencies are found, Revit will post warnings regarding those inconsistencies. This should be run from within a transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalConsistencyChecking..::..Dispose Method
AnalyticalConsistencyChecking Class See Also Send Feedback
Releases all resources used by the AnalyticalConsistencyChecking

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalConsistencyChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalCurveSelector Enumeration

[image]

Revit 2013 API
AnalyticalCurveSelector Enumeration
See Also Send Feedback
Specifies which portion of an Analytical Curve is of interest.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalCurveSelector
Visual Basic
Public Enumeration AnalyticalCurveSelector
Visual C++
public enum class AnalyticalCurveSelector

Members

Member name | Description
StartPoint | Start of curve (corresponds to end = 0).
EndPoint | End of curve (corresponds to end = 1).
WholeCurve | Entire curve.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalCurveType Enumeration

[image]

Revit 2013 API
AnalyticalCurveType Enumeration
See Also Send Feedback
Identifies what type of Analytical Model curves should be extracted.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalCurveType
Visual Basic
Public Enumeration AnalyticalCurveType
Visual C++
public enum class AnalyticalCurveType

Members

Member name | Description
RawCurves | Base Analytical Model curves generated.
RigidLinkHead | Rigid Link at end 0 (head) of the Beam.
RigidLinkTail | Rigid Link at end 1 (tail) of the Beam.
ActiveCurves | Curves displayed on screen (not including Rigid Links).
ApproximatedCurves | Curves approximated using linear segments.
BaseCurve | Default Analytical Model curve of linear elements (beams, braces, columns).
AllRigidLinks | All Rigid Link curves. Rigid Link at end 0 (head) will be in the first entry. Rigid Link at end 1 (tail) will be in the last entry.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalDirection Enumeration

[image]

Revit 2013 API
AnalyticalDirection Enumeration
See Also Send Feedback
Specifies a direction for manipulating analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalDirection
Visual Basic
Public Enumeration AnalyticalDirection
Visual C++
public enum class AnalyticalDirection

Members

Member name | Description
Vertical | Change in vertical direction only.
VerticalTop | Vertical change, for top of Element's analytical model.
VerticalBottom | Vertical change, for bottom of Element's analytical model.
Horizontal | Change in horizontal direction only (no elevation change).
HorizontalStart | Horizontal change, corresponding to start of Curve Driver.
HorizontalEnd | Horizontal change, corresponding to end of Curve Driver.
Any | Any change, including vertical and horizontal.
X | Change in X direction
Y | Change in Y direction
Z | Change in Z direction

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalElementSelector Enumeration

[image]

Revit 2013 API
AnalyticalElementSelector Enumeration
See Also Send Feedback
Specifies a portion of an Analytical Element or the whole element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalElementSelector
Visual Basic
Public Enumeration AnalyticalElementSelector
Visual C++
public enum class AnalyticalElementSelector

Members

Member name | Description
StartOrBase | Start or base of element (corresponds to end = 0).
EndOrTop | End or top of element (corresponds to end = 1).
Whole | Entire element

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalFixityState Enumeration

[image]

Revit 2013 API
AnalyticalFixityState Enumeration
See Also Send Feedback
Specifies the fixity setting of individual degrees of freedom in analytical release conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalFixityState
Visual Basic
Public Enumeration AnalyticalFixityState
Visual C++
public enum class AnalyticalFixityState

Members

Member name | Description
Fixed | Degree of freedom is Fixed.
Released | Degree of freedom is Released.
Spring | Degree of freedom has a Spring coefficient.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalLink Class

[image]

Revit 2013 API
AnalyticalLink Class
Members See Also Send Feedback
An analytical link element that is used to create connections between other AnalyticalModel elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AnalyticalLink : Element
Visual Basic
Public Class AnalyticalLink _
    Inherits Element
Visual C++
public ref class AnalyticalLink : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalLink

See Also

AnalyticalLink Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalLink Members

[image] [image]

Revit 2013 API
AnalyticalLink Members
AnalyticalLink Class Methods Properties See Also Send Feedback

The AnalyticalLink type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a AnalyticalLink element between two Hubs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoGenerated | Specifies whether or not an AnalyticalLink was created by an AnalyticalModel element.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidHub | Checks whether input hub is valid for an AnalyticalLink.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | End |
Public property | EndHubId | Hub ID at end of AnalyticalLink.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerId | ElementId of AnalyticalModel element which created the AnalyticalLink (if any) invalidElementId if this Analytical Link was created by the User or API
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Start |
Public property | StartHubId | Hub ID at start of AnalyticalLink.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLink Methods

[image] [image]

Revit 2013 API
AnalyticalLink Methods
AnalyticalLink Class See Also Send Feedback

The AnalyticalLink type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of a AnalyticalLink element between two Hubs.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsAutoGenerated | Specifies whether or not an AnalyticalLink was created by an AnalyticalModel element.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
 | IsValidHub | Checks whether input hub is valid for an AnalyticalLink.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
AnalyticalLink..::..Create Method
AnalyticalLink Class See Also Send Feedback
Creates a new instance of a AnalyticalLink element between two Hubs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static AnalyticalLink Create(
    Document doc,
    ElementId type,
    ElementId startHubId,
    ElementId endHubId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    type As ElementId, _
    startHubId As ElementId, _
    endHubId As ElementId _
) As AnalyticalLink
Visual C++
public:
static AnalyticalLink^ Create(
    Document^ doc,
    ElementId^ type,
    ElementId^ startHubId,
    ElementId^ endHubId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Document to which new AnalyticalLink should be added.
type
Type: Autodesk.Revit.DB..::..ElementId
AnalyticalLinkType for the new AnalyticalLink.
startHubId
Type: Autodesk.Revit.DB..::..ElementId
Hub at start of AnalyticalLink.
endHubId
Type: Autodesk.Revit.DB..::..ElementId
Hub at end of AnalyticalLink.

Return Value

The newly created AnalyticalLink instance.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | startHubId is not a valid Hub ID for an AnalyticalLink element. -or- endHubId is not a valid Hub ID for an AnalyticalLink element. -or- Thrown if startHubId or endHubId do not represent ids of Hubs. -or- Thrown if startHubId == endHubId. -or- Thrown if type does not represent an id of an AnalyticalLinkType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


IsAutoGenerated Method

[image]

Revit 2013 API
AnalyticalLink..::..IsAutoGenerated Method
AnalyticalLink Class See Also Send Feedback
Specifies whether or not an AnalyticalLink was created by an AnalyticalModel element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsAutoGenerated()
Visual Basic
Public Function IsAutoGenerated As Boolean
Visual C++
public:
bool IsAutoGenerated()

Return Value

True if AnalyticalLink was created by an AnalyticalModel element, false otherwise.

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


IsValidHub Method

[image]

Revit 2013 API
AnalyticalLink..::..IsValidHub Method
AnalyticalLink Class See Also Send Feedback
Checks whether input hub is valid for an AnalyticalLink.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidHub(
    Document doc,
    ElementId hubId
)
Visual Basic
Public Shared Function IsValidHub ( _
    doc As Document, _
    hubId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidHub(
    Document^ doc,
    ElementId^ hubId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
Hubs's document.
hubId
Type: Autodesk.Revit.DB..::..ElementId
Hub to test for validity.

Return Value

True is returned when provided hubId points hub that is valid for AnalyticalLink, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLink Properties

[image] [image]

Revit 2013 API
AnalyticalLink Properties
AnalyticalLink Class See Also Send Feedback

The AnalyticalLink type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | End |
Public property | EndHubId | Hub ID at end of AnalyticalLink.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerId | ElementId of AnalyticalModel element which created the AnalyticalLink (if any) invalidElementId if this Analytical Link was created by the User or API
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Start |
Public property | StartHubId | Hub ID at start of AnalyticalLink.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


End Property

[image]

Revit 2013 API
AnalyticalLink..::..End Property
AnalyticalLink Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ End { get; }
Visual Basic
Public ReadOnly Property End As XYZ
    Get
Visual C++
public:
property XYZ^ End {
    XYZ^ get ();
}

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


EndHubId Property

[image]

Revit 2013 API
AnalyticalLink..::..EndHubId Property
AnalyticalLink Class See Also Send Feedback
Hub ID at end of AnalyticalLink.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId EndHubId { get; }
Visual Basic
Public ReadOnly Property EndHubId As ElementId
    Get
Visual C++
public:
property ElementId^ EndHubId {
    ElementId^ get ();
}

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


OwnerId Property

[image]

Revit 2013 API
AnalyticalLink..::..OwnerId Property
AnalyticalLink Class See Also Send Feedback
ElementId of AnalyticalModel element which created the AnalyticalLink (if any) invalidElementId if this Analytical Link was created by the User or API

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId OwnerId { get; }
Visual Basic
Public ReadOnly Property OwnerId As ElementId
    Get
Visual C++
public:
property ElementId^ OwnerId {
    ElementId^ get ();
}

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalyticalLink..::..Parameter Property
AnalyticalLink Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalyticalLink Class
AnalyticalLink Members
Autodesk.Revit.DB.Structure Namespace


Start Property

[image]

Revit 2013 API
AnalyticalLink..::..Start Property
AnalyticalLink Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Start { get; }
Visual Basic
Public ReadOnly Property Start As XYZ
    Get
Visual C++
public:
property XYZ^ Start {
    XYZ^ get ();
}

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


StartHubId Property

[image]

Revit 2013 API
AnalyticalLink..::..StartHubId Property
AnalyticalLink Class See Also Send Feedback
Hub ID at start of AnalyticalLink.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId StartHubId { get; }
Visual Basic
Public ReadOnly Property StartHubId As ElementId
    Get
Visual C++
public:
property ElementId^ StartHubId {
    ElementId^ get ();
}

See Also

AnalyticalLink Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLinkType Class

[image]

Revit 2013 API
AnalyticalLinkType Class
Members See Also Send Feedback
An object that specifies the analysis properties for an AnalyticalLink element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AnalyticalLinkType : ElementType
Visual Basic
Public Class AnalyticalLinkType _
    Inherits ElementType
Visual C++
public ref class AnalyticalLinkType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..AnalyticalLinkType

See Also

AnalyticalLinkType Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalLinkType Members

[image] [image]

Revit 2013 API
AnalyticalLinkType Members
AnalyticalLinkType Class Methods Properties See Also Send Feedback

The AnalyticalLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
 | IsValidAnalyticalFixityState | Returns whether the input fixity state is valid for Analytical Link Type parameters.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationX | Fixity of rotation around X.
Public property | RotationY | Fixity of rotation around Y.
Public property | RotationZ | Fixity of rotation around Z.
Public property | TranslationX | Fixity of translation along X.
Public property | TranslationY | Fixity of translation along Y.
Public property | TranslationZ | Fixity of translation along Z.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLinkType Methods

[image] [image]

Revit 2013 API
AnalyticalLinkType Methods
AnalyticalLinkType Class See Also Send Feedback

The AnalyticalLinkType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
 | IsValidAnalyticalFixityState | Returns whether the input fixity state is valid for Analytical Link Type parameters.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalFixityState Method

[image]

Revit 2013 API
AnalyticalLinkType..::..IsValidAnalyticalFixityState Method
AnalyticalLinkType Class See Also Send Feedback
Returns whether the input fixity state is valid for Analytical Link Type parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool IsValidAnalyticalFixityState(
    AnalyticalFixityState fixityState
)
Visual Basic
Public Shared Function IsValidAnalyticalFixityState ( _
    fixityState As AnalyticalFixityState _
) As Boolean
Visual C++
public:
static bool IsValidAnalyticalFixityState(
    AnalyticalFixityState fixityState
)

Parameters

fixityState
Type: Autodesk.Revit.DB.Structure..::..AnalyticalFixityState
The fixity state value to check.

Return Value

True if valid.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLinkType Properties

[image] [image]

Revit 2013 API
AnalyticalLinkType Properties
AnalyticalLinkType Class See Also Send Feedback

The AnalyticalLinkType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RotationX | Fixity of rotation around X.
Public property | RotationY | Fixity of rotation around Y.
Public property | RotationZ | Fixity of rotation around Z.
Public property | TranslationX | Fixity of translation along X.
Public property | TranslationY | Fixity of translation along Y.
Public property | TranslationZ | Fixity of translation along Z.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalyticalLinkType..::..Parameter Property
AnalyticalLinkType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalyticalLinkType Class
AnalyticalLinkType Members
Autodesk.Revit.DB.Structure Namespace


RotationX Property

[image]

Revit 2013 API
AnalyticalLinkType..::..RotationX Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of rotation around X.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState RotationX { get; set; }
Visual Basic
Public Property RotationX As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState RotationX {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationX is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


RotationY Property

[image]

Revit 2013 API
AnalyticalLinkType..::..RotationY Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of rotation around Y.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState RotationY { get; set; }
Visual Basic
Public Property RotationY As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState RotationY {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationY is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


RotationZ Property

[image]

Revit 2013 API
AnalyticalLinkType..::..RotationZ Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of rotation around Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState RotationZ { get; set; }
Visual Basic
Public Property RotationZ As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState RotationZ {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state rotationZ is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


TranslationX Property

[image]

Revit 2013 API
AnalyticalLinkType..::..TranslationX Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of translation along X.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState TranslationX { get; set; }
Visual Basic
Public Property TranslationX As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState TranslationX {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state translationX is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


TranslationY Property

[image]

Revit 2013 API
AnalyticalLinkType..::..TranslationY Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of translation along Y.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState TranslationY { get; set; }
Visual Basic
Public Property TranslationY As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState TranslationY {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state translationY is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


TranslationZ Property

[image]

Revit 2013 API
AnalyticalLinkType..::..TranslationZ Property
AnalyticalLinkType Class See Also Send Feedback
Fixity of translation along Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AnalyticalFixityState TranslationZ { get; set; }
Visual Basic
Public Property TranslationZ As AnalyticalFixityState
    Get
    Set
Visual C++
public:
property AnalyticalFixityState TranslationZ {
    AnalyticalFixityState get ();
    void set (AnalyticalFixityState value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The fixity state translationZ is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AnalyticalLinkType Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalLoopType Enumeration

[image]

Revit 2013 API
AnalyticalLoopType Enumeration
See Also Send Feedback
Specifies kind of analytical model loop.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum AnalyticalLoopType
Visual Basic
Public Enumeration AnalyticalLoopType
Visual C++
public enum class AnalyticalLoopType

Members

Member name | Description
All | All analytical loops of analytical model surface elements (floor, slab, wall).
External | Loops outside all other loops.
Internal | An internal loop is a loop that is inside another loop.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Class

[image]

Revit 2013 API
AnalyticalModel Class
Members See Also Send Feedback
AnalyticalModel represents the Analytical Model portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModel : Element
Visual Basic
Public Class AnalyticalModel _
    Inherits Element
Visual C++
public ref class AnalyticalModel : public Element

Remarks

AnalyticalModel is made up of the following information:
  • Curves, representing the graphical representation of the Element with respect to analysis.
  • Support Information.
  • Adjustment Information, both Manual and Automatic.
  • Parameter Information, including projection, hard points, approximation, and rigid links.
  • Analytical Offset.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelSurface

See Also

AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Members

[image] [image]

Revit 2013 API
AnalyticalModel Members
AnalyticalModel Class Methods Properties See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disconnect | Unjoin from Hub Element.
Public method | Dispose | (Inherited from Element.)
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction.
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made.
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve.
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOffset | Gets the offset of the analytical model at end.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoint | Retrieves point of the Analytical Model.
Public method | GetReference | Returns a reference to a given curve within the analytical model.
Public method | GetRigidLink | Returns rigid link curve corresponding to selector.
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end.
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element.
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
Public method | IsApproximated | Indicates if Analytical Model is approximated or not.
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled.
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported.
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user.
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve.
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point.
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall.
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect.
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection.
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model.
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model.
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user.
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction.
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction.
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value.
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value.
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetOffset | Sets the offset of the analytical model at end.
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RigidLinksOption | Indicates if parameters indicate if Rigid Links should be formed.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Methods

[image] [image]

Revit 2013 API
AnalyticalModel Methods
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically.
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links.
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed.
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points.
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disconnect | Unjoin from Hub Element.
Public method | Dispose | (Inherited from Element.)
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction.
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model.
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made.
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against.
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve.
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model.
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOffset | Gets the offset of the analytical model at end.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoint | Retrieves point of the Analytical Model.
Public method | GetReference | Returns a reference to a given curve within the analytical model.
Public method | GetRigidLink | Returns rigid link curve corresponding to selector.
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end.
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element.
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element.
Public method | IsApproximated | Indicates if Analytical Model is approximated or not.
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled.
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported.
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled.
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user.
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end.
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve.
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point.
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall.
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect.
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection.
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model.
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model.
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user.
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model.
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction.
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction.
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value.
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value.
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element.
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetOffset | Sets the offset of the analytical model at end.
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Approximate Method

[image]

Revit 2013 API
AnalyticalModel..::..Approximate Method
AnalyticalModel Class See Also Send Feedback
Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Approximate(
    bool enableApproximation
)
Visual Basic
Public Sub Approximate ( _
    enableApproximation As Boolean _
)
Visual C++
public:
void Approximate(
    bool enableApproximation
)

Parameters

enableApproximation
Type: System..::..Boolean
Enable/disable approximated function.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanApproximate Method

[image]

Revit 2013 API
AnalyticalModel..::..CanApproximate Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model can be approximated or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanApproximate()
Visual Basic
Public Function CanApproximate As Boolean
Visual C++
public:
bool CanApproximate()

Return Value

True if Analytical Model can be approximated; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanDisable Method

[image]

Revit 2013 API
AnalyticalModel..::..CanDisable Method
AnalyticalModel Class See Also Send Feedback
Reports whether the user can enable or disable the Analytical Model programmatically.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanDisable()
Visual Basic
Public Function CanDisable As Boolean
Visual C++
public:
bool CanDisable()

Return Value

True if one can enable/disable the Analytical Model, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanDisableAutoDetect Method

[image]

Revit 2013 API
AnalyticalModel..::..CanDisableAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Auto-detect can be disabled programmatically

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanDisableAutoDetect(
    AnalyticalDirection direction
)
Visual Basic
Public Function CanDisableAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool CanDisableAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which to test whether Analytical Auto-detect can be disabled

Return Value

True if Analytical Auto-detect can be disabled, false otherwise

Remarks

Certain Elements can have Auto-detect enabled (e.g., a Structural Wall) but the disabling of Auto-detect is undefined. This is because Auto-detect is actually a setting in the Analytical Projection parameter, and changing this value from Auto-detect is not defined.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanHaveRigidLinks Method

[image]

Revit 2013 API
AnalyticalModel..::..CanHaveRigidLinks Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model supports Rigid Links.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanHaveRigidLinks()
Visual Basic
Public Function CanHaveRigidLinks As Boolean
Visual C++
public:
bool CanHaveRigidLinks()

Return Value

True if Analytical Model supports Rigid Links; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanSetAnalyticalOffset Method

[image]

Revit 2013 API
AnalyticalModel..::..CanSetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Determines whether the Analytical Model Offset can be changed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanSetAnalyticalOffset()
Visual Basic
Public Function CanSetAnalyticalOffset As Boolean
Visual C++
public:
bool CanSetAnalyticalOffset()

Return Value

True if user can set Analytical Model offset, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CanUseHardPoints Method

[image]

Revit 2013 API
AnalyticalModel..::..CanUseHardPoints Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model can use Hard Points.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CanUseHardPoints()
Visual Basic
Public Function CanUseHardPoints As Boolean
Visual C++
public:
bool CanUseHardPoints()

Return Value

True if Analytical Model can use Hard Points, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


CloneAdjustment Method

[image]

Revit 2013 API
AnalyticalModel..::..CloneAdjustment Method
AnalyticalModel Class See Also Send Feedback
The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void CloneAdjustment(
    AnalyticalModel source,
    int end
)
Visual Basic
Public Sub CloneAdjustment ( _
    source As AnalyticalModel, _
    end As Integer _
)
Visual C++
public:
void CloneAdjustment(
    AnalyticalModel^ source,
    int end
)

Parameters

source
Type: Autodesk.Revit.DB.Structure..::..AnalyticalModel
end
Type: System..::..Int32

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Disconnect Method

[image]

Revit 2013 API
AnalyticalModel..::..Disconnect Method
AnalyticalModel Class See Also Send Feedback
Unjoin from Hub Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void Disconnect(
    AnalyticalElementSelector selector
)
Visual Basic
Public Sub Disconnect ( _
    selector As AnalyticalElementSelector _
)
Visual C++
public:
void Disconnect(
    AnalyticalElementSelector selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Enable Method

[image]

Revit 2013 API
AnalyticalModel..::..Enable Method
AnalyticalModel Class See Also Send Feedback
Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void Enable(
    bool enable
)
Visual Basic
Public Sub Enable ( _
    enable As Boolean _
)
Visual C++
public:
void Enable(
    bool enable
)

Parameters

enable
Type: System..::..Boolean
Enable (true) or disable (false) Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


EnableAutoDetect Method

[image]

Revit 2013 API
AnalyticalModel..::..EnableAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Enable or disable Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)
Visual Basic
Public Sub EnableAutoDetect ( _
    direction As AnalyticalDirection, _
    enabled As Boolean _
)
Visual C++
public:
void EnableAutoDetect(
    AnalyticalDirection direction,
    bool enabled
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which to enable Analytical Auto-detect
enabled
Type: System..::..Boolean
Turn Analytical Auto-detect on (true) or off (false)

Remarks

It is possible to enable Analytical Auto-detect for one direction and have it disabled for another direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel cannot disable Auto-detect for direction

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAlignmentMethod Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAlignmentMethod Method
AnalyticalModel Class See Also Send Feedback
Gets the alignment method for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public AnalyticalAlignmentMethod GetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAlignmentMethod ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As AnalyticalAlignmentMethod
Visual C++
public:
AnalyticalAlignmentMethod GetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.

Return Value

The alignment method at a given end.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalModelSketchComponents Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalModelSketchComponents Method
AnalyticalModel Class See Also Send Feedback
Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSketchComponent> GetAnalyticalModelSketchComponents()
Visual Basic
Public Function GetAnalyticalModelSketchComponents As IList(Of AnalyticalModelSketchComponent)
Visual C++
public:
IList<AnalyticalModelSketchComponent^>^ GetAnalyticalModelSketchComponents()

Return Value

If the Analytical Model supports Sketch-based adjustment of the Analytical Model, then this will return an array of AnalyticalModelSketchComponents. Otherwise, it will return an empty array.

Remarks

The AnalyticalModelSketchComponent abstraction is necessary for the those Elements (currently only Slab) consisting of a Sketch, and each Sketch line has the potential to have Analytical Model specific items associated with it. These Analytical Model artifacts are components of the Slab, not of the individual curves (which have no Analytical Model). This form results in writable AnalyticalModelSketchComponents.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalModelSupports Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalModelSupports Method
AnalyticalModel Class See Also Send Feedback
Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<AnalyticalModelSupport> GetAnalyticalModelSupports()
Visual Basic
Public Function GetAnalyticalModelSupports As IList(Of AnalyticalModelSupport)
Visual C++
public:
IList<AnalyticalModelSupport^>^ GetAnalyticalModelSupports()

Return Value

Array of AnalyticalModelSupport objects, each one representing a support.

Remarks

If an Element is not supported by anything, the array returned should be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalOffset Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getOffset() instead.")]
public XYZ GetAnalyticalOffset()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getOffset() instead.")> _
Public Function GetAnalyticalOffset As XYZ
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getOffset() instead.")]
public:
XYZ^ GetAnalyticalOffset()

Return Value

Offset of Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method

[image] [image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction.
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction.

See Also

AnalyticalModel Class
AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method (AnalyticalDirection)

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionDatumPlane Method (AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves analytical model projection information for a specific direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")> _
Public Function GetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane on to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection)

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Gets the datum plane for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAnalyticalProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model is projected.

Return Value

Datum Plane on to which analytical model is projected, or invalidElementId if not projected to a Datum Plane.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns). This Datum Plane identifies a Level, a Grid, or a Ref Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method

[image] [image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.

See Also

AnalyticalModel Class
AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method (AnalyticalDirection)

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionType Method (AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")> _
Public Function GetAnalyticalProjectionType ( _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call getAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction) instead.")]
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of projection.

Return Value

Indicates if the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection)

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection)
AnalyticalModel Class See Also Send Feedback
Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAnalyticalProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.

Return Value

Indicates if the projection is a preset value, or refers to a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model

See Also

AnalyticalModel Class
GetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace


GetAnalyzeAs Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAnalyzeAs Method
AnalyticalModel Class See Also Send Feedback
Returns value of Analyze As parameter for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyzeAs GetAnalyzeAs()
Visual Basic
Public Function GetAnalyzeAs As AnalyzeAs
Visual C++
public:
AnalyzeAs GetAnalyzeAs()

Return Value

AnalyzeAs enumeration, indicating how Analytical Model is analyzed.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetApproximationDeviation Method

[image]

Revit 2013 API
AnalyticalModel..::..GetApproximationDeviation Method
AnalyticalModel Class See Also Send Feedback
Retrieves amount by which approximation is made.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double GetApproximationDeviation()
Visual Basic
Public Function GetApproximationDeviation As Double
Visual C++
public:
double GetApproximationDeviation()

Return Value

Maximum distance from approximated line to curve. If approximation does not make sense, then this will be 0.0.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetAutoDetectMatchedElements Method

[image]

Revit 2013 API
AnalyticalModel..::..GetAutoDetectMatchedElements Method
AnalyticalModel Class See Also Send Feedback
Retrieves other Element Ids that this Element is Auto-detecting against.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAutoDetectMatchedElements(
    AnalyticalDirection direction
)
Visual Basic
Public Function GetAutoDetectMatchedElements ( _
    direction As AnalyticalDirection _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAutoDetectMatchedElements(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Analytical Auto-detect is being done.

Return Value

A set of Element Ids against which this Element is Auto-detecting. The set may be empty if this Element is not Auto-detecting against anything.

Remarks

An empty set is a valid return value. It just means that this Element is not Auto-detecting against any other Elements in the given direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetCurve Method

[image]

Revit 2013 API
AnalyticalModel..::..GetCurve Method
AnalyticalModel Class Example See Also Send Feedback
Returns the single curve of the Analytical Model, if it is only one curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Curve GetCurve()
Visual Basic
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

Single curve of the Analytical Model.

Examples

CopyC#
public void GetColumnCurve(FamilyInstance familyInst)
{
    // get AnalyticalModel from structural column
    if (familyInst.StructuralType == StructuralType.Column)
    {
        AnalyticalModel modelColumn = familyInst.GetAnalyticalModel();
        // column should be represented by a single curve
        if (modelColumn.IsSingleCurve() == true)
        {
            Curve columnCurve = modelColumn.GetCurve();
        }
    }
}
CopyVB.NET
Public Sub GetColumnCurve(ByVal familyInst As Autodesk.Revit.DB.FamilyInstance)
    ' get AnalyticalModel from structural column
    If familyInst.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Column Then
        Dim modelColumn As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
        ' column should be represented by a single curve
        If modelColumn.IsSingleCurve() = True Then
            Dim columnCurve As Curve = modelColumn.GetCurve()
        End If
    End If
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel contains more than one single curve.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetCurves Method

[image]

Revit 2013 API
AnalyticalModel..::..GetCurves Method
AnalyticalModel Class See Also Send Feedback
Retrieves all curves for the Analytical Model of a given type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<Curve> GetCurves(
    AnalyticalCurveType curveType
)
Visual Basic
Public Function GetCurves ( _
    curveType As AnalyticalCurveType _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurves(
    AnalyticalCurveType curveType
)

Parameters

curveType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalCurveType
Which curve type should be returned.

Return Value

An array of curves representing analytical model.

Remarks

If the analytical model contains no curves of the given type, then the returned array may be empty.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetElementId Method

[image]

Revit 2013 API
AnalyticalModel..::..GetElementId Method
AnalyticalModel Class See Also Send Feedback
Retrieves Element Id of the structural element corresponding to the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetElementId()
Visual Basic
Public Function GetElementId As ElementId
Visual C++
public:
ElementId^ GetElementId()

Return Value

Element Id for a structural element.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetManualAdjustmentMatchedElements Method

[image]

Revit 2013 API
AnalyticalModel..::..GetManualAdjustmentMatchedElements Method
AnalyticalModel Class See Also Send Feedback
Retrieves other Element Ids against which the Analytical Model has been adjusted.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetManualAdjustmentMatchedElements()
Visual Basic
Public Function GetManualAdjustmentMatchedElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetManualAdjustmentMatchedElements()

Return Value

Set of Element Ids, representing those Elements against which the Analytical Model has been adjusted. The set may be empty if Analytical Model is not participating in locked Manual Analytical Adjustment.

Remarks

This is only meaningful for locked Manual Analytical Adjustment. When operating unlocked, the Analytical Model is offset by a certain amount, not against a given Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetOffset Method

[image]

Revit 2013 API
AnalyticalModel..::..GetOffset Method
AnalyticalModel Class See Also Send Feedback
Gets the offset of the analytical model at end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ GetOffset(
    AnalyticalElementSelector selector
)
Visual Basic
Public Function GetOffset ( _
    selector As AnalyticalElementSelector _
) As XYZ
Visual C++
public:
XYZ^ GetOffset(
    AnalyticalElementSelector selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.

Return Value

Offset of analytical model from base analytical model at the given end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | selector is not valid for the Analytical Model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Function only work for curve-based elements.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetPoint Method

[image]

Revit 2013 API
AnalyticalModel..::..GetPoint Method
AnalyticalModel Class Example See Also Send Feedback
Retrieves point of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ GetPoint()
Visual Basic
Public Function GetPoint As XYZ
Visual C++
public:
XYZ^ GetPoint()

Return Value

Point of the Analytical Model.

Examples

CopyC#
// retrieve and iterate current selected element
UIDocument uidoc = commandData.Application.ActiveUIDocument;
ElementSet selection = uidoc.Selection.Elements;
foreach (Element e in selection)
{
    // if the element is structural footing
    FamilyInstance familyInst = e as FamilyInstance;
    if (null != familyInst && familyInst.StructuralType == StructuralType.Footing)
    {
        AnalyticalModel model = familyInst.GetAnalyticalModel();
        // structural footing should be expressable as a single point
        if (model.IsSinglePoint() == true)
        {
            XYZ analyticalLocationPoint = model.GetPoint();
        }
    }
}
CopyVB.NET
' retrieve and iterate current selected element
Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
Dim selection As ElementSet = uidoc.Selection.Elements
For Each e As Autodesk.Revit.DB.Element In selection
    ' if the element is structural footing
    Dim familyInst As Autodesk.Revit.DB.FamilyInstance = TryCast(e, Autodesk.Revit.DB.FamilyInstance)
    If familyInst IsNot Nothing AndAlso familyInst.StructuralType = Autodesk.Revit.DB.Structure.StructuralType.Footing Then
        Dim model As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
        ' structural footing should be expressable as a single point
        If model.IsSinglePoint() = True Then
            Dim analyticalLocationPoint As Autodesk.Revit.DB.XYZ = model.GetPoint()
        End If
    End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel cannot be expressed as a single point.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetReference Method

[image]

Revit 2013 API
AnalyticalModel..::..GetReference Method
AnalyticalModel Class See Also Send Feedback
Returns a reference to a given curve within the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Reference GetReference(
    AnalyticalModelSelector selector
)
Visual Basic
Public Function GetReference ( _
    selector As AnalyticalModelSelector _
) As Reference
Visual C++
public:
Reference^ GetReference(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalModelSelector
Specifies where in the analytical model the reference lies.

Return Value

Requested reference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | selector is not valid for this AnalyticalModel.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetRigidLink Method

[image]

Revit 2013 API
AnalyticalModel..::..GetRigidLink Method
AnalyticalModel Class See Also Send Feedback
Returns rigid link curve corresponding to selector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Curve GetRigidLink(
    AnalyticalModelSelector selector
)
Visual Basic
Public Function GetRigidLink ( _
    selector As AnalyticalModelSelector _
) As Curve
Visual C++
public:
Curve^ GetRigidLink(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalModelSelector
Identifies from which end of the analytical model to get the Rigid Link.

Return Value

Rigid link satisfying selector.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | selector is not valid for this AnalyticalModel. -or- Thrown if selector identifies a entire curve instead of just an endpoint. This is because this only returns one curve, and an entire analytical curve may have any number of rigid links.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


GetSweptProfile Method

[image]

Revit 2013 API
AnalyticalModel..::..GetSweptProfile Method
AnalyticalModel Class See Also Send Feedback
Retrieves the swept profile information for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSweptProfile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As AnalyticalModelSweptProfile
Visual C++
public:
AnalyticalModelSweptProfile^ GetSweptProfile()

Return Value

The swept profile information for the Analytical Model.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel does not support a swept profile representation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasAlignment Method

[image]

Revit 2013 API
AnalyticalModel..::..HasAlignment Method
AnalyticalModel Class See Also Send Feedback
Checks if analytical alignment is applicable at a given end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasAlignment(
    AnalyticalDirection direction
)
Visual Basic
Public Function HasAlignment ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool HasAlignment(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
The direction of the analytical model.

Return Value

True if analytical alignment is supported.

Remarks

True for analytical models of linear elements (beams, braces, columns).

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasDeletedLinks Method

[image]

Revit 2013 API
AnalyticalModel..::..HasDeletedLinks Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model contains deleted Analytical Links.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasDeletedLinks()
Visual Basic
Public Function HasDeletedLinks As Boolean
Visual C++
public:
bool HasDeletedLinks()

Return Value

True if contains, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasRigidLinksWith Method

[image]

Revit 2013 API
AnalyticalModel..::..HasRigidLinksWith Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model has Rigid Links with specified element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasRigidLinksWith(
    ElementId neighborId
)
Visual Basic
Public Function HasRigidLinksWith ( _
    neighborId As ElementId _
) As Boolean
Visual C++
public:
bool HasRigidLinksWith(
    ElementId^ neighborId
)

Parameters

neighborId
Type: Autodesk.Revit.DB..::..ElementId
neighboring Element, to which Rigid Links may exist.

Return Value

true if Rigid Links exist, false otherwise.

Remarks

This is bidirectional, so this can be used to see if Rigid Links exist from Column to Beam.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


HasSweptProfile Method

[image]

Revit 2013 API
AnalyticalModel..::..HasSweptProfile Method
AnalyticalModel Class See Also Send Feedback
Indicates if this Element's Analytical Model can be represented as a swept profile.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool HasSweptProfile()
Visual Basic
Public Function HasSweptProfile As Boolean
Visual C++
public:
bool HasSweptProfile()

Return Value

True if the Analytical Model can be represented as a swept profile, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsAnalyzeAsValid Method

[image]

Revit 2013 API
AnalyticalModel..::..IsAnalyzeAsValid Method
AnalyticalModel Class See Also Send Feedback
Determines if the given Analyze As parameter is valid for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)
Visual Basic
Public Function IsAnalyzeAsValid ( _
    analyzeAs As AnalyzeAs _
) As Boolean
Visual C++
public:
bool IsAnalyzeAsValid(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed.

Return Value

True if valid; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsApproximated Method

[image]

Revit 2013 API
AnalyticalModel..::..IsApproximated Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model is approximated or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsApproximated()
Visual Basic
Public Function IsApproximated As Boolean
Visual C++
public:
bool IsApproximated()

Return Value

True if the Analytical Model is approximated, false otherwise. False if approximation is meaningless for Analytical Model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsAutoDetectEnabled Method

[image]

Revit 2013 API
AnalyticalModel..::..IsAutoDetectEnabled Method
AnalyticalModel Class See Also Send Feedback
Reports if Analytical Auto-detect for the given direction is enabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)
Visual Basic
Public Function IsAutoDetectEnabled ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsAutoDetectEnabled(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Auto-detect behavior may be enabled.

Return Value

True if enabled in the given direction, false otherwise.

Remarks

Just because Auto-detect is enabled in one direction, that does not mean that it is enabled in a different direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for Analytical Auto-detect.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsElementFullySupported Method

[image]

Revit 2013 API
AnalyticalModel..::..IsElementFullySupported Method
AnalyticalModel Class See Also Send Feedback
Indicates if Analytical Model is fully supported.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsElementFullySupported()
Visual Basic
Public Function IsElementFullySupported As Boolean
Visual C++
public:
bool IsElementFullySupported()

Return Value

True if Analytical Model is fully supported, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsEnabled Method

[image]

Revit 2013 API
AnalyticalModel..::..IsEnabled Method
AnalyticalModel Class See Also Send Feedback
Reports whether the Analytical Model is enabled or disabled.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsEnabled()
Visual Basic
Public Function IsEnabled As Boolean
Visual C++
public:
bool IsEnabled()

Return Value

True if Analytical Model is enabled, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support enabling or disabling the analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsManuallyAdjusted Method

[image]

Revit 2013 API
AnalyticalModel..::..IsManuallyAdjusted Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Analytical Model has been manually adjusted by the user.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsManuallyAdjusted()
Visual Basic
Public Function IsManuallyAdjusted As Boolean
Visual C++
public:
bool IsManuallyAdjusted()

Return Value

True if user has manually adjusted the Analytical Model; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsModified Method

[image]

Revit 2013 API
AnalyticalModel..::..IsModified Method
AnalyticalModel Class See Also Send Feedback
Checks if AM has been adjusted from auto-detect at any end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsModified()
Visual Basic
Public Function IsModified As Boolean
Visual C++
public:
bool IsModified()

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsSingleCurve Method

[image]

Revit 2013 API
AnalyticalModel..::..IsSingleCurve Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Analytical Model can be expressed as a single curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSingleCurve()
Visual Basic
Public Function IsSingleCurve As Boolean
Visual C++
public:
bool IsSingleCurve()

Return Value

True if Analytical Model can be expressed as a single curve, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsSinglePoint Method

[image]

Revit 2013 API
AnalyticalModel..::..IsSinglePoint Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Analytical Model can be expressed as a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSinglePoint()
Visual Basic
Public Function IsSinglePoint As Boolean
Visual C++
public:
bool IsSinglePoint()

Return Value

True if Analytical Model can be expressed as a single point, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsSurface Method

[image]

Revit 2013 API
AnalyticalModel..::..IsSurface Method
AnalyticalModel Class See Also Send Feedback
Checks if the analytical model belongs to the surface object like floor, slab or wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSurface()
Visual Basic
Public Function IsSurface As Boolean
Visual C++
public:
bool IsSurface()

Return Value

True is returned when this object is AnalyticalModelSurface class, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalProjectionType Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Analytical Projection Type is valid for the given Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")]
public bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")> _
Public Function IsValidAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call isValidProjectionType() instead.")]
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type for Analytical Model Projection.

Return Value

True if Analytical Projection Type is valid; false otherwise. False if direction does not satisfy isValidDirectionForProjection().

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDatumPlaneForProjection Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidDatumPlaneForProjection Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")]
public bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")> _
Public Function IsValidDatumPlaneForProjection ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call isValidProjectionDatumPlane() instead.")]
public:
bool IsValidDatumPlaneForProjection(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of analytical model projection.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model is projected.

Return Value

True if Datum Plane is valid, false otherwise.

Remarks

Validity of a Datum Plane for analytical projection is both element and context specific. For instance, two different Beams may have two different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDirectionForAutoDetect Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidDirectionForAutoDetect Method
AnalyticalModel Class See Also Send Feedback
Tests if the supplied direction is valid for Analytical Auto-detect.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidDirectionForAutoDetect ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForAutoDetect(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Auto-detect behavior may be valid.

Return Value

True if direction is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidDirectionForProjection Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidDirectionForProjection Method
AnalyticalModel Class See Also Send Feedback
Indicates if the input direction is valid for Analytical Model projection.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidDirectionForProjection ( _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidDirectionForProjection(
    AnalyticalDirection direction
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which the Analytical Model may be projected.

Return Value

True if AnalyticalDirection is valid for Element, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidForManualAdjustment Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidForManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Indicates if the identified reference is acceptable for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidForManualAdjustment(
    Reference reference
)
Visual Basic
Public Function IsValidForManualAdjustment ( _
    reference As Reference _
) As Boolean
Visual C++
public:
bool IsValidForManualAdjustment(
    Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
Reference that will be examined.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful to determine if a reference is acceptable for Manual Analytical Adjustment in general. This looks briefly at the reference, without looking at the specific context.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidManualAdjustmentSource Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidManualAdjustmentSource Method
AnalyticalModel Class See Also Send Feedback
Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentSource(
    Reference source,
    AnalyticalDirection adjustmentDirection
)
Visual Basic
Public Function IsValidManualAdjustmentSource ( _
    source As Reference, _
    adjustmentDirection As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentSource(
    Reference^ source,
    AnalyticalDirection adjustmentDirection
)

Parameters

source
Type: Autodesk.Revit.DB..::..Reference
Reference to be examined.
adjustmentDirection
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which adjustment will occur.

Return Value

True if reference can be used as source; false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for usage as a "Source". In other words, if the reference identifies an Analytical Model portion that can be adjusted by the user.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidManualAdjustmentTarget Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidManualAdjustmentTarget Method
AnalyticalModel Class See Also Send Feedback
Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidManualAdjustmentTarget(
    Reference target,
    Reference source,
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidManualAdjustmentTarget ( _
    target As Reference, _
    source As Reference, _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidManualAdjustmentTarget(
    Reference^ target,
    Reference^ source,
    AnalyticalDirection direction
)

Parameters

target
Type: Autodesk.Revit.DB..::..Reference
Target reference.
source
Type: Autodesk.Revit.DB..::..Reference
Source reference. This is necessary to avoid illegal conditions. For instance if Element A is manually adjusted against Element B, Element B cannot in general be adjusted against Element A.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which source Element can be adjusted against target Element.

Return Value

True if reference can be used, false otherwise.

Remarks

This method is useful for determining if a reference is acceptable for a target. In other words, if the reference identifies an Analytical Model portion that can be adjusted against.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidProjectionDatumPlane Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
Public Function IsValidProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of analytical model projection.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model is projected.

Return Value

True if Datum Plane is valid, false otherwise.

Remarks

Validity of a Datum Plane for analytical projection is both element and context specific. For instance, two different Beams may have two different results.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidProjectionType Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidProjectionType Method
AnalyticalModel Class See Also Send Feedback
Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Function IsValidProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
Selector of element part.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which Analytical Model may be projected.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type for Analytical Model Projection.

Return Value

True if Projection Type is valid; false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidRigidLinksOption Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidRigidLinksOption Method
AnalyticalModel Class See Also Send Feedback
Indicates if Rigid Links option is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)
Visual Basic
Public Function IsValidRigidLinksOption ( _
    rigidLinksOption As AnalyticalRigidLinksOption _
) As Boolean
Visual C++
public:
bool IsValidRigidLinksOption(
    AnalyticalRigidLinksOption rigidLinksOption
)

Parameters

rigidLinksOption
Type: Autodesk.Revit.DB.Structure..::..AnalyticalRigidLinksOption
Rigid Links option to validate.

Return Value

True if option is valid, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidSelector Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidSelector Method
AnalyticalModel Class See Also Send Feedback
Indicates if the input selector is valid for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidSelector(
    AnalyticalModelSelector selector
)
Visual Basic
Public Function IsValidSelector ( _
    selector As AnalyticalModelSelector _
) As Boolean
Visual C++
public:
bool IsValidSelector(
    AnalyticalModelSelector^ selector
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalModelSelector
Portion of the analytical model geometry.

Return Value

True if selector is valid for this Analytical Model, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


IsValidSelectorAndDirection Method

[image]

Revit 2013 API
AnalyticalModel..::..IsValidSelectorAndDirection Method
AnalyticalModel Class See Also Send Feedback
Indicates if the input selector is valid for analytical direction for Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidSelectorAndDirection(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)
Visual Basic
Public Function IsValidSelectorAndDirection ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection _
) As Boolean
Visual C++
public:
bool IsValidSelectorAndDirection(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
Selector of element part
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction which will be validated for the Analytical Model

Return Value

True if selector is valid for given direction, false otherwise

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


ManuallyAdjust Method

[image]

Revit 2013 API
AnalyticalModel..::..ManuallyAdjust Method
AnalyticalModel Class Example See Also Send Feedback
Perform Manual Analytical Adjustment on analytical model, with respect to another Element

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ManuallyAdjust(
    Reference source,
    Reference target,
    bool lock
)
Visual Basic
Public Function ManuallyAdjust ( _
    source As Reference, _
    target As Reference, _
    lock As Boolean _
) As Boolean
Visual C++
public:
bool ManuallyAdjust(
    Reference^ source,
    Reference^ target,
    bool lock
)

Parameters

source
Type: Autodesk.Revit.DB..::..Reference
Which part of Analytical Model needs to change.
target
Type: Autodesk.Revit.DB..::..Reference
Which part of another Analytical Model change should be made against.
lock
Type: System..::..Boolean
Whether adjustment should be locked or unlocked.

Return Value

Indicates the successful completion of the Manual Analytical Adjustment operation. True if source Element was adjusted successfully, false otherwise.

Remarks

If the Manual Analytical Adjustment is locked, then the Source Analytical Model will update itself whenever the Target Analytical Model changes. If the Manual Analytical Adjustment is not locked, then the Source Analytical Model will remain at a given offset, not following the target. Success, in this context, is achieved when the Source adjusts itself against the Target. Additionally, this requires an open transaction on the current document. Model regeneration is required after the operation.

Examples

CopyC#
// to do

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if source cannot be used as source reference, or if target cannot be used as target reference.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


ResetLinks Method

[image]

Revit 2013 API
AnalyticalModel..::..ResetLinks Method
AnalyticalModel Class See Also Send Feedback
The function is trying to recreate analytical link elements that were deleted by the user.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ResetLinks()
Visual Basic
Public Sub ResetLinks
Visual C++
public:
void ResetLinks()

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


ResetManualAdjustment Method

[image]

Revit 2013 API
AnalyticalModel..::..ResetManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Resets all manual adjustments performed by the user onto the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ResetManualAdjustment()
Visual Basic
Public Function ResetManualAdjustment As Boolean
Visual C++
public:
bool ResetManualAdjustment()

Return Value

Indicates the successful reset of all manual adjustment. True if reset succeeds, false otherwise.

Remarks

Resets all manual adjustment. Therefore, if Analytical Offset is applicable, that will reset as well. Success, in this context, is achieved only when the Source resets itself to its original position.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAlignmentMethod Method

[image]

Revit 2013 API
AnalyticalModel..::..SetAlignmentMethod Method
AnalyticalModel Class See Also Send Feedback
Sets the alignment method for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalAlignmentMethod method
)
Visual Basic
Public Sub SetAlignmentMethod ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    method As AnalyticalAlignmentMethod _
)
Visual C++
public:
void SetAlignmentMethod(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalAlignmentMethod method
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.
method
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
The alignment method at a given end.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- method is in valid for analytical model

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalOffset Method

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalOffset Method
AnalyticalModel Class See Also Send Feedback
Sets Analytical Offset in the case where the user can do that.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call setOffset() instead.")]
public void SetAnalyticalOffset(
    XYZ offset
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call setOffset() instead.")> _
Public Sub SetAnalyticalOffset ( _
    offset As XYZ _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call setOffset() instead.")]
public:
void SetAnalyticalOffset(
    XYZ^ offset
)

Parameters

offset
Type: Autodesk.Revit.DB..::..XYZ
Offset for the entire Analytical Model.

Remarks

This is different than Manual Analytical Adjustment, in that it is a basic offset that applies to the entire Analytical Model at once. Additionally, it is set in a different manner than Manual Analytical Adjustment, since it does not depend on another Element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | This AnalyticalModel does not support offset.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method

[image] [image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionDatumPlane Method
AnalyticalModel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane.
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction.

See Also

AnalyticalModel Class
AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method (AnalyticalDirection, ElementId)

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionDatumPlane Method (AnalyticalDirection, ElementId)
AnalyticalModel Class See Also Send Feedback
Sets analytical model projection to a Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")]
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")> _
Public Sub SetAnalyticalProjectionDatumPlane ( _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call setAnalyticalProjectionDatumPlane(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, ElementId datumPlaneId) instead.")]
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model may be projected.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
SetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection, ElementId)

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionDatumPlane Method (AnalyticalElementSelector, AnalyticalDirection, ElementId)
AnalyticalModel Class See Also Send Feedback
Sets the datum plane for a given selector and direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId datumPlaneId
)
Visual Basic
Public Sub SetAnalyticalProjectionDatumPlane ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    ElementId^ datumPlaneId
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction in which analytical model may be projected.
datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Datum Plane on to which analytical model may be projected.

Remarks

Applicable for analytical models of linear elements (beams, braces, columns). This Datum Plane identifies a Level, a Grid, or a Ref Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- Datum Plane is invalid projection target.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModel Class
SetAnalyticalProjectionDatumPlane Overload
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method

[image] [image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionType Method
AnalyticalModel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value.
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value.

See Also

AnalyticalModel Class
AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method (AnalyticalDirection, AnalyticalProjectionType)

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionType Method (AnalyticalDirection, AnalyticalProjectionType)
AnalyticalModel Class See Also Send Feedback
Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, AnalyticalProjectionType::Enum projectionType) instead.")]
public void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2012. Call setAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, AnalyticalProjectionType::Enum projectionType) instead.")> _
Public Sub SetAnalyticalProjectionType ( _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2012. Call setAnalyticalProjectionType(AnalyticalElementSelector::Enum selector, AnalyticalDirection::Enum direction, AnalyticalProjectionType::Enum projectionType) instead.")]
public:
void SetAnalyticalProjectionType(
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction to project Analytical Model.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Preset value for Analytical Model projection.

Remarks

This should be used if setting the analytical model projection to something other than a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the direction

See Also

AnalyticalModel Class
SetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType)

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyticalProjectionType Method (AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType)
AnalyticalModel Class See Also Send Feedback
Sets the analytical model projection to a preset value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Sub SetAnalyticalProjectionType ( _
    selector As AnalyticalElementSelector, _
    direction As AnalyticalDirection, _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalElementSelector selector,
    AnalyticalDirection direction,
    AnalyticalProjectionType projectionType
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
direction
Type: Autodesk.Revit.DB.Structure..::..AnalyticalDirection
Direction of the analytical model.
projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Preset value for Analytical Model projection.

Remarks

This should be used if setting the analytical model projection to something other than a Datum Plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | direction is invalid for analytical model -or- The analytical model does not provide projectionType for the selector or direction

See Also

AnalyticalModel Class
SetAnalyticalProjectionType Overload
Autodesk.Revit.DB.Structure Namespace


SetAnalyzeAs Method

[image]

Revit 2013 API
AnalyticalModel..::..SetAnalyzeAs Method
AnalyticalModel Class See Also Send Feedback
Sets value of Analyze As parameter for this Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)
Visual Basic
Public Sub SetAnalyzeAs ( _
    analyzeAs As AnalyzeAs _
)
Visual C++
public:
void SetAnalyzeAs(
    AnalyzeAs analyzeAs
)

Parameters

analyzeAs
Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed .

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | analyzeAs is invalid for analytical model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetApproximationDeviation Method

[image]

Revit 2013 API
AnalyticalModel..::..SetApproximationDeviation Method
AnalyticalModel Class See Also Send Feedback
Adjusts the amount by which approximation is made.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetApproximationDeviation(
    double deviation
)
Visual Basic
Public Sub SetApproximationDeviation ( _
    deviation As Double _
)
Visual C++
public:
void SetApproximationDeviation(
    double deviation
)

Parameters

deviation
Type: System..::..Double
Maximum distance from line to actual curve

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel does not support approximation.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetOffset Method

[image]

Revit 2013 API
AnalyticalModel..::..SetOffset Method
AnalyticalModel Class Example See Also Send Feedback
Sets the offset of the analytical model at end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetOffset(
    AnalyticalElementSelector selector,
    XYZ offset
)
Visual Basic
Public Sub SetOffset ( _
    selector As AnalyticalElementSelector, _
    offset As XYZ _
)
Visual C++
public:
void SetOffset(
    AnalyticalElementSelector selector,
    XYZ^ offset
)

Parameters

selector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of analytical model to offset.
offset
Type: Autodesk.Revit.DB..::..XYZ
New offset for end of analytical model.

Examples

CopyC#
// extend the analytical model by 1 foot at each end. Direction of offset is parallel to the analytical model curve.
AnalyticalModel model = familyInstance.GetAnalyticalModel();
Curve curve = model.GetCurve();
XYZ tangentDirection0 = curve.ComputeDerivatives(0, true).BasisX.Normalize().Negate();
XYZ tangentDirection1 = curve.ComputeDerivatives(1, true).BasisX.Normalize();
model.SetOffset(AnalyticalElementSelector.StartOrBase, tangentDirection0);
model.SetOffset(AnalyticalElementSelector.EndOrTop, tangentDirection1);

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | Function only work for curve-based elements.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SetUsesHardPoints Method

[image]

Revit 2013 API
AnalyticalModel..::..SetUsesHardPoints Method
AnalyticalModel Class See Also Send Feedback
Sets Hard Points for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetUsesHardPoints(
    bool hardPoints
)
Visual Basic
Public Sub SetUsesHardPoints ( _
    hardPoints As Boolean _
)
Visual C++
public:
void SetUsesHardPoints(
    bool hardPoints
)

Parameters

hardPoints
Type: System..::..Boolean
Enable/disable Hard Points (true = enable).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | This AnalyticalModel cannot use Hard Points.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


SupportsManualAdjustment Method

[image]

Revit 2013 API
AnalyticalModel..::..SupportsManualAdjustment Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Element supports Manual Analytical Adjustment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool SupportsManualAdjustment()
Visual Basic
Public Function SupportsManualAdjustment As Boolean
Visual C++
public:
bool SupportsManualAdjustment()

Return Value

True if Manual Adjustment is possible, false otherwise.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


UsesHardPoints Method

[image]

Revit 2013 API
AnalyticalModel..::..UsesHardPoints Method
AnalyticalModel Class See Also Send Feedback
Indicates if the Analytical Model is using Hard Points during approximation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool UsesHardPoints()
Visual Basic
Public Function UsesHardPoints As Boolean
Visual C++
public:
bool UsesHardPoints()

Return Value

True if Hard Points are being used, false otherwise. False if Hard Points are meaningless for Analytical Model.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModel Properties

[image] [image]

Revit 2013 API
AnalyticalModel Properties
AnalyticalModel Class See Also Send Feedback

The AnalyticalModel type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RigidLinksOption | Indicates if parameters indicate if Rigid Links should be formed.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalyticalModel..::..Parameter Property
AnalyticalModel Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalyticalModel Class
AnalyticalModel Members
Autodesk.Revit.DB.Structure Namespace


RigidLinksOption Property

[image]

Revit 2013 API
AnalyticalModel..::..RigidLinksOption Property
AnalyticalModel Class See Also Send Feedback
Indicates if parameters indicate if Rigid Links should be formed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalRigidLinksOption RigidLinksOption { get; set; }
Visual Basic
Public Property RigidLinksOption As AnalyticalRigidLinksOption
    Get
    Set
Visual C++
public:
property AnalyticalRigidLinksOption RigidLinksOption {
    AnalyticalRigidLinksOption get ();
    void set (AnalyticalRigidLinksOption value);
}

Field Value

For Structural Beams:
  • Enabled: rigid links will be formed, overriding Structural Column setting.
  • Disabled: rigid links will not be formed, overriding Structural Column setting.
  • FromColumn: rigid links may be formed, depending on Structural Column setting.
For Structural Columns:
  • Enabled: rigid links will be formed, unless Structural Beam setting overrides.
  • Disabled: rigid links will not be formed, unless Structural Beam setting overrides.
If rigid links are not applicable to this Analytical Model, this will return Disabled.

Remarks

Rigid Links are the result of an interaction between neighboring Structural Columns and Structural Beams

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: rigidLinksOption is not valid for this Analytical Model.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: This AnalyticalModel does not support Rigid Links.

See Also

AnalyticalModel Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Class

[image]

Revit 2013 API
AnalyticalModelSelector Class
Members Example See Also Send Feedback
Defines a portion of an Analytical Model for an Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSelector : IDisposable
Visual Basic
Public Class AnalyticalModelSelector _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSelector : IDisposable

Remarks

This is used to identify the portion of an analytical model of interest to a client. To identify the portion of the analytical model, the client must identify the curve in question, by using one of the following:
  • The specific curve within the analytical model.
  • The index of the curve within the analytical model.
If a specific part of that curve is of interest, the client needs to identify that by specifying one of the following:
  • The start of the curve.
  • The end of the curve.
  • The entire curve. This is the default behavior, so this does not need specifying.

Examples

CopyC#
public bool GetReferenceData(FamilyInstance familyInst)
{
    AnalyticalModel analyticalModelFrame = familyInst.GetAnalyticalModel();
    Curve analyticalCurve = analyticalModelFrame.GetCurve();
    if (null != analyticalCurve)
    {
        // test the stable reference to the curve.
        AnalyticalModelSelector amSelector = new AnalyticalModelSelector(analyticalCurve);
        amSelector.CurveSelector = AnalyticalCurveSelector.WholeCurve;
        Reference curveReference = analyticalModelFrame.GetReference(amSelector);

        // test the stable reference to the start point of the curve
        amSelector.CurveSelector = AnalyticalCurveSelector.StartPoint;
        Reference startPointReference = analyticalModelFrame.GetReference(amSelector);

        // test the stable reference to the start point of the curve
        amSelector.CurveSelector = AnalyticalCurveSelector.EndPoint;
        Reference endPointReference = analyticalModelFrame.GetReference(amSelector);
    }

    return true;
}
CopyVB.NET
Public Function GetReferenceData(ByVal familyInst As Autodesk.Revit.DB.FamilyInstance) As Boolean
    Dim analyticalModelFrame As Autodesk.Revit.DB.Structure.AnalyticalModel = familyInst.GetAnalyticalModel()
    Dim analyticalCurve As Curve = analyticalModelFrame.GetCurve()
    If analyticalCurve IsNot Nothing Then
        ' test the stable reference to the curve.
        Dim amSelector As New Autodesk.Revit.DB.Structure.AnalyticalModelSelector(analyticalCurve)
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.WholeCurve
        Dim curveReference As Reference = analyticalModelFrame.GetReference(amSelector)

        ' test the stable reference to the start point of the curve
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.StartPoint
        Dim startPointReference As Reference = analyticalModelFrame.GetReference(amSelector)

        ' test the stable reference to the start point of the curve
        amSelector.CurveSelector = Autodesk.Revit.DB.Structure.AnalyticalCurveSelector.EndPoint
        Dim endPointReference As Reference = analyticalModelFrame.GetReference(amSelector)
    End If

    Return True
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSelector

See Also

AnalyticalModelSelector Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Members

[image] [image]

Revit 2013 API
AnalyticalModelSelector Members
AnalyticalModelSelector Class Constructors Methods Properties See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Constructors

 | Name | Description
Public method | AnalyticalModelSelector()()()() | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve.
Public method | AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSelector
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor

[image] [image]

Revit 2013 API
AnalyticalModelSelector Constructor
AnalyticalModelSelector Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AnalyticalModelSelector()()()() | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(AnalyticalCurveSelector) | Creates a selector for the analytical model geometry.
Public method | AnalyticalModelSelector(Curve) | Creates a selector based on a specific analytical curve.
Public method | AnalyticalModelSelector(Curve, AnalyticalCurveSelector) | Creates a selector based on one portion of a specific analytical curve.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor

[image]

Revit 2013 API
AnalyticalModelSelector Constructor
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector()
Visual Basic
Public Sub New
Visual C++
public:
AnalyticalModelSelector()

Remarks

This version is useful for single-curve or single-point analytical models. Additionally, this only acts with respect to the entire curve or point.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (AnalyticalCurveSelector)

[image]

Revit 2013 API
AnalyticalModelSelector Constructor (AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector for the analytical model geometry.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic
Public Sub New ( _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    AnalyticalCurveSelector inCurveSelector
)

Parameters

inCurveSelector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalCurveSelector
Portion of the analytical curve in which the client has interest.

Remarks

This version is useful for single-curve or single-point analytical models.

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (Curve)

[image]

Revit 2013 API
AnalyticalModelSelector Constructor (Curve)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve
)
Visual Basic
Public Sub New ( _
    curve As Curve _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve upon which this selector acts.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)

[image]

Revit 2013 API
AnalyticalModelSelector Constructor (Curve, AnalyticalCurveSelector)
AnalyticalModelSelector Class See Also Send Feedback
Creates a selector based on one portion of a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalModelSelector(
    Curve curve,
    AnalyticalCurveSelector inCurveSelector
)
Visual Basic
Public Sub New ( _
    curve As Curve, _
    inCurveSelector As AnalyticalCurveSelector _
)
Visual C++
public:
AnalyticalModelSelector(
    Curve^ curve,
    AnalyticalCurveSelector inCurveSelector
)

Parameters

curve
Type: Autodesk.Revit.DB..::..Curve
The curve upon which this selector acts.
inCurveSelector
Type: Autodesk.Revit.DB.Structure..::..AnalyticalCurveSelector
Portion of the analytical curve in which the client is interested.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSelector Class
AnalyticalModelSelector Overload
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Methods

[image] [image]

Revit 2013 API
AnalyticalModelSelector Methods
AnalyticalModelSelector Class See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalModelSelector..::..Dispose Method
AnalyticalModelSelector Class See Also Send Feedback
Releases all resources used by the AnalyticalModelSelector

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSelector Properties

[image] [image]

Revit 2013 API
AnalyticalModelSelector Properties
AnalyticalModelSelector Class See Also Send Feedback

The AnalyticalModelSelector type exposes the following members.

Properties

 | Name | Description
Public property | CurveSelector |

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


CurveSelector Property

[image]

Revit 2013 API
AnalyticalModelSelector..::..CurveSelector Property
AnalyticalModelSelector Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalCurveSelector CurveSelector { get; set; }
Visual Basic
Public Property CurveSelector As AnalyticalCurveSelector
    Get
    Set
Visual C++
public:
property AnalyticalCurveSelector CurveSelector {
    AnalyticalCurveSelector get ();
    void set (AnalyticalCurveSelector value);
}

See Also

AnalyticalModelSelector Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Class

[image]

Revit 2013 API
AnalyticalModelSketchComponent Class
Members See Also Send Feedback
This is one component of an AnalyticalModelSketch, which exists to provide greater granularity over the Analytical Model than at the Element level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSketchComponent : IDisposable
Visual Basic
Public Class AnalyticalModelSketchComponent _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSketchComponent : IDisposable

Remarks

This may or may not be a simple one-to-one mapping to ElementIds. For instance, one Element may be defined by multiple Curve Elements within a Sketch. But another Element may not have that designation, and the individual curves are not defined by any other Elements within a document.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSketchComponent

See Also

AnalyticalModelSketchComponent Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Members

[image] [image]

Revit 2013 API
AnalyticalModelSketchComponent Members
AnalyticalModelSketchComponent Class Methods See Also Send Feedback

The AnalyticalModelSketchComponent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSketchComponent
Public method | EnableAutoDetect | Enables Auto-detect on Sketch Component.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalAlignmentMethod | Retrieves Analytical Alignment Method preset for Sketch Component.
Public method | GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
Public method | GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
Public method | GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
Public method | GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
Public method | IsValidAnalyticalAlignmentMethod | Indicates whether Analytical Alignment Method is valid for Sketch Component.
Public method | IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
Public method | IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
Public method | SetAnalyticalAlignmentMethod | Sets the Alignment Method to the supplied Analytical Alignment Method
Public method | SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
Public method | SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSketchComponent Methods

[image] [image]

Revit 2013 API
AnalyticalModelSketchComponent Methods
AnalyticalModelSketchComponent Class See Also Send Feedback

The AnalyticalModelSketchComponent type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | EnableAutoDetect | Enables Auto-detect on Sketch Component.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalAlignmentMethod | Retrieves Analytical Alignment Method preset for Sketch Component.
Public method | GetAnalyticalProjectionDatumPlane | Retrieves Datum Plane ElementId for Analytical Projection
Public method | GetAnalyticalProjectionType | Retrieves Analytical Projection Type preset for Sketch Component.
Public method | GetAutoDetectMatchedElements | Retrieves ElementIds that Sketch Component is Auto-detecting against.
Public method | GetComponentElementId | Retrieves ElementId of Sketch Component, if such an operation makes sense.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsAutoDetectEnabled | Indicates whether Auto-detect is enabled on the given Sketch component.
Public method | IsValidAnalyticalAlignmentMethod | Indicates whether Analytical Alignment Method is valid for Sketch Component.
Public method | IsValidAnalyticalProjectionType | Indicates whether Analytical Projection Type is valid for Sketch Component.
Public method | IsValidDatumPlaneForProjection | Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.
Public method | SetAnalyticalAlignmentMethod | Sets the Alignment Method to the supplied Analytical Alignment Method
Public method | SetAnalyticalProjectionDatumPlane | Sets the Analytical Projection to supplied Datum Plane.
Public method | SetAnalyticalProjectionType | Sets the Analytical Projection to the supplied Analytical Projection Type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..Dispose Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Releases all resources used by the AnalyticalModelSketchComponent

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


EnableAutoDetect Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..EnableAutoDetect Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Enables Auto-detect on Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void EnableAutoDetect()
Visual Basic
Public Sub EnableAutoDetect
Visual C++
public:
void EnableAutoDetect()

Remarks

To disable Auto-detect on Sketch Component, another method (SetAnalyticalAlignmentMethod) must be used

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalAlignmentMethod Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..GetAnalyticalAlignmentMethod Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves Analytical Alignment Method preset for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalAlignmentMethod GetAnalyticalAlignmentMethod()
Visual Basic
Public Function GetAnalyticalAlignmentMethod As AnalyticalAlignmentMethod
Visual C++
public:
AnalyticalAlignmentMethod GetAnalyticalAlignmentMethod()

Return Value

Indicates whether Alignment Method is at Auto-Detect or Projection

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..GetAnalyticalProjectionDatumPlane Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves Datum Plane ElementId for Analytical Projection

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetAnalyticalProjectionDatumPlane()
Visual Basic
Public Function GetAnalyticalProjectionDatumPlane As ElementId
Visual C++
public:
ElementId^ GetAnalyticalProjectionDatumPlane()

Return Value

Represents Datum used for Analytical Projection, if Analytical Projection Type indicates that a Datum Plane is to be used. Otherwise, invalidElementId is returned.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..GetAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves Analytical Projection Type preset for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalProjectionType GetAnalyticalProjectionType()
Visual Basic
Public Function GetAnalyticalProjectionType As AnalyticalProjectionType
Visual C++
public:
AnalyticalProjectionType GetAnalyticalProjectionType()

Return Value

Indicates whether Analytical Projection is at a preset, or refers to a Datum.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetAutoDetectMatchedElements Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..GetAutoDetectMatchedElements Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves ElementIds that Sketch Component is Auto-detecting against.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ICollection<ElementId> GetAutoDetectMatchedElements()
Visual Basic
Public Function GetAutoDetectMatchedElements As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetAutoDetectMatchedElements()

Return Value

Set of ElementIds that Sketch Component is auto-detecting against.

Remarks

An empty set indicates that the Sketch Component is just not Auto-detecting against anything.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


GetComponentElementId Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..GetComponentElementId Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Retrieves ElementId of Sketch Component, if such an operation makes sense.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetComponentElementId()
Visual Basic
Public Function GetComponentElementId As ElementId
Visual C++
public:
ElementId^ GetComponentElementId()

Return Value

ElementId of Sketch Component. If the operation does not make sense (perhaps because the Sketch abstraction does not translate one-to-one to ElementIds), then this will return invalidElementId.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsAutoDetectEnabled Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..IsAutoDetectEnabled Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Auto-detect is enabled on the given Sketch component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsAutoDetectEnabled()
Visual Basic
Public Function IsAutoDetectEnabled As Boolean
Visual C++
public:
bool IsAutoDetectEnabled()

Return Value

True if Auto-detect is enabled, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalAlignmentMethod Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..IsValidAnalyticalAlignmentMethod Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Analytical Alignment Method is valid for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)
Visual Basic
Public Function IsValidAnalyticalAlignmentMethod ( _
    alignmentMethod As AnalyticalAlignmentMethod _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)

Parameters

alignmentMethod
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method preset to test for validity.

Return Value

True means alignment method is valid, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsValidAnalyticalProjectionType Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..IsValidAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Analytical Projection Type is valid for Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Function IsValidAnalyticalProjectionType ( _
    projectionType As AnalyticalProjectionType _
) As Boolean
Visual C++
public:
bool IsValidAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type preset to test for validity.

Return Value

True is projection type is valid, false otherwise.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


IsValidDatumPlaneForProjection Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..IsValidDatumPlaneForProjection Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsValidDatumPlaneForProjection(
    ElementId datumPlaneId
)
Visual Basic
Public Function IsValidDatumPlaneForProjection ( _
    datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDatumPlaneForProjection(
    ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
ElementId identifying Datum Plane.

Return Value

True if Datum Plane is valid; false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalAlignmentMethod Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..SetAnalyticalAlignmentMethod Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Alignment Method to the supplied Analytical Alignment Method

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)
Visual Basic
Public Sub SetAnalyticalAlignmentMethod ( _
    alignmentMethod As AnalyticalAlignmentMethod _
)
Visual C++
public:
void SetAnalyticalAlignmentMethod(
    AnalyticalAlignmentMethod alignmentMethod
)

Parameters

alignmentMethod
Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
Analytical Alignment Method which the Analytical Model should use for alignment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | alignmentMethod is not valid for this Sketch component.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..SetAnalyticalProjectionDatumPlane Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Analytical Projection to supplied Datum Plane.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionDatumPlane(
    ElementId datumPlaneId
)
Visual Basic
Public Sub SetAnalyticalProjectionDatumPlane ( _
    datumPlaneId As ElementId _
)
Visual C++
public:
void SetAnalyticalProjectionDatumPlane(
    ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB..::..ElementId
Identifies Datum Plane ElementId.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | datumPlaneId is not valid for this Sketch Component.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method

[image]

Revit 2013 API
AnalyticalModelSketchComponent..::..SetAnalyticalProjectionType Method
AnalyticalModelSketchComponent Class See Also Send Feedback
Sets the Analytical Projection to the supplied Analytical Projection Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)
Visual Basic
Public Sub SetAnalyticalProjectionType ( _
    projectionType As AnalyticalProjectionType _
)
Visual C++
public:
void SetAnalyticalProjectionType(
    AnalyticalProjectionType projectionType
)

Parameters

projectionType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalProjectionType
Analytical Projection Type to which the Analytical Model should project.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | projectionType is not valid for this Sketch component.

See Also

AnalyticalModelSketchComponent Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Class

[image]

Revit 2013 API
AnalyticalModelSupport Class
Members See Also Send Feedback
Represents one support for an Element, in the realm of the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSupport : IDisposable
Visual Basic
Public Class AnalyticalModelSupport _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSupport : IDisposable

Remarks

Analytical Support has been defined as if and how an Element is supported, by looking at the Analytical Models of Elements. There are different priorities of support, and different types of support. Additionally, even though an Element has supports, it may not be fully supported.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSupport

See Also

AnalyticalModelSupport Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Members

[image] [image]

Revit 2013 API
AnalyticalModelSupport Members
AnalyticalModelSupport Class Methods See Also Send Feedback

The AnalyticalModelSupport type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSupport
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Retrieves the curve providing support.
Public method | GetFace | Retrieves surface providing support,
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoint | Retrieves the point providing support.
Public method | GetPriority | Retrieves the priority of the support provided.
Public method | GetSupportingElement | Retrieves the actual Element Id providing support.
Public method | GetSupportType | Gets the type of support provided.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupport Methods

[image] [image]

Revit 2013 API
AnalyticalModelSupport Methods
AnalyticalModelSupport Class See Also Send Feedback

The AnalyticalModelSupport type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetCurve | Retrieves the curve providing support.
Public method | GetFace | Retrieves surface providing support,
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoint | Retrieves the point providing support.
Public method | GetPriority | Retrieves the priority of the support provided.
Public method | GetSupportingElement | Retrieves the actual Element Id providing support.
Public method | GetSupportType | Gets the type of support provided.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..Dispose Method
AnalyticalModelSupport Class See Also Send Feedback
Releases all resources used by the AnalyticalModelSupport

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetCurve Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetCurve Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the curve providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Curve GetCurve()
Visual Basic
Public Function GetCurve As Curve
Visual C++
public:
Curve^ GetCurve()

Return Value

Represents the curve providing support, if the Support Type is Curve Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the Support Type is not Curve Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetFace Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetFace Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves surface providing support,

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Face GetFace()
Visual Basic
Public Function GetFace As Face
Visual C++
public:
Face^ GetFace()

Return Value

Surface representing the surface providing support, if the Support Type is Surface Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the Support Type is not Surface Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetPoint Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetPoint Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the point providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public XYZ GetPoint()
Visual Basic
Public Function GetPoint As XYZ
Visual C++
public:
XYZ^ GetPoint()

Return Value

Represents the point providing support, if the Support Type is Point Support.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | Thrown when the Support Type is not Point Support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetPriority Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetPriority Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the priority of the support provided.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalSupportPriority GetPriority()
Visual Basic
Public Function GetPriority As AnalyticalSupportPriority
Visual C++
public:
AnalyticalSupportPriority GetPriority()

Return Value

Indicates the support priority, as determined by Analytical Support Checking

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetSupportingElement Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetSupportingElement Method
AnalyticalModelSupport Class See Also Send Feedback
Retrieves the actual Element Id providing support.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetSupportingElement()
Visual Basic
Public Function GetSupportingElement As ElementId
Visual C++
public:
ElementId^ GetSupportingElement()

Return Value

Represents Element that provides support.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


GetSupportType Method

[image]

Revit 2013 API
AnalyticalModelSupport..::..GetSupportType Method
AnalyticalModelSupport Class See Also Send Feedback
Gets the type of support provided.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AnalyticalSupportType GetSupportType()
Visual Basic
Public Function GetSupportType As AnalyticalSupportType
Visual C++
public:
AnalyticalSupportType GetSupportType()

Return Value

Indicates type of support provided.

See Also

AnalyticalModelSupport Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSurface Class

[image]

Revit 2013 API
AnalyticalModelSurface Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AnalyticalModelSurface : AnalyticalModel
Visual Basic
Public Class AnalyticalModelSurface _
    Inherits AnalyticalModel
Visual C++
public ref class AnalyticalModelSurface : public AnalyticalModel

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AnalyticalModel
Autodesk.Revit.DB.Structure..::..AnalyticalModelSurface

See Also

AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSurface Members

[image] [image]

Revit 2013 API
AnalyticalModelSurface Members
AnalyticalModelSurface Class Methods Properties See Also Send Feedback

The AnalyticalModelSurface type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models; (Inherited from AnalyticalModel.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not. (Inherited from AnalyticalModel.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically. (Inherited from AnalyticalModel.)
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically; (Inherited from AnalyticalModel.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links. (Inherited from AnalyticalModel.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed. (Inherited from AnalyticalModel.)
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points. (Inherited from AnalyticalModel.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends; (Inherited from AnalyticalModel.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disconnect | Unjoin from Hub Element. (Inherited from AnalyticalModel.)
Public method | Dispose | (Inherited from Element.)
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle. (Inherited from AnalyticalModel.)
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect. (Inherited from AnalyticalModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made. (Inherited from AnalyticalModel.)
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against. (Inherited from AnalyticalModel.)
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve. (Inherited from AnalyticalModel.)
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type. (Inherited from AnalyticalModel.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHiddenOpenings | Retrieves Identifiers of all hidden openings.
Public method | GetLoops | Retrieves Analytical Model Loops with respect to the loopType.
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted. (Inherited from AnalyticalModel.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOffset | Gets the offset of the analytical model at end. (Inherited from AnalyticalModel.)
Public method | GetOpeningLoops | Retrieves Array of CurveLoops of Analytical Surface Opening.. Only valid openings for hide are allowed.
Public method | GetOpenings | Retrieves Analytical Surface Openings Identifiers valid to be used in showOpening/hideOpening functions.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoint | Retrieves point of the Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetReference | Returns a reference to a given curve within the analytical model. (Inherited from AnalyticalModel.)
Public method | GetRigidLink | Returns rigid link curve corresponding to selector. (Inherited from AnalyticalModel.)
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end. (Inherited from AnalyticalModel.)
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links. (Inherited from AnalyticalModel.)
Public method | HasOpenings | Checks if the analytical model surface have any openings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element. (Inherited from AnalyticalModel.)
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile. (Inherited from AnalyticalModel.)
Public method | HideOpening | Hides set of curves originating from Opening.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element. (Inherited from AnalyticalModel.)
Public method | IsApproximated | Indicates if Analytical Model is approximated or not. (Inherited from AnalyticalModel.)
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled. (Inherited from AnalyticalModel.)
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported. (Inherited from AnalyticalModel.)
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled. (Inherited from AnalyticalModel.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user. (Inherited from AnalyticalModel.)
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end. (Inherited from AnalyticalModel.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOpeningHidden | Returns true if opening with given Identifier is hidden.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve. (Inherited from AnalyticalModel.)
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point. (Inherited from AnalyticalModel.)
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall. (Inherited from AnalyticalModel.)
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction. (Inherited from AnalyticalModel.)
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction. (Inherited from AnalyticalModel.)
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect. (Inherited from AnalyticalModel.)
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection. (Inherited from AnalyticalModel.)
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidOpeningForHide | Returns true if opening with given Identifier could be hidden, false for all other Identifiers.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction. (Inherited from AnalyticalModel.)
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction. (Inherited from AnalyticalModel.)
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element; (Inherited from AnalyticalModel.)
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user. (Inherited from AnalyticalModel.)
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model. (Inherited from AnalyticalModel.)
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element. (Inherited from AnalyticalModel.)
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made. (Inherited from AnalyticalModel.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLoops | Set new analytical model geometry (newLoops) for analytical surface elements such as floors and slabs.
Public method | SetOffset | Sets the offset of the analytical model at end. (Inherited from AnalyticalModel.)
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | ShowOpening | Shows previously hidden set of curves originating from Opening.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation. (Inherited from AnalyticalModel.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RigidLinksOption | Indicates if parameters indicate if Rigid Links should be formed. (Inherited from AnalyticalModel.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSurface Methods

[image] [image]

Revit 2013 API
AnalyticalModelSurface Methods
AnalyticalModelSurface Class See Also Send Feedback

The AnalyticalModelSurface type exposes the following members.

Methods

 | Name | Description
Public method | Approximate | Switches between non-approximated (e.g., Curved) Analytical Models and approximated (made up of lines only) Analytical Models; (Inherited from AnalyticalModel.)
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanApproximate | Indicates if Analytical Model can be approximated or not. (Inherited from AnalyticalModel.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanDisable | Reports whether the user can enable or disable the Analytical Model programmatically. (Inherited from AnalyticalModel.)
Public method | CanDisableAutoDetect | Indicates if Analytical Auto-detect can be disabled programmatically; (Inherited from AnalyticalModel.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveRigidLinks | Indicates if Analytical Model supports Rigid Links. (Inherited from AnalyticalModel.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanSetAnalyticalOffset | Determines whether the Analytical Model Offset can be changed. (Inherited from AnalyticalModel.)
Public method | CanUseHardPoints | Indicates if Analytical Model can use Hard Points. (Inherited from AnalyticalModel.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CloneAdjustment | The method clones the adjustment of one end of the AM on another AM, with respect to the one of the ends. One of the Analytical Model ends; (Inherited from AnalyticalModel.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Disconnect | Unjoin from Hub Element. (Inherited from AnalyticalModel.)
Public method | Dispose | (Inherited from Element.)
Public method | Enable | Enables or disables Analytical Model, if the Element allows a one-operation Analytical Model toggle. (Inherited from AnalyticalModel.)
Public method | EnableAutoDetect | Enable or disable Analytical Auto-detect. (Inherited from AnalyticalModel.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAlignmentMethod | Gets the alignment method for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAnalyticalModelSketchComponents | Retrieves a collection of AnalyticalModelSketchComponent objects, which are useful for those Analytical Models that have finer calibration below the Element level. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalModelSupports | Retrieves the AnalyticalModelSupport array, which is useful to extract Analytical Support Information from Elements. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalOffset | Obsolete. Retrieves Analytical Offset in the case where the user can do that. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)
Public method | GetAnalyzeAs | Returns value of Analyze As parameter for Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetApproximationDeviation | Retrieves amount by which approximation is made. (Inherited from AnalyticalModel.)
Public method | GetAutoDetectMatchedElements | Retrieves other Element Ids that this Element is Auto-detecting against. (Inherited from AnalyticalModel.)
Public method | GetCurve | Returns the single curve of the Analytical Model, if it is only one curve. (Inherited from AnalyticalModel.)
Public method | GetCurves | Retrieves all curves for the Analytical Model of a given type. (Inherited from AnalyticalModel.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetElementId | Retrieves Element Id of the structural element corresponding to the Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHiddenOpenings | Retrieves Identifiers of all hidden openings.
Public method | GetLoops | Retrieves Analytical Model Loops with respect to the loopType.
Public method | GetManualAdjustmentMatchedElements | Retrieves other Element Ids against which the Analytical Model has been adjusted. (Inherited from AnalyticalModel.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOffset | Gets the offset of the analytical model at end. (Inherited from AnalyticalModel.)
Public method | GetOpeningLoops | Retrieves Array of CurveLoops of Analytical Surface Opening.. Only valid openings for hide are allowed.
Public method | GetOpenings | Retrieves Analytical Surface Openings Identifiers valid to be used in showOpening/hideOpening functions.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPoint | Retrieves point of the Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetReference | Returns a reference to a given curve within the analytical model. (Inherited from AnalyticalModel.)
Public method | GetRigidLink | Returns rigid link curve corresponding to selector. (Inherited from AnalyticalModel.)
Public method | GetSweptProfile | Retrieves the swept profile information for Analytical Model. (Inherited from AnalyticalModel.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasAlignment | Checks if analytical alignment is applicable at a given end. (Inherited from AnalyticalModel.)
Public method | HasDeletedLinks | Indicates if Analytical Model contains deleted Analytical Links. (Inherited from AnalyticalModel.)
Public method | HasOpenings | Checks if the analytical model surface have any openings.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | HasRigidLinksWith | Indicates if Analytical Model has Rigid Links with specified element. (Inherited from AnalyticalModel.)
Public method | HasSweptProfile | Indicates if this Element's Analytical Model can be represented as a swept profile. (Inherited from AnalyticalModel.)
Public method | HideOpening | Hides set of curves originating from Opening.
Public method | IsAnalyzeAsValid | Determines if the given Analyze As parameter is valid for this Element. (Inherited from AnalyticalModel.)
Public method | IsApproximated | Indicates if Analytical Model is approximated or not. (Inherited from AnalyticalModel.)
Public method | IsAutoDetectEnabled | Reports if Analytical Auto-detect for the given direction is enabled. (Inherited from AnalyticalModel.)
Public method | IsElementFullySupported | Indicates if Analytical Model is fully supported. (Inherited from AnalyticalModel.)
Public method | IsEnabled | Reports whether the Analytical Model is enabled or disabled. (Inherited from AnalyticalModel.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsManuallyAdjusted | Indicates if the Analytical Model has been manually adjusted by the user. (Inherited from AnalyticalModel.)
Public method | IsModified | Checks if AM has been adjusted from auto-detect at any end. (Inherited from AnalyticalModel.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOpeningHidden | Returns true if opening with given Identifier is hidden.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSingleCurve | Indicates if the Analytical Model can be expressed as a single curve. (Inherited from AnalyticalModel.)
Public method | IsSinglePoint | Indicates if the Analytical Model can be expressed as a single point. (Inherited from AnalyticalModel.)
Public method | IsSurface | Checks if the analytical model belongs to the surface object like floor, slab or wall. (Inherited from AnalyticalModel.)
Public method | IsValidAnalyticalProjectionType | Obsolete. Indicates if a given Analytical Projection Type is valid for the given Analytical Direction. (Inherited from AnalyticalModel.)
Public method | IsValidDatumPlaneForProjection | Obsolete. Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction. (Inherited from AnalyticalModel.)
Public method | IsValidDirectionForAutoDetect | Tests if the supplied direction is valid for Analytical Auto-detect. (Inherited from AnalyticalModel.)
Public method | IsValidDirectionForProjection | Indicates if the input direction is valid for Analytical Model projection. (Inherited from AnalyticalModel.)
Public method | IsValidForManualAdjustment | Indicates if the identified reference is acceptable for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidManualAdjustmentSource | Indicates if the identified reference is acceptable as a source for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidManualAdjustmentTarget | Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | IsValidOpeningForHide | Returns true if opening with given Identifier could be hidden, false for all other Identifiers.
Public method | IsValidProjectionDatumPlane | Indicates if a given Datum Plane is valid for analytical model projection with respect to the given analytical direction. (Inherited from AnalyticalModel.)
Public method | IsValidProjectionType | Indicates if a given Analytical Projection Type is valid for the given Analytical Element Selector and Analytical Direction. (Inherited from AnalyticalModel.)
Public method | IsValidRigidLinksOption | Indicates if Rigid Links option is valid for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidSelector | Indicates if the input selector is valid for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidSelectorAndDirection | Indicates if the input selector is valid for analytical direction for Analytical Model. (Inherited from AnalyticalModel.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | ManuallyAdjust | Perform Manual Analytical Adjustment on analytical model, with respect to another Element; (Inherited from AnalyticalModel.)
Public method | ResetLinks | The function is trying to recreate analytical link elements that were deleted by the user. (Inherited from AnalyticalModel.)
Public method | ResetManualAdjustment | Resets all manual adjustments performed by the user onto the Analytical Model. (Inherited from AnalyticalModel.)
Public method | SetAlignmentMethod | Sets the alignment method for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalOffset | Obsolete. Sets Analytical Offset in the case where the user can do that. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)
Public method | SetAnalyzeAs | Sets value of Analyze As parameter for this Element. (Inherited from AnalyticalModel.)
Public method | SetApproximationDeviation | Adjusts the amount by which approximation is made. (Inherited from AnalyticalModel.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetLoops | Set new analytical model geometry (newLoops) for analytical surface elements such as floors and slabs.
Public method | SetOffset | Sets the offset of the analytical model at end. (Inherited from AnalyticalModel.)
Public method | SetUsesHardPoints | Sets Hard Points for the Analytical Model. (Inherited from AnalyticalModel.)
Public method | ShowOpening | Shows previously hidden set of curves originating from Opening.
Public method | SupportsManualAdjustment | Indicates if the Element supports Manual Analytical Adjustment. (Inherited from AnalyticalModel.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | UsesHardPoints | Indicates if the Analytical Model is using Hard Points during approximation. (Inherited from AnalyticalModel.)

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionDatumPlane Method

[image] [image]

Revit 2013 API
AnalyticalModelSurface..::..GetAnalyticalProjectionDatumPlane Method
AnalyticalModelSurface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalDirection) | Obsolete. Retrieves analytical model projection information for a specific direction. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection) | Gets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)

See Also

AnalyticalModelSurface Class
AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


GetAnalyticalProjectionType Method

[image] [image]

Revit 2013 API
AnalyticalModelSurface..::..GetAnalyticalProjectionType Method
AnalyticalModelSurface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetAnalyticalProjectionType(AnalyticalDirection) | Obsolete. Retrieves Analytical Model projection information for a specific direction. In direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)
Public method | GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection) | Retrieves Analytical Model projection information for a specific direction. in direction: direction in which the Analytical Model may be projected. (Inherited from AnalyticalModel.)

See Also

AnalyticalModelSurface Class
AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


GetHiddenOpenings Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..GetHiddenOpenings Method
AnalyticalModelSurface Class See Also Send Feedback
Retrieves Identifiers of all hidden openings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void GetHiddenOpenings(
    out ICollection<ElementId> openingsIds
)
Visual Basic
Public Sub GetHiddenOpenings ( _
    <OutAttribute> ByRef openingsIds As ICollection(Of ElementId) _
)
Visual C++
public:
void GetHiddenOpenings(
    [OutAttribute] ICollection<ElementId^>^% openingsIds
)

Parameters

openingsIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%
Set of openings Identifiers which are hidden in Analytical Surface Element.

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


GetLoops Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..GetLoops Method
AnalyticalModelSurface Class See Also Send Feedback
Retrieves Analytical Model Loops with respect to the loopType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<CurveLoop> GetLoops(
    AnalyticalLoopType loopType
)
Visual Basic
Public Function GetLoops ( _
    loopType As AnalyticalLoopType _
) As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetLoops(
    AnalyticalLoopType loopType
)

Parameters

loopType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalLoopType

Return Value

Loops that satisfy loopType criteria are returned.

Remarks

For multiple concentric loops, only the outermost loop will be considered External. All other loops will be considered Internal.

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


GetOpeningLoops Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..GetOpeningLoops Method
AnalyticalModelSurface Class See Also Send Feedback
Retrieves Array of CurveLoops of Analytical Surface Opening.. Only valid openings for hide are allowed.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<CurveLoop> GetOpeningLoops(
    ElementId openingId
)
Visual Basic
Public Function GetOpeningLoops ( _
    openingId As ElementId _
) As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ GetOpeningLoops(
    ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB..::..ElementId
Identifies which Opening creates the CurveLoop in the analytical surface.

Return Value

Array of CurveLoops associated with Opening.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | openingId is invalid for Analytical Model Surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


GetOpenings Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..GetOpenings Method
AnalyticalModelSurface Class See Also Send Feedback
Retrieves Analytical Surface Openings Identifiers valid to be used in showOpening/hideOpening functions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void GetOpenings(
    out ICollection<ElementId> openingsIds
)
Visual Basic
Public Sub GetOpenings ( _
    <OutAttribute> ByRef openingsIds As ICollection(Of ElementId) _
)
Visual C++
public:
void GetOpenings(
    [OutAttribute] ICollection<ElementId^>^% openingsIds
)

Parameters

openingsIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%
Set of openings Identifiers in Analytical Surface Element which are valid for hide.

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


HasOpenings Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..HasOpenings Method
AnalyticalModelSurface Class See Also Send Feedback
Checks if the analytical model surface have any openings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasOpenings()
Visual Basic
Public Function HasOpenings As Boolean
Visual C++
public:
bool HasOpenings()

Return Value

True if Analytical Surface Element contains any openings (included invalid for hide).

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


HideOpening Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..HideOpening Method
AnalyticalModelSurface Class See Also Send Feedback
Hides set of curves originating from Opening.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HideOpening(
    ElementId openingId
)
Visual Basic
Public Function HideOpening ( _
    openingId As ElementId _
) As Boolean
Visual C++
public:
bool HideOpening(
    ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB..::..ElementId
Opening to hide in analytical surface.

Return Value

True if given opening was hidden (operation was successful).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | openingId is invalid for Analytical Model Surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


IsOpeningHidden Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..IsOpeningHidden Method
AnalyticalModelSurface Class See Also Send Feedback
Returns true if opening with given Identifier is hidden.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsOpeningHidden(
    ElementId openingId
)
Visual Basic
Public Function IsOpeningHidden ( _
    openingId As ElementId _
) As Boolean
Visual C++
public:
bool IsOpeningHidden(
    ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of opening to check.

Return Value

True for openings which are hidden, false for all other Identifiers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


IsValidOpeningForHide Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..IsValidOpeningForHide Method
AnalyticalModelSurface Class See Also Send Feedback
Returns true if opening with given Identifier could be hidden, false for all other Identifiers.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidOpeningForHide(
    ElementId openingId
)
Visual Basic
Public Function IsValidOpeningForHide ( _
    openingId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidOpeningForHide(
    ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB..::..ElementId
Identifier of opening to check.

Return Value

True for openings which are valid to be hidden, false for all other Identifiers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionDatumPlane Method

[image] [image]

Revit 2013 API
AnalyticalModelSurface..::..SetAnalyticalProjectionDatumPlane Method
AnalyticalModelSurface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalDirection, ElementId) | Obsolete. Sets analytical model projection to a Datum Plane. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId) | Sets the datum plane for a given selector and direction. (Inherited from AnalyticalModel.)

See Also

AnalyticalModelSurface Class
AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


SetAnalyticalProjectionType Method

[image] [image]

Revit 2013 API
AnalyticalModelSurface..::..SetAnalyticalProjectionType Method
AnalyticalModelSurface Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAnalyticalProjectionType(AnalyticalDirection, AnalyticalProjectionType) | Obsolete. Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)
Public method | SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType) | Sets the analytical model projection to a preset value. (Inherited from AnalyticalModel.)

See Also

AnalyticalModelSurface Class
AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


SetLoops Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..SetLoops Method
AnalyticalModelSurface Class See Also Send Feedback
Set new analytical model geometry (newLoops) for analytical surface elements such as floors and slabs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool SetLoops(
    AnalyticalLoopType loopType,
    IList<CurveLoop> newLoops
)
Visual Basic
Public Function SetLoops ( _
    loopType As AnalyticalLoopType, _
    newLoops As IList(Of CurveLoop) _
) As Boolean
Visual C++
public:
bool SetLoops(
    AnalyticalLoopType loopType,
    IList<CurveLoop^>^ newLoops
)

Parameters

loopType
Type: Autodesk.Revit.DB.Structure..::..AnalyticalLoopType
Determine what kind of loops will be set. Rest of loops remain unchanged.
newLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
New analytical geometry for analytical surface elements.

Return Value

False if setting the new location failed for one or more curves. True if setting new location succeeded for all curves.

Remarks

Analytical surface will be automatically generated from provided newLoops. Number of newLoops and number of curves in each newloop have to correspond to loops number with the same loopType in element. To verify number of loops and their type use getLoops method. Currently you can not set arbitrary shape for analytical walls. For walls false will be returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when number of newLoops is different from number of current loops considering loopType. -or- Thrown when number of curves in each loop in newLoop don't correspond to number of curves in current loop. -or- Thrown when type of curves in newLoop differ from number of curves in current loop (eg. line changed to arc). -or- Thrown when length of any curve in newLoops is invalid. -or- Thrown when new loops intersect themselves or intersect with loops already set in analytical model.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


ShowOpening Method

[image]

Revit 2013 API
AnalyticalModelSurface..::..ShowOpening Method
AnalyticalModelSurface Class See Also Send Feedback
Shows previously hidden set of curves originating from Opening.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool ShowOpening(
    ElementId openingId
)
Visual Basic
Public Function ShowOpening ( _
    openingId As ElementId _
) As Boolean
Visual C++
public:
bool ShowOpening(
    ElementId^ openingId
)

Parameters

openingId
Type: Autodesk.Revit.DB..::..ElementId
Opening to show in analytical surface.

Return Value

True if given opening was shown (operation was successful).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | openingId is invalid for Analytical Model Surface.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSurface Properties

[image] [image]

Revit 2013 API
AnalyticalModelSurface Properties
AnalyticalModelSurface Class See Also Send Feedback

The AnalyticalModelSurface type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RigidLinksOption | Indicates if parameters indicate if Rigid Links should be formed. (Inherited from AnalyticalModel.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AnalyticalModelSurface Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AnalyticalModelSurface..::..Parameter Property
AnalyticalModelSurface Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AnalyticalModelSurface Class
AnalyticalModelSurface Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Class

[image]

Revit 2013 API
AnalyticalModelSweptProfile Class
Members See Also Send Feedback
Represents an extruded profile swept along a driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AnalyticalModelSweptProfile : IDisposable
Visual Basic
Public Class AnalyticalModelSweptProfile _
    Implements IDisposable
Visual C++
public ref class AnalyticalModelSweptProfile : IDisposable

Remarks

Elements such as beams may be formed from a profile that has been swept along a curve. This analytical model represents such a form and is used to access the cross section and the underlying curve that make up the Element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalModelSweptProfile

See Also

AnalyticalModelSweptProfile Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Members

[image] [image]

Revit 2013 API
AnalyticalModelSweptProfile Members
AnalyticalModelSweptProfile Class Methods Properties See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the AnalyticalModelSweptProfile
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Methods

[image] [image]

Revit 2013 API
AnalyticalModelSweptProfile Methods
AnalyticalModelSweptProfile Class See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetDrivingCurve | Provides access to the curve that dictates the path of the swept profile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSweptProfile | Returns an object that describes the profile that is swept along the driving curve.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalModelSweptProfile..::..Dispose Method
AnalyticalModelSweptProfile Class See Also Send Feedback
Releases all resources used by the AnalyticalModelSweptProfile

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


GetDrivingCurve Method

[image]

Revit 2013 API
AnalyticalModelSweptProfile..::..GetDrivingCurve Method
AnalyticalModelSweptProfile Class See Also Send Feedback
Provides access to the curve that dictates the path of the swept profile.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Curve GetDrivingCurve()
Visual Basic
Public Function GetDrivingCurve As Curve
Visual C++
public:
Curve^ GetDrivingCurve()

Return Value

A curve that defines the path of the swept profile.

Remarks

The profile may not be swept the entire length of this curve. One should check the set back properties on this object to locate how far the actual sweep is from the ends of the curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


GetSweptProfile Method

[image]

Revit 2013 API
AnalyticalModelSweptProfile..::..GetSweptProfile Method
AnalyticalModelSweptProfile Class See Also Send Feedback
Returns an object that describes the profile that is swept along the driving curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Profile GetSweptProfile()
Visual Basic
Public Function GetSweptProfile As Profile
Visual C++
public:
Profile^ GetSweptProfile()

Return Value

A geometric profile object.

Remarks

The profile is swept perpendicular to the driving curve.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSweptProfile Properties

[image] [image]

Revit 2013 API
AnalyticalModelSweptProfile Properties
AnalyticalModelSweptProfile Class See Also Send Feedback

The AnalyticalModelSweptProfile type exposes the following members.

Properties

 | Name | Description
Public property | EndSetBack | The distance from the end of the driving curve to the point where the sweep actually ends.
Public property | StartSetBack | The distance from the start of the driving curve to the point where the sweep actually begins.

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


EndSetBack Property

[image]

Revit 2013 API
AnalyticalModelSweptProfile..::..EndSetBack Property
AnalyticalModelSweptProfile Class See Also Send Feedback
The distance from the end of the driving curve to the point where the sweep actually ends.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double EndSetBack { get; }
Visual Basic
Public ReadOnly Property EndSetBack As Double
    Get
Visual C++
public:
property double EndSetBack {
    double get ();
}

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


StartSetBack Property

[image]

Revit 2013 API
AnalyticalModelSweptProfile..::..StartSetBack Property
AnalyticalModelSweptProfile Class See Also Send Feedback
The distance from the start of the driving curve to the point where the sweep actually begins.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double StartSetBack { get; }
Visual Basic
Public ReadOnly Property StartSetBack As Double
    Get
Visual C++
public:
property double StartSetBack {
    double get ();
}

See Also

AnalyticalModelSweptProfile Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalProjectionType Enumeration

[image]

Revit 2013 API
AnalyticalProjectionType Enumeration
See Also Send Feedback
Presets for given Analytical Projection. Combined with AnalyticalDirection, this abstracts Analytical Projections for all Structural Elements

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalProjectionType
Visual Basic
Public Enumeration AnalyticalProjectionType
Visual C++
public enum class AnalyticalProjectionType

Members

Member name | Description
Top | Vertically, on top of physical model.
Center | Vertically, center of physical model.
Bottom | Vertically, bottom of physical model.
SideOne | Horizontally, corresponds to first side (e.g., interior).
SideTwo | Horizontally, corresponds to second side (e.g., exterior).
AutoDetect | Auto-detect projections for analytical model.
Invalid | Set to a bad setting. Should only be set at this very rarely (i.e., at initial creation).
SketchCurve | For sketch-based analytical models.
DatumPlane | Use a Datum Plane for projection (e.g., Grid, Level).
NotApplicable | None of the other projection types apply.
Default | Element-specific default value.
CenterOfCore | Center of wall core.
LocationLine | Location Line.
Varies | Projection types are different at each end.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalRigidLinksOption Enumeration

[image]

Revit 2013 API
AnalyticalRigidLinksOption Enumeration
See Also Send Feedback
Specifies how Rigid Links will be made for the Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalRigidLinksOption
Visual Basic
Public Enumeration AnalyticalRigidLinksOption
Visual C++
public enum class AnalyticalRigidLinksOption

Members

Member name | Description
Enabled | For a structural column, enables rigid link formation, unless the neighboring structural beam overrides the setting. For a structural beam, enables rigid link formation, overriding the neighboring structural column's setting.
Disabled | For a structural column, this disables rigid Link formation, unless the neighboring structural beam overrides the setting. For a structural beam, this disables rigid Link formation, overriding the neighboring structural column's setting.
FromColumn | For a structural beam, this indicates that the structural column setting should be used to determine rigid link formation. This value is not applicable to structural columns.

Remarks

Rigid Links are curves connecting neighboring Structural Beams and Structural Columns.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Class

[image]

Revit 2013 API
AnalyticalSupportChecking Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AnalyticalSupportChecking : IDisposable
Visual Basic
Public Class AnalyticalSupportChecking _
    Implements IDisposable
Visual C++
public ref class AnalyticalSupportChecking : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..AnalyticalSupportChecking

See Also

AnalyticalSupportChecking Members
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Members

[image] [image]

Revit 2013 API
AnalyticalSupportChecking Members
AnalyticalSupportChecking Class Methods See Also Send Feedback

The AnalyticalSupportChecking type exposes the following members.

Methods

 | Name | Description
 | CheckMemberSupports | Check if the document contains unsupported Structural Elements.
Public method | Dispose | Releases all resources used by the AnalyticalSupportChecking
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportChecking Methods

[image] [image]

Revit 2013 API
AnalyticalSupportChecking Methods
AnalyticalSupportChecking Class See Also Send Feedback

The AnalyticalSupportChecking type exposes the following members.

Methods

 | Name | Description
 | CheckMemberSupports | Check if the document contains unsupported Structural Elements.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


CheckMemberSupports Method

[image]

Revit 2013 API
AnalyticalSupportChecking..::..CheckMemberSupports Method
AnalyticalSupportChecking Class See Also Send Feedback
Check if the document contains unsupported Structural Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static bool CheckMemberSupports(
    Document document,
    string progressIndicatorText
)
Visual Basic
Public Shared Function CheckMemberSupports ( _
    document As Document, _
    progressIndicatorText As String _
) As Boolean
Visual C++
public:
static bool CheckMemberSupports(
    Document^ document,
    String^ progressIndicatorText
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
Document in which to perform Analytical Support Check.
progressIndicatorText
Type: System..::..String
Text to display on progress indicator.

Return Value

True if the support check succeeded, false otherwise.

Remarks

Existence of unsupported Elements will not affect the return value. Reporting of unsupported Structural Elements will be done via Warnings. This should be run from within a transaction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
AnalyticalSupportChecking..::..Dispose Method
AnalyticalSupportChecking Class See Also Send Feedback
Releases all resources used by the AnalyticalSupportChecking

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

AnalyticalSupportChecking Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportPriority Enumeration

[image]

Revit 2013 API
AnalyticalSupportPriority Enumeration
See Also Send Feedback
Defines how "highly" another Element is giving support for one Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalSupportPriority
Visual Basic
Public Enumeration AnalyticalSupportPriority
Visual C++
public enum class AnalyticalSupportPriority

Members

Member name | Description
UnknownPriority | Priority has not been determined.
HighestPriority |
SecondHighestPriority |
ThirdHighestPriority |
FourthHigestPriority |

Remarks

For instance, a Column may be a higher priority for a Beam than another Beam. This is useful to find the best supports for a given Element.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyticalSupportType Enumeration

[image]

Revit 2013 API
AnalyticalSupportType Enumeration
See Also Send Feedback
Indicates what kind of support another Element provides -- Point, Surface, or Curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyticalSupportType
Visual Basic
Public Enumeration AnalyticalSupportType
Visual C++
public enum class AnalyticalSupportType

Members

Member name | Description
UnknownSupport | Support has not been determined.
PointSupport | Support at just one point.
CurveSupport | Support along a curve.
SurfaceSupport | Support along a surface.

See Also

Autodesk.Revit.DB.Structure Namespace


AnalyzeAs Enumeration

[image]

Revit 2013 API
AnalyzeAs Enumeration
See Also Send Feedback
Analyze As has various functions within the Analytical Model, and is Element-dependent. "Not for Analysis" usually means that there will not be an Analytical Model generated. The others indicate how the Analytical Model behavior will treat the Element in question. For instance "Hanger" columns have different support expectations than "Gravity" columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AnalyzeAs
Visual Basic
Public Enumeration AnalyzeAs
Visual C++
public enum class AnalyzeAs

Members

Member name | Description
Hanger | A hanging Element.
Gravity | Interpreted as Gravity (support going down).
Lateral | Interpreted as Lateral (support going across).
SlabOneWay | Floor interpreted as Slab One-Way.
Mat | Floor interpreted as Mat Foundation, or general foundation.
SlabOnGrade | Floor interpreted as Slab on a Grade.
NotForAnalysis | Element is not for Analysis.
NotApplicable | Analyze As is not applicable.
SlabTwoWay | Floor interpreted as Slab Two-Way.
GravityLateral | Wall interpreted as Gravity and Lateral

See Also

Autodesk.Revit.DB.Structure Namespace


AreaLoad Class

[image]

Revit 2013 API
AreaLoad Class
Members Example See Also Send Feedback
An object that represents a force applied across an area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaLoad : LoadBase
Visual Basic
Public Class AreaLoad _
    Inherits LoadBase
Visual C++
public ref class AreaLoad : public LoadBase

Examples

CopyC#
public void GetInfo_AreaLoad(AreaLoad areaLoad)
{
    string message = "AreaLoad Force : ";
    // Get areaload force1 position
    message += "\nAreaLoad Force1 position :(" + areaLoad.Force1.X + ", "
        + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")";
    // Get areaload force2 position
    message += "\nAreaLoad Force2 position :(" + areaLoad.Force2.X + ", "
        + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")";
    // Get areaload force3 position
    message += "\nAreaLoad Force3 position :(" + areaLoad.Force3.X + ", "
        + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")";

    // Get loop number
    message += "\nLoop number is :" + areaLoad.NumLoops;
    for (int i = 0; i < areaLoad.NumLoops; i++)
    {
        // Get curve number
        message += "\nCurve number is : " + areaLoad.get_NumCurves(i);
        for (int j = 0; j < areaLoad.get_NumCurves(i); j++)
        {
            Autodesk.Revit.DB.Curve curve = areaLoad.get_Curve(i, j);
            // Get curve start point
            message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
            // Get curve end point
            message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
                + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
        }
    }

    // Get ref points information
    for (int k = 0; k < areaLoad.NumRefPoints; k++)
    {
        // Get areaload Ref point
        message += "\nAreaLoad Ref point :(" + areaLoad.get_RefPoint(k).X + ", "
            + areaLoad.get_RefPoint(k).Y + ", " + areaLoad.get_RefPoint(k).Z + ")";
    }
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaLoad(ByVal areaLoad As Autodesk.Revit.DB.Structure.AreaLoad)
    Dim message As String = "AreaLoad Force : "
    ' Get areaload force1 position
    message += vbLf & "AreaLoad Force1 position :(" + areaLoad.Force1.X + ", " + areaLoad.Force1.Y + ", " + areaLoad.Force1.Z + ")"
    ' Get areaload force2 position
    message += vbLf & "AreaLoad Force2 position :(" + areaLoad.Force2.X + ", " + areaLoad.Force2.Y + ", " + areaLoad.Force2.Z + ")"
    ' Get areaload force3 position
    message += vbLf & "AreaLoad Force3 position :(" + areaLoad.Force3.X + ", " + areaLoad.Force3.Y + ", " + areaLoad.Force3.Z + ")"

    ' Get loop number
    message += vbLf & "Loop number is :" + areaLoad.NumLoops
    Dim i As Integer = 0
    While i < areaLoad.NumLoops
        ' Get curve number
        message += vbLf & "Curve number is : " + areaLoad.NumCurves(i)
        Dim j As Integer = 0
        While j < areaLoad.NumCurves(i)
            Dim curve As Autodesk.Revit.DB.Curve = areaLoad.Curve(i, j)
            ' Get curve start point
            message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
            ' Get curve end point
            message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
            System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
        End While
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Get ref points information
    Dim k As Integer = 0
    While k < areaLoad.NumRefPoints
        ' Get areaload Ref point
        message += vbLf & "AreaLoad Ref point :(" + areaLoad.RefPoint(k).X + ", " + areaLoad.RefPoint(k).Y + ", " + areaLoad.RefPoint(k).Z + ")"
        System.Math.Max(System.Threading.Interlocked.Increment(k), k - 1)
    End While
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..AreaLoad

See Also

AreaLoad Members
Autodesk.Revit.DB.Structure Namespace


AreaLoad Members

[image] [image]

Revit 2013 API
AreaLoad Members
AreaLoad Class Methods Properties See Also Send Feedback

The AreaLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to one of the points for the area load.
Public property | Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Public property | Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Public property | Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves within a geometric loop that defines the area.
Public property | NumLoops | Returns the number of geometric curve loops that define the area.
Public property | NumRefPoints | Returns the total number of reference points for the area load.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RefPoint | Retrieve the physical location of the reference point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoad Methods

[image] [image]

Revit 2013 API
AreaLoad Methods
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoad Properties

[image] [image]

Revit 2013 API
AreaLoad Properties
AreaLoad Class See Also Send Feedback

The AreaLoad type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the geometric curve within a geometric loop that defines the area.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to one of the points for the area load.
Public property | Force1 | Returns the three dimensional force applied to the point 1 of the area load.
Public property | Force2 | Returns the three dimensional force applied to the point 2 of the area load.
Public property | Force3 | Returns the three dimensional force applied to the point 3 of the area load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumCurves | Returns the number of curves within a geometric loop that defines the area.
Public property | NumLoops | Returns the number of geometric curve loops that define the area.
Public property | NumRefPoints | Returns the total number of reference points for the area load.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RefPoint | Retrieve the physical location of the reference point.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Curve Property

[image]

Revit 2013 API
AreaLoad..::..Curve Property
AreaLoad Class See Also Send Feedback
Returns the geometric curve within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve this[
    int loopIndex,
    int curveIndex
] { get; }
Visual Basic
Public ReadOnly Property Curve ( _
    loopIndex As Integer, _
    curveIndex As Integer _
) As Curve
    Get
Visual C++
public:
property Curve^ Curve[int loopIndex, int curveIndex] {
    Curve^ get (int loopIndex, int curveIndex);
}

Parameters

loopIndex
Type: System..::..Int32
The index of the geometric loop.
curveIndex
Type: System..::..Int32
The index curve within the loop.

Remarks

The loop index should be between 0 and less than NumLoops. The curve index should be between 0 and less than NumCurves(loopIndex).

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2013 API
AreaLoad..::..Force Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints. The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force1 Property

[image]

Revit 2013 API
AreaLoad..::..Force1 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 1 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic
Public ReadOnly Property Force1 As XYZ
    Get
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force2 Property

[image]

Revit 2013 API
AreaLoad..::..Force2 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 2 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic
Public ReadOnly Property Force2 As XYZ
    Get
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Force3 Property

[image]

Revit 2013 API
AreaLoad..::..Force3 Property
AreaLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point 3 of the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force3 { get; }
Visual Basic
Public ReadOnly Property Force3 As XYZ
    Get
Visual C++
public:
property XYZ^ Force3 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec*Feet.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumCurves Property

[image]

Revit 2013 API
AreaLoad..::..NumCurves Property
AreaLoad Class See Also Send Feedback
Returns the number of curves within a geometric loop that defines the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property NumCurves ( _
    index As Integer _
) As Integer
    Get
Visual C++
public:
property int NumCurves[int index] {
    int get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the geometric loop.

Remarks

The index should be between 0 and less than NumLoops.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumLoops Property

[image]

Revit 2013 API
AreaLoad..::..NumLoops Property
AreaLoad Class See Also Send Feedback
Returns the number of geometric curve loops that define the area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumLoops { get; }
Visual Basic
Public ReadOnly Property NumLoops As Integer
    Get
Visual C++
public:
property int NumLoops {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


NumRefPoints Property

[image]

Revit 2013 API
AreaLoad..::..NumRefPoints Property
AreaLoad Class See Also Send Feedback
Returns the total number of reference points for the area load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumRefPoints { get; }
Visual Basic
Public ReadOnly Property NumRefPoints As Integer
    Get
Visual C++
public:
property int NumRefPoints {
    int get ();
}

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AreaLoad..::..Parameter Property
AreaLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaLoad Class
AreaLoad Members
Autodesk.Revit.DB.Structure Namespace


RefPoint Property

[image]

Revit 2013 API
AreaLoad..::..RefPoint Property
AreaLoad Class See Also Send Feedback
Retrieve the physical location of the reference point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property RefPoint ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ RefPoint[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the point to return.

Remarks

The index should be between 0 and less than NumRefPoints.

See Also

AreaLoad Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Class

[image]

Revit 2013 API
AreaLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaLoadType : LoadTypeBase
Visual Basic
Public Class AreaLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class AreaLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..AreaLoadType

See Also

AreaLoadType Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Members

[image] [image]

Revit 2013 API
AreaLoadType Members
AreaLoadType Class Methods Properties See Also Send Feedback

The AreaLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Methods

[image] [image]

Revit 2013 API
AreaLoadType Methods
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadType Properties

[image] [image]

Revit 2013 API
AreaLoadType Properties
AreaLoadType Class See Also Send Feedback

The AreaLoadType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AreaLoadType..::..Parameter Property
AreaLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaLoadType Class
AreaLoadType Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Class

[image]

Revit 2013 API
AreaLoadTypeSet Class
Members See Also Send Feedback
A set that contains areaload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaLoadTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class AreaLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AreaLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..AreaLoadTypeSet

See Also

AreaLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Members

[image] [image]

Revit 2013 API
AreaLoadTypeSet Members
AreaLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | AreaLoadTypeSet | Initializes a new instance of the AreaLoadTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every areaload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areaload type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areaload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areaload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Constructor

[image]

Revit 2013 API
AreaLoadTypeSet Constructor
AreaLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the AreaLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoadTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
AreaLoadTypeSet()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Methods

[image] [image]

Revit 2013 API
AreaLoadTypeSet Methods
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every areaload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a areaload type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified areaload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified areaload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..Clear Method
AreaLoadTypeSet Class See Also Send Feedback
Removes every areaload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..Contains Method
AreaLoadTypeSet Class See Also Send Feedback
Tests for the existence of a areaload type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    AreaLoadType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The areaload type to be searched for.

Return Value

The Contains method returns True if the areaload type is within the set, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..Erase Method
AreaLoadTypeSet Class See Also Send Feedback
Removes a specified areaload type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    AreaLoadType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As AreaLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The areaload type to be erased.

Return Value

The number of areaload types that were erased from the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..ForwardIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..GetEnumerator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..Insert Method
AreaLoadTypeSet Class See Also Send Feedback
Insert the specified areaload type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    AreaLoadType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As AreaLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    AreaLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..AreaLoadType
The areaload type to be inserted into the set.

Return Value

Returns whether the areaload type was inserted into the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
AreaLoadTypeSet..::..ReverseIterator Method
AreaLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AreaLoadTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As AreaLoadTypeSetIterator
Visual C++
public:
virtual AreaLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSet Properties

[image] [image]

Revit 2013 API
AreaLoadTypeSet Properties
AreaLoadTypeSet Class See Also Send Feedback

The AreaLoadTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of areaload types that are in the set.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
AreaLoadTypeSet..::..IsEmpty Property
AreaLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
AreaLoadTypeSet..::..Size Property
AreaLoadTypeSet Class See Also Send Feedback
Returns the number of areaload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AreaLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Class

[image]

Revit 2013 API
AreaLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a areaload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class AreaLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class AreaLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AreaLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..AreaLoadTypeSetIterator

See Also

AreaLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Members

[image] [image]

Revit 2013 API
AreaLoadTypeSetIterator Members
AreaLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | AreaLoadTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Constructor

[image]

Revit 2013 API
AreaLoadTypeSetIterator Constructor
AreaLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaLoadTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
AreaLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Methods

[image] [image]

Revit 2013 API
AreaLoadTypeSetIterator Methods
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
AreaLoadTypeSetIterator..::..MoveNext Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
AreaLoadTypeSetIterator..::..Reset Method
AreaLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaLoadTypeSetIterator Properties

[image] [image]

Revit 2013 API
AreaLoadTypeSetIterator Properties
AreaLoadTypeSetIterator Class See Also Send Feedback

The AreaLoadTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
AreaLoadTypeSetIterator..::..Current Property
AreaLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AreaLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Class

[image]

Revit 2013 API
AreaReinforcement Class
Members Example See Also Send Feedback
An object that represents an Area Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaReinforcement : Element
Visual Basic
Public Class AreaReinforcement _
    Inherits Element
Visual C++
public ref class AreaReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    message += "\nNumber of distinct bar shapes : " + areaReinforcement.NumBarDescriptions;

    for (int i = 0; i < areaReinforcement.NumBarDescriptions; i++)
    {
        message += "\nBar Description " + i;
        message += "\n\tBar count : " +
                          areaReinforcement.get_BarDescription(i).Count;
        message += "\n\tBar type name : " +
                          areaReinforcement.get_BarDescription(i).BarType.Name;
        message += "\n\tBar layer index : " +
                          areaReinforcement.get_BarDescription(i).Layer;
        message += "\n\tBar length : " +
                          areaReinforcement.get_BarDescription(i).Length;
    }

    // Show the AreaReinforcement Curves information
    message += "\nArea Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves.";

    foreach (Autodesk.Revit.DB.Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve reinCurve = ii as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
        XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcement(ByVal areaReinforcement As Autodesk.Revit.DB.Structure.AreaReinforcement)
    Dim message As String = "AreaReinforcement : "

    ' Show the AreaReinforcement Type information
    'message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    ' Show the AreaReinforcement bar information
    message += vbLf & "Number of distinct bar shapes : " + areaReinforcement.NumBarDescriptions

    Dim i As Integer = 0
    While i < areaReinforcement.NumBarDescriptions
        message += vbLf & "Bar Description " + i
        message += vbLf & vbTab & "Bar count : " + areaReinforcement.BarDescription(i).Count
        message += vbLf & vbTab & "Bar type name : " + areaReinforcement.BarDescription(i).BarType.Name
        message += vbLf & vbTab & "Bar layer index : " + areaReinforcement.BarDescription(i).Layer
        message += vbLf & vbTab & "Bar length : " + areaReinforcement.BarDescription(i).Length
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Show the AreaReinforcement Curves information
    message += vbLf & "Area Reinforcement has " + areaReinforcement.Curves.Size + " boundary curves."

    For Each ii As Autodesk.Revit.DB.Element In areaReinforcement.Curves
        Dim reinCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If reinCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = reinCurve.Curve
        ' get the location curve
        Dim start As Autodesk.Revit.DB.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.DB.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += vbLf & "Curve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")"
        message += vbLf & "       End point (" + [end].X + ", " + [end].Y + ", " + [end].Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..AreaReinforcement

See Also

AreaReinforcement Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Members

[image] [image]

Revit 2013 API
AreaReinforcement Members
AreaReinforcement Class Methods Properties See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RemoveAreaReinforcementSystem | Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AdditionalBottomCoverOffset | Additional offset from the bottom or interior cover reference.
Public property | AdditionalTopCoverOffset | Additional offset from the top or exterior cover reference.
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Area Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Obsolete. Retrieves the number of distinct bar shapes.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Methods

[image] [image]

Revit 2013 API
AreaReinforcement Methods
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RemoveAreaReinforcementSystem | Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


GetCurveElementIds Method

[image]

Revit 2013 API
AreaReinforcement..::..GetCurveElementIds Method
AreaReinforcement Class See Also Send Feedback
Retrieves the set of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetCurveElementIds()
Visual Basic
Public Function GetCurveElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetCurveElementIds()

Return Value

A collection of ElementIds of AreaReinforcementCurve elements.

Remarks

Each ElementId in the collection is an Id of an Element of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


GetRebarInSystemIds Method

[image]

Revit 2013 API
AreaReinforcement..::..GetRebarInSystemIds Method
AreaReinforcement Class See Also Send Feedback
Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetRebarInSystemIds()
Visual Basic
Public Function GetRebarInSystemIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRebarInSystemIds()

Remarks

The RebarInSystem elements are only created if ReinforcementSettings.HostStructuralRebar is set to true. If that setting is false, this function returns an empty array.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


RemoveAreaReinforcementSystem Method

[image]

Revit 2013 API
AreaReinforcement..::..RemoveAreaReinforcementSystem Method
AreaReinforcement Class See Also Send Feedback
Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ElementId> RemoveAreaReinforcementSystem(
    Document doc,
    AreaReinforcement system
)
Visual Basic
Public Shared Function RemoveAreaReinforcementSystem ( _
    doc As Document, _
    system As AreaReinforcement _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ RemoveAreaReinforcementSystem(
    Document^ doc,
    AreaReinforcement^ system
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
system
Type: Autodesk.Revit.DB.Structure..::..AreaReinforcement
An AreaReinforcement element in the document.

Return Value

The ids of the newly created Rebar elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document doc does not contain the element system
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcement Properties

[image] [image]

Revit 2013 API
AreaReinforcement Properties
AreaReinforcement Class See Also Send Feedback

The AreaReinforcement type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalBottomCoverOffset | Additional offset from the bottom or interior cover reference.
Public property | AdditionalTopCoverOffset | Additional offset from the top or exterior cover reference.
Public property | AreaReinforcementType | Retrieves the type of the Area Reinforcement.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Area Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Area Reinforcement.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve or change the Major Direction of the Area Reinforcement.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Obsolete. Retrieves the number of distinct bar shapes.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AdditionalBottomCoverOffset Property

[image]

Revit 2013 API
AreaReinforcement..::..AdditionalBottomCoverOffset Property
AreaReinforcement Class See Also Send Feedback
Additional offset from the bottom or interior cover reference.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double AdditionalBottomCoverOffset { get; set; }
Visual Basic
Public Property AdditionalBottomCoverOffset As Double
    Get
    Set
Visual C++
public:
property double AdditionalBottomCoverOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for additionalBottomCoverOffset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AdditionalTopCoverOffset Property

[image]

Revit 2013 API
AreaReinforcement..::..AdditionalTopCoverOffset Property
AreaReinforcement Class See Also Send Feedback
Additional offset from the top or exterior cover reference.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double AdditionalTopCoverOffset { get; set; }
Visual Basic
Public Property AdditionalTopCoverOffset As Double
    Get
    Set
Visual C++
public:
property double AdditionalTopCoverOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for additionalTopCoverOffset must be no more than 30000 feet in absolute value.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Property

[image]

Revit 2013 API
AreaReinforcement..::..AreaReinforcementType Property
AreaReinforcement Class See Also Send Feedback
Retrieves the type of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AreaReinforcementType AreaReinforcementType { get; }
Visual Basic
Public ReadOnly Property AreaReinforcementType As AreaReinforcementType
    Get
Visual C++
public:
property AreaReinforcementType^ AreaReinforcementType {
    AreaReinforcementType^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Property

[image]

Revit 2013 API
AreaReinforcement..::..BarDescription Property
AreaReinforcement Class See Also Send Feedback
Retrieves the BarDescription property of an Area Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public BarDescription this[
    int idx
] { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")> _
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of a Bar Description.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2013 API
AreaReinforcement..::..Curves Property
AreaReinforcement Class See Also Send Feedback
Retrieves the array of curves forming the boundary of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public ElementArray Curves { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")> _
Public ReadOnly Property Curves As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type AreaReinforcementCurve. Each element has a Curve property to retrieve the geometric curve, together with some Parameters allowing the developer to override the clear cover side, hook type, and hook direction of each layer of bars terminating at the curve.

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2013 API
AreaReinforcement..::..Direction Property
AreaReinforcement Class See Also Send Feedback
Retrieve or change the Major Direction of the Area Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


NumBarDescriptions Property

[image]

Revit 2013 API
AreaReinforcement..::..NumBarDescriptions Property
AreaReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.")]
public int NumBarDescriptions { get; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.")> _
Public ReadOnly Property NumBarDescriptions As Integer
    Get
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.")]
public:
property int NumBarDescriptions {
    int get ();
}

See Also

AreaReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AreaReinforcement..::..Parameter Property
AreaReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaReinforcement Class
AreaReinforcement Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Class

[image]

Revit 2013 API
AreaReinforcementCurve Class
Members Example See Also Send Feedback
An object that specifies the type of a floor in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaReinforcementCurve : CurveElement
Visual Basic
Public Class AreaReinforcementCurve _
    Inherits CurveElement
Visual C++
public ref class AreaReinforcementCurve : public CurveElement

Remarks

The structural layers of the floor can be accessed via this object.

Examples

CopyC#
public void GetInfo_AreaReinforcementCurve(AreaReinforcement areaReinforcement)
{
    string message = "Area Reinforcement Curves : ";

    // Get area reinforcement curves by iterating the Curves property
    foreach (Element ii in areaReinforcement.Curves)
    {
        AreaReinforcementCurve areaReinforcementCurve = ii as AreaReinforcementCurve;
        if (null == areaReinforcementCurve)
        {
            continue;
        }
        Autodesk.Revit.DB.Curve curve = areaReinforcementCurve.Curve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
                       + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "\nCurve end point:(" + curve.get_EndPoint(1).X + ", "
                       + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Public Sub GetInfo_AreaReinforcementCurve(ByVal areaReinforcement As Autodesk.Revit.DB.Structure.AreaReinforcement)
    Dim message As String = "Area Reinforcement Curves : "

    ' Get area reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.DB.Element In areaReinforcement.Curves
        Dim areaReinforcementCurve As AreaReinforcementCurve = TryCast(ii, AreaReinforcementCurve)
        If areaReinforcementCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Autodesk.Revit.DB.Curve = areaReinforcementCurve.Curve

        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += vbLf & "Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..CurveElement
Autodesk.Revit.DB.Structure..::..AreaReinforcementCurve

See Also

AreaReinforcementCurve Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Members

[image] [image]

Revit 2013 API
AreaReinforcementCurve Members
AreaReinforcementCurve Class Methods Properties See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Methods

[image] [image]

Revit 2013 API
AreaReinforcementCurve Methods
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLineStyleIds | Retrieves the set of available line style Element Ids. (Inherited from CurveElement.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementCurve Properties

[image] [image]

Revit 2013 API
AreaReinforcementCurve Properties
AreaReinforcementCurve Class See Also Send Feedback

The AreaReinforcementCurve type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CenterPointReference | Centerpoint reference of curve element. Curves such as circles, arcs, ellipses, and partial ellipses support this property. (Inherited from CurveElement.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curve | Returns the 3D curve forming part of the boundary of an Area Reinforcement element.
Public property | CurveElementType | The curve element type. (Inherited from CurveElement.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | GeometryCurve | Geometry curve of the curve element. (Inherited from CurveElement.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LineStyle | The line style of this curve element. (Inherited from CurveElement.)
Public property | LineStyles | Obsolete. All available line styles. (Inherited from CurveElement.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchPlane | The sketch plane the curve element lies in. (Inherited from CurveElement.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


Curve Property

[image]

Revit 2013 API
AreaReinforcementCurve..::..Curve Property
AreaReinforcementCurve Class See Also Send Feedback
Returns the 3D curve forming part of the boundary of an Area Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Curve Curve { get; }
Visual Basic
Public ReadOnly Property Curve As Curve
    Get
Visual C++
public:
property Curve^ Curve {
    Curve^ get ();
}

See Also

AreaReinforcementCurve Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AreaReinforcementCurve..::..Parameter Property
AreaReinforcementCurve Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaReinforcementCurve Class
AreaReinforcementCurve Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Class

[image]

Revit 2013 API
AreaReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Area Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AreaReinforcementType : ElementType
Visual Basic
Public Class AreaReinforcementType _
    Inherits ElementType
Visual C++
public ref class AreaReinforcementType : public ElementType

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..AreaReinforcementType

See Also

AreaReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Members

[image] [image]

Revit 2013 API
AreaReinforcementType Members
AreaReinforcementType Class Methods Properties See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Methods

[image] [image]

Revit 2013 API
AreaReinforcementType Methods
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


AreaReinforcementType Properties

[image] [image]

Revit 2013 API
AreaReinforcementType Properties
AreaReinforcementType Class See Also Send Feedback

The AreaReinforcementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

AreaReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
AreaReinforcementType..::..Parameter Property
AreaReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

AreaReinforcementType Class
AreaReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


BarDescription Class

[image]

Revit 2013 API
BarDescription Class
Members See Also Send Feedback
A description of a straight rebar, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This class is obsolete in Revit 2013. Use RebarInSystem instead.")]
public class BarDescription : IDisposable
Visual Basic
<ObsoleteAttribute("This class is obsolete in Revit 2013. Use RebarInSystem instead.")> _
Public Class BarDescription _
    Implements IDisposable
Visual C++
[ObsoleteAttribute(L"This class is obsolete in Revit 2013. Use RebarInSystem instead.")]
public ref class BarDescription : IDisposable

Remarks

An AreaReinforcement or PathReinforcement element generates a collection of BarDescription objects with multiplicities.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..BarDescription

See Also

BarDescription Members
Autodesk.Revit.DB.Structure Namespace


BarDescription Members

[image] [image]

Revit 2013 API
BarDescription Members
BarDescription Class Methods Properties See Also Send Feedback

The BarDescription type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the BarDescription
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Gets the rebar hook type identifier of a Bar Description.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarType | Obsolete. Retrieves the Rebar Bar Type property of a Bar Description.
Public property | BarTypeId | Retrieves the Rebar Bar Type Id property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | Layer | Obsolete. Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | LayerDirection | Retrieves the layer index for this Bar Description when area or path reinforcement's host is wall.
Public property | LayerFace | Retrieves the layer index for this Bar Description when area or path reinforcement's host is floor.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Methods

[image] [image]

Revit 2013 API
BarDescription Methods
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Gets the rebar hook type identifier of a Bar Description.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
BarDescription..::..Dispose Method
BarDescription Class See Also Send Feedback
Releases all resources used by the BarDescription

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


GetHookTypeId Method

[image]

Revit 2013 API
BarDescription..::..GetHookTypeId Method
BarDescription Class See Also Send Feedback
Gets the rebar hook type identifier of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetHookTypeId(
    int end
)
Visual Basic
Public Function GetHookTypeId ( _
    end As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetHookTypeId(
    int end
)

Parameters

end
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook

Return Value

id of the rebar hook type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Properties

[image] [image]

Revit 2013 API
BarDescription Properties
BarDescription Class See Also Send Feedback

The BarDescription type exposes the following members.

Properties

 | Name | Description
Public property | BarType | Obsolete. Retrieves the Rebar Bar Type property of a Bar Description.
Public property | BarTypeId | Retrieves the Rebar Bar Type Id property of a Bar Description.
Public property | Count | Retrieves the number of bars of this shape.
Public property | HooksInSameDirection | Retrieves the Rebar Hooks In Same Direction property of a Bar Description.
Public property | HookType | Retrieves the Rebar Hook Type property of a Bar Description.
Public property | Layer | Obsolete. Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.
Public property | LayerDirection | Retrieves the layer index for this Bar Description when area or path reinforcement's host is wall.
Public property | LayerFace | Retrieves the layer index for this Bar Description when area or path reinforcement's host is floor.
Public property | Length | Retrieves the length of a Bar Description.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarType Property

[image]

Revit 2013 API
BarDescription..::..BarType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Bar Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use property BarTypeId instead.")]
public RebarBarType BarType { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use property BarTypeId instead.")> _
Public ReadOnly Property BarType As RebarBarType
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use property BarTypeId instead.")]
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BarTypeId Property

[image]

Revit 2013 API
BarDescription..::..BarTypeId Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Bar Type Id property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId BarTypeId { get; }
Visual Basic
Public ReadOnly Property BarTypeId As ElementId
    Get
Visual C++
public:
property ElementId^ BarTypeId {
    ElementId^ get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Count Property

[image]

Revit 2013 API
BarDescription..::..Count Property
BarDescription Class See Also Send Feedback
Retrieves the number of bars of this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


HooksInSameDirection Property

[image]

Revit 2013 API
BarDescription..::..HooksInSameDirection Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hooks In Same Direction property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool HooksInSameDirection { get; }
Visual Basic
Public ReadOnly Property HooksInSameDirection As Boolean
    Get
Visual C++
public:
property bool HooksInSameDirection {
    bool get ();
}

Remarks

If true, both hooks are bent in the same direction; if false, the hooks are bent in opposite directions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


HookType Property

[image]

Revit 2013 API
BarDescription..::..HookType Property
BarDescription Class See Also Send Feedback
Retrieves the Rebar Hook Type property of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarHookType this[
    int end
] { get; }
Visual Basic
Public ReadOnly Property HookType ( _
    end As Integer _
) As RebarHookType
    Get
Visual C++
public:
property RebarHookType^ HookType[int end] {
    RebarHookType^ get (int end);
}

Parameters

end
Type: System..::..Int32
Which end of the bar: 0 or 1.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Layer Property

[image]

Revit 2013 API
BarDescription..::..Layer Property
BarDescription Class See Also Send Feedback
Retrieves the layer index (0, 1, 2, or 3) for this Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use a combination of LayerFace and LayerDirection instead.")]
public int Layer { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use a combination of LayerFace and LayerDirection instead.")> _
Public ReadOnly Property Layer As Integer
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use a combination of LayerFace and LayerDirection instead.")]
public:
property int Layer {
    int get ();
}

Remarks

For floors, layer 0 is Top Major; layer 1 is Top Minor; layer 2 is Bottom Major; layer 3 is Bottom Minor. For walls, layer 0 is Front Major; layer 1 is Front Minor; layer 2 is Back Major; layer 3 is Back Minor.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


LayerDirection Property

[image]

Revit 2013 API
BarDescription..::..LayerDirection Property
BarDescription Class See Also Send Feedback
Retrieves the layer index for this Bar Description when area or path reinforcement's host is wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReinforcementLayerDirection LayerDirection { get; }
Visual Basic
Public ReadOnly Property LayerDirection As ReinforcementLayerDirection
    Get
Visual C++
public:
property ReinforcementLayerDirection LayerDirection {
    ReinforcementLayerDirection get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


LayerFace Property

[image]

Revit 2013 API
BarDescription..::..LayerFace Property
BarDescription Class See Also Send Feedback
Retrieves the layer index for this Bar Description when area or path reinforcement's host is floor.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ReinforcementLayerFace LayerFace { get; }
Visual Basic
Public ReadOnly Property LayerFace As ReinforcementLayerFace
    Get
Visual C++
public:
property ReinforcementLayerFace LayerFace {
    ReinforcementLayerFace get ();
}

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


Length Property

[image]

Revit 2013 API
BarDescription..::..Length Property
BarDescription Class See Also Send Feedback
Retrieves the length of a Bar Description.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Length { get; }
Visual Basic
Public ReadOnly Property Length As Double
    Get
Visual C++
public:
property double Length {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

BarDescription Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionsType Enumeration

[image]

Revit 2013 API
BoundaryConditionsType Enumeration
See Also Send Feedback
This enum declares type of BoundaryConditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum BoundaryConditionsType
Visual Basic
Public Enumeration BoundaryConditionsType
Visual C++
public enum class BoundaryConditionsType

Members

Member name | Description
Nothing | Invalid type
Point | Point Boundary Conditions
Line | Line Boundary Conditions
Area | Area Boundary Conditions

See Also

Autodesk.Revit.DB.Structure Namespace


BracePlanRepresentation Enumeration

[image]

Revit 2013 API
BracePlanRepresentation Enumeration
See Also Send Feedback
The possible representations for braces in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum BracePlanRepresentation
Visual Basic
Public Enumeration BracePlanRepresentation
Visual C++
public enum class BracePlanRepresentation

Members

Member name | Description
ParallelLine | Braces are represented by a parallel line.
LineWithAngle | Braces are represented by a line with angle.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricArea Class

[image]

Revit 2013 API
FabricArea Class
Members See Also Send Feedback
An object that represents an Fabric Area Distribution within the Autodesk Revit project. It is container for Fabric Sheet elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricArea : Element
Visual Basic
Public Class FabricArea _
    Inherits Element
Visual C++
public ref class FabricArea : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Fabric Area element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..FabricArea

See Also

FabricArea Members
Autodesk.Revit.DB.Structure Namespace


FabricArea Members

[image] [image]

Revit 2013 API
FabricArea Members
FabricArea Class Methods Properties See Also Send Feedback

The FabricArea type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CopyCurveLoopsInSketch | Creates copies of the CurveLoops in the FabricArea sketch.
 | Create | create FabricArea from an array of GCurves A document The element that will host the FabricArea. An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area. A vector to the define the major direction of the fabric distribution
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the identifiers of the set of curves forming the boundary of the Fabric Area.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFabricSheetElementIds | Retrieves the identifiers of all the FabricSheet Elements in the FabricArea.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalSheetMass | Calculated all sheet mass: Volume of Wire * Unit Weight.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetValidViewsForTags | Gets ids of the views where tags and symbols can be placed for the FabricArea and/or FabricSheets
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCoverOffsetValid |
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFabricSheetType |
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidMajorLapSplice |
Public method | IsValidMinorLapSplice |
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFabricLocation | Set Fabric location in the host.
Public method | SetFabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public method | SetMajorSheetAlignment | Set Major Sheet Alignment in the distribution.
Public method | SetMinorSheetAlignment | Set Minor Sheet Alignment in the distribution.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverOffset | Additional cover offset of the fabric distribution.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve the Major Direction of the Fabric Area.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FabricAreaType | Retrieves the type of the Fabric Area.
Public property | FabricLocation | Fabric location in the host.
Public property | FabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostId | Host element (slab, wall, etc.) Id.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LapSplicePosition | Fabric lap splice position in the fabric distribution
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorLapSpliceLength | Fabric lap splice length in major direction in the fabric distribution.
Public property | MajorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorLapSpliceLength | Fabric lap splice length in minor direction in the fabric distribution.
Public property | MinorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Sketch element id
Public property | TagViewId | Tag new members in view
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricArea Methods

[image] [image]

Revit 2013 API
FabricArea Methods
FabricArea Class See Also Send Feedback

The FabricArea type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | CopyCurveLoopsInSketch | Creates copies of the CurveLoops in the FabricArea sketch.
 | Create | create FabricArea from an array of GCurves A document The element that will host the FabricArea. An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area. A vector to the define the major direction of the fabric distribution
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the identifiers of the set of curves forming the boundary of the Fabric Area.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFabricSheetElementIds | Retrieves the identifiers of all the FabricSheet Elements in the FabricArea.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTotalSheetMass | Calculated all sheet mass: Volume of Wire * Unit Weight.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetValidViewsForTags | Gets ids of the views where tags and symbols can be placed for the FabricArea and/or FabricSheets
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsCoverOffsetValid |
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsFabricSheetType |
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidMajorLapSplice |
Public method | IsValidMinorLapSplice |
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFabricLocation | Set Fabric location in the host.
Public method | SetFabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public method | SetMajorSheetAlignment | Set Major Sheet Alignment in the distribution.
Public method | SetMinorSheetAlignment | Set Minor Sheet Alignment in the distribution.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


CopyCurveLoopsInSketch Method

[image]

Revit 2013 API
FabricArea..::..CopyCurveLoopsInSketch Method
FabricArea Class See Also Send Feedback
Creates copies of the CurveLoops in the FabricArea sketch.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<CurveLoop> CopyCurveLoopsInSketch()
Visual Basic
Public Function CopyCurveLoopsInSketch As IList(Of CurveLoop)
Visual C++
public:
IList<CurveLoop^>^ CopyCurveLoopsInSketch()

Remarks

Tags on the curves are not copied.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
FabricArea..::..Create Method
FabricArea Class See Also Send Feedback
create FabricArea from an array of GCurves A document The element that will host the FabricArea. An array of curves that will define the outline of the FabricArea. This includes curves defining openings in the interior of the area. A vector to the define the major direction of the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FabricArea Create(
    Document aDoc,
    Element hostElement,
    IList<CurveLoop> curveLoops,
    XYZ majorDirection
)
Visual Basic
Public Shared Function Create ( _
    aDoc As Document, _
    hostElement As Element, _
    curveLoops As IList(Of CurveLoop), _
    majorDirection As XYZ _
) As FabricArea
Visual C++
public:
static FabricArea^ Create(
    Document^ aDoc,
    Element^ hostElement,
    IList<CurveLoop^>^ curveLoops,
    XYZ^ majorDirection
)

Parameters

aDoc
Type: Autodesk.Revit.DB..::..Document
hostElement
Type: Autodesk.Revit.DB..::..Element
curveLoops
Type: System.Collections.Generic..::..IList<(Of <(<'CurveLoop>)>)>
majorDirection
Type: Autodesk.Revit.DB..::..XYZ

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Not all curveLoops in curveLoops are closed and continuous. -or- Not all curveLoops in curveLoops are in the same plane. -or- curveLoops should only contain lines or arcs. -or- the host Element is not a valid host for Area Rebar, Path Rebar or Fabric Area reinforcement
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | majorDirection has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


GetCurveElementIds Method

[image]

Revit 2013 API
FabricArea..::..GetCurveElementIds Method
FabricArea Class See Also Send Feedback
Retrieves the identifiers of the set of curves forming the boundary of the Fabric Area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetCurveElementIds()
Visual Basic
Public Function GetCurveElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetCurveElementIds()

Return Value

A collection of ElementIds of AreaReinforcementCurve elements.

Remarks

Each ElementId in the collection is an Id of an Element of type CurveElem.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


GetFabricSheetElementIds Method

[image]

Revit 2013 API
FabricArea..::..GetFabricSheetElementIds Method
FabricArea Class See Also Send Feedback
Retrieves the identifiers of all the FabricSheet Elements in the FabricArea.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetFabricSheetElementIds()
Visual Basic
Public Function GetFabricSheetElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetFabricSheetElementIds()

Return Value

A collection of ElementIds of FabricSheet elements.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


GetTotalSheetMass Method

[image]

Revit 2013 API
FabricArea..::..GetTotalSheetMass Method
FabricArea Class See Also Send Feedback
Calculated all sheet mass: Volume of Wire * Unit Weight.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double GetTotalSheetMass()
Visual Basic
Public Function GetTotalSheetMass As Double
Visual C++
public:
double GetTotalSheetMass()

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


GetValidViewsForTags Method

[image]

Revit 2013 API
FabricArea..::..GetValidViewsForTags Method
FabricArea Class See Also Send Feedback
Gets ids of the views where tags and symbols can be placed for the FabricArea and/or FabricSheets

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetValidViewsForTags()
Visual Basic
Public Function GetValidViewsForTags As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetValidViewsForTags()

Return Value

A collection of DBView ElementIds

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


IsCoverOffsetValid Method

[image]

Revit 2013 API
FabricArea..::..IsCoverOffsetValid Method
FabricArea Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsCoverOffsetValid(
    double coverOffset
)
Visual Basic
Public Function IsCoverOffsetValid ( _
    coverOffset As Double _
) As Boolean
Visual C++
public:
bool IsCoverOffsetValid(
    double coverOffset
)

Parameters

coverOffset
Type: System..::..Double

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


IsFabricSheetType Method

[image]

Revit 2013 API
FabricArea..::..IsFabricSheetType Method
FabricArea Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsFabricSheetType(
    ElementId fabricSheetTypeId
)
Visual Basic
Public Function IsFabricSheetType ( _
    fabricSheetTypeId As ElementId _
) As Boolean
Visual C++
public:
bool IsFabricSheetType(
    ElementId^ fabricSheetTypeId
)

Parameters

fabricSheetTypeId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


IsValidMajorLapSplice Method

[image]

Revit 2013 API
FabricArea..::..IsValidMajorLapSplice Method
FabricArea Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMajorLapSplice(
    double majorLapSplice
)
Visual Basic
Public Function IsValidMajorLapSplice ( _
    majorLapSplice As Double _
) As Boolean
Visual C++
public:
bool IsValidMajorLapSplice(
    double majorLapSplice
)

Parameters

majorLapSplice
Type: System..::..Double

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


IsValidMinorLapSplice Method

[image]

Revit 2013 API
FabricArea..::..IsValidMinorLapSplice Method
FabricArea Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMinorLapSplice(
    double minorLapSplice
)
Visual Basic
Public Function IsValidMinorLapSplice ( _
    minorLapSplice As Double _
) As Boolean
Visual C++
public:
bool IsValidMinorLapSplice(
    double minorLapSplice
)

Parameters

minorLapSplice
Type: System..::..Double

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


SetFabricLocation Method

[image]

Revit 2013 API
FabricArea..::..SetFabricLocation Method
FabricArea Class See Also Send Feedback
Set Fabric location in the host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFabricLocation(
    FabricLocation fabricLocation
)
Visual Basic
Public Sub SetFabricLocation ( _
    fabricLocation As FabricLocation _
)
Visual C++
public:
void SetFabricLocation(
    FabricLocation fabricLocation
)

Parameters

fabricLocation
Type: Autodesk.Revit.DB.Structure..::..FabricLocation

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


SetFabricSheetTypeId Method

[image]

Revit 2013 API
FabricArea..::..SetFabricSheetTypeId Method
FabricArea Class See Also Send Feedback
Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetFabricSheetTypeId(
    ElementId fabricSheetTypeId
)
Visual Basic
Public Sub SetFabricSheetTypeId ( _
    fabricSheetTypeId As ElementId _
)
Visual C++
public:
void SetFabricSheetTypeId(
    ElementId^ fabricSheetTypeId
)

Parameters

fabricSheetTypeId
Type: Autodesk.Revit.DB..::..ElementId

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | fabricSheetTypeId is not a Fabric Sheet Type.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


SetMajorSheetAlignment Method

[image]

Revit 2013 API
FabricArea..::..SetMajorSheetAlignment Method
FabricArea Class See Also Send Feedback
Set Major Sheet Alignment in the distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorSheetAlignment(
    FabricSheetAlignment alignment
)
Visual Basic
Public Sub SetMajorSheetAlignment ( _
    alignment As FabricSheetAlignment _
)
Visual C++
public:
void SetMajorSheetAlignment(
    FabricSheetAlignment alignment
)

Parameters

alignment
Type: Autodesk.Revit.DB.Structure..::..FabricSheetAlignment

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


SetMinorSheetAlignment Method

[image]

Revit 2013 API
FabricArea..::..SetMinorSheetAlignment Method
FabricArea Class See Also Send Feedback
Set Minor Sheet Alignment in the distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorSheetAlignment(
    FabricSheetAlignment alignment
)
Visual Basic
Public Sub SetMinorSheetAlignment ( _
    alignment As FabricSheetAlignment _
)
Visual C++
public:
void SetMinorSheetAlignment(
    FabricSheetAlignment alignment
)

Parameters

alignment
Type: Autodesk.Revit.DB.Structure..::..FabricSheetAlignment

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricArea Properties

[image] [image]

Revit 2013 API
FabricArea Properties
FabricArea Class See Also Send Feedback

The FabricArea type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverOffset | Additional cover offset of the fabric distribution.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Direction | Retrieve the Major Direction of the Fabric Area.
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FabricAreaType | Retrieves the type of the Fabric Area.
Public property | FabricLocation | Fabric location in the host.
Public property | FabricSheetTypeId | Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostId | Host element (slab, wall, etc.) Id.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LapSplicePosition | Fabric lap splice position in the fabric distribution
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorLapSpliceLength | Fabric lap splice length in major direction in the fabric distribution.
Public property | MajorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorLapSpliceLength | Fabric lap splice length in minor direction in the fabric distribution.
Public property | MinorSheetAlignment | Fabric Sheet alignment in the fabric distribution
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SketchId | Sketch element id
Public property | TagViewId | Tag new members in view
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


CoverOffset Property

[image]

Revit 2013 API
FabricArea..::..CoverOffset Property
FabricArea Class See Also Send Feedback
Additional cover offset of the fabric distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CoverOffset { get; set; }
Visual Basic
Public Property CoverOffset As Double
    Get
    Set
Visual C++
public:
property double CoverOffset {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for coverOffset is not a number -or- When setting this property: coverOffset is greater then the host thickness.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for coverOffset must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2013 API
FabricArea..::..Direction Property
FabricArea Class See Also Send Feedback
Retrieve the Major Direction of the Fabric Area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Direction { get; }
Visual Basic
Public ReadOnly Property Direction As XYZ
    Get
Visual C++
public:
property XYZ^ Direction {
    XYZ^ get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricAreaType Property

[image]

Revit 2013 API
FabricArea..::..FabricAreaType Property
FabricArea Class See Also Send Feedback
Retrieves the type of the Fabric Area.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricAreaType FabricAreaType { get; }
Visual Basic
Public ReadOnly Property FabricAreaType As FabricAreaType
    Get
Visual C++
public:
property FabricAreaType^ FabricAreaType {
    FabricAreaType^ get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricLocation Property

[image]

Revit 2013 API
FabricArea..::..FabricLocation Property
FabricArea Class See Also Send Feedback
Fabric location in the host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricLocation FabricLocation { get; }
Visual Basic
Public ReadOnly Property FabricLocation As FabricLocation
    Get
Visual C++
public:
property FabricLocation FabricLocation {
    FabricLocation get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricSheetTypeId Property

[image]

Revit 2013 API
FabricArea..::..FabricSheetTypeId Property
FabricArea Class See Also Send Feedback
Fabric Sheet Type Id. Defines the Fabric Sheet to be hosted and replicated by this element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId FabricSheetTypeId { get; }
Visual Basic
Public ReadOnly Property FabricSheetTypeId As ElementId
    Get
Visual C++
public:
property ElementId^ FabricSheetTypeId {
    ElementId^ get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


HostId Property

[image]

Revit 2013 API
FabricArea..::..HostId Property
FabricArea Class See Also Send Feedback
Host element (slab, wall, etc.) Id.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId HostId { get; }
Visual Basic
Public ReadOnly Property HostId As ElementId
    Get
Visual C++
public:
property ElementId^ HostId {
    ElementId^ get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


LapSplicePosition Property

[image]

Revit 2013 API
FabricArea..::..LapSplicePosition Property
FabricArea Class See Also Send Feedback
Fabric lap splice position in the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricLapSplicePosition LapSplicePosition { get; set; }
Visual Basic
Public Property LapSplicePosition As FabricLapSplicePosition
    Get
    Set
Visual C++
public:
property FabricLapSplicePosition LapSplicePosition {
    FabricLapSplicePosition get ();
    void set (FabricLapSplicePosition value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


MajorLapSpliceLength Property

[image]

Revit 2013 API
FabricArea..::..MajorLapSpliceLength Property
FabricArea Class See Also Send Feedback
Fabric lap splice length in major direction in the fabric distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorLapSpliceLength { get; set; }
Visual Basic
Public Property MajorLapSpliceLength As Double
    Get
    Set
Visual C++
public:
property double MajorLapSpliceLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: majorLapSpliceLength is greater than the half of the overall length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


MajorSheetAlignment Property

[image]

Revit 2013 API
FabricArea..::..MajorSheetAlignment Property
FabricArea Class See Also Send Feedback
Fabric Sheet alignment in the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricSheetAlignment MajorSheetAlignment { get; }
Visual Basic
Public ReadOnly Property MajorSheetAlignment As FabricSheetAlignment
    Get
Visual C++
public:
property FabricSheetAlignment MajorSheetAlignment {
    FabricSheetAlignment get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


MinorLapSpliceLength Property

[image]

Revit 2013 API
FabricArea..::..MinorLapSpliceLength Property
FabricArea Class See Also Send Feedback
Fabric lap splice length in minor direction in the fabric distribution.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorLapSpliceLength { get; set; }
Visual Basic
Public Property MinorLapSpliceLength As Double
    Get
    Set
Visual C++
public:
property double MinorLapSpliceLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: minorLapSpliceLength is greater than the half of the overall width.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


MinorSheetAlignment Property

[image]

Revit 2013 API
FabricArea..::..MinorSheetAlignment Property
FabricArea Class See Also Send Feedback
Fabric Sheet alignment in the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricSheetAlignment MinorSheetAlignment { get; }
Visual Basic
Public ReadOnly Property MinorSheetAlignment As FabricSheetAlignment
    Get
Visual C++
public:
property FabricSheetAlignment MinorSheetAlignment {
    FabricSheetAlignment get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricArea..::..Parameter Property
FabricArea Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricArea Class
FabricArea Members
Autodesk.Revit.DB.Structure Namespace


SketchId Property

[image]

Revit 2013 API
FabricArea..::..SketchId Property
FabricArea Class See Also Send Feedback
Sketch element id

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SketchId { get; }
Visual Basic
Public ReadOnly Property SketchId As ElementId
    Get
Visual C++
public:
property ElementId^ SketchId {
    ElementId^ get ();
}

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


TagViewId Property

[image]

Revit 2013 API
FabricArea..::..TagViewId Property
FabricArea Class See Also Send Feedback
Tag new members in view

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId TagViewId { get; set; }
Visual Basic
Public Property TagViewId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ TagViewId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: tagViewId is not a valid view for tagging the FabricArea or FabricSheets.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricArea Class
Autodesk.Revit.DB.Structure Namespace


FabricAreaType Class

[image]

Revit 2013 API
FabricAreaType Class
Members See Also Send Feedback
A FabricAreaType object is used in FabricArea object generation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricAreaType : ElementType
Visual Basic
Public Class FabricAreaType _
    Inherits ElementType
Visual C++
public ref class FabricAreaType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..FabricAreaType

See Also

FabricAreaType Members
Autodesk.Revit.DB.Structure Namespace


FabricAreaType Members

[image] [image]

Revit 2013 API
FabricAreaType Members
FabricAreaType Class Methods Properties See Also Send Feedback

The FabricAreaType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricAreaType Class
Autodesk.Revit.DB.Structure Namespace


FabricAreaType Methods

[image] [image]

Revit 2013 API
FabricAreaType Methods
FabricAreaType Class See Also Send Feedback

The FabricAreaType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricAreaType Class
Autodesk.Revit.DB.Structure Namespace


FabricAreaType Properties

[image] [image]

Revit 2013 API
FabricAreaType Properties
FabricAreaType Class See Also Send Feedback

The FabricAreaType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricAreaType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricAreaType..::..Parameter Property
FabricAreaType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricAreaType Class
FabricAreaType Members
Autodesk.Revit.DB.Structure Namespace


FabricLapSplicePosition Enumeration

[image]

Revit 2013 API
FabricLapSplicePosition Enumeration
See Also Send Feedback
Fabric lap splice position in the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum FabricLapSplicePosition
Visual Basic
Public Enumeration FabricLapSplicePosition
Visual C++
public enum class FabricLapSplicePosition

Members

Member name | Description
Aligned | The fabric sheets are aligned.
HalfwayStagger | Every second fabric sheet is shifted half way.
PassingStagger | Every second fabric sheet is shifted half way and reversed.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricLocation Enumeration

[image]

Revit 2013 API
FabricLocation Enumeration
See Also Send Feedback
Fabric location in the host

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum FabricLocation
Visual Basic
Public Enumeration FabricLocation
Visual C++
public enum class FabricLocation

Members

Member name | Description
TopOrExternal | The fabric is on the top face of a floor host, or on the external face of a wall host.
BottomOrInternal | The fabric is on the bottom face of a floor host, or on the internal face of a wall host.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricReinSpanSymbol Class

[image]

Revit 2013 API
FabricReinSpanSymbol Class
Members See Also Send Feedback
Represents a FabricSheet Span Symbol element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricReinSpanSymbol : IndependentTag
Visual Basic
Public Class FabricReinSpanSymbol _
    Inherits IndependentTag
Visual C++
public ref class FabricReinSpanSymbol : public IndependentTag

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..IndependentTag
Autodesk.Revit.DB.Structure..::..FabricReinSpanSymbol

See Also

FabricReinSpanSymbol Members
Autodesk.Revit.DB.Structure Namespace


FabricReinSpanSymbol Members

[image] [image]

Revit 2013 API
FabricReinSpanSymbol Members
FabricReinSpanSymbol Class Methods Properties See Also Send Feedback

The FabricReinSpanSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be assigned. (Inherited from IndependentTag.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of FabricReinSpanSymbol in the project
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTaggedLocalElement | Get the tagged local element if any. (Inherited from IndependentTag.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Whether the tag has a leader or not. (Inherited from IndependentTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not. (Inherited from IndependentTag.)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not. (Inherited from IndependentTag.)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from IndependentTag.)
Public property | LeaderElbow | Returns the position of the elbow of leader. (Inherited from IndependentTag.)
Public property | LeaderEnd | Returns the position of the end of leader. (Inherited from IndependentTag.)
Public property | LeaderEndCondition | The leader end condition of the tag. (Inherited from IndependentTag.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TaggedElementId | The LinkElementId of the tagged element. (Inherited from IndependentTag.)
Public property | TaggedLocalElementId | The id of the tagged local element if any. (Inherited from IndependentTag.)
Public property | TagHeadPosition | Returns the position of the head of tag. (Inherited from IndependentTag.)
Public property | TagOrientation | The tag orientation of the tag. (Inherited from IndependentTag.)
Public property | TagText | Returns the text of the Tag. (Inherited from IndependentTag.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricReinSpanSymbol Class
Autodesk.Revit.DB.Structure Namespace


FabricReinSpanSymbol Methods

[image] [image]

Revit 2013 API
FabricReinSpanSymbol Methods
FabricReinSpanSymbol Class See Also Send Feedback

The FabricReinSpanSymbol type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | CanLeaderEndConditionBeAssigned | Checks whether the LeaderEndCondition can be assigned. (Inherited from IndependentTag.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new instance of FabricReinSpanSymbol in the project
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTaggedLocalElement | Get the tagged local element if any. (Inherited from IndependentTag.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricReinSpanSymbol Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
FabricReinSpanSymbol..::..Create Method
FabricReinSpanSymbol Class See Also Send Feedback
Creates a new instance of FabricReinSpanSymbol in the project

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static FabricReinSpanSymbol Create(
    Document doc,
    ElementId viewId,
    LinkElementId hostId,
    XYZ point,
    ElementId symbolId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    viewId As ElementId, _
    hostId As LinkElementId, _
    point As XYZ, _
    symbolId As ElementId _
) As FabricReinSpanSymbol
Visual C++
public:
static FabricReinSpanSymbol^ Create(
    Document^ doc,
    ElementId^ viewId,
    LinkElementId^ hostId,
    XYZ^ point,
    ElementId^ symbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The id of the view in which the symbol should appear
hostId
Type: Autodesk.Revit.DB..::..LinkElementId
The id of the FabricSheet host (either in the document, or linked from another document)
point
Type: Autodesk.Revit.DB..::..XYZ
The span symbol's head position
symbolId
Type: Autodesk.Revit.DB..::..ElementId
The id of the family symbol of this symbol

Return Value

A reference to the newly-created symbol.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricReinSpanSymbol Class
Autodesk.Revit.DB.Structure Namespace


FabricReinSpanSymbol Properties

[image] [image]

Revit 2013 API
FabricReinSpanSymbol Properties
FabricReinSpanSymbol Class See Also Send Feedback

The FabricReinSpanSymbol type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HasLeader | Whether the tag has a leader or not. (Inherited from IndependentTag.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IsMaterialTag | Identifies if it is a material tag or not. (Inherited from IndependentTag.)
Public property | IsMulticategoryTag | Identifies if it is a multi-category tag or not. (Inherited from IndependentTag.)
Public property | IsOrphaned | Identifies if the tag is orphaned or not. (Inherited from IndependentTag.)
Public property | LeaderElbow | Returns the position of the elbow of leader. (Inherited from IndependentTag.)
Public property | LeaderEnd | Returns the position of the end of leader. (Inherited from IndependentTag.)
Public property | LeaderEndCondition | The leader end condition of the tag. (Inherited from IndependentTag.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TaggedElementId | The LinkElementId of the tagged element. (Inherited from IndependentTag.)
Public property | TaggedLocalElementId | The id of the tagged local element if any. (Inherited from IndependentTag.)
Public property | TagHeadPosition | Returns the position of the head of tag. (Inherited from IndependentTag.)
Public property | TagOrientation | The tag orientation of the tag. (Inherited from IndependentTag.)
Public property | TagText | Returns the text of the Tag. (Inherited from IndependentTag.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricReinSpanSymbol Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricReinSpanSymbol..::..Parameter Property
FabricReinSpanSymbol Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricReinSpanSymbol Class
FabricReinSpanSymbol Members
Autodesk.Revit.DB.Structure Namespace


FabricSheet Class

[image]

Revit 2013 API
FabricSheet Class
Members See Also Send Feedback
An object that represents an Fabric Sheet Element within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricSheet : Element
Visual Basic
Public Class FabricSheet _
    Inherits Element
Visual C++
public ref class FabricSheet : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Fabric Sheet element is available only in the Autodesk Revit Structure product.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..FabricSheet

See Also

FabricSheet Members
Autodesk.Revit.DB.Structure Namespace


FabricSheet Members

[image] [image]

Revit 2013 API
FabricSheet Members
FabricSheet Class Methods Properties See Also Send Feedback

The FabricSheet type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetWireCenterlines()()()() | A list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.
Public method | GetWireCenterlines(WireDistributionDirection) | A list of curves representing the wires centerlines of the Fabric Sheet.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutOverallLength | Sheet Length after cutting
Public property | CutOverallWidth | Sheet Width after cutting
Public property | CutSheetMass | Gets the sheet mass after cutting
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FabricAreaOwnerId | Fabric Area (Region Element) Id.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetTypeId | Fabric Sheet Type Id.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


FabricSheet Methods

[image] [image]

Revit 2013 API
FabricSheet Methods
FabricSheet Class See Also Send Feedback

The FabricSheet type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | GetWireCenterlines()()()() | A list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.
Public method | GetWireCenterlines(WireDistributionDirection) | A list of curves representing the wires centerlines of the Fabric Sheet.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


GetWireCenterlines Method

[image] [image]

Revit 2013 API
FabricSheet..::..GetWireCenterlines Method
FabricSheet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetWireCenterlines()()()() | A list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.
Public method | GetWireCenterlines(WireDistributionDirection) | A list of curves representing the wires centerlines of the Fabric Sheet.

See Also

FabricSheet Class
FabricSheet Members
Autodesk.Revit.DB.Structure Namespace


GetWireCenterlines Method

[image]

Revit 2013 API
FabricSheet..::..GetWireCenterlines Method
FabricSheet Class See Also Send Feedback
A list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetWireCenterlines()
Visual Basic
Public Function GetWireCenterlines As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetWireCenterlines()

Return Value

The centerline curves or empty array if the curves cannot be computed.

See Also

FabricSheet Class
GetWireCenterlines Overload
Autodesk.Revit.DB.Structure Namespace


GetWireCenterlines Method (WireDistributionDirection)

[image]

Revit 2013 API
FabricSheet..::..GetWireCenterlines Method (WireDistributionDirection)
FabricSheet Class See Also Send Feedback
A list of curves representing the wires centerlines of the Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetWireCenterlines(
    WireDistributionDirection wireDirection
)
Visual Basic
Public Function GetWireCenterlines ( _
    wireDirection As WireDistributionDirection _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetWireCenterlines(
    WireDistributionDirection wireDirection
)

Parameters

wireDirection
Type: Autodesk.Revit.DB.Structure..::..WireDistributionDirection
Direction of wire distribution in the Fabric Sheet.

Return Value

The centerline curves or empty array if the curves cannot be computed.

See Also

FabricSheet Class
GetWireCenterlines Overload
Autodesk.Revit.DB.Structure Namespace


FabricSheet Properties

[image] [image]

Revit 2013 API
FabricSheet Properties
FabricSheet Class See Also Send Feedback

The FabricSheet type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | CutOverallLength | Sheet Length after cutting
Public property | CutOverallWidth | Sheet Width after cutting
Public property | CutSheetMass | Gets the sheet mass after cutting
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | FabricAreaOwnerId | Fabric Area (Region Element) Id.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetTypeId | Fabric Sheet Type Id.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


CutOverallLength Property

[image]

Revit 2013 API
FabricSheet..::..CutOverallLength Property
FabricSheet Class See Also Send Feedback
Sheet Length after cutting

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutOverallLength { get; }
Visual Basic
Public ReadOnly Property CutOverallLength As Double
    Get
Visual C++
public:
property double CutOverallLength {
    double get ();
}

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


CutOverallWidth Property

[image]

Revit 2013 API
FabricSheet..::..CutOverallWidth Property
FabricSheet Class See Also Send Feedback
Sheet Width after cutting

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutOverallWidth { get; }
Visual Basic
Public ReadOnly Property CutOverallWidth As Double
    Get
Visual C++
public:
property double CutOverallWidth {
    double get ();
}

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


CutSheetMass Property

[image]

Revit 2013 API
FabricSheet..::..CutSheetMass Property
FabricSheet Class See Also Send Feedback
Gets the sheet mass after cutting

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double CutSheetMass { get; }
Visual Basic
Public ReadOnly Property CutSheetMass As Double
    Get
Visual C++
public:
property double CutSheetMass {
    double get ();
}

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


FabricAreaOwnerId Property

[image]

Revit 2013 API
FabricSheet..::..FabricAreaOwnerId Property
FabricSheet Class See Also Send Feedback
Fabric Area (Region Element) Id.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId FabricAreaOwnerId { get; }
Visual Basic
Public ReadOnly Property FabricAreaOwnerId As ElementId
    Get
Visual C++
public:
property ElementId^ FabricAreaOwnerId {
    ElementId^ get ();
}

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricSheet..::..Parameter Property
FabricSheet Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricSheet Class
FabricSheet Members
Autodesk.Revit.DB.Structure Namespace


SheetTypeId Property

[image]

Revit 2013 API
FabricSheet..::..SheetTypeId Property
FabricSheet Class See Also Send Feedback
Fabric Sheet Type Id.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SheetTypeId { get; }
Visual Basic
Public ReadOnly Property SheetTypeId As ElementId
    Get
Visual C++
public:
property ElementId^ SheetTypeId {
    ElementId^ get ();
}

See Also

FabricSheet Class
Autodesk.Revit.DB.Structure Namespace


FabricSheetAlignment Enumeration

[image]

Revit 2013 API
FabricSheetAlignment Enumeration
See Also Send Feedback
Fabric Sheet alignment in the fabric distribution

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013
Since: 2013

Syntax

C#
public enum FabricSheetAlignment
Visual Basic
Public Enumeration FabricSheetAlignment
Visual C++
public enum class FabricSheetAlignment

Members

Member name | Description
Null | The fabric sheets are alignment is not set.
StartingEdge | The fabric sheets are aligned to starting edge.
EndingEdge | The fabric sheets are aligned to ending edge.
BothEdges | The fabric sheets are aligned to starting and ending edge.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricSheetLayoutPattern Enumeration

[image]

Revit 2013 API
FabricSheetLayoutPattern Enumeration
See Also Send Feedback
The pattern for how the wires in Fabric Sheet are laid out.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FabricSheetLayoutPattern
Visual Basic
Public Enumeration FabricSheetLayoutPattern
Visual C++
public enum class FabricSheetLayoutPattern

Members

Member name | Description
ActualSpacing | The spacing between the rebars is fixed and specified by input.
FixedNumber | The spacing between the rebars is adjustable, but the number of bars is constant based on input.
MaximumSpacing | The maximum distance between the rebars is specified by input, and the number of rebars changes based on the length of rebar set.
NumberWithSpacing | Both the spacing between the rebars and the number of rebars are constant based on input.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricSheetType Class

[image]

Revit 2013 API
FabricSheetType Class
Members See Also Send Feedback
A Fabric Sheet Type object that is used in the generation of Fabric Wire.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricSheetType : ElementType
Visual Basic
Public Class FabricSheetType _
    Inherits ElementType
Visual C++
public ref class FabricSheetType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..FabricSheetType

See Also

FabricSheetType Members
Autodesk.Revit.DB.Structure Namespace


FabricSheetType Members

[image] [image]

Revit 2013 API
FabricSheetType Members
FabricSheetType Class Methods Properties See Also Send Feedback

The FabricSheetType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidFabricWireType | Verifies that input is ElementId of a FabricWireType
Public method | IsValidMajorLapSplice |
Public method | IsValidMaterial | Verifies that input is ElementId of a Material
Public method | IsValidMinorLapSplice |
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMajorLayoutAsActualSpacing | Set Major Layout Pattern as Actual Spacing.
Public method | SetMajorLayoutAsFixedNumber | Set Major Layout Pattern as Fixed Number.
Public method | SetMajorLayoutAsMaximumSpacing | Set Major Layout Pattern as Maximum Spacing.
Public method | SetMajorLayoutAsNumberWithSpacing | Set Major Layout Pattern as Number with Spacing.
Public method | SetMinorLayoutAsActualSpacing | Set Minor Layout Pattern as Actual Spacing.
Public method | SetMinorLayoutAsFixedNumber | Set Minor Layout Pattern as Fixed Number.
Public method | SetMinorLayoutAsMaximumSpacing | Set Minor Layout Pattern as Maximum Spacing.
Public method | SetMinorLayoutAsNumberWithSpacing | Set Minor Layout Pattern as Number with Spacing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorDirectionWireType | Determines which "Fabric Wire" type will be used in the major direction.
Public property | MajorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the major direction).
Public property | MajorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MajorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MajorNumberOfWires | Determines the number of wires used in the major direction (includes the 1st and last wires).
Public property | MajorReinforcementArea | Area of fabric divided by the spacing of the wire.
Public property | MajorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MajorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).
Public property | Material | Defines wire material ElementId of the Fabric Sheet
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorDirectionWireType | Determines which "Fabric Wire" type will be used in the minor direction.
Public property | MinorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).
Public property | MinorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MinorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MinorNumberOfWires | Determines the number of wires used in the minor direction (includes the 1st and last wires).
Public property | MinorReinforcementArea | Area of Wire / Spacing of Wire.
Public property | MinorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MinorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OverallLength | Determines the length of the wire sheet (including overhangs) in the major direction.
Public property | OverallWidth | Determines the length of the wire sheet (including overhangs) in the minor direction.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | PhysicalMaterialAsset | Defines Physical Material Asset.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetMass | Defines sheet mass.
Public property | SheetMassUnit | Defines sheet mass per area unit.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


FabricSheetType Methods

[image] [image]

Revit 2013 API
FabricSheetType Methods
FabricSheetType Class See Also Send Feedback

The FabricSheetType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidFabricWireType | Verifies that input is ElementId of a FabricWireType
Public method | IsValidMajorLapSplice |
Public method | IsValidMaterial | Verifies that input is ElementId of a Material
Public method | IsValidMinorLapSplice |
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetMajorLayoutAsActualSpacing | Set Major Layout Pattern as Actual Spacing.
Public method | SetMajorLayoutAsFixedNumber | Set Major Layout Pattern as Fixed Number.
Public method | SetMajorLayoutAsMaximumSpacing | Set Major Layout Pattern as Maximum Spacing.
Public method | SetMajorLayoutAsNumberWithSpacing | Set Major Layout Pattern as Number with Spacing.
Public method | SetMinorLayoutAsActualSpacing | Set Minor Layout Pattern as Actual Spacing.
Public method | SetMinorLayoutAsFixedNumber | Set Minor Layout Pattern as Fixed Number.
Public method | SetMinorLayoutAsMaximumSpacing | Set Minor Layout Pattern as Maximum Spacing.
Public method | SetMinorLayoutAsNumberWithSpacing | Set Minor Layout Pattern as Number with Spacing.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


IsValidFabricWireType Method

[image]

Revit 2013 API
FabricSheetType..::..IsValidFabricWireType Method
FabricSheetType Class See Also Send Feedback
Verifies that input is ElementId of a FabricWireType

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidFabricWireType(
    ElementId elemId
)
Visual Basic
Public Function IsValidFabricWireType ( _
    elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidFabricWireType(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of expected FabricWireType

Return Value

True if ElementId is of a FabricWireType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


IsValidMajorLapSplice Method

[image]

Revit 2013 API
FabricSheetType..::..IsValidMajorLapSplice Method
FabricSheetType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMajorLapSplice(
    double majorLapSplice
)
Visual Basic
Public Function IsValidMajorLapSplice ( _
    majorLapSplice As Double _
) As Boolean
Visual C++
public:
bool IsValidMajorLapSplice(
    double majorLapSplice
)

Parameters

majorLapSplice
Type: System..::..Double

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


IsValidMaterial Method

[image]

Revit 2013 API
FabricSheetType..::..IsValidMaterial Method
FabricSheetType Class See Also Send Feedback
Verifies that input is ElementId of a Material

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMaterial(
    ElementId elemId
)
Visual Basic
Public Function IsValidMaterial ( _
    elemId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidMaterial(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
ElementId of expected Material

Return Value

True if ElementId is of a Material

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


IsValidMinorLapSplice Method

[image]

Revit 2013 API
FabricSheetType..::..IsValidMinorLapSplice Method
FabricSheetType Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsValidMinorLapSplice(
    double minorLapSplice
)
Visual Basic
Public Function IsValidMinorLapSplice ( _
    minorLapSplice As Double _
) As Boolean
Visual C++
public:
bool IsValidMinorLapSplice(
    double minorLapSplice
)

Parameters

minorLapSplice
Type: System..::..Double

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMajorLayoutAsActualSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMajorLayoutAsActualSpacing Method
FabricSheetType Class See Also Send Feedback
Set Major Layout Pattern as Actual Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorLayoutAsActualSpacing(
    double overallWidth,
    double minorStartOverhang,
    double spacing
)
Visual Basic
Public Sub SetMajorLayoutAsActualSpacing ( _
    overallWidth As Double, _
    minorStartOverhang As Double, _
    spacing As Double _
)
Visual C++
public:
void SetMajorLayoutAsActualSpacing(
    double overallWidth,
    double minorStartOverhang,
    double spacing
)

Parameters

overallWidth
Type: System..::..Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the minor direction.
spacing
Type: System..::..Double
Distance between the wires in the major direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMajorLayoutAsFixedNumber Method

[image]

Revit 2013 API
FabricSheetType..::..SetMajorLayoutAsFixedNumber Method
FabricSheetType Class See Also Send Feedback
Set Major Layout Pattern as Fixed Number.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorLayoutAsFixedNumber(
    double overallWidth,
    double minorStartOverhang,
    double minorEndOverhang,
    int numberOfWires
)
Visual Basic
Public Sub SetMajorLayoutAsFixedNumber ( _
    overallWidth As Double, _
    minorStartOverhang As Double, _
    minorEndOverhang As Double, _
    numberOfWires As Integer _
)
Visual C++
public:
void SetMajorLayoutAsFixedNumber(
    double overallWidth,
    double minorStartOverhang,
    double minorEndOverhang,
    int numberOfWires
)

Parameters

overallWidth
Type: System..::..Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the minor direction.
minorEndOverhang
Type: System..::..Double
Distance from the last wire to the edge of the sheet in the minor direction.
numberOfWires
Type: System..::..Int32
Number of the wires to set in the major direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for minorEndOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for minorEndOverhang must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMajorLayoutAsMaximumSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMajorLayoutAsMaximumSpacing Method
FabricSheetType Class See Also Send Feedback
Set Major Layout Pattern as Maximum Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorLayoutAsMaximumSpacing(
    double overallWidth,
    double minorStartOverhang,
    double minorEndOverhang,
    double spacing
)
Visual Basic
Public Sub SetMajorLayoutAsMaximumSpacing ( _
    overallWidth As Double, _
    minorStartOverhang As Double, _
    minorEndOverhang As Double, _
    spacing As Double _
)
Visual C++
public:
void SetMajorLayoutAsMaximumSpacing(
    double overallWidth,
    double minorStartOverhang,
    double minorEndOverhang,
    double spacing
)

Parameters

overallWidth
Type: System..::..Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the minor direction.
minorEndOverhang
Type: System..::..Double
Distance from the last wire to the edge of the sheet in the minor direction.
spacing
Type: System..::..Double
Distance between the wires in the major direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for minorEndOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for minorEndOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMajorLayoutAsNumberWithSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMajorLayoutAsNumberWithSpacing Method
FabricSheetType Class See Also Send Feedback
Set Major Layout Pattern as Number with Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMajorLayoutAsNumberWithSpacing(
    double overallWidth,
    double minorStartOverhang,
    int numberOfWires,
    double spacing
)
Visual Basic
Public Sub SetMajorLayoutAsNumberWithSpacing ( _
    overallWidth As Double, _
    minorStartOverhang As Double, _
    numberOfWires As Integer, _
    spacing As Double _
)
Visual C++
public:
void SetMajorLayoutAsNumberWithSpacing(
    double overallWidth,
    double minorStartOverhang,
    int numberOfWires,
    double spacing
)

Parameters

overallWidth
Type: System..::..Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the minor direction.
numberOfWires
Type: System..::..Int32
Number of the wires to set in the major direction.
spacing
Type: System..::..Double
Distance between the wires in the major direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMinorLayoutAsActualSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMinorLayoutAsActualSpacing Method
FabricSheetType Class See Also Send Feedback
Set Minor Layout Pattern as Actual Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorLayoutAsActualSpacing(
    double overallLength,
    double majorStartOverhang,
    double spacing
)
Visual Basic
Public Sub SetMinorLayoutAsActualSpacing ( _
    overallLength As Double, _
    majorStartOverhang As Double, _
    spacing As Double _
)
Visual C++
public:
void SetMinorLayoutAsActualSpacing(
    double overallLength,
    double majorStartOverhang,
    double spacing
)

Parameters

overallLength
Type: System..::..Double
The entire length of the wire sheet in the major direction.
majorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the major direction.
spacing
Type: System..::..Double
Distance between the wires in the minor direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMinorLayoutAsFixedNumber Method

[image]

Revit 2013 API
FabricSheetType..::..SetMinorLayoutAsFixedNumber Method
FabricSheetType Class See Also Send Feedback
Set Minor Layout Pattern as Fixed Number.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorLayoutAsFixedNumber(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    int numberOfWires
)
Visual Basic
Public Sub SetMinorLayoutAsFixedNumber ( _
    overallLength As Double, _
    majorStartOverhang As Double, _
    majorEndOverhang As Double, _
    numberOfWires As Integer _
)
Visual C++
public:
void SetMinorLayoutAsFixedNumber(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    int numberOfWires
)

Parameters

overallLength
Type: System..::..Double
The entire length of the wire sheet in the major direction.
majorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the major direction.
majorEndOverhang
Type: System..::..Double
Distance from the last wire to the edge of the sheet in the major direction.
numberOfWires
Type: System..::..Int32
Number of the wires to set in the minor direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMinorLayoutAsMaximumSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMinorLayoutAsMaximumSpacing Method
FabricSheetType Class See Also Send Feedback
Set Minor Layout Pattern as Maximum Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorLayoutAsMaximumSpacing(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    double spacing
)
Visual Basic
Public Sub SetMinorLayoutAsMaximumSpacing ( _
    overallLength As Double, _
    majorStartOverhang As Double, _
    majorEndOverhang As Double, _
    spacing As Double _
)
Visual C++
public:
void SetMinorLayoutAsMaximumSpacing(
    double overallLength,
    double majorStartOverhang,
    double majorEndOverhang,
    double spacing
)

Parameters

overallLength
Type: System..::..Double
The entire length of the wire sheet in the major direction.
majorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the major direction.
majorEndOverhang
Type: System..::..Double
Distance from the last wire to the edge of the sheet in the major direction.
spacing
Type: System..::..Double
Distance between the wires in the minor direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- The given value for majorEndOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for majorEndOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SetMinorLayoutAsNumberWithSpacing Method

[image]

Revit 2013 API
FabricSheetType..::..SetMinorLayoutAsNumberWithSpacing Method
FabricSheetType Class See Also Send Feedback
Set Minor Layout Pattern as Number with Spacing.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetMinorLayoutAsNumberWithSpacing(
    double overallLength,
    double majorStartOverhang,
    int numberOfWires,
    double spacing
)
Visual Basic
Public Sub SetMinorLayoutAsNumberWithSpacing ( _
    overallLength As Double, _
    majorStartOverhang As Double, _
    numberOfWires As Integer, _
    spacing As Double _
)
Visual C++
public:
void SetMinorLayoutAsNumberWithSpacing(
    double overallLength,
    double majorStartOverhang,
    int numberOfWires,
    double spacing
)

Parameters

overallLength
Type: System..::..Double
The entire length of the wire sheet in the major direction.
majorStartOverhang
Type: System..::..Double
Distance from the edge of the sheet to the first wire in the major direction.
numberOfWires
Type: System..::..Int32
Number of wires in the minor direction.
spacing
Type: System..::..Double
Distance between the wires in the minor direction.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for overallLength is not a number -or- The given value for majorStartOverhang is not a number -or- numberOfWires must range from 2 to 1000000. -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for overallLength must be greater than 0 and no more than 30000 feet. -or- The given value for majorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


FabricSheetType Properties

[image] [image]

Revit 2013 API
FabricSheetType Properties
FabricSheetType Class See Also Send Feedback

The FabricSheetType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | MajorDirectionWireType | Determines which "Fabric Wire" type will be used in the major direction.
Public property | MajorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the major direction).
Public property | MajorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MajorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MajorNumberOfWires | Determines the number of wires used in the major direction (includes the 1st and last wires).
Public property | MajorReinforcementArea | Area of fabric divided by the spacing of the wire.
Public property | MajorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MajorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).
Public property | Material | Defines wire material ElementId of the Fabric Sheet
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MinorDirectionWireType | Determines which "Fabric Wire" type will be used in the minor direction.
Public property | MinorEndOverhang | Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).
Public property | MinorLapSpliceLength | Defines the internal snapping for single fabric placement.
Public property | MinorLayoutPattern | Identifies the layout pattern of Fabric Sheet.
Public property | MinorNumberOfWires | Determines the number of wires used in the minor direction (includes the 1st and last wires).
Public property | MinorReinforcementArea | Area of Wire / Spacing of Wire.
Public property | MinorSpacing | Determines the spacing between the wires (not including the overhangs).
Public property | MinorStartOverhang | Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OverallLength | Determines the length of the wire sheet (including overhangs) in the major direction.
Public property | OverallWidth | Determines the length of the wire sheet (including overhangs) in the minor direction.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | PhysicalMaterialAsset | Defines Physical Material Asset.
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | SheetMass | Defines sheet mass.
Public property | SheetMassUnit | Defines sheet mass per area unit.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorDirectionWireType Property

[image]

Revit 2013 API
FabricSheetType..::..MajorDirectionWireType Property
FabricSheetType Class See Also Send Feedback
Determines which "Fabric Wire" type will be used in the major direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MajorDirectionWireType { get; set; }
Visual Basic
Public Property MajorDirectionWireType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MajorDirectionWireType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the ElementId majorDirectionWireType is either invalid or not a FabricWireType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorEndOverhang Property

[image]

Revit 2013 API
FabricSheetType..::..MajorEndOverhang Property
FabricSheetType Class See Also Send Feedback
Determines the distance from the edge of the sheet to the last wire (measured in the major direction).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorEndOverhang { get; }
Visual Basic
Public ReadOnly Property MajorEndOverhang As Double
    Get
Visual C++
public:
property double MajorEndOverhang {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorLapSpliceLength Property

[image]

Revit 2013 API
FabricSheetType..::..MajorLapSpliceLength Property
FabricSheetType Class See Also Send Feedback
Defines the internal snapping for single fabric placement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorLapSpliceLength { get; set; }
Visual Basic
Public Property MajorLapSpliceLength As Double
    Get
    Set
Visual C++
public:
property double MajorLapSpliceLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: majorLapSpliceLength is greater than the half of the overall length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorLayoutPattern Property

[image]

Revit 2013 API
FabricSheetType..::..MajorLayoutPattern Property
FabricSheetType Class See Also Send Feedback
Identifies the layout pattern of Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricSheetLayoutPattern MajorLayoutPattern { get; }
Visual Basic
Public ReadOnly Property MajorLayoutPattern As FabricSheetLayoutPattern
    Get
Visual C++
public:
property FabricSheetLayoutPattern MajorLayoutPattern {
    FabricSheetLayoutPattern get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorNumberOfWires Property

[image]

Revit 2013 API
FabricSheetType..::..MajorNumberOfWires Property
FabricSheetType Class See Also Send Feedback
Determines the number of wires used in the major direction (includes the 1st and last wires).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MajorNumberOfWires { get; }
Visual Basic
Public ReadOnly Property MajorNumberOfWires As Integer
    Get
Visual C++
public:
property int MajorNumberOfWires {
    int get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorReinforcementArea Property

[image]

Revit 2013 API
FabricSheetType..::..MajorReinforcementArea Property
FabricSheetType Class See Also Send Feedback
Area of fabric divided by the spacing of the wire.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorReinforcementArea { get; }
Visual Basic
Public ReadOnly Property MajorReinforcementArea As Double
    Get
Visual C++
public:
property double MajorReinforcementArea {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorSpacing Property

[image]

Revit 2013 API
FabricSheetType..::..MajorSpacing Property
FabricSheetType Class See Also Send Feedback
Determines the spacing between the wires (not including the overhangs).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorSpacing { get; }
Visual Basic
Public ReadOnly Property MajorSpacing As Double
    Get
Visual C++
public:
property double MajorSpacing {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MajorStartOverhang Property

[image]

Revit 2013 API
FabricSheetType..::..MajorStartOverhang Property
FabricSheetType Class See Also Send Feedback
Determines the distance from the edge of the sheet to the 1st wire (measured in the major direction).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MajorStartOverhang { get; }
Visual Basic
Public ReadOnly Property MajorStartOverhang As Double
    Get
Visual C++
public:
property double MajorStartOverhang {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


Material Property

[image]

Revit 2013 API
FabricSheetType..::..Material Property
FabricSheetType Class See Also Send Feedback
Defines wire material ElementId of the Fabric Sheet

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId Material { get; set; }
Visual Basic
Public Property Material As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ Material {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorDirectionWireType Property

[image]

Revit 2013 API
FabricSheetType..::..MinorDirectionWireType Property
FabricSheetType Class See Also Send Feedback
Determines which "Fabric Wire" type will be used in the minor direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId MinorDirectionWireType { get; set; }
Visual Basic
Public Property MinorDirectionWireType As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ MinorDirectionWireType {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: the ElementId minorDirectionWireType is either invalid or not a FabricWireType.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorEndOverhang Property

[image]

Revit 2013 API
FabricSheetType..::..MinorEndOverhang Property
FabricSheetType Class See Also Send Feedback
Determines the distance from the edge of the sheet to the last wire (measured in the minor direction).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorEndOverhang { get; }
Visual Basic
Public ReadOnly Property MinorEndOverhang As Double
    Get
Visual C++
public:
property double MinorEndOverhang {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorLapSpliceLength Property

[image]

Revit 2013 API
FabricSheetType..::..MinorLapSpliceLength Property
FabricSheetType Class See Also Send Feedback
Defines the internal snapping for single fabric placement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorLapSpliceLength { get; set; }
Visual Basic
Public Property MinorLapSpliceLength As Double
    Get
    Set
Visual C++
public:
property double MinorLapSpliceLength {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: minorLapSpliceLength is greater than the half of the overall width.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorLayoutPattern Property

[image]

Revit 2013 API
FabricSheetType..::..MinorLayoutPattern Property
FabricSheetType Class See Also Send Feedback
Identifies the layout pattern of Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public FabricSheetLayoutPattern MinorLayoutPattern { get; }
Visual Basic
Public ReadOnly Property MinorLayoutPattern As FabricSheetLayoutPattern
    Get
Visual C++
public:
property FabricSheetLayoutPattern MinorLayoutPattern {
    FabricSheetLayoutPattern get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorNumberOfWires Property

[image]

Revit 2013 API
FabricSheetType..::..MinorNumberOfWires Property
FabricSheetType Class See Also Send Feedback
Determines the number of wires used in the minor direction (includes the 1st and last wires).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int MinorNumberOfWires { get; }
Visual Basic
Public ReadOnly Property MinorNumberOfWires As Integer
    Get
Visual C++
public:
property int MinorNumberOfWires {
    int get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorReinforcementArea Property

[image]

Revit 2013 API
FabricSheetType..::..MinorReinforcementArea Property
FabricSheetType Class See Also Send Feedback
Area of Wire / Spacing of Wire.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorReinforcementArea { get; }
Visual Basic
Public ReadOnly Property MinorReinforcementArea As Double
    Get
Visual C++
public:
property double MinorReinforcementArea {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorSpacing Property

[image]

Revit 2013 API
FabricSheetType..::..MinorSpacing Property
FabricSheetType Class See Also Send Feedback
Determines the spacing between the wires (not including the overhangs).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorSpacing { get; }
Visual Basic
Public ReadOnly Property MinorSpacing As Double
    Get
Visual C++
public:
property double MinorSpacing {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


MinorStartOverhang Property

[image]

Revit 2013 API
FabricSheetType..::..MinorStartOverhang Property
FabricSheetType Class See Also Send Feedback
Determines the distance from the edge of the sheet to the 1st wire (measured in the minor direction).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MinorStartOverhang { get; }
Visual Basic
Public ReadOnly Property MinorStartOverhang As Double
    Get
Visual C++
public:
property double MinorStartOverhang {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


OverallLength Property

[image]

Revit 2013 API
FabricSheetType..::..OverallLength Property
FabricSheetType Class See Also Send Feedback
Determines the length of the wire sheet (including overhangs) in the major direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double OverallLength { get; }
Visual Basic
Public ReadOnly Property OverallLength As Double
    Get
Visual C++
public:
property double OverallLength {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


OverallWidth Property

[image]

Revit 2013 API
FabricSheetType..::..OverallWidth Property
FabricSheetType Class See Also Send Feedback
Determines the length of the wire sheet (including overhangs) in the minor direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double OverallWidth { get; }
Visual Basic
Public ReadOnly Property OverallWidth As Double
    Get
Visual C++
public:
property double OverallWidth {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricSheetType..::..Parameter Property
FabricSheetType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricSheetType Class
FabricSheetType Members
Autodesk.Revit.DB.Structure Namespace


PhysicalMaterialAsset Property

[image]

Revit 2013 API
FabricSheetType..::..PhysicalMaterialAsset Property
FabricSheetType Class See Also Send Feedback
Defines Physical Material Asset.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string PhysicalMaterialAsset { get; }
Visual Basic
Public ReadOnly Property PhysicalMaterialAsset As String
    Get
Visual C++
public:
property String^ PhysicalMaterialAsset {
    String^ get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SheetMass Property

[image]

Revit 2013 API
FabricSheetType..::..SheetMass Property
FabricSheetType Class See Also Send Feedback
Defines sheet mass.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SheetMass { get; set; }
Visual Basic
Public Property SheetMass As Double
    Get
    Set
Visual C++
public:
property double SheetMass {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for sheetMass is not a number
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for sheetMass must be non-negative.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


SheetMassUnit Property

[image]

Revit 2013 API
FabricSheetType..::..SheetMassUnit Property
FabricSheetType Class See Also Send Feedback
Defines sheet mass per area unit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double SheetMassUnit { get; }
Visual Basic
Public ReadOnly Property SheetMassUnit As Double
    Get
Visual C++
public:
property double SheetMassUnit {
    double get ();
}

See Also

FabricSheetType Class
Autodesk.Revit.DB.Structure Namespace


FabricTagComponentReference Enumeration

[image]

Revit 2013 API
FabricTagComponentReference Enumeration
See Also Send Feedback
How FabricSheet tag text will be aligned to the FabricSheet symbol.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum FabricTagComponentReference
Visual Basic
Public Enumeration FabricTagComponentReference
Visual C++
public enum class FabricTagComponentReference

Members

Member name | Description
MajorAxis | Tag and Leader will reference the symbol major direction axis.
MinorAxis | Tag and Leader will reference the symbol minor direction axis.
Diagonal | Tag and Leader will reference the symbol diagonal.
Intersection | Tag and Leader will reference the intersection of the major and minor axes.

See Also

Autodesk.Revit.DB.Structure Namespace


FabricWireType Class

[image]

Revit 2013 API
FabricWireType Class
Members See Also Send Feedback
A Fabric Wire Type object that is used in the generation of Fabric Wire.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class FabricWireType : ElementType
Visual Basic
Public Class FabricWireType _
    Inherits ElementType
Visual C++
public ref class FabricWireType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..FabricWireType

See Also

FabricWireType Members
Autodesk.Revit.DB.Structure Namespace


FabricWireType Members

[image] [image]

Revit 2013 API
FabricWireType Members
FabricWireType Class Methods Properties See Also Send Feedback

The FabricWireType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireDiameter | Determines the diameter of the wire. This should be positive lesser than 1.0.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricWireType Class
Autodesk.Revit.DB.Structure Namespace


FabricWireType Methods

[image] [image]

Revit 2013 API
FabricWireType Methods
FabricWireType Class See Also Send Feedback

The FabricWireType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FabricWireType Class
Autodesk.Revit.DB.Structure Namespace


FabricWireType Properties

[image] [image]

Revit 2013 API
FabricWireType Properties
FabricWireType Class See Also Send Feedback

The FabricWireType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WireDiameter | Determines the diameter of the wire. This should be positive lesser than 1.0.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

FabricWireType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
FabricWireType..::..Parameter Property
FabricWireType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

FabricWireType Class
FabricWireType Members
Autodesk.Revit.DB.Structure Namespace


WireDiameter Property

[image]

Revit 2013 API
FabricWireType..::..WireDiameter Property
FabricWireType Class See Also Send Feedback
Determines the diameter of the wire. This should be positive lesser than 1.0.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double WireDiameter { get; set; }
Visual Basic
Public Property WireDiameter As Double
    Get
    Set
Visual C++
public:
property double WireDiameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The given value for wireDiameter is not a number
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The wire diameter wireDiameter is negative or greater than 1.0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

FabricWireType Class
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Class

[image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Class
Members Example See Also Send Feedback
A filter used to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class FamilyStructuralMaterialTypeFilter : ElementSlowFilter
Visual Basic
Public Class FamilyStructuralMaterialTypeFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class FamilyStructuralMaterialTypeFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Examples

CopyC#
// Use FamilyStructuralMaterialType filter to find families whose material type is Wood
FamilyStructuralMaterialTypeFilter filter = new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood);

// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> woodFamiles = collector.WherePasses(filter).ToElements();

// Find families are not Wood: Use inverted filter to match families
FamilyStructuralMaterialTypeFilter notWoodFilter =
    new FamilyStructuralMaterialTypeFilter(StructuralMaterialType.Wood, true); // inverted filter
collector = new FilteredElementCollector(document);
ICollection<Element> notWoodFamilies = collector.WherePasses(notWoodFilter).ToElements();
CopyVB.NET
' Use FamilyStructuralMaterialType filter to find families whose material type is Wood
Dim filter As New Autodesk.Revit.DB.Structure.FamilyStructuralMaterialTypeFilter(Autodesk.Revit.DB.Structure.StructuralMaterialType.Wood)

' Apply the filter to the elements in the active document
Dim collector As New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim woodFamiles As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(filter).ToElements()

' Find families are not Wood: Use inverted filter to match families
Dim notWoodFilter As New Autodesk.Revit.DB.Structure.FamilyStructuralMaterialTypeFilter(Autodesk.Revit.DB.Structure.StructuralMaterialType.Wood, True)
' inverted filter
collector = New Autodesk.Revit.DB.FilteredElementCollector(document)
Dim notWoodFamilies As ICollection(Of Autodesk.Revit.DB.Element) = collector.WherePasses(notWoodFilter).ToElements()

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Structure..::..FamilyStructuralMaterialTypeFilter

See Also

FamilyStructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Members

[image] [image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Members
FamilyStructuralMaterialTypeFilter Class Constructors Methods Properties See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | FamilyStructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match families that have the given structural material type.
Public method | FamilyStructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralMaterialType | The family structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor

[image] [image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Constructor
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FamilyStructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match families that have the given structural material type.
Public method | FamilyStructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)

[image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)

[image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match families by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
FamilyStructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.
inverted
Type: System..::..Boolean
True if the filter should match all families which are not of the given structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Methods

[image] [image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Methods
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter..::..PassesFilter Method
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

FamilyStructuralMaterialTypeFilter Class
FamilyStructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


FamilyStructuralMaterialTypeFilter Properties

[image] [image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter Properties
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback

The FamilyStructuralMaterialTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralMaterialType | The family structural material type.

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Property

[image]

Revit 2013 API
FamilyStructuralMaterialTypeFilter..::..StructuralMaterialType Property
FamilyStructuralMaterialTypeFilter Class See Also Send Feedback
The family structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

FamilyStructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


Hub Class

[image]

Revit 2013 API
Hub Class
Members See Also Send Feedback
Represents a connection between two or more Autodesk Revit Elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class Hub : Element
Visual Basic
Public Class Hub _
    Inherits Element
Visual C++
public ref class Hub : public Element

Remarks

  • Elements connected via a Hub do not refer directly to each other - they each refer to the Hub that keeps all the connectivity information.
  • In 2012 Hubs connect only structural Analytical Model Elements.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..Hub

See Also

Hub Members
Autodesk.Revit.DB.Structure Namespace


Hub Members

[image] [image]

Revit 2013 API
Hub Members
Hub Class Methods Properties See Also Send Feedback

The Hub type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubConnectorManager | Retrieves the ConnectorManager of the Hub.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrigin | Retrieves position of a Hub if such position is a 3D point.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOrigin | Provides information if Hub has a specific location at point in 3D space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


Hub Methods

[image] [image]

Revit 2013 API
Hub Methods
Hub Class See Also Send Feedback

The Hub type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHubConnectorManager | Retrieves the ConnectorManager of the Hub.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetOrigin | Retrieves position of a Hub if such position is a 3D point.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasOrigin | Provides information if Hub has a specific location at point in 3D space.
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


GetHubConnectorManager Method

[image]

Revit 2013 API
Hub..::..GetHubConnectorManager Method
Hub Class See Also Send Feedback
Retrieves the ConnectorManager of the Hub.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ConnectorManager GetHubConnectorManager()
Visual Basic
Public Function GetHubConnectorManager As ConnectorManager
Visual C++
public:
ConnectorManager^ GetHubConnectorManager()

Return Value

The ConnectorManager.

Remarks

The ConnectorManager provides information about elements connected via the Hub.

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


GetOrigin Method

[image]

Revit 2013 API
Hub..::..GetOrigin Method
Hub Class See Also Send Feedback
Retrieves position of a Hub if such position is a 3D point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public XYZ GetOrigin()
Visual Basic
Public Function GetOrigin As XYZ
Visual C++
public:
XYZ^ GetOrigin()

Return Value

The origin.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Hub does not have an Origin.

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


HasOrigin Method

[image]

Revit 2013 API
Hub..::..HasOrigin Method
Hub Class See Also Send Feedback
Provides information if Hub has a specific location at point in 3D space.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool HasOrigin()
Visual Basic
Public Function HasOrigin As Boolean
Visual C++
public:
bool HasOrigin()

Return Value

True if the Hub has a specific location at point in 3D space.

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


Hub Properties

[image] [image]

Revit 2013 API
Hub Properties
Hub Class See Also Send Feedback

The Hub type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Hub Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
Hub..::..Parameter Property
Hub Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Hub Class
Hub Members
Autodesk.Revit.DB.Structure Namespace


LineLoad Class

[image]

Revit 2013 API
LineLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied in a linear manner.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LineLoad : LoadBase
Visual Basic
Public Class LineLoad _
    Inherits LoadBase
Visual C++
public ref class LineLoad : public LoadBase

Remarks

The load/moment may be uniform or it may vary between the two ends of the line.

Examples

CopyC#
 private void LineLoadInformation(LineLoad lineLoad)
{
     StringBuilder information = new StringBuilder("Line Load: ");

     // Get the load case name
     information.Append("\nLoad case for load: " + lineLoad.LoadCaseName);

     //Get the three dimensional force applied to the start point and end point of the line load.
     information.Append("\nForce at the start of this line load: " + XYZToString(lineLoad.Force1));
     information.Append("\nForce at the end of this line load: " + XYZToString(lineLoad.Force2));

     //Get the three dimensional location of the start point and end point for the line load.
     information.Append("\nStart point of this line load: " + XYZToString(lineLoad.StartPoint));
     information.Append("\nEnd Point of this line load: " + XYZToString(lineLoad.EndPoint));

     //Get the three dimensional moment applied to the start point and end point of the line load.
     information.Append("\nMoment at the start of this line load: " + XYZToString(lineLoad.Moment1));
     information.Append("\nMoment at the end of this line load: " + XYZToString(lineLoad.Moment2));

     //Whether the load is projected or not
     if (lineLoad.ProjectedLoad)
     {
         information.Append("\nThis line load is projected.");
     }
     else
     {
         information.Append("\nThis line load is not projected");
     }

     //Report if the load is uniform
     if (false != lineLoad.UniformLoad)
     {
         information.Append("\nThis load is uniform.");
     }
     else
     {
         information.Append("\nThis load is not uniform.");
     }

     //show information of lineload in a MessageBox.
     TaskDialog.Show("Revit",information.ToString());
 }

 // output the point's three coordinates
 string XYZToString(XYZ point)
 {
     return "(" + point.X + ", " + point.Y + ", " + point.Z + ")";
 }
CopyVB.NET
Private Sub LineLoadInformation(ByVal lineLoad As Autodesk.Revit.DB.Structure.LineLoad)
    Dim information As New StringBuilder("Line Load: ")

    ' Get the load case name
    information.Append(vbLf & "Load case for load: " + lineLoad.LoadCaseName)

    'Get the three dimensional force applied to the start point and end point of the line load.
    information.Append(vbLf & "Force at the start of this line load: " + XYZToString(lineLoad.Force1))
    information.Append(vbLf & "Force at the end of this line load: " + XYZToString(lineLoad.Force2))

    'Get the three dimensional location of the start point and end point for the line load.
    information.Append(vbLf & "Start point of this line load: " + XYZToString(lineLoad.StartPoint))
    information.Append(vbLf & "End Point of this line load: " + XYZToString(lineLoad.EndPoint))

    'Get the three dimensional moment applied to the start point and end point of the line load.
    information.Append(vbLf & "Moment at the start of this line load: " + XYZToString(lineLoad.Moment1))
    information.Append(vbLf & "Moment at the end of this line load: " + XYZToString(lineLoad.Moment2))

    'Whether the load is projected or not
    If lineLoad.ProjectedLoad Then
        information.Append(vbLf & "This line load is projected.")
    Else
        information.Append(vbLf & "This line load is not projected")
    End If

    'Report if the load is uniform
    If 0 <> lineLoad.UniformLoad Then
        information.Append(vbLf & "This load is uniform.")
    Else
        information.Append(vbLf & "This load is not uniform.")
    End If

    'show information of lineload in a MessageBox.
    TaskDialog.Show("Revit", information.ToString())
End Sub

' output the point's three coordinates
Function XYZToString(ByVal point As Autodesk.Revit.DB.XYZ) As String
    Return "(" + point.X + ", " + point.Y + ", " + point.Z + ")"
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..LineLoad

See Also

LineLoad Members
Autodesk.Revit.DB.Structure Namespace


LineLoad Members

[image] [image]

Revit 2013 API
LineLoad Members
LineLoad Class Methods Properties See Also Send Feedback

The LineLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndPoint | Returns the three dimensional location of the end point for the line load.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the start point of the line load.
Public property | Force2 | Returns the three dimensional force applied to the end point of the line load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment applied to one of the points for the line load.
Public property | Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Public property | Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Returns the three dimensional location of one of the points for the line load.
Public property | ProjectedLoad | Returns whether the load is projected or not.
Public property | StartPoint | Returns the three dimensional location of the start point for the line load.
Public property | UniformLoad | Report if the load is uniform.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoad Methods

[image] [image]

Revit 2013 API
LineLoad Methods
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoad Properties

[image] [image]

Revit 2013 API
LineLoad Properties
LineLoad Class See Also Send Feedback

The LineLoad type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | EndPoint | Returns the three dimensional location of the end point for the line load.
Public property | Force | Returns the three dimensional force applied to one of the points for the line load.
Public property | Force1 | Returns the three dimensional force applied to the start point of the line load.
Public property | Force2 | Returns the three dimensional force applied to the end point of the line load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment applied to one of the points for the line load.
Public property | Moment1 | Returns the three dimensional moment applied to the start point of the line load.
Public property | Moment2 | Returns the three dimensional moment applied to the end point of the line load.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Returns the three dimensional location of one of the points for the line load.
Public property | ProjectedLoad | Returns whether the load is projected or not.
Public property | StartPoint | Returns the three dimensional location of the start point for the line load.
Public property | UniformLoad | Report if the load is uniform.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


EndPoint Property

[image]

Revit 2013 API
LineLoad..::..EndPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the end point for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ EndPoint { get; }
Visual Basic
Public ReadOnly Property EndPoint As XYZ
    Get
Visual C++
public:
property XYZ^ EndPoint {
    XYZ^ get ();
}

Remarks

The location of the end point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2013 API
LineLoad..::..Force Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Force ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Force[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force1 Property

[image]

Revit 2013 API
LineLoad..::..Force1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the start point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force1 { get; }
Visual Basic
Public ReadOnly Property Force1 As XYZ
    Get
Visual C++
public:
property XYZ^ Force1 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Force2 Property

[image]

Revit 2013 API
LineLoad..::..Force2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional force applied to the end point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force2 { get; }
Visual Basic
Public ReadOnly Property Force2 As XYZ
    Get
Visual C++
public:
property XYZ^ Force2 {
    XYZ^ get ();
}

Remarks

The force is measured in Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment Property

[image]

Revit 2013 API
LineLoad..::..Moment Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Moment ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Moment[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment1 Property

[image]

Revit 2013 API
LineLoad..::..Moment1 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the start point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Moment1 { get; }
Visual Basic
Public ReadOnly Property Moment1 As XYZ
    Get
Visual C++
public:
property XYZ^ Moment1 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment2 Property

[image]

Revit 2013 API
LineLoad..::..Moment2 Property
LineLoad Class See Also Send Feedback
Returns the three dimensional moment applied to the end point of the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Moment2 { get; }
Visual Basic
Public ReadOnly Property Moment2 As XYZ
    Get
Visual C++
public:
property XYZ^ Moment2 {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LineLoad..::..Parameter Property
LineLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LineLoad Class
LineLoad Members
Autodesk.Revit.DB.Structure Namespace


Point Property

[image]

Revit 2013 API
LineLoad..::..Point Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of one of the points for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Point ( _
    index As Integer _
) As XYZ
    Get
Visual C++
public:
property XYZ^ Point[int index] {
    XYZ^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of the point to return.

Remarks

An index of 0 represents the start point and 1 represents the end point. The location of the point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


ProjectedLoad Property

[image]

Revit 2013 API
LineLoad..::..ProjectedLoad Property
LineLoad Class See Also Send Feedback
Returns whether the load is projected or not.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool ProjectedLoad { get; }
Visual Basic
Public ReadOnly Property ProjectedLoad As Boolean
    Get
Visual C++
public:
property bool ProjectedLoad {
    bool get ();
}

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


StartPoint Property

[image]

Revit 2013 API
LineLoad..::..StartPoint Property
LineLoad Class See Also Send Feedback
Returns the three dimensional location of the start point for the line load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ StartPoint { get; }
Visual Basic
Public ReadOnly Property StartPoint As XYZ
    Get
Visual C++
public:
property XYZ^ StartPoint {
    XYZ^ get ();
}

Remarks

The location of the start point is measured in decimal feet.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


UniformLoad Property

[image]

Revit 2013 API
LineLoad..::..UniformLoad Property
LineLoad Class See Also Send Feedback
Report if the load is uniform.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool UniformLoad { get; }
Visual Basic
Public ReadOnly Property UniformLoad As Boolean
    Get
Visual C++
public:
property bool UniformLoad {
    bool get ();
}

Remarks

This property will return True is the line load is uniform, i.e. the load is that same across the entire line.

See Also

LineLoad Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Class

[image]

Revit 2013 API
LineLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LineLoadType : LoadTypeBase
Visual Basic
Public Class LineLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class LineLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..LineLoadType

See Also

LineLoadType Members
Autodesk.Revit.DB.Structure Namespace


LineLoadType Members

[image] [image]

Revit 2013 API
LineLoadType Members
LineLoadType Class Methods Properties See Also Send Feedback

The LineLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Methods

[image] [image]

Revit 2013 API
LineLoadType Methods
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


LineLoadType Properties

[image] [image]

Revit 2013 API
LineLoadType Properties
LineLoadType Class See Also Send Feedback

The LineLoadType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LineLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LineLoadType..::..Parameter Property
LineLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LineLoadType Class
LineLoadType Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Class

[image]

Revit 2013 API
LineLoadTypeSet Class
Members See Also Send Feedback
A set that contains lineload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LineLoadTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class LineLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LineLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LineLoadTypeSet

See Also

LineLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Members

[image] [image]

Revit 2013 API
LineLoadTypeSet Members
LineLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | LineLoadTypeSet | Initializes a new instance of the LineLoadTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every lineload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a lineload type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified lineload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified lineload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Constructor

[image]

Revit 2013 API
LineLoadTypeSet Constructor
LineLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the LineLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoadTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
LineLoadTypeSet()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Methods

[image] [image]

Revit 2013 API
LineLoadTypeSet Methods
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every lineload type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a lineload type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified lineload type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified lineload type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LineLoadTypeSet..::..Clear Method
LineLoadTypeSet Class See Also Send Feedback
Removes every lineload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
LineLoadTypeSet..::..Contains Method
LineLoadTypeSet Class See Also Send Feedback
Tests for the existence of a lineload type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    LineLoadType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The lineload type to be searched for.

Return Value

The Contains method returns True if the lineload type is within the set, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
LineLoadTypeSet..::..Erase Method
LineLoadTypeSet Class See Also Send Feedback
Removes a specified lineload type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    LineLoadType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As LineLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The lineload type to be erased.

Return Value

The number of lineload types that were erased from the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LineLoadTypeSet..::..ForwardIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LineLoadTypeSet..::..GetEnumerator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LineLoadTypeSet..::..Insert Method
LineLoadTypeSet Class See Also Send Feedback
Insert the specified lineload type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    LineLoadType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As LineLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LineLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LineLoadType
The lineload type to be inserted into the set.

Return Value

Returns whether the lineload type was inserted into the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LineLoadTypeSet..::..ReverseIterator Method
LineLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LineLoadTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LineLoadTypeSetIterator
Visual C++
public:
virtual LineLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSet Properties

[image] [image]

Revit 2013 API
LineLoadTypeSet Properties
LineLoadTypeSet Class See Also Send Feedback

The LineLoadTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of lineload types that are in the set.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LineLoadTypeSet..::..IsEmpty Property
LineLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LineLoadTypeSet..::..Size Property
LineLoadTypeSet Class See Also Send Feedback
Returns the number of lineload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LineLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Class

[image]

Revit 2013 API
LineLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a lineload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LineLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LineLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LineLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LineLoadTypeSetIterator

See Also

LineLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Members

[image] [image]

Revit 2013 API
LineLoadTypeSetIterator Members
LineLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LineLoadTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Constructor

[image]

Revit 2013 API
LineLoadTypeSetIterator Constructor
LineLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LineLoadTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
LineLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Methods

[image] [image]

Revit 2013 API
LineLoadTypeSetIterator Methods
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LineLoadTypeSetIterator..::..MoveNext Method
LineLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LineLoadTypeSetIterator..::..Reset Method
LineLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LineLoadTypeSetIterator Properties

[image] [image]

Revit 2013 API
LineLoadTypeSetIterator Properties
LineLoadTypeSetIterator Class See Also Send Feedback

The LineLoadTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LineLoadTypeSetIterator..::..Current Property
LineLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LineLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Class

[image]

Revit 2013 API
LoadBase Class
Members Example See Also Send Feedback
The LoadBase object is the base class for all load objects within the Autodesk Revit API.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadBase : Element
Visual Basic
Public Class LoadBase _
    Inherits Element
Visual C++
public ref class LoadBase : public Element

Remarks

Load objects are only available in Autodesk Revit Structure. This object contains methods that are common to all other load objects.

Examples

CopyC#
private void LoadBaseInformation(LoadBase loadBase)
{
    string message = "LoadBase data for line load: ";
    //Get the name of the load case to which this load belongs
    message += "\nLoad case name: " + loadBase.LoadCaseName;

    //Get the name of the category to which this load belongs
    message += "\nLoad category name: " + loadBase.LoadCategoryName;

    //A string representing the nature of the load
    message += "\nLoad nature name: " + loadBase.LoadNatureName;

    //show the load base information in the messagebox
    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub LoadBaseInformation(ByVal loadBase As Autodesk.Revit.DB.Structure.LoadBase)
    Dim message As String = "LoadBase data for line load: "
    'Get the name of the load case to which this load belongs
    message += vbLf & "Load case name: " + loadBase.LoadCaseName

    'Get the name of the category to which this load belongs
    message += vbLf & "Load category name: " + loadBase.LoadCategoryName

    'A string representing the nature of the load
    message += vbLf & "Load nature name: " + loadBase.LoadNatureName

    'show the load base information in the messagebox
    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..AreaLoad
Autodesk.Revit.DB.Structure..::..LineLoad
Autodesk.Revit.DB.Structure..::..PointLoad

See Also

LoadBase Members
Autodesk.Revit.DB.Structure Namespace


LoadBase Members

[image] [image]

Revit 2013 API
LoadBase Members
LoadBase Class Methods Properties See Also Send Feedback

The LoadBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs.
Public property | LoadCategoryName | The name of the category to which this load belongs.
Public property | LoadNatureName | A string representing the nature of the load.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Methods

[image] [image]

Revit 2013 API
LoadBase Methods
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadBase Properties

[image] [image]

Revit 2013 API
LoadBase Properties
LoadBase Class See Also Send Feedback

The LoadBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs.
Public property | LoadCategoryName | The name of the category to which this load belongs.
Public property | LoadNatureName | A string representing the nature of the load.
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


HostElement Property

[image]

Revit 2013 API
LoadBase..::..HostElement Property
LoadBase Class See Also Send Feedback
The host element for the load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public Element HostElement { get; }
Visual Basic
Public ReadOnly Property HostElement As Element
    Get
Visual C++
public:
property Element^ HostElement {
    Element^ get ();
}

Field Value

If the load is host-based this is the host element. Otherwise this property is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseName Property

[image]

Revit 2013 API
LoadBase..::..LoadCaseName Property
LoadBase Class See Also Send Feedback
The name of the load case to which this load belongs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LoadCaseName { get; }
Visual Basic
Public ReadOnly Property LoadCaseName As String
    Get
Visual C++
public:
property String^ LoadCaseName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadCategoryName Property

[image]

Revit 2013 API
LoadBase..::..LoadCategoryName Property
LoadBase Class See Also Send Feedback
The name of the category to which this load belongs.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LoadCategoryName { get; }
Visual Basic
Public ReadOnly Property LoadCategoryName As String
    Get
Visual C++
public:
property String^ LoadCategoryName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


LoadNatureName Property

[image]

Revit 2013 API
LoadBase..::..LoadNatureName Property
LoadBase Class See Also Send Feedback
A string representing the nature of the load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LoadNatureName { get; }
Visual Basic
Public ReadOnly Property LoadNatureName As String
    Get
Visual C++
public:
property String^ LoadNatureName {
    String^ get ();
}

See Also

LoadBase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadBase..::..Parameter Property
LoadBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadBase Class
LoadBase Members
Autodesk.Revit.DB.Structure Namespace


LoadCase Class

[image]

Revit 2013 API
LoadCase Class
Members Example See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCase : Element
Visual Basic
Public Class LoadCase _
    Inherits Element
Visual C++
public ref class LoadCase : public Element

Examples

CopyC#
private void LoadCaseInfomation(Document document, LoadCase loadCase)
{
    string loadCaseNumber;   //Store the load cases number
    StringBuilder information = new StringBuilder(10);

    // first get all the load case categories in a list
    List<Category> loadCaseCategories = new List<Category>();
    GetLoadCaseCategories(document, ref loadCaseCategories);

    //get the load case name
    information.Append("\nCase Name: " + loadCase.Name);

    //get the number of the load case
    Parameter caseNumber = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NUMBER);
    if (null == caseNumber)
    {
        loadCaseNumber = "";
    }
    else
    {
        loadCaseNumber = caseNumber.AsInteger().ToString();
    }
    information.Append("\nCase Number: " + loadCaseNumber);

    //get the category of the load case
    Parameter caseCategoryid = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_CATEGORY);
    Autodesk.Revit.DB.ElementId loadCaseCategoryId = caseCategoryid.AsElementId();

    information.Append("\nCategory: " + GetCategoryName(loadCaseCategoryId, loadCaseCategories));

    //get the nature of load case
    Parameter caseNatureId = loadCase.get_Parameter(BuiltInParameter.LOAD_CASE_NATURE);
    Autodesk.Revit.DB.ElementId loadCaseNatureId = caseNatureId.AsElementId();
    LoadNature loadNature = document.GetElement(loadCaseNatureId) as LoadNature;
    information.Append("\nNature: " + loadNature.Name + "\n");

    //show the information to the user
    TaskDialog.Show("Revit",information.ToString());
}

private void GetLoadCaseCategories(Document document, ref List<Category> loadCaseCategories)
{
    //get all the categories of load cases
    Categories categories = document.Settings.Categories;
    Category caseCategory = categories.get_Item(BuiltInCategory.OST_LoadCases);
    CategoryNameMap categoryNameMap = caseCategory.SubCategories;
    System.Collections.IEnumerator iter = categoryNameMap.GetEnumerator();
    iter.Reset();
    while (iter.MoveNext())
    {
        Category temp = iter.Current as Category;
        if (null != temp)
        {
            loadCaseCategories.Add(temp);
        }
    }
}

/// <summary>
/// Get the category name according to the load case category id.
/// </summary>
private string GetCategoryName(Autodesk.Revit.DB.ElementId loadCaseCategoryId, List<Category> loadCaseCategories)
{
    string categoryName = "";

    foreach (Category category in loadCaseCategories)
    {
        if (category.Id.Equals(loadCaseCategoryId))
        {
            categoryName = category.Name;
            break;
        }
    }
    return categoryName;
}
CopyVB.NET
Private Sub LoadCaseInfomation(ByVal document As Document, ByVal loadCase As LoadCase)
    Dim loadCaseNumber As String
    'Store the load cases number
    Dim information As New StringBuilder(10)

    ' first get all the load case categories in a list
    Dim loadCaseCategories As New List(Of Autodesk.Revit.DB.Category)()
    GetLoadCaseCategories(document, loadCaseCategories)

    'get the load case name
    information.Append(vbLf & "Case Name: " + loadCase.Name)

    'get the number of the load case
    Dim caseNumber As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NUMBER)
    If caseNumber Is Nothing Then
        loadCaseNumber = ""
    Else
        loadCaseNumber = caseNumber.AsInteger().ToString()
    End If
    information.Append(vbLf & "Case Number: " + loadCaseNumber)

    'get the category of the load case
    Dim caseCategoryid As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_CATEGORY)
    Dim loadCaseCategoryId As Autodesk.Revit.DB.ElementId = caseCategoryid.AsElementId()

    information.Append(vbLf & "Category: " + GetCategoryName(loadCaseCategoryId, loadCaseCategories))

    'get the nature of load case
    Dim caseNatureId As Parameter = loadCase.Parameter(BuiltInParameter.LOAD_CASE_NATURE)
    Dim loadCaseNatureId As Autodesk.Revit.DB.ElementId = caseNatureId.AsElementId()
    Dim loadNature As LoadNature = TryCast(document.GetElement(loadCaseNatureId), LoadNature)
    information.Append(vbLf & "Nature: " + loadNature.Name + vbLf)

    'show the information to the user
    TaskDialog.Show("Revit", information.ToString())
End Sub

Private Sub GetLoadCaseCategories(ByVal document As Document, ByRef loadCaseCategories As List(Of Autodesk.Revit.DB.Category))
    'get all the categories of load cases
    Dim categories As Categories = document.Settings.Categories
    Dim caseCategory As Autodesk.Revit.DB.Category = categories.Item(BuiltInCategory.OST_LoadCases)
    Dim categoryNameMap As CategoryNameMap = caseCategory.SubCategories
    Dim iter As System.Collections.IEnumerator = categoryNameMap.GetEnumerator()
    iter.Reset()
    While iter.MoveNext()
        Dim temp As Autodesk.Revit.DB.Category = TryCast(iter.Current, Autodesk.Revit.DB.Category)
        If temp IsNot Nothing Then
            loadCaseCategories.Add(temp)
        End If
    End While
End Sub

' <summary>
' Get the category name according to the load case category id.
' </summary>
Private Function GetCategoryName(ByVal loadCaseCategoryId As Autodesk.Revit.DB.ElementId, ByVal loadCaseCategories As List(Of Autodesk.Revit.DB.Category)) As String
    Dim categoryName As String = ""

    For Each category As Autodesk.Revit.DB.Category In loadCaseCategories
        If category.Id.Equals(loadCaseCategoryId) Then
            categoryName = category.Name
            Exit For
        End If
    Next
    Return categoryName
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadCase

See Also

LoadCase Members
Autodesk.Revit.DB.Structure Namespace


LoadCase Members

[image] [image]

Revit 2013 API
LoadCase Members
LoadCase Class Methods Properties See Also Send Feedback

The LoadCase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


LoadCase Methods

[image] [image]

Revit 2013 API
LoadCase Methods
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


LoadCase Properties

[image] [image]

Revit 2013 API
LoadCase Properties
LoadCase Class See Also Send Feedback

The LoadCase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadCase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadCase..::..Parameter Property
LoadCase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadCase Class
LoadCase Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Class

[image]

Revit 2013 API
LoadCaseArray Class
Members See Also Send Feedback
An array that contains load case objects.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCaseArray : APIObject,
    IEnumerable
Visual Basic
Public Class LoadCaseArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCaseArray

See Also

LoadCaseArray Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Members

[image] [image]

Revit 2013 API
LoadCaseArray Members
LoadCaseArray Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArray type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCaseArray | Initializes a new instance of the LoadCaseArray class

Methods

 | Name | Description
Public method | Append | Add the load case to the end of the array.
Public method | Clear | Removes every load case from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load case at a specified index within the array.
Public property | Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Constructor

[image]

Revit 2013 API
LoadCaseArray Constructor
LoadCaseArray Class See Also Send Feedback
Initializes a new instance of the LoadCaseArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCaseArray()
Visual Basic
Public Sub New
Visual C++
public:
LoadCaseArray()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Methods

[image] [image]

Revit 2013 API
LoadCaseArray Methods
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the load case to the end of the array.
Public method | Clear | Removes every load case from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2013 API
LoadCaseArray..::..Append Method
LoadCaseArray Class See Also Send Feedback
Add the load case to the end of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    LoadCase item
)
Visual Basic
Public Overridable Sub Append ( _
    item As LoadCase _
)
Visual C++
public:
virtual void Append(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCase
The load case to be added.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LoadCaseArray..::..Clear Method
LoadCaseArray Class See Also Send Feedback
Removes every load case from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LoadCaseArray..::..ForwardIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LoadCaseArray..::..GetEnumerator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LoadCaseArray..::..Insert Method
LoadCaseArray Class See Also Send Feedback
Insert the specified load case into the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCase item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As LoadCase, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCase^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCase
The load case to be inserted into the array.
index
Type: System..::..Int32
The load case will be inserted before this index.

Return Value

Returns whether the load case was inserted into the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LoadCaseArray..::..ReverseIterator Method
LoadCaseArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCaseArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LoadCaseArrayIterator
Visual C++
public:
virtual LoadCaseArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArray Properties

[image] [image]

Revit 2013 API
LoadCaseArray Properties
LoadCaseArray Class See Also Send Feedback

The LoadCaseArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load case at a specified index within the array.
Public property | Size | Returns the number of load cases that are in the array.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LoadCaseArray..::..IsEmpty Property
LoadCaseArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2013 API
LoadCaseArray..::..Item Property
LoadCaseArray Class See Also Send Feedback
Gets or sets an load case at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCase this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As LoadCase
    Get
    Set
Visual C++
public:
virtual property LoadCase^ Item[int index] {
    LoadCase^ get (int index);
    void set (int index, LoadCase^ value);
}

Parameters

index
Type: System..::..Int32
The index of the load case to be set or retrieved.

Return Value

Returns the load case at the specified index.

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LoadCaseArray..::..Size Property
LoadCaseArray Class See Also Send Feedback
Returns the number of load cases that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Class

[image]

Revit 2013 API
LoadCaseArrayIterator Class
Members See Also Send Feedback
An iterator to an load case array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LoadCaseArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LoadCaseArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCaseArrayIterator

See Also

LoadCaseArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Members

[image] [image]

Revit 2013 API
LoadCaseArrayIterator Members
LoadCaseArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCaseArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Constructor

[image]

Revit 2013 API
LoadCaseArrayIterator Constructor
LoadCaseArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCaseArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
LoadCaseArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Methods

[image] [image]

Revit 2013 API
LoadCaseArrayIterator Methods
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LoadCaseArrayIterator..::..MoveNext Method
LoadCaseArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LoadCaseArrayIterator..::..Reset Method
LoadCaseArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseArrayIterator Properties

[image] [image]

Revit 2013 API
LoadCaseArrayIterator Properties
LoadCaseArrayIterator Class See Also Send Feedback

The LoadCaseArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LoadCaseArrayIterator..::..Current Property
LoadCaseArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Class

[image]

Revit 2013 API
LoadCaseSet Class
Members See Also Send Feedback
A set that contains load cases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCaseSet : APIObject,
    IEnumerable
Visual Basic
Public Class LoadCaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCaseSet

See Also

LoadCaseSet Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Members

[image] [image]

Revit 2013 API
LoadCaseSet Members
LoadCaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSet type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCaseSet | Initializes a new instance of the LoadCaseSet class

Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Constructor

[image]

Revit 2013 API
LoadCaseSet Constructor
LoadCaseSet Class See Also Send Feedback
Initializes a new instance of the LoadCaseSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCaseSet()
Visual Basic
Public Sub New
Visual C++
public:
LoadCaseSet()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Methods

[image] [image]

Revit 2013 API
LoadCaseSet Methods
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every load case from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load case within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load case from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load case into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LoadCaseSet..::..Clear Method
LoadCaseSet Class See Also Send Feedback
Removes every load case from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
LoadCaseSet..::..Contains Method
LoadCaseSet Class See Also Send Feedback
Tests for the existence of a load case within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadCase item
)
Visual Basic
Public Overridable Function Contains ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCase
The load case to be searched for.

Return Value

The Contains method returns True if the load case is within the set, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
LoadCaseSet..::..Erase Method
LoadCaseSet Class See Also Send Feedback
Removes a specified load case from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    LoadCase item
)
Visual Basic
Public Overridable Function Erase ( _
    item As LoadCase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCase
The load case to be erased.

Return Value

The number of load cases that were erased from the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LoadCaseSet..::..ForwardIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LoadCaseSet..::..GetEnumerator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LoadCaseSet..::..Insert Method
LoadCaseSet Class See Also Send Feedback
Insert the specified load case into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadCase item
)
Visual Basic
Public Overridable Function Insert ( _
    item As LoadCase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadCase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCase
The load case to be inserted into the set.

Return Value

Returns whether the load case was inserted into the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LoadCaseSet..::..ReverseIterator Method
LoadCaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCaseSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LoadCaseSetIterator
Visual C++
public:
virtual LoadCaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSet Properties

[image] [image]

Revit 2013 API
LoadCaseSet Properties
LoadCaseSet Class See Also Send Feedback

The LoadCaseSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load cases that are in the set.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LoadCaseSet..::..IsEmpty Property
LoadCaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LoadCaseSet..::..Size Property
LoadCaseSet Class See Also Send Feedback
Returns the number of load cases that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Class

[image]

Revit 2013 API
LoadCaseSetIterator Class
Members See Also Send Feedback
An iterator to a load case set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LoadCaseSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LoadCaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCaseSetIterator

See Also

LoadCaseSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Members

[image] [image]

Revit 2013 API
LoadCaseSetIterator Members
LoadCaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCaseSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Constructor

[image]

Revit 2013 API
LoadCaseSetIterator Constructor
LoadCaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCaseSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
LoadCaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Methods

[image] [image]

Revit 2013 API
LoadCaseSetIterator Methods
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LoadCaseSetIterator..::..MoveNext Method
LoadCaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LoadCaseSetIterator..::..Reset Method
LoadCaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCaseSetIterator Properties

[image] [image]

Revit 2013 API
LoadCaseSetIterator Properties
LoadCaseSetIterator Class See Also Send Feedback

The LoadCaseSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LoadCaseSetIterator..::..Current Property
LoadCaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Class

[image]

Revit 2013 API
LoadCombination Class
Members Example See Also Send Feedback
An object that represents a load combination.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCombination : Element
Visual Basic
Public Class LoadCombination _
    Inherits Element
Visual C++
public ref class LoadCombination : public Element

Examples

CopyC#
private void CombinationInformation(LoadCombination loadCombination)
{
    StringBuilder information = new StringBuilder();

    //Get the string with Load Combination Name or empty string
    information.Append("\n\nCombination Name: " + loadCombination.Name);

    //Get the string with Load Combination State
    information.Append("\nCombination state: " + loadCombination.CombinationState);

    //Load Combination State index or 0
    information.Append("\nState index : " + loadCombination.CombinationStateIndex.ToString());

    //Get the string with Load Combination Type
    information.Append("\nCombination type: " + loadCombination.CombinationType);

    //Get Load Combination Type index or 0
    information.Append("\nType index: " + loadCombination.CombinationTypeIndex.ToString());

    //Get the number of Load Combination Components
    int componentsNumber = loadCombination.NumberOfComponents;
    information.Append("\nComponents number: " + componentsNumber.ToString());
    for (int j = 0; j < componentsNumber; j++)
    {
        double factor = loadCombination.get_Factor(j);
        string caseName = loadCombination.get_CombinationCaseName(j);
        information.Append("\nCase name[" + j.ToString() + "]: " + caseName + "  factor: " +
                              factor.ToString());
    }

    //return the number of usage in the combination
    int usageNumber = loadCombination.NumberOfUsages;
    information.Append("\nNumber of usages: " + usageNumber + "\nUsage names: ");
    //get each usage name
    for (int i = 0; i < usageNumber; i++)
    {
        information.Append(loadCombination.get_UsageName(i) + "  ");
    }

    TaskDialog.Show("Revit",information.ToString());
}
CopyVB.NET
Private Sub CombinationInformation(ByVal loadCombination As LoadCombination)
    Dim information As New StringBuilder()

    'Get the string with Load Combination Name or empty string
    information.Append(vbLf & vbLf & "Combination Name: " + loadCombination.Name)

    'Get the string with Load Combination State
    information.Append(vbLf & "Combination state: " + loadCombination.CombinationState)

    'Load Combination State index or 0
    information.Append(vbLf & "State index : " + loadCombination.CombinationStateIndex.ToString())

    'Get the string with Load Combination Type
    information.Append(vbLf & "Combination type: " + loadCombination.CombinationType)

    'Get Load Combination Type index or 0
    information.Append(vbLf & "Type index: " + loadCombination.CombinationTypeIndex.ToString())

    'Get the number of Load Combination Components
    Dim componentsNumber As Integer = loadCombination.NumberOfComponents
    information.Append(vbLf & "Components number: " + componentsNumber.ToString())
    Dim j As Integer = 0
    While j < componentsNumber
        Dim factor As Double = loadCombination.Factor(j)
        Dim caseName As String = loadCombination.CombinationCaseName(j)
        information.Append(vbLf & "Case name[" + j.ToString() + "]: " + caseName + "  factor: " + factor.ToString())
        System.Math.Max(System.Threading.Interlocked.Increment(j), j - 1)
    End While

    'return the number of usage in the combination
    Dim usageNumber As Integer = loadCombination.NumberOfUsages
    information.Append(vbLf & "Number of usages: " + usageNumber + vbLf & "Usage names: ")
    'get each usage name
    Dim i As Integer = 0
    While i < usageNumber
        information.Append(loadCombination.UsageName(i) + "  ")
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    TaskDialog.Show("Revit", information.ToString())
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadCombination

See Also

LoadCombination Members
Autodesk.Revit.DB.Structure Namespace


LoadCombination Members

[image] [image]

Revit 2013 API
LoadCombination Members
LoadCombination Class Methods Properties See Also Send Feedback

The LoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CombinationCaseName | Returns load combination case name.
Public property | CombinationNatureName | Returns load combination nature name of load case element.
Public property | CombinationState | Returns load combination state.
Public property | CombinationStateIndex | Returns the index in predefined load combination state array {}.
Public property | CombinationType | Returns load combination type.
Public property | CombinationTypeIndex | Returns the index in predefined load combination type array.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Factor | Returns factor value.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns load combination name.
Public property | NumberOfComponents | Returns number of factors.
Public property | NumberOfUsages | Returns number of usages.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsageName | Returns usage value.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Methods

[image] [image]

Revit 2013 API
LoadCombination Methods
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombination Properties

[image] [image]

Revit 2013 API
LoadCombination Properties
LoadCombination Class See Also Send Feedback

The LoadCombination type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CombinationCaseName | Returns load combination case name.
Public property | CombinationNatureName | Returns load combination nature name of load case element.
Public property | CombinationState | Returns load combination state.
Public property | CombinationStateIndex | Returns the index in predefined load combination state array {}.
Public property | CombinationType | Returns load combination type.
Public property | CombinationTypeIndex | Returns the index in predefined load combination type array.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Factor | Returns factor value.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Returns load combination name.
Public property | NumberOfComponents | Returns number of factors.
Public property | NumberOfUsages | Returns number of usages.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | UsageName | Returns usage value.
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationCaseName Property

[image]

Revit 2013 API
LoadCombination..::..CombinationCaseName Property
LoadCombination Class See Also Send Feedback
Returns load combination case name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property CombinationCaseName ( _
    index As Integer _
) As String
    Get
Visual C++
public:
property String^ CombinationCaseName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of load case.

Remarks

The index should be not less then 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationNatureName Property

[image]

Revit 2013 API
LoadCombination..::..CombinationNatureName Property
LoadCombination Class See Also Send Feedback
Returns load combination nature name of load case element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property CombinationNatureName ( _
    index As Integer _
) As String
    Get
Visual C++
public:
property String^ CombinationNatureName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of load case.

Remarks

The index should be not less 0 and be less than load cases count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationState Property

[image]

Revit 2013 API
LoadCombination..::..CombinationState Property
LoadCombination Class See Also Send Feedback
Returns load combination state.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string CombinationState { get; }
Visual Basic
Public ReadOnly Property CombinationState As String
    Get
Visual C++
public:
property String^ CombinationState {
    String^ get ();
}

Remarks

The state should be "Serviceability" or "Ultimate".

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationStateIndex Property

[image]

Revit 2013 API
LoadCombination..::..CombinationStateIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination state array {}.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int CombinationStateIndex { get; }
Visual Basic
Public ReadOnly Property CombinationStateIndex As Integer
    Get
Visual C++
public:
property int CombinationStateIndex {
    int get ();
}

Remarks

The index should be 0 ("Serviceability") or 1 ("Ultimate").

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationType Property

[image]

Revit 2013 API
LoadCombination..::..CombinationType Property
LoadCombination Class See Also Send Feedback
Returns load combination type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string CombinationType { get; }
Visual Basic
Public ReadOnly Property CombinationType As String
    Get
Visual C++
public:
property String^ CombinationType {
    String^ get ();
}

Remarks

The type should be "Combination" or "Envelope".

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


CombinationTypeIndex Property

[image]

Revit 2013 API
LoadCombination..::..CombinationTypeIndex Property
LoadCombination Class See Also Send Feedback
Returns the index in predefined load combination type array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int CombinationTypeIndex { get; }
Visual Basic
Public ReadOnly Property CombinationTypeIndex As Integer
    Get
Visual C++
public:
property int CombinationTypeIndex {
    int get ();
}

Remarks

The index should be 0 ("Combination") or 1 ("Envelope").

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Factor Property

[image]

Revit 2013 API
LoadCombination..::..Factor Property
LoadCombination Class See Also Send Feedback
Returns factor value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property Factor ( _
    index As Integer _
) As Double
    Get
Visual C++
public:
property double Factor[int index] {
    double get (int index);
}

Parameters

index
Type: System..::..Int32
The index of factor in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Name Property

[image]

Revit 2013 API
LoadCombination..::..Name Property
LoadCombination Class See Also Send Feedback
Returns load combination name.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


NumberOfComponents Property

[image]

Revit 2013 API
LoadCombination..::..NumberOfComponents Property
LoadCombination Class See Also Send Feedback
Returns number of factors.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfComponents { get; }
Visual Basic
Public ReadOnly Property NumberOfComponents As Integer
    Get
Visual C++
public:
property int NumberOfComponents {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


NumberOfUsages Property

[image]

Revit 2013 API
LoadCombination..::..NumberOfUsages Property
LoadCombination Class See Also Send Feedback
Returns number of usages.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfUsages { get; }
Visual Basic
Public ReadOnly Property NumberOfUsages As Integer
    Get
Visual C++
public:
property int NumberOfUsages {
    int get ();
}

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadCombination..::..Parameter Property
LoadCombination Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadCombination Class
LoadCombination Members
Autodesk.Revit.DB.Structure Namespace


UsageName Property

[image]

Revit 2013 API
LoadCombination..::..UsageName Property
LoadCombination Class See Also Send Feedback
Returns usage value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string this[
    int index
] { get; }
Visual Basic
Public ReadOnly Property UsageName ( _
    index As Integer _
) As String
    Get
Visual C++
public:
property String^ UsageName[int index] {
    String^ get (int index);
}

Parameters

index
Type: System..::..Int32
The index of usage in load combination.

Remarks

The index should be not less 0 and be less than load factors count.

See Also

LoadCombination Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Class

[image]

Revit 2013 API
LoadCombinationArray Class
Members See Also Send Feedback
An array that can contain LoadCombination objects.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadCombinationArray : APIObject,
    IEnumerable
Visual Basic
Public Class LoadCombinationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadCombinationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCombinationArray

See Also

LoadCombinationArray Members
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Members

[image] [image]

Revit 2013 API
LoadCombinationArray Members
LoadCombinationArray Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationArray | Initializes a new instance of the LoadCombinationArray class

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Constructor

[image]

Revit 2013 API
LoadCombinationArray Constructor
LoadCombinationArray Class See Also Send Feedback
Initializes a new instance of the LoadCombinationArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCombinationArray()
Visual Basic
Public Sub New
Visual C++
public:
LoadCombinationArray()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Methods

[image] [image]

Revit 2013 API
LoadCombinationArray Methods
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Methods

 | Name | Description
Public method | Append |
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2013 API
LoadCombinationArray..::..Append Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    LoadCombination item
)
Visual Basic
Public Overridable Sub Append ( _
    item As LoadCombination _
)
Visual C++
public:
virtual void Append(
    LoadCombination^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCombination

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LoadCombinationArray..::..Clear Method
LoadCombinationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LoadCombinationArray..::..ForwardIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LoadCombinationArray..::..GetEnumerator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LoadCombinationArray..::..Insert Method
LoadCombinationArray Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    LoadCombination item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As LoadCombination, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadCombination^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadCombination
index
Type: System..::..Int32

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LoadCombinationArray..::..ReverseIterator Method
LoadCombinationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCombinationArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LoadCombinationArrayIterator
Visual C++
public:
virtual LoadCombinationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArray Properties

[image] [image]

Revit 2013 API
LoadCombinationArray Properties
LoadCombinationArray Class See Also Send Feedback

The LoadCombinationArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LoadCombinationArray..::..IsEmpty Property
LoadCombinationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2013 API
LoadCombinationArray..::..Item Property
LoadCombinationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadCombination this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As LoadCombination
    Get
    Set
Visual C++
public:
virtual property LoadCombination^ Item[int index] {
    LoadCombination^ get (int index);
    void set (int index, LoadCombination^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LoadCombinationArray..::..Size Property
LoadCombinationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadCombinationArray Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Class

[image]

Revit 2013 API
LoadCombinationArrayIterator Class
Members See Also Send Feedback
An iterator to an array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LoadCombinationArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LoadCombinationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadCombinationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadCombinationArrayIterator

See Also

LoadCombinationArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Members

[image] [image]

Revit 2013 API
LoadCombinationArrayIterator Members
LoadCombinationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LoadCombinationArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Constructor

[image]

Revit 2013 API
LoadCombinationArrayIterator Constructor
LoadCombinationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadCombinationArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
LoadCombinationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Methods

[image] [image]

Revit 2013 API
LoadCombinationArrayIterator Methods
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LoadCombinationArrayIterator..::..MoveNext Method
LoadCombinationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LoadCombinationArrayIterator..::..Reset Method
LoadCombinationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadCombinationArrayIterator Properties

[image] [image]

Revit 2013 API
LoadCombinationArrayIterator Properties
LoadCombinationArrayIterator Class See Also Send Feedback

The LoadCombinationArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LoadCombinationArrayIterator..::..Current Property
LoadCombinationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadCombinationArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Class

[image]

Revit 2013 API
LoadNature Class
Members See Also Send Feedback
A structural Load nature object.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadNature : Element
Visual Basic
Public Class LoadNature _
    Inherits Element
Visual C++
public ref class LoadNature : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadNature

See Also

LoadNature Members
Autodesk.Revit.DB.Structure Namespace


LoadNature Members

[image] [image]

Revit 2013 API
LoadNature Members
LoadNature Class Methods Properties See Also Send Feedback

The LoadNature type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Methods

[image] [image]

Revit 2013 API
LoadNature Methods
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


LoadNature Properties

[image] [image]

Revit 2013 API
LoadNature Properties
LoadNature Class See Also Send Feedback

The LoadNature type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadNature Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadNature..::..Parameter Property
LoadNature Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadNature Class
LoadNature Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Class

[image]

Revit 2013 API
LoadTypeBase Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadTypeBase : ElementType
Visual Basic
Public Class LoadTypeBase _
    Inherits ElementType
Visual C++
public ref class LoadTypeBase : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..AreaLoadType
Autodesk.Revit.DB.Structure..::..LineLoadType
Autodesk.Revit.DB.Structure..::..PointLoadType

See Also

LoadTypeBase Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Members

[image] [image]

Revit 2013 API
LoadTypeBase Members
LoadTypeBase Class Methods Properties See Also Send Feedback

The LoadTypeBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Methods

[image] [image]

Revit 2013 API
LoadTypeBase Methods
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBase Properties

[image] [image]

Revit 2013 API
LoadTypeBase Properties
LoadTypeBase Class See Also Send Feedback

The LoadTypeBase type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadTypeBase Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadTypeBase..::..Parameter Property
LoadTypeBase Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadTypeBase Class
LoadTypeBase Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Class

[image]

Revit 2013 API
LoadTypeBaseSet Class
Members See Also Send Feedback
A set that contains load type bases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadTypeBaseSet : APIObject,
    IEnumerable
Visual Basic
Public Class LoadTypeBaseSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadTypeBaseSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadTypeBaseSet

See Also

LoadTypeBaseSet Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Members

[image] [image]

Revit 2013 API
LoadTypeBaseSet Members
LoadTypeBaseSet Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Constructors

 | Name | Description
Public method | LoadTypeBaseSet | Initializes a new instance of the LoadTypeBaseSet class

Methods

 | Name | Description
Public method | Clear | Removes every load type base from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load type base within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load type base from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load type base into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Constructor

[image]

Revit 2013 API
LoadTypeBaseSet Constructor
LoadTypeBaseSet Class See Also Send Feedback
Initializes a new instance of the LoadTypeBaseSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadTypeBaseSet()
Visual Basic
Public Sub New
Visual C++
public:
LoadTypeBaseSet()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Methods

[image] [image]

Revit 2013 API
LoadTypeBaseSet Methods
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every load type base from the set, rendering it empty.
Public method | Contains | Tests for the existence of a load type base within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified load type base from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load type base into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..Clear Method
LoadTypeBaseSet Class See Also Send Feedback
Removes every load type base from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..Contains Method
LoadTypeBaseSet Class See Also Send Feedback
Tests for the existence of a load type base within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    LoadTypeBase item
)
Visual Basic
Public Overridable Function Contains ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Contains(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadTypeBase
The load type base to be searched for.

Return Value

The Contains method returns True if the load type base is within the set, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..Erase Method
LoadTypeBaseSet Class See Also Send Feedback
Removes a specified load type base from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    LoadTypeBase item
)
Visual Basic
Public Overridable Function Erase ( _
    item As LoadTypeBase _
) As Integer
Visual C++
public:
virtual int Erase(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadTypeBase
The load type base to be erased.

Return Value

The number of load type bases that were erased from the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..ForwardIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..GetEnumerator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..Insert Method
LoadTypeBaseSet Class See Also Send Feedback
Insert the specified load type base into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    LoadTypeBase item
)
Visual Basic
Public Overridable Function Insert ( _
    item As LoadTypeBase _
) As Boolean
Visual C++
public:
virtual bool Insert(
    LoadTypeBase^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadTypeBase
The load type base to be inserted into the set.

Return Value

Returns whether the load type base was inserted into the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LoadTypeBaseSet..::..ReverseIterator Method
LoadTypeBaseSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadTypeBaseSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LoadTypeBaseSetIterator
Visual C++
public:
virtual LoadTypeBaseSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSet Properties

[image] [image]

Revit 2013 API
LoadTypeBaseSet Properties
LoadTypeBaseSet Class See Also Send Feedback

The LoadTypeBaseSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of load type bases that are in the set.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LoadTypeBaseSet..::..IsEmpty Property
LoadTypeBaseSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LoadTypeBaseSet..::..Size Property
LoadTypeBaseSet Class See Also Send Feedback
Returns the number of load type bases that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadTypeBaseSet Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Class

[image]

Revit 2013 API
LoadTypeBaseSetIterator Class
Members See Also Send Feedback
An iterator to a load type base set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LoadTypeBaseSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LoadTypeBaseSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadTypeBaseSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadTypeBaseSetIterator

See Also

LoadTypeBaseSetIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Members

[image] [image]

Revit 2013 API
LoadTypeBaseSetIterator Members
LoadTypeBaseSetIterator Class Constructors Methods Properties See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LoadTypeBaseSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Constructor

[image]

Revit 2013 API
LoadTypeBaseSetIterator Constructor
LoadTypeBaseSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadTypeBaseSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
LoadTypeBaseSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Methods

[image] [image]

Revit 2013 API
LoadTypeBaseSetIterator Methods
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LoadTypeBaseSetIterator..::..MoveNext Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LoadTypeBaseSetIterator..::..Reset Method
LoadTypeBaseSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadTypeBaseSetIterator Properties

[image] [image]

Revit 2013 API
LoadTypeBaseSetIterator Properties
LoadTypeBaseSetIterator Class See Also Send Feedback

The LoadTypeBaseSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LoadTypeBaseSetIterator..::..Current Property
LoadTypeBaseSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadTypeBaseSetIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Class

[image]

Revit 2013 API
LoadUsage Class
Members See Also Send Feedback
This object represents a load case within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadUsage : Element
Visual Basic
Public Class LoadUsage _
    Inherits Element
Visual C++
public ref class LoadUsage : public Element

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadUsage

See Also

LoadUsage Members
Autodesk.Revit.DB.Structure Namespace


LoadUsage Members

[image] [image]

Revit 2013 API
LoadUsage Members
LoadUsage Class Methods Properties See Also Send Feedback

The LoadUsage type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Methods

[image] [image]

Revit 2013 API
LoadUsage Methods
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


LoadUsage Properties

[image] [image]

Revit 2013 API
LoadUsage Properties
LoadUsage Class See Also Send Feedback

The LoadUsage type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

LoadUsage Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
LoadUsage..::..Parameter Property
LoadUsage Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

LoadUsage Class
LoadUsage Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Class

[image]

Revit 2013 API
LoadUsageArray Class
Members See Also Send Feedback
An array that contains load usage objects.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class LoadUsageArray : APIObject,
    IEnumerable
Visual Basic
Public Class LoadUsageArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class LoadUsageArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadUsageArray

See Also

LoadUsageArray Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Members

[image] [image]

Revit 2013 API
LoadUsageArray Members
LoadUsageArray Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArray type exposes the following members.

Constructors

 | Name | Description
Public method | LoadUsageArray | Initializes a new instance of the LoadUsageArray class

Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Constructor

[image]

Revit 2013 API
LoadUsageArray Constructor
LoadUsageArray Class See Also Send Feedback
Initializes a new instance of the LoadUsageArray class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadUsageArray()
Visual Basic
Public Sub New
Visual C++
public:
LoadUsageArray()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Methods

[image] [image]

Revit 2013 API
LoadUsageArray Methods
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the load usage to the end of the array.
Public method | Clear | Removes every load usage from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified load usage into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Append Method

[image]

Revit 2013 API
LoadUsageArray..::..Append Method
LoadUsageArray Class See Also Send Feedback
Add the load usage to the end of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    LoadUsage item
)
Visual Basic
Public Overridable Sub Append ( _
    item As LoadUsage _
)
Visual C++
public:
virtual void Append(
    LoadUsage^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadUsage
The load usage to be added.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
LoadUsageArray..::..Clear Method
LoadUsageArray Class See Also Send Feedback
Removes every load usage from the array, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
LoadUsageArray..::..ForwardIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
LoadUsageArray..::..GetEnumerator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
LoadUsageArray..::..Insert Method
LoadUsageArray Class See Also Send Feedback
Insert the specified load usage into the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    LoadUsage item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As LoadUsage, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    LoadUsage^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..LoadUsage
The load usage to be inserted into the array.
index
Type: System..::..Int32
The load usage will be inserted before this index.

Return Value

Returns whether the load usage was inserted into the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
LoadUsageArray..::..ReverseIterator Method
LoadUsageArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadUsageArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As LoadUsageArrayIterator
Visual C++
public:
virtual LoadUsageArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArray Properties

[image] [image]

Revit 2013 API
LoadUsageArray Properties
LoadUsageArray Class See Also Send Feedback

The LoadUsageArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an load usage at a specified index within the array.
Public property | Size | Returns the number of load usages that are in the array.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
LoadUsageArray..::..IsEmpty Property
LoadUsageArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Item Property

[image]

Revit 2013 API
LoadUsageArray..::..Item Property
LoadUsageArray Class See Also Send Feedback
Gets or sets an load usage at a specified index within the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual LoadUsage this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As LoadUsage
    Get
    Set
Visual C++
public:
virtual property LoadUsage^ Item[int index] {
    LoadUsage^ get (int index);
    void set (int index, LoadUsage^ value);
}

Parameters

index
Type: System..::..Int32
The index of the load usage to be set or retrieved.

Return Value

Returns the load usage at the specified index.

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
LoadUsageArray..::..Size Property
LoadUsageArray Class See Also Send Feedback
Returns the number of load usages that are in the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

LoadUsageArray Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Class

[image]

Revit 2013 API
LoadUsageArrayIterator Class
Members See Also Send Feedback
An iterator to an load usage array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class LoadUsageArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class LoadUsageArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class LoadUsageArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..LoadUsageArrayIterator

See Also

LoadUsageArrayIterator Members
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Members

[image] [image]

Revit 2013 API
LoadUsageArrayIterator Members
LoadUsageArrayIterator Class Constructors Methods Properties See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | LoadUsageArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Constructor

[image]

Revit 2013 API
LoadUsageArrayIterator Constructor
LoadUsageArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public LoadUsageArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
LoadUsageArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Methods

[image] [image]

Revit 2013 API
LoadUsageArrayIterator Methods
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
LoadUsageArrayIterator..::..MoveNext Method
LoadUsageArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
LoadUsageArrayIterator..::..Reset Method
LoadUsageArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


LoadUsageArrayIterator Properties

[image] [image]

Revit 2013 API
LoadUsageArrayIterator Properties
LoadUsageArrayIterator Class See Also Send Feedback

The LoadUsageArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
LoadUsageArrayIterator..::..Current Property
LoadUsageArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

LoadUsageArrayIterator Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Class

[image]

Revit 2013 API
PathReinforcement Class
Members Example See Also Send Feedback
An object that represents an Path Reinforcement within the Autodesk Revit project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PathReinforcement : Element
Visual Basic
Public Class PathReinforcement _
    Inherits Element
Visual C++
public ref class PathReinforcement : public Element

Remarks

This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Path Reinforcement element is available only in the Autodesk Revit Structure product.

Examples

CopyC#
private void Getinfo_PathReinforcement(PathReinforcement pathReinforcement)
{
    string message = "PathReinforcement : ";

    // Show the NumBarDescriptions property
    message += "\nNumber of distinct bar shapes : " + pathReinforcement.NumBarDescriptions;
    for (int i = 0; i < pathReinforcement.NumBarDescriptions; i++)
    {
       BarDescription description = pathReinforcement.get_BarDescription(i);
       message += "\nBar count : " + description.Count;
       message += "\nBar type name : " + description.BarType.Name;
       message += "\nBar layer : " + description.Layer;
       message += "\nBar length : " + description.Length;
    }

    // Show the PathReinforcement Curves information
    message += "\nPath Reinforcement has " + pathReinforcement.Curves.Size + " path curves.";
    foreach (Autodesk.Revit.DB.Element ii in pathReinforcement.Curves)
    {
       ModelCurve pathCurve = ii as ModelCurve;
       if (null == pathCurve)
       {
          continue;
       }
       Curve curve = pathCurve.GeometryCurve;   // get the location curve
       XYZ start = curve.get_EndPoint(0);  // get the start point of the curve
       XYZ end = curve.get_EndPoint(1);    // get the end point of the curve
       message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
       message += "   End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_PathReinforcement(ByVal pathReinforcement As Autodesk.Revit.DB.Structure.PathReinforcement)
    Dim message As String = "PathReinforcement : "

    ' Show the NumBarDescriptions property
    message += vbLf & "Number of distinct bar shapes : " + pathReinforcement.NumBarDescriptions
    Dim i As Integer = 0
    While i < pathReinforcement.NumBarDescriptions
        Dim description As BarDescription = pathReinforcement.BarDescription(i)
        message += vbLf & "Bar count : " + description.Count
        message += vbLf & "Bar type name : " + description.BarType.Name
        message += vbLf & "Bar layer : " + description.Layer
        message += vbLf & "Bar length : " + description.Length
        System.Math.Max(System.Threading.Interlocked.Increment(i), i - 1)
    End While

    ' Show the PathReinforcement Curves information
    message += vbLf & "Path Reinforcement has " + pathReinforcement.Curves.Size + " path curves."
    For Each ii As Autodesk.Revit.DB.Element In pathReinforcement.Curves
        Dim pathCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathCurve Is Nothing Then
            Continue For
        End If
        Dim curve As Curve = pathCurve.GeometryCurve
        ' get the location curve
        Dim start As Autodesk.Revit.DB.XYZ = curve.EndPoint(0)
        ' get the start point of the curve
        Dim [end] As Autodesk.Revit.DB.XYZ = curve.EndPoint(1)
        ' get the end point of the curve
        message += vbLf & "Curve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")"
        message += "   End point (" + [end].X + ", " + [end].Y + ", " + [end].Z + ")"
    Next

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..PathReinforcement

See Also

PathReinforcement Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Members

[image] [image]

Revit 2013 API
PathReinforcement Members
PathReinforcement Class Methods Properties See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the set of ElementIds of curves forming the boundary of the Path Reinforcement.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the PathReinforcement element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RemovePathReinforcementSystem | Deletes the specified PathReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Path Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes. This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Methods

[image] [image]

Revit 2013 API
PathReinforcement Methods
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurveElementIds | Retrieves the set of ElementIds of curves forming the boundary of the Path Reinforcement.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetRebarInSystemIds | Returns the ids of the RebarInSystem elements owned by the PathReinforcement element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RemovePathReinforcementSystem | Deletes the specified PathReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


GetCurveElementIds Method

[image]

Revit 2013 API
PathReinforcement..::..GetCurveElementIds Method
PathReinforcement Class See Also Send Feedback
Retrieves the set of ElementIds of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<ElementId> GetCurveElementIds()
Visual Basic
Public Function GetCurveElementIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetCurveElementIds()

Return Value

A collection of ElementIds of ModelCurve elements.

Remarks

Each ElementId in the collection is an Id of an Element of type ModelCurve.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


GetRebarInSystemIds Method

[image]

Revit 2013 API
PathReinforcement..::..GetRebarInSystemIds Method
PathReinforcement Class See Also Send Feedback
Returns the ids of the RebarInSystem elements owned by the PathReinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<ElementId> GetRebarInSystemIds()
Visual Basic
Public Function GetRebarInSystemIds As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetRebarInSystemIds()

Remarks

The RebarInSystem elements are only created if ReinforcementSettings.HostStructuralRebar is set to true. If that setting is false, this function returns an empty array.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


RemovePathReinforcementSystem Method

[image]

Revit 2013 API
PathReinforcement..::..RemovePathReinforcementSystem Method
PathReinforcement Class See Also Send Feedback
Deletes the specified PathReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static IList<ElementId> RemovePathReinforcementSystem(
    Document doc,
    PathReinforcement system
)
Visual Basic
Public Shared Function RemovePathReinforcementSystem ( _
    doc As Document, _
    system As PathReinforcement _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ RemovePathReinforcementSystem(
    Document^ doc,
    PathReinforcement^ system
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.
system
Type: Autodesk.Revit.DB.Structure..::..PathReinforcement
A PathReinforcement element in the document.

Return Value

The ids of the newly created Rebar elements.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The document doc does not contain the element system
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcement Properties

[image] [image]

Revit 2013 API
PathReinforcement Properties
PathReinforcement Class See Also Send Feedback

The PathReinforcement type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDescription | Obsolete. Retrieves the BarDescription property of an Path Reinforcement element.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Obsolete. Retrieves the array of curves forming the boundary of the Path Reinforcement.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | NumBarDescriptions | Retrieves the number of distinct bar shapes. This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PathReinforcementType | Retrieves the type of the Path Reinforcement.
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


BarDescription Property

[image]

Revit 2013 API
PathReinforcement..::..BarDescription Property
PathReinforcement Class See Also Send Feedback
Retrieves the BarDescription property of an Path Reinforcement element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public BarDescription this[
    int idx
] { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")> _
Public ReadOnly Property BarDescription ( _
    idx As Integer _
) As BarDescription
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetRebarInSystemIds() instead.")]
public:
property BarDescription^ BarDescription[int idx] {
    BarDescription^ get (int idx);
}

Parameters

idx
Type: System..::..Int32
Index of a Bar Description.

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2013 API
PathReinforcement..::..Curves Property
PathReinforcement Class Example See Also Send Feedback
Retrieves the array of curves forming the boundary of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public ElementArray Curves { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")> _
Public ReadOnly Property Curves As ElementArray
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Call GetCurveElementIds() instead.")]
public:
property ElementArray^ Curves {
    ElementArray^ get ();
}

Remarks

Each element in the array is of type ModelCurve.

Examples

CopyC#
private void Getinfo_PathReinforcementCurve(PathReinforcement pathReinforcement)
{
    string message = "Path Reinforcement Curves : ";

    // Get path reinforcement curves by iterating the Curves property
    foreach (Autodesk.Revit.DB.Element ii in pathReinforcement.Curves)
    {
        ModelCurve pathReinforcementCurve = ii as ModelCurve;
        if (null == pathReinforcementCurve)
        {
            continue;
        }

        Autodesk.Revit.DB.Curve curve = pathReinforcementCurve.GeometryCurve;

        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";

    }
    TaskDialog.Show("Revit",message);

}
CopyVB.NET
Private Sub Getinfo_PathReinforcementCurve(ByVal pathReinforcement As Autodesk.Revit.DB.Structure.PathReinforcement)
    Dim message As String = "Path Reinforcement Curves : "

    ' Get path reinforcement curves by iterating the Curves property
    For Each ii As Autodesk.Revit.DB.Element In pathReinforcement.Curves
        Dim pathReinforcementCurve As ModelCurve = TryCast(ii, ModelCurve)
        If pathReinforcementCurve Is Nothing Then
            Continue For
        End If

        Dim curve As Autodesk.Revit.DB.Curve = pathReinforcementCurve.GeometryCurve

        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point

        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next
    TaskDialog.Show("Revit", message)

End Sub

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


NumBarDescriptions Property

[image]

Revit 2013 API
PathReinforcement..::..NumBarDescriptions Property
PathReinforcement Class See Also Send Feedback
Retrieves the number of distinct bar shapes. This property is deprecated in Revit 2013. Use GetRebarInSystemIds instead.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumBarDescriptions { get; }
Visual Basic
Public ReadOnly Property NumBarDescriptions As Integer
    Get
Visual C++
public:
property int NumBarDescriptions {
    int get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
PathReinforcement..::..Parameter Property
PathReinforcement Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PathReinforcement Class
PathReinforcement Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Property

[image]

Revit 2013 API
PathReinforcement..::..PathReinforcementType Property
PathReinforcement Class See Also Send Feedback
Retrieves the type of the Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PathReinforcementType PathReinforcementType { get; }
Visual Basic
Public ReadOnly Property PathReinforcementType As PathReinforcementType
    Get
Visual C++
public:
property PathReinforcementType^ PathReinforcementType {
    PathReinforcementType^ get ();
}

See Also

PathReinforcement Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Class

[image]

Revit 2013 API
PathReinforcementType Class
Members See Also Send Feedback
An object that specifies the type of a Structural Path Reinforcement element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PathReinforcementType : ElementType
Visual Basic
Public Class PathReinforcementType _
    Inherits ElementType
Visual C++
public ref class PathReinforcementType : public ElementType

Remarks

The clear cover settings can be accessed via this object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..PathReinforcementType

See Also

PathReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Members

[image] [image]

Revit 2013 API
PathReinforcementType Members
PathReinforcementType Class Methods Properties See Also Send Feedback

The PathReinforcementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Methods

[image] [image]

Revit 2013 API
PathReinforcementType Methods
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


PathReinforcementType Properties

[image] [image]

Revit 2013 API
PathReinforcementType Properties
PathReinforcementType Class See Also Send Feedback

The PathReinforcementType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PathReinforcementType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
PathReinforcementType..::..Parameter Property
PathReinforcementType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PathReinforcementType Class
PathReinforcementType Members
Autodesk.Revit.DB.Structure Namespace


PointLoad Class

[image]

Revit 2013 API
PointLoad Class
Members Example See Also Send Feedback
An object that represents a force/moment applied to a single point.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointLoad : LoadBase
Visual Basic
Public Class PointLoad _
    Inherits LoadBase
Visual C++
public ref class PointLoad : public LoadBase

Examples

CopyC#
private void Getinfo_PointLoad(PointLoad pointLoad)
{
    string message = "Point Load :";

    // Get the load case name
    message += "\nLoad case for load: " + pointLoad.LoadCaseName;

    //get the three dimensional force applied to the point load
    message += "\nForce: (" + pointLoad.Force.X + ", " +
             pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")";

    //get the three dimensional moment application to the point load
    message += "\nMoment: (" + pointLoad.Moment.X + ", " +
             pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")";

    //get the three dimensional coordinates of point load
    message += "\nPoint load location: (" + pointLoad.Point.X + ", " +
             pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")";

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_PointLoad(ByVal pointLoad As Autodesk.Revit.DB.Structure.PointLoad)
    Dim message As String = "Point Load :"

    ' Get the load case name
    message += vbLf & "Load case for load: " + pointLoad.LoadCaseName

    'get the three dimensional force applied to the point load
    message += vbLf & "Force: (" + pointLoad.Force.X + ", " + pointLoad.Force.Y + ", " + pointLoad.Force.Z + ")"

    'get the three dimensional moment application to the point load
    message += vbLf & "Moment: (" + pointLoad.Moment.X + ", " + pointLoad.Moment.Y + ", " + pointLoad.Moment.Z + ")"

    'get the three dimensional coordinates of point load
    message += vbLf & "Point load location: (" + pointLoad.Point.X + ", " + pointLoad.Point.Y + ", " + pointLoad.Point.Z + ")"

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..LoadBase
Autodesk.Revit.DB.Structure..::..PointLoad

See Also

PointLoad Members
Autodesk.Revit.DB.Structure Namespace


PointLoad Members

[image] [image]

Revit 2013 API
PointLoad Members
PointLoad Class Methods Properties See Also Send Feedback

The PointLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to the point load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment application to the point load.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Returns the three dimensional coordinates of point load.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoad Methods

[image] [image]

Revit 2013 API
PointLoad Methods
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoad Properties

[image] [image]

Revit 2013 API
PointLoad Properties
PointLoad Class See Also Send Feedback

The PointLoad type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Force | Returns the three dimensional force applied to the point load.
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HostElement | The host element for the load. (Inherited from LoadBase.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | LoadCaseName | The name of the load case to which this load belongs. (Inherited from LoadBase.)
Public property | LoadCategoryName | The name of the category to which this load belongs. (Inherited from LoadBase.)
Public property | LoadNatureName | A string representing the nature of the load. (Inherited from LoadBase.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Moment | Returns the three dimensional moment application to the point load.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Point | Returns the three dimensional coordinates of point load.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Force Property

[image]

Revit 2013 API
PointLoad..::..Force Property
PointLoad Class See Also Send Feedback
Returns the three dimensional force applied to the point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Force { get; }
Visual Basic
Public ReadOnly Property Force As XYZ
    Get
Visual C++
public:
property XYZ^ Force {
    XYZ^ get ();
}

Remarks

The force is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Moment Property

[image]

Revit 2013 API
PointLoad..::..Moment Property
PointLoad Class See Also Send Feedback
Returns the three dimensional moment application to the point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Moment { get; }
Visual Basic
Public ReadOnly Property Moment As XYZ
    Get
Visual C++
public:
property XYZ^ Moment {
    XYZ^ get ();
}

Remarks

The moment is measured in Feet*Kg / Sec.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
PointLoad..::..Parameter Property
PointLoad Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PointLoad Class
PointLoad Members
Autodesk.Revit.DB.Structure Namespace


Point Property

[image]

Revit 2013 API
PointLoad..::..Point Property
PointLoad Class See Also Send Feedback
Returns the three dimensional coordinates of point load.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Point { get; }
Visual Basic
Public ReadOnly Property Point As XYZ
    Get
Visual C++
public:
property XYZ^ Point {
    XYZ^ get ();
}

Remarks

The location is measured in decimal feet.

See Also

PointLoad Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Class

[image]

Revit 2013 API
PointLoadType Class
Members See Also Send Feedback
An object that represents a Load type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointLoadType : LoadTypeBase
Visual Basic
Public Class PointLoadType _
    Inherits LoadTypeBase
Visual C++
public ref class PointLoadType : public LoadTypeBase

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..LoadTypeBase
Autodesk.Revit.DB.Structure..::..PointLoadType

See Also

PointLoadType Members
Autodesk.Revit.DB.Structure Namespace


PointLoadType Members

[image] [image]

Revit 2013 API
PointLoadType Members
PointLoadType Class Methods Properties See Also Send Feedback

The PointLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Methods

[image] [image]

Revit 2013 API
PointLoadType Methods
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


PointLoadType Properties

[image] [image]

Revit 2013 API
PointLoadType Properties
PointLoadType Class See Also Send Feedback

The PointLoadType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

PointLoadType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
PointLoadType..::..Parameter Property
PointLoadType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

PointLoadType Class
PointLoadType Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Class

[image]

Revit 2013 API
PointLoadTypeSet Class
Members See Also Send Feedback
A set that contains pointload types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class PointLoadTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class PointLoadTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class PointLoadTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..PointLoadTypeSet

See Also

PointLoadTypeSet Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Members

[image] [image]

Revit 2013 API
PointLoadTypeSet Members
PointLoadTypeSet Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | PointLoadTypeSet | Initializes a new instance of the PointLoadTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every pointload type from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Constructor

[image]

Revit 2013 API
PointLoadTypeSet Constructor
PointLoadTypeSet Class See Also Send Feedback
Initializes a new instance of the PointLoadTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointLoadTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
PointLoadTypeSet()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Methods

[image] [image]

Revit 2013 API
PointLoadTypeSet Methods
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every pointload type from the set, rendering it empty.
Public method | Contains |
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase |
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert |
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
PointLoadTypeSet..::..Clear Method
PointLoadTypeSet Class See Also Send Feedback
Removes every pointload type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
PointLoadTypeSet..::..Contains Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    PointLoadType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
PointLoadTypeSet..::..Erase Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    PointLoadType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As PointLoadType _
) As Integer
Visual C++
public:
virtual int Erase(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
PointLoadTypeSet..::..ForwardIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
PointLoadTypeSet..::..GetEnumerator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
PointLoadTypeSet..::..Insert Method
PointLoadTypeSet Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    PointLoadType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As PointLoadType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    PointLoadType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..PointLoadType

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
PointLoadTypeSet..::..ReverseIterator Method
PointLoadTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual PointLoadTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As PointLoadTypeSetIterator
Visual C++
public:
virtual PointLoadTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSet Properties

[image] [image]

Revit 2013 API
PointLoadTypeSet Properties
PointLoadTypeSet Class See Also Send Feedback

The PointLoadTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of pointload types that are in the set.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
PointLoadTypeSet..::..IsEmpty Property
PointLoadTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
PointLoadTypeSet..::..Size Property
PointLoadTypeSet Class See Also Send Feedback
Returns the number of pointload types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

PointLoadTypeSet Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Class

[image]

Revit 2013 API
PointLoadTypeSetIterator Class
Members See Also Send Feedback
An iterator to a pointload type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class PointLoadTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class PointLoadTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class PointLoadTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..PointLoadTypeSetIterator

See Also

PointLoadTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Members

[image] [image]

Revit 2013 API
PointLoadTypeSetIterator Members
PointLoadTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | PointLoadTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Constructor

[image]

Revit 2013 API
PointLoadTypeSetIterator Constructor
PointLoadTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public PointLoadTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
PointLoadTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Methods

[image] [image]

Revit 2013 API
PointLoadTypeSetIterator Methods
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
PointLoadTypeSetIterator..::..MoveNext Method
PointLoadTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
PointLoadTypeSetIterator..::..Reset Method
PointLoadTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PointLoadTypeSetIterator Properties

[image] [image]

Revit 2013 API
PointLoadTypeSetIterator Properties
PointLoadTypeSetIterator Class See Also Send Feedback

The PointLoadTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
PointLoadTypeSetIterator..::..Current Property
PointLoadTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

PointLoadTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


PositionOnCurve Enumeration

[image]

Revit 2013 API
PositionOnCurve Enumeration
See Also Send Feedback
Specifies position on analytical curve to calculate direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PositionOnCurve
Visual Basic
Public Enumeration PositionOnCurve
Visual C++
public enum class PositionOnCurve

Members

Member name | Description
StartPointPosition | Direction in start point of analytical curve.
EndPointPosition | Direction in end point of analytical curve.
MainPosition | Common direction from start to end points.

See Also

Autodesk.Revit.DB.Structure Namespace


Rebar Class

[image]

Revit 2013 API
Rebar Class
Members Example See Also Send Feedback
Represents a rebar element in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public class Rebar : Element
Visual Basic
Public Class Rebar _
    Inherits Element
Visual C++
public ref class Rebar : public Element

Examples

CopyC#
private void Getinfo_Rebar(Rebar rebar)
{
    string message = "Rebar: ";
    //get the bar type of the rebar
    message += "\nBar Type: " + rebar.BarType.Name;

    //get the curve information
    IList<Curve> curves = rebar.GetCenterlineCurves(false, false, false);
    message += "\n\nThe Curves property has " + curves.Count + " curves:";
    foreach (Curve curve in curves)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.get_EndPoint(0).X + ", "
            + curve.get_EndPoint(0).Y + ", " + curve.get_EndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.get_EndPoint(1).X + ", "
            + curve.get_EndPoint(1).Y + ", " + curve.get_EndPoint(1).Z + ")";
    }

    //get the host element of the rebar
    if (null != rebar.Host) //maybe some rebars don't have host
    {
        message += "\n\nThe host element ID : " + rebar.Host.Id.IntegerValue;
    }

    TaskDialog.Show("Revit",message);
}
CopyVB.NET
Private Sub Getinfo_Rebar(ByVal rebar As Autodesk.Revit.DB.Structure.Rebar)
    Dim message As String = "Rebar: "
    'get the bar type of the rebar
    message += vbLf & "Bar Type: " + rebar.BarType.Name

    'get the curve information
    Dim curves As CurveArray = rebar.Curves
    message += vbLf & vbLf & "The Curves property has " + curves.Size + " curves:"
    For Each curve As Curve In curves
        ' Get curve start point
        message += vbLf & "Curve start point:(" + curve.EndPoint(0).X + ", " + curve.EndPoint(0).Y + ", " + curve.EndPoint(0).Z + ")"
        ' Get curve end point
        message += "; Curve end point:(" + curve.EndPoint(1).X + ", " + curve.EndPoint(1).Y + ", " + curve.EndPoint(1).Z + ")"
    Next

    'get the host element of the rebar
    If rebar.Host IsNot Nothing Then
        'maybe some rebars don't have host
        message += vbLf & vbLf & "The host element ID : " + rebar.Host.Id.IntegerValue
    End If

    TaskDialog.Show("Revit", message)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..Rebar

See Also

Rebar Members
Autodesk.Revit.DB.Structure Namespace


Rebar Members

[image] [image]

Revit 2013 API
Rebar Members
Rebar Class Methods Properties See Also Send Feedback

The Rebar type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateFromCurves | Creates a new instance of a Rebar element within the project.
 | CreateFromCurvesAndShape | Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.
 | CreateFromRebarShape | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RebarShapeMatchesCurvesAndHooks | Checks if rebarShape matches curves and hooks.
Public method | ScaleToBox | Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.
Public method | ScaleToBoxFor3D | Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetHookTypeId | Set the id of the RebarHookType to be applied to the rebar.
Public method | SetHostId | The element that contains the rebar.
Public method | SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
Public method | SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
Public method | SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method | SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method | SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
Public method | SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
Public method | SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BarType | Obsolete. Return the type of the rebar.
Public property | BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistributionPath | Obsolete. For Rebar with an array layout, return the distribution path (a line).
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | For a spiral, the overall height.
Public property | Host | Obsolete. The element that contains the rebar.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IncludeFirstBar | Identifies if the first bar in rebar set is shown.
Public property | IncludeLastBar | Identifies if the last bar in rebar set is shown.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | MultiplanarDepth | For a multiplanar rebar, the depth of the instance.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions | The number of potential bars in the set.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShape | Obsolete. Get/Set the RebarShape associated with the Rebar.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of an individual bar multiplied by Quantity.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Rebar Methods

[image] [image]

Revit 2013 API
Rebar Methods
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | CreateFromCurves | Creates a new instance of a Rebar element within the project.
 | CreateFromCurvesAndShape | Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.
 | CreateFromRebarShape | Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
 | RebarShapeMatchesCurvesAndHooks | Checks if rebarShape matches curves and hooks.
Public method | ScaleToBox | Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.
Public method | ScaleToBoxFor3D | Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetHookTypeId | Set the id of the RebarHookType to be applied to the rebar.
Public method | SetHostId | The element that contains the rebar.
Public method | SetLayoutAsFixedNumber | Sets the Layout Rule property of rebar set to FixedNumber.
Public method | SetLayoutAsMaximumSpacing | Sets the Layout Rule property of rebar set to MaximumSpacing
Public method | SetLayoutAsMinimumClearSpacing | Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method | SetLayoutAsNumberWithSpacing | Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method | SetLayoutAsSingle | Sets the Layout Rule property of rebar set to Single.
Public method | SetSolidInView | Sets this rebar element to be shown solidly in a 3D view.
Public method | SetUnobscuredInView | Sets this rebar element to be shown unobscured in a view.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


CreateFromCurves Method

[image]

Revit 2013 API
Rebar..::..CreateFromCurves Method
Rebar Class Example See Also Send Feedback
Creates a new instance of a Rebar element within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public static Rebar CreateFromCurves(
    Document doc,
    RebarStyle style,
    RebarBarType barType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    IList<Curve> curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)
Visual Basic
Public Shared Function CreateFromCurves ( _
    doc As Document, _
    style As RebarStyle, _
    barType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation, _
    useExistingShapeIfPossible As Boolean, _
    createNewShape As Boolean _
) As Rebar
Visual C++
public:
static Rebar^ CreateFromCurves(
    Document^ doc,
    RebarStyle style,
    RebarBarType^ barType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient,
    bool useExistingShapeIfPossible,
    bool createNewShape
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
host
Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
useExistingShapeIfPossible
Type: System..::..Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true".
createNewShape
Type: System..::..Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.

Return Value

The newly created Rebar instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Examples

CopyC#
Rebar CreateRebar(Autodesk.Revit.DB.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
    // Define the rebar geometry information - Line rebar
    LocationPoint location = column.Location as LocationPoint;
    XYZ origin = location.Point;
    XYZ normal = new XYZ(1, 0, 0);
    XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
    Line rebarLine = document.Application.Create.NewLineBound(origin, rebarLineEnd);

    // Create the line rebar
    IList<Curve> curves = new List<Curve>();
    curves.Add(rebarLine);

    Rebar rebar = Rebar.CreateFromCurves(document, Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, hookType, hookType,
                        column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);

    if (null != rebar)
    {
        // set specific layout for new rebar
        Parameter paramLayout = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE);
        paramLayout.Set(1); // 1 = Fixed Number
        Parameter paramNum = rebar.get_Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS);
        paramNum.Set(10);
        rebar.ArrayLength = 1.5;
    }

    return rebar;
}
CopyVB.NET
Function CreateRebar(ByVal document As Autodesk.Revit.DB.Document, ByVal column As Autodesk.Revit.DB.FamilyInstance, _
                     ByVal barType As Autodesk.Revit.DB.Structure.RebarBarType, _
                     ByVal hookType As Autodesk.Revit.DB.Structure.RebarHookType) _
                     As Autodesk.Revit.DB.Structure.Rebar
    ' Define the rebar geometry information - Line rebar
    Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
    Dim origin As Autodesk.Revit.DB.XYZ = location.Point
    Dim normal As New Autodesk.Revit.DB.XYZ(1, 0, 0)
    Dim rebarLineEnd As New Autodesk.Revit.DB.XYZ(origin.X, origin.Y, origin.Z + 9)
    Dim rebarLine As Line = document.Application.Create.NewLineBound(origin, rebarLineEnd)

    ' Create the line rebar
    Dim curves As New CurveArray()
    curves.Append(rebarLine)

    Dim rebar As Autodesk.Revit.DB.Structure.Rebar = _
        document.Create.NewRebar(Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, _
                                 hookType, hookType, column, origin, curves, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Right, _
                                 Autodesk.Revit.DB.Structure.RebarHookOrientation.Left, True, True)

    If rebar IsNot Nothing Then
        ' set specific layout for new rebar
        Dim paramLayout As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_LAYOUT_RULE)
        paramLayout.[Set](1)
        ' 1 = Fixed Number
        Dim paramNum As Parameter = rebar.Parameter(BuiltInParameter.REBAR_ELEM_QUANTITY_OF_BARS)
        paramNum.[Set](10)
        rebar.ArrayLength = 1.5
    End If

    Return rebar
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host. -or- curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Both useExistingShapeIfPossible and createNewShape are false.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


CreateFromCurvesAndShape Method

[image]

Revit 2013 API
Rebar..::..CreateFromCurvesAndShape Method
Rebar Class See Also Send Feedback
Creates a new instance of a Rebar element within the project. The instance will have the default shape parameters from the RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static Rebar CreateFromCurvesAndShape(
    Document doc,
    RebarShape rebarShape,
    RebarBarType barType,
    RebarHookType startHook,
    RebarHookType endHook,
    Element host,
    XYZ norm,
    IList<Curve> curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)
Visual Basic
Public Shared Function CreateFromCurvesAndShape ( _
    doc As Document, _
    rebarShape As RebarShape, _
    barType As RebarBarType, _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    host As Element, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation _
) As Rebar
Visual C++
public:
static Rebar^ CreateFromCurvesAndShape(
    Document^ doc,
    RebarShape^ rebarShape,
    RebarBarType^ barType,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    Element^ host,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
rebarShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar. A RebarShape element matches curves and hooks. A RebarShape element provides RebarStyle of the rebar.
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
host
Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Return Value

The newly created Rebar instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host. -or- curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | rebarShape does not match curves.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


CreateFromRebarShape Method

[image]

Revit 2013 API
Rebar..::..CreateFromRebarShape Method
Rebar Class See Also Send Feedback
Creates a new Rebar, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public static Rebar CreateFromRebarShape(
    Document doc,
    RebarShape rebarShape,
    RebarBarType barType,
    Element host,
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic
Public Shared Function CreateFromRebarShape ( _
    doc As Document, _
    rebarShape As RebarShape, _
    barType As RebarBarType, _
    host As Element, _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
) As Rebar
Visual C++
public:
static Rebar^ CreateFromRebarShape(
    Document^ doc,
    RebarShape^ rebarShape,
    RebarBarType^ barType,
    Element^ host,
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
rebarShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar.
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
host
Type: Autodesk.Revit.DB..::..Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
origin
Type: Autodesk.Revit.DB..::..XYZ
The lower-left corner of the shape's bounding box will be placed at this point in the project.
xVec
Type: Autodesk.Revit.DB..::..XYZ
The x-axis in the shape definition will be mapped to this direction in the project.
yVec
Type: Autodesk.Revit.DB..::..XYZ
The y-axis in the shape definition will be mapped to this direction in the project.

Return Value

The newly created Rebar instance, or nullNothingnullptra null reference (Nothing in Visual Basic) if the operation fails.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | host is not a valid rebar host.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xVec has zero length. -or- yVec has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


DoesBarExistAtPosition Method

[image]

Revit 2013 API
Rebar..::..DoesBarExistAtPosition Method
Rebar Class See Also Send Feedback
Checks whether a bar exists at the specified position.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DoesBarExistAtPosition(
    int barPosition
)
Visual Basic
Public Function DoesBarExistAtPosition ( _
    barPosition As Integer _
) As Boolean
Visual C++
public:
bool DoesBarExistAtPosition(
    int barPosition
)

Parameters

barPosition
Type: System..::..Int32
A bar position index between 0 and NumberOfBarPositions-1.

Remarks

Returns true, unless the bar position is the first or last in the set and it is suppressed by IncludeFirstBar or IncludeLastBar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPosition is not in the range [ 0, NumberOfBarPositions-1 ].

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


GetBarPositionTransform Method

[image]

Revit 2013 API
Rebar..::..GetBarPositionTransform Method
Rebar Class See Also Send Feedback
Return a transform representing the relative position of any individual bar in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Transform GetBarPositionTransform(
    int barPositionIndex
)
Visual Basic
Public Function GetBarPositionTransform ( _
    barPositionIndex As Integer _
) As Transform
Visual C++
public:
Transform^ GetBarPositionTransform(
    int barPositionIndex
)

Parameters

barPositionIndex
Type: System..::..Int32
An index between 0 and (NumberOfBarPositions-1).

Return Value

The position of a bar in the set relative to the first position.

Remarks

The transform is a translation along the distribution path. It can be applied to the results of GetCenterlineCurves() to produce any bar in the rebar set. For barPositionIndex=0, the identity transform is always returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


GetBendData Method

[image]

Revit 2013 API
Rebar..::..GetBendData Method
Rebar Class See Also Send Feedback
Gets the RebarBendData, containing bar and hook information, of the instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public RebarBendData GetBendData()
Visual Basic
Public Function GetBendData As RebarBendData
Visual C++
public:
RebarBendData^ GetBendData()

Remarks

Internally, the bend data is used by many RebarShape methods to generate shape geometry.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


GetCenterlineCurves Method

[image] [image]

Revit 2013 API
Rebar..::..GetCenterlineCurves Method
Rebar Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetCenterlineCurves(Boolean) | Obsolete. A chain of curves representing the centerline of the rebar.
Public method | GetCenterlineCurves(Boolean, Boolean, Boolean) | A chain of curves representing the centerline of the rebar.

See Also

Rebar Class
Rebar Members
Autodesk.Revit.DB.Structure Namespace


GetCenterlineCurves Method (Boolean)

[image]

Revit 2013 API
Rebar..::..GetCenterlineCurves Method (Boolean)
Rebar Class See Also Send Feedback
A chain of curves representing the centerline of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")]
public IList<Curve> GetCenterlineCurves(
    bool adjustForSelfIntersection
)
Visual Basic
<ObsoleteAttribute("This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")> _
Public Function GetCenterlineCurves ( _
    adjustForSelfIntersection As Boolean _
) As IList(Of Curve)
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Autodesk Revit 2013. Call the three-argument function with the same name instead.")]
public:
IList<Curve^>^ GetCenterlineCurves(
    bool adjustForSelfIntersection
)

Parameters

adjustForSelfIntersection
Type: System..::..Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).

Return Value

The centerline curves, including the hooks and bends, or an empty array if the curves cannot be computed because the parameter values are inconsistent with the constraints of the RebarShape definition.

Remarks

If the Rebar is a set, meaning GetLayoutRule() does not return Single, this method returns the first rebar in the set, even if the first bar is suppressed by IncludeFirstBar being false. This function is equivalent to calling GetCenterlineCurves(adjustForSelfIntersection, false, false).

See Also

Rebar Class
GetCenterlineCurves Overload
Autodesk.Revit.DB.Structure Namespace


GetCenterlineCurves Method (Boolean, Boolean, Boolean)

[image]

Revit 2013 API
Rebar..::..GetCenterlineCurves Method (Boolean, Boolean, Boolean)
Rebar Class See Also Send Feedback
A chain of curves representing the centerline of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetCenterlineCurves(
    bool adjustForSelfIntersection,
    bool suppressHooks,
    bool suppressBendRadius
)
Visual Basic
Public Function GetCenterlineCurves ( _
    adjustForSelfIntersection As Boolean, _
    suppressHooks As Boolean, _
    suppressBendRadius As Boolean _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCenterlineCurves(
    bool adjustForSelfIntersection,
    bool suppressHooks,
    bool suppressBendRadius
)

Parameters

adjustForSelfIntersection
Type: System..::..Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
suppressHooks
Type: System..::..Boolean
Identifies if the chain will include hooks curves.
suppressBendRadius
Type: System..::..Boolean
Identifies if the connected chain will include unfilleted curves.

Return Value

The centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.

Remarks

If the Rebar is a set, meaning GetLayoutRule() does not return Single, this method returns the first rebar in the set, even if the first bar is suppressed by IncludeFirstBar being false.

See Also

Rebar Class
GetCenterlineCurves Overload
Autodesk.Revit.DB.Structure Namespace


GetDistributionPath Method

[image]

Revit 2013 API
Rebar..::..GetDistributionPath Method
Rebar Class See Also Send Feedback
The distribution path of a rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Line GetDistributionPath()
Visual Basic
Public Function GetDistributionPath As Line
Visual C++
public:
Line^ GetDistributionPath()

Return Value

A line beginning at (0, 0, 0) and representing the direction and length of the set.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


GetHookTypeId Method

[image]

Revit 2013 API
Rebar..::..GetHookTypeId Method
Rebar Class See Also Send Feedback
Get the id of the RebarHookType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public ElementId GetHookTypeId(
    int end
)
Visual Basic
Public Function GetHookTypeId ( _
    end As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetHookTypeId(
    int end
)

Parameters

end
Type: System..::..Int32
0 for the start hook, 1 for the end hook.

Return Value

The id of a RebarHookType, or invalidElementId if the rebar has no hook at the specified end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


GetHostId Method

[image]

Revit 2013 API
Rebar..::..GetHostId Method
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public ElementId GetHostId()
Visual Basic
Public Function GetHostId As ElementId
Visual C++
public:
ElementId^ GetHostId()

Return Value

The element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IsSolidInView Method

[image]

Revit 2013 API
Rebar..::..IsSolidInView Method
Rebar Class See Also Send Feedback
Checks if this rebar element is shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSolidInView(
    View3D view
)
Visual Basic
Public Function IsSolidInView ( _
    view As View3D _
) As Boolean
Visual C++
public:
bool IsSolidInView(
    View3D^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View3D
The 3D view element

Return Value

True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element doesn't have valid visibility data.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IsUnobscuredInView Method

[image]

Revit 2013 API
Rebar..::..IsUnobscuredInView Method
Rebar Class See Also Send Feedback
Checks if this rebar element is shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsUnobscuredInView(
    View view
)
Visual Basic
Public Function IsUnobscuredInView ( _
    view As View _
) As Boolean
Visual C++
public:
bool IsUnobscuredInView(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view element

Return Value

True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element doesn't have valid visibility data.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeMatchesCurvesAndHooks Method

[image]

Revit 2013 API
Rebar..::..RebarShapeMatchesCurvesAndHooks Method
Rebar Class See Also Send Feedback
Checks if rebarShape matches curves and hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static bool RebarShapeMatchesCurvesAndHooks(
    RebarShape rebarShape,
    RebarBarType barType,
    XYZ norm,
    IList<Curve> curves,
    RebarHookType startHook,
    RebarHookType endHook,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)
Visual Basic
Public Shared Function RebarShapeMatchesCurvesAndHooks ( _
    rebarShape As RebarShape, _
    barType As RebarBarType, _
    norm As XYZ, _
    curves As IList(Of Curve), _
    startHook As RebarHookType, _
    endHook As RebarHookType, _
    startHookOrient As RebarHookOrientation, _
    endHookOrient As RebarHookOrientation _
) As Boolean
Visual C++
public:
static bool RebarShapeMatchesCurvesAndHooks(
    RebarShape^ rebarShape,
    RebarBarType^ barType,
    XYZ^ norm,
    IList<Curve^>^ curves,
    RebarHookType^ startHook,
    RebarHookType^ endHook,
    RebarHookOrientation startHookOrient,
    RebarHookOrientation endHookOrient
)

Parameters

rebarShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar.
barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
norm
Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
curves
Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
startHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
endHook
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is nullNothingnullptra null reference (Nothing in Visual Basic), it means to create a rebar with no hook.
startHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
endHookOrient
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."

Return Value

True if rebarShape matches curves and hooks.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | curves is empty. -or- curves contains a curve that is neither a line nor an arc. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | norm has zero length.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ScaleToBox Method

[image]

Revit 2013 API
Rebar..::..ScaleToBox Method
Rebar Class See Also Send Feedback
Move and resize the bar to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. The algorithm then proceeds as follows. First the bar is given the default values of the shape parameters from the shape definition. Then, if it is possible to do so without violating the shape definition, the parameter values are scaled so that the width and height of the shape match the lengths of xVec and yVec. If there is no way to do this within the shape definition due to overconstraining, a compromise is attempted, such as scaling the whole shape until either the width or the height is correct. Finally the shape is rotated to match the coordinate system of the box. The algorithm is the same one used in one-click placement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void ScaleToBox(
    XYZ origin,
    XYZ xVec,
    XYZ yVec
)
Visual Basic
Public Sub ScaleToBox ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ _
)
Visual C++
public:
void ScaleToBox(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xVec has zero length. -or- yVec has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape.
Autodesk.Revit.Exceptions..::..InvalidOperationException | The operation has failed for geometric reasons, such as the box being too small given the bar diameter.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ScaleToBoxFor3D Method

[image]

Revit 2013 API
Rebar..::..ScaleToBoxFor3D Method
Rebar Class See Also Send Feedback
Move and resize a spiral or multiplanar instance to fit within a specified box. The arguments are interpreted as an arbitrary rectangle in 3D with vertices: origin, origin+xVec, origin+xVec+yVec, origin+yVec. One end of the rebar shape is inscribed in this rectangle. The other end is placed in the parallel plane at distance given by the height argument, in the direction of xVec cross yVec. This method replaces ScaleToBoxForSpiral() from prior releases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void ScaleToBoxFor3D(
    XYZ origin,
    XYZ xVec,
    XYZ yVec,
    double height
)
Visual Basic
Public Sub ScaleToBoxFor3D ( _
    origin As XYZ, _
    xVec As XYZ, _
    yVec As XYZ, _
    height As Double _
)
Visual C++
public:
void ScaleToBoxFor3D(
    XYZ^ origin,
    XYZ^ xVec,
    XYZ^ yVec,
    double height
)

Parameters

origin
Type: Autodesk.Revit.DB..::..XYZ
One corner of the rectangle.
xVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the first edge of the rectangle. The length must be positive.
yVec
Type: Autodesk.Revit.DB..::..XYZ
Vector representing the second edge of the rectangle. Must be perpendicular to xVec.
height
Type: System..::..Double
New value for the Height or MultiplanarDepth property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | xVec has zero length. -or- yVec has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral or multiplanar shape. -or- The operation has failed for geometric reasons, such as the box being too small given the bar diameter.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetHookTypeId Method

[image]

Revit 2013 API
Rebar..::..SetHookTypeId Method
Rebar Class See Also Send Feedback
Set the id of the RebarHookType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetHookTypeId(
    int end,
    ElementId hookTypeId
)
Visual Basic
Public Sub SetHookTypeId ( _
    end As Integer, _
    hookTypeId As ElementId _
)
Visual C++
public:
void SetHookTypeId(
    int end,
    ElementId^ hookTypeId
)

Parameters

end
Type: System..::..Int32
0 for the start hook, 1 for the end hook.
hookTypeId
Type: Autodesk.Revit.DB..::..ElementId
The id of a RebarHookType element, or invalidElementId if the rebar should have no hook at the specified end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetHostId Method

[image]

Revit 2013 API
Rebar..::..SetHostId Method
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetHostId(
    Document doc,
    ElementId hostId
)
Visual Basic
Public Sub SetHostId ( _
    doc As Document, _
    hostId As ElementId _
)
Visual C++
public:
void SetHostId(
    Document^ doc,
    ElementId^ hostId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document containing both this element and the host element.
hostId
Type: Autodesk.Revit.DB..::..ElementId
The element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column. The rebar does not need to be strictly inside the host, but it must be assigned to one host element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | hostId is not a legal Rebar host (see the RebarHostData class).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsFixedNumber Method

[image]

Revit 2013 API
Rebar..::..SetLayoutAsFixedNumber Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to FixedNumber.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetLayoutAsFixedNumber(
    int numberOfBarPositions,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic
Public Sub SetLayoutAsFixedNumber ( _
    numberOfBarPositions As Integer, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsFixedNumber(
    int numberOfBarPositions,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

numberOfBarPositions
Type: System..::..Int32
The number of bar positions in rebar set
arrayLength
Type: System..::..Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::..Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::..Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::..Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to FixedNumber, you must also simultaneously set NumberOfBarPositions, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsMaximumSpacing Method

[image]

Revit 2013 API
Rebar..::..SetLayoutAsMaximumSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to MaximumSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetLayoutAsMaximumSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic
Public Sub SetLayoutAsMaximumSpacing ( _
    spacing As Double, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsMaximumSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

spacing
Type: System..::..Double
The maximum spacing between rebar in rebar set
arrayLength
Type: System..::..Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::..Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::..Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::..Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to MaximumSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsMinimumClearSpacing Method

[image]

Revit 2013 API
Rebar..::..SetLayoutAsMinimumClearSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to MinimumClearSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic
Public Sub SetLayoutAsMinimumClearSpacing ( _
    spacing As Double, _
    arrayLength As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsMinimumClearSpacing(
    double spacing,
    double arrayLength,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

spacing
Type: System..::..Double
The maximum spacing between rebar in rebar set
arrayLength
Type: System..::..Double
The distribution length of rebar set
barsOnNormalSide
Type: System..::..Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::..Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::..Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to MinimumClearSpacing, you must also simultaneously set Spacing, SetLength, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The spacing isn't bigger than 0.0. -or- the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsNumberWithSpacing Method

[image]

Revit 2013 API
Rebar..::..SetLayoutAsNumberWithSpacing Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to NumberWithSpacing

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)
Visual Basic
Public Sub SetLayoutAsNumberWithSpacing ( _
    numberOfBarPositions As Integer, _
    spacing As Double, _
    barsOnNormalSide As Boolean, _
    includeFirstBar As Boolean, _
    includeLastBar As Boolean _
)
Visual C++
public:
void SetLayoutAsNumberWithSpacing(
    int numberOfBarPositions,
    double spacing,
    bool barsOnNormalSide,
    bool includeFirstBar,
    bool includeLastBar
)

Parameters

numberOfBarPositions
Type: System..::..Int32
The number of bar positions in rebar set
spacing
Type: System..::..Double
The maximum spacing between rebar in rebar set
barsOnNormalSide
Type: System..::..Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
includeFirstBar
Type: System..::..Boolean
Identifies if the first bar in rebar set is shown
includeLastBar
Type: System..::..Boolean
Identifies if the last bar in rebar set is shown

Remarks

When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions, Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- The spacing isn't bigger than 0.0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This Rebar is an instance of a spiral or multiplanar shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetLayoutAsSingle Method

[image]

Revit 2013 API
Rebar..::..SetLayoutAsSingle Method
Rebar Class See Also Send Feedback
Sets the Layout Rule property of rebar set to Single.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetLayoutAsSingle()
Visual Basic
Public Sub SetLayoutAsSingle
Visual C++
public:
void SetLayoutAsSingle()

Remarks

Only one bar will remain, which is at the position of rebar plane

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetSolidInView Method

[image]

Revit 2013 API
Rebar..::..SetSolidInView Method
Rebar Class See Also Send Feedback
Sets this rebar element to be shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetSolidInView(
    View3D view,
    bool solid
)
Visual Basic
Public Sub SetSolidInView ( _
    view As View3D, _
    solid As Boolean _
)
Visual C++
public:
void SetSolidInView(
    View3D^ view,
    bool solid
)

Parameters

view
Type: Autodesk.Revit.DB..::..View3D
The 3D view element
solid
Type: System..::..Boolean
True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element doesn't have valid visibility data.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


SetUnobscuredInView Method

[image]

Revit 2013 API
Rebar..::..SetUnobscuredInView Method
Rebar Class See Also Send Feedback
Sets this rebar element to be shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetUnobscuredInView(
    View view,
    bool unobscured
)
Visual Basic
Public Sub SetUnobscuredInView ( _
    view As View, _
    unobscured As Boolean _
)
Visual C++
public:
void SetUnobscuredInView(
    View^ view,
    bool unobscured
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view element
unobscured
Type: System..::..Boolean
True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element doesn't have valid visibility data.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Rebar Properties

[image] [image]

Revit 2013 API
Rebar Properties
Rebar Class See Also Send Feedback

The Rebar type exposes the following members.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BarType | Obsolete. Return the type of the rebar.
Public property | BaseFinishingTurns | For a spiral, the number of finishing turns at the lower end of the spiral.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | DistributionPath | Obsolete. For Rebar with an array layout, return the distribution path (a line).
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Height | For a spiral, the overall height.
Public property | Host | Obsolete. The element that contains the rebar.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | IncludeFirstBar | Identifies if the first bar in rebar set is shown.
Public property | IncludeLastBar | Identifies if the last bar in rebar set is shown.
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | MultiplanarDepth | For a multiplanar rebar, the depth of the instance.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions | The number of potential bars in the set.
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Pitch | For a spiral, the pitch, or vertical distance traveled in one rotation.
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShape | Obsolete. Get/Set the RebarShape associated with the Rebar.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | TopFinishingTurns | For a spiral, the number of finishing turns at the upper end of the spiral.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of an individual bar multiplied by Quantity.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ArrayLength Property

[image]

Revit 2013 API
Rebar..::..ArrayLength Property
Rebar Class See Also Send Feedback
Identifies the distribution path length of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double ArrayLength { get; set; }
Visual Basic
Public Property ArrayLength As Double
    Get
    Set
Visual C++
public:
property double ArrayLength {
    double get ();
    void set (double value);
}

Field Value

The distribution path length of rebar set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the set length arrayLength isn't acceptable.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BarsOnNormalSide Property

[image]

Revit 2013 API
Rebar..::..BarsOnNormalSide Property
Rebar Class See Also Send Feedback
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool BarsOnNormalSide { get; set; }
Visual Basic
Public Property BarsOnNormalSide As Boolean
    Get
    Set
Visual C++
public:
property bool BarsOnNormalSide {
    bool get ();
    void set (bool value);
}

Field Value

True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BarType Property

[image]

Revit 2013 API
Rebar..::..BarType Property
Rebar Class See Also Send Feedback
Return the type of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")]
public RebarBarType BarType { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")> _
Public Property BarType As RebarBarType
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetTypeId and ChangeTypeId instead.")]
public:
property RebarBarType^ BarType {
    RebarBarType^ get ();
    void set (RebarBarType^ value);
}

Remarks

Returns a RebarBarType element that defines bar diameter and bend radius for the rebar.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


BaseFinishingTurns Property

[image]

Revit 2013 API
Rebar..::..BaseFinishingTurns Property
Rebar Class See Also Send Feedback
For a spiral, the number of finishing turns at the lower end of the spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int BaseFinishingTurns { get; set; }
Visual Basic
Public Property BaseFinishingTurns As Integer
    Get
    Set
Visual C++
public:
property int BaseFinishingTurns {
    int get ();
    void set (int value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


DistributionPath Property

[image]

Revit 2013 API
Rebar..::..DistributionPath Property
Rebar Class See Also Send Feedback
For Rebar with an array layout, return the distribution path (a line).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetDistributionPath instead.")]
public Curve DistributionPath { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetDistributionPath instead.")> _
Public ReadOnly Property DistributionPath As Curve
    Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetDistributionPath instead.")]
public:
property Curve^ DistributionPath {
    Curve^ get ();
}

Remarks

This creates a new curve.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Height Property

[image]

Revit 2013 API
Rebar..::..Height Property
Rebar Class See Also Send Feedback
For a spiral, the overall height.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: height must be positive.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Host Property

[image]

Revit 2013 API
Rebar..::..Host Property
Rebar Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")]
public Element Host { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")> _
Public Property Host As Element
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use GetHostId and SetHostId instead.")]
public:
property Element^ Host {
    Element^ get ();
    void set (Element^ value);
}

Remarks

Returns the Autodesk Revit element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IncludeFirstBar Property

[image]

Revit 2013 API
Rebar..::..IncludeFirstBar Property
Rebar Class See Also Send Feedback
Identifies if the first bar in rebar set is shown.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool IncludeFirstBar { get; set; }
Visual Basic
Public Property IncludeFirstBar As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeFirstBar {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


IncludeLastBar Property

[image]

Revit 2013 API
Rebar..::..IncludeLastBar Property
Rebar Class See Also Send Feedback
Identifies if the last bar in rebar set is shown.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool IncludeLastBar { get; set; }
Visual Basic
Public Property IncludeLastBar As Boolean
    Get
    Set
Visual C++
public:
property bool IncludeLastBar {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


LayoutRule Property

[image]

Revit 2013 API
Rebar..::..LayoutRule Property
Rebar Class See Also Send Feedback
Identifies the layout rule of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public RebarLayoutRule LayoutRule { get; }
Visual Basic
Public ReadOnly Property LayoutRule As RebarLayoutRule
    Get
Visual C++
public:
property RebarLayoutRule LayoutRule {
    RebarLayoutRule get ();
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


MaxSpacing Property

[image]

Revit 2013 API
Rebar..::..MaxSpacing Property
Rebar Class See Also Send Feedback
Identifies the maximum spacing between rebar in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double MaxSpacing { get; set; }
Visual Basic
Public Property MaxSpacing As Double
    Get
    Set
Visual C++
public:
property double MaxSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The maxSpacing isn't bigger than 0.0.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


MultiplanarDepth Property

[image]

Revit 2013 API
Rebar..::..MultiplanarDepth Property
Rebar Class See Also Send Feedback
For a multiplanar rebar, the depth of the instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double MultiplanarDepth { get; set; }
Visual Basic
Public Property MultiplanarDepth As Double
    Get
    Set
Visual C++
public:
property double MultiplanarDepth {
    double get ();
    void set (double value);
}

Remarks

Applicable only when an instance of a RebarShape with a RebarShapeMultiplanarDefinition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: multiplanarDepth must be positive.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a multiplanar shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Normal Property

[image]

Revit 2013 API
Rebar..::..Normal Property
Rebar Class See Also Send Feedback
A unit-length vector normal to the plane of the rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


NumberOfBarPositions Property

[image]

Revit 2013 API
Rebar..::..NumberOfBarPositions Property
Rebar Class See Also Send Feedback
The number of potential bars in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int NumberOfBarPositions { get; set; }
Visual Basic
Public Property NumberOfBarPositions As Integer
    Get
    Set
Visual C++
public:
property int NumberOfBarPositions {
    int get ();
    void set (int value);
}

Remarks

The number of positions is equal to the number of actual bars (the Quantity), plus one or two more positions depending on IncludeFistBar and IncludeLastBar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the number of bar positions numberOfBarPositions is less than 1 or more than 1002.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InapplicableDataException | When setting this property: This rebar element represents a single bar (the layout rule is Single).

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
Rebar..::..Parameter Property
Rebar Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Rebar Class
Rebar Members
Autodesk.Revit.DB.Structure Namespace


Pitch Property

[image]

Revit 2013 API
Rebar..::..Pitch Property
Rebar Class See Also Send Feedback
For a spiral, the pitch, or vertical distance traveled in one rotation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double Pitch { get; set; }
Visual Basic
Public Property Pitch As Double
    Get
    Set
Visual C++
public:
property double Pitch {
    double get ();
    void set (double value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: pitch must be positive.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Quantity Property

[image]

Revit 2013 API
Rebar..::..Quantity Property
Rebar Class See Also Send Feedback
Identifies the number of bars in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int Quantity { get; }
Visual Basic
Public ReadOnly Property Quantity As Integer
    Get
Visual C++
public:
property int Quantity {
    int get ();
}

Field Value

The number of bars in rebar set.

Remarks

Quantity is equal to NumberOfBarPositions if IncludeFirstBar and IncludeLastBar are set. If any end bars are excluded, they are not counted in the Quantity.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Property

[image]

Revit 2013 API
Rebar..::..RebarShape Property
Rebar Class See Also Send Feedback
Get/Set the RebarShape associated with the Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")]
public RebarShape RebarShape { get; set; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")> _
Public Property RebarShape As RebarShape
    Get
    Set
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2013. Use the RebarShapeId property instead.")]
public:
property RebarShape^ RebarShape {
    RebarShape^ get ();
    void set (RebarShape^ value);
}

Remarks

When set, the instance will choose values for its shape parameters to try to preserve its previous shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeId Property

[image]

Revit 2013 API
Rebar..::..RebarShapeId Property
Rebar Class See Also Send Feedback
The RebarShape element that defines the shape of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId RebarShapeId { get; set; }
Visual Basic
Public Property RebarShapeId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ RebarShapeId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Remarks

Changing the value of this property causes the Rebar instance to choose values for its shape parameters to preserve its previous shape as closely as possible

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: shapeId is not the id of a RebarShape in the document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


ScheduleMark Property

[image]

Revit 2013 API
Rebar..::..ScheduleMark Property
Rebar Class See Also Send Feedback
The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string ScheduleMark { get; set; }
Visual Basic
Public Property ScheduleMark As String
    Get
    Set
Visual C++
public:
property String^ ScheduleMark {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


TopFinishingTurns Property

[image]

Revit 2013 API
Rebar..::..TopFinishingTurns Property
Rebar Class See Also Send Feedback
For a spiral, the number of finishing turns at the upper end of the spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int TopFinishingTurns { get; set; }
Visual Basic
Public Property TopFinishingTurns As Integer
    Get
    Set
Visual C++
public:
property int TopFinishingTurns {
    int get ();
    void set (int value);
}

Remarks

Applies only to instances where RebarShape.Definition is of type RebarShapeDefinitionByArc, and its Type property is equal to the value RebarShapeDefinitionByArcType.Spiral.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: turns must be between 0 and 100.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | This Rebar is not an instance of a spiral shape.

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


TotalLength Property

[image]

Revit 2013 API
Rebar..::..TotalLength Property
Rebar Class See Also Send Feedback
The length of an individual bar multiplied by Quantity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double TotalLength { get; }
Visual Basic
Public ReadOnly Property TotalLength As Double
    Get
Visual C++
public:
property double TotalLength {
    double get ();
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


Volume Property

[image]

Revit 2013 API
Rebar..::..Volume Property
Rebar Class See Also Send Feedback
The volume of an individual bar multiplied by Quantity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

See Also

Rebar Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Class

[image]

Revit 2013 API
RebarBarType Class
Members See Also Send Feedback
A Rebar type object that is used in the generation of Rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarBarType : ElementType
Visual Basic
Public Class RebarBarType _
    Inherits ElementType
Visual C++
public ref class RebarBarType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..RebarBarType

See Also

RebarBarType Members
Autodesk.Revit.DB.Structure Namespace


RebarBarType Members

[image] [image]

Revit 2013 API
RebarBarType Members
RebarBarType Class Methods Properties See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new RebarBarType object
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookLength | Identifies the hook length for a hook type
Public method | GetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | GetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetHookLength | Identifies the hook length for a hook type
Public method | SetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | SetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDiameter | Defines bar diameter of rebar
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumBendRadius | Defines maximum bend radius of rebar
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
Public property | StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
Public property | StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Methods

[image] [image]

Revit 2013 API
RebarBarType Methods
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new RebarBarType object
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookLength | Identifies the hook length for a hook type
Public method | GetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | GetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetAutoCalcHookLengths | Identifies if the hook lengths of a hook type are automatically calculated for this bar type
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetHookLength | Identifies the hook length for a hook type
Public method | SetHookOffsetLength | Identifies the hook offset length for a hook type
Public method | SetHookPermission | Identifies if a hook type is permitted for this bar type
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
RebarBarType..::..Create Method
RebarBarType Class See Also Send Feedback
Creates a new RebarBarType object

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarBarType Create(
    Document ADoc
)
Visual Basic
Public Shared Function Create ( _
    ADoc As Document _
) As RebarBarType
Visual C++
public:
static RebarBarType^ Create(
    Document^ ADoc
)

Parameters

ADoc
Type: Autodesk.Revit.DB..::..Document

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetAutoCalcHookLengths Method

[image]

Revit 2013 API
RebarBarType..::..GetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool GetAutoCalcHookLengths(
    ElementId hookId
)
Visual Basic
Public Function GetAutoCalcHookLengths ( _
    hookId As ElementId _
) As Boolean
Visual C++
public:
bool GetAutoCalcHookLengths(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type

Return Value

True if the hook lengths are automatically calculated, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookLength Method

[image]

Revit 2013 API
RebarBarType..::..GetHookLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetHookLength(
    ElementId hookId
)
Visual Basic
Public Function GetHookLength ( _
    hookId As ElementId _
) As Double
Visual C++
public:
double GetHookLength(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type

Return Value

The hook length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook length will be returned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookOffsetLength Method

[image]

Revit 2013 API
RebarBarType..::..GetHookOffsetLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetHookOffsetLength(
    ElementId hookId
)
Visual Basic
Public Function GetHookOffsetLength ( _
    hookId As ElementId _
) As Double
Visual C++
public:
double GetHookOffsetLength(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type

Return Value

The hook offset length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook offset length will be returned

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length -or- The element hookId does not exist in the document containing this RebarBarType -or- the hook specified by id hookId doesn't have valid default offset length
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document containing this RebarBarType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The element is a member of a loaded family. -or- The element is a member of a group type that is not being edited. -or- hookId is a member of a loaded family. -or- hookId is a member of a group type that is not being edited.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


GetHookPermission Method

[image]

Revit 2013 API
RebarBarType..::..GetHookPermission Method
RebarBarType Class See Also Send Feedback
Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool GetHookPermission(
    ElementId hookId
)
Visual Basic
Public Function GetHookPermission ( _
    hookId As ElementId _
) As Boolean
Visual C++
public:
bool GetHookPermission(
    ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type

Return Value

True if the hook type is permitted for this bar type, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetAutoCalcHookLengths Method

[image]

Revit 2013 API
RebarBarType..::..SetAutoCalcHookLengths Method
RebarBarType Class See Also Send Feedback
Identifies if the hook lengths of a hook type are automatically calculated for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetAutoCalcHookLengths(
    ElementId hookId,
    bool autoCalculated
)
Visual Basic
Public Sub SetAutoCalcHookLengths ( _
    hookId As ElementId, _
    autoCalculated As Boolean _
)
Visual C++
public:
void SetAutoCalcHookLengths(
    ElementId^ hookId,
    bool autoCalculated
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
autoCalculated
Type: System..::..Boolean
True if the hook lengths should be automatically calculated, otherwise false When it is false, default hook length and default hook offset length will be reported

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookLength Method

[image]

Revit 2013 API
RebarBarType..::..SetHookLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetHookLength(
    ElementId hookId,
    double hookLength
)
Visual Basic
Public Sub SetHookLength ( _
    hookId As ElementId, _
    hookLength As Double _
)
Visual C++
public:
void SetHookLength(
    ElementId^ hookId,
    double hookLength
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
hookLength
Type: System..::..Double
The hook length for a hook type

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookOffsetLength Method

[image]

Revit 2013 API
RebarBarType..::..SetHookOffsetLength Method
RebarBarType Class See Also Send Feedback
Identifies the hook offset length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetHookOffsetLength(
    ElementId hookId,
    double newLength
)
Visual Basic
Public Sub SetHookOffsetLength ( _
    hookId As ElementId, _
    newLength As Double _
)
Visual C++
public:
void SetHookOffsetLength(
    ElementId^ hookId,
    double newLength
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
newLength
Type: System..::..Double
The hook offset length for a hook type

Remarks

AutoCalcHookLengths is ignored when this property is set

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid -or- the hook specified by id hookId doesn't have valid offset length
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


SetHookPermission Method

[image]

Revit 2013 API
RebarBarType..::..SetHookPermission Method
RebarBarType Class See Also Send Feedback
Identifies if a hook type is permitted for this bar type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetHookPermission(
    ElementId hookId,
    bool permission
)
Visual Basic
Public Sub SetHookPermission ( _
    hookId As ElementId, _
    permission As Boolean _
)
Visual C++
public:
void SetHookPermission(
    ElementId^ hookId,
    bool permission
)

Parameters

hookId
Type: Autodesk.Revit.DB..::..ElementId
id of the hook type
permission
Type: System..::..Boolean
True if the hook type should be permitted for this bar type, otherwise false

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | the rebar hook type id hookId is not valid
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarType Properties

[image] [image]

Revit 2013 API
RebarBarType Properties
RebarBarType Class See Also Send Feedback

The RebarBarType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarDiameter | Defines bar diameter of rebar
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaximumBendRadius | Defines maximum bend radius of rebar
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StandardBendDiameter | Defines bar bend diameter for rebar whose style is standard
Public property | StandardHookBendDiameter | Defines hook bend diameter for rebar whose style is standard
Public property | StirrupTieBendDiameter | Defines bar and hook bend diameter for rebar whose style is stirrup/tie
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


BarDiameter Property

[image]

Revit 2013 API
RebarBarType..::..BarDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar diameter of rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double BarDiameter { get; set; }
Visual Basic
Public Property BarDiameter As Double
    Get
    Set
Visual C++
public:
property double BarDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar diameter of rebar

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bar diameter barDiam is not positive or bigger than the smallest value of 1.0, standard bend diameter, standard hook bend diameter and stirrup/tie bend diameter
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


MaximumBendRadius Property

[image]

Revit 2013 API
RebarBarType..::..MaximumBendRadius Property
RebarBarType Class See Also Send Feedback
Defines maximum bend radius of rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double MaximumBendRadius { get; set; }
Visual Basic
Public Property MaximumBendRadius As Double
    Get
    Set
Visual C++
public:
property double MaximumBendRadius {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
RebarBarType..::..Parameter Property
RebarBarType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RebarBarType Class
RebarBarType Members
Autodesk.Revit.DB.Structure Namespace


StandardBendDiameter Property

[image]

Revit 2013 API
RebarBarType..::..StandardBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StandardBendDiameter { get; set; }
Visual Basic
Public Property StandardBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StandardBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bend diameter standardBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


StandardHookBendDiameter Property

[image]

Revit 2013 API
RebarBarType..::..StandardHookBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines hook bend diameter for rebar whose style is standard

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StandardHookBendDiameter { get; set; }
Visual Basic
Public Property StandardHookBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StandardHookBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The hook bend diameter for rebar whose style is standard

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bend diameter standardHookBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


StirrupTieBendDiameter Property

[image]

Revit 2013 API
RebarBarType..::..StirrupTieBendDiameter Property
RebarBarType Class See Also Send Feedback
Defines bar and hook bend diameter for rebar whose style is stirrup/tie

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StirrupTieBendDiameter { get; set; }
Visual Basic
Public Property StirrupTieBendDiameter As Double
    Get
    Set
Visual C++
public:
property double StirrupTieBendDiameter {
    double get ();
    void set (double value);
}

Field Value

The bar and hook bend diameter for rebar whose style is stirrup/tie

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: the bend diameter stirrupTieBendDiam isn't between bar diameter and 99.0
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarBarType Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Class

[image]

Revit 2013 API
RebarBarTypeSet Class
Members See Also Send Feedback
A set that contains RebarBar types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarBarTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RebarBarTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarBarTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarBarTypeSet

See Also

RebarBarTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Members

[image] [image]

Revit 2013 API
RebarBarTypeSet Members
RebarBarTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarBarTypeSet | Initializes a new instance of the RebarBarTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Constructor

[image]

Revit 2013 API
RebarBarTypeSet Constructor
RebarBarTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarBarTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarBarTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
RebarBarTypeSet()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Methods

[image] [image]

Revit 2013 API
RebarBarTypeSet Methods
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every RebarBar type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarBar type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarBar type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarBar type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
RebarBarTypeSet..::..Clear Method
RebarBarTypeSet Class See Also Send Feedback
Removes every RebarBar type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
RebarBarTypeSet..::..Contains Method
RebarBarTypeSet Class See Also Send Feedback
Tests for the existence of a RebarBar type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarBarType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
The RebarBar type to be searched for.

Return Value

The Contains method returns True if the RebarBar type is within the set, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
RebarBarTypeSet..::..Erase Method
RebarBarTypeSet Class See Also Send Feedback
Removes a specified RebarBar type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RebarBarType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RebarBarType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
The RebarBar type to be erased.

Return Value

The number of RebarBar types that were erased from the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
RebarBarTypeSet..::..ForwardIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
RebarBarTypeSet..::..GetEnumerator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
RebarBarTypeSet..::..Insert Method
RebarBarTypeSet Class See Also Send Feedback
Insert the specified RebarBar type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarBarType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RebarBarType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarBarType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
The RebarBar type to be inserted into the set.

Return Value

Returns whether the RebarBar type was inserted into the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
RebarBarTypeSet..::..ReverseIterator Method
RebarBarTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarBarTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RebarBarTypeSetIterator
Visual C++
public:
virtual RebarBarTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSet Properties

[image] [image]

Revit 2013 API
RebarBarTypeSet Properties
RebarBarTypeSet Class See Also Send Feedback

The RebarBarTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarBar types that are in the set.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
RebarBarTypeSet..::..IsEmpty Property
RebarBarTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
RebarBarTypeSet..::..Size Property
RebarBarTypeSet Class See Also Send Feedback
Returns the number of RebarBar types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarBarTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Class

[image]

Revit 2013 API
RebarBarTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarBar type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RebarBarTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RebarBarTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarBarTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarBarTypeSetIterator

See Also

RebarBarTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Members

[image] [image]

Revit 2013 API
RebarBarTypeSetIterator Members
RebarBarTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RebarBarTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Constructor

[image]

Revit 2013 API
RebarBarTypeSetIterator Constructor
RebarBarTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarBarTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RebarBarTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Methods

[image] [image]

Revit 2013 API
RebarBarTypeSetIterator Methods
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
RebarBarTypeSetIterator..::..MoveNext Method
RebarBarTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
RebarBarTypeSetIterator..::..Reset Method
RebarBarTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBarTypeSetIterator Properties

[image] [image]

Revit 2013 API
RebarBarTypeSetIterator Properties
RebarBarTypeSetIterator Class See Also Send Feedback

The RebarBarTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
RebarBarTypeSetIterator..::..Current Property
RebarBarTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarBarTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarBendData Class

[image]

Revit 2013 API
RebarBendData Class
Members See Also Send Feedback
The class contains values that specify the bar diameter, bend diameters, and hook lengths of a rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarBendData : IDisposable
Visual Basic
Public Class RebarBendData _
    Implements IDisposable
Visual C++
public ref class RebarBendData : IDisposable

Remarks

These values are the ones required by RebarShape.ComputeShapeCurves() besides the shape-specific parameters. The purpose of collecting the values in this class is to allow you to create and analyze an accurate representation of a RebarShape, without creating a Rebar instance, and without referring to RebarBarType, RebarHookType, and RebarStyle. If you do have a Rebar instance, its GetBendData() method will produce a RebarBendData object.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarBendData

See Also

RebarBendData Members
Autodesk.Revit.DB.Structure Namespace


RebarBendData Members

[image] [image]

Revit 2013 API
RebarBendData Members
RebarBendData Class Constructors Methods Properties See Also Send Feedback

The RebarBendData type exposes the following members.

Constructors

 | Name | Description
Public method | RebarBendData()()()() | Initializes a new instance of the RebarBendData class
Public method | RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle) | Initializes a new instance of the RebarBendData class

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarBendData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarDiameter | The diameter of the bar.
Public property | BendRadius | The radius of all fillets, except hook fillets, in the Rebar shape.
Public property | HookBendRadius | The radius of the hook fillets in the Rebar shape.
Public property | HookLength0 | The extension length of the hook at the start.
Public property | HookLength1 | The extension length of the hook at the end.

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


RebarBendData Constructor

[image] [image]

Revit 2013 API
RebarBendData Constructor
RebarBendData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RebarBendData()()()() | Initializes a new instance of the RebarBendData class
Public method | RebarBendData(RebarBarType, RebarHookType, RebarHookType, RebarStyle) | Initializes a new instance of the RebarBendData class

See Also

RebarBendData Class
RebarBendData Members
Autodesk.Revit.DB.Structure Namespace


RebarBendData Constructor

[image]

Revit 2013 API
RebarBendData Constructor
RebarBendData Class See Also Send Feedback
Initializes a new instance of the RebarBendData class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarBendData()
Visual Basic
Public Sub New
Visual C++
public:
RebarBendData()

See Also

RebarBendData Class
RebarBendData Overload
Autodesk.Revit.DB.Structure Namespace


RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle)

[image]

Revit 2013 API
RebarBendData Constructor (RebarBarType, RebarHookType, RebarHookType, RebarStyle)
RebarBendData Class See Also Send Feedback
Initializes a new instance of the RebarBendData class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarBendData(
    RebarBarType barType,
    RebarHookType hookType0,
    RebarHookType hookType1,
    RebarStyle style
)
Visual Basic
Public Sub New ( _
    barType As RebarBarType, _
    hookType0 As RebarHookType, _
    hookType1 As RebarHookType, _
    style As RebarStyle _
)
Visual C++
public:
RebarBendData(
    RebarBarType^ barType,
    RebarHookType^ hookType0,
    RebarHookType^ hookType1,
    RebarStyle style
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
hookType0
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
hookType1
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarBendData Class
RebarBendData Overload
Autodesk.Revit.DB.Structure Namespace


RebarBendData Methods

[image] [image]

Revit 2013 API
RebarBendData Methods
RebarBendData Class See Also Send Feedback

The RebarBendData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarBendData..::..Dispose Method
RebarBendData Class See Also Send Feedback
Releases all resources used by the RebarBendData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


RebarBendData Properties

[image] [image]

Revit 2013 API
RebarBendData Properties
RebarBendData Class See Also Send Feedback

The RebarBendData type exposes the following members.

Properties

 | Name | Description
Public property | BarDiameter | The diameter of the bar.
Public property | BendRadius | The radius of all fillets, except hook fillets, in the Rebar shape.
Public property | HookBendRadius | The radius of the hook fillets in the Rebar shape.
Public property | HookLength0 | The extension length of the hook at the start.
Public property | HookLength1 | The extension length of the hook at the end.

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


BarDiameter Property

[image]

Revit 2013 API
RebarBendData..::..BarDiameter Property
RebarBendData Class See Also Send Feedback
The diameter of the bar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double BarDiameter { get; set; }
Visual Basic
Public Property BarDiameter As Double
    Get
    Set
Visual C++
public:
property double BarDiameter {
    double get ();
    void set (double value);
}

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


BendRadius Property

[image]

Revit 2013 API
RebarBendData..::..BendRadius Property
RebarBendData Class See Also Send Feedback
The radius of all fillets, except hook fillets, in the Rebar shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double BendRadius { get; set; }
Visual Basic
Public Property BendRadius As Double
    Get
    Set
Visual C++
public:
property double BendRadius {
    double get ();
    void set (double value);
}

Remarks

Inner radius, not centerline

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


HookBendRadius Property

[image]

Revit 2013 API
RebarBendData..::..HookBendRadius Property
RebarBendData Class See Also Send Feedback
The radius of the hook fillets in the Rebar shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double HookBendRadius { get; set; }
Visual Basic
Public Property HookBendRadius As Double
    Get
    Set
Visual C++
public:
property double HookBendRadius {
    double get ();
    void set (double value);
}

Remarks

Inner radius, not centerline

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


HookLength0 Property

[image]

Revit 2013 API
RebarBendData..::..HookLength0 Property
RebarBendData Class See Also Send Feedback
The extension length of the hook at the start.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double HookLength0 { get; set; }
Visual Basic
Public Property HookLength0 As Double
    Get
    Set
Visual C++
public:
property double HookLength0 {
    double get ();
    void set (double value);
}

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


HookLength1 Property

[image]

Revit 2013 API
RebarBendData..::..HookLength1 Property
RebarBendData Class See Also Send Feedback
The extension length of the hook at the end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public double HookLength1 { get; set; }
Visual Basic
Public Property HookLength1 As Double
    Get
    Set
Visual C++
public:
property double HookLength1 {
    double get ();
    void set (double value);
}

See Also

RebarBendData Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Class

[image]

Revit 2013 API
RebarCoverType Class
Members See Also Send Feedback
A named value for a clear cover distance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarCoverType : ElementType
Visual Basic
Public Class RebarCoverType _
    Inherits ElementType
Visual C++
public ref class RebarCoverType : public ElementType

Remarks

In Revit Structure, CoverTypes are the rows in the Rebar Cover Settings dialog.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..RebarCoverType

See Also

RebarCoverType Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Members

[image] [image]

Revit 2013 API
RebarCoverType Members
RebarCoverType Class Methods Properties See Also Send Feedback

The RebarCoverType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new CoverType in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverDistance | A distance that can be used as a concrete cover value in a document.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Methods

[image] [image]

Revit 2013 API
RebarCoverType Methods
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new CoverType in the document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
RebarCoverType..::..Create Method
RebarCoverType Class See Also Send Feedback
Creates a new CoverType in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarCoverType Create(
    Document doc,
    string name,
    double coverDistance
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    name As String, _
    coverDistance As Double _
) As RebarCoverType
Visual C++
public:
static RebarCoverType^ Create(
    Document^ doc,
    String^ name,
    double coverDistance
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
name
Type: System..::..String
coverDistance
Type: System..::..Double

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | name is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | coverDistance cannot be negative.

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverType Properties

[image] [image]

Revit 2013 API
RebarCoverType Properties
RebarCoverType Class See Also Send Feedback

The RebarCoverType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CoverDistance | A distance that can be used as a concrete cover value in a document.
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


CoverDistance Property

[image]

Revit 2013 API
RebarCoverType..::..CoverDistance Property
RebarCoverType Class See Also Send Feedback
A distance that can be used as a concrete cover value in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double CoverDistance { get; set; }
Visual Basic
Public Property CoverDistance As Double
    Get
    Set
Visual C++
public:
property double CoverDistance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: coverDistance cannot be negative.

See Also

RebarCoverType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
RebarCoverType..::..Parameter Property
RebarCoverType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RebarCoverType Class
RebarCoverType Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Class

[image]

Revit 2013 API
RebarCoverTypeSet Class
Members See Also Send Feedback
A set that contains RebarCover types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarCoverTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RebarCoverTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarCoverTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarCoverTypeSet

See Also

RebarCoverTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Members

[image] [image]

Revit 2013 API
RebarCoverTypeSet Members
RebarCoverTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarCoverTypeSet | Initializes a new instance of the RebarCoverTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every RebarCover type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarCover type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarCover type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarCover type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Constructor

[image]

Revit 2013 API
RebarCoverTypeSet Constructor
RebarCoverTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarCoverTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarCoverTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
RebarCoverTypeSet()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Methods

[image] [image]

Revit 2013 API
RebarCoverTypeSet Methods
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every RebarCover type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarCover type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarCover type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarCover type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..Clear Method
RebarCoverTypeSet Class See Also Send Feedback
Removes every RebarCover type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..Contains Method
RebarCoverTypeSet Class See Also Send Feedback
Tests for the existence of a RebarCover type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarCoverType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
The RebarCover type to be searched for.

Return Value

The Contains method returns True if the RebarCover type is within the set, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..Erase Method
RebarCoverTypeSet Class See Also Send Feedback
Removes a specified RebarCover type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RebarCoverType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RebarCoverType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
The RebarCover type to be erased.

Return Value

The number of RebarCover types that were erased from the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..ForwardIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..GetEnumerator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..Insert Method
RebarCoverTypeSet Class See Also Send Feedback
Insert the specified RebarCover type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarCoverType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RebarCoverType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarCoverType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
The RebarCover type to be inserted into the set.

Return Value

Returns whether the RebarCover type was inserted into the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
RebarCoverTypeSet..::..ReverseIterator Method
RebarCoverTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarCoverTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RebarCoverTypeSetIterator
Visual C++
public:
virtual RebarCoverTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSet Properties

[image] [image]

Revit 2013 API
RebarCoverTypeSet Properties
RebarCoverTypeSet Class See Also Send Feedback

The RebarCoverTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarCover types that are in the set.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
RebarCoverTypeSet..::..IsEmpty Property
RebarCoverTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
RebarCoverTypeSet..::..Size Property
RebarCoverTypeSet Class See Also Send Feedback
Returns the number of RebarCover types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarCoverTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Class

[image]

Revit 2013 API
RebarCoverTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarCover type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RebarCoverTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RebarCoverTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarCoverTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarCoverTypeSetIterator

See Also

RebarCoverTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Members

[image] [image]

Revit 2013 API
RebarCoverTypeSetIterator Members
RebarCoverTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RebarCoverTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Constructor

[image]

Revit 2013 API
RebarCoverTypeSetIterator Constructor
RebarCoverTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarCoverTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RebarCoverTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Methods

[image] [image]

Revit 2013 API
RebarCoverTypeSetIterator Methods
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
RebarCoverTypeSetIterator..::..MoveNext Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
RebarCoverTypeSetIterator..::..Reset Method
RebarCoverTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarCoverTypeSetIterator Properties

[image] [image]

Revit 2013 API
RebarCoverTypeSetIterator Properties
RebarCoverTypeSetIterator Class See Also Send Feedback

The RebarCoverTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
RebarCoverTypeSetIterator..::..Current Property
RebarCoverTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarCoverTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookOrientation Enumeration

[image]

Revit 2013 API
RebarHookOrientation Enumeration
See Also Send Feedback
Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarHookOrientation
Visual Basic
Public Enumeration RebarHookOrientation
Visual C++
public enum class RebarHookOrientation

Members

Member name | Description
Right | Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
Left | Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).

See Also

Autodesk.Revit.DB.Structure Namespace


RebarHookType Class

[image]

Revit 2013 API
RebarHookType Class
Members See Also Send Feedback
A Rebar Hook type object that is used in the generation of Rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarHookType : ElementType
Visual Basic
Public Class RebarHookType _
    Inherits ElementType
Visual C++
public ref class RebarHookType : public ElementType

Remarks

This object contains the definition of the hooks that may be created at the ends of the rebar. The specifics of these hooks are angle (range 0-PI) between first/last segment of rebar and the straight segment of the hook, rebar shape style and a multiplier used to compute the length of the straight segment of the hook. The default length is computed as the bar diameter * the multiplier. Length can be overridden by settings in the RebarBarType class.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..RebarHookType

See Also

RebarHookType Members
Autodesk.Revit.DB.Structure Namespace


RebarHookType Members

[image] [image]

Revit 2013 API
RebarHookType Members
RebarHookType Class Methods Properties See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new RebarHookType in a document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDefaultHookLength | Computes the default hook length, which is equal to barDiameter * multiplier.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookExtensionLength | Computes the hook extension length.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOffsetLengthRequired | Check whether hook offset length is required. remarks: If hook angle is no more than 90 degree, hook offset length is not meaningful. returns: True if hook offset length is required, otherwise false.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HookAngle | The hook angle, measured in radians. Must be greater than 0 and no more than pi.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StraightLineMultiplier | Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.
Public property | Style | The hook may only be applied to shapes of the specified style.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


RebarHookType Methods

[image] [image]

Revit 2013 API
RebarHookType Methods
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Creates a new RebarHookType in a document.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDefaultHookLength | Computes the default hook length, which is equal to barDiameter * multiplier.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookExtensionLength | Computes the hook extension length.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsOffsetLengthRequired | Check whether hook offset length is required. remarks: If hook angle is no more than 90 degree, hook offset length is not meaningful. returns: True if hook offset length is required, otherwise false.
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
RebarHookType..::..Create Method
RebarHookType Class See Also Send Feedback
Creates a new RebarHookType in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarHookType Create(
    Document doc,
    double angle,
    double multiplier
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    angle As Double, _
    multiplier As Double _
) As RebarHookType
Visual C++
public:
static RebarHookType^ Create(
    Document^ doc,
    double angle,
    double multiplier
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
angle
Type: System..::..Double
Determine the hook angle of new RebarHookType.
multiplier
Type: System..::..Double
Determine the straight line multiplier of new RebarHookType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | angle must be greater than 0 and no more than pi. -or- multiplier must be greater than 0 and no more than 99.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


GetDefaultHookLength Method

[image]

Revit 2013 API
RebarHookType..::..GetDefaultHookLength Method
RebarHookType Class See Also Send Feedback
Computes the default hook length, which is equal to barDiameter * multiplier.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetDefaultHookLength(
    double barDiameter
)
Visual Basic
Public Function GetDefaultHookLength ( _
    barDiameter As Double _
) As Double
Visual C++
public:
double GetDefaultHookLength(
    double barDiameter
)

Parameters

barDiameter
Type: System..::..Double

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


GetHookExtensionLength Method

[image]

Revit 2013 API
RebarHookType..::..GetHookExtensionLength Method
RebarHookType Class See Also Send Feedback
Computes the hook extension length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double GetHookExtensionLength(
    RebarBarType barType
)
Visual Basic
Public Function GetHookExtensionLength ( _
    barType As RebarBarType _
) As Double
Visual C++
public:
double GetHookExtensionLength(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


IsOffsetLengthRequired Method

[image]

Revit 2013 API
RebarHookType..::..IsOffsetLengthRequired Method
RebarHookType Class See Also Send Feedback
Check whether hook offset length is required. remarks: If hook angle is no more than 90 degree, hook offset length is not meaningful. returns: True if hook offset length is required, otherwise false.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsOffsetLengthRequired()
Visual Basic
Public Function IsOffsetLengthRequired As Boolean
Visual C++
public:
bool IsOffsetLengthRequired()

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


RebarHookType Properties

[image] [image]

Revit 2013 API
RebarHookType Properties
RebarHookType Class See Also Send Feedback

The RebarHookType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HookAngle | The hook angle, measured in radians. Must be greater than 0 and no more than pi.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StraightLineMultiplier | Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.
Public property | Style | The hook may only be applied to shapes of the specified style.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


HookAngle Property

[image]

Revit 2013 API
RebarHookType..::..HookAngle Property
RebarHookType Class See Also Send Feedback
The hook angle, measured in radians. Must be greater than 0 and no more than pi.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double HookAngle { get; set; }
Visual Basic
Public Property HookAngle As Double
    Get
    Set
Visual C++
public:
property double HookAngle {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: hookAngle must be greater than 0 and no more than pi.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
RebarHookType..::..Parameter Property
RebarHookType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RebarHookType Class
RebarHookType Members
Autodesk.Revit.DB.Structure Namespace


StraightLineMultiplier Property

[image]

Revit 2013 API
RebarHookType..::..StraightLineMultiplier Property
RebarHookType Class See Also Send Feedback
Multiplier of bar diameter. Used to compute a default hook length. The default hook length can be overridden by the RebarBarType class.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double StraightLineMultiplier { get; set; }
Visual Basic
Public Property StraightLineMultiplier As Double
    Get
    Set
Visual C++
public:
property double StraightLineMultiplier {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: straightLineMultiplier must be greater than 0 and no more than 99.

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


Style Property

[image]

Revit 2013 API
RebarHookType..::..Style Property
RebarHookType Class See Also Send Feedback
The hook may only be applied to shapes of the specified style.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarStyle Style { get; set; }
Visual Basic
Public Property Style As RebarStyle
    Get
    Set
Visual C++
public:
property RebarStyle Style {
    RebarStyle get ();
    void set (RebarStyle value);
}

See Also

RebarHookType Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Class

[image]

Revit 2013 API
RebarHookTypeSet Class
Members See Also Send Feedback
A set that contains RebarHook types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarHookTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RebarHookTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarHookTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarHookTypeSet

See Also

RebarHookTypeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Members

[image] [image]

Revit 2013 API
RebarHookTypeSet Members
RebarHookTypeSet Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarHookTypeSet | Initializes a new instance of the RebarHookTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every RebarHook type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarHook type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarHook type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarHook type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Constructor

[image]

Revit 2013 API
RebarHookTypeSet Constructor
RebarHookTypeSet Class See Also Send Feedback
Initializes a new instance of the RebarHookTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarHookTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
RebarHookTypeSet()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Methods

[image] [image]

Revit 2013 API
RebarHookTypeSet Methods
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every RebarHook type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a RebarHook type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified RebarHook type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified RebarHook type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
RebarHookTypeSet..::..Clear Method
RebarHookTypeSet Class See Also Send Feedback
Removes every RebarHook type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
RebarHookTypeSet..::..Contains Method
RebarHookTypeSet Class See Also Send Feedback
Tests for the existence of a RebarHook type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarHookType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
The RebarHook type to be searched for.

Return Value

The Contains method returns True if the RebarHook type is within the set, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
RebarHookTypeSet..::..Erase Method
RebarHookTypeSet Class See Also Send Feedback
Removes a specified RebarHook type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RebarHookType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RebarHookType _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
The RebarHook type to be erased.

Return Value

The number of RebarHook types that were erased from the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
RebarHookTypeSet..::..ForwardIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
RebarHookTypeSet..::..GetEnumerator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
RebarHookTypeSet..::..Insert Method
RebarHookTypeSet Class See Also Send Feedback
Insert the specified RebarHook type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarHookType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RebarHookType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarHookType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarHookType
The RebarHook type to be inserted into the set.

Return Value

Returns whether the RebarHook type was inserted into the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
RebarHookTypeSet..::..ReverseIterator Method
RebarHookTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarHookTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RebarHookTypeSetIterator
Visual C++
public:
virtual RebarHookTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSet Properties

[image] [image]

Revit 2013 API
RebarHookTypeSet Properties
RebarHookTypeSet Class See Also Send Feedback

The RebarHookTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of RebarHook types that are in the set.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
RebarHookTypeSet..::..IsEmpty Property
RebarHookTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
RebarHookTypeSet..::..Size Property
RebarHookTypeSet Class See Also Send Feedback
Returns the number of RebarHook types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarHookTypeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Class

[image]

Revit 2013 API
RebarHookTypeSetIterator Class
Members See Also Send Feedback
An iterator to a RebarHook type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RebarHookTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RebarHookTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarHookTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarHookTypeSetIterator

See Also

RebarHookTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Members

[image] [image]

Revit 2013 API
RebarHookTypeSetIterator Members
RebarHookTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RebarHookTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Constructor

[image]

Revit 2013 API
RebarHookTypeSetIterator Constructor
RebarHookTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarHookTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RebarHookTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Methods

[image] [image]

Revit 2013 API
RebarHookTypeSetIterator Methods
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
RebarHookTypeSetIterator..::..MoveNext Method
RebarHookTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
RebarHookTypeSetIterator..::..Reset Method
RebarHookTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHookTypeSetIterator Properties

[image] [image]

Revit 2013 API
RebarHookTypeSetIterator Properties
RebarHookTypeSetIterator Class See Also Send Feedback

The RebarHookTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
RebarHookTypeSetIterator..::..Current Property
RebarHookTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarHookTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarHostData Class

[image]

Revit 2013 API
RebarHostData Class
Members See Also Send Feedback
Interface to rebar-specific data stored in each valid rebar host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarHostData : IDisposable
Visual Basic
Public Class RebarHostData _
    Implements IDisposable
Visual C++
public ref class RebarHostData : IDisposable

Remarks

Rebar host elements keep track of the "exposed faces," those that are not completely concealed by another rebar host. Faces may be concealed by joins; for instance, the top face of a beam that supports a slab is concealed. Faces can also be concealed by adjacency; for instance, the bottom face of a column that is supported by a foundation. Each exposed face of a rebar host must have a valid CoverType associated with it.

Rebar hosts also have cover parameters, providing a limited interface to the GetCoverType and SetCoverType methods. Each parameter simply gets or sets the cover setting associated with one or more particular faces of the host.

  • CLEAR_COVER_EXTERIOR (walls only)
  • CLEAR_COVER_INTERIOR (walls only)
  • CLEAR_COVER_OTHER (all hosts except in-place families and stairs)
  • CLEAR_COVER (in-place families and stairs)
  • CLEAR_COVER_TOP (all hosts except walls, in-place families, and stairs)
  • CLEAR_COVER_BOTTOM (all hosts except walls, in-place families, and stairs)

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarHostData

See Also

RebarHostData Members
Autodesk.Revit.DB.Structure Namespace


RebarHostData Members

[image] [image]

Revit 2013 API
RebarHostData Members
RebarHostData Class Methods See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarHostData
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAreaReinforcementsInHost | Returns all AreaReinforcement elements hosted by the referenced element.
Public method | GetCommonCoverType | If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetCoverType | Gets the CoverType associated with a face of the element.
Public method | GetExposedFaces | Returns all the exposed faces, that is, those that have an associated CoverType.
Public method | GetFabricAreasInHost | Returns all FabricArea elements hosted by the referenced element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPathReinforcementsInHost | Returns all PathReinforcement elements hosted by the referenced element.
 | GetRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetRebarsInHost | Returns all Rebar elements hosted by the referenced element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFaceExposed | Checks whether the specified face is considered exposed, and therefore has an associated CoverType.
Public method | IsValidHost | Reports whether the element is a valid rebar host.
Public method | SetCommonCoverType | Associate a single CoverType with all exposed faces of the host element.
Public method | SetCoverType | Associates the specified CoverType with the specified face of the element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


RebarHostData Methods

[image] [image]

Revit 2013 API
RebarHostData Methods
RebarHostData Class See Also Send Feedback

The RebarHostData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAreaReinforcementsInHost | Returns all AreaReinforcement elements hosted by the referenced element.
Public method | GetCommonCoverType | If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).
Public method | GetCoverType | Gets the CoverType associated with a face of the element.
Public method | GetExposedFaces | Returns all the exposed faces, that is, those that have an associated CoverType.
Public method | GetFabricAreasInHost | Returns all FabricArea elements hosted by the referenced element.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPathReinforcementsInHost | Returns all PathReinforcement elements hosted by the referenced element.
 | GetRebarHostData | Gets a RebarHostData object referring to the specified rebar host element.
Public method | GetRebarsInHost | Returns all Rebar elements hosted by the referenced element.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsFaceExposed | Checks whether the specified face is considered exposed, and therefore has an associated CoverType.
Public method | IsValidHost | Reports whether the element is a valid rebar host.
Public method | SetCommonCoverType | Associate a single CoverType with all exposed faces of the host element.
Public method | SetCoverType | Associates the specified CoverType with the specified face of the element.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarHostData..::..Dispose Method
RebarHostData Class See Also Send Feedback
Releases all resources used by the RebarHostData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetAreaReinforcementsInHost Method

[image]

Revit 2013 API
RebarHostData..::..GetAreaReinforcementsInHost Method
RebarHostData Class See Also Send Feedback
Returns all AreaReinforcement elements hosted by the referenced element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<AreaReinforcement> GetAreaReinforcementsInHost()
Visual Basic
Public Function GetAreaReinforcementsInHost As IList(Of AreaReinforcement)
Visual C++
public:
IList<AreaReinforcement^>^ GetAreaReinforcementsInHost()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetCommonCoverType Method

[image]

Revit 2013 API
RebarHostData..::..GetCommonCoverType Method
RebarHostData Class See Also Send Feedback
If all exposed faces of the host have the same associated CoverType, return that CoverType; otherwise, return nullNothingnullptra null reference (Nothing in Visual Basic).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarCoverType GetCommonCoverType()
Visual Basic
Public Function GetCommonCoverType As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCommonCoverType()

Return Value

The common CoverType for all exposed faces, or nullNothingnullptra null reference (Nothing in Visual Basic) if there are multiple CoverTypes.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetCoverType Method

[image]

Revit 2013 API
RebarHostData..::..GetCoverType Method
RebarHostData Class See Also Send Feedback
Gets the CoverType associated with a face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarCoverType GetCoverType(
    Reference face
)
Visual Basic
Public Function GetCoverType ( _
    face As Reference _
) As RebarCoverType
Visual C++
public:
RebarCoverType^ GetCoverType(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference

Return Value

The cover associated with the face, if it is an exposed face. If the face is concealed, returns nullNothingnullptra null reference (Nothing in Visual Basic).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetExposedFaces Method

[image]

Revit 2013 API
RebarHostData..::..GetExposedFaces Method
RebarHostData Class See Also Send Feedback
Returns all the exposed faces, that is, those that have an associated CoverType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Reference> GetExposedFaces()
Visual Basic
Public Function GetExposedFaces As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ GetExposedFaces()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetFabricAreasInHost Method

[image]

Revit 2013 API
RebarHostData..::..GetFabricAreasInHost Method
RebarHostData Class See Also Send Feedback
Returns all FabricArea elements hosted by the referenced element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<FabricArea> GetFabricAreasInHost()
Visual Basic
Public Function GetFabricAreasInHost As IList(Of FabricArea)
Visual C++
public:
IList<FabricArea^>^ GetFabricAreasInHost()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetPathReinforcementsInHost Method

[image]

Revit 2013 API
RebarHostData..::..GetPathReinforcementsInHost Method
RebarHostData Class See Also Send Feedback
Returns all PathReinforcement elements hosted by the referenced element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<PathReinforcement> GetPathReinforcementsInHost()
Visual Basic
Public Function GetPathReinforcementsInHost As IList(Of PathReinforcement)
Visual C++
public:
IList<PathReinforcement^>^ GetPathReinforcementsInHost()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetRebarHostData Method

[image]

Revit 2013 API
RebarHostData..::..GetRebarHostData Method
RebarHostData Class See Also Send Feedback
Gets a RebarHostData object referring to the specified rebar host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static RebarHostData GetRebarHostData(
    Element host
)
Visual Basic
Public Shared Function GetRebarHostData ( _
    host As Element _
) As RebarHostData
Visual C++
public:
static RebarHostData^ GetRebarHostData(
    Element^ host
)

Parameters

host
Type: Autodesk.Revit.DB..::..Element
An element to host rebar.

Return Value

A RebarHostData object, or nullNothingnullptra null reference (Nothing in Visual Basic).

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) for elements that cannot ever be rebar hosts, such as levels.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


GetRebarsInHost Method

[image]

Revit 2013 API
RebarHostData..::..GetRebarsInHost Method
RebarHostData Class See Also Send Feedback
Returns all Rebar elements hosted by the referenced element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<Rebar> GetRebarsInHost()
Visual Basic
Public Function GetRebarsInHost As IList(Of Rebar)
Visual C++
public:
IList<Rebar^>^ GetRebarsInHost()

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


IsFaceExposed Method

[image]

Revit 2013 API
RebarHostData..::..IsFaceExposed Method
RebarHostData Class See Also Send Feedback
Checks whether the specified face is considered exposed, and therefore has an associated CoverType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsFaceExposed(
    Reference face
)
Visual Basic
Public Function IsFaceExposed ( _
    face As Reference _
) As Boolean
Visual C++
public:
bool IsFaceExposed(
    Reference^ face
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference

Return Value

True if %face% is exposed, false otherwise.

Remarks

This method replaces the method HasCoverTypeForReference() from the 2011 Revit API.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


IsValidHost Method

[image]

Revit 2013 API
RebarHostData..::..IsValidHost Method
RebarHostData Class See Also Send Feedback
Reports whether the element is a valid rebar host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsValidHost()
Visual Basic
Public Function IsValidHost As Boolean
Visual C++
public:
bool IsValidHost()

Return Value

True if the referenced Element can currently host Rebar elements, false otherwise.

Remarks

If GetRebarHostData() returns a RebarHostData object, but RebarHostData.IsValidHost() returns false, this means that the element can be made a valid rebar host, generally by setting a property like FLOOR_PARAM_IS_STRUCTURAL or by changing the element's physical material to concrete. On the other hand, if GetRebarHostData() returns nullNothingnullptra null reference (Nothing in Visual Basic), the element cannot be made into a rebar host. This method replaces the Valid property from the 2011 Revit API.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


SetCommonCoverType Method

[image]

Revit 2013 API
RebarHostData..::..SetCommonCoverType Method
RebarHostData Class See Also Send Feedback
Associate a single CoverType with all exposed faces of the host element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetCommonCoverType(
    RebarCoverType coverType
)
Visual Basic
Public Sub SetCommonCoverType ( _
    coverType As RebarCoverType _
)
Visual C++
public:
void SetCommonCoverType(
    RebarCoverType^ coverType
)

Parameters

coverType
Type: Autodesk.Revit.DB.Structure..::..RebarCoverType
A CoverType object to be applied to all faces.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


SetCoverType Method

[image]

Revit 2013 API
RebarHostData..::..SetCoverType Method
RebarHostData Class See Also Send Feedback
Associates the specified CoverType with the specified face of the element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetCoverType(
    Reference face,
    RebarCoverType coverType
)
Visual Basic
Public Sub SetCoverType ( _
    face As Reference, _
    coverType As RebarCoverType _
)
Visual C++
public:
void SetCoverType(
    Reference^ face,
    RebarCoverType^ coverType
)

Parameters

face
Type: Autodesk.Revit.DB..::..Reference
coverType
Type: Autodesk.Revit.DB.Structure..::..RebarCoverType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | In this element, face does not have an associated CoverType, because it is not exposed.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarHostData Class
Autodesk.Revit.DB.Structure Namespace


RebarInSystem Class

[image]

Revit 2013 API
RebarInSystem Class
Members See Also Send Feedback
Represents a rebar element that is part of a system.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RebarInSystem : Element
Visual Basic
Public Class RebarInSystem _
    Inherits Element
Visual C++
public ref class RebarInSystem : public Element

Remarks

A RebarInSystem element is part of another element, the "system", which controls most of its properties. The system elements are AreaReinforcement and PathReinforcement. Only a few properties of RebarInSystem are modifiable. Otherwise, the appearance and behavior of RebarInSystem elements is identical to Rebar elements. RebarInSystem elements may be converted to Rebar elements by removing the system element.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..RebarInSystem

See Also

RebarInSystem Members
Autodesk.Revit.DB.Structure Namespace


RebarInSystem Members

[image] [image]

Revit 2013 API
RebarInSystem Members
RebarInSystem Class Methods Properties See Also Send Feedback

The RebarInSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions |
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | SystemId | The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of an individual bar multiplied by Quantity.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


RebarInSystem Methods

[image] [image]

Revit 2013 API
RebarInSystem Methods
RebarInSystem Class See Also Send Feedback

The RebarInSystem type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | DoesBarExistAtPosition | Checks whether a bar exists at the specified position.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetBarPositionTransform | Return a transform representing the relative position of any individual bar in the set.
Public method | GetBendData | Gets the RebarBendData, containing bar and hook information, of the instance.
Public method | GetCenterlineCurves | A chain of curves representing the centerline of the rebar.
Public method | GetDistributionPath | The distribution path of a rebar set.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookTypeId | Get the id of the RebarHookType to be applied to the rebar.
Public method | GetHostId | The element that contains the rebar.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSolidInView | Checks if this rebar element is shown solidly in a 3D view.
Public method | IsUnobscuredInView | Checks if this rebar element is shown unobscured in a view.
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


DoesBarExistAtPosition Method

[image]

Revit 2013 API
RebarInSystem..::..DoesBarExistAtPosition Method
RebarInSystem Class See Also Send Feedback
Checks whether a bar exists at the specified position.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DoesBarExistAtPosition(
    int barPosition
)
Visual Basic
Public Function DoesBarExistAtPosition ( _
    barPosition As Integer _
) As Boolean
Visual C++
public:
bool DoesBarExistAtPosition(
    int barPosition
)

Parameters

barPosition
Type: System..::..Int32
A bar position index between 0 and NumberOfBarPositions-1.

Remarks

Returns true, unless the bar position is the first or last in the set and it is suppressed by IncludeFirstBar or IncludeLastBar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPosition is not in the range [ 0, NumberOfBarPositions-1 ].

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetBarPositionTransform Method

[image]

Revit 2013 API
RebarInSystem..::..GetBarPositionTransform Method
RebarInSystem Class See Also Send Feedback
Return a transform representing the relative position of any individual bar in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Transform GetBarPositionTransform(
    int barPositionIndex
)
Visual Basic
Public Function GetBarPositionTransform ( _
    barPositionIndex As Integer _
) As Transform
Visual C++
public:
Transform^ GetBarPositionTransform(
    int barPositionIndex
)

Parameters

barPositionIndex
Type: System..::..Int32
An index between 0 and (NumberOfBarPositions-1).

Return Value

The position of a bar in the set relative to the first position.

Remarks

The transform is a translation along the distribution path. It can be applied to the results of GetCenterlineCurves() to produce any bar in the rebar set. For barPositionIndex=0, the identity transform is always returned.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ].

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetBendData Method

[image]

Revit 2013 API
RebarInSystem..::..GetBendData Method
RebarInSystem Class See Also Send Feedback
Gets the RebarBendData, containing bar and hook information, of the instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RebarBendData GetBendData()
Visual Basic
Public Function GetBendData As RebarBendData
Visual C++
public:
RebarBendData^ GetBendData()

Remarks

Internally, the bend data is used by many RebarShape methods to generate shape geometry.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetCenterlineCurves Method

[image]

Revit 2013 API
RebarInSystem..::..GetCenterlineCurves Method
RebarInSystem Class See Also Send Feedback
A chain of curves representing the centerline of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<Curve> GetCenterlineCurves(
    bool adjustForSelfIntersection,
    bool suppressHooks,
    bool suppressBendRadius
)
Visual Basic
Public Function GetCenterlineCurves ( _
    adjustForSelfIntersection As Boolean, _
    suppressHooks As Boolean, _
    suppressBendRadius As Boolean _
) As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCenterlineCurves(
    bool adjustForSelfIntersection,
    bool suppressHooks,
    bool suppressBendRadius
)

Parameters

adjustForSelfIntersection
Type: System..::..Boolean
If the curves overlap, as in a planar stirrup, this parameter controls whether they should be adjusted to avoid intersection (as in fine views), or kept in a single plane for simplicity (as in coarse views).
suppressHooks
Type: System..::..Boolean
Identifies if the chain will include hooks curves.
suppressBendRadius
Type: System..::..Boolean
Identifies if the connected chain will include unfilleted curves.

Return Value

The centerline curves or empty array if the curves cannot be computed because the parameters values are inconsistent with the constraints of the RebarShape definition.

Remarks

If the Rebar is a set, meaning GetLayoutRule() does not return Single, this method returns the first rebar in the set, even if the first bar is suppressed by IncludeFirstBar being false.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetDistributionPath Method

[image]

Revit 2013 API
RebarInSystem..::..GetDistributionPath Method
RebarInSystem Class See Also Send Feedback
The distribution path of a rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Line GetDistributionPath()
Visual Basic
Public Function GetDistributionPath As Line
Visual C++
public:
Line^ GetDistributionPath()

Return Value

A line beginning at (0, 0, 0) and representing the direction and length of the set.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetHookTypeId Method

[image]

Revit 2013 API
RebarInSystem..::..GetHookTypeId Method
RebarInSystem Class See Also Send Feedback
Get the id of the RebarHookType to be applied to the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetHookTypeId(
    int end
)
Visual Basic
Public Function GetHookTypeId ( _
    end As Integer _
) As ElementId
Visual C++
public:
ElementId^ GetHookTypeId(
    int end
)

Parameters

end
Type: System..::..Int32
0 for the start hook, 1 for the end hook.

Return Value

The id of a RebarHookType, or invalidElementId if the rebar has no hook at the specified end.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | end must be 0 or 1.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


GetHostId Method

[image]

Revit 2013 API
RebarInSystem..::..GetHostId Method
RebarInSystem Class See Also Send Feedback
The element that contains the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId GetHostId()
Visual Basic
Public Function GetHostId As ElementId
Visual C++
public:
ElementId^ GetHostId()

Return Value

The element that the rebar object belongs to, such as a structural wall, floor, foundation, beam, brace or column.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


IsSolidInView Method

[image]

Revit 2013 API
RebarInSystem..::..IsSolidInView Method
RebarInSystem Class See Also Send Feedback
Checks if this rebar element is shown solidly in a 3D view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSolidInView(
    View3D view
)
Visual Basic
Public Function IsSolidInView ( _
    view As View3D _
) As Boolean
Visual C++
public:
bool IsSolidInView(
    View3D^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View3D
The 3D view element

Return Value

True if rebar is shown solidly, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


IsUnobscuredInView Method

[image]

Revit 2013 API
RebarInSystem..::..IsUnobscuredInView Method
RebarInSystem Class See Also Send Feedback
Checks if this rebar element is shown unobscured in a view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsUnobscuredInView(
    View view
)
Visual Basic
Public Function IsUnobscuredInView ( _
    view As View _
) As Boolean
Visual C++
public:
bool IsUnobscuredInView(
    View^ view
)

Parameters

view
Type: Autodesk.Revit.DB..::..View
The view element

Return Value

True if rebar is shown unobscured, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


RebarInSystem Properties

[image] [image]

Revit 2013 API
RebarInSystem Properties
RebarInSystem Class See Also Send Feedback

The RebarInSystem type exposes the following members.

Properties

 | Name | Description
Public property | ArrayLength | Identifies the distribution path length of rebar set.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BarsOnNormalSide | Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | LayoutRule | Identifies the layout rule of rebar set.
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | MaxSpacing | Identifies the maximum spacing between rebar in rebar set.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | Normal | A unit-length vector normal to the plane of the rebar
Public property | NumberOfBarPositions |
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | Quantity | Identifies the number of bars in rebar set.
Public property | RebarShapeId | The RebarShape element that defines the shape of the rebar.
Public property | ScheduleMark | The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.
Public property | SystemId | The Id of an AreaReinforcement or PathReinforcement element that owns this element.
Public property | TotalLength | The length of an individual bar multiplied by Quantity.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | Volume | The volume of an individual bar multiplied by Quantity.
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


ArrayLength Property

[image]

Revit 2013 API
RebarInSystem..::..ArrayLength Property
RebarInSystem Class See Also Send Feedback
Identifies the distribution path length of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double ArrayLength { get; }
Visual Basic
Public ReadOnly Property ArrayLength As Double
    Get
Visual C++
public:
property double ArrayLength {
    double get ();
}

Field Value

The distribution path length of rebar set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


BarsOnNormalSide Property

[image]

Revit 2013 API
RebarInSystem..::..BarsOnNormalSide Property
RebarInSystem Class See Also Send Feedback
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool BarsOnNormalSide { get; }
Visual Basic
Public ReadOnly Property BarsOnNormalSide As Boolean
    Get
Visual C++
public:
property bool BarsOnNormalSide {
    bool get ();
}

Field Value

True if the bars of rebar set are on the same side of the rebar plane indicated by the normal, and false if the bars are on the opposite side.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


LayoutRule Property

[image]

Revit 2013 API
RebarInSystem..::..LayoutRule Property
RebarInSystem Class See Also Send Feedback
Identifies the layout rule of rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RebarLayoutRule LayoutRule { get; }
Visual Basic
Public ReadOnly Property LayoutRule As RebarLayoutRule
    Get
Visual C++
public:
property RebarLayoutRule LayoutRule {
    RebarLayoutRule get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


MaxSpacing Property

[image]

Revit 2013 API
RebarInSystem..::..MaxSpacing Property
RebarInSystem Class See Also Send Feedback
Identifies the maximum spacing between rebar in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double MaxSpacing { get; }
Visual Basic
Public ReadOnly Property MaxSpacing As Double
    Get
Visual C++
public:
property double MaxSpacing {
    double get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InapplicableDataException | This rebar element represents a single bar (the layout rule is Single).

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


Normal Property

[image]

Revit 2013 API
RebarInSystem..::..Normal Property
RebarInSystem Class See Also Send Feedback
A unit-length vector normal to the plane of the rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
    Get
Visual C++
public:
property XYZ^ Normal {
    XYZ^ get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


NumberOfBarPositions Property

[image]

Revit 2013 API
RebarInSystem..::..NumberOfBarPositions Property
RebarInSystem Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int NumberOfBarPositions { get; }
Visual Basic
Public ReadOnly Property NumberOfBarPositions As Integer
    Get
Visual C++
public:
property int NumberOfBarPositions {
    int get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
RebarInSystem..::..Parameter Property
RebarInSystem Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RebarInSystem Class
RebarInSystem Members
Autodesk.Revit.DB.Structure Namespace


Quantity Property

[image]

Revit 2013 API
RebarInSystem..::..Quantity Property
RebarInSystem Class See Also Send Feedback
Identifies the number of bars in rebar set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int Quantity { get; }
Visual Basic
Public ReadOnly Property Quantity As Integer
    Get
Visual C++
public:
property int Quantity {
    int get ();
}

Field Value

The number of bars in rebar set.

Remarks

Quantity is equal to NumberOfBarPositions if IncludeFirstBar and IncludeLastBar are set. If any end bars are excluded, they are not counted in the Quantity.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeId Property

[image]

Revit 2013 API
RebarInSystem..::..RebarShapeId Property
RebarInSystem Class See Also Send Feedback
The RebarShape element that defines the shape of the rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId RebarShapeId { get; }
Visual Basic
Public ReadOnly Property RebarShapeId As ElementId
    Get
Visual C++
public:
property ElementId^ RebarShapeId {
    ElementId^ get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


ScheduleMark Property

[image]

Revit 2013 API
RebarInSystem..::..ScheduleMark Property
RebarInSystem Class See Also Send Feedback
The Schedule Mark parameter. On creation, the Schedule Mark is set to a value that is unique to the host, but it can be set to any value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string ScheduleMark { get; set; }
Visual Basic
Public Property ScheduleMark As String
    Get
    Set
Visual C++
public:
property String^ ScheduleMark {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


SystemId Property

[image]

Revit 2013 API
RebarInSystem..::..SystemId Property
RebarInSystem Class See Also Send Feedback
The Id of an AreaReinforcement or PathReinforcement element that owns this element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId SystemId { get; }
Visual Basic
Public ReadOnly Property SystemId As ElementId
    Get
Visual C++
public:
property ElementId^ SystemId {
    ElementId^ get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


TotalLength Property

[image]

Revit 2013 API
RebarInSystem..::..TotalLength Property
RebarInSystem Class See Also Send Feedback
The length of an individual bar multiplied by Quantity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double TotalLength { get; }
Visual Basic
Public ReadOnly Property TotalLength As Double
    Get
Visual C++
public:
property double TotalLength {
    double get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


Volume Property

[image]

Revit 2013 API
RebarInSystem..::..Volume Property
RebarInSystem Class See Also Send Feedback
The volume of an individual bar multiplied by Quantity.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public double Volume { get; }
Visual Basic
Public ReadOnly Property Volume As Double
    Get
Visual C++
public:
property double Volume {
    double get ();
}

See Also

RebarInSystem Class
Autodesk.Revit.DB.Structure Namespace


RebarLayoutRule Enumeration

[image]

Revit 2013 API
RebarLayoutRule Enumeration
See Also Send Feedback
The rule for how the rebars in rebar set are laid out

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarLayoutRule
Visual Basic
Public Enumeration RebarLayoutRule
Visual C++
public enum class RebarLayoutRule

Members

Member name | Description
Single | It is a single rebar and not a rebar set.
FixedNumber | The spacing between the rebar is adjustable, but the number of bars is constant based on input.
MaximumSpacing | The maximum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set.
NumberWithSpacing | Both the spacing between rebar and the number of rebar are constant based on input.
MinimumClearSpacing | The minimum distance between rebar is specified by input, and the number of rebar changes based on the length of rebar set. This spacing is maintained even if the rebar size changes.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShape Class

[image]

Revit 2013 API
RebarShape Class
Members See Also Send Feedback
RebarShape specifies the shape type for a Rebar instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public class RebarShape : ElementType
Visual Basic
Public Class RebarShape _
    Inherits ElementType
Visual C++
public ref class RebarShape : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..RebarShape

See Also

RebarShape Members
Autodesk.Revit.DB.Structure Namespace


RebarShape Members

[image] [image]

Revit 2013 API
RebarShape Members
RebarShape Class Methods Properties See Also Send Feedback

The RebarShape type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a new instance of a Rebar Shape, which defines the shape of a rebar.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookAngle | Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).
Public method | GetHookOrientation | Get the hook orientation.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMultiplanarDefinition | The optional 3D structure of the shape.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetRebarShapeDefinition | Return the definition of the RebarShape.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSameShapeIgnoringHooks | Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HigherEnd | Defines the higher end of rebar shape.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RebarStyle | Whether the shape represents a standard bar or a stirrup.
Public property | SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
Public property | SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
Public property | StirrupTieAttachment |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Methods

[image] [image]

Revit 2013 API
RebarShape Methods
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a new instance of a Rebar Shape, which defines the shape of a rebar.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAllowed | Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetCurvesForBrowser | Generate curves for the shape, as used in the shape browser.
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHookAngle | Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).
Public method | GetHookOrientation | Get the hook orientation.
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMultiplanarDefinition | The optional 3D structure of the shape.
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetRebarShapeDefinition | Return the definition of the RebarShape.
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSameShapeIgnoringHooks | Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetAllowed | Specify which bar types can be used with this RebarShape. Bar types are allowed by default.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
RebarShape..::..Create Method
RebarShape Class See Also Send Feedback
Create a new instance of a Rebar Shape, which defines the shape of a rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static RebarShape Create(
    Document doc,
    RebarShapeDefinition definition,
    RebarShapeMultiplanarDefinition multiplanarDefinition,
    RebarStyle style,
    StirrupTieAttachmentType attachmentType,
    int startHookAngle,
    RebarHookOrientation startHookOrientation,
    int endHookAngle,
    RebarHookOrientation endHookOrientation,
    int higherEnd
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    definition As RebarShapeDefinition, _
    multiplanarDefinition As RebarShapeMultiplanarDefinition, _
    style As RebarStyle, _
    attachmentType As StirrupTieAttachmentType, _
    startHookAngle As Integer, _
    startHookOrientation As RebarHookOrientation, _
    endHookAngle As Integer, _
    endHookOrientation As RebarHookOrientation, _
    higherEnd As Integer _
) As RebarShape
Visual C++
public:
static RebarShape^ Create(
    Document^ doc,
    RebarShapeDefinition^ definition,
    RebarShapeMultiplanarDefinition^ multiplanarDefinition,
    RebarStyle style,
    StirrupTieAttachmentType attachmentType,
    int startHookAngle,
    RebarHookOrientation startHookOrientation,
    int endHookAngle,
    RebarHookOrientation endHookOrientation,
    int higherEnd
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document to contain the RebarShape.
definition
Type: Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
The definition of the rebar shape, as a set of curves in a plane driven by parameters.
multiplanarDefinition
Type: Autodesk.Revit.DB.Structure..::..RebarShapeMultiplanarDefinition
If not null, the created RebarShape will be a 3D shape. The shape is built out of the planar RebarShapeDefinition, with additional out-of-plane segments defined by the RebarShapeMultiplanarDefinition object. Not supported in conjunction with RebarShapeDefinitionByArc of type Spiral or LappedCircle.
style
Type: Autodesk.Revit.DB.Structure..::..RebarStyle
Whether the shape is to be used as a standard bar or a stirrup/tie.
attachmentType
Type: Autodesk.Revit.DB.Structure..::..StirrupTieAttachmentType
When the style is stirrup/tie, specify whether it will attach to the interior of cover (cover is measured to the stirrups), or to the exterior of cover (cover is measured to the standard bars). Ignored when the style is Standard.
startHookAngle
Type: System..::..Int32
The start hook angle, expressed as an integral number of degrees. If 0, the shape will have no start hook. Common values are 0, 90, 135, and 180.
startHookOrientation
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the start hook. Ignored when startHookAngle is 0.
endHookAngle
Type: System..::..Int32
The end hook angle, expressed as an integral number of degrees. If 0, the shape will have no end hook. Common values are 0, 90, 135, and 180.
endHookOrientation
Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
The orientation of the end hook. Ignored when endHookAngle is 0.
higherEnd
Type: System..::..Int32
When the rebar crosses itself, one end will be "lifted" to avoid self-intersection. Specify which end should be lifted: 0 for start, 1 for end.

Return Value

A new RebarShape instance.

Remarks

Replaces the method Autodesk.Revit.Creation.NewRebarShape() from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | definition is linked to a Document other than doc. -or- A multiplanar definition is specified when the given RebarShapeDefinition does not support it. The following RebarShapeDefinitions do not support multiplanar: a simple line; spiral; lapped circle. -or- The DepthParamId property of multiplanarDefinition is invalid or has not been added to definition.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | startHookAngle must be at least 0 and no more than 180. -or- endHookAngle must be at least 0 and no more than 180. -or- higherEnd must be 0 or 1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetAllowed Method

[image]

Revit 2013 API
RebarShape..::..GetAllowed Method
RebarShape Class See Also Send Feedback
Check whether a bar type can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool GetAllowed(
    RebarBarType barType
)
Visual Basic
Public Function GetAllowed ( _
    barType As RebarBarType _
) As Boolean
Visual C++
public:
bool GetAllowed(
    RebarBarType^ barType
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A bar type in the same document as this shape.

Return Value

True if this shape may be combined with this barType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetCurvesForBrowser Method

[image]

Revit 2013 API
RebarShape..::..GetCurvesForBrowser Method
RebarShape Class See Also Send Feedback
Generate curves for the shape, as used in the shape browser.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public IList<Curve> GetCurvesForBrowser()
Visual Basic
Public Function GetCurvesForBrowser As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetCurvesForBrowser()

Return Value

An array of curves representing the shape with its default parameters.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetHookAngle Method

[image]

Revit 2013 API
RebarShape..::..GetHookAngle Method
RebarShape Class See Also Send Feedback
Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int GetHookAngle(
    int index
)
Visual Basic
Public Function GetHookAngle ( _
    index As Integer _
) As Integer
Visual C++
public:
int GetHookAngle(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Replaces the property RebarShape.HookAngle from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index must be 0 or 1.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetHookOrientation Method

[image]

Revit 2013 API
RebarShape..::..GetHookOrientation Method
RebarShape Class See Also Send Feedback
Get the hook orientation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarHookOrientation GetHookOrientation(
    int index
)
Visual Basic
Public Function GetHookOrientation ( _
    index As Integer _
) As RebarHookOrientation
Visual C++
public:
RebarHookOrientation GetHookOrientation(
    int index
)

Parameters

index
Type: System..::..Int32
0 for the starting hook, 1 for the ending hook.

Remarks

Replaces the property RebarShape.HookOrientation from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index must be 0 or 1.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetMultiplanarDefinition Method

[image]

Revit 2013 API
RebarShape..::..GetMultiplanarDefinition Method
RebarShape Class See Also Send Feedback
The optional 3D structure of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeMultiplanarDefinition GetMultiplanarDefinition()
Visual Basic
Public Function GetMultiplanarDefinition As RebarShapeMultiplanarDefinition
Visual C++
public:
RebarShapeMultiplanarDefinition^ GetMultiplanarDefinition()

Return Value

A copy of the multiplanar definition. Changes will not affect the RebarShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


GetRebarShapeDefinition Method

[image]

Revit 2013 API
RebarShape..::..GetRebarShapeDefinition Method
RebarShape Class See Also Send Feedback
Return the definition of the RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeDefinition GetRebarShapeDefinition()
Visual Basic
Public Function GetRebarShapeDefinition As RebarShapeDefinition
Visual C++
public:
RebarShapeDefinition^ GetRebarShapeDefinition()

Return Value

A copy of the definition. Changes will not affect the RebarShape.

Remarks

Replaces the property RebarShape.Definition from previous releases.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


IsSameShapeIgnoringHooks Method

[image]

Revit 2013 API
RebarShape..::..IsSameShapeIgnoringHooks Method
RebarShape Class See Also Send Feedback
Test whether two shapes have equivalent definitions by comparing the RebarShapeDefinition and MultiplanarDefinition properties.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsSameShapeIgnoringHooks(
    RebarShape otherShape
)
Visual Basic
Public Function IsSameShapeIgnoringHooks ( _
    otherShape As RebarShape _
) As Boolean
Visual C++
public:
bool IsSameShapeIgnoringHooks(
    RebarShape^ otherShape
)

Parameters

otherShape
Type: Autodesk.Revit.DB.Structure..::..RebarShape
Another shape to be compared to this one.

Return Value

True if the shape definitions match, false otherwise.

Remarks

This method will return true if the definitions are exactly equivalent, or if they are equivalent but have the opposite start/end orientation. Replaces the property RebarShape.SameShapeIgnoringHooks from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SetAllowed Method

[image]

Revit 2013 API
RebarShape..::..SetAllowed Method
RebarShape Class See Also Send Feedback
Specify which bar types can be used with this RebarShape. Bar types are allowed by default.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetAllowed(
    RebarBarType barType,
    bool allowed
)
Visual Basic
Public Sub SetAllowed ( _
    barType As RebarBarType, _
    allowed As Boolean _
)
Visual C++
public:
void SetAllowed(
    RebarBarType^ barType,
    bool allowed
)

Parameters

barType
Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A bar type in the same document as this shape.
allowed
Type: System..::..Boolean
Whether this shape may be combined with barType.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShape Properties

[image] [image]

Revit 2013 API
RebarShape Properties
RebarShape Class See Also Send Feedback

The RebarShape type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | HigherEnd | Defines the higher end of rebar shape.
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | RebarStyle | Whether the shape represents a standard bar or a stirrup.
Public property | SimpleArc | Check whether this shape consists of a single arc, possibly with hooks.
Public property | SimpleLine | Check whether this shape consists of a single straight segment, possibly with hooks.
Public property | StirrupTieAttachment |
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


HigherEnd Property

[image]

Revit 2013 API
RebarShape..::..HigherEnd Property
RebarShape Class See Also Send Feedback
Defines the higher end of rebar shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public int HigherEnd { get; }
Visual Basic
Public ReadOnly Property HigherEnd As Integer
    Get
Visual C++
public:
property int HigherEnd {
    int get ();
}

Field Value

0 for start, 1 for end.

Remarks

Change this property will make rebar shape's start and end hooks swap.

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
RebarShape..::..Parameter Property
RebarShape Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

RebarShape Class
RebarShape Members
Autodesk.Revit.DB.Structure Namespace


RebarStyle Property

[image]

Revit 2013 API
RebarShape..::..RebarStyle Property
RebarShape Class See Also Send Feedback
Whether the shape represents a standard bar or a stirrup.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public RebarStyle RebarStyle { get; }
Visual Basic
Public ReadOnly Property RebarStyle As RebarStyle
    Get
Visual C++
public:
property RebarStyle RebarStyle {
    RebarStyle get ();
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SimpleArc Property

[image]

Revit 2013 API
RebarShape..::..SimpleArc Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single arc, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool SimpleArc { get; }
Visual Basic
Public ReadOnly Property SimpleArc As Boolean
    Get
Visual C++
public:
property bool SimpleArc {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


SimpleLine Property

[image]

Revit 2013 API
RebarShape..::..SimpleLine Property
RebarShape Class See Also Send Feedback
Check whether this shape consists of a single straight segment, possibly with hooks.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool SimpleLine { get; }
Visual Basic
Public ReadOnly Property SimpleLine As Boolean
    Get
Visual C++
public:
property bool SimpleLine {
    bool get ();
}

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


StirrupTieAttachment Property

[image]

Revit 2013 API
RebarShape..::..StirrupTieAttachment Property
RebarShape Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public StirrupTieAttachmentType StirrupTieAttachment { get; }
Visual Basic
Public ReadOnly Property StirrupTieAttachment As StirrupTieAttachmentType
    Get
Visual C++
public:
property StirrupTieAttachmentType StirrupTieAttachment {
    StirrupTieAttachmentType get ();
}

Field Value

Access attachment type of stirrup/tie rebar

See Also

RebarShape Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeArcReferenceType Enumeration

[image]

Revit 2013 API
RebarShapeArcReferenceType Enumeration
See Also Send Feedback
A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarShapeArcReferenceType
Visual Basic
Public Enumeration RebarShapeArcReferenceType
Visual C++
public enum class RebarShapeArcReferenceType

Members

Member name | Description
Internal | Measure to the interior of the bend.
Centerline | Measure to the centerline of the bar.
External | Measure to the exterior of the bend.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeBendAngle Enumeration

[image]

Revit 2013 API
RebarShapeBendAngle Enumeration
See Also Send Feedback
A bend in a rebar shape has an angular range specified by one of these values. The angles refer to the angle swept out by one segment as it is bent relative to another. That is, an "Obtuse" bend results in two segments that meet at an angle that is less than 90 degrees when measured internally. Put another way, to create an equilateral triangle, you would need two "Obtuse" bends.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarShapeBendAngle
Visual Basic
Public Enumeration RebarShapeBendAngle
Visual C++
public enum class RebarShapeBendAngle

Members

Member name | Description
Acute | The angle is less than 90 degrees.
Right | The angle is 90 degrees.
Obtuse | The angle is between 90 and 180 degrees.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint Class

[image]

Revit 2013 API
RebarShapeConstraint Class
Members See Also Send Feedback
A dimension or other constraint that takes part in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraint : IDisposable
Visual Basic
Public Class RebarShapeConstraint _
    Implements IDisposable
Visual C++
public ref class RebarShapeConstraint : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendArcLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendRadius
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeDefaultBend
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintAngleFromFixedDir
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintArcLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintChordLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintCircumference
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintDiameter
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintFixedSegmentDir
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintProjectedSegmentLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintRadius
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSagittaLength
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSegmentLength

See Also

RebarShapeConstraint Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint Members

[image] [image]

Revit 2013 API
RebarShapeConstraint Members
RebarShapeConstraint Class Methods See Also Send Feedback

The RebarShapeConstraint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeConstraint
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint Methods

[image] [image]

Revit 2013 API
RebarShapeConstraint Methods
RebarShapeConstraint Class See Also Send Feedback

The RebarShapeConstraint type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeConstraint..::..Dispose Method
RebarShapeConstraint Class See Also Send Feedback
Releases all resources used by the RebarShapeConstraint

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeConstraint Class
Autodesk.Revit.DB.Structure Namespace


GetParamId Method

[image]

Revit 2013 API
RebarShapeConstraint..::..GetParamId Method
RebarShapeConstraint Class See Also Send Feedback
Return the Id of the parameter associated with this constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public ElementId GetParamId()
Visual Basic
Public Function GetParamId As ElementId
Visual C++
public:
ElementId^ GetParamId()

Return Value

The Id of the parameter, or InvalidElementId if the constraint does not have one.

Remarks

Most subclasses of RebarShapeConstraint require a parameter.

See Also

RebarShapeConstraint Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendArcLength Class

[image]

Revit 2013 API
RebarShapeConstraint180DegreeBendArcLength Class
Members See Also Send Feedback
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraint180DegreeBendArcLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraint180DegreeBendArcLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraint180DegreeBendArcLength : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendArcLength

See Also

RebarShapeConstraint180DegreeBendArcLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendArcLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeBendArcLength Members
RebarShapeConstraint180DegreeBendArcLength Class Constructors Methods See Also Send Feedback

The RebarShapeConstraint180DegreeBendArcLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraint180DegreeBendArcLength | Create a 180-degree bend constraint driven by arc length.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint180DegreeBendArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendArcLength Constructor

[image]

Revit 2013 API
RebarShapeConstraint180DegreeBendArcLength Constructor
RebarShapeConstraint180DegreeBendArcLength Class See Also Send Feedback
Create a 180-degree bend constraint driven by arc length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraint180DegreeBendArcLength(
    ElementId paramId
)
Visual Basic
Public Sub New ( _
    paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraint180DegreeBendArcLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraint180DegreeBendArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendArcLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeBendArcLength Methods
RebarShapeConstraint180DegreeBendArcLength Class See Also Send Feedback

The RebarShapeConstraint180DegreeBendArcLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint180DegreeBendArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendRadius Class

[image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Class
Members See Also Send Feedback
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the radius of the arc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraint180DegreeBendRadius : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraint180DegreeBendRadius _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraint180DegreeBendRadius : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeBendRadius

See Also

RebarShapeConstraint180DegreeBendRadius Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendRadius Members

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Members
RebarShapeConstraint180DegreeBendRadius Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraint180DegreeBendRadius type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraint180DegreeBendRadius | Create a 180-degree bend constraint driven by radius.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArcReferenceType | A choice of rule for measuring the radius.

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendRadius Constructor

[image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Constructor
RebarShapeConstraint180DegreeBendRadius Class See Also Send Feedback
Create a 180-degree bend constraint driven by radius.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraint180DegreeBendRadius(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraint180DegreeBendRadius(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the radius.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendRadius Methods

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Methods
RebarShapeConstraint180DegreeBendRadius Class See Also Send Feedback

The RebarShapeConstraint180DegreeBendRadius type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeBendRadius Properties

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius Properties
RebarShapeConstraint180DegreeBendRadius Class See Also Send Feedback

The RebarShapeConstraint180DegreeBendRadius type exposes the following members.

Properties

 | Name | Description
Public property | ArcReferenceType | A choice of rule for measuring the radius.

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace


ArcReferenceType Property

[image]

Revit 2013 API
RebarShapeConstraint180DegreeBendRadius..::..ArcReferenceType Property
RebarShapeConstraint180DegreeBendRadius Class See Also Send Feedback
A choice of rule for measuring the radius.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeArcReferenceType ArcReferenceType { get; }
Visual Basic
Public ReadOnly Property ArcReferenceType As RebarShapeArcReferenceType
    Get
Visual C++
public:
property RebarShapeArcReferenceType ArcReferenceType {
    RebarShapeArcReferenceType get ();
}

See Also

RebarShapeConstraint180DegreeBendRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeDefaultBend Class

[image]

Revit 2013 API
RebarShapeConstraint180DegreeDefaultBend Class
Members See Also Send Feedback
A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The arc's radius is not specified by the shape; instead it is a "default bend radius," taken from the RebarBarType associated with the Rebar instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraint180DegreeDefaultBend : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraint180DegreeDefaultBend _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraint180DegreeDefaultBend : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint180DegreeDefaultBend

See Also

RebarShapeConstraint180DegreeDefaultBend Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeDefaultBend Members

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeDefaultBend Members
RebarShapeConstraint180DegreeDefaultBend Class Constructors Methods See Also Send Feedback

The RebarShapeConstraint180DegreeDefaultBend type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraint180DegreeDefaultBend | Create a 180-degree bend constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint180DegreeDefaultBend Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeDefaultBend Constructor

[image]

Revit 2013 API
RebarShapeConstraint180DegreeDefaultBend Constructor
RebarShapeConstraint180DegreeDefaultBend Class See Also Send Feedback
Create a 180-degree bend constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraint180DegreeDefaultBend()
Visual Basic
Public Sub New
Visual C++
public:
RebarShapeConstraint180DegreeDefaultBend()

See Also

RebarShapeConstraint180DegreeDefaultBend Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraint180DegreeDefaultBend Methods

[image] [image]

Revit 2013 API
RebarShapeConstraint180DegreeDefaultBend Methods
RebarShapeConstraint180DegreeDefaultBend Class See Also Send Feedback

The RebarShapeConstraint180DegreeDefaultBend type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraint180DegreeDefaultBend Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintAngleFromFixedDir Class

[image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Class
Members See Also Send Feedback
A constraint which can be applied to a RebarShapeSegment and drives the angle of the segment relative to a fixed direction in UV-space.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintAngleFromFixedDir : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintAngleFromFixedDir _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintAngleFromFixedDir : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintAngleFromFixedDir

See Also

RebarShapeConstraintAngleFromFixedDir Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintAngleFromFixedDir Members

[image] [image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Members
RebarShapeConstraintAngleFromFixedDir Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintAngleFromFixedDir | Create an angular constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property | Sign | When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintAngleFromFixedDir Constructor

[image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Constructor
RebarShapeConstraintAngleFromFixedDir Class See Also Send Feedback
Create an angular constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintAngleFromFixedDir(
    ElementId paramId,
    int sign,
    UV direction
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    sign As Integer, _
    direction As UV _
)
Visual C++
public:
RebarShapeConstraintAngleFromFixedDir(
    ElementId^ paramId,
    int sign,
    UV^ direction
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
A Rebar Shape parameter of type UT_Angle.
sign
Type: System..::..Int32
The sign of the angle relative to the direction.
direction
Type: Autodesk.Revit.DB..::..UV
A fixed direction in UV-space.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | sign is not 1 or -1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | direction has zero length.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintAngleFromFixedDir Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Methods
RebarShapeConstraintAngleFromFixedDir Class See Also Send Feedback

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintAngleFromFixedDir Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir Properties
RebarShapeConstraintAngleFromFixedDir Class See Also Send Feedback

The RebarShapeConstraintAngleFromFixedDir type exposes the following members.

Properties

 | Name | Description
Public property | Direction | A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.
Public property | Sign | When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir..::..Direction Property
RebarShapeConstraintAngleFromFixedDir Class See Also Send Feedback
A fixed direction in UV-space. The parameter will drive the segment's angle relative to this direction.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Direction { get; set; }
Visual Basic
Public Property Direction As UV
    Get
    Set
Visual C++
public:
property UV^ Direction {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: direction has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


Sign Property

[image]

Revit 2013 API
RebarShapeConstraintAngleFromFixedDir..::..Sign Property
RebarShapeConstraintAngleFromFixedDir Class See Also Send Feedback
When the sign is 1, the Direction is rotated clockwise by the angle's value. When -1, the Direction is rotated counter-clockwise.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int Sign { get; set; }
Visual Basic
Public Property Sign As Integer
    Get
    Set
Visual C++
public:
property int Sign {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: sign is not 1 or -1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintAngleFromFixedDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintArcLength Class

[image]

Revit 2013 API
RebarShapeConstraintArcLength Class
Members See Also Send Feedback
An arc-length constraint associated with an arc in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintArcLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintArcLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintArcLength : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintArcLength

See Also

RebarShapeConstraintArcLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintArcLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraintArcLength Members
RebarShapeConstraintArcLength Class Constructors Methods See Also Send Feedback

The RebarShapeConstraintArcLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintArcLength | Create an arc-length constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintArcLength Constructor

[image]

Revit 2013 API
RebarShapeConstraintArcLength Constructor
RebarShapeConstraintArcLength Class See Also Send Feedback
Create an arc-length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintArcLength(
    ElementId paramId
)
Visual Basic
Public Sub New ( _
    paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraintArcLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintArcLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintArcLength Methods
RebarShapeConstraintArcLength Class See Also Send Feedback

The RebarShapeConstraintArcLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintArcLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintChordLength Class

[image]

Revit 2013 API
RebarShapeConstraintChordLength Class
Members See Also Send Feedback
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the straight distance between the arc endpoints.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintChordLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintChordLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintChordLength : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintChordLength

See Also

RebarShapeConstraintChordLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintChordLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraintChordLength Members
RebarShapeConstraintChordLength Class Constructors Methods See Also Send Feedback

The RebarShapeConstraintChordLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintChordLength | Create a constraint to drive chord length.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintChordLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintChordLength Constructor

[image]

Revit 2013 API
RebarShapeConstraintChordLength Constructor
RebarShapeConstraintChordLength Class See Also Send Feedback
Create a constraint to drive chord length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintChordLength(
    ElementId paramId
)
Visual Basic
Public Sub New ( _
    paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraintChordLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintChordLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintChordLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintChordLength Methods
RebarShapeConstraintChordLength Class See Also Send Feedback

The RebarShapeConstraintChordLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintChordLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintCircumference Class

[image]

Revit 2013 API
RebarShapeConstraintCircumference Class
Members See Also Send Feedback
A circumference constraint associated with an arc in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintCircumference : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintCircumference _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintCircumference : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintCircumference

See Also

RebarShapeConstraintCircumference Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintCircumference Members

[image] [image]

Revit 2013 API
RebarShapeConstraintCircumference Members
RebarShapeConstraintCircumference Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintCircumference type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintCircumference | Create a circumference constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the diameter.

See Also

RebarShapeConstraintCircumference Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintCircumference Constructor

[image]

Revit 2013 API
RebarShapeConstraintCircumference Constructor
RebarShapeConstraintCircumference Class See Also Send Feedback
Create a circumference constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintCircumference(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraintCircumference(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the circumference.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintCircumference Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintCircumference Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintCircumference Methods
RebarShapeConstraintCircumference Class See Also Send Feedback

The RebarShapeConstraintCircumference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintCircumference Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintCircumference Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintCircumference Properties
RebarShapeConstraintCircumference Class See Also Send Feedback

The RebarShapeConstraintCircumference type exposes the following members.

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the diameter.

See Also

RebarShapeConstraintCircumference Class
Autodesk.Revit.DB.Structure Namespace


ArcReferenceType Property

[image]

Revit 2013 API
RebarShapeConstraintCircumference..::..ArcReferenceType Property
RebarShapeConstraintCircumference Class See Also Send Feedback
The choice of rule for measuring the diameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeArcReferenceType ArcReferenceType { get; }
Visual Basic
Public ReadOnly Property ArcReferenceType As RebarShapeArcReferenceType
    Get
Visual C++
public:
property RebarShapeArcReferenceType ArcReferenceType {
    RebarShapeArcReferenceType get ();
}

See Also

RebarShapeConstraintCircumference Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintDiameter Class

[image]

Revit 2013 API
RebarShapeConstraintDiameter Class
Members See Also Send Feedback
A diameter constraint associated with an arc in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintDiameter : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintDiameter _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintDiameter : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintDiameter

See Also

RebarShapeConstraintDiameter Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintDiameter Members

[image] [image]

Revit 2013 API
RebarShapeConstraintDiameter Members
RebarShapeConstraintDiameter Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintDiameter type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintDiameter | Create a diameter constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the diameter.

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintDiameter Constructor

[image]

Revit 2013 API
RebarShapeConstraintDiameter Constructor
RebarShapeConstraintDiameter Class See Also Send Feedback
Create a diameter constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintDiameter(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraintDiameter(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the diameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintDiameter Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintDiameter Methods
RebarShapeConstraintDiameter Class See Also Send Feedback

The RebarShapeConstraintDiameter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintDiameter Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintDiameter Properties
RebarShapeConstraintDiameter Class See Also Send Feedback

The RebarShapeConstraintDiameter type exposes the following members.

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the diameter.

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace


ArcReferenceType Property

[image]

Revit 2013 API
RebarShapeConstraintDiameter..::..ArcReferenceType Property
RebarShapeConstraintDiameter Class See Also Send Feedback
The choice of rule for measuring the diameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeArcReferenceType ArcReferenceType { get; }
Visual Basic
Public ReadOnly Property ArcReferenceType As RebarShapeArcReferenceType
    Get
Visual C++
public:
property RebarShapeArcReferenceType ArcReferenceType {
    RebarShapeArcReferenceType get ();
}

See Also

RebarShapeConstraintDiameter Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintFixedSegmentDir Class

[image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir Class
Members See Also Send Feedback
A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintFixedSegmentDir : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintFixedSegmentDir _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintFixedSegmentDir : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintFixedSegmentDir

See Also

RebarShapeConstraintFixedSegmentDir Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintFixedSegmentDir Members

[image] [image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir Members
RebarShapeConstraintFixedSegmentDir Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintFixedSegmentDir type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintFixedSegmentDir | Create a fixed segment direction constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction |

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintFixedSegmentDir Constructor

[image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir Constructor
RebarShapeConstraintFixedSegmentDir Class See Also Send Feedback
Create a fixed segment direction constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintFixedSegmentDir(
    UV dir
)
Visual Basic
Public Sub New ( _
    dir As UV _
)
Visual C++
public:
RebarShapeConstraintFixedSegmentDir(
    UV^ dir
)

Parameters

dir
Type: Autodesk.Revit.DB..::..UV
A fixed direction in UV-space.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintFixedSegmentDir Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir Methods
RebarShapeConstraintFixedSegmentDir Class See Also Send Feedback

The RebarShapeConstraintFixedSegmentDir type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintFixedSegmentDir Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir Properties
RebarShapeConstraintFixedSegmentDir Class See Also Send Feedback

The RebarShapeConstraintFixedSegmentDir type exposes the following members.

Properties

 | Name | Description
Public property | Direction |

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2013 API
RebarShapeConstraintFixedSegmentDir..::..Direction Property
RebarShapeConstraintFixedSegmentDir Class See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Direction { get; set; }
Visual Basic
Public Property Direction As UV
    Get
    Set
Visual C++
public:
property UV^ Direction {
    UV^ get ();
    void set (UV^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintFixedSegmentDir Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintProjectedSegmentLength Class

[image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Class
Members See Also Send Feedback
A constraint that measures the length of a segment as measured by projecting onto a direction that is not parallel to the segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintProjectedSegmentLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintProjectedSegmentLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintProjectedSegmentLength : public RebarShapeConstraint

Remarks

The constraint has two references, indexed by 0 and 1, that do not have to correspond to the start and end of the segment. The constraint also specifies a direction as a 2D vector, which is not necessarily parallel to the segment, but must point from the segment's start toward its end.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintProjectedSegmentLength

See Also

RebarShapeConstraintProjectedSegmentLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintProjectedSegmentLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Members
RebarShapeConstraintProjectedSegmentLength Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintProjectedSegmentLength | Initializes a new instance of the RebarShapeConstraintProjectedSegmentLength class

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Direction | A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.
Public property | TripleProductSign | Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintProjectedSegmentLength Constructor

[image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Constructor
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback
Initializes a new instance of the RebarShapeConstraintProjectedSegmentLength class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintProjectedSegmentLength(
    ElementId paramId,
    UV direction,
    int tripleProductSign,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    direction As UV, _
    tripleProductSign As Integer, _
    refType0 As RebarShapeSegmentEndReferenceType, _
    refType1 As RebarShapeSegmentEndReferenceType _
)
Visual C++
public:
RebarShapeConstraintProjectedSegmentLength(
    ElementId^ paramId,
    UV^ direction,
    int tripleProductSign,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
direction
Type: Autodesk.Revit.DB..::..UV
A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment's direction has a positive dot product with this vector.
tripleProductSign
Type: System..::..Int32
Sign of the z-coordinate of the cross product of the "dir" argument with the segment vector. In other words, 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.
refType0
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
refType1
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier. -or- tripleProductSign is not 1 or -1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | direction has zero length.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintProjectedSegmentLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Methods
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


GetSegmentEndReferenceType Method

[image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength..::..GetSegmentEndReferenceType Method
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback
Choice of two possibilities for the start and end references of the length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
    int index
)
Visual Basic
Public Function GetSegmentEndReferenceType ( _
    index As Integer _
) As RebarShapeSegmentEndReferenceType
Visual C++
public:
RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
    int index
)

Parameters

index
Type: System..::..Int32
Which reference on the constraint. Either 0 or 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not 0 or 1.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintProjectedSegmentLength Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength Properties
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback

The RebarShapeConstraintProjectedSegmentLength type exposes the following members.

Properties

 | Name | Description
Public property | Direction | A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.
Public property | TripleProductSign | Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


Direction Property

[image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength..::..Direction Property
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback
A vector specifying the direction of the constraint. The direction is fixed, and the shape is always constructed so that the segment direction has a positive dot product with this vector.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UV Direction { get; }
Visual Basic
Public ReadOnly Property Direction As UV
    Get
Visual C++
public:
property UV^ Direction {
    UV^ get ();
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: direction has zero length.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


TripleProductSign Property

[image]

Revit 2013 API
RebarShapeConstraintProjectedSegmentLength..::..TripleProductSign Property
RebarShapeConstraintProjectedSegmentLength Class See Also Send Feedback
Sign of the z-coordinate of the cross product of the Direction property with the segment vector. TripleProductSign is 1 if the segment direction is to be on the left of the constraint direction, or -1 if the segment direction is to be on the right.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int TripleProductSign { get; }
Visual Basic
Public ReadOnly Property TripleProductSign As Integer
    Get
Visual C++
public:
property int TripleProductSign {
    int get ();
}

See Also

RebarShapeConstraintProjectedSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintRadius Class

[image]

Revit 2013 API
RebarShapeConstraintRadius Class
Members See Also Send Feedback
A radius constraint associated with an arc in a RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintRadius : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintRadius _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintRadius : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintRadius

See Also

RebarShapeConstraintRadius Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintRadius Members

[image] [image]

Revit 2013 API
RebarShapeConstraintRadius Members
RebarShapeConstraintRadius Class Constructors Methods Properties See Also Send Feedback

The RebarShapeConstraintRadius type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintRadius | Create a radius constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the radius.

See Also

RebarShapeConstraintRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintRadius Constructor

[image]

Revit 2013 API
RebarShapeConstraintRadius Constructor
RebarShapeConstraintRadius Class See Also Send Feedback
Create a radius constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintRadius(
    ElementId paramId,
    RebarShapeArcReferenceType refType
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType As RebarShapeArcReferenceType _
)
Visual C++
public:
RebarShapeConstraintRadius(
    ElementId^ paramId,
    RebarShapeArcReferenceType refType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
A choice of rule for measuring the radius.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintRadius Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintRadius Methods
RebarShapeConstraintRadius Class See Also Send Feedback

The RebarShapeConstraintRadius type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintRadius Properties

[image] [image]

Revit 2013 API
RebarShapeConstraintRadius Properties
RebarShapeConstraintRadius Class See Also Send Feedback

The RebarShapeConstraintRadius type exposes the following members.

Properties

 | Name | Description
Public property | ArcReferenceType | The choice of rule for measuring the radius.

See Also

RebarShapeConstraintRadius Class
Autodesk.Revit.DB.Structure Namespace


ArcReferenceType Property

[image]

Revit 2013 API
RebarShapeConstraintRadius..::..ArcReferenceType Property
RebarShapeConstraintRadius Class See Also Send Feedback
The choice of rule for measuring the radius.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeArcReferenceType ArcReferenceType { get; }
Visual Basic
Public ReadOnly Property ArcReferenceType As RebarShapeArcReferenceType
    Get
Visual C++
public:
property RebarShapeArcReferenceType ArcReferenceType {
    RebarShapeArcReferenceType get ();
}

See Also

RebarShapeConstraintRadius Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSagittaLength Class

[image]

Revit 2013 API
RebarShapeConstraintSagittaLength Class
Members See Also Send Feedback
A constraint that can be applied to a RebarShapeDefinitionByArc and drives the height of the arc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintSagittaLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintSagittaLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintSagittaLength : public RebarShapeConstraint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSagittaLength

See Also

RebarShapeConstraintSagittaLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSagittaLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraintSagittaLength Members
RebarShapeConstraintSagittaLength Class Constructors Methods See Also Send Feedback

The RebarShapeConstraintSagittaLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintSagittaLength | Create a constraint to drive sagitta length.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintSagittaLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSagittaLength Constructor

[image]

Revit 2013 API
RebarShapeConstraintSagittaLength Constructor
RebarShapeConstraintSagittaLength Class See Also Send Feedback
Create a constraint to drive sagitta length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintSagittaLength(
    ElementId paramId
)
Visual Basic
Public Sub New ( _
    paramId As ElementId _
)
Visual C++
public:
RebarShapeConstraintSagittaLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not a valid Element identifier.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintSagittaLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSagittaLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintSagittaLength Methods
RebarShapeConstraintSagittaLength Class See Also Send Feedback

The RebarShapeConstraintSagittaLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintSagittaLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSegmentLength Class

[image]

Revit 2013 API
RebarShapeConstraintSegmentLength Class
Members See Also Send Feedback
A constraint that controls the length of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeConstraintSegmentLength : RebarShapeConstraint
Visual Basic
Public Class RebarShapeConstraintSegmentLength _
    Inherits RebarShapeConstraint
Visual C++
public ref class RebarShapeConstraintSegmentLength : public RebarShapeConstraint

Remarks

The constraint has two references, indexed by 0 and 1, that do not have to correspond to the start and end of the segment.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeConstraint
Autodesk.Revit.DB.Structure..::..RebarShapeConstraintSegmentLength

See Also

RebarShapeConstraintSegmentLength Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSegmentLength Members

[image] [image]

Revit 2013 API
RebarShapeConstraintSegmentLength Members
RebarShapeConstraintSegmentLength Class Constructors Methods See Also Send Feedback

The RebarShapeConstraintSegmentLength type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeConstraintSegmentLength | Create a segment length constraint.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSegmentLength Constructor

[image]

Revit 2013 API
RebarShapeConstraintSegmentLength Constructor
RebarShapeConstraintSegmentLength Class See Also Send Feedback
Create a segment length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeConstraintSegmentLength(
    ElementId paramId,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)
Visual Basic
Public Sub New ( _
    paramId As ElementId, _
    refType0 As RebarShapeSegmentEndReferenceType, _
    refType1 As RebarShapeSegmentEndReferenceType _
)
Visual C++
public:
RebarShapeConstraintSegmentLength(
    ElementId^ paramId,
    RebarShapeSegmentEndReferenceType refType0,
    RebarShapeSegmentEndReferenceType refType1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The Id of a Rebar Shape parameter.
refType0
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
refType1
Type: Autodesk.Revit.DB.Structure..::..RebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeConstraintSegmentLength Methods

[image] [image]

Revit 2013 API
RebarShapeConstraintSegmentLength Methods
RebarShapeConstraintSegmentLength Class See Also Send Feedback

The RebarShapeConstraintSegmentLength type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from RebarShapeConstraint.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParamId | Return the Id of the parameter associated with this constraint. (Inherited from RebarShapeConstraint.)
Public method | GetSegmentEndReferenceType | Choice of two possibilities for the start and end references of the length constraint.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


GetSegmentEndReferenceType Method

[image]

Revit 2013 API
RebarShapeConstraintSegmentLength..::..GetSegmentEndReferenceType Method
RebarShapeConstraintSegmentLength Class See Also Send Feedback
Choice of two possibilities for the start and end references of the length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
    int index
)
Visual Basic
Public Function GetSegmentEndReferenceType ( _
    index As Integer _
) As RebarShapeSegmentEndReferenceType
Visual C++
public:
RebarShapeSegmentEndReferenceType GetSegmentEndReferenceType(
    int index
)

Parameters

index
Type: System..::..Int32
Which reference on the constraint. Either 0 or 1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | index is not 0 or 1.

See Also

RebarShapeConstraintSegmentLength Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Class

[image]

Revit 2013 API
RebarShapeDefinition Class
Members See Also Send Feedback
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public class RebarShapeDefinition : IDisposable
Visual Basic
Public Class RebarShapeDefinition _
    Implements IDisposable
Visual C++
public ref class RebarShapeDefinition : IDisposable

Remarks

A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter may be associated with:
  • One or more RebarShapeConstraints; or
  • A formula; or
  • Neither of the above.
Each shape instance (Rebar object) will have its own values for these parameters. The RebarShapeDefinition also stores a default value for each parameter, which is ignored if the parameter is associated with a formula.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionBySegments

See Also

RebarShapeDefinition Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Members

[image] [image]

Revit 2013 API
RebarShapeDefinition Members
RebarShapeDefinition Class Methods Properties See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Dispose | Releases all resources used by the RebarShapeDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition.
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it.
Public method | GetParameters | Return the Ids of the shared parameters in the Definition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasParameter | Whether the definition stores the parameter.
Public method | RemoveParameter | Remove the parameter from the definition.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition.
Public method | SetParameterFormula | Associate a formula with the parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Methods

[image] [image]

Revit 2013 API
RebarShapeDefinition Methods
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Methods

 | Name | Description
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition.
Public method | AddParameter | Add a parameter to the shape definition.
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition.
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it.
Public method | GetParameters | Return the Ids of the shared parameters in the Definition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasParameter | Whether the definition stores the parameter.
Public method | RemoveParameter | Remove the parameter from the definition.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition.
Public method | SetParameterFormula | Associate a formula with the parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


AddFormulaParameter Method

[image]

Revit 2013 API
RebarShapeDefinition..::..AddFormulaParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a formula-driven parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddFormulaParameter(
    ElementId paramId,
    string formula
)
Visual Basic
Public Sub AddFormulaParameter ( _
    paramId As ElementId, _
    formula As String _
)
Visual C++
public:
void AddFormulaParameter(
    ElementId^ paramId,
    String^ formula
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The parameter. To obtain the id of a shared parameter, call RebarShapeParameters.GetElementIdForExternalDefinition.
formula
Type: System..::..String
The formula expressed as a string. The string is exactly what a user would type into the Family Types dialog, e.g. "Total Length*3.14159*(Bar Diameter/2)*(Bar Diameter/2)"

Remarks

Like AddParameter(), this function introduces a parameter into the shape definition, but the parameter's value is driven by a formula. Formula parameters cannot be used in constraints to drive the shape. The formula is in the same format as in Revit families. The formula is allowed to refer to other parameters that are already in the definition, plus the builtin parameters REBAR_INSTANCE_BAR_DIAMETER, REBAR_INSTANCE_BEND_DIAMETER, REBAR_SHAPE_START_HOOK_LENGTH, REBAR_SHAPE_START_HOOK_OFFSET, REBAR_SHAPE_END_HOOK_LENGTH, REBAR_SHAPE_END_HOOK_OFFSET, REBAR_ELEM_LENGTH, REBAR_ELEM_TOTAL_LENGTH, and REBAR_ELEM_QUANTITY_OF_BARS.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


AddParameter Method

[image]

Revit 2013 API
RebarShapeDefinition..::..AddParameter Method
RebarShapeDefinition Class See Also Send Feedback
Add a parameter to the shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddParameter(
    ElementId paramId,
    double defaultValue
)
Visual Basic
Public Sub AddParameter ( _
    paramId As ElementId, _
    defaultValue As Double _
)
Visual C++
public:
void AddParameter(
    ElementId^ paramId,
    double defaultValue
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
The parameter. To obtain the id of a shared parameter, call RebarShapeParameters.GetElementIdForExternalDefinition.
defaultValue
Type: System..::..Double
A default value for this parameter in shapes. The default values should be chosen carefully, because they are required to be consistent as a set of constraints.

Remarks

A shape parameter must be a shared parameter and have value type double. A parameter must be added to the definition before it can be used to drive the shape in a RebarShapeConstraint object. A parameter that does not drive a constraint is legal and will simply become an editable parameter on any Rebar that is an instance of this RebarShape.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


CheckDefaultParameterValues Method

[image]

Revit 2013 API
RebarShapeDefinition..::..CheckDefaultParameterValues Method
RebarShapeDefinition Class See Also Send Feedback
Check that the shape can be solved with the default parameter values.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiameter
)
Visual Basic
Public Function CheckDefaultParameterValues ( _
    bendRadius As Double, _
    barDiameter As Double _
) As Boolean
Visual C++
public:
bool CheckDefaultParameterValues(
    double bendRadius,
    double barDiameter
)

Parameters

bendRadius
Type: System..::..Double
A value for the Bend Radius parameter. Zero is allowed.
barDiameter
Type: System..::..Double
A value for the Bar Diameter parameter. Zero is allowed.

Return Value

True if the rebar can be solved with the default parameter values and the given bend radius and bar diameter; false if it cannot.

Remarks

This function runs the rebar solver with the default parameter values. If it fails (returns false), rebar instances of this shape will not work. This may be from the default parameters being inconsistent, or from some error in the shape definition. The solver requires a specific bend radius and bar diameter, and the result depends on these values, but in practice they usually do not affect the result of this function as long as they are small. It is legal to pass 0.0 for both arguments. The definition must be Complete in order for this function to succeed.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeDefinition..::..Dispose Method
RebarShapeDefinition Class See Also Send Feedback
Releases all resources used by the RebarShapeDefinition

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


GetParameterDefaultValue Method

[image]

Revit 2013 API
RebarShapeDefinition..::..GetParameterDefaultValue Method
RebarShapeDefinition Class See Also Send Feedback
Return the parameter's default value as stored in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public double GetParameterDefaultValue(
    ElementId paramId
)
Visual Basic
Public Function GetParameterDefaultValue ( _
    paramId As ElementId _
) As Double
Visual C++
public:
double GetParameterDefaultValue(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.

Return Value

The parameter value.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


GetParameterFormula Method

[image]

Revit 2013 API
RebarShapeDefinition..::..GetParameterFormula Method
RebarShapeDefinition Class See Also Send Feedback
Return the parameter's formula, if one is associated with it.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public string GetParameterFormula(
    ElementId paramId
)
Visual Basic
Public Function GetParameterFormula ( _
    paramId As ElementId _
) As String
Visual C++
public:
String^ GetParameterFormula(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.

Return Value

The formula, or an empty string if there is no formula for the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


GetParameters Method

[image]

Revit 2013 API
RebarShapeDefinition..::..GetParameters Method
RebarShapeDefinition Class See Also Send Feedback
Return the Ids of the shared parameters in the Definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public IList<ElementId> GetParameters()
Visual Basic
Public Function GetParameters As IList(Of ElementId)
Visual C++
public:
IList<ElementId^>^ GetParameters()

Return Value

List of parameters as ElementIds.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


HasParameter Method

[image]

Revit 2013 API
RebarShapeDefinition..::..HasParameter Method
RebarShapeDefinition Class See Also Send Feedback
Whether the definition stores the parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool HasParameter(
    ElementId paramId
)
Visual Basic
Public Function HasParameter ( _
    paramId As ElementId _
) As Boolean
Visual C++
public:
bool HasParameter(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter.

Return Value

True if the definition stores the parameter, false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RemoveParameter Method

[image]

Revit 2013 API
RebarShapeDefinition..::..RemoveParameter Method
RebarShapeDefinition Class See Also Send Feedback
Remove the parameter from the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void RemoveParameter(
    ElementId paramId
)
Visual Basic
Public Sub RemoveParameter ( _
    paramId As ElementId _
)
Visual C++
public:
void RemoveParameter(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.

Remarks

If the definition does not have the parameter, the method does nothing.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


SetParameterDefaultValue Method

[image]

Revit 2013 API
RebarShapeDefinition..::..SetParameterDefaultValue Method
RebarShapeDefinition Class See Also Send Feedback
Change the parameter's value as stored in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetParameterDefaultValue(
    ElementId paramId,
    double value
)
Visual Basic
Public Sub SetParameterDefaultValue ( _
    paramId As ElementId, _
    value As Double _
)
Visual C++
public:
void SetParameterDefaultValue(
    ElementId^ paramId,
    double value
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.
value
Type: System..::..Double
New value for the parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


SetParameterFormula Method

[image]

Revit 2013 API
RebarShapeDefinition..::..SetParameterFormula Method
RebarShapeDefinition Class See Also Send Feedback
Associate a formula with the parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void SetParameterFormula(
    ElementId paramId,
    string formula
)
Visual Basic
Public Sub SetParameterFormula ( _
    paramId As ElementId, _
    formula As String _
)
Visual C++
public:
void SetParameterFormula(
    ElementId^ paramId,
    String^ formula
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.
formula
Type: System..::..String
The formula expressed as a string. The string is exactly what a user would type into the Family Types dialog, e.g. "Total Length*3.14159*(Bar Diameter/2)*(Bar Diameter/2)"

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | This RebarShapeDefinition does not have a value for the parameter paramId.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinition Properties

[image] [image]

Revit 2013 API
RebarShapeDefinition Properties
RebarShapeDefinition Class See Also Send Feedback

The RebarShapeDefinition type exposes the following members.

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained.
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


Complete Property

[image]

Revit 2013 API
RebarShapeDefinition..::..Complete Property
RebarShapeDefinition Class See Also Send Feedback
Report whether the shape definition is fully constrained.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public bool Complete { get; }
Visual Basic
Public ReadOnly Property Complete As Boolean
    Get
Visual C++
public:
property bool Complete {
    bool get ();
}

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


IsPlanar Property

[image]

Revit 2013 API
RebarShapeDefinition..::..IsPlanar Property
RebarShapeDefinition Class See Also Send Feedback
Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public bool IsPlanar { get; }
Visual Basic
Public ReadOnly Property IsPlanar As Boolean
    Get
Visual C++
public:
property bool IsPlanar {
    bool get ();
}

See Also

RebarShapeDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Class

[image]

Revit 2013 API
RebarShapeDefinitionByArc Class
Members See Also Send Feedback
Definition of a shape whose size and position can determined by a single arc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public class RebarShapeDefinitionByArc : RebarShapeDefinition
Visual Basic
Public Class RebarShapeDefinitionByArc _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionByArc : public RebarShapeDefinition

Remarks

In this shape definition, all dimensions are allowed to be driving dimensions.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArc

See Also

RebarShapeDefinitionByArc Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Members

[image] [image]

Revit 2013 API
RebarShapeDefinitionByArc Members
RebarShapeDefinitionByArc Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) | Create a non-spiral shape definition.
Public method | RebarShapeDefinitionByArc(Document, Double, Double, Int32, Int32) | Create a spiral shape definition.

Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Dispose | (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this definition.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition.)
Public method | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition.)
Public method | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method | SetConstraints | Assign a new list of constraints to this definition.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Constructor

[image] [image]

Revit 2013 API
RebarShapeDefinitionByArc Constructor
RebarShapeDefinitionByArc Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RebarShapeDefinitionByArc(Document, RebarShapeDefinitionByArcType) | Create a non-spiral shape definition.
Public method | RebarShapeDefinitionByArc(Document, Double, Double, Int32, Int32) | Create a spiral shape definition.

See Also

RebarShapeDefinitionByArc Class
RebarShapeDefinitionByArc Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Constructor (Document, RebarShapeDefinitionByArcType)

[image]

Revit 2013 API
RebarShapeDefinitionByArc Constructor (Document, RebarShapeDefinitionByArcType)
RebarShapeDefinitionByArc Class See Also Send Feedback
Create a non-spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeDefinitionByArc(
    Document doc,
    RebarShapeDefinitionByArcType type
)
Visual Basic
Public Sub New ( _
    doc As Document, _
    type As RebarShapeDefinitionByArcType _
)
Visual C++
public:
RebarShapeDefinitionByArc(
    Document^ doc,
    RebarShapeDefinitionByArcType type
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
type
Type: Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionByArcType

Remarks

Replaces RebarShape.NewDefinitionByArc() from prior versions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
RebarShapeDefinitionByArc Overload
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Constructor (Document, Double, Double, Int32, Int32)

[image]

Revit 2013 API
RebarShapeDefinitionByArc Constructor (Document, Double, Double, Int32, Int32)
RebarShapeDefinitionByArc Class See Also Send Feedback
Create a spiral shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeDefinitionByArc(
    Document doc,
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)
Visual Basic
Public Sub New ( _
    doc As Document, _
    height As Double, _
    pitch As Double, _
    baseFinishingTurns As Integer, _
    topFinishingTurns As Integer _
)
Visual C++
public:
RebarShapeDefinitionByArc(
    Document^ doc,
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
height
Type: System..::..Double
The height of the spiral (assuming the spiral is vertical).
pitch
Type: System..::..Double
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns
Type: System..::..Int32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns
Type: System..::..Int32
The number of finishing turns at the upper end of the spiral.

Remarks

In order to create a spiral definition, you must provide default values for the spiral-specific parameters. Replaces RebarShape.NewDefinitionByArc() from prior versions.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | baseFinishingTurns is not between 0 and 100. -or- topFinishingTurns is not between 0 and 100.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for pitch must be greater than 0 and no more than 30000 feet.

See Also

RebarShapeDefinitionByArc Class
RebarShapeDefinitionByArc Overload
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Methods

[image] [image]

Revit 2013 API
RebarShapeDefinitionByArc Methods
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Methods

 | Name | Description
Public method | AddConstraintArcLength | Specify a parameter to drive the arc length of the shape.
Public method | AddConstraintChordLength | Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).
Public method | AddConstraintCircumference | Specify a parameter to drive the circumference of the shape.
Public method | AddConstraintDiameter | Specify a parameter to drive the diameter of the shape.
Public method | AddConstraintRadius | Specify a parameter to drive the radius of the shape.
Public method | AddConstraintSagittaLength | Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Dispose | (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this definition.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition.)
Public method | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition.)
Public method | SetArcTypeSpiral | Set the RebarShapeDefinitionByArc.Type property to Spiral.
Public method | SetConstraints | Assign a new list of constraints to this definition.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintArcLength Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintArcLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the arc length of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintArcLength(
    ElementId paramId
)
Visual Basic
Public Sub AddConstraintArcLength ( _
    paramId As ElementId _
)
Visual C++
public:
void AddConstraintArcLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintChordLength Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintChordLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the chord length (the straight-line distance between the endpoints of the arc).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintChordLength(
    ElementId paramId
)
Visual Basic
Public Sub AddConstraintChordLength ( _
    paramId As ElementId _
)
Visual C++
public:
void AddConstraintChordLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().

Remarks

The chord length is measured on the centerline of the bar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintCircumference Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintCircumference Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the circumference of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintCircumference(
    ElementId paramId,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic
Public Sub AddConstraintCircumference ( _
    paramId As ElementId, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintCircumference(
    ElementId^ paramId,
    RebarShapeArcReferenceType arcRefType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
arcRefType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
Specify along which circle the circumference is measured--to the interior of the bar, the centerline, or the exterior.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintDiameter Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintDiameter Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the diameter of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintDiameter(
    ElementId paramId,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic
Public Sub AddConstraintDiameter ( _
    paramId As ElementId, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintDiameter(
    ElementId^ paramId,
    RebarShapeArcReferenceType arcRefType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
arcRefType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
Specify how the diameter should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintRadius Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintRadius Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the radius of the shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintRadius(
    ElementId paramId,
    RebarShapeArcReferenceType arcRefType
)
Visual Basic
Public Sub AddConstraintRadius ( _
    paramId As ElementId, _
    arcRefType As RebarShapeArcReferenceType _
)
Visual C++
public:
void AddConstraintRadius(
    ElementId^ paramId,
    RebarShapeArcReferenceType arcRefType
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
arcRefType
Type: Autodesk.Revit.DB.Structure..::..RebarShapeArcReferenceType
Specify how the radius should be measured--to the interior of the bend, the centerline of the bar, or the exterior.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintSagittaLength Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..AddConstraintSagittaLength Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Specify a parameter to drive the sagittal length (the height of the circular segment, measured perpendicular to the chord).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public void AddConstraintSagittaLength(
    ElementId paramId
)
Visual Basic
Public Sub AddConstraintSagittaLength ( _
    paramId As ElementId _
)
Visual C++
public:
void AddConstraintSagittaLength(
    ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().

Remarks

The sagitta will be measured on the centerline of the bar.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


GetConstraints Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..GetConstraints Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Retrieve the list of constraints associated with this definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<RebarShapeConstraint> GetConstraints()
Visual Basic
Public Function GetConstraints As IList(Of RebarShapeConstraint)
Visual C++
public:
IList<RebarShapeConstraint^>^ GetConstraints()

Return Value

The list of constraints.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


SetArcTypeSpiral Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..SetArcTypeSpiral Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Set the RebarShapeDefinitionByArc.Type property to Spiral.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)
Visual Basic
Public Sub SetArcTypeSpiral ( _
    height As Double, _
    pitch As Double, _
    baseFinishingTurns As Integer, _
    topFinishingTurns As Integer _
)
Visual C++
public:
void SetArcTypeSpiral(
    double height,
    double pitch,
    int baseFinishingTurns,
    int topFinishingTurns
)

Parameters

height
Type: System..::..Double
The height of the spiral (assuming the spiral is vertical).
pitch
Type: System..::..Double
The pitch, or vertical distance traveled in one rotation.
baseFinishingTurns
Type: System..::..Int32
The number of finishing turns at the lower end of the spiral.
topFinishingTurns
Type: System..::..Int32
The number of finishing turns at the upper end of the spiral.

Remarks

In order to create a spiral definition, you must provide default values for height, pitch, and finishing turns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | baseFinishingTurns is not between 0 and 100. -or- topFinishingTurns is not between 0 and 100.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for height must be greater than 0 and no more than 30000 feet. -or- The given value for pitch must be greater than 0 and no more than 30000 feet.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


SetConstraints Method

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..SetConstraints Method
RebarShapeDefinitionByArc Class See Also Send Feedback
Assign a new list of constraints to this definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetConstraints(
    IList<RebarShapeConstraint> constraints
)
Visual Basic
Public Sub SetConstraints ( _
    constraints As IList(Of RebarShapeConstraint) _
)
Visual C++
public:
void SetConstraints(
    IList<RebarShapeConstraint^>^ constraints
)

Parameters

constraints
Type: System.Collections.Generic..::..IList<(Of <(<'RebarShapeConstraint>)>)>
A new list of constraints.

Remarks

Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with AddParameter().

If the Type is Arc or LappedCircle, the allowable constraint types are:

  • RebarShapeConstraintArcLength
  • RebarShapeConstraintRadius
  • RebarShapeConstraintDiameter
  • RebarShapeConstraintCircumference
  • RebarShapeConstraintSagittaLength
  • RebarShapeConstraintChordLength
At least two independent constraints must be specified. Overconstraining is supported.

If the Type is Spiral, the allowable constraints are:

  • RebarShapeConstraintRadius
  • RebarShapeConstraintDiameter
  • RebarShapeConstraintCircumference
At least one constraint must be specified.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more of the constraints is of a type not supported for this definition. -or- One or more of the constraints refers to a parameter that has not been added yet.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArc Properties

[image] [image]

Revit 2013 API
RebarShapeDefinitionByArc Properties
RebarShapeDefinitionByArc Class See Also Send Feedback

The RebarShapeDefinitionByArc type exposes the following members.

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | Type | Among those rebar shapes defined by an arc, specify which kind.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


Type Property

[image]

Revit 2013 API
RebarShapeDefinitionByArc..::..Type Property
RebarShapeDefinitionByArc Class See Also Send Feedback
Among those rebar shapes defined by an arc, specify which kind.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2009

Syntax

C#
public RebarShapeDefinitionByArcType Type { get; set; }
Visual Basic
Public Property Type As RebarShapeDefinitionByArcType
    Get
    Set
Visual C++
public:
property RebarShapeDefinitionByArcType Type {
    RebarShapeDefinitionByArcType get ();
    void set (RebarShapeDefinitionByArcType value);
}

Remarks

This property may be explicitly set to Arc or LappedCircle. But to set the property to Spiral, you must call SetArcTypeSpiral() and provide default values for the height, pitch, and finishing turns.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The arc type cannot be set directly to Spiral. Instead, call SetArcTypeSpiral() to provide defaults for spiral parameters.

See Also

RebarShapeDefinitionByArc Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionByArcType Enumeration

[image]

Revit 2013 API
RebarShapeDefinitionByArcType Enumeration
See Also Send Feedback
A RebarShapeDefinitionByArc takes one of three forms.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarShapeDefinitionByArcType
Visual Basic
Public Enumeration RebarShapeDefinitionByArcType
Visual C++
public enum class RebarShapeDefinitionByArcType

Members

Member name | Description
Arc | An arc, subtending an angle less than 360 degrees.
LappedCircle | A full circle, subtending an angle more than 360 degrees and less than 720 degrees. The behavior in Revit is the same as Arc, but an extra complete circle is included in the rebar.
Spiral | A helical bar. The extent of the helix is determined by the Rebar properties Height and Pitch.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Class

[image]

Revit 2013 API
RebarShapeDefinitionBySegments Class
Members See Also Send Feedback
Definition of a shape in terms of one or more straight segments of rebar, with arc bends between the segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarShapeDefinitionBySegments : RebarShapeDefinition
Visual Basic
Public Class RebarShapeDefinitionBySegments _
    Inherits RebarShapeDefinition
Visual C++
public ref class RebarShapeDefinitionBySegments : public RebarShapeDefinition

Remarks

The segments are represented by RebarShapeEdge objects. The segments are numbered starting with 0, and they have a direction; so the beginning of the shape is end 0 of segment 0, and the end of the shape is end 1 of segment (NumberOfEdges-1).

The ends and junctions are represented by RebarShapeVertex objects. The number of vertices is always one greater than the number of edges. The first vertex represents the start of the shape; the last vertex represents the end of the shape; and the intermediate vertices represent the bends between segments.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeDefinition
Autodesk.Revit.DB.Structure..::..RebarShapeDefinitionBySegments

See Also

RebarShapeDefinitionBySegments Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Members

[image] [image]

Revit 2013 API
RebarShapeDefinitionBySegments Members
RebarShapeDefinitionBySegments Class Constructors Methods Properties See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeDefinitionBySegments | Create a rebar shape definition with a given number of segments.

Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
Public method | AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Dispose | (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition.)
Public method | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition.)
Public method | GetSegment | Return a reference to one of the segments in the definition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Return a reference to one of the vertices in the definition.
Public method | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameterFromSegment | Remove constraints from an edge.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition.)
Public method | SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, ElementId, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | MajorSegmentIndex | Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.
Public property | NumberOfSegments | The number of straight segments in this shape.
Public property | NumberOfVertices | The number of vertices in this shape, always equal to NumberOfSegments + 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Constructor

[image]

Revit 2013 API
RebarShapeDefinitionBySegments Constructor
RebarShapeDefinitionBySegments Class See Also Send Feedback
Create a rebar shape definition with a given number of segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarShapeDefinitionBySegments(
    Document doc,
    int numberOfSegments
)
Visual Basic
Public Sub New ( _
    doc As Document, _
    numberOfSegments As Integer _
)
Visual C++
public:
RebarShapeDefinitionBySegments(
    Document^ doc,
    int numberOfSegments
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document. The definition object is not a part of the document, but it will contain references to parameters that are in a document. The definition can be used for RebarShape creation only in the specified document.
numberOfSegments
Type: System..::..Int32
The number of segments in the definition.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | numberOfSegments must be at least 1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Methods

[image] [image]

Revit 2013 API
RebarShapeDefinitionBySegments Methods
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Methods

 | Name | Description
Public method | AddBendDefaultRadius | Specify a default-radius bend.
Public method | AddBendVariableRadius | Specify a variable-radius bend.
Public method | AddConstraintParallelToSegment | Constrain the length of a segment by parameterizing its length.
Public method | AddConstraintToSegment | Add a constraint that helps determine the length of a segment.
Public method | AddFormulaParameter | Add a formula-driven parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | AddListeningDimensionBendToBend | Specify a dimension between two bends, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToBend | Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.
Public method | AddListeningDimensionSegmentToSegment | Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Public method | AddParameter | Add a parameter to the shape definition. (Inherited from RebarShapeDefinition.)
Public method | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. (Inherited from RebarShapeDefinition.)
Public method | Dispose | (Inherited from RebarShapeDefinition.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | GetParameterFormula | Return the parameter's formula, if one is associated with it. (Inherited from RebarShapeDefinition.)
Public method | GetParameters | Return the Ids of the shared parameters in the Definition. (Inherited from RebarShapeDefinition.)
Public method | GetSegment | Return a reference to one of the segments in the definition.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVertex | Return a reference to one of the vertices in the definition.
Public method | HasParameter | Whether the definition stores the parameter. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameter | Remove the parameter from the definition. (Inherited from RebarShapeDefinition.)
Public method | RemoveParameterFromSegment | Remove constraints from an edge.
Public method | SetParameterDefaultValue | Change the parameter's value as stored in the definition. (Inherited from RebarShapeDefinition.)
Public method | SetParameterFormula | Associate a formula with the parameter. (Inherited from RebarShapeDefinition.)
Public method | SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, ElementId, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.
Public method | SetSegmentFixedDirection | Fix the direction of a segment.
Public method | SetSegmentVariableDirection | Remove the fixed direction from a segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddBendDefaultRadius Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddBendDefaultRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a default-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddBendDefaultRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle
)
Visual Basic
Public Sub AddBendDefaultRadius ( _
    vertexIndex As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle _
)
Visual C++
public:
void AddBendDefaultRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle
)

Parameters

vertexIndex
Type: System..::..Int32
Index of the vertex (1 to NumberOfVertices - 2).
turn
Type: System..::..Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::..RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.

Remarks

You must add a bend at each vertex except the first and last.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is not between 0 and NumberOfVertices. -or- turn is neither -1 nor 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddBendVariableRadius Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddBendVariableRadius Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a variable-radius bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddBendVariableRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle,
    ElementId paramId,
    bool measureIncludingBarThickness
)
Visual Basic
Public Sub AddBendVariableRadius ( _
    vertexIndex As Integer, _
    turn As Integer, _
    angle As RebarShapeBendAngle, _
    paramId As ElementId, _
    measureIncludingBarThickness As Boolean _
)
Visual C++
public:
void AddBendVariableRadius(
    int vertexIndex,
    int turn,
    RebarShapeBendAngle angle,
    ElementId^ paramId,
    bool measureIncludingBarThickness
)

Parameters

vertexIndex
Type: System..::..Int32
Index of the vertex (1 to NumberOfVertices - 2).
turn
Type: System..::..Int32
Specify 1 for a left turn, -1 for a right turn.
angle
Type: Autodesk.Revit.DB.Structure..::..RebarShapeBendAngle
Specify whether the bend is acute, obtuse, etc.
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter driving the radius.
measureIncludingBarThickness
Type: System..::..Boolean
If true, the radius is measured to the outside of the bend; if false, it is measured to the inside.

Remarks

You must add a bend between each two segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is not between 0 and NumberOfVertices. -or- turn is neither -1 nor 1. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintParallelToSegment Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddConstraintParallelToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Constrain the length of a segment by parameterizing its length.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddConstraintParallelToSegment(
    int iSegment,
    ElementId paramId,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic
Public Sub AddConstraintParallelToSegment ( _
    iSegment As Integer, _
    paramId As ElementId, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintParallelToSegment(
    int iSegment,
    ElementId^ paramId,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend0
Type: System..::..Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::..Boolean
Choose between two possibilities for the second reference of the length dimension.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddConstraintToSegment Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddConstraintToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Add a constraint that helps determine the length of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddConstraintToSegment(
    int iSegment,
    ElementId paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)
Visual Basic
Public Sub AddConstraintToSegment ( _
    iSegment As Integer, _
    paramId As ElementId, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    signOfZCoordOfCrossProductOfConstraintDirBySegmentDir As Integer, _
    measureToOutsideOfBend0 As Boolean, _
    measureToOutsideOfBend1 As Boolean _
)
Visual C++
public:
void AddConstraintToSegment(
    int iSegment,
    ElementId^ paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int signOfZCoordOfCrossProductOfConstraintDirBySegmentDir,
    bool measureToOutsideOfBend0,
    bool measureToOutsideOfBend1
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the constraint. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
constraintDirCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the constraint direction.
signOfZCoordOfCrossProductOfConstraintDirBySegmentDir
Type: System..::..Int32
Legal values are 1 and -1. For a fixed-direction segment, this value is ignored. For a variable-direction segment, this value is combined with the constraint length (the nonnegative value associated with 'param') to determine the direction of the segment. For example, a segment whose direction vector lies in the upper-right quadrant of the plane, and whose x-axis projected length is A and whose y-axis projected length is B, could be created by calling: AddConstraintToSegment(iSegment, paramA, 1.0, 0.0, 1, ...) AddConstraintToSegment(iSegment, paramB, 0.0, 1.0, -1, ...)
measureToOutsideOfBend0
Type: System..::..Boolean
Choose between two possibilities for the first reference of the length dimension. If false, the reference is at the point where the bend begins; equivalently, at the projection of the bend centerpoint onto the segment. If true, the reference is moved outward by a distance equal to the bend radius plus the bar diameter; if the bend is a right angle or greater, this is equivalent to putting the reference at the outer face of the bend.
measureToOutsideOfBend1
Type: System..::..Boolean
Choose between two possibilities for the second reference of the length dimension.

Remarks

The vector defined by (constraintDirCoordX, constraintDirCoordY) must have a positive dot product with the desired direction of the segment. This restriction, combined with the value of signOfZCoordOfCrossProductOfConstraintDirBySegmentDir, defines a quadrant of the plane that limits the variable-angle segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- signOfZCoordOfCrossProductOfConstraintDirBySegmentDir is neither -1 nor 1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionBendToBend Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddListeningDimensionBendToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension between two bends, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddListeningDimensionBendToBend(
    ElementId paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)
Visual Basic
Public Sub AddListeningDimensionBendToBend ( _
    paramId As ElementId, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iEnd0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionBendToBend(
    ElementId^ paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iEnd0,
    int iSegment1,
    int iEnd1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to report the length of the dimension. The parameter will be read-only on Rebar instances.
constraintDirCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::..Int32
Index of the first segment (0 to NumberOfSegments - 1).
iEnd0
Type: System..::..Int32
End (0 or 1) of the first segment.
iSegment1
Type: System..::..Int32
Index of the second segment (0 to NumberOfSegments - 1).
iEnd1
Type: System..::..Int32
End (0 or 1) of the second segment.

Remarks

Each reference is at the outside of the bend, perpendicular to the specified segment. So the overall length of a shape with 5 segments might be defined by calling this function with iSegment0=0, iEnd0=0, iSegment1=4, iEnd1=1.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- iSegment0 is not between 0 and NumberOfEdges. -or- iEnd0 is neither 0 nor 1. -or- iSegment1 is not between 0 and NumberOfEdges. -or- iEnd1 is neither 0 nor 1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionSegmentToBend Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddListeningDimensionSegmentToBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to one fixed-direction segment, referring to that segment and some other bend in the shape, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToBend(
    ElementId paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)
Visual Basic
Public Sub AddListeningDimensionSegmentToBend ( _
    paramId As ElementId, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer, _
    iEnd1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToBend(
    ElementId^ paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1,
    int iEnd1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to report the length of the dimension. The parameter will be read-only on Rebar instances.
constraintDirCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::..Int32
Index of the first segment (0 to NumberOfSegments - 1).
iSegment1
Type: System..::..Int32
Index of the second segment (0 to NumberOfSegments - 1).
iEnd1
Type: System..::..Int32
End (0 or 1) of the second segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- iSegment0 is not between 0 and NumberOfEdges. -or- Edge iSegment0 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY). -or- iSegment1 is not between 0 and NumberOfEdges. -or- iEnd1 is neither 0 nor 1.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


AddListeningDimensionSegmentToSegment Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..AddListeningDimensionSegmentToSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddListeningDimensionSegmentToSegment(
    ElementId paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)
Visual Basic
Public Sub AddListeningDimensionSegmentToSegment ( _
    paramId As ElementId, _
    constraintDirCoordX As Double, _
    constraintDirCoordY As Double, _
    iSegment0 As Integer, _
    iSegment1 As Integer _
)
Visual C++
public:
void AddListeningDimensionSegmentToSegment(
    ElementId^ paramId,
    double constraintDirCoordX,
    double constraintDirCoordY,
    int iSegment0,
    int iSegment1
)

Parameters

paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to report the length of the dimension. The parameter will be read-only on Rebar instances.
constraintDirCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the constraint direction.
constraintDirCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the constraint direction.
iSegment0
Type: System..::..Int32
Index of the first segment (0 to NumberOfSegments - 1).
iSegment1
Type: System..::..Int32
Index of the second segment (0 to NumberOfSegments - 1).

Remarks

RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- iSegment0 is not between 0 and NumberOfEdges. -or- iSegment1 is not between 0 and NumberOfEdges. -or- Edge iSegment0 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY). -or- Edge iSegment1 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY).
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


GetSegment Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..GetSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Return a reference to one of the segments in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeSegment GetSegment(
    int segmentIndex
)
Visual Basic
Public Function GetSegment ( _
    segmentIndex As Integer _
) As RebarShapeSegment
Visual C++
public:
RebarShapeSegment^ GetSegment(
    int segmentIndex
)

Parameters

segmentIndex
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).

Return Value

The requested segment.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | segmentIndex is not between 0 and NumberOfEdges.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


GetVertex Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..GetVertex Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Return a reference to one of the vertices in the definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeVertex GetVertex(
    int vertexIndex
)
Visual Basic
Public Function GetVertex ( _
    vertexIndex As Integer _
) As RebarShapeVertex
Visual C++
public:
RebarShapeVertex^ GetVertex(
    int vertexIndex
)

Parameters

vertexIndex
Type: System..::..Int32
Index of the vertex (0 to NumberOfVertices - 1).

Return Value

The requested vertex.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | vertexIndex is not between 0 and NumberOfVertices.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RemoveParameterFromSegment Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..RemoveParameterFromSegment Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove constraints from an edge.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveParameterFromSegment(
    int iSegment,
    ElementId paramId
)
Visual Basic
Public Sub RemoveParameterFromSegment ( _
    iSegment As Integer, _
    paramId As ElementId _
)
Visual C++
public:
void RemoveParameterFromSegment(
    int iSegment,
    ElementId^ paramId
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter driving one or more constraints.

Remarks

This reverses the effect of any AddConstraint and SetSegmentAs180DegreeBend operations involving the specified segment and parameter.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method

[image] [image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentAs180DegreeBend Method
RebarShapeDefinitionBySegments Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetSegmentAs180DegreeBend(Int32) | Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.
Public method | SetSegmentAs180DegreeBend(Int32, ElementId, Boolean) | Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

See Also

RebarShapeDefinitionBySegments Class
RebarShapeDefinitionBySegments Members
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method (Int32)

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentAs180DegreeBend Method (Int32)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment
)
Visual Basic
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges.

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace


SetSegmentAs180DegreeBend Method (Int32, ElementId, Boolean)

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentAs180DegreeBend Method (Int32, ElementId, Boolean)
RebarShapeDefinitionBySegments Class See Also Send Feedback
Indicate that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be driven by radiusParam.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentAs180DegreeBend(
    int iSegment,
    ElementId paramId,
    bool measureToOutsideOfBend
)
Visual Basic
Public Sub SetSegmentAs180DegreeBend ( _
    iSegment As Integer, _
    paramId As ElementId, _
    measureToOutsideOfBend As Boolean _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
    int iSegment,
    ElementId^ paramId,
    bool measureToOutsideOfBend
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
paramId
Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter to drive the radius. To obtain the id of a shared parameter, call RebarShape.GetElementIdForExternalDefinition().
measureToOutsideOfBend
Type: System..::..Boolean
Choose between two possibilities for the references of the radius dimension. If true, measure to the exterior face of the bar. If false, measure to the interior face.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Length or UT_Angle.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeDefinitionBySegments Class
SetSegmentAs180DegreeBend Overload
Autodesk.Revit.DB.Structure Namespace


SetSegmentFixedDirection Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentFixedDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Fix the direction of a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)
Visual Basic
Public Sub SetSegmentFixedDirection ( _
    iSegment As Integer, _
    vecCoordX As Double, _
    vecCoordY As Double _
)
Visual C++
public:
void SetSegmentFixedDirection(
    int iSegment,
    double vecCoordX,
    double vecCoordY
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).
vecCoordX
Type: System..::..Double
The x-coordinate of a 2D vector specifying the segment direction.
vecCoordY
Type: System..::..Double
The y-coordinate of a 2D vector specifying the segment direction.

Remarks

The centerline of the edge will be constrained to be parallel to the vector. The edge must have at least one constraint.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges. -or- The length of the vector (vecCoordX, vecCoordY) is too close to zero.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


SetSegmentVariableDirection Method

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..SetSegmentVariableDirection Method
RebarShapeDefinitionBySegments Class See Also Send Feedback
Remove the fixed direction from a segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetSegmentVariableDirection(
    int iSegment
)
Visual Basic
Public Sub SetSegmentVariableDirection ( _
    iSegment As Integer _
)
Visual C++
public:
void SetSegmentVariableDirection(
    int iSegment
)

Parameters

iSegment
Type: System..::..Int32
Index of the segment (0 to NumberOfSegments - 1).

Remarks

The edge's angle will be allowed to vary, with a range of 90 degrees. The edge must have at least two constraints.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | iSegment is not between 0 and NumberOfEdges.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeDefinitionBySegments Properties

[image] [image]

Revit 2013 API
RebarShapeDefinitionBySegments Properties
RebarShapeDefinitionBySegments Class See Also Send Feedback

The RebarShapeDefinitionBySegments type exposes the following members.

Properties

 | Name | Description
Public property | Complete | Report whether the shape definition is fully constrained. (Inherited from RebarShapeDefinition.)
Public property | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. (Inherited from RebarShapeDefinition.)
Public property | MajorSegmentIndex | Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.
Public property | NumberOfSegments | The number of straight segments in this shape.
Public property | NumberOfVertices | The number of vertices in this shape, always equal to NumberOfSegments + 1.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


MajorSegmentIndex Property

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..MajorSegmentIndex Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
Index of a segment that can be considered the most important. Revit attempts to preserve the orientation of this segment when a Rebar instance changes its RebarShape to one with a different number of segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int MajorSegmentIndex { get; set; }
Visual Basic
Public Property MajorSegmentIndex As Integer
    Get
    Set
Visual C++
public:
property int MajorSegmentIndex {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: majorSegmentIndex is not between 0 and NumberOfEdges.

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


NumberOfSegments Property

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..NumberOfSegments Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
The number of straight segments in this shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int NumberOfSegments { get; }
Visual Basic
Public ReadOnly Property NumberOfSegments As Integer
    Get
Visual C++
public:
property int NumberOfSegments {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


NumberOfVertices Property

[image]

Revit 2013 API
RebarShapeDefinitionBySegments..::..NumberOfVertices Property
RebarShapeDefinitionBySegments Class See Also Send Feedback
The number of vertices in this shape, always equal to NumberOfSegments + 1.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public int NumberOfVertices { get; }
Visual Basic
Public ReadOnly Property NumberOfVertices As Integer
    Get
Visual C++
public:
property int NumberOfVertices {
    int get ();
}

See Also

RebarShapeDefinitionBySegments Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeMultiplanarDefinition Class

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition Class
Members See Also Send Feedback
A specification for a simple 3D rebar shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarShapeMultiplanarDefinition : IDisposable
Visual Basic
Public Class RebarShapeMultiplanarDefinition _
    Implements IDisposable
Visual C++
public ref class RebarShapeMultiplanarDefinition : IDisposable

Remarks

Simple 3D rebar shapes are supported by adding segments to a regular 2D shape definition. The added segments consist of three optional parts: a "duplicate shape" and two connectors. A "duplicate shape" is a second copy of the 2D shape, offset in a perpendicular direction, and connected at either the start or the end by a perpendicular connector segment. Also supported is adding one or both connector segments, without the duplicate shape. Fillets are applied to the connector segments with a diameter that is given by the OutOfPlaneBendDiameter property. The length of the connectors is given by the Rebar instance parameter "multiplanar depth." The MultiplanarDepth property of this class is the default value of the parameter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeMultiplanarDefinition

See Also

RebarShapeMultiplanarDefinition Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeMultiplanarDefinition Members

[image] [image]

Revit 2013 API
RebarShapeMultiplanarDefinition Members
RebarShapeMultiplanarDefinition Class Constructors Methods Properties See Also Send Feedback

The RebarShapeMultiplanarDefinition type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeMultiplanarDefinition | Create a RebarShapeMultiplanarDefinition for use in creating a RebarShape.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeMultiplanarDefinition
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPresenceOfSegments | Simultaneously set the presence of all 3D segments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DepthParamId | Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation.
Public property | IsDuplicateShapePresent | Whether the shape definition includes an offset copy of the 2D shape.
Public property | IsEndConnectorPresent | Whether a perpendicular segment is constructed from the end of the 2D shape.
Public property | IsStartConnectorPresent | Whether a perpendicular segment is constructed from the start of the 2D shape.
Public property | OutOfPlaneBendDiameter | Bend diameter to be applied to the connector segments.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeMultiplanarDefinition Constructor

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition Constructor
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Create a RebarShapeMultiplanarDefinition for use in creating a RebarShape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarShapeMultiplanarDefinition(
    double outOfPlaneBendDiameter
)
Visual Basic
Public Sub New ( _
    outOfPlaneBendDiameter As Double _
)
Visual C++
public:
RebarShapeMultiplanarDefinition(
    double outOfPlaneBendDiameter
)

Parameters

outOfPlaneBendDiameter
Type: System..::..Double
Bend diameter to be used when the rebar bends out of its main plane.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for outOfPlaneBendDiameter must be greater than 0 and no more than 30000 feet.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeMultiplanarDefinition Methods

[image] [image]

Revit 2013 API
RebarShapeMultiplanarDefinition Methods
RebarShapeMultiplanarDefinition Class See Also Send Feedback

The RebarShapeMultiplanarDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetPresenceOfSegments | Simultaneously set the presence of all 3D segments.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..Dispose Method
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Releases all resources used by the RebarShapeMultiplanarDefinition

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


SetPresenceOfSegments Method

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..SetPresenceOfSegments Method
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Simultaneously set the presence of all 3D segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetPresenceOfSegments(
    bool isDuplicateShapePresent,
    bool isStartConnectorPresent,
    bool isEndConnectorPresent
)
Visual Basic
Public Sub SetPresenceOfSegments ( _
    isDuplicateShapePresent As Boolean, _
    isStartConnectorPresent As Boolean, _
    isEndConnectorPresent As Boolean _
)
Visual C++
public:
void SetPresenceOfSegments(
    bool isDuplicateShapePresent,
    bool isStartConnectorPresent,
    bool isEndConnectorPresent
)

Parameters

isDuplicateShapePresent
Type: System..::..Boolean
isStartConnectorPresent
Type: System..::..Boolean
isEndConnectorPresent
Type: System..::..Boolean

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The shape is disconnected or forms a complete loop: If the duplicate shape is present, exactly one of the connectors must be present.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeMultiplanarDefinition Properties

[image] [image]

Revit 2013 API
RebarShapeMultiplanarDefinition Properties
RebarShapeMultiplanarDefinition Class See Also Send Feedback

The RebarShapeMultiplanarDefinition type exposes the following members.

Properties

 | Name | Description
Public property | DepthParamId | Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation.
Public property | IsDuplicateShapePresent | Whether the shape definition includes an offset copy of the 2D shape.
Public property | IsEndConnectorPresent | Whether a perpendicular segment is constructed from the end of the 2D shape.
Public property | IsStartConnectorPresent | Whether a perpendicular segment is constructed from the start of the 2D shape.
Public property | OutOfPlaneBendDiameter | Bend diameter to be applied to the connector segments.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


DepthParamId Property

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..DepthParamId Property
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Id of the parameter driving the multiplanar depth. The depth is measured center-to-center of the bar. A valid shape parameter must be assigned to DepthParamId before the MultiplanarDefinition can be used in RebarShape creation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId DepthParamId { get; set; }
Visual Basic
Public Property DepthParamId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ DepthParamId {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


IsDuplicateShapePresent Property

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..IsDuplicateShapePresent Property
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Whether the shape definition includes an offset copy of the 2D shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsDuplicateShapePresent { get; }
Visual Basic
Public ReadOnly Property IsDuplicateShapePresent As Boolean
    Get
Visual C++
public:
property bool IsDuplicateShapePresent {
    bool get ();
}

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


IsEndConnectorPresent Property

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..IsEndConnectorPresent Property
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Whether a perpendicular segment is constructed from the end of the 2D shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEndConnectorPresent { get; }
Visual Basic
Public ReadOnly Property IsEndConnectorPresent As Boolean
    Get
Visual C++
public:
property bool IsEndConnectorPresent {
    bool get ();
}

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


IsStartConnectorPresent Property

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..IsStartConnectorPresent Property
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Whether a perpendicular segment is constructed from the start of the 2D shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsStartConnectorPresent { get; }
Visual Basic
Public ReadOnly Property IsStartConnectorPresent As Boolean
    Get
Visual C++
public:
property bool IsStartConnectorPresent {
    bool get ();
}

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


OutOfPlaneBendDiameter Property

[image]

Revit 2013 API
RebarShapeMultiplanarDefinition..::..OutOfPlaneBendDiameter Property
RebarShapeMultiplanarDefinition Class See Also Send Feedback
Bend diameter to be applied to the connector segments.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double OutOfPlaneBendDiameter { get; set; }
Visual Basic
Public Property OutOfPlaneBendDiameter As Double
    Get
    Set
Visual C++
public:
property double OutOfPlaneBendDiameter {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for outOfPlaneBendDiameter must be greater than 0 and no more than 30000 feet.

See Also

RebarShapeMultiplanarDefinition Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeParameters Class

[image]

Revit 2013 API
RebarShapeParameters Class
Members See Also Send Feedback
Class containing functions that create and retrieve shared parameters for RebarShapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeParameters : IDisposable
Visual Basic
Public Class RebarShapeParameters _
    Implements IDisposable
Visual C++
public ref class RebarShapeParameters : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeParameters

See Also

RebarShapeParameters Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeParameters Members

[image] [image]

Revit 2013 API
RebarShapeParameters Members
RebarShapeParameters Class Methods See Also Send Feedback

The RebarShapeParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeParameters
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the specified document.
 | GetElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, return InvalidElementId.
 | GetExternalDefinitionForElementId | Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOrCreateElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, add the parameter to the document and generate a new ElementId.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalDefinition | Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeParameters Methods

[image] [image]

Revit 2013 API
RebarShapeParameters Methods
RebarShapeParameters Class See Also Send Feedback

The RebarShapeParameters type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllRebarShapeParameters | List all shape parameters used by all the existing RebarShapes in the specified document.
 | GetElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, return InvalidElementId.
 | GetExternalDefinitionForElementId | Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOrCreateElementIdForExternalDefinition | Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, add the parameter to the document and generate a new ElementId.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | IsValidExternalDefinition | Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeParameters..::..Dispose Method
RebarShapeParameters Class See Also Send Feedback
Releases all resources used by the RebarShapeParameters

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


GetAllRebarShapeParameters Method

[image]

Revit 2013 API
RebarShapeParameters..::..GetAllRebarShapeParameters Method
RebarShapeParameters Class See Also Send Feedback
List all shape parameters used by all the existing RebarShapes in the specified document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static IList<ElementId> GetAllRebarShapeParameters(
    Document doc
)
Visual Basic
Public Shared Function GetAllRebarShapeParameters ( _
    doc As Document _
) As IList(Of ElementId)
Visual C++
public:
static IList<ElementId^>^ GetAllRebarShapeParameters(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document.

Return Value

ElementIds corresponding to the external parameters.

Remarks

This method replaces RebarShape.GetAllRebarShapeParameters() from prior releases.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


GetElementIdForExternalDefinition Method

[image]

Revit 2013 API
RebarShapeParameters..::..GetElementIdForExternalDefinition Method
RebarShapeParameters Class See Also Send Feedback
Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, return InvalidElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ElementId GetElementIdForExternalDefinition(
    Document doc,
    ExternalDefinition externalDefinition
)
Visual Basic
Public Shared Function GetElementIdForExternalDefinition ( _
    doc As Document, _
    externalDefinition As ExternalDefinition _
) As ElementId
Visual C++
public:
static ElementId^ GetElementIdForExternalDefinition(
    Document^ doc,
    ExternalDefinition^ externalDefinition
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
externalDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
A shared parameter.

Return Value

An ElementId representing the shared parameter stored in the document, or InvalidElementId if the parameter is not stored in the document.

Remarks

Before a parameter can be used in a RebarShapeDefinition, it must exist in the definition's document. There are two ways to achieve this. It can be bound to one or more categories in the document using the Document.ParameterBindings property, or it can be created by calling RebarShapeParameters.GetOrCreateElementIdForExternalDefinition().

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


GetExternalDefinitionForElementId Method

[image]

Revit 2013 API
RebarShapeParameters..::..GetExternalDefinitionForElementId Method
RebarShapeParameters Class See Also Send Feedback
Seach a DefinitionFile for the ExternalDefinition corresponding to a parameter in a document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ExternalDefinition GetExternalDefinitionForElementId(
    Document doc,
    ElementId paramId,
    DefinitionFile definitionFile
)
Visual Basic
Public Shared Function GetExternalDefinitionForElementId ( _
    doc As Document, _
    paramId As ElementId, _
    definitionFile As DefinitionFile _
) As ExternalDefinition
Visual C++
public:
static ExternalDefinition^ GetExternalDefinitionForElementId(
    Document^ doc,
    ElementId^ paramId,
    DefinitionFile^ definitionFile
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
paramId
Type: Autodesk.Revit.DB..::..ElementId
The id of a shared parameter in the document.
definitionFile
Type: Autodesk.Revit.DB..::..DefinitionFile
A database of shared parameters.

Return Value

The external parameter corresponding to the parameter's ElementId, or null if the Id does not correspond to an external parameter, or the parameter is not in the definition file.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


GetOrCreateElementIdForExternalDefinition Method

[image]

Revit 2013 API
RebarShapeParameters..::..GetOrCreateElementIdForExternalDefinition Method
RebarShapeParameters Class See Also Send Feedback
Retrieve the ElementId corresponding to an external rebar shape parameter in the document, if it exists; otherwise, add the parameter to the document and generate a new ElementId.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static ElementId GetOrCreateElementIdForExternalDefinition(
    Document doc,
    ExternalDefinition externalDefinition
)
Visual Basic
Public Shared Function GetOrCreateElementIdForExternalDefinition ( _
    doc As Document, _
    externalDefinition As ExternalDefinition _
) As ElementId
Visual C++
public:
static ElementId^ GetOrCreateElementIdForExternalDefinition(
    Document^ doc,
    ExternalDefinition^ externalDefinition
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A document.
externalDefinition
Type: Autodesk.Revit.DB..::..ExternalDefinition
A shared parameter.

Return Value

An ElementId representing the shared parameter stored in the document.

Remarks

Before a parameter can be used in a RebarShapeDefinition, it must exist in the definition's document. There are two ways to achieve this. It can be bound to one or more categories in the document using the Document.ParameterBindings property, or it can be created with this method.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


IsValidExternalDefinition Method

[image]

Revit 2013 API
RebarShapeParameters..::..IsValidExternalDefinition Method
RebarShapeParameters Class See Also Send Feedback
Checks that an ExternalDefinition (shared parameter) may be used as a Rebar Shape parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public static bool IsValidExternalDefinition(
    ExternalDefinition param
)
Visual Basic
Public Shared Function IsValidExternalDefinition ( _
    param As ExternalDefinition _
) As Boolean
Visual C++
public:
static bool IsValidExternalDefinition(
    ExternalDefinition^ param
)

Parameters

param
Type: Autodesk.Revit.DB..::..ExternalDefinition
Definition of a shared parameter.

Return Value

True if the definition is of type Length, false otherwise.

Remarks

A Rebar Shape parameter must be an ExternalDefinition with a ParameterType of Length.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was nullNothingnullptra null reference (Nothing in Visual Basic)

See Also

RebarShapeParameters Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSegment Class

[image]

Revit 2013 API
RebarShapeSegment Class
Members See Also Send Feedback
Part of a RebarShapeDefinitionBySegments, representing one segment of a shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeSegment : IDisposable
Visual Basic
Public Class RebarShapeSegment _
    Implements IDisposable
Visual C++
public ref class RebarShapeSegment : IDisposable

Remarks

Each segment must have enough constraints to determine its position. Overconstraining is allowed. The most common combinations are:

  • A fixed direction together with a parallel length constraint;
  • A parallel length constraint plus another length constraint parallel to the x-axis or y-axis;
  • A parallel length constraint plus length constraints parallel to both the x-axis and y-axis.
Multiple constraints may be driven by the same parameter, even on the same segment.

Length constraints may be measured in two ways. For "measured to the outside of the bend," the reference is a tangent to the exterior face of the bar; the thickness of the bar is included. For "measured to the inside," the reference is the center of the arc of the bend; this is the point where the bend begins, if the constraint is parallel to the segment.

A 180-degree bend is described by introducing a short segment in between the two straight segments, tangent to the midpoint of the bend.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeSegment

See Also

RebarShapeSegment Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeSegment Members

[image] [image]

Revit 2013 API
RebarShapeSegment Members
RebarShapeSegment Class Methods See Also Send Feedback

The RebarShapeSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeSegment
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this segment.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConstraints | Assign a new list of constraints to this segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSegment Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSegment Methods

[image] [image]

Revit 2013 API
RebarShapeSegment Methods
RebarShapeSegment Class See Also Send Feedback

The RebarShapeSegment type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this segment.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConstraints | Assign a new list of constraints to this segment.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSegment Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeSegment..::..Dispose Method
RebarShapeSegment Class See Also Send Feedback
Releases all resources used by the RebarShapeSegment

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeSegment Class
Autodesk.Revit.DB.Structure Namespace


GetConstraints Method

[image]

Revit 2013 API
RebarShapeSegment..::..GetConstraints Method
RebarShapeSegment Class See Also Send Feedback
Retrieve the list of constraints associated with this segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<RebarShapeConstraint> GetConstraints()
Visual Basic
Public Function GetConstraints As IList(Of RebarShapeConstraint)
Visual C++
public:
IList<RebarShapeConstraint^>^ GetConstraints()

Return Value

The list of constraints.

See Also

RebarShapeSegment Class
Autodesk.Revit.DB.Structure Namespace


SetConstraints Method

[image]

Revit 2013 API
RebarShapeSegment..::..SetConstraints Method
RebarShapeSegment Class See Also Send Feedback
Assign a new list of constraints to this segment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetConstraints(
    IList<RebarShapeConstraint> constraints
)
Visual Basic
Public Sub SetConstraints ( _
    constraints As IList(Of RebarShapeConstraint) _
)
Visual C++
public:
void SetConstraints(
    IList<RebarShapeConstraint^>^ constraints
)

Parameters

constraints
Type: System.Collections.Generic..::..IList<(Of <(<'RebarShapeConstraint>)>)>
A new list of constraints.

Remarks

Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with RebarShapeDefinition.AddParameter().

The allowable constraint types are:

  • RebarShapeConstraintAngleFromFixedDir
  • RebarShapeConstraintSegmentLength
  • RebarShapeConstraintFixedSegmentDir
  • RebarShapeConstraintProjectedSegmentLength
  • RebarShapeConstraint180DegreeBendArcLength
  • RebarShapeConstraint180DegreeBendRadius
  • RebarShapeConstraint180DegreeDefaultBend
At least two independent constraints must be specified. Overconstraining is supported.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more of the constraints is of a type not supported for RebarShapeSegment.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeSegment Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSegmentEndReferenceType Enumeration

[image]

Revit 2013 API
RebarShapeSegmentEndReferenceType Enumeration
See Also Send Feedback
A choice of two reference points for one end of a constraint driving the length of a RebarShapeSegment.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum RebarShapeSegmentEndReferenceType
Visual Basic
Public Enumeration RebarShapeSegmentEndReferenceType
Visual C++
public enum class RebarShapeSegmentEndReferenceType

Members

Member name | Description
Straight | Refers to the end of the straight part of the segment: the point where the bend begins.
Exterior | Refers to the farthest point on the arc of the bend. Assuming the bend is 90 degrees or more, an Exterior constraint will be longer than a Straight constraint by an amount equal to the bend radius.

Remarks

The RebarShapeSegmentEndReferenceType of a constraint is meaningful only when the bend is right or obtuse. If the bend is acute, the reference type is ignored.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Class

[image]

Revit 2013 API
RebarShapeSet Class
Members See Also Send Feedback
An set that contains rebar shapes.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class RebarShapeSet : APIObject,
    IEnumerable
Visual Basic
Public Class RebarShapeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class RebarShapeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarShapeSet

See Also

RebarShapeSet Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Members

[image] [image]

Revit 2013 API
RebarShapeSet Members
RebarShapeSet Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSet type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeSet | Initializes a new instance of the RebarShapeSet class

Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Constructor

[image]

Revit 2013 API
RebarShapeSet Constructor
RebarShapeSet Class See Also Send Feedback
Initializes a new instance of the RebarShapeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarShapeSet()
Visual Basic
Public Sub New
Visual C++
public:
RebarShapeSet()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Methods

[image] [image]

Revit 2013 API
RebarShapeSet Methods
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every rebar shape from the set, rendering it empty.
Public method | Contains | Tests for the existence of a rebar shape within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified rebar shape from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified rebar shape into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
RebarShapeSet..::..Clear Method
RebarShapeSet Class See Also Send Feedback
Removes every rebar shape from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
RebarShapeSet..::..Contains Method
RebarShapeSet Class See Also Send Feedback
Tests for the existence of a rebar shape within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    RebarShape item
)
Visual Basic
Public Overridable Function Contains ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Contains(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarShape
The rebar shape to be searched for.

Return Value

The Contains method returns True if the rebar shape is within the set, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
RebarShapeSet..::..Erase Method
RebarShapeSet Class See Also Send Feedback
Removes a specified rebar shape from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    RebarShape item
)
Visual Basic
Public Overridable Function Erase ( _
    item As RebarShape _
) As Integer
Visual C++
public:
virtual int Erase(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarShape
The rebar shape to be erased.

Return Value

The number of rebar shapes that were erased from the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
RebarShapeSet..::..ForwardIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
RebarShapeSet..::..GetEnumerator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
RebarShapeSet..::..Insert Method
RebarShapeSet Class See Also Send Feedback
Insert the specified rebar shape into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    RebarShape item
)
Visual Basic
Public Overridable Function Insert ( _
    item As RebarShape _
) As Boolean
Visual C++
public:
virtual bool Insert(
    RebarShape^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..RebarShape
The rebar shape to be inserted into the set.

Return Value

Returns whether the rebar shape was inserted into the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
RebarShapeSet..::..ReverseIterator Method
RebarShapeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RebarShapeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As RebarShapeSetIterator
Visual C++
public:
virtual RebarShapeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSet Properties

[image] [image]

Revit 2013 API
RebarShapeSet Properties
RebarShapeSet Class See Also Send Feedback

The RebarShapeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of rebar shapes that are in the set.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
RebarShapeSet..::..IsEmpty Property
RebarShapeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
RebarShapeSet..::..Size Property
RebarShapeSet Class See Also Send Feedback
Returns the number of rebar shapes that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

RebarShapeSet Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Class

[image]

Revit 2013 API
RebarShapeSetIterator Class
Members See Also Send Feedback
An iterator to a rebar shape set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class RebarShapeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class RebarShapeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class RebarShapeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..RebarShapeSetIterator

See Also

RebarShapeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Members

[image] [image]

Revit 2013 API
RebarShapeSetIterator Members
RebarShapeSetIterator Class Constructors Methods Properties See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | RebarShapeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Constructor

[image]

Revit 2013 API
RebarShapeSetIterator Constructor
RebarShapeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public RebarShapeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
RebarShapeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Methods

[image] [image]

Revit 2013 API
RebarShapeSetIterator Methods
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
RebarShapeSetIterator..::..MoveNext Method
RebarShapeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
RebarShapeSetIterator..::..Reset Method
RebarShapeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeSetIterator Properties

[image] [image]

Revit 2013 API
RebarShapeSetIterator Properties
RebarShapeSetIterator Class See Also Send Feedback

The RebarShapeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
RebarShapeSetIterator..::..Current Property
RebarShapeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

RebarShapeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeVertex Class

[image]

Revit 2013 API
RebarShapeVertex Class
Members See Also Send Feedback
A bend between segments of a rebar shape definition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class RebarShapeVertex : IDisposable
Visual Basic
Public Class RebarShapeVertex _
    Implements IDisposable
Visual C++
public ref class RebarShapeVertex : IDisposable

Remarks

A RebarShapeVertex is part of a RebarShapeDefinitionBySegments object. There is one vertex between each pair of adjacent segments, plus one at each end of the overall shape. The end vertices currently are ignored by the shape definition, even if they have constraints.

A bend may have the default radius of the bar type referenced by the Rebar element, or it may have a radius defined by a parameter.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..RebarShapeVertex

See Also

RebarShapeVertex Members
Autodesk.Revit.DB.Structure Namespace


RebarShapeVertex Members

[image] [image]

Revit 2013 API
RebarShapeVertex Members
RebarShapeVertex Class Methods Properties See Also Send Feedback

The RebarShapeVertex type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the RebarShapeVertex
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this vertex.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConstraints | Assign a new list of constraints to this vertex.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BendAngle | The range of permissible angles at this bend.
Public property | Turn | The sense of the turn: 1 for a left turn, -1 for a right turn. 0 is permissible for the first and last vertex, since they do not correspond to bends. (0 is also the default, so the Turn property must be set on each internal vertex before the RebarShapeDefinitionBySegments is used.)

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeVertex Methods

[image] [image]

Revit 2013 API
RebarShapeVertex Methods
RebarShapeVertex Class See Also Send Feedback

The RebarShapeVertex type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetConstraints | Retrieve the list of constraints associated with this vertex.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetConstraints | Assign a new list of constraints to this vertex.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
RebarShapeVertex..::..Dispose Method
RebarShapeVertex Class See Also Send Feedback
Releases all resources used by the RebarShapeVertex

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


GetConstraints Method

[image]

Revit 2013 API
RebarShapeVertex..::..GetConstraints Method
RebarShapeVertex Class See Also Send Feedback
Retrieve the list of constraints associated with this vertex.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public IList<RebarShapeConstraint> GetConstraints()
Visual Basic
Public Function GetConstraints As IList(Of RebarShapeConstraint)
Visual C++
public:
IList<RebarShapeConstraint^>^ GetConstraints()

Return Value

The list of constraints.

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


SetConstraints Method

[image]

Revit 2013 API
RebarShapeVertex..::..SetConstraints Method
RebarShapeVertex Class See Also Send Feedback
Assign a new list of constraints to this vertex.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public void SetConstraints(
    IList<RebarShapeConstraint> constraints
)
Visual Basic
Public Sub SetConstraints ( _
    constraints As IList(Of RebarShapeConstraint) _
)
Visual C++
public:
void SetConstraints(
    IList<RebarShapeConstraint^>^ constraints
)

Parameters

constraints
Type: System.Collections.Generic..::..IList<(Of <(<'RebarShapeConstraint>)>)>
A new list of constraints.

Remarks

Any existing constraints are discarded. The new constraints replace them. Any parameters driving the constraints must already be added with RebarShapeDefinition.AddParameter().

The allowable constraint types are:

  • RebarShapeConstraintRadius
  • RebarShapeConstraintArcLength
Any number of constraints may be specified. With no constraints, the bend radius will default to the appropriate bend radius from the RebarBarType element.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | One or more of the constraints is of a type not supported for RebarShapeVertex.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeVertex Properties

[image] [image]

Revit 2013 API
RebarShapeVertex Properties
RebarShapeVertex Class See Also Send Feedback

The RebarShapeVertex type exposes the following members.

Properties

 | Name | Description
Public property | BendAngle | The range of permissible angles at this bend.
Public property | Turn | The sense of the turn: 1 for a left turn, -1 for a right turn. 0 is permissible for the first and last vertex, since they do not correspond to bends. (0 is also the default, so the Turn property must be set on each internal vertex before the RebarShapeDefinitionBySegments is used.)

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


BendAngle Property

[image]

Revit 2013 API
RebarShapeVertex..::..BendAngle Property
RebarShapeVertex Class See Also Send Feedback
The range of permissible angles at this bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeBendAngle BendAngle { get; set; }
Visual Basic
Public Property BendAngle As RebarShapeBendAngle
    Get
    Set
Visual C++
public:
property RebarShapeBendAngle BendAngle {
    RebarShapeBendAngle get ();
    void set (RebarShapeBendAngle value);
}

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


Turn Property

[image]

Revit 2013 API
RebarShapeVertex..::..Turn Property
RebarShapeVertex Class See Also Send Feedback
The sense of the turn: 1 for a left turn, -1 for a right turn. 0 is permissible for the first and last vertex, since they do not correspond to bends. (0 is also the default, so the Turn property must be set on each internal vertex before the RebarShapeDefinitionBySegments is used.)

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public RebarShapeVertexTurn Turn { get; set; }
Visual Basic
Public Property Turn As RebarShapeVertexTurn
    Get
    Set
Visual C++
public:
property RebarShapeVertexTurn Turn {
    RebarShapeVertexTurn get ();
    void set (RebarShapeVertexTurn value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: turn must be Left or Right.

See Also

RebarShapeVertex Class
Autodesk.Revit.DB.Structure Namespace


RebarShapeVertexTurn Enumeration

[image]

Revit 2013 API
RebarShapeVertexTurn Enumeration
See Also Send Feedback
Specify whether a bend at a RebarShapeVertex represents a left or right turn.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012
Since: 2012

Syntax

C#
public enum RebarShapeVertexTurn
Visual Basic
Public Enumeration RebarShapeVertexTurn
Visual C++
public enum class RebarShapeVertexTurn

Members

Member name | Description
Right | A right turn.
Default | The turn value has not yet been set, or will not be used.
Left | A left turn.

See Also

Autodesk.Revit.DB.Structure Namespace


RebarStyle Enumeration

[image]

Revit 2013 API
RebarStyle Enumeration
See Also Send Feedback
Describes the usage style of a RebarShape. The style affects the bend radius and the set of allowable hooks. It also affects Rebar instance auto-constraining behavior.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RebarStyle
Visual Basic
Public Enumeration RebarStyle
Visual C++
public enum class RebarStyle

Members

Member name | Description
Standard | A standard or longitudinal bar.
StirrupTie | A stirrup or tie bar.

See Also

Autodesk.Revit.DB.Structure Namespace


ReinforcementLayerDirection Enumeration

[image]

Revit 2013 API
ReinforcementLayerDirection Enumeration
See Also Send Feedback
Describes the direction of reinforcement layer.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ReinforcementLayerDirection
Visual Basic
Public Enumeration ReinforcementLayerDirection
Visual C++
public enum class ReinforcementLayerDirection

Members

Member name | Description
Major | Reinforcement layer is in the major direction.
Minor | Reinforcement layer is in the minor direction.

See Also

Autodesk.Revit.DB.Structure Namespace


ReinforcementLayerFace Enumeration

[image]

Revit 2013 API
ReinforcementLayerFace Enumeration
See Also Send Feedback
Describes the position of layer at area or path reinforcement's host.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ReinforcementLayerFace
Visual Basic
Public Enumeration ReinforcementLayerFace
Visual C++
public enum class ReinforcementLayerFace

Members

Member name | Description
TopOrFront | Reinforcement layer is on the top face of a floor host, or on the front face of a wall host.
BottomOrBack | Reinforcement layer is on the bottom face of a floor host, or on the back face of a wall host.

See Also

Autodesk.Revit.DB.Structure Namespace


ReinforcementSettings Class

[image]

Revit 2013 API
ReinforcementSettings Class
Members See Also Send Feedback
Provides access to project-wide reinforcement settings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ReinforcementSettings : IDisposable
Visual Basic
Public Class ReinforcementSettings _
    Implements IDisposable
Visual C++
public ref class ReinforcementSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..ReinforcementSettings

See Also

ReinforcementSettings Members
Autodesk.Revit.DB.Structure Namespace


ReinforcementSettings Members

[image] [image]

Revit 2013 API
ReinforcementSettings Members
ReinforcementSettings Class Methods Properties See Also Send Feedback

The ReinforcementSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the ReinforcementSettings
Public method | DocumentContainsNoAreaOrPathReinforcement | Checks whether the document is free of AreaReinforcement and PathReinforcement elements. Only in this case is it permissible to change the HostStructuralRebar property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReinforcementSettings | Obtains the ReinforcementSettings object for the specified project document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HostStructuralRebar | Host Structural Rebar within Area and Path Reinforcement.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


ReinforcementSettings Methods

[image] [image]

Revit 2013 API
ReinforcementSettings Methods
ReinforcementSettings Class See Also Send Feedback

The ReinforcementSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | DocumentContainsNoAreaOrPathReinforcement | Checks whether the document is free of AreaReinforcement and PathReinforcement elements. Only in this case is it permissible to change the HostStructuralRebar property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetReinforcementSettings | Obtains the ReinforcementSettings object for the specified project document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
ReinforcementSettings..::..Dispose Method
ReinforcementSettings Class See Also Send Feedback
Releases all resources used by the ReinforcementSettings

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


DocumentContainsNoAreaOrPathReinforcement Method

[image]

Revit 2013 API
ReinforcementSettings..::..DocumentContainsNoAreaOrPathReinforcement Method
ReinforcementSettings Class See Also Send Feedback
Checks whether the document is free of AreaReinforcement and PathReinforcement elements. Only in this case is it permissible to change the HostStructuralRebar property.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool DocumentContainsNoAreaOrPathReinforcement()
Visual Basic
Public Function DocumentContainsNoAreaOrPathReinforcement As Boolean
Visual C++
public:
bool DocumentContainsNoAreaOrPathReinforcement()

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


GetReinforcementSettings Method

[image]

Revit 2013 API
ReinforcementSettings..::..GetReinforcementSettings Method
ReinforcementSettings Class See Also Send Feedback
Obtains the ReinforcementSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ReinforcementSettings GetReinforcementSettings(
    Document doc
)
Visual Basic
Public Shared Function GetReinforcementSettings ( _
    doc As Document _
) As ReinforcementSettings
Visual C++
public:
static ReinforcementSettings^ GetReinforcementSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A project document.

Return Value

The ReinforcementSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | doc is not a project document.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


ReinforcementSettings Properties

[image] [image]

Revit 2013 API
ReinforcementSettings Properties
ReinforcementSettings Class See Also Send Feedback

The ReinforcementSettings type exposes the following members.

Properties

 | Name | Description
Public property | HostStructuralRebar | Host Structural Rebar within Area and Path Reinforcement.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


HostStructuralRebar Property

[image]

Revit 2013 API
ReinforcementSettings..::..HostStructuralRebar Property
ReinforcementSettings Class See Also Send Feedback
Host Structural Rebar within Area and Path Reinforcement.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HostStructuralRebar { get; set; }
Visual Basic
Public Property HostStructuralRebar As Boolean
    Get
    Set
Visual C++
public:
property bool HostStructuralRebar {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: the document contains one or more AreaReinforcement or PathReinforcement elements.

See Also

ReinforcementSettings Class
Autodesk.Revit.DB.Structure Namespace


SlabFoundationType Enumeration

[image]

Revit 2013 API
SlabFoundationType Enumeration
See Also Send Feedback
SlabFoundation type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum SlabFoundationType
Visual Basic
Public Enumeration SlabFoundationType
Visual C++
public enum class SlabFoundationType

Members

Member name | Description
SlabOneWay | SlabFoundationType is SlabOneWay.
SlabFoundation | SlabFoundationType is SlabFoundation.
SlabOnGrade | SlabFoundationType is SlabOnGrade.
SlabTwoWay | SlabFoundationType is SlabTwoWay.

See Also

Autodesk.Revit.DB.Structure Namespace


StirrupTieAttachmentType Enumeration

[image]

Revit 2013 API
StirrupTieAttachmentType Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public enum StirrupTieAttachmentType
Visual Basic
Public Enumeration StirrupTieAttachmentType
Visual C++
public enum class StirrupTieAttachmentType

Members

Member name | Description
InteriorFace | Designate Stirrup/Tie rebar to attach to interior face of cover reference.
ExteriorFace | Designate Stirrup/Tie rebar to attach to exterior face of cover reference.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralConnectionApplyTo Enumeration

[image]

Revit 2013 API
StructuralConnectionApplyTo Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum StructuralConnectionApplyTo
Visual Basic
Public Enumeration StructuralConnectionApplyTo
Visual C++
public enum class StructuralConnectionApplyTo

Members

Member name | Description
BeamsAndBraces | Designate a StructuralConnectionType to apply to beams and braces.
ColumnTop | Designate a StructuralConnectionType to apply to the top of a column.
ColumnBase | Designate a StructuralConnectionType to apply to the base of a column.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Class

[image]

Revit 2013 API
StructuralConnectionType Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class StructuralConnectionType : ElementType
Visual Basic
Public Class StructuralConnectionType _
    Inherits ElementType
Visual C++
public ref class StructuralConnectionType : public ElementType

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Structure..::..StructuralConnectionType

See Also

StructuralConnectionType Members
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Members

[image] [image]

Revit 2013 API
StructuralConnectionType Members
StructuralConnectionType Class Methods Properties See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllStructuralConnectionTypeIds | Collects the ids of all StructuralConnectionTypes in the document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidFamilySymbolId | Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Properties

 | Name | Description
Public property | ApplyTo | Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Methods

[image] [image]

Revit 2013 API
StructuralConnectionType Methods
StructuralConnectionType Class See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
 | Create | Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetAllStructuralConnectionTypeIds | Collects the ids of all StructuralConnectionTypes in the document.
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetFamilySymbolId | FamilySymbol of the annotation to use for this connection type.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidFamilySymbolId | Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


Create Method

[image]

Revit 2013 API
StructuralConnectionType..::..Create Method
StructuralConnectionType Class See Also Send Feedback
Create a new StructuralConnectionType, allowing the specified annotation FamilySymbol to be applied to structural members.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static StructuralConnectionType Create(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    string name,
    ElementId familySymbolId
)
Visual Basic
Public Shared Function Create ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    name As String, _
    familySymbolId As ElementId _
) As StructuralConnectionType
Visual C++
public:
static StructuralConnectionType^ Create(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    String^ name,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
applyTo
Type: Autodesk.Revit.DB.Structure..::..StructuralConnectionApplyTo
Specify which type of member this connection type can be applied to.
name
Type: System..::..String
A name for the connection type. It must be unique within the document.
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId
The id of an annotation FamilySymbol. InvalidElementId is allowed. Otherwise, the FamilySymbol must be in the category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo argument.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to applyTo.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


GetAllStructuralConnectionTypeIds Method

[image]

Revit 2013 API
StructuralConnectionType..::..GetAllStructuralConnectionTypeIds Method
StructuralConnectionType Class See Also Send Feedback
Collects the ids of all StructuralConnectionTypes in the document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void GetAllStructuralConnectionTypeIds(
    Document cda,
    out ICollection<ElementId> ids
)
Visual Basic
Public Shared Sub GetAllStructuralConnectionTypeIds ( _
    cda As Document, _
    <OutAttribute> ByRef ids As ICollection(Of ElementId) _
)
Visual C++
public:
static void GetAllStructuralConnectionTypeIds(
    Document^ cda,
    [OutAttribute] ICollection<ElementId^>^% ids
)

Parameters

cda
Type: Autodesk.Revit.DB..::..Document
ids
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>%

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


GetFamilySymbolId Method

[image]

Revit 2013 API
StructuralConnectionType..::..GetFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
FamilySymbol of the annotation to use for this connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId GetFamilySymbolId()
Visual Basic
Public Function GetFamilySymbolId As ElementId
Visual C++
public:
ElementId^ GetFamilySymbolId()

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


SetFamilySymbolId Method

[image]

Revit 2013 API
StructuralConnectionType..::..SetFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
FamilySymbol of the annotation to use for this connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void SetFamilySymbolId(
    ElementId familySymbolId
)
Visual Basic
Public Sub SetFamilySymbolId ( _
    familySymbolId As ElementId _
)
Visual C++
public:
void SetFamilySymbolId(
    ElementId^ familySymbolId
)

Parameters

familySymbolId
Type: Autodesk.Revit.DB..::..ElementId

Remarks

The FamilySymbol must be of category "Connection Symbols" (OST_StructConnectionSymbols) and have its "Apply To" parameter set to match the applyTo property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when familySymbolId is the id of some element that is not a FamilySymbol, is not of the category "Connection Symbols" (OST_StructConnectionSymbols), or has its "Apply To" parameter not equal to this type's applyTo property.
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


ValidFamilySymbolId Method

[image]

Revit 2013 API
StructuralConnectionType..::..ValidFamilySymbolId Method
StructuralConnectionType Class See Also Send Feedback
Checks whether the family symbol id is allowed for StructuralConnectionTypes with the given value for the applyTo property.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static bool ValidFamilySymbolId(
    Document doc,
    StructuralConnectionApplyTo applyTo,
    ElementId familySymbolId
)
Visual Basic
Public Shared Function ValidFamilySymbolId ( _
    doc As Document, _
    applyTo As StructuralConnectionApplyTo, _
    familySymbolId As ElementId _
) As Boolean
Visual C++
public:
static bool ValidFamilySymbolId(
    Document^ doc,
    StructuralConnectionApplyTo applyTo,
    ElementId^ familySymbolId
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
applyTo
Type: Autodesk.Revit.DB.Structure..::..StructuralConnectionApplyTo
familySymbolId
Type: Autodesk.Revit.DB..::..ElementId

Return Value

True if %familySymbolId% is invalidElementId; or if it is the id of a FamilySymbol of category "Connection Symbols" (OST_StructConnectionSymbols) with its "Apply To" parameter set to match the applyTo property. Returns false otherwise.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


StructuralConnectionType Properties

[image] [image]

Revit 2013 API
StructuralConnectionType Properties
StructuralConnectionType Class See Also Send Feedback

The StructuralConnectionType type exposes the following members.

Properties

 | Name | Description
Public property | ApplyTo | Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


ApplyTo Property

[image]

Revit 2013 API
StructuralConnectionType..::..ApplyTo Property
StructuralConnectionType Class See Also Send Feedback
Choose whether this connection type applies to beams and braces, to tops of columns, or to bases of columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralConnectionApplyTo ApplyTo { get; }
Visual Basic
Public ReadOnly Property ApplyTo As StructuralConnectionApplyTo
    Get
Visual C++
public:
property StructuralConnectionApplyTo ApplyTo {
    StructuralConnectionApplyTo get ();
}

Remarks

The property cannot be changed. Create a new StructuralConnectionType if a different value is needed.

See Also

StructuralConnectionType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
StructuralConnectionType..::..Parameter Property
StructuralConnectionType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

StructuralConnectionType Class
StructuralConnectionType Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsage Enumeration

[image]

Revit 2013 API
StructuralInstanceUsage Enumeration
See Also Send Feedback

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum StructuralInstanceUsage
Visual Basic
Public Enumeration StructuralInstanceUsage
Visual C++
public enum class StructuralInstanceUsage

Members

Member name | Description
Undefined |
Wall |
Column |
Girder |
Joist |
Purlin |
Other |
Brace |
HorizontalBracing |
KickerBracing |
Automatic |
TrussChord |
TrussWeb |

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Class

[image]

Revit 2013 API
StructuralInstanceUsageFilter Class
Members See Also Send Feedback
A filter used to find elements that are structural family instances (typically columns, beams or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class StructuralInstanceUsageFilter : ElementSlowFilter
Visual Basic
Public Class StructuralInstanceUsageFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralInstanceUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Structure..::..StructuralInstanceUsageFilter

See Also

StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Members

[image] [image]

Revit 2013 API
StructuralInstanceUsageFilter Members
StructuralInstanceUsageFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Constructors

 | Name | Description
Public method | StructuralInstanceUsageFilter(StructuralInstanceUsage) | Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage.
Public method | StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) | Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralUsage | The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor

[image] [image]

Revit 2013 API
StructuralInstanceUsageFilter Constructor
StructuralInstanceUsageFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StructuralInstanceUsageFilter(StructuralInstanceUsage) | Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage.
Public method | StructuralInstanceUsageFilter(StructuralInstanceUsage, Boolean) | Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage)

[image]

Revit 2013 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match structural family instances (typically columns, beams, or braces) of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)
Visual Basic
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralInstanceUsage
The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)

[image]

Revit 2013 API
StructuralInstanceUsageFilter Constructor (StructuralInstanceUsage, Boolean)
StructuralInstanceUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralUsage As StructuralInstanceUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralInstanceUsageFilter(
    StructuralInstanceUsage structuralUsage,
    bool inverted
)

Parameters

structuralUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralInstanceUsage
The structural usage to match.
inverted
Type: System..::..Boolean
True if the filter should match all family instances which are not of the given structural usage.

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Methods

[image] [image]

Revit 2013 API
StructuralInstanceUsageFilter Methods
StructuralInstanceUsageFilter Class See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
StructuralInstanceUsageFilter..::..PassesFilter Method
StructuralInstanceUsageFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

StructuralInstanceUsageFilter Class
StructuralInstanceUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralInstanceUsageFilter Properties

[image] [image]

Revit 2013 API
StructuralInstanceUsageFilter Properties
StructuralInstanceUsageFilter Class See Also Send Feedback

The StructuralInstanceUsageFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralUsage | The family instance structural usage.

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralUsage Property

[image]

Revit 2013 API
StructuralInstanceUsageFilter..::..StructuralUsage Property
StructuralInstanceUsageFilter Class See Also Send Feedback
The family instance structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralInstanceUsage StructuralUsage { get; }
Visual Basic
Public ReadOnly Property StructuralUsage As StructuralInstanceUsage
    Get
Visual C++
public:
property StructuralInstanceUsage StructuralUsage {
    StructuralInstanceUsage get ();
}

See Also

StructuralInstanceUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Enumeration

[image]

Revit 2013 API
StructuralMaterialType Enumeration
See Also Send Feedback
Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralMaterialType
Visual Basic
Public Enumeration StructuralMaterialType
Visual C++
public enum class StructuralMaterialType

Members

Member name | Description
Undefined | Structural material type is undefined.
Steel | Structural material type is steel.
Concrete | Structural material type is concrete.
Wood | Structural material type is wood.
Other | Structural material type is other.
PrecastConcrete | Structural material type is precast concrete.
Generic | Structural material type is generic.
Aluminum | Structural material type is aluminum.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Class

[image]

Revit 2013 API
StructuralMaterialTypeFilter Class
Members See Also Send Feedback
A filter used to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class StructuralMaterialTypeFilter : ElementSlowFilter
Visual Basic
Public Class StructuralMaterialTypeFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralMaterialTypeFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Structure..::..StructuralMaterialTypeFilter

See Also

StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Members

[image] [image]

Revit 2013 API
StructuralMaterialTypeFilter Members
StructuralMaterialTypeFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Constructors

 | Name | Description
Public method | StructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match family instances that have the given structural material type.
Public method | StructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralMaterialType | The structural material type.

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor

[image] [image]

Revit 2013 API
StructuralMaterialTypeFilter Constructor
StructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StructuralMaterialTypeFilter(StructuralMaterialType) | Constructs a new instance of a filter to match family instances that have the given structural material type.
Public method | StructuralMaterialTypeFilter(StructuralMaterialType, Boolean) | Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor (StructuralMaterialType)

[image]

Revit 2013 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType)
StructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances that have the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)

[image]

Revit 2013 API
StructuralMaterialTypeFilter Constructor (StructuralMaterialType, Boolean)
StructuralMaterialTypeFilter Class See Also Send Feedback
Constructs a new instance of a filter to match family instances by structural material type, with the option to match all families which are not of the given structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralMaterialType As StructuralMaterialType, _
    inverted As Boolean _
)
Visual C++
public:
StructuralMaterialTypeFilter(
    StructuralMaterialType structuralMaterialType,
    bool inverted
)

Parameters

structuralMaterialType
Type: Autodesk.Revit.DB.Structure..::..StructuralMaterialType
The structural material type to match.
inverted
Type: System..::..Boolean
True if the filter should match all family instances which are not of the given structural material type.

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Methods

[image] [image]

Revit 2013 API
StructuralMaterialTypeFilter Methods
StructuralMaterialTypeFilter Class See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
StructuralMaterialTypeFilter..::..PassesFilter Method
StructuralMaterialTypeFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

StructuralMaterialTypeFilter Class
StructuralMaterialTypeFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialTypeFilter Properties

[image] [image]

Revit 2013 API
StructuralMaterialTypeFilter Properties
StructuralMaterialTypeFilter Class See Also Send Feedback

The StructuralMaterialTypeFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralMaterialType | The structural material type.

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralMaterialType Property

[image]

Revit 2013 API
StructuralMaterialTypeFilter..::..StructuralMaterialType Property
StructuralMaterialTypeFilter Class See Also Send Feedback
The structural material type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralMaterialType StructuralMaterialType { get; }
Visual Basic
Public ReadOnly Property StructuralMaterialType As StructuralMaterialType
    Get
Visual C++
public:
property StructuralMaterialType StructuralMaterialType {
    StructuralMaterialType get ();
}

See Also

StructuralMaterialTypeFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Class

[image]

Revit 2013 API
StructuralSettings Class
Members See Also Send Feedback
Provides access to project-wide structural settings.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class StructuralSettings : IDisposable
Visual Basic
Public Class StructuralSettings _
    Implements IDisposable
Visual C++
public ref class StructuralSettings : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..StructuralSettings

See Also

StructuralSettings Members
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Members

[image] [image]

Revit 2013 API
StructuralSettings Members
StructuralSettings Class Methods Properties See Also Send Feedback

The StructuralSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the StructuralSettings
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStructuralSettings | Obtains the StructuralSettings object for the specified project document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
Public property | AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
Public property | AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
Public property | AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
Public property | AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
Public property | AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
Public property | AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
Public property | AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
Public property | AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
Public property | AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
Public property | AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
Public property | AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
Public property | AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
Public property | BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
Public property | BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
Public property | BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
Public property | BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
Public property | BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
Public property | BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
Public property | BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
Public property | BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
Public property | CheckAnalyticalModelAsset | Whether to check for valid Asset within the Material of associated Physical Element.
Public property | DifferentiateAnalyticalEnds | Whether to use a subcategory for the ends of a linear analytical model, rather than the main category.
Public property | KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
Public property | ShowBraceAbove | Whether to show brace symbols above beams in plan views.
Public property | ShowBraceBelow | Whether to show brace symbols below beams in plan views.
Public property | SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
Public property | SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
Public property | SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Methods

[image] [image]

Revit 2013 API
StructuralSettings Methods
StructuralSettings Class See Also Send Feedback

The StructuralSettings type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStructuralSettings | Obtains the StructuralSettings object for the specified project document.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


Dispose Method

[image]

Revit 2013 API
StructuralSettings..::..Dispose Method
StructuralSettings Class See Also Send Feedback
Releases all resources used by the StructuralSettings

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


GetStructuralSettings Method

[image]

Revit 2013 API
StructuralSettings..::..GetStructuralSettings Method
StructuralSettings Class See Also Send Feedback
Obtains the StructuralSettings object for the specified project document.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static StructuralSettings GetStructuralSettings(
    Document doc
)
Visual Basic
Public Shared Function GetStructuralSettings ( _
    doc As Document _
) As StructuralSettings
Visual C++
public:
static StructuralSettings^ GetStructuralSettings(
    Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
A project document.

Return Value

The StructuralSettings object.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralSettings Properties

[image] [image]

Revit 2013 API
StructuralSettings Properties
StructuralSettings Class See Also Send Feedback

The StructuralSettings type exposes the following members.

Properties

 | Name | Description
Public property | AnalyticalModelAdjustmentTolerance | Tolerance for the analytical adjustment distance.
Public property | AnalyticalModelAutoCheckConsistency | Whether to check automatically for consistency between the analytical and physical models.
Public property | AnalyticalModelAutoCheckMemberSupports | Whether to check automatically for member supports.
Public property | AnalyticalModelCheckAdjustment | Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.
Public property | AnalyticalModelCheckBeamSlabDistance | Whether to check the analytical model distance between beam and slab for a level.
Public property | AnalyticalModelCheckCircularReferences | Whether to check member supports for circular references.
Public property | AnalyticalModelCheckDiscrepancy | Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.
Public property | AnalyticalModelCheckInstability | Whether to check for possible instability based on release conditions.
Public property | AnalyticalModelCheckSupportDistance | Check that joins in the physical model are consistent with proximity in the analytical model.
Public property | AnalyticalModelDiscrepancyTolerance | Tolerance for the analytical-to-physical model distance.
Public property | AnalyticalModelHorizontalAutofixTolerance | Tolerance for horizontal auto-detect for the analytical model.
Public property | AnalyticalModelSupportDistanceTolerance | The maximum distance between two structural elements, where analytical model support rules still apply.
Public property | AnalyticalModelVerticalAutofixTolerance | Tolerance for vertical auto-detect for the analytical model.
Public property | BoundaryConditionAreaAndLineSymbolSpacing | Symbol spacing for boundary conditions.
Public property | BoundaryConditionFamilySymbolFixed | The id of the FamilySymbol to represent a fixed boundary condition.
Public property | BoundaryConditionFamilySymbolPinned | The id of the FamilySymbol to represent a pinned boundary condition.
Public property | BoundaryConditionFamilySymbolRoller | The id of the FamilySymbol to represent a roller boundary condition.
Public property | BoundaryConditionFamilySymbolUserDefined | The id of the FamilySymbol to represent a user-defined boundary condition.
Public property | BraceAboveSymbol | The id of the ElementType to represent a brace above a beam in plan view.
Public property | BraceBelowSymbol | The id of the ElementType to represent a brace below a beam in plan view.
Public property | BraceParallelLineOffset | The distance by which brace symbols in plan views will be offset.
Public property | CheckAnalyticalModelAsset | Whether to check for valid Asset within the Material of associated Physical Element.
Public property | DifferentiateAnalyticalEnds | Whether to use a subcategory for the ends of a linear analytical model, rather than the main category.
Public property | KickerBraceSymbol | The id of the ElementType to represent a kicker brace.
Public property | ShowBraceAbove | Whether to show brace symbols above beams in plan views.
Public property | ShowBraceBelow | Whether to show brace symbols below beams in plan views.
Public property | SymbolicCutbackForBeamAndTruss | Symbolic cutback distance to be applied to all beams and trusses.
Public property | SymbolicCutbackForBrace | Symbolic cutback distance to be applied to all braces.
Public property | SymbolicCutbackForColumn | Symbolic cutback distance to be applied to all columns.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAdjustmentTolerance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelAdjustmentTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for the analytical adjustment distance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelAdjustmentTolerance { get; set; }
Visual Basic
Public Property AnalyticalModelAdjustmentTolerance As Double
    Get
    Set
Visual C++
public:
property double AnalyticalModelAdjustmentTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAutoCheckConsistency Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelAutoCheckConsistency Property
StructuralSettings Class See Also Send Feedback
Whether to check automatically for consistency between the analytical and physical models.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelAutoCheckConsistency { get; set; }
Visual Basic
Public Property AnalyticalModelAutoCheckConsistency As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelAutoCheckConsistency {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelAutoCheckMemberSupports Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelAutoCheckMemberSupports Property
StructuralSettings Class See Also Send Feedback
Whether to check automatically for member supports.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelAutoCheckMemberSupports { get; set; }
Visual Basic
Public Property AnalyticalModelAutoCheckMemberSupports As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelAutoCheckMemberSupports {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckAdjustment Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckAdjustment Property
StructuralSettings Class See Also Send Feedback
Whether to check for analytical model distance from default location is larger than the tolerance defined by the property AnalyticalModelAdjustmentTolerance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckAdjustment { get; set; }
Visual Basic
Public Property AnalyticalModelCheckAdjustment As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckAdjustment {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckBeamSlabDistance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckBeamSlabDistance Property
StructuralSettings Class See Also Send Feedback
Whether to check the analytical model distance between beam and slab for a level.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckBeamSlabDistance { get; set; }
Visual Basic
Public Property AnalyticalModelCheckBeamSlabDistance As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckBeamSlabDistance {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckCircularReferences Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckCircularReferences Property
StructuralSettings Class See Also Send Feedback
Whether to check member supports for circular references.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckCircularReferences { get; set; }
Visual Basic
Public Property AnalyticalModelCheckCircularReferences As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckCircularReferences {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckDiscrepancy Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckDiscrepancy Property
StructuralSettings Class See Also Send Feedback
Whether to check for distance between analytical and physical models greater than a tolerance defined by AnalyticalModelDiscrepancyTolerance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckDiscrepancy { get; set; }
Visual Basic
Public Property AnalyticalModelCheckDiscrepancy As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckDiscrepancy {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckInstability Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckInstability Property
StructuralSettings Class See Also Send Feedback
Whether to check for possible instability based on release conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckInstability { get; set; }
Visual Basic
Public Property AnalyticalModelCheckInstability As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckInstability {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelCheckSupportDistance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelCheckSupportDistance Property
StructuralSettings Class See Also Send Feedback
Check that joins in the physical model are consistent with proximity in the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AnalyticalModelCheckSupportDistance { get; set; }
Visual Basic
Public Property AnalyticalModelCheckSupportDistance As Boolean
    Get
    Set
Visual C++
public:
property bool AnalyticalModelCheckSupportDistance {
    bool get ();
    void set (bool value);
}

Remarks

When this check is enabled, a warning will be given for physically joined members whose analytical curves are more than a certain distance apart. The distance is given by the AnalyticalModelSupportDistanceTolerance property.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelDiscrepancyTolerance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelDiscrepancyTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for the analytical-to-physical model distance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelDiscrepancyTolerance { get; set; }
Visual Basic
Public Property AnalyticalModelDiscrepancyTolerance As Double
    Get
    Set
Visual C++
public:
property double AnalyticalModelDiscrepancyTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelHorizontalAutofixTolerance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelHorizontalAutofixTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for horizontal auto-detect for the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelHorizontalAutofixTolerance { get; set; }
Visual Basic
Public Property AnalyticalModelHorizontalAutofixTolerance As Double
    Get
    Set
Visual C++
public:
property double AnalyticalModelHorizontalAutofixTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelSupportDistanceTolerance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelSupportDistanceTolerance Property
StructuralSettings Class See Also Send Feedback
The maximum distance between two structural elements, where analytical model support rules still apply.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelSupportDistanceTolerance { get; set; }
Visual Basic
Public Property AnalyticalModelSupportDistanceTolerance As Double
    Get
    Set
Visual C++
public:
property double AnalyticalModelSupportDistanceTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


AnalyticalModelVerticalAutofixTolerance Property

[image]

Revit 2013 API
StructuralSettings..::..AnalyticalModelVerticalAutofixTolerance Property
StructuralSettings Class See Also Send Feedback
Tolerance for vertical auto-detect for the analytical model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double AnalyticalModelVerticalAutofixTolerance { get; set; }
Visual Basic
Public Property AnalyticalModelVerticalAutofixTolerance As Double
    Get
    Set
Visual C++
public:
property double AnalyticalModelVerticalAutofixTolerance {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionAreaAndLineSymbolSpacing Property

[image]

Revit 2013 API
StructuralSettings..::..BoundaryConditionAreaAndLineSymbolSpacing Property
StructuralSettings Class See Also Send Feedback
Symbol spacing for boundary conditions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double BoundaryConditionAreaAndLineSymbolSpacing { get; set; }
Visual Basic
Public Property BoundaryConditionAreaAndLineSymbolSpacing As Double
    Get
    Set
Visual C++
public:
property double BoundaryConditionAreaAndLineSymbolSpacing {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolFixed Property

[image]

Revit 2013 API
StructuralSettings..::..BoundaryConditionFamilySymbolFixed Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a fixed boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolFixed { get; set; }
Visual Basic
Public Property BoundaryConditionFamilySymbolFixed As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolFixed {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolPinned Property

[image]

Revit 2013 API
StructuralSettings..::..BoundaryConditionFamilySymbolPinned Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a pinned boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolPinned { get; set; }
Visual Basic
Public Property BoundaryConditionFamilySymbolPinned As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolPinned {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolRoller Property

[image]

Revit 2013 API
StructuralSettings..::..BoundaryConditionFamilySymbolRoller Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a roller boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolRoller { get; set; }
Visual Basic
Public Property BoundaryConditionFamilySymbolRoller As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolRoller {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BoundaryConditionFamilySymbolUserDefined Property

[image]

Revit 2013 API
StructuralSettings..::..BoundaryConditionFamilySymbolUserDefined Property
StructuralSettings Class See Also Send Feedback
The id of the FamilySymbol to represent a user-defined boundary condition.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BoundaryConditionFamilySymbolUserDefined { get; set; }
Visual Basic
Public Property BoundaryConditionFamilySymbolUserDefined As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BoundaryConditionFamilySymbolUserDefined {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceAboveSymbol Property

[image]

Revit 2013 API
StructuralSettings..::..BraceAboveSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a brace above a beam in plan view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BraceAboveSymbol { get; set; }
Visual Basic
Public Property BraceAboveSymbol As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BraceAboveSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceBelowSymbol Property

[image]

Revit 2013 API
StructuralSettings..::..BraceBelowSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a brace below a beam in plan view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId BraceBelowSymbol { get; set; }
Visual Basic
Public Property BraceBelowSymbol As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ BraceBelowSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


BraceParallelLineOffset Property

[image]

Revit 2013 API
StructuralSettings..::..BraceParallelLineOffset Property
StructuralSettings Class See Also Send Feedback
The distance by which brace symbols in plan views will be offset.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double BraceParallelLineOffset { get; set; }
Visual Basic
Public Property BraceParallelLineOffset As Double
    Get
    Set
Visual C++
public:
property double BraceParallelLineOffset {
    double get ();
    void set (double value);
}

Remarks

Applies only when BracePlanRepresentation is set to ParallelLine.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


CheckAnalyticalModelAsset Property

[image]

Revit 2013 API
StructuralSettings..::..CheckAnalyticalModelAsset Property
StructuralSettings Class See Also Send Feedback
Whether to check for valid Asset within the Material of associated Physical Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool CheckAnalyticalModelAsset { get; set; }
Visual Basic
Public Property CheckAnalyticalModelAsset As Boolean
    Get
    Set
Visual C++
public:
property bool CheckAnalyticalModelAsset {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


DifferentiateAnalyticalEnds Property

[image]

Revit 2013 API
StructuralSettings..::..DifferentiateAnalyticalEnds Property
StructuralSettings Class See Also Send Feedback
Whether to use a subcategory for the ends of a linear analytical model, rather than the main category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool DifferentiateAnalyticalEnds { get; set; }
Visual Basic
Public Property DifferentiateAnalyticalEnds As Boolean
    Get
    Set
Visual C++
public:
property bool DifferentiateAnalyticalEnds {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


KickerBraceSymbol Property

[image]

Revit 2013 API
StructuralSettings..::..KickerBraceSymbol Property
StructuralSettings Class See Also Send Feedback
The id of the ElementType to represent a kicker brace.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ElementId KickerBraceSymbol { get; set; }
Visual Basic
Public Property KickerBraceSymbol As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ KickerBraceSymbol {
    ElementId^ get ();
    void set (ElementId^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


ShowBraceAbove Property

[image]

Revit 2013 API
StructuralSettings..::..ShowBraceAbove Property
StructuralSettings Class See Also Send Feedback
Whether to show brace symbols above beams in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowBraceAbove { get; set; }
Visual Basic
Public Property ShowBraceAbove As Boolean
    Get
    Set
Visual C++
public:
property bool ShowBraceAbove {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


ShowBraceBelow Property

[image]

Revit 2013 API
StructuralSettings..::..ShowBraceBelow Property
StructuralSettings Class See Also Send Feedback
Whether to show brace symbols below beams in plan views.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowBraceBelow { get; set; }
Visual Basic
Public Property ShowBraceBelow As Boolean
    Get
    Set
Visual C++
public:
property bool ShowBraceBelow {
    bool get ();
    void set (bool value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForBeamAndTruss Property

[image]

Revit 2013 API
StructuralSettings..::..SymbolicCutbackForBeamAndTruss Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all beams and trusses.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForBeamAndTruss { get; set; }
Visual Basic
Public Property SymbolicCutbackForBeamAndTruss As Double
    Get
    Set
Visual C++
public:
property double SymbolicCutbackForBeamAndTruss {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForBrace Property

[image]

Revit 2013 API
StructuralSettings..::..SymbolicCutbackForBrace Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all braces.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForBrace { get; set; }
Visual Basic
Public Property SymbolicCutbackForBrace As Double
    Get
    Set
Visual C++
public:
property double SymbolicCutbackForBrace {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


SymbolicCutbackForColumn Property

[image]

Revit 2013 API
StructuralSettings..::..SymbolicCutbackForColumn Property
StructuralSettings Class See Also Send Feedback
Symbolic cutback distance to be applied to all columns.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double SymbolicCutbackForColumn { get; set; }
Visual Basic
Public Property SymbolicCutbackForColumn As Double
    Get
    Set
Visual C++
public:
property double SymbolicCutbackForColumn {
    double get ();
    void set (double value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural.

See Also

StructuralSettings Class
Autodesk.Revit.DB.Structure Namespace


StructuralType Enumeration

[image]

Revit 2013 API
StructuralType Enumeration
See Also Send Feedback
Represents the structural type of a family instance.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum StructuralType
Visual Basic
Public Enumeration StructuralType
Visual C++
public enum class StructuralType

Members

Member name | Description
NonStructural | Non-Structural
Beam | Structural Beam
Brace | Structural Brace
Column | Structural Column
Footing | Structural Footing
UnknownFraming | Unknown Framing

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralWallUsage Enumeration

[image]

Revit 2013 API
StructuralWallUsage Enumeration
See Also Send Feedback
Represents the structural usage of a wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011
Since: 2011

Syntax

C#
public enum StructuralWallUsage
Visual Basic
Public Enumeration StructuralWallUsage
Visual C++
public enum class StructuralWallUsage

Members

Member name | Description
NonBearing | Structural usage is non-bearing.
Bearing | Structural usage is bearing.
Shear | Structural usage is shear.
Combined | Structural usage is combined.

See Also

Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Class

[image]

Revit 2013 API
StructuralWallUsageFilter Class
Members See Also Send Feedback
A filter used to match walls that have the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class StructuralWallUsageFilter : ElementSlowFilter
Visual Basic
Public Class StructuralWallUsageFilter _
    Inherits ElementSlowFilter
Visual C++
public ref class StructuralWallUsageFilter : public ElementSlowFilter

Remarks

This filter is a slow filter, but it uses a quick filter to eliminate non-candidate elements before the elements are obtained and expanded. Therefore this filter does not have to be paired with another quick filter to minimize the number of Elements that are expanded.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB.Structure..::..StructuralWallUsageFilter

See Also

StructuralWallUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Members

[image] [image]

Revit 2013 API
StructuralWallUsageFilter Members
StructuralWallUsageFilter Class Constructors Methods Properties See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Constructors

 | Name | Description
Public method | StructuralWallUsageFilter(StructuralWallUsage) | Constructs a new instance of a filter to match walls that have the given structural wall usage.
Public method | StructuralWallUsageFilter(StructuralWallUsage, Boolean) | Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralWallUsage | The wall structural usage.

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor

[image] [image]

Revit 2013 API
StructuralWallUsageFilter Constructor
StructuralWallUsageFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StructuralWallUsageFilter(StructuralWallUsage) | Constructs a new instance of a filter to match walls that have the given structural wall usage.
Public method | StructuralWallUsageFilter(StructuralWallUsage, Boolean) | Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor (StructuralWallUsage)

[image]

Revit 2013 API
StructuralWallUsageFilter Constructor (StructuralWallUsage)
StructuralWallUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match walls that have the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage
)
Visual Basic
Public Sub New ( _
    structuralWallUsage As StructuralWallUsage _
)
Visual C++
public:
StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage
)

Parameters

structuralWallUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralWallUsage
The wall structural usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)

[image]

Revit 2013 API
StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)
StructuralWallUsageFilter Class See Also Send Feedback
Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)
Visual Basic
Public Sub New ( _
    structuralWallUsage As StructuralWallUsage, _
    inverted As Boolean _
)
Visual C++
public:
StructuralWallUsageFilter(
    StructuralWallUsage structuralWallUsage,
    bool inverted
)

Parameters

structuralWallUsage
Type: Autodesk.Revit.DB.Structure..::..StructuralWallUsage
The structural usage to match.
inverted
Type: System..::..Boolean
True if the filter should match all walls which are not of the given structural wall usage.

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Overload
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Methods

[image] [image]

Revit 2013 API
StructuralWallUsageFilter Methods
StructuralWallUsageFilter Class See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | (Inherited from ElementFilter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


PassesFilter Method

[image] [image]

Revit 2013 API
StructuralWallUsageFilter..::..PassesFilter Method
StructuralWallUsageFilter Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassesFilter(Element) | Applies the filter to a given element. (Inherited from ElementFilter.)
Public method | PassesFilter(Document, ElementId) | Applies the filter to a given element. (Inherited from ElementFilter.)

See Also

StructuralWallUsageFilter Class
StructuralWallUsageFilter Members
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsageFilter Properties

[image] [image]

Revit 2013 API
StructuralWallUsageFilter Properties
StructuralWallUsageFilter Class See Also Send Feedback

The StructuralWallUsageFilter type exposes the following members.

Properties

 | Name | Description
Public property | Inverted | True if the results of the filter are inverted; elements that would normally be accepted by this filter will be rejected, and elements that would normally be rejected will be accepted. (Inherited from ElementFilter.)
Public property | StructuralWallUsage | The wall structural usage.

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


StructuralWallUsage Property

[image]

Revit 2013 API
StructuralWallUsageFilter..::..StructuralWallUsage Property
StructuralWallUsageFilter Class See Also Send Feedback
The wall structural usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public StructuralWallUsage StructuralWallUsage { get; }
Visual Basic
Public ReadOnly Property StructuralWallUsage As StructuralWallUsage
    Get
Visual C++
public:
property StructuralWallUsage StructuralWallUsage {
    StructuralWallUsage get ();
}

See Also

StructuralWallUsageFilter Class
Autodesk.Revit.DB.Structure Namespace


TranslationRotationValue Enumeration

[image]

Revit 2013 API
TranslationRotationValue Enumeration
See Also Send Feedback
Values for BoundaryConditions Translation and Rotation parameters.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TranslationRotationValue
Visual Basic
Public Enumeration TranslationRotationValue
Visual C++
public enum class TranslationRotationValue

Members

Member name | Description
Fixed | TranslationRotationValue is Fixed.
Release | TranslationRotationValue is Release.
Spring | TranslationRotationValue is Spring.

See Also

Autodesk.Revit.DB.Structure Namespace


Truss Class

[image]

Revit 2013 API
Truss Class
Members See Also Send Feedback
Represents all kinds of Trusses.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Truss : Element
Visual Basic
Public Class Truss _
    Inherits Element
Visual C++
public ref class Truss : public Element

Remarks

The Truss object represents all the kinds of Trusses in Revit. The TrussType property is used to distinguish the type of the Truss.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB.Structure..::..Truss

See Also

Truss Members
Autodesk.Revit.DB.Structure Namespace


Truss Members

[image] [image]

Revit 2013 API
Truss Members
Truss Class Methods Properties See Also Send Feedback

The Truss type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DetachChord | Detach a truss's specific chord from the element to which it is attached.
Public method | Dispose | (Inherited from Element.)
 | DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss, its lock status and its usage, etc.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Get all the truss curves.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Members | Get all the members of truss.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TrussType | Retrieve/set an object that represents the type of the truss.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Truss Methods

[image] [image]

Revit 2013 API
Truss Methods
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | AttachChord | Attach a truss's specific chord to a specified element, the element should be a roof or floor.
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | DetachChord | Detach a truss's specific chord from the element to which it is attached.
Public method | Dispose | (Inherited from Element.)
 | DropTruss | Drop truss Family, it will disassociate all members from the truss and delete the truss.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetTrussMemberInfo | Query if a given element is a member of a truss, its lock status and its usage, etc.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | RemoveProfile | Remove the profile of a truss.
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetProfile | Add or modify the profile of a truss.
Public method | TogglePinMember | Pin/Unpin a truss member.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


AttachChord Method

[image]

Revit 2013 API
Truss..::..AttachChord Method
Truss Class See Also Send Feedback
Attach a truss's specific chord to a specified element, the element should be a roof or floor.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AttachChord(
    Element attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)
Visual Basic
Public Sub AttachChord ( _
    attachToElement As Element, _
    location As TrussChordLocation, _
    forceRemoveSketch As Boolean _
)
Visual C++
public:
void AttachChord(
    Element^ attachToElement,
    TrussChordLocation location,
    bool forceRemoveSketch
)

Parameters

attachToElement
Type: Autodesk.Revit.DB..::..Element
The element to which the truss's chord will attach. The element should be a roof or floor.
location
Type: Autodesk.Revit.DB.Structure..::..TrussChordLocation
The chord need to be attached.
forceRemoveSketch
Type: System..::..Boolean
Whether to detach the original sketch if there is one.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


DetachChord Method

[image]

Revit 2013 API
Truss..::..DetachChord Method
Truss Class See Also Send Feedback
Detach a truss's specific chord from the element to which it is attached.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void DetachChord(
    TrussChordLocation location
)
Visual Basic
Public Sub DetachChord ( _
    location As TrussChordLocation _
)
Visual C++
public:
void DetachChord(
    TrussChordLocation location
)

Parameters

location
Type: Autodesk.Revit.DB.Structure..::..TrussChordLocation
The chord.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


DropTruss Method

[image]

Revit 2013 API
Truss..::..DropTruss Method
Truss Class See Also Send Feedback
Drop truss Family, it will disassociate all members from the truss and delete the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static void DropTruss(
    Truss truss
)
Visual Basic
Public Shared Sub DropTruss ( _
    truss As Truss _
)
Visual C++
public:
static void DropTruss(
    Truss^ truss
)

Parameters

truss
Type: Autodesk.Revit.DB.Structure..::..Truss
The truss to be dropped.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


GetTrussMemberInfo Method

[image]

Revit 2013 API
Truss..::..GetTrussMemberInfo Method
Truss Class See Also Send Feedback
Query if a given element is a member of a truss, its lock status and its usage, etc.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussMemberInfo GetTrussMemberInfo(
    ElementId elemId
)
Visual Basic
Public Function GetTrussMemberInfo ( _
    elemId As ElementId _
) As TrussMemberInfo
Visual C++
public:
TrussMemberInfo^ GetTrussMemberInfo(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The querying element.

Return Value

A struct TrussMemberInfo that contains the querying element's host truss, whether to lock to the truss, usage type, etc.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


RemoveProfile Method

[image]

Revit 2013 API
Truss..::..RemoveProfile Method
Truss Class See Also Send Feedback
Remove the profile of a truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveProfile()
Visual Basic
Public Sub RemoveProfile
Visual C++
public:
void RemoveProfile()

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


SetProfile Method

[image]

Revit 2013 API
Truss..::..SetProfile Method
Truss Class See Also Send Feedback
Add or modify the profile of a truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetProfile(
    CurveArray topChords,
    CurveArray bottomChords
)
Visual Basic
Public Sub SetProfile ( _
    topChords As CurveArray, _
    bottomChords As CurveArray _
)
Visual C++
public:
void SetProfile(
    CurveArray^ topChords,
    CurveArray^ bottomChords
)

Parameters

topChords
Type: Autodesk.Revit.DB..::..CurveArray
The curves serving as top chords of the truss.
bottomChords
Type: Autodesk.Revit.DB..::..CurveArray
The curves serving as bottom chords of the truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


TogglePinMember Method

[image]

Revit 2013 API
Truss..::..TogglePinMember Method
Truss Class See Also Send Feedback
Pin/Unpin a truss member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public void TogglePinMember(
    ElementId elemId
)
Visual Basic
Public Sub TogglePinMember ( _
    elemId As ElementId _
)
Visual C++
public:
void TogglePinMember(
    ElementId^ elemId
)

Parameters

elemId
Type: Autodesk.Revit.DB..::..ElementId
The member element is going to pin/unpin.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Truss Properties

[image] [image]

Revit 2013 API
Truss Properties
Truss Class See Also Send Feedback

The Truss type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | Curves | Get all the truss curves.
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Members | Get all the members of truss.
Public property | Name | A human readable name for the Element. (Inherited from Element.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | TrussType | Retrieve/set an object that represents the type of the truss.
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Curves Property

[image]

Revit 2013 API
Truss..::..Curves Property
Truss Class See Also Send Feedback
Get all the truss curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public CurveArray Curves { get; }
Visual Basic
Public ReadOnly Property Curves As CurveArray
    Get
Visual C++
public:
property CurveArray^ Curves {
    CurveArray^ get ();
}

Return Value

The Curves property returns a CurveArray that contains all the truss curves.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Members Property

[image]

Revit 2013 API
Truss..::..Members Property
Truss Class See Also Send Feedback
Get all the members of truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> Members { get; }
Visual Basic
Public ReadOnly Property Members As ICollection(Of ElementId)
    Get
Visual C++
public:
property ICollection<ElementId^>^ Members {
    ICollection<ElementId^>^ get ();
}

Return Value

The Members property returns an ElementIdSet that contains all the member Ids of truss.

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
Truss..::..Parameter Property
Truss Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

Truss Class
Truss Members
Autodesk.Revit.DB.Structure Namespace


TrussType Property

[image]

Revit 2013 API
Truss..::..TrussType Property
Truss Class See Also Send Feedback
Retrieve/set an object that represents the type of the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussType TrussType { get; set; }
Visual Basic
Public Property TrussType As TrussType
    Get
    Set
Visual C++
public:
property TrussType^ TrussType {
    TrussType^ get ();
    void set (TrussType^ value);
}

See Also

Truss Class
Autodesk.Revit.DB.Structure Namespace


TrussChordLocation Enumeration

[image]

Revit 2013 API
TrussChordLocation Enumeration
See Also Send Feedback
This enumerated type represents the options for the Truss Chord Location.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TrussChordLocation
Visual Basic
Public Enumeration TrussChordLocation
Visual C++
public enum class TrussChordLocation

Members

Member name | Description
Bottom | The bottom chord of the Truss.
Top | The top chord of the Truss.

See Also

Autodesk.Revit.DB.Structure Namespace


TrussCurveType Enumeration

[image]

Revit 2013 API
TrussCurveType Enumeration
See Also Send Feedback
Types of curves created in truss families.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TrussCurveType
Visual Basic
Public Enumeration TrussCurveType
Visual C++
public enum class TrussCurveType

Members

Member name | Description
NonTrussCurve |
TopChord |
BottomChord |
Web |

See Also

Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Class

[image]

Revit 2013 API
TrussMemberInfo Class
Members See Also Send Feedback
Provides access to the information of a truss member in Autodesk Revit.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TrussMemberInfo
Visual Basic
Public Class TrussMemberInfo
Visual C++
public ref class TrussMemberInfo

Remarks

A struct TrussMemberInfo that contains an element's host truss, whether to lock to the truss, usage type, etc.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB.Structure..::..TrussMemberInfo

See Also

TrussMemberInfo Members
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Members

[image] [image]

Revit 2013 API
TrussMemberInfo Members
TrussMemberInfo Class Constructors Methods Properties See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Constructors

 | Name | Description
Public method | TrussMemberInfo | For Internal Use Only.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | hostTrussId | The host truss' ElementId of the member.
Public property | lockedToTruss | Whether the member is locked to the host truss.
Public property | memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Constructor

[image]

Revit 2013 API
TrussMemberInfo Constructor
TrussMemberInfo Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussMemberInfo()
Visual Basic
Public Sub New
Visual C++
public:
TrussMemberInfo()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Methods

[image] [image]

Revit 2013 API
TrussMemberInfo Methods
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberInfo Properties

[image] [image]

Revit 2013 API
TrussMemberInfo Properties
TrussMemberInfo Class See Also Send Feedback

The TrussMemberInfo type exposes the following members.

Properties

 | Name | Description
Public property | hostTrussId | The host truss' ElementId of the member.
Public property | lockedToTruss | Whether the member is locked to the host truss.
Public property | memberTypeKey | Kind of the member in the truss.

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


hostTrussId Property

[image]

Revit 2013 API
TrussMemberInfo..::..hostTrussId Property
TrussMemberInfo Class See Also Send Feedback
The host truss' ElementId of the member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public ElementId hostTrussId { get; set; }
Visual Basic
Public Property hostTrussId As ElementId
    Get
    Set
Visual C++
public:
property ElementId^ hostTrussId {
    ElementId^ get ();
    void set (ElementId^ value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


lockedToTruss Property

[image]

Revit 2013 API
TrussMemberInfo..::..lockedToTruss Property
TrussMemberInfo Class See Also Send Feedback
Whether the member is locked to the host truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool lockedToTruss { get; set; }
Visual Basic
Public Property lockedToTruss As Boolean
    Get
    Set
Visual C++
public:
property bool lockedToTruss {
    bool get ();
    void set (bool value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


memberTypeKey Property

[image]

Revit 2013 API
TrussMemberInfo..::..memberTypeKey Property
TrussMemberInfo Class See Also Send Feedback
Kind of the member in the truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussMemberType memberTypeKey { get; set; }
Visual Basic
Public Property memberTypeKey As TrussMemberType
    Get
    Set
Visual C++
public:
property TrussMemberType memberTypeKey {
    TrussMemberType get ();
    void set (TrussMemberType value);
}

See Also

TrussMemberInfo Class
Autodesk.Revit.DB.Structure Namespace


TrussMemberType Enumeration

[image]

Revit 2013 API
TrussMemberType Enumeration
See Also Send Feedback
Indicates the "kind" of a truss member.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum TrussMemberType
Visual Basic
Public Enumeration TrussMemberType
Visual C++
public enum class TrussMemberType

Members

Member name | Description
ETK_Unknown | Unknown element type.
ETK_TrussTopChord | Truss top chord.
ETK_TrussBottomChord | Truss bottom chord.
ETK_TrussVertWeb | Truss VertWeb.
ETK_TrussDiagWeb | Truss DiagWeb.

See Also

Autodesk.Revit.DB.Structure Namespace


TrussType Class

[image]

Revit 2013 API
TrussType Class
Members See Also Send Feedback
Represents a specific type of truss.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TrussType : FamilySymbol
Visual Basic
Public Class TrussType _
    Inherits FamilySymbol
Visual C++
public ref class TrussType : public FamilySymbol

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB..::..InsertableObject
Autodesk.Revit.DB..::..FamilySymbol
Autodesk.Revit.DB.Structure..::..TrussType

See Also

TrussType Members
Autodesk.Revit.DB.Structure Namespace


TrussType Members

[image] [image]

Revit 2013 API
TrussType Members
TrussType Class Methods Properties See Also Send Feedback

The TrussType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


TrussType Methods

[image] [image]

Revit 2013 API
TrussType Methods
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Methods

 | Name | Description
Public method | ArePhasesModifiable | Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element. (Inherited from Element.)
Public method | CanBeHidden | Indicates if the element can be hidden in the view. (Inherited from Element.)
Public method | CanHaveAnalyticalModel | Indicates whether the Element can have an Analytical Model. (Inherited from Element.)
Public method | CanHaveTypeAssigned()()()() | Identifies if the element can have a type assigned. (Inherited from Element.)
Public method | ChangeTypeId(ElementId) | Changes type of the element. (Inherited from Element.)
Public method | DeleteEntity | Deletes the existing entity created by %schema% in the element; (Inherited from Element.)
Public method | Dispose | (Inherited from Element.)
Public method | Duplicate | Duplicate this object. (Inherited from ElementType.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAnalyticalModel | Retrieves writeable Analytical Model for Element. (Inherited from Element.)
Public method | GetAnalyticalModelId | Retrieves the Element Id of the Analytical Model Element for this Element. (Inherited from Element.)
Public method | GetDividedSurfaceData | Get an interface to the divided surfaces on this element. (Inherited from Element.)
Public method | GetEntity | Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise. (Inherited from Element.)
Public method | GetExternalFileReference | Gets information pertaining to the external file referenced by the element. (Inherited from Element.)
Public method | GetFamilyPointLocations | Returns the Point Locations for the Family Symbol. (Inherited from FamilySymbol.)
Public method | GetGeneratingElementIds | Returns the ids of the element(s) that generated the input geometry object. (Inherited from Element.)
Public method | GetGeometryObjectFromReference | Retrieve one geometric primitive contained in the element given a reference. (Inherited from Element.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaterialArea | Get the area of the given material on this element. (Inherited from Element.)
Public method | GetMaterialVolume | Get the volume of the given material on this element. (Inherited from Element.)
Public method | GetMonitoredLinkElementIds | Provides the link instance IDs when the element is monitoring. (Inherited from Element.)
Public method | GetMonitoredLocalElementIds | Provides the local element IDs when the element is monitoring. (Inherited from Element.)
Public method | GetPhaseStatus | Gets the status of a given element in the input phase; (Inherited from Element.)
Public method | GetPreviewImage | Get the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element. (Inherited from ElementType.)
Public method | GetSimilarTypes | Obtains a set of types that are similar to this type. (Inherited from ElementType.)
Public method | GetThermalProperties | Returns the thermal properties. (Inherited from FamilySymbol.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeId | Returns the identifier of this element's type. (Inherited from Element.)
Public method | GetValidTypes()()()() | Obtains a set of types that are valid for this element. (Inherited from Element.)
Public method | HasPhases | Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId. (Inherited from Element.)
Public method | IsExternalFileReference | Determines whether this Element represents an external file. (Inherited from Element.)
Public method | IsHidden | Identifies if the element has been permanently hidden in the view. (Inherited from Element.)
Public method | IsMonitoringLinkElement | Indicate whether an element is monitoring any elements in any linked models. (Inherited from Element.)
Public method | IsMonitoringLocalElement | Indicate whether an element is monitoring other local elements. (Inherited from Element.)
Public method | IsPhaseCreatedValid | Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element. (Inherited from Element.)
Public method | IsPhaseDemolishedValid | Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element. (Inherited from Element.)
Public method | IsSimilarType | Checks if given type is similar to this type. (Inherited from ElementType.)
Public method | IsValidType(ElementId) | Checks if given type is valid for this element. (Inherited from Element.)
Public method | SetEntity | Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten. (Inherited from Element.)
Public method | SetThermalProperties | Set the thermal properties. (Inherited from FamilySymbol.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


TrussType Properties

[image] [image]

Revit 2013 API
TrussType Properties
TrussType Class See Also Send Feedback

The TrussType type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyInstanceId | The id of the assembly instance to which the element belongs. (Inherited from Element.)
Public property | BoundingBox | Retrieves a box that circumscribes all geometry of the element. (Inherited from Element.)
Public property | Category | Retrieves a Category object that represents the category or sub category in which the element resides. (Inherited from Element.)
Public property | CreatedPhaseId | Id of a Phase at which the Element was created. (Inherited from Element.)
Public property | DemolishedPhaseId | Id of a Phase at which the Element was demolished. (Inherited from Element.)
Public property | DesignOption | Returns the design option to which the element belongs. (Inherited from Element.)
Public property | Document | Returns the Document in which the Element resides. (Inherited from Element.)
Public property | Family | Returns the Family object to which the symbol belongs. (Inherited from FamilySymbol.)
Public property | Geometry | Retrieves the geometric representation of the element. (Inherited from Element.)
Public property | Group | Return to group to which an element belongs. If it is not in a group then this will return nullNothingnullptra null reference (Nothing in Visual Basic). (Inherited from Element.)
Public property | Id | Provides a way of uniquely identifying an Element within an Autodesk Revit project. (Inherited from Element.)
Public property | Level | If the element is level based then level to which the element is assigned is returned. (Inherited from Element.)
Public property | Location | This property is used to find the physical location of an element within a project. (Inherited from Element.)
Public property | Materials | Get all materials present in the element. (Inherited from Element.)
Public property | Name | Set the name for the ElementType. (Inherited from ElementType.)
Public property | OwnerViewId | The id of the view that owns the element. (Inherited from Element.)
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)
Public property | Parameters | Retrieves a set containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | ParametersMap | Retrieves a map containing all of the parameters that are contained within the element. (Inherited from Element.)
Public property | PhaseCreated | Obsolete. An object representing the phase when the element is created. (Inherited from Element.)
Public property | PhaseDemolished | Obsolete. An object representing the phase for when the element is to be demolished. (Inherited from Element.)
Public property | Pinned | Identifies if the element has been pinned to prevent changes. (Inherited from Element.)
Public property | StructuralMaterialType | This property returns the physical material from which the type is made. (Inherited from FamilySymbol.)
Public property | UniqueId | A stable unique identifier for an element within the document. (Inherited from Element.)
Public property | ViewSpecific | Identifies if the element is owned by a view. (Inherited from Element.)
Public property | WorksetId | Get Id of the Workset which owns the element. (Inherited from Element.)

See Also

TrussType Class
Autodesk.Revit.DB.Structure Namespace


Parameter Property

[image] [image]

Revit 2013 API
TrussType..::..Parameter Property
TrussType Class See Also Send Feedback
Retrieves a parameter from the element given an identifier.

Overload List

 | Name | Description
Public property | Parameter[([( Guid])]) | Retrieves a parameter from the element given a GUID for a shared parameter. (Inherited from Element.)
Public property | Parameter[([( String])]) | Retrieves a parameter from the element given its name. (Inherited from Element.)
Public property | Parameter[([( BuiltInParameter])]) | Retrieves a parameter from the element given a parameter id. (Inherited from Element.)
Public property | Parameter[([( Definition])]) | Retrieves a parameter from the element based on its definition. (Inherited from Element.)

See Also

TrussType Class
TrussType Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Class

[image]

Revit 2013 API
TrussTypeSet Class
Members See Also Send Feedback
A set that contains Truss types.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class TrussTypeSet : APIObject,
    IEnumerable
Visual Basic
Public Class TrussTypeSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class TrussTypeSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..TrussTypeSet

See Also

TrussTypeSet Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Members

[image] [image]

Revit 2013 API
TrussTypeSet Members
TrussTypeSet Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSet type exposes the following members.

Constructors

 | Name | Description
Public method | TrussTypeSet | Initializes a new instance of the TrussTypeSet class

Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Constructor

[image]

Revit 2013 API
TrussTypeSet Constructor
TrussTypeSet Class See Also Send Feedback
Initializes a new instance of the TrussTypeSet class

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussTypeSet()
Visual Basic
Public Sub New
Visual C++
public:
TrussTypeSet()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Methods

[image] [image]

Revit 2013 API
TrussTypeSet Methods
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every Truss type from the set, rendering it empty.
Public method | Contains | Tests for the existence of a Truss type within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified Truss type from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified Truss type into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Clear Method

[image]

Revit 2013 API
TrussTypeSet..::..Clear Method
TrussTypeSet Class See Also Send Feedback
Removes every Truss type from the set, rendering it empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Contains Method

[image]

Revit 2013 API
TrussTypeSet..::..Contains Method
TrussTypeSet Class See Also Send Feedback
Tests for the existence of a Truss type within the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    TrussType item
)
Visual Basic
Public Overridable Function Contains ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Contains(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..TrussType
The Truss type to be searched for.

Return Value

The Contains method returns True if the Truss type is within the set, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Erase Method

[image]

Revit 2013 API
TrussTypeSet..::..Erase Method
TrussTypeSet Class See Also Send Feedback
Removes a specified Truss type from the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    TrussType item
)
Visual Basic
Public Overridable Function Erase ( _
    item As TrussType _
) As Integer
Visual C++
public:
virtual int Erase(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..TrussType
The Truss type to be erased.

Return Value

The number of Truss types that were erased from the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ForwardIterator Method

[image]

Revit 2013 API
TrussTypeSet..::..ForwardIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


GetEnumerator Method

[image]

Revit 2013 API
TrussTypeSet..::..GetEnumerator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Insert Method

[image]

Revit 2013 API
TrussTypeSet..::..Insert Method
TrussTypeSet Class See Also Send Feedback
Insert the specified Truss type into the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    TrussType item
)
Visual Basic
Public Overridable Function Insert ( _
    item As TrussType _
) As Boolean
Visual C++
public:
virtual bool Insert(
    TrussType^ item
)

Parameters

item
Type: Autodesk.Revit.DB.Structure..::..TrussType
The Truss type to be inserted into the set.

Return Value

Returns whether the Truss type was inserted into the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


ReverseIterator Method

[image]

Revit 2013 API
TrussTypeSet..::..ReverseIterator Method
TrussTypeSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual TrussTypeSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As TrussTypeSetIterator
Visual C++
public:
virtual TrussTypeSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSet Properties

[image] [image]

Revit 2013 API
TrussTypeSet Properties
TrussTypeSet Class See Also Send Feedback

The TrussTypeSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of Truss types that are in the set.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


IsEmpty Property

[image]

Revit 2013 API
TrussTypeSet..::..IsEmpty Property
TrussTypeSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


Size Property

[image]

Revit 2013 API
TrussTypeSet..::..Size Property
TrussTypeSet Class See Also Send Feedback
Returns the number of Truss types that are in the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

TrussTypeSet Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Class

[image]

Revit 2013 API
TrussTypeSetIterator Class
Members See Also Send Feedback
An iterator to a Truss type set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class TrussTypeSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class TrussTypeSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class TrussTypeSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Structure..::..TrussTypeSetIterator

See Also

TrussTypeSetIterator Members
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Members

[image] [image]

Revit 2013 API
TrussTypeSetIterator Members
TrussTypeSetIterator Class Constructors Methods Properties See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | TrussTypeSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Constructor

[image]

Revit 2013 API
TrussTypeSetIterator Constructor
TrussTypeSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public TrussTypeSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
TrussTypeSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Methods

[image] [image]

Revit 2013 API
TrussTypeSetIterator Methods
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


MoveNext Method

[image]

Revit 2013 API
TrussTypeSetIterator..::..MoveNext Method
TrussTypeSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Reset Method

[image]

Revit 2013 API
TrussTypeSetIterator..::..Reset Method
TrussTypeSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


TrussTypeSetIterator Properties

[image] [image]

Revit 2013 API
TrussTypeSetIterator Properties
TrussTypeSetIterator Class See Also Send Feedback

The TrussTypeSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


Current Property

[image]

Revit 2013 API
TrussTypeSetIterator..::..Current Property
TrussTypeSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

TrussTypeSetIterator Class
Autodesk.Revit.DB.Structure Namespace


WireDistributionDirection Enumeration

[image]

Revit 2013 API
WireDistributionDirection Enumeration
See Also Send Feedback
Defines direction of distribution of wires in a Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum WireDistributionDirection
Visual Basic
Public Enumeration WireDistributionDirection
Visual C++
public enum class WireDistributionDirection

Members

Member name | Description
Major | Wires are distributed in the Major direction.
Minor | Wires are distributed in the Minor direction.

See Also

Autodesk.Revit.DB.Structure Namespace


Autodesk.Revit.Exceptions Namespace

[image]

Revit 2013 API
Autodesk.Revit.Exceptions Namespace
Send Feedback

Classes

 | Class | Description
Public class | ApplicationException | The exception that is thrown when a non-fatal application error occurs.
Public class | ArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.
Public class | ArgumentNullException | The exception that is thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed to a method that does not accept it as a valid argument.
Public class | ArgumentOutOfRangeException | The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.
Public class | ArgumentsInconsistentException | The exception that is thrown when each individual argument is OK, but a joint constraint is violated.
Public class | AutoJoinFailedException | The exception that is thrown when an autojoin operation failed.
Public class | DirectoryNotFoundException | The exception that is thrown when the specified directory could not be found.
Public class | DisabledDisciplineException | The exception that is thrown when the function cannot execute because a discipline is disabled. The exception specifies which discipline(s) would let the operation succeed.
Public class | ExternalApplicationException | The exception that is thrown when an issue in the Add-Ins resulted in an unexpected error.
Public class | FamilyContextException | The exception that is thrown when an operation is invalid in the current family document, because of the type of family.
Public class | FileAccessException | The exception that is thrown when the specified file could not be accessed, e.g. read-only, locked by the OS etc.
Public class | FileArgumentAlreadyExistsException | The exception that is thrown when the specified file exists.
Public class | FileArgumentNotFoundException | The exception that is thrown when a method received a filename as an argument and requires it to exist as a precondition.
Public class | FileNotFoundException | The exception that is thrown when the specified file could not be found.
Public class | ForbiddenForDynamicUpdateException | The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
Public class | FunctionId | The information of a function throwing an exception.
Public class | InapplicableDataException | The exception that is thrown when attempting to access a piece of data that is structurally not part of an object at the moment.
Public class | InternalException | The exception that is thrown when an issue in the Revit code resulted in an unexpected error.
Public class | InvalidDataStreamException | The exception that is thrown when the reading or saving operation failed due to parsing error.
Public class | InvalidLicenseException | The exception that is thrown when an operation is denied by the license manager, e.g. save from demo mode.
Public class | InvalidObjectException | The exception that is thrown when referencing an object that is no longer valid.
Public class | InvalidOperationException | The exception that is thrown when a method call is invalid for the object's current state.
Public class | InvalidPathArgumentException | The exception that is thrown when a method received a pathname as an argument, but the pathname is illegal: too long, invalid characters, etc.
Public class | IOException | The exception that is thrown when an I/O error occurs.
Public class | ModificationForbiddenException | The exception that is thrown by the undo transaction framework when a modification operation is not allowed.
Public class | ModificationOutsideTransactionException | The exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.
Public class | ObjectAccessException | The exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.
Public class | OperationCanceledException | The exception that is thrown when an operation is unexpectedly cancelled.
Public class | OptionalFunctionalityNotAvailableException | The exception that is thrown when the optional functionality is not available in the installed Revit
Public class | RegenerationFailedException | The exception that is thrown when a regeneration operation failed.
Public class | RevitServerCommunicationException | The exception that is thrown when there is any network communication error happening.
Public class | RevitServerException | The exception that is base class for all exceptions originating from the Revit server.
Public class | RevitServerInternalException | The exception that is thrown when there is any server internal error happening.
Public class | RevitServerModelContentionException | The exception that is thrown when the server-based source model is being accessed by other users.


ApplicationException Class

[image]

Revit 2013 API
ApplicationException Class
Members See Also Send Feedback
The exception that is thrown when a non-fatal application error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ApplicationException : Exception
Visual Basic
<SerializableAttribute> _
Public Class ApplicationException _
    Inherits Exception
Visual C++
[SerializableAttribute]
public ref class ApplicationException : public Exception

Remarks

This class is the base class of all Revit specified exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..ExternalApplicationException
Autodesk.Revit.Exceptions..::..InternalException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..OperationCanceledException
Autodesk.Revit.Exceptions..::..RevitServerException

See Also

ApplicationException Members
Autodesk.Revit.Exceptions Namespace


ApplicationException Members

[image] [image]

Revit 2013 API
ApplicationException Members
ApplicationException Class Methods Properties See Also Send Feedback

The ApplicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ApplicationException Methods

[image] [image]

Revit 2013 API
ApplicationException Methods
ApplicationException Class See Also Send Feedback

The ApplicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides Exception..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ApplicationException..::..GetObjectData Method
ApplicationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ApplicationException Properties

[image] [image]

Revit 2013 API
ApplicationException Properties
ApplicationException Class See Also Send Feedback

The ApplicationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


FunctionId Property

[image]

Revit 2013 API
ApplicationException..::..FunctionId Property
ApplicationException Class See Also Send Feedback
The information of the function throwing the exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public FunctionId FunctionId { get; }
Visual Basic
Public ReadOnly Property FunctionId As FunctionId
    Get
Visual C++
public:
property FunctionId^ FunctionId {
    FunctionId^ get ();
}

See Also

ApplicationException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Class

[image]

Revit 2013 API
ArgumentException Class
Members See Also Send Feedback
The exception that is thrown when one of the arguments provided to a method is not valid.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class ArgumentException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ArgumentException : public ApplicationException

Remarks

This is the base class for exceptions that are thrown while validating the arguments to a function.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..ArgumentNullException
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException
Autodesk.Revit.Exceptions..::..FileArgumentAlreadyExistsException
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException

See Also

ArgumentException Members
Autodesk.Revit.Exceptions Namespace


ArgumentException Members

[image] [image]

Revit 2013 API
ArgumentException Members
ArgumentException Class Methods Properties See Also Send Feedback

The ArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Overrides Exception..::..Message.)
Public property | ParamName | Gets the name of the parameter that causes this exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Methods

[image] [image]

Revit 2013 API
ArgumentException Methods
ArgumentException Class See Also Send Feedback

The ArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ArgumentException..::..GetObjectData Method
ArgumentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentException Properties

[image] [image]

Revit 2013 API
ArgumentException Properties
ArgumentException Class See Also Send Feedback

The ArgumentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Overrides Exception..::..Message.)
Public property | ParamName | Gets the name of the parameter that causes this exception.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


Message Property

[image]

Revit 2013 API
ArgumentException..::..Message Property
ArgumentException Class See Also Send Feedback
Gets the error message and the parameter name, or only the error message if no parameter name is set.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override string Message { get; }
Visual Basic
Public Overrides ReadOnly Property Message As String
    Get
Visual C++
public:
virtual property String^ Message {
    String^ get () override;
}

Implements

_Exception..::..Message

Remarks

The text of Message should completely describe the error and should, when possible, explain how to correct it.

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ParamName Property

[image]

Revit 2013 API
ArgumentException..::..ParamName Property
ArgumentException Class See Also Send Feedback
Gets the name of the parameter that causes this exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string ParamName { get; }
Visual Basic
Public ReadOnly Property ParamName As String
    Get
Visual C++
public:
property String^ ParamName {
    String^ get ();
}

See Also

ArgumentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Class

[image]

Revit 2013 API
ArgumentNullException Class
Members See Also Send Feedback
The exception that is thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed to a method that does not accept it as a valid argument.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentNullException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class ArgumentNullException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentNullException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..ArgumentNullException

See Also

ArgumentNullException Members
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Members

[image] [image]

Revit 2013 API
ArgumentNullException Members
ArgumentNullException Class Methods Properties See Also Send Feedback

The ArgumentNullException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Methods

[image] [image]

Revit 2013 API
ArgumentNullException Methods
ArgumentNullException Class See Also Send Feedback

The ArgumentNullException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ArgumentNullException..::..GetObjectData Method
ArgumentNullException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentNullException Properties

[image] [image]

Revit 2013 API
ArgumentNullException Properties
ArgumentNullException Class See Also Send Feedback

The ArgumentNullException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentNullException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Class

[image]

Revit 2013 API
ArgumentOutOfRangeException Class
Members See Also Send Feedback
The exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentOutOfRangeException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class ArgumentOutOfRangeException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentOutOfRangeException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException

See Also

ArgumentOutOfRangeException Members
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Members

[image] [image]

Revit 2013 API
ArgumentOutOfRangeException Members
ArgumentOutOfRangeException Class Methods Properties See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Methods

[image] [image]

Revit 2013 API
ArgumentOutOfRangeException Methods
ArgumentOutOfRangeException Class See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ArgumentOutOfRangeException..::..GetObjectData Method
ArgumentOutOfRangeException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentOutOfRangeException Properties

[image] [image]

Revit 2013 API
ArgumentOutOfRangeException Properties
ArgumentOutOfRangeException Class See Also Send Feedback

The ArgumentOutOfRangeException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentOutOfRangeException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Class

[image]

Revit 2013 API
ArgumentsInconsistentException Class
Members See Also Send Feedback
The exception that is thrown when each individual argument is OK, but a joint constraint is violated.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ArgumentsInconsistentException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class ArgumentsInconsistentException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class ArgumentsInconsistentException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException

See Also

ArgumentsInconsistentException Members
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Members

[image] [image]

Revit 2013 API
ArgumentsInconsistentException Members
ArgumentsInconsistentException Class Methods Properties See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Methods

[image] [image]

Revit 2013 API
ArgumentsInconsistentException Methods
ArgumentsInconsistentException Class See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ArgumentsInconsistentException..::..GetObjectData Method
ArgumentsInconsistentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


ArgumentsInconsistentException Properties

[image] [image]

Revit 2013 API
ArgumentsInconsistentException Properties
ArgumentsInconsistentException Class See Also Send Feedback

The ArgumentsInconsistentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ArgumentsInconsistentException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Class

[image]

Revit 2013 API
AutoJoinFailedException Class
Members See Also Send Feedback
The exception that is thrown when an autojoin operation failed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class AutoJoinFailedException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class AutoJoinFailedException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class AutoJoinFailedException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..AutoJoinFailedException

See Also

AutoJoinFailedException Members
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Members

[image] [image]

Revit 2013 API
AutoJoinFailedException Members
AutoJoinFailedException Class Methods Properties See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Methods

[image] [image]

Revit 2013 API
AutoJoinFailedException Methods
AutoJoinFailedException Class See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
AutoJoinFailedException..::..GetObjectData Method
AutoJoinFailedException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


AutoJoinFailedException Properties

[image] [image]

Revit 2013 API
AutoJoinFailedException Properties
AutoJoinFailedException Class See Also Send Feedback

The AutoJoinFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

AutoJoinFailedException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Class

[image]

Revit 2013 API
DirectoryNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the specified directory could not be found.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class DirectoryNotFoundException : IOException
Visual Basic
<SerializableAttribute> _
Public Class DirectoryNotFoundException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class DirectoryNotFoundException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException

See Also

DirectoryNotFoundException Members
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Members

[image] [image]

Revit 2013 API
DirectoryNotFoundException Members
DirectoryNotFoundException Class Methods Properties See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Methods

[image] [image]

Revit 2013 API
DirectoryNotFoundException Methods
DirectoryNotFoundException Class See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
DirectoryNotFoundException..::..GetObjectData Method
DirectoryNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


DirectoryNotFoundException Properties

[image] [image]

Revit 2013 API
DirectoryNotFoundException Properties
DirectoryNotFoundException Class See Also Send Feedback

The DirectoryNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DirectoryNotFoundException Class
Autodesk.Revit.Exceptions Namespace


DisabledDisciplineException Class

[image]

Revit 2013 API
DisabledDisciplineException Class
Members See Also Send Feedback
The exception that is thrown when the function cannot execute because a discipline is disabled. The exception specifies which discipline(s) would let the operation succeed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class DisabledDisciplineException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class DisabledDisciplineException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class DisabledDisciplineException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..DisabledDisciplineException

See Also

DisabledDisciplineException Members
Autodesk.Revit.Exceptions Namespace


DisabledDisciplineException Members

[image] [image]

Revit 2013 API
DisabledDisciplineException Members
DisabledDisciplineException Class Methods Properties See Also Send Feedback

The DisabledDisciplineException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DisabledDisciplineException Class
Autodesk.Revit.Exceptions Namespace


DisabledDisciplineException Methods

[image] [image]

Revit 2013 API
DisabledDisciplineException Methods
DisabledDisciplineException Class See Also Send Feedback

The DisabledDisciplineException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DisabledDisciplineException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
DisabledDisciplineException..::..GetObjectData Method
DisabledDisciplineException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

DisabledDisciplineException Class
Autodesk.Revit.Exceptions Namespace


DisabledDisciplineException Properties

[image] [image]

Revit 2013 API
DisabledDisciplineException Properties
DisabledDisciplineException Class See Also Send Feedback

The DisabledDisciplineException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DisabledDisciplineException Class
Autodesk.Revit.Exceptions Namespace


ExternalApplicationException Class

[image]

Revit 2013 API
ExternalApplicationException Class
Members See Also Send Feedback
The exception that is thrown when an issue in the Add-Ins resulted in an unexpected error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ExternalApplicationException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class ExternalApplicationException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class ExternalApplicationException : public ApplicationException

Remarks

Please contact your external application provider with the information about what led to this exception.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ExternalApplicationException

See Also

ExternalApplicationException Members
Autodesk.Revit.Exceptions Namespace


ExternalApplicationException Members

[image] [image]

Revit 2013 API
ExternalApplicationException Members
ExternalApplicationException Class Methods Properties See Also Send Feedback

The ExternalApplicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExternalApplicationException Class
Autodesk.Revit.Exceptions Namespace


ExternalApplicationException Methods

[image] [image]

Revit 2013 API
ExternalApplicationException Methods
ExternalApplicationException Class See Also Send Feedback

The ExternalApplicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ExternalApplicationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ExternalApplicationException..::..GetObjectData Method
ExternalApplicationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ExternalApplicationException Class
Autodesk.Revit.Exceptions Namespace


ExternalApplicationException Properties

[image] [image]

Revit 2013 API
ExternalApplicationException Properties
ExternalApplicationException Class See Also Send Feedback

The ExternalApplicationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ExternalApplicationException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Class

[image]

Revit 2013 API
FamilyContextException Class
Members See Also Send Feedback
The exception that is thrown when an operation is invalid in the current family document, because of the type of family.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FamilyContextException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class FamilyContextException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class FamilyContextException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..FamilyContextException

See Also

FamilyContextException Members
Autodesk.Revit.Exceptions Namespace


FamilyContextException Members

[image] [image]

Revit 2013 API
FamilyContextException Members
FamilyContextException Class Methods Properties See Also Send Feedback

The FamilyContextException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Methods

[image] [image]

Revit 2013 API
FamilyContextException Methods
FamilyContextException Class See Also Send Feedback

The FamilyContextException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FamilyContextException..::..GetObjectData Method
FamilyContextException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FamilyContextException Properties

[image] [image]

Revit 2013 API
FamilyContextException Properties
FamilyContextException Class See Also Send Feedback

The FamilyContextException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FamilyContextException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Class

[image]

Revit 2013 API
FileAccessException Class
Members See Also Send Feedback
The exception that is thrown when the specified file could not be accessed, e.g. read-only, locked by the OS etc.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileAccessException : IOException
Visual Basic
<SerializableAttribute> _
Public Class FileAccessException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class FileAccessException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..FileAccessException

See Also

FileAccessException Members
Autodesk.Revit.Exceptions Namespace


FileAccessException Members

[image] [image]

Revit 2013 API
FileAccessException Members
FileAccessException Class Methods Properties See Also Send Feedback

The FileAccessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Methods

[image] [image]

Revit 2013 API
FileAccessException Methods
FileAccessException Class See Also Send Feedback

The FileAccessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FileAccessException..::..GetObjectData Method
FileAccessException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileAccessException Properties

[image] [image]

Revit 2013 API
FileAccessException Properties
FileAccessException Class See Also Send Feedback

The FileAccessException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileAccessException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentAlreadyExistsException Class

[image]

Revit 2013 API
FileArgumentAlreadyExistsException Class
Members See Also Send Feedback
The exception that is thrown when the specified file exists.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileArgumentAlreadyExistsException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class FileArgumentAlreadyExistsException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class FileArgumentAlreadyExistsException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..FileArgumentAlreadyExistsException

See Also

FileArgumentAlreadyExistsException Members
Autodesk.Revit.Exceptions Namespace


FileArgumentAlreadyExistsException Members

[image] [image]

Revit 2013 API
FileArgumentAlreadyExistsException Members
FileArgumentAlreadyExistsException Class Methods Properties See Also Send Feedback

The FileArgumentAlreadyExistsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentAlreadyExistsException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentAlreadyExistsException Methods

[image] [image]

Revit 2013 API
FileArgumentAlreadyExistsException Methods
FileArgumentAlreadyExistsException Class See Also Send Feedback

The FileArgumentAlreadyExistsException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileArgumentAlreadyExistsException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FileArgumentAlreadyExistsException..::..GetObjectData Method
FileArgumentAlreadyExistsException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FileArgumentAlreadyExistsException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentAlreadyExistsException Properties

[image] [image]

Revit 2013 API
FileArgumentAlreadyExistsException Properties
FileArgumentAlreadyExistsException Class See Also Send Feedback

The FileArgumentAlreadyExistsException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentAlreadyExistsException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Class

[image]

Revit 2013 API
FileArgumentNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when a method received a filename as an argument and requires it to exist as a precondition.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileArgumentNotFoundException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class FileArgumentNotFoundException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class FileArgumentNotFoundException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException

See Also

FileArgumentNotFoundException Members
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Members

[image] [image]

Revit 2013 API
FileArgumentNotFoundException Members
FileArgumentNotFoundException Class Methods Properties See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Methods

[image] [image]

Revit 2013 API
FileArgumentNotFoundException Methods
FileArgumentNotFoundException Class See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FileArgumentNotFoundException..::..GetObjectData Method
FileArgumentNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileArgumentNotFoundException Properties

[image] [image]

Revit 2013 API
FileArgumentNotFoundException Properties
FileArgumentNotFoundException Class See Also Send Feedback

The FileArgumentNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileArgumentNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Class

[image]

Revit 2013 API
FileNotFoundException Class
Members See Also Send Feedback
The exception that is thrown when the specified file could not be found.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FileNotFoundException : IOException
Visual Basic
<SerializableAttribute> _
Public Class FileNotFoundException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class FileNotFoundException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..FileNotFoundException

See Also

FileNotFoundException Members
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Members

[image] [image]

Revit 2013 API
FileNotFoundException Members
FileNotFoundException Class Methods Properties See Also Send Feedback

The FileNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Methods

[image] [image]

Revit 2013 API
FileNotFoundException Methods
FileNotFoundException Class See Also Send Feedback

The FileNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FileNotFoundException..::..GetObjectData Method
FileNotFoundException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


FileNotFoundException Properties

[image] [image]

Revit 2013 API
FileNotFoundException Properties
FileNotFoundException Class See Also Send Feedback

The FileNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FileNotFoundException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Class

[image]

Revit 2013 API
ForbiddenForDynamicUpdateException Class
Members See Also Send Feedback
The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ForbiddenForDynamicUpdateException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class ForbiddenForDynamicUpdateException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ForbiddenForDynamicUpdateException : public InvalidOperationException

Remarks

Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException

See Also

ForbiddenForDynamicUpdateException Members
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Members

[image] [image]

Revit 2013 API
ForbiddenForDynamicUpdateException Members
ForbiddenForDynamicUpdateException Class Methods Properties See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Methods

[image] [image]

Revit 2013 API
ForbiddenForDynamicUpdateException Methods
ForbiddenForDynamicUpdateException Class See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ForbiddenForDynamicUpdateException..::..GetObjectData Method
ForbiddenForDynamicUpdateException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


ForbiddenForDynamicUpdateException Properties

[image] [image]

Revit 2013 API
ForbiddenForDynamicUpdateException Properties
ForbiddenForDynamicUpdateException Class See Also Send Feedback

The ForbiddenForDynamicUpdateException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ForbiddenForDynamicUpdateException Class
Autodesk.Revit.Exceptions Namespace


FunctionId Class

[image]

Revit 2013 API
FunctionId Class
Members See Also Send Feedback
The information of a function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class FunctionId : ISerializable
Visual Basic
<SerializableAttribute> _
Public Class FunctionId _
    Implements ISerializable
Visual C++
[SerializableAttribute]
public ref class FunctionId : ISerializable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.Exceptions..::..FunctionId

See Also

FunctionId Members
Autodesk.Revit.Exceptions Namespace


FunctionId Members

[image] [image]

Revit 2013 API
FunctionId Members
FunctionId Class Methods Properties See Also Send Feedback

The FunctionId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | File | The name of the file including the function throwing an exception.
Public property | Function | The name of the function throwing an exception.
Public property | Line | The line number of the function throwing an exception.

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


FunctionId Methods

[image] [image]

Revit 2013 API
FunctionId Methods
FunctionId Class See Also Send Feedback

The FunctionId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
FunctionId..::..GetObjectData Method
FunctionId Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


FunctionId Properties

[image] [image]

Revit 2013 API
FunctionId Properties
FunctionId Class See Also Send Feedback

The FunctionId type exposes the following members.

Properties

 | Name | Description
Public property | File | The name of the file including the function throwing an exception.
Public property | Function | The name of the function throwing an exception.
Public property | Line | The line number of the function throwing an exception.

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


File Property

[image]

Revit 2013 API
FunctionId..::..File Property
FunctionId Class See Also Send Feedback
The name of the file including the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string File { get; }
Visual Basic
Public ReadOnly Property File As String
    Get
Visual C++
public:
property String^ File {
    String^ get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


Function Property

[image]

Revit 2013 API
FunctionId..::..Function Property
FunctionId Class See Also Send Feedback
The name of the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Function { get; }
Visual Basic
Public ReadOnly Property Function As String
    Get
Visual C++
public:
property String^ Function {
    String^ get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


Line Property

[image]

Revit 2013 API
FunctionId..::..Line Property
FunctionId Class See Also Send Feedback
The line number of the function throwing an exception.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Line { get; }
Visual Basic
Public ReadOnly Property Line As Integer
    Get
Visual C++
public:
property int Line {
    int get ();
}

See Also

FunctionId Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Class

[image]

Revit 2013 API
InapplicableDataException Class
Members See Also Send Feedback
The exception that is thrown when attempting to access a piece of data that is structurally not part of an object at the moment.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InapplicableDataException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class InapplicableDataException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InapplicableDataException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..InapplicableDataException

See Also

InapplicableDataException Members
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Members

[image] [image]

Revit 2013 API
InapplicableDataException Members
InapplicableDataException Class Methods Properties See Also Send Feedback

The InapplicableDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Methods

[image] [image]

Revit 2013 API
InapplicableDataException Methods
InapplicableDataException Class See Also Send Feedback

The InapplicableDataException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InapplicableDataException..::..GetObjectData Method
InapplicableDataException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


InapplicableDataException Properties

[image] [image]

Revit 2013 API
InapplicableDataException Properties
InapplicableDataException Class See Also Send Feedback

The InapplicableDataException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InapplicableDataException Class
Autodesk.Revit.Exceptions Namespace


InternalException Class

[image]

Revit 2013 API
InternalException Class
Members See Also Send Feedback
The exception that is thrown when an issue in the Revit code resulted in an unexpected error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InternalException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class InternalException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InternalException : public ApplicationException

Remarks

Please contact Autodesk Developer Support with the information about what led to this exception.

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InternalException

See Also

InternalException Members
Autodesk.Revit.Exceptions Namespace


InternalException Members

[image] [image]

Revit 2013 API
InternalException Members
InternalException Class Methods Properties See Also Send Feedback

The InternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InternalException Methods

[image] [image]

Revit 2013 API
InternalException Methods
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InternalException..::..GetObjectData Method
InternalException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InternalException Properties

[image] [image]

Revit 2013 API
InternalException Properties
InternalException Class See Also Send Feedback

The InternalException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InternalException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Class

[image]

Revit 2013 API
InvalidDataStreamException Class
Members See Also Send Feedback
The exception that is thrown when the reading or saving operation failed due to parsing error.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidDataStreamException : IOException
Visual Basic
<SerializableAttribute> _
Public Class InvalidDataStreamException _
    Inherits IOException
Visual C++
[SerializableAttribute]
public ref class InvalidDataStreamException : public IOException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..InvalidDataStreamException

See Also

InvalidDataStreamException Members
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Members

[image] [image]

Revit 2013 API
InvalidDataStreamException Members
InvalidDataStreamException Class Methods Properties See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Methods

[image] [image]

Revit 2013 API
InvalidDataStreamException Methods
InvalidDataStreamException Class See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides IOException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InvalidDataStreamException..::..GetObjectData Method
InvalidDataStreamException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidDataStreamException Properties

[image] [image]

Revit 2013 API
InvalidDataStreamException Properties
InvalidDataStreamException Class See Also Send Feedback

The InvalidDataStreamException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDataStreamException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Class

[image]

Revit 2013 API
InvalidLicenseException Class
Members See Also Send Feedback
The exception that is thrown when an operation is denied by the license manager, e.g. save from demo mode.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidLicenseException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class InvalidLicenseException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidLicenseException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..InvalidLicenseException

See Also

InvalidLicenseException Members
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Members

[image] [image]

Revit 2013 API
InvalidLicenseException Members
InvalidLicenseException Class Methods Properties See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Methods

[image] [image]

Revit 2013 API
InvalidLicenseException Methods
InvalidLicenseException Class See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InvalidLicenseException..::..GetObjectData Method
InvalidLicenseException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidLicenseException Properties

[image] [image]

Revit 2013 API
InvalidLicenseException Properties
InvalidLicenseException Class See Also Send Feedback

The InvalidLicenseException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidLicenseException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Class

[image]

Revit 2013 API
InvalidObjectException Class
Members See Also Send Feedback
The exception that is thrown when referencing an object that is no longer valid.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidObjectException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class InvalidObjectException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class InvalidObjectException : public InvalidOperationException

Remarks

The object may no longer exist for many reasons:
  • The object was explicitly deleted from the database.
  • A change to other database items caused the item to be automatically deleted from the database.
  • The object no longer exists as its creation was undone (by rolling a transaction back).

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..InvalidObjectException

See Also

InvalidObjectException Members
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Members

[image] [image]

Revit 2013 API
InvalidObjectException Members
InvalidObjectException Class Methods Properties See Also Send Feedback

The InvalidObjectException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Methods

[image] [image]

Revit 2013 API
InvalidObjectException Methods
InvalidObjectException Class See Also Send Feedback

The InvalidObjectException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InvalidObjectException..::..GetObjectData Method
InvalidObjectException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidObjectException Properties

[image] [image]

Revit 2013 API
InvalidObjectException Properties
InvalidObjectException Class See Also Send Feedback

The InvalidObjectException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidObjectException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Class

[image]

Revit 2013 API
InvalidOperationException Class
Members See Also Send Feedback
The exception that is thrown when a method call is invalid for the object's current state.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidOperationException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class InvalidOperationException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class InvalidOperationException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..AutoJoinFailedException
Autodesk.Revit.Exceptions..::..DisabledDisciplineException
Autodesk.Revit.Exceptions..::..FamilyContextException
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException
Autodesk.Revit.Exceptions..::..InapplicableDataException
Autodesk.Revit.Exceptions..::..InvalidLicenseException
Autodesk.Revit.Exceptions..::..InvalidObjectException
Autodesk.Revit.Exceptions..::..ModificationForbiddenException
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException
Autodesk.Revit.Exceptions..::..ObjectAccessException
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException
Autodesk.Revit.Exceptions..::..RegenerationFailedException

See Also

InvalidOperationException Members
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Members

[image] [image]

Revit 2013 API
InvalidOperationException Members
InvalidOperationException Class Methods Properties See Also Send Feedback

The InvalidOperationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Methods

[image] [image]

Revit 2013 API
InvalidOperationException Methods
InvalidOperationException Class See Also Send Feedback

The InvalidOperationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InvalidOperationException..::..GetObjectData Method
InvalidOperationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidOperationException Properties

[image] [image]

Revit 2013 API
InvalidOperationException Properties
InvalidOperationException Class See Also Send Feedback

The InvalidOperationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidOperationException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Class

[image]

Revit 2013 API
InvalidPathArgumentException Class
Members See Also Send Feedback
The exception that is thrown when a method received a pathname as an argument, but the pathname is illegal: too long, invalid characters, etc.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class InvalidPathArgumentException : ArgumentException
Visual Basic
<SerializableAttribute> _
Public Class InvalidPathArgumentException _
    Inherits ArgumentException
Visual C++
[SerializableAttribute]
public ref class InvalidPathArgumentException : public ArgumentException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..ArgumentException
Autodesk.Revit.Exceptions..::..InvalidPathArgumentException

See Also

InvalidPathArgumentException Members
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Members

[image] [image]

Revit 2013 API
InvalidPathArgumentException Members
InvalidPathArgumentException Class Methods Properties See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Methods

[image] [image]

Revit 2013 API
InvalidPathArgumentException Methods
InvalidPathArgumentException Class See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ArgumentException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
InvalidPathArgumentException..::..GetObjectData Method
InvalidPathArgumentException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


InvalidPathArgumentException Properties

[image] [image]

Revit 2013 API
InvalidPathArgumentException Properties
InvalidPathArgumentException Class See Also Send Feedback

The InvalidPathArgumentException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets the error message and the parameter name, or only the error message if no parameter name is set. (Inherited from ArgumentException.)
Public property | ParamName | Gets the name of the parameter that causes this exception. (Inherited from ArgumentException.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidPathArgumentException Class
Autodesk.Revit.Exceptions Namespace


IOException Class

[image]

Revit 2013 API
IOException Class
Members See Also Send Feedback
The exception that is thrown when an I/O error occurs.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class IOException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class IOException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class IOException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..IOException
Autodesk.Revit.Exceptions..::..DirectoryNotFoundException
Autodesk.Revit.Exceptions..::..FileAccessException
Autodesk.Revit.Exceptions..::..FileNotFoundException
Autodesk.Revit.Exceptions..::..InvalidDataStreamException

See Also

IOException Members
Autodesk.Revit.Exceptions Namespace


IOException Members

[image] [image]

Revit 2013 API
IOException Members
IOException Class Methods Properties See Also Send Feedback

The IOException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


IOException Methods

[image] [image]

Revit 2013 API
IOException Methods
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
IOException..::..GetObjectData Method
IOException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


IOException Properties

[image] [image]

Revit 2013 API
IOException Properties
IOException Class See Also Send Feedback

The IOException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

IOException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Class

[image]

Revit 2013 API
ModificationForbiddenException Class
Members See Also Send Feedback
The exception that is thrown by the undo transaction framework when a modification operation is not allowed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationForbiddenException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class ModificationForbiddenException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationForbiddenException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..ModificationForbiddenException

See Also

ModificationForbiddenException Members
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Members

[image] [image]

Revit 2013 API
ModificationForbiddenException Members
ModificationForbiddenException Class Methods Properties See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Methods

[image] [image]

Revit 2013 API
ModificationForbiddenException Methods
ModificationForbiddenException Class See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ModificationForbiddenException..::..GetObjectData Method
ModificationForbiddenException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationForbiddenException Properties

[image] [image]

Revit 2013 API
ModificationForbiddenException Properties
ModificationForbiddenException Class See Also Send Feedback

The ModificationForbiddenException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationForbiddenException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Class

[image]

Revit 2013 API
ModificationOutsideTransactionException Class
Members See Also Send Feedback
The exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ModificationOutsideTransactionException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class ModificationOutsideTransactionException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ModificationOutsideTransactionException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException

See Also

ModificationOutsideTransactionException Members
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Members

[image] [image]

Revit 2013 API
ModificationOutsideTransactionException Members
ModificationOutsideTransactionException Class Methods Properties See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Methods

[image] [image]

Revit 2013 API
ModificationOutsideTransactionException Methods
ModificationOutsideTransactionException Class See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ModificationOutsideTransactionException..::..GetObjectData Method
ModificationOutsideTransactionException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ModificationOutsideTransactionException Properties

[image] [image]

Revit 2013 API
ModificationOutsideTransactionException Properties
ModificationOutsideTransactionException Class See Also Send Feedback

The ModificationOutsideTransactionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ModificationOutsideTransactionException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Class

[image]

Revit 2013 API
ObjectAccessException Class
Members See Also Send Feedback
The exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class ObjectAccessException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class ObjectAccessException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ObjectAccessException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..ObjectAccessException

See Also

ObjectAccessException Members
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Members

[image] [image]

Revit 2013 API
ObjectAccessException Members
ObjectAccessException Class Methods Properties See Also Send Feedback

The ObjectAccessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Methods

[image] [image]

Revit 2013 API
ObjectAccessException Methods
ObjectAccessException Class See Also Send Feedback

The ObjectAccessException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
ObjectAccessException..::..GetObjectData Method
ObjectAccessException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


ObjectAccessException Properties

[image] [image]

Revit 2013 API
ObjectAccessException Properties
ObjectAccessException Class See Also Send Feedback

The ObjectAccessException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ObjectAccessException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Class

[image]

Revit 2013 API
OperationCanceledException Class
Members See Also Send Feedback
The exception that is thrown when an operation is unexpectedly cancelled.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class OperationCanceledException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class OperationCanceledException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class OperationCanceledException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..OperationCanceledException

See Also

OperationCanceledException Members
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Members

[image] [image]

Revit 2013 API
OperationCanceledException Members
OperationCanceledException Class Methods Properties See Also Send Feedback

The OperationCanceledException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Methods

[image] [image]

Revit 2013 API
OperationCanceledException Methods
OperationCanceledException Class See Also Send Feedback

The OperationCanceledException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
OperationCanceledException..::..GetObjectData Method
OperationCanceledException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


OperationCanceledException Properties

[image] [image]

Revit 2013 API
OperationCanceledException Properties
OperationCanceledException Class See Also Send Feedback

The OperationCanceledException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OperationCanceledException Class
Autodesk.Revit.Exceptions Namespace


OptionalFunctionalityNotAvailableException Class

[image]

Revit 2013 API
OptionalFunctionalityNotAvailableException Class
Members See Also Send Feedback
The exception that is thrown when the optional functionality is not available in the installed Revit

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class OptionalFunctionalityNotAvailableException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class OptionalFunctionalityNotAvailableException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class OptionalFunctionalityNotAvailableException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..OptionalFunctionalityNotAvailableException

See Also

OptionalFunctionalityNotAvailableException Members
Autodesk.Revit.Exceptions Namespace


OptionalFunctionalityNotAvailableException Members

[image] [image]

Revit 2013 API
OptionalFunctionalityNotAvailableException Members
OptionalFunctionalityNotAvailableException Class Methods Properties See Also Send Feedback

The OptionalFunctionalityNotAvailableException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OptionalFunctionalityNotAvailableException Class
Autodesk.Revit.Exceptions Namespace


OptionalFunctionalityNotAvailableException Methods

[image] [image]

Revit 2013 API
OptionalFunctionalityNotAvailableException Methods
OptionalFunctionalityNotAvailableException Class See Also Send Feedback

The OptionalFunctionalityNotAvailableException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

OptionalFunctionalityNotAvailableException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
OptionalFunctionalityNotAvailableException..::..GetObjectData Method
OptionalFunctionalityNotAvailableException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

OptionalFunctionalityNotAvailableException Class
Autodesk.Revit.Exceptions Namespace


OptionalFunctionalityNotAvailableException Properties

[image] [image]

Revit 2013 API
OptionalFunctionalityNotAvailableException Properties
OptionalFunctionalityNotAvailableException Class See Also Send Feedback

The OptionalFunctionalityNotAvailableException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

OptionalFunctionalityNotAvailableException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Class

[image]

Revit 2013 API
RegenerationFailedException Class
Members See Also Send Feedback
The exception that is thrown when a regeneration operation failed.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RegenerationFailedException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class RegenerationFailedException _
    Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class RegenerationFailedException : public InvalidOperationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..InvalidOperationException
Autodesk.Revit.Exceptions..::..RegenerationFailedException

See Also

RegenerationFailedException Members
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Members

[image] [image]

Revit 2013 API
RegenerationFailedException Members
RegenerationFailedException Class Methods Properties See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Methods

[image] [image]

Revit 2013 API
RegenerationFailedException Methods
RegenerationFailedException Class See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
RegenerationFailedException..::..GetObjectData Method
RegenerationFailedException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


RegenerationFailedException Properties

[image] [image]

Revit 2013 API
RegenerationFailedException Properties
RegenerationFailedException Class See Also Send Feedback

The RegenerationFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RegenerationFailedException Class
Autodesk.Revit.Exceptions Namespace


RevitServerCommunicationException Class

[image]

Revit 2013 API
RevitServerCommunicationException Class
Members See Also Send Feedback
The exception that is thrown when there is any network communication error happening.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RevitServerCommunicationException : RevitServerException
Visual Basic
<SerializableAttribute> _
Public Class RevitServerCommunicationException _
    Inherits RevitServerException
Visual C++
[SerializableAttribute]
public ref class RevitServerCommunicationException : public RevitServerException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..RevitServerException
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException

See Also

RevitServerCommunicationException Members
Autodesk.Revit.Exceptions Namespace


RevitServerCommunicationException Members

[image] [image]

Revit 2013 API
RevitServerCommunicationException Members
RevitServerCommunicationException Class Methods Properties See Also Send Feedback

The RevitServerCommunicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerCommunicationException Class
Autodesk.Revit.Exceptions Namespace


RevitServerCommunicationException Methods

[image] [image]

Revit 2013 API
RevitServerCommunicationException Methods
RevitServerCommunicationException Class See Also Send Feedback

The RevitServerCommunicationException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RevitServerCommunicationException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
RevitServerCommunicationException..::..GetObjectData Method
RevitServerCommunicationException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

RevitServerCommunicationException Class
Autodesk.Revit.Exceptions Namespace


RevitServerCommunicationException Properties

[image] [image]

Revit 2013 API
RevitServerCommunicationException Properties
RevitServerCommunicationException Class See Also Send Feedback

The RevitServerCommunicationException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerCommunicationException Class
Autodesk.Revit.Exceptions Namespace


RevitServerException Class

[image]

Revit 2013 API
RevitServerException Class
Members See Also Send Feedback
The exception that is base class for all exceptions originating from the Revit server.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RevitServerException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class RevitServerException _
    Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class RevitServerException : public ApplicationException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..RevitServerException
Autodesk.Revit.Exceptions..::..RevitServerCommunicationException
Autodesk.Revit.Exceptions..::..RevitServerInternalException
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException

See Also

RevitServerException Members
Autodesk.Revit.Exceptions Namespace


RevitServerException Members

[image] [image]

Revit 2013 API
RevitServerException Members
RevitServerException Class Methods Properties See Also Send Feedback

The RevitServerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerException Class
Autodesk.Revit.Exceptions Namespace


RevitServerException Methods

[image] [image]

Revit 2013 API
RevitServerException Methods
RevitServerException Class See Also Send Feedback

The RevitServerException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RevitServerException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
RevitServerException..::..GetObjectData Method
RevitServerException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

RevitServerException Class
Autodesk.Revit.Exceptions Namespace


RevitServerException Properties

[image] [image]

Revit 2013 API
RevitServerException Properties
RevitServerException Class See Also Send Feedback

The RevitServerException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerException Class
Autodesk.Revit.Exceptions Namespace


RevitServerInternalException Class

[image]

Revit 2013 API
RevitServerInternalException Class
Members See Also Send Feedback
The exception that is thrown when there is any server internal error happening.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RevitServerInternalException : RevitServerException
Visual Basic
<SerializableAttribute> _
Public Class RevitServerInternalException _
    Inherits RevitServerException
Visual C++
[SerializableAttribute]
public ref class RevitServerInternalException : public RevitServerException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..RevitServerException
Autodesk.Revit.Exceptions..::..RevitServerInternalException

See Also

RevitServerInternalException Members
Autodesk.Revit.Exceptions Namespace


RevitServerInternalException Members

[image] [image]

Revit 2013 API
RevitServerInternalException Members
RevitServerInternalException Class Methods Properties See Also Send Feedback

The RevitServerInternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerInternalException Class
Autodesk.Revit.Exceptions Namespace


RevitServerInternalException Methods

[image] [image]

Revit 2013 API
RevitServerInternalException Methods
RevitServerInternalException Class See Also Send Feedback

The RevitServerInternalException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RevitServerInternalException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
RevitServerInternalException..::..GetObjectData Method
RevitServerInternalException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

RevitServerInternalException Class
Autodesk.Revit.Exceptions Namespace


RevitServerInternalException Properties

[image] [image]

Revit 2013 API
RevitServerInternalException Properties
RevitServerInternalException Class See Also Send Feedback

The RevitServerInternalException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerInternalException Class
Autodesk.Revit.Exceptions Namespace


RevitServerModelContentionException Class

[image]

Revit 2013 API
RevitServerModelContentionException Class
Members See Also Send Feedback
The exception that is thrown when the server-based source model is being accessed by other users.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
[SerializableAttribute]
public class RevitServerModelContentionException : RevitServerException
Visual Basic
<SerializableAttribute> _
Public Class RevitServerModelContentionException _
    Inherits RevitServerException
Visual C++
[SerializableAttribute]
public ref class RevitServerModelContentionException : public RevitServerException

Inheritance Hierarchy

System..::..Object
System..::..Exception
Autodesk.Revit.Exceptions..::..ApplicationException
Autodesk.Revit.Exceptions..::..RevitServerException
Autodesk.Revit.Exceptions..::..RevitServerModelContentionException

See Also

RevitServerModelContentionException Members
Autodesk.Revit.Exceptions Namespace


RevitServerModelContentionException Members

[image] [image]

Revit 2013 API
RevitServerModelContentionException Members
RevitServerModelContentionException Class Methods Properties See Also Send Feedback

The RevitServerModelContentionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerModelContentionException Class
Autodesk.Revit.Exceptions Namespace


RevitServerModelContentionException Methods

[image] [image]

Revit 2013 API
RevitServerModelContentionException Methods
RevitServerModelContentionException Class See Also Send Feedback

The RevitServerModelContentionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Retrieves data needed to serialize the target object. (Overrides RevitServerException..::..GetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

RevitServerModelContentionException Class
Autodesk.Revit.Exceptions Namespace


GetObjectData Method

[image]

Revit 2013 API
RevitServerModelContentionException..::..GetObjectData Method
RevitServerModelContentionException Class See Also Send Feedback
Retrieves data needed to serialize the target object.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Visual Basic
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
Visual C++
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.Serialization..::..SerializationInfo
Data needed to serialize or deserialize the object.
context
Type: System.Runtime.Serialization..::..StreamingContext
The destination of the serialized stream.

Implements

ISerializable..::..GetObjectData(SerializationInfo, StreamingContext)
_Exception..::..GetObjectData(SerializationInfo, StreamingContext)

See Also

RevitServerModelContentionException Class
Autodesk.Revit.Exceptions Namespace


RevitServerModelContentionException Properties

[image] [image]

Revit 2013 API
RevitServerModelContentionException Properties
RevitServerModelContentionException Class See Also Send Feedback

The RevitServerModelContentionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | FunctionId | The information of the function throwing the exception. (Inherited from ApplicationException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

RevitServerModelContentionException Class
Autodesk.Revit.Exceptions Namespace


Autodesk.Revit.UI Namespace

[image]

Revit 2013 API
Autodesk.Revit.UI Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInCommandBinding | This object represents a binding between a Revit command and one or more handlers which override the behavior of the command in Revit.
Public class | ButtonData | Base class used to contain information necessary to construct a button in the Ribbon.
Public class | ComboBox | This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.
Public class | ComboBoxData | This class contains information necessary to construct a combo box in the Ribbon.
Public class | ComboBoxMember | This class represents an item in the drop-down list of a ComboBox.
Public class | ComboBoxMemberData | This class contains information necessary to construct a ComboBoxMember.
Public class | ContextualHelp | Contains the details for how Revit should allow invocation of contextual help for an item added by an application.
Public class | ExternalApplicationArray | An array that can contain any number of IExternalApplication objects.
Public class | ExternalApplicationArrayIterator | An iterator to an array of IExternalApplication objects..
Public class | ExternalCommandData | A class contains reference to Application and View which are needed by external command.
Public class | ExternalEvent | A class that represent an external event.
Public class | OpenOptionsForUI | This class contains options available for opening a document from disk via the method OpenAndActivateDocument.
Public class | PreviewControl | Presents a preview control to browse the Revit model.
Public class | PulldownButton | The PulldownButton object represents a button with a drop-down list on RibbonPanel.
Public class | PulldownButtonData | This class contains information necessary to construct a pulldown button in the Ribbon.
Public class | PushButton | The PushButton object represents an button on a RibbonPanel.
Public class | PushButtonData | This class contains information necessary to construct a push button in the Ribbon.
Public class | RadioButtonGroup | Represents a group of related buttons in the Ribbon.
Public class | RadioButtonGroupData | This class contains information necessary to construct a ribbon gallery in the Ribbon.
Public class | RevitCommandId | Represents a command id in Autodesk Revit.
Public class | RibbonButton | This class is the base class of PushButton and PulldownButton.
Public class | RibbonItem | The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.
Public class | RibbonItemData | Base class used to contain information necessary to construct a RibbonItem in the Ribbon.
Public class | RibbonPanel | Represents a panel added by an External Application or External Command into the Add-Ins tab.
Public class | SplitButton | The SplitButton object represents a button with a clickable button appearing above a pulldown.
Public class | SplitButtonData | This class contains information necessary to construct a split button in the Ribbon.
Public class | TabbedDialogExtension | Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.
Public class | TaskDialog | A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.
Public class | TextBox | The TextBox object represents text-based control that allows the user to enter text.
Public class | TextBoxData | This class contains information necessary to construct a text box in the Ribbon.
Public class | ToggleButton | The ToggleButton object represents a button that has been added to a RadioButtonGroup.
Public class | ToggleButtonData | This class contains information necessary to construct a toggle button in a RadioButtonGroup.
Public class | UIApplication | Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, and the active document.
Public class | UIControlledApplication | Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
Public class | UIDocument | An object that represents an Autodesk Revit project opened in the Revit user interface.
Public class | UIView | A class containing data about view windows in the Revit user interface.

Interfaces

 | Interface | Description
Public interface | IDropHandler | An interface to be executed when custom data is dragged and dropped onto the Revit user interface.
Public interface | IExternalApplication | An interface that supports addition of external applications to Revit.
Public interface | IExternalCommand | An interface that should be implemented to provide the implementation for a Revit add-in External Command.
Public interface | IExternalCommandAvailability | An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.
Public interface | IExternalEventHandler | An interface to be executed when an external event is raised.

Delegates

 | Delegate | Description
Public delegate | TabbedDialogAction | Delegate for tabbed dialog actions, such as OnOK, OnCancel and RestoreDefaults.

Enumerations

 | Enumeration | Description
Public enumeration | ContextualHelpType | Represents the contextual help type.
Public enumeration | DetachFromCentralOptionForUI | Options for workset detachment behavior.
Public enumeration | ExternalEventRequest | Represents the possible outcomes of a request for raising an external event.
Public enumeration | Result | Informs Autodesk Revit of the status of your application after execution.
Public enumeration | RibbonItemType | An enumerated type listing all the toolbar item styles.
Public enumeration | Tab | An enumerated type listing static tabs which support addition of panels via the API.
Public enumeration | TaskDialogCommandLinkId | Enum to specify the Id of CommandLink.
Public enumeration | TaskDialogCommonButtons | A enumerated type containing the standard buttons available for Task Dialogs.
Public enumeration | TaskDialogIcon | Standard icons to be used in the task dialog.
Public enumeration | TaskDialogResult | Enum to specify the task dialog result.


AddInCommandBinding Class

[image]

Revit 2013 API
AddInCommandBinding Class
Members See Also Send Feedback
This object represents a binding between a Revit command and one or more handlers which override the behavior of the command in Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class AddInCommandBinding
Visual Basic
Public Class AddInCommandBinding
Visual C++
public ref class AddInCommandBinding

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..AddInCommandBinding

See Also

AddInCommandBinding Members
Autodesk.Revit.UI Namespace


AddInCommandBinding Members

[image] [image]

Revit 2013 API
AddInCommandBinding Members
AddInCommandBinding Class Methods Properties Events See Also Send Feedback

The AddInCommandBinding type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RevitCommandId | The Revit command Id.

Events

 | Name | Description
Public event | CanExecute | Occurs when the command associated with this AddInCommandBinding initiates a check to determine whether the command can be executed on the command target.
Public event | Executed | Occurs when the command associated with this AddInCommandBinding executes.

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


AddInCommandBinding Methods

[image] [image]

Revit 2013 API
AddInCommandBinding Methods
AddInCommandBinding Class See Also Send Feedback

The AddInCommandBinding type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


AddInCommandBinding Properties

[image] [image]

Revit 2013 API
AddInCommandBinding Properties
AddInCommandBinding Class See Also Send Feedback

The AddInCommandBinding type exposes the following members.

Properties

 | Name | Description
Public property | RevitCommandId | The Revit command Id.

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


RevitCommandId Property

[image]

Revit 2013 API
AddInCommandBinding..::..RevitCommandId Property
AddInCommandBinding Class See Also Send Feedback
The Revit command Id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RevitCommandId RevitCommandId { get; }
Visual Basic
Public ReadOnly Property RevitCommandId As RevitCommandId
    Get
Visual C++
public:
property RevitCommandId^ RevitCommandId {
    RevitCommandId^ get ();
}

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


AddInCommandBinding Events

[image] [image]

Revit 2013 API
AddInCommandBinding Events
AddInCommandBinding Class See Also Send Feedback

The AddInCommandBinding type exposes the following members.

Events

 | Name | Description
Public event | CanExecute | Occurs when the command associated with this AddInCommandBinding initiates a check to determine whether the command can be executed on the command target.
Public event | Executed | Occurs when the command associated with this AddInCommandBinding executes.

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


CanExecute Event

[image]

Revit 2013 API
AddInCommandBinding..::..CanExecute Event
AddInCommandBinding Class See Also Send Feedback
Occurs when the command associated with this AddInCommandBinding initiates a check to determine whether the command can be executed on the command target.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<CanExecuteEventArgs> CanExecute
Visual Basic
Public Event CanExecute As EventHandler(Of CanExecuteEventArgs)
Visual C++
public:
 event EventHandler<CanExecuteEventArgs^>^ CanExecute {
    void add (EventHandler<CanExecuteEventArgs^>^ value);
    void remove (EventHandler<CanExecuteEventArgs^>^ value);
}

Remarks

This callback will be called by Revit's user interface any time there is a contextual change. Therefore, the callback must be fast and is not permitted to be blocking in any way.

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


Executed Event

[image]

Revit 2013 API
AddInCommandBinding..::..Executed Event
AddInCommandBinding Class See Also Send Feedback
Occurs when the command associated with this AddInCommandBinding executes.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<ExecutedEventArgs> Executed
Visual Basic
Public Event Executed As EventHandler(Of ExecutedEventArgs)
Visual C++
public:
 event EventHandler<ExecutedEventArgs^>^ Executed {
    void add (EventHandler<ExecutedEventArgs^>^ value);
    void remove (EventHandler<ExecutedEventArgs^>^ value);
}

See Also

AddInCommandBinding Class
Autodesk.Revit.UI Namespace


ButtonData Class

[image]

Revit 2013 API
ButtonData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ButtonData : RibbonItemData
Visual Basic
Public Class ButtonData _
    Inherits RibbonItemData
Visual C++
public ref class ButtonData : public RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..PulldownButtonData
Autodesk.Revit.UI..::..PushButtonData

See Also

ButtonData Members
Autodesk.Revit.UI Namespace


ButtonData Members

[image] [image]

Revit 2013 API
ButtonData Members
ButtonData Class Methods Properties See Also Send Feedback

The ButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Image | The image of the button.
Public property | LargeImage | The large image of the button.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ButtonData Methods

[image] [image]

Revit 2013 API
ButtonData Methods
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ButtonData Properties

[image] [image]

Revit 2013 API
ButtonData Properties
ButtonData Class See Also Send Feedback

The ButtonData type exposes the following members.

Properties

 | Name | Description
Public property | Image | The image of the button.
Public property | LargeImage | The large image of the button.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
ButtonData..::..Image Property
ButtonData Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set, or if it is promoted to the Quick Access Toolbar. The best size is 16 x 16 pixels; if larger, the image will NOT be adjusted to fit the toolbar button.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


LargeImage Property

[image]

Revit 2013 API
ButtonData..::..LargeImage Property
ButtonData Class See Also Send Feedback
The large image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic
Public Property LargeImage As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown on a push button added to a pulldown button. The best size is 32 x 32 pixels; if larger, the image will be adjusted to fit the button.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


Text Property

[image]

Revit 2013 API
ButtonData..::..Text Property
ButtonData Class See Also Send Feedback
The user-visible text of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ButtonData Class
Autodesk.Revit.UI Namespace


ComboBox Class

[image]

Revit 2013 API
ComboBox Class
Members See Also Send Feedback
This class represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ComboBox : RibbonItem
Visual Basic
Public Class ComboBox _
    Inherits RibbonItem
Visual C++
public ref class ComboBox : public RibbonItem

Remarks

The order of items shown in the ComboBox depends upon the order which they were added, unless the ComboBoxMembers have been assigned to groups. If the members have been assigned groups, they will be sorted to fall under their groups regardless of the order in which they were added. Use of this class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..ComboBox

See Also

ComboBox Members
Autodesk.Revit.UI Namespace


ComboBox Members

[image] [image]

Revit 2013 API
ComboBox Members
ComboBox Class Methods Properties Events See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new item to the ComboBox.
Public method | AddItems | Adds a new items to the ComboBox.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ComboBox member of the ComboBox.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image shown on the ComboBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

Events

 | Name | Description
Public event | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
Public event | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
Public event | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Methods

[image] [image]

Revit 2013 API
ComboBox Methods
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new item to the ComboBox.
Public method | AddItems | Adds a new items to the ComboBox.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2013 API
ComboBox..::..AddItem Method
ComboBox Class See Also Send Feedback
Adds a new item to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMember AddItem(
    ComboBoxMemberData memberData
)
Visual Basic
Public Function AddItem ( _
    memberData As ComboBoxMemberData _
) As ComboBoxMember
Visual C++
public:
ComboBoxMember^ AddItem(
    ComboBoxMemberData^ memberData
)

Parameters

memberData
Type: Autodesk.Revit.UI..::..ComboBoxMemberData
An object containing the data needed to construct the ComboBoxMember.

Return Value

The newly added ComboBoxMember.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when memberData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with memberData.Name already exists in the drop-down list.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddItems Method

[image]

Revit 2013 API
ComboBox..::..AddItems Method
ComboBox Class See Also Send Feedback
Adds a new items to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ComboBoxMember> AddItems(
    IList<ComboBoxMemberData> memberData
)
Visual Basic
Public Function AddItems ( _
    memberData As IList(Of ComboBoxMemberData) _
) As IList(Of ComboBoxMember)
Visual C++
public:
IList<ComboBoxMember^>^ AddItems(
    IList<ComboBoxMemberData^>^ memberData
)

Parameters

memberData
Type: System.Collections.Generic..::..IList<(Of <(<'ComboBoxMemberData>)>)>
An object list containing the data needed to construct the ComboBoxMember.

Return Value

The newly added ComboBoxMembers.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when memberData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with memberData.Name already exists in the drop-down list.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2013 API
ComboBox..::..AddSeparator Method
ComboBox Class See Also Send Feedback
Adds a separator to the drop-down list.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddSeparator()
Visual Basic
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator will be added below the last added member.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2013 API
ComboBox..::..GetItems Method
ComboBox Class See Also Send Feedback
Gets the copy of a collection of the ComboBoxMembers assigned to the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ComboBoxMember> GetItems()
Visual Basic
Public Function GetItems As IList(Of ComboBoxMember)
Visual C++
public:
IList<ComboBoxMember^>^ GetItems()

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Properties

[image] [image]

Revit 2013 API
ComboBox Properties
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ComboBox member of the ComboBox.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image shown on the ComboBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2013 API
ComboBox..::..Current Property
ComboBox Class See Also Send Feedback
Gets or sets the current checked ComboBox member of the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMember Current { get; set; }
Visual Basic
Public Property Current As ComboBoxMember
    Get
    Set
Visual C++
public:
property ComboBoxMember^ Current {
    ComboBoxMember^ get ();
    void set (ComboBoxMember^ value);
}

Remarks

The default value is the first ComboBox member added to the ComboBox.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when trying to set this property to a button not in this ComboBox.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
ComboBox..::..Image Property
ComboBox Class See Also Send Feedback
The image shown on the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBox Events

[image] [image]

Revit 2013 API
ComboBox Events
ComboBox Class See Also Send Feedback

The ComboBox type exposes the following members.

Events

 | Name | Description
Public event | CurrentChanged | Subscribe to this event to be notified when the current item of the ComboBox is changed.
Public event | DropDownClosed | Subscribe to this event to be notified when the drop-down of the ComboBox is closed.
Public event | DropDownOpened | Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


CurrentChanged Event

[image]

Revit 2013 API
ComboBox..::..CurrentChanged Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the current item of the ComboBox is changed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ComboBoxCurrentChangedEventArgs> CurrentChanged
Visual Basic
Public Event CurrentChanged As EventHandler(Of ComboBoxCurrentChangedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxCurrentChangedEventArgs^>^ CurrentChanged {
    void add (EventHandler<ComboBoxCurrentChangedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxCurrentChangedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


DropDownClosed Event

[image]

Revit 2013 API
ComboBox..::..DropDownClosed Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the drop-down of the ComboBox is closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ComboBoxDropDownClosedEventArgs> DropDownClosed
Visual Basic
Public Event DropDownClosed As EventHandler(Of ComboBoxDropDownClosedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxDropDownClosedEventArgs^>^ DropDownClosed {
    void add (EventHandler<ComboBoxDropDownClosedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxDropDownClosedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


DropDownOpened Event

[image]

Revit 2013 API
ComboBox..::..DropDownOpened Event
ComboBox Class See Also Send Feedback
Subscribe to this event to be notified when the drop-down of the ComboBox is opened.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ComboBoxDropDownOpenedEventArgs> DropDownOpened
Visual Basic
Public Event DropDownOpened As EventHandler(Of ComboBoxDropDownOpenedEventArgs)
Visual C++
public:
 event EventHandler<ComboBoxDropDownOpenedEventArgs^>^ DropDownOpened {
    void add (EventHandler<ComboBoxDropDownOpenedEventArgs^>^ value);
    void remove (EventHandler<ComboBoxDropDownOpenedEventArgs^>^ value);
}

See Also

ComboBox Class
Autodesk.Revit.UI Namespace


ComboBoxData Class

[image]

Revit 2013 API
ComboBoxData Class
Members See Also Send Feedback
This class contains information necessary to construct a combo box in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxData : RibbonItemData
Visual Basic
Public Class ComboBoxData _
    Inherits RibbonItemData
Visual C++
public ref class ComboBoxData : public RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ComboBoxData

See Also

ComboBoxData Members
Autodesk.Revit.UI Namespace


ComboBoxData Members

[image] [image]

Revit 2013 API
ComboBoxData Members
ComboBoxData Class Constructors Methods Properties See Also Send Feedback

The ComboBoxData type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxData | Constructs a new instance of ComboBoxData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Image | The image shown on the ComboBox.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Constructor

[image]

Revit 2013 API
ComboBoxData Constructor
ComboBoxData Class See Also Send Feedback
Constructs a new instance of ComboBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ComboBoxData(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
ComboBoxData(
    String^ name
)

Parameters

name
Type: System..::..String
The internal name of the ComboBoxMember.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for name.

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Methods

[image] [image]

Revit 2013 API
ComboBoxData Methods
ComboBoxData Class See Also Send Feedback

The ComboBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxData Properties

[image] [image]

Revit 2013 API
ComboBoxData Properties
ComboBoxData Class See Also Send Feedback

The ComboBoxData type exposes the following members.

Properties

 | Name | Description
Public property | Image | The image shown on the ComboBox.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
ComboBoxData..::..Image Property
ComboBoxData Class See Also Send Feedback
The image shown on the ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBoxData Class
Autodesk.Revit.UI Namespace


ComboBoxMember Class

[image]

Revit 2013 API
ComboBoxMember Class
Members See Also Send Feedback
This class represents an item in the drop-down list of a ComboBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxMember : RibbonItem
Visual Basic
Public Class ComboBoxMember _
    Inherits RibbonItem
Visual C++
public ref class ComboBoxMember : public RibbonItem

Remarks

Note that a ComboBoxMember will not show an individual tool tip. Use of this class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..ComboBoxMember

See Also

ComboBoxMember Members
Autodesk.Revit.UI Namespace


ComboBoxMember Members

[image] [image]

Revit 2013 API
ComboBoxMember Members
ComboBoxMember Class Methods Properties See Also Send Feedback

The ComboBoxMember type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | GroupName | The group to which the ComboBoxMember is assigned.
Public property | Image | The image shown on the ComboBoxMember.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMember Methods

[image] [image]

Revit 2013 API
ComboBoxMember Methods
ComboBoxMember Class See Also Send Feedback

The ComboBoxMember type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMember Properties

[image] [image]

Revit 2013 API
ComboBoxMember Properties
ComboBoxMember Class See Also Send Feedback

The ComboBoxMember type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | GroupName | The group to which the ComboBoxMember is assigned.
Public property | Image | The image shown on the ComboBoxMember.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


GroupName Property

[image]

Revit 2013 API
ComboBoxMember..::..GroupName Property
ComboBoxMember Class See Also Send Feedback
The group to which the ComboBoxMember is assigned.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GroupName { get; }
Visual Basic
Public ReadOnly Property GroupName As String
    Get
Visual C++
public:
property String^ GroupName {
    String^ get ();
}

Remarks

If set, the ComboBoxMember appears under a group header in the ComboBox. If nullNothingnullptra null reference (Nothing in Visual Basic), the ComboBoxMember is not a member of any group. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
ComboBoxMember..::..Image Property
ComboBoxMember Class See Also Send Feedback
The image shown on the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

ComboBoxMember Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Class

[image]

Revit 2013 API
ComboBoxMemberData Class
Members See Also Send Feedback
This class contains information necessary to construct a ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ComboBoxMemberData : RibbonItemData
Visual Basic
Public Class ComboBoxMemberData _
    Inherits RibbonItemData
Visual C++
public ref class ComboBoxMemberData : public RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ComboBoxMemberData

See Also

ComboBoxMemberData Members
Autodesk.Revit.UI Namespace


ComboBoxMemberData Members

[image] [image]

Revit 2013 API
ComboBoxMemberData Members
ComboBoxMemberData Class Constructors Methods Properties See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxMemberData | Constructs a new instance of ComboBoxMemberData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | GroupName | Gets or sets a group name for the ComboBoxMember.
Public property | Image | The image shown on the ComboBoxMember.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the ComboBoxMember.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Constructor

[image]

Revit 2013 API
ComboBoxMemberData Constructor
ComboBoxMemberData Class See Also Send Feedback
Constructs a new instance of ComboBoxMemberData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ComboBoxMemberData(
    string name,
    string text
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
ComboBoxMemberData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::..String
The internal name of the ComboBoxMember.
text
Type: System..::..String
The user visible text seen on the item.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Methods

[image] [image]

Revit 2013 API
ComboBoxMemberData Methods
ComboBoxMemberData Class See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ComboBoxMemberData Properties

[image] [image]

Revit 2013 API
ComboBoxMemberData Properties
ComboBoxMemberData Class See Also Send Feedback

The ComboBoxMemberData type exposes the following members.

Properties

 | Name | Description
Public property | GroupName | Gets or sets a group name for the ComboBoxMember.
Public property | Image | The image shown on the ComboBoxMember.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the ComboBoxMember.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


GroupName Property

[image]

Revit 2013 API
ComboBoxMemberData..::..GroupName Property
ComboBoxMemberData Class See Also Send Feedback
Gets or sets a group name for the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string GroupName { get; set; }
Visual Basic
Public Property GroupName As String
    Get
    Set
Visual C++
public:
property String^ GroupName {
    String^ get ();
    void set (String^ value);
}

Remarks

The GroupName is used to group the items and also appears in the group header. All ComboBoxMembers assigned to the same group will be grouped in the ComboBox. There will be a header that shows the name. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
ComboBoxMemberData..::..Image Property
ComboBoxMemberData Class See Also Send Feedback
The image shown on the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item when the item is added to a ComboBox. The best size is 16 x 16 pixels.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


Text Property

[image]

Revit 2013 API
ComboBoxMemberData..::..Text Property
ComboBoxMemberData Class See Also Send Feedback
The user-visible text of the ComboBoxMember.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string, or when the value contains invalid characters.

See Also

ComboBoxMemberData Class
Autodesk.Revit.UI Namespace


ContextualHelp Class

[image]

Revit 2013 API
ContextualHelp Class
Members See Also Send Feedback
Contains the details for how Revit should allow invocation of contextual help for an item added by an application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ContextualHelp
Visual Basic
Public Class ContextualHelp
Visual C++
public ref class ContextualHelp

Remarks

An instance of this class may be used to assign a contextual help location to any RibbonItem (through the RibbonItem.SetContextualHelp() method). It is also possible to use an instance of this class to launch the help path and topic at any time (this permits association of help topics with user interface components inside dialogs created by the add-in application).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..ContextualHelp

See Also

ContextualHelp Members
Autodesk.Revit.UI Namespace


ContextualHelp Members

[image] [image]

Revit 2013 API
ContextualHelp Members
ContextualHelp Class Constructors Methods Properties See Also Send Feedback

The ContextualHelp type exposes the following members.

Constructors

 | Name | Description
Public method | ContextualHelp | Constructs a contextual help object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Launch | Launches and displays the help topic specified by the contents of this ContextualHelp object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HelpPath | The context id, help URL, or help file path.
Public property | HelpTopicUrl | The help topic URL.
Public property | HelpType | The contextual help type.

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


ContextualHelp Constructor

[image]

Revit 2013 API
ContextualHelp Constructor
ContextualHelp Class See Also Send Feedback
Constructs a contextual help object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ContextualHelp(
    ContextualHelpType helpType,
    string helpPath
)
Visual Basic
Public Sub New ( _
    helpType As ContextualHelpType, _
    helpPath As String _
)
Visual C++
public:
ContextualHelp(
    ContextualHelpType helpType,
    String^ helpPath
)

Parameters

helpType
Type: Autodesk.Revit.UI..::..ContextualHelpType
The contextual help type.
helpPath
Type: System..::..String
The contextual help path.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the helpPath is null or empty.

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


ContextualHelp Methods

[image] [image]

Revit 2013 API
ContextualHelp Methods
ContextualHelp Class See Also Send Feedback

The ContextualHelp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Launch | Launches and displays the help topic specified by the contents of this ContextualHelp object.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


Launch Method

[image]

Revit 2013 API
ContextualHelp..::..Launch Method
ContextualHelp Class See Also Send Feedback
Launches and displays the help topic specified by the contents of this ContextualHelp object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void Launch()
Visual Basic
Public Sub Launch
Visual C++
public:
void Launch()

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


ContextualHelp Properties

[image] [image]

Revit 2013 API
ContextualHelp Properties
ContextualHelp Class See Also Send Feedback

The ContextualHelp type exposes the following members.

Properties

 | Name | Description
Public property | HelpPath | The context id, help URL, or help file path.
Public property | HelpTopicUrl | The help topic URL.
Public property | HelpType | The contextual help type.

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


HelpPath Property

[image]

Revit 2013 API
ContextualHelp..::..HelpPath Property
ContextualHelp Class See Also Send Feedback
The context id, help URL, or help file path.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string HelpPath { get; set; }
Visual Basic
Public Property HelpPath As String
    Get
    Set
Visual C++
public:
property String^ HelpPath {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the help path to null or empty.

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


HelpTopicUrl Property

[image]

Revit 2013 API
ContextualHelp..::..HelpTopicUrl Property
ContextualHelp Class See Also Send Feedback
The help topic URL.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string HelpTopicUrl { get; set; }
Visual Basic
Public Property HelpTopicUrl As String
    Get
    Set
Visual C++
public:
property String^ HelpTopicUrl {
    String^ get ();
    void set (String^ value);
}

Remarks

Applies only to objects of type ContextualHelpType.ChmFile. If empty or nullNothingnullptra null reference (Nothing in Visual Basic), the default page of the help file will be displayed.
Obtain the URL by:
  1. Open the chm file and go to the page you want to show.
  2. Right click on the page, and choose the Properties command.
  3. In the middle of properties page there is a property called: Address (URL). The end of the URL contains the topic URL used to open the help file to the correct page. Here is an example: mk:@MSITStore:C:\RevitAPI2013.chm::/WhatsNew.htm The help topic URL of this page is "WhatsNew.htm". Another example: mk:@MSITStore:C:\RevitAPI2013.chm::/html/329b02eb-5ee4-1715-2fbf-2cbbc0d3ff2a.htm The help topic URL of this page is "html/329b02eb-5ee4-1715-2fbf-2cbbc0d3ff2a.htm".

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


HelpType Property

[image]

Revit 2013 API
ContextualHelp..::..HelpType Property
ContextualHelp Class See Also Send Feedback
The contextual help type.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ContextualHelpType HelpType { get; set; }
Visual Basic
Public Property HelpType As ContextualHelpType
    Get
    Set
Visual C++
public:
property ContextualHelpType HelpType {
    ContextualHelpType get ();
    void set (ContextualHelpType value);
}

See Also

ContextualHelp Class
Autodesk.Revit.UI Namespace


ContextualHelpType Enumeration

[image]

Revit 2013 API
ContextualHelpType Enumeration
See Also Send Feedback
Represents the contextual help type.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum ContextualHelpType
Visual Basic
Public Enumeration ContextualHelpType
Visual C++
public enum class ContextualHelpType

Members

Member name | Description
None | None.
ContextId | Represents an Autodesk help context id, which will automatically be mapped to a URL in the Revit help system.
Url | Represents an arbitrary URL. When users invoke help for this item, Revit will load this URL into the user's default browser.
ChmFile | Represents the path to a file on disk. When users invoke help for this item, Revit will launch this file.

See Also

Autodesk.Revit.UI Namespace


DetachFromCentralOptionForUI Enumeration

[image]

Revit 2013 API
DetachFromCentralOptionForUI Enumeration
See Also Send Feedback
Options for workset detachment behavior.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public enum DetachFromCentralOptionForUI
Visual Basic
Public Enumeration DetachFromCentralOptionForUI
Visual C++
public enum class DetachFromCentralOptionForUI

Members

Member name | Description
DoNotDetach | Do not detach the file being opened from its central file.
DetachAndPreserveWorksets | Detach the file being opened from its central file and preserve worksets.
DetachAndPrompt | Detach the file being opened from its central file and prompt the user to preserve or discard worksets.

See Also

Autodesk.Revit.UI Namespace


ExternalApplicationArray Class

[image]

Revit 2013 API
ExternalApplicationArray Class
Members See Also Send Feedback
An array that can contain any number of IExternalApplication objects.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExternalApplicationArray : APIObject,
    IEnumerable
Visual Basic
Public Class ExternalApplicationArray _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class ExternalApplicationArray : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI..::..ExternalApplicationArray

See Also

ExternalApplicationArray Members
Autodesk.Revit.UI Namespace


ExternalApplicationArray Members

[image] [image]

Revit 2013 API
ExternalApplicationArray Members
ExternalApplicationArray Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalApplicationArray | Initializes a new instance of the ExternalApplicationArray class

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Constructor

[image]

Revit 2013 API
ExternalApplicationArray Constructor
ExternalApplicationArray Class See Also Send Feedback
Initializes a new instance of the ExternalApplicationArray class

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ExternalApplicationArray()
Visual Basic
Public Sub New
Visual C++
public:
ExternalApplicationArray()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Methods

[image] [image]

Revit 2013 API
ExternalApplicationArray Methods
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Methods

 | Name | Description
Public method | Append | Add the item to the end of the array.
Public method | Clear | Removes every item from the array, rendering it empty.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ForwardIterator | Retrieve a forward moving iterator to the array.
Public method | GetEnumerator | Retrieve a forward moving iterator to the array.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified item into the array.
Public method | ReverseIterator | Retrieve a backward moving iterator to the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Append Method

[image]

Revit 2013 API
ExternalApplicationArray..::..Append Method
ExternalApplicationArray Class See Also Send Feedback
Add the item to the end of the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Append(
    IExternalApplication item
)
Visual Basic
Public Overridable Sub Append ( _
    item As IExternalApplication _
)
Visual C++
public:
virtual void Append(
    IExternalApplication^ item
)

Parameters

item
Type: Autodesk.Revit.UI..::..IExternalApplication
The item to be added.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Clear Method

[image]

Revit 2013 API
ExternalApplicationArray..::..Clear Method
ExternalApplicationArray Class See Also Send Feedback
Removes every item from the array, rendering it empty.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ForwardIterator Method

[image]

Revit 2013 API
ExternalApplicationArray..::..ForwardIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


GetEnumerator Method

[image]

Revit 2013 API
ExternalApplicationArray..::..GetEnumerator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a forward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the array.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Insert Method

[image]

Revit 2013 API
ExternalApplicationArray..::..Insert Method
ExternalApplicationArray Class See Also Send Feedback
Insert the specified item into the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Insert(
    IExternalApplication item,
    int index
)
Visual Basic
Public Overridable Sub Insert ( _
    item As IExternalApplication, _
    index As Integer _
)
Visual C++
public:
virtual void Insert(
    IExternalApplication^ item,
    int index
)

Parameters

item
Type: Autodesk.Revit.UI..::..IExternalApplication
The item to be inserted into the array.
index
Type: System..::..Int32
The item will be inserted before this index.

Return Value

Returns whether the item was inserted into the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ReverseIterator Method

[image]

Revit 2013 API
ExternalApplicationArray..::..ReverseIterator Method
ExternalApplicationArray Class See Also Send Feedback
Retrieve a backward moving iterator to the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ExternalApplicationArrayIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As ExternalApplicationArrayIterator
Visual C++
public:
virtual ExternalApplicationArrayIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArray Properties

[image] [image]

Revit 2013 API
ExternalApplicationArray Properties
ExternalApplicationArray Class See Also Send Feedback

The ExternalApplicationArray type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the array is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item | Gets or sets an item at a specified index within the array.
Public property | Size | Returns the number of objects that are in the array.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


IsEmpty Property

[image]

Revit 2013 API
ExternalApplicationArray..::..IsEmpty Property
ExternalApplicationArray Class See Also Send Feedback
Test to see if the array is empty.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the array is empty then True will be returned, otherwise False.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Item Property

[image]

Revit 2013 API
ExternalApplicationArray..::..Item Property
ExternalApplicationArray Class See Also Send Feedback
Gets or sets an item at a specified index within the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IExternalApplication this[
    int index
] { get; set; }
Visual Basic
Public Overridable Property Item ( _
    index As Integer _
) As IExternalApplication
    Get
    Set
Visual C++
public:
virtual property IExternalApplication^ Item[int index] {
    IExternalApplication^ get (int index);
    void set (int index, IExternalApplication^ value);
}

Parameters

index
Type: System..::..Int32
The index of the item to be set or retrieved.

Return Value

Returns the object at the specified index.

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


Size Property

[image]

Revit 2013 API
ExternalApplicationArray..::..Size Property
ExternalApplicationArray Class See Also Send Feedback
Returns the number of objects that are in the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

ExternalApplicationArray Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Class

[image]

Revit 2013 API
ExternalApplicationArrayIterator Class
Members See Also Send Feedback
An iterator to an array of IExternalApplication objects..

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ExternalApplicationArrayIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class ExternalApplicationArrayIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class ExternalApplicationArrayIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI..::..ExternalApplicationArrayIterator

See Also

ExternalApplicationArrayIterator Members
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Members

[image] [image]

Revit 2013 API
ExternalApplicationArrayIterator Members
ExternalApplicationArrayIterator Class Constructors Methods Properties See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Constructors

 | Name | Description
Public method | ExternalApplicationArrayIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Constructor

[image]

Revit 2013 API
ExternalApplicationArrayIterator Constructor
ExternalApplicationArrayIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ExternalApplicationArrayIterator()
Visual Basic
Public Sub New
Visual C++
public:
ExternalApplicationArrayIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Methods

[image] [image]

Revit 2013 API
ExternalApplicationArrayIterator Methods
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the array.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


MoveNext Method

[image]

Revit 2013 API
ExternalApplicationArrayIterator..::..MoveNext Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the array.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


Reset Method

[image]

Revit 2013 API
ExternalApplicationArrayIterator..::..Reset Method
ExternalApplicationArrayIterator Class See Also Send Feedback
Bring the iterator back to the start of the array.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the array in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalApplicationArrayIterator Properties

[image] [image]

Revit 2013 API
ExternalApplicationArrayIterator Properties
ExternalApplicationArrayIterator Class See Also Send Feedback

The ExternalApplicationArrayIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2013 API
ExternalApplicationArrayIterator..::..Current Property
ExternalApplicationArrayIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

ExternalApplicationArrayIterator Class
Autodesk.Revit.UI Namespace


ExternalCommandData Class

[image]

Revit 2013 API
ExternalCommandData Class
Members See Also Send Feedback
A class contains reference to Application and View which are needed by external command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ExternalCommandData : APIObject
Visual Basic
Public Class ExternalCommandData _
    Inherits APIObject
Visual C++
public ref class ExternalCommandData : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI..::..ExternalCommandData

See Also

ExternalCommandData Members
Autodesk.Revit.UI Namespace


ExternalCommandData Members

[image] [image]

Revit 2013 API
ExternalCommandData Members
ExternalCommandData Class Methods Properties See Also Send Feedback

The ExternalCommandData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | Retrieves an object that represents the current Application for external command.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JournalData | A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property | View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


ExternalCommandData Methods

[image] [image]

Revit 2013 API
ExternalCommandData Methods
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


ExternalCommandData Properties

[image] [image]

Revit 2013 API
ExternalCommandData Properties
ExternalCommandData Class See Also Send Feedback

The ExternalCommandData type exposes the following members.

Properties

 | Name | Description
Public property | Application | Retrieves an object that represents the current Application for external command.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | JournalData | A data map that can be used to read and write data to the Autodesk Revit journal file.
Public property | View | Retrieves an object that represents the View external command work on.

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2013 API
ExternalCommandData..::..Application Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the current Application for external command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIApplication Application { get; set; }
Visual Basic
Public Property Application As UIApplication
    Get
    Set
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
    void set (UIApplication^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


JournalData Property

[image]

Revit 2013 API
ExternalCommandData..::..JournalData Property
ExternalCommandData Class Example See Also Send Feedback
A data map that can be used to read and write data to the Autodesk Revit journal file.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IDictionary<string, string> JournalData { get; set; }
Visual Basic
Public Property JournalData As IDictionary(Of String, String)
    Get
    Set
Visual C++
public:
property IDictionary<String^, String^>^ JournalData {
    IDictionary<String^, String^>^ get ();
    void set (IDictionary<String^, String^>^ value);
}

Remarks

The data map is a string to string map that can be used to store data in the Revit journal file at the end of execution of the external command. If the command is then executed from the journal file during playback this data is then passed to the external command in this Data property so the external command can execute with this passed data in a UI-less mode, hence providing non interactive journal playback for automated testing purposes. For more information on Revit's journaling features contact the Autodesk Developer Network.

Examples

CopyC#
void WriteJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.JournalData as Autodesk.Revit.Collections.StringStringMap;
    dataMap.Clear();

    // Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit");
    dataMap.Insert("Information", "This is an example.");
    dataMap.Insert("Greeting", "Hello Everyone.");
}

/// <summary>
/// This sample shows how to get data from journal file.
/// </summary>
void ReadJournalData(ExternalCommandData commandData)
{
    // Get the StringStringMap class which can write data into.
    Autodesk.Revit.Collections.StringStringMap dataMap = commandData.JournalData as Autodesk.Revit.Collections.StringStringMap;

    // Begin to get the support data.
    String prompt = "Name: " + dataMap.get_Item("Name");
    prompt += "\nInformation: " + dataMap.get_Item("Information");
    prompt += "\nGreeting: " + dataMap.get_Item("Greeting");

    TaskDialog.Show("Revit",prompt);
}
CopyVB.NET
Sub WriteJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data
    dataMap.Clear()

    ' Begin to add the support data
    dataMap.Insert("Name", "Autodesk.Revit")
    dataMap.Insert("Information", "This is an example.")
    dataMap.Insert("Greeting", "Hello Everyone.")
End Sub

' <summary>
' This sample shows how to get data from journal file.
' </summary>
Sub ReadJournalData(ByVal commandData As ExternalCommandData)
    ' Get the StringStringMap class which can write data into.
    Dim dataMap As Autodesk.Revit.Collections.StringStringMap = commandData.Data

    ' Begin to get the support data.
    Dim prompt As [String] = "Name: " + dataMap.Item("Name")
    prompt += vbLf & "Information: " + dataMap.Item("Information")
    prompt += vbLf & "Greeting: " + dataMap.Item("Greeting")

    TaskDialog.Show("Revit", prompt)
End Sub

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


View Property

[image]

Revit 2013 API
ExternalCommandData..::..View Property
ExternalCommandData Class See Also Send Feedback
Retrieves an object that represents the View external command work on.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View View { get; set; }
Visual Basic
Public Property View As View
    Get
    Set
Visual C++
public:
property View^ View {
    View^ get ();
    void set (View^ value);
}

See Also

ExternalCommandData Class
Autodesk.Revit.UI Namespace


ExternalEvent Class

[image]

Revit 2013 API
ExternalEvent Class
Members See Also Send Feedback
A class that represent an external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExternalEvent : IDisposable
Visual Basic
Public Class ExternalEvent _
    Implements IDisposable
Visual C++
public ref class ExternalEvent : IDisposable

Remarks

An instance if this class will be returned to an external event's owner upon the event's creation. The event's owner will use this instance to signal that his application needs to be called by Revit. Revit will periodically check if any of the events have been signaled (raised), and will execute all events that were signaled (raised) by calling the Execute method on the events' respective handlers.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..ExternalEvent

See Also

ExternalEvent Members
Autodesk.Revit.UI Namespace


ExternalEvent Members

[image] [image]

Revit 2013 API
ExternalEvent Members
ExternalEvent Class Methods Properties See Also Send Feedback

The ExternalEvent type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an instance of external event.
Public method | Dispose | Releases all resources used by the ExternalEvent
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Raise | Instructing Revit to raise (signal) the external event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsPending | Checking whether an event has been raised but not yet executed.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


ExternalEvent Methods

[image] [image]

Revit 2013 API
ExternalEvent Methods
ExternalEvent Class See Also Send Feedback

The ExternalEvent type exposes the following members.

Methods

 | Name | Description
 | Create | Creates an instance of external event.
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Raise | Instructing Revit to raise (signal) the external event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


Create Method

[image]

Revit 2013 API
ExternalEvent..::..Create Method
ExternalEvent Class See Also Send Feedback
Creates an instance of external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static ExternalEvent Create(
    IExternalEventHandler handler
)
Visual Basic
Public Shared Function Create ( _
    handler As IExternalEventHandler _
) As ExternalEvent
Visual C++
public:
static ExternalEvent^ Create(
    IExternalEventHandler^ handler
)

Parameters

handler
Type: Autodesk.Revit.UI..::..IExternalEventHandler
An instance of IExternalEventHandler which will execute the event.

Return Value

An instance of ExternalEvent class, which will be used to invoke the event

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
ExternalEvent..::..Dispose Method
ExternalEvent Class See Also Send Feedback
Releases all resources used by the ExternalEvent

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


Raise Method

[image]

Revit 2013 API
ExternalEvent..::..Raise Method
ExternalEvent Class See Also Send Feedback
Instructing Revit to raise (signal) the external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ExternalEventRequest Raise()
Visual Basic
Public Function Raise As ExternalEventRequest
Visual C++
public:
ExternalEventRequest Raise()

Return Value

The result of event raising request. If the request is 'Accepted', the event would be added to the event queue and its handler will be executed in the next event-processing cycle.

Remarks

Revit will wait until it is ready to process the event and then it will execute its event handler by calling the Execute method. Revit processes external events only when no other commands or edit modes are currently active in Revit, which is the same policy like the one that applies to evoking external commands.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


ExternalEvent Properties

[image] [image]

Revit 2013 API
ExternalEvent Properties
ExternalEvent Class See Also Send Feedback

The ExternalEvent type exposes the following members.

Properties

 | Name | Description
Public property | IsPending | Checking whether an event has been raised but not yet executed.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


IsPending Property

[image]

Revit 2013 API
ExternalEvent..::..IsPending Property
ExternalEvent Class See Also Send Feedback
Checking whether an event has been raised but not yet executed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool IsPending { get; }
Visual Basic
Public ReadOnly Property IsPending As Boolean
    Get
Visual C++
public:
property bool IsPending {
    bool get ();
}

Remarks

When en event is requested to raise it is not executed immediatelly; instead, it waits for the next possible opportunity, which is determined by various internal conditions in Revit (policy similar to invoking external commands). When the opportunity comes, the event is executed by calling the event's handler. In the meantime, the event is 'Pending'.

See Also

ExternalEvent Class
Autodesk.Revit.UI Namespace


ExternalEventRequest Enumeration

[image]

Revit 2013 API
ExternalEventRequest Enumeration
See Also Send Feedback
Represents the possible outcomes of a request for raising an external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ExternalEventRequest
Visual Basic
Public Enumeration ExternalEventRequest
Visual C++
public enum class ExternalEventRequest

Members

Member name | Description
Accepted | Request accepted; event was added into the event queue and will be executed momentarily.
Pending | Request not accepted, because the previous request is still pending (not executed).
Denied | Request was denied due to failures of the corresponding event handler.
TimedOut | Request not accepted due to synchronization issues with other thread(s).

See Also

Autodesk.Revit.UI Namespace


IDropHandler Interface

[image]

Revit 2013 API
IDropHandler Interface
Members See Also Send Feedback
An interface to be executed when custom data is dragged and dropped onto the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IDropHandler
Visual Basic
Public Interface IDropHandler
Visual C++
public interface class IDropHandler

Remarks

Custom data is supported for drag and drop only during an invocation of the DoDragDrop method on Application.

See Also

IDropHandler Members
Autodesk.Revit.UI Namespace


IDropHandler Members

[image] [image]

Revit 2013 API
IDropHandler Members
IDropHandler Interface Methods See Also Send Feedback

The IDropHandler type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to handle the drop event for your data.

See Also

IDropHandler Interface
Autodesk.Revit.UI Namespace


IDropHandler Methods

[image] [image]

Revit 2013 API
IDropHandler Methods
IDropHandler Interface See Also Send Feedback

The IDropHandler type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Implement this method to handle the drop event for your data.

See Also

IDropHandler Interface
Autodesk.Revit.UI Namespace


Execute Method

[image]

Revit 2013 API
IDropHandler..::..Execute Method
IDropHandler Interface See Also Send Feedback
Implement this method to handle the drop event for your data.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
void Execute(
    UIDocument document,
    Object data
)
Visual Basic
Sub Execute ( _
    document As UIDocument, _
    data As Object _
)
Visual C++
void Execute(
    UIDocument^ document,
    Object^ data
)

Parameters

document
Type: Autodesk.Revit.UI..::..UIDocument
The document on which the data was dropped.
data
Type: System..::..Object
The data.

See Also

IDropHandler Interface
Autodesk.Revit.UI Namespace


IExternalApplication Interface

[image]

Revit 2013 API
IExternalApplication Interface
Members See Also Send Feedback
An interface that supports addition of external applications to Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExternalApplication
Visual Basic
Public Interface IExternalApplication
Visual C++
public interface class IExternalApplication

Remarks

External applications are permitted to customize the Revit UI, and to add events and updaters to the session.

See Also

IExternalApplication Members
Autodesk.Revit.UI Namespace


IExternalApplication Members

[image] [image]

Revit 2013 API
IExternalApplication Members
IExternalApplication Interface Methods See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


IExternalApplication Methods

[image] [image]

Revit 2013 API
IExternalApplication Methods
IExternalApplication Interface See Also Send Feedback

The IExternalApplication type exposes the following members.

Methods

 | Name | Description
Public method | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down.
Public method | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


OnShutdown Method

[image]

Revit 2013 API
IExternalApplication..::..OnShutdown Method
IExternalApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit shuts down.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
Result OnShutdown(
    UIControlledApplication application
)
Visual Basic
Function OnShutdown ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnShutdown(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::..UIControlledApplication
A handle to the application being shut down.

Return Value

Indicates if the external application completes its work successfully.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


OnStartup Method

[image]

Revit 2013 API
IExternalApplication..::..OnStartup Method
IExternalApplication Interface See Also Send Feedback
Implement this method to execute some tasks when Autodesk Revit starts.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
Result OnStartup(
    UIControlledApplication application
)
Visual Basic
Function OnStartup ( _
    application As UIControlledApplication _
) As Result
Visual C++
Result OnStartup(
    UIControlledApplication^ application
)

Parameters

application
Type: Autodesk.Revit.UI..::..UIControlledApplication
A handle to the application being started.

Return Value

Indicates if the external application completes its work successfully.

See Also

IExternalApplication Interface
Autodesk.Revit.UI Namespace


IExternalCommand Interface

[image]

Revit 2013 API
IExternalCommand Interface
Members Example See Also Send Feedback
An interface that should be implemented to provide the implementation for a Revit add-in External Command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExternalCommand
Visual Basic
Public Interface IExternalCommand
Visual C++
public interface class IExternalCommand

Remarks

To add an external command to Autodesk Revit the developer should implement an object that supports the IExternalCommand interface.

Examples

CopyC#
public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
    ref string message, ElementSet elements)
{
    try
    {
        Document doc = commandData.Application.ActiveUIDocument.Document;
        UIDocument uidoc = commandData.Application.ActiveUIDocument;
        // Delete selected elements
        ICollection<Autodesk.Revit.DB.ElementId> ids =
            doc.Delete(uidoc.Selection.Elements);

        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent =
           ("Click Yes to return Succeeded. Selected members will be deleted.\n" +
           "Click No to return Failed.  Selected members will not be deleted.\n" +
           "Click Cancel to return Cancelled.  Selected members will not be deleted.");
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Yes |
            TaskDialogCommonButtons.No | TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult taskDialogResult = taskDialog.Show();

        if (taskDialogResult == TaskDialogResult.Yes)
        {
            return Autodesk.Revit.UI.Result.Succeeded;
        }
        else if (taskDialogResult == TaskDialogResult.No)
        {
            elements = uidoc.Selection.Elements;
            message = "Failed to delete selection.";
            return Autodesk.Revit.UI.Result.Failed;
        }
        else
        {
            return Autodesk.Revit.UI.Result.Cancelled;
        }
    }
    catch
    {
        message = "Unexpected Exception thrown.";
        return Autodesk.Revit.UI.Result.Failed;
    }

}
CopyVB.NET
Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result _
        Implements IExternalCommand.Execute
    Try
        Dim doc As Document = commandData.Application.ActiveUIDocument.Document
        Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument
        ' Delete selected elements
        Dim ids As ICollection(Of Autodesk.Revit.DB.ElementId) = doc.Delete(uidoc.Selection.Elements)

        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = ("Click Yes to return Succeeded. Selected members will be deleted." & vbLf + "Click No to return Failed.  Selected members will not be deleted." & vbLf + "Click Cancel to return Cancelled.  Selected members will not be deleted.")
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Yes Or TaskDialogCommonButtons.No Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim taskDialogResult As TaskDialogResult = taskDialog.Show()

        If taskDialogResult = taskDialogResult.Yes Then
            Return Autodesk.Revit.UI.Result.Succeeded
        ElseIf taskDialogResult = taskDialogResult.No Then
            elements = uidoc.Selection.Elements
            message = "Failed to delete selection."
            Return Autodesk.Revit.UI.Result.Failed
        Else
            Return Autodesk.Revit.UI.Result.Cancelled
        End If
    Catch
        message = "Unexpected Exception thrown."
        Return Autodesk.Revit.UI.Result.Failed
    End Try

End Function

See Also

IExternalCommand Members
Autodesk.Revit.UI Namespace


IExternalCommand Members

[image] [image]

Revit 2013 API
IExternalCommand Members
IExternalCommand Interface Methods See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


IExternalCommand Methods

[image] [image]

Revit 2013 API
IExternalCommand Methods
IExternalCommand Interface See Also Send Feedback

The IExternalCommand type exposes the following members.

Methods

 | Name | Description
Public method | Execute | Overload this method to implement and external command within Revit.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


Execute Method

[image]

Revit 2013 API
IExternalCommand..::..Execute Method
IExternalCommand Interface See Also Send Feedback
Overload this method to implement and external command within Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
Result Execute(
    ExternalCommandData commandData,
    out string message,
    ElementSet elements
)
Visual Basic
Function Execute ( _
    commandData As ExternalCommandData, _
    <OutAttribute> ByRef message As String, _
    <OutAttribute> elements As ElementSet _
) As Result
Visual C++
Result Execute(
    ExternalCommandData^ commandData,
    [InAttribute] [OutAttribute] String^% message,
    [InAttribute] [OutAttribute] ElementSet^ elements
)

Parameters

commandData
Type: Autodesk.Revit.UI..::..ExternalCommandData
An ExternalCommandData object which contains reference to Application and View needed by external command.
message
Type: System..::..String%
Error message can be returned by external command. This will be displayed only if the command status was "Failed". There is a limit of 1023 characters for this message; strings longer than this will be truncated.
elements
Type: Autodesk.Revit.DB..::..ElementSet
Element set indicating problem elements to display in the failure dialog. This will be used only if the command status was "Failed".

Return Value

The result indicates if the execution fails, succeeds, or was canceled by user. If it does not succeed, Revit will undo any changes made by the external command.

See Also

IExternalCommand Interface
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Interface

[image]

Revit 2013 API
IExternalCommandAvailability Interface
Members Example See Also Send Feedback
An interface that should be implemented to provide the implementation for a accessibility check for a Revit add-in External Command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IExternalCommandAvailability
Visual Basic
Public Interface IExternalCommandAvailability
Visual C++
public interface class IExternalCommandAvailability

Remarks

This interface should share the same assembly with add-in External Command.

Examples

CopyC#
public class SampleAccessibilityCheck : IExternalCommandAvailability
{
    public bool IsCommandAvailable(Autodesk.Revit.UI.UIApplication applicationData,
        CategorySet selectedCategories)
    {
        // Allow button click if there is no active selection
        if (selectedCategories.IsEmpty)
            return true;
        // Allow button click if there is at least one wall selected
        foreach (Category c in selectedCategories)
        {
            if (c.Id.IntegerValue == (int)BuiltInCategory.OST_Walls)
                return true;
        }
        return false;
    }
}
CopyVB.NET
Public Class SampleAccessibilityCheck
    Implements IExternalCommandAvailability
    Public Function IsCommandAvailable(ByVal applicationData As Autodesk.Revit.UI.UIApplication, _
                                       ByVal selectedCategories As CategorySet) As Boolean _
                                       Implements IExternalCommandAvailability.IsCommandAvailable
        ' Allow button click if there is no active selection
        If selectedCategories.IsEmpty Then
            Return True
        End If
        ' Allow button click if there is at least one wall selected
        For Each c As Category In selectedCategories
            If c.Id.IntegerValue = DirectCast(BuiltInCategory.OST_Walls, Integer) Then
                Return True
            End If
        Next
        Return False
    End Function
End Class

See Also

IExternalCommandAvailability Members
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Members

[image] [image]

Revit 2013 API
IExternalCommandAvailability Members
IExternalCommandAvailability Interface Methods See Also Send Feedback

The IExternalCommandAvailability type exposes the following members.

Methods

 | Name | Description
Public method | IsCommandAvailable | Implement this method to provide control over whether your external command is enabled or disabled.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


IExternalCommandAvailability Methods

[image] [image]

Revit 2013 API
IExternalCommandAvailability Methods
IExternalCommandAvailability Interface See Also Send Feedback

The IExternalCommandAvailability type exposes the following members.

Methods

 | Name | Description
Public method | IsCommandAvailable | Implement this method to provide control over whether your external command is enabled or disabled.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


IsCommandAvailable Method

[image]

Revit 2013 API
IExternalCommandAvailability..::..IsCommandAvailable Method
IExternalCommandAvailability Interface See Also Send Feedback
Implement this method to provide control over whether your external command is enabled or disabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
bool IsCommandAvailable(
    UIApplication applicationData,
    CategorySet selectedCategories
)
Visual Basic
Function IsCommandAvailable ( _
    applicationData As UIApplication, _
    selectedCategories As CategorySet _
) As Boolean
Visual C++
bool IsCommandAvailable(
    UIApplication^ applicationData,
    CategorySet^ selectedCategories
)

Parameters

applicationData
Type: Autodesk.Revit.UI..::..UIApplication
An ApplicationServices.Application object which contains reference to Application needed by external command.
selectedCategories
Type: Autodesk.Revit.DB..::..CategorySet
An list of categories of the elements which have been selected in Revit in the active document, or an empty set if no elements are selected or there is no active document.

Return Value

Indicates whether Revit should enable or disable the corresponding external command.

Remarks

This callback will be called by Revit's user interface any time there is a contextual change. Therefore, the callback must be fast and is not permitted to be blocking in any way.

See Also

IExternalCommandAvailability Interface
Autodesk.Revit.UI Namespace


IExternalEventHandler Interface

[image]

Revit 2013 API
IExternalEventHandler Interface
Members See Also Send Feedback
An interface to be executed when an external event is raised.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public interface IExternalEventHandler
Visual Basic
Public Interface IExternalEventHandler
Visual C++
public interface class IExternalEventHandler

Remarks

An instance of a class implementing this interface will be registered with Revit first, and every time the corresponding external event is raised, the Execute method of this interface will be invoked.

See Also

IExternalEventHandler Members
Autodesk.Revit.UI Namespace


IExternalEventHandler Members

[image] [image]

Revit 2013 API
IExternalEventHandler Members
IExternalEventHandler Interface Methods See Also Send Feedback

The IExternalEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Execute | This method is called to handle the external event.
Public method | GetName | String identification of the event handler.

See Also

IExternalEventHandler Interface
Autodesk.Revit.UI Namespace


IExternalEventHandler Methods

[image] [image]

Revit 2013 API
IExternalEventHandler Methods
IExternalEventHandler Interface See Also Send Feedback

The IExternalEventHandler type exposes the following members.

Methods

 | Name | Description
Public method | Execute | This method is called to handle the external event.
Public method | GetName | String identification of the event handler.

See Also

IExternalEventHandler Interface
Autodesk.Revit.UI Namespace


Execute Method

[image]

Revit 2013 API
IExternalEventHandler..::..Execute Method
IExternalEventHandler Interface See Also Send Feedback
This method is called to handle the external event.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
void Execute(
    UIApplication app
)
Visual Basic
Sub Execute ( _
    app As UIApplication _
)
Visual C++
void Execute(
    UIApplication^ app
)

Parameters

app
Type: Autodesk.Revit.UI..::..UIApplication

See Also

IExternalEventHandler Interface
Autodesk.Revit.UI Namespace


GetName Method

[image]

Revit 2013 API
IExternalEventHandler..::..GetName Method
IExternalEventHandler Interface See Also Send Feedback
String identification of the event handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
string GetName()
Visual Basic
Function GetName As String
Visual C++
String^ GetName()

Return Value

The event's name

See Also

IExternalEventHandler Interface
Autodesk.Revit.UI Namespace


OpenOptionsForUI Class

[image]

Revit 2013 API
OpenOptionsForUI Class
Members See Also Send Feedback
This class contains options available for opening a document from disk via the method OpenAndActivateDocument.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class OpenOptionsForUI : IDisposable
Visual Basic
Public Class OpenOptionsForUI _
    Implements IDisposable
Visual C++
public ref class OpenOptionsForUI : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..OpenOptionsForUI

See Also

OpenOptionsForUI Members
Autodesk.Revit.UI Namespace


OpenOptionsForUI Members

[image] [image]

Revit 2013 API
OpenOptionsForUI Members
OpenOptionsForUI Class Constructors Methods Properties See Also Send Feedback

The OpenOptionsForUI type exposes the following members.

Constructors

 | Name | Description
Public method | OpenOptionsForUI | Default constructor.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the OpenOptionsForUI
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DetachFromCentralOption | Specifies whether or not a workset-enabled document is detached from its central document.

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


OpenOptionsForUI Constructor

[image]

Revit 2013 API
OpenOptionsForUI Constructor
OpenOptionsForUI Class See Also Send Feedback
Default constructor.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public OpenOptionsForUI()
Visual Basic
Public Sub New
Visual C++
public:
OpenOptionsForUI()

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


OpenOptionsForUI Methods

[image] [image]

Revit 2013 API
OpenOptionsForUI Methods
OpenOptionsForUI Class See Also Send Feedback

The OpenOptionsForUI type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
OpenOptionsForUI..::..Dispose Method
OpenOptionsForUI Class See Also Send Feedback
Releases all resources used by the OpenOptionsForUI

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


OpenOptionsForUI Properties

[image] [image]

Revit 2013 API
OpenOptionsForUI Properties
OpenOptionsForUI Class See Also Send Feedback

The OpenOptionsForUI type exposes the following members.

Properties

 | Name | Description
Public property | DetachFromCentralOption | Specifies whether or not a workset-enabled document is detached from its central document.

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


DetachFromCentralOption Property

[image]

Revit 2013 API
OpenOptionsForUI..::..DetachFromCentralOption Property
OpenOptionsForUI Class See Also Send Feedback
Specifies whether or not a workset-enabled document is detached from its central document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public DetachFromCentralOptionForUI DetachFromCentralOption { get; set; }
Visual Basic
Public Property DetachFromCentralOption As DetachFromCentralOptionForUI
    Get
    Set
Visual C++
public:
property DetachFromCentralOptionForUI DetachFromCentralOption {
    DetachFromCentralOptionForUI get ();
    void set (DetachFromCentralOptionForUI value);
}

See Also

OpenOptionsForUI Class
Autodesk.Revit.UI Namespace


PreviewControl Class

[image]

Revit 2013 API
PreviewControl Class
Members See Also Send Feedback
Presents a preview control to browse the Revit model.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class PreviewControl : UserControl,
    IDisposable
Visual Basic
Public Class PreviewControl _
    Inherits UserControl _
    Implements IDisposable
Visual C++
public ref class PreviewControl : public UserControl,
    IDisposable

Remarks

The dialog or form or window host this preview control must be modal. The view can be any graphical view but not a non-graphical view. And only one can be active. The view can be manipulated by embedded view cube and the visibility and graphical settings set on the view will be evident in the preview control.

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Control
System.Windows.Controls..::..ContentControl
System.Windows.Controls..::..UserControl
Autodesk.Revit.UI..::..PreviewControl

See Also

PreviewControl Members
Autodesk.Revit.UI Namespace


PreviewControl Members

[image] [image]

Revit 2013 API
PreviewControl Members
PreviewControl Class Constructors Methods Properties Events See Also Send Feedback

The PreviewControl type exposes the following members.

Constructors

 | Name | Description
Public method | PreviewControl | Constructs a preview control.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Dispose | This method is called if the user explicitly disposes of the object (by calling the Dispose method in other managed languages, or the destructor in C++).
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property; (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewId | The view Id.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


PreviewControl Constructor

[image]

Revit 2013 API
PreviewControl Constructor
PreviewControl Class See Also Send Feedback
Constructs a preview control.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public PreviewControl(
    Document document,
    ElementId viewId
)
Visual Basic
Public Sub New ( _
    document As Document, _
    viewId As ElementId _
)
Visual C++
public:
PreviewControl(
    Document^ document,
    ElementId^ viewId
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id want to browse in this control.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when dbDocument or viewId is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the given document is a linked document or the given viewId is invalid or the view is a schedule or other non-graphical view such as schedule views or the project browser view.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when there is an active preview control already.

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


PreviewControl Methods

[image] [image]

Revit 2013 API
PreviewControl Methods
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | Dispose | This method is called if the user explicitly disposes of the object (by calling the Dispose method in other managed languages, or the destructor in C++).
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout()()()(). (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property; (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate()()()(). (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


AddHandler Method

[image] [image]

Revit 2013 API
PreviewControl..::..AddHandler Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


ApplyAnimationClock Method

[image] [image]

Revit 2013 API
PreviewControl..::..ApplyAnimationClock Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


BeginAnimation Method

[image] [image]

Revit 2013 API
PreviewControl..::..BeginAnimation Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


BeginStoryboard Method

[image] [image]

Revit 2013 API
PreviewControl..::..BeginStoryboard Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


BringIntoView Method

[image] [image]

Revit 2013 API
PreviewControl..::..BringIntoView Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BringIntoView()()()() | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


ClearValue Method

[image] [image]

Revit 2013 API
PreviewControl..::..ClearValue Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
PreviewControl..::..Dispose Method
PreviewControl Class See Also Send Feedback
This method is called if the user explicitly disposes of the object (by calling the Dispose method in other managed languages, or the destructor in C++).

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


SetBinding Method

[image] [image]

Revit 2013 API
PreviewControl..::..SetBinding Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


SetValue Method

[image] [image]

Revit 2013 API
PreviewControl..::..SetValue Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


TransformToAncestor Method

[image] [image]

Revit 2013 API
PreviewControl..::..TransformToAncestor Method
PreviewControl Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)

See Also

PreviewControl Class
PreviewControl Members
Autodesk.Revit.UI Namespace


PreviewControl Properties

[image] [image]

Revit 2013 API
PreviewControl Properties
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. (Inherited from UIElement.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit()()()() method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. (Inherited from UIElement.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the Uid for this element. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | ViewId | The view Id.
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. (Inherited from UIElement.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


ViewId Property

[image]

Revit 2013 API
PreviewControl..::..ViewId Property
PreviewControl Class See Also Send Feedback
The view Id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


PreviewControl Events

[image] [image]

Revit 2013 API
PreviewControl Events
PreviewControl Class See Also Send Feedback

The PreviewControl type exposes the following members.

Events

 | Name | Description
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)

See Also

PreviewControl Class
Autodesk.Revit.UI Namespace


PulldownButton Class

[image]

Revit 2013 API
PulldownButton Class
Members See Also Send Feedback
The PulldownButton object represents a button with a drop-down list on RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PulldownButton : RibbonButton
Visual Basic
Public Class PulldownButton _
    Inherits RibbonButton
Visual C++
public ref class PulldownButton : public RibbonButton

Remarks

Use of this class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PulldownButton
Autodesk.Revit.UI..::..SplitButton

See Also

PulldownButton Members
Autodesk.Revit.UI Namespace


PulldownButton Members

[image] [image]

Revit 2013 API
PulldownButton Members
PulldownButton Class Methods Properties See Also Send Feedback

The PulldownButton type exposes the following members.

Methods

 | Name | Description
Public method | AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of buttons assigned to the pulldown button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButton Methods

[image] [image]

Revit 2013 API
PulldownButton Methods
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Methods

 | Name | Description
Public method | AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Public method | AddSeparator | Adds a separator to the drop-down list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of buttons assigned to the pulldown button.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


AddPushButton Method

[image]

Revit 2013 API
PulldownButton..::..AddPushButton Method
PulldownButton Class See Also Send Feedback
Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public PushButton AddPushButton(
    PushButtonData buttonData
)
Visual Basic
Public Function AddPushButton ( _
    buttonData As PushButtonData _
) As PushButton
Visual C++
public:
PushButton^ AddPushButton(
    PushButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit.UI..::..PushButtonData
An object containing the data needed to construct the pushbutton.

Return Value

The newly added pushbutton.

Remarks

The new button will display its large image if PushButton.LargeImage is set.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with buttonData.Name already exists in the button.

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2013 API
PulldownButton..::..AddSeparator Method
PulldownButton Class See Also Send Feedback
Adds a separator to the drop-down list.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddSeparator()
Visual Basic
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator will appear just below the last added PushButton.

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2013 API
PulldownButton..::..GetItems Method
PulldownButton Class See Also Send Feedback
Gets a copy of the collection of buttons assigned to the pulldown button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<PushButton> GetItems()
Visual Basic
Public Function GetItems As IList(Of PushButton)
Visual C++
public:
IList<PushButton^>^ GetItems()

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButton Properties

[image] [image]

Revit 2013 API
PulldownButton Properties
PulldownButton Class See Also Send Feedback

The PulldownButton type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PulldownButton Class
Autodesk.Revit.UI Namespace


PulldownButtonData Class

[image]

Revit 2013 API
PulldownButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a pulldown button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PulldownButtonData : ButtonData
Visual Basic
Public Class PulldownButtonData _
    Inherits ButtonData
Visual C++
public ref class PulldownButtonData : public ButtonData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..PulldownButtonData
Autodesk.Revit.UI..::..SplitButtonData

See Also

PulldownButtonData Members
Autodesk.Revit.UI Namespace


PulldownButtonData Members

[image] [image]

Revit 2013 API
PulldownButtonData Members
PulldownButtonData Class Constructors Methods Properties See Also Send Feedback

The PulldownButtonData type exposes the following members.

Constructors

 | Name | Description
Public method | PulldownButtonData | Constructs a new instance of PulldownButtonData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Constructor

[image]

Revit 2013 API
PulldownButtonData Constructor
PulldownButtonData Class See Also Send Feedback
Constructs a new instance of PulldownButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public PulldownButtonData(
    string name,
    string text
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
PulldownButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::..String
The internal name of the new button.
text
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Methods

[image] [image]

Revit 2013 API
PulldownButtonData Methods
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PulldownButtonData Properties

[image] [image]

Revit 2013 API
PulldownButtonData Properties
PulldownButtonData Class See Also Send Feedback

The PulldownButtonData type exposes the following members.

Properties

 | Name | Description
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

PulldownButtonData Class
Autodesk.Revit.UI Namespace


PushButton Class

[image]

Revit 2013 API
PushButton Class
Members Example See Also Send Feedback
The PushButton object represents an button on a RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PushButton : RibbonButton
Visual Basic
Public Class PushButton _
    Inherits RibbonButton
Visual C++
public ref class PushButton : public RibbonButton

Remarks

Use of this class is not supported in Revit Macros.

Examples

CopyC#
private void AddPushButton(RibbonPanel panel)
{
    PushButton pushButton = panel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    pushButton.ToolTip = "Say Hello World";
    // Set the large image shown on button
    pushButton.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
}
CopyVB.NET
Private Sub AddPushButton(ByVal panel As RibbonPanel)
    Dim pushButton As PushButton = TryCast(panel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    pushButton.ToolTip = "Say Hello World"
    ' Set the large image shown on button
    pushButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"))
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PushButton
Autodesk.Revit.UI..::..ToggleButton

See Also

PushButton Members
Autodesk.Revit.UI Namespace


PushButton Members

[image] [image]

Revit 2013 API
PushButton Members
PushButton Class Methods Properties See Also Send Feedback

The PushButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButton Methods

[image] [image]

Revit 2013 API
PushButton Methods
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButton Properties

[image] [image]

Revit 2013 API
PushButton Properties
PushButton Class See Also Send Feedback

The PushButton type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

PushButton Class
Autodesk.Revit.UI Namespace


AssemblyName Property

[image]

Revit 2013 API
PushButton..::..AssemblyName Property
PushButton Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


AvailabilityClassName Property

[image]

Revit 2013 API
PushButton..::..AvailabilityClassName Property
PushButton Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this push button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic
Public Property AvailabilityClassName As String
    Get
    Set
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


ClassName Property

[image]

Revit 2013 API
PushButton..::..ClassName Property
PushButton Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic
Public Property ClassName As String
    Get
    Set
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when setting the value to a ToggleButton which is not initialized with an external command.

See Also

PushButton Class
Autodesk.Revit.UI Namespace


PushButtonData Class

[image]

Revit 2013 API
PushButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a push button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PushButtonData : ButtonData
Visual Basic
Public Class PushButtonData _
    Inherits ButtonData
Visual C++
public ref class PushButtonData : public ButtonData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..PushButtonData
Autodesk.Revit.UI..::..ToggleButtonData

See Also

PushButtonData Members
Autodesk.Revit.UI Namespace


PushButtonData Members

[image] [image]

Revit 2013 API
PushButtonData Members
PushButtonData Class Constructors Methods Properties See Also Send Feedback

The PushButtonData type exposes the following members.

Constructors

 | Name | Description
Public method | PushButtonData | Constructs a new instance of PushButtonData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Constructor

[image]

Revit 2013 API
PushButtonData Constructor
PushButtonData Class See Also Send Feedback
Constructs a new instance of PushButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public PushButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
PushButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::..String
The internal name of the new button.
text
Type: System..::..String
The user visible text seen on the new button.
assemblyName
Type: System..::..String
The assembly path of the button.
className
Type: System..::..String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Methods

[image] [image]

Revit 2013 API
PushButtonData Methods
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


PushButtonData Properties

[image] [image]

Revit 2013 API
PushButtonData Properties
PushButtonData Class See Also Send Feedback

The PushButtonData type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button.
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button.
Public property | ClassName | The name of the class containing the implementation for the command.
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


AssemblyName Property

[image]

Revit 2013 API
PushButtonData..::..AssemblyName Property
PushButtonData Class See Also Send Feedback
The assembly path of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string AssemblyName { get; set; }
Visual Basic
Public Property AssemblyName As String
    Get
    Set
Visual C++
public:
property String^ AssemblyName {
    String^ get ();
    void set (String^ value);
}

Remarks

The path of the assembly which contains the corresponding external command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


AvailabilityClassName Property

[image]

Revit 2013 API
PushButtonData..::..AvailabilityClassName Property
PushButtonData Class See Also Send Feedback
The full class name for the class providing the entry point to decide availability of this push button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string AvailabilityClassName { get; set; }
Visual Basic
Public Property AvailabilityClassName As String
    Get
    Set
Visual C++
public:
property String^ AvailabilityClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

This is the class implementing IExternalCommandAvailability interface.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


ClassName Property

[image]

Revit 2013 API
PushButtonData..::..ClassName Property
PushButtonData Class See Also Send Feedback
The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string ClassName { get; set; }
Visual Basic
Public Property ClassName As String
    Get
    Set
Visual C++
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string.

See Also

PushButtonData Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Class

[image]

Revit 2013 API
RadioButtonGroup Class
Members Example See Also Send Feedback
Represents a group of related buttons in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RadioButtonGroup : RibbonItem
Visual Basic
Public Class RadioButtonGroup _
    Inherits RibbonItem
Visual C++
public ref class RadioButtonGroup : public RibbonItem

Remarks

This class contains a collection of ToggleButtons. Only one of the ToggleButtons will appear active at a given time. When a different button is clicked in the UI the current ToggleButton will be changed, and the ToggleButton's external command will be invoked. Use of this class is not supported in Revit Macros.

Examples

CopyC#
private void AddRadioGroup(RibbonPanel panel)
{
    // add radio button group
    RadioButtonGroupData radioData = new RadioButtonGroupData("radioGroup");
    RadioButtonGroup radioButtonGroup = panel.AddItem(radioData) as RadioButtonGroup;

    // create toggle buttons and add to radio button group
    ToggleButtonData tb1 = new ToggleButtonData("toggleButton1", "Red");
    tb1.ToolTip = "Red Option";
    tb1.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    ToggleButtonData tb2 = new ToggleButtonData("toggleButton2", "Green");
    tb2.ToolTip = "Green Option";
    tb2.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));
    ToggleButtonData tb3 = new ToggleButtonData("toggleButton3", "Blue");
    tb3.ToolTip = "Blue Option";
    tb3.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    radioButtonGroup.AddItem(tb1);
    radioButtonGroup.AddItem(tb2);
    radioButtonGroup.AddItem(tb3);
}
CopyVB.NET
Private Sub AddRadioGroup(ByVal panel As RibbonPanel)
    ' add radio button group
    Dim radioData As New RadioButtonGroupData("radioGroup")
    Dim radioButtonGroup As RadioButtonGroup = TryCast(panel.AddItem(radioData), RadioButtonGroup)

    ' create toggle buttons and add to radio button group
    Dim tb1 As New ToggleButtonData("toggleButton1", "Red")
    tb1.ToolTip = "Red Option"
    tb1.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim tb2 As New ToggleButtonData("toggleButton2", "Green")
    tb2.ToolTip = "Green Option"
    tb2.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))
    Dim tb3 As New ToggleButtonData("toggleButton3", "Blue")
    tb3.ToolTip = "Blue Option"
    tb3.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    radioButtonGroup.AddItem(tb1)
    radioButtonGroup.AddItem(tb2)
    radioButtonGroup.AddItem(tb3)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RadioButtonGroup

See Also

RadioButtonGroup Members
Autodesk.Revit.UI Namespace


RadioButtonGroup Members

[image] [image]

Revit 2013 API
RadioButtonGroup Members
RadioButtonGroup Class Methods Properties See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new ToggleButton to the RadioButtonGroup.
Public method | AddItems | Adds new ToggleButtons to the RadioButtonGroup.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Methods

[image] [image]

Revit 2013 API
RadioButtonGroup Methods
RadioButtonGroup Class See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a new ToggleButton to the RadioButtonGroup.
Public method | AddItems | Adds new ToggleButtons to the RadioButtonGroup.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets the collection of ToggleButtons assigned to the RadioButtonGroup.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2013 API
RadioButtonGroup..::..AddItem Method
RadioButtonGroup Class See Also Send Feedback
Adds a new ToggleButton to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ToggleButton AddItem(
    ToggleButtonData buttonData
)
Visual Basic
Public Function AddItem ( _
    buttonData As ToggleButtonData _
) As ToggleButton
Visual C++
public:
ToggleButton^ AddItem(
    ToggleButtonData^ buttonData
)

Parameters

buttonData
Type: Autodesk.Revit.UI..::..ToggleButtonData
An object containing the data needed to construct the ToggleButton.

Return Value

The newly added ToggleButton.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with buttonData.Name already exists in the group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


AddItems Method

[image]

Revit 2013 API
RadioButtonGroup..::..AddItems Method
RadioButtonGroup Class See Also Send Feedback
Adds new ToggleButtons to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ToggleButton> AddItems(
    IList<ToggleButtonData> buttonData
)
Visual Basic
Public Function AddItems ( _
    buttonData As IList(Of ToggleButtonData) _
) As IList(Of ToggleButton)
Visual C++
public:
IList<ToggleButton^>^ AddItems(
    IList<ToggleButtonData^>^ buttonData
)

Parameters

buttonData
Type: System.Collections.Generic..::..IList<(Of <(<'ToggleButtonData>)>)>
A list of objects containing the data needed to construct the ToggleButtons.

Return Value

The newly added ToggleButtons.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when buttonData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when button with buttonData.Name already exists in the group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2013 API
RadioButtonGroup..::..GetItems Method
RadioButtonGroup Class See Also Send Feedback
Gets the collection of ToggleButtons assigned to the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<ToggleButton> GetItems()
Visual Basic
Public Function GetItems As IList(Of ToggleButton)
Visual C++
public:
IList<ToggleButton^>^ GetItems()

Remarks

This is a copy of all the ToggleButtons assigned to this group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroup Properties

[image] [image]

Revit 2013 API
RadioButtonGroup Properties
RadioButtonGroup Class See Also Send Feedback

The RadioButtonGroup type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets or sets the current checked ToggleButton of the RadioButtonGroup.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


Current Property

[image]

Revit 2013 API
RadioButtonGroup..::..Current Property
RadioButtonGroup Class See Also Send Feedback
Gets or sets the current checked ToggleButton of the RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ToggleButton Current { get; set; }
Visual Basic
Public Property Current As ToggleButton
    Get
    Set
Visual C++
public:
property ToggleButton^ Current {
    ToggleButton^ get ();
    void set (ToggleButton^ value);
}

Remarks

The default value is the first ToggleButton added to the group. When using this property to set the current ToggleButton, the external command of that button will not be called.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when trying to set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when trying to set this property to a button not in this group.

See Also

RadioButtonGroup Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Class

[image]

Revit 2013 API
RadioButtonGroupData Class
Members See Also Send Feedback
This class contains information necessary to construct a ribbon gallery in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class RadioButtonGroupData : RibbonItemData
Visual Basic
Public Class RadioButtonGroupData _
    Inherits RibbonItemData
Visual C++
public ref class RadioButtonGroupData : public RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..RadioButtonGroupData

See Also

RadioButtonGroupData Members
Autodesk.Revit.UI Namespace


RadioButtonGroupData Members

[image] [image]

Revit 2013 API
RadioButtonGroupData Members
RadioButtonGroupData Class Constructors Methods Properties See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Constructors

 | Name | Description
Public method | RadioButtonGroupData | Constructs a new instance of RadioButtonGroupData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Constructor

[image]

Revit 2013 API
RadioButtonGroupData Constructor
RadioButtonGroupData Class See Also Send Feedback
Constructs a new instance of RadioButtonGroupData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public RadioButtonGroupData(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
RadioButtonGroupData(
    String^ name
)

Parameters

name
Type: System..::..String
The internal name of the RadioButtonGroup.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for name.

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Methods

[image] [image]

Revit 2013 API
RadioButtonGroupData Methods
RadioButtonGroupData Class See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


RadioButtonGroupData Properties

[image] [image]

Revit 2013 API
RadioButtonGroupData Properties
RadioButtonGroupData Class See Also Send Feedback

The RadioButtonGroupData type exposes the following members.

Properties

 | Name | Description
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

RadioButtonGroupData Class
Autodesk.Revit.UI Namespace


Result Enumeration

[image]

Revit 2013 API
Result Enumeration
See Also Send Feedback
Informs Autodesk Revit of the status of your application after execution.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum Result
Visual Basic
Public Enumeration Result
Visual C++
public enum class Result

Members

Member name | Description
Failed | The external application was unable to complete its task.
Succeeded | The external application completed successfully. Autodesk Revit will keep this object during the entire Revit session.
Cancelled | Signifies that the external application is cancelled.

See Also

Autodesk.Revit.UI Namespace


RevitCommandId Class

[image]

Revit 2013 API
RevitCommandId Class
Members See Also Send Feedback
Represents a command id in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class RevitCommandId
Visual Basic
Public Class RevitCommandId
Visual C++
public ref class RevitCommandId

Remarks

Each Revit command is assigned a command id and non-localized name. This class allows you to look up a command by its name, and represents any Revit command in the use of an AddInCommandBinding.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RevitCommandId

See Also

RevitCommandId Members
Autodesk.Revit.UI Namespace


RevitCommandId Members

[image] [image]

Revit 2013 API
RevitCommandId Members
RevitCommandId Class Methods Properties See Also Send Feedback

The RevitCommandId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LookupCommandId | Looks up and retrieves the Revit command id with the given id string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CanHaveBinding | Indicates whether the command can be assigned a binding to an external add-in..
Public property | HasBinding | Indicates whether the command has already been bound to an external add-in.
Public property | Id | The command id.
Public property | Name | The command name.

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


RevitCommandId Methods

[image] [image]

Revit 2013 API
RevitCommandId Methods
RevitCommandId Class See Also Send Feedback

The RevitCommandId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LookupCommandId | Looks up and retrieves the Revit command id with the given id string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


LookupCommandId Method

[image]

Revit 2013 API
RevitCommandId..::..LookupCommandId Method
RevitCommandId Class See Also Send Feedback
Looks up and retrieves the Revit command id with the given id string.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static RevitCommandId LookupCommandId(
    string name
)
Visual Basic
Public Shared Function LookupCommandId ( _
    name As String _
) As RevitCommandId
Visual C++
public:
static RevitCommandId^ LookupCommandId(
    String^ name
)

Parameters

name
Type: System..::..String
The Revit command name. Refer to the entries in the Revit journal to find the string to use for a particular command.

Return Value

The Revit command id. Returning nullNothingnullptra null reference (Nothing in Visual Basic) if a command with the given name was not found.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when name is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the given name is empty.

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


RevitCommandId Properties

[image] [image]

Revit 2013 API
RevitCommandId Properties
RevitCommandId Class See Also Send Feedback

The RevitCommandId type exposes the following members.

Properties

 | Name | Description
Public property | CanHaveBinding | Indicates whether the command can be assigned a binding to an external add-in..
Public property | HasBinding | Indicates whether the command has already been bound to an external add-in.
Public property | Id | The command id.
Public property | Name | The command name.

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


CanHaveBinding Property

[image]

Revit 2013 API
RevitCommandId..::..CanHaveBinding Property
RevitCommandId Class See Also Send Feedback
Indicates whether the command can be assigned a binding to an external add-in..

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanHaveBinding { get; }
Visual Basic
Public ReadOnly Property CanHaveBinding As Boolean
    Get
Visual C++
public:
property bool CanHaveBinding {
    bool get ();
}

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


HasBinding Property

[image]

Revit 2013 API
RevitCommandId..::..HasBinding Property
RevitCommandId Class See Also Send Feedback
Indicates whether the command has already been bound to an external add-in.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool HasBinding { get; }
Visual Basic
Public ReadOnly Property HasBinding As Boolean
    Get
Visual C++
public:
property bool HasBinding {
    bool get ();
}

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


Id Property

[image]

Revit 2013 API
RevitCommandId..::..Id Property
RevitCommandId Class See Also Send Feedback
The command id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public uint Id { get; }
Visual Basic
Public ReadOnly Property Id As UInteger
    Get
Visual C++
public:
property unsigned int Id {
    unsigned int get ();
}

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2013 API
RevitCommandId..::..Name Property
RevitCommandId Class See Also Send Feedback
The command name.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

RevitCommandId Class
Autodesk.Revit.UI Namespace


RibbonButton Class

[image]

Revit 2013 API
RibbonButton Class
Members See Also Send Feedback
This class is the base class of PushButton and PulldownButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class RibbonButton : RibbonItem
Visual Basic
Public Class RibbonButton _
    Inherits RibbonItem
Visual C++
public ref class RibbonButton : public RibbonItem

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PulldownButton
Autodesk.Revit.UI..::..PushButton

See Also

RibbonButton Members
Autodesk.Revit.UI Namespace


RibbonButton Members

[image] [image]

Revit 2013 API
RibbonButton Members
RibbonButton Class Methods Properties See Also Send Feedback

The RibbonButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button.
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonButton Methods

[image] [image]

Revit 2013 API
RibbonButton Methods
RibbonButton Class See Also Send Feedback

The RibbonButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonButton Properties

[image] [image]

Revit 2013 API
RibbonButton Properties
RibbonButton Class See Also Send Feedback

The RibbonButton type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button.
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
RibbonButton..::..Image Property
RibbonButton Class See Also Send Feedback
The image of the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button if it is a part of a stacked set or if it is promoted to the Quick Access Toolbar. The image should be 16 x 16 pixels. If the image is larger it will NOT be adjusted to fit the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


IsEnabledByContext Property

[image]

Revit 2013 API
RibbonButton..::..IsEnabledByContext Property
RibbonButton Class See Also Send Feedback
Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool IsEnabledByContext { get; }
Visual Basic
Public ReadOnly Property IsEnabledByContext As Boolean
    Get
Visual C++
public:
property bool IsEnabledByContext {
    bool get ();
}

Remarks

The button may be enabled for a given context but still disabled programmatically using the Enabled property for the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


LargeImage Property

[image]

Revit 2013 API
RibbonButton..::..LargeImage Property
RibbonButton Class See Also Send Feedback
The large image shown on the button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource LargeImage { get; set; }
Visual Basic
Public Property LargeImage As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ LargeImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the button in the Ribbon panel if the button is not a part of a stacked set. It will also be shown if the button is added to a pulldown button. The image should be 32 x 32 pixels. If the image is larger it will be adjusted to fit the button.

See Also

RibbonButton Class
Autodesk.Revit.UI Namespace


RibbonItem Class

[image]

Revit 2013 API
RibbonItem Class
Members See Also Send Feedback
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class RibbonItem
Visual Basic
Public Class RibbonItem
Visual C++
public ref class RibbonItem

Remarks

This class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..ComboBox
Autodesk.Revit.UI..::..ComboBoxMember
Autodesk.Revit.UI..::..RadioButtonGroup
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..TextBox

See Also

RibbonItem Members
Autodesk.Revit.UI Namespace


RibbonItem Members

[image] [image]

Revit 2013 API
RibbonItem Members
RibbonItem Class Methods Properties See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetContextualHelp | Gets the contextual help bound with this control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled.
Public property | ItemText | Gets or sets the text displayed on the item.
Public property | ItemType | Gets the item type.
Public property | LongDescription | Long description of the command tooltip
Public property | Name | The name of the item.
Public property | ToolTip | The description that appears as a ToolTip for the item.
Public property | ToolTipImage | The image to show as a part of the button extended tooltip
Public property | Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItem Methods

[image] [image]

Revit 2013 API
RibbonItem Methods
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetContextualHelp | Gets the contextual help bound with this control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Equals Method

[image]

Revit 2013 API
RibbonItem..::..Equals Method
RibbonItem Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another panel object.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


GetContextualHelp Method

[image]

Revit 2013 API
RibbonItem..::..GetContextualHelp Method
RibbonItem Class See Also Send Feedback
Gets the contextual help bound with this control.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ContextualHelp GetContextualHelp()
Visual Basic
Public Function GetContextualHelp As ContextualHelp
Visual C++
public:
ContextualHelp^ GetContextualHelp()

Return Value

The contextual help assigned to the item, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no binding assigned.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


SetContextualHelp Method

[image]

Revit 2013 API
RibbonItem..::..SetContextualHelp Method
RibbonItem Class See Also Send Feedback
Sets the contextual help bound with this button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetContextualHelp(
    ContextualHelp contextualHelp
)
Visual Basic
Public Sub SetContextualHelp ( _
    contextualHelp As ContextualHelp _
)
Visual C++
public:
void SetContextualHelp(
    ContextualHelp^ contextualHelp
)

Parameters

contextualHelp
Type: Autodesk.Revit.UI..::..ContextualHelp
The contextual help.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItem Properties

[image] [image]

Revit 2013 API
RibbonItem Properties
RibbonItem Class See Also Send Feedback

The RibbonItem type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled.
Public property | ItemText | Gets or sets the text displayed on the item.
Public property | ItemType | Gets the item type.
Public property | LongDescription | Long description of the command tooltip
Public property | Name | The name of the item.
Public property | ToolTip | The description that appears as a ToolTip for the item.
Public property | ToolTipImage | The image to show as a part of the button extended tooltip
Public property | Visible | Gets or sets a value indicating whether the item is visible.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Enabled Property

[image]

Revit 2013 API
RibbonItem..::..Enabled Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is enabled.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Remarks

When the Enabled property is set to false, the item cannot be clicked, and the item's appearance changes. The Image and Text assigned to the item appear grayed out. For pushbuttons, the button may be enabled programmatically but be disabled in the user interface because of the Revit context; see the property IsEnabledByContext for RibbonButton.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ItemText Property

[image]

Revit 2013 API
RibbonItem..::..ItemText Property
RibbonItem Class See Also Send Feedback
Gets or sets the text displayed on the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual string ItemText { get; set; }
Visual Basic
Public Overridable Property ItemText As String
    Get
    Set
Visual C++
public:
virtual property String^ ItemText {
    String^ get ();
    void set (String^ value);
}

Remarks

The text can be changed at run time. nullNothingnullptra null reference (Nothing in Visual Basic) or empty string is not allowed.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the text to empty or to the string contains "%".
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the text to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ItemType Property

[image]

Revit 2013 API
RibbonItem..::..ItemType Property
RibbonItem Class See Also Send Feedback
Gets the item type.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public RibbonItemType ItemType { get; }
Visual Basic
Public ReadOnly Property ItemType As RibbonItemType
    Get
Visual C++
public:
property RibbonItemType ItemType {
    RibbonItemType get ();
}

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


LongDescription Property

[image]

Revit 2013 API
RibbonItem..::..LongDescription Property
RibbonItem Class See Also Send Feedback
Long description of the command tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string LongDescription { get; set; }
Visual Basic
Public Property LongDescription As String
    Get
    Set
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

It will be used as part of the button's extended tooltip. This tooltip is shown when the mouse hovers over the command for a long amount of time. You can split the text of this option into multiple paragraphs by placing <p> tags around each paragraph. Optional. If neither of this property and TooltipImage is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2013 API
RibbonItem..::..Name Property
RibbonItem Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; internal set; }
Visual Basic
Public Property Name As String
    Get
    Friend Set
Visual C++
public:
property String^ Name {
    String^ get ();
    internal: void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the text to empty or to the string contains "%".

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ToolTip Property

[image]

Revit 2013 API
RibbonItem..::..ToolTip Property
RibbonItem Class See Also Send Feedback
The description that appears as a ToolTip for the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic
Public Property ToolTip As String
    Get
    Set
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the item. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


ToolTipImage Property

[image]

Revit 2013 API
RibbonItem..::..ToolTipImage Property
RibbonItem Class See Also Send Feedback
The image to show as a part of the button extended tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource ToolTipImage { get; set; }
Visual Basic
Public Property ToolTipImage As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ ToolTipImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

Shown when the cursor hovers over the command. If neither this property nor LongDescription is supplied, the button will not have an extended tooltip. Maximum height or width is 355 pixels. SplitButton and RadioButtonGroup cannot display the tooltip set by this method. SplitButton shows the current PushButton tooltip and RadioButtonGroup has no tooltip.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


Visible Property

[image]

Revit 2013 API
RibbonItem..::..Visible Property
RibbonItem Class See Also Send Feedback
Gets or sets a value indicating whether the item is visible.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Remarks

When the Visible property is set to false, the item won't be displayed on Ribbon.

See Also

RibbonItem Class
Autodesk.Revit.UI Namespace


RibbonItemData Class

[image]

Revit 2013 API
RibbonItemData Class
Members See Also Send Feedback
Base class used to contain information necessary to construct a RibbonItem in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class RibbonItemData
Visual Basic
Public Class RibbonItemData
Visual C++
public ref class RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..ComboBoxData
Autodesk.Revit.UI..::..ComboBoxMemberData
Autodesk.Revit.UI..::..RadioButtonGroupData
Autodesk.Revit.UI..::..TextBoxData

See Also

RibbonItemData Members
Autodesk.Revit.UI Namespace


RibbonItemData Members

[image] [image]

Revit 2013 API
RibbonItemData Members
RibbonItemData Class Methods Properties See Also Send Feedback

The RibbonItemData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LongDescription | Long description of the command tooltip
Public property | Name | The name of the item.
Public property | ToolTip | The description that appears as a ToolTip for the item.
Public property | ToolTipImage | The image to show as a part of the button extended tooltip

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemData Methods

[image] [image]

Revit 2013 API
RibbonItemData Methods
RibbonItemData Class See Also Send Feedback

The RibbonItemData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


GetContextualHelp Method

[image]

Revit 2013 API
RibbonItemData..::..GetContextualHelp Method
RibbonItemData Class See Also Send Feedback
Gets the contextual help bound with this control.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ContextualHelp GetContextualHelp()
Visual Basic
Public Function GetContextualHelp As ContextualHelp
Visual C++
public:
ContextualHelp^ GetContextualHelp()

Return Value

The contextual help assigned to the item, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no binding assigned.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


SetContextualHelp Method

[image]

Revit 2013 API
RibbonItemData..::..SetContextualHelp Method
RibbonItemData Class See Also Send Feedback
Sets the contextual help bound with this button data.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetContextualHelp(
    ContextualHelp contextualHelp
)
Visual Basic
Public Sub SetContextualHelp ( _
    contextualHelp As ContextualHelp _
)
Visual C++
public:
void SetContextualHelp(
    ContextualHelp^ contextualHelp
)

Parameters

contextualHelp
Type: Autodesk.Revit.UI..::..ContextualHelp
The contextual help.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemData Properties

[image] [image]

Revit 2013 API
RibbonItemData Properties
RibbonItemData Class See Also Send Feedback

The RibbonItemData type exposes the following members.

Properties

 | Name | Description
Public property | LongDescription | Long description of the command tooltip
Public property | Name | The name of the item.
Public property | ToolTip | The description that appears as a ToolTip for the item.
Public property | ToolTipImage | The image to show as a part of the button extended tooltip

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


LongDescription Property

[image]

Revit 2013 API
RibbonItemData..::..LongDescription Property
RibbonItemData Class See Also Send Feedback
Long description of the command tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string LongDescription { get; set; }
Visual Basic
Public Property LongDescription As String
    Get
    Set
Visual C++
public:
property String^ LongDescription {
    String^ get ();
    void set (String^ value);
}

Remarks

It will be used as part of the button's extended tooltip. This tooltip is shown when the mouse hovers over the command for a long amount of time. You can split the text of this option into multiple paragraphs by placing <p> tags around each paragraph. Optional. If neither of this property and TooltipImage is supplied, the button will not have an extended tooltip. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2013 API
RibbonItemData..::..Name Property
RibbonItemData Class See Also Send Feedback
The name of the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


ToolTip Property

[image]

Revit 2013 API
RibbonItemData..::..ToolTip Property
RibbonItemData Class See Also Send Feedback
The description that appears as a ToolTip for the item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string ToolTip { get; set; }
Visual Basic
Public Property ToolTip As String
    Get
    Set
Visual C++
public:
property String^ ToolTip {
    String^ get ();
    void set (String^ value);
}

Remarks

The text that is displayed when the mouse pointer moves over the item. SplitButton and RadioButtonGroup cannot display the tooltip set by this method, the SplitButton will always show the current PushButton tooltip, and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


ToolTipImage Property

[image]

Revit 2013 API
RibbonItemData..::..ToolTipImage Property
RibbonItemData Class See Also Send Feedback
The image to show as a part of the button extended tooltip

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ImageSource ToolTipImage { get; set; }
Visual Basic
Public Property ToolTipImage As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ ToolTipImage {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

Shown when the cursor hovers over the command. If neither this property nor LongDescription is supplied, the button will not have an extended tooltip. Maximum height or width is 355 pixels. SplitButton and RadioButtonGroup cannot display the tooltip set by this method. SplitButton shows the current PushButton tooltip and RadioButtonGroup has no tooltip.

See Also

RibbonItemData Class
Autodesk.Revit.UI Namespace


RibbonItemType Enumeration

[image]

Revit 2013 API
RibbonItemType Enumeration
See Also Send Feedback
An enumerated type listing all the toolbar item styles.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum RibbonItemType
Visual Basic
Public Enumeration RibbonItemType
Visual C++
public enum class RibbonItemType

Members

Member name | Description
PushButton | A standard button with text and image.
PulldownButton | A button with a pull-down menu list.
SplitButton | A split button with a default button and a pull-down menu list.
ToggleButton | A standard button that can be added to RadioButtonGroup.
RadioButtonGroup | An item that contains a collection of RibbonToggleButton items.
ComboBoxMember | An item in the drop-down list of a ComboBox.
ComboBox | A selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
TextBox | A text-based control that allows the user to enter text.

See Also

Autodesk.Revit.UI Namespace


RibbonPanel Class

[image]

Revit 2013 API
RibbonPanel Class
Members Example See Also Send Feedback
Represents a panel added by an External Application or External Command into the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class RibbonPanel
Visual Basic
Public Class RibbonPanel
Visual C++
public ref class RibbonPanel

Remarks

The Panel class provides read and write access to the RibbonItems contained in the panel. Use of this class is not supported in Revit Macros.

Examples

CopyC#
public Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel �NewRibbonPanel"
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";
    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("Hello Button",
        "Hello Button", assembly, "Hello.HelloButton")) as PushButton;

    // create bitmap image for button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);

    // assign bitmap to button
    pushButton.LargeImage = largeImage;

    // assign a small bitmap to button which is used if command
    // is moved to Quick Access Toolbar
    Uri uriSmallImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png");
    BitmapImage smallImage = new BitmapImage(uriSmallImage);

    // assign small image to button
    pushButton.Image = smallImage;

    // add a vertical separator bar to the panel
    ribbonPanel.AddSeparator();

    // define 3 new buttons to be added as stacked buttons
    PushButtonData buttonRed = new PushButtonData ("Hello Red", "Hello Red",
        assembly, "Hello.HelloRed");
    buttonRed.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Red.bmp"));
    PushButtonData buttonBlue = new PushButtonData("Hello Blue", "Hello Blue",
        assembly, "Hello.HelloBlue");
    buttonBlue.Image = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Blue.bmp"));
    PushButtonData buttonGreen = new PushButtonData("Hello Green", "Hello Green",
        assembly, "Hello.HelloGreen");
    buttonGreen.Image =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Green.bmp"));

    // add 3 stacked buttons to the panel
    ribbonPanel.AddStackedItems(buttonRed, buttonBlue, buttonGreen);

    // add a pull-down button to the panel
    PulldownButton pulldownButton = ribbonPanel.AddItem(new PulldownButtonData("Hello",
        "Hello 123")) as PulldownButton;
    pulldownButton.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Hello.bmp"));

    // add some menu items to the pull-down button and assign bitmaps to them
    PushButton buttonOne = pulldownButton.AddPushButton(new PushButtonData("Hello One",
        "Hello 123", assembly, "Hello.HelloOne"));
    buttonOne.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));
    PushButton buttonTwo = pulldownButton.AddPushButton(new PushButtonData("Hello Two",
        "Hello 123", assembly, "Hello.HelloTwo"));
    buttonTwo.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));
    PushButton buttonThree = pulldownButton.AddPushButton(new PushButtonData("Hello Three",
        "Hello 123", assembly, "Hello.HelloThree"));
    buttonThree.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));

    return Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel "NewRibbonPanel"
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"
    Dim pushButton As PushButton = TryCast(ribbonPanel.AddItem(New PushButtonData("Hello Button", "Hello Button", assembly, "Hello.HelloButton")), PushButton)

    ' create bitmap image for button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)

    ' assign bitmap to button
    pushButton.LargeImage = largeImage

    ' assign a small bitmap to button which is used if command
    ' is moved to Quick Access Toolbar
    Dim uriSmallImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png")
    Dim smallImage As New BitmapImage(uriSmallImage)

    ' assign small image to button
    pushButton.Image = smallImage

    ' add a vertical separator bar to the panel
    ribbonPanel.AddSeparator()

    ' define 3 new buttons to be added as stacked buttons
    Dim buttonRed As New PushButtonData("Hello Red", "Hello Red", assembly, "Hello.HelloRed")
    buttonRed.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Red.bmp"))
    Dim buttonBlue As New PushButtonData("Hello Blue", "Hello Blue", assembly, "Hello.HelloBlue")
    buttonBlue.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Blue.bmp"))
    Dim buttonGreen As New PushButtonData("Hello Green", "Hello Green", assembly, "Hello.HelloGreen")
    buttonGreen.Image = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Green.bmp"))

    ' add 3 stacked buttons to the panel
    ribbonPanel.AddStackedItems(buttonRed, buttonBlue, buttonGreen)

    ' add a pull-down button to the panel
    Dim pulldownButton As PulldownButton = TryCast(ribbonPanel.AddItem(New PulldownButtonData("Hello", "Hello 123")), PulldownButton)
    pulldownButton.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Hello.bmp"))

    ' add some menu items to the pull-down button and assign bitmaps to them
    Dim buttonOne As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello One", "Hello 123", assembly, "Hello.HelloOne"))
    buttonOne.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\One.bmp"))
    Dim buttonTwo As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello Two", "Hello 123", assembly, "Hello.HelloTwo"))
    buttonTwo.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Two.bmp"))
    Dim buttonThree As PushButton = pulldownButton.AddPushButton(New PushButtonData("Hello Three", "Hello 123", assembly, "Hello.HelloThree"))
    buttonThree.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Three.bmp"))

    Return Result.Succeeded
End Function

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonPanel

See Also

RibbonPanel Members
Autodesk.Revit.UI Namespace


RibbonPanel Members

[image] [image]

Revit 2013 API
RibbonPanel Members
RibbonPanel Class Methods Properties See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a Ribbon item to the panel.
Public method | AddSeparator | Adds a new Separator to the panel.
Public method | AddSlideOut | Adds a slideout to the current panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData) | Adds two stacked items to the panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) | Adds three stacked items to the panel.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Public property | Name | Gets or sets the name of the RibbonPanel.
Public property | Title | Gets or sets the text of the RibbonPanel.
Public property | Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


RibbonPanel Methods

[image] [image]

Revit 2013 API
RibbonPanel Methods
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Methods

 | Name | Description
Public method | AddItem | Adds a Ribbon item to the panel.
Public method | AddSeparator | Adds a new Separator to the panel.
Public method | AddSlideOut | Adds a slideout to the current panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData) | Adds two stacked items to the panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) | Adds three stacked items to the panel.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Overrides Object..::..Equals(Object).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddItem Method

[image]

Revit 2013 API
RibbonPanel..::..AddItem Method
RibbonPanel Class See Also Send Feedback
Adds a Ribbon item to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public RibbonItem AddItem(
    RibbonItemData itemData
)
Visual Basic
Public Function AddItem ( _
    itemData As RibbonItemData _
) As RibbonItem
Visual C++
public:
RibbonItem^ AddItem(
    RibbonItemData^ itemData
)

Parameters

itemData
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the new item.

Return Value

The added Ribbon item.

Remarks

The new item may either be a PushButton, PulldownButton, SplitButon, RadioButtonGroup, ComboBox, or TextBox depending upon the type of data passed in. The new item may be created as a large-size vertical control in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when itemData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an item with the itemData.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddSeparator Method

[image]

Revit 2013 API
RibbonPanel..::..AddSeparator Method
RibbonPanel Class See Also Send Feedback
Adds a new Separator to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void AddSeparator()
Visual Basic
Public Sub AddSeparator
Visual C++
public:
void AddSeparator()

Remarks

The separator won't be shown if there are no items already added to the panel.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddSlideOut Method

[image]

Revit 2013 API
RibbonPanel..::..AddSlideOut Method
RibbonPanel Class Example See Also Send Feedback
Adds a slideout to the current panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddSlideOut()
Visual Basic
Public Sub AddSlideOut
Visual C++
public:
void AddSlideOut()

Remarks

The slideout part of the panel can be shown by clicking on the arrow at the bottom of the panel. After calling AddSlideOut(), any subsequent calls to add new items will add the new item(s) to the slideout. The slideout part of the panel will be shown only if items are added after this call.

Examples

CopyC#
private static void AddSlideOut(RibbonPanel panel)
{
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";

    panel.AddSlideOut();

    // create some controls for the slide out
    PushButtonData b1 = new PushButtonData("ButtonName1", "Button 1",
        assembly, "Hello.HelloButton");
    b1.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"));
    PushButtonData b2 = new PushButtonData("ButtonName2", "Button 2",
        assembly, "Hello.HelloTwo");
    b2.LargeImage = new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png"));

    // items added after call to AddSlideOut() are added to slide-out automatically
    panel.AddItem(b1);
    panel.AddItem(b2);
}
CopyVB.NET
Private Shared Sub AddSlideOut(ByVal panel As RibbonPanel)
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"

    panel.AddSlideOut()

    ' create some controls for the slide out
    Dim b1 As New PushButtonData("ButtonName1", "Button 1", assembly, "Hello.HelloButton")
    b1.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png"))
    Dim b2 As New PushButtonData("ButtonName2", "Button 2", assembly, "Hello.HelloTwo")
    b2.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_16x16.png"))

    ' items added after call to AddSlideOut() are added to slide-out automatically
    panel.AddItem(b1)
    panel.AddItem(b2)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when a slide out panel is already added.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


AddStackedItems Method

[image] [image]

Revit 2013 API
RibbonPanel..::..AddStackedItems Method
RibbonPanel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddStackedItems(RibbonItemData, RibbonItemData) | Adds two stacked items to the panel.
Public method | AddStackedItems(RibbonItemData, RibbonItemData, RibbonItemData) | Adds three stacked items to the panel.

See Also

RibbonPanel Class
RibbonPanel Members
Autodesk.Revit.UI Namespace


AddStackedItems Method (RibbonItemData, RibbonItemData)

[image]

Revit 2013 API
RibbonPanel..::..AddStackedItems Method (RibbonItemData, RibbonItemData)
RibbonPanel Class See Also Send Feedback
Adds two stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
    RibbonItemData item1,
    RibbonItemData item2
)
Visual Basic
Public Function AddStackedItems ( _
    item1 As RibbonItemData, _
    item2 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
    RibbonItemData^ item1,
    RibbonItemData^ item2
)

Parameters

item1
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when item1 or item2 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an item with the item1.Name or item2.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
AddStackedItems Overload
Autodesk.Revit.UI Namespace


AddStackedItems Method (RibbonItemData, RibbonItemData, RibbonItemData)

[image]

Revit 2013 API
RibbonPanel..::..AddStackedItems Method (RibbonItemData, RibbonItemData, RibbonItemData)
RibbonPanel Class See Also Send Feedback
Adds three stacked items to the panel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public IList<RibbonItem> AddStackedItems(
    RibbonItemData item1,
    RibbonItemData item2,
    RibbonItemData item3
)
Visual Basic
Public Function AddStackedItems ( _
    item1 As RibbonItemData, _
    item2 As RibbonItemData, _
    item3 As RibbonItemData _
) As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ AddStackedItems(
    RibbonItemData^ item1,
    RibbonItemData^ item2,
    RibbonItemData^ item3
)

Parameters

item1
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the first item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item2
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the second item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.
item3
Type: Autodesk.Revit.UI..::..RibbonItemData
Data containing information about the third item. This data must be of type PushButtonData, PulldownButtonData, ComboBoxData, or TextBoxData.

Return Value

A collection containing the added items.

Remarks

Each new item may either be a PushButton, PulldownButton, ComboBox or TextBox, depending upon the type of data passed in for each argument. The new items will be created as small-size horizontal controls, with the first stacked on top of the second in the panel.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when item1, item2 or item3 is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an item with item1.Name or item2.Name or item3.Name already exists in the panel or the data is not of the correct type.

See Also

RibbonPanel Class
AddStackedItems Overload
Autodesk.Revit.UI Namespace


Equals Method

[image]

Revit 2013 API
RibbonPanel..::..Equals Method
RibbonPanel Class See Also Send Feedback
Determines whether the specified Object is equal to the current Object.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
Another panel object.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


GetItems Method

[image]

Revit 2013 API
RibbonPanel..::..GetItems Method
RibbonPanel Class See Also Send Feedback
Gets a copy of the collection of RibbonItems assigned to the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<RibbonItem> GetItems()
Visual Basic
Public Function GetItems As IList(Of RibbonItem)
Visual C++
public:
IList<RibbonItem^>^ GetItems()

Remarks

This method gets the items assigned to the RibbonPanel.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


RibbonPanel Properties

[image] [image]

Revit 2013 API
RibbonPanel Properties
RibbonPanel Class See Also Send Feedback

The RibbonPanel type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.
Public property | Name | Gets or sets the name of the RibbonPanel.
Public property | Title | Gets or sets the text of the RibbonPanel.
Public property | Visible | Gets or sets a value indicating whether the RibbonPanel is displayed.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Enabled Property

[image]

Revit 2013 API
RibbonPanel..::..Enabled Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel can respond to user interaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set
Visual C++
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Field Value

True if the panel allows interaction, false if the panel disallows interaction with all the controls it contains.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Name Property

[image]

Revit 2013 API
RibbonPanel..::..Name Property
RibbonPanel Class See Also Send Feedback
Gets or sets the name of the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Remarks

The name will be displayed on the panel if the Text is not set.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Title Property

[image]

Revit 2013 API
RibbonPanel..::..Title Property
RibbonPanel Class See Also Send Feedback
Gets or sets the text of the RibbonPanel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

If this property is not set, the default value is its Name.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the title contains angle bracket.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


Visible Property

[image]

Revit 2013 API
RibbonPanel..::..Visible Property
RibbonPanel Class See Also Send Feedback
Gets or sets a value indicating whether the RibbonPanel is displayed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Visible { get; set; }
Visual Basic
Public Property Visible As Boolean
    Get
    Set
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

Field Value

True if the RibbonPanel is displayed; otherwise, false. The default is true.

See Also

RibbonPanel Class
Autodesk.Revit.UI Namespace


SplitButton Class

[image]

Revit 2013 API
SplitButton Class
Members Example See Also Send Feedback
The SplitButton object represents a button with a clickable button appearing above a pulldown.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SplitButton : PulldownButton
Visual Basic
Public Class SplitButton _
    Inherits PulldownButton
Visual C++
public ref class SplitButton : public PulldownButton

Remarks

Use of this class is not supported in Revit Macros.

Examples

CopyC#
private void AddSplitButton(RibbonPanel panel)
{
    string assembly = @"D:\Sample\HelloWorld\bin\Debug\Hello.dll";

    // create push buttons for split button drop down
    PushButtonData bOne = new PushButtonData("ButtonNameA", "Option One",
        assembly, "Hello.HelloOne");
    bOne.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\One.bmp"));

    PushButtonData bTwo = new PushButtonData("ButtonNameB", "Option Two",
        assembly, "Hello.HelloTwo");
    bTwo.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Two.bmp"));

    PushButtonData bThree = new PushButtonData("ButtonNameC", "Option Three",
        assembly, "Hello.HelloThree");
    bThree.LargeImage =
        new BitmapImage(new Uri(@"D:\Sample\HelloWorld\bin\Debug\Three.bmp"));

    SplitButtonData sb1 = new SplitButtonData("splitButton1", "Split");
    SplitButton sb = panel.AddItem(sb1) as SplitButton;
    sb.AddPushButton(bOne);
    sb.AddPushButton(bTwo);
    sb.AddPushButton(bThree);
}
CopyVB.NET
Private Sub AddSplitButton(ByVal panel As RibbonPanel)
    Dim assembly As String = "D:\Sample\HelloWorld\bin\Debug\Hello.dll"

    ' create push buttons for split button drop down
    Dim bOne As New PushButtonData("ButtonNameA", "Option One", assembly, "Hello.HelloOne")
    bOne.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\One.bmp"))

    Dim bTwo As New PushButtonData("ButtonNameB", "Option Two", assembly, "Hello.HelloTwo")
    bTwo.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Two.bmp"))

    Dim bThree As New PushButtonData("ButtonNameC", "Option Three", assembly, "Hello.HelloThree")
    bThree.LargeImage = New BitmapImage(New Uri("D:\Sample\HelloWorld\bin\Debug\Three.bmp"))

    Dim sb1 As New SplitButtonData("splitButton1", "Split")
    Dim sb As SplitButton = TryCast(panel.AddItem(sb1), SplitButton)
    sb.AddPushButton(bOne)
    sb.AddPushButton(bTwo)
    sb.AddPushButton(bThree)
End Sub

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PulldownButton
Autodesk.Revit.UI..::..SplitButton

See Also

SplitButton Members
Autodesk.Revit.UI Namespace


SplitButton Members

[image] [image]

Revit 2013 API
SplitButton Members
SplitButton Class Methods Properties See Also Send Feedback

The SplitButton type exposes the following members.

Methods

 | Name | Description
Public method | AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton.)
Public method | AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CurrentButton | Gets or sets the current PushButton of the SplitButton.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButton Methods

[image] [image]

Revit 2013 API
SplitButton Methods
SplitButton Class See Also Send Feedback

The SplitButton type exposes the following members.

Methods

 | Name | Description
Public method | AddPushButton | Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand. (Inherited from PulldownButton.)
Public method | AddSeparator | Adds a separator to the drop-down list. (Inherited from PulldownButton.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetItems | Gets a copy of the collection of buttons assigned to the pulldown button. (Inherited from PulldownButton.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButton Properties

[image] [image]

Revit 2013 API
SplitButton Properties
SplitButton Class See Also Send Feedback

The SplitButton type exposes the following members.

Properties

 | Name | Description
Public property | CurrentButton | Gets or sets the current PushButton of the SplitButton.
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | IsSynchronizedWithCurrentItem | Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


CurrentButton Property

[image]

Revit 2013 API
SplitButton..::..CurrentButton Property
SplitButton Class See Also Send Feedback
Gets or sets the current PushButton of the SplitButton.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public PushButton CurrentButton { get; set; }
Visual Basic
Public Property CurrentButton As PushButton
    Get
    Set
Visual C++
public:
property PushButton^ CurrentButton {
    PushButton^ get ();
    void set (PushButton^ value);
}

Remarks

This property is applicable only if IsSynchronizedWithCurrentItem is true. The default value of this property will be the first enabled PushButton in the drop down list after the SplitButton is shown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when trying to set the CurrentButton to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when trying to set the CurrentButton to a button which is not in current drop-down list.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when trying to set the CurrentButton if IsSynchronizedWithCurrentItem is false.

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


IsSynchronizedWithCurrentItem Property

[image]

Revit 2013 API
SplitButton..::..IsSynchronizedWithCurrentItem Property
SplitButton Class See Also Send Feedback
Indicates whether the top PushButton on the SplitButton changes based on the CurrentButton property.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool IsSynchronizedWithCurrentItem { get; set; }
Visual Basic
Public Property IsSynchronizedWithCurrentItem As Boolean
    Get
    Set
Visual C++
public:
property bool IsSynchronizedWithCurrentItem {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true the SplitButton uses the current PushButton's properties to display the image, text, tooltip, etc. and executes the current item when clicked. If it is false the first listed PushButton in the GetItems() return is shown, and executes this PushButton when clicked. If it is false the items in drop down list can only be executed by opening the drop down list and clicking an item in the list. The default value is true.

See Also

SplitButton Class
Autodesk.Revit.UI Namespace


SplitButtonData Class

[image]

Revit 2013 API
SplitButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a split button in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class SplitButtonData : PulldownButtonData
Visual Basic
Public Class SplitButtonData _
    Inherits PulldownButtonData
Visual C++
public ref class SplitButtonData : public PulldownButtonData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..PulldownButtonData
Autodesk.Revit.UI..::..SplitButtonData

See Also

SplitButtonData Members
Autodesk.Revit.UI Namespace


SplitButtonData Members

[image] [image]

Revit 2013 API
SplitButtonData Members
SplitButtonData Class Constructors Methods Properties See Also Send Feedback

The SplitButtonData type exposes the following members.

Constructors

 | Name | Description
Public method | SplitButtonData | Constructs a new instance of SplitButtonData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Constructor

[image]

Revit 2013 API
SplitButtonData Constructor
SplitButtonData Class See Also Send Feedback
Constructs a new instance of SplitButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public SplitButtonData(
    string name,
    string text
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
SplitButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::..String
The internal name of the new button.
text
Type: System..::..String

Remarks

This text will be displayed on the button if drop-down is empty. If sub-items are added, then the split button will display the current PushButton's text.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Methods

[image] [image]

Revit 2013 API
SplitButtonData Methods
SplitButtonData Class See Also Send Feedback

The SplitButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


SplitButtonData Properties

[image] [image]

Revit 2013 API
SplitButtonData Properties
SplitButtonData Class See Also Send Feedback

The SplitButtonData type exposes the following members.

Properties

 | Name | Description
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

SplitButtonData Class
Autodesk.Revit.UI Namespace


Tab Enumeration

[image]

Revit 2013 API
Tab Enumeration
See Also Send Feedback
An enumerated type listing static tabs which support addition of panels via the API.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum Tab
Visual Basic
Public Enumeration Tab
Visual C++
public enum class Tab

Members

Member name | Description
AddIns | The Add-Ins tab.
Analyze | The Analyze tab.

See Also

Autodesk.Revit.UI Namespace


TabbedDialogAction Delegate

[image]

Revit 2013 API
TabbedDialogAction Delegate
See Also Send Feedback
Delegate for tabbed dialog actions, such as OnOK, OnCancel and RestoreDefaults.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public delegate void TabbedDialogAction()
Visual Basic
Public Delegate Sub TabbedDialogAction
Visual C++
public delegate void TabbedDialogAction()

See Also

Autodesk.Revit.UI Namespace


TabbedDialogExtension Class

[image]

Revit 2013 API
TabbedDialogExtension Class
Members See Also Send Feedback
Contains the information required to create and implement the behavior for the new tab inside the Revit options dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class TabbedDialogExtension
Visual Basic
Public Class TabbedDialogExtension
Visual C++
public ref class TabbedDialogExtension

Remarks

Each page has an associated user interface control and the handlers of buttons Cancel, Restore Defaults and help can optionally be set. The size of the control is limited to 305 (height) x 288 (width) in physical pixels.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..TabbedDialogExtension

See Also

TabbedDialogExtension Members
Autodesk.Revit.UI Namespace


TabbedDialogExtension Members

[image] [image]

Revit 2013 API
TabbedDialogExtension Members
TabbedDialogExtension Class Constructors Methods Properties See Also Send Feedback

The TabbedDialogExtension type exposes the following members.

Constructors

 | Name | Description
Public method | TabbedDialogExtension | Constructs a extension instance with a control and ok action handler.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Control | The control.
Public property | OnCancelAction | The cancel handler.
Public property | OnOKAction | The ok handler.
Public property | OnRestoreDefaultsAction | The restore defaults handler.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


TabbedDialogExtension Constructor

[image]

Revit 2013 API
TabbedDialogExtension Constructor
TabbedDialogExtension Class See Also Send Feedback
Constructs a extension instance with a control and ok action handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TabbedDialogExtension(
    UserControl userControl,
    TabbedDialogAction onOK
)
Visual Basic
Public Sub New ( _
    userControl As UserControl, _
    onOK As TabbedDialogAction _
)
Visual C++
public:
TabbedDialogExtension(
    UserControl^ userControl,
    TabbedDialogAction^ onOK
)

Parameters

userControl
Type: System.Windows.Controls..::..UserControl
The control.
onOK
Type: Autodesk.Revit.UI..::..TabbedDialogAction
The ok action handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when userControl or onOK is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when userControl is already bound to another tabbed dialog.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


TabbedDialogExtension Methods

[image] [image]

Revit 2013 API
TabbedDialogExtension Methods
TabbedDialogExtension Class See Also Send Feedback

The TabbedDialogExtension type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


GetContextualHelp Method

[image]

Revit 2013 API
TabbedDialogExtension..::..GetContextualHelp Method
TabbedDialogExtension Class See Also Send Feedback
Gets the contextual help.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ContextualHelp GetContextualHelp()
Visual Basic
Public Function GetContextualHelp As ContextualHelp
Visual C++
public:
ContextualHelp^ GetContextualHelp()

Return Value

The contextual help assigned to the help button of the Revit options dialog, or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no binding assigned.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


SetContextualHelp Method

[image]

Revit 2013 API
TabbedDialogExtension..::..SetContextualHelp Method
TabbedDialogExtension Class See Also Send Feedback
Sets the contextual help.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void SetContextualHelp(
    ContextualHelp contextualHelp
)
Visual Basic
Public Sub SetContextualHelp ( _
    contextualHelp As ContextualHelp _
)
Visual C++
public:
void SetContextualHelp(
    ContextualHelp^ contextualHelp
)

Parameters

contextualHelp
Type: Autodesk.Revit.UI..::..ContextualHelp
The contextual help.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


TabbedDialogExtension Properties

[image] [image]

Revit 2013 API
TabbedDialogExtension Properties
TabbedDialogExtension Class See Also Send Feedback

The TabbedDialogExtension type exposes the following members.

Properties

 | Name | Description
Public property | Control | The control.
Public property | OnCancelAction | The cancel handler.
Public property | OnOKAction | The ok handler.
Public property | OnRestoreDefaultsAction | The restore defaults handler.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


Control Property

[image]

Revit 2013 API
TabbedDialogExtension..::..Control Property
TabbedDialogExtension Class See Also Send Feedback
The control.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public UserControl Control { get; }
Visual Basic
Public ReadOnly Property Control As UserControl
    Get
Visual C++
public:
property UserControl^ Control {
    UserControl^ get ();
}

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


OnCancelAction Property

[image]

Revit 2013 API
TabbedDialogExtension..::..OnCancelAction Property
TabbedDialogExtension Class See Also Send Feedback
The cancel handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TabbedDialogAction OnCancelAction { get; set; }
Visual Basic
Public Property OnCancelAction As TabbedDialogAction
    Get
    Set
Visual C++
public:
property TabbedDialogAction^ OnCancelAction {
    TabbedDialogAction^ get ();
    void set (TabbedDialogAction^ value);
}

Remarks

This handler will be invoked when the "Cancel" button in Revit options dialog is clicked. The Revit options dialog will be closed directly if this property was set to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


OnOKAction Property

[image]

Revit 2013 API
TabbedDialogExtension..::..OnOKAction Property
TabbedDialogExtension Class See Also Send Feedback
The ok handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TabbedDialogAction OnOKAction { get; }
Visual Basic
Public ReadOnly Property OnOKAction As TabbedDialogAction
    Get
Visual C++
public:
property TabbedDialogAction^ OnOKAction {
    TabbedDialogAction^ get ();
}

Remarks

This handler will be invoked when the "Ok" button in Revit options dialog is clicked.

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


OnRestoreDefaultsAction Property

[image]

Revit 2013 API
TabbedDialogExtension..::..OnRestoreDefaultsAction Property
TabbedDialogExtension Class See Also Send Feedback
The restore defaults handler.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public TabbedDialogAction OnRestoreDefaultsAction { get; set; }
Visual Basic
Public Property OnRestoreDefaultsAction As TabbedDialogAction
    Get
    Set
Visual C++
public:
property TabbedDialogAction^ OnRestoreDefaultsAction {
    TabbedDialogAction^ get ();
    void set (TabbedDialogAction^ value);
}

Remarks

This handler will be invoked when the "Restore Defaults" button in Revit options dialog is clicked and the handler should apply only to options set on this page. There is no "Restore Defaults" button in Revit options dialog if this property was set to nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

TabbedDialogExtension Class
Autodesk.Revit.UI Namespace


TaskDialog Class

[image]

Revit 2013 API
TaskDialog Class
Members Example See Also Send Feedback
A task dialog is a dialog box that can be used to display information and receive simple input from the user. It has a common set of controls that are arranged in a standard order to assure consistent look and feel.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TaskDialog : APIObject
Visual Basic
Public Class TaskDialog _
    Inherits APIObject
Visual C++
public ref class TaskDialog : public APIObject

Remarks

There are two ways to create and show a task dialog to the user. The first option is to construct the TaskDialog, set its properties individually, and use the instance method Show() to show it to the user. The second is to use one of the static Show() methods to construct and show the dialog in one step. When you use the static methods only a subset of the options can be specified.

Please follow Revit standards to create task dialogs. The standards are listed in the remarks of each property or method.

Examples

CopyC#
// Get the application and document from external command data.
Application app = commandData.Application.Application;
Document activeDoc = commandData.Application.ActiveUIDocument.Document;

// Creates a Revit task dialog to communicate information to the user.
TaskDialog mainDialog = new TaskDialog("Hello, Revit!");
mainDialog.MainInstruction = "Hello, Revit!";
mainDialog.MainContent =
    "This sample shows how to use a Revit task dialog to communicate with the user."
    + "The command links below open additional task dialogs with more information.";

// Add commmandLink options to task dialog
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink1,
                          "View information about the Revit installation");
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink2,
                          "View information about the active document");

// Set common buttons and default button. If no CommonButton or CommandLink is added,
// task dialog will show a Close button by default
mainDialog.CommonButtons = TaskDialogCommonButtons.Close;
mainDialog.DefaultButton = TaskDialogResult.Close;

// Set footer text. Footer text is usually used to link to the help document.
mainDialog.FooterText =
    "<a href=\"http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=2484975 \">"
    + "Click here for the Revit API Developer Center</a>";

TaskDialogResult tResult = mainDialog.Show();

// If the user clicks the first command link, a simple Task Dialog
// with only a Close button shows information about the Revit installation.
if (TaskDialogResult.CommandLink1 == tResult)
{
    TaskDialog dialog_CommandLink1 = new TaskDialog("Revit Build Information");
    dialog_CommandLink1.MainInstruction =
        "Revit Version Name is: " + app.VersionName + "\n"
        + "Revit Version Number is: " + app.VersionNumber + "\n"
        + "Revit Version Build is: " + app.VersionBuild;

    dialog_CommandLink1.Show();

}

// If the user clicks the second command link, a simple Task Dialog
// created by static method shows information about the active document
else if (TaskDialogResult.CommandLink2 == tResult)
{
    TaskDialog.Show("Active Document Inforamtion",
        "Active document: " + activeDoc.Title + "\n"
        + "Active view name: " + activeDoc.ActiveView.Name);
}
CopyVB.NET
' Get the application and document from external command data.
Dim app As Application = commandData.Application.Application
Dim activeDoc As Document = commandData.Application.ActiveUIDocument.Document

' Creates a Revit task dialog to communicate information to the user.
Dim mainDialog As New TaskDialog("Hello, Revit!")
mainDialog.MainInstruction = "Hello, Revit!"
mainDialog.MainContent = "This sample shows how to use a Revit task dialog to communicate with the user." + "The command links below open additional task dialogs with more information."

' Add commmandLink options to task dialog
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink1, "View information about the Revit installation")
mainDialog.AddCommandLink(TaskDialogCommandLinkId.CommandLink2, "View information about the active document")

' Set common buttons and default button. If no CommonButton or CommandLink is added,
' task dialog will show a Close button by default
mainDialog.CommonButtons = TaskDialogCommonButtons.Close
mainDialog.DefaultButton = TaskDialogResult.Close

' Set footer text. Footer text is usually used to link to the help document.
mainDialog.FooterText = "<a href=""http://usa.autodesk.com/adsk/servlet/index?siteID=123112&id=2484975 "">" + "Click here for the Revit API Developer Center</a>"

Dim tResult As TaskDialogResult = mainDialog.Show()

' If the user clicks the first command link, a simple Task Dialog
' with only a Close button shows information about the Revit installation.
If TaskDialogResult.CommandLink1 = tResult Then
    Dim dialog_CommandLink1 As New TaskDialog("Revit Build Information")
    dialog_CommandLink1.MainInstruction = "Revit Version Name is: " + app.VersionName + vbLf + "Revit Version Number is: " + app.VersionNumber + vbLf + "Revit Version Build is: " + app.VersionBuild

    dialog_CommandLink1.Show()

    ' If the user clicks the second command link, a simple Task Dialog
    ' created by static method shows information about the active document
ElseIf TaskDialogResult.CommandLink2 = tResult Then
    TaskDialog.Show("Active Document Inforamtion", "Active document: " + activeDoc.Title + vbLf + "Active view name: " + activeDoc.ActiveView.Name)
End If

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI..::..TaskDialog

See Also

TaskDialog Members
Autodesk.Revit.UI Namespace


TaskDialog Members

[image] [image]

Revit 2013 API
TaskDialog Members
TaskDialog Class Constructors Methods Properties See Also Send Feedback

The TaskDialog type exposes the following members.

Constructors

 | Name | Description
Public method | TaskDialog | Creates a task dialog with title.

Methods

 | Name | Description
Public method | AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
Public method | AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Show()()()() | Shows the task dialog.
 | Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
 | Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
 | Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WasVerificationChecked | Gets the status of the verification checkbox.

Properties

 | Name | Description
Public property | AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
Public property | CommonButtons | The push buttons displayed in the task dialog.
Public property | DefaultButton | The default button for the dialog.
Public property | ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
Public property | FooterText | FooterText is used in the footer area of the task dialog.
Public property | Id | The Id of the task dialog.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MainContent | MainContent is the smaller text that appears just below the main instructions.
Public property | MainIcon | The icon shown in the task dialog.
Public property | MainInstruction | The large primary text that appears at the top of a task dialog.
Public property | Title | Title of the task dialog.
Public property | TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
Public property | VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Constructor

[image]

Revit 2013 API
TaskDialog Constructor
TaskDialog Class See Also Send Feedback
Creates a task dialog with title.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialog(
    string title
)
Visual Basic
Public Sub New ( _
    title As String _
)
Visual C++
public:
TaskDialog(
    String^ title
)

Parameters

title
Type: System..::..String

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when title is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when title is an empty string.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Methods

[image] [image]

Revit 2013 API
TaskDialog Methods
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Methods

 | Name | Description
Public method | AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
Public method | AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Show()()()() | Shows the task dialog.
 | Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
 | Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
 | Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WasVerificationChecked | Gets the status of the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


AddCommandLink Method

[image] [image]

Revit 2013 API
TaskDialog..::..AddCommandLink Method
TaskDialog Class See Also Send Feedback
Adds a CommandLink to the TaskDialog.

Overload List

 | Name | Description
Public method | AddCommandLink(TaskDialogCommandLinkId, String) | Adds a CommandLink associated to the given id, displaying the indicating main content.
Public method | AddCommandLink(TaskDialogCommandLinkId, String, String) | Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.

See Also

TaskDialog Class
TaskDialog Members
Autodesk.Revit.UI Namespace


AddCommandLink Method (TaskDialogCommandLinkId, String)

[image]

Revit 2013 API
TaskDialog..::..AddCommandLink Method (TaskDialogCommandLinkId, String)
TaskDialog Class See Also Send Feedback
Adds a CommandLink associated to the given id, displaying the indicating main content.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddCommandLink(
    TaskDialogCommandLinkId id,
    string mainContent
)
Visual Basic
Public Sub AddCommandLink ( _
    id As TaskDialogCommandLinkId, _
    mainContent As String _
)
Visual C++
public:
void AddCommandLink(
    TaskDialogCommandLinkId id,
    String^ mainContent
)

Parameters

id
Type: Autodesk.Revit.UI..::..TaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
mainContent
Type: System..::..String
The main content of the CommandLink.

Remarks

Parameter mainContent cannot contain newlines.

If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.

CommandLinks will always be shown in the dialog in the order of their ids.

See Also

TaskDialog Class
AddCommandLink Overload
Autodesk.Revit.UI Namespace


AddCommandLink Method (TaskDialogCommandLinkId, String, String)

[image]

Revit 2013 API
TaskDialog..::..AddCommandLink Method (TaskDialogCommandLinkId, String, String)
TaskDialog Class See Also Send Feedback
Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void AddCommandLink(
    TaskDialogCommandLinkId id,
    string mainContent,
    string supportingContent
)
Visual Basic
Public Sub AddCommandLink ( _
    id As TaskDialogCommandLinkId, _
    mainContent As String, _
    supportingContent As String _
)
Visual C++
public:
void AddCommandLink(
    TaskDialogCommandLinkId id,
    String^ mainContent,
    String^ supportingContent
)

Parameters

id
Type: Autodesk.Revit.UI..::..TaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
mainContent
Type: System..::..String
The main content of the CommandLink.
supportingContent
Type: System..::..String
The main content of the CommandLink.

Remarks

Parameter mainContent cannot contain newlines.

If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.

CommandLinks will always be shown in the dialog in the order of their ids.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when mainContent is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when mainContent is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the mainContent contains newline characters.

See Also

TaskDialog Class
AddCommandLink Overload
Autodesk.Revit.UI Namespace


Show Method

[image] [image]

Revit 2013 API
TaskDialog..::..Show Method
TaskDialog Class See Also Send Feedback
Shows a task dialog.

Overload List

 | Name | Description
Public method | Show()()()() | Shows the task dialog.
 | Show(String, String) | Shows a task dialog with title, main instruction and a Close button.
 | Show(String, String, TaskDialogCommonButtons) | Shows a task dialog with title, main instruction and common buttons.
 | Show(String, String, TaskDialogCommonButtons, TaskDialogResult) | Shows a task dialog with title, main instruction, common buttons and default buttons.

See Also

TaskDialog Class
TaskDialog Members
Autodesk.Revit.UI Namespace


Show Method

[image]

Revit 2013 API
TaskDialog..::..Show Method
TaskDialog Class See Also Send Feedback
Shows the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult Show()
Visual Basic
Public Function Show As TaskDialogResult
Visual C++
public:
TaskDialogResult Show()

Return Value

The user's response to the task dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the task dialog is shown out of main thread of Revit.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String)

[image]

Revit 2013 API
TaskDialog..::..Show Method (String, String)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction and a Close button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction
)
Visual Basic
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction
)

Parameters

title
Type: System..::..String
The title of the task dialog.
mainInstruction
Type: System..::..String
The main instruction of the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String, TaskDialogCommonButtons)

[image]

Revit 2013 API
TaskDialog..::..Show Method (String, String, TaskDialogCommonButtons)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction and common buttons.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction,
    TaskDialogCommonButtons buttons
)
Visual Basic
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String, _
    buttons As TaskDialogCommonButtons _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction,
    TaskDialogCommonButtons buttons
)

Parameters

title
Type: System..::..String
The title of the task dialog.
mainInstruction
Type: System..::..String
The main instruction of the task dialog.
buttons
Type: Autodesk.Revit.UI..::..TaskDialogCommonButtons
The common buttons to be shown the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


Show Method (String, String, TaskDialogCommonButtons, TaskDialogResult)

[image]

Revit 2013 API
TaskDialog..::..Show Method (String, String, TaskDialogCommonButtons, TaskDialogResult)
TaskDialog Class See Also Send Feedback
Shows a task dialog with title, main instruction, common buttons and default buttons.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public static TaskDialogResult Show(
    string title,
    string mainInstruction,
    TaskDialogCommonButtons buttons,
    TaskDialogResult defaultButton
)
Visual Basic
Public Shared Function Show ( _
    title As String, _
    mainInstruction As String, _
    buttons As TaskDialogCommonButtons, _
    defaultButton As TaskDialogResult _
) As TaskDialogResult
Visual C++
public:
static TaskDialogResult Show(
    String^ title,
    String^ mainInstruction,
    TaskDialogCommonButtons buttons,
    TaskDialogResult defaultButton
)

Parameters

title
Type: System..::..String
The title of the task dialog.
mainInstruction
Type: System..::..String
The main instruction of the task dialog.
buttons
Type: Autodesk.Revit.UI..::..TaskDialogCommonButtons
The common buttons to be shown the task dialog.
defaultButton
Type: Autodesk.Revit.UI..::..TaskDialogResult
The default button of the task dialog.

Return Value

The user's response to the task dialog.

See Also

TaskDialog Class
Show Overload
Autodesk.Revit.UI Namespace


WasVerificationChecked Method

[image]

Revit 2013 API
TaskDialog..::..WasVerificationChecked Method
TaskDialog Class See Also Send Feedback
Gets the status of the verification checkbox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool WasVerificationChecked()
Visual Basic
Public Function WasVerificationChecked As Boolean
Visual C++
public:
bool WasVerificationChecked()

Return Value

Whether the verification checkbox is checked.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the task dialog does not have verification checkbox or the task dialog is not shown yet.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialog Properties

[image] [image]

Revit 2013 API
TaskDialog Properties
TaskDialog Class See Also Send Feedback

The TaskDialog type exposes the following members.

Properties

 | Name | Description
Public property | AllowCancellation | Whether the task dialog can be cancelled if no cancel button is specified.
Public property | CommonButtons | The push buttons displayed in the task dialog.
Public property | DefaultButton | The default button for the dialog.
Public property | ExpandedContent | ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.
Public property | FooterText | FooterText is used in the footer area of the task dialog.
Public property | Id | The Id of the task dialog.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | MainContent | MainContent is the smaller text that appears just below the main instructions.
Public property | MainIcon | The icon shown in the task dialog.
Public property | MainInstruction | The large primary text that appears at the top of a task dialog.
Public property | Title | Title of the task dialog.
Public property | TitleAutoPrefix | Whether the TaskDialog's title will automatically have the add-in name added as a prefix.
Public property | VerificationText | VerificationText is used to label the verification checkbox.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


AllowCancellation Property

[image]

Revit 2013 API
TaskDialog..::..AllowCancellation Property
TaskDialog Class See Also Send Feedback
Whether the task dialog can be cancelled if no cancel button is specified.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool AllowCancellation { get; set; }
Visual Basic
Public Property AllowCancellation As Boolean
    Get
    Set
Visual C++
public:
property bool AllowCancellation {
    bool get ();
    void set (bool value);
}

Remarks

The default value is true. If there is a cancel button in the task dialog, the it always can be cancelled.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


CommonButtons Property

[image]

Revit 2013 API
TaskDialog..::..CommonButtons Property
TaskDialog Class See Also Send Feedback
The push buttons displayed in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialogCommonButtons CommonButtons { get; set; }
Visual Basic
Public Property CommonButtons As TaskDialogCommonButtons
    Get
    Set
Visual C++
public:
property TaskDialogCommonButtons CommonButtons {
    TaskDialogCommonButtons get ();
    void set (TaskDialogCommonButtons value);
}

Remarks

If no common button or CommandLink is added to the task dialog, the dialog will contain the Close common button by default.

Revit task dialogs are following these conventions for commit button usage:

  • Use a single Close button instead of a single OK button on informational messages.
  • Use a question at the end of the Main Instruction with a Yes/No combo (or Yes/No/Cancel) instead of OK/Cancel. This should work 99% of the time. For example: “Are you sure you want to overwrite the file?” and use Yes/No buttons.
  • Do not customize the button names unless there is a very good reason to do so. For example, “Are you sure you want to save the file?” would use Yes/No buttons and not Save/No or Save/Cancel.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


DefaultButton Property

[image]

Revit 2013 API
TaskDialog..::..DefaultButton Property
TaskDialog Class See Also Send Feedback
The default button for the dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialogResult DefaultButton { get; set; }
Visual Basic
Public Property DefaultButton As TaskDialogResult
    Get
    Set
Visual C++
public:
property TaskDialogResult DefaultButton {
    TaskDialogResult get ();
    void set (TaskDialogResult value);
}

Remarks

If DefaultButton is TaskDialogResult.None or its value does not correspond to any CommonButton or CommandLink in the dialog, then the first button in the dialog will be the default.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


ExpandedContent Property

[image]

Revit 2013 API
TaskDialog..::..ExpandedContent Property
TaskDialog Class See Also Send Feedback
ExpandedContent is hidden by default and will display at the bottom of the task dialog when the "Show details" button is pressed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string ExpandedContent { get; set; }
Visual Basic
Public Property ExpandedContent As String
    Get
    Set
Visual C++
public:
property String^ ExpandedContent {
    String^ get ();
    void set (String^ value);
}

Remarks

If added to a dialog, a Show/Hide toggle button displays at the bottom of the task dialog. The Expanded Content is hidden by default. This area is used when even more information needs to be relayed to the user than space allows. It is rarely used, but can be used for showing technical information passed through in a variable, for example back-end error information, lists of files, etc. Variable information should always be introduced with a lead-in sentence.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


FooterText Property

[image]

Revit 2013 API
TaskDialog..::..FooterText Property
TaskDialog Class See Also Send Feedback
FooterText is used in the footer area of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string FooterText { get; set; }
Visual Basic
Public Property FooterText As String
    Get
    Set
Visual C++
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


Id Property

[image]

Revit 2013 API
TaskDialog..::..Id Property
TaskDialog Class See Also Send Feedback
The Id of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

Remarks

Id is used as TaskDialogShowingEventArgs.DialogId for DialogBoxShowing events.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainContent Property

[image]

Revit 2013 API
TaskDialog..::..MainContent Property
TaskDialog Class See Also Send Feedback
MainContent is the smaller text that appears just below the main instructions.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string MainContent { get; set; }
Visual Basic
Public Property MainContent As String
    Get
    Set
Visual C++
public:
property String^ MainContent {
    String^ get ();
    void set (String^ value);
}

Remarks

The Main Content is optional. It should be used to give further explanation to the user, such as how to correct the problem or work around the situation. It displays in a smaller black font below the main instructions. Follow these guidelines:
  • Text should be clear and jargon free.
  • Main content should not simply restate the main instructions in a different way, they should contain additional information that builds upon or reinforces the main instructions.
  • Main content should be written in sentence format (normal capitalization and punctuation).
  • Address the user directly as “you” when needed.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainIcon Property

[image]

Revit 2013 API
TaskDialog..::..MainIcon Property
TaskDialog Class See Also Send Feedback
The icon shown in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TaskDialogIcon MainIcon { get; set; }
Visual Basic
Public Property MainIcon As TaskDialogIcon
    Get
    Set
Visual C++
public:
property TaskDialogIcon MainIcon {
    TaskDialogIcon get ();
    void set (TaskDialogIcon value);
}

Remarks

There is no icon by default.

Task dialogs in Revit rarely use icons, to reduce the visual clutter shown to the user. Only one icon can be used in the task dialog, the Warning (!) icon, and it should be used only when there is a risk of data loss or significant time lost. If there is no data loss or time lost as a possible result of the message, do not use the icon.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


MainInstruction Property

[image]

Revit 2013 API
TaskDialog..::..MainInstruction Property
TaskDialog Class See Also Send Feedback
The large primary text that appears at the top of a task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string MainInstruction { get; set; }
Visual Basic
Public Property MainInstruction As String
    Get
    Set
Visual C++
public:
property String^ MainInstruction {
    String^ get ();
    void set (String^ value);
}

Remarks

It should concisely sum up the problem or situation that is causing the message to display. Follow these guidelines:

  • Every task dialog includes a main instruction.
  • Text should not exceed three lines.
  • Text should use plain language and be jargon free.
  • Main instructions should be written in sentence format – normal capitalization and punctuation.
  • Address the user directly as “you” when appropriate.
  • When presented with multiple command link options the standard final line for the main instructions should be, "What do you want to do?”

Revit will automatically break lines to make the message fit well. "\n" also breaks down to the next line. For a paragraph break, use "\n\n".

Hyperlinks added to the main instructions will not be enabled when the dialog is shown on Vista.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


Title Property

[image]

Revit 2013 API
TaskDialog..::..Title Property
TaskDialog Class See Also Send Feedback
Title of the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string Title { get; set; }
Visual Basic
Public Property Title As String
    Get
    Set
Visual C++
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Remarks

Titles of task dialogs should be unique. Do not reuse the same title for multiple task dialogs.

Newline characters are not allowed in Title.

When the dialogs is shown, Revit will put “External Command Name –“ or “External Application –“ in the front of the value by default. Examples:

  • Plug-in Name – No Rooms to Calculate
  • Plug-in Name – Invalid Value for Length
You can suppress it by setting TitleAutoPrefix to false.

Titles should describe the nature of the problem or state the situation that currently exists. The title tells the user why they are getting the message, not what they are supposed to do.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the value to nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the value to an empty string or string contains newline characters.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TitleAutoPrefix Property

[image]

Revit 2013 API
TaskDialog..::..TitleAutoPrefix Property
TaskDialog Class See Also Send Feedback
Whether the TaskDialog's title will automatically have the add-in name added as a prefix.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool TitleAutoPrefix { get; set; }
Visual Basic
Public Property TitleAutoPrefix As Boolean
    Get
    Set
Visual C++
public:
property bool TitleAutoPrefix {
    bool get ();
    void set (bool value);
}

Remarks

The default value is true.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


VerificationText Property

[image]

Revit 2013 API
TaskDialog..::..VerificationText Property
TaskDialog Class See Also Send Feedback
VerificationText is used to label the verification checkbox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string VerificationText { get; set; }
Visual Basic
Public Property VerificationText As String
    Get
    Set
Visual C++
public:
property String^ VerificationText {
    String^ get ();
    void set (String^ value);
}

Remarks

If VerificationText is set, a checkbox with the text will be shown. You can get the response of checkbox by checking the return value of the WasVerificationChecked() method.

See Also

TaskDialog Class
Autodesk.Revit.UI Namespace


TaskDialogCommandLinkId Enumeration

[image]

Revit 2013 API
TaskDialogCommandLinkId Enumeration
See Also Send Feedback
Enum to specify the Id of CommandLink.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogCommandLinkId
Visual Basic
Public Enumeration TaskDialogCommandLinkId
Visual C++
public enum class TaskDialogCommandLinkId

Members

Member name | Description
CommandLink1 | CommandLink1.
CommandLink2 | CommandLink2.
CommandLink3 | CommandLink3.
CommandLink4 | CommandLink4.

See Also

Autodesk.Revit.UI Namespace


TaskDialogCommonButtons Enumeration

[image]

Revit 2013 API
TaskDialogCommonButtons Enumeration
See Also Send Feedback
A enumerated type containing the standard buttons available for Task Dialogs.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
[FlagsAttribute]
public enum TaskDialogCommonButtons
Visual Basic
<FlagsAttribute> _
Public Enumeration TaskDialogCommonButtons
Visual C++
[FlagsAttribute]
public enum class TaskDialogCommonButtons

Members

Member name | Description
None | No common button.
Ok | OK button.
Yes | Yes button.
No | No button.
Cancel | Cancel button.
Retry | Retry button.
Close | Close button.

See Also

Autodesk.Revit.UI Namespace


TaskDialogIcon Enumeration

[image]

Revit 2013 API
TaskDialogIcon Enumeration
See Also Send Feedback
Standard icons to be used in the task dialog.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogIcon
Visual Basic
Public Enumeration TaskDialogIcon
Visual C++
public enum class TaskDialogIcon

Members

Member name | Description
TaskDialogIconNone | No icon.
TaskDialogIconWarning | Warning icon.

See Also

Autodesk.Revit.UI Namespace


TaskDialogResult Enumeration

[image]

Revit 2013 API
TaskDialogResult Enumeration
See Also Send Feedback
Enum to specify the task dialog result.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public enum TaskDialogResult
Visual Basic
Public Enumeration TaskDialogResult
Visual C++
public enum class TaskDialogResult

Members

Member name | Description
None | Nothing is returned from the task dialog.
Ok | The return value for TaskDialogCommonButtons.Ok.
Cancel | The return value for TaskDialogCommonButtons.Cancel or the task dialog is cancelled by ESC, Alt+F4 or the X close button.
Retry | The return value for TaskDialogCommonButtons.Retry.
Yes | The return value for TaskDialogCommonButtons.Yes.
No | The return value for TaskDialogCommonButtons.No.
Close | The return value for TaskDialogCommonButtons.Close.
CommandLink1 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink1.
CommandLink2 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink2.
CommandLink3 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink3.
CommandLink4 | The return value for CommandLink whose Id is TaskDialogCommmandLinkId.CommandLink4.

See Also

Autodesk.Revit.UI Namespace


TextBox Class

[image]

Revit 2013 API
TextBox Class
Members See Also Send Feedback
The TextBox object represents text-based control that allows the user to enter text.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TextBox : RibbonItem
Visual Basic
Public Class TextBox _
    Inherits RibbonItem
Visual C++
public ref class TextBox : public RibbonItem

Remarks

The ItemText property inherited from RibbonItem has no effect. The text entered in the TextBox is edited by the UI user is accepted only if the user presses the Enter key or click the image button when ShowImageAsButton is true. If the user clicks off of this component without pressing Enter or click the image button; then the text will be reverted to the previous value. Use of this class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..TextBox

See Also

TextBox Members
Autodesk.Revit.UI Namespace


TextBox Members

[image] [image]

Revit 2013 API
TextBox Members
TextBox Class Methods Properties Events See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the TextBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | PromptText | The prompt text for the text box.
Public property | SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
Public property | ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Value | The object that supplies the text value.
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Public property | Width | Gets or sets the width of the TextBox.

Events

 | Name | Description
Public event | EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Methods

[image] [image]

Revit 2013 API
TextBox Methods
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Properties

[image] [image]

Revit 2013 API
TextBox Properties
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Properties

 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the TextBox.
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | PromptText | The prompt text for the text box.
Public property | SelectTextOnFocus | A value that indicates if the text is selected when the text box gains focus.
Public property | ShowImageAsButton | Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Value | The object that supplies the text value.
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)
Public property | Width | Gets or sets the width of the TextBox.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
TextBox..::..Image Property
TextBox Class See Also Send Feedback
The image of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


PromptText Property

[image]

Revit 2013 API
TextBox..::..PromptText Property
TextBox Class See Also Send Feedback
The prompt text for the text box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public string PromptText { get; set; }
Visual Basic
Public Property PromptText As String
    Get
    Set
Visual C++
public:
property String^ PromptText {
    String^ get ();
    void set (String^ value);
}

Remarks

Prompt text is displayed when the text box is empty and does not have keyboard focus. This text is displayed in italics. The default value is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

TextBox Class
Autodesk.Revit.UI Namespace


SelectTextOnFocus Property

[image]

Revit 2013 API
TextBox..::..SelectTextOnFocus Property
TextBox Class See Also Send Feedback
A value that indicates if the text is selected when the text box gains focus.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool SelectTextOnFocus { get; set; }
Visual Basic
Public Property SelectTextOnFocus As Boolean
    Get
    Set
Visual C++
public:
property bool SelectTextOnFocus {
    bool get ();
    void set (bool value);
}

Remarks

If the value is true all the text in the text box will be selected when the text box gets keyboard focus. If it is false the text is not selected. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


ShowImageAsButton Property

[image]

Revit 2013 API
TextBox..::..ShowImageAsButton Property
TextBox Class See Also Send Feedback
Gets or sets a value that indicates if the Image set in the text box should be displayed as a clickable button.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public bool ShowImageAsButton { get; set; }
Visual Basic
Public Property ShowImageAsButton As Boolean
    Get
    Set
Visual C++
public:
property bool ShowImageAsButton {
    bool get ();
    void set (bool value);
}

Remarks

If this property is true, the image will shown as a button inside the textbox. Clicking this button will trigger the EnterPressed event. The default value is false.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Value Property

[image]

Revit 2013 API
TextBox..::..Value Property
TextBox Class See Also Send Feedback
The object that supplies the text value.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set
Visual C++
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

Remarks

The value assigned to the TextBox can be a String or any other data type. If the type is not a String the TextBox will display the return of the ToString() method. When the text is edited in the UI, the type of Value will always be String.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


Width Property

[image]

Revit 2013 API
TextBox..::..Width Property
TextBox Class See Also Send Feedback
Gets or sets the width of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Remarks

The value for this property must be positive and cannot be Infinity. This value is interpreted in device-independent units (1/96th inch) measurement device-independent units. The default value is 200.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBox Events

[image] [image]

Revit 2013 API
TextBox Events
TextBox Class See Also Send Feedback

The TextBox type exposes the following members.

Events

 | Name | Description
Public event | EnterPressed | Subscribe to this event to be notified when the Enter button is pressed in the text box.

See Also

TextBox Class
Autodesk.Revit.UI Namespace


EnterPressed Event

[image]

Revit 2013 API
TextBox..::..EnterPressed Event
TextBox Class See Also Send Feedback
Subscribe to this event to be notified when the Enter button is pressed in the text box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<TextBoxEnterPressedEventArgs> EnterPressed
Visual Basic
Public Event EnterPressed As EventHandler(Of TextBoxEnterPressedEventArgs)
Visual C++
public:
 event EventHandler<TextBoxEnterPressedEventArgs^>^ EnterPressed {
    void add (EventHandler<TextBoxEnterPressedEventArgs^>^ value);
    void remove (EventHandler<TextBoxEnterPressedEventArgs^>^ value);
}

See Also

TextBox Class
Autodesk.Revit.UI Namespace


TextBoxData Class

[image]

Revit 2013 API
TextBoxData Class
Members See Also Send Feedback
This class contains information necessary to construct a text box in the Ribbon.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class TextBoxData : RibbonItemData
Visual Basic
Public Class TextBoxData _
    Inherits RibbonItemData
Visual C++
public ref class TextBoxData : public RibbonItemData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..TextBoxData

See Also

TextBoxData Members
Autodesk.Revit.UI Namespace


TextBoxData Members

[image] [image]

Revit 2013 API
TextBoxData Members
TextBoxData Class Constructors Methods Properties See Also Send Feedback

The TextBoxData type exposes the following members.

Constructors

 | Name | Description
Public method | TextBoxData | Constructs a new instance of TextBoxData.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Image | The image of the TextBox.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Constructor

[image]

Revit 2013 API
TextBoxData Constructor
TextBoxData Class See Also Send Feedback
Constructs a new instance of TextBoxData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public TextBoxData(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)
Visual C++
public:
TextBoxData(
    String^ name
)

Parameters

name
Type: System..::..String
The internal name of the TextBoxData.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for name.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for name.

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Methods

[image] [image]

Revit 2013 API
TextBoxData Methods
TextBoxData Class See Also Send Feedback

The TextBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


TextBoxData Properties

[image] [image]

Revit 2013 API
TextBoxData Properties
TextBoxData Class See Also Send Feedback

The TextBoxData type exposes the following members.

Properties

 | Name | Description
Public property | Image | The image of the TextBox.
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


Image Property

[image]

Revit 2013 API
TextBoxData..::..Image Property
TextBoxData Class See Also Send Feedback
The image of the TextBox.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ImageSource Image { get; set; }
Visual Basic
Public Property Image As ImageSource
    Get
    Set
Visual C++
public:
property ImageSource^ Image {
    ImageSource^ get ();
    void set (ImageSource^ value);
}

Remarks

The image will be shown on the left side of the item. The best size is 16 x 16 pixels.

See Also

TextBoxData Class
Autodesk.Revit.UI Namespace


ToggleButton Class

[image]

Revit 2013 API
ToggleButton Class
Members See Also Send Feedback
The ToggleButton object represents a button that has been added to a RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ToggleButton : PushButton
Visual Basic
Public Class ToggleButton _
    Inherits PushButton
Visual C++
public ref class ToggleButton : public PushButton

Remarks

Use of this class is not supported in Revit Macros.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItem
Autodesk.Revit.UI..::..RibbonButton
Autodesk.Revit.UI..::..PushButton
Autodesk.Revit.UI..::..ToggleButton

See Also

ToggleButton Members
Autodesk.Revit.UI Namespace


ToggleButton Members

[image] [image]

Revit 2013 API
ToggleButton Members
ToggleButton Class Methods Properties See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button. (Inherited from PushButton.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButton.)
Public property | ClassName | The name of the class containing the implementation for the command. (Inherited from PushButton.)
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButton Methods

[image] [image]

Revit 2013 API
ToggleButton Methods
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from RibbonItem.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItem.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button. (Inherited from RibbonItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButton Properties

[image] [image]

Revit 2013 API
ToggleButton Properties
ToggleButton Class See Also Send Feedback

The ToggleButton type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button. (Inherited from PushButton.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButton.)
Public property | ClassName | The name of the class containing the implementation for the command. (Inherited from PushButton.)
Public property | Enabled | Gets or sets a value indicating whether the item is enabled. (Inherited from RibbonItem.)
Public property | Image | The image of the button. (Inherited from RibbonButton.)
Public property | IsEnabledByContext | Indicates if this button can be executed. True if the pushbutton is permitted to be executed based on the current Revit context (active document, active view and active tool). False if the pushbutton is disabled because of the active context. (Inherited from RibbonButton.)
Public property | ItemText | Gets or sets the text displayed on the item. (Inherited from RibbonItem.)
Public property | ItemType | Gets the item type. (Inherited from RibbonItem.)
Public property | LargeImage | The large image shown on the button. (Inherited from RibbonButton.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItem.)
Public property | Name | The name of the item. (Inherited from RibbonItem.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItem.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItem.)
Public property | Visible | Gets or sets a value indicating whether the item is visible. (Inherited from RibbonItem.)

See Also

ToggleButton Class
Autodesk.Revit.UI Namespace


ToggleButtonData Class

[image]

Revit 2013 API
ToggleButtonData Class
Members See Also Send Feedback
This class contains information necessary to construct a toggle button in a RadioButtonGroup.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class ToggleButtonData : PushButtonData
Visual Basic
Public Class ToggleButtonData _
    Inherits PushButtonData
Visual C++
public ref class ToggleButtonData : public PushButtonData

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..RibbonItemData
Autodesk.Revit.UI..::..ButtonData
Autodesk.Revit.UI..::..PushButtonData
Autodesk.Revit.UI..::..ToggleButtonData

See Also

ToggleButtonData Members
Autodesk.Revit.UI Namespace


ToggleButtonData Members

[image] [image]

Revit 2013 API
ToggleButtonData Members
ToggleButtonData Class Constructors Methods Properties See Also Send Feedback

The ToggleButtonData type exposes the following members.

Constructors

 | Name | Description
Public method | ToggleButtonData(String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.
Public method | ToggleButtonData(String, String, String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
Public property | ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor

[image] [image]

Revit 2013 API
ToggleButtonData Constructor
ToggleButtonData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToggleButtonData(String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.
Public method | ToggleButtonData(String, String, String, String) | Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.

See Also

ToggleButtonData Class
ToggleButtonData Members
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor (String, String)

[image]

Revit 2013 API
ToggleButtonData Constructor (String, String)
ToggleButtonData Class See Also Send Feedback
Constructs a new instance of ToggleButtonData, where the ToggleButton will not be associated to an ExternalCommand.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ToggleButtonData(
    string name,
    string text
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String _
)
Visual C++
public:
ToggleButtonData(
    String^ name,
    String^ text
)

Parameters

name
Type: System..::..String
The internal name of the new button.
text
Type: System..::..String
The user visible text seen on the new button.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ToggleButtonData Class
ToggleButtonData Overload
Autodesk.Revit.UI Namespace


ToggleButtonData Constructor (String, String, String, String)

[image]

Revit 2013 API
ToggleButtonData Constructor (String, String, String, String)
ToggleButtonData Class See Also Send Feedback
Constructs a new instance of ToggleButtonData, where the ToggleButton will execute an ExternalCommand when clicked.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ToggleButtonData(
    string name,
    string text,
    string assemblyName,
    string className
)
Visual Basic
Public Sub New ( _
    name As String, _
    text As String, _
    assemblyName As String, _
    className As String _
)
Visual C++
public:
ToggleButtonData(
    String^ name,
    String^ text,
    String^ assemblyName,
    String^ className
)

Parameters

name
Type: System..::..String
The internal name of the new button.
text
Type: System..::..String
The user visible text seen on the new button.
assemblyName
Type: System..::..String
The assembly path of the button.
className
Type: System..::..String
The name of the class containing the implementation for the command.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when nullNothingnullptra null reference (Nothing in Visual Basic) is passed for one or more arguments.
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when an empty string is passed for one or more arguments.

See Also

ToggleButtonData Class
ToggleButtonData Overload
Autodesk.Revit.UI Namespace


ToggleButtonData Methods

[image] [image]

Revit 2013 API
ToggleButtonData Methods
ToggleButtonData Class See Also Send Feedback

The ToggleButtonData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetContextualHelp | Gets the contextual help bound with this control. (Inherited from RibbonItemData.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetContextualHelp | Sets the contextual help bound with this button data. (Inherited from RibbonItemData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


ToggleButtonData Properties

[image] [image]

Revit 2013 API
ToggleButtonData Properties
ToggleButtonData Class See Also Send Feedback

The ToggleButtonData type exposes the following members.

Properties

 | Name | Description
Public property | AssemblyName | The assembly path of the button. (Inherited from PushButtonData.)
Public property | AvailabilityClassName | The full class name for the class providing the entry point to decide availability of this push button. (Inherited from PushButtonData.)
Public property | ClassName | The name of the class containing the implementation for the command. (Inherited from PushButtonData.)
Public property | Image | The image of the button. (Inherited from ButtonData.)
Public property | LargeImage | The large image of the button. (Inherited from ButtonData.)
Public property | LongDescription | Long description of the command tooltip; (Inherited from RibbonItemData.)
Public property | Name | The name of the item. (Inherited from RibbonItemData.)
Public property | Text | The user-visible text of the button. (Inherited from ButtonData.)
Public property | ToolTip | The description that appears as a ToolTip for the item. (Inherited from RibbonItemData.)
Public property | ToolTipImage | The image to show as a part of the button extended tooltip; (Inherited from RibbonItemData.)

See Also

ToggleButtonData Class
Autodesk.Revit.UI Namespace


UIApplication Class

[image]

Revit 2013 API
UIApplication Class
Members See Also Send Feedback
Represents an active session of the Autodesk Revit user interface, providing access to UI customization methods, events, and the active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class UIApplication : IDisposable
Visual Basic
Public Class UIApplication _
    Implements IDisposable
Visual C++
public ref class UIApplication : IDisposable

Remarks

You can access documents from the database level Application object, obtained from the Application property. If you have an instance of the database level Application object, you can construct a UIApplication from it.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..UIApplication

See Also

UIApplication Members
Autodesk.Revit.UI Namespace


UIApplication Members

[image] [image]

Revit 2013 API
UIApplication Members
UIApplication Class Constructors Methods Properties Events See Also Send Feedback

The UIApplication type exposes the following members.

Constructors

 | Name | Description
Public method | UIApplication | Use a database level Application to construct a UI-level Application.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Dispose | Releases all resources used by the UIApplication
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
 | DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ActiveUIDocument | Provides access to an object that represents the currently active project.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Constructor

[image]

Revit 2013 API
UIApplication Constructor
UIApplication Class See Also Send Feedback
Use a database level Application to construct a UI-level Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIApplication(
    Application pApplication
)
Visual Basic
Public Sub New ( _
    pApplication As Application _
)
Visual C++
public:
UIApplication(
    Application^ pApplication
)

Parameters

pApplication
Type: Autodesk.Revit.ApplicationServices..::..Application

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Methods

[image] [image]

Revit 2013 API
UIApplication Methods
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Dispose |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
 | DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


CreateAddInCommandBinding Method

[image]

Revit 2013 API
UIApplication..::..CreateAddInCommandBinding Method
UIApplication Class See Also Send Feedback
Creates a new AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AddInCommandBinding CreateAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Function CreateAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
) As AddInCommandBinding
Visual C++
public:
AddInCommandBinding^ CreateAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId
The Revit command id to identify the command handler you want to replace.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when uiApplication or revitCommandId is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the given command already has been bound.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2013 API
UIApplication..::..CreateRibbonPanel Method
UIApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2013 API
UIApplication..::..CreateRibbonPanel Method (String)
UIApplication Class Example See Also Send Feedback
Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.

Examples

CopyC#
public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;

    return Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    'the add-in application “HelloWorld” will be triggered when button is pushed

    Dim pushButton As PushButton = TryCast(ribbonPanel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    ' Set the large image shown on button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)
    pushButton.LargeImage = largeImage

    Return Result.Succeeded
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | panelName is Empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If more than 100 panels were created.

See Also

UIApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String, String)

[image]

Revit 2013 API
UIApplication..::..CreateRibbonPanel Method (String, String)
UIApplication Class See Also Send Feedback
Create a new RibbonPanel on the specified tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string tabName,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tabName As String, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ tabName,
    String^ panelName
)

Parameters

tabName
Type: System..::..String
The name of the tab, on which the new panel will be created.
panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | tabName or panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | tabName or panelName is Empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Too many panels have been added to this tab (Maximum is 100).

See Also

UIApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2013 API
UIApplication..::..CreateRibbonPanel Method (Tab, String)
UIApplication Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

UIApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonTab Method

[image]

Revit 2013 API
UIApplication..::..CreateRibbonTab Method
UIApplication Class See Also Send Feedback
Creates a new tab on the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void CreateRibbonTab(
    string tabName
)
Visual Basic
Public Overridable Sub CreateRibbonTab ( _
    tabName As String _
)
Visual C++
public:
virtual void CreateRibbonTab(
    String^ tabName
)

Parameters

tabName
Type: System..::..String
The name of the tab to be created.

Remarks

This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | tabName or panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | tabName or panelName is Empty or the tab name duplicates the name of another tab in the Revit UI.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Too many custom tabs have been created in this session. (Maximum is 20).

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
UIApplication..::..Dispose Method
UIApplication Class See Also Send Feedback
Releases all resources used by the UIApplication

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DoDragDrop Method

[image] [image]

Revit 2013 API
UIApplication..::..DoDragDrop Method
UIApplication Class See Also Send Feedback

Overload List

Name | Description
DoDragDrop(ICollection<(Of <<'(String>)>>)) | Initiates a drag and drop operation of a collection of file names on the Revit user interface.
DoDragDrop(Object, IDropHandler) | Initiates a drag and drop operation with a custom drop implementation.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


DoDragDrop Method (ICollection(String))

[image]

Revit 2013 API
UIApplication..::..DoDragDrop Method (ICollection<(Of <(<'String>)>)>)
UIApplication Class See Also Send Feedback
Initiates a drag and drop operation of a collection of file names on the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void DoDragDrop(
    ICollection<string> dropData
)
Visual Basic
Public Shared Sub DoDragDrop ( _
    dropData As ICollection(Of String) _
)
Visual C++
public:
static void DoDragDrop(
    ICollection<String^>^ dropData
)

Parameters

dropData
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>
The list of file paths and names.

Remarks

The behavior after the 'dragData' dragged onto Revit is listed bellow:
  • Only one AutoCAD format or image file dragged onto Revit: a new import placement editor will be started for import the file;
  • More than one AutoCAD format or image files dragged onto Revit: a new import placement editor will be started only for the first AutoCAD format or image file;
  • Only one family file dragged onto Revit: the family will be loaded, and an editor will be started to place the family;
  • More than one family files dragged onto Revit: all the families will be loaded;
  • More than one family files including other format files dragged onto Revit: Revit will try to open all the files;
  • If a valid file or list of files is passed, Revit will do its best to use them appropriately. If any files are not usable, failure will be signalled to the interactive Revit user (and will not be signalled to the application with an exception).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when dropData is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | Thrown when dropData contains a file that doens't exist.

See Also

UIApplication Class
DoDragDrop Overload
Autodesk.Revit.UI Namespace


DoDragDrop Method (Object, IDropHandler)

[image]

Revit 2013 API
UIApplication..::..DoDragDrop Method (Object, IDropHandler)
UIApplication Class See Also Send Feedback
Initiates a drag and drop operation with a custom drop implementation.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public static void DoDragDrop(
    Object dropData,
    IDropHandler handler
)
Visual Basic
Public Shared Sub DoDragDrop ( _
    dropData As Object, _
    handler As IDropHandler _
)
Visual C++
public:
static void DoDragDrop(
    Object^ dropData,
    IDropHandler^ handler
)

Parameters

dropData
Type: System..::..Object
Any arbitrary data to be passed to the drop handler when the drop occurs.
handler
Type: Autodesk.Revit.UI..::..IDropHandler
The handler to be executed when the drop occurs.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when dropData or handler is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

UIApplication Class
DoDragDrop Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image] [image]

Revit 2013 API
UIApplication..::..GetRibbonPanels Method
UIApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image]

Revit 2013 API
UIApplication..::..GetRibbonPanels Method
UIApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in Macros.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (String)

[image]

Revit 2013 API
UIApplication..::..GetRibbonPanels Method (String)
UIApplication Class See Also Send Feedback
Get all the custom Panels on a designated Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    string tabName
)
Visual Basic
Public Function GetRibbonPanels ( _
    tabName As String _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    String^ tabName
)

Parameters

tabName
Type: System..::..String
The name of the tab on which the panels are located.

Remarks

Built-in panels will not be included. tabName must be the name of one of the tabs added by CreateRibbonTab(String). This method is not supported in Macros.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2013 API
UIApplication..::..GetRibbonPanels Method (Tab)
UIApplication Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in Macros.

See Also

UIApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


OpenAndActivateDocument Method

[image] [image]

Revit 2013 API
UIApplication..::..OpenAndActivateDocument Method
UIApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenAndActivateDocument(String) | Opens and activates a Revit document.
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) | Opens and activates a Revit document.

See Also

UIApplication Class
UIApplication Members
Autodesk.Revit.UI Namespace


OpenAndActivateDocument Method (String)

[image]

Revit 2013 API
UIApplication..::..OpenAndActivateDocument Method (String)
UIApplication Class See Also Send Feedback
Opens and activates a Revit document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public UIDocument OpenAndActivateDocument(
    string fileName
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    fileName As String _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
A full path to a revit file to be opened. The file can be either a Revit project, template, or family document.

Remarks

This method, if successful, changes the active document. It is not allowed to have an open transaction in the active document when calling this method. Consequently, this method can only be used in manual transaction mode, not in automatic mode. Additionally, this method may not be called from inside an event handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'fileName'.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file specified by 'fileName' cannot be found.
Autodesk.Revit.Exceptions..::..ArgumentException | The given 'fileName' is not a Revit file (a project, template, or family document).
Autodesk.Revit.Exceptions..::..InvalidOperationException
  • If the active document is currently modifiable.
  • If an API event handler is currently being executed.

See Also

UIApplication Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI Namespace


OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)

[image]

Revit 2013 API
UIApplication..::..OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)
UIApplication Class See Also Send Feedback
Opens and activates a Revit document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public UIDocument OpenAndActivateDocument(
    ModelPath modelPath,
    OpenOptionsForUI openOptions
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    modelPath As ModelPath, _
    openOptions As OpenOptionsForUI _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    ModelPath^ modelPath,
    OpenOptionsForUI^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
A path to a revit file to be opened. The file can be either a Revit project, template, or family document.
openOptions
Type: Autodesk.Revit.UI..::..OpenOptionsForUI
Options for opening the file.

Remarks

This method, if successful, changes the active document. It is not allowed to have an open transaction in the active document when calling this method. Consequently, this method can only be used in manual transaction mode, not in automatic mode. Additionally, this method may not be called from inside an event handler.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'modelPath'.
Autodesk.Revit.Exceptions..::..ArgumentNullException | If nullNothingnullptra null reference (Nothing in Visual Basic) is passed as 'openOptions'.
Autodesk.Revit.Exceptions..::..FileArgumentNotFoundException | The file specified by 'modelPath' cannot be found or the given 'modelPath' is not a Revit file (a project, template, or family document).
Autodesk.Revit.Exceptions..::..ArgumentException | If the modelPath is not a FilePath
Autodesk.Revit.Exceptions..::..InvalidOperationException
  • If the active document is currently modifiable.
  • If an API event handler is currently being executed.

See Also

UIApplication Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI Namespace


RemoveAddInCommandBinding Method

[image]

Revit 2013 API
UIApplication..::..RemoveAddInCommandBinding Method
UIApplication Class See Also Send Feedback
Removes an AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Sub RemoveAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
)
Visual C++
public:
void RemoveAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId
The Revit command id to identify the command handler you want to remove the binding.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when uiApplication or revitCommandId is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the given command is not bound with this add-in.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Properties

[image] [image]

Revit 2013 API
UIApplication Properties
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ActiveUIDocument | Provides access to an object that represents the currently active project.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents | Get the rectangle that represents the screen pixel coordinates of drawing area.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.
Public property | MainWindowExtents | Get the rectangle that represents the screen pixel coordinates of Revit main window.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ActiveAddInId Property

[image]

Revit 2013 API
UIApplication..::..ActiveAddInId Property
UIApplication Class See Also Send Feedback
Get current active external application or external command id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ActiveUIDocument Property

[image]

Revit 2013 API
UIApplication..::..ActiveUIDocument Property
UIApplication Class See Also Send Feedback
Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual UIDocument ActiveUIDocument { get; }
Visual Basic
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument
    Get
Visual C++
public:
virtual property UIDocument^ ActiveUIDocument {
    UIDocument^ get ();
}

Remarks

External API commands can access this property in read-only mode only! The ability to modify the property is reserved for future implementations.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to modify the property.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2013 API
UIApplication..::..Application Property
UIApplication Class See Also Send Feedback
Returns the database level Application represented by this UI level Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic
Public ReadOnly Property Application As Application
    Get
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DrawingAreaExtents Property

[image]

Revit 2013 API
UIApplication..::..DrawingAreaExtents Property
UIApplication Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of drawing area.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual Rectangle DrawingAreaExtents { get; }
Visual Basic
Public Overridable ReadOnly Property DrawingAreaExtents As Rectangle
    Get
Visual C++
public:
virtual property Rectangle^ DrawingAreaExtents {
    Rectangle^ get ();
}

Remarks

The drawing area of the Revit window displays views (and sheets and schedules) of the current project. The size of drawing area restricts the max size of the view windows. If there is no project opened, null will be returned.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


LoadedApplications Property

[image]

Revit 2013 API
UIApplication..::..LoadedApplications Property
UIApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
    Get
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


MainWindowExtents Property

[image]

Revit 2013 API
UIApplication..::..MainWindowExtents Property
UIApplication Class See Also Send Feedback
Get the rectangle that represents the screen pixel coordinates of Revit main window.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public virtual Rectangle MainWindowExtents { get; }
Visual Basic
Public Overridable ReadOnly Property MainWindowExtents As Rectangle
    Get
Visual C++
public:
virtual property Rectangle^ MainWindowExtents {
    Rectangle^ get ();
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIApplication Events

[image] [image]

Revit 2013 API
UIApplication Events
UIApplication Class See Also Send Feedback

The UIApplication type exposes the following members.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ApplicationClosing Event

[image]

Revit 2013 API
UIApplication..::..ApplicationClosing Event
UIApplication Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

No document may be modified at the time of the event.

The sender object of this event is UIControlledApplication object.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DialogBoxShowing Event

[image]

Revit 2013 API
UIApplication..::..DialogBoxShowing Event
UIApplication Class Example See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DialogBoxShowing : IExternalApplication
{
    // Implement the OnStartup method to register events when Revit starts.
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.DialogBoxShowing +=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // Implement this method to unregister the subscribed events when Revit exits.
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
        application.DialogBoxShowing -=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // The DialogBoxShowing event handler, which allow you to
    // do some work before the dialog shows
    void AppDialogShowing(object sender, DialogBoxShowingEventArgs args)
    {
        // Get the help id of the showing dialog
        int dialogId = args.HelpId;

        // Format the prompt information string
        String promptInfo = "A Revit dialog will be opened.\n";
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + "\n";
        promptInfo += "If you don't want the dialog to open, please press cancel button";

        // Show the prompt message, and allow the user to close the dialog directly.
        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent = promptInfo;
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok |
                                            TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult result = taskDialog.Show();
        if (TaskDialogResult.Cancel == result)
        {
            // Do not show the Revit dialog
            args.OverrideResult(1);
        }
        else
        {
            // Continue to show the Revit dialog
            args.OverrideResult(0);
        }
    }
}
CopyVB.NET
Public Class Application_DialogBoxShowing
    Implements IExternalApplication
    ' Implement the OnStartup method to register events when Revit starts.
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' Implement this method to unregister the subscribed events when Revit exits.
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' The DialogBoxShowing event handler, which allow you to
    ' do some work before the dialog shows
    Sub AppDialogShowing(ByVal sender As Object, ByVal args As Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs)
        ' Get the help id of the showing dialog
        Dim dialogId As Integer = args.HelpId

        ' Format the prompt information string
        Dim promptInfo As [String] = "A Revit dialog will be opened." & vbLf
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + vbLf
        promptInfo += "If you don't want the dialog to open, please press cancel button"

        ' Show the prompt message, and allow the user to close the dialog directly.
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = promptInfo
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()
        If TaskDialogResult.Cancel = result Then
            ' Do not show the Revit dialog
            args.OverrideResult(1)
        Else
            ' Continue to show the Revit dialog
            args.OverrideResult(0)
        End If
    End Sub
End Class

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


DisplayingOptionsDialog Event

[image]

Revit 2013 API
UIApplication..::..DisplayingOptionsDialog Event
UIApplication Class See Also Send Feedback
Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<DisplayingOptionsDialogEventArgs> DisplayingOptionsDialog
Visual Basic
Public Event DisplayingOptionsDialog As EventHandler(Of DisplayingOptionsDialogEventArgs)
Visual C++
public:
 event EventHandler<DisplayingOptionsDialogEventArgs^>^ DisplayingOptionsDialog {
    void add (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
    void remove (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


Idling Event

[image]

Revit 2013 API
UIApplication..::..Idling Event
UIApplication Class Example See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

There are two ways to use this event. In the default mode, a single raise of the event will be made each time Revit begins an idle session. Note that when the user is active in the Revit user interface, idle sessions begin whenever the mouse stops moving for a moment or when a command completes. However, if the user is not active in the user interface at all, Revit may not invoke additional idling sessions for quite some time; this means that your application may not be able to take advantage of time when the user leaves the machine completely for a period of time.

In the non-default mode, your application forces Revit to keep the idling session open and to make repeated calls to your event subscriber. In this mode even if the user is totally inactive the Revit session will continue to make Idling calls to your application. However, this can result in performance degradation for the system on which Revit is running because the CPU remains fully engaged in serving Idling events during the Revit application's downtime.

You can indicate the preference for the non-default Idling frequency by calling SetRaiseWithoutDelay()()()() each time the Idling event callback is made. Revit will revert to the default Idling frequency if this method is not called every time in your callback.

Event is not cancellable.

Examples

CopyC#
// Create a text note and update it once per second while Revit is idle
TextNote textNote = null;
String oldDateTime = null;
public Result Execute(ExternalCommandData commandData, ref string message, ElementSet elements)
{
    UIApplication uiApp = new UIApplication(commandData.Application.Application);
    Document doc = commandData.Application.ActiveUIDocument.Document;
    Transaction t = new Transaction(doc, "Text Note Creation");
    t.Start();
    textNote = doc.Create.NewTextNote(doc.ActiveView, XYZ.Zero, XYZ.BasisX, XYZ.BasisY, 0, TextAlignFlags.TEF_ALIGN_LEFT, DateTime.Now.ToString());
    t.Commit();
    oldDateTime = DateTime.Now.ToString();
    uiApp.Idling += new EventHandler<IdlingEventArgs>(idleUpdate);
    return Result.Succeeded;
}
public void idleUpdate(object sender, IdlingEventArgs e)
{
    UIApplication uiApp = sender as UIApplication;
    Document doc = uiApp.ActiveUIDocument.Document;
    if (oldDateTime != DateTime.Now.ToString())
    {
        Transaction transaction = new Transaction(doc, "Text Note Update");
        transaction.Start();
        textNote.Text = DateTime.Now.ToString();
        transaction.Commit();
        oldDateTime = DateTime.Now.ToString();
    }
}

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ViewActivated Event

[image]

Revit 2013 API
UIApplication..::..ViewActivated Event
UIApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


ViewActivating Event

[image]

Revit 2013 API
UIApplication..::..ViewActivating Event
UIApplication Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

See Also

UIApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Class

[image]

Revit 2013 API
UIControlledApplication Class
Members See Also Send Feedback
Represents the Autodesk Revit user interface, providing access to UI customization methods and events.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class UIControlledApplication
Visual Basic
Public Class UIControlledApplication
Visual C++
public ref class UIControlledApplication

Remarks

This class does not provide access to documents because it is provided to you through the ExternalApplication OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents. You can work with documents by getting them from the UIApplication class; that class is obtained from events and ExternalCommand callbacks.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..UIControlledApplication

See Also

UIControlledApplication Members
Autodesk.Revit.UI Namespace


UIControlledApplication Members

[image] [image]

Revit 2013 API
UIControlledApplication Members
UIControlledApplication Class Methods Properties Events See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Methods

[image] [image]

Revit 2013 API
UIControlledApplication Methods
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding | Creates a new AddInCommandBinding.
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.
Public method | CreateRibbonTab | Creates a new tab on the Revit user interface.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveAddInCommandBinding | Removes an AddInCommandBinding.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


CreateAddInCommandBinding Method

[image]

Revit 2013 API
UIControlledApplication..::..CreateAddInCommandBinding Method
UIControlledApplication Class See Also Send Feedback
Creates a new AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AddInCommandBinding CreateAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Function CreateAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
) As AddInCommandBinding
Visual C++
public:
AddInCommandBinding^ CreateAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId
The Revit command id to identify the command handler you want to replace.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when uiApplication or revitCommandId is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the given command already has been bound.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2013 API
UIControlledApplication..::..CreateRibbonPanel Method
UIControlledApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRibbonPanel(String) | Create a new RibbonPanel on the Add-Ins tab.
Public method | CreateRibbonPanel(String, String) | Create a new RibbonPanel on the specified tab.
Public method | CreateRibbonPanel(Tab, String) | Create a new RibbonPanel on the designated standard Revit tab.

See Also

UIControlledApplication Class
UIControlledApplication Members
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2013 API
UIControlledApplication..::..CreateRibbonPanel Method (String)
UIControlledApplication Class Example See Also Send Feedback
Create a new RibbonPanel on the Add-Ins tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the Revit AddIns tab. This method is not supported in Macros.

Examples

CopyC#
public Autodesk.Revit.UI.Result OnStartup(UIControlledApplication application)
{
    // add new ribbon panel
    RibbonPanel ribbonPanel = application.CreateRibbonPanel("NewRibbonPanel");

    //Create a push button in the ribbon panel “NewRibbonPanel”
    //the add-in application “HelloWorld” will be triggered when button is pushed

    PushButton pushButton = ribbonPanel.AddItem(new PushButtonData("HelloWorld",
        "HelloWorld", @"D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")) as PushButton;

    // Set the large image shown on button
    Uri uriImage = new Uri(@"D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png");
    BitmapImage largeImage = new BitmapImage(uriImage);
    pushButton.LargeImage = largeImage;

    return Result.Succeeded;
}
CopyVB.NET
Public Function OnStartup(ByVal application As UIControlledApplication) As Autodesk.Revit.UI.Result Implements IExternalApplication.OnStartup
    ' add new ribbon panel
    Dim ribbonPanel As RibbonPanel = application.CreateRibbonPanel("NewRibbonPanel")

    'Create a push button in the ribbon panel “NewRibbonPanel”
    'the add-in application “HelloWorld” will be triggered when button is pushed

    Dim pushButton As PushButton = TryCast(ribbonPanel.AddItem(New PushButtonData("HelloWorld", "HelloWorld", "D:\HelloWorld.dll", "HelloWorld.CsHelloWorld")), PushButton)

    ' Set the large image shown on button
    Dim uriImage As New Uri("D:\Sample\HelloWorld\bin\Debug\39-Globe_32x32.png")
    Dim largeImage As New BitmapImage(uriImage)
    pushButton.LargeImage = largeImage

    Return Result.Succeeded
End Function

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | panelName is Empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If more than 100 panels were created.

See Also

UIControlledApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (String, String)

[image]

Revit 2013 API
UIControlledApplication..::..CreateRibbonPanel Method (String, String)
UIControlledApplication Class See Also Send Feedback
Create a new RibbonPanel on the specified tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string tabName,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tabName As String, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ tabName,
    String^ panelName
)

Parameters

tabName
Type: System..::..String
The name of the tab, on which the new panel will be created.
panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | tabName or panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | tabName or panelName is Empty.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Too many panels have been added to this tab (Maximum is 100).

See Also

UIControlledApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2013 API
UIControlledApplication..::..CreateRibbonPanel Method (Tab, String)
UIControlledApplication Class See Also Send Feedback
Create a new RibbonPanel on the designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
The target tab, on which the new panel will be created.
panelName
Type: System..::..String
The name of the panel to be created.

Remarks

This method will create a custom panel appending to the specified tab. This method is not supported in Macros.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | panelName is Empty or the tab is not valid.
Autodesk.Revit.Exceptions..::..InvalidOperationException | If more than 100 panels were created or the tab cannot be found.

See Also

UIControlledApplication Class
CreateRibbonPanel Overload
Autodesk.Revit.UI Namespace


CreateRibbonTab Method

[image]

Revit 2013 API
UIControlledApplication..::..CreateRibbonTab Method
UIControlledApplication Class Example See Also Send Feedback
Creates a new tab on the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void CreateRibbonTab(
    string tabName
)
Visual Basic
Public Overridable Sub CreateRibbonTab ( _
    tabName As String _
)
Visual C++
public:
virtual void CreateRibbonTab(
    String^ tabName
)

Parameters

tabName
Type: System..::..String
The name of the tab to be created.

Remarks

This method will create a custom tab at the end of the list of static tabs. If multiple tabs are added, they will be shown in the order added. This method is not supported in Macros.

Examples

CopyC#
public Result OnStartup(UIControlledApplication application)
{
    // Create a custom ribbon tab
    String tabName = "This Tab Name";
    application.CreateRibbonTab(tabName);

    // Create two push buttons
    PushButtonData button1 = new PushButtonData("Button1", "My Button #1",
        @"C:\ExternalCommands.dll", "Revit.Test.Command1");
    PushButtonData button2 = new PushButtonData("Button2", "My Button #2",
        @"C:\ExternalCommands.dll", "Revit.Test.Command2");

    // Create a ribbon panel
    RibbonPanel m_projectPanel = application.CreateRibbonPanel(tabName, "This Panel Name");

    // Add the buttons to the panel
    List<RibbonItem> projectButtons = new List<RibbonItem>();
    projectButtons.AddRange(m_projectPanel.AddStackedItems(button1, button2));

    return Result.Succeeded;
}

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | tabName or panelName is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..ArgumentException | tabName or panelName is Empty or the tab name duplicates the name of another tab in the Revit UI.
Autodesk.Revit.Exceptions..::..InvalidOperationException | Too many custom tabs have been created in this session. (Maximum is 20).

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image] [image]

Revit 2013 API
UIControlledApplication..::..GetRibbonPanels Method
UIControlledApplication Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRibbonPanels()()()() | Get all the custom Panels on Add-Ins tab of Revit.
Public method | GetRibbonPanels(String) | Get all the custom Panels on a designated Revit tab.
Public method | GetRibbonPanels(Tab) | Get all the custom Panels on a designated standard Revit tab.

See Also

UIControlledApplication Class
UIControlledApplication Members
Autodesk.Revit.UI Namespace


GetRibbonPanels Method

[image]

Revit 2013 API
UIControlledApplication..::..GetRibbonPanels Method
UIControlledApplication Class See Also Send Feedback
Get all the custom Panels on Add-Ins tab of Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

Remarks

The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included. This method is not supported in Macros.

See Also

UIControlledApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (String)

[image]

Revit 2013 API
UIControlledApplication..::..GetRibbonPanels Method (String)
UIControlledApplication Class See Also Send Feedback
Get all the custom Panels on a designated Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    string tabName
)
Visual Basic
Public Function GetRibbonPanels ( _
    tabName As String _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    String^ tabName
)

Parameters

tabName
Type: System..::..String
The name of the tab on which the panels are located.

Remarks

Built-in panels will not be included. tabName must be the name of one of the tabs added by CreateRibbonTab(String). This method is not supported in Macros.

See Also

UIControlledApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2013 API
UIControlledApplication..::..GetRibbonPanels Method (Tab)
UIControlledApplication Class See Also Send Feedback
Get all the custom Panels on a designated standard Revit tab.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
The tab on which the panels are located.

Remarks

Built-in panels will not be included. This method is not supported in Macros.

See Also

UIControlledApplication Class
GetRibbonPanels Overload
Autodesk.Revit.UI Namespace


RemoveAddInCommandBinding Method

[image]

Revit 2013 API
UIControlledApplication..::..RemoveAddInCommandBinding Method
UIControlledApplication Class See Also Send Feedback
Removes an AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void RemoveAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Sub RemoveAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
)
Visual C++
public:
void RemoveAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId
The Revit command id to identify the command handler you want to remove the binding.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when uiApplication or revitCommandId is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the given command is not bound with this add-in.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Properties

[image] [image]

Revit 2013 API
UIControlledApplication Properties
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId | Get current active external application or external command id.
Public property | ControlledApplication | Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
Public property | LoadedApplications | Returns an array of successfully loaded external applications.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ActiveAddInId Property

[image]

Revit 2013 API
UIControlledApplication..::..ActiveAddInId Property
UIControlledApplication Class See Also Send Feedback
Get current active external application or external command id.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ControlledApplication Property

[image]

Revit 2013 API
UIControlledApplication..::..ControlledApplication Property
UIControlledApplication Class See Also Send Feedback
Returns the database level ControlledApplication represented by this UI-level ControlledApplication.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ControlledApplication ControlledApplication { get; }
Visual Basic
Public ReadOnly Property ControlledApplication As ControlledApplication
    Get
Visual C++
public:
property ControlledApplication^ ControlledApplication {
    ControlledApplication^ get ();
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


LoadedApplications Property

[image]

Revit 2013 API
UIControlledApplication..::..LoadedApplications Property
UIControlledApplication Class See Also Send Feedback
Returns an array of successfully loaded external applications.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
    Get
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

Remarks

This property can be used by your application to find all successfully loaded external applications when Revit starts.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIControlledApplication Events

[image] [image]

Revit 2013 API
UIControlledApplication Events
UIControlledApplication Class See Also Send Feedback

The UIControlledApplication type exposes the following members.

Events

 | Name | Description
Public event | ApplicationClosing | Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event | DialogBoxShowing | Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event | DisplayingOptionsDialog | Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event | Idling | Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event | ViewActivated | Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event | ViewActivating | Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ApplicationClosing Event

[image]

Revit 2013 API
UIControlledApplication..::..ApplicationClosing Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

Remarks

This event is raised when the Revit application is just about to be closed.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

No document may be modified at the time of the event.

The sender object of this event is UIControlledApplication object.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


DialogBoxShowing Event

[image]

Revit 2013 API
UIControlledApplication..::..DialogBoxShowing Event
UIControlledApplication Class Example See Also Send Feedback
Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to show a dialog box or a message box.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False.

Depending on the type of the dialog that is being shown, the event's argument's type varies as follows: When it is a dialog box, the event’s argument is an object of DialogBoxShowingEventArgs. When it is a message box, the event’s argument is an object of MessageBoxShowingEventArgs,which is subclass of DialogBoxShowingEventArgs. When it is a task dialog, the event’s argument is an object of TaskDialogShowingEventArgs,which is subclass of DialogBoxShowingEventArgs.

No document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Examples

CopyC#
public class Application_DialogBoxShowing : IExternalApplication
{
    // Implement the OnStartup method to register events when Revit starts.
    public Result OnStartup(UIControlledApplication application)
    {
        // Register related events
        application.DialogBoxShowing +=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // Implement this method to unregister the subscribed events when Revit exits.
    public Result OnShutdown(UIControlledApplication application)
    {
        // unregister events
        application.DialogBoxShowing -=
            new EventHandler<Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs>(AppDialogShowing);
        return Result.Succeeded;
    }

    // The DialogBoxShowing event handler, which allow you to
    // do some work before the dialog shows
    void AppDialogShowing(object sender, DialogBoxShowingEventArgs args)
    {
        // Get the help id of the showing dialog
        int dialogId = args.HelpId;

        // Format the prompt information string
        String promptInfo = "A Revit dialog will be opened.\n";
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + "\n";
        promptInfo += "If you don't want the dialog to open, please press cancel button";

        // Show the prompt message, and allow the user to close the dialog directly.
        TaskDialog taskDialog = new TaskDialog("Revit");
        taskDialog.MainContent = promptInfo;
        TaskDialogCommonButtons buttons = TaskDialogCommonButtons.Ok |
                                            TaskDialogCommonButtons.Cancel;
        taskDialog.CommonButtons = buttons;
        TaskDialogResult result = taskDialog.Show();
        if (TaskDialogResult.Cancel == result)
        {
            // Do not show the Revit dialog
            args.OverrideResult(1);
        }
        else
        {
            // Continue to show the Revit dialog
            args.OverrideResult(0);
        }
    }
}
CopyVB.NET
Public Class Application_DialogBoxShowing
    Implements IExternalApplication
    ' Implement the OnStartup method to register events when Revit starts.
    Public Function OnStartup(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnStartup
        ' Register related events
        AddHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' Implement this method to unregister the subscribed events when Revit exits.
    Public Function OnShutdown(ByVal application As UIControlledApplication) As Result Implements IExternalApplication.OnShutdown
        ' unregister events
        RemoveHandler application.DialogBoxShowing, AddressOf AppDialogShowing
        Return Result.Succeeded
    End Function

    ' The DialogBoxShowing event handler, which allow you to
    ' do some work before the dialog shows
    Sub AppDialogShowing(ByVal sender As Object, ByVal args As Autodesk.Revit.UI.Events.DialogBoxShowingEventArgs)
        ' Get the help id of the showing dialog
        Dim dialogId As Integer = args.HelpId

        ' Format the prompt information string
        Dim promptInfo As [String] = "A Revit dialog will be opened." & vbLf
        promptInfo += "The help id of this dialog is " + dialogId.ToString() + vbLf
        promptInfo += "If you don't want the dialog to open, please press cancel button"

        ' Show the prompt message, and allow the user to close the dialog directly.
        Dim taskDialog As New TaskDialog("Revit")
        taskDialog.MainContent = promptInfo
        Dim buttons As TaskDialogCommonButtons = TaskDialogCommonButtons.Ok Or TaskDialogCommonButtons.Cancel
        taskDialog.CommonButtons = buttons
        Dim result As TaskDialogResult = taskDialog.Show()
        If TaskDialogResult.Cancel = result Then
            ' Do not show the Revit dialog
            args.OverrideResult(1)
        Else
            ' Continue to show the Revit dialog
            args.OverrideResult(0)
        End If
    End Sub
End Class

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


DisplayingOptionsDialog Event

[image]

Revit 2013 API
UIControlledApplication..::..DisplayingOptionsDialog Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public event EventHandler<DisplayingOptionsDialogEventArgs> DisplayingOptionsDialog
Visual Basic
Public Event DisplayingOptionsDialog As EventHandler(Of DisplayingOptionsDialogEventArgs)
Visual C++
public:
 event EventHandler<DisplayingOptionsDialogEventArgs^>^ DisplayingOptionsDialog {
    void add (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
    void remove (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


Idling Event

[image]

Revit 2013 API
UIControlledApplication..::..Idling Event
UIControlledApplication Class Example See Also Send Feedback
Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

Remarks

This event is raised when it is safe for the API application to access the active document between user interactions. The event is raised only when the Revit UI is in a state where the user could successfully click on an API command button.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

In order to change a document, you must begin a new transaction for that document. This transaction will appear in the Revit undo stack and may be undone by the Revit user.

This event is invoked between user actions in the Revit UI. If the handler for this event requires a significant amount of processing time, users will perceive a slowdown in the responsiveness of Revit. If the execution for updates can be safely split across multiple calls to this event, the user perception of Revit responsiveness will be improved.

There are two ways to use this event. In the default mode, a single raise of the event will be made each time Revit begins an idle session. Note that when the user is active in the Revit user interface, idle sessions begin whenever the mouse stops moving for a moment or when a command completes. However, if the user is not active in the user interface at all, Revit may not invoke additional idling sessions for quite some time; this means that your application may not be able to take advantage of time when the user leaves the machine completely for a period of time.

In the non-default mode, your application forces Revit to keep the idling session open and to make repeated calls to your event subscriber. In this mode even if the user is totally inactive the Revit session will continue to make Idling calls to your application. However, this can result in performance degradation for the system on which Revit is running because the CPU remains fully engaged in serving Idling events during the Revit application's downtime.

You can indicate the preference for the non-default Idling frequency by calling SetRaiseWithoutDelay()()()() each time the Idling event callback is made. Revit will revert to the default Idling frequency if this method is not called every time in your callback.

Event is not cancellable.

Examples

CopyC#
// Create a text note and update it once per second while Revit is idle
TextNote textNote = null;
String oldDateTime = null;
public Result Execute(ExternalCommandData commandData, ref string message, ElementSet elements)
{
    UIApplication uiApp = new UIApplication(commandData.Application.Application);
    Document doc = commandData.Application.ActiveUIDocument.Document;
    Transaction t = new Transaction(doc, "Text Note Creation");
    t.Start();
    textNote = doc.Create.NewTextNote(doc.ActiveView, XYZ.Zero, XYZ.BasisX, XYZ.BasisY, 0, TextAlignFlags.TEF_ALIGN_LEFT, DateTime.Now.ToString());
    t.Commit();
    oldDateTime = DateTime.Now.ToString();
    uiApp.Idling += new EventHandler<IdlingEventArgs>(idleUpdate);
    return Result.Succeeded;
}
public void idleUpdate(object sender, IdlingEventArgs e)
{
    UIApplication uiApp = sender as UIApplication;
    Document doc = uiApp.ActiveUIDocument.Document;
    if (oldDateTime != DateTime.Now.ToString())
    {
        Transaction transaction = new Transaction(doc, "Text Note Update");
        transaction.Start();
        textNote.Text = DateTime.Now.ToString();
        transaction.Commit();
        oldDateTime = DateTime.Now.ToString();
    }
}

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ViewActivated Event

[image]

Revit 2013 API
UIControlledApplication..::..ViewActivated Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

Remarks

This event is raised immediately after Revit has finished activating a view of the document. It is raised even when view activating failed or was cancelled (during ViewActivating event).

Check the 'Status' field in event’s argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of view activating has already been finished.

The document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


ViewActivating Event

[image]

Revit 2013 API
UIControlledApplication..::..ViewActivating Event
UIControlledApplication Class See Also Send Feedback
Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to activate a view of the document.

Event is not cancellable. The 'Cancellable' property of event’s argument is always False. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The document may be modified during this event.

The following API functions are not available for the current document during this event:

  • Close()()()() and similar overloads.
  • Save()()()() and similar overloads.
  • SaveAs(String) and similar overloads.

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ViewActivated event will be raised immediately after view activating is finished.

See Also

UIControlledApplication Class
Autodesk.Revit.UI Namespace


UIDocument Class

[image]

Revit 2013 API
UIDocument Class
Members See Also Send Feedback
An object that represents an Autodesk Revit project opened in the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class UIDocument : IDisposable
Visual Basic
Public Class UIDocument _
    Implements IDisposable
Visual C++
public ref class UIDocument : IDisposable

Remarks

This class represents a document opened in the user interface and therefore offers interfaces to work with settings and operations in the UI (for example, the active selection). Revit can have multiple projects open and multiple views to those projects. The active or top most view will be the active project and hence the active document which is available from the UIApplication object.

Obtain the database level Document (which contains interfaces not related to the UI) via the Document property. If you have a database level Document and need to access it from the UI, you can construct a new UIDocument from that object (the document must be open and visible in the UI to allow the methods to work successfully).

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..UIDocument

See Also

UIDocument Members
Autodesk.Revit.UI Namespace


UIDocument Members

[image] [image]

Revit 2013 API
UIDocument Members
UIDocument Class Constructors Methods Properties See Also Send Feedback

The UIDocument type exposes the following members.

Constructors

 | Name | Description
Public method | UIDocument | Use a database level Document to construct a UI-level Document.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UIDocument
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews | Get a list of all open view windows in the Revit user interface.
 | GetRevitUIFamilyLoadOptions | Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
Public method | RefreshActiveView | Refresh the display of the active view in the active document.
Public method | SaveAndClose | Close the document, prompting the user for saving it when necessary.
Public method | SaveAs | Saves the document to a file name obtained from the Revit user.
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId) | Shows the element by zoom to fit.
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveView | The currently active view of the currently active document.
Public property | Application | Retrieves an object that represents the current Application.
Public property | Document | Returns the database level document represented by this UI-level document.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


UIDocument Constructor

[image]

Revit 2013 API
UIDocument Constructor
UIDocument Class See Also Send Feedback
Use a database level Document to construct a UI-level Document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIDocument(
    Document pDocument
)
Visual Basic
Public Sub New ( _
    pDocument As Document _
)
Visual C++
public:
UIDocument(
    Document^ pDocument
)

Parameters

pDocument
Type: Autodesk.Revit.DB..::..Document

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


UIDocument Methods

[image] [image]

Revit 2013 API
UIDocument Methods
UIDocument Class See Also Send Feedback

The UIDocument type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews | Get a list of all open view windows in the Revit user interface.
 | GetRevitUIFamilyLoadOptions | Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PromptForFamilyInstancePlacement | Prompts the user to place instances of the specified FamilySymbol.
Public method | RefreshActiveView | Refresh the display of the active view in the active document.
Public method | SaveAndClose | Close the document, prompting the user for saving it when necessary.
Public method | SaveAs | Saves the document to a file name obtained from the Revit user.
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId) | Shows the element by zoom to fit.
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
UIDocument..::..Dispose Method
UIDocument Class See Also Send Feedback
Releases all resources used by the UIDocument

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


GetOpenUIViews Method

[image]

Revit 2013 API
UIDocument..::..GetOpenUIViews Method
UIDocument Class See Also Send Feedback
Get a list of all open view windows in the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<UIView> GetOpenUIViews()
Visual Basic
Public Function GetOpenUIViews As IList(Of UIView)
Visual C++
public:
IList<UIView^>^ GetOpenUIViews()

Remarks

A sheet view with an activated viewport will return the view associated with the activated viewport, not the sheet view.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


GetRevitUIFamilyLoadOptions Method

[image]

Revit 2013 API
UIDocument..::..GetRevitUIFamilyLoadOptions Method
UIDocument Class See Also Send Feedback
Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public static IFamilyLoadOptions GetRevitUIFamilyLoadOptions()
Visual Basic
Public Shared Function GetRevitUIFamilyLoadOptions As IFamilyLoadOptions
Visual C++
public:
static IFamilyLoadOptions^ GetRevitUIFamilyLoadOptions()

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this API method is invoked in UI less mode

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


PromptForFamilyInstancePlacement Method

[image]

Revit 2013 API
UIDocument..::..PromptForFamilyInstancePlacement Method
UIDocument Class See Also Send Feedback
Prompts the user to place instances of the specified FamilySymbol.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void PromptForFamilyInstancePlacement(
    FamilySymbol familySymbol
)
Visual Basic
Public Sub PromptForFamilyInstancePlacement ( _
    familySymbol As FamilySymbol _
)
Visual C++
public:
void PromptForFamilyInstancePlacement(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol
The FamilySymbol.

Remarks

This method opens its own transaction, so it's not permitted to be invoked in an active transaction. In a single invocation, the user can place multiple instances of the input family type until they finish the placement (with Cancel or ESC or a click elsewhere in the UI). The user will not be permitted to change the type to be placed. Users are not permitted to change the active view during this placement operation (the operation will be completed).

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when this API method is invoked in an active transaction, or this document is not active, or this is a family document and the instances of this family symbol can not exist in the current family, or this family symbol has no command to create instance, or the command to create instance is disabled in active view.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


RefreshActiveView Method

[image]

Revit 2013 API
UIDocument..::..RefreshActiveView Method
UIDocument Class See Also Send Feedback
Refresh the display of the active view in the active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public void RefreshActiveView()
Visual Basic
Public Sub RefreshActiveView
Visual C++
public:
void RefreshActiveView()

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


SaveAndClose Method

[image]

Revit 2013 API
UIDocument..::..SaveAndClose Method
UIDocument Class See Also Send Feedback
Close the document, prompting the user for saving it when necessary.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAndClose()
Visual Basic
Public Function SaveAndClose As Boolean
Visual C++
public:
bool SaveAndClose()

Return Value

False if closing procedure fails or if saving of a modified document was requested but failed. Also returns False if closing is cancelled by an external application during 'DocumentClosing' event. When function succeeds, True is returned.

Remarks

UI dialogs may be shown during the call (e.g. when the document has been changed since last time it was saved) to get user responses. The currently active document may not be closed by this function. It can only be closed via Revit's UI.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when attempting to close the currently active document. Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


SaveAs Method

[image]

Revit 2013 API
UIDocument..::..SaveAs Method
UIDocument Class See Also Send Feedback
Saves the document to a file name obtained from the Revit user.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

Return Value

False if save operation fails. Also returns False if saving as is cancelled by an external application during 'DocumentSavingAs' event. When function succeeds, True is returned.

Remarks

Because the argument list is null, a SaveAs dialog will be shown to query the file name.

This method may not be called unless all transactions, sub-transactions, and transaction groups that were opened by the API code were closed. That also implies that this method cannot be called during dynamic updates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if there are any transactions, sub-transactions or transaction groups which were opened by the API code, and not closed. All of these items must be handled before attempting to close the document.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


ShowElements Method

[image] [image]

Revit 2013 API
UIDocument..::..ShowElements Method
UIDocument Class See Also Send Feedback
Shows one or more elements by zoom to fit.

Overload List

 | Name | Description
Public method | ShowElements(Element) | Shows the element by zoom to fit.
Public method | ShowElements(ElementId) | Shows the element by zoom to fit.
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) | Shows the elements by zoom to fit.
Public method | ShowElements(ElementSet) | Shows the elements by zoom to fit.

See Also

UIDocument Class
UIDocument Members
Autodesk.Revit.UI Namespace


ShowElements Method (Element)

[image]

Revit 2013 API
UIDocument..::..ShowElements Method (Element)
UIDocument Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
Element that will be shown.

Remarks

Places the element in the center of screen by moving the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Element is null.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ElementId)

[image]

Revit 2013 API
UIDocument..::..ShowElements Method (ElementId)
UIDocument Class See Also Send Feedback
Shows the element by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ElementId elementId
)
Visual Basic
Public Sub ShowElements ( _
    elementId As ElementId _
)
Visual C++
public:
void ShowElements(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId
Element id that will be shown.

Remarks

Places the element in the center of screen by moving the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Element id is not valid.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ICollection(ElementId))

[image]

Revit 2013 API
UIDocument..::..ShowElements Method (ICollection<(Of <(<'ElementId>)>)>)
UIDocument Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub ShowElements ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void ShowElements(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of element ids which will be shown.

Remarks

Places all the elements on the screen by moving the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | elementIds is null.
Autodesk.Revit.Exceptions..::..ArgumentException | Member of elementIds is null.
Autodesk.Revit.Exceptions..::..ArgumentException | Member of elementIds is not valid.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


ShowElements Method (ElementSet)

[image]

Revit 2013 API
UIDocument..::..ShowElements Method (ElementSet)
UIDocument Class See Also Send Feedback
Shows the elements by zoom to fit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet
The set of elements that will be shown.

Remarks

Places all the elements on the screen by moving the view.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Elements is null.
Autodesk.Revit.Exceptions..::..ArgumentException | Member of elements is null.

See Also

UIDocument Class
ShowElements Overload
Autodesk.Revit.UI Namespace


UIDocument Properties

[image] [image]

Revit 2013 API
UIDocument Properties
UIDocument Class See Also Send Feedback

The UIDocument type exposes the following members.

Properties

 | Name | Description
Public property | ActiveView | The currently active view of the currently active document.
Public property | Application | Retrieves an object that represents the current Application.
Public property | Document | Returns the database level document represented by this UI-level document.
Public property | Selection | Retrieve the currently selected Elements in Autodesk Revit.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


ActiveView Property

[image]

Revit 2013 API
UIDocument..::..ActiveView Property
UIDocument Class See Also Send Feedback
The currently active view of the currently active document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public View ActiveView { get; set; }
Visual Basic
Public Property ActiveView As View
    Get
    Set
Visual C++
public:
property View^ ActiveView {
    View^ get ();
    void set (View^ value);
}

Remarks

This property is applicable to the currently active document only.

The active view can only be changed when:

  • There is no open transaction.
  • IsModifiable is false.
  • IsReadOnly is false.
  • ViewActivating, ViewActivated, and any pre-action of events (such as DocumentSaving or DocumentClosingevents) are not being handled.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting the property: If the 'view' argument is NULL.
Autodesk.Revit.Exceptions..::..ArgumentException When setting the property:
  • If the given view is not a valid view of the document; -or-
  • If the given view is a template view; -or-
  • If the given view is an internal view.
Autodesk.Revit.Exceptions..::..InvalidOperationException

When getting the property: If the document is not currently active.

When setting the property:

  • If the document is not currently active; -or-
  • If the document is currently modifiable (i.e. with an active transaction); -or-
  • If the document is currently in read-only state; -or-
  • When invoked during either ViewActivating or ViewActivated event; -or-
  • When invoked during any pre-action kind of event, such as DocumentSaving, DocumentClosing, etc.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Application Property

[image]

Revit 2013 API
UIDocument..::..Application Property
UIDocument Class See Also Send Feedback
Retrieves an object that represents the current Application.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic
Public ReadOnly Property Application As UIApplication
    Get
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Document Property

[image]

Revit 2013 API
UIDocument..::..Document Property
UIDocument Class See Also Send Feedback
Returns the database level document represented by this UI-level document.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


Selection Property

[image]

Revit 2013 API
UIDocument..::..Selection Property
UIDocument Class See Also Send Feedback
Retrieve the currently selected Elements in Autodesk Revit.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic
Public ReadOnly Property Selection As Selection
    Get
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

Remarks

Returns an object that represents the active selection. The Selection property returns an object that represents the active selection when the command was started.

See Also

UIDocument Class
Autodesk.Revit.UI Namespace


UIView Class

[image]

Revit 2013 API
UIView Class
Members See Also Send Feedback
A class containing data about view windows in the Revit user interface.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class UIView : IDisposable
Visual Basic
Public Class UIView _
    Implements IDisposable
Visual C++
public ref class UIView : IDisposable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI..::..UIView

See Also

UIView Members
Autodesk.Revit.UI Namespace


UIView Members

[image] [image]

Revit 2013 API
UIView Members
UIView Class Methods Properties See Also Send Feedback

The UIView type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Releases all resources used by the UIView
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowRectangle | Gets the rectangle containing the coordinates of the view's drawing area.
Public method | GetZoomCorners | Gets the corners of the view's rectangle.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ZoomAndCenterRectangle | Zoom and center the view to a specified rectangle.

Properties

 | Name | Description
Public property | ViewId | The id of the View associated with a UIView.

See Also

UIView Class
Autodesk.Revit.UI Namespace


UIView Methods

[image] [image]

Revit 2013 API
UIView Methods
UIView Class See Also Send Feedback

The UIView type exposes the following members.

Methods

 | Name | Description
Public method | Dispose |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWindowRectangle | Gets the rectangle containing the coordinates of the view's drawing area.
Public method | GetZoomCorners | Gets the corners of the view's rectangle.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | ZoomAndCenterRectangle | Zoom and center the view to a specified rectangle.

See Also

UIView Class
Autodesk.Revit.UI Namespace


Dispose Method

[image]

Revit 2013 API
UIView..::..Dispose Method
UIView Class See Also Send Feedback
Releases all resources used by the UIView

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

UIView Class
Autodesk.Revit.UI Namespace


GetWindowRectangle Method

[image]

Revit 2013 API
UIView..::..GetWindowRectangle Method
UIView Class See Also Send Feedback
Gets the rectangle containing the coordinates of the view's drawing area.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Rectangle GetWindowRectangle()
Visual Basic
Public Function GetWindowRectangle As Rectangle
Visual C++
public:
Rectangle^ GetWindowRectangle()

Return Value

The rectangle of the view window.

Remarks

The rectangle does not include the window border or title bar.

See Also

UIView Class
Autodesk.Revit.UI Namespace


GetZoomCorners Method

[image]

Revit 2013 API
UIView..::..GetZoomCorners Method
UIView Class See Also Send Feedback
Gets the corners of the view's rectangle.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public IList<XYZ> GetZoomCorners()
Visual Basic
Public Function GetZoomCorners As IList(Of XYZ)
Visual C++
public:
IList<XYZ^>^ GetZoomCorners()

Return Value

The two points that define the corners of the view's rectangle in model coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | The view is not a graphical view.

See Also

UIView Class
Autodesk.Revit.UI Namespace


ZoomAndCenterRectangle Method

[image]

Revit 2013 API
UIView..::..ZoomAndCenterRectangle Method
UIView Class See Also Send Feedback
Zoom and center the view to a specified rectangle.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void ZoomAndCenterRectangle(
    XYZ viewCorner1,
    XYZ viewCorner2
)
Visual Basic
Public Sub ZoomAndCenterRectangle ( _
    viewCorner1 As XYZ, _
    viewCorner2 As XYZ _
)
Visual C++
public:
void ZoomAndCenterRectangle(
    XYZ^ viewCorner1,
    XYZ^ viewCorner2
)

Parameters

viewCorner1
Type: Autodesk.Revit.DB..::..XYZ
A corner of the desired view rectangle in model coordinates.
viewCorner2
Type: Autodesk.Revit.DB..::..XYZ
The opposite corner of the desired view rectangle in model coordinates.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | The view corner points must differ when projected onto a plane perpendicular to the view direction.

See Also

UIView Class
Autodesk.Revit.UI Namespace


UIView Properties

[image] [image]

Revit 2013 API
UIView Properties
UIView Class See Also Send Feedback

The UIView type exposes the following members.

Properties

 | Name | Description
Public property | ViewId | The id of the View associated with a UIView.

See Also

UIView Class
Autodesk.Revit.UI Namespace


ViewId Property

[image]

Revit 2013 API
UIView..::..ViewId Property
UIView Class See Also Send Feedback
The id of the View associated with a UIView.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ElementId ViewId { get; }
Visual Basic
Public ReadOnly Property ViewId As ElementId
    Get
Visual C++
public:
property ElementId^ ViewId {
    ElementId^ get ();
}

Return Value

The id of the View.

See Also

UIView Class
Autodesk.Revit.UI Namespace


Autodesk.Revit.UI.Events Namespace

[image]

Revit 2013 API
Autodesk.Revit.UI.Events Namespace
Send Feedback

Classes

 | Class | Description
Public class | ApplicationClosingEventArgs | The event arguments used by the ApplicationClosing event.
Public class | CanExecuteEventArgs | The event arguments used by AddInCommandBinding's CanExecute event.
Public class | ComboBoxCurrentChangedEventArgs | The event arguments used by ComboBox's CurrentChanged event.
Public class | ComboBoxDropDownClosedEventArgs | The event arguments used by ComboBox's DropDownClosed event.
Public class | ComboBoxDropDownOpenedEventArgs | The event arguments used by ComboBox's DropDownOpened event.
Public class | CommandEventArgs | The base class of the command Executed and CanExecute event arguments.
Public class | DialogBoxData | An object that is passed to your application when a dialog is displayed in Revit.
Public class | DialogBoxShowingEventArgs | The base class for the event arguments used by the DialogBoxShowing event.
Public class | DisplayingOptionsDialogEventArgs | The event arguments used by DisplayingOptionDialog event.
Public class | ExecutedEventArgs | The event arguments used by AddInCommandBinding's Executed event.
Public class | IdlingEventArgs | The event arguments used by the Idling event.
Public class | MessageBoxData | An object that represents a simple message box that prompts the user for some action.
Public class | MessageBoxShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.
Public class | RibbonItemEventArgs | The base class of the RibbonItem event arguments which have UIApplication property.
Public class | TaskDialogShowingEventArgs | The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.
Public class | TextBoxEnterPressedEventArgs | The event arguments used by TextBox's EnterPressed event.
Public class | ViewActivatedEventArgs | The event arguments used by the ViewActivated event.
Public class | ViewActivatingEventArgs | The event arguments used by the ViewActivating event.


ApplicationClosingEventArgs Class

[image]

Revit 2013 API
ApplicationClosingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ApplicationClosing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ApplicationClosingEventArgs : PreEventArgs
Visual Basic
Public Class ApplicationClosingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class ApplicationClosingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..ApplicationClosingEventArgs

See Also

ApplicationClosingEventArgs Members
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Members

[image] [image]

Revit 2013 API
ApplicationClosingEventArgs Members
ApplicationClosingEventArgs Class Methods Properties See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Methods

[image] [image]

Revit 2013 API
ApplicationClosingEventArgs Methods
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ApplicationClosingEventArgs Properties

[image] [image]

Revit 2013 API
ApplicationClosingEventArgs Properties
ApplicationClosingEventArgs Class See Also Send Feedback

The ApplicationClosingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

ApplicationClosingEventArgs Class
Autodesk.Revit.UI.Events Namespace


CanExecuteEventArgs Class

[image]

Revit 2013 API
CanExecuteEventArgs Class
Members See Also Send Feedback
The event arguments used by AddInCommandBinding's CanExecute event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CanExecuteEventArgs : CommandEventArgs
Visual Basic
Public Class CanExecuteEventArgs _
    Inherits CommandEventArgs
Visual C++
public ref class CanExecuteEventArgs : public CommandEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.UI.Events..::..CommandEventArgs
Autodesk.Revit.UI.Events..::..CanExecuteEventArgs

See Also

CanExecuteEventArgs Members
Autodesk.Revit.UI.Events Namespace


CanExecuteEventArgs Members

[image] [image]

Revit 2013 API
CanExecuteEventArgs Members
CanExecuteEventArgs Class Methods Properties See Also Send Feedback

The CanExecuteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSelectedCategoryIds | Gets the category ids of selected elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveDocument | The active document. (Inherited from CommandEventArgs.)
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CanExecute | The value that indicates whether the Command associated with this event can be executed.
Public property | CommandId | The command id. (Inherited from CommandEventArgs.)

See Also

CanExecuteEventArgs Class
Autodesk.Revit.UI.Events Namespace


CanExecuteEventArgs Methods

[image] [image]

Revit 2013 API
CanExecuteEventArgs Methods
CanExecuteEventArgs Class See Also Send Feedback

The CanExecuteEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSelectedCategoryIds | Gets the category ids of selected elements.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanExecuteEventArgs Class
Autodesk.Revit.UI.Events Namespace


GetSelectedCategoryIds Method

[image]

Revit 2013 API
CanExecuteEventArgs..::..GetSelectedCategoryIds Method
CanExecuteEventArgs Class See Also Send Feedback
Gets the category ids of selected elements.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public ICollection<ElementId> GetSelectedCategoryIds()
Visual Basic
Public Function GetSelectedCategoryIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetSelectedCategoryIds()

See Also

CanExecuteEventArgs Class
Autodesk.Revit.UI.Events Namespace


CanExecuteEventArgs Properties

[image] [image]

Revit 2013 API
CanExecuteEventArgs Properties
CanExecuteEventArgs Class See Also Send Feedback

The CanExecuteEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ActiveDocument | The active document. (Inherited from CommandEventArgs.)
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CanExecute | The value that indicates whether the Command associated with this event can be executed.
Public property | CommandId | The command id. (Inherited from CommandEventArgs.)

See Also

CanExecuteEventArgs Class
Autodesk.Revit.UI.Events Namespace


CanExecute Property

[image]

Revit 2013 API
CanExecuteEventArgs..::..CanExecute Property
CanExecuteEventArgs Class See Also Send Feedback
The value that indicates whether the Command associated with this event can be executed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public bool CanExecute { get; set; }
Visual Basic
Public Property CanExecute As Boolean
    Get
    Set
Visual C++
public:
property bool CanExecute {
    bool get ();
    void set (bool value);
}

See Also

CanExecuteEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Class

[image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's CurrentChanged event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ComboBoxCurrentChangedEventArgs : RibbonItemEventArgs
Visual Basic
Public Class ComboBoxCurrentChangedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxCurrentChangedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxCurrentChangedEventArgs

See Also

ComboBoxCurrentChangedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Members

[image] [image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs Members
ComboBoxCurrentChangedEventArgs Class Methods Properties See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)
Public property | NewValue | The current item for the ComboBox after the change.
Public property | OldValue | The current item for the ComboBox before the change.

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Methods

[image] [image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs Methods
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxCurrentChangedEventArgs Properties

[image] [image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs Properties
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback

The ComboBoxCurrentChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)
Public property | NewValue | The current item for the ComboBox after the change.
Public property | OldValue | The current item for the ComboBox before the change.

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


NewValue Property

[image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs..::..NewValue Property
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback
The current item for the ComboBox after the change.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ComboBoxMember NewValue { get; }
Visual Basic
Public ReadOnly Property NewValue As ComboBoxMember
    Get
Visual C++
public:
property ComboBoxMember^ NewValue {
    ComboBoxMember^ get ();
}

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


OldValue Property

[image]

Revit 2013 API
ComboBoxCurrentChangedEventArgs..::..OldValue Property
ComboBoxCurrentChangedEventArgs Class See Also Send Feedback
The current item for the ComboBox before the change.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ComboBoxMember OldValue { get; }
Visual Basic
Public ReadOnly Property OldValue As ComboBoxMember
    Get
Visual C++
public:
property ComboBoxMember^ OldValue {
    ComboBoxMember^ get ();
}

See Also

ComboBoxCurrentChangedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Class

[image]

Revit 2013 API
ComboBoxDropDownClosedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's DropDownClosed event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ComboBoxDropDownClosedEventArgs : RibbonItemEventArgs
Visual Basic
Public Class ComboBoxDropDownClosedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxDropDownClosedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownClosedEventArgs

See Also

ComboBoxDropDownClosedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Members

[image] [image]

Revit 2013 API
ComboBoxDropDownClosedEventArgs Members
ComboBoxDropDownClosedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxDropDownClosedEventArgs | Initializes a new instance of the ComboBoxDropDownClosedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Constructor

[image]

Revit 2013 API
ComboBoxDropDownClosedEventArgs Constructor
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback
Initializes a new instance of the ComboBoxDropDownClosedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ComboBoxDropDownClosedEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
ComboBoxDropDownClosedEventArgs()

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Methods

[image] [image]

Revit 2013 API
ComboBoxDropDownClosedEventArgs Methods
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownClosedEventArgs Properties

[image] [image]

Revit 2013 API
ComboBoxDropDownClosedEventArgs Properties
ComboBoxDropDownClosedEventArgs Class See Also Send Feedback

The ComboBoxDropDownClosedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownClosedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Class

[image]

Revit 2013 API
ComboBoxDropDownOpenedEventArgs Class
Members See Also Send Feedback
The event arguments used by ComboBox's DropDownOpened event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ComboBoxDropDownOpenedEventArgs : RibbonItemEventArgs
Visual Basic
Public Class ComboBoxDropDownOpenedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class ComboBoxDropDownOpenedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownOpenedEventArgs

See Also

ComboBoxDropDownOpenedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Members

[image] [image]

Revit 2013 API
ComboBoxDropDownOpenedEventArgs Members
ComboBoxDropDownOpenedEventArgs Class Constructors Methods Properties See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ComboBoxDropDownOpenedEventArgs | Initializes a new instance of the ComboBoxDropDownOpenedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Constructor

[image]

Revit 2013 API
ComboBoxDropDownOpenedEventArgs Constructor
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback
Initializes a new instance of the ComboBoxDropDownOpenedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ComboBoxDropDownOpenedEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
ComboBoxDropDownOpenedEventArgs()

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Methods

[image] [image]

Revit 2013 API
ComboBoxDropDownOpenedEventArgs Methods
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ComboBoxDropDownOpenedEventArgs Properties

[image] [image]

Revit 2013 API
ComboBoxDropDownOpenedEventArgs Properties
ComboBoxDropDownOpenedEventArgs Class See Also Send Feedback

The ComboBoxDropDownOpenedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

ComboBoxDropDownOpenedEventArgs Class
Autodesk.Revit.UI.Events Namespace


CommandEventArgs Class

[image]

Revit 2013 API
CommandEventArgs Class
Members See Also Send Feedback
The base class of the command Executed and CanExecute event arguments.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class CommandEventArgs : RevitEventArgs
Visual Basic
Public Class CommandEventArgs _
    Inherits RevitEventArgs
Visual C++
public ref class CommandEventArgs : public RevitEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.UI.Events..::..CommandEventArgs
Autodesk.Revit.UI.Events..::..CanExecuteEventArgs
Autodesk.Revit.UI.Events..::..ExecutedEventArgs

See Also

CommandEventArgs Members
Autodesk.Revit.UI.Events Namespace


CommandEventArgs Members

[image] [image]

Revit 2013 API
CommandEventArgs Members
CommandEventArgs Class Methods Properties See Also Send Feedback

The CommandEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveDocument | The active document.
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CommandId | The command id.

See Also

CommandEventArgs Class
Autodesk.Revit.UI.Events Namespace


CommandEventArgs Methods

[image] [image]

Revit 2013 API
CommandEventArgs Methods
CommandEventArgs Class See Also Send Feedback

The CommandEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CommandEventArgs Class
Autodesk.Revit.UI.Events Namespace


CommandEventArgs Properties

[image] [image]

Revit 2013 API
CommandEventArgs Properties
CommandEventArgs Class See Also Send Feedback

The CommandEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ActiveDocument | The active document.
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CommandId | The command id.

See Also

CommandEventArgs Class
Autodesk.Revit.UI.Events Namespace


ActiveDocument Property

[image]

Revit 2013 API
CommandEventArgs..::..ActiveDocument Property
CommandEventArgs Class See Also Send Feedback
The active document.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public Document ActiveDocument { get; }
Visual Basic
Public ReadOnly Property ActiveDocument As Document
    Get
Visual C++
public:
property Document^ ActiveDocument {
    Document^ get ();
}

See Also

CommandEventArgs Class
Autodesk.Revit.UI.Events Namespace


CommandId Property

[image]

Revit 2013 API
CommandEventArgs..::..CommandId Property
CommandEventArgs Class See Also Send Feedback
The command id.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public RevitCommandId CommandId { get; }
Visual Basic
Public ReadOnly Property CommandId As RevitCommandId
    Get
Visual C++
public:
property RevitCommandId^ CommandId {
    RevitCommandId^ get ();
}

See Also

CommandEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Class

[image]

Revit 2013 API
DialogBoxData Class
Members See Also Send Feedback
An object that is passed to your application when a dialog is displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class DialogBoxData : APIObject
Visual Basic
Public Class DialogBoxData _
    Inherits APIObject
Visual C++
public ref class DialogBoxData : public APIObject

Remarks

When the application receives this object, a dialog has been displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI.Events..::..DialogBoxData
Autodesk.Revit.UI.Events..::..MessageBoxData

See Also

DialogBoxData Members
Autodesk.Revit.UI.Events Namespace


DialogBoxData Members

[image] [image]

Revit 2013 API
DialogBoxData Members
DialogBoxData Class Methods Properties See Also Send Feedback

The DialogBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | HelpId | An ID that represents the dialog that has been displayed.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Methods

[image] [image]

Revit 2013 API
DialogBoxData Methods
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


OverrideResult Method

[image]

Revit 2013 API
DialogBoxData..::..OverrideResult Method
DialogBoxData Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::..Int32
The result code you wish the Revit dialog to return.

Return Value

Returns true if the result code was accepted.

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxData Properties

[image] [image]

Revit 2013 API
DialogBoxData Properties
DialogBoxData Class See Also Send Feedback

The DialogBoxData type exposes the following members.

Properties

 | Name | Description
Public property | HelpId | An ID that represents the dialog that has been displayed.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


HelpId Property

[image]

Revit 2013 API
DialogBoxData..::..HelpId Property
DialogBoxData Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic
Public ReadOnly Property HelpId As Integer
    Get
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Class

[image]

Revit 2013 API
DialogBoxShowingEventArgs Class
Members See Also Send Feedback
The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class DialogBoxShowingEventArgs : PreEventArgs
Visual Basic
Public Class DialogBoxShowingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public PreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs

See Also

DialogBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Members

[image] [image]

Revit 2013 API
DialogBoxShowingEventArgs Members
DialogBoxShowingEventArgs Class Methods Properties See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Methods

[image] [image]

Revit 2013 API
DialogBoxShowingEventArgs Methods
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


OverrideResult Method

[image]

Revit 2013 API
DialogBoxShowingEventArgs..::..OverrideResult Method
DialogBoxShowingEventArgs Class See Also Send Feedback
Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool OverrideResult(
    int result
)
Visual Basic
Public Function OverrideResult ( _
    result As Integer _
) As Boolean
Visual C++
public:
bool OverrideResult(
    int result
)

Parameters

result
Type: System..::..Int32
The result code you wish the Revit dialog to return.

Return Value

True if the result code was accepted.

Remarks

The range of valid result values depends on the type of dialog as follows:
  1. DialogBox: Any non-zero value will cause a dialog to be dismissed.
  2. MessageBox: Standard Message Box IDs, such as IDOK and IDCANCEL, are accepted. For all possible IDs, refer to the Windows API documentation. The ID used must be relevant to the buttons in a message box.
  3. TaskDialog: Standard Message Box IDs and Revit Custom IDs are accepted, depending on the buttons used in a dialog. Standard buttons, such as OK and Cancel, have standard IDs described in Windows API documentation. Buttons with custom text have custom IDs with incremental values starting at 1001 for the left-most or top-most button in a task dialog.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogBoxShowingEventArgs Properties

[image] [image]

Revit 2013 API
DialogBoxShowingEventArgs Properties
DialogBoxShowingEventArgs Class See Also Send Feedback

The DialogBoxShowingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | HelpId | An ID that represents the dialog that has been displayed.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


HelpId Property

[image]

Revit 2013 API
DialogBoxShowingEventArgs..::..HelpId Property
DialogBoxShowingEventArgs Class See Also Send Feedback
An ID that represents the dialog that has been displayed.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public int HelpId { get; }
Visual Basic
Public ReadOnly Property HelpId As Integer
    Get
Visual C++
public:
property int HelpId {
    int get ();
}

Remarks

Use this ID within your application to key suitable responses for the dialog. Note: this id is not guaranteed to remain stable for different builds of Autodesk Revit.

See Also

DialogBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DisplayingOptionsDialogEventArgs Class

[image]

Revit 2013 API
DisplayingOptionsDialogEventArgs Class
Members See Also Send Feedback
The event arguments used by DisplayingOptionDialog event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class DisplayingOptionsDialogEventArgs : PreEventArgs
Visual Basic
Public Class DisplayingOptionsDialogEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class DisplayingOptionsDialogEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DisplayingOptionsDialogEventArgs

See Also

DisplayingOptionsDialogEventArgs Members
Autodesk.Revit.UI.Events Namespace


DisplayingOptionsDialogEventArgs Members

[image] [image]

Revit 2013 API
DisplayingOptionsDialogEventArgs Members
DisplayingOptionsDialogEventArgs Class Methods Properties See Also Send Feedback

The DisplayingOptionsDialogEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddTab | Add tab to option dialog with tab name and handler information.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | PagesCount | The count of pages in the options dialog (include the default pages added by Revit).

See Also

DisplayingOptionsDialogEventArgs Class
Autodesk.Revit.UI.Events Namespace


DisplayingOptionsDialogEventArgs Methods

[image] [image]

Revit 2013 API
DisplayingOptionsDialogEventArgs Methods
DisplayingOptionsDialogEventArgs Class See Also Send Feedback

The DisplayingOptionsDialogEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | AddTab | Add tab to option dialog with tab name and handler information.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DisplayingOptionsDialogEventArgs Class
Autodesk.Revit.UI.Events Namespace


AddTab Method

[image]

Revit 2013 API
DisplayingOptionsDialogEventArgs..::..AddTab Method
DisplayingOptionsDialogEventArgs Class See Also Send Feedback
Add tab to option dialog with tab name and handler information.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public void AddTab(
    string newTabName,
    TabbedDialogExtension tabbedDialogExtension
)
Visual Basic
Public Sub AddTab ( _
    newTabName As String, _
    tabbedDialogExtension As TabbedDialogExtension _
)
Visual C++
public:
void AddTab(
    String^ newTabName,
    TabbedDialogExtension^ tabbedDialogExtension
)

Parameters

newTabName
Type: System..::..String
The new tab page name.
tabbedDialogExtension
Type: Autodesk.Revit.UI..::..TabbedDialogExtension
The handlers information for the new tab page.

Remarks

There is a limit to the number of options page permitted in the dialog.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the limit of pages allowed in the Options dialog will be exceeded (99).

See Also

DisplayingOptionsDialogEventArgs Class
Autodesk.Revit.UI.Events Namespace


DisplayingOptionsDialogEventArgs Properties

[image] [image]

Revit 2013 API
DisplayingOptionsDialogEventArgs Properties
DisplayingOptionsDialogEventArgs Class See Also Send Feedback

The DisplayingOptionsDialogEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | PagesCount | The count of pages in the options dialog (include the default pages added by Revit).

See Also

DisplayingOptionsDialogEventArgs Class
Autodesk.Revit.UI.Events Namespace


PagesCount Property

[image]

Revit 2013 API
DisplayingOptionsDialogEventArgs..::..PagesCount Property
DisplayingOptionsDialogEventArgs Class See Also Send Feedback
The count of pages in the options dialog (include the default pages added by Revit).

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public int PagesCount { get; }
Visual Basic
Public ReadOnly Property PagesCount As Integer
    Get
Visual C++
public:
property int PagesCount {
    int get ();
}

See Also

DisplayingOptionsDialogEventArgs Class
Autodesk.Revit.UI.Events Namespace


ExecutedEventArgs Class

[image]

Revit 2013 API
ExecutedEventArgs Class
Members See Also Send Feedback
The event arguments used by AddInCommandBinding's Executed event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public class ExecutedEventArgs : CommandEventArgs
Visual Basic
Public Class ExecutedEventArgs _
    Inherits CommandEventArgs
Visual C++
public ref class ExecutedEventArgs : public CommandEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.UI.Events..::..CommandEventArgs
Autodesk.Revit.UI.Events..::..ExecutedEventArgs

See Also

ExecutedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ExecutedEventArgs Members

[image] [image]

Revit 2013 API
ExecutedEventArgs Members
ExecutedEventArgs Class Methods Properties See Also Send Feedback

The ExecutedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveDocument | The active document. (Inherited from CommandEventArgs.)
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CommandId | The command id. (Inherited from CommandEventArgs.)

See Also

ExecutedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ExecutedEventArgs Methods

[image] [image]

Revit 2013 API
ExecutedEventArgs Methods
ExecutedEventArgs Class See Also Send Feedback

The ExecutedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExecutedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ExecutedEventArgs Properties

[image] [image]

Revit 2013 API
ExecutedEventArgs Properties
ExecutedEventArgs Class See Also Send Feedback

The ExecutedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ActiveDocument | The active document. (Inherited from CommandEventArgs.)
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CommandId | The command id. (Inherited from CommandEventArgs.)

See Also

ExecutedEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Class

[image]

Revit 2013 API
IdlingEventArgs Class
Members See Also Send Feedback
The event arguments used by the Idling event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class IdlingEventArgs : PreEventArgs
Visual Basic
Public Class IdlingEventArgs _
    Inherits PreEventArgs
Visual C++
public ref class IdlingEventArgs : public PreEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..IdlingEventArgs

See Also

IdlingEventArgs Members
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Members

[image] [image]

Revit 2013 API
IdlingEventArgs Members
IdlingEventArgs Class Methods Properties See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetRaiseWithoutDelay | Sets the next invocation of the idling event to be called promptly, rather than relying on the default recurrence of idling from the Revit application. For more details see the remarks describing the Idling event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Methods

[image] [image]

Revit 2013 API
IdlingEventArgs Methods
IdlingEventArgs Class See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | SetRaiseWithoutDelay | Sets the next invocation of the idling event to be called promptly, rather than relying on the default recurrence of idling from the Revit application. For more details see the remarks describing the Idling event.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


SetRaiseWithoutDelay Method

[image]

Revit 2013 API
IdlingEventArgs..::..SetRaiseWithoutDelay Method
IdlingEventArgs Class See Also Send Feedback
Sets the next invocation of the idling event to be called promptly, rather than relying on the default recurrence of idling from the Revit application. For more details see the remarks describing the Idling event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void SetRaiseWithoutDelay()
Visual Basic
Public Sub SetRaiseWithoutDelay
Visual C++
public:
void SetRaiseWithoutDelay()

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


IdlingEventArgs Properties

[image] [image]

Revit 2013 API
IdlingEventArgs Properties
IdlingEventArgs Class See Also Send Feedback

The IdlingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)

See Also

IdlingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Class

[image]

Revit 2013 API
MessageBoxData Class
Members See Also Send Feedback
An object that represents a simple message box that prompts the user for some action.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class MessageBoxData : DialogBoxData
Visual Basic
Public Class MessageBoxData _
    Inherits DialogBoxData
Visual C++
public ref class MessageBoxData : public DialogBoxData

Remarks

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI.Events..::..DialogBoxData
Autodesk.Revit.UI.Events..::..MessageBoxData

See Also

MessageBoxData Members
Autodesk.Revit.UI.Events Namespace


MessageBoxData Members

[image] [image]

Revit 2013 API
MessageBoxData Members
MessageBoxData Class Methods Properties See Also Send Feedback

The MessageBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DialogType | An integer that describes the standard windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Methods

[image] [image]

Revit 2013 API
MessageBoxData Methods
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxData Properties

[image] [image]

Revit 2013 API
MessageBoxData Properties
MessageBoxData Class See Also Send Feedback

The MessageBoxData type exposes the following members.

Properties

 | Name | Description
Public property | DialogType | An integer that describes the standard windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


DialogType Property

[image]

Revit 2013 API
MessageBoxData..::..DialogType Property
MessageBoxData Class See Also Send Feedback
An integer that describes the standard windows type of the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic
Public ReadOnly Property DialogType As Integer
    Get
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2013 API
MessageBoxData..::..Message Property
MessageBoxData Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxData Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Class

[image]

Revit 2013 API
MessageBoxShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Windows message box is about to be displayed in Revit.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class MessageBoxShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic
Public Class MessageBoxShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class MessageBoxShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a simple message box is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..MessageBoxShowingEventArgs

See Also

MessageBoxShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Members

[image] [image]

Revit 2013 API
MessageBoxShowingEventArgs Members
MessageBoxShowingEventArgs Class Methods Properties See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | DialogType | An integer that describes the standard Windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Methods

[image] [image]

Revit 2013 API
MessageBoxShowingEventArgs Methods
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


MessageBoxShowingEventArgs Properties

[image] [image]

Revit 2013 API
MessageBoxShowingEventArgs Properties
MessageBoxShowingEventArgs Class See Also Send Feedback

The MessageBoxShowingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | DialogType | An integer that describes the standard Windows type of the dialog box.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Public property | Message | The message that has been displayed in the dialog box.

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogType Property

[image]

Revit 2013 API
MessageBoxShowingEventArgs..::..DialogType Property
MessageBoxShowingEventArgs Class See Also Send Feedback
An integer that describes the standard Windows type of the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public int DialogType { get; }
Visual Basic
Public ReadOnly Property DialogType As Integer
    Get
Visual C++
public:
property int DialogType {
    int get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2013 API
MessageBoxShowingEventArgs..::..Message Property
MessageBoxShowingEventArgs Class See Also Send Feedback
The message that has been displayed in the dialog box.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

MessageBoxShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Class

[image]

Revit 2013 API
RibbonItemEventArgs Class
Members See Also Send Feedback
The base class of the RibbonItem event arguments which have UIApplication property.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class RibbonItemEventArgs : EventArgs
Visual Basic
Public Class RibbonItemEventArgs _
    Inherits EventArgs
Visual C++
public ref class RibbonItemEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events..::..ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events..::..TextBoxEnterPressedEventArgs

See Also

RibbonItemEventArgs Members
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Members

[image] [image]

Revit 2013 API
RibbonItemEventArgs Members
RibbonItemEventArgs Class Constructors Methods Properties See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | RibbonItemEventArgs | Initializes a new instance of the RibbonItemEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | The current UIApplication.

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Constructor

[image]

Revit 2013 API
RibbonItemEventArgs Constructor
RibbonItemEventArgs Class See Also Send Feedback
Initializes a new instance of the RibbonItemEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public RibbonItemEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
RibbonItemEventArgs()

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Methods

[image] [image]

Revit 2013 API
RibbonItemEventArgs Methods
RibbonItemEventArgs Class See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


RibbonItemEventArgs Properties

[image] [image]

Revit 2013 API
RibbonItemEventArgs Properties
RibbonItemEventArgs Class See Also Send Feedback

The RibbonItemEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Application | The current UIApplication.

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


Application Property

[image]

Revit 2013 API
RibbonItemEventArgs..::..Application Property
RibbonItemEventArgs Class See Also Send Feedback
The current UIApplication.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic
Public ReadOnly Property Application As UIApplication
    Get
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

RibbonItemEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Class

[image]

Revit 2013 API
TaskDialogShowingEventArgs Class
Members See Also Send Feedback
The event arguments used by the DialogBoxShowing event when a Revit task dialog that prompts the user for some action is shown.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class TaskDialogShowingEventArgs : DialogBoxShowingEventArgs
Visual Basic
Public Class TaskDialogShowingEventArgs _
    Inherits DialogBoxShowingEventArgs
Visual C++
public ref class TaskDialogShowingEventArgs : public DialogBoxShowingEventArgs

Remarks

When the application receives this object, a task dialog is about to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.UI.Events..::..DialogBoxShowingEventArgs
Autodesk.Revit.UI.Events..::..TaskDialogShowingEventArgs

See Also

TaskDialogShowingEventArgs Members
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Members

[image] [image]

Revit 2013 API
TaskDialogShowingEventArgs Members
TaskDialogShowingEventArgs Class Methods Properties See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | DialogId | String ID associated with the task dialog.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Public property | Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Methods

[image] [image]

Revit 2013 API
TaskDialogShowingEventArgs Methods
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxShowingEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TaskDialogShowingEventArgs Properties

[image] [image]

Revit 2013 API
TaskDialogShowingEventArgs Properties
TaskDialogShowingEventArgs Class See Also Send Feedback

The TaskDialogShowingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | DialogId | String ID associated with the task dialog.
Public property | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxShowingEventArgs.)
Public property | Message | The message provided by the task dialog.

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


DialogId Property

[image]

Revit 2013 API
TaskDialogShowingEventArgs..::..DialogId Property
TaskDialogShowingEventArgs Class See Also Send Feedback
String ID associated with the task dialog.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string DialogId { get; }
Visual Basic
Public ReadOnly Property DialogId As String
    Get
Visual C++
public:
property String^ DialogId {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Message Property

[image]

Revit 2013 API
TaskDialogShowingEventArgs..::..Message Property
TaskDialogShowingEventArgs Class See Also Send Feedback
The message provided by the task dialog.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string Message { get; }
Visual Basic
Public ReadOnly Property Message As String
    Get
Visual C++
public:
property String^ Message {
    String^ get ();
}

See Also

TaskDialogShowingEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Class

[image]

Revit 2013 API
TextBoxEnterPressedEventArgs Class
Members See Also Send Feedback
The event arguments used by TextBox's EnterPressed event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class TextBoxEnterPressedEventArgs : RibbonItemEventArgs
Visual Basic
Public Class TextBoxEnterPressedEventArgs _
    Inherits RibbonItemEventArgs
Visual C++
public ref class TextBoxEnterPressedEventArgs : public RibbonItemEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.UI.Events..::..RibbonItemEventArgs
Autodesk.Revit.UI.Events..::..TextBoxEnterPressedEventArgs

See Also

TextBoxEnterPressedEventArgs Members
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Members

[image] [image]

Revit 2013 API
TextBoxEnterPressedEventArgs Members
TextBoxEnterPressedEventArgs Class Constructors Methods Properties See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | TextBoxEnterPressedEventArgs | Initializes a new instance of the TextBoxEnterPressedEventArgs class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Constructor

[image]

Revit 2013 API
TextBoxEnterPressedEventArgs Constructor
TextBoxEnterPressedEventArgs Class See Also Send Feedback
Initializes a new instance of the TextBoxEnterPressedEventArgs class

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public TextBoxEnterPressedEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
TextBoxEnterPressedEventArgs()

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Methods

[image] [image]

Revit 2013 API
TextBoxEnterPressedEventArgs Methods
TextBoxEnterPressedEventArgs Class See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


TextBoxEnterPressedEventArgs Properties

[image] [image]

Revit 2013 API
TextBoxEnterPressedEventArgs Properties
TextBoxEnterPressedEventArgs Class See Also Send Feedback

The TextBoxEnterPressedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Application | The current UIApplication. (Inherited from RibbonItemEventArgs.)

See Also

TextBoxEnterPressedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Class

[image]

Revit 2013 API
ViewActivatedEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivated event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewActivatedEventArgs : PostDocEventArgs
Visual Basic
Public Class ViewActivatedEventArgs _
    Inherits PostDocEventArgs
Visual C++
public ref class ViewActivatedEventArgs : public PostDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PostEventArgs
Autodesk.Revit.DB.Events..::..PostDocEventArgs
Autodesk.Revit.UI.Events..::..ViewActivatedEventArgs

See Also

ViewActivatedEventArgs Members
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Members

[image] [image]

Revit 2013 API
ViewActivatedEventArgs Members
ViewActivatedEventArgs Class Methods Properties See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CurrentActiveView | The view that has just become active.
Public property | Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Public property | PreviousActiveView | The previously active view.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Methods

[image] [image]

Revit 2013 API
ViewActivatedEventArgs Methods
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatedEventArgs Properties

[image] [image]

Revit 2013 API
ViewActivatedEventArgs Properties
ViewActivatedEventArgs Class See Also Send Feedback

The ViewActivatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CurrentActiveView | The view that has just become active.
Public property | Document | The document associated with the event. (Inherited from PostDocEventArgs.)
Public property | PreviousActiveView | The previously active view.
Public property | Status | Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an APIevent handler). (Inherited from PostEventArgs.)

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


CurrentActiveView Property

[image]

Revit 2013 API
ViewActivatedEventArgs..::..CurrentActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The view that has just become active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic
Public ReadOnly Property CurrentActiveView As View
    Get
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


PreviousActiveView Property

[image]

Revit 2013 API
ViewActivatedEventArgs..::..PreviousActiveView Property
ViewActivatedEventArgs Class See Also Send Feedback
The previously active view.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View PreviousActiveView { get; }
Visual Basic
Public ReadOnly Property PreviousActiveView As View
    Get
Visual C++
public:
property View^ PreviousActiveView {
    View^ get ();
}

Remarks

May be nullNothingnullptra null reference (Nothing in Visual Basic) if there was no previously active view.

See Also

ViewActivatedEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Class

[image]

Revit 2013 API
ViewActivatingEventArgs Class
Members See Also Send Feedback
The event arguments used by the ViewActivating event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class ViewActivatingEventArgs : PreDocEventArgs
Visual Basic
Public Class ViewActivatingEventArgs _
    Inherits PreDocEventArgs
Visual C++
public ref class ViewActivatingEventArgs : public PreDocEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Autodesk.Revit.DB.Events..::..RevitEventArgs
Autodesk.Revit.DB.Events..::..PreEventArgs
Autodesk.Revit.DB.Events..::..PreDocEventArgs
Autodesk.Revit.UI.Events..::..ViewActivatingEventArgs

See Also

ViewActivatingEventArgs Members
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Members

[image] [image]

Revit 2013 API
ViewActivatingEventArgs Members
ViewActivatingEventArgs Class Methods Properties See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CurrentActiveView | The view that is currently active.
Public property | Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Public property | NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Methods

[image] [image]

Revit 2013 API
ViewActivatingEventArgs Methods
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


ViewActivatingEventArgs Properties

[image] [image]

Revit 2013 API
ViewActivatingEventArgs Properties
ViewActivatingEventArgs Class See Also Send Feedback

The ViewActivatingEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Indicates whether the event is being cancelled. When the event is cancellable, set the property to True to cancel it. (Inherited from RevitEventArgs.)
Public property | Cancellable | Indicates whether an event may be cancelled by an event delegate. (Inherited from RevitEventArgs.)
Public property | CurrentActiveView | The view that is currently active.
Public property | Document | The document associated with the event. (Inherited from PreDocEventArgs.)
Public property | NewActiveView | The view that is going to become active.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


CurrentActiveView Property

[image]

Revit 2013 API
ViewActivatingEventArgs..::..CurrentActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is currently active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View CurrentActiveView { get; }
Visual Basic
Public ReadOnly Property CurrentActiveView As View
    Get
Visual C++
public:
property View^ CurrentActiveView {
    View^ get ();
}

Remarks

May be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no currently active view.

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


NewActiveView Property

[image]

Revit 2013 API
ViewActivatingEventArgs..::..NewActiveView Property
ViewActivatingEventArgs Class See Also Send Feedback
The view that is going to become active.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View NewActiveView { get; }
Visual Basic
Public ReadOnly Property NewActiveView As View
    Get
Visual C++
public:
property View^ NewActiveView {
    View^ get ();
}

See Also

ViewActivatingEventArgs Class
Autodesk.Revit.UI.Events Namespace


Autodesk.Revit.UI.Macros Namespace

[image]

Revit 2013 API
Autodesk.Revit.UI.Macros Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInIdAttribute | The custom AddInId attribute for Macros macros use only.
Public class | ApplicationEntryPoint | For Revit Macros use only.
Public class | DocumentEntryPoint | For Revit Macros use only.
Public class | VendorIdAttribute | The custom VendorId attribute for Macros macros use only.

Interfaces

 | Interface | Description
Public interface | IEntryPoint |


AddInIdAttribute Class

[image]

Revit 2013 API
AddInIdAttribute Class
Members See Also Send Feedback
The custom AddInId attribute for Macros macros use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public class AddInIdAttribute : Attribute
Visual Basic
Public Class AddInIdAttribute _
    Inherits Attribute
Visual C++
public ref class AddInIdAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.Macros..::..AddInIdAttribute

See Also

AddInIdAttribute Members
Autodesk.Revit.UI.Macros Namespace


AddInIdAttribute Members

[image] [image]

Revit 2013 API
AddInIdAttribute Members
AddInIdAttribute Class Constructors Methods Properties See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AddInIdAttribute | Constructs a new AddInIdAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | AddInId guid value.

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


AddInIdAttribute Constructor

[image]

Revit 2013 API
AddInIdAttribute Constructor
AddInIdAttribute Class See Also Send Feedback
Constructs a new AddInIdAttribute.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public AddInIdAttribute(
    string addInIdStr
)
Visual Basic
Public Sub New ( _
    addInIdStr As String _
)
Visual C++
public:
AddInIdAttribute(
    String^ addInIdStr
)

Parameters

addInIdStr
Type: System..::..String

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


AddInIdAttribute Methods

[image] [image]

Revit 2013 API
AddInIdAttribute Methods
AddInIdAttribute Class See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


AddInIdAttribute Properties

[image] [image]

Revit 2013 API
AddInIdAttribute Properties
AddInIdAttribute Class See Also Send Feedback

The AddInIdAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | AddInId guid value.

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


Value Property

[image]

Revit 2013 API
AddInIdAttribute..::..Value Property
AddInIdAttribute Class See Also Send Feedback
AddInId guid value.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2011

Syntax

C#
public ValueType Value { get; }
Visual Basic
Public ReadOnly Property Value As ValueType
    Get
Visual C++
public:
property ValueType^ Value {
    ValueType^ get ();
}

See Also

AddInIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Class

[image]

Revit 2013 API
ApplicationEntryPoint Class
Members See Also Send Feedback
For Revit Macros use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class ApplicationEntryPoint : IEntryPoint
Visual Basic
Public MustInherit Class ApplicationEntryPoint _
    Implements IEntryPoint
Visual C++
public ref class ApplicationEntryPoint abstract : IEntryPoint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.Macros..::..ApplicationEntryPoint

See Also

ApplicationEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Members

[image] [image]

Revit 2013 API
ApplicationEntryPoint Members
ApplicationEntryPoint Class Constructors Methods Properties Events See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Constructors

 | Name | Description
Public method | ApplicationEntryPoint | Initializes a new instance of the ApplicationEntryPoint class

Methods

 | Name | Description
Public method | CreateAddInCommandBinding |
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |
Public method | CreateRibbonTab |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) |
 | DoDragDrop(Object, IDropHandler) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |
Public method | RemoveAddInCommandBinding |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveAddInId |
Public property | ActiveUIDocument |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents |
Public property | LoadedApplications |
Public property | MainWindowExtents |

Events

 | Name | Description
Public event | ApplicationClosing |
Public event | DialogBoxShowing |
Public event | DisplayingOptionsDialog |
Public event | Idling |
Public event | ViewActivated |
Public event | ViewActivating |

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Constructor

[image]

Revit 2013 API
ApplicationEntryPoint Constructor
ApplicationEntryPoint Class See Also Send Feedback
Initializes a new instance of the ApplicationEntryPoint class

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ApplicationEntryPoint()
Visual Basic
Public Sub New
Visual C++
public:
ApplicationEntryPoint()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Methods

[image] [image]

Revit 2013 API
ApplicationEntryPoint Methods
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | CreateAddInCommandBinding |
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |
Public method | CreateRibbonTab |
 | DoDragDrop(ICollection<(Of <<'(String>)>>)) |
 | DoDragDrop(Object, IDropHandler) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |
Public method | RemoveAddInCommandBinding |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


CreateAddInCommandBinding Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..CreateAddInCommandBinding Method
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInCommandBinding CreateAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Function CreateAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
) As AddInCommandBinding
Visual C++
public:
AddInCommandBinding^ CreateAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


CreateRibbonPanel Method

[image] [image]

Revit 2013 API
ApplicationEntryPoint..::..CreateRibbonPanel Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateRibbonPanel(String) |
Public method | CreateRibbonPanel(String, String) |
Public method | CreateRibbonPanel(Tab, String) |

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


CreateRibbonPanel Method (String)

[image]

Revit 2013 API
ApplicationEntryPoint..::..CreateRibbonPanel Method (String)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ panelName
)

Parameters

panelName
Type: System..::..String

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.UI.Macros Namespace


CreateRibbonPanel Method (String, String)

[image]

Revit 2013 API
ApplicationEntryPoint..::..CreateRibbonPanel Method (String, String)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    string tabName,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tabName As String, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    String^ tabName,
    String^ panelName
)

Parameters

tabName
Type: System..::..String
panelName
Type: System..::..String

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.UI.Macros Namespace


CreateRibbonPanel Method (Tab, String)

[image]

Revit 2013 API
ApplicationEntryPoint..::..CreateRibbonPanel Method (Tab, String)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual RibbonPanel CreateRibbonPanel(
    Tab tab,
    string panelName
)
Visual Basic
Public Overridable Function CreateRibbonPanel ( _
    tab As Tab, _
    panelName As String _
) As RibbonPanel
Visual C++
public:
virtual RibbonPanel^ CreateRibbonPanel(
    Tab tab,
    String^ panelName
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab
panelName
Type: System..::..String

See Also

ApplicationEntryPoint Class
CreateRibbonPanel Overload
Autodesk.Revit.UI.Macros Namespace


CreateRibbonTab Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..CreateRibbonTab Method
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void CreateRibbonTab(
    string tabName
)
Visual Basic
Public Overridable Sub CreateRibbonTab ( _
    tabName As String _
)
Visual C++
public:
virtual void CreateRibbonTab(
    String^ tabName
)

Parameters

tabName
Type: System..::..String

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DoDragDrop Method

[image] [image]

Revit 2013 API
ApplicationEntryPoint..::..DoDragDrop Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

Name | Description
DoDragDrop(ICollection<(Of <<'(String>)>>)) |
DoDragDrop(Object, IDropHandler) |

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


DoDragDrop Method (ICollection(String))

[image]

Revit 2013 API
ApplicationEntryPoint..::..DoDragDrop Method (ICollection<(Of <(<'String>)>)>)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public static void DoDragDrop(
    ICollection<string> dropData
)
Visual Basic
Public Shared Sub DoDragDrop ( _
    dropData As ICollection(Of String) _
)
Visual C++
public:
static void DoDragDrop(
    ICollection<String^>^ dropData
)

Parameters

dropData
Type: System.Collections.Generic..::..ICollection<(Of <(<'String>)>)>

See Also

ApplicationEntryPoint Class
DoDragDrop Overload
Autodesk.Revit.UI.Macros Namespace


DoDragDrop Method (Object, IDropHandler)

[image]

Revit 2013 API
ApplicationEntryPoint..::..DoDragDrop Method (Object, IDropHandler)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public static void DoDragDrop(
    Object dropData,
    IDropHandler handler
)
Visual Basic
Public Shared Sub DoDragDrop ( _
    dropData As Object, _
    handler As IDropHandler _
)
Visual C++
public:
static void DoDragDrop(
    Object^ dropData,
    IDropHandler^ handler
)

Parameters

dropData
Type: System..::..Object
handler
Type: Autodesk.Revit.UI..::..IDropHandler

See Also

ApplicationEntryPoint Class
DoDragDrop Overload
Autodesk.Revit.UI.Macros Namespace


FinishInitializationEO Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..FinishInitializationEO Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void FinishInitializationEO()
Visual Basic
Public Sub FinishInitializationEO
Visual C++
public:
virtual void FinishInitializationEO() sealed

Implements

IEntryPoint..::..FinishInitialization()()()()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


GetRibbonPanels Method

[image] [image]

Revit 2013 API
ApplicationEntryPoint..::..GetRibbonPanels Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetRibbonPanels()()()() |
Public method | GetRibbonPanels(String) |
Public method | GetRibbonPanels(Tab) |

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


GetRibbonPanels Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..GetRibbonPanels Method
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual List<RibbonPanel> GetRibbonPanels()
Visual Basic
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel)
Visual C++
public:
virtual List<RibbonPanel^>^ GetRibbonPanels()

See Also

ApplicationEntryPoint Class
GetRibbonPanels Overload
Autodesk.Revit.UI.Macros Namespace


GetRibbonPanels Method (String)

[image]

Revit 2013 API
ApplicationEntryPoint..::..GetRibbonPanels Method (String)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    string tabName
)
Visual Basic
Public Function GetRibbonPanels ( _
    tabName As String _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    String^ tabName
)

Parameters

tabName
Type: System..::..String

See Also

ApplicationEntryPoint Class
GetRibbonPanels Overload
Autodesk.Revit.UI.Macros Namespace


GetRibbonPanels Method (Tab)

[image]

Revit 2013 API
ApplicationEntryPoint..::..GetRibbonPanels Method (Tab)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public List<RibbonPanel> GetRibbonPanels(
    Tab tab
)
Visual Basic
Public Function GetRibbonPanels ( _
    tab As Tab _
) As List(Of RibbonPanel)
Visual C++
public:
List<RibbonPanel^>^ GetRibbonPanels(
    Tab tab
)

Parameters

tab
Type: Autodesk.Revit.UI..::..Tab

See Also

ApplicationEntryPoint Class
GetRibbonPanels Overload
Autodesk.Revit.UI.Macros Namespace


Initialize Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..Initialize Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic
Public Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
public:
virtual void Initialize(
    Object^ obj,
    String^ addinFolder
) sealed

Parameters

obj
Type: System..::..Object
addinFolder
Type: System..::..String

Implements

IEntryPoint..::..Initialize(Object, String)

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


OnShutdownEO Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..OnShutdownEO Method
ApplicationEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void OnShutdownEO()
Visual Basic
Public Sub OnShutdownEO
Visual C++
public:
virtual void OnShutdownEO() sealed

Implements

IEntryPoint..::..OnShutdown()()()()

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


OpenAndActivateDocument Method

[image] [image]

Revit 2013 API
ApplicationEntryPoint..::..OpenAndActivateDocument Method
ApplicationEntryPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OpenAndActivateDocument(String) |
Public method | OpenAndActivateDocument(ModelPath, OpenOptionsForUI) |

See Also

ApplicationEntryPoint Class
ApplicationEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


OpenAndActivateDocument Method (String)

[image]

Revit 2013 API
ApplicationEntryPoint..::..OpenAndActivateDocument Method (String)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIDocument OpenAndActivateDocument(
    string fileName
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    fileName As String _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    String^ fileName
)

Parameters

fileName
Type: System..::..String

See Also

ApplicationEntryPoint Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI.Macros Namespace


OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)

[image]

Revit 2013 API
ApplicationEntryPoint..::..OpenAndActivateDocument Method (ModelPath, OpenOptionsForUI)
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIDocument OpenAndActivateDocument(
    ModelPath modelPath,
    OpenOptionsForUI openOptions
)
Visual Basic
Public Function OpenAndActivateDocument ( _
    modelPath As ModelPath, _
    openOptions As OpenOptionsForUI _
) As UIDocument
Visual C++
public:
UIDocument^ OpenAndActivateDocument(
    ModelPath^ modelPath,
    OpenOptionsForUI^ openOptions
)

Parameters

modelPath
Type: Autodesk.Revit.DB..::..ModelPath
openOptions
Type: Autodesk.Revit.UI..::..OpenOptionsForUI

See Also

ApplicationEntryPoint Class
OpenAndActivateDocument Overload
Autodesk.Revit.UI.Macros Namespace


RemoveAddInCommandBinding Method

[image]

Revit 2013 API
ApplicationEntryPoint..::..RemoveAddInCommandBinding Method
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void RemoveAddInCommandBinding(
    RevitCommandId revitCommandId
)
Visual Basic
Public Sub RemoveAddInCommandBinding ( _
    revitCommandId As RevitCommandId _
)
Visual C++
public:
void RemoveAddInCommandBinding(
    RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UI..::..RevitCommandId

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Properties

[image] [image]

Revit 2013 API
ApplicationEntryPoint Properties
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAddInId |
Public property | ActiveUIDocument |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application | Returns the database level Application represented by this UI level Application.
Public property | DrawingAreaExtents |
Public property | LoadedApplications |
Public property | MainWindowExtents |

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ActiveAddInId Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..ActiveAddInId Property
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public AddInId ActiveAddInId { get; }
Visual Basic
Public ReadOnly Property ActiveAddInId As AddInId
    Get
Visual C++
public:
property AddInId^ ActiveAddInId {
    AddInId^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ActiveUIDocument Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..ActiveUIDocument Property
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual UIDocument ActiveUIDocument { get; }
Visual Basic
Public Overridable ReadOnly Property ActiveUIDocument As UIDocument
    Get
Visual C++
public:
virtual property UIDocument^ ActiveUIDocument {
    UIDocument^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


AddinFolder Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..AddinFolder Property
ApplicationEntryPoint Class See Also Send Feedback
The full path to the Revit Macros module.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string AddinFolder { get; }
Visual Basic
Public ReadOnly Property AddinFolder As String
    Get
Visual C++
public:
virtual property String^ AddinFolder {
    String^ get () sealed;
}

Implements

IEntryPoint..::..AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the Macros module is loaded in such a way to make that result unreliable.

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Application Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..Application Property
ApplicationEntryPoint Class See Also Send Feedback
Returns the database level Application represented by this UI level Application.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Application Application { get; }
Visual Basic
Public ReadOnly Property Application As Application
    Get
Visual C++
public:
property Application^ Application {
    Application^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DrawingAreaExtents Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..DrawingAreaExtents Property
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Rectangle DrawingAreaExtents { get; }
Visual Basic
Public Overridable ReadOnly Property DrawingAreaExtents As Rectangle
    Get
Visual C++
public:
virtual property Rectangle^ DrawingAreaExtents {
    Rectangle^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


LoadedApplications Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..LoadedApplications Property
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual ExternalApplicationArray LoadedApplications { get; }
Visual Basic
Public Overridable ReadOnly Property LoadedApplications As ExternalApplicationArray
    Get
Visual C++
public:
virtual property ExternalApplicationArray^ LoadedApplications {
    ExternalApplicationArray^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


MainWindowExtents Property

[image]

Revit 2013 API
ApplicationEntryPoint..::..MainWindowExtents Property
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Rectangle MainWindowExtents { get; }
Visual Basic
Public Overridable ReadOnly Property MainWindowExtents As Rectangle
    Get
Visual C++
public:
virtual property Rectangle^ MainWindowExtents {
    Rectangle^ get ();
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ApplicationEntryPoint Events

[image] [image]

Revit 2013 API
ApplicationEntryPoint Events
ApplicationEntryPoint Class See Also Send Feedback

The ApplicationEntryPoint type exposes the following members.

Events

 | Name | Description
Public event | ApplicationClosing |
Public event | DialogBoxShowing |
Public event | DisplayingOptionsDialog |
Public event | Idling |
Public event | ViewActivated |
Public event | ViewActivating |

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ApplicationClosing Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..ApplicationClosing Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing
Visual Basic
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs)
Visual C++
public:
 event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing {
    void add (EventHandler<ApplicationClosingEventArgs^>^ value);
    void remove (EventHandler<ApplicationClosingEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DialogBoxShowing Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..DialogBoxShowing Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<DialogBoxShowingEventArgs> DialogBoxShowing
Visual Basic
Public Event DialogBoxShowing As EventHandler(Of DialogBoxShowingEventArgs)
Visual C++
public:
 event EventHandler<DialogBoxShowingEventArgs^>^ DialogBoxShowing {
    void add (EventHandler<DialogBoxShowingEventArgs^>^ value);
    void remove (EventHandler<DialogBoxShowingEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DisplayingOptionsDialog Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..DisplayingOptionsDialog Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<DisplayingOptionsDialogEventArgs> DisplayingOptionsDialog
Visual Basic
Public Event DisplayingOptionsDialog As EventHandler(Of DisplayingOptionsDialogEventArgs)
Visual C++
public:
 event EventHandler<DisplayingOptionsDialogEventArgs^>^ DisplayingOptionsDialog {
    void add (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
    void remove (EventHandler<DisplayingOptionsDialogEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Idling Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..Idling Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<IdlingEventArgs> Idling
Visual Basic
Public Event Idling As EventHandler(Of IdlingEventArgs)
Visual C++
public:
 event EventHandler<IdlingEventArgs^>^ Idling {
    void add (EventHandler<IdlingEventArgs^>^ value);
    void remove (EventHandler<IdlingEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ViewActivated Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..ViewActivated Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatedEventArgs> ViewActivated
Visual Basic
Public Event ViewActivated As EventHandler(Of ViewActivatedEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatedEventArgs^>^ ViewActivated {
    void add (EventHandler<ViewActivatedEventArgs^>^ value);
    void remove (EventHandler<ViewActivatedEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ViewActivating Event

[image]

Revit 2013 API
ApplicationEntryPoint..::..ViewActivating Event
ApplicationEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public event EventHandler<ViewActivatingEventArgs> ViewActivating
Visual Basic
Public Event ViewActivating As EventHandler(Of ViewActivatingEventArgs)
Visual C++
public:
 event EventHandler<ViewActivatingEventArgs^>^ ViewActivating {
    void add (EventHandler<ViewActivatingEventArgs^>^ value);
    void remove (EventHandler<ViewActivatingEventArgs^>^ value);
}

See Also

ApplicationEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DocumentEntryPoint Class

[image]

Revit 2013 API
DocumentEntryPoint Class
Members See Also Send Feedback
For Revit Macros use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class DocumentEntryPoint : IEntryPoint
Visual Basic
Public MustInherit Class DocumentEntryPoint _
    Implements IEntryPoint
Visual C++
public ref class DocumentEntryPoint abstract : IEntryPoint

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.Macros..::..DocumentEntryPoint

See Also

DocumentEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


DocumentEntryPoint Members

[image] [image]

Revit 2013 API
DocumentEntryPoint Members
DocumentEntryPoint Class Constructors Methods Properties See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Constructors

 | Name | Description
Public method | DocumentEntryPoint | Initializes a new instance of the DocumentEntryPoint class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews |
 | GetRevitUIFamilyLoadOptions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | PromptForFamilyInstancePlacement |
Public method | RefreshActiveView |
Public method | SaveAndClose |
Public method | SaveAs |
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveView |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application |
Public property | Document |
Public property | Selection |

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DocumentEntryPoint Constructor

[image]

Revit 2013 API
DocumentEntryPoint Constructor
DocumentEntryPoint Class See Also Send Feedback
Initializes a new instance of the DocumentEntryPoint class

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public DocumentEntryPoint()
Visual Basic
Public Sub New
Visual C++
public:
DocumentEntryPoint()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


DocumentEntryPoint Methods

[image] [image]

Revit 2013 API
DocumentEntryPoint Methods
DocumentEntryPoint Class See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FinishInitializationEO | For Revit Macros internal use only.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOpenUIViews |
 | GetRevitUIFamilyLoadOptions |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | For Revit Macros internal use only.
Public method | OnShutdownEO | For Revit Macros internal use only.
Public method | PromptForFamilyInstancePlacement |
Public method | RefreshActiveView |
Public method | SaveAndClose |
Public method | SaveAs |
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


FinishInitializationEO Method

[image]

Revit 2013 API
DocumentEntryPoint..::..FinishInitializationEO Method
DocumentEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void FinishInitializationEO()
Visual Basic
Public Sub FinishInitializationEO
Visual C++
public:
virtual void FinishInitializationEO() sealed

Implements

IEntryPoint..::..FinishInitialization()()()()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


GetOpenUIViews Method

[image]

Revit 2013 API
DocumentEntryPoint..::..GetOpenUIViews Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<UIView> GetOpenUIViews()
Visual Basic
Public Function GetOpenUIViews As IList(Of UIView)
Visual C++
public:
IList<UIView^>^ GetOpenUIViews()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


GetRevitUIFamilyLoadOptions Method

[image]

Revit 2013 API
DocumentEntryPoint..::..GetRevitUIFamilyLoadOptions Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public static IFamilyLoadOptions GetRevitUIFamilyLoadOptions()
Visual Basic
Public Shared Function GetRevitUIFamilyLoadOptions As IFamilyLoadOptions
Visual C++
public:
static IFamilyLoadOptions^ GetRevitUIFamilyLoadOptions()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Initialize Method

[image]

Revit 2013 API
DocumentEntryPoint..::..Initialize Method
DocumentEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic
Public Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
public:
virtual void Initialize(
    Object^ obj,
    String^ addinFolder
) sealed

Parameters

obj
Type: System..::..Object
addinFolder
Type: System..::..String

Implements

IEntryPoint..::..Initialize(Object, String)

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


OnShutdownEO Method

[image]

Revit 2013 API
DocumentEntryPoint..::..OnShutdownEO Method
DocumentEntryPoint Class See Also Send Feedback
For Revit Macros internal use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void OnShutdownEO()
Visual Basic
Public Sub OnShutdownEO
Visual C++
public:
virtual void OnShutdownEO() sealed

Implements

IEntryPoint..::..OnShutdown()()()()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


PromptForFamilyInstancePlacement Method

[image]

Revit 2013 API
DocumentEntryPoint..::..PromptForFamilyInstancePlacement Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void PromptForFamilyInstancePlacement(
    FamilySymbol familySymbol
)
Visual Basic
Public Sub PromptForFamilyInstancePlacement ( _
    familySymbol As FamilySymbol _
)
Visual C++
public:
void PromptForFamilyInstancePlacement(
    FamilySymbol^ familySymbol
)

Parameters

familySymbol
Type: Autodesk.Revit.DB..::..FamilySymbol

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


RefreshActiveView Method

[image]

Revit 2013 API
DocumentEntryPoint..::..RefreshActiveView Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void RefreshActiveView()
Visual Basic
Public Sub RefreshActiveView
Visual C++
public:
void RefreshActiveView()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


SaveAndClose Method

[image]

Revit 2013 API
DocumentEntryPoint..::..SaveAndClose Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAndClose()
Visual Basic
Public Function SaveAndClose As Boolean
Visual C++
public:
bool SaveAndClose()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


SaveAs Method

[image]

Revit 2013 API
DocumentEntryPoint..::..SaveAs Method
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public bool SaveAs()
Visual Basic
Public Function SaveAs As Boolean
Visual C++
public:
bool SaveAs()

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ShowElements Method

[image] [image]

Revit 2013 API
DocumentEntryPoint..::..ShowElements Method
DocumentEntryPoint Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ShowElements(Element) |
Public method | ShowElements(ElementId) |
Public method | ShowElements(ICollection<(Of <<'(ElementId>)>>)) |
Public method | ShowElements(ElementSet) |

See Also

DocumentEntryPoint Class
DocumentEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


ShowElements Method (Element)

[image]

Revit 2013 API
DocumentEntryPoint..::..ShowElements Method (Element)
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    Element element
)
Visual Basic
Public Sub ShowElements ( _
    element As Element _
)
Visual C++
public:
void ShowElements(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.UI.Macros Namespace


ShowElements Method (ElementId)

[image]

Revit 2013 API
DocumentEntryPoint..::..ShowElements Method (ElementId)
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ElementId elementId
)
Visual Basic
Public Sub ShowElements ( _
    elementId As ElementId _
)
Visual C++
public:
void ShowElements(
    ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB..::..ElementId

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.UI.Macros Namespace


ShowElements Method (ICollection(ElementId))

[image]

Revit 2013 API
DocumentEntryPoint..::..ShowElements Method (ICollection<(Of <(<'ElementId>)>)>)
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ICollection<ElementId> elementIds
)
Visual Basic
Public Sub ShowElements ( _
    elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
void ShowElements(
    ICollection<ElementId^>^ elementIds
)

Parameters

elementIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.UI.Macros Namespace


ShowElements Method (ElementSet)

[image]

Revit 2013 API
DocumentEntryPoint..::..ShowElements Method (ElementSet)
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public void ShowElements(
    ElementSet elements
)
Visual Basic
Public Sub ShowElements ( _
    elements As ElementSet _
)
Visual C++
public:
void ShowElements(
    ElementSet^ elements
)

Parameters

elements
Type: Autodesk.Revit.DB..::..ElementSet

See Also

DocumentEntryPoint Class
ShowElements Overload
Autodesk.Revit.UI.Macros Namespace


DocumentEntryPoint Properties

[image] [image]

Revit 2013 API
DocumentEntryPoint Properties
DocumentEntryPoint Class See Also Send Feedback

The DocumentEntryPoint type exposes the following members.

Properties

 | Name | Description
Public property | ActiveView |
Public property | AddinFolder | The full path to the Revit Macros module.
Public property | Application |
Public property | Document |
Public property | Selection |

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


ActiveView Property

[image]

Revit 2013 API
DocumentEntryPoint..::..ActiveView Property
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public View ActiveView { get; set; }
Visual Basic
Public Property ActiveView As View
    Get
    Set
Visual C++
public:
property View^ ActiveView {
    View^ get ();
    void set (View^ value);
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


AddinFolder Property

[image]

Revit 2013 API
DocumentEntryPoint..::..AddinFolder Property
DocumentEntryPoint Class See Also Send Feedback
The full path to the Revit Macros module.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public string AddinFolder { get; }
Visual Basic
Public ReadOnly Property AddinFolder As String
    Get
Visual C++
public:
virtual property String^ AddinFolder {
    String^ get () sealed;
}

Implements

IEntryPoint..::..AddinFolder

Remarks

This path should be used instead of the .NET GetExecutingAssembly() result, because the Macros module is loaded in such a way to make that result unreliable.

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Application Property

[image]

Revit 2013 API
DocumentEntryPoint..::..Application Property
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public UIApplication Application { get; }
Visual Basic
Public ReadOnly Property Application As UIApplication
    Get
Visual C++
public:
property UIApplication^ Application {
    UIApplication^ get ();
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Document Property

[image]

Revit 2013 API
DocumentEntryPoint..::..Document Property
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Document Document { get; }
Visual Basic
Public ReadOnly Property Document As Document
    Get
Visual C++
public:
property Document^ Document {
    Document^ get ();
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


Selection Property

[image]

Revit 2013 API
DocumentEntryPoint..::..Selection Property
DocumentEntryPoint Class See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Selection Selection { get; }
Visual Basic
Public ReadOnly Property Selection As Selection
    Get
Visual C++
public:
property Selection^ Selection {
    Selection^ get ();
}

See Also

DocumentEntryPoint Class
Autodesk.Revit.UI.Macros Namespace


IEntryPoint Interface

[image]

Revit 2013 API
IEntryPoint Interface
Members See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface IEntryPoint
Visual Basic
Public Interface IEntryPoint
Visual C++
public interface class IEntryPoint

See Also

IEntryPoint Members
Autodesk.Revit.UI.Macros Namespace


IEntryPoint Members

[image] [image]

Revit 2013 API
IEntryPoint Members
IEntryPoint Interface Methods Properties See Also Send Feedback

The IEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | FinishInitialization |
Public method | Initialize |
Public method | OnShutdown |

Properties

 | Name | Description
Public property | AddinFolder |

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


IEntryPoint Methods

[image] [image]

Revit 2013 API
IEntryPoint Methods
IEntryPoint Interface See Also Send Feedback

The IEntryPoint type exposes the following members.

Methods

 | Name | Description
Public method | FinishInitialization |
Public method | Initialize |
Public method | OnShutdown |

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


FinishInitialization Method

[image]

Revit 2013 API
IEntryPoint..::..FinishInitialization Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
void FinishInitialization()
Visual Basic
Sub FinishInitialization
Visual C++
void FinishInitialization()

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


Initialize Method

[image]

Revit 2013 API
IEntryPoint..::..Initialize Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
void Initialize(
    Object obj,
    string addinFolder
)
Visual Basic
Sub Initialize ( _
    obj As Object, _
    addinFolder As String _
)
Visual C++
void Initialize(
    Object^ obj,
    String^ addinFolder
)

Parameters

obj
Type: System..::..Object
addinFolder
Type: System..::..String

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


OnShutdown Method

[image]

Revit 2013 API
IEntryPoint..::..OnShutdown Method
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
void OnShutdown()
Visual Basic
Sub OnShutdown
Visual C++
void OnShutdown()

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


IEntryPoint Properties

[image] [image]

Revit 2013 API
IEntryPoint Properties
IEntryPoint Interface See Also Send Feedback

The IEntryPoint type exposes the following members.

Properties

 | Name | Description
Public property | AddinFolder |

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


AddinFolder Property

[image]

Revit 2013 API
IEntryPoint..::..AddinFolder Property
IEntryPoint Interface See Also Send Feedback

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
string AddinFolder { get; }
Visual Basic
ReadOnly Property AddinFolder As String
    Get
Visual C++
property String^ AddinFolder {
    String^ get ();
}

See Also

IEntryPoint Interface
Autodesk.Revit.UI.Macros Namespace


VendorIdAttribute Class

[image]

Revit 2013 API
VendorIdAttribute Class
Members See Also Send Feedback
The custom VendorId attribute for Macros macros use only.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public class VendorIdAttribute : Attribute
Visual Basic
Public Class VendorIdAttribute _
    Inherits Attribute
Visual C++
public ref class VendorIdAttribute : public Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
Autodesk.Revit.UI.Macros..::..VendorIdAttribute

See Also

VendorIdAttribute Members
Autodesk.Revit.UI.Macros Namespace


VendorIdAttribute Members

[image] [image]

Revit 2013 API
VendorIdAttribute Members
VendorIdAttribute Class Constructors Methods Properties See Also Send Feedback

The VendorIdAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | VendorIdAttribute | Constructs a new VendorIdAttribute.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | AddInId VendorId value.

See Also

VendorIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


VendorIdAttribute Constructor

[image]

Revit 2013 API
VendorIdAttribute Constructor
VendorIdAttribute Class See Also Send Feedback
Constructs a new VendorIdAttribute.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public VendorIdAttribute(
    string vendorIdStr
)
Visual Basic
Public Sub New ( _
    vendorIdStr As String _
)
Visual C++
public:
VendorIdAttribute(
    String^ vendorIdStr
)

Parameters

vendorIdStr
Type: System..::..String

See Also

VendorIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


VendorIdAttribute Methods

[image] [image]

Revit 2013 API
VendorIdAttribute Methods
VendorIdAttribute Class See Also Send Feedback

The VendorIdAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VendorIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


VendorIdAttribute Properties

[image] [image]

Revit 2013 API
VendorIdAttribute Properties
VendorIdAttribute Class See Also Send Feedback

The VendorIdAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Value | AddInId VendorId value.

See Also

VendorIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


Value Property

[image]

Revit 2013 API
VendorIdAttribute..::..Value Property
VendorIdAttribute Class See Also Send Feedback
AddInId VendorId value.

Namespace: Autodesk.Revit.UI.Macros
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0
Since: 2012

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

VendorIdAttribute Class
Autodesk.Revit.UI.Macros Namespace


Autodesk.Revit.UI.Selection Namespace

[image]

Revit 2013 API
Autodesk.Revit.UI.Selection Namespace
Send Feedback

Classes

 | Class | Description
Public class | PickedBox | A class that contains two XYZ points representing the pick box on the screen.
Public class | Selection | Contains the current user selection of elements within the project.
Public class | SelElementSet | This class contains the current user selection of elements within the project.

Interfaces

 | Interface | Description
Public interface | ISelectionFilter | An interface that provides the ability to filter objects during a selection operation.

Enumerations

 | Enumeration | Description
Public enumeration | ObjectSnapTypes | This enumerated type contains object snap types allowed to be set during PickPoint operations.
Public enumeration | ObjectType | This enumerated type contains object types allowed to be selected during selection operations.
Public enumeration | PickBoxStyle | The enum that controls the style of the pick box.


ISelectionFilter Interface

[image]

Revit 2013 API
ISelectionFilter Interface
Members Example See Also Send Feedback
An interface that provides the ability to filter objects during a selection operation.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public interface ISelectionFilter
Visual Basic
Public Interface ISelectionFilter
Visual C++
public interface class ISelectionFilter

Examples

CopyC#
public static IList<Element> GetManyRefByRectangle(UIDocument doc)
{
    ReferenceArray ra = new ReferenceArray();
    ISelectionFilter selFilter = new MassSelectionFilter();
    IList<Element> eList = doc.Selection.PickElementsByRectangle(selFilter,
        "Select multiple faces") as IList<Element>;
    return eList;
}

public class MassSelectionFilter : ISelectionFilter
{
    public bool AllowElement(Element element)
    {
        if (element.Category.Name == "Mass")
        {
            return true;
        }
        return false;
    }

    public bool AllowReference(Reference refer, XYZ point)
    {
        return false;
    }
}
CopyVB.NET
Public Shared Function GetManyRefByRectangle(ByVal doc As UIDocument) As IList(Of Autodesk.Revit.DB.Element)
    Dim ra As New ReferenceArray()
    Dim selFilter As ISelectionFilter = New MassSelectionFilter()
    Dim eList As IList(Of Autodesk.Revit.DB.Element) = TryCast(doc.Selection.PickElementsByRectangle(selFilter, "Select multiple faces"), IList(Of Autodesk.Revit.DB.Element))
    Return eList
End Function

Public Class MassSelectionFilter
    Implements ISelectionFilter
    Public Function AllowElement(ByVal element As Autodesk.Revit.DB.Element) As Boolean Implements ISelectionFilter.AllowElement
        If element.Category.Name = "Mass" Then
            Return True
        End If
        Return False
    End Function

    Public Function AllowReference(ByVal refer As Reference, ByVal point As Autodesk.Revit.DB.XYZ) As Boolean Implements ISelectionFilter.AllowReference
        Return False
    End Function
End Class

See Also

ISelectionFilter Members
Autodesk.Revit.UI.Selection Namespace


ISelectionFilter Members

[image] [image]

Revit 2013 API
ISelectionFilter Members
ISelectionFilter Interface Methods See Also Send Feedback

The ISelectionFilter type exposes the following members.

Methods

 | Name | Description
Public method | AllowElement | Override this pre-filter method to specify if the element should be permitted to be selected.
Public method | AllowReference | Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


ISelectionFilter Methods

[image] [image]

Revit 2013 API
ISelectionFilter Methods
ISelectionFilter Interface See Also Send Feedback

The ISelectionFilter type exposes the following members.

Methods

 | Name | Description
Public method | AllowElement | Override this pre-filter method to specify if the element should be permitted to be selected.
Public method | AllowReference | Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


AllowElement Method

[image]

Revit 2013 API
ISelectionFilter..::..AllowElement Method
ISelectionFilter Interface See Also Send Feedback
Override this pre-filter method to specify if the element should be permitted to be selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
bool AllowElement(
    Element elem
)
Visual Basic
Function AllowElement ( _
    elem As Element _
) As Boolean
Visual C++
bool AllowElement(
    Element^ elem
)

Parameters

elem
Type: Autodesk.Revit.DB..::..Element
A candidate element in selection operation.

Return Value

Return true to allow the user to select this candidate element. Return false to prevent selection of this element.

Remarks

If an exception is thrown from this method, the element will not be permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


AllowReference Method

[image]

Revit 2013 API
ISelectionFilter..::..AllowReference Method
ISelectionFilter Interface See Also Send Feedback
Override this post-filter method to specify if a reference to a piece of geometry is permitted to be selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
bool AllowReference(
    Reference reference,
    XYZ position
)
Visual Basic
Function AllowReference ( _
    reference As Reference, _
    position As XYZ _
) As Boolean
Visual C++
bool AllowReference(
    Reference^ reference,
    XYZ^ position
)

Parameters

reference
Type: Autodesk.Revit.DB..::..Reference
A candidate reference in selection operation.
position
Type: Autodesk.Revit.DB..::..XYZ
The 3D position of the mouse on the candidate reference.

Return Value

Return true to allow the user to select this candidate reference. Return false to prevent selection of this candidate.

Remarks

If an exception is thrown from this method, the element will not be permitted to be selected.

See Also

ISelectionFilter Interface
Autodesk.Revit.UI.Selection Namespace


ObjectSnapTypes Enumeration

[image]

Revit 2013 API
ObjectSnapTypes Enumeration
See Also Send Feedback
This enumerated type contains object snap types allowed to be set during PickPoint operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
[FlagsAttribute]
public enum ObjectSnapTypes
Visual Basic
<FlagsAttribute> _
Public Enumeration ObjectSnapTypes
Visual C++
[FlagsAttribute]
public enum class ObjectSnapTypes

Members

Member name | Description
None | Snaps to nothing.
Endpoints | Snaps to the endpoint of an element or component.
Midpoints | Snaps to the midpoint of an element or component.
Nearest | Snaps to the nearest element or component.
WorkPlaneGrid | Snaps to a work plane grid.
Intersections | Snaps to intersections.
Centers | Snaps to the center of an arc.
Perpendicular | Snaps to perpendicular elements or components.
Tangents | Snaps tangent to an arc.
Quadrants | Snaps to quadrant points. For arcs, jump snaps are enabled.
Points | Snaps to site points.

See Also

Autodesk.Revit.UI.Selection Namespace


ObjectType Enumeration

[image]

Revit 2013 API
ObjectType Enumeration
See Also Send Feedback
This enumerated type contains object types allowed to be selected during selection operations.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum ObjectType
Visual Basic
Public Enumeration ObjectType
Visual C++
public enum class ObjectType

Members

Member name | Description
Nothing | Nothing.
Element | Whole element.
PointOnElement | Any point on an element (on a face or curve).
Edge | Any model edge.
Face | Any face.

See Also

Autodesk.Revit.UI.Selection Namespace


PickBoxStyle Enumeration

[image]

Revit 2013 API
PickBoxStyle Enumeration
See Also Send Feedback
The enum that controls the style of the pick box.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public enum PickBoxStyle
Visual Basic
Public Enumeration PickBoxStyle
Visual C++
public enum class PickBoxStyle

Members

Member name | Description
Crossing | Draws the box with the style that is used when selecting objects completely or partially inside the box.
Enclosing | Draws the box with the style that is used when selecting objects that are completely enclosed by the box.
Directional | The style of the box depends on the direction in which the box is being drawn. It uses the Crossing style if it is being drawn from right to left, or the Enclosing style when drawn in the opposite direction.

See Also

Autodesk.Revit.UI.Selection Namespace


PickedBox Class

[image]

Revit 2013 API
PickedBox Class
Members See Also Send Feedback
A class that contains two XYZ points representing the pick box on the screen.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class PickedBox
Visual Basic
Public Class PickedBox
Visual C++
public ref class PickedBox

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.UI.Selection..::..PickedBox

See Also

PickedBox Members
Autodesk.Revit.UI.Selection Namespace


PickedBox Members

[image] [image]

Revit 2013 API
PickedBox Members
PickedBox Class Methods Properties See Also Send Feedback

The PickedBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Max | Maximum coordinates (upper-right-front corner of the pick box).
Public property | Min | Minimum coordinates (lower-left-rear corner of the pick box).

See Also

PickedBox Class
Autodesk.Revit.UI.Selection Namespace


PickedBox Methods

[image] [image]

Revit 2013 API
PickedBox Methods
PickedBox Class See Also Send Feedback

The PickedBox type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PickedBox Class
Autodesk.Revit.UI.Selection Namespace


PickedBox Properties

[image] [image]

Revit 2013 API
PickedBox Properties
PickedBox Class See Also Send Feedback

The PickedBox type exposes the following members.

Properties

 | Name | Description
Public property | Max | Maximum coordinates (upper-right-front corner of the pick box).
Public property | Min | Minimum coordinates (lower-left-rear corner of the pick box).

See Also

PickedBox Class
Autodesk.Revit.UI.Selection Namespace


Max Property

[image]

Revit 2013 API
PickedBox..::..Max Property
PickedBox Class See Also Send Feedback
Maximum coordinates (upper-right-front corner of the pick box).

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Max { get; set; }
Visual Basic
Public Property Max As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Max {
    XYZ^ get ();
    void set (XYZ^ value);
}

See Also

PickedBox Class
Autodesk.Revit.UI.Selection Namespace


Min Property

[image]

Revit 2013 API
PickedBox..::..Min Property
PickedBox Class See Also Send Feedback
Minimum coordinates (lower-left-rear corner of the pick box).

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ Min { get; set; }
Visual Basic
Public Property Min As XYZ
    Get
    Set
Visual C++
public:
property XYZ^ Min {
    XYZ^ get ();
    void set (XYZ^ value);
}

See Also

PickedBox Class
Autodesk.Revit.UI.Selection Namespace


Selection Class

[image]

Revit 2013 API
Selection Class
Members Example See Also Send Feedback
Contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class Selection : APIObject
Visual Basic
Public Class Selection _
    Inherits APIObject
Visual C++
public ref class Selection : public APIObject

Remarks

The Selection object is used to retrieve the current user selected elements when an external API command is executed.

Examples

CopyC#
[Autodesk.Revit.Attributes.Transaction(TransactionMode.ReadOnly)]
[Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)]
public class Document_Selection : IExternalCommand
{
    public Autodesk.Revit.UI.Result Execute(ExternalCommandData commandData,
        ref string message, ElementSet elements)
    {
        try
        {
            // Select some elements in Revit before invoking this command

            // Get the handle of current document.
            UIDocument uidoc = commandData.Application.ActiveUIDocument;

            // Get the element selection of current document.
            Selection selection = uidoc.Selection;
            ElementSet collection = selection.Elements;

            if (0 == collection.Size)
            {
                // If no elements selected.
                TaskDialog.Show("Revit","You haven't selected any elements.");
            }
            else
            {
                String info = "Ids of selected elements in the document are: ";
                foreach (Element elem in collection)
                {
                   info += "\n\t" + elem.Id.IntegerValue;
                }

                TaskDialog.Show("Revit",info);
            }
        }
        catch (Exception e)
        {
            message = e.Message;
            return Autodesk.Revit.UI.Result.Failed;
        }

        return Autodesk.Revit.UI.Result.Succeeded;
    }
    /// </ExampleMethod>
}
CopyVB.NET
<Autodesk.Revit.Attributes.Transaction(TransactionMode.[ReadOnly])> _
<Autodesk.Revit.Attributes.Regeneration(RegenerationOption.Manual)> _
Public Class Document_Selection
    Implements IExternalCommand
    Public Function Execute(ByVal commandData As ExternalCommandData, ByRef message As String, ByVal elements As ElementSet) As Autodesk.Revit.UI.Result Implements IExternalCommand.Execute
        Try
            ' Select some elements in Revit before invoking this command

            ' Get the handle of current document.
            Dim uidoc As UIDocument = commandData.Application.ActiveUIDocument

            ' Get the element selection of current document.
            Dim selection As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
            Dim collection As ElementSet = selection.Elements

            If 0 = collection.Size Then
                ' If no elements selected.
                TaskDialog.Show("Revit", "You haven't selected any elements.")
            Else
                Dim info As [String] = "Ids of selected elements in the document are: "
                For Each elem As Autodesk.Revit.DB.Element In collection
                    info += vbLf & vbTab + elem.Id.IntegerValue
                Next

                TaskDialog.Show("Revit", info)
            End If
        Catch e As Exception
            message = e.Message
            Return Autodesk.Revit.UI.Result.Failed
        End Try

        Return Autodesk.Revit.UI.Result.Succeeded
    End Function
    ' </ExampleMethod>
End Class

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.UI.Selection..::..Selection

See Also

Selection Members
Autodesk.Revit.UI.Selection Namespace


Selection Members

[image] [image]

Revit 2013 API
Selection Members
Selection Class Methods Properties See Also Send Feedback

The Selection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementIds | The ids of the elements that are currently selected.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickBox(PickBoxStyle) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickBox(PickBoxStyle, String) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickElementsByRectangle()()()() | Prompts the user to select multiple elements by drawing a rectangle.
Public method | PickElementsByRectangle(String) | Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.
Public method | PickElementsByRectangle(ISelectionFilter) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.
Public method | PickElementsByRectangle(ISelectionFilter, String) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.
Public method | PickObject(ObjectType) | Prompts the user to select one object.
Public method | PickObject(ObjectType, ISelectionFilter) | Prompts the user to select one object which passes a custom filter.
Public method | PickObject(ObjectType, String) | Prompts the user to select one object while showing a custom status prompt string.
Public method | PickObject(ObjectType, ISelectionFilter, String) | Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType) | Prompts the user to select multiple objects.
Public method | PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
Public method | PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <<'(Reference>)>>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.
Public method | PickPoint()()()() | Prompts the user to pick a point on the active work plane.
Public method | PickPoint(String) | Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
Public method | PickPoint(ObjectSnapTypes) | Prompts the user to pick a point on the active work plane using specified snap settings.
Public method | PickPoint(ObjectSnapTypes, String) | Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Elements | The elements that are shown as selected in the Revit user-interface.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


Selection Methods

[image] [image]

Revit 2013 API
Selection Methods
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetElementIds | The ids of the elements that are currently selected.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PickBox(PickBoxStyle) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickBox(PickBoxStyle, String) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickElementsByRectangle()()()() | Prompts the user to select multiple elements by drawing a rectangle.
Public method | PickElementsByRectangle(String) | Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.
Public method | PickElementsByRectangle(ISelectionFilter) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.
Public method | PickElementsByRectangle(ISelectionFilter, String) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.
Public method | PickObject(ObjectType) | Prompts the user to select one object.
Public method | PickObject(ObjectType, ISelectionFilter) | Prompts the user to select one object which passes a custom filter.
Public method | PickObject(ObjectType, String) | Prompts the user to select one object while showing a custom status prompt string.
Public method | PickObject(ObjectType, ISelectionFilter, String) | Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType) | Prompts the user to select multiple objects.
Public method | PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
Public method | PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <<'(Reference>)>>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.
Public method | PickPoint()()()() | Prompts the user to pick a point on the active work plane.
Public method | PickPoint(String) | Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
Public method | PickPoint(ObjectSnapTypes) | Prompts the user to pick a point on the active work plane using specified snap settings.
Public method | PickPoint(ObjectSnapTypes, String) | Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


GetElementIds Method

[image]

Revit 2013 API
Selection..::..GetElementIds Method
Selection Class See Also Send Feedback
The ids of the elements that are currently selected.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public ICollection<ElementId> GetElementIds()
Visual Basic
Public Function GetElementIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetElementIds()

Return Value

A collection containing the ids of the selected elements.

Remarks

Refers to the same set of elements as the Selection.Elements property. The collection returned by this method allows these elements to be processed with the same filtering logic and FilteredElementCollector constructor as regular iterations.

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


PickBox Method

[image] [image]

Revit 2013 API
Selection..::..PickBox Method
Selection Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PickBox(PickBoxStyle) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.
Public method | PickBox(PickBoxStyle, String) | Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickBox Method (PickBoxStyle)

[image]

Revit 2013 API
Selection..::..PickBox Method (PickBoxStyle)
Selection Class See Also Send Feedback
Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public PickedBox PickBox(
    PickBoxStyle style
)
Visual Basic
Public Function PickBox ( _
    style As PickBoxStyle _
) As PickedBox
Visual C++
public:
PickedBox^ PickBox(
    PickBoxStyle style
)

Parameters

style
Type: Autodesk.Revit.UI.Selection..::..PickBoxStyle
Specifies the value that controls the style of the pick box.

Return Value

The picked box that contains two XYZ points.

Remarks

The method starts an editor and returns when it finishes. Returns a PickedBox that contains two XYZ points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the style is not a recognized value.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.

See Also

Selection Class
PickBox Overload
Autodesk.Revit.UI.Selection Namespace


PickBox Method (PickBoxStyle, String)

[image]

Revit 2013 API
Selection..::..PickBox Method (PickBoxStyle, String)
Selection Class See Also Send Feedback
Invokes a general purpose two-click editor that lets the user to specify a rectangular area on the screen.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public PickedBox PickBox(
    PickBoxStyle style,
    string statusPrompt
)
Visual Basic
Public Function PickBox ( _
    style As PickBoxStyle, _
    statusPrompt As String _
) As PickedBox
Visual C++
public:
PickedBox^ PickBox(
    PickBoxStyle style,
    String^ statusPrompt
)

Parameters

style
Type: Autodesk.Revit.UI.Selection..::..PickBoxStyle
Specifies the value that controls the style of the pick box.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

The picked box that contains two XYZ points.

Remarks

The method starts an editor and returns when it finishes. Returns a PickedBox that contains two XYZ points.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the style is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.

See Also

Selection Class
PickBox Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method

[image] [image]

Revit 2013 API
Selection..::..PickElementsByRectangle Method
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle.

Overload List

 | Name | Description
Public method | PickElementsByRectangle()()()() | Prompts the user to select multiple elements by drawing a rectangle.
Public method | PickElementsByRectangle(String) | Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.
Public method | PickElementsByRectangle(ISelectionFilter) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.
Public method | PickElementsByRectangle(ISelectionFilter, String) | Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method

[image]

Revit 2013 API
Selection..::..PickElementsByRectangle Method
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle()
Visual Basic
Public Function PickElementsByRectangle As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle()

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (String)

[image]

Revit 2013 API
Selection..::..PickElementsByRectangle Method (String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    string statusPrompt
)
Visual Basic
Public Function PickElementsByRectangle ( _
    statusPrompt As String _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    String^ statusPrompt
)

Parameters

statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
// Choose objects from Revit.
IList<Element> rectanglePick = uidoc.Selection.PickElementsByRectangle("Select by rectangle");
foreach (Element element in rectanglePick)
{
    uidoc.Selection.Elements.Add(element);
}
TaskDialog.Show("Revit", string.Format("{0} elements added to Selection.", rectanglePick.Count));
CopyVB.NET
Dim selectionCount As Integer = choices.Elements.Size
' Choose objects from Revit.
Dim hasPickSome As IList(Of Autodesk.Revit.DB.Element) = choices.PickElementsByRectangle("Select by rectangle")
If hasPickSome.Count > 0 Then
    Dim newSelectionCount As Integer = choices.Elements.Size
    Dim prompt As String = String.Format("{0} elements added to Selection.", newSelectionCount - selectionCount)
    TaskDialog.Show("Revit", prompt)
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (ISelectionFilter)

[image]

Revit 2013 API
Selection..::..PickElementsByRectangle Method (ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    ISelectionFilter pSelFilter
)
Visual Basic
Public Function PickElementsByRectangle ( _
    pSelFilter As ISelectionFilter _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    ISelectionFilter^ pSelFilter
)

Parameters

pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickElementsByRectangle Method (ISelectionFilter, String)

[image]

Revit 2013 API
Selection..::..PickElementsByRectangle Method (ISelectionFilter, String)
Selection Class See Also Send Feedback
Prompts the user to select multiple elements by drawing a rectangle which pass a customer filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Element> PickElementsByRectangle(
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic
Public Function PickElementsByRectangle ( _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As IList(Of Element)
Visual C++
public:
IList<Element^>^ PickElementsByRectangle(
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A collection of elements selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickElementsByRectangle Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method

[image] [image]

Revit 2013 API
Selection..::..PickObject Method
Selection Class See Also Send Feedback
Prompts the user to select one object.

Overload List

 | Name | Description
Public method | PickObject(ObjectType) | Prompts the user to select one object.
Public method | PickObject(ObjectType, ISelectionFilter) | Prompts the user to select one object which passes a custom filter.
Public method | PickObject(ObjectType, String) | Prompts the user to select one object while showing a custom status prompt string.
Public method | PickObject(ObjectType, ISelectionFilter, String) | Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType)

[image]

Revit 2013 API
Selection..::..PickObject Method (ObjectType)
Selection Class Example See Also Send Feedback
Prompts the user to select one object.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType
)
Visual Basic
Public Function PickObject ( _
    objectType As ObjectType _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
Selection choices = uidoc.Selection;
 // Pick one object from Revit.
 Reference hasPickOne = choices.PickObject(ObjectType.Element);
 if (hasPickOne != null)
 {
     TaskDialog.Show("Revit", "One element selected.");
 }
CopyVB.NET
Dim choices As Autodesk.Revit.UI.Selection.Selection = uidoc.Selection
' Pick one object from Revit.
Dim hasPickOne As Reference = choices.PickObject(Autodesk.Revit.UI.Selection.ObjectType.Element)
If hasPickOne IsNot Nothing Then
    TaskDialog.Show("Revit", "One element added to Selection.")
End If

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancels this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, ISelectionFilter)

[image]

Revit 2013 API
Selection..::..PickObject Method (ObjectType, ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select one object which passes a custom filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    ISelectionFilter pSelFilter
)
Visual Basic
Public Function PickObject ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, String)

[image]

Revit 2013 API
Selection..::..PickObject Method (ObjectType, String)
Selection Class See Also Send Feedback
Prompts the user to select one object while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    string statusPrompt
)
Visual Basic
Public Function PickObject ( _
    objectType As ObjectType, _
    statusPrompt As String _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObject Method (ObjectType, ISelectionFilter, String)

[image]

Revit 2013 API
Selection..::..PickObject Method (ObjectType, ISelectionFilter, String)
Selection Class See Also Send Feedback
Prompts the user to select one object which passes a custom filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public Reference PickObject(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic
Public Function PickObject ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As Reference
Visual C++
public:
Reference^ PickObject(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A reference object selected by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObject Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method

[image] [image]

Revit 2013 API
Selection..::..PickObjects Method
Selection Class See Also Send Feedback
Prompts the user to select multiple objects.

Overload List

 | Name | Description
Public method | PickObjects(ObjectType) | Prompts the user to select multiple objects.
Public method | PickObjects(ObjectType, ISelectionFilter) | Prompts the user to select multiple objects which pass a customer filter.
Public method | PickObjects(ObjectType, String) | Prompts the user to select multiple objects while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.
Public method | PickObjects(ObjectType, ISelectionFilter, String, IList<(Of <<'(Reference>)>>)) | Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType)

[image]

Revit 2013 API
Selection..::..PickObjects Method (ObjectType)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType
)
Visual Basic
Public Function PickObjects ( _
    objectType As ObjectType _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter)

[image]

Revit 2013 API
Selection..::..PickObjects Method (ObjectType, ISelectionFilter)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects which pass a customer filter.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter
)
Visual Basic
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, String)

[image]

Revit 2013 API
Selection..::..PickObjects Method (ObjectType, String)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    string statusPrompt
)
Visual Basic
Public Function PickObjects ( _
    objectType As ObjectType, _
    statusPrompt As String _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

>

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter, String)

[image]

Revit 2013 API
Selection..::..PickObjects Method (ObjectType, ISelectionFilter, String)
Selection Class Example See Also Send Feedback
Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt
)
Visual Basic
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.
statusPrompt
Type: System..::..String
The message shown on the status bar.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
public void SelectPlanarFaces(Autodesk.Revit.DB.Document document)
{
    UIDocument uidoc = new UIDocument(document);
    ISelectionFilter selFilter = new PlanarFacesSelectionFilter(document);
    IList<Reference> faces = uidoc.Selection.PickObjects(ObjectType.Face, selFilter, "Select multiple planar faces");
}

public class PlanarFacesSelectionFilter : ISelectionFilter
{
    Document doc = null;
    public PlanarFacesSelectionFilter(Document document)
    {
        doc = document;
    }

    public bool AllowElement(Element element)
    {
        return true;
    }

    public bool AllowReference(Reference refer, XYZ point)
    {
        if (doc.GetElement(refer).GetGeometryObjectFromReference(refer) is PlanarFace)
        {
            return true; // Only return true for planar faces. Non-planar faces will not be selectable
        }
        return false;
    }
}
CopyVB.NET
Public Sub SelectPlanarFaces(ByVal document As Autodesk.Revit.DB.Document)
    Dim uidoc As New UIDocument(document)
    Dim selFilter As ISelectionFilter = New PlanarFacesSelectionFilter()
    Dim faces As IList(Of Reference) = uidoc.Selection.PickObjects(Autodesk.Revit.UI.Selection.ObjectType.Face, selFilter, "Select multiple planar faces")
End Sub

Public Class PlanarFacesSelectionFilter
    Implements ISelectionFilter
    Public Function AllowElement(ByVal element As Autodesk.Revit.DB.Element) As Boolean Implements ISelectionFilter.AllowElement
        Return True
    End Function

    Public Function AllowReference(ByVal refer As Reference, ByVal point As Autodesk.Revit.DB.XYZ) As Boolean Implements ISelectionFilter.AllowReference
        If TypeOf refer.GeometryObject Is PlanarFace Then
            Return True
        End If

        Return False
    End Function
End Class

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic) or statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickObjects Method (ObjectType, ISelectionFilter, String, IList(Reference))

[image]

Revit 2013 API
Selection..::..PickObjects Method (ObjectType, ISelectionFilter, String, IList<(Of <(<'Reference>)>)>)
Selection Class See Also Send Feedback
Prompts the user to select multiple objects which pass a custom filter while showing a custom status prompt string. A preselected set of objects may be supplied and will be selected at the start of the selection.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public IList<Reference> PickObjects(
    ObjectType objectType,
    ISelectionFilter pSelFilter,
    string statusPrompt,
    IList<Reference> pPreSelected
)
Visual Basic
Public Function PickObjects ( _
    objectType As ObjectType, _
    pSelFilter As ISelectionFilter, _
    statusPrompt As String, _
    pPreSelected As IList(Of Reference) _
) As IList(Of Reference)
Visual C++
public:
IList<Reference^>^ PickObjects(
    ObjectType objectType,
    ISelectionFilter^ pSelFilter,
    String^ statusPrompt,
    IList<Reference^>^ pPreSelected
)

Parameters

objectType
Type: Autodesk.Revit.UI.Selection..::..ObjectType
Specifies the type of object to be selected.
pSelFilter
Type: Autodesk.Revit.UI.Selection..::..ISelectionFilter
The selection filter.
statusPrompt
Type: System..::..String
The message shown on the status bar.
pPreSelected
Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
The previously selected set of objects.

Return Value

A collection of references selected by the user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

The user will be shown "Finish" and "Cancel" buttons on the dialog bar to complete the selection operation. Uncheck the "Multiple" check-box to select single object and it will return the selected object directly.

The previously selected set of objects will be highlighted.

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

The selection will not be automatically added to the active selection buffer.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the objectType is not a recognized value.
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the pSelFilter is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the Revit user cancelled this operation. Thrown when pPreSelected references has objects that are not the type of objectType. Thrown when objectType is PointOnElement which is not supported for selection involving preselected items.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickObjects Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method

[image] [image]

Revit 2013 API
Selection..::..PickPoint Method
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane.

Overload List

 | Name | Description
Public method | PickPoint()()()() | Prompts the user to pick a point on the active work plane.
Public method | PickPoint(String) | Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
Public method | PickPoint(ObjectSnapTypes) | Prompts the user to pick a point on the active work plane using specified snap settings.
Public method | PickPoint(ObjectSnapTypes, String) | Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.

See Also

Selection Class
Selection Members
Autodesk.Revit.UI.Selection Namespace


PickPoint Method

[image]

Revit 2013 API
Selection..::..PickPoint Method
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ PickPoint()
Visual Basic
Public Function PickPoint As XYZ
Visual C++
public:
XYZ^ PickPoint()

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (String)

[image]

Revit 2013 API
Selection..::..PickPoint Method (String)
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ PickPoint(
    string statusPrompt
)
Visual Basic
Public Function PickPoint ( _
    statusPrompt As String _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    String^ statusPrompt
)

Parameters

statusPrompt
Type: System..::..String
Specifies the message shown on the status bar.

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (ObjectSnapTypes)

[image]

Revit 2013 API
Selection..::..PickPoint Method (ObjectSnapTypes)
Selection Class See Also Send Feedback
Prompts the user to pick a point on the active work plane using specified snap settings.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ PickPoint(
    ObjectSnapTypes snapSettings
)
Visual Basic
Public Function PickPoint ( _
    snapSettings As ObjectSnapTypes _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    ObjectSnapTypes snapSettings
)

Parameters

snapSettings
Type: Autodesk.Revit.UI.Selection..::..ObjectSnapTypes
Specifies the object snap types for this pick. Multiple object snap types can be combined with "|"

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


PickPoint Method (ObjectSnapTypes, String)

[image]

Revit 2013 API
Selection..::..PickPoint Method (ObjectSnapTypes, String)
Selection Class Example See Also Send Feedback
Prompts the user to pick a point on the active work plane using specified snap settings while showing a custom status prompt string.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public XYZ PickPoint(
    ObjectSnapTypes snapSettings,
    string statusPrompt
)
Visual Basic
Public Function PickPoint ( _
    snapSettings As ObjectSnapTypes, _
    statusPrompt As String _
) As XYZ
Visual C++
public:
XYZ^ PickPoint(
    ObjectSnapTypes snapSettings,
    String^ statusPrompt
)

Parameters

snapSettings
Type: Autodesk.Revit.UI.Selection..::..ObjectSnapTypes
Specifies the object snap types for this pick. Multiple object snap types can be combined with "|"
statusPrompt
Type: System..::..String
Specifies the message shown on the status bar.

Return Value

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Remarks

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

Examples

CopyC#
public void PickPoint(UIDocument uidoc)
{
    ObjectSnapTypes snapTypes = ObjectSnapTypes.Endpoints | ObjectSnapTypes.Intersections;
    XYZ point = uidoc.Selection.PickPoint(snapTypes, "Select an end point or intersection");

    string strCoords = "Selected point is " + point.ToString();

    TaskDialog.Show("Revit", strCoords);
}
CopyVB.NET
Public Sub PickPoint(ByVal uidoc As UIDocument)
    Dim snapTypes As ObjectSnapTypes = ObjectSnapTypes.Endpoints Or ObjectSnapTypes.Intersections
    Dim point As Autodesk.Revit.DB.XYZ = uidoc.Selection.PickPoint(snapTypes, "Select an end point or intersection")

    Dim strCoords As String = "Selected point is " + point.ToString()

    TaskDialog.Show("Revit", strCoords)
End Sub

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument statusPrompt is nullNothingnullptra null reference (Nothing in Visual Basic).
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when no work plane set in current view.
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode.
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update.

See Also

Selection Class
PickPoint Overload
Autodesk.Revit.UI.Selection Namespace


Selection Properties

[image] [image]

Revit 2013 API
Selection Properties
Selection Class See Also Send Feedback

The Selection type exposes the following members.

Properties

 | Name | Description
Public property | Elements | The elements that are shown as selected in the Revit user-interface.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


Elements Property

[image]

Revit 2013 API
Selection..::..Elements Property
Selection Class Example See Also Send Feedback
The elements that are shown as selected in the Revit user-interface.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public SelElementSet Elements { get; set; }
Visual Basic
Public Property Elements As SelElementSet
    Get
    Set
Visual C++
public:
property SelElementSet^ Elements {
    SelElementSet^ get ();
    void set (SelElementSet^ value);
}

Field Value

The selected elements.

Remarks

PickOne and WindowSelect add to this set because they modify the set of elements selected in the user-interface after the External Command is complete. Selections made with PickObject, PickObjects, and PickElementsByRectangle do not persist after the External Command is complete, and therefore they do not affect this property.

Examples

CopyC#
private void ChangeSelection(Document document)
{
    // Get selected elements form current document.
    UIDocument uidoc = new UIDocument(document);
    Autodesk.Revit.UI.Selection.SelElementSet collection = uidoc.Selection.Elements;

    // Display current number of selected elements
    TaskDialog.Show("Revit","Number of selected elements: " + collection.Size.ToString());

    //Create a new SelElementSet
    SelElementSet newSelectedElementSet = SelElementSet.Create();

    // Add wall into the created element set.
    foreach (Autodesk.Revit.DB.Element elements in collection)
    {
        if (elements is Wall)
        {
            newSelectedElementSet.Add(elements);
        }
    }

    // Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet;

    // Give the user some information.
    if (0 != newSelectedElementSet.Size)
    {
        TaskDialog.Show("Revit",uidoc.Selection.Elements.Size.ToString() + " Walls are selected!");
    }
    else
    {
        TaskDialog.Show("Revit","No Walls have been selected!");
    }
}
CopyVB.NET
Private Sub ChangeSelection(ByVal document As Document)
    ' Get selected elements form current document.
    Dim uidoc As New UIDocument(document)
    Dim collection As Autodesk.Revit.UI.Selection.SelElementSet = uidoc.Selection.Elements

    ' Display current number of selected elements
    TaskDialog.Show("Revit", "Number of selected elements: " + collection.Size.ToString())

    'Create a new SelElementSet
    Dim newSelectedElementSet As SelElementSet = SelElementSet.Create()

    ' Add wall into the created element set.
    For Each elements As Autodesk.Revit.DB.Element In collection
        If TypeOf elements Is Wall Then
            newSelectedElementSet.Add(elements)
        End If
    Next

    ' Set the created element set as current select element set.
    uidoc.Selection.Elements = newSelectedElementSet

    ' Give the user some information.
    If 0 <> newSelectedElementSet.Size Then
        TaskDialog.Show("Revit", uidoc.Selection.Elements.Size.ToString() + " Walls are selected!")
    Else
        TaskDialog.Show("Revit", "No Walls have been selected!")
    End If
End Sub

See Also

Selection Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Class

[image]

Revit 2013 API
SelElementSet Class
Members See Also Send Feedback
This class contains the current user selection of elements within the project.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public class SelElementSet : ElementSet
Visual Basic
Public Class SelElementSet _
    Inherits ElementSet
Visual C++
public ref class SelElementSet : public ElementSet

Remarks

Add or Remove elements from the selected element set. The elements in the set will be highlighted as selected elements in the UI.

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..ElementSet
Autodesk.Revit.UI.Selection..::..SelElementSet

See Also

SelElementSet Members
Autodesk.Revit.UI.Selection Namespace


SelElementSet Members

[image] [image]

Revit 2013 API
SelElementSet Members
SelElementSet Class Methods Properties See Also Send Feedback

The SelElementSet type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet..::..Clear()()()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
 | Create | Creates a new instance of a set specifically for holding selected elements.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet..::..Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Methods

[image] [image]

Revit 2013 API
SelElementSet Methods
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Methods

 | Name | Description
Public method | Add | Add an element into the selected element set.
Public method | Clear | Clear the selected element set. (Overrides ElementSet..::..Clear()()()().)
Public method | Contains | Tests for the existence of an element within the set. (Inherited from ElementSet.)
 | Create | Creates a new instance of a set specifically for holding selected elements.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Remove an element from the selected element set. (Overrides ElementSet..::..Erase(Element).)
Public method | ForwardIterator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetEnumerator | Retrieve a forward moving iterator to the set. (Inherited from ElementSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified element into the set. (Inherited from ElementSet.)
Public method | Remove | Remove an element from the selected element set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set. (Inherited from ElementSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Add Method

[image]

Revit 2013 API
SelElementSet..::..Add Method
SelElementSet Class See Also Send Feedback
Add an element into the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Add(
    Element element
)
Visual Basic
Public Overridable Sub Add ( _
    element As Element _
)
Visual C++
public:
virtual void Add(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to be added.

Remarks

This function will add the specified element to the selected element set, just like the element is picked from the UI.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Clear Method

[image]

Revit 2013 API
SelElementSet..::..Clear Method
SelElementSet Class See Also Send Feedback
Clear the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public override void Clear()
Visual Basic
Public Overrides Sub Clear
Visual C++
public:
virtual void Clear() override

Remarks

All the elements in the selected element set will be removed and no element will be highlighted after the operation.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Create Method

[image]

Revit 2013 API
SelElementSet..::..Create Method
SelElementSet Class See Also Send Feedback
Creates a new instance of a set specifically for holding selected elements.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public static SelElementSet Create()
Visual Basic
Public Shared Function Create As SelElementSet
Visual C++
public:
static SelElementSet^ Create()

Return Value

Returns a new Element Set.

Remarks

If the user wants to change the selected Element with the API, the instance SelElementSet must be created to do the operation of Add and Remove.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Erase Method

[image]

Revit 2013 API
SelElementSet..::..Erase Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public override int Erase(
    Element element
)
Visual Basic
Public Overrides Function Erase ( _
    element As Element _
) As Integer
Visual C++
public:
virtual int Erase(
    Element^ element
) override

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to be removed.

Return Value

Returns count of the elements to be erased from the selected element set.

Remarks

This function will do same task as Remove.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Remove Method

[image]

Revit 2013 API
SelElementSet..::..Remove Method
SelElementSet Class See Also Send Feedback
Remove an element from the selected element set.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Remove(
    Element element
)
Visual Basic
Public Overridable Sub Remove ( _
    element As Element _
)
Visual C++
public:
virtual void Remove(
    Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB..::..Element
The element to be removed.

Remarks

This function will remove the specified from the selected element set, just like de-select it from the UI.

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


SelElementSet Properties

[image] [image]

Revit 2013 API
SelElementSet Properties
SelElementSet Class See Also Send Feedback

The SelElementSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty. (Inherited from ElementSet.)
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of elements that are in the set. (Inherited from ElementSet.)

See Also

SelElementSet Class
Autodesk.Revit.UI.Selection Namespace


Autodesk.Revit.Utility Namespace

[image]

Revit 2013 API
Autodesk.Revit.Utility Namespace
Send Feedback

Classes

 | Class | Description
Public class | Asset |
Public class | AssetProperties | A set of asset properties.
Public class | AssetProperty |
Public class | AssetPropertyBoolean |
Public class | AssetPropertyDistance |
Public class | AssetPropertyDouble |
Public class | AssetPropertyDoubleArray2d |
Public class | AssetPropertyDoubleArray3d |
Public class | AssetPropertyDoubleArray4d |
Public class | AssetPropertyDoubleMatrix44 |
Public class | AssetPropertyEnum |
Public class | AssetPropertyFloat |
Public class | AssetPropertyInteger |
Public class | AssetPropertyReference |
Public class | AssetPropertyString |
Public class | AssetPropertyTime |
Public class | AssetSet | A set that contains assets.
Public class | AssetSetIterator | An iterator to a asset set.

Enumerations

 | Enumeration | Description
Public enumeration | AssetPropertyType | An enumerated to list AssetProperty Types in Revit.
Public enumeration | AssetType | An enumerated to list Asset Types in Revit.


Asset Class

[image]

Revit 2013 API
Asset Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class Asset : AssetProperties
Visual Basic
Public Class Asset _
    Inherits AssetProperties
Visual C++
public ref class Asset : public AssetProperties

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetProperties
Autodesk.Revit.Utility..::..Asset

See Also

Asset Members
Autodesk.Revit.Utility Namespace


Asset Members

[image] [image]

Revit 2013 API
Asset Members
Asset Class Methods Properties See Also Send Feedback

The Asset type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) | (Inherited from AssetProperties.)
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Methods

[image] [image]

Revit 2013 API
Asset Methods
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Asset Properties

[image] [image]

Revit 2013 API
Asset Properties
Asset Class See Also Send Feedback

The Asset type exposes the following members.

Properties

 | Name | Description
Public property | AssetType | Get the object's AssetPropertyType
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) | (Inherited from AssetProperties.)
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)
Public property | LibraryName | Get the library name
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object. (Inherited from AssetProperties.)
Public property | Title | Get the asset's title
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetType Property

[image]

Revit 2013 API
Asset..::..AssetType Property
Asset Class See Also Send Feedback
Get the object's AssetPropertyType

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetType AssetType { get; }
Visual Basic
Public ReadOnly Property AssetType As AssetType
    Get
Visual C++
public:
property AssetType AssetType {
    AssetType get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2013 API
Asset..::..Item Property
Asset Class See Also Send Feedback
Gets a property by an identifier.

Overload List

 | Name | Description
Public property | Item[([( Int32])]) | (Inherited from AssetProperties.)
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name. (Inherited from AssetProperties.)

See Also

Asset Class
Asset Members
Autodesk.Revit.Utility Namespace


LibraryName Property

[image]

Revit 2013 API
Asset..::..LibraryName Property
Asset Class See Also Send Feedback
Get the library name

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string LibraryName { get; }
Visual Basic
Public ReadOnly Property LibraryName As String
    Get
Visual C++
public:
property String^ LibraryName {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


Title Property

[image]

Revit 2013 API
Asset..::..Title Property
Asset Class See Also Send Feedback
Get the asset's title

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Title { get; }
Visual Basic
Public ReadOnly Property Title As String
    Get
Visual C++
public:
property String^ Title {
    String^ get ();
}

See Also

Asset Class
Autodesk.Revit.Utility Namespace


AssetProperties Class

[image]

Revit 2013 API
AssetProperties Class
Members See Also Send Feedback
A set of asset properties.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetProperties : AssetProperty
Visual Basic
Public Class AssetProperties _
    Inherits AssetProperty
Visual C++
public ref class AssetProperties : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetProperties
Autodesk.Revit.Utility..::..Asset

See Also

AssetProperties Members
Autodesk.Revit.Utility Namespace


AssetProperties Members

[image] [image]

Revit 2013 API
AssetProperties Members
AssetProperties Class Methods Properties See Also Send Feedback

The AssetProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name.
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object.
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Methods

[image] [image]

Revit 2013 API
AssetProperties Methods
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperties Properties

[image] [image]

Revit 2013 API
AssetProperties Properties
AssetProperties Class See Also Send Feedback

The AssetProperties type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name.
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Size | Gets the number of the AssetProperty(s) in the object.
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


Item Property

[image] [image]

Revit 2013 API
AssetProperties..::..Item Property
AssetProperties Class See Also Send Feedback
Gets a property by an identifier.

Overload List

 | Name | Description
Public property | Item[([( Int32])]) |
Public property | Item[([( String])]) | Gets the one property that the current object contains with the given name.

See Also

AssetProperties Class
AssetProperties Members
Autodesk.Revit.Utility Namespace


Item Property (Int32)

[image]

Revit 2013 API
AssetProperties..::..Item Property (Int32)
AssetProperties Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetProperty this[
    int index
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    index As Integer _
) As AssetProperty
    Get
Visual C++
public:
property AssetProperty^ default[int index] {
    AssetProperty^ get (int index);
}

Parameters

index
Type: System..::..Int32

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Item Property (String)

[image]

Revit 2013 API
AssetProperties..::..Item Property (String)
AssetProperties Class See Also Send Feedback
Gets the one property that the current object contains with the given name.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetProperty this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item ( _
    name As String _
) As AssetProperty
    Get
Visual C++
public:
property AssetProperty^ default[String^ name] {
    AssetProperty^ get (String^ name);
}

Parameters

name
Type: System..::..String

See Also

AssetProperties Class
Item Overload
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2013 API
AssetProperties..::..Size Property
AssetProperties Class See Also Send Feedback
Gets the number of the AssetProperty(s) in the object.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

AssetProperties Class
Autodesk.Revit.Utility Namespace


AssetProperty Class

[image]

Revit 2013 API
AssetProperty Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetProperty : APIObject
Visual Basic
Public Class AssetProperty _
    Inherits APIObject
Visual C++
public ref class AssetProperty : public APIObject

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetProperties
Autodesk.Revit.Utility..::..AssetPropertyBoolean
Autodesk.Revit.Utility..::..AssetPropertyDistance
Autodesk.Revit.Utility..::..AssetPropertyDouble
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray2d
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray3d
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray4d
Autodesk.Revit.Utility..::..AssetPropertyDoubleMatrix44
Autodesk.Revit.Utility..::..AssetPropertyEnum
Autodesk.Revit.Utility..::..AssetPropertyFloat
Autodesk.Revit.Utility..::..AssetPropertyInteger
Autodesk.Revit.Utility..::..AssetPropertyReference
Autodesk.Revit.Utility..::..AssetPropertyString
Autodesk.Revit.Utility..::..AssetPropertyTime

See Also

AssetProperty Members
Autodesk.Revit.Utility Namespace


AssetProperty Members

[image] [image]

Revit 2013 API
AssetProperty Members
AssetProperty Class Methods Properties See Also Send Feedback

The AssetProperty type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeName | Get the name of the AssetProperty
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty
Public property | Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Methods

[image] [image]

Revit 2013 API
AssetProperty Methods
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeName | Get the name of the AssetProperty
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


GetTypeName Method

[image]

Revit 2013 API
AssetProperty..::..GetTypeName Method
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public static string GetTypeName(
    AssetPropertyType type
)
Visual Basic
Public Shared Function GetTypeName ( _
    type As AssetPropertyType _
) As String
Visual C++
public:
static String^ GetTypeName(
    AssetPropertyType type
)

Parameters

type
Type: Autodesk.Revit.Utility..::..AssetPropertyType

Exceptions

Exception | Condition
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when type is AssetPropertyType::APT_Unknown or AssetPropertyType::APT_Last.

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetProperty Properties

[image] [image]

Revit 2013 API
AssetProperty Properties
AssetProperty Class See Also Send Feedback

The AssetProperty type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty
Public property | Type | Returns the Type of the AssetProperty

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Name Property

[image]

Revit 2013 API
AssetProperty..::..Name Property
AssetProperty Class See Also Send Feedback
Get the name of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Name { get; }
Visual Basic
Public ReadOnly Property Name As String
    Get
Visual C++
public:
property String^ Name {
    String^ get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


Type Property

[image]

Revit 2013 API
AssetProperty..::..Type Property
AssetProperty Class See Also Send Feedback
Returns the Type of the AssetProperty

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AssetPropertyType Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As AssetPropertyType
    Get
Visual C++
public:
virtual property AssetPropertyType Type {
    AssetPropertyType get ();
}

See Also

AssetProperty Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Class

[image]

Revit 2013 API
AssetPropertyBoolean Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyBoolean : AssetProperty
Visual Basic
Public Class AssetPropertyBoolean _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyBoolean : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyBoolean

See Also

AssetPropertyBoolean Members
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Members

[image] [image]

Revit 2013 API
AssetPropertyBoolean Members
AssetPropertyBoolean Class Methods Properties See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Methods

[image] [image]

Revit 2013 API
AssetPropertyBoolean Methods
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyBoolean Properties

[image] [image]

Revit 2013 API
AssetPropertyBoolean Properties
AssetPropertyBoolean Class See Also Send Feedback

The AssetPropertyBoolean type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyBoolean..::..Value Property
AssetPropertyBoolean Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public bool Value { get; }
Visual Basic
Public ReadOnly Property Value As Boolean
    Get
Visual C++
public:
property bool Value {
    bool get ();
}

See Also

AssetPropertyBoolean Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Class

[image]

Revit 2013 API
AssetPropertyDistance Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDistance : AssetProperty
Visual Basic
Public Class AssetPropertyDistance _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDistance : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDistance

See Also

AssetPropertyDistance Members
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Members

[image] [image]

Revit 2013 API
AssetPropertyDistance Members
AssetPropertyDistance Class Methods Properties See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DisplayUnitType |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Methods

[image] [image]

Revit 2013 API
AssetPropertyDistance Methods
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDistance Properties

[image] [image]

Revit 2013 API
AssetPropertyDistance Properties
AssetPropertyDistance Class See Also Send Feedback

The AssetPropertyDistance type exposes the following members.

Properties

 | Name | Description
Public property | DisplayUnitType |
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


DisplayUnitType Property

[image]

Revit 2013 API
AssetPropertyDistance..::..DisplayUnitType Property
AssetPropertyDistance Class See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DisplayUnitType DisplayUnitType { get; }
Visual Basic
Public ReadOnly Property DisplayUnitType As DisplayUnitType
    Get
Visual C++
public:
property DisplayUnitType DisplayUnitType {
    DisplayUnitType get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDistance..::..Value Property
AssetPropertyDistance Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic
Public ReadOnly Property Value As Double
    Get
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDistance Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Class

[image]

Revit 2013 API
AssetPropertyDouble Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDouble : AssetProperty
Visual Basic
Public Class AssetPropertyDouble _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDouble : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDouble

See Also

AssetPropertyDouble Members
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Members

[image] [image]

Revit 2013 API
AssetPropertyDouble Members
AssetPropertyDouble Class Methods Properties See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Methods

[image] [image]

Revit 2013 API
AssetPropertyDouble Methods
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDouble Properties

[image] [image]

Revit 2013 API
AssetPropertyDouble Properties
AssetPropertyDouble Class See Also Send Feedback

The AssetPropertyDouble type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDouble..::..Value Property
AssetPropertyDouble Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public double Value { get; }
Visual Basic
Public ReadOnly Property Value As Double
    Get
Visual C++
public:
property double Value {
    double get ();
}

See Also

AssetPropertyDouble Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Class

[image]

Revit 2013 API
AssetPropertyDoubleArray2d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray2d : AssetProperty
Visual Basic
Public Class AssetPropertyDoubleArray2d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray2d : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray2d

See Also

AssetPropertyDoubleArray2d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Members

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray2d Members
AssetPropertyDoubleArray2d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Methods

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray2d Methods
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray2d Properties

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray2d Properties
AssetPropertyDoubleArray2d Class See Also Send Feedback

The AssetPropertyDoubleArray2d type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDoubleArray2d..::..Value Property
AssetPropertyDoubleArray2d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic
Public ReadOnly Property Value As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray2d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Class

[image]

Revit 2013 API
AssetPropertyDoubleArray3d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray3d : AssetProperty
Visual Basic
Public Class AssetPropertyDoubleArray3d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray3d : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray3d

See Also

AssetPropertyDoubleArray3d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Members

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray3d Members
AssetPropertyDoubleArray3d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Methods

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray3d Methods
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray3d Properties

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray3d Properties
AssetPropertyDoubleArray3d Class See Also Send Feedback

The AssetPropertyDoubleArray3d type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDoubleArray3d..::..Value Property
AssetPropertyDoubleArray3d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic
Public ReadOnly Property Value As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray3d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Class

[image]

Revit 2013 API
AssetPropertyDoubleArray4d Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDoubleArray4d : AssetProperty
Visual Basic
Public Class AssetPropertyDoubleArray4d _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleArray4d : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDoubleArray4d

See Also

AssetPropertyDoubleArray4d Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Members

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray4d Members
AssetPropertyDoubleArray4d Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Methods

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray4d Methods
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleArray4d Properties

[image] [image]

Revit 2013 API
AssetPropertyDoubleArray4d Properties
AssetPropertyDoubleArray4d Class See Also Send Feedback

The AssetPropertyDoubleArray4d type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDoubleArray4d..::..Value Property
AssetPropertyDoubleArray4d Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic
Public ReadOnly Property Value As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleArray4d Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Class

[image]

Revit 2013 API
AssetPropertyDoubleMatrix44 Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyDoubleMatrix44 : AssetProperty
Visual Basic
Public Class AssetPropertyDoubleMatrix44 _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyDoubleMatrix44 : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyDoubleMatrix44

See Also

AssetPropertyDoubleMatrix44 Members
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Members

[image] [image]

Revit 2013 API
AssetPropertyDoubleMatrix44 Members
AssetPropertyDoubleMatrix44 Class Methods Properties See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Methods

[image] [image]

Revit 2013 API
AssetPropertyDoubleMatrix44 Methods
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyDoubleMatrix44 Properties

[image] [image]

Revit 2013 API
AssetPropertyDoubleMatrix44 Properties
AssetPropertyDoubleMatrix44 Class See Also Send Feedback

The AssetPropertyDoubleMatrix44 type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyDoubleMatrix44..::..Value Property
AssetPropertyDoubleMatrix44 Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DoubleArray Value { get; }
Visual Basic
Public ReadOnly Property Value As DoubleArray
    Get
Visual C++
public:
property DoubleArray^ Value {
    DoubleArray^ get ();
}

See Also

AssetPropertyDoubleMatrix44 Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Class

[image]

Revit 2013 API
AssetPropertyEnum Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyEnum : AssetProperty
Visual Basic
Public Class AssetPropertyEnum _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyEnum : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyEnum

See Also

AssetPropertyEnum Members
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Members

[image] [image]

Revit 2013 API
AssetPropertyEnum Members
AssetPropertyEnum Class Methods Properties See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Methods

[image] [image]

Revit 2013 API
AssetPropertyEnum Methods
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyEnum Properties

[image] [image]

Revit 2013 API
AssetPropertyEnum Properties
AssetPropertyEnum Class See Also Send Feedback

The AssetPropertyEnum type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyEnum..::..Value Property
AssetPropertyEnum Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyEnum Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Class

[image]

Revit 2013 API
AssetPropertyFloat Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyFloat : AssetProperty
Visual Basic
Public Class AssetPropertyFloat _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyFloat : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyFloat

See Also

AssetPropertyFloat Members
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Members

[image] [image]

Revit 2013 API
AssetPropertyFloat Members
AssetPropertyFloat Class Methods Properties See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Methods

[image] [image]

Revit 2013 API
AssetPropertyFloat Methods
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyFloat Properties

[image] [image]

Revit 2013 API
AssetPropertyFloat Properties
AssetPropertyFloat Class See Also Send Feedback

The AssetPropertyFloat type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyFloat..::..Value Property
AssetPropertyFloat Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public float Value { get; }
Visual Basic
Public ReadOnly Property Value As Single
    Get
Visual C++
public:
property float Value {
    float get ();
}

See Also

AssetPropertyFloat Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Class

[image]

Revit 2013 API
AssetPropertyInteger Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyInteger : AssetProperty
Visual Basic
Public Class AssetPropertyInteger _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyInteger : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyInteger

See Also

AssetPropertyInteger Members
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Members

[image] [image]

Revit 2013 API
AssetPropertyInteger Members
AssetPropertyInteger Class Methods Properties See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Methods

[image] [image]

Revit 2013 API
AssetPropertyInteger Methods
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyInteger Properties

[image] [image]

Revit 2013 API
AssetPropertyInteger Properties
AssetPropertyInteger Class See Also Send Feedback

The AssetPropertyInteger type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyInteger..::..Value Property
AssetPropertyInteger Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public int Value { get; }
Visual Basic
Public ReadOnly Property Value As Integer
    Get
Visual C++
public:
property int Value {
    int get ();
}

See Also

AssetPropertyInteger Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Class

[image]

Revit 2013 API
AssetPropertyReference Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyReference : AssetProperty
Visual Basic
Public Class AssetPropertyReference _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyReference : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyReference

See Also

AssetPropertyReference Members
Autodesk.Revit.Utility Namespace


AssetPropertyReference Members

[image] [image]

Revit 2013 API
AssetPropertyReference Members
AssetPropertyReference Class Methods Properties See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Methods

[image] [image]

Revit 2013 API
AssetPropertyReference Methods
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyReference Properties

[image] [image]

Revit 2013 API
AssetPropertyReference Properties
AssetPropertyReference Class See Also Send Feedback

The AssetPropertyReference type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyReference..::..Value Property
AssetPropertyReference Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0
Since: 2013

Syntax

C#
public AssetProperty Value { get; }
Visual Basic
Public ReadOnly Property Value As AssetProperty
    Get
Visual C++
public:
property AssetProperty^ Value {
    AssetProperty^ get ();
}

See Also

AssetPropertyReference Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Class

[image]

Revit 2013 API
AssetPropertyString Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyString : AssetProperty
Visual Basic
Public Class AssetPropertyString _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyString : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyString

See Also

AssetPropertyString Members
Autodesk.Revit.Utility Namespace


AssetPropertyString Members

[image] [image]

Revit 2013 API
AssetPropertyString Members
AssetPropertyString Class Methods Properties See Also Send Feedback

The AssetPropertyString type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Methods

[image] [image]

Revit 2013 API
AssetPropertyString Methods
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyString Properties

[image] [image]

Revit 2013 API
AssetPropertyString Properties
AssetPropertyString Class See Also Send Feedback

The AssetPropertyString type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyString..::..Value Property
AssetPropertyString Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public string Value { get; }
Visual Basic
Public ReadOnly Property Value As String
    Get
Visual C++
public:
property String^ Value {
    String^ get ();
}

See Also

AssetPropertyString Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Class

[image]

Revit 2013 API
AssetPropertyTime Class
Members See Also Send Feedback

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetPropertyTime : AssetProperty
Visual Basic
Public Class AssetPropertyTime _
    Inherits AssetProperty
Visual C++
public ref class AssetPropertyTime : public AssetProperty

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetProperty
Autodesk.Revit.Utility..::..AssetPropertyTime

See Also

AssetPropertyTime Members
Autodesk.Revit.Utility Namespace


AssetPropertyTime Members

[image] [image]

Revit 2013 API
AssetPropertyTime Members
AssetPropertyTime Class Methods Properties See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Methods

[image] [image]

Revit 2013 API
AssetPropertyTime Methods
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyTime Properties

[image] [image]

Revit 2013 API
AssetPropertyTime Properties
AssetPropertyTime Class See Also Send Feedback

The AssetPropertyTime type exposes the following members.

Properties

 | Name | Description
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Name | Get the name of the AssetProperty; (Inherited from AssetProperty.)
Public property | Type | Returns the Type of the AssetProperty; (Inherited from AssetProperty.)
Public property | Value | Get the value of the property

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


Value Property

[image]

Revit 2013 API
AssetPropertyTime..::..Value Property
AssetPropertyTime Class See Also Send Feedback
Get the value of the property

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public DateTime Value { get; }
Visual Basic
Public ReadOnly Property Value As DateTime
    Get
Visual C++
public:
property DateTime Value {
    DateTime get ();
}

See Also

AssetPropertyTime Class
Autodesk.Revit.Utility Namespace


AssetPropertyType Enumeration

[image]

Revit 2013 API
AssetPropertyType Enumeration
See Also Send Feedback
An enumerated to list AssetProperty Types in Revit.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AssetPropertyType
Visual Basic
Public Enumeration AssetPropertyType
Visual C++
public enum class AssetPropertyType

Members

Member name | Description
APT_Unknown |
APT_Properties |
APT_Boolean |
APT_Enum |
APT_Integer |
APT_Float |
APT_Double | AssetPropertyDouble.
APT_DoubleArray2d | AssetPropertyDoubleArray2d.
APT_DoubleArray3d | AssetPropertyDoubleArray3d.
APT_DoubleArray4d | AssetPropertyDoubleArray4d.
APT_Double44 | AssetPropertyDoubleMatrix44.
APT_String |
APT_Time |
APT_Distance |
APT_Asset |
APT_Reference |
APT_Last |

See Also

Autodesk.Revit.Utility Namespace


AssetSet Class

[image]

Revit 2013 API
AssetSet Class
Members See Also Send Feedback
A set that contains assets.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public class AssetSet : APIObject, IEnumerable
Visual Basic
Public Class AssetSet _
    Inherits APIObject _
    Implements IEnumerable
Visual C++
public ref class AssetSet : public APIObject,
    IEnumerable

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetSet

See Also

AssetSet Members
Autodesk.Revit.Utility Namespace


AssetSet Members

[image] [image]

Revit 2013 API
AssetSet Members
AssetSet Class Constructors Methods Properties See Also Send Feedback

The AssetSet type exposes the following members.

Constructors

 | Name | Description
Public method | AssetSet | Initializes a new instance of the AssetSet class

Methods

 | Name | Description
Public method | Clear | Removes every asset from the set, rendering it empty.
Public method | Contains | Tests for the existence of a asset within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified asset from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified asset into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Constructor

[image]

Revit 2013 API
AssetSet Constructor
AssetSet Class See Also Send Feedback
Initializes a new instance of the AssetSet class

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetSet()
Visual Basic
Public Sub New
Visual C++
public:
AssetSet()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Methods

[image] [image]

Revit 2013 API
AssetSet Methods
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Methods

 | Name | Description
Public method | Clear | Removes every asset from the set, rendering it empty.
Public method | Contains | Tests for the existence of a asset within the set.
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Erase | Removes a specified asset from the set.
Public method | ForwardIterator | Retrieve a forward moving iterator to the set.
Public method | GetEnumerator | Retrieve a forward moving iterator to the set.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Insert | Insert the specified asset into the set.
Public method | ReverseIterator | Retrieve a backward moving iterator to the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Clear Method

[image]

Revit 2013 API
AssetSet..::..Clear Method
AssetSet Class See Also Send Feedback
Removes every asset from the set, rendering it empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Clear()
Visual Basic
Public Overridable Sub Clear
Visual C++
public:
virtual void Clear()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Contains Method

[image]

Revit 2013 API
AssetSet..::..Contains Method
AssetSet Class See Also Send Feedback
Tests for the existence of a asset within the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Contains(
    Asset item
)
Visual Basic
Public Overridable Function Contains ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Contains(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::..Asset
The asset to be searched for.

Return Value

The Contains method returns True if the asset is within the set, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Erase Method

[image]

Revit 2013 API
AssetSet..::..Erase Method
AssetSet Class See Also Send Feedback
Removes a specified asset from the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Erase(
    Asset item
)
Visual Basic
Public Overridable Function Erase ( _
    item As Asset _
) As Integer
Visual C++
public:
virtual int Erase(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::..Asset
The asset to be erased.

Return Value

The number of assets that were erased from the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ForwardIterator Method

[image]

Revit 2013 API
AssetSet..::..ForwardIterator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AssetSetIterator ForwardIterator()
Visual Basic
Public Overridable Function ForwardIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ForwardIterator()

Return Value

Returns a forward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


GetEnumerator Method

[image]

Revit 2013 API
AssetSet..::..GetEnumerator Method
AssetSet Class See Also Send Feedback
Retrieve a forward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual IEnumerator GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator()

Return Value

Returns a forward moving iterator to the set.

Implements

IEnumerable..::..GetEnumerator()()()()

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Insert Method

[image]

Revit 2013 API
AssetSet..::..Insert Method
AssetSet Class See Also Send Feedback
Insert the specified asset into the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool Insert(
    Asset item
)
Visual Basic
Public Overridable Function Insert ( _
    item As Asset _
) As Boolean
Visual C++
public:
virtual bool Insert(
    Asset^ item
)

Parameters

item
Type: Autodesk.Revit.Utility..::..Asset
The asset to be inserted into the set.

Return Value

Returns whether the asset was inserted into the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


ReverseIterator Method

[image]

Revit 2013 API
AssetSet..::..ReverseIterator Method
AssetSet Class See Also Send Feedback
Retrieve a backward moving iterator to the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual AssetSetIterator ReverseIterator()
Visual Basic
Public Overridable Function ReverseIterator As AssetSetIterator
Visual C++
public:
virtual AssetSetIterator^ ReverseIterator()

Return Value

Returns a backward moving iterator to the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSet Properties

[image] [image]

Revit 2013 API
AssetSet Properties
AssetSet Class See Also Send Feedback

The AssetSet type exposes the following members.

Properties

 | Name | Description
Public property | IsEmpty | Test to see if the set is empty.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)
Public property | Size | Returns the number of assets that are in the set.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


IsEmpty Property

[image]

Revit 2013 API
AssetSet..::..IsEmpty Property
AssetSet Class See Also Send Feedback
Test to see if the set is empty.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool IsEmpty { get; }
Visual Basic
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
Visual C++
public:
virtual property bool IsEmpty {
    bool get ();
}

Remarks

If the set is empty then True will be returned, otherwise False.

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


Size Property

[image]

Revit 2013 API
AssetSet..::..Size Property
AssetSet Class See Also Send Feedback
Returns the number of assets that are in the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual int Size { get; }
Visual Basic
Public Overridable ReadOnly Property Size As Integer
    Get
Visual C++
public:
virtual property int Size {
    int get ();
}

See Also

AssetSet Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Class

[image]

Revit 2013 API
AssetSetIterator Class
Members See Also Send Feedback
An iterator to a asset set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public abstract class AssetSetIterator : APIObject,
    IEnumerator
Visual Basic
Public MustInherit Class AssetSetIterator _
    Inherits APIObject _
    Implements IEnumerator
Visual C++
public ref class AssetSetIterator abstract : public APIObject,
    IEnumerator

Inheritance Hierarchy

System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.Utility..::..AssetSetIterator

See Also

AssetSetIterator Members
Autodesk.Revit.Utility Namespace


AssetSetIterator Members

[image] [image]

Revit 2013 API
AssetSetIterator Members
AssetSetIterator Class Constructors Methods Properties See Also Send Feedback

The AssetSetIterator type exposes the following members.

Constructors

 | Name | Description
Public method | AssetSetIterator | For Internal Use Only.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Constructor

[image]

Revit 2013 API
AssetSetIterator Constructor
AssetSetIterator Class See Also Send Feedback
For Internal Use Only.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public AssetSetIterator()
Visual Basic
Public Sub New
Visual C++
public:
AssetSetIterator()

Remarks

This constructor is exposed to enable support for COM interop only. This object should never be created by the developer.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Methods

[image] [image]

Revit 2013 API
AssetSetIterator Methods
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | MoveNext | Move the iterator one item forward.
Public method | Reset | Bring the iterator back to the start of the set.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


MoveNext Method

[image]

Revit 2013 API
AssetSetIterator..::..MoveNext Method
AssetSetIterator Class See Also Send Feedback
Move the iterator one item forward.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

Returns True if the iterator was successfully moved forward one item and the Current property will return a valid item. False will be returned it the iterator has reached the end of the set.

Implements

IEnumerator..::..MoveNext()()()()

Remarks

MoveNext must be called before the Current property is valid with a new or Reset iterator in line with the expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Reset Method

[image]

Revit 2013 API
AssetSetIterator..::..Reset Method
AssetSetIterator Class See Also Send Feedback
Bring the iterator back to the start of the set.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual void Reset()
Visual Basic
Public Overridable Sub Reset
Visual C++
public:
virtual void Reset()

Implements

IEnumerator..::..Reset()()()()

Remarks

The Reset method will return the iterator back to the start of the set in line with the definition of IEnumerator. Note that you must call MoveNext before the first item can be accessed via the Current property.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetSetIterator Properties

[image] [image]

Revit 2013 API
AssetSetIterator Properties
AssetSetIterator Class See Also Send Feedback

The AssetSetIterator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Retrieves the item that is the current focus of the iterator.
Public property | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject.)

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


Current Property

[image]

Revit 2013 API
AssetSetIterator..::..Current Property
AssetSetIterator Class See Also Send Feedback
Retrieves the item that is the current focus of the iterator.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public virtual Object Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As Object
    Get
Visual C++
public:
virtual property Object^ Current {
    Object^ get ();
}

Implements

IEnumerator..::..Current

Remarks

A new or Reset iterator must have MoveNext called on it before Current will return a valid item as per expected behavior of IEnumerator.

See Also

AssetSetIterator Class
Autodesk.Revit.Utility Namespace


AssetType Enumeration

[image]

Revit 2013 API
AssetType Enumeration
See Also Send Feedback
An enumerated to list Asset Types in Revit.

Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2013.0.0.0

Syntax

C#
public enum AssetType
Visual Basic
Public Enumeration AssetType
Visual C++
public enum class AssetType

Members

Member name | Description
Appearance | Appearance assets (materials).
Content | Content assets (RPC / entourage).

See Also

Autodesk.Revit.Utility Namespace


What's New

Major changes and renovations to the Revit API

.NET 4.0 for compilation

All Revit components including RevitAPI.dll and RevitAPIUI.dll are now built with the .NET 4.0 compiler. Thus, add-in projects which reference Revit DLLs must be set as .NET 4.0 Framework projects as well.

New macro environment

VSTA has been replaced by SharpDevelop. This provides identical capabilities for macro creation, editing, and debugging as well as for deployment (application-level and document-level macros) and a simple upgrade procedure for existing macros.

SharpDevelop also provides expanded IDE capabilities, .NET 4.0, extended refactoring tools, code analysis tools, a regular expression toolkit, and macro IDE add-in support.

Revit.ini registration disabled

Add-ins will no longer be read from Revit.ini. Revit will look only to .addin files in the machine-wide and user-specific locations when deciding what add-ins to load.

Document.Element properties replaced

The indexed properties:

  • Document.Element[ElementId]
  • Document.Element[String]

have been replaced by methods:

  • Document.GetElement(ElementId)
  • Document.GetElement(String)

The old indexed properties have been marked obsolete.
The behavior for the new methods is identical to what they replaced.

Replacements for use of old-style collections

ElementArray and ElementSet are now obsolete

With a few exceptions, API methods using ElementArray and ElementSet have been replaced with equivalents using .NET generic collections of ElementIds (ICollection<ElementId>).

Some APIs have been obsoleted with no replacement; these methods are batch element creation methods which dated to the time when regeneration was automatic after every database change. Now that regeneration is manual, having separate batch creation methods provides no extra benefit as multiple element creation calls can be chained together with no delay caused by regeneration. Thus these methods are obsolete:

  • ItemFactoryBase.NewTextNotes()
  • Creation.Document.NewRooms(List<RoomCreationData>)
  • Creation.Document.NewWalls() (all overloads)

When replacing calls to these methods, you should use the corresponding creation method which creates a single element in a loop, while delaying calls to Regenerate() until the loop has concluded. Because Regenerate() is delayed, you should not make inquiries to the newly created elements' geometry as a part of the loop.

Definitions and DefinitionGroups

These classes used to inherit from base classes consisting of old-style Revit API collections. The new versions of the classes offer the same functionality, but implement System.Collections.Generic.IEnumerable<T>.

Code which referred to the older base class or its associated iterator will need to be changed to access members through iteration or the now-available LINQ methods.
In addition, code which called ForwardIterator() or ReverseIterator() on these classes will need to be changed as the new version of the class does not offer these two legacy methods.

GeometryElement.Objects

The property

  • GeometryElement.Objects

has been obsoleted. GeometryElement now inherits directly from IEnumerable<GeometryObject>, and it possible to directly iterate the contents of the GeometryElement using .NET and LINQ, if needed.

Replacements for wall creation methods

New wall creation APIs have been provided as a part of the Wall class:

  • static Wall Create(Document document, Curve curve, ElementId levelId, bool structural) - Creates a new rectangular profile wall within the project using the default wall style.
  • static Wall Create(Document document, Curve curve, ElementId wallTypeId, ElementId levelId, double height, double offset, bool flip, bool structural) - Creates a new rectangular profile wall within the project using the specified wall type, height, and offset.
  • static Wall Create(Document document, IList<Curve> profile, bool structural) - Creates a non rectangular profile wall within the project using the default wall type:
  • static Wall Create(Document document, IList<Curve > profile, ElementId wallTypeId, ElementId levelId, bool structural) - Creates a non rectangular profile wall within the project using the specified wall type.
  • static Wall Create(Document document, IList<Curve > profile, ElementId wallTypeId, ElementId levelId, bool structural, XYZ normal) - Creates a non rectangular profile wall within the project using the specified wall type and normal vector.

These methods replace the obsolete methods on Autodesk.Revit.Creation.Document (NewWall() (all overloads)). The NewWalls() overloads are obsoleted without dedicated replacements, as described here: ElementArray and ElementSet are now obsolete

Idling event and External Events

Idling event frequency

The Idling event has been changed to offer two different modes of behavior. The default behavior has changed; pre-existing code that needs the original behavior will need to opt-in to the non-default behavior.

In the default mode, a single raise of the event will be made each time Revit begins an idle session. Note that when the user is active in the Revit user interface, idle sessions begin whenever the mouse stops moving for a moment or when a command completes. However, if the user is not active in the user interface at all, Revit may not invoke additional idling sessions for quite some time; this means that your application may not be able to take advantage of time when the user leaves the machine completely idle for a period of time.

In the non-default mode, your application forces Revit to keep the idling session open and to make repeated calls to your event subscriber. In this mode even if the user is totally inactive the Revit session will continue to make Idling calls to your application. However, this can result in performance degradation for the system on which Revit is running because the CPU remains fully engaged in serving Idling events during the Revit application's downtime.

You can indicate the preference for the non-default Idling frequency by calling

  • IdlingEventArgs.SetRaiseWithoutDelay()

each time the Idling event callback is made. Revit will revert to the default Idling frequency if this method is not called every time in your callback.

Idling event with no active document

The Idling event now is invoked when there is no document active in Revit.

External Events framework

The External Events framework is a new API framework tailored for asynchronous processing such as that which is needed to support modeless dialogs. It operates similarly to the Idling event with default frequency.
With this framework, instead of implementing an event handler and implementing the handler to do nothing when there is no activity in your dialog, instead you do the following:

  1. Implement an external event by deriving from the interface:
    • IExternalEvent
  2. Create an ExternalEvent with
    • ExternalEvent.Create()
  3. When an event happens in your modeless UI where a Revit action needs to be taken, call
    • ExternalEvent.Raise()
  4. Revit will wait for an available Idling timecycle and call the implementation of your event:
    • IExternalEvent.Execute()

This framework is more useful for modeless dialog developers because you can skip the default no-op implementation when nothing has happened, and tell Revit when there is some work you need to do in Revit. It also saves on the time required for Revit to make repeated calls to the Idling event when there is no actual work to be done.

Calling OpenAndActivateDocument during events

The UIApplication.OpenAndActivateDocument can now be invoked during events under the following conditions:

  1. When invoked from an External Event, not restrictions apply except for the original active document to be free of transactions and transaction groups.
  2. When invoked from regular event handlers, the following restrictions apply:
    • There must be no active document open yet in Revit
    • The event must not be nested in other events or in execution external command

Document & worksharing changes

Worksharing properties

The information required to identify a workshared file on the central or local locations have changed due to changes to RevitServer. As a result, the members

  • Application.GetRevitServerNetworkHosts()
  • Application.CurrentRevitServerAccelerator
  • Document.WorksharingCentralFilename

replace the properties

  • Application.CentralServerName
  • Application.LocalServerName
  • Document.GetWorksharingCentralModelPath()

The new members:

  • Application.GetWorksharingCentralGUID(ServerPath serverModelPath)
  • Document.WorksharingCentralGUID

provides read access to the worksharing central GUID of the given server-based model. This is applicable only to workshared models saved in Revit 2013 or later.

New overloads for Application.OpenDocumentFile() and UIApplication.OpenAndActivateDocument()

The new overloads support parameters OpenOptions and OpenOptionsForUI, respectively, to specify how a Revit document should be opened. Both options classes currently offer the ability to detach the opened document from central if applicable.

The property:

  • OpenOptions.DetachFromCentralOption
    can be set to DoNotDetach (the default) or DetachAndPreserve.

The property:

  • OpenOptionsForUI.DetachFromCentralOption
    can be set to DoNotDetach (the default), DetachAndPreserveWorksets or DetachAndPrompt.

BasicFileInfo

The new class

  • BasicFileInfo
    offers basic information about a Revit file, including worksharing status, Revit version, username and central path. The information can be extracted without fully opening the file.

Point cloud engine API changes

Because these are new methods in a pre-existing interface, existing code will have to be modified to implement the methods.

Free()

Unlike other Point Cloud interfaces in the Revit 2012 release, this interface did not offer a method to be called when Revit is finished with it.

When Revit calls this function it indicates that the IPointCloudAccess interface is no longer going to be used and the provider of the interface can dispose of all allocated resources.

GetOffset()

Implement this method to return the offset stored in the point cloud. All points are assumed to be offset by the same offset vector. The offset should be expressed in the same units as used by the point coordinates (the scale conversion factor is not applied). The offset will be used by Revit if the user choose to place an instance relative to another point cloud (the "Auto - Origin To Last Placed" placement option).

CreatePointSetIterator()

A second overload with an additional argument – density – the desired number of points per unit area. Area is computed in native units of the point cloud.

IFC export APIs

The IFC export implementation in Revit has switched to a more generic toolkit. As a result, many of the APIs introduced in Revit 2012 to support customized IFC export have been removed and replaced, and new interfaces introduced that allow more flexibility in the data which is written to the IFC file. Autodesk recommends that any customization of IFC export begin with the implementation of the default Revit IFC exporter client, and that customizations written for 2012 be ported incrementally to support Revit 2013.

Construction Modeling changes

The following members are now obsolete:

  • Part.GetDividedParents() - replaced with Part.GetSourceElementIds
  • PartMaker.GetDividedElementIds() - replaced with PartMaker.GetSourceElementIds
  • PartMaker.IsElementDivided() - replaced with PartMaker.IsSourceElement
  • PartMaker.SetDividedElementIds() - replaced with PartMaker.SetSourceElementIds
  • PartUtils.ArePartsValidForDivide -> replaced with PartUtils.AreElementsValidForDivide()

The following members are now obsolete - they are not being replaced with new members because the information they returned can be obtained by applying GetSourceElementIds recursively to source elements that are Parts.

  • Part.OriginalDividedElementId
  • Part.ParentDividedElementId
  • PartUtils.GetDividedParent()

The following members are obsolete. Their replacements live on the PartMakerMethodToDivideVolumes class, which you can obtain for a given PartMaker using PartUtils.GetPartMakerMethodToDivideVolume():

  • PartUtils.AreElementsValidIntersectingReferences()
  • PartUtils.IsValidSketchPlane()
  • PartUtils.SetOffsetForIntersectingReference()
  • PartUtils.GetOffsetForIntersectingReference()
  • PartUtils.PartMakerUsesReference()

The methods:

  • AssemblyViewUtils.CreatePartList()
  • AssemblyViewUtils.CreateMaterialTakeoff()
    now return ViewSchedule instead of View.

Structure changes

Rebar.GetCenterlineCurves()

The overload taking one argument is now obsolete.

The new three-argument Rebar.GetCenterlineCurves(Boolean, Boolean, Boolean) has arguments to control whether or not to:

  • adjust for self-intersection
  • include hooks
  • include bend radius curves (fillets)

Rebar member changes

These members are now obsolete:

  • Rebar.DistributionPath is replaced by Rebar.GetDistributionPath()
  • Rebar.Host is replaced by Rebar.GetHostId() and SetHostId()
  • Rebar.RebarShape is replaced by Rebar.RebarShapeId property
  • Rebar.BarType is obsoleted. Use the inherited GetTypeId() and ChangeTypeId()

AreaReinforcement and PathReinforcement

BarDescription class

The new RebarInSystem element replaces the BarDescription class. This class and related methods:

  • AreaReinforcement.NumBarDescriptions()
  • AreaReinforcement.GetBarDescription()
  • PathReinforcement.NumBarDescriptions()
  • PathReinforcement.GetBarDescription()

are obsolete in 2013.

When ReinforcementSettings.HostStructuralRebar is true, Area and Path Reinforcement elements create individual rebar elements that participate in views and schedules. The individual RebarInSystem elements have the same graphical representation and parameters as Rebar elements, and have the same API methods for inquiry. But the RebarInSystem elements are almost entirely controlled by their system element (Area or Path). Therefore they are missing most of the modification methods of the Rebar class.

New methods:

  • AreaReinforcement.GetRebarInSystemIds()
  • AreaReinforcement.RemoveAreaReinforcementSystem()
  • PathReinforcement.GetRebarInSystemIds()
  • PathReinforcement.RemovePathReinforcementSystem()

MEP changes

ConnectorProfileType, PartType

ConnectorProfileType enums are renamed to:
Invalid, Round, Rectangular, Oval

PartType::UndefinedPartType is renamed to PartType::Undefined.

ConnectorElement

Subclasses of ConnectorElement: PipeConnector, DuctConnector, and ElectricalConnector, are obsolete.

  • IsPrimary - moved to ConnectorElement
  • AssignAsPrimary - moved to ConnectorElement
  • LinkedConnector - moved to ConnectorElement as GetLinkedConnectorElement and SetLinkedConnectorElement
  • Please query the parameters RBS_PIPE_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM, RBS_DUCT_CONNECTOR_SYSTEM_CLASSIFICATION_PARAM, or RBS_ELEC_CIRCUIT_TYPE on ConnectorElement to obtain the PipeSystemType, DuctSystemType, and ElectricalSystemType values on the now obsolete PipeConnector, DuctConnector, and ElectricalConnector elements.

Connector element types can now be created using new methods:

  • ConnectorElement.CreatePipeConnector()
  • ConnectorElement.CreateDuctConnector()
  • ConnectorElement.CreateElectricalConnector()
  • ConnectorElement.CreateConduitConnector()
  • ConnectorElement.CreateCableTrayConnector()

These methods replace the methods on Autodesk.Revit.Creation.FamilyItemFactory (NewDuctConnector, NewPipeConnector, NewElectricalConnector). Those methods are now obsolete.

Obsolete API Cleanup

Many API classes and methods previously marked Obsolete in Revit 2012 and earlier have been removed from the API.

Classes removed

  • MaterialConcrete, MaterialGeneric, MaterialOther, MaterialSteel, MaterialWood - all data is now accessed via the Material class
  • Autodesk.Revit.DB.ConstructionType - replaced by Autodesk.DB.Analysis.ConstructionType
  • SuspendUpdating - no longer needed because Automatic regeneration mode has been removed.Autodesk.Revit.UI.Macros.ApplicationEntryPoint
  • Autodesk.Revit.VSTA.ApplicationEntryPoint - replaced by Autodesk.Revit.UI.Macros.ApplicationEntryPoint
  • Autodesk.Revit.VSTA.DocumentEntryPoint - replaced by Autodesk.Revit.UI.Macros.DocumentEntryPoint
  • Autodesk.Revit.VSTA.IEntryPoint - replaced by Autodesk.Revit.UI.Macros.IEntryPoint
  • Autodesk.Revit.VSTA.AddInIdAttribute - replaced by Autodesk.Revit.UI.Macros.AddInIdAttribute
  • Autodesk.Revit.VSTA.VendorIdAttribute - replaced by Autodesk.Revit.UI.Macros.VendorIdAttribute

Methods and properties removed

  • AnalysisDisplayLegend.Width - replaced by legend settings of AnalysisDisplayStyle.
  • AnalysisDisplayLegendSettings.SetTextTypeId(ElementId , Document)
  • AnalysisDisplayMarkersAndTextSettings.SetTextTypeId(ElementId , Document)
  • AnalyticalModel methods

· IsValidAnalyticalProjectionType(AnalyticalDirection , AnalyticalProjectionType) replaced by IsValidProjectionType

· GetAnalyticalProjectionDatumPlane(AnalyticalDirection ) replaced by GetAnalyticalProjectionDatumPlane(AnalyticalElementSelector , AnalyticalDirection)

· IsValidDatumPlaneForProjection(AnalyticalDirection, ElementId ) replaced by IsValidProjectionDatumPlane

· SetAnalyticalProjectionDatumPlane(AnalyticalDirection , ElementId ) replaced by setAnalyticalProjectionDatumPlane(AnalyticalElementSelector, AnalyticalDirection, ElementId)

· SetAnalyticalOffset(XYZ) replaced by SetOffset

· GetAnalyticalOffset() replaced by GetOffset

· GetAnalyticalProjectionType(AnalyticalDirection) replaced by GetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection)

· SetAnalyticalProjectionType(AnalyticalDirection , AnalyticalProjectionType ) replaced by SetAnalyticalProjectionType(AnalyticalElementSelector, AnalyticalDirection, AnalyticalProjectionType)

  • IFCExportOptions.CurrentViewOnly
  • PointCloudFilter.GetFilterOutline() - replaced by PointCloudFilterUtils.GetFilteredOutline()
  • RebarHostData.HasCoverTypeForReference(Reference ) - replaced by IsFaceExposed()
  • SpatialFieldManager members
    • CurrentUnits replaced by AnalysisResultSchema.CurrentUnits and SpatialFieldManager.SetResultSchema()
    • UpdateSpatialFieldPrimitive(int , Autodesk.Revit.DB.Analysis.FieldDomainPoints, Autodesk.Revit.DB.Analysis.FieldValues)
    • SetUnits(System.Collections.Generic.IList<System.String> , System.Collections.Generic.IList<double>) replaced by AnalysisResultSchema.SetUnits() and SpatialFieldManager.SetResultSchema()
    • GetDescription() replaced by SpatialFieldManager.SetResultSchema() and AnalysisResultSchema.Description
    • SetDescription(System.String) replaced by AnalysisResultSchema.Description and SpatialFieldManager.SetResultSchema()
  • AnnotationSymbol.AsFamilyInstance
  • Area.Boundary - replaced by GetBoundarySegments(SpatialElementBoundaryOptions)
  • Element members
    • ObjectType replaced by GetTypeId() and ChangeTypeId()
    • SimilarObjectTypes replaced by GetValidTypes()
  • Materials members
    • AddOther(System.String) replaced by Material.Create
    • AddWood(System.String) replaced by Material.Create
    • AddConcrete(System.String) replaced by Material.Create
    • AddSteel(System.String) replaced by Material.Create
    • AddGeneric(System.String) replaced by Material.Create
  • PropertySetElement.Create(Document, MaterialAspect) replaced by PropertySetElement.Create(Document, StructuralAsset) and PropertySetElement.Create(Document, ThermalAsset)
  • Mullion.AsFamilyInstance
  • Panel.AsFamilyInstance
  • Rebar.IsShownInFrontOfGeometryInView[View] - replaced by IsUnobscuredInView() and SetUnobscuredInView()
  • PointOnEdge members
    • PointOnEdge(Autodesk.Revit.DB.Reference, double) replaced by PointLocationOnCurve
    • CurveParameter replaced by LocationOnCurve
  • Room.Boundary - replaced by GetBoundarySegments(SpatialElementBoundaryOptions)
  • Face.MaterialElement - replaced by MaterialElementId
  • Reference members
    • Element replaced by Document.GetElement(Reference)
    • GeometryObject replaced by Element.GetGeometryObjectFromReference(Reference)
    • Transform replaced by ReferenceByContext.GetInstanceTransform() after obtaining ReferenceWithContext from Document.FindReferencesWithContextByDirection()
    • ProximityParameter replaced by ReferenceByContext.ProximityParameter after obtaining ReferenceWithContext from Document.FindReferencesWithContextByDirection()
  • PipingSystem members
    • FluidType, FluidType is now a property of the system type. Get the system type, and set the parameter RBS_PIPE_FLUID_TYPE_PARAM directly
    • FluidTemperature, FluidTemperature is now a property of the system type. Get the system type, and set the parameter RBS_PIPE_FLUID_TEMPERATURE_PARAM directly
    • FluidDensity, FluidDensity is now a property of the system type. Get the system type, and set the parameter RBS_PIPE_FLUID_DENSITY_PARAM directly
    • FluidViscosity, FluidViscosity is now a property of the system type. Get the system type, and set the parameter RBS_PIPE_FLUID_VISCOSITY_PARAM directly
  • Space.Boundary - replaced by GetBoundarySegments(SpatialElementBoundaryOptions)
  • Application.LibraryPaths - replaced by GetLibraryPaths() and SetLibraryPaths()
  • ControlledApplication.LibraryPaths - replaced by GetLibraryPaths() and SetLibraryPaths()
  • Application.NewPointOnEdge(Autodesk.Revit.DB.Reference , double edgeParam) - replaced by other constructor that uses PointLocationOnCurve
  • Document members
    • Move() - all overloads - replaced by methods of ElementTransformUtils
    • Rotate() - all overloads - replaced by methods of ElementTransformUtils
    • Mirror() - all overloads - replaced by methods of ElementTransformUtils
    • Array() - all overloads - replaced by methods of LinearArray and RadialArray
    • ArrayWithoutAssociate() - all overloads - replaced by methods of LinearArray and RadialArray
    • SaveAs(System.String, bool) - replaced by SaveAs(String, SaveAsOptions)
    • FindReferencesByDirection() - replaced by FindReferencesWithContextByDirection() and ReferenceIntersector methods
    • ExternalFileReference & ImportFileData - all methods and enums related to material paths
    • AbbreviationItem - empty class removed completely
    • WorksharingCentralFilename - replaced by GetWorksharingCentralModelPath()
  • ModelPathUtils.GetRevitServerPrefix() - RSN:// is the prefix string for Revit Server path.

Major enhancements to the Revit API

Stairs and railings API

Stairs and stairs components

The new classes in the Autodesk.Revit.DB.Architecture namespace:

  • Stairs
  • StairsType

provide access to new stairs elements in the Revit database. Note that these API classes only provide access to the Stairs created "by component" introduced in this release. Stairs elements created by sketch cannot be accessed as a Stairs object in the API. It is possible to identify both type of stairs using the BuiltInCategory OST_Stairs and the static method Stairs.IsByComponent() can identify an element id represents a by component stairs.

The classes:

  • StairsLanding
  • StairsLandingType
  • StairsRun
  • StairsRunType

provide access to the subcomponents and subcomponent types of the new Stairs elements.

Railings and railing components

The new classes in the Autodesk.Revit.DB.Architecture namespace:

  • Railing
  • RailingType

provide access to the top level railing elements in the Revit database. Railings can be associated to a host, such as a stairs or a floor, or placed in space. Railings can be continuous or non-continuous. If non-continuous, only a limited level of access is provided.

Stairs annotations

The new class

  • CutMarkType

provides access to the properties and capabilities of a CutMark annotation which can be associated to stairs.

The new classes

  • StairsPath
  • StairsPathType

provide access to the stairs path annotation.

View API

View Creation

  • Plan Views can now be created with the new ViewPlan.Create(document, viewFamilyTypeId, levelId) method. For example, a ceiling plan can be created as follows:

Element level = doc.GetElement(uidoc.Selection.PickObject(ObjectType.Element)) as Level;

IEnumerable<ViewFamilyType> viewFamilyTypes = from elem in new FilteredElementCollector(doc)

         .OfClass(typeof(ViewFamilyType))

          let type = elem as ViewFamilyType

          where type.ViewFamily == ViewFamily.CeilingPlan

          select type;

ViewPlan ceilingPlan = ViewPlan.Create(doc, viewFamilyTypes.First().Id, level.Id);

ceilingPlan.Name = "New Ceiling Plan for " + level.Name;

ceilingPlan.DetailLevel = ViewDetailLevel.Fine;

//3D views can be created with View3D.CreateIsometric and View3D.CreatePerspective.

//The new ViewOrientation3D object is used to get or set the orientation of 3D views.

View3D view = View3D.CreateIsometric(doc, viewFamily3d);

XYZ eyePosition = new XYZ(10, 10, 10);

XYZ upDirection = new XYZ(-1, 0, 1);

XYZ forwardDirection = new XYZ(1, 0, 1);

view.SetOrientation(new ViewOrientation3D(eyePosition, upDirection, forwardDirection));

  • The ViewSection class now has methods that support the creation of Callout, Reference Callout, and Reference Section views.
  • Rendering views containing images imported from disk can be created using the new ImageView class and the ImageView.Create method.

DisplayStyle

The enum DisplayStyle (with values including Wireframe, HLR, and Shading) has been added so the API can be used to get/set the new DisplayStyle property.

ViewDetailLevel

The enum ViewDetailLevel (with values Coarse, Medium, and Fine) has been added with get/set access to the new DetailLevel property.

ViewRange

The view range for plan views can now be retrieved via ViewPlan.GetViewRange().

3D View Locking

  • 3D Views can now be locked and unlocked via the API with the methods SaveOrientationAndLock, RestoreOrientationAndLock, and Unlock.
  • The property IsLocked indicates if a view is currently locked.
  • NewTag can now be used in locked 3D Views.

View.Duplicate

Views can now be duplicated via the API with the View.Duplicate(ViewDuplicateOption) method.

UIView class and UIDocument.GetOpenUIViews()

The UIView class has been added to represent a view window in the Revit user interface. GetOpenUIViews provides a list of all open views. UIView.GetWindowRectangle() returns a rectangle that describes the size and placement of the UIView window.

Pan and Zoom

The method

  • UIView.ZoomAndCenterRectangle()

offers the ability to zoom and pan the active view to center on the input region of the model.

The method

  • UIView.GetZoomCorners()

returns the two points that define the corners of the view's rectangle in model coordinates.

PlanViewDirection

The enum PlanViewDirection has been added so API can be used to get/set the view direction to either Up or Down for StructuralPlan views.

ViewFamilyType class and ViewFamily enum

The ViewFamilyType class has been created to correspond to the Types seen in the UI's Properties dialog for each view. The ViewFamily enum (FloorPlan, Section, Legend, etc) specifies the family of the ViewFamilyType.

Temporary view modes

View.EnableRevealHiddenMode, View.EnableTemporaryAnalyticalDisplayMode, View.DisableTemporaryViewMode, and the TemporaryViewMode Enumeration have been added to allow control of temporary view modes.

Schedules

Schedule API

Several new classses have been added to allow schedule views to be created, modified, and added to drawing sheets. Major new classes include:

  • The ViewSchedule class that represents the schedule view. Its create methods are used to create new schedules.
  • The ScheduleField class for the inidivual fields in a schedule
  • The ScheduleSheetInstance class represents schedules placed on sheets. The create method creates an instance of a schedule on a sheet.
  • The ScheduleDefinition class defines the contents of a schedule view, including:
  1. Basic properties that determine the kind of schedule, such as the schedule's category.
  2. A set of fields that become the columns of the schedule.
  3. Filters that restrict the set of elements visible in the schedule.
  4. Sorting and grouping criteria.

Running API commands in Schedule Views

API commands may now be active when a Schedule is active in the current document.

Schedule export

The ViewSchedule class has been added to the API and the method ViewSchedule.Export method exports an existing schedule to a text file.

Discipline controls

The properties:

  • Application.IsArchitectureEnabled
  • Application.IsStructureEnabled
  • Application.IsStructuralAnalysisEnabled
  • application.IsMassingEnabled
  • Application.IsEnergyAnalysisEnabled
  • Application.IsSystemsEnabled
  • Application.IsMechanicalEnabled
  • Application.IsMechanicalAnalysisEnabled
  • Application.IsElectricalEnabled
  • Application.IsElectricalAnalysisEnabled
  • Application.IsPipingEnabled
  • Application.IsPipingAnalysisEnabled

provide read and modify access to the available disciplines. Your application can read the properties to determine when to enable or disable aspects of the UI.
Enabling and disabling disciplines is available only in Autodesk Revit (and not in any other Revit product). When a discipline's status is toggled, Revit's UI will be adjusted, and certain operations and features will be enabled or disabled as appropriate.

Rendering Options

The settings shown in the Rendering Options Dialog are exposed, allowing an API user can get and set Rendering Options for a 3d view.

The new methods:

  • View3D.GetRenderingSettings
  • View3D.SetRenderingSettings

gets or changes the rendering settings for the 3d view.

The class

  • RenderingSettings

offers properties and methods which correspond to the options in the UI dialog:

  • RenderingSettings.UsesRegionRendering - Boolean value that indicates whether to use region rendering.
  • RenderingSettings.BackgroundStyle - The enum value that controls the background style for rendering.
  • RenderingSettings.ResolutionTarget - The resolution target.
  • RenderingSettings.PrinterResolution - The resolution level when using printer.
  • RenderingSettings.LightingSource - The lighting scheme type.
  • RenderingSettings.ResolutionValue - The rendering resolution in dots per inch (DPI).
  • RenderingSettings.GetBackgroundSettings() - Returns an object that represents the rendering background settings.
  • RenderingSettings.SetBackgroundSettings() - Changes the rendering background settings details for the current background style.
  • RenderingSettings.GetRenderingImageExposureSettings() - Returns an object that represents the rendering image exposure settings.
  • RenderingSettings.SetRenderingImageExposureSettings() - Changes the rendering image exposure settings.
  • RenderingSettings.GetRenderingQualitySettings() - Returns an object that represents the rendering quality settings.
  • RenderingSettings.SetRenderingQualitySettings() - Changes rendering quality settings.
  • RenderingSettings.GetRenderingRegionOutline() - Returns the outline of the rendering region.

The rendering properties are exposed with the following supplementary classes and enums:

  • enum BackgroundImageFit - Represents the type of background image fit.
  • enum ResolutionTarget - Represents the resolution target (Screen or Printer) used for rendering.
  • enum PrinterResolution - Controls the resolution level for a printer target.
  • enum LightingSource - Represents the lighting scheme type.
  • enum RenderingQuality - Represents the rendering quality.
  • enum BackgroundStyle- Represents the background style.
  • class SkyBackgroundSettings - Represents the rendering sky background settings.
  • class ColorBackgroundSettings - Represents the rendering color background settings.
  • class ImageBackgroundSettings - Represents the rendering image background settings.
  • class RenderingImageExposureSettings - Represents the exposure settings of rendering.

Example: checking rendering options for a 3D view

RenderingSettings renderingSettings = view3D.GetRenderingSettings();

Transaction newTran = new Transaction(doc, "Change Rendering Settings");

newTran.Start();

renderingSettings.BackgroundStyle = BackgroundStyle.Image;

view3D.SetRenderingSettings(renderingSettings);

newTran.Commit();

Construction Modeling

Linked element parents for parts

Parts can be created from linked elements. There are new overloads:

  • PartUtils.CreateParts()
  • PartUtils.IsValidForCreateParts()
  • PartUtils.HasAssociatedParts()
  • PartUtils.GetAssociatedParts()
  • PartUtils.GetAssociatedPartMaker()

which accept LinkElementIds (representing the id of the element in the link). The existing Part utilities accepting ElementId have not been changed.

Merged parts

The methods:

  • PartUtils.ArePartsValidForMerge()
  • PartUtils.CreateMergedPart()
  • PartUtils.FindMergeableClusters()
  • PartUtils.GetChainLengthToOriginal()
  • PartUtils.GetMergedParts()
  • PartUtils.IsMergedPart()

provide support for merging of parts.

Excluded parts

The new property

  • Part.Excluded

allows identification and assignment of parts to be excluded.

Part category

The new members:

  • Part.OriginalCategoryId
  • Part.GetSourceElementOriginalCategoryIds()

provide the ability to get and set the original category id for a given part.

Part division

Part divisions can now be assigned custom geometry divisions. The members:

  • PartMakerMethodToDivideVolumes.ProfileMatch
  • PartMakerMethodToDivideVolumes.DivisionGap
  • PartMakerMethodToDivideVolumes.ProfileOffset
  • PartMakerMethodToDivideVolumes.SplitterProfileType
  • PartMakerMethodToDivideVolumes.ProfileFlipAcross
  • PartMakerMethodToDivideVolumes.ProfileFlipAlong
  • PartMakerMethodToDivideVolumes.GetSketchCurves()
  • PartMakerMethodToDivideVolumes.GetPlaneOfSketch()
  • PartMakerMethodToDivideVolumes.GetSplitRefsOffsets()
  • PartMakerMethodToDivideVolumes.CanBeDivisionProfile()

offer the ability to examine and control properties of the divisions.

Assembly views

The method

  • AssemblyViewUtils.AcquireAssemblyViews()

transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.

Assembly instance transform and location

The methods

  • AssemblyInstance.GetTransform()
  • AssemblyInstance.SetTransform()

provide read and write access to the transformation origin of the assembly. Changing this value causes the origin point to change relative to the assembly members (and does not move the assembly members). All assemblies of the same type should have changed their transforms by the same amount. For example, if you changed the transform of the assembly by a rotation of 90 degrees, then other assemblies should also have rotated their transform by 90 degrees.

The inherited property

  • AssemblyInstance.Location

also has been modified to return a the location for an AssemblyInstance.

Structure improvements

New Rebar members

  • RebarShapeMatchesCurvesAndHooks() checks if rebarShape matches curves and hooks
  • CreateFromCurvesAndShape() creates a new instance of a Rebar element with default shape parameters from the RebarShape
  • GetBarPositionTransform()
  • GetBarExistsAtPosition()
  • GetHookTypeId() and SetHookTypeId()
  • ScheduleMark property
  • TotalLength property
  • Volume property

ReinforcementSettings

The new class ReinforcementSettings controls project settings that are accessible from the Reinforcement Settings dialog in the Revit UI. For 2013 the only supported setting is the HostStructuralRebar property, which is new for 2013 and affects the AreaReinforcement and PathReinforcement elements.

AreaReinforcement/PathReinforcement

AreaReinforcement and PathReinforcement now have types.
The types - AreaReinforcementType and PathReinforcementType - contain only identity data.

There is no change to the interface for creating Area and Path Reinforcement elements. A default, or most-recently-used type, is automatically assigned on element creation.

New Area- and PathReinforcementTypes can be created using the following methods:

  • (static) AreaReinforcementType AreaReinforcementType.Create(Document ADoc, AString Name)
  • (static) PathReinforcementType PathReinforcementType.Create(Document ADoc, AString Name)

Analytical model

The new element type

  • AnalyticalLink

can be created between two other Analytical Elements, e.g. an analytical beam and analytical column. There are two kinds of Links: user defined and automatically generated. Links have properties like "fixity state" that can be accessed via the API.

MEP improvements

Routing Preferences

Revit MEP now supports a system for selecting preferred pipe and duct sizes, materials, and fitting types for use in an MEP project. The routing preferences API can be used to set routing preference policies for end users as well as to query which fittings and segments will be used given size criteria.

  • property MEPCurveType.RoutingPreferenceManager - accesses the main routing preferences object for a give MEPCurve Type. Currently, PipeType and DuctType are the only MEPCurve types that support Routing Preferences.
  • class RoutingPreferenceManager - manages all routing preference rules for segments and fittings and allows the user to query which fitting or segment will be chosen by Revit, given a size condition.
  • classes RoutingCriterionBase and PrimarySizeCriterion - These classes manage criteria for selecting fittings and segments based on minimum and maximum size constraints.
  • class RoutingPreferenceRule - Manages one segment or fitting preference
  • classes RoutingCondition and RoutingConditions - Inputs to RoutingPreferenceManager.GetMEPPartId() to select fittings and segments based on their selection criteria.
  • class Segment - A class representing a length of MEPCurve that contains a material and set available sizes.
  • class PipeSegment - a subclass of Segment representing a length of pipe

· PipeSegment.Create(ElementId materialId, ElementId scheduleId) - Creates a new PipeSegment of given material, schedule, and size list.

  • enum RoutingPreferenceRuleGroupType - Each routing preference rule is grouped according to what type of routing item it manages

· Elbows

· Junctions

· Crosses

· Transitions

· Unions

· MechanicalJoints

· Segments

· TransitionsRectangularToRound

· TransitionsRectangularToOval

· TransitionsOvalToRound

MEP Sections

The new class

  • MEPSection

is the base class for duct and pipe section. It is a series of connected elements (segments - ducts or pipes, fittings, terminals and accessories). All section members should have same flow analysis properties: Flow, Size, Velocity, Friction and Roughness. One section member element which contains more than one connector can belongs to multiple section.
For example: One Tee fitting that has 3 connectors usually belongs to 3 sections. One segment that connects to a tap will be divided into 2 sections

FluidType and FluidTemperature

The new class

  • FluidTemperature

represents the viscosity and density properties as defined at a certain temperature.

The class

  • FluidType

has been extended to provide read and write access to a collection of FluidTemperature objects which represent the fluid's properties at various temperatures.

Panel schedule - spare values

The new functions

  • PanelScheduleView.GetSpareLoadValue()
  • PanelScheduleView.SetSpareLoadValue()
  • PanelScheduleView.GetSpareCurrentValue()
  • PanelScheduleViwe.SetSpareCurrentValue()

provide access to the parameter values of spare circuits.

LabelUtils

New overloads of

  • LabelUtils.GetLabelFor()

have been added to supply the user-visible string matching members of the enums DuctLossMethodType, PipeLossMethodType, and PipeFlowState.

Physical Properties

Thermal properties

Thermal properties of various elements have been enhanced in Revit 2013.

  • class ThermalProperties
    • Absorptance
    • HeatTransferCoefficient
    • Roughness
    • ThermalMass
    • ThermalResistance

This class is a property on the following types:

  • ThermalProperties WallType.ThermalProperties
  • ThermalProperties FloorType.ThermalProperties
  • ThermalProperties CeilingType.ThermalProperties
  • ThermalProperties RoofType.ThermalProperties
  • ThermalProperties BuildingPadType.ThermalProperties
  • class FamilyThermalProperties

· AnalyticConstructionTypeId - This value corresponds to the 'id' property of a constructionType node in Constructions.xml, a supplied data library of thermal properties of common construction types.

· HeatTransferCoefficient

· SolarHeatGainCoefficient

· ThermalResistance

· VisualLightTransmittance

· Find() - returns a FamilyThermalProperties object from an "id" string in Constructions.xml

  • FamilySymbol.GetThermalProperties() – Gets the thermal properties of a family symbol of a door, window, or curtain panel.
  • FamilySymbol.SetThermalProperties()-- Sets the thermal properties of a family symbol of a door, window, or curtain panel.

This class is a property on Door, Window, and Curtain Panel family symbols

  • FamilyThermalProperties FamilySymbol.ThermalProperties

Structural properties

  • Beam, Column, and Foundation family instances now support an ElementId of an additional structural Material element

* ElementId FamilyInstance.StructuralMaterialId (Foundation, Beam, and Column instances)

All compound structurals can now elect one layer in the structural to be used as the "structural" layer.

  • int CompoundStructure.StructuralMaterialIndex
  • PropertySetElement now supports a StructuralAsset property via the GetStructuralAsset and SetStructuralAsset methods.
    StructuralAsset contains named properties for various structural values, such as PoissonModulus and YoungModulus, that offer enhanced ease of use over the previous parameter-api based access to these same values.

Material assets

  • StructuralAsset – contains structural properties that can be set on materials via PropertySetElement and SetMaterialAspectByPropertySet()
  • ThermalAsset – contains thermal properties that can be set on materials via PropertySetElement and SetMaterialAspectByPropertySet()
  • PropertySetElement.Create() - now takes a StructuralAsset or ThermalAsset as a parameter instead of a MaterialAspect.

GBXML Export

  • Thermal properties of building construction element types can now be set to use calculated values or pre-defined values from
    Constructions.xml with:

· MEPBuildingConstruction.GetBuildingConstructionOverride

· MEPBuildingConstruction.SetBuildingConstructionOverride

  • EnergyDataSettings.IncludeThermalProperties
    • Indicates if thermal information from model assemblies and components is included in GreenBuildingXML export of the detailed model.

User interface API improvements

Contextual help support

Items placed on the Ribbon can now be assigned an action for contextual help using

  • RibbonItem.SetContextualHelp()

The options supported include linking to an external URL, launching a locally installed help file, or linking to a topic on the Autodesk help wiki.

You can also invoke the same set of contextual help options at any arbitrary time within your add-in by creating a ContextualHelp object with the appropriate target location, and invoking

  • ContextualHelp.Launch()

Support for Keyboard Shortcuts and Quick Access Toolbar

API commands may now be assigned keyboard shortcuts, and those assignments will be preserved even if add-ins are added, removed or changed in subsequent sessions.

API commands may also be moved to the Quick Access Toolbar, and that assignment will also be preserved even if add-ins are added, removed or changed in subsequent sessions.

Replace implementation of commands

It provides ability to replace the existing Revit command (located in any tab, application menu and right-click menus) implementation with add-in routine.

  • RevitCommandId

The new class RevitCommandId provides ability to look up and retrieve an object representing Revit Command id given an id string. The id string of the command is the string which appears in the journal when the command is clicked, e.g. "ID_APP_EXIT".

  • AddInCommandBinding

The new class AddInCommandBinding provides ability to override the Revit command implementation with Executed and CanExecute events.

  • UIApplication.CreateAddInCommandBinding()
  • UIControlledApplication.CreateAddInCommandBinding()

These 2 new methods provides ability to create the command binding with given Revit command id.

Preview control

The new class

  • PreviewControl

provides the ability to embed an interactive Revit view as a WPF control inside a dialog.

Options dialog customization

Subscribe to the new event

  • UIApplication.DisplayingOptionsDialog

to be notified when Revit is preparing the Options dialog for display. During the event callback, your application can call

  • DisplayingOptionsDialogEventArgs.AddTab()

to add a new tab to the dialog. The contents of the panel shown when this new tab is selected are determined by the members assigned to the input class:

  • TabbedDialogExtension

Drag & Drop support

The new methods

  • UIApplication.DoDragDrop(ICollection<String>)
  • UIApplication.DoDragDrop(Object, IDropHandler)

initiate a drag and drop operation on the Revit user interface.
The first method accepts a list of file names, which can be Revit files, import CAD and images, or some combination of the two. The second method accepts arbitrary data, and provides an IDropHandler callback to handle the drop of the data when the user completes it.

Translation API enhancements

Several updates have been made to the APIs related to data exchange and translation of models.

DGN import

The new method

  • Document.Import(string, DGNImportOptions, View)

supports import of DGN files into Revit views.

DXF import

The method

  • Document.Import(string, DWGImportOptions)

now also supports DXF files for import.

DWG and DXF export settings changes

The options supported for DWG and DXF export have been expanded. A new base class

  • BaseExportOptions

supports all properties shared by DWG/DXF & DGN export tasks. New properties include:

  • BaseExportOptions.HideScopeBox
  • BaseExportOptions.HideReferencePlane
  • BaseExportOptions.HideUnreferenceViewTag

DGN export

The options supported for DGN export have changed to match the new implementation of DGN export based on DWG supporting DGN V8. The previously existing class

  • DGNExportOptions

thus offers many new properties inherited from the same base classes as DWGExportOptions.

The property

  • DGNExportOptions.TemplateFile

has been replaced with:

  • DGNExportOptions.SeedName

FBX Export

Three new options have been added:

  • FBXExportOptions.UseLevelsOfDetail - true to use levels of detail, false otherwise
  • FBXExportOptions.LevelsOfDetailValue - the value of the levels of detail
  • FBXExportOptions.WithoutBoundaryEdges - true to export without boundary edges, false otherwise

DividedPath

A DividedPath is an element supported in the massing environment that consists of a set of points distributed along a connected set of curves and edges. The points can be the result of a uniform distribution along the curves. The type of the distribution is determined by a selected 'layout'. The distance between the layout points depends on the curves, the layout, and layout specific settings. In addition, points can also be the result of intersecting the curves with other elements.

The class

  • DividedPath

exposes the interface for this element type. It permits creation of a new DividedPath from input curves and edges, as well as optionally, intersecting elements. It allows control over the layout type and parameters, as well as other miscellaneous settings.

Analysis Visualization Framework

The following additions have been made to support deformed shapes in analysis visualization display:

  • AnalysisDisplayStyleDeformedShapeTextLabelType class
  • AnalysisDisplayDeformedShapeSettings class

A new override to CreateAnalysisDisplayStyle accepts an input argument of AnalysisDisplayDeformedShapeSettings

Revit Link creation

The API now contains two creation methods for Revit links.

  • RevitLinkType.Create(Document, ModelPath, RevitLinkOptions) will create a new Revit link type and load the associated linked file into the document. This returns a RevitLinkLoadResult, which stores the ElementId of the newly-created RevitLinkType and contains any errors which occurred when trying to load the linked file (The RevitLinkLoadResultType enumeration contains the full list.)
  • RevitLinkInstance.Create(Document, ElementId) will create a new instance of an already-loaded RevitLinkType.

FilledRegion

The class

  • FilledRegion

has been extended to offer the ability to create Filled regions, to get the boundaries of the region, and to apply a linestyle to all boundary segments.

The class

  • FilledRegionType

has been added providing access to the visible properties of a filled region type.

Light API

The classes

  • LightType
  • LightFamily

have been added to offer the ability to get and set photometric data and all other lighting parameters from both family instances in project documents and all family types in family documents. The LightType and LightFamily classes expose the same data except for light shape and distribution types which are only available from the LightFamily class.

Some examples of lighting parameters exposed are;

  • initial color
  • initial intensity
  • loss factor
  • color filter
  • dimming color

Light Group API

The classes

  • LightGroupManager
  • LightGroup

have been added to offer the ability to manage light groups to allow control over which lights are used when rendering the scene.

The LightGroupManager class gives the user the ability to

  • create a new light group
  • delete an existing light group
  • turn on or off all the lights in a light group
  • turn on or off individual lights
  • set the dimmer value for individual lights

The LightGroup class gives the user the ability to

  • get the name of a light group
  • rename light group
  • add a light to a light group
  • remove a light from a light group

Light groups are used in rendering options to turn lights on or off when rendering.

ReferenceIntersector

The new class ReferenceIntersector allows ray-cast selection of elements, given a point and direction, similar to FindReferencesWithContextByDirection(), but with support for filtering the output based on element or reference type.
The enum FindReferenceTarget is used with ReferenceIntersector to filter selection of elements, meshes, edges, curves, and faces.

Key members of ReferenceIntersector

  • ReferenceIntersector(ElementId targetElementId, FindReferenceTarget targetType, View3d view3d) - constructor specifying a single element to search for in the intersection test.
  • ReferenceIntersector(ElementIdSet targetElementIds, FindReferenceTarget targetType, View3d view3d) - constructor specifying a set of ElementIds to search for in the intersection test.
  • ReferenceIntersector(ElementFilter filter, FindReferenceTarget targetType, View3d view3d) - constructor specifying an ElementFilter for the intersection test.
  • Find(XYZ origin, XYZ direction) - Finds all references intersecting the origin-direction ray given the selection criteria set up in the ReferenceIntersector constructor
  • FindNearest (XYZ origin, XYZ direction) - Finds the reference closest to the origin in the origin-direction ray given the selection criteria set up in the ReferenceIntersector constructor

Small enhancements & API interface changes

Elements & filtering

Element.PhaseCreated and Element.PhaseDemolished

These readonly properties have been obsoleted and replaced with read/write properties:

  • Element.CreatedPhaseId
  • Element.DemolishedPhaseId

The new method Element.AllowsPhases() indicates whether these phase id properties can be modified for any given element.

Phase filter

The new class

  • PhaseFilter

and related types support read/write and create access to phase filters.

SelectionFilterElement

The new class

  • SelectionFilterElement

provides access to a filter type which contains a selected set of element ids, rather than criteria based on parameters.

Ceiling, Floor and CeilingAndFloor

The newly exposed Ceiling class represents a ceiling in Revit. It inherits from CeilingAndFloor. The Floor class has been modified to also inherit from CeilingAndFloor.

Geometry & sketching

Split volumes

The new method:

  • SolidUtils.SplitVolumes()

takes a solid which includes multiple disjoint enclosed volumes, and returns newly allocated Solids representing each volume. If no splitting was necessary, a copy of the input Solid is returned.

Solid tessellation

The new method:

  • SolidUtils.TessellateSolidOrShell()

generates a single triangulated structure for the given input Solid (which could one or more fully closed volumes, or a shell of faces which do not form a closed volume). The function returns:

  • TriangulatedSolidOrShell

which allows access to the stored triangulated components and triangles.

Use the method:

  • FacetingUtils.ConvertTrianglesToQuads()

with a TriangulationInterface object constructed from the TessellateSolidOrShell results to convert pairs of adjacent, coplanar triangles into quadrilaterals.

Face.Triangulate()

A new overload to Face.Triangulate() accepts a level of detail as an argument. Levels of detail close to 0 (the minimum) will result in coarser triangulations than levels of detail close to 1 (the maximum).

Ellipse - axes

The new properties:

  • Ellipse.XDirection
  • Ellipse.YDirection

provide the unit vectors of the ellipse for the X and Y directions.

GeometryElement.GetBoundingBox()

This new method provides read access to the bounding box of a given geometry element.

ItemFactoryBase.NewAlignment()

This method can now align a line and a reference plane as well as all other geometry types from previous versions.

CylindricalHelix curve type

A new subclass of Curve has been introduced: CylindricalHelix. The class offers methods useful for reading and creating such curves.

In this release, CylindricalHelix curves are used only in specific applications in stairs and railings, and should not be used or encountered when accessing curves of other Revit elements and geometry.

CurveLoop as IEnumerable<Curve>

The members of a CurveLoop can now be traversed, as CurveLoop implements IEnumerable<Curve>.

CurveElement - center point reference

The new property:

  • CurveElement.CenterPointReference
    returns a reference to the center of a curve if that curve is one that has a center (e.g. arcs, circles, elliptical arcs or ellipses). This reference can be used for dimensioning to the center point.

ModelCurve.ChangeToReferenceLine

ModelCurve.ChangeToReferenceLine is now supported in all family types, not just conceptual modeling.

NewSketchPlane(Document, Reference)

This new overload for NewSketchPlane in the ItemFactoryBase class supports creation of a sketch plane directly from a Reference representing a planar face.

Detailing & Annotations

MultiSegmentGrid class

This class has been added to the API to support multi-segment grids.

Grid geometry

Element.Geometry now supports Grids and MultiSegmentGrids, including the ability to see gaps and extents applied to the grid lines to form different segments.

Diameter dimensions

Revit now supports Diameter dimensions. The DimensionShape enumeration contains a new Diameter member. And there is a new creation method for diameter dimensions:

  • FamilyItemFactory.NewDiameterDimension()

DimensionSegment overrides

There are several new properties on DimensionSegment to override text properties.

  • DimensionSegment.Prefix
  • DimensionSegment.Suffix
  • DimensionSegment.Above
  • DimensionSegment.Below
  • DimensionSegment.ValueOverride

These properties are also available on Dimension, for use with dimensions with just one segment.

Detail element draw order

The class

  • DetailElementOrderUtils

has been added providing the ability to affect the draw order of detail elements (including FilledRegions)

Families & content

SpatialElementCalculationPoint

This class provides access to the "Room or Space Calculation Point" seen in families. The Spatial Element Calculation Point is graphically showed as a location point marker with a "snake" line from the origin of the family. If the Spatial Element Calculation Point is turned on, this point will be used as a search point for room and space relations for all instances of this family. The API offer creation, read and modification options for this object type.

RPC content assets

The AssetType enum now contains a value "Content", which can be used to enumerate the loaded RPC content assets in the Revit session.

NewFamilyInstance validation

Some validation has been added to overloads of NewFamilyInstance(). This validation is intended to prevent use of the incorrect overload for a given family symbol input. For specific details on the exceptional conditions which
will be validated, consult the documentation.

Family.PlacementType

This new property provides information about the placement type for instances of the given family. PlacementType roughly maps to the overloads of NewFamilyInstance.

DataStorage element

The new DataStorage class represents an element which API applications can create logically organize different sets of ExtensibleStorage entities into separate elements. This allows an application to update one set of data in a local workshared project without locking other elements.

ApplicationInitialized event

The ControlledApplication object now supports an ApplicationInitialized event, which is called once the Revit application is fully initialized, after all external applications have been started and when the application is ready to work with documents.

ProgressChanged application event and ProgressChangedEventArgs

The application object now supports a ProgressChanged event and ProgressChangedEventsArgs object that returns progress bar data from time-consuming transactions.

  • ProgressChangedEventArgs
    • Caption – The name of the current transaction or subtransaction in progress
    • Stage – The type of progress event (Started, RangeChanged, PositionChanged, CaptionChanged, UserCancelled, Finished)
    • Position – The numerical index between zero and UpperRange showing the number of completed steps of the current transaction or subtransaction
    • UpperRange – The total number of steps in the current transaction or subtransaction
    • Cancel - Cancels the current transaction in progress, if possible.
    • Cancellable - indicates if the current transaction can be cancelled.

SiteLocation - PlaceName

The new property:

  • SiteLocation.PlaceName

provides the place name of the site location.

Application.DefaultProjectTemplate

Provides the full path to the default template file for new project documents

UnitType, DisplayUnit and FamilyParameter updates

Many new units have been added to UnitType, DisplayUnitType and ParameterType.

One UnitType was renamed: UT_TemperalExp was renamed to UT_ThermalExpansion.
The corresponding ParameterType value (TemperalExp) was also renamed to ThermalExpansion.

BasePoint and BASEPOINT_ANGLETON_PARAM "True North" Parameter

The parameter to return the "True North" angle parameter "BASEPOINT_ANGLETON_PARAM" on the BasePoint object is now a double instead of a string.

Journaling of Add-in user interface

Revit now activates a tool to collect and journal certain actions which take place in the user interface provided by an add-in. The tool supports actions in both WPF and Windows Forms dialogs.
Some actions and some components may not be fully recorded.

This capability is useful to Autodesk in the event that a journal can be supplied from a Revit user indicating the presence of a software problem. Replay of add-in UI via journals is not supported.